Toolkit Pro: Toolkit Pro Overview

Toolkit Pro v24.3.0
for Visual C++ ( MFC )
Toolkit Pro Overview

API Documentation for Codejock Toolkit Pro class library.

Create professional applications that incorporate a full set of highly customizable user interface components including Visual Studio style docking panes and Office style ribbons, toolbars and menus to give your application a modern appearance.

ToolkitPro overview image

Toolkit Pro Class Library

Toolkit Pro for Visual C++ provides Windows developers with a robust set of components combining our most popular components: Calendar, Chart, Command Bars, Controls, Docking Pane, Gauge, Property Grid, Grid Control, Shortcut Bar, Skin Framework, Syntax Edit and Task Panel into a single library.

Calendar

Calendar provides Windows developers with Outlook style calendar and date selection components. Easily create a calendar that can manage appointments arranged by day, week, work week, or month.

Chart

Chart is easy to use and can be added to your project with only a few lines of code. All charts are fully customizable allowing you to create virtually any charting style.

Command Bars

Command Bars provides Windows developers with comprehensive, fully customizable menus, toolbars, ribbon and MDI tab windows to give your application a professional and modern interface.

Controls

Controls provides Windows developers with several ready-to-use components that have been thoroughly designed and tested.

Docking Pane

Docking Pane allows you to create fully customizable docking panes with a professional and modern interface. Windows developers can easily create tear off tabs and auto hide windows that allow for a more manageable application workspace.

Gauge

Gauge control allows for the creation and extension of multi -dimensional gauges where almost every visual element can be configured or animated to meet the most demanding business needs including analogue, digital and state gauge styles.

Property Grid

Property Grid provides Windows developers with a comprehensive, fully customizable property grid giving your application a professional and modern interface. Windows developers can easily create a hierarchical list of editable properties and represent any data type or sub-item.

Grid Control

Grid control provides Windows developers with a sophisticated Outlook style Grid. Windows developers can easily create, group, and sort data in a flat or hierarchical format.

Shortcut Bar

Shortcut Bar provides Windows developers with a sophisticated Office style Shortcut Bar navigation panel similar to the navigation panel seen in Microsoft® Outlook.

Skin Framework

Skin Framework provides Windows developers with a highly sophisticated application skinning framework technology that was developed with Windows Themes (Visual Styles) in mind. Achieving a completely themed application can be accomplished with only a few lines of code.

Syntax Edit

Syntax Edit provides your users with a highly sophisticated text editor control that supports syntax colorization and many advanced features.

Task Panel

Task Panel provides Windows developers with a sophisticated Office Task Panel similar to what is seen in Microsoft® Office and Windows Explorer. The TaskPanel can even be used as a Visual Studio style tool box.

Generated by doxygen 1.12.0


Toolkit Pro: Gauge Overview

Gauge Overview

The Gauge Control offers a versatile means to represent diverse numerical and state data, with flexibility, dynamism, and extensive customization options. Built entirely in Markup, it leverages Markup's rendering capabilities and adaptability. Codejock Gauges are fully DPI-responsive, maintaining drawing quality while scaled to any size. The actual gauge implementation is achieved through Codejock's proprietary JavaScript extension for XAML, simplifying the entry level for gauge developers. Furthermore, gauge configurations (traits) can be stored in either JSON format or dynamic JavaScript code that evaluates JSON configuration data.

Given the varied nature of data users may wish to represent on a gauge, along with the customization needs, our approach emphasizes remarkable flexibility in configuring gauges. This means a single implementation of a gauge can yield countless visual variations and behaviors by simply adjusting a traits configuration file without any code alterations. While Codejock offers basic pre-designed gauges, users can tailor more sophisticated ones to their exact requirements by tweaking the gauge traits configuration file. In addition, Codejock offers consulting and development services for complex gauges, contact us for details.

The aim of this article is to furnish comprehensive guidance on modifying the Gauge Control traits file.

Architecture

The following is a simplified overview of the Gauge architecture, outlining its fundamental components:

Let's break down each level of the Gauge architecture:

  • Gauge Control: At the highest level is the Gauge control itself. This control is placed on a window within the application interface. It offers methods and properties for loading and accessing the actual representation of the gauge, as well as its configuration, reflected data, and behavior.
  • Gauge Type: The next level of abstraction is the gauge type. Each Gauge control can operate on only one gauge type at a time, although the implementation doesn't limit the number of possible gauge types. A gauge type, by itself, doesn't perform much action and can be considered as a Model for a gauge. It primarily provides access to common properties specific to a particular abstract gauge type and ensures that any loaded gauge is compatible with its underlying type. Currently, the implementation provides only two gauge types:
    • Meter: Designed to represent numerical data within a certain range and dimensions. Its key properties include the displayed value, minimum and maximum possible values. Examples of Meter gauge types range from analogue or digital thermometers to speedometers, barometers, and more.
    • State: This type represents a finite number of states, with a basic property being a numerical identifier for the current state. Examples include light indicators for on/off states, battery or coverage level indicators, toggle switches, semaphores, and check marks.
  • Gauge Style: Below the gauge types lie the core gauge implementation that defines a generic gauge style. Each gauge type can load a single gauge style at a time, with no limitation on the number of possible gauges for a particular style. A style implementation resides in a separate XAML file, declaring all graphical primitives, while an embedded scripting block defines the gauge's behavior and appearance based on the provided configuration traits.
  • Gauge Traits: Finally, the lowest level entails configuration traits. This layer comprises common traits utilized by all gauges, alongside unique traits specific to each gauge style for appearance and behavior configuration. Traits can be stored as fixed data in JSON format or within a JavaScript function definition signature, enabling dynamic trait evaluation. This flexibility allows for configurable traits, accommodating scenarios where resource paths are determined only upon gauge loading.

Each of these layers will be expounded upon in further detail within this article.

Gauge Loading

To initiate gauge loading, the process begins with loading its traits and style. Once this step is successfully completed, the gauge becomes operable through its type object, which is accessible via the Gauge control object.

  1. Loading gauge traits from a JS/JSON file

Toolkit Pro:

IStreamPtr pTraitsStream;
VERIFY(SUCCEEDED(XTPCreateReadOnlyFileStream(strGaugeDir + _T("\\State\\Image\\MultiState\\traits.js"), &pTraitsStream)));

Alternatively the following convenience functions can be used for loading traits of markup streams:

XTPCreateFileStream, XTPCreateReadOnlyResourceStream, XTPCreateReadOnlyStreamOnUri

Suite Pro (VB):

Dim Traits As New GaugeTraits
Traits.Load GaugeDir + "\State\Image\MultiState\traits.js"
  1. (only if applicable) Loading initialization traits from a JSON file

Some gauges require additional initialization traits to be passed to the loading procedure. The need to perform this steps is indicated by the presence of init_traits.json file in a gauge resource directory. If the initialization traits are provided, they get combined with evaluated traits and the the initialization traits values are preferred over the evaluated values if name collisions are detected.

Toolkit Pro:

CString strTraitsArgs;
VERIFy(XTPLoadFileText(strGaugeDir + _T("\\State\\Image\\MultiState\\Battery\\init_traits.json"), strTraitsArgs));

Suite Pro (VB):

Traits.TraitsArgument = ReadFileText(GaugeDir + "\Gauges\State\Image\MultiState\Battery\init_traits.json")
  1. Creating a traits collection object from the loaded data stream and specifying a resource path in the file system

ToolitPro:

CXTPGaugeTraits traits(*pTraitsStream, strTraitsArgs);
traits.SetResourcePath(strGaugeDir + _T("\\State\\Image\\MultiState\\Battery"));

Suite Pro (VB):

Traits.ResourcePath = GaugeDir + "\State\Image\MultiState\Battery"

When a gauge utilizes configurable images, typically the images need to be loaded from specific locations. Since the exact image resource location is often not known in advance, the traits only specify the image file names and utilize the provided resource path to construct the actual file locations. It's important to note that resource file locations aren't limited to the file system; they can also be loaded from a resource module. This approach enables the consolidation of a library of gauges, along with their resources and related scripts, within a single resource DLL. In such cases, the resource location must be specified as a resource module:

Toolkit Pro:

HMODULE hGaugeLib = ...;
CXTPGaugeTraits traits(*pTraitsStream, strTraitsArgs);
traits.SetResourceModule(hGaugeLib);

Suite Pro (VB):

Traits.ResourceModule = ModuleHandle
  1. (optional) Traits customization

In certain cases it may be required to override known trait values before loading a gauge as some traits may get appliled only once upon gauge loading and cannot be changed at runtime. Each of such value can be customized using CXTPGaugeTraits::SetCustomTrait method with a full JSON object path specified in JavaScript syntax and a new value.

Toolkit Pro:

traits.SetCustomTrait(_T("transparent"), COleVariant(VARIANT_TRUE, VT_BOOL));
traits.SetCustomTrait(_T("backgroundColor"), L"#ff00ff");
traits.SetCustomTrait(_T("toggleBySpaceBar"), COleVariant(VARIANT_TRUE, VT_FALSE));

Suite Pro (VB):

Traits.SetCustomTrait "transparent", True
Traits.SetCustomTrait "backgroundColor", "#ff00ff"
Traits.SetCustomTrait "toggleBySpaceBar", False
  1. Loading gauge style
IStreamPtr pGaugeStream;
VERIFY(SUCCEEDED(XTPCreateReadOnlyFileStream(strGaugeDir + _T("\\State\\Image\\style.xaml"), &pGaugeStream)));
  1. Loading the gauge into the Gauge control

Toolkit Pro:

CXTPGaugeMeterType* pStateGauge = m_wndGauge.LoadStateType(*pGaugeStream, traits);
VERIFY(NULL != pStateGauge);

For this particular example CXTPGaugeCtrl::LoadStateType is used because a Battery is of the State type. If it was a gauge of the Meter type then the CXTPGaugeCtrl::LoadMeterType would have to be used instead.

Suite Pro (VB):

If ctlGauge.LoadStateType(GaugeDir + "\State\Image\style.xaml", Traits) Is Nothing Then
' Unable to load
End If
  1. Updating gauge state via its type specific object:

Toolkit Pro:

pStateGauge->SetState(1);
pStateGauge->Update();

Suite Pro (VB):

With ctlGauge.Type.State
.State = 1
.Update
End With

Some gauge traits are used only once when a gauge is being loaded, so changing their value later has no effect, for such traits consider traits customization described earlier. And changing those traits that can be updated at runtime should follow a call of the Update method for the changes to take effect.

Gauge Style Markup

All gauge markup script must adhere to a standardized structure at the top level and include a defined script entry. Below is an empty template for a Meter gauge. Templates for gauges of different types will share the same structure, with only the type name and common default traits specified in the GaugeLib.init call differing. It's essential to keep all named markup objects with their pre-defined attributes unchanged across all gauges. While the detailed walkthrough of the actual gauge implementation is omitted in this article, a shallow overview is provided to enhance understanding of its structure.

<Page
xmlns='http://schemas.microsoft.com/winfx/2006/xaml/presentation'
xmlns:x='http://schemas.microsoft.com/winfx/2006/xaml'
xmlns:xtp='urn:schemas-codejock-com:xaml-extensions'>
<Viewbox Stretch='Uniform'>
<Canvas Name='Canvas' HorizontalAlignment='Center' VerticalAlignment='Center' Background='{x:Static SystemColors.WindowBrush}' Width='1000' Height='1000'>
<Image Name='Back' Canvas.Left='0' Canvas.Top='0' Width='1000' Height='1000'/>
<Image Name='BackOverlay' Canvas.Left='0' Canvas.Top='0' Width='1000' Height='1000'/>
<!-- Gauge specific markup goes here -->
<Image Name='FrontOverlay' Canvas.Left='0' Canvas.Top='0' Width='1000' Height='1000'/>
</Canvas>
<xtp:Script Language='JScript' Requires='lib:runtime, lib:gauge'>
// <![CDATA[
function onInit() {
// TODO: required gauge initialization handler
}
function onUpdate() {
// TODO: required gauge update handler
}
function onInput(message, wParam, lParam) {
// TODO: optional gauge input handler
}
function onShutdown() {
// TODO: optional gauge shutdown handler
}
GaugeLib.init({
init: onInit, // required
update: onUpdate, // required
input: onInput, // optional
shutdown: onShutdown, // optional
traits: { // required
type: 'Meter',
// Meter specific common default traits
min: 0,
max: 100,
current: 0
}
});
//]]>
</xtp:Script>
</Viewbox>
</Page>

Gauge Traits

As mentioned earlier, gauge traits can be represented either in JSON format or as a JavaScript function that returns an evaluated traits object. Additionally, there are several common traits that are not specific to any particular gauge. These include:

  1. backgroundColor: An optional string defining the background color value in XAML-compatible format (Red, White, Blue, etc.), or an RGB color in HTML format (e.g., #AABBCC). The default color value uses the system-defined window color.
  2. transparent: An optional boolean value specifying whether the gauge has a transparent background or not. Further explanation is provided below in this article. The default value is false. See Gauge transparency for more details.
  3. background: The only required common trait specifying an image to be displayed on the gauge background. Its value can be either a full image path or an image traits object. The format of an image traits object is described further in this article.
  4. backgroundOverlay: An optional image path or image traits object defining another image to be displayed on top of the background image.
  5. foregroundOverlay: An optional image path or image traits object defining another image to be displayed on top of all gauge elements. Combining background and overlay images allows for advanced effects such as glass, etc.
  6. viewboxStretch: An optional viewbox stretch mode constant defining how the XAML viewbox is stretched when the Gauge control size is changed. It can have one of the following values: None, Fill, Uniform, UniformToFill.
  1. actions: An optional JavaScript object that exposes a set of the traits specific actions to be invoked from the client code using CXTPGaugeBaseType::InvokeAction method call. If init action is specified, it will be called automatically upon gauge initialization as a function of type function(gauge) {}.

A simple JSON trait file for the Meter type could resemble the following:

{
"backgroundColor" : "Brown",
"background" : "file://C:\Data\MyGauge\background.svg",
"foregroundOverlay" : "file://C:\Data\MyGauge\foreground-overlay.svg",
"min" : 0,
"max" : 100,
"current" : 50
}

Certainly, hardcoded image locations are often not acceptable. Here's an example of how to define the traits file in JavaScript, allowing for the evaluation of image locations using the resource location information provided during traits loading in an application:

function (ctx) {
var rt = ctx.libs['runtime'];
return {
backgroundColor : 'Brown',
background : rt.resource('background.svg'),
foregroundOverlay : rt.resource('foreground-overlay.svg'),
min : 0,
max : 100,
current : 50
};
}

The traits file will begin with the keyword function and contain the implementation of a single JavaScript function that returns an evaluated traits object. This function accepts only one argument, named ctx, which is an object structured as follows:

{
arg: [object|null],
libs: {
runtime: [object]
}
}

The arg object value is an optional object that can be specified in the client code during gauge traits collection initialization. Its sole purpose is to facilitate data exchange between the client code and traits execution for further customization.

Traits evaluation can be simplified by leveraging the capabilities of JavaScript and the built-in gauge runtime library. For example, trait object templates can be utilized to define all common properties once and then derive a template object:

function (ctx) {
var rt = ctx.libs['runtime'];
var templates = {
labels: {
large: {
cx: 2,
cy: .2,
rx: 1,
ry: .8,
foreground: '#282828',
background: null,
fontSize: 40,
fontFamily: 'Arial',
format: '%i'
},
small: {
cx: 2,
cy: .2,
rx: 1,
ry: .8,
foreground: "#282828",
background: null,
fontSize: 30,
fontFamily: 'Arial',
format: '%i'
}
}
};
return {
backgroundColor : 'Brown',
background : rt.resource('background.svg'),
foregroundOverlay : rt.resource('foreground-overlay.svg'),
min : 0,
max : 100,
current : 50,
text1 : rt.extend(templates.labels.large, {
cx: 2,
cy: .2,
rx: 1,
ry: .8,
format: '-%i'
}),
text2 : rt.extend(templates.labels.small, {
cx: 2,
cy: .2,
rx: 1,
ry: .8,
format: 'Value: %i'
})
};
}

Coordinate System

To ensure smooth scaling of the gauge elements without binding to fixed coordinates, the gauge coordinate system utilizes ranges [-1..1] across the Y and X axes. These axes are directed downward and to the right respectively, with the center point (0,0) positioned at the physical gauge center. Therefore, the top left gauge corner has coordinates (-1, -1), and the bottom right corner has coordinates (1, 1). All position values, absolute and relative offsets, element sizes, and point coordinates must be specified in this coordinate system in the trait files.

Image Traits

  1. An image can be specified in two different ways in a traits file:
{
icon : rt.resource('icon.svg')
}
  1. Using a JavaScript object that describes image properties such as size, relative offset, opacity, etc.:
{
icon: {
// Image traits
src : rt.resource('icon.svg'),
opacity : 0.5,
// Location traits
x : 0.5,
y : 0.5,
cx : 0.2,
cy : 0.2,
rx : 0.01,
ry : 0.03,
angle : 45,
crx : 0.01,
cry : 0.01
}
}

The numerical attributes of the image traits object can be animated (see Animations and transitions). The image traits object consists of the following properties:

  • src: A required string that identifies image location to be used as a value of the Image.Source XAML attribute.
  • opacity: An image opacity level in the range [0..1], where 0 makes the image fully transparent and 1 makes it fully opaque. The default value is 1. The location traits properties format is explained later in the article.

Font Traits

The font traits object describes text formatting options, for example:

{
// Font traits
fontSize: 10,
fontFamily: 'Arial',
foreground: 'Red',
background: 'Black'
// Location traits
x : 0.5,
y : 0.5,
cx : 0.2,
cy : 0.2,
rx : 0.01,
ry : 0.03,
angle : 45,
crx : 0.01,
cry : 0.01
}

The location traits properties format is described below.

Location Traits

The location traits are not a separate object by themselves, but rather a subset of common traits that specify element location. They are particularly used in image and text traits objects, and their properties have the following meanings:

  • x and y: The absolute coordinates of the top-left corner of the element. The default value for both is 0.
  • cx and cy: The displayed width and height of the element. If not specified, the actual element size is used.
  • rx and ry: The relative offset of the assumed top-left corner of the element from the real top-left corner coordinates. For example, if rx is set, then for all calculations where the element's top-left position is needed, the value will be computed as x + rx, while the element itself will remain at position (x, y). These are not used if not specified.
  • angle: The value of the element's rotation angle in degrees relative to its upright position. If specified, the element is rotated clockwise around its computed rotation center. The default value of 0 leaves the element in its default orientation.
  • crx and cry: the relative offset of the element's rotation center. It is always computed from the assumed top-left corner coordinates. If not specified, then the top-left corner serves as the rotation center. For example, if element traits are {..., cx: 1, cy: 1, crx: 0.5, cry: 0.5, angle: 45 }, then the element will be rotated exactly around its center instead of the top-left corner.

The location traits object can also include properties of the view traits object described below.

View Traits

The view traits are a subset of the properties that configure a view of an element or a set of elements. These properties can be included along with the location traits, or they can be part of a parent object or any other object that will be used as a source of view traits for a particular gauge implementation:

{
// Top level traits
background: rt.resource('background.svg'),
min: 0,
max: 100,
current: 0,
// Common view traits for images below
zoom: 0.5,
offset: { x: 0.5, y: 0.5 },
icon1: rt.extend(templates.icon, {
src: rt.resource('icon1.svg')
}),
icon2: rt.extend(templates.icon, {
src: rt.resource('icon2.svg')
}),
icon3: rt.extend(templates.icon, {
src: rt.resource('icon3.svg'),
// View traits specific for Icon3
zoom: 1,
offset: { x: -1, y: -1 },
})
}

The view traits properties include:

  • zoom: A multiplier value that is applied to all related location and size metrics of applicable elements.
  • offset.x, offset.y: The absolute offset values that get added to x and y location properties of applicable elements.

Animations and Transitions

Location, image, and text traits can be animated using a specified effect and animation time. Animation involves sequentially changing the specified numeric properties from their start to their stop values within the specified time frame, using the specified animation effect. A special traits object format is required to enable traits animation. For example, a static image can be described with the following image traits object:

{
src: rt.resource('state0.svg'),
cx: 1,
cy: 1,
x: -.5,
y: 0
}

To achieve the desired effect of smoothly transitioning the image along the X-axis from left to right over half a second while simultaneously fading it in, an easing effect needs to be applied for a seamless transition. This can be accomplished by modifying the image traits object as follows:

{
transition: {
effect: 'easeInBounce',
time: 500,
res: 25
},
start: {
src: rt.resource('state0.svg'),
cx: 1,
cey: 1,
x: -.5,
y: 0,
opacity: 0
},
stop: {
x: -.5,
opacity: 1
}
},

The above transition is applied only for showing an image. When showing and hiding require different transition effects, each even will need a separate declaration of its transition configuration:

{
show: {
transition: {
effect: 'easeInSine',
time: 100,
res: 25
},
start: {
y: -1,
opacity: 0
},
stop: {
opacity: 1
}
},
hide: {
transition: {
effect: 'easeOutSine',
time: 100,
res: 25
},
start: {
y: -1,
opacity: 1
},
stop: {
opacity: 0
}
}

The transition object describes transition configuration:

  • time: Specifies animation duration represented in milliseconds
  • res: Specified animation resolution, i.e. the number of milliseconds after which the animated properties get updated.
  • effect: A required string that specified the easing effect to be used for this transition. The list of supported values is provided below, and detailed information along with preview of every easing method can be found at https://gizma.com/easing:
    • easeInSine
    • easeOutSine
    • easeInOutSine
    • easeInQuad
    • easeOutQuad
    • easeInOutQuad
    • easeInCubic
    • easeOutCubic
    • easeInOutCubic
    • easeInQuart
    • easeOutQuart
    • easeInOutQuart
    • easeInQuint
    • easeOutQuint
    • easeInOutQuint
    • easeInExpo
    • easeOutExpo
    • easeInOutExpo
    • easeInCirc
    • easeOutCirc
    • easeInOutCirc
    • easeInBack
    • easeOutBack
    • easeInOutBack
    • easeInElastic
    • easeOutElastic
    • easeInOutElastic
    • easeInBounce
    • easeOutBounce
    • easeInOutBounce

The start object describes the initial state of the animated traits. In this example opacity: 0 is added to the initial image traits object to make image fully transparent when animation starts.

The stop object describes the final state of the animated traits. In this example only animation of x and opacity properties is specified, their values will get updated during the animation execution, and other properties will remain intact.

The show object contains transition description for showing an object. And the hide object respectively contains transition description for hiding an object.

Gauge Transparency

In the preceding section of this article, we discussed how transparency in gauges can be enabled by setting the backgroundColor: ... and transparent: true common traits. Once transparency is enabled, the specified background color serves as an alpha color key value. This means that any pixels matching that color value will become invisible. It's crucial to carefully select a background color that is entirely unique and not used in any images within the gauge. Additionally, this color should not result from semi-transparent image overlaps or animated color/opacity transitions. Otherwise, the gauge will display visual "holes" wherever that color appears.

Furthermore, it's important to note that due to the native implementation of child control transparency in the Windows operating system, certain application manifest entries need to be added.

<compatibility xmlns="urn:schemas-microsoft-com:compatibility.v1">
<application>
<!-- Windows 7 and Windows Server 2008 R2 -->
<supportedOS Id="{35138b9a-5d96-4fbd-8e2d-a2440225f93a}" />
<!-- Windows Windows 8 and Windows Server 2012 -->
<supportedOS Id="{4a2f28e3-53b9-4441-ba9c-d69d4a4a6e38}" />
<!-- Windows 8.1 and Windows Server 2012 R2 -->
<supportedOS Id="{1f676c76-80e1-4239-95bb-83d0f6d0da78}" />
<!-- Windows 10, Windows 11, Windows Server 2016, Windows Server 2019 and Windows Server 2022 -->
<supportedOS Id="{8e0f7a12-bfb3-4fe8-b9a5-48fd50a15a9a}" />
</application>
</compatibility>

This also implies that gauge control transparency is supported only starting with Windows 7.

Meter Gauge Type

As mentioned before, the Meter gauge type is designed to represent numerical data within a certain range and dimensions. Its key properties include the displayed value, minimum and maximum possible values. Examples of Meter gauge types range from analogue or digital thermometers to speedometers, barometers, and more.

The Meter gauge type expects four required traits to be provided:

  1. current: The global currently displayed value. It must be in range determined by the min and max traits.
  2. min: The global minimum allowed displayed value.
  3. max: The global maximum allowed displayed value.
  4. dimensions: The array of traits object specific to each dimension.

When current, min and max are defined at the root level they defined a common default values for all dimensions that don't override those values. Once defined in a particular dimension they override the default common value. The dimensions array must be defined in the root traits object only.

For example, it is required to create a odometer gauge to represent the speed value in both metric and imperial unints on different scales, i.e. it has to have 2 scales with 2 pointers. This kind of Meter gauge will need to have 2 dimensions. Each dimension will have a common min value equal to 0 as speed cannot go below it, but the max and current values will be different. Regardless of the actual gauge implementation and its appearance, at the core of such a gauge will be the followg in traits structure:

{
min: 0, // common for kph/mph
dimensions: [
// Metric scale (kph)
{
max: 200,
current: 0
},
// Imperial scale (mph)
{
max: 124,
current: 0
}
]
}

All other traits are specific to each particular gauge implementation that are described below.

The Scale Meter gauge style

Scale Meter Gauge

The Scale Meter gauge is designed to show round or arc scales with pointers, and provides the following features:

  1. There can be up to 5 scales
  2. Each scale's center position and dimensions can be configured
  3. Each scale has one pointer, a number of ticks, up to 2 optional icons, up to 2 optional labels (hints)
  4. A scale can be directed either clockwise or counter clockwise
  5. The start angle and a span of each can be configured
  6. The total number of ticks for each scale can be split in groups to have each tick group starting with a large tick
  7. Each small and large tick is an image object
  8. Each tick can have an associated label
  9. An individual tick appearance can be customized
  10. Each pointer is an image object
  11. Each scale icon if specified is an image object
  12. Each scale hint if specified is a font object
  13. A cap image can be displayed on top of all displayed scaled

The traits schema for the Scale Meter gauge:

{
/* Common traits */
...
/* Meter type traits */
...
// Defines the cap image
cap: { /* Image, View and Location traits */ },
dimensions: [
// Defines a particular scale
{
/* Optional Meter type traits to override Meter type traits at the top level */
...
// Defines direction orientation
clockwise: true | false,
// Defines scale span and angle
angle: {
// Defines where the scale starts
start: /* A numeric degree value in range 0..360 */,
// Defines how long the scale spans
span: /* A numeric degree value in range 0..360 */
},
// Defines scale pointer image
pointer: { /* Image, View and Location traits */ },
// Defines the scale itself
scale: {
// Defines scale ticks
ticks: {
// Defines the total number of ticks
count: /* A numeric number */,
// Defines how many groups the ticks are split in
split: /* A numeric number */,
// Defines a small tick image
small: { /* Image, View and Location traits */ },
// Defines a large tick image
large: { /* Image, View and Location traits */ }
// An optional definition of individual tick apperance.
// Each array element corresponds to a tick with with the same index.
// Only not null elements get processed.
custom: [
{ /* Image, View and Location traits */ },
...
]
},
// Defines tick labels
labels: {
// Defines label format for large ticks
large: {
/* Font, View and Location traits */
format: /* An sprintf-like format string where the only placeholder will receive the current value */
},
// Defines label format for small ticks
small: {
/* Font, View and Location traits */
format: /* An sprintf-like format string where the only placeholder will receive the current value */
}
}
},
// Defines the first optional hint label
hint1: {
/* Font, View and Location traits */
format: /* Label text */
},
// Defines the second optional hint label
hint2: {
/* Font, View and Location traits */
format: /* Label text */
},
// Defines the first optional scale icon
icon1: { /* Image, View and Location traits */ },
// Defines the second optional scale icon
icon2: { /* Image, View and Location traits */ }
},
...
]
}

The following below example shows a built in Circular Quarter Top-Left gauge traits:

function(ctx) {
var rt = ctx.libs.runtime;
var gaugeMin = 0;
var gaugeMax = 10;
var gaugePos = 0;
var gaugeWidth = 1000;
var gaugeHeight = 1000;
var gaugeType = 0; // Meter
return {
backgroundColor: '#ababab',
transparent: true,
min: gaugeMin,
max: gaugeMax,
current: gaugePos,
background: rt.resource('background.svg'),
cap: {
src: rt.resource('cap.svg'),
cx: .25,
cy: .25,
rx: -.58,
ry: -.58
},
dimensions: [
// Dim 0
{
clockwise: true,
angle: {
start: 0,
span: 90
},
pointer: {
src: rt.resource('pointer.svg'),
x: .7,
y: .71,
cx: .2,
cy: 1.5,
rx: .068,
ry: 1.5,
crx: 0,
cry: 1.2
},
scale: {
ticks: {
count: 51,
split: 10,
small: {
src: rt.resource('tick.small.svg'),
x: .7,
y: .7,
cx: .01,
cy: .05,
rx: .001,
ry: 1.2
},
large: {
src: rt.resource('tick.large.svg'),
x: .7,
y: .7,
cx: .02,
cy: .13,
rx: .001,
ry: 1.2
}
},
labels: {
large: {
x: .7,
y: .7,
cx: 10,
cy: .2,
rx: 5,
ry: 1.375,
foreground: '#3d5a80',
background: null,
fontSize: 60,
fontFamily: 'Arial',
format: '%i'
}
}
},
hint1 : {
format: 'CODEJOCK SOFTWARE',
x: .26,
y: .9,
cx: 2,
cy: .2,
foreground: '#c0c0c0',
background: null,
fontSize: 30,
fontFamily: 'Arial'
}
}
]
}
}

The Digital Meter gauge style

Digital Meter Gauge

The Digital Meter gauge is designed to show numeric data on a digital-like screen. It provides the following features:

  1. It can have up to 5 indepdenent screens
  2. Each screen can have up to 20 digits
  3. Each screen can have its skew configured
  4. Each screen can have up to 2 icons and up to 2 labels
  5. Height, margins, digit thickness and position of each screen are configurable
  6. Thousands groupping can be enabled for each screen
  7. Active and inactive digit parts appearance are configurable
  8. Optional digit background and overlay images can be speicified

The traits schema for the Digital Meter gauge:

{
/* Common traits */
...
/* Meter type traits */
...
// Optionally defines a common screen height to be used by all screens by default
height: /* A numeric value in gauge coordinate system */,
// Optionally defines a common digits margins to be used by all screens by default
margins: {
// Defines a horizontal margin value for a digit parts
x: /* A numeric value */,
// Defines a vertical margin value for a digit parts
y: /* A numeric value */
},
// Optionally defines a common digit parts thickness for all screens to be used by default
thickness: /* A numeric value */,
// Optionally defines a maximum number of digits per screen for all screens to be used by default
maxDigits: /* A numeric value in range 1..20 */
// Optionally enable thousand groupping for all screens to be used by default
groupThousands: true | false,
// Optionally defines a skew angle for all screens to be used by default
skew: // A numeric value
// Optionally defines visual appearance of active digits parts for all screens to be used by default
active: {
// Defines an element fill color
fill: /* A string value of an RGB color in XAML format */,
// Defines an element stroke color
stroke: /* A string value of an RGB color in XAML format */,
// Defines an element stroke size
strokeSize: /* A numeric value */
},
// Optionally defines visual appearance of inactive digits parts for all screens to be used by default
inactive: {
// Defines an element fill color
fill: /* A string value of an RGB color in XAML format */,
// Defines an element stroke color
stroke: /* A string value of an RGB color in XAML format */,
// Defines an element stroke size
strokeSize: /* A numeric value */
},
// Optionally defines a digit background image for all screens to be used by default
digitBackground: /* Image, View and Location traits */,
// Optionally defines a digit overlay image for all screens to be used by default
digitOverlay: /* Image, View and Location traits */,
// Define gauge specific optional icons (not used by the screens)
icon1: /* Image, View and Location traits */,
icon2: /* Image, View and Location traits */,
// Define gauge specific optional labels (not used by the screens)
label1: {
/* Font, View and Location traits */
...,
format: /* Label text */
},
label2: {
/* Font, View and Location traits */
...,
format: /* Label text */
},
// Defines up to 5 digital screens
dimensions: [
{
/* Optional Meter type traits to override Meter type traits at the top level */
...
// Defines screen position in gauge coordinates
position: {
x: /* Numeric value */,
y: /* Numeric value */
},
// Define screen specific optional icons
icon1: /* Image, View and Location traits */,
icon2: /* Image, View and Location traits */,
// Define screen specific optional labels
label1: {
/* Font, View and Location traits */
...,
format: /* Label text */
},
label2: {
/* Font, View and Location traits */
...,
format: /* Label text */
},
// Top level traits can be overriden for this particular screen:
height: ...,
margins: ...,
thickness: ...,
maxDigits: ...,
groupThousands: ...,
skew: ...,
active: ...,
inactive: ...,
digitBackground: ...,
digitOverlay: ...
},
...
]
}

The following below example shows the built in Clock-HHMM gauge traits with explanation comments (reduced source):

function(ctx) {
// Getting the Gauge Runtime library reference.
var rt = ctx.libs.runtime;
// Computing basic measurements.
var clockHeight = .3;
var dcx = clockHeight / 2;
var pointSize = clockHeight / 8;
// Defining a point template object for preventing code duplicates.
var templates = {
point: {
src: rt.resource('point.svg'),
cx: pointSize,
cy: pointSize
}
};
// Building the result traits object.
return {
// Defining gauge actions.
actions: (function() {
return {
init: ...,
setTime: ...,
runClock: ...,
stopClock: ...,
setHourFormat: ...,
showLeadingZeros: ...
};
})(),
viewboxStretch: 'None',
current: 0,
background: rt.resource('background.svg'),
height: clockHeight,
margins: { x: 7, y: 7 },
thickness: 10,
maxDigits: 2,
groupThousands: true,
skew: -5,
active: {
fill: '#a0c0ff',
stroke: 'Orange',
strokeSize: 2
},
inactive: {
fill: '#777777',
stroke: '#666666',
strokeSize: 2
},
dimensions: [
// Dim 0: Hours
{
position: { x: -dcx * 3, y: -dcx },
min: 0,
max: 23
},
// Dim 1: Minutes
{
icon1: rt.extend(templates.point, {
x: -pointSize / 2,
y: -dcx + dcx / 2
}),
icon2: rt.extend(templates.point, {
x: -pointSize / 2,
y: dcx - dcx / 2
}),
position: { x: dcx / 2, y: -dcx },
min: 0,
max: 59
}
]
}
}

State Gauge Type

The State gauge type can be used to represent a finite number of possible states, and unlike the passive Meter type, the State type provides interaction with a user and allows changing states using a mouse or a keyboard. This ability makes opens a lots of oportunities for implementing gauge based state driven visual controls.

The State type requires these required triats to be provided:

  1. stateCount: The required number of possible states.
  2. state: The required current active state in range [0 .. stateCount)
  3. states: The required array of image or animation objects where the index of each element corresponds to a state index.

The Image State gauge style

The Image style assumes that each state can be represented via one image. Changing a state causes a previosly active state image to be hidden if hideInactive traits is set to true, and an image associated with the next state to be shown. Image showing and hiding can be animated. State changing can be triggered in the code or as a result of user input.

The following traits can be used for controlling the Image gauge:

  1. hideInactive: An optional boolean value that causes images of inactive states to be hidden if its value is true, or kept shown if it's value is false.
  2. toggleByMouse: An optional boolean value that allows toggling to the next state by clicking a gauge with a right mouse button.
  3. toggleBySpaceBar: An optional boolean value that allows toggling to the next state by clicking a space bar on a keyboard.

By default this style changes states from 0 to stateCount - 1 and then starts over at 0. If another state changing logic is required then then nextState action must be defined in triats as follows:

{
actions: {
nextState: function(gauge) {
var oldState = gauge.traits.state;
var newState = ...; // TODO: Compute the next state based on oldState value.
return newState;
}
}
}

The following below is an example of a On/Off gauge with a brief explanation of its basic blocks:

function(ctx) {
// Getting the Gauge Runtime library reference.
var rt = ctx.libs.runtime;
// Defining a transition template object for preventing code duplicates.
var transitionTemplate = {
effect: 'easeInSine',
time: 100,
res: 25
};
// Defining a state template object with common properties specified for preventing code duplicates.
var stateTemplate = {
show: {
transition: transitionTemplate,
start: {
y: -.7,
opacity: 0
},
stop: {
opacity: 1,
y: -1
}
},
hide: {
transition: transitionTemplate,
start: {
y: -1,
opacity: 1
},
stop: {
opacity: 0,
y: -1.3
}
}
};
// Building the 'states' array from the cloned state template objects.
var states = [
rt.clone(stateTemplate),
rt.clone(stateTemplate)
];
// Specifying image source for each state.
states[0].show.start.src = rt.resource('on.svg');
states[1].show.start.src = rt.resource('off.svg');
// Defining the result traits.
return {
transparent: true,
backgroundColor: '#808080',
state: 0,
hideInactive: true,
toggleByMouse: true,
toggleBySpaceBar: true,
states: states
};
}


Toolkit Pro: Class List

Class List
Here are the classes, structs, unions and interfaces with brief descriptions:
[detail level 1234]
C CAppearanceSetPropertyPage2003 | CAppearanceSetPropertyPage2003 implements an Office 2003 tab appearance
C CAppearanceSetPropertyPage2007 | CAppearanceSetPropertyPage2007 implements an Office 2007 tab appearance
C CAppearanceSetPropertyPageAccess2007 | CAppearanceSetPropertyPageAccess2007 implements an Office 2007 tab appearance
C CAppearanceSetPropertyPageFlat | CAppearanceSetPropertyPageFlat implements an Office 2000 Flat tab appearance
C CAppearanceSetPropertyPageSelected | CAppearanceSetPropertyPageSelected implements an "Office 2000 Selected" tab appearance
C CAppearanceSetStateButtons | CAppearanceSetStateButtons implements a "State Button" tab appearance
C CAppearanceSetVisio | CAppearanceSetVisio implements a Visio tab appearance
C CAppearanceSetVisualStudio2005 | CAppearanceSetVisualStudio2005 implements a Visual Studio 2005 tab appearance
C CColorSetVisualStudio2003 | CColorSetVisualStudio2003 implements a Visual Studio 2003 tab color set
C CColorSetVisualStudio2005 | CColorSetVisualStudio2005 implements a Visual Studio 2005 tab color set
C CColorSetWinNative | CColorSetWinNative implements a Windows XP tab color set
C CXTPActiveScriptEngine | Implements ActiveScript engine component
C CXTPActiveScriptObjectContext | Wrapper around scriptable object
C CXTPActiveScriptStdRuntime | Implements standard scripting runtime library
C CXTPAlphaWnd | CXTPTabClientAlphaWnd is CWnd derived class represents alpha context helper window
C CXTPAnimationDC | CXTPAnimationDC is a CXTPBufferDC derived class
C CXTPApplication | Defines a global XTP application object interface
C CXTPArcBall | Implements natural object rotation computation using quaternions
C CXTPArrayT | This class represents a simple array of typed elements
C CXTPAsyncGuard | A convenience class for guarding an adapted object reference by a RW-lock provided
C CXTPAutoResetValue | Helper class template provides functionality to temporary set some to variable and reset to initial or other value on destroy
C CXTPAuxData | CXTPAuxData is a standalone global item data structure class
C CXTPBatchAllocObjT | This template class used as a helper class to override new/delete operators and use batch allocation inside them
C CXTPBrowseButton | CXTPBrowseButton is a CXTPButton derived class
C CXTPBrowseDialog | CXTPBrowseDialog is derived from the BROWSEINFO structure
C CXTPBrowseEdit | CXTPBrowseEdit is a CXTPEdit derived class
C CXTPBrush | Provides a convenient object oriented interface for HBRUSH GDI object and uses GDI handle caching
C CXTPButton | Push Button control
C CXTPButtonTheme | CXTPButtonTheme is a class used to perform Button Theme drawing tasks
C CXTPButtonThemeFlat | CXTPButtonThemeFlat is a class used to perform Flat Theme drawing tasks
C CXTPButtonThemeNativeWindows10 | CXTPButtonThemeNativeWindows10 is a class used to perform Visual Studio 2015 theme drawing tasks
C CXTPButtonThemeNativeWindows11 | CXTPButtonThemeNativeWindows11 is a class used to perform Visual Studio 2015 theme drawing tasks
C CXTPButtonThemeOffice2000 | CXTPButtonThemeOffice2000 is a class used to perform Office 2000 Theme drawing tasks
C CXTPButtonThemeOffice2003 | CXTPButtonThemeOffice2003 is a class used to perform Office 2003 Theme drawing tasks
C CXTPButtonThemeOffice2013 | CXTPButtonThemeOffice2013 is a class used to perform Office 2013 theme drawing tasks
C CXTPButtonThemeOfficeXP | CXTPButtonThemeOfficeXP is a class used to perform Office XP Theme drawing tasks
C CXTPButtonThemeResource | CXTPButtonThemeResource is a class used to perform Office 2007 Theme drawing tasks
C CXTPButtonThemeUltraFlat | CXTPButtonThemeUltraFlat is a class used to perform Ultra Flat Theme drawing tasks
C CXTPButtonThemeVisualStudio2012 | CXTPButtonThemeVisualStudio2012 is a class used to perform Visual Studio 2012 theme drawing tasks
C CXTPButtonThemeVisualStudio2015 | CXTPButtonThemeVisualStudio2015 is a class used to perform Visual Studio 2015 theme drawing tasks
C CXTPButtonThemeVisualStudio2017 | CXTPButtonThemeVisualStudio2017 is a class used to perform Visual Studio 2017 theme drawing tasks
C CXTPButtonThemeVisualStudio2019 | CXTPButtonThemeVisualStudio2019 is a class used to perform Visual Studio 2019 theme drawing tasks
C CXTPButtonThemeVisualStudio2022 | CXTPButtonThemeVisualStudio2022 is a class used to perform Visual Studio 2022 theme drawing tasks
C CXTPCalendarBusyStatusComboBox | This class implements the busy status selector combobox
C CXTPCalendarCaptionBarControl | CXTPCalendarCaptionBarControl represents CalendarCaptionBar control and used as a part of CXTPCalendarControl object
C CXTPCalendarCaptionBarNativeWindows10Theme | CXTPCalendarCaptionBarNativeWindows10Theme is a CXTPCalendarCaptionBarOffice2013Theme derived class that represents the Native Windows 10 calendar theme
C CXTPCalendarCaptionBarNativeWindows11Theme | CXTPCalendarCaptionBarNativeWindows11Theme is a CXTPCalendarCaptionBarOffice2013Theme derived class that represents the Native Windows 11 calendar theme
C CXTPCalendarCaptionBarOffice2000Theme | CXTPCalendarCaptionBarOffice2000Theme is a CXTPCalendarCaptionBarPaintManager derived class thatrepresents the Office 2000 calendar theme
C CXTPCalendarCaptionBarOffice2003Theme | CXTPCalendarCaptionBarOffice2003Theme is a CXTPCalendarCaptionBarOfficeXPTheme derived class that represents the Office 2003 calendar theme
C CXTPCalendarCaptionBarOffice2013Theme | CXTPCalendarCaptionBarOffice2013Theme is a CXTPCalendarCaptionBarOffice2003Theme derived class that represents the Office 2013 white calendar theme
C CXTPCalendarCaptionBarOfficeXPTheme | CXTPCalendarCaptionBarOfficeXPTheme is a CXTPCalendarCaptionBarOffice2000Theme derived class that represents the Office XP calendar theme
C CXTPCalendarCaptionBarPaintManager | Utility class, handles most of the drawing activities
C CXTPCalendarCaptionBarResourceTheme | CXTPCalendarCaptionBarResourceTheme is a CXTPCalendarCaptionBarOffice2013Theme derived class that represents the Resource calendar theme
C CXTPCalendarCaptionBarTheme | This class CalendarCaptionBar control drawing, user interaction logic and interaction logic with attached Calendar control
C CXTPCalendarCaptionBarThemePart | This class used as a base class for graphical Parts of CalendarCaptionBar paint theme
C CXTPCalendarCaptionBarVisualStudio2015Theme | CXTPCalendarCaptionBarVisualStudio2015Theme is a CXTPCalendarCaptionBarOffice2013Theme derived class that represents the Visual Studio 2015 white calendar theme
C CXTPCalendarCaptionBarVisualStudio2017Theme | CXTPCalendarCaptionBarVisualStudio2017Theme is a CXTPCalendarCaptionBarOffice2013Theme derived class that represents the Visual Studio 2017 white calendar theme
C CXTPCalendarCaptionBarVisualStudio2019Theme | CXTPCalendarCaptionBarVisualStudio2019Theme is a CXTPCalendarCaptionBarOffice2013Theme derived class that represents the Visual Studio 2019 white calendar theme
C CXTPCalendarCaptionBarVisualStudio2022Theme | CXTPCalendarCaptionBarVisualStudio2022Theme is a CXTPCalendarCaptionBarOffice2013Theme derived class that represents Visual Studio 2022 white calendar theme
C CXTPCalendarComboBoxBase | This class is used as the base class for all owner drawn Calendar Event comboboxes
►C CXTPCalendarControl | Class CXTPCalendarControl implements the calendar's view interface
C CUpdateContext | Class CUpdateContext updates context and redraws control parts depending on input parameters
C CViewChanged_ContextData | Class CViewChanged_ContextData is used as locker context for CViewChangedContext
C CViewChangedContext | Class CViewChangedContext used to avoid multiple sending of XTP_NC_CALENDARVIEWWASCHANGED notification for one action
C CXTPCalendarController | Class CXTPCalendarController provides a connection between a CXTPCalendarControl object and a CXTPDatePickerControl object
C CXTPCalendarControlView | Implementation of the Calendar control as a view class
C CXTPCalendarControlViewPrintOptions | Describes printing options for the Calendar Control
C CXTPCalendarCustomDataProvider | Custom implementation of XTPCalendarData based on notifications
C CXTPCalendarCustomProperties | This class is used to store properties collection
►C CXTPCalendarData | This class defines an abstract representation of the Calendar control data with all necessary methods and some predefined functionality added
C CXTPDPCache |
C EventsMapByID_T |
C CXTPCalendarDatabaseDataProvider | This class is the implementation of the XTPCalendarData abstract class which represents the data portion of the Calendar control
C CXTPCalendarDayView | This class implements a specific view portion of the Calendar control - called Day view
C CXTPCalendarDayViewDay | This class represents a day view portion of the Calendar Day View
C CXTPCalendarDayViewEvent | This class represents an event view portion of the CalendarDayViewDay
C CXTPCalendarDayViewGroup | This class represents a single resource view portion of the Calendar Day View
C CXTPCalendarDayViewTimeScale | This class implements a specific view portion of the Calendar Day view - called Time scale
C CXTPCalendarEvent | This class represents the data of a single Event used in the Calendar control
C CXTPCalendarEventCategories | This class is used as a collection of CXTPCalendarEventCategory objects
C CXTPCalendarEventCategory | This class defines Calendar Event Category properties
C CXTPCalendarEventCategoryComboBox | This class implements the event category selector combobox
C CXTPCalendarEventCategoryIDs | This class represents the collection of event categories IDs
C CXTPCalendarEventColorDlg | This class is used to edit Calendar Event Category and Label information
C CXTPCalendarEventColorEdit | This class is used by CXTPCalendarEventColorListBox to create an inplace edit box for renaming event categories and labels
C CXTPCalendarEventColorListBox | This class is used to display a list of Calendar Event Categories or Labels that can be edited
C CXTPCalendarEventColorNewDlg | This class is used to add new Calendar Event Categories or Labels to the existing data array
C CXTPCalendarEventLabel | This class defines Calendar Event label properties
C CXTPCalendarEventLabelComboBox | This class implements the event label selector combobox
C CXTPCalendarEventLabels | This class is used as a collection of CXTPCalendarEventLabel objects
C CXTPCalendarEventPropertiesDlg | This class is used to edit calendar event properties
C CXTPCalendarEventRecurrenceDlg | This class is used for manipulations with recurrence state of the events
C CXTPCalendarEvents | This class represents a simple array collection of CXTPCalendarEvent objects
C CXTPCalendarIconIDs | This class represents the collection of custom icons IDs
C CXTPCalendarMemoryDataProvider | This class implements an abstract representation of the data used in the XTPCalendarData class
►C CXTPCalendarMonthView | This class implements a specific view portion of the Calendar control - called Month view
C CMonthViewGrid |
C CXTPCalendarMonthViewDay | This class represents a day view portion of the CalendarMonthView
C CXTPCalendarMonthViewEvent | This class represents an event view portion of the CalendarMonthViewDay
C CXTPCalendarMonthViewGroup | This class represents a single resource view portion of the Calendar Month View
C CXTPCalendarMsgNotifier | This class is used to catch windows messages, which the system sends to top-level windows, and to send them to subscribers windows
C CXTPCalendarNativeWindows10Theme | CXTPCalendarNativeWindows10Theme is a CXTPCalendarOffice2013Theme derived class that represents the Native Windows 10 calendar theme
C CXTPCalendarNativeWindows11Theme | CXTPCalendarNativeWindows11Theme is a CXTPCalendarOffice2013Theme derived class that represents the Native Windows 11 calendar theme
C CXTPCalendarOccurSeriesChooseDlg | This class implements a dialog to choose between current occurrence and whole recurrence event series (or pattern)
C CXTPCalendarOffice2000Theme | CXTPCalendarOffice2000Theme is a CXTPCalendarPaintManager derived class that represents the Office 2000 calendar theme
C CXTPCalendarOffice2003Theme | CXTPCalendarOffice2003Theme is a CXTPCalendarOffice2000Theme derived class that represents the Office 2003 calendar theme
C CXTPCalendarOffice2013Theme | CXTPCalendarOffice2013Theme is a CXTPCalendarOffice2000Theme derived class that represents the Office 2013 calendar theme
C CXTPCalendarOfficeXPTheme | CXTPCalendarOfficeXPTheme is a CXTPCalendarOffice2000Theme derived class that represents the Office XP calendar theme
C CXTPCalendarOptions | Structure contains all calendar options
C CXTPCalendarPageSetupDialog | Customized Calendar control page setup dialog
C CXTPCalendarPaintManager | Utility class, handles most of the drawing activities
C CXTPCalendarPtrCollectionT | This class represents a simple array collection of objects
C CXTPCalendarRecurrencePattern | This class represents a recurrence pattern and stores data to build a schedule for recurrence events
►C CXTPCalendarReminder | This class describes a reminder for a calendar event and implements base properties for and operations on the reminder
C RecurrenceEventInfo | This structure contains data members to unambiguously define related recurrence event occurrence
C CXTPCalendarReminderForOccurrenceArray | This class implements a collection of CXTPCalendarReminderForOccurrence objects as well as some common operations on it
C CXTPCalendarReminders | This class represents a simple array collection of CXTPCalendarReminder objects
C CXTPCalendarRemindersDialog | This class used to display calendar reminders
C CXTPCalendarRemindersManager | This class is used to monitor and manage calendar events reminders
C CXTPCalendarResource | Class CXTPCalendarResource represents a calendar for some subject like a person, a shared resource, or even a group of people or resources
C CXTPCalendarResourceDescription | This class is a wrapper for CXTPCalendarResource class
C CXTPCalendarResources | This class represents a simple array collection of CXTPCalendarResource objects
C CXTPCalendarResourcesManager | This class is used as a helper to manage calendar resources (and schedules) data configurations
C CXTPCalendarResourcesNf | This class implements CXTPCalendarResource functionality with the addition of a notifications mechanism implemented by CXTPNotifySink
C CXTPCalendarResourceTheme | CXTPCalendarResourceTheme is a CXTPCalendarPaintManager derived class that represents the Resource calendar theme
C CXTPCalendarSchedule | Calendar Schedule is a characteristic of the Calendar Event, which describes a belonging of the Event to a particular Schedule (which could be people schedule, common resource schedule, etc)
C CXTPCalendarSchedules | This class represents a simple array collection of CXTPCalendarSchedule objects
C CXTPCalendarShadowDrawer | This is a helper class which handles shadows drawing (for events, etc)
C CXTPCalendarThemeBOOLValue | Helper class provides functionality to manage customized BOOL value objects
C CXTPCalendarThemeCustomizableXValueT | Helper class template provides functionality to manage customized value for the specified type
C CXTPCalendarThemeFontValue | Helper class provides functionality to manage font value objects
C CXTPCalendarThemeIntValue | Helper class provides functionality to manage customized int value objects
C CXTPCalendarThemeRectValue | Helper class provides functionality to manage customized CRect value objects
C CXTPCalendarThemeStringValue | Helper class provides functionality to manage customized string value objects
C CXTPCalendarTimeLineView | This class implements a specific view portion of the Calendar control - called Timeline view
C CXTPCalendarTimeLineViewEvent | This class represents an event timeline view portion of the CXTPCalendarViewEvent
C CXTPCalendarTimeLineViewGroup | This class represents an event timeline view portion of the CalendarViewGroup
C CXTPCalendarTimeLineViewGroups | This class represents a collection of CXTPCalendarTimeLineViewGroup objects
C CXTPCalendarTimeLineViewPart | Helper base class to implement parts for calendar paint manager objects
C CXTPCalendarTimeLineViewTimeScale | This class implements a specific view portion of the Calendar control called Timeline view scale
C CXTPCalendarTimeLineViewTimeScalePart | Helper base class to implement parts for calendar paint manager
C CXTPCalendarTimeZone | This class extends the TIME_ZONE_INFORMATION structure
►C CXTPCalendarTimeZones | This class represents a simple array collection of CXTPCalendarTimeZone objects
C REGISTRY_TIMEZONE_INFORMATION | This structure represents a format of binary data stored in the "TZI" registry key
C CXTPCalendarTip | Emulates the functionality of a "tool tip" control
C CXTPCalendarTLV_TimeScaleParams | This class implements Timeline scale params
C CXTPCalendarTLV_TimeScaleParams_Day | This class implements Timeline scale params for Day case
C CXTPCalendarTLV_TimeScaleParams_Month | This class implements Timeline scale params for Month case
C CXTPCalendarTLV_TimeScaleParams_Week | This class implements Timeline scale params for Week case
C CXTPCalendarTLV_TimeScaleParams_WorkWeek | This class implements Timeline scale params for WorkWeek case
C CXTPCalendarTypedPtrAutoDeleteArray | This class represents a simple array collection of objects pointers
C CXTPCalendarTypedPtrAutoDeleteMap | This class represents a simple map of typed keys to typed objects pointers
C CXTPCalendarUIntArray | This class represents the collection of UINT elements
C CXTPCalendarUtils | Helper class with static member functions to perform common tasks with dates, events and other objects
►C CXTPCalendarView | This class represents the view portion of the Calendar control
C CSelectionChanged_ContextData | This class defines an internal structure used as a counter on selection changes, which is needed to redraw a view when necessary
C CSelectionChangedContext | Class CSelectionChangedContext is used to avoid multiple sending of an XTP_NC_CALENDAR_SELECTION_CHANGED notification for one selection changing operation
C SEventTimeFormatInfo |
C CXTPCalendarViewDay | This class represents the day view portion of the CalendarView
C CXTPCalendarViewDayT | This class template customizes, overrides and implements some functionality for the CXTPCalendarViewDay base class
C CXTPCalendarViewEvent | This class represents an event view portion of the CalendarViewGroup
C CXTPCalendarViewEvents | This class is used as a collection of Event View objects
C CXTPCalendarViewEventSubjectEditor | This class is used to edit an event subject
C CXTPCalendarViewEventSubjectEditorColored | This class is used to edit event subject in Office 2007 Theme
C CXTPCalendarViewEventT | This class is used to build the ViewEvent layer of the DayView and ViewEvent hierarchies
C CXTPCalendarViewGroup | Regular schema:
C CXTPCalendarViewGroupT | This class template customizes, overrides and implements some functionality for the CXTPCalendarViewGroup base class
C CXTPCalendarViewPart | Helper base class to implement parts for calendar paint manager
C CXTPCalendarViewPartBrushValue | Helper class provides functionality to manage brush value objects
C CXTPCalendarViewPartCustomizableValueT | Helper class template provides functionality to manage customized values for the specified class objects
C CXTPCalendarViewPartFontValue | Helper class provides functionality to manage font settings for various graphical elements of control
C CXTPCalendarViewT | This template class represents a view portion of the Calendar control
C CXTPCalendarVisualStudio2015Theme | CXTPCalendarVisualStudio2015Theme is a CXTPCalendarOffice2013Theme derived class that represents the Visual Studio 2015 calendar theme
C CXTPCalendarVisualStudio2017Theme | CXTPCalendarVisualStudio2017Theme is a CXTPCalendarOffice2013Theme derived class that represents the Visual Studio 2017 calendar theme
C CXTPCalendarVisualStudio2019Theme | CXTPCalendarVisualStudio2019Theme is a CXTPCalendarOffice2013Theme derived class that represents the Visual Studio 2019 calendar theme
C CXTPCalendarVisualStudio2022Theme | CXTPCalendarVisualStudio2022Theme is a CXTPCalendarOffice2013Theme derived class that represents the Visual Studio 2022 calendar theme
C CXTPCalendarWeekView | This class implements a specific view portion of the Calendar control - called Week view
C CXTPCalendarWeekViewDay | This class represents a day view portion of the CalendarWeekView
C CXTPCalendarWeekViewEvent | This class represents an event view portion of the CalendarWeekViewDay
C CXTPCalendarWeekViewGroup | This class represents a single resource view portion of the Calendar Week View
C CXTPCalendarWMHandler | This class helps to handle Windows messages (WM_*) processing portion of the Calendar control views
C CXTPCaption | CXTPCaption is a CStatic derived class
C CXTPCaptionButton | CXTPCaptionButton is a CXTPButton derived class
C CXTPCaptionButtonTheme | CXTPCaptionButtonTheme is derived from CXTPButtonTheme
C CXTPCaptionButtonThemeOffice2003 | Class CXTPCaptionButtonThemeOffice2003 is a CXTPButtonOffice2003Theme derived class
C CXTPCaptionButtonThemeOfficeXP | Class CXTPCaptionButtonThemeOfficeXP is a CXTPButtonOfficeXPTheme derived class
C CXTPCaptionPopupWnd | CXTPCaptionPopupWnd is a CWnd derived class
C CXTPCaptionTheme | CXTPCaptionTheme is a CXTPControlTheme derived class used to control caption themes
C CXTPCaptionThemeOffice2003 | CXTPCaptionThemeOffice2003 is derived from CXTPCaptionTheme
C CXTPCaptionThemeOfficeXP | CXTPCaptionThemeOfficeXP is derived from CXTPCaptionTheme
C CXTPChart2dDiagram | The base class for all 2D diagrams
C CXTPChart2dDrawingObjectFactory | Implements a 2D drawing object factory singleton
C CXTPChart3dBox | Represents a 3D box build around included points and provides useful and fast operations
C CXTPChart3dDeviceCommand | Defines a common implementation interface for chart 3D drawing commands
C CXTPChart3dDeviceContext | A base implementation of 3D device context
C CXTPChart3dDiagram | The base class for all 3D diagrams
C CXTPChart3dDiagramView | This class represents the view of a chart diagram, which is a kind of CXTPChartElementView
C CXTPChart3dDrawingObjectFactory | Implements a 3D drawing object factory singleton
C CXTPChart3dFunnelDeviceCommandEvents | Defines interface for 3D chart funnel device command event sink
C CXTPChart3dFunnelDiagram | This class abstracts the funnel diagram
C CXTPChart3dFunnelDiagramView | This class abstracts the view of a funnel diagram
C CXTPChart3dFunnelSeriesLabel | CXTPChartFunnelSeriesLabelBase is a kind of CXTPChart3dFunnelSeriesLabel
C CXTPChart3dFunnelSeriesLabelDeviceCommand | Implements 3D chart funnel series label device command
C CXTPChart3dFunnelSeriesLabelsView | Represents a view object for all funnel series labels
C CXTPChart3dFunnelSeriesLabelsViewDeviceCommand | Represents device command for all funnel series labels view
C CXTPChart3dFunnelSeriesLabelView | Represents a series label view object
C CXTPChart3dFunnelSeriesPointView | This class abstracts the view of a funnel series point
C CXTPChart3dFunnelSeriesStyle | This class abstracts the basic style of a funnel series
C CXTPChart3dFunnelSeriesView | This class abstracts the view of a funnel series
C CXTPChart3dLineDeviceCommand | Provides an interface for 3D line drawing device command
C CXTPChart3dPie | This class abstracts a pie chart
C CXTPChart3dPieDeviceCommand | Base class implementation for 3D pie chart device command
C CXTPChart3dPieDeviceCommandEvents | Defines interface for 3D chart pie device command event sink
C CXTPChart3dPieDiagram | This class abstracts the pie diagram
C CXTPChart3dPieDiagramView | This class abstracts the view of a pie diagram
C CXTPChart3dPieSeriesLabel | CXTPChartPieSeriesLabelBase is a kind of CXTPChart3dPieSeriesLabel
C CXTPChart3dPieSeriesLabelDeviceCommand | Implements 3D chart pie series label device command
C CXTPChart3dPieSeriesLabelsView | Represents a view object for all pie series labels
C CXTPChart3dPieSeriesLabelsViewDeviceCommand | Represents device command for all pie series labels view
C CXTPChart3dPieSeriesLabelView | Represents a series label view object
C CXTPChart3dPieSeriesPointView | This class abstracts the view of a pie series point
C CXTPChart3dPieSeriesStyle | This class abstracts the pie series style
C CXTPChart3dPieSeriesView | This class abstracts the view of a pie series
C CXTPChart3dPyramidDeviceCommandEvents | Defines interface for 3D chart pyramid device command event sink
C CXTPChart3dPyramidDiagram | This class abstracts the pyramid diagram
C CXTPChart3dPyramidDiagramView | This class abstracts the view of a pyramid diagram
C CXTPChart3dPyramidSeriesLabel | CXTPChartPyramidSeriesLabelBase is a kind of CXTPChart3dPyramidSeriesLabel
C CXTPChart3dPyramidSeriesLabelDeviceCommand | Implements 3D chart pyramid series label device command
C CXTPChart3dPyramidSeriesLabelsView | Represents a view object for all pyramid series labels
C CXTPChart3dPyramidSeriesLabelsViewDeviceCommand | Represents device command for all pyramid series labels view
C CXTPChart3dPyramidSeriesLabelView | Represents series label view object
C CXTPChart3dPyramidSeriesPointView | This class abstracts the view of a pyramid series point
C CXTPChart3dPyramidSeriesStyle | This class abstracts the basic style of a pyramid series
C CXTPChart3dPyramidSeriesView | This class abstracts the view of a pyramid series
C CXTPChart3dRotateDeviceCommand | Base class implementation for 3D chart rotation device command
C CXTPChart3dRotation | Represents a 3D rotation primitive for chart objects using Euler angles Yaw, Pitch and Roll in degrees
C CXTPChart3dTranslateDeviceCommand | Base class implementation for 3D chart translation device command
C CXTPChartAppearance | This class represents the appearance of the chart
C CXTPChartAreaSeriesStyle | CXTPChartAreaSeriesStyle is a CXTPChartPointSeriesStyle derived class which represents the area series style
C CXTPChartAreaSeriesView | CXTPChartAreaSeriesView is a kind of CXTPChartSeriesView
C CXTPChartAxis | This abstract base class represents a chart axis as a kind of chart element
C CXTPChartAxisAppearance | This class represents the appearance of a chart axis.This class is is subclassed from CXTPChartElementAppearance class
C CXTPChartAxisConstantLine | CXTPChartAxisConstantLine is a hybrid object derived from CXTPChartTextElement and CXTPChartLegendItemView
C CXTPChartAxisConstantLines | This class encapsulates a collection of CXTPChartAxisConstantLine objects
C CXTPChartAxisCustomLabel | CXTPChartAxisCustomLabel is a CXTPChartElement derived class
C CXTPChartAxisCustomLabels | This class encapsulates a collection of CXTPChartAxisCustomLabel objects
C CXTPChartAxisGridLines | CXTPChartAxisGridLines is a kind of CXTPChartElement, This class represents the grid lines parallel to an axis
C CXTPChartAxisLabel | CXTPChartAxisLabel is a kind of CXTPChartTextElement
C CXTPChartAxisRange | This class represents the value range of the axis
C CXTPChartAxisStrip | This is a hybrid object of CXTPChartElement and CXTPChartLegendItemView
C CXTPChartAxisStrips | This class encapsulates a collection of chart axis strip objects
C CXTPChartAxisTickMarks | This class represents the tick marks in an axis
C CXTPChartAxisTitle | This class represents the axis title
C CXTPChartAxisViewTick | This class represents a tick mark in the axis
C CXTPChartAxisX | CXTPChartAxisX is a derived class from the CXTPChartAxis class and represents the X axis of a chart
C CXTPChartAxisY | CXTPChartAxisY is a derived class from the CXTPChartAxis class and represents the Y axis of a chart
C CXTPChartBarSeriesErrorBarView | This class abstracts the view of the label of a bar series
C CXTPChartBarSeriesLabel | This class abstracts the label of a bar series
C CXTPChartBarSeriesLabelView | This class abstracts the view of the label of a bar series
C CXTPChartBarSeriesPointView | This class represents the view of a bar series point, which is a kind of CXTPChartPointSeriesPointView
C CXTPChartBarSeriesStyle | This class represents a bar series style for the chart, which is a kind of CXTPChartSeriesStyle
C CXTPChartBarSeriesView | This class represents the view of a bar series, which is a kind of CXTPChartSeriesView
C CXTPChartBorder | This class abstracts the border of a chart, it is a kind of chart element
C CXTPChartBoundedCircleDeviceCommand | This class represents a bounded circle device command, which is a kind of CXTPChartDeviceCommand
C CXTPChartBoundedPolygonDeviceCommand | Base class implementation for 2D chart bounded polygon device command
C CXTPChartBoundedTextDeviceCommand | This class represents a bounded text device command, which is a kind of CXTPChartDeviceCommand
C CXTPChartBubbleSeriesLabel | CXTPChartBubbleSeriesLabel is a kind of CXTPChartSeriesLabel
C CXTPChartBubbleSeriesLabelView | CXTPChartBubbleSeriesLabelView is a kind of CXTPChartSeriesLabelView
C CXTPChartBubbleSeriesPointView | This class represents the view of a bubble series point, which is a kind of CXTPChartPointSeriesPointView
C CXTPChartBubbleSeriesStyle | This class represents a bubble series style, which is a kind of CXTPChartPointSeriesStyle
C CXTPChartBubbleSeriesView | This class represents the view of a bubble series, which is a kind of CXTPChartSeriesView
C CXTPChartCandleStickSeriesPointView | This class represents the view of a candle stick series point, which is a kind of CXTPChartSeriesPointView
C CXTPChartCandleStickSeriesStyle | This class represents a candle stick series style, which is a kind of CXTPChartHighLowSeriesStyle
C CXTPChartCandleStickSeriesView | This class represents the view of a candle stick series, which is a kind of CXTPChartSeriesView
C CXTPChartCircleDeviceCommand | This class is the base class for all circle device commands
C CXTPChartClipDeviceCommand | Base class implementation for 2D chart clipping device command
C CXTPChartColor | This class abstracts a color entity
C CXTPChartContainer | This class represents the chart container
C CXTPChartContent | This class represents chart content, which is a kind of CXTPChartElement
C CXTPChartContentAppearance | This class represents the appearance of a chart content
C CXTPChartContentView | This class represents the view of the chart content, which is a kind of CXTPChartElementView
C CXTPChartControl | CXTPChartControl is a CWnd derived class
C CXTPChartDateTimeScaleTypeMap | This class is a kind of CXTPChartScaleTypeMap, which abstracts a date-time scale type for an axis
C CXTPChartDeviceCommand | Defines a common implementation interface for chart drawing commands
C CXTPChartDeviceCommandEvents | Defines a callback interface for a chart device command event sink
C CXTPChartDeviceContext | This class abstracts a device context
C CXTPChartDiagram | This class represents a chart diagram, which is a kind of CXTPChartElement
C CXTPChartDiagram2D | This class represents a chart 2D diagram, which is a kind of CXTPChartDiagram
C CXTPChartDiagram2DAppearance | This class represents the appearance of diagram in 2D
C CXTPChartDiagram2DAxisView | This class abstracts the view of a chart axis and its child items in a bounding rectangle context
C CXTPChartDiagram2DSeriesLabel | This class abstracts the label of a point series
C CXTPChartDiagram2DSeriesLabelView | This class abstracts the view of the label of a point series
C CXTPChartDiagram2DSeriesStyle | This class represents a line series style, which is a kind of CXTPChartSeriesStyle
C CXTPChartDiagram2DView | This class represents the view of a chart 2D diagram, which is a kind of CXTPChartDiagramView
C CXTPChartDiagram3DAppearance | This class represents the appearance of diagram in 3D
C CXTPChartDiagramDomain | Represents a virtual diagram rectangular domain area
C CXTPChartDiagramView | This class represents the view of a chart diagram, which is a kind of CXTPChartElementView
C CXTPChartDrawingObjectFactory | Provides a set of factory methods for creating drawing device commands and a base class interface for an abstract drawing object factory
C CXTPChartElement | This class abstracts a chart element, this class acts as a base class for all chart elements
C CXTPChartElementAppearance | This class represents the appearance of a chart element
C CXTPChartElementCollection | This class abstracts a chart collection
C CXTPChartElementView | This class represents the view of a chart element
C CXTPChartEllipse | This class abstracts an ellipse
C CXTPChartFastLineSeriesStyle | This class represents a line series style, which is a kind of CXTPChartPointSeriesStyle
C CXTPChartFastLineSeriesView | This class represents the view of a line series, which is a kind of CXTPChartSeriesView
C CXTPChartFillStyle | This class abstracts a fill style used to fill the background of various chart elements
C CXTPChartFinanceStyleAppearance | This class represents the finance series appearance of the chart
C CXTPChartFont | This class abstracts a font entity
C CXTPChartFunnelDiagram | This class abstracts the funnel diagram
C CXTPChartFunnelDiagramBase | This class abstracts the funnel diagram
C CXTPChartFunnelDiagramView | This class abstracts the view of a funnel diagram
C CXTPChartFunnelSeriesLabel | CXTPChartFunnelSeriesLabel is a kind of CXTPChartSeriesLabel
C CXTPChartFunnelSeriesLabelBase | CXTPChartFunnelSeriesLabelBase is a kind of CXTPChartSeriesLabel
C CXTPChartFunnelSeriesLabelView | Defines 2D series label view
C CXTPChartFunnelSeriesLabelViewBase | This class abstracts the view of a funnel series label
C CXTPChartFunnelSeriesPointView | This class abstracts the view of a funnel series point
C CXTPChartFunnelSeriesPointViewBase | This class abstracts the view of a funnel series point
C CXTPChartFunnelSeriesStyle | This class abstracts the basic style of a funnel series
C CXTPChartFunnelSeriesStyleBase | This class abstracts the basic style of a funnel serie.This class is a kind of CXTPChartSeriesStyle
C CXTPChartFunnelSeriesView | This class abstracts the view of a funnel series
C CXTPChartFunnelSeriesViewBase | This class abstracts the view of a funnel series.This class is a kind of CXTPChartSeriesView
C CXTPChartGanttSeriesPointView | This class represents the view of a Gantt series point, which is a kind of CXTPChartPointSeriesPointView
C CXTPChartGanttSeriesStyle | This class represents a Gantt series style for the chart, which is a kind of CXTPChartBarSeriesStyle
C CXTPChartGanttSeriesView | This class represents the view of a Gantt series, which is a kind of CXTPChartSeriesView
C CXTPChartHighLowSeriesPointView | This class abstracts the view of the stock series point of the chart
C CXTPChartHighLowSeriesStyle | This class represents the stock series style in the chart
C CXTPChartHighLowSeriesView | This class abstracts the view of the stock series of the chart
C CXTPChartHitTestElementCommand | Defines a base class interface for a 2D hit test command
C CXTPChartLegend | This class represents a chart legend as a kind of chart element
C CXTPChartLegendAppearance | This class represents the appearance of a chart legend
C CXTPChartLegendItemView | CXTPChartLegendItemView is an abstract base class which represents a chart legend item
C CXTPChartLegendView | This class abstracts the view of a legend and its child items in a bounding rectangle context
C CXTPChartLineDeviceCommand | Provides an interface for 2D line drawing device command
C CXTPChartLineSeriesErrorBarView | This class abstracts the view of the label of a bar series, it is a kind of point series label view
C CXTPChartLineSeriesStyle | This class represents a line series style, which is a kind of CXTPChartPointSeriesStyle
C CXTPChartLineSeriesView | This class represents the view of a line series, which is a kind of CXTPChartSeriesView
C CXTPChartLineStyle | This class represents a chart line style, which is a kind of CXTPCmdTarget
C CXTPChartMarker | This class abstracts a marker used in marking the points in a point series style chart
C CXTPChartMarkupElementDeviceCommand | Implements 2D markup element drawing device command
C CXTPChartNumberFormat | This class helper is used to format number to string
C CXTPChartNumericalScaleTypeMap | This class is a kind of CXTPChartScaleTypeMap, which abstracts a numeric scale type for an axis
C CXTPChartObject | A base class for all chart objects
C CXTPChartPalette | This class abstracts a color palette
C CXTPChartPaletteEntry | This class represents a palette entry, which abstracts two 32 bit color values of type ARGB
C CXTPChartPanel | This class abstracts a chart panel
C CXTPChartPanelCollection | This class abstracts a chart panel collection
C CXTPChartPie | This class abstracts a pie chart
C CXTPChartPieBase | This class abstracts a pie chart
C CXTPChartPieDeviceCommand | Base class implementation for 2D pie chart device command
C CXTPChartPieDeviceCommandImpl | This class is a common implementation for a pie chart device command
C CXTPChartPieDiagram | This class abstracts the pie diagram
C CXTPChartPieDiagramBase | This class abstracts the pie diagram
C CXTPChartPieDiagramView | This class abstracts the view of a pie diagram
C CXTPChartPieSeriesLabel | CXTPChartPieSeriesLabelBase is a kind of CXTPChartPieSeriesLabel
C CXTPChartPieSeriesLabelBase | CXTPChartPieSeriesLabelBase is a kind of CXTPChartSeriesLabel
C CXTPChartPieSeriesLabelsView | Defines 2D series label collection view
C CXTPChartPieSeriesLabelsViewBase | Defines a base class interface for series label collection view
C CXTPChartPieSeriesLabelView | Defines 2D series label view
C CXTPChartPieSeriesLabelViewBase | Defines a base class interface for series label view
C CXTPChartPieSeriesPointView | This class abstracts the view of a pie series point
C CXTPChartPieSeriesPointViewBase | This class abstracts the view of a pie series point
C CXTPChartPieSeriesStyle | This class abstracts the pie series style
C CXTPChartPieSeriesStyleBase | This class abstracts the basic style of a pie serie.This class is a kind of CXTPChartSeriesStyle
C CXTPChartPieSeriesView | This class abstracts the view of a pie series
C CXTPChartPieSeriesViewBase | This class abstracts the view of a pie series
C CXTPChartPieStyleAppearance | This class represents the pie series appearance of the chart
C CXTPChartPointSeriesErrorBarView | This class abstracts the view of the label of a bar series
C CXTPChartPointSeriesLabel | This class abstracts the label of a point series
C CXTPChartPointSeriesLabelView | This class abstracts the view of the label of a point series
C CXTPChartPointSeriesPointView | This class represents the view of a point series point, which is a kind of CXTPChartSeriesPointView
C CXTPChartPointSeriesStyle | This class represents a line series style, which is a kind of CXTPChartSeriesStyle
C CXTPChartPointSeriesView | This class represents the view of a point series, which is a kind of CXTPChartSeriesView
C CXTPChartPolygonAntialiasingDeviceCommand | Base class implementation for 2D chart antialiased polygon device command
C CXTPChartPolygonDeviceCommand | Base class implementation for 2D chart polygon device command
C CXTPChartPolylineDeviceCommand | Provides an interface for 2D poly-line drawing device command
C CXTPChartPyramidDiagram | This class abstracts the pyramid diagram
C CXTPChartPyramidDiagramBase | This class abstracts the pyramid diagram
C CXTPChartPyramidDiagramView | This class abstracts the view of a pyramid diagram
C CXTPChartPyramidSeriesLabel | CXTPChartPyramidSeriesLabel is a kind of CXTPChartSeriesLabel
C CXTPChartPyramidSeriesLabelBase | This class abstracts the pyramid series label
C CXTPChartPyramidSeriesLabelView | Defines 2D series label view
C CXTPChartPyramidSeriesLabelViewBase | This class abstracts the view of a pyramid series label
C CXTPChartPyramidSeriesPointView | This class abstracts the view of a pyramid series point
C CXTPChartPyramidSeriesPointViewBase | This class abstracts the view of a pyramid series point
C CXTPChartPyramidSeriesStyle | This class abstracts the basic style of a pyramid series
C CXTPChartPyramidSeriesStyleBase | This class abstracts the basic style of a pyramid series
C CXTPChartPyramidSeriesView | This class abstracts the view of a pyramid series
C CXTPChartPyramidSeriesViewBase | This class abstracts the view of a pyramid series
C CXTPChartQualitativeScaleTypeMap | This class abstracts a scale type map, which represents qualitative values
C CXTPChartRadarAreaSeriesStyle | This class represents a line series style, which is a kind of CXTPChartSeriesStyle
C CXTPChartRadarAreaSeriesView | This class represents the view of a point series, which is a kind of CXTPChartSeriesView
C CXTPChartRadarAxisView | This class abstracts the view of a chart axis and its child items in a bounding rectangle context
C CXTPChartRadarAxisX | CXTPChartRadarAxisX is a derived class from the CXTPChartAxis class and represents the X axis of a chart
C CXTPChartRadarAxisXView | This class abstracts the view of a chart axis and its child items in a bounding rectangle context
C CXTPChartRadarAxisXViewTick | This class represents a tick mark in the axis
C CXTPChartRadarAxisY | CXTPChartRadarAxisY is a derived class from the CXTPChartAxis class and represents the Y axis of a chart
C CXTPChartRadarAxisYView | This class abstracts the view of a chart axis and its child items in a bounding rectangle context
C CXTPChartRadarAxisYViewTick | This class represents a tick mark in the axis
C CXTPChartRadarDiagram | This class represents a chart 2D diagram, which is a kind of CXTPChartDiagram
C CXTPChartRadarDiagramSeriesStyle | This class represents a base radar series style, which is a kind of CXTPChartSeriesStyle
C CXTPChartRadarDiagramView | This class represents the view of a chart 2D diagram, which is a kind of CXTPChartDiagramView
C CXTPChartRadarLineSeriesStyle | This class represents a line series style, which is a kind of CXTPChartSeriesStyle
C CXTPChartRadarLineSeriesView | This class represents the view of a point series, which is a kind of CXTPChartSeriesView
C CXTPChartRadarPointSeriesLabel | This class abstracts the label of a point series
C CXTPChartRadarPointSeriesLabelView | This class abstracts the view of the label of a point series, it is a kind of chart series label view
C CXTPChartRadarPointSeriesPointView | This class represents the view of a point series point, which is a kind of CXTPChartSeriesPointView
C CXTPChartRadarPointSeriesStyle | This class represents a line series style, which is a kind of CXTPChartSeriesStyle
C CXTPChartRadarPointSeriesView | This class represents the view of a point series, which is a kind of CXTPChartSeriesView
C CXTPChartRadarSplineAreaSeriesStyle | This class represents a spline area series style, which is a kind of CXTPChartRadarAreaSeriesStyle
C CXTPChartRadarSplineAreaSeriesView | CXTPChartRadarSplineAreaSeriesView is a kind of CXTPChartSeriesView
C CXTPChartRadarSplineSeriesStyle | This class represents the spline series style in the chart
C CXTPChartRadarSplineSeriesView | This class represents the view of a spline series, which is a kind of CXTPChartSeriesView
C CXTPChartRangeAreaSeriesLabel | This class abstracts the label of a bar series
C CXTPChartRangeAreaSeriesLabelView | This class abstracts the view of the label of a bar series
C CXTPChartRangeBarSeriesLabel | This class abstracts the label of a bar series
C CXTPChartRangeBarSeriesLabelView | This class abstracts the view of the label of a bar series
C CXTPChartRangeBarSeriesPointView | This class represents the view of a RangeBar series point, which is a kind of CXTPChartPointSeriesPointView
C CXTPChartRangeBarSeriesStyle | This class represents a RangeBar series style for the chart, which is a kind of CXTPChartBarSeriesStyle
C CXTPChartRangeBarSeriesView | This class represents the view of a RangeBar series, which is a kind of CXTPChartSeriesView
C CXTPChartRangeSplineAreaSeriesPointView | This class represents the view of a RangeBar series point, which is a kind of CXTPChartPointSeriesPointView
C CXTPChartRangeSplineAreaSeriesStyle | CXTPChartRangeSplineAreaSeriesStyle is a CXTPChartAreaSeriesStyle derived class which represents the area series style
C CXTPChartRangeSplineAreaSeriesView | CXTPChartRangeSplineAreaSeriesView is a kind of CXTPChartAreaSeriesView
C CXTPChartRectangleDeviceCommand | Base class implementation for 2D chart rectangle device command
C CXTPChartRotateDeviceCommand | Base class implementation for 2D chart rotation device command
C CXTPChartRotatedTextPainterBase | This abstract base class represents a rotated text painter which is used for drawing various rotated text elements in the chart
C CXTPChartRotatedTextPainterNearLine | This abstract base class renders a rotated text near a line which is used for drawing various rotated text elements near lines in the chart
C CXTPChartScaleTypeMap | This class abstracts a scale type map
C CXTPChartScatterLineSeriesStyle | This class represents a line series style, which is a kind of CXTPChartPointSeriesStyle
C CXTPChartSeries | This class represents a series in the chart, which is a kind of CXTPChartElement
C CXTPChartSeriesCollection | This class represents the collection of series in the chart, which is a kind of CXTPChartElement
C CXTPChartSeriesLabel | This class abstracts the label of a series
C CXTPChartSeriesPoint | CXTPChartSeriesPoint is a kind of CXTPChartElement
C CXTPChartSeriesPointCollection | CXTPChartSeriesPointCollection class represents a collection of chart series points
C CXTPChartSeriesPointView | Represents chart series point view
C CXTPChartSeriesStyle | CXTPChartSeriesStyle is a CXTPChartElement derived class
C CXTPChartSolidSplinePolygonDeviceCommand | Base class implementation for 2D chart solid spline polygon device command
C CXTPChartSplineAreaSeriesStyle | This class represents a spline area series style, which is a kind of CXTPChartAreaSeriesStyle
C CXTPChartSplineAreaSeriesView | CXTPChartSplineAreaSeriesView is a kind of CXTPChartSeriesView
C CXTPChartSplineDeviceCommand | Provides an interface for 2D spline drawing device command
C CXTPChartSplineSeriesStyle | This class represents the spline series style in the chart
C CXTPChartSplineSeriesView | This class represents the view of a spline series, which is a kind of CXTPChartSeriesView
C CXTPChartStackedAreaSeriesStyle | CXTPChartStackedAreaSeriesStyle is a CXTPChartAreaSeriesStyle derived class which represents the area series style
C CXTPChartStackedAreaSeriesView | CXTPChartStackedAreaSeriesView is a kind of CXTPChartSeriesView
C CXTPChartStackedBarSeriesPointView | This class represents the view of a bar series point, which is a kind of CXTPChartPointSeriesPointView
C CXTPChartStackedBarSeriesStyle | This class represents a bar series style for the chart, which is a kind of CXTPChartSeriesStyle
C CXTPChartStackedBarSeriesView | This class represents the view of a bar series, which is a kind of CXTPChartSeriesView
C CXTPChartStackedSplineAreaSeriesStyle | CXTPChartStackedSplineAreaSeriesStyle is a CXTPChartStackedAreaSeriesStyle derived class which represents the area series style
C CXTPChartStackedSplineAreaSeriesView | CXTPChartStackedSplineAreaSeriesView is a kind of CXTPChartSeriesView
C CXTPChartStepAreaSeriesStyle | This class represents a StepArea series style, which is a kind of CXTPChartAreaSeriesStyle
C CXTPChartStepAreaSeriesView | This class represents the view of a StepArea series, which is a kind of CXTPChartSeriesView
C CXTPChartStepLineSeriesPointView | This class represents the view of a step line series point, which is a kind of CXTPChartSeriesPointView
C CXTPChartStepLineSeriesStyle | This class represents a StepLine series style, which is a kind of CXTPChartLineSeriesStyle
C CXTPChartStepLineSeriesView | This class represents the view of a StepLine series, which is a kind of CXTPChartSeriesView
C CXTPChartStrings | This class is a collection class of strings
C CXTPChartTextAntialiasingDeviceCommand | This class represents a text device command, which is a kind of CXTPChartDeviceCommand
C CXTPChartTextDeviceCommand | This class represents a text device command, which is a kind of CXTPChartDeviceCommand
C CXTPChartTextElement | This class abstracts a chart text element
C CXTPChartTextPainter | This class represents a text painter which is used for drawing various text elements in the chart
C CXTPChartTextPainterBase | This abstract class represents a text painter which is used for drawing various text elements in the chart
C CXTPChartTimeScaleTypeMap | This class is a kind of CXTPChartScaleTypeMap, which abstracts a time scale type for an axis
C CXTPChartTitle | This class represents a chart title
C CXTPChartTitleAppearance | This class represents the appearance of a chart title
C CXTPChartTitleCollection | CXTPChartTitleCollection represents a collection of chart titles
C CXTPChartTranslateDeviceCommand | Base class implementation for 2D chart translation device command
C CXTPCheckboxButtonPart | This class implements Checkbox button part of the SwitchViewBar
►C CXTPCheckListBox | CXTPListBox derived class
C CCheckListState | CCheckListState is a helper class used by CXTPCheckListBox that contains information about the checkbox image that is used by the check list box
C CXTPClientCursorPos | CXTPClientCursorPos is a helper class used to retrieve the cursor position in client coordinates
C CXTPClientRect | CXTPClientRect is a helper class used to retrieve the client area for a specified window
C CXTPCmdTarget | Extends functionality of CCmdTarget and introduces workarounds for known issues and limitations of CCmdTarget
C CXTPColorBase | CXTPColorBase is a CStatic derived base class
C CXTPColorDialog | CXTPColorDialog is a CPropertySheet derived class
►C CXTPColorHex | CXTPColorHex is a CStatic derived class
►C CRgnCell | CRgnCell is a CRgn derived class used by the CXTPColorHex to create individual color cells
►C CTX_DATA | Contains pre-computed hexagon data for both small and big hexagons
C HEXAGON_DATA | Describes pre-computed hexagon data
C CXTPColorLum | CXTPColorLum is a CXTPColorBase derived class
C CXTPColorManager | CXTPColorManager is a stand alone class
C CXTPColorPageCustom | CXTPColorPageCustom is derived from CPropertyPage
C CXTPColorPageStandard | CXTPColorPageStandard is derived from CPropertyPage
C CXTPColorPicker | CXTPColorPicker is a CXTPButton derived class
C CXTPColorPopup | CXTPColorPopup is a CXTPColorSelectorCtrl derived class
►C CXTPColorSelectorCtrl | CXTPColorSelectorCtrl is a CWnd derived class
C COLOR_CELL | COLOR_CELL structure is used by the CXTPColorSelectorCtrl class to maintain information about a particular color cell
C CXTPColorSelectorCtrlTheme | CXTPColorSelectorCtrlTheme is derived from CXTPControlThemeManagerStyle to handle theme specific visualizations for the CXTPColorSelectorCtrl class
C CXTPColorSelectorCtrlThemeNativeWindows10 | CXTPColorSelectorCtrlThemeNativeWindows10 is derived from CXTPColorSelectorCtrlThemeVisualStudio2015 to handle theme specific visualizations for the CXTPColorSelectorCtrl class
C CXTPColorSelectorCtrlThemeNativeWindows11 | CXTPColorSelectorCtrlThemeNativeWindows11 is derived from CXTPColorSelectorCtrlThemeVisualStudio2015 to handle theme specific visualizations for the CXTPColorSelectorCtrl class
C CXTPColorSelectorCtrlThemeOffice2003 | CXTPColorSelectorCtrlThemeOffice2003 is derived from CXTPColorSelectorCtrlThemeOfficeXP to handle theme specific visualizations for the CXTPColorSelectorCtrl class
C CXTPColorSelectorCtrlThemeOffice2013 | CXTPColorSelectorCtrlThemeOffice2013 is derived from CXTPColorSelectorCtrlTheme to handle theme specific visualizations for the CXTPColorSelectorCtrl class
C CXTPColorSelectorCtrlThemeOfficeXP | CXTPColorSelectorCtrlThemeOfficeXP is derived from CXTPColorSelectorCtrlTheme to handle theme specific visualizations for the CXTPColorSelectorCtrl class
C CXTPColorSelectorCtrlThemeResource | CXTPColorSelectorCtrlThemeResource is derived from CXTPColorSelectorCtrlThemeOfficeXP to handle theme specific visualizations for the CXTPColorSelectorCtrl class
C CXTPColorSelectorCtrlThemeVisualStudio2015 | CXTPColorSelectorCtrlThemeVisualStudio2015 is derived from CXTPColorSelectorCtrlThemeOffice2013 to handle theme specific visualizations for the CXTPColorSelectorCtrl class
C CXTPColorSelectorCtrlThemeVisualStudio2017 | CXTPColorSelectorCtrlThemeVisualStudio2017 is derived from CXTPColorSelectorCtrlThemeVisualStudio2015 to handle theme specific visualizations for the CXTPColorSelectorCtrl class
C CXTPColorSelectorCtrlThemeVisualStudio2019 | CXTPColorSelectorCtrlThemeVisualStudio2019 is derived from CXTPColorSelectorCtrlThemeVisualStudio2015 to handle theme specific visualizations for the CXTPColorSelectorCtrl class
C CXTPColorSelectorCtrlThemeVisualStudio2022 | CXTPColorSelectorCtrlThemeVisualStudio2022 is derived from CXTPColorSelectorCtrlThemeVisualStudio2015 to handle theme specific visualizations for the CXTPColorSelectorCtrl class
C CXTPColorSetCaptionButton | Default theme caption button color set
C CXTPColorSetStateButton | Base class used to define various state colors used by command bar buttons text, background and border
C CXTPColorSetStateCheckBox | Helper class used to define various state colors used by check box and radio button controls
C CXTPColorSetStateCheckMark | Helper class used to define various state colors used by command bar check marks foreground and background
C CXTPColorSetStateComboBox | Helper class used to define various state colors used by command bar glyphs
C CXTPColorSetStateMenu | Color set class used to define various state colors used by command bar menus
C CXTPColorSetStateMenuTitleBar | Color set class used to define various state colors used by command bar menu title bars
C CXTPColorSetStateRibbon | Color set class used to define various state colors used by command bar ribbon
C CXTPColorSetStateToolbar | Color set class used to define various state colors used by command bar toolbars
C CXTPColorWnd | CXTPColorWnd is a CXTPColorBase derived class
C CXTPComboBox | Functionality of a themed Windows combobox
C CXTPComboBoxEditCtrl | Used by the CXTPComboBox object to subclass the edit-box portion of the control
C CXTPComboBoxTheme | CXTPComboBoxTheme is a class used to perform ComboBox Theme drawing tasks
C CXTPComboBoxThemeDefault | Used as the paint manager for a combobox control to render a default appearance
C CXTPComboBoxThemeNativeWindows10 | Used as the paint manager for a combobox control to render a Native Windows 10 appearance
C CXTPComboBoxThemeNativeWindows11 | Used as the paint manager for a combobox control to render a Native Windows 10 appearance
C CXTPComboBoxThemeOffice2000 | Used as the paint manager for a combobox control to render an Office 2000 appearance
C CXTPComboBoxThemeOffice2003 | Used as the paint manager for a combobox control to render an Office 2003 appearance
C CXTPComboBoxThemeOffice2013 | Used as the paint manager for a combobox control to render an Office 2013 appearance
C CXTPComboBoxThemeOfficeXPFlat | Used as the paint manager for a combobox control to render an Office XP Flat appearance
C CXTPComboBoxThemeResource | Used as the paint manager for a combobox control to render a resource appearance
C CXTPComboBoxThemeVisualStudio | Used as the paint manager for a combobox control to render a Visual Studio appearance
C CXTPComboBoxThemeVisualStudio2010 | Used as the paint manager for a combobox control to render a Visual Studio 2010 appearance
C CXTPComboBoxThemeVisualStudio2012 | Used as the paint manager for a combobox control to render a Visual Studio 2012 appearance
C CXTPComboBoxThemeVisualStudio2015 | Used as the paint manager for a combobox control to render a Visual Studio 2015 appearance
C CXTPComboBoxThemeVisualStudio2017 | Used as the paint manager for a combobox control to render a Visual Studio 2017 appearance
C CXTPComboBoxThemeVisualStudio2019 | Used as the paint manager for a combobox control to render a Visual Studio 2019 appearance
C CXTPComboBoxThemeVisualStudio2022 | Used as the paint manager for a combobox control to render a Visual Studio 2022 appearance
C CXTPComInitializer | Initializes COM and increments and holds COM initialization reference counter for the thread where constructed
C CXTPCommandBar | CXTPCommandBar is a CWnd derived class
C CXTPCommandBarEditCtrl | CXTPCommandBarEditCtrl is a CEdit derived class
C CXTPCommandBarKeyboardTip | CXTPCommandBarKeyboardTip is a CWnd derived class which represents a keyboard tip single window
C CXTPCommandBarList | CXTPCommandBarList is a CList derived class
►C CXTPCommandBars | CXTPCommandBars is a standalone class
C KEYBOARDTIPS | Keyboard tips information
C CXTPCommandBarsContextMenus | CXTPCommandBarsContextMenus is CXTPCommandBarList derived class which represents a collection of context menus
C CXTPCommandBarScrollBarCtrl | CXTPCommandBarScrollBarCtrl is a CScrollBar derived class
C CXTPCommandBarsFrameHook | CXTPCommandBarsFrameHook is a CXTPHookManagerHookAble derived class
C CXTPCommandBarsModernUITheme | Base class for the Modern UI themes for Command Bars
C CXTPCommandBarsNativeWindows10Theme | Used to enable a Native Windows 10 style theme for Command Bars
C CXTPCommandBarsNativeWindows11Theme | Used to enable a Native Windows 10 style theme for Command Bars
C CXTPCommandBarsNativeXPTheme | Used to enable a Native Windows XP style theme for Command Bars
C CXTPCommandBarsOffice2000Theme | Used to enable an Office 2000 style theme for Command Bars
C CXTPCommandBarsOffice2003Theme | Used to enable an Office 2003 style theme for Command Bars
C CXTPCommandBarsOffice2013Theme | Used to enable an Office 2013 style theme for Command Bars
C CXTPCommandBarsOfficeXPTheme | Used to enable an Office XP style theme for Command Bars
C CXTPCommandBarsOptions | Options of the command bars
C CXTPCommandBarsSiteBase | CXTPCommandBarsSiteBase is a standalone class
C CXTPCommandBarsVisualStudio2012Theme | Used to enable a Visual Studio 2012 theme for Command Bars
C CXTPCommandBarsVisualStudio2015Theme | Used to enable a Visual Studio 2015 style theme for Command Bars
C CXTPCommandBarsVisualStudio2017Theme | Used to enable a Visual Studio 2017 style theme for Command Bars
C CXTPCommandBarsVisualStudio2019Theme | Used to enable a Visual Studio 2019 style theme for Command Bars
C CXTPCommandBarsVisualStudio2022Theme | Used to enable a Visual Studio 2022 style theme for Command Bars
C CXTPCommonPicturePreviewProvider | Provides a preview handler for the common picture file types: BMP, PNG, TIF, TIFF, ICO, JPEG, JPG, EXIF, WMF, EMF
C CXTPControl | CXTPControl is a CXTPCmdTarget derived class
C CXTPControlAction | CXTPControlAction is a CXTPCmdTarget derived class
C CXTPControlActions | CXTPControlActions is a CXTPCmdTarget derived class
C CXTPControlBitmap | CXTPControlBitmap is a CXTPControlLabel derived class
C CXTPControlButton | CXTPControlButton is a CXTPControl derived class
C CXTPControlButtonColor | CXTPControlButtonColor is a CXTPControlButton derived class
C CXTPControlCheckBox | CXTPControlCheckBox is a CXTPControlButton derived class
C CXTPControlColorSelector | CXTPControlColorSelector is a CXTPControl derived class
C CXTPControlComboBox | CXTPControlComboBox is a CXTPControl derived class
C CXTPControlComboBoxEditCtrl | Inplace Edit control of the combo
C CXTPControlComboBoxGalleryPopupBar | CXTPControlComboBoxPopupBar object
C CXTPControlComboBoxList | CXTPControlComboBoxList is a CXTPControlComboBoxPopupBar derived class
C CXTPControlComboBoxPopupBar | CXTPControlComboBoxPopupBar is a CXTPPopupBar derived class
C CXTPControlCustom | CXTPControlCustom is a CXTPControlButton derived class
C CXTPControlEdit | CXTPControlEdit is a CXTPControl derived class
C CXTPControlEditCtrl | Inplace Edit control of CXTPControlEdit
C CXTPControlFontComboBox | CXTPControlFontComboBox is a CXTPControlComboBox derived class
C CXTPControlFontComboBoxList | CXTPControlFontComboBoxList is a CXTPControlComboBoxList derived class
►C CXTPControlGallery | CXTPControlGallery is a CXTPControlPopup derived class
C GALLERYITEM_POSITION | Structure contains item position description
C CXTPControlGalleryItem | CXTPControlGalleryItem is a CXTPCmdTarget derived class
C CXTPControlGalleryItems | CXTPControlGalleryItems is a CXTPCmdTarget derived class
C CXTPControlGalleryNativeWindows10Theme | The CXTPControlGalleryResourceTheme class is used to enable a Gallery Native Windows 10 style theme for Command Bars
C CXTPControlGalleryNativeWindows11Theme | The CXTPControlGalleryResourceTheme class is used to enable a Gallery Native Windows 10 style theme for Command Bars
C CXTPControlGalleryOffice2013Theme | The CXTPControlGalleryResourceTheme class is used to enable a Gallery Office 2013 style theme for Command Bars
C CXTPControlGalleryPaintManager | CXTPControlGalleryPaintManager is a standalone class used to draw a CXTPControlGallery object
C CXTPControlGalleryResourceTheme | Used to enable a Gallery Resource style theme for Command Bars
C CXTPControlGalleryVisualStudio2015Theme | The CXTPControlGalleryResourceTheme class is used to enable a Gallery Visual Studio 2015 style theme for Command Bars
C CXTPControlGalleryVisualStudio2017Theme | The CXTPControlGalleryResourceTheme class is used to enable a Gallery Visual Studio 2017 style theme for Command Bars
C CXTPControlGalleryVisualStudio2019Theme | The CXTPControlGalleryResourceTheme class is used to enable a Gallery Visual Studio 2019 style theme for Command Bars
C CXTPControlGalleryVisualStudio2022Theme | The CXTPControlGalleryResourceTheme class is used to enable a Gallery Visual Studio 2022 style theme for Command Bars
C CXTPControlHyperlink | CXTPControlHyperlink is a CXTPControl derived class
C CXTPControlLabel | CXTPControlLabel is a CXTPControl derived class
C CXTPControlListBox | CXTPControlComboBox is a CXTPControl derived class
C CXTPControlMarkupLabel | CXTPControlMarkupLabel is a CXTPControlLabel derived class
C CXTPControlOleItems | CXTPControlOleItems is a CXTPControlButton derived class
C CXTPControlPopup | CXTPControlPopup is a CXTPControl derived class
C CXTPControlPopupColor | CXTPControlPopupColor is a CXTPControlPopup derived class
C CXTPControlProgress | CXTPControlProgress is a CXTPControl derived class
C CXTPControlRadioButton | CXTPControlRadioButton is a CXTPControlButton derived class
C CXTPControlRecentFileList | CXTPControlRecentFileList is a CXTPControlButton derived class
C CXTPControls | CXTPControls is a CXTPCmdTarget derived class
C CXTPControlScrollBar | CXTPControlScrollBar is a CXTPControl derived class
C CXTPControlSelector | CXTPControlSelector is a CXTPControl derived class that represents a control selector
C CXTPControlSizeComboBox | CXTPControlSizeComboBox is a CXTPControlComboBox derived class
C CXTPControlSlider | CXTPControlSlider is a CXTPControl derived class
C CXTPControlSliderCtrl | Inplace slider control of CXTPControlSlider
C CXTPControlStatic | CXTPControlStatic is a CXTPControl derived class
C CXTPControlTabWorkspace | TabWorkspace control
C CXTPControlTheme | CXTPControlTheme can be used as a base class for user defined themes
►C CXTPControlToolbars | CXTPControlToolbars is a CXTPControlButton derived class
C CXTPControlToolbar | Represents a single toolbar item
C CXTPControlWindowList | CXTPControlWindowList is a CXTPControlButton derived class
C CXTPControlWorkspaceActions | CXTPControlWorkspaceActions is a CXTPControlButton derived class
C CXTPCriticalSection | Critical Section Wrapper
C CXTPCustomizeCommandsListBox | List of the commands
C CXTPCustomizeCommandsPage | CXTPCustomizeCommandsPage is a CPropertyPage derived class
C CXTPCustomizeKeyboardPage | CXTPCustomizeKeyboardPage is a CPropertyPage derived class
C CXTPCustomizeMenusPage | CXTPCustomizeMenusPage is a CPropertyPage derived class
C CXTPCustomizeOptionsPage | CXTPCustomizeOptionsPage is a CPropertyPage derived class
C CXTPCustomizeSheet | CXTPCustomizeSheet is a CPropertySheet derived class
C CXTPCustomizeToolbarsPage | CXTPCustomizeToolbarsPage is a CPropertyPage derived class
C CXTPDateEdit | CXTPDateEdit is a CXTPMaskEdit derived class
C CXTPDateLabelPart | This class implements Date Label part of the ScrollDateBar
C CXTPDatePickerButton | This class represents a DatePicker button
C CXTPDatePickerButtons | Class CXTPDatePickerButtons represents a collection of buttons
C CXTPDatePickerControl | Class CXTPDatePickerControl encapsulates the functionality of a date and time picker control
►C CXTPDatePickerDaysCollection |
C SELECTED_BLOCK | Selected block structure
C CXTPDatePickerItemDay | Class CXTPDatePickerItemDay represents one displayed day item in the calendar
C CXTPDatePickerItemMonth | Class CXTPDatePickerItemMonth represents one month inside the date picker month grid
C CXTPDatePickerList | This class provides the functionality of a list control which displays month names
C CXTPDatePickerPaintManager | Class CXTPDatePickerPaintManager handles most of the drawing activities for the DatePicker control
C CXTPDatePickerThemeNativeWindows10 | Class CXTPDatePickerThemeNativeWindows10 is derived from CXTPDatePickerThemeOffice2013 for rendering an Native Windows 10 style for DatePicker control
C CXTPDatePickerThemeNativeWindows11 | Class CXTPDatePickerThemeNativeWindows11 is derived from CXTPDatePickerThemeOffice2013 for rendering an Native Windows 11 style for DatePicker control
C CXTPDatePickerThemeOffice2000 | Class CXTPDatePickerThemeOffice2000 is derived from CXTPDatePickerPaintManager for rendering an Office 2000 style for DatePicker control
C CXTPDatePickerThemeOffice2003 | Class CXTPDatePickerThemeOffice2003 is derived from CXTPDatePickerPaintManager for rendering an Office 2003 style for DatePicker control
C CXTPDatePickerThemeOffice2013 | Class CXTPDatePickerThemeOffice2013 is derived from CXTPDatePickerPaintManager for rendering an Office 2013 style for DatePicker control
C CXTPDatePickerThemeOfficeXP | Class CXTPDatePickerThemeOfficeXP is derived from CXTPDatePickerPaintManager for rendering an Office XP style for DatePicker control
C CXTPDatePickerThemeResource | Class CXTPDatePickerThemeResource is derived from CXTPDatePickerPaintManager for rendering a Resource DLL style for DatePicker control
C CXTPDatePickerThemeVisualStudio2015 | Class CXTPDatePickerThemeVisualStudio2015 is derived from CXTPDatePickerThemeOffice2013 for rendering an Visual Studio 2015 style for DatePicker control
C CXTPDatePickerThemeVisualStudio2017 | Class CXTPDatePickerThemeVisualStudio2017 is derived from CXTPDatePickerThemeOffice2013 for rendering an Visual Studio 2017 style for DatePicker control
C CXTPDatePickerThemeVisualStudio2019 | Class CXTPDatePickerThemeVisualStudio2019 is derived from CXTPDatePickerThemeOffice2013 for rendering an Visual Studio 2019 style for DatePicker control
C CXTPDatePickerThemeVisualStudio2022 | Class CXTPDatePickerThemeVisualStudio2022 is derived from CXTPDatePickerThemeOffice2013 for rendering an Visual Studio 2022 style for DatePicker control
C CXTPDeviceCaps | Used to store and update sytem information
C CXTPDialogBar | CXTPDialogBar is a CXTPToolBar derived class
C CXTPDialogBase | CXTPDialogBase is a TBase derived class
C CXTPDialogEx | CXTPDialogEx is a CXTPDialogBase derived class
C CXTPDialogScrollBarContainer | CXTPDialogScrollBarContainer class adds XTP scroll bars to a class derived from CDialog
C CXTPDirWatcher | The CXTPDirWatcher is a thread class that will monitor a specified path for file and directory changes to occur
C CXTPDockBar | CXTPDockBar is a CWnd derived class
C CXTPDockContext | CXTPDockContext is a standalone class
C CXTPDockingPane | CXTPDockingPane is a CXTPDockingPaneBase derived class
C CXTPDockingPaneAutoHidePanel | CXTPDockingPaneAutoHidePanel is a multiple inheritance class derived from CWnd and CXTPDockingPaneBase
C CXTPDockingPaneAutoHideWnd | CXTPDockingPaneAutoHideWnd is a CMiniFrameWnd derived class
C CXTPDockingPaneBase | CXTPDockingPaneBase is a standalone class
C CXTPDockingPaneBaseContainer | CXTPDockingPaneBaseContainer is a CXTPDockingPaneBase derived class
C CXTPDockingPaneCaptionButton | CXTPDockingPaneCaptionButton is a standalone internal class
C CXTPDockingPaneCaptionButtons | CXTPDockingPaneCaptionButtons is a CArray derived class used to manipulate Caption Buttons
C CXTPDockingPaneColorSet | Helper class used to initialize default colors for a theme from an .INI resource
C CXTPDockingPaneColorSet2012 | Helper class used to initialize default colors for a theme from an .INI resource
C CXTPDockingPaneColorSet2013 | Helper class used to initialize default colors for a theme from an .INI resource
C CXTPDockingPaneColorSet2015 | Helper class used to initialize default colors for a theme from an .INI resource
C CXTPDockingPaneColorSet2017 | Helper class used to initialize default colors for a theme from an .INI resource
C CXTPDockingPaneColorSet2019 | Helper class used to initialize default colors for a theme from an .INI resource
C CXTPDockingPaneColorSet2022 | Helper class used to initialize default colors for a theme from an .INI resource
C CXTPDockingPaneColorSetNativeWindows10 | Helper class used to initialize default colors for a theme from an .INI resource
C CXTPDockingPaneColorSetNativeWindows11 | Helper class used to initialize default colors for a theme from an .INI resource
C CXTPDockingPaneContext | CXTPDockingPaneContext is a standalone class
C CXTPDockingPaneContextAlphaWnd | CXTPDockingPaneContextAlphaWnd is a CWnd derived class that represents an alpha context helper window
C CXTPDockingPaneContextStickerWnd | CXTPDockingPaneContextStickerWnd is a CWnd derived class that represents a sticker window
C CXTPDockingPaneDefaultTheme | CXTPDockingPaneDefaultTheme is a CXTPDockingPanePaintManager derived class that represents a classic theme for docking panes
C CXTPDockingPaneGripperedTheme | CXTPDockingPaneGripperedTheme is a CXTPDockingPaneDefaultTheme derived class that represents a gripper theme for docking panes
C CXTPDockingPaneLayout | CXTPDockingPaneLayout is a standalone class
C CXTPDockingPaneManager | CXTPDockingPaneManager is a CWnd derived class
C CXTPDockingPaneMiniWnd | CXTPDockingPaneMiniWnd is a multiple inheritance class derived from CMiniFrameWnd and CXTPDockingPaneBase
C CXTPDockingPaneNativeWindows10Theme | CXTPDockingPaneNativeWindows10Theme is used to define drawing routines specific to a Native Windows 10 docking pane theme
C CXTPDockingPaneNativeWindows11Theme | CXTPDockingPaneNativeWindows11Theme is used to define drawing routines specific to a Native Windows 10 docking pane theme
C CXTPDockingPaneOffice2002VisioTheme | CXTPDockingPaneOffice2002VisioTheme is a CXTPDockingPaneVisualStudio2003Theme derived class that represents a Visio theme for docking panes
C CXTPDockingPaneOffice2003OutlookTheme | CXTPDockingPaneOffice2003OutlookTheme is a CXTPDockingPaneOffice2003Theme derived class that represents an Office 2003 theme for docking panes
C CXTPDockingPaneOffice2003Theme | CXTPDockingPaneOffice2003Theme is a CXTPDockingPaneVisualStudio2003Theme derived class that represents an Office 2003 theme for docking panes
C CXTPDockingPaneOffice2003VisioTheme | CXTPDockingPaneOffice2003VisioTheme is a CXTPDockingPaneOffice2002VisioTheme derived class that represents an Office 2003 Visio theme for docking panes
C CXTPDockingPaneOffice2007OutlookTheme | CXTPDockingPaneOffice2007OutlookTheme is CXTPDockingPaneOffice2007Theme derived class that represents an Outlook 2007 theme for docking panes
C CXTPDockingPaneOffice2007Theme | CXTPDockingPaneOffice2007Theme is a CXTPDockingPaneOffice2003Theme derived class that represents an Office 2007 theme for docking panes
C CXTPDockingPaneOffice2007VisioTheme | CXTPDockingPaneOffice2007VisioTheme is a CXTPDockingPaneOffice2003VisioTheme derived class that represents an Office 2007 Visio theme for docking panes
C CXTPDockingPaneOffice2007WordTheme | CXTPDockingPaneOffice2007WordTheme is a CXTPDockingPaneOffice2003Theme derived class that represents an Office Word 2007 theme for docking panes
C CXTPDockingPaneOffice2013Theme | CXTPDockingPaneOffice2013Theme is used to define drawing routines specific to an Office 2013 docking pane theme
C CXTPDockingPanePaintManager | CXTPDockingPanePaintManager is a standalone class
C CXTPDockingPanePanelColorSet2012 | Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines
C CXTPDockingPanePanelColorSet2013 | Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines
C CXTPDockingPanePanelColorSet2015 | Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines
C CXTPDockingPanePanelColorSet2017 | Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines
C CXTPDockingPanePanelColorSet2019 | Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines
C CXTPDockingPanePanelColorSet2022 | Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines
C CXTPDockingPanePanelColorSetNativeWindows10 | Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines
C CXTPDockingPanePanelColorSetNativeWindows11 | Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines
C CXTPDockingPanePanelPaintManager | CXTPDockingPanePanelPaintManager is a CXTPTabPaintManager derived class that is used to store the color and appearance information of the tabs in the tab manager
C CXTPDockingPanePanelTheme2012 | Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines
C CXTPDockingPanePanelTheme2013 | Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines
C CXTPDockingPanePanelTheme2015 | Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines
C CXTPDockingPanePanelTheme2017 | Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines
C CXTPDockingPanePanelTheme2019 | Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines
C CXTPDockingPanePanelTheme2022 | Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines
C CXTPDockingPanePanelThemeNativeWindows10 | Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines
C CXTPDockingPanePanelThemeNativeWindows11 | Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines
C CXTPDockingPaneSidePanel | CXTPDockingPaneSidePanel is a multiple inheritance class derived from CWnd and CXTPDockingPaneBase
C CXTPDockingPaneSplitterContainer | CXTPDockingPaneSplitterContainer is a CXTPDockingPaneBase derived class
C CXTPDockingPaneSplitterWnd | CXTPDockingPaneSplitterWnd is a CWnd derived class
C CXTPDockingPaneTabbedContainer | CXTPDockingPaneTabbedContainer is a multiple inheritance class derived from CWnd and CXTPDockingPaneBase
C CXTPDockingPaneTabColorSet2012 | Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines
C CXTPDockingPaneTabColorSet2013 | Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines
C CXTPDockingPaneTabColorSet2015 | Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines
C CXTPDockingPaneTabColorSet2017 | Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines
C CXTPDockingPaneTabColorSet2019 | Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines
C CXTPDockingPaneTabColorSet2022 | Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines
C CXTPDockingPaneTabColorSetNativeWindows10 | Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines
C CXTPDockingPaneTabColorSetNativeWindows11 | Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines
C CXTPDockingPaneTabColorSetOfficePanel | Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines
C CXTPDockingPaneTabColorSetVisualStudio2003 | Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines
C CXTPDockingPaneTabColorSetVisualStudio2005 | Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines
C CXTPDockingPaneTabPaintManager | CXTPDockingPaneTabPaintManager is a CXTPTabPaintManager derived class that is used to store the color and appearance information of the tabs in the tab manager
C CXTPDockingPaneTabTheme2012 | Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines
C CXTPDockingPaneTabTheme2013 | Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines
C CXTPDockingPaneTabTheme2015 | Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines
C CXTPDockingPaneTabTheme2017 | Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines
C CXTPDockingPaneTabTheme2019 | Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines
C CXTPDockingPaneTabTheme2022 | Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines
C CXTPDockingPaneTabThemeNativeWindows10 | Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines
C CXTPDockingPaneTabThemeNativeWindows11 | Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines
C CXTPDockingPaneVisualStudio2003Theme | CXTPDockingPaneVisualStudio2003Theme is a CXTPDockingPaneGripperedTheme derived class that represents a Visual Studio 2003 theme for docking panes
C CXTPDockingPaneVisualStudio2005Beta1Theme | CXTPDockingPaneVisualStudio2005Beta1Theme is CXTPDockingPaneVisualStudio2003Theme derived class that represents a Visual Studio 2005 Beta 1 theme for docking panes
C CXTPDockingPaneVisualStudio2005Beta2Theme | CXTPDockingPaneVisualStudio2005Beta2Theme is CXTPDockingPaneVisualStudio2005Beta1Theme derived class that represents a Visual Studio 2005 Beta 2 theme for docking panes
C CXTPDockingPaneVisualStudio2005Theme | CXTPDockingPaneVisualStudio2005Theme is a CXTPDockingPaneVisualStudio2005Beta2Theme derived class that represents a Visual Studio 2005 theme for docking panes
C CXTPDockingPaneVisualStudio2008Theme | CXTPDockingPaneVisualStudio2008Theme is a CXTPDockingPaneVisualStudio2005Theme derived class that represents a Visual Studio 2008 theme for docking panes
C CXTPDockingPaneVisualStudio2010Theme | CXTPDockingPaneVisualStudio2010Theme is a CXTPDockingPaneVisualStudio2008Theme derived class that represents a Visual Studio 2010 theme for docking panes
C CXTPDockingPaneVisualStudio2012Theme | CXTPDockingPaneVisualStudio2012Theme is used to define drawing routines specific to a Visual Studio 2012 docking pane theme
C CXTPDockingPaneVisualStudio2015Theme | CXTPDockingPaneVisualStudio2015Theme is used to define drawing routines specific to a Visual Studio 2015 docking pane theme
C CXTPDockingPaneVisualStudio2017Theme | CXTPDockingPaneVisualStudio2017Theme is used to define drawing routines specific to a Visual Studio 2017 docking pane theme
C CXTPDockingPaneVisualStudio2019Theme | CXTPDockingPaneVisualStudio2019Theme is used to define drawing routines specific to a Visual Studio 2019 docking pane theme
C CXTPDockingPaneVisualStudio2022Theme | CXTPDockingPaneVisualStudio2022Theme is used to define drawing routines specific to a Visual Studio 2022 docking pane theme
C CXTPDockingPaneVisualStudio6Theme | CXTPDockingPaneVisualStudio6Theme is a CXTPDockingPaneGripperedTheme derived class that represents a Visual Studio 6 theme for docking panes
►C CXTPDockingPaneWindowSelect | CXTPDockingPaneWindowSelect is a CMiniFrameWnd derived class used to show a window selector for Ctrl+F9 and Alt+F7 handlers
C CColumn | Column description
C CItem | Item description
C CXTPDockingPaneWinExplorerTheme | CXTPDockingPaneWinExplorerTheme is a CXTPDockingPaneDefaultTheme derived class that represents an Explorer theme for docking panes
C CXTPDockingPaneWinNativeTheme | CXTPDockingPaneWinNativeTheme is a CXTPDockingPaneVisualStudio2003Theme derived class that represents a Win Native theme for docking panes
C CXTPDockState | CXTPDockState is a standalone class
C CXTPDropSource | Derived from IDropSource
C CXTPEdit | CXTPEdit is a CEdit derived class
C CXTPEditListBox | CXTPEditListBox is a CXTPListBox derived class
C CXTPEditListBoxToolBar | CXTPEditListBoxToolBar is a CStatic derived class
C CXTPEditTheme | CXTPEditTheme is the base class for all edit themes used to perform drawing tasks
C CXTPEditThemeDefault | CXTPEditThemeDefault is a class used to perform theme drawing tasks
C CXTPEditThemeFlat | CXTPEditThemeFlat is a class used to perform theme drawing tasks
C CXTPEditThemeNativeWindows10 | CXTPEditThemeNativeWindows10 is a class used to perform theme drawing tasks
C CXTPEditThemeNativeWindows11 | CXTPEditThemeNativeWindows11 is a class used to perform theme drawing tasks
C CXTPEditThemeOffice2000 | CXTPEditThemeOffice2000 is a class used to perform theme drawing tasks
C CXTPEditThemeOffice2003 | CXTPEditThemeOffice2003 is a class used to perform theme drawing tasks
C CXTPEditThemeOffice2013 | CXTPEditThemeOffice2013 is a class used to perform theme drawing tasks
C CXTPEditThemeOfficeXP | CXTPEditThemeOfficeXP is a class used to perform theme drawing tasks
C CXTPEditThemeResource | CXTPEditThemeResource is a class used to perform theme drawing tasks
C CXTPEditThemeUltraFlat | CXTPEditThemeUltraFlat is a class used to perform theme drawing tasks
C CXTPEditThemeVisualStudio2010 | CXTPEditThemeVisualStudio2010 is a class used to perform theme drawing tasks
C CXTPEditThemeVisualStudio2012 | CXTPEditThemeVisualStudio2012 is a class used to perform theme drawing tasks
C CXTPEditThemeVisualStudio2015 | CXTPEditThemeVisualStudio2015 is a class used to perform theme drawing tasks
C CXTPEditThemeVisualStudio2017 | CXTPEditThemeVisualStudio2017 is a class used to perform theme drawing tasks
C CXTPEditThemeVisualStudio2019 | CXTPEditThemeVisualStudio2019 is a class used to perform theme drawing tasks
C CXTPEditThemeVisualStudio2022 | CXTPEditThemeVisualStudio2022 is a class used to perform theme drawing tasks
C CXTPEmptyRect | CXTPEmptyRect is a helper class used to instantiate an empty CRect object
C CXTPEmptySize | CXTPEmptySize is a helper class used to instantiate an empty CSize object
C CXTPExcelTabCtrl | CXTPExcelTabCtrl is a CWnd derived class
C CXTPExcelTabCtrlButtonState | Used by the CXTPExcelTabCtrl class to manage navigation button information
C CXTPExcelTabCtrlTheme | CXTPExcelTabCtrlTheme is used to draw the CXTPExcelTabCtrl object
C CXTPExcelTabCtrlThemeNativeWindows10 | This class is used to draw a CXTPTabCtrl object using Excel Native Windows 10 theme
C CXTPExcelTabCtrlThemeNativeWindows11 | This class is used to draw a CXTPTabCtrl object using Excel Native Windows 11 theme
C CXTPExcelTabCtrlThemeOffice2003 | This class is used to draw a CXTPTabCtrl object using Excel Office 2003 theme
C CXTPExcelTabCtrlThemeOffice2013 | This class is used to draw a CXTPTabCtrl object using Excel Office 2013 theme
C CXTPExcelTabCtrlThemeOfficeXP | This class is used to draw a CXTPTabCtrl object using Excel Office XP theme
C CXTPExcelTabCtrlThemeVisualStudio2015 | This class is used to draw a CXTPExcelTabCtrlThemeVisualStudio2015 object using Excel Visual Studio 2015 theme
C CXTPExcelTabCtrlThemeVisualStudio2017 | This class is used to draw a CXTPExcelTabCtrlThemeVisualStudio2017 object using Excel Visual Studio 2017 theme
C CXTPExcelTabCtrlThemeVisualStudio2019 | This class is used to draw a CXTPExcelTabCtrlThemeVisualStudio2019 object using Excel Visual Studio 2019 theme
C CXTPExcelTabCtrlThemeVisualStudio2022 | This class is used to draw a CXTPExcelTabCtrlThemeVisualStudio2022 object using Excel Visual Studio 2022 theme
C CXTPExcludedMemberPadding | The CXTPExcludedMemberPadding type is used for declaring padding members for the members that were excluded by conditional compilation in order to preserve the layout of the compiled classes
C CXTPExpandButtonPart | This class implements Expand button part of the ScrollDateBar
C CXTPEyeDropper | Creates an eye dropper control that can be used to select any color that is displayed anywhere on the screen
C CXTPFlowGraphConnection | Represents a connection
C CXTPFlowGraphConnectionPoint | Represents a connection point for a node
C CXTPFlowGraphConnectionPoints | Represents a collection of connection points for a Node
C CXTPFlowGraphConnections | Represents a collection of connections for a Node
C CXTPFlowGraphControl | Flow Graph Control
C CXTPFlowGraphEditItem | Represents an edit control used to edit captions for elements in the flow graph
C CXTPFlowGraphElement | Base class for all elements in the flow graph
C CXTPFlowGraphImage | Object used to represent an image displayed in a Node or connection point
C CXTPFlowGraphImages | Collection of images that can be used in the flow graph
C CXTPFlowGraphNode | Represents a Node object
C CXTPFlowGraphNodeCustom | Represents a Node object defined by custom XAML markup
C CXTPFlowGraphNodeGroup | Represents a group of Nodes
C CXTPFlowGraphNodeGroups | Represents a collection of groups in a page
C CXTPFlowGraphNodes | Represents a collection of Nodes in a page or group
C CXTPFlowGraphPage | Represents a page in the flow graph
C CXTPFlowGraphPageHistory | Object that contains page transition history for the flow graph
C CXTPFlowGraphPageHistoryItem | Used internally to store Node history for history operations
C CXTPFlowGraphPages | Represents a collection of pages in the flow graph
C CXTPFlowGraphPaintManager | Handles most of the drawing activities of the flow graph
C CXTPFlowGraphSelectedElements | Collection of selected elements in the flow graph
C CXTPFlowGraphUndoAddConnectionCommand | This class abstracts the undo add connection command
C CXTPFlowGraphUndoAddConnectionPointCommand | This class abstracts the undo add connection point command
C CXTPFlowGraphUndoAddNodeCommand | This class abstracts the undo add Node command
C CXTPFlowGraphUndoCommand | This class abstracts the undo command
C CXTPFlowGraphUndoDeleteConnectionCommand | This class abstracts the undo delete connection command
C CXTPFlowGraphUndoDeleteConnectionPointCommand | This class abstracts the undo delete connection point command
C CXTPFlowGraphUndoDeleteNodeCommand | This class abstracts the undo delete Node command
C CXTPFlowGraphUndoGroupCommand | This class abstracts the undo commands in a group
C CXTPFlowGraphUndoManager | This class abstracts an undo manager
C CXTPFlowGraphUndoSetConnectionPositionCommand | This class abstracts the undo set connection position command
C CXTPFlowGraphUndoSetNodeCaptionCommand | This class abstracts the undo set Node caption command
C CXTPFlowGraphUndoSetNodePositionCommand | This class abstracts the undo set Node position command
C CXTPFlowGraphUndoSetNodeSizeCommand | This class abstracts the undo set Node size command
C CXTPFont | Provides a convenient object oriented interface for HFONT GDI object and uses GDI handle caching
C CXTPFontComboBox | CXTPFontComboBox is a CXTPComboBox derived class
C CXTPFontCtrlBase | CXTPFontCtrlBase is a base class used by CXTPFontListBox and CXTPFontComboBox controls to perform common drawing routines
C CXTPFontEnum | CXTPFontEnum is a standalone singleton font enumeration class
C CXTPFontListBox | CXTPFontListBox is a CXTPListBox derived class
C CXTPFontManager | Singleton class to manage fonts used by library windows and controls
C CXTPFramePaintManager | Paint manager for the Office 2007 style window frame
C CXTPFrameShadow | The class represents frame shadow object
C CXTPFrameShadowManager | Provides frame shadow management functionality
C CXTPFrameThemeOffice2007System | Used to enable a system style theme for Command Bars
C CXTPFrameWnd | CXTPFrameWnd is a CXTPFrameWndBase derived class
C CXTPFrameWndBase | CXTPFrameWndBase is a standalone class
C CXTPGaugeBaseType | A base class for all gauge types
C CXTPGaugeCtrl | Gauge control hosts a JavaScript and Markup based gauge implementation of a certain type and provides a bidirectional data and event exchange between native and script implementation
C CXTPGaugeMeterType | Implements a Meter gauge type
C CXTPGaugeStateType | Implements a State gauge type
C CXTPGaugeTraits | Defines a set of loaded gauge traits
C CXTPGdiObject | Implements common functionality for all XTP GDI object
C CXTPGifPreviewProvider | Provides a preview handler for static and animated GIF files
C CXTPGlobalAtom | A helper class for handling a global atom primitive
C CXTPGraphicBitmapPng | CXTPGraphicBitmapPng is a CBitmap derived class used to load .PNG files from files and resources
C CXTPGridColumn | Represents a grid column item with its properties and operations
C CXTPGridColumnOrder | Represents the column order, used for sorting and grouping
C CXTPGridColumns | This class is a collection of grid column objects
►C CXTPGridControl | Implementation of the Grid control
C CUpdateContext | Internal grid update helper
C CXTPGridControlLocale | Helper class with static member functions used to control active locale for Grid control and perform some locale dependent tasks
C CXTPGridDataManager | Represents a grid data manager
C CXTPGridFilterEditControl | Functionality of the filter string edit control associated to the main Grid control window
C CXTPGridGroupRow | This class represents a 'group row' of the Grid control view
C CXTPGridHeader | A grid header is a part of the grid window positioned above columns of text or numbers
C CXTPGridHeaderDragWnd | CXTPGridHeaderDragWnd is a CWnd derived class
C CXTPGridHeaderDropWnd | CXTPGridHeaderDropWnd is a CWnd derived class
C CXTPGridHyperlink | This class represents hyperlinks
C CXTPGridHyperlinks | This class represents an array of pointers to CXTPGridHyperlink objects
C CXTPGridHyperlinkStyle | This class stores the anchor styles
C CXTPGridIconNavigator | Utility class, handles Grid control icon navigation
C CXTPGridInplaceButton | CXTPGridInplaceButton is a CXTPGridInplaceControl derived class that represents a combo button and expand button of a grid cell
C CXTPGridInplaceButtons | This class represents a collection of in-place buttons for a single item of the Grid control
C CXTPGridInplaceControl | CXTPGridInplaceControl is the base class for all in-place controls of the Grid control item
C CXTPGridInplaceEdit | CXTPGridInplaceEdit is a CXTPGridInplaceControl derived class that represents an edit control to allow users to change a cell of a Grid control
C CXTPGridInplaceList | CXTPGridInplaceList is a CXTPGridInplaceControl derived class that represents a list box with item constraints
C CXTPGridNavigator | Utility class, handles Grid control item navigation
C CXTPGridPageSetupDialog | Customized Grid control page setup dialog
C CXTPGridPaintManager | Utility class that handles most drawing activities
C CXTPGridRecord | CXTPGridRecord represents a collection of CXTPGridRecordItem objects or objects of classes that are children of CXTPGridRecordItem
C CXTPGridRecordItem | Class for working with single list cell
C CXTPGridRecordItemButton | This class represents an item button and inherits basic functionality from the CXTPGridRecordItemControl class
C CXTPGridRecordItemCheckbox | This class represents a checkbox-only cell and inherits basic functionality from the CXTPGridRecordItem class
C CXTPGridRecordItemConstraint | CXTPGridRecordItemConstraint is a CXTPCmdTarget derived class
C CXTPGridRecordItemConstraints | CXTPGridRecordItemConstraints is a CXTPCmdTarget derived class
C CXTPGridRecordItemControl | This class represents a generic item control and handles control's behaviour, common for all derived item controls
C CXTPGridRecordItemControlHookWnd | This class represents an item control hook window
C CXTPGridRecordItemControls | This class represents the inplace controls of a single item
C CXTPGridRecordItemDateTime | Represents a time cell and inherits basic functionality from the CXTPGridRecordItem class
C CXTPGridRecordItemEditOptions | This class represents edit options for a single item or column
C CXTPGridRecordItemNumber | This class represents a numeric cell and inherits basic functionality from the CXTPGridRecordItem class
C CXTPGridRecordItemPercentNumber | This class represents a numeric percent cell and inherits basic functionality from the CXTPGridRecordItemNumber class
C CXTPGridRecordItemPreview | This represents a preview cell and inherits basic functionality from the CXTPGridRecordItem class
C CXTPGridRecordItemText | This class represents a text-only cell and inherits basic functionality from the CXTPGridRecordItem class
C CXTPGridRecordItemVariant | Represents a variant item and inherits basic functionality from the CXTPGridRecordItem class
C CXTPGridRecords | This class represents a grid records collection
C CXTPGridRow | CXTPGridRow class represents a row of the Grid control window
C CXTPGridRows | This class represents a rows collection class
C CXTPGridSection | Represents a grid section
C CXTPGridSections | Collection of sections
C CXTPGridSelectedRows | Encapsulates a collection of CXTPGridRow pointers that represent the selected rows in a Grid control
C CXTPGridSubListControl | Field chooser list box control
C CXTPGridThemeDefault | CXTPGridThemeDefault is a CXTPGridPaintManager derived class that represents an Office 97 style theme
C CXTPGridThemeExplorer | CXTPGridThemeExplorer is a CXTPGridPaintManager derived class that represents an Explorer style theme
C CXTPGridThemeNativeWindows10 | CXTPGridThemeNativeWindows10 is a CXTPGridThemeOffice2013 derived class that represents a Native Windows 10 style theme
C CXTPGridThemeNativeWindows11 | CXTPGridThemeNativeWindows11 is a CXTPGridThemeOffice2013 derived class that represents a Native Windows 10 style theme
C CXTPGridThemeOffice2003 | CXTPGridThemeOffice2003 is a CXTPGridPaintManager derived class that represents an Office 2003 style theme
C CXTPGridThemeOffice2003Luna | CXTPGridThemeOffice2003Luna is a CXTPGridPaintManager derived class that represents an Office 2003 Luna style theme
C CXTPGridThemeOffice2013 | CXTPGridThemeOffice2013 is a CXTPGridPaintManager derived class that represents an Office 2013 style theme
C CXTPGridThemeOfficeXP | CXTPGridThemeOfficeXP is a CXTPGridPaintManager derived class that represents an Office XP style theme
C CXTPGridThemeResource | CXTPGridThemeResource is a CXTPGridPaintManager derived class that represents a Resource style theme
C CXTPGridThemeVisualStudio2012Blue | CXTPGridThemeVisualStudio2012Blue is a CXTPGridThemeOffice2013 derived class that represents a Visual Studio 2012 Blue style theme
C CXTPGridThemeVisualStudio2012Dark | CXTPGridThemeVisualStudio2012Dark is a CXTPGridThemeOffice2013 derived class that represents a Visual Studio 2012 Dark style theme
C CXTPGridThemeVisualStudio2012Light | CXTPGridThemeVisualStudio2012Light is a CXTPGridThemeOffice2013 derived class that represents a Visual Studio 2012 Light style theme
C CXTPGridThemeVisualStudio2015 | CXTPGridThemeVisualStudio2015 is a CXTPGridThemeOffice2013 derived class that represents a Visual Studio 2015 style theme
C CXTPGridThemeVisualStudio2017 | CXTPGridThemeVisualStudio2017 is a CXTPGridThemeOffice2013 derived class that represents a Visual Studio 2017 style theme
C CXTPGridThemeVisualStudio2019 | CXTPGridThemeVisualStudio2019 is a CXTPGridThemeOffice2013 derived class that represents a Visual Studio 2019 style theme
C CXTPGridThemeVisualStudio2022 | CXTPGridThemeVisualStudio2022 is a CXTPGridThemeOffice2013 derived class that represents a Visual Studio 2022 style theme
C CXTPGridThickness | Describes the thickness of the left, top, right, and bottom sides of a rectangle
C CXTPGridTip | Encapsulates the functionality of a "tip control", a small pop-up window that displays a single line of text describing the hidden text when hovering an item on the grid area
C CXTPGridView | Implementation of the Grid control as a view class
C CXTPGridViewPrintOptions | This class is used to store printing options
C CXTPGroupLine | CXTPGroupLine is a CStatic derived class
C CXTPHeaderCtrl | CXTPHeaderCtrl is a CHeaderCtrl derived class
C CXTPHeaderCtrlTheme | CXTPHeaderCtrlTheme is a theme class used to draw a Windows classic style theme for the header control
C CXTPHeaderCtrlThemeExplorer | CXTPHeaderCtrlThemeExplorer is a CXTPHeaderCtrlThemeOffice2003 derived theme class used to draw an Office XP style theme for the header control
C CXTPHeaderCtrlThemeOffice2003 | CXTPHeaderCtrlThemeOffice2003 is a CXTPHeaderCtrlTheme derived theme class used to draw an Office 2003 style theme for the header control
C CXTPHeaderCtrlThemeOfficeXP | CXTPHeaderCtrlThemeOfficeXP is a CXTPHeaderCtrlTheme derived theme class used to draw an Office XP style theme for the header control
C CXTPHeaderCtrlThemeResource | CXTPHeaderCtrlThemeResource is a CXTPHeaderCtrlThemeOfficeXP derived theme class used to draw a resource .dll style theme for the header control
C CXTPHeapAllocatorT | This template class used as a base class for allocators which can use a custom (separate) heap
C CXTPHeapObjectT | This template class used as a helper class to override new/delete operators and use custom heap allocators inside them
C CXTPHeapString | This class used to store strings
C CXTPHeapStringT | This template used to store strings using different allocators
C CXTPHexEdit | CXTPHexEdit is a CEdit derived class
C CXTPHookManager | CXTPHookManager is standalone class
C CXTPHookManagerHookAble | HookAble interface
C CXTPHyperLink | CXTPHyperLink is a CStatic derived class
C CXTPIconHandle | CXTPIconHandle is a standalone helper class
C CXTPImageEditorDlg | CXTPImageEditorDlg is a CDialog derived class
C CXTPImageList | CXTPImageList extends CImageList with add additional functionality for images resizing that depends on DPI
C CXTPImageManager | CXTPImageManager is a standalone class
C CXTPImageManagerIcon | Icons holder class
C CXTPImageManagerIconHandle | CXTPImageManagerIconHandle is a HICON wrapper class
C CXTPImageManagerIconSet | CXTPImageManagerIconSet represents the collection of icons for a specified identifier
C CXTPImageManagerImageList | This class is used to connect ImageManager with specified HIMAGELIST
C CXTPImageManagerResource |
C CXTPImageManagerVectorImageHandle | Represents a generic interface for a vector image of any possible format to be used with CXTPImageManager
C CXTPInternalCollectionT |
C CXTPItemEdit | CXTPItemEdit is a CXTPBrowseEdit derived class
C CXTPKeyboardManager | CXTPKeyboardManager class used to handle keyboard hooks
►C CXTPListBase | CXTPListBase is a non-inherited class
C ROWCOLOR | ROWCOLOR structure is used by the CXTPListBase class to store user-defined background and text color settings for a particular row in a list control
C CXTPListBox | CXTPListBox is a CListBox derived class
C CXTPListBoxTheme | CXTPListBoxTheme is the base class used by CXTPListBox themes to draw the list box control
C CXTPListBoxThemeDefault | CXTPListBoxThemeDefault is used by CXTPListBox to draw a default style list box
C CXTPListBoxThemeNativeWindows10 | CXTPListBoxThemeNativeWindows10 is used by CXTPListBox to draw a Native Windows 10 style list box
C CXTPListBoxThemeNativeWindows11 | CXTPListBoxThemeNativeWindows11 is used by CXTPListBox to draw a Native Windows 10 style list box
C CXTPListBoxThemeOffice2003 | CXTPListBoxThemeOffice2003 is used by CXTPListBox to draw an Office 2003 style list box
C CXTPListBoxThemeOffice2013 | CXTPListBoxThemeOffice2013 is used by CXTPListBox to draw an Office 2013 style list box
C CXTPListBoxThemeOfficeXP | CXTPListBoxThemeOfficeXP is used by CXTPListBox to draw an Office XP style list box
C CXTPListBoxThemeResource | CXTPListBoxThemeResource is used by CXTPListBox to draw a resource style list box
C CXTPListBoxThemeVisualStudio2015 | CXTPListBoxThemeVisualStudio2015 is used by CXTPListBox to draw a Visual Studio 2015 style list box
C CXTPListBoxThemeVisualStudio2017 | CXTPListBoxThemeVisualStudio2017 is used by CXTPListBox to draw a Visual Studio 2017 style list box
C CXTPListBoxThemeVisualStudio2019 | CXTPListBoxThemeVisualStudio2019 is used by CXTPListBox to draw a Visual Studio 2019 style list box
C CXTPListBoxThemeVisualStudio2022 | CXTPListBoxThemeVisualStudio2022 is used by CXTPListBox to draw a Visual Studio 2022 style list box
C CXTPListCtrl | CXTPListCtrl is a multiple inheritance class derived from CListCtrl and CXTPListBase
C CXTPListView | CXTPListView is a multiple inheritance class derived from CListView and CXTPListBase
C CXTPLockGuard | Critical Sections Lock/Unlock helper
C CXTPLogFont | CXTPLogFont is a self initializing LOGFONT derived class
C CXTPMarkupBorder | CXTPMarkupBorder is a CXTPMarkupDecorator derived class
C CXTPMarkupButton | CXTPMarkupButton is a CXTPMarkupButtonBase derived class
C CXTPMarkupButtonBase | CXTPMarkupButtonBase is a CXTPMarkupContentControl derived class
C CXTPMarkupCheckBox | CXTPMarkupCheckBox is a CXTPMarkupToggleButton derived class
C CXTPMarkupColumnDefinition | CXTPMarkupColumnDefinition is a CXTPMarkupDefinitionBase derived class
C CXTPMarkupColumnDefinitionCollection | CXTPMarkupColumnDefinitionCollection is a CXTPMarkupDefinitionCollection derived class
C CXTPMarkupContentControl | CXTPMarkupContentControl is a CXTPMarkupControl derived class
C CXTPMarkupContext | CXTPMarkupContext is a standalone class used to provide common settings for Markup objects
C CXTPMarkupControl | CXTPMarkupControl is a CXTPMarkupFrameworkElement derived class
C CXTPMarkupDecorator | CXTPMarkupDecorator is a CXTPMarkupFrameworkElement derived class
C CXTPMarkupDefinitionBase | CXTPMarkupDefinitionBase is the base class for CXTPMarkupColumnDefinition and CXTPMarkupRowDefinition that defines constraints and definitions for grid rows and columns
C CXTPMarkupDefinitionCollection | CXTPMarkupDefinitionCollection is the base class for CXTPMarkupDefinitionCollection and CXTPMarkupDefinitionCollection
C CXTPMarkupDeviceDependentImage | Implements an abstract device dependent image
C CXTPMarkupDockPanel | CXTPMarkupDockPanel is a CXTPMarkupPanel derived class
C CXTPMarkupExtension | Base class for all markup extension objects
C CXTPMarkupFrameworkElement | This class represents the provided framework-level implementation built on CXTPMarkupUIElement
C CXTPMarkupGdiImage | Implements an abstract GDI device dependent image
C CXTPMarkupGdiPlusImage | Implements an abstract GDI+ device dependent image
C CXTPMarkupGdiPlusMatrixTransform | GDI+ MatrixTransform implementation
C CXTPMarkupGdiPlusRotateTransform | GDI+ RotateTransform implementation
C CXTPMarkupGdiPlusScaleTransform | GDI+ ScaleTransform implementation
C CXTPMarkupGdiPlusSkewTransform | GDI+ SkewTransform implementation
C CXTPMarkupGdiPlusTransformationMatrix | Encapsulates GDI+ transformation matrix access
C CXTPMarkupGdiPlusTransformObject | Base class for all GDI+ markup transformation objects
C CXTPMarkupGdiPlusTransformObjectImpl | Implements GDI+ markup matrix access and delegates the actual transformation to a derived class
C CXTPMarkupGdiPlusTranslateTransform | GDI+ TranslateTransform implementation
C CXTPMarkupGrid | CXTPMarkupGrid is a CXTPMarkupPanel derived class
C CXTPMarkupGridLength | CXTPMarkupGridLength is a class defined length of grid rows and columns
C CXTPMarkupImage | CXTPMarkupImage is a CXTPMarkupFrameworkElement derived class
C CXTPMarkupMatrixTransform | Default MatrixTransform implementation
C CXTPMarkupPage | CXTPMarkupPage is a CXTPMarkupFrameworkElement derived class
C CXTPMarkupPanel | CXTPMarkupPanel is a CXTPMarkupFrameworkElement derived class
C CXTPMarkupRadioButton | CXTPMarkupRadioButton is a CXTPMarkupToggleButton derived class
C CXTPMarkupRotateTransform | Default RotateTransform implementation
C CXTPMarkupRowDefinition | CXTPMarkupRowDefinition is a CXTPMarkupDefinitionBase derived class
C CXTPMarkupRowDefinitionCollection | CXTPMarkupRowDefinitionCollection is a CXTPMarkupDefinitionCollection derived class
C CXTPMarkupScaleTransform | Default ScaleTransform implementation
C CXTPMarkupSkewTransform | Default SkewTransform implementation
C CXTPMarkupStackPanel | CXTPMarkupStackPanel is a CXTPMarkupPanel derived class
C CXTPMarkupStaticExtension | A base class for a markup static extension composite object
C CXTPMarkupStaticExtensionBooleanProperty | A convenience class that represents a boolean static extension property
C CXTPMarkupStaticExtensionBrushProperty | A convenience class that represents a brush static extension property
C CXTPMarkupStaticExtensionColorProperty | A convenience class that represents an RGB color static extension property
C CXTPMarkupStaticExtensionDoubleProperty | A convenience class that represents a double static extension property
C CXTPMarkupStaticExtensionIntegerProperty | A convenience class that represents an integer static extension property
C CXTPMarkupStaticExtensionProperty | A convenience base class for all static extension properties
C CXTPMarkupStaticExtensionStringProperty | A convenience class that represents a string static extension property
C CXTPMarkupSystemBrushKeyStaticExtension | A property static extension object that represents a system brush key
C CXTPMarkupSystemBrushStaticExtension | A property static extension object that represents a system brush
C CXTPMarkupSystemColorKeyStaticExtension | A property static extension object that represents a system color key
C CXTPMarkupSystemColorsStaticExtension | A composite static extension object that represents system colors
C CXTPMarkupSystemColorStaticExtension | A property static extension object that represents a system color
C CXTPMarkupTextBlock | CXTPMarkupTextBlock is a CXTPMarkupFrameworkElement derived class
C CXTPMarkupThemePart | Used to create a theme part object used for rendering
C CXTPMarkupThickness | Describes the thickness of the left, top, right, and bottom sides of a rectangle
C CXTPMarkupToggleButton | CXTPMarkupToggleButton is a CXTPMarkupButtonBase derived class
C CXTPMarkupTransform | Base class for all markup transformation objects
C CXTPMarkupTransformationMatrix | An abstract class for device context transformation matrix
C CXTPMarkupTranslateTransform | Default TranslateTransform implementation
C CXTPMarkupTreeCtrl | Tree control class that allows for adding markup items
C CXTPMarkupUIElement | Base class for XML Markup core level implementations
C CXTPMarkupUIElementCollection | CXTPMarkupUIElementCollection is a CXTPMarkupCollection derived class
C CXTPMarkupUniformGrid | CXTPMarkupUniformGrid is a CXTPMarkupPanel derived class
C CXTPMarkupViewbox | CXTPMarkupViewbox is a CXTPMarkupDecorator derived class
►C CXTPMarkupVisual | Provides rendering support for XML Markup, which includes hit testing, coordinate transformation, and bounding box calculations
C TransformationMatrices | A structure that optionally describes the previous and the new transformation matrices
C CXTPMarkupWrapPanel | CXTPMarkupWrapPanel is a CXTPMarkupPanel derived class
C CXTPMarkupXtpScript | Contains a code in the script language chosen
C CXTPMarqueeCtrl | CXTPMarqueeCtrl is a CProgressCtrl derived class
C CXTPMarqueeCtrlPaintManager | Derived from CCmdTarget and is used by the progress bar to perform all default drawing routines
C CXTPMarqueeCtrlThemeFlat | Derived from CXTPMarqueeCtrlPaintManager and is used by the progress bar to draw a flat style progress bar
C CXTPMarqueeCtrlThemeNativeWindows | Derived from CXTPMarqueeCtrlPaintManager and is used by the progress bar to draw a native Windows style progress bar
C CXTPMarqueeCtrlThemeNativeWinXP | Derived from CXTPMarqueeCtrlPaintManager and is used by the progress bar to draw a native Windows style progress bar
C CXTPMarqueeCtrlThemeOffice2000 | The CXTPMarqueeCtrlThemeFlat class is derived from CXTPMarqueeCtrlPaintManager and is used by the progress bar to draw an Office 2000 style progress bar
C CXTPMarqueeCtrlThemeOffice2003 | The CXTPMarqueeCtrlThemeFlat class is derived from CXTPMarqueeCtrlPaintManager and is used by the progress bar to draw an Office 2003 style progress bar
C CXTPMarqueeCtrlThemeOffice2013 | The CXTPMarqueeCtrlThemeFlat class is derived from CXTPMarqueeCtrlPaintManager and is used by the progress bar to draw an Office 2013 style progress bar
C CXTPMarqueeCtrlThemeOfficeXP | The CXTPMarqueeCtrlThemeXP class is derived from CXTPMarqueeCtrlThemeFlat and is used by the progress bar to draw an Office XP style progress bar
C CXTPMarqueeCtrlThemeResource | The CXTPMarqueeCtrlThemeFlat class is derived from CXTPMarqueeCtrlPaintManager and is used by the progress bar to draw an progress bar using a resource DLL
C CXTPMarqueeCtrlThemeUltraFlat | Derived from CXTPMarqueeCtrlThemeFlat and is used by the progress bar to draw a flat style progress bar with no borders
C CXTPMarqueeCtrlThemeVisualStudio2015 | The CXTPMarqueeCtrlThemeFlat class is derived from CXTPMarqueeCtrlPaintManager and is used by the progress bar to draw a Visual Studio 2015 style progress bar
C CXTPMarqueeCtrlThemeVisualStudio2017 | The CXTPMarqueeCtrlThemeFlat class is derived from CXTPMarqueeCtrlPaintManager and is used by the progress bar to draw a Visual Studio 2017 style progress bar
C CXTPMarqueeCtrlThemeVisualStudio2019 | The CXTPMarqueeCtrlThemeFlat class is derived from CXTPMarqueeCtrlPaintManager and is used by the progress bar to draw a Visual Studio 2019 style progress bar
C CXTPMarqueeCtrlThemeVisualStudio2022 | The CXTPMarqueeCtrlThemeFlat class is derived from CXTPMarqueeCtrlPaintManager and is used by the progress bar to draw a Visual Studio 2022 style progress bar
C CXTPMaskEdit | CXTPMaskEdit is a CXTPEdit derived class
C CXTPMaskEditT | CXTPMaskEditT is a template class
C CXTPMathUtils | This class provide some mathematical utility functions
C CXTPMatrix | Represents a matrix object built upon a continuos array of elements and provides basic algorithms for it
C CXTPMDIClientWnd | CXTPMDIClientWnd is a CWnd derived helper class for the CXTPMDIWndTab tab control
C CXTPMDIFrameWnd | CXTPMDIFrameWnd is a CXTPFrameWndBase derived class
C CXTPMDIFrameWndEx | CXTPMDIFrameWndEx is a CXTPMDIFrameWnd derived class
C CXTPMDIWndTab | Used for creating a tabbed MDI document interface
C CXTPMemFile | CXTPMemFile is a CMemFile derived class
C CXTPMenuBar | CXTPMenuBar is a CXTPToolBar derived class
C CXTPMenuBarMDIMenuInfo | CXTPMenuBarMDIMenuInfo structure used to describe the parameters of application MDI menus
C CXTPMenuBarMDIMenus | CXTPMenuBarMDIMenus represents a collection of MDI menus for CXTPMenuBar
C CXTPMessageBar | CXTPMessageBar is a CControlBar derived class
C CXTPMessageBarButton | CXTPMessageBarButton is a standalone class
C CXTPMessageBarPaintManager | Used by the message bar to perform standard paint routines
C CXTPMessageBarThemeNativeWindows10 | Used by the message bar to draw a Native Windows 10 style message bar
C CXTPMessageBarThemeNativeWindows11 | Used by the message bar to draw a Native Windows 10 style message bar
C CXTPMessageBarThemeOffice2010 | Used by the message bar to draw an Office 2010 style message bar
C CXTPMessageBarThemeOffice2013 | Used by the message bar to draw an Office 2013 style message bar
C CXTPMessageBarThemeVisualStudio2015 | Used by the message bar to draw a Visual Studio 2015 style message bar
C CXTPMessageBarThemeVisualStudio2017 | Used by the message bar to draw a Visual Studio 2017 style message bar
C CXTPMessageBarThemeVisualStudio2019 | Used by the message bar to draw a Visual Studio 2019 style message bar
C CXTPMessageBarThemeVisualStudio2022 | Used by the message bar to draw a Visual Studio 2022 style message bar
C CXTPMiniToolBar | Represents a MiniToolbar object
C CXTPModuleHandle | CXTPModuleHandle class is helper for LoadLibray/GetModuleHandle methods
►C CXTPMouseManager | CXTPMouseManager is standalone class
C CTrackArray | Array of the tracking bars
C CXTPMsgPreviewProvider | Provides a preview handler for the Outlook Message (MSG) file type
C CXTPMultiMonitor | MultiMonitor API wrapper class
C CXTPNonClientMetrics | CXTPNonClientMetrics is a self-initializing NONCLIENTMETRICS derived class
►C CXTPNotifyConnection | This class is used as implementation of Connection interface in a XTPNotification mechanism
C CEmptySyncObject | This struct is derived from CSyncObject and should be used instead of CCriticalSection to improve performance and to provide compatibility
C CONNECTION_DESCRIPTOR | This struct is used in the implementation of the class CXTPNotifyConnection to store connection between a Connection object, Notification code and the sink object
C CXTPNotifyConnectionMT | This class is used as thread-safety implementation of Connection interface in a XTPNotification mechanism
►C CXTPNotifySinkBase | This class is used as implementation of Sink interface in a XTPNotification mechanism
C ADVISE_DESCRIPTOR | This struct is used in to store connection between a Connection object(s), Notification code and the sink object
C CXTPObservable | Provides a basic implementation of the Observable design pattern
C CXTPOpenGLListPool | Provides a convenient API around an OpenGL list for reliable list management
C CXTPOpenGLUtils | Provides a set of common OpenGL utilities
C CXTPOriginalControls | CXTPOriginalControls object
C CXTPPageScroller | CXTPPageScroller is a CWnd derived class
►C CXTPPaintManager | Paint manager of the command bars
C CLogFont | CLogFont is a self initializing LOGFONT derived class
C CXTPPaintManagerColor | Used to manage COLORREF values for determining default and application defined colors
C CXTPPaintManagerColorGradient | Used to manage COLORREF values for determining light and dark gradient colors
C CXTPPaintManagerFont | PaintManagers used CFont wrapper
C CXTPPasswordPeek | CXTPPasswordPeek is a CXTPEdit derived class
C CXTPPen | Provides a convenient object oriented interface for HPEN GDI object and uses GDI handle caching
C CXTPPoint2T | This class represents a two-dimensional point
C CXTPPoint3T | This class represents a three-dimensional point
C CXTPPopupBar | CXTPPopupBar is a CXTPCommandBar derived class
►C CXTPPopupControl | CXTPPopupControl is a class for control of a pop-up window
C POPUPSTATE | Pop-up state descriptor
C CXTPPopupItem | CXTPPopupItem is a class used to manage a pop-up item object
C CXTPPopupPaintManager | CXTPPopupPaintManager is a class used to perform specialized drawing tasks
C CXTPPopupThemeMSN | CXTPPopupThemeMSN is a class used to perform MSN Messenger drawing tasks
C CXTPPopupThemeOffice2000 | CXTPPopupThemeOffice2000 is a class used to perform Office 2000 drawing tasks
C CXTPPopupThemeOffice2003 | CXTPPopupThemeOffice2003 is a class used to perform Office 2003 drawing tasks
C CXTPPopupThemeOffice2013 | CXTPPopupThemeOffice2013 is a class used to perform Office 2013 drawing tasks
C CXTPPopupThemeOfficeXP | CXTPPopupThemeOfficeXP is a class used to perform Office XP drawing tasks
C CXTPPopupThemeResource | CXTPPopupThemeResource is a class used to perform resource drawing tasks
C CXTPPopupToolBar | CXTPPopupToolBar is a CXTPPopupBar derived class
C CXTPPreviewCtrl | Implements the preview control that can display visual preview data provided by the best matching preview provider registered to the control
C CXTPPreviewProviderBase | Base class for a preview provider which implements common behavior to be exposed by a preview provider
C CXTPPreviewView | CXTPPreviewView is a CPreviewView derived class that represents a print preview window with a themed toolBar
C CXTPProgressBase | CXTPControlProgressBase is base class for all progress objects
C CXTPProgressCtrl | The ProgressBar control shows the progress of a lengthy operation by filling a rectangle with chunks from left to right
C CXTPProgressCtrlPaintManager | Derived from CXTPCmdTarget and is used by the progress bar to perform all default drawing routines
C CXTPProgressCtrlThemeFlat | Derived from CXTPProgressCtrlPaintManager and is used by the progress bar to draw a flat style progress bar
C CXTPProgressCtrlThemeNativeWindows | Derived from CXTPProgressCtrlPaintManager and is used by the progress bar to draw a native Windows style progress bar
C CXTPProgressCtrlThemeNativeWinXP | Derived from CXTPProgressCtrlPaintManager and is used by the progress bar to draw a native Windows style progress bar
C CXTPProgressCtrlThemeOffice2000 | The CXTPProgressCtrlThemeFlat class is derived from CXTPProgressCtrlPaintManager and is used by the progress bar to draw an Office 2000 style progress bar
C CXTPProgressCtrlThemeOffice2003 | The CXTPProgressCtrlThemeFlat class is derived from CXTPProgressCtrlPaintManager and is used by the progress bar to draw an Office 2003 style progress bar
C CXTPProgressCtrlThemeOffice2013 | The CXTPProgressCtrlThemeFlat class is derived from CXTPProgressCtrlPaintManager and is used by the progress bar to draw an Office 2013 style progress bar
C CXTPProgressCtrlThemeOfficeXP | The CXTPProgressCtrlThemeXP class is derived from CXTPProgressCtrlThemeFlat and is used by the progress bar to draw an Office XP style progress bar
C CXTPProgressCtrlThemeResource | The CXTPProgressCtrlThemeFlat class is derived from CXTPProgressCtrlPaintManager and is used by the progress bar to draw an progress bar using a resource DLL
C CXTPProgressCtrlThemeUltraFlat | Derived from CXTPProgressCtrlThemeFlat and is used by the progress bar to draw a flat style progress bar with no borders
C CXTPProgressCtrlThemeVisualStudio2015 | The CXTPProgressCtrlThemeFlat class is derived from CXTPProgressCtrlPaintManager and is used by the progress bar to draw a Visual Studio 2015 style progress bar
C CXTPProgressCtrlThemeVisualStudio2017 | Derived from CXTPProgressCtrlThemeOffice2013 and is used by the progress bar to draw a Visual Studio 2017 style progress bar
C CXTPProgressCtrlThemeVisualStudio2019 | Derived from CXTPProgressCtrlThemeOffice2013 and is used by the progress bar to draw a Visual Studio 2019 style progress bar
C CXTPProgressCtrlThemeVisualStudio2022 | Derived from CXTPProgressCtrlThemeOffice2013 and is used by the progress bar to draw a Visual Studio 2022 style progress bar
C CXTPProgressPaintManager | CXTPProgressPaintManager object
C CXTPProgressThemeNativeWindows10 | CXTPProgressThemeNativeWindows10 object
C CXTPProgressThemeNativeWindows11 | CXTPProgressThemeNativeWindows11 object
C CXTPProgressThemeOffice2013 | CXTPProgressThemeOffice2013 object
C CXTPProgressThemeVisualStudio2015 | CXTPProgressThemeVisualStudio2015 object
C CXTPProgressThemeVisualStudio2017 | CXTPProgressThemeVisualStudio2017 object
C CXTPProgressThemeVisualStudio2019 | CXTPProgressThemeVisualStudio2019 object
C CXTPProgressThemeVisualStudio2022 | CXTPProgressThemeVisualStudio2022 object
C CXTPPropertyGrid | CXTPPropertyGrid is a CWnd derived class
C CXTPPropertyGridCoolTheme | CXTPPropertyGridCoolTheme is a CXTPPropertyGridPaintManager derived class
C CXTPPropertyGridDelphiTheme | CXTPPropertyGridDelphiTheme is a CXTPPropertyGridPaintManager derived class
C CXTPPropertyGridInplaceButton | CXTPPropertyGridInplaceButton is a CXTPCmdTarget derived class
C CXTPPropertyGridInplaceButtons | CXTPPropertyGridInplaceButtons is a CXTPCmdTarget derived class
C CXTPPropertyGridInplaceControl | CXTPPropertyGridInplaceControl is a CWnd derived class that represents the base class for all items with in-place controls
C CXTPPropertyGridInplaceControls | CXTPPropertyGridInplaceControls is a standalone class that represents a collection of CXTPPropertyGridInplaceControl classes
C CXTPPropertyGridInplaceEdit | CXTPPropertyGridInplaceEdit is a CEdit derived class
C CXTPPropertyGridInplaceList | CXTPPropertyGridInplaceList is a CListBox derived class
C CXTPPropertyGridInplaceMonthCal | Month calendar pop-up used for CXTPPropertyGridItemDate item
C CXTPPropertyGridInplaceMultilineEdit | CXTPPropertyGridInplaceMultilineEdit is a CEdit derived class
C CXTPPropertyGridInplaceSlider | CXTPPropertyGridInplaceSlider is a CXTPPropertyGridInplaceControl derived class
C CXTPPropertyGridInplaceSpinButton | CXTPPropertyGridInplaceSpinButton is a CXTPPropertyGridInplaceControl derived class
C CXTPPropertyGridItem | CXTPPropertyGridItem is the base class representing an item of the Property Grid control
C CXTPPropertyGridItemBool | CXTPPropertyGridItemBool is a CXTPPropertyGridItem derived class
C CXTPPropertyGridItemCategory | CXTPPropertyGridItemCategory is a CXTPPropertyGridItem derived class
C CXTPPropertyGridItemColor | CXTPPropertyGridItemColor is a CXTPPropertyGridItem derived class
C CXTPPropertyGridItemConstraint | CXTPPropertyGridItemConstraint is a CXTPCmdTarget derived class
C CXTPPropertyGridItemConstraints | CXTPPropertyGridItemConstraints is a CXTPCmdTarget derived class
C CXTPPropertyGridItemDate | CXTPPropertyGridItemDate is a CXTPPropertyGridItem derived class
C CXTPPropertyGridItemDouble | CXTPPropertyGridItemDouble is a CXTPPropertyGridItem derived class
C CXTPPropertyGridItemEnum | CXTPPropertyGridItemEnum is a CXTPPropertyGridItem derived class
C CXTPPropertyGridItemFlags | CXTPPropertyGridItemFlags is a CXTPPropertyGridItem derived class
C CXTPPropertyGridItemFont | CXTPPropertyGridItemFont is a CXTPPropertyGridItem derived class
C CXTPPropertyGridItemMetrics | Standalone class used by CXTPPropertyGridPaintManager to store item metrics
C CXTPPropertyGridItemMultilineString | CXTPPropertyGridItemMultilineString is a CXTPPropertyGridItem derived class
C CXTPPropertyGridItemNumber | CXTPPropertyGridItemNumber is a CXTPPropertyGridItem derived class
C CXTPPropertyGridItemOption | CXTPPropertyGridItemOption is a CXTPPropertyGridItem derived class
C CXTPPropertyGridItemPoint | CXTPPropertyGridItemPoint is a CXTPPropertyGridItem derived class
C CXTPPropertyGridItems | CXTPPropertyGridItems is a CList derived class
C CXTPPropertyGridItemSize | CXTPPropertyGridItemSize is a CXTPPropertyGridItem derived class
C CXTPPropertyGridNativeWindows10Theme | CXTPPropertyGridNativeWindows10Theme is a CXTPPropertyGridVisualStudio2010Theme derived class
C CXTPPropertyGridNativeWindows11Theme | CXTPPropertyGridNativeWindows11Theme is a CXTPPropertyGridVisualStudio2010Theme derived class
C CXTPPropertyGridNativeXPTheme | CXTPPropertyGridNativeXPTheme is a CXTPPropertyGridPaintManager derived class
C CXTPPropertyGridOffice2003Theme | CXTPPropertyGridOffice2003Theme is a CXTPPropertyGridPaintManager derived class
C CXTPPropertyGridOffice2007Theme | CXTPPropertyGridOffice2007Theme is a CXTPPropertyGridOffice2003Theme derived class
C CXTPPropertyGridOffice2013Theme | CXTPPropertyGridOffice2013Theme is a CXTPPropertyGridPaintManager derived class
C CXTPPropertyGridOfficeXPTheme | CXTPPropertyGridOfficeXPTheme is a CXTPPropertyGridPaintManager derived class
C CXTPPropertyGridPaintManager | Standalone class used by CXTPPropertyGrid as the paint manager
C CXTPPropertyGridSimpleTheme | CXTPPropertyGridSimpleTheme is a CXTPPropertyGridPaintManager derived class
C CXTPPropertyGridToolBar | CXTPPropertyGridToolBar is a CToolBar derived class
C CXTPPropertyGridToolTip | CXTPPropertyGridToolTip is a CWnd derived class
C CXTPPropertyGridUpdateContext | CXTPPropertyGridUpdateContext is a CXTPCmdTarget derived class used to save the state of the property grid such as the currently selected item, XTPPropertyGridSortOrder preference, and the expanding state of each item in the grid
C CXTPPropertyGridVerb | CXTPPropertyGridVerb is used to create a verb link similar to what is seen in Visual Studio .NET
C CXTPPropertyGridVerbs | A collection of CXTPPropertyGridVerb objects that are displayed in the verb panel
C CXTPPropertyGridView | CXTPPropertyGridView is a CListBox derived class
C CXTPPropertyGridVisualStudio2005Theme | CXTPPropertyGridVisualStudio2005Theme is a CXTPPropertyGridPaintManager derived class
C CXTPPropertyGridVisualStudio2010Theme | CXTPPropertyGridVisualStudio2010Theme is a CXTPPropertyGridPaintManager derived class
C CXTPPropertyGridVisualStudio2012Theme | CXTPPropertyGridVisualStudio2012Theme is a CXTPPropertyGridVisualStudio2010Theme derived class
C CXTPPropertyGridVisualStudio2015Theme | CXTPPropertyGridVisualStudio2015Theme is a CXTPPropertyGridVisualStudio2010Theme derived class
C CXTPPropertyGridVisualStudio2017Theme | CXTPPropertyGridVisualStudio2017Theme is a CXTPPropertyGridVisualStudio2010Theme derived class
C CXTPPropertyGridVisualStudio2019Theme | CXTPPropertyGridVisualStudio2019Theme is a CXTPPropertyGridVisualStudio2010Theme derived class
C CXTPPropertyGridVisualStudio2022Theme | CXTPPropertyGridVisualStudio2022Theme is a CXTPPropertyGridVisualStudio2010Theme derived class
C CXTPPropertyPage | CXTPPropertyPage is a CPropertyPage derived class
C CXTPPropertyPageControlNavigator | CXTPPropertyPageControlNavigator is a CXTPPropertyPageNavigator derived class
C CXTPPropertyPageListNavigator | CXTPPropertyPageListNavigator is a CXTPListBox and CXTPPropertyPageControlNavigator derived class
C CXTPPropertyPageNavigator | CXTPPropertyPageNavigator is a standalone class
C CXTPPropertyPageTreeNavigator | CXTPPropertyPageTreeNavigator is a CTreeCtrl and CXTPPropertyPageControlNavigator derived class
C CXTPPropertySheet | CXTPPropertySheet is a CXTPDialogEx derived class
C CXTPPropExchange | CXTPPropExchange is standalone pure class
C CXTPPropExchangeArchive | CXTPPropExchangeArchive is CXTPPropExchange derived class
C CXTPPropExchangeEnumerator | CXTPPropExchangeEnumerator is standalone class
C CXTPPropExchangeIniFile | CXTPPropExchangeIniFile is CXTPPropExchange derived class
C CXTPPropExchangeRegistry | CXTPPropExchangeRegistry is CXTPPropExchange derived class
C CXTPPropExchangeSection | CXTPPropExchangeSection is standalone class
C CXTPPropExchangeXMLNode | CXTPPropExchangeXMLNode is CXTPPropExchange derived class
C CXTPRadioButtonPart | This class implements Radio button part of the SwitchViewBar
C CXTPReBar | The CXTPReBar object extends the standard MFC CReBar class to provide extended functionality such as saving and restoring band layouts
C CXTPReBarPaintManager | The CXTPReBarPaintManager template class is used to enable a ReBar theme for Command Bars
C CXTPRecentFileList | CXTPRecentFileList is a CRecentFileList derived class
C CXTPRectT | This class abstracts a rectangular entity and its operations
C CXTPRegistryManager | CXTPRegistryManager is a standalone registry management class
C CXTPResize | CXTPResize is a base class
C CXTPResizeDialog | CXTPResizeDialog is a multiple inheritance class derived from CDialog and CXTPResize
C CXTPResizeFormView | CXTPResizeFormView is a multiple inheritance class derived from CFormView and CXTPResize
C CXTPResizeGroupBox | CXTPResizeGroupBox is a CButton derived class that can be used to display a flicker free group box while resizing
C CXTPResizeItem | CXTPResizeItem is a standalone helper class
C CXTPResizePoint | CXTPResizePoint is an XTP_RESIZEPOINT structure derived class
C CXTPResizePropertyPage | CXTPResizePropertyPage is a multiple inheritance class derived from CPropertyPage and CXTPResize
C CXTPResizePropertySheet | CXTPResizePropertySheet is a multiple inheritance class derived from CPropertySheet and CXTPResize
C CXTPResizeRect | CXTPResizeRect is an XTP_RESIZERECT structure derived class
C CXTPResourceImage | Represent a resource image and provides basic images functions
C CXTPResourceImages | Implements resource image collection and its operations
►C CXTPResourceManager | Standalone class used to managed toolkit resources
C CManageState | CManageState is used internally by the toolkit to switch module states
C CXTPResourceManagerXML | Class used to managed toolkit resources from an XML file
C CXTPResourceTheme | Used to enable a resource style theme for Command Bars
C CXTPRibbonBackstageView | CXTPRibbonBackstageView is a CDialog derived class used for a Backstage parent frame
C CXTPRibbonBar | CXTPRibbonBar is a CXTPMenuBar derived class
C CXTPRibbonControls | CXTPRibbonControls is a CXTPControls derived class
C CXTPRibbonControlSystemButton | CXTPRibbonControlSystemButton is a CXTPControlPopup derived class used as a system button for a Ribbon Bar
C CXTPRibbonControlSystemPopupBarButton | CXTPRibbonControlSystemPopupBarButton is a CXTPControlButton derived class used in a system pop-up bar for bottom option buttons
C CXTPRibbonControlSystemPopupBarListCaption | CXTPRibbonControlSystemPopupBarListCaption is a CXTPControl derived class used in a Ribbon system pop-up to draw captions of enumerable controls
C CXTPRibbonControlSystemPopupBarListItem | CXTPRibbonControlSystemPopupBarListItem is a CXTPControlButton derived class used in a Ribbon system pop-up to draw buttons of enumerable controls
C CXTPRibbonControlSystemPopupBarPinableListItem | CXTPRibbonControlSystemPopupBarPinableListItem is a CXTPRibbonControlSystemPopupBarListItem derived class used in a Ribbon system pop-up to draw recent file list items
C CXTPRibbonControlSystemRecentFileList | CXTPRibbonControlSystemRecentFileList is a CXTPRibbonControlSystemPopupBarListCaption derived class used in a Ribbon system pop-up to draw recent file list controls
C CXTPRibbonControlTab | CXTPRibbonControlTab is a CXTPTabManager derived class
C CXTPRibbonCustomizePage | CXTPRibbonCustomizePage is a CPropertyPage derived class
C CXTPRibbonCustomizeQuickAccessPage | CXTPRibbonCustomizeQuickAccessPage is a CPropertyPage derived class
C CXTPRibbonGroup | Represents a single group that is added to a CXTPRibbonTab
C CXTPRibbonGroups | Represents a collection of CXTPRibbonGroup objects
C CXTPRibbonMarkupFrameTheme | Used to enable a system style theme for Command Bars
C CXTPRibbonMarkupTheme | CXTPRibbonMarkupTheme class
►C CXTPRibbonOffice2013Theme | CXTPRibbonOffice2013Theme is a CXTPRibbonMarkupTheme derived class used to represent an Office 2013 ribbon theme
C CThemeStaticExtension | Helper class used to define variables to be used by XAML Markup code
C CXTPRibbonPaintManager | Standalone class used by CXTPRibbonBar as a paint manager
C CXTPRibbonQuickAccessControls | CXTPRibbonQuickAccessControls is a CXTPControls derived class
C CXTPRibbonSystemPopupBar | CXTPRibbonSystemPopupBar is a CXTPPopupBar derived class used as a system pop-up bar for a Ribbon Bar
C CXTPRibbonSystemPopupBarPage | CXTPRibbonSystemPopupBarPage is a CXTPPopupBar derived class used as a system pop-up bar page of a Ribbon Bar
C CXTPRibbonTab | Represents a tab in the Ribbon Bar
C CXTPRibbonTabPopupToolBar | Implements a pop-up when the Ribbon is in minimzed mode
C CXTPRibbonTheme | Used to enable a Ribbon style theme for Command Bars
C CXTPRibbonThemeNativeWindows10 | CXTPRibbonThemeNativeWindows10 is a CXTPRibbonOffice2013Theme derived class used to represent a Native Windows 10 ribbon theme
C CXTPRibbonThemeNativeWindows11 | CXTPRibbonThemeNativeWindows11 is a CXTPRibbonOffice2013Theme derived class used to represent a Native Windows 10 ribbon theme
C CXTPRibbonThemeOffice2007System | CXTPRibbonThemeOffice2007System is a CXTPRibbonMarkupTheme derived class used to represent an Office 2007 ribbon theme
C CXTPRibbonThemeResource | CXTPRibbonThemeResource is a CXTPRibbonPaintManager derived class used to represent a Resource .DLL ribbon theme
C CXTPRibbonThemeVisualStudio2015 | CXTPRibbonThemeVisualStudio2015 is a CXTPRibbonOffice2013Theme derived class used to represent a Visual Studio 2015 ribbon theme
C CXTPRibbonThemeVisualStudio2017 | CXTPRibbonThemeVisualStudio2017 is a CXTPRibbonOffice2013Theme derived class used to represent a Visual Studio 2017 ribbon theme
C CXTPRibbonThemeVisualStudio2019 | CXTPRibbonThemeVisualStudio2019 is a CXTPRibbonOffice2013Theme derived class used to represent a Visual Studio 2019 ribbon theme
C CXTPRibbonThemeVisualStudio2022 | CXTPRibbonThemeVisualStudio2022 is a CXTPRibbonOffice2013Theme derived class used to represent a Visual Studio 2022 ribbon theme
►C CXTPRWCriticalSection | Implements recursive read-write lock synchronization pattern
C CExclusiveLock | A convenience class for obtaining exclusive lock for a scope
C CSharedLock | A convenience class for obtaining shared lock for a scope
C CXTPScrollable | The adaptor class for a scrollable control for which standard scroll bars have to be overriden
C CXTPScrollableEditT | An adaptor for any CEdit derived control that overrides standard scrollbars with custom scrollbars
C CXTPScrollableListBoxT | An adaptor for any CListBox derived control that overrides standard scrollbars with custom scrollbars
C CXTPScrollableListCtrlT | An adaptor for any CListCtrl derived control that overrides standard scrollbars with custom scrollbars
C CXTPScrollableTreeCtrlT | An adaptor for any CTreeCtrl derived control that overrides standard scrollbars with custom scrollbars
C CXTPScrollBar | Scrollbar control
C CXTPScrollBarContainer | CXTPScrollBarContainer class adds XTP scroll bars to a class derived from CWnd
C CXTPScrollBarCtrl | Scrollbar control
C CXTPScrollBarPaintManager | CXTPScrollBarPaintManager is standalone class used to draw CXTPCommandBarScrollBarCtrl object
C CXTPScrollBarThemeFlat | Scrollbar paint manager used to draw flat scrollbars
C CXTPScrollBarThemeNativeWindows10 | Scrollbar paint manager used to draw Native Windows 10 like scrollbars
C CXTPScrollBarThemeNativeWindows11 | Scrollbar paint manager used to draw Native Windows 10 like scrollbars
C CXTPScrollBarThemeOffice2000 | Scrollbar paint manager used to draw Office 200 like scrollbars
C CXTPScrollBarThemeOffice2003 | Scrollbar paint manager used to draw Office 2003 like scrollbars
C CXTPScrollBarThemeOffice2013 | Used to enable a Gallery Office 2013 style theme for Command Bars
C CXTPScrollBarThemeOfficeXP | Scrollbar paint manager used to draw Office XP like scrollbars
C CXTPScrollBarThemeResource | Scrollbar paint manager used to draw scrollbars from the currently loaded resource image data
C CXTPScrollBarThemeUltraFlat | Scrollbar paint manager used to draw ultra flat scrollbars
C CXTPScrollBarThemeVisualStudio2012 | Scrollbar paint manager used to draw Visual Studio 2012 like scrollbars
C CXTPScrollBarThemeVisualStudio2015 | Scrollbar paint manager used to draw Visual Studio 2015 like scrollbars
C CXTPScrollBarThemeVisualStudio2017 | Scrollbar paint manager used to draw Visual Studio 2017 like scrollbars
C CXTPScrollBarThemeVisualStudio2019 | Scrollbar paint manager used to draw Visual Studio 2019 like scrollbars
C CXTPScrollBarThemeVisualStudio2022 | Scrollbar paint manager used to draw Visual Studio 2022 like scrollbars
C CXTPScrollBarThemeWindowsClassic | Scrollbar paint manager used to draw classic Windows scrollbars
C CXTPScrollBarThemeWindowsUx | Scrollbar paint manager used to draw scrollbars that use current Windows theme
C CXTPScrollBase | CXTPScrollBase is the base class for all scrollable objects
C CXTPScrollDateButtonPart | This class implements Scroll Date button part of the ScrollDateBar
C CXTPSearchOptionsCtrl | CXTPSearchOptionsCtrl is a CStatic derived class
C CXTPSearchOptionsView | CXTPSearchOptionsView is a CFormView derived class
C CXTPShadowManager | CXTPShadowManager is standalone class used to manage CommandBars' shadows
C CXTPShellExplorerProvider | Implements ShellExplorer WebBrowser provider and gives access to ShellExplorer specific functionality
C CXTPShellListBase | CXTPShellListBase is a multiple inheritance class derived from CXTPListView and CXTPShellPidl
C CXTPShellListCtrl | CXTPShellListCtrl is a multiple inheritance class derived from CXTPListCtrl and CXTPShellPidl
C CXTPShellListCtrlEx | CXTPShellListCtrlEx is a CXTPShellListCtrl derived class
C CXTPShellListView | CXTPShellListView is a multiple inheritance class derived from CXTPListView and CXTPShellPidl
►C CXTPShellPidl | CXTPShellPidl is a standalone base class
C CShellMalloc | CXTPShellPidl::CShellMalloc is a helper class that is used by CXTPShellPidl to initialize a pointer to the Shell's IMalloc interface used for allocating memory blocks
C CShellSpecialFolder | CXTPShellPidl::CShellSpecialFolder is a helper class that is used by CXTPShellPidl to initialize a pointer to an ITEMIDLIST structure of a special folder
C CXTPShellSettings | CXTPShellSettings is a SHELLFLAGSTATE struct derived class
C CXTPShellTreeBase | CXTPShellTreeBase is a multiple inheritance class derived from CXTPTreeView and CXTPShellPidl
C CXTPShellTreeCtrl | CXTPShellTreeCtrl is a multiple inheritance class derived from CXTPTreeCtrl and CXTPShellPidl
C CXTPShellTreeView | CXTPShellTreeView is a multiple inheritance class derived from CXTPTreeView and CXTPShellPidl
C CXTPShortcutBar | CXTPShortcutBar is a CWnd derived class used to implement an Outlook 2003 shortcut bar control style
C CXTPShortcutBarItem | CXTPShortcutBarItem is a base class that represents an item for a shortcut bar control
C CXTPShortcutBarNativeWindows10Theme | CXTPShortcutBarNativeWindows10Theme is a CXTPShortcutBarOffice2013Theme derived class that represents a Native Windows 10 shortcut bar theme
C CXTPShortcutBarNativeWindows11Theme | CXTPShortcutBarNativeWindows11Theme is a CXTPShortcutBarOffice2013Theme derived class that represents a Native Windows 10 shortcut bar theme
C CXTPShortcutBarNativeWinXPTheme | CXTPShortcutBarNativeWinXPTheme is a CXTPShortcutBarOffice2003Theme derived class that represents a Native Windows XP shortcut bar theme
C CXTPShortcutBarOffice2000Theme | CXTPShortcutBarOffice2000Theme is a CXTPShortcutBarPaintManager derived class that represents an Office 2000 shortcut bar theme
C CXTPShortcutBarOffice2003Theme | CXTPShortcutBarOffice2003Theme is a CXTPShortcutBarPaintManager derived class that represents an Office 2003 shortcut bar theme
C CXTPShortcutBarOffice2013Theme | CXTPShortcutBarOffice2013Theme is a CXTPShortcutBarResourceTheme derived class that represents an Office 2013 shortcut bar theme
C CXTPShortcutBarOfficeXPTheme | CXTPShortcutBarOfficeXPTheme is a CXTPShortcutBarPaintManager derived class that represents an Office XP shortcut bar theme
C CXTPShortcutBarPaintManager | CXTPShortcutBarPaintManager is a standalone class used as a paint manager for a shortcut bar control
C CXTPShortcutBarPane | CXTPShortcutBarPane is a CWnd derived class used as a client area for a shortcut bar control
C CXTPShortcutBarPaneItem | CXTPShortcutBarPaneItem is a base class that represents an item for a shortcut bar pane
C CXTPShortcutBarResourceTheme | CXTPShortcutBarResourceTheme is a CXTPShortcutBarOffice2003Theme derived class that represents the Office 2007, 2010 and 2012 shortcut bar themes
C CXTPShortcutBarVisualStudio2015Theme | CXTPShortcutBarVisualStudio2015Theme is a CXTPShortcutBarOffice2013Theme derived class that represents a Visual Studio 2015 shortcut bar theme
C CXTPShortcutBarVisualStudio2017Theme | CXTPShortcutBarVisualStudio2017Theme is a CXTPShortcutBarOffice2013Theme derived class that represents a Visual Studio 2017 shortcut bar theme
C CXTPShortcutBarVisualStudio2019Theme | CXTPShortcutBarVisualStudio2019Theme is a CXTPShortcutBarOffice2013Theme derived class that represents a Visual Studio 2019 shortcut bar theme
C CXTPShortcutBarVisualStudio2022Theme | CXTPShortcutBarVisualStudio2022Theme is a CXTPShortcutBarOffice2013Theme derived class that represents a Visual Studio 2022 shortcut bar theme
►C CXTPShortcutListBox | CCXTPShortcutListBox is a CListBox derived class
C CONTENT_ITEM | CONTENT_ITEM structure is used by the CXTPShortcutListBox class to maintain information about a particular menu item
C CXTPShortcutListBoxTheme | CXTPShortcutListBoxTheme is used to draw the CXTPShortcutListBox object
C CXTPShortcutListBoxThemeOffice2003 | Class CXTPShortcutListBoxThemeOffice2003 is derived from CXTPShortcutListBoxThemeXP
C CXTPShortcutListBoxThemeOfficeXP | Class CXTPShortcutListBoxThemeOfficeXP is derived from CXTPShortcutListBoxTheme
C CXTPShortcutManager | CXTPShortcutManager is a standalone class used to manipulate accelerators of a frame
C CXTPShortcutManagerAccel | CXTPShortcutManagerAccel represents an accelerator key used in an accelerator table
C CXTPShortcutManagerAccelTable | CXTPShortcutManagerAccelTable represents an accelerator table for the CXTPShortcutManager class
►C CXTPSimpleCriticalSection | Implements simple and lightweight synchronization critical section primitive
C CLock | A helper class for locking a scope or providing exception safe locking
C CXTPSimpleEvent | Implements no-named simple and lightweight synchronization event primitive
C CXTPSingleton | Implements Singleton design pattern
C CXTPSingletonBase | Implements Singleton design pattern for a derived class with possibility of providing a parent class
C CXTPSingletonDependencies | Describes the list of up to 10 optional singleton dependencies
C CXTPSingletonPointer | Implements Singleton design pattern for a pointer of unspecified type that is to be allocated, created and destroyed by a client
C CXTPSizeIcon | CStatic derived helper class
C CXTPSizeT | This class incapsulates size data
C CXTPSkinImage | Simple bitmap holder and draw operations for Skin Framework
C CXTPSkinImages | CXTPSkinImages represents a cached collection of CXTPSkinImage classes
C CXTPSkinManager | CXTPSkinManager is a standalone class that represents a global object that manages skins
C CXTPSkinManagerClass | CXTPSkinManagerClass is a standalone class that represents a single visual class of the skin manager
C CXTPSkinManagerColorFilter | CXTPSkinManagerColorFilter represents the parent class for all color filters of skin manager
C CXTPSkinManagerMetrics | CXTPSkinManagerMetrics is a standalone class that represents a collection of metrics of the current skin
C CXTPSkinManagerResourceFile | CXTPSkinManagerResourceFile is a standalone class that represents a manager of visual style resources
C CXTPSkinManagerSchema | CXTPSkinManagerSchema is a standalone class used to read a visual styles schema file
C CXTPSkinManagerSchemaProperty | CXTPSkinManagerSchemaProperty is a standalone class representing a single property of a visual styles .ini file
C CXTPSkinObject | CXTPSkinObject is a CWnd derived class
C CXTPSkinObjectButton | CXTPSkinObjectButton is a CXTPSkinObjectFrame derived class
C CXTPSkinObjectClassMap | CXTPSkinObjectClassMap is a standalone class that helps map windows controls to skin framework classes
C CXTPSkinObjectComboBox | CXTPSkinObjectComboBox is a CXTPSkinObjectFrame derived class
C CXTPSkinObjectComCtl32Control | CXTPSkinObjectComCtl32Control is a CXTPSkinObjectUser32Control derived class
C CXTPSkinObjectDateTime | CXTPSkinObjectDateTime is a CXTPSkinObjectComboBox derived class
C CXTPSkinObjectEdit | CXTPSkinObjectEdit is a CXTPSkinObjectUser32Control derived class
►C CXTPSkinObjectFrame | CXTPSkinObjectFrame is a CXTPSkinObject derived class
C CCaptionButton | Caption button class
C CXTPSkinObjectHeader | CXTPSkinObjectHeader is a CXTPSkinObjectFrame derived class
C CXTPSkinObjectListBox | CXTPSkinObjectListBox is a CXTPSkinObjectUser32Control derived class
C CXTPSkinObjectListView | CXTPSkinObjectListView is a CXTPSkinObjectComCtl32Control derived class
C CXTPSkinObjectMonthCal | CXTPSkinObjectMonthCal is a CXTPSkinObjectFrame derived class
C CXTPSkinObjectProgress | CXTPSkinObjectProgress is a CXTPSkinObjectFrame derived class
C CXTPSkinObjectReBar | CXTPSkinObjectReBar is a CXTPSkinObjectFrame derived class
C CXTPSkinObjectScrollBar | CXTPSkinObjectScrollBar is a CXTPSkinObjectFrame derived class
C CXTPSkinObjectSolidFilled | CXTPSkinObjectSolidFilled is a CXTPSkinObjectFrame derived class
C CXTPSkinObjectSpin | CXTPSkinObjectSpin is a CXTPSkinObjectFrame derived class
C CXTPSkinObjectStatusBar | CXTPSkinObjectStatusBar is a CXTPSkinObjectFrame derived class
C CXTPSkinObjectTab | CXTPSkinObjectTab is a CXTPSkinObjectFrame derived class
C CXTPSkinObjectToolBar | CXTPSkinObjectToolBar is a CXTPSkinObjectFrame derived class
C CXTPSkinObjectTrackBar | CXTPSkinObjectTrackBar is a CXTPSkinObjectFrame derived class
C CXTPSkinObjectTreeView | CXTPSkinObjectTreeView is a CXTPSkinObjectComCtl32Control derived class
C CXTPSkinObjectUser32Control | CXTPSkinObjectUser32Control is a CXTPSkinObjectFrame derived class
C CXTPSliderPaintManager | Paint manager for the slider control
C CXTPSmartPtrInternalT |
►C CXTPSortClass | CXTPSortClass is a standalone class
C ITEMDATA | This structure is used by the CXTPSortClass for storing a temporary item data pointer that contains each list item's name (used for sorting) and original item data (if any)
C CXTPSoundManager | CXTPSoundManager is a standalone class
C CXTPSpinButtonCtrl | Functionality of a themed Windows spin button control
C CXTPSplitPath | CXTPSplitPath conveniently wraps the _splitpath API for easier access to path components such as file name and extension
C CXTPSplitterWnd | CXTPSplitterWnd is a CSplitterWnd derived class
C CXTPSplitterWndEx | CXTPSplitterWndEx is a CXTPSplitterWnd derived class
C CXTPSplitterWndTheme | Class CXTPSplitterWndTheme is derived from CXTPControlTheme
C CXTPSplitterWndThemeOffice2003 | Class CXTPSplitterWndThemeOffice2003 is derived from CXTPSplitterWndTheme
C CXTPSplitterWndThemeOffice2013 | Class CXTPSplitterWndThemeOffice2013 is derived from CXTPSplitterWndThemeOfficeXP
C CXTPSplitterWndThemeOfficeXP | Class CXTPSplitterWndThemeOfficeXP is derived from CXTPSplitterWndTheme
C CXTPSplitterWndThemeResource | Class CXTPSplitterWndThemeResource is derived from CXTPSplitterWndTheme
C CXTPSplitterWndThemeVisualStudio2010 | Class CXTPSplitterWndThemeVisualStudio2010 is derived from CXTPSplitterWndTheme
C CXTPSplitterWndThemeVisualStudio2015 | Class CXTPSplitterWndThemeVisualStudio2015 is derived from CXTPSplitterWndThemeOffice2013
C CXTPSplitterWndThemeVisualStudio2017 | Class CXTPSplitterWndThemeVisualStudio2017 is derived from CXTPSplitterWndThemeOffice2013
C CXTPSplitterWndThemeVisualStudio2019 | Class CXTPSplitterWndThemeVisualStudio2019 is derived from CXTPSplitterWndThemeOffice2013
C CXTPSplitterWndThemeVisualStudio2022 | Class CXTPSplitterWndThemeVisualStudio2022 is derived from CXTPSplitterWndThemeOffice2013
C CXTPStatusBar | CXTPStatusBar is a CControlBar derived class
C CXTPStatusBarPane | CXTPStatusBarPane is a CXTPCmdTarget derived class
C CXTPStatusBarProgressPane | CXTPStatusBarProgressPane is a CXTPStatusBarPane derived class
C CXTPStatusBarScrollBarPane | CXTPStatusBarScrollBarPane is a CXTPStatusBarPane derived class
C CXTPStatusBarSliderPane | CXTPStatusBarSliderPane is a CXTPStatusBarPane derived class
►C CXTPStatusBarSwitchPane | CXTPStatusBarSwitchPane is a CXTPStatusBarPane derived class
C SWITCH | Holds status bar pane switch properties
C CXTPStatusBarThemeNativeWindows10 | Used to enable the Native Windows 10 style theme for the status bar
C CXTPStatusBarThemeNativeWindows11 | Used to enable the Native Windows 10 style theme for the status bar
C CXTPStatusBarThemeOffice2013 | The CXTPStatusBarThemeVisualStudio2015 class is used to enable the Office 2013 style theme for the status bar
C CXTPStatusBarThemeVisualStudio2015 | Used to enable the Visual Studio 2015 style theme for the status bar
C CXTPStatusBarThemeVisualStudio2017 | Used to enable the Visual Studio 2017 style theme for the status bar
C CXTPStatusBarThemeVisualStudio2019 | Used to enable the Visual Studio 2019 style theme for the status bar
C CXTPStatusBarThemeVisualStudio2022 | Used to enable the Visual Studio 2022 style theme for the status bar
C CXTPStickerBase | A sticker base control
C CXTPSubscriptionList | Holds a list of observable objects to which an oberser is subscribed
C CXTPSvgImage | Implements basic SVG image format support
C CXTPSvgPreviewProvider | Provides a preview handler for XAML files that uses Markup components for rendering file contents
C CXTPSwitchViewButtonPart | This class implements SwitchView button part of the SwitchViewBar
C CXTPSynchronized | A base class for a synchronized object
C CXTPSyntaxEditAutoCompleteWnd | This class implements the auto-complete window
C CXTPSyntaxEditBatchCommand | This class represents a pack of commands in one
►C CXTPSyntaxEditBufferCommand | The base class for all edit commands related to CXTPSyntaxEditBufferManager
C CXTPSyntaxEditBufferKeepOverwriteSettings | Keeps the buffer overwrite flag for the specified buffer manager from class construction until destruction, and resets this flag to FALSE during class lifetime
►C CXTPSyntaxEditBufferManager | This class is the main class for buffer management
►C CXTPSyntaxEditStringsManager | This is helper class designed to manage a set of strings
C CStringPtrArray | Internal class, implements a collection of strings
C CXTPSyntaxEditColorComboBox | This class allows for colors to be edited by using a combobox control
C CXTPSyntaxEditColorInfo | This storage class is designed to contain information from the color settings file section
C CXTPSyntaxEditColorInfoArray | This collection class stores the color info objects
C CXTPSyntaxEditColorSampleText | This class, derived from CStatic, is used to display a sample of colored text
C CXTPSyntaxEditColorTheme | This class provides the functionality to read configuration information from configuration files with a predefined structure
C CXTPSyntaxEditColorThemesManager | This class provides the functionality to store the set of all color themes that would be written from configuration files
C CXTPSyntaxEditCommand | This class represents an abstract Edit Control command interface
C CXTPSyntaxEditConfigurationManager | This class manages all configuration parameters of the control
►C CXTPSyntaxEditCtrl | This class is the main CWnd-based editor class
C CAverageVal | CXTPSyntaxEditCtrl::CAverageVal
C CXTPSyntaxEditDeleteStringCommand | This class represents the delete string command
C CXTPSyntaxEditDoc | This class represents the Document portion of an Edit control
C CXTPSyntaxEditDrawTextProcessor | This helper class is used by CXTPSyntaxEditCtrl as the Draw Text Processor
C CXTPSyntaxEditFileChangesMonitor | This class monitors files changes
C CXTPSyntaxEditFindReplaceDlg | This class implements the "Find and Replace" and "Find" dialogs for a SyntaxEdit control
C CXTPSyntaxEditGoToLineDlg | This class implements the "GoToLine" dialog for a SyntaxEdit control
C CXTPSyntaxEditInsertStringCommand | This class represents the insert string command
C CXTPSyntaxEditLexClass | CXTPSyntaxEditLexClass class is used to represent lexical block of text definition and to parse text
C CXTPSyntaxEditLexOnScreenParseCnt | CXTPSyntaxEditLexOnScreenParseCnt provides context data storage for OnScreen iterated parsing process
C CXTPSyntaxEditLexParser | This class used to 'run' lex schema parsing in a separate thread
C CXTPSyntaxEditLexParserSchemaOptions | This class is designed to easily manipulate parser options
C CXTPSyntaxEditLexTextBlock | Block of text which corresponds to a lex class in a text schema
C CXTPSyntaxEditLexTextSchema | Used to store data which is necessary to parse a text and parsing results
C CXTPSyntaxEditLexTokensDef | This class stores tokens definition: a list of tokens and corresponding lists of start and end tokens separators
C CXTPSyntaxEditLexVariable | XTPSyntaxEditLexAnalyser namespace is used group text parser classes, separate them from others and to make class names shorter without risk to be duplicated
C CXTPSyntaxEditLexVariant | CXTPSyntaxEditLexVariant provides functionality to manipulate Lexical Analyzer's related variant type
C CXTPSyntaxEditLineMarksManager | Functionality to manipulate marks on text lines
C CXTPSyntaxEditOptions | Shared Options of SyntaxEdit
C CXTPSyntaxEditPaintManager | This class is used by CXTPSyntaxEditCtrl as the paint manager
C CXTPSyntaxEditPropertiesDlg | This class provides a default dialog to edit SyntaxEdit control settings
C CXTPSyntaxEditPropertiesPageColor | This class implements property page colors options
C CXTPSyntaxEditPropertiesPageEdit | This class implements a property page for common edit options
C CXTPSyntaxEditPropertiesPageFont | This class implements property page font options
C CXTPSyntaxEditReplaceStringCommand | This class represents the replace string command
C CXTPSyntaxEditSelection | This class is used to represent syntax edit text selection and allows for selection properties to be get and set in two measurements: string and display
C CXTPSyntaxEditTextIterator | This class provides functionality to navigate text in the data buffer, seek forward/backward, retrieve text by lines, and determine control symbols like CRLF
C CXTPSyntaxEditTextRegion | This class is designed to store the coordinates of a text region
C CXTPSyntaxEditTextSchemesManager | This class provides the functionality to store the set of all text schemes that would be written from configuration files
C CXTPSyntaxEditTipComboBox | This class implements a combo box with a tooltip
C CXTPSyntaxEditTipListBox | This class implements a list box with a tooltip
C CXTPSyntaxEditTipWnd | CXTPSyntaxEditTipWnd implements a tooltip window for the CXTPSyntaxEditTipListBox class
C CXTPSyntaxEditToolTipCtrl | Encapsulates the functionality of a "tip control," a small pop-up window that displays a single line of text describing the hidden text when hovering over an item on the report area
C CXTPSyntaxEditUndoRedoManager | This class maintains the list of undo/redo commands
C CXTPSyntaxEditView | This class represents a View portion of the Edit Control
C CXTPSyntaxEditViewPrintOptions | Describes printing options for the Calendar control
C CXTPSystemMetrics | Used to store and update sytem information
C CXTPSystemPreviewProvider | Provides a preview handler that uses supported system means for previewing files
C CXTPSystemVersion | CXTPSystemVersion is used to get the current Windows OS version
C CXTPTabBase | CXTPTabBase is a standalone base class
C CXTPTabBaseTheme | CXTPTabBaseTheme is used to draw the CXTPTabBase object
C CXTPTabBaseThemeOffice2003 | Class CXTPTabBaseThemeOffice2003 is derived from CXTPTabBaseThemeOfficeXP
C CXTPTabBaseThemeOfficeXP | Class CXTPTabBaseThemeOfficeXP is derived from CXTPTabBaseTheme
C CXTPTabClientContext | CXTPTabClientContext is a standalone class
C CXTPTabClientDraggingContents | Managers tab client dragging contents
C CXTPTabClientSticker | A tab client sticker control
C CXTPTabClientWnd | CXTPTabClientWnd is a CWnd derived class
C CXTPTabColorSetDefault | CXTPTabColorSetDefault implements a default tab color set
C CXTPTabColorSetNativeWindows10 | CXTPTabColorSetNativeWindows10 implements a Native Windows 10 tab color set
C CXTPTabColorSetNativeWindows11 | CXTPTabColorSetNativeWindows11 implements a Native Windows 10 tab color set
C CXTPTabColorSetOffice2003 | CXTPTabColorSetOffice2003 implements an Office 2003 tab color set
C CXTPTabColorSetOffice2007 | CXTPTabColorSetOffice2007 implements an Office 2007 tab color set
C CXTPTabColorSetOffice2007Access | CXTPTabColorSetOffice2007Access implements an Office 2007 Access tab color set
C CXTPTabColorSetOffice2013 | CXTPTabColorSetOffice2013 implements an Office 2013 tab color set
C CXTPTabColorSetVisualStudio2008 | CXTPTabColorSetVisualStudio2008 implements a Visual Studio 2008 tab color set
C CXTPTabColorSetVisualStudio2010 | CXTPTabColorSetVisualStudio2010 implements a Visual Studio 2010 tab color set
C CXTPTabColorSetVisualStudio2012 | CXTPTabColorSetVisualStudio2012 implements a Visual Studio 2012 tab color set
C CXTPTabColorSetVisualStudio2012Dark | CXTPTabColorSetVisualStudio2012Dark implements a Visual Studio 2012 Dark tab color set
C CXTPTabColorSetVisualStudio2015 | CXTPTabColorSetVisualStudio2015 implements a Visual Studio 2015 tab color set
C CXTPTabColorSetVisualStudio2017 | CXTPTabColorSetVisualStudio2017 implements a Visual Studio 2017 tab color set
C CXTPTabColorSetVisualStudio2019 | CXTPTabColorSetVisualStudio2019 implements a Visual Studio 2019 tab color set
C CXTPTabColorSetVisualStudio2022 | CXTPTabColorSetVisualStudio2022 implements a Visual Studio 2022 tab color set
C CXTPTabControl | CXTPTabControl is used to draw an enhanced tab control with Office 2003, Visual Studio, or Win XP tabs
C CXTPTabCtrl | CXTPTabCtrl is a multiple inheritance class derived from CTabCtrl and CXTPTabCtrlBase
C CXTPTabCtrlButton | CXTPTabCtrlButton is a standalone structure class
C CXTPTabCtrlButtons | CXTPTabCtrlButtons is a CWnd derived class
C CXTPTabExBase | CXTPTabExBase is a standalone base class
►C CXTPTabManager | CXTPTabManager is the base class for docking pane tabs, tab control tabs, and MDI client tabs
C CRowIndexer | Helper class used to collect the indices of rows for a multi-row tab manager
C ROW_ITEMS | Helper structure that contains the first and last item indices of rows of the tab manager
C CXTPTabManagerAtom | CXTPTabManagerAtom is a class that has only one purpose; to catch the event when a property of the PaintManager is changed
C CXTPTabManagerItem | CXTPTabManagerItem is the base class for the tabs that appear in the command bars tab workspace, docking panes, and tab control
C CXTPTabManagerNavigateButton | CXTPTabManagerNavigateButton is a class used to represent a tab navigation button
C CXTPTabManagerNavigateButtons | CXTPTabManagerNavigateButtons is a class used to represent a collection of tab navigation buttons
C CXTPTabPaintManager | CXTPTabPaintManager is used to store the color and appearance information of the tabs in the tab manager
►C CXTPTabPaintManagerColorSet | CXTPTabPaintManagerColorSet represents the colors for all of the components of the tab manager (e.g
C COLORSET_TAB_EXCEL | Colors used for Excel tab button colorization
C COLORSET_TAB_PROPERTYPAGE | Colors used for Office 2000 tab button colorization
C COLORSET_TAB_PROPERTYPAGE2003 | Colors used for Office 2003 tab button colorization
C COLORSET_TAB_STATEBUTTON | Colors used for "State Button" tab button colorization
C CXTPTabPaintManagerTheme | CXTPTabPaintManagerTheme is a class that represents the appearance of all components of the tab manager (e.g
C CXTPTabThemeExcel2003 | CXTPTabThemeExcel2003 implements an Excel tab appearance
C CXTPTabThemeFlat | CXTPTabThemeFlat implements a "Flat" tab appearance
C CXTPTabThemeNativeWindows10 | CXTPTabThemeNativeWindows10 implements a Native Windows 10 tab appearance
C CXTPTabThemeNativeWindows11 | CXTPTabThemeNativeWindows11 implements a Native Windows 10 tab appearance
C CXTPTabThemeOffice2000 | CXTPTabThemeOffice2000 implements an Office 2000 tab appearance
C CXTPTabThemeOffice2013 | CXTPTabThemeOffice2013 implements an Office 2013 tab appearance
C CXTPTabThemeVisualStudio2003 | CXTPTabThemeVisualStudio2003 implements a Visual Studio 2003 tab appearance
C CXTPTabThemeVisualStudio2010 | CXTPTabThemeVisualStudio2010 implements a Visual Studio 2010 tab appearance
C CXTPTabThemeVisualStudio2012 | CXTPTabThemeVisualStudio2012 implements a Visual Studio 2012 tab appearance
C CXTPTabThemeVisualStudio2015 | CXTPTabThemeVisualStudio2015 implements a Visual Studio 2015 tab appearance
C CXTPTabThemeVisualStudio2017 | CXTPTabThemeVisualStudio2017 implements a Visual Studio 2017 tab appearance
C CXTPTabThemeVisualStudio2019 | CXTPTabThemeVisualStudio2019 implements a Visual Studio 2019 tab appearance
C CXTPTabThemeVisualStudio2022 | CXTPTabThemeVisualStudio2022 implements a Visual Studio 2022 tab appearance
C CXTPTabToolBar | CXTPTabToolBar is a CXTPToolBar derived class
C CXTPTabView | CXTPTabView is a multiple inheritance class derived from CCtrlView and CXTPTabCtrlBaseEx
C CXTPTagCloudCtrl | Used to create a tag cloud control representing a visual depiction of generated tags identified by color and font size to represent the prominence or frequency of the tags depicted
C CXTPTagCloudStyle | CXTPTagCloudStyle is a helper class used by CXTPTagCloudStyleManager to manage styles for the CXTPTagCloudCtrl class
C CXTPTagCloudStyleManager | CXTPTagCloudStyleManager is a singleton class used to manage CXTPTagCloudStyle structs that identify each tag style used by CXTPTagCloudCtrl
C CXTPTagCloudTagArray | CXTPTagCloudTagArray is a CArray derived class used to manage XTP_TAGCLOUDTAG objects for the CXTPTagCloudCtrl class
C CXTPTaskButtonTheme | CXTPTaskButtonTheme
C CXTPTaskButtonThemeExpando | CXTPTaskButtonThemeExpando
C CXTPTaskDialog | Creates, displays, and operates a task dialog
C CXTPTaskDialogClient | CXTPTaskDialogClient window
►C CXTPTaskDialogLinkCtrl | CXTPTaskDialogLinkCtrl is a CStatic derived class that is used to display a text block that contains clickable links
C LINKITEM | LINKITEM is used to set and retrieve information about a link item
C CXTPTaskDialogProgressCtrl | CXTPTaskDialogProgressCtrl
►C CXTPTaskPanel | CXTPTaskPanel is used to implement an Explorer and Office-like Task Panel control
C CRepositionContext | CRepositionContext is a helper class used to lock/unlock redraw for the Task Panel
C CXTPTaskPanelExplorerTheme | CXTPTaskPanelExplorerTheme represents an Explorer style theme
C CXTPTaskPanelExplorerThemePlain | CXTPTaskPanelExplorerThemePlain represents a classic Explorer style theme
C CXTPTaskPanelGroup | CXTPTaskPanelGroup is used in a Task Panel control to represent a group
C CXTPTaskPanelGroupItem | CXTPTaskPanelGroupItem is used in a TaskPanel control to represent a single item of a group
C CXTPTaskPanelGroupItems | CXTPTaskPanelGroupItems represents a collection of items in a group
C CXTPTaskPanelGroups | CXTPTaskPanelGroups represents a collection of groups in a Task Panel control
C CXTPTaskPanelItem | CXTPTaskPanelItem is used in a Task Panel control to represent a single item
C CXTPTaskPanelItems | CXTPTaskPanelItems is used in a Task Panel control to represent a collection of items
C CXTPTaskPanelListViewOffice2003Theme | CXTPTaskPanelListViewOffice2003Theme represents a List View Office 2003 style theme
C CXTPTaskPanelListViewOfficeXPTheme | CXTPTaskPanelListViewOfficeXPTheme represents a List View Office XP style theme
C CXTPTaskPanelListViewTheme | CXTPTaskPanelListViewTheme class represents a List View style theme
C CXTPTaskPanelNativeWindows10Theme | CXTPTaskPanelNativeWindows10Theme represents a Native Windows 10 style theme
C CXTPTaskPanelNativeWindows11Theme | CXTPTaskPanelNativeWindows11Theme represents a Native Windows 10 style theme
C CXTPTaskPanelOffice2003Theme | CXTPTaskPanelOffice2003Theme represents an Office 2003 style theme
C CXTPTaskPanelOffice2003ThemePlain | CXTPTaskPanelOffice2003ThemePlain represents a classic Office 2003 style theme
C CXTPTaskPanelOffice2013Theme | CXTPTaskPanelOffice2013Theme represents an Office 2013 style theme
C CXTPTaskPanelOfficeXPThemePlain | CXTPTaskPanelOfficeXPThemePlain represents a classic Office XP style theme
C CXTPTaskPanelPaintManager | CXTPTaskPanelPaintManager is a standalone class used by CXTPTaskPanel as a paint manager
C CXTPTaskPanelPaintManagerPlain | Base class theme that all other themes are derived from
C CXTPTaskPanelScrollButton | CXTPTaskPanelScrollButton is a standalone class that represents a task panel scroll button
C CXTPTaskPanelShortcutBarOffice2003Theme | CXTPTaskPanelShortcutBarOffice2003Theme represents an Office 2003 ShortcutBar style theme
C CXTPTaskPanelShortcutBarOffice2007Theme | CXTPTaskPanelShortcutBarOffice2007Theme represents an Office 2007 ShortcutBar style theme
C CXTPTaskPanelToolboxTheme | CXTPTaskPanelToolboxTheme represents a Toolbox style theme
C CXTPTaskPanelVisualStudio2005Theme | CXTPTaskPanelVisualStudio2005Theme represents a Visual Studio 2005 style theme
C CXTPTaskPanelVisualStudio2010Theme | CXTPTaskPanelVisualStudio2010Theme represents a VS.NET 2010 style theme
C CXTPTaskPanelVisualStudio2012Theme | CXTPTaskPanelVisualStudio2012Theme represents a VS.NET 2012 style theme
C CXTPTaskPanelVisualStudio2015Theme | CXTPTaskPanelVisualStudio2015Theme represents a Visutal Studio 2015 style theme
C CXTPTaskPanelVisualStudio2017Theme | CXTPTaskPanelVisualStudio2017Theme represents a Visutal Studio 2017 style theme
C CXTPTaskPanelVisualStudio2019Theme | CXTPTaskPanelVisualStudio2019Theme represents a Visutal Studio 2019 style theme
C CXTPTaskPanelVisualStudio2022Theme | CXTPTaskPanelVisualStudio2022Theme represents a Visutal Studio 2022 style theme
C CXTPTcbItem | Used to maintain information for a particular tab item in a CXTPExcelTabCtrl, CXTPTabCtrl, or CXTPTabView object
C CXTPTearOffFrame | The class represents a floating torn off frame
C CXTPTempColorMask | Can be used to temporarily set the color mask used by XTPImageManager when using images with different color masks
C CXTPTextOnPath | GDI+ drawing of text on path
C CXTPTextPreviewProvider | Provides a preview handler for the text file type (TXT)
C CXTPThemeDLL | CXTPThemeDLL is a helper class used to load Codejock theme resource DLLs
C CXTPThreadLocal | Implements thread local variable adapter
C CXTPTimeEdit | CXTPTimeEdit is a CXTPDateEdit derived class
C CXTPTipOfTheDay | CXTPTipOfTheDay is a CDialog derived class
C CXTPTipWindow | CXTPTipWindow is a CWnd derived class
C CXTPToolBar | CXTPToolBar is a CXTPCommandBar derived class
C CXTPToolhelpApi | A wrapper around the Toolhelp32 API
C CXTPToolTipContext | CXTPToolTipContext is a CXTPCmdTarget derived class
C CXTPToolTipContextToolTip | CXTPToolTipContextToolTip is CWnd derived class, the base class for custom tool tips
C CXTPTrackBlock | This class represents a track control block
►C CXTPTrackControl | This class represents a track control
C DRAGBLOCK | This structure abstracts the state of block being dragged
C CXTPTrackControlItem | This class represents a container cell for a set of blocks and keys and inherits basic functionality from the CXTPGridRecordItem class
C CXTPTrackHeader | This class represents a track control header
C CXTPTrackKey | This class represents a track control key
C CXTPTrackMarker | This class represents a track control marker
C CXTPTrackMarkers | This class abstracts the track control markers
C CXTPTrackPaintManager | This class represents a track control paint manager
C CXTPTrackSelectedBlocks | This class abstracts the selected blocks of the track control
C CXTPTrackThemeDefault | CXTPTrackThemeDefault is a CXTPTrackPaintManager derived class that represents an Office 97 style theme
C CXTPTrackThemeExplorer | CXTPTrackThemeExplorer is a CXTPTrackPaintManager derived class that represents an Explorer style theme
C CXTPTrackThemeNativeWindows10 | CXTPTrackThemeNativeWindows10 is a CXTPTrackThemeOffice2013 derived class that represents a Native Windows 10 style theme
C CXTPTrackThemeNativeWindows11 | CXTPTrackThemeNativeWindows11 is a CXTPTrackThemeOffice2013 derived class that represents a Native Windows 10 style theme
C CXTPTrackThemeOffice2003 | CXTPTrackThemeOffice2003 is a CXTPTrackPaintManager derived class that represents an Office 2003 style theme
C CXTPTrackThemeOffice2003Luna | CXTPTrackThemeOffice2003Luna is a CXTPTrackPaintManager derived class that represents an Office 2003 Luna style theme
C CXTPTrackThemeOffice2013 | CXTPTrackThemeOffice2013 is a CXTPTrackPaintManager derived class that represents an Office 2013 style theme
C CXTPTrackThemeOfficeXP | CXTPTrackThemeOfficeXP is a CXTPTrackPaintManager derived class that represents an Office XP style theme
C CXTPTrackThemeResource | CXTPTrackThemeResource is a CXTPTrackPaintManager derived class that represents a Resource style theme
C CXTPTrackThemeVisualStudio2012Blue | CXTPTrackThemeVisualStudio2012Blue is a CXTPTrackThemeOffice2013 derived class that represents a Visual Studio 2012 Blue style theme
C CXTPTrackThemeVisualStudio2012Dark | CXTPTrackThemeVisualStudio2012Dark is a CXTPTrackThemeOffice2013 derived class that represents a Visual Studio 2012 Dark style theme
C CXTPTrackThemeVisualStudio2012Light | CXTPTrackThemeVisualStudio2012Light is a CXTPTrackThemeOffice2013 derived class that represents a Visual Studio 2012 Light style theme
C CXTPTrackThemeVisualStudio2015 | CXTPTrackThemeVisualStudio2015 is a CXTPTrackThemeOffice2013 derived class that represents a Visual Studio 2015 style theme
C CXTPTrackThemeVisualStudio2017 | CXTPTrackThemeVisualStudio2017 is a CXTPTrackThemeOffice2013 derived class that represents a Visual Studio 2017 style theme
C CXTPTrackThemeVisualStudio2019 | CXTPTrackThemeVisualStudio2019 is a CXTPTrackThemeOffice2013 derived class that represents a Visual Studio 2019 style theme
C CXTPTrackThemeVisualStudio2022 | CXTPTrackThemeVisualStudio2022 is a CXTPTrackThemeOffice2013 derived class that represents a Visual Studio 2022 style theme
C CXTPTrackUndoAddBlockCommand | This class abstracts the undo add block command
C CXTPTrackUndoAddMarkerCommand | This class abstracts the undo add marker command
C CXTPTrackUndoCommand | This class abstracts the undo command
C CXTPTrackUndoDeleteBlockCommand | This class abstracts the undo delete block command
C CXTPTrackUndoDeleteMarkerCommand | This class abstracts the undo delete marker command
C CXTPTrackUndoGroupCommand | This class abstracts the undo commands in a group
C CXTPTrackUndoManager | This class abstracts an undo manager
C CXTPTrackUndoSetBlockPositionCommand | This class abstracts the undo set block position command
C CXTPTrackUndoSetMarkerPositionCommand | This class abstracts the undo set marker position command
C CXTPTransparentBitmap | CXTPTransparentBitmap is a helper class used to extract the transparent color from a transparent BitMap
C CXTPTrayIcon | CXTPTrayIcon is a CWnd derived class of the NOTIFYICONDATA structure
►C CXTPTreeBase | CXTPTreeBase is a CTreeView derived class
C CLRFONT | CLRFONT structure is used to by the CXTPShellTreeCtrl and CXTPShellTreeView classes to maintain font information for a particular tree item
C CXTPTreeCtrl | CXTPTreeCtrl is a CTreeCtrl derived class
C CXTPTreeNativeWindows10Theme | CXTPTreeNativeWindows10Theme is a CXTPTreeTheme derived class used to render a Native Windows 10 style tree
C CXTPTreeNativeWindows11Theme | CXTPTreeNativeWindows11Theme is a CXTPTreeTheme derived class used to render a Native Windows 11 style tree
C CXTPTreeOffice2013Theme | CXTPTreeOffice2013Theme is a CXTPTreeTheme derived class used to render a Office 2013 style tree
C CXTPTreeTheme | CXTPTreeTheme is a class used to perform tree control theme drawing tasks
C CXTPTreeView | CXTPTreeView is a CTreeView derived class
C CXTPTreeVisualStudio2012Theme | CXTPTreeVisualStudio2012Theme is a CXTPTreeTheme derived class used to render a Visual Studio 2012 style tree
C CXTPTreeVisualStudio2015Theme | CXTPTreeVisualStudio2015Theme is a CXTPTreeTheme derived class used to render a Visual Studio 2015 style tree
C CXTPTreeVisualStudio2017Theme | CXTPTreeVisualStudio2017Theme is a CXTPTreeTheme derived class used to render a Visual Studio 2017 style tree
C CXTPTreeVisualStudio2019Theme | CXTPTreeVisualStudio2019Theme is a CXTPTreeTheme derived class used to render a Visual Studio 2019 style tree
C CXTPTreeVisualStudio2022Theme | CXTPTreeVisualStudio2022Theme is a CXTPTreeTheme derived class used to render a Visual Studio 2022 style tree
C CXTPVisualStudio2005Theme | Used to enable a Visual Studio 2005 style theme for Command Bars
C CXTPVisualStudio2008Theme | Used to enable a Visual Studio 2008 style theme for Command Bars
C CXTPVisualStudio2010Theme | Used to enable a Visual Studio 2010 style theme for Command Bars
C CXTPWebBrowserCtrl | Implements the WebBrowser control that is capable of hosting different supported Web browsers
C CXTPWebBrowserProvider | Implements the base class for a WebBrowser provider
C CXTPWebViewProvider | Implements WebView2 WebBrowser provider and gives access to WebView2 specific functionality
C CXTPWinApp | All XTP application classes have to derive from CXTPWinApp instead of CWinApp or CWinAppEx
C CXTPWindowList | CXTPWindowList dialog
C CXTPWindowPos | CXTPWindowPos is a WINDOWPLACEMENT structure derived class
C CXTPWindowRect | CXTPWindowRect is a helper class used to retrieve the screen size for a specified window
C CXTPWinThemeWrapper | Wraps the UxTheme.dll visual theme API
C CXTPWinThread | All XTP threads should derive from CXTPWinThread instead of CWinThread in order to ensure compatibility with the main process thread that is derived from CXTPWinApp
C CXTPXamlPreviewProvider | Provides a preview handler for XAML files that uses Markup components for rendering file contents
C CXTPZipMemFile | Zipped memory file
C ITimeProvider | Interface for overriding the GetCurrentTime() function in calendar control
C IXTPApplicationEvents | Defines a callback interface for XTP application event sink
C IXTPFrameShadowManagerEvents | An interface for Frame Shadow Manager event listener
C IXTPGaugeClientSite | Provides a client site interface for a gauge control owner
C IXTPMarkupClientSite | Defines default implementation of the markup client site interface
C IXTPMarkupDeviceDependentImageSite | Describes an image site interface
C IXTPPreview | The base interface for a preview handler implementation
C IXTPPreviewHost | Interface implemented by the preview host control
C IXTPPreviewProvider | Interface to be implemented by a preview provider
C IXTPScrollable | This interface is to be implemented only by special scrollable controls that require overriding of scroll bars using CXTPScrollable adaptor and for which the default implementation of this interface by CXTPScrollable does not work
C IXTPSkinManagerWindowFilter | Implement this interface in order to provide custom configured window filter functionality
C IXTPWebBrowserEventSink | Describes default WebBrowser control event sink interface and providers default implementation of the event handlers
C NMXTPCHARHDR | Structure used as a parameter for XTP_FN_SETFORMAT and XTP_FN_GETFORMAT messages
C NMXTPCONTROL | This structure is passed as a parameter in CBN_XTP_EXECUTE message
C NMXTPSCROLL | The NMXTPSCROLL structure contains information about the scroll bar
C NMXTPTABCHANGE | Structure used as a parameter for TCN_SELCHANGING and TCN_SELCHANGE messages when a Ribbon tab is changed
C XTP_CALENDAR_DAYVIEWCELL_PARAMS | Set of parameters transferred from calendar items for an XTP_NC_CALENDAR_BEFORE_DRAW_DAYVIEWCELL notification
C XTP_CALENDAR_GETITEMTEXT_PARAMS | Set of parameters transferred from calendar items for an XTP_NC_CALENDAR_GETITEMTEXT notification
C XTP_CALENDAR_HITTESTINFO | Basic set of parameters transferred from calendar items to mouse handlers
C XTP_CALENDAR_HITTESTINFO_TIMELINE_VIEW | Set of parameters transferred from calendar items to mouse handlers
C XTP_CALENDAR_MONTHVIEW_DAYPOS | Defines a set of data and methods to easily manipulate with day positions in month view
C XTP_CALENDAR_PATTERN_END | This structure describes parameters of the end of the recurrence pattern type
►C XTP_CALENDAR_RECURRENCE_OPTIONS | This structure defines a set of Recurrence Pattern options and is used by a CXTPRecurrencePattern to easily manage and transfer recurrence pattern data
C PATTERN_DAILY | Defines a group of parameters to describe the Daily pattern
C PATTERN_MONTHLY | Defines a group of parameters to describe the Month pattern
C PATTERN_MONTHNTH | Defines a group of parameters to describe the Month pattern
C PATTERN_WEEKLY | Defines a group of parameters to describe the Weekly pattern
C PATTERN_YEARLY | Defines a group of parameters to describe the Year pattern
C PATTERN_YEARNTH | Defines a group of parameters to describe the Year pattern
C XTP_CALENDAR_THEME_DAYVIEWCELL_PARAMS | Set of parameters transferred from calendar items for an XTP_NC_CALENDAR_BEFORE_DRAW_THEMEOBJECT notification
C XTP_CALENDAR_THEME_DAYVIEWTIMESCALECELL_PARAMS | Set of parameters transferred from calendar items for an XTP_NC_CALENDAR_BEFORE_DRAW_THEMEOBJECT notification
C XTP_CALENDAR_TIMELINE_VIEW_SCALE | Timeline's view scale
►C XTP_CALENDAR_USERACTION_PARAMS | Set of parameters transferred from calendar items for an XTP_NC_CALENDAR_USERACTION notification
C EXPANDDAYBUTTONACTION_PARAMS | Defines parameters for xtpCalendarUserAction_OnExpandDay user action
C SCROLLDAYBUTTONACTION_PARAMS | Defines parameters for xtpCalendarUserAction_OnScrollDay user action
C XTP_CALENDAR_VIEWSELECTION | Structure contains the calendar day view selection block
C XTP_CALENDAR_WPARAM2 | Doubled custom parameter for notifications
C XTP_COMMANDBARS_CATEGORYINFO | This structure stores categories for CXTPCustomizeCommandsPage and CXTPCustomizeKeyboardPage option pages
C XTP_COMMANDBARS_CREATEBAR | Creates a bar structure
C XTP_COMMANDBARS_CREATECONTROL | Creates a control structure
C XTP_COMMANDBARS_ICONSINFO | This structure collect icons options for command bars
C XTP_COMMANDBARS_PROPEXCHANGE_PARAM | XTP_COMMANDBARS_PROPEXCHANGE_PARAM is a structure used to store the CommandBar's save settings
C XTP_DAYITEM_METRICS | This structure represents a set of parameters which are used to display day items
C XTP_DOCKINGPANE_ACTION | The XTP_DOCKINGPANE_ACTION structure contains information about the action performed by the user with docking panes
C XTP_DOCKINGPANE_CLICK | The XTP_DOCKINGPANE_CLICK structure contains information about the pane that was used in an XTP_DPN_PANEMENUCLICK message
C XTP_DOCKINGPANE_INFO | Internal structure used by the Layout manager
C XTP_EDIT_ACDATA | The XTP_EDIT_ACDATA structure defines items' displayed data and provides text and icons for each displayed line in the auto-complete window
C XTP_EDIT_COLLAPSEDBLOCK | Stores collapsed block parameters
C XTP_EDIT_COLORVALUES | Stores the colors for different phrases
C XTP_EDIT_FONTOPTIONS | The XTP_EDIT_FONTOPTIONS structure is a self-initializing LOGFONT structure that initializes all values equal to XTP_EDIT_FONTOPTIONS_UNSPEC_OPTION except for lfFaceName which is set to zero length
C XTP_EDIT_LINECOL | The XTP_EDIT_LINECOL structure represents the coordinates of text items on the displaying context in terms of line/column
C XTP_EDIT_NMHDR_DOCMODIFIED | Document notification structure
C XTP_EDIT_NMHDR_EDITCHANGED | Structure to notify "Edit changed" event
C XTP_EDIT_NMHDR_ENABLESCROLLBAR | Structure to notify XTP_EDIT_NM_ENABLESCROLLBAR event
C XTP_EDIT_NMHDR_MARGINCLICKED | Structure to notify XTP_EDIT_NM_MARGINCLICKED event
C XTP_EDIT_NMHDR_PARSEEVENT | Structure to notify XTP_EDIT_NM_PARSEEVENT event
C XTP_EDIT_NMHDR_ROWCOLCHANGED | Row column notification structure
C XTP_EDIT_NMHDR_SETSCROLLPOS | Structure to notify XTP_EDIT_NM_UPDATESCROLLPOS event
C XTP_EDIT_ROWCOLRECT | The XTP_EDIT_ROWCOLRECT structure is used to define a row and column selection rectangle
C XTP_EDIT_ROWSBLOCK | XTP_EDIT_ROWSBLOCK structure
C XTP_EDIT_SENMBOOKMARK | Bookmark notification structure
C XTP_EDIT_TEXTBLOCK | Summary The XTP_EDIT_TEXTBLOCK structure stores the text blocks after parsing
C XTP_EVENT_DRAG_OPERATION_PARAMS | This structure is used with notifications for custom edit event notifications when eOperation is xtpCalendarEO_DragXXX
C XTP_EVENT_EDIT_OPERATION_PARAMS | This structure is used as a generic and base class for custom edit event notifications
C XTP_EVENT_IN_PLACE_CREATE_EVENT_OPERATION_PARAMS | This structure is used with notifications for custom edit event notifications when eOperation is xtpCalendarEO_InPlaceCreateEvent
C XTP_EVENT_PASTE_OPERATION_PARAMS | This structure is used with notifications for custom edit event notifications when eOperation is xtpCalendarEO_Paste
C XTP_GRIDDATAMANAGER_COM_ERROR | Basic set of parameters transferred to item handlers
C XTP_GRIDRECORDITEM_ARGS | Basic set of parameters transferred to item handlers
C XTP_GRIDRECORDITEM_CLICKARGS | A set of parameters transferred to mouse click item handlers
C XTP_GRIDRECORDITEM_DRAWARGS | A set of parameters transferred to the Draw item handler
C XTP_GRIDRECORDITEM_METRICS | Record item drawing metrics
C XTP_IMAGERESOURCE_INFO | This structure is used to define the position and style of the icon in resources
C XTP_LC_TIMEFORMAT | Time format structure
C XTP_LVITEMDATA | The XTP_LVITEMDATA structure is used to maintain information for a particular list item in a CXTPShellListCtrl or CXTPShellListView window
C XTP_NC_DATEPICKER_BUTTON | Structure used to send button notification messages
C XTP_NM_FLOWGRAPH_CONNECTIONCHANGED | Information about the connection that has changed
C XTP_NM_FLOWGRAPH_CONNECTIONCHANGING | Information about the connection that is currently changing
C XTP_NM_FLOWGRAPH_ENDLABELEDIT | Information about the label whose editing has ended
C XTP_NM_FLOWGRAPH_NODECHANGED | Information about the node that has changed
C XTP_NM_GRID_BEFORE_COPYPASTE | This structure is sent to the Main window in a WM_NOTIFY message from Item and provides all parameters required by the Main window to process control specific notifications
C XTP_NM_GRIDCOLUMNORDERCHANGED | This structure is sent to the main window in a WM_NOTIFY message after columns order or group order is changed
C XTP_NM_GRIDCOLUMNRESIZE | This structure is sent to the main window in a WM_NOTIFY message after a column is resized
C XTP_NM_GRIDCONSTRAINTSELECTING | This structure is sent to the Main window in a WM_NOTIFY message from Item and provides all parameters required by the Main window to process control specific notifications
C XTP_NM_GRIDDRAGDROP | This structure is sent to the Main window in a WM_NOTIFY message from Grid Control to determine if records are dragged or dropped
C XTP_NM_GRIDGIVEFEEDBACK | NM_GRIDGIVEFEEDBACK notification data
C XTP_NM_GRIDINPLACEBUTTON | This structure is sent to the Main window in a WM_NOTIFY message from Item and provides all parameters required by the Main window to process control specific notifications
C XTP_NM_GRIDITEMCONTROL | This structure is sent to the Main window in a WM_NOTIFY message from the item control and provides all parameters needed to process control specific notifications by the main window
C XTP_NM_GRIDITEMMETRICS | This structure is sent to the Main window in a WM_NOTIFY message from Item and provides all parameters required by the Main window to process control specific notifications
C XTP_NM_GRIDPREVIEWKEYDOWN | This structure is sent to the Main window in a WM_NOTIFY message before processing the OnKeyDown event
C XTP_NM_GRIDRECORDITEM | This structure is sent to the Main window in a WM_NOTIFY message from Item and provides all parameters required by the Main window to process control specific notifications
C XTP_NM_GRIDREQUESTEDIT | A set of parameters transferred with an XTP_NM_GRID_REQUESTEDIT message
C XTP_NM_GRIDROWRESIZE | This structure is sent to the main window in a WM_NOTIFY message after a row is resized
C XTP_NM_GRIDSCROLL | NM_GRIDSCROLL notification data
C XTP_NM_GRIDSTATECHANGED | This structure contains information for use in processing an XTP_NM_GRID_STATECHANGED message
C XTP_NM_GRIDTOOLTIPINFO | This structure is sent to the Main window in a WM_NOTIFY message from Item and provides all parameters required by the Main window to process control specific notifications
C XTP_NM_SELECTION_CHANGING | This struct defines data for an XTP_NM_GRID_SELCHANGING notification
C XTP_NM_TRACKCONTROL | This structure contains notification details
C XTP_PICK_BUTTON | XTP_PICK_BUTTON structure is used by the CXTPColorSelectorCtrl class to support a user-defined color list
C XTP_PROPERTYGRID_NOTIFYEDIT | This struct is passed with XTP_PGN_REQUESTEDIT, XTP_PGN_AFTEREDIT, and XTP_PGN_CANCELEDIT notifications to determine the item and its new value
C XTP_RESIZEPOINT | The XTP_RESIZEPOINT structure is used by the CXTPResizePoint class for defining single-precision floating point x- and y- coordinates of a point
C XTP_RESIZERECT | XTP_RESIZERECT structure is used by the CXTPResizeRect class for defining single-precision floating point coordinates of the upper-left and lower-right corners of a rectangle
C XTP_RESOURCEMANAGER_LANGINFO | Standalone structure used to manage Language Info
C XTP_SCROLLBAR_POSINFO | The XTP_SCROLLBAR_POSINFO structure contains scroll bar information
C XTP_SCROLLBAR_TRACKINFO | The XTP_SCROLLBAR_TRACKINFO structure contains tracking information
C XTP_SCROLLBARDRAWCOLORS | Used by paint manager to retrieve the current state color settings when drawing scrollbars
C XTP_SCROLLBARINICOLORS | Used by paint manager to retrieve color settings from the loaded resource INI file
C XTP_SLIDERTICKS | The XTP_SLIDERTICKS structure contains slider ticks
C XTP_TAGCLOUDTAG | Manages the attributes for each tag element such as weight, font, background and foreground color
C XTP_TASKPANEL_GROUPCOLORS | Structure used to store task panel group colorization information for various parts of the group
C XTP_TPNENDLABELEDIT | This structure is passed as a parameter when an XTP_TPN_ENDLABELEDIT event occurs
C XTP_TPNGROUPEXPANDING | This structure is passed as a parameter when an XTP_TPN_GROUPEXPANDING event occurs
C XTP_TVITEMDATA | The XTP_TVITEMDATA structure is used to maintain information for a particular tree item in a CXTPShellTreeCtrl or CXTPShellTreeView window
C XTP_URI | Parse URI information
C XTP_URI_DEFAULTS | Default URI values
C XTP_WEEK_VIEW_LAYOUT | This struct store a Week View layout
C XTPGridInputState | Stores the mouse and key states
C XTPPROGRESSDRAWSTRUCT | Struct used by the progress bar during paint operations
C XTPRIBBON_HEADER_COLOR | Struct used to define context tab colors for the ribbon control


Toolkit Pro: CAppearanceSetPropertyPage2003 Class Reference

Public Member Functions | Public Attributes | List of all members
CAppearanceSetPropertyPage2003 Class Reference

CAppearanceSetPropertyPage2003 implements an Office 2003 tab appearance. More...

Inheritance diagram for CAppearanceSetPropertyPage2003:
[legend]

Public Member Functions

CAppearanceSetPropertyPage2003 ()
Constructs a CAppearanceSetPropertyPage2003 object.
virtual CRect | GetHeaderMargin ()
Gets the top, left, right, and bottom margins of the tab header.
virtual void | RefreshMetrics ()
Refreshes the appearance metrics.
virtual void | DrawSingleButton (CDC *pDC, CXTPTabManagerItem *pItem)
Draws a single tab button in the tab client header area.
virtual CRect | FillTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl)
Fills both the tab header and the tab client area and then draws the tab client frame.
virtual XTPTabColorStyle | GetDefaultColorSet ()
Gets the default value of the color set for this theme.
virtual CRect | GetButtonDrawRect (const CXTPTabManagerItem *pItem)
Retrieves the bounding rectangle of a specified drawing item.
- Public Member Functions inherited from CXTPTabPaintManagerTheme
CXTPTabPaintManagerTheme ()
Constructs a CXTPTabPaintManagerTheme object.
virtual | ~CXTPTabPaintManagerTheme ()
Destroys a CXTPTabPaintManagerTheme object, handles cleanup and deallocation.
CXTPTabPaintManagerColorSet * | GetColorSet () const
Gets the color set.
virtual CRect | GetHeaderRect (CRect rcControl, CXTPTabManager *pTabManager)
Gets the bounding rectangle of the tab header area.
virtual CRect | GetHeaderClipBox (CDC *pDC, CXTPTabManager *pTabManager)
Gets the clip box of the tab header area.
int | GetHeaderHeight (CXTPTabManager *pTabManager)
Gets the height of the tab header area.
virtual CRect | GetClientRect (CRect rcControl, CXTPTabManager *pTabManager)
Gets the bounding rectangle of the tab client area.
virtual CRect | GetClientMargin ()
Gets the top, left, right, and bottom margins of the tab client area.
virtual int | GetButtonLength (CDC *pDC, CXTPTabManagerItem *pItem)
Retrieves the total length of a specified tab button including the left and right button margins.
virtual int | GetButtonHeight (const CXTPTabManager *pTabManager)
Retrieves the total height of the tab buttons within a specified tab manager including the top and bottom margins and the icon.
virtual void | DrawTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl)
Draws the tab control.
virtual void | RepositionTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcClient)
Moves the tab buttons of the tab control to their correct positions.
virtual void | AdjustClientRect (CXTPTabManager *pTabManager, CRect &rcClient)
Adjusts the tab client rectangle.
virtual void | DrawWorkspacePart (CDC *pDC, LPRECT lpRect, XTPTabWorkspacePart workspacePart)
Draws a specified TabMDIClient TabWorkspace part.
virtual int | GetSupportedColorSets ()
Gets the supported color sets for this theme.
COLORREF | FillButton (CDC *pDC, CXTPTabManagerItem *pItem, LPPOINT pts, int nCount, XTPTabPosition tabPosition, BOOL bAbsolute=FALSE)
Draws a tab button within a specified polygon.
virtual void | DrawText (CDC *pDC, CXTPTabManager *pManager, const CString &str, LPRECT lpRect, UINT nFormat)
Draws the text of a specified item.

Public Attributes

BOOL | m_bDoubleHighlightedBorder
TRUE to draw a double border on mouse over when hot tracking is enabled.
- Public Attributes inherited from CXTPTabPaintManagerTheme
CRect | m_rcHeaderMargin
CRect struct containing the left, top, right, and bottom.
int | m_nRowMargin
margins of the tab header.

Additional Inherited Members

- Protected Attributes inherited from CXTPTabPaintManagerTheme
int | m_nButtonHeight
Current tab button height (without margins).
CXTPTabPaintManager * | m_pPaintManager
Self paint manager pointer.
BOOL | m_bButtonsReverseZOrder
Draw buttons in right to left order.

Detailed Description

CAppearanceSetPropertyPage2003 implements an Office 2003 tab appearance.

To use the Office 2003 appearance, SetAppearance is used to apply the xtpTabAppearancePropertyPage2003 XTPTabAppearanceStyle.

CAppearanceSetPropertyPage2003 supports the following XTPTabColorStyle: xtpTabColorDefault: Default color style. xtpTabColorOffice2003: Office 2003 color style. xtpTabColorVisualStudio2005: Visual Studio 2005 color style.

By default, m_bDoubleHighlightedBorder is FALSE. If m_bDoubleHighlightedBorder is TRUE, then a double border is drawn on mouse over when hot tracking is enabled.

See also
XTPTabColorStyle, XTPTabAppearanceStyle, SetAppearance, GetAppearance, GetAppearanceSet, SetColor, GetColor, GetColorSet, SetColorSet, SetAppearanceSet

Member Function Documentation

◆ DrawSingleButton()

virtual void DrawSingleButton | ( | CDC * | pDC,
 |  | CXTPTabManagerItem * | pItem )
 virtual

Draws a single tab button in the tab client header area.

Parameters
pDC | Pointer to a valid device context.
pItem | Pointer to the tab button to draw.

This method is only used to draw the tab button. This method does not draw the button's icon or text.

DrawSingleButton calls CXTPTabPaintManager::DrawSingleButtonIconAndText after the button is drawn to draw the button's icon and text.

If m_bDoubleHighlightedBorder is TRUE, then a double border is drawn on mouse over when hot tracking is enabled.

See also
CXTPTabPaintManager::DrawTabControlEx, CXTPTabPaintManager::DrawSingleButtonIconAndText, m_bDoubleHighlightedBorder

Reimplemented from CXTPTabPaintManagerTheme.

Reimplemented in CAppearanceSetVisualStudio2005.

◆ FillTabControl()

virtual CRect FillTabControl | ( | CXTPTabManager * | pTabManager,
 |  | CDC * | pDC,
 |  | CRect | rcControl )
 virtual

Fills both the tab header and the tab client area and then draws the tab client frame.

Parameters
pTabManager | Pointer to the tab manager to fill.
pDC | Pointer to a valid device context.
rcControl | Bounding rectangle of the tab manager control. See CXTPTabManager::GetControlRect.
Returns
The bounding rectangle of the tab header.

If CXTPTabPaintManager::m_bFillBackground is TRUE, then the tab client space is filled using CXTPTabPaintManagerColorSet::m_clrControlFace. CXTPTabPaintManager::m_bFillBackground is only FALSE when drawing docking pane panel auto-hide tabs because there is no client area to draw.

See also
CXTPTabPaintManagerTheme::GetHeaderRect, CXTPTabPaintManager::m_bFillBackground, XTPTabClientFrame, CXTPTabPaintManager::m_clientFrame

Reimplemented from CXTPTabPaintManagerTheme.

◆ GetButtonDrawRect()

virtual CRect GetButtonDrawRect ( const CXTPTabManagerItem * pItem )
virtual

Retrieves the bounding rectangle of a specified drawing item.

Parameters
pItem Pointer to the drawing item with the bounding rectangle to retrieve.
Returns
The bounding rectangle of the specified drawing item.
See also
CXTPTabManagerItem::GetRect

Reimplemented from CXTPTabPaintManagerTheme.

Reimplemented in CAppearanceSetVisualStudio2005.

◆ GetDefaultColorSet()

virtual XTPTabColorStyle GetDefaultColorSet ( )
inlinevirtual

Gets the default value of the color set for this theme.

Returns
The default value of the color set for this theme.
See also
GetSupportedColorSets

Reimplemented from CXTPTabPaintManagerTheme.

◆ GetHeaderMargin()

virtual CRect GetHeaderMargin ( )
inlinevirtual

Gets the top, left, right, and bottom margins of the tab header.

Returns
The top, left, right, and bottom margins of the tab header.

The margins of the tab header are the space placed around the tab buttons inside the tab header.

The margins of the tab header are not placed around each tab button. Instead, they are placed around all tab buttons.

See also
CXTPTabPaintManager::GetHeaderRect

Reimplemented from CXTPTabPaintManagerTheme.

Reimplemented in CAppearanceSetVisualStudio2005.

◆ RefreshMetrics()

virtual void RefreshMetrics ( )
virtual

Refreshes the appearance metrics.

Override this member to change the appearance metrics.

This method is used to refresh the appearance metrics such as font, button height, margin size, etc.

Reimplemented from CXTPTabPaintManagerTheme.

The documentation for this class was generated from the following file:
  • XTPTabThemePropertyPage2003.h


Toolkit Pro: CAppearanceSetPropertyPage2007 Class Reference

Public Member Functions | Protected Member Functions | List of all members
CAppearanceSetPropertyPage2007 Class Reference

CAppearanceSetPropertyPage2007 implements an Office 2007 tab appearance. More...

Inheritance diagram for CAppearanceSetPropertyPage2007:
[legend]

Public Member Functions

CAppearanceSetPropertyPage2007 ()
Constructs a CAppearanceSetPropertyPage2007 object.
- Public Member Functions inherited from CXTPTabPaintManagerTheme
CXTPTabPaintManagerTheme ()
Constructs a CXTPTabPaintManagerTheme object.
virtual | ~CXTPTabPaintManagerTheme ()
Destroys a CXTPTabPaintManagerTheme object, handles cleanup and deallocation.
CXTPTabPaintManagerColorSet * | GetColorSet () const
Gets the color set.
virtual CRect | GetHeaderRect (CRect rcControl, CXTPTabManager *pTabManager)
Gets the bounding rectangle of the tab header area.
virtual CRect | GetHeaderClipBox (CDC *pDC, CXTPTabManager *pTabManager)
Gets the clip box of the tab header area.
int | GetHeaderHeight (CXTPTabManager *pTabManager)
Gets the height of the tab header area.
virtual CRect | GetClientRect (CRect rcControl, CXTPTabManager *pTabManager)
Gets the bounding rectangle of the tab client area.
virtual CRect | GetHeaderMargin ()
Gets the top, left, right, and bottom margins of the tab header.
virtual CRect | GetClientMargin ()
Gets the top, left, right, and bottom margins of the tab client area.
virtual int | GetButtonLength (CDC *pDC, CXTPTabManagerItem *pItem)
Retrieves the total length of a specified tab button including the left and right button margins.
virtual int | GetButtonHeight (const CXTPTabManager *pTabManager)
Retrieves the total height of the tab buttons within a specified tab manager including the top and bottom margins and the icon.
virtual CRect | GetButtonDrawRect (const CXTPTabManagerItem *pItem)
Retrieves the bounding rectangle of a specified drawing item.
virtual void | DrawTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl)
Draws the tab control.
virtual void | RepositionTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcClient)
Moves the tab buttons of the tab control to their correct positions.
virtual void | AdjustClientRect (CXTPTabManager *pTabManager, CRect &rcClient)
Adjusts the tab client rectangle.
virtual void | DrawWorkspacePart (CDC *pDC, LPRECT lpRect, XTPTabWorkspacePart workspacePart)
Draws a specified TabMDIClient TabWorkspace part.
virtual int | GetSupportedColorSets ()
Gets the supported color sets for this theme.
COLORREF | FillButton (CDC *pDC, CXTPTabManagerItem *pItem, LPPOINT pts, int nCount, XTPTabPosition tabPosition, BOOL bAbsolute=FALSE)
Draws a tab button within a specified polygon.
virtual void | DrawText (CDC *pDC, CXTPTabManager *pManager, const CString &str, LPRECT lpRect, UINT nFormat)
Draws the text of a specified item.

Protected Member Functions

virtual void | RefreshMetrics ()
Refreshes the appearance metrics.
virtual void | DrawSingleButton (CDC *pDC, CXTPTabManagerItem *pItem)
Draws a single tab button in the tab client header area.
virtual CRect | FillTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl)
Fills both the tab header and the tab client area and then draws the tab client frame.
virtual XTPTabColorStyle | GetDefaultColorSet ()
Gets the default value of the color set for this theme.

Additional Inherited Members

- Public Attributes inherited from CXTPTabPaintManagerTheme
CRect | m_rcHeaderMargin
CRect struct containing the left, top, right, and bottom.
int | m_nRowMargin
margins of the tab header.
- Protected Attributes inherited from CXTPTabPaintManagerTheme
int | m_nButtonHeight
Current tab button height (without margins).
CXTPTabPaintManager * | m_pPaintManager
Self paint manager pointer.
BOOL | m_bButtonsReverseZOrder
Draw buttons in right to left order.

Detailed Description

CAppearanceSetPropertyPage2007 implements an Office 2007 tab appearance.

To use the Office 2007 appearance, SetAppearance is used to apply the xtpTabAppearancePropertyPage2007 XTPTabAppearanceStyle.

See also
XTPTabColorStyle, XTPTabAppearanceStyle, SetAppearance, GetAppearance, GetAppearanceSet, SetColor, GetColor, GetColorSet, SetColorSet, SetAppearanceSet

Member Function Documentation

◆ DrawSingleButton()

virtual void DrawSingleButton | ( | CDC * | pDC,
 |  | CXTPTabManagerItem * | pItem )
 protectedvirtual

Draws a single tab button in the tab client header area.

Parameters
pDC | Pointer to a valid device context.
pItem | Pointer to the tab button to draw.

This method is only used to draw the tab button. This method does not draw the button's icon or text.

DrawSingleButton calls CXTPTabPaintManager::DrawSingleButtonIconAndText after the button is drawn to draw the button's icon and text.

If m_bDoubleHighlightedBorder is TRUE, then a double border is drawn on mouse over when hot tracking is enabled.

See also
CXTPTabPaintManager::DrawTabControlEx, CXTPTabPaintManager::DrawSingleButtonIconAndText, m_bDoubleHighlightedBorder

Reimplemented from CXTPTabPaintManagerTheme.

Reimplemented in CAppearanceSetPropertyPageAccess2007.

◆ FillTabControl()

virtual CRect FillTabControl | ( | CXTPTabManager * | pTabManager,
 |  | CDC * | pDC,
 |  | CRect | rcControl )
 protectedvirtual

Fills both the tab header and the tab client area and then draws the tab client frame.

Parameters
pTabManager | Pointer to the tab manager to fill.
pDC | Pointer to a valid device context.
rcControl | Bounding rectangle of the tab manager control. See CXTPTabManager::GetControlRect.
Returns
The bounding rectangle of the tab header.

If CXTPTabPaintManager::m_bFillBackground is TRUE, then the tab client space is filled using CXTPTabPaintManagerColorSet::m_clrControlFace. CXTPTabPaintManager::m_bFillBackground is only FALSE when drawing docking pane panel auto-hide tabs because there is no client area to draw.

See also
CXTPTabPaintManagerTheme::GetHeaderRect, CXTPTabPaintManager::m_bFillBackground, XTPTabClientFrame, CXTPTabPaintManager::m_clientFrame

Reimplemented from CXTPTabPaintManagerTheme.

Reimplemented in CAppearanceSetPropertyPageAccess2007.

◆ GetDefaultColorSet()

virtual XTPTabColorStyle GetDefaultColorSet ( )
inlineprotectedvirtual

Gets the default value of the color set for this theme.

Returns
The default value of the color set for this theme.
See also
GetSupportedColorSets

Reimplemented from CXTPTabPaintManagerTheme.

Reimplemented in CAppearanceSetPropertyPageAccess2007.

◆ RefreshMetrics()

virtual void RefreshMetrics ( )
protectedvirtual

Refreshes the appearance metrics.

Override this member to change the appearance metrics.

This method is used to refresh the appearance metrics such as font, button height, margin size, etc.

Reimplemented from CXTPTabPaintManagerTheme.

Reimplemented in CAppearanceSetPropertyPageAccess2007.

The documentation for this class was generated from the following file:
  • XTPTabThemePropertyPage2007.h


Toolkit Pro: CAppearanceSetPropertyPageAccess2007 Class Reference

Public Member Functions | Protected Member Functions | List of all members
CAppearanceSetPropertyPageAccess2007 Class Reference

CAppearanceSetPropertyPageAccess2007 implements an Office 2007 tab appearance. More...

Inheritance diagram for CAppearanceSetPropertyPageAccess2007:
[legend]

Public Member Functions

CAppearanceSetPropertyPageAccess2007 ()
Constructs a CAppearanceSetPropertyPageAccess2007 object.
- Public Member Functions inherited from CAppearanceSetPropertyPage2007
CAppearanceSetPropertyPage2007 ()
Constructs a CAppearanceSetPropertyPage2007 object.
- Public Member Functions inherited from CXTPTabPaintManagerTheme
CXTPTabPaintManagerTheme ()
Constructs a CXTPTabPaintManagerTheme object.
virtual | ~CXTPTabPaintManagerTheme ()
Destroys a CXTPTabPaintManagerTheme object, handles cleanup and deallocation.
CXTPTabPaintManagerColorSet * | GetColorSet () const
Gets the color set.
virtual CRect | GetHeaderRect (CRect rcControl, CXTPTabManager *pTabManager)
Gets the bounding rectangle of the tab header area.
virtual CRect | GetHeaderClipBox (CDC *pDC, CXTPTabManager *pTabManager)
Gets the clip box of the tab header area.
int | GetHeaderHeight (CXTPTabManager *pTabManager)
Gets the height of the tab header area.
virtual CRect | GetClientRect (CRect rcControl, CXTPTabManager *pTabManager)
Gets the bounding rectangle of the tab client area.
virtual CRect | GetClientMargin ()
Gets the top, left, right, and bottom margins of the tab client area.
virtual int | GetButtonLength (CDC *pDC, CXTPTabManagerItem *pItem)
Retrieves the total length of a specified tab button including the left and right button margins.
virtual int | GetButtonHeight (const CXTPTabManager *pTabManager)
Retrieves the total height of the tab buttons within a specified tab manager including the top and bottom margins and the icon.
virtual void | DrawTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl)
Draws the tab control.
virtual void | RepositionTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcClient)
Moves the tab buttons of the tab control to their correct positions.
virtual void | AdjustClientRect (CXTPTabManager *pTabManager, CRect &rcClient)
Adjusts the tab client rectangle.
virtual void | DrawWorkspacePart (CDC *pDC, LPRECT lpRect, XTPTabWorkspacePart workspacePart)
Draws a specified TabMDIClient TabWorkspace part.
virtual int | GetSupportedColorSets ()
Gets the supported color sets for this theme.
COLORREF | FillButton (CDC *pDC, CXTPTabManagerItem *pItem, LPPOINT pts, int nCount, XTPTabPosition tabPosition, BOOL bAbsolute=FALSE)
Draws a tab button within a specified polygon.
virtual void | DrawText (CDC *pDC, CXTPTabManager *pManager, const CString &str, LPRECT lpRect, UINT nFormat)
Draws the text of a specified item.

Protected Member Functions

virtual void | RefreshMetrics ()
Refreshes the appearance metrics.
virtual void | DrawSingleButton (CDC *pDC, CXTPTabManagerItem *pItem)
Draws a single tab button in the tab client header area.
virtual CRect | FillTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl)
Fills both the tab header and the tab client area and then draws the tab client frame.
virtual XTPTabColorStyle | GetDefaultColorSet ()
Gets the default value of the color set for this theme.
CRect | GetButtonDrawRect (const CXTPTabManagerItem *pItem)
Retrieves the bounding rectangle of a specified drawing item.
virtual CRect | GetHeaderMargin ()
Gets the top, left, right, and bottom margins of the tab header.
- Protected Member Functions inherited from CAppearanceSetPropertyPage2007

Additional Inherited Members

- Public Attributes inherited from CXTPTabPaintManagerTheme
CRect | m_rcHeaderMargin
CRect struct containing the left, top, right, and bottom.
int | m_nRowMargin
margins of the tab header.
- Protected Attributes inherited from CXTPTabPaintManagerTheme
int | m_nButtonHeight
Current tab button height (without margins).
CXTPTabPaintManager * | m_pPaintManager
Self paint manager pointer.
BOOL | m_bButtonsReverseZOrder
Draw buttons in right to left order.

Detailed Description

CAppearanceSetPropertyPageAccess2007 implements an Office 2007 tab appearance.

To use the Office 2007 appearance, SetAppearance is used to apply the xtpTabAppearancePropertyPage2007 XTPTabAppearanceStyle.

See also
XTPTabColorStyle, XTPTabAppearanceStyle, SetAppearance, GetAppearance, GetAppearanceSet, SetColor, GetColor, GetColorSet, SetColorSet, SetAppearanceSet

Member Function Documentation

◆ DrawSingleButton()

virtual void DrawSingleButton | ( | CDC * | pDC,
 |  | CXTPTabManagerItem * | pItem )
 protectedvirtual

Draws a single tab button in the tab client header area.

Parameters
pDC | Pointer to a valid device context.
pItem | Pointer to the tab button to draw.

This method is only used to draw the tab button. This method does not draw the button's icon or text.

DrawSingleButton calls CXTPTabPaintManager::DrawSingleButtonIconAndText after the button is drawn to draw the button's icon and text.

If m_bDoubleHighlightedBorder is TRUE, then a double border is drawn on mouse over when hot tracking is enabled.

See also
CXTPTabPaintManager::DrawTabControlEx, CXTPTabPaintManager::DrawSingleButtonIconAndText, m_bDoubleHighlightedBorder

Reimplemented from CAppearanceSetPropertyPage2007.

◆ FillTabControl()

virtual CRect FillTabControl | ( | CXTPTabManager * | pTabManager,
 |  | CDC * | pDC,
 |  | CRect | rcControl )
 protectedvirtual

Fills both the tab header and the tab client area and then draws the tab client frame.

Parameters
pTabManager | Pointer to the tab manager to fill.
pDC | Pointer to a valid device context.
rcControl | Bounding rectangle of the tab manager control. See CXTPTabManager::GetControlRect.
Returns
The bounding rectangle of the tab header.

If CXTPTabPaintManager::m_bFillBackground is TRUE, then the tab client space is filled using CXTPTabPaintManagerColorSet::m_clrControlFace. CXTPTabPaintManager::m_bFillBackground is only FALSE when drawing docking pane panel auto-hide tabs because there is no client area to draw.

See also
CXTPTabPaintManagerTheme::GetHeaderRect, CXTPTabPaintManager::m_bFillBackground, XTPTabClientFrame, CXTPTabPaintManager::m_clientFrame

Reimplemented from CAppearanceSetPropertyPage2007.

◆ GetButtonDrawRect()

CRect GetButtonDrawRect ( const CXTPTabManagerItem * pItem )
protectedvirtual

Retrieves the bounding rectangle of a specified drawing item.

Parameters
pItem Pointer to the drawing item with the bounding rectangle to retrieve.
Returns
The bounding rectangle of the specified drawing item.
See also
CXTPTabManagerItem::GetRect

Reimplemented from CXTPTabPaintManagerTheme.

◆ GetDefaultColorSet()

virtual XTPTabColorStyle GetDefaultColorSet ( )
inlineprotectedvirtual

Gets the default value of the color set for this theme.

Returns
The default value of the color set for this theme.
See also
GetSupportedColorSets

Reimplemented from CAppearanceSetPropertyPage2007.

◆ GetHeaderMargin()

virtual CRect GetHeaderMargin ( )
inlineprotectedvirtual

Gets the top, left, right, and bottom margins of the tab header.

Returns
The top, left, right, and bottom margins of the tab header.

The margins of the tab header are the space placed around the tab buttons inside the tab header.

The margins of the tab header are not placed around each tab button. Instead, they are placed around all tab buttons.

See also
CXTPTabPaintManager::GetHeaderRect

Reimplemented from CXTPTabPaintManagerTheme.

◆ RefreshMetrics()

virtual void RefreshMetrics ( )
protectedvirtual

Refreshes the appearance metrics.

Override this member to change the appearance metrics.

This method is used to refresh the appearance metrics such as font, button height, margin size, etc.

Reimplemented from CAppearanceSetPropertyPage2007.

The documentation for this class was generated from the following file:
  • XTPTabThemePropertyPageAccess2007.h


Toolkit Pro: CAppearanceSetPropertyPageFlat Class Reference

Public Member Functions | Public Attributes | List of all members
CAppearanceSetPropertyPageFlat Class Reference

CAppearanceSetPropertyPageFlat implements an Office 2000 Flat tab appearance. More...

Inheritance diagram for CAppearanceSetPropertyPageFlat:
[legend]

Public Member Functions

CAppearanceSetPropertyPageFlat ()
Constructs a CAppearanceSetPropertyPageFlat object.
virtual void | DrawSingleButton (CDC *pDC, CXTPTabManagerItem *pItem)
Draws a single tab button in the tab client header area.
virtual XTPTabColorStyle | GetDefaultColorSet ()
Gets the default value of the color set for this theme.
- Public Member Functions inherited from CXTPTabThemeFlat
CXTPTabThemeFlat ()
Constructs a CXTPTabThemeFlat object.
virtual CRect | FillTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl)
Fills both the tab header and the tab client area and then draws the tab client frame.
- Public Member Functions inherited from CXTPTabPaintManagerTheme
CXTPTabPaintManagerTheme ()
Constructs a CXTPTabPaintManagerTheme object.
virtual | ~CXTPTabPaintManagerTheme ()
Destroys a CXTPTabPaintManagerTheme object, handles cleanup and deallocation.
virtual void | RefreshMetrics ()
Refreshes the appearance metrics.
CXTPTabPaintManagerColorSet * | GetColorSet () const
Gets the color set.
virtual CRect | GetHeaderRect (CRect rcControl, CXTPTabManager *pTabManager)
Gets the bounding rectangle of the tab header area.
virtual CRect | GetHeaderClipBox (CDC *pDC, CXTPTabManager *pTabManager)
Gets the clip box of the tab header area.
int | GetHeaderHeight (CXTPTabManager *pTabManager)
Gets the height of the tab header area.
virtual CRect | GetClientRect (CRect rcControl, CXTPTabManager *pTabManager)
Gets the bounding rectangle of the tab client area.
virtual CRect | GetHeaderMargin ()
Gets the top, left, right, and bottom margins of the tab header.
virtual CRect | GetClientMargin ()
Gets the top, left, right, and bottom margins of the tab client area.
virtual int | GetButtonLength (CDC *pDC, CXTPTabManagerItem *pItem)
Retrieves the total length of a specified tab button including the left and right button margins.
virtual int | GetButtonHeight (const CXTPTabManager *pTabManager)
Retrieves the total height of the tab buttons within a specified tab manager including the top and bottom margins and the icon.
virtual CRect | GetButtonDrawRect (const CXTPTabManagerItem *pItem)
Retrieves the bounding rectangle of a specified drawing item.
virtual void | DrawTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl)
Draws the tab control.
virtual void | RepositionTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcClient)
Moves the tab buttons of the tab control to their correct positions.
virtual void | AdjustClientRect (CXTPTabManager *pTabManager, CRect &rcClient)
Adjusts the tab client rectangle.
virtual void | DrawWorkspacePart (CDC *pDC, LPRECT lpRect, XTPTabWorkspacePart workspacePart)
Draws a specified TabMDIClient TabWorkspace part.
virtual int | GetSupportedColorSets ()
Gets the supported color sets for this theme.
COLORREF | FillButton (CDC *pDC, CXTPTabManagerItem *pItem, LPPOINT pts, int nCount, XTPTabPosition tabPosition, BOOL bAbsolute=FALSE)
Draws a tab button within a specified polygon.
virtual void | DrawText (CDC *pDC, CXTPTabManager *pManager, const CString &str, LPRECT lpRect, UINT nFormat)
Draws the text of a specified item.

Public Attributes

BOOL | m_bBlurPoints
TRUE to smooth corners of flat tabs.
BOOL | m_bVisualStudio2005Style
TRUE to draw with Visual Studio 2005 style.
- Public Attributes inherited from CXTPTabPaintManagerTheme
CRect | m_rcHeaderMargin
CRect struct containing the left, top, right, and bottom.
int | m_nRowMargin
margins of the tab header.

Additional Inherited Members

- Protected Attributes inherited from CXTPTabPaintManagerTheme
int | m_nButtonHeight
Current tab button height (without margins).
CXTPTabPaintManager * | m_pPaintManager
Self paint manager pointer.
BOOL | m_bButtonsReverseZOrder
Draw buttons in right to left order.

Detailed Description

CAppearanceSetPropertyPageFlat implements an Office 2000 Flat tab appearance.

To use the Office 2000 Flat appearance, SetAppearance is used to apply the xtpTabAppearancePropertyPageFlat XTPTabAppearanceStyle.

CAppearanceSetPropertyPageSelected supports the following XTPTabColorStyle: xtpTabColorDefault: Default color style. xtpTabColorVisualStudio2003: Visual Studio color style. xtpTabColorOffice2003: Office 2003 color style.

See also
XTPTabColorStyle, XTPTabAppearanceStyle, SetAppearance, GetAppearance, GetAppearanceSet, SetColor, GetColor, GetColorSet, SetColorSet, SetAppearanceSet

Constructor & Destructor Documentation

◆ CAppearanceSetPropertyPageFlat()

CAppearanceSetPropertyPageFlat ( )
inline

Constructs a CAppearanceSetPropertyPageFlat object.

By default, m_bBlurPoints is TRUE to smooth tab corners.

Member Function Documentation

◆ DrawSingleButton()

virtual void DrawSingleButton | ( | CDC * | pDC,
 |  | CXTPTabManagerItem * | pItem )
 virtual

Draws a single tab button in the tab client header area.

Parameters
pDC | Pointer to a valid device context.
pItem | Pointer to the tab button to draw.

This method is only used to draw the tab button. This method does not draw the button's icon or text.

DrawSingleButton calls CXTPTabPaintManager::DrawSingleButtonIconAndText after the button is drawn to draw the button's icon and text.

If m_bBlurPoints is TRUE, then tab corners will be smoothed.

See also
CXTPTabPaintManager::DrawTabControlEx, CXTPTabPaintManager::DrawSingleButtonIconAndText, m_bBlurPoints

Reimplemented from CXTPTabThemeFlat.

Reimplemented in CXTPTabThemeVisualStudio2010.

◆ GetDefaultColorSet()

virtual XTPTabColorStyle GetDefaultColorSet ( )
inlinevirtual

Gets the default value of the color set for this theme.

Returns
The default value of the color set for this theme.
See also
GetSupportedColorSets

Reimplemented from CXTPTabThemeFlat.

Reimplemented in CXTPTabThemeVisualStudio2010.

The documentation for this class was generated from the following file:
  • XTPTabThemePropertyPageFlat.h


Toolkit Pro: CAppearanceSetPropertyPageSelected Class Reference

Public Member Functions | List of all members
CAppearanceSetPropertyPageSelected Class Reference

CAppearanceSetPropertyPageSelected implements an "Office 2000 Selected" tab appearance. More...

Inheritance diagram for CAppearanceSetPropertyPageSelected:
[legend]

Public Member Functions

virtual void | DrawSingleButton (CDC *pDC, CXTPTabManagerItem *pItem)
Draws a single tab button in the tab client header area.
- Public Member Functions inherited from CXTPTabThemeOffice2000
CXTPTabThemeOffice2000 ()
Constructs a CXTPTabThemeOffice2000 object.
virtual void | RefreshMetrics ()
Refreshes the appearance metrics.
virtual CRect | FillTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl)
Fills both the tab header and the tab client area and then draws the tab client frame.
virtual XTPTabColorStyle | GetDefaultColorSet ()
Gets the default value of the color set for this theme.
virtual CRect | GetClientMargin ()
Gets the top, left, right, and bottom margins of the tab client area.
virtual CRect | GetButtonDrawRect (const CXTPTabManagerItem *pItem)
Retrieves the bounding rectangle of a specified drawing item.
virtual CRect | GetHeaderClipBox (CDC *pDC, CXTPTabManager *pTabManager)
Gets the clip box of the tab header area.
- Public Member Functions inherited from CXTPTabPaintManagerTheme
CXTPTabPaintManagerTheme ()
Constructs a CXTPTabPaintManagerTheme object.
virtual | ~CXTPTabPaintManagerTheme ()
Destroys a CXTPTabPaintManagerTheme object, handles cleanup and deallocation.
CXTPTabPaintManagerColorSet * | GetColorSet () const
Gets the color set.
virtual CRect | GetHeaderRect (CRect rcControl, CXTPTabManager *pTabManager)
Gets the bounding rectangle of the tab header area.
int | GetHeaderHeight (CXTPTabManager *pTabManager)
Gets the height of the tab header area.
virtual CRect | GetClientRect (CRect rcControl, CXTPTabManager *pTabManager)
Gets the bounding rectangle of the tab client area.
virtual CRect | GetHeaderMargin ()
Gets the top, left, right, and bottom margins of the tab header.
virtual int | GetButtonLength (CDC *pDC, CXTPTabManagerItem *pItem)
Retrieves the total length of a specified tab button including the left and right button margins.
virtual int | GetButtonHeight (const CXTPTabManager *pTabManager)
Retrieves the total height of the tab buttons within a specified tab manager including the top and bottom margins and the icon.
virtual void | DrawTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl)
Draws the tab control.
virtual void | RepositionTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcClient)
Moves the tab buttons of the tab control to their correct positions.
virtual void | AdjustClientRect (CXTPTabManager *pTabManager, CRect &rcClient)
Adjusts the tab client rectangle.
virtual void | DrawWorkspacePart (CDC *pDC, LPRECT lpRect, XTPTabWorkspacePart workspacePart)
Draws a specified TabMDIClient TabWorkspace part.
virtual int | GetSupportedColorSets ()
Gets the supported color sets for this theme.
COLORREF | FillButton (CDC *pDC, CXTPTabManagerItem *pItem, LPPOINT pts, int nCount, XTPTabPosition tabPosition, BOOL bAbsolute=FALSE)
Draws a tab button within a specified polygon.
virtual void | DrawText (CDC *pDC, CXTPTabManager *pManager, const CString &str, LPRECT lpRect, UINT nFormat)
Draws the text of a specified item.

Additional Inherited Members

- Public Attributes inherited from CXTPTabPaintManagerTheme
CRect | m_rcHeaderMargin
CRect struct containing the left, top, right, and bottom.
int | m_nRowMargin
margins of the tab header.
- Protected Attributes inherited from CXTPTabPaintManagerTheme
int | m_nButtonHeight
Current tab button height (without margins).
CXTPTabPaintManager * | m_pPaintManager
Self paint manager pointer.
BOOL | m_bButtonsReverseZOrder
Draw buttons in right to left order.

Detailed Description

CAppearanceSetPropertyPageSelected implements an "Office 2000 Selected" tab appearance.

To use the Office 2000 Selected appearance, SetAppearance is used to apply the xtpTabAppearancePropertyPageSelected XTPTabAppearanceStyle.

CAppearanceSetPropertyPageSelected supports the following XTPTabColorStyle: xtpTabColorDefault: Default color style. xtpTabColorOffice2003: Office 2003 color style. xtpTabColorWinNative: Windows XP color style.

See also
XTPTabColorStyle, XTPTabAppearanceStyle, SetAppearance, GetAppearance, GetAppearanceSet, SetColor, GetColor, GetColorSet, SetColorSet, SetAppearanceSet

Member Function Documentation

◆ DrawSingleButton()

virtual void DrawSingleButton | ( | CDC * | pDC,
 |  | CXTPTabManagerItem * | pItem )
 virtual

Draws a single tab button in the tab client header area.

Parameters
pDC | Pointer to a valid device context.
pItem | Pointer to the tab button to draw.

This method is only used to draw the tab button. This method does not draw the button's icon or text.

DrawSingleButton calls CXTPTabPaintManager::DrawSingleButtonIconAndText after the button is drawn to draw the button's icon and text.

If the tab button is selected or highlighted, then CXTPTabPaintManager::CAppearanceSetPropertyPageSelected::DrawSingleButton is called instead of CXTPTabPaintManager::DrawSingleButtonIconAndText.

See also
CXTPTabPaintManager::DrawTabControlEx, CXTPTabPaintManager::DrawSingleButtonIconAndText

Reimplemented from CXTPTabThemeOffice2000.

The documentation for this class was generated from the following file:
  • XTPTabThemePropertyPageSelected.h


Toolkit Pro: CAppearanceSetStateButtons Class Reference

Public Member Functions | List of all members
CAppearanceSetStateButtons Class Reference

CAppearanceSetStateButtons implements a "State Button" tab appearance. More...

Inheritance diagram for CAppearanceSetStateButtons:
[legend]

Public Member Functions

CAppearanceSetStateButtons ()
Constructs a CAppearanceSetStateButtons object.
virtual void | DrawSingleButton (CDC *pDC, CXTPTabManagerItem *pItem)
Draws a single tab button in the tab client header area.
virtual CRect | FillTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl)
Fills both the tab header and the tab client area and then draws the tab client frame.
virtual XTPTabColorStyle | GetDefaultColorSet ()
Gets the default value of the color set for this theme.
- Public Member Functions inherited from CXTPTabPaintManagerTheme
CXTPTabPaintManagerTheme ()
Constructs a CXTPTabPaintManagerTheme object.
virtual | ~CXTPTabPaintManagerTheme ()
Destroys a CXTPTabPaintManagerTheme object, handles cleanup and deallocation.
virtual void | RefreshMetrics ()
Refreshes the appearance metrics.
CXTPTabPaintManagerColorSet * | GetColorSet () const
Gets the color set.
virtual CRect | GetHeaderRect (CRect rcControl, CXTPTabManager *pTabManager)
Gets the bounding rectangle of the tab header area.
virtual CRect | GetHeaderClipBox (CDC *pDC, CXTPTabManager *pTabManager)
Gets the clip box of the tab header area.
int | GetHeaderHeight (CXTPTabManager *pTabManager)
Gets the height of the tab header area.
virtual CRect | GetClientRect (CRect rcControl, CXTPTabManager *pTabManager)
Gets the bounding rectangle of the tab client area.
virtual CRect | GetHeaderMargin ()
Gets the top, left, right, and bottom margins of the tab header.
virtual CRect | GetClientMargin ()
Gets the top, left, right, and bottom margins of the tab client area.
virtual int | GetButtonLength (CDC *pDC, CXTPTabManagerItem *pItem)
Retrieves the total length of a specified tab button including the left and right button margins.
virtual int | GetButtonHeight (const CXTPTabManager *pTabManager)
Retrieves the total height of the tab buttons within a specified tab manager including the top and bottom margins and the icon.
virtual CRect | GetButtonDrawRect (const CXTPTabManagerItem *pItem)
Retrieves the bounding rectangle of a specified drawing item.
virtual void | DrawTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl)
Draws the tab control.
virtual void | RepositionTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcClient)
Moves the tab buttons of the tab control to their correct positions.
virtual void | AdjustClientRect (CXTPTabManager *pTabManager, CRect &rcClient)
Adjusts the tab client rectangle.
virtual void | DrawWorkspacePart (CDC *pDC, LPRECT lpRect, XTPTabWorkspacePart workspacePart)
Draws a specified TabMDIClient TabWorkspace part.
virtual int | GetSupportedColorSets ()
Gets the supported color sets for this theme.
COLORREF | FillButton (CDC *pDC, CXTPTabManagerItem *pItem, LPPOINT pts, int nCount, XTPTabPosition tabPosition, BOOL bAbsolute=FALSE)
Draws a tab button within a specified polygon.
virtual void | DrawText (CDC *pDC, CXTPTabManager *pManager, const CString &str, LPRECT lpRect, UINT nFormat)
Draws the text of a specified item.

Additional Inherited Members

- Public Attributes inherited from CXTPTabPaintManagerTheme
CRect | m_rcHeaderMargin
CRect struct containing the left, top, right, and bottom.
int | m_nRowMargin
margins of the tab header.
- Protected Attributes inherited from CXTPTabPaintManagerTheme
int | m_nButtonHeight
Current tab button height (without margins).
CXTPTabPaintManager * | m_pPaintManager
Self paint manager pointer.
BOOL | m_bButtonsReverseZOrder
Draw buttons in right to left order.

Detailed Description

CAppearanceSetStateButtons implements a "State Button" tab appearance.

To use the "State Button" appearance, SetAppearance is used to apply the xtpTabAppearanceStateButtons XTPTabAppearanceStyle.

CAppearanceSetStateButtons supports the following XTPTabColorStyle: xtpTabColorDefault: Default color style. xtpTabColorVisualStudio2003: Visual Studio color style. xtpTabColorOffice2003: Office 2003 color style. xtpTabColorWinNative: Windows XP color style. xtpTabColorVisualStudio2005: Visual Studio 2005 color style.

See also
XTPTabColorStyle, XTPTabAppearanceStyle, SetAppearance, GetAppearance, GetAppearanceSet, SetColor, GetColor, GetColorSet, SetColorSet, SetAppearanceSet

Member Function Documentation

◆ DrawSingleButton()

virtual void DrawSingleButton | ( | CDC * | pDC,
 |  | CXTPTabManagerItem * | pItem )
 virtual

Draws a single tab button in the tab client header area.

Parameters
pDC | Pointer to a valid device context.
pItem | Pointer to the tab button to draw.

This method is only used to draw the tab button. This method does not draw the button's icon or text.

DrawSingleButton calls CXTPTabPaintManager::DrawSingleButtonIconAndText after the button is drawn to draw the button's icon and text.

See also
CXTPTabPaintManager::DrawTabControlEx, CXTPTabPaintManager::DrawSingleButtonIconAndText

Reimplemented from CXTPTabPaintManagerTheme.

◆ FillTabControl()

virtual CRect FillTabControl | ( | CXTPTabManager * | pTabManager,
 |  | CDC * | pDC,
 |  | CRect | rcControl )
 virtual

Fills both the tab header and the tab client area and then draws the tab client frame.

Parameters
pTabManager | Pointer to the tab manager to fill.
pDC | Pointer to a valid device context.
rcControl | Bounding rectangle of the tab manager control. See CXTPTabManager::GetControlRect.
Returns
The bounding rectangle of the tab header.

If CXTPTabPaintManager::m_bFillBackground is TRUE, then the tab client space is filled using CXTPTabPaintManagerColorSet::m_clrControlFace. CXTPTabPaintManager::m_bFillBackground is only FALSE when drawing docking pane panel auto-hide tabs because there is no client area to draw.

See also
CXTPTabPaintManagerTheme::GetHeaderRect, CXTPTabPaintManager::m_bFillBackground, XTPTabClientFrame, CXTPTabPaintManager::m_clientFrame

Reimplemented from CXTPTabPaintManagerTheme.

◆ GetDefaultColorSet()

virtual XTPTabColorStyle GetDefaultColorSet ( )
inlinevirtual

Gets the default value of the color set for this theme.

Returns
The default value of the color set for this theme.
See also
GetSupportedColorSets

Reimplemented from CXTPTabPaintManagerTheme.

The documentation for this class was generated from the following file:
  • XTPTabThemeStateButtons.h


Toolkit Pro: CAppearanceSetVisio Class Reference

Public Member Functions | List of all members
CAppearanceSetVisio Class Reference

CAppearanceSetVisio implements a Visio tab appearance. More...

Inheritance diagram for CAppearanceSetVisio:
[legend]

Public Member Functions

void | AdjustClientRect (CXTPTabManager *pTabManager, CRect &rcClient)
Adjusts the tab client rectangle.
void | RepositionTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcClient)
Moves the tab buttons of the tab control to their correct positions.
CRect | GetHeaderRect (CRect rcControl, CXTPTabManager *pTabManager)
Gets the bounding rectangle of the tab header area.
CRect | GetClientRect (CRect rcControl, CXTPTabManager *pTabManager)
Gets the bounding rectangle of the tab client area.
void | DrawSingleButton (CDC *pDC, CXTPTabManagerItem *pItem)
Draws a single tab button in the tab client header area.
void | DrawTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl)
Draws the tab control.
- Public Member Functions inherited from CXTPTabPaintManagerTheme
CXTPTabPaintManagerTheme ()
Constructs a CXTPTabPaintManagerTheme object.
virtual | ~CXTPTabPaintManagerTheme ()
Destroys a CXTPTabPaintManagerTheme object, handles cleanup and deallocation.
virtual void | RefreshMetrics ()
Refreshes the appearance metrics.
CXTPTabPaintManagerColorSet * | GetColorSet () const
Gets the color set.
virtual CRect | GetHeaderClipBox (CDC *pDC, CXTPTabManager *pTabManager)
Gets the clip box of the tab header area.
int | GetHeaderHeight (CXTPTabManager *pTabManager)
Gets the height of the tab header area.
virtual CRect | GetHeaderMargin ()
Gets the top, left, right, and bottom margins of the tab header.
virtual CRect | GetClientMargin ()
Gets the top, left, right, and bottom margins of the tab client area.
virtual int | GetButtonLength (CDC *pDC, CXTPTabManagerItem *pItem)
Retrieves the total length of a specified tab button including the left and right button margins.
virtual int | GetButtonHeight (const CXTPTabManager *pTabManager)
Retrieves the total height of the tab buttons within a specified tab manager including the top and bottom margins and the icon.
virtual CRect | GetButtonDrawRect (const CXTPTabManagerItem *pItem)
Retrieves the bounding rectangle of a specified drawing item.
virtual CRect | FillTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl)
Fills both the tab header and the tab client area and then draws the tab client frame.
virtual void | DrawWorkspacePart (CDC *pDC, LPRECT lpRect, XTPTabWorkspacePart workspacePart)
Draws a specified TabMDIClient TabWorkspace part.
virtual int | GetSupportedColorSets ()
Gets the supported color sets for this theme.
virtual XTPTabColorStyle | GetDefaultColorSet ()
Gets the default value of the color set for this theme.
COLORREF | FillButton (CDC *pDC, CXTPTabManagerItem *pItem, LPPOINT pts, int nCount, XTPTabPosition tabPosition, BOOL bAbsolute=FALSE)
Draws a tab button within a specified polygon.
virtual void | DrawText (CDC *pDC, CXTPTabManager *pManager, const CString &str, LPRECT lpRect, UINT nFormat)
Draws the text of a specified item.

Additional Inherited Members

- Public Attributes inherited from CXTPTabPaintManagerTheme
CRect | m_rcHeaderMargin
CRect struct containing the left, top, right, and bottom.
int | m_nRowMargin
margins of the tab header.
- Protected Attributes inherited from CXTPTabPaintManagerTheme
int | m_nButtonHeight
Current tab button height (without margins).
CXTPTabPaintManager * | m_pPaintManager
Self paint manager pointer.
BOOL | m_bButtonsReverseZOrder
Draw buttons in right to left order.

Detailed Description

CAppearanceSetVisio implements a Visio tab appearance.

To use the Visio appearance, SetAppearance is used to apply the xtpTabAppearanceVisio XTPTabAppearanceStyle.

CAppearanceSetVisio supports the following XTPTabColorStyle: xtpTabColorDefault: Default color style. xtpTabColorOffice2003: Office 2003 color style.

See also
XTPTabColorStyle, XTPTabAppearanceStyle, SetAppearance, GetAppearance, GetAppearanceSet, SetColor, GetColor, GetColorSet, SetColorSet, SetAppearanceSet

Member Function Documentation

◆ AdjustClientRect()

void AdjustClientRect | ( | CXTPTabManager * | pTabManager,
 |  | CRect & | rcClient )
 virtual

Adjusts the tab client rectangle.

Parameters
pTabManager | Pointer to the tab manager to adjust the tab client rectangle.
rcClient | [out] Reference to a CRect object to receive the new tab client rectangle with margins included.

Both CXTPTabPaintManager::AdjustClientRect and CXTPTabPaintManager::RepositionTabControl are called when the window is resized. When CXTPTabPaintManager::DrawTabControl is called, the changes will be used when drawing the tab control.

This method will adjust the tab client rectangle based on the currently set XTPTabClientFrame.

CXTPTabPaintManager::AdjustClientRect calls this method if there is one or more tabs in the tab manager.

See also
CXTPTabPaintManager::AdjustClientRect

Reimplemented from CXTPTabPaintManagerTheme.

◆ DrawSingleButton()

void DrawSingleButton | ( | CDC * | pDC,
 |  | CXTPTabManagerItem * | pItem )
 virtual

Draws a single tab button in the tab client header area.

Parameters
pDC | Pointer to a valid device context.
pItem | Pointer to the tab button to draw.

This method is only used to draw the tab button. This method does not draw the button's icon or text.

DrawSingleButton calls CXTPTabPaintManager::DrawSingleButtonIconAndText after the button is drawn to draw the button's icon and text.

See also
CXTPTabPaintManager::DrawTabControlEx, CXTPTabPaintManager::DrawSingleButtonIconAndText

Reimplemented from CXTPTabPaintManagerTheme.

◆ DrawTabControl()

void DrawTabControl | ( | CXTPTabManager * | pTabManager,
 |  | CDC * | pDC,
 |  | CRect | rcControl )
 virtual

Draws the tab control.

Parameters
pTabManager | Pointer to the tab manager to draw.
pDC | Pointer to a valid device context.
rcControl | Bounding rectangle of the client area.

This method is called during various Draw and Paint functions.

This method is called by CXTPTabPaintManager::DrawTabControl when the tab control must be drawn.

Reimplemented from CXTPTabPaintManagerTheme.

◆ GetClientRect()

CRect GetClientRect | ( | CRect | rcControl,
 |  | CXTPTabManager * | pTabManager )
 virtual

Gets the bounding rectangle of the tab client area.

Parameters
rcControl | Bounding rectangle of the tab control.
pTabManager | Pointer to a CXTPTabManager object.
Returns
The bounding rectangle of the tab client area.
See also
GetClientRect, CXTPTabManager::GetControlRect

Reimplemented from CXTPTabPaintManagerTheme.

◆ GetHeaderRect()

CRect GetHeaderRect | ( | CRect | rcControl,
 |  | CXTPTabManager * | pTabManager )
 virtual

Gets the bounding rectangle of the tab header area.

Parameters
rcControl | Bounding rectangle of the tab header. See CXTPTabManager::GetControlRect.
pTabManager | Pointer to a CXTPTabManager object.
Returns
The bounding rectangle of the tab header area.
See also
GetClientRect, CXTPTabManager::GetControlRect, CXTPTabManager::CXTPTabPaintManagerTheme::GetHeaderMargin, CXTPTabManager::CXTPTabPaintManagerTheme::GetClientMargin

Reimplemented from CXTPTabPaintManagerTheme.

◆ RepositionTabControl()

void RepositionTabControl | ( | CXTPTabManager * | pTabManager,
 |  | CDC * | pDC,
 |  | CRect | rcClient )
 virtual

Moves the tab buttons of the tab control to their correct positions.

Parameters
pTabManager | Pointer to the tab manager that the tab buttons are on.
pDC | Pointer to a valid device context.
rcClient | Bounding rectangle of the tab client area.

Both CXTPTabPaintManager::AdjustClientRect and CXTPTabPaintManager::RepositionTabControl are called when the window is resized. When CXTPTabPaintManager::DrawTabControl is called, the changes will be used when drawing the tab control.

This method is called during CXTPTabPaintManager::RepositionTabControl.

Reimplemented from CXTPTabPaintManagerTheme.

The documentation for this class was generated from the following file:
  • XTPTabThemeVisio.h


Toolkit Pro: CAppearanceSetVisualStudio2005 Class Reference

Public Member Functions | List of all members
CAppearanceSetVisualStudio2005 Class Reference

CAppearanceSetVisualStudio2005 implements a Visual Studio 2005 tab appearance. More...

Inheritance diagram for CAppearanceSetVisualStudio2005:
[legend]

Public Member Functions

CAppearanceSetVisualStudio2005 ()
Constructs a CAppearanceSetVisualStudio2005 object.
virtual void | DrawSingleButton (CDC *pDC, CXTPTabManagerItem *pItem)
Draws a single tab button in the tab client header area.
virtual CRect | GetHeaderMargin ()
Gets the top, left, right, and bottom margins of the tab header.
virtual CRect | GetButtonDrawRect (const CXTPTabManagerItem *pItem)
Retrieves the bounding rectangle of a specified drawing item.
- Public Member Functions inherited from CAppearanceSetPropertyPage2003
CAppearanceSetPropertyPage2003 ()
Constructs a CAppearanceSetPropertyPage2003 object.
virtual void | RefreshMetrics ()
Refreshes the appearance metrics.
virtual CRect | FillTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl)
Fills both the tab header and the tab client area and then draws the tab client frame.
virtual XTPTabColorStyle | GetDefaultColorSet ()
Gets the default value of the color set for this theme.
- Public Member Functions inherited from CXTPTabPaintManagerTheme
CXTPTabPaintManagerTheme ()
Constructs a CXTPTabPaintManagerTheme object.
virtual | ~CXTPTabPaintManagerTheme ()
Destroys a CXTPTabPaintManagerTheme object, handles cleanup and deallocation.
CXTPTabPaintManagerColorSet * | GetColorSet () const
Gets the color set.
virtual CRect | GetHeaderRect (CRect rcControl, CXTPTabManager *pTabManager)
Gets the bounding rectangle of the tab header area.
virtual CRect | GetHeaderClipBox (CDC *pDC, CXTPTabManager *pTabManager)
Gets the clip box of the tab header area.
int | GetHeaderHeight (CXTPTabManager *pTabManager)
Gets the height of the tab header area.
virtual CRect | GetClientRect (CRect rcControl, CXTPTabManager *pTabManager)
Gets the bounding rectangle of the tab client area.
virtual CRect | GetClientMargin ()
Gets the top, left, right, and bottom margins of the tab client area.
virtual int | GetButtonLength (CDC *pDC, CXTPTabManagerItem *pItem)
Retrieves the total length of a specified tab button including the left and right button margins.
virtual int | GetButtonHeight (const CXTPTabManager *pTabManager)
Retrieves the total height of the tab buttons within a specified tab manager including the top and bottom margins and the icon.
virtual void | DrawTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl)
Draws the tab control.
virtual void | RepositionTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcClient)
Moves the tab buttons of the tab control to their correct positions.
virtual void | AdjustClientRect (CXTPTabManager *pTabManager, CRect &rcClient)
Adjusts the tab client rectangle.
virtual void | DrawWorkspacePart (CDC *pDC, LPRECT lpRect, XTPTabWorkspacePart workspacePart)
Draws a specified TabMDIClient TabWorkspace part.
virtual int | GetSupportedColorSets ()
Gets the supported color sets for this theme.
COLORREF | FillButton (CDC *pDC, CXTPTabManagerItem *pItem, LPPOINT pts, int nCount, XTPTabPosition tabPosition, BOOL bAbsolute=FALSE)
Draws a tab button within a specified polygon.
virtual void | DrawText (CDC *pDC, CXTPTabManager *pManager, const CString &str, LPRECT lpRect, UINT nFormat)
Draws the text of a specified item.

Additional Inherited Members

- Public Attributes inherited from CAppearanceSetPropertyPage2003
BOOL | m_bDoubleHighlightedBorder
TRUE to draw a double border on mouse over when hot tracking is enabled.
- Public Attributes inherited from CXTPTabPaintManagerTheme
CRect | m_rcHeaderMargin
CRect struct containing the left, top, right, and bottom.
int | m_nRowMargin
margins of the tab header.
- Protected Attributes inherited from CXTPTabPaintManagerTheme
int | m_nButtonHeight
Current tab button height (without margins).
CXTPTabPaintManager * | m_pPaintManager
Self paint manager pointer.
BOOL | m_bButtonsReverseZOrder
Draw buttons in right to left order.

Detailed Description

CAppearanceSetVisualStudio2005 implements a Visual Studio 2005 tab appearance.

To use the Visual Studio appearance, SetAppearance is used to apply the xtpTabAppearanceVisualStudio2005 XTPTabAppearanceStyle.

See also
XTPTabColorStyle, XTPTabAppearanceStyle, SetAppearance, GetAppearance, GetAppearanceSet, SetColor, GetColor, GetColorSet, SetColorSet, SetAppearanceSet

Member Function Documentation

◆ DrawSingleButton()

virtual void DrawSingleButton | ( | CDC * | pDC,
 |  | CXTPTabManagerItem * | pItem )
 virtual

Draws a single tab button in the tab client header area.

Parameters
pDC | Pointer to a valid device context.
pItem | Pointer to the tab button to draw.

This method is only used to draw the tab button. This method does not draw the button's icon or text.

DrawSingleButton calls CXTPTabPaintManager::DrawSingleButtonIconAndText after the button is drawn to draw the button's icon and text.

See also
CXTPTabPaintManager::DrawTabControlEx, CXTPTabPaintManager::DrawSingleButtonIconAndText

Reimplemented from CAppearanceSetPropertyPage2003.

◆ GetButtonDrawRect()

virtual CRect GetButtonDrawRect ( const CXTPTabManagerItem * pItem )
virtual

Retrieves the bounding rectangle of a specified drawing item.

Parameters
pItem Pointer to the drawing item with the bounding rectangle to retrieve.
Returns
The bounding rectangle of the specified drawing item.
See also
CXTPTabManagerItem::GetRect

Reimplemented from CAppearanceSetPropertyPage2003.

◆ GetHeaderMargin()

virtual CRect GetHeaderMargin ( )
inlinevirtual

Gets the top, left, right, and bottom margins of the tab header.

Returns
The top, left, right, and bottom margins of the tab header.

The margins of the tab header are the space placed around the tab buttons inside the tab header.

The margins of the tab header are not placed around each tab button. Instead, they are placed around all tab buttons.

See also
CXTPTabPaintManagerTheme::m_rcHeaderMargin, CXTPTabPaintManager::GetHeaderRect

Reimplemented from CAppearanceSetPropertyPage2003.

The documentation for this class was generated from the following file:
  • XTPTabThemeVisualStudio2005.h


Toolkit Pro: CColorSetVisualStudio2003 Class Reference

Public Member Functions | List of all members
CColorSetVisualStudio2003 Class Reference

CColorSetVisualStudio2003 implements a Visual Studio 2003 tab color set. More...

Inheritance diagram for CColorSetVisualStudio2003:
[legend]

Public Member Functions

virtual void | RefreshMetrics ()
Refreshes the visual metrics of the tabs.
void | FillNavigateButton (CDC *pDC, CXTPTabManagerNavigateButton *pButton, CRect &rc)
Fills a specified tab navigation button.
- Public Member Functions inherited from CXTPTabColorSetDefault
void | FillNavigateButton (CDC *pDC, CXTPTabManagerNavigateButton *pButton, CRect &rc)
Fills a specified tab navigation button.
- Public Member Functions inherited from CXTPTabPaintManagerColorSet
CXTPTabPaintManagerColorSet ()
Constructs a CXTPTabPaintManagerColorSet object.
virtual | ~CXTPTabPaintManagerColorSet ()
Destroys a CXTPTabPaintManagerColorSet object, handles cleanup and deallocation.
virtual void | SetTextColor (CDC *pDC, CXTPTabManagerItem *pItem)
Sets the text color for the tab.
virtual void | FillHeader (CDC *pDC, CRect rc, CXTPTabManager *pTabManager)
Fills the header of the tab client of a specified tab manager.
virtual COLORREF | FillClient (CDC *pDC, CRect rc, CXTPTabManager *pTabManager)
Fills the tab client area of a specified tab manager.
virtual COLORREF | GetClientColor (CXTPTabManager *pTabManager)
Obtains client background color.
virtual void | FillStateButton (CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem)
Fills a specified tab button when XTPTabAppearanceStyle is xtpTabAppearanceStateButtons.
virtual COLORREF | FillPropertyButton (CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem)
Fills a specified tab button.
virtual void | SelectClipRgn (CDC *pDC, CRect rcClient, CXTPTabManager *pTabManager)
Sets a clipping region for the specified tab client area.
virtual COLORREF | GetItemColor (CXTPTabManagerItem *pItem)
Retrieves the color of a specified tab.
void | GradientFill (CDC *pDC, CRect rc, COLORREF clrLight, COLORREF clrDark, XTPTabPosition position)
Performs a gradient fill of a rectangle with a color that smoothly fades from top to bottom.
virtual BOOL | IsAppThemed () const
Determines if Windows XP themes are enabled and if a Windows XP theme is currently used.

Additional Inherited Members

- Public Attributes inherited from CXTPTabPaintManagerColorSet
CXTPPaintManagerColorGradient | m_clrHeaderFace
Color set of the tab header background.
CXTPPaintManagerColorGradient m_clrAutoHideFace
Color set of the auto-hide panel background.
CXTPPaintManagerColor | m_clrFrameBorder
Color of the border placed around the tab buttons and the tab client.
CXTPPaintManagerColor m_clrControlFace
Color of the control foreground.
CXTPPaintManagerColor | m_clrPaneFace
Color of the control pane foreground.
CXTPPaintManagerColor | m_clrBorderHighlight
Color of the highlight border.
CXTPPaintManagerColor | m_clrTabClientBack
Background color for the tab client area.
CXTPPaintManagerColor | m_clrTabClientBorder
Border color for the tab client area.
CXTPPaintManagerColor m_clrButtonNormal
Color of normal tabs.
CXTPPaintManagerColor | m_clrButtonPressed
Tab pressed button color.
CXTPPaintManagerColor | m_clrButtonHighlighted
Tab button color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonHighlightedClose
Tab close button color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonBorderHighlighted
Tab button border color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonBorderTabContext1
Tab button border color with tab context.
CXTPPaintManagerColor | m_clrButtonBorderTabContext2
Tab button border color with tab context.
CXTPPaintManagerColor | m_clrButtonBorderKeyTips
Tab button border color when ALT button is pressed.
CXTPPaintManagerColor | m_clrButtonSelected
Color of the currently selected tab.
CXTPPaintManagerColor | m_clrButtonSelectedPressed
Color of the currently selected tab when pressed.
CXTPPaintManagerColor | m_clrButtonSelectedHighlighted
Color of the currently selected tab when highlighted.
CXTPPaintManagerColor | m_clrButtonBorder
Tab button border (edge) color.
CXTPPaintManagerColor | m_clrButtonBorderHot
Tab button highlight or pressed border (edge) color.
CXTPPaintManagerColor m_clrTextNormal
Color of text in a normal tab.
CXTPPaintManagerColor m_clrTextPressed
Color of text in a "pressed" tab button.
CXTPPaintManagerColor | m_clrTextHighlight
Color of text on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrTextHighlightClose
Color of close button text on mouse over when hot tracking is enabled.
CXTPPaintManagerColor m_clrTextSelected
Color of text in a "selected" tab button.
CXTPPaintManagerColor m_clrTextSelectedPressed
Color of text in a "pressed" tab button.
CXTPPaintManagerColor | m_clrTextSelectedHighlighted
Color of text for tabs in all non-active groups of tabs in MDITabClient.
CXTPPaintManagerColor m_clrTextDisabled
Color of text when a tab is disabled.
CXTPPaintManagerColor | m_clrActiveFilesGlyph
Color of navigation button.
CXTPPaintManagerColor | m_clrActiveFilesGlyphHighlighted
Color of highlighted navigation button.
CXTPPaintManagerColor | m_clrActiveFilesGlyphPressed
Color of selected navigation button.
CXTPPaintManagerColor | m_clrActiveFilesBack
Color of highlighted navigation button background.
CXTPPaintManagerColor | m_clrActiveFilesBackHighlighted
Color of navigation button background.
CXTPPaintManagerColor | m_clrActiveFilesBackPressed
Color of selected navigation button background.
COLORSET_TAB_STATEBUTTON | m_csStateButton
Color set of state button style tabs.
COLORSET_TAB_PROPERTYPAGE | m_csPropertyPage
Color set of visual studio style tabs.
COLORSET_TAB_PROPERTYPAGE2003 | m_csPropertyPage2003
Color set of Office 2003 style tabs.
COLORSET_TAB_EXCEL | m_csExcelSelected
Color set of selected (focused) Excel style tabs.
COLORSET_TAB_EXCEL | m_csExcelNormal
Color set of normal Excel style tabs.
- Protected Attributes inherited from CXTPTabPaintManagerColorSet
CXTPTabPaintManager * | m_pPaintManager
Self paint manager pointer.

Detailed Description

CColorSetVisualStudio2003 implements a Visual Studio 2003 tab color set.

To use the Visual Studio 2003 color set, SetColor is used to apply the xtpTabColorVisualStudio2003 XTPTabColorStyle.

See also
XTPTabColorStyle, XTPTabAppearanceStyle, SetAppearance, GetAppearance, GetAppearanceSet, SetColor, GetColor, GetColorSet, SetColorSet, SetAppearanceSet

Member Function Documentation

◆ FillNavigateButton()

void FillNavigateButton | ( | CDC * | pDC,
 |  | CXTPTabManagerNavigateButton * | pButton,
 |  | CRect & | rc )
 virtual

Fills a specified tab navigation button.

Parameters
pDC | Pointer to a valid device context.
pButton | Pointer to the tab navigation button to fill.
rc | Reference to the bounding rectangle of the tab navigation button.

This method is used to fill the tab navigation buttons in the header of the tab client and is overridden by XTPTabColorStyle and CXTPTabPaintManagerColorSet to perform actions such as painting the highlighted, pressed, and normal versions of tab navigation buttons.

See also
CXTPTabManager::GetNavigateButton, CXTPTabManagerNavigateButton

Implements CXTPTabPaintManagerColorSet.

◆ RefreshMetrics()

virtual void RefreshMetrics ( )
virtual

Refreshes the visual metrics of the tabs.

Override this method to change the colors of the color members.

All of the color members are refreshed when this method is called.

Reimplemented from CXTPTabColorSetDefault.

The documentation for this class was generated from the following file:
  • XTPTabColorSetVisualStudio2003.h


Toolkit Pro: CColorSetVisualStudio2005 Class Reference

Public Member Functions | Protected Attributes | List of all members
CColorSetVisualStudio2005 Class Reference

CColorSetVisualStudio2005 implements a Visual Studio 2005 tab color set. More...

Inheritance diagram for CColorSetVisualStudio2005:
[legend]

Public Member Functions

CColorSetVisualStudio2005 ()
Constructs a CColorSetVisualStudio2005 object.
void | RefreshMetrics ()
Refreshes the visual metrics of the tabs.
COLORREF | FillPropertyButton (CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem)
Fills a specified tab button.
- Public Member Functions inherited from CXTPTabColorSetOffice2003
virtual void | FillNavigateButton (CDC *pDC, CXTPTabManagerNavigateButton *pButton, CRect &rc)
Fills a specified tab navigation button.
void | Rectangle (CDC *pDC, CRect rc, int nPen, int nBrush)
Draws a rectangle with a border.
- Public Member Functions inherited from CXTPTabColorSetDefault
- Public Member Functions inherited from CXTPTabPaintManagerColorSet
CXTPTabPaintManagerColorSet ()
Constructs a CXTPTabPaintManagerColorSet object.
virtual | ~CXTPTabPaintManagerColorSet ()
Destroys a CXTPTabPaintManagerColorSet object, handles cleanup and deallocation.
virtual void | SetTextColor (CDC *pDC, CXTPTabManagerItem *pItem)
Sets the text color for the tab.
virtual void | FillHeader (CDC *pDC, CRect rc, CXTPTabManager *pTabManager)
Fills the header of the tab client of a specified tab manager.
virtual COLORREF | FillClient (CDC *pDC, CRect rc, CXTPTabManager *pTabManager)
Fills the tab client area of a specified tab manager.
virtual COLORREF | GetClientColor (CXTPTabManager *pTabManager)
Obtains client background color.
virtual void | FillStateButton (CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem)
Fills a specified tab button when XTPTabAppearanceStyle is xtpTabAppearanceStateButtons.
virtual void | SelectClipRgn (CDC *pDC, CRect rcClient, CXTPTabManager *pTabManager)
Sets a clipping region for the specified tab client area.
virtual COLORREF | GetItemColor (CXTPTabManagerItem *pItem)
Retrieves the color of a specified tab.
void | GradientFill (CDC *pDC, CRect rc, COLORREF clrLight, COLORREF clrDark, XTPTabPosition position)
Performs a gradient fill of a rectangle with a color that smoothly fades from top to bottom.
virtual BOOL | IsAppThemed () const
Determines if Windows XP themes are enabled and if a Windows XP theme is currently used.

Protected Attributes

BOOL | m_bGradientButton
TRUE if luna colors are enabled.
- Protected Attributes inherited from CXTPTabColorSetOffice2003
CXTPPaintManagerColor | m_clrNavigateButtonBorder
Border color of tab navigation buttons on mouse over.
BOOL | m_bLunaTheme
TRUE if the current system theme is xtpSystemThemeSilver, xtpSystemThemeOlive or xtpSystemThemeOlive, otherwise FALSE.
- Protected Attributes inherited from CXTPTabPaintManagerColorSet
CXTPTabPaintManager * | m_pPaintManager
Self paint manager pointer.

Additional Inherited Members

- Public Attributes inherited from CXTPTabPaintManagerColorSet
CXTPPaintManagerColorGradient | m_clrHeaderFace
Color set of the tab header background.
CXTPPaintManagerColorGradient m_clrAutoHideFace
Color set of the auto-hide panel background.
CXTPPaintManagerColor | m_clrFrameBorder
Color of the border placed around the tab buttons and the tab client.
CXTPPaintManagerColor m_clrControlFace
Color of the control foreground.
CXTPPaintManagerColor | m_clrPaneFace
Color of the control pane foreground.
CXTPPaintManagerColor | m_clrBorderHighlight
Color of the highlight border.
CXTPPaintManagerColor | m_clrTabClientBack
Background color for the tab client area.
CXTPPaintManagerColor | m_clrTabClientBorder
Border color for the tab client area.
CXTPPaintManagerColor m_clrButtonNormal
Color of normal tabs.
CXTPPaintManagerColor | m_clrButtonPressed
Tab pressed button color.
CXTPPaintManagerColor | m_clrButtonHighlighted
Tab button color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonHighlightedClose
Tab close button color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonBorderHighlighted
Tab button border color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonBorderTabContext1
Tab button border color with tab context.
CXTPPaintManagerColor | m_clrButtonBorderTabContext2
Tab button border color with tab context.
CXTPPaintManagerColor | m_clrButtonBorderKeyTips
Tab button border color when ALT button is pressed.
CXTPPaintManagerColor | m_clrButtonSelected
Color of the currently selected tab.
CXTPPaintManagerColor | m_clrButtonSelectedPressed
Color of the currently selected tab when pressed.
CXTPPaintManagerColor | m_clrButtonSelectedHighlighted
Color of the currently selected tab when highlighted.
CXTPPaintManagerColor | m_clrButtonBorder
Tab button border (edge) color.
CXTPPaintManagerColor | m_clrButtonBorderHot
Tab button highlight or pressed border (edge) color.
CXTPPaintManagerColor m_clrTextNormal
Color of text in a normal tab.
CXTPPaintManagerColor m_clrTextPressed
Color of text in a "pressed" tab button.
CXTPPaintManagerColor | m_clrTextHighlight
Color of text on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrTextHighlightClose
Color of close button text on mouse over when hot tracking is enabled.
CXTPPaintManagerColor m_clrTextSelected
Color of text in a "selected" tab button.
CXTPPaintManagerColor m_clrTextSelectedPressed
Color of text in a "pressed" tab button.
CXTPPaintManagerColor | m_clrTextSelectedHighlighted
Color of text for tabs in all non-active groups of tabs in MDITabClient.
CXTPPaintManagerColor m_clrTextDisabled
Color of text when a tab is disabled.
CXTPPaintManagerColor | m_clrActiveFilesGlyph
Color of navigation button.
CXTPPaintManagerColor | m_clrActiveFilesGlyphHighlighted
Color of highlighted navigation button.
CXTPPaintManagerColor | m_clrActiveFilesGlyphPressed
Color of selected navigation button.
CXTPPaintManagerColor | m_clrActiveFilesBack
Color of highlighted navigation button background.
CXTPPaintManagerColor | m_clrActiveFilesBackHighlighted
Color of navigation button background.
CXTPPaintManagerColor | m_clrActiveFilesBackPressed
Color of selected navigation button background.
COLORSET_TAB_STATEBUTTON | m_csStateButton
Color set of state button style tabs.
COLORSET_TAB_PROPERTYPAGE | m_csPropertyPage
Color set of visual studio style tabs.
COLORSET_TAB_PROPERTYPAGE2003 | m_csPropertyPage2003
Color set of Office 2003 style tabs.
COLORSET_TAB_EXCEL | m_csExcelSelected
Color set of selected (focused) Excel style tabs.
COLORSET_TAB_EXCEL | m_csExcelNormal
Color set of normal Excel style tabs.

Detailed Description

CColorSetVisualStudio2005 implements a Visual Studio 2005 tab color set.

To use the Visual Studio 2005 color set, SetColor is used to apply the xtpTabColorVisualStudio2005 XTPTabColorStyle.

The following appearances (XTPTabAppearanceStyle) support CColorSetVisualStudio2005: xtpTabAppearancePropertyPage2003: Office 2003 appearance. xtpTabAppearanceStateButtons: State Button appearance.

See also
XTPTabColorStyle, XTPTabAppearanceStyle, SetAppearance, GetAppearance, GetAppearanceSet, SetColor, GetColor, GetColorSet, SetColorSet, SetAppearanceSet

Member Function Documentation

◆ FillPropertyButton()

COLORREF FillPropertyButton | ( | CDC * | pDC,
 |  | CRect | rcItem,
 |  | CXTPTabManagerItem * | pItem )
 virtual

Fills a specified tab button.

Parameters
pDC | Pointer to a valid device context.
rcItem | Bounding rectangle of the tab button to fill.
pItem | Pointer to the tab button to fill.
Returns
The color of the specified tab button.

This method is used to fill all tab buttons except when XTPTabAppearanceStyle is set to xtpTabAppearanceStateButtons. xtpTabAppearanceStateButtons requires the FillStateButton member.

If m_bGradientButton is TRUE, then CXTPTabColorSetOffice2003::FillPropertyButton is used to fill the tab button with a gradient fill. See CXTPTabColorSetOffice2003::FillPropertyButton for details.

If m_bGradientButton is FALSE, then CXTPTabPaintManagerColorSet::FillPropertyButton is used.

See also
m_bGradientButton

Reimplemented from CXTPTabColorSetOffice2003.

◆ RefreshMetrics()

void RefreshMetrics ( )
virtual

Refreshes the visual metrics of the tabs.

Override this method to change the colors of the color members.

All of the color members are refreshed when this method is called.

Reimplemented from CXTPTabColorSetOffice2003.

Member Data Documentation

◆ m_bGradientButton

BOOL m_bGradientButton
protected

TRUE if luna colors are enabled.

This will be TRUE when using Windows XP and the current system theme is xtpSystemThemeSilver, xtpSystemThemeOlive or xtpSystemThemeOlive, otherwise FALSE.

The documentation for this class was generated from the following file:
  • XTPTabColorSetVisualStudio2005.h


Toolkit Pro: CColorSetWinNative Class Reference

Public Member Functions | Protected Attributes | List of all members
CColorSetWinNative Class Reference

CColorSetWinNative implements a Windows XP tab color set. More...

Inheritance diagram for CColorSetWinNative:
[legend]

Public Member Functions

virtual void | RefreshMetrics ()
Refreshes the visual metrics of the tabs.
virtual COLORREF | FillPropertyButton (CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem)
Fills a specified tab button.
virtual COLORREF | FillClient (CDC *pDC, CRect rc, CXTPTabManager *pTabManager)
Fills the tab client area of a specified tab manager.
virtual void | SelectClipRgn (CDC *pDC, CRect rcClient, CXTPTabManager *pTabManager)
Sets a clipping region for the specified tab client area.
virtual void | FillNavigateButton (CDC *pDC, CXTPTabManagerNavigateButton *pButton, CRect &rc)
Fills a specified tab navigation button.
virtual void | FillStateButton (CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem)
Fills a specified tab button when XTPTabAppearanceStyle is xtpTabAppearanceStateButtons.
virtual BOOL | IsAppThemed () const
Determines if Windows XP themes are enabled and if a Windows XP theme is currently used.
- Public Member Functions inherited from CXTPTabColorSetDefault
void | FillNavigateButton (CDC *pDC, CXTPTabManagerNavigateButton *pButton, CRect &rc)
Fills a specified tab navigation button.
- Public Member Functions inherited from CXTPTabPaintManagerColorSet
CXTPTabPaintManagerColorSet ()
Constructs a CXTPTabPaintManagerColorSet object.
virtual | ~CXTPTabPaintManagerColorSet ()
Destroys a CXTPTabPaintManagerColorSet object, handles cleanup and deallocation.
virtual void | SetTextColor (CDC *pDC, CXTPTabManagerItem *pItem)
Sets the text color for the tab.
virtual void | FillHeader (CDC *pDC, CRect rc, CXTPTabManager *pTabManager)
Fills the header of the tab client of a specified tab manager.
virtual COLORREF | GetClientColor (CXTPTabManager *pTabManager)
Obtains client background color.
virtual COLORREF | GetItemColor (CXTPTabManagerItem *pItem)
Retrieves the color of a specified tab.
void | GradientFill (CDC *pDC, CRect rc, COLORREF clrLight, COLORREF clrDark, XTPTabPosition position)
Performs a gradient fill of a rectangle with a color that smoothly fades from top to bottom.

Protected Attributes

CXTPWinThemeWrapper * | m_themeTabButton
Internally used helper to draw property page buttons using Windows XP color set.
CXTPWinThemeWrapper * | m_themeToolbar
Internally used helper to draw state buttons using Windows XP color set.
- Protected Attributes inherited from CXTPTabPaintManagerColorSet
CXTPTabPaintManager * | m_pPaintManager
Self paint manager pointer.

Additional Inherited Members

- Public Attributes inherited from CXTPTabPaintManagerColorSet
CXTPPaintManagerColorGradient | m_clrHeaderFace
Color set of the tab header background.
CXTPPaintManagerColorGradient m_clrAutoHideFace
Color set of the auto-hide panel background.
CXTPPaintManagerColor | m_clrFrameBorder
Color of the border placed around the tab buttons and the tab client.
CXTPPaintManagerColor m_clrControlFace
Color of the control foreground.
CXTPPaintManagerColor | m_clrPaneFace
Color of the control pane foreground.
CXTPPaintManagerColor | m_clrBorderHighlight
Color of the highlight border.
CXTPPaintManagerColor | m_clrTabClientBack
Background color for the tab client area.
CXTPPaintManagerColor | m_clrTabClientBorder
Border color for the tab client area.
CXTPPaintManagerColor m_clrButtonNormal
Color of normal tabs.
CXTPPaintManagerColor | m_clrButtonPressed
Tab pressed button color.
CXTPPaintManagerColor | m_clrButtonHighlighted
Tab button color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonHighlightedClose
Tab close button color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonBorderHighlighted
Tab button border color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonBorderTabContext1
Tab button border color with tab context.
CXTPPaintManagerColor | m_clrButtonBorderTabContext2
Tab button border color with tab context.
CXTPPaintManagerColor | m_clrButtonBorderKeyTips
Tab button border color when ALT button is pressed.
CXTPPaintManagerColor | m_clrButtonSelected
Color of the currently selected tab.
CXTPPaintManagerColor | m_clrButtonSelectedPressed
Color of the currently selected tab when pressed.
CXTPPaintManagerColor | m_clrButtonSelectedHighlighted
Color of the currently selected tab when highlighted.
CXTPPaintManagerColor | m_clrButtonBorder
Tab button border (edge) color.
CXTPPaintManagerColor | m_clrButtonBorderHot
Tab button highlight or pressed border (edge) color.
CXTPPaintManagerColor m_clrTextNormal
Color of text in a normal tab.
CXTPPaintManagerColor m_clrTextPressed
Color of text in a "pressed" tab button.
CXTPPaintManagerColor | m_clrTextHighlight
Color of text on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrTextHighlightClose
Color of close button text on mouse over when hot tracking is enabled.
CXTPPaintManagerColor m_clrTextSelected
Color of text in a "selected" tab button.
CXTPPaintManagerColor m_clrTextSelectedPressed
Color of text in a "pressed" tab button.
CXTPPaintManagerColor | m_clrTextSelectedHighlighted
Color of text for tabs in all non-active groups of tabs in MDITabClient.
CXTPPaintManagerColor m_clrTextDisabled
Color of text when a tab is disabled.
CXTPPaintManagerColor | m_clrActiveFilesGlyph
Color of navigation button.
CXTPPaintManagerColor | m_clrActiveFilesGlyphHighlighted
Color of highlighted navigation button.
CXTPPaintManagerColor | m_clrActiveFilesGlyphPressed
Color of selected navigation button.
CXTPPaintManagerColor | m_clrActiveFilesBack
Color of highlighted navigation button background.
CXTPPaintManagerColor | m_clrActiveFilesBackHighlighted
Color of navigation button background.
CXTPPaintManagerColor | m_clrActiveFilesBackPressed
Color of selected navigation button background.
COLORSET_TAB_STATEBUTTON | m_csStateButton
Color set of state button style tabs.
COLORSET_TAB_PROPERTYPAGE | m_csPropertyPage
Color set of visual studio style tabs.
COLORSET_TAB_PROPERTYPAGE2003 | m_csPropertyPage2003
Color set of Office 2003 style tabs.
COLORSET_TAB_EXCEL | m_csExcelSelected
Color set of selected (focused) Excel style tabs.
COLORSET_TAB_EXCEL | m_csExcelNormal
Color set of normal Excel style tabs.

Detailed Description

CColorSetWinNative implements a Windows XP tab color set.

To use the Windows XP color set, SetColor is used to apply the xtpTabColorWinNative XTPTabColorStyle.

The following appearances (XTPTabAppearanceStyle) support CColorSetWinNative: xtpTabAppearancePropertyPage: Office 2000 appearance. xtpTabAppearancePropertyPageSelected: Office 2000 selected appearance. xtpTabAppearanceStateButtons: State Button appearance.

See also
XTPTabColorStyle, XTPTabAppearanceStyle, SetAppearance, GetAppearance, GetAppearanceSet, SetColor, GetColor, GetColorSet, SetColorSet, SetAppearanceSet

Member Function Documentation

◆ FillClient()

virtual COLORREF FillClient | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | CXTPTabManager * | pTabManager )
 virtual

Fills the tab client area of a specified tab manager.

Parameters
pDC | Pointer to a valid device context.
rc | Bounding rectangle of the tab client area.
pTabManager | Pointer to the tab manager with the tab client area to fill.

The bounding rectangle of the tab client area can be retrieved by using CXTPTabPaintManagerTheme::GetClientRect or CXTPTabManager::GetClientRect.

Returns
If IsAppThemed is TRUE, then a value of 0 is returned.

If IsAppThemed is FALSE and a tab is selected, then the color from CXTPTabManager::GetItemColor for the currently selected tab is returned.

If IsAppThemed is FALSE and a tab is not selected, then CXTPTabPaintManagerColorSet::m_clrButtonSelected is returned.

Reimplemented from CXTPTabPaintManagerColorSet.

◆ FillNavigateButton()

virtual void FillNavigateButton | ( | CDC * | pDC,
 |  | CXTPTabManagerNavigateButton * | pButton,
 |  | CRect & | rc )
 virtual

Fills a specified tab navigation button.

Parameters
pDC | Pointer to a valid device context.
pButton | Pointer to the tab navigation button to fill.
rc | Reference to the bounding rectangle of the tab navigation button.

This method is used to fill the tab navigation buttons in the header of the tab client and is overridden by XTPTabColorStyle and CXTPTabPaintManagerColorSet to perform actions such as painting the highlighted, pressed, and normal versions of tab navigation buttons.

If IsAppThemed is FALSE, then CXTPTabColorSetDefault::FillNavigationButton is used.

See also
CXTPTabManager::GetNavigateButton, CXTPTabManagerNavigateButton

Implements CXTPTabPaintManagerColorSet.

◆ FillPropertyButton()

virtual COLORREF FillPropertyButton | ( | CDC * | pDC,
 |  | CRect | rcItem,
 |  | CXTPTabManagerItem * | pItem )
 virtual

Fills a specified tab button.

Parameters
pDC | Pointer to a valid device context.
rcItem | Bounding rectangle of the tab button to fill.
pItem | Pointer to the tab button to fill.
Returns
XTP_TABMANAGER_COLOR_NONE

This method is used to fill all tab buttons except when XTPTabAppearanceStyle is set to xtpTabAppearanceStateButtons. xtpTabAppearanceStateButtons requires the FillStateButton member.

If IsAppThemed is FALSE, then CXTPTabColorSetDefault::FillPropertyButton is used.

See also
FillStateButton

Reimplemented from CXTPTabPaintManagerColorSet.

◆ FillStateButton()

virtual void FillStateButton | ( | CDC * | pDC,
 |  | CRect | rcItem,
 |  | CXTPTabManagerItem * | pItem )
 virtual

Fills a specified tab button when XTPTabAppearanceStyle is xtpTabAppearanceStateButtons.

Parameters
pDC | Pointer to a valid device context.
rcItem | Bounding rectangle of the tab button to fill.
pItem | Pointer to the tab button to fill.

This method is only used to fill buttons when XTPTabAppearanceStyle is xtpTabAppearanceStateButtons. Otherwise, FillPropertyButton is used.

If IsAppThemed is FALSE and/or the tab button is not selected, then CXTPTabColorSetDefault::FillStateButton is used.

See also
FillPropertyButton

Reimplemented from CXTPTabPaintManagerColorSet.

◆ IsAppThemed()

virtual BOOL IsAppThemed ( ) const
virtual

Determines if Windows XP themes are enabled and if a Windows XP theme is currently used.

Returns
TRUE if Windows XP themes are enabled and if a Windows XP theme is currently used, otherwise FALSE.

IsAppThemed will return FALSE if running an operating system before Windows XP (i.e. 98, 2000, NT) or if Windows XP is used with Standard/Classic themes.

This method is called internally to determine how to colorize tab buttons. If this method returns TRUE, then Windows XP colorization is used to colorize tab buttons. If this method returns FALSE, then CXTPTabPaintManager::CXTPTabColorSetDefault is used to colorize tab buttons.

See also
CXTPTabPaintManager::IsAppThemed

Reimplemented from CXTPTabPaintManagerColorSet.

◆ RefreshMetrics()

virtual void RefreshMetrics ( )
virtual

Refreshes the visual metrics of the tabs.

Override this method to change the colors of the color members.

All of the color members are refreshed when this method is called.

Reimplemented from CXTPTabColorSetDefault.

◆ SelectClipRgn()

virtual void SelectClipRgn | ( | CDC * | pDC,
 |  | CRect | rcClient,
 |  | CXTPTabManager * | pTabManager )
 virtual

Sets a clipping region for the specified tab client area.

Parameters
pDC | Pointer to a valid device context.
rcClient | Bounding rectangle of the tab client area. This will be the clipping region for the device context.
pTabManager | Pointer to the tab manager.

Reimplemented from CXTPTabPaintManagerColorSet.

The documentation for this class was generated from the following file:
  • XTPTabColorSetWinNative.h


Toolkit Pro: CXTPActiveScriptEngine Class Reference

Public Member Functions | List of all members
CXTPActiveScriptEngine Class Reference

Implements ActiveScript engine component. More...

Inheritance diagram for CXTPActiveScriptEngine:
[legend]

Public Member Functions

CXTPActiveScriptEngine ()
Constructs scripting engine object.
virtual | ~CXTPActiveScriptEngine ()
Handles scripting engine deallocation.
HRESULT | Initialize (LPCWSTR lpszEngineProgId, IActiveScriptSite *pSite=NULL)
Initializes scripting engine.
void | Uninitialize ()
Uninitializes scripting engine.
HRESULT | LoadCode (LPCWSTR lpszCode)
Loads a chunk of code into execution context.
HRESULT | Run ()
Runs execution context.
CXTPActiveScriptObjectContext * | GetGlobalContext () const
Obtains global object's context instance.
CXTPActiveScriptObjectContext * | CreateContext (LPDISPATCH pDispObject) const
This member is called to create a context instance pointer.
const ExceptionData * | GetExceptionData () const
Information about the last unhandled exception.
const EXCEPINFO * | GetExceptionInfo () const
Information about the last unhandled exception.
HRESULT | AddNamedItem (LPCWSTR lpszName, LPVOID lpItemData=NULL, DWORD dwFlags=SCRIPTITEM_ISVISIBLE)
Adds named item name and data into execution context.
LPVOID | GetNamedItemData (LPCWSTR lpszName) const
Obtains data pointer associated with named item.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

Implements ActiveScript engine component.

Member Function Documentation

◆ AddNamedItem()

HRESULT AddNamedItem | ( | LPCWSTR | lpszName,
 |  | LPVOID | lpItemData = NULL,
 |  | DWORD | dwFlags = SCRIPTITEM_ISVISIBLE )

Adds named item name and data into execution context.

Parameters
lpszName | Item name pointer.
lpItemData | Opional item data pointer.
dwFlags | Item flags. For all available values refer to IActiveScript::AddNamedItem Win32 SDK documentation.
Returns
S_OK if successful.

◆ CreateContext()

CXTPActiveScriptObjectContext * CreateContext ( LPDISPATCH pDispObject ) const

This member is called to create a context instance pointer.

Parameters
pDispObject Points to a DISPATCH object.
Returns
A pointer to a CXTPActiveScriptObjectContext object.

◆ GetExceptionData()

const ExceptionData * GetExceptionData ( ) const

Information about the last unhandled exception.

Returns
The last unhandled exception data pointer or NULL.

◆ GetExceptionInfo()

const EXCEPINFO * GetExceptionInfo ( ) const

Information about the last unhandled exception.

Returns
The last unhandled exception data pointer or NULL.

◆ GetGlobalContext()

CXTPActiveScriptObjectContext * GetGlobalContext ( ) const

Obtains global object's context instance.

Returns
Global object's context instance pointer or NULL if failed.

◆ GetNamedItemData()

LPVOID GetNamedItemData ( LPCWSTR lpszName ) const

Obtains data pointer associated with named item.

Parameters
lpszName Item name pointer.
Returns
Item data pointer value or NULL if not specified.

◆ Initialize()

HRESULT Initialize | ( | LPCWSTR | lpszEngineProgId,
 |  | IActiveScriptSite * | pSite = NULL )

Initializes scripting engine.

Parameters
lpszEngineProgId | ProgID of scripting language to initialize scripting engine for. Standard ProgIDs are JScript and VBScript. More language providers can be installed if necessary.
pSite | An optional pointer to an engine site interface that receives notifications and requests from the scripting engine.
Returns
S_OK if successful.

◆ LoadCode()

HRESULT LoadCode ( LPCWSTR lpszCode )

Loads a chunk of code into execution context.

Number of chunks of code in one execution context is unlimited.

Parameters
lpszCode Chunk code.
Returns
S_OK if successful.

◆ Run()

HRESULT Run ( )

Runs execution context.

Returns
S_OK if successful.
The documentation for this class was generated from the following file:
  • XTPActiveScriptEngine.h


Toolkit Pro: CXTPActiveScriptObjectContext Class Reference

Public Member Functions | List of all members
CXTPActiveScriptObjectContext Class Reference

Wrapper around scriptable object. More...

Public Member Functions

ULONG | AddRef ()
Increments context reference count.
ULONG | Release ()
Decrements context reference count.
CXTPActiveScriptEngine * GetEngine ()
Obtains parent scripting engine instance pointer.
const CXTPActiveScriptEngine * | GetEngine () const
Obtains parent scripting engine instance pointer.
HRESULT | GetValue (LPCWSTR lpszName, CComVariant *pvtResult)
Obtains named property value.
HRESULT | SetValue (LPCWSTR lpszName, VARIANT vtValue)
Sets named property value.
HRESULT | InvokeWithArgs (VARIANT *lpArguments, UINT nCount, VARIANT *pvtResult=NULL)
Invokes a function object.
HRESULT | Invoke (VARIANT *pvtResult=NULL)
Invokes a function object with no arguments.
template<class A1 >
HRESULT | Invoke (A1 arg1, VARIANT *pvtResult=NULL)
Invokes a function object with 1 argument.
template<class A1 , class A2 >
HRESULT | Invoke (A1 arg1, A2 arg2, VARIANT *pvtResult=NULL)
Invokes a function object with 1 argument.
template<class A1 , class A2 , class A3 >
HRESULT | Invoke (A1 arg1, A2 arg2, A3 arg3, VARIANT *pvtResult=NULL)
Invokes a function object with 1 argument.
template<class A1 , class A2 , class A3 , class A4 >
HRESULT | Invoke (A1 arg1, A2 arg2, A3 arg3, A4 arg4, VARIANT *pvtResult=NULL)
Invokes a function object with 1 argument.
template<class A1 , class A2 , class A3 , class A4 , class A5 >
HRESULT | Invoke (A1 arg1, A2 arg2, A3 arg3, A4 arg4, A5 arg5, VARIANT *pvtResult=NULL)
Invokes a function object with 1 argument.
CXTPActiveScriptObjectContext * | GetContext (LPCWSTR lpszName)
Obtains context object's property or function.

Detailed Description

Wrapper around scriptable object.

Member Function Documentation

◆ AddRef()

ULONG AddRef ( )

Increments context reference count.

Returns
Current number of references.

◆ GetContext()

CXTPActiveScriptObjectContext * GetContext ( LPCWSTR lpszName )

Obtains context object's property or function.

Parameters
lpszName Name of object's property or function.
Returns
A pointer to new context object or NULL if failed.

◆ GetEngine() [1/2]

CXTPActiveScriptEngine * GetEngine ( )

Obtains parent scripting engine instance pointer.

Returns
A pointer to a CXTPActiveScriptEngine object.

◆ GetEngine() [2/2]

const CXTPActiveScriptEngine * GetEngine ( ) const

Obtains parent scripting engine instance pointer.

Returns
A pointer to a CXTPActiveScriptEngine object.

◆ GetValue()

HRESULT GetValue | ( | LPCWSTR | lpszName,
 |  | CComVariant * | pvtResult )

Obtains named property value.

Parameters
lpszName | Object's property name.
pvtResult | A pointer to a value that receives property value.
Returns
S_OK if successful or standard COM error code.

◆ Invoke() [1/6]

template<class A1 , class A2 , class A3 , class A4 , class A5 >
HRESULT Invoke | ( | A1 | arg1,
 |  | A2 | arg2,
 |  | A3 | arg3,
 |  | A4 | arg4,
 |  | A5 | arg5,
 |  | VARIANT * | pvtResult = NULL )

Invokes a function object with 1 argument.

Parameters
arg1 | 1st function argument.
arg2 | 2nd function argument.
arg3 | 3rd function argument.
arg4 | 4th function argument.
arg5 | 5th function argument.
pvtResult | Optional pointer to value that revceives a value returned from function.
Returns
S_OK if successful or standard COM error code.

◆ Invoke() [2/6]

template<class A1 , class A2 , class A3 , class A4 >
HRESULT Invoke | ( | A1 | arg1,
 |  | A2 | arg2,
 |  | A3 | arg3,
 |  | A4 | arg4,
 |  | VARIANT * | pvtResult = NULL )

Invokes a function object with 1 argument.

Parameters
arg1 | 1st function argument.
arg2 | 2nd function argument.
arg3 | 3rd function argument.
arg4 | 4th function argument.
pvtResult | Optional pointer to value that revceives a value returned from function.
Returns
S_OK if successful or standard COM error code.

◆ Invoke() [3/6]

template<class A1 , class A2 , class A3 >
HRESULT Invoke | ( | A1 | arg1,
 |  | A2 | arg2,
 |  | A3 | arg3,
 |  | VARIANT * | pvtResult = NULL )

Invokes a function object with 1 argument.

Parameters
arg1 | 1st function argument.
arg2 | 2nd function argument.
arg3 | 3rd function argument.
pvtResult | Optional pointer to value that revceives a value returned from function.
Returns
S_OK if successful or standard COM error code.

◆ Invoke() [4/6]

template<class A1 , class A2 >
HRESULT Invoke | ( | A1 | arg1,
 |  | A2 | arg2,
 |  | VARIANT * | pvtResult = NULL )

Invokes a function object with 1 argument.

Parameters
arg1 | 1st function argument.
arg2 | 2nd function argument.
pvtResult | Optional pointer to value that revceives a value returned from function.
Returns
S_OK if successful or standard COM error code.

◆ Invoke() [5/6]

template<class A1 >
HRESULT Invoke | ( | A1 | arg1,
 |  | VARIANT * | pvtResult = NULL )

Invokes a function object with 1 argument.

Parameters
arg1 | The only function argument.
pvtResult | Optional pointer to value that revceives a value returned from function.
Returns
S_OK if successful or standard COM error code.

◆ Invoke() [6/6]

HRESULT Invoke ( VARIANT * pvtResult = NULL )

Invokes a function object with no arguments.

Parameters
pvtResult Optional pointer to value that revceives a value returned from function.
Returns
S_OK if successful or standard COM error code.

◆ InvokeWithArgs()

HRESULT InvokeWithArgs | ( | VARIANT * | lpArguments,
 |  | UINT | nCount,
 |  | VARIANT * | pvtResult = NULL )

Invokes a function object.

Parameters
lpArguments | Pointer to an array of function arguments.
nCount | Number of arguments pointed by lpArguments.
pvtResult | Optional pointer to value that revceives a value returned from function.
Returns
S_OK if successful or standard COM error code.

◆ Release()

ULONG Release ( )

Decrements context reference count.

Returns
Current number of references.

◆ SetValue()

HRESULT SetValue | ( | LPCWSTR | lpszName,
 |  | VARIANT | vtValue )

Sets named property value.

Parameters
lpszName | Object's property name.
vtValue | New property value.
Returns
S_OK if successful or standard COM error code.
The documentation for this class was generated from the following file:
  • XTPActiveScriptEngine.h


Toolkit Pro: CXTPActiveScriptStdRuntime Class Reference

Public Member Functions | List of all members
CXTPActiveScriptStdRuntime Class Reference

Implements standard scripting runtime library. More...

Inheritance diagram for CXTPActiveScriptStdRuntime:
[legend]

Public Member Functions

CXTPActiveScriptStdRuntime ()
Constructs scripting runtime library.
CXTPActiveScriptStdRuntime (IActiveScriptSite *pSite, BOOL bAddSiteRef=TRUE)
Constructs scripting runtime library.
~CXTPActiveScriptStdRuntime ()
Handles standard scripting runtime library deallocation.
void Shutdown ()
Releases all used resources.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

Implements standard scripting runtime library.

Constructor & Destructor Documentation

◆ CXTPActiveScriptStdRuntime()

CXTPActiveScriptStdRuntime | ( | IActiveScriptSite * | pSite,
 |  | BOOL | bAddSiteRef = TRUE )

Constructs scripting runtime library.

Parameters
pSite | Active script site pointer that is needed for named items access requested by 'getObject' handler.
bAddSiteRef | If TRUE then pSite reference counter will be incremented.
The documentation for this class was generated from the following file:
  • XTPActiveScriptEngine.h


Toolkit Pro: CXTPAlphaWnd Class Reference

Public Member Functions | List of all members
CXTPAlphaWnd Class Reference

CXTPTabClientAlphaWnd is CWnd derived class represents alpha context helper window. More...

Public Member Functions

CXTPAlphaWnd ()
Constructs a CXTPTabClientAlphaWnd object.
virtual ~CXTPAlphaWnd ()
Destroys a CXTPTabClientAlphaWnd object, handles cleanup and deallocation.

Detailed Description

CXTPTabClientAlphaWnd is CWnd derived class represents alpha context helper window.

The documentation for this class was generated from the following file:
  • XTPTabClientContext.h


Toolkit Pro: CXTPAnimationDC Class Reference

Public Types | Public Member Functions | Static Public Member Functions | Protected Attributes | List of all members
CXTPAnimationDC Class Reference

CXTPAnimationDC is a CXTPBufferDC derived class. More...

Public Types

typedef void(AFX_CDECL *) LPFNANIMATION(CRect rc, CDC *pDestDC, CDC *pSrcDC, int nType, int nSteps, int nAnimationTime)
Function pointer used to define a custom animation effect.

Public Member Functions

CXTPAnimationDC (HDC hDestDC, const CRect &rcPaint)
Constructs a CXTPBufferDC object used to create a memory device context used to draw an off-screen bitmap.
CXTPAnimationDC (HDC hDestDC, const CRect &rcPaint, const CXTPPaintManagerColorGradient &clrBack, const BOOL bHorz=FALSE)
Constructs a CXTPBufferDC object used to create a memory device context used to draw an off-screen bitmap.
virtual | ~CXTPAnimationDC ()
Destroys a CXTPAnimationDC object, handles cleanup and deallocation.
void | Animate (int nType=xtpAniDefault, int nSteps=10, int nAnimationTime=1000)
This member function performs the animation.

Static Public Member Functions

static void AFX_CDECL | DefaultAnimation (CRect rc, CDC *pDestDC, CDC *pSrcDC, int nType, int nSteps, int nAnimationTime)
This member implements default animation effects Fade, Slide and Unfold.
static void AFX_CDECL | SetCustomAnimation (LPFNANIMATION pCustom)
Call this member function to setup new Animation effects.

Protected Attributes

HDC | m_hDestDC
Handle to the destination device context.
CBitmap | m_bitmap
Bitmap in memory device context.
CRect | m_rect
Size of the area to paint.
HGDIOBJ | m_hOldBitmap
Handle to the previously selected bitmap.

Detailed Description

CXTPAnimationDC is a CXTPBufferDC derived class.

This class can be used to render animation effects for the current device context.

By calling Animate, the device context is drawn on the screen with a defined animation type. See XTPAnimationDCType for a list of available animation styles.

Animations are similar to the menu animation effect as seen in Microsoft(r) Windows(r) or Microsoft(r) Office products. Example: See Animate for an example that demonstrates the use of CXTPAnimationDC.

See also
LPFNANIMATION, XTPAnimationDCType, Animate, SetCustomAnimation

Member Typedef Documentation

◆ LPFNANIMATION

void(AFX_CDECL *) LPFNANIMATION(CRect rc, CDC *pDestDC, CDC *pSrcDC, int nType, int nSteps, int nAnimationTime)

Function pointer used to define a custom animation effect.

Parameters
rc | Area to display.
pDestDC | Destination device context.
pSrcDC | Source device context.
nType | Enumerated XTPAnimationDCType to determine animation effect.
nSteps | Number of steps to complete animation.
nAnimationTime | Amount of time in milliseconds between each step. Example: See CXTPAnimationDC::SetCustomAnimation for an example that demonstrates the use of LPFNANIMATION.
See also
CXTPAnimationDC::SetCustomAnimation, XTPAnimationDCType

Constructor & Destructor Documentation

◆ CXTPAnimationDC() [1/2]

CXTPAnimationDC | ( | HDC | hDestDC,
 |  | const CRect & | rcPaint )

Constructs a CXTPBufferDC object used to create a memory device context used to draw an off-screen bitmap.

Parameters
hDestDC | Handle to the destination device context the memory device is BitBlt to.
rcPaint | Size of the area to paint.

◆ CXTPAnimationDC() [2/2]

CXTPAnimationDC | ( | HDC | hDestDC,
 |  | const CRect & | rcPaint,
 |  | const CXTPPaintManagerColorGradient & | clrBack,
 |  | const BOOL | bHorz = FALSE )

Constructs a CXTPBufferDC object used to create a memory device context used to draw an off-screen bitmap.

Parameters
hDestDC | Handle to the destination device context the memory device is BitBlt to.
rcPaint | Size of the area to paint.
clrBack | Represents background color for fill; can be COLORREF or gradient values using CXTPPaintManagerColorGradient.
bHorz | Used when drawing a gradient background. TRUE to draw gradient from left-to-right, otherwise drawn top-to-bottom.

Member Function Documentation

◆ Animate()

void Animate | ( | int | nType = xtpAniDefault,
 |  | int | nSteps = 10,
 |  | int | nAnimationTime = 1000 )

This member function performs the animation.

Parameters
nType | [in] Type of animation to perform.
nSteps | [in] Number of steps to take during animation.
nAnimationTime | [in] Amount of time to rest, in milliseconds, between each step.

Call this member function from your WM_PAINT handler to render the animation background. Example: The following example demonstrates the use of Animate:

void CMainFrame::DoAnimationTest(CDC* pDC, XTPAnimationDCType anim)
{
   CRect r(100, 100, 300, 200);
   CXTPBufferDC background(pDC, r, (COLORREF)-1);
   background.FromDC();
   {
      CXTPAnimationDC memDC(pDC, r, NULL);

      r -= r.TopLeft();

      memDC.Rectangle(r);
      memDC.MoveTo(0, 0);
      memDC.LineTo(r.BottomRight());
      memDC.SelectStockObject(GRAY_BRUSH);
      memDC.FloodFill(r.left + 10, r.top + 10, RGB(0, 0, 0));
      memDC.Animate(anim, 10, 1000);
   }

   Sleep(2000);
}
See also
LPFNANIMATION, XTPAnimationDCType, SetCustomAnimation

◆ DefaultAnimation()

static void AFX_CDECL DefaultAnimation | ( | CRect | rc,
 |  | CDC * | pDestDC,
 |  | CDC * | pSrcDC,
 |  | int | nType,
 |  | int | nSteps,
 |  | int | nAnimationTime )
 static

This member implements default animation effects Fade, Slide and Unfold.

Parameters
rc | [in] Bounding rectangle.
pDestDC | [in] Pointer to the device context you must draw to.
pSrcDC | [in] Device context that contains the bitmap you must take.
nType | [in] Type of animation to perform. For custom animation, you must use numbers greater than xtpAniNone.
nSteps | [in] Number of steps to take during the animation.
nAnimationTime | [in] Amount of time to rest, in milliseconds, between each step.

You can add new animation effects to call the SetCustomAnimation member. Example: See SetCustomAnimation for an example that demonstrates the use of DefaultAnimation.

Returns
See also
LPFNANIMATION, XTPAnimationDCType, Animate, SetCustomAnimation

◆ SetCustomAnimation()

static void AFX_CDECL SetCustomAnimation ( LPFNANIMATION pCustom )
static

Call this member function to setup new Animation effects.

Parameters
pCustom [in] Function pointer that holds the address of a custom animation function.

You can call DefaultAnimation in your custom animation method to handle default animation effects. Example: The following example demonstrates the use of SetCustomAnimation:

int CMainFrame::OnCreate()
{
   // custom animation procedure.
   CXTPAnimationDC::SetCustomAnimation(CustomAnimation);
   ...
}
...
void CMainFrame::CustomAnimation(CRect rc, CDC* pDestDC,
   CDC* pSrcDC, int nType, int nSteps, int nAnimationTime)
{
   if (nType == xtpAniUnfold)
   {
      // do custom animation
   }
   else
   {
      CXTPAnimationDC::DefaultAnimation(rc, pDestDC,
      pSrcDC, nType, nSteps, nAnimationTime);
   }
}
Returns
See also
LPFNANIMATION, XTPAnimationDCType, Animate, DefaultAnimation
The documentation for this class was generated from the following file:
  • XTPAnimationDC.h


Toolkit Pro: CXTPApplication Class Reference

Public Member Functions | List of all members
CXTPApplication Class Reference

Defines a global XTP application object interface. More...

Inheritance diagram for CXTPApplication:
[legend]

Public Member Functions

BOOL | IsReady () const
Determines if the application object is ready to be used, i.e.
AFX_MODULE_STATE * | GetModuleState ()
Returns module state pointer obtained at the point where XTPInitialize or XTPGetApplication is first called.
void | SetAmbientProperty (XTPApplicationAmbientProperty nProperty, COleVariant vtValue)
Sets ambient property value.
const COleVariant & | GetAmbientProperty (XTPApplicationAmbientProperty nProperty) const
Gets ambient property value.
void | TriggerAmbientPropertyUpdate (XTPApplicationAmbientProperty nProperty)
Triggers ambient property update notification even if property value is not changed.
int | GetComInitFlags () const
Obtains COM initialization flags.
DWORD | GetAppThreadId () const
Obtains main application thread ID.
- Public Member Functions inherited from CXTPObservable< CXTPApplication, IXTPApplicationEvents >
void | Subscribe (IXTPApplicationEvents *pObserver, CXTPSubscriptionList< CXTPApplication, IXTPApplicationEvents > *pSubcriptionList=NULL)
Subscribes a unique observer for events.
void | Unsubscribe (IXTPApplicationEvents *pObserver)
Unsubscribes an observer from events.
void | Notify (void(IXTPApplicationEvents::*method)(CXTPApplication *))
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(IXTPApplicationEvents::*method)(CXTPApplication *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(IXTPApplicationEvents::*method)(CXTPApplication *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(IXTPApplicationEvents::*method)(CXTPApplication *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(IXTPApplicationEvents::*method)(CXTPApplication *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(IXTPApplicationEvents::*method)(CXTPApplication *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(IXTPApplicationEvents::*method)(CXTPApplication *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(IXTPApplicationEvents::*method)(CXTPApplication *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *))
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
- Public Member Functions inherited from CXTPSynchronized
CXTPRWCriticalSection & | GetAccessCriticalSection () const
Accesses a synchronized object's critical section.

Additional Inherited Members

- Protected Member Functions inherited from CXTPObservable< CXTPApplication, IXTPApplicationEvents >
CXTPObservable ()
Constructs an observable object.
~CXTPObservable ()
Handles observable object destruction.

Detailed Description

Defines a global XTP application object interface.

The object is kept alive until a call to XTPShutdown. At any moment there is one and only one XTP application instance per loaded dynamic or executable module which links XTP framework.

See also
XTPGetApplication, XTPInitialize, XTPShutdown, CXTPWinApp

Member Function Documentation

◆ GetAmbientProperty()

const COleVariant & GetAmbientProperty ( XTPApplicationAmbientProperty nProperty ) const

Gets ambient property value.

Parameters
nProperty Ambient property identifier.
Returns
A reference to a COleVariant object tha represents ambient property value.

Ambient properties are the global values specific to the current application. Unlike global variables, changing an ambient property notifies all subscribed clients about a property changed so that takes effect immediately accross entire application. Accessing ambient properties asynchronously should be guarded using XTPAccessShared or XTPAccessExclusive.

See also
XTPApplicationAmbientProperty, IXTPApplicationEvents

◆ GetAppThreadId()

DWORD GetAppThreadId ( ) const

Obtains main application thread ID.

Returns
Main application thread ID.

◆ GetComInitFlags()

int GetComInitFlags ( ) const

Obtains COM initialization flags.

Returns
COM initialization flags

◆ GetModuleState()

AFX_MODULE_STATE * GetModuleState ( )

Returns module state pointer obtained at the point where XTPInitialize or XTPGetApplication is first called.

Returns
Module state pointer.
See also
XTPInitialize, XTPGetApplication

◆ IsReady()

BOOL IsReady ( ) const

Determines if the application object is ready to be used, i.e.

it has been initialized and hasn't been shutdown.

Returns
TRUE is the application object is ready, FALSE otherwise.
See also
XTPInitialize, XTPGetApplication

◆ SetAmbientProperty()

void SetAmbientProperty | ( | XTPApplicationAmbientProperty | nProperty,
 |  | COleVariant | vtValue )

Sets ambient property value.

Parameters
nProperty | Ambient property identifier.
vtValue | Ambient property value determined by its identifier.

Ambient properties are the global values specific to the current application. Unlike global variables, changing an ambient property notifies all subscribed clients about a property changed so that takes effect immediately accross entire application. Accessing ambient properties asynchronously should be guarded using XTPAccessShared or XTPAccessExclusive.

See also
XTPApplicationAmbientProperty, IXTPApplicationEvents

◆ TriggerAmbientPropertyUpdate()

void TriggerAmbientPropertyUpdate ( XTPApplicationAmbientProperty nProperty )

Triggers ambient property update notification even if property value is not changed.

Parameters
nProperty Ambient property identifier.
See also
XTPInitialize, XTPGetApplication
The documentation for this class was generated from the following file:
  • XTPApplication.h


Toolkit Pro: CXTPArcBall Class Reference

Public Member Functions | List of all members
CXTPArcBall Class Reference

Implements natural object rotation computation using quaternions. More...

Public Member Functions

CXTPArcBall ()
Constructs an empy arc-ball object.
void | SetBounds (double dWidth, double dHeight)
Sets object bounds.
BOOL | HasBounds () const
Determines if object bounds have been set.
void | SetBegin (double x, double y)
Sets initial rotation point that is mapped from 2D space onto a 3D sphere determined by object bounds.
void | SetEnd (double x, double y)
Sets final rotation point that is mapped from 2D space onto a 3D sphere determined by object bounds.
void | GetRotationQuaternion (double &xQuat, double &yQuat, double &zQuat, double &wQuat)
Obtains rotation quaternion parameters based on the mapped rotation starting and ending points.

Detailed Description

Implements natural object rotation computation using quaternions.

An object is assumed to have bounds, and rotation begin and end points, for which a rotation quaternion can be computed and used for actual rotation of the view matrix.

See also
CXTPMatrix

Member Function Documentation

◆ GetRotationQuaternion()

void GetRotationQuaternion | ( | double & | xQuat,
 |  | double & | yQuat,
 |  | double & | zQuat,
 |  | double & | wQuat )

Obtains rotation quaternion parameters based on the mapped rotation starting and ending points.

Parameters
xQuat | X component of the rotation quaternion.
yQuat | Y component of the rotation quaternion.
zQuat | Z component of the rotation quaternion.
wQuat | W component of the rotation quaternion.

◆ HasBounds()

BOOL HasBounds ( ) const

Determines if object bounds have been set.

Returns
TRUE is object bounds have been set.
See also
SetBounds

◆ SetBegin()

void SetBegin | ( | double | x,
 |  | double | y )

Sets initial rotation point that is mapped from 2D space onto a 3D sphere determined by object bounds.

Parameters
x | X coordiante of the rotation starting point.
y | Y coordiante of the rotation starting point.
See also
SetEnd, SetBounds

◆ SetBounds()

void SetBounds | ( | double | dWidth,
 |  | double | dHeight )

Sets object bounds.

Parameters
dWidth | The width of object bounds.
dHeight | The height of object bounds.
See also
HasBounds

◆ SetEnd()

void SetEnd | ( | double | x,
 |  | double | y )

Sets final rotation point that is mapped from 2D space onto a 3D sphere determined by object bounds.

Parameters
x | X coordiante of the rotation final point.
y | Y coordiante of the rotation final point.
See also
SetBegin, SetBounds
The documentation for this class was generated from the following file:
  • XTPArcBall.h


Toolkit Pro: CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE > Class Template Reference

Public Member Functions | Protected Attributes | List of all members
CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE > Class Template Reference

This class represents a simple array of typed elements. More...

Inheritance diagram for CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE >:
[legend]

Public Member Functions

CXTPArrayT ()
Default object constructor.
virtual | ~CXTPArrayT ()
Default object destructor.
virtual int | GetSize () const
This member function is used to obtain the number of elements in the collection.
virtual void | SetSize (int nNewSize, int nGrowBy=-1)
This member function is used to change the array size.
virtual TYPE | GetAt (int nIndex) const
This member function returns an element at the specified numeric index.
virtual void | SetAt (int nIndex, ARG_TYPE newElement)
This member function is used to set a new element to the position specified in the nIndex parameter.
virtual TYPE & | ElementAt (int nIndex)
This member function returns a reference to element at the specified numeric index.
virtual const TYPE * | GetData () const
This member function is used to Direct Access to the element data.
virtual TYPE * | GetData ()
This member function is used to Direct Access to the element data.
virtual void | SetAtGrow (int nIndex, ARG_TYPE newElement)
This member function is used to set a new element to the position specified in the nIndex parameter.
virtual int | Add (ARG_TYPE newElement)
This member function adds a new element to the end of the array.
virtual int | Append (const CXTPArrayT &src)
This member function adds the elements from a specified array to the end of this array.
virtual void | Copy (const CXTPArrayT &src)
This member function overwrites the contents of this array with the contents of a specified array.
TYPE | operator[] (int nIndex) const
This operator returns the array element at a specified numeric index.
TYPE & | operator[] (int nIndex)
This operator returns a reference to the array element at a specified numeric index.
virtual void | InsertAt (int nIndex, ARG_TYPE newElement, int nCount=1)
This member function is used to insert a number of copies of an element, specified by the nCount parameter, to the array starting at the position specified by the nIndex parameter.
virtual void | RemoveAt (int nIndex, int nCount=1)
This member function is used to remove a number of array elements, specified by the nCount parameter, from the array starting at the position specified by the nIndex parameter.
virtual void | RemoveAll ()
This member function is used to remove all array elements from the array.
virtual void | InsertAt (int nStartIndex, CXTPArrayT *pNewArray)
This member function is used to insert an array of elements to the array starting at the position specified by the nStartIndex parameter.
virtual int | FindElement (ARG_TYPE nElement) const
Call this member function to find an element in the collection.
virtual void | AddIfNeed (ARG_TYPE newElement)
Call this member function to add a specified element to the collection if it is not present already.
virtual BOOL | RemoveElement (ARG_TYPE nElement)
Call this member function to remove all elements with a specified value from the collection.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Attributes

CArray< TYPE, ARG_TYPE > m_arElements
Elements storage.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

template<class TYPE, class ARG_TYPE, class OLE_TYPE = long>
class CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE >

This class represents a simple array of typed elements.

It repeats CArray methods names and parameters as far as CArray behavior.

This class derived from CXTPCmdTarget. This allow to use it as base class for collection which has features for ActiveX support.

See also
CArray, CXTPCmdTarget.

Member Function Documentation

◆ Add()

template<class TYPE , class ARG_TYPE , class OLE_TYPE = long>
virtual int Add ( ARG_TYPE newElement )
virtual

This member function adds a new element to the end of the array.

Parameters
newElement A new value for the specified index.
Returns
The index of the added element.

◆ AddIfNeed()

template<class TYPE , class ARG_TYPE , class OLE_TYPE = long>
virtual void AddIfNeed ( ARG_TYPE newElement )
virtual

Call this member function to add a specified element to the collection if it is not present already.

Parameters
newElement An element to add.

If the specified element is already present in the collection, then this function does nothing.

See also
CArray::Add

◆ Append()

template<class TYPE , class ARG_TYPE , class OLE_TYPE = long>
virtual int Append ( const CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE > & src )
virtual

This member function adds the elements from a specified array to the end of this array.

Parameters
src A reference to an array of TYPE objects to add to this array.
Returns
The index of the first appended element.
See also
GetAt, Add, InsertAt, SetAt

◆ Copy()

template<class TYPE , class ARG_TYPE , class OLE_TYPE = long>
virtual void Copy ( const CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE > & src )
virtual

This member function overwrites the contents of this array with the contents of a specified array.

Parameters
src A reference to an array of TYPE objects to overwrite this array.
See also
GetAt, Add, InsertAt, SetAt

◆ ElementAt()

template<class TYPE , class ARG_TYPE , class OLE_TYPE = long>
virtual TYPE & ElementAt ( int nIndex )
virtual

This member function returns a reference to element at the specified numeric index.

Parameters
nIndex An integer index that is greater than or equal to 0 and less than the value returned by GetSIze.
Returns
The array element reference at the specified index.

◆ FindElement()

template<class TYPE , class ARG_TYPE , class OLE_TYPE = long>
virtual int FindElement ( ARG_TYPE nElement ) const
virtual

Call this member function to find an element in the collection.

Parameters
nElement Element to find.
Returns
The zero-based index of the element in the collection, or a value of -1 if the element is not found.

◆ GetAt()

template<class TYPE , class ARG_TYPE , class OLE_TYPE = long>
virtual TYPE GetAt ( int nIndex ) const
virtual

This member function returns an element at the specified numeric index.

Parameters
nIndex An integer index that is greater than or equal to 0 and less than the value returned by GetSIze.

Returns the array element at the specified index.

Returns
The element currently at this index.

◆ GetData() [1/2]

template<class TYPE , class ARG_TYPE , class OLE_TYPE = long>
virtual TYPE * GetData ( )
virtual

This member function is used to Direct Access to the element data.

May return NULL.

Returns
The pointer to allocated array data or NULL.

◆ GetData() [2/2]

template<class TYPE , class ARG_TYPE , class OLE_TYPE = long>
virtual const TYPE * GetData ( ) const
virtual

This member function is used to Direct Access to the element data.

May return NULL.

Returns
The pointer to allocated array data or NULL.

◆ GetSize()

template<class TYPE , class ARG_TYPE , class OLE_TYPE = long>
virtual int GetSize ( ) const
virtual

This member function is used to obtain the number of elements in the collection.

Call this method to retrieve the number of elements in the array. Because indexes are zero-based, the size is 1 greater than the largest index.

Returns
The number of items in the collection.

◆ InsertAt() [1/2]

template<class TYPE , class ARG_TYPE , class OLE_TYPE = long>
virtual void InsertAt | ( | int | nIndex,
 |  | ARG_TYPE | newElement,
 |  | int | nCount = 1 )
 virtual

This member function is used to insert a number of copies of an element, specified by the nCount parameter, to the array starting at the position specified by the nIndex parameter.

Parameters
nIndex | An integer index that is greater than or equal to 0 and less than the value returned by GetCount().
newElement | A new value for the specified index.
nCount | The number of copies of the element to be inserted. By default, this parameter is 1.

◆ InsertAt() [2/2]

template<class TYPE , class ARG_TYPE , class OLE_TYPE = long>
virtual void InsertAt | ( | int | nStartIndex,
 |  | CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE > * | pNewArray )
 virtual

This member function is used to insert an array of elements to the array starting at the position specified by the nStartIndex parameter.

Parameters
nStartIndex | An integer index that is greater than or equal to 0 and less than the value returned by GetCount().
pNewArray | A pointer to the array which contains the elements to be inserted.

◆ operator[]() [1/2]

template<class TYPE , class ARG_TYPE , class OLE_TYPE = long>
TYPE & operator[] ( int nIndex )

This operator returns a reference to the array element at a specified numeric index.

Parameters
nIndex An integer index that is greater than or equal to 0 and less than the value returned by GetSize.
Returns
A reference to the array element at the specified index.

◆ operator[]() [2/2]

template<class TYPE , class ARG_TYPE , class OLE_TYPE = long>
TYPE operator[] ( int nIndex ) const

This operator returns the array element at a specified numeric index.

Parameters
nIndex An integer index that is greater than or equal to 0 and less than the value returned by GetSize.
Returns
The array element at the specified index.

◆ RemoveAll()

template<class TYPE , class ARG_TYPE , class OLE_TYPE = long>
virtual void RemoveAll ( )
virtual

This member function is used to remove all array elements from the array.

See also
RemoveAt

Reimplemented in CXTPGridHyperlinks, and CXTPGridRecordItemControls.

◆ RemoveAt()

template<class TYPE , class ARG_TYPE , class OLE_TYPE = long>
virtual void RemoveAt | ( | int | nIndex,
 |  | int | nCount = 1 )
 virtual

This member function is used to remove a number of array elements, specified by the nCount parameter, from the array starting at the position specified by the nIndex parameter.

Parameters
nIndex | An integer index that is greater than or equal to 0 and less than the value returned by GetCount().
nCount | The number of elements to be removed. By default, this parameter is 1.

Reimplemented in CXTPGridHyperlinks, and CXTPGridRecordItemControls.

◆ RemoveElement()

template<class TYPE , class ARG_TYPE , class OLE_TYPE = long>
virtual BOOL RemoveElement ( ARG_TYPE nElement )
virtual

Call this member function to remove all elements with a specified value from the collection.

Parameters
nElement The element with the specified value to be removed.
Returns
TRUE if the specified element is found and removed, otherwise FALSE.
See also
CArray::RemoveAt, CArray::RemoveAll

◆ SetAt()

template<class TYPE , class ARG_TYPE , class OLE_TYPE = long>
virtual void SetAt | ( | int | nIndex,
 |  | ARG_TYPE | newElement )
 virtual

This member function is used to set a new element to the position specified in the nIndex parameter.

Parameters
nIndex | An integer index that is greater than or equal to 0 and less than the value returned by GetCount.
newElement | A new value for the specified index.

Use this method to set the specified element to the position specified in nIndex parameter.

See also
GetAt, Add, InsertAt

◆ SetAtGrow()

template<class TYPE , class ARG_TYPE , class OLE_TYPE = long>
virtual void SetAtGrow | ( | int | nIndex,
 |  | ARG_TYPE | newElement )
 virtual

This member function is used to set a new element to the position specified in the nIndex parameter.

Potentially growing the array.

Parameters
nIndex | An integer index that is greater than or equal to 0 and less than the value returned by GetCount.
newElement | A new value for the specified index.

Use this method to set the specified element to the position specified in nIndex parameter.

See also
SetAt, Add, InsertAt

◆ SetSize()

template<class TYPE , class ARG_TYPE , class OLE_TYPE = long>
virtual void SetSize | ( | int | nNewSize,
 |  | int | nGrowBy = -1 )
 virtual

This member function is used to change the array size.

Parameters
nNewSize | An int that contains the new array size.
nGrowBy | An int that contains a number of elements to grow internal data storage if need.

Argument nNewSize contains the new array size (number of elements). Must be greater than or equal to 0.

The documentation for this class was generated from the following file:
  • XTPSmartPtrInternalT.h


Toolkit Pro: CXTPAsyncGuard< Adaptee, RWLock > Class Template Reference

Public Member Functions | List of all members
CXTPAsyncGuard< Adaptee, RWLock > Class Template Reference

A convenience class for guarding an adapted object reference by a RW-lock provided. More...

Public Member Functions

CXTPAsyncGuard (Adaptee &adaptee, CXTPRWCriticalSection &cs)
Constructs the guard object.
CXTPAsyncGuard (Adaptee &adaptee, CXTPRWCriticalSection &cs, long &nConditionCounter)
Constructs the guard object.
CXTPAsyncGuard (const CXTPAsyncGuard &rhs)
Copies the guard object.
~CXTPAsyncGuard ()
Handles guard destruction.
Adaptee * | operator-> ()
Accesses an adapted object's pointer.
const Adaptee * | operator-> () const
Accesses an adapted object's pointer.
Adaptee & | operator* ()
Accesses an adapted object's reference.
const Adaptee & | operator* () const
Accesses an adapted object's reference.
operator Adaptee * ()
Casts object to an adapted object's pointer.
operator const Adaptee * () const
Casts object to an adapted object's pointer.

Detailed Description

template<class Adaptee, class RWLock>
class CXTPAsyncGuard< Adaptee, RWLock >

A convenience class for guarding an adapted object reference by a RW-lock provided.

Parameters
Adaptee | Type of an adapted object reference.
RWLock | RW-lock type. Can be either CXTPRWCriticalSection::CSharedLock or CXTPRWCriticalSection::CExclusiveLock.

Constructor & Destructor Documentation

◆ CXTPAsyncGuard() [1/3]

template<class Adaptee , class RWLock >
CXTPAsyncGuard | ( | Adaptee & | adaptee,
 |  | CXTPRWCriticalSection & | cs )
 inline

Constructs the guard object.

Parameters
adaptee | A reference to an object to be guarded.
cs | Critical section reference for while a lock is to be obtained.

◆ CXTPAsyncGuard() [2/3]

template<class Adaptee , class RWLock >
CXTPAsyncGuard | ( | Adaptee & | adaptee,
 |  | CXTPRWCriticalSection & | cs,
 |  | long & | nConditionCounter )
 inline

Constructs the guard object.

Parameters
adaptee | A reference to an object to be guarded.
cs | Critical section reference for while a lock is to be obtained.
nConditionCounter | If zero, the guard will lock the critical section and increment the counter until the critical section is unlocked. Otherwise critical section does not get locked.

◆ CXTPAsyncGuard() [3/3]

template<class Adaptee , class RWLock >
CXTPAsyncGuard ( const CXTPAsyncGuard< Adaptee, RWLock > & rhs )
inline

Copies the guard object.

Parameters
rhs A reference to a source guard object.

◆ ~CXTPAsyncGuard()

template<class Adaptee , class RWLock >
~CXTPAsyncGuard ( )
inline

Handles guard destruction.

Unlocks owned critical section. If there was an option condition counter provided, unlocks critical section only if decrmented counter value is zero.

Member Function Documentation

◆ operator Adaptee *()

template<class Adaptee , class RWLock >
operator Adaptee * ( )
inline

Casts object to an adapted object's pointer.

Returns
An adapted object's pointer.

◆ operator const Adaptee *()

template<class Adaptee , class RWLock >
operator const Adaptee * ( ) const
inline

Casts object to an adapted object's pointer.

Returns
An adapted object's pointer.

◆ operator*() [1/2]

template<class Adaptee , class RWLock >
Adaptee & operator* ( )
inline

Accesses an adapted object's reference.

Returns
An adapted object's reference.

◆ operator*() [2/2]

template<class Adaptee , class RWLock >
const Adaptee & operator* ( ) const
inline

Accesses an adapted object's reference.

Returns
An adapted object's reference.

◆ operator->() [1/2]

template<class Adaptee , class RWLock >
Adaptee * operator-> ( )
inline

Accesses an adapted object's pointer.

Returns
An adapted object's pointer.

◆ operator->() [2/2]

template<class Adaptee , class RWLock >
const Adaptee * operator-> ( ) const
inline

Accesses an adapted object's pointer.

Returns
An adapted object's pointer.
The documentation for this class was generated from the following file:
  • XTPSynchro.h


Toolkit Pro: CXTPAutoResetValue< _TValue > Class Template Reference

Public Member Functions | List of all members
CXTPAutoResetValue< _TValue > Class Template Reference

Helper class template provides functionality to temporary set some to variable and reset to initial or other value on destroy. More...

Public Member Functions

CXTPAutoResetValue (_TValue &rData)
Object constructor.
CXTPAutoResetValue (_TValue &rData, const _TValue &valReset)
Object constructor.
virtual | ~CXTPAutoResetValue ()
Object destructor.
operator _TValue & ()
This member operator is used to access the managing variable.
const _TValue & | operator= (const _TValue &rSrc)
This member function overloads the assignment operator for the CXTPAutoResetValue class.

Detailed Description

template<class _TValue>
class CXTPAutoResetValue< _TValue >

Helper class template provides functionality to temporary set some to variable and reset to initial or other value on destroy.

Can be useful to lock some data or actions via flags and unlock automatically.

Constructor & Destructor Documentation

◆ CXTPAutoResetValue() [1/2]

template<class _TValue >
CXTPAutoResetValue ( _TValue & rData )
inline

Object constructor.

Parameters
rData A reference to the managing variable.

The original value of rData is stored in a separate member and it will be restored on destroy.

◆ CXTPAutoResetValue() [2/2]

template<class _TValue >
CXTPAutoResetValue | ( | _TValue & | rData,
 |  | const _TValue & | valReset )
 inline

Object constructor.

Parameters
rData | A reference to the managing variable.
valReset | A value to set when destroyed.

The original value of rData is ignored. The valReset value will be used on destroy.

◆ ~CXTPAutoResetValue()

template<class _TValue >
virtual ~CXTPAutoResetValue ( )
inlinevirtual

Object destructor.

The managing variable value will be restored to its original value or to a value specified as the second constructor parameter.

Member Function Documentation

◆ operator _TValue &()

template<class _TValue >
operator _TValue & ( )
inline

This member operator is used to access the managing variable.

Returns
Managing variable reference.

◆ operator=()

template<class _TValue >
const _TValue & operator= ( const _TValue & rSrc )
inline

This member function overloads the assignment operator for the CXTPAutoResetValue class.

Parameters
rSrc A new value.
Returns
A reference to this object.
The documentation for this class was generated from the following file:
  • XTPCalendarUtils.h


Toolkit Pro: CXTPAuxData Class Reference

Public Member Functions | Public Attributes | List of all members
CXTPAuxData Class Reference

CXTPAuxData is a standalone global item data structure class. More...

Public Member Functions

virtual | ~CXTPAuxData ()
Destroys an CXTPAuxData object, handles cleanup and deallocation.
BOOL | LoadSysCursors ()
Initializes the cursors used by the library.
BOOL | LoadSysFonts (LPCTSTR lpszHorzFaceName=NULL, LPCTSTR lpszVertFaceName=NULL)
Initializes the fonts used by the library.
void | FreeSysFonts ()
This member function frees font resources.
void | UpdateSysColors ()
This member function updates system colors used by the library.
void | UpdateSysMetrics ()
This member function updates system metrics used by the library.
DWORD | GetComCtlVersion ()
This member function is called to retrieve the version information for the common control .dll (comctl32.dll).
BOOL | IsComCtlValid () const
This member function is called to check the current version of the common control .dll (comctl32.dll).
void | InitResources (HINSTANCE hInst)
This member function is called by the library to initialize resources.
void | UseOfficeFont (BOOL bOfficeFont)
Enables/disables Tahoma font usage for the library.
BOOL | FontExists (LPCTSTR lpszFaceName)
Determines if a font is installed.
BOOL | CreateSysFont (const CXTPLogFont &lf, CFont &font, long lfWeight=-1, char lfUnderline=-1, long lfOrientation=-1, long lfEscapement=-1)
Initializes the fonts used by the library.
BOOL | CreateSysFont (const CXTPLogFont &lf, CXTPFont &font, long lfWeight=-1, char lfUnderline=-1, long lfOrientation=-1, long lfEscapement=-1)
Initializes the fonts used by the library.
BOOL | SetGlobalFont (CFont *pHorzFont, CFont *pVertFont=NULL)
Initializes the fonts used by the library.
BOOL | SetGlobalFont (LPCTSTR lpszFaceName, LPCTSTR lpszVertFaceName=NULL)
Initializes the fonts used by the library.
CString | XTPGetVersion (bool bVerNumOnly=false)
Retrieves the library version.

Public Attributes

COLORREF | clr3DFace
An RGB value that represents the face color for three dimensional display elements.
COLORREF | clr3DShadow
An RGB value that represents the shadow color for three dimensional display elements.
COLORREF | clr3DDkShadow
An RGB value that represents the dark shadow for three dimensional display elements.
COLORREF | clr3DHilight
An RGB value that represents the highlight color for three dimensional display elements.
COLORREF | clr3DLight
An RGB value that represents the light color for three dimensional display elements.
COLORREF | clrBtnText
An RGB value that represents the text color on push buttons.
COLORREF | clrGrayText
An RGB value that represents the grayed (disabled) text.
COLORREF | clrHighlight
An RGB value that represents the item(s) selected in a control.
COLORREF | clrHighlightText
An RGB value that represents the text color of item(s) selected in a control.
COLORREF | clrMenu
An RGB value that represents the menu background.
COLORREF | clrMenuText
An RGB value that represents the text color in menus.
COLORREF | clrWindow
An RGB value that represents the window background.
COLORREF | clrWindowFrame
An RGB value that represents the window frame.
COLORREF | clrWindowText
An RGB value that represents the text color in windows.
COLORREF | clrActiveCaption
An RGB value that represents the active window title bar.
COLORREF | clrInActiveCaption
An RGB value that represents the inactive window title bar.
COLORREF | clrGradActiveCapt
An RGB value that represents the gradient active title bar.
COLORREF | clrGradInActiveCapt
An RGB value that represents the gradient inactive title bar.
COLORREF | clrActiveCaptText
An RGB value that represents the active caption text.
COLORREF | clrInactiveCaptText
An RGB value that represents the inactive caption text.
COLORREF | clrXPBarFace
An RGB value that represents the XP toolbar background color.
COLORREF | clrXPHighlight
An RGB value that represents the XP menu item selected color.
COLORREF | clrXPHighlightBorder
An RGB value that represents the XP menu item selected border color.
COLORREF | clrXPHighlightPushed
An RGB value that represents the XP menu item pushed color.
COLORREF | clrXPIconShadow
An RGB value that represents the XP menu item icon shadow.
COLORREF | clrXPGrayText
An RGB value that represents the XP menu item disabled text color.
COLORREF | clrXPHighlightChecked
An RGB value that represents the XP menu item checked color.
COLORREF | clrXPHighlightCheckedBorder
An RGB value that represents the XP menu item checked border color.
COLORREF | clrXPGripper
An RGB value that represents the XP toolbar gripper color.
COLORREF | clrXPSeparator
An RGB value that represents the XP toolbar separator color.
COLORREF | clrXPDisabled
An RGB value that represents the XP menu icon disabled color.
COLORREF | clrXPMenuTextBack
An RGB value that represents the XP menu item text background color.
COLORREF | clrXPMenuExpanded
An RGB value that represents the XP hidden menu commands background color.
COLORREF | clrXPMenuBorder
An RGB value that represents the XP menu border color.
COLORREF | clrXPMenuText
An RGB value that represents the XP menu item text color.
COLORREF | clrXPHighlightText
An RGB value that represents the XP menu item selected text color.
COLORREF | clrXPBarText
An RGB value that represents the XP toolbar text color.
COLORREF | clrXPBarTextPushed
An RGB value that represents the XP toolbar pushed text color.
COLORREF | clrXPTabInactiveBack
An RGB value that represents the XP inactive tab background color.
COLORREF | clrXPTabInactiveText
An RGB value that represents the XP inactive tab text color.
HCURSOR | hcurDragCopy
Drag copy cursor handle.
HCURSOR | hcurDragMove
Drag move cursor handle.
HCURSOR | hcurDragNone
Drag none cursor handle.
HCURSOR | hcurHand
Hand cursor handle.
HCURSOR | hcurHSplitBar
Horizontal Splitter cursor handle.
HCURSOR | hcurVSplitBar
Vertical Splitter cursor handle.
HCURSOR | hcurMove
4 way move cursor handle.
int | cxSmIcon
cx small icon size (width).
int | cySmIcon
cy small icon size (height).
int | cxSize
Width, in pixels, of a button in a window's caption or title bar.
int | cySize
Height, in pixels, of a button in a window's caption or title bar.
int | cxHThumb
Width, in pixels, of the thumb box in a horizontal scrollbar.
int | cyVThumb
Height, in pixels, of the thumb box in a vertical scrollbar.
int | cyMenuItem
Height, in pixels, of single-line menu bar.
CXTPFont | xtpFont
Menu font.
CXTPFont | xtpFontBold
Menu bold font.
CXTPFont | xtpFontULine
Menu underlined font.
CXTPFont | xtpFontVert
Vertical menu font.
CXTPFont | xtpFontVertBold
Vertical menu bold font.
CXTPFont | xtpFontIconTitle
Icon title font.
CXTPFont | xtpFontIconTitleBold
Icon title bold font.
CXTPFont | xtpFontMarlettIcon
Marlett icon font.
CXTPFont | xtpFontStatus
Status bar font.
CXTPFont | xtpFontSmCaption
Small caption font.
BOOL | bWin95
TRUE if Windows 95.
BOOL | bWin98
TRUE if Windows 98.
BOOL | bWinNT
TRUE if Windows NT.
BOOL | bWin2K
TRUE if Windows 2000.
BOOL | bWinXP
TRUE if Windows XP.
BOOL | bUseOfficeFont
TRUE to use the Tahoma font if found, good for Office style applications by default.
BOOL | bUseSolidShadows
TRUE to use solid shadows for operating systems that do not supported layered windows.
BOOL | bMenuShadows
TRUE to use shadows under the menus.
int | iComCtlVersion
Common control .dll (comctl32.dll) version information.

Detailed Description

CXTPAuxData is a standalone global item data structure class.

It is used by the toolkit to initialize and store resource and item data shared by all objects. Items include system colors, icons, fonts, and OS flags.

Member Function Documentation

◆ CreateSysFont() [1/2]

BOOL CreateSysFont | ( | const CXTPLogFont & | lf,
 |  | CFont & | font,
 |  | long | lfWeight = -1,
 |  | char | lfUnderline = -1,
 |  | long | lfOrientation = -1,
 |  | long | lfEscapement = -1 )

Initializes the fonts used by the library.

Parameters
lf | [in] Reference to a CXTPLogFont or LOGFONT structure.
font | [in] Reference to a CFont object.
lfWeight | [in] Optional; specifies font weight.
lfUnderline | [in] Optional; specifies font underline.
lfOrientation | [in] Optional; specifies font orientation.
lfEscapement | [in] Optional; specifies font escapement.

Call this member function to create a CFont object from an existing CXTPLogFont or LOGFONT structure. You can specify additional values to set that will override what is specified in the LOGFONT structure passed in.

Returns
TRUE if the font was successfully created, otherwise FALSE.

◆ CreateSysFont() [2/2]

BOOL CreateSysFont | ( | const CXTPLogFont & | lf,
 |  | CXTPFont & | font,
 |  | long | lfWeight = -1,
 |  | char | lfUnderline = -1,
 |  | long | lfOrientation = -1,
 |  | long | lfEscapement = -1 )

Initializes the fonts used by the library.

Parameters
lf | [in] Reference to a CXTPLogFont or LOGFONT structure.
font | [in] Reference to a CFont object.
lfWeight | [in] Optional; specifies font weight.
lfUnderline | [in] Optional; specifies font underline.
lfOrientation | [in] Optional; specifies font orientation.
lfEscapement | [in] Optional; specifies font escapement.

Call this member function to create a CFont object from an existing CXTPLogFont or LOGFONT structure. You can specify additional values to set that will override what is specified in the LOGFONT structure passed in.

Returns
TRUE if the font was successfully created, otherwise FALSE.

◆ FontExists()

BOOL FontExists ( LPCTSTR lpszFaceName )

Determines if a font is installed.

Parameters
lpszFaceName [in] A NULL-terminated string that represents the font name to search for.

Call this member function to determine if the font specified by strFaceName has been installed on the operating system.

Returns
TRUE if the font is installed, otherwise FALSE.

◆ GetComCtlVersion()

DWORD GetComCtlVersion ( )

This member function is called to retrieve the version information for the common control .dll (comctl32.dll).

Returns
A DWORD value.

◆ InitResources()

void InitResources ( HINSTANCE hInst )

This member function is called by the library to initialize resources.

Parameters
hInst Instance handle for resources.

◆ IsComCtlValid()

BOOL IsComCtlValid ( ) const

This member function is called to check the current version of the common control .dll (comctl32.dll).

Returns
TRUE if the version is 4.72 or higher, otherwise FALSE.

◆ LoadSysCursors()

BOOL LoadSysCursors ( )

Initializes the cursors used by the library.

Returns
TRUE if successful, otherwise FALSE.

◆ LoadSysFonts()

BOOL LoadSysFonts | ( | LPCTSTR | lpszHorzFaceName = NULL,
 |  | LPCTSTR | lpszVertFaceName = NULL )

Initializes the fonts used by the library.

Parameters
lpszHorzFaceName | [in] Pointer to a NULL-terminated font name that is used to create the horizontal fonts used by the library.
lpszVertFaceName | [in] Pointer to a NULL-terminated font name that is used to create the vertical fonts used by the library.

Call this member function to update all of the fonts used by the library.

Returns
TRUE if successful, otherwise FALSE if a font fails to load.

◆ SetGlobalFont() [1/2]

BOOL SetGlobalFont | ( | CFont * | pHorzFont,
 |  | CFont * | pVertFont = NULL )

Initializes the fonts used by the library.

Parameters
pHorzFont | [in] A pointer to a valid CFont object that is used to define the fonts that the library will use.
pVertFont | [in] A pointer to a valid CFont object that is used to define the vertical fonts used by the library. If NULL, then 'pFont' will be used.

Call this member function to update the fonts used by the library. This function will not update the fonts used for Icon Title, Marlett Icon or Small Captions. To change these fonts as well, use the CreateSysFont method.

Returns
TRUE if successful, otherwise returns FALSE if a font fails to load.

◆ SetGlobalFont() [2/2]

BOOL SetGlobalFont | ( | LPCTSTR | lpszFaceName,
 |  | LPCTSTR | lpszVertFaceName = NULL )

Initializes the fonts used by the library.

Parameters
lpszFaceName | [in] A pointer to a NULL-terminated font name that is used to create the horizontal fonts used by the library.
lpszVertFaceName | [in] A pointer to a NULL-terminated font name that is used to create the vertical fonts used by the library.

Call this member function to update the fonts used by the library. This function will not update the fonts used for Icon Title, Marlett Icon or Small Captions. To change these fonts as well, use the CreateSysFont method.

Returns
TRUE if successful, otherwise returns FALSE if a font fails to load.

◆ UseOfficeFont()

void UseOfficeFont ( BOOL bOfficeFont )

Enables/disables Tahoma font usage for the library.

Parameters
bOfficeFont [in] True to use the "Tahoma" font if found on the operating system.

Call this member function to use the Office font (Tahoma) if it exists on the operating system.

◆ XTPGetVersion()

CString XTPGetVersion ( bool bVerNumOnly = false )

Retrieves the library version.

Parameters
bVerNumOnly [in] true to return the version number only (excluding "Xtreme Toolkit v").

Call this member function to retrieve a CString object that represents the current version of the Xtreme Toolkit. The string returned is formatted like so: "Xtreme Toolkit v1.94".

Returns
A NULL-terminated string that indicates the version of the Xtreme Toolkit.
The documentation for this class was generated from the following file:
  • XTPGlobal.h


Toolkit Pro: CXTPBatchAllocObjT< _TObject, _TBatchAllocData, _TAllocator > Class Template Reference

Public Member Functions | Static Public Member Functions | List of all members
CXTPBatchAllocObjT< _TObject, _TBatchAllocData, _TAllocator > Class Template Reference

This template class used as a helper class to override new/delete operators and use batch allocation inside them. More...

Public Member Functions

void *PASCAL | operator new (size_t nSize)
Allocate memory block of nSize bytes.
void PASCAL | operator delete (void *p)
Free memory block previously allocated by operator new.

Static Public Member Functions

static void AFX_CDECL FreeExtraData ()
This member function check all blocks and deallocate which are completely free.

Detailed Description

template<class _TObject, class _TBatchAllocData, class _TAllocator = _TObject::TAllocator>
class CXTPBatchAllocObjT< _TObject, _TBatchAllocData, _TAllocator >

This template class used as a helper class to override new/delete operators and use batch allocation inside them.

Batch allocation means that memory allocated not for one object only, but for many objects at one time (for 1024 objects by default). Next allocations take memory from this big block. New blocks allocated when necessary. This increase performance and reduce heap fragmentation. Batch allocation mechanism responsible for allocation/deallocation blocks of memory from heap and internally organize free/busy lists of memory pieces. When object deleted, its memory stored in free list and used for new objects. When all memory pieces from block free, it may be deallocated from heap automatically (this depends on options in _TBatchAllocData) or by FreeExtraData call,

Parameters
_TObject | A base class;
_TAllocator | An allocator class name; by default _TObject::TAllocator is used.
_TBatchAllocData | This class must contain following static members for allocator:

struct BatchAllocData { static BOOL m_bEnableBatchAllocation; // Define is Batch Allocation enabled; static LONG m_dwAllocatedObjects; // allocated blocks count;

Parameters
static | BOOL m_bDestroyEmptyBlocksOnFree; // if TRUE completely free blocks will be deallocated on free objects, otherwise they will stay in free list. static BOOL m_bDestroyLastEmptyBlockOnFree; // if
TRUE | last completely free block will be deallocated on free objects, otherwise it will stay in free list.

static int m_nBlockSize; // Count of objects in block. protected: static XTP_BATCHALLOC_BLOCK_HEADER* m_pFreeBlocks; // List of blocks which have free pieces. static XTP_BATCHALLOC_BLOCK_HEADER* m_pBusyBlocks; // List of blocks which have not free pieces. };

Example:

// Batch data must be declared (and implemented)
// probably in header (*.h) file:
XTP_DECLARE_BATCH_ALLOC_OBJ_DATA(CBatchGridRecord_Data);
class CBatchGridRecord : public CXTPBatchAllocObjT<CXTPGridRecord, CBatchGridRecord_Data>
{
   // ...
};

// in implementation (*.cpp) file:
XTP_IMPLEMENT_BATCH_ALLOC_OBJ_DATA(CBatchGridRecord_Data, CBatchGridRecord, TRUE);

// To enable Batch allocations use second parameter in
// XTP_IMPLEMENT_BATCH_ALLOC_OBJ_DATA macro or set corresponding flag
// on initialization, before any allocations:
//
CMyCustomHeapAllocator::ms_bUseCustomHeap = TRUE;

// How to use:
CBatchGridRecord* pMyClassObj = new CBatchGridRecord();
See also
XTP_DECLARE_BATCH_ALLOC_OBJ_DATA, XTP_IMPLEMENT_BATCH_ALLOC_OBJ_DATA,

Member Function Documentation

◆ FreeExtraData()

template<class _TObject , class _TBatchAllocData , class _TAllocator = _TObject::TAllocator>
static void AFX_CDECL FreeExtraData ( )
inlinestatic

This member function check all blocks and deallocate which are completely free.

Returns
See also
_TBatchAllocData

◆ operator delete()

template<class _TObject , class _TBatchAllocData , class _TAllocator = _TObject::TAllocator>
void PASCAL operator delete ( void * p )
inline

Free memory block previously allocated by operator new.

Parameters
p [in] Pointer to a memory block.
Returns
See also
operator new

◆ operator new()

template<class _TObject , class _TBatchAllocData , class _TAllocator = _TObject::TAllocator>
void *PASCAL operator new ( size_t nSize )
inline

Allocate memory block of nSize bytes.

Parameters
nSize Requested block size.
Returns
A pointer to allocated block or NULL.
See also
operator delete
The documentation for this class was generated from the following file:
  • XTPCustomHeap.h


Toolkit Pro: CXTPBrowseButton Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPBrowseButton Class Reference

CXTPBrowseButton is a CXTPButton derived class. More...

Inheritance diagram for CXTPBrowseButton:
[legend]

Public Member Functions

CXTPBrowseButton ()
Constructs a CXTPBrowseButton object.
virtual | ~CXTPBrowseButton ()
Destroys a CXTPBrowseButton object, handles cleanup and deallocation.
virtual BOOL | Create (CXTPBrowseEdit *pEditWnd, DWORD dwBStyle, UINT nID, UINT nMenu=(UINT) -1, UINT nSubMenuIndx=(UINT) -1)
This member function is called to create the browse button used by the edit control.
void | SetBrowseStyle (DWORD dwxStyle)
This member function will set the browse style for the button.
- Public Member Functions inherited from CXTPButton
CXTPButton ()
Constructs a CXTPButton object.
virtual | ~CXTPButton ()
Destroys a CXTPButton object, handles cleanup and deallocation.
BYTE | GetButtonStyle () const
Retrieves the button styles for this object.
virtual BOOL | IsPushed ()
Call this member function to determine if the the button is currently being pushed.
virtual BOOL | IsHighlighted ()
Call this member function to determine if the the button is currently being highlighted (mouse over).
virtual BOOL | GetChecked ()
Call this member function to determine if the checked state has been defined for the button control.
void | SetChecked (BOOL bChecked)
Sets the highlight state for the button control.
BOOL | GetFlatStyle () const
Gets the flat style appearance of the button control.
void | SetFlatStyle (BOOL bFlatStyle=TRUE)
Sets the flat style appearance of the button control.
BOOL | GetUseVisualStyle () const
Determines if the control is drawn using visual styles/SkinFramework, if supported.
void | SetUseVisualStyle (BOOL bUseVisualStyle=TRUE)
Enables Windows XP visual styles for the control.
long | GetBorderGap () const
Call this member function to retrieve the gap between the button's image and border.
void | SetBorderGap (int nBorderGap)
Call this member function to set the gap between the button's image and border.
XTPPushButtonStyle | GetPushButtonStyle () const
This function retrieves a flag from the XTPPushButtonStyle enumeration that specifies the current style of the button.
void | SetPushButtonStyle (XTPPushButtonStyle nPushButtonStyle)
This member function will set the display style for the button.
virtual int | GetTextAlignment () const
Gets the alignment of the text on the button control.
void | SetTextAlignment (DWORD dwAlignment)
Sets the alignment of the text on the button control.
virtual int | GetImageAlignment () const
Gets the alignment of the image on the button control.
void | SetImageAlignment (DWORD dwAlignment)
Sets the alignment of the image on the button control.
XTPButtonTextImageRelation | GetTextImageRelation () const
Gets the text and image relation in the button.
void | SetTextImageRelation (XTPButtonTextImageRelation relation)
Sets the text and image relation in the button.
long | GetImageGap () const
Call this member function to retrieve the gap between the button's text and image.
void | SetImageGap (int nImageGap)
Call this member function to set the gap between the button's text and image.
virtual CSize | GetImageSize ()
Call this member function to return the size of the image displayed for the button control.
virtual BOOL | IsDpiImageScalingEnabled () const
Call this member to check if DPI scaling of images is enabled.
virtual void | SetDpiImageScaling (BOOL bEnable)
Call this member to enable/disable DPI scaling of images.
CXTPImageManagerIcon * | GetIcon () const
Call this member function to return a pointer to the image manager for the button control.
virtual void | DrawImage (CDC *pDC, CRect rc)
This method is called to draw the image of the control.
XTPGroupBoxBorderStyle | GetBorderStyle () const
Gets the border style of the control.
void | SetBorderStyle (XTPGroupBoxBorderStyle style)
Sets the border style of the control.
BOOL | GetShowFocus () const
Gets whether a focus rectangle is drawn around the contents of a button when the button has focus.
void | SetShowFocus (BOOL bShowFocus)
Sets whether a focus rectangle is drawn around the contents of a button when the button has focus.
virtual BOOL | SetTheme (XTPControlTheme eTheme)
Call this member to switch the visual theme of the control.
virtual void | SetTheme (CXTPButtonTheme *pPaintManager)
Call this member to switch the visual theme of the control.
CXTPButtonTheme * GetTheme ()
Call this member function to get a pointer to the currently selected theme.
void | RedrawButton (BOOL bUpdateWindow=FALSE)
Redraws the button.
BOOL | IsDropDownStyle () const
This member function is called to determine if the buttons have a drop down arrow and if it is drop down style.
virtual CRect | GetButtonRect ()
This member function is called to determine the size and location of the button.
void | SetBuddy (CWnd *pWndBuddy, BOOL bMoveButton=TRUE)
Sets the control used as the buddy control.
void | SetTooltip (LPCTSTR lpszTooltip)
Associates tooltip text with the button.
CString | GetTooltip () const
Call this member to retrieve the button's tooltip.
CXTPToolTipContext * | GetToolTipContext () const
Call this method to get a pointer to the tooltip context.
virtual BOOL | SetIcon (CSize size, HICON hIcon, HICON hIconHot=NULL, BOOL bRedraw=TRUE)
This member function will set the normal and hot state icons for the push button.
virtual BOOL | SetIcon (CSize size, UINT nID, UINT nHotID=0, BOOL bRedraw=TRUE)
This member function will set the normal and hot state icons for the push button.
virtual BOOL | SetIcon (CSize size, LPCTSTR lpszID, LPCTSTR lpszHotID=NULL, BOOL bRedraw=TRUE)
This member function will set the normal and hot state icons for the push button.
BOOL | SetIcon (CSize size, CXTPImageManagerIcon *pIcon, BOOL bRedraw=TRUE)
This member function will set the normal and hot state icons for the push button.
virtual BOOL | SetIcon (CSize size, const CXTPImageManagerIconHandle &hIconHandle, const CXTPImageManagerIconHandle &hIconHotHandle, BOOL bRedraw=TRUE)
This member function will set the normal and hot state icons for the push button.
virtual BOOL | SetBitmap (CSize size, UINT nID, BOOL bRedraw=TRUE)
This member function will set the bitmap associated with the button.
virtual CString | GetButtonText ()
Call this member function to return the button's text minus the '&'.
CSize | GetGlyphSize (BOOL bCheckBox)
Retrieves the size of the check box glyph.
BOOL | IsPushButton () const
Determines if the button is a push button or a drop down button.
void | EnableMarkup (BOOL bEnableMarkup=TRUE)
Allows the use of a XAML snippet to be used for the text of panes in the control.
virtual COLORREF | GetButtonTextColor ()
Gets the button's text color.
virtual COLORREF | GetButtonBackColor ()
Gets the button's back color.
virtual void | InternalTextChanged ()
This member function is called when the text has changed.
CXTPMarkupContext * | GetMarkupContext () const
Retrieves a pointer to the markup context.
CXTPMarkupUIElement * GetMarkupUIElement ()
Call this method to get the markup element that renders the caption of the control.

Protected Attributes

DWORD | m_dwBStyle
Search type.
UINT | m_nID
Resource ID for push button.
UINT | m_nMenu
Pop-up menu ID.
UINT | m_nSubMenuIndx
Index of pop-up sub-menu.
CXTPBrowseEdit * | m_pEditWnd
Parent edit control.
- Protected Attributes inherited from CXTPButton
CXTPMarkupContext * | m_pMarkupContext
Markup context.
CXTPMarkupUIElement * | m_pUIElement
Markup element pointer.
BOOL | m_bImageDPIScaling
TRUE if DPI scaling of images enabled.

Additional Inherited Members

- Public Attributes inherited from CXTPButton
BOOL | m_bPushed
TRUE if button was pressed.
BOOL | m_bHot
TRUE if mouse under button.
CXTPButtonTheme * | m_pTheme
Pointer to the current theme object.
BOOL | m_bChecked
TRUE if checked.
BOOL | m_bFlatStyle
TRUE to see the flat style.
BOOL | m_bUseVisualStyle
TRUE to use visual styles.
long | m_nImageAlignment
Image Alignment.
long | m_nBorderGap
Gap between the button edge and the image.
long | m_nPushButtonStyle
The style of the button.
BOOL | m_bEnableMarkup
TRUE to enable markup.
long | m_nImageGap
Gap between the button text and the image.
long | m_nTextImageRelation
Image and text orientation.
CXTPImageManagerIcon * | m_pIcon
Multiple state icon manager converts icon to different states.
CSize | m_szVectorIcon
Size of displayed image if vector icon is used.
long | m_nBorderStyle
Border style used.
BOOL | m_bShowFocus
TRUE to show the focus rectangle.
HWND | m_hWndBuddy
Handle to the buddy control.
CXTPToolTipContext * | m_pToolTipContext
TooltipContext.
CString | m_strTooltip
Tooltip of the item.
- Protected Member Functions inherited from CXTPButton
virtual void | OnDropDown ()
Occurs when the drop down button is dropped down.
virtual void | OnDraw (CDC *pDC)
This member function performs all of the drawing logic of the calendar control window.
void | DoDropDown ()
Manually drops down a drop down button.
virtual void | RefreshMetrics ()
Call this member function to refresh theme colors and redraw the control.

Detailed Description

CXTPBrowseButton is a CXTPButton derived class.

It is used by CXTPBrowseEdit to create the browse button used for displaying file dialogs and pop-up menus.

Member Function Documentation

◆ Create()

virtual BOOL Create | ( | CXTPBrowseEdit * | pEditWnd,
 |  | DWORD | dwBStyle,
 |  | UINT | nID,
 |  | UINT | nMenu = (UINT) -1,
 |  | UINT | nSubMenuIndx = (UINT) -1 )
 virtual

This member function is called to create the browse button used by the edit control.

Parameters
pEditWnd | [in] Parent edit control.
dwBStyle | [in] Search type.
nID | [in] Resource ID for push button.
nMenu | [in] Pop-up menu ID.
nSubMenuIndx | [in] Index of pop-up submenu.
Returns
TRUE if successful, otherwise FALSE.

◆ SetBrowseStyle()

void SetBrowseStyle ( DWORD dwxStyle )

This member function will set the browse style for the button.

Parameters
dwxStyle Specifies the browse style. The button style can be defined as one or more of the styles listed in the Remarks section.

The CXTPBrowseButton can be set to use one or more of the following styles: BES_XTP_CHOOSEDIR: Display the choose folder dialog. BES_XTP_CHOOSEFILE: Display the choose file dialog. BES_XTP_POPUPMENU: Display a user-defined context menu.

See also
SetXButtonStyle
The documentation for this class was generated from the following file:
  • XTPBrowseEdit.h


Toolkit Pro: CXTPBrowseDialog Class Reference

Public Member Functions | Static Public Member Functions | Protected Attributes | List of all members
CXTPBrowseDialog Class Reference

CXTPBrowseDialog is derived from the BROWSEINFO structure. More...

Public Member Functions

CXTPBrowseDialog (CWnd *pParent=NULL)
Constructs a CXTPBrowseDialog object.
virtual | ~CXTPBrowseDialog ()
Destroys a CXTPBrowseDialog object, handles cleanup and deallocation.
INT_PTR | DoModal ()
Call this member function to invoke the browse dialog box and to return the dialog box result when done.
void | SetOwner (HWND hWnd)
Call this member function to set the owner window for the dialog box.
HWND | GetOwner ()
Call this member function to get an HWND handle to the owner window for the dialog box.
void | SetPidlRoot (LPCITEMIDLIST pidl)
Call this member function to set the address of an ITEMIDLIST structure which specifies the location of the root folder to browse from.
LPCITEMIDLIST | GetPidlRoot ()
Call this member function to return the address of the ITEMIDLIST structure that was specified for the location of the root folder.
void | SetDisplayName (LPCTSTR szDisplayName)
Call this member function to set the address for the display name that the dialog box will use.
LPCTSTR | GetDisplayName ()
Call this member function to return the display name that is used by the browse dialog box.
void | SetTitle (LPCTSTR szTitle)
Call this member function to set the title for the browse dialog box.
LPCTSTR | GetTitle ()
Call this member function to return a NULL-terminated string that represents the title that was set for the dialog box.
void | SetOptions (UINT uf)
Call this member function to set the flags for specifying the options for the browse dialog box.
UINT | GetOptions ()
Call this member function to return the flags specifying the options that have been set for the dialog box.
void | SetCallback (BFFCALLBACK pf)
Call this member function to define the address for the BrowseCallbackProc function that is to be called when an event occurs.
BFFCALLBACK | GetCallback ()
Call this member function to return the address for the BrowseCallbackProc function that is called when an event occurs.
void | SetData (LPARAM lp)
Call this member function to set the application data that is passed to the callback function.
LPARAM | GetData ()
Retrieves application data that was set to be passed to the callback function.
void | SetSelPath (LPCTSTR szSelPath)
Call this member function to set the initial path to select when the browse dialog is first opened.
LPCTSTR | GetSelPath ()
Call this member function to get a NULL-terminated string that represents the currently selected directory.
int | GetImage ()
Call this member function to get the index to the system image list of the image associated with the selected folder.

Static Public Member Functions

static int CALLBACK BrowseCtrlCallback (HWND hwnd, UINT uMsg, LPARAM lParam, LPARAM lpData)
Application defined callback.

Protected Attributes

TCHAR m_szSelPath [MAX_PATH]
NULL-terminated string that represents the selected directory.

Detailed Description

CXTPBrowseDialog is derived from the BROWSEINFO structure.

It is used to display a directory chooser dialog using shell extensions.

The CXTPBrowseDialog class allows you to configure various options, including setting the dialog's title or assigning a callback function for defining the folder display and file filtering styles.

Constructor & Destructor Documentation

◆ CXTPBrowseDialog()

CXTPBrowseDialog ( CWnd * pParent = NULL )

Constructs a CXTPBrowseDialog object.

Parameters
pParent [in] Pointer to a CWnd object that represents the parent window for the browse dialog.

Member Function Documentation

◆ BrowseCtrlCallback()

static int CALLBACK BrowseCtrlCallback | ( | HWND | hwnd,
 |  | UINT | uMsg,
 |  | LPARAM | lParam,
 |  | LPARAM | lpData )
 static

Application defined callback.

Parameters
hwnd | A handle to a window.
uMsg | The message that is sent to the window.
lParam | Specifies the application-defined data passed by the BrowseCtrlCallback function.
lpData | Data that is passed into the function.

Application defined callback function used with the SHBrowseForFolder function. The browse dialog box calls this function to notify it about events. You can define your own callback function by using the SetCallback method.

Returns
An integer value.

◆ DoModal()

INT_PTR DoModal ( )

Call this member function to invoke the browse dialog box and to return the dialog box result when done.

Returns
IDOK if the OK button was pressed, otherwise IDCANCEL.

◆ GetCallback()

BFFCALLBACK GetCallback ( )

Call this member function to return the address for the BrowseCallbackProc function that is called when an event occurs.

Returns
The address for the BrowseCallbackProc function that is called when an event occurs.

◆ GetData()

LPARAM GetData ( )

Retrieves application data that was set to be passed to the callback function.

Returns
The application data that was set to be passed to the callback function, if one is specified.

◆ GetDisplayName()

LPCTSTR GetDisplayName ( )

Call this member function to return the display name that is used by the browse dialog box.

Returns
The display name that is used by the browse dialog box.

◆ GetImage()

int GetImage ( )

Call this member function to get the index to the system image list of the image associated with the selected folder.

Returns
The index to the system image list.

◆ GetOptions()

UINT GetOptions ( )

Call this member function to return the flags specifying the options that have been set for the dialog box.

Returns
The flags specifying the options that have been set for the dialog box.

◆ GetOwner()

HWND GetOwner ( )

Call this member function to get an HWND handle to the owner window for the dialog box.

Returns
An HWND handle.

◆ GetPidlRoot()

LPCITEMIDLIST GetPidlRoot ( )

Call this member function to return the address of the ITEMIDLIST structure that was specified for the location of the root folder.

Returns
The address of the ITEMIDLIST structure that was specified for the location of the root folder.

◆ GetSelPath()

LPCTSTR GetSelPath ( )

Call this member function to get a NULL-terminated string that represents the currently selected directory.

Returns
A NULL-terminated string that represents the selected directory.

◆ GetTitle()

LPCTSTR GetTitle ( )

Call this member function to return a NULL-terminated string that represents the title that was set for the dialog box.

Returns
A NULL-terminated string that represents the title that was set for the dialog box.

◆ SetCallback()

void SetCallback ( BFFCALLBACK pf )

Call this member function to define the address for the BrowseCallbackProc function that is to be called when an event occurs.

Parameters
pf [in] Address of an application-defined function that the dialog box calls when an event occurs. For more information, see the BrowseCallbackProc function. This member can be NULL.

◆ SetData()

void SetData ( LPARAM lp )

Call this member function to set the application data that is passed to the callback function.

Parameters
lp [in] Application-defined value that the dialog box passes to the callback function, if one is specified.

◆ SetDisplayName()

void SetDisplayName ( LPCTSTR szDisplayName )

Call this member function to set the address for the display name that the dialog box will use.

Parameters
szDisplayName [in] Address of a buffer to receive the display name of the folder selected by the user. The size of this buffer is assumed to be MAX_PATH bytes.

◆ SetOptions()

void SetOptions ( UINT uf )

Call this member function to set the flags for specifying the options for the browse dialog box.

Parameters
uf [in] Flags specifying the options for the dialog box. See the Remarks section below for a list of available styles.

Styles to be added or removed can be combined by using the bitwise OR (|) operator. It can be one or more of the following: BIF_BROWSEFORCOMPUTER: Only return computers. If the user selects anything other than a computer, then the OK button is grayed. BIF_BROWSEFORPRINTER: Only allow the selection of printers. If the user selects anything other than a printer, then the OK button is grayed. In Microsoft Windows XP, the best practice is to use an XP-style dialog, setting the root of the dialog to the Printers and Faxes folder (CSIDL_PRINTERS). BIF_BROWSEINCLUDEFILES: Version 4.71. The browse dialog box will display files as well as folders. BIF_BROWSEINCLUDEURLS: Version 5.0. The browse dialog box can display URLs. The BIF_USENEWUI and BIF_BROWSEINCLUDEFILES flags must also be set. If these three flags are not set, then the browser dialog box will reject URLs. Even when these flags are set, the browse dialog box will only display URLs if the folder that contains the selected item supports them. When the folder's IShellFolder::GetAttributesOf method is called to request the selected item's attributes, the folder must set the SFGAO_FOLDER attribute flag. Otherwise, the browse dialog box will not display the URL. BIF_DONTGOBELOWDOMAIN: Do not include network folders below the domain level in the dialog box's tree view control. BIF_EDITBOX: Version 4.71. Include an edit control in the browse dialog box that allows the user to type the name of an item. BIF_NEWDIALOGSTYLE: Version 5.0. Use the new user interface. Setting this flag provides the user with a larger dialog box that can be resized. The dialog box has several new capabilities including: drag-and-drop capability within the dialog box, reordering, shortcut menus, new folders, delete, and other shortcut menu commands. To use this flag, you must call OleInitialize or CoInitialize before calling SHBrowseForFolder. BIF_NONEWFOLDERBUTTON: Version 6.0. Do not include the New Folder button in the browse dialog box. BIF_NOTRANSLATETARGETS: Version 6.0. When the selected item is a shortcut, return the PIDL of the shortcut itself rather than its target. BIF_RETURNFSANCESTORS: Only return file system ancestors. An ancestor is a subfolder that is beneath the root folder in the namespace hierarchy. If the user selects an ancestor of the root folder that is not a part of the file system, then the OK button is grayed. BIF_RETURNONLYFSDIRS: Only return file system directories. If the user selects folders that are not a part of the file system, then the OK button is grayed. BIF_SHAREABLE: Version 5.0. The browse dialog box can display shareable resources on remote systems. It is intended for applications that want to expose remote shares on a local system. The BIF_NEWDIALOGSTYLE flag must also be set. BIF_STATUSTEXT: Include a status area in the dialog box. The callback function can set the status text by sending messages to the dialog box. This flag is not supported when BIF_NEWDIALOGSTYLE is specified. BIF_UAHINT: Version 6.0. When combined with BIF_NEWDIALOGSTYLE, adds a usage hint to the dialog box in place of the edit box. BIF_EDITBOX overrides this flag. BIF_USENEWUI: Version 5.0. Use the new user interface, including an edit box. This flag is equivalent to BIF_EDITBOX | BIF_NEWDIALOGSTYLE. To use BIF_USENEWUI, you must call OleInitialize or CoInitialize before calling SHBrowseForFolder. BIF_VALIDATE: Version 4.71. If the user types an invalid name into the edit box, then the browse dialog box will call the application's BrowseCallbackProc with the BFFM_VALIDATEFAILED message. This flag is ignored if BIF_EDITBOX is not specified.

◆ SetOwner()

void SetOwner ( HWND hWnd )

Call this member function to set the owner window for the dialog box.

Parameters
hWnd [in] Handle to the owner window for the dialog box.

◆ SetPidlRoot()

void SetPidlRoot ( LPCITEMIDLIST pidl )

Call this member function to set the address of an ITEMIDLIST structure which specifies the location of the root folder to browse from.

Parameters
pidl [in] Address of an ITEMIDLIST structure specifying the location of the root folder to browse from. Only the specified folder and its subfolders appear in the dialog box. This member can be NULL, in which case, the namespace root (the desktop folder) is used.

◆ SetSelPath()

void SetSelPath ( LPCTSTR szSelPath )

Call this member function to set the initial path to select when the browse dialog is first opened.

Parameters
szSelPath [in] A NULL-terminated string that represents the directory that is selected when the dialog is initially opened. If not set, GetCurrentDirectory is called to set the directory.

◆ SetTitle()

void SetTitle ( LPCTSTR szTitle )

Call this member function to set the title for the browse dialog box.

Parameters
szTitle [in] Address of a NULL-terminated string that is displayed above the tree view control in the dialog box. This string can be used to specify instructions to the user.
The documentation for this class was generated from the following file:
  • XTPBrowseDialog.h


Toolkit Pro: CXTPBrowseEdit Class Reference

Public Member Functions | Static Public Attributes | Protected Attributes | List of all members
CXTPBrowseEdit Class Reference

CXTPBrowseEdit is a CXTPEdit derived class. More...

Inheritance diagram for CXTPBrowseEdit:
[legend]

Public Member Functions

CXTPBrowseEdit ()
Constructs a CXTPBrowseEdit object.
virtual | ~CXTPBrowseEdit ()
Destroys a CXTPBrowseEdit object, handles cleanup and deallocation.
bool | IsBrowsing ()
Call this member function to determine if the browse edit control is in the middle of a browse operation.
void | SetGap (int nGap)
Call this member function to set the gap between the browse button and the edit window.
virtual void | SetFileDialog (CFileDialog *pFileDialog)
This member function will set a CFileDialog derived class object to be the file open dialog.
virtual void | SetDlgOpenFile (BOOL bOpenFileDialog=TRUE)
This member function will set the File Open dialog style.
void | SetDlgDefExt (LPCTSTR lpszDefExt=NULL)
This member function sets the default extension for the File Open dialog.
void | SetDlgFileName (LPCTSTR lpszFileName=NULL)
This member function sets the default file name for the File Open dialog.
virtual void | SetDlgStyle (DWORD dwFlags=OFN_HIDEREADONLY|OFN_OVERWRITEPROMPT)
This member function sets the style flags for the File Open dialog.
void | SetDlgFilter (LPCTSTR lpszFilter=NULL)
This member function sets the file filter for the File Open dialog.
void | SetDlgTitle (LPCTSTR lpszTitle=NULL)
This member function sets the title for the directory dialog.
void | SetDlgInitialDir (LPCTSTR lpszInitialDir)
This member function sets the initial directory for the directory dialog.
virtual bool | Initialize (CWnd *pParentWnd, DWORD dwBStyle, UINT nMenu=0, int nSubMenuIndx=0)
This member function is called to initialize the browse edit control.
virtual bool | Initialize (CWnd *pParentWnd)
This member function is called to initialize the browse edit control.
virtual void | OnBrowse ()
This member function is called whenever the browse button is pressed and can be overridden to perform custom browse functions.
virtual void | ChooseDirectory ()
This member function is called by the browse edit control to display a directory chooser dialog.
virtual void | ChooseFile ()
This member function is called by the browse edit control to display a File Open dialog.
virtual void | PopupMenu ()
This member function is called by the browse edit control to create and track a pop-up menu.
virtual void | PositionBrowseButton ()
This member function is called by the browse edit control to position the browse button in relation to the edit control.
CXTPBrowseButton * GetBrowseButton ()
Call this member function to get a reference to the browse button.
- Public Member Functions inherited from CXTPEdit
CXTPEdit ()
Constructs a CXTPEdit object.
virtual | ~CXTPEdit ()
Destroys a CXTPEdit object, handles cleanup and deallocation.
BOOL | SetEditMask (LPCTSTR lpszMask, LPCTSTR lpszLiteral, LPCTSTR lpszDefault=NULL)
This member function will set the mask for the edit control.
void | SetPattern (LPCTSTR lpszPattern)
Call this member function to set the pattern for the edit mask.
virtual BOOL | CanPaste ()
Call this member function to determine if the Clipboard contains information that can be pasted into this edit view.
BOOL | HasSelection () const
Call this member function to determine if a selection has been made.
void | AdjustBuddyRect (CWnd *pBuddy, CRect &rcUpDown, int nAlignment)
Called by the framework to adjust the size of the area to draw the buddy control borders on.
void | DrawBuddyBorders (CWnd *pBuddy, CDC *pDC, CRect rc, int nAlignment)
Called by the framework to draw the borders for the associated buddy window.
virtual void | RefreshMetrics ()
This member is called to update the color, text and other visual elements of the control.
virtual void | SetTheme (XTPControlTheme nTheme)
Call this member to switch the visual theme of the control.
XTPControlTheme GetThemeID ()
Call this member function to get the style for the theme.
CXTPEditTheme * GetTheme ()
Call this member to retrieve a pointer to the current theme.
BOOL | GetFlatStyle () const
Gets the flat style appearance of the button control.
void | SetFlatStyle (BOOL bFlatStyle=TRUE)
Sets the flat style appearance of the button control.
BOOL | GetUseVisualStyle () const
Determines if the control is drawn using visual styles/SkinFramework, if supported.
void | SetUseVisualStyle (BOOL bUseVisualStyle=TRUE)
Enables Windows XP visual styles for the control.
BOOL | IsPatternValid ()
Called by the framework to determine if the pattern set using SetPattern() is valid.
void | ShowThemedBorder (BOOL bShowThemedBorder)
Call this member function to enable/disable theme border display.
BOOL | IsHighlighted () const
Call this member function to determine if the edit state is highlighted, meaning that the mouse cursor is currently hovering over the control.
BOOL | IsFocused () const
Call this member function to determine if the edit-box has input focus.
BOOL | IsFlatStyle () const
Gets the flat style appearance of the edit control.
BOOL | ShowBorder () const
Call this member to determine if non-client borders are displayed.
- Public Member Functions inherited from CXTPMaskEditT< CEdit >
CXTPMaskEditT ()
Constructs a CXTPMaskEditT object.
void | SetUseMask (BOOL bUseMask)
Call this member function to enable or disable the mask for the mask edit control.
BOOL | CanUseMask () const
This member function is called to determine if the mask for the edit control can be used.
void | SetOverType (BOOL bOverType)
This member function is called to enable or disable type over, also known as insert mode.
BOOL | CanOverType () const
This member function is called to determine if type over has been enabled.
BOOL | PosInRange (int iPos) const
This member function is called to determine if the index specified by 'iPos' is a valid index for the currently displayed edit text.
TCHAR | GetPromptChar () const
This member function retrieves the character that is currently used as the mask prompt.
CString | GetPromptString (int nLength) const
This helper member function retrieves the string contains nLength prompt characters.
void | SetPromptChar (TCHAR ch, BOOL bAutoReplace=TRUE)
This member function is called to set the prompt character that is displayed to the user that indicates the field can be edited.
afx_msg BOOL | MaskCut ()
This member function is called to perform a cut operation using the currently selected text.
afx_msg BOOL | MaskCopy ()
This member function is called to perform a copy operation using the currently selected text.
void | MaskReplaceSel (LPCTSTR lpszNewText)
This member function is called to perform a replace operation using the currently selected text.
afx_msg BOOL | MaskPaste ()
This member function is called to perform a paste operation using the current clipboard text.
void | MaskDeleteSel ()
This member function is called to delete the selection.
afx_msg BOOL | MaskClear ()
This member function is called to clear the current text selection.
afx_msg BOOL | MaskUndo ()
This member function is called to undo the previous action.
afx_msg void | MaskSelectAll ()
This member function is called to select all text in the mask edit control.
BOOL | IsModified () const
This member function is called to determine if the text has been modified.
void | SetMaskedText (LPCTSTR lpszMaskedText, int iPos=0, BOOL bUpdateWindow=TRUE)
This method called to set masked text for the edit control.
TCHAR | ConvertUnicodeAlpha (TCHAR nChar, BOOL bUpperCase) const
Converts character to Upper/Lower case.
virtual BOOL | CheckChar (TCHAR &nChar, int nPos)
This member function is used internally to validate the character indicated by 'nChar'.
virtual BOOL | ProcessMask (TCHAR &nChar, int nEndPos)
This member function is used internally to process the character passed in by 'nChar' whose index is specified by 'nEndPos'.
virtual BOOL | PreTranslateMessage (MSG *pMsg)
Used by class CWinApp to translate window messages before they are dispatched to theTranslateMessage andDispatchMessage Windows functions.
void | DeleteCharAt (int iPos)
Deletes character in specified position.
void | InsertCharAt (int iPos, TCHAR nChar)
Inserts character to specified position.
BOOL | CopyToClipboard (const CString &strText)
Copies text to system clipboard.
CString | GetMaskedText (int nStartPos=0, int nEndPos=-1) const
Retrieves masked text of the control.

Static Public Attributes

static int m_nDefaultGap
Default distance between the button and edit control.

Protected Attributes

int | m_nGap
Distance between the button and edit control.
bool | m_bBrowsing
true if in browse operation.
BOOL | m_bOpenFileDialog
TRUE for Open File dialog, FALSE for Save As.
UINT | m_nMenu
Pop-up menu ID.
UINT | m_nSubMenuIndx
Index of a pop-up submenu.
DWORD | m_dwFlags
File dialog styles.
DWORD | m_dwBStyle
Search type.
CString | m_strDefExt
Default file extension.
CString | m_strFileName
Default file name.
CString | m_strFilter
Default file filter.
CString | m_strInitialDir
Initial directory.
CString | m_strTitle
Directory dialog title.
CFileDialog * | m_pFileDialog
Pointer to a valid CFileDialog object.
CXTPBrowseButton | m_btnBrowse
Pointer to a push button.
- Protected Attributes inherited from CXTPEdit
CXTPEditTheme * | m_pTheme
Pointer to the current edit theme.
BOOL | m_bPreSubclassInit
TRUE if the control has been subclassed.
BOOL | m_bShowBorder
TRUE if non-client borders are displayed.
BOOL | m_bHighlighted
TRUE when the mouse is hovering over the control.
BOOL | m_bFocused
TRUE when the control has input focus.
CXTPRegExp * | m_pRegExp
Pointer to the CXTPRegExp object for this control.
- Protected Attributes inherited from CXTPMaskEditT< CEdit >
int | m_nStartChar
Current position of the first character in the current selection.
int | m_nEndChar
Current position of the first non-selected character past the end of the current selection.
BOOL | m_bUseMask
TRUE to use the edit mask.
BOOL | m_bOverType
TRUE to over type the text, set with VK_INSERT key press.
BOOL | m_bRedo
TRUE to redo, or FALSE to undo.
BOOL | m_bModified
TRUE if mask edit has been modified.
TCHAR | m_chPrompt
Prompt character used to identify the text entry.
CString | m_strMask
Buffer that holds the actual edit mask value.
CString | m_strDefault
Contains the edit controls default display text.
CString | m_strUndoBuffer
Holds the contents of the undo buffer.
CString | m_strRedoBuffer
Holds the contents of the redo buffer.
CString | m_strWindowText
Buffer that holds the actual edit text.
CString | m_strLiteral
Literal format that restricts where the user can enter text.
BOOL | m_bUpdateUndo
TRUE to update undo.

Additional Inherited Members

- Protected Member Functions inherited from CXTPEdit
HBRUSH | GetClientBrush (CDC *pDC)
Retrieves a handle to the client background brush.
void | RedrawEdit ()
Called by the framework to redraw the edit control.
void | RedrawFocusedFrame ()
Called by the framework to redraw the focus rectangle for the edit control.
- Protected Member Functions inherited from CXTPMaskEditT< CEdit >
virtual BOOL | OnCommand (WPARAM wParam, LPARAM lParam)
The framework calls this member function when the user selects an item from a menu.

Detailed Description

CXTPBrowseEdit is a CXTPEdit derived class.

This class also has a push button associated with it. The control can be used to search for directories and files or activate a pop-up menu.

Member Function Documentation

◆ GetBrowseButton()

CXTPBrowseButton * GetBrowseButton ( )

Call this member function to get a reference to the browse button.

Returns
A reference to the browse button.

◆ Initialize() [1/2]

virtual bool Initialize ( CWnd * pParentWnd )
virtual

This member function is called to initialize the browse edit control.

Parameters
pParentWnd [in] Pointer to the parent of the edit control.

The Initialize function must be called once for each browse edit control to complete initialization. This should be done after you have subclassed or created the browse edit control.

The browse edit control can be defined to use any of the following styles: BES_XTP_CHOOSEDIR: Display the choose folder dialog. BES_XTP_CHOOSEFILE: Display the choose file dialog. BES_XTP_POPUPMENU: Display a user-defined context menu.

The single argument version of Initialize will call the CXTPEdit base class to initialize the edit portion of the control only. Generally you would not want to use this override for standard initialization. Example: The following example demonstrates the use of Initialize:

BOOL CBrowseEditDlg::OnInitDialog()
{
   CXTPResizeDialog::OnInitDialog();
   ...
   // Initialize browse edit controls.
   m_edit1.Initialize(this, BES_XTP_POPUPMENU, IDR_POPUP);
   m_edit2.Initialize(this, BES_XTP_CHOOSEDIR);
   m_edit3.Initialize(this, BES_XTP_CHOOSEFILE);

   return TRUE;  // return TRUE  unless you set the focus to a control
}
Returns
true if initialization was successful, otherwise false.

◆ Initialize() [2/2]

virtual bool Initialize | ( | CWnd * | pParentWnd,
 |  | DWORD | dwBStyle,
 |  | UINT | nMenu = 0,
 |  | int | nSubMenuIndx = 0 )
 virtual

This member function is called to initialize the browse edit control.

Parameters
pParentWnd | [in] Pointer to the parent of the edit control.
dwBStyle | [in] A DWORD value that represents the type of search to perform. It can be any one of the styles listed in the remarks section.
nMenu | [in] If dwBStyle contains the BES_XTP_POPUPMENU flag, then nMenu represents the resource ID of a pop-up menu. Otherwise this value is ignored.
nSubMenuIndx | [in] Index of the submenu to display.

The Initialize function must be called once for each browse edit control to complete initialization. This should be done after you have subclassed or created the browse edit control.

The browse edit control can be defined to use any of the following styles: BES_XTP_CHOOSEDIR: Display the choose folder dialog. BES_XTP_CHOOSEFILE: Display the choose file dialog. BES_XTP_POPUPMENU: Display a user-defined context menu.

The single argument version of Initialize will call the CXTPEdit base class to initialize the edit portion of the control only. Generally you would not want to use this override for standard initialization. Example: The following example demonstrates the use of Initialize:

BOOL CBrowseEditDlg::OnInitDialog()
{
   CXTPResizeDialog::OnInitDialog();
   ...
   // Initialize browse edit controls.
   m_edit1.Initialize(this, BES_XTP_POPUPMENU, IDR_POPUP);
   m_edit2.Initialize(this, BES_XTP_CHOOSEDIR);
   m_edit3.Initialize(this, BES_XTP_CHOOSEFILE);

   return TRUE;  // return TRUE  unless you set the focus to a control
}
Returns
TRUE if initialization was successful, otherwise FALSE.

◆ IsBrowsing()

bool IsBrowsing ( )

Call this member function to determine if the browse edit control is in the middle of a browse operation.

Returns
true if the control is displaying a File Open dialog or pop-up menu.

◆ PopupMenu()

virtual void PopupMenu ( )
virtual

This member function is called by the browse edit control to create and track a pop-up menu.

The menu selection is then copied to the edit control.

◆ SetDlgDefExt()

void SetDlgDefExt ( LPCTSTR lpszDefExt = NULL )

This member function sets the default extension for the File Open dialog.

Parameters
lpszDefExt [in] Pointer to a NULL-terminated string that represents the default file extension to be used with the File Open dialog.

◆ SetDlgFileName()

void SetDlgFileName ( LPCTSTR lpszFileName = NULL )

This member function sets the default file name for the File Open dialog.

Parameters
lpszFileName [in] Pointer to a NULL-terminated string that represents the default file name to be used with the File Open dialog.

◆ SetDlgFilter()

void SetDlgFilter ( LPCTSTR lpszFilter = NULL )

This member function sets the file filter for the File Open dialog.

Parameters
lpszFilter [in] Pointer to a NULL-terminated string that represents the file filter used by the File Open dialog.

◆ SetDlgInitialDir()

void SetDlgInitialDir ( LPCTSTR lpszInitialDir )

This member function sets the initial directory for the directory dialog.

Parameters
lpszInitialDir [in] Pointer to a NULL-terminated string that represents the initial directory of the dialog.

◆ SetDlgOpenFile()

virtual void SetDlgOpenFile ( BOOL bOpenFileDialog = TRUE )
virtual

This member function will set the File Open dialog style.

Parameters
bOpenFileDialog [in] TRUE to construct a File Open dialog box, or FALSE to construct a File Save As dialog box.

◆ SetDlgStyle()

virtual void SetDlgStyle ( DWORD dwFlags = OFN_HIDEREADONLY|OFN_OVERWRITEPROMPT )
virtual

This member function sets the style flags for the File Open dialog.

Parameters
dwFlags [in] The desired OFN_ styles for the File Open dialog.

◆ SetDlgTitle()

void SetDlgTitle ( LPCTSTR lpszTitle = NULL )

This member function sets the title for the directory dialog.

Parameters
lpszTitle [in] Pointer to a NULL-terminated string that represents the title of the "browse for directory" dialog.

◆ SetFileDialog()

virtual void SetFileDialog ( CFileDialog * pFileDialog )
virtual

This member function will set a CFileDialog derived class object to be the file open dialog.

Parameters
pFileDialog [in] Pointer to the CFileDialog object that will replace the standard File Open dialog.

◆ SetGap()

void SetGap ( int nGap )

Call this member function to set the gap between the browse button and the edit window.

Parameters
nGap [in] Gap, in pixels, between the browse button and the edit window.

Member Data Documentation

◆ m_bOpenFileDialog

BOOL m_bOpenFileDialog
protected

TRUE for Open File dialog, FALSE for Save As.

See SetDlgOpenFile.

The documentation for this class was generated from the following file:
  • XTPBrowseEdit.h


Toolkit Pro: CXTPBrush Class Reference

Public Member Functions | List of all members
CXTPBrush Class Reference

Provides a convenient object oriented interface for HBRUSH GDI object and uses GDI handle caching. More...

Inheritance diagram for CXTPBrush:
[legend]

Public Member Functions

CXTPBrush ()
Constructs an empty CXTPBrush object.
CXTPBrush (COLORREF crColor)
Initializes a brush with a specified solid color.
CXTPBrush (int nIndex, COLORREF crColor)
Initializes a brush with the specified hatched pattern and color.
CXTPBrush (CBitmap *pBitmap)
Initializes a brush with a pattern specified by a bitmap.
~CXTPBrush ()
Handles CXTPBrush object destruction.
BOOL | CreateSolidBrush (COLORREF crColor)
Initializes a brush with a specified solid color.
BOOL | CreateHatchBrush (int nIndex, COLORREF crColor)
Initializes a brush with the specified hatched pattern and color.
BOOL | CreateBrushIndirect (const LOGBRUSH *lpLogBrush)
Initializes a brush with a style, color, and pattern specified in a LOGBRUSH structure.
BOOL | CreatePatternBrush (CBitmap *pBitmap)
Initializes a brush with a pattern specified by a bitmap.
BOOL | CreateDIBPatternBrush (HGLOBAL hPackedDIB, UINT nUsage)
Initializes a brush with the pattern specified by a device-independent bitmap (DIB).
BOOL | CreateDIBPatternBrush (const void *lpPackedDIB, UINT nUsage)
Initializes a brush with the pattern specified by a device-independent bitmap (DIB).
BOOL | CreateSysColorBrush (int nIndex)
Initializes a brush with a system color.
int | GetLogBrush (LOGBRUSH *pLogBrush)
Call this function to retrieve a copy of the LOGBRUSH structure that describes the encapsulated GDI object.
CBrush * | GetNativeGdiObject ()
Obtains a pointer to the encapsulated GDI object as CBrush type.
const CBrush * | GetNativeGdiObject () const
Obtains a pointer to the encapsulated GDI object as CBrush type.
operator HBRUSH () const
Casts an object to an encapsulated GDI handle.
operator CBrush & ()
Converts an object to CBrush reference making it possible to use CXTPBrush with MFC classes and methods that use CBrush or CGdiObject reference as an argument.
operator const CBrush & () const
Converts an object to CBrush constant reference making it possible to use CXTPBrush with MFC classes and methods that use CBrush or CGdiObject constant reference as an argument.
- Public Member Functions inherited from CXTPGdiObject
virtual | ~CXTPGdiObject ()=0
Handles CXTPGdiObject destruction.
operator HGDIOBJ () const
Casts an object to an encapsulated GDI handle.
HGDIOBJ | GetSafeHandle () const
Returns m_hObject unless this is NULL, in which case NULL is returned.
BOOL | DeleteObject ()
Decrements reference counter for a cached GDI object or delete the cached GDI object once the reference counter is equal to zero.
int | GetObject (int nCount, LPVOID lpObject) const
Fills a buffer with data that defines a specified object.
UINT | GetObjectType () const
Retrieves the type of the GDI object.
BOOL | CreateStockObject (int nIndex)
Retrieves a handle to one of the predefined stock Windows GDI pens, brushes, or fonts, and attaches the GDI object to the CGdiObject object.
BOOL | operator== (const CXTPGdiObject &obj) const
Determines if two GDI objects are logically equal.
BOOL | operator!= (const CXTPGdiObject &obj) const
Determines if two GDI objects are logically not equal.
operator CGdiObject & ()
Converts an object to CGdiObject reference making it possible to use CXTPGdiObject with MFC classes and methods that use CGdiObject reference as an argument.
operator const CGdiObject & () const
Converts an object to CGdiObject constance reference making it possible to use CXTPGdiObject with MFC classes and methods that use CGdiObject reference as an argument.
__declspec (property(get=GetSafeHandle)) HGDIOBJ m_hObject
A read-only encapsulated GDI handle value.
void | SetHandleOwnershipNotGuaranteed ()
Sets handle ownership guaranteed status.
BOOL | IsHandleOwnershipGuaranteed () const
Determines handle ownership guaranteed status.

Additional Inherited Members

- Protected Member Functions inherited from CXTPGdiObject
CXTPGdiObject ()
Performs internal CXTPGdiObject construction logic.

Detailed Description

Provides a convenient object oriented interface for HBRUSH GDI object and uses GDI handle caching.

Mimics CBrush's interface from MFC however cannot be cast to CBrush or CGdiObject types.

XTP GDI objects use cached GDI handles so one native GDI handle can be shared across several XTP GDI object instances. The lifetime of a handle is controlled by XTP GDI reference counter, meaning a handle is deleted only when the last XTP GDI object that references a particular handle is destroyed or DeleteObject is called. Note, because an encapsulated GDI handle is cached and shared, passing m_hObject to DeleteObject from Windows SDK or convering an XTP GDI object to CGdiObject& and making a call to CGdiObject::DeleteObject will delete a cached handle and leave all XTP GDI object that reference the delete handle in an undetermined state. This will also affect every place in a program where the cached handles are used. So use the encapsulated GDI handle or CGdiObject very carefully and for read-only purposes.

See also
CXTPGdiObject, CXTPFont, CXTPPen

Constructor & Destructor Documentation

◆ CXTPBrush() [1/3]

CXTPBrush ( COLORREF crColor )

Initializes a brush with a specified solid color.

Parameters
crColor A COLORREF structure that specifies the color of the brush.

If the requested brush has already been created from another CXTPBrush instance and not yet deleted the same brush will be re-used and its reference counter will be incremented.

◆ CXTPBrush() [2/3]

CXTPBrush | ( | int | nIndex,
 |  | COLORREF | crColor )

Initializes a brush with the specified hatched pattern and color.

Parameters
nIndex | Specifies the hatch style of the brush.
crColor | A COLORREF structure that specifies the color of the brush.

If the requested brush has already been created from another CXTPBrush instance and not yet deleted the same brush will be re-used and its reference counter will be incremented.

◆ CXTPBrush() [3/3]

CXTPBrush ( CBitmap * pBitmap )

Initializes a brush with a pattern specified by a bitmap.

Parameters
pBitmap Pattern bitmap pointer.

If the requested brush has already been created from another CXTPBrush instance and not yet deleted the same brush will be re-used and its reference counter will be incremented.

Member Function Documentation

◆ CreateBrushIndirect()

BOOL CreateBrushIndirect ( const LOGBRUSH * lpLogBrush )

Initializes a brush with a style, color, and pattern specified in a LOGBRUSH structure.

Parameters
lpLogBrush Points to a LOGBRUSH structure that contains information about the brush.
Returns
Nonzero if successful; otherwise 0.

If the requested brush has already been created from another CXTPBrush instance and not yet deleted the same brush will be re-used and its reference counter will be incremented.

◆ CreateDIBPatternBrush() [1/2]

BOOL CreateDIBPatternBrush | ( | const void * | lpPackedDIB,
 |  | UINT | nUsage )

Initializes a brush with the pattern specified by a device-independent bitmap (DIB).

Parameters
lpPackedDIB | Points to a packed DIB consisting of a BITMAPINFO structure immediately followed by an array of bytes defining the pixels of the bitmap.
nUsage | Specifies whether the bmiColors[] fields of the BITMAPINFO data structure(a part of the "packed DIB") contain explicit RGB values or indices into the currently realized logical palette.
Returns
Nonzero if successful; otherwise 0.

If the requested brush has already been created from another CXTPBrush instance and not yet deleted the same brush will be re-used and its reference counter will be incremented.

◆ CreateDIBPatternBrush() [2/2]

BOOL CreateDIBPatternBrush | ( | HGLOBAL | hPackedDIB,
 |  | UINT | nUsage )

Initializes a brush with the pattern specified by a device-independent bitmap (DIB).

Parameters
hPackedDIB | Identifies a global memory object containing a packed device independent bitmap(DIB).
nUsage | Specifies whether the bmiColors[] fields of the BITMAPINFO data structure(a part of the "packed DIB") contain explicit RGB values or indices into the currently realized logical palette.
Returns
Nonzero if successful; otherwise 0.

If the requested brush has already been created from another CXTPBrush instance and not yet deleted the same brush will be re-used and its reference counter will be incremented.

◆ CreateHatchBrush()

BOOL CreateHatchBrush | ( | int | nIndex,
 |  | COLORREF | crColor )

Initializes a brush with the specified hatched pattern and color.

Parameters
nIndex | Specifies the hatch style of the brush.
crColor | A COLORREF structure that specifies the color of the brush.
Returns
Nonzero if successful; otherwise 0.

If the requested brush has already been created from another CXTPBrush instance and not yet deleted the same brush will be re-used and its reference counter will be incremented.

◆ CreatePatternBrush()

BOOL CreatePatternBrush ( CBitmap * pBitmap )

Initializes a brush with a pattern specified by a bitmap.

Parameters
pBitmap Pattern bitmap pointer.
Returns
Nonzero if successful; otherwise 0.

If the requested brush has already been created from another CXTPBrush instance and not yet deleted the same brush will be re-used and its reference counter will be incremented.

◆ CreateSolidBrush()

BOOL CreateSolidBrush ( COLORREF crColor )

Initializes a brush with a specified solid color.

Parameters
crColor A COLORREF structure that specifies the color of the brush.
Returns
Nonzero if successful; otherwise 0.

If the requested brush has already been created from another CXTPBrush instance and not yet deleted the same brush will be re-used and its reference counter will be incremented.

◆ CreateSysColorBrush()

BOOL CreateSysColorBrush ( int nIndex )

Initializes a brush with a system color.

Parameters
nIndex Specifies a color index.
Returns
Nonzero if successful; otherwise 0.

If the requested brush has already been created from another CXTPBrush instance and not yet deleted the same brush will be re-used and its reference counter will be incremented.

◆ GetLogBrush()

int GetLogBrush ( LOGBRUSH * pLogBrush )

Call this function to retrieve a copy of the LOGBRUSH structure that describes the encapsulated GDI object.

Parameters
pLogBrush Pointer to the LOGBRUSH structure to receive the brush information.
Returns
Nonzero if the function succeeds, otherwise 0.

◆ GetNativeGdiObject() [1/2]

CBrush * GetNativeGdiObject ( )

Obtains a pointer to the encapsulated GDI object as CBrush type.

The returned object must not be deleted or modified as it will affect every place in a program where the cached handle is used.

Returns
A pointer to the encapsulated GDI object as CBrush type.

◆ GetNativeGdiObject() [2/2]

const CBrush * GetNativeGdiObject ( ) const

Obtains a pointer to the encapsulated GDI object as CBrush type.

The returned object must not be deleted or modified as it will affect every place in a program where the cached handle is used.

Returns
A pointer to the encapsulated GDI object as CBrush type.

◆ operator CBrush &()

operator CBrush & ( )

Converts an object to CBrush reference making it possible to use CXTPBrush with MFC classes and methods that use CBrush or CGdiObject reference as an argument.

Returns
An encapsulated CBrush reference.

The returned object must not be deleted or modified as it will affect every place in a program where the cached handle is used.

◆ operator const CBrush &()

operator const CBrush & ( ) const

Converts an object to CBrush constant reference making it possible to use CXTPBrush with MFC classes and methods that use CBrush or CGdiObject constant reference as an argument.

Returns
An encapsulated CBrush constant reference.

The returned object must not be deleted or modified as it will affect every place in a program where the cached handle is used.

◆ operator HBRUSH()

operator HBRUSH ( ) const

Casts an object to an encapsulated GDI handle.

The returned handle must not be passed to DeleteObject and should be used for read-only purposes, i.e. GDI object state should not be modified as it will affect every place in a program where the cached hande is used.

Returns
Encapsulated GDI handle or NULL.
The documentation for this class was generated from the following file:
  • XTPGdiObjects.h


Toolkit Pro: CXTPButton Class Reference

Public Member Functions | Public Attributes | Protected Member Functions | Protected Attributes | List of all members
CXTPButton Class Reference

Push Button control. More...

Inheritance diagram for CXTPButton:
[legend]

Public Member Functions

CXTPButton ()
Constructs a CXTPButton object.
virtual | ~CXTPButton ()
Destroys a CXTPButton object, handles cleanup and deallocation.
BYTE | GetButtonStyle () const
Retrieves the button styles for this object.
virtual BOOL | IsPushed ()
Call this member function to determine if the the button is currently being pushed.
virtual BOOL | IsHighlighted ()
Call this member function to determine if the the button is currently being highlighted (mouse over).
virtual BOOL | GetChecked ()
Call this member function to determine if the checked state has been defined for the button control.
void | SetChecked (BOOL bChecked)
Sets the highlight state for the button control.
BOOL | GetFlatStyle () const
Gets the flat style appearance of the button control.
void | SetFlatStyle (BOOL bFlatStyle=TRUE)
Sets the flat style appearance of the button control.
BOOL | GetUseVisualStyle () const
Determines if the control is drawn using visual styles/SkinFramework, if supported.
void | SetUseVisualStyle (BOOL bUseVisualStyle=TRUE)
Enables Windows XP visual styles for the control.
long | GetBorderGap () const
Call this member function to retrieve the gap between the button's image and border.
void | SetBorderGap (int nBorderGap)
Call this member function to set the gap between the button's image and border.
XTPPushButtonStyle | GetPushButtonStyle () const
This function retrieves a flag from the XTPPushButtonStyle enumeration that specifies the current style of the button.
void | SetPushButtonStyle (XTPPushButtonStyle nPushButtonStyle)
This member function will set the display style for the button.
virtual int | GetTextAlignment () const
Gets the alignment of the text on the button control.
void | SetTextAlignment (DWORD dwAlignment)
Sets the alignment of the text on the button control.
virtual int | GetImageAlignment () const
Gets the alignment of the image on the button control.
void | SetImageAlignment (DWORD dwAlignment)
Sets the alignment of the image on the button control.
XTPButtonTextImageRelation | GetTextImageRelation () const
Gets the text and image relation in the button.
void | SetTextImageRelation (XTPButtonTextImageRelation relation)
Sets the text and image relation in the button.
long | GetImageGap () const
Call this member function to retrieve the gap between the button's text and image.
void | SetImageGap (int nImageGap)
Call this member function to set the gap between the button's text and image.
virtual CSize | GetImageSize ()
Call this member function to return the size of the image displayed for the button control.
virtual BOOL | IsDpiImageScalingEnabled () const
Call this member to check if DPI scaling of images is enabled.
virtual void | SetDpiImageScaling (BOOL bEnable)
Call this member to enable/disable DPI scaling of images.
CXTPImageManagerIcon * | GetIcon () const
Call this member function to return a pointer to the image manager for the button control.
virtual void | DrawImage (CDC *pDC, CRect rc)
This method is called to draw the image of the control.
XTPGroupBoxBorderStyle | GetBorderStyle () const
Gets the border style of the control.
void | SetBorderStyle (XTPGroupBoxBorderStyle style)
Sets the border style of the control.
BOOL | GetShowFocus () const
Gets whether a focus rectangle is drawn around the contents of a button when the button has focus.
void | SetShowFocus (BOOL bShowFocus)
Sets whether a focus rectangle is drawn around the contents of a button when the button has focus.
virtual BOOL | SetTheme (XTPControlTheme eTheme)
Call this member to switch the visual theme of the control.
virtual void | SetTheme (CXTPButtonTheme *pPaintManager)
Call this member to switch the visual theme of the control.
CXTPButtonTheme * GetTheme ()
Call this member function to get a pointer to the currently selected theme.
void | RedrawButton (BOOL bUpdateWindow=FALSE)
Redraws the button.
BOOL | IsDropDownStyle () const
This member function is called to determine if the buttons have a drop down arrow and if it is drop down style.
virtual CRect | GetButtonRect ()
This member function is called to determine the size and location of the button.
void | SetBuddy (CWnd *pWndBuddy, BOOL bMoveButton=TRUE)
Sets the control used as the buddy control.
void | SetTooltip (LPCTSTR lpszTooltip)
Associates tooltip text with the button.
CString | GetTooltip () const
Call this member to retrieve the button's tooltip.
CXTPToolTipContext * | GetToolTipContext () const
Call this method to get a pointer to the tooltip context.
virtual BOOL | SetIcon (CSize size, HICON hIcon, HICON hIconHot=NULL, BOOL bRedraw=TRUE)
This member function will set the normal and hot state icons for the push button.
virtual BOOL | SetIcon (CSize size, UINT nID, UINT nHotID=0, BOOL bRedraw=TRUE)
This member function will set the normal and hot state icons for the push button.
virtual BOOL | SetIcon (CSize size, LPCTSTR lpszID, LPCTSTR lpszHotID=NULL, BOOL bRedraw=TRUE)
This member function will set the normal and hot state icons for the push button.
BOOL | SetIcon (CSize size, CXTPImageManagerIcon *pIcon, BOOL bRedraw=TRUE)
This member function will set the normal and hot state icons for the push button.
virtual BOOL | SetIcon (CSize size, const CXTPImageManagerIconHandle &hIconHandle, const CXTPImageManagerIconHandle &hIconHotHandle, BOOL bRedraw=TRUE)
This member function will set the normal and hot state icons for the push button.
virtual BOOL | SetBitmap (CSize size, UINT nID, BOOL bRedraw=TRUE)
This member function will set the bitmap associated with the button.
virtual CString | GetButtonText ()
Call this member function to return the button's text minus the '&'.
CSize | GetGlyphSize (BOOL bCheckBox)
Retrieves the size of the check box glyph.
BOOL | IsPushButton () const
Determines if the button is a push button or a drop down button.
void | EnableMarkup (BOOL bEnableMarkup=TRUE)
Allows the use of a XAML snippet to be used for the text of panes in the control.
virtual COLORREF | GetButtonTextColor ()
Gets the button's text color.
virtual COLORREF | GetButtonBackColor ()
Gets the button's back color.
virtual void | InternalTextChanged ()
This member function is called when the text has changed.
CXTPMarkupContext * | GetMarkupContext () const
Retrieves a pointer to the markup context.
CXTPMarkupUIElement * GetMarkupUIElement ()
Call this method to get the markup element that renders the caption of the control.

Public Attributes

BOOL | m_bPushed
TRUE if button was pressed.
BOOL | m_bHot
TRUE if mouse under button.
CXTPButtonTheme * | m_pTheme
Pointer to the current theme object.
BOOL | m_bChecked
TRUE if checked.
BOOL | m_bFlatStyle
TRUE to see the flat style.
BOOL | m_bUseVisualStyle
TRUE to use visual styles.
long | m_nImageAlignment
Image Alignment.
long | m_nBorderGap
Gap between the button edge and the image.
long | m_nPushButtonStyle
The style of the button.
BOOL | m_bEnableMarkup
TRUE to enable markup.
long | m_nImageGap
Gap between the button text and the image.
long | m_nTextImageRelation
Image and text orientation.
CXTPImageManagerIcon * | m_pIcon
Multiple state icon manager converts icon to different states.
CSize | m_szVectorIcon
Size of displayed image if vector icon is used.
long | m_nBorderStyle
Border style used.
BOOL | m_bShowFocus
TRUE to show the focus rectangle.
HWND | m_hWndBuddy
Handle to the buddy control.
CXTPToolTipContext * | m_pToolTipContext
TooltipContext.
CString | m_strTooltip
Tooltip of the item.

Protected Member Functions

virtual void | OnDropDown ()
Occurs when the drop down button is dropped down.
virtual void | OnDraw (CDC *pDC)
This member function performs all of the drawing logic of the calendar control window.
void | DoDropDown ()
Manually drops down a drop down button.
virtual void | RefreshMetrics ()
Call this member function to refresh theme colors and redraw the control.

Protected Attributes

CXTPMarkupContext * | m_pMarkupContext
Markup context.
CXTPMarkupUIElement * | m_pUIElement
Markup element pointer.
BOOL | m_bImageDPIScaling
TRUE if DPI scaling of images enabled.

Detailed Description

Push Button control.

Member Function Documentation

◆ DrawImage()

virtual void DrawImage | ( | CDC * | pDC,
 |  | CRect | rc )
 virtual

This method is called to draw the image of the control.

Parameters
pDC | Pointer to a valid device context.
rc | Size of the image.

◆ EnableMarkup()

void EnableMarkup ( BOOL bEnableMarkup = TRUE )

Allows the use of a XAML snippet to be used for the text of panes in the control.

Parameters
bEnableMarkup TRUE to enable markup, FALSE to disable markup.

◆ GetBorderGap()

long GetBorderGap ( ) const

Call this member function to retrieve the gap between the button's image and border.

Returns
The amount, in pixels, of the gap between the button's image and border.

◆ GetBorderStyle()

XTPGroupBoxBorderStyle GetBorderStyle ( ) const

Gets the border style of the control.

Returns
Flag from the XTPGroupBoxBorderStyle enumeration that specifies the border style of the control.

◆ GetButtonBackColor()

virtual COLORREF GetButtonBackColor ( )
virtual

Gets the button's back color.

Returns
The button's back color.

◆ GetButtonRect()

virtual CRect GetButtonRect ( )
virtual

This member function is called to determine the size and location of the button.

Returns
The size and location of the button, or an empty rect if no button is defined.

◆ GetButtonStyle()

BYTE GetButtonStyle ( ) const

Retrieves the button styles for this object.

This function returns only the BS_ style values, not any of the other window styles.

Returns
The BS_ style for this button.

◆ GetButtonText()

virtual CString GetButtonText ( )
virtual

Call this member function to return the button's text minus the '&'.

Returns
A CString object that represents the button's text.

◆ GetButtonTextColor()

virtual COLORREF GetButtonTextColor ( )
virtual

Gets the button's text color.

Returns
The button's text color.

◆ GetChecked()

virtual BOOL GetChecked ( )
virtual

Call this member function to determine if the checked state has been defined for the button control.

Returns
TRUE if the checked state is defined for the button control, otherwise FALSE.

◆ GetFlatStyle()

BOOL GetFlatStyle ( ) const

Gets the flat style appearance of the button control.

The control will appear flat until the mouse pointer moves over it, at which point it appears three-dimensional.

Returns
TRUE if the flat style is used, otherwise FALSE.

◆ GetGlyphSize()

CSize GetGlyphSize ( BOOL bCheckBox )

Retrieves the size of the check box glyph.

Parameters
bCheckBox TRUE if the check box is checked, otherwise FALSE.
Returns
The size of the check box glyph.

◆ GetIcon()

CXTPImageManagerIcon * GetIcon ( ) const

Call this member function to return a pointer to the image manager for the button control.

Returns
A pointer to a CXTPImageManagerIcon object.

◆ GetImageAlignment()

virtual int GetImageAlignment ( ) const
virtual

Gets the alignment of the image on the button control.

Returns
Alignment of the image on the button control.

◆ GetImageGap()

long GetImageGap ( ) const

Call this member function to retrieve the gap between the button's text and image.

Returns
The amount, in pixels, of the gap between the button's text and image.

◆ GetImageSize()

virtual CSize GetImageSize ( )
virtual

Call this member function to return the size of the image displayed for the button control.

Returns
A CSize object.

◆ GetMarkupContext()

CXTPMarkupContext * GetMarkupContext ( ) const

Retrieves a pointer to the markup context.

Returns
A pointer to a CXTPMarkupContext object.

◆ GetMarkupUIElement()

CXTPMarkupUIElement * GetMarkupUIElement ( )

Call this method to get the markup element that renders the caption of the control.

Returns
Pointer to a CXTPMarkupUIElement element.

◆ GetPushButtonStyle()

XTPPushButtonStyle GetPushButtonStyle ( ) const

This function retrieves a flag from the XTPPushButtonStyle enumeration that specifies the current style of the button.

Returns
The button styles for this CXTPButton object.

◆ GetShowFocus()

BOOL GetShowFocus ( ) const

Gets whether a focus rectangle is drawn around the contents of a button when the button has focus.

Returns
TRUE if the focus rectangle is shown, otherwise FALSE.

◆ GetTextAlignment()

virtual int GetTextAlignment ( ) const
virtual

Gets the alignment of the text on the button control.

Returns
Alignment of the text on the button control.

◆ GetTextImageRelation()

XTPButtonTextImageRelation GetTextImageRelation ( ) const

Gets the text and image relation in the button.

Returns
Flag from the XTPButtonTextImageRelation enumeration that specifies the text and image relation in the button.

◆ GetTheme()

CXTPButtonTheme * GetTheme ( )

Call this member function to get a pointer to the currently selected theme.

Returns
A pointer to a CXTPButtonTheme object representing the currently selected theme.

◆ GetTooltip()

CString GetTooltip ( ) const

Call this member to retrieve the button's tooltip.

Returns
The tooltip text for the button.

◆ GetToolTipContext()

CXTPToolTipContext * GetToolTipContext ( ) const

Call this method to get a pointer to the tooltip context.

Returns
A pointer to the tooltip context.

◆ GetUseVisualStyle()

BOOL GetUseVisualStyle ( ) const

Determines if the control is drawn using visual styles/SkinFramework, if supported.

This method enables Windows XP visual styles for the control. This Control will draw using visual styles if both the control and the operating system support it. Visual styles and SkinFramework skins are specifications for the appearance of controls. GetUseVisualStyle determines whether to use the currently set Windows XP visual style. If using SkinFramework, then it determines whether to use the currently set style of the SkinFramework.

Returns
TRUE if the currently set Windows XP visual style will be used to theme the control. If using SkinFramework, then the currently set style of the SkinFramework will be used to skin the control. FALSE if the currently set appearance/style in the OS will be used.

◆ IsDpiImageScalingEnabled()

virtual BOOL IsDpiImageScalingEnabled ( ) const
virtual

Call this member to check if DPI scaling of images is enabled.

If DPI image scaling has ever been changed for the object using SetDpiImageScaling then the returned value will be the latest value set via SetDpiImageScaling, otherwise it'll return the global DPI bitmap scaling flag obtained via CXTPDpi::IsDpiBitmapScalingEnabled.

Returns
TRUE if DPI scaling of images is enabled, otherwise FALSE.

◆ IsDropDownStyle()

BOOL IsDropDownStyle ( ) const

This member function is called to determine if the buttons have a drop down arrow and if it is drop down style.

Returns
TRUE if the button uses drop down style, otherwise FALSE.

◆ IsHighlighted()

virtual BOOL IsHighlighted ( )
virtual

Call this member function to determine if the the button is currently being highlighted (mouse over).

Returns
TRUE if the button is currently being highlighted (mouse over), otherwise FALSE.

◆ IsPushButton()

BOOL IsPushButton ( ) const

Determines if the button is a push button or a drop down button.

Returns
TRUE if the button is a push button, FALSE if it is a drop down button.

◆ IsPushed()

virtual BOOL IsPushed ( )
virtual

Call this member function to determine if the the button is currently being pushed.

Returns
TRUE if the button is currently being pushed, otherwise FALSE.

Reimplemented in CXTPColorPicker.

◆ OnDraw()

virtual void OnDraw ( CDC * pDC )
protectedvirtual

This member function performs all of the drawing logic of the calendar control window.

Parameters
pDC Pointer to a valid device context.

◆ RedrawButton()

void RedrawButton ( BOOL bUpdateWindow = FALSE )

Redraws the button.

Parameters
bUpdateWindow TRUE to notify the parent window.

◆ SetBitmap()

virtual BOOL SetBitmap | ( | CSize | size,
 |  | UINT | nID,
 |  | BOOL | bRedraw = TRUE )
 virtual

This member function will set the bitmap associated with the button.

Parameters
size | CSize object that represents the size of the bitmap.
nID | Resource ID for the bitmap.
bRedraw | Specifies whether the button is to be redrawn. A nonzero value redraws the button. A zero value does not redraw the button. The button is redrawn by default.
Returns
TRUE if successful, otherwise FALSE.

◆ SetBorderGap()

void SetBorderGap ( int nBorderGap )

Call this member function to set the gap between the button's image and border.

Parameters
nBorderGap The amount, in pixels, of the gap between the button's image and border.

◆ SetBorderStyle()

void SetBorderStyle ( XTPGroupBoxBorderStyle style )

Sets the border style of the control.

Parameters
style Flag from the XTPGroupBoxBorderStyle enumeration that specifies the border style of the control.

◆ SetBuddy()

void SetBuddy | ( | CWnd * | pWndBuddy,
 |  | BOOL | bMoveButton = TRUE )

Sets the control used as the buddy control.

Parameters
pWndBuddy | Handle to the control to use as a buddy.
bMoveButton | TRUE to move the button, FALSE to move the buddy.

◆ SetChecked()

void SetChecked ( BOOL bChecked )

Sets the highlight state for the button control.

Parameters
bChecked Specifies whether the button is to be checked. TRUE will check the button, FALSE will uncheck it.

This member function sets the highlighting state of the button control. This is the same as its CButton counterpart, except the m_bChecked flag is set. This is done because MFC does not recognize the button as being checked unless it is a radio or check box.

◆ SetDpiImageScaling()

virtual void SetDpiImageScaling ( BOOL bEnable )
virtual

Call this member to enable/disable DPI scaling of images.

Overrides the default value used from the CXTPDpi::IsDpiBitmapScalingEnabled call.

Parameters
bEnable TRUE to enable DPI scaling of images, FALSE to disable.

◆ SetFlatStyle()

void SetFlatStyle ( BOOL bFlatStyle = TRUE )

Sets the flat style appearance of the button control.

Parameters
bFlatStyle TRUE to use the flat style, otherwise FALSE.

The control will appear flat until the mouse pointer moves over it, at which point it appears three-dimensional.

◆ SetIcon() [1/5]

virtual BOOL SetIcon | ( | CSize | size,
 |  | const CXTPImageManagerIconHandle & | hIconHandle,
 |  | const CXTPImageManagerIconHandle & | hIconHotHandle,
 |  | BOOL | bRedraw = TRUE )
 virtual

This member function will set the normal and hot state icons for the push button.

Parameters
size | CSize object that represents the size of the icon.
hIconHandle | Handle to the normal icon.
hIconHotHandle | Handle to the hot icon.
bRedraw | Specifies whether the button is to be redrawn. A nonzero value redraws the button. A zero value does not redraw the button. The button is redrawn by default.
Returns
TRUE if successful, otherwise FALSE.

◆ SetIcon() [2/5]

BOOL SetIcon | ( | CSize | size,
 |  | CXTPImageManagerIcon * | pIcon,
 |  | BOOL | bRedraw = TRUE )

This member function will set the normal and hot state icons for the push button.

Parameters
size | CSize object that represents the size of the icon.
pIcon | Handle to a CXTPImageManagerIcon icon.
bRedraw | Specifies whether the button is to be redrawn. A nonzero value redraws the button. A zero value does not redraw the button. The button is redrawn by default.
Returns
TRUE if successful, otherwise FALSE.

◆ SetIcon() [3/5]

virtual BOOL SetIcon | ( | CSize | size,
 |  | HICON | hIcon,
 |  | HICON | hIconHot = NULL,
 |  | BOOL | bRedraw = TRUE )
 virtual

This member function will set the normal and hot state icons for the push button.

Parameters
size | CSize object that represents the size of the icon.
hIcon | Handle to the normal icon.
hIconHot | Handle to the hot icon.
bRedraw | Specifies whether the button is to be redrawn. A nonzero value redraws the button. A zero value does not redraw the button. The button is redrawn by default.
Returns
TRUE if successful, otherwise FALSE.

◆ SetIcon() [4/5]

virtual BOOL SetIcon | ( | CSize | size,
 |  | LPCTSTR | lpszID,
 |  | LPCTSTR | lpszHotID = NULL,
 |  | BOOL | bRedraw = TRUE )
 virtual

This member function will set the normal and hot state icons for the push button.

Parameters
size | CSize object that represents the size of the icon.
lpszID | Resource string ID for the normal icon.
lpszHotID | Resource string ID for the hot icon.
bRedraw | Specifies whether the button is to be redrawn. A nonzero value redraws the button. A zero value does not redraw the button. The button is redrawn by default.
Returns
TRUE if successful, otherwise FALSE.

◆ SetIcon() [5/5]

virtual BOOL SetIcon | ( | CSize | size,
 |  | UINT | nID,
 |  | UINT | nHotID = 0,
 |  | BOOL | bRedraw = TRUE )
 virtual

This member function will set the normal and hot state icons for the push button.

Parameters
size | CSize object that represents the size of the icon.
nID | Resource ID for the normal icon.
nHotID | Resource ID for the pressed icon.
bRedraw | Specifies whether the button is to be redrawn. A nonzero value redraws the button. A zero value does not redraw the button. The button is redrawn by default.
Returns
TRUE if successful, otherwise FALSE.

◆ SetImageAlignment()

void SetImageAlignment ( DWORD dwAlignment )

Sets the alignment of the image on the button control.

Parameters
dwAlignment Alignment of the image on the button control.

◆ SetImageGap()

void SetImageGap ( int nImageGap )

Call this member function to set the gap between the button's text and image.

Parameters
nImageGap Amount, in pixels, of the gap between the button's text and image.

◆ SetPushButtonStyle()

void SetPushButtonStyle ( XTPPushButtonStyle nPushButtonStyle )

This member function will set the display style for the button.

Parameters
nPushButtonStyle Specifies the button style. The button style can be defined as one or more of the styles listed in the Remarks section.

The Button can be set to any value from the XTPPushButtonStyle enumeration.

See also
GetPushButtonStyle

◆ SetShowFocus()

void SetShowFocus ( BOOL bShowFocus )

Sets whether a focus rectangle is drawn around the contents of a button when the button has focus.

Parameters
bShowFocus TRUE to show the focus rectangle, FALSE to hide it.

◆ SetTextAlignment()

void SetTextAlignment ( DWORD dwAlignment )

Sets the alignment of the text on the button control.

Parameters
dwAlignment Alignment of the text on the button control.

◆ SetTextImageRelation()

void SetTextImageRelation ( XTPButtonTextImageRelation relation )

Sets the text and image relation in the button.

Parameters
relation Flag from the XTPButtonTextImageRelation enumeration that specifies the text and image relation in the button.

◆ SetTheme() [1/2]

virtual void SetTheme ( CXTPButtonTheme * pPaintManager )
virtual

Call this member to switch the visual theme of the control.

Parameters
pPaintManager A CXTPButtonTheme pointer to the theme object. If pPaintManager is NULL, then themes are disabled and the paint manager is used.

Reimplemented in CXTPCaptionButton.

◆ SetTheme() [2/2]

virtual BOOL SetTheme ( XTPControlTheme eTheme )
virtual

Call this member to switch the visual theme of the control.

Parameters
eTheme New visual theme. Can be any of the values listed in the Remarks section.

eTheme can be one of the following: xtpControlThemeDefault: Use default theme. xtpControlThemeFlat: Flat appearance style. xtpControlThemeUltraFlat: Ultra flat appearance style. xtpControlThemeOffice2000: Office 2000 appearance style. xtpControlThemeOfficeXP: Office XP appearance style. xtpControlThemeOffice2003: Office 2003 appearance style. xtpControlThemeResource: Office 2007 appearance style. xtpControlThemeVisualStudio2012Light: VS 2012 Light style theme. xtpControlThemeVisualStudio2012Dark: VS 2012 Dark style theme.

Returns
TRUE if successful, otherwise FALSE.

Reimplemented in CXTPCaptionButton.

◆ SetTooltip()

void SetTooltip ( LPCTSTR lpszTooltip )

Associates tooltip text with the button.

Parameters
lpszTooltip The tooltip text to display when the mouse cursor is over the item.

◆ SetUseVisualStyle()

void SetUseVisualStyle ( BOOL bUseVisualStyle = TRUE )

Enables Windows XP visual styles for the control.

This method enables Windows XP visual styles for the control. This Control will draw using visual styles if both the control and the operating system support it. Visual styles and SkinFramework skins are specifications for the appearance of controls. GetUseVisualStyle determines whether to use the currently set Windows XP visual style. If using SkinFramework, then it determines whether to use the currently set style of the SkinFramework.

Parameters
bUseVisualStyle TRUE if the currently set Windows XP visual style will be used to theme the control. If using SkinFramework, then the currently set style of the SkinFramework will be used to skin the control. FALSE if the currently set appearance/style in the OS will be used.
The documentation for this class was generated from the following file:
  • XTPButton.h


Toolkit Pro: CXTPButtonTheme Class Reference

Public Member Functions | Public Attributes | List of all members
CXTPButtonTheme Class Reference

CXTPButtonTheme is a class used to perform Button Theme drawing tasks. More...

Inheritance diagram for CXTPButtonTheme:
[legend]

Public Member Functions

CXTPButtonTheme ()
Constructs a CXTPButtonTheme object.
virtual | ~CXTPButtonTheme ()
Destroys a CXTPButtonTheme object, handles cleanup and deallocation.
virtual void | DrawButtonBackground (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the background for the button.
virtual void | DrawFocusRect (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the focus rectangle for the button.
virtual void | DrawButton (CDC *pDC, CXTPButton *pButton)
This member function is called to the button.
virtual void | DrawButtonVisualStyleBackground (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the styled background for the button.
virtual void | RefreshMetrics (CXTPButton *pButton)
This member function is called by the theme manager to refresh the visual styles used by each component's theme.
virtual void | DrawPushButtonText (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the text for the button.
virtual void | DrawPushButtonIcon (CDC *pDC, CXTPButton *pButton)
This member function draws the icon for the button, if one has been defined.
virtual void | DrawPushButtonDropDown (CDC *pDC, CXTPButton *pButton)
This member function draws the dropdown for the button, if one has been defined.
virtual COLORREF | GetTextColor (CXTPButton *pButton)
Call this member function to return the color used to draw the button text.
virtual void | DrawCheckBoxMark (CDC *pDC, CXTPButton *pButton)
This member function draws the check box mark for the button, if one has been defined.
virtual void | DrawRadioButtonMark (CDC *pDC, CXTPButton *pButton)
This member function draws the radio button mark for the button, if one has been defined.
void | DrawButtonText (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the text for the button.
virtual void | DrawGroupBox (CDC *pDC, CXTPButton *pButton)
This member function draws the group box for the button, if one has been defined.
- Public Member Functions inherited from CXTPControlTheme
CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme | GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Public Attributes

CXTPPaintManagerColor | m_crTextDisabled
RGB value for disabled text color.
CXTPPaintManagerColor | m_crBorderHilite
RGB value for border highlight color.
CXTPPaintManagerColor | m_crBorderShadow
RGB value for border shadow color.
CXTPPaintManagerColor | m_crBorder3DHilite
RGB value for 3D border highlight color.
CXTPPaintManagerColor | m_crBorder3DShadow
RGB value for 3D border shadow color.
CXTPPaintManagerColor | m_crBack
RGB value for background color.
CXTPPaintManagerColor | m_crText
RGB value for text color.
CXTPPaintManagerColor | m_crTextCheck
RGB value for checked text color.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlTheme
static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Attributes inherited from CXTPControlTheme
XTPControlTheme | m_nTheme
Currently selected theme style index.

Detailed Description

CXTPButtonTheme is a class used to perform Button Theme drawing tasks.

This is the base class for all button themes.

Member Function Documentation

◆ DrawButton()

virtual void DrawButton | ( | CDC * | pDC,
 |  | CXTPButton * | pButton )
 virtual

This member function is called to the button.

Parameters
pDC | A CDC pointer that represents the current device context.
pButton | Pointer to a CXTPButton object.

Reimplemented in CXTPTaskButtonTheme, and CXTPTaskButtonThemeExpando.

◆ DrawButtonBackground()

virtual void DrawButtonBackground | ( | CDC * | pDC,
 |  | CXTPButton * | pButton )
 virtual

This member function is called to draw the background for the button.

Parameters
pDC | A CDC pointer that represents the current device context.
pButton | Pointer to a CXTPButton object.

Reimplemented in CXTPButtonThemeFlat, CXTPButtonThemeOffice2000, CXTPButtonThemeOffice2003, CXTPButtonThemeOffice2013, CXTPButtonThemeOfficeXP, CXTPButtonThemeResource, CXTPButtonThemeUltraFlat, CXTPButtonThemeVisualStudio2012, CXTPCaptionButtonTheme, CXTPCaptionButtonThemeOffice2003, and CXTPCaptionButtonThemeOfficeXP.

◆ DrawButtonText()

void DrawButtonText | ( | CDC * | pDC,
 |  | CXTPButton * | pButton )

This member function is called to draw the text for the button.

Parameters
pDC | A CDC pointer that represents the current device context.
pButton | Pointer to a CXTPButton object.

◆ DrawButtonVisualStyleBackground()

virtual void DrawButtonVisualStyleBackground | ( | CDC * | pDC,
 |  | CXTPButton * | pButton )
 virtual

This member function is called to draw the styled background for the button.

Parameters
pDC | A CDC pointer that represents the current device context.
pButton | Pointer to a CXTPButton object.

◆ DrawCheckBoxMark()

virtual void DrawCheckBoxMark | ( | CDC * | pDC,
 |  | CXTPButton * | pButton )
 virtual

This member function draws the check box mark for the button, if one has been defined.

Parameters
pDC | A CDC pointer that represents the current device context.
pButton | Pointer to a CXTPButton object.

Reimplemented in CXTPButtonThemeOffice2013, CXTPButtonThemeResource, CXTPButtonThemeUltraFlat, and CXTPButtonThemeVisualStudio2012.

◆ DrawFocusRect()

virtual void DrawFocusRect | ( | CDC * | pDC,
 |  | CXTPButton * | pButton )
 virtual

This member function is called to draw the focus rectangle for the button.

Parameters
pDC | A CDC pointer that represents the current device context.
pButton | Pointer to a CXTPButton object.

◆ DrawGroupBox()

virtual void DrawGroupBox | ( | CDC * | pDC,
 |  | CXTPButton * | pButton )
 virtual

This member function draws the group box for the button, if one has been defined.

Parameters
pDC | A CDC pointer that represents the current device context.
pButton | Pointer to a CXTPButton object.

Reimplemented in CXTPButtonThemeOffice2013, and CXTPButtonThemeUltraFlat.

◆ DrawPushButtonDropDown()

virtual void DrawPushButtonDropDown | ( | CDC * | pDC,
 |  | CXTPButton * | pButton )
 virtual

This member function draws the dropdown for the button, if one has been defined.

Parameters
pDC | A CDC pointer that represents the current device context.
pButton | Pointer to a CXTPButton object.

Reimplemented in CXTPButtonThemeOffice2013.

◆ DrawPushButtonIcon()

virtual void DrawPushButtonIcon | ( | CDC * | pDC,
 |  | CXTPButton * | pButton )
 virtual

This member function draws the icon for the button, if one has been defined.

Parameters
pDC | A CDC pointer that represents the current device context.
pButton | Pointer to a CXTPButton object.

Reimplemented in CXTPButtonThemeOffice2013.

◆ DrawPushButtonText()

virtual void DrawPushButtonText | ( | CDC * | pDC,
 |  | CXTPButton * | pButton )
 virtual

This member function is called to draw the text for the button.

Parameters
pDC | A CDC pointer that represents the current device context.
pButton | Pointer to a CXTPButton object.

Reimplemented in CXTPButtonThemeOffice2013.

◆ DrawRadioButtonMark()

virtual void DrawRadioButtonMark | ( | CDC * | pDC,
 |  | CXTPButton * | pButton )
 virtual

This member function draws the radio button mark for the button, if one has been defined.

Parameters
pDC | A CDC pointer that represents the current device context.
pButton | Pointer to a CXTPButton object.

Reimplemented in CXTPButtonThemeOffice2013, CXTPButtonThemeResource, CXTPButtonThemeUltraFlat, and CXTPButtonThemeVisualStudio2012.

◆ GetTextColor()

virtual COLORREF GetTextColor ( CXTPButton * pButton )
virtual

Call this member function to return the color used to draw the button text.

Parameters
pButton Pointer to a CXTPButton object.
Returns
An RGB value that represents the button text color.

Reimplemented in CXTPButtonThemeOffice2013, CXTPButtonThemeVisualStudio2012, CXTPCaptionButtonTheme, CXTPCaptionButtonThemeOffice2003, CXTPCaptionButtonThemeOfficeXP, and CXTPTaskButtonTheme.

◆ RefreshMetrics()

virtual void RefreshMetrics ( CXTPButton * pButton )
virtual

This member function is called by the theme manager to refresh the visual styles used by each component's theme.

Parameters
pButton Pointer to a CXTPButton object.

Reimplemented in CXTPButtonThemeNativeWindows10, CXTPButtonThemeNativeWindows11, CXTPButtonThemeOffice2003, CXTPButtonThemeOffice2013, CXTPButtonThemeOfficeXP, CXTPButtonThemeResource, CXTPButtonThemeUltraFlat, CXTPButtonThemeVisualStudio2012, CXTPButtonThemeVisualStudio2015, CXTPButtonThemeVisualStudio2017, CXTPButtonThemeVisualStudio2019, CXTPButtonThemeVisualStudio2022, and CXTPTaskButtonTheme.

The documentation for this class was generated from the following file:
  • XTPButtonTheme.h


Toolkit Pro: CXTPButtonThemeFlat Class Reference

Public Member Functions | List of all members
CXTPButtonThemeFlat Class Reference

CXTPButtonThemeFlat is a class used to perform Flat Theme drawing tasks. More...

Inheritance diagram for CXTPButtonThemeFlat:
[legend]

Public Member Functions

CXTPButtonThemeFlat ()
Constructs a CXTPButtonThemeFlat object.
void | DrawButtonBackground (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the background for a button.
- Public Member Functions inherited from CXTPButtonTheme
CXTPButtonTheme ()
Constructs a CXTPButtonTheme object.
virtual | ~CXTPButtonTheme ()
Destroys a CXTPButtonTheme object, handles cleanup and deallocation.
virtual void | DrawFocusRect (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the focus rectangle for the button.
virtual void | DrawButton (CDC *pDC, CXTPButton *pButton)
This member function is called to the button.
virtual void | DrawButtonVisualStyleBackground (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the styled background for the button.
virtual void | RefreshMetrics (CXTPButton *pButton)
This member function is called by the theme manager to refresh the visual styles used by each component's theme.
virtual void | DrawPushButtonText (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the text for the button.
virtual void | DrawPushButtonIcon (CDC *pDC, CXTPButton *pButton)
This member function draws the icon for the button, if one has been defined.
virtual void | DrawPushButtonDropDown (CDC *pDC, CXTPButton *pButton)
This member function draws the dropdown for the button, if one has been defined.
virtual COLORREF | GetTextColor (CXTPButton *pButton)
Call this member function to return the color used to draw the button text.
virtual void | DrawCheckBoxMark (CDC *pDC, CXTPButton *pButton)
This member function draws the check box mark for the button, if one has been defined.
virtual void | DrawRadioButtonMark (CDC *pDC, CXTPButton *pButton)
This member function draws the radio button mark for the button, if one has been defined.
void | DrawButtonText (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the text for the button.
virtual void | DrawGroupBox (CDC *pDC, CXTPButton *pButton)
This member function draws the group box for the button, if one has been defined.
- Public Member Functions inherited from CXTPControlTheme
CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme | GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlTheme
static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPButtonTheme
CXTPPaintManagerColor | m_crTextDisabled
RGB value for disabled text color.
CXTPPaintManagerColor | m_crBorderHilite
RGB value for border highlight color.
CXTPPaintManagerColor | m_crBorderShadow
RGB value for border shadow color.
CXTPPaintManagerColor | m_crBorder3DHilite
RGB value for 3D border highlight color.
CXTPPaintManagerColor | m_crBorder3DShadow
RGB value for 3D border shadow color.
CXTPPaintManagerColor | m_crBack
RGB value for background color.
CXTPPaintManagerColor | m_crText
RGB value for text color.
CXTPPaintManagerColor | m_crTextCheck
RGB value for checked text color.
- Protected Attributes inherited from CXTPControlTheme
XTPControlTheme | m_nTheme
Currently selected theme style index.

Detailed Description

CXTPButtonThemeFlat is a class used to perform Flat Theme drawing tasks.

Member Function Documentation

◆ DrawButtonBackground()

void DrawButtonBackground | ( | CDC * | pDC,
 |  | CXTPButton * | pButton )
 virtual

This member function is called to draw the background for a button.

Parameters
pDC | A CDC pointer that represents the current device context.
pButton | Pointer to a CXTPButton object.

Reimplemented from CXTPButtonTheme.

The documentation for this class was generated from the following file:
  • XTPButtonThemeFlat.h


Toolkit Pro: CXTPButtonThemeNativeWindows10 Class Reference

Public Member Functions | List of all members
CXTPButtonThemeNativeWindows10 Class Reference

CXTPButtonThemeNativeWindows10 is a class used to perform Visual Studio 2015 theme drawing tasks. More...

Inheritance diagram for CXTPButtonThemeNativeWindows10:
[legend]

Public Member Functions

CXTPButtonThemeNativeWindows10 ()
Constructs a CXTPButtonThemeNativeWindows10 object.
virtual void | RefreshMetrics (CXTPButton *pButton)
This member function is called by the theme manager to refresh the visual styles used by each component's theme.
- Public Member Functions inherited from CXTPButtonThemeOffice2013
virtual void | DrawButtonBackground (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the background for the button.
virtual void | DrawGroupBox (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the group box for the button.
virtual void | DrawCheckBoxMark (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the check box mark for the button control.
virtual void | DrawRadioButtonMark (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the radio mark for the button control.
virtual COLORREF | GetTextColor (CXTPButton *pButton)
Call this member function to retrieve the color used to draw the button text.
virtual void | DrawPushButtonText (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the text for the button.
virtual void | DrawPushButtonIcon (CDC *pDC, CXTPButton *pButton)
This member function draws the icon for the button, if one has been defined.
virtual void | DrawPushButtonDropDown (CDC *pDC, CXTPButton *pButton)
This member function draws the dropdown for the button, if one has been defined.
- Public Member Functions inherited from CXTPButtonThemeUltraFlat
CXTPButtonThemeUltraFlat ()
Constructs a CXTPButtonThemeUltraFlat object.
- Public Member Functions inherited from CXTPButtonTheme
CXTPButtonTheme ()
Constructs a CXTPButtonTheme object.
virtual | ~CXTPButtonTheme ()
Destroys a CXTPButtonTheme object, handles cleanup and deallocation.
virtual void | DrawFocusRect (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the focus rectangle for the button.
virtual void | DrawButton (CDC *pDC, CXTPButton *pButton)
This member function is called to the button.
virtual void | DrawButtonVisualStyleBackground (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the styled background for the button.
void | DrawButtonText (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the text for the button.
- Public Member Functions inherited from CXTPControlTheme
CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme | GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlTheme
static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPButtonThemeUltraFlat
CXTPPaintManagerColor | m_crBackHilite
RGB value for highlighted background color.
CXTPPaintManagerColor | m_crBackPushed
RGB value for pushed background color.
CXTPPaintManagerColor | m_crBackChecked
RGB value for when the control is checked.
CXTPPaintManagerColor | m_crBorderPushed
RGB value for border pushed color.
CXTPPaintManagerColor | m_crTextPushed
RGB value for pushed text color.
CXTPPaintManagerColor | m_crTextHilite
RGB value for highlighted text color.
CXTPPaintManagerColor | m_crCheckMark
RGB value for check mark color.
- Public Attributes inherited from CXTPButtonTheme
CXTPPaintManagerColor | m_crTextDisabled
RGB value for disabled text color.
CXTPPaintManagerColor | m_crBorderHilite
RGB value for border highlight color.
CXTPPaintManagerColor | m_crBorderShadow
RGB value for border shadow color.
CXTPPaintManagerColor | m_crBorder3DHilite
RGB value for 3D border highlight color.
CXTPPaintManagerColor | m_crBorder3DShadow
RGB value for 3D border shadow color.
CXTPPaintManagerColor | m_crBack
RGB value for background color.
CXTPPaintManagerColor | m_crText
RGB value for text color.
CXTPPaintManagerColor | m_crTextCheck
RGB value for checked text color.
- Protected Attributes inherited from CXTPButtonThemeOffice2013
CXTPPaintManagerColor | m_crBorder
An RGB value representing border color.
CXTPPaintManagerColor | m_crBorderDefault
An RGB value representing default border color.
CXTPPaintManagerColor | m_crBorderDisabled
An RGB value representing disabled border color.
CXTPPaintManagerColor | m_crBackDisabled
An RGB value representing disabled background color.
CXTPPaintManagerColor | m_crMark
An RGB value representing checkmark color.
CXTPPaintManagerColor | m_crMarkHilite
An RGB value representing checkmark hilite color.
CXTPPaintManagerColor | m_crMarkPushed
An RGB value representing checkmark pushed color.
CXTPPaintManagerColor | m_crMarkDisabled
An RGB value representing checkmark disabled color.
- Protected Attributes inherited from CXTPControlTheme
XTPControlTheme | m_nTheme
Currently selected theme style index.

Detailed Description

CXTPButtonThemeNativeWindows10 is a class used to perform Visual Studio 2015 theme drawing tasks.

Member Function Documentation

◆ RefreshMetrics()

virtual void RefreshMetrics ( CXTPButton * pButton )
virtual

This member function is called by the theme manager to refresh the visual styles used by each component's theme.

Parameters
pButton Pointer to a CXTPButton object.

Reimplemented from CXTPButtonThemeOffice2013.

The documentation for this class was generated from the following file:
  • XTPButtonThemeNativeWindows10.h


Toolkit Pro: CXTPButtonThemeNativeWindows11 Class Reference

Public Member Functions | List of all members
CXTPButtonThemeNativeWindows11 Class Reference

CXTPButtonThemeNativeWindows11 is a class used to perform Visual Studio 2015 theme drawing tasks. More...

Inheritance diagram for CXTPButtonThemeNativeWindows11:
[legend]

Public Member Functions

CXTPButtonThemeNativeWindows11 ()
Constructs a CXTPButtonThemeNativeWindows11 object.
virtual void | RefreshMetrics (CXTPButton *pButton)
This member function is called by the theme manager to refresh the visual styles used by each component's theme.
- Public Member Functions inherited from CXTPButtonThemeOffice2013
virtual void | DrawButtonBackground (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the background for the button.
virtual void | DrawGroupBox (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the group box for the button.
virtual void | DrawCheckBoxMark (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the check box mark for the button control.
virtual void | DrawRadioButtonMark (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the radio mark for the button control.
virtual COLORREF | GetTextColor (CXTPButton *pButton)
Call this member function to retrieve the color used to draw the button text.
virtual void | DrawPushButtonText (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the text for the button.
virtual void | DrawPushButtonIcon (CDC *pDC, CXTPButton *pButton)
This member function draws the icon for the button, if one has been defined.
virtual void | DrawPushButtonDropDown (CDC *pDC, CXTPButton *pButton)
This member function draws the dropdown for the button, if one has been defined.
- Public Member Functions inherited from CXTPButtonThemeUltraFlat
CXTPButtonThemeUltraFlat ()
Constructs a CXTPButtonThemeUltraFlat object.
- Public Member Functions inherited from CXTPButtonTheme
CXTPButtonTheme ()
Constructs a CXTPButtonTheme object.
virtual | ~CXTPButtonTheme ()
Destroys a CXTPButtonTheme object, handles cleanup and deallocation.
virtual void | DrawFocusRect (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the focus rectangle for the button.
virtual void | DrawButton (CDC *pDC, CXTPButton *pButton)
This member function is called to the button.
virtual void | DrawButtonVisualStyleBackground (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the styled background for the button.
void | DrawButtonText (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the text for the button.
- Public Member Functions inherited from CXTPControlTheme
CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme | GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlTheme
static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPButtonThemeUltraFlat
CXTPPaintManagerColor | m_crBackHilite
RGB value for highlighted background color.
CXTPPaintManagerColor | m_crBackPushed
RGB value for pushed background color.
CXTPPaintManagerColor | m_crBackChecked
RGB value for when the control is checked.
CXTPPaintManagerColor | m_crBorderPushed
RGB value for border pushed color.
CXTPPaintManagerColor | m_crTextPushed
RGB value for pushed text color.
CXTPPaintManagerColor | m_crTextHilite
RGB value for highlighted text color.
CXTPPaintManagerColor | m_crCheckMark
RGB value for check mark color.
- Public Attributes inherited from CXTPButtonTheme
CXTPPaintManagerColor | m_crTextDisabled
RGB value for disabled text color.
CXTPPaintManagerColor | m_crBorderHilite
RGB value for border highlight color.
CXTPPaintManagerColor | m_crBorderShadow
RGB value for border shadow color.
CXTPPaintManagerColor | m_crBorder3DHilite
RGB value for 3D border highlight color.
CXTPPaintManagerColor | m_crBorder3DShadow
RGB value for 3D border shadow color.
CXTPPaintManagerColor | m_crBack
RGB value for background color.
CXTPPaintManagerColor | m_crText
RGB value for text color.
CXTPPaintManagerColor | m_crTextCheck
RGB value for checked text color.
- Protected Attributes inherited from CXTPButtonThemeOffice2013
CXTPPaintManagerColor | m_crBorder
An RGB value representing border color.
CXTPPaintManagerColor | m_crBorderDefault
An RGB value representing default border color.
CXTPPaintManagerColor | m_crBorderDisabled
An RGB value representing disabled border color.
CXTPPaintManagerColor | m_crBackDisabled
An RGB value representing disabled background color.
CXTPPaintManagerColor | m_crMark
An RGB value representing checkmark color.
CXTPPaintManagerColor | m_crMarkHilite
An RGB value representing checkmark hilite color.
CXTPPaintManagerColor | m_crMarkPushed
An RGB value representing checkmark pushed color.
CXTPPaintManagerColor | m_crMarkDisabled
An RGB value representing checkmark disabled color.
- Protected Attributes inherited from CXTPControlTheme
XTPControlTheme | m_nTheme
Currently selected theme style index.

Detailed Description

CXTPButtonThemeNativeWindows11 is a class used to perform Visual Studio 2015 theme drawing tasks.

Member Function Documentation

◆ RefreshMetrics()

virtual void RefreshMetrics ( CXTPButton * pButton )
virtual

This member function is called by the theme manager to refresh the visual styles used by each component's theme.

Parameters
pButton Pointer to a CXTPButton object.

Reimplemented from CXTPButtonThemeOffice2013.

The documentation for this class was generated from the following file:
  • XTPButtonThemeNativeWindows11.h


Toolkit Pro: CXTPButtonThemeOffice2000 Class Reference

Public Member Functions | List of all members
CXTPButtonThemeOffice2000 Class Reference

CXTPButtonThemeOffice2000 is a class used to perform Office 2000 Theme drawing tasks. More...

Inheritance diagram for CXTPButtonThemeOffice2000:
[legend]

Public Member Functions

CXTPButtonThemeOffice2000 ()
Constructs a CXTPButtonThemeOffice2000 object.
void | DrawButtonBackground (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the background for the button.
- Public Member Functions inherited from CXTPButtonThemeUltraFlat
CXTPButtonThemeUltraFlat ()
Constructs a CXTPButtonThemeUltraFlat object.
virtual void | RefreshMetrics (CXTPButton *pButton)
This member function is called by the theme manager to refresh the visual styles used by each component's theme.
virtual void | DrawGroupBox (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the group box for the button.
virtual void | DrawCheckBoxMark (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the check box mark for the button control.
virtual void | DrawRadioButtonMark (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the radio mark for the button control.
- Public Member Functions inherited from CXTPButtonTheme
CXTPButtonTheme ()
Constructs a CXTPButtonTheme object.
virtual | ~CXTPButtonTheme ()
Destroys a CXTPButtonTheme object, handles cleanup and deallocation.
virtual void | DrawFocusRect (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the focus rectangle for the button.
virtual void | DrawButton (CDC *pDC, CXTPButton *pButton)
This member function is called to the button.
virtual void | DrawButtonVisualStyleBackground (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the styled background for the button.
virtual void | DrawPushButtonText (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the text for the button.
virtual void | DrawPushButtonIcon (CDC *pDC, CXTPButton *pButton)
This member function draws the icon for the button, if one has been defined.
virtual void | DrawPushButtonDropDown (CDC *pDC, CXTPButton *pButton)
This member function draws the dropdown for the button, if one has been defined.
virtual COLORREF | GetTextColor (CXTPButton *pButton)
Call this member function to return the color used to draw the button text.
void | DrawButtonText (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the text for the button.
- Public Member Functions inherited from CXTPControlTheme
CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme | GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlTheme
static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPButtonThemeUltraFlat
CXTPPaintManagerColor | m_crBackHilite
RGB value for highlighted background color.
CXTPPaintManagerColor | m_crBackPushed
RGB value for pushed background color.
CXTPPaintManagerColor | m_crBackChecked
RGB value for when the control is checked.
CXTPPaintManagerColor | m_crBorderPushed
RGB value for border pushed color.
CXTPPaintManagerColor | m_crTextPushed
RGB value for pushed text color.
CXTPPaintManagerColor | m_crTextHilite
RGB value for highlighted text color.
CXTPPaintManagerColor | m_crCheckMark
RGB value for check mark color.
- Public Attributes inherited from CXTPButtonTheme
CXTPPaintManagerColor | m_crTextDisabled
RGB value for disabled text color.
CXTPPaintManagerColor | m_crBorderHilite
RGB value for border highlight color.
CXTPPaintManagerColor | m_crBorderShadow
RGB value for border shadow color.
CXTPPaintManagerColor | m_crBorder3DHilite
RGB value for 3D border highlight color.
CXTPPaintManagerColor | m_crBorder3DShadow
RGB value for 3D border shadow color.
CXTPPaintManagerColor | m_crBack
RGB value for background color.
CXTPPaintManagerColor | m_crText
RGB value for text color.
CXTPPaintManagerColor | m_crTextCheck
RGB value for checked text color.
- Protected Attributes inherited from CXTPControlTheme
XTPControlTheme | m_nTheme
Currently selected theme style index.

Detailed Description

CXTPButtonThemeOffice2000 is a class used to perform Office 2000 Theme drawing tasks.

Member Function Documentation

◆ DrawButtonBackground()

void DrawButtonBackground | ( | CDC * | pDC,
 |  | CXTPButton * | pButton )
 virtual

This member function is called to draw the background for the button.

Parameters
pDC | A CDC pointer that represents the current device context.
pButton | Pointer to a CXTPButton object.

Reimplemented from CXTPButtonThemeUltraFlat.

The documentation for this class was generated from the following file:
  • XTPButtonThemeOffice2000.h


Toolkit Pro: CXTPButtonThemeOffice2003 Class Reference

Public Member Functions | List of all members
CXTPButtonThemeOffice2003 Class Reference

CXTPButtonThemeOffice2003 is a class used to perform Office 2003 Theme drawing tasks. More...

Inheritance diagram for CXTPButtonThemeOffice2003:
[legend]

Public Member Functions

CXTPButtonThemeOffice2003 ()
Constructs a CXTPButtonThemeOffice2003 object.
void | DrawButtonBackground (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the background for the button.
void | RefreshMetrics (CXTPButton *pButton)
This member function is called by the theme manager to refresh the visual styles used by each component's theme.
- Public Member Functions inherited from CXTPButtonThemeOfficeXP
CXTPButtonThemeOfficeXP ()
Constructs a CXTPButtonThemeOfficeXP object.
void | DrawButtonBackground (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the background for the button.
void | RefreshMetrics (CXTPButton *pButton)
This member function is called by the theme manager to refresh the visual styles used by each component's theme.
- Public Member Functions inherited from CXTPButtonThemeUltraFlat
CXTPButtonThemeUltraFlat ()
Constructs a CXTPButtonThemeUltraFlat object.
virtual void | DrawGroupBox (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the group box for the button.
virtual void | DrawCheckBoxMark (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the check box mark for the button control.
virtual void | DrawRadioButtonMark (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the radio mark for the button control.
- Public Member Functions inherited from CXTPButtonTheme
CXTPButtonTheme ()
Constructs a CXTPButtonTheme object.
virtual | ~CXTPButtonTheme ()
Destroys a CXTPButtonTheme object, handles cleanup and deallocation.
virtual void | DrawFocusRect (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the focus rectangle for the button.
virtual void | DrawButton (CDC *pDC, CXTPButton *pButton)
This member function is called to the button.
virtual void | DrawButtonVisualStyleBackground (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the styled background for the button.
virtual void | DrawPushButtonText (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the text for the button.
virtual void | DrawPushButtonIcon (CDC *pDC, CXTPButton *pButton)
This member function draws the icon for the button, if one has been defined.
virtual void | DrawPushButtonDropDown (CDC *pDC, CXTPButton *pButton)
This member function draws the dropdown for the button, if one has been defined.
virtual COLORREF | GetTextColor (CXTPButton *pButton)
Call this member function to return the color used to draw the button text.
void | DrawButtonText (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the text for the button.
- Public Member Functions inherited from CXTPControlTheme
CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme | GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlTheme
static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPButtonThemeUltraFlat
CXTPPaintManagerColor | m_crBackHilite
RGB value for highlighted background color.
CXTPPaintManagerColor | m_crBackPushed
RGB value for pushed background color.
CXTPPaintManagerColor | m_crBackChecked
RGB value for when the control is checked.
CXTPPaintManagerColor | m_crBorderPushed
RGB value for border pushed color.
CXTPPaintManagerColor | m_crTextPushed
RGB value for pushed text color.
CXTPPaintManagerColor | m_crTextHilite
RGB value for highlighted text color.
CXTPPaintManagerColor | m_crCheckMark
RGB value for check mark color.
- Public Attributes inherited from CXTPButtonTheme
CXTPPaintManagerColor | m_crTextDisabled
RGB value for disabled text color.
CXTPPaintManagerColor | m_crBorderHilite
RGB value for border highlight color.
CXTPPaintManagerColor | m_crBorderShadow
RGB value for border shadow color.
CXTPPaintManagerColor | m_crBorder3DHilite
RGB value for 3D border highlight color.
CXTPPaintManagerColor | m_crBorder3DShadow
RGB value for 3D border shadow color.
CXTPPaintManagerColor | m_crBack
RGB value for background color.
CXTPPaintManagerColor | m_crText
RGB value for text color.
CXTPPaintManagerColor | m_crTextCheck
RGB value for checked text color.
- Protected Attributes inherited from CXTPControlTheme
XTPControlTheme | m_nTheme
Currently selected theme style index.

Detailed Description

CXTPButtonThemeOffice2003 is a class used to perform Office 2003 Theme drawing tasks.

Member Function Documentation

◆ DrawButtonBackground()

void DrawButtonBackground | ( | CDC * | pDC,
 |  | CXTPButton * | pButton )
 virtual

This member function is called to draw the background for the button.

Parameters
pDC | A CDC pointer that represents the current device context.
pButton | Pointer to a CXTPButton object.

Reimplemented from CXTPButtonThemeUltraFlat.

Reimplemented in CXTPCaptionButtonThemeOffice2003.

◆ RefreshMetrics()

void RefreshMetrics ( CXTPButton * pButton )
virtual

This member function is called by the theme manager to refresh the visual styles used by each component's theme.

Parameters
pButton Pointer to a CXTPButton object.

Reimplemented from CXTPButtonThemeUltraFlat.

The documentation for this class was generated from the following file:
  • XTPButtonThemeOffice2003.h


Toolkit Pro: CXTPButtonThemeOffice2013 Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPButtonThemeOffice2013 Class Reference

CXTPButtonThemeOffice2013 is a class used to perform Office 2013 theme drawing tasks. More...

Inheritance diagram for CXTPButtonThemeOffice2013:
[legend]

Public Member Functions

virtual void | DrawButtonBackground (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the background for the button.
virtual void | DrawGroupBox (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the group box for the button.
virtual void | DrawCheckBoxMark (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the check box mark for the button control.
virtual void | DrawRadioButtonMark (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the radio mark for the button control.
virtual void | RefreshMetrics (CXTPButton *pButton)
This member function is called by the theme manager to refresh the visual styles used by each component's theme.
virtual COLORREF | GetTextColor (CXTPButton *pButton)
Call this member function to retrieve the color used to draw the button text.
virtual void | DrawPushButtonText (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the text for the button.
virtual void | DrawPushButtonIcon (CDC *pDC, CXTPButton *pButton)
This member function draws the icon for the button, if one has been defined.
virtual void | DrawPushButtonDropDown (CDC *pDC, CXTPButton *pButton)
This member function draws the dropdown for the button, if one has been defined.
- Public Member Functions inherited from CXTPButtonThemeUltraFlat
CXTPButtonThemeUltraFlat ()
Constructs a CXTPButtonThemeUltraFlat object.
- Public Member Functions inherited from CXTPButtonTheme
CXTPButtonTheme ()
Constructs a CXTPButtonTheme object.
virtual | ~CXTPButtonTheme ()
Destroys a CXTPButtonTheme object, handles cleanup and deallocation.
virtual void | DrawFocusRect (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the focus rectangle for the button.
virtual void | DrawButton (CDC *pDC, CXTPButton *pButton)
This member function is called to the button.
virtual void | DrawButtonVisualStyleBackground (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the styled background for the button.
void | DrawButtonText (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the text for the button.
- Public Member Functions inherited from CXTPControlTheme
CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme | GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Attributes

CXTPPaintManagerColor | m_crBorder
An RGB value representing border color.
CXTPPaintManagerColor | m_crBorderDefault
An RGB value representing default border color.
CXTPPaintManagerColor | m_crBorderDisabled
An RGB value representing disabled border color.
CXTPPaintManagerColor | m_crBackDisabled
An RGB value representing disabled background color.
CXTPPaintManagerColor | m_crMark
An RGB value representing checkmark color.
CXTPPaintManagerColor | m_crMarkHilite
An RGB value representing checkmark hilite color.
CXTPPaintManagerColor | m_crMarkPushed
An RGB value representing checkmark pushed color.
CXTPPaintManagerColor | m_crMarkDisabled
An RGB value representing checkmark disabled color.
- Protected Attributes inherited from CXTPControlTheme
XTPControlTheme | m_nTheme
Currently selected theme style index.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlTheme
static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPButtonThemeUltraFlat
CXTPPaintManagerColor | m_crBackHilite
RGB value for highlighted background color.
CXTPPaintManagerColor | m_crBackPushed
RGB value for pushed background color.
CXTPPaintManagerColor | m_crBackChecked
RGB value for when the control is checked.
CXTPPaintManagerColor | m_crBorderPushed
RGB value for border pushed color.
CXTPPaintManagerColor | m_crTextPushed
RGB value for pushed text color.
CXTPPaintManagerColor | m_crTextHilite
RGB value for highlighted text color.
CXTPPaintManagerColor | m_crCheckMark
RGB value for check mark color.
- Public Attributes inherited from CXTPButtonTheme
CXTPPaintManagerColor | m_crTextDisabled
RGB value for disabled text color.
CXTPPaintManagerColor | m_crBorderHilite
RGB value for border highlight color.
CXTPPaintManagerColor | m_crBorderShadow
RGB value for border shadow color.
CXTPPaintManagerColor | m_crBorder3DHilite
RGB value for 3D border highlight color.
CXTPPaintManagerColor | m_crBorder3DShadow
RGB value for 3D border shadow color.
CXTPPaintManagerColor | m_crBack
RGB value for background color.
CXTPPaintManagerColor | m_crText
RGB value for text color.
CXTPPaintManagerColor | m_crTextCheck
RGB value for checked text color.

Detailed Description

CXTPButtonThemeOffice2013 is a class used to perform Office 2013 theme drawing tasks.

Member Function Documentation

◆ DrawButtonBackground()

virtual void DrawButtonBackground | ( | CDC * | pDC,
 |  | CXTPButton * | pButton )
 virtual

This member function is called to draw the background for the button.

Parameters
pDC | A CDC pointer that represents the current device context.
pButton | Pointer to a CXTPButton object.

Reimplemented from CXTPButtonThemeUltraFlat.

Reimplemented in CXTPButtonThemeVisualStudio2012.

◆ DrawCheckBoxMark()

virtual void DrawCheckBoxMark | ( | CDC * | pDC,
 |  | CXTPButton * | pButton )
 virtual

This member function is called to draw the check box mark for the button control.

Parameters
pDC | Pointer to a valid device context.
pButton | Pointer to the CXTPButton to draw the check box for.

Reimplemented from CXTPButtonThemeUltraFlat.

Reimplemented in CXTPButtonThemeVisualStudio2012.

◆ DrawGroupBox()

virtual void DrawGroupBox | ( | CDC * | pDC,
 |  | CXTPButton * | pButton )
 virtual

This member function is called to draw the group box for the button.

Parameters
pDC | A CDC pointer that represents the current device context.
pButton | Pointer to a CXTPButton object.

Reimplemented from CXTPButtonThemeUltraFlat.

◆ DrawPushButtonDropDown()

virtual void DrawPushButtonDropDown | ( | CDC * | pDC,
 |  | CXTPButton * | pButton )
 virtual

This member function draws the dropdown for the button, if one has been defined.

Parameters
pDC | A CDC pointer that represents the current device context.
pButton | Pointer to a CXTPButton object.

Reimplemented from CXTPButtonTheme.

◆ DrawPushButtonIcon()

virtual void DrawPushButtonIcon | ( | CDC * | pDC,
 |  | CXTPButton * | pButton )
 virtual

This member function draws the icon for the button, if one has been defined.

Parameters
pDC | A CDC pointer that represents the current device context.
pButton | Pointer to a CXTPButton object.

Reimplemented from CXTPButtonTheme.

◆ DrawPushButtonText()

virtual void DrawPushButtonText | ( | CDC * | pDC,
 |  | CXTPButton * | pButton )
 virtual

This member function is called to draw the text for the button.

Parameters
pDC | A CDC pointer that represents the current device context.
pButton | Pointer to a CXTPButton object.

Reimplemented from CXTPButtonTheme.

◆ DrawRadioButtonMark()

virtual void DrawRadioButtonMark | ( | CDC * | pDC,
 |  | CXTPButton * | pButton )
 virtual

This member function is called to draw the radio mark for the button control.

Parameters
pDC | Pointer to a valid device context.
pButton | Pointer to the CXTPButton to draw the radio mark for.

Reimplemented from CXTPButtonThemeUltraFlat.

Reimplemented in CXTPButtonThemeVisualStudio2012.

◆ GetTextColor()

virtual COLORREF GetTextColor ( CXTPButton * pButton )
virtual

Call this member function to retrieve the color used to draw the button text.

Parameters
pButton Pointer to a CXTPButton object.
Returns
An RGB value that represents the button text color.

Reimplemented from CXTPButtonTheme.

Reimplemented in CXTPButtonThemeVisualStudio2012.

◆ RefreshMetrics()

virtual void RefreshMetrics ( CXTPButton * pButton )
virtual

This member function is called by the theme manager to refresh the visual styles used by each component's theme.

Parameters
pButton Pointer to a CXTPButton object.

Reimplemented from CXTPButtonThemeUltraFlat.

Reimplemented in CXTPButtonThemeNativeWindows10, CXTPButtonThemeNativeWindows11, CXTPButtonThemeVisualStudio2012, CXTPButtonThemeVisualStudio2015, CXTPButtonThemeVisualStudio2017, CXTPButtonThemeVisualStudio2019, and CXTPButtonThemeVisualStudio2022.

The documentation for this class was generated from the following file:
  • XTPButtonThemeOffice2013.h


Toolkit Pro: CXTPButtonThemeOfficeXP Class Reference

Public Member Functions | List of all members
CXTPButtonThemeOfficeXP Class Reference

CXTPButtonThemeOfficeXP is a class used to perform Office XP Theme drawing tasks. More...

Inheritance diagram for CXTPButtonThemeOfficeXP:
[legend]

Public Member Functions

CXTPButtonThemeOfficeXP ()
Constructs a CXTPButtonThemeOfficeXP object.
void | DrawButtonBackground (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the background for the button.
void | RefreshMetrics (CXTPButton *pButton)
This member function is called by the theme manager to refresh the visual styles used by each component's theme.
- Public Member Functions inherited from CXTPButtonThemeUltraFlat
CXTPButtonThemeUltraFlat ()
Constructs a CXTPButtonThemeUltraFlat object.
virtual void | DrawGroupBox (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the group box for the button.
virtual void | DrawCheckBoxMark (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the check box mark for the button control.
virtual void | DrawRadioButtonMark (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the radio mark for the button control.
- Public Member Functions inherited from CXTPButtonTheme
CXTPButtonTheme ()
Constructs a CXTPButtonTheme object.
virtual | ~CXTPButtonTheme ()
Destroys a CXTPButtonTheme object, handles cleanup and deallocation.
virtual void | DrawFocusRect (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the focus rectangle for the button.
virtual void | DrawButton (CDC *pDC, CXTPButton *pButton)
This member function is called to the button.
virtual void | DrawButtonVisualStyleBackground (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the styled background for the button.
virtual void | DrawPushButtonText (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the text for the button.
virtual void | DrawPushButtonIcon (CDC *pDC, CXTPButton *pButton)
This member function draws the icon for the button, if one has been defined.
virtual void | DrawPushButtonDropDown (CDC *pDC, CXTPButton *pButton)
This member function draws the dropdown for the button, if one has been defined.
virtual COLORREF | GetTextColor (CXTPButton *pButton)
Call this member function to return the color used to draw the button text.
void | DrawButtonText (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the text for the button.
- Public Member Functions inherited from CXTPControlTheme
CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme | GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlTheme
static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPButtonThemeUltraFlat
CXTPPaintManagerColor | m_crBackHilite
RGB value for highlighted background color.
CXTPPaintManagerColor | m_crBackPushed
RGB value for pushed background color.
CXTPPaintManagerColor | m_crBackChecked
RGB value for when the control is checked.
CXTPPaintManagerColor | m_crBorderPushed
RGB value for border pushed color.
CXTPPaintManagerColor | m_crTextPushed
RGB value for pushed text color.
CXTPPaintManagerColor | m_crTextHilite
RGB value for highlighted text color.
CXTPPaintManagerColor | m_crCheckMark
RGB value for check mark color.
- Public Attributes inherited from CXTPButtonTheme
CXTPPaintManagerColor | m_crTextDisabled
RGB value for disabled text color.
CXTPPaintManagerColor | m_crBorderHilite
RGB value for border highlight color.
CXTPPaintManagerColor | m_crBorderShadow
RGB value for border shadow color.
CXTPPaintManagerColor | m_crBorder3DHilite
RGB value for 3D border highlight color.
CXTPPaintManagerColor | m_crBorder3DShadow
RGB value for 3D border shadow color.
CXTPPaintManagerColor | m_crBack
RGB value for background color.
CXTPPaintManagerColor | m_crText
RGB value for text color.
CXTPPaintManagerColor | m_crTextCheck
RGB value for checked text color.
- Protected Attributes inherited from CXTPControlTheme
XTPControlTheme | m_nTheme
Currently selected theme style index.

Detailed Description

CXTPButtonThemeOfficeXP is a class used to perform Office XP Theme drawing tasks.

Member Function Documentation

◆ DrawButtonBackground()

void DrawButtonBackground | ( | CDC * | pDC,
 |  | CXTPButton * | pButton )
 virtual

This member function is called to draw the background for the button.

Parameters
pDC | A CDC pointer that represents the current device context.
pButton | Pointer to a CXTPButton object.

Reimplemented from CXTPButtonThemeUltraFlat.

Reimplemented in CXTPCaptionButtonThemeOffice2003, and CXTPCaptionButtonThemeOfficeXP.

◆ RefreshMetrics()

void RefreshMetrics ( CXTPButton * pButton )
virtual

This member function is called by the theme manager to refresh the visual styles used by each component's theme.

Parameters
pButton Pointer to a CXTPButton object.

Reimplemented from CXTPButtonThemeUltraFlat.

The documentation for this class was generated from the following file:
  • XTPButtonThemeOfficeXP.h


Toolkit Pro: CXTPButtonThemeResource Class Reference

Public Member Functions | List of all members
CXTPButtonThemeResource Class Reference

CXTPButtonThemeResource is a class used to perform Office 2007 Theme drawing tasks. More...

Inheritance diagram for CXTPButtonThemeResource:
[legend]

Public Member Functions

CXTPButtonThemeResource ()
Constructs a CXTPButtonThemeResource object.
virtual void | DrawButtonBackground (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the background for the button.
virtual void | DrawCheckBoxMark (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the check box mark for the button control.
virtual void | DrawRadioButtonMark (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the radio mark for the button control.
virtual void | RefreshMetrics (CXTPButton *pButton)
This member function is called by the theme manager to refresh the visual styles used by each component's theme.
- Public Member Functions inherited from CXTPButtonThemeUltraFlat
CXTPButtonThemeUltraFlat ()
Constructs a CXTPButtonThemeUltraFlat object.
virtual void | DrawGroupBox (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the group box for the button.
- Public Member Functions inherited from CXTPButtonTheme
CXTPButtonTheme ()
Constructs a CXTPButtonTheme object.
virtual | ~CXTPButtonTheme ()
Destroys a CXTPButtonTheme object, handles cleanup and deallocation.
virtual void | DrawFocusRect (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the focus rectangle for the button.
virtual void | DrawButton (CDC *pDC, CXTPButton *pButton)
This member function is called to the button.
virtual void | DrawButtonVisualStyleBackground (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the styled background for the button.
virtual void | DrawPushButtonText (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the text for the button.
virtual void | DrawPushButtonIcon (CDC *pDC, CXTPButton *pButton)
This member function draws the icon for the button, if one has been defined.
virtual void | DrawPushButtonDropDown (CDC *pDC, CXTPButton *pButton)
This member function draws the dropdown for the button, if one has been defined.
virtual COLORREF | GetTextColor (CXTPButton *pButton)
Call this member function to return the color used to draw the button text.
void | DrawButtonText (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the text for the button.
- Public Member Functions inherited from CXTPControlTheme
CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme | GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlTheme
static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPButtonThemeUltraFlat
CXTPPaintManagerColor | m_crBackHilite
RGB value for highlighted background color.
CXTPPaintManagerColor | m_crBackPushed
RGB value for pushed background color.
CXTPPaintManagerColor | m_crBackChecked
RGB value for when the control is checked.
CXTPPaintManagerColor | m_crBorderPushed
RGB value for border pushed color.
CXTPPaintManagerColor | m_crTextPushed
RGB value for pushed text color.
CXTPPaintManagerColor | m_crTextHilite
RGB value for highlighted text color.
CXTPPaintManagerColor | m_crCheckMark
RGB value for check mark color.
- Public Attributes inherited from CXTPButtonTheme
CXTPPaintManagerColor | m_crTextDisabled
RGB value for disabled text color.
CXTPPaintManagerColor | m_crBorderHilite
RGB value for border highlight color.
CXTPPaintManagerColor | m_crBorderShadow
RGB value for border shadow color.
CXTPPaintManagerColor | m_crBorder3DHilite
RGB value for 3D border highlight color.
CXTPPaintManagerColor | m_crBorder3DShadow
RGB value for 3D border shadow color.
CXTPPaintManagerColor | m_crBack
RGB value for background color.
CXTPPaintManagerColor | m_crText
RGB value for text color.
CXTPPaintManagerColor | m_crTextCheck
RGB value for checked text color.
- Protected Attributes inherited from CXTPControlTheme
XTPControlTheme | m_nTheme
Currently selected theme style index.

Detailed Description

CXTPButtonThemeResource is a class used to perform Office 2007 Theme drawing tasks.

Member Function Documentation

◆ DrawButtonBackground()

virtual void DrawButtonBackground | ( | CDC * | pDC,
 |  | CXTPButton * | pButton )
 virtual

This member function is called to draw the background for the button.

Parameters
pDC | A CDC pointer that represents the current device context.
pButton | Pointer to a CXTPButton object.

Reimplemented from CXTPButtonThemeUltraFlat.

◆ DrawCheckBoxMark()

virtual void DrawCheckBoxMark | ( | CDC * | pDC,
 |  | CXTPButton * | pButton )
 virtual

This member function is called to draw the check box mark for the button control.

Parameters
pDC | Pointer to a valid device context.
pButton | Pointer to the CXTPButton to draw the check box for.

Reimplemented from CXTPButtonThemeUltraFlat.

◆ DrawRadioButtonMark()

virtual void DrawRadioButtonMark | ( | CDC * | pDC,
 |  | CXTPButton * | pButton )
 virtual

This member function is called to draw the radio mark for the button control.

Parameters
pDC | Pointer to a valid device context.
pButton | Pointer to the CXTPButton to draw the radio mark for.

Reimplemented from CXTPButtonThemeUltraFlat.

◆ RefreshMetrics()

virtual void RefreshMetrics ( CXTPButton * pButton )
virtual

This member function is called by the theme manager to refresh the visual styles used by each component's theme.

Parameters
pButton Pointer to a CXTPButton object.

Reimplemented from CXTPButtonThemeUltraFlat.

The documentation for this class was generated from the following file:
  • XTPButtonThemeResource.h


Toolkit Pro: CXTPButtonThemeUltraFlat Class Reference

Public Member Functions | Public Attributes | List of all members
CXTPButtonThemeUltraFlat Class Reference

CXTPButtonThemeUltraFlat is a class used to perform Ultra Flat Theme drawing tasks. More...

Inheritance diagram for CXTPButtonThemeUltraFlat:
[legend]

Public Member Functions

CXTPButtonThemeUltraFlat ()
Constructs a CXTPButtonThemeUltraFlat object.
virtual void | RefreshMetrics (CXTPButton *pButton)
This member function is called by the theme manager to refresh the visual styles used by each component's theme.
virtual void | DrawButtonBackground (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the background for the button.
virtual void | DrawGroupBox (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the group box for the button.
virtual void | DrawCheckBoxMark (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the check box mark for the button control.
virtual void | DrawRadioButtonMark (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the radio mark for the button control.
- Public Member Functions inherited from CXTPButtonTheme
CXTPButtonTheme ()
Constructs a CXTPButtonTheme object.
virtual | ~CXTPButtonTheme ()
Destroys a CXTPButtonTheme object, handles cleanup and deallocation.
virtual void | DrawFocusRect (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the focus rectangle for the button.
virtual void | DrawButton (CDC *pDC, CXTPButton *pButton)
This member function is called to the button.
virtual void | DrawButtonVisualStyleBackground (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the styled background for the button.
virtual void | DrawPushButtonText (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the text for the button.
virtual void | DrawPushButtonIcon (CDC *pDC, CXTPButton *pButton)
This member function draws the icon for the button, if one has been defined.
virtual void | DrawPushButtonDropDown (CDC *pDC, CXTPButton *pButton)
This member function draws the dropdown for the button, if one has been defined.
virtual COLORREF | GetTextColor (CXTPButton *pButton)
Call this member function to return the color used to draw the button text.
void | DrawButtonText (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the text for the button.
- Public Member Functions inherited from CXTPControlTheme
CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme | GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Public Attributes

CXTPPaintManagerColor | m_crBackHilite
RGB value for highlighted background color.
CXTPPaintManagerColor | m_crBackPushed
RGB value for pushed background color.
CXTPPaintManagerColor | m_crBackChecked
RGB value for when the control is checked.
CXTPPaintManagerColor | m_crBorderPushed
RGB value for border pushed color.
CXTPPaintManagerColor | m_crTextPushed
RGB value for pushed text color.
CXTPPaintManagerColor | m_crTextHilite
RGB value for highlighted text color.
CXTPPaintManagerColor | m_crCheckMark
RGB value for check mark color.
- Public Attributes inherited from CXTPButtonTheme
CXTPPaintManagerColor | m_crTextDisabled
RGB value for disabled text color.
CXTPPaintManagerColor | m_crBorderHilite
RGB value for border highlight color.
CXTPPaintManagerColor | m_crBorderShadow
RGB value for border shadow color.
CXTPPaintManagerColor | m_crBorder3DHilite
RGB value for 3D border highlight color.
CXTPPaintManagerColor | m_crBorder3DShadow
RGB value for 3D border shadow color.
CXTPPaintManagerColor | m_crBack
RGB value for background color.
CXTPPaintManagerColor | m_crText
RGB value for text color.
CXTPPaintManagerColor | m_crTextCheck
RGB value for checked text color.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlTheme
static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Attributes inherited from CXTPControlTheme
XTPControlTheme | m_nTheme
Currently selected theme style index.

Detailed Description

CXTPButtonThemeUltraFlat is a class used to perform Ultra Flat Theme drawing tasks.

Member Function Documentation

◆ DrawButtonBackground()

virtual void DrawButtonBackground | ( | CDC * | pDC,
 |  | CXTPButton * | pButton )
 virtual

This member function is called to draw the background for the button.

Parameters
pDC | A CDC pointer that represents the current device context.
pButton | Pointer to a CXTPButton object.

Reimplemented from CXTPButtonTheme.

Reimplemented in CXTPButtonThemeOffice2000, CXTPButtonThemeOffice2003, CXTPButtonThemeOffice2013, CXTPButtonThemeOfficeXP, CXTPButtonThemeResource, CXTPButtonThemeVisualStudio2012, CXTPCaptionButtonThemeOffice2003, and CXTPCaptionButtonThemeOfficeXP.

◆ DrawCheckBoxMark()

virtual void DrawCheckBoxMark | ( | CDC * | pDC,
 |  | CXTPButton * | pButton )
 virtual

This member function is called to draw the check box mark for the button control.

Parameters
pDC | Pointer to a valid device context.
pButton | Pointer to the CXTPButton to draw the check box for.

Reimplemented from CXTPButtonTheme.

Reimplemented in CXTPButtonThemeOffice2013, CXTPButtonThemeResource, and CXTPButtonThemeVisualStudio2012.

◆ DrawGroupBox()

virtual void DrawGroupBox | ( | CDC * | pDC,
 |  | CXTPButton * | pButton )
 virtual

This member function is called to draw the group box for the button.

Parameters
pDC | A CDC pointer that represents the current device context.
pButton | Pointer to a CXTPButton object.

Reimplemented from CXTPButtonTheme.

Reimplemented in CXTPButtonThemeOffice2013.

◆ DrawRadioButtonMark()

virtual void DrawRadioButtonMark | ( | CDC * | pDC,
 |  | CXTPButton * | pButton )
 virtual

This member function is called to draw the radio mark for the button control.

Parameters
pDC | Pointer to a valid device context.
pButton | Pointer to the CXTPButton to draw the radio mark for.

Reimplemented from CXTPButtonTheme.

Reimplemented in CXTPButtonThemeOffice2013, CXTPButtonThemeResource, and CXTPButtonThemeVisualStudio2012.

◆ RefreshMetrics()

virtual void RefreshMetrics ( CXTPButton * pButton )
virtual

This member function is called by the theme manager to refresh the visual styles used by each component's theme.

Parameters
pButton Pointer to a CXTPButton object.

Reimplemented from CXTPButtonTheme.

Reimplemented in CXTPButtonThemeNativeWindows10, CXTPButtonThemeNativeWindows11, CXTPButtonThemeOffice2003, CXTPButtonThemeOffice2013, CXTPButtonThemeOfficeXP, CXTPButtonThemeResource, CXTPButtonThemeVisualStudio2012, CXTPButtonThemeVisualStudio2015, CXTPButtonThemeVisualStudio2017, CXTPButtonThemeVisualStudio2019, and CXTPButtonThemeVisualStudio2022.

The documentation for this class was generated from the following file:
  • XTPButtonThemeUltraFlat.h


Toolkit Pro: CXTPButtonThemeVisualStudio2012 Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPButtonThemeVisualStudio2012 Class Reference

CXTPButtonThemeVisualStudio2012 is a class used to perform Visual Studio 2012 theme drawing tasks. More...

Inheritance diagram for CXTPButtonThemeVisualStudio2012:
[legend]

Public Member Functions

CXTPButtonThemeVisualStudio2012 (BOOL bLight)
Constructs a CXTPButtonThemeVisualStudio2012 object.
void | RefreshMetrics (CXTPButton *pButton)
This member function is called by the theme manager to refresh the visual styles used by each component's theme.
virtual COLORREF | GetTextColor (CXTPButton *pButton)
Call this member function to retrieve the color used to draw the button text.
virtual void | DrawCheckBoxMark (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the check box mark for the button control.
virtual void | DrawRadioButtonMark (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the radio mark for the button control.
virtual void | DrawButtonBackground (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the background for the button control.
- Public Member Functions inherited from CXTPButtonThemeOffice2013
virtual void | DrawGroupBox (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the group box for the button.
virtual void | DrawPushButtonText (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the text for the button.
virtual void | DrawPushButtonIcon (CDC *pDC, CXTPButton *pButton)
This member function draws the icon for the button, if one has been defined.
virtual void | DrawPushButtonDropDown (CDC *pDC, CXTPButton *pButton)
This member function draws the dropdown for the button, if one has been defined.
- Public Member Functions inherited from CXTPButtonThemeUltraFlat
CXTPButtonThemeUltraFlat ()
Constructs a CXTPButtonThemeUltraFlat object.
- Public Member Functions inherited from CXTPButtonTheme
CXTPButtonTheme ()
Constructs a CXTPButtonTheme object.
virtual | ~CXTPButtonTheme ()
Destroys a CXTPButtonTheme object, handles cleanup and deallocation.
virtual void | DrawFocusRect (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the focus rectangle for the button.
virtual void | DrawButton (CDC *pDC, CXTPButton *pButton)
This member function is called to the button.
virtual void | DrawButtonVisualStyleBackground (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the styled background for the button.
void | DrawButtonText (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the text for the button.
- Public Member Functions inherited from CXTPControlTheme
CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme | GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Attributes

BOOL | m_bLight
TRUE when drawing light theme.
- Protected Attributes inherited from CXTPButtonThemeOffice2013
CXTPPaintManagerColor | m_crBorder
An RGB value representing border color.
CXTPPaintManagerColor | m_crBorderDefault
An RGB value representing default border color.
CXTPPaintManagerColor | m_crBorderDisabled
An RGB value representing disabled border color.
CXTPPaintManagerColor | m_crBackDisabled
An RGB value representing disabled background color.
CXTPPaintManagerColor | m_crMark
An RGB value representing checkmark color.
CXTPPaintManagerColor | m_crMarkHilite
An RGB value representing checkmark hilite color.
CXTPPaintManagerColor | m_crMarkPushed
An RGB value representing checkmark pushed color.
CXTPPaintManagerColor | m_crMarkDisabled
An RGB value representing checkmark disabled color.
- Protected Attributes inherited from CXTPControlTheme
XTPControlTheme | m_nTheme
Currently selected theme style index.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlTheme
static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPButtonThemeUltraFlat
CXTPPaintManagerColor | m_crBackHilite
RGB value for highlighted background color.
CXTPPaintManagerColor | m_crBackPushed
RGB value for pushed background color.
CXTPPaintManagerColor | m_crBackChecked
RGB value for when the control is checked.
CXTPPaintManagerColor | m_crBorderPushed
RGB value for border pushed color.
CXTPPaintManagerColor | m_crTextPushed
RGB value for pushed text color.
CXTPPaintManagerColor | m_crTextHilite
RGB value for highlighted text color.
CXTPPaintManagerColor | m_crCheckMark
RGB value for check mark color.
- Public Attributes inherited from CXTPButtonTheme
CXTPPaintManagerColor | m_crTextDisabled
RGB value for disabled text color.
CXTPPaintManagerColor | m_crBorderHilite
RGB value for border highlight color.
CXTPPaintManagerColor | m_crBorderShadow
RGB value for border shadow color.
CXTPPaintManagerColor | m_crBorder3DHilite
RGB value for 3D border highlight color.
CXTPPaintManagerColor | m_crBorder3DShadow
RGB value for 3D border shadow color.
CXTPPaintManagerColor | m_crBack
RGB value for background color.
CXTPPaintManagerColor | m_crText
RGB value for text color.
CXTPPaintManagerColor | m_crTextCheck
RGB value for checked text color.

Detailed Description

CXTPButtonThemeVisualStudio2012 is a class used to perform Visual Studio 2012 theme drawing tasks.

Constructor & Destructor Documentation

◆ CXTPButtonThemeVisualStudio2012()

CXTPButtonThemeVisualStudio2012 ( BOOL bLight )

Constructs a CXTPButtonThemeVisualStudio2012 object.

Parameters
bLight TRUE to use Light theme, FALSE to use Dark theme.

Member Function Documentation

◆ DrawButtonBackground()

virtual void DrawButtonBackground | ( | CDC * | pDC,
 |  | CXTPButton * | pButton )
 virtual

This member function is called to draw the background for the button control.

Parameters
pDC | Pointer to a valid device context.
pButton | Pointer to the CXTPButton to draw the background for.

Reimplemented from CXTPButtonThemeOffice2013.

◆ DrawCheckBoxMark()

virtual void DrawCheckBoxMark | ( | CDC * | pDC,
 |  | CXTPButton * | pButton )
 virtual

This member function is called to draw the check box mark for the button control.

Parameters
pDC | Pointer to a valid device context.
pButton | Pointer to the CXTPButton to draw the check box for.

Reimplemented from CXTPButtonThemeOffice2013.

◆ DrawRadioButtonMark()

virtual void DrawRadioButtonMark | ( | CDC * | pDC,
 |  | CXTPButton * | pButton )
 virtual

This member function is called to draw the radio mark for the button control.

Parameters
pDC | Pointer to a valid device context.
pButton | Pointer to the CXTPButton to draw the radio mark for.

Reimplemented from CXTPButtonThemeOffice2013.

◆ GetTextColor()

virtual COLORREF GetTextColor ( CXTPButton * pButton )
virtual

Call this member function to retrieve the color used to draw the button text.

Parameters
pButton Pointer to a CXTPButton object.
Returns
An RGB value that represents the button text color.

Reimplemented from CXTPButtonThemeOffice2013.

◆ RefreshMetrics()

void RefreshMetrics ( CXTPButton * pButton )
virtual

This member function is called by the theme manager to refresh the visual styles used by each component's theme.

Parameters
pButton Pointer to a CXTPButton object.

Reimplemented from CXTPButtonThemeOffice2013.

The documentation for this class was generated from the following file:
  • XTPButtonThemeVisualStudio2012.h


Toolkit Pro: CXTPButtonThemeVisualStudio2015 Class Reference

Public Member Functions | List of all members
CXTPButtonThemeVisualStudio2015 Class Reference

CXTPButtonThemeVisualStudio2015 is a class used to perform Visual Studio 2015 theme drawing tasks. More...

Inheritance diagram for CXTPButtonThemeVisualStudio2015:
[legend]

Public Member Functions

CXTPButtonThemeVisualStudio2015 ()
Constructs a CXTPButtonThemeVisualStudio2015 object.
virtual void | RefreshMetrics (CXTPButton *pButton)
This member function is called by the theme manager to refresh the visual styles used by each component's theme.
- Public Member Functions inherited from CXTPButtonThemeOffice2013
virtual void | DrawButtonBackground (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the background for the button.
virtual void | DrawGroupBox (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the group box for the button.
virtual void | DrawCheckBoxMark (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the check box mark for the button control.
virtual void | DrawRadioButtonMark (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the radio mark for the button control.
virtual COLORREF | GetTextColor (CXTPButton *pButton)
Call this member function to retrieve the color used to draw the button text.
virtual void | DrawPushButtonText (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the text for the button.
virtual void | DrawPushButtonIcon (CDC *pDC, CXTPButton *pButton)
This member function draws the icon for the button, if one has been defined.
virtual void | DrawPushButtonDropDown (CDC *pDC, CXTPButton *pButton)
This member function draws the dropdown for the button, if one has been defined.
- Public Member Functions inherited from CXTPButtonThemeUltraFlat
CXTPButtonThemeUltraFlat ()
Constructs a CXTPButtonThemeUltraFlat object.
- Public Member Functions inherited from CXTPButtonTheme
CXTPButtonTheme ()
Constructs a CXTPButtonTheme object.
virtual | ~CXTPButtonTheme ()
Destroys a CXTPButtonTheme object, handles cleanup and deallocation.
virtual void | DrawFocusRect (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the focus rectangle for the button.
virtual void | DrawButton (CDC *pDC, CXTPButton *pButton)
This member function is called to the button.
virtual void | DrawButtonVisualStyleBackground (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the styled background for the button.
void | DrawButtonText (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the text for the button.
- Public Member Functions inherited from CXTPControlTheme
CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme | GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlTheme
static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPButtonThemeUltraFlat
CXTPPaintManagerColor | m_crBackHilite
RGB value for highlighted background color.
CXTPPaintManagerColor | m_crBackPushed
RGB value for pushed background color.
CXTPPaintManagerColor | m_crBackChecked
RGB value for when the control is checked.
CXTPPaintManagerColor | m_crBorderPushed
RGB value for border pushed color.
CXTPPaintManagerColor | m_crTextPushed
RGB value for pushed text color.
CXTPPaintManagerColor | m_crTextHilite
RGB value for highlighted text color.
CXTPPaintManagerColor | m_crCheckMark
RGB value for check mark color.
- Public Attributes inherited from CXTPButtonTheme
CXTPPaintManagerColor | m_crTextDisabled
RGB value for disabled text color.
CXTPPaintManagerColor | m_crBorderHilite
RGB value for border highlight color.
CXTPPaintManagerColor | m_crBorderShadow
RGB value for border shadow color.
CXTPPaintManagerColor | m_crBorder3DHilite
RGB value for 3D border highlight color.
CXTPPaintManagerColor | m_crBorder3DShadow
RGB value for 3D border shadow color.
CXTPPaintManagerColor | m_crBack
RGB value for background color.
CXTPPaintManagerColor | m_crText
RGB value for text color.
CXTPPaintManagerColor | m_crTextCheck
RGB value for checked text color.
- Protected Attributes inherited from CXTPButtonThemeOffice2013
CXTPPaintManagerColor | m_crBorder
An RGB value representing border color.
CXTPPaintManagerColor | m_crBorderDefault
An RGB value representing default border color.
CXTPPaintManagerColor | m_crBorderDisabled
An RGB value representing disabled border color.
CXTPPaintManagerColor | m_crBackDisabled
An RGB value representing disabled background color.
CXTPPaintManagerColor | m_crMark
An RGB value representing checkmark color.
CXTPPaintManagerColor | m_crMarkHilite
An RGB value representing checkmark hilite color.
CXTPPaintManagerColor | m_crMarkPushed
An RGB value representing checkmark pushed color.
CXTPPaintManagerColor | m_crMarkDisabled
An RGB value representing checkmark disabled color.
- Protected Attributes inherited from CXTPControlTheme
XTPControlTheme | m_nTheme
Currently selected theme style index.

Detailed Description

CXTPButtonThemeVisualStudio2015 is a class used to perform Visual Studio 2015 theme drawing tasks.

Member Function Documentation

◆ RefreshMetrics()

virtual void RefreshMetrics ( CXTPButton * pButton )
virtual

This member function is called by the theme manager to refresh the visual styles used by each component's theme.

Parameters
pButton Pointer to a CXTPButton object.

Reimplemented from CXTPButtonThemeOffice2013.

The documentation for this class was generated from the following file:
  • XTPButtonThemeVisualStudio2015.h


Toolkit Pro: CXTPButtonThemeVisualStudio2017 Class Reference

Public Member Functions | List of all members
CXTPButtonThemeVisualStudio2017 Class Reference

CXTPButtonThemeVisualStudio2017 is a class used to perform Visual Studio 2017 theme drawing tasks. More...

Inheritance diagram for CXTPButtonThemeVisualStudio2017:
[legend]

Public Member Functions

CXTPButtonThemeVisualStudio2017 ()
Constructs a CXTPButtonThemeVisualStudio2017 object.
virtual void | RefreshMetrics (CXTPButton *pButton)
This member function is called by the theme manager to refresh the visual styles used by each component's theme.
- Public Member Functions inherited from CXTPButtonThemeOffice2013
virtual void | DrawButtonBackground (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the background for the button.
virtual void | DrawGroupBox (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the group box for the button.
virtual void | DrawCheckBoxMark (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the check box mark for the button control.
virtual void | DrawRadioButtonMark (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the radio mark for the button control.
virtual COLORREF | GetTextColor (CXTPButton *pButton)
Call this member function to retrieve the color used to draw the button text.
virtual void | DrawPushButtonText (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the text for the button.
virtual void | DrawPushButtonIcon (CDC *pDC, CXTPButton *pButton)
This member function draws the icon for the button, if one has been defined.
virtual void | DrawPushButtonDropDown (CDC *pDC, CXTPButton *pButton)
This member function draws the dropdown for the button, if one has been defined.
- Public Member Functions inherited from CXTPButtonThemeUltraFlat
CXTPButtonThemeUltraFlat ()
Constructs a CXTPButtonThemeUltraFlat object.
- Public Member Functions inherited from CXTPButtonTheme
CXTPButtonTheme ()
Constructs a CXTPButtonTheme object.
virtual | ~CXTPButtonTheme ()
Destroys a CXTPButtonTheme object, handles cleanup and deallocation.
virtual void | DrawFocusRect (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the focus rectangle for the button.
virtual void | DrawButton (CDC *pDC, CXTPButton *pButton)
This member function is called to the button.
virtual void | DrawButtonVisualStyleBackground (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the styled background for the button.
void | DrawButtonText (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the text for the button.
- Public Member Functions inherited from CXTPControlTheme
CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme | GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlTheme
static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPButtonThemeUltraFlat
CXTPPaintManagerColor | m_crBackHilite
RGB value for highlighted background color.
CXTPPaintManagerColor | m_crBackPushed
RGB value for pushed background color.
CXTPPaintManagerColor | m_crBackChecked
RGB value for when the control is checked.
CXTPPaintManagerColor | m_crBorderPushed
RGB value for border pushed color.
CXTPPaintManagerColor | m_crTextPushed
RGB value for pushed text color.
CXTPPaintManagerColor | m_crTextHilite
RGB value for highlighted text color.
CXTPPaintManagerColor | m_crCheckMark
RGB value for check mark color.
- Public Attributes inherited from CXTPButtonTheme
CXTPPaintManagerColor | m_crTextDisabled
RGB value for disabled text color.
CXTPPaintManagerColor | m_crBorderHilite
RGB value for border highlight color.
CXTPPaintManagerColor | m_crBorderShadow
RGB value for border shadow color.
CXTPPaintManagerColor | m_crBorder3DHilite
RGB value for 3D border highlight color.
CXTPPaintManagerColor | m_crBorder3DShadow
RGB value for 3D border shadow color.
CXTPPaintManagerColor | m_crBack
RGB value for background color.
CXTPPaintManagerColor | m_crText
RGB value for text color.
CXTPPaintManagerColor | m_crTextCheck
RGB value for checked text color.
- Protected Attributes inherited from CXTPButtonThemeOffice2013
CXTPPaintManagerColor | m_crBorder
An RGB value representing border color.
CXTPPaintManagerColor | m_crBorderDefault
An RGB value representing default border color.
CXTPPaintManagerColor | m_crBorderDisabled
An RGB value representing disabled border color.
CXTPPaintManagerColor | m_crBackDisabled
An RGB value representing disabled background color.
CXTPPaintManagerColor | m_crMark
An RGB value representing checkmark color.
CXTPPaintManagerColor | m_crMarkHilite
An RGB value representing checkmark hilite color.
CXTPPaintManagerColor | m_crMarkPushed
An RGB value representing checkmark pushed color.
CXTPPaintManagerColor | m_crMarkDisabled
An RGB value representing checkmark disabled color.
- Protected Attributes inherited from CXTPControlTheme
XTPControlTheme | m_nTheme
Currently selected theme style index.

Detailed Description

CXTPButtonThemeVisualStudio2017 is a class used to perform Visual Studio 2017 theme drawing tasks.

Member Function Documentation

◆ RefreshMetrics()

virtual void RefreshMetrics ( CXTPButton * pButton )
virtual

This member function is called by the theme manager to refresh the visual styles used by each component's theme.

Parameters
pButton Pointer to a CXTPButton object.

Reimplemented from CXTPButtonThemeOffice2013.

The documentation for this class was generated from the following file:
  • XTPButtonThemeVisualStudio2017.h


Toolkit Pro: CXTPButtonThemeVisualStudio2019 Class Reference

Public Member Functions | List of all members
CXTPButtonThemeVisualStudio2019 Class Reference

CXTPButtonThemeVisualStudio2019 is a class used to perform Visual Studio 2019 theme drawing tasks. More...

Inheritance diagram for CXTPButtonThemeVisualStudio2019:
[legend]

Public Member Functions

CXTPButtonThemeVisualStudio2019 ()
Constructs a CXTPButtonThemeVisualStudio2019 object.
virtual void | RefreshMetrics (CXTPButton *pButton)
This member function is called by the theme manager to refresh the visual styles used by each component's theme.
- Public Member Functions inherited from CXTPButtonThemeOffice2013
virtual void | DrawButtonBackground (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the background for the button.
virtual void | DrawGroupBox (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the group box for the button.
virtual void | DrawCheckBoxMark (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the check box mark for the button control.
virtual void | DrawRadioButtonMark (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the radio mark for the button control.
virtual COLORREF | GetTextColor (CXTPButton *pButton)
Call this member function to retrieve the color used to draw the button text.
virtual void | DrawPushButtonText (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the text for the button.
virtual void | DrawPushButtonIcon (CDC *pDC, CXTPButton *pButton)
This member function draws the icon for the button, if one has been defined.
virtual void | DrawPushButtonDropDown (CDC *pDC, CXTPButton *pButton)
This member function draws the dropdown for the button, if one has been defined.
- Public Member Functions inherited from CXTPButtonThemeUltraFlat
CXTPButtonThemeUltraFlat ()
Constructs a CXTPButtonThemeUltraFlat object.
- Public Member Functions inherited from CXTPButtonTheme
CXTPButtonTheme ()
Constructs a CXTPButtonTheme object.
virtual | ~CXTPButtonTheme ()
Destroys a CXTPButtonTheme object, handles cleanup and deallocation.
virtual void | DrawFocusRect (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the focus rectangle for the button.
virtual void | DrawButton (CDC *pDC, CXTPButton *pButton)
This member function is called to the button.
virtual void | DrawButtonVisualStyleBackground (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the styled background for the button.
void | DrawButtonText (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the text for the button.
- Public Member Functions inherited from CXTPControlTheme
CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme | GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlTheme
static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPButtonThemeUltraFlat
CXTPPaintManagerColor | m_crBackHilite
RGB value for highlighted background color.
CXTPPaintManagerColor | m_crBackPushed
RGB value for pushed background color.
CXTPPaintManagerColor | m_crBackChecked
RGB value for when the control is checked.
CXTPPaintManagerColor | m_crBorderPushed
RGB value for border pushed color.
CXTPPaintManagerColor | m_crTextPushed
RGB value for pushed text color.
CXTPPaintManagerColor | m_crTextHilite
RGB value for highlighted text color.
CXTPPaintManagerColor | m_crCheckMark
RGB value for check mark color.
- Public Attributes inherited from CXTPButtonTheme
CXTPPaintManagerColor | m_crTextDisabled
RGB value for disabled text color.
CXTPPaintManagerColor | m_crBorderHilite
RGB value for border highlight color.
CXTPPaintManagerColor | m_crBorderShadow
RGB value for border shadow color.
CXTPPaintManagerColor | m_crBorder3DHilite
RGB value for 3D border highlight color.
CXTPPaintManagerColor | m_crBorder3DShadow
RGB value for 3D border shadow color.
CXTPPaintManagerColor | m_crBack
RGB value for background color.
CXTPPaintManagerColor | m_crText
RGB value for text color.
CXTPPaintManagerColor | m_crTextCheck
RGB value for checked text color.
- Protected Attributes inherited from CXTPButtonThemeOffice2013
CXTPPaintManagerColor | m_crBorder
An RGB value representing border color.
CXTPPaintManagerColor | m_crBorderDefault
An RGB value representing default border color.
CXTPPaintManagerColor | m_crBorderDisabled
An RGB value representing disabled border color.
CXTPPaintManagerColor | m_crBackDisabled
An RGB value representing disabled background color.
CXTPPaintManagerColor | m_crMark
An RGB value representing checkmark color.
CXTPPaintManagerColor | m_crMarkHilite
An RGB value representing checkmark hilite color.
CXTPPaintManagerColor | m_crMarkPushed
An RGB value representing checkmark pushed color.
CXTPPaintManagerColor | m_crMarkDisabled
An RGB value representing checkmark disabled color.
- Protected Attributes inherited from CXTPControlTheme
XTPControlTheme | m_nTheme
Currently selected theme style index.

Detailed Description

CXTPButtonThemeVisualStudio2019 is a class used to perform Visual Studio 2019 theme drawing tasks.

Member Function Documentation

◆ RefreshMetrics()

virtual void RefreshMetrics ( CXTPButton * pButton )
virtual

This member function is called by the theme manager to refresh the visual styles used by each component's theme.

Parameters
pButton Pointer to a CXTPButton object.

Reimplemented from CXTPButtonThemeOffice2013.

The documentation for this class was generated from the following file:
  • XTPButtonThemeVisualStudio2019.h


Toolkit Pro: CXTPButtonThemeVisualStudio2022 Class Reference

Public Member Functions | List of all members
CXTPButtonThemeVisualStudio2022 Class Reference

CXTPButtonThemeVisualStudio2022 is a class used to perform Visual Studio 2022 theme drawing tasks. More...

Inheritance diagram for CXTPButtonThemeVisualStudio2022:
[legend]

Public Member Functions

CXTPButtonThemeVisualStudio2022 ()
Constructs a CXTPButtonThemeVisualStudio2022 object.
virtual void | RefreshMetrics (CXTPButton *pButton)
This member function is called by the theme manager to refresh the visual styles used by each component's theme.
- Public Member Functions inherited from CXTPButtonThemeOffice2013
virtual void | DrawButtonBackground (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the background for the button.
virtual void | DrawGroupBox (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the group box for the button.
virtual void | DrawCheckBoxMark (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the check box mark for the button control.
virtual void | DrawRadioButtonMark (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the radio mark for the button control.
virtual COLORREF | GetTextColor (CXTPButton *pButton)
Call this member function to retrieve the color used to draw the button text.
virtual void | DrawPushButtonText (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the text for the button.
virtual void | DrawPushButtonIcon (CDC *pDC, CXTPButton *pButton)
This member function draws the icon for the button, if one has been defined.
virtual void | DrawPushButtonDropDown (CDC *pDC, CXTPButton *pButton)
This member function draws the dropdown for the button, if one has been defined.
- Public Member Functions inherited from CXTPButtonThemeUltraFlat
CXTPButtonThemeUltraFlat ()
Constructs a CXTPButtonThemeUltraFlat object.
- Public Member Functions inherited from CXTPButtonTheme
CXTPButtonTheme ()
Constructs a CXTPButtonTheme object.
virtual | ~CXTPButtonTheme ()
Destroys a CXTPButtonTheme object, handles cleanup and deallocation.
virtual void | DrawFocusRect (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the focus rectangle for the button.
virtual void | DrawButton (CDC *pDC, CXTPButton *pButton)
This member function is called to the button.
virtual void | DrawButtonVisualStyleBackground (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the styled background for the button.
void | DrawButtonText (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the text for the button.
- Public Member Functions inherited from CXTPControlTheme
CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme | GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlTheme
static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPButtonThemeUltraFlat
CXTPPaintManagerColor | m_crBackHilite
RGB value for highlighted background color.
CXTPPaintManagerColor | m_crBackPushed
RGB value for pushed background color.
CXTPPaintManagerColor | m_crBackChecked
RGB value for when the control is checked.
CXTPPaintManagerColor | m_crBorderPushed
RGB value for border pushed color.
CXTPPaintManagerColor | m_crTextPushed
RGB value for pushed text color.
CXTPPaintManagerColor | m_crTextHilite
RGB value for highlighted text color.
CXTPPaintManagerColor | m_crCheckMark
RGB value for check mark color.
- Public Attributes inherited from CXTPButtonTheme
CXTPPaintManagerColor | m_crTextDisabled
RGB value for disabled text color.
CXTPPaintManagerColor | m_crBorderHilite
RGB value for border highlight color.
CXTPPaintManagerColor | m_crBorderShadow
RGB value for border shadow color.
CXTPPaintManagerColor | m_crBorder3DHilite
RGB value for 3D border highlight color.
CXTPPaintManagerColor | m_crBorder3DShadow
RGB value for 3D border shadow color.
CXTPPaintManagerColor | m_crBack
RGB value for background color.
CXTPPaintManagerColor | m_crText
RGB value for text color.
CXTPPaintManagerColor | m_crTextCheck
RGB value for checked text color.
- Protected Attributes inherited from CXTPButtonThemeOffice2013
CXTPPaintManagerColor | m_crBorder
An RGB value representing border color.
CXTPPaintManagerColor | m_crBorderDefault
An RGB value representing default border color.
CXTPPaintManagerColor | m_crBorderDisabled
An RGB value representing disabled border color.
CXTPPaintManagerColor | m_crBackDisabled
An RGB value representing disabled background color.
CXTPPaintManagerColor | m_crMark
An RGB value representing checkmark color.
CXTPPaintManagerColor | m_crMarkHilite
An RGB value representing checkmark hilite color.
CXTPPaintManagerColor | m_crMarkPushed
An RGB value representing checkmark pushed color.
CXTPPaintManagerColor | m_crMarkDisabled
An RGB value representing checkmark disabled color.
- Protected Attributes inherited from CXTPControlTheme
XTPControlTheme | m_nTheme
Currently selected theme style index.

Detailed Description

CXTPButtonThemeVisualStudio2022 is a class used to perform Visual Studio 2022 theme drawing tasks.

Member Function Documentation

◆ RefreshMetrics()

virtual void RefreshMetrics ( CXTPButton * pButton )
virtual

This member function is called by the theme manager to refresh the visual styles used by each component's theme.

Parameters
pButton Pointer to a CXTPButton object.

Reimplemented from CXTPButtonThemeOffice2013.

The documentation for this class was generated from the following file:
  • XTPButtonThemeVisualStudio2022.h


Toolkit Pro: CXTPCalendarBusyStatusComboBox Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPCalendarBusyStatusComboBox Class Reference

This class implements the busy status selector combobox. More...

Inheritance diagram for CXTPCalendarBusyStatusComboBox:
[legend]

Public Member Functions

virtual BOOL | Init (CXTPCalendarEvent *pEvent, XTPCalendarTheme nTheme)
Call this member function to initialize the combobox.
- Public Member Functions inherited from CXTPCalendarComboBoxBase
CXTPCalendarComboBoxBase ()
Standard object constructor.
virtual | ~CXTPCalendarComboBoxBase ()
Standard object destructor.

Protected Member Functions

virtual void | DrawItem (LPDRAWITEMSTRUCT lpDIS)
This function implements custom draw combobox items.
- Protected Member Functions inherited from CXTPCalendarComboBoxBase
virtual void | MeasureItem (LPMEASUREITEMSTRUCT lpMIS)
This function implements measure items for custom draw.
virtual CRect | CalcColorRect (CRect rItem)
This member function is called to calculate the size for the color rectangle displayed for each item.

Detailed Description

This class implements the busy status selector combobox.

Member Function Documentation

◆ DrawItem()

virtual void DrawItem ( LPDRAWITEMSTRUCT lpDIS )
protectedvirtual

This function implements custom draw combobox items.

Parameters
lpDIS A pointer to a LPDRAWITEMSTRUCT structure.

◆ Init()

virtual BOOL Init | ( | CXTPCalendarEvent * | pEvent,
 |  | XTPCalendarTheme | nTheme )
 virtual

Call this member function to initialize the combobox.

Parameters
pEvent | Pointer to the selected calendar event.
nTheme | Current Calendar theme.
Returns
TRUE if successful, FALSE otherwise.

Reimplemented from CXTPCalendarComboBoxBase.

The documentation for this class was generated from the following file:
  • XTPCalendarEventPropertiesDlg.h


Toolkit Pro: CXTPCalendarCaptionBarControl Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPCalendarCaptionBarControl Class Reference

CXTPCalendarCaptionBarControl represents CalendarCaptionBar control and used as a part of CXTPCalendarControl object. More...

Public Member Functions

CXTPCalendarCaptionBarControl ()
Default object constructor.
virtual | ~CXTPCalendarCaptionBarControl ()
Default object destructor.
virtual CRect | CalcMinRect (BOOL bExactSize=FALSE)
This member function retrieves the minimum size required to show a CaptionBar control.
virtual BOOL | Create (DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID)
This member function is used to create the CaptionBar control window.
virtual void | AdjustLayout (CDC *pDC=NULL, const CRect *prcWnd=NULL)
This member function is used to adjust the object's layout depending on the provided bounding rectangle.
CXTPCalendarCaptionBarTheme * | GetTheme () const
This member function is used to obtain pointer to CXTPCalendarCaptionBarTheme object.
void | SetTheme (CXTPCalendarCaptionBarTheme *pTheme)
This member function is used to set theme object.
BOOL | RegisterWindowClass (HINSTANCE hInstance=NULL)
Register the window class if it has not already been registered.
CRect | GetBorders () const
This member function is used to adjust the object's layout depending on the provided bounding rectangle.
virtual void | SetBorders (int nLeft, int nTop, int nRight, int nBottom)
This member function is used to adjust the object's layout depending on the provided bounding rectangle.
virtual void | UpdateBorders ()
This member function is used to adjust the object's layout depending on the provided bounding rectangle.
void | EnableTimeline (BOOL bEnable)
This member function is used to show or hide Timeline button.
BOOL | IsTimelineEnable ()
This member function is used to get state of m_bTimelineEnable.
void | EnableMulticolumns (BOOL bEnable)
This member function is used to show or hide Multi-Columns mode button.
BOOL | IsMulticolumnsEnable ()
This member function is used to get state of m_bMulticolumnsEnable.
void | UseOneLine (BOOL bSet)
This member function is used to get state of GetTheme()->m_bIsOneLine -.
BOOL | IsUseOneLine ()
This member function is used to get state of GetTheme()->m_bIsOneLine - flag to toggle CaptionMode 2-lines or 1-line modes.
void | SetButtonText (int iButtonNumber, CString sButtonText)
This member function is used to Set Button Text if text not empty and hide button and adjust Caption Bar if text is empty.

Protected Attributes

CXTPCalendarCaptionBarTheme * | m_pTheme
Store pointer to CXTPCalendarCaptionBarTheme object.
CRect | m_Borders
Store options to draw border lines;

Detailed Description

CXTPCalendarCaptionBarControl represents CalendarCaptionBar control and used as a part of CXTPCalendarControl object.

They looks and works as a single control but separated on 2 objects for customization possibilities.

This class is used as owner (host, events source) window for CXTPCalendarCaptionBarTheme object which implements the most control logic.

See also
CXTPCalendarCaptionBarTheme
CXTPCalendarControl

Constructor & Destructor Documentation

◆ CXTPCalendarCaptionBarControl()

CXTPCalendarCaptionBarControl ( )

Default object constructor.

See also
~CXTPCalendarCaptionBarControl

◆ ~CXTPCalendarCaptionBarControl()

virtual ~CXTPCalendarCaptionBarControl ( )
virtual

Default object destructor.

See also
CXTPCalendarCaptionBarControl

Member Function Documentation

◆ AdjustLayout()

virtual void AdjustLayout | ( | CDC * | pDC = NULL,
 |  | const CRect * | prcWnd = NULL )
 virtual

This member function is used to adjust the object's layout depending on the provided bounding rectangle.

Parameters
pDC | Pointer to a valid device context (may be NULL).
prcWnd | A CRect object containing the dimensions of the bounding rectangle for this part.

◆ CalcMinRect()

virtual CRect CalcMinRect ( BOOL bExactSize = FALSE )
virtual

This member function retrieves the minimum size required to show a CaptionBar control.

Parameters
bExactSize BOOL flag for calc mode
Returns
This member function call CXTPCalendarCaptionBarTheme::CalcMinRect function.
A minimum rectangle required to show CaptionBar control.
See also
CXTPCalendarCaptionBarTheme::CalcMinRect

◆ Create()

virtual BOOL Create | ( | DWORD | dwStyle,
 |  | const RECT & | rect,
 |  | CWnd * | pParentWnd,
 |  | UINT | nID )
 virtual

This member function is used to create the CaptionBar control window.

Parameters
dwStyle | Specifies the window style attributes.
rect | A RECT object that contains the coordinates of the window, in the client coordinates of pParentWnd.
pParentWnd | A CWnd pointer to the parent window.
nID | A UINT that contains the ID of the child window.
Returns
Nonzero if successful. Otherwise 0.

◆ EnableMulticolumns()

void EnableMulticolumns ( BOOL bEnable )

This member function is used to show or hide Multi-Columns mode button.

Parameters
bEnable BOOL flag to pass
See also
m_bMulticolumnsEnable

◆ EnableTimeline()

void EnableTimeline ( BOOL bEnable )

This member function is used to show or hide Timeline button.

Parameters
bEnable BOOL flag to pass
See also
m_bTimelineEnable

◆ GetBorders()

AFX_INLINE CRect GetBorders ( ) const

This member function is used to adjust the object's layout depending on the provided bounding rectangle.

Returns
A CRect object containing the dimensions of the bounding rectangle

◆ GetTheme()

CXTPCalendarCaptionBarTheme * GetTheme ( ) const

This member function is used to obtain pointer to CXTPCalendarCaptionBarTheme object.

Returns
A pointer to CXTPCalendarCaptionBarTheme object.

◆ IsMulticolumnsEnable()

BOOL IsMulticolumnsEnable ( )

This member function is used to get state of m_bMulticolumnsEnable.

Returns
TRUE if the this button enable.

◆ IsTimelineEnable()

BOOL IsTimelineEnable ( )

This member function is used to get state of m_bTimelineEnable.

Returns
TRUE if the time line is enabled, FALSE else.

◆ IsUseOneLine()

BOOL IsUseOneLine ( )

This member function is used to get state of GetTheme()->m_bIsOneLine - flag to toggle CaptionMode 2-lines or 1-line modes.

Returns
TRUE if the this One Line mode used

◆ RegisterWindowClass()

BOOL RegisterWindowClass ( HINSTANCE hInstance = NULL )

Register the window class if it has not already been registered.

Parameters
hInstance Instance of resource where control is located
Returns
TRUE if the window class was successfully registered. FALSE otherwise.

◆ SetBorders()

virtual void SetBorders | ( | int | nLeft,
 |  | int | nTop,
 |  | int | nRight,
 |  | int | nBottom )
 virtual

This member function is used to adjust the object's layout depending on the provided bounding rectangle.

Parameters
nLeft | rectange data
nTop | rectange data
nRight | rectange data
nBottom | rectange data

◆ SetButtonText()

void SetButtonText | ( | int | iButtonNumber,
 |  | CString | sButtonText )

This member function is used to Set Button Text if text not empty and hide button and adjust Caption Bar if text is empty.

Parameters
iButtonNumber | ordinal number of button starting from 0
sButtonText | CString of text passed

Smart function which allow to set custom text on Caption Bar buttons and hide if text EMPTY at least MonthView, WeekView and DayView buttons to prevent user switch mode (for restricted app)

Example of using with button numbers linked to specific View type:

GetCalendarCaptionBarCtrl().SetButtonText(0, _T("D"));   // DayView
GetCalendarCaptionBarCtrl().SetButtonText(1, _T("W"));   // WeekView
GetCalendarCaptionBarCtrl().SetButtonText(2, _T("M"));   // MonthView
GetCalendarCaptionBarCtrl().SetButtonText(3, _T("TL"));  // TimeLine
GetCalendarCaptionBarCtrl().SetButtonText(4, _T("WW"));  // WorkWeek
GetCalendarCaptionBarCtrl().SetButtonText(5, _T("FW"));  // FullWeek
GetCalendarCaptionBarCtrl().SetButtonText(6, _T("III")); // Multi-Columns mode

◆ SetTheme()

void SetTheme ( CXTPCalendarCaptionBarTheme * pTheme )

This member function is used to set theme object.

Parameters
pTheme A pointer to CXTPCalendarCaptionBarTheme object.

◆ UseOneLine()

void UseOneLine ( BOOL bSet )

This member function is used to get state of GetTheme()->m_bIsOneLine -.

Parameters
bSet BOOL flag to toggle CaptionMode 2-lines or 1-line modes
The documentation for this class was generated from the following file:
  • XTPCalendarCaptionBarControl.h


Toolkit Pro: CXTPCalendarCaptionBarNativeWindows10Theme Class Reference

Public Member Functions | List of all members
CXTPCalendarCaptionBarNativeWindows10Theme Class Reference

CXTPCalendarCaptionBarNativeWindows10Theme is a CXTPCalendarCaptionBarOffice2013Theme derived class that represents the Native Windows 10 calendar theme. More...

Inheritance diagram for CXTPCalendarCaptionBarNativeWindows10Theme:
[legend]

Public Member Functions

CXTPCalendarCaptionBarNativeWindows10Theme (CXTPCalendarCaptionBarTheme *pTheme=NULL)
Default paint manager constructor.
virtual | ~CXTPCalendarCaptionBarNativeWindows10Theme ()
Default paint manager destructor.
- Public Member Functions inherited from CXTPCalendarCaptionBarOffice2013Theme
CXTPCalendarCaptionBarOffice2013Theme (CXTPCalendarCaptionBarTheme *pTheme=NULL)
Default paint manager constructor.
virtual | ~CXTPCalendarCaptionBarOffice2013Theme ()
Default paint manager destructor.
virtual void | RefreshMetrics ()
Performs refreshing of graphical related parameters from system settings.
- Public Member Functions inherited from CXTPCalendarCaptionBarOffice2003Theme
CXTPCalendarCaptionBarOffice2003Theme (CXTPCalendarCaptionBarTheme *pTheme=NULL)
Default paint manager constructor.
virtual | ~CXTPCalendarCaptionBarOffice2003Theme ()
Default paint manager destructor.
- Public Member Functions inherited from CXTPCalendarCaptionBarOfficeXPTheme
CXTPCalendarCaptionBarOfficeXPTheme (CXTPCalendarCaptionBarTheme *pTheme=NULL)
Default paint manager constructor.
virtual | ~CXTPCalendarCaptionBarOfficeXPTheme ()
Default paint manager destructor.
- Public Member Functions inherited from CXTPCalendarCaptionBarOffice2000Theme
CXTPCalendarCaptionBarOffice2000Theme (CXTPCalendarCaptionBarTheme *pTheme=NULL)
Default paint manager constructor.
virtual | ~CXTPCalendarCaptionBarOffice2000Theme ()
Default paint manager destructor.
- Public Member Functions inherited from CXTPCalendarCaptionBarPaintManager
CXTPCalendarCaptionBarPaintManager (CXTPCalendarCaptionBarTheme *pTheme=NULL)
Default paint manager constructor.
virtual | ~CXTPCalendarCaptionBarPaintManager ()
Default paint manager destructor.
virtual XTPCalendarTheme | GetPaintTheme () const
This member function is used to obtain current paint theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Attributes inherited from CXTPCalendarCaptionBarOffice2013Theme
- Protected Attributes inherited from CXTPCalendarCaptionBarPaintManager
CXTPCalendarCaptionBarTheme * | m_pTheme
Store pointer to a parent theme object.
CXTPPaintManagerColor | m_clrSwitchViewBarBk
Store SwitchViewBar background color.
CXTPPaintManagerColor | m_clrScrollDateBarBk
Store ScrollDateBar background color.
CXTPPaintManagerColor | m_clrTextColor
Store the text color.
CXTPPaintManagerColor | m_clrBorders [4]
Store border line color, left = 0, top = 1, right = 2, bottom = 3.
CXTPPaintManagerColor | m_clrScrollTriangleColor
Defines date scroll arrow color.
CXTPCalendarThemeFontValue | m_fntTextFont
Store the text font.

Detailed Description

CXTPCalendarCaptionBarNativeWindows10Theme is a CXTPCalendarCaptionBarOffice2013Theme derived class that represents the Native Windows 10 calendar theme.

Constructor & Destructor Documentation

◆ CXTPCalendarCaptionBarNativeWindows10Theme()

CXTPCalendarCaptionBarNativeWindows10Theme ( CXTPCalendarCaptionBarTheme * pTheme = NULL )

Default paint manager constructor.

Parameters
pTheme A pointer to CXTPCalendarCaptionBarTheme object.

Handles initial initialization.

See also
RefreshMetrics()

◆ ~CXTPCalendarCaptionBarNativeWindows10Theme()

virtual ~CXTPCalendarCaptionBarNativeWindows10Theme ( )
virtual

Default paint manager destructor.

Handles member items deallocation.

The documentation for this class was generated from the following file:
  • XTPCalendarCaptionBarNativeWindows10Theme.h


Toolkit Pro: CXTPCalendarCaptionBarNativeWindows11Theme Class Reference

Public Member Functions | List of all members
CXTPCalendarCaptionBarNativeWindows11Theme Class Reference

CXTPCalendarCaptionBarNativeWindows11Theme is a CXTPCalendarCaptionBarOffice2013Theme derived class that represents the Native Windows 11 calendar theme. More...

Inheritance diagram for CXTPCalendarCaptionBarNativeWindows11Theme:
[legend]

Public Member Functions

CXTPCalendarCaptionBarNativeWindows11Theme (CXTPCalendarCaptionBarTheme *pTheme=NULL)
Default paint manager constructor.
virtual | ~CXTPCalendarCaptionBarNativeWindows11Theme ()
Default paint manager destructor.
- Public Member Functions inherited from CXTPCalendarCaptionBarOffice2013Theme
CXTPCalendarCaptionBarOffice2013Theme (CXTPCalendarCaptionBarTheme *pTheme=NULL)
Default paint manager constructor.
virtual | ~CXTPCalendarCaptionBarOffice2013Theme ()
Default paint manager destructor.
virtual void | RefreshMetrics ()
Performs refreshing of graphical related parameters from system settings.
- Public Member Functions inherited from CXTPCalendarCaptionBarOffice2003Theme
CXTPCalendarCaptionBarOffice2003Theme (CXTPCalendarCaptionBarTheme *pTheme=NULL)
Default paint manager constructor.
virtual | ~CXTPCalendarCaptionBarOffice2003Theme ()
Default paint manager destructor.
- Public Member Functions inherited from CXTPCalendarCaptionBarOfficeXPTheme
CXTPCalendarCaptionBarOfficeXPTheme (CXTPCalendarCaptionBarTheme *pTheme=NULL)
Default paint manager constructor.
virtual | ~CXTPCalendarCaptionBarOfficeXPTheme ()
Default paint manager destructor.
- Public Member Functions inherited from CXTPCalendarCaptionBarOffice2000Theme
CXTPCalendarCaptionBarOffice2000Theme (CXTPCalendarCaptionBarTheme *pTheme=NULL)
Default paint manager constructor.
virtual | ~CXTPCalendarCaptionBarOffice2000Theme ()
Default paint manager destructor.
- Public Member Functions inherited from CXTPCalendarCaptionBarPaintManager
CXTPCalendarCaptionBarPaintManager (CXTPCalendarCaptionBarTheme *pTheme=NULL)
Default paint manager constructor.
virtual | ~CXTPCalendarCaptionBarPaintManager ()
Default paint manager destructor.
virtual XTPCalendarTheme | GetPaintTheme () const
This member function is used to obtain current paint theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Attributes inherited from CXTPCalendarCaptionBarOffice2013Theme
- Protected Attributes inherited from CXTPCalendarCaptionBarPaintManager
CXTPCalendarCaptionBarTheme * | m_pTheme
Store pointer to a parent theme object.
CXTPPaintManagerColor | m_clrSwitchViewBarBk
Store SwitchViewBar background color.
CXTPPaintManagerColor | m_clrScrollDateBarBk
Store ScrollDateBar background color.
CXTPPaintManagerColor | m_clrTextColor
Store the text color.
CXTPPaintManagerColor | m_clrBorders [4]
Store border line color, left = 0, top = 1, right = 2, bottom = 3.
CXTPPaintManagerColor | m_clrScrollTriangleColor
Defines date scroll arrow color.
CXTPCalendarThemeFontValue | m_fntTextFont
Store the text font.

Detailed Description

CXTPCalendarCaptionBarNativeWindows11Theme is a CXTPCalendarCaptionBarOffice2013Theme derived class that represents the Native Windows 11 calendar theme.

Constructor & Destructor Documentation

◆ CXTPCalendarCaptionBarNativeWindows11Theme()

CXTPCalendarCaptionBarNativeWindows11Theme ( CXTPCalendarCaptionBarTheme * pTheme = NULL )

Default paint manager constructor.

Parameters
pTheme A pointer to CXTPCalendarCaptionBarTheme object.

Handles initial initialization.

See also
RefreshMetrics()

◆ ~CXTPCalendarCaptionBarNativeWindows11Theme()

virtual ~CXTPCalendarCaptionBarNativeWindows11Theme ( )
virtual

Default paint manager destructor.

Handles member items deallocation.

The documentation for this class was generated from the following file:
  • XTPCalendarCaptionBarNativeWindows11Theme.h


Toolkit Pro: CXTPCalendarCaptionBarOffice2000Theme Class Reference

Public Member Functions | List of all members
CXTPCalendarCaptionBarOffice2000Theme Class Reference

CXTPCalendarCaptionBarOffice2000Theme is a CXTPCalendarCaptionBarPaintManager derived class thatrepresents the Office 2000 calendar theme. More...

Inheritance diagram for CXTPCalendarCaptionBarOffice2000Theme:
[legend]

Public Member Functions

CXTPCalendarCaptionBarOffice2000Theme (CXTPCalendarCaptionBarTheme *pTheme=NULL)
Default paint manager constructor.
virtual | ~CXTPCalendarCaptionBarOffice2000Theme ()
Default paint manager destructor.
virtual void | RefreshMetrics ()
Performs refreshing of graphical related parameters from system settings.
- Public Member Functions inherited from CXTPCalendarCaptionBarPaintManager
CXTPCalendarCaptionBarPaintManager (CXTPCalendarCaptionBarTheme *pTheme=NULL)
Default paint manager constructor.
virtual | ~CXTPCalendarCaptionBarPaintManager ()
Default paint manager destructor.
virtual XTPCalendarTheme | GetPaintTheme () const
This member function is used to obtain current paint theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Attributes inherited from CXTPCalendarCaptionBarPaintManager
CXTPCalendarCaptionBarTheme * | m_pTheme
Store pointer to a parent theme object.
CXTPPaintManagerColor | m_clrSwitchViewBarBk
Store SwitchViewBar background color.
CXTPPaintManagerColor | m_clrScrollDateBarBk
Store ScrollDateBar background color.
CXTPPaintManagerColor | m_clrTextColor
Store the text color.
CXTPPaintManagerColor | m_clrBorders [4]
Store border line color, left = 0, top = 1, right = 2, bottom = 3.
CXTPPaintManagerColor | m_clrScrollTriangleColor
Defines date scroll arrow color.
CXTPCalendarThemeFontValue | m_fntTextFont
Store the text font.

Detailed Description

CXTPCalendarCaptionBarOffice2000Theme is a CXTPCalendarCaptionBarPaintManager derived class thatrepresents the Office 2000 calendar theme.

Constructor & Destructor Documentation

◆ CXTPCalendarCaptionBarOffice2000Theme()

CXTPCalendarCaptionBarOffice2000Theme ( CXTPCalendarCaptionBarTheme * pTheme = NULL )

Default paint manager constructor.

Parameters
pTheme A pointer to CXTPCalendarCaptionBarTheme object.

Handles initial initialization.

See also
RefreshMetrics()

◆ ~CXTPCalendarCaptionBarOffice2000Theme()

virtual ~CXTPCalendarCaptionBarOffice2000Theme ( )
virtual

Default paint manager destructor.

Handles member items deallocation.

Member Function Documentation

◆ RefreshMetrics()

virtual void RefreshMetrics ( )
virtual

Performs refreshing of graphical related parameters from system settings.

Base implementation do nothing.

Reimplemented from CXTPCalendarCaptionBarPaintManager.

Reimplemented in CXTPCalendarCaptionBarOffice2013Theme, CXTPCalendarCaptionBarOfficeXPTheme, and CXTPCalendarCaptionBarResourceTheme.

The documentation for this class was generated from the following file:
  • XTPCalendarCaptionBarOffice2000Theme.h


Toolkit Pro: CXTPCalendarCaptionBarOffice2003Theme Class Reference

Public Member Functions | List of all members
CXTPCalendarCaptionBarOffice2003Theme Class Reference

CXTPCalendarCaptionBarOffice2003Theme is a CXTPCalendarCaptionBarOfficeXPTheme derived class that represents the Office 2003 calendar theme. More...

Inheritance diagram for CXTPCalendarCaptionBarOffice2003Theme:
[legend]

Public Member Functions

CXTPCalendarCaptionBarOffice2003Theme (CXTPCalendarCaptionBarTheme *pTheme=NULL)
Default paint manager constructor.
virtual | ~CXTPCalendarCaptionBarOffice2003Theme ()
Default paint manager destructor.
- Public Member Functions inherited from CXTPCalendarCaptionBarOfficeXPTheme
CXTPCalendarCaptionBarOfficeXPTheme (CXTPCalendarCaptionBarTheme *pTheme=NULL)
Default paint manager constructor.
virtual | ~CXTPCalendarCaptionBarOfficeXPTheme ()
Default paint manager destructor.
virtual void | RefreshMetrics ()
Performs refreshing of graphical related parameters from system settings.
- Public Member Functions inherited from CXTPCalendarCaptionBarOffice2000Theme
CXTPCalendarCaptionBarOffice2000Theme (CXTPCalendarCaptionBarTheme *pTheme=NULL)
Default paint manager constructor.
virtual | ~CXTPCalendarCaptionBarOffice2000Theme ()
Default paint manager destructor.
- Public Member Functions inherited from CXTPCalendarCaptionBarPaintManager
CXTPCalendarCaptionBarPaintManager (CXTPCalendarCaptionBarTheme *pTheme=NULL)
Default paint manager constructor.
virtual | ~CXTPCalendarCaptionBarPaintManager ()
Default paint manager destructor.
virtual XTPCalendarTheme | GetPaintTheme () const
This member function is used to obtain current paint theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Attributes inherited from CXTPCalendarCaptionBarPaintManager
CXTPCalendarCaptionBarTheme * | m_pTheme
Store pointer to a parent theme object.
CXTPPaintManagerColor | m_clrSwitchViewBarBk
Store SwitchViewBar background color.
CXTPPaintManagerColor | m_clrScrollDateBarBk
Store ScrollDateBar background color.
CXTPPaintManagerColor | m_clrTextColor
Store the text color.
CXTPPaintManagerColor | m_clrBorders [4]
Store border line color, left = 0, top = 1, right = 2, bottom = 3.
CXTPPaintManagerColor | m_clrScrollTriangleColor
Defines date scroll arrow color.
CXTPCalendarThemeFontValue | m_fntTextFont
Store the text font.

Detailed Description

CXTPCalendarCaptionBarOffice2003Theme is a CXTPCalendarCaptionBarOfficeXPTheme derived class that represents the Office 2003 calendar theme.

Constructor & Destructor Documentation

◆ CXTPCalendarCaptionBarOffice2003Theme()

CXTPCalendarCaptionBarOffice2003Theme ( CXTPCalendarCaptionBarTheme * pTheme = NULL )

Default paint manager constructor.

Parameters
pTheme A pointer to CXTPCalendarCaptionBarTheme object.

Handles initial initialization.

See also
RefreshMetrics()

◆ ~CXTPCalendarCaptionBarOffice2003Theme()

virtual ~CXTPCalendarCaptionBarOffice2003Theme ( )
virtual

Default paint manager destructor.

Handles member items deallocation.

The documentation for this class was generated from the following file:
  • XTPCalendarCaptionBarOffice2003Theme.h


Toolkit Pro: CXTPCalendarCaptionBarOffice2013Theme Class Reference

Public Member Functions | List of all members
CXTPCalendarCaptionBarOffice2013Theme Class Reference

CXTPCalendarCaptionBarOffice2013Theme is a CXTPCalendarCaptionBarOffice2003Theme derived class that represents the Office 2013 white calendar theme. More...

Inheritance diagram for CXTPCalendarCaptionBarOffice2013Theme:
[legend]

Public Member Functions

CXTPCalendarCaptionBarOffice2013Theme (CXTPCalendarCaptionBarTheme *pTheme=NULL)
Default paint manager constructor.
virtual | ~CXTPCalendarCaptionBarOffice2013Theme ()
Default paint manager destructor.
virtual void | RefreshMetrics ()
Performs refreshing of graphical related parameters from system settings.
- Public Member Functions inherited from CXTPCalendarCaptionBarOffice2003Theme
CXTPCalendarCaptionBarOffice2003Theme (CXTPCalendarCaptionBarTheme *pTheme=NULL)
Default paint manager constructor.
virtual | ~CXTPCalendarCaptionBarOffice2003Theme ()
Default paint manager destructor.
- Public Member Functions inherited from CXTPCalendarCaptionBarOfficeXPTheme
CXTPCalendarCaptionBarOfficeXPTheme (CXTPCalendarCaptionBarTheme *pTheme=NULL)
Default paint manager constructor.
virtual | ~CXTPCalendarCaptionBarOfficeXPTheme ()
Default paint manager destructor.
- Public Member Functions inherited from CXTPCalendarCaptionBarOffice2000Theme
CXTPCalendarCaptionBarOffice2000Theme (CXTPCalendarCaptionBarTheme *pTheme=NULL)
Default paint manager constructor.
virtual | ~CXTPCalendarCaptionBarOffice2000Theme ()
Default paint manager destructor.
- Public Member Functions inherited from CXTPCalendarCaptionBarPaintManager
CXTPCalendarCaptionBarPaintManager (CXTPCalendarCaptionBarTheme *pTheme=NULL)
Default paint manager constructor.
virtual | ~CXTPCalendarCaptionBarPaintManager ()
Default paint manager destructor.
virtual XTPCalendarTheme | GetPaintTheme () const
This member function is used to obtain current paint theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Attributes inherited from CXTPCalendarCaptionBarPaintManager
CXTPCalendarCaptionBarTheme * | m_pTheme
Store pointer to a parent theme object.
CXTPPaintManagerColor | m_clrSwitchViewBarBk
Store SwitchViewBar background color.
CXTPPaintManagerColor | m_clrScrollDateBarBk
Store ScrollDateBar background color.
CXTPPaintManagerColor | m_clrTextColor
Store the text color.
CXTPPaintManagerColor | m_clrBorders [4]
Store border line color, left = 0, top = 1, right = 2, bottom = 3.
CXTPPaintManagerColor | m_clrScrollTriangleColor
Defines date scroll arrow color.
CXTPCalendarThemeFontValue | m_fntTextFont
Store the text font.

Detailed Description

CXTPCalendarCaptionBarOffice2013Theme is a CXTPCalendarCaptionBarOffice2003Theme derived class that represents the Office 2013 white calendar theme.

Constructor & Destructor Documentation

◆ CXTPCalendarCaptionBarOffice2013Theme()

CXTPCalendarCaptionBarOffice2013Theme ( CXTPCalendarCaptionBarTheme * pTheme = NULL )

Default paint manager constructor.

Parameters
pTheme A pointer to CXTPCalendarCaptionBarTheme object.

Handles initial initialization.

See also
RefreshMetrics()

◆ ~CXTPCalendarCaptionBarOffice2013Theme()

virtual ~CXTPCalendarCaptionBarOffice2013Theme ( )
virtual

Default paint manager destructor.

Handles member items deallocation.

Member Function Documentation

◆ RefreshMetrics()

virtual void RefreshMetrics ( )
virtual

Performs refreshing of graphical related parameters from system settings.

Base implementation do nothing.

Reimplemented from CXTPCalendarCaptionBarOfficeXPTheme.

Reimplemented in CXTPCalendarCaptionBarResourceTheme.

The documentation for this class was generated from the following file:
  • XTPCalendarCaptionBarOffice2013Theme.h


Toolkit Pro: CXTPCalendarCaptionBarOfficeXPTheme Class Reference

Public Member Functions | List of all members
CXTPCalendarCaptionBarOfficeXPTheme Class Reference

CXTPCalendarCaptionBarOfficeXPTheme is a CXTPCalendarCaptionBarOffice2000Theme derived class that represents the Office XP calendar theme. More...

Inheritance diagram for CXTPCalendarCaptionBarOfficeXPTheme:
[legend]

Public Member Functions

CXTPCalendarCaptionBarOfficeXPTheme (CXTPCalendarCaptionBarTheme *pTheme=NULL)
Default paint manager constructor.
virtual | ~CXTPCalendarCaptionBarOfficeXPTheme ()
Default paint manager destructor.
virtual void | RefreshMetrics ()
Performs refreshing of graphical related parameters from system settings.
- Public Member Functions inherited from CXTPCalendarCaptionBarOffice2000Theme
CXTPCalendarCaptionBarOffice2000Theme (CXTPCalendarCaptionBarTheme *pTheme=NULL)
Default paint manager constructor.
virtual | ~CXTPCalendarCaptionBarOffice2000Theme ()
Default paint manager destructor.
- Public Member Functions inherited from CXTPCalendarCaptionBarPaintManager
CXTPCalendarCaptionBarPaintManager (CXTPCalendarCaptionBarTheme *pTheme=NULL)
Default paint manager constructor.
virtual | ~CXTPCalendarCaptionBarPaintManager ()
Default paint manager destructor.
virtual XTPCalendarTheme | GetPaintTheme () const
This member function is used to obtain current paint theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Attributes inherited from CXTPCalendarCaptionBarPaintManager
CXTPCalendarCaptionBarTheme * | m_pTheme
Store pointer to a parent theme object.
CXTPPaintManagerColor | m_clrSwitchViewBarBk
Store SwitchViewBar background color.
CXTPPaintManagerColor | m_clrScrollDateBarBk
Store ScrollDateBar background color.
CXTPPaintManagerColor | m_clrTextColor
Store the text color.
CXTPPaintManagerColor | m_clrBorders [4]
Store border line color, left = 0, top = 1, right = 2, bottom = 3.
CXTPPaintManagerColor | m_clrScrollTriangleColor
Defines date scroll arrow color.
CXTPCalendarThemeFontValue | m_fntTextFont
Store the text font.

Detailed Description

CXTPCalendarCaptionBarOfficeXPTheme is a CXTPCalendarCaptionBarOffice2000Theme derived class that represents the Office XP calendar theme.

Constructor & Destructor Documentation

◆ CXTPCalendarCaptionBarOfficeXPTheme()

CXTPCalendarCaptionBarOfficeXPTheme ( CXTPCalendarCaptionBarTheme * pTheme = NULL )

Default paint manager constructor.

Parameters
pTheme A pointer to CXTPCalendarCaptionBarTheme object.

Handles initial initialization.

See also
RefreshMetrics()

◆ ~CXTPCalendarCaptionBarOfficeXPTheme()

virtual ~CXTPCalendarCaptionBarOfficeXPTheme ( )
virtual

Default paint manager destructor.

Handles member items deallocation.

Member Function Documentation

◆ RefreshMetrics()

virtual void RefreshMetrics ( )
virtual

Performs refreshing of graphical related parameters from system settings.

Base implementation do nothing.

Reimplemented from CXTPCalendarCaptionBarOffice2000Theme.

Reimplemented in CXTPCalendarCaptionBarOffice2013Theme, and CXTPCalendarCaptionBarResourceTheme.

The documentation for this class was generated from the following file:
  • XTPCalendarCaptionBarOfficeXPTheme.h


Toolkit Pro: CXTPCalendarCaptionBarPaintManager Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPCalendarCaptionBarPaintManager Class Referenceabstract

Utility class, handles most of the drawing activities. More...

Inheritance diagram for CXTPCalendarCaptionBarPaintManager:
[legend]

Public Member Functions

CXTPCalendarCaptionBarPaintManager (CXTPCalendarCaptionBarTheme *pTheme=NULL)
Default paint manager constructor.
virtual | ~CXTPCalendarCaptionBarPaintManager ()
Default paint manager destructor.
virtual XTPCalendarTheme | GetPaintTheme () const
This member function is used to obtain current paint theme.
virtual void | RefreshMetrics ()
Performs refreshing of graphical related parameters from system settings.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Attributes

CXTPCalendarCaptionBarTheme * | m_pTheme
Store pointer to a parent theme object.
CXTPPaintManagerColor | m_clrSwitchViewBarBk
Store SwitchViewBar background color.
CXTPPaintManagerColor | m_clrScrollDateBarBk
Store ScrollDateBar background color.
CXTPPaintManagerColor | m_clrTextColor
Store the text color.
CXTPPaintManagerColor | m_clrBorders [4]
Store border line color, left = 0, top = 1, right = 2, bottom = 3.
CXTPPaintManagerColor | m_clrScrollTriangleColor
Defines date scroll arrow color.
CXTPCalendarThemeFontValue | m_fntTextFont
Store the text font.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

Utility class, handles most of the drawing activities.

It stores all settings, needed by control to perform drawing operations : fonts, colors, styles for all others classes of control. It also implements all functions for drawing typical graphical primitives, functions that directly work with device context. Can be overridden to provide another look and feel for the control. Thus, you have an easy way to change the "skin" of your control. Just provide your own implementation of CXTPCalendarCaptionBarPaintManager and don't touch the functionality of any of the other control classes.

Create a CXTPCalendarCaptionBarPaintManager by calling its constructor. Furthermore, you can call get and set functions to change settings as needed.

Constructor & Destructor Documentation

◆ CXTPCalendarCaptionBarPaintManager()

CXTPCalendarCaptionBarPaintManager ( CXTPCalendarCaptionBarTheme * pTheme = NULL )

Default paint manager constructor.

Parameters
pTheme A pointer to CXTPCalendarCaptionBarTheme object.

Handles initial initialization.

See also
RefreshMetrics()

◆ ~CXTPCalendarCaptionBarPaintManager()

virtual ~CXTPCalendarCaptionBarPaintManager ( )
virtual

Default paint manager destructor.

Handles member items deallocation.

Member Function Documentation

◆ GetPaintTheme()

AFX_INLINE XTPCalendarTheme GetPaintTheme ( ) const
virtual

This member function is used to obtain current paint theme.

Returns
A paint theme ID from enum XTPCalendarTheme.

◆ RefreshMetrics()

virtual void RefreshMetrics ( )
virtual

Performs refreshing of graphical related parameters from system settings.

Base implementation do nothing.

Reimplemented in CXTPCalendarCaptionBarOffice2000Theme, CXTPCalendarCaptionBarOffice2013Theme, CXTPCalendarCaptionBarOfficeXPTheme, and CXTPCalendarCaptionBarResourceTheme.

The documentation for this class was generated from the following file:
  • XTPCalendarCaptionBarPaintManager.h


Toolkit Pro: CXTPCalendarCaptionBarResourceTheme Class Reference

Public Member Functions | List of all members
CXTPCalendarCaptionBarResourceTheme Class Reference

CXTPCalendarCaptionBarResourceTheme is a CXTPCalendarCaptionBarOffice2013Theme derived class that represents the Resource calendar theme. More...

Inheritance diagram for CXTPCalendarCaptionBarResourceTheme:
[legend]

Public Member Functions

CXTPCalendarCaptionBarResourceTheme (CXTPCalendarCaptionBarTheme *pTheme=NULL)
Default paint manager constructor.
virtual | ~CXTPCalendarCaptionBarResourceTheme ()
Default paint manager destructor.
virtual void | RefreshMetrics ()
Performs refreshing of graphical related parameters from system settings.
virtual COLORREF | GetColor2 (LPCTSTR pcszColorName, COLORREF clrDefault)
This member function is used to read color by name from resources.
- Public Member Functions inherited from CXTPCalendarCaptionBarOffice2013Theme
CXTPCalendarCaptionBarOffice2013Theme (CXTPCalendarCaptionBarTheme *pTheme=NULL)
Default paint manager constructor.
virtual | ~CXTPCalendarCaptionBarOffice2013Theme ()
Default paint manager destructor.
- Public Member Functions inherited from CXTPCalendarCaptionBarOffice2003Theme
CXTPCalendarCaptionBarOffice2003Theme (CXTPCalendarCaptionBarTheme *pTheme=NULL)
Default paint manager constructor.
virtual | ~CXTPCalendarCaptionBarOffice2003Theme ()
Default paint manager destructor.
- Public Member Functions inherited from CXTPCalendarCaptionBarOfficeXPTheme
CXTPCalendarCaptionBarOfficeXPTheme (CXTPCalendarCaptionBarTheme *pTheme=NULL)
Default paint manager constructor.
virtual | ~CXTPCalendarCaptionBarOfficeXPTheme ()
Default paint manager destructor.
- Public Member Functions inherited from CXTPCalendarCaptionBarOffice2000Theme
CXTPCalendarCaptionBarOffice2000Theme (CXTPCalendarCaptionBarTheme *pTheme=NULL)
Default paint manager constructor.
virtual | ~CXTPCalendarCaptionBarOffice2000Theme ()
Default paint manager destructor.
- Public Member Functions inherited from CXTPCalendarCaptionBarPaintManager
CXTPCalendarCaptionBarPaintManager (CXTPCalendarCaptionBarTheme *pTheme=NULL)
Default paint manager constructor.
virtual | ~CXTPCalendarCaptionBarPaintManager ()
Default paint manager destructor.
virtual XTPCalendarTheme | GetPaintTheme () const
This member function is used to obtain current paint theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Attributes inherited from CXTPCalendarCaptionBarOffice2013Theme
- Protected Attributes inherited from CXTPCalendarCaptionBarPaintManager
CXTPCalendarCaptionBarTheme * | m_pTheme
Store pointer to a parent theme object.
CXTPPaintManagerColor | m_clrSwitchViewBarBk
Store SwitchViewBar background color.
CXTPPaintManagerColor | m_clrScrollDateBarBk
Store ScrollDateBar background color.
CXTPPaintManagerColor | m_clrTextColor
Store the text color.
CXTPPaintManagerColor | m_clrBorders [4]
Store border line color, left = 0, top = 1, right = 2, bottom = 3.
CXTPPaintManagerColor | m_clrScrollTriangleColor
Defines date scroll arrow color.
CXTPCalendarThemeFontValue | m_fntTextFont
Store the text font.

Detailed Description

CXTPCalendarCaptionBarResourceTheme is a CXTPCalendarCaptionBarOffice2013Theme derived class that represents the Resource calendar theme.

Constructor & Destructor Documentation

◆ CXTPCalendarCaptionBarResourceTheme()

CXTPCalendarCaptionBarResourceTheme ( CXTPCalendarCaptionBarTheme * pTheme = NULL )

Default paint manager constructor.

Parameters
pTheme A pointer to CXTPCalendarCaptionBarTheme object.

Handles initial initialization.

See also
RefreshMetrics()

◆ ~CXTPCalendarCaptionBarResourceTheme()

virtual ~CXTPCalendarCaptionBarResourceTheme ( )
virtual

Default paint manager destructor.

Handles member items deallocation.

Member Function Documentation

◆ GetColor2()

virtual COLORREF GetColor2 | ( | LPCTSTR | pcszColorName,
 |  | COLORREF | clrDefault )
 virtual

This member function is used to read color by name from resources.

Parameters
pcszColorName | string with Color Name
clrDefault | COLORREF of default color
Returns
A RGB color value.

◆ RefreshMetrics()

virtual void RefreshMetrics ( )
virtual

Performs refreshing of graphical related parameters from system settings.

Base implementation do nothing.

Reimplemented from CXTPCalendarCaptionBarOffice2013Theme.

The documentation for this class was generated from the following file:
  • XTPCalendarCaptionBarResourceTheme.h


Toolkit Pro: CXTPCalendarCaptionBarTheme Class Reference

Public Member Functions | Public Attributes | Protected Member Functions | Protected Attributes | List of all members
CXTPCalendarCaptionBarTheme Class Reference

This class CalendarCaptionBar control drawing, user interaction logic and interaction logic with attached Calendar control. More...

Inheritance diagram for CXTPCalendarCaptionBarTheme:
[legend]

Public Member Functions

CXTPCalendarCaptionBarTheme ()
Default object constructor.
virtual | ~CXTPCalendarCaptionBarTheme ()
Default object destructor.
virtual CRect | CalcMinRect (CDC *pDC=NULL, BOOL bExactSize=FALSE)
This member function retrieves the minimum size required to show a CaptionBar control.
virtual void | AdjustLayout (CDC *pDC, const CRect &rcRect)
This member function is used to adjust the object's layout depending on the provided bounding rectangle.
virtual void | RefreshMetrics ()
Performs refreshing of graphical related parameters from system settings.
virtual void | Redraw (BOOL bUpdateNow=FALSE)
This member function initiates the CalendarCaptionBar control's redrawing.
BOOL | IsSwitchViewButtons () const
This member functions is used to get is CaptionBar object visible.
BOOL | IsScrollDateButtons () const
This member functions is used to get is Scroll Date Buttons object visible.
BOOL | IsDateLabel () const
This member functions is used to get is Date Label object visible.
BOOL | IsExpandButton () const
This member functions is used to get is Expand Button object visible.
void | SetSwitchViewButtons (BOOL bVisible)
This member function is used to set visible Switch View Buttons object's state.
void | SetScrollDateButtons (BOOL bVisible)
This member functions is used to set Scroll Date Buttons object visible or not.
void | SetDateLabel (BOOL bVisible)
This member functions is used to set Date Label object visible or not.
void | SetExpandButton (BOOL bVisible)
This member functions is used to set Expand Button object visible or not.
void | SetExpandButtonCheck (BOOL bCheck)
This member functions is used to set Expand Button Checked state.
BOOL | GetExpandButtonCheck ()
This member functions is used to get is Expand Button object checked.
virtual XTPCalendarTheme | GetPaintTheme () const
This member function is used to obtain current paint theme.
virtual void | SetPaintTheme (XTPCalendarTheme nTheme)
This member function is used to set current paint theme.
virtual void | SetPaintTheme (CXTPCalendarCaptionBarPaintManager *pPaintManager)
This member function is used to set current paint theme.
CXTPNotifyConnection * GetConnection ()
This member function is used to get Notify Connection object.
virtual void | Draw (CDC *pDC)
This member function is used to draw the object content utilizing the specified device context.
virtual void | DrawBorders (CDC *pDC, const CRect &rcRect, const CRect &rcBorders)
This member function is used to draw the object borders.
virtual const CRect & | GetRect ()
This member function is used to obtain an object rectangle.
CWnd * | GetOwnerWnd () const
This member function is used to obtain an owner (parent, host) window.
virtual void | SetOwner (CXTPCalendarCaptionBarControl *pCaptionBar)
This member function is used to set owner (parent, host) window.
virtual void | AttachCalendar (CXTPCalendarControl *pCalendar)
This member function is used to attach to CalendarControl to interact as a single control.
virtual CXTPCalendarControl * | GetCalendarCtrl () const
This member function is used to obtain attached calendar control.
virtual void | UpdateControlsState ()
This member function is called to update CaptionBar controls states correspondingly to attached calendar control.
virtual void | OnPartClick (int nPartID)
This member function is called when user click on the caption bar element (part).
CXTPCalendarCaptionBarPaintManager * | GetPaintManager () const
Gives access to theme paint manager.
BOOL | IsOneLine ()
This member functions is used to get is CaptionBar layout use 1-line shape.
void | SetOneLine (BOOL bSet)
This member functions is used to set CaptionBar layout to use 1-line shape.
- Public Member Functions inherited from CXTPCalendarWMHandler
CXTPCalendarWMHandler ()
Default object constructor.
virtual BOOL | OnLButtonDown (UINT nFlags, CPoint point)
This member function is used to process left mouse button down events.
virtual BOOL | OnLButtonUp (UINT nFlags, CPoint point)
This member function is used to process left mouse button up events.
virtual BOOL | OnLButtonDblClk (UINT nFlags, CPoint point)
This member function is used to process left mouse button double click events.
virtual void | OnChar (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process keyboard events.
virtual void | OnKeyDown (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process key-down keyboard events.
virtual void | OnKeyUp (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process key-up keyboard events.
virtual BOOL | OnSysKeyDown (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process key-up keyboard events.
virtual BOOL | OnWndMsg (UINT message, WPARAM wParam, LPARAM lParam, LRESULT *pResult)
This method is called by framework after default message processing.
virtual void | OnPostAdjustLayout ()
This member function is used to perform additional adjustments in some kinds of views.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Public Attributes

double | m_dScale
The scale.
BOOL | m_bTimelineEnable
Flag to show (and able to use) button to toggle TimeLine mode.
BOOL | m_bMulticolumnsEnable
Flag to show (and able to use) button to toggle Multi-Column / 2-Column Week modes.
CXTPCalendarCaptionBarControl * | m_pCaptionBar
Store pointer owner CaptionBar control.

Protected Member Functions

virtual int | GetChildHandlersCount () const
This member function is used to obtain the number of CXTPCalendarWMHandler elements in the descendant handlers collection.
virtual CXTPCalendarWMHandler * | GetChildHandlerAt (int nIndex) const
Call this method to get a handler object at the specified numeric index.
virtual void | OnBeforeDestroy ()
This member function is called by the framework before destroying the view.
virtual void | OnMouseMove (UINT nFlags, CPoint point)
This member function is used to process mouse movement events.
virtual BOOL | OnTimer (UINT_PTR uTimerID)
The framework calls this member function after each interval specified in the SetTimer member function.

Protected Attributes

CXTPCalendarControl * | m_pCalendar
Store pointer attached calendar control.
CRect | m_rcRect
Store object rect.
UINT_PTR | m_nCheckHotStateTimerID
Store timer ID to refresh controls hot state.
CXTPSwitchViewButtonPart * | m_pButtonViewDay
Store Switch to DayView button part object.
CXTPSwitchViewButtonPart * | m_pButtonViewWeek
Store Switch to WeekView button part object.
CXTPSwitchViewButtonPart * | m_pButtonViewMonth
Store Switch to MonthView button part object.
CXTPRadioButtonPart * | m_pShowWorkWeek
Store Show Work Week radio button part object.
CXTPRadioButtonPart * | m_pShowFullWeek
Store Show Full Week radio button part object.
CXTPCheckboxButtonPart * | m_pShowMcWeek
Store Show Multicolumns Week check box part object.
CXTPCheckboxButtonPart * | m_pShowTimeline
Store Show Timeline check box part object.
CXTPScrollDateButtonPart * | m_pScrollPrevDate
Store Scroll Date Prev button part object.
CXTPScrollDateButtonPart * | m_pScrollNextDate
Store Scroll Date Next button part object.
CXTPDateLabelPart * | m_pDateLabel
Store Date Label part object.
CXTPExpandButtonPart * | m_pExpandButton
Store Expand button part object.
BOOL | m_bIsSwitchViewButtons
Store option is SwitchViewBar visible.
BOOL | m_bIsScrollDateButtons
Store option is ScrollDate buttons visible.
BOOL | m_bIsDateLabel
Store option is date Label visible.
BOOL | m_bIsExpandButton
Store option is Expand button visible.
BOOL | m_bIsOneLine
flag to present 1-line (if TRUE) or 2-lines object layout

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

This class CalendarCaptionBar control drawing, user interaction logic and interaction logic with attached Calendar control.

paint theme.

See also
CXTPCalendarCaptionBarTheme

Constructor & Destructor Documentation

◆ CXTPCalendarCaptionBarTheme()

CXTPCalendarCaptionBarTheme ( )

Default object constructor.

See also
~CXTPCalendarCaptionBarTheme

◆ ~CXTPCalendarCaptionBarTheme()

virtual ~CXTPCalendarCaptionBarTheme ( )
virtual

Default object destructor.

See also
CXTPCalendarCaptionBarTheme()

Member Function Documentation

◆ AdjustLayout()

virtual void AdjustLayout | ( | CDC * | pDC,
 |  | const CRect & | rcRect )
 virtual

This member function is used to adjust the object's layout depending on the provided bounding rectangle.

Parameters
pDC | Pointer to a valid device context (may be NULL).
rcRect | A CRect object containing the dimensions of the bounding rectangle for this part.

◆ AttachCalendar()

virtual void AttachCalendar ( CXTPCalendarControl * pCalendar )
virtual

This member function is used to attach to CalendarControl to interact as a single control.

Parameters
pCalendar A pointer to CXTPCalendarControl object or set as NULL to detach from calendar.
See also
GetCalendarCtrl

◆ CalcMinRect()

virtual CRect CalcMinRect | ( | CDC * | pDC = NULL,
 |  | BOOL | bExactSize = FALSE )
 virtual

This member function retrieves the minimum size required to show a CaptionBar control.

Parameters
pDC | Pointer to a valid device context (may be NULL).
bExactSize | BOOL flag to make Caption Bar minimum height if TRUE and 11 pixels more if not (esthetic choice)
Returns
A minimum rectangle required to show CaptionBar control.
See also
CXTPCalendarCaptionBarControl::CalcMinRect

◆ Draw()

virtual void Draw ( CDC * pDC )
virtual

This member function is used to draw the object content utilizing the specified device context.

Parameters
pDC Pointer to a valid device context.

◆ DrawBorders()

virtual void DrawBorders | ( | CDC * | pDC,
 |  | const CRect & | rcRect,
 |  | const CRect & | rcBorders )
 virtual

This member function is used to draw the object borders.

Parameters
pDC | Pointer to a valid device context.
rcRect | object rectangle
rcBorders | border rectangle

◆ GetCalendarCtrl()

AFX_INLINE CXTPCalendarControl * GetCalendarCtrl ( ) const
virtual

This member function is used to obtain attached calendar control.

Returns
A pointer to CXTPCalendarControl object.

◆ GetChildHandlerAt()

virtual CXTPCalendarWMHandler * GetChildHandlerAt ( int nIndex ) const
protectedvirtual

Call this method to get a handler object at the specified numeric index.

Parameters
nIndex An integer index that is greater than or equal to 0 and less than the value returned by GetChildHandlersCount.

Returns the array element at the specified index.

Returns
The pointer to the CXTPCalendarWMHandler element currently at this index.

Reimplemented from CXTPCalendarWMHandler.

◆ GetChildHandlersCount()

virtual int GetChildHandlersCount ( ) const
protectedvirtual

This member function is used to obtain the number of CXTPCalendarWMHandler elements in the descendant handlers collection.

Call this method to retrieve the number of elements in the array. Because indexes are zero-based, the size is 1 greater than the largest index.

This number shows a count of single day views for a day/week/month view, a number of resource groups for a single day view, a number of event views for a resource group view, and so on.

Returns
A count of descendant handlers.
See also
CXTPCalendarWMHandler overview

Reimplemented from CXTPCalendarWMHandler.

◆ GetConnection()

CXTPNotifyConnection * GetConnection ( )

This member function is used to get Notify Connection object.

Returns
pointer to CXTPNotifyConnection object;

◆ GetExpandButtonCheck()

BOOL GetExpandButtonCheck ( )

This member functions is used to get is Expand Button object checked.

Returns
TRUE if corresponding object is checked, FALSE otherwise.

◆ GetOwnerWnd()

CWnd * GetOwnerWnd ( ) const

This member function is used to obtain an owner (parent, host) window.

Returns
A pointer to CWnd object.

◆ GetPaintManager()

AFX_INLINE CXTPCalendarCaptionBarPaintManager * GetPaintManager ( ) const

Gives access to theme paint manager.

Returns
A pointer to a theme paint manager or NULL of no paint manager is set.

◆ GetPaintTheme()

virtual XTPCalendarTheme GetPaintTheme ( ) const
virtual

This member function is used to obtain current paint theme.

Returns
A paint theme ID from enum XTPCalendarTheme.

◆ GetRect()

AFX_INLINE const CRect & GetRect ( )
virtual

This member function is used to obtain an object rectangle.

Returns
An object rectangle.

◆ IsDateLabel()

AFX_INLINE BOOL IsDateLabel ( ) const

This member functions is used to get is Date Label object visible.

Returns
TRUE if corresponding object is visible, FALSE otherwise.

◆ IsExpandButton()

AFX_INLINE BOOL IsExpandButton ( ) const

This member functions is used to get is Expand Button object visible.

Returns
TRUE if corresponding object is visible, FALSE otherwise.

◆ IsOneLine()

BOOL IsOneLine ( )
inline

This member functions is used to get is CaptionBar layout use 1-line shape.

Returns
TRUE if corresponding object use 1-line shape, FALSE if 2-lines shape.

◆ IsScrollDateButtons()

AFX_INLINE BOOL IsScrollDateButtons ( ) const

This member functions is used to get is Scroll Date Buttons object visible.

Returns
TRUE if corresponding object is visible, FALSE otherwise.

◆ IsSwitchViewButtons()

AFX_INLINE BOOL IsSwitchViewButtons ( ) const

This member functions is used to get is CaptionBar object visible.

Returns
TRUE if corresponding object is visible, FALSE otherwise.
See also
SetSwitchViewButtons
SetScrollDateButtons
SetDateLabel

◆ OnMouseMove()

virtual void OnMouseMove | ( | UINT | nFlags,
 |  | CPoint | point )
 protectedvirtual

This member function is used to process mouse movement events.

Parameters
nFlags | A UINT that indicates whether various virtual keys are down.
point | A CPoint object that specifies the x- and y- coordinates of the cursor. These coordinates are always relative to the upper-left corner of the window.

This method is called by the CalendarView when the user moves the mouse cursor or stylus.

Reimplemented from CXTPCalendarWMHandler.

◆ OnPartClick()

virtual void OnPartClick ( int nPartID )
virtual

This member function is called when user click on the caption bar element (part).

Parameters
nPartID An identifier of clicked part object.

◆ OnTimer()

virtual BOOL OnTimer ( UINT_PTR uTimerID )
protectedvirtual

The framework calls this member function after each interval specified in the SetTimer member function.

Parameters
uTimerID A UINT that is used to specify the identifier of the timer.
Returns
TRUE if the message is handled properly, FALSE otherwise.

Reimplemented from CXTPCalendarWMHandler.

◆ Redraw()

virtual void Redraw ( BOOL bUpdateNow = FALSE )
virtual

This member function initiates the CalendarCaptionBar control's redrawing.

Parameters
bUpdateNow Set this parameter to TRUE if you'd like to force control's redrawing.

Call this member function if you want to request or force the control's redrawing.

See also
CXTPCalendarCaptionBarTheme::Redraw
AdjustLayout

◆ RefreshMetrics()

virtual void RefreshMetrics ( )
virtual

Performs refreshing of graphical related parameters from system settings.

Base implementation do nothing.

◆ SetDateLabel()

AFX_INLINE void SetDateLabel ( BOOL bVisible )

This member functions is used to set Date Label object visible or not.

Parameters
bVisible A BOOL value to define visible state.

◆ SetExpandButton()

AFX_INLINE void SetExpandButton ( BOOL bVisible )

This member functions is used to set Expand Button object visible or not.

Parameters
bVisible A BOOL value to define visible state.

◆ SetExpandButtonCheck()

void SetExpandButtonCheck ( BOOL bCheck )

This member functions is used to set Expand Button Checked state.

Parameters
bCheck A BOOL value to define checked state.

◆ SetOneLine()

void SetOneLine ( BOOL bSet )
inline

This member functions is used to set CaptionBar layout to use 1-line shape.

Parameters
bSet BOOL (TRUE to use 1-line shape, FALSE to use 2-lines shape)

◆ SetOwner()

virtual void SetOwner ( CXTPCalendarCaptionBarControl * pCaptionBar )
virtual

This member function is used to set owner (parent, host) window.

CXTPCalendarCaptionBarControl::SetTheme call this method.

Parameters
pCaptionBar A pointer to CXTPCalendarCaptionBarControl window.

◆ SetPaintTheme() [1/2]

virtual void SetPaintTheme ( CXTPCalendarCaptionBarPaintManager * pPaintManager )
virtual

This member function is used to set current paint theme.

Parameters
pPaintManager Pointer to a valid CXTPCalendarCaptionBarPaintManager derived class.

◆ SetPaintTheme() [2/2]

virtual void SetPaintTheme ( XTPCalendarTheme nTheme )
virtual

This member function is used to set current paint theme.

Parameters
nTheme A paint theme ID from enum XTPCalendarTheme.

◆ SetScrollDateButtons()

AFX_INLINE void SetScrollDateButtons ( BOOL bVisible )

This member functions is used to set Scroll Date Buttons object visible or not.

Parameters
bVisible A BOOL value to define visible state.

◆ SetSwitchViewButtons()

AFX_INLINE void SetSwitchViewButtons ( BOOL bVisible )

This member function is used to set visible Switch View Buttons object's state.

Parameters
bVisible A BOOL value to define visible state.
See also
GetVisible
The documentation for this class was generated from the following file:
  • XTPCalendarCaptionBarTheme.h


Toolkit Pro: CXTPCalendarCaptionBarThemePart Class Reference

Public Member Functions | Public Attributes | Protected Attributes | List of all members
CXTPCalendarCaptionBarThemePart Class Reference

This class used as a base class for graphical Parts of CalendarCaptionBar paint theme. More...

Inheritance diagram for CXTPCalendarCaptionBarThemePart:
[legend]

Public Member Functions

CXTPCalendarCaptionBarThemePart (CXTPCalendarCaptionBarTheme *pTheme, int nPartID)
Default object constructor.
virtual | ~CXTPCalendarCaptionBarThemePart ()
Default object destructor.
virtual void | AdjustLayout (CDC *pDC, const CRect &rcRect)
This member function is used to adjust the object's layout depending on the provided bounding rectangle.
virtual void | Draw (CDC *pDC)
This member function is used to draw the part content utilizing the specified device context.
virtual void | RefreshMetrics ()
Performs refreshing of graphical related parameters from system settings.
virtual void | Redraw (BOOL bUpdateNow=FALSE)
This member function initiates the CalendarCaptionBar control's redrawing.
virtual BOOL | HitTest (const CPoint &pt) const
This member function is used to determine is the specified point over visible object rectangle.
virtual CXTPCalendarCaptionBarTheme * | GetTheme () const
This member function is used to obtain pointer to parent CXTPCalendarCaptionBarTheme object.
virtual XTPCalendarTheme | GetPaintTheme () const
This member function is used to obtain current paint theme.
virtual int | GetPartID () const
This member function is used to obtain an object identifier.
virtual CRect | GetRect () const
This member function is used to obtain an object rectangle.
virtual CString | GetText () const
This member function is used to obtain an object text.
virtual void | SetText (LPCTSTR pcszText)
This member function is used to set object text.
virtual BOOL | IsVisible () const
This member function is used to get is part object visible.
virtual void | SetVisible (BOOL bVisible)
This member function is used to set visible object's state.
virtual int | GetCheck () const
This member function is used to get checked state.
virtual void | SetCheck (int nCheck)
This member function is used to set checked state.
int | GetState () const
This member function is used to get object state (flags from CXTPCalendarCaptionBarThemePart::EStates enum).
virtual void | SetState (int nState)
This member function is used to set object state as set of flags from CXTPCalendarCaptionBarThemePart::EStates enum.
virtual COLORREF | GetTextColor ()
This member function is used to get object text color.
CXTPCalendarCaptionBarPaintManager * | GetPaintManager () const
Gets the paint manager.
virtual void | OnMouseMove (UINT nFlags, CPoint point)
This member function is used to processes mouse movement events.
virtual BOOL | OnLButtonDown (UINT nFlags, CPoint point)
This member function is used to process left mouse button down events.
virtual BOOL | OnLButtonUp (UINT nFlags, CPoint point)
This member function is used to process left mouse button up events.
- Public Member Functions inherited from CXTPCalendarWMHandler
CXTPCalendarWMHandler ()
Default object constructor.
virtual int | GetChildHandlersCount () const
This member function is used to obtain the number of CXTPCalendarWMHandler elements in the descendant handlers collection.
virtual CXTPCalendarWMHandler * | GetChildHandlerAt (int nIndex) const
Call this method to get a handler object at the specified numeric index.
virtual BOOL | OnLButtonDblClk (UINT nFlags, CPoint point)
This member function is used to process left mouse button double click events.
virtual void | OnChar (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process keyboard events.
virtual void | OnKeyDown (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process key-down keyboard events.
virtual void | OnKeyUp (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process key-up keyboard events.
virtual BOOL | OnSysKeyDown (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process key-up keyboard events.
virtual BOOL | OnTimer (UINT_PTR uTimerID)
The framework calls this member function after each interval specified in the SetTimer member function.
virtual BOOL | OnWndMsg (UINT message, WPARAM wParam, LPARAM lParam, LRESULT *pResult)
This method is called by framework after default message processing.
virtual void | OnPostAdjustLayout ()
This member function is used to perform additional adjustments in some kinds of views.
virtual void | OnBeforeDestroy ()
This member function is called by the framework before destroying the view.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Public Attributes

CXTPPaintManagerColor | m_clrTextColor
Store the object's text color.
CRect | m_rcRect
Store a Part rectangle.
int | m_nState
Store a Part state.
CString | m_strText
Store a Part text.

Protected Attributes

CXTPCalendarCaptionBarTheme * | m_pTheme
Store pointer to a parent theme object.
int | m_nPartID
Store a Part ID.
BOOL | m_bVisible
Store a Part visible state.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

This class used as a base class for graphical Parts of CalendarCaptionBar paint theme.

See also
CXTPCalendarCaptionBarTheme

Constructor & Destructor Documentation

◆ CXTPCalendarCaptionBarThemePart()

CXTPCalendarCaptionBarThemePart | ( | CXTPCalendarCaptionBarTheme * | pTheme,
 |  | int | nPartID )

Default object constructor.

Parameters
pTheme | Pointer to parent CXTPCalendarCaptionBarTheme object.
nPartID | An object identifier (value from enum XTPEnumCalendarCaptionBarThemeObject).
See also
~CXTPCalendarCaptionBarThemePart

◆ ~CXTPCalendarCaptionBarThemePart()

virtual ~CXTPCalendarCaptionBarThemePart ( )
virtual

Default object destructor.

See also
CXTPCalendarCaptionBarThemePart

Member Function Documentation

◆ AdjustLayout()

virtual void AdjustLayout | ( | CDC * | pDC,
 |  | const CRect & | rcRect )
 virtual

This member function is used to adjust the object's layout depending on the provided bounding rectangle.

Parameters
pDC | Pointer to a valid device context (may be NULL).
rcRect | A CRect object containing the dimensions of the bounding rectangle for this part.

Reimplemented in CXTPCheckboxButtonPart, CXTPExpandButtonPart, CXTPRadioButtonPart, CXTPScrollDateButtonPart, and CXTPSwitchViewButtonPart.

◆ Draw()

virtual void Draw ( CDC * pDC )
virtual

This member function is used to draw the part content utilizing the specified device context.

Parameters
pDC Pointer to a valid device context.

Reimplemented in CXTPCheckboxButtonPart, CXTPDateLabelPart, CXTPExpandButtonPart, CXTPRadioButtonPart, CXTPScrollDateButtonPart, and CXTPSwitchViewButtonPart.

◆ GetCheck()

AFX_INLINE int GetCheck ( ) const
virtual

This member function is used to get checked state.

Returns
Nonzero if object is checked, 0 (zero) otherwise.
See also
SetCheck

◆ GetPaintManager()

CXTPCalendarCaptionBarPaintManager * GetPaintManager ( ) const

Gets the paint manager.

Returns
A pointer to the paint manager.

◆ GetPaintTheme()

virtual XTPCalendarTheme GetPaintTheme ( ) const
virtual

This member function is used to obtain current paint theme.

Returns
A paint theme ID from enum XTPCalendarTheme.

◆ GetPartID()

AFX_INLINE int GetPartID ( ) const
virtual

This member function is used to obtain an object identifier.

Returns
An object ID (value from enum XTPEnumCalendarCaptionBarThemeObject).

◆ GetRect()

AFX_INLINE CRect GetRect ( ) const
virtual

This member function is used to obtain an object rectangle.

Returns
An object rectangle.

◆ GetState()

AFX_INLINE int GetState ( ) const

This member function is used to get object state (flags from CXTPCalendarCaptionBarThemePart::EStates enum).

Returns
Current object state flags.
See also
SetState

◆ GetText()

AFX_INLINE CString GetText ( ) const
virtual

This member function is used to obtain an object text.

Returns
An object text as CString.
See also
SetText

◆ GetTextColor()

virtual COLORREF GetTextColor ( )
virtual

This member function is used to get object text color.

Returns
m_clrTextColor value returned if it is defined, otherwise GetTheme()->m_clrTextColor value returned.
See also
CXTPCalendarCaptionBarThemePart::m_clrTextColor,
CXTPCalendarCaptionBarTheme::m_clrTextColor

◆ GetTheme()

AFX_INLINE CXTPCalendarCaptionBarTheme * GetTheme ( ) const
virtual

This member function is used to obtain pointer to parent CXTPCalendarCaptionBarTheme object.

Returns
A pointer to CXTPCalendarCaptionBarTheme object.

◆ HitTest()

virtual BOOL HitTest ( const CPoint & pt ) const
virtual

This member function is used to determine is the specified point over visible object rectangle.

Parameters
pt A CPoint object reference that contains the point to test.
Returns
TRUE if the point is inside the caption bar, FALSE else.

◆ IsVisible()

AFX_INLINE BOOL IsVisible ( ) const
virtual

This member function is used to get is part object visible.

Returns
TRUE if object is visible, FALSE otherwise.
See also
SetVisible

◆ OnLButtonDown()

virtual BOOL OnLButtonDown | ( | UINT | nFlags,
 |  | CPoint | point )
 virtual

This member function is used to process left mouse button down events.

Parameters
nFlags | An int that indicates whether various virtual keys are down.
point | A CPoint object that specifies the x- and y- coordinates of the cursor. These coordinates are always relative to the upper-left corner of the window.
Returns
TRUE if the message is handled successfully, FALSE else.

This method is called by the parent object when the user presses the left mouse button.

Reimplemented from CXTPCalendarWMHandler.

Reimplemented in CXTPScrollDateButtonPart.

◆ OnLButtonUp()

virtual BOOL OnLButtonUp | ( | UINT | nFlags,
 |  | CPoint | point )
 virtual

This member function is used to process left mouse button up events.

Parameters
nFlags | An int that indicates whether various virtual keys are down.
point | A CPoint object that specifies the x- and y- coordinates of the cursor. These coordinates are always relative to the upper-left corner of the window.
Returns
TRUE if the message is handled successfully, FALSE else.

This method is called by the parent object when the user releases the left mouse button.

Reimplemented from CXTPCalendarWMHandler.

◆ OnMouseMove()

virtual void OnMouseMove | ( | UINT | nFlags,
 |  | CPoint | point )
 virtual

This member function is used to processes mouse movement events.

Parameters
nFlags | A UINT that is used to indicate whether various virtual keys are down.
point | A CPoint that specifies the x- and y- coordinates of the cursor. These coordinates are always relative to the upper-left corner of the window.

This method is called by the parent object when the user moves the mouse cursor.

Reimplemented from CXTPCalendarWMHandler.

◆ Redraw()

virtual void Redraw ( BOOL bUpdateNow = FALSE )
virtual

This member function initiates the CalendarCaptionBar control's redrawing.

Parameters
bUpdateNow Set this parameter to TRUE if you'd like to force control's redrawing.

Call this member function if you want to request or force the control's redrawing.

See also
CXTPCalendarCaptionBarTheme::Redraw
AdjustLayout

◆ RefreshMetrics()

virtual void RefreshMetrics ( )
inlinevirtual

Performs refreshing of graphical related parameters from system settings.

Base implementation do nothing.

Reimplemented in CXTPCheckboxButtonPart, CXTPDateLabelPart, CXTPRadioButtonPart, and CXTPSwitchViewButtonPart.

◆ SetCheck()

AFX_INLINE void SetCheck ( int nCheck )
virtual

This member function is used to set checked state.

Parameters
nCheck Set as Nonzero if object is checked, 0 (zero) otherwise.
See also
GetCheck

◆ SetState()

AFX_INLINE void SetState ( int nState )
virtual

This member function is used to set object state as set of flags from CXTPCalendarCaptionBarThemePart::EStates enum.

Parameters
nState Current object state flags.
See also
SetState

◆ SetText()

AFX_INLINE void SetText ( LPCTSTR pcszText )
virtual

This member function is used to set object text.

Parameters
pcszText An object text to set.
See also
GetText

◆ SetVisible()

AFX_INLINE void SetVisible ( BOOL bVisible )
virtual

This member function is used to set visible object's state.

Parameters
bVisible - A BOOL value to define visible state.
See also
GetVisible
The documentation for this class was generated from the following file:
  • XTPCalendarCaptionBarThemePart.h


Toolkit Pro: CXTPCalendarCaptionBarVisualStudio2015Theme Class Reference

Public Member Functions | List of all members
CXTPCalendarCaptionBarVisualStudio2015Theme Class Reference

CXTPCalendarCaptionBarVisualStudio2015Theme is a CXTPCalendarCaptionBarOffice2013Theme derived class that represents the Visual Studio 2015 white calendar theme. More...

Inheritance diagram for CXTPCalendarCaptionBarVisualStudio2015Theme:
[legend]

Public Member Functions

CXTPCalendarCaptionBarVisualStudio2015Theme (CXTPCalendarCaptionBarTheme *pTheme=NULL)
Default paint manager constructor.
virtual | ~CXTPCalendarCaptionBarVisualStudio2015Theme ()
Default paint manager destructor.
- Public Member Functions inherited from CXTPCalendarCaptionBarOffice2013Theme
CXTPCalendarCaptionBarOffice2013Theme (CXTPCalendarCaptionBarTheme *pTheme=NULL)
Default paint manager constructor.
virtual | ~CXTPCalendarCaptionBarOffice2013Theme ()
Default paint manager destructor.
virtual void | RefreshMetrics ()
Performs refreshing of graphical related parameters from system settings.
- Public Member Functions inherited from CXTPCalendarCaptionBarOffice2003Theme
CXTPCalendarCaptionBarOffice2003Theme (CXTPCalendarCaptionBarTheme *pTheme=NULL)
Default paint manager constructor.
virtual | ~CXTPCalendarCaptionBarOffice2003Theme ()
Default paint manager destructor.
- Public Member Functions inherited from CXTPCalendarCaptionBarOfficeXPTheme
CXTPCalendarCaptionBarOfficeXPTheme (CXTPCalendarCaptionBarTheme *pTheme=NULL)
Default paint manager constructor.
virtual | ~CXTPCalendarCaptionBarOfficeXPTheme ()
Default paint manager destructor.
- Public Member Functions inherited from CXTPCalendarCaptionBarOffice2000Theme
CXTPCalendarCaptionBarOffice2000Theme (CXTPCalendarCaptionBarTheme *pTheme=NULL)
Default paint manager constructor.
virtual | ~CXTPCalendarCaptionBarOffice2000Theme ()
Default paint manager destructor.
- Public Member Functions inherited from CXTPCalendarCaptionBarPaintManager
CXTPCalendarCaptionBarPaintManager (CXTPCalendarCaptionBarTheme *pTheme=NULL)
Default paint manager constructor.
virtual | ~CXTPCalendarCaptionBarPaintManager ()
Default paint manager destructor.
virtual XTPCalendarTheme | GetPaintTheme () const
This member function is used to obtain current paint theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Attributes inherited from CXTPCalendarCaptionBarOffice2013Theme
- Protected Attributes inherited from CXTPCalendarCaptionBarPaintManager
CXTPCalendarCaptionBarTheme * | m_pTheme
Store pointer to a parent theme object.
CXTPPaintManagerColor | m_clrSwitchViewBarBk
Store SwitchViewBar background color.
CXTPPaintManagerColor | m_clrScrollDateBarBk
Store ScrollDateBar background color.
CXTPPaintManagerColor | m_clrTextColor
Store the text color.
CXTPPaintManagerColor | m_clrBorders [4]
Store border line color, left = 0, top = 1, right = 2, bottom = 3.
CXTPPaintManagerColor | m_clrScrollTriangleColor
Defines date scroll arrow color.
CXTPCalendarThemeFontValue | m_fntTextFont
Store the text font.

Detailed Description

CXTPCalendarCaptionBarVisualStudio2015Theme is a CXTPCalendarCaptionBarOffice2013Theme derived class that represents the Visual Studio 2015 white calendar theme.

Constructor & Destructor Documentation

◆ CXTPCalendarCaptionBarVisualStudio2015Theme()

CXTPCalendarCaptionBarVisualStudio2015Theme ( CXTPCalendarCaptionBarTheme * pTheme = NULL )

Default paint manager constructor.

Parameters
pTheme A pointer to CXTPCalendarCaptionBarTheme object.

Handles initial initialization.

See also
RefreshMetrics()

◆ ~CXTPCalendarCaptionBarVisualStudio2015Theme()

virtual ~CXTPCalendarCaptionBarVisualStudio2015Theme ( )
virtual

Default paint manager destructor.

Handles member items deallocation.

The documentation for this class was generated from the following file:
  • XTPCalendarCaptionBarVisualStudio2015Theme.h


Toolkit Pro: CXTPCalendarCaptionBarVisualStudio2017Theme Class Reference

Public Member Functions | List of all members
CXTPCalendarCaptionBarVisualStudio2017Theme Class Reference

CXTPCalendarCaptionBarVisualStudio2017Theme is a CXTPCalendarCaptionBarOffice2013Theme derived class that represents the Visual Studio 2017 white calendar theme. More...

Inheritance diagram for CXTPCalendarCaptionBarVisualStudio2017Theme:
[legend]

Public Member Functions

CXTPCalendarCaptionBarVisualStudio2017Theme (CXTPCalendarCaptionBarTheme *pTheme=NULL)
Default paint manager constructor.
virtual | ~CXTPCalendarCaptionBarVisualStudio2017Theme ()
Default paint manager destructor.
- Public Member Functions inherited from CXTPCalendarCaptionBarOffice2013Theme
CXTPCalendarCaptionBarOffice2013Theme (CXTPCalendarCaptionBarTheme *pTheme=NULL)
Default paint manager constructor.
virtual | ~CXTPCalendarCaptionBarOffice2013Theme ()
Default paint manager destructor.
virtual void | RefreshMetrics ()
Performs refreshing of graphical related parameters from system settings.
- Public Member Functions inherited from CXTPCalendarCaptionBarOffice2003Theme
CXTPCalendarCaptionBarOffice2003Theme (CXTPCalendarCaptionBarTheme *pTheme=NULL)
Default paint manager constructor.
virtual | ~CXTPCalendarCaptionBarOffice2003Theme ()
Default paint manager destructor.
- Public Member Functions inherited from CXTPCalendarCaptionBarOfficeXPTheme
CXTPCalendarCaptionBarOfficeXPTheme (CXTPCalendarCaptionBarTheme *pTheme=NULL)
Default paint manager constructor.
virtual | ~CXTPCalendarCaptionBarOfficeXPTheme ()
Default paint manager destructor.
- Public Member Functions inherited from CXTPCalendarCaptionBarOffice2000Theme
CXTPCalendarCaptionBarOffice2000Theme (CXTPCalendarCaptionBarTheme *pTheme=NULL)
Default paint manager constructor.
virtual | ~CXTPCalendarCaptionBarOffice2000Theme ()
Default paint manager destructor.
- Public Member Functions inherited from CXTPCalendarCaptionBarPaintManager
CXTPCalendarCaptionBarPaintManager (CXTPCalendarCaptionBarTheme *pTheme=NULL)
Default paint manager constructor.
virtual | ~CXTPCalendarCaptionBarPaintManager ()
Default paint manager destructor.
virtual XTPCalendarTheme | GetPaintTheme () const
This member function is used to obtain current paint theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Attributes inherited from CXTPCalendarCaptionBarOffice2013Theme
- Protected Attributes inherited from CXTPCalendarCaptionBarPaintManager
CXTPCalendarCaptionBarTheme * | m_pTheme
Store pointer to a parent theme object.
CXTPPaintManagerColor | m_clrSwitchViewBarBk
Store SwitchViewBar background color.
CXTPPaintManagerColor | m_clrScrollDateBarBk
Store ScrollDateBar background color.
CXTPPaintManagerColor | m_clrTextColor
Store the text color.
CXTPPaintManagerColor | m_clrBorders [4]
Store border line color, left = 0, top = 1, right = 2, bottom = 3.
CXTPPaintManagerColor | m_clrScrollTriangleColor
Defines date scroll arrow color.
CXTPCalendarThemeFontValue | m_fntTextFont
Store the text font.

Detailed Description

CXTPCalendarCaptionBarVisualStudio2017Theme is a CXTPCalendarCaptionBarOffice2013Theme derived class that represents the Visual Studio 2017 white calendar theme.

Constructor & Destructor Documentation

◆ CXTPCalendarCaptionBarVisualStudio2017Theme()

CXTPCalendarCaptionBarVisualStudio2017Theme ( CXTPCalendarCaptionBarTheme * pTheme = NULL )

Default paint manager constructor.

Parameters
pTheme A pointer to CXTPCalendarCaptionBarTheme object.

Handles initial initialization.

See also
RefreshMetrics()

◆ ~CXTPCalendarCaptionBarVisualStudio2017Theme()

virtual ~CXTPCalendarCaptionBarVisualStudio2017Theme ( )
virtual

Default paint manager destructor.

Handles member items deallocation.

The documentation for this class was generated from the following file:
  • XTPCalendarCaptionBarVisualStudio2017Theme.h


Toolkit Pro: CXTPCalendarCaptionBarVisualStudio2019Theme Class Reference

Public Member Functions | List of all members
CXTPCalendarCaptionBarVisualStudio2019Theme Class Reference

CXTPCalendarCaptionBarVisualStudio2019Theme is a CXTPCalendarCaptionBarOffice2013Theme derived class that represents the Visual Studio 2019 white calendar theme. More...

Inheritance diagram for CXTPCalendarCaptionBarVisualStudio2019Theme:
[legend]

Public Member Functions

CXTPCalendarCaptionBarVisualStudio2019Theme (CXTPCalendarCaptionBarTheme *pTheme=NULL)
Default paint manager constructor.
virtual | ~CXTPCalendarCaptionBarVisualStudio2019Theme ()
Default paint manager destructor.
- Public Member Functions inherited from CXTPCalendarCaptionBarOffice2013Theme
CXTPCalendarCaptionBarOffice2013Theme (CXTPCalendarCaptionBarTheme *pTheme=NULL)
Default paint manager constructor.
virtual | ~CXTPCalendarCaptionBarOffice2013Theme ()
Default paint manager destructor.
virtual void | RefreshMetrics ()
Performs refreshing of graphical related parameters from system settings.
- Public Member Functions inherited from CXTPCalendarCaptionBarOffice2003Theme
CXTPCalendarCaptionBarOffice2003Theme (CXTPCalendarCaptionBarTheme *pTheme=NULL)
Default paint manager constructor.
virtual | ~CXTPCalendarCaptionBarOffice2003Theme ()
Default paint manager destructor.
- Public Member Functions inherited from CXTPCalendarCaptionBarOfficeXPTheme
CXTPCalendarCaptionBarOfficeXPTheme (CXTPCalendarCaptionBarTheme *pTheme=NULL)
Default paint manager constructor.
virtual | ~CXTPCalendarCaptionBarOfficeXPTheme ()
Default paint manager destructor.
- Public Member Functions inherited from CXTPCalendarCaptionBarOffice2000Theme
CXTPCalendarCaptionBarOffice2000Theme (CXTPCalendarCaptionBarTheme *pTheme=NULL)
Default paint manager constructor.
virtual | ~CXTPCalendarCaptionBarOffice2000Theme ()
Default paint manager destructor.
- Public Member Functions inherited from CXTPCalendarCaptionBarPaintManager
CXTPCalendarCaptionBarPaintManager (CXTPCalendarCaptionBarTheme *pTheme=NULL)
Default paint manager constructor.
virtual | ~CXTPCalendarCaptionBarPaintManager ()
Default paint manager destructor.
virtual XTPCalendarTheme | GetPaintTheme () const
This member function is used to obtain current paint theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Attributes inherited from CXTPCalendarCaptionBarOffice2013Theme
- Protected Attributes inherited from CXTPCalendarCaptionBarPaintManager
CXTPCalendarCaptionBarTheme * | m_pTheme
Store pointer to a parent theme object.
CXTPPaintManagerColor | m_clrSwitchViewBarBk
Store SwitchViewBar background color.
CXTPPaintManagerColor | m_clrScrollDateBarBk
Store ScrollDateBar background color.
CXTPPaintManagerColor | m_clrTextColor
Store the text color.
CXTPPaintManagerColor | m_clrBorders [4]
Store border line color, left = 0, top = 1, right = 2, bottom = 3.
CXTPPaintManagerColor | m_clrScrollTriangleColor
Defines date scroll arrow color.
CXTPCalendarThemeFontValue | m_fntTextFont
Store the text font.

Detailed Description

CXTPCalendarCaptionBarVisualStudio2019Theme is a CXTPCalendarCaptionBarOffice2013Theme derived class that represents the Visual Studio 2019 white calendar theme.

Constructor & Destructor Documentation

◆ CXTPCalendarCaptionBarVisualStudio2019Theme()

CXTPCalendarCaptionBarVisualStudio2019Theme ( CXTPCalendarCaptionBarTheme * pTheme = NULL )

Default paint manager constructor.

Parameters
pTheme A pointer to CXTPCalendarCaptionBarTheme object.

Handles initial initialization.

See also
RefreshMetrics()

◆ ~CXTPCalendarCaptionBarVisualStudio2019Theme()

virtual ~CXTPCalendarCaptionBarVisualStudio2019Theme ( )
virtual

Default paint manager destructor.

Handles member items deallocation.

The documentation for this class was generated from the following file:
  • XTPCalendarCaptionBarVisualStudio2019Theme.h


Toolkit Pro: CXTPCalendarCaptionBarVisualStudio2022Theme Class Reference

Public Member Functions | List of all members
CXTPCalendarCaptionBarVisualStudio2022Theme Class Reference

CXTPCalendarCaptionBarVisualStudio2022Theme is a CXTPCalendarCaptionBarOffice2013Theme derived class that represents Visual Studio 2022 white calendar theme. More...

Inheritance diagram for CXTPCalendarCaptionBarVisualStudio2022Theme:
[legend]

Public Member Functions

CXTPCalendarCaptionBarVisualStudio2022Theme (CXTPCalendarCaptionBarTheme *pTheme=NULL)
Default paint manager constructor.
virtual | ~CXTPCalendarCaptionBarVisualStudio2022Theme ()
Default paint manager destructor.
- Public Member Functions inherited from CXTPCalendarCaptionBarOffice2013Theme
CXTPCalendarCaptionBarOffice2013Theme (CXTPCalendarCaptionBarTheme *pTheme=NULL)
Default paint manager constructor.
virtual | ~CXTPCalendarCaptionBarOffice2013Theme ()
Default paint manager destructor.
virtual void | RefreshMetrics ()
Performs refreshing of graphical related parameters from system settings.
- Public Member Functions inherited from CXTPCalendarCaptionBarOffice2003Theme
CXTPCalendarCaptionBarOffice2003Theme (CXTPCalendarCaptionBarTheme *pTheme=NULL)
Default paint manager constructor.
virtual | ~CXTPCalendarCaptionBarOffice2003Theme ()
Default paint manager destructor.
- Public Member Functions inherited from CXTPCalendarCaptionBarOfficeXPTheme
CXTPCalendarCaptionBarOfficeXPTheme (CXTPCalendarCaptionBarTheme *pTheme=NULL)
Default paint manager constructor.
virtual | ~CXTPCalendarCaptionBarOfficeXPTheme ()
Default paint manager destructor.
- Public Member Functions inherited from CXTPCalendarCaptionBarOffice2000Theme
CXTPCalendarCaptionBarOffice2000Theme (CXTPCalendarCaptionBarTheme *pTheme=NULL)
Default paint manager constructor.
virtual | ~CXTPCalendarCaptionBarOffice2000Theme ()
Default paint manager destructor.
- Public Member Functions inherited from CXTPCalendarCaptionBarPaintManager
CXTPCalendarCaptionBarPaintManager (CXTPCalendarCaptionBarTheme *pTheme=NULL)
Default paint manager constructor.
virtual | ~CXTPCalendarCaptionBarPaintManager ()
Default paint manager destructor.
virtual XTPCalendarTheme | GetPaintTheme () const
This member function is used to obtain current paint theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Attributes inherited from CXTPCalendarCaptionBarOffice2013Theme
- Protected Attributes inherited from CXTPCalendarCaptionBarPaintManager
CXTPCalendarCaptionBarTheme * | m_pTheme
Store pointer to a parent theme object.
CXTPPaintManagerColor | m_clrSwitchViewBarBk
Store SwitchViewBar background color.
CXTPPaintManagerColor | m_clrScrollDateBarBk
Store ScrollDateBar background color.
CXTPPaintManagerColor | m_clrTextColor
Store the text color.
CXTPPaintManagerColor | m_clrBorders [4]
Store border line color, left = 0, top = 1, right = 2, bottom = 3.
CXTPPaintManagerColor | m_clrScrollTriangleColor
Defines date scroll arrow color.
CXTPCalendarThemeFontValue | m_fntTextFont
Store the text font.

Detailed Description

CXTPCalendarCaptionBarVisualStudio2022Theme is a CXTPCalendarCaptionBarOffice2013Theme derived class that represents Visual Studio 2022 white calendar theme.

Constructor & Destructor Documentation

◆ CXTPCalendarCaptionBarVisualStudio2022Theme()

CXTPCalendarCaptionBarVisualStudio2022Theme ( CXTPCalendarCaptionBarTheme * pTheme = NULL )

Default paint manager constructor.

Parameters
pTheme A pointer to CXTPCalendarCaptionBarTheme object.

Handles initial initialization.

See also
RefreshMetrics()

◆ ~CXTPCalendarCaptionBarVisualStudio2022Theme()

virtual ~CXTPCalendarCaptionBarVisualStudio2022Theme ( )
virtual

Default paint manager destructor.

Handles member items deallocation.

The documentation for this class was generated from the following file:
  • XTPCalendarCaptionBarVisualStudio2022Theme.h


Toolkit Pro: CXTPCalendarComboBoxBase Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPCalendarComboBoxBase Class Reference

This class is used as the base class for all owner drawn Calendar Event comboboxes. More...

Inheritance diagram for CXTPCalendarComboBoxBase:
[legend]

Public Member Functions

CXTPCalendarComboBoxBase ()
Standard object constructor.
virtual | ~CXTPCalendarComboBoxBase ()
Standard object destructor.
virtual BOOL | Init (CXTPCalendarEvent *pEvent, XTPCalendarTheme nTheme)
Call this member function to initialize the combobox.

Protected Member Functions

virtual void | MeasureItem (LPMEASUREITEMSTRUCT lpMIS)
This function implements measure items for custom draw.
virtual CRect | CalcColorRect (CRect rItem)
This member function is called to calculate the size for the color rectangle displayed for each item.

Detailed Description

This class is used as the base class for all owner drawn Calendar Event comboboxes.

Member Function Documentation

◆ CalcColorRect()

virtual CRect CalcColorRect ( CRect rItem )
protectedvirtual

This member function is called to calculate the size for the color rectangle displayed for each item.

Parameters
rItem Combobox client coordinates of the item.
Returns
Client coordinates of the color rectangle for the item.

◆ Init()

virtual BOOL Init | ( | CXTPCalendarEvent * | pEvent,
 |  | XTPCalendarTheme | nTheme )
 virtual

Call this member function to initialize the combobox.

Parameters
pEvent | Pointer to the selected calendar event.
nTheme | Current Calendar theme.
Returns
TRUE if successful, FALSE otherwise.

Reimplemented in CXTPCalendarBusyStatusComboBox, CXTPCalendarEventCategoryComboBox, and CXTPCalendarEventLabelComboBox.

◆ MeasureItem()

virtual void MeasureItem ( LPMEASUREITEMSTRUCT lpMIS )
protectedvirtual

This function implements measure items for custom draw.

Parameters
lpMIS A pointer to a LPMEASUREITEMSTRUCT structure.
The documentation for this class was generated from the following file:
  • XTPCalendarEventPropertiesDlg.h


Toolkit Pro: CXTPCalendarControl Class Reference

Classes | Public Member Functions | Static Public Member Functions | Public Attributes | Protected Member Functions | Protected Attributes | List of all members
CXTPCalendarControl Class Reference

Class CXTPCalendarControl implements the calendar's view interface. More...

Classes

class | CUpdateContext
Class CUpdateContext updates context and redraws control parts depending on input parameters. More...
class | CViewChanged_ContextData
Class CViewChanged_ContextData is used as locker context for CViewChangedContext. More...
class | CViewChangedContext
Class CViewChangedContext used to avoid multiple sending of XTP_NC_CALENDARVIEWWASCHANGED notification for one action. More...

Public Member Functions

CXTPCalendarControl ()
This member function constructs a CXTPCalendarControl object.
virtual | ~CXTPCalendarControl ()
This member function destroys a CXTPCalendarControl object and handles cleanup and deallocation.
virtual BOOL | Create (DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID)
This member function handles control window creation.
virtual void | Populate ()
This member function populates the active control view with events data.
virtual XTPCalendarTheme | GetPaintTheme () const
This member function is used to obtain current paint theme.
virtual void | SetPaintTheme (XTPCalendarTheme ePaintTheme)
This member function is used to set current paint theme.
virtual void | SetPaintTheme (CXTPCalendarPaintManager *pPaintManager, CXTPCalendarTheme *pTheme)
This member function is used to set current paint theme.
XTPCalendarThemeVersion | GetThemeVersion () const
This member function is used to obtain the current theme ID.
CXTPCalendarPaintManager * | GetPaintManager () const
This member function obtains a pointer to the associated paint manager.
CXTPCalendarTheme * | GetTheme () const
This member function obtains a pointer to the associated theme object.
void | SetTheme (CXTPCalendarTheme *pTheme)
This member function sets (or disables) the new control drawing theme.
CXTPCalendarResources * | GetResources () const
Obtain a pointer to collection of Calendar Resources.
void | SetResources (CXTPCalendarResources *pResources, CXTPCalendarData *pOptionsDataProvider=NULL)
This member function sets the new Resources collection for the control.
void | SetDataProvider (LPCTSTR lpszConnectionString)
This member function sets the custom data provider for the control.
void | SetDataProvider (CXTPCalendarData *pDataProvider, BOOL bCloseDataProviderWhenDestroy=TRUE)
This member function sets the custom data provider for the control.
void | SetDataProvider (XTPCalendarDataProvider eDataProvider, LPCTSTR lpszConnectionString=NULL)
This member function sets the custom data provider for the control.
CXTPCalendarData * | GetDataProvider () const
Returns common data provider if it was previously set.
virtual CXTPCalendarView * | GetActiveView () const
This member function obtains a pointer to the current calendar view.
CXTPCalendarDayView * | GetDayView () const
This member function obtains a pointer to the Day calendar view.
CXTPCalendarWeekView * | GetWeekView () const
This member function obtains a pointer to the Week calendar view.
CXTPCalendarMonthView * | GetMonthView () const
This member function obtains a pointer to the Month calendar view.
CXTPCalendarTimeLineView * | GetTimeLineView () const
This member function obtains a pointer to the TimeLine calendar view.
virtual void | SwitchActiveView (XTPCalendarViewType eView)
This member function sets a predefined calendar view for the control.
void | SetLayoutRTL (BOOL bRightToLeft)
Call this member to set right-to-left mode.
BOOL | IsLayoutRTL () const
Call this member to determine if right-to-left mode is active.
int | GetTimeLineScale () const
Call this member to get current TimeLine mode.
virtual void | RedrawControl (BOOL bForce=FALSE)
This member function initiates the Calendar control's redrawing.
virtual void | AdjustLayout ()
This member function adjusts the main control parts depending on the current control's size.
virtual void | AdjustLayout (CDC *pDC, const CRect &rcView)
This member function adjusts the main control parts depending on the current control's size.
virtual void | AdjustScrollBar (int nSBType=-1)
This member function adjusts the scroll bar to reflect the current control's state.
void | OnCalendarTimeline ()
This member function switch calendar to timeline mode.
int | GetWorkWeekMask () const
This member function gets the bitwise mask of the work week.
void | SetWorkWeekMask (const int nMask)
This member function sets the bitwise mask for the work week.
int | GetFirstDayOfWeek () const
This member function gets the first day of the week.
int | GetFirstWeekOfYearDays () const
This member function gets the first week of year days.
void | SetFirstDayOfWeek (const int nFirstDayOfWeek)
This member function sets the first day of the week.
void | SetFirstWeekOfYearDays (const int nFirstWeekOfYearDays)
Call this member function to set the first week of year days.
void | GetWorkDayStartTime (COleDateTime &dtTime) const
This member function gets the begin time of the working day.
void | GetWorkDayStartTime (int &nHour, int &nMin, int &nSec) const
This member function gets the begin time of the working day.
void | GetWorkDayEndTime (COleDateTime &dtTime) const
This member function gets the end time of the working day.
void | GetWorkDayEndTime (int &nHour, int &nMin, int &nSec) const
This member function gets the end time of the working day.
void | SetLongDayHeaderFormat (LPCTSTR pcszCustomFormat)
Sets format for Cell's Day Header in Month View.
void | SetSmallDayHeaderFormat (LPCTSTR pcszCustomFormat)
Sets format for Cell's Day Header in Month View.
void | SetWorkDayStartTime (const COleDateTime &dtTime)
This member function sets the begin time for the working day.
void | SetWorkDayStartTime (int nHour, int nMin, int nSec)
This member function sets the begin time for the working day.
void | SetWorkDayEndTime (const COleDateTime &dtTime)
This member function sets an end time for the working day.
void | SetWorkDayEndTime (int nHour, int nMin, int nSec)
This member function sets an end time for the working day.
void | AddCustomTimeIntervalForReminder (int nMin, LPCTSTR szCustomMeaning=NULL, BOOL bIgnoreDefaultValues=FALSE)
This member function adds a custom time interval for an event to choose in the event properties dialog.
BOOL | DayView_IsAutoResetBusyFlag () const
Call this method to determine if the AutoResetBusyFlag is set.
void | DayView_SetAutoResetBusyFlag (BOOL bAutoResetBusyFlag=TRUE)
Call this method to set the AutoResetBusyFlag.
BOOL | MonthView_IsCompressWeekendDays () const
Call this method to determine whether weekend days are drawn compressed in month view or not.
void | MonthView_SetCompressWeekendDays (BOOL bCompress=TRUE)
Call this method to specify whether weekend days are drawn compressed in the month view.
BOOL | MonthView_IsShowEndDate () const
Call this method to determine whether the end date is shown for events in the month view.
void | MonthView_SetShowEndDate (BOOL bShowEnd=TRUE)
Call this method to specify whether the end date is shown in the month view.
BOOL | MonthView_IsShowTimeAsClocks () const
Call this method to determine if the time is shown as a graphical clock for events in the month view.
void | MonthView_SetShowTimeAsClocks (BOOL bShowClocks=TRUE)
Call this method to specify if the events start and end time is shown as a graphical clock in the month view.
BOOL | WeekView_IsShowEndDate () const
Call this method to determine if the end date is shown for events in the week view.
void | WeekView_SetShowEndDate (BOOL bShowEnd)
Call this method to specify if the end date is shown in week view.
BOOL | WeekView_IsShowTimeAsClocks () const
Call this method to determine if the time is shown as a graphical clock for events in the week view.
void | WeekView_SetShowTimeAsClocks (BOOL bShowClocks)
Call this method to specify if the events start and end time is shown as a graphical clock in week view.
void | SetPaintManager (CXTPCalendarPaintManager *pPaintManager)
This member function sets the new control drawing PaintManager.
virtual BOOL | UpdateMouseCursor ()
This member function updates the mouse cursor in relation with the control's state.
virtual BOOL | IsToday (const COleDateTime &dtDate) const
This member function is used to determine if the provided date is "today" The today date may be overriden with SetTodayDateOverride() call or with custom time provider.
COleDateTime | GetTodayDate () const
This member function is used to determine the "today" date The today date may be overriden with SetTodayDateOverride() call or with custom time provider.
void | SetTodayDateOverride (const COleDateTime &dtTodayOverride)
This member function is used to override the "today" date.
COleDateTime | GetTodayDateOverride () const
This member function returns override for "today" date is it was set with SetTodayDateOverride() call.
void | ResetTodayDateOverride ()
This member function resets override for "today" date to the current date.
virtual void | QueueDayViewSwitch (DATE dtDate)
This member function queues the calendar view while changing to the day view for the specified day.
virtual BOOL | RegisterWindowClass (HINSTANCE hInstance=NULL)
Registers the window class if it has not already been registered.
CXTPNotifyConnection * | GetConnection () const
Obtain a pointer to the notification connection object.
virtual void | SendNotification (XTP_NOTIFY_CODE EventCode, WPARAM wParam, LPARAM lParam)
This member function sends a notification to all control's event subscribers.
virtual void | SendNotificationAlways (XTP_NOTIFY_CODE EventCode, WPARAM wParam, LPARAM lParam)
This member function sends a notification to all control's event subscribers.
virtual void | EnableSendNotifications (BOOL bEnable=TRUE)
This member function enables or disables sending a notification to all control's event subscribers.
virtual CXTPCalendarRemindersManager * | GetRemindersManager () const
Obtain an associated Reminders Manager object.
virtual void | OnEditCommand (UINT uCommandID)
This member function is used to process the command with the specified ID.
virtual afx_msg void | OnUndo ()
This member function is used to process the "Undo" command.
virtual afx_msg void | OnCut ()
This member function is used to process the "Cut" command.
virtual afx_msg void | OnCopy ()
This member function is used to process the "Copy" command.
virtual afx_msg void | OnPaste ()
This member function is used to process the "Paste" command.
virtual afx_msg void | OnUpdateCmdUI (CCmdUI *pCmdUI)
This member function is used to update the user interface object represented by pCmdUI.
virtual afx_msg void | OnUpdateUndo (CCmdUI *pCmdUI)
This member function is used to update the user interface object represented by pCmdUI for the "Undo" command only.
virtual afx_msg void | OnUpdateCut (CCmdUI *pCmdUI)
This member function is used to update the user interface object represented by pCmdUI for the "Cut" command only.
virtual afx_msg void | OnUpdateCopy (CCmdUI *pCmdUI)
This member function is used to update the user interface object represented by pCmdUI for the "Copy" command only.
virtual afx_msg void | OnUpdatePaste (CCmdUI *pCmdUI)
This member function is used to update the user interface object represented by pCmdUI for the "Paste" command only.
virtual afx_msg BOOL | OnWndMsg (UINT message, WPARAM wParam, LPARAM lParam, LRESULT *pResult)
This member function is called by WindowProc, or is called during message reflection.
virtual BOOL | OnWndMsg_Children (UINT message, WPARAM wParam, LPARAM lParam, LRESULT *pResult)
This member function is used to catch messages before child windows (like Subject editor).
virtual BOOL | DoDeleteEvent (CXTPCalendarViewEvent *pViewEvent)
This member function deletes a specified event from the calendar.
virtual BOOL | DoDeleteSelectedEvents (CXTPCalendarViewEvent *pViewEvent)
This member function deletes selected events from the calendar.
CXTPCalendarOptions * | GetCalendarOptions () const
Call this member function to get direct access to calendar options data.
BOOL | SelectEventById (DWORD dEventID, BOOL bSelect=TRUE)
This member function attempts to select an event through a passed event ID.
BOOL | SelectViewEventByIdAndGroup (int nScheduleID, DWORD dEventID, BOOL bSelect=TRUE)
This member function is making attempt to select view event by passed Schedule ID and event ID.
virtual void | SetBorders (int nLeft, int nTop, int nRight, int nBottom)
This member function is used to adjust the object's layout depending on the provided bounding rectangle.
virtual void | UpdateBorders ()
This member function is used to adjust the object's layout depending on the provided bounding rectangle.
virtual void | ShowToolTip (const CString &strText, const CRect rcToolTip, CFont *pFont, BOOL bAdvanced=FALSE)
This member function is used to show a ToolTip rectangle.
virtual void | HideToolTip ()
This member function is used to hide the ToolTip rectangle.
virtual BOOL | IsToolTipVisible () const
This member function is the ToolTip rectangle visible on the screen.
BOOL | IsToolTipsEnabled () const
This member function returns TRUE if the ToolTips enabled, FALSE otherwise.
void | EnableToolTips (BOOL bEnable=TRUE)
This member function is used to enable or disable ToolTips for the control.
BOOL | IsRemindersEnabled () const
This member function returns TRUE if the Reminders functionality is enabled for this Calendar control and FALSE otherwise.
void | EnableReminders (BOOL bEnable=TRUE)
This member function is used to enable or disable Reminders functionality for the control.
virtual DWORD | GetAskItemTextFlags () const
This member function returns set of flags which define calendar items to send XTP_NC_CALENDAR_GETITEMTEXT notification.
BOOL | IsMarkupEnabled () const
This member function returns TRUE if Markup functionality is enabled for this Calendar control and FALSE otherwise.
void | EnableMarkup (BOOL bEnableMarkup=TRUE)
This member function is used to enable or disable Markup functionality for the control.
CXTPMarkupContext * | GetMarkupContext () const
Retrieves a pointer to the markup context.
void | RefreshCaptionBar ()
This member function Refresh Caption Bar after some layout modifications.
BOOL | IsReadonlyMode () const
This member function is used to get the state of Read-only mode.

Static Public Member Functions

static CXTPCalendarData *AFX_CDECL | CreateDataProvider (LPCTSTR lpszConnectionString)
Call this method to create a data provider from a specified Calendar connection string.
static CXTPCalendarData *AFX_CDECL | CreateDataProvider (XTPCalendarDataProvider eDataProvider)
Call this method to create a data provider of the specified type.
static XTPCalendarDataProvider AFX_CDECL | DataProviderTypeFromConStr (LPCTSTR lpszConnectionString, XTPCalendarDataProvider eDPDefault=xtpCalendarDataProviderUnknown)
Call this method to retrieve a type of the data provider from its connection string.
static CString AFX_CDECL | DataSourceFromConStr (LPCTSTR lpszConnectionString)
Call this method to retrieve a data source connection string from a regular Calendar connection string.

Public Attributes

XTPCalendarMouseMode | m_mouseMode
Current mouse operation mode.
BOOL | m_bDeleteOnFinalRelease
If TRUE - Delete self OnFinalRelease() call.
BOOL | m_bDisableRedraw
If TRUE - control window is not redraw, it is draw last window content (draw cached bitmap).
BOOL | m_bTimelineMode
flag to separate timeline (if TRUE) and other calendar modes
XTPCalendarViewType | m_eViewType
current view type
int | m_nTimelineScale
current timeline scale type
int | m_nCaptionHeight
height param - can be used for custom layout adjustment
BOOL | m_bPreventAutoAllDayMode
Flag to prevent dragging event into AllDay zone.
BOOL | m_bMultiColorScheduleMode
Flag to show Schedules titles in different colors.
BOOL | m_bMultiColumnWeekMode
Flag to select Outlook2007 and Outlook2003 behavior.
BOOL | m_bHideCaptionBar
Flag to Hide Caption Bar when TimeLine mode used.
BOOL | m_bReadOnlyMode
View- and Print-only mode to use Calendar.
BOOL | m_bFullDateMode
Useful for Multi-schedules case flag to use DayHeader special format.
BOOL | m_bTooltipUnderMouse
2-way tooltip positioning - TRUE - under mouse cursor, FALSE - on the top of mouse cursor
BOOL | m_bShowLinks
flag to show or hide 'virtual' view events
BOOL | m_bHideLinkContainer
flag to hide or show 'virtual' view events container column
BOOL | m_bPromptToDeleteRecurrentEvent
flag to use Ocurrence or Master case selector (default = TRUE)
BOOL | m_bDeleteOcurrenceEventIfNoPrompt
True to delete Ocurrence event, False - delete Master (default = TRUE)
CString | m_OwnerUser
string as current user name place holder
CString | m_sCustomFormat4Tooltip
Free-styled tooltip tag-based way to fill tooltip string used tags <BODY>,<LOC>,<SUBJ>,<TIME> in any combination with fillers.
CString | m_sCustomTitle
used for unique title - e.g.
BOOL | m_bForcePagination
flag to Force Pagination during PrintPreview
BOOL | m_bShowTooltipForNotFocused
flag to Show Tooltip For Not Focused Control
BOOL | m_bShowTooltipForAllDayEvents
flag to Show Tooltip For All Day Events
BOOL | m_bSwitchToDayViewIfPickedSingleDay
flag to switch to DatView on DatePicker one day selection (if TRUE) or keep previous view (FALSE)
BOOL | m_bMultipleSchedulesMode
flag to use MutilpleSchedulesModel (one event - many view events case)
BOOL | m_bMultipleSchedulesNoSelfLinks
flag to use MutilpleSchedulesModel (one event - many view events case - allow to eliminate selflinks)
CMap< int, int, CString, CString & > | m_mapCustomReminderValues
custom time intervals for reminder

Protected Member Functions

virtual void | OnDraw (CDC *pDC)
This member function performs all of the drawing logic of the calendar control window.
virtual void | SetActiveView (CXTPCalendarView *pView)
This member function sets the custom calendar view for the control.
virtual UINT | SetTimer (UINT uTimeOut_ms)
This member function creates a timer event.
virtual void | OnBeforeDestroy ()
This member function is called by the framework before the view is destroyed.
virtual void | AdjustScrollBarEx (int nSBType)
This member function adjusts the scroll bar to reflect the current control's state.
virtual void | _SetDataProvider (CXTPCalendarData *pDataProvider, BOOL bCloseDataProviderWhenDestroy=TRUE)
This member function internally sets the custom data provider for the control.
virtual void | OnOptionsChanged (int nOptionRelation)
This member function is called by the calendar control when a calendar option is changed.

Protected Attributes

CRect | m_Borders
Store options to draw border lines;.
CViewChanged_ContextData | m_cntViewChanged
Locker context for CViewChangedContext.
int | m_nRowsPerWheel
Amount of rows to scroll when using the mouse wheel.
CString | m_strUndoUIText
Text label for the Undo UI command.
CString | m_strRedoUIText
Text label for the Redo UI command.
BOOL | m_bUpdateWhenEventChangedNotify
Whether to update control when notification comes about an event change.
CXTPCalendarRemindersManager * | m_pRemindersManager
Stores reminders manager object.
CXTPMarkupContext * | m_pMarkupContext
The markup context.

Detailed Description

Class CXTPCalendarControl implements the calendar's view interface.

A CXTPCalendarControl object implements a calendar view interface similar to an Outlook 2003 interface.

There are 2 main separated concepts: Calendar data contents and Calendar views representing this contents.

It can show 3 types of following predefined views. Also any type of user view could also be implemented as a descendant of CXTPCalendarView class.

Day and work week views - using CXTPCalendarDayView class. Week view - using CXTPCalendarWeekView class. Month view - using CXTPCalendarMonthView class.

One of the other main Control's concepts is Calendar Resources. Resource is the source of Calendar data contents with some additional properties. This concept is designed to represent a schedule of a separate person, or a shared resource (sic!) like a conference room, a projector, and any similar entity. Each Resource has its own Data Provider, therefore the Control can show different data sources on the same screen. For example, you can configure Control to show your own Outlook events in "your" resource (using MAPI Data Provider), then you can use some shared resource data using Database Data Provider, etc.

Note that each event now has a standard "Schedule" property, defining which user's schedule it belongs to. And each resource has a collection of Schedule ID's to represent on it. For example, you can have only one common Data Provider which stores events data for all members of your organization. Every member has a corresponding schedule (i.e. Jeff - ID 1, Matt - ID 2, John - ID 3, Room 1 - ID 10, Room 2 - ID 11, etc). You can configure a number of resources to show data for every team member separately, and one resource to show events for both room 1 and room 2 together. Or for example, you want to show a common view of all events for a specified team including only some of employees. You will add their schedule ID's to the corresponding Resource collection, and see all of them. Of course, when you open event details, you'll see who it belongs to.

There are 2 regular models of using your custom data source with Calendar control.

a) Firstly, you can use built-in Memory data provider, which will handle all the data in itself. If you do not specify neither XML nor Binary filename, it will not be automatically loaded or saved. In this case, you'll have 2 entry points in your application: – Loading all data from your data source (could be done on form load for example). Your data access code would transfer CalendarEvents records from the data storage to objects and add them into corresponding Calendar's collection. – Saving data to your data storage. You'll have to iterate all CalendarEvents, transfer them into your data records and upload into the database. This could be implemented through pressing the Save button for example. This is the most easy way.

b) Second idea is to handle basic data storage operations by yourself. This is called "custom data provider model". It could be needed when you have many CalendarEvents records and do not want to store them all in memory because of a huge size. Another possible need of using this model is having all the information always updated if your data storage is shared.

For some predefined examples of this functionality look Calendar Samples, and menu items: MultiSchedules configuration and Load sample configurations...

See also
CXTPCalendarView
CXTPCalendarData
CXTPCalendarResource

Constructor & Destructor Documentation

◆ CXTPCalendarControl()

CXTPCalendarControl ( )

This member function constructs a CXTPCalendarControl object.

Construct a CXTPCalendarControl object in two steps. First, call the constructor CXTPCalendarControl and then call Create method, which initializes the window.

Example:

Declare a local CXTPCalendarControl object.
CXTPCalendarControl myCalendar;

// Declare a dynamic CXTPCalendarControl object.
CXTPCalendarControl* pMyCalendar = new CXTPCalendarControl();

// Create a window
if (!myCalendar.Create(WS_CHILD | WS_TABSTOP | WS_VISIBLE, rcRect, this,
ID_CALENDAR_CONTROL))
{
    TRACE(_T("Failed to create calendar control window\n"));
}
See also
Create

Member Function Documentation

◆ _SetDataProvider()

virtual void _SetDataProvider | ( | CXTPCalendarData * | pDataProvider,
 |  | BOOL | bCloseDataProviderWhenDestroy = TRUE )
 protectedvirtual

This member function internally sets the custom data provider for the control.

Parameters
pDataProvider | Pointer to the custom data provider object.
bCloseDataProviderWhenDestroy | BOOL value shows whether data provider should be closed with the control's destruction.

This method is used by SetDataProvider().

See also
SetDataProvider

◆ AddCustomTimeIntervalForReminder()

void AddCustomTimeIntervalForReminder | ( | int | nMin,
 |  | LPCTSTR | szCustomMeaning = NULL,
 |  | BOOL | bIgnoreDefaultValues = FALSE )

This member function adds a custom time interval for an event to choose in the event properties dialog.

Parameters
nMin | An int. Custom reminder interval in minutes.
szCustomMeaning | A string that describes this interval (e.g. hour, day). Default string is CXTPCalendarUtils::FormatTimeDuration(nMin).
bIgnoreDefaultValues | Tells the event properties dialog to ignore default reminder time intervals (1,5,10,15 minutes)

◆ AdjustLayout() [1/2]

virtual void AdjustLayout ( )
virtual

This member function adjusts the main control parts depending on the current control's size.

See also
CXTPCalendarControl::CUpdateContext
AdjustScrollBar
RedrawControl

◆ AdjustLayout() [2/2]

virtual void AdjustLayout | ( | CDC * | pDC,
 |  | const CRect & | rcView )
 virtual

This member function adjusts the main control parts depending on the current control's size.

Parameters
pDC | Pointer to a valid device context.
rcView | A rectangle for calendar control.
See also
CXTPCalendarControl::CUpdateContext
AdjustScrollBar
RedrawControl

◆ AdjustScrollBar()

virtual void AdjustScrollBar ( int nSBType = -1 )
virtual

This member function adjusts the scroll bar to reflect the current control's state.

Parameters
nSBType Specifies the scroll bar type to be adjusted. This parameter can be either of the following:
  • SB_HORZ - Horizontal scroll bar.
  • SB_VERT - Vertical scroll bar.
See also
CXTPCalendarControl::CUpdateContext
AdjustLayout
RedrawControl

◆ AdjustScrollBarEx()

virtual void AdjustScrollBarEx ( int nSBType )
protectedvirtual

This member function adjusts the scroll bar to reflect the current control's state.

Parameters
nSBType Specifies the scroll bar type to be adjusted. This parameter can be either of the following:
  • SB_HORZ - Horizontal scroll bar.
  • SB_VERT - Vertical scroll bar.
See also
CXTPCalendarControl::CUpdateContext
AdjustLayout
RedrawControl

◆ Create()

virtual BOOL Create | ( | DWORD | dwStyle,
 |  | const RECT & | rect,
 |  | CWnd * | pParentWnd,
 |  | UINT | nID )
 virtual

This member function handles control window creation.

Parameters
dwStyle | Specifies the window style attributes.
rect | The size and position of the window, in client coordinates of pParentWnd.
pParentWnd | The parent window.
nID | The ID of the child window.
Returns
Nonzero if successful; otherwise 0.

◆ CreateDataProvider() [1/2]

static CXTPCalendarData *AFX_CDECL CreateDataProvider ( LPCTSTR lpszConnectionString )
static

Call this method to create a data provider from a specified Calendar connection string.

Parameters
lpszConnectionString A text Calendar connection string.

This is a helper method which creates calendar's data provider of the specified type with settings taken from the connection string.

Returns
Pointer to the created Calendar Data Provider object.

◆ CreateDataProvider() [2/2]

static CXTPCalendarData *AFX_CDECL CreateDataProvider ( XTPCalendarDataProvider eDataProvider )
static

Call this method to create a data provider of the specified type.

Parameters
eDataProvider A member of XTPCalendarDataProvider enumeration, which specifies a type of the Data Provider to create.

This is a helper method which creates calendar's data provider of the specified type.

Returns
Pointer to the created Calendar Data Provider object.

◆ DataProviderTypeFromConStr()

static XTPCalendarDataProvider AFX_CDECL DataProviderTypeFromConStr | ( | LPCTSTR | lpszConnectionString,
 |  | XTPCalendarDataProvider | eDPDefault = xtpCalendarDataProviderUnknown )
 static

Call this method to retrieve a type of the data provider from its connection string.

Parameters
lpszConnectionString | A text Calendar connection string.
eDPDefault | Default data provider type to be returned if it can't be determined from the string.

This is a helper method which parses a connection string and identifies the type of the data provider which is specified there.

Returns
One of the values from XTPCalendarDataProvider enumeration.
See also
DataSourceFromConStr()
CreateDataProvider()

◆ DataSourceFromConStr()

static CString AFX_CDECL DataSourceFromConStr ( LPCTSTR lpszConnectionString )
static

Call this method to retrieve a data source connection string from a regular Calendar connection string.

Parameters
lpszConnectionString A text Calendar connection string.

This is a helper method which parses a connection string and identifies a data source connection string there.

Returns
Identified data source connection string.
See also
DataProviderTypeFromConStr()
CreateDataProvider()

◆ DayView_IsAutoResetBusyFlag()

BOOL DayView_IsAutoResetBusyFlag ( ) const

Call this method to determine if the AutoResetBusyFlag is set.

Returns
Value of AutoResetBusyFlag.
See also
MonthView_SetCompressWeekendDays

◆ DayView_SetAutoResetBusyFlag()

void DayView_SetAutoResetBusyFlag ( BOOL bAutoResetBusyFlag = TRUE )

Call this method to set the AutoResetBusyFlag.

Parameters
bAutoResetBusyFlag A BOOL. TRUE to set the AutoResetBusyFlag. FALSE otherwise.
See also
MonthView_SetCompressWeekendDays

◆ DoDeleteEvent()

virtual BOOL DoDeleteEvent ( CXTPCalendarViewEvent * pViewEvent )
virtual

This member function deletes a specified event from the calendar.

Parameters
pViewEvent View of the event to delete.

Call member function if you want to delete an event basing on its View object.

Returns
TRUE if event was deleted successfully; otherwise FALSE.

◆ DoDeleteSelectedEvents()

virtual BOOL DoDeleteSelectedEvents ( CXTPCalendarViewEvent * pViewEvent )
virtual

This member function deletes selected events from the calendar.

Parameters
pViewEvent View of the last event to delete.

Call member function if you want to delete all selected events.

Returns
TRUE if events were deleted successfully; otherwise FALSE.

◆ EnableMarkup()

void EnableMarkup ( BOOL bEnableMarkup = TRUE )

This member function is used to enable or disable Markup functionality for the control.

Enabling this functionality allows a control to process customized special property xtpMarkupTemplate which could be set for each event. If this property exists and contains text with Markup information, it will be drawn inside the Event rectangle (instead of Subject and Body).

Parameters
bEnableMarkup Specifies whether Markup functionality should be enabled (TRUE) or disabled (FALSE).

◆ EnableReminders()

void EnableReminders ( BOOL bEnable = TRUE )

This member function is used to enable or disable Reminders functionality for the control.

Parameters
bEnable A BOOL. Specifies whether Reminders functionality should be enabled (TRUE) or disabled (FALSE).
See also
IsRemindersEnabled

◆ EnableSendNotifications()

AFX_INLINE void EnableSendNotifications ( BOOL bEnable = TRUE )
virtual

This member function enables or disables sending a notification to all control's event subscribers.

Parameters
bEnable TRUE to allow sending notifications, FALSE to disallow.
See also
SendNotification

◆ EnableToolTips()

AFX_INLINE void EnableToolTips ( BOOL bEnable = TRUE )

This member function is used to enable or disable ToolTips for the control.

Parameters
bEnable A BOOL. Specifies whether ToolTips should be enabled (TRUE) or disabled (FALSE).
See also
IsToolTipsEnabled

◆ GetActiveView()

AFX_INLINE CXTPCalendarView * GetActiveView ( ) const
virtual

This member function obtains a pointer to the current calendar view.

Call this member function to obtain the calendar view object currently used in this calendar control.

Returns
A CXTPCalendarView pointer to the associated calendar view object.
See also
CXTPCalendarView overview
SetActiveView
GetViewDay
GetWeekView
GetMonthView

◆ GetAskItemTextFlags()

virtual DWORD GetAskItemTextFlags ( ) const
virtual

This member function returns set of flags which define calendar items to send XTP_NC_CALENDAR_GETITEMTEXT notification.

If Calendar theme is set - return value is got from the theme object, otherwise it is got from the paint manager object.

Returns
Set of flags from enums XTPCalendarGetItemText, XTPCalendarGetItemTextEx.
See also
XTPCalendarGetItemText
XTPCalendarGetItemTextEx
CXTPCalendarPaintManager::GetAskItemTextFlags
CXTPCalendarPaintManager::SetAskItemTextFlags
CXTPCalendarTheme::GetAskItemTextFlags
CXTPCalendarTheme::SetAskItemTextFlags
XTP_NC_CALENDAR_GETITEMTEXT

◆ GetCalendarOptions()

AFX_INLINE CXTPCalendarOptions * GetCalendarOptions ( ) const

Call this member function to get direct access to calendar options data.

This member function wraps CXTPCalendarData::GetCalendarOptions() method. If you read or change returned structure members no additional checks are made and no notifications are sent. The preferred way is to use CXTPCalendarControl options methods like GetWorkWeekMask(), SetWorkWeekMask(), GetFirstDayOfWeek(), SetFirstDayOfWeek(), ... etc.

Returns
A pointer to calendar options data class CXTPCalendarOptions.
See also
CXTPCalendarOptions
CXTPCalendarData::GetCalendarOptions().

◆ GetConnection()

AFX_INLINE CXTPNotifyConnection * GetConnection ( ) const

Obtain a pointer to the notification connection object.

Used to subscribe (Advice) for notification events from the control.

Returns
Connection object pointer.
See also
CXTPNotifyConnection overview
IXTPNotificationSink overview

◆ GetDataProvider()

CXTPCalendarData * GetDataProvider ( ) const

Returns common data provider if it was previously set.

Returns
A pointer to the common data provider if it was previously set; otherwise, returns NULL.

◆ GetDayView()

AFX_INLINE CXTPCalendarDayView * GetDayView ( ) const

This member function obtains a pointer to the Day calendar view.

Call this member function to obtain a Day calendar view object regardless of its visibility.

Returns
A CXTPCalendarView pointer to the associated calendar view object.
See also
CXTPCalendarView overview
GetActiveView
GetWeekView
GetMonthView

◆ GetFirstDayOfWeek()

int GetFirstDayOfWeek ( ) const

This member function gets the first day of the week.

Returns
First day of the week represented by an integer from range between 1 and 7, where 1 = Sunday, 2 = Monday, and so on.
See also
SetFirstDayOfWeek
XTPCalendarWeekDay

◆ GetFirstWeekOfYearDays()

int GetFirstWeekOfYearDays ( ) const

This member function gets the first week of year days.

Returns
An integer denoting the first week of year days,

◆ GetMarkupContext()

AFX_INLINE CXTPMarkupContext * GetMarkupContext ( ) const

Retrieves a pointer to the markup context.

Returns
A pointer to a CXTPMarkupContext object.

◆ GetMonthView()

AFX_INLINE CXTPCalendarMonthView * GetMonthView ( ) const

This member function obtains a pointer to the Month calendar view.

Call this member function to obtain a Month calendar view object regardless of its visibility.

Returns
A CXTPCalendarView pointer to the associated calendar view object.
See also
CXTPCalendarView overview
GetActiveView
GetWeekView
GetDayView

◆ GetPaintManager()

AFX_INLINE CXTPCalendarPaintManager * GetPaintManager ( ) const

This member function obtains a pointer to the associated paint manager.

Call this member function to obtain the paint manager object used for drawing a calendar control window.

Returns
A CXTPCalendarPaintManager pointer to the associated paint manager object.

◆ GetPaintTheme()

virtual XTPCalendarTheme GetPaintTheme ( ) const
virtual

This member function is used to obtain current paint theme.

Returns
A paint theme ID from enum XTPCalendarTheme.

◆ GetRemindersManager()

AFX_INLINE CXTPCalendarRemindersManager * GetRemindersManager ( ) const
virtual

Obtain an associated Reminders Manager object.

Use this method to retrieve a pointer to the Reminders Manager object associated to this Calendar control.

Returns
Calendar Reminders Manager.
See also
CXTPCalendarRemindersManager overview

◆ GetResources()

CXTPCalendarResources * GetResources ( ) const

Obtain a pointer to collection of Calendar Resources.

Use this method to retrieve a pointer to the Calendar Resources collection of this Calendar control.

Returns
CXTPCalendarResources pointer.
See also
CXTPCalendarResources overview

◆ GetTheme()

AFX_INLINE CXTPCalendarTheme * GetTheme ( ) const

This member function obtains a pointer to the associated theme object.

Themes are used for drawing a calendar control window instead of a Paint manager. This is a new feature of Calendar control which will be further developed. Some new drawing features will be added for themes only (no for Paint manager). But the Paint manager will also be used for compatibility.

Initial version. Themes will be expanded in the feature.

Returns
A CXTPCalendarTheme pointer to the associated theme object or NULL.
See also
CXTPCalendarView::GetTheme
GetPaintManager

◆ GetThemeVersion()

XTPCalendarThemeVersion GetThemeVersion ( ) const

This member function is used to obtain the current theme ID.

Basically this can be used to check if the 2010 or 2007 theme is used.

Returns
A theme version ID from enum XTPCalendarThemeVersion.

◆ GetTimeLineScale()

int GetTimeLineScale ( ) const

Call this member to get current TimeLine mode.

Returns
An integer representing one of the following values.
  xtpTSPID_Day      = 1,
  xtpTSPID_Week     = 2,
  xtpTSPID_Month    = 3,
  xtpTSPID_WorkWeek = 4,

◆ GetTimeLineView()

AFX_INLINE CXTPCalendarTimeLineView * GetTimeLineView ( ) const

This member function obtains a pointer to the TimeLine calendar view.

Call this member function to obtain a TimeLine calendar view object regardless of its visibility.

Returns
A CXTPCalendarView pointer to the associated calendar view object.
See also
CXTPCalendarView overview
GetActiveView
GetWeekView
GetDayView
GetMonthView

◆ GetTodayDate()

COleDateTime GetTodayDate ( ) const

This member function is used to determine the "today" date The today date may be overriden with SetTodayDateOverride() call or with custom time provider.

Returns
COleDateTime with "today" date for this calendar control instance

◆ GetTodayDateOverride()

COleDateTime GetTodayDateOverride ( ) const

This member function returns override for "today" date is it was set with SetTodayDateOverride() call.

If the GetState() member function of COleDateTime returns invalid flag for returned date, then no override was applied.

Returns
COleDateTime object with override today date.

◆ GetWeekView()

AFX_INLINE CXTPCalendarWeekView * GetWeekView ( ) const

This member function obtains a pointer to the Week calendar view.

Call this member function to obtain a Week calendar view object regardless of its visibility.

Returns
A CXTPCalendarView pointer to the associated calendar view object.
See also
CXTPCalendarView overview
GetActiveView
GetDayView
GetMonthView

◆ GetWorkDayEndTime() [1/2]

void GetWorkDayEndTime ( COleDateTime & dtTime ) const

This member function gets the end time of the working day.

Parameters
dtTime A reference to the COleDateTime value to store the result.
See also
SetWorkDayEndTime
GetWorkDayStartTime
SetWorkDayStartTime

◆ GetWorkDayEndTime() [2/2]

void GetWorkDayEndTime | ( | int & | nHour,
 |  | int & | nMin,
 |  | int & | nSec ) const

This member function gets the end time of the working day.

Parameters
nHour | An int. A reference to the hour part of the result.
nMin | An int. A reference to the minutes part of the result.
nSec | An int. A reference to the seconds part of the result.
See also
SetWorkDayEndTime
GetWorkDayStartTime
SetWorkDayStartTime

◆ GetWorkDayStartTime() [1/2]

void GetWorkDayStartTime ( COleDateTime & dtTime ) const

This member function gets the begin time of the working day.

Parameters
dtTime A reference to the COleDateTime value to store the result.
See also
SetWorkDayStartTime
GetWorkDayEndTime
SetWorkDayEndTime

◆ GetWorkDayStartTime() [2/2]

void GetWorkDayStartTime | ( | int & | nHour,
 |  | int & | nMin,
 |  | int & | nSec ) const

This member function gets the begin time of the working day.

Parameters
nHour | An int. A reference to the hour part of the result.
nMin | An int. A reference to the minutes part of the result.
nSec | An int. A reference to the seconds part of the result.
See also
SetWorkDayStartTime
GetWorkDayEndTime
SetWorkDayEndTime

◆ GetWorkWeekMask()

int GetWorkWeekMask ( ) const

This member function gets the bitwise mask of the work week.

Returns
An integer containing the bitwise day mask.
See also
SetWorkWeekMask
XTPCalendarWeekDay

◆ HideToolTip()

virtual void HideToolTip ( )
virtual

This member function is used to hide the ToolTip rectangle.

See also
IsToolTipVisible

◆ IsLayoutRTL()

BOOL IsLayoutRTL ( ) const

Call this member to determine if right-to-left mode is active.

Returns
TRUE if right-to-left mode is enabled and FALSE otherwise.

◆ IsMarkupEnabled()

AFX_INLINE BOOL IsMarkupEnabled ( ) const

This member function returns TRUE if Markup functionality is enabled for this Calendar control and FALSE otherwise.

Enabled state automatically processes static Markup text for events, and enables processing of dynamic Markup text customization using XTP_NC_CALENDAR_GETITEMTEXT notification.

Returns
TRUE if Markup feature is enabled, FALSE otherwise.
See also
CXTPCalendarViewEvent::GetMarkupText()

◆ IsReadonlyMode()

BOOL IsReadonlyMode ( ) const

This member function is used to get the state of Read-only mode.

Returns
TRUE if current mode is Read-only.

◆ IsRemindersEnabled()

BOOL IsRemindersEnabled ( ) const

This member function returns TRUE if the Reminders functionality is enabled for this Calendar control and FALSE otherwise.

Returns
TRUE if reminders are enabled, FALSE otherwise.
See also
EnableReminders()

◆ IsToday()

virtual BOOL IsToday ( const COleDateTime & dtDate ) const
virtual

This member function is used to determine if the provided date is "today" The today date may be overriden with SetTodayDateOverride() call or with custom time provider.

Parameters
dtDate A specific date.
Returns
A BOOL. TRUE if the provided date is "today" for this calendar control instance, FALSE otherwise

◆ IsToolTipsEnabled()

AFX_INLINE BOOL IsToolTipsEnabled ( ) const

This member function returns TRUE if the ToolTips enabled, FALSE otherwise.

Returns
TRUE if the ToolTips enabled, FALSE otherwise.
See also
EnableToolTips

◆ IsToolTipVisible()

virtual BOOL IsToolTipVisible ( ) const
virtual

This member function is the ToolTip rectangle visible on the screen.

Returns
TRUE if ToolTip rectangle visible, FALSE otherwise.
See also
HideToolTip

◆ MonthView_IsCompressWeekendDays()

BOOL MonthView_IsCompressWeekendDays ( ) const

Call this method to determine whether weekend days are drawn compressed in month view or not.

Returns
TRUE if weekend days are drawn compressed. FALSE otherwise.
See also
MonthView_SetCompressWeekendDays

◆ MonthView_IsShowEndDate()

BOOL MonthView_IsShowEndDate ( ) const

Call this method to determine whether the end date is shown for events in the month view.

Returns
TRUE if the end date is shown. FALSE otherwise.
See also
MonthView_SetShowEndDate

◆ MonthView_IsShowTimeAsClocks()

BOOL MonthView_IsShowTimeAsClocks ( ) const

Call this method to determine if the time is shown as a graphical clock for events in the month view.

Returns
TRUE for time shown as graphical clock. FALSE otherwise.
See also
MonthView_SetShowTimeAsClocks

◆ MonthView_SetCompressWeekendDays()

void MonthView_SetCompressWeekendDays ( BOOL bCompress = TRUE )

Call this method to specify whether weekend days are drawn compressed in the month view.

Parameters
bCompress A BOOL. TRUE if weekend days are drawn compressed. FALSE otherwise.
See also
MonthView_IsCompressWeekendDays

◆ MonthView_SetShowEndDate()

void MonthView_SetShowEndDate ( BOOL bShowEnd = TRUE )

Call this method to specify whether the end date is shown in the month view.

Parameters
bShowEnd A BOOL. TRUE if the end date is shown in month view. FALSE otherwise.
See also
MonthView_IsShowEndDate

◆ MonthView_SetShowTimeAsClocks()

void MonthView_SetShowTimeAsClocks ( BOOL bShowClocks = TRUE )

Call this method to specify if the events start and end time is shown as a graphical clock in the month view.

Parameters
bShowClocks A BOOL. TRUE if the time is shown as a graphical clock. FALSE otherwise.
See also
MonthView_IsShowTimeAsClocks

◆ OnCopy()

virtual afx_msg void OnCopy ( )
virtual

This member function is used to process the "Copy" command.

See also
OnCommand
OnUndo
OnCut
OnPaste

◆ OnCut()

virtual afx_msg void OnCut ( )
virtual

This member function is used to process the "Cut" command.

See also
OnCommand
OnUndo
OnCopy
OnPaste

◆ OnDraw()

virtual void OnDraw ( CDC * pDC )
protectedvirtual

This member function performs all of the drawing logic of the calendar control window.

Parameters
pDC Pointer to a valid device context.
See also
OnPaint

◆ OnEditCommand()

virtual void OnEditCommand ( UINT uCommandID )
virtual

This member function is used to process the command with the specified ID.

Parameters
uCommandID Command ID. Specifies which command to process.
See also
OnUndo
OnCut
OnCopy
OnPaste

◆ OnOptionsChanged()

virtual void OnOptionsChanged ( int nOptionRelation )
protectedvirtual

This member function is called by the calendar control when a calendar option is changed.

It is called from the set option methods like SetWorkWeekMask(), SetFirstDayOfWeek(), SetWorkDayStartTime(), SetWorkDayEndTime(), DayView_SetAutoResetBusyFlag(), ... etc. See CXTPCalendarOptions for details. Default implementation sends XTP_NC_CALENDAROPTIONSWASCHANGED notification.

Parameters
nOptionRelation Changed option relation (or kind). Value -1 specify global or common option. Value from XTPCalendarViewType enum specify which kind of view changed option is related.

TRUE if events were deleted successfully; otherwise FALSE.

See also
CXTPCalendarOptions
CXTPCalendarData::GetCalendarOptions()
XTP_NC_CALENDAROPTIONSWASCHANGED

◆ OnPaste()

virtual afx_msg void OnPaste ( )
virtual

This member function is used to process the "Paste" command.

See also
OnCommand
OnUndo
OnCut
OnCopy

◆ OnUndo()

virtual afx_msg void OnUndo ( )
virtual

This member function is used to process the "Undo" command.

See also
OnCommand
OnCut
OnCopy
OnPaste

◆ OnUpdateCmdUI()

virtual afx_msg void OnUpdateCmdUI ( CCmdUI * pCmdUI )
virtual

This member function is used to update the user interface object represented by pCmdUI.

Parameters
pCmdUI pointer to the CCmdUI object.
See also
OnUpdateUndo
OnUpdateCut
OnUpdateCopy
OnUpdatePaste

◆ OnUpdateCopy()

virtual afx_msg void OnUpdateCopy ( CCmdUI * pCmdUI )
virtual

This member function is used to update the user interface object represented by pCmdUI for the "Copy" command only.

Parameters
pCmdUI pointer to the CCmdUI object.
See also
OnUpdateUndo
OnUpdateUndo
OnUpdateCut
OnUpdatePaste

◆ OnUpdateCut()

virtual afx_msg void OnUpdateCut ( CCmdUI * pCmdUI )
virtual

This member function is used to update the user interface object represented by pCmdUI for the "Cut" command only.

Parameters
pCmdUI pointer to the CCmdUI object.
See also
OnUpdateUndo
OnUpdateUndo
OnUpdateCopy
OnUpdatePaste

◆ OnUpdatePaste()

virtual afx_msg void OnUpdatePaste ( CCmdUI * pCmdUI )
virtual

This member function is used to update the user interface object represented by pCmdUI for the "Paste" command only.

Parameters
pCmdUI pointer to the CCmdUI object.
See also
OnUpdateUndo
OnUpdateUndo
OnUpdateCut
OnUpdateCopy

◆ OnUpdateUndo()

virtual afx_msg void OnUpdateUndo ( CCmdUI * pCmdUI )
virtual

This member function is used to update the user interface object represented by pCmdUI for the "Undo" command only.

Parameters
pCmdUI pointer to the CCmdUI object.
See also
OnUpdateUndo
OnUpdateCut
OnUpdateCopy
OnUpdatePaste

◆ OnWndMsg()

virtual afx_msg BOOL OnWndMsg | ( | UINT | message,
 |  | WPARAM | wParam,
 |  | LPARAM | lParam,
 |  | LRESULT * | pResult )
 virtual

This member function is called by WindowProc, or is called during message reflection.

Parameters
message | Specifies the message to be sent.
wParam | Specifies additional message-dependent information.
lParam | Specifies additional message-dependent information.
pResult | The return value of WindowProc. Depends on the message; may be NULL.
Returns
TRUE if the message is handled properly, FALSE else.

◆ OnWndMsg_Children()

virtual BOOL OnWndMsg_Children | ( | UINT | message,
 |  | WPARAM | wParam,
 |  | LPARAM | lParam,
 |  | LRESULT * | pResult )
 virtual

This member function is used to catch messages before child windows (like Subject editor).

The child windows must call OnWndMsg_Children() for the messages which are interesting for other calendar control parts (main control window, view, day view, event view). The OnWndMsg() method may be overridden for this purposes. This mechanism is used instead of PreTranslateMessage() for ActiveX builds.

Parameters
message | Specifies the message to be sent.
wParam | Specifies additional message-dependent information.
lParam | Specifies additional message-dependent information.
pResult | The return value of WindowProc. Depends on the message; may be NULL.
Returns
TRUE if message was handled; otherwise FALSE.
See also
CXTPCalendarViewEventSubjectEditor
OnWndMsg().

◆ Populate()

virtual void Populate ( )
virtual

This member function populates the active control view with events data.

Creates a new events views collection for the view, populating it with the data objects taken from the associated data provider.

◆ QueueDayViewSwitch()

virtual void QueueDayViewSwitch ( DATE dtDate )
virtual

This member function queues the calendar view while changing to the day view for the specified day.

Parameters
dtDate A specified date to change to.

Call this member function for changing calendar view to the day view for the specified day.

See also
CXTPCalendarDayView overview
XTPCalendarViewType
GetAvtiveView
SetAvtiveView

◆ RedrawControl()

virtual void RedrawControl ( BOOL bForce = FALSE )
virtual

This member function initiates the Calendar control's redrawing.

Parameters
bForce Set this parameter to TRUE if you'd like to force control's redrawing even if update is locked.

Call this member function if you want to force the control's redrawing. The control will be redrawn to reflect its latest state.

See also
CXTPCalendarControl::CUpdateContext
AdjustLayout
AdjustScrollBar
LockUpdate
UnlockUpdate.

◆ RegisterWindowClass()

virtual BOOL RegisterWindowClass ( HINSTANCE hInstance = NULL )
virtual

Registers the window class if it has not already been registered.

Parameters
hInstance Instance of the resource where the control is located.
Returns
TRUE if the window class was successfully registered, otherwise FALSE.

◆ ResetTodayDateOverride()

void ResetTodayDateOverride ( )

This member function resets override for "today" date to the current date.

If no override is applied the calls to GetTodayDate() and IsToday() will use the CXTPCalendarUtils::GetCurrentTime() to determine the current time on user machine.

◆ SelectEventById()

BOOL SelectEventById | ( | DWORD | dEventID,
 |  | BOOL | bSelect = TRUE )

This member function attempts to select an event through a passed event ID.

Parameters
dEventID | : DWORD of event id.
bSelect | : BOOL - EnsureVisible && Select if bSelect = TRUE, EnsureVisible only if bSelect = FALSE.
Returns
TRUE if successful.

◆ SelectViewEventByIdAndGroup()

BOOL SelectViewEventByIdAndGroup | ( | int | nScheduleID,
 |  | DWORD | dEventID,
 |  | BOOL | bSelect = TRUE )

This member function is making attempt to select view event by passed Schedule ID and event ID.

Parameters
nScheduleID | Schedule ID - used in case with multiple links.
dEventID | DWORD of event id.
bSelect | BOOL - EnsureVisible && Select if bSelect = TRUE, EnsureVisible only if bSelect = FALSE.
Returns
TRUE if successful.

◆ SendNotification()

virtual void SendNotification | ( | XTP_NOTIFY_CODE | EventCode,
 |  | WPARAM | wParam,
 |  | LPARAM | lParam )
 virtual

This member function sends a notification to all control's event subscribers.

Parameters
EventCode | A specific code identifying the event.
wParam | First custom parameter. Depends on the event type. See specific event description for details.
lParam | Second custom parameter. Depends on the event type. See specific event description for details.

This member function is called internally from inside the control when a notification is sent to all notification listeners. SendNotification depends on EnableSendNotifications flag. SendNotificationAlways - Performs send in any case.

See also
XTP_NOTIFY_CODE
GetConnection

◆ SendNotificationAlways()

virtual void SendNotificationAlways | ( | XTP_NOTIFY_CODE | EventCode,
 |  | WPARAM | wParam,
 |  | LPARAM | lParam )
 virtual

This member function sends a notification to all control's event subscribers.

Parameters
EventCode | A specific code identifying the event.
wParam | First custom parameter. Depends on the event type. See specific event description for details.
lParam | Second custom parameter. Depends on the event type. See specific event description for details.

This member function is called internally from inside the control when a notification is sent to all notification listeners. SendNotification depends on EnableSendNotifications flag. SendNotificationAlways - Performs send in any case.

See also
XTP_NOTIFY_CODE
GetConnection

◆ SetActiveView()

virtual void SetActiveView ( CXTPCalendarView * pView )
protectedvirtual

This member function sets the custom calendar view for the control.

Parameters
pView Pointer to the custom calendar view object.

Call this member function to set the custom calendar view currently used by the calendar control. Note that custom calendar view must be descendant of CXTPCalendarView.

See also
CXTPCalendarView overview
GetActiveView

◆ SetBorders()

virtual void SetBorders | ( | int | nLeft,
 |  | int | nTop,
 |  | int | nRight,
 |  | int | nBottom )
 virtual

This member function is used to adjust the object's layout depending on the provided bounding rectangle.

Parameters
nLeft | rectange data.
nTop | rectange data.
nRight | rectange data.
nBottom | rectange data.

◆ SetDataProvider() [1/3]

void SetDataProvider | ( | CXTPCalendarData * | pDataProvider,
 |  | BOOL | bCloseDataProviderWhenDestroy = TRUE )

This member function sets the custom data provider for the control.

Parameters
pDataProvider | Pointer to the custom data provider object.
bCloseDataProviderWhenDestroy | BOOL value shows whether data provider should be closed with the control's destruction.

Call this member function to set the custom data provider that is currently used by this calendar control. Note that custom data provider must be a descendant of CXTPCalendarData.

See also
CXTPCalendarData
XTPCalendarDataProvider
GetDataProvider

◆ SetDataProvider() [2/3]

void SetDataProvider ( LPCTSTR lpszConnectionString )

This member function sets the custom data provider for the control.

Parameters
lpszConnectionString A text Calendar connection string.

Call this member function to set the custom data provider that is currently used by this calendar control. Note that custom data provider must be a descendant of CXTPCalendarData.

See also
CXTPCalendarData
XTPCalendarDataProvider
GetDataProvider

◆ SetDataProvider() [3/3]

void SetDataProvider | ( | XTPCalendarDataProvider | eDataProvider,
 |  | LPCTSTR | lpszConnectionString = NULL )

This member function sets the custom data provider for the control.

Parameters
eDataProvider | Data provider type.
lpszConnectionString | A text Calendar connection string.

Call this member function to set the custom data provider that is currently used by this calendar control. Note that custom data provider must be a descendant of CXTPCalendarData.

See also
CXTPCalendarData
XTPCalendarDataProvider
GetDataProvider

◆ SetFirstDayOfWeek()

void SetFirstDayOfWeek ( const int nFirstDayOfWeek )

This member function sets the first day of the week.

Parameters
nFirstDayOfWeek An int that contains the new first day of the week. An integer from range between 1 and 7, where 1 = Sunday, 2 = Monday, and so on.
See also
GetFirstDayOfWeek
XTPCalendarWeekDay

◆ SetFirstWeekOfYearDays()

void SetFirstWeekOfYearDays ( const int nFirstWeekOfYearDays )

Call this member function to set the first week of year days.

Parameters
nFirstWeekOfYearDays An integer denoting the first week of year days.

◆ SetLayoutRTL()

void SetLayoutRTL ( BOOL bRightToLeft )

Call this member to set right-to-left mode.

Parameters
bRightToLeft TRUE to set right-to-left reading-order properties.

◆ SetLongDayHeaderFormat()

void SetLongDayHeaderFormat ( LPCTSTR pcszCustomFormat )

Sets format for Cell's Day Header in Month View.

Parameters
pcszCustomFormat An string sd custom format.

◆ SetPaintManager()

void SetPaintManager ( CXTPCalendarPaintManager * pPaintManager )

This member function sets the new control drawing PaintManager.

Parameters
pPaintManager A CXTPCalendarPaintManager pointer to the new paint manager object.

Call this member function to set the paint manager object used for drawing a calendar control window.

See also
GetPaintManager

◆ SetPaintTheme() [1/2]

virtual void SetPaintTheme | ( | CXTPCalendarPaintManager * | pPaintManager,
 |  | CXTPCalendarTheme * | pTheme )
 virtual

This member function is used to set current paint theme.

Parameters
pPaintManager | A valid pointer to a CXTPCalendarPaintManager object.
pTheme | Pointer to a CXTPCalendarTheme object when using resource DLL otherwise NULL.

◆ SetPaintTheme() [2/2]

virtual void SetPaintTheme ( XTPCalendarTheme ePaintTheme )
virtual

This member function is used to set current paint theme.

Parameters
ePaintTheme A paint theme ID from enum XTPCalendarTheme.

◆ SetResources()

void SetResources | ( | CXTPCalendarResources * | pResources,
 |  | CXTPCalendarData * | pOptionsDataProvider = NULL )

This member function sets the new Resources collection for the control.

Parameters
pResources | A pointer to the CXTPCalendarResources collection object.
pOptionsDataProvider | A pointer to the Data Provider object for using on Calendar Options.

Call this member function to programmatically set the new Resources collection for the control.

◆ SetSmallDayHeaderFormat()

void SetSmallDayHeaderFormat ( LPCTSTR pcszCustomFormat )

Sets format for Cell's Day Header in Month View.

Parameters
pcszCustomFormat An string sd custom format.

◆ SetTheme()

void SetTheme ( CXTPCalendarTheme * pTheme )

This member function sets (or disables) the new control drawing theme.

Parameters
pTheme A CXTPCalendarTheme pointer to the theme object. If pTheme is NULL - themes are disabled and the paint manager is used.

Themes are used for drawing a calendar control window instead of a Paint manager. This is a new feature of Calendar control which will be further developed. Some new drawing features will be added for themes only (no for Paint manager). But the Paint manager will also be used for compatibility.

Initial version. Themes will be expanded in the feature.

See also
GetPaintManager

◆ SetTimer()

virtual UINT SetTimer ( UINT uTimeOut_ms )
protectedvirtual

This member function creates a timer event.

Parameters
uTimeOut_ms Duration of timer in milliseconds.
Returns
The identifier of the timer.

◆ SetTodayDateOverride()

void SetTodayDateOverride ( const COleDateTime & dtTodayOverride )

This member function is used to override the "today" date.

Calendar control will assume the date provided as "today" The today date is used to draw highlight border for day views (mark them as today).

Parameters
dtTodayOverride reference to a COleDateTime object

◆ SetWorkDayEndTime() [1/2]

void SetWorkDayEndTime ( const COleDateTime & dtTime )

This member function sets an end time for the working day.

Parameters
dtTime A new end time value.
See also
GetWorkDayEndTime
GetWorkDayStartTime
SetWorkDayStartTime

◆ SetWorkDayEndTime() [2/2]

void SetWorkDayEndTime | ( | int | nHour,
 |  | int | nMin,
 |  | int | nSec )

This member function sets an end time for the working day.

Parameters
nHour | An int. The hour part of the new time value.
nMin | An int. The minutes part of the new time value.
nSec | An int. The seconds part of the new time value.
See also
GetWorkDayEndTime
GetWorkDayStartTime
SetWorkDayStartTime

◆ SetWorkDayStartTime() [1/2]

void SetWorkDayStartTime ( const COleDateTime & dtTime )

This member function sets the begin time for the working day.

Parameters
dtTime A new begin time value.
See also
GetWorkDayStartTime
GetWorkDayEndTime
SetWorkDayEndTime

◆ SetWorkDayStartTime() [2/2]

void SetWorkDayStartTime | ( | int | nHour,
 |  | int | nMin,
 |  | int | nSec )

This member function sets the begin time for the working day.

Parameters
nHour | An int. The hour part of the new time value.
nMin | An int. The minutes part of the new time value.
nSec | An int. The seconds part of the new time value.
See also
GetWorkDayStartTime
GetWorkDayEndTime
SetWorkDayEndTime

◆ SetWorkWeekMask()

void SetWorkWeekMask ( const int nMask )

This member function sets the bitwise mask for the work week.

Parameters
nMask An int that contains the new bitwise mask for the work week.
See also
GetWorkWeekMask
XTPCalendarWeekDay

◆ ShowToolTip()

virtual void ShowToolTip | ( | const CString & | strText,
 |  | const CRect | rcToolTip,
 |  | CFont * | pFont,
 |  | BOOL | bAdvanced = FALSE )
 virtual

This member function is used to show a ToolTip rectangle.

Parameters
strText | A text to be shown inside a tooltip rectangle.
rcToolTip | A rect for a tooltip window.
pFont | Font for to draw tooltip text.
bAdvanced | TRUE for advanced processing (Office2007 theme "add new appt").

◆ SwitchActiveView()

virtual void SwitchActiveView ( XTPCalendarViewType eView )
virtual

This member function sets a predefined calendar view for the control.

Parameters
eView Calendar view type.

Call this member function to set the predefined calendar view that is currently used by this calendar control.

See also
CXTPCalendarView overview
XTPCalendarViewType
GetActiveView

◆ UpdateMouseCursor()

virtual BOOL UpdateMouseCursor ( )
virtual

This member function updates the mouse cursor in relation with the control's state.

Returns
A BOOL. TRUE if the mouse cursor was updated to one of the known modes, FALSE if the mode is unknown and the cursor was set to default arrow.

◆ WeekView_IsShowEndDate()

BOOL WeekView_IsShowEndDate ( ) const

Call this method to determine if the end date is shown for events in the week view.

Returns
TRUE if the end date is shown. FALSE otherwise.
See also
WeekView_SetShowEndDate

◆ WeekView_IsShowTimeAsClocks()

BOOL WeekView_IsShowTimeAsClocks ( ) const

Call this method to determine if the time is shown as a graphical clock for events in the week view.

Returns
TRUE for time shown as graphical clocks, FALSE otherwise.
See also
WeekView_SetShowTimeAsClocks

◆ WeekView_SetShowEndDate()

void WeekView_SetShowEndDate ( BOOL bShowEnd )

Call this method to specify if the end date is shown in week view.

Parameters
bShowEnd A BOOL. TRUE if the end date is shown in week view. FALSE otherwise.
See also
WeekView_IsShowEndDate

◆ WeekView_SetShowTimeAsClocks()

void WeekView_SetShowTimeAsClocks ( BOOL bShowClocks )

Call this method to specify if the events start and end time is shown as a graphical clock in week view.

Parameters
bShowClocks A BOOL. TRUE for time to be shown as graphical clocks, FALSE otherwise.
See also
WeekView_IsShowTimeAsClocks

Member Data Documentation

◆ m_bDisableRedraw

BOOL m_bDisableRedraw

If TRUE - control window is not redraw, it is draw last window content (draw cached bitmap).

FALSE by default.

◆ m_sCustomTitle

CString m_sCustomTitle

used for unique title - e.g.

for PrintJob name

The documentation for this class was generated from the following file:
  • XTPCalendarControl.h


Toolkit Pro: CXTPCalendarControl::CUpdateContext Class Reference

  • CXTPCalendarControl
  • CUpdateContext
Public Member Functions | List of all members
CXTPCalendarControl::CUpdateContext Class Reference

Class CUpdateContext updates context and redraws control parts depending on input parameters. More...

Public Member Functions

CUpdateContext (CXTPCalendarControl *pControl, int nOptions=xtpCalendarUpdateLayout|xtpCalendarUpdateRedraw)
Constructs a CUpdateContext object.
~CUpdateContext ()
Destroys a CUpdateContext object and calls all the required Calendar Control adjusting and redrawing functions.

Detailed Description

Class CUpdateContext updates context and redraws control parts depending on input parameters.

See also
XTPCalendarUpdateOptions
AdjustLayout
AdjustScrollBar
RedrawControl

Constructor & Destructor Documentation

◆ CUpdateContext()

CUpdateContext | ( | CXTPCalendarControl * | pControl,
 |  | int | nOptions = xtpCalendarUpdateLayout | xtpCalendarUpdateRedraw )
 inline

Constructs a CUpdateContext object.

Parameters
pControl | Pointer to the CXTPCalendarControl to adjust.
nOptions | A bitwise combination of the adjusting parameters.

When constructing a CUpdateContext object, specify if the control's layout needs adjustment and/or redrawing.

See also
XTPCalendarUpdateOptions

◆ ~CUpdateContext()

~CUpdateContext ( )
inline

Destroys a CUpdateContext object and calls all the required Calendar Control adjusting and redrawing functions.

See also
XTPCalendarUpdateOptions
The documentation for this class was generated from the following file:
  • XTPCalendarControl.h


Toolkit Pro: CXTPCalendarControl::CViewChanged_ContextData Class Reference

  • CXTPCalendarControl
  • CViewChanged_ContextData
Public Member Functions | Public Attributes | List of all members
CXTPCalendarControl::CViewChanged_ContextData Class Reference

Class CViewChanged_ContextData is used as locker context for CViewChangedContext. More...

Public Member Functions

CViewChanged_ContextData ()
Default object constructor.

Public Attributes

int | m_nLockCount
View change notification lock counter.
BOOL | m_bRequest
View change send notification request.

Detailed Description

Class CViewChanged_ContextData is used as locker context for CViewChangedContext.

The documentation for this class was generated from the following file:
  • XTPCalendarControl.h


Toolkit Pro: CXTPCalendarControl::CViewChangedContext Class Reference

  • CXTPCalendarControl
  • CViewChangedContext
Public Member Functions | List of all members
CXTPCalendarControl::CViewChangedContext Class Reference

Class CViewChangedContext used to avoid multiple sending of XTP_NC_CALENDARVIEWWASCHANGED notification for one action. More...

Public Member Functions

CViewChangedContext (CXTPCalendarView *pView, int eType=xtpCalendarViewChangedSend)
Constructs a CViewChangedContext object.
CViewChangedContext (CXTPCalendarControl *pControl, int eType=xtpCalendarViewChangedSend)
Constructs a CViewChangedContext object.
virtual ~CViewChangedContext ()
Destroys a CViewChangedContext object and send notification if this is last locker object.

Detailed Description

Class CViewChangedContext used to avoid multiple sending of XTP_NC_CALENDARVIEWWASCHANGED notification for one action.

Constructor & Destructor Documentation

◆ CViewChangedContext() [1/2]

CViewChangedContext | ( | CXTPCalendarView * | pView,
 |  | int | eType = xtpCalendarViewChangedSend )

Constructs a CViewChangedContext object.

Parameters
pView | Pointer to parent CXTPCalendarView object.
eType | Value from enum XTPCalendarViewChangedUpdateOptions.
See also
XTP_NC_CALENDARVIEWWASCHANGED

◆ CViewChangedContext() [2/2]

CViewChangedContext | ( | CXTPCalendarControl * | pControl,
 |  | int | eType = xtpCalendarViewChangedSend )

Constructs a CViewChangedContext object.

Parameters
pControl | Pointer to parent CXTPCalendarControl object.
eType | Value from enum XTPCalendarViewChangedUpdateOptions.
See also
XTP_NC_CALENDARVIEWWASCHANGED
The documentation for this class was generated from the following file:
  • XTPCalendarControl.h


Toolkit Pro: CXTPCalendarController Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPCalendarController Class Reference

Class CXTPCalendarController provides a connection between a CXTPCalendarControl object and a CXTPDatePickerControl object. More...

Inheritance diagram for CXTPCalendarController:
[legend]

Public Member Functions

CXTPCalendarController ()
Constructs a CXTPCalendarController object.
virtual | ~CXTPCalendarController ()
Destroys a CXTPCalendarController object, handles cleanup and deallocation.
virtual void | SetCalendar (CXTPCalendarControl *pCalendarCtrl)
This member function associates a custom calendar control with the controller.
virtual void | SetDatePicker (CXTPDatePickerControl *pDatePickerCtrl)
This member function associates a custom date picker control with the controller.
virtual CXTPCalendarControl * | GetCalendar () const
Gets a calendar control object associated with the controller.
virtual CXTPDatePickerControl * | GetDatePicker () const
Gets a date picker control object associated with the controller.
virtual BOOL | IsBoldDaysWithEvents () const
This member function is used to determine whether Bold font is used for days in DatePicker which have corresponding Calendar events.
virtual void | SetBoldDaysWithEvents (BOOL bBold)
This member function enables or disables Bold font usage for displaying days in DatePicker which have corresponding Calendar events.
virtual BOOL | IsBoldDaysOnIdle () const
Is BoldDaysOnIdle option enabled or disabled.
virtual void | SetBoldDaysOnIdle (BOOL bBoldDaysOnIdle)
Enable or Disable retrieve days state (bold or regular) on idle (by timer) for the associated DatePicker.
virtual long | GetBoldDaysPerIdleStep () const
Returns Amount of days for the associated DatePicker to update state in one idle step.
virtual long | GetBoldDaysIdleStepTime_ms () const
Returns time between idle steps to update days state (bold or regular) for the associated DatePicker.
virtual void | SetBoldDaysPerIdleStep (long nDaysPerStep)
Set amount of days for the associated DatePicker to update state in one idle step.
virtual void | SetBoldDaysIdleStepTime_ms (long nStepTime_ms)
Set time (in milliseconds) between idle steps to update days state (bold or regular) for the associated DatePicker.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

virtual void | AdviseToNotifications ()
This member function subscribes itself for all necessary notifications.
virtual void | SetFirstDayOfWeekToDatePicker ()
This member function gets the first day of week from the calendar control and set the same value to the date picker control.
virtual void | OnEvent_CalendarView (XTP_NOTIFY_CODE Event, WPARAM wParam, LPARAM lParam)
This member function is used to determine if Compressed Weekend Day - Sunday, is used as the first day of week in the active calendar view.
virtual void | OnEvent_CalendarOptionsChanged (XTP_NOTIFY_CODE Event, WPARAM wParam, LPARAM lParam)
This member function catches all the events when calendar control options were changed.
virtual void | OnEvent_CalendarResourcesChanged (XTP_NOTIFY_CODE Event, WPARAM wParam, LPARAM lParam)
This member function catches all the events when resource configuration is changed in the CalendarControl.
virtual void | OnEvent_CalendarThemeChanged (XTP_NOTIFY_CODE Event, WPARAM wParam, LPARAM lParam)
This member function catches the XTP_NC_CALENDAR_THEME_CHANGED event.
virtual void | OnEvent_DatePicker (XTP_NOTIFY_CODE Event, WPARAM wParam, LPARAM lParam)
This member function catches all the events from the associated date picker control.
virtual void | OnEvent_DtPickGetItemMetrics (XTP_NOTIFY_CODE Event, WPARAM wParam, LPARAM lParam)
This member function catches all the events from the associated date picker control.
BOOL | _HasEvents (COleDateTime dtDay)
This member function is used to determine if the specified day has events or not.

Protected Attributes

CXTPCalendarControl * | m_pCalendarCtrl
Pointer to the associated Calendar control.
CXTPDatePickerControl * | m_pDatePickerCtrl
Pointer to the associated DatePicker control.
BOOL | m_bBoldDaysWithEvents
TRUE to use Bold for days with events in the associated DatePicker.
BOOL | m_bUseActiveViewResoucesForBold
If true - active view resources are used, if FALSE - calendar control Resources are used.
BOOL | m_bBoldDaysOnIdle
TRUE to retrieve days state (bold or regular) on idle (by timer) for the associated DatePicker.
long | m_nBoldDaysPerIdleStep
Amount of days for the associated DatePicker to update state in one idle step.
long | m_nBoldDaysIdleStepTime_ms
Time between idle steps to update days state (bold or regular) for the associated DatePicker.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

Class CXTPCalendarController provides a connection between a CXTPCalendarControl object and a CXTPDatePickerControl object.

A CXTPCalendarController object provides synchronization facilities between CXTPCalendarControl and CXTPDatePickerControl controls. It works as a "glue" between both controls and reflects changes on one of them to the corresponded changes on the second one.

See also
CXTPCalendarControl
CXTPDatePickerControl

Constructor & Destructor Documentation

◆ CXTPCalendarController()

CXTPCalendarController ( )

Constructs a CXTPCalendarController object.

Construction of the CXTPCalendarController object defines a point of synchronization between CXTPCalendarControl and CXTPDatePickerControl controls. It can be constructed both in the same scope with controls which would provide us with full live objects time synchronization, and in the local scope for short time synchronization.

Example:

Declare a local CXTPCalendarController object.
CXTPCalendarController myCalendarController;

// Assigns CXTPCalendarControl instance to the object.
myCalendarController.SetCalendar(&m_wndCalendar);

// Assigns CXTPDatePickerControl instance to the object.
myCalendarController.SetDatePicker(&m_wndDatePicker);
See also
SetCalendar
SetDatePicker

Member Function Documentation

◆ _HasEvents()

BOOL _HasEvents ( COleDateTime dtDay )
protected

This member function is used to determine if the specified day has events or not.

Parameters
dtDay A COleDateTime object that contains the day's date.
Returns
TRUE if the specified day has events, FALSE otherwise.

◆ AdviseToNotifications()

virtual void AdviseToNotifications ( )
protectedvirtual

This member function subscribes itself for all necessary notifications.

This member function is called when controller object wants to reinitialize its event subscriptions from associated controls.

See also
CXTPCalendarController overview

◆ GetBoldDaysIdleStepTime_ms()

AFX_INLINE long GetBoldDaysIdleStepTime_ms ( ) const
virtual

Returns time between idle steps to update days state (bold or regular) for the associated DatePicker.

Returns
Time between idle steps in milliseconds.
See also
SetBoldDaysOnIdle
IsBoldDaysOnIdle
GetBoldDaysPerIdleStep
SetBoldDaysPerIdleStep
SetBoldDaysIdleStepTime_ms

◆ GetBoldDaysPerIdleStep()

AFX_INLINE long GetBoldDaysPerIdleStep ( ) const
virtual

Returns Amount of days for the associated DatePicker to update state in one idle step.

Returns
Amount of days for the associated DatePicker to update state in one idle step.
See also
SetBoldDaysOnIdle
IsBoldDaysOnIdle
GetBoldDaysIdleStepTime_ms
SetBoldDaysPerIdleStep
SetBoldDaysIdleStepTime_ms

◆ GetCalendar()

virtual CXTPCalendarControl * GetCalendar ( ) const
virtual

Gets a calendar control object associated with the controller.

Returns
A pointer to calendar control.

A pointer to calendar control object associated with the controller or NULL.

See also
SetCalendar
SetDatePicker
GetDatePicker

◆ GetDatePicker()

virtual CXTPDatePickerControl * GetDatePicker ( ) const
virtual

Gets a date picker control object associated with the controller.

Returns
A pointer to the date picker control.

A pointer to date picker control object associated with the controller or NULL.

See also
SetCalendar
SetDatePicker
GetCalendar

◆ IsBoldDaysOnIdle()

AFX_INLINE BOOL IsBoldDaysOnIdle ( ) const
virtual

Is BoldDaysOnIdle option enabled or disabled.

Returns
TRUE if enabled retrieve days state (bold or regular) on idle (by timer) for the associated DatePicker.
See also
SetBoldDaysOnIdle
GetBoldDaysPerIdleStep
GetBoldDaysIdleStepTime_ms
SetBoldDaysPerIdleStep
SetBoldDaysIdleStepTime_ms

◆ IsBoldDaysWithEvents()

AFX_INLINE BOOL IsBoldDaysWithEvents ( ) const
virtual

This member function is used to determine whether Bold font is used for days in DatePicker which have corresponding Calendar events.

Returns
TRUE when Bold font is used, FALSE otherwise.
See also
SetBoldDaysWithEvents

◆ OnEvent_CalendarOptionsChanged()

virtual void OnEvent_CalendarOptionsChanged | ( | XTP_NOTIFY_CODE | Event,
 |  | WPARAM | wParam,
 |  | LPARAM | lParam )
 protectedvirtual

This member function catches all the events when calendar control options were changed.

Parameters
Event | Events code.
wParam | First user's parameter.
lParam | Second user's parameter.

This member function is called when an event is fired when calendar control options where changed.

See also
AdviseToNotifications

◆ OnEvent_CalendarResourcesChanged()

virtual void OnEvent_CalendarResourcesChanged | ( | XTP_NOTIFY_CODE | Event,
 |  | WPARAM | wParam,
 |  | LPARAM | lParam )
 protectedvirtual

This member function catches all the events when resource configuration is changed in the CalendarControl.

Parameters
Event | Events code.
wParam | First user's parameter.
lParam | Second user's parameter.
See also
AdviseToNotifications

◆ OnEvent_CalendarThemeChanged()

virtual void OnEvent_CalendarThemeChanged | ( | XTP_NOTIFY_CODE | Event,
 |  | WPARAM | wParam,
 |  | LPARAM | lParam )
 protectedvirtual

This member function catches the XTP_NC_CALENDAR_THEME_CHANGED event.

Parameters
Event | Events code.
wParam | First user's parameter.
lParam | Second user's parameter.
See also
AdviseToNotifications

◆ OnEvent_CalendarView()

virtual void OnEvent_CalendarView | ( | XTP_NOTIFY_CODE | Event,
 |  | WPARAM | wParam,
 |  | LPARAM | lParam )
 protectedvirtual

This member function is used to determine if Compressed Weekend Day - Sunday, is used as the first day of week in the active calendar view.

It means that first day of week is automatically shifted from Sunday to Monday because Sunday is compressed with Saturday and it cannot be shown as first day of week in the active calendar view.

See also
CXTPCalendarWeekView
CXTPCalendarMonthView,
CXTPCalendarControl::MonthView_IsCompressWeekendDays()
CXTPCalendarControl::GetFirstDayOfWeek()

This member function catches all the events from the associated calendar control and its view.

Parameters
Event | Events code.
wParam | First user's parameter.
lParam | Second user's parameter.

This member function is called when an event is fired from the associated CXTPCalendarControl object or from its view.

See also
AdviseToNotifications

◆ OnEvent_DatePicker()

virtual void OnEvent_DatePicker | ( | XTP_NOTIFY_CODE | Event,
 |  | WPARAM | wParam,
 |  | LPARAM | lParam )
 protectedvirtual

This member function catches all the events from the associated date picker control.

Parameters
Event | Events code.
wParam | First user's parameter.
lParam | Second user's parameter.

This member function is called when an event is fired from the associated CXTPDatePickerControl object.

See also
AdviseToNotifications

◆ OnEvent_DtPickGetItemMetrics()

virtual void OnEvent_DtPickGetItemMetrics | ( | XTP_NOTIFY_CODE | Event,
 |  | WPARAM | wParam,
 |  | LPARAM | lParam )
 protectedvirtual

This member function catches all the events from the associated date picker control.

Parameters
Event | Events code.
wParam | First user's parameter.
lParam | Second user's parameter.

This member function is called when an event is fired from the associated CXTPDatePickerControl object.

See also
AdviseToNotifications

◆ SetBoldDaysIdleStepTime_ms()

AFX_INLINE void SetBoldDaysIdleStepTime_ms ( long nStepTime_ms )
virtual

Set time (in milliseconds) between idle steps to update days state (bold or regular) for the associated DatePicker.

Parameters
nStepTime_ms An idle step in milliseconds.
See also
SetBoldDaysOnIdle
IsBoldDaysOnIdle
GetBoldDaysPerIdleStep
SetBoldDaysPerIdleStep
GetBoldDaysIdleStepTime_ms

◆ SetBoldDaysOnIdle()

AFX_INLINE void SetBoldDaysOnIdle ( BOOL bBoldDaysOnIdle )
virtual

Enable or Disable retrieve days state (bold or regular) on idle (by timer) for the associated DatePicker.

Parameters
bBoldDaysOnIdle Set as TRUE to Enable or FALSE to Disable retrieve days state on idle.
See also
IsBoldDaysOnIdle
GetBoldDaysPerIdleStep
GetBoldDaysIdleStepTime_ms
SetBoldDaysPerIdleStep
SetBoldDaysIdleStepTime_ms

◆ SetBoldDaysPerIdleStep()

AFX_INLINE void SetBoldDaysPerIdleStep ( long nDaysPerStep )
virtual

Set amount of days for the associated DatePicker to update state in one idle step.

Parameters
nDaysPerStep An amount of days to update in one step.
See also
SetBoldDaysOnIdle
IsBoldDaysOnIdle
GetBoldDaysIdleStepTime_ms
GetBoldDaysPerIdleStep
SetBoldDaysIdleStepTime_ms

◆ SetBoldDaysWithEvents()

virtual void SetBoldDaysWithEvents ( BOOL bBold )
virtual

This member function enables or disables Bold font usage for displaying days in DatePicker which have corresponding Calendar events.

Parameters
bBold TRUE to enable; FALSE to disable.

Disabling this parameter could be useful in cases when determining whether a particular day has events takes a long time.

See also
IsBoldDaysWithEvents

◆ SetCalendar()

virtual void SetCalendar ( CXTPCalendarControl * pCalendarCtrl )
virtual

This member function associates a custom calendar control with the controller.

Parameters
pCalendarCtrl A pointer to the user's CXTPCalendarControl object.

Call this member function to associate your CXTPCalendarControl object with this calendar controller.

See also
CXTPCalendarControl overview
SetDatePicker

◆ SetDatePicker()

virtual void SetDatePicker ( CXTPDatePickerControl * pDatePickerCtrl )
virtual

This member function associates a custom date picker control with the controller.

Parameters
pDatePickerCtrl Pointer to the user's CXTPDatePickerControl object.

Call this member function to associate your CXTPDatePickerControl object with this calendar controller.

See also
CXTPDatePickerControl overview
SetCalendar

◆ SetFirstDayOfWeekToDatePicker()

virtual void SetFirstDayOfWeekToDatePicker ( )
protectedvirtual

This member function gets the first day of week from the calendar control and set the same value to the date picker control.

See also
OnEvent_CalendarOptionsChanged()
CXTPCalendarController overview
The documentation for this class was generated from the following file:
  • XTPCalendarController.h


Toolkit Pro: CXTPCalendarControlView Class Reference

Public Member Functions | Public Attributes | Protected Member Functions | Static Protected Member Functions | Protected Attributes | List of all members
CXTPCalendarControlView Class Reference

The CXTPCalendarControlView class provides an implementation of the Calendar control as a view class. More...

Public Member Functions

virtual CXTPCalendarControl & | GetCalendarCtrl ()
Call this method to access a Calendar control object.
virtual CXTPCalendarCaptionBarControl & | GetCalendarCaptionBarCtrl ()
Call this method to access a CaptionBar control object.
virtual void | SetCalendarCtrl (CXTPCalendarControl *pCalendar, BOOL bReleaseWhenDestroy=TRUE)
Call this method to set a custom Calendar control object.
CXTPCalendarControlViewPrintOptions * | GetPrintOptions () const
Call this method to access print options for this view.
void | SetScrollBarCtrl (CScrollBar *pScrollBar, int nBar=SB_VERT)
Use this member function to set external scroll bar control.
virtual BOOL | IsShowCaptionBar () const
Call this method to retrieve a Caption Bar control's visible state.
virtual void | ShowCaptionBar (BOOL bShow)
Call this method to show or hide a Caption Bar control.

Public Attributes

BOOL | m_bPrintDirect
if TRUE - the Print Dialog is bypassed.
BOOL | m_bResizeControlWithView
if FALSE - attached Calendar control will not be resized with view.
BOOL | m_bPrintFullScale
extra flag for printing if no Range on Print Option selected, FALSE
BOOL | m_bPrintFineMode
if TRUE - default and all Print Option features, if FALSE - B/W print without Header and Footer
BOOL | m_bPrintRepeatHeaderFooterMode
flag to repeat readers and footers on each page
BOOL | m_bDF_mode
Last page print mode flag (FALSE - print last page same size as other, TRUE (default) - can be shorter then others)
COleDateTime | m_dtTimeScaleOldMaxTime
stored original time scale settings during print / print preview
COleDateTime | m_dtTimeScaleOldMinTime
stored original time scale settings during print / print preview ext print support

Protected Member Functions

CXTPCalendarControlView ()
Protected constructor used by dynamic creation.
virtual | ~CXTPCalendarControlView ()
Destroys a CXTPCalendarControlView object, handles cleanup and deallocation.
virtual void | DrawDateHeader (BOOL bCalculate, CDC *pDC, CRect &rrcHeader)
Draws main (central) date header area.
virtual void | _DrawDateHeaderCalendar (BOOL bCalculate, CDC *pDC, COleDateTime dtYearMonth, CRect &rrcHeaderCalendar)
Draws month calendar in the right part of the central date header area.
virtual int | _GetDateHeaderMonths (COleDateTime &dtYearMonth1, COleDateTime &dtYearMonth2, CString &strHeader1, CString &strHeader2, CString &strHeaderWeekDay)
Calculates a number of shown months and captions for them to be drawn on the date header.
virtual CRect | AdjustCalendarForPrint (CDC *pDC, CRect rcCalendar, CPrintInfo *pInfo)
Adjusts a calendar printing rectangle by adding space for a header, footer and similar areas.

Static Protected Member Functions

static CRect AFX_CDECL _HimetricToLP (CDC *pDC, const CRect rcHimetric)
Converts a rectangle of HIMETRIC units into logical units.

Protected Attributes

COleDateTime | m_dtPrintFrom
Top bound of the printing area for a day view.
COleDateTime | m_dtPrintTo
Bottom bound of the printing area for a day view.
CXTPCalendarControlViewPrintOptions * | m_pPrintOptions
Printing options.
BOOL | m_bShowCaptionBar
Store Office 2007 theme Calendar Caption Bar state.

Detailed Description

The CXTPCalendarControlView class provides an implementation of the Calendar control as a view class.

Use the GetCalendarCtrl() method to access methods of CXTPCalendarControl.

See also
CXTPCalendarControl

Member Function Documentation

◆ _DrawDateHeaderCalendar()

virtual void _DrawDateHeaderCalendar | ( | BOOL | bCalculate,
 |  | CDC * | pDC,
 |  | COleDateTime | dtYearMonth,
 |  | CRect & | rrcHeaderCalendar )
 protectedvirtual

Draws month calendar in the right part of the central date header area.

Parameters
bCalculate | If TRUE, then only calculate rectangles and do not performs drawing itself.
pDC | Pointer to a valid device context.
dtYearMonth | Which month's calendar to draw.
rrcHeaderCalendar | [out] Drawn rectangle area.

◆ _GetDateHeaderMonths()

virtual int _GetDateHeaderMonths | ( | COleDateTime & | dtYearMonth1,
 |  | COleDateTime & | dtYearMonth2,
 |  | CString & | strHeader1,
 |  | CString & | strHeader2,
 |  | CString & | strHeaderWeekDay )
 protectedvirtual

Calculates a number of shown months and captions for them to be drawn on the date header.

Parameters
dtYearMonth1 | Bottom boundary of the date period.
dtYearMonth2 | Top boundary of the date period.
strHeader1 | [out] Bottom boundary caption.
strHeader2 | [out] Top boundary caption.
strHeaderWeekDay | [out] Week day name (for a single day view only).
Returns
A number of months between the bottom and top boundaries, including them.

◆ _HimetricToLP()

static CRect AFX_CDECL _HimetricToLP | ( | CDC * | pDC,
 |  | const CRect | rcHimetric )
 staticprotected

Converts a rectangle of HIMETRIC units into logical units.

Parameters
pDC | Pointer to a valid device context.
rcHimetric | A rectangle to convert in HIMETRIC units.

Use this function when you get HIMETRIC sizes from OLE and wish to convert them to your application's natural mapping mode. The conversion is accomplished by first converting the HIMETRIC units into pixels and then converting these units into logical units using the device context's current mapping units. Note that the extents of the device's window and viewport will affect the result.

Returns
A converted rectangle in logical units.
See also
CDC::HIMETRICtoLP()

◆ AdjustCalendarForPrint()

virtual CRect AdjustCalendarForPrint | ( | CDC * | pDC,
 |  | CRect | rcCalendar,
 |  | CPrintInfo * | pInfo )
 protectedvirtual

Adjusts a calendar printing rectangle by adding space for a header, footer and similar areas.

Parameters
pDC | Pointer to a valid device context.
rcCalendar | Calendar printing rectangle.
pInfo | Pointer to calendar Print Options object.
Returns
An adjusted calendar printing rectangle.

◆ DrawDateHeader()

virtual void DrawDateHeader | ( | BOOL | bCalculate,
 |  | CDC * | pDC,
 |  | CRect & | rrcHeader )
 protectedvirtual

Draws main (central) date header area.

Parameters
bCalculate | If TRUE, then only calculate rectangles and do not performs drawing itself.
pDC | Pointer to a valid device context.
rrcHeader | [out] Drawn rectangle area.

◆ GetCalendarCaptionBarCtrl()

AFX_INLINE CXTPCalendarCaptionBarControl & GetCalendarCaptionBarCtrl ( )
virtual

Call this method to access a CaptionBar control object.

Returns
Reference to a child GetCalendarCaptionBarCtrl window.

◆ GetCalendarCtrl()

virtual CXTPCalendarControl & GetCalendarCtrl ( )
virtual

Call this method to access a Calendar control object.

Returns
Reference to a child CXTPCalendarControl window.

◆ GetPrintOptions()

AFX_INLINE CXTPCalendarControlViewPrintOptions * GetPrintOptions ( ) const

Call this method to access print options for this view.

Returns
Pointer to an object describing print options of this view.

◆ IsShowCaptionBar()

virtual BOOL IsShowCaptionBar ( ) const
virtual

Call this method to retrieve a Caption Bar control's visible state.

Returns
TRUE if the Caption Bar is visible, FALSE otherwise.
See also
ShowCaptionBar
CXTPCalendarCaptionBarControl

◆ SetCalendarCtrl()

virtual void SetCalendarCtrl | ( | CXTPCalendarControl * | pCalendar,
 |  | BOOL | bReleaseWhenDestroy = TRUE )
 virtual

Call this method to set a custom Calendar control object.

Parameters
pCalendar | Pointer to custom report object.
bReleaseWhenDestroy | Set this parameter as TRUE to call InternalRelease for pCalendar object on destroy of CXTPCalendarControlView.

◆ SetScrollBarCtrl()

void SetScrollBarCtrl | ( | CScrollBar * | pScrollBar,
 |  | int | nBar = SB_VERT )

Use this member function to set external scroll bar control.

Parameters
pScrollBar | Pointer to a scrollbar object.
nBar | Specifies the bar orientation either SB_VERT or SB_HORZ.
See also
CScrollBar

◆ ShowCaptionBar()

virtual void ShowCaptionBar ( BOOL bShow )
virtual

Call this method to show or hide a Caption Bar control.

Parameters
bShow Set this parameter as TRUE to show Caption Bar and as FALSE to hide it.
See also
IsShowCaptionBar
CXTPCalendarCaptionBarControl

Member Data Documentation

◆ m_bPrintDirect

BOOL m_bPrintDirect

if TRUE - the Print Dialog is bypassed.

FALSE by default.

◆ m_bPrintFullScale

BOOL m_bPrintFullScale

extra flag for printing if no Range on Print Option selected, FALSE

  • use Working hour range, TRUE - Time Scale range

◆ m_bResizeControlWithView

BOOL m_bResizeControlWithView

if FALSE - attached Calendar control will not be resized with view.

TRUE by default.

The documentation for this class was generated from the following file:
  • XTPCalendarControlView.h


Toolkit Pro: CXTPCalendarControlViewPrintOptions Class Reference

Public Member Functions | Public Attributes | List of all members
CXTPCalendarControlViewPrintOptions Class Reference

Describes printing options for the Calendar Control. More...

Public Member Functions

CXTPCalendarControlViewPrintOptions ()
Default constructor.
void | Set (const CXTPCalendarControlViewPrintOptions *pSrc)
Copies all print options from a specified PrintOptions object.
virtual LCID | GetActiveLCID ()
Override this member function in a derived class to retrieve the active locale ID.

Public Attributes

COleDateTime | m_dtPrintFrom
Top bound of the printing area for a day view.
COleDateTime | m_dtPrintTo
Bottom bound of the printing area for a day view.
BOOL | m_bPrintFromToExactly
Defines whether to cut printing area by showing only area between m_dtPrintFrom and m_dtPrintTo.
COleDateTime | m_dtMonthViewPrintBeginDate
Begin date to print for multi month print option.
COleDateTime | m_dtMonthViewPrintEndDate
End date to print for multi month print option.
BOOL | m_bPrintDateHeader
Defines whether to print a date header or not.
LOGFONT | m_lfDateHeaderFont
Font for day header caption (Day 1 - Day 2)
LOGFONT | m_lfDateHeaderWeekDayFont
Font for day header week day(Monday, ...)
LOGFONT | m_lfDateHeaderCalendarFont
Font for day header small calendar.
BOOL | m_b3SmallCal
Print 3 small calendars in header instead of 1.

Detailed Description

Describes printing options for the Calendar Control.

Use this class when you want to programmatically customize printing options for the Calendar control.

See each property description to examine which customization options are available.

See also
CXTPPrintOptions
CXTPCalendarPageSetupDialog overview

Member Function Documentation

◆ GetActiveLCID()

virtual LCID GetActiveLCID ( )
virtual

Override this member function in a derived class to retrieve the active locale ID.

Returns
Locale ID. Base implementation returns LOCALE_USER_DEFAULT;

◆ Set()

void Set ( const CXTPCalendarControlViewPrintOptions * pSrc )

Copies all print options from a specified PrintOptions object.

Parameters
pSrc - Pointer to the object to copy options from.
The documentation for this class was generated from the following file:
  • XTPCalendarControlView.h


Toolkit Pro: CXTPCalendarCustomDataProvider Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPCalendarCustomDataProvider Class Reference

Custom implementation of XTPCalendarData based on notifications. More...

Inheritance diagram for CXTPCalendarCustomDataProvider:
[legend]

Public Member Functions

CXTPCalendarCustomDataProvider ()
Default constructor.
virtual | ~CXTPCalendarCustomDataProvider ()
Default Destructor.
virtual void | Close ()
Call this member function to close the connection to a data source.
- Public Member Functions inherited from CXTPCalendarData
CXTPCalendarData ()
Default constructor.
virtual | ~CXTPCalendarData ()
Default Destructor.
virtual BOOL | Open ()
Call this member function to initialize a newly constructed Data object.
virtual BOOL | Create ()
Call this member function to create a file for storing custom data provider data.
virtual BOOL | Save ()
This method saves data to the file.
virtual BOOL | IsOpen () const
This method determines whether a data source connection is opened.
virtual XTPCalendarDataProvider | GetType () const
This method determines the type of the current Data Provider implementation.
virtual CXTPCalendarEventsPtr | RetrieveDayEvents (COleDateTime dtDay)
Retrieves day events for a specified day from the data source.
virtual CXTPCalendarEventPtr | CreateNewEvent (DWORD dwEventID=XTP_CALENDAR_UNKNOWN_EVENT_ID)
Creates a new empty CXTPCalendarEvent object.
virtual CXTPCalendarRecurrencePatternPtr | CreateNewRecurrencePattern (DWORD dwPatternID=XTP_CALENDAR_UNKNOWN_RECURRENCE_PATTERN_ID)
Creates a new empty CXTPCalendarRecurrencePattern object.
virtual CXTPCalendarEventPtr | GetEvent (DWORD dwEventID)
Reads an event from the data source.
virtual CXTPCalendarRecurrencePatternPtr | GetRecurrencePattern (DWORD dwPatternID)
Reads a recurrence pattern from the data source.
virtual BOOL | AddEvent (CXTPCalendarEvent *pEvent)
Creates a new event in the data source.
virtual BOOL | AddEvents (CXTPCalendarEvents *pEvents)
Creates a set of events in the data source.
virtual void | RemoveAllEvents ()
Removes all events from the data source.
virtual BOOL | DeleteEvent (CXTPCalendarEvent *pEvent)
Deletes an event from the data source.
virtual BOOL | ChangeEvent (CXTPCalendarEvent *pNewEvent)
Updates event properties in the data source.
virtual CXTPNotifyConnection * | GetConnection () const
Returns a connection pointer for the data source.
virtual CXTPCalendarCustomProperties * | GetCustomProperties () const
Returns a custom properties collection.
virtual CXTPCalendarEventLabels * | GetLabelList () const
Returns a collection of Labels used in this Data source.
virtual CXTPCalendarEventCategories * | GetEventCategories () const
Returns a collection of Event categories.
virtual void | SetLabelList (CXTPCalendarEventLabels *pLabelList)
Set custom collection of Labels to be used in this Data source.
virtual BOOL | AddEventLabel (int nID, CString strName, COLORREF crLabel)
Call this member function to add a new item to the event label list.
virtual BOOL | AddEventCategory (UINT uID, CString strName, COLORREF crBorder, COLORREF crBkBase)
Call this member function to add a new item to the event category list.
virtual void | UpdateEventLabels (COLORREF *clrEventColors, UINT uCount)
Update event labels colors when the theme is changed.
virtual void | ClearEventCategoryList ()
Call this member function to remove all items from the event category list.
virtual void | ClearEventLabelList ()
Call this member function to remove all items from the event label list.
virtual void | RestoreEventCategoryList ()
Call this member function to restore the event category list to default values.
virtual void | RestoreEventLabelList ()
Call this member function to restore the event label list to default values.
void | UpdateEventCategories (COLORREF *pClrBkBase, COLORREF *pClrBorder, int nCount)
This member function updates the default colors of the category list when the theme is changed.
virtual CXTPCalendarSchedules * | GetSchedules () const
Returns a collection of schedules used in this data source.
virtual void | SetConnectionString (LPCTSTR lpszConnectionString)
Sets a data provider connection string.
virtual CString | GetConnectionString () const
Returns a data provider connection string.
virtual CString | GetDataSource ()
Returns a data provider data source.
virtual int | GetCacheMode () const
Determines current cache mode.
virtual void | SetCacheMode (int eCacheMode, CXTPCalendarData *pCacheDataProvider=NULL)
Sets common data provider cache mode.
virtual void | ClearCache ()
Clears common data provider cache.
virtual CXTPCalendarEventsPtr | GetUpcomingEvents (COleDateTime dtFrom=(DATE) 0, COleDateTimeSpan spPeriod=(DATE) 0)
Retrieves a collection of events expiring in the period from dtFrom during next spPeriod.
virtual CXTPCalendarEventsPtr | GetAllEvents_raw ()
This method Gets all events without generating recurrence occurrences.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

virtual CXTPCalendarEventsPtr | DoRetrieveDayEvents (COleDateTime dtDay)
Retrieves day events for a specified day from the data source.
virtual void | DoRemoveAllEvents ()
Removes all events from the data source.
virtual CXTPCalendarEventPtr | DoRead_Event (DWORD dwEventID)
Read event from the data source.
virtual CXTPCalendarRecurrencePatternPtr | DoRead_RPattern (DWORD dwPatternID)
Read recurrence pattern from the data source.
virtual BOOL | DoCreate_Event (CXTPCalendarEvent *pEvent, DWORD &rdwNewEventID)
Creates a new event in the data source.
virtual BOOL | DoUpdate_Event (CXTPCalendarEvent *pEvent)
Updates event properties in the data source.
virtual BOOL | DoDelete_Event (CXTPCalendarEvent *pEvent)
Deletes an event from the data source.
virtual BOOL | DoCreate_RPattern (CXTPCalendarRecurrencePattern *pPattern, DWORD &rdwNewPatternID)
Creates a new recurrence pattern in the data source.
virtual BOOL | DoUpdate_RPattern (CXTPCalendarRecurrencePattern *pPattern)
Updates a recurrence pattern in the database.
virtual BOOL | DoDelete_RPattern (CXTPCalendarRecurrencePattern *pPattern)
Deletes a recurrence pattern from the database.
virtual CXTPCalendarEventsPtr | DoGetAllEvents_raw ()
This method implements Getting all events without generating recurrence occurrences.
virtual CXTPCalendarEventsPtr | DoGetUpcomingEvents (COleDateTime dtFrom, COleDateTimeSpan spPeriod)
This method implements getting a collection of events expiring in the period from dtFrom during next spPeriod.
- Protected Member Functions inherited from CXTPCalendarData
virtual void | SendNotification (XTP_NOTIFY_CODE EventCode, WPARAM wParam, LPARAM lParam)
Sends a notification to all listeners.
virtual BOOL | OnTimeZoneChanged ()
This method is called by the calendar control framework when Time Zone is Changed.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCalendarData
static CXTPCalendarData *AFX_CDECL | CreateDataProvider (LPCTSTR lpszConnectionString)
Call this method to create a data provider from a specified Calendar connection string.
static CXTPCalendarData *AFX_CDECL | CreateDataProvider (XTPCalendarDataProvider eDataProvider)
Call this method to create a data provider of the specified type.
static XTPCalendarDataProvider AFX_CDECL | DataProviderTypeFromConStr (LPCTSTR lpszConnectionString, XTPCalendarDataProvider eDPDefault=xtpCalendarDataProviderUnknown)
Call this method to retrieve a type of the data provider from its connection string.
static CString AFX_CDECL | DataSourceFromConStr (LPCTSTR lpszConnectionString)
Call this method to retrieve a data source connection string from a regular Calendar connection string.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPCalendarData
- Static Protected Member Functions inherited from CXTPCalendarData
static DWORD AFX_CDECL | GetNextFreeTempID ()
Call this member function to get a unique temporary event ID.
- Protected Attributes inherited from CXTPCalendarData
BOOL | m_bOpened
Stores a flag whether a data source connection is open.
CXTPNotifyConnection * | m_pConnection
Connection object to send notifications.
BOOL | m_bDisableNotificationsSending
Stores a flag whether notifications sending is disabled.
CXTPCalendarEventLabels * | m_pLabelList
Event labels list.
CXTPCalendarSchedules * | m_pSchedules
Data source Schedules list.
CXTPCalendarEventCategories * | m_pEventCategories
Store a collection of Event categories.
CXTPCalendarCustomProperties * | m_pCustomProperties
Custom properties collection object.
CString | m_strConnectionString
default connection string;
XTPCalendarDataProvider | m_typeProvider
Data provider type.
CXTPCalendarOptions * | m_pCalendarOptions
This member stores user's calendar view options.
- Static Protected Attributes inherited from CXTPCalendarData
static DWORD | ms_dwNextFreeTempID
Next unique event ID.

Detailed Description

Custom implementation of XTPCalendarData based on notifications.

This class is the implementation of the XTPCalendarData abstract class which represents a data portion of the Calendar control.

This implementation is based on a notifications mechanism. Each significant method sends a custom notification, which could be handled by a user and where a custom data access code should be implemented.

See also
CXTPCalendarData overview

Constructor & Destructor Documentation

◆ CXTPCalendarCustomDataProvider()

CXTPCalendarCustomDataProvider ( )

Default constructor.

Constructs a Data object. To establish a connection to a specified data source and initialize the object you must call Open() member function immediately after construction.

See also
Open()

◆ ~CXTPCalendarCustomDataProvider()

virtual ~CXTPCalendarCustomDataProvider ( )
virtual

Default Destructor.

Handles all deallocation.

Member Function Documentation

◆ DoCreate_Event()

virtual BOOL DoCreate_Event | ( | CXTPCalendarEvent * | pEvent,
 |  | DWORD & | rdwNewEventID )
 protectedvirtual

Creates a new event in the data source.

Parameters
pEvent | Pointer to the CXTPCalendarEvent object which describes all data fields of a newly created record.
rdwNewEventID | [out] EventID of a newly created record.

This method creates a data record corresponding with the specified event.

This implementation of the method sends a notification XTP_NC_CALENDAR_DoCreate_Event which a user can handle and implement a custom method.

Returns
TRUE if event created successfully, FALSE in case of any error during the process.
See also
XTP_NC_CALENDAR_DoCreate_Event notification

Reimplemented from CXTPCalendarData.

◆ DoCreate_RPattern()

virtual BOOL DoCreate_RPattern | ( | CXTPCalendarRecurrencePattern * | pPattern,
 |  | DWORD & | rdwNewPatternID )
 protectedvirtual

Creates a new recurrence pattern in the data source.

Parameters
pPattern | Pointer to the CXTPCalendarRecurrencePattern object which describes all data fields of a newly created record.
rdwNewPatternID | [out] ID of a newly created record

This method creates a data record corresponding with the specified recurrence pattern.

This implementation of the method sends a notification XTP_NC_CALENDAR_DoCreate_RPattern which a user can handle and implement a custom method.

Returns
TRUE if recurrence pattern created successfully, FALSE in case of any error during the process.
See also
XTP_NC_CALENDAR_DoCreate_RPattern notification

Reimplemented from CXTPCalendarData.

◆ DoDelete_Event()

virtual BOOL DoDelete_Event ( CXTPCalendarEvent * pEvent )
protectedvirtual

Deletes an event from the data source.

Parameters
pEvent Pointer to the CXTPCalendarEvent object which describes all data fields of an event.

This method deletes a data record corresponding with the specified event.

This implementation of the method sends a notification XTP_NC_CALENDAR_DoDelete_Event which a user can handle and implement a custom method.

Returns
TRUE if an event deleted successfully, FALSE in case of any errors during the process.
See also
XTP_NC_CALENDAR_DoDelete_Event notification

Reimplemented from CXTPCalendarData.

◆ DoDelete_RPattern()

virtual BOOL DoDelete_RPattern ( CXTPCalendarRecurrencePattern * pPattern )
protectedvirtual

Deletes a recurrence pattern from the database.

Parameters
pPattern Pointer to the CXTPCalendarRecurrencePattern object which should be deleted.

This method deletes a data record corresponding with the specified recurrence pattern.

This implementation of the method sends a notification XTP_NC_CALENDAR_DoDelete_RPattern which a user can handle and implement a custom method.

Returns
TRUE if recurrence pattern deleted successfully, FALSE in case of any error during the process.
See also
XTP_NC_CALENDAR_DoDelete_RPattern notification

Reimplemented from CXTPCalendarData.

◆ DoGetAllEvents_raw()

virtual CXTPCalendarEventsPtr DoGetAllEvents_raw ( )
protectedvirtual

This method implements Getting all events without generating recurrence occurrences.

This method actually implements working with the data source. Simple events are included as is.

This implementation of the method sends a notification XTP_NC_CALENDAR_DoGetAllEvents_raw which a user can handle and implement a custom method.

Returns
A CXTPCalendarEvents pointer containing a collection of all events.
See also
XTP_NC_CALENDAR_DoGetAllEvents_raw notification
GetAllEvents_raw()

Reimplemented from CXTPCalendarData.

◆ DoGetUpcomingEvents()

virtual CXTPCalendarEventsPtr DoGetUpcomingEvents | ( | COleDateTime | dtFrom,
 |  | COleDateTimeSpan | spPeriod )
 protectedvirtual

This method implements getting a collection of events expiring in the period from dtFrom during next spPeriod.

Parameters
dtFrom | Start date and time of a specified period.
spPeriod | A duration of a specified period.

This method is used by a reminders manager.

This implementation of the method sends a notification XTP_NC_CALENDAR_DoGetUpcomingEvents which a user can handle and implement a custom method.

Returns
A CXTPCalendarEvents pointer containing a collection of upcoming events.
See also
CXTPCalendarRemindersManager overview
XTP_NC_CALENDAR_DoGetUpcomingEvents notification

Reimplemented from CXTPCalendarData.

◆ DoRead_Event()

virtual CXTPCalendarEventPtr DoRead_Event ( DWORD dwEventID )
protectedvirtual

Read event from the data source.

Parameters
dwEventID Event ID of the read target.

This method retrieves all data for a specified event.

This implementation of the method sends a notification XTP_NC_CALENDAR_DoRead_Event which a user can handle and implement a custom method.

Returns
A pointer to the new CXTPCalendarEvent object in which fields are filled with data from the data source.
See also
XTP_NC_CALENDAR_DoRead_Event notification

Reimplemented from CXTPCalendarData.

◆ DoRead_RPattern()

virtual CXTPCalendarRecurrencePatternPtr DoRead_RPattern ( DWORD dwPatternID )
protectedvirtual

Read recurrence pattern from the data source.

Parameters
dwPatternID Pattern ID of the read target.

This method retrieves all data for a specified recurrence pattern.

This implementation of the method sends a notification XTP_NC_CALENDAR_DoRead_RPattern which a user can handle and implement a custom method.

Returns
A pointer to the new CXTPCalendarRecurrencePatternPtr object in which fields are filled with data from the data source.
See also
XTP_NC_CALENDAR_DoRead_RPattern notification

Reimplemented from CXTPCalendarData.

◆ DoRemoveAllEvents()

virtual void DoRemoveAllEvents ( )
protectedvirtual

Removes all events from the data source.

This method removes all appointments from the data source.

This implementation of the method sends a notification XTP_NC_CALENDAR_DoRemoveAllEvents which a user can handle and implement a custom method.

See also
XTP_NC_CALENDAR_DoRemoveAllEvents notification

Reimplemented from CXTPCalendarData.

◆ DoRetrieveDayEvents()

virtual CXTPCalendarEventsPtr DoRetrieveDayEvents ( COleDateTime dtDay )
protectedvirtual

Retrieves day events for a specified day from the data source.

Parameters
dtDay A specified day.

This method retrieves all appointments for a specified day from the data source. It includes recurrence appointments occurrences, regular appointments for this day, and multi-day appointments which also have a part of this day.

This implementation of the method sends a notification to XTP_NC_CALENDAR_DoRetrieveDayEvents which a user can handle and implement a custom method.

Returns
A collection of events for a specified day.
See also
XTP_NC_CALENDAR_DoRetrieveDayEvents notification

Reimplemented from CXTPCalendarData.

◆ DoUpdate_Event()

virtual BOOL DoUpdate_Event ( CXTPCalendarEvent * pEvent )
protectedvirtual

Updates event properties in the data source.

Parameters
pEvent Pointer to the CXTPCalendarEvent object which describes all data fields of an event.

This method updates a data record corresponding with the specified event.

This implementation of the method sends a notification XTP_NC_CALENDAR_DoUpdate_Event which a user can handle and implement a custom method.

Returns
TRUE if an event updated successfully, FALSE in case of any errors during the process.
See also
XTP_NC_CALENDAR_DoUpdate_Event notification

Reimplemented from CXTPCalendarData.

◆ DoUpdate_RPattern()

virtual BOOL DoUpdate_RPattern ( CXTPCalendarRecurrencePattern * pPattern )
protectedvirtual

Updates a recurrence pattern in the database.

Parameters
pPattern Pointer to the CXTPCalendarRecurrencePattern object.

This method updates a data record corresponding with the specified recurrence pattern.

This implementation of the method sends a notification XTP_NC_CALENDAR_DoUpdate_RPattern which a user can handle and implement a custom method.

Returns
TRUE if recurrence pattern updated successfully, FALSE in case of any error during the process.
See also
XTP_NC_CALENDAR_DoUpdate_RPattern notification

Reimplemented from CXTPCalendarData.

The documentation for this class was generated from the following file:
  • XTPCalendarCustomDataProvider.h


Toolkit Pro: CXTPCalendarCustomProperties Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPCalendarCustomProperties Class Reference

This class is used to store properties collection. More...

Inheritance diagram for CXTPCalendarCustomProperties:
[legend]

Public Member Functions

CXTPCalendarCustomProperties (BOOL bNameIgnoreCase=TRUE)
Default object constructor.
virtual | ~CXTPCalendarCustomProperties ()
Default object destructor.
virtual BOOL | GetProperty (LPCTSTR pcszName, COleVariant &rVarValue) const
This member function is used to get property value using the specified name.
virtual BOOL | SetProperty (LPCTSTR pcszName, const COleVariant &varValue)
This member function is used to set property value with the specified name.
virtual BOOL | RemoveProperty (LPCTSTR pcszName)
This member function is used to remove property with the specified name.
virtual void | RemoveAll ()
This member function is used to remove all properties.
virtual int | GetCount ()
This member function is to get properties count in the collection.
POSITION | GetStartPosition () const
Starts a properties collection iteration by returning a POSITION value that can be passed to a GetNextProperty call.
void | GetNextProperty (POSITION &rPos, CString &rStrName, COleVariant &rVarValue) const
Retrieves the properties collection element at rPos, then updates rPos to refer to the next element in the collection.
virtual void | DoPropExchange (CXTPPropExchange *pPX)
Call this member function to Store/Load a properties collection using the specified data object.
BOOL | LoadFromXML (LPCTSTR pcszXMLData)
This helper function is used to load a properties collection from a XML string source.
BOOL | SaveToXML (CString &rstrXMLData)
This helper function is used to store a properties collection to a XML string.
void | CopyTo (CXTPCalendarCustomProperties *pDest)
This helper function is used to copy properties from a source collection object to a destination collection.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

void | _Load (CXTPPropExchange *pPX)
Call this member function to Load a properties collection using the specified data object.
void | _Save (CXTPPropExchange *pPX)
Call this member function to Store a properties collection using the specified data object.
CString | PrepareName (LPCTSTR pcszName) const
Call this member function to prepare a property name before passing it to the map access functions.

Protected Attributes

CXTPOleVariantMap | m_mapProperties
Properties storage map.
BOOL | m_bNameIgnoreCase
if TRUE - properties names are not case sensitive.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

This class is used to store properties collection.

It contains methods to Get, Set, Remove and Iterate on properties.

See also
CXTPCalendarEvent::GetCustomProperties()

Constructor & Destructor Documentation

◆ CXTPCalendarCustomProperties()

CXTPCalendarCustomProperties ( BOOL bNameIgnoreCase = TRUE )

Default object constructor.

Parameters
bNameIgnoreCase [in] if TRUE - properties names are not case sensitive.

Member Function Documentation

◆ _Load()

void _Load ( CXTPPropExchange * pPX )
protected

Call this member function to Load a properties collection using the specified data object.

Parameters
pPX Source CXTPPropExchange data object reference.

◆ _Save()

void _Save ( CXTPPropExchange * pPX )
protected

Call this member function to Store a properties collection using the specified data object.

Parameters
pPX Destination CXTPPropExchange data object reference.

◆ CopyTo()

void CopyTo ( CXTPCalendarCustomProperties * pDest )

This helper function is used to copy properties from a source collection object to a destination collection.

Parameters
pDest [out] A pointer to destination properties collection object.

RemoveAll method is called for destination collection before copying.

See also
LoadFromXML
SaveToXML

◆ DoPropExchange()

virtual void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Call this member function to Store/Load a properties collection using the specified data object.

Parameters
pPX Source or destination CXTPPropExchange data object reference.

This member function is used to store or load properties collection data to or form an storage.

◆ GetCount()

virtual int GetCount ( )
virtual

This member function is to get properties count in the collection.

Returns
Properties amount in the collection.
See also
GetProperty
SetProperty
RemoveProperty
RemoveAll

◆ GetNextProperty()

void GetNextProperty | ( | POSITION & | rPos,
 |  | CString & | rStrName,
 |  | COleVariant & | rVarValue ) const

Retrieves the properties collection element at rPos, then updates rPos to refer to the next element in the collection.

Parameters
rPos | [in out] Specifies a reference to a POSITION value returned by a previous GetNextProperty or GetStartPosition call.
rStrName | [out] A reference to CString object to receive property name value.
rVarValue | [out] A reference to COleVariant object to receive property value.
See also
GetStartPosition
CMap

◆ GetProperty()

virtual BOOL GetProperty | ( | LPCTSTR | pcszName,
 |  | COleVariant & | rVarValue ) const
 virtual

This member function is used to get property value using the specified name.

Parameters
pcszName | [in] A pointer to property name string.
rVarValue | [out] A reference to COleVariant object to receive property value.

The corresponding method for ActiveX returns a VT_EMPTY variant value instead of FALSE.

Returns
TRUE if successful, FALSE if specified property is not present in the collection.
See also
SetProperty
RemoveProperty

◆ GetStartPosition()

POSITION GetStartPosition ( ) const

Starts a properties collection iteration by returning a POSITION value that can be passed to a GetNextProperty call.

Returns
A POSITION value with start position.
See also
GetNextProperty
CMap

◆ LoadFromXML()

BOOL LoadFromXML ( LPCTSTR pcszXMLData )

This helper function is used to load a properties collection from a XML string source.

Parameters
pcszXMLData [in] A pointer to a XML string data source.

RemoveAll method is called for collection before loading.

Returns
TRUE if successful, FALSE otherwise.
See also
SaveToXML

◆ PrepareName()

CString PrepareName ( LPCTSTR pcszName ) const
protected

Call this member function to prepare a property name before passing it to the map access functions.

Parameters
pcszName [in] A pointer to a property name string.

If m_bNameIgnoreCase is TRUE, property names are converted to lower case.

Returns
Prepared property name string to pass to the map access functions.

◆ RemoveAll()

virtual void RemoveAll ( )
virtual

This member function is used to remove all properties.

See also
RemoveProperty
GetProperty
SetProperty

◆ RemoveProperty()

virtual BOOL RemoveProperty ( LPCTSTR pcszName )
virtual

This member function is used to remove property with the specified name.

Parameters
pcszName [in] A pointer to property name string.
Returns
TRUE if successful, FALSE otherwise.
See also
GetProperty
SetProperty

◆ SaveToXML()

BOOL SaveToXML ( CString & rstrXMLData )

This helper function is used to store a properties collection to a XML string.

Parameters
rstrXMLData - [out] A XML string object reference.
Returns
TRUE if successful, FALSE otherwise.
See also
LoadFromXML

◆ SetProperty()

virtual BOOL SetProperty | ( | LPCTSTR | pcszName,
 |  | const COleVariant & | varValue )
 virtual

This member function is used to set property value with the specified name.

Parameters
pcszName | [in] A pointer to property name string.
varValue | [in] A const reference to COleVariant object with a property value.
Returns
TRUE if successful, FALSE otherwise.
See also
GetProperty
RemoveProperty
The documentation for this class was generated from the following file:
  • XTPCalendarCustomProperties.h


Toolkit Pro: CXTPCalendarData Class Reference

Classes | Public Member Functions | Static Public Member Functions | Protected Member Functions | Static Protected Member Functions | Protected Attributes | Static Protected Attributes | List of all members
CXTPCalendarData Class Reference

This class defines an abstract representation of the Calendar control data with all necessary methods and some predefined functionality added. More...

Inheritance diagram for CXTPCalendarData:
[legend]

Classes

class | CXTPDPCache
class | EventsMapByID_T

Public Member Functions

CXTPCalendarData ()
Default constructor.
virtual | ~CXTPCalendarData ()
Default Destructor.
virtual BOOL | Open ()
Call this member function to initialize a newly constructed Data object.
virtual BOOL | Create ()
Call this member function to create a file for storing custom data provider data.
virtual BOOL | Save ()
This method saves data to the file.
virtual void | Close ()
Call this member function to close the connection to a data source.
virtual BOOL | IsOpen () const
This method determines whether a data source connection is opened.
virtual XTPCalendarDataProvider | GetType () const
This method determines the type of the current Data Provider implementation.
virtual CXTPCalendarEventsPtr | RetrieveDayEvents (COleDateTime dtDay)
Retrieves day events for a specified day from the data source.
virtual CXTPCalendarEventPtr | CreateNewEvent (DWORD dwEventID=XTP_CALENDAR_UNKNOWN_EVENT_ID)
Creates a new empty CXTPCalendarEvent object.
virtual CXTPCalendarRecurrencePatternPtr | CreateNewRecurrencePattern (DWORD dwPatternID=XTP_CALENDAR_UNKNOWN_RECURRENCE_PATTERN_ID)
Creates a new empty CXTPCalendarRecurrencePattern object.
virtual CXTPCalendarEventPtr | GetEvent (DWORD dwEventID)
Reads an event from the data source.
virtual CXTPCalendarRecurrencePatternPtr | GetRecurrencePattern (DWORD dwPatternID)
Reads a recurrence pattern from the data source.
virtual BOOL | AddEvent (CXTPCalendarEvent *pEvent)
Creates a new event in the data source.
virtual BOOL | AddEvents (CXTPCalendarEvents *pEvents)
Creates a set of events in the data source.
virtual void | RemoveAllEvents ()
Removes all events from the data source.
virtual BOOL | DeleteEvent (CXTPCalendarEvent *pEvent)
Deletes an event from the data source.
virtual BOOL | ChangeEvent (CXTPCalendarEvent *pNewEvent)
Updates event properties in the data source.
virtual CXTPNotifyConnection * | GetConnection () const
Returns a connection pointer for the data source.
virtual CXTPCalendarCustomProperties * | GetCustomProperties () const
Returns a custom properties collection.
virtual CXTPCalendarEventLabels * | GetLabelList () const
Returns a collection of Labels used in this Data source.
virtual CXTPCalendarEventCategories * | GetEventCategories () const
Returns a collection of Event categories.
virtual void | SetLabelList (CXTPCalendarEventLabels *pLabelList)
Set custom collection of Labels to be used in this Data source.
virtual BOOL | AddEventLabel (int nID, CString strName, COLORREF crLabel)
Call this member function to add a new item to the event label list.
virtual BOOL | AddEventCategory (UINT uID, CString strName, COLORREF crBorder, COLORREF crBkBase)
Call this member function to add a new item to the event category list.
virtual void | UpdateEventLabels (COLORREF *clrEventColors, UINT uCount)
Update event labels colors when the theme is changed.
virtual void | ClearEventCategoryList ()
Call this member function to remove all items from the event category list.
virtual void | ClearEventLabelList ()
Call this member function to remove all items from the event label list.
virtual void | RestoreEventCategoryList ()
Call this member function to restore the event category list to default values.
virtual void | RestoreEventLabelList ()
Call this member function to restore the event label list to default values.
void | UpdateEventCategories (COLORREF *pClrBkBase, COLORREF *pClrBorder, int nCount)
This member function updates the default colors of the category list when the theme is changed.
virtual CXTPCalendarSchedules * | GetSchedules () const
Returns a collection of schedules used in this data source.
virtual void | SetConnectionString (LPCTSTR lpszConnectionString)
Sets a data provider connection string.
virtual CString | GetConnectionString () const
Returns a data provider connection string.
virtual CString | GetDataSource ()
Returns a data provider data source.
virtual int | GetCacheMode () const
Determines current cache mode.
virtual void | SetCacheMode (int eCacheMode, CXTPCalendarData *pCacheDataProvider=NULL)
Sets common data provider cache mode.
virtual void | ClearCache ()
Clears common data provider cache.
virtual CXTPCalendarEventsPtr | GetUpcomingEvents (COleDateTime dtFrom=(DATE) 0, COleDateTimeSpan spPeriod=(DATE) 0)
Retrieves a collection of events expiring in the period from dtFrom during next spPeriod.
virtual CXTPCalendarEventsPtr | GetAllEvents_raw ()
This method Gets all events without generating recurrence occurrences.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Static Public Member Functions

static CXTPCalendarData *AFX_CDECL | CreateDataProvider (LPCTSTR lpszConnectionString)
Call this method to create a data provider from a specified Calendar connection string.
static CXTPCalendarData *AFX_CDECL | CreateDataProvider (XTPCalendarDataProvider eDataProvider)
Call this method to create a data provider of the specified type.
static XTPCalendarDataProvider AFX_CDECL | DataProviderTypeFromConStr (LPCTSTR lpszConnectionString, XTPCalendarDataProvider eDPDefault=xtpCalendarDataProviderUnknown)
Call this method to retrieve a type of the data provider from its connection string.
static CString AFX_CDECL | DataSourceFromConStr (LPCTSTR lpszConnectionString)
Call this method to retrieve a data source connection string from a regular Calendar connection string.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Protected Member Functions

virtual CXTPCalendarEventsPtr | DoRetrieveDayEvents (COleDateTime dtDay)
Retrieves day events for a specified day from the data source.
virtual void | DoRemoveAllEvents ()
Removes all events from the data source.
virtual CXTPCalendarEventPtr | DoRead_Event (DWORD dwEventID)
Read event from the data source.
virtual CXTPCalendarRecurrencePatternPtr | DoRead_RPattern (DWORD dwPatternID)
Read recurrence pattern from the data source.
virtual BOOL | DoCreate_Event (CXTPCalendarEvent *pEvent, DWORD &rdwNewEventID)
Creates a new event in the data source.
virtual BOOL | DoUpdate_Event (CXTPCalendarEvent *pEvent)
Updates event properties in the data source.
virtual BOOL | DoDelete_Event (CXTPCalendarEvent *pEvent)
Deletes an event from the data source.
virtual BOOL | DoCreate_RPattern (CXTPCalendarRecurrencePattern *pPattern, DWORD &rdwNewPatternID)
Creates a new recurrence pattern in the data source.
virtual BOOL | DoUpdate_RPattern (CXTPCalendarRecurrencePattern *pPattern)
Updates a recurrence pattern in the database.
virtual BOOL | DoDelete_RPattern (CXTPCalendarRecurrencePattern *pPattern)
Deletes a recurrence pattern from the database.
virtual CXTPCalendarEventsPtr | DoGetUpcomingEvents (COleDateTime dtFrom, COleDateTimeSpan spPeriod)
Retrieves a collection of events expiring in the period from dtFrom during next spPeriod.
virtual CXTPCalendarEventsPtr | DoGetAllEvents_raw ()
Retrieves all events without generating recurrence occurrences.
virtual void | SendNotification (XTP_NOTIFY_CODE EventCode, WPARAM wParam, LPARAM lParam)
Sends a notification to all listeners.
virtual BOOL | OnTimeZoneChanged ()
This method is called by the calendar control framework when Time Zone is Changed.

Static Protected Member Functions

static DWORD AFX_CDECL GetNextFreeTempID ()
Call this member function to get a unique temporary event ID.

Protected Attributes

BOOL | m_bOpened
Stores a flag whether a data source connection is open.
CXTPNotifyConnection * | m_pConnection
Connection object to send notifications.
BOOL | m_bDisableNotificationsSending
Stores a flag whether notifications sending is disabled.
CXTPCalendarEventLabels * | m_pLabelList
Event labels list.
CXTPCalendarSchedules * | m_pSchedules
Data source Schedules list.
CXTPCalendarEventCategories * | m_pEventCategories
Store a collection of Event categories.
CXTPCalendarCustomProperties * | m_pCustomProperties
Custom properties collection object.
CString | m_strConnectionString
default connection string;
XTPCalendarDataProvider | m_typeProvider
Data provider type.
CXTPCalendarOptions * | m_pCalendarOptions
This member stores user's calendar view options.

Static Protected Attributes

static DWORD ms_dwNextFreeTempID
Next unique event ID.

Detailed Description

This class defines an abstract representation of the Calendar control data with all necessary methods and some predefined functionality added.

This class is the definition of the XTPCalendarData abstract class which represents a data portion of the Calendar control.

To implement a custom Data Provider solution you should create a class derived from CXTPCalendarData and implement necessary virtual methods. The first main set of methods to be implemented are Open, Close, Save, Create, IsOpen, etc. The second main set of methods to be implemented is starting from Do verb. Those are: DoRetrieveDayEvents, DoRead_Event, DoUpdate_RPattern, etc.

To use a descendant of CXTPCalendarData in a regular way you first construct an instance of CXTPCalendarData object, then use Open() member function to establish connection to the data source and initialize the object. Class provides a number of functions to manipulate events and events related data. After finishing working with data source you should call Close() member function to close connection, de-initialize the object and free unused resources.

This class also contains an implementation of the data provider cache, which is used by default and gets a great performance increase in case when any slow connections are used (for example database connection).

See also
CXTPCalendarData overview
CXTPCalendarEvents
CXTPCalendarEvent
CXTPCalendarCustomDataProvider

Constructor & Destructor Documentation

◆ CXTPCalendarData()

CXTPCalendarData ( )

Default constructor.

Constructs a Data object. To establish a connection to a specified data source and initialize the object, you must call the Open() member function immediately after construction.

See also
Open()

◆ ~CXTPCalendarData()

virtual ~CXTPCalendarData ( )
virtual

Default Destructor.

Handles all deallocation.

Member Function Documentation

◆ AddEvent()

virtual BOOL AddEvent ( CXTPCalendarEvent * pEvent )
virtual

Creates a new event in the data source.

Parameters
pEvent Pointer to the CXTPCalendarEvent object which describes all data fields of a newly created record.

This method creates a data record corresponding with the specified event. This method uses DoCreate_Event realization and implements some additional service processing.

Returns
TRUE if event created successfully, FALSE in case of any error during the process.

◆ AddEventCategory()

virtual BOOL AddEventCategory | ( | UINT | uID,
 |  | CString | strName,
 |  | COLORREF | crBorder,
 |  | COLORREF | crBkBase )
 virtual

Call this member function to add a new item to the event category list.

Parameters
uID | Unique identifier for the category.
strName | Name of the category to add.
crBorder | Border color for the category.
crBkBase | Background base color for the category.
Returns
TRUE if the item was added to the category list, otherwise FALSE.

◆ AddEventLabel()

virtual BOOL AddEventLabel | ( | int | nID,
 |  | CString | strName,
 |  | COLORREF | crLabel )
 virtual

Call this member function to add a new item to the event label list.

Parameters
nID | Unique identifier for the label.
strName | Name of the list to add.
crLabel | Background base color for the list.
Returns
TRUE if the item was added to the list, otherwise FALSE.

◆ AddEvents()

virtual BOOL AddEvents ( CXTPCalendarEvents * pEvents )
virtual

Creates a set of events in the data source.

Parameters
pEvents Pointer to the CXTPCalendarEvents collection which contains a number of CXTPCalendarEvent objects.

This method adds a collection of events into the data source.

Returns
TRUE if all events were added successfully, FALSE in case of any error during the process.

◆ ChangeEvent()

virtual BOOL ChangeEvent ( CXTPCalendarEvent * pNewEvent )
virtual

Updates event properties in the data source.

Parameters
pNewEvent Pointer to the CXTPCalendarEvent object which describes all data fields of an event.

This method updates a data record corresponding with the specified event. This method uses DoUpdate_Event realization and implements some additional service processing.

Returns
TRUE if an event updated successfully, FALSE in case of any errors during the process.

◆ Create()

AFX_INLINE BOOL Create ( )
virtual

Call this member function to create a file for storing custom data provider data.

It will be opened by default.

Returns
TRUE is successful. FALSE otherwise.

Reimplemented in CXTPCalendarDatabaseDataProvider, and CXTPCalendarMemoryDataProvider.

◆ CreateDataProvider() [1/2]

static CXTPCalendarData *AFX_CDECL CreateDataProvider ( LPCTSTR lpszConnectionString )
static

Call this method to create a data provider from a specified Calendar connection string.

Parameters
lpszConnectionString A text Calendar connection string.

This is a helper method which creates calendar's data provider of the specified type with settings taken from the connection string.

Returns
Pointer to the created Calendar Data Provider object.

◆ CreateDataProvider() [2/2]

static CXTPCalendarData *AFX_CDECL CreateDataProvider ( XTPCalendarDataProvider eDataProvider )
static

Call this method to create a data provider of the specified type.

Parameters
eDataProvider A member of XTPCalendarDataProvider enumeration, which specifies a type of the Data Provider to create.

This is a helper method which creates calendar's data provider of the specified type.

Returns
Pointer to the created Calendar Data Provider object.

◆ CreateNewEvent()

virtual CXTPCalendarEventPtr CreateNewEvent ( DWORD dwEventID = XTP_CALENDAR_UNKNOWN_EVENT_ID )
virtual

Creates a new empty CXTPCalendarEvent object.

Parameters
dwEventID ID for a new event.

This method creates a new CXTPCalendarEvent class and initializes its ID.

It could be reimplemented in a descendant if it has its own ID's source (for example, database key field).

Returns
Created empty event.

◆ CreateNewRecurrencePattern()

virtual CXTPCalendarRecurrencePatternPtr CreateNewRecurrencePattern ( DWORD dwPatternID = XTP_CALENDAR_UNKNOWN_RECURRENCE_PATTERN_ID )
virtual

Creates a new empty CXTPCalendarRecurrencePattern object.

Parameters
dwPatternID ID for a new Recurrence Pattern.

This method creates a new CXTPCalendarRecurrencePattern class and initializes its ID.

It could be reimplemented in a descendant if it has its own ID's source (for example, database key field).

Returns
Created empty Recurrence Pattern.

◆ DataProviderTypeFromConStr()

static XTPCalendarDataProvider AFX_CDECL DataProviderTypeFromConStr | ( | LPCTSTR | lpszConnectionString,
 |  | XTPCalendarDataProvider | eDPDefault = xtpCalendarDataProviderUnknown )
 static

Call this method to retrieve a type of the data provider from its connection string.

Parameters
lpszConnectionString | A text Calendar connection string.
eDPDefault | Default data provider type to be returned if it can't be determined from the string.

This is a helper method which parses a connection string and identifies a type of the data provider which is specified there.

Returns
One of the values from XTPCalendarDataProvider enumeration.
See also
DataSourceFromConStr()
CreateDataProvider()

◆ DataSourceFromConStr()

static CString AFX_CDECL DataSourceFromConStr ( LPCTSTR lpszConnectionString )
static

Call this method to retrieve a data source connection string from a regular Calendar connection string.

Parameters
lpszConnectionString A text Calendar connection string.

This is a helper method which parses a connection string and identifies a data source connection string there.

Returns
Identified data source connection string.
See also
DataProviderTypeFromConStr()
CreateDataProvider()

◆ DeleteEvent()

virtual BOOL DeleteEvent ( CXTPCalendarEvent * pEvent )
virtual

Deletes an event from the data source.

Parameters
pEvent Pointer to the CXTPCalendarEvent object which describes all data fields of an event.

This method deletes a data record corresponding with the specified event. This method uses DoDelete_Event realization and implements some additional service processing.

Returns
TRUE if an event deleted successfully, FALSE in case of any errors during the process.

◆ DoCreate_Event()

virtual BOOL DoCreate_Event | ( | CXTPCalendarEvent * | pEvent,
 |  | DWORD & | rdwNewEventID )
 protectedvirtual

Creates a new event in the data source.

Parameters
pEvent | Pointer to the CXTPCalendarEvent object which describes all data fields of a newly created record.
rdwNewEventID | [out] EventID of a newly created record.

This method creates a data record corresponding with the specified event. It has empty implementation in this class and should be implemented by any custom realization of CXTPCalendarData.

Returns
TRUE if event created successfully, FALSE in case of any error during the process.

Reimplemented in CXTPCalendarCustomDataProvider, CXTPCalendarDatabaseDataProvider, and CXTPCalendarMemoryDataProvider.

◆ DoCreate_RPattern()

virtual BOOL DoCreate_RPattern | ( | CXTPCalendarRecurrencePattern * | pPattern,
 |  | DWORD & | rdwNewPatternID )
 protectedvirtual

Creates a new recurrence pattern in the data source.

Parameters
pPattern | Pointer to the CXTPCalendarRecurrencePattern object which describes all data fields of a newly created record.
rdwNewPatternID | [out] ID of a newly created record.

This method creates a data record corresponding with the specified recurrence pattern. It has empty implementation in this class and should be implemented by any custom realization of CXTPCalendarData.

Returns
TRUE if recurrence pattern created successfully, FALSE in case of any error during the process.

Reimplemented in CXTPCalendarCustomDataProvider, CXTPCalendarDatabaseDataProvider, and CXTPCalendarMemoryDataProvider.

◆ DoDelete_Event()

virtual BOOL DoDelete_Event ( CXTPCalendarEvent * pEvent )
protectedvirtual

Deletes an event from the data source.

Parameters
pEvent Pointer to the CXTPCalendarEvent object which describes all data fields of an event.

This method deletes a data record corresponding with the specified event. It has empty implementation in this class and should be implemented by any custom realization of CXTPCalendarData.

Returns
TRUE if an event deleted successfully, FALSE in case of any errors during the process.

Reimplemented in CXTPCalendarCustomDataProvider, CXTPCalendarDatabaseDataProvider, and CXTPCalendarMemoryDataProvider.

◆ DoDelete_RPattern()

virtual BOOL DoDelete_RPattern ( CXTPCalendarRecurrencePattern * pPattern )
protectedvirtual

Deletes a recurrence pattern from the database.

Parameters
pPattern Pointer to the CXTPCalendarRecurrencePattern object which should be deleted.

This method deletes a data record corresponding with the specified recurrence pattern. It has empty implementation in this class and should be implemented by any custom realization of CXTPCalendarData.

Returns
TRUE if recurrence pattern deleted successfully, FALSE in case of any error during the process.

Reimplemented in CXTPCalendarCustomDataProvider, CXTPCalendarDatabaseDataProvider, and CXTPCalendarMemoryDataProvider.

◆ DoGetAllEvents_raw()

virtual CXTPCalendarEventsPtr DoGetAllEvents_raw ( )
protectedvirtual

Retrieves all events without generating recurrence occurrences.

Simple events are included as is. For the recurrence events only master events are included, recurrence occurrences are not generated. It has empty implementation in this class and should be implemented by any custom realization of CXTPCalendarData.

Returns
A CXTPCalendarEvents pointer containing a collection of all events.
See also
GetAllEvents_raw()

Reimplemented in CXTPCalendarCustomDataProvider, CXTPCalendarDatabaseDataProvider, and CXTPCalendarMemoryDataProvider.

◆ DoGetUpcomingEvents()

virtual CXTPCalendarEventsPtr DoGetUpcomingEvents | ( | COleDateTime | dtFrom,
 |  | COleDateTimeSpan | spPeriod )
 protectedvirtual

Retrieves a collection of events expiring in the period from dtFrom during next spPeriod.

Parameters
dtFrom | Start date and time of a specified period.
spPeriod | A duration of a specified period.

This method is used by a reminders manager. It has empty implementation in this class and should be implemented by any custom realization of CXTPCalendarData.

Returns
A CXTPCalendarEvents pointer containing a collection of upcoming events.
See also
CXTPCalendarRemindersManager overview

Reimplemented in CXTPCalendarCustomDataProvider, CXTPCalendarDatabaseDataProvider, and CXTPCalendarMemoryDataProvider.

◆ DoRead_Event()

virtual CXTPCalendarEventPtr DoRead_Event ( DWORD dwEventID )
protectedvirtual

Read event from the data source.

Parameters
dwEventID Event ID of the read target.

This method retrieves all data for a specified event. It has empty implementation in this class and should be implemented by any custom realization of CXTPCalendarData.

Returns
A pointer to the new CXTPCalendarEvent object in which fields are filled with data from the data source.

Reimplemented in CXTPCalendarCustomDataProvider, CXTPCalendarDatabaseDataProvider, and CXTPCalendarMemoryDataProvider.

◆ DoRead_RPattern()

virtual CXTPCalendarRecurrencePatternPtr DoRead_RPattern ( DWORD dwPatternID )
protectedvirtual

Read recurrence pattern from the data source.

Parameters
dwPatternID Pattern ID of the read target.

This method retrieves all data for a specified recurrence pattern. It has empty implementation in this class and should be implemented by any custom realization of CXTPCalendarData.

Returns
A pointer to the new CXTPCalendarRecurrencePatternPtr object in which fields are filled with data from the data source.

Reimplemented in CXTPCalendarCustomDataProvider, CXTPCalendarDatabaseDataProvider, and CXTPCalendarMemoryDataProvider.

◆ DoRemoveAllEvents()

virtual void DoRemoveAllEvents ( )
protectedvirtual

Removes all events from the data source.

This method removes all appointments from the data source. It has empty implementation in this class and should be implemented by any custom realization of CXTPCalendarData.

Reimplemented in CXTPCalendarCustomDataProvider, CXTPCalendarDatabaseDataProvider, and CXTPCalendarMemoryDataProvider.

◆ DoRetrieveDayEvents()

virtual CXTPCalendarEventsPtr DoRetrieveDayEvents ( COleDateTime dtDay )
protectedvirtual

Retrieves day events for a specified day from the data source.

Parameters
dtDay A specified day.

This method retrieves all appointments for a specified day from the data source. It includes recurrence appointments occurrences, regular appointments for this day, and multi-day appointments which also have a part of this day. It has empty implementation in this class and should be implemented by any custom realization of CXTPCalendarData.

Returns
A collection of events for a specified day.

Reimplemented in CXTPCalendarCustomDataProvider, CXTPCalendarDatabaseDataProvider, and CXTPCalendarMemoryDataProvider.

◆ DoUpdate_Event()

virtual BOOL DoUpdate_Event ( CXTPCalendarEvent * pEvent )
protectedvirtual

Updates event properties in the data source.

Parameters
pEvent Pointer to the CXTPCalendarEvent object which describes all data fields of an event.

This method updates a data record corresponding with the specified event. It has empty implementation in this class and should be implemented by any custom realization of CXTPCalendarData.

Returns
TRUE if an event updated successfully, FALSE in case of any errors during the process.

Reimplemented in CXTPCalendarCustomDataProvider, CXTPCalendarDatabaseDataProvider, and CXTPCalendarMemoryDataProvider.

◆ DoUpdate_RPattern()

virtual BOOL DoUpdate_RPattern ( CXTPCalendarRecurrencePattern * pPattern )
protectedvirtual

Updates a recurrence pattern in the database.

Parameters
pPattern Pointer to the CXTPCalendarRecurrencePattern object.

This method updates a data record corresponding with the specified recurrence pattern. It has empty implementation in this class and should be implemented by any custom realization of CXTPCalendarData.

Returns
TRUE if recurrence pattern updated successfully, FALSE in case of any error during the process.

Reimplemented in CXTPCalendarCustomDataProvider, CXTPCalendarDatabaseDataProvider, and CXTPCalendarMemoryDataProvider.

◆ GetAllEvents_raw()

virtual CXTPCalendarEventsPtr GetAllEvents_raw ( )
virtual

This method Gets all events without generating recurrence occurrences.

Simple events are included as is. For the recurrence events only master events are included, recurrence occurrences are not generated. This method uses DoGetAllEvents_raw realization and implements some additional service processing.

Returns
A CXTPCalendarEvents pointer containing a collection of all events.
See also
_Save()
Serialize()
DoGetAllEvents_raw()

◆ GetCacheMode()

AFX_INLINE int GetCacheMode ( ) const
virtual

Determines current cache mode.

Returns
Current cache mode defined by the XTPCalendarDataProviderCacheMode enumeration.
See also
XTPCalendarDataProviderCacheMode enumeration
SetCacheMode()

◆ GetConnection()

AFX_INLINE CXTPNotifyConnection * GetConnection ( ) const
virtual

Returns a connection pointer for the data source.

Returns
A connection pointer.
See also
CXTPNotifyConnection overview

◆ GetConnectionString()

AFX_INLINE CString GetConnectionString ( ) const
virtual

Returns a data provider connection string.

Returns
Current connection string.
See also
SetConnectionString()
GetDataSource()

◆ GetCustomProperties()

AFX_INLINE CXTPCalendarCustomProperties * GetCustomProperties ( ) const
virtual

Returns a custom properties collection.

Returns
A custom properties collection associated with the data source.
See also
CXTPCalendarCustomProperties overview

◆ GetDataSource()

virtual CString GetDataSource ( )
virtual

Returns a data provider data source.

Returns
String with current data source settings.

This method parses a connection string and returns a data source as a part of it.

See also
GetConnectionString()
SetConnectionString()

◆ GetEvent()

virtual CXTPCalendarEventPtr GetEvent ( DWORD dwEventID )
virtual

Reads an event from the data source.

Parameters
dwEventID Event ID of the read target.

This method retrieves all data for a specified event. This method uses DoRead_Event realization and implements some additional service processing.

Returns
A pointer to the new CXTPCalendarEvent object in which fields are filled with data from the data source.

◆ GetEventCategories()

AFX_INLINE CXTPCalendarEventCategories * GetEventCategories ( ) const
virtual

Returns a collection of Event categories.

Returns
A collection of Event categories. By default it has some predefined values.
See also
CXTPCalendarEventCategories overview
CXTPCalendarEventCategories::InitDefaultValues()

◆ GetLabelList()

AFX_INLINE CXTPCalendarEventLabels * GetLabelList ( ) const
virtual

Returns a collection of Labels used in this Data source.

Returns
A collection of Labels used in this Data source. By default it has some predefined values.
See also
CXTPCalendarEventLabels overview
SetLabelList()
CXTPCalendarEventLabels::InitDefaultValues

◆ GetNextFreeTempID()

AFX_INLINE DWORD AFX_CDECL GetNextFreeTempID ( )
staticprotected

Call this member function to get a unique temporary event ID.

Returns
New value for event ID.

◆ GetRecurrencePattern()

virtual CXTPCalendarRecurrencePatternPtr GetRecurrencePattern ( DWORD dwPatternID )
virtual

Reads a recurrence pattern from the data source.

Parameters
dwPatternID Pattern ID of the read target.

This method retrieves all data for a specified recurrence pattern. This method uses DoRead_RPattern realization and implements some additional service processing.

Returns
A pointer to the new CXTPCalendarRecurrencePatternPtr object in which fields are filled with data from the data source.

◆ GetSchedules()

AFX_INLINE CXTPCalendarSchedules * GetSchedules ( ) const
virtual

Returns a collection of schedules used in this data source.

Returns
A collection of schedules associated with the data source.
See also
CXTPCalendarSchedules overview.

◆ GetType()

AFX_INLINE XTPCalendarDataProvider GetType ( ) const
virtual

This method determines the type of the current Data Provider implementation.

Returns
The current Data Provider implementation type.
See also
XTPCalendarDataProvider enumeration

◆ GetUpcomingEvents()

virtual CXTPCalendarEventsPtr GetUpcomingEvents | ( | COleDateTime | dtFrom = (DATE) 0,
 |  | COleDateTimeSpan | spPeriod = (DATE) 0 )
 virtual

Retrieves a collection of events expiring in the period from dtFrom during next spPeriod.

Parameters
dtFrom | Start date and time of a specified period.
spPeriod | A duration of a specified period.

This method is used by a reminders manager. This method uses DoGetUpcomingEvents realization and implements some additional service processing.

Returns
A CXTPCalendarEvents pointer containing a collection of upcoming events.
See also
CXTPCalendarRemindersManager overview

◆ IsOpen()

AFX_INLINE BOOL IsOpen ( ) const
virtual

This method determines whether a data source connection is opened.

Returns
TRUE when a connection is already opened. FALSE otherwise.

◆ OnTimeZoneChanged()

virtual BOOL OnTimeZoneChanged ( )
inlineprotectedvirtual

This method is called by the calendar control framework when Time Zone is Changed.

The data provider implementation may use this method to adjust its data for a new timezone.

Returns
TRUE if internal data changed and calendar must be re-populated, FALSE if this event is ignored (no data changed). Base implementation does nothing and returns FALSE.
See also
CXTPTopLevelWndMsgNotifier, XTP_WM_TIME_ZONE_CHANGED

Reimplemented in CXTPCalendarMemoryDataProvider.

◆ Open()

AFX_INLINE BOOL Open ( )
virtual

Call this member function to initialize a newly constructed Data object.

Your data object must be created before you can call Open().

Returns
Boolean value representing success/failure result.

Reimplemented in CXTPCalendarDatabaseDataProvider, and CXTPCalendarMemoryDataProvider.

◆ RemoveAllEvents()

virtual void RemoveAllEvents ( )
virtual

Removes all events from the data source.

This method removes all appointments from the data source. This method uses DoRemoveAllEvents realization and implements some additional service processing.

◆ RetrieveDayEvents()

virtual CXTPCalendarEventsPtr RetrieveDayEvents ( COleDateTime dtDay )
virtual

Retrieves day events for a specified day from the data source.

Parameters
dtDay A specified day.

This method retrieves all appointments for a specified day from the data source. It includes recurrence appointments occurrences, regular appointments for this day, and multi-day appointments which also have a part of this day. This method uses the DoRetrieveDayEvents realization and implements some additional service processing.

Returns
A collection of events for a specified day.

◆ Save()

AFX_INLINE BOOL Save ( )
virtual

This method saves data to the file.

The most recent data from the data provider will be saved in the same external file as before. Note that all the data inside the data provider is already up to date, this method just allows it to be saved externally.

Returns
TRUE is successful. FALSE otherwise.

Reimplemented in CXTPCalendarDatabaseDataProvider, and CXTPCalendarMemoryDataProvider.

◆ SendNotification()

virtual void SendNotification | ( | XTP_NOTIFY_CODE | EventCode,
 |  | WPARAM | wParam,
 |  | LPARAM | lParam )
 protectedvirtual

Sends a notification to all listeners.

Parameters
EventCode | Notification event code.
wParam | First notification parameter.
lParam | Second notification parameter.
See also
CXTPNotifyConnection overview

◆ SetCacheMode()

virtual void SetCacheMode | ( | int | eCacheMode,
 |  | CXTPCalendarData * | pCacheDataProvider = NULL )
 virtual

Sets common data provider cache mode.

Parameters
eCacheMode | Cache mode. See XTPCalendarDataProviderCacheMode.
pCacheDataProvider | Data Provider object which you want to use for cache purposes. By default it is CXTPCalendarMemoryDataProvider.

This method updates an internal cache mode.

See also
XTPCalendarDataProviderCacheMode enumeration

◆ SetConnectionString()

AFX_INLINE void SetConnectionString ( LPCTSTR lpszConnectionString )
virtual

Sets a data provider connection string.

Parameters
lpszConnectionString A connection string.
See also
GetConnectionString()
GetDataSource()

◆ SetLabelList()

virtual void SetLabelList ( CXTPCalendarEventLabels * pLabelList )
virtual

Set custom collection of Labels to be used in this Data source.

Parameters
pLabelList A custom collection of Labels to be used there.
See also
CXTPCalendarEventLabels overview
GetLabelList()

◆ UpdateEventCategories()

void UpdateEventCategories | ( | COLORREF * | pClrBkBase,
 |  | COLORREF * | pClrBorder,
 |  | int | nCount )

This member function updates the default colors of the category list when the theme is changed.

Parameters
pClrBkBase | Array of COLORREF values representing the background color for each category item.
pClrBorder | Array of COLORREF values represening the border color for each category item.
nCount | Size of pClrBack and pClrBorder arrays.

◆ UpdateEventLabels()

virtual void UpdateEventLabels | ( | COLORREF * | clrEventColors,
 |  | UINT | uCount )
 virtual

Update event labels colors when the theme is changed.

Parameters
clrEventColors | An array of colors.
uCount | Number of items in the array above.
The documentation for this class was generated from the following file:
  • XTPCalendarData.h


Toolkit Pro: CXTPCalendarData::CXTPDPCache Class Reference

  • CXTPCalendarData
  • CXTPDPCache
Public Member Functions | List of all members
CXTPCalendarData::CXTPDPCache Class Reference

Public Member Functions

CXTPDPCache ()
Default class constructor.
virtual | ~CXTPDPCache ()
Default class destructor.
void | SafeClose ()
Closes a cache.
void | SafeRemoveAll ()
Safely removes all elements from the cache.
virtual BOOL | IsDayInCache (COleDateTime dtDay)
Checks whether events for this day are already stored in the cache.
virtual void | SetDayInCache (COleDateTime dtDay, BOOL bSet=TRUE)
Sets a flag that this day is in the cache.
virtual BOOL | IsEventInCache (CXTPCalendarEvent *pEvent)
Checks whether a specified event is already stored in the cache.
virtual void | AddToCache (CXTPCalendarEvents *pEvents, COleDateTime dtDay)
Adds a collection of events to the cache for a specified day.
virtual void | AddToCacheIfNeed (CXTPCalendarEvent *pEvent)
Checks whether a specified event is already stored in the cache and adds it there if not.
virtual void | _AddToCacheIfNeed (CXTPCalendarRecurrencePattern *pPattern)
Checks whether a specified recurrence pattern is already stored in the cache and adds it there if not.

Detailed Description

Implementation of the data provider cache.

Member Function Documentation

◆ _AddToCacheIfNeed()

virtual void _AddToCacheIfNeed ( CXTPCalendarRecurrencePattern * pPattern )
virtual

Checks whether a specified recurrence pattern is already stored in the cache and adds it there if not.

Parameters
pPattern An pattern to check / add.

◆ AddToCache()

virtual void AddToCache | ( | CXTPCalendarEvents * | pEvents,
 |  | COleDateTime | dtDay )
 virtual

Adds a collection of events to the cache for a specified day.

Parameters
pEvents | An events collection.
dtDay | A specified day.

◆ AddToCacheIfNeed()

virtual void AddToCacheIfNeed ( CXTPCalendarEvent * pEvent )
virtual

Checks whether a specified event is already stored in the cache and adds it there if not.

Parameters
pEvent An event to check / add.

◆ IsDayInCache()

virtual BOOL IsDayInCache ( COleDateTime dtDay )
virtual

Checks whether events for this day are already stored in the cache.

Parameters
dtDay A day to check.
Returns
TRUE if day is already stored in cache, FALSE otherwise.

◆ IsEventInCache()

virtual BOOL IsEventInCache ( CXTPCalendarEvent * pEvent )
virtual

Checks whether a specified event is already stored in the cache.

Parameters
pEvent An event to check.
Returns
TRUE if an event is already stored in cache, FALSE otherwise.

◆ SetDayInCache()

virtual void SetDayInCache | ( | COleDateTime | dtDay,
 |  | BOOL | bSet = TRUE )
 virtual

Sets a flag that this day is in the cache.

Parameters
dtDay | A day to set.
bSet | Whether to set or clear flag.
The documentation for this class was generated from the following file:
  • XTPCalendarData.h


Toolkit Pro: CXTPCalendarData::EventsMapByID_T< _TObject > Class Template Reference

  • CXTPCalendarData
  • EventsMapByID_T
Public Member Functions | Protected Types | Protected Attributes | List of all members
CXTPCalendarData::EventsMapByID_T< _TObject > Class Template Reference

Public Member Functions

EventsMapByID_T (UINT uHashTableSize=XTP_OBJECT_CACHE_HASH_TABLE_SIZE)
Default class constructor.
virtual | ~EventsMapByID_T ()
Default class destructor.
void | Add (DWORD dwID, _TObject *pObj)
This member function is used to add new or to replace existing pairs of IDs and Objects.
_TObject * | Get (DWORD dwID)
This member function is used to obtain a pointer to an object using the specified ID.
BOOL | IsExist (DWORD dwID)
This member function is used to determine if an object with the specified ID exists.
BOOL | Remove (DWORD dwID)
This member function is used to remove an object with the specified ID.
void | RemoveAll ()
This member function is used to remove all stored objects from the map.
POSITION | GetStartPosition ()
This member function is used to get the start iteration position.
_TObject * | GetNextElement (POSITION &rPos, DWORD &rID)
This member function is used to get the next object pointer.
int | GetCount ()
This member function is used to get object count.

Protected Types

typedef CXTPSmartPtrInternalT< CCmdTarget > TObjPtr
typedef CXTPSmartPtrInternalT<_TObject> TObjPtr; Smart pointer object type.

Protected Attributes

CMap< DWORD, DWORD, TObjPtr, TObjPtr & > m_mapID2Object
The map of ID to object.

Detailed Description

template<class _TObject>
class CXTPCalendarData::EventsMapByID_T< _TObject >

This template class is used as a map (see CMap) to store ID and object pairs. Using the map allows for Quick Access using the ID.

See also
CMap

Member Typedef Documentation

◆ TObjPtr

template<class _TObject >
CXTPSmartPtrInternalT<CCmdTarget> TObjPtr
protected

typedef CXTPSmartPtrInternalT<_TObject> TObjPtr; Smart pointer object type.

to avoid warning C4786 CXTPCmdTarget used. Smart pointer object type.

Constructor & Destructor Documentation

◆ EventsMapByID_T()

template<class _TObject >
EventsMapByID_T ( UINT uHashTableSize = XTP_OBJECT_CACHE_HASH_TABLE_SIZE )
inline

Default class constructor.

Parameters
uHashTableSize Size of the map hash table.
See also
CMap
CMap::InitHashTable

◆ ~EventsMapByID_T()

template<class _TObject >
virtual ~EventsMapByID_T ( )
inlinevirtual

Default class destructor.

Handles member items deallocation. Decreases references of stored objects.

See also
CMap

Member Function Documentation

◆ Add()

template<class _TObject >
void Add | ( | DWORD | dwID,
 |  | _TObject * | pObj )
 inline

This member function is used to add new or to replace existing pairs of IDs and Objects.

Parameters
dwID | Object ID.
pObj | Object Pointer.

Call this method to add new or to replace existing elements in the map. InternalAddRef is called for the stored object.

See also
Get
Remove
CMap::SetAt

◆ Get()

template<class _TObject >
_TObject * Get ( DWORD dwID )
inline

This member function is used to obtain a pointer to an object using the specified ID.

Parameters
dwID Object ID.

Call this method to search for the object using the ID. InternalAddRef is called for the non-NULL returned object.

Returns
Object pointer or NULL.
See also
Add
CMap::Lookup

◆ GetCount()

template<class _TObject >
int GetCount ( )
inline

This member function is used to get object count.

Returns
Count of the objects in the map.
See also
CMap::GetCount

◆ GetNextElement()

template<class _TObject >
_TObject * GetNextElement | ( | POSITION & | rPos,
 |  | DWORD & | rID )
 inline

This member function is used to get the next object pointer.

Parameters
rPos | [in/out] Iteration position of the element.
rID | [out] Element ID.

Call this method to iterate on elements stored in the map. InternalAddRef is not called for the returned object. rPos parameter value is set to the element next position or NULL if iterating is finished.

Returns
A pointer to the object which corresponds to the specified position (rPos parameter value).
See also
GetStartPosition
CMap::GetNextAssoc

◆ GetStartPosition()

template<class _TObject >
POSITION GetStartPosition ( )
inline

This member function is used to get the start iteration position.

Returns
A POSITION value that indicates a starting position for iterating the map; or NULL if the map is empty.
See also
GetNextElement
CMap::GetStartPosition

◆ IsExist()

template<class _TObject >
BOOL IsExist ( DWORD dwID )
inline

This member function is used to determine if an object with the specified ID exists.

Parameters
dwID Object ID.

Similar to Get method, but calls InternalAddRef for the returned object.

Returns
TRUE if object with ID exists. Otherwise FALSE.
See also
Get
CMap::Lookup

◆ Remove()

template<class _TObject >
BOOL Remove ( DWORD dwID )
inline

This member function is used to remove an object with the specified ID.

Parameters
dwID Object ID.

Call this method to remove an element with the supplied ID from the map. InternalAddRef is called for the removed object.

Returns
Nonzero if the entry was found and successfully removed; otherwise 0.
See also
Add
RemoveAll
CMap::RemoveKey

◆ RemoveAll()

template<class _TObject >
void RemoveAll ( )
inline

This member function is used to remove all stored objects from the map.

Call this method to cleanup the map. InternalAddRef is called for all objects.

See also
Remove
CMap::RemoveAll
The documentation for this class was generated from the following file:
  • XTPCalendarData.h


Toolkit Pro: CXTPCalendarDatabaseDataProvider Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPCalendarDatabaseDataProvider Class Reference

This class is the implementation of the XTPCalendarData abstract class which represents the data portion of the Calendar control. More...

Inheritance diagram for CXTPCalendarDatabaseDataProvider:
[legend]

Public Member Functions

CXTPCalendarDatabaseDataProvider ()
Default constructor.
virtual | ~CXTPCalendarDatabaseDataProvider ()
Default Destructor.
virtual BOOL | Open ()
Call this member function to initialize a newly constructed Data object.
virtual BOOL | OpenEx (LPDISPATCH pdispADOConnection)
Call this member function to initialize a data provider using an existing ADO Connection object.
virtual BOOL | Create ()
Call this member function to create an empty database.
virtual BOOL | Save ()
This method saves data to the database.
virtual void | Close ()
Call this member function to close the connection to a data source.
- Public Member Functions inherited from CXTPCalendarData
CXTPCalendarData ()
Default constructor.
virtual | ~CXTPCalendarData ()
Default Destructor.
virtual BOOL | IsOpen () const
This method determines whether a data source connection is opened.
virtual XTPCalendarDataProvider | GetType () const
This method determines the type of the current Data Provider implementation.
virtual CXTPCalendarEventsPtr | RetrieveDayEvents (COleDateTime dtDay)
Retrieves day events for a specified day from the data source.
virtual CXTPCalendarEventPtr | CreateNewEvent (DWORD dwEventID=XTP_CALENDAR_UNKNOWN_EVENT_ID)
Creates a new empty CXTPCalendarEvent object.
virtual CXTPCalendarRecurrencePatternPtr | CreateNewRecurrencePattern (DWORD dwPatternID=XTP_CALENDAR_UNKNOWN_RECURRENCE_PATTERN_ID)
Creates a new empty CXTPCalendarRecurrencePattern object.
virtual CXTPCalendarEventPtr | GetEvent (DWORD dwEventID)
Reads an event from the data source.
virtual CXTPCalendarRecurrencePatternPtr | GetRecurrencePattern (DWORD dwPatternID)
Reads a recurrence pattern from the data source.
virtual BOOL | AddEvent (CXTPCalendarEvent *pEvent)
Creates a new event in the data source.
virtual BOOL | AddEvents (CXTPCalendarEvents *pEvents)
Creates a set of events in the data source.
virtual void | RemoveAllEvents ()
Removes all events from the data source.
virtual BOOL | DeleteEvent (CXTPCalendarEvent *pEvent)
Deletes an event from the data source.
virtual BOOL | ChangeEvent (CXTPCalendarEvent *pNewEvent)
Updates event properties in the data source.
virtual CXTPNotifyConnection * | GetConnection () const
Returns a connection pointer for the data source.
virtual CXTPCalendarCustomProperties * | GetCustomProperties () const
Returns a custom properties collection.
virtual CXTPCalendarEventLabels * | GetLabelList () const
Returns a collection of Labels used in this Data source.
virtual CXTPCalendarEventCategories * | GetEventCategories () const
Returns a collection of Event categories.
virtual void | SetLabelList (CXTPCalendarEventLabels *pLabelList)
Set custom collection of Labels to be used in this Data source.
virtual BOOL | AddEventLabel (int nID, CString strName, COLORREF crLabel)
Call this member function to add a new item to the event label list.
virtual BOOL | AddEventCategory (UINT uID, CString strName, COLORREF crBorder, COLORREF crBkBase)
Call this member function to add a new item to the event category list.
virtual void | UpdateEventLabels (COLORREF *clrEventColors, UINT uCount)
Update event labels colors when the theme is changed.
virtual void | ClearEventCategoryList ()
Call this member function to remove all items from the event category list.
virtual void | ClearEventLabelList ()
Call this member function to remove all items from the event label list.
virtual void | RestoreEventCategoryList ()
Call this member function to restore the event category list to default values.
virtual void | RestoreEventLabelList ()
Call this member function to restore the event label list to default values.
void | UpdateEventCategories (COLORREF *pClrBkBase, COLORREF *pClrBorder, int nCount)
This member function updates the default colors of the category list when the theme is changed.
virtual CXTPCalendarSchedules * | GetSchedules () const
Returns a collection of schedules used in this data source.
virtual void | SetConnectionString (LPCTSTR lpszConnectionString)
Sets a data provider connection string.
virtual CString | GetConnectionString () const
Returns a data provider connection string.
virtual CString | GetDataSource ()
Returns a data provider data source.
virtual int | GetCacheMode () const
Determines current cache mode.
virtual void | SetCacheMode (int eCacheMode, CXTPCalendarData *pCacheDataProvider=NULL)
Sets common data provider cache mode.
virtual void | ClearCache ()
Clears common data provider cache.
virtual CXTPCalendarEventsPtr | GetUpcomingEvents (COleDateTime dtFrom=(DATE) 0, COleDateTimeSpan spPeriod=(DATE) 0)
Retrieves a collection of events expiring in the period from dtFrom during next spPeriod.
virtual CXTPCalendarEventsPtr | GetAllEvents_raw ()
This method Gets all events without generating recurrence occurrences.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

virtual CXTPCalendarEventsPtr | DoRetrieveDayEvents (COleDateTime dtDay)
Retrieve day events for a specified day.
virtual void | DoRemoveAllEvents ()
Remove all events from the database.
virtual CXTPCalendarEventPtr | DoRead_Event (DWORD dwEventID)
Read event from the database.
virtual CXTPCalendarRecurrencePatternPtr | DoRead_RPattern (DWORD dwPatternID)
Read recurrence pattern from the database.
virtual BOOL | DoCreate_Event (CXTPCalendarEvent *pEvent, DWORD &rdwNewEventID)
Creates a new event in the database.
virtual BOOL | DoUpdate_Event (CXTPCalendarEvent *pEvent)
Updates event properties in the database.
virtual BOOL | DoDelete_Event (CXTPCalendarEvent *pEvent)
Deletes an event from the database.
virtual BOOL | DoCreate_RPattern (CXTPCalendarRecurrencePattern *pPattern, DWORD &rdwNewPatternID)
Creates a new recurrence pattern in the database.
virtual BOOL | DoUpdate_RPattern (CXTPCalendarRecurrencePattern *pPattern)
Updates a recurrence pattern in the database.
virtual BOOL | DoDelete_RPattern (CXTPCalendarRecurrencePattern *pPattern)
Deletes a recurrence pattern from the database.
virtual CXTPCalendarEventsPtr | DoGetAllEvents_raw ()
This method implements Getting all events from the database without generating recurrence occurrences.
virtual CXTPCalendarEventsPtr | DoGetUpcomingEvents (COleDateTime dtFrom, COleDateTimeSpan spPeriod)
Retrieves a collection of events expiring in the period from dtFrom during next spPeriod.
- Protected Member Functions inherited from CXTPCalendarData
virtual void | SendNotification (XTP_NOTIFY_CODE EventCode, WPARAM wParam, LPARAM lParam)
Sends a notification to all listeners.
virtual BOOL | OnTimeZoneChanged ()
This method is called by the calendar control framework when Time Zone is Changed.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCalendarData
static CXTPCalendarData *AFX_CDECL | CreateDataProvider (LPCTSTR lpszConnectionString)
Call this method to create a data provider from a specified Calendar connection string.
static CXTPCalendarData *AFX_CDECL | CreateDataProvider (XTPCalendarDataProvider eDataProvider)
Call this method to create a data provider of the specified type.
static XTPCalendarDataProvider AFX_CDECL | DataProviderTypeFromConStr (LPCTSTR lpszConnectionString, XTPCalendarDataProvider eDPDefault=xtpCalendarDataProviderUnknown)
Call this method to retrieve a type of the data provider from its connection string.
static CString AFX_CDECL | DataSourceFromConStr (LPCTSTR lpszConnectionString)
Call this method to retrieve a data source connection string from a regular Calendar connection string.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPCalendarData
- Static Protected Member Functions inherited from CXTPCalendarData
static DWORD AFX_CDECL | GetNextFreeTempID ()
Call this member function to get a unique temporary event ID.
- Protected Attributes inherited from CXTPCalendarData
BOOL | m_bOpened
Stores a flag whether a data source connection is open.
CXTPNotifyConnection * | m_pConnection
Connection object to send notifications.
BOOL | m_bDisableNotificationsSending
Stores a flag whether notifications sending is disabled.
CXTPCalendarEventLabels * | m_pLabelList
Event labels list.
CXTPCalendarSchedules * | m_pSchedules
Data source Schedules list.
CXTPCalendarEventCategories * | m_pEventCategories
Store a collection of Event categories.
CXTPCalendarCustomProperties * | m_pCustomProperties
Custom properties collection object.
CString | m_strConnectionString
default connection string;
XTPCalendarDataProvider | m_typeProvider
Data provider type.
CXTPCalendarOptions * | m_pCalendarOptions
This member stores user's calendar view options.
- Static Protected Attributes inherited from CXTPCalendarData
static DWORD | ms_dwNextFreeTempID
Next unique event ID.

Detailed Description

This class is the implementation of the XTPCalendarData abstract class which represents the data portion of the Calendar control.

This implementation uses a MS Access database as the data source. The Data source stores all Events data and provides a way to retrieve and save CXTPCalendarEvent objects.

 To use CXTPCalendarDatabaseDataProvider, first construct an instance
 of the CXTPCalendarDatabaseDataProvider object. Then use the Open() member
 function to establish a connection to the data source and initialize the
 object. The CXTPCalendarDatabaseDataProvider class provides a number of
 functions to manipulate events and event related data. After finishing
 work with the data source, call the Close() member function to close the
 connection, de-initialize the object and free any unused resources.
See also
CXTPCalendarData
CXTPCalendarMemoryDataProvider

Constructor & Destructor Documentation

◆ CXTPCalendarDatabaseDataProvider()

CXTPCalendarDatabaseDataProvider ( )

Default constructor.

Constructs a Data object. To establish a connection to a specified data source and initialize the object the Open() member function must be called immediately after construction.

See also
Open()

◆ ~CXTPCalendarDatabaseDataProvider()

virtual ~CXTPCalendarDatabaseDataProvider ( )
virtual

Default Destructor.

Handles all deallocation.

Member Function Documentation

◆ Create()

virtual BOOL Create ( )
virtual

Call this member function to create an empty database.

A database is created with the necessary tables structure. It is opened by default.

Returns
TRUE is successful. FALSE otherwise.

Reimplemented from CXTPCalendarData.

◆ DoCreate_Event()

virtual BOOL DoCreate_Event | ( | CXTPCalendarEvent * | pEvent,
 |  | DWORD & | rdwNewEventID )
 protectedvirtual

Creates a new event in the database.

Parameters
pEvent | Pointer to the CXTPCalendarEvent object which describes all data fields of a newly created record.
rdwNewEventID | [out] EventID of a newly created record, it is an auto-generated numeric events table key.

This method creates and executes a database query which adds a new record to the events table.

Returns
TRUE if event created successfully, FALSE in case of any error during the process.

Reimplemented from CXTPCalendarData.

◆ DoCreate_RPattern()

virtual BOOL DoCreate_RPattern | ( | CXTPCalendarRecurrencePattern * | pPattern,
 |  | DWORD & | rdwNewPatternID )
 protectedvirtual

Creates a new recurrence pattern in the database.

Parameters
pPattern | Pointer to the CXTPCalendarRecurrencePattern object which describes all data fields of a newly created record.
rdwNewPatternID | [out] ID of a newly created record, it is an auto-generated numeric table key.

This method creates and executes a database query which adds a new record to the recurrence patterns table.

Returns
TRUE if recurrence pattern created successfully, FALSE in case of any error during the process.

Reimplemented from CXTPCalendarData.

◆ DoDelete_Event()

virtual BOOL DoDelete_Event ( CXTPCalendarEvent * pEvent )
protectedvirtual

Deletes an event from the database.

Parameters
pEvent Pointer to the CXTPCalendarEvent object which describes all data fields of an event.

This method creates and executes a database query which deletes a corresponding database record.

Returns
TRUE if an event deleted successfully, FALSE in case of any errors during the process.

Reimplemented from CXTPCalendarData.

◆ DoDelete_RPattern()

virtual BOOL DoDelete_RPattern ( CXTPCalendarRecurrencePattern * pPattern )
protectedvirtual

Deletes a recurrence pattern from the database.

Parameters
pPattern Pointer to the CXTPCalendarRecurrencePattern object which should be deleted.

This method creates and executes a database query which deletes a corresponding record from the recurrence patterns table.

Returns
TRUE if recurrence pattern deleted successfully, FALSE in case of any error during the process.

Reimplemented from CXTPCalendarData.

◆ DoGetAllEvents_raw()

virtual CXTPCalendarEventsPtr DoGetAllEvents_raw ( )
protectedvirtual

This method implements Getting all events from the database without generating recurrence occurrences.

Simple events are included as is. For the recurrence events only master events are included, recurrence occurrences are not generated.

Returns
A CXTPCalendarEvents pointer containing a collection of all events.
See also
GetAllEvents_raw()

Reimplemented from CXTPCalendarData.

◆ DoGetUpcomingEvents()

virtual CXTPCalendarEventsPtr DoGetUpcomingEvents | ( | COleDateTime | dtFrom,
 |  | COleDateTimeSpan | spPeriod )
 protectedvirtual

Retrieves a collection of events expiring in the period from dtFrom during next spPeriod.

Parameters
dtFrom | Start date and time of a specified period.
spPeriod | A duration of a specified period.

This method creates and executes a database query which returns a collection of upcoming events. It is used by a reminders manager.

Returns
A CXTPCalendarEvents pointer containing a collection of upcoming events.
See also
CXTPCalendarRemindersManager overview

Reimplemented from CXTPCalendarData.

◆ DoRead_Event()

virtual CXTPCalendarEventPtr DoRead_Event ( DWORD dwEventID )
protectedvirtual

Read event from the database.

Parameters
dwEventID Event ID of the read target.

This method creates and executes a database query which retrieves all data for a specified event.

Returns
A pointer to the new CXTPCalendarEvent object which fields contains a data from the database.

Reimplemented from CXTPCalendarData.

◆ DoRead_RPattern()

virtual CXTPCalendarRecurrencePatternPtr DoRead_RPattern ( DWORD dwPatternID )
protectedvirtual

Read recurrence pattern from the database.

Parameters
dwPatternID Pattern ID of the read target.

This method creates and executes a database query which retrieves all data for a specified recurrence pattern.

Returns
A pointer to the created CXTPCalendarRecurrencePattern object.

Reimplemented from CXTPCalendarData.

◆ DoRemoveAllEvents()

virtual void DoRemoveAllEvents ( )
protectedvirtual

Remove all events from the database.

This method creates and executes a database query which removes all appointments from the database.

Reimplemented from CXTPCalendarData.

◆ DoRetrieveDayEvents()

virtual CXTPCalendarEventsPtr DoRetrieveDayEvents ( COleDateTime dtDay )
protectedvirtual

Retrieve day events for a specified day.

Parameters
dtDay A specified day.

This method creates and executes a database query on order to retrieve all appointments for a specified day.

Returns
A collection of events for a specified day.

Reimplemented from CXTPCalendarData.

◆ DoUpdate_Event()

virtual BOOL DoUpdate_Event ( CXTPCalendarEvent * pEvent )
protectedvirtual

Updates event properties in the database.

Parameters
pEvent Pointer to the CXTPCalendarEvent object which describes all data fields of an event.

This method creates and executes a database query which updates a corresponding database record with properties from the specified event.

Returns
TRUE if an event updated successfully, FALSE in case of any errors during the process.

Reimplemented from CXTPCalendarData.

◆ DoUpdate_RPattern()

virtual BOOL DoUpdate_RPattern ( CXTPCalendarRecurrencePattern * pPattern )
protectedvirtual

Updates a recurrence pattern in the database.

Parameters
pPattern Pointer to the CXTPCalendarRecurrencePattern object.

This method creates and executes a database query which updates a corresponding record in the recurrence patterns table.

Returns
TRUE if recurrence pattern updated successfully, FALSE in case of any error during the process.

Reimplemented from CXTPCalendarData.

◆ Open()

virtual BOOL Open ( )
virtual

Call this member function to initialize a newly constructed Data object.

Data object must be created before you call Open.

Returns
TRUE is successful. FALSE otherwise.

Reimplemented from CXTPCalendarData.

◆ OpenEx()

virtual BOOL OpenEx ( LPDISPATCH pdispADOConnection )
virtual

Call this member function to initialize a data provider using an existing ADO Connection object.

Parameters
pdispADOConnection [in] An IDispatch interface of ADO Connection.

Set Connection String as "Provider=ADO;" (or "Provider=Access;") Connection object must be opened before pass to OpenEx. Also the calendar data provider does not close the ADO Connection through the Close method. You have to close it yourself.

Returns
TRUE is successful. FALSE otherwise.

◆ Save()

virtual BOOL Save ( )
virtual

This method saves data to the database.

Actually, this method just always returns TRUE for the database data provider. The reason is that database data provider always keep consistency of its data and could be closed without saving. The database file would contain the most recent data.

Returns
TRUE is successful. FALSE otherwise.

Reimplemented from CXTPCalendarData.

The documentation for this class was generated from the following file:
  • XTPCalendarDatabaseDataProvider.h


Toolkit Pro: CXTPCalendarDayView Class Reference

Public Types | Public Member Functions | Public Attributes | Protected Member Functions | Protected Attributes | List of all members
CXTPCalendarDayView Class Reference

This class implements a specific view portion of the Calendar control - called Day view. More...

Inheritance diagram for CXTPCalendarDayView:
[legend]

Public Types

typedef CXTPCalendarViewT< CXTPCalendarDayViewDay > TBase

Public Member Functions

CXTPCalendarDayView (CXTPCalendarControl *pCalendarControl)
Default object constructor.
virtual | ~CXTPCalendarDayView ()
Default class destructor.
virtual XTPCalendarViewType | GetViewType () const
Call this member function to obtain the view type flag.
virtual void | AdjustLayout (CDC *pDC, const CRect &rcView, BOOL bCallPostAdjustLayout=TRUE)
This member function is used to adjust the view's layout depending on the window's client dimensions and calls.
virtual void | AdjustLayout2 (CDC *pDC, const CRect &rcView, BOOL bCallPostAdjustLayout=TRUE)
This member function is used to adjust the view's layout depending on the window's client dimensions and calls.
virtual BOOL | GetScrollBarInfoV (SCROLLINFO *pSI) const
This member function is used to retrieve information about a scroll bar's state.
virtual BOOL | GetScrollBarInfoH (SCROLLINFO *pSI, int *pnScrollStep=NULL) const
This member function is used to retrieve information about a scroll bar's state.
virtual void | ScrollV (int nPos, int nPos_raw)
This member function is used to scroll the content of a view.
virtual void | ScrollH (int nPos, int nPos_raw)
This member function is used to scroll the content of a view.
virtual int | GetMinColumnWidth () const
This member function returns values which interpreted as a minimum column width, where column is a group view object.
virtual void | SetMinColumnWidth (int nWidth)
This member function used to set minimum column width, where column is a group view object.
virtual void | OnDraw (CDC *pDC)
This member function performs all of the drawing logic of the calendar view.
virtual void | Draw (CDC *pDC)
This member function is used to draw the view content using the specified device context.
virtual void | Draw2 (CDC *pDC)
This member function is used to draw the view content using the specified device context.
virtual BOOL | OnLButtonDown (UINT nFlags, CPoint point)
This member function is used to process left mouse button events.
virtual BOOL | OnLButtonUp (UINT nFlags, CPoint point)
This member function is used to processes left mouse button events.
virtual void | OnMouseMove (UINT nFlags, CPoint point)
This member function is used to process mouse move events.
virtual void | OnKeyDown (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process keyboard events.
virtual COleDateTime | GetViewDayDate (int nIndex) const
Call this member function to get the date of a day view by the day's index.
virtual BOOL | HitTestEx (CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const
This member function is used to determine which view item, if any, is at a specified position index, and returns additional info in a XTP_CALENDAR_HITTESTINFO structure.
int | GetVisibleRowCount () const
This member function is used to obtain the visible row count on the view.
int | GetTopRow () const
This member function is used to obtain the top visible row on the view.
int | GetRowCount () const
This member function is used to obtain the total row count on the view.
COleDateTimeSpan | GetScaleInterval () const
This member function is used to obtain the time scale item interval.
void | SetScaleInterval (const COleDateTimeSpan spScaleInterval)
This member function is used to set the time scale item interval.
COleDateTime | GetScaleMinTime () const
This member function is used to obtain the minimal time which is shown on the day view scale.
void | SetScaleMinTime (const COleDateTime dtNewScaleMinTime)
This member function is used to set the minimal time which is shown on the day view scale.
COleDateTime | GetScaleMaxTime () const
This member function is used to obtain the maximal time which is shown on the day view scale.
void | SetScaleMaxTime (const COleDateTime dtNewScaleMaxTime)
This member function is used to set the maximal time which is shown on the day view scale.
void | SetScaleText (LPCTSTR strText)
This member function is used to set the text label for the default time scale.
CString | GetScaleText () const
This member function is used to obtain the text label of the default time scale.
void | SetAdditionalScaleText (LPCTSTR strText)
This member function is used to set the text label for the additional time scale.
CString | GetAdditionalScaleText () const
This member function is used to obtain the text label of the additional time scale.
void | SetAdditionalScaleTimeZone (const TIME_ZONE_INFORMATION *pTzInfo)
This member function is used to set the time zone information for the additional time scale.
const TIME_ZONE_INFORMATION & | GetAdditionalScaleTimeZone () const
This member function is used to get the time zone information for the additional time scale.
CXTPCalendarTimeZonePtr | GetCurrentTimeZoneInfo () const
Get full information about current time zone.
CXTPCalendarTimeZonePtr | GetAdditionalScaleTimeZoneInfo () const
Get full information about additional time scale time zone.
void | ShowAdditionalScale (BOOL bShow=TRUE)
This member function is used to Show or hide the additional time scale.
BOOL | IsScaleLeftVisible () const
This member function is used to obtain the visibility flag of left time scale.
BOOL | IsScaleRightVisible () const
This member function is used to obtain the visibility flag of right time scale.
BOOL | IsAdditionalScaleLeftVisible () const
This member function is used to obtain the visibility flag of the additional left time scale.
BOOL | IsAdditionalScaleRightVisible () const
This member function is used to obtain the visibility flag of the additional right time scale.
BOOL | IsDrawNowLineOverAppoinment () const
This member function is used to obtain the flag of the now line drawing.
BOOL | IsExpandUp () const
This member function is used to obtain the Expand Up glyph flag value.
BOOL | IsExpandDown () const
This member function is used to obtain the Expand Down glyph flag value.
COleDateTime | GetCellTime (int nCell) const
This member function is used to obtain the time value for the specified cell.
COleDateTimeSpan | GetCellDuration () const
This member function is used to obtain the current cell duration.
int | GetCellNumber (COleDateTime dtTime, BOOL bForEndTime) const
This member function is used to calculate the cell number for the specified time value.
int | GetCellNumber (int nHour, int nMin, int nSec, BOOL bForEndTime) const
This member function is used to calculate the cell number for the specified time value.
virtual BOOL | GetSelection (COleDateTime *pBegin=NULL, COleDateTime *pEnd=NULL, BOOL *pbAllDayEvent=NULL, int *pnGroupIndex=NULL, COleDateTimeSpan *pspSelectionResolution=NULL) const
This member function is used to obtain the view selection.
virtual void | ShowDay (const COleDateTime &date, BOOL bSelect=TRUE)
This member function is used to show the specified day in the calendar day view.
virtual void | ShowDays (const COleDateTime &dtBegin, const COleDateTime &dtEnd)
This member function is used to show the specified day interval in the calendar day view.
virtual void | ShowWorkingDays (const COleDateTime &dtDay)
This member function is used to show that working week in the calendar day view, which includes the specified day.
virtual void | AddDay (const COleDateTime &date)
This member function is used to add a specified date to the dates set showing in the current calendar day view.
virtual BOOL | EnsureVisible (CXTPCalendarViewEvent *pViewEvent)
This member function is used to ensure that an event view item is visible.
virtual BOOL | EnsureVisibleH (CXTPCalendarViewEvent *pViewEvent)
This member function is used to ensure that an event view item is visible.
virtual BOOL | EnsureVisibleH (CXTPCalendarViewGroup *pViewGroup)
This member function is used to ensure that an event view item is visible.
virtual void | ScrollToWorkDayBegin ()
This member function is used to start view from the work day starting time.
virtual BOOL | IsGroupHeaderVisible () const
This member function is used to determine whether resource group header should be visible.
virtual CXTPCalendarDayViewTimeScale * | GetTimeScale (int nNumber=1) const
This member function is used to get main or additional time scale object.
virtual CXTPCalendarDayViewDay * | GetDay (COleDateTime dtDay)
Call this member function to obtain the CXTPCalendarDayViewDay object by the day's date.
virtual void | ScrollDaysToPrev (int nScrollDaysCount=1)
This member function is used to scroll the view back a specified number of days.
virtual void | ScrollDaysToNext (int nScrollDaysCount=1)
This member function is used to scroll the view forward a specified number of days.
void | ScrollToColumn (long lColumn)
This member function is used to scroll the view forward a specified number of columns (schedules).
- Public Member Functions inherited from CXTPCalendarViewT< CXTPCalendarDayViewDay >
CXTPCalendarViewT (CXTPCalendarControl *pCalendarControl, XTPCalendarViewType nViewType)
Default object constructor.
virtual | ~CXTPCalendarViewT ()
Default class destructor.
virtual CXTPCalendarDayViewDay * | GetViewDay (int nIndex) const
Call this member function to obtain a _TViewDay object corresponding with the day's index.
- Public Member Functions inherited from CXTPCalendarView
UINT | GetDiscreteSelectionCount () const
This member function is used to get the number of selected events.
COleDateTime | GetDiscreteSelectionValue (UINT id) const
This member function gets a selected event by using its event ordinal number.
BOOL | AddToDiscreteSelection (UINT id)
This member function adds an event to the selection by using its event ordinal number.
BOOL | IsInDiscreteSelection (UINT id) const
This member function checks if an event is in the selection.
void | ClearDiscreteSelection ()
This member function is used to Clear Discrete Selection.
CXTPCalendarView (CXTPCalendarControl *pCalendarControl)
Default object constructor.
virtual | ~CXTPCalendarView ()
Default class destructor.
virtual void | Populate ()
This member function is used to populate the view with data for all items contained in the view.
virtual void | RedrawControl ()
This member function is used to perform the redrawing of the control's layout.
virtual void | OnScrollEnd (int nBar)
This member function is used to force scroll to the end of the scroll range.
virtual BOOL | OnLButtonDblClk (UINT nFlags, CPoint point)
This member function is used to process mouse double-click events.
virtual void | OnChar (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process keyboard events.
virtual BOOL | OnSysKeyDown (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process system keyboard events.
CRect | GetViewRect () const
Call this member function to obtain the view's bounding rectangle.
virtual int | GetChildHandlersCount () const
This member function is used to obtain the number of CXTPCalendarWMHandler elements in the descendant handlers collection.
virtual CXTPCalendarWMHandler * | GetChildHandlerAt (int nIndex) const
Call this method to get a handler object at the specified numeric index.
virtual int | GetViewDayCount () const
Call this member function to obtain the number of "day views" in the view collection.
virtual CXTPCalendarViewDay * | GetViewDay_ (int nIndex) const
Call this member function to obtain the CXTPCalendarViewDay object by the day's index.
virtual CXTPCalendarViewDay * | _GetViewDay (const COleDateTime &dtDay) const
Call this member function to obtain the CXTPCalendarViewDay object by the day's index.
virtual BOOL | HitTest (CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const
This member function is used to determines which view item, if any, is at a specified position index, and returns additional information in the XTP_CALENDAR_HITTESTINFO argument.
virtual XTPCalendarDraggingMode | GetDraggingMode () const
Call this member function to determine the current dragging mode.
virtual CXTPCalendarPaintManager * | GetPaintManager () const
Call this member function to obtain the PaintManager object.
virtual CXTPCalendarTheme * | GetTheme () const
This member function obtains a pointer to the associated theme object.
CXTPCalendarControl * | GetCalendarControl () const
Call this member function to obtain a pointer to the Calendar Control object.
CXTPCalendarOptions * | GetCalendarOptions () const
Call this member function to get direct access to calendar options data.
virtual CXTPCalendarResources * | GetResources () const
Call this member function to obtain a pointer to the associated Calendar Resources collection object.
virtual void | SetResources (CXTPCalendarResources *pResources)
This member function sets the new Resources collection for the view.
virtual void | UnselectAllEvents ()
Call this member function to un-select all of the events of the current view.
virtual void | SelectEvent (CXTPCalendarEvent *pEvent, BOOL bSelect=TRUE)
This member function is used to select or un-select the provided event.
void | SelectViewEvent (CXTPCalendarViewEvent *pViewEvent, BOOL bSelect=TRUE)
This member function is used to select or un-select the provided event.
virtual CXTPCalendarViewEvents * | GetSelectedViewEvents () const
Call this member function to obtain a pointer to a selected event's views.
virtual CXTPCalendarViewEventsPtr | GetSelectedEvents () const
Call this member function to obtain a pointer to a selected event's views collection.
CXTPCalendarViewEvent * | GetLastSelectedViewEvent () const
This member function is used to obtain the last selected event view.
virtual BOOL | HasSelectedViewEvent () const
Call this member function to determine if any view event is selected.
BOOL | IsSingleEventSelected () const
This member function is used to determine if just one event is selected.
int | FindLastSelectedDay () const
This member function is used to obtain the last selected day index.
COleDateTime | GetLastSelectedDate () const
This member function is used to obtain the last selected day date.
void | SetSelection (const COleDateTime &dtBegin, const COleDateTime &dtEnd, BOOL bAllDayEvent=FALSE, int nGroupIndex=0)
This member function sets the new selection for the view.
void | ResetSelection ()
This member function resets the current selection - set it empty.
BOOL | SelectionContains (COleDateTime date, int nGroupIndex=-1, BOOL *pbAllDaySelection=NULL)
This member function is used to determine if a date time value is contained inside the selection.
virtual void | SelectDay (COleDateTime dtSelDay, int nGroupIndex=0)
This member function is used to select or un-select the day identified by the provided date.
virtual int | GetRowHeight () const
Call this member function to determine the row height required to display the event.
virtual CXTPCalendarEventsPtr | RetrieveDayEvents (CXTPCalendarResource *pRC, COleDateTime dtDay)
Call this member function to get the collection of the day's events.
virtual BOOL | IsEditingSubject () const
Call this member function to determine if the subject is in an editable mode.
virtual CRect | GetSubjectEditorRect () const
Call this member function to obtain the bounding rectangle of the subject editor.
virtual CRect | GetTooltipRect (const CPoint &ptHit, const XTP_CALENDAR_HITTESTINFO &hitInfo) const
Call this member function to obtain the bounding rectangle of the tooltip space (currently this is only "click to add new appointment").
virtual void | ShowToolTip (BOOL bShow=TRUE)
This member function is used to show/hide a ToolTip rectangle.
virtual UINT | GetShowToolTipTimeOut () const
This member function is used to obtain the timeout value for displaying a tooltip.
virtual void | OnUpdateEditingSubject (CString strNewSubject)
Call this member function to set the new subject text for the editing event.
virtual BOOL | CanUndo () const
Call this member function to determine if you can perform an undo operation for the subject editor.
virtual BOOL | CanRedo () const
Call this member function to determine if a redo operation is possible for the subject editor.
virtual BOOL | Undo ()
This member function is used to perform an Undo operation.
virtual BOOL | Redo ()
This member function is used to perform a Redo operation.
virtual void | EmptyUndoBuffer ()
This member function is used to erase the undo buffer.
virtual CString | FormatEventTime (COleDateTime dtTime) const
This member function is used to format the time using the provided format.
void | SetCustomTimeFormat (const CString &strFormat)
This member function is used to set custom time format for view.
void | ResetCustomTimeFormat ()
Reset custom time format to default.
virtual CString | GetDayHeaderFormat () const
Call this member function to determine the current format string.
virtual void | SetDayHeaderFormat (LPCTSTR sFmt)
Call this member function to set the day header format.
virtual BOOL | CanCut () const
Call this member function to determine if it is possible to perform a Cut operation.
virtual BOOL | CanCopy () const
Call this member function to determine if it is possible to perform a Copy operation.
virtual BOOL | CanPaste () const
Call this member function to determine if it is possible to perform a Paste operation.
virtual BOOL | Cut ()
This member function is used to perform a Cut operation.
virtual BOOL | Copy ()
This member function is used to perform a Copy operation.
virtual BOOL | Paste ()
This member function is used to perform a Paste operation.
virtual CXTPCalendarEvent * | GetDraggingEventOrig () const
This member function is used to obtain the event object before the start of the event editing (dragging).
virtual CXTPCalendarEvent * | GetDraggingEventNew () const
This member function is used to obtain the event object that is currently being edited.
virtual BOOL | SetDraggingEvent (CXTPCalendarEvent *pEventOrig)
This member function is used to prepare the event to event editing (dragging) operation.
virtual BOOL | CommitDraggingEvent ()
This member function is used to commit the event editing (dragging) operation.
virtual void | CancelDraggingEvent ()
This member function is used to cancel the event editing (dragging) operation.
virtual void | StartEditSubject (CXTPCalendarViewEvent *pViewEvent)
This member function is used to start the event subject editing.
virtual void | EndEditSubject (XTPCalendarEndEditSubjectAction eAction, BOOL bUpdateControl=TRUE)
This member function is used to finish the event subject editing.
virtual UINT | GetStartEditSubjectTimeOut () const
This member function is used to obtain the time value after a mouse click event in the subject editing window.
virtual void | StartEditNewEventInplace (LPCTSTR pcszInitialSubject)
This member function is used to create a new event and start subject editing.
virtual CXTPCalendarViewEvent * | FindViewEvent (CXTPCalendarEvent *pEvent, COleDateTime dtDay) const
This member function is used to obtain the event view object for the specified event and day.
virtual void | SelectDays (COleDateTime dtNewSel)
This member function is used to change the days selection depending on the previous state of the selection.
virtual void | ProcessEventSelection (XTP_CALENDAR_HITTESTINFO *pInfo, UINT nFlags)
This member function is used to process events that are selected with the mouse.
virtual void | EnableVScroll (BOOL bEnable=TRUE)
This member function(s) is used to disable or enable vertical or horizontal scrolling of the view (by date or time).
virtual void | EnableHScroll (BOOL bEnable=TRUE)
This member function(s) is used to disable or enable vertical or horizontal scrolling of the view (by date or time).
virtual BOOL | IsHScrollEnabled () const
This member function(s) is used to obtain the status of the vertical or horizontal scrolling features of the view (by date or time).
virtual BOOL | IsVScrollEnabled () const
This member function(s) is used to obtain the status of the vertical or horizontal scrolling features of the view (by date or time).
virtual void | SetDayHeaderFormatLong (LPCTSTR pcszCustomFormat)
This member function(s) is used to set the date format string for the day view.
virtual void | SetDayHeaderFormatMiddle (LPCTSTR pcszCustomFormat)
This member function(s) is used to set the date format string for the day view.
virtual void | SetDayHeaderFormatShort (LPCTSTR pcszCustomFormat)
This member function(s) is used to set the date format string for the day view.
virtual void | SetDayHeaderFormatShortest (LPCTSTR pcszCustomFormat)
This member function(s) is used to set the date format string for the day view.
virtual BOOL | IsTodayVisible () const
Call this member function to determine if Today is visible.
virtual CString | GetItemTextEventTimeMax () const
This member function is called by the calendar framework to retrieve an event time string of maximum length (to reserve space).
virtual void | CalculateHeaderFormat (CDC *pDC, int nWidth, CFont *pTextFont)
This member function creates the day header format string.
- Public Member Functions inherited from CXTPCalendarWMHandler
CXTPCalendarWMHandler ()
Default object constructor.
virtual void | OnKeyUp (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process key-up keyboard events.
virtual BOOL | OnWndMsg (UINT message, WPARAM wParam, LPARAM lParam, LRESULT *pResult)
This method is called by framework after default message processing.
virtual void | OnPostAdjustLayout ()
This member function is used to perform additional adjustments in some kinds of views.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Public Attributes

COleDateTime | m_dtTimeScaleMin
Time scale minimum value.
COleDateTime | m_dtTimeScaleMax
Time scale maximum value.
BOOL | m_bDraftMode
flag to set printout to print in B/W without Header and Footer to maximize main information space and simplify params set (default = FALSE)
BOOL | m_bPrintRepeatHeaderFooterMode
flag to set printout to print Header and Footer only on first page to maximize main information space (default = TRUE)
BOOL | m_bDF_mode
Last page print mode flag (FALSE - print last page same size as other, TRUE (default) - can be shorter then others)
BOOL | m_bPrintFullScale
print timescale range - if FALSE - print working hours range
int | m_nDayViewPrintInterval
interval to use in DayView Printing: 60 or 45 or 30 or 15
BOOL | m_bEcoAllDayMode
If True use short AllDay area height.
BOOL | m_bPreventDragAllDayEventInDayView
default FALSE If True it will be impossible to Drag All Day Event In DayView
int | m_nDayHeaderPeriod
interval between in multi-scheduled mode Day Header for same date repeated - need for scrolling in very many - schedules case when one day can use few screens
int | m_nCurPage
for AllDay event printing control by CXTPCalendarControlView
BOOL | m_bUseNewHitTestCode
Tells whether to use new hit test code or not.
BOOL | m_bShowLinks
flag to show or hide 'virtual' view events
BOOL | m_bHideLinkContainer
flag to hide or show 'virtual' view events container column
BOOL | m_bShowAllDayEventsOnly
flag that enables showing all-day events only

Protected Member Functions

virtual void | StopVertEventScroll ()
This member function is used to stop vertical scrolling.
virtual void | StopHorzEventScroll ()
This member function is used to stop horizontal scrolling.
BOOL | GetIsCanHScrollGroupsLeft (COleDateTime dtNewSelEnd, BOOL bVKShift)
This member function is an utility function used by OnKeyDown It determines if we can scroll groups left if hscroll is disabled.
BOOL | GetIsCanHScrollGroupsRight (COleDateTime dtNewSelEnd, BOOL bVKShift)
This member function is an utility function used by OnKeyDown It determines if we can scroll groups right if hscroll is disabled.
virtual void | SetMouseOutOfDragArea (BOOL bOutOfArea)
This member function is used to change the mouse cursor.
virtual BOOL | IsOutOfClientRect (CPoint pnt, XTP_CALENDAR_HITTESTINFO *pHitInfo)
This member function is used to determine if the point is in the drag able rectangle.
virtual XTPCalendarDayViewScrollDirection | GetNeededScrollDirection (CPoint pnt) const
This member function is used to determine the scroll direction.
virtual BOOL | VertEventScroll (BOOL bUp)
This member function is used to vertically scroll an event in the current view.
virtual BOOL | HorzEventScroll (BOOL bLeft)
This member function is used to horizontally scroll an event in the current view.
virtual COleDateTimeSpan | GetEventDurationMin () const
This member function is used to return the minimum event duration so that the event is visible in the current view.
virtual void | SelectDay (CXTPCalendarViewDay *pDay, int nGroupIndex)
This member function is used to select or un-select the provided day, including all of the day's events.
virtual void | SelectDay (CXTPCalendarViewDay *pDay)
This member function is used to select or un-select the provided day, including all of the day's events.
virtual void | AdjustAdditionalScaleTimeZone ()
Converts Time Zones from both timescales to the minutes shift of the second time scale in comparison with the first one.
virtual void | _ScrollV (int nIndex, int nPos_raw)
This member function is used to scroll the content of a view.
int | _GetTimeScaleWith () const
This member function is used to get time scales area width.
CRect | _GetScrollRectClient () const
This member function is used to get horizontal scroll area rect.
BOOL | _EnsureVisibleH (CXTPCalendarViewEvent *pViewEvent)
This member function is used to ensure that an event view item is visible.
BOOL | _EnsureVisibleV (CXTPCalendarViewEvent *pViewEvent)
This member function is used to ensure that an event view item is visible.
BOOL | _EnsureVisibleSelectionH ()
This member function is used to ensure that an selection is visible.
virtual void | OnStartDragging (CPoint point, XTP_CALENDAR_HITTESTINFO *pHitTest)
This member function is used to start the event editing (dragging).
virtual BOOL | OnDragging (CPoint point, XTP_CALENDAR_HITTESTINFO *pHitTest)
This member function is used to perform the event editing (dragging) operation step.
virtual BOOL | OnEndDragging (CPoint point, XTP_CALENDAR_HITTESTINFO *pHitInfo)
This member function is used to finish the event editing (dragging) operation.
virtual void | ProcessDaySelection (XTP_CALENDAR_HITTESTINFO *pInfo, UINT nFlags)
This member function is used to process the days selection that are selected with the mouse.
virtual CXTPCalendarViewEvent * | FindEventToEditByTAB (COleDateTime dtMinStart, BOOL bReverse, CXTPCalendarEvent *pAfterEvent=NULL)
This member function is used to obtain the next event view object used for editing events by pressing the TAB key.
virtual COleDateTime | GetNextTimeEditByTAB () const
This member function is used to obtain the next date and time to start the find event view for editing events using the TAB key.
virtual void | UpdateNextTimeEditByTAB (COleDateTime dtNext, BOOL bReverse, BOOL bReset=FALSE)
This member function is used to set the next date and time to start the find event view for editing events using the TAB key.
virtual BOOL | OnTimer (UINT_PTR uTimerID)
The framework calls this member function after each interval specified in the SetTimer member function.
virtual void | OnActivateView (BOOL bActivate, CXTPCalendarView *pActivateView, CXTPCalendarView *pInactiveView)
This member function is called by the framework view when it is activated or deactivated.
- Protected Member Functions inherited from CXTPCalendarView
virtual UINT | SetTimer (UINT uTimeOut_ms)
This member function is used to create a timer event.
virtual void | KillTimer (UINT uTimerID)
This member function is used to destroy a timer event.
virtual void | OnBeforeDestroy ()
This member function is called by the framework before destroying the view.
virtual void | SendNotification (XTP_NOTIFY_CODE EventCode, WPARAM wParam=0, LPARAM lParam=0)
This member function is used to send a notification from the parent Calendar control.
virtual void | _CalculateEventTimeFormat ()
This member function is used to create the time format string.
virtual CString | _GetMaxWidthFormat (CDC *pDC, CString strFormat, BOOL bMonth) const
This function is used to calculate the max width of the date used in the specified format string.
virtual int | _GetMaxWidth (CDC *pDC, CString strFormat) const
This member function is used to calculate, in pixels, the max date width for the specified format string.
virtual void | _RemoveYearPart (CString &strFormat)
This member function is used to remove the year part from the specified format string.
virtual void | _ReadDefaultHeaderFormats ()
This member function is used to build day header date format default strings.
virtual CString | _GetDayHeaderFormat (int nLevel) const
This member function gets a custom or default day header date format string.
virtual BOOL | _CanSubjectEditor (UINT idEditCmd) const
This member function is used to determine if the specified editing operation command is possible for the event subject editor window.
virtual CWnd * | _GetSubjectEditorWnd () const
This member function is used to obtain a pointer to the event subject editor window.
virtual COleDataSource * | _CopySelectedEvents (DWORD dwCopyFlags=0)
This member function is used to copy selected events and CXTPCalendarEvent objects, to a COleDataSource object.
virtual CXTPCalendarEventsPtr | _ReadEventsFromClipboard (COleDataObject *pData, DWORD *pdwCopyFlags=NULL)
This member function is used to read events and CXTPCalendarEvent objects, from a COleDataSource object.
virtual BOOL | _Undo (CXTPCalendarEvent *pEvent=NULL)
This member function is used to perform an undo/redo operation for the specified event.
virtual XTPEnumCalendarUpdateResult | OnEventChanged_InDataProvider (XTP_NOTIFY_CODE nfCode, CXTPCalendarEvent *pEvent)
This member function handles the changing of an event in the associated data provider.
BOOL | _IsDragModeCopyMove (int eDragMode) const
This method is used to determine Copy or Move dragging mode.
BOOL | IsEditOperationDisabledNotify (XTPCalendarEditOperation eOperation, CXTPCalendarViewEvent *pEventView) const
This method is used to determine if specified editing operation is disabled.
BOOL | OnBeforeEditOperationNotify (XTPCalendarEditOperation eOperation, CXTPCalendarViewEvent *pEventView)
This method is used to customize or disable specified editing operation.
BOOL | OnBeforeEditOperationNotify (XTPCalendarEditOperation eOperation, CXTPCalendarViewEvents *pEventViews)
This method is used to customize or disable specified editing operation.
BOOL | OnBeforePasteNotify (CXTPCalendarEvent *pEvent, BOOL bPasteWillChangeExistingEvent)
This method is used to customize or disable paste editing operation.
BOOL | OnInPlaceCreateEvent (LPCTSTR pcszInitialSubject)
This method is used to customize or disable xtpCalendarEO_InPlaceCreateEvent editing operation.

Protected Attributes

int | m_nScrollOffsetX
Stores horizontal left offset of visible day view part.
int | m_nMinColumnWidth
0 means disabled; -1 use some default width for multiresources only; -N use for multiresources only (internally converted to +N); +N used always (in single and multi resources mode).
XTP_DAY_VIEW_LAYOUT | m_LayoutX
Layout data.
- Protected Attributes inherited from CXTPCalendarView
CSelectionChanged_ContextData m_cntSelChanged
Counter on selection changes,.
int | m_eUndoMode
Undo mode, see XTPCalendarUndoMode.
BOOL | m_bResetUndoBuffer
Clean undo buffer before add next undo action.
CUndoBuffer * | m_pPrevUndoBuffer
Undo buffer data after last undo buffer clean.
CUndoBuffer * | m_pUndoBuffer
Undo buffer object.
XTP_VIEW_LAYOUT | m_Layout
Layout data.
SEventTimeFormatInfo | m_EventTimeFormat
Information used to format events times.
CString | m_strHeaderFormat
Day header active date format string.
CString | m_strDayHeaderFormatLong
Day header Long date format custom string.
CString | m_strDayHeaderFormatMiddle
Day header Middle date format custom string.
CString | m_strDayHeaderFormatShort
Day header Short date format custom string.
CString | m_strDayHeaderFormatShortest
Day header Shortest date format custom string.
CString | m_strDayHeaderFormatDefaultLong
Day header Long date format default string.
CString | m_strDayHeaderFormatDefaultMiddle
Day header Middle date format default string.
CString | m_strDayHeaderFormatDefaultShort
Day header Short date format default string.
CString | m_strDayHeaderFormatDefaultShortest
Day header Shortest date format default string.
CRect | m_rcView
Client rect.
CRect | m_rcTooltip
Last shown tooltip rect (while GetTooltipRect returns calculated currently required tooltip rect)
CXTPCalendarEventPtr | m_ptrDraggingEventOrig
Event object before start event editing.
CXTPCalendarEventPtr | m_ptrDraggingEventNew
Editing event object.
COleDateTimeSpan | m_spDraggingStartOffset
Start dragging operation offset from the beginning of the event.
CPoint | m_ptStartDragging
Request to start dragging operation from this point.
XTPCalendarDraggingMode | m_eDraggingMode
Editing event mode.
BOOL | m_bStartedClickInside
Is OnLButtonDown was inside view rect.
CXTPCalendarViewEventPtr | m_ptrEditingViewEvent
Currently editing subject event view or event view requested to edit subject by timeout.
CXTPCalendarViewEvent * | m_pLastEvent
Last selected event.
UINT | m_nTimerID_StartEditSubject
Timer ID of edit event subject request.
UINT | m_nTimerID_ShowToolTip
Timer ID of start show tooltip request.
CXTPCalendarControl * | m_pControl
Pointer to the owner control object.
CXTPCalendarViewEvents * | m_pSelectedEvents
Selected Events;.
XTP_CALENDAR_HITTESTINFO m_LastHitInfo
Last HitInfo data.
UINT | m_nKeyStateTimerID
Timer ID to check Keys state (like Control).
XTP_CALENDAR_VIEWSELECTION | m_selectedBlock
Current selection.
BOOL | m_bScrollV_Disabled
Is vertical scrolling disabled for a view.
BOOL | m_bScrollH_Disabled
Is horizontal scrolling disabled for a view.
CXTPCalendarResources * | m_pResources
Resources array.
CXTPCalendarPtrCollectionT< CXTPCalendarViewDay > | m_arDays
Stores the view day collection.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

This class implements a specific view portion of the Calendar control - called Day view.

The Day view consists of one or more days, placed in a row. Each day is stretched down by a number of fixed time intervals. Each day is represented by a CXTPCalendarDayViewDay class.

The Day view also contains two time scales defining those intervals at the left or right of the view, which is represented by the CXTPCalendarDayViewTimeScale class. One time scale is the main and is visible by default, second one is the additional and can be enabled programmatically. Time scale interval can be changed using the SetScaleInterval member function. The content of the view refreshes automatically.

See also
CXTPCalendarView
CXTPCalendarWeekView
CXTPCalendarMonthView
CXTPCalendarDayViewDay
CXTPCalendarDayViewEvent

Member Typedef Documentation

◆ TBase

CXTPCalendarViewT<CXTPCalendarDayViewDay> TBase

Base class type definition.

Constructor & Destructor Documentation

◆ CXTPCalendarDayView()

CXTPCalendarDayView ( CXTPCalendarControl * pCalendarControl )

Default object constructor.

Parameters
pCalendarControl Pointer to CXTPCalendarControl object.
See also
~CXTPCalendarEvent()

◆ ~CXTPCalendarDayView()

virtual ~CXTPCalendarDayView ( )
virtual

Default class destructor.

Handles class members deallocation.

Member Function Documentation

◆ _EnsureVisibleH()

BOOL _EnsureVisibleH ( CXTPCalendarViewEvent * pViewEvent )
protected

This member function is used to ensure that an event view item is visible.

Parameters
pViewEvent A CXTPCalendarViewEvent object. A pointer to the event view item being made visible.

If necessary, the function scrolls the day view so that the event view item is visible.

Returns
Returns TRUE if the system scrolled the day view in the Calendar control to ensure that the specified event view item is visible. Otherwise, the return value is FALSE.

◆ _EnsureVisibleSelectionH()

BOOL _EnsureVisibleSelectionH ( )
protected

This member function is used to ensure that an selection is visible.

If necessary, the function scrolls the day view horizontally so that the selection is visible.

Returns
Returns TRUE if the system scrolled the day view, otherwise FALSE.

◆ _EnsureVisibleV()

BOOL _EnsureVisibleV ( CXTPCalendarViewEvent * pViewEvent )
protected

This member function is used to ensure that an event view item is visible.

Parameters
pViewEvent A CXTPCalendarViewEvent object. A pointer to the event view item being made visible.

If necessary, the function scrolls the day view so that the event view item is visible.

Returns
Returns TRUE if the system scrolled the day view in the Calendar control to ensure that the specified event view item is visible. Otherwise, the return value is FALSE.

◆ _GetScrollRectClient()

CRect _GetScrollRectClient ( ) const
protected

This member function is used to get horizontal scroll area rect.

Returns
Horizontal scroll area rect.

◆ _GetTimeScaleWith()

int _GetTimeScaleWith ( ) const
protected

This member function is used to get time scales area width.

Returns
Time scales area width in pixels.

◆ _ScrollV()

virtual void _ScrollV | ( | int | nIndex,
 |  | int | nPos_raw )
 protectedvirtual

This member function is used to scroll the content of a view.

Parameters
nIndex | Position value.
nPos_raw | Raw position value. (Not used at this time.)

◆ AddDay()

virtual void AddDay ( const COleDateTime & date )
virtual

This member function is used to add a specified date to the dates set showing in the current calendar day view.

Parameters
date A COleDateTime object that contains the date to display.

Call this member function to display a specific day in the calendar day view in addition to the days already visible.

◆ AdjustAdditionalScaleTimeZone()

virtual void AdjustAdditionalScaleTimeZone ( )
protectedvirtual

Converts Time Zones from both timescales to the minutes shift of the second time scale in comparison with the first one.

See also
CXTPCalendarViewDay
SelectDay(COleDateTime dtSelDay, BOOL bSelect)

◆ AdjustLayout()

virtual void AdjustLayout | ( | CDC * | pDC,
 |  | const CRect & | rcView,
 |  | BOOL | bCallPostAdjustLayout = TRUE )
 virtual

This member function is used to adjust the view's layout depending on the window's client dimensions and calls.

Parameters
pDC | Pointer to a valid device context.
rcView | A CRect that contains the bounding rectangle dimensions of the view.
bCallPostAdjustLayout | TRUE for calling additional post-adjustments

Call Populate() prior adjusting layout. Adjust layout of all sub-items. AdjustLayout2 is called by calendar control instead of AdjustLayout when theme is set.

Reimplemented from CXTPCalendarView.

◆ AdjustLayout2()

virtual void AdjustLayout2 | ( | CDC * | pDC,
 |  | const CRect & | rcView,
 |  | BOOL | bCallPostAdjustLayout = TRUE )
 virtual

This member function is used to adjust the view's layout depending on the window's client dimensions and calls.

Parameters
pDC | Pointer to a valid device context.
rcView | A CRect that contains the bounding rectangle dimensions of the view.
bCallPostAdjustLayout | TRUE for calling additional post-adjustments

Call Populate() prior adjusting layout. Adjust layout of all sub-items. AdjustLayout2 is called by calendar control instead of AdjustLayout when theme is set.

Reimplemented from CXTPCalendarView.

◆ Draw()

virtual void Draw ( CDC * pDC )
virtual

This member function is used to draw the view content using the specified device context.

Parameters
pDC Pointer to a valid device context.

Call AdjustLayout() before Draw()

See also
AdjustLayout

Reimplemented from CXTPCalendarView.

◆ Draw2()

virtual void Draw2 ( CDC * pDC )
virtual

This member function is used to draw the view content using the specified device context.

Parameters
pDC Pointer to a valid device context.

Call AdjustLayout() before Draw() Draw2 is called by calendar control instead of Draw when theme is set.

See also
AdjustLayout

Reimplemented from CXTPCalendarView.

◆ EnsureVisible()

virtual BOOL EnsureVisible ( CXTPCalendarViewEvent * pViewEvent )
virtual

This member function is used to ensure that an event view item is visible.

Parameters
pViewEvent A CXTPCalendarViewEvent object. A pointer to the event view item being made visible.

If necessary, the function scrolls the day view so that the event view item is visible.

Returns
Returns TRUE if the system scrolled the day view in the Calendar control to ensure that the specified event view item is visible. Otherwise, the return value is FALSE.

◆ EnsureVisibleH() [1/2]

virtual BOOL EnsureVisibleH ( CXTPCalendarViewEvent * pViewEvent )
virtual

This member function is used to ensure that an event view item is visible.

Parameters
pViewEvent A CXTPCalendarViewEvent object. A pointer to the event view item being made visible.

If necessary, the function scrolls the day view so that the event view item is visible.

Returns
Returns TRUE if the system scrolled the day view in the Calendar control to ensure that the specified event view item is visible. Otherwise, the return value is FALSE.

◆ EnsureVisibleH() [2/2]

virtual BOOL EnsureVisibleH ( CXTPCalendarViewGroup * pViewGroup )
virtual

This member function is used to ensure that an event view item is visible.

Parameters
pViewGroup A CXTPCalendarViewGroup object. A pointer to the group view being made visible.

If necessary, the function scrolls the day view so that the event view item is visible.

Returns
Returns TRUE if the system scrolled the day view in the Calendar control to ensure that the specified event view item is visible. Otherwise, the return value is FALSE.

◆ FindEventToEditByTAB()

virtual CXTPCalendarViewEvent * FindEventToEditByTAB | ( | COleDateTime | dtMinStart,
 |  | BOOL | bReverse,
 |  | CXTPCalendarEvent * | pAfterEvent = NULL )
 protectedvirtual

This member function is used to obtain the next event view object used for editing events by pressing the TAB key.

Parameters
dtMinStart | A COleDateTime object that contains the first date and time to start the search.
bReverse | If TRUE the reverse order is used, otherwise normal is used.
pAfterEvent | A CXTPCalendarEvent object that contains the last event object to search for.
Returns
A CXTPCalendarViewEvent object that contains the view object or NULL.
See also
GetNextTimeEditByTAB
UpdateNextTimeEditByTAB

Reimplemented from CXTPCalendarView.

◆ GetAdditionalScaleText()

CString GetAdditionalScaleText ( ) const

This member function is used to obtain the text label of the additional time scale.

Returns
A CString object that contains the additional time scale text label.

◆ GetAdditionalScaleTimeZone()

const TIME_ZONE_INFORMATION & GetAdditionalScaleTimeZone ( ) const

This member function is used to get the time zone information for the additional time scale.

Returns
A reference to time zone information structure.

◆ GetAdditionalScaleTimeZoneInfo()

CXTPCalendarTimeZonePtr GetAdditionalScaleTimeZoneInfo ( ) const

Get full information about additional time scale time zone.

Retrieve additional information from the registry.

Returns
A smart pointer to CXTPCalendarTimeZone object.
See also
GetTimeZoneInformation()
CXTPCalendarTimeZone::GetTimeZoneInfo()

◆ GetCellDuration()

COleDateTimeSpan GetCellDuration ( ) const

This member function is used to obtain the current cell duration.

Returns
A COleDateTimeSpan object that contains the amount of time between a cell's start coordinates and the next cell's starting coordinates.

◆ GetCellNumber() [1/2]

int GetCellNumber | ( | COleDateTime | dtTime,
 |  | BOOL | bForEndTime ) const

This member function is used to calculate the cell number for the specified time value.

Parameters
dtTime | A COleDateTime object that contains a time value to check for.
bForEndTime | A BOOL that contains the value that indicates if we should consider a split line between cells to belong to the end of the previous cell or to the beginning of the next cell.
Returns
Call this member function when you want to retrieve which cell contains a specified time value.

◆ GetCellNumber() [2/2]

int GetCellNumber | ( | int | nHour,
 |  | int | nMin,
 |  | int | nSec,
 |  | BOOL | bForEndTime ) const

This member function is used to calculate the cell number for the specified time value.

Parameters
nHour | An int that contains the hour part of the time value to check for.
nMin | An int that contains the minute part of the time value to check for.
nSec | An int that contains the second part of the time value to check for.
bForEndTime | A BOOL that contains the value that indicates if we should consider a split line between cells to belong to the end of the previous cell or to the beginning of the next cell.
Returns
Call this member function when you want to retrieve which cell contains a specified time value.

◆ GetCellTime()

COleDateTime GetCellTime ( int nCell ) const

This member function is used to obtain the time value for the specified cell.

Parameters
nCell An int that contains a cell number.
Returns
A COleDateTime object that contains the specific time value for the cell's beginning coordinate.

◆ GetCurrentTimeZoneInfo()

CXTPCalendarTimeZonePtr GetCurrentTimeZoneInfo ( ) const

Get full information about current time zone.

Retrieve additional information from the registry.

Returns
A smart pointer to CXTPCalendarTimeZone object.
See also
GetTimeZoneInformation()
CXTPCalendarTimeZone::GetTimeZoneInfo()

◆ GetDay()

virtual CXTPCalendarDayViewDay * GetDay ( COleDateTime dtDay )
virtual

Call this member function to obtain the CXTPCalendarDayViewDay object by the day's date.

Parameters
dtDay A day date to find.

Returns NULL if no day with the specified date in the days collection.

Returns
A pointer to a CXTPCalendarViewDay object.
See also
GetViewDayCount()
GetViewDay_
GetViewDay

◆ GetEventDurationMin()

virtual COleDateTimeSpan GetEventDurationMin ( ) const
protectedvirtual

This member function is used to return the minimum event duration so that the event is visible in the current view.

Returns
A COleDateTimeSpan object that specifies the minimum duration of the event.

Reimplemented from CXTPCalendarView.

◆ GetIsCanHScrollGroupsLeft()

BOOL GetIsCanHScrollGroupsLeft | ( | COleDateTime | dtNewSelEnd,
 |  | BOOL | bVKShift )
 protected

This member function is an utility function used by OnKeyDown It determines if we can scroll groups left if hscroll is disabled.

Parameters
bVKShift | The state of the Shift virtual key
dtNewSelEnd | The last selection date-time.
Returns
True if can scroll left, false otherwise

◆ GetIsCanHScrollGroupsRight()

BOOL GetIsCanHScrollGroupsRight | ( | COleDateTime | dtNewSelEnd,
 |  | BOOL | bVKShift )
 protected

This member function is an utility function used by OnKeyDown It determines if we can scroll groups right if hscroll is disabled.

Parameters
bVKShift | The state of the Shift virtual key
dtNewSelEnd | The last selection date-time.
Returns
True if can scroll right, false otherwise

◆ GetMinColumnWidth()

AFX_INLINE int GetMinColumnWidth ( ) const
virtual

This member function returns values which interpreted as a minimum column width, where column is a group view object.

The returned number may be one of the following values: [ul] [li] 0 means disabled; [li] -1 use some default width for multiresources only; [li] -N use for multiresources only (internally converted to +N); [li] +N used always (in single and multi resources mode). [/ul]

Returns
Minimum column width in pixels (may be negative) or 0 or -1.
See also
SetMinColumnWidth

◆ GetNeededScrollDirection()

virtual XTPCalendarDayViewScrollDirection GetNeededScrollDirection ( CPoint pnt ) const
protectedvirtual

This member function is used to determine the scroll direction.

Parameters
pnt Test mouse point.

This function returns an XTPCalendarDayViewScrollDirection enumeration which defines the scroll direction.

Returns
xtpCalendarDayViewScrollUp/xtpCalendarDayViewScrollDown if scrolling up/down is needed. xtpCalendarDayViewScrollNotNeeded if scrolling is not needed.

◆ GetNextTimeEditByTAB()

virtual COleDateTime GetNextTimeEditByTAB ( ) const
protectedvirtual

This member function is used to obtain the next date and time to start the find event view for editing events using the TAB key.

Returns
A COleDateTime object that contains the next date and time.
See also
FindEventToEditByTAB
UpdateNextTimeEditByTAB

Reimplemented from CXTPCalendarView.

◆ GetRowCount()

AFX_INLINE int GetRowCount ( ) const

This member function is used to obtain the total row count on the view.

Returns
An int containing the total count of rows on the view.

◆ GetScaleInterval()

COleDateTimeSpan GetScaleInterval ( ) const

This member function is used to obtain the time scale item interval.

Returns
A COleDateTimeSpan object that contains the time interval of the time scale item.

◆ GetScaleMaxTime()

COleDateTime GetScaleMaxTime ( ) const

This member function is used to obtain the maximal time which is shown on the day view scale.

Returns
A COleDateTime object that contains the maximal scale time.

◆ GetScaleMinTime()

COleDateTime GetScaleMinTime ( ) const

This member function is used to obtain the minimal time which is shown on the day view scale.

Returns
A COleDateTime object that contains the minimal scale time.

◆ GetScaleText()

CString GetScaleText ( ) const

This member function is used to obtain the text label of the default time scale.

Returns
A CString object that contains the default time scale text label.

◆ GetScrollBarInfoH()

virtual BOOL GetScrollBarInfoH | ( | SCROLLINFO * | pSI,
 |  | int * | pnScrollStep = NULL ) const
 virtual

This member function is used to retrieve information about a scroll bar's state.

Parameters
pSI | A pointer to scrollbar information structure.
pnScrollStep | A pointer to int to receive scroll step. Can be NULL.
Returns
A BOOL. TRUE if the visible row count is not the same as the actual row count. FALSE otherwise.

Reimplemented from CXTPCalendarView.

◆ GetScrollBarInfoV()

virtual BOOL GetScrollBarInfoV ( SCROLLINFO * pSI ) const
virtual

This member function is used to retrieve information about a scroll bar's state.

Parameters
pSI A pointer to scrollbar information structure.
Returns
A BOOL. TRUE if the visible row count is not the same as the actual row count. FALSE otherwise.

Reimplemented from CXTPCalendarView.

◆ GetSelection()

virtual BOOL GetSelection | ( | COleDateTime * | pBegin = NULL,
 |  | COleDateTime * | pEnd = NULL,
 |  | BOOL * | pbAllDayEvent = NULL,
 |  | int * | pnGroupIndex = NULL,
 |  | COleDateTimeSpan * | pspSelectionResolution = NULL ) const
 virtual

This member function is used to obtain the view selection.

Parameters
pBegin | A pointer to the COleDateTime object that contains the beginning of the selection.
pEnd | A pointer to the COleDateTime object that contains the ending of the selection.
pbAllDayEvent | A pointer to the BOOL variable that contains the AllDayEvent attribute of the selection (used in the day view only).
pnGroupIndex | A pointer to int to receive group index.
pspSelectionResolution | A pointer to the COleDateTimeSpan object that contains the selection unit length. (i.e. 1 day, 1 Hour, ... 5 min)

Call this member function to fill provided COleDateTime objects with the values of the selection beginning, ending, and selection unit length.

Returns
TRUE - If the selection is returned successfully. FALSE otherwise.

Reimplemented from CXTPCalendarView.

◆ GetTimeScale()

AFX_INLINE CXTPCalendarDayViewTimeScale * GetTimeScale ( int nNumber = 1 ) const
virtual

This member function is used to get main or additional time scale object.

Parameters
nNumber A time scale object number: 1 - main(left) time scale, 2 - additional time scale. 3 - right time scale,

By default number 1 (main time scale) is used.

Returns
Pointer to the CXTPCalendarDayViewTimeScale object.

◆ GetTopRow()

AFX_INLINE int GetTopRow ( ) const

This member function is used to obtain the top visible row on the view.

Returns
An int that contains the number of the top visible row on the view.

◆ GetViewDayDate()

virtual COleDateTime GetViewDayDate ( int nIndex ) const
virtual

Call this member function to get the date of a day view by the day's index.

Parameters
nIndex Day view index in the view collection.
Returns
COleDateTime object with the day view date and time.

Index number starts at 0 and cannot be negative.

See also
GetViewDayCount()

Implements CXTPCalendarView.

◆ GetViewType()

virtual XTPCalendarViewType GetViewType ( ) const
virtual

Call this member function to obtain the view type flag.

Returns
An XTPCalendarViewType object that contains the view type flag.
See also
XTPCalendarViewType

Reimplemented from CXTPCalendarViewT< CXTPCalendarDayViewDay >.

◆ GetVisibleRowCount()

AFX_INLINE int GetVisibleRowCount ( ) const

This member function is used to obtain the visible row count on the view.

Returns
An int containing the count of the visible rows on the view.

◆ HitTestEx()

virtual BOOL HitTestEx | ( | CPoint | pt,
 |  | XTP_CALENDAR_HITTESTINFO * | pHitTest ) const
 virtual

This member function is used to determine which view item, if any, is at a specified position index, and returns additional info in a XTP_CALENDAR_HITTESTINFO structure.

Parameters
pt | Coordinates of point to test.
pHitTest | Pointer to a XTP_CALENDAR_HITTESTINFO structure.
Returns
TRUE if item found. FALSE otherwise.
See also
XTP_CALENDAR_HITTESTINFO

Reimplemented from CXTPCalendarView.

◆ HorzEventScroll()

virtual BOOL HorzEventScroll ( BOOL bLeft )
protectedvirtual

This member function is used to horizontally scroll an event in the current view.

Parameters
bLeft A BOOL that contains the direction to scroll: TRUE if left. FALSE if right.
Returns
TRUE, if scrolled successfully. FALSE otherwise.

◆ IsAdditionalScaleLeftVisible()

BOOL IsAdditionalScaleLeftVisible ( ) const

This member function is used to obtain the visibility flag of the additional left time scale.

Returns
A BOOL that contains the visibility flag value. TRUE - If the additional time scale is visible. FALSE - If the additional time scale is not visible.

◆ IsAdditionalScaleRightVisible()

BOOL IsAdditionalScaleRightVisible ( ) const

This member function is used to obtain the visibility flag of the additional right time scale.

Returns
A BOOL that contains the visibility flag value. TRUE - If the additional time scale is visible. FALSE - If the additional time scale is not visible.

◆ IsDrawNowLineOverAppoinment()

BOOL IsDrawNowLineOverAppoinment ( ) const

This member function is used to obtain the flag of the now line drawing.

Returns
A BOOL that contains the now line drawing. TRUE - If now line over apponitment. FALSE - If now line under apponitment.

◆ IsExpandDown()

BOOL IsExpandDown ( ) const

This member function is used to obtain the Expand Down glyph flag value.

Returns
A BOOL that contains the Expand Down flag value. TRUE - If the Expand Down glyph is visible. FALSE - If the Expand Down glyph is not visible.

◆ IsExpandUp()

BOOL IsExpandUp ( ) const

This member function is used to obtain the Expand Up glyph flag value.

Returns
A BOOL that contains the Expand Up glyph flag value. TRUE - If the Expand Up glyph is visible. FALSE - If the Expand Up glyph is not visible.

◆ IsGroupHeaderVisible()

virtual BOOL IsGroupHeaderVisible ( ) const
virtual

This member function is used to determine whether resource group header should be visible.

This method returns FALSE when resource groups count is zero and there is only one schedule used.

Returns
TRUE when visible; FALSE otherwise.

◆ IsOutOfClientRect()

virtual BOOL IsOutOfClientRect | ( | CPoint | pnt,
 |  | XTP_CALENDAR_HITTESTINFO * | pHitInfo )
 protectedvirtual

This member function is used to determine if the point is in the drag able rectangle.

Parameters
pnt | A CPoint object that contains the point to test.
pHitInfo | Pointer to the XTP_CALENDAR_HITTESTINFO structure, which helps to determine the client rectangle.
Returns
TRUE if the point is out of the drag able rectangle, FALSE otherwise.

◆ IsScaleLeftVisible()

BOOL IsScaleLeftVisible ( ) const

This member function is used to obtain the visibility flag of left time scale.

Returns
A BOOL that contains the visibility flag value. TRUE - If left time scale is visible. FALSE - If left time scale is not visible.

◆ IsScaleRightVisible()

BOOL IsScaleRightVisible ( ) const

This member function is used to obtain the visibility flag of right time scale.

Returns
A BOOL that contains the visibility flag value. TRUE - If right time scale is visible. FALSE - If right time scale is not visible.

◆ OnActivateView()

virtual void OnActivateView | ( | BOOL | bActivate,
 |  | CXTPCalendarView * | pActivateView,
 |  | CXTPCalendarView * | pInactiveView )
 protectedvirtual

This member function is called by the framework view when it is activated or deactivated.

Parameters
bActivate | Indicates whether the view is being activated or deactivated.
pActivateView | Points to the view object that is being activated.
pInactiveView | Points to the view object that is being deactivated.

Override this member function to handle activated/deactivated events.

See also
CXTPCalendarControl::SwitchActiveView(XTPCalendarViewType eView)
CXTPCalendarControl::SetActiveView(CXTPCalendarView* pView)

Reimplemented from CXTPCalendarView.

◆ OnDragging()

virtual BOOL OnDragging | ( | CPoint | point,
 |  | XTP_CALENDAR_HITTESTINFO * | pHitTest )
 protectedvirtual

This member function is used to perform the event editing (dragging) operation step.

Parameters
point | A CPoint that contains the mouse position coordinates.
pHitTest | A pointer to an XTP_CALENDAR_HITTESTINFO struct that contains the HitTest results from the specified point.
Returns
TRUE if the operation is successful, FALSE otherwise.

Reimplemented from CXTPCalendarView.

◆ OnDraw()

virtual void OnDraw ( CDC * pDC )
virtual

This member function performs all of the drawing logic of the calendar view.

Parameters
pDC Pointer to a valid device context.

Reimplemented from CXTPCalendarView.

◆ OnEndDragging()

virtual BOOL OnEndDragging | ( | CPoint | point,
 |  | XTP_CALENDAR_HITTESTINFO * | pHitInfo )
 protectedvirtual

This member function is used to finish the event editing (dragging) operation.

Parameters
point | A CPoint that contains the mouse position coordinates.
pHitInfo | A pointer to an XTP_CALENDAR_HITTESTINFO struct that contains the HitTest results from the specified point.
Returns
TRUE if the operation is successful, FALSE otherwise.

Reimplemented from CXTPCalendarView.

◆ OnKeyDown()

virtual void OnKeyDown | ( | UINT | nChar,
 |  | UINT | nRepCnt,
 |  | UINT | nFlags )
 virtual

This member function is used to process keyboard events.

Parameters
nChar | Virtual key code of the given key.
nRepCnt | Number of times the keystroke is repeated as a result of the user holding down the key.
nFlags | Scan code, key-transition code, previous key state, and context code.

This method is called by the CalendarControl when the user presses keys on the keyboard.

Reimplemented from CXTPCalendarView.

◆ OnLButtonDown()

virtual BOOL OnLButtonDown | ( | UINT | nFlags,
 |  | CPoint | point )
 virtual

This member function is used to process left mouse button events.

Parameters
nFlags | Indicates whether various virtual keys are down.
point | Specifies the x- and y- coordinate of the cursor. These coordinates are always relative to the upper-left corner of the window.
Returns
TRUE if the operation is successful, FALSE else.

This method is called by the CalendarControl when the user presses the left mouse button.

Reimplemented from CXTPCalendarView.

◆ OnLButtonUp()

virtual BOOL OnLButtonUp | ( | UINT | nFlags,
 |  | CPoint | point )
 virtual

This member function is used to processes left mouse button events.

Parameters
nFlags | A UINT that is used to indicate whether various virtual keys are down.
point | A CPoint that specifies the x- and y- coordinates of the cursor. These coordinates are always relative to the upper-left corner of the window.
Returns
TRUE if the operation is successful, FALSE else.

This method is called by the CalendarControl when the user releases the left mouse button.

Reimplemented from CXTPCalendarView.

◆ OnMouseMove()

virtual void OnMouseMove | ( | UINT | nFlags,
 |  | CPoint | point )
 virtual

This member function is used to process mouse move events.

Parameters
nFlags | Indicates whether various virtual keys are down.
point | Specifies the x- and y- coordinate of the cursor. These coordinates are always relative to the upper-left corner of the window.

This method is called by the CalendarControl when the user moves the mouse cursor or stylus.

Reimplemented from CXTPCalendarView.

◆ OnStartDragging()

virtual void OnStartDragging | ( | CPoint | point,
 |  | XTP_CALENDAR_HITTESTINFO * | pHitTest )
 protectedvirtual

This member function is used to start the event editing (dragging).

Parameters
point | A CPoint that contains the mouse position with the coordinates to start the event editing (dragging).
pHitTest | A pointer to an XTP_CALENDAR_HITTESTINFO struct that contains the HitTest results from a specified point.

Reimplemented from CXTPCalendarView.

◆ OnTimer()

virtual BOOL OnTimer ( UINT_PTR uTimerID )
protectedvirtual

The framework calls this member function after each interval specified in the SetTimer member function.

Parameters
uTimerID A UINT that is used to specify the identifier of the timer.
Returns
TRUE if the message is handled properly, FALSE otherwise.

Reimplemented from CXTPCalendarView.

◆ ProcessDaySelection()

AFX_INLINE void ProcessDaySelection | ( | XTP_CALENDAR_HITTESTINFO * | pInfo,
 |  | UINT | nFlags )
 protectedvirtual

This member function is used to process the days selection that are selected with the mouse.

Parameters
pInfo | A pointer to a XTP_CALENDAR_HITTESTINFO struct that contains HitTest information about the current mouse position.
nFlags | A UINT that contains the current state of the additional mouse and keyboard buttons. Like MK_SHIFT, ...
See also
SelectDays

Reimplemented from CXTPCalendarView.

◆ ScrollDaysToNext()

virtual void ScrollDaysToNext ( int nScrollDaysCount = 1 )
virtual

This member function is used to scroll the view forward a specified number of days.

Parameters
nScrollDaysCount An int that is used to specify the number of days to scroll.

Call this member function to switch the number of days forward from the current date.

See also
ScrollDaysToPrev

◆ ScrollDaysToPrev()

virtual void ScrollDaysToPrev ( int nScrollDaysCount = 1 )
virtual

This member function is used to scroll the view back a specified number of days.

Parameters
nScrollDaysCount An int that is used to specify the number of days to scroll.

Call this member function when you want to switch the number of days back from the current day.

See also
ScrollDaysToNext

◆ ScrollH()

virtual void ScrollH | ( | int | nPos,
 |  | int | nPos_raw )
 virtual

This member function is used to scroll the content of a view.

Parameters
nPos | Position value.
nPos_raw | Raw position value. (Not used at this time.)

Reimplemented from CXTPCalendarView.

◆ ScrollToColumn()

void ScrollToColumn ( long lColumn )

This member function is used to scroll the view forward a specified number of columns (schedules).

Parameters
lColumn columns # to show

◆ ScrollToWorkDayBegin()

virtual void ScrollToWorkDayBegin ( )
virtual

This member function is used to start view from the work day starting time.

Call this method after set new data provider because new data provider store other time scale resolution value.

◆ ScrollV()

virtual void ScrollV | ( | int | nPos,
 |  | int | nPos_raw )
 virtual

This member function is used to scroll the content of a view.

Parameters
nPos | Position value.
nPos_raw | Raw position value. (Not used at this time.)

Reimplemented from CXTPCalendarView.

◆ SelectDay() [1/2]

virtual void SelectDay ( CXTPCalendarViewDay * pDay )
protectedvirtual

This member function is used to select or un-select the provided day, including all of the day's events.

Parameters
pDay A pointer to a CXTPCalendarViewDay object.
See also
CXTPCalendarViewDay
SelectDay(COleDateTime dtSelDay, BOOL bSelect)

◆ SelectDay() [2/2]

virtual void SelectDay | ( | CXTPCalendarViewDay * | pDay,
 |  | int | nGroupIndex )
 protectedvirtual

This member function is used to select or un-select the provided day, including all of the day's events.

Parameters
pDay | A pointer to a CXTPCalendarViewDay object.
nGroupIndex | A group index to select.
See also
CXTPCalendarViewDay
SelectDay(COleDateTime dtSelDay, BOOL bSelect)

Reimplemented from CXTPCalendarView.

◆ SetAdditionalScaleText()

void SetAdditionalScaleText ( LPCTSTR strText )

This member function is used to set the text label for the additional time scale.

Parameters
strText A CString that contains the new text label.

◆ SetAdditionalScaleTimeZone()

void SetAdditionalScaleTimeZone ( const TIME_ZONE_INFORMATION * pTzInfo )

This member function is used to set the time zone information for the additional time scale.

Parameters
pTzInfo A pointer to time zone information structure.
See also
MSDN Articles: INFO: Retrieving Time-Zone Information KB115231, Q115231

HOWTO: Change Time Zone Information Using Visual Basic KB221542, Q221542

◆ SetMinColumnWidth()

AFX_INLINE void SetMinColumnWidth ( int nWidth )
virtual

This member function used to set minimum column width, where column is a group view object.

Parameters
nWidth [in] Minimum column width in pixels (may be negative) or 0 or -1. See remarks section.

nWidth number may be one of the following values: [ul] [li] 0 means disabled; [li] -1 use some default width for multiresources only; [li] -N use for multiresources only (internally converted to +N); [li] +N used always (in single and multi resources mode). [/ul]

See also
GetMinColumnWidth

◆ SetMouseOutOfDragArea()

virtual void SetMouseOutOfDragArea ( BOOL bOutOfArea )
protectedvirtual

This member function is used to change the mouse cursor.

Parameters
bOutOfArea TRUE means out (FALSE - inside) of drag area.

Call this member function to changes the mouse cursor depending on which drag mode is currently active. Note: The drag mode is contained in the XTPCalendarDraggingMode m_eDraggingMode member variable.

◆ SetScaleInterval()

void SetScaleInterval ( const COleDateTimeSpan spScaleInterval )

This member function is used to set the time scale item interval.

Parameters
spScaleInterval A COleDateTimeSpan object that contains the new time scale item interval.

◆ SetScaleMaxTime()

void SetScaleMaxTime ( const COleDateTime dtNewScaleMaxTime )

This member function is used to set the maximal time which is shown on the day view scale.

Only time part of the argument will be used by the control. It will be used for all dates. Date part of the argument is ignored.

Parameters
dtNewScaleMaxTime A COleDateTime object that contains the new maximal time scale value.

◆ SetScaleMinTime()

void SetScaleMinTime ( const COleDateTime dtNewScaleMinTime )

This member function is used to set the minimal time which is shown on the day view scale.

Only time part of the argument will be used by the control. It will be used for all dates. Date part of the argument is ignored.

Parameters
dtNewScaleMinTime A COleDateTime object that contains the new minimal time scale value.

◆ SetScaleText()

void SetScaleText ( LPCTSTR strText )

This member function is used to set the text label for the default time scale.

Parameters
strText A CString that contains the new text label for the default time label.

◆ ShowAdditionalScale()

void ShowAdditionalScale ( BOOL bShow = TRUE )

This member function is used to Show or hide the additional time scale.

Parameters
bShow A BOOL that contains the new visibility flag value. TRUE - Default value, shows the additional time scale. FALSE - Do not show the default value.

◆ ShowDay()

virtual void ShowDay | ( | const COleDateTime & | date,
 |  | BOOL | bSelect = TRUE )
 virtual

This member function is used to show the specified day in the calendar day view.

Parameters
date | A COleDateTime object that contains the date to show.
bSelect | TRUE to select the specified day after showing, FALSE otherwise. TRUE is the default value.

Call this member function to show only the specified day in the calendar day view.

Implements CXTPCalendarView.

◆ ShowDays()

virtual void ShowDays | ( | const COleDateTime & | dtBegin,
 |  | const COleDateTime & | dtEnd )
 virtual

This member function is used to show the specified day interval in the calendar day view.

Parameters
dtBegin | A COleDateTime object that contains the beginning interval date to show.
dtEnd | A COleDateTime object that contains the ending interval date to show.

Call this member function to show all days from the dtBegin up to dtEnd inclusive.

◆ ShowWorkingDays()

virtual void ShowWorkingDays ( const COleDateTime & dtDay )
virtual

This member function is used to show that working week in the calendar day view, which includes the specified day.

Parameters
dtDay A COleDateTime object that contains the date to show.

Call this member function to show working week which includes dtDay.

◆ StopHorzEventScroll()

virtual void StopHorzEventScroll ( )
protectedvirtual

This member function is used to stop horizontal scrolling.

If there is a horizontal scroll event in process, then calling this member function stops the v scrolling.

◆ StopVertEventScroll()

virtual void StopVertEventScroll ( )
protectedvirtual

This member function is used to stop vertical scrolling.

If there is a vertical scroll event in process, then calling this member function stops the vertical scrolling.

◆ UpdateNextTimeEditByTAB()

virtual void UpdateNextTimeEditByTAB | ( | COleDateTime | dtNext,
 |  | BOOL | bReverse,
 |  | BOOL | bReset = FALSE )
 protectedvirtual

This member function is used to set the next date and time to start the find event view for editing events using the TAB key.

Parameters
dtNext | A COleDateTime object that contains the next date and time to start the find event view.
bReverse | If TRUE the reverse order is used, otherwise normal is used.
bReset | If TRUE the next time is set to the start (or end) iteration position.
See also
GetNextTimeEditByTAB
FindEventToEditByTAB

Reimplemented from CXTPCalendarView.

◆ VertEventScroll()

virtual BOOL VertEventScroll ( BOOL bUp )
protectedvirtual

This member function is used to vertically scroll an event in the current view.

Parameters
bUp A BOOL that contains the direction to scroll: TRUE if up. FALSE if down.
Returns
TRUE, if scrolled successfully. FALSE otherwise.
The documentation for this class was generated from the following file:
  • XTPCalendarDayView.h


Toolkit Pro: CXTPCalendarDayViewDay Class Reference

Public Types | Public Member Functions | Protected Member Functions | List of all members
CXTPCalendarDayViewDay Class Reference

This class represents a day view portion of the Calendar Day View. More...

Inheritance diagram for CXTPCalendarDayViewDay:
[legend]

Public Types

typedef CXTPCalendarViewDayT< CXTPCalendarDayView, CXTPCalendarDayViewGroup, XTP_CALENDAR_HITTESTINFO, CXTPCalendarDayViewDay > | TBase
Base class type definition.
- Public Types inherited from CXTPCalendarViewDayT< CXTPCalendarDayView, CXTPCalendarDayViewGroup, XTP_CALENDAR_HITTESTINFO, CXTPCalendarDayViewDay >
typedef CXTPCalendarDayView | TView

Public Member Functions

CXTPCalendarDayViewDay (CXTPCalendarDayView *pDayView, COleDateTime dtDate)
Default object constructor.
virtual | ~CXTPCalendarDayViewDay ()
Default class destructor.
virtual void | Draw (CDC *pDC)
This member function is used to draw the view content utilizing the specified device context.
virtual void | DrawEvents (CDC *pDC)
This member function is used to draw the view content utilizing the specified device context.
virtual void | DrawTopmostLayer (CDC *pDC)
This member function is used to draw the view content utilizing the specified device context.
virtual void | AdjustLayout (CDC *pDC, const CRect &rcDay)
This member function is used to adjust the view's layout depending on the provided bounding rectangle and calls AdjustLayout() for all sub items.
virtual void | AdjustLayout2 (CDC *pDC, const CRect &rcDay)
This member function is used to adjust the view's layout depending on the provided bounding rectangle and calls AdjustLayout() for all sub items.
virtual void | Populate (COleDateTime dtDayDate)
This member function is used to populate the view with data for all items contained in the view.
virtual CString | GetCaption () const
This member function is used to obtain a single day's view caption.
virtual void | FillHitTestEx (XTP_CALENDAR_HITTESTINFO *pInfo) const
This member function is used to fill an XTP_CALENDAR_HITTESTINFO structure.
- Public Member Functions inherited from CXTPCalendarViewDayT< CXTPCalendarDayView, CXTPCalendarDayViewGroup, XTP_CALENDAR_HITTESTINFO, CXTPCalendarDayViewDay >
CXTPCalendarViewDayT (const CXTPCalendarDayView *pView)
Default object constructor.
virtual | ~CXTPCalendarViewDayT ()
Default class destructor.
CXTPCalendarDayView * | GetView () const
This member function is used to obtain the owner view object.
virtual CXTPCalendarDayViewGroup * | GetViewGroup (int nIndex) const
Call this member function to obtain a pointer to the _TViewGroup object that corresponds to the resource's index.
virtual CXTPCalendarViewGroup * | CreateGroup ()
This member function is used to create a new instance of a group.
- Public Member Functions inherited from CXTPCalendarViewDay
CXTPCalendarViewDay (const CXTPCalendarView *pView)
Default object constructor.
virtual | ~CXTPCalendarViewDay ()
Default class destructor.
virtual int | GetChildHandlersCount () const
This member function is used to obtain the number of resource group views elements in the collection.
virtual CXTPCalendarWMHandler * | GetChildHandlerAt (int nIndex) const
Call this method to get a resource group view object at the specified numeric index.
virtual BOOL | HitTest (CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const
This member function is used to determine which view item, if any, is at the specified position index, and returns additional info in an XTP_CALENDAR_HITTESTINFO struct.
virtual BOOL | HitTestEx (CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const
This member function is used to determine which view item, if any, is at the specified position index, and returns additional info in the XTP_CALENDAR_HITTESTINFO template object.
virtual CXTPCalendarView * | GetView_ () const
Call this member function to obtain a pointer to a CXTPCalendarView object.
virtual CXTPCalendarControl * | GetCalendarControl () const
Call this member function to obtain a pointer to a CXTPCalendarControl object.
virtual CXTPCalendarResources * | GetResources () const
Call this member function to obtain a pointer to the associated Calendar Resources collection object.
virtual void | SetResources (CXTPCalendarResources *pResources)
This member function sets the new Resources collection for the view day.
virtual int | GetViewEventsCount () const
Call this member function to obtain the number of event views in the day view collection.
virtual CXTPCalendarViewEvent * | GetViewEvent_ (int nIndex) const
Call this member function to obtain a pointer to a CXTPCalendarViewEvent object associated with the event's index.
int | GetViewGroupsCount () const
Call this member function to obtain the number of resource group views in the view day collection.
CXTPCalendarViewGroup * | GetViewGroup_ (int nIndex) const
Call this member function to obtain a pointer to a CXTPCalendarViewGroup object associated with the group's index.
virtual COleDateTime | GetDayDate () const
Call this member function to obtain a day date value.
virtual COleDateTime | SetDayDate (COleDateTime dtDayDate)
Call this member function to obtain the day date value.
virtual BOOL | ContainsInvisibleEvents () const
Call this member function to determine if there are any invisible event views.
virtual BOOL | ContainsInvisibleEventsUpdate ()
Call this member function to determine if there are any invisible event views and to calculate the rectangle for the ExpandSign.
virtual BOOL | IsSelected () const
Call this member function to determine if the day view is selected.
virtual void | SetSelected ()
This member function is used to set the day view as selected.
virtual CRect | GetDayRect () const
Call this member function to obtain the day view rectangle coordinates.
virtual void | SetDayRect (CRect rcDay)
This member function is used to set the day view rectangle coordinates.
virtual BOOL | IsExpanded () const
Call this member function to determine if there are invisible event views because the boundaries of the day view are hidden and if the day view should display the expand sign.
virtual CRect | GetExpandSignRect () const
Call this member function to obtain the expand sign rectangle.
virtual UINT | SetTimer (UINT uTimeOut_ms)
This member function is used to create a timer event.
virtual void | KillTimer (UINT uTimerID)
This member function is used to destroy a timer event.
virtual int | GetDayIndex () const
This member function is used to obtain the index of the "this" pointer day in the Calendar Day View.
virtual BOOL | UserAction_OnExpandDay (XTPCalendarExpandDayButton eButton)
This member function is used to process the user action xtpCalendarUserAction_OnExpandDay.
- Public Member Functions inherited from CXTPCalendarWMHandler
CXTPCalendarWMHandler ()
Default object constructor.
virtual BOOL | OnLButtonDown (UINT nFlags, CPoint point)
This member function is used to process left mouse button down events.
virtual BOOL | OnLButtonUp (UINT nFlags, CPoint point)
This member function is used to process left mouse button up events.
virtual BOOL | OnLButtonDblClk (UINT nFlags, CPoint point)
This member function is used to process left mouse button double click events.
virtual void | OnChar (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process keyboard events.
virtual void | OnKeyDown (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process key-down keyboard events.
virtual void | OnKeyUp (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process key-up keyboard events.
virtual BOOL | OnSysKeyDown (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process key-up keyboard events.
virtual BOOL | OnTimer (UINT_PTR uTimerID)
The framework calls this member function after each interval specified in the SetTimer member function.
virtual BOOL | OnWndMsg (UINT message, WPARAM wParam, LPARAM lParam, LRESULT *pResult)
This method is called by framework after default message processing.
virtual void | OnPostAdjustLayout ()
This member function is used to perform additional adjustments in some kinds of views.
virtual void | OnBeforeDestroy ()
This member function is called by the framework before destroying the view.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

virtual void | OnMouseMove (UINT nFlags, CPoint point)
This member function is used to processes mouse movement events.
- Protected Member Functions inherited from CXTPCalendarViewDayT< CXTPCalendarDayView, CXTPCalendarDayViewGroup, XTP_CALENDAR_HITTESTINFO, CXTPCalendarDayViewDay >
- Protected Member Functions inherited from CXTPCalendarViewDay
virtual void | OnPrePopulateDay ()
This member function is used to allow some customization before show events.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Attributes inherited from CXTPCalendarViewDay
XTP_VIEW_DAY_LAYOUT | m_Layout
Layout data.
COleDateTime | m_dtDate
Day date.
CXTPCalendarResources * | m_pResources
Resources array.
CXTPCalendarPtrCollectionT< CXTPCalendarViewGroup > | m_arViewGroups
Storage for views of groups.
CXTPCalendarView * | m_pView
Storage for a owner view.

Detailed Description

This class represents a day view portion of the Calendar Day View.

It represents a specific view of the CalendarView's associated events data grouped by one day and provides basic functionality on this data using user input through keyboard and mouse.

 CXTPCalendarDayViewDay is based on the CXTPCalendarViewDayT template
 class. It inherits basic behavior from the CXTPCalendarViewDayT template
 class. Furthermore, CXTPCalendarDayViewDay overlaps and adds some
 new functionality to get its own behavior and appearance.
See also
CXTPCalendarViewDay
CXTPCalendarViewDayT

Constructor & Destructor Documentation

◆ CXTPCalendarDayViewDay()

CXTPCalendarDayViewDay | ( | CXTPCalendarDayView * | pDayView,
 |  | COleDateTime | dtDate )

Default object constructor.

Parameters
pDayView | Pointer to parent CXTPCalendarDayView object.
dtDate | A date for which the day view is created.

Constructs a CXTPCalendarDayViewDay object.

See also
~CXTPCalendarDayViewDay()

◆ ~CXTPCalendarDayViewDay()

virtual ~CXTPCalendarDayViewDay ( )
virtual

Default class destructor.

Handles member items deallocation.

Member Function Documentation

◆ AdjustLayout()

virtual void AdjustLayout | ( | CDC * | pDC,
 |  | const CRect & | rcDay )
 virtual

This member function is used to adjust the view's layout depending on the provided bounding rectangle and calls AdjustLayout() for all sub items.

Parameters
pDC | Pointer to a valid device context.
rcDay | A CRect object containing the dimensions of the bounding rectangle for the control.

AdjustLayout2 is called by calendar control instead of AdjustLayout when theme is set.

Reimplemented from CXTPCalendarViewDayT< CXTPCalendarDayView, CXTPCalendarDayViewGroup, XTP_CALENDAR_HITTESTINFO, CXTPCalendarDayViewDay >.

◆ AdjustLayout2()

virtual void AdjustLayout2 | ( | CDC * | pDC,
 |  | const CRect & | rcDay )
 virtual

This member function is used to adjust the view's layout depending on the provided bounding rectangle and calls AdjustLayout() for all sub items.

Parameters
pDC | Pointer to a valid device context.
rcDay | A CRect object containing the dimensions of the bounding rectangle for the control.

AdjustLayout2 is called by calendar control instead of AdjustLayout when theme is set.

◆ Draw()

virtual void Draw ( CDC * pDC )
virtual

This member function is used to draw the view content utilizing the specified device context.

Parameters
pDC Pointer to a valid device context.

Call AdjustLayout() before Draw().

See also
AdjustLayout(CRect rcDay)

Reimplemented from CXTPCalendarViewDay.

◆ DrawEvents()

virtual void DrawEvents ( CDC * pDC )
virtual

This member function is used to draw the view content utilizing the specified device context.

Parameters
pDC Pointer to a valid device context.

Call AdjustLayout() before Draw().

See also
AdjustLayout(CRect rcDay)

◆ DrawTopmostLayer()

virtual void DrawTopmostLayer ( CDC * pDC )
virtual

This member function is used to draw the view content utilizing the specified device context.

Parameters
pDC Pointer to a valid device context.

Call AdjustLayout() before Draw().

See also
AdjustLayout(CRect rcDay)

◆ FillHitTestEx()

virtual void FillHitTestEx ( XTP_CALENDAR_HITTESTINFO * pInfo ) const
virtual

This member function is used to fill an XTP_CALENDAR_HITTESTINFO structure.

Parameters
pInfo A pointer to an XTP_CALENDAR_HITTESTINFO structure.

Call this member function to gather hit test information from the day view.

See also
XTP_CALENDAR_HITTESTINFO

Implements CXTPCalendarViewDayT< CXTPCalendarDayView, CXTPCalendarDayViewGroup, XTP_CALENDAR_HITTESTINFO, CXTPCalendarDayViewDay >.

◆ GetCaption()

virtual CString GetCaption ( ) const
virtual

This member function is used to obtain a single day's view caption.

Returns
A CString object that contains the day's view caption.

◆ OnMouseMove()

virtual void OnMouseMove | ( | UINT | nFlags,
 |  | CPoint | point )
 protectedvirtual

This member function is used to processes mouse movement events.

Parameters
nFlags | A UINT that is used to indicate whether various virtual keys are down.
point | A CPoint that specifies the x- and y- coordinates of the cursor. These coordinates are always relative to the upper-left corner of the window.

This method is called by the CalendarControl when the user moves the mouse cursor or stylus.

Reimplemented from CXTPCalendarWMHandler.

◆ Populate()

virtual void Populate ( COleDateTime dtDayDate )
virtual

This member function is used to populate the view with data for all items contained in the view.

Parameters
dtDayDate A COleDateTime object that contains the day's date.

Reimplemented from CXTPCalendarViewDay.

The documentation for this class was generated from the following file:
  • XTPCalendarDayViewDay.h


Toolkit Pro: CXTPCalendarDayViewEvent Class Reference

Public Types | Public Member Functions | Public Attributes | Protected Member Functions | List of all members
CXTPCalendarDayViewEvent Class Reference

This class represents an event view portion of the CalendarDayViewDay. More...

Inheritance diagram for CXTPCalendarDayViewEvent:
[legend]

Public Types

typedef CXTPCalendarViewEventT< CXTPCalendarDayViewGroup > TBase

Public Member Functions

CXTPCalendarDayViewEvent (CXTPCalendarEvent *pEvent, CXTPCalendarDayViewGroup *pViewGroup)
Default object constructor.
virtual | ~CXTPCalendarDayViewEvent ()
Default class destructor.
virtual void | AdjustLayout (CDC *pDC, const CRect &rcEventMax, int nEventPlaceNumber)
This member function is used to adjust the view's layout depending on the provided rectangle and then calls AdjustLayout() for all sub-items.
virtual void | AdjustLayout2 (CDC *pDC, const CRect &rcEventMax, int nEventPlaceNumber)
This member function is used to adjust the view's layout depending on the provided rectangle and then calls AdjustLayout() for all sub-items.
virtual void | OnPostAdjustLayout ()
This member function is used to perform additional adjustments in some kinds of views.
virtual void | Draw (CDC *pDC)
This member function is used to draw the view content using the specified device context.
virtual BOOL | HitTestEx (CPoint point, XTP_CALENDAR_HITTESTINFO *pInfo) const
This member function is used to fill an XTP_CALENDAR_HITTESTINFO structure.
virtual BOOL | IsMultidayEvent () const
Call this member function to determine if an event is "Multi Day".
virtual BOOL | IsVisible () const
This member function is used to determine if the event is visible.
virtual BOOL | IsVisibleEx (BOOL bCheckTop, BOOL bCheckBottom, BOOL bTopAndBottom) const
This member function is used to obtain the value of the visibility flag.
virtual CXTPCalendarViewEvent * | StartEditSubject ()
This member function is used to create and show the subject editor.
CRect | GetEventsRect () const
This member function is used to obtain the event's bounding rectangle.
int | GetEventPlacePos () const
This member function is used to obtain the event's view position identifier.
int | GetEventPlaceCount () const
This member function is used to obtain the count of the event view positions.
void | SetEventPlacePos (int nPlace)
This member function is used to set the event view place identifier.
void | SetEventPlaceCount (int nPlaceCount)
This member function is used to set the event view places count.
BOOL | IsHideEventTime () const
This member function is used to determine if the event time should not be displayed.
CRect | GetTimeframeRect () const
This member function is used to obtain timeframe's bounding rectangle.
virtual void | AdjustSubjectEditor ()
This member function is used to perform adjustments of the subject editor area.
virtual void | AdjustSubjectEditorEx (BOOL bUpdateView)
This member function is used to perform adjustments of the subject editor area.
int | GetSlotNumber () const
This member function returns the slot number of event in all day/ multiday events.
void | SetSlotNumber (int nSlotNumber)
This member function set the slot number of event in all day/ multiday events.
- Public Member Functions inherited from CXTPCalendarViewEventT< CXTPCalendarDayViewGroup >
CXTPCalendarViewEventT (CXTPCalendarEvent *pEvent, CXTPCalendarDayViewGroup *pViewGroup)
Default object constructor.
virtual | ~CXTPCalendarViewEventT ()
Default class destructor.
virtual CXTPCalendarViewGroup * | GetViewGroup_ () const
This member function is used to obtain a base CXTPCalendarViewGroup* pointer to a corresponding DayView object.
CXTPCalendarDayViewGroup * | GetViewGroup () const
This member function is used to obtain a pointer to a DayView object.
- Public Member Functions inherited from CXTPCalendarViewEvent
CXTPCalendarViewEvent (CXTPCalendarEvent *pEvent, CXTPCalendarViewGroup *pViewGroup)
Default object constructor.
virtual | ~CXTPCalendarViewEvent ()
Default class destructor.
virtual BOOL | HitTest (CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const
This member function is used to determine which view item, if any, is at the specified position index, and returns additional info in the XTP_CALENDAR_HITTESTINFO struct.
virtual CXTPCalendarEvent * | GetEvent () const
Call this member function to obtain the corresponding read only event object without increasing the object's reference counter.
virtual CXTPCalendarControl * | GetCalendarControl () const
Call this member function to obtain a pointer to the calendar control object.
virtual BOOL | IsSelected () const
Call this member function to determine if the given event view is selected.
virtual void | SetSelected (BOOL bSet=TRUE)
This member function is used to set the day view as select or unselected.
virtual CString | GetEditingSubjectFromEditor () const
Call this member function to obtain an edited subject.
virtual CString | EndEditSubject ()
This member function is used to end the editing project, delete the subject editor, and to obtain the edited text.
virtual void | ShowToolTip ()
This member function is used to show a ToolTip rectangle.
virtual void | HideToolTip ()
This member function is used to hide the ToolTip rectangle.
virtual BOOL | IsEditingSubject () const
Call this member function to determine if the event's subject is currently being edited.
virtual CRect | GetSubjectEditorRect () const
This member function is used to obtain the subject editor rectangle coordinates.
virtual CWnd * | GetSubjectEditor () const
This member function is used to obtain the event's subject editor window.
virtual BOOL | IsShowingToolTip ()
Call this member function to determine if the event's tooltip is visible.
virtual CString | FormatEventTime (COleDateTime dtTime) const
This member function is used to format the event's time as a string with a predefined format.
virtual CRect | GetFirstClockRect () const
This member function is used to obtain the rectangle coordinates used for drawing a clock in the beginning of a multi day event.
virtual CRect | GetLastClockRect () const
This member function is used to obtain the rectangle coordinates used for drawing a clock in the end of a multi-day event.
virtual CRect | GetTextRect () const
This member function is used to obtain the rectangle coordinates used for displaying the event's subject.
virtual CRect | GetStartTimeRect () const
This member function is used to obtain the rectangle coordinates used for displaying a clock to show the start event time for single day events.
virtual CRect | GetEndTimeRect () const
This member function is used to obtain the rectangle coordinates for displaying a clock to show the end event time for single day events.
virtual CRect | GetViewEventRect () const
This member function is used to obtain the rectangle coordinates for the event's rectangle.
virtual CRect | GetViewEventRectMax () const
This member function is used to obtain the rectangle coordinates for the event's maximum rectangle dimensions.
virtual CRect | GetReminderGlyphRect () const
This member function is used to obtain the rectangle coordinates for displaying the remainder icon.
virtual CRect | GetRecurrenceGlyphRect () const
This member function is used to obtain the rectangle coordinates used for displaying the recurrence icon.
virtual CRect | GetMeetingGlyphRect () const
This member function obtains the rectangle coordinates for displaying the meeting icon.
virtual CRect | GetPrivateGlyphRect () const
This member function is used to obtain the rectangle coordinates used for displaying the private icon.
virtual BOOL | IsMultyDayTextAlign () const
This member function is used to obtain the flag to determine if multi-day text align mode is on.
virtual int | GetMultiDayEventFlags () const
This member function is used to obtain the multi-day event state flags.
virtual void | SetMultiDayEvent_MasterSlave (BOOL bMaster, CXTPCalendarViewEvent *pMasterView)
This member function is used to set the multi-day event Master/Slave state.
virtual void | AddMultiDayEvent_Slave (CXTPCalendarViewEvent *pSlaveView, int nMasterEventPlace)
This member function is used to add a Slave event view to the Master event view.
virtual void | SetTextOutOfBorders (BOOL bOutOfBorders)
This member function is used to set a flag to determine if the text size exceeds the event view bounds.
virtual BOOL | IsTextOutOfBorders () const
This member function is used to determine if the text size exceeds the event view bounds.
virtual int | GetEventPlaceNumber () const
This member function is used to obtain the place number of the event view.
virtual int | GetEventTimelinePlaceNumber () const
This member function is used to obtain the place number of the event in Timeline view.
CRect | GetEventRect () const
This member function is used to obtain the event view's bounding rectangle.
virtual CString | GetItemTextSubject () const
Call this function to get the item subject.
virtual CString | GetItemTextLocation () const
Call this function to get the item location.
virtual CString | GetItemTextBody () const
Call this function to get the item body.
virtual CString | GetItemTextStartTime () const
Call this function to get the item start time.
virtual CString | GetItemTextEndTime () const
Call this function to get the item end time.
virtual CString | GetItemText (DWORD dwItemFlag, LPCTSTR pcszDefaultText=NULL) const
Call this function to get the item text.
virtual CString | GetMarkupText () const
This member function is used to obtain markup template text.
virtual CXTPMarkupUIElement * | GetMarkupUIElement ()
This member function is used to get a stored CXTPMarkupUIElement object.
virtual int | CalcIconsRect (CRect rc)
This member function is used to adjust the icons rectangle used to draw the event view icons.
virtual BOOL | OnLButtonDown (UINT nFlags, CPoint point)
This member function is used to process left mouse button down events.
virtual BOOL | OnLButtonUp (UINT nFlags, CPoint point)
This member function is used to process left mouse button up events.
virtual BOOL | OnLButtonDblClk (UINT nFlags, CPoint point)
This member function is used to process left mouse button double click events.
virtual void | OnMouseMove (UINT nFlags, CPoint point)
This member function is used to process mouse movement events.
virtual BOOL | OnWndMsg (UINT message, WPARAM wParam, LPARAM lParam, LRESULT *pResult)
This method is called by framework after default message processing.
virtual UINT | SetTimer (UINT uTimeOut_ms)
This member function is used to create a timer event.
virtual void | KillTimer (UINT uTimerID)
This member function is used to destroy a timer event.
virtual BOOL | OnTimer (UINT_PTR uTimerID)
The framework calls this member function after each interval specified in the SetTimer member function.
virtual UINT | GetShowToolTipTimeOut () const
This member function is used to obtain the timeout value for displaying a tooltip.
virtual void | OnBeforeDestroy ()
Called by the framework before the destroy() function is called.
- Public Member Functions inherited from CXTPCalendarWMHandler
CXTPCalendarWMHandler ()
Default object constructor.
virtual int | GetChildHandlersCount () const
This member function is used to obtain the number of CXTPCalendarWMHandler elements in the descendant handlers collection.
virtual CXTPCalendarWMHandler * | GetChildHandlerAt (int nIndex) const
Call this method to get a handler object at the specified numeric index.
virtual void | OnChar (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process keyboard events.
virtual void | OnKeyDown (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process key-down keyboard events.
virtual void | OnKeyUp (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process key-up keyboard events.
virtual BOOL | OnSysKeyDown (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process key-up keyboard events.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Public Attributes

CRect | m_rcTimeframe
Rectangle area to display times.
BOOL | m_bHideEventTime
Flag determines if event time should not be displayed.
BOOL | m_bShowArrow
TRUE if event in AllDay area should have arrow to indicate more events follows.
- Public Attributes inherited from CXTPCalendarViewEvent
CRect | m_rcEvent
Event view rectangle.
CRect | m_rcEventMax
Event view rectangle margins.
CRect | m_rcText
Rectangle to display event text in event view.
CSize | m_szText
Sizes of displayed text.
CRect | m_rcFirstClock
Rectangle to draw clock in the beginning of the first day of multi-day event.
CRect | m_rcLastClock
Rectangle to draw clock at the end of the last day of multi-day event.
CRect | m_rcStartTime
Rectangle to display start time day event view.
CRect | m_rcEndTime
Rectangle to display end time event view.
int | m_nMultiDayEventFlags
Multi-day event flags packed into integer by bitwise operations.
CRect | m_rcReminderGlyph
Rectangle to draw reminder glyph event view.
CRect | m_rcRecurrenceGlyph
Rectangle to draw recurrence glyph event view.
CRect | m_rcMeetingGlyph
Rectangle to draw meeting glyph event view.
CRect | m_rcPrivateGlyph
Rectangle to draw private glyph event view.
CRect | m_rcSubjectEditor
Subject editor rectangle.
CRect | m_rcToolTip
Tool tip rectangle.
CXTPMarkupUIElement * | m_pUIElement
Store pointer to CXTPMarkupUIElement object.
CString | m_strUIElementText
Store last markup text for which m_pUIElement object was updated.

Protected Member Functions

virtual CFont * | GetSubjectEditorFont () const
This member function is used to obtain the editor window font.
virtual DWORD | GetSubjectEditorStyles () const
This member function is used to obtain the styles of the editor window.
virtual void | ChangeEventPlace (int nNewPlace)
This function is used to change the event place number.
- Protected Member Functions inherited from CXTPCalendarViewEvent
virtual void | AdjustMultidayEvent (CRect rcEventMax, int nEventPlaceNumber)
This member function is used to adjust a multi-day view's layout depending on the provided rectangle coordinates.
virtual CString | GetToolText ()
This member function is used to obtain tooltip text for the event view.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCalendarViewEvent
static void AFX_CDECL | _MoveRectY (int nYbasePrev, int nYbaseNew, CRect &rRC)
This member function is used to move the rectangle vertically.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Attributes inherited from CXTPCalendarViewEvent
CXTPCalendarEvent * m_ptrEvent
Pointer to the displayed event object.
BOOL | m_bSelected
Event view selected flag.
CXTPCalendarViewEvent * m_pMasterView
Pointer to Master event view object.
int | m_nEventPlaceNumber
Event view place number (sequential identifier).
int | m_nEventTimelinePlaceNumber
Event view place number in Timeline view.
UINT | m_nTimerID_ShowToolTip
Identifier of timer event to show tooltip with delay.
CXTPCalendarViewEventSubjectEditor * | m_pSubjectEditor
Pointer to the subject editor.
BOOL | m_bMultyDayTextAlign
Flag indicates special text alignment for a multi-day event.
BOOL | m_bTextOutOfBorders
Flag indicates text out of event borders.

Detailed Description

This class represents an event view portion of the CalendarDayViewDay.

This class is used to represent a specific view of the event associated data according to various view types and display settings. This class also provides basic functionality on the data by using user input through the keyboard and mouse.

 CXTPCalendarDayViewEvent is based on the CXTPCalendarDayEventT template
 class. It inherits basic behavior from the CXTPCalendarDayEventT template
 class. Furthermore, CXTPCalendarDayViewEvent overlaps and adds some
 new functionality to get its own behavior and appearance.
See also
CXTPCalendarViewEvent
CXTPCalendarViewEventT

Member Typedef Documentation

◆ TBase

CXTPCalendarViewEventT<CXTPCalendarDayViewGroup> TBase

Base class type definition.

Constructor & Destructor Documentation

◆ CXTPCalendarDayViewEvent()

CXTPCalendarDayViewEvent | ( | CXTPCalendarEvent * | pEvent,
 |  | CXTPCalendarDayViewGroup * | pViewGroup )

Default object constructor.

Parameters
pEvent | Pointer to CXTPCalendarEvent.
pViewGroup | Pointer to CXTPCalendarDayViewGroup object.
See also
~CXTPCalendarDayViewDay()

Member Function Documentation

◆ AdjustLayout()

virtual void AdjustLayout | ( | CDC * | pDC,
 |  | const CRect & | rcEventMax,
 |  | int | nEventPlaceNumber )
 virtual

This member function is used to adjust the view's layout depending on the provided rectangle and then calls AdjustLayout() for all sub-items.

Parameters
pDC | Pointer to a valid device context.
rcEventMax | A CRect object that contains the rectangle dimensions for drawing the view.
nEventPlaceNumber | An int that is used as a sequential place number.

Call Populate(COleDateTime dtDayDate) prior to adjust layout. AdjustLayout2 is called by calendar control instead of AdjustLayout when theme is set.

Reimplemented from CXTPCalendarViewEvent.

◆ AdjustLayout2()

virtual void AdjustLayout2 | ( | CDC * | pDC,
 |  | const CRect & | rcEventMax,
 |  | int | nEventPlaceNumber )
 virtual

This member function is used to adjust the view's layout depending on the provided rectangle and then calls AdjustLayout() for all sub-items.

Parameters
pDC | Pointer to a valid device context.
rcEventMax | A CRect object that contains the rectangle dimensions for drawing the view.
nEventPlaceNumber | An int that is used as a sequential place number.

Call Populate(COleDateTime dtDayDate) prior to adjust layout. AdjustLayout2 is called by calendar control instead of AdjustLayout when theme is set.

Implements CXTPCalendarViewEvent.

◆ AdjustSubjectEditor()

virtual void AdjustSubjectEditor ( )
virtual

This member function is used to perform adjustments of the subject editor area.

Call this member function to perform adjustment of subject editor rectangle.

Reimplemented from CXTPCalendarViewEvent.

◆ AdjustSubjectEditorEx()

virtual void AdjustSubjectEditorEx ( BOOL bUpdateView )
virtual

This member function is used to perform adjustments of the subject editor area.

Inputs bUpdateView - A BOOL. TRUE if event view update is required.

Parameters
bUpdateView TRUE if event view update is required, otherwise FALSE.

Call this member function to perform adjustment of subject editor rectangle.

◆ ChangeEventPlace()

virtual void ChangeEventPlace ( int nNewPlace )
protectedvirtual

This function is used to change the event place number.

Parameters
nNewPlace New event place number.

Reimplemented from CXTPCalendarViewEvent.

◆ Draw()

virtual void Draw ( CDC * pDC )
virtual

This member function is used to draw the view content using the specified device context.

Parameters
pDC Pointer to a valid device context.

Call AdjustLayout() before calling Draw().

See also
AdjustLayout(CRect rcDay)

Implements CXTPCalendarViewEvent.

◆ GetEventPlaceCount()

AFX_INLINE int GetEventPlaceCount ( ) const

This member function is used to obtain the count of the event view positions.

Call this member function to count the number of event view positions.

Returns
An int that contains the number of view positions.

◆ GetEventPlacePos()

AFX_INLINE int GetEventPlacePos ( ) const

This member function is used to obtain the event's view position identifier.

The position identifier is a sequential number used to identify the event views.

Returns
An int that contains the value of the position identifier.

◆ GetEventsRect()

CRect GetEventsRect ( ) const

This member function is used to obtain the event's bounding rectangle.

Call this member function to get the event's bounding rectangle coordinates.

Returns
A CRect object containing the bounding rectangle coordinates.

◆ GetSlotNumber()

AFX_INLINE int GetSlotNumber ( ) const

This member function returns the slot number of event in all day/ multiday events.

Returns
An integer specifying the slot number.

◆ GetSubjectEditorFont()

virtual CFont * GetSubjectEditorFont ( ) const
protectedvirtual

This member function is used to obtain the editor window font.

Returns
Pointer to a CFont object that contains the editor window font.

Reimplemented from CXTPCalendarViewEvent.

◆ GetSubjectEditorStyles()

AFX_INLINE DWORD GetSubjectEditorStyles ( ) const
protectedvirtual

This member function is used to obtain the styles of the editor window.

Returns
A DWORD that contains the value of the window styles.

Reimplemented from CXTPCalendarViewEvent.

◆ GetTimeframeRect()

AFX_INLINE CRect GetTimeframeRect ( ) const

This member function is used to obtain timeframe's bounding rectangle.

Call this member function to get timeframe's bounding rectangle coordinates.

Returns
A CRect object containing the bounding rectangle coordinates.

◆ HitTestEx()

virtual BOOL HitTestEx | ( | CPoint | point,
 |  | XTP_CALENDAR_HITTESTINFO * | pInfo ) const
 virtual

This member function is used to fill an XTP_CALENDAR_HITTESTINFO structure.

Parameters
point | A CPoint object that contains the point to test.
pInfo | A pointer to an XTP_CALENDAR_HITTESTINFO structure.
Returns
TRUE if the test is successful, FALSE otherwise.

Call this member function to gather hit test information from the day view.

See also
XTP_CALENDAR_HITTESTINFO

Implements CXTPCalendarViewEvent.

◆ IsHideEventTime()

AFX_INLINE BOOL IsHideEventTime ( ) const

This member function is used to determine if the event time should not be displayed.

Returns
A BOOL that contains the HideExentTime value. TRUE - if event time should not be displayed. Otherwise FALSE.

◆ IsMultidayEvent()

virtual BOOL IsMultidayEvent ( ) const
virtual

Call this member function to determine if an event is "Multi Day".

Returns
TRUE if events is "Multi Day". FALSE otherwise.

Reimplemented from CXTPCalendarViewEvent.

◆ IsVisible()

virtual BOOL IsVisible ( ) const
virtual

This member function is used to determine if the event is visible.

This function calls IsVisibleEx(TRUE, TRUE, FALSE);

Returns
A BOOL that contains the value of the visibility of the event. TRUE if the event is visible. FALSE otherwise.

Implements CXTPCalendarViewEvent.

◆ IsVisibleEx()

virtual BOOL IsVisibleEx | ( | BOOL | bCheckTop,
 |  | BOOL | bCheckBottom,
 |  | BOOL | bTopAndBottom ) const
 virtual

This member function is used to obtain the value of the visibility flag.

Parameters
bCheckTop | A BOOL that indicates if the top bound visibility is checked.
bCheckBottom | A BOOL that indicates if the bottom bound visibility is checked.
bTopAndBottom | A BOOL that indicates if the top and bottom bound visibility is checked.

Checks visibility of boundaries.

Returns
A BOOL that contains the value of the visibility flag. TRUE if boundaries are visible. FALSE otherwise.

◆ OnPostAdjustLayout()

virtual void OnPostAdjustLayout ( )
virtual

This member function is used to perform additional adjustments in some kinds of views.

Call this member function to perform additional adjustments after all adjustment activities are completed.

Reimplemented from CXTPCalendarViewEvent.

◆ SetEventPlaceCount()

AFX_INLINE void SetEventPlaceCount ( int nPlaceCount )

This member function is used to set the event view places count.

Parameters
nPlaceCount An int that contains the number of view places.

Call this member function to set event view places count.

◆ SetEventPlacePos()

AFX_INLINE void SetEventPlacePos ( int nPlace )

This member function is used to set the event view place identifier.

Parameters
nPlace An int that contains the place identifier value.

Call this member function to set the event view place identifier.

◆ SetSlotNumber()

AFX_INLINE void SetSlotNumber ( int nSlotNumber )

This member function set the slot number of event in all day/ multiday events.

Parameters
nSlotNumber An integer specifying the slot number.

◆ StartEditSubject()

virtual CXTPCalendarViewEvent * StartEditSubject ( )
virtual

This member function is used to create and show the subject editor.

A subject is created only for the master event if the event is multi-day. If this member function is called for a slave event, then the editing process is passed to the master event.\

Returns
A pointer to an CXTPCalendarViewEvent object for which the editor is created.

Reimplemented from CXTPCalendarViewEvent.

The documentation for this class was generated from the following file:
  • XTPCalendarDayViewEvent.h


Toolkit Pro: CXTPCalendarDayViewGroup Class Reference

Public Types | Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPCalendarDayViewGroup Class Reference

This class represents a single resource view portion of the Calendar Day View. More...

Inheritance diagram for CXTPCalendarDayViewGroup:
[legend]

Public Types

typedef CXTPCalendarViewGroupT< CXTPCalendarDayViewDay, CXTPCalendarDayViewEvent, CXTPCalendarDayViewGroup > | TBase
Base class type definition.
- Public Types inherited from CXTPCalendarViewGroupT< CXTPCalendarDayViewDay, CXTPCalendarDayViewEvent, CXTPCalendarDayViewGroup >
typedef CXTPCalendarDayViewDay | TViewDay

Public Member Functions

CXTPCalendarDayViewGroup (CXTPCalendarDayViewDay *pViewDay)
Default object constructor.
virtual | ~CXTPCalendarDayViewGroup ()
Default class destructor.
virtual void | AdjustLayout (CDC *pDC, const CRect &rcGroup)
This member function is used to adjust the view's layout depending on the provided bounding rectangle and calls AdjustLayout() for all sub items.
virtual void | AdjustLayout2 (CDC *pDC, const CRect &rcGroup)
This member function is used to adjust the view's layout depending on the provided bounding rectangle and calls AdjustLayout() for all sub items.
virtual void | Draw (CDC *pDC)
This member function is used to draw the view content utilizing the specified device context.
virtual BOOL | HitTestEx (CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const
This member function is used to fill the XTP_CALENDAR_HITTESTINFO structure.
virtual int | GetBusyStatus (COleDateTime dtTime) const
This member function is used to obtain the busy status for the specified time.
virtual CRect | GetAllDayEventsRect () const
This member function is used to obtain the drawing area of all day events.
virtual void | AdjustDayEvents (CDC *pDC)
Adjusts layout of day events items.
int | GetRowHeight () const
This member function is used to obtain the height of a single cell.
int | GetVisibleRowCount () const
This member function is used to obtain the number of rows visible in the view.
int | GetTopRow () const
This member function is used to obtain the number of the top visible row in the view.
int | GetRowCount () const
This member function is used to obtain the total number of rows in the view.
COleDateTime | GetCellDateTime (int nCell) const
This member function is used to obtain the beginning time value for the specified cell.
int | GetDateTimeCell (const COleDateTime &dtTime, BOOL bForEndTime) const
This member function is used to calculate the cell number for the specified time value.
CRect | GetCellRect (int nCell) const
This member function is used to obtain the rect for the specified cell.
virtual CRect | GetTooltipRect (const CPoint &ptHit, const XTP_CALENDAR_HITTESTINFO &hitInfo) const
Call this member function to obtain the bounding rectangle of the tooltip space (currently this is only "click to add new appointment").
BOOL | IsWorkDateTime (const COleDateTime &dtDateTime) const
This member function is used to check if the specified date time is work or non-work.
BOOL | IsGroupHeaderVisible () const
This member function is used to determine if the group header is visible or not.
void | SetExpandUp ()
Call this member function to set the ExpandUp sign visible.
void | SetExpandDown ()
Call this member function to set the ExpandDown sign visible.
BOOL | IsExpandUp () const
Call this member function to determine if the ExpandUp sign is visible.
BOOL | IsExpandDown () const
Call this member function to determine if the ExpandDown sign is visible.
CRect | GetAllDayEventsScrollButtonRect (XTP_DAY_VIEW_GROUP_LAYOUT::XTPEnumHotItem nButton) const
Calculates the rectangle to fill with a scroll button icon for day view when there are too many alldayevents to show without scrolling.
BOOL | NeedScrollAllDayEvents () const
Call this member function to determine if all day events scroll icons will be shown in day view.
BOOL | IsShowAllDayEventsUpScrollButton () const
Call this member function to determine if the up scroll button for the alldayevents area will be shown.
BOOL | IsShowAllDayEventsDownScrollButton () const
Call this member function to determine if the down scroll button for the alldayevents area will be shown.
void | SetShowAllDayEventsUpScrollButton (BOOL bShow)
Call this member function to set the visibility for the up scroll button in the all day events area.
void | SetShowAllDayEventsDownScrollButton (BOOL bShow)
Call this member function to set the visibility for the down scroll button in the all day events area.
int | GetFirstVisibleAllDayEvent () const
Call this member function to determine the index of the first visible all day event in group view.
int | GetLastVisibleAllDayEvent () const
Call this member function to determine the index of the last visible all day event in group view.
BOOL | IsUpAllDayEventsScrollButtonVisible () const
Call this member function to determine if the up scroll icon in the all day events area is visible-highlighted.
BOOL | IsDownAllDayEventsScrollButtonVisible () const
Call this member function to determine if the down scroll icon in the all day events area is visible-highlighted.
void | FindMinMaxGroupDayEvents (CXTPCalendarDayViewEvent *&rpMin, CXTPCalendarDayViewEvent *&rpMax) const
Call this member function to find the top and bottom events in a group.
BOOL | UserAction_OnScrollDay (XTPCalendarScrollDayButton eButton)
This member function is used to process the user action xtpCalendarUserAction_OnScrollDay.
BOOL | UserAction_OnScrollAllDayEvents (XTP_DAY_VIEW_GROUP_LAYOUT::XTPEnumHotItem eHotBtn)
This member function is used to process the user actions xtpCalendarUserAction_OnScrollAllDayEvensUp and xtpCalendarUserAction_OnScrollAllDayEvensDown.
BOOL | ScrollIcon_ScrollAllDayEventsUp ()
This member function processes click on up scroll icon in the all day events area.
BOOL | ScrollIcon_ScrollAllDayEventsDown ()
This member function processes click on down scroll icon in the all day events area.
int | GetEventsCountInAllDayArea () const
This member function returns events count in the all day area of the group.
virtual BOOL | HitTestAllDayEventsScrollIcons (CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const
This member function is used to fill an XTP_CALENDAR_HITTESTINFO structure.
- Public Member Functions inherited from CXTPCalendarViewGroupT< CXTPCalendarDayViewDay, CXTPCalendarDayViewEvent, CXTPCalendarDayViewGroup >
CXTPCalendarViewGroupT (CXTPCalendarDayViewDay *pViewDay)
Default object constructor.
virtual | ~CXTPCalendarViewGroupT ()
Default class destructor.
CXTPCalendarDayViewDay * | GetViewDay () const
This member function is used to obtain the owner view object.
virtual CXTPCalendarDayViewEvent * | GetViewEvent (int nIndex) const
Call this member function to obtain a pointer to the _TViewEvent object that corresponds to the event's index.
- Public Member Functions inherited from CXTPCalendarViewGroup
CXTPCalendarViewGroup (CXTPCalendarViewDay *pViewDay)
Default object constructor.
virtual | ~CXTPCalendarViewGroup ()
Default class destructor.
virtual CXTPCalendarResources * | GetResources () const
Obtain a pointer to a collection of Calendar Resources.
virtual CXTPCalendarData * | GetDataProvider () const
Returns data provider for this view group.
virtual void | AddResource (CXTPCalendarResource *pResource, BOOL bWithAddRef)
Adds a new Resource object into the collection of resources for this Group View.
virtual void | SetResources (CXTPCalendarResources *pResources)
Assigns a new Resources collection to this Group View.
virtual UINT | GetScheduleID () const
Returns default Schedule ID - the first existing one.
virtual void | Populate (COleDateTime dtDayDate)
This member function is used to populate the view with data for all items contained in the view.
virtual BOOL | HitTest (CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const
This member function is used to determine which view item, if any, is at the specified position index, and returns additional info in an XTP_CALENDAR_HITTESTINFO struct.
virtual CRect | GetRect () const
Call this member function to obtain the group's rectangle area.
virtual CRect | GetHeaderRect () const
Call this member function to obtain the group's header rectangle area.
int | GetViewEventsCount () const
Call this member function to obtain the number of event views in the day view collection.
CXTPCalendarViewEvent * | GetViewEvent_ (int nIndex) const
Call this member function to obtain a pointer to a CXTPCalendarViewEvent object associated with the event's index.
CXTPCalendarViewDay * | GetViewDay_ () const
Call this member function to obtain a pointer to the containing CXTPCalendarViewDay object.
virtual int | GetGroupIndex () const
This member function is used to obtain the index of the "this" pointer Group View in the Calendar Day View.
virtual CString | GetCaption () const
This member function is used to obtain a group's view caption.
virtual int | GetChildHandlersCount () const
This member function is used to obtain the number of event views elements in this Group View.
virtual CXTPCalendarWMHandler * | GetChildHandlerAt (int nIndex) const
Call this method to get an event view object at the specified numeric index.
virtual CXTPCalendarViewEvent * | GetViewEventByEvent_ (CXTPCalendarEvent *pEvent) const
Call this member function to obtain a pointer to a CXTPCalendarViewEvent object that is identified by the corresponding event object.
virtual CXTPCalendarViewEvent * | GetViewEventByPlace_ (int nEventPlace) const
Call this member function to obtain an event view object identified by its event place number.
virtual CXTPCalendarControl * | GetCalendarControl () const
Call this member function to obtain a pointer to the calendar control object.
virtual void | ExchangeEventPlace (CXTPCalendarViewEvent *pViewEvent, int nNewPlace)
This member function is used to exchange event view positions.
- Public Member Functions inherited from CXTPCalendarWMHandler
CXTPCalendarWMHandler ()
Default object constructor.
virtual BOOL | OnLButtonUp (UINT nFlags, CPoint point)
This member function is used to process left mouse button up events.
virtual void | OnChar (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process keyboard events.
virtual void | OnKeyDown (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process key-down keyboard events.
virtual void | OnKeyUp (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process key-up keyboard events.
virtual BOOL | OnSysKeyDown (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process key-up keyboard events.
virtual BOOL | OnTimer (UINT_PTR uTimerID)
The framework calls this member function after each interval specified in the SetTimer member function.
virtual BOOL | OnWndMsg (UINT message, WPARAM wParam, LPARAM lParam, LRESULT *pResult)
This method is called by framework after default message processing.
virtual void | OnPostAdjustLayout ()
This member function is used to perform additional adjustments in some kinds of views.
virtual void | OnBeforeDestroy ()
This member function is called by the framework before destroying the view.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

virtual BOOL | OnLButtonDown (UINT nFlags, CPoint point)
This member function is used to process left mouse button events.
virtual BOOL | OnLButtonDblClk (UINT nFlags, CPoint point)
This member function is used to process left mouse button events.
BOOL | OnAllDaysAreaClick (UINT nFlags, CPoint point)
This member function is used by OnLButtonDblClk() and OnLButtonDown() to filter scroll icons presses in the all days events area.
virtual void | OnMouseMove (UINT nFlags, CPoint point)
This member function is used to process mouse movement events.
virtual CXTPCalendarViewPart * | GetCellViewPart (const COleDateTime &dtDateTime) const
This member function is used to obtain the view part of the specified cell.
virtual void | GetCellEvents (int nCell, TViewEventsCollection *pViewEvents, COleDateTime &rdtMinEventTime, COleDateTime &rdtMaxEventTime)
This member function is used to obtain the events collection which belongs to the specified cell.
virtual BOOL | HitTestDateTime (XTP_CALENDAR_HITTESTINFO *pHitTest) const
This member function is used to fill an XTP_CALENDAR_HITTESTINFO structure.
virtual void | FillHitTestEx (XTP_CALENDAR_HITTESTINFO *pHitTest) const
This member function is used to fill an XTP_CALENDAR_HITTESTINFO structure.
- Protected Member Functions inherited from CXTPCalendarViewGroupT< CXTPCalendarDayViewDay, CXTPCalendarDayViewEvent, CXTPCalendarDayViewGroup >
- Protected Member Functions inherited from CXTPCalendarViewGroup
virtual UINT | SetTimer (UINT uTimeOut_ms)
This member function is used to create a timer event.
virtual void | KillTimer (UINT uTimerID)
This member function is used to destroy a timer event.
virtual void | OnPrePopulate (CXTPCalendarEvents *pEvents)
This member function is used to allow some customization before show events.

Protected Attributes

XTP_DAY_VIEW_GROUP_LAYOUT | m_LayoutX
Store group view layout.
BOOL | m_bExpandUP
Store is ExpandUP sign visible.
BOOL | m_bExpandDOWN
Store is ExpandDOWN sign visible.
- Protected Attributes inherited from CXTPCalendarViewGroup
XTP_VIEW_GROUP_LAYOUT | m_Layout
This group view client coordinates.
CXTPCalendarPtrCollectionT< CXTPCalendarViewEvent > | m_arEvents
Storage for events views.
CXTPCalendarResources * | m_pResources
An associated resource object.
CXTPCalendarViewDay * | m_pViewDay
Parent day view.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

This class represents a single resource view portion of the Calendar Day View.

It represents a specific view of the CalendarView's associated events data grouped by one day and one resource and provides basic functionality on this data using user input through keyboard and mouse.

See also
CXTPCalendarDayViewDay

Constructor & Destructor Documentation

◆ CXTPCalendarDayViewGroup()

CXTPCalendarDayViewGroup ( CXTPCalendarDayViewDay * pViewDay )

Default object constructor.

Construct CXTPCalendarDayViewGroup object.

Parameters
pViewDay Pointer to CXTPCalendarDayViewDay object.
See also
~CXTPCalendarDayViewGroup()

◆ ~CXTPCalendarDayViewGroup()

virtual ~CXTPCalendarDayViewGroup ( )
virtual

Default class destructor.

Handles member items deallocation.

Member Function Documentation

◆ AdjustDayEvents()

virtual void AdjustDayEvents ( CDC * pDC )
virtual

Adjusts layout of day events items.

Parameters
pDC Pointer to a valid device context.

◆ AdjustLayout()

virtual void AdjustLayout | ( | CDC * | pDC,
 |  | const CRect & | rcGroup )
 virtual

This member function is used to adjust the view's layout depending on the provided bounding rectangle and calls AdjustLayout() for all sub items.

Parameters
pDC | Pointer to a valid device context.
rcGroup | A CRect object containing the dimensions of the bounding rectangle for the DayViewGroup area.

AdjustLayout2 is called by calendar control instead of AdjustLayout when theme is set.

Reimplemented from CXTPCalendarViewGroup.

◆ AdjustLayout2()

virtual void AdjustLayout2 | ( | CDC * | pDC,
 |  | const CRect & | rcGroup )
 virtual

This member function is used to adjust the view's layout depending on the provided bounding rectangle and calls AdjustLayout() for all sub items.

Parameters
pDC | Pointer to a valid device context.
rcGroup | A CRect object containing the dimensions of the bounding rectangle for the DayViewGroup area.

AdjustLayout2 is called by calendar control instead of AdjustLayout when theme is set.

Reimplemented from CXTPCalendarViewGroup.

◆ Draw()

virtual void Draw ( CDC * pDC )
virtual

This member function is used to draw the view content utilizing the specified device context.

Parameters
pDC Pointer to a valid device context.

Call AdjustLayout() before Draw()

See also
AdjustLayout

Reimplemented from CXTPCalendarViewGroup.

◆ FillHitTestEx()

virtual void FillHitTestEx ( XTP_CALENDAR_HITTESTINFO * pHitTest ) const
protectedvirtual

This member function is used to fill an XTP_CALENDAR_HITTESTINFO structure.

Parameters
pHitTest A pointer to an XTP_CALENDAR_HITTESTINFO structure.

Call this member function to gather hit test information from the day view.

See also
XTP_CALENDAR_HITTESTINFO

Implements CXTPCalendarViewGroupT< CXTPCalendarDayViewDay, CXTPCalendarDayViewEvent, CXTPCalendarDayViewGroup >.

◆ FindMinMaxGroupDayEvents()

void FindMinMaxGroupDayEvents | ( | CXTPCalendarDayViewEvent *& | rpMin,
 |  | CXTPCalendarDayViewEvent *& | rpMax ) const

Call this member function to find the top and bottom events in a group.

Parameters
rpMin | [out] Reference to store pointer to a top event.
rpMax | [out] Reference to store pointer to a bottom event.

◆ GetAllDayEventsRect()

AFX_INLINE CRect GetAllDayEventsRect ( ) const
virtual

This member function is used to obtain the drawing area of all day events.

Returns
A CRect object containing the coordinates of the all day events drawing area.

◆ GetAllDayEventsScrollButtonRect()

CRect GetAllDayEventsScrollButtonRect ( XTP_DAY_VIEW_GROUP_LAYOUT::XTPEnumHotItem nButton ) const

Calculates the rectangle to fill with a scroll button icon for day view when there are too many alldayevents to show without scrolling.

Can be useful to implement visualization themes.

Parameters
nButton xtpHotAllDayEventsScrollUp or xtpHotAllDayEventsScrollDown buttons ids.
Returns
CRect for scroll icon to show.

◆ GetBusyStatus()

virtual int GetBusyStatus ( COleDateTime dtTime ) const
virtual

This member function is used to obtain the busy status for the specified time.

Parameters
dtTime A COleDateTime object that contains the time value for which to check the busy status.
Returns
XTPCalendarEventBusyStatus value.

◆ GetCellDateTime()

COleDateTime GetCellDateTime ( int nCell ) const

This member function is used to obtain the beginning time value for the specified cell.

Parameters
nCell An int that contains the cell index.
Returns
A COleDateTime object that contains the beginning time value for the specified cell.

◆ GetCellEvents()

virtual void GetCellEvents | ( | int | nCell,
 |  | TViewEventsCollection * | pViewEvents,
 |  | COleDateTime & | rdtMinEventTime,
 |  | COleDateTime & | rdtMaxEventTime )
 protectedvirtual

This member function is used to obtain the events collection which belongs to the specified cell.

Parameters
nCell | An int that contains the cell number for the events collection.
pViewEvents | Pointer to an event views collection. This pointer is used populate the views collection with data.
rdtMinEventTime | A COleDateTime object used to contain the minimum time for events in the returned collection.
rdtMaxEventTime | A COleDateTime object used to contain the maximum time for events in the returned collection.
See also
TViewEventsCollection

◆ GetCellRect()

CRect GetCellRect ( int nCell ) const

This member function is used to obtain the rect for the specified cell.

Parameters
nCell An int that contains the cell index.
Returns
A CRect object that contains the cell rect.

◆ GetCellViewPart()

virtual CXTPCalendarViewPart * GetCellViewPart ( const COleDateTime & dtDateTime ) const
protectedvirtual

This member function is used to obtain the view part of the specified cell.

Parameters
dtDateTime A COleDateTime object that contains the cell's date to return the view part for.
Returns
A pointer to a CXTPCalendarViewPart object. The CXTPCalendarViewPart object contains the Day View Working Cell part if dtDateTime is the same as the Work Date Time. Otherwise the CXTPCalendarViewPart object contains the Non-Work Cell part.
See also
CXTPCalendarViewPart overview

◆ GetDateTimeCell()

int GetDateTimeCell | ( | const COleDateTime & | dtTime,
 |  | BOOL | bForEndTime ) const

This member function is used to calculate the cell number for the specified time value.

Parameters
dtTime | A COleDateTime object that contains the time value to search for.
bForEndTime | A BOOL object that determines if a split line between cells is needed. The split line is used to indicate if the date to search for belongs to the end of the previous cell or to the beginning of the next cell.
Returns
Call this member function to retrieve the cell that contains the specified time value.

◆ GetEventsCountInAllDayArea()

int GetEventsCountInAllDayArea ( ) const

This member function returns events count in the all day area of the group.

Returns
The number of events in all data area.

◆ GetFirstVisibleAllDayEvent()

int GetFirstVisibleAllDayEvent ( ) const

Call this member function to determine the index of the first visible all day event in group view.

Returns
Index of the view event object.

◆ GetLastVisibleAllDayEvent()

int GetLastVisibleAllDayEvent ( ) const

Call this member function to determine the index of the last visible all day event in group view.

Returns
Index of the view event object.

◆ GetRowCount()

int GetRowCount ( ) const

This member function is used to obtain the total number of rows in the view.

Returns
An int that contains the total number of rows in the view.

◆ GetRowHeight()

int GetRowHeight ( ) const

This member function is used to obtain the height of a single cell.

Returns
An int that contains the height, in pixels, of a single cell.

◆ GetTooltipRect()

virtual CRect GetTooltipRect | ( | const CPoint & | ptHit,
 |  | const XTP_CALENDAR_HITTESTINFO & | hitInfo ) const
 virtual

Call this member function to obtain the bounding rectangle of the tooltip space (currently this is only "click to add new appointment").

Tooltip rectangle is calculated basing on the current mouse position.

Parameters
ptHit | CPoint& of mouse position.
hitInfo | XTP_CALENDAR_HITTESTINFO.
Returns
A CRect object with relative coordinates of the tooltip.

This member function returns a rectangle calculated as a single cell rect which user currently holds a mouse on.

Reimplemented from CXTPCalendarViewGroup.

◆ GetTopRow()

int GetTopRow ( ) const

This member function is used to obtain the number of the top visible row in the view.

Returns
An int that contains the number of the top visible row in the view.

◆ GetVisibleRowCount()

int GetVisibleRowCount ( ) const

This member function is used to obtain the number of rows visible in the view.

Returns
An int that contains the number of rows visible in the view.

◆ HitTestAllDayEventsScrollIcons()

virtual BOOL HitTestAllDayEventsScrollIcons | ( | CPoint | pt,
 |  | XTP_CALENDAR_HITTESTINFO * | pHitTest ) const
 virtual

This member function is used to fill an XTP_CALENDAR_HITTESTINFO structure.

Parameters
pHitTest | A pointer to an XTP_CALENDAR_HITTESTINFO structure.
pt | A CPoint object that contains the point to test.

Call this member function to gather hit test information from the day view. It uses pHitTest->pt point for gathering information.

Returns
A BOOL. TRUE if pHitTest->pt point is on a valid part of the Day View. FALSE otherwise.
See also
XTP_CALENDAR_HITTESTINFO

◆ HitTestDateTime()

virtual BOOL HitTestDateTime ( XTP_CALENDAR_HITTESTINFO * pHitTest ) const
protectedvirtual

This member function is used to fill an XTP_CALENDAR_HITTESTINFO structure.

Parameters
pHitTest A pointer to an XTP_CALENDAR_HITTESTINFO structure.

Call this member function to gather hit test information from the day view. It uses pHitTest->pt point for gathering information.

Returns
A BOOL. TRUE if pHitTest->pt point is on a valid part of the Day View. FALSE otherwise.
See also
XTP_CALENDAR_HITTESTINFO

◆ HitTestEx()

virtual BOOL HitTestEx | ( | CPoint | pt,
 |  | XTP_CALENDAR_HITTESTINFO * | pHitTest ) const
 virtual

This member function is used to fill the XTP_CALENDAR_HITTESTINFO structure.

Parameters
pt | A CPoint object that contains the point to test.
pHitTest | Pointer to an XTP_CALENDAR_HITTESTINFO struct.
Returns
TRUE if the test is succesful, FALSE else.

Call this member function to gather hit test information from the day view.

See also
XTP_CALENDAR_HITTESTINFO

Reimplemented from CXTPCalendarViewGroup.

◆ IsDownAllDayEventsScrollButtonVisible()

BOOL IsDownAllDayEventsScrollButtonVisible ( ) const

Call this member function to determine if the down scroll icon in the all day events area is visible-highlighted.

Returns
TRUE if visible, FALSE otherwise.

◆ IsExpandDown()

AFX_INLINE BOOL IsExpandDown ( ) const

Call this member function to determine if the ExpandDown sign is visible.

Can be useful to implement visualization themes.

Returns
TRUE if the ExpandDown sign is visible, FALSE otherwise.

◆ IsExpandUp()

AFX_INLINE BOOL IsExpandUp ( ) const

Call this member function to determine if the ExpandUp sign is visible.

Can be useful to implement visualization themes.

Returns
TRUE if the ExpandUp sign is visible, FALSE otherwise.

◆ IsGroupHeaderVisible()

AFX_INLINE BOOL IsGroupHeaderVisible ( ) const

This member function is used to determine if the group header is visible or not.

Returns
TRUE if the group header is visible, FALSE otherwise.

◆ IsShowAllDayEventsDownScrollButton()

BOOL IsShowAllDayEventsDownScrollButton ( ) const

Call this member function to determine if the down scroll button for the alldayevents area will be shown.

Returns
TRUE if the down scroll button for the alldayevents area will be shown.

◆ IsShowAllDayEventsUpScrollButton()

BOOL IsShowAllDayEventsUpScrollButton ( ) const

Call this member function to determine if the up scroll button for the alldayevents area will be shown.

Returns
TRUE if the up scroll button for the alldayevents area will be shown.

◆ IsUpAllDayEventsScrollButtonVisible()

BOOL IsUpAllDayEventsScrollButtonVisible ( ) const

Call this member function to determine if the up scroll icon in the all day events area is visible-highlighted.

Returns
TRUE if visible, FALSE otherwise.

◆ IsWorkDateTime()

BOOL IsWorkDateTime ( const COleDateTime & dtDateTime ) const

This member function is used to check if the specified date time is work or non-work.

Parameters
dtDateTime A COleDateTime object that contains the date time value to check.
Returns
TRUE if the specified date time is work, FALSE otherwise.

◆ NeedScrollAllDayEvents()

BOOL NeedScrollAllDayEvents ( ) const

Call this member function to determine if all day events scroll icons will be shown in day view.

Returns
TRUE if all day events scroll icons will be shown in day view.

◆ OnAllDaysAreaClick()

BOOL OnAllDaysAreaClick | ( | UINT | nFlags,
 |  | CPoint | point )
 protected

This member function is used by OnLButtonDblClk() and OnLButtonDown() to filter scroll icons presses in the all days events area.

Parameters
nFlags | A UINT that is used to indicate whether various virtual keys are down.
point | A CPoint that specifies the x- and y- coordinates of the cursor. These coordinates are always relative to the upper-left corner of the window.
Returns
TRUE if the operation is successful, FALSE otherwise.

◆ OnLButtonDblClk()

virtual BOOL OnLButtonDblClk | ( | UINT | nFlags,
 |  | CPoint | point )
 protectedvirtual

This member function is used to process left mouse button events.

Parameters
nFlags | A UINT that is used to indicate whether various virtual keys are down.
point | A CPoint that specifies the x- and y- coordinates of the cursor. These coordinates are always relative to the upper-left corner of the window.
Returns
TRUE if the operation is successful, FALSE otherwise.

This method is called by the CalendarControl when the user presses the left mouse button.

Reimplemented from CXTPCalendarWMHandler.

◆ OnLButtonDown()

virtual BOOL OnLButtonDown | ( | UINT | nFlags,
 |  | CPoint | point )
 protectedvirtual

This member function is used to process left mouse button events.

Parameters
nFlags | A UINT that is used to indicate whether various virtual keys are down.
point | A CPoint that specifies the x- and y- coordinates of the cursor. These coordinates are always relative to the upper-left corner of the window.
Returns
TRUE if the operation is successful, FALSE otherwise.

This method is called by the CalendarControl when the user presses the left mouse button.

Reimplemented from CXTPCalendarWMHandler.

◆ OnMouseMove()

virtual void OnMouseMove | ( | UINT | nFlags,
 |  | CPoint | point )
 protectedvirtual

This member function is used to process mouse movement events.

Parameters
nFlags | A UINT that is used to indicate whether various virtual keys are down.
point | A CPoint that specifies the x- and y- coordinates of the cursor. These coordinates are always relative to the upper-left corner of the window.

This method is called by the CalendarControl when the user moves the mouse cursor or stylus.

Reimplemented from CXTPCalendarWMHandler.

◆ ScrollIcon_ScrollAllDayEventsDown()

BOOL ScrollIcon_ScrollAllDayEventsDown ( )

This member function processes click on down scroll icon in the all day events area.

Returns
TRUE if the action was handled by default, FALSE if the user canceled default handler.
See also
XTP_NC_CALENDAR_USERACTION

◆ ScrollIcon_ScrollAllDayEventsUp()

BOOL ScrollIcon_ScrollAllDayEventsUp ( )

This member function processes click on up scroll icon in the all day events area.

Returns
TRUE if the action was handled by default, FALSE if the user canceled default handler.
See also
XTP_NC_CALENDAR_USERACTION

◆ SetExpandDown()

AFX_INLINE void SetExpandDown ( )

Call this member function to set the ExpandDown sign visible.

Can be useful to implement visualization themes.

◆ SetExpandUp()

AFX_INLINE void SetExpandUp ( )

Call this member function to set the ExpandUp sign visible.

Can be useful to implement visualization themes.

◆ SetShowAllDayEventsDownScrollButton()

void SetShowAllDayEventsDownScrollButton ( BOOL bShow )

Call this member function to set the visibility for the down scroll button in the all day events area.

Parameters
bShow TRUE to turn on visibility for up scroll button, FALSE to hide

◆ SetShowAllDayEventsUpScrollButton()

void SetShowAllDayEventsUpScrollButton ( BOOL bShow )

Call this member function to set the visibility for the up scroll button in the all day events area.

Parameters
bShow TRUE to turn on visibility for up scroll button, FALSE to hide

◆ UserAction_OnScrollAllDayEvents()

BOOL UserAction_OnScrollAllDayEvents ( XTP_DAY_VIEW_GROUP_LAYOUT::XTPEnumHotItem eHotBtn )

This member function is used to process the user actions xtpCalendarUserAction_OnScrollAllDayEvensUp and xtpCalendarUserAction_OnScrollAllDayEvensDown.

Parameters
eHotBtn - [in] a button from which this action comes.

Implementation sends an XTP_NC_CALENDAR_USERACTION notification.

Returns
TRUE if action was handled by user and default processing must be skipped, FALSE otherwise.
See also
XTP_NC_CALENDAR_USERACTION

◆ UserAction_OnScrollDay()

BOOL UserAction_OnScrollDay ( XTPCalendarScrollDayButton eButton )

This member function is used to process the user action xtpCalendarUserAction_OnScrollDay.

Parameters
eButton - [in] a button from which this action comes.

Implementation sends an XTP_NC_CALENDAR_USERACTION notification.

Returns
TRUE if the action was handled by the user and default processing must be skipped, FALSE otherwise.
See also
XTP_NC_CALENDAR_USERACTION
The documentation for this class was generated from the following file:
  • XTPCalendarDayViewDay.h


Toolkit Pro: CXTPCalendarDayViewTimeScale Class Reference

Public Member Functions | Public Attributes | Protected Attributes | List of all members
CXTPCalendarDayViewTimeScale Class Reference

This class implements a specific view portion of the Calendar Day view - called Time scale. More...

Inheritance diagram for CXTPCalendarDayViewTimeScale:
[legend]

Public Member Functions

CXTPCalendarDayViewTimeScale (CXTPCalendarDayView *pDayView, BOOL bVisible=TRUE, BOOL bDrawNowLine=TRUE)
Default object constructor.
virtual | ~CXTPCalendarDayViewTimeScale ()
Default class destructor.
int | CalcWidth (CDC *pDC)
This member function is used to obtain the time scale width in pixels.
int | GetWidth () const
This member function is used to get the time scale width.
void | Draw (CDC *pDC)
This member function is used to perform all drawing logic of the time scale.
virtual void | AdjustLayout (CDC *pDC)
This function is used to adjust the time scale layout.
virtual CString | Format (COleDateTime dtTime, BOOL bTopCell, CString *pHour=NULL, CString *pMin=NULL)
This member function is used to format the time scale text.
virtual BOOL | IsDrawNowLine () const
This member function is used to determine if the Current Time Mark can be drawn for this time scale.
COleDateTimeSpan | GetScaleInterval () const
This member function obtains the time scale cell interval.
void | SetCaption (LPCTSTR strCaption)
This member function is used to set the text caption for the time scale.
CString | GetCaption () const
This member function is used to obtain the text caption for the time scale.
void | SetTimeshift (int nMinutes)
This member function is used to set the new time shift in hours for the time scale.
int | GetTimeshift () const
This member function is used to obtain the time shift in hours for the time scale.
void | SetVisible (BOOL bVisible)
This member function is used to set the time scale visibility mode (TRUE - visible, FALSE - invisible).
BOOL | GetVisible () const
This member function is used to obtain the current time scale visibility mode.
BOOL | HitTestDateTime (XTP_CALENDAR_HITTESTINFO *pHitTest) const
This member function is used to fill an XTP_CALENDAR_HITTESTINFO structure.
CXTPCalendarDayView * | GetDayView () const
This member function obtains the time scale owner view.
void | MoveTo (int nXPos)
This member function shifts the time scale object.
void | SetCustomTimeFormat (BOOL bAmPm, BOOL bLeadingZero=TRUE, const CString &separator=_T(":"), const CString &am=_T("am"), const CString &pm=_T("pm"))
Sets the custom time format for the day view timescale.
void | ResetCustomTimeFormat ()
Resets the timescale time format to the current locale format.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Public Attributes

BOOL m_bDrawNowLine
Specifies whether we should draw the "Now" line on the time scale.

Protected Attributes

XTP_TIMESCALE_LAYOUT | m_Layout
Store time scale layout.
CXTPCalendarDayView * | m_pDayView
Pointer to the parent Calendar Day view object.
CString | m_strCaption
Caption under time scale.
int | m_nTimeshift_min
Time zone time shift in minutes.
BOOL | m_bVisible
Show this timescale or not.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

This class implements a specific view portion of the Calendar Day view - called Time scale.

The Day view contains two time scales defining those intervals at the left of the view, which is represented by the CXTPCalendarDayViewTimeScale class. One time scale is the main and is visible by default. The second time scale is the alternative and could be enabled programmatically. Time scale interval could be changed using the SetScaleInterval member function.

See also
CXTPCalendarDayViewDay

Constructor & Destructor Documentation

◆ CXTPCalendarDayViewTimeScale()

CXTPCalendarDayViewTimeScale | ( | CXTPCalendarDayView * | pDayView,
 |  | BOOL | bVisible = TRUE,
 |  | BOOL | bDrawNowLine = TRUE )

Default object constructor.

Parameters
pDayView | Pointer to associated CXTPCalendarDayView object.
bVisible | Specifies initial visibility mode for the time scale.
bDrawNowLine | If TRUE current time mark is drawn.
See also
~CXTPCalendarDayViewTimeScale()

◆ ~CXTPCalendarDayViewTimeScale()

virtual ~CXTPCalendarDayViewTimeScale ( )
virtual

Default class destructor.

Handles member items deallocation.

See also
CXTPCalendarDayViewTimeScale

Member Function Documentation

◆ AdjustLayout()

virtual void AdjustLayout ( CDC * pDC )
virtual

This function is used to adjust the time scale layout.

Parameters
pDC Pointer to a valid device context.

◆ CalcWidth()

int CalcWidth ( CDC * pDC )

This member function is used to obtain the time scale width in pixels.

Parameters
pDC Pointer to a valid device context.
Returns
An int that contains the time scale width in pixels.

◆ Draw()

void Draw ( CDC * pDC )

This member function is used to perform all drawing logic of the time scale.

Parameters
pDC A pointer to a valid device context.

◆ Format()

virtual CString Format | ( | COleDateTime | dtTime,
 |  | BOOL | bTopCell,
 |  | CString * | pHour = NULL,
 |  | CString * | pMin = NULL )
 virtual

This member function is used to format the time scale text.

Parameters
dtTime | A COleDateTime object that contains the time to format to text.
bTopCell | If TRUE and minutes value is 0 the minutes value is replaced on am/pm value. This valid only for AM/PM 12-hour time format. If this parameter is FALSE, the minutes value 0 is replaced only if the hour value is 12.
pHour | A pointer to the CString object to write the hour part of the value.
pMin | A pointer to the CString object to write the minutes part of the value.
Returns
A string containing formatted text.

◆ GetCaption()

AFX_INLINE CString GetCaption ( ) const

This member function is used to obtain the text caption for the time scale.

Use GetCaption() to get the current time scale caption.

Returns
A CString object that contains the text caption for the time scale.
See also
SetCaption

◆ GetDayView()

AFX_INLINE CXTPCalendarDayView * GetDayView ( ) const

This member function obtains the time scale owner view.

Use this member function to get the day view object which owns the time scale.

Returns
A pointer to CXTPCalendarDayView object.

◆ GetScaleInterval()

COleDateTimeSpan GetScaleInterval ( ) const

This member function obtains the time scale cell interval.

Use this member function to retrieve the current time scale cell interval.

Returns
A COleDateTimeSpan object that contains the cell interval for the time scale.

◆ GetTimeshift()

AFX_INLINE int GetTimeshift ( ) const

This member function is used to obtain the time shift in hours for the time scale.

Use this member function to retrieve the current time shift for the time scale.

Returns
An int that contains the time shift for the time scale in minutes.
See also
SetTimeshift

◆ GetVisible()

AFX_INLINE BOOL GetVisible ( ) const

This member function is used to obtain the current time scale visibility mode.

Returns
A BOOL that contains the time scale visibility scale value. TRUE if the time scale is visible. FALSE otherwise.
See also
SetVisible(BOOL)

◆ GetWidth()

AFX_INLINE int GetWidth ( ) const

This member function is used to get the time scale width.

Returns
An int that contains the time scale width in pixels.

◆ HitTestDateTime()

BOOL HitTestDateTime ( XTP_CALENDAR_HITTESTINFO * pHitTest ) const

This member function is used to fill an XTP_CALENDAR_HITTESTINFO structure.

Parameters
pHitTest A pointer to an XTP_CALENDAR_HITTESTINFO structure.
Returns
TRUE if the test is succesful, FALSE otherwise.

Call this member function to gather hit test information from the day view. It uses pHitTest->pt point for gathering hit test information.

See also
XTP_CALENDAR_HITTESTINFO

◆ IsDrawNowLine()

AFX_INLINE BOOL IsDrawNowLine ( ) const
virtual

This member function is used to determine if the Current Time Mark can be drawn for this time scale.

By default it returns TRUE for primary time scale and FALSE for secondary.

Returns
Returns TRUE if Current Time Mark may be drawn for this time scale, FALSE otherwise.

◆ MoveTo()

void MoveTo ( int nXPos )

This member function shifts the time scale object.

Parameters
nXPos Offset from base position.

Used by horizontal scrolling to place the timescale always visible on the left border.

◆ SetCaption()

AFX_INLINE void SetCaption ( LPCTSTR strCaption )

This member function is used to set the text caption for the time scale.

Parameters
strCaption A CString object that contains the new text caption for the time scale.

Use this function to set the current time scale caption.

See also
GetCaption

◆ SetCustomTimeFormat()

void SetCustomTimeFormat | ( | BOOL | bAmPm,
 |  | BOOL | bLeadingZero = TRUE,
 |  | const CString & | separator = _T(":"),
 |  | const CString & | am = _T("am"),
 |  | const CString & | pm = _T("pm") )

Sets the custom time format for the day view timescale.

Parameters
bAmPm | selects 24hrs or 12hrs time format TRUE - 12hrs format FALSE - 24 hrs format
bLeadingZero | Set to TRUE to fill 1-digit time with leading zero
separator | hours-mins separator
am | string to fill for "am"
pm | string to fill for "pm"

This function overrides the locale time format for calendar control. To reset the time format back to locale, call ResetCustomTimeFormat()

◆ SetTimeshift()

AFX_INLINE void SetTimeshift ( int nMinutes )

This member function is used to set the new time shift in hours for the time scale.

Parameters
nMinutes An int that contains the new time shift for the time scale in minutes.

Use this member function to set the new time shift for the time scale.

See also
GetTimeshift

◆ SetVisible()

AFX_INLINE void SetVisible ( BOOL bVisible )

This member function is used to set the time scale visibility mode (TRUE - visible, FALSE - invisible).

Parameters
bVisible A BOOL that contains the new time scale visible state. TRUE - Visible. FALSE - Invisible.
See also
GetVisible()
The documentation for this class was generated from the following file:
  • XTPCalendarDayViewTimeScale.h


Toolkit Pro: CXTPCalendarEvent Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPCalendarEvent Class Reference

This class represents the data of a single Event used in the Calendar control. More...

Inheritance diagram for CXTPCalendarEvent:
[legend]

Public Member Functions

CXTPCalendarEvent (CXTPCalendarData *pDataProvider)
Default object constructor.
virtual | ~CXTPCalendarEvent ()
Default class destructor.
virtual DWORD | GetEventID () const
This member function is used to obtain a unique event ID.
virtual void | SetEventID (DWORD dwEventID)
This member function is used to set a new ID value for an event.
virtual UINT | GetScheduleID () const
This member function is used to obtain a schedule ID of the event.
virtual void | SetScheduleID (UINT uScheduleID)
This member function is used to set a new schedule ID for the event.
virtual CString | GetScheduleSet () const
This member function is used to obtain a multiple schedules set for the event.
virtual void | SetScheduleSet (CString ScheduleSet)
This member function is used to set a new multiple schedules set for the event.
virtual CString | GetSubject () const
This member function is used to obtain the event subject.
virtual void | SetSubject (LPCTSTR pcszSubject)
This member function is used to set the subject text for the event.
virtual CString | GetLocation () const
Call this member function to obtain the event location text.
virtual void | SetLocation (LPCTSTR pcszLocation)
This member function is used to set the location text for the event.
virtual CXTPCalendarEventLabel * | GetLabel () const
Call this member function to obtain the event label.
virtual int | GetLabelID () const
Call this member function to get the event label ID.
virtual void | SetLabelID (int nLabelID)
This member function is used to set the new label ID for the event.
virtual BOOL | IsAllDayEvent () const
Call this member function to determine if an event is an "All Day" event.
virtual void | SetAllDayEvent (BOOL bSet=TRUE)
This member function is used to set the "All Day" flag for an event.
BOOL | IsEventVisible () const
Call this member function to determine if an event is Visible.
void | SetEventVisible (BOOL bSet)
This member function is used to set the EventVisible flag for an event.
virtual COleDateTime | GetStartTime () const
Call this member function to get the event's start DateTime.
virtual void | SetStartTime (COleDateTime dtStart)
This member function is used to set the new start date and time for the event.
virtual COleDateTime | GetEndTime () const
Call this member function to get the event's end DateTime.
virtual void | SetEndTime (COleDateTime dtEnd)
This member function is used to set the new end date and time for the event.
virtual int | GetDurationMinutes () const
Call this member function to get an event duration in minutes.
virtual COleDateTimeSpan | GetDuration () const
Call this member function to get an event duration as an COleDateTimeSpan object.
virtual void | SetDuration (COleDateTimeSpan spDuration, BOOL bKeepStart=TRUE)
This member function is used to set the new duration for the event.
virtual void | MoveEvent (COleDateTime dtNewStartTime)
This member function is used to move the start date event to the provided DateTime.
virtual int | GetEventPeriodDays () const
Call this member function to get an event duration as a number of days.
virtual BOOL | IsReminder () const
Call this member function to determine if a reminder is set for event.
virtual void | SetReminder (BOOL bReminder)
Call this member function to setup a reminder for this event.
virtual BOOL | IsSound () const
Call this member function to determine if a sound file is configured for the event reminder.
virtual int | GetReminderMinutesBeforeStart () const
Call this member function to determine the number of minutes before the start of an event.
virtual void | SetReminderMinutesBeforeStart (int nMinutes)
This member function is used to set the number of minutes before the start of an event.
virtual CString | GetReminderSoundFile () const
Call this member function to determine a full path to the sound file assigned to the event reminder.
virtual void | SetReminderSoundFile (LPCTSTR pcszFile)
This member function is used to set the sound file for the event reminder.
virtual CString | GetBody () const
Call this member function to obtain the body text for the event.
virtual void | SetBody (LPCTSTR pcszDesc)
This member function is used to set the body text for the event.
virtual int | GetBusyStatus () const
Call this member function to get a busy status value for the event.
virtual void | SetBusyStatus (int Status)
This member function is used to set the busy status value for the event.
virtual int | GetImportance () const
Call this member function to get an importance level for an event.
virtual void | SetImportance (int nImportance)
This member function is used to set the importance level for the event.
virtual COleDateTime | GetCreationTime () const
Call this member function to get the creation time for an event.
virtual void | SetCreationTime (COleDateTime dtTime)
This member function is used to set the creation time for an event.
virtual COleDateTime | GetLastModificationTime () const
Call this member function to get the last modification time for an event.
virtual void | SetLastModificationTime (COleDateTime dtTime)
This member function is used to set the modification time for the event.
virtual XTPCalendarEventRecurrenceState | GetRecurrenceState () const
Call this member function to get a recurrence state for the event.
virtual BOOL | MakeEventAsRecurrence ()
Call this member function to change the recurrence state for the event.
virtual BOOL | UpdateRecurrence (CXTPCalendarRecurrencePattern *pRPattern)
This member function is used to set the recurrence pattern for the event.
virtual BOOL | RemoveRecurrence ()
This member function removes the recurrence pattern for the event.
virtual DWORD | GetRecurrencePatternID () const
Call this member function to get the recurrence pattern ID.
virtual CXTPCalendarRecurrencePatternPtr | GetRecurrencePattern () const
Call this member function to get the event's recurrence pattern object.
virtual BOOL | MakeAsRException (DWORD dwPatternID=XTP_CALENDAR_UNKNOWN_RECURRENCE_PATTERN_ID)
Call this member function to set the event's recurrence pattern as an exception occurrence.
virtual BOOL | IsRExceptionDeleted () const
Call this member function to determine if an exception occurrence is marked as deleted.
virtual void | SetRExceptionDeleted (BOOL bDeleted=TRUE)
Call this member function to mark an exception occurrence as deleted/undeleted.
virtual BOOL | Update (CXTPCalendarEvent *pNewData)
Call this member function to update the event's data.
virtual CXTPCalendarEventPtr | CloneEvent ()
Call this member function to obtain a pointer to the read-write interface of the event.
virtual BOOL | CloneEventTo (CXTPCalendarEvent *pEventDest)
Clones current event properties into a provided object instance.
virtual CXTPCalendarEventPtr | CloneForOccurrence (COleDateTime dtStart, COleDateTime dtEnd, DWORD dwNewEventID=XTP_CALENDAR_UNKNOWN_EVENT_ID)
This member function is used to build an occurrence event by duplicating the master event.
BOOL | IsEqualIDs (const CXTPCalendarEvent *pEvent) const
Call this member function to compare IDs of different events.
BOOL | IsEqualStartEnd (const CXTPCalendarEvent *pEvent) const
Call this member function to compare start dates of different events.
virtual void | SetMeeting (BOOL bMeeting=TRUE)
This member function is used to set the state for the meeting flag.
virtual BOOL | IsMeeting () const
This member function is used to obtain the value of the Meeting state flag.
virtual void | SetPrivate (BOOL bPrivate=TRUE)
This member function is used to set the state for the private flag.
virtual BOOL | IsPrivate () const
This member function is used to obtain the value of the private state flag.
CXTPCalendarCustomIconIDs * | GetCustomIcons () const
This member function is used to obtain collection of custom icons IDs associated with event object.
CXTPCalendarEventCategoryIDs * | GetCategories () const
This member function is used to obtain a collection of Event category IDs associated with an event object.
int | GetCategoriesCount () const
This member function is used to obtain the count of Event category IDs associated with an event object.
virtual void | DoPropExchange (CXTPPropExchange *pPX)
Call this member function to Store/Load an event using the specified data object.
CXTPCalendarCustomProperties * | GetCustomProperties () const
Get custom (named, user-defined) properties collection.
virtual COleDateTime | GetRException_StartTimeOrig () const
This member function is used to obtain the original start time of an exception event.
virtual void | SetRException_StartTimeOrig (COleDateTime dtStartOrig)
This member function is used to set the original start time of an exception event.
virtual COleDateTime | GetRException_EndTimeOrig () const
This member function is used to obtain the original end time of an exception event.
virtual void | SetRException_EndTimeOrig (COleDateTime dtEndOrig)
This member function is used to set the original end time of an exception event.
virtual void | SetRecurrencePatternID (DWORD dwRecurrencePatternID)
This member function is used to set the new ID value for the event recurrence pattern.
CXTPCalendarData * | GetDataProvider () const
Returns event data provider.
CXTPCalendarRecurrencePattern * | GetRPatternRef () const
This member function is used to obtain a pointer to the internally stored Recurrence Pattern object.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

virtual void | Clear ()
This member function is used to set all event properties to the empty or default state.
virtual BOOL | CalcStartEndDatesFromPattern ()
This member function is used to calculate the date-time values of the start and end dates for occurrences of recurrent events.
virtual BOOL | UpdateStartEndDatesFromPatternExceptions ()
This member function is used to change the date-time values of the start and end dates of the master event using exception occurrences of recurrent events.
virtual BOOL | SetRecurrenceState_Master (CXTPCalendarRecurrencePattern *pPattern)
This member function is used to assign a new RecurrencePattern to an event and set the Master flag.
virtual BOOL | SetRecurrenceState_ExceptionOccurrence (XTPCalendarEventRecurrenceState nState, DWORD dwNewPatternID=XTP_CALENDAR_UNKNOWN_RECURRENCE_PATTERN_ID)
This member function is used to set the exception recurrence.
virtual BOOL | SetRecurrenceState_NotRecurring ()
This function is used to reset the recurrence state for an event.
virtual void | ClearIntermediateData ()
Clear intermediate data members which where set when operations with recurrence properties where made.

Protected Attributes

CXTPCalendarData * | m_pDataProvider
Pointer to the owner data provider.
BOOL | m_bMeeting
Boolean flag that is used to indicate if an event is a meeting.
BOOL | m_bPrivate
Boolean flag that is used to indicate if an event is a private meeting.
DWORD | m_dwEventID
ID of this event object.
int | m_nLabelID
Label ID.
CString | m_strSubject
Subject value.
CString | m_strLocation
Location value.
UINT | m_uScheduleID
ID of the corresponding Schedule.
BOOL | m_bEventVisible
flag to display event on screen

BOOL | m_bAllDayEvent
Is this an all day event value.
COleDateTime | m_dtStartTime
Start event time value.
COleDateTime | m_dtEndTime
End event time value.
BOOL | m_bReminder
This flag value indicates is the Reminder enabled or not.
int | m_nReminderMinutesBeforeStart
Reminder time value.
CString | m_strReminderSoundFile
Reminder sound file path.
CString | m_strBody
Body value.
int | m_nBusyStatus
Event Busy Status value.
int | m_nImportance
Event Importance value.
XTPCalendarEventRecurrenceState | m_nRecurrenceState
Event Recurrence State.
COleDateTime | m_dtCreationTime
Creation event time value.
COleDateTime | m_dtLastModificationTime
Last Modification event time value.
CXTPCalendarRecurrencePatternPtr | m_ptrRPattern
Recurrence Pattern object for a master event only.
DWORD | m_dwRecurrencePatternID
Recurrence Pattern ID.
BOOL | m_bRExceptionDeleted
Is Recurrence Exception deleted.
COleDateTime | m_dtRException_StartTimeOrig
Original start time of Recurrence exception event.
COleDateTime | m_dtRException_EndTimeOrig
Original end time of Recurrence exception event.
DWORD | m_dwRecurrencePatternID_ToUse
Previously used pattern ID.
CXTPCalendarCustomProperties * | m_pCustomProperties
Custom properties collection object.
CXTPCalendarCustomIconIDs * | m_pCustomIconsIDs
An array to store custom icons id's assigned to event.
CXTPCalendarEventCategoryIDs * | m_pEventCategoryIDs
An array to store categories id's assigned to event.
CString | m_sMultipleSchedules
ScheduleSet string in form "|#1|...|#N|".

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

This class represents the data of a single Event used in the Calendar control.

Event can be recurring or non-recurring: see GetRecurrenceState() method and XTPCalendarEventRecurrenceState. If Event is recurring use GetRecurrencePattern() method to retrieve recurrence properties. Recurrence States (XTPCalendarEventRecurrenceState):

xtpCalendarRecurrenceMaster: Main event which is used for creating Occurrences. xtpCalendarRecurrenceOccurrence: Event is one Occurrence of the Recurrence series. xtpCalendarRecurrenceException: Event is Occurrence which properties differ than in the Recurrence pattern or this Occurrence is deleted (for example Start/End time or Location are different).

See also
CXTPCalendarRecurrencePattern overview,
CXTPCalendarEventLabels overview,
CXTPCalendarEventLabel overview,
XTPCalendarEventRecurrenceState

Constructor & Destructor Documentation

◆ CXTPCalendarEvent()

CXTPCalendarEvent ( CXTPCalendarData * pDataProvider )

Default object constructor.

Parameters
pDataProvider Pointer to CXTPCalendarData object.
See also
~CXTPCalendarEvent()

◆ ~CXTPCalendarEvent()

virtual ~CXTPCalendarEvent ( )
virtual

Default class destructor.

Handles member items deallocation. Decreases reference of stored objects: CXTPCalendarEventLabels and CXTPCalendarRecurrencePattern.

Member Function Documentation

◆ CalcStartEndDatesFromPattern()

virtual BOOL CalcStartEndDatesFromPattern ( )
protectedvirtual

This member function is used to calculate the date-time values of the start and end dates for occurrences of recurrent events.

Returns
TRUE if successful. FALSE otherwise.

◆ Clear()

virtual void Clear ( )
protectedvirtual

This member function is used to set all event properties to the empty or default state.

The same as after new object creation.

◆ ClearIntermediateData()

virtual void ClearIntermediateData ( )
protectedvirtual

Clear intermediate data members which where set when operations with recurrence properties where made.

This method is automatically called by the date provider when event is updated or added.

◆ CloneEvent()

virtual CXTPCalendarEventPtr CloneEvent ( )
virtual

Call this member function to obtain a pointer to the read-write interface of the event.

Returns
Pointer to a CXTPCalendarEvent object that contains the read-write interface of the event.

◆ CloneEventTo()

virtual BOOL CloneEventTo ( CXTPCalendarEvent * pEventDest )
virtual

Clones current event properties into a provided object instance.

Parameters
pEventDest Pointer to a destination CXTPCalendarEvent object.

This member function is used by CloneEvent() implementation.

Returns
TRUE if cloned successfully; FALSE otherwise.

◆ CloneForOccurrence()

virtual CXTPCalendarEventPtr CloneForOccurrence | ( | COleDateTime | dtStart,
 |  | COleDateTime | dtEnd,
 |  | DWORD | dwNewEventID = XTP_CALENDAR_UNKNOWN_EVENT_ID )
 virtual

This member function is used to build an occurrence event by duplicating the master event.

Parameters
dtStart | Start occurrence event date time.
dtEnd | End occurrence event date time.
dwNewEventID | Occurrence event ID. If specified value is XTP_CALENDAR_UNKNOWN_EVENT_ID - a new occurrence event ID will be generated automatically.

Call this member function to get an occurrence event object.

Returns
Pointer to a CXTPCalendarEvent object that contains the cloned occurrence event.
See also
CXTPCalendarEvent

◆ DoPropExchange()

virtual void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Call this member function to Store/Load an event using the specified data object.

Parameters
pPX Source or destination CXTPPropExchange data object reference.

This member function is used to either store event data to or load event data from storage.

◆ GetBody()

AFX_INLINE CString GetBody ( ) const
virtual

Call this member function to obtain the body text for the event.

Returns
A CString object with the body text for the event.
See also
SetBody

◆ GetBusyStatus()

AFX_INLINE int GetBusyStatus ( ) const
virtual

Call this member function to get a busy status value for the event.

Returns
Busy status value for the event as an XTPCalendarEventBusyStatus flag.
See also
SetBusyStatus
XTPCalendarEventBusyStatus enum

◆ GetCategories()

AFX_INLINE CXTPCalendarEventCategoryIDs * GetCategories ( ) const

This member function is used to obtain a collection of Event category IDs associated with an event object.

Returns
Pointer to a CXTPCalendarEventCategoryIDs object.
See also
CXTPCalendarEventCategories overview
CXTPCalendarData::GetEventCategories

◆ GetCategoriesCount()

int GetCategoriesCount ( ) const

This member function is used to obtain the count of Event category IDs associated with an event object.

Returns
An int that contains the count of CXTPCalendarEventCategoryIDs.
See also
CXTPCalendarEventCategories overview
CXTPCalendarData::GetEventCategories

◆ GetCreationTime()

AFX_INLINE COleDateTime GetCreationTime ( ) const
virtual

Call this member function to get the creation time for an event.

Returns
Creation time for event as COleDateTime object.
See also
SetCreationTime

◆ GetCustomIcons()

AFX_INLINE CXTPCalendarCustomIconIDs * GetCustomIcons ( ) const

This member function is used to obtain collection of custom icons IDs associated with event object.

Returns
Pointer to CXTPCalendarCustomIconIDs object.

◆ GetCustomProperties()

AFX_INLINE CXTPCalendarCustomProperties * GetCustomProperties ( ) const

Get custom (named, user-defined) properties collection.

Returns
A pointer to a CXTPCalendarCustomProperties object.
See also
CXTPCalendarCustomProperties.

◆ GetDataProvider()

AFX_INLINE CXTPCalendarData * GetDataProvider ( ) const

Returns event data provider.

Returns
A pointer to the data provider which stores this event object.

◆ GetDuration()

virtual COleDateTimeSpan GetDuration ( ) const
virtual

Call this member function to get an event duration as an COleDateTimeSpan object.

Returns
An COleDateTimeSpan object that contains an event duration interval.
See also
SetDuration

◆ GetDurationMinutes()

virtual int GetDurationMinutes ( ) const
virtual

Call this member function to get an event duration in minutes.

Returns
Integer value of an event duration in minutes.
See also
GetDuration

◆ GetEndTime()

AFX_INLINE COleDateTime GetEndTime ( ) const
virtual

Call this member function to get the event's end DateTime.

Returns
A COleDateTime object that contains the event's end DateTime.
See also
SetEndTime

◆ GetEventID()

AFX_INLINE DWORD GetEventID ( ) const
virtual

This member function is used to obtain a unique event ID.

Returns
A DWORD value denoting the event ID.
See also
CXTPCalendarEvent
SetEventID

◆ GetEventPeriodDays()

virtual int GetEventPeriodDays ( ) const
virtual

Call this member function to get an event duration as a number of days.

Returns
Integer value of an event duration in days.
See also
GetDurationMinutes()
GetDuration()

◆ GetImportance()

AFX_INLINE int GetImportance ( ) const
virtual

Call this member function to get an importance level for an event.

Returns
An importance level for an event as an XTPCalendarEventImportance enum.
See also
SetImportance
XTPCalendarEventImportance enum

◆ GetLabel()

virtual CXTPCalendarEventLabel * GetLabel ( ) const
virtual

Call this member function to obtain the event label.

Returns
Pointer to an CXTPCalendarEventLabel object that contains the event label.
See also
CXTPCalendarEventLabel
SetLocation

◆ GetLabelID()

AFX_INLINE int GetLabelID ( ) const
virtual

Call this member function to get the event label ID.

Returns
An int that contains the event label ID value.
See also
CXTPCalendarEventLabel
SetLabelID

◆ GetLastModificationTime()

AFX_INLINE COleDateTime GetLastModificationTime ( ) const
virtual

Call this member function to get the last modification time for an event.

Returns
A COleDateTime object that contains the last modification time for the event.
See also
SetLastModificationTime

◆ GetLocation()

AFX_INLINE CString GetLocation ( ) const
virtual

Call this member function to obtain the event location text.

Returns
A CString object that contains the location text.
See also
SetLocation

◆ GetRecurrencePattern()

virtual CXTPCalendarRecurrencePatternPtr GetRecurrencePattern ( ) const
virtual

Call this member function to get the event's recurrence pattern object.

Returns
Pointer to a CXTPCalendarRecurrencePattern object that contains the event's recurrence pattern.
See also
CXTPCalendarRecurrencePattern

◆ GetRecurrencePatternID()

AFX_INLINE DWORD GetRecurrencePatternID ( ) const
virtual

Call this member function to get the recurrence pattern ID.

Returns
A DWORD containing the recurrence pattern ID.

◆ GetRecurrenceState()

AFX_INLINE XTPCalendarEventRecurrenceState GetRecurrenceState ( ) const
virtual

Call this member function to get a recurrence state for the event.

Returns
Recurrence state for the event as an XTPCalendarEventRecurrenceState enum.
See also
MakeEventAsRecurrence
XTPCalendarEventRecurrenceState enum

◆ GetReminderMinutesBeforeStart()

AFX_INLINE int GetReminderMinutesBeforeStart ( ) const
virtual

Call this member function to determine the number of minutes before the start of an event.

Returns
An int that contains the number of Minutes before the start of an event.
See also
SetReminderMinutesBeforeStart(int nMinutes)

◆ GetReminderSoundFile()

AFX_INLINE CString GetReminderSoundFile ( ) const
virtual

Call this member function to determine a full path to the sound file assigned to the event reminder.

Returns
A CString object with a full path to the sound file for the event reminder.
See also
SetReminderSoundFile(LPCTSTR pcszFile)

◆ GetRException_EndTimeOrig()

AFX_INLINE COleDateTime GetRException_EndTimeOrig ( ) const
virtual

This member function is used to obtain the original end time of an exception event.

Returns
A COleDateTime object that contains the original date.
See also
GetRException_StartTimeOrig
SetRException_EndTimeOrig

◆ GetRException_StartTimeOrig()

AFX_INLINE COleDateTime GetRException_StartTimeOrig ( ) const
virtual

This member function is used to obtain the original start time of an exception event.

Returns
A COleDateTime object with the start original date.
See also
SetRException_StartTimeOrig
GetRException_EndTimeOrig

◆ GetRPatternRef()

CXTPCalendarRecurrencePattern * GetRPatternRef ( ) const

This member function is used to obtain a pointer to the internally stored Recurrence Pattern object.

Returns
A CXTPCalendarRecurrencePattern pointer that contains the Recurrence Pattern object.

◆ GetScheduleID()

AFX_INLINE UINT GetScheduleID ( ) const
virtual

This member function is used to obtain a schedule ID of the event.

Returns
A UINT schedule value.

String with the schedule ID allows for the identification of schedules for different resources. For example, Schedule ID could contain the name of the employee, who is the owner of this event.

See also
CXTPCalendarEvent
SetScheduleID

◆ GetScheduleSet()

AFX_INLINE CString GetScheduleSet ( ) const
virtual

This member function is used to obtain a multiple schedules set for the event.

Returns
Current schedule set value.

◆ GetStartTime()

AFX_INLINE COleDateTime GetStartTime ( ) const
virtual

Call this member function to get the event's start DateTime.

Returns
A COleDateTime object containing the event's start DateTime.
See also
SetStartTime

◆ GetSubject()

AFX_INLINE CString GetSubject ( ) const
virtual

This member function is used to obtain the event subject.

Returns
A CString object that contains the subject text.

◆ IsAllDayEvent()

AFX_INLINE BOOL IsAllDayEvent ( ) const
virtual

Call this member function to determine if an event is an "All Day" event.

Returns
A BOOL - TRUE if event is "All Day", FALSE otherwise.
See also
SetAllDayEvent

◆ IsEqualIDs()

BOOL IsEqualIDs ( const CXTPCalendarEvent * pEvent ) const

Call this member function to compare IDs of different events.

Parameters
pEvent Pointer to a CXTPCalendarEvent object that contains an event to compare.
Returns
TRUE if the provided event ID is equal the "this" ID. FALSE otherwise.

◆ IsEqualStartEnd()

BOOL IsEqualStartEnd ( const CXTPCalendarEvent * pEvent ) const

Call this member function to compare start dates of different events.

Parameters
pEvent Pointer to a CXTPCalendarEvent object that contains an event to compare.
Returns
TRUE if the provided event start date is equal to the "this" date. FALSE otherwise.

◆ IsEventVisible()

AFX_INLINE BOOL IsEventVisible ( ) const

Call this member function to determine if an event is Visible.

Returns
A BOOL - TRUE if event Visible.

◆ IsMeeting()

AFX_INLINE BOOL IsMeeting ( ) const
virtual

This member function is used to obtain the value of the Meeting state flag.

Returns
TRUE if the event is a meeting. FALSE otherwise.

◆ IsPrivate()

AFX_INLINE BOOL IsPrivate ( ) const
virtual

This member function is used to obtain the value of the private state flag.

Returns
TRUE if the event is private. FALSE otherwise. The private flag is used to indicate that a meeting event is private.

◆ IsReminder()

AFX_INLINE BOOL IsReminder ( ) const
virtual

Call this member function to determine if a reminder is set for event.

Returns
TRUE if a reminder is set. FALSE otherwise.
See also
SetReminder()

◆ IsRExceptionDeleted()

AFX_INLINE BOOL IsRExceptionDeleted ( ) const
virtual

Call this member function to determine if an exception occurrence is marked as deleted.

Returns
TRUE if an exception occurrence is marked as deleted. FALSE otherwise.
See also
SetRExceptionDeleted(BOOL bDeleted = TRUE)

◆ IsSound()

AFX_INLINE BOOL IsSound ( ) const
virtual

Call this member function to determine if a sound file is configured for the event reminder.

Returns
TRUE if sound file is configured. FALSE otherwise.

◆ MakeAsRException()

AFX_INLINE BOOL MakeAsRException ( DWORD dwPatternID = XTP_CALENDAR_UNKNOWN_RECURRENCE_PATTERN_ID )
virtual

Call this member function to set the event's recurrence pattern as an exception occurrence.

Parameters
dwPatternID Recurrence pattern ID.
Returns
TRUE if successful. FALSE otherwise.

◆ MakeEventAsRecurrence()

virtual BOOL MakeEventAsRecurrence ( )
virtual

Call this member function to change the recurrence state for the event.

Returns
TRUE if recurrence state successfully changed. FALSE otherwise.
See also
GetRecurrenceState
XTPCalendarEventRecurrenceState enum

◆ MoveEvent()

virtual void MoveEvent ( COleDateTime dtNewStartTime )
virtual

This member function is used to move the start date event to the provided DateTime.

The duration of the event does not change.

Parameters
dtNewStartTime An COleDateTime object that contains the new start date for the event.

◆ RemoveRecurrence()

virtual BOOL RemoveRecurrence ( )
virtual

This member function removes the recurrence pattern for the event.

Returns
TRUE if the operation is successful. FALSE otherwise.
See also
UpdateRecurrence(CXTPCalendarRecurrencePattern* pRPattern)

◆ SetAllDayEvent()

AFX_INLINE void SetAllDayEvent ( BOOL bSet = TRUE )
virtual

This member function is used to set the "All Day" flag for an event.

Parameters
bSet A BOOL. Boolean value used to set the "All Day" flag to TRUE or FALSE. TRUE - Event is an "All day" event. FALSE - Event is not an "All day" event.
See also
IsAllDayEvent

◆ SetBody()

AFX_INLINE void SetBody ( LPCTSTR pcszDesc )
virtual

This member function is used to set the body text for the event.

Parameters
pcszDesc An LPCTSTR Pointer to the string with the body text.
See also
GetBody

◆ SetBusyStatus()

AFX_INLINE void SetBusyStatus ( int Status )
virtual

This member function is used to set the busy status value for the event.

Parameters
Status An int that contains the busy status value.
See also
GetBusyStatus
XTPCalendarEventBusyStatus enum

◆ SetCreationTime()

AFX_INLINE void SetCreationTime ( COleDateTime dtTime )
virtual

This member function is used to set the creation time for an event.

Parameters
dtTime A COleDateTime object that contains the new creation time.
See also
GetCreationTime

◆ SetDuration()

virtual void SetDuration | ( | COleDateTimeSpan | spDuration,
 |  | BOOL | bKeepStart = TRUE )
 virtual

This member function is used to set the new duration for the event.

Parameters
spDuration | An COleDateTimeSpan object that contains the new date interval value.
bKeepStart | TRUE - Expanded flag and expand end DateTime. FALSE - Expand start DateTime.
See also
GetDuration

◆ SetEndTime()

virtual void SetEndTime ( COleDateTime dtEnd )
virtual

This member function is used to set the new end date and time for the event.

Parameters
dtEnd new date value.
See also
GetEndTime

◆ SetEventID()

virtual void SetEventID ( DWORD dwEventID )
virtual

This member function is used to set a new ID value for an event.

Parameters
dwEventID A DWORD that contains the event id value.

◆ SetEventVisible()

AFX_INLINE void SetEventVisible ( BOOL bSet )

This member function is used to set the EventVisible flag for an event.

Parameters
bSet A BOOL. Boolean value used to set the EventVisible flag to TRUE or FALSE.

◆ SetImportance()

AFX_INLINE void SetImportance ( int nImportance )
virtual

This member function is used to set the importance level for the event.

Parameters
nImportance - An int that contains the importance level value.
See also
GetImportance
XTPCalendarEventImportance enum

◆ SetLabelID()

AFX_INLINE void SetLabelID ( int nLabelID )
virtual

This member function is used to set the new label ID for the event.

Parameters
nLabelID An int that contains the label ID value.
See also
GetLabelID

◆ SetLastModificationTime()

AFX_INLINE void SetLastModificationTime ( COleDateTime dtTime )
virtual

This member function is used to set the modification time for the event.

Parameters
dtTime A COleDateTime object that contains the new modification time.
See also
GetLastModificationTime

◆ SetLocation()

AFX_INLINE void SetLocation ( LPCTSTR pcszLocation )
virtual

This member function is used to set the location text for the event.

Parameters
pcszLocation An LPCTSTR object that contains the string of text.
See also
GetLocation

◆ SetMeeting()

AFX_INLINE void SetMeeting ( BOOL bMeeting = TRUE )
virtual

This member function is used to set the state for the meeting flag.

Parameters
bMeeting A BOOL that contains the new state for the meeting flag.

Call this member function to set meeting state flag.

◆ SetPrivate()

AFX_INLINE void SetPrivate ( BOOL bPrivate = TRUE )
virtual

This member function is used to set the state for the private flag.

Parameters
bPrivate A BOOL that contains the new state for the private flag.

Call this member function to set the private state flag. The private flag is used to indicate that a meeting event is private.

◆ SetRecurrencePatternID()

virtual void SetRecurrencePatternID ( DWORD dwRecurrencePatternID )
virtual

This member function is used to set the new ID value for the event recurrence pattern.

Parameters
dwRecurrencePatternID An DWORD that contains the event recurrence pattern id value.

◆ SetRecurrenceState_ExceptionOccurrence()

virtual BOOL SetRecurrenceState_ExceptionOccurrence | ( | XTPCalendarEventRecurrenceState | nState,
 |  | DWORD | dwNewPatternID = XTP_CALENDAR_UNKNOWN_RECURRENCE_PATTERN_ID )
 protectedvirtual

This member function is used to set the exception recurrence.

Parameters
nState | An int that contains the new state value.
dwNewPatternID | A DWORD that contains the new pattern ID.
Returns
TRUE if the provided event start dates are equal. FALSE otherwise.

◆ SetRecurrenceState_Master()

virtual BOOL SetRecurrenceState_Master ( CXTPCalendarRecurrencePattern * pPattern )
protectedvirtual

This member function is used to assign a new RecurrencePattern to an event and set the Master flag.

Parameters
pPattern Pointer to a CXTPCalendarRecurrencePattern object that contains the new recurrence pattern for the event.
Returns
TRUE If the provided event start dates are equal. FALSE otherwise.

◆ SetRecurrenceState_NotRecurring()

virtual BOOL SetRecurrenceState_NotRecurring ( )
protectedvirtual

This function is used to reset the recurrence state for an event.

Returns
Always returns TRUE.

◆ SetReminder()

AFX_INLINE void SetReminder ( BOOL bReminder )
virtual

Call this member function to setup a reminder for this event.

Parameters
bReminder TRUE to enable reminder. FALSE to disable.

This function allows firing reminder notifications to be enabled/disabled for this event. This boolean setting corresponds to a checkbox near "Reminder" word in the Event details dialog.

See also
IsReminder()

◆ SetReminderMinutesBeforeStart()

AFX_INLINE void SetReminderMinutesBeforeStart ( int nMinutes )
virtual

This member function is used to set the number of minutes before the start of an event.

Parameters
nMinutes An int that contains the number of minutes before the start of an event.
See also
GetReminderMinutesBeforeStart()

◆ SetReminderSoundFile()

AFX_INLINE void SetReminderSoundFile ( LPCTSTR pcszFile )
virtual

This member function is used to set the sound file for the event reminder.

Parameters
pcszFile An LPCTSTR object. A pointer to a string with full path to the sound file.
See also
GetReminderSoundFile()

◆ SetRException_EndTimeOrig()

AFX_INLINE void SetRException_EndTimeOrig ( COleDateTime dtEndOrig )
virtual

This member function is used to set the original end time of an exception event.

Parameters
dtEndOrig A COleDateTime object that contains the original end time of an exception event.
See also
GetRException_EndTimeOrig
SetRException_StartTimeOrig

◆ SetRException_StartTimeOrig()

AFX_INLINE void SetRException_StartTimeOrig ( COleDateTime dtStartOrig )
virtual

This member function is used to set the original start time of an exception event.

Parameters
dtStartOrig A COleDateTime object that contains the original start time of the exception event.
See also
GetRException_StartTimeOrig

◆ SetRExceptionDeleted()

AFX_INLINE void SetRExceptionDeleted ( BOOL bDeleted = TRUE )
virtual

Call this member function to mark an exception occurrence as deleted/undeleted.

Parameters
bDeleted A BOOL. Exception deleted flag value. TRUE - To mark the exception recurrence as deleted. FALSE - To mark the exception recurrence as un-deleted.
See also
IsRExceptionDeleted()

◆ SetScheduleID()

AFX_INLINE void SetScheduleID ( UINT uScheduleID )
virtual

This member function is used to set a new schedule ID for the event.

Parameters
uScheduleID An UINT that contains the ScheduleID.

◆ SetScheduleSet()

AFX_INLINE void SetScheduleSet ( CString ScheduleSet )
virtual

This member function is used to set a new multiple schedules set for the event.

Parameters
ScheduleSet CString uScheduleID - |#1|...|#n| type of string

◆ SetStartTime()

virtual void SetStartTime ( COleDateTime dtStart )
virtual

This member function is used to set the new start date and time for the event.

The time is accepted as is, and no any conversions is performed.

Parameters
dtStart A COleDateTime object that contains the new start date value.
See also
GetStartTime

◆ SetSubject()

AFX_INLINE void SetSubject ( LPCTSTR pcszSubject )
virtual

This member function is used to set the subject text for the event.

Parameters
pcszSubject A LPCTSTR object that contains the string of text.

◆ Update()

virtual BOOL Update ( CXTPCalendarEvent * pNewData )
virtual

Call this member function to update the event's data.

Parameters
pNewData Pointer to a CXTPCalendarEvent object that contains the new data.
Returns
TRUE if successful. FALSE otherwise.
See also
CXTPCalendarEvent

◆ UpdateRecurrence()

virtual BOOL UpdateRecurrence ( CXTPCalendarRecurrencePattern * pRPattern )
virtual

This member function is used to set the recurrence pattern for the event.

Parameters
pRPattern A pointer to a CXTPCalendarRecurrencePattern object that contains the updated recurrence pattern.
Returns
TRUE if new pattern changed successfully. FALSE otherwise.
See also
CXTPCalendarRecurrencePattern
RemoveRecurrence

◆ UpdateStartEndDatesFromPatternExceptions()

virtual BOOL UpdateStartEndDatesFromPatternExceptions ( )
protectedvirtual

This member function is used to change the date-time values of the start and end dates of the master event using exception occurrences of recurrent events.

Returns
TRUE if successful. FALSE otherwise.

Member Data Documentation

◆ m_bAllDayEvent

BOOL m_bAllDayEvent
protected

Is this an all day event value.

◆ m_dtEndTime

COleDateTime m_dtEndTime
protected

End event time value.

◆ m_dtStartTime

COleDateTime m_dtStartTime
protected

Start event time value.

◆ m_nLabelID

int m_nLabelID
protected

Label ID.

◆ m_nReminderMinutesBeforeStart

int m_nReminderMinutesBeforeStart
protected

Reminder time value.

(in minutes)

◆ m_strLocation

CString m_strLocation
protected

Location value.

◆ m_strSubject

CString m_strSubject
protected

Subject value.

The documentation for this class was generated from the following file:
  • XTPCalendarEvent.h


Toolkit Pro: CXTPCalendarEventCategories Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPCalendarEventCategories Class Reference

This class is used as a collection of CXTPCalendarEventCategory objects. More...

Inheritance diagram for CXTPCalendarEventCategories:
[legend]

Public Member Functions

CXTPCalendarEventCategories ()
Default class constructor.
virtual | ~CXTPCalendarEventCategories ()
Default class destructor.
virtual void | InitDefaultValues ()
This member function is used to fill the collection using a default label list.
void | UpdateDefaultValues (COLORREF *pClrBkBase, COLORREF *pClrBorder, int nCount)
This member function updates the default colors of a category list when the theme is changed.
void | SetDefaultValues (BOOL bDefault)
Call this member function to set a flag indicating custom labels are defined.
virtual CXTPCalendarEventCategory * | Find (UINT nID) const
This member function is used to search for the event category with a specified ID.
- Public Member Functions inherited from CXTPCalendarPtrCollectionT< CXTPCalendarEventCategory >
CXTPCalendarPtrCollectionT ()
Default collection constructor.
virtual | ~CXTPCalendarPtrCollectionT ()
Default collection destructor.
virtual int | GetCount () const
This member function is used to obtain the number of elements in the collection.
virtual void | Add (CXTPCalendarEventCategory *pNewElement)
This member function adds a new element to the end of the array.
virtual void | Add (CXTPCalendarEventCategory *pNewElement, BOOL bWithAddRef)
This member function adds a new element to the end of the array.
virtual void | SetAt (int nIndex, CXTPCalendarEventCategory *pElement)
This member function is used to set a new element to the position specified in the nIndex parameter.
virtual int | Find (const CXTPCalendarEventCategory *pElement) const
This member function finds an element index in the collection using its pointer.
virtual void | InsertAt (int nIndex, CXTPCalendarEventCategory *pElement)
This member function is used to insert a new element at the position specified in the nIndex parameter.
virtual void | Append (const CXTPCalendarPtrCollectionT< CXTPCalendarEventCategory > *pElementsArray)
This member function is used to add a new elements to the end of the array.
virtual void | SetSize (int nNewSize)
This member function is used to change the array size.
virtual CXTPCalendarEventCategory * | GetAt (int nIndex) const
This member function returns an element at the specified numeric index.
virtual CXTPCalendarEventCategory * | GetAt (int nIndex, BOOL bWithAddRef) const
This member function returns an element at the specified numeric index.
virtual void | RemoveAt (int nIndex)
This member function removes an element at the specified index from the array.
virtual void | Remove (CXTPCalendarEventCategory *pElement)
This member function finds an element using its pointer and removes it from the array.
virtual void | RemoveAll ()
This member function is used to remove all of the elements from the array.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

virtual int FindIndex (UINT nID) const
Finds an event category index in the collection by its ID.

Protected Attributes

BOOL | m_bDefaultValues
Set to FALSE when using custom values.
- Protected Attributes inherited from CXTPCalendarPtrCollectionT< CXTPCalendarEventCategory >
CArray< TObjectPtr, TObjectPtr & > | m_arElements
Objects storage.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Types inherited from CXTPCalendarPtrCollectionT< CXTPCalendarEventCategory >
typedef CXTPSmartPtrInternalT< CXTPCalendarEventCategory > | TObjectPtr
Smart pointer type for stored objects.

Detailed Description

This class is used as a collection of CXTPCalendarEventCategory objects.

See also
CXTPCalendarEventCategory, CXTPCalendarEvent

Constructor & Destructor Documentation

◆ ~CXTPCalendarEventCategories()

virtual ~CXTPCalendarEventCategories ( )
virtual

Default class destructor.

Handles class members deallocation.

Member Function Documentation

◆ Find()

virtual CXTPCalendarEventCategory * Find ( UINT nID ) const
virtual

This member function is used to search for the event category with a specified ID.

Parameters
nID An UINT that contains the category ID.
Returns
A pointer to a CXTPCalendarEventCategory object or NULL.

◆ FindIndex()

virtual int FindIndex ( UINT nID ) const
protectedvirtual

Finds an event category index in the collection by its ID.

Parameters
nID An UINT that contains the category ID.
Returns
Category index in the collection.
See also
Find

◆ SetDefaultValues()

void SetDefaultValues ( BOOL bDefault )

Call this member function to set a flag indicating custom labels are defined.

Parameters
bDefault Set to FALSE when using custom values.

◆ UpdateDefaultValues()

void UpdateDefaultValues | ( | COLORREF * | pClrBkBase,
 |  | COLORREF * | pClrBorder,
 |  | int | nCount )

This member function updates the default colors of a category list when the theme is changed.

Parameters
pClrBkBase | Array of COLORREF values representing the background color for each category item.
pClrBorder | Array of COLORREF values represening the border color for each category item.
nCount | Size of pClrBack and pClrBorder arrays.
The documentation for this class was generated from the following file:
  • XTPCalendarEventLabel.h


Toolkit Pro: CXTPCalendarEventCategory Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPCalendarEventCategory Class Reference

This class defines Calendar Event Category properties. More...

Inheritance diagram for CXTPCalendarEventCategory:
[legend]

Public Member Functions

CXTPCalendarEventCategory (UINT nID=0, LPCTSTR pcszName=_T(""), COLORREF clrBorder=0, COLORREF clrBkBase=0)
Default class constructor.
CXTPCalendarEventCategory (CXTPCalendarEventCategory *pCategory)
Default class constructor.
virtual | ~CXTPCalendarEventCategory ()
Default class destructor.
UINT | GetID () const
This member function is used to obtain a unique category ID.
void | SetID (UINT nID)
This member function is used to set a unique category ID.
CString | GetName () const
This member function is used to obtain a category name.
void | SetName (LPCTSTR pcszName)
This member function is used to set a category name.
virtual COLORREF | GetBorderColor () const
This member function is used to obtain an event border color.
virtual void | SetBorderColor (COLORREF clrColor)
This member function is used to set an event border color.
virtual COLORREF | GetBkBaseColor () const
This member function is used to obtain a background base color.
virtual void | SetBkBaseColor (COLORREF clrColor)
This member function is used to set a background base color.
virtual CXTPPaintManagerColorGradient & | GetBackgroundColor ()
This member function is used to obtain an event background color.
virtual COLORREF | GetBkColorAllDayEvents () const
This member function is used to obtain All Day Events area background color.
virtual COLORREF | GetBkColorWorkCell () const
This member function is used to obtain Day View Work Cell background color.
virtual COLORREF | GetBkColorNonWorkCell () const
This member function is used to obtain Day View NonWork Cell background color.
virtual COLORREF | GetColorCellBorder () const
This member function is used to obtain Day View Cell border color.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Attributes

UINT | m_nID
Stores category identifier.
CString | m_strName
Stores category name.
COLORREF | m_clrBorder
Stores Event border color.
COLORREF | m_clrBkBase
Stores Base color to calculate few background colors for event background and other elements.
CXTPPaintManagerColorGradient | m_grclrBackground
Stores an event background gradient color.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

This class defines Calendar Event Category properties.

Visual effects for Event Categories (event and day's cells background colors) are implemented in Office 2007 theme only. If one or more categories are set for an event, then the the category's colors are used. Otherwise the label's colors are used (is label defined). For Office 2003 theme, the label's colors are used in any case.

See also
CXTPCalendarEvent
CXTPCalendarEventCategories

Constructor & Destructor Documentation

◆ CXTPCalendarEventCategory() [1/2]

CXTPCalendarEventCategory | ( | UINT | nID = 0,
 |  | LPCTSTR | pcszName = _T(""),
 |  | COLORREF | clrBorder = 0,
 |  | COLORREF | clrBkBase = 0 )

Default class constructor.

Parameters
nID | Category identifier.
pcszName | Category name.
clrBorder | Event border color.
clrBkBase | Base color to calculate few background colors for event background and other elements.

◆ CXTPCalendarEventCategory() [2/2]

CXTPCalendarEventCategory ( CXTPCalendarEventCategory * pCategory )

Default class constructor.

Parameters
pCategory Points to the source category object to initialize this object with.

Member Function Documentation

◆ GetBackgroundColor()

virtual CXTPPaintManagerColorGradient & GetBackgroundColor ( )
virtual

This member function is used to obtain an event background color.

Returns
An event background gradient color.
See also
GetBkBaseColor
SetBkBaseColor

◆ GetBkBaseColor()

AFX_INLINE COLORREF GetBkBaseColor ( ) const
virtual

This member function is used to obtain a background base color.

Returns
A background base color.
See also
SetBkBaseColor

◆ GetBkColorAllDayEvents()

virtual COLORREF GetBkColorAllDayEvents ( ) const
virtual

This member function is used to obtain All Day Events area background color.

Returns
All Day Events area background color.
See also
GetBkBaseColor
SetBkBaseColor

◆ GetBkColorNonWorkCell()

virtual COLORREF GetBkColorNonWorkCell ( ) const
virtual

This member function is used to obtain Day View NonWork Cell background color.

Returns
A Day View NonWork Cell background color.
See also
GetBkBaseColor
SetBkBaseColor

◆ GetBkColorWorkCell()

virtual COLORREF GetBkColorWorkCell ( ) const
virtual

This member function is used to obtain Day View Work Cell background color.

Returns
A Day View Work Cell background color.
See also
GetBkBaseColor
SetBkBaseColor

◆ GetBorderColor()

AFX_INLINE COLORREF GetBorderColor ( ) const
virtual

This member function is used to obtain an event border color.

Returns
An event border color.
See also
SetBorderColor

◆ GetColorCellBorder()

virtual COLORREF GetColorCellBorder ( ) const
virtual

This member function is used to obtain Day View Cell border color.

Returns
A Day View Cell border color.
See also
GetBkBaseColor
SetBkBaseColor

◆ GetID()

AFX_INLINE UINT GetID ( ) const

This member function is used to obtain a unique category ID.

Returns
A unique category ID.
See also
SetID

◆ GetName()

AFX_INLINE CString GetName ( ) const

This member function is used to obtain a category name.

Returns
A category name.
See also
SetName

◆ SetBkBaseColor()

AFX_INLINE void SetBkBaseColor ( COLORREF clrColor )
virtual

This member function is used to set a background base color.

Parameters
clrColor A background base color.
See also
GetBkBaseColor

◆ SetBorderColor()

AFX_INLINE void SetBorderColor ( COLORREF clrColor )
virtual

This member function is used to set an event border color.

Parameters
clrColor An event border color.
See also
GetBorderColor

◆ SetID()

AFX_INLINE void SetID ( UINT nID )

This member function is used to set a unique category ID.

Parameters
nID A unique category ID.
See also
GetID

◆ SetName()

AFX_INLINE void SetName ( LPCTSTR pcszName )

This member function is used to set a category name.

Parameters
pcszName A category name.
See also
GetName
The documentation for this class was generated from the following file:
  • XTPCalendarEventLabel.h


Toolkit Pro: CXTPCalendarEventCategoryComboBox Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPCalendarEventCategoryComboBox Class Reference

This class implements the event category selector combobox. More...

Inheritance diagram for CXTPCalendarEventCategoryComboBox:
[legend]

Public Member Functions

CXTPCalendarEventCategoryComboBox ()
Standard object constructor.
virtual | ~CXTPCalendarEventCategoryComboBox ()
Standard object destructor.
virtual BOOL | Init (CXTPCalendarEvent *pEvent, XTPCalendarTheme nTheme)
Call this member function to initialize the combobox.
virtual void | GetChecked (CXTPCalendarEventCategoryIDs *pChecked, BOOL *pbChanged)
Use this member to get selected categories.
CXTPCalendarEventCategoryIDs & GetCategoryArray ()
Call this member function to retrieve a reference to the combobox category array.
- Public Member Functions inherited from CXTPCalendarComboBoxBase
CXTPCalendarComboBoxBase ()
Standard object constructor.
virtual | ~CXTPCalendarComboBoxBase ()
Standard object destructor.

Protected Member Functions

virtual void | DrawItem (LPDRAWITEMSTRUCT lpDIS)
This function implements custom draw combobox items.
virtual void | DrawCollapsed (CDC *pDC, CRect rcItem, BOOL bFocused, BOOL bDisabled)
Called to draw an event category item when the combobox is collapsed.
virtual void | DrawExpanded (CDC *pDC, CRect rcItem, BOOL bSelected, UINT uItemID)
Called to draw an event category item when the combobox is expanded.
virtual int | GetLBCurSel () const
Use this member function to get the list box selected item (works for dropped state only).
virtual void | RedrawLB (BOOL bUpdateNow=FALSE)
Use this member function to redraw the list box (works for dropped state only).
- Protected Member Functions inherited from CXTPCalendarComboBoxBase
virtual void | MeasureItem (LPMEASUREITEMSTRUCT lpMIS)
This function implements measure items for custom draw.
virtual CRect | CalcColorRect (CRect rItem)
This member function is called to calculate the size for the color rectangle displayed for each item.

Protected Attributes

CXTPCalendarEventCategories * | m_pCategories
Pointer to categories array.
CXTPCalendarEventCategoryIDs | m_arChecked
Array which stores checked item IDs.
- Protected Attributes inherited from CXTPCalendarComboBoxBase

Detailed Description

This class implements the event category selector combobox.

Member Function Documentation

◆ DrawCollapsed()

virtual void DrawCollapsed | ( | CDC * | pDC,
 |  | CRect | rcItem,
 |  | BOOL | bFocused,
 |  | BOOL | bDisabled )
 protectedvirtual

Called to draw an event category item when the combobox is collapsed.

Parameters
pDC | Pointer to a valid device context.
rcItem | Size of the category item to draw.
bFocused | TRUE if the combobox has input focus.
bDisabled | TRUE if the combobox is disabled.

◆ DrawExpanded()

virtual void DrawExpanded | ( | CDC * | pDC,
 |  | CRect | rcItem,
 |  | BOOL | bSelected,
 |  | UINT | uItemID )
 protectedvirtual

Called to draw an event category item when the combobox is expanded.

Parameters
pDC | Points to a valid device context.
rcItem | Size of the category item to draw.
bSelected | TRUE if the category item is selected.
uItemID | Index ID of the category item.

◆ DrawItem()

virtual void DrawItem ( LPDRAWITEMSTRUCT lpDIS )
protectedvirtual

This function implements custom draw combobox items.

Parameters
lpDIS A pointer to LPDRAWITEMSTRUCT structure.

◆ GetCategoryArray()

AFX_INLINE CXTPCalendarEventCategoryIDs & GetCategoryArray ( )

Call this member function to retrieve a reference to the combobox category array.

Returns
A reference to the combobox category array.

◆ GetChecked()

virtual void GetChecked | ( | CXTPCalendarEventCategoryIDs * | pChecked,
 |  | BOOL * | pbChanged )
 virtual

Use this member to get selected categories.

Parameters
pChecked | [in/out] A pointer to a CXTPCalendarEventCategoryIDs collection to receive selected category's IDs.
pbChanged | [in/out] This member is set to TRUE if the category's IDs set changed.

◆ GetLBCurSel()

virtual int GetLBCurSel ( ) const
protectedvirtual

Use this member function to get the list box selected item (works for dropped state only).

Returns
Currently selected item index or LB_ERR.

◆ Init()

virtual BOOL Init | ( | CXTPCalendarEvent * | pEvent,
 |  | XTPCalendarTheme | nTheme )
 virtual

Call this member function to initialize the combobox.

Parameters
pEvent | Pointer to the selected calendar event.
nTheme | Current Calendar theme.
Returns
TRUE if successful, FALSE otherwise.

Reimplemented from CXTPCalendarComboBoxBase.

◆ RedrawLB()

virtual void RedrawLB ( BOOL bUpdateNow = FALSE )
protectedvirtual

Use this member function to redraw the list box (works for dropped state only).

Parameters
bUpdateNow Set as TRUE to call UpdateWindow, FALSE to call Invalidate.
The documentation for this class was generated from the following file:
  • XTPCalendarEventPropertiesDlg.h


Toolkit Pro: CXTPCalendarEventCategoryIDs Class Reference

Public Member Functions | List of all members
CXTPCalendarEventCategoryIDs Class Reference

This class represents the collection of event categories IDs. More...

Inheritance diagram for CXTPCalendarEventCategoryIDs:
[legend]

Public Member Functions

CXTPCalendarEventCategoryIDs ()
Default object constructor.
virtual | ~CXTPCalendarEventCategoryIDs ()
Default object destructor.
virtual void | DoPropExchange (CXTPPropExchange *pPX)
Call this member function to Store/Load collection data using the specified data object.
virtual void | DoPropExchange (CXTPPropExchange *pPX, LPCTSTR pcszSection, LPCTSTR pcszElement)
Call this member function to Store/Load collection data using the specified data object.
- Public Member Functions inherited from CXTPCalendarUIntArray
int | Find (UINT uID) const
Call this member function to find an ID in the collection.
virtual BOOL | RemoveID (UINT uID)
Call this member function to remove an ID from the collection.
virtual CString | SaveToString () const
Call this member function to store collection data as a comma separated string.
virtual void | LoadFromString (LPCTSTR pcszData)
Call this member function to read collection data from a comma separated string.
- Public Member Functions inherited from CXTPArrayT< UINT, UINT >
CXTPArrayT ()
Default object constructor.
virtual | ~CXTPArrayT ()
Default object destructor.
virtual int | GetSize () const
This member function is used to obtain the number of elements in the collection.
virtual void | SetSize (int nNewSize, int nGrowBy=-1)
This member function is used to change the array size.
virtual UINT | GetAt (int nIndex) const
This member function returns an element at the specified numeric index.
virtual void | SetAt (int nIndex, UINT newElement)
This member function is used to set a new element to the position specified in the nIndex parameter.
virtual UINT & | ElementAt (int nIndex)
This member function returns a reference to element at the specified numeric index.
virtual const UINT * | GetData () const
This member function is used to Direct Access to the element data.
virtual UINT * | GetData ()
This member function is used to Direct Access to the element data.
virtual void | SetAtGrow (int nIndex, UINT newElement)
This member function is used to set a new element to the position specified in the nIndex parameter.
virtual int | Add (UINT newElement)
This member function adds a new element to the end of the array.
virtual int | Append (const CXTPArrayT &src)
This member function adds the elements from a specified array to the end of this array.
virtual void | Copy (const CXTPArrayT &src)
This member function overwrites the contents of this array with the contents of a specified array.
UINT | operator[] (int nIndex) const
This operator returns the array element at a specified numeric index.
UINT & | operator[] (int nIndex)
This operator returns a reference to the array element at a specified numeric index.
virtual void | InsertAt (int nIndex, UINT newElement, int nCount=1)
This member function is used to insert a number of copies of an element, specified by the nCount parameter, to the array starting at the position specified by the nIndex parameter.
virtual void | InsertAt (int nStartIndex, CXTPArrayT *pNewArray)
This member function is used to insert an array of elements to the array starting at the position specified by the nStartIndex parameter.
virtual void | RemoveAt (int nIndex, int nCount=1)
This member function is used to remove a number of array elements, specified by the nCount parameter, from the array starting at the position specified by the nIndex parameter.
virtual void | RemoveAll ()
This member function is used to remove all array elements from the array.
virtual int | FindElement (UINT nElement) const
Call this member function to find an element in the collection.
virtual void | AddIfNeed (UINT newElement)
Call this member function to add a specified element to the collection if it is not present already.
virtual BOOL | RemoveElement (UINT nElement)
Call this member function to remove all elements with a specified value from the collection.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Public Types inherited from CXTPCalendarUIntArray
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Attributes inherited from CXTPArrayT< UINT, UINT >
CArray< UINT, UINT > | m_arElements
Elements storage.

Detailed Description

This class represents the collection of event categories IDs.

It also implements some useful operations.

Member Function Documentation

◆ DoPropExchange() [1/2]

AFX_INLINE void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Call this member function to Store/Load collection data using the specified data object.

Parameters
pPX Source or destination CXTPPropExchange data object reference.

This member function is used to either store event data to or load event data from storage.

◆ DoPropExchange() [2/2]

virtual void DoPropExchange | ( | CXTPPropExchange * | pPX,
 |  | LPCTSTR | pcszSection,
 |  | LPCTSTR | pcszElement )
 virtual

Call this member function to Store/Load collection data using the specified data object.

Parameters
pPX | Source or destination CXTPPropExchange data object reference.
pcszSection | Section name for elements set.
pcszElement | Element value property name.

This member function is used to either store event data to or load event data from storage.

Reimplemented from CXTPCalendarUIntArray.

The documentation for this class was generated from the following file:
  • XTPCalendarEventLabel.h


Toolkit Pro: CXTPCalendarEventColorDlg Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPCalendarEventColorDlg Class Reference

This class is used to edit Calendar Event Category and Label information. More...

Public Member Functions

CXTPCalendarEventColorDlg (BOOL bCategories, CXTPCalendarControl *pCalendarCtrl, CWnd *pParent=NULL)
Constructs a CXTPCalendarEventColorDlg object used to edit calendar event categories and labels.

Protected Member Functions

void UpdateSelColor (int nIndex=LB_ERR)
This member function is called to update the diplayed color for the color picker whenever a listbox selection changes.

Protected Attributes

BOOL | m_bCategories
TRUE when editing event categories.
CXTPCalendarControl * m_pCalendarCtrl
Pointer to the calendar object.
CXTPCalendarEventPtr | m_pEvent
Pointer to the calendar event object.

Detailed Description

This class is used to edit Calendar Event Category and Label information.

Constructor & Destructor Documentation

◆ CXTPCalendarEventColorDlg()

CXTPCalendarEventColorDlg | ( | BOOL | bCategories,
 |  | CXTPCalendarControl * | pCalendarCtrl,
 |  | CWnd * | pParent = NULL )

Constructs a CXTPCalendarEventColorDlg object used to edit calendar event categories and labels.

Parameters
bCategories | TRUE to edit event category list, FALSE to edit event labels.
pCalendarCtrl | Points to a valid CXTPCalendarControl object.
pParent | A pointer to the dialog box's parent or owner window.

Member Function Documentation

◆ UpdateSelColor()

void UpdateSelColor ( int nIndex = LB_ERR )
protected

This member function is called to update the diplayed color for the color picker whenever a listbox selection changes.

Parameters
nIndex Index of the listbox item to retrieve color information from. If LB_ERR, the currently selected item is used.

Member Data Documentation

◆ m_bCategories

BOOL m_bCategories
protected

TRUE when editing event categories.

◆ m_pCalendarCtrl

CXTPCalendarControl* m_pCalendarCtrl
protected

Pointer to the calendar object.

The documentation for this class was generated from the following file:
  • XTPCalendarEventColorDlg.h


Toolkit Pro: CXTPCalendarEventColorEdit Class Reference

Public Member Functions | List of all members
CXTPCalendarEventColorEdit Class Reference

This class is used by CXTPCalendarEventColorListBox to create an inplace edit box for renaming event categories and labels. More...

Public Member Functions

CXTPCalendarEventColorEdit (int nIndex)
Constructs a CXTPCalendarEventColorEdit object used to edit calendar event categories and labels names.
int GetIndex () const
Returns the index of the listbox item associated with this edit control.

Detailed Description

This class is used by CXTPCalendarEventColorListBox to create an inplace edit box for renaming event categories and labels.

Constructor & Destructor Documentation

◆ CXTPCalendarEventColorEdit()

CXTPCalendarEventColorEdit ( int nIndex )

Constructs a CXTPCalendarEventColorEdit object used to edit calendar event categories and labels names.

Parameters
nIndex Index of the list box item to edit.

Member Function Documentation

◆ GetIndex()

AFX_INLINE int GetIndex ( ) const

Returns the index of the listbox item associated with this edit control.

Returns
Gets index
The documentation for this class was generated from the following file:
  • XTPCalendarEventColorListBox.h


Toolkit Pro: CXTPCalendarEventColorListBox Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPCalendarEventColorListBox Class Reference

This class is used to display a list of Calendar Event Categories or Labels that can be edited. More...

Public Member Functions

CXTPCalendarEventColorListBox ()
Constructs a CXTPCalendarEventColorListBox object used to edit calendar event categories and labels.
virtual | ~CXTPCalendarEventColorListBox ()
Destructor handles cleanup and deallocation.
virtual void | Init (CXTPCalendarData *pData, CXTPCalendarEvent *pEvent, BOOL bCategories)
This member function is called to initialize the listbox with calendar event category or list data.
virtual void | BeginEdit ()
Called to begin the editing of a listbox event category or label item.
virtual void | EndEdit (BOOL bUpdate=TRUE)
Called to end the editing of a listbox event category or label item.
virtual void | DeleteItem (int nItem=LB_ERR)
Called to delete a list box category or label item.
virtual int | AddItem ()
Called to add a new event category or label to the listbox.
virtual void | SetItemColor (COLORREF crItem, int nItem=LB_ERR)
Call this member function to set the color for a calendar event category or label.
CXTPCalendarEventLabel * | GetLabel (int nIndex)
Call this member function to retrieve the label object for the specified index.
CXTPCalendarEventCategory * | GetCategory (int nIndex)
Call this member function to retrieve the category object for the specified index.
CXTPCalendarEventColorEdit * GetEdit ()
This member function is called to get a pointer to the edit control used for renaming calendar event categories and labels.
void | UpdateCategories (CXTPCalendarData *pData)
This member function is called to update the calendar event categories based on the current listbox state.
void | UpdateLabels (CXTPCalendarData *pData)
This member function is called to update the calendar event labels based on the current listbox state.
void | ToggleCheck (int nItem)
This member function is called to toggle the checked state for the specified calendar event category.
void | SetModified (BOOL bModified)
This member function is called to set the modified state for the listbox control.
BOOL | IsModified ()
This member function is called to check the modified state of the listbox control.

Protected Member Functions

CRect CalcColorRect (CRect rItem)
This member function is called to determine the size and location of a color rectangle for the specified item.

Protected Attributes

BOOL | m_bModified
TRUE if the listbox state has been changed.
BOOL | m_bCategories
TRUE if the listbox should display calendar event categories.
CSize | m_sizeColor
Size in pixels of the color selection box.
CXTPCalendarData * | m_pData
Points to a valid CXTPCalendarData object.
CXTPCalendarEvent * | m_pEvent
Points to a valid CXTPCalendarEvent object.
CXTPCalendarEventColorEdit * | m_pWndEdit
Points to a valid CXTPCalendarEventColorEdit object, only valid when a list box item is being edited.
CXTPCalendarEventCategoryIDs | m_arChecked
Array which store checked item IDs.

Detailed Description

This class is used to display a list of Calendar Event Categories or Labels that can be edited.

Member Function Documentation

◆ AddItem()

virtual int AddItem ( )
virtual

Called to add a new event category or label to the listbox.

Returns
An index of the newly added item if successful, otherwise returns LB_ERR.

◆ CalcColorRect()

CRect CalcColorRect ( CRect rItem )
protected

This member function is called to determine the size and location of a color rectangle for the specified item.

Parameters
rItem Size and location of the listbox item used to calculate the color rectangle.
Returns
A CRect object representing the size and location of the color rectangle for the specified item.

◆ DeleteItem()

virtual void DeleteItem ( int nItem = LB_ERR )
virtual

Called to delete a list box category or label item.

Parameters
nItem Index of the item to delete.

◆ EndEdit()

virtual void EndEdit ( BOOL bUpdate = TRUE )
virtual

Called to end the editing of a listbox event category or label item.

Parameters
bUpdate TRUE to save edit changes, FALSE to discard.

◆ GetCategory()

CXTPCalendarEventCategory * GetCategory ( int nIndex )

Call this member function to retrieve the category object for the specified index.

Parameters
nIndex Index of the item to get the category pointer for.
Returns
A CXTPCalendarEventLabel object pointer if successful, otherwise returns NULL.

◆ GetEdit()

AFX_INLINE CXTPCalendarEventColorEdit * GetEdit ( )

This member function is called to get a pointer to the edit control used for renaming calendar event categories and labels.

Returns
A pointer to a valid CXTPCalendarEventColorEdit if active, otherwise returns NULL.

◆ GetLabel()

CXTPCalendarEventLabel * GetLabel ( int nIndex )

Call this member function to retrieve the label object for the specified index.

Parameters
nIndex Index of the item to get the label pointer for.
Returns
A CXTPCalendarEventLabel object pointer if successful, otherwise returns NULL.

◆ Init()

virtual void Init | ( | CXTPCalendarData * | pData,
 |  | CXTPCalendarEvent * | pEvent,
 |  | BOOL | bCategories )
 virtual

This member function is called to initialize the listbox with calendar event category or list data.

Parameters
pData | Points to a valid CXTPCalendarData object.
pEvent | Points to a valid CXTPCalendarEvent object.
bCategories | TRUE if the list should display event categories, FALSE to display labels.

◆ IsModified()

AFX_INLINE BOOL IsModified ( )

This member function is called to check the modified state of the listbox control.

Returns
TRUE if the listox state has been changed, otherwise returns FALSE.

◆ SetItemColor()

virtual void SetItemColor | ( | COLORREF | crItem,
 |  | int | nItem = LB_ERR )
 virtual

Call this member function to set the color for a calendar event category or label.

Parameters
crItem | RGB value representing new item color.
nItem | Index of the listbox item to set color for.

◆ SetModified()

AFX_INLINE void SetModified ( BOOL bModified )

This member function is called to set the modified state for the listbox control.

Parameters
bModified TRUE if the state of the list box has changed and calendar data needs to be updated.

◆ ToggleCheck()

void ToggleCheck ( int nItem )

This member function is called to toggle the checked state for the specified calendar event category.

Parameters
nItem Index of the item to toggle check state for.

◆ UpdateCategories()

void UpdateCategories ( CXTPCalendarData * pData )

This member function is called to update the calendar event categories based on the current listbox state.

Parameters
pData Points to a valid CXTPCalendarData object.

◆ UpdateLabels()

void UpdateLabels ( CXTPCalendarData * pData )

This member function is called to update the calendar event labels based on the current listbox state.

Parameters
pData Points to a valid CXTPCalendarData object.
The documentation for this class was generated from the following file:
  • XTPCalendarEventColorListBox.h


Toolkit Pro: CXTPCalendarEventColorNewDlg Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPCalendarEventColorNewDlg Class Reference

This class is used to add new Calendar Event Categories or Labels to the existing data array. More...

Public Member Functions

CXTPCalendarEventColorNewDlg (BOOL bCategories, CWnd *pParent=NULL)
Constructs a CXTPCalendarEventColorNewDlg object used to add new calendar event categories and labels.

Protected Member Functions

virtual void EnableOkButton ()
This member function is called to enable / disable the OK button for the dialog.

Protected Attributes

BOOL m_bCategories
TRUE when editing event categories.

Detailed Description

This class is used to add new Calendar Event Categories or Labels to the existing data array.

Constructor & Destructor Documentation

◆ CXTPCalendarEventColorNewDlg()

CXTPCalendarEventColorNewDlg | ( | BOOL | bCategories,
 |  | CWnd * | pParent = NULL )

Constructs a CXTPCalendarEventColorNewDlg object used to add new calendar event categories and labels.

Parameters
bCategories | TRUE to edit event category list, FALSE to edit event labels.
pParent | A pointer to the dialog box's parent or owner window.
The documentation for this class was generated from the following file:
  • XTPCalendarEventColorNewDlg.h


Toolkit Pro: CXTPCalendarEventLabel Class Reference

Public Member Functions | Public Attributes | List of all members
CXTPCalendarEventLabel Class Reference

This class defines Calendar Event label properties. More...

Inheritance diagram for CXTPCalendarEventLabel:
[legend]

Public Member Functions

CXTPCalendarEventLabel (int nID=0, COLORREF clrColor=0, LPCTSTR pcszName=_T(""))
Default class constructor.
CXTPCalendarEventLabel (CXTPCalendarEventLabel *pSrc)
Default class constructor.
virtual | ~CXTPCalendarEventLabel ()
Default class destructor.
const CXTPCalendarEventLabel & | operator= (const CXTPCalendarEventLabel &rSrc)
This member function is used to set new object properties.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Public Attributes

int | m_nLabelID
Label ID.
COLORREF | m_clrColor
Label color used to fill the event background.
CString | m_strName
Label name.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

This class defines Calendar Event label properties.

See also
CXTPCalendarEvent

Constructor & Destructor Documentation

◆ CXTPCalendarEventLabel() [1/2]

CXTPCalendarEventLabel | ( | int | nID = 0,
 |  | COLORREF | clrColor = 0,
 |  | LPCTSTR | pcszName = _T("") )

Default class constructor.

Parameters
nID | Label ID.
clrColor | Label color.
pcszName | Label name.

◆ CXTPCalendarEventLabel() [2/2]

CXTPCalendarEventLabel ( CXTPCalendarEventLabel * pSrc )

Default class constructor.

Parameters
pSrc Pointer to the source used initialize this object.

◆ ~CXTPCalendarEventLabel()

virtual ~CXTPCalendarEventLabel ( )
virtual

Default class destructor.

Handles class member deallocation.

Member Function Documentation

◆ operator=()

const CXTPCalendarEventLabel & operator= ( const CXTPCalendarEventLabel & rSrc )

This member function is used to set new object properties.

Parameters
rSrc Reference to the source object.

This is the overloaded assignment operator.

Returns
Reference to this class instance.
The documentation for this class was generated from the following file:
  • XTPCalendarEventLabel.h


Toolkit Pro: CXTPCalendarEventLabelComboBox Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPCalendarEventLabelComboBox Class Reference

This class implements the event label selector combobox. More...

Inheritance diagram for CXTPCalendarEventLabelComboBox:
[legend]

Public Member Functions

virtual BOOL | Init (CXTPCalendarEvent *pEvent, XTPCalendarTheme nTheme)
Call this member function to initialize the combobox.
virtual int | GetLabelID () const
Use this member to get the selected label ID.
virtual int | GetLabelID (int nID) const
Use this member to get the selected label ID.
virtual void | SetLabelID (int nID)
Use this member to set the selected label ID.
- Public Member Functions inherited from CXTPCalendarComboBoxBase
CXTPCalendarComboBoxBase ()
Standard object constructor.
virtual | ~CXTPCalendarComboBoxBase ()
Standard object destructor.

Protected Member Functions

virtual void | DrawItem (LPDRAWITEMSTRUCT lpDIS)
This function implements the custom draw combobox items.
- Protected Member Functions inherited from CXTPCalendarComboBoxBase
virtual void | MeasureItem (LPMEASUREITEMSTRUCT lpMIS)
This function implements measure items for custom draw.
virtual CRect | CalcColorRect (CRect rItem)
This member function is called to calculate the size for the color rectangle displayed for each item.

Detailed Description

This class implements the event label selector combobox.

Member Function Documentation

◆ DrawItem()

virtual void DrawItem ( LPDRAWITEMSTRUCT lpDIS )
protectedvirtual

This function implements the custom draw combobox items.

Parameters
lpDIS A pointer to a LPDRAWITEMSTRUCT structure.

◆ GetLabelID() [1/2]

virtual int GetLabelID ( ) const
virtual

Use this member to get the selected label ID.

Returns
A selected label ID.

◆ GetLabelID() [2/2]

virtual int GetLabelID ( int nID ) const
virtual

Use this member to get the selected label ID.

Parameters
nID A selected label ID.
Returns
A selected label ID.

◆ Init()

virtual BOOL Init | ( | CXTPCalendarEvent * | pEvent,
 |  | XTPCalendarTheme | nTheme )
 virtual

Call this member function to initialize the combobox.

Parameters
pEvent | Pointer to the selected calendar event.
nTheme | Current Calendar theme.
Returns
TRUE if successful, FALSE otherwise.

Reimplemented from CXTPCalendarComboBoxBase.

◆ SetLabelID()

virtual void SetLabelID ( int nID )
virtual

Use this member to set the selected label ID.

Parameters
nID A selected label ID.
The documentation for this class was generated from the following file:
  • XTPCalendarEventPropertiesDlg.h


Toolkit Pro: CXTPCalendarEventLabels Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPCalendarEventLabels Class Reference

This class is used as a collection of CXTPCalendarEventLabel objects. More...

Inheritance diagram for CXTPCalendarEventLabels:
[legend]

Public Member Functions

CXTPCalendarEventLabels ()
Default class constructor.
virtual | ~CXTPCalendarEventLabels ()
Default class destructor.
virtual void | InitDefaultValues ()
This member function is used to fill the collection using a default label list.
void | UpdateDefaultValues (COLORREF *clrEventColors, UINT uCount)
This member function updates the default colors of labels when the theme is changed.
void | SetDefaultValues (BOOL bDefault)
Call this member function to set a flag indicating that custom labels are defined.
CXTPCalendarEventLabel * | Find (int nLabelID) const
This member function is used to search for the label with a specified ID.
- Public Member Functions inherited from CXTPCalendarPtrCollectionT< CXTPCalendarEventLabel >
CXTPCalendarPtrCollectionT ()
Default collection constructor.
virtual | ~CXTPCalendarPtrCollectionT ()
Default collection destructor.
virtual int | GetCount () const
This member function is used to obtain the number of elements in the collection.
virtual void | Add (CXTPCalendarEventLabel *pNewElement)
This member function adds a new element to the end of the array.
virtual void | Add (CXTPCalendarEventLabel *pNewElement, BOOL bWithAddRef)
This member function adds a new element to the end of the array.
virtual void | SetAt (int nIndex, CXTPCalendarEventLabel *pElement)
This member function is used to set a new element to the position specified in the nIndex parameter.
virtual int | Find (const CXTPCalendarEventLabel *pElement) const
This member function finds an element index in the collection using its pointer.
virtual void | InsertAt (int nIndex, CXTPCalendarEventLabel *pElement)
This member function is used to insert a new element at the position specified in the nIndex parameter.
virtual void | Append (const CXTPCalendarPtrCollectionT< CXTPCalendarEventLabel > *pElementsArray)
This member function is used to add a new elements to the end of the array.
virtual void | SetSize (int nNewSize)
This member function is used to change the array size.
virtual CXTPCalendarEventLabel * | GetAt (int nIndex) const
This member function returns an element at the specified numeric index.
virtual CXTPCalendarEventLabel * | GetAt (int nIndex, BOOL bWithAddRef) const
This member function returns an element at the specified numeric index.
virtual void | RemoveAt (int nIndex)
This member function removes an element at the specified index from the array.
virtual void | Remove (CXTPCalendarEventLabel *pElement)
This member function finds an element using its pointer and removes it from the array.
virtual void | RemoveAll ()
This member function is used to remove all of the elements from the array.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

int FindIndex (int nLabelID) const
Finds label index in the internal array by its ID.

Protected Attributes

BOOL | m_bDefaultValues
Set to FALSE when using custom values.
- Protected Attributes inherited from CXTPCalendarPtrCollectionT< CXTPCalendarEventLabel >
CArray< TObjectPtr, TObjectPtr & > | m_arElements
Objects storage.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Types inherited from CXTPCalendarPtrCollectionT< CXTPCalendarEventLabel >
typedef CXTPSmartPtrInternalT< CXTPCalendarEventLabel > | TObjectPtr
Smart pointer type for stored objects.

Detailed Description

This class is used as a collection of CXTPCalendarEventLabel objects.

See also
CXTPCalendarEventLabel
CXTPCalendarEvent

Constructor & Destructor Documentation

◆ ~CXTPCalendarEventLabels()

virtual ~CXTPCalendarEventLabels ( )
virtual

Default class destructor.

Handles class members deallocation.

Member Function Documentation

◆ Find()

CXTPCalendarEventLabel * Find ( int nLabelID ) const

This member function is used to search for the label with a specified ID.

Parameters
nLabelID An int that contains the label ID.
Returns
A pointer to a CXTPCalendarEventLabel object or NULL.

◆ FindIndex()

int FindIndex ( int nLabelID ) const
protected

Finds label index in the internal array by its ID.

Parameters
nLabelID Label ID.
Returns
Label index in the internal label array.
See also
Find

◆ SetDefaultValues()

void SetDefaultValues ( BOOL bDefault )

Call this member function to set a flag indicating that custom labels are defined.

Parameters
bDefault Set to FALSE when using custom values.

◆ UpdateDefaultValues()

void UpdateDefaultValues | ( | COLORREF * | clrEventColors,
 |  | UINT | uCount )

This member function updates the default colors of labels when the theme is changed.

Parameters
clrEventColors | An array of colors.
uCount | Number of items in the array above.
The documentation for this class was generated from the following file:
  • XTPCalendarEventLabel.h


Toolkit Pro: CXTPCalendarEventPropertiesDlg Class Reference

Public Member Functions | Public Attributes | Protected Member Functions | Protected Attributes | List of all members
CXTPCalendarEventPropertiesDlg Class Reference

This class is used to edit calendar event properties. More...

Public Member Functions

CXTPCalendarEventPropertiesDlg (CXTPCalendarControl *pControl, BOOL bAddEvent, CWnd *pParent=NULL, CXTPCalendarEvent *pEditingEvent=NULL, UINT nIDTemplate=CXTPCalendarEventPropertiesDlg::IDD, COleDateTime dtInitial=COleDateTime::GetCurrentTime())
Constructor with extra COleDateTime parameter - initial Dialog setting - user can change it if needed.
virtual ~CXTPCalendarEventPropertiesDlg ()
Default object destructor.

Public Attributes

BOOL | m_bOccurrence
If TRUE the not recurring event or recurrence exception (ocurrence) is editing, otherwise master event is editing.
BOOL | m_bRecurrenceUpdate
Flag to force update event if recurrence dialog used.

Protected Member Functions

virtual void | UpdateControlsFromEvent ()
Update dialog controls values using editing event properties.
virtual void | UpdateControlsState ()
Update dialog controls state (enabled and visible) using editing event properties.
virtual void | InitReminderComboBox ()
Initialize Reminder combobox.

Protected Attributes

CXTPCalendarEventPtr | m_ptrEditingEvent
Pointer to editing event object.
CXTPCalendarControl * m_ptrControl
Pointer to Calendar control.
CWnd * | m_pOwnerWnd
Pointer to Owner Wnd.
BOOL | m_bAddEvent
Store edit mode: Add or Change.
DWORD | m_dNewEventID
Successfully added Event ID.
BOOL | m_bHScrollEnabled
Tells whether the horizontal scrollbar is enabled or not.
BOOL | m_bVScrollEnabled
Tells whether the vertical scrollbar is enabled or not.
CString | m_strSubject
Store subject editor value.
CString | m_strLocation
Store location editor value.
CString | m_strBody
Store body editor value.
COleDateTime | m_dtStartDate
Store StartDate editor value.
COleDateTime | m_dtStartTime
Store StartTime editor value.
COleDateTime | m_dtEndDate
Store EndDate editor value.
COleDateTime | m_dtEndTime
Store EndTime editor value.
int | m_nBusyStatus
Store BusyStatus checkbox value.
BOOL | m_bAllDayEvent
Store AllDayEvent checkbox value.
BOOL | m_bPrivate
Store Private checkbox value.
BOOL | m_bMeeting
Store Meeting checkbox value.
BOOL | m_bReminder
Store Reminder checkbox value.
int | m_nAllDayEventSet
If value < 0 - AllDayEvent control initialized from editing event, otherwise it is initialized from m_nAllDayEventSet value.
CXTPCalendarEventCategoryComboBox | m_wndCategoryCombo
Categories combobox control instance.
CXTPCalendarEventLabelComboBox | m_wndLabelCombo
Label combobox control instance.
CComboBox | m_wndReminderCombo
Reminder combobox control instance.
CXTPCalendarBusyStatusComboBox | m_wndBusyStatusCombo
BusyStatus combobox control instance.
CComboBox | m_ctrlScheduleIDCB
ScheduleID combobox control instance.
CStatic | m_ctrlScheduleLabel
Label window for ScheduleID combobox control.
CCheckListBox | m_ctrlScheduleSet
for MultipleSchedules support

Detailed Description

This class is used to edit calendar event properties.

This is a default implementation which can be used as either an example or as a base class for custom dialogs. It is designed to be localized; XTPResourceManager is used to load resources.

See also
CXTPCalendarEventRecurrenceDlg

Constructor & Destructor Documentation

◆ CXTPCalendarEventPropertiesDlg()

CXTPCalendarEventPropertiesDlg | ( | CXTPCalendarControl * | pControl,
 |  | BOOL | bAddEvent,
 |  | CWnd * | pParent = NULL,
 |  | CXTPCalendarEvent * | pEditingEvent = NULL,
 |  | UINT | nIDTemplate = CXTPCalendarEventPropertiesDlg::IDD,
 |  | COleDateTime | dtInitial = COleDateTime::GetCurrentTime() )

Constructor with extra COleDateTime parameter - initial Dialog setting - user can change it if needed.

Parameters
pControl | Pointer to CXTPCalendarControl.
bAddEvent | BOOL flag to add event (if TRUE) or modify existing (if FALSE).
pParent | Parent CWnd*.
pEditingEvent | Pointer to passed event.
nIDTemplate | Dialog resource template ID.
dtInitial | Initial datetime passed.

Member Function Documentation

◆ InitReminderComboBox()

virtual void InitReminderComboBox ( )
protectedvirtual

Initialize Reminder combobox.

Time duration formatted using active resource file.

Member Data Documentation

◆ m_bAddEvent

BOOL m_bAddEvent
protected

Store edit mode: Add or Change.

◆ m_bAllDayEvent

BOOL m_bAllDayEvent
protected

Store AllDayEvent checkbox value.

UpdateData method used to Exchange value with dialog control.

◆ m_bMeeting

BOOL m_bMeeting
protected

Store Meeting checkbox value.

UpdateData method used to Exchange value with dialog control.

◆ m_bPrivate

BOOL m_bPrivate
protected

Store Private checkbox value.

UpdateData method used to Exchange value with dialog control.

◆ m_bReminder

BOOL m_bReminder
protected

Store Reminder checkbox value.

UpdateData method used to Exchange value with dialog control.

◆ m_bVScrollEnabled

BOOL m_bVScrollEnabled
protected

Tells whether the vertical scrollbar is enabled or not.

◆ m_dNewEventID

DWORD m_dNewEventID
protected

Successfully added Event ID.

◆ m_dtEndDate

COleDateTime m_dtEndDate
protected

Store EndDate editor value.

UpdateData method used to Exchange value with dialog control.

◆ m_dtEndTime

COleDateTime m_dtEndTime
protected

Store EndTime editor value.

UpdateData method used to Exchange value with dialog control.

◆ m_dtStartDate

COleDateTime m_dtStartDate
protected

Store StartDate editor value.

UpdateData method used to Exchange value with dialog control.

◆ m_dtStartTime

COleDateTime m_dtStartTime
protected

Store StartTime editor value.

UpdateData method used to Exchange value with dialog control.

◆ m_nBusyStatus

int m_nBusyStatus
protected

Store BusyStatus checkbox value.

UpdateData method used to Exchange value with dialog control.

◆ m_pOwnerWnd

CWnd* m_pOwnerWnd
protected

Pointer to Owner Wnd.

◆ m_ptrControl

CXTPCalendarControl* m_ptrControl
protected

Pointer to Calendar control.

◆ m_ptrEditingEvent

CXTPCalendarEventPtr m_ptrEditingEvent
protected

Pointer to editing event object.

◆ m_strBody

CString m_strBody
protected

Store body editor value.

UpdateData method used to Exchange value with dialog control.

◆ m_strLocation

CString m_strLocation
protected

Store location editor value.

UpdateData method used to Exchange value with dialog control

◆ m_strSubject

CString m_strSubject
protected

Store subject editor value.

UpdateData method used to Exchange value with dialog control.

The documentation for this class was generated from the following file:
  • XTPCalendarEventPropertiesDlg.h


Toolkit Pro: CXTPCalendarEventRecurrenceDlg Class Reference

Public Member Functions | Public Attributes | Protected Member Functions | Protected Attributes | List of all members
CXTPCalendarEventRecurrenceDlg Class Reference

This class is used for manipulations with recurrence state of the events. More...

Public Member Functions

CXTPCalendarEventRecurrenceDlg (CXTPCalendarEvent *pMasterEvent, CWnd *pParent=NULL, UINT nIDTemplate=CXTPCalendarEventRecurrenceDlg::IDD)
Dialog class constructor.
virtual ~CXTPCalendarEventRecurrenceDlg ()
Default collection destructor.

Public Attributes

BOOL | m_bDisableRemove
Set TRUE to disable button remove recurrence.
int | nWorkWeekMask
This structure member represents week working days using XTPCalendarWeekDay enumeration.

Protected Member Functions

virtual void | InitStartEndCB ()
Initialize data for Start and End combobox controls.
virtual void | InitDurationCB ()
Initialize data for Duration combobox control.
virtual void | InitDayOfWeekCBs (CComboBox &wndCB)
Initialize data for days of week names.
virtual void | InitMonthCBs (CComboBox &wndCB)
Initialize data for months names.
virtual void | InitWhichDayCBs (CComboBox &wndCB)
Initialize data for which day (First, Second, ...).
virtual void | MsgBox_WrongValue (CWnd *pWnd)
Shows error message if the user's input is incorrect.
virtual void | MsgBox_WrongValueRange (UINT nCtrlID, int nMin, int nMax)
Shows error message if the user's input is incorrect.

Protected Attributes

CXTPCalendarEventPtr | m_ptrMasterEvent
Pointer to master event

CXTPCalendarRecurrencePatternPtr | m_ptrPattern
recurrence pattern

COleDateTime | m_dtStart
Store StartTime editor value.
COleDateTime | m_dtEnd
Store EndTime editor value.
COleDateTime | m_dtStartDate
Store StartDate editor value.
COleDateTime | m_dtEndDate
Store EndDate editor value.
CComboBox | m_wndCbStart
StartTime combobox object.
CComboBox | m_wndCbEnd
EndTime combobox object.
CComboBox | m_wndCbDuration
Duration combobox object.
int | m_nOccurNum
Store Number of occurrences editor value.
int | m_nDayInterval
Daly recurrence case.
int | m_nWeeklyInterval
Weekly recurrence case.
BOOL | m_bMonday
Store Monday checkbox state.
BOOL | m_bTuesday
Store Tuesday checkbox state.
BOOL | m_bWednesday
Store Wednesday checkbox state.
BOOL | m_bThursday
Store Thursday checkbox state.
BOOL | m_bFriday
Store Friday checkbox state.
BOOL | m_bSaturday
Store Saturday checkbox state.
BOOL | m_bSunday
Store Sunday checkbox state.
int | m_MonthDate
Monthly recurrence case.
int | m_nMonthInterval
Store month interval editor value.
int | m_nMonthInterval2
Store month interval editor value (for second case).
CComboBox | m_wndCbMonthDay
Day of week combobox object for monthly recurrence.
CComboBox | m_wndCbMonthWhich
Which Day combobox object for monthly recurrence.
int | m_nDayOfMonth
Yearly recurrence case.
CComboBox | m_wndYearMonth
Month combobox object for Yearly recurrence.
CComboBox | m_wndComboYearMonth2
Month combobox object for Yearly recurrence (for second case).
CComboBox | m_wndCbYearWhich
Which Day combobox object for Yearly recurrence.
CComboBox | m_wndCbYearDay
Day of week combobox object for Yearly recurrence.

Detailed Description

This class is used for manipulations with recurrence state of the events.

See also
CXTPCalendarEventPropertiesDlg

Constructor & Destructor Documentation

◆ CXTPCalendarEventRecurrenceDlg()

CXTPCalendarEventRecurrenceDlg | ( | CXTPCalendarEvent * | pMasterEvent,
 |  | CWnd * | pParent = NULL,
 |  | UINT | nIDTemplate = CXTPCalendarEventRecurrenceDlg::IDD )

Dialog class constructor.

Parameters
pMasterEvent | [in] Master event pointer to edit recurrence.
pParent | [in] Pointer to parent window. Can be NULL.
nIDTemplate | [in] Contains the ID number of a dialog-box template resource.
See also
~CXTPCalendarEventRecurrenceDlg()

Member Function Documentation

◆ InitDayOfWeekCBs()

virtual void InitDayOfWeekCBs ( CComboBox & wndCB )
protectedvirtual

Initialize data for days of week names.

Parameters
wndCB A CComboBox object reference to set data.

Values formatted using active locale.

◆ InitDurationCB()

virtual void InitDurationCB ( )
protectedvirtual

Initialize data for Duration combobox control.

Time duration formatted using active resource file.

◆ InitMonthCBs()

virtual void InitMonthCBs ( CComboBox & wndCB )
protectedvirtual

Initialize data for months names.

Parameters
wndCB A CComboBox object reference to set data.

Values formatted using active resource file.

◆ InitStartEndCB()

virtual void InitStartEndCB ( )
protectedvirtual

Initialize data for Start and End combobox controls.

Time formatted using active locale.

◆ InitWhichDayCBs()

virtual void InitWhichDayCBs ( CComboBox & wndCB )
protectedvirtual

Initialize data for which day (First, Second, ...).

Parameters
wndCB - A CComboBox object reference to set data.

Values formatted using active resource file.

◆ MsgBox_WrongValue()

virtual void MsgBox_WrongValue ( CWnd * pWnd )
protectedvirtual

Shows error message if the user's input is incorrect.

Parameters
pWnd A pointer to control with wrong value (to set focus).

Message formatted using active resource file.

◆ MsgBox_WrongValueRange()

virtual void MsgBox_WrongValueRange | ( | UINT | nCtrlID,
 |  | int | nMin,
 |  | int | nMax )
 protectedvirtual

Shows error message if the user's input is incorrect.

Parameters
nCtrlID | A dialog control ID with wrong value (to set focus).
nMin | A minimum value of allowed range.
nMax | A maximum value of allowed range.

Message formatted using active resource file.

Member Data Documentation

◆ m_bDisableRemove

BOOL m_bDisableRemove

Set TRUE to disable button remove recurrence.

FALSE by default.

◆ m_bFriday

BOOL m_bFriday
protected

Store Friday checkbox state.

UpdateData method used to Exchange value with dialog control.

◆ m_bMonday

BOOL m_bMonday
protected

Store Monday checkbox state.

UpdateData method used to Exchange value with dialog control.

◆ m_bSaturday

BOOL m_bSaturday
protected

Store Saturday checkbox state.

UpdateData method used to Exchange value with dialog control.

◆ m_bSunday

BOOL m_bSunday
protected

Store Sunday checkbox state.

UpdateData method used to Exchange value with dialog control.

◆ m_bThursday

BOOL m_bThursday
protected

Store Thursday checkbox state.

UpdateData method used to Exchange value with dialog control.

◆ m_bTuesday

BOOL m_bTuesday
protected

Store Tuesday checkbox state.

UpdateData method used to Exchange value with dialog control.

◆ m_bWednesday

BOOL m_bWednesday
protected

Store Wednesday checkbox state.

UpdateData method used to Exchange value with dialog control.

◆ m_dtEndDate

COleDateTime m_dtEndDate
protected

Store EndDate editor value.

UpdateData method used to Exchange value with dialog control.

◆ m_dtStartDate

COleDateTime m_dtStartDate
protected

Store StartDate editor value.

UpdateData method used to Exchange value with dialog control.

◆ m_MonthDate

int m_MonthDate
protected

Monthly recurrence case.

Store month day editor value. UpdateData method used to Exchange value with dialog control.

◆ m_nDayInterval

int m_nDayInterval
protected

Daly recurrence case.

Store days interval editor value. UpdateData method used to Exchange value with dialog control.

◆ m_nDayOfMonth

int m_nDayOfMonth
protected

Yearly recurrence case.

Store month day editor value for Yearly recurrence. UpdateData method used to Exchange value with dialog control.

◆ m_nMonthInterval

int m_nMonthInterval
protected

Store month interval editor value.

UpdateData method used to Exchange value with dialog control.

◆ m_nMonthInterval2

int m_nMonthInterval2
protected

Store month interval editor value (for second case).

UpdateData method used to Exchange value with dialog control.

◆ m_nOccurNum

int m_nOccurNum
protected

Store Number of occurrences editor value.

UpdateData method used to Exchange value with dialog control.

◆ m_nWeeklyInterval

int m_nWeeklyInterval
protected

Weekly recurrence case.

Store weeks interval editor value. UpdateData method used to Exchange value with dialog control.

◆ m_wndCbEnd

CComboBox m_wndCbEnd
protected

EndTime combobox object.

The documentation for this class was generated from the following file:
  • XTPCalendarEventRecurrenceDlg.h


Toolkit Pro: CXTPCalendarEvents Class Reference

Public Types | Public Member Functions | Static Public Member Functions | Protected Attributes | List of all members
CXTPCalendarEvents Class Reference

This class represents a simple array collection of CXTPCalendarEvent objects. More...

Inheritance diagram for CXTPCalendarEvents:
[legend]

Public Types

typedef int(AFX_CDECL *) T_CompareFunc(const CXTPCalendarEvent **ppEv1, const CXTPCalendarEvent **ppEv2)
Define a function pointer for comparing events.

Public Member Functions

CXTPCalendarEvents ()
Default collection constructor.
virtual | ~CXTPCalendarEvents ()
Default collection destructor.
void | Add (CXTPCalendarEvent *pNewEvent, BOOL bWithAddRef=TRUE)
This member function is used to add a new event element to the end of an array.
void | Append (CXTPCalendarEvents *pEventsArray)
Adds a new events element to the end of an array.
CXTPCalendarEvent * | GetAt (int nIndex, BOOL bWithAddRef=FALSE) const
Call this method to get an event at the specified numeric index.
void | SetAt (int nIndex, CXTPCalendarEvent *pEvent, BOOL bWithAddRef=TRUE)
This member function is used to set a new event element to the position specified in the nIndex parameter.
void | InsertAt (int nIndex, CXTPCalendarEvent *pEvent, BOOL bWithAddRef=TRUE)
Inserts an element at a specified index.
void | RemoveAt (int nIndex)
Removes an element of the specified index from this array.
int | GetCount () const
This member function is used to obtain the number of CXTPCalendarEvent elements in this collection.
void | SetSize (int nNewSize, int nGrowBy=-1)
Set size of the array.
void | RemoveAll ()
This function is used to remove all of the elements from this array.
int | Find (CXTPCalendarEvent *pFEvent) const
This method is used to find an event using the EventID in this array.
int | Find (DWORD dwEventID) const
This method is used to find an event using the EventID in this array.
CXTPCalendarEvent * | FindEvent (DWORD dwEventID) const
This member function is used to find an event using the EventID in this array.
CXTPCalendarEvent * | FindEvent (CXTPCalendarEvent *pFEvent) const
This member function is used to find an event using the EventID in this array.
BOOL | RemoveByID (DWORD dwEventID)
This member function is used to find and remove an event using the EventID in this array.
void | CloneEvents ()
Clone events in the collection.
void | Sort (T_CompareFunc pCompareFunc)
This member function is used to sort events in this array.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Static Public Member Functions

static int AFX_CDECL | CompareEvents_ForView (const CXTPCalendarEvent **ppEv1, const CXTPCalendarEvent **ppEv2)
This member function is used to compare specified events so that the events are displayed properly in the event's views.
static int AFX_CDECL | CompareEvents_ForViewByStart (const CXTPCalendarEvent **ppEv1, const CXTPCalendarEvent **ppEv2)
This member function is used to compare specified events so that the events are displayed properly in the event's views.
static int AFX_CDECL | CompareEvents_ByID (const CXTPCalendarEvent **ppEv1, const CXTPCalendarEvent **ppEv2)
This member function is used to compare specified events by the event's IDs.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Protected Attributes

CArray< CXTPCalendarEvent *, CXTPCalendarEvent * > m_arEvents
An internal storage for CXTPCalendarEvent pointers.

Detailed Description

This class represents a simple array collection of CXTPCalendarEvent objects.

Array indexes always start at position 0.

As with a C array, the access time for an indexed element of this array is constant and is independent of the array size.

Methods Add(), SetAt(), and Append() call InternalAddRef() for the added event. Methods Get(), and Find() do not call InternalAddRef() for the returned event. Methods RemoveAt(), RemoveBy(), RemoveAll(), and the destructor call InternalRelease() for the removed events.

See also
CArray overview
CXTPCalendarEvent overview

Member Typedef Documentation

◆ T_CompareFunc

int(AFX_CDECL *) T_CompareFunc(const CXTPCalendarEvent **ppEv1, const CXTPCalendarEvent **ppEv2)

Define a function pointer for comparing events.

Parameters
ppEv1 | Pointer to calender event pointer(first event).
ppEv2 | Pointer to calender event pointer(second event).

This function pointer is used in the Sort method.

See also
Sort method
CompareEvents_ForView function
CompareEvents_ByID function

Constructor & Destructor Documentation

◆ CXTPCalendarEvents()

CXTPCalendarEvents ( )

Default collection constructor.

See also
~CXTPCalendarEvents()

◆ ~CXTPCalendarEvents()

virtual ~CXTPCalendarEvents ( )
virtual

Default collection destructor.

Handles member item deallocation. Decreases reference of all stored CXTPCalendarEvent objects.

See also
RemoveAll()

Member Function Documentation

◆ Add()

void Add | ( | CXTPCalendarEvent * | pNewEvent,
 |  | BOOL | bWithAddRef = TRUE )

This member function is used to add a new event element to the end of an array.

Parameters
pNewEvent | The event element to add to this array.
bWithAddRef | If this parameter is TRUE, then InternalAddRef() is called for the pNewEvent, otherwise InternalAddRef() is not called. The default value is TRUE.

Use this method to add the specified event pointer to the end of the events collection. Reference to the new object is increased or decreased depending on the value of the bWithAddRef parameter.

Example:

// CXTPCalendarEvents - derived class
CXTPCalendarEvents* pList = new CXTPCalendarEvents();
CXTPCalendarEventPtr ptrEvent1 = new CXTPCalendarEvent()

// Add() will call InernalAddRef()
pList->Add(ptrEvent1);

// Add() will not call InernalAddRef()
pList->Add(new CXTPCalendarEvent(), FALSE);

// GetAt() will call InernalAddRef()
CXTPCalendarEventPtr ptrEvent0 = pList->GetAt(0, TRUE);

// GetAt() will not call InernalAddRef()
CXTPCalendarEvent* pEvent1 = pList->GetAt(1);

_ASSERTE(2 == pList->GetCount());

//RemoveAll() will call InernalRelease() for all objects
pList->RemoveAll();

_ASSERTE(0 == pList->GetCount());
See also
GetAt
RemoveAll
GetCount
CXTPCalendarEvents overview
CXTPCalendarEvent overview

◆ Append()

void Append ( CXTPCalendarEvents * pEventsArray )

Adds a new events element to the end of an array.

Parameters
pEventsArray The pointer to the collection of event elements to add to this array.

Use this method to add event elements from the specified array to the end of the events collection. Reference to the new object is increased by default. This depends on the array constructor parameter. See array constructor CXTPCalendarEvents(BOOL bWithAddRefRelease = TRUE);

Example:

// CXTPCalendarEvents - derived class
CXTPCalendarEvents arEvents1;
CXTPCalendarEventsPtr ptrEvents2 = new CXTPCalendarEvents();
...
ptrEvents2->Append(&arEvents1);
See also
CXTPCalendarEvents overview
GetAt
RemoveAll
GetCount
constructor CXTPCalendarEvents
CXTPCalendarEvents overview
CXTPCalendarEvents overview
CXTPCalendarEvent overview
CXTPCalendarEvent overview

◆ CloneEvents()

void CloneEvents ( )

Clone events in the collection.

This function pointer is used to replace events objects to their clones. If there is not enough memory to clone some events, they are removed from the collection.

See also
CXTPCalendarEvent::CloneEvent()

◆ CompareEvents_ByID()

static int AFX_CDECL CompareEvents_ByID | ( | const CXTPCalendarEvent ** | ppEv1,
 |  | const CXTPCalendarEvent ** | ppEv2 )
 static

This member function is used to compare specified events by the event's IDs.

Parameters
ppEv1 | Pointer to the first event pointer.
ppEv2 | Pointer to the second event pointer.

This function is used as a parameter for the Sort method to sort events using EventIDs in ascending order. This is useful for performing a fast search for an event ID.

Example: See example for CXTPCalendarEvents::Sort method.

Returns
0 if Event1 == Event2; 1 if Event1 > Event2; -1 if Event1 < Event2.
See also
method CXTPCalendarEvents::Sort overview
CompareEvents_ForView function

◆ CompareEvents_ForView()

static int AFX_CDECL CompareEvents_ForView | ( | const CXTPCalendarEvent ** | ppEv1,
 |  | const CXTPCalendarEvent ** | ppEv2 )
 static

This member function is used to compare specified events so that the events are displayed properly in the event's views.

Parameters
ppEv1 | Pointer to the first event pointer.
ppEv2 | Pointer to the second event pointer.

This function is used as a parameter for the Sort method to sort events in the order needed to display the events in the event's views.

Example: See example for CXTPCalendarEvents::Sort method.

Returns
0 if Event1 == Event2; 1 if Event1 > Event2; -1 if Event1 < Event2.

◆ CompareEvents_ForViewByStart()

static int AFX_CDECL CompareEvents_ForViewByStart | ( | const CXTPCalendarEvent ** | ppEv1,
 |  | const CXTPCalendarEvent ** | ppEv2 )
 static

This member function is used to compare specified events so that the events are displayed properly in the event's views.

An extra function for sort.

Parameters
ppEv1 | Pointer to the first event pointer.
ppEv2 | Pointer to the second event pointer.

This function is used as a parameter for the Sort method to sort events in the order needed to display the events in the event's views.

Example: See example for CXTPCalendarEvents::Sort method.

Returns
0 if Event1 == Event2; 1 if Event1 > Event2; -1 if Event1 < Event2.

◆ Find() [1/2]

int Find ( CXTPCalendarEvent * pFEvent ) const

This method is used to find an event using the EventID in this array.

Parameters
pFEvent A pointer to a CXTPCalendarEvent object that contains the event object.

When using dwEventID - This method searches this collection for the first match of an event object with event ID equal to dwEventID. When using pFEvent - This method searches this collection for the first match of an event object with identifiers equal to identifiers of the pFEvent. If there are no recurrence events, then these are Event IDs. For recurrence events, then these are RecurrencePatternID, Start/End times, or RException_StartTimeOrig/RException_EndTimeOrig. For details see implementation CXTPCalendarEvent::IsEqualIDs().

Example:

// CXTPCalendarEvents - derived class
CXTPCalendarEvents arEvents;
CXTPCalendarEvent* pEvent;
...
if (arEvents.Find(pEvent->GetEventID()) < 0) {
   arEvents.Add(pEvent);
}
Returns
The zero-based index of the first event in the collection that matches the requested dwEventID. -1 if the event is not found.
See also
CXTPCalendarEvents overview
constructor CXTPCalendarEvents
CXTPCalendarEvents overview
CXTPCalendarEvents overview
CXTPCalendarEvent overview
CXTPCalendarEvent overview

◆ Find() [2/2]

int Find ( DWORD dwEventID ) const

This method is used to find an event using the EventID in this array.

Parameters
dwEventID A DWORD that contains the unique event ID.

When using dwEventID - This method searches this collection for the first match of an event object with event ID equal to dwEventID. When using pFEvent - This method searches this collection for the first match of an event object with identifiers equal to identifiers of the pFEvent. If there are no recurrence events, then these are Event IDs. For recurrence events, then these are RecurrencePatternID, Start/End times, or RException_StartTimeOrig/RException_EndTimeOrig. For details see implementation CXTPCalendarEvent::IsEqualIDs().

Example:

// CXTPCalendarEvents - derived class
CXTPCalendarEvents arEvents;
CXTPCalendarEvent* pEvent;
...
if (arEvents.Find(pEvent->GetEventID()) < 0) {
   arEvents.Add(pEvent);
}
Returns
The zero-based index of the first event in the collection that matches the requested dwEventID. -1 if the event is not found.
See also
CXTPCalendarEvents overview
constructor CXTPCalendarEvents
CXTPCalendarEvents overview
CXTPCalendarEvents overview
CXTPCalendarEvent overview
CXTPCalendarEvent overview

◆ FindEvent() [1/2]

CXTPCalendarEvent * FindEvent ( CXTPCalendarEvent * pFEvent ) const

This member function is used to find an event using the EventID in this array.

Parameters
pFEvent A CXTPCalendarEvent pointer that contains the event object to compare.

When using dwEventID - This method searches this collection for the first match of a event object with event ID equal to dwEventID. Reference to the returned object is not increased. When using pFEvent - This method searches this collection for the first match of an event object with identifiers equal to identifiers of the pFEvent. In the case of no recurrence events these are EventIDs. In the case of recurrence events these are RecurrencePatternIDs, Start/End times or RException_StartTimeOrig/RException_EndTimeOrig. For details see implementation CXTPCalendarEvent::IsEqualIDs() Reference to the returned object is not increased by default.

Example:

// CXTPCalendarEvents - derived class
CXTPCalendarEvents arEvents;
CXTPCalendarEvent* pEvent;
...
CXTPCalendarEvent* pEvent2;
pEvent2 = arEvents.Find(pEvent->GetEventID());
if (pEvent2) {
   pEvent2.Update(pEvent);
}
Returns
The pointer to the first event in the collection that matches the requested dwEventID; NULL if the event is not found.
See also
CXTPCalendarEvents overview
CXTPCalendarEvent overview

◆ FindEvent() [2/2]

CXTPCalendarEvent * FindEvent ( DWORD dwEventID ) const

This member function is used to find an event using the EventID in this array.

Parameters
dwEventID A DWORD that contains the unique event ID.

When using dwEventID - This method searches this collection for the first match of a event object with event ID equal to dwEventID. Reference to the returned object is not increased. When using pFEvent - This method searches this collection for the first match of an event object with identifiers equal to identifiers of the pFEvent. In the case of no recurrence events these are EventIDs. In the case of recurrence events these are RecurrencePatternIDs, Start/End times or RException_StartTimeOrig/RException_EndTimeOrig. For details see implementation CXTPCalendarEvent::IsEqualIDs() Reference to the returned object is not increased by default.

Example:

// CXTPCalendarEvents - derived class
CXTPCalendarEvents arEvents;
CXTPCalendarEvent* pEvent;
...
CXTPCalendarEvent* pEvent2;
pEvent2 = arEvents.Find(pEvent->GetEventID());
if (pEvent2) {
   pEvent2.Update(pEvent);
}
Returns
The pointer to the first event in the collection that matches the requested dwEventID; NULL if the event is not found.
See also
CXTPCalendarEvents overview
CXTPCalendarEvent overview

◆ GetAt()

CXTPCalendarEvent * GetAt | ( | int | nIndex,
 |  | BOOL | bWithAddRef = FALSE ) const

Call this method to get an event at the specified numeric index.

Parameters
nIndex | An integer index that is greater than or equal to 0 and less than the value returned by GetCount.
bWithAddRef | If this parameter is TRUE, the InternalAdRef() will be called for the returned object. Otherwise it will not be called. The default value is FALSE.

Reference to the returned object is increased or not depending on the bWithAddRef parameter. Returns the array element at the specified index.

Example: See example for CXTPCalendarEvents::Add method.

Returns
The pointer to the CXTPCalendarEvent element currently at this index.

◆ GetCount()

AFX_INLINE int GetCount ( ) const

This member function is used to obtain the number of CXTPCalendarEvent elements in this collection.

Call this method to retrieve the number of elements in the array. Because indexes are zero-based, the size is 1 greater than the largest index.

Example: See example for CXTPCalendarEvents::Add method.

Returns
An int that contains the number of items in the collection.
See also
CXTPCalendarEvents overview

◆ InsertAt()

void InsertAt | ( | int | nIndex,
 |  | CXTPCalendarEvent * | pEvent,
 |  | BOOL | bWithAddRef = TRUE )

Inserts an element at a specified index.

Parameters
nIndex | An integer index that is greater than or equal to 0 and may be greater than the value returned by GetCount.
pEvent | Pointer to the event to insert.
bWithAddRef | Set this value to TRUE to increment the reference count of the inserted object, FALSE to insert object without incrementing reference count. Default value is TRUE.

Inserts one element at a specified index in an array. In the process, it shifts up (by incrementing the index) the existing element at this index, and it shifts up all the elements above it.

See also
CXTPCalendarEvents overview

◆ RemoveAll()

void RemoveAll ( )

This function is used to remove all of the elements from this array.

Removes all of the pointers from this array. Reference to removed objects are decreased by default.

Example: See example for CXTPCalendarEvents::Add method.

See also
CXTPCalendarEvents overview

◆ RemoveAt()

void RemoveAt ( int nIndex )

Removes an element of the specified index from this array.

Parameters
nIndex An integer index that is greater than or equal to 0 and less than the value returned by GetCount.

Removes the pointer from this array. Reference to the removed object is decreased by default.

See also
CXTPCalendarEvents overview

◆ RemoveByID()

AFX_INLINE BOOL RemoveByID ( DWORD dwEventID )

This member function is used to find and remove an event using the EventID in this array.

Parameters
dwEventID A DWORD containing a unique event ID.

This method searches this collection for the first match of an event object with the event ID equal to dwEventID and removes the object from the collection.

Example:

// CXTPCalendarEvents - derived class
CXTPCalendarEvents arEvents;
DWORD dwEventIDToRemove;
...
if (arEvents.RemoveByID(dwEventIDToRemove) < 0) {
   ...
}
Returns
TRUE if the event is found and removed. FALSE if the event is not found.
See also
CXTPCalendarEvents overview
constructor CXTPCalendarEvents
CXTPCalendarEvents overview
CXTPCalendarEvents overview
CXTPCalendarEvent overview
CXTPCalendarEvent overview

◆ SetAt()

void SetAt | ( | int | nIndex,
 |  | CXTPCalendarEvent * | pEvent,
 |  | BOOL | bWithAddRef = TRUE )

This member function is used to set a new event element to the position specified in the nIndex parameter.

Parameters
nIndex | An integer index that is greater than or equal to 0 and less than the value returned by GetCount.
pEvent | The event element to add to this array.
bWithAddRef | If this parameter is TRUE, then InternalAddRef() is called for the pEvent object, otherwise InternalAddRef() is not called.

Use this method to set the specified event pointer to the position specified in the nIndex parameter. Reference to the previous object is decreased by default. This depends on the array constructor parameter. See the array constructor CXTPCalendarEvents(BOOL bWithAddRefRelease = TRUE); Reference to the new object is increased or decreased depending on the bWithAddRef parameter.

Example:

// CXTPCalendarEvents - derived class
CXTPCalendarEvents* pList = new CXTPCalendarEvents();
CXTPCalendarEventPtr ptrEvent1 = new CXTPCalendarEvent()

pList->Add(ptrEvent1);
pList->SetAt(0, new CXTPCalendarEvent(), FALSE);
See also
CXTPCalendarEvents overview
constructor CXTPCalendarEvents
CXTPCalendarEvents overview
CXTPCalendarEvents overview
CXTPCalendarEvent overview
CXTPCalendarEvent overview

◆ SetSize()

AFX_INLINE void SetSize | ( | int | nNewSize,
 |  | int | nGrowBy = -1 )

Set size of the array.

Parameters
nNewSize | A new array size (elements count).
nGrowBy | Amount of elements to grow array when Add and InsertAt methods used. -1 (by default) means using default parameter value.
See also
GetCount
RemoveAll

◆ Sort()

void Sort ( T_CompareFunc pCompareFunc )

This member function is used to sort events in this array.

Parameters
pCompareFunc A T_CompareFunc function pointer that is used to compare events.

This method sorts events in this collection using the specified compare events function. The QuickSort algorithm is used.

Example:

CXTPCalendarEvents - derived class
CXTPCalendarEvents arEvents;
...
arEvents.Sort(CompareEvents_ForView);
...
See also
CXTPCalendarEvents overview
CXTPCalendarEvents overview
CXTPCalendarEvents overview
CXTPCalendarEvent overview
CXTPCalendarEvent overview
CompareEvents_ForView function
CompareEvents_ByID function
qsort() function in the stdlib.h
The documentation for this class was generated from the following file:
  • XTPCalendarEvents.h


Toolkit Pro: CXTPCalendarIconIDs Class Reference

Public Member Functions | List of all members
CXTPCalendarIconIDs Class Reference

This class represents the collection of custom icons IDs. More...

Inheritance diagram for CXTPCalendarIconIDs:
[legend]

Public Member Functions

CXTPCalendarIconIDs ()
Default object constructor.
virtual | ~CXTPCalendarIconIDs ()
Default object destructor.
virtual void | DoPropExchange (CXTPPropExchange *pPX)
Call this member function to Store/Load collection data using the specified data object.
virtual void | DoPropExchange (CXTPPropExchange *pPX, LPCTSTR pcszSection, LPCTSTR pcszElement)
Call this member function to Store/Load collection data using the specified data object.
- Public Member Functions inherited from CXTPCalendarUIntArray
int | Find (UINT uID) const
Call this member function to find an ID in the collection.
virtual BOOL | RemoveID (UINT uID)
Call this member function to remove an ID from the collection.
virtual CString | SaveToString () const
Call this member function to store collection data as a comma separated string.
virtual void | LoadFromString (LPCTSTR pcszData)
Call this member function to read collection data from a comma separated string.
- Public Member Functions inherited from CXTPArrayT< UINT, UINT >
CXTPArrayT ()
Default object constructor.
virtual | ~CXTPArrayT ()
Default object destructor.
virtual int | GetSize () const
This member function is used to obtain the number of elements in the collection.
virtual void | SetSize (int nNewSize, int nGrowBy=-1)
This member function is used to change the array size.
virtual UINT | GetAt (int nIndex) const
This member function returns an element at the specified numeric index.
virtual void | SetAt (int nIndex, UINT newElement)
This member function is used to set a new element to the position specified in the nIndex parameter.
virtual UINT & | ElementAt (int nIndex)
This member function returns a reference to element at the specified numeric index.
virtual const UINT * | GetData () const
This member function is used to Direct Access to the element data.
virtual UINT * | GetData ()
This member function is used to Direct Access to the element data.
virtual void | SetAtGrow (int nIndex, UINT newElement)
This member function is used to set a new element to the position specified in the nIndex parameter.
virtual int | Add (UINT newElement)
This member function adds a new element to the end of the array.
virtual int | Append (const CXTPArrayT &src)
This member function adds the elements from a specified array to the end of this array.
virtual void | Copy (const CXTPArrayT &src)
This member function overwrites the contents of this array with the contents of a specified array.
UINT | operator[] (int nIndex) const
This operator returns the array element at a specified numeric index.
UINT & | operator[] (int nIndex)
This operator returns a reference to the array element at a specified numeric index.
virtual void | InsertAt (int nIndex, UINT newElement, int nCount=1)
This member function is used to insert a number of copies of an element, specified by the nCount parameter, to the array starting at the position specified by the nIndex parameter.
virtual void | InsertAt (int nStartIndex, CXTPArrayT *pNewArray)
This member function is used to insert an array of elements to the array starting at the position specified by the nStartIndex parameter.
virtual void | RemoveAt (int nIndex, int nCount=1)
This member function is used to remove a number of array elements, specified by the nCount parameter, from the array starting at the position specified by the nIndex parameter.
virtual void | RemoveAll ()
This member function is used to remove all array elements from the array.
virtual int | FindElement (UINT nElement) const
Call this member function to find an element in the collection.
virtual void | AddIfNeed (UINT newElement)
Call this member function to add a specified element to the collection if it is not present already.
virtual BOOL | RemoveElement (UINT nElement)
Call this member function to remove all elements with a specified value from the collection.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Public Types inherited from CXTPCalendarUIntArray
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Attributes inherited from CXTPArrayT< UINT, UINT >
CArray< UINT, UINT > | m_arElements
Elements storage.

Detailed Description

This class represents the collection of custom icons IDs.

It also implements some useful operations on custom icons IDs collection.

Constructor & Destructor Documentation

◆ CXTPCalendarIconIDs()

CXTPCalendarIconIDs ( )

Default object constructor.

See also
~CXTPCalendarIconIDs()

◆ ~CXTPCalendarIconIDs()

virtual ~CXTPCalendarIconIDs ( )
virtual

Default object destructor.

See also
CXTPCalendarIconIDs()

Member Function Documentation

◆ DoPropExchange() [1/2]

AFX_INLINE void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Call this member function to Store/Load collection data using the specified data object.

Parameters
pPX Source or destination CXTPPropExchange data object reference.

This member function is used to either store event data to or load event data from storage.

◆ DoPropExchange() [2/2]

virtual void DoPropExchange | ( | CXTPPropExchange * | pPX,
 |  | LPCTSTR | pcszSection,
 |  | LPCTSTR | pcszElement )
 virtual

Call this member function to Store/Load collection data using the specified data object.

Parameters
pPX | Source or destination CXTPPropExchange data object reference.
pcszSection | Section name for elements set.
pcszElement | Element value property name.

This member function is used to either store event data to or load event data from storage.

Reimplemented from CXTPCalendarUIntArray.

The documentation for this class was generated from the following file:
  • XTPCalendarEventLabel.h


Toolkit Pro: CXTPCalendarMemoryDataProvider Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPCalendarMemoryDataProvider Class Reference

This class implements an abstract representation of the data used in the XTPCalendarData class. More...

Inheritance diagram for CXTPCalendarMemoryDataProvider:
[legend]

Public Member Functions

CXTPCalendarMemoryDataProvider ()
Default constructor.
virtual | ~CXTPCalendarMemoryDataProvider ()
Default Destructor.
virtual BOOL | Open ()
Call this member function to initialize a newly constructed Data object.
virtual BOOL | Create ()
Call this member function to create a file for storing memory data provider data.
virtual BOOL | Save ()
This method saves data to the file.
virtual void | Close ()
Call this member function to close the connection to a data source.
virtual CXTPCalendarEventsPtr | RetrieveEvents (COleDateTime dtStartDay, COleDateTime dtEndDay)
Call this member function to get a collection of events for the specified date range.
virtual void | Serialize (CArchive &ar)
This method reads data from or writes data to an archive.
virtual void | DoPropExchange (CXTPPropExchange *pPX)
This method reads data from or writes data to storage.
- Public Member Functions inherited from CXTPCalendarData
CXTPCalendarData ()
Default constructor.
virtual | ~CXTPCalendarData ()
Default Destructor.
virtual BOOL | IsOpen () const
This method determines whether a data source connection is opened.
virtual XTPCalendarDataProvider | GetType () const
This method determines the type of the current Data Provider implementation.
virtual CXTPCalendarEventsPtr | RetrieveDayEvents (COleDateTime dtDay)
Retrieves day events for a specified day from the data source.
virtual CXTPCalendarEventPtr | CreateNewEvent (DWORD dwEventID=XTP_CALENDAR_UNKNOWN_EVENT_ID)
Creates a new empty CXTPCalendarEvent object.
virtual CXTPCalendarRecurrencePatternPtr | CreateNewRecurrencePattern (DWORD dwPatternID=XTP_CALENDAR_UNKNOWN_RECURRENCE_PATTERN_ID)
Creates a new empty CXTPCalendarRecurrencePattern object.
virtual CXTPCalendarEventPtr | GetEvent (DWORD dwEventID)
Reads an event from the data source.
virtual CXTPCalendarRecurrencePatternPtr | GetRecurrencePattern (DWORD dwPatternID)
Reads a recurrence pattern from the data source.
virtual BOOL | AddEvent (CXTPCalendarEvent *pEvent)
Creates a new event in the data source.
virtual BOOL | AddEvents (CXTPCalendarEvents *pEvents)
Creates a set of events in the data source.
virtual void | RemoveAllEvents ()
Removes all events from the data source.
virtual BOOL | DeleteEvent (CXTPCalendarEvent *pEvent)
Deletes an event from the data source.
virtual BOOL | ChangeEvent (CXTPCalendarEvent *pNewEvent)
Updates event properties in the data source.
virtual CXTPNotifyConnection * | GetConnection () const
Returns a connection pointer for the data source.
virtual CXTPCalendarCustomProperties * | GetCustomProperties () const
Returns a custom properties collection.
virtual CXTPCalendarEventLabels * | GetLabelList () const
Returns a collection of Labels used in this Data source.
virtual CXTPCalendarEventCategories * | GetEventCategories () const
Returns a collection of Event categories.
virtual void | SetLabelList (CXTPCalendarEventLabels *pLabelList)
Set custom collection of Labels to be used in this Data source.
virtual BOOL | AddEventLabel (int nID, CString strName, COLORREF crLabel)
Call this member function to add a new item to the event label list.
virtual BOOL | AddEventCategory (UINT uID, CString strName, COLORREF crBorder, COLORREF crBkBase)
Call this member function to add a new item to the event category list.
virtual void | UpdateEventLabels (COLORREF *clrEventColors, UINT uCount)
Update event labels colors when the theme is changed.
virtual void | ClearEventCategoryList ()
Call this member function to remove all items from the event category list.
virtual void | ClearEventLabelList ()
Call this member function to remove all items from the event label list.
virtual void | RestoreEventCategoryList ()
Call this member function to restore the event category list to default values.
virtual void | RestoreEventLabelList ()
Call this member function to restore the event label list to default values.
void | UpdateEventCategories (COLORREF *pClrBkBase, COLORREF *pClrBorder, int nCount)
This member function updates the default colors of the category list when the theme is changed.
virtual CXTPCalendarSchedules * | GetSchedules () const
Returns a collection of schedules used in this data source.
virtual void | SetConnectionString (LPCTSTR lpszConnectionString)
Sets a data provider connection string.
virtual CString | GetConnectionString () const
Returns a data provider connection string.
virtual CString | GetDataSource ()
Returns a data provider data source.
virtual int | GetCacheMode () const
Determines current cache mode.
virtual void | SetCacheMode (int eCacheMode, CXTPCalendarData *pCacheDataProvider=NULL)
Sets common data provider cache mode.
virtual void | ClearCache ()
Clears common data provider cache.
virtual CXTPCalendarEventsPtr | GetUpcomingEvents (COleDateTime dtFrom=(DATE) 0, COleDateTimeSpan spPeriod=(DATE) 0)
Retrieves a collection of events expiring in the period from dtFrom during next spPeriod.
virtual CXTPCalendarEventsPtr | GetAllEvents_raw ()
This method Gets all events without generating recurrence occurrences.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

virtual BOOL | _Load (CXTPPropExchange *pPX)
This method reads data from an archive.
virtual BOOL | _Save (CXTPPropExchange *pPX)
This method writes data to an archive.
virtual CXTPCalendarEventsPtr | DoRetrieveDayEvents (COleDateTime dtDay)
Retrieves day events for a specified day from the memory storage.
virtual void | DoRemoveAllEvents ()
Removes all events from the memory storage.
virtual CXTPCalendarEventPtr | DoRead_Event (DWORD dwEventID)
Read event from the memory storage.
virtual CXTPCalendarRecurrencePatternPtr | DoRead_RPattern (DWORD dwPatternID)
Read recurrence pattern from the memory storage.
virtual BOOL | DoCreate_Event (CXTPCalendarEvent *pEvent, DWORD &rdwNewEventID)
Creates a new event in the memory storage.
virtual BOOL | DoUpdate_Event (CXTPCalendarEvent *pEvent)
Updates event properties in the memory storage.
virtual BOOL | DoDelete_Event (CXTPCalendarEvent *pEvent)
Deletes an event from the memory storage.
virtual BOOL | DoCreate_RPattern (CXTPCalendarRecurrencePattern *pPattern, DWORD &rdwNewPatternID)
Creates a new recurrence pattern in the memory storage.
virtual BOOL | DoUpdate_RPattern (CXTPCalendarRecurrencePattern *pPattern)
Updates a recurrence pattern in the memory storage.
virtual BOOL | DoDelete_RPattern (CXTPCalendarRecurrencePattern *pPattern)
Deletes a recurrence pattern from the memory storage.
virtual CXTPCalendarEventsPtr | DoGetAllEvents_raw ()
This method implements getting all events from the memory storage without generating recurrence occurrences.
virtual CXTPCalendarEventsPtr | DoGetUpcomingEvents (COleDateTime dtFrom, COleDateTimeSpan spPeriod)
Retrieves a collection of events expiring in the period from dtFrom during next spPeriod.
virtual BOOL | OnTimeZoneChanged ()
This method is called by the calendar control framework when the Time Zone is Changed.
- Protected Member Functions inherited from CXTPCalendarData
virtual void | SendNotification (XTP_NOTIFY_CODE EventCode, WPARAM wParam, LPARAM lParam)
Sends a notification to all listeners.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCalendarData
static CXTPCalendarData *AFX_CDECL | CreateDataProvider (LPCTSTR lpszConnectionString)
Call this method to create a data provider from a specified Calendar connection string.
static CXTPCalendarData *AFX_CDECL | CreateDataProvider (XTPCalendarDataProvider eDataProvider)
Call this method to create a data provider of the specified type.
static XTPCalendarDataProvider AFX_CDECL | DataProviderTypeFromConStr (LPCTSTR lpszConnectionString, XTPCalendarDataProvider eDPDefault=xtpCalendarDataProviderUnknown)
Call this method to retrieve a type of the data provider from its connection string.
static CString AFX_CDECL | DataSourceFromConStr (LPCTSTR lpszConnectionString)
Call this method to retrieve a data source connection string from a regular Calendar connection string.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPCalendarData
- Static Protected Member Functions inherited from CXTPCalendarData
static DWORD AFX_CDECL | GetNextFreeTempID ()
Call this member function to get a unique temporary event ID.
- Protected Attributes inherited from CXTPCalendarData
BOOL | m_bOpened
Stores a flag whether a data source connection is open.
CXTPNotifyConnection * | m_pConnection
Connection object to send notifications.
BOOL | m_bDisableNotificationsSending
Stores a flag whether notifications sending is disabled.
CXTPCalendarEventLabels * | m_pLabelList
Event labels list.
CXTPCalendarSchedules * | m_pSchedules
Data source Schedules list.
CXTPCalendarEventCategories * | m_pEventCategories
Store a collection of Event categories.
CXTPCalendarCustomProperties * | m_pCustomProperties
Custom properties collection object.
CString | m_strConnectionString
default connection string;
XTPCalendarDataProvider | m_typeProvider
Data provider type.
CXTPCalendarOptions * | m_pCalendarOptions
This member stores user's calendar view options.
- Static Protected Attributes inherited from CXTPCalendarData
static DWORD | ms_dwNextFreeTempID
Next unique event ID.

Detailed Description

This class implements an abstract representation of the data used in the XTPCalendarData class.

This class is the implementation of the XTPCalendarData abstract class which represents a data portion of the Calendar control.

 This class provides a memory storage implementation of the
 CXTPCalendarData class. It stores all elements using standard
 CXTPCalendarEvents array collection and provides fast search
 on it using search tree algorithms.

 To use CXTPCalendarMemoryDataProvider, you first construct an instance
 of a CXTPCalendarDatabaseDataProvider object. Then use the Open() member
 function to establish a connection to the data source and initialize the
 object. This class provides a number of functions to manipulate events and
 events related data. After finishing work with the data source, you should
 call the Close() member function to close the connection, de-initialize the
 object and free unused resources.
See also
CXTPCalendarData overview
CXTPCalendarEvents
CXTPCalendarEvent

Constructor & Destructor Documentation

◆ CXTPCalendarMemoryDataProvider()

CXTPCalendarMemoryDataProvider ( )

Default constructor.

Constructs a Data object. To establish a connection to a specified data source and initialize the object you must call the Open() member function immediately after construction.

See also
Open()

◆ ~CXTPCalendarMemoryDataProvider()

virtual ~CXTPCalendarMemoryDataProvider ( )
virtual

Default Destructor.

Handles all deallocation.

Member Function Documentation

◆ _Load()

virtual BOOL _Load ( CXTPPropExchange * pPX )
protectedvirtual

This method reads data from an archive.

Parameters
pPX A CXTPPropExchange object to serialize to or from.

The existing data is not removed from the data provider and new data will be loaded from the specified archive and added to the existing data set. Call RemoveAllEvents() manually if you need a cleanup before load. Method can throw CArchiveException.

Returns
TRUE is successful. FALSE otherwise.
See also
_Save()
Serialize()

◆ _Save()

virtual BOOL _Save ( CXTPPropExchange * pPX )
protectedvirtual

This method writes data to an archive.

Parameters
pPX A CXTPPropExchange object to serialize to or from.

The most recent data from the data provider will be saved to archive. Method can throw CArchiveException.

Returns
TRUE is successful. FALSE otherwise.
See also
_Load()
Serialize()

◆ Create()

virtual BOOL Create ( )
virtual

Call this member function to create a file for storing memory data provider data.

It will be opened by default.

Returns
TRUE is successful. FALSE otherwise.

Reimplemented from CXTPCalendarData.

◆ DoCreate_Event()

virtual BOOL DoCreate_Event | ( | CXTPCalendarEvent * | pEvent,
 |  | DWORD & | rdwNewEventID )
 protectedvirtual

Creates a new event in the memory storage.

Parameters
pEvent | Pointer to the CXTPCalendarEvent object which describes all data fields of a newly created record.
rdwNewEventID | [out] EventID of a newly created record

This method creates a memory data record corresponding with the specified event.

Returns
TRUE if event created successfully, FALSE in case of any error during the process.

Reimplemented from CXTPCalendarData.

◆ DoCreate_RPattern()

virtual BOOL DoCreate_RPattern | ( | CXTPCalendarRecurrencePattern * | pPattern,
 |  | DWORD & | rdwNewPatternID )
 protectedvirtual

Creates a new recurrence pattern in the memory storage.

Parameters
pPattern | Pointer to the CXTPCalendarRecurrencePattern object which describes all data fields of a newly created memory record.
rdwNewPatternID | [out] ID of a newly created memory record

This method creates a memory data record corresponding with the specified recurrence pattern.

Returns
TRUE if recurrence pattern created successfully, FALSE in case of any error during the process.

Reimplemented from CXTPCalendarData.

◆ DoDelete_Event()

virtual BOOL DoDelete_Event ( CXTPCalendarEvent * pEvent )
protectedvirtual

Deletes an event from the memory storage.

Parameters
pEvent Pointer to the CXTPCalendarEvent object which describes all data fields of an event.

This method deletes a memory data record corresponding with the specified event.

Returns
TRUE if an event deleted successfully, FALSE in case of any errors during the process.

Reimplemented from CXTPCalendarData.

◆ DoDelete_RPattern()

virtual BOOL DoDelete_RPattern ( CXTPCalendarRecurrencePattern * pPattern )
protectedvirtual

Deletes a recurrence pattern from the memory storage.

Parameters
pPattern Pointer to the CXTPCalendarRecurrencePattern object which should be deleted.

This method deletes a memory data record corresponding with the specified recurrence pattern.

Returns
TRUE if recurrence pattern deleted successfully, FALSE in case of any error during the process.

Reimplemented from CXTPCalendarData.

◆ DoGetAllEvents_raw()

virtual CXTPCalendarEventsPtr DoGetAllEvents_raw ( )
protectedvirtual

This method implements getting all events from the memory storage without generating recurrence occurrences.

Simple events are included as is. For the recurrence events only master events are included, recurrence occurrences are not generated.

Returns
A CXTPCalendarEvents pointer containing a collection of all events.
See also
GetAllEvents_raw()

Reimplemented from CXTPCalendarData.

◆ DoGetUpcomingEvents()

virtual CXTPCalendarEventsPtr DoGetUpcomingEvents | ( | COleDateTime | dtFrom,
 |  | COleDateTimeSpan | spPeriod )
 protectedvirtual

Retrieves a collection of events expiring in the period from dtFrom during next spPeriod.

Parameters
dtFrom | Start date and time of a specified period.
spPeriod | A duration of a specified period.

This method returns a collection of upcoming events. It is used by a reminders manager.

Returns
A CXTPCalendarEvents pointer containing a collection of upcoming events.
See also
CXTPCalendarRemindersManager overview

Reimplemented from CXTPCalendarData.

◆ DoPropExchange()

virtual void DoPropExchange ( CXTPPropExchange * pPX )
virtual

This method reads data from or writes data to storage.

Parameters
pPX A CXTPPropExchange object to serialize to or from.

For the save case, the most recent data from the data provider will be saved to the archive. For the load case, existing data is not removed from the data provider and new data will be loaded from the specified archive and added to the existing data set. Call RemoveAllEvents() manually if you need a cleanup before load. For load and save operations, the _Load() and _Save() protected methods are used respectfully. Method can throw CArchiveException.

See also
_Load()
_Save()

◆ DoRead_Event()

virtual CXTPCalendarEventPtr DoRead_Event ( DWORD dwEventID )
protectedvirtual

Read event from the memory storage.

Parameters
dwEventID Event ID of the read target.

This method retrieves all data for a specified event.

Returns
A pointer to the new CXTPCalendarEvent object in which fields are filled with a data from the corresponding memory storage.

Reimplemented from CXTPCalendarData.

◆ DoRead_RPattern()

virtual CXTPCalendarRecurrencePatternPtr DoRead_RPattern ( DWORD dwPatternID )
protectedvirtual

Read recurrence pattern from the memory storage.

Parameters
dwPatternID Pattern ID of the read target.

This method retrieves all data for a specified recurrence pattern.

Returns
A pointer to the new CXTPCalendarRecurrencePatternPtr object in which fields are filled with a data from the corresponding memory storage.

Reimplemented from CXTPCalendarData.

◆ DoRemoveAllEvents()

virtual void DoRemoveAllEvents ( )
protectedvirtual

Removes all events from the memory storage.

This method removes all appointments from the memory storage.

Reimplemented from CXTPCalendarData.

◆ DoRetrieveDayEvents()

virtual CXTPCalendarEventsPtr DoRetrieveDayEvents ( COleDateTime dtDay )
protectedvirtual

Retrieves day events for a specified day from the memory storage.

Parameters
dtDay A specified day.

This method retrieves all appointments for a specified day from the memory storage. It includes recurrence appointments occurrences, regular appointments for this day, and multi-day appointments which also have a part of this day.

Returns
A collection of events for a specified day.

Reimplemented from CXTPCalendarData.

◆ DoUpdate_Event()

virtual BOOL DoUpdate_Event ( CXTPCalendarEvent * pEvent )
protectedvirtual

Updates event properties in the memory storage.

Parameters
pEvent Pointer to the CXTPCalendarEvent object which describes all data fields of an event.

This method updates a memory data record corresponding with the specified event.

Returns
TRUE if an event updated successfully, FALSE in case of any errors during the process.

Reimplemented from CXTPCalendarData.

◆ DoUpdate_RPattern()

virtual BOOL DoUpdate_RPattern ( CXTPCalendarRecurrencePattern * pPattern )
protectedvirtual

Updates a recurrence pattern in the memory storage.

Parameters
pPattern Pointer to the CXTPCalendarRecurrencePattern object.

This method updates a memory data record corresponding with the specified recurrence pattern.

Returns
TRUE if recurrence pattern updated successfully, FALSE in case of any error during the process.

Reimplemented from CXTPCalendarData.

◆ OnTimeZoneChanged()

virtual BOOL OnTimeZoneChanged ( )
inlineprotectedvirtual

This method is called by the calendar control framework when the Time Zone is Changed.

The data provider implementation may use this method to adjust its data for a new timezone.

Returns
TRUE if internal data has changed and the calendar must be re-populated, FALSE if this event is ignored (no data changed). Base implementation does nothing and returns FALSE.
See also
CXTPTopLevelWndMsgNotifier
XTP_WM_TIME_ZONE_CHANGED

Reimplemented from CXTPCalendarData.

◆ Open()

virtual BOOL Open ( )
virtual

Call this member function to initialize a newly constructed Data object.

Your data object must be created before you can call Open().

Returns
Boolean value represents succsess/failure result

Reimplemented from CXTPCalendarData.

◆ RetrieveEvents()

virtual CXTPCalendarEventsPtr RetrieveEvents | ( | COleDateTime | dtStartDay,
 |  | COleDateTime | dtEndDay )
 virtual

Call this member function to get a collection of events for the specified date range.

Parameters
dtStartDay | A COleDateTime object without the time portion.
dtEndDay | A COleDateTime object without the time portion.
Returns
A CXTPCalendarEvents pointer containing a collection of day events.
See also
CXTPCalendarEvents

◆ Save()

virtual BOOL Save ( )
virtual

This method saves data to the file.

The most recent data from the data provider will be saved in the same file as before.

Returns
TRUE is successful. FALSE otherwise.

Reimplemented from CXTPCalendarData.

◆ Serialize()

virtual void Serialize ( CArchive & ar )
virtual

This method reads data from or writes data to an archive.

Parameters
ar A CArchive object to serialize to or from.

For the save case, the most recent data from the data provider will be saved to the archive. For the load case, existing data is not removed from the data provider and new data will be loaded from the specified archive and added to the existing data set. Call RemoveAllEvents() manually if you need a cleanup before load. For load and save operations, the _Load() and _Save() protected methods are used respectfully. Method can throw CArchiveException.

See also
_Load()
_Save()
The documentation for this class was generated from the following file:
  • XTPCalendarMemoryDataProvider.h


Toolkit Pro: CXTPCalendarMonthView Class Reference

Classes | Public Types | Public Member Functions | Public Attributes | Protected Member Functions | Protected Attributes | List of all members
CXTPCalendarMonthView Class Reference

This class implements a specific view portion of the Calendar control - called Month view. More...

Inheritance diagram for CXTPCalendarMonthView:
[legend]

Classes

class CMonthViewGrid

Public Types

typedef CXTPCalendarViewT< CXTPCalendarMonthViewDay > TBase

Public Member Functions

CXTPCalendarMonthView (CXTPCalendarControl *pCalendarControl)
Default object constructor.
virtual | ~CXTPCalendarMonthView ()
Default class destructor.
virtual void | Populate ()
This member function is used to populate the view with data for all items contained in the view.
virtual void | AdjustLayout (CDC *pDC, const CRect &rcView, BOOL bCallPostAdjustLayout=TRUE)
This member function is used to adjust the view's layout depending on the window's client size and then calls AdjustLayout() for all sub-items.
virtual void | AdjustLayout2 (CDC *pDC, const CRect &rcView, BOOL bCallPostAdjustLayout=TRUE)
This member function is used to adjust the view's layout depending on the window's client size and then calls AdjustLayout() for all sub-items.
virtual void | ShowDay (const COleDateTime &date, BOOL bSelect=TRUE)
This member function is used to show the specified day in the calendar view.
virtual BOOL | GetScrollBarInfoV (SCROLLINFO *pSI) const
This member function is used to retrieve information about the current scroll bar state.
virtual void | ScrollV (int nPos, int nPos_raw)
This member function is used to scroll the contents of a view.
virtual void | Draw (CDC *pDC)
This member function is used to draw the view content using the specified device context.
virtual void | Draw2 (CDC *pDC)
This member function is used to draw the view content using the specified device context.
virtual int | GetEventCaptionFormat () const
This member function is used to obtain the event caption format flags.
virtual int | GetEventTimeWidth () const
This member function is used to obtain the width necessary to display the event's time.
virtual void | OnMouseMove (UINT nFlags, CPoint point)
This member function is used to processes mouse movement events.
virtual BOOL | OnLButtonDown (UINT nFlags, CPoint point)
This member function is used to process left mouse button events.
virtual void | OnKeyDown (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process keyboard events.
virtual CXTPCalendarViewDay * | GetViewDay_ (int nIndex) const
This member function is used to obtain the view's day object by the given index.
virtual COleDateTime | GetViewDayDate (int nIndex) const
Call this member function to obtain the date of a day view by the day's index.
virtual void | GetWeekDayTextIfNeed (CString *pstrText, int nWeekDay)
This member function is used to obtain week day header text.
CString | _FormatDayDate (COleDateTime dtDay, BOOL bLong)
This member function is used to obtain the format string of a day date.
void | SetLongDayHeaderFormat (LPCTSTR pcszCustomFormat)
Sets the format for Cell's Day Header in Month View.
void | SetSmallDayHeaderFormat (LPCTSTR pcszCustomFormat)
Sets the format for Cell's Day Header in Month View.
CMonthViewGrid * | GetGrid () const
This member function is used to obtain the Month View days grid object.
- Public Member Functions inherited from CXTPCalendarViewT< CXTPCalendarMonthViewDay >
CXTPCalendarViewT (CXTPCalendarControl *pCalendarControl, XTPCalendarViewType nViewType)
Default object constructor.
virtual | ~CXTPCalendarViewT ()
Default class destructor.
virtual XTPCalendarViewType | GetViewType () const
Call this member function to obtain the view type flag.
virtual CXTPCalendarMonthViewDay * | GetViewDay (int nIndex) const
Call this member function to obtain a _TViewDay object corresponding with the day's index.
- Public Member Functions inherited from CXTPCalendarView
UINT | GetDiscreteSelectionCount () const
This member function is used to get the number of selected events.
COleDateTime | GetDiscreteSelectionValue (UINT id) const
This member function gets a selected event by using its event ordinal number.
BOOL | AddToDiscreteSelection (UINT id)
This member function adds an event to the selection by using its event ordinal number.
BOOL | IsInDiscreteSelection (UINT id) const
This member function checks if an event is in the selection.
void | ClearDiscreteSelection ()
This member function is used to Clear Discrete Selection.
CXTPCalendarView (CXTPCalendarControl *pCalendarControl)
Default object constructor.
virtual | ~CXTPCalendarView ()
Default class destructor.
virtual void | RedrawControl ()
This member function is used to perform the redrawing of the control's layout.
virtual void | ScrollH (int nPos, int nPos_raw)
Scroll horizontally.
virtual void | OnScrollEnd (int nBar)
This member function is used to force scroll to the end of the scroll range.
virtual BOOL | GetScrollBarInfoH (SCROLLINFO *pSI, int *pnScrollStep=NULL) const
This member function is used to retrieve the information about a scroll bar state.
virtual void | OnDraw (CDC *pDC)
This member function performs all of the drawing logic of the calendar view.
virtual BOOL | OnLButtonUp (UINT nFlags, CPoint point)
This member function is used to process left mouse button events.
virtual BOOL | OnLButtonDblClk (UINT nFlags, CPoint point)
This member function is used to process mouse double-click events.
virtual void | OnChar (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process keyboard events.
virtual BOOL | OnSysKeyDown (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process system keyboard events.
CRect | GetViewRect () const
Call this member function to obtain the view's bounding rectangle.
virtual int | GetChildHandlersCount () const
This member function is used to obtain the number of CXTPCalendarWMHandler elements in the descendant handlers collection.
virtual CXTPCalendarWMHandler * | GetChildHandlerAt (int nIndex) const
Call this method to get a handler object at the specified numeric index.
virtual int | GetViewDayCount () const
Call this member function to obtain the number of "day views" in the view collection.
virtual CXTPCalendarViewDay * | _GetViewDay (const COleDateTime &dtDay) const
Call this member function to obtain the CXTPCalendarViewDay object by the day's index.
virtual BOOL | HitTest (CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const
This member function is used to determines which view item, if any, is at a specified position index, and returns additional information in the XTP_CALENDAR_HITTESTINFO argument.
virtual BOOL | HitTestEx (CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const
This member function is used to determine which view item, if any, is at a specified position index, and returns additional info in an XTP_CALENDAR_HITTESTINFO object.
virtual XTPCalendarDraggingMode | GetDraggingMode () const
Call this member function to determine the current dragging mode.
virtual CXTPCalendarPaintManager * | GetPaintManager () const
Call this member function to obtain the PaintManager object.
virtual CXTPCalendarTheme * | GetTheme () const
This member function obtains a pointer to the associated theme object.
CXTPCalendarControl * | GetCalendarControl () const
Call this member function to obtain a pointer to the Calendar Control object.
CXTPCalendarOptions * | GetCalendarOptions () const
Call this member function to get direct access to calendar options data.
virtual CXTPCalendarResources * | GetResources () const
Call this member function to obtain a pointer to the associated Calendar Resources collection object.
virtual void | SetResources (CXTPCalendarResources *pResources)
This member function sets the new Resources collection for the view.
virtual void | UnselectAllEvents ()
Call this member function to un-select all of the events of the current view.
virtual void | SelectEvent (CXTPCalendarEvent *pEvent, BOOL bSelect=TRUE)
This member function is used to select or un-select the provided event.
void | SelectViewEvent (CXTPCalendarViewEvent *pViewEvent, BOOL bSelect=TRUE)
This member function is used to select or un-select the provided event.
virtual void | SelectDay (CXTPCalendarViewDay *pDay, int nGroupIndex=0)
This member function is used to select or un-select the provided day, including all of the day's events.
virtual CXTPCalendarViewEvents * | GetSelectedViewEvents () const
Call this member function to obtain a pointer to a selected event's views.
virtual CXTPCalendarViewEventsPtr | GetSelectedEvents () const
Call this member function to obtain a pointer to a selected event's views collection.
CXTPCalendarViewEvent * | GetLastSelectedViewEvent () const
This member function is used to obtain the last selected event view.
virtual BOOL | HasSelectedViewEvent () const
Call this member function to determine if any view event is selected.
BOOL | IsSingleEventSelected () const
This member function is used to determine if just one event is selected.
int | FindLastSelectedDay () const
This member function is used to obtain the last selected day index.
COleDateTime | GetLastSelectedDate () const
This member function is used to obtain the last selected day date.
virtual BOOL | GetSelection (COleDateTime *pBegin=NULL, COleDateTime *pEnd=NULL, BOOL *pbAllDayEvent=NULL, int *pnGroupIndex=NULL, COleDateTimeSpan *pspSelectionResolution=NULL) const
This member function is used to obtain the view's selection.
void | SetSelection (const COleDateTime &dtBegin, const COleDateTime &dtEnd, BOOL bAllDayEvent=FALSE, int nGroupIndex=0)
This member function sets the new selection for the view.
void | ResetSelection ()
This member function resets the current selection - set it empty.
BOOL | SelectionContains (COleDateTime date, int nGroupIndex=-1, BOOL *pbAllDaySelection=NULL)
This member function is used to determine if a date time value is contained inside the selection.
virtual void | SelectDay (COleDateTime dtSelDay, int nGroupIndex=0)
This member function is used to select or un-select the day identified by the provided date.
virtual int | GetRowHeight () const
Call this member function to determine the row height required to display the event.
virtual CXTPCalendarEventsPtr | RetrieveDayEvents (CXTPCalendarResource *pRC, COleDateTime dtDay)
Call this member function to get the collection of the day's events.
virtual BOOL | IsEditingSubject () const
Call this member function to determine if the subject is in an editable mode.
virtual CRect | GetSubjectEditorRect () const
Call this member function to obtain the bounding rectangle of the subject editor.
virtual CRect | GetTooltipRect (const CPoint &ptHit, const XTP_CALENDAR_HITTESTINFO &hitInfo) const
Call this member function to obtain the bounding rectangle of the tooltip space (currently this is only "click to add new appointment").
virtual void | ShowToolTip (BOOL bShow=TRUE)
This member function is used to show/hide a ToolTip rectangle.
virtual UINT | GetShowToolTipTimeOut () const
This member function is used to obtain the timeout value for displaying a tooltip.
virtual void | OnUpdateEditingSubject (CString strNewSubject)
Call this member function to set the new subject text for the editing event.
virtual BOOL | CanUndo () const
Call this member function to determine if you can perform an undo operation for the subject editor.
virtual BOOL | CanRedo () const
Call this member function to determine if a redo operation is possible for the subject editor.
virtual BOOL | Undo ()
This member function is used to perform an Undo operation.
virtual BOOL | Redo ()
This member function is used to perform a Redo operation.
virtual void | EmptyUndoBuffer ()
This member function is used to erase the undo buffer.
virtual CString | FormatEventTime (COleDateTime dtTime) const
This member function is used to format the time using the provided format.
void | SetCustomTimeFormat (const CString &strFormat)
This member function is used to set custom time format for view.
void | ResetCustomTimeFormat ()
Reset custom time format to default.
virtual CString | GetDayHeaderFormat () const
Call this member function to determine the current format string.
virtual void | SetDayHeaderFormat (LPCTSTR sFmt)
Call this member function to set the day header format.
virtual BOOL | CanCut () const
Call this member function to determine if it is possible to perform a Cut operation.
virtual BOOL | CanCopy () const
Call this member function to determine if it is possible to perform a Copy operation.
virtual BOOL | CanPaste () const
Call this member function to determine if it is possible to perform a Paste operation.
virtual BOOL | Cut ()
This member function is used to perform a Cut operation.
virtual BOOL | Copy ()
This member function is used to perform a Copy operation.
virtual BOOL | Paste ()
This member function is used to perform a Paste operation.
virtual CXTPCalendarEvent * | GetDraggingEventOrig () const
This member function is used to obtain the event object before the start of the event editing (dragging).
virtual CXTPCalendarEvent * | GetDraggingEventNew () const
This member function is used to obtain the event object that is currently being edited.
virtual BOOL | SetDraggingEvent (CXTPCalendarEvent *pEventOrig)
This member function is used to prepare the event to event editing (dragging) operation.
virtual BOOL | CommitDraggingEvent ()
This member function is used to commit the event editing (dragging) operation.
virtual void | CancelDraggingEvent ()
This member function is used to cancel the event editing (dragging) operation.
virtual void | OnStartDragging (CPoint point, XTP_CALENDAR_HITTESTINFO *pHitTest)
This member function is used to start the event editing (dragging).
virtual BOOL | OnDragging (CPoint point, XTP_CALENDAR_HITTESTINFO *pHitTest)
This member function is used to perform the event editing (dragging) operation step.
virtual BOOL | OnEndDragging (CPoint point, XTP_CALENDAR_HITTESTINFO *pHitInfo)
This member function is used to finish the event editing (dragging) operation.
virtual void | StartEditSubject (CXTPCalendarViewEvent *pViewEvent)
This member function is used to start the event subject editing.
virtual void | EndEditSubject (XTPCalendarEndEditSubjectAction eAction, BOOL bUpdateControl=TRUE)
This member function is used to finish the event subject editing.
virtual UINT | GetStartEditSubjectTimeOut () const
This member function is used to obtain the time value after a mouse click event in the subject editing window.
virtual void | StartEditNewEventInplace (LPCTSTR pcszInitialSubject)
This member function is used to create a new event and start subject editing.
virtual CXTPCalendarViewEvent * | FindViewEvent (CXTPCalendarEvent *pEvent, COleDateTime dtDay) const
This member function is used to obtain the event view object for the specified event and day.
virtual CXTPCalendarViewEvent * | FindEventToEditByTAB (COleDateTime dtMinStart, BOOL bReverse, CXTPCalendarEvent *pAfterEvent=NULL)
This member function is used to obtain the next event view object used for editing events by pressing the TAB key.
virtual COleDateTime | GetNextTimeEditByTAB () const
This member function is used to obtain the next date and time to start the find event view for editing events using the TAB key.
virtual void | UpdateNextTimeEditByTAB (COleDateTime dtNext, BOOL bReverse, BOOL bReset=FALSE)
This member function is used to set the next date and time to start the find event view for editing events using the TAB key.
virtual void | ProcessDaySelection (XTP_CALENDAR_HITTESTINFO *pInfo, UINT nFlags)
This member function is used to process the days selection that are selected with the mouse.
virtual void | SelectDays (COleDateTime dtNewSel)
This member function is used to change the days selection depending on the previous state of the selection.
virtual void | ProcessEventSelection (XTP_CALENDAR_HITTESTINFO *pInfo, UINT nFlags)
This member function is used to process events that are selected with the mouse.
virtual void | EnableVScroll (BOOL bEnable=TRUE)
This member function(s) is used to disable or enable vertical or horizontal scrolling of the view (by date or time).
virtual void | EnableHScroll (BOOL bEnable=TRUE)
This member function(s) is used to disable or enable vertical or horizontal scrolling of the view (by date or time).
virtual BOOL | IsHScrollEnabled () const
This member function(s) is used to obtain the status of the vertical or horizontal scrolling features of the view (by date or time).
virtual BOOL | IsVScrollEnabled () const
This member function(s) is used to obtain the status of the vertical or horizontal scrolling features of the view (by date or time).
virtual void | SetDayHeaderFormatLong (LPCTSTR pcszCustomFormat)
This member function(s) is used to set the date format string for the day view.
virtual void | SetDayHeaderFormatMiddle (LPCTSTR pcszCustomFormat)
This member function(s) is used to set the date format string for the day view.
virtual void | SetDayHeaderFormatShort (LPCTSTR pcszCustomFormat)
This member function(s) is used to set the date format string for the day view.
virtual void | SetDayHeaderFormatShortest (LPCTSTR pcszCustomFormat)
This member function(s) is used to set the date format string for the day view.
virtual BOOL | IsTodayVisible () const
Call this member function to determine if Today is visible.
virtual CString | GetItemTextEventTimeMax () const
This member function is called by the calendar framework to retrieve an event time string of maximum length (to reserve space).
virtual void | CalculateHeaderFormat (CDC *pDC, int nWidth, CFont *pTextFont)
This member function creates the day header format string.
- Public Member Functions inherited from CXTPCalendarWMHandler
CXTPCalendarWMHandler ()
Default object constructor.
virtual void | OnKeyUp (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process key-up keyboard events.
virtual BOOL | OnWndMsg (UINT message, WPARAM wParam, LPARAM lParam, LRESULT *pResult)
This method is called by framework after default message processing.
virtual void | OnPostAdjustLayout ()
This member function is used to perform additional adjustments in some kinds of views.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Public Attributes

BOOL m_bDraftMode
print mode flag for B/W prinitng without Headers and Footers

Protected Member Functions

void | _CalculateDateFormats (CDC *pDC)
This member function is used to calculate the view's date format based on the current locale.
void | _ReadDefaultDateFormats ()
This member function is used to build day header date format default strings.
void | _SplitDateFormat (const CString &strDateFormat, CStringArray &rarTokens)
This member function is used to parse the format string into tokens.
void | _CalculateEventCaptionFormat (CDC *pDC)
This member function is used to calculate the event view's date format based on the current locale.
- Protected Member Functions inherited from CXTPCalendarView
virtual UINT | SetTimer (UINT uTimeOut_ms)
This member function is used to create a timer event.
virtual void | KillTimer (UINT uTimerID)
This member function is used to destroy a timer event.
virtual BOOL | OnTimer (UINT_PTR uTimerID)
The framework calls this member function after each interval specified in the SetTimer member function.
virtual void | OnBeforeDestroy ()
This member function is called by the framework before destroying the view.
virtual void | OnActivateView (BOOL bActivate, CXTPCalendarView *pActivateView, CXTPCalendarView *pInactiveView)
This member function is called by the framework view when it is activated or deactivated.
virtual void | SendNotification (XTP_NOTIFY_CODE EventCode, WPARAM wParam=0, LPARAM lParam=0)
This member function is used to send a notification from the parent Calendar control.
virtual void | _CalculateEventTimeFormat ()
This member function is used to create the time format string.
virtual CString | _GetMaxWidthFormat (CDC *pDC, CString strFormat, BOOL bMonth) const
This function is used to calculate the max width of the date used in the specified format string.
virtual int | _GetMaxWidth (CDC *pDC, CString strFormat) const
This member function is used to calculate, in pixels, the max date width for the specified format string.
virtual void | _RemoveYearPart (CString &strFormat)
This member function is used to remove the year part from the specified format string.
virtual void | _ReadDefaultHeaderFormats ()
This member function is used to build day header date format default strings.
virtual CString | _GetDayHeaderFormat (int nLevel) const
This member function gets a custom or default day header date format string.
virtual BOOL | _CanSubjectEditor (UINT idEditCmd) const
This member function is used to determine if the specified editing operation command is possible for the event subject editor window.
virtual CWnd * | _GetSubjectEditorWnd () const
This member function is used to obtain a pointer to the event subject editor window.
virtual COleDataSource * | _CopySelectedEvents (DWORD dwCopyFlags=0)
This member function is used to copy selected events and CXTPCalendarEvent objects, to a COleDataSource object.
virtual CXTPCalendarEventsPtr | _ReadEventsFromClipboard (COleDataObject *pData, DWORD *pdwCopyFlags=NULL)
This member function is used to read events and CXTPCalendarEvent objects, from a COleDataSource object.
virtual COleDateTimeSpan | GetEventDurationMin () const
This member function is used to obtain the minimum event duration visible in the current view.
virtual BOOL | _Undo (CXTPCalendarEvent *pEvent=NULL)
This member function is used to perform an undo/redo operation for the specified event.
virtual XTPEnumCalendarUpdateResult | OnEventChanged_InDataProvider (XTP_NOTIFY_CODE nfCode, CXTPCalendarEvent *pEvent)
This member function handles the changing of an event in the associated data provider.
BOOL | _IsDragModeCopyMove (int eDragMode) const
This method is used to determine Copy or Move dragging mode.
BOOL | IsEditOperationDisabledNotify (XTPCalendarEditOperation eOperation, CXTPCalendarViewEvent *pEventView) const
This method is used to determine if specified editing operation is disabled.
BOOL | OnBeforeEditOperationNotify (XTPCalendarEditOperation eOperation, CXTPCalendarViewEvent *pEventView)
This method is used to customize or disable specified editing operation.
BOOL | OnBeforeEditOperationNotify (XTPCalendarEditOperation eOperation, CXTPCalendarViewEvents *pEventViews)
This method is used to customize or disable specified editing operation.
BOOL | OnBeforePasteNotify (CXTPCalendarEvent *pEvent, BOOL bPasteWillChangeExistingEvent)
This method is used to customize or disable paste editing operation.
BOOL | OnInPlaceCreateEvent (LPCTSTR pcszInitialSubject)
This method is used to customize or disable xtpCalendarEO_InPlaceCreateEvent editing operation.

Protected Attributes

CString | m_strLongDateFormat
String of the long date format.
CString | m_strSmallDateFormat
String of the short date format.
int | m_nEventCaptionFormat
Event caption format flags are stored in packed form by bitwise operations.
int | m_nEventTimeWidth
width of the area to display the event times.
XTP_CALENDAR_MONTHVIEW_DAYPOS | m_DayPOS_LastSelected
Last selected day positions.
COleDateTime | m_dtLightColorDateBase
Month from this date will be painted with light color in month view.
CMonthViewGrid * | m_pGrid
Pointer to the grid object.
- Protected Attributes inherited from CXTPCalendarView
CSelectionChanged_ContextData m_cntSelChanged
Counter on selection changes,.
int | m_eUndoMode
Undo mode, see XTPCalendarUndoMode.
BOOL | m_bResetUndoBuffer
Clean undo buffer before add next undo action.
CUndoBuffer * | m_pPrevUndoBuffer
Undo buffer data after last undo buffer clean.
CUndoBuffer * | m_pUndoBuffer
Undo buffer object.
XTP_VIEW_LAYOUT | m_Layout
Layout data.
SEventTimeFormatInfo | m_EventTimeFormat
Information used to format events times.
CString | m_strHeaderFormat
Day header active date format string.
CString | m_strDayHeaderFormatLong
Day header Long date format custom string.
CString | m_strDayHeaderFormatMiddle
Day header Middle date format custom string.
CString | m_strDayHeaderFormatShort
Day header Short date format custom string.
CString | m_strDayHeaderFormatShortest
Day header Shortest date format custom string.
CString | m_strDayHeaderFormatDefaultLong
Day header Long date format default string.
CString | m_strDayHeaderFormatDefaultMiddle
Day header Middle date format default string.
CString | m_strDayHeaderFormatDefaultShort
Day header Short date format default string.
CString | m_strDayHeaderFormatDefaultShortest
Day header Shortest date format default string.
CRect | m_rcView
Client rect.
CRect | m_rcTooltip
Last shown tooltip rect (while GetTooltipRect returns calculated currently required tooltip rect)
CXTPCalendarEventPtr | m_ptrDraggingEventOrig
Event object before start event editing.
CXTPCalendarEventPtr | m_ptrDraggingEventNew
Editing event object.
COleDateTimeSpan | m_spDraggingStartOffset
Start dragging operation offset from the beginning of the event.
CPoint | m_ptStartDragging
Request to start dragging operation from this point.
XTPCalendarDraggingMode | m_eDraggingMode
Editing event mode.
BOOL | m_bStartedClickInside
Is OnLButtonDown was inside view rect.
CXTPCalendarViewEventPtr | m_ptrEditingViewEvent
Currently editing subject event view or event view requested to edit subject by timeout.
CXTPCalendarViewEvent * | m_pLastEvent
Last selected event.
UINT | m_nTimerID_StartEditSubject
Timer ID of edit event subject request.
UINT | m_nTimerID_ShowToolTip
Timer ID of start show tooltip request.
CXTPCalendarControl * | m_pControl
Pointer to the owner control object.
CXTPCalendarViewEvents * | m_pSelectedEvents
Selected Events;.
XTP_CALENDAR_HITTESTINFO m_LastHitInfo
Last HitInfo data.
UINT | m_nKeyStateTimerID
Timer ID to check Keys state (like Control).
XTP_CALENDAR_VIEWSELECTION | m_selectedBlock
Current selection.
BOOL | m_bScrollV_Disabled
Is vertical scrolling disabled for a view.
BOOL | m_bScrollH_Disabled
Is horizontal scrolling disabled for a view.
CXTPCalendarResources * | m_pResources
Resources array.
CXTPCalendarPtrCollectionT< CXTPCalendarViewDay > | m_arDays
Stores the view day collection.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

This class implements a specific view portion of the Calendar control - called Month view.

The Month can contain one or more weeks, placed in a column. Each week consist of 7 days, as a normal week. Weekend days of the week can be drawn compressed, which means that 2 weekend days will be drawn in a rectangle of a usual day. Each day is represented by a CXTPCalendarMonthViewDay class.

See also
CXTPCalendarView
CXTPCalendarDayView
CXTPCalendarWeekView
CXTPCalendarMonthViewDay
CXTPCalendarMonthViewEvent

Member Typedef Documentation

◆ TBase

CXTPCalendarViewT<CXTPCalendarMonthViewDay> TBase

Base class type definition

Constructor & Destructor Documentation

◆ CXTPCalendarMonthView()

CXTPCalendarMonthView ( CXTPCalendarControl * pCalendarControl )

Default object constructor.

Parameters
pCalendarControl - Pointer to a CXTPCalendarControl object.
See also
~CXTPCalendarMonthView()

◆ ~CXTPCalendarMonthView()

virtual ~CXTPCalendarMonthView ( )
virtual

Default class destructor.

Handles member item deallocation.

Member Function Documentation

◆ _CalculateDateFormats()

void _CalculateDateFormats ( CDC * pDC )
protected

This member function is used to calculate the view's date format based on the current locale.

Parameters
pDC Pointer to a valid device context.

◆ _CalculateEventCaptionFormat()

void _CalculateEventCaptionFormat ( CDC * pDC )
protected

This member function is used to calculate the event view's date format based on the current locale.

Parameters
pDC Pointer to a valid device context.

◆ _FormatDayDate()

CString _FormatDayDate | ( | COleDateTime | dtDay,
 |  | BOOL | bLong )

This member function is used to obtain the format string of a day date.

Parameters
dtDay | A COleDateTime object that contains the date to be formatted.
bLong | A BOOL. Determines whether to apply a long date format.

Call this member function to obtain the date in a form appropriate to display in the day header text.

Returns
CString object with the formatted date.
See also
GetViewDayCount()

◆ _ReadDefaultDateFormats()

void _ReadDefaultDateFormats ( )
protected

This member function is used to build day header date format default strings.

This member function read locale settings and fill m_strDayHeaderFormatDefaultXXX members.

See also
_CalculateDateFormats()
CXTPCalendarView::_ReadDefaultHeaderFormats(),
m_strDayHeaderFormatDefaultLong
m_strDayHeaderFormatDefaultMiddle
m_strDayHeaderFormatDefaultShort
m_strDayHeaderFormatDefaultShortest.

◆ _SplitDateFormat()

void _SplitDateFormat | ( | const CString & | strDateFormat,
 |  | CStringArray & | rarTokens )
 protected

This member function is used to parse the format string into tokens.

Parameters
strDateFormat | A CString that contains the string to parse.
rarTokens | A CStringArray that contains the resultant token array.

◆ AdjustLayout()

virtual void AdjustLayout | ( | CDC * | pDC,
 |  | const CRect & | rcView,
 |  | BOOL | bCallPostAdjustLayout = TRUE )
 virtual

This member function is used to adjust the view's layout depending on the window's client size and then calls AdjustLayout() for all sub-items.

Parameters
pDC | Pointer to a valid device context.
rcView | A CRect object that contains the coordinates used to draw the view.
bCallPostAdjustLayout | A BOOL. Flag used to call for additional adjustments.

Call Populate() prior to AdjustLayout. AdjustLayout2 is called by calendar control instead of AdjustLayout when theme is set.

Reimplemented from CXTPCalendarView.

◆ AdjustLayout2()

virtual void AdjustLayout2 | ( | CDC * | pDC,
 |  | const CRect & | rcView,
 |  | BOOL | bCallPostAdjustLayout = TRUE )
 virtual

This member function is used to adjust the view's layout depending on the window's client size and then calls AdjustLayout() for all sub-items.

Parameters
pDC | Pointer to a valid device context.
rcView | A CRect object that contains the coordinates used to draw the view.
bCallPostAdjustLayout | A BOOL. Flag used to call for additional adjustments.

Call Populate() prior to AdjustLayout. AdjustLayout2 is called by calendar control instead of AdjustLayout when theme is set.

Reimplemented from CXTPCalendarView.

◆ Draw()

virtual void Draw ( CDC * pDC )
virtual

This member function is used to draw the view content using the specified device context.

Parameters
pDC Pointer to a valid device context.

Call AdjustLayout() before Draw(). Draw2 is called by calendar control instead of Draw when theme is set.

See also
AdjustLayout().

Reimplemented from CXTPCalendarView.

◆ Draw2()

virtual void Draw2 ( CDC * pDC )
virtual

This member function is used to draw the view content using the specified device context.

Parameters
pDC Pointer to a valid device context.

Call AdjustLayout() before Draw(). Draw2 is called by calendar control instead of Draw when theme is set.

See also
AdjustLayout().

Reimplemented from CXTPCalendarView.

◆ GetEventCaptionFormat()

AFX_INLINE int GetEventCaptionFormat ( ) const
virtual

This member function is used to obtain the event caption format flags.

Call this member function to obtain event caption format flags. Event caption format flags are stored in a packed form. Use bitwise operations to determine each flag state.

Returns
Integer value containing flags.

◆ GetEventTimeWidth()

AFX_INLINE int GetEventTimeWidth ( ) const
virtual

This member function is used to obtain the width necessary to display the event's time.

Returns
An int that contains the width as an integer value.

◆ GetGrid()

AFX_INLINE CXTPCalendarMonthView::CMonthViewGrid * GetGrid ( ) const

This member function is used to obtain the Month View days grid object.

Returns
A pointer to a CMonthViewGrid object that contains the Month View days grid object.
See also
CMonthViewGrid

◆ GetScrollBarInfoV()

virtual BOOL GetScrollBarInfoV ( SCROLLINFO * pSI ) const
virtual

This member function is used to retrieve information about the current scroll bar state.

Parameters
pSI A SCROLLINFO pointer. Pointer to a scrollbar information structure.
Returns
TRUE if scroll bar information is obtained, FALSE otherwise.

Reimplemented from CXTPCalendarView.

◆ GetViewDay_()

virtual CXTPCalendarViewDay * GetViewDay_ ( int nIndex ) const
virtual

This member function is used to obtain the view's day object by the given index.

Parameters
nIndex An int. Day view index in the view collection.

Index numbers start with 0 and cannot be negative.

Returns
Pointer to a CXTPCalendarMonthViewDay object.
See also
GetViewDayCount()

Reimplemented from CXTPCalendarView.

◆ GetViewDayDate()

virtual COleDateTime GetViewDayDate ( int nIndex ) const
virtual

Call this member function to obtain the date of a day view by the day's index.

Parameters
nIndex An int. Day view index in the view collection.

Index numbers start with 0 and cannot be negative.

Returns
A COleDateTime object that contains the day view date and time.
See also
GetViewDayCount()

Implements CXTPCalendarView.

◆ GetWeekDayTextIfNeed()

virtual void GetWeekDayTextIfNeed | ( | CString * | pstrText,
 |  | int | nWeekDay )
 virtual

This member function is used to obtain week day header text.

Parameters
pstrText | [in, out] Pointer to item text.
nWeekDay | Week day number as: 1 - Sunday, 2 - Monday, ... 7 - Satyrday.

If AskItemTextFlags has the xtpCalendarItemText_MonthViewWeekDayHeader flag set, an XTP_NC_CALENDAR_GETITEMTEXT notification is sent to customize standard text.

See also
XTPCalendarGetItemText,XTPCalendarGetItemTextEx
XTP_NC_CALENDAR_GETITEMTEXT
CXTPCalendarControl::GetAskItemTextFlags
CXTPCalendarPaintManager::GetAskItemTextFlags
CXTPCalendarPaintManager::SetAskItemTextFlags
CXTPCalendarTheme::GetAskItemTextFlags
CXTPCalendarTheme::SetAskItemTextFlags

◆ OnKeyDown()

virtual void OnKeyDown | ( | UINT | nChar,
 |  | UINT | nRepCnt,
 |  | UINT | nFlags )
 virtual

This member function is used to process keyboard events.

Parameters
nChar | A UINT. Virtual key code of the given key.
nRepCnt | A UINT. Number of times the keystroke is repeated as a result of the user holding down the key.
nFlags | A UINT. Scan code, key-transition code, previous key state, and context code.

This method is called by the CalendarControl when the user presses keys on the keyboard.

Reimplemented from CXTPCalendarView.

◆ OnLButtonDown()

virtual BOOL OnLButtonDown | ( | UINT | nFlags,
 |  | CPoint | point )
 virtual

This member function is used to process left mouse button events.

Parameters
nFlags | A UINT that is used to indicates whether various virtual keys are down.
point | A CPoint that specifies the x- and y- coordinates of the cursor. These coordinates are always relative to the upper-left corner of the window.
Returns
TRUE if the message is handled properly, FALSE otherwise.

This method is called by the CalendarControl when the user presses the left mouse button.

Reimplemented from CXTPCalendarView.

◆ OnMouseMove()

virtual void OnMouseMove | ( | UINT | nFlags,
 |  | CPoint | point )
 virtual

This member function is used to processes mouse movement events.

Parameters
nFlags | A UINT that is used to indicate whether various virtual keys are down.
point | A CPoint that specifies the x- and y- coordinates of the cursor. These coordinates are always relative to the upper-left corner of the window.

This method is called by the CalendarControl when the user moves the mouse cursor or stylus.

Reimplemented from CXTPCalendarView.

◆ ScrollV()

virtual void ScrollV | ( | int | nPos,
 |  | int | nPos_raw )
 virtual

This member function is used to scroll the contents of a view.

Parameters
nPos | An int that contains the position value.
nPos_raw | An int that contains the raw position value.

ScrollV internally uses Populate() to fill new view data. Note: nPos is not used at this time. It is reserved for future use.

See also
Populate()
GetScrollBarInfoV.

Reimplemented from CXTPCalendarView.

◆ SetLongDayHeaderFormat()

AFX_INLINE void SetLongDayHeaderFormat ( LPCTSTR pcszCustomFormat )

Sets the format for Cell's Day Header in Month View.

Parameters
pcszCustomFormat : format string

◆ SetSmallDayHeaderFormat()

AFX_INLINE void SetSmallDayHeaderFormat ( LPCTSTR pcszCustomFormat )

Sets the format for Cell's Day Header in Month View.

Parameters
pcszCustomFormat : format string

◆ ShowDay()

virtual void ShowDay | ( | const COleDateTime & | date,
 |  | BOOL | bSelect = TRUE )
 virtual

This member function is used to show the specified day in the calendar view.

Parameters
date | A COleDateTime object that contains the date to show.
bSelect | TRUE to select the specified day after showing, FALSE otherwise. TRUE is the default value.

Call this member function to show only the specified day in the calendar view.

Implements CXTPCalendarView.

The documentation for this class was generated from the following file:
  • XTPCalendarMonthView.h


Toolkit Pro: CXTPCalendarMonthView::CMonthViewGrid Class Reference

  • CXTPCalendarMonthView
  • CMonthViewGrid
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPCalendarMonthView::CMonthViewGrid Class Reference

Public Member Functions

CMonthViewGrid (CXTPCalendarMonthView *pView)
Default class constructor.
virtual | ~CMonthViewGrid ()
Default class destructor.
COleDateTime | GetBeginDate () const
This member function is used to obtain the date of the first cell (cell [0, 0]) in the grid.
void | SetBeginDate (COleDateTime dtBeginDate)
This member function is used to set the start view date.
COleDateTime | ShiftDateToCell_00 (COleDateTime dtDate) const
This member function is used to shift the specified date to the first cell date in the grid.
int | GetWeeksCount () const
This member function is used to obtain the weeks (rows) count in the grid.
void | SetWeeksCount (int nWeeks)
This member function is used to set the number of weeks that are shown in the grid (Month View).
COleDateTime | GetDayDate (int nWeekIndex, int nWeekDayIndex) const
This member function is used to retrieve the specified day date.
CRect | GetDayRect (int nWeekIndex, int nWeekDayIndex, BOOL bIncludeBorders=FALSE) const
This member function is used to obtain the bounding rectangle of the day cell.
CRect | GetCelRect (int nWeekIndex, int nColIndex, BOOL bIncludeBorders=FALSE) const
This member function is used to obtain the bounding rectangle of the full grid cell.
int | GetWeekDayCol (int nWeekDayIndex) const
This member function is used to obtain the column for the specified week day.
int | GetWeekDayForColIndex (int nColIdx) const
This member function is used to obtain the week day index for the specified column.
int | GetColsCount () const
This member function is used to obtain the number of columns that are displayed in the Month View.
int | GetColHeaderHeight () const
This member function is used to obtain the number of pixels in the height of the Month View week days columns header.
void | SetColHeaderHeight (int nHeight)
This member function is used to set the height of the Month View week days columns header.
void | ScrollV (int nPos)
This member function is used to scroll the contents of a grid.
int | GetScrollPos () const
This member function is used to obtain the current scrolling position.
void | AdjustLayout (CDC *pDC)
This member function is used to adjust the grid's layout depending on the window's client size and then calls AdjustLayout() for all sub-items.
void | Draw (CDC *pDC)
This member function is used to draw the grid content using the specified device context.
void | AdjustFirstDayOfWeek ()
This member function is used to adjust the grid's columns depending on the FirstDayOfWeek calendar control option value.
void | AdjustGrid (const CRect &rcRect)
This member function is used to adjust the grid's columns and rows.
void | AdjustDays (CDC *pDC)
This member function is used to call AdjustLayout for each day in the days collection with corresponding day rect.
void | AdjustEvents (CDC *pDC)
This member function is used to adjust the event views layout.
CXTPCalendarMonthViewDay * | GetViewDay (int nWeekIndex, int nWeekDayIndex) const
This function is used to obtain the view day object that is associated with the given indexes.
XTP_CALENDAR_MONTHVIEW_DAYPOS | GetMaxDayPOS () const
This member function is used to obtain the maximum number of available day positions.
int | GetFirstDayOfWeek () const
This member function is used to obtain the First Day Of Week index.

Protected Member Functions

void | AdjustHeader (CDC *pDC)
This member function is used to adjust the grid's column header layout.
COleDateTime | GetMiddleScrollBeginDate () const
This member function is used to calculate the date for a middle scrollbar position.

Protected Attributes

COleDateTime | m_dtBeginDate
First Cell (cell [0, 0]) date in the grid.
int | m_nWeeksCount
The number of weeks that are displayed.
int | m_nColHeaderHeight
Column header height in pixels.
CStringArray | m_arColHeaderText
Array of columns (week days) headers names.
CUIntArray | m_arColsLeftX
Array of columns left borders positions.
CUIntArray | m_arRowsTopY
Array of rows top borders positions.
int | m_nFirstDayOfWeekIndex
First Day Of Week index: 1-Sunday, 2-Monday ...
CXTPCalendarMonthView * | m_pView
Pointer to the parent view class.

Detailed Description

This helper class implements a grid for the month view.

See also
CXTPCalendarMonthView overview

Constructor & Destructor Documentation

◆ CMonthViewGrid()

CMonthViewGrid ( CXTPCalendarMonthView * pView )

Default class constructor.

Parameters
pView A CXTPCalendarMonthView pointer to the parent view class.

◆ ~CMonthViewGrid()

virtual ~CMonthViewGrid ( )
virtual

Default class destructor.

Handles member item deallocation.

Member Function Documentation

◆ AdjustDays()

void AdjustDays ( CDC * pDC )

This member function is used to call AdjustLayout for each day in the days collection with corresponding day rect.

Parameters
pDC Pointer to a valid device context.
See also
AdjustEvents

◆ AdjustEvents()

void AdjustEvents ( CDC * pDC )

This member function is used to adjust the event views layout.

Parameters
pDC Pointer to a valid device context.
See also
AdjustLayout
CXTPCalendarMonthView::AdjustLayout

◆ AdjustFirstDayOfWeek()

void AdjustFirstDayOfWeek ( )

This member function is used to adjust the grid's columns depending on the FirstDayOfWeek calendar control option value.

See also
CXTPCalendarControl::GetFirstDayOfWeek

◆ AdjustGrid()

void AdjustGrid ( const CRect & rcRect )

This member function is used to adjust the grid's columns and rows.

Parameters
rcRect A rectangle for grid.
See also
AdjustDays

◆ AdjustHeader()

void AdjustHeader ( CDC * pDC )
protected

This member function is used to adjust the grid's column header layout.

Parameters
pDC Pointer to a valid device context.
See also
AdjustLayout
CXTPCalendarMonthView::AdjustLayout

◆ AdjustLayout()

void AdjustLayout ( CDC * pDC )

This member function is used to adjust the grid's layout depending on the window's client size and then calls AdjustLayout() for all sub-items.

Parameters
pDC Pointer to a valid device context.
See also
CXTPCalendarMonthView::AdjustLayout

◆ Draw()

void Draw ( CDC * pDC )

This member function is used to draw the grid content using the specified device context.

Parameters
pDC Pointer to a valid device context.

Call CXTPCalendarMonthView::AdjustLayout before Draw().

See also
CXTPCalendarMonthView::Draw
CXTPCalendarMonthView::AdjustLayout

◆ GetBeginDate()

AFX_INLINE COleDateTime GetBeginDate ( ) const

This member function is used to obtain the date of the first cell (cell [0, 0]) in the grid.

Returns
A COleDateTime object that contains the date of the first cell (cell [0, 0]) in the grid.
See also
SetBeginDate
ShiftDateToCell_00

◆ GetCelRect()

CRect GetCelRect | ( | int | nWeekIndex,
 |  | int | nColIndex,
 |  | BOOL | bIncludeBorders = FALSE ) const

This member function is used to obtain the bounding rectangle of the full grid cell.

Parameters
nWeekIndex | An int that contains the index of the week. Valid values are from 0 to GetWeeksCount()-1.
nColIndex | An int that contains the index of the cell in the grid. Valid values are from 0 to GetColsCount()-1.
bIncludeBorders | A BOOL. If TRUE, then borders between cells are included in the bounding rectangle coordinates. If FALSE, then the borders between cells are not included in the bounding rectangle coordinates.

Full grid cell means either a day cell for no compressed days or a cell which includes 2 day cells for compressed Sat/Sun if the "compress weekend days" option is ON.

Returns
A CRect object that contains the bounding rectangle coordinates of the full grid cell.
See also
GetDayRect
GetWeeksCount
GetColsCount
CRect

◆ GetColHeaderHeight()

int GetColHeaderHeight ( ) const

This member function is used to obtain the number of pixels in the height of the Month View week days columns header.

Returns
An int that contains the value of the columns header height in pixels.

◆ GetColsCount()

int GetColsCount ( ) const

This member function is used to obtain the number of columns that are displayed in the Month View.

If the "compress weekend days" option is ON, then 6 is returned, otherwise 7.

Returns
An int that contains the number of columns that are displayed in the Month View.
See also
GetWeekDayCol

◆ GetDayDate()

COleDateTime GetDayDate | ( | int | nWeekIndex,
 |  | int | nWeekDayIndex ) const

This member function is used to retrieve the specified day date.

Parameters
nWeekIndex | An int that contains the index of the week. Valid values are from 0 to GetWeeksCount()-1.
nWeekDayIndex | An int that contains the index of the day cell in the week. Valid values are from 0 to 6.
Returns
A COleDateTime object that contains the specified day date.
See also
GetWeeksCount
SetWeeksCount

◆ GetDayRect()

CRect GetDayRect | ( | int | nWeekIndex,
 |  | int | nWeekDayIndex,
 |  | BOOL | bIncludeBorders = FALSE ) const

This member function is used to obtain the bounding rectangle of the day cell.

Parameters
nWeekIndex | An int that contains the index of the week. Valid values are from 0 to GetWeeksCount()-1.
nWeekDayIndex | An int that contains the index of the day cell in the week. Valid values are from 0 to 6.
bIncludeBorders | A BOOL. If TRUE, then borders between days are included in the bounding rectangle coordinates. If FALSE, then borders are not included in the bounding rectangle coordinates.
Returns
A CRect object that contains the bounding rectangle coordinates of the day cell.
See also
GetCelRect
GetWeeksCount
CRect

◆ GetFirstDayOfWeek()

AFX_INLINE int GetFirstDayOfWeek ( ) const

This member function is used to obtain the First Day Of Week index.

Returns
An int that contains the First Day Of Week index. (1-Sunday, 2-Monday ...)
See also
GetWeekDayCol

◆ GetMaxDayPOS()

AFX_INLINE XTP_CALENDAR_MONTHVIEW_DAYPOS GetMaxDayPOS ( ) const

This member function is used to obtain the maximum number of available day positions.

Returns
A XTP_CALENDAR_MONTHVIEW_DAYPOS object that contains the maximum number of available day positions.
See also
XTP_CALENDAR_MONTHVIEW_DAYPOS
XTP_CALENDAR_HITTESTINFO
CXTPCalendarMonthView::m_DayPOS_LastSelected

◆ GetMiddleScrollBeginDate()

COleDateTime GetMiddleScrollBeginDate ( ) const
protected

This member function is used to calculate the date for a middle scrollbar position.

Returns
A COleDateTime object that contains the date for a middle scrollbar position.
See also
ScrollV
GetScrollPos
CXTPCalendarMonthView::ScrollV
CXTPCalendarMonthView::GetScrollBarInfoV

◆ GetScrollPos()

int GetScrollPos ( ) const

This member function is used to obtain the current scrolling position.

Returns
An int that contains the current scrolling position.
See also
ScrollV
CXTPCalendarMonthView::ScrollV
CXTPCalendarMonthView::GetScrollBarInfoV

◆ GetViewDay()

CXTPCalendarMonthViewDay * GetViewDay | ( | int | nWeekIndex,
 |  | int | nWeekDayIndex ) const

This function is used to obtain the view day object that is associated with the given indexes.

Parameters
nWeekIndex | An int that contains the index of the week. Valid values are from 0 to GetWeeksCount()-1.
nWeekDayIndex | An int that contains the index of the day cell in the week.
Returns
A pointer to a CXTPCalendarMonthViewDay object that contains the view day that is associated with the given indexes.
See also
CXTPCalendarMonthView::GetViewDay

◆ GetWeekDayCol()

int GetWeekDayCol ( int nWeekDayIndex ) const

This member function is used to obtain the column for the specified week day.

Parameters
nWeekDayIndex An int that contains the index of the week day. 1-Sunday, 2-Monday, ....

If the "compress weekend days" option is ON then, only one column number is returned for Saturday and Sunday.

Returns
An int that contains the column number for the specified week day.
See also
GetColsCount
GetWeekDayForColIndex

◆ GetWeekDayForColIndex()

int GetWeekDayForColIndex ( int nColIdx ) const

This member function is used to obtain the week day index for the specified column.

Parameters
nColIdx An int that contains the index of the week day. 1-Sunday, 2-Monday, ....

If the "compress weekend days" option is ON then, 7 (Saturday) returned for the compressed column.

Returns
Index of the week day as: 1-Sunday, 2-Monday, ....
See also
GetColsCount
GetWeekDayCol

◆ GetWeeksCount()

AFX_INLINE int GetWeeksCount ( ) const

This member function is used to obtain the weeks (rows) count in the grid.

Returns
An int that contains the number of weeks (rows) in the grid.
See also
SetWeeksCount

◆ ScrollV()

void ScrollV ( int nPos )

This member function is used to scroll the contents of a grid.

Parameters
nPos An int that contains the position value.

This member function calculates the date time that corresponds with the current scroll bar position. Next, the function adjusts the dates in the grid so that the date that is associated with the current scroll bar position is placed in the beginning cell of the grid.

See also
GetScrollPos
CXTPCalendarMonthView::ScrollV
CXTPCalendarMonthView::GetScrollBarInfoV

◆ SetBeginDate()

void SetBeginDate ( COleDateTime dtBeginDate )

This member function is used to set the start view date.

Parameters
dtBeginDate A COleDateTime object that contains the start view date.

This date will be adjusted (shifted) to be the first cell (cell [0, 0]) date in the grid.

See also
GetBeginDate
ShiftDateToCell_00

◆ SetColHeaderHeight()

void SetColHeaderHeight ( int nHeight )

This member function is used to set the height of the Month View week days columns header.

Parameters
nHeight A new height value in pixels.

Should be used in visual themes AdjustLayout processing.

◆ SetWeeksCount()

void SetWeeksCount ( int nWeeks )

This member function is used to set the number of weeks that are shown in the grid (Month View).

Parameters
nWeeks An int that contains the number of weeks shown in the grid. Minimum and maximum values are defined as XTP_CALENDAR_MONTHVIEW_SHOW_WEEKS_MIN and XTP_CALENDAR_MONTHVIEW_SHOW_WEEKS_MAX.
See also
GetWeeksCount
XTP_CALENDAR_MONTHVIEW_SHOW_WEEKS_MIN
XTP_CALENDAR_MONTHVIEW_SHOW_WEEKS_MAX

◆ ShiftDateToCell_00()

COleDateTime ShiftDateToCell_00 ( COleDateTime dtDate ) const

This member function is used to shift the specified date to the first cell date in the grid.

Parameters
dtDate A COleDateTime object that contains the date to shift.
Returns
A COleDateTime object that contains the date that was shifted to the first cell in the grid.
See also
GetBeginDate
SetBeginDate
The documentation for this class was generated from the following file:
  • XTPCalendarMonthView.h


Toolkit Pro: CXTPCalendarMonthViewDay Class Reference

Public Types | Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPCalendarMonthViewDay Class Reference

This class represents a day view portion of the CalendarMonthView. More...

Inheritance diagram for CXTPCalendarMonthViewDay:
[legend]

Public Types

typedef CXTPCalendarViewDayT< CXTPCalendarMonthView, CXTPCalendarMonthViewGroup, XTP_CALENDAR_HITTESTINFO, CXTPCalendarMonthViewDay > | TBase
Base class type definition.
- Public Types inherited from CXTPCalendarViewDayT< CXTPCalendarMonthView, CXTPCalendarMonthViewGroup, XTP_CALENDAR_HITTESTINFO, CXTPCalendarMonthViewDay >
typedef CXTPCalendarMonthView | TView

Public Member Functions

CXTPCalendarMonthViewDay (const CXTPCalendarMonthView *pMonthView, int nWeekIndex, int nWeekDayIndex)
Default object constructor.
virtual | ~CXTPCalendarMonthViewDay ()
Default class destructor.
virtual void | AdjustLayout (CDC *pDC, const CRect &rcDay)
This member function is used to adjust the view's layout depending on the provided rectangle and then calls AdjustLayout() for all sub-items.
virtual void | AdjustLayout2 (CDC *pDC, const CRect &rcDay)
This member function is used to adjust the view's layout depending on the provided rectangle and then calls AdjustLayout() for all sub-items.
virtual void | Draw (CDC *pDC)
This member function is used to draw the view contents using the specified device context.
virtual void | FillHitTestEx (XTP_CALENDAR_HITTESTINFO *pInfo) const
This member function is used to fill a XTP_CALENDAR_HITTESTINFO structure.
virtual BOOL | HitTestEx (CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const
This member function is used to determine which view item, if any, is at the specified position index, and returns additional info in the XTP_CALENDAR_HITTESTINFO template object.
CRect | CalcDayDateRect () const
This member function is used to calculate the day date bounding rectangle.
CRect | GetDayEventsRect () const
This member function is used to calculate the day view area in which to draw event views.
virtual void | SetSelected ()
This member function is used to set the day view as selected.
- Public Member Functions inherited from CXTPCalendarViewDayT< CXTPCalendarMonthView, CXTPCalendarMonthViewGroup, XTP_CALENDAR_HITTESTINFO, CXTPCalendarMonthViewDay >
CXTPCalendarViewDayT (const CXTPCalendarMonthView *pView)
Default object constructor.
virtual | ~CXTPCalendarViewDayT ()
Default class destructor.
CXTPCalendarMonthView * | GetView () const
This member function is used to obtain the owner view object.
virtual CXTPCalendarMonthViewGroup * | GetViewGroup (int nIndex) const
Call this member function to obtain a pointer to the _TViewGroup object that corresponds to the resource's index.
virtual CXTPCalendarViewGroup * | CreateGroup ()
This member function is used to create a new instance of a group.
- Public Member Functions inherited from CXTPCalendarViewDay
CXTPCalendarViewDay (const CXTPCalendarView *pView)
Default object constructor.
virtual | ~CXTPCalendarViewDay ()
Default class destructor.
virtual void | Populate (COleDateTime dtDayDate)
This member function is used to populate the view with data for all items contained in the view.
virtual int | GetChildHandlersCount () const
This member function is used to obtain the number of resource group views elements in the collection.
virtual CXTPCalendarWMHandler * | GetChildHandlerAt (int nIndex) const
Call this method to get a resource group view object at the specified numeric index.
virtual BOOL | HitTest (CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const
This member function is used to determine which view item, if any, is at the specified position index, and returns additional info in an XTP_CALENDAR_HITTESTINFO struct.
virtual CXTPCalendarView * | GetView_ () const
Call this member function to obtain a pointer to a CXTPCalendarView object.
virtual CXTPCalendarControl * | GetCalendarControl () const
Call this member function to obtain a pointer to a CXTPCalendarControl object.
virtual CXTPCalendarResources * | GetResources () const
Call this member function to obtain a pointer to the associated Calendar Resources collection object.
virtual void | SetResources (CXTPCalendarResources *pResources)
This member function sets the new Resources collection for the view day.
virtual int | GetViewEventsCount () const
Call this member function to obtain the number of event views in the day view collection.
virtual CXTPCalendarViewEvent * | GetViewEvent_ (int nIndex) const
Call this member function to obtain a pointer to a CXTPCalendarViewEvent object associated with the event's index.
int | GetViewGroupsCount () const
Call this member function to obtain the number of resource group views in the view day collection.
CXTPCalendarViewGroup * | GetViewGroup_ (int nIndex) const
Call this member function to obtain a pointer to a CXTPCalendarViewGroup object associated with the group's index.
virtual COleDateTime | GetDayDate () const
Call this member function to obtain a day date value.
virtual COleDateTime | SetDayDate (COleDateTime dtDayDate)
Call this member function to obtain the day date value.
virtual BOOL | ContainsInvisibleEvents () const
Call this member function to determine if there are any invisible event views.
virtual BOOL | ContainsInvisibleEventsUpdate ()
Call this member function to determine if there are any invisible event views and to calculate the rectangle for the ExpandSign.
virtual BOOL | IsSelected () const
Call this member function to determine if the day view is selected.
virtual CRect | GetDayRect () const
Call this member function to obtain the day view rectangle coordinates.
virtual void | SetDayRect (CRect rcDay)
This member function is used to set the day view rectangle coordinates.
virtual BOOL | IsExpanded () const
Call this member function to determine if there are invisible event views because the boundaries of the day view are hidden and if the day view should display the expand sign.
virtual CRect | GetExpandSignRect () const
Call this member function to obtain the expand sign rectangle.
virtual UINT | SetTimer (UINT uTimeOut_ms)
This member function is used to create a timer event.
virtual void | KillTimer (UINT uTimerID)
This member function is used to destroy a timer event.
virtual int | GetDayIndex () const
This member function is used to obtain the index of the "this" pointer day in the Calendar Day View.
virtual BOOL | UserAction_OnExpandDay (XTPCalendarExpandDayButton eButton)
This member function is used to process the user action xtpCalendarUserAction_OnExpandDay.
- Public Member Functions inherited from CXTPCalendarWMHandler
CXTPCalendarWMHandler ()
Default object constructor.
virtual BOOL | OnLButtonUp (UINT nFlags, CPoint point)
This member function is used to process left mouse button up events.
virtual BOOL | OnLButtonDblClk (UINT nFlags, CPoint point)
This member function is used to process left mouse button double click events.
virtual void | OnChar (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process keyboard events.
virtual void | OnKeyDown (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process key-down keyboard events.
virtual void | OnKeyUp (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process key-up keyboard events.
virtual BOOL | OnSysKeyDown (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process key-up keyboard events.
virtual BOOL | OnTimer (UINT_PTR uTimerID)
The framework calls this member function after each interval specified in the SetTimer member function.
virtual BOOL | OnWndMsg (UINT message, WPARAM wParam, LPARAM lParam, LRESULT *pResult)
This method is called by framework after default message processing.
virtual void | OnPostAdjustLayout ()
This member function is used to perform additional adjustments in some kinds of views.
virtual void | OnBeforeDestroy ()
This member function is called by the framework before destroying the view.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

virtual BOOL | OnLButtonDown (UINT nFlags, CPoint point)
This member function is used to process left mouse button events.
virtual void | OnMouseMove (UINT nFlags, CPoint point)
This member function is used to processes mouse movement events.
virtual CXTPCalendarMonthViewDay * | GetPThis ()
This member function is used to obtain a pointer to itself.
- Protected Member Functions inherited from CXTPCalendarViewDayT< CXTPCalendarMonthView, CXTPCalendarMonthViewGroup, XTP_CALENDAR_HITTESTINFO, CXTPCalendarMonthViewDay >
- Protected Member Functions inherited from CXTPCalendarViewDay
virtual void | OnPrePopulateDay ()
This member function is used to allow some customization before show events.

Protected Attributes

int | m_nWeekIndex
Week identifier.
int | m_nWeekDayIndex
Day identifier.
- Protected Attributes inherited from CXTPCalendarViewDay
XTP_VIEW_DAY_LAYOUT | m_Layout
Layout data.
COleDateTime | m_dtDate
Day date.
CXTPCalendarResources * | m_pResources
Resources array.
CXTPCalendarPtrCollectionT< CXTPCalendarViewGroup > | m_arViewGroups
Storage for views of groups.
CXTPCalendarView * | m_pView
Storage for a owner view.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

This class represents a day view portion of the CalendarMonthView.

It represents a specific view of the CalendarView's associated events data grouped by one day and provides basic functionality on this data using user input through keyboard and mouse.

 CXTPCalendarMonthViewDay is based on CXTPCalendarViewDayT template
 class. It inherits basic behavior from its parent and overlaps/add some
 methods to get its own behavior and look.
See also
CXTPCalendarViewDay
CXTPCalendarViewDayT

Constructor & Destructor Documentation

◆ CXTPCalendarMonthViewDay()

CXTPCalendarMonthViewDay | ( | const CXTPCalendarMonthView * | pMonthView,
 |  | int | nWeekIndex,
 |  | int | nWeekDayIndex )

Default object constructor.

Construct a CXTPCalendarMonthViewDay object.

Parameters
pMonthView | Pointer to CXTPCalendarMonthView object.
nWeekIndex | An int that contains a week view identifier.
nWeekDayIndex | An int that contains a day view identifier.
See also
~CXTPCalendarMonthViewDay()

◆ ~CXTPCalendarMonthViewDay()

virtual ~CXTPCalendarMonthViewDay ( )
virtual

Default class destructor.

Handles member items deallocation.

Member Function Documentation

◆ AdjustLayout()

virtual void AdjustLayout | ( | CDC * | pDC,
 |  | const CRect & | rcDay )
 virtual

This member function is used to adjust the view's layout depending on the provided rectangle and then calls AdjustLayout() for all sub-items.

Parameters
pDC | Pointer to a valid device context.
rcDay | A CRect object that contains the coordinates for drawing the view.

Call Populate(COleDateTime dtDayDate) prior to calling AdjustLayout(). AdjustLayout2 is called by calendar control instead of AdjustLayout when theme is set.

Reimplemented from CXTPCalendarViewDayT< CXTPCalendarMonthView, CXTPCalendarMonthViewGroup, XTP_CALENDAR_HITTESTINFO, CXTPCalendarMonthViewDay >.

◆ AdjustLayout2()

virtual void AdjustLayout2 | ( | CDC * | pDC,
 |  | const CRect & | rcDay )
 virtual

This member function is used to adjust the view's layout depending on the provided rectangle and then calls AdjustLayout() for all sub-items.

Parameters
pDC | Pointer to a valid device context.
rcDay | A CRect object that contains the coordinates for drawing the view.

Call Populate(COleDateTime dtDayDate) prior to calling AdjustLayout(). AdjustLayout2 is called by calendar control instead of AdjustLayout when theme is set.

◆ CalcDayDateRect()

CRect CalcDayDateRect ( ) const

This member function is used to calculate the day date bounding rectangle.

Returns
A CRect object denoting the day date bounding rectangle.

Call this member function to determine the day view header's bounding rectangle.

◆ Draw()

virtual void Draw ( CDC * pDC )
virtual

This member function is used to draw the view contents using the specified device context.

Parameters
pDC Pointer to a valid device context.

Call AdjustLayout() before Draw()

See also
AdjustLayout(CRect rcDay)

Reimplemented from CXTPCalendarViewDay.

◆ FillHitTestEx()

virtual void FillHitTestEx ( XTP_CALENDAR_HITTESTINFO * pInfo ) const
virtual

This member function is used to fill a XTP_CALENDAR_HITTESTINFO structure.

Parameters
pInfo Pointer to XTP_CALENDAR_HITTESTINFO structure.

Call this member function to gather hit-test information.

See also
XTP_CALENDAR_HITTESTINFO

Implements CXTPCalendarViewDayT< CXTPCalendarMonthView, CXTPCalendarMonthViewGroup, XTP_CALENDAR_HITTESTINFO, CXTPCalendarMonthViewDay >.

◆ GetDayEventsRect()

CRect GetDayEventsRect ( ) const

This member function is used to calculate the day view area in which to draw event views.

Call this member function to determine the day view area that is used for drawing the event views.

Returns
CRect object with rectangle coordinates.

◆ GetPThis()

AFX_INLINE CXTPCalendarMonthViewDay * GetPThis ( )
protectedvirtual

This member function is used to obtain a pointer to itself.

Call this member function to get the "this" pointer.

Returns
Pointer to a CXTPCalendarMonthViewDay.

Implements CXTPCalendarViewDayT< CXTPCalendarMonthView, CXTPCalendarMonthViewGroup, XTP_CALENDAR_HITTESTINFO, CXTPCalendarMonthViewDay >.

◆ HitTestEx()

virtual BOOL HitTestEx | ( | CPoint | pt,
 |  | XTP_CALENDAR_HITTESTINFO * | pHitTest ) const
 virtual

This member function is used to determine which view item, if any, is at the specified position index, and returns additional info in the XTP_CALENDAR_HITTESTINFO template object.

Parameters
pt | A CPoint that contains the coordinates of the point test.
pHitTest | A pointer to a XTP_CALENDAR_HITTESTINFO structure.

Implements standard functionality for the HitTestEx method.

Returns
A BOOL. TRUE if the item is found. FALSE otherwise.
See also
XTP_CALENDAR_HITTESTINFO

Reimplemented from CXTPCalendarViewDay.

◆ OnLButtonDown()

virtual BOOL OnLButtonDown | ( | UINT | nFlags,
 |  | CPoint | point )
 protectedvirtual

This member function is used to process left mouse button events.

Parameters
nFlags | A UINT that is used to indicates whether various virtual keys are down.
point | A CPoint that specifies the x- and y- coordinates of the cursor. These coordinates are always relative to the upper-left corner of the window.
Returns
TRUE if the message is handled properly, FALSE else.

This method is called by the CalendarControl when the user presses the left mouse button.

Reimplemented from CXTPCalendarWMHandler.

◆ OnMouseMove()

virtual void OnMouseMove | ( | UINT | nFlags,
 |  | CPoint | point )
 protectedvirtual

This member function is used to processes mouse movement events.

Parameters
nFlags | A UINT that is used to indicate whether various virtual keys are down.
point | A CPoint that specifies the x- and y- coordinates of the cursor. These coordinates are always relative to the upper-left corner of the window.

This method is called by the CalendarControl when the user moves the mouse cursor or stylus.

Reimplemented from CXTPCalendarWMHandler.

◆ SetSelected()

virtual void SetSelected ( )
virtual

This member function is used to set the day view as selected.

See also
IsSelected()

Reimplemented from CXTPCalendarViewDay.

The documentation for this class was generated from the following file:
  • XTPCalendarMonthViewDay.h


Toolkit Pro: CXTPCalendarMonthViewEvent Class Reference

Public Types | Public Member Functions | Protected Member Functions | List of all members
CXTPCalendarMonthViewEvent Class Reference

This class represents an event view portion of the CalendarMonthViewDay. More...

Inheritance diagram for CXTPCalendarMonthViewEvent:
[legend]

Public Types

typedef CXTPCalendarViewEventT< CXTPCalendarMonthViewGroup > TBase

Public Member Functions

CXTPCalendarMonthViewEvent (CXTPCalendarEvent *pEvent, CXTPCalendarMonthViewGroup *pViewGroup)
Default object constructor.
virtual | ~CXTPCalendarMonthViewEvent ()
Default class destructor.
virtual void | Draw (CDC *pDC)
This member function is used to draw the view content using the specified device context.
virtual BOOL | HitTestEx (CPoint point, XTP_CALENDAR_HITTESTINFO *pInfo) const
This member function is used to fill a XTP_CALENDAR_HITTESTINFO structure.
virtual void | AdjustLayout (CDC *pDC, const CRect &rcEventMax, int nEventPlaceNumber)
This member function is used to adjust the view's layout depending on the provided bounding rectangle and then calls AdjustLayout() for all sub-items.
virtual void | AdjustLayout2 (CDC *pDC, const CRect &rcEventMax, int nEventPlaceNumber)
This member function is used to adjust the view's layout depending on the provided bounding rectangle and then calls AdjustLayout() for all sub-items.
virtual BOOL | IsVisible () const
This member function is used to obtain the value of the view visible flag.
BOOL | IsShowEndTime () const
This member function is used to obtain the value of the "show end time" flag.
BOOL | IsTimeAsClock () const
This member function is used to obtain the value of the "show time as clock" flag.
virtual void | OnPostAdjustLayout ()
This member function is used to perform additional adjustments.
- Public Member Functions inherited from CXTPCalendarViewEventT< CXTPCalendarMonthViewGroup >
CXTPCalendarViewEventT (CXTPCalendarEvent *pEvent, CXTPCalendarMonthViewGroup *pViewGroup)
Default object constructor.
virtual | ~CXTPCalendarViewEventT ()
Default class destructor.
virtual CXTPCalendarViewGroup * | GetViewGroup_ () const
This member function is used to obtain a base CXTPCalendarViewGroup* pointer to a corresponding DayView object.
CXTPCalendarMonthViewGroup * | GetViewGroup () const
This member function is used to obtain a pointer to a DayView object.
- Public Member Functions inherited from CXTPCalendarViewEvent
CXTPCalendarViewEvent (CXTPCalendarEvent *pEvent, CXTPCalendarViewGroup *pViewGroup)
Default object constructor.
virtual | ~CXTPCalendarViewEvent ()
Default class destructor.
virtual BOOL | HitTest (CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const
This member function is used to determine which view item, if any, is at the specified position index, and returns additional info in the XTP_CALENDAR_HITTESTINFO struct.
virtual CXTPCalendarEvent * | GetEvent () const
Call this member function to obtain the corresponding read only event object without increasing the object's reference counter.
virtual CXTPCalendarControl * | GetCalendarControl () const
Call this member function to obtain a pointer to the calendar control object.
virtual BOOL | IsSelected () const
Call this member function to determine if the given event view is selected.
virtual void | SetSelected (BOOL bSet=TRUE)
This member function is used to set the day view as select or unselected.
virtual BOOL | IsMultidayEvent () const
Call this member function to determine if the given event view is a multi-day event.
virtual CXTPCalendarViewEvent * | StartEditSubject ()
This member function is used to create and to show the subject editor.
virtual CString | GetEditingSubjectFromEditor () const
Call this member function to obtain an edited subject.
virtual CString | EndEditSubject ()
This member function is used to end the editing project, delete the subject editor, and to obtain the edited text.
virtual void | ShowToolTip ()
This member function is used to show a ToolTip rectangle.
virtual void | HideToolTip ()
This member function is used to hide the ToolTip rectangle.
virtual BOOL | IsEditingSubject () const
Call this member function to determine if the event's subject is currently being edited.
virtual CRect | GetSubjectEditorRect () const
This member function is used to obtain the subject editor rectangle coordinates.
virtual CWnd * | GetSubjectEditor () const
This member function is used to obtain the event's subject editor window.
virtual BOOL | IsShowingToolTip ()
Call this member function to determine if the event's tooltip is visible.
virtual CString | FormatEventTime (COleDateTime dtTime) const
This member function is used to format the event's time as a string with a predefined format.
virtual CRect | GetFirstClockRect () const
This member function is used to obtain the rectangle coordinates used for drawing a clock in the beginning of a multi day event.
virtual CRect | GetLastClockRect () const
This member function is used to obtain the rectangle coordinates used for drawing a clock in the end of a multi-day event.
virtual CRect | GetTextRect () const
This member function is used to obtain the rectangle coordinates used for displaying the event's subject.
virtual CRect | GetStartTimeRect () const
This member function is used to obtain the rectangle coordinates used for displaying a clock to show the start event time for single day events.
virtual CRect | GetEndTimeRect () const
This member function is used to obtain the rectangle coordinates for displaying a clock to show the end event time for single day events.
virtual CRect | GetViewEventRect () const
This member function is used to obtain the rectangle coordinates for the event's rectangle.
virtual CRect | GetViewEventRectMax () const
This member function is used to obtain the rectangle coordinates for the event's maximum rectangle dimensions.
virtual CRect | GetReminderGlyphRect () const
This member function is used to obtain the rectangle coordinates for displaying the remainder icon.
virtual CRect | GetRecurrenceGlyphRect () const
This member function is used to obtain the rectangle coordinates used for displaying the recurrence icon.
virtual CRect | GetMeetingGlyphRect () const
This member function obtains the rectangle coordinates for displaying the meeting icon.
virtual CRect | GetPrivateGlyphRect () const
This member function is used to obtain the rectangle coordinates used for displaying the private icon.
virtual BOOL | IsMultyDayTextAlign () const
This member function is used to obtain the flag to determine if multi-day text align mode is on.
virtual int | GetMultiDayEventFlags () const
This member function is used to obtain the multi-day event state flags.
virtual void | SetMultiDayEvent_MasterSlave (BOOL bMaster, CXTPCalendarViewEvent *pMasterView)
This member function is used to set the multi-day event Master/Slave state.
virtual void | AddMultiDayEvent_Slave (CXTPCalendarViewEvent *pSlaveView, int nMasterEventPlace)
This member function is used to add a Slave event view to the Master event view.
virtual void | SetTextOutOfBorders (BOOL bOutOfBorders)
This member function is used to set a flag to determine if the text size exceeds the event view bounds.
virtual BOOL | IsTextOutOfBorders () const
This member function is used to determine if the text size exceeds the event view bounds.
virtual int | GetEventPlaceNumber () const
This member function is used to obtain the place number of the event view.
virtual int | GetEventTimelinePlaceNumber () const
This member function is used to obtain the place number of the event in Timeline view.
CRect | GetEventRect () const
This member function is used to obtain the event view's bounding rectangle.
virtual void | AdjustSubjectEditor ()
This member function is used to perform adjustments of the subject editor area.
virtual CString | GetItemTextSubject () const
Call this function to get the item subject.
virtual CString | GetItemTextLocation () const
Call this function to get the item location.
virtual CString | GetItemTextBody () const
Call this function to get the item body.
virtual CString | GetItemTextStartTime () const
Call this function to get the item start time.
virtual CString | GetItemTextEndTime () const
Call this function to get the item end time.
virtual CString | GetItemText (DWORD dwItemFlag, LPCTSTR pcszDefaultText=NULL) const
Call this function to get the item text.
virtual CString | GetMarkupText () const
This member function is used to obtain markup template text.
virtual CXTPMarkupUIElement * | GetMarkupUIElement ()
This member function is used to get a stored CXTPMarkupUIElement object.
virtual int | CalcIconsRect (CRect rc)
This member function is used to adjust the icons rectangle used to draw the event view icons.
virtual BOOL | OnLButtonDown (UINT nFlags, CPoint point)
This member function is used to process left mouse button down events.
virtual BOOL | OnLButtonUp (UINT nFlags, CPoint point)
This member function is used to process left mouse button up events.
virtual BOOL | OnLButtonDblClk (UINT nFlags, CPoint point)
This member function is used to process left mouse button double click events.
virtual void | OnMouseMove (UINT nFlags, CPoint point)
This member function is used to process mouse movement events.
virtual BOOL | OnWndMsg (UINT message, WPARAM wParam, LPARAM lParam, LRESULT *pResult)
This method is called by framework after default message processing.
virtual UINT | SetTimer (UINT uTimeOut_ms)
This member function is used to create a timer event.
virtual void | KillTimer (UINT uTimerID)
This member function is used to destroy a timer event.
virtual BOOL | OnTimer (UINT_PTR uTimerID)
The framework calls this member function after each interval specified in the SetTimer member function.
virtual UINT | GetShowToolTipTimeOut () const
This member function is used to obtain the timeout value for displaying a tooltip.
virtual DWORD | GetSubjectEditorStyles () const
This member function is used to obtain the styles of the editor window.
virtual void | ChangeEventPlace (int nNewPlace)
This function is used to change the event place number.
virtual void | OnBeforeDestroy ()
Called by the framework before the destroy() function is called.
- Public Member Functions inherited from CXTPCalendarWMHandler
CXTPCalendarWMHandler ()
Default object constructor.
virtual int | GetChildHandlersCount () const
This member function is used to obtain the number of CXTPCalendarWMHandler elements in the descendant handlers collection.
virtual CXTPCalendarWMHandler * | GetChildHandlerAt (int nIndex) const
Call this method to get a handler object at the specified numeric index.
virtual void | OnChar (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process keyboard events.
virtual void | OnKeyDown (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process key-down keyboard events.
virtual void | OnKeyUp (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process key-up keyboard events.
virtual BOOL | OnSysKeyDown (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process key-up keyboard events.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

virtual CFont * | GetSubjectEditorFont () const
This member function is used to obtain the editor window font.
- Protected Member Functions inherited from CXTPCalendarViewEvent
virtual void | AdjustMultidayEvent (CRect rcEventMax, int nEventPlaceNumber)
This member function is used to adjust a multi-day view's layout depending on the provided rectangle coordinates.
virtual CString | GetToolText ()
This member function is used to obtain tooltip text for the event view.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCalendarViewEvent
static void AFX_CDECL | _MoveRectY (int nYbasePrev, int nYbaseNew, CRect &rRC)
This member function is used to move the rectangle vertically.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPCalendarViewEvent
CRect | m_rcEvent
Event view rectangle.
CRect | m_rcEventMax
Event view rectangle margins.
CRect | m_rcText
Rectangle to display event text in event view.
CSize | m_szText
Sizes of displayed text.
CRect | m_rcFirstClock
Rectangle to draw clock in the beginning of the first day of multi-day event.
CRect | m_rcLastClock
Rectangle to draw clock at the end of the last day of multi-day event.
CRect | m_rcStartTime
Rectangle to display start time day event view.
CRect | m_rcEndTime
Rectangle to display end time event view.
int | m_nMultiDayEventFlags
Multi-day event flags packed into integer by bitwise operations.
CRect | m_rcReminderGlyph
Rectangle to draw reminder glyph event view.
CRect | m_rcRecurrenceGlyph
Rectangle to draw recurrence glyph event view.
CRect | m_rcMeetingGlyph
Rectangle to draw meeting glyph event view.
CRect | m_rcPrivateGlyph
Rectangle to draw private glyph event view.
CRect | m_rcSubjectEditor
Subject editor rectangle.
CRect | m_rcToolTip
Tool tip rectangle.
CXTPMarkupUIElement * | m_pUIElement
Store pointer to CXTPMarkupUIElement object.
CString | m_strUIElementText
Store last markup text for which m_pUIElement object was updated.
- Protected Attributes inherited from CXTPCalendarViewEvent
CXTPCalendarEvent * m_ptrEvent
Pointer to the displayed event object.
BOOL | m_bSelected
Event view selected flag.
CXTPCalendarViewEvent * m_pMasterView
Pointer to Master event view object.
int | m_nEventPlaceNumber
Event view place number (sequential identifier).
int | m_nEventTimelinePlaceNumber
Event view place number in Timeline view.
UINT | m_nTimerID_ShowToolTip
Identifier of timer event to show tooltip with delay.
CXTPCalendarViewEventSubjectEditor * | m_pSubjectEditor
Pointer to the subject editor.
BOOL | m_bMultyDayTextAlign
Flag indicates special text alignment for a multi-day event.
BOOL | m_bTextOutOfBorders
Flag indicates text out of event borders.

Detailed Description

This class represents an event view portion of the CalendarMonthViewDay.

It represents a specific view of the event associated data according to various view types and display settings and provides basic functionality on this data using user input through keyboard and mouse.

 CXTPCalendarMonthViewEvent is based on the CXTPCalendarViewEventT template
 class. It inherits basic behavior from the CXTPCalendarViewEventT template
 class. Furthermore, CXTPCalendarMonthViewEvent overlaps and adds some
 new functionality to get its own behavior and appearance.
See also
CXTPCalendarViewEvent
CXTPCalendarViewEventT

Member Typedef Documentation

◆ TBase

CXTPCalendarViewEventT<CXTPCalendarMonthViewGroup> TBase

Base class type definition.

Constructor & Destructor Documentation

◆ CXTPCalendarMonthViewEvent()

CXTPCalendarMonthViewEvent | ( | CXTPCalendarEvent * | pEvent,
 |  | CXTPCalendarMonthViewGroup * | pViewGroup )

Default object constructor.

Parameters
pEvent | Pointer to CXTPCalendarEvent.
pViewGroup | Pointer to CXTPCalendarMonthViewGroup object.
See also
~CXTPCalendarWeekViewDay()

Member Function Documentation

◆ AdjustLayout()

virtual void AdjustLayout | ( | CDC * | pDC,
 |  | const CRect & | rcEventMax,
 |  | int | nEventPlaceNumber )
 virtual

This member function is used to adjust the view's layout depending on the provided bounding rectangle and then calls AdjustLayout() for all sub-items.

Parameters
pDC | Pointer to a valid device context.
rcEventMax | A CRect object that contains the coordinates for drawing the view.
nEventPlaceNumber | An int that contains the sequential place number.

Call Populate(COleDateTime dtDayDate) prior to calling AdjustLayout(). AdjustLayout2 is called by calendar control instead of AdjustLayout when theme is set.

Reimplemented from CXTPCalendarViewEvent.

◆ AdjustLayout2()

virtual void AdjustLayout2 | ( | CDC * | pDC,
 |  | const CRect & | rcEventMax,
 |  | int | nEventPlaceNumber )
 virtual

This member function is used to adjust the view's layout depending on the provided bounding rectangle and then calls AdjustLayout() for all sub-items.

Parameters
pDC | Pointer to a valid device context.
rcEventMax | A CRect object that contains the coordinates for drawing the view.
nEventPlaceNumber | An int that contains the sequential place number.

Call Populate(COleDateTime dtDayDate) prior to calling AdjustLayout(). AdjustLayout2 is called by calendar control instead of AdjustLayout when theme is set.

Implements CXTPCalendarViewEvent.

◆ Draw()

virtual void Draw ( CDC * pDC )
virtual

This member function is used to draw the view content using the specified device context.

Parameters
pDC Pointer to a valid device context.

Call AdjustLayout() before Draw()

See also
AdjustLayout(CRect rcDay)

Implements CXTPCalendarViewEvent.

◆ GetSubjectEditorFont()

virtual CFont * GetSubjectEditorFont ( ) const
protectedvirtual

This member function is used to obtain the editor window font.

Returns
A pointer to a CFont object that contains the editor window font.

Reimplemented from CXTPCalendarViewEvent.

◆ HitTestEx()

virtual BOOL HitTestEx | ( | CPoint | point,
 |  | XTP_CALENDAR_HITTESTINFO * | pInfo ) const
 virtual

This member function is used to fill a XTP_CALENDAR_HITTESTINFO structure.

Parameters
point | A CPoint that contains the point to test.
pInfo | A pointer to a XTP_CALENDAR_HITTESTINFO structure.
Returns
TRUE if the test is successful, FALSE else.

Call this member function to gather hit test information from the day view.

See also
XTP_CALENDAR_HITTESTINFO

Implements CXTPCalendarViewEvent.

◆ IsShowEndTime()

BOOL IsShowEndTime ( ) const

This member function is used to obtain the value of the "show end time" flag.

Call this member function to determine the value of the "show end time" flag.

Returns
A BOOL. TRUE if the view shows the end time value. FALSE otherwise.

◆ IsTimeAsClock()

BOOL IsTimeAsClock ( ) const

This member function is used to obtain the value of the "show time as clock" flag.

Call this member function to determine the value of the "show time as clock" flag.

Returns
A BOOL. TRUE if the view shows the time as a clock. FALSE otherwise.

◆ IsVisible()

virtual BOOL IsVisible ( ) const
virtual

This member function is used to obtain the value of the view visible flag.

Call this member function to determine the value of the visible flag.

Returns
A BOOL. TRUE if the view is visible. FALSE otherwise.

Implements CXTPCalendarViewEvent.

◆ OnPostAdjustLayout()

virtual void OnPostAdjustLayout ( )
virtual

This member function is used to perform additional adjustments.

Call this member function to perform additional adjustments after all adjustment activities are completed.

Reimplemented from CXTPCalendarViewEvent.

The documentation for this class was generated from the following file:
  • XTPCalendarMonthViewEvent.h


Toolkit Pro: CXTPCalendarMonthViewGroup Class Reference

Public Types | Public Member Functions | Protected Member Functions | List of all members
CXTPCalendarMonthViewGroup Class Reference

This class represents a single resource view portion of the Calendar Month View. More...

Inheritance diagram for CXTPCalendarMonthViewGroup:
[legend]

Public Types

typedef CXTPCalendarViewGroupT< CXTPCalendarMonthViewDay, CXTPCalendarMonthViewEvent, CXTPCalendarMonthViewGroup > | TBase
Base class type definition.
- Public Types inherited from CXTPCalendarViewGroupT< CXTPCalendarMonthViewDay, CXTPCalendarMonthViewEvent, CXTPCalendarMonthViewGroup >
typedef CXTPCalendarMonthViewDay | TViewDay

Public Member Functions

CXTPCalendarMonthViewGroup (CXTPCalendarMonthViewDay *pViewDay)
Default object constructor.
virtual | ~CXTPCalendarMonthViewGroup ()
Default class destructor.
virtual CRect | GetTooltipRect (const CPoint &ptHit, const XTP_CALENDAR_HITTESTINFO &hitInfo) const
Call this member function to obtain the bounding rectangle of the tooltip space (currently this is only "click to add new appointment").
- Public Member Functions inherited from CXTPCalendarViewGroupT< CXTPCalendarMonthViewDay, CXTPCalendarMonthViewEvent, CXTPCalendarMonthViewGroup >
CXTPCalendarViewGroupT (CXTPCalendarMonthViewDay *pViewDay)
Default object constructor.
virtual | ~CXTPCalendarViewGroupT ()
Default class destructor.
CXTPCalendarMonthViewDay * | GetViewDay () const
This member function is used to obtain the owner view object.
virtual CXTPCalendarMonthViewEvent * | GetViewEvent (int nIndex) const
Call this member function to obtain a pointer to the _TViewEvent object that corresponds to the event's index.
- Public Member Functions inherited from CXTPCalendarViewGroup
CXTPCalendarViewGroup (CXTPCalendarViewDay *pViewDay)
Default object constructor.
virtual | ~CXTPCalendarViewGroup ()
Default class destructor.
virtual CXTPCalendarResources * | GetResources () const
Obtain a pointer to a collection of Calendar Resources.
virtual CXTPCalendarData * | GetDataProvider () const
Returns data provider for this view group.
virtual void | AddResource (CXTPCalendarResource *pResource, BOOL bWithAddRef)
Adds a new Resource object into the collection of resources for this Group View.
virtual void | SetResources (CXTPCalendarResources *pResources)
Assigns a new Resources collection to this Group View.
virtual UINT | GetScheduleID () const
Returns default Schedule ID - the first existing one.
virtual void | Populate (COleDateTime dtDayDate)
This member function is used to populate the view with data for all items contained in the view.
virtual void | AdjustLayout (CDC *pDC, const CRect &rcGroup)
This member function is used to adjust the view's layout depending on the provided rectangle and then calls AdjustLayout() for all of the sub-items.
virtual void | AdjustLayout2 (CDC *pDC, const CRect &rcGroup)
This member function is used to adjust the view's layout depending on the provided rectangle and then calls AdjustLayout() for all of the sub-items.
virtual void | Draw (CDC *pDC)
This member function is used to draw the view contents using the specified device context.
virtual BOOL | HitTest (CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const
This member function is used to determine which view item, if any, is at the specified position index, and returns additional info in an XTP_CALENDAR_HITTESTINFO struct.
virtual BOOL | HitTestEx (CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const
This member function is used to determine which view item, if any, is at the specified position index, and returns additional info in the XTP_CALENDAR_HITTESTINFO template object.
virtual CRect | GetRect () const
Call this member function to obtain the group's rectangle area.
virtual CRect | GetHeaderRect () const
Call this member function to obtain the group's header rectangle area.
int | GetViewEventsCount () const
Call this member function to obtain the number of event views in the day view collection.
CXTPCalendarViewEvent * | GetViewEvent_ (int nIndex) const
Call this member function to obtain a pointer to a CXTPCalendarViewEvent object associated with the event's index.
CXTPCalendarViewDay * | GetViewDay_ () const
Call this member function to obtain a pointer to the containing CXTPCalendarViewDay object.
virtual int | GetGroupIndex () const
This member function is used to obtain the index of the "this" pointer Group View in the Calendar Day View.
virtual CString | GetCaption () const
This member function is used to obtain a group's view caption.
virtual int | GetChildHandlersCount () const
This member function is used to obtain the number of event views elements in this Group View.
virtual CXTPCalendarWMHandler * | GetChildHandlerAt (int nIndex) const
Call this method to get an event view object at the specified numeric index.
virtual CXTPCalendarViewEvent * | GetViewEventByEvent_ (CXTPCalendarEvent *pEvent) const
Call this member function to obtain a pointer to a CXTPCalendarViewEvent object that is identified by the corresponding event object.
virtual CXTPCalendarViewEvent * | GetViewEventByPlace_ (int nEventPlace) const
Call this member function to obtain an event view object identified by its event place number.
virtual CXTPCalendarControl * | GetCalendarControl () const
Call this member function to obtain a pointer to the calendar control object.
virtual void | ExchangeEventPlace (CXTPCalendarViewEvent *pViewEvent, int nNewPlace)
This member function is used to exchange event view positions.
- Public Member Functions inherited from CXTPCalendarWMHandler
CXTPCalendarWMHandler ()
Default object constructor.
virtual BOOL | OnLButtonDown (UINT nFlags, CPoint point)
This member function is used to process left mouse button down events.
virtual BOOL | OnLButtonUp (UINT nFlags, CPoint point)
This member function is used to process left mouse button up events.
virtual BOOL | OnLButtonDblClk (UINT nFlags, CPoint point)
This member function is used to process left mouse button double click events.
virtual void | OnMouseMove (UINT nFlags, CPoint point)
This member function is used to process mouse movement events.
virtual void | OnChar (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process keyboard events.
virtual void | OnKeyDown (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process key-down keyboard events.
virtual void | OnKeyUp (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process key-up keyboard events.
virtual BOOL | OnSysKeyDown (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process key-up keyboard events.
virtual BOOL | OnTimer (UINT_PTR uTimerID)
The framework calls this member function after each interval specified in the SetTimer member function.
virtual BOOL | OnWndMsg (UINT message, WPARAM wParam, LPARAM lParam, LRESULT *pResult)
This method is called by framework after default message processing.
virtual void | OnPostAdjustLayout ()
This member function is used to perform additional adjustments in some kinds of views.
virtual void | OnBeforeDestroy ()
This member function is called by the framework before destroying the view.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

virtual CXTPCalendarMonthViewGroup * | GetPThis ()
This member function is used to obtain a pointer to itself.
virtual void | FillHitTestEx (XTP_CALENDAR_HITTESTINFO *pHitTest) const
This member function is used to fill a XTP_CALENDAR_HITTESTINFO structure.
- Protected Member Functions inherited from CXTPCalendarViewGroupT< CXTPCalendarMonthViewDay, CXTPCalendarMonthViewEvent, CXTPCalendarMonthViewGroup >
- Protected Member Functions inherited from CXTPCalendarViewGroup
virtual UINT | SetTimer (UINT uTimeOut_ms)
This member function is used to create a timer event.
virtual void | KillTimer (UINT uTimerID)
This member function is used to destroy a timer event.
virtual void | OnPrePopulate (CXTPCalendarEvents *pEvents)
This member function is used to allow some customization before show events.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Attributes inherited from CXTPCalendarViewGroup
XTP_VIEW_GROUP_LAYOUT | m_Layout
This group view client coordinates.
CXTPCalendarPtrCollectionT< CXTPCalendarViewEvent > | m_arEvents
Storage for events views.
CXTPCalendarResources * | m_pResources
An associated resource object.
CXTPCalendarViewDay * | m_pViewDay
Parent day view.

Detailed Description

This class represents a single resource view portion of the Calendar Month View.

It represents a specific view of the CalendarView's associated events data grouped by one day and one resource group. And provides basic functionality on this data using user input through keyboard and mouse.

See also
CXTPCalendarMonthViewDay

Constructor & Destructor Documentation

◆ CXTPCalendarMonthViewGroup()

CXTPCalendarMonthViewGroup ( CXTPCalendarMonthViewDay * pViewDay )

Default object constructor.

Construct CXTPCalendarMonthViewGroup object.

Parameters
pViewDay Pointer to CXTPCalendarMonthViewDay object.

◆ ~CXTPCalendarMonthViewGroup()

virtual ~CXTPCalendarMonthViewGroup ( )
virtual

Default class destructor.

Handles member items deallocation.

Member Function Documentation

◆ FillHitTestEx()

virtual void FillHitTestEx ( XTP_CALENDAR_HITTESTINFO * pHitTest ) const
protectedvirtual

This member function is used to fill a XTP_CALENDAR_HITTESTINFO structure.

Parameters
pHitTest Pointer to XTP_CALENDAR_HITTESTINFO structure.

Call this member function to gather hit-test information.

See also
XTP_CALENDAR_HITTESTINFO

Implements CXTPCalendarViewGroupT< CXTPCalendarMonthViewDay, CXTPCalendarMonthViewEvent, CXTPCalendarMonthViewGroup >.

◆ GetPThis()

AFX_INLINE CXTPCalendarMonthViewGroup * GetPThis ( )
protectedvirtual

This member function is used to obtain a pointer to itself.

Call this member function to get the "this" pointer.

Returns
Pointer to a CXTPCalendarMonthViewGroup.

Implements CXTPCalendarViewGroupT< CXTPCalendarMonthViewDay, CXTPCalendarMonthViewEvent, CXTPCalendarMonthViewGroup >.

◆ GetTooltipRect()

virtual CRect GetTooltipRect | ( | const CPoint & | ptHit,
 |  | const XTP_CALENDAR_HITTESTINFO & | hitInfo ) const
 virtual

Call this member function to obtain the bounding rectangle of the tooltip space (currently this is only "click to add new appointment").

Tooltip rectangle is calculated based on the current mouse position.

Parameters
ptHit | mouse position point
hitInfo | info to get
Returns
A CRect object with relative coordinates of the tooltip.

This member function returns a rectangle calculated as a bottom cell rect of the day area where user currently holds a mouse on.

Reimplemented from CXTPCalendarViewGroup.

The documentation for this class was generated from the following file:
  • XTPCalendarMonthViewDay.h


Toolkit Pro: CXTPCalendarMsgNotifier Class Reference

Public Types | Public Member Functions | Protected Member Functions | List of all members
CXTPCalendarMsgNotifier Class Reference

This class is used to catch windows messages, which the system sends to top-level windows, and to send them to subscribers windows. More...

Public Types

enum EnumParams { msgAll = 0 }
This enum contains additional parameter value(s). More...

Public Member Functions

CXTPCalendarMsgNotifier ()
Default object constructor.
virtual | ~CXTPCalendarMsgNotifier ()
Default object destructor.
void | Advise (CWnd *pWnd, UINT uWndMsg=msgAll)
Advise CWnd object to receive specified top-level windows message(s).
void | Unadvise (CWnd *pWnd, UINT uWndMsg=msgAll)
Unadvise CWnd object from receive specified top-level windows message(s).

Protected Member Functions

BOOL CreateWnd ()
This method is used to Create a CWnd object.

Detailed Description

This class is used to catch windows messages, which the system sends to top-level windows, and to send them to subscribers windows.

The following messages are supported: WM_TIMECHANGE WM_SYSCOLORCHANGE

See also
WM_TIMECHANGE
WM_SYSCOLORCHANGE

Member Enumeration Documentation

◆ EnumParams

enum EnumParams

This enum contains additional parameter value(s).

Enumerator
msgAll

This value means all messages or any message.

Member Function Documentation

◆ Advise()

void Advise | ( | CWnd * | pWnd,
 |  | UINT | uWndMsg = msgAll )

Advise CWnd object to receive specified top-level windows message(s).

Parameters
pWnd | [in] A pointer to client window.
uWndMsg | [in] Windows message ID.

If uWndMsg is msgAll than all supported messages will be sent to client window.

See also
Unadvise

◆ CreateWnd()

BOOL CreateWnd ( )
protected

This method is used to Create a CWnd object.

A simple top-level window will be created.

Returns
TRUE is successfull, FALSE otherwise.

◆ Unadvise()

void Unadvise | ( | CWnd * | pWnd,
 |  | UINT | uWndMsg = msgAll )

Unadvise CWnd object from receive specified top-level windows message(s).

Parameters
pWnd | [in] A pointer to client window.
uWndMsg | [in] Windows message ID.

If uWndMsg is msgAll unadvised from all supported messages.

See also
Advise
The documentation for this class was generated from the following file:
  • XTPCalendarMsgNotifier.h


Toolkit Pro: CXTPCalendarNativeWindows10Theme Class Reference

Public Member Functions | List of all members
CXTPCalendarNativeWindows10Theme Class Reference

CXTPCalendarNativeWindows10Theme is a CXTPCalendarOffice2013Theme derived class that represents the Native Windows 10 calendar theme. More...

Inheritance diagram for CXTPCalendarNativeWindows10Theme:
[legend]

Public Member Functions

CXTPCalendarNativeWindows10Theme ()
Default paint manager constructor.
virtual | ~CXTPCalendarNativeWindows10Theme ()
Default paint manager destructor.
- Public Member Functions inherited from CXTPCalendarOffice2013Theme
CXTPCalendarOffice2013Theme ()
Default paint manager constructor.
virtual | ~CXTPCalendarOffice2013Theme ()
Default paint manager destructor.
virtual void | RefreshMetrics ()
This member function is used to initialize all drawing defaults.
virtual void | DrawHeader (CDC *pDC, CRect &rcHeader, BOOL bIsSelected, BOOL bIsCurrent, const CXTPPaintManagerColorGradient &grclr, COLORREF clrUnderLineHdr)
This member function is used to draw the Header.
virtual void | UpdateEventLabelsDefaultColors ()
This member function is called to update event label default colors.
virtual void | UpdateEventCategoriesDefaultColors ()
This member function is called to update event category default colors.
virtual void | UpdateGlyphs ()
Initializes Calendar images.
virtual COLORREF | GetEventBackColor (CXTPCalendarEvent *pEvent)
Call this member function to get the background color for the specified event.
virtual COLORREF | GetEventEdgeColor (CXTPCalendarEvent *pEvent)
Call this member function to get the edge color for the specified event.
- Public Member Functions inherited from CXTPCalendarOffice2000Theme
CXTPCalendarOffice2000Theme ()
Default paint manager constructor.
virtual | ~CXTPCalendarOffice2000Theme ()
Default paint manager destructor.
- Public Member Functions inherited from CXTPCalendarPaintManager
BEGIN_VIEW_PART (ControlPart, XTPCalendarViewPart) virtual void RefreshMetrics()
Paint manager's ControlPart is used as parent for the other parts of the control.
END_VIEW_PART (ControlPart) BEGIN_VIEW_PART(DayViewTimeScaleHeaderPart
This paint manager part is used to draw the time scale header, 'Now' line, and the expand signs for the Day View.
virtual void | OnDraw (CDC *pDC, CXTPCalendarDayView *pView, CRect rc, CString strText)
This member function is used to draw the time scale header.
virtual void | DrawNowLine (CDC *pDC, CXTPCalendarDayView *pView, CRect rc, int y, BOOL bDrawBk=FALSE)
This member function is used to draw the 'Now' line.
virtual void | DrawNowLine (CDC *pDC, CXTPCalendarDayView *pView, CXTPCalendarDayViewTimeScale *pScale, CRect rc, int y, BOOL bDrawBk=FALSE)
This member function is used to draw the 'Now' line.
virtual void | DrawExpandSigns (CDC *pDC, CXTPCalendarDayView *pView, const CRect &rcTSHours)
This member function is used to draw expand signs.
END_VIEW_PART (DayViewTimeScaleHeaderPart) BEGIN_VIEW_PART(DayViewTimeScaleCellPart
This paint manager part is used to draw time scale time cells for the Day View.
void | AdjustTimeFont (CDC *pDC, CRect rcCell)
This member function is used to adjust the time text font size.
void | CalcWidth (CDC *pDC, const CString &strHour, const CString &strMin, int nHourHeight, int &nWidth)
This member function is used to adjust the time text font size.
virtual void | DrawHourCell (CDC *pDC, CRect rc, CString strText, BOOL bFillBackground=TRUE, BOOL bCurrentTime=FALSE)
This member function is used to draw background of the time scale header.
virtual void | DrawBigHourCell (CDC *pDC, CRect rc, CString strHour, CString strMin, int nRowPerHour, BOOL bFillBackground=TRUE, BOOL bCurrentTime=FALSE)
This member function is used to draw the big hour cell.
END_VIEW_PART (DayViewTimeScaleCellPart) BEGIN_VIEW_PART(DayViewCellPart
This paint manager part is used as the base class for the parts which draw different kinds of no all-day-cells (work/non-work) for the Day View.
virtual void | GetParams (CXTPCalendarDayViewGroup *pViewGroup, XTP_CALENDAR_DAYVIEWCELL_PARAMS *rCellParams)
This member function is used to fill out cell parameters with default values.
virtual void | OnDraw (CDC *pDC, CXTPCalendarDayViewGroup *pViewGroup, CRect rc, const XTP_CALENDAR_DAYVIEWCELL_PARAMS &cellParams)
This member function is used to draw the day view with no all-day-cells.
END_VIEW_PART (DayViewCellPart) BEGIN_VIEW_PART(DayViewWorkCellPart
This paint manager part is used to draw a day view that contains no all day work time cells.
END_VIEW_PART (DayViewWorkCellPart) BEGIN_VIEW_PART(DayViewNonworkCellPart
This paint manager part is used to draw "no all day non-work" time cells for the Day View.
END_VIEW_PART (DayViewNonworkCellPart) BEGIN_VIEW_PART(DayMonthViewHeaderPart
This paint manager part is used to draw days headers for the Day View.
END_VIEW_PART (DayMonthViewHeaderPart) BEGIN_VIEW_PART(DayViewHeaderPart
This paint manager part is used to draw days headers for the Day View.
virtual DayMonthViewHeaderPart void | OnDraw (CDC *pDC, CXTPCalendarDayViewDay *pViewDay, CRect rc, CString strText)
This member function is used to draw the day header.
END_VIEW_PART (DayViewHeaderPart) BEGIN_VIEW_PART(DayViewGroupHeaderPart
This paint manager part is used to draw Groups headers for the Day View.
virtual DayMonthViewHeaderPart void | OnDraw (CDC *pDC, CXTPCalendarDayViewGroup *pViewGroup, CRect rc, CString strText)
This member function is used to draw the day header.
END_VIEW_PART (DayViewGroupHeaderPart) BEGIN_VIEW_PART(DayViewAllDayEventsPart
This paint manager part is used to draw all day events area for the Day View.
virtual void | OnDraw (CDC *pDC, CXTPCalendarDayViewGroup *pViewGroup, CRect rc, BOOL bSelected)
This member function is used to draw the all-day events area.
END_VIEW_PART (DayViewAllDayEventsPart) BEGIN_VIEW_PART(DayViewAllDayEventScrollIconsPart
This paint manager part is used to draw all day events scroll buttons if there are too many all day events.
virtual XTPCalendarViewPart void | OnDraw (CDC *pDC, CXTPCalendarDayViewGroup *pViewGroup, BOOL bDrawUp, BOOL bDrawDown, const CRect &rcIconUp, const CRect &rcIconDown, BOOL bHighlightUp, BOOL bHighlightDown)
This member function is used to draw scroll icons in all day events area.
END_VIEW_PART (DayViewAllDayEventScrollIconsPart) BEGIN_VIEW_PART(DayViewEventPart
This paint manager part is used to draw events for the Day View.
virtual void | OnDraw (CDC *pDC, CXTPCalendarDayViewEvent *pViewEvent)
This member function is used to draw an event.
END_VIEW_PART (DayViewEventPart) BEGIN_VIEW_PART(MonthViewGridPart
This paint manager part is used to draw days grid and to fill days cells background for the Month View.
virtual void | OnDrawGrid (CDC *pDC, CXTPCalendarMonthView *pMonthView)
This member function is used to draw the days grid and to fill the days cells background.
END_VIEW_PART (MonthViewGridPart) BEGIN_VIEW_PART(MonthViewHeaderPart
This paint manager part is used to draw week days headers for the Month View.
virtual DayMonthViewHeaderPart void | OnDraw (CDC *pDC, CXTPCalendarMonthView *pMonthView, CRect rc, int nCollIndex, CString strText)
This member function is used to draw the week day header.
END_VIEW_PART (MonthViewHeaderPart) BEGIN_VIEW_PART(MonthViewEventPart
This paint manager part is used to draw events and day dates for the Month View.
virtual void | OnDrawEvent (CDC *pDC, CXTPCalendarMonthViewEvent *pViewEvent)
This member function is used to draw an event.
virtual void | OnDrawDayDate (CDC *pDC, CRect rc, BOOL bToday, BOOL bSelected, BOOL bFirstMonthDay, CString strText)
This member function is used to draw the week day header.
END_VIEW_PART (MonthViewEventPart) BEGIN_VIEW_PART(WeekViewPart
This paint manager part is used to draw week days grid and headers for the Week View.
virtual void | OnDraw (CDC *pDC, CXTPCalendarWeekView *pWeekView)
This member function is used to draw an event.
virtual void | DrawDayHeader (CDC *pDC, CRect rcDay, int nHeaderHeight, CString strHeader, BOOL bIsCurrent=FALSE, BOOL bIsSelected=FALSE)
This member function is used to draw the day header.
END_VIEW_PART (WeekViewPart) BEGIN_VIEW_PART(WeekViewEventPart
This paint manager part is used to draw events for the Week View.
virtual void | OnDraw (CDC *pDC, CXTPCalendarWeekViewEvent *pWeekViewEvent)
This member function is used to draw the specified event.
virtual void | DrawBorder (CDC *pDC, CRect rcView, CXTPCalendarWeekViewEvent *pWeekViewEvent)
This member functions is used to draw the event border.
virtual int | DrawTimes (CDC *pDC, CXTPCalendarWeekViewEvent *pWeekViewEvent)
This member function is used to draw the event's times texts or icons.
virtual void | DrawSubj (CDC *pDC, CXTPCalendarWeekViewEvent *pWeekViewEvent)
This member function is used to draw the event subject.
END_VIEW_PART (WeekViewEventPart) BEGIN_VIEW_PART(TimeLineViewTimeScalePart_Day
This paint manager part is used to draw time scale for the Time Line view.
virtual void | DrawGroup (CDC *pDC, const CRect &rcRect, CXTPCalendarTimeLineViewGroup *pGroup)
Call this function to draw the time line view group.
virtual CSize | CalcEventSize (CDC *c, CXTPCalendarTimeLineViewEvent *pViewEvent)
Call this function to calculate the time line view event size.
virtual void | DrawEvent (CDC *pDC, const CRect &rcEvents, CXTPCalendarTimeLineViewEvent *pViewEvent)
Call this function to draw the event.
virtual void | _Init ()
Call this function to do the initializations.
virtual | ~CTimeLineViewPart ()
Destroys the CTimeLineViewPart object, does the cleanup.
CXTPCalendarPaintManager ()
Default paint manager constructor.
virtual | ~CXTPCalendarPaintManager ()
Default paint manager destructor.
virtual XTPCalendarTheme | GetPaintTheme () const
This member function is used to obtain the current paint theme.
virtual void | SetPaintTheme (XTPCalendarTheme ePaintTheme)
This member function is used to set the current paint theme.
virtual COLORREF | GetEventBackColor (CXTPCalendarEvent *pEvent, COLORREF crDefault)
Call this member function to get the background color for the specified event.
virtual void | DrawLine (CDC *pDC, int xPos, int yPos, int cx, int cy)
This member function is used to draw an arbitrary line.
virtual void | DrawHorizontalLine (CDC *pDC, int xPos, int yPos, int cx)
This member function is used to draw a Horizontal line.
virtual void | DrawVerticalLine (CDC *pDC, int xPos, int yPos, int cy)
This member function is used to draw a Vertical line.
virtual int | DrawClock (CDC *pDC, COleDateTime dtClockTime, CRect rcView, COLORREF clrBackground, XTPCalendarClockAlignFlags cafAlign)
This member function is used to draw the time as a clock.
virtual int | DrawBitmap (CImageList *pImageList, CDC *pDC, CRect rcView, int iIcon, UINT uFlags=0)
This member function is used to draw a bitmap from the provided ImageList.
virtual int | DrawBitmap (UINT nIDResource, CDC *pDC, CRect rcBitmap)
This member function is used to draw the bitmap using its resource id.
virtual int | DrawIconChar (CDC *pDC, CRect rc, TCHAR ch)
This member function is used to draw the Glyph symbol using special font.
virtual const CSize | GetExpandSignSize ()
This member function is used to obtain the horizontal and vertical size of the Expand Sign bitmap.
virtual CSize | GetClockSize ()
This member function is used to obtain the horizontal and vertical size of the Clock.
virtual void | SetControl (CXTPCalendarControl *pControl)
This member function is used to set the CXTPCalendarControl object for the CXTPCalendarPaintManager.
virtual void | DrawShadow (CDC *pDC, const CRect &rcRect)
Call this member function to draw the shadow regions around the rectangle.
virtual int | DrawIcons (CDC *pDC, CXTPCalendarViewEvent *pViewEvent)
Call this member function to draw icons corresponding to the event state.
virtual void | DrawHeader (CDC *pDC, CRect &rcHeader, BOOL bIsSelected, BOOL bIsCurrent)
This member function is used to draw the Header.
virtual void | DrawBusyStatus (CDC *pDC, CRect &rcRect, int eBusyStatus)
This member function is used to fill the area using the corresponding busy color or pattern.
virtual void | DrawBusyStatus (CDC *pDC, CRgn &rgnBusy, int eBusyStatus)
This member function is used to fill the area using the corresponding busy color or pattern.
void | EnableTheme (BOOL bEnableTheme)
This member function is used to enable a new theme.
BOOL | IsThemeEnabled ()
This member function is used to obtain the status of the theme.
XTPCurrentSystemTheme GetCurrentSystemTheme ()
Call this member function to determine the current Windows XP theme that is in use.
void | SetBusyStatusBrush (int nBusyStatus, CBrush *pBrush, BOOL bAutodeleteBrush)
Call this member function to set custom brush to draw event busy status.
CBrush * | GetBusyStatusBrush (int nBusyStatus)
Call this member function to get a brush to draw event busy status.
DWORD | GetAskItemTextFlags () const
This member function returns a set of flags which define calendar items to send an XTP_NC_CALENDAR_GETITEMTEXT notification.
void | SetAskItemTextFlags (DWORD dwFlags)
This member function is used to set flags which define calendar items to send an XTP_NC_CALENDAR_GETITEMTEXT notification.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPCalendarPaintManager
DayViewTimeScaleHeaderPart CXTPCalendarViewPartFontValue | m_fntTimeText
Time text font.
int | m_nHourWidth
Width of hour part of the text in pixels.
int | m_nMinWidth
Width of minutes (am/pm) part of the text in pixels.
BOOL | m_bShowMinutes
Show minutes in TS when '60 Minutes' is selected.
XTPCalendarViewPart CXTPPaintManagerColor | m_clrBackgroundSlave
Background secondary color.
CXTPPaintManagerColor | m_clrShadow
Cell background color.
CXTPPaintManagerColor | m_clrHour
Cell border color.
XTPCalendarViewPart CXTPPaintManagerColor | m_clrBackground2
Second background color which is used to fill days background.
XTPCalendarViewPart COLORREF | m_clrTextHighLightColor
Text color for the selected event.
COLORREF | m_clrMultiDayEventFrameColor
Multi-day event frame color.
COLORREF | m_clrClassicUnderline
Underline color for today day.
CXTPPaintManagerColorGradient | m_grclrClassicSelDay
Gradient color for today day.
COLORREF | m_clrTextNormalColor
Text color for the day header and some other elements.
COLORREF | m_clrHeaderBottomLine
Text color for the day header bottom line.
XTPCalendarTimeLineViewPart CXTPPaintManagerColor | m_clrEventBar
Event bar color.
CXTPPaintManagerColor m_clrEventBarLine
Event bar line color.
CXTPPaintManagerColor | m_clrEventBorderLine
Event border line color.
CXTPPaintManagerColor | m_clrTimeScaleBackground
Time scale background color.
CXTPPaintManagerColor | m_clrTimeScaleHightlite
Time scale highlight color.
CXTPPaintManagerColor m_clrTimeScaleText
The time scale text color.
CXTPPaintManagerColor | m_clrSelectedBackground
The selected background color.
CXTPPaintManagerColor m_clrSelectedText
The selected text color.
CXTPPaintManagerColor | m_clrBackground
The background color.
CXTPPaintManagerColor | m_clrText
The text color.
CXTPPaintManagerColor | m_clrWeekendBackground
Time scale weekend background color.
CXTPPaintManagerColor m_clrButtonFace
Stores standard Button Face color.
CXTPPaintManagerColor | m_clrButtonFaceText
Stores standard color to display text.
CXTPPaintManagerColor m_clrWindow
Stores standard windows color.
CXTPPaintManagerColor m_clrWindowText
Stores standard color to display window text.
CXTPPaintManagerColor m_clr3DShadow
Stores standard color to display shadow items.
CXTPPaintManagerColor | m_clrHighlight
Stores standard color to display highlighted items.
CXTPPaintManagerColor | m_clrBorders [4]
Stores border line color, left = 0, top = 1, right = 2, bottom = 3.
CXTPPaintManagerColorGradient | m_grclrToday
Gradient color of today's header.
CUIntArray | m_arStartCol
hold start column in each virtual page
CUIntArray | m_arStartRow
hold start row in each virtual page

int | m_PrintPageWidth
Print page width.
- Protected Types inherited from CXTPCalendarPaintManager
enum | XTPEnumExpandSigns { idxExpandSignUp = 0 , idxExpandSignDown = 1 }
Enumerates types of expand signs drawn on a day view. More...
enum XTPEnumEventGlyphs {
idxMeeting = 0 , idxPrivate = 1 , idxRecurrenceException = 2 , idxRecurrenceOccurrence = 3 ,
idxReminder = 4
}
Enumerates types of event glyphs. More...
- Protected Member Functions inherited from CXTPCalendarOffice2013Theme
- Protected Member Functions inherited from CXTPCalendarPaintManager
CXTPCalendarViewPart * | AddViewPart (CXTPCalendarViewPart *pPart)
Call this member function to add the specified ViewPart object to the parts list.
CXTPCalendarViewPartBrushValue * | _GetAtGrow_BusyStatusBrushValue (int eBusyStatus, BOOL bGrow)
Returns drawing brush value for a specific busy status.
virtual void | InitBusyStatusDefaultColors ()
Set default colors/patterns to fill Busy Status area.
- Protected Attributes inherited from CXTPCalendarOffice2013Theme
- Protected Attributes inherited from CXTPCalendarPaintManager
CList< CXTPCalendarViewPart *, CXTPCalendarViewPart * > | m_lstViewParts
Collection to store ViewParts objects.
CXTPImageManager * | m_pExpandSigns
Stores standard Expand Signs icons.
CXTPImageManager * m_pGlyphs
Stores standard glyphs for displaying events.
CFont * | m_pGlyphsFont
Stores standard glyphs font for displaying events.
CBitmap | m_bmpElsewherePattern
Stores standard bitmap pattern to draw Elsewhere event busy status.
CXTPBrush | m_xtpBrushElsewhere
Stores standard brush to draw Elsewhere event busy status.
CBitmap | m_bmpTentativePattern
Stores standard bitmap pattern to draw Tentative event busy status.
CXTPBrush | m_xtpBrushTentative
Stores standard brush to draw Tentative event busy status.
CXTPCalendarTypedPtrAutoDeleteArray< CPtrArray, CXTPCalendarViewPartBrushValue * > | m_arBusyStatusBrushes
Stores customizable brush values to draw Event Busy Status in the Day View.
CSize | m_szClockRect
Stores dimensions for a rectangle used to display the time as a clock glyph.
CXTPCalendarControl * | m_pControl
Stores a pointer to a CXTPCalendarControl object.
BOOL | m_bEnableTheme
True to enable Luna theme.
COLORREF | m_clrUnderLineHdr
Color of header's underline.
XTPCurrentSystemTheme | m_CurrSystemTheme
Current theme flag.
XTPCalendarTheme | m_nPaintTheme
Store the Paint Theme;.
DWORD | m_dwAskItemTextFlags
Store flag set to send XTP_NC_CALENDAR_GETITEMTEXT notification.

Detailed Description

CXTPCalendarNativeWindows10Theme is a CXTPCalendarOffice2013Theme derived class that represents the Native Windows 10 calendar theme.

Constructor & Destructor Documentation

◆ CXTPCalendarNativeWindows10Theme()

CXTPCalendarNativeWindows10Theme ( )

Default paint manager constructor.

Handles initial initialization.

See also
RefreshMetrics()

◆ ~CXTPCalendarNativeWindows10Theme()

virtual ~CXTPCalendarNativeWindows10Theme ( )
virtual

Default paint manager destructor.

Handles member items deallocation.

The documentation for this class was generated from the following file:
  • XTPCalendarNativeWindows10Theme.h


Toolkit Pro: CXTPCalendarNativeWindows11Theme Class Reference

Public Member Functions | List of all members
CXTPCalendarNativeWindows11Theme Class Reference

CXTPCalendarNativeWindows11Theme is a CXTPCalendarOffice2013Theme derived class that represents the Native Windows 11 calendar theme. More...

Inheritance diagram for CXTPCalendarNativeWindows11Theme:
[legend]

Public Member Functions

CXTPCalendarNativeWindows11Theme ()
Default paint manager constructor.
virtual | ~CXTPCalendarNativeWindows11Theme ()
Default paint manager destructor.
- Public Member Functions inherited from CXTPCalendarOffice2013Theme
CXTPCalendarOffice2013Theme ()
Default paint manager constructor.
virtual | ~CXTPCalendarOffice2013Theme ()
Default paint manager destructor.
virtual void | RefreshMetrics ()
This member function is used to initialize all drawing defaults.
virtual void | DrawHeader (CDC *pDC, CRect &rcHeader, BOOL bIsSelected, BOOL bIsCurrent, const CXTPPaintManagerColorGradient &grclr, COLORREF clrUnderLineHdr)
This member function is used to draw the Header.
virtual void | UpdateEventLabelsDefaultColors ()
This member function is called to update event label default colors.
virtual void | UpdateEventCategoriesDefaultColors ()
This member function is called to update event category default colors.
virtual void | UpdateGlyphs ()
Initializes Calendar images.
virtual COLORREF | GetEventBackColor (CXTPCalendarEvent *pEvent)
Call this member function to get the background color for the specified event.
virtual COLORREF | GetEventEdgeColor (CXTPCalendarEvent *pEvent)
Call this member function to get the edge color for the specified event.
- Public Member Functions inherited from CXTPCalendarOffice2000Theme
CXTPCalendarOffice2000Theme ()
Default paint manager constructor.
virtual | ~CXTPCalendarOffice2000Theme ()
Default paint manager destructor.
- Public Member Functions inherited from CXTPCalendarPaintManager
BEGIN_VIEW_PART (ControlPart, XTPCalendarViewPart) virtual void RefreshMetrics()
Paint manager's ControlPart is used as parent for the other parts of the control.
END_VIEW_PART (ControlPart) BEGIN_VIEW_PART(DayViewTimeScaleHeaderPart
This paint manager part is used to draw the time scale header, 'Now' line, and the expand signs for the Day View.
virtual void | OnDraw (CDC *pDC, CXTPCalendarDayView *pView, CRect rc, CString strText)
This member function is used to draw the time scale header.
virtual void | DrawNowLine (CDC *pDC, CXTPCalendarDayView *pView, CRect rc, int y, BOOL bDrawBk=FALSE)
This member function is used to draw the 'Now' line.
virtual void | DrawNowLine (CDC *pDC, CXTPCalendarDayView *pView, CXTPCalendarDayViewTimeScale *pScale, CRect rc, int y, BOOL bDrawBk=FALSE)
This member function is used to draw the 'Now' line.
virtual void | DrawExpandSigns (CDC *pDC, CXTPCalendarDayView *pView, const CRect &rcTSHours)
This member function is used to draw expand signs.
END_VIEW_PART (DayViewTimeScaleHeaderPart) BEGIN_VIEW_PART(DayViewTimeScaleCellPart
This paint manager part is used to draw time scale time cells for the Day View.
void | AdjustTimeFont (CDC *pDC, CRect rcCell)
This member function is used to adjust the time text font size.
void | CalcWidth (CDC *pDC, const CString &strHour, const CString &strMin, int nHourHeight, int &nWidth)
This member function is used to adjust the time text font size.
virtual void | DrawHourCell (CDC *pDC, CRect rc, CString strText, BOOL bFillBackground=TRUE, BOOL bCurrentTime=FALSE)
This member function is used to draw background of the time scale header.
virtual void | DrawBigHourCell (CDC *pDC, CRect rc, CString strHour, CString strMin, int nRowPerHour, BOOL bFillBackground=TRUE, BOOL bCurrentTime=FALSE)
This member function is used to draw the big hour cell.
END_VIEW_PART (DayViewTimeScaleCellPart) BEGIN_VIEW_PART(DayViewCellPart
This paint manager part is used as the base class for the parts which draw different kinds of no all-day-cells (work/non-work) for the Day View.
virtual void | GetParams (CXTPCalendarDayViewGroup *pViewGroup, XTP_CALENDAR_DAYVIEWCELL_PARAMS *rCellParams)
This member function is used to fill out cell parameters with default values.
virtual void | OnDraw (CDC *pDC, CXTPCalendarDayViewGroup *pViewGroup, CRect rc, const XTP_CALENDAR_DAYVIEWCELL_PARAMS &cellParams)
This member function is used to draw the day view with no all-day-cells.
END_VIEW_PART (DayViewCellPart) BEGIN_VIEW_PART(DayViewWorkCellPart
This paint manager part is used to draw a day view that contains no all day work time cells.
END_VIEW_PART (DayViewWorkCellPart) BEGIN_VIEW_PART(DayViewNonworkCellPart
This paint manager part is used to draw "no all day non-work" time cells for the Day View.
END_VIEW_PART (DayViewNonworkCellPart) BEGIN_VIEW_PART(DayMonthViewHeaderPart
This paint manager part is used to draw days headers for the Day View.
END_VIEW_PART (DayMonthViewHeaderPart) BEGIN_VIEW_PART(DayViewHeaderPart
This paint manager part is used to draw days headers for the Day View.
virtual DayMonthViewHeaderPart void | OnDraw (CDC *pDC, CXTPCalendarDayViewDay *pViewDay, CRect rc, CString strText)
This member function is used to draw the day header.
END_VIEW_PART (DayViewHeaderPart) BEGIN_VIEW_PART(DayViewGroupHeaderPart
This paint manager part is used to draw Groups headers for the Day View.
virtual DayMonthViewHeaderPart void | OnDraw (CDC *pDC, CXTPCalendarDayViewGroup *pViewGroup, CRect rc, CString strText)
This member function is used to draw the day header.
END_VIEW_PART (DayViewGroupHeaderPart) BEGIN_VIEW_PART(DayViewAllDayEventsPart
This paint manager part is used to draw all day events area for the Day View.
virtual void | OnDraw (CDC *pDC, CXTPCalendarDayViewGroup *pViewGroup, CRect rc, BOOL bSelected)
This member function is used to draw the all-day events area.
END_VIEW_PART (DayViewAllDayEventsPart) BEGIN_VIEW_PART(DayViewAllDayEventScrollIconsPart
This paint manager part is used to draw all day events scroll buttons if there are too many all day events.
virtual XTPCalendarViewPart void | OnDraw (CDC *pDC, CXTPCalendarDayViewGroup *pViewGroup, BOOL bDrawUp, BOOL bDrawDown, const CRect &rcIconUp, const CRect &rcIconDown, BOOL bHighlightUp, BOOL bHighlightDown)
This member function is used to draw scroll icons in all day events area.
END_VIEW_PART (DayViewAllDayEventScrollIconsPart) BEGIN_VIEW_PART(DayViewEventPart
This paint manager part is used to draw events for the Day View.
virtual void | OnDraw (CDC *pDC, CXTPCalendarDayViewEvent *pViewEvent)
This member function is used to draw an event.
END_VIEW_PART (DayViewEventPart) BEGIN_VIEW_PART(MonthViewGridPart
This paint manager part is used to draw days grid and to fill days cells background for the Month View.
virtual void | OnDrawGrid (CDC *pDC, CXTPCalendarMonthView *pMonthView)
This member function is used to draw the days grid and to fill the days cells background.
END_VIEW_PART (MonthViewGridPart) BEGIN_VIEW_PART(MonthViewHeaderPart
This paint manager part is used to draw week days headers for the Month View.
virtual DayMonthViewHeaderPart void | OnDraw (CDC *pDC, CXTPCalendarMonthView *pMonthView, CRect rc, int nCollIndex, CString strText)
This member function is used to draw the week day header.
END_VIEW_PART (MonthViewHeaderPart) BEGIN_VIEW_PART(MonthViewEventPart
This paint manager part is used to draw events and day dates for the Month View.
virtual void | OnDrawEvent (CDC *pDC, CXTPCalendarMonthViewEvent *pViewEvent)
This member function is used to draw an event.
virtual void | OnDrawDayDate (CDC *pDC, CRect rc, BOOL bToday, BOOL bSelected, BOOL bFirstMonthDay, CString strText)
This member function is used to draw the week day header.
END_VIEW_PART (MonthViewEventPart) BEGIN_VIEW_PART(WeekViewPart
This paint manager part is used to draw week days grid and headers for the Week View.
virtual void | OnDraw (CDC *pDC, CXTPCalendarWeekView *pWeekView)
This member function is used to draw an event.
virtual void | DrawDayHeader (CDC *pDC, CRect rcDay, int nHeaderHeight, CString strHeader, BOOL bIsCurrent=FALSE, BOOL bIsSelected=FALSE)
This member function is used to draw the day header.
END_VIEW_PART (WeekViewPart) BEGIN_VIEW_PART(WeekViewEventPart
This paint manager part is used to draw events for the Week View.
virtual void | OnDraw (CDC *pDC, CXTPCalendarWeekViewEvent *pWeekViewEvent)
This member function is used to draw the specified event.
virtual void | DrawBorder (CDC *pDC, CRect rcView, CXTPCalendarWeekViewEvent *pWeekViewEvent)
This member functions is used to draw the event border.
virtual int | DrawTimes (CDC *pDC, CXTPCalendarWeekViewEvent *pWeekViewEvent)
This member function is used to draw the event's times texts or icons.
virtual void | DrawSubj (CDC *pDC, CXTPCalendarWeekViewEvent *pWeekViewEvent)
This member function is used to draw the event subject.
END_VIEW_PART (WeekViewEventPart) BEGIN_VIEW_PART(TimeLineViewTimeScalePart_Day
This paint manager part is used to draw time scale for the Time Line view.
virtual void | DrawGroup (CDC *pDC, const CRect &rcRect, CXTPCalendarTimeLineViewGroup *pGroup)
Call this function to draw the time line view group.
virtual CSize | CalcEventSize (CDC *c, CXTPCalendarTimeLineViewEvent *pViewEvent)
Call this function to calculate the time line view event size.
virtual void | DrawEvent (CDC *pDC, const CRect &rcEvents, CXTPCalendarTimeLineViewEvent *pViewEvent)
Call this function to draw the event.
virtual void | _Init ()
Call this function to do the initializations.
virtual | ~CTimeLineViewPart ()
Destroys the CTimeLineViewPart object, does the cleanup.
CXTPCalendarPaintManager ()
Default paint manager constructor.
virtual | ~CXTPCalendarPaintManager ()
Default paint manager destructor.
virtual XTPCalendarTheme | GetPaintTheme () const
This member function is used to obtain the current paint theme.
virtual void | SetPaintTheme (XTPCalendarTheme ePaintTheme)
This member function is used to set the current paint theme.
virtual COLORREF | GetEventBackColor (CXTPCalendarEvent *pEvent, COLORREF crDefault)
Call this member function to get the background color for the specified event.
virtual void | DrawLine (CDC *pDC, int xPos, int yPos, int cx, int cy)
This member function is used to draw an arbitrary line.
virtual void | DrawHorizontalLine (CDC *pDC, int xPos, int yPos, int cx)
This member function is used to draw a Horizontal line.
virtual void | DrawVerticalLine (CDC *pDC, int xPos, int yPos, int cy)
This member function is used to draw a Vertical line.
virtual int | DrawClock (CDC *pDC, COleDateTime dtClockTime, CRect rcView, COLORREF clrBackground, XTPCalendarClockAlignFlags cafAlign)
This member function is used to draw the time as a clock.
virtual int | DrawBitmap (CImageList *pImageList, CDC *pDC, CRect rcView, int iIcon, UINT uFlags=0)
This member function is used to draw a bitmap from the provided ImageList.
virtual int | DrawBitmap (UINT nIDResource, CDC *pDC, CRect rcBitmap)
This member function is used to draw the bitmap using its resource id.
virtual int | DrawIconChar (CDC *pDC, CRect rc, TCHAR ch)
This member function is used to draw the Glyph symbol using special font.
virtual const CSize | GetExpandSignSize ()
This member function is used to obtain the horizontal and vertical size of the Expand Sign bitmap.
virtual CSize | GetClockSize ()
This member function is used to obtain the horizontal and vertical size of the Clock.
virtual void | SetControl (CXTPCalendarControl *pControl)
This member function is used to set the CXTPCalendarControl object for the CXTPCalendarPaintManager.
virtual void | DrawShadow (CDC *pDC, const CRect &rcRect)
Call this member function to draw the shadow regions around the rectangle.
virtual int | DrawIcons (CDC *pDC, CXTPCalendarViewEvent *pViewEvent)
Call this member function to draw icons corresponding to the event state.
virtual void | DrawHeader (CDC *pDC, CRect &rcHeader, BOOL bIsSelected, BOOL bIsCurrent)
This member function is used to draw the Header.
virtual void | DrawBusyStatus (CDC *pDC, CRect &rcRect, int eBusyStatus)
This member function is used to fill the area using the corresponding busy color or pattern.
virtual void | DrawBusyStatus (CDC *pDC, CRgn &rgnBusy, int eBusyStatus)
This member function is used to fill the area using the corresponding busy color or pattern.
void | EnableTheme (BOOL bEnableTheme)
This member function is used to enable a new theme.
BOOL | IsThemeEnabled ()
This member function is used to obtain the status of the theme.
XTPCurrentSystemTheme GetCurrentSystemTheme ()
Call this member function to determine the current Windows XP theme that is in use.
void | SetBusyStatusBrush (int nBusyStatus, CBrush *pBrush, BOOL bAutodeleteBrush)
Call this member function to set custom brush to draw event busy status.
CBrush * | GetBusyStatusBrush (int nBusyStatus)
Call this member function to get a brush to draw event busy status.
DWORD | GetAskItemTextFlags () const
This member function returns a set of flags which define calendar items to send an XTP_NC_CALENDAR_GETITEMTEXT notification.
void | SetAskItemTextFlags (DWORD dwFlags)
This member function is used to set flags which define calendar items to send an XTP_NC_CALENDAR_GETITEMTEXT notification.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPCalendarPaintManager
DayViewTimeScaleHeaderPart CXTPCalendarViewPartFontValue | m_fntTimeText
Time text font.
int | m_nHourWidth
Width of hour part of the text in pixels.
int | m_nMinWidth
Width of minutes (am/pm) part of the text in pixels.
BOOL | m_bShowMinutes
Show minutes in TS when '60 Minutes' is selected.
XTPCalendarViewPart CXTPPaintManagerColor | m_clrBackgroundSlave
Background secondary color.
CXTPPaintManagerColor | m_clrShadow
Cell background color.
CXTPPaintManagerColor | m_clrHour
Cell border color.
XTPCalendarViewPart CXTPPaintManagerColor | m_clrBackground2
Second background color which is used to fill days background.
XTPCalendarViewPart COLORREF | m_clrTextHighLightColor
Text color for the selected event.
COLORREF | m_clrMultiDayEventFrameColor
Multi-day event frame color.
COLORREF | m_clrClassicUnderline
Underline color for today day.
CXTPPaintManagerColorGradient | m_grclrClassicSelDay
Gradient color for today day.
COLORREF | m_clrTextNormalColor
Text color for the day header and some other elements.
COLORREF | m_clrHeaderBottomLine
Text color for the day header bottom line.
XTPCalendarTimeLineViewPart CXTPPaintManagerColor | m_clrEventBar
Event bar color.
CXTPPaintManagerColor m_clrEventBarLine
Event bar line color.
CXTPPaintManagerColor | m_clrEventBorderLine
Event border line color.
CXTPPaintManagerColor | m_clrTimeScaleBackground
Time scale background color.
CXTPPaintManagerColor | m_clrTimeScaleHightlite
Time scale highlight color.
CXTPPaintManagerColor m_clrTimeScaleText
The time scale text color.
CXTPPaintManagerColor | m_clrSelectedBackground
The selected background color.
CXTPPaintManagerColor m_clrSelectedText
The selected text color.
CXTPPaintManagerColor | m_clrBackground
The background color.
CXTPPaintManagerColor | m_clrText
The text color.
CXTPPaintManagerColor | m_clrWeekendBackground
Time scale weekend background color.
CXTPPaintManagerColor m_clrButtonFace
Stores standard Button Face color.
CXTPPaintManagerColor | m_clrButtonFaceText
Stores standard color to display text.
CXTPPaintManagerColor m_clrWindow
Stores standard windows color.
CXTPPaintManagerColor m_clrWindowText
Stores standard color to display window text.
CXTPPaintManagerColor m_clr3DShadow
Stores standard color to display shadow items.
CXTPPaintManagerColor | m_clrHighlight
Stores standard color to display highlighted items.
CXTPPaintManagerColor | m_clrBorders [4]
Stores border line color, left = 0, top = 1, right = 2, bottom = 3.
CXTPPaintManagerColorGradient | m_grclrToday
Gradient color of today's header.
CUIntArray | m_arStartCol
hold start column in each virtual page
CUIntArray | m_arStartRow
hold start row in each virtual page

int | m_PrintPageWidth
Print page width.
- Protected Types inherited from CXTPCalendarPaintManager
enum | XTPEnumExpandSigns { idxExpandSignUp = 0 , idxExpandSignDown = 1 }
Enumerates types of expand signs drawn on a day view. More...
enum XTPEnumEventGlyphs {
idxMeeting = 0 , idxPrivate = 1 , idxRecurrenceException = 2 , idxRecurrenceOccurrence = 3 ,
idxReminder = 4
}
Enumerates types of event glyphs. More...
- Protected Member Functions inherited from CXTPCalendarOffice2013Theme
- Protected Member Functions inherited from CXTPCalendarPaintManager
CXTPCalendarViewPart * | AddViewPart (CXTPCalendarViewPart *pPart)
Call this member function to add the specified ViewPart object to the parts list.
CXTPCalendarViewPartBrushValue * | _GetAtGrow_BusyStatusBrushValue (int eBusyStatus, BOOL bGrow)
Returns drawing brush value for a specific busy status.
virtual void | InitBusyStatusDefaultColors ()
Set default colors/patterns to fill Busy Status area.
- Protected Attributes inherited from CXTPCalendarOffice2013Theme
- Protected Attributes inherited from CXTPCalendarPaintManager
CList< CXTPCalendarViewPart *, CXTPCalendarViewPart * > | m_lstViewParts
Collection to store ViewParts objects.
CXTPImageManager * | m_pExpandSigns
Stores standard Expand Signs icons.
CXTPImageManager * m_pGlyphs
Stores standard glyphs for displaying events.
CFont * | m_pGlyphsFont
Stores standard glyphs font for displaying events.
CBitmap | m_bmpElsewherePattern
Stores standard bitmap pattern to draw Elsewhere event busy status.
CXTPBrush | m_xtpBrushElsewhere
Stores standard brush to draw Elsewhere event busy status.
CBitmap | m_bmpTentativePattern
Stores standard bitmap pattern to draw Tentative event busy status.
CXTPBrush | m_xtpBrushTentative
Stores standard brush to draw Tentative event busy status.
CXTPCalendarTypedPtrAutoDeleteArray< CPtrArray, CXTPCalendarViewPartBrushValue * > | m_arBusyStatusBrushes
Stores customizable brush values to draw Event Busy Status in the Day View.
CSize | m_szClockRect
Stores dimensions for a rectangle used to display the time as a clock glyph.
CXTPCalendarControl * | m_pControl
Stores a pointer to a CXTPCalendarControl object.
BOOL | m_bEnableTheme
True to enable Luna theme.
COLORREF | m_clrUnderLineHdr
Color of header's underline.
XTPCurrentSystemTheme | m_CurrSystemTheme
Current theme flag.
XTPCalendarTheme | m_nPaintTheme
Store the Paint Theme;.
DWORD | m_dwAskItemTextFlags
Store flag set to send XTP_NC_CALENDAR_GETITEMTEXT notification.

Detailed Description

CXTPCalendarNativeWindows11Theme is a CXTPCalendarOffice2013Theme derived class that represents the Native Windows 11 calendar theme.

Constructor & Destructor Documentation

◆ CXTPCalendarNativeWindows11Theme()

CXTPCalendarNativeWindows11Theme ( )

Default paint manager constructor.

Handles initial initialization.

See also
RefreshMetrics()

◆ ~CXTPCalendarNativeWindows11Theme()

virtual ~CXTPCalendarNativeWindows11Theme ( )
virtual

Default paint manager destructor.

Handles member items deallocation.

The documentation for this class was generated from the following file:
  • XTPCalendarNativeWindows11Theme.h


Toolkit Pro: CXTPCalendarOccurSeriesChooseDlg Class Reference

Public Member Functions | Public Attributes | Protected Attributes | List of all members
CXTPCalendarOccurSeriesChooseDlg Class Reference

This class implements a dialog to choose between current occurrence and whole recurrence event series (or pattern). More...

Public Member Functions

CXTPCalendarOccurSeriesChooseDlg (CWnd *pParent, UINT nIDResourceLabels, LPCTSTR lpszResourceIcon=IDI_EXCLAMATION, UINT nIDTemplate=CXTPCalendarOccurSeriesChooseDlg::IDD)
Default object constructor.
virtual | ~CXTPCalendarOccurSeriesChooseDlg ()
Default class destructor.
virtual void | SetEvent (CXTPCalendarEvent *pEvent)
Update dialog information from the specified event.

Public Attributes

BOOL m_bOccur
[in/out] Contain default/selected choice.

Protected Attributes

CStatic | m_ctrlMessage
Dialog message text control.
CStatic | m_ctrlIcon
Dialog icon control.
CButton | m_ctrlOccur
Occurrence radio button control.
CButton | m_ctrlSeries
Series radio button control.
CString | m_strTitle
Dialog title string.
CString | m_strMessage
Dialog message text prepared string.
CString | m_strOccur
Occurrence radio button label text string.
CString | m_strSeries
Series radio button label text string.
UINT | m_nIDResourceLabels
Dialog labels string resource ID.
HICON | m_hIcon
Dialog icon resource ID.

Detailed Description

This class implements a dialog to choose between current occurrence and whole recurrence event series (or pattern).

This is useful in operations with events like edit or delete event. The dialog items inscriptions are customizable and loaded from resources.

Constructor & Destructor Documentation

◆ CXTPCalendarOccurSeriesChooseDlg()

CXTPCalendarOccurSeriesChooseDlg | ( | CWnd * | pParent,
 |  | UINT | nIDResourceLabels,
 |  | LPCTSTR | lpszResourceIcon = IDI_EXCLAMATION,
 |  | UINT | nIDTemplate = CXTPCalendarOccurSeriesChooseDlg::IDD )

Default object constructor.

Parameters
pParent | Pointer to the parent window.
nIDResourceLabels | Dialog labels string resource ID.
lpszResourceIcon | Dialog icon resource ID.
nIDTemplate | [in] Contains the ID number of a dialog-box template resource.

The string format for nIDResourceLabels is: "Title\\nOccurrence\\nSeries\\nMessage" Where:

  • Title - Dialog window title text.
  • Occurrence - Occurrence radio button label.
  • Series - Series radio button label.
  • Message - Dialog message text. If message string has s format specifier - event subject is inserted instead. See SetEvent() method.
See also
~CXTPCalendarEvent()

Member Function Documentation

◆ SetEvent()

virtual void SetEvent ( CXTPCalendarEvent * pEvent )
virtual

Update dialog information from the specified event.

Parameters
pEvent Pointer to the calendar event object.

If message string has s format specifier - event subject is inserted instead by default.

Member Data Documentation

◆ m_bOccur

BOOL m_bOccur

[in/out] Contain default/selected choice.

If TRUE - occurrence is selected, otherwise series.

◆ m_ctrlIcon

CStatic m_ctrlIcon
protected

Dialog icon control.

◆ m_ctrlMessage

CStatic m_ctrlMessage
protected

Dialog message text control.

◆ m_ctrlSeries

CButton m_ctrlSeries
protected

Series radio button control.

◆ m_strMessage

CString m_strMessage
protected

Dialog message text prepared string.

◆ m_strOccur

CString m_strOccur
protected

Occurrence radio button label text string.

◆ m_strSeries

CString m_strSeries
protected

Series radio button label text string.

◆ m_strTitle

CString m_strTitle
protected

Dialog title string.

The documentation for this class was generated from the following file:
  • XTPCalendarOccurSeriesChooseDlg.h


Toolkit Pro: CXTPCalendarOffice2000Theme Class Reference

Public Member Functions | List of all members
CXTPCalendarOffice2000Theme Class Reference

CXTPCalendarOffice2000Theme is a CXTPCalendarPaintManager derived class that represents the Office 2000 calendar theme. More...

Inheritance diagram for CXTPCalendarOffice2000Theme:
[legend]

Public Member Functions

CXTPCalendarOffice2000Theme ()
Default paint manager constructor.
virtual | ~CXTPCalendarOffice2000Theme ()
Default paint manager destructor.
- Public Member Functions inherited from CXTPCalendarPaintManager
BEGIN_VIEW_PART (ControlPart, XTPCalendarViewPart) virtual void RefreshMetrics()
Paint manager's ControlPart is used as parent for the other parts of the control.
END_VIEW_PART (ControlPart) BEGIN_VIEW_PART(DayViewTimeScaleHeaderPart
This paint manager part is used to draw the time scale header, 'Now' line, and the expand signs for the Day View.
virtual void | RefreshMetrics ()
Performs refreshing of graphical related parameters from system settings.
virtual void | OnDraw (CDC *pDC, CXTPCalendarDayView *pView, CRect rc, CString strText)
This member function is used to draw the time scale header.
virtual void | DrawNowLine (CDC *pDC, CXTPCalendarDayView *pView, CRect rc, int y, BOOL bDrawBk=FALSE)
This member function is used to draw the 'Now' line.
virtual void | DrawNowLine (CDC *pDC, CXTPCalendarDayView *pView, CXTPCalendarDayViewTimeScale *pScale, CRect rc, int y, BOOL bDrawBk=FALSE)
This member function is used to draw the 'Now' line.
virtual void | DrawExpandSigns (CDC *pDC, CXTPCalendarDayView *pView, const CRect &rcTSHours)
This member function is used to draw expand signs.
END_VIEW_PART (DayViewTimeScaleHeaderPart) BEGIN_VIEW_PART(DayViewTimeScaleCellPart
This paint manager part is used to draw time scale time cells for the Day View.
virtual void | RefreshMetrics ()
This member function is used to refresh the graphical related parameters using system settings.
void | AdjustTimeFont (CDC *pDC, CRect rcCell)
This member function is used to adjust the time text font size.
void | CalcWidth (CDC *pDC, const CString &strHour, const CString &strMin, int nHourHeight, int &nWidth)
This member function is used to adjust the time text font size.
virtual void | DrawHourCell (CDC *pDC, CRect rc, CString strText, BOOL bFillBackground=TRUE, BOOL bCurrentTime=FALSE)
This member function is used to draw background of the time scale header.
virtual void | DrawBigHourCell (CDC *pDC, CRect rc, CString strHour, CString strMin, int nRowPerHour, BOOL bFillBackground=TRUE, BOOL bCurrentTime=FALSE)
This member function is used to draw the big hour cell.
END_VIEW_PART (DayViewTimeScaleCellPart) BEGIN_VIEW_PART(DayViewCellPart
This paint manager part is used as the base class for the parts which draw different kinds of no all-day-cells (work/non-work) for the Day View.
virtual void | RefreshMetrics ()
This member function is used to refresh the graphical related parameters using system settings.
virtual void | GetParams (CXTPCalendarDayViewGroup *pViewGroup, XTP_CALENDAR_DAYVIEWCELL_PARAMS *rCellParams)
This member function is used to fill out cell parameters with default values.
virtual void | OnDraw (CDC *pDC, CXTPCalendarDayViewGroup *pViewGroup, CRect rc, const XTP_CALENDAR_DAYVIEWCELL_PARAMS &cellParams)
This member function is used to draw the day view with no all-day-cells.
END_VIEW_PART (DayViewCellPart) BEGIN_VIEW_PART(DayViewWorkCellPart
This paint manager part is used to draw a day view that contains no all day work time cells.
virtual DayViewCellPart void | RefreshMetrics ()
This member function is used to perform the refreshing of graphical related parameters from system settings.
END_VIEW_PART (DayViewWorkCellPart) BEGIN_VIEW_PART(DayViewNonworkCellPart
This paint manager part is used to draw "no all day non-work" time cells for the Day View.
virtual DayViewCellPart void | RefreshMetrics ()
This member function is used to perform refreshing of graphical related parameters from system settings.
END_VIEW_PART (DayViewNonworkCellPart) BEGIN_VIEW_PART(DayMonthViewHeaderPart
This paint manager part is used to draw days headers for the Day View.
virtual void | RefreshMetrics ()
This member function is used to perform refreshing of graphical related parameters from system settings.
END_VIEW_PART (DayMonthViewHeaderPart) BEGIN_VIEW_PART(DayViewHeaderPart
This paint manager part is used to draw days headers for the Day View.
virtual DayMonthViewHeaderPart void | OnDraw (CDC *pDC, CXTPCalendarDayViewDay *pViewDay, CRect rc, CString strText)
This member function is used to draw the day header.
END_VIEW_PART (DayViewHeaderPart) BEGIN_VIEW_PART(DayViewGroupHeaderPart
This paint manager part is used to draw Groups headers for the Day View.
virtual DayMonthViewHeaderPart void | OnDraw (CDC *pDC, CXTPCalendarDayViewGroup *pViewGroup, CRect rc, CString strText)
This member function is used to draw the day header.
END_VIEW_PART (DayViewGroupHeaderPart) BEGIN_VIEW_PART(DayViewAllDayEventsPart
This paint manager part is used to draw all day events area for the Day View.
virtual XTPCalendarViewPart void | RefreshMetrics ()
This member functions is used to perform refreshing of graphical related parameters from system settings.
virtual void | OnDraw (CDC *pDC, CXTPCalendarDayViewGroup *pViewGroup, CRect rc, BOOL bSelected)
This member function is used to draw the all-day events area.
END_VIEW_PART (DayViewAllDayEventsPart) BEGIN_VIEW_PART(DayViewAllDayEventScrollIconsPart
This paint manager part is used to draw all day events scroll buttons if there are too many all day events.
virtual XTPCalendarViewPart void | OnDraw (CDC *pDC, CXTPCalendarDayViewGroup *pViewGroup, BOOL bDrawUp, BOOL bDrawDown, const CRect &rcIconUp, const CRect &rcIconDown, BOOL bHighlightUp, BOOL bHighlightDown)
This member function is used to draw scroll icons in all day events area.
END_VIEW_PART (DayViewAllDayEventScrollIconsPart) BEGIN_VIEW_PART(DayViewEventPart
This paint manager part is used to draw events for the Day View.
virtual XTPCalendarViewPart void | RefreshMetrics ()
Performs refreshing of graphical related parameters from system settings.
virtual void | OnDraw (CDC *pDC, CXTPCalendarDayViewEvent *pViewEvent)
This member function is used to draw an event.
END_VIEW_PART (DayViewEventPart) BEGIN_VIEW_PART(MonthViewGridPart
This paint manager part is used to draw days grid and to fill days cells background for the Month View.
virtual void | RefreshMetrics ()
Performs refreshing of graphical related parameters from system settings.
virtual void | OnDrawGrid (CDC *pDC, CXTPCalendarMonthView *pMonthView)
This member function is used to draw the days grid and to fill the days cells background.
END_VIEW_PART (MonthViewGridPart) BEGIN_VIEW_PART(MonthViewHeaderPart
This paint manager part is used to draw week days headers for the Month View.
virtual DayMonthViewHeaderPart void | OnDraw (CDC *pDC, CXTPCalendarMonthView *pMonthView, CRect rc, int nCollIndex, CString strText)
This member function is used to draw the week day header.
END_VIEW_PART (MonthViewHeaderPart) BEGIN_VIEW_PART(MonthViewEventPart
This paint manager part is used to draw events and day dates for the Month View.
virtual void | RefreshMetrics ()
Performs refreshing of graphical related parameters from system settings.
virtual void | OnDrawEvent (CDC *pDC, CXTPCalendarMonthViewEvent *pViewEvent)
This member function is used to draw an event.
virtual void | OnDrawDayDate (CDC *pDC, CRect rc, BOOL bToday, BOOL bSelected, BOOL bFirstMonthDay, CString strText)
This member function is used to draw the week day header.
END_VIEW_PART (MonthViewEventPart) BEGIN_VIEW_PART(WeekViewPart
This paint manager part is used to draw week days grid and headers for the Week View.
virtual void | RefreshMetrics ()
Performs refreshing of graphical related parameters from system settings.
virtual void | OnDraw (CDC *pDC, CXTPCalendarWeekView *pWeekView)
This member function is used to draw an event.
virtual void | DrawDayHeader (CDC *pDC, CRect rcDay, int nHeaderHeight, CString strHeader, BOOL bIsCurrent=FALSE, BOOL bIsSelected=FALSE)
This member function is used to draw the day header.
END_VIEW_PART (WeekViewPart) BEGIN_VIEW_PART(WeekViewEventPart
This paint manager part is used to draw events for the Week View.
virtual void | RefreshMetrics ()
This member function is used to perform refreshing of graphical related parameters from system settings.
virtual void | OnDraw (CDC *pDC, CXTPCalendarWeekViewEvent *pWeekViewEvent)
This member function is used to draw the specified event.
virtual void | DrawBorder (CDC *pDC, CRect rcView, CXTPCalendarWeekViewEvent *pWeekViewEvent)
This member functions is used to draw the event border.
virtual int | DrawTimes (CDC *pDC, CXTPCalendarWeekViewEvent *pWeekViewEvent)
This member function is used to draw the event's times texts or icons.
virtual void | DrawSubj (CDC *pDC, CXTPCalendarWeekViewEvent *pWeekViewEvent)
This member function is used to draw the event subject.
END_VIEW_PART (WeekViewEventPart) BEGIN_VIEW_PART(TimeLineViewTimeScalePart_Day
This paint manager part is used to draw time scale for the Time Line view.
virtual void | DrawGroup (CDC *pDC, const CRect &rcRect, CXTPCalendarTimeLineViewGroup *pGroup)
Call this function to draw the time line view group.
virtual CSize | CalcEventSize (CDC *c, CXTPCalendarTimeLineViewEvent *pViewEvent)
Call this function to calculate the time line view event size.
virtual void | DrawEvent (CDC *pDC, const CRect &rcEvents, CXTPCalendarTimeLineViewEvent *pViewEvent)
Call this function to draw the event.
virtual void | RefreshMetrics ()
Call this function to refresh the metrics.
virtual void | _Init ()
Call this function to do the initializations.
virtual | ~CTimeLineViewPart ()
Destroys the CTimeLineViewPart object, does the cleanup.
CXTPCalendarPaintManager ()
Default paint manager constructor.
virtual | ~CXTPCalendarPaintManager ()
Default paint manager destructor.
virtual void | UpdateEventLabelsDefaultColors ()
This member function is called to update event label default colors.
virtual void | UpdateEventCategoriesDefaultColors ()
This member function is called to update event category default colors.
virtual XTPCalendarTheme | GetPaintTheme () const
This member function is used to obtain the current paint theme.
virtual void | SetPaintTheme (XTPCalendarTheme ePaintTheme)
This member function is used to set the current paint theme.
virtual void | RefreshMetrics ()
This member function is used to initialize all drawing defaults.
virtual void | UpdateGlyphs ()
Initializes Calendar images.
virtual COLORREF | GetEventBackColor (CXTPCalendarEvent *pEvent, COLORREF crDefault)
Call this member function to get the background color for the specified event.
virtual void | DrawLine (CDC *pDC, int xPos, int yPos, int cx, int cy)
This member function is used to draw an arbitrary line.
virtual void | DrawHorizontalLine (CDC *pDC, int xPos, int yPos, int cx)
This member function is used to draw a Horizontal line.
virtual void | DrawVerticalLine (CDC *pDC, int xPos, int yPos, int cy)
This member function is used to draw a Vertical line.
virtual int | DrawClock (CDC *pDC, COleDateTime dtClockTime, CRect rcView, COLORREF clrBackground, XTPCalendarClockAlignFlags cafAlign)
This member function is used to draw the time as a clock.
virtual int | DrawBitmap (CImageList *pImageList, CDC *pDC, CRect rcView, int iIcon, UINT uFlags=0)
This member function is used to draw a bitmap from the provided ImageList.
virtual int | DrawBitmap (UINT nIDResource, CDC *pDC, CRect rcBitmap)
This member function is used to draw the bitmap using its resource id.
virtual int | DrawIconChar (CDC *pDC, CRect rc, TCHAR ch)
This member function is used to draw the Glyph symbol using special font.
virtual const CSize | GetExpandSignSize ()
This member function is used to obtain the horizontal and vertical size of the Expand Sign bitmap.
virtual CSize | GetClockSize ()
This member function is used to obtain the horizontal and vertical size of the Clock.
virtual void | SetControl (CXTPCalendarControl *pControl)
This member function is used to set the CXTPCalendarControl object for the CXTPCalendarPaintManager.
virtual void | DrawShadow (CDC *pDC, const CRect &rcRect)
Call this member function to draw the shadow regions around the rectangle.
virtual int | DrawIcons (CDC *pDC, CXTPCalendarViewEvent *pViewEvent)
Call this member function to draw icons corresponding to the event state.
virtual void | DrawHeader (CDC *pDC, CRect &rcHeader, BOOL bIsSelected, BOOL bIsCurrent)
This member function is used to draw the Header.
virtual void | DrawHeader (CDC *pDC, CRect &rcHeader, BOOL bIsSelected, BOOL bIsCurrent, const CXTPPaintManagerColorGradient &grclr, COLORREF clrUnderLineHdr)
This member function is used to draw the Header.
virtual void | DrawBusyStatus (CDC *pDC, CRect &rcRect, int eBusyStatus)
This member function is used to fill the area using the corresponding busy color or pattern.
virtual void | DrawBusyStatus (CDC *pDC, CRgn &rgnBusy, int eBusyStatus)
This member function is used to fill the area using the corresponding busy color or pattern.
void | EnableTheme (BOOL bEnableTheme)
This member function is used to enable a new theme.
BOOL | IsThemeEnabled ()
This member function is used to obtain the status of the theme.
XTPCurrentSystemTheme GetCurrentSystemTheme ()
Call this member function to determine the current Windows XP theme that is in use.
void | SetBusyStatusBrush (int nBusyStatus, CBrush *pBrush, BOOL bAutodeleteBrush)
Call this member function to set custom brush to draw event busy status.
CBrush * | GetBusyStatusBrush (int nBusyStatus)
Call this member function to get a brush to draw event busy status.
DWORD | GetAskItemTextFlags () const
This member function returns a set of flags which define calendar items to send an XTP_NC_CALENDAR_GETITEMTEXT notification.
void | SetAskItemTextFlags (DWORD dwFlags)
This member function is used to set flags which define calendar items to send an XTP_NC_CALENDAR_GETITEMTEXT notification.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPCalendarPaintManager
DayViewTimeScaleHeaderPart CXTPCalendarViewPartFontValue | m_fntTimeText
Time text font.
int | m_nHourWidth
Width of hour part of the text in pixels.
int | m_nMinWidth
Width of minutes (am/pm) part of the text in pixels.
BOOL | m_bShowMinutes
Show minutes in TS when '60 Minutes' is selected.
XTPCalendarViewPart CXTPPaintManagerColor | m_clrBackgroundSlave
Background secondary color.
CXTPPaintManagerColor | m_clrShadow
Cell background color.
CXTPPaintManagerColor | m_clrHour
Cell border color.
XTPCalendarViewPart CXTPPaintManagerColor | m_clrBackground2
Second background color which is used to fill days background.
XTPCalendarViewPart COLORREF | m_clrTextHighLightColor
Text color for the selected event.
COLORREF | m_clrMultiDayEventFrameColor
Multi-day event frame color.
COLORREF | m_clrClassicUnderline
Underline color for today day.
CXTPPaintManagerColorGradient | m_grclrClassicSelDay
Gradient color for today day.
COLORREF | m_clrTextNormalColor
Text color for the day header and some other elements.
COLORREF | m_clrHeaderBottomLine
Text color for the day header bottom line.
XTPCalendarTimeLineViewPart CXTPPaintManagerColor | m_clrEventBar
Event bar color.
CXTPPaintManagerColor m_clrEventBarLine
Event bar line color.
CXTPPaintManagerColor | m_clrEventBorderLine
Event border line color.
CXTPPaintManagerColor | m_clrTimeScaleBackground
Time scale background color.
CXTPPaintManagerColor | m_clrTimeScaleHightlite
Time scale highlight color.
CXTPPaintManagerColor m_clrTimeScaleText
The time scale text color.
CXTPPaintManagerColor | m_clrSelectedBackground
The selected background color.
CXTPPaintManagerColor m_clrSelectedText
The selected text color.
CXTPPaintManagerColor | m_clrBackground
The background color.
CXTPPaintManagerColor | m_clrText
The text color.
CXTPPaintManagerColor | m_clrWeekendBackground
Time scale weekend background color.
CXTPPaintManagerColor m_clrButtonFace
Stores standard Button Face color.
CXTPPaintManagerColor | m_clrButtonFaceText
Stores standard color to display text.
CXTPPaintManagerColor m_clrWindow
Stores standard windows color.
CXTPPaintManagerColor m_clrWindowText
Stores standard color to display window text.
CXTPPaintManagerColor m_clr3DShadow
Stores standard color to display shadow items.
CXTPPaintManagerColor | m_clrHighlight
Stores standard color to display highlighted items.
CXTPPaintManagerColor | m_clrBorders [4]
Stores border line color, left = 0, top = 1, right = 2, bottom = 3.
CXTPPaintManagerColorGradient | m_grclrToday
Gradient color of today's header.
CUIntArray | m_arStartCol
hold start column in each virtual page
CUIntArray | m_arStartRow
hold start row in each virtual page

int | m_PrintPageWidth
Print page width.
- Protected Types inherited from CXTPCalendarPaintManager
enum | XTPEnumExpandSigns { idxExpandSignUp = 0 , idxExpandSignDown = 1 }
Enumerates types of expand signs drawn on a day view. More...
enum XTPEnumEventGlyphs {
idxMeeting = 0 , idxPrivate = 1 , idxRecurrenceException = 2 , idxRecurrenceOccurrence = 3 ,
idxReminder = 4
}
Enumerates types of event glyphs. More...
- Protected Member Functions inherited from CXTPCalendarPaintManager
CXTPCalendarViewPart * | AddViewPart (CXTPCalendarViewPart *pPart)
Call this member function to add the specified ViewPart object to the parts list.
CXTPCalendarViewPartBrushValue * | _GetAtGrow_BusyStatusBrushValue (int eBusyStatus, BOOL bGrow)
Returns drawing brush value for a specific busy status.
virtual void | InitBusyStatusDefaultColors ()
Set default colors/patterns to fill Busy Status area.
- Protected Attributes inherited from CXTPCalendarPaintManager
CList< CXTPCalendarViewPart *, CXTPCalendarViewPart * > | m_lstViewParts
Collection to store ViewParts objects.
CXTPImageManager * | m_pExpandSigns
Stores standard Expand Signs icons.
CXTPImageManager * m_pGlyphs
Stores standard glyphs for displaying events.
CFont * | m_pGlyphsFont
Stores standard glyphs font for displaying events.
CBitmap | m_bmpElsewherePattern
Stores standard bitmap pattern to draw Elsewhere event busy status.
CXTPBrush | m_xtpBrushElsewhere
Stores standard brush to draw Elsewhere event busy status.
CBitmap | m_bmpTentativePattern
Stores standard bitmap pattern to draw Tentative event busy status.
CXTPBrush | m_xtpBrushTentative
Stores standard brush to draw Tentative event busy status.
CXTPCalendarTypedPtrAutoDeleteArray< CPtrArray, CXTPCalendarViewPartBrushValue * > | m_arBusyStatusBrushes
Stores customizable brush values to draw Event Busy Status in the Day View.
CSize | m_szClockRect
Stores dimensions for a rectangle used to display the time as a clock glyph.
CXTPCalendarControl * | m_pControl
Stores a pointer to a CXTPCalendarControl object.
BOOL | m_bEnableTheme
True to enable Luna theme.
COLORREF | m_clrUnderLineHdr
Color of header's underline.
XTPCurrentSystemTheme | m_CurrSystemTheme
Current theme flag.
XTPCalendarTheme | m_nPaintTheme
Store the Paint Theme;.
DWORD | m_dwAskItemTextFlags
Store flag set to send XTP_NC_CALENDAR_GETITEMTEXT notification.

Detailed Description

CXTPCalendarOffice2000Theme is a CXTPCalendarPaintManager derived class that represents the Office 2000 calendar theme.

Constructor & Destructor Documentation

◆ CXTPCalendarOffice2000Theme()

CXTPCalendarOffice2000Theme ( )

Default paint manager constructor.

Handles initial initialization.

See also
RefreshMetrics()

◆ ~CXTPCalendarOffice2000Theme()

virtual ~CXTPCalendarOffice2000Theme ( )
virtual

Default paint manager destructor.

Handles member items deallocation.

The documentation for this class was generated from the following file:
  • XTPCalendarOffice2000Theme.h


Toolkit Pro: CXTPCalendarOffice2003Theme Class Reference

Public Member Functions | List of all members
CXTPCalendarOffice2003Theme Class Reference

CXTPCalendarOffice2003Theme is a CXTPCalendarOffice2000Theme derived class that represents the Office 2003 calendar theme. More...

Inheritance diagram for CXTPCalendarOffice2003Theme:
[legend]

Public Member Functions

CXTPCalendarOffice2003Theme ()
Default paint manager constructor.
virtual | ~CXTPCalendarOffice2003Theme ()
Default paint manager destructor.
virtual void | RefreshMetrics ()
This member function is used to initialize all drawing defaults.
- Public Member Functions inherited from CXTPCalendarOffice2000Theme
CXTPCalendarOffice2000Theme ()
Default paint manager constructor.
virtual | ~CXTPCalendarOffice2000Theme ()
Default paint manager destructor.
- Public Member Functions inherited from CXTPCalendarPaintManager
BEGIN_VIEW_PART (ControlPart, XTPCalendarViewPart) virtual void RefreshMetrics()
Paint manager's ControlPart is used as parent for the other parts of the control.
END_VIEW_PART (ControlPart) BEGIN_VIEW_PART(DayViewTimeScaleHeaderPart
This paint manager part is used to draw the time scale header, 'Now' line, and the expand signs for the Day View.
virtual void | OnDraw (CDC *pDC, CXTPCalendarDayView *pView, CRect rc, CString strText)
This member function is used to draw the time scale header.
virtual void | DrawNowLine (CDC *pDC, CXTPCalendarDayView *pView, CRect rc, int y, BOOL bDrawBk=FALSE)
This member function is used to draw the 'Now' line.
virtual void | DrawNowLine (CDC *pDC, CXTPCalendarDayView *pView, CXTPCalendarDayViewTimeScale *pScale, CRect rc, int y, BOOL bDrawBk=FALSE)
This member function is used to draw the 'Now' line.
virtual void | DrawExpandSigns (CDC *pDC, CXTPCalendarDayView *pView, const CRect &rcTSHours)
This member function is used to draw expand signs.
END_VIEW_PART (DayViewTimeScaleHeaderPart) BEGIN_VIEW_PART(DayViewTimeScaleCellPart
This paint manager part is used to draw time scale time cells for the Day View.
void | AdjustTimeFont (CDC *pDC, CRect rcCell)
This member function is used to adjust the time text font size.
void | CalcWidth (CDC *pDC, const CString &strHour, const CString &strMin, int nHourHeight, int &nWidth)
This member function is used to adjust the time text font size.
virtual void | DrawHourCell (CDC *pDC, CRect rc, CString strText, BOOL bFillBackground=TRUE, BOOL bCurrentTime=FALSE)
This member function is used to draw background of the time scale header.
virtual void | DrawBigHourCell (CDC *pDC, CRect rc, CString strHour, CString strMin, int nRowPerHour, BOOL bFillBackground=TRUE, BOOL bCurrentTime=FALSE)
This member function is used to draw the big hour cell.
END_VIEW_PART (DayViewTimeScaleCellPart) BEGIN_VIEW_PART(DayViewCellPart
This paint manager part is used as the base class for the parts which draw different kinds of no all-day-cells (work/non-work) for the Day View.
virtual void | GetParams (CXTPCalendarDayViewGroup *pViewGroup, XTP_CALENDAR_DAYVIEWCELL_PARAMS *rCellParams)
This member function is used to fill out cell parameters with default values.
virtual void | OnDraw (CDC *pDC, CXTPCalendarDayViewGroup *pViewGroup, CRect rc, const XTP_CALENDAR_DAYVIEWCELL_PARAMS &cellParams)
This member function is used to draw the day view with no all-day-cells.
END_VIEW_PART (DayViewCellPart) BEGIN_VIEW_PART(DayViewWorkCellPart
This paint manager part is used to draw a day view that contains no all day work time cells.
END_VIEW_PART (DayViewWorkCellPart) BEGIN_VIEW_PART(DayViewNonworkCellPart
This paint manager part is used to draw "no all day non-work" time cells for the Day View.
END_VIEW_PART (DayViewNonworkCellPart) BEGIN_VIEW_PART(DayMonthViewHeaderPart
This paint manager part is used to draw days headers for the Day View.
END_VIEW_PART (DayMonthViewHeaderPart) BEGIN_VIEW_PART(DayViewHeaderPart
This paint manager part is used to draw days headers for the Day View.
virtual DayMonthViewHeaderPart void | OnDraw (CDC *pDC, CXTPCalendarDayViewDay *pViewDay, CRect rc, CString strText)
This member function is used to draw the day header.
END_VIEW_PART (DayViewHeaderPart) BEGIN_VIEW_PART(DayViewGroupHeaderPart
This paint manager part is used to draw Groups headers for the Day View.
virtual DayMonthViewHeaderPart void | OnDraw (CDC *pDC, CXTPCalendarDayViewGroup *pViewGroup, CRect rc, CString strText)
This member function is used to draw the day header.
END_VIEW_PART (DayViewGroupHeaderPart) BEGIN_VIEW_PART(DayViewAllDayEventsPart
This paint manager part is used to draw all day events area for the Day View.
virtual void | OnDraw (CDC *pDC, CXTPCalendarDayViewGroup *pViewGroup, CRect rc, BOOL bSelected)
This member function is used to draw the all-day events area.
END_VIEW_PART (DayViewAllDayEventsPart) BEGIN_VIEW_PART(DayViewAllDayEventScrollIconsPart
This paint manager part is used to draw all day events scroll buttons if there are too many all day events.
virtual XTPCalendarViewPart void | OnDraw (CDC *pDC, CXTPCalendarDayViewGroup *pViewGroup, BOOL bDrawUp, BOOL bDrawDown, const CRect &rcIconUp, const CRect &rcIconDown, BOOL bHighlightUp, BOOL bHighlightDown)
This member function is used to draw scroll icons in all day events area.
END_VIEW_PART (DayViewAllDayEventScrollIconsPart) BEGIN_VIEW_PART(DayViewEventPart
This paint manager part is used to draw events for the Day View.
virtual void | OnDraw (CDC *pDC, CXTPCalendarDayViewEvent *pViewEvent)
This member function is used to draw an event.
END_VIEW_PART (DayViewEventPart) BEGIN_VIEW_PART(MonthViewGridPart
This paint manager part is used to draw days grid and to fill days cells background for the Month View.
virtual void | OnDrawGrid (CDC *pDC, CXTPCalendarMonthView *pMonthView)
This member function is used to draw the days grid and to fill the days cells background.
END_VIEW_PART (MonthViewGridPart) BEGIN_VIEW_PART(MonthViewHeaderPart
This paint manager part is used to draw week days headers for the Month View.
virtual DayMonthViewHeaderPart void | OnDraw (CDC *pDC, CXTPCalendarMonthView *pMonthView, CRect rc, int nCollIndex, CString strText)
This member function is used to draw the week day header.
END_VIEW_PART (MonthViewHeaderPart) BEGIN_VIEW_PART(MonthViewEventPart
This paint manager part is used to draw events and day dates for the Month View.
virtual void | OnDrawEvent (CDC *pDC, CXTPCalendarMonthViewEvent *pViewEvent)
This member function is used to draw an event.
virtual void | OnDrawDayDate (CDC *pDC, CRect rc, BOOL bToday, BOOL bSelected, BOOL bFirstMonthDay, CString strText)
This member function is used to draw the week day header.
END_VIEW_PART (MonthViewEventPart) BEGIN_VIEW_PART(WeekViewPart
This paint manager part is used to draw week days grid and headers for the Week View.
virtual void | OnDraw (CDC *pDC, CXTPCalendarWeekView *pWeekView)
This member function is used to draw an event.
virtual void | DrawDayHeader (CDC *pDC, CRect rcDay, int nHeaderHeight, CString strHeader, BOOL bIsCurrent=FALSE, BOOL bIsSelected=FALSE)
This member function is used to draw the day header.
END_VIEW_PART (WeekViewPart) BEGIN_VIEW_PART(WeekViewEventPart
This paint manager part is used to draw events for the Week View.
virtual void | OnDraw (CDC *pDC, CXTPCalendarWeekViewEvent *pWeekViewEvent)
This member function is used to draw the specified event.
virtual void | DrawBorder (CDC *pDC, CRect rcView, CXTPCalendarWeekViewEvent *pWeekViewEvent)
This member functions is used to draw the event border.
virtual int | DrawTimes (CDC *pDC, CXTPCalendarWeekViewEvent *pWeekViewEvent)
This member function is used to draw the event's times texts or icons.
virtual void | DrawSubj (CDC *pDC, CXTPCalendarWeekViewEvent *pWeekViewEvent)
This member function is used to draw the event subject.
END_VIEW_PART (WeekViewEventPart) BEGIN_VIEW_PART(TimeLineViewTimeScalePart_Day
This paint manager part is used to draw time scale for the Time Line view.
virtual void | DrawGroup (CDC *pDC, const CRect &rcRect, CXTPCalendarTimeLineViewGroup *pGroup)
Call this function to draw the time line view group.
virtual CSize | CalcEventSize (CDC *c, CXTPCalendarTimeLineViewEvent *pViewEvent)
Call this function to calculate the time line view event size.
virtual void | DrawEvent (CDC *pDC, const CRect &rcEvents, CXTPCalendarTimeLineViewEvent *pViewEvent)
Call this function to draw the event.
virtual void | _Init ()
Call this function to do the initializations.
virtual | ~CTimeLineViewPart ()
Destroys the CTimeLineViewPart object, does the cleanup.
CXTPCalendarPaintManager ()
Default paint manager constructor.
virtual | ~CXTPCalendarPaintManager ()
Default paint manager destructor.
virtual void | UpdateEventLabelsDefaultColors ()
This member function is called to update event label default colors.
virtual void | UpdateEventCategoriesDefaultColors ()
This member function is called to update event category default colors.
virtual XTPCalendarTheme | GetPaintTheme () const
This member function is used to obtain the current paint theme.
virtual void | SetPaintTheme (XTPCalendarTheme ePaintTheme)
This member function is used to set the current paint theme.
virtual void | UpdateGlyphs ()
Initializes Calendar images.
virtual COLORREF | GetEventBackColor (CXTPCalendarEvent *pEvent, COLORREF crDefault)
Call this member function to get the background color for the specified event.
virtual void | DrawLine (CDC *pDC, int xPos, int yPos, int cx, int cy)
This member function is used to draw an arbitrary line.
virtual void | DrawHorizontalLine (CDC *pDC, int xPos, int yPos, int cx)
This member function is used to draw a Horizontal line.
virtual void | DrawVerticalLine (CDC *pDC, int xPos, int yPos, int cy)
This member function is used to draw a Vertical line.
virtual int | DrawClock (CDC *pDC, COleDateTime dtClockTime, CRect rcView, COLORREF clrBackground, XTPCalendarClockAlignFlags cafAlign)
This member function is used to draw the time as a clock.
virtual int | DrawBitmap (CImageList *pImageList, CDC *pDC, CRect rcView, int iIcon, UINT uFlags=0)
This member function is used to draw a bitmap from the provided ImageList.
virtual int | DrawBitmap (UINT nIDResource, CDC *pDC, CRect rcBitmap)
This member function is used to draw the bitmap using its resource id.
virtual int | DrawIconChar (CDC *pDC, CRect rc, TCHAR ch)
This member function is used to draw the Glyph symbol using special font.
virtual const CSize | GetExpandSignSize ()
This member function is used to obtain the horizontal and vertical size of the Expand Sign bitmap.
virtual CSize | GetClockSize ()
This member function is used to obtain the horizontal and vertical size of the Clock.
virtual void | SetControl (CXTPCalendarControl *pControl)
This member function is used to set the CXTPCalendarControl object for the CXTPCalendarPaintManager.
virtual void | DrawShadow (CDC *pDC, const CRect &rcRect)
Call this member function to draw the shadow regions around the rectangle.
virtual int | DrawIcons (CDC *pDC, CXTPCalendarViewEvent *pViewEvent)
Call this member function to draw icons corresponding to the event state.
virtual void | DrawHeader (CDC *pDC, CRect &rcHeader, BOOL bIsSelected, BOOL bIsCurrent)
This member function is used to draw the Header.
virtual void | DrawHeader (CDC *pDC, CRect &rcHeader, BOOL bIsSelected, BOOL bIsCurrent, const CXTPPaintManagerColorGradient &grclr, COLORREF clrUnderLineHdr)
This member function is used to draw the Header.
virtual void | DrawBusyStatus (CDC *pDC, CRect &rcRect, int eBusyStatus)
This member function is used to fill the area using the corresponding busy color or pattern.
virtual void | DrawBusyStatus (CDC *pDC, CRgn &rgnBusy, int eBusyStatus)
This member function is used to fill the area using the corresponding busy color or pattern.
void | EnableTheme (BOOL bEnableTheme)
This member function is used to enable a new theme.
BOOL | IsThemeEnabled ()
This member function is used to obtain the status of the theme.
XTPCurrentSystemTheme GetCurrentSystemTheme ()
Call this member function to determine the current Windows XP theme that is in use.
void | SetBusyStatusBrush (int nBusyStatus, CBrush *pBrush, BOOL bAutodeleteBrush)
Call this member function to set custom brush to draw event busy status.
CBrush * | GetBusyStatusBrush (int nBusyStatus)
Call this member function to get a brush to draw event busy status.
DWORD | GetAskItemTextFlags () const
This member function returns a set of flags which define calendar items to send an XTP_NC_CALENDAR_GETITEMTEXT notification.
void | SetAskItemTextFlags (DWORD dwFlags)
This member function is used to set flags which define calendar items to send an XTP_NC_CALENDAR_GETITEMTEXT notification.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPCalendarPaintManager
DayViewTimeScaleHeaderPart CXTPCalendarViewPartFontValue | m_fntTimeText
Time text font.
int | m_nHourWidth
Width of hour part of the text in pixels.
int | m_nMinWidth
Width of minutes (am/pm) part of the text in pixels.
BOOL | m_bShowMinutes
Show minutes in TS when '60 Minutes' is selected.
XTPCalendarViewPart CXTPPaintManagerColor | m_clrBackgroundSlave
Background secondary color.
CXTPPaintManagerColor | m_clrShadow
Cell background color.
CXTPPaintManagerColor | m_clrHour
Cell border color.
XTPCalendarViewPart CXTPPaintManagerColor | m_clrBackground2
Second background color which is used to fill days background.
XTPCalendarViewPart COLORREF | m_clrTextHighLightColor
Text color for the selected event.
COLORREF | m_clrMultiDayEventFrameColor
Multi-day event frame color.
COLORREF | m_clrClassicUnderline
Underline color for today day.
CXTPPaintManagerColorGradient | m_grclrClassicSelDay
Gradient color for today day.
COLORREF | m_clrTextNormalColor
Text color for the day header and some other elements.
COLORREF | m_clrHeaderBottomLine
Text color for the day header bottom line.
XTPCalendarTimeLineViewPart CXTPPaintManagerColor | m_clrEventBar
Event bar color.
CXTPPaintManagerColor m_clrEventBarLine
Event bar line color.
CXTPPaintManagerColor | m_clrEventBorderLine
Event border line color.
CXTPPaintManagerColor | m_clrTimeScaleBackground
Time scale background color.
CXTPPaintManagerColor | m_clrTimeScaleHightlite
Time scale highlight color.
CXTPPaintManagerColor m_clrTimeScaleText
The time scale text color.
CXTPPaintManagerColor | m_clrSelectedBackground
The selected background color.
CXTPPaintManagerColor m_clrSelectedText
The selected text color.
CXTPPaintManagerColor | m_clrBackground
The background color.
CXTPPaintManagerColor | m_clrText
The text color.
CXTPPaintManagerColor | m_clrWeekendBackground
Time scale weekend background color.
CXTPPaintManagerColor m_clrButtonFace
Stores standard Button Face color.
CXTPPaintManagerColor | m_clrButtonFaceText
Stores standard color to display text.
CXTPPaintManagerColor m_clrWindow
Stores standard windows color.
CXTPPaintManagerColor m_clrWindowText
Stores standard color to display window text.
CXTPPaintManagerColor m_clr3DShadow
Stores standard color to display shadow items.
CXTPPaintManagerColor | m_clrHighlight
Stores standard color to display highlighted items.
CXTPPaintManagerColor | m_clrBorders [4]
Stores border line color, left = 0, top = 1, right = 2, bottom = 3.
CXTPPaintManagerColorGradient | m_grclrToday
Gradient color of today's header.
CUIntArray | m_arStartCol
hold start column in each virtual page
CUIntArray | m_arStartRow
hold start row in each virtual page

int | m_PrintPageWidth
Print page width.
- Protected Types inherited from CXTPCalendarPaintManager
enum | XTPEnumExpandSigns { idxExpandSignUp = 0 , idxExpandSignDown = 1 }
Enumerates types of expand signs drawn on a day view. More...
enum XTPEnumEventGlyphs {
idxMeeting = 0 , idxPrivate = 1 , idxRecurrenceException = 2 , idxRecurrenceOccurrence = 3 ,
idxReminder = 4
}
Enumerates types of event glyphs. More...
- Protected Member Functions inherited from CXTPCalendarPaintManager
CXTPCalendarViewPart * | AddViewPart (CXTPCalendarViewPart *pPart)
Call this member function to add the specified ViewPart object to the parts list.
CXTPCalendarViewPartBrushValue * | _GetAtGrow_BusyStatusBrushValue (int eBusyStatus, BOOL bGrow)
Returns drawing brush value for a specific busy status.
virtual void | InitBusyStatusDefaultColors ()
Set default colors/patterns to fill Busy Status area.
- Protected Attributes inherited from CXTPCalendarPaintManager
CList< CXTPCalendarViewPart *, CXTPCalendarViewPart * > | m_lstViewParts
Collection to store ViewParts objects.
CXTPImageManager * | m_pExpandSigns
Stores standard Expand Signs icons.
CXTPImageManager * m_pGlyphs
Stores standard glyphs for displaying events.
CFont * | m_pGlyphsFont
Stores standard glyphs font for displaying events.
CBitmap | m_bmpElsewherePattern
Stores standard bitmap pattern to draw Elsewhere event busy status.
CXTPBrush | m_xtpBrushElsewhere
Stores standard brush to draw Elsewhere event busy status.
CBitmap | m_bmpTentativePattern
Stores standard bitmap pattern to draw Tentative event busy status.
CXTPBrush | m_xtpBrushTentative
Stores standard brush to draw Tentative event busy status.
CXTPCalendarTypedPtrAutoDeleteArray< CPtrArray, CXTPCalendarViewPartBrushValue * > | m_arBusyStatusBrushes
Stores customizable brush values to draw Event Busy Status in the Day View.
CSize | m_szClockRect
Stores dimensions for a rectangle used to display the time as a clock glyph.
CXTPCalendarControl * | m_pControl
Stores a pointer to a CXTPCalendarControl object.
BOOL | m_bEnableTheme
True to enable Luna theme.
COLORREF | m_clrUnderLineHdr
Color of header's underline.
XTPCurrentSystemTheme | m_CurrSystemTheme
Current theme flag.
XTPCalendarTheme | m_nPaintTheme
Store the Paint Theme;.
DWORD | m_dwAskItemTextFlags
Store flag set to send XTP_NC_CALENDAR_GETITEMTEXT notification.

Detailed Description

CXTPCalendarOffice2003Theme is a CXTPCalendarOffice2000Theme derived class that represents the Office 2003 calendar theme.

Constructor & Destructor Documentation

◆ CXTPCalendarOffice2003Theme()

CXTPCalendarOffice2003Theme ( )

Default paint manager constructor.

Handles initial initialization.

See also
RefreshMetrics()

◆ ~CXTPCalendarOffice2003Theme()

virtual ~CXTPCalendarOffice2003Theme ( )
virtual

Default paint manager destructor.

Handles member items deallocation.

Member Function Documentation

◆ RefreshMetrics()

virtual void RefreshMetrics ( )
virtual

This member function is used to initialize all drawing defaults.

Initializes all drawings defaults (fonts, colors, etc.). most of defaults are system defaults.

Reimplemented from CXTPCalendarPaintManager.

The documentation for this class was generated from the following file:
  • XTPCalendarOffice2003Theme.h


Toolkit Pro: CXTPCalendarOffice2013Theme Class Reference

Public Member Functions | List of all members
CXTPCalendarOffice2013Theme Class Reference

CXTPCalendarOffice2013Theme is a CXTPCalendarOffice2000Theme derived class that represents the Office 2013 calendar theme. More...

Inheritance diagram for CXTPCalendarOffice2013Theme:
[legend]

Public Member Functions

CXTPCalendarOffice2013Theme ()
Default paint manager constructor.
virtual | ~CXTPCalendarOffice2013Theme ()
Default paint manager destructor.
virtual void | RefreshMetrics ()
This member function is used to initialize all drawing defaults.
virtual void | DrawHeader (CDC *pDC, CRect &rcHeader, BOOL bIsSelected, BOOL bIsCurrent, const CXTPPaintManagerColorGradient &grclr, COLORREF clrUnderLineHdr)
This member function is used to draw the Header.
virtual void | UpdateEventLabelsDefaultColors ()
This member function is called to update event label default colors.
virtual void | UpdateEventCategoriesDefaultColors ()
This member function is called to update event category default colors.
virtual void | UpdateGlyphs ()
Initializes Calendar images.
virtual COLORREF | GetEventBackColor (CXTPCalendarEvent *pEvent)
Call this member function to get the background color for the specified event.
virtual COLORREF | GetEventEdgeColor (CXTPCalendarEvent *pEvent)
Call this member function to get the edge color for the specified event.
- Public Member Functions inherited from CXTPCalendarOffice2000Theme
CXTPCalendarOffice2000Theme ()
Default paint manager constructor.
virtual | ~CXTPCalendarOffice2000Theme ()
Default paint manager destructor.
- Public Member Functions inherited from CXTPCalendarPaintManager
BEGIN_VIEW_PART (ControlPart, XTPCalendarViewPart) virtual void RefreshMetrics()
Paint manager's ControlPart is used as parent for the other parts of the control.
END_VIEW_PART (ControlPart) BEGIN_VIEW_PART(DayViewTimeScaleHeaderPart
This paint manager part is used to draw the time scale header, 'Now' line, and the expand signs for the Day View.
virtual void | OnDraw (CDC *pDC, CXTPCalendarDayView *pView, CRect rc, CString strText)
This member function is used to draw the time scale header.
virtual void | DrawNowLine (CDC *pDC, CXTPCalendarDayView *pView, CRect rc, int y, BOOL bDrawBk=FALSE)
This member function is used to draw the 'Now' line.
virtual void | DrawNowLine (CDC *pDC, CXTPCalendarDayView *pView, CXTPCalendarDayViewTimeScale *pScale, CRect rc, int y, BOOL bDrawBk=FALSE)
This member function is used to draw the 'Now' line.
virtual void | DrawExpandSigns (CDC *pDC, CXTPCalendarDayView *pView, const CRect &rcTSHours)
This member function is used to draw expand signs.
END_VIEW_PART (DayViewTimeScaleHeaderPart) BEGIN_VIEW_PART(DayViewTimeScaleCellPart
This paint manager part is used to draw time scale time cells for the Day View.
void | AdjustTimeFont (CDC *pDC, CRect rcCell)
This member function is used to adjust the time text font size.
void | CalcWidth (CDC *pDC, const CString &strHour, const CString &strMin, int nHourHeight, int &nWidth)
This member function is used to adjust the time text font size.
virtual void | DrawHourCell (CDC *pDC, CRect rc, CString strText, BOOL bFillBackground=TRUE, BOOL bCurrentTime=FALSE)
This member function is used to draw background of the time scale header.
virtual void | DrawBigHourCell (CDC *pDC, CRect rc, CString strHour, CString strMin, int nRowPerHour, BOOL bFillBackground=TRUE, BOOL bCurrentTime=FALSE)
This member function is used to draw the big hour cell.
END_VIEW_PART (DayViewTimeScaleCellPart) BEGIN_VIEW_PART(DayViewCellPart
This paint manager part is used as the base class for the parts which draw different kinds of no all-day-cells (work/non-work) for the Day View.
virtual void | GetParams (CXTPCalendarDayViewGroup *pViewGroup, XTP_CALENDAR_DAYVIEWCELL_PARAMS *rCellParams)
This member function is used to fill out cell parameters with default values.
virtual void | OnDraw (CDC *pDC, CXTPCalendarDayViewGroup *pViewGroup, CRect rc, const XTP_CALENDAR_DAYVIEWCELL_PARAMS &cellParams)
This member function is used to draw the day view with no all-day-cells.
END_VIEW_PART (DayViewCellPart) BEGIN_VIEW_PART(DayViewWorkCellPart
This paint manager part is used to draw a day view that contains no all day work time cells.
END_VIEW_PART (DayViewWorkCellPart) BEGIN_VIEW_PART(DayViewNonworkCellPart
This paint manager part is used to draw "no all day non-work" time cells for the Day View.
END_VIEW_PART (DayViewNonworkCellPart) BEGIN_VIEW_PART(DayMonthViewHeaderPart
This paint manager part is used to draw days headers for the Day View.
END_VIEW_PART (DayMonthViewHeaderPart) BEGIN_VIEW_PART(DayViewHeaderPart
This paint manager part is used to draw days headers for the Day View.
virtual DayMonthViewHeaderPart void | OnDraw (CDC *pDC, CXTPCalendarDayViewDay *pViewDay, CRect rc, CString strText)
This member function is used to draw the day header.
END_VIEW_PART (DayViewHeaderPart) BEGIN_VIEW_PART(DayViewGroupHeaderPart
This paint manager part is used to draw Groups headers for the Day View.
virtual DayMonthViewHeaderPart void | OnDraw (CDC *pDC, CXTPCalendarDayViewGroup *pViewGroup, CRect rc, CString strText)
This member function is used to draw the day header.
END_VIEW_PART (DayViewGroupHeaderPart) BEGIN_VIEW_PART(DayViewAllDayEventsPart
This paint manager part is used to draw all day events area for the Day View.
virtual void | OnDraw (CDC *pDC, CXTPCalendarDayViewGroup *pViewGroup, CRect rc, BOOL bSelected)
This member function is used to draw the all-day events area.
END_VIEW_PART (DayViewAllDayEventsPart) BEGIN_VIEW_PART(DayViewAllDayEventScrollIconsPart
This paint manager part is used to draw all day events scroll buttons if there are too many all day events.
virtual XTPCalendarViewPart void | OnDraw (CDC *pDC, CXTPCalendarDayViewGroup *pViewGroup, BOOL bDrawUp, BOOL bDrawDown, const CRect &rcIconUp, const CRect &rcIconDown, BOOL bHighlightUp, BOOL bHighlightDown)
This member function is used to draw scroll icons in all day events area.
END_VIEW_PART (DayViewAllDayEventScrollIconsPart) BEGIN_VIEW_PART(DayViewEventPart
This paint manager part is used to draw events for the Day View.
virtual void | OnDraw (CDC *pDC, CXTPCalendarDayViewEvent *pViewEvent)
This member function is used to draw an event.
END_VIEW_PART (DayViewEventPart) BEGIN_VIEW_PART(MonthViewGridPart
This paint manager part is used to draw days grid and to fill days cells background for the Month View.
virtual void | OnDrawGrid (CDC *pDC, CXTPCalendarMonthView *pMonthView)
This member function is used to draw the days grid and to fill the days cells background.
END_VIEW_PART (MonthViewGridPart) BEGIN_VIEW_PART(MonthViewHeaderPart
This paint manager part is used to draw week days headers for the Month View.
virtual DayMonthViewHeaderPart void | OnDraw (CDC *pDC, CXTPCalendarMonthView *pMonthView, CRect rc, int nCollIndex, CString strText)
This member function is used to draw the week day header.
END_VIEW_PART (MonthViewHeaderPart) BEGIN_VIEW_PART(MonthViewEventPart
This paint manager part is used to draw events and day dates for the Month View.
virtual void | OnDrawEvent (CDC *pDC, CXTPCalendarMonthViewEvent *pViewEvent)
This member function is used to draw an event.
virtual void | OnDrawDayDate (CDC *pDC, CRect rc, BOOL bToday, BOOL bSelected, BOOL bFirstMonthDay, CString strText)
This member function is used to draw the week day header.
END_VIEW_PART (MonthViewEventPart) BEGIN_VIEW_PART(WeekViewPart
This paint manager part is used to draw week days grid and headers for the Week View.
virtual void | OnDraw (CDC *pDC, CXTPCalendarWeekView *pWeekView)
This member function is used to draw an event.
virtual void | DrawDayHeader (CDC *pDC, CRect rcDay, int nHeaderHeight, CString strHeader, BOOL bIsCurrent=FALSE, BOOL bIsSelected=FALSE)
This member function is used to draw the day header.
END_VIEW_PART (WeekViewPart) BEGIN_VIEW_PART(WeekViewEventPart
This paint manager part is used to draw events for the Week View.
virtual void | OnDraw (CDC *pDC, CXTPCalendarWeekViewEvent *pWeekViewEvent)
This member function is used to draw the specified event.
virtual void | DrawBorder (CDC *pDC, CRect rcView, CXTPCalendarWeekViewEvent *pWeekViewEvent)
This member functions is used to draw the event border.
virtual int | DrawTimes (CDC *pDC, CXTPCalendarWeekViewEvent *pWeekViewEvent)
This member function is used to draw the event's times texts or icons.
virtual void | DrawSubj (CDC *pDC, CXTPCalendarWeekViewEvent *pWeekViewEvent)
This member function is used to draw the event subject.
END_VIEW_PART (WeekViewEventPart) BEGIN_VIEW_PART(TimeLineViewTimeScalePart_Day
This paint manager part is used to draw time scale for the Time Line view.
virtual void | DrawGroup (CDC *pDC, const CRect &rcRect, CXTPCalendarTimeLineViewGroup *pGroup)
Call this function to draw the time line view group.
virtual CSize | CalcEventSize (CDC *c, CXTPCalendarTimeLineViewEvent *pViewEvent)
Call this function to calculate the time line view event size.
virtual void | DrawEvent (CDC *pDC, const CRect &rcEvents, CXTPCalendarTimeLineViewEvent *pViewEvent)
Call this function to draw the event.
virtual void | _Init ()
Call this function to do the initializations.
virtual | ~CTimeLineViewPart ()
Destroys the CTimeLineViewPart object, does the cleanup.
CXTPCalendarPaintManager ()
Default paint manager constructor.
virtual | ~CXTPCalendarPaintManager ()
Default paint manager destructor.
virtual XTPCalendarTheme | GetPaintTheme () const
This member function is used to obtain the current paint theme.
virtual void | SetPaintTheme (XTPCalendarTheme ePaintTheme)
This member function is used to set the current paint theme.
virtual COLORREF | GetEventBackColor (CXTPCalendarEvent *pEvent, COLORREF crDefault)
Call this member function to get the background color for the specified event.
virtual void | DrawLine (CDC *pDC, int xPos, int yPos, int cx, int cy)
This member function is used to draw an arbitrary line.
virtual void | DrawHorizontalLine (CDC *pDC, int xPos, int yPos, int cx)
This member function is used to draw a Horizontal line.
virtual void | DrawVerticalLine (CDC *pDC, int xPos, int yPos, int cy)
This member function is used to draw a Vertical line.
virtual int | DrawClock (CDC *pDC, COleDateTime dtClockTime, CRect rcView, COLORREF clrBackground, XTPCalendarClockAlignFlags cafAlign)
This member function is used to draw the time as a clock.
virtual int | DrawBitmap (CImageList *pImageList, CDC *pDC, CRect rcView, int iIcon, UINT uFlags=0)
This member function is used to draw a bitmap from the provided ImageList.
virtual int | DrawBitmap (UINT nIDResource, CDC *pDC, CRect rcBitmap)
This member function is used to draw the bitmap using its resource id.
virtual int | DrawIconChar (CDC *pDC, CRect rc, TCHAR ch)
This member function is used to draw the Glyph symbol using special font.
virtual const CSize | GetExpandSignSize ()
This member function is used to obtain the horizontal and vertical size of the Expand Sign bitmap.
virtual CSize | GetClockSize ()
This member function is used to obtain the horizontal and vertical size of the Clock.
virtual void | SetControl (CXTPCalendarControl *pControl)
This member function is used to set the CXTPCalendarControl object for the CXTPCalendarPaintManager.
virtual void | DrawShadow (CDC *pDC, const CRect &rcRect)
Call this member function to draw the shadow regions around the rectangle.
virtual int | DrawIcons (CDC *pDC, CXTPCalendarViewEvent *pViewEvent)
Call this member function to draw icons corresponding to the event state.
virtual void | DrawHeader (CDC *pDC, CRect &rcHeader, BOOL bIsSelected, BOOL bIsCurrent)
This member function is used to draw the Header.
virtual void | DrawBusyStatus (CDC *pDC, CRect &rcRect, int eBusyStatus)
This member function is used to fill the area using the corresponding busy color or pattern.
virtual void | DrawBusyStatus (CDC *pDC, CRgn &rgnBusy, int eBusyStatus)
This member function is used to fill the area using the corresponding busy color or pattern.
void | EnableTheme (BOOL bEnableTheme)
This member function is used to enable a new theme.
BOOL | IsThemeEnabled ()
This member function is used to obtain the status of the theme.
XTPCurrentSystemTheme GetCurrentSystemTheme ()
Call this member function to determine the current Windows XP theme that is in use.
void | SetBusyStatusBrush (int nBusyStatus, CBrush *pBrush, BOOL bAutodeleteBrush)
Call this member function to set custom brush to draw event busy status.
CBrush * | GetBusyStatusBrush (int nBusyStatus)
Call this member function to get a brush to draw event busy status.
DWORD | GetAskItemTextFlags () const
This member function returns a set of flags which define calendar items to send an XTP_NC_CALENDAR_GETITEMTEXT notification.
void | SetAskItemTextFlags (DWORD dwFlags)
This member function is used to set flags which define calendar items to send an XTP_NC_CALENDAR_GETITEMTEXT notification.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPCalendarPaintManager
DayViewTimeScaleHeaderPart CXTPCalendarViewPartFontValue | m_fntTimeText
Time text font.
int | m_nHourWidth
Width of hour part of the text in pixels.
int | m_nMinWidth
Width of minutes (am/pm) part of the text in pixels.
BOOL | m_bShowMinutes
Show minutes in TS when '60 Minutes' is selected.
XTPCalendarViewPart CXTPPaintManagerColor | m_clrBackgroundSlave
Background secondary color.
CXTPPaintManagerColor | m_clrShadow
Cell background color.
CXTPPaintManagerColor | m_clrHour
Cell border color.
XTPCalendarViewPart CXTPPaintManagerColor | m_clrBackground2
Second background color which is used to fill days background.
XTPCalendarViewPart COLORREF | m_clrTextHighLightColor
Text color for the selected event.
COLORREF | m_clrMultiDayEventFrameColor
Multi-day event frame color.
COLORREF | m_clrClassicUnderline
Underline color for today day.
CXTPPaintManagerColorGradient | m_grclrClassicSelDay
Gradient color for today day.
COLORREF | m_clrTextNormalColor
Text color for the day header and some other elements.
COLORREF | m_clrHeaderBottomLine
Text color for the day header bottom line.
XTPCalendarTimeLineViewPart CXTPPaintManagerColor | m_clrEventBar
Event bar color.
CXTPPaintManagerColor m_clrEventBarLine
Event bar line color.
CXTPPaintManagerColor | m_clrEventBorderLine
Event border line color.
CXTPPaintManagerColor | m_clrTimeScaleBackground
Time scale background color.
CXTPPaintManagerColor | m_clrTimeScaleHightlite
Time scale highlight color.
CXTPPaintManagerColor m_clrTimeScaleText
The time scale text color.
CXTPPaintManagerColor | m_clrSelectedBackground
The selected background color.
CXTPPaintManagerColor m_clrSelectedText
The selected text color.
CXTPPaintManagerColor | m_clrBackground
The background color.
CXTPPaintManagerColor | m_clrText
The text color.
CXTPPaintManagerColor | m_clrWeekendBackground
Time scale weekend background color.
CXTPPaintManagerColor m_clrButtonFace
Stores standard Button Face color.
CXTPPaintManagerColor | m_clrButtonFaceText
Stores standard color to display text.
CXTPPaintManagerColor m_clrWindow
Stores standard windows color.
CXTPPaintManagerColor m_clrWindowText
Stores standard color to display window text.
CXTPPaintManagerColor m_clr3DShadow
Stores standard color to display shadow items.
CXTPPaintManagerColor | m_clrHighlight
Stores standard color to display highlighted items.
CXTPPaintManagerColor | m_clrBorders [4]
Stores border line color, left = 0, top = 1, right = 2, bottom = 3.
CXTPPaintManagerColorGradient | m_grclrToday
Gradient color of today's header.
CUIntArray | m_arStartCol
hold start column in each virtual page
CUIntArray | m_arStartRow
hold start row in each virtual page

int | m_PrintPageWidth
Print page width.
- Protected Types inherited from CXTPCalendarPaintManager
enum | XTPEnumExpandSigns { idxExpandSignUp = 0 , idxExpandSignDown = 1 }
Enumerates types of expand signs drawn on a day view. More...
enum XTPEnumEventGlyphs {
idxMeeting = 0 , idxPrivate = 1 , idxRecurrenceException = 2 , idxRecurrenceOccurrence = 3 ,
idxReminder = 4
}
Enumerates types of event glyphs. More...
- Protected Member Functions inherited from CXTPCalendarPaintManager
CXTPCalendarViewPart * | AddViewPart (CXTPCalendarViewPart *pPart)
Call this member function to add the specified ViewPart object to the parts list.
CXTPCalendarViewPartBrushValue * | _GetAtGrow_BusyStatusBrushValue (int eBusyStatus, BOOL bGrow)
Returns drawing brush value for a specific busy status.
virtual void | InitBusyStatusDefaultColors ()
Set default colors/patterns to fill Busy Status area.
- Protected Attributes inherited from CXTPCalendarPaintManager
CList< CXTPCalendarViewPart *, CXTPCalendarViewPart * > | m_lstViewParts
Collection to store ViewParts objects.
CXTPImageManager * | m_pExpandSigns
Stores standard Expand Signs icons.
CXTPImageManager * m_pGlyphs
Stores standard glyphs for displaying events.
CFont * | m_pGlyphsFont
Stores standard glyphs font for displaying events.
CBitmap | m_bmpElsewherePattern
Stores standard bitmap pattern to draw Elsewhere event busy status.
CXTPBrush | m_xtpBrushElsewhere
Stores standard brush to draw Elsewhere event busy status.
CBitmap | m_bmpTentativePattern
Stores standard bitmap pattern to draw Tentative event busy status.
CXTPBrush | m_xtpBrushTentative
Stores standard brush to draw Tentative event busy status.
CXTPCalendarTypedPtrAutoDeleteArray< CPtrArray, CXTPCalendarViewPartBrushValue * > | m_arBusyStatusBrushes
Stores customizable brush values to draw Event Busy Status in the Day View.
CSize | m_szClockRect
Stores dimensions for a rectangle used to display the time as a clock glyph.
CXTPCalendarControl * | m_pControl
Stores a pointer to a CXTPCalendarControl object.
BOOL | m_bEnableTheme
True to enable Luna theme.
COLORREF | m_clrUnderLineHdr
Color of header's underline.
XTPCurrentSystemTheme | m_CurrSystemTheme
Current theme flag.
XTPCalendarTheme | m_nPaintTheme
Store the Paint Theme;.
DWORD | m_dwAskItemTextFlags
Store flag set to send XTP_NC_CALENDAR_GETITEMTEXT notification.

Detailed Description

CXTPCalendarOffice2013Theme is a CXTPCalendarOffice2000Theme derived class that represents the Office 2013 calendar theme.

Constructor & Destructor Documentation

◆ CXTPCalendarOffice2013Theme()

CXTPCalendarOffice2013Theme ( )

Default paint manager constructor.

Handles initial initialization.

See also
RefreshMetrics()

◆ ~CXTPCalendarOffice2013Theme()

virtual ~CXTPCalendarOffice2013Theme ( )
virtual

Default paint manager destructor.

Handles member items deallocation.

Member Function Documentation

◆ DrawHeader()

virtual void DrawHeader | ( | CDC * | pDC,
 |  | CRect & | rcHeader,
 |  | BOOL | bIsSelected,
 |  | BOOL | bIsCurrent,
 |  | const CXTPPaintManagerColorGradient & | grclr,
 |  | COLORREF | clrUnderLineHdr )
 virtual

This member function is used to draw the Header.

Parameters
pDC | Pointer to a valid device context.
rcHeader | A CRect that contains the bounding rectangle coordinates used to draw the header.
bIsSelected | A BOOL. TRUE if the header is selected. FALSE otherwise.
bIsCurrent | A BOOL. TRUE if the header represents the current time. FALSE otherwise.
grclr | A CXTPPaintManagerColorGradient object that specifies the Gradient color.
clrUnderLineHdr | A COLORREF object that specifies the color of header's underline.

Reimplemented from CXTPCalendarPaintManager.

◆ GetEventBackColor()

virtual COLORREF GetEventBackColor ( CXTPCalendarEvent * pEvent )
virtual

Call this member function to get the background color for the specified event.

Parameters
pEvent Points to the Calendar event.
Returns
An RGB value representing the event background color.

◆ GetEventEdgeColor()

virtual COLORREF GetEventEdgeColor ( CXTPCalendarEvent * pEvent )
virtual

Call this member function to get the edge color for the specified event.

Parameters
pEvent : Points to the Calendar event.
Returns
An RGB value representing the event edge color.

◆ RefreshMetrics()

virtual void RefreshMetrics ( )
virtual

This member function is used to initialize all drawing defaults.

Initializes all drawings defaults (fonts, colors, etc.). most of defaults are system defaults.

Reimplemented from CXTPCalendarPaintManager.

◆ UpdateGlyphs()

virtual void UpdateGlyphs ( )
virtual

Initializes Calendar images.

Called by the paint manager to initialize images used by the Calendar control.

Reimplemented from CXTPCalendarPaintManager.

The documentation for this class was generated from the following file:
  • XTPCalendarOffice2013Theme.h


Toolkit Pro: CXTPCalendarOfficeXPTheme Class Reference

Public Member Functions | List of all members
CXTPCalendarOfficeXPTheme Class Reference

CXTPCalendarOfficeXPTheme is a CXTPCalendarOffice2000Theme derived class that represents the Office XP calendar theme. More...

Inheritance diagram for CXTPCalendarOfficeXPTheme:
[legend]

Public Member Functions

CXTPCalendarOfficeXPTheme ()
Default paint manager constructor.
virtual | ~CXTPCalendarOfficeXPTheme ()
Default paint manager destructor.
- Public Member Functions inherited from CXTPCalendarOffice2000Theme
CXTPCalendarOffice2000Theme ()
Default paint manager constructor.
virtual | ~CXTPCalendarOffice2000Theme ()
Default paint manager destructor.
- Public Member Functions inherited from CXTPCalendarPaintManager
BEGIN_VIEW_PART (ControlPart, XTPCalendarViewPart) virtual void RefreshMetrics()
Paint manager's ControlPart is used as parent for the other parts of the control.
END_VIEW_PART (ControlPart) BEGIN_VIEW_PART(DayViewTimeScaleHeaderPart
This paint manager part is used to draw the time scale header, 'Now' line, and the expand signs for the Day View.
virtual void | RefreshMetrics ()
Performs refreshing of graphical related parameters from system settings.
virtual void | OnDraw (CDC *pDC, CXTPCalendarDayView *pView, CRect rc, CString strText)
This member function is used to draw the time scale header.
virtual void | DrawNowLine (CDC *pDC, CXTPCalendarDayView *pView, CRect rc, int y, BOOL bDrawBk=FALSE)
This member function is used to draw the 'Now' line.
virtual void | DrawNowLine (CDC *pDC, CXTPCalendarDayView *pView, CXTPCalendarDayViewTimeScale *pScale, CRect rc, int y, BOOL bDrawBk=FALSE)
This member function is used to draw the 'Now' line.
virtual void | DrawExpandSigns (CDC *pDC, CXTPCalendarDayView *pView, const CRect &rcTSHours)
This member function is used to draw expand signs.
END_VIEW_PART (DayViewTimeScaleHeaderPart) BEGIN_VIEW_PART(DayViewTimeScaleCellPart
This paint manager part is used to draw time scale time cells for the Day View.
virtual void | RefreshMetrics ()
This member function is used to refresh the graphical related parameters using system settings.
void | AdjustTimeFont (CDC *pDC, CRect rcCell)
This member function is used to adjust the time text font size.
void | CalcWidth (CDC *pDC, const CString &strHour, const CString &strMin, int nHourHeight, int &nWidth)
This member function is used to adjust the time text font size.
virtual void | DrawHourCell (CDC *pDC, CRect rc, CString strText, BOOL bFillBackground=TRUE, BOOL bCurrentTime=FALSE)
This member function is used to draw background of the time scale header.
virtual void | DrawBigHourCell (CDC *pDC, CRect rc, CString strHour, CString strMin, int nRowPerHour, BOOL bFillBackground=TRUE, BOOL bCurrentTime=FALSE)
This member function is used to draw the big hour cell.
END_VIEW_PART (DayViewTimeScaleCellPart) BEGIN_VIEW_PART(DayViewCellPart
This paint manager part is used as the base class for the parts which draw different kinds of no all-day-cells (work/non-work) for the Day View.
virtual void | RefreshMetrics ()
This member function is used to refresh the graphical related parameters using system settings.
virtual void | GetParams (CXTPCalendarDayViewGroup *pViewGroup, XTP_CALENDAR_DAYVIEWCELL_PARAMS *rCellParams)
This member function is used to fill out cell parameters with default values.
virtual void | OnDraw (CDC *pDC, CXTPCalendarDayViewGroup *pViewGroup, CRect rc, const XTP_CALENDAR_DAYVIEWCELL_PARAMS &cellParams)
This member function is used to draw the day view with no all-day-cells.
END_VIEW_PART (DayViewCellPart) BEGIN_VIEW_PART(DayViewWorkCellPart
This paint manager part is used to draw a day view that contains no all day work time cells.
virtual DayViewCellPart void | RefreshMetrics ()
This member function is used to perform the refreshing of graphical related parameters from system settings.
END_VIEW_PART (DayViewWorkCellPart) BEGIN_VIEW_PART(DayViewNonworkCellPart
This paint manager part is used to draw "no all day non-work" time cells for the Day View.
virtual DayViewCellPart void | RefreshMetrics ()
This member function is used to perform refreshing of graphical related parameters from system settings.
END_VIEW_PART (DayViewNonworkCellPart) BEGIN_VIEW_PART(DayMonthViewHeaderPart
This paint manager part is used to draw days headers for the Day View.
virtual void | RefreshMetrics ()
This member function is used to perform refreshing of graphical related parameters from system settings.
END_VIEW_PART (DayMonthViewHeaderPart) BEGIN_VIEW_PART(DayViewHeaderPart
This paint manager part is used to draw days headers for the Day View.
virtual DayMonthViewHeaderPart void | OnDraw (CDC *pDC, CXTPCalendarDayViewDay *pViewDay, CRect rc, CString strText)
This member function is used to draw the day header.
END_VIEW_PART (DayViewHeaderPart) BEGIN_VIEW_PART(DayViewGroupHeaderPart
This paint manager part is used to draw Groups headers for the Day View.
virtual DayMonthViewHeaderPart void | OnDraw (CDC *pDC, CXTPCalendarDayViewGroup *pViewGroup, CRect rc, CString strText)
This member function is used to draw the day header.
END_VIEW_PART (DayViewGroupHeaderPart) BEGIN_VIEW_PART(DayViewAllDayEventsPart
This paint manager part is used to draw all day events area for the Day View.
virtual XTPCalendarViewPart void | RefreshMetrics ()
This member functions is used to perform refreshing of graphical related parameters from system settings.
virtual void | OnDraw (CDC *pDC, CXTPCalendarDayViewGroup *pViewGroup, CRect rc, BOOL bSelected)
This member function is used to draw the all-day events area.
END_VIEW_PART (DayViewAllDayEventsPart) BEGIN_VIEW_PART(DayViewAllDayEventScrollIconsPart
This paint manager part is used to draw all day events scroll buttons if there are too many all day events.
virtual XTPCalendarViewPart void | OnDraw (CDC *pDC, CXTPCalendarDayViewGroup *pViewGroup, BOOL bDrawUp, BOOL bDrawDown, const CRect &rcIconUp, const CRect &rcIconDown, BOOL bHighlightUp, BOOL bHighlightDown)
This member function is used to draw scroll icons in all day events area.
END_VIEW_PART (DayViewAllDayEventScrollIconsPart) BEGIN_VIEW_PART(DayViewEventPart
This paint manager part is used to draw events for the Day View.
virtual XTPCalendarViewPart void | RefreshMetrics ()
Performs refreshing of graphical related parameters from system settings.
virtual void | OnDraw (CDC *pDC, CXTPCalendarDayViewEvent *pViewEvent)
This member function is used to draw an event.
END_VIEW_PART (DayViewEventPart) BEGIN_VIEW_PART(MonthViewGridPart
This paint manager part is used to draw days grid and to fill days cells background for the Month View.
virtual void | RefreshMetrics ()
Performs refreshing of graphical related parameters from system settings.
virtual void | OnDrawGrid (CDC *pDC, CXTPCalendarMonthView *pMonthView)
This member function is used to draw the days grid and to fill the days cells background.
END_VIEW_PART (MonthViewGridPart) BEGIN_VIEW_PART(MonthViewHeaderPart
This paint manager part is used to draw week days headers for the Month View.
virtual DayMonthViewHeaderPart void | OnDraw (CDC *pDC, CXTPCalendarMonthView *pMonthView, CRect rc, int nCollIndex, CString strText)
This member function is used to draw the week day header.
END_VIEW_PART (MonthViewHeaderPart) BEGIN_VIEW_PART(MonthViewEventPart
This paint manager part is used to draw events and day dates for the Month View.
virtual void | RefreshMetrics ()
Performs refreshing of graphical related parameters from system settings.
virtual void | OnDrawEvent (CDC *pDC, CXTPCalendarMonthViewEvent *pViewEvent)
This member function is used to draw an event.
virtual void | OnDrawDayDate (CDC *pDC, CRect rc, BOOL bToday, BOOL bSelected, BOOL bFirstMonthDay, CString strText)
This member function is used to draw the week day header.
END_VIEW_PART (MonthViewEventPart) BEGIN_VIEW_PART(WeekViewPart
This paint manager part is used to draw week days grid and headers for the Week View.
virtual void | RefreshMetrics ()
Performs refreshing of graphical related parameters from system settings.
virtual void | OnDraw (CDC *pDC, CXTPCalendarWeekView *pWeekView)
This member function is used to draw an event.
virtual void | DrawDayHeader (CDC *pDC, CRect rcDay, int nHeaderHeight, CString strHeader, BOOL bIsCurrent=FALSE, BOOL bIsSelected=FALSE)
This member function is used to draw the day header.
END_VIEW_PART (WeekViewPart) BEGIN_VIEW_PART(WeekViewEventPart
This paint manager part is used to draw events for the Week View.
virtual void | RefreshMetrics ()
This member function is used to perform refreshing of graphical related parameters from system settings.
virtual void | OnDraw (CDC *pDC, CXTPCalendarWeekViewEvent *pWeekViewEvent)
This member function is used to draw the specified event.
virtual void | DrawBorder (CDC *pDC, CRect rcView, CXTPCalendarWeekViewEvent *pWeekViewEvent)
This member functions is used to draw the event border.
virtual int | DrawTimes (CDC *pDC, CXTPCalendarWeekViewEvent *pWeekViewEvent)
This member function is used to draw the event's times texts or icons.
virtual void | DrawSubj (CDC *pDC, CXTPCalendarWeekViewEvent *pWeekViewEvent)
This member function is used to draw the event subject.
END_VIEW_PART (WeekViewEventPart) BEGIN_VIEW_PART(TimeLineViewTimeScalePart_Day
This paint manager part is used to draw time scale for the Time Line view.
virtual void | DrawGroup (CDC *pDC, const CRect &rcRect, CXTPCalendarTimeLineViewGroup *pGroup)
Call this function to draw the time line view group.
virtual CSize | CalcEventSize (CDC *c, CXTPCalendarTimeLineViewEvent *pViewEvent)
Call this function to calculate the time line view event size.
virtual void | DrawEvent (CDC *pDC, const CRect &rcEvents, CXTPCalendarTimeLineViewEvent *pViewEvent)
Call this function to draw the event.
virtual void | RefreshMetrics ()
Call this function to refresh the metrics.
virtual void | _Init ()
Call this function to do the initializations.
virtual | ~CTimeLineViewPart ()
Destroys the CTimeLineViewPart object, does the cleanup.
CXTPCalendarPaintManager ()
Default paint manager constructor.
virtual | ~CXTPCalendarPaintManager ()
Default paint manager destructor.
virtual void | UpdateEventLabelsDefaultColors ()
This member function is called to update event label default colors.
virtual void | UpdateEventCategoriesDefaultColors ()
This member function is called to update event category default colors.
virtual XTPCalendarTheme | GetPaintTheme () const
This member function is used to obtain the current paint theme.
virtual void | SetPaintTheme (XTPCalendarTheme ePaintTheme)
This member function is used to set the current paint theme.
virtual void | RefreshMetrics ()
This member function is used to initialize all drawing defaults.
virtual void | UpdateGlyphs ()
Initializes Calendar images.
virtual COLORREF | GetEventBackColor (CXTPCalendarEvent *pEvent, COLORREF crDefault)
Call this member function to get the background color for the specified event.
virtual void | DrawLine (CDC *pDC, int xPos, int yPos, int cx, int cy)
This member function is used to draw an arbitrary line.
virtual void | DrawHorizontalLine (CDC *pDC, int xPos, int yPos, int cx)
This member function is used to draw a Horizontal line.
virtual void | DrawVerticalLine (CDC *pDC, int xPos, int yPos, int cy)
This member function is used to draw a Vertical line.
virtual int | DrawClock (CDC *pDC, COleDateTime dtClockTime, CRect rcView, COLORREF clrBackground, XTPCalendarClockAlignFlags cafAlign)
This member function is used to draw the time as a clock.
virtual int | DrawBitmap (CImageList *pImageList, CDC *pDC, CRect rcView, int iIcon, UINT uFlags=0)
This member function is used to draw a bitmap from the provided ImageList.
virtual int | DrawBitmap (UINT nIDResource, CDC *pDC, CRect rcBitmap)
This member function is used to draw the bitmap using its resource id.
virtual int | DrawIconChar (CDC *pDC, CRect rc, TCHAR ch)
This member function is used to draw the Glyph symbol using special font.
virtual const CSize | GetExpandSignSize ()
This member function is used to obtain the horizontal and vertical size of the Expand Sign bitmap.
virtual CSize | GetClockSize ()
This member function is used to obtain the horizontal and vertical size of the Clock.
virtual void | SetControl (CXTPCalendarControl *pControl)
This member function is used to set the CXTPCalendarControl object for the CXTPCalendarPaintManager.
virtual void | DrawShadow (CDC *pDC, const CRect &rcRect)
Call this member function to draw the shadow regions around the rectangle.
virtual int | DrawIcons (CDC *pDC, CXTPCalendarViewEvent *pViewEvent)
Call this member function to draw icons corresponding to the event state.
virtual void | DrawHeader (CDC *pDC, CRect &rcHeader, BOOL bIsSelected, BOOL bIsCurrent)
This member function is used to draw the Header.
virtual void | DrawHeader (CDC *pDC, CRect &rcHeader, BOOL bIsSelected, BOOL bIsCurrent, const CXTPPaintManagerColorGradient &grclr, COLORREF clrUnderLineHdr)
This member function is used to draw the Header.
virtual void | DrawBusyStatus (CDC *pDC, CRect &rcRect, int eBusyStatus)
This member function is used to fill the area using the corresponding busy color or pattern.
virtual void | DrawBusyStatus (CDC *pDC, CRgn &rgnBusy, int eBusyStatus)
This member function is used to fill the area using the corresponding busy color or pattern.
void | EnableTheme (BOOL bEnableTheme)
This member function is used to enable a new theme.
BOOL | IsThemeEnabled ()
This member function is used to obtain the status of the theme.
XTPCurrentSystemTheme GetCurrentSystemTheme ()
Call this member function to determine the current Windows XP theme that is in use.
void | SetBusyStatusBrush (int nBusyStatus, CBrush *pBrush, BOOL bAutodeleteBrush)
Call this member function to set custom brush to draw event busy status.
CBrush * | GetBusyStatusBrush (int nBusyStatus)
Call this member function to get a brush to draw event busy status.
DWORD | GetAskItemTextFlags () const
This member function returns a set of flags which define calendar items to send an XTP_NC_CALENDAR_GETITEMTEXT notification.
void | SetAskItemTextFlags (DWORD dwFlags)
This member function is used to set flags which define calendar items to send an XTP_NC_CALENDAR_GETITEMTEXT notification.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPCalendarPaintManager
DayViewTimeScaleHeaderPart CXTPCalendarViewPartFontValue | m_fntTimeText
Time text font.
int | m_nHourWidth
Width of hour part of the text in pixels.
int | m_nMinWidth
Width of minutes (am/pm) part of the text in pixels.
BOOL | m_bShowMinutes
Show minutes in TS when '60 Minutes' is selected.
XTPCalendarViewPart CXTPPaintManagerColor | m_clrBackgroundSlave
Background secondary color.
CXTPPaintManagerColor | m_clrShadow
Cell background color.
CXTPPaintManagerColor | m_clrHour
Cell border color.
XTPCalendarViewPart CXTPPaintManagerColor | m_clrBackground2
Second background color which is used to fill days background.
XTPCalendarViewPart COLORREF | m_clrTextHighLightColor
Text color for the selected event.
COLORREF | m_clrMultiDayEventFrameColor
Multi-day event frame color.
COLORREF | m_clrClassicUnderline
Underline color for today day.
CXTPPaintManagerColorGradient | m_grclrClassicSelDay
Gradient color for today day.
COLORREF | m_clrTextNormalColor
Text color for the day header and some other elements.
COLORREF | m_clrHeaderBottomLine
Text color for the day header bottom line.
XTPCalendarTimeLineViewPart CXTPPaintManagerColor | m_clrEventBar
Event bar color.
CXTPPaintManagerColor m_clrEventBarLine
Event bar line color.
CXTPPaintManagerColor | m_clrEventBorderLine
Event border line color.
CXTPPaintManagerColor | m_clrTimeScaleBackground
Time scale background color.
CXTPPaintManagerColor | m_clrTimeScaleHightlite
Time scale highlight color.
CXTPPaintManagerColor m_clrTimeScaleText
The time scale text color.
CXTPPaintManagerColor | m_clrSelectedBackground
The selected background color.
CXTPPaintManagerColor m_clrSelectedText
The selected text color.
CXTPPaintManagerColor | m_clrBackground
The background color.
CXTPPaintManagerColor | m_clrText
The text color.
CXTPPaintManagerColor | m_clrWeekendBackground
Time scale weekend background color.
CXTPPaintManagerColor m_clrButtonFace
Stores standard Button Face color.
CXTPPaintManagerColor | m_clrButtonFaceText
Stores standard color to display text.
CXTPPaintManagerColor m_clrWindow
Stores standard windows color.
CXTPPaintManagerColor m_clrWindowText
Stores standard color to display window text.
CXTPPaintManagerColor m_clr3DShadow
Stores standard color to display shadow items.
CXTPPaintManagerColor | m_clrHighlight
Stores standard color to display highlighted items.
CXTPPaintManagerColor | m_clrBorders [4]
Stores border line color, left = 0, top = 1, right = 2, bottom = 3.
CXTPPaintManagerColorGradient | m_grclrToday
Gradient color of today's header.
CUIntArray | m_arStartCol
hold start column in each virtual page
CUIntArray | m_arStartRow
hold start row in each virtual page

int | m_PrintPageWidth
Print page width.
- Protected Types inherited from CXTPCalendarPaintManager
enum | XTPEnumExpandSigns { idxExpandSignUp = 0 , idxExpandSignDown = 1 }
Enumerates types of expand signs drawn on a day view. More...
enum XTPEnumEventGlyphs {
idxMeeting = 0 , idxPrivate = 1 , idxRecurrenceException = 2 , idxRecurrenceOccurrence = 3 ,
idxReminder = 4
}
Enumerates types of event glyphs. More...
- Protected Member Functions inherited from CXTPCalendarPaintManager
CXTPCalendarViewPart * | AddViewPart (CXTPCalendarViewPart *pPart)
Call this member function to add the specified ViewPart object to the parts list.
CXTPCalendarViewPartBrushValue * | _GetAtGrow_BusyStatusBrushValue (int eBusyStatus, BOOL bGrow)
Returns drawing brush value for a specific busy status.
virtual void | InitBusyStatusDefaultColors ()
Set default colors/patterns to fill Busy Status area.
- Protected Attributes inherited from CXTPCalendarPaintManager
CList< CXTPCalendarViewPart *, CXTPCalendarViewPart * > | m_lstViewParts
Collection to store ViewParts objects.
CXTPImageManager * | m_pExpandSigns
Stores standard Expand Signs icons.
CXTPImageManager * m_pGlyphs
Stores standard glyphs for displaying events.
CFont * | m_pGlyphsFont
Stores standard glyphs font for displaying events.
CBitmap | m_bmpElsewherePattern
Stores standard bitmap pattern to draw Elsewhere event busy status.
CXTPBrush | m_xtpBrushElsewhere
Stores standard brush to draw Elsewhere event busy status.
CBitmap | m_bmpTentativePattern
Stores standard bitmap pattern to draw Tentative event busy status.
CXTPBrush | m_xtpBrushTentative
Stores standard brush to draw Tentative event busy status.
CXTPCalendarTypedPtrAutoDeleteArray< CPtrArray, CXTPCalendarViewPartBrushValue * > | m_arBusyStatusBrushes
Stores customizable brush values to draw Event Busy Status in the Day View.
CSize | m_szClockRect
Stores dimensions for a rectangle used to display the time as a clock glyph.
CXTPCalendarControl * | m_pControl
Stores a pointer to a CXTPCalendarControl object.
BOOL | m_bEnableTheme
True to enable Luna theme.
COLORREF | m_clrUnderLineHdr
Color of header's underline.
XTPCurrentSystemTheme | m_CurrSystemTheme
Current theme flag.
XTPCalendarTheme | m_nPaintTheme
Store the Paint Theme;.
DWORD | m_dwAskItemTextFlags
Store flag set to send XTP_NC_CALENDAR_GETITEMTEXT notification.

Detailed Description

CXTPCalendarOfficeXPTheme is a CXTPCalendarOffice2000Theme derived class that represents the Office XP calendar theme.

Constructor & Destructor Documentation

◆ CXTPCalendarOfficeXPTheme()

CXTPCalendarOfficeXPTheme ( )

Default paint manager constructor.

Handles initial initialization.

See also
RefreshMetrics()

◆ ~CXTPCalendarOfficeXPTheme()

virtual ~CXTPCalendarOfficeXPTheme ( )
virtual

Default paint manager destructor.

Handles member items deallocation.

The documentation for this class was generated from the following file:
  • XTPCalendarOfficeXPTheme.h


Toolkit Pro: CXTPCalendarOptions Class Reference

Public Member Functions | Public Attributes | Protected Attributes | List of all members
CXTPCalendarOptions Class Reference

Structure contains all calendar options. More...

Inheritance diagram for CXTPCalendarOptions:
[legend]

Public Member Functions

CXTPCalendarOptions ()
Default object constructor.
virtual | ~CXTPCalendarOptions ()
Default Destructor.
void | DoPropExchange (CXTPPropExchange *pPX)
This method reads data from or writes data to storage.
CXTPCalendarTimeZonePtr | GetCurrentTimeZoneInfo ()
Get full information about the current time zone.
void | OnOptionsChanged ()
This member function is called when option was changed.
void | SetDataProvider (CXTPCalendarData *pDataProvider)
This member function sets the custom data provider for the control.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Public Attributes

int | nWorkWeekMask
This structure member represents week working days using XTPCalendarWeekDay enumeration.
int | nFirstDayOfTheWeek
This member shows the first day of the week using XTPCalendarWeekDay enum.
COleDateTime | dtWorkDayStartTime
This member contains work day start time.
COleDateTime | dtWorkDayEndTime
This member contains work day end time.
COleDateTime | dtScaleMinTime
The scale minimum time.
COleDateTime | dtScaleMaxTime
The scale maximum time.
BOOL | bEnableInPlaceEditEventSubject_ByF2
Set TRUE to enable in-place edit event subject by F2, FALSE otherwise.
BOOL | bEnableInPlaceEditEventSubject_ByMouseClick
Set TRUE to enable in-place edit event subject by Mouse Click, FALSE otherwise.
BOOL | bEnableInPlaceEditEventSubject_ByTab
Set TRUE to enable in-place edit event subject by TAB, FALSE otherwise.
BOOL | bEnableInPlaceEditEventSubject_AfterEventResize
Set TRUE to enable in-place edit event subject after event resize, FALSE otherwise.
BOOL | bEnableInPlaceCreateEvent
Set TRUE to enable in-place event creation, FALSE otherwise.
BOOL | bUseOutlookFontGlyphs
Set TRUE to use 'MS Outlook' font to display Glyps, otherwise bitmaps are used.
BOOL | bDayView_AutoResetBusyFlag
If TRUE - 'Busy' event status will be automatically set to 'Free' when moving event from hours area to all day events area and vice versa.
int | nDayView_ScaleInterval
DayView scale interval in minutes.
CString | strDayView_ScaleLabel
Stores main time scale label (day view)

CString | strDayView_AdditionalScaleLabel
Stores secondary time scale label (day view)
BOOL | bDayView_ScaleLeftVisible
TRUE to show time scale on the left

BOOL | bDayView_ScaleRightVisible
TRUE to show time scale on the right

BOOL | bDayView_AdditionalScaleLeftVisible
TRUE when additional time scale on the left is visible in day view.
BOOL | bDayView_AdditionalScaleRightVisible
TRUE when additional time scale on the right is visible in day view.
BOOL | bDayView_DrawNowLineOverAppoinment
TRUE to show time line over appointments.
TIME_ZONE_INFORMATION | tziDayView_AdditionalScaleTimeZone
Stores time zone information for the secondary time scale.
int | nDayView_CurrentTimeMarkVisible
A set of flags which define when Current Time Mark on the timescale is visible.
BOOL | bDayView_TimeScaleShowMinutes
If TRUE - minutes will be shown on time scale.
BOOL | bShowAllDayExpandButton
TRUE to show all day header expand buttons when needed.
BOOL | bMonthView_CompressWeekendDays
TRUE when compressing weekend days in month view, FALSE otherwise.
BOOL | bMonthView_ShowEndDate
TRUE when showing event end date in month view, FALSE otherwise.
BOOL | bMonthView_ShowTimeAsClocks
TRUE when showing event time as graphical clocks in month view, FALSE otherwise.
BOOL | bMonthView_HideTimes
TRUE to suppress drawing time in month view event, FALSE otherwise.
BOOL | bWeekView_ShowEndDate
TRUE when showing event end date in week view, FALSE otherwise.
BOOL | bWeekView_ShowTimeAsClocks
TRUE when showing event time as graphical clocks in week view, FALSE otherwise.
BOOL | bTimeLineCompact
TRUE when showing event compatized or not (like Entry List in Outlook)
BOOL | bTimeLineFocused
TRUE when showing focused view of timeline.
DWORD | dwAdditionalOptions
Additional calendar options.
BOOL | bHatchAllDayViewEventsBkgnd
flag to enable-disable all day events cell background color fill or hatch
BOOL | bShowCategoryIcons
flag to show-hide additional categories icons in event view for day-multicolumn week views
BOOL | bEnableAddNewTooltip
TRUE when "add new appointment" tooltips appears, FALSE otherwise.
CString | strTooltipAddNewText
Text for "add new appointment" tooltip.
BOOL | bEnablePrevNextEventButtons
TRUE when "Prev/Next Appointment" buttons are enabled, FALSE otherwise.

Protected Attributes

CXTPCalendarData * m_pDataProvider
A stored pointer to the owner data provider.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

Structure contains all calendar options.

This structure contains all options which could be changed by the user for CXTPCalendarControl.

See also
CXTPCalendarControl
XTPCalendarWeekDay
XTPCalendarWeekDay

Constructor & Destructor Documentation

◆ ~CXTPCalendarOptions()

virtual ~CXTPCalendarOptions ( )
virtual

Default Destructor.

Handles all deallocation.

Member Function Documentation

◆ DoPropExchange()

void DoPropExchange ( CXTPPropExchange * pPX )

This method reads data from or writes data to storage.

Parameters
pPX A CXTPPropExchange object to serialize to or from.

For the save case the options data from will be saved to archive. For the load a new data will be loaded from the specified archive and set to members.

See also
CXTPPropExchange

◆ GetCurrentTimeZoneInfo()

CXTPCalendarTimeZonePtr GetCurrentTimeZoneInfo ( )

Get full information about the current time zone.

Retrieve additional information from the registry.

Returns
A smart pointer to CXTPCalendarTimeZone object.
See also
GetTimeZoneInformation()
CXTPCalendarTimeZone::GetTimeZoneInfo()

◆ SetDataProvider()

void SetDataProvider ( CXTPCalendarData * pDataProvider )

This member function sets the custom data provider for the control.

Parameters
pDataProvider Pointer to the custom data provider object.

Call this member function to set the custom data provider that is currently used by this calendar control. Note that custom data provider must be a descendant of CXTPCalendarData.

See also
CXTPCalendarData overview
GetDataProvider

Member Data Documentation

◆ bDayView_AutoResetBusyFlag

BOOL bDayView_AutoResetBusyFlag

If TRUE - 'Busy' event status will be automatically set to 'Free' when moving event from hours area to all day events area and vice versa.

If FALSE - status flag is not changed automatically.

◆ bDayView_TimeScaleShowMinutes

BOOL bDayView_TimeScaleShowMinutes

If TRUE - minutes will be shown on time scale.

FALSE by default.

◆ nDayView_CurrentTimeMarkVisible

int nDayView_CurrentTimeMarkVisible

A set of flags which define when Current Time Mark on the timescale is visible.

See Also XTPCalendarCurrentTimeMarkFlags. By default it is xtpCalendarCurrentTimeMarkVisibleForToday.

◆ nWorkWeekMask

int nWorkWeekMask

This structure member represents week working days using XTPCalendarWeekDay enumeration.

Each day is represented by the corresponding binary bit.

◆ strTooltipAddNewText

CString strTooltipAddNewText

Text for "add new appointment" tooltip.

Default is: "Click to add appointment"

The documentation for this class was generated from the following file:
  • XTPCalendarOptions.h


Toolkit Pro: CXTPCalendarPageSetupDialog Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPCalendarPageSetupDialog Class Reference

Customized Calendar control page setup dialog. More...

Public Member Functions

CXTPCalendarPageSetupDialog (CXTPCalendarControlViewPrintOptions *pOptions, DWORD dwFlags=PSD_MARGINS|PSD_INWININIINTLMEASURE, CWnd *pParentWnd=NULL)
Class constructor.
virtual ~CXTPCalendarPageSetupDialog ()
Default class constructor, handles members cleanup.

Protected Member Functions

CString | FormatFontName (const LOGFONT &lfFont)
Converts a font name to a human readable string.
virtual BOOL | OnInitDialog ()
Dialog-box initialization.
virtual void | OnOK ()
Called when the user clicks the OK button (the button with an ID of IDOK).
afx_msg void | OnBnClickedPrintDateHeader ()
Called when the user clicks the Print Date Header check box.
afx_msg void | OnBnClickedDateHeaderFont ()
Called when the user clicks the Date Header font button.

Protected Attributes

CXTPCalendarControlViewPrintOptions * | m_pOptions
Pointer to associated print options object.
CComboBox | m_ctrlPrintFromCmb
A combo for choosing CXTPCalendarControlViewPrintOptions::m_dtPrintFrom value.
CComboBox | m_ctrlPrintToCmb
A combo for choosing CXTPCalendarControlViewPrintOptions::m_dtPrintTo value.
CButton | m_ctrlPrintFromTo
A check box for editing CXTPCalendarControlViewPrintOptions::m_bPrintFromToExactly value.
CButton | m_ctrlPrintDateHeader
A check box for editing CXTPCalendarControlViewPrintOptions::m_bPrintDateHeader value.
CStatic | m_ctrlDateHeaderFontLabel
A label for displaying CXTPCalendarControlViewPrintOptions::m_lfDateHeaderFont caption.
CEdit | m_ctrlDateHeaderFont
A label for displaying CXTPCalendarControlViewPrintOptions::m_lfDateHeaderFont value.
CButton | m_ctrlDateHeaderFontButton
A button for choosing CXTPCalendarControlViewPrintOptions::m_lfDateHeaderFont value.
CButton | m_ctrlBlackWhitePrinting
A check box for editing CXTPCalendarControlViewPrintOptions::m_bBlackWhitePrinting value.
CButton | m_ctrl3SmallCal
A check box for setting CXTPCalendarControlViewPrintOptions::m_b3SmallCal value.
LOGFONT | m_lfDateHeader
a date time picker for begin date in month view printing
CDateTimeCtrl | m_ctrlMonthViewPrintFrom
a date time picker for end date in month view printing
CDateTimeCtrl | m_ctrlMonthViewPrintTo
a check box which swithes between use or not multimonth printing option
CButton | m_ctrlMonthViewPrintRange
Date header font temporary storage.
CEdit | m_ctrlHeaderFormat
An edit for header format string.
CEdit | m_ctrlFooterFormat
An edit for footer format string.
CButton | m_ctrlHeaderFormatBtn
A button to show header specifiers menu.
CButton | m_ctrlFooterFormatBtn
A button to show footer specifiers menu.

Detailed Description

Customized Calendar control page setup dialog.

Use this class when you want to allow users to customize printing options for the Calendar control.

This class enhances standard MFC page setup dialog, which encapsulates the services provided by the Windows common OLE Page Setup dialog box with additional support for setting and modifying print margins. This class is designed to take the place of the Print Setup dialog box.

See also
CXTPCalendarControlViewPrintOptions overview
CPageSetupDialog overview

Constructor & Destructor Documentation

◆ CXTPCalendarPageSetupDialog()

CXTPCalendarPageSetupDialog | ( | CXTPCalendarControlViewPrintOptions * | pOptions,
 |  | DWORD | dwFlags = PSD_MARGINS|PSD_INWININIINTLMEASURE,
 |  | CWnd * | pParentWnd = NULL )

Class constructor.

Parameters
pOptions | A pointer to an associated CXTPCalendarControlViewPrintOptions object for storing user's interaction results.
dwFlags | One or more flags you can use to customize the settings of the dialog box. The values can be combined using the bitwise-OR operator. For more details see CPageSetupDialog::CPageSetupDialog.
pParentWnd | Pointer to the dialog box's parent or owner.

Use the DoModal function to display the dialog box.

See also
CPageSetupDialog::CPageSetupDialog()

Member Function Documentation

◆ FormatFontName()

CString FormatFontName ( const LOGFONT & lfFont )
protected

Converts a font name to a human readable string.

Parameters
lfFont A reference to a font.
Returns
A string describing a provided font.

◆ OnBnClickedDateHeaderFont()

afx_msg void OnBnClickedDateHeaderFont ( )
protected

Called when the user clicks the Date Header font button.

Shows standard Font dialog in order to customize a Date Header font.

◆ OnBnClickedPrintDateHeader()

afx_msg void OnBnClickedPrintDateHeader ( )
protected

Called when the user clicks the Print Date Header check box.

Enables/disables all controls related to configuring a Date Header.

◆ OnInitDialog()

virtual BOOL OnInitDialog ( )
protectedvirtual

Dialog-box initialization.

Returns
FALSE because it has explicitly set the input focus to one of the controls in the dialog box.
See also
CPageSetupDialog::OnInitDialog()

◆ OnOK()

virtual void OnOK ( )
protectedvirtual

Called when the user clicks the OK button (the button with an ID of IDOK).

Saves all values into m_pOptions structure.

See also
CPageSetupDialog::OnOK()
The documentation for this class was generated from the following file:
  • XTPCalendarControlView.h


Toolkit Pro: CXTPCalendarPaintManager Class Reference

Public Member Functions | Public Attributes | Protected Types | Protected Member Functions | Protected Attributes | List of all members
CXTPCalendarPaintManager Class Reference

Utility class, handles most of the drawing activities. More...

Inheritance diagram for CXTPCalendarPaintManager:
[legend]

Public Member Functions

BEGIN_VIEW_PART (ControlPart, XTPCalendarViewPart) virtual void RefreshMetrics()
Paint manager's ControlPart is used as parent for the other parts of the control.
END_VIEW_PART (ControlPart) BEGIN_VIEW_PART(DayViewTimeScaleHeaderPart
This paint manager part is used to draw the time scale header, 'Now' line, and the expand signs for the Day View.
virtual void | RefreshMetrics ()
Performs refreshing of graphical related parameters from system settings.
virtual void | OnDraw (CDC *pDC, CXTPCalendarDayView *pView, CRect rc, CString strText)
This member function is used to draw the time scale header.
virtual void | DrawNowLine (CDC *pDC, CXTPCalendarDayView *pView, CRect rc, int y, BOOL bDrawBk=FALSE)
This member function is used to draw the 'Now' line.
virtual void | DrawNowLine (CDC *pDC, CXTPCalendarDayView *pView, CXTPCalendarDayViewTimeScale *pScale, CRect rc, int y, BOOL bDrawBk=FALSE)
This member function is used to draw the 'Now' line.
virtual void | DrawExpandSigns (CDC *pDC, CXTPCalendarDayView *pView, const CRect &rcTSHours)
This member function is used to draw expand signs.
END_VIEW_PART (DayViewTimeScaleHeaderPart) BEGIN_VIEW_PART(DayViewTimeScaleCellPart
This paint manager part is used to draw time scale time cells for the Day View.
virtual void | RefreshMetrics ()
This member function is used to refresh the graphical related parameters using system settings.
void | AdjustTimeFont (CDC *pDC, CRect rcCell)
This member function is used to adjust the time text font size.
void | CalcWidth (CDC *pDC, const CString &strHour, const CString &strMin, int nHourHeight, int &nWidth)
This member function is used to adjust the time text font size.
virtual void | DrawHourCell (CDC *pDC, CRect rc, CString strText, BOOL bFillBackground=TRUE, BOOL bCurrentTime=FALSE)
This member function is used to draw background of the time scale header.
virtual void | DrawBigHourCell (CDC *pDC, CRect rc, CString strHour, CString strMin, int nRowPerHour, BOOL bFillBackground=TRUE, BOOL bCurrentTime=FALSE)
This member function is used to draw the big hour cell.
END_VIEW_PART (DayViewTimeScaleCellPart) BEGIN_VIEW_PART(DayViewCellPart
This paint manager part is used as the base class for the parts which draw different kinds of no all-day-cells (work/non-work) for the Day View.
virtual void | RefreshMetrics ()
This member function is used to refresh the graphical related parameters using system settings.
virtual void | GetParams (CXTPCalendarDayViewGroup *pViewGroup, XTP_CALENDAR_DAYVIEWCELL_PARAMS *rCellParams)
This member function is used to fill out cell parameters with default values.
virtual void | OnDraw (CDC *pDC, CXTPCalendarDayViewGroup *pViewGroup, CRect rc, const XTP_CALENDAR_DAYVIEWCELL_PARAMS &cellParams)
This member function is used to draw the day view with no all-day-cells.
END_VIEW_PART (DayViewCellPart) BEGIN_VIEW_PART(DayViewWorkCellPart
This paint manager part is used to draw a day view that contains no all day work time cells.
virtual DayViewCellPart void | RefreshMetrics ()
This member function is used to perform the refreshing of graphical related parameters from system settings.
END_VIEW_PART (DayViewWorkCellPart) BEGIN_VIEW_PART(DayViewNonworkCellPart
This paint manager part is used to draw "no all day non-work" time cells for the Day View.
virtual DayViewCellPart void | RefreshMetrics ()
This member function is used to perform refreshing of graphical related parameters from system settings.
END_VIEW_PART (DayViewNonworkCellPart) BEGIN_VIEW_PART(DayMonthViewHeaderPart
This paint manager part is used to draw days headers for the Day View.
virtual void | RefreshMetrics ()
This member function is used to perform refreshing of graphical related parameters from system settings.
END_VIEW_PART (DayMonthViewHeaderPart) BEGIN_VIEW_PART(DayViewHeaderPart
This paint manager part is used to draw days headers for the Day View.
virtual DayMonthViewHeaderPart void | OnDraw (CDC *pDC, CXTPCalendarDayViewDay *pViewDay, CRect rc, CString strText)
This member function is used to draw the day header.
END_VIEW_PART (DayViewHeaderPart) BEGIN_VIEW_PART(DayViewGroupHeaderPart
This paint manager part is used to draw Groups headers for the Day View.
virtual DayMonthViewHeaderPart void | OnDraw (CDC *pDC, CXTPCalendarDayViewGroup *pViewGroup, CRect rc, CString strText)
This member function is used to draw the day header.
END_VIEW_PART (DayViewGroupHeaderPart) BEGIN_VIEW_PART(DayViewAllDayEventsPart
This paint manager part is used to draw all day events area for the Day View.
virtual XTPCalendarViewPart void | RefreshMetrics ()
This member functions is used to perform refreshing of graphical related parameters from system settings.
virtual void | OnDraw (CDC *pDC, CXTPCalendarDayViewGroup *pViewGroup, CRect rc, BOOL bSelected)
This member function is used to draw the all-day events area.
END_VIEW_PART (DayViewAllDayEventsPart) BEGIN_VIEW_PART(DayViewAllDayEventScrollIconsPart
This paint manager part is used to draw all day events scroll buttons if there are too many all day events.
virtual XTPCalendarViewPart void | OnDraw (CDC *pDC, CXTPCalendarDayViewGroup *pViewGroup, BOOL bDrawUp, BOOL bDrawDown, const CRect &rcIconUp, const CRect &rcIconDown, BOOL bHighlightUp, BOOL bHighlightDown)
This member function is used to draw scroll icons in all day events area.
END_VIEW_PART (DayViewAllDayEventScrollIconsPart) BEGIN_VIEW_PART(DayViewEventPart
This paint manager part is used to draw events for the Day View.
virtual XTPCalendarViewPart void | RefreshMetrics ()
Performs refreshing of graphical related parameters from system settings.
virtual void | OnDraw (CDC *pDC, CXTPCalendarDayViewEvent *pViewEvent)
This member function is used to draw an event.
END_VIEW_PART (DayViewEventPart) BEGIN_VIEW_PART(MonthViewGridPart
This paint manager part is used to draw days grid and to fill days cells background for the Month View.
virtual void | RefreshMetrics ()
Performs refreshing of graphical related parameters from system settings.
virtual void | OnDrawGrid (CDC *pDC, CXTPCalendarMonthView *pMonthView)
This member function is used to draw the days grid and to fill the days cells background.
END_VIEW_PART (MonthViewGridPart) BEGIN_VIEW_PART(MonthViewHeaderPart
This paint manager part is used to draw week days headers for the Month View.
virtual DayMonthViewHeaderPart void | OnDraw (CDC *pDC, CXTPCalendarMonthView *pMonthView, CRect rc, int nCollIndex, CString strText)
This member function is used to draw the week day header.
END_VIEW_PART (MonthViewHeaderPart) BEGIN_VIEW_PART(MonthViewEventPart
This paint manager part is used to draw events and day dates for the Month View.
virtual void | RefreshMetrics ()
Performs refreshing of graphical related parameters from system settings.
virtual void | OnDrawEvent (CDC *pDC, CXTPCalendarMonthViewEvent *pViewEvent)
This member function is used to draw an event.
virtual void | OnDrawDayDate (CDC *pDC, CRect rc, BOOL bToday, BOOL bSelected, BOOL bFirstMonthDay, CString strText)
This member function is used to draw the week day header.
END_VIEW_PART (MonthViewEventPart) BEGIN_VIEW_PART(WeekViewPart
This paint manager part is used to draw week days grid and headers for the Week View.
virtual void | RefreshMetrics ()
Performs refreshing of graphical related parameters from system settings.
virtual void | OnDraw (CDC *pDC, CXTPCalendarWeekView *pWeekView)
This member function is used to draw an event.
virtual void | DrawDayHeader (CDC *pDC, CRect rcDay, int nHeaderHeight, CString strHeader, BOOL bIsCurrent=FALSE, BOOL bIsSelected=FALSE)
This member function is used to draw the day header.
END_VIEW_PART (WeekViewPart) BEGIN_VIEW_PART(WeekViewEventPart
This paint manager part is used to draw events for the Week View.
virtual void | RefreshMetrics ()
This member function is used to perform refreshing of graphical related parameters from system settings.
virtual void | OnDraw (CDC *pDC, CXTPCalendarWeekViewEvent *pWeekViewEvent)
This member function is used to draw the specified event.
virtual void | DrawBorder (CDC *pDC, CRect rcView, CXTPCalendarWeekViewEvent *pWeekViewEvent)
This member functions is used to draw the event border.
virtual int | DrawTimes (CDC *pDC, CXTPCalendarWeekViewEvent *pWeekViewEvent)
This member function is used to draw the event's times texts or icons.
virtual void | DrawSubj (CDC *pDC, CXTPCalendarWeekViewEvent *pWeekViewEvent)
This member function is used to draw the event subject.
END_VIEW_PART (WeekViewEventPart) BEGIN_VIEW_PART(TimeLineViewTimeScalePart_Day
This paint manager part is used to draw time scale for the Time Line view.
virtual void | DrawGroup (CDC *pDC, const CRect &rcRect, CXTPCalendarTimeLineViewGroup *pGroup)
Call this function to draw the time line view group.
virtual CSize | CalcEventSize (CDC *c, CXTPCalendarTimeLineViewEvent *pViewEvent)
Call this function to calculate the time line view event size.
virtual void | DrawEvent (CDC *pDC, const CRect &rcEvents, CXTPCalendarTimeLineViewEvent *pViewEvent)
Call this function to draw the event.
virtual void | RefreshMetrics ()
Call this function to refresh the metrics.
virtual void | _Init ()
Call this function to do the initializations.
virtual | ~CTimeLineViewPart ()
Destroys the CTimeLineViewPart object, does the cleanup.
CXTPCalendarPaintManager ()
Default paint manager constructor.
virtual | ~CXTPCalendarPaintManager ()
Default paint manager destructor.
virtual void | UpdateEventLabelsDefaultColors ()
This member function is called to update event label default colors.
virtual void | UpdateEventCategoriesDefaultColors ()
This member function is called to update event category default colors.
virtual XTPCalendarTheme | GetPaintTheme () const
This member function is used to obtain the current paint theme.
virtual void | SetPaintTheme (XTPCalendarTheme ePaintTheme)
This member function is used to set the current paint theme.
virtual void | RefreshMetrics ()
This member function is used to initialize all drawing defaults.
virtual void | UpdateGlyphs ()
Initializes Calendar images.
virtual COLORREF | GetEventBackColor (CXTPCalendarEvent *pEvent, COLORREF crDefault)
Call this member function to get the background color for the specified event.
virtual void | DrawLine (CDC *pDC, int xPos, int yPos, int cx, int cy)
This member function is used to draw an arbitrary line.
virtual void | DrawHorizontalLine (CDC *pDC, int xPos, int yPos, int cx)
This member function is used to draw a Horizontal line.
virtual void | DrawVerticalLine (CDC *pDC, int xPos, int yPos, int cy)
This member function is used to draw a Vertical line.
virtual int | DrawClock (CDC *pDC, COleDateTime dtClockTime, CRect rcView, COLORREF clrBackground, XTPCalendarClockAlignFlags cafAlign)
This member function is used to draw the time as a clock.
virtual int | DrawBitmap (CImageList *pImageList, CDC *pDC, CRect rcView, int iIcon, UINT uFlags=0)
This member function is used to draw a bitmap from the provided ImageList.
virtual int | DrawBitmap (UINT nIDResource, CDC *pDC, CRect rcBitmap)
This member function is used to draw the bitmap using its resource id.
virtual int | DrawIconChar (CDC *pDC, CRect rc, TCHAR ch)
This member function is used to draw the Glyph symbol using special font.
virtual const CSize | GetExpandSignSize ()
This member function is used to obtain the horizontal and vertical size of the Expand Sign bitmap.
virtual CSize | GetClockSize ()
This member function is used to obtain the horizontal and vertical size of the Clock.
virtual void | SetControl (CXTPCalendarControl *pControl)
This member function is used to set the CXTPCalendarControl object for the CXTPCalendarPaintManager.
virtual void | DrawShadow (CDC *pDC, const CRect &rcRect)
Call this member function to draw the shadow regions around the rectangle.
virtual int | DrawIcons (CDC *pDC, CXTPCalendarViewEvent *pViewEvent)
Call this member function to draw icons corresponding to the event state.
virtual void | DrawHeader (CDC *pDC, CRect &rcHeader, BOOL bIsSelected, BOOL bIsCurrent)
This member function is used to draw the Header.
virtual void | DrawHeader (CDC *pDC, CRect &rcHeader, BOOL bIsSelected, BOOL bIsCurrent, const CXTPPaintManagerColorGradient &grclr, COLORREF clrUnderLineHdr)
This member function is used to draw the Header.
virtual void | DrawBusyStatus (CDC *pDC, CRect &rcRect, int eBusyStatus)
This member function is used to fill the area using the corresponding busy color or pattern.
virtual void | DrawBusyStatus (CDC *pDC, CRgn &rgnBusy, int eBusyStatus)
This member function is used to fill the area using the corresponding busy color or pattern.
void | EnableTheme (BOOL bEnableTheme)
This member function is used to enable a new theme.
BOOL | IsThemeEnabled ()
This member function is used to obtain the status of the theme.
XTPCurrentSystemTheme GetCurrentSystemTheme ()
Call this member function to determine the current Windows XP theme that is in use.
void | SetBusyStatusBrush (int nBusyStatus, CBrush *pBrush, BOOL bAutodeleteBrush)
Call this member function to set custom brush to draw event busy status.
CBrush * | GetBusyStatusBrush (int nBusyStatus)
Call this member function to get a brush to draw event busy status.
DWORD | GetAskItemTextFlags () const
This member function returns a set of flags which define calendar items to send an XTP_NC_CALENDAR_GETITEMTEXT notification.
void | SetAskItemTextFlags (DWORD dwFlags)
This member function is used to set flags which define calendar items to send an XTP_NC_CALENDAR_GETITEMTEXT notification.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Public Attributes

DayViewTimeScaleHeaderPart CXTPCalendarViewPartFontValue | m_fntTimeText
Time text font.
int | m_nHourWidth
Width of hour part of the text in pixels.
int | m_nMinWidth
Width of minutes (am/pm) part of the text in pixels.
BOOL | m_bShowMinutes
Show minutes in TS when '60 Minutes' is selected.
XTPCalendarViewPart CXTPPaintManagerColor | m_clrBackgroundSlave
Background secondary color.
CXTPPaintManagerColor | m_clrShadow
Cell background color.
CXTPPaintManagerColor | m_clrHour
Cell border color.
XTPCalendarViewPart CXTPPaintManagerColor | m_clrBackground2
Second background color which is used to fill days background.
XTPCalendarViewPart COLORREF | m_clrTextHighLightColor
Text color for the selected event.
COLORREF | m_clrMultiDayEventFrameColor
Multi-day event frame color.
COLORREF | m_clrClassicUnderline
Underline color for today day.
CXTPPaintManagerColorGradient | m_grclrClassicSelDay
Gradient color for today day.
COLORREF | m_clrTextNormalColor
Text color for the day header and some other elements.
COLORREF | m_clrHeaderBottomLine
Text color for the day header bottom line.
XTPCalendarTimeLineViewPart CXTPPaintManagerColor | m_clrEventBar
Event bar color.
CXTPPaintManagerColor m_clrEventBarLine
Event bar line color.
CXTPPaintManagerColor | m_clrEventBorderLine
Event border line color.
CXTPPaintManagerColor | m_clrTimeScaleBackground
Time scale background color.
CXTPPaintManagerColor | m_clrTimeScaleHightlite
Time scale highlight color.
CXTPPaintManagerColor m_clrTimeScaleText
The time scale text color.
CXTPPaintManagerColor | m_clrSelectedBackground
The selected background color.
CXTPPaintManagerColor m_clrSelectedText
The selected text color.
CXTPPaintManagerColor | m_clrBackground
The background color.
CXTPPaintManagerColor | m_clrText
The text color.
CXTPPaintManagerColor | m_clrWeekendBackground
Time scale weekend background color.
CXTPPaintManagerColor m_clrButtonFace
Stores standard Button Face color.
CXTPPaintManagerColor | m_clrButtonFaceText
Stores standard color to display text.
CXTPPaintManagerColor m_clrWindow
Stores standard windows color.
CXTPPaintManagerColor m_clrWindowText
Stores standard color to display window text.
CXTPPaintManagerColor m_clr3DShadow
Stores standard color to display shadow items.
CXTPPaintManagerColor | m_clrHighlight
Stores standard color to display highlighted items.
CXTPPaintManagerColor | m_clrBorders [4]
Stores border line color, left = 0, top = 1, right = 2, bottom = 3.
CXTPPaintManagerColorGradient | m_grclrToday
Gradient color of today's header.
CUIntArray | m_arStartCol
hold start column in each virtual page
CUIntArray | m_arStartRow
hold start row in each virtual page

int | m_PrintPageWidth
Print page width.

Protected Types

enum XTPEnumExpandSigns { idxExpandSignUp = 0 , idxExpandSignDown = 1 }
Enumerates types of expand signs drawn on a day view. More...
enum XTPEnumEventGlyphs {
idxMeeting = 0 , idxPrivate = 1 , idxRecurrenceException = 2 , idxRecurrenceOccurrence = 3 ,
idxReminder = 4
}
Enumerates types of event glyphs. More...

Protected Member Functions

CXTPCalendarViewPart * | AddViewPart (CXTPCalendarViewPart *pPart)
Call this member function to add the specified ViewPart object to the parts list.
CXTPCalendarViewPartBrushValue * | _GetAtGrow_BusyStatusBrushValue (int eBusyStatus, BOOL bGrow)
Returns drawing brush value for a specific busy status.
virtual void | InitBusyStatusDefaultColors ()
Set default colors/patterns to fill Busy Status area.

Protected Attributes

CList< CXTPCalendarViewPart *, CXTPCalendarViewPart * > | m_lstViewParts
Collection to store ViewParts objects.
CXTPImageManager * | m_pExpandSigns
Stores standard Expand Signs icons.
CXTPImageManager * m_pGlyphs
Stores standard glyphs for displaying events.
CFont * | m_pGlyphsFont
Stores standard glyphs font for displaying events.
CBitmap | m_bmpElsewherePattern
Stores standard bitmap pattern to draw Elsewhere event busy status.
CXTPBrush | m_xtpBrushElsewhere
Stores standard brush to draw Elsewhere event busy status.
CBitmap | m_bmpTentativePattern
Stores standard bitmap pattern to draw Tentative event busy status.
CXTPBrush | m_xtpBrushTentative
Stores standard brush to draw Tentative event busy status.
CXTPCalendarTypedPtrAutoDeleteArray< CPtrArray, CXTPCalendarViewPartBrushValue * > | m_arBusyStatusBrushes
Stores customizable brush values to draw Event Busy Status in the Day View.
CSize | m_szClockRect
Stores dimensions for a rectangle used to display the time as a clock glyph.
CXTPCalendarControl * | m_pControl
Stores a pointer to a CXTPCalendarControl object.
BOOL | m_bEnableTheme
True to enable Luna theme.
COLORREF | m_clrUnderLineHdr
Color of header's underline.
XTPCurrentSystemTheme | m_CurrSystemTheme
Current theme flag.
XTPCalendarTheme | m_nPaintTheme
Store the Paint Theme;.
DWORD | m_dwAskItemTextFlags
Store flag set to send XTP_NC_CALENDAR_GETITEMTEXT notification.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

Utility class, handles most of the drawing activities.

It stores all settings, needed by control to perform drawing operations : fonts, colors, styles for all others classes of control. It also implements all functions for drawing typical graphical primitives, functions that directly work with device context. Can be overridden to provide another look and feel for the control. Thus, you have an easy way to change the "skin" of your control. Just provide your own implementation of CXTPCalendarPaintManager and don't touch the functionality of any of the other control classes.

 Create a CXTPCalendarPaintManager by calling its constructor.
 Furthermore, you can call get and set functions to change
 settings as needed.

Member Enumeration Documentation

◆ XTPEnumEventGlyphs

enum XTPEnumEventGlyphs
protected

Enumerates types of event glyphs.

Enumerator
idxMeeting | Meeting glyph.
idxPrivate | Private glyph.
idxRecurrenceException | Recurrence exception glyph.
idxRecurrenceOccurrence | Recurrence occurrence glyph.
idxReminder | Reminder glyph.

◆ XTPEnumExpandSigns

enum XTPEnumExpandSigns
protected

Enumerates types of expand signs drawn on a day view.

Enumerator
idxExpandSignUp | Expand sign: arrow up
idxExpandSignDown | Expand sign: arrow down

Constructor & Destructor Documentation

◆ CXTPCalendarPaintManager()

CXTPCalendarPaintManager ( )

Default paint manager constructor.

Handles initial initialization.

See also
RefreshMetrics()

◆ ~CXTPCalendarPaintManager()

virtual ~CXTPCalendarPaintManager ( )
virtual

Default paint manager destructor.

Handles member items deallocation.

Member Function Documentation

◆ _GetAtGrow_BusyStatusBrushValue()

CXTPCalendarViewPartBrushValue * _GetAtGrow_BusyStatusBrushValue | ( | int | eBusyStatus,
 |  | BOOL | bGrow )
 protected

Returns drawing brush value for a specific busy status.

Parameters
eBusyStatus | Busy status enumeration.
bGrow | Append a new brush value if needed or not.
Returns
Pointer to CXTPCalendarViewPartBrushValue array member.
See also
XTPCalendarEventBusyStatus

◆ AddViewPart()

CXTPCalendarViewPart * AddViewPart ( CXTPCalendarViewPart * pPart )
protected

Call this member function to add the specified ViewPart object to the parts list.

Parameters
pPart Pointer to a 'View Part' object.
Returns
Pointer to a 'View Part' object.

◆ AdjustTimeFont()

void AdjustTimeFont | ( | CDC * | pDC,
 |  | CRect | rcCell )

This member function is used to adjust the time text font size.

Parameters
pDC | Pointer to a valid device context.
rcCell | A CRect object that contains the time scale hour cell bounding rectangle.

◆ BEGIN_VIEW_PART()

BEGIN_VIEW_PART | ( | ControlPart | ,
 |  | XTPCalendarViewPart | )

Paint manager's ControlPart is used as parent for the other parts of the control.

Performs refreshing of graphical related parameters from system settings.

◆ CalcEventSize()

virtual CSize CalcEventSize | ( | CDC * | c,
 |  | CXTPCalendarTimeLineViewEvent * | pViewEvent )
 virtual

Call this function to calculate the time line view event size.

Parameters
pViewEvent | The event view.
c | Points to a valid device context
Returns
A CSize object denoting the size of the time line view event.

◆ CalcWidth()

void CalcWidth | ( | CDC * | pDC,
 |  | const CString & | strHour,
 |  | const CString & | strMin,
 |  | int | nHourHeight,
 |  | int & | nWidth )

This member function is used to adjust the time text font size.

Parameters
pDC | Pointer to a valid device context.
strHour | A CString object that contains the Hour text.
strMin | A CString object that contains the Minutes text.
nHourHeight | A hour big text height.
nWidth | An int that returns the width of time scale with provided hour and minutes texts.

◆ DrawBigHourCell()

virtual void DrawBigHourCell | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | CString | strHour,
 |  | CString | strMin,
 |  | int | nRowPerHour,
 |  | BOOL | bFillBackground = TRUE,
 |  | BOOL | bCurrentTime = FALSE )
 virtual

This member function is used to draw the big hour cell.

Parameters
pDC | Pointer to a valid device context.
rc | A CRect object that contains the time scale hour cell bounding rectangle.
strHour | A CString object that contains the Hour text.
strMin | A CString object that contains the Minutes text.
nRowPerHour | An int that contains the Rows per hour.
bFillBackground | A BOOL. If TRUE, then fill the background before drawing. If FALSE, then do not fill the background before drawing.
bCurrentTime | TRUE to display current time.

◆ DrawBitmap() [1/2]

virtual int DrawBitmap | ( | CImageList * | pImageList,
 |  | CDC * | pDC,
 |  | CRect | rcView,
 |  | int | iIcon,
 |  | UINT | uFlags = 0 )
 virtual

This member function is used to draw a bitmap from the provided ImageList.

Parameters
pImageList | A CImageList pointer to the ImageList.
pDC | Pointer to a valid device context.
rcView | A CRect object that contains the bounding rectangle coordinates to draw the bitmap.
iIcon | An int that contains the image index.
uFlags | Additional drawing options. Should be 0 or DT_VCENTER.

Use this function to draw a bitmap in the view's bounding rectangle. If the provided bounding rectangle is too small, then the bitmap is not drawn.

Returns
An int that contains the width of the drawn bitmap.

◆ DrawBitmap() [2/2]

virtual int DrawBitmap | ( | UINT | nIDResource,
 |  | CDC * | pDC,
 |  | CRect | rcBitmap )
 virtual

This member function is used to draw the bitmap using its resource id.

Parameters
nIDResource | A UINT that contains the integer resource id of the bitmap.
pDC | Pointer to a valid device context.
rcBitmap | A CRect that contains the bounding rectangle coordinates used to draw the bitmap.

Use this function to draw a bitmap in the view's bounding rectangle. If the provided bounding rectangle is too small, then the bitmap is not drawn.

Returns
An int that contains the width of the drawn bitmap.

◆ DrawBorder()

virtual void DrawBorder | ( | CDC * | pDC,
 |  | CRect | rcView,
 |  | CXTPCalendarWeekViewEvent * | pWeekViewEvent )
 virtual

This member functions is used to draw the event border.

Parameters
pDC | Pointer to a valid device context.
pWeekViewEvent | A CXTPCalendarWeekViewEvent pointer to the Week Event View object.
rcView | A CRect that contains the day view's bounding rectangle coordinates.

◆ DrawBusyStatus() [1/2]

virtual void DrawBusyStatus | ( | CDC * | pDC,
 |  | CRect & | rcRect,
 |  | int | eBusyStatus )
 virtual

This member function is used to fill the area using the corresponding busy color or pattern.

Parameters
pDC | Pointer to a valid device context.
rcRect | A CRect object that contains the rectangle coordinates used to fill the corresponding busy color or pattern.
eBusyStatus | An int that contains the Event Busy Status value from enum XTPCalendarEventBusyStatus.
See also
XTPCalendarEventBusyStatus
CRgn

◆ DrawBusyStatus() [2/2]

virtual void DrawBusyStatus | ( | CDC * | pDC,
 |  | CRgn & | rgnBusy,
 |  | int | eBusyStatus )
 virtual

This member function is used to fill the area using the corresponding busy color or pattern.

Parameters
pDC | Pointer to a valid device context.
eBusyStatus | An int that contains the Event Busy Status value from enum XTPCalendarEventBusyStatus.
rgnBusy | A CRgn that contains the region area used to fill with the corresponding busy color or pattern and draw the region border using m_clrWindowText color.
See also
XTPCalendarEventBusyStatus
CRgn

◆ DrawClock()

virtual int DrawClock | ( | CDC * | pDC,
 |  | COleDateTime | dtClockTime,
 |  | CRect | rcView,
 |  | COLORREF | clrBackground,
 |  | XTPCalendarClockAlignFlags | cafAlign )
 virtual

This member function is used to draw the time as a clock.

Parameters
pDC | Pointer to a valid device context.
dtClockTime | A COleDateTime object that contains the time to draw.
rcView | A CRect object that contains the bounding rectangle coordinates of where the clock is drawn.
clrBackground | A COLORREF object that contains the background color of the clock.
cafAlign | A XTPCalendarClockAlignFlags alignment flag, appropriate values are determined by enum XTPCalendarClockAlignFlags.

This member function is used anywhere a time clock is needed.

Returns
Returns the size (width) of the square where clock icon was drawn inside. Zero when clock icon wasn't successfully drawn.
See also
XTPCalendarClockAlignFlags

◆ DrawDayHeader()

virtual void DrawDayHeader | ( | CDC * | pDC,
 |  | CRect | rcDay,
 |  | int | nHeaderHeight,
 |  | CString | strHeader,
 |  | BOOL | bIsCurrent = FALSE,
 |  | BOOL | bIsSelected = FALSE )
 virtual

This member function is used to draw the day header.

Parameters
pDC | Pointer to a valid device context.
rcDay | A CRect object that contains the day's bounding rectangle coordinates.
nHeaderHeight | An int that contains the header height value.
strHeader | A CString object that contains the header text.
bIsCurrent | A BOOL. TRUE if this is the current day for today. FALSE otherwise.
bIsSelected | A BOOL. TRUE if the day is selected. FALSE otherwise.

◆ DrawEvent()

virtual void DrawEvent | ( | CDC * | pDC,
 |  | const CRect & | rcEvents,
 |  | CXTPCalendarTimeLineViewEvent * | pViewEvent )
 virtual

Call this function to draw the event.

Parameters
pDC | The device context.
rcEvents | The rectangular bounds.
pViewEvent | The event view.

◆ DrawExpandSigns()

virtual void DrawExpandSigns | ( | CDC * | pDC,
 |  | CXTPCalendarDayView * | pView,
 |  | const CRect & | rcTSHours )
 virtual

This member function is used to draw expand signs.

Parameters
pDC | Pointer to a valid device context.
pView | A CXTPCalendarDayView pointer to the Day View object.
rcTSHours | A CRect that contains the Time scale hours rectangle.

◆ DrawGroup()

virtual void DrawGroup | ( | CDC * | pDC,
 |  | const CRect & | rcRect,
 |  | CXTPCalendarTimeLineViewGroup * | pGroup )
 virtual

Call this function to draw the time line view group.

Parameters
pDC | The device context.
rcRect | Rectangular drawing area.
pGroup | The calendar time line view group.

◆ DrawHeader() [1/2]

virtual void DrawHeader | ( | CDC * | pDC,
 |  | CRect & | rcHeader,
 |  | BOOL | bIsSelected,
 |  | BOOL | bIsCurrent )
 virtual

This member function is used to draw the Header.

Parameters
pDC | Pointer to a valid device context.
rcHeader | A CRect that contains the bounding rectangle coordinates used to draw the header.
bIsSelected | A BOOL. TRUE if the header is selected. FALSE otherwise.
bIsCurrent | A BOOL. TRUE if the header represents the current time. FALSE otherwise.

◆ DrawHeader() [2/2]

virtual void DrawHeader | ( | CDC * | pDC,
 |  | CRect & | rcHeader,
 |  | BOOL | bIsSelected,
 |  | BOOL | bIsCurrent,
 |  | const CXTPPaintManagerColorGradient & | grclr,
 |  | COLORREF | clrUnderLineHdr )
 virtual

This member function is used to draw the Header.

Parameters
pDC | Pointer to a valid device context.
rcHeader | A CRect that contains the bounding rectangle coordinates used to draw the header.
bIsSelected | A BOOL. TRUE if the header is selected. FALSE otherwise.
bIsCurrent | A BOOL. TRUE if the header represents the current time. FALSE otherwise.
grclr | A CXTPPaintManagerColorGradient object that specifies the Gradient color.
clrUnderLineHdr | A COLORREF object that specifies the color of header's underline.

Reimplemented in CXTPCalendarOffice2013Theme.

◆ DrawHorizontalLine()

virtual void DrawHorizontalLine | ( | CDC * | pDC,
 |  | int | xPos,
 |  | int | yPos,
 |  | int | cx )
 virtual

This member function is used to draw a Horizontal line.

Parameters
pDC | Pointer to a valid device context.
xPos | An int that contains the Horizontal coordinate of the beginning of the line.
yPos | An int that contains the Vertical coordinate of the beginning of the line.
cx | An int that contains the Length of the line.

This member function is used anywhere a simple horizontal line is needed.

◆ DrawHourCell()

virtual void DrawHourCell | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | CString | strText,
 |  | BOOL | bFillBackground = TRUE,
 |  | BOOL | bCurrentTime = FALSE )
 virtual

This member function is used to draw background of the time scale header.

This member function is used to draw the hour cell.

Parameters
pDC | Pointer to a valid device context.
rc | A CRect object that contains the time scale hour cell bounding rectangle.
strText | A CString object that contains the time text.
bFillBackground | A BOOL. If TRUE, then fill the background before drawing. If FALSE, then do not fill the background before drawing.
bCurrentTime | TRUE to display current time.

◆ DrawIconChar()

virtual int DrawIconChar | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | TCHAR | ch )
 virtual

This member function is used to draw the Glyph symbol using special font.

Parameters
pDC | Pointer to a valid device context.
rc | A CRect that contains the bounding rectangle coordinates used to draw the symbol.
ch | A char symbol (from the font) to draw.

Use this function to draw the Glyph symbol in the center of the provided bounding rectangle.

Returns
An int that contains the width of the drawn symbol.

◆ DrawIcons()

virtual int DrawIcons | ( | CDC * | pDC,
 |  | CXTPCalendarViewEvent * | pViewEvent )
 virtual

Call this member function to draw icons corresponding to the event state.

Parameters
pDC | Pointer to a valid device context.
pViewEvent | A CXTPCalendarViewEvent pointer to the event view object.
Returns
Draws icons

◆ DrawLine()

virtual void DrawLine | ( | CDC * | pDC,
 |  | int | xPos,
 |  | int | yPos,
 |  | int | cx,
 |  | int | cy )
 virtual

This member function is used to draw an arbitrary line.

Parameters
pDC | Pointer to a valid device context.
xPos | An int that contains the Horizontal coordinate of the beginning of line.
yPos | An int that contains the Vertical coordinate of the beginning of line.
cx | An int that contains the Horizontal coordinate of the end of line.
cy | An int that contains the Vertical coordinate of the end of line.

This member function is used anywhere a simple arbitrary line is needed.

◆ DrawNowLine() [1/2]

virtual void DrawNowLine | ( | CDC * | pDC,
 |  | CXTPCalendarDayView * | pView,
 |  | CRect | rc,
 |  | int | y,
 |  | BOOL | bDrawBk = FALSE )
 virtual

This member function is used to draw the 'Now' line.

Parameters
pDC | Pointer to a valid device context.
pView | A CXTPCalendarDayView pointer to the Day View object.
rc | A CRect that contains the Time scale bounding rectangle.
y | An int that contains the 'Now' line position.
bDrawBk | If FALSE, then draw only the line. If TRUE, then draw the line and the gradient fill.

◆ DrawNowLine() [2/2]

virtual void DrawNowLine | ( | CDC * | pDC,
 |  | CXTPCalendarDayView * | pView,
 |  | CXTPCalendarDayViewTimeScale * | pScale,
 |  | CRect | rc,
 |  | int | y,
 |  | BOOL | bDrawBk = FALSE )
 virtual

This member function is used to draw the 'Now' line.

Parameters
pDC | Pointer to a valid device context.
pView | A CXTPCalendarDayView pointer to the Day View object.
pScale | A CXTPCalendarDayViewTimeScale pointer to the Day View object.
rc | A CRect that contains the Time scale bounding rectangle.
y | An int that contains the 'Now' line position.
bDrawBk | If FALSE, then draw only the line. If TRUE, then draw the line and the gradient fill.

◆ DrawShadow()

virtual void DrawShadow | ( | CDC * | pDC,
 |  | const CRect & | rcRect )
 virtual

Call this member function to draw the shadow regions around the rectangle.

Parameters
pDC | Pointer to a valid device context.
rcRect | A CRect that contains the rectangle coordinates of where to draw the shadow regions.

◆ DrawSubj()

virtual void DrawSubj | ( | CDC * | pDC,
 |  | CXTPCalendarWeekViewEvent * | pWeekViewEvent )
 virtual

This member function is used to draw the event subject.

Parameters
pDC | Pointer to a valid device context.
pWeekViewEvent | A CXTPCalendarWeekViewEvent pointer to the Week Event View object.

◆ DrawTimes()

virtual int DrawTimes | ( | CDC * | pDC,
 |  | CXTPCalendarWeekViewEvent * | pWeekViewEvent )
 virtual

This member function is used to draw the event's times texts or icons.

Parameters
pDC | Pointer to a valid device context.
pWeekViewEvent | A CXTPCalendarWeekViewEvent pointer to the Week Event View object.
Returns
Draws times texts or icons

◆ DrawVerticalLine()

virtual void DrawVerticalLine | ( | CDC * | pDC,
 |  | int | xPos,
 |  | int | yPos,
 |  | int | cy )
 virtual

This member function is used to draw a Vertical line.

Parameters
pDC | Pointer to a valid device context.
xPos | An int that contains the Horizontal coordinates of the beginning of the line.
yPos | An int that contains the Vertical coordinates of the beginning of the line.
cy | An int that contains the Length of the line.

This member function is used anywhere a simple vertical line is needed.

◆ EnableTheme()

AFX_INLINE void EnableTheme ( BOOL bEnableTheme )

This member function is used to enable a new theme.

Parameters
bEnableTheme A BOOL. TRUE if the theme enabled. FALSE otherwise.

◆ END_VIEW_PART() [1/3]

END_VIEW_PART ( ControlPart )

This paint manager part is used to draw the time scale header, 'Now' line, and the expand signs for the Day View.

Day View related drawing.

◆ END_VIEW_PART() [2/3]

END_VIEW_PART ( DayViewEventPart )

This paint manager part is used to draw days grid and to fill days cells background for the Month View.

Month View related drawing

◆ END_VIEW_PART() [3/3]

END_VIEW_PART ( MonthViewEventPart )

This paint manager part is used to draw week days grid and headers for the Week View.

Week view related drawing

◆ GetAskItemTextFlags()

AFX_INLINE DWORD GetAskItemTextFlags ( ) const

This member function returns a set of flags which define calendar items to send an XTP_NC_CALENDAR_GETITEMTEXT notification.

Returns
Set of flags from enums XTPCalendarGetItemText, XTPCalendarGetItemTextEx.
See also
XTPCalendarGetItemText
XTPCalendarGetItemTextEx
SetAskItemTextFlags
CXTPCalendarControl::GetAskItemTextFlags
CXTPCalendarTheme::GetAskItemTextFlags
CXTPCalendarTheme::SetAskItemTextFlags
XTP_NC_CALENDAR_GETITEMTEXT

◆ GetBusyStatusBrush()

CBrush * GetBusyStatusBrush ( int nBusyStatus )

Call this member function to get a brush to draw event busy status.

Parameters
nBusyStatus Busy status value.
Returns
Pointer to a brush object.

◆ GetClockSize()

AFX_INLINE CSize GetClockSize ( )
virtual

This member function is used to obtain the horizontal and vertical size of the Clock.

Returns
A CSize object that contains the bitmap size.

◆ GetCurrentSystemTheme()

AFX_INLINE XTPCurrentSystemTheme GetCurrentSystemTheme ( )

Call this member function to determine the current Windows XP theme that is in use.

Returns
A XTPCurrentSystemTheme enumeration that represents the current Windows theme in use, can be one of the following values: xtpSystemThemeUnknown - No known theme in use, or Windows Classic theme. xtpSystemThemeBlue - Blue theme in use. xtpSystemThemeOlive - Olive theme in use. xtpSystemThemeSilver - Silver theme in use.

◆ GetEventBackColor()

virtual COLORREF GetEventBackColor | ( | CXTPCalendarEvent * | pEvent,
 |  | COLORREF | crDefault )
 virtual

Call this member function to get the background color for the specified event.

Parameters
pEvent | Points to the Calendar event.
crDefault | RGB value representing the default color to be returned if one could not be found.
Returns
An RGB value representing the event background color if successful, otherwise returns the value specified by crDefault.

◆ GetExpandSignSize()

virtual const CSize GetExpandSignSize ( )
virtual

This member function is used to obtain the horizontal and vertical size of the Expand Sign bitmap.

Returns
A CSize object that contains the bitmap size.

◆ GetPaintTheme()

AFX_INLINE XTPCalendarTheme GetPaintTheme ( ) const
virtual

This member function is used to obtain the current paint theme.

Returns
A paint theme ID from enum XTPCalendarTheme.

◆ GetParams()

virtual void GetParams | ( | CXTPCalendarDayViewGroup * | pViewGroup,
 |  | XTP_CALENDAR_DAYVIEWCELL_PARAMS * | rCellParams )
 virtual

This member function is used to fill out cell parameters with default values.

Parameters
pViewGroup | [in] A CXTPCalendarDayViewGroup pointer to the Day View Group object.
rCellParams | [in, out] A XTP_CALENDAR_DAYVIEWCELL_PARAMS object that contains the cell's parameters.

◆ IsThemeEnabled()

AFX_INLINE BOOL IsThemeEnabled ( )

This member function is used to obtain the status of the theme.

Returns
A BOOL. TRUE if theme is enabled. FALSE otherwise.

◆ OnDraw() [1/10]

virtual void OnDraw | ( | CDC * | pDC,
 |  | CXTPCalendarDayView * | pView,
 |  | CRect | rc,
 |  | CString | strText )
 virtual

This member function is used to draw the time scale header.

Parameters
pDC | Pointer to a valid device context.
pView | A CXTPCalendarDayView pointer that contains the Day View object.
rc | The time scale header's bounding rectangle.
strText | A CString object that contains the header text.

◆ OnDraw() [2/10]

virtual DayMonthViewHeaderPart void OnDraw | ( | CDC * | pDC,
 |  | CXTPCalendarDayViewDay * | pViewDay,
 |  | CRect | rc,
 |  | CString | strText )
 virtual

This member function is used to draw the day header.

Parameters
pDC | Pointer to a valid device context.
pViewDay | A CXTPCalendarDayViewDay pointer to the Day View object.
rc | A CRect object that contains the coordinates of the Header's bounding rectangle.
strText | A CString object that contains the Header text.

◆ OnDraw() [3/10]

virtual void OnDraw | ( | CDC * | pDC,
 |  | CXTPCalendarDayViewEvent * | pViewEvent )
 virtual

This member function is used to draw an event.

Parameters
pDC | Pointer to a valid device context.
pViewEvent | A CXTPCalendarDayViewEvent pointer to the Day Event View object.

◆ OnDraw() [4/10]

virtual XTPCalendarViewPart void OnDraw | ( | CDC * | pDC,
 |  | CXTPCalendarDayViewGroup * | pViewGroup,
 |  | BOOL | bDrawUp,
 |  | BOOL | bDrawDown,
 |  | const CRect & | rcIconUp,
 |  | const CRect & | rcIconDown,
 |  | BOOL | bHighlightUp,
 |  | BOOL | bHighlightDown )
 virtual

This member function is used to draw scroll icons in all day events area.

Parameters
pDC | Pointer to a valid device context.
pViewGroup | A CXTPCalendarDayViewGroup pointer to the Group object.
bDrawUp | selects show-hide up scroll icon
bDrawDown | selects show-hide down scroll icon
rcIconUp | scroll up icon area
rcIconDown | scroll down icon area
bHighlightUp | selects if draw the icon in highlighted color
bHighlightDown | selects if draw the icon in highlighted color

◆ OnDraw() [5/10]

virtual void OnDraw | ( | CDC * | pDC,
 |  | CXTPCalendarDayViewGroup * | pViewGroup,
 |  | CRect | rc,
 |  | BOOL | bSelected )
 virtual

This member function is used to draw the all-day events area.

Parameters
pDC | Pointer to a valid device context.
pViewGroup | A CXTPCalendarDayViewGroup pointer to the Group object.
rc | A CRect object that contains the all-day events area bounding rectangle coordinates.
bSelected | A BOOL. TRUE if the draw area is selected. FALSE otherwise.

◆ OnDraw() [6/10]

virtual void OnDraw | ( | CDC * | pDC,
 |  | CXTPCalendarDayViewGroup * | pViewGroup,
 |  | CRect | rc,
 |  | const XTP_CALENDAR_DAYVIEWCELL_PARAMS & | cellParams )
 virtual

This member function is used to draw the day view with no all-day-cells.

Parameters
pDC | Pointer to a valid device context.
pViewGroup | A CXTPCalendarDayViewGroup pointer to the Day View Group object.
rc | A CRect object that contains the cell's bounding rectangle.
cellParams | A XTP_CALENDAR_DAYVIEWCELL_PARAMS object that contains the cell's parameters.

◆ OnDraw() [7/10]

virtual DayMonthViewHeaderPart void OnDraw | ( | CDC * | pDC,
 |  | CXTPCalendarDayViewGroup * | pViewGroup,
 |  | CRect | rc,
 |  | CString | strText )
 virtual

This member function is used to draw the day header.

Parameters
pDC | Pointer to a valid device context.
pViewGroup | A CXTPCalendarDayViewGroup pointer to the Group object.
rc | A CRect object that contains the coordinates of the Header's bounding rectangle.
strText | A CString object that contains the Header text.

◆ OnDraw() [8/10]

virtual DayMonthViewHeaderPart void OnDraw | ( | CDC * | pDC,
 |  | CXTPCalendarMonthView * | pMonthView,
 |  | CRect | rc,
 |  | int | nCollIndex,
 |  | CString | strText )
 virtual

This member function is used to draw the week day header.

Parameters
pDC | Pointer to a valid device context.
pMonthView | A CXTPCalendarMonthView pointer to the Month View object.
rc | A CRect object that contains the Week Day header's bounding rectangle coordinates.
nCollIndex | An int that contains the Week Day column index in the grid.
strText | A CString object that contains the formatted Week Day name.

◆ OnDraw() [9/10]

virtual void OnDraw | ( | CDC * | pDC,
 |  | CXTPCalendarWeekView * | pWeekView )
 virtual

This member function is used to draw an event.

Parameters
pDC | Pointer to a valid device context.
pWeekView | A CXTPCalendarWeekView pointer to the Week Event View object.

◆ OnDraw() [10/10]

virtual void OnDraw | ( | CDC * | pDC,
 |  | CXTPCalendarWeekViewEvent * | pWeekViewEvent )
 virtual

This member function is used to draw the specified event.

Parameters
pDC | Pointer to a valid device context.
pWeekViewEvent | A CXTPCalendarWeekViewEvent pointer to the Week Event View object.

◆ OnDrawDayDate()

virtual void OnDrawDayDate | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | BOOL | bToday,
 |  | BOOL | bSelected,
 |  | BOOL | bFirstMonthDay,
 |  | CString | strText )
 virtual

This member function is used to draw the week day header.

Parameters
pDC | Pointer to a valid device context.
rc | A CRect object that contains the Day header's bounding rectangle coordinates.
bToday | TRUE for today day, otherwise FALSE.
bSelected | Is day selected.
strText | Formatted day date string.
bFirstMonthDay | TRUE to display the first month day.

◆ OnDrawEvent()

virtual void OnDrawEvent | ( | CDC * | pDC,
 |  | CXTPCalendarMonthViewEvent * | pViewEvent )
 virtual

This member function is used to draw an event.

Parameters
pDC | Pointer to a valid device context.
pViewEvent | A CXTPCalendarMonthViewEvent pointer to the Month Event View object.

◆ OnDrawGrid()

virtual void OnDrawGrid | ( | CDC * | pDC,
 |  | CXTPCalendarMonthView * | pMonthView )
 virtual

This member function is used to draw the days grid and to fill the days cells background.

Parameters
pDC | Pointer to a valid device context.
pMonthView | A CXTPCalendarMonthView pointer to the Month View object.

◆ RefreshMetrics()

virtual void RefreshMetrics ( )
virtual

This member function is used to initialize all drawing defaults.

Initializes all drawings defaults (fonts, colors, etc.). most of defaults are system defaults.

Reimplemented in CXTPCalendarOffice2003Theme, CXTPCalendarOffice2013Theme, and CXTPCalendarResourceTheme.

◆ SetAskItemTextFlags()

AFX_INLINE void SetAskItemTextFlags ( DWORD dwFlags )

This member function is used to set flags which define calendar items to send an XTP_NC_CALENDAR_GETITEMTEXT notification.

Parameters
dwFlags Set of flags from enums XTPCalendarGetItemText, XTPCalendarGetItemTextEx.
See also
XTPCalendarGetItemText
XTPCalendarGetItemTextEx
GetAskItemTextFlags
CXTPCalendarControl::GetAskItemTextFlags
CXTPCalendarTheme::GetAskItemTextFlags
CXTPCalendarTheme::SetAskItemTextFlags
XTP_NC_CALENDAR_GETITEMTEXT

◆ SetBusyStatusBrush()

void SetBusyStatusBrush | ( | int | nBusyStatus,
 |  | CBrush * | pBrush,
 |  | BOOL | bAutodeleteBrush )

Call this member function to set custom brush to draw event busy status.

Parameters
nBusyStatus | Busy status value.
pBrush | Pointer to a brush object.
bAutodeleteBrush | This parameter indicates should be a brush object deleted when destroy or other brush is set. If TRUE - brush object will be deleted automatically.

Example:

 m_wndCalendar.GetPaintManager()->SetBusyStatusBrush(
 xtpCalendarBusyStatusFree, new CBrush(RGB(240, 255, 250)), TRUE);

 m_wndCalendar.GetPaintManager()->SetBusyStatusBrush(
 xtpCalendarBusyStatusTentative, new CBrush(RGB(240, 120, 250)), TRUE);

 m_wndCalendar.GetPaintManager()->SetBusyStatusBrush(
 100, new CBrush(RGB(240, 120, 250)), TRUE);

◆ SetControl()

virtual void SetControl ( CXTPCalendarControl * pControl )
virtual

This member function is used to set the CXTPCalendarControl object for the CXTPCalendarPaintManager.

Parameters
pControl A CXTPCalendarControl pointer to the CXTPCalendarControl object.

◆ SetPaintTheme()

AFX_INLINE void SetPaintTheme ( XTPCalendarTheme ePaintTheme )
virtual

This member function is used to set the current paint theme.

Parameters
ePaintTheme A paint theme ID from enum XTPCalendarTheme.

◆ UpdateGlyphs()

virtual void UpdateGlyphs ( )
virtual

Initializes Calendar images.

Called by the paint manager to initialize images used by the Calendar control.

Reimplemented in CXTPCalendarOffice2013Theme.

Member Data Documentation

◆ m_clr3DShadow

CXTPPaintManagerColor m_clr3DShadow

Stores standard color to display shadow items.

◆ m_clrButtonFace

CXTPPaintManagerColor m_clrButtonFace

Stores standard Button Face color.

◆ m_clrClassicUnderline

COLORREF m_clrClassicUnderline

Underline color for today day.

◆ m_clrEventBar

XTPCalendarTimeLineViewPart CXTPPaintManagerColor m_clrEventBar

Event bar color.

◆ m_clrEventBarLine

CXTPPaintManagerColor m_clrEventBarLine

Event bar line color.

◆ m_clrHeaderBottomLine

COLORREF m_clrHeaderBottomLine

Text color for the day header bottom line.

◆ m_clrMultiDayEventFrameColor

COLORREF m_clrMultiDayEventFrameColor

Multi-day event frame color.

◆ m_clrSelectedText

CXTPPaintManagerColor m_clrSelectedText

The selected text color.

◆ m_clrTextHighLightColor

XTPCalendarViewPart COLORREF m_clrTextHighLightColor

Text color for the selected event.

Text color for the selected day header.

◆ m_clrTextNormalColor

COLORREF m_clrTextNormalColor

Text color for the day header and some other elements.

Text color for the event.

◆ m_clrTimeScaleText

CXTPPaintManagerColor m_clrTimeScaleText

The time scale text color.

◆ m_clrWindow

CXTPPaintManagerColor m_clrWindow

Stores standard windows color.

◆ m_clrWindowText

CXTPPaintManagerColor m_clrWindowText

Stores standard color to display window text.

◆ m_pGlyphs

CXTPImageManager* m_pGlyphs
protected

Stores standard glyphs for displaying events.

Used when glyphs font is not installed.

◆ m_PrintPageWidth

int m_PrintPageWidth

Print page width.

The documentation for this class was generated from the following file:
  • XTPCalendarPaintManager.h


Toolkit Pro: CXTPCalendarPtrCollectionT< _TObject > Class Template Reference

Public Member Functions | Protected Types | Protected Attributes | List of all members
CXTPCalendarPtrCollectionT< _TObject > Class Template Reference

This class represents a simple array collection of objects. More...

Inheritance diagram for CXTPCalendarPtrCollectionT< _TObject >:
[legend]

Public Member Functions

CXTPCalendarPtrCollectionT ()
Default collection constructor.
virtual | ~CXTPCalendarPtrCollectionT ()
Default collection destructor.
virtual int | GetCount () const
This member function is used to obtain the number of elements in the collection.
virtual void | Add (_TObject *pNewElement)
This member function adds a new element to the end of the array.
virtual void | Add (_TObject *pNewElement, BOOL bWithAddRef)
This member function adds a new element to the end of the array.
virtual void | SetAt (int nIndex, _TObject *pElement)
This member function is used to set a new element to the position specified in the nIndex parameter.
virtual int | Find (const _TObject *pElement) const
This member function finds an element index in the collection using its pointer.
virtual void | InsertAt (int nIndex, _TObject *pElement)
This member function is used to insert a new element at the position specified in the nIndex parameter.
virtual void | Append (const CXTPCalendarPtrCollectionT< _TObject > *pElementsArray)
This member function is used to add a new elements to the end of the array.
virtual void | SetSize (int nNewSize)
This member function is used to change the array size.
virtual _TObject * | GetAt (int nIndex) const
This member function returns an element at the specified numeric index.
virtual _TObject * | GetAt (int nIndex, BOOL bWithAddRef) const
This member function returns an element at the specified numeric index.
virtual void | RemoveAt (int nIndex)
This member function removes an element at the specified index from the array.
virtual void | Remove (_TObject *pElement)
This member function finds an element using its pointer and removes it from the array.
virtual void | RemoveAll ()
This member function is used to remove all of the elements from the array.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Types

typedef CXTPSmartPtrInternalT< _TObject > TObjectPtr
Smart pointer type for stored objects.

Protected Attributes

CArray< TObjectPtr, TObjectPtr & > m_arElements
Objects storage.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

template<class _TObject>
class CXTPCalendarPtrCollectionT< _TObject >

This class represents a simple array collection of objects.

Array indexes always start at position 0.

 As with a C array, the access time for indexed element of this
 array is constant and is independent of the array size.
See also
overview
CArray overview

Constructor & Destructor Documentation

◆ CXTPCalendarPtrCollectionT()

template<class _TObject >
AFX_INLINE CXTPCalendarPtrCollectionT ( )

Default collection constructor.

See also
~CXTPCalendarPtrCollectionT()

◆ ~CXTPCalendarPtrCollectionT()

template<class _TObject >
AFX_INLINE ~CXTPCalendarPtrCollectionT ( )
virtual

Default collection destructor.

Handles member items deallocation. Decreases reference of all stored objects.

See also
RemoveAll()

Member Function Documentation

◆ Add() [1/2]

template<class _TObject >
AFX_INLINE void Add ( _TObject * pNewElement )
virtual

This member function adds a new element to the end of the array.

Parameters
pNewElement A pointer to a _TObjectThe object. Element to add to the array.

Use this method to add the specified pointer to the end of the events collection. Reference to the added object is increased.

Example:

CXTPCalendarPtrCollectionT<CXTPCalendarEvent> arList;
CXTPCalendarEventPtr ptrEvent1 = new CXTPCalendarEvent()

// Add() will call InernalAddRef()
arList.Add(ptrEvent1);

// Add() will not call InernalAddRef()
arList.Add(new CXTPCalendarEvent(), FALSE);

// GetAt() will call InernalAddRef()
CXTPCalendarEventPtr ptrEvent0 = arList.GetAt(0);

// GetAt() will not call InernalAddRef()
CXTPCalendarEvent* pEvent1 = arList.GetAt(1, FALSE);

_ASSERTE(2 == arList.GetCount());

//RemoveAll() will call InernalRelease() for all objects
arList.RemoveAll();

_ASSERTE(0 == arList.GetCount());

Version 2

CXTPCalendarPtrCollectionT<CXTPCalendarEvent> arList;
CXTPCalendarEventPtr ptrEvent1 = new CXTPCalendarEvent()

// Add() will call InernalAddRef()
arList.Add(ptrEvent1);

// Add() will not call InernalAddRef()
arList.Add(new CXTPCalendarEvent(), FALSE);

// GetAt() will call InernalAddRef()
CXTPCalendarEventPtr ptrEvent0 = arList.GetAt(0);

// GetAt() will not call InernalAddRef()
CXTPCalendarEvent* pEvent1 = arList.GetAt(1, FALSE);

_ASSERTE(2 == arList.GetCount());

//RemoveAll() will call InernalRelease() for all objects
arList.RemoveAll();

_ASSERTE(0 == arList.GetCount());
See also
CXTPCalendarPtrCollectionT overview
GetAt
RemoveAll
GetCount

◆ Add() [2/2]

template<class _TObject >
AFX_INLINE void Add | ( | _TObject * | pNewElement,
 |  | BOOL | bWithAddRef )
 virtual

This member function adds a new element to the end of the array.

Parameters
pNewElement | A pointer to a _TObjectThe object. Element to add to the array.
bWithAddRef | A BOOL. If this parameter is TRUE then InternalAddRef() is called for pNewElement, otherwise it is not called.

Use this method to add the specified pointer to the end of the events collection. Reference to the added object is increased.

Example:

CXTPCalendarPtrCollectionT<CXTPCalendarEvent> arList;
CXTPCalendarEventPtr ptrEvent1 = new CXTPCalendarEvent()

// Add() will call InernalAddRef()
arList.Add(ptrEvent1);

// Add() will not call InernalAddRef()
arList.Add(new CXTPCalendarEvent(), FALSE);

// GetAt() will call InernalAddRef()
CXTPCalendarEventPtr ptrEvent0 = arList.GetAt(0);

// GetAt() will not call InernalAddRef()
CXTPCalendarEvent* pEvent1 = arList.GetAt(1, FALSE);

_ASSERTE(2 == arList.GetCount());

//RemoveAll() will call InernalRelease() for all objects
arList.RemoveAll();

_ASSERTE(0 == arList.GetCount());

Version 2

CXTPCalendarPtrCollectionT<CXTPCalendarEvent> arList;
CXTPCalendarEventPtr ptrEvent1 = new CXTPCalendarEvent()

// Add() will call InernalAddRef()
arList.Add(ptrEvent1);

// Add() will not call InernalAddRef()
arList.Add(new CXTPCalendarEvent(), FALSE);

// GetAt() will call InernalAddRef()
CXTPCalendarEventPtr ptrEvent0 = arList.GetAt(0);

// GetAt() will not call InernalAddRef()
CXTPCalendarEvent* pEvent1 = arList.GetAt(1, FALSE);

_ASSERTE(2 == arList.GetCount());

//RemoveAll() will call InernalRelease() for all objects
arList.RemoveAll();

_ASSERTE(0 == arList.GetCount());
See also
CXTPCalendarPtrCollectionT overview
GetAt
RemoveAll
GetCount

◆ Append()

template<class _TObject >
AFX_INLINE void Append ( const CXTPCalendarPtrCollectionT< _TObject > * pElementsArray )
virtual

This member function is used to add a new elements to the end of the array.

Parameters
pElementsArray A pointer to an array of _TObject objects. A pointer to the collection to add to the array.

Use this method to add the elements from the specified array to the end of the collection. Reference to the new object is increased.

Example:

CXTPCalendarPtrCollectionT<CXTPCalendarEvent> arList1;
CXTPCalendarPtrCollectionT<CXTPCalendarEvent> arList2;
...
arList1.Append(&arList2);
See also
GetAt
Add
InsertAt
SetAt

◆ Find()

template<class _TObject >
AFX_INLINE int Find ( const _TObject * pElement ) const
virtual

This member function finds an element index in the collection using its pointer.

Parameters
pElement A pointer to a _TObject object. The element to find in the array.
Returns
-1 if element is not found, otherwise an integer index that is greater than or equal to 0 and less than the value returned by GetCount. The specified element currently at this index.

Reimplemented in CXTPCalendarReminders.

◆ GetAt() [1/2]

template<class _TObject >
AFX_INLINE _TObject * GetAt ( int nIndex ) const
virtual

This member function returns an element at the specified numeric index.

Reference to the returned object is increased.

Parameters
nIndex An integer index that is greater than or equal to 0 and less than the value returned by GetCount.

Returns the array element at the specified index.

Example: See the example for the Add() method.

Returns
A pointer to a _TObject object. The element currently at this index.

◆ GetAt() [2/2]

template<class _TObject >
AFX_INLINE _TObject * GetAt | ( | int | nIndex,
 |  | BOOL | bWithAddRef ) const
 virtual

This member function returns an element at the specified numeric index.

Reference to the returned object is increased.

Parameters
nIndex | An integer index that is greater than or equal to 0 and less than the value returned by GetCount.
bWithAddRef | A BOOL. If this parameter is TRUE then InternalAddRef() is called for the returned object, otherwise it is not called.

Returns the array element at the specified index.

Example: See the example for the Add() method.

Returns
A pointer to a _TObject object. The element currently at this index.

◆ GetCount()

template<class _TObject >
AFX_INLINE int GetCount ( ) const
virtual

This member function is used to obtain the number of elements in the collection.

Call this method to retrieve the number of elements in the array. Because indexes are zero-based, the size is 1 greater than the largest index.

Example: See example for CXTPCalendarEvents::Add method.

Returns
The number of items in the collection.

◆ InsertAt()

template<class _TObject >
AFX_INLINE void InsertAt | ( | int | nIndex,
 |  | _TObject * | pElement )
 virtual

This member function is used to insert a new element at the position specified in the nIndex parameter.

Parameters
nIndex | An integer index that is greater than or equal to 0 and less than the value returned by GetCount().
pElement | A pointer to a _TObject object. The element to add to the array.

Use this method to insert the specified element t the position specified in the nIndex parameter. Reference to the new object is increased.

Example:

CXTPCalendarPtrCollectionT<CXTPCalendarEvent> arList;
CXTPCalendarEventPtr ptrEvent1 = new CXTPCalendarEvent()

arList.Add(ptrEvent1);
arList.InsertAt(0, new CXTPCalendarEvent());
See also
GetAt
Add
InsertAt

◆ Remove()

template<class _TObject >
AFX_INLINE void Remove ( _TObject * pElement )
virtual

This member function finds an element using its pointer and removes it from the array.

Parameters
pElement A pointer to a _TObject object. The element to find in the array.

Removes the pointer from this array and releases the instance of the stored object.

See also
RemoveAt()
RemoveAll()

◆ RemoveAll()

template<class _TObject >
AFX_INLINE void RemoveAll ( )
virtual

This member function is used to remove all of the elements from the array.

Removes all of the pointers from this array and releases instances of all stored objects.

Example: See example for CXTPCalendarEvents::Add method.

See also
CXTPCalendarEvents overview

◆ RemoveAt()

template<class _TObject >
AFX_INLINE void RemoveAt ( int nIndex )
virtual

This member function removes an element at the specified index from the array.

Parameters
nIndex An integer index that is greater than or equal to 0 and less than the value returned by GetCount().

Removes the pointer from this array and releases the instance of the stored object.

◆ SetAt()

template<class _TObject >
AFX_INLINE void SetAt | ( | int | nIndex,
 |  | _TObject * | pElement )
 virtual

This member function is used to set a new element to the position specified in the nIndex parameter.

Parameters
nIndex | An integer index that is greater than or equal to 0 and less than the value returned by GetCount.
pElement | A pointer to a _TObject object. The element to add to the array.

Use this method to set the specified element to the position specified in nIndex parameter. Reference to the previous object is decreased. Reference to the new object is increased.

Example:

CXTPCalendarPtrCollectionT<CXTPCalendarEvent> arList;
CXTPCalendarEventPtr ptrEvent1 = new CXTPCalendarEvent()

arList.Add(ptrEvent1);
arList.SetAt(0, new CXTPCalendarEvent());
See also
GetAt
Add
InsertAt

◆ SetSize()

template<class _TObject >
AFX_INLINE void SetSize ( int nNewSize )
virtual

This member function is used to change the array size.

Parameters
nNewSize An int that contains the new array size.

Argument nNewSize contains the new array size (number of elements). Must be greater than or equal to 0.

The documentation for this class was generated from the following file:
  • XTPCalendarPtrCollectionT.h


Toolkit Pro: CXTPCalendarRecurrencePattern Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPCalendarRecurrencePattern Class Reference

This class represents a recurrence pattern and stores data to build a schedule for recurrence events. More...

Inheritance diagram for CXTPCalendarRecurrencePattern:
[legend]

Public Member Functions

virtual | ~CXTPCalendarRecurrencePattern ()
Default class destructor.
virtual DWORD | GetPatternID () const
Returns a unique pattern ID.
virtual COleDateTime | GetStartTime () const
Call this member function to get start date-time.
virtual void | SetStartTime (COleDateTime dtStart)
This member function is used to set the new start date and time.
virtual int | GetDurationMinutes () const
Call this member function to get a duration in minutes.
virtual void | SetDurationMinutes (int nMinutes)
This member function is used to set the new duration value.
virtual COleDateTimeSpan | GetDuration () const
Call this member function to get the duration as a COleDateTimeSpan object.
virtual COleDateTime | GetStartOccurrenceTime (COleDateTime dtOccurrenceStartDate) const
Call this member function to get the occurrence start date-time.
virtual COleDateTime | GetEndOccurrenceTime (COleDateTime dtOccurrenceStartDate) const
Call this member function to get the occurrence end date-time by its start time.
virtual int | GetRecurrenceType () const
This member function is used to obtain the value of the recurrence type flag.
virtual const XTP_CALENDAR_RECURRENCE_OPTIONS & | GetRecurrenceOptions () const
This member function is used to obtain a set of recurrence options.
virtual void | SetRecurrenceOptions (const XTP_CALENDAR_RECURRENCE_OPTIONS &Options)
This member function is used to set the recurrence options.
virtual COleDateTime | GetPatternStartDate () const
Call this member function to obtain the start pattern DateTime.
virtual void | SetPatternStartDate (COleDateTime dtStart)
This member function is used to set the new start pattern date and time.
virtual COleDateTime | GetPatternEndDate () const
Call this member function to obtain the end pattern DateTime.
virtual void | SetPatternEndDate (COleDateTime dtEnd)
This member function is used to set the new end pattern date.
virtual int | GetEndAfterOccurrences () const
This member function is used to obtain the "End After occurrences" recurrence pattern option.
virtual void | SetEndAfterOccurrences (int nOccurrences)
This member function is used to set the "End After occurrences" recurrence pattern option.
virtual BOOL | IsNoEndDate () const
This member function is used to determine if the pattern has an end date.
virtual void | SetNoEndDate ()
This member function is used to reset the pattern end date.
virtual XTPCalendarPatternEnd | GetUseEndMethod () const
Call this method to retrieve the value of the "use end" flag.
virtual const XTP_CALENDAR_PATTERN_END & | GetPatternEnd () const
Call this method to retrieve the end pattern value.
virtual void | SetPatternEnd (const XTP_CALENDAR_PATTERN_END &patternEnd)
Call this method to set the end pattern value.
virtual void | GetOccurrencesDates (CXTPCalendarDatesArray &rArDates, COleDateTime dtStart, COleDateTime dtEnd) const
This member function is used to obtain the occurrence dates from the pattern in the given interval.
virtual BOOL | GetOccurrences (CXTPCalendarEvents *pEventsArray, COleDateTime dtStart, COleDateTime dtEnd, CXTPCalendarEvent *pMasterEvent)
This member function is used to obtain the occurrence dates from the pattern in the given interval.
virtual CXTPCalendarRecurrencePatternPtr | ClonePattern ()
This member function is used to obtain a pointer to the read-write copy of the pattern object.
virtual BOOL | Update (CXTPCalendarRecurrencePattern *pNewData)
This member function is used to update the pattern data from the given pattern.
virtual DWORD | GetMasterEventID () const
This member function is used to obtain the master event ID value.
virtual void | SetMasterEventID (DWORD dwEventID)
This member function is used to set the master event ID value.
virtual CXTPCalendarEventPtr | GetMasterEvent () const
This member function is used to obtain a pointer to the read-only interface of the master event.
virtual BOOL | SetException (CXTPCalendarEvent *pException, CXTPCalendarEvent *pMasterEventToUpdate=NULL)
This member function is used to add an exception to the master event.
virtual BOOL | RemoveException (CXTPCalendarEvent *pException, CXTPCalendarEvent *pMasterEventToUpdate=NULL)
This member function is used to remove an exception from the master event.
virtual void | RemoveAllExceptions ()
This member function is used to remove all of the exceptions from the master event.
virtual CXTPCalendarEventsPtr | GetExceptions ()
This member function is used to return the read-only collection with the exception events.
virtual void | DoPropExchange (CXTPPropExchange *pPX)
Call this member function to Store/Load a recurrence pattern using the specified data object.
CXTPCalendarCustomProperties * | GetCustomProperties () const
Get custom (named, user-defined) properties collection.
virtual int | FindExceptionIndex (COleDateTime dtStartOrig, COleDateTime dtEndOrig) const
This member function is used to find the index of the exception event by its original start and end dates.
virtual CXTPCalendarEvent * | FindException (COleDateTime dtStartOrig, COleDateTime dtEndOrig) const
This member function is used to find the exception event by its original start and end dates.
virtual BOOL | FindExceptions (CXTPCalendarEvents *pEvents, COleDateTime dtStart, COleDateTime dtEnd) const
This member function is used to find an exception event by its original start and end dates.
CXTPCalendarReminderForOccurrenceArray * GetOccReminders ()
This member function is used to retrieve a collection of reminders settings for occurrences of this recurrence pattern.
void | SetOccReminder (CXTPCalendarEvent *pOccEvent, int nbIsReminder=xtpCalendarRmdPrm_DontChange, DATE dtNextReminderTime_Snoozed=xtpCalendarRmdPrm_DontChange)
This member function is used to setup an occurrence with new Reminder settings.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

CXTPCalendarRecurrencePattern (CXTPCalendarData *pDataProvider)
Protected pattern constructor.
void SetPatternID (DWORD dwID)
This member function is used to assign an ID to a pattern.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

This class represents a recurrence pattern and stores data to build a schedule for recurrence events.

See also
CXTPCalendarEvent overview.

Constructor & Destructor Documentation

◆ CXTPCalendarRecurrencePattern()

CXTPCalendarRecurrencePattern ( CXTPCalendarData * pDataProvider )
protected

Protected pattern constructor.

Parameters
pDataProvider Pointer to a CXTPCalendarData object.
See also
~CXTPCalendarEvent()

◆ ~CXTPCalendarRecurrencePattern()

virtual ~CXTPCalendarRecurrencePattern ( )
virtual

Default class destructor.

Handles member items deallocation. Decreases reference of stored objects: CXTPCalendarEventLabels and CXTPCalendarRecurrencePattern.

Member Function Documentation

◆ ClonePattern()

virtual CXTPCalendarRecurrencePatternPtr ClonePattern ( )
virtual

This member function is used to obtain a pointer to the read-write copy of the pattern object.

Returns
Smart pointer to CXTPCalendarRecurrencePattern object.
See also
CXTPCalendarRecurrencePattern.

◆ DoPropExchange()

virtual void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Call this member function to Store/Load a recurrence pattern using the specified data object.

Parameters
pPX Source or destination CXTPPropExchange data object reference.

This member function is used to store data to or load data from storage.

◆ FindException()

virtual CXTPCalendarEvent * FindException | ( | COleDateTime | dtStartOrig,
 |  | COleDateTime | dtEndOrig ) const
 virtual

This member function is used to find the exception event by its original start and end dates.

Parameters
dtStartOrig | A COleDateTime object that contains the start date.
dtEndOrig | A COleDateTime object that contains the end date.
Returns
If the exception event is found, then the function returns a pointer to a CXTPCalendarEvent object that contains the exception event. If the exception event is not found, then the function returns NULL.
See also
CXTPCalendarEvent

◆ FindExceptionIndex()

virtual int FindExceptionIndex | ( | COleDateTime | dtStartOrig,
 |  | COleDateTime | dtEndOrig ) const
 virtual

This member function is used to find the index of the exception event by its original start and end dates.

Parameters
dtStartOrig | A COleDateTime object that contains the start date.
dtEndOrig | A COleDateTime object that contains the end date.
Returns
An int that contains the value of the index in the collection. -1 if the exception is not found in the collection.

◆ FindExceptions()

virtual BOOL FindExceptions | ( | CXTPCalendarEvents * | pEvents,
 |  | COleDateTime | dtStart,
 |  | COleDateTime | dtEnd ) const
 virtual

This member function is used to find an exception event by its original start and end dates.

Parameters
pEvents | A CXTPCalendarEvents pointer that points to the collection of events to be found.
dtStart | A COleDateTime object that contains the start date of the search interval.
dtEnd | A COleDateTime object that contains the end date of search interval.
Returns
A BOOL. The base class implementation alway returns TRUE. This function should return TRUE if successful. FALSE otherwise.
See also
CXTPCalendarEvents

◆ GetCustomProperties()

AFX_INLINE CXTPCalendarCustomProperties * GetCustomProperties ( ) const

Get custom (named, user-defined) properties collection.

Returns
A pointer to CXTPCalendarCustomProperties object.
See also
CXTPCalendarCustomProperties.

◆ GetDuration()

virtual COleDateTimeSpan GetDuration ( ) const
virtual

Call this member function to get the duration as a COleDateTimeSpan object.

Returns
A COleDateTimeSpan object with a duration interval.
See also
SetDuration(COleDateTimeSpan spDuration, BOOL bKeepStart = TRUE)

◆ GetDurationMinutes()

AFX_INLINE int GetDurationMinutes ( ) const
virtual

Call this member function to get a duration in minutes.

Returns
Integer value of a duration in minutes.
See also
SetDurationMinutes(int nMinutes)
GetDuration()

◆ GetEndAfterOccurrences()

AFX_INLINE int GetEndAfterOccurrences ( ) const
virtual

This member function is used to obtain the "End After occurrences" recurrence pattern option.

Returns
An int that contains the occurrence count for the pattern end.
See also
SetEndAfterOccurrences
GetPatternEndDate
IsNoEndDate

◆ GetEndOccurrenceTime()

virtual COleDateTime GetEndOccurrenceTime ( COleDateTime dtOccurrenceStartDate ) const
virtual

Call this member function to get the occurrence end date-time by its start time.

Parameters
dtOccurrenceStartDate A COleDateTime object that contains the date-time occurrence to identify.
Returns
A COleDateTime object containing the occurrence end date-time.
See also
SetStartTime(COleDateTime dtStart)

◆ GetExceptions()

virtual CXTPCalendarEventsPtr GetExceptions ( )
virtual

This member function is used to return the read-only collection with the exception events.

Returns
Smart pointer to a CXTPCalendarEvents object that contains the read-only collection of exception events.
See also
CXTPCalendarEvent
CXTPCalendarEvent
RemoveAllExceptions()

◆ GetMasterEvent()

virtual CXTPCalendarEventPtr GetMasterEvent ( ) const
virtual

This member function is used to obtain a pointer to the read-only interface of the master event.

Returns
Smart pointer to CXTPCalendarEvent object.

◆ GetMasterEventID()

AFX_INLINE DWORD GetMasterEventID ( ) const
virtual

This member function is used to obtain the master event ID value.

Returns
A DWORD that contains the master event ID value.
See also
SetMasterEventID(DWORD dwEventID).

◆ GetOccReminders()

AFX_INLINE CXTPCalendarReminderForOccurrenceArray * GetOccReminders ( )

This member function is used to retrieve a collection of reminders settings for occurrences of this recurrence pattern.

Returns
An array of CXTPCalendarReminderForoccurrence objects for every occurrence with configured Reminders settings.
See also
CXTPCalendarReminderForoccurrenceArray overview

◆ GetOccurrences()

virtual BOOL GetOccurrences | ( | CXTPCalendarEvents * | pEventsArray,
 |  | COleDateTime | dtStart,
 |  | COleDateTime | dtEnd,
 |  | CXTPCalendarEvent * | pMasterEvent )
 virtual

This member function is used to obtain the occurrence dates from the pattern in the given interval.

Parameters
pEventsArray | Pointer to a CXTPCalendarEvents object that contains the returned collection of slave events (occurrences).
dtStart | A COleDateTime object that contains the interval's begin date.
dtEnd | A COleDateTime object that contains the interval's end date.
pMasterEvent | Pointer to a CXTPCalendarEvent object that contains the master event.
Returns
TRUE if succesfully obtain the dates, FALSE otherwise.
See also
CXTPCalendarEvents
CXTPCalendarEvent

◆ GetOccurrencesDates()

virtual void GetOccurrencesDates | ( | CXTPCalendarDatesArray & | rArDates,
 |  | COleDateTime | dtStart,
 |  | COleDateTime | dtEnd ) const
 virtual

This member function is used to obtain the occurrence dates from the pattern in the given interval.

Parameters
rArDates | A CDatesArray reference to an array of dates to be returned.
dtStart | A COleDateTime object that contains the interval's begin date.
dtEnd | A COleDateTime object that contains the interval's end date.
See also
CDatesArray

◆ GetPatternEnd()

AFX_INLINE const XTP_CALENDAR_PATTERN_END & GetPatternEnd ( ) const
virtual

Call this method to retrieve the end pattern value.

Returns
A reference of the associated pattern end structure.
See also
XTP_CALENDAR_PATTERN_END
XTPCalendarPatternEnd

◆ GetPatternEndDate()

AFX_INLINE COleDateTime GetPatternEndDate ( ) const
virtual

Call this member function to obtain the end pattern DateTime.

Returns
A COleDateTime object that contains the parent's end DateTime.
See also
SetPatternEndDate(COleDateTime dtEnd)

◆ GetPatternID()

AFX_INLINE DWORD GetPatternID ( ) const
virtual

Returns a unique pattern ID.

Returns
A DWORD containing a unique pattern ID.
See also
CXTPCalendarRecurrencePattern()

◆ GetPatternStartDate()

AFX_INLINE COleDateTime GetPatternStartDate ( ) const
virtual

Call this member function to obtain the start pattern DateTime.

Returns
A COleDateTime object containing the parent's start DateTime.
See also
SetPatternStartTime(COleDateTime dtStart)

◆ GetRecurrenceOptions()

AFX_INLINE const XTP_CALENDAR_RECURRENCE_OPTIONS & GetRecurrenceOptions ( ) const
virtual

This member function is used to obtain a set of recurrence options.

Returns
Reference to an XTP_CALENDAR_RECURRENCE_OPTIONS struct.
See also
XTP_CALENDAR_RECURRENCE_OPTIONS
SetRecurrenceOptions(const XTP_CALENDAR_RECURRENCE_OPTIONS& Options)

◆ GetRecurrenceType()

AFX_INLINE int GetRecurrenceType ( ) const
virtual

This member function is used to obtain the value of the recurrence type flag.

Returns
An int that contains the previous value of the Recurrence type flag.
See also
XTPCalendarEventRecurrenceType
XTP_CALENDAR_RECURRENCE_OPTIONS
SetRecurrenceOptions(const XTP_CALENDAR_RECURRENCE_OPTIONS& Options)

◆ GetStartOccurrenceTime()

virtual COleDateTime GetStartOccurrenceTime ( COleDateTime dtOccurrenceStartDate ) const
virtual

Call this member function to get the occurrence start date-time.

Parameters
dtOccurrenceStartDate COleDateTime representing the start date.
Returns
A COleDateTime object that contains the parent's start date-time.
See also
SetStartOccurrenceTime(COleDateTime dtStart)

◆ GetStartTime()

AFX_INLINE COleDateTime GetStartTime ( ) const
virtual

Call this member function to get start date-time.

Returns
COleDateTime object containing start date-time.
See also
SetStartTime(COleDateTime dtStart)

◆ GetUseEndMethod()

AFX_INLINE XTPCalendarPatternEnd GetUseEndMethod ( ) const
virtual

Call this method to retrieve the value of the "use end" flag.

Returns
An int that contains the "use end" flag value.
See also
XTPCalendarPatternEnd.

◆ IsNoEndDate()

AFX_INLINE BOOL IsNoEndDate ( ) const
virtual

This member function is used to determine if the pattern has an end date.

Returns
A BOOL. TRUE if the pattern end is not set. FALSE otherwise.
See also
SetNoEndDate()
GetEndAfterOccurrences()
GetPatternEndDate()

◆ RemoveAllExceptions()

virtual void RemoveAllExceptions ( )
virtual

This member function is used to remove all of the exceptions from the master event.

See also
RemoveException(CXTPCalendarEvent* pException, CXTPCalendarEvent* pMasterEventToUpdate = NULL)
SetException(CXTPCalendarEvent* pException, CXTPCalendarEvent* pMasterEventToUpdate = NULL)

◆ RemoveException()

virtual BOOL RemoveException | ( | CXTPCalendarEvent * | pException,
 |  | CXTPCalendarEvent * | pMasterEventToUpdate = NULL )
 virtual

This member function is used to remove an exception from the master event.

Parameters
pException | A pointer to a CXTPCalendarEvent object that represents the exception.
pMasterEventToUpdate | A pointer to the CXTPCalendarEvent object from which the exception is removed.
Returns
TRUE if successful; FALSE otherwise.
See also
CXTPCalendarEvent
CXTPCalendarEvent
RemoveAllExceptions()

◆ SetDurationMinutes()

AFX_INLINE void SetDurationMinutes ( int nMinutes )
virtual

This member function is used to set the new duration value.

Parameters
nMinutes An int that contains the new duration value in minutes.
See also
GetDurationMinutes()

◆ SetEndAfterOccurrences()

AFX_INLINE void SetEndAfterOccurrences ( int nOccurrences )
virtual

This member function is used to set the "End After occurrences" recurrence pattern option.

Parameters
nOccurrences An int that contains the occurrence count for the pattern end.
See also
GetEndAfterOccurrences
GetPatternEndDate
IsNoEndDate

◆ SetException()

virtual BOOL SetException | ( | CXTPCalendarEvent * | pException,
 |  | CXTPCalendarEvent * | pMasterEventToUpdate = NULL )
 virtual

This member function is used to add an exception to the master event.

Parameters
pException | A pointer to a CXTPCalendarEvent object which represents the exception.
pMasterEventToUpdate | A pointer to a CXTPCalendarEvent object that is updated with the exception.
Returns
A BOOL. TRUE if the update is successful. FALSE otherwise.
See also
CXTPCalendarEvent
CXTPCalendarEvent

◆ SetMasterEventID()

AFX_INLINE void SetMasterEventID ( DWORD dwEventID )
virtual

This member function is used to set the master event ID value.

Parameters
dwEventID A DWORD that contains the new master event ID value.
See also
GetMasterEventID()

◆ SetNoEndDate()

AFX_INLINE void SetNoEndDate ( )
virtual

This member function is used to reset the pattern end date.

See also
IsNoEndDate()
GetEndAfterOccurrences()
GetPatternEndDate()

◆ SetOccReminder()

void SetOccReminder | ( | CXTPCalendarEvent * | pOccEvent,
 |  | int | nbIsReminder = xtpCalendarRmdPrm_DontChange,
 |  | DATE | dtNextReminderTime_Snoozed = xtpCalendarRmdPrm_DontChange )

This member function is used to setup an occurrence with new Reminder settings.

Parameters
pOccEvent | A CXTPCalendarEvent pointer that points to the occurrence event which is to be modified.
nbIsReminder | Trigger value showing whether to change enabled reminder flag for this occurrence or not.
dtNextReminderTime_Snoozed | Reminder snooze time.
See also
GetOccReminders()
XTPEnumCalendarReminderForoccurrenceParameters overview

◆ SetPatternEnd()

virtual void SetPatternEnd ( const XTP_CALENDAR_PATTERN_END & patternEnd )
virtual

Call this method to set the end pattern value.

Parameters
patternEnd A reference to the source pattern end structure.
See also
GetPatternEnd()

◆ SetPatternEndDate()

virtual void SetPatternEndDate ( COleDateTime dtEnd )
virtual

This member function is used to set the new end pattern date.

Parameters
dtEnd A COleDateTime object that contains the new date value.
See also
COleDateTime
GetPatternEndDate()

◆ SetPatternID()

void SetPatternID ( DWORD dwID )
protected

This member function is used to assign an ID to a pattern.

Parameters
dwID Identifier to set.
See also
GetPatternID()

◆ SetPatternStartDate()

virtual void SetPatternStartDate ( COleDateTime dtStart )
virtual

This member function is used to set the new start pattern date and time.

Parameters
dtStart A COleDateTime object that contains the new date value.
See also
GetPatternStartTime()

◆ SetRecurrenceOptions()

virtual void SetRecurrenceOptions ( const XTP_CALENDAR_RECURRENCE_OPTIONS & Options )
virtual

This member function is used to set the recurrence options.

Parameters
Options Reference to a XTP_CALENDAR_RECURRENCE_OPTIONS struct.
See also
XTP_CALENDAR_RECURRENCE_OPTIONS
SetRecurrenceOptions(const XTP_CALENDAR_RECURRENCE_OPTIONS& Options)

◆ SetStartTime()

AFX_INLINE void SetStartTime ( COleDateTime dtStart )
virtual

This member function is used to set the new start date and time.

Parameters
dtStart A COleDateTime object that contains the new start date value.
See also
GetStartTime()

◆ Update()

virtual BOOL Update ( CXTPCalendarRecurrencePattern * pNewData )
virtual

This member function is used to update the pattern data from the given pattern.

Parameters
pNewData A pointer to a CXTPCalendarRecurrencePattern object that contains the pattern to update.
Returns
A pointer to a CXTPCalendarRecurrencePattern object that contains the updated pattern.
See also
CXTPCalendarRecurrencePattern.
The documentation for this class was generated from the following file:
  • XTPCalendarRecurrencePattern.h


Toolkit Pro: CXTPCalendarReminder Class Reference

Classes | Public Member Functions | Protected Types | Protected Member Functions | Protected Attributes | List of all members
CXTPCalendarReminder Class Reference

This class describes a reminder for a calendar event and implements base properties for and operations on the reminder. More...

Inheritance diagram for CXTPCalendarReminder:
[legend]

Classes

struct RecurrenceEventInfo
This structure contains data members to unambiguously define related recurrence event occurrence. More...

Public Member Functions

CXTPCalendarReminder (CXTPCalendarRemindersManager *pOwnerMan=NULL)
Default object constructor.
virtual | ~CXTPCalendarReminder ()
Default class destructor.
virtual CXTPCalendarEventPtr | GetEvent () const
Retrieve the calendar event for which this reminder is related.
virtual COleDateTime | GetNextReminderTime () const
Call this member function to retrieve the date and time when a reminder is scheduled to be activated.
virtual int | GetMinutesBeforeStart () const
Call this member function to determine the number of minutes before the start of an event.
virtual BOOL | Snooze (int nMinutesAfterNow)
Call this member function to Snooze an active reminder.
virtual BOOL | Dismiss ()
Call this member function to Dismiss an active reminder.
virtual BOOL | IsEqualID (const CXTPCalendarReminder *pReminder2) const
Call this member function to determine if reminders objects have equal IDs (or are they represent the same reminder).
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Types

enum EventType { evtNormal = 1 , evtRecurrence = 2 }
This enum define the event type: recurrence or non-recurrence. More...

Protected Member Functions

virtual void SetEvent (CXTPCalendarEvent *pEvent)
Set a calendar event for which this reminder is related.

Protected Attributes

COleDateTime | m_dtNextReminderTime
Store reminder activation date and time.
int | m_nMinutesBeforeStart
Store minutes before start event to activate reminder.
COleDateTime | m_dtEventStartTime
Store related event start time.
CXTPCalendarData * m_pEventDataProvider
Store related event data provider.
EventType | m_eEventType
Define related event type: recurrence or non-recurrence.
union {
DWORD m_dwNormalEventID
Non-recurrence event ID.
RecurrenceEventInfo m_RecurrenceEventInfo
Recurrence event information (instead of ID).
};
This union contains data members to unambiguously define a related event.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

This class describes a reminder for a calendar event and implements base properties for and operations on the reminder.

Member Enumeration Documentation

◆ EventType

enum EventType
protected

This enum define the event type: recurrence or non-recurrence.

Enumerator
evtNormal | event type is recurrence.
evtRecurrence | event type is non-recurrence.

Constructor & Destructor Documentation

◆ CXTPCalendarReminder()

CXTPCalendarReminder ( CXTPCalendarRemindersManager * pOwnerMan = NULL )

Default object constructor.

Parameters
pOwnerMan A pointer to the reminders manager which owns this object.
See also
~CXTPCalendarReminder()

◆ ~CXTPCalendarReminder()

virtual ~CXTPCalendarReminder ( )
virtual

Default class destructor.

Handles member items deallocation.

See also
CXTPCalendarReminder()

Member Function Documentation

◆ Dismiss()

AFX_INLINE BOOL Dismiss ( )
virtual

Call this member function to Dismiss an active reminder.

Reminder flag for corresponding event object is set to FALSE.

Returns
TRUE if operation is successful, FALSE otherwise.
See also
Snooze
GetEvent
CXTPCalendarRemindersManager::Dismiss

◆ GetEvent()

virtual CXTPCalendarEventPtr GetEvent ( ) const
virtual

Retrieve the calendar event for which this reminder is related.

Returns
A pointer to a calendar event object.

◆ GetMinutesBeforeStart()

AFX_INLINE int GetMinutesBeforeStart ( ) const
virtual

Call this member function to determine the number of minutes before the start of an event.

Returns
An int that contains the number of Minutes before the start of an event.
See also
CXTPCalendarEvent::GetReminderMinutesBeforeStart
GetEvent

◆ GetNextReminderTime()

AFX_INLINE COleDateTime GetNextReminderTime ( ) const
virtual

Call this member function to retrieve the date and time when a reminder is scheduled to be activated.

This value for non-snoozed event is: EventStartTime - MinutesBeforeStart. For snoozed event this value is set when Snooze() method is called.

Returns
Reminder activation date and time.
See also
GetMinutesBeforeStart
Snooze
GetEvent

◆ IsEqualID()

virtual BOOL IsEqualID ( const CXTPCalendarReminder * pReminder2 ) const
virtual

Call this member function to determine if reminders objects have equal IDs (or are they represent the same reminder).

Parameters
pReminder2 A pointer to reminder object to compare.
Returns
TRUE if reminders objects have equal IDs, FALSE otherwise.

◆ SetEvent()

virtual void SetEvent ( CXTPCalendarEvent * pEvent )
protectedvirtual

Set a calendar event for which this reminder is related.

Parameters
pEvent A pointer to calendar event.
See also
GetEvent

◆ Snooze()

AFX_INLINE BOOL Snooze ( int nMinutesAfterNow )
virtual

Call this member function to Snooze an active reminder.

Parameters
nMinutesAfterNow A value in minutes to activate reminder again.
Returns
TRUE if operation is successful, FALSE otherwise.
See also
Dismiss
GetNextReminderTime
GetEvent
CXTPCalendarRemindersManager::Snooze

Member Data Documentation

◆ [union]

union { ... }

This union contains data members to unambiguously define a related event.

See also
RecurrenceEventInfo
m_eEventType

◆ m_dtNextReminderTime

COleDateTime m_dtNextReminderTime
protected

Store reminder activation date and time.

◆ m_pEventDataProvider

CXTPCalendarData* m_pEventDataProvider
protected

Store related event data provider.

The documentation for this class was generated from the following file:
  • XTPCalendarRemindersManager.h


Toolkit Pro: CXTPCalendarReminder::RecurrenceEventInfo Struct Reference

  • CXTPCalendarReminder
  • RecurrenceEventInfo
Public Attributes | List of all members
CXTPCalendarReminder::RecurrenceEventInfo Struct Reference

This structure contains data members to unambiguously define related recurrence event occurrence. More...

Public Attributes

DWORD | m_dwMasterEventID
Recurrence master event ID.
DATE | m_dtOccurrenceStartTime
Recurrence occurrence start time or recurrence exception original start time.
DATE | m_dtOccurrenceEndTime
Recurrence occurrence end time or recurrence exception original end time.

Detailed Description

This structure contains data members to unambiguously define related recurrence event occurrence.

See also
EventType
The documentation for this struct was generated from the following file:
  • XTPCalendarRemindersManager.h


Toolkit Pro: CXTPCalendarReminderForOccurrenceArray Class Reference

Public Member Functions | Static Public Member Functions | List of all members
CXTPCalendarReminderForOccurrenceArray Class Reference

This class implements a collection of CXTPCalendarReminderForOccurrence objects as well as some common operations on it. More...

Public Member Functions

CXTPCalendarReminderForOccurrenceArray ()
Default collection constructor.
virtual | ~CXTPCalendarReminderForOccurrenceArray ()
Default collection destructorparameteparam.
int | Find (CXTPCalendarEvent *pOccEvent) const
Finds an index of the occurrence event.
int | Find (DATE dtOccStartTime, DATE dtOccEndTime) const
Finds an index of the occurrence event by its start and end time.
int | UpdateOccIfNeed (CXTPCalendarEvent *pOccEvent, CXTPCalendarRecurrencePattern *pPattern)
Updates occurrence custom properties with the values from the array if the necessary one is found there.
BOOL | Load (CXTPCalendarCustomProperties *pProps)
Loads an array of occurrences information from the Calendar Custom Properties object.
BOOL | Save (CXTPCalendarCustomProperties *pProps, CXTPCalendarRecurrencePattern *pPattern)
Saves an array of occurrences information to the Calendar Custom Properties object.

Static Public Member Functions

static int AFX_CDECL | UpdateOccIfNeedEx (CXTPCalendarEvent *pOccEvent, const CXTPCalendarReminderForOccurrence *pOccRmdData, CXTPCalendarRecurrencePattern *pPattern)
Updates occurrence custom properties with the values from the provided CXTPCalendarReminderForOccurrence structure.
static void AFX_CDECL | ClearProperties (CXTPCalendarCustomProperties *pProps)
An utility method which clears all occurrences custom properties which was previously set by Save method.

Detailed Description

This class implements a collection of CXTPCalendarReminderForOccurrence objects as well as some common operations on it.

Constructor & Destructor Documentation

◆ CXTPCalendarReminderForOccurrenceArray()

CXTPCalendarReminderForOccurrenceArray ( )

Default collection constructor.

See also
~CXTPCalendarReminderForOccurrenceArray()

◆ ~CXTPCalendarReminderForOccurrenceArray()

virtual ~CXTPCalendarReminderForOccurrenceArray ( )
virtual

Default collection destructorparameteparam.

Handles member item deallocation. Decreases reference of all stored CXTPCalendarReminderForOccurrence objects.

See also
RemoveAll()

Member Function Documentation

◆ ClearProperties()

static void AFX_CDECL ClearProperties ( CXTPCalendarCustomProperties * pProps )
static

An utility method which clears all occurrences custom properties which was previously set by Save method.

Parameters
pProps Pointer to CXTPCalendarCustomProperties object to be cleared.
Returns
void.
See also
Save()
Load()

◆ Find() [1/2]

int Find ( CXTPCalendarEvent * pOccEvent ) const

Finds an index of the occurrence event.

Parameters
pOccEvent Pointer to the occurrence event object.
Returns
An index of the occurrence event object in the array if found; or -1 if not found.
See also
Find()

◆ Find() [2/2]

int Find | ( | DATE | dtOccStartTime,
 |  | DATE | dtOccEndTime ) const

Finds an index of the occurrence event by its start and end time.

Parameters
dtOccStartTime | Occurrence start time.
dtOccEndTime | Occurrence end time.
Returns
An index of the occurrence event object in the array if found; or -1 if not found.
See also
Find()

◆ Load()

BOOL Load ( CXTPCalendarCustomProperties * pProps )

Loads an array of occurrences information from the Calendar Custom Properties object.

Parameters
pProps Pointer to a source CXTPCalendarCustomProperties object.
Returns
TRUE when loaded successfully; FALSE otherwise.
See also
Save()

◆ Save()

BOOL Save | ( | CXTPCalendarCustomProperties * | pProps,
 |  | CXTPCalendarRecurrencePattern * | pPattern )

Saves an array of occurrences information to the Calendar Custom Properties object.

Parameters
pProps | Pointer to a destination CXTPCalendarCustomProperties object.
pPattern | Pointer to the parent Recurrence Pattern object for those occurrences.
Returns
TRUE when saved successfully; FALSE otherwise.
See also
Load()

◆ UpdateOccIfNeed()

int UpdateOccIfNeed | ( | CXTPCalendarEvent * | pOccEvent,
 |  | CXTPCalendarRecurrencePattern * | pPattern )

Updates occurrence custom properties with the values from the array if the necessary one is found there.

Parameters
pOccEvent | Pointer to the occurrence event object.
pPattern | Pointer to the parent Recurrence Pattern object for those occurrences.
Returns
Nonzero if updated successfully; zero if update failed.
See also
UpdateOccIfNeedEx

◆ UpdateOccIfNeedEx()

static int AFX_CDECL UpdateOccIfNeedEx | ( | CXTPCalendarEvent * | pOccEvent,
 |  | const CXTPCalendarReminderForOccurrence * | pOccRmdData,
 |  | CXTPCalendarRecurrencePattern * | pPattern )
 static

Updates occurrence custom properties with the values from the provided CXTPCalendarReminderForOccurrence structure.

Parameters
pOccEvent | Pointer to the occurrence event object.
pOccRmdData | Pointer to the Reminder data for the occurrence.
pPattern | Pointer to the parent Recurrence Pattern object for those occurrences.
Returns
Nonzero if updated successfully; zero if update failed.
See also
CXTPCalendarReminderForOccurrence overview
UpdateOccIfNeed
The documentation for this class was generated from the following file:
  • XTPCalendarRecurrencePattern.h


Toolkit Pro: CXTPCalendarReminders Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPCalendarReminders Class Reference

This class represents a simple array collection of CXTPCalendarReminder objects. More...

Inheritance diagram for CXTPCalendarReminders:
[legend]

Public Member Functions

virtual int | Find (const CXTPCalendarReminder *pReminder) const
Finds a specified reminder object in the collection.
virtual int | Find (CXTPCalendarEvent *pEvent) const
Finds a reminder object in the collection which is related to the event specified.
virtual int | Find (DWORD dwEventID, CXTPCalendarData *pDP=NULL) const
Finds a reminder object in the collection which is related to the specified event ID.
virtual BOOL | RemoveDataForEvent (CXTPCalendarEvent *pEvent)
Try to find and remove reminder object which is related to the event specified.
virtual void | Sort ()
Sort reminders by the event start time field.
- Public Member Functions inherited from CXTPCalendarPtrCollectionT< CXTPCalendarReminder >
CXTPCalendarPtrCollectionT ()
Default collection constructor.
virtual | ~CXTPCalendarPtrCollectionT ()
Default collection destructor.
virtual int | GetCount () const
This member function is used to obtain the number of elements in the collection.
virtual void | Add (CXTPCalendarReminder *pNewElement)
This member function adds a new element to the end of the array.
virtual void | Add (CXTPCalendarReminder *pNewElement, BOOL bWithAddRef)
This member function adds a new element to the end of the array.
virtual void | SetAt (int nIndex, CXTPCalendarReminder *pElement)
This member function is used to set a new element to the position specified in the nIndex parameter.
virtual void | InsertAt (int nIndex, CXTPCalendarReminder *pElement)
This member function is used to insert a new element at the position specified in the nIndex parameter.
virtual void | Append (const CXTPCalendarPtrCollectionT< CXTPCalendarReminder > *pElementsArray)
This member function is used to add a new elements to the end of the array.
virtual void | SetSize (int nNewSize)
This member function is used to change the array size.
virtual CXTPCalendarReminder * | GetAt (int nIndex) const
This member function returns an element at the specified numeric index.
virtual CXTPCalendarReminder * | GetAt (int nIndex, BOOL bWithAddRef) const
This member function returns an element at the specified numeric index.
virtual void | RemoveAt (int nIndex)
This member function removes an element at the specified index from the array.
virtual void | Remove (CXTPCalendarReminder *pElement)
This member function finds an element using its pointer and removes it from the array.
virtual void | RemoveAll ()
This member function is used to remove all of the elements from the array.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

virtual BOOL _RemoveDataForMasterEvent (CXTPCalendarEvent *pEvent)
Try to find and remove reminder(s) object(s) which are related to the recurrence master event specified.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Types inherited from CXTPCalendarPtrCollectionT< CXTPCalendarReminder >
typedef CXTPSmartPtrInternalT< CXTPCalendarReminder > | TObjectPtr
Smart pointer type for stored objects.
- Protected Attributes inherited from CXTPCalendarPtrCollectionT< CXTPCalendarReminder >
CArray< TObjectPtr, TObjectPtr & > | m_arElements
Objects storage.

Detailed Description

This class represents a simple array collection of CXTPCalendarReminder objects.

Member Function Documentation

◆ _RemoveDataForMasterEvent()

virtual BOOL _RemoveDataForMasterEvent ( CXTPCalendarEvent * pEvent )
protectedvirtual

Try to find and remove reminder(s) object(s) which are related to the recurrence master event specified.

Parameters
pEvent A pointer to the master event.
Returns
TRUE if the related reminder(s) object(s) was removed from the collection, FALSE otherwise.

◆ Find() [1/3]

virtual int Find ( const CXTPCalendarReminder * pReminder ) const
virtual

Finds a specified reminder object in the collection.

CXTPCalendarReminder::IsEqualID method is used to compare reminders.

Parameters
pReminder A pointer to the reminder object to find.
Returns
Index of the equal reminder object in the collection or -1 if such object is not present.
See also
CXTPCalendarEvent

Reimplemented from CXTPCalendarPtrCollectionT< CXTPCalendarReminder >.

◆ Find() [2/3]

virtual int Find ( CXTPCalendarEvent * pEvent ) const
virtual

Finds a reminder object in the collection which is related to the event specified.

Parameters
pEvent A pointer to the event.
Returns
Index of the related reminder object in the collection or -1 if such object is not present.
See also
CXTPCalendarReminder

◆ Find() [3/3]

virtual int Find | ( | DWORD | dwEventID,
 |  | CXTPCalendarData * | pDP = NULL ) const
 virtual

Finds a reminder object in the collection which is related to the specified event ID.

Parameters
dwEventID | Event ID of a normal event or Master event.
pDP | A pointer to the event data provider.
Returns
Index of the related reminder object in the collection or -1 if such object is not present.
See also
CXTPCalendarReminder
CXTPCalendarEvent

◆ RemoveDataForEvent()

virtual BOOL RemoveDataForEvent ( CXTPCalendarEvent * pEvent )
virtual

Try to find and remove reminder object which is related to the event specified.

Parameters
pEvent A pointer to the event.
Returns
TRUE if the related reminder object is removed from the collection, FALSE otherwise.
The documentation for this class was generated from the following file:
  • XTPCalendarRemindersManager.h


Toolkit Pro: CXTPCalendarRemindersDialog Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPCalendarRemindersDialog Class Reference

This class used to display calendar reminders. More...

Public Member Functions

CXTPCalendarRemindersDialog (CWnd *pParent=NULL, UINT nIDTemplate=CXTPCalendarRemindersDialog::IDD)
Dialog class constructor.
virtual | ~CXTPCalendarRemindersDialog ()
Default object destructor.
virtual BOOL | Create (CWnd *pParent=NULL)
Use this method to create a dialog window.
virtual void | SetRemindersManager (CXTPCalendarControl *pCalendar)
Use this method to attach dialog to calendar control (and reminders manager).
virtual void | UpdateFromManager ()
Use this method to update the dialog reminders list from the reminders manager.
virtual void | Detach ()
Use this method to update the dialog reminders list from the calendar control (and reminders manager).
virtual BOOL | IsShowInTaskBar ()
This method is used to determine if the dialog window is displayed in the Microsoft Windows taskbar.
virtual void | SetShowInTaskBar (BOOL bShow=TRUE)
This method is used to set if the dialog window is displayed in the Microsoft Windows taskbar.
BOOL | IsAutoPopup () const
This method is used to determine if the dialog window pops up automatically when new reminders arrive.
void | SetAutoPopup (BOOL bAutoPopup=TRUE)
This method is used to set if the dialog window pops up automatically when new reminders arrive.

Protected Attributes

CXTPCalendarRemindersManager * | m_pRemindersMan
Store pointer to reminders manager.
CXTPCalendarReminders | m_arActiveReminders
Store active reminders list.
CXTPCalendarControl * | m_pCalendar
Store pointer to calendar control.
int | m_nNextRefreshIndex
Store next reminder item index for automatic refresh by timer or -1 to refresh all.
CListCtrl | m_ctrlRemindersList
Reminders list control.
CStatic | m_ctrlDescription
Description control.
CComboBox | m_ctrlSnoozeTimeCB
Snooze combobox control.
CButton | m_ctrlSnoozeBtn
Snooze button.
CButton | m_ctrlDismissBtn
Dismiss button.
CButton | m_ctrlDismissAllBtn
Dismiss All button.
CButton | m_ctrlOpenItemBtn
Open Item button.
BOOL | m_bShowInTaskBar
Store ShowInTaskBar property value.
BOOL | m_bAutoPopup
Store AutoPopup property value.

Detailed Description

This class used to display calendar reminders.

This is a default implementation which can be used as an example or as a base class for custom dialogs. It designed to be localized - XTPResourceManager is used to load resources.

Constructor & Destructor Documentation

◆ CXTPCalendarRemindersDialog()

CXTPCalendarRemindersDialog | ( | CWnd * | pParent = NULL,
 |  | UINT | nIDTemplate = CXTPCalendarRemindersDialog::IDD )

Dialog class constructor.

Parameters
pParent | [in] Pointer to parent window. Can be NULL.
nIDTemplate | [in] Contains the ID number of a dialog-box template resource.

Member Function Documentation

◆ Create()

virtual BOOL Create ( CWnd * pParent = NULL )
virtual

Use this method to create a dialog window.

Parameters
pParent [in] Pointer to parent window. Can be NULL.
Returns
TRUE if dialog window created successfully, FALSE otherwise.

◆ IsAutoPopup()

AFX_INLINE BOOL IsAutoPopup ( ) const

This method is used to determine if the dialog window pops up automatically when new reminders arrive.

Returns
TRUE if the dialog window pops up automatically, FALSE otherwise.

◆ IsShowInTaskBar()

virtual BOOL IsShowInTaskBar ( )
virtual

This method is used to determine if the dialog window is displayed in the Microsoft Windows taskbar.

Returns
TRUE if dialog displayed in the taskbar, FALSE otherwise.

◆ SetAutoPopup()

AFX_INLINE void SetAutoPopup ( BOOL bAutoPopup = TRUE )

This method is used to set if the dialog window pops up automatically when new reminders arrive.

Parameters
bAutoPopup [in] Set TRUE to pop up dialog automatically, FALSE otherwise.

◆ SetRemindersManager()

virtual void SetRemindersManager ( CXTPCalendarControl * pCalendar )
virtual

Use this method to attach dialog to calendar control (and reminders manager).

Parameters
pCalendar [in] Pointer to control.

◆ SetShowInTaskBar()

virtual void SetShowInTaskBar ( BOOL bShow = TRUE )
virtual

This method is used to set if the dialog window is displayed in the Microsoft Windows taskbar.

Parameters
bShow [in] Set TRUE to show dialog in the taskbar, FALSE otherwise.

Member Data Documentation

◆ m_bAutoPopup

BOOL m_bAutoPopup
protected

Store AutoPopup property value.

◆ m_ctrlDescription

CStatic m_ctrlDescription
protected

Description control.

◆ m_ctrlDismissBtn

CButton m_ctrlDismissBtn
protected

Dismiss button.

◆ m_ctrlOpenItemBtn

CButton m_ctrlOpenItemBtn
protected

Open Item button.

◆ m_ctrlSnoozeBtn

CButton m_ctrlSnoozeBtn
protected

Snooze button.

The documentation for this class was generated from the following file:
  • XTPCalendarRemindersDialog.h


Toolkit Pro: CXTPCalendarRemindersManager Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPCalendarRemindersManager Class Reference

This class is used to monitor and manage calendar events reminders. More...

Public Member Functions

CXTPCalendarRemindersManager ()
Default object constructor.
virtual | ~CXTPCalendarRemindersManager ()
Default object destructor.
virtual int | GetActiveRemindersCount () const
Call this method to retrieve reminders count in the active reminders collection.
virtual void | GetActiveReminders (CXTPCalendarReminders &rarActiveReminders) const
Call this method to retrieve the active reminders collection.
virtual BOOL | Snooze (CXTPCalendarReminder *pReminder, int nMinutesAfterNow)
Call this member function to Snooze a specified reminder.
virtual BOOL | Dismiss (CXTPCalendarReminder *pReminder)
Call this member function to Dismiss a specified reminder.
virtual BOOL | DismissAll ()
Call this member function to Dismiss all active reminders.
CXTPNotifyConnection * | GetConnection () const
Obtain a pointer to the notification connection object.
virtual BOOL | StartMonitoring (CXTPCalendarResources *pResources, COleDateTimeSpan spPeriod2Cache)
This method is used to attach to calendar resources (data provider) and start reminders monitoring.
virtual BOOL | StopMonitoring ()
This method is used to detach from calendar resources (data provider) and and to clear all reminders in reminders manager.
virtual BOOL | IsMonitoringRunning () const
Call this method to determine if StartMonitoring was successfully called and if the reminders manager is monitoring reminders.

Protected Member Functions

virtual void | NotifyReminders (int eAction, LPARAM lParam=0)
This method is used to send an XTP_NC_CALENDAR_ON_REMINDERS notification via connection object.
virtual void | PostNotify_RemindersFire ()
Schedule to call NotifyReminders(xtpCalendarRemindersFire) in 500 ms.
virtual void | RemoveAll ()
This method clears all reminders in reminders manager collections.

Protected Attributes

CXTPNotifyConnection * | m_pConnection
A pointer to the notification connection object.
CXTPCalendarResourcesNf * m_pResourcesNf
A collection of calendar resources to be monitored.
COleDateTimeSpan | m_spPeriod2Cache
Time period to cache data from the calendar resources.
COleDateTime | m_dtLastUpdateTime
Store last time when reminders data was loaded from the calendar resources.
CXTPCalendarReminders | m_arWaitingReminders
Waiting reminders collection.
CXTPCalendarReminders m_arActiveReminders
Active reminders collection.
BOOL | m_bMonitoringRunning
Flag indicate that reminders manager is started;.

Detailed Description

This class is used to monitor and manage calendar events reminders.

It will send notifications when the active reminders list is changed - new reminder(s) come or some reminder(s) goes away.

When Reminder manager starts, it checks all events which have a Reminder flag set. Reminder for event is added to active reminders list when: Event->StartTime - Event->ReminderMinutesBeforeStart <= Now

There are 2 actions with reminder: Dismiss - reset Reminder flag for the event and remove reminder. Reminder never comes back;

Snooze - set new NextReminderTime value and remove reminder. Reminder will come back when NextReminderTime <= Now.

Some Reminder manager data is stored in CalendarEvent custom properties (or RecurrencePattern custom properties). This means if your own events storage is used, you have to save/load custom properties too.

StartMonitoring/StopMonitoring are used to start/stop reminders manager. These methods are called by the calendar control automatically when CXTPCalendarControl::EnableReminders() method is called.

GetActiveReminders is used to retrieve collection of active reminders.

Constructor & Destructor Documentation

◆ CXTPCalendarRemindersManager()

CXTPCalendarRemindersManager ( )

Default object constructor.

See also
~CXTPCalendarRemindersManager()

◆ ~CXTPCalendarRemindersManager()

virtual ~CXTPCalendarRemindersManager ( )
virtual

Default object destructor.

See also
CXTPCalendarRemindersManager()

Member Function Documentation

◆ Dismiss()

virtual BOOL Dismiss ( CXTPCalendarReminder * pReminder )
virtual

Call this member function to Dismiss a specified reminder.

Reminder flag for the corresponding event object is set to FALSE.

Parameters
pReminder A pointer to a reminder object.
Returns
TRUE if the operation is successful, FALSE otherwise.
See also
Snooze
CXTPCalendarReminder::Snooze
CXTPCalendarReminder::Dismiss

◆ DismissAll()

virtual BOOL DismissAll ( )
virtual

Call this member function to Dismiss all active reminders.

Reminder flag for each event object is set to FALSE.

Returns
TRUE if operation is successful, FALSE otherwise.
See also
Snooze
Dismiss
CXTPCalendarReminder::Snooze
CXTPCalendarReminder::Dismiss

◆ GetActiveReminders()

virtual void GetActiveReminders ( CXTPCalendarReminders & rarActiveReminders ) const
virtual

Call this method to retrieve the active reminders collection.

Parameters
rarActiveReminders A reference to an array to retrieve active reminders.
See also
GetActiveRemindersCount

◆ GetActiveRemindersCount()

virtual int GetActiveRemindersCount ( ) const
virtual

Call this method to retrieve reminders count in the active reminders collection.

Can be useful to quickly determine if the active reminders collection is empty without copy collection.

Returns
Active reminders count.
See also
GetActiveReminders

◆ GetConnection()

AFX_INLINE CXTPNotifyConnection * GetConnection ( ) const

Obtain a pointer to the notification connection object.

Used to subscribe (Advice) for notification events from the reminders manager.

Returns
Connection object pointer.
See also
CXTPNotifyConnection overview
IXTPNotificationSink overview

◆ IsMonitoringRunning()

AFX_INLINE BOOL IsMonitoringRunning ( ) const
virtual

Call this method to determine if StartMonitoring was successfully called and if the reminders manager is monitoring reminders.

Returns
TRUE if reminders manager is active (started/running), FALSE otherwise.
See also
StartMonitoring
StopMonitoring

◆ NotifyReminders()

virtual void NotifyReminders | ( | int | eAction,
 |  | LPARAM | lParam = 0 )
 protectedvirtual

This method is used to send an XTP_NC_CALENDAR_ON_REMINDERS notification via connection object.

Parameters
eAction | A reminders action. Value from enum XTPCalendarRemindersAction.
lParam | Reserved. Set to 0.
See also
XTP_NC_CALENDAR_ON_REMINDERS
XTPCalendarRemindersAction

◆ PostNotify_RemindersFire()

virtual void PostNotify_RemindersFire ( )
protectedvirtual

Schedule to call NotifyReminders(xtpCalendarRemindersFire) in 500 ms.

See also
NotifyReminders
XTP_NC_CALENDAR_ON_REMINDERS
XTPCalendarRemindersAction

◆ RemoveAll()

virtual void RemoveAll ( )
protectedvirtual

This method clears all reminders in reminders manager collections.

See also
StopMonitoring

◆ Snooze()

virtual BOOL Snooze | ( | CXTPCalendarReminder * | pReminder,
 |  | int | nMinutesAfterNow )
 virtual

Call this member function to Snooze a specified reminder.

Parameters
pReminder | A pointer to a reminder object.
nMinutesAfterNow | A value in minutes to activate the reminder again.
Returns
TRUE if operation is successful, FALSE otherwise.
See also
Dismiss
CXTPCalendarReminder::Snooze
CXTPCalendarReminder::Dismiss
CXTPCalendarReminder::GetNextReminderTime

◆ StartMonitoring()

virtual BOOL StartMonitoring | ( | CXTPCalendarResources * | pResources,
 |  | COleDateTimeSpan | spPeriod2Cache )
 virtual

This method is used to attach to calendar resources (data provider) and start reminders monitoring.

Parameters
pResources | A pointer to a calendar resources collection.
spPeriod2Cache | A time period for which reminder manager will read reminders from calendar resources (data provider).

To retrieve reminders, the CXTPCalendarData::GetUpcomingEvents() method is used. This can be a slow operation and by using the spPeriod2Cache parameter value we can control how often this method will be called.

For example calendar control use spPeriod2Cache = 2 hours by default. This means than GetUpcomingEvents will be called only once per 2 hours.

Returns
TRUE if operation is successful, FALSE otherwise.
See also
StopMonitoring

◆ StopMonitoring()

virtual BOOL StopMonitoring ( )
virtual

This method is used to detach from calendar resources (data provider) and and to clear all reminders in reminders manager.

Returns
TRUE if operation is successful, FALSE otherwise.
See also
StartMonitoring

Member Data Documentation

◆ m_arActiveReminders

CXTPCalendarReminders m_arActiveReminders
protected

Active reminders collection.

◆ m_pResourcesNf

CXTPCalendarResourcesNf* m_pResourcesNf
protected

A collection of calendar resources to be monitored.

The documentation for this class was generated from the following file:
  • XTPCalendarRemindersManager.h


Toolkit Pro: CXTPCalendarResource Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPCalendarResource Class Reference

Class CXTPCalendarResource represents a calendar for some subject like a person, a shared resource, or even a group of people or resources. More...

Inheritance diagram for CXTPCalendarResource:
[legend]

Public Member Functions

CXTPCalendarResource (CXTPCalendarControl *pCalendarCtrl=NULL)
Default object constructor.
virtual | ~CXTPCalendarResource ()
Default class destructor.
CXTPCalendarData * | GetDataProvider () const
This member function obtains a pointer to the current data provider instance.
void | SetDataProvider (CXTPCalendarData *pDataProvider, BOOL bCloseDataProviderWhenDestroy=FALSE)
This member function sets the custom data provider for the control.
virtual CXTPCalendarEventsPtr | RetrieveDayEvents (COleDateTime dtDay)
Call this member function to get the collection of the day's events for this resource.
virtual CUIntArray * | GetSchedules ()
Call this member function to get the collection of all schedule IDs for this resource.
virtual BOOL | ExistsScheduleID (UINT uScheduleID, BOOL bReturnTrueIfSchedulesSetEmpty=TRUE)
This member function determines whether a schedule with the specified ID exists or not.
void | FilterEventsByScheduleID (CXTPCalendarEvents *pEvents)
This member function is used to remove events which are not from this resource.
virtual BOOL | IsSchedulesSetEmpty () const
Call this member function to determine if the schedules set in this resource is empty or not.
virtual CString | GetName () const
This member function returns a string name of this resource object.
virtual void | SetName (LPCTSTR pcszResourceName)
This member function applies a new name to the resource object.
virtual COLORREF | GetColor () const
This member function returns a color of this resource object.
virtual void | SetColor (COLORREF color)
This member function applies a new color to the resource object.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Attributes

CString | m_strResourceName
Text name of the resource

CXTPCalendarControl * | m_pCalendarCtrl
Parent Calendar control

CXTPCalendarData * | m_pDataProvider
Associated data provider

CUIntArray | m_arScheduleIDs
which schedules are used for this resource.
COLORREF | m_Color
color of resource

BOOL | m_bCloseDataProviderWhenDestroy
If TRUE - call Close() method for the data provider when control is destroyed.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

Class CXTPCalendarResource represents a calendar for some subject like a person, a shared resource, or even a group of people or resources.

Each resource is to be drawn in the separate column on the calendar view. Each resource should have its own DataProvider. For example, events for people could be stored inside the Memory data provider (somebody's own or temporary events), and for other resources - inside a Database data provider (those events are not changed by the user). So, there is a possibility to use any combination of data providers in the same control.

See also
CXTPCalendarControl
CXTPCalendarData

Constructor & Destructor Documentation

◆ CXTPCalendarResource()

CXTPCalendarResource ( CXTPCalendarControl * pCalendarCtrl = NULL )

Default object constructor.

Constructs a CXTPCalendarResource object.

Parameters
pCalendarCtrl Pointer to the parent Calendar control.
See also
~CXTPCalendarResource

◆ ~CXTPCalendarResource()

virtual ~CXTPCalendarResource ( )
virtual

Default class destructor.

Handles member items deallocation.

See also
XTPCalendarResource

Member Function Documentation

◆ ExistsScheduleID()

virtual BOOL ExistsScheduleID | ( | UINT | uScheduleID,
 |  | BOOL | bReturnTrueIfSchedulesSetEmpty = TRUE )
 virtual

This member function determines whether a schedule with the specified ID exists or not.

Parameters
uScheduleID | A numeric ID of the schedule to check.
bReturnTrueIfSchedulesSetEmpty | TRUE by default. If there are not any schedules specified inside this resource, the Calendar will show all available events.
Returns
TRUE if a schedule ID exists in the Schedules collection for this resource; FALSE otherwise.
See also
GetSchedules
IsSchedulesSetEmpty

◆ FilterEventsByScheduleID()

void FilterEventsByScheduleID ( CXTPCalendarEvents * pEvents )

This member function is used to remove events which are not from this resource.

Parameters
pEvents An events collection to be filtered.
See also
ExistsScheduleID

◆ GetColor()

AFX_INLINE COLORREF GetColor ( ) const
virtual

This member function returns a color of this resource object.

Returns
A COLORREF with the color of the resource object.
See also
SetColor

◆ GetDataProvider()

AFX_INLINE CXTPCalendarData * GetDataProvider ( ) const

This member function obtains a pointer to the current data provider instance.

Call this member function to obtain the data provider object currently used by this calendar control.

Returns
A CXTPCalendarData pointer to the associated data provider object.
See also
CXTPCalendarData overview
SetDataProvider

◆ GetName()

AFX_INLINE CString GetName ( ) const
virtual

This member function returns a string name of this resource object.

Returns
A string with the name of the resource object.
See also
SetName

◆ GetSchedules()

AFX_INLINE CUIntArray * GetSchedules ( )
virtual

Call this member function to get the collection of all schedule IDs for this resource.

Returns
A pointer to the CUIntArray collection which contains numeric IDs for all schedules existing in this resource.
See also
CUIntArray overview
IsSchedulesSetEmpty
ExistsScheduleID

◆ IsSchedulesSetEmpty()

AFX_INLINE BOOL IsSchedulesSetEmpty ( ) const
virtual

Call this member function to determine if the schedules set in this resource is empty or not.

Returns
TRUE if the schedules set is empty for this resource; FALSE if at least 1 schedule exists.
See also
GetSchedules
ExistsScheduleID

◆ RetrieveDayEvents()

virtual CXTPCalendarEventsPtr RetrieveDayEvents ( COleDateTime dtDay )
virtual

Call this member function to get the collection of the day's events for this resource.

All events from the applied schedules will be included.

Parameters
dtDay A COleDateTime object that contains the day's date.
Returns
A pointer to a CXTPCalendarEvents object that contains the collection of the day's events.
See also
CXTPCalendarEvents

◆ SetColor()

AFX_INLINE void SetColor ( COLORREF color )
virtual

This member function applies a new color to the resource object.

Parameters
color A COLORREF with the new color for the resource.
See also
GetColor

◆ SetDataProvider()

void SetDataProvider | ( | CXTPCalendarData * | pDataProvider,
 |  | BOOL | bCloseDataProviderWhenDestroy = FALSE )

This member function sets the custom data provider for the control.

Parameters
pDataProvider | Pointer to the custom data provider object.
bCloseDataProviderWhenDestroy | If this parameter is TRUE, the Close method of the data provided will be called on this resource destruction.

Call this member function to set the custom data provider that is currently used by this calendar control. Note that custom data provider must be a descendant of CXTPCalendarData.

See also
CXTPCalendarData overview
GetDataProvider

◆ SetName()

AFX_INLINE void SetName ( LPCTSTR pcszResourceName )
virtual

This member function applies a new name to the resource object.

Parameters
pcszResourceName A string with the new name for the resource.
See also
GetName
The documentation for this class was generated from the following file:
  • XTPCalendarResource.h


Toolkit Pro: CXTPCalendarResourceDescription Class Reference

Public Member Functions | Public Attributes | List of all members
CXTPCalendarResourceDescription Class Reference

This class is a wrapper for CXTPCalendarResource class. More...

Inheritance diagram for CXTPCalendarResourceDescription:
[legend]

Public Member Functions

CXTPCalendarResourceDescription ()
Default object constructor.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Public Attributes

BOOL | m_bEnabled
This flag indicates is resource enabled.
BOOL | m_bGenerateName
This flag indicates that resource name should be generated from the schedule(s) name(s).
CXTPCalendarResourcePtr | m_ptrResource
A smart pointer to the resource object.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

This class is a wrapper for CXTPCalendarResource class.

It is needed for easier processing in scope of CXTPCalendarResourcesManager.

The documentation for this class was generated from the following file:
  • XTPCalendarResourcesManager.h


Toolkit Pro: CXTPCalendarResources Class Reference

Public Member Functions | List of all members
CXTPCalendarResources Class Reference

This class represents a simple array collection of CXTPCalendarResource objects. More...

Inheritance diagram for CXTPCalendarResources:
[legend]

Public Member Functions

CXTPCalendarResources ()
Default collection constructor.
virtual | ~CXTPCalendarResources ()
Default collection destructor.
CXTPCalendarResource * | Find (CXTPCalendarEvent *pEvent) const
This member function is used to remove events which are not from this resource.
CXTPCalendarEventsPtr | RetrieveDayEvents (COleDateTime dtDay) const
This member function is used to remove events which are not from this resource.
- Public Member Functions inherited from CXTPCalendarPtrCollectionT< CXTPCalendarResource >
CXTPCalendarPtrCollectionT ()
Default collection constructor.
virtual | ~CXTPCalendarPtrCollectionT ()
Default collection destructor.
virtual int | GetCount () const
This member function is used to obtain the number of elements in the collection.
virtual void | Add (CXTPCalendarResource *pNewElement)
This member function adds a new element to the end of the array.
virtual void | Add (CXTPCalendarResource *pNewElement, BOOL bWithAddRef)
This member function adds a new element to the end of the array.
virtual void | SetAt (int nIndex, CXTPCalendarResource *pElement)
This member function is used to set a new element to the position specified in the nIndex parameter.
virtual int | Find (const CXTPCalendarResource *pElement) const
This member function finds an element index in the collection using its pointer.
virtual void | InsertAt (int nIndex, CXTPCalendarResource *pElement)
This member function is used to insert a new element at the position specified in the nIndex parameter.
virtual void | Append (const CXTPCalendarPtrCollectionT< CXTPCalendarResource > *pElementsArray)
This member function is used to add a new elements to the end of the array.
virtual void | SetSize (int nNewSize)
This member function is used to change the array size.
virtual CXTPCalendarResource * | GetAt (int nIndex) const
This member function returns an element at the specified numeric index.
virtual CXTPCalendarResource * | GetAt (int nIndex, BOOL bWithAddRef) const
This member function returns an element at the specified numeric index.
virtual void | RemoveAt (int nIndex)
This member function removes an element at the specified index from the array.
virtual void | Remove (CXTPCalendarResource *pElement)
This member function finds an element using its pointer and removes it from the array.
virtual void | RemoveAll ()
This member function is used to remove all of the elements from the array.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Types inherited from CXTPCalendarPtrCollectionT< CXTPCalendarResource >
typedef CXTPSmartPtrInternalT< CXTPCalendarResource > | TObjectPtr
Smart pointer type for stored objects.
- Protected Attributes inherited from CXTPCalendarPtrCollectionT< CXTPCalendarResource >
CArray< TObjectPtr, TObjectPtr & > | m_arElements
Objects storage.

Detailed Description

This class represents a simple array collection of CXTPCalendarResource objects.

See also
CXTPCalendarPtrCollectionT

Constructor & Destructor Documentation

◆ CXTPCalendarResources()

CXTPCalendarResources ( )

Default collection constructor.

See also
~CXTPCalendarResources()

◆ ~CXTPCalendarResources()

virtual ~CXTPCalendarResources ( )
virtual

Default collection destructor.

Handles member item deallocation. Decreases reference of all stored CXTPCalendarResource objects.

See also
RemoveAll()

Member Function Documentation

◆ Find()

CXTPCalendarResource * Find ( CXTPCalendarEvent * pEvent ) const

This member function is used to remove events which are not from this resource.

Parameters
pEvent A pointer to a CXTPCalendarEvent.
Returns
A pointer to the calendar resource.
See also
ExistsScheduleID

◆ RetrieveDayEvents()

CXTPCalendarEventsPtr RetrieveDayEvents ( COleDateTime dtDay ) const

This member function is used to remove events which are not from this resource.

Parameters
dtDay COleDateTime.
Returns
A calendar events pointer object.
See also
ExistsScheduleID
The documentation for this class was generated from the following file:
  • XTPCalendarResource.h


Toolkit Pro: CXTPCalendarResourcesManager Class Reference

Public Types | Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPCalendarResourcesManager Class Reference

This class is used as a helper to manage calendar resources (and schedules) data configurations. More...

Inheritance diagram for CXTPCalendarResourcesManager:
[legend]

Public Types

enum XTPEnumCalendarDataProviderFlags { xtpCalendarDPFUnknown = 0 , xtpCalendarDPF_CreateIfNotExists = 0x001 , xtpCalendarDPF_SaveOnDestroy = 0x010 , xtpCalendarDPF_CloseOnDestroy = 0x020 }
This enum specifies data provider flags. More...

Public Member Functions

CXTPCalendarResourcesManager ()
Default object constructor.
virtual | ~CXTPCalendarResourcesManager ()
Default object destructor.
BOOL | AddDataProvider (LPCTSTR pcszConnectionString, int eDPFlags=xtpCalendarDPF_CreateIfNotExists)
Adds a new data provider to the data providers collection using a specified Calendar connection string.
BOOL | SetDataProvider (int nIndex, LPCTSTR pcszConnectionString, int eDPFlags=xtpCalendarDPF_CreateIfNotExists)
Set a new data provider to data providers collection using specified Calendar connection string.
int | GetDataProvidersCount () const
Retrieve data providers count in the collection.
CXTPCalendarData * | GetDataProvider (int nIndex) const
Retrieve data provider at specified index.
void | RemoveDataProvider (int nIndex)
Remove data provider at specified index.
CXTPCalendarData * | GetDataProvider (LPCTSTR pcszConnectionString, int *pnIndex=NULL) const
Call this method to find a data provider by a connection string.
CString | GetDataProvider_ConnStr (int nIndex) const
Retrieve a text Calendar connection string for data provider at specified index.
BOOL | AddResource (LPCTSTR pcszName, BOOL bEnabled)
Adds a new data resource to the calendar resources collection.
int | GetResourcesCount () const
Retrieve the calendar data resources count for the collection.
CXTPCalendarResourceDescription * | GetResource (int nIndex) const
Retrieve resource at specified index.
void | RemoveResource (int nIndex)
Remove resource at specified index.
void | MoveResource (int nIndex, int nNewIndex)
Move resource to a new position in the collection.
void | DoExchangeCfg (CXTPPropExchange *pPX)
This method reads data providers and resources configuration from or writes data providers and resources configuration to storage.
BOOL | SaveCfg (LPCTSTR pcszFile)
This method writes data providers and resources configuration to a specified file.
BOOL | LoadCfg (LPCTSTR pcszFile)
This method loads data providers and resources configuration from a specified file.
void | ApplyToCalendar (CXTPCalendarControl *pCalendar)
Set the active configuration (enabled resources) to calendar control.
void | RemoveAll ()
Remove all resources and all data providers.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

void | _Save (CXTPPropExchange *pPX)
This method saves data providers and resources configuration to storage.
void | _Load (CXTPPropExchange *pPX)
This method loads data providers and resources configuration from storage.
void | _SaveCloseDPifNeed (CXTPCalendarData *pData)
This method is called to Save and Close data provider if these actions were specified in AddDataProvider or SetDataProvider methods.

Protected Attributes

CXTPCalendarPtrCollectionT< CXTPCalendarData > | m_arDataProviders
Data providers collection.
CXTPCalendarPtrCollectionT< CXTPCalendarResourceDescription > | m_arResources
Resources collection.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

This class is used as a helper to manage calendar resources (and schedules) data configurations.

Member Enumeration Documentation

◆ XTPEnumCalendarDataProviderFlags

enum XTPEnumCalendarDataProviderFlags

This enum specifies data provider flags.

Enumerator
xtpCalendarDPFUnknown | Zero value flag.
xtpCalendarDPF_CreateIfNotExists | Call Create method of data provider if Open method returns FALSE.
xtpCalendarDPF_SaveOnDestroy | Call Save method of data provider on Resources Manager destroy.
xtpCalendarDPF_CloseOnDestroy | Call Close method of data provider on Resources Manager destroy.

Member Function Documentation

◆ _Load()

void _Load ( CXTPPropExchange * pPX )
protected

This method loads data providers and resources configuration from storage.

Parameters
pPX A CXTPPropExchange object to serialize from.
See also
_Save
LoadCfg
SaveCfg
DoExchangeCfg

◆ _Save()

void _Save ( CXTPPropExchange * pPX )
protected

This method saves data providers and resources configuration to storage.

Parameters
pPX A CXTPPropExchange object to serialize to.
See also
_Load
LoadCfg
SaveCfg
DoExchangeCfg

◆ _SaveCloseDPifNeed()

void _SaveCloseDPifNeed ( CXTPCalendarData * pData )
protected

This method is called to Save and Close data provider if these actions were specified in AddDataProvider or SetDataProvider methods.

Parameters
pData A pointer to data provider object.
See also
AddDataProvider
SetDataProvider
XTPEnumCalendarDataProviderFlags.

◆ AddDataProvider()

BOOL AddDataProvider | ( | LPCTSTR | pcszConnectionString,
 |  | int | eDPFlags = xtpCalendarDPF_CreateIfNotExists )

Adds a new data provider to the data providers collection using a specified Calendar connection string.

Parameters
pcszConnectionString | A text Calendar connection string.
eDPFlags | Additional flags to control data provider creation/Opening and destruction/Closing.
Returns
TRUE if operation is successful, FALSE otherwise.
See also
SetDataProvider
XTPEnumCalendarDataProviderFlags
CXTPCalendarControl::CreateDataProvider
CXTPCalendarData overview

◆ AddResource()

BOOL AddResource | ( | LPCTSTR | pcszName,
 |  | BOOL | bEnabled )

Adds a new data resource to the calendar resources collection.

Parameters
pcszName | Resource name string.
bEnabled | Is resource enabled.
Returns
TRUE if operation is successful, FALSE otherwise.
See also
GetResourcesCount
GetResource
RemoveResource
MoveResource

◆ ApplyToCalendar()

void ApplyToCalendar ( CXTPCalendarControl * pCalendar )

Set the active configuration (enabled resources) to calendar control.

Parameters
pCalendar A pointer to calendar control.
See also
CXTPCalendarControl::SetResources

◆ DoExchangeCfg()

void DoExchangeCfg ( CXTPPropExchange * pPX )

This method reads data providers and resources configuration from or writes data providers and resources configuration to storage.

Parameters
pPX A CXTPPropExchange object to serialize to or from.
See also
SaveCfg
LoadCfg

◆ GetDataProvider() [1/2]

CXTPCalendarData * GetDataProvider ( int nIndex ) const

Retrieve data provider at specified index.

Parameters
nIndex Zero-based data provider index in the collection.
Returns
Data provider at specified index.
See also
GetDataProvidersCount
AddDataProvider
SetDataProvider
RemoveDataProvider

◆ GetDataProvider() [2/2]

CXTPCalendarData * GetDataProvider | ( | LPCTSTR | pcszConnectionString,
 |  | int * | pnIndex = NULL ) const

Call this method to find a data provider by a connection string.

Parameters
pcszConnectionString | A text Calendar connection string.
pnIndex | A pointer to receive data provider index in the collection.
Returns
Pointer to a data provider with specified connection string if such presents in the collection, NULL otherwise.
See also
GetDataProvider_ConnStr

◆ GetDataProvider_ConnStr()

CString GetDataProvider_ConnStr ( int nIndex ) const

Retrieve a text Calendar connection string for data provider at specified index.

Parameters
nIndex Zero-based data provider index in the collection.
Returns
A text Calendar connection string.
See also
GetDataProvider

◆ GetDataProvidersCount()

int GetDataProvidersCount ( ) const

Retrieve data providers count in the collection.

Returns
Data providers count.
See also
GetDataProvider
AddDataProvider
SetDataProvider
RemoveDataProvider

◆ GetResource()

CXTPCalendarResourceDescription * GetResource ( int nIndex ) const

Retrieve resource at specified index.

Parameters
nIndex Zero-based resource index in the collection.
Returns
Calendar resource at specified index.
See also
AddResource
GetResourcesCount
RemoveResource
MoveResource

◆ GetResourcesCount()

int GetResourcesCount ( ) const

Retrieve the calendar data resources count for the collection.

Returns
Calendar data resources count for the collection.
See also
AddResource
GetResourcesCount
RemoveResource
MoveResource

◆ LoadCfg()

BOOL LoadCfg ( LPCTSTR pcszFile )

This method loads data providers and resources configuration from a specified file.

Parameters
pcszFile A file name to load configuration.
Returns
TRUE if operation is successful, FALSE otherwise.
See also
SaveCfg
DoExchangeCfg

◆ MoveResource()

void MoveResource | ( | int | nIndex,
 |  | int | nNewIndex )

Move resource to a new position in the collection.

Parameters
nIndex | Current zero-based resource index in the collection.
nNewIndex | A new index to move resource to.
See also
AddResource
GetResourcesCount
GetResource
RemoveResource

◆ RemoveAll()

void RemoveAll ( )

Remove all resources and all data providers.

Data providers will be saved and closed if this was specified for them.

See also
XTPEnumCalendarDataProviderFlags

◆ RemoveDataProvider()

void RemoveDataProvider ( int nIndex )

Remove data provider at specified index.

Parameters
nIndex Zero-based data provider index in the collection.
See also
GetDataProvidersCount
GetDataProvider
AddDataProvider
SetDataProvider

◆ RemoveResource()

void RemoveResource ( int nIndex )

Remove resource at specified index.

Parameters
nIndex Zero-based resource index in the collection.
See also
AddResource
GetResourcesCount
GetResource
MoveResource

◆ SaveCfg()

BOOL SaveCfg ( LPCTSTR pcszFile )

This method writes data providers and resources configuration to a specified file.

Parameters
pcszFile A file name to store configuration.
Returns
TRUE if operation is successful, FALSE otherwise.
See also
LoadCfg
DoExchangeCfg

◆ SetDataProvider()

BOOL SetDataProvider | ( | int | nIndex,
 |  | LPCTSTR | pcszConnectionString,
 |  | int | eDPFlags = xtpCalendarDPF_CreateIfNotExists )

Set a new data provider to data providers collection using specified Calendar connection string.

Parameters
nIndex | Index of the data provider in the collection.
pcszConnectionString | A text Calendar connection string.
eDPFlags | Additional flags to control data provider creation/Opening and destruction/Closing.
Returns
TRUE if operation is successful, FALSE otherwise.
See also
AddDataProvider, XTPEnumCalendarDataProviderFlags, CXTPCalendarControl::CreateDataProvider, CXTPCalendarData overview.
The documentation for this class was generated from the following file:
  • XTPCalendarResourcesManager.h


Toolkit Pro: CXTPCalendarResourcesNf Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPCalendarResourcesNf Class Reference

This class implements CXTPCalendarResource functionality with the addition of a notifications mechanism implemented by CXTPNotifySink. More...

Inheritance diagram for CXTPCalendarResourcesNf:
[legend]

Public Member Functions

CXTPCalendarResourcesNf ()
Default object constructor.
virtual | ~CXTPCalendarResourcesNf ()
Default class destructor.
CXTPNotifyConnection * | GetConnection () const
Obtain a pointer to the notification connection object.
virtual void | ReBuildInternalData ()
Rebuilds notification connection objects after changes in resources configuration.
virtual const CXTPCalendarResources * | GetResourcesGroupedByDP () const
Call this member function to retrieve a resources collection only for unique data providers.
CXTPCalendarResource * | FindByDataProvider (CXTPCalendarData *pData) const
Call this member function to retrieve a resource object for a specified data provider.
- Public Member Functions inherited from CXTPCalendarResources
CXTPCalendarResources ()
Default collection constructor.
virtual | ~CXTPCalendarResources ()
Default collection destructor.
CXTPCalendarResource * | Find (CXTPCalendarEvent *pEvent) const
This member function is used to remove events which are not from this resource.
CXTPCalendarEventsPtr | RetrieveDayEvents (COleDateTime dtDay) const
This member function is used to remove events which are not from this resource.
- Public Member Functions inherited from CXTPCalendarPtrCollectionT< CXTPCalendarResource >
CXTPCalendarPtrCollectionT ()
Default collection constructor.
virtual | ~CXTPCalendarPtrCollectionT ()
Default collection destructor.
virtual int | GetCount () const
This member function is used to obtain the number of elements in the collection.
virtual void | Add (CXTPCalendarResource *pNewElement)
This member function adds a new element to the end of the array.
virtual void | Add (CXTPCalendarResource *pNewElement, BOOL bWithAddRef)
This member function adds a new element to the end of the array.
virtual void | SetAt (int nIndex, CXTPCalendarResource *pElement)
This member function is used to set a new element to the position specified in the nIndex parameter.
virtual int | Find (const CXTPCalendarResource *pElement) const
This member function finds an element index in the collection using its pointer.
virtual void | InsertAt (int nIndex, CXTPCalendarResource *pElement)
This member function is used to insert a new element at the position specified in the nIndex parameter.
virtual void | Append (const CXTPCalendarPtrCollectionT< CXTPCalendarResource > *pElementsArray)
This member function is used to add a new elements to the end of the array.
virtual void | SetSize (int nNewSize)
This member function is used to change the array size.
virtual CXTPCalendarResource * | GetAt (int nIndex) const
This member function returns an element at the specified numeric index.
virtual CXTPCalendarResource * | GetAt (int nIndex, BOOL bWithAddRef) const
This member function returns an element at the specified numeric index.
virtual void | RemoveAt (int nIndex)
This member function removes an element at the specified index from the array.
virtual void | Remove (CXTPCalendarResource *pElement)
This member function finds an element using its pointer and removes it from the array.
virtual void | RemoveAll ()
This member function is used to remove all of the elements from the array.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

virtual void OnEvent (XTP_NOTIFY_CODE dwNotifyCode, WPARAM wParam, LPARAM lParam, DWORD dwFlags)
This member function catches all the events from the associated data provider and forwards it to CXTPCalendarResourcesNf subscribers.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Types inherited from CXTPCalendarPtrCollectionT< CXTPCalendarResource >
typedef CXTPSmartPtrInternalT< CXTPCalendarResource > | TObjectPtr
Smart pointer type for stored objects.
- Protected Attributes inherited from CXTPCalendarPtrCollectionT< CXTPCalendarResource >
CArray< TObjectPtr, TObjectPtr & > | m_arElements
Objects storage.

Detailed Description

This class implements CXTPCalendarResource functionality with the addition of a notifications mechanism implemented by CXTPNotifySink.

See also
CXTPCalendarResource overview
CXTPNotifySink overview

Constructor & Destructor Documentation

◆ CXTPCalendarResourcesNf()

CXTPCalendarResourcesNf ( )

Default object constructor.

Constructs a CXTPCalendarResourcesNf object.

See also
~CXTPCalendarResourcesNf

◆ ~CXTPCalendarResourcesNf()

virtual ~CXTPCalendarResourcesNf ( )
virtual

Default class destructor.

Handles member items deallocation.

See also
CXTPCalendarResourcesNf

Member Function Documentation

◆ FindByDataProvider()

AFX_INLINE CXTPCalendarResource * FindByDataProvider ( CXTPCalendarData * pData ) const

Call this member function to retrieve a resource object for a specified data provider.

This method returns a resource from a temporary internal collection.

Parameters
pData pointer to CXTPCalendarData.
Returns
A pointer to the internal resource from collection which is rebuilt during the ReBuildInternalData method execution.
See also
GetResourcesGroupedByDP
ReBuildInternalData

◆ GetConnection()

AFX_INLINE CXTPNotifyConnection * GetConnection ( ) const

Obtain a pointer to the notification connection object.

Used to subscribe (Advice) for notification events from the control.

Returns
Connection object pointer.
See also
CXTPNotifyConnection overview
IXTPNotificationSink overview

◆ GetResourcesGroupedByDP()

AFX_INLINE const CXTPCalendarResources * GetResourcesGroupedByDP ( ) const
virtual

Call this member function to retrieve a resources collection only for unique data providers.

This method returns a collection of temporary resources objects having only unique data providers. It could be useful to retrieve a complete collection of events for further processing from all data providers in scope of resources collection, and in order not to retrieve duplicate events.

Returns
A pointer to the internal resources collection which is rebuilt during the ReBuildInternalData method execution.
See also
ReBuildInternalData

◆ OnEvent()

virtual void OnEvent | ( | XTP_NOTIFY_CODE | dwNotifyCode,
 |  | WPARAM | wParam,
 |  | LPARAM | lParam,
 |  | DWORD | dwFlags )
 protectedvirtual

This member function catches all the events from the associated data provider and forwards it to CXTPCalendarResourcesNf subscribers.

Parameters
dwNotifyCode | Events notification code.
wParam | First user's parameter.
lParam | Second user's parameter.
dwFlags | Unused parameter.

Implements CXTPNotifySinkBase.

◆ ReBuildInternalData()

virtual void ReBuildInternalData ( )
virtual

Rebuilds notification connection objects after changes in resources configuration.

Call this member function after advising to notifications from connection pointers of the CXTPCalendarResourcesNf object.

See also
GetConnection
GetResourcesGroupedByDP
The documentation for this class was generated from the following file:
  • XTPCalendarResource.h


Toolkit Pro: CXTPCalendarResourceTheme Class Reference

Public Member Functions | List of all members
CXTPCalendarResourceTheme Class Reference

CXTPCalendarResourceTheme is a CXTPCalendarPaintManager derived class that represents the Resource calendar theme. More...

Inheritance diagram for CXTPCalendarResourceTheme:
[legend]

Public Member Functions

CXTPCalendarResourceTheme ()
Default paint manager constructor.
virtual | ~CXTPCalendarResourceTheme ()
Default paint manager destructor.
virtual void | RefreshMetrics ()
This member function is used to initialize all drawing defaults.
- Public Member Functions inherited from CXTPCalendarPaintManager
BEGIN_VIEW_PART (ControlPart, XTPCalendarViewPart) virtual void RefreshMetrics()
Paint manager's ControlPart is used as parent for the other parts of the control.
END_VIEW_PART (ControlPart) BEGIN_VIEW_PART(DayViewTimeScaleHeaderPart
This paint manager part is used to draw the time scale header, 'Now' line, and the expand signs for the Day View.
virtual void | OnDraw (CDC *pDC, CXTPCalendarDayView *pView, CRect rc, CString strText)
This member function is used to draw the time scale header.
virtual void | DrawNowLine (CDC *pDC, CXTPCalendarDayView *pView, CRect rc, int y, BOOL bDrawBk=FALSE)
This member function is used to draw the 'Now' line.
virtual void | DrawNowLine (CDC *pDC, CXTPCalendarDayView *pView, CXTPCalendarDayViewTimeScale *pScale, CRect rc, int y, BOOL bDrawBk=FALSE)
This member function is used to draw the 'Now' line.
virtual void | DrawExpandSigns (CDC *pDC, CXTPCalendarDayView *pView, const CRect &rcTSHours)
This member function is used to draw expand signs.
END_VIEW_PART (DayViewTimeScaleHeaderPart) BEGIN_VIEW_PART(DayViewTimeScaleCellPart
This paint manager part is used to draw time scale time cells for the Day View.
void | AdjustTimeFont (CDC *pDC, CRect rcCell)
This member function is used to adjust the time text font size.
void | CalcWidth (CDC *pDC, const CString &strHour, const CString &strMin, int nHourHeight, int &nWidth)
This member function is used to adjust the time text font size.
virtual void | DrawHourCell (CDC *pDC, CRect rc, CString strText, BOOL bFillBackground=TRUE, BOOL bCurrentTime=FALSE)
This member function is used to draw background of the time scale header.
virtual void | DrawBigHourCell (CDC *pDC, CRect rc, CString strHour, CString strMin, int nRowPerHour, BOOL bFillBackground=TRUE, BOOL bCurrentTime=FALSE)
This member function is used to draw the big hour cell.
END_VIEW_PART (DayViewTimeScaleCellPart) BEGIN_VIEW_PART(DayViewCellPart
This paint manager part is used as the base class for the parts which draw different kinds of no all-day-cells (work/non-work) for the Day View.
virtual void | GetParams (CXTPCalendarDayViewGroup *pViewGroup, XTP_CALENDAR_DAYVIEWCELL_PARAMS *rCellParams)
This member function is used to fill out cell parameters with default values.
virtual void | OnDraw (CDC *pDC, CXTPCalendarDayViewGroup *pViewGroup, CRect rc, const XTP_CALENDAR_DAYVIEWCELL_PARAMS &cellParams)
This member function is used to draw the day view with no all-day-cells.
END_VIEW_PART (DayViewCellPart) BEGIN_VIEW_PART(DayViewWorkCellPart
This paint manager part is used to draw a day view that contains no all day work time cells.
END_VIEW_PART (DayViewWorkCellPart) BEGIN_VIEW_PART(DayViewNonworkCellPart
This paint manager part is used to draw "no all day non-work" time cells for the Day View.
END_VIEW_PART (DayViewNonworkCellPart) BEGIN_VIEW_PART(DayMonthViewHeaderPart
This paint manager part is used to draw days headers for the Day View.
END_VIEW_PART (DayMonthViewHeaderPart) BEGIN_VIEW_PART(DayViewHeaderPart
This paint manager part is used to draw days headers for the Day View.
virtual DayMonthViewHeaderPart void | OnDraw (CDC *pDC, CXTPCalendarDayViewDay *pViewDay, CRect rc, CString strText)
This member function is used to draw the day header.
END_VIEW_PART (DayViewHeaderPart) BEGIN_VIEW_PART(DayViewGroupHeaderPart
This paint manager part is used to draw Groups headers for the Day View.
virtual DayMonthViewHeaderPart void | OnDraw (CDC *pDC, CXTPCalendarDayViewGroup *pViewGroup, CRect rc, CString strText)
This member function is used to draw the day header.
END_VIEW_PART (DayViewGroupHeaderPart) BEGIN_VIEW_PART(DayViewAllDayEventsPart
This paint manager part is used to draw all day events area for the Day View.
virtual void | OnDraw (CDC *pDC, CXTPCalendarDayViewGroup *pViewGroup, CRect rc, BOOL bSelected)
This member function is used to draw the all-day events area.
END_VIEW_PART (DayViewAllDayEventsPart) BEGIN_VIEW_PART(DayViewAllDayEventScrollIconsPart
This paint manager part is used to draw all day events scroll buttons if there are too many all day events.
virtual XTPCalendarViewPart void | OnDraw (CDC *pDC, CXTPCalendarDayViewGroup *pViewGroup, BOOL bDrawUp, BOOL bDrawDown, const CRect &rcIconUp, const CRect &rcIconDown, BOOL bHighlightUp, BOOL bHighlightDown)
This member function is used to draw scroll icons in all day events area.
END_VIEW_PART (DayViewAllDayEventScrollIconsPart) BEGIN_VIEW_PART(DayViewEventPart
This paint manager part is used to draw events for the Day View.
virtual void | OnDraw (CDC *pDC, CXTPCalendarDayViewEvent *pViewEvent)
This member function is used to draw an event.
END_VIEW_PART (DayViewEventPart) BEGIN_VIEW_PART(MonthViewGridPart
This paint manager part is used to draw days grid and to fill days cells background for the Month View.
virtual void | OnDrawGrid (CDC *pDC, CXTPCalendarMonthView *pMonthView)
This member function is used to draw the days grid and to fill the days cells background.
END_VIEW_PART (MonthViewGridPart) BEGIN_VIEW_PART(MonthViewHeaderPart
This paint manager part is used to draw week days headers for the Month View.
virtual DayMonthViewHeaderPart void | OnDraw (CDC *pDC, CXTPCalendarMonthView *pMonthView, CRect rc, int nCollIndex, CString strText)
This member function is used to draw the week day header.
END_VIEW_PART (MonthViewHeaderPart) BEGIN_VIEW_PART(MonthViewEventPart
This paint manager part is used to draw events and day dates for the Month View.
virtual void | OnDrawEvent (CDC *pDC, CXTPCalendarMonthViewEvent *pViewEvent)
This member function is used to draw an event.
virtual void | OnDrawDayDate (CDC *pDC, CRect rc, BOOL bToday, BOOL bSelected, BOOL bFirstMonthDay, CString strText)
This member function is used to draw the week day header.
END_VIEW_PART (MonthViewEventPart) BEGIN_VIEW_PART(WeekViewPart
This paint manager part is used to draw week days grid and headers for the Week View.
virtual void | OnDraw (CDC *pDC, CXTPCalendarWeekView *pWeekView)
This member function is used to draw an event.
virtual void | DrawDayHeader (CDC *pDC, CRect rcDay, int nHeaderHeight, CString strHeader, BOOL bIsCurrent=FALSE, BOOL bIsSelected=FALSE)
This member function is used to draw the day header.
END_VIEW_PART (WeekViewPart) BEGIN_VIEW_PART(WeekViewEventPart
This paint manager part is used to draw events for the Week View.
virtual void | OnDraw (CDC *pDC, CXTPCalendarWeekViewEvent *pWeekViewEvent)
This member function is used to draw the specified event.
virtual void | DrawBorder (CDC *pDC, CRect rcView, CXTPCalendarWeekViewEvent *pWeekViewEvent)
This member functions is used to draw the event border.
virtual int | DrawTimes (CDC *pDC, CXTPCalendarWeekViewEvent *pWeekViewEvent)
This member function is used to draw the event's times texts or icons.
virtual void | DrawSubj (CDC *pDC, CXTPCalendarWeekViewEvent *pWeekViewEvent)
This member function is used to draw the event subject.
END_VIEW_PART (WeekViewEventPart) BEGIN_VIEW_PART(TimeLineViewTimeScalePart_Day
This paint manager part is used to draw time scale for the Time Line view.
virtual void | DrawGroup (CDC *pDC, const CRect &rcRect, CXTPCalendarTimeLineViewGroup *pGroup)
Call this function to draw the time line view group.
virtual CSize | CalcEventSize (CDC *c, CXTPCalendarTimeLineViewEvent *pViewEvent)
Call this function to calculate the time line view event size.
virtual void | DrawEvent (CDC *pDC, const CRect &rcEvents, CXTPCalendarTimeLineViewEvent *pViewEvent)
Call this function to draw the event.
virtual void | _Init ()
Call this function to do the initializations.
virtual | ~CTimeLineViewPart ()
Destroys the CTimeLineViewPart object, does the cleanup.
CXTPCalendarPaintManager ()
Default paint manager constructor.
virtual | ~CXTPCalendarPaintManager ()
Default paint manager destructor.
virtual void | UpdateEventLabelsDefaultColors ()
This member function is called to update event label default colors.
virtual void | UpdateEventCategoriesDefaultColors ()
This member function is called to update event category default colors.
virtual XTPCalendarTheme | GetPaintTheme () const
This member function is used to obtain the current paint theme.
virtual void | SetPaintTheme (XTPCalendarTheme ePaintTheme)
This member function is used to set the current paint theme.
virtual void | UpdateGlyphs ()
Initializes Calendar images.
virtual COLORREF | GetEventBackColor (CXTPCalendarEvent *pEvent, COLORREF crDefault)
Call this member function to get the background color for the specified event.
virtual void | DrawLine (CDC *pDC, int xPos, int yPos, int cx, int cy)
This member function is used to draw an arbitrary line.
virtual void | DrawHorizontalLine (CDC *pDC, int xPos, int yPos, int cx)
This member function is used to draw a Horizontal line.
virtual void | DrawVerticalLine (CDC *pDC, int xPos, int yPos, int cy)
This member function is used to draw a Vertical line.
virtual int | DrawClock (CDC *pDC, COleDateTime dtClockTime, CRect rcView, COLORREF clrBackground, XTPCalendarClockAlignFlags cafAlign)
This member function is used to draw the time as a clock.
virtual int | DrawBitmap (CImageList *pImageList, CDC *pDC, CRect rcView, int iIcon, UINT uFlags=0)
This member function is used to draw a bitmap from the provided ImageList.
virtual int | DrawBitmap (UINT nIDResource, CDC *pDC, CRect rcBitmap)
This member function is used to draw the bitmap using its resource id.
virtual int | DrawIconChar (CDC *pDC, CRect rc, TCHAR ch)
This member function is used to draw the Glyph symbol using special font.
virtual const CSize | GetExpandSignSize ()
This member function is used to obtain the horizontal and vertical size of the Expand Sign bitmap.
virtual CSize | GetClockSize ()
This member function is used to obtain the horizontal and vertical size of the Clock.
virtual void | SetControl (CXTPCalendarControl *pControl)
This member function is used to set the CXTPCalendarControl object for the CXTPCalendarPaintManager.
virtual void | DrawShadow (CDC *pDC, const CRect &rcRect)
Call this member function to draw the shadow regions around the rectangle.
virtual int | DrawIcons (CDC *pDC, CXTPCalendarViewEvent *pViewEvent)
Call this member function to draw icons corresponding to the event state.
virtual void | DrawHeader (CDC *pDC, CRect &rcHeader, BOOL bIsSelected, BOOL bIsCurrent)
This member function is used to draw the Header.
virtual void | DrawHeader (CDC *pDC, CRect &rcHeader, BOOL bIsSelected, BOOL bIsCurrent, const CXTPPaintManagerColorGradient &grclr, COLORREF clrUnderLineHdr)
This member function is used to draw the Header.
virtual void | DrawBusyStatus (CDC *pDC, CRect &rcRect, int eBusyStatus)
This member function is used to fill the area using the corresponding busy color or pattern.
virtual void | DrawBusyStatus (CDC *pDC, CRgn &rgnBusy, int eBusyStatus)
This member function is used to fill the area using the corresponding busy color or pattern.
void | EnableTheme (BOOL bEnableTheme)
This member function is used to enable a new theme.
BOOL | IsThemeEnabled ()
This member function is used to obtain the status of the theme.
XTPCurrentSystemTheme GetCurrentSystemTheme ()
Call this member function to determine the current Windows XP theme that is in use.
void | SetBusyStatusBrush (int nBusyStatus, CBrush *pBrush, BOOL bAutodeleteBrush)
Call this member function to set custom brush to draw event busy status.
CBrush * | GetBusyStatusBrush (int nBusyStatus)
Call this member function to get a brush to draw event busy status.
DWORD | GetAskItemTextFlags () const
This member function returns a set of flags which define calendar items to send an XTP_NC_CALENDAR_GETITEMTEXT notification.
void | SetAskItemTextFlags (DWORD dwFlags)
This member function is used to set flags which define calendar items to send an XTP_NC_CALENDAR_GETITEMTEXT notification.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPCalendarPaintManager
DayViewTimeScaleHeaderPart CXTPCalendarViewPartFontValue | m_fntTimeText
Time text font.
int | m_nHourWidth
Width of hour part of the text in pixels.
int | m_nMinWidth
Width of minutes (am/pm) part of the text in pixels.
BOOL | m_bShowMinutes
Show minutes in TS when '60 Minutes' is selected.
XTPCalendarViewPart CXTPPaintManagerColor | m_clrBackgroundSlave
Background secondary color.
CXTPPaintManagerColor | m_clrShadow
Cell background color.
CXTPPaintManagerColor | m_clrHour
Cell border color.
XTPCalendarViewPart CXTPPaintManagerColor | m_clrBackground2
Second background color which is used to fill days background.
XTPCalendarViewPart COLORREF | m_clrTextHighLightColor
Text color for the selected event.
COLORREF | m_clrMultiDayEventFrameColor
Multi-day event frame color.
COLORREF | m_clrClassicUnderline
Underline color for today day.
CXTPPaintManagerColorGradient | m_grclrClassicSelDay
Gradient color for today day.
COLORREF | m_clrTextNormalColor
Text color for the day header and some other elements.
COLORREF | m_clrHeaderBottomLine
Text color for the day header bottom line.
XTPCalendarTimeLineViewPart CXTPPaintManagerColor | m_clrEventBar
Event bar color.
CXTPPaintManagerColor m_clrEventBarLine
Event bar line color.
CXTPPaintManagerColor | m_clrEventBorderLine
Event border line color.
CXTPPaintManagerColor | m_clrTimeScaleBackground
Time scale background color.
CXTPPaintManagerColor | m_clrTimeScaleHightlite
Time scale highlight color.
CXTPPaintManagerColor m_clrTimeScaleText
The time scale text color.
CXTPPaintManagerColor | m_clrSelectedBackground
The selected background color.
CXTPPaintManagerColor m_clrSelectedText
The selected text color.
CXTPPaintManagerColor | m_clrBackground
The background color.
CXTPPaintManagerColor | m_clrText
The text color.
CXTPPaintManagerColor | m_clrWeekendBackground
Time scale weekend background color.
CXTPPaintManagerColor m_clrButtonFace
Stores standard Button Face color.
CXTPPaintManagerColor | m_clrButtonFaceText
Stores standard color to display text.
CXTPPaintManagerColor m_clrWindow
Stores standard windows color.
CXTPPaintManagerColor m_clrWindowText
Stores standard color to display window text.
CXTPPaintManagerColor m_clr3DShadow
Stores standard color to display shadow items.
CXTPPaintManagerColor | m_clrHighlight
Stores standard color to display highlighted items.
CXTPPaintManagerColor | m_clrBorders [4]
Stores border line color, left = 0, top = 1, right = 2, bottom = 3.
CXTPPaintManagerColorGradient | m_grclrToday
Gradient color of today's header.
CUIntArray | m_arStartCol
hold start column in each virtual page
CUIntArray | m_arStartRow
hold start row in each virtual page

int | m_PrintPageWidth
Print page width.
- Protected Types inherited from CXTPCalendarPaintManager
enum | XTPEnumExpandSigns { idxExpandSignUp = 0 , idxExpandSignDown = 1 }
Enumerates types of expand signs drawn on a day view. More...
enum XTPEnumEventGlyphs {
idxMeeting = 0 , idxPrivate = 1 , idxRecurrenceException = 2 , idxRecurrenceOccurrence = 3 ,
idxReminder = 4
}
Enumerates types of event glyphs. More...
- Protected Member Functions inherited from CXTPCalendarPaintManager
CXTPCalendarViewPart * | AddViewPart (CXTPCalendarViewPart *pPart)
Call this member function to add the specified ViewPart object to the parts list.
CXTPCalendarViewPartBrushValue * | _GetAtGrow_BusyStatusBrushValue (int eBusyStatus, BOOL bGrow)
Returns drawing brush value for a specific busy status.
virtual void | InitBusyStatusDefaultColors ()
Set default colors/patterns to fill Busy Status area.
- Protected Attributes inherited from CXTPCalendarPaintManager
CList< CXTPCalendarViewPart *, CXTPCalendarViewPart * > | m_lstViewParts
Collection to store ViewParts objects.
CXTPImageManager * | m_pExpandSigns
Stores standard Expand Signs icons.
CXTPImageManager * m_pGlyphs
Stores standard glyphs for displaying events.
CFont * | m_pGlyphsFont
Stores standard glyphs font for displaying events.
CBitmap | m_bmpElsewherePattern
Stores standard bitmap pattern to draw Elsewhere event busy status.
CXTPBrush | m_xtpBrushElsewhere
Stores standard brush to draw Elsewhere event busy status.
CBitmap | m_bmpTentativePattern
Stores standard bitmap pattern to draw Tentative event busy status.
CXTPBrush | m_xtpBrushTentative
Stores standard brush to draw Tentative event busy status.
CXTPCalendarTypedPtrAutoDeleteArray< CPtrArray, CXTPCalendarViewPartBrushValue * > | m_arBusyStatusBrushes
Stores customizable brush values to draw Event Busy Status in the Day View.
CSize | m_szClockRect
Stores dimensions for a rectangle used to display the time as a clock glyph.
CXTPCalendarControl * | m_pControl
Stores a pointer to a CXTPCalendarControl object.
BOOL | m_bEnableTheme
True to enable Luna theme.
COLORREF | m_clrUnderLineHdr
Color of header's underline.
XTPCurrentSystemTheme | m_CurrSystemTheme
Current theme flag.
XTPCalendarTheme | m_nPaintTheme
Store the Paint Theme;.
DWORD | m_dwAskItemTextFlags
Store flag set to send XTP_NC_CALENDAR_GETITEMTEXT notification.

Detailed Description

CXTPCalendarResourceTheme is a CXTPCalendarPaintManager derived class that represents the Resource calendar theme.

Constructor & Destructor Documentation

◆ CXTPCalendarResourceTheme()

CXTPCalendarResourceTheme ( )

Default paint manager constructor.

Handles initial initialization.

See also
RefreshMetrics()

◆ ~CXTPCalendarResourceTheme()

virtual ~CXTPCalendarResourceTheme ( )
virtual

Default paint manager destructor.

Handles member items deallocation.

Member Function Documentation

◆ RefreshMetrics()

virtual void RefreshMetrics ( )
virtual

This member function is used to initialize all drawing defaults.

Initializes all drawings defaults (fonts, colors, etc.). most of the defaults are system defaults.

Reimplemented from CXTPCalendarPaintManager.

The documentation for this class was generated from the following file:
  • XTPCalendarResourceTheme.h


Toolkit Pro: CXTPCalendarSchedule Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPCalendarSchedule Class Reference

Calendar Schedule is a characteristic of the Calendar Event, which describes a belonging of the Event to a particular Schedule (which could be people schedule, common resource schedule, etc). More...

Inheritance diagram for CXTPCalendarSchedule:
[legend]

Public Member Functions

CXTPCalendarSchedule (UINT uScheduleID=0, LPCTSTR pcszScheduleName=_T(""))
Default object constructor.
virtual | ~CXTPCalendarSchedule ()
Default class destructor.
UINT | GetID () const
This member function is used to obtain a unique schedule ID.
CString | GetName () const
This member function is used to obtain the schedule name.
void | SetID (UINT uScheduleID)
This member function is used to set a new ID value for a schedule.
void | SetName (LPCTSTR pcszScheduleName)
This member function is used to set the schedule name text.
CXTPCalendarCustomProperties * | GetCustomProperties () const
Get custom (named, user-defined) properties collection.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Attributes

CString | m_strScheduleName
Stores Schedule Name.
UINT | m_uScheduleID
Stores numeric positive ID of the schedule.
CXTPCalendarCustomProperties * | m_pCustomProperties
Stores custom properties collection for this Schedule.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

Calendar Schedule is a characteristic of the Calendar Event, which describes a belonging of the Event to a particular Schedule (which could be people schedule, common resource schedule, etc).

This class implements base properties of the Schedule and operations on it.

Constructor & Destructor Documentation

◆ CXTPCalendarSchedule()

CXTPCalendarSchedule | ( | UINT | uScheduleID = 0,
 |  | LPCTSTR | pcszScheduleName = _T("") )

Default object constructor.

Constructs a CXTPCalendarSchedule object.

Parameters
uScheduleID | A numeric positive ID of the schedule.
pcszScheduleName | A string name of the schedule (could be a name of the person, etc)
See also
~CXTPCalendarSchedule

◆ ~CXTPCalendarSchedule()

virtual ~CXTPCalendarSchedule ( )
virtual

Default class destructor.

Handles member items deallocation.

See also
CXTPCalendarSchedule

Member Function Documentation

◆ GetCustomProperties()

AFX_INLINE CXTPCalendarCustomProperties * GetCustomProperties ( ) const

Get custom (named, user-defined) properties collection.

Returns
A pointer to CXTPCalendarCustomProperties object.
See also
CXTPCalendarCustomProperties

◆ GetID()

AFX_INLINE UINT GetID ( ) const

This member function is used to obtain a unique schedule ID.

Returns
A UINT unique id.
See also
CXTPCalendarSchedule
SetID

◆ GetName()

AFX_INLINE CString GetName ( ) const

This member function is used to obtain the schedule name.

Returns
A CString object that contains the schedule name text.
See also
SetName

◆ SetID()

AFX_INLINE void SetID ( UINT uScheduleID )

This member function is used to set a new ID value for a schedule.

Parameters
uScheduleID A DWORD that contains the id value.
See also
GetID

◆ SetName()

AFX_INLINE void SetName ( LPCTSTR pcszScheduleName )

This member function is used to set the schedule name text.

Parameters
pcszScheduleName An LPCTSTR object that contains the string of text.
See also
GetName
The documentation for this class was generated from the following file:
  • XTPCalendarResource.h


Toolkit Pro: CXTPCalendarSchedules Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPCalendarSchedules Class Reference

This class represents a simple array collection of CXTPCalendarSchedule objects. More...

Inheritance diagram for CXTPCalendarSchedules:
[legend]

Public Member Functions

CXTPCalendarSchedules ()
Default collection constructor.
virtual | ~CXTPCalendarSchedules ()
Default collection destructor.
virtual BOOL | AddNewSchedule (LPCTSTR pcszScheduleName)
Creates and adds a new schedule object by its name.
virtual BOOL | RemoveSchedule (UINT uScheduleID)
Removes a schedule object from the array by its ID.
virtual LPCTSTR | GetScheduleName (UINT uScheduleID) const
Returns a name of the schedule by its numeric ID.
virtual int | FindIndex (UINT uScheduleID) const
Finds schedule index in the internal array by its ID.
virtual void | SetScheduleName (UINT uScheduleID, LPCTSTR pcszNewName)
Sets a new schedule name by its numeric ID.
virtual void | DoPropExchange (CXTPPropExchange *pPX)
Call this member function to Store/Load a schedule using the specified data object.
- Public Member Functions inherited from CXTPCalendarPtrCollectionT< CXTPCalendarSchedule >
CXTPCalendarPtrCollectionT ()
Default collection constructor.
virtual | ~CXTPCalendarPtrCollectionT ()
Default collection destructor.
virtual int | GetCount () const
This member function is used to obtain the number of elements in the collection.
virtual void | Add (CXTPCalendarSchedule *pNewElement)
This member function adds a new element to the end of the array.
virtual void | Add (CXTPCalendarSchedule *pNewElement, BOOL bWithAddRef)
This member function adds a new element to the end of the array.
virtual void | SetAt (int nIndex, CXTPCalendarSchedule *pElement)
This member function is used to set a new element to the position specified in the nIndex parameter.
virtual int | Find (const CXTPCalendarSchedule *pElement) const
This member function finds an element index in the collection using its pointer.
virtual void | InsertAt (int nIndex, CXTPCalendarSchedule *pElement)
This member function is used to insert a new element at the position specified in the nIndex parameter.
virtual void | Append (const CXTPCalendarPtrCollectionT< CXTPCalendarSchedule > *pElementsArray)
This member function is used to add a new elements to the end of the array.
virtual void | SetSize (int nNewSize)
This member function is used to change the array size.
virtual CXTPCalendarSchedule * | GetAt (int nIndex) const
This member function returns an element at the specified numeric index.
virtual CXTPCalendarSchedule * | GetAt (int nIndex, BOOL bWithAddRef) const
This member function returns an element at the specified numeric index.
virtual void | RemoveAt (int nIndex)
This member function removes an element at the specified index from the array.
virtual void | Remove (CXTPCalendarSchedule *pElement)
This member function finds an element using its pointer and removes it from the array.
virtual void | RemoveAll ()
This member function is used to remove all of the elements from the array.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

virtual UINT | _GetNextID () const
Finds the next available ID which does not exist in the array.
virtual void | _Load (CXTPPropExchange *pPX)
Call this member function to Load a schedule from the specified data object.
virtual void | _Save (CXTPPropExchange *pPX)
Call this member function to Store a schedule to the specified data object.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Types inherited from CXTPCalendarPtrCollectionT< CXTPCalendarSchedule >
typedef CXTPSmartPtrInternalT< CXTPCalendarSchedule > | TObjectPtr
Smart pointer type for stored objects.
- Protected Attributes inherited from CXTPCalendarPtrCollectionT< CXTPCalendarSchedule >
CArray< TObjectPtr, TObjectPtr & > | m_arElements
Objects storage.

Detailed Description

This class represents a simple array collection of CXTPCalendarSchedule objects.

Array indexes always start at position 0.

As with a C array, the access time for indexed element of this array is constant and is independent of the array size.

See also
CArray overview
CXTPCalendarSchedule overview

Constructor & Destructor Documentation

◆ CXTPCalendarSchedules()

CXTPCalendarSchedules ( )

Default collection constructor.

See also
~CXTPCalendarSchedules()

◆ ~CXTPCalendarSchedules()

virtual ~CXTPCalendarSchedules ( )
virtual

Default collection destructor.

Handles member item deallocation. Decreases reference of all stored CXTPCalendarSchedule objects.

See also
RemoveAll()

Member Function Documentation

◆ _GetNextID()

virtual UINT _GetNextID ( ) const
protectedvirtual

Finds the next available ID which does not exist in the array.

Returns
Available ID which does not exist in the array.

Function found max ID and returns it incremented by one.

◆ _Load()

virtual void _Load ( CXTPPropExchange * pPX )
protectedvirtual

Call this member function to Load a schedule from the specified data object.

Parameters
pPX Source CXTPPropExchange data object reference.

This member function is used to load schedule data from a specified storage.

◆ _Save()

virtual void _Save ( CXTPPropExchange * pPX )
protectedvirtual

Call this member function to Store a schedule to the specified data object.

Parameters
pPX Destination CXTPPropExchange data object reference.

This member function is used to store schedule data to a storage.

◆ AddNewSchedule()

virtual BOOL AddNewSchedule ( LPCTSTR pcszScheduleName )
virtual

Creates and adds a new schedule object by its name.

Parameters
pcszScheduleName String with the schedule name.
Returns
TRUE if added successfully; FALSE otherwise.
See also
RemoveSchedule

◆ DoPropExchange()

virtual void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Call this member function to Store/Load a schedule using the specified data object.

Parameters
pPX Source or destination CXTPPropExchange data object reference.

This member function is used to store schedule data to or load schedule data from storage.

◆ FindIndex()

virtual int FindIndex ( UINT uScheduleID ) const
virtual

Finds schedule index in the internal array by its ID.

Parameters
uScheduleID Label ID.
Returns
Schedule index in the internal label array.

◆ GetScheduleName()

virtual LPCTSTR GetScheduleName ( UINT uScheduleID ) const
virtual

Returns a name of the schedule by its numeric ID.

Parameters
uScheduleID The ID for the schedule.
Returns
A LPCTSTR value specifying the schedule name.
See also
SetScheduleName

◆ RemoveSchedule()

virtual BOOL RemoveSchedule ( UINT uScheduleID )
virtual

Removes a schedule object from the array by its ID.

Parameters
uScheduleID The ID for the schedule.
Returns
TRUE if object was found and removed from the array; FALSE otherwise.
See also
AddNewSchedule

◆ SetScheduleName()

virtual void SetScheduleName | ( | UINT | uScheduleID,
 |  | LPCTSTR | pcszNewName )
 virtual

Sets a new schedule name by its numeric ID.

Parameters
uScheduleID | The ID for the schedule.
pcszNewName | String of text for the new name of the schedule.
See also
GetScheduleName
The documentation for this class was generated from the following file:
  • XTPCalendarResource.h


Toolkit Pro: CXTPCalendarShadowDrawer Class Reference

Public Member Functions | Static Public Member Functions | Protected Attributes | List of all members
CXTPCalendarShadowDrawer Class Reference

This is a helper class which handles shadows drawing (for events, etc). More...

Public Member Functions

CXTPCalendarShadowDrawer (CDC *pDC, double dMaxAlpha)
Constructs the object and initializes.
virtual | ~CXTPCalendarShadowDrawer ()
Destroy the CXTPCalendarShadowDrawer and does the cleanups.
void | DrawShadowRectPart (const CRect &rcShadow, const XTPShadowPart part)
Generic drawing of the shadow rectangle part.
void | ApplyShadowLR (UINT *pBitmap, const ULONG ulBitmapWidth, const ULONG ulBitmapHeight)
Applied shadow to bitmap.
void | ApplyShadowTB (UINT *pBitmap, const ULONG ulBitmapWidth, const ULONG ulBitmapHeight)
Applied shadow to bitmap.
void | ApplyShadowTR (UINT *pBitmap, const ULONG ulBitmapWidth, const ULONG ulBitmapHeight)
Applies shadow to bitmap.
void | ApplyShadowBR (UINT *pBitmap, const ULONG ulBitmapWidth, const ULONG ulBitmapHeight)
Applies shadow to bitmap.
void | ApplyShadowBL (UINT *pBitmap, const ULONG ulBitmapWidth, const ULONG ulBitmapHeight)
Applies shadow to bitmap.
void | ApplyShadow2007Right (UINT *pBitmap, const ULONG ulBitmapWidth, const ULONG ulBitmapHeight)
Applies shadow to bitmap.
void | ApplyShadow2007Bottom (UINT *pBitmap, const ULONG ulBitmapWidth, const ULONG ulBitmapHeight)
Applies shadow to bitmap.
void | ApplyShadow2007TR (UINT *pBitmap, const ULONG ulBitmapWidth, const ULONG ulBitmapHeight)
Applies shadow to bitmap.
void | ApplyShadow2007BL (UINT *pBitmap, const ULONG ulBitmapWidth, const ULONG ulBitmapHeight)
Applies shadow to bitmap.
void | ApplyShadow2007BR (UINT *pBitmap, const ULONG ulBitmapWidth, const ULONG ulBitmapHeight)
Applies shadow to bitmap.
void | ApplyShadow2007Center (UINT *pBitmap, const ULONG ulBitmapWidth, const ULONG ulBitmapHeight)
Applies shadow to bitmap.

Static Public Member Functions

static COLORREF AFX_CDECL | AlphaPixel (const COLORREF crPixel, const UINT i)
Call this function to get the alpha pixel.
static int AFX_CDECL | CheckValue (int iValue)
Call this function to check whether the input is within the limit of 0 and 255.

Protected Attributes

CDC * | m_pDC
drawing device context
double | m_dMaxAlpha
maximal shadow alpha grade

Detailed Description

This is a helper class which handles shadows drawing (for events, etc).

Constructor & Destructor Documentation

◆ CXTPCalendarShadowDrawer()

CXTPCalendarShadowDrawer | ( | CDC * | pDC,
 |  | double | dMaxAlpha )

Constructs the object and initializes.

Parameters
pDC | A pointer to the device context.
dMaxAlpha | The maximum value for the alpha channel.

Member Function Documentation

◆ AlphaPixel()

static COLORREF AFX_CDECL AlphaPixel | ( | const COLORREF | crPixel,
 |  | const UINT | i )
 static

Call this function to get the alpha pixel.

Parameters
crPixel | The color of the pixel.
i | The alpha value.
Returns
The alpha pixel value.

◆ ApplyShadow2007BL()

void ApplyShadow2007BL | ( | UINT * | pBitmap,
 |  | const ULONG | ulBitmapWidth,
 |  | const ULONG | ulBitmapHeight )

Applies shadow to bitmap.

Parameters
pBitmap | UINT*.
ulBitmapWidth | ULONG.
ulBitmapHeight | ULONG.

◆ ApplyShadow2007Bottom()

void ApplyShadow2007Bottom | ( | UINT * | pBitmap,
 |  | const ULONG | ulBitmapWidth,
 |  | const ULONG | ulBitmapHeight )

Applies shadow to bitmap.

Parameters
pBitmap | UINT*.
ulBitmapWidth | ULONG.
ulBitmapHeight | ULONG.

◆ ApplyShadow2007BR()

void ApplyShadow2007BR | ( | UINT * | pBitmap,
 |  | const ULONG | ulBitmapWidth,
 |  | const ULONG | ulBitmapHeight )

Applies shadow to bitmap.

Parameters
pBitmap | UINT*.
ulBitmapWidth | ULONG.
ulBitmapHeight | ULONG.

◆ ApplyShadow2007Center()

void ApplyShadow2007Center | ( | UINT * | pBitmap,
 |  | const ULONG | ulBitmapWidth,
 |  | const ULONG | ulBitmapHeight )

Applies shadow to bitmap.

Parameters
pBitmap | UINT*.
ulBitmapWidth | ULONG.
ulBitmapHeight | ULONG.

◆ ApplyShadow2007Right()

void ApplyShadow2007Right | ( | UINT * | pBitmap,
 |  | const ULONG | ulBitmapWidth,
 |  | const ULONG | ulBitmapHeight )

Applies shadow to bitmap.

Parameters
pBitmap | UINT*.
ulBitmapWidth | ULONG.
ulBitmapHeight | ULONG.

◆ ApplyShadow2007TR()

void ApplyShadow2007TR | ( | UINT * | pBitmap,
 |  | const ULONG | ulBitmapWidth,
 |  | const ULONG | ulBitmapHeight )

Applies shadow to bitmap.

Parameters
pBitmap | UINT*.
ulBitmapWidth | ULONG.
ulBitmapHeight | ULONG.

◆ ApplyShadowBL()

void ApplyShadowBL | ( | UINT * | pBitmap,
 |  | const ULONG | ulBitmapWidth,
 |  | const ULONG | ulBitmapHeight )

Applies shadow to bitmap.

Parameters
pBitmap | UINT*.
ulBitmapWidth | ULONG.
ulBitmapHeight | ULONG.

◆ ApplyShadowBR()

void ApplyShadowBR | ( | UINT * | pBitmap,
 |  | const ULONG | ulBitmapWidth,
 |  | const ULONG | ulBitmapHeight )

Applies shadow to bitmap.

Parameters
pBitmap | UINT*.
ulBitmapWidth | ULONG.
ulBitmapHeight | ULONG.

◆ ApplyShadowLR()

void ApplyShadowLR | ( | UINT * | pBitmap,
 |  | const ULONG | ulBitmapWidth,
 |  | const ULONG | ulBitmapHeight )

Applied shadow to bitmap.

Parameters
pBitmap | UINT*.
ulBitmapWidth | ULONG.
ulBitmapHeight | ULONG.

◆ ApplyShadowTB()

void ApplyShadowTB | ( | UINT * | pBitmap,
 |  | const ULONG | ulBitmapWidth,
 |  | const ULONG | ulBitmapHeight )

Applied shadow to bitmap.

Parameters
pBitmap | UINT*.
ulBitmapWidth | ULONG.
ulBitmapHeight | ULONG.

◆ ApplyShadowTR()

void ApplyShadowTR | ( | UINT * | pBitmap,
 |  | const ULONG | ulBitmapWidth,
 |  | const ULONG | ulBitmapHeight )

Applies shadow to bitmap.

Parameters
pBitmap | UINT*.
ulBitmapWidth | ULONG.
ulBitmapHeight | ULONG.

◆ CheckValue()

static int AFX_CDECL CheckValue ( int iValue )
static

Call this function to check whether the input is within the limit of 0 and 255.

Parameters
iValue - The input.
Returns
The returns 0 if the input is less than 0 and 255 if it is greater than 255, else returns the value.

◆ DrawShadowRectPart()

void DrawShadowRectPart | ( | const CRect & | rcShadow,
 |  | const XTPShadowPart | part )

Generic drawing of the shadow rectangle part.

Parameters
rcShadow | rectangle to draw.
part | XTPShadowPart.
The documentation for this class was generated from the following file:
  • XTPCalendarShadowDrawer.h


Toolkit Pro: CXTPCalendarThemeBOOLValue Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPCalendarThemeBOOLValue Class Reference

Helper class provides functionality to manage customized BOOL value objects. More...

Inheritance diagram for CXTPCalendarThemeBOOLValue:
[legend]

Public Member Functions

CXTPCalendarThemeBOOLValue ()
Default object constructor.
virtual void | DoPropExchange (CXTPPropExchange *pPX, LPCTSTR pcszPropName)
This method reads data from or writes data to storage.
const CXTPCalendarThemeBOOLValue & | operator= (BOOL bValue)
This member operator is used to set the custom value.
- Public Member Functions inherited from CXTPCalendarThemeCustomizableXValueT< BOOL, BOOL >
CXTPCalendarThemeCustomizableXValueT ()
Default object constructor.
virtual | ~CXTPCalendarThemeCustomizableXValueT ()
Default object destructor.
virtual void | DoDestroy (BOOL &refValue)
This member function is used to destroy objects of type _TValue if necessary (Close handles, free memory, ...).
virtual BOOL | IsDefaultValue () const
This member function is used to determine if the default value is set.
virtual BOOL | IsStandardValue () const
This member function determines if the standard value is set and used.
virtual BOOL | IsCustomValue () const
This member function determines if the custom value is set and used.
virtual void | SetStandardValue (BOOL refValue, BOOL bAutoDestroy)
This member function is used to set the standard value.
virtual void | SetStandardValue (BOOL refValue)
This member function is used to set the standard value.
virtual void | SetCustomValue (BOOL refValue, BOOL bAutoDestroy)
This member function is used to set the custom value.
virtual void | SetCustomValue (BOOL refValue)
This member function is used to set the custom value.
virtual void | SetDefaultValue ()
This member function is used to reset the custom value.
virtual BOOL | GetValue () const
This member function is used to get the current value.
virtual const BOOL & | GetValueX () const
This member function is used to get the current value.
virtual BOOL | GetStandardValue () const
This member function is used to get the standard value.
operator BOOL () const
This member operator is used to get the current value.
void | CopySettings (const CXTPCalendarThemeCustomizableXValueT< BOOL, BOOL > &refSrc)
This member function is used to set the standard value using the current value from the specified object.
const CXTPCalendarThemeCustomizableXValueT< BOOL, BOOL > & | operator= (BOOL refValue)
This member operator is used to set the custom value.
virtual void | Serialize (CArchive &ar)
This method reads data from or writes data to an archive.

Protected Member Functions

void DoPX_Value (CXTPPropExchange *pPX, LPCTSTR pcszPropName, BOOL &rXValue, BOOL bStandard)
This method reads value data from or writes value data to storage.

Additional Inherited Members

- Protected Attributes inherited from CXTPCalendarThemeCustomizableXValueT< BOOL, BOOL >
BOOL | m_ValueStandard
Stores default value.
BOOL | m_bAutoDestroy_Standard
Call DoDestroy for standard value.
BOOL | m_bIsStandardSet
Is standard value set.
BOOL | m_ValueCustom
Stores custom value.
BOOL | m_bAutoDestroy_Custom
Call DoDestroy for custom vale.
BOOL | m_bIsCustomSet
Is custom value set.

Detailed Description

Helper class provides functionality to manage customized BOOL value objects.

Member Function Documentation

◆ DoPropExchange()

virtual void DoPropExchange | ( | CXTPPropExchange * | pPX,
 |  | LPCTSTR | pcszPropName )
 virtual

This method reads data from or writes data to storage.

Parameters
pPX | A CXTPPropExchange object to serialize to or from.
pcszPropName | The name of the property being exchanged.
See also
Serialize()
DoPX_Value()

Implements CXTPCalendarThemeCustomizableXValueT< BOOL, BOOL >.

◆ DoPX_Value()

void DoPX_Value | ( | CXTPPropExchange * | pPX,
 |  | LPCTSTR | pcszPropName,
 |  | BOOL & | rXValue,
 |  | BOOL | bStandard )
 protected

This method reads value data from or writes value data to storage.

Parameters
pPX | A CXTPPropExchange object to serialize to or from.
pcszPropName | A value name.
rXValue | Reference to value.
bStandard | Standard or Custom value.
See also
DoPropExchange()

◆ operator=()

const CXTPCalendarThemeBOOLValue & operator= ( BOOL bValue )

This member operator is used to set the custom value.

Parameters
bValue A new custom value.
Returns
Reference to this object.
The documentation for this class was generated from the following file:
  • XTPCalendarViewPart.h


Toolkit Pro: CXTPCalendarThemeCustomizableXValueT< _TValue, _TValueRef > Class Template Reference

Public Member Functions | Protected Attributes | List of all members
CXTPCalendarThemeCustomizableXValueT< _TValue, _TValueRef > Class Template Referenceabstract

Helper class template provides functionality to manage customized value for the specified type. More...

Inheritance diagram for CXTPCalendarThemeCustomizableXValueT< _TValue, _TValueRef >:
[legend]

Public Member Functions

CXTPCalendarThemeCustomizableXValueT ()
Default object constructor.
virtual | ~CXTPCalendarThemeCustomizableXValueT ()
Default object destructor.
virtual void | DoDestroy (_TValue &refValue)
This member function is used to destroy objects of type _TValue if necessary (Close handles, free memory, ...).
virtual BOOL | IsDefaultValue () const
This member function is used to determine if the default value is set.
virtual BOOL | IsStandardValue () const
This member function determines if the standard value is set and used.
virtual BOOL | IsCustomValue () const
This member function determines if the custom value is set and used.
virtual void | SetStandardValue (_TValueRef refValue, BOOL bAutoDestroy)
This member function is used to set the standard value.
virtual void | SetStandardValue (_TValueRef refValue)
This member function is used to set the standard value.
virtual void | SetCustomValue (_TValueRef refValue, BOOL bAutoDestroy)
This member function is used to set the custom value.
virtual void | SetCustomValue (_TValueRef refValue)
This member function is used to set the custom value.
virtual void | SetDefaultValue ()
This member function is used to reset the custom value.
virtual _TValueRef | GetValue () const
This member function is used to get the current value.
virtual const _TValue & | GetValueX () const
This member function is used to get the current value.
virtual _TValueRef | GetStandardValue () const
This member function is used to get the standard value.
operator _TValueRef () const
This member operator is used to get the current value.
void | CopySettings (const CXTPCalendarThemeCustomizableXValueT< _TValue, _TValueRef > &refSrc)
This member function is used to set the standard value using the current value from the specified object.
const CXTPCalendarThemeCustomizableXValueT< _TValue, _TValueRef > & | operator= (_TValueRef refValue)
This member operator is used to set the custom value.
virtual void | Serialize (CArchive &ar)
This method reads data from or writes data to an archive.
virtual void | DoPropExchange (CXTPPropExchange *pPX, LPCTSTR pcszPropName)=0
This method reads data from or writes data to storage.

Protected Attributes

_TValue | m_ValueStandard
Stores default value.
BOOL | m_bAutoDestroy_Standard
Call DoDestroy for standard value.
BOOL | m_bIsStandardSet
Is standard value set.
_TValue | m_ValueCustom
Stores custom value.
BOOL | m_bAutoDestroy_Custom
Call DoDestroy for custom vale.
BOOL | m_bIsCustomSet
Is custom value set.

Detailed Description

template<class _TValue, class _TValueRef = _TValue&>
class CXTPCalendarThemeCustomizableXValueT< _TValue, _TValueRef >

Helper class template provides functionality to manage customized value for the specified type.

Member Function Documentation

◆ CopySettings()

template<class _TValue , class _TValueRef = _TValue&>
void CopySettings ( const CXTPCalendarThemeCustomizableXValueT< _TValue, _TValueRef > & refSrc )
inline

This member function is used to set the standard value using the current value from the specified object.

Parameters
refSrc Reference to a source object.
See also
SetStandardValue
SetCustomValue
SetDefaultValue
GetValue
IsStandardValue
IsCustomValue
GetStandardValue

◆ DoDestroy()

template<class _TValue , class _TValueRef = _TValue&>
virtual void DoDestroy ( _TValue & refValue )
inlinevirtual

This member function is used to destroy objects of type _TValue if necessary (Close handles, free memory, ...).

Parameters
refValue An object reference to destroy.

Reimplemented in CXTPCalendarThemeStringValue.

◆ DoPropExchange()

template<class _TValue , class _TValueRef = _TValue&>
virtual void DoPropExchange | ( | CXTPPropExchange * | pPX,
 |  | LPCTSTR | pcszPropName )
 pure virtual

This method reads data from or writes data to storage.

Parameters
pPX | A CXTPPropExchange object to serialize to or from.
pcszPropName | The name of the property being exchanged.
See also
Serialize()
DoPX_Value()

Implemented in CXTPCalendarThemeBOOLValue, CXTPCalendarThemeIntValue, CXTPCalendarThemeRectValue, and CXTPCalendarThemeStringValue.

◆ GetStandardValue()

template<class _TValue , class _TValueRef = _TValue&>
virtual _TValueRef GetStandardValue ( ) const
inlinevirtual

This member function is used to get the standard value.

Returns
Standard value.
See also
SetStandardValue
SetCustomValue
SetDefaultValue

◆ GetValue()

template<class _TValue , class _TValueRef = _TValue&>
virtual _TValueRef GetValue ( ) const
inlinevirtual

This member function is used to get the current value.

The default value is used if the custom value is not set. Otherwise, a custom value is used.

Returns
Current value as _TValueRef.
See also
SetStandardValue
SetCustomValue
SetDefaultValue

◆ GetValueX()

template<class _TValue , class _TValueRef = _TValue&>
virtual const _TValue & GetValueX ( ) const
inlinevirtual

This member function is used to get the current value.

The default value is used if the custom value is not set. Otherwise, a custom value is used.

Returns
Current value as const _TValue&.
See also
SetStandardValue
SetCustomValue
SetDefaultValue

◆ IsCustomValue()

template<class _TValue , class _TValueRef = _TValue&>
virtual BOOL IsCustomValue ( ) const
inlinevirtual

This member function determines if the custom value is set and used.

Returns
TRUE if custom value is set, otherwise FALSE.

◆ IsDefaultValue()

template<class _TValue , class _TValueRef = _TValue&>
virtual BOOL IsDefaultValue ( ) const
inlinevirtual

This member function is used to determine if the default value is set.

Returns
A BOOL. TRUE if the default value is set. FALSE otherwise.

◆ IsStandardValue()

template<class _TValue , class _TValueRef = _TValue&>
virtual BOOL IsStandardValue ( ) const
inlinevirtual

This member function determines if the standard value is set and used.

Returns
TRUE if standard value is set and custom value is not set, otherwise FALSE.

◆ operator _TValueRef()

template<class _TValue , class _TValueRef = _TValue&>
operator _TValueRef ( ) const
inline

This member operator is used to get the current value.

The default value is used if the custom value is not set. Otherwise, a custom value is used.

Returns
Current value.
See also
SetStandardValue
SetCustomValue
SetDefaultValue
GetValue

◆ operator=()

template<class _TValue , class _TValueRef = _TValue&>
const CXTPCalendarThemeCustomizableXValueT< _TValue, _TValueRef > & operator= ( _TValueRef refValue )
inline

This member operator is used to set the custom value.

Parameters
refValue A new custom value.
Returns
Reference to this object.

◆ Serialize()

template<class _TValue , class _TValueRef = _TValue&>
virtual void Serialize ( CArchive & ar )
inlinevirtual

This method reads data from or writes data to an archive.

Parameters
ar A CArchive object to serialize to or from.
See also
DoPropExchange()
Parameters
ar for simple types which can be easy serialized. override for more complex cases

◆ SetCustomValue() [1/2]

template<class _TValue , class _TValueRef = _TValue&>
virtual void SetCustomValue ( _TValueRef refValue )
inlinevirtual

This member function is used to set the custom value.

Parameters
refValue A custom value.

Call this member function to set the custom value. If set, this value is used instead of default value.

See also
SetStandardValue
SetDefaultValue

◆ SetCustomValue() [2/2]

template<class _TValue , class _TValueRef = _TValue&>
virtual void SetCustomValue | ( | _TValueRef | refValue,
 |  | BOOL | bAutoDestroy )
 inlinevirtual

This member function is used to set the custom value.

Parameters
refValue | A custom value.
bAutoDestroy | Set to TRUE if the value being set will be automatically destroyed when no longer needed, otherwise set it to FALSE.

Call this member function to set the custom value. If set, this value is used instead of default value.

See also
SetStandardValue
SetDefaultValue

◆ SetDefaultValue()

template<class _TValue , class _TValueRef = _TValue&>
virtual void SetDefaultValue ( )
inlinevirtual

This member function is used to reset the custom value.

Call this member function to ensure that the default value is used and not the custom value. If the default value is not set - method does nothing.

See also
SetStandardValue
SetCustomValue

◆ SetStandardValue() [1/2]

template<class _TValue , class _TValueRef = _TValue&>
virtual void SetStandardValue ( _TValueRef refValue )
inlinevirtual

This member function is used to set the standard value.

Parameters
refValue A standard value.

Call this member function to set the standard value. This value is used as the default value if there is not a custom value set.

See also
SetCustomValue
SetDefaultValue

◆ SetStandardValue() [2/2]

template<class _TValue , class _TValueRef = _TValue&>
virtual void SetStandardValue | ( | _TValueRef | refValue,
 |  | BOOL | bAutoDestroy )
 inlinevirtual

This member function is used to set the standard value.

Parameters
refValue | A standard value.
bAutoDestroy | Set to TRUE if the value being set will be automatically destroyed when no longer needed, otherwise set it to FALSE.

Call this member function to set the standard value. This value is used as the default value if there is not a custom value set.

See also
SetCustomValue
SetDefaultValue

Member Data Documentation

◆ m_bIsCustomSet

template<class _TValue , class _TValueRef = _TValue&>
BOOL m_bIsCustomSet
protected

Is custom value set.

◆ m_bIsStandardSet

template<class _TValue , class _TValueRef = _TValue&>
BOOL m_bIsStandardSet
protected

Is standard value set.

◆ m_ValueCustom

template<class _TValue , class _TValueRef = _TValue&>
_TValue m_ValueCustom
protected

Stores custom value.

◆ m_ValueStandard

template<class _TValue , class _TValueRef = _TValue&>
_TValue m_ValueStandard
protected

Stores default value.

The documentation for this class was generated from the following file:
  • XTPCalendarViewPart.h


Toolkit Pro: CXTPCalendarThemeFontValue Class Reference

Public Member Functions | List of all members
CXTPCalendarThemeFontValue Class Reference

Helper class provides functionality to manage font value objects. More...

Inheritance diagram for CXTPCalendarThemeFontValue:
[legend]

Public Member Functions

CXTPCalendarThemeFontValue ()
Default constructor.
~CXTPCalendarThemeFontValue ()
Handles object deallocation.
virtual void | SetStandardValue (LOGFONT *pLogFont)
This member function is used to set the value for the standard font.
virtual void | SetCustomValue (LOGFONT *pLogFont)
This member function is used to set the value for the custom font.
virtual void | SetStandardValue (CFont *pFont)
Used to assign the standard value to a view part element.
virtual void | SetCustomValue (CFont *pFont)
Used to assign the custom value to a view part element.
const CXTPCalendarThemeFontValue & | operator= (LOGFONT &rLogFont)
This member function overloads the assignment operator for the CXTPCalendarViewPartFontValue class.
void | CopySettings (const CXTPCalendarThemeFontValue &refSrc)
This member function is use to set the standard value using the current value from the specified object.
virtual void | Serialize (CArchive &ar)
This method reads data from or writes data to an archive.
- Public Member Functions inherited from CXTPCalendarViewPartCustomizableValueT< CFont >
CXTPCalendarViewPartCustomizableValueT ()
Default object constructor.
virtual | ~CXTPCalendarViewPartCustomizableValueT ()
Default object destructor.
virtual BOOL | IsDefaultValue () const
This member function is used to determine if the default value is set.
virtual BOOL | IsStandardValue () const
This member function determines if the standard value is set and used.
virtual BOOL | IsCustomValue () const
This member function determines if the custom value is set and used.
virtual void | SetStandardValue (CFont *pValue, BOOL bAutoDelete)
This member function is used to set the standard value.
virtual void | SetCustomValue (CFont *pValue, BOOL bAutoDelete)
This member function is used to set the custom value.
virtual void | SetDefaultValue ()
This member function is used to reset the custom value.
virtual CFont * | GetValue () const
This member function is used to get the current value.
virtual CFont * | GetStandardValue () const
This member function is use to get the standard value.
operator CFont * () const
This member operator is used to get the current value.
CFont * | operator-> ()
Get a current value object.
void | CopySettings (const CXTPCalendarViewPartCustomizableValueT< CFont > &refSrc)
This member function is used to set the standard value using the current value from the specified object.

Additional Inherited Members

- Public Types inherited from CXTPCalendarViewPartCustomizableValueT< CFont >
- Protected Member Functions inherited from CXTPCalendarViewPartCustomizableValueT< CFont >
- Protected Attributes inherited from CXTPCalendarViewPartCustomizableValueT< CFont >
CFont * | m_pValueStandard
Stores default value.
BOOL | m_bAutoDelete_Standard
Call operator delete for the standard value.
CFont * | m_pValueCustom
Stores custom value.
BOOL | m_bAutoDelete_Custom
Call operator delete for the custom value.

Detailed Description

Helper class provides functionality to manage font value objects.

Member Function Documentation

◆ CopySettings()

void CopySettings ( const CXTPCalendarThemeFontValue & refSrc )

This member function is use to set the standard value using the current value from the specified object.

Parameters
refSrc Reference to a source object.
See also
SetStandardValue
SetCustomValue
SetDefaultValue
GetValue
IsStandardValue
IsCustomValue
GetStandardValue

◆ operator=()

const CXTPCalendarThemeFontValue & operator= ( LOGFONT & rLogFont )

This member function overloads the assignment operator for the CXTPCalendarViewPartFontValue class.

Parameters
rLogFont A reference to LOGFONT structure.

Creates a new custom font.

Returns
A reference to a CXTPCalendarViewPartFontValue.

◆ Serialize()

virtual void Serialize ( CArchive & ar )
virtual

This method reads data from or writes data to an archive.

Parameters
ar A CArchive object to serialize to or from.
See also
DoPropExchange()

◆ SetCustomValue() [1/2]

virtual void SetCustomValue ( CFont * pFont )
virtual

Used to assign the custom value to a view part element.

Parameters
pFont pointer to CFont object

◆ SetCustomValue() [2/2]

virtual void SetCustomValue ( LOGFONT * pLogFont )
virtual

This member function is used to set the value for the custom font.

Parameters
pLogFont A pointer to a LOGFONT structure that contains the custom font value.

Call this member function to set the custom font. If set, this font is used as the object value.

◆ SetStandardValue() [1/2]

virtual void SetStandardValue ( CFont * pFont )
virtual

Used to assign the standard value to a view part element.

Parameters
pFont pointer to CFont object

◆ SetStandardValue() [2/2]

virtual void SetStandardValue ( LOGFONT * pLogFont )
virtual

This member function is used to set the value for the standard font.

Parameters
pLogFont A pointer to a LOGFONT structure that contains the standard font value.

Call this member function to set the standard font. This font is used as the default font if there is not a custom font value set.

The documentation for this class was generated from the following file:
  • XTPCalendarViewPart.h


Toolkit Pro: CXTPCalendarThemeIntValue Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPCalendarThemeIntValue Class Reference

Helper class provides functionality to manage customized int value objects. More...

Inheritance diagram for CXTPCalendarThemeIntValue:
[legend]

Public Member Functions

CXTPCalendarThemeIntValue ()
Default object constructor.
virtual void | DoPropExchange (CXTPPropExchange *pPX, LPCTSTR pcszPropName)
This method reads data from or writes data to storage.
const CXTPCalendarThemeIntValue & | operator= (int nValue)
This member operator is used to set the custom value.
- Public Member Functions inherited from CXTPCalendarThemeCustomizableXValueT< int, int >
CXTPCalendarThemeCustomizableXValueT ()
Default object constructor.
virtual | ~CXTPCalendarThemeCustomizableXValueT ()
Default object destructor.
virtual void | DoDestroy (int &refValue)
This member function is used to destroy objects of type _TValue if necessary (Close handles, free memory, ...).
virtual BOOL | IsDefaultValue () const
This member function is used to determine if the default value is set.
virtual BOOL | IsStandardValue () const
This member function determines if the standard value is set and used.
virtual BOOL | IsCustomValue () const
This member function determines if the custom value is set and used.
virtual void | SetStandardValue (int refValue, BOOL bAutoDestroy)
This member function is used to set the standard value.
virtual void | SetStandardValue (int refValue)
This member function is used to set the standard value.
virtual void | SetCustomValue (int refValue, BOOL bAutoDestroy)
This member function is used to set the custom value.
virtual void | SetCustomValue (int refValue)
This member function is used to set the custom value.
virtual void | SetDefaultValue ()
This member function is used to reset the custom value.
virtual int | GetValue () const
This member function is used to get the current value.
virtual const int & | GetValueX () const
This member function is used to get the current value.
virtual int | GetStandardValue () const
This member function is used to get the standard value.
operator int () const
This member operator is used to get the current value.
void | CopySettings (const CXTPCalendarThemeCustomizableXValueT< int, int > &refSrc)
This member function is used to set the standard value using the current value from the specified object.
const CXTPCalendarThemeCustomizableXValueT< int, int > & | operator= (int refValue)
This member operator is used to set the custom value.
virtual void | Serialize (CArchive &ar)
This method reads data from or writes data to an archive.

Protected Member Functions

void DoPX_Value (CXTPPropExchange *pPX, LPCTSTR pcszPropName, int &rXValue, BOOL bStandard)
This method reads value data from or writes value data to storage.

Additional Inherited Members

- Protected Attributes inherited from CXTPCalendarThemeCustomizableXValueT< int, int >
int | m_ValueStandard
Stores default value.
BOOL | m_bAutoDestroy_Standard
Call DoDestroy for standard value.
BOOL | m_bIsStandardSet
Is standard value set.
int | m_ValueCustom
Stores custom value.
BOOL | m_bAutoDestroy_Custom
Call DoDestroy for custom vale.
BOOL | m_bIsCustomSet
Is custom value set.

Detailed Description

Helper class provides functionality to manage customized int value objects.

Member Function Documentation

◆ DoPropExchange()

virtual void DoPropExchange | ( | CXTPPropExchange * | pPX,
 |  | LPCTSTR | pcszPropName )
 virtual

This method reads data from or writes data to storage.

Parameters
pPX | A CXTPPropExchange object to serialize to or from.
pcszPropName | The name of the property being exchanged.
See also
Serialize()
DoPX_Value()

Implements CXTPCalendarThemeCustomizableXValueT< int, int >.

◆ DoPX_Value()

void DoPX_Value | ( | CXTPPropExchange * | pPX,
 |  | LPCTSTR | pcszPropName,
 |  | int & | rXValue,
 |  | BOOL | bStandard )
 protected

This method reads value data from or writes value data to storage.

Parameters
pPX | A CXTPPropExchange object to serialize to or from.
pcszPropName | A value name.
rXValue | Reference to value.
bStandard | Standard or Custom value.
See also
DoPropExchange()

◆ operator=()

const CXTPCalendarThemeIntValue & operator= ( int nValue )

This member operator is used to set the custom value.

Parameters
nValue A new custom value.
Returns
Reference to this object.
The documentation for this class was generated from the following file:
  • XTPCalendarViewPart.h


Toolkit Pro: CXTPCalendarThemeRectValue Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPCalendarThemeRectValue Class Reference

Helper class provides functionality to manage customized CRect value objects. More...

Inheritance diagram for CXTPCalendarThemeRectValue:
[legend]

Public Member Functions

CXTPCalendarThemeRectValue ()
Default object constructor.
virtual void | DoPropExchange (CXTPPropExchange *pPX, LPCTSTR pcszPropName)
This method reads value data from or writes value data to storage.
const CXTPCalendarThemeRectValue & | operator= (const CRect &rcValue)
This member operator is use to set custom value.
- Public Member Functions inherited from CXTPCalendarThemeCustomizableXValueT< CRect, CRect >
CXTPCalendarThemeCustomizableXValueT ()
Default object constructor.
virtual | ~CXTPCalendarThemeCustomizableXValueT ()
Default object destructor.
virtual void | DoDestroy (CRect &refValue)
This member function is used to destroy objects of type _TValue if necessary (Close handles, free memory, ...).
virtual BOOL | IsDefaultValue () const
This member function is used to determine if the default value is set.
virtual BOOL | IsStandardValue () const
This member function determines if the standard value is set and used.
virtual BOOL | IsCustomValue () const
This member function determines if the custom value is set and used.
virtual void | SetStandardValue (CRect refValue, BOOL bAutoDestroy)
This member function is used to set the standard value.
virtual void | SetStandardValue (CRect refValue)
This member function is used to set the standard value.
virtual void | SetCustomValue (CRect refValue, BOOL bAutoDestroy)
This member function is used to set the custom value.
virtual void | SetCustomValue (CRect refValue)
This member function is used to set the custom value.
virtual void | SetDefaultValue ()
This member function is used to reset the custom value.
virtual CRect | GetValue () const
This member function is used to get the current value.
virtual const CRect & | GetValueX () const
This member function is used to get the current value.
virtual CRect | GetStandardValue () const
This member function is used to get the standard value.
operator CRect () const
This member operator is used to get the current value.
void | CopySettings (const CXTPCalendarThemeCustomizableXValueT< CRect, CRect > &refSrc)
This member function is used to set the standard value using the current value from the specified object.
const CXTPCalendarThemeCustomizableXValueT< CRect, CRect > & | operator= (CRect refValue)
This member operator is used to set the custom value.
virtual void | Serialize (CArchive &ar)
This method reads data from or writes data to an archive.

Protected Member Functions

void DoPX_Value (CXTPPropExchange *pPX, LPCTSTR pcszPropName, CRect &rXValue, BOOL bStandard)
This methods reads value data from or writes value data to storage.

Additional Inherited Members

- Protected Attributes inherited from CXTPCalendarThemeCustomizableXValueT< CRect, CRect >
CRect | m_ValueStandard
Stores default value.
BOOL | m_bAutoDestroy_Standard
Call DoDestroy for standard value.
BOOL | m_bIsStandardSet
Is standard value set.
CRect | m_ValueCustom
Stores custom value.
BOOL | m_bAutoDestroy_Custom
Call DoDestroy for custom vale.
BOOL | m_bIsCustomSet
Is custom value set.

Detailed Description

Helper class provides functionality to manage customized CRect value objects.

Member Function Documentation

◆ DoPropExchange()

virtual void DoPropExchange | ( | CXTPPropExchange * | pPX,
 |  | LPCTSTR | pcszPropName )
 virtual

This method reads value data from or writes value data to storage.

Parameters
pPX | A CXTPPropExchange object to serialize to or from.
pcszPropName | The name of the property being exchanged.
See also
Serialize()
DoPX_Value()

Implements CXTPCalendarThemeCustomizableXValueT< CRect, CRect >.

◆ DoPX_Value()

void DoPX_Value | ( | CXTPPropExchange * | pPX,
 |  | LPCTSTR | pcszPropName,
 |  | CRect & | rXValue,
 |  | BOOL | bStandard )
 protected

This methods reads value data from or writes value data to storage.

Parameters
pPX | A CXTPPropExchange object to serialize to or from.
pcszPropName | A value name.
rXValue | Reference to value.
bStandard | Standard or Custom value.
See also
DoPropExchange()

◆ operator=()

const CXTPCalendarThemeRectValue & operator= ( const CRect & rcValue )

This member operator is use to set custom value.

Parameters
rcValue A new custom value.
Returns
Reference to this object.
The documentation for this class was generated from the following file:
  • XTPCalendarViewPart.h


Toolkit Pro: CXTPCalendarThemeStringValue Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPCalendarThemeStringValue Class Reference

Helper class provides functionality to manage customized string value objects. More...

Inheritance diagram for CXTPCalendarThemeStringValue:
[legend]

Public Member Functions

CXTPCalendarThemeStringValue ()
Default constructor.
operator const CString & () const
This member operator is used to get the current value.
const CXTPCalendarThemeStringValue & | operator= (LPCTSTR pcszValue)
This member operator is used to set a custom value.
virtual void | DoPropExchange (CXTPPropExchange *pPX, LPCTSTR pcszPropName)
This method reads data from or writes data to storage.
- Public Member Functions inherited from CXTPCalendarThemeCustomizableXValueT< CString, LPCTSTR >
CXTPCalendarThemeCustomizableXValueT ()
Default object constructor.
virtual | ~CXTPCalendarThemeCustomizableXValueT ()
Default object destructor.
virtual BOOL | IsDefaultValue () const
This member function is used to determine if the default value is set.
virtual BOOL | IsStandardValue () const
This member function determines if the standard value is set and used.
virtual BOOL | IsCustomValue () const
This member function determines if the custom value is set and used.
virtual void | SetStandardValue (LPCTSTR refValue, BOOL bAutoDestroy)
This member function is used to set the standard value.
virtual void | SetStandardValue (LPCTSTR refValue)
This member function is used to set the standard value.
virtual void | SetCustomValue (LPCTSTR refValue, BOOL bAutoDestroy)
This member function is used to set the custom value.
virtual void | SetCustomValue (LPCTSTR refValue)
This member function is used to set the custom value.
virtual void | SetDefaultValue ()
This member function is used to reset the custom value.
virtual LPCTSTR | GetValue () const
This member function is used to get the current value.
virtual const CString & | GetValueX () const
This member function is used to get the current value.
virtual LPCTSTR | GetStandardValue () const
This member function is used to get the standard value.
operator LPCTSTR () const
This member operator is used to get the current value.
void | CopySettings (const CXTPCalendarThemeCustomizableXValueT< CString, LPCTSTR > &refSrc)
This member function is used to set the standard value using the current value from the specified object.
const CXTPCalendarThemeCustomizableXValueT< CString, LPCTSTR > & | operator= (LPCTSTR refValue)
This member operator is used to set the custom value.
virtual void | Serialize (CArchive &ar)
This method reads data from or writes data to an archive.

Protected Member Functions

virtual void | DoDestroy (CString &refValue)
This member operator is used to destroy/clear value data.
void | DoPX_Value (CXTPPropExchange *pPX, LPCTSTR pcszPropName, CString &rXValue, BOOL bStandard)
This method reads value data from or writes value data to storage.

Additional Inherited Members

- Protected Attributes inherited from CXTPCalendarThemeCustomizableXValueT< CString, LPCTSTR >
CString | m_ValueStandard
Stores default value.
BOOL | m_bAutoDestroy_Standard
Call DoDestroy for standard value.
BOOL | m_bIsStandardSet
Is standard value set.
CString | m_ValueCustom
Stores custom value.
BOOL | m_bAutoDestroy_Custom
Call DoDestroy for custom vale.
BOOL | m_bIsCustomSet
Is custom value set.

Detailed Description

Helper class provides functionality to manage customized string value objects.

Member Function Documentation

◆ DoDestroy()

virtual void DoDestroy ( CString & refValue )
inlineprotectedvirtual

This member operator is used to destroy/clear value data.

Parameters
refValue A value reference to destroy/clear data.

Reimplemented from CXTPCalendarThemeCustomizableXValueT< CString, LPCTSTR >.

◆ DoPropExchange()

virtual void DoPropExchange | ( | CXTPPropExchange * | pPX,
 |  | LPCTSTR | pcszPropName )
 virtual

This method reads data from or writes data to storage.

Parameters
pPX | A CXTPPropExchange object to serialize to or from.
pcszPropName | The name of the property being exchanged.
See also
Serialize()
DoPX_Value()

Implements CXTPCalendarThemeCustomizableXValueT< CString, LPCTSTR >.

◆ DoPX_Value()

void DoPX_Value | ( | CXTPPropExchange * | pPX,
 |  | LPCTSTR | pcszPropName,
 |  | CString & | rXValue,
 |  | BOOL | bStandard )
 protected

This method reads value data from or writes value data to storage.

Parameters
pPX | A CXTPPropExchange object to serialize to or from.
pcszPropName | A value name.
rXValue | Reference to value.
bStandard | Standard or Custom value.
See also
DoPropExchange()

◆ operator const CString &()

operator const CString & ( ) const
inline

This member operator is used to get the current value.

The default value is used if the custom value is not set. Otherwise, a custom value is used.

Returns
A pointer to the current value.

Example: See example for SetCustomValue.

See also
SetStandardValue
SetCustomValue
SetDefaultValue
GetValue

◆ operator=()

const CXTPCalendarThemeStringValue & operator= ( LPCTSTR pcszValue )

This member operator is used to set a custom value.

Parameters
pcszValue A new custom value.
Returns
Reference to this object.
The documentation for this class was generated from the following file:
  • XTPCalendarViewPart.h


Toolkit Pro: CXTPCalendarTimeLineView Class Reference

Public Types | Public Member Functions | Public Attributes | Protected Member Functions | Protected Attributes | List of all members
CXTPCalendarTimeLineView Class Reference

This class implements a specific view portion of the Calendar control - called Timeline view. More...

Inheritance diagram for CXTPCalendarTimeLineView:
[legend]

Public Types

typedef CXTPCalendarView TBase

Public Member Functions

CXTPCalendarTimeLineView (CXTPCalendarControl *pCalendarControl)
Default object constructor.
virtual | ~CXTPCalendarTimeLineView ()
Default class destructor.
virtual XTPCalendarViewType | GetViewType () const
Call this member function to obtain the view type flag.
virtual void | Populate ()
This member function is used to populate the view with data for all items contained in the view.
virtual void | AdjustLayout (CDC *pDC, const CRect &rcView, BOOL bCallPostAdjustLayout=TRUE)
This member function is used to adjust the view's layout depending on the window's client dimensions and calls.
virtual void | Draw (CDC *pDC)
This member function performs all of the drawing logic of the calendar view.
virtual void | Draw2 (CDC *pDC)
This member function performs all of the drawing logic of the calendar view.
virtual COleDateTime | GetViewDayDate (int nIndex) const
Call this member function to obtain the date of the day view by the day's index.
virtual COleDateTime | GetStartViewDate () const
Call this member function to obtain the start view date.
virtual void | SetStartViewDate (COleDateTime dt)
Call this member function to set the start view date.
virtual int | GetTimeScaleID () const
Call this member function to get the current time scale ID.
virtual void | SetTimeScaleID (int eTimeScaleParamsID)
Call this member function to set the current time scale.
CXTPCalendarTimeLineViewTimeScale * | GetTimeScale () const
Call this member function to set the current time scale as an object.
virtual BOOL | HitTest (CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const
This member function is used to determine which view item, if any, is at a specified position index, and returns additional info in an XTP_CALENDAR_HITTESTINFO structure.
virtual BOOL | HitTestEx (CPoint pt, XTP_CALENDAR_HITTESTINFO_TIMELINE_VIEW *pHitTest) const
This member function is used to determine which view item, if any, is at a specified position index, and returns additional info in an XTP_CALENDAR_HITTESTINFO_TIMELINE_VIEW structure.
virtual BOOL | GetScrollBarInfoV (SCROLLINFO *pSI) const
This member function is used to retrieve information about a scrollbar's state.
virtual BOOL | GetScrollBarInfoH (SCROLLINFO *pSI, int *pnScrollStep=NULL) const
This member function is used to retrieve information about a scrollbar's state.
virtual void | ScrollH (int nPos, int nPos_raw)
This member function is used to scroll the content of a view.
virtual void | ScrollV (int nPos, int nPos_raw)
This member function is used to scroll the content of a view.
virtual void | ShowDay (const COleDateTime &date, BOOL bSelect=TRUE)
Scrolls the specified date into view and selects it if required.
void | ShowCalendarPopup (COleDateTime dt, CPoint point)
This member function shows a pop-up DatePicker control.
virtual BOOL | HitTestEx (CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const
This member function is used to determine which view item, if any, is at a specified position index, and returns additional info in an XTP_CALENDAR_HITTESTINFO object.
- Public Member Functions inherited from CXTPCalendarView
UINT | GetDiscreteSelectionCount () const
This member function is used to get the number of selected events.
COleDateTime | GetDiscreteSelectionValue (UINT id) const
This member function gets a selected event by using its event ordinal number.
BOOL | AddToDiscreteSelection (UINT id)
This member function adds an event to the selection by using its event ordinal number.
BOOL | IsInDiscreteSelection (UINT id) const
This member function checks if an event is in the selection.
void | ClearDiscreteSelection ()
This member function is used to Clear Discrete Selection.
CXTPCalendarView (CXTPCalendarControl *pCalendarControl)
Default object constructor.
virtual | ~CXTPCalendarView ()
Default class destructor.
virtual void | AdjustLayout2 (CDC *pDC, const CRect &rcView, BOOL bCallPostAdjustLayout=TRUE)
This member function is used to adjust the view's layout depending on the window client size and calls AdjustLayout() for all sub-items.
virtual void | RedrawControl ()
This member function is used to perform the redrawing of the control's layout.
virtual void | OnDraw (CDC *pDC)
This member function performs all of the drawing logic of the calendar view.
virtual BOOL | OnLButtonDown (UINT nFlags, CPoint point)
This member function is used to process left mouse button events.
virtual BOOL | OnLButtonUp (UINT nFlags, CPoint point)
This member function is used to process left mouse button events.
virtual void | OnMouseMove (UINT nFlags, CPoint point)
This member function is used to process mouse movement events.
virtual BOOL | OnLButtonDblClk (UINT nFlags, CPoint point)
This member function is used to process mouse double-click events.
virtual void | OnChar (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process keyboard events.
virtual void | OnKeyDown (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to processes keyboard events.
virtual BOOL | OnSysKeyDown (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process system keyboard events.
CRect | GetViewRect () const
Call this member function to obtain the view's bounding rectangle.
virtual int | GetChildHandlersCount () const
This member function is used to obtain the number of CXTPCalendarWMHandler elements in the descendant handlers collection.
virtual CXTPCalendarWMHandler * | GetChildHandlerAt (int nIndex) const
Call this method to get a handler object at the specified numeric index.
virtual int | GetViewDayCount () const
Call this member function to obtain the number of "day views" in the view collection.
virtual CXTPCalendarViewDay * | GetViewDay_ (int nIndex) const
Call this member function to obtain the CXTPCalendarViewDay object by the day's index.
virtual CXTPCalendarViewDay * | _GetViewDay (const COleDateTime &dtDay) const
Call this member function to obtain the CXTPCalendarViewDay object by the day's index.
virtual XTPCalendarDraggingMode | GetDraggingMode () const
Call this member function to determine the current dragging mode.
virtual CXTPCalendarPaintManager * | GetPaintManager () const
Call this member function to obtain the PaintManager object.
virtual CXTPCalendarTheme * | GetTheme () const
This member function obtains a pointer to the associated theme object.
CXTPCalendarControl * | GetCalendarControl () const
Call this member function to obtain a pointer to the Calendar Control object.
CXTPCalendarOptions * | GetCalendarOptions () const
Call this member function to get direct access to calendar options data.
virtual CXTPCalendarResources * | GetResources () const
Call this member function to obtain a pointer to the associated Calendar Resources collection object.
virtual void | SetResources (CXTPCalendarResources *pResources)
This member function sets the new Resources collection for the view.
virtual void | UnselectAllEvents ()
Call this member function to un-select all of the events of the current view.
virtual void | SelectEvent (CXTPCalendarEvent *pEvent, BOOL bSelect=TRUE)
This member function is used to select or un-select the provided event.
void | SelectViewEvent (CXTPCalendarViewEvent *pViewEvent, BOOL bSelect=TRUE)
This member function is used to select or un-select the provided event.
virtual void | SelectDay (CXTPCalendarViewDay *pDay, int nGroupIndex=0)
This member function is used to select or un-select the provided day, including all of the day's events.
virtual CXTPCalendarViewEvents * | GetSelectedViewEvents () const
Call this member function to obtain a pointer to a selected event's views.
virtual CXTPCalendarViewEventsPtr | GetSelectedEvents () const
Call this member function to obtain a pointer to a selected event's views collection.
CXTPCalendarViewEvent * | GetLastSelectedViewEvent () const
This member function is used to obtain the last selected event view.
virtual BOOL | HasSelectedViewEvent () const
Call this member function to determine if any view event is selected.
BOOL | IsSingleEventSelected () const
This member function is used to determine if just one event is selected.
int | FindLastSelectedDay () const
This member function is used to obtain the last selected day index.
COleDateTime | GetLastSelectedDate () const
This member function is used to obtain the last selected day date.
virtual BOOL | GetSelection (COleDateTime *pBegin=NULL, COleDateTime *pEnd=NULL, BOOL *pbAllDayEvent=NULL, int *pnGroupIndex=NULL, COleDateTimeSpan *pspSelectionResolution=NULL) const
This member function is used to obtain the view's selection.
void | SetSelection (const COleDateTime &dtBegin, const COleDateTime &dtEnd, BOOL bAllDayEvent=FALSE, int nGroupIndex=0)
This member function sets the new selection for the view.
void | ResetSelection ()
This member function resets the current selection - set it empty.
BOOL | SelectionContains (COleDateTime date, int nGroupIndex=-1, BOOL *pbAllDaySelection=NULL)
This member function is used to determine if a date time value is contained inside the selection.
virtual void | SelectDay (COleDateTime dtSelDay, int nGroupIndex=0)
This member function is used to select or un-select the day identified by the provided date.
virtual int | GetRowHeight () const
Call this member function to determine the row height required to display the event.
virtual CXTPCalendarEventsPtr | RetrieveDayEvents (CXTPCalendarResource *pRC, COleDateTime dtDay)
Call this member function to get the collection of the day's events.
virtual BOOL | IsEditingSubject () const
Call this member function to determine if the subject is in an editable mode.
virtual CRect | GetSubjectEditorRect () const
Call this member function to obtain the bounding rectangle of the subject editor.
virtual void | ShowToolTip (BOOL bShow=TRUE)
This member function is used to show/hide a ToolTip rectangle.
virtual UINT | GetShowToolTipTimeOut () const
This member function is used to obtain the timeout value for displaying a tooltip.
virtual void | OnUpdateEditingSubject (CString strNewSubject)
Call this member function to set the new subject text for the editing event.
virtual BOOL | CanUndo () const
Call this member function to determine if you can perform an undo operation for the subject editor.
virtual BOOL | CanRedo () const
Call this member function to determine if a redo operation is possible for the subject editor.
virtual BOOL | Undo ()
This member function is used to perform an Undo operation.
virtual BOOL | Redo ()
This member function is used to perform a Redo operation.
virtual void | EmptyUndoBuffer ()
This member function is used to erase the undo buffer.
virtual CString | FormatEventTime (COleDateTime dtTime) const
This member function is used to format the time using the provided format.
void | SetCustomTimeFormat (const CString &strFormat)
This member function is used to set custom time format for view.
void | ResetCustomTimeFormat ()
Reset custom time format to default.
virtual CString | GetDayHeaderFormat () const
Call this member function to determine the current format string.
virtual void | SetDayHeaderFormat (LPCTSTR sFmt)
Call this member function to set the day header format.
virtual BOOL | CanCut () const
Call this member function to determine if it is possible to perform a Cut operation.
virtual BOOL | CanCopy () const
Call this member function to determine if it is possible to perform a Copy operation.
virtual BOOL | CanPaste () const
Call this member function to determine if it is possible to perform a Paste operation.
virtual BOOL | Cut ()
This member function is used to perform a Cut operation.
virtual BOOL | Copy ()
This member function is used to perform a Copy operation.
virtual BOOL | Paste ()
This member function is used to perform a Paste operation.
virtual CXTPCalendarEvent * | GetDraggingEventOrig () const
This member function is used to obtain the event object before the start of the event editing (dragging).
virtual CXTPCalendarEvent * | GetDraggingEventNew () const
This member function is used to obtain the event object that is currently being edited.
virtual BOOL | SetDraggingEvent (CXTPCalendarEvent *pEventOrig)
This member function is used to prepare the event to event editing (dragging) operation.
virtual BOOL | CommitDraggingEvent ()
This member function is used to commit the event editing (dragging) operation.
virtual void | CancelDraggingEvent ()
This member function is used to cancel the event editing (dragging) operation.
virtual void | OnStartDragging (CPoint point, XTP_CALENDAR_HITTESTINFO *pHitTest)
This member function is used to start the event editing (dragging).
virtual BOOL | OnDragging (CPoint point, XTP_CALENDAR_HITTESTINFO *pHitTest)
This member function is used to perform the event editing (dragging) operation step.
virtual BOOL | OnEndDragging (CPoint point, XTP_CALENDAR_HITTESTINFO *pHitInfo)
This member function is used to finish the event editing (dragging) operation.
virtual void | StartEditSubject (CXTPCalendarViewEvent *pViewEvent)
This member function is used to start the event subject editing.
virtual void | EndEditSubject (XTPCalendarEndEditSubjectAction eAction, BOOL bUpdateControl=TRUE)
This member function is used to finish the event subject editing.
virtual UINT | GetStartEditSubjectTimeOut () const
This member function is used to obtain the time value after a mouse click event in the subject editing window.
virtual void | StartEditNewEventInplace (LPCTSTR pcszInitialSubject)
This member function is used to create a new event and start subject editing.
virtual CXTPCalendarViewEvent * | FindViewEvent (CXTPCalendarEvent *pEvent, COleDateTime dtDay) const
This member function is used to obtain the event view object for the specified event and day.
virtual CXTPCalendarViewEvent * | FindEventToEditByTAB (COleDateTime dtMinStart, BOOL bReverse, CXTPCalendarEvent *pAfterEvent=NULL)
This member function is used to obtain the next event view object used for editing events by pressing the TAB key.
virtual COleDateTime | GetNextTimeEditByTAB () const
This member function is used to obtain the next date and time to start the find event view for editing events using the TAB key.
virtual void | UpdateNextTimeEditByTAB (COleDateTime dtNext, BOOL bReverse, BOOL bReset=FALSE)
This member function is used to set the next date and time to start the find event view for editing events using the TAB key.
virtual void | ProcessDaySelection (XTP_CALENDAR_HITTESTINFO *pInfo, UINT nFlags)
This member function is used to process the days selection that are selected with the mouse.
virtual void | SelectDays (COleDateTime dtNewSel)
This member function is used to change the days selection depending on the previous state of the selection.
virtual void | ProcessEventSelection (XTP_CALENDAR_HITTESTINFO *pInfo, UINT nFlags)
This member function is used to process events that are selected with the mouse.
virtual void | EnableVScroll (BOOL bEnable=TRUE)
This member function(s) is used to disable or enable vertical or horizontal scrolling of the view (by date or time).
virtual void | EnableHScroll (BOOL bEnable=TRUE)
This member function(s) is used to disable or enable vertical or horizontal scrolling of the view (by date or time).
virtual BOOL | IsHScrollEnabled () const
This member function(s) is used to obtain the status of the vertical or horizontal scrolling features of the view (by date or time).
virtual BOOL | IsVScrollEnabled () const
This member function(s) is used to obtain the status of the vertical or horizontal scrolling features of the view (by date or time).
virtual void | SetDayHeaderFormatLong (LPCTSTR pcszCustomFormat)
This member function(s) is used to set the date format string for the day view.
virtual void | SetDayHeaderFormatMiddle (LPCTSTR pcszCustomFormat)
This member function(s) is used to set the date format string for the day view.
virtual void | SetDayHeaderFormatShort (LPCTSTR pcszCustomFormat)
This member function(s) is used to set the date format string for the day view.
virtual void | SetDayHeaderFormatShortest (LPCTSTR pcszCustomFormat)
This member function(s) is used to set the date format string for the day view.
virtual BOOL | IsTodayVisible () const
Call this member function to determine if Today is visible.
virtual CString | GetItemTextEventTimeMax () const
This member function is called by the calendar framework to retrieve an event time string of maximum length (to reserve space).
virtual void | CalculateHeaderFormat (CDC *pDC, int nWidth, CFont *pTextFont)
This member function creates the day header format string.
- Public Member Functions inherited from CXTPCalendarWMHandler
CXTPCalendarWMHandler ()
Default object constructor.
virtual void | OnKeyUp (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process key-up keyboard events.
virtual BOOL | OnWndMsg (UINT message, WPARAM wParam, LPARAM lParam, LRESULT *pResult)
This method is called by framework after default message processing.
virtual void | OnPostAdjustLayout ()
This member function is used to perform additional adjustments in some kinds of views.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Public Attributes

CXTPCalendarTimeLineViewGroups * | m_pGroups
Array of events organized in groups.
BOOL | m_bTimeLineSeparateGroup
Flag to use separatore line between groups or not.
int | m_nTimelineMaxPixelsForEvent_ScaleDay
Width in pixels for 1 event for day scale.
int | m_nTimelineMaxPixelsForEvent_ScaleWeek
Width in pixels for 1 event for week scale.
int | m_nTimelineMaxPixelsForEvent
Width in pixels for 1 event for month scale.
COLORREF | m_clrEventBar
Event Bar Color.
COLORREF | m_clrEventBarLine
Event Bar Line Color.
COLORREF | m_clrEventBorderLine
Event Border Line Color.
COLORREF | m_clrTimeScaleBackground
Time Scale Background Color.
COLORREF | m_clrTimeScaleBorder
Time Scale Border Color.
COLORREF | m_clrTimeScaleHighlight
Time Scale Highlight Color.
COLORREF | m_clrTimeScaleText
Time Scale Text Color.
COLORREF | m_clrSelectedBackground
Selected Background Color.
COLORREF | m_clrSelectedText
Selected Text Color.
COLORREF | m_clrBackground
Background Color.
COLORREF | m_clrText
Text Color.
COLORREF | m_clrWeekendBackground
Weekend Background Color.

Protected Member Functions

virtual void | RefreshMetrics ()
This member function is called by the framework when metrics must be updated.
virtual void | OnBeforeDestroy ()
This member function is called by the framework before the view is destroyed.
virtual void | OnScrollEnd (int nBar)
This member function is used to force scroll to the end of the scroll range.
CRect | GetTooltipRect (const CPoint &ptHit, const XTP_CALENDAR_HITTESTINFO &hitInfo) const
Call this member function to obtain the bounding rectangle of the tooltip space.
virtual CXTPCalendarEventsPtr | _GetEvents (COleDateTime dtStartDay, COleDateTime dtEndDay)
Call this member function to get all events in a given range.
- Protected Member Functions inherited from CXTPCalendarView
virtual UINT | SetTimer (UINT uTimeOut_ms)
This member function is used to create a timer event.
virtual void | KillTimer (UINT uTimerID)
This member function is used to destroy a timer event.
virtual BOOL | OnTimer (UINT_PTR uTimerID)
The framework calls this member function after each interval specified in the SetTimer member function.
virtual void | OnActivateView (BOOL bActivate, CXTPCalendarView *pActivateView, CXTPCalendarView *pInactiveView)
This member function is called by the framework view when it is activated or deactivated.
virtual void | SendNotification (XTP_NOTIFY_CODE EventCode, WPARAM wParam=0, LPARAM lParam=0)
This member function is used to send a notification from the parent Calendar control.
virtual void | _CalculateEventTimeFormat ()
This member function is used to create the time format string.
virtual CString | _GetMaxWidthFormat (CDC *pDC, CString strFormat, BOOL bMonth) const
This function is used to calculate the max width of the date used in the specified format string.
virtual int | _GetMaxWidth (CDC *pDC, CString strFormat) const
This member function is used to calculate, in pixels, the max date width for the specified format string.
virtual void | _RemoveYearPart (CString &strFormat)
This member function is used to remove the year part from the specified format string.
virtual void | _ReadDefaultHeaderFormats ()
This member function is used to build day header date format default strings.
virtual CString | _GetDayHeaderFormat (int nLevel) const
This member function gets a custom or default day header date format string.
virtual BOOL | _CanSubjectEditor (UINT idEditCmd) const
This member function is used to determine if the specified editing operation command is possible for the event subject editor window.
virtual CWnd * | _GetSubjectEditorWnd () const
This member function is used to obtain a pointer to the event subject editor window.
virtual COleDataSource * | _CopySelectedEvents (DWORD dwCopyFlags=0)
This member function is used to copy selected events and CXTPCalendarEvent objects, to a COleDataSource object.
virtual CXTPCalendarEventsPtr | _ReadEventsFromClipboard (COleDataObject *pData, DWORD *pdwCopyFlags=NULL)
This member function is used to read events and CXTPCalendarEvent objects, from a COleDataSource object.
virtual COleDateTimeSpan | GetEventDurationMin () const
This member function is used to obtain the minimum event duration visible in the current view.
virtual BOOL | _Undo (CXTPCalendarEvent *pEvent=NULL)
This member function is used to perform an undo/redo operation for the specified event.
virtual XTPEnumCalendarUpdateResult | OnEventChanged_InDataProvider (XTP_NOTIFY_CODE nfCode, CXTPCalendarEvent *pEvent)
This member function handles the changing of an event in the associated data provider.
BOOL | _IsDragModeCopyMove (int eDragMode) const
This method is used to determine Copy or Move dragging mode.
BOOL | IsEditOperationDisabledNotify (XTPCalendarEditOperation eOperation, CXTPCalendarViewEvent *pEventView) const
This method is used to determine if specified editing operation is disabled.
BOOL | OnBeforeEditOperationNotify (XTPCalendarEditOperation eOperation, CXTPCalendarViewEvent *pEventView)
This method is used to customize or disable specified editing operation.
BOOL | OnBeforeEditOperationNotify (XTPCalendarEditOperation eOperation, CXTPCalendarViewEvents *pEventViews)
This method is used to customize or disable specified editing operation.
BOOL | OnBeforePasteNotify (CXTPCalendarEvent *pEvent, BOOL bPasteWillChangeExistingEvent)
This method is used to customize or disable paste editing operation.
BOOL | OnInPlaceCreateEvent (LPCTSTR pcszInitialSubject)
This method is used to customize or disable xtpCalendarEO_InPlaceCreateEvent editing operation.

Protected Attributes

CXTPCalendarTimeLineViewTimeScale * | m_pTimeScale
Pointer to attached Time Scale object.
int | m_nHScrollPos
keep HScroll position.
int | m_nVScrollPos
Keep VScroll position.
- Protected Attributes inherited from CXTPCalendarView
CSelectionChanged_ContextData m_cntSelChanged
Counter on selection changes,.
int | m_eUndoMode
Undo mode, see XTPCalendarUndoMode.
BOOL | m_bResetUndoBuffer
Clean undo buffer before add next undo action.
CUndoBuffer * | m_pPrevUndoBuffer
Undo buffer data after last undo buffer clean.
CUndoBuffer * | m_pUndoBuffer
Undo buffer object.
XTP_VIEW_LAYOUT | m_Layout
Layout data.
SEventTimeFormatInfo | m_EventTimeFormat
Information used to format events times.
CString | m_strHeaderFormat
Day header active date format string.
CString | m_strDayHeaderFormatLong
Day header Long date format custom string.
CString | m_strDayHeaderFormatMiddle
Day header Middle date format custom string.
CString | m_strDayHeaderFormatShort
Day header Short date format custom string.
CString | m_strDayHeaderFormatShortest
Day header Shortest date format custom string.
CString | m_strDayHeaderFormatDefaultLong
Day header Long date format default string.
CString | m_strDayHeaderFormatDefaultMiddle
Day header Middle date format default string.
CString | m_strDayHeaderFormatDefaultShort
Day header Short date format default string.
CString | m_strDayHeaderFormatDefaultShortest
Day header Shortest date format default string.
CRect | m_rcView
Client rect.
CRect | m_rcTooltip
Last shown tooltip rect (while GetTooltipRect returns calculated currently required tooltip rect)
CXTPCalendarEventPtr | m_ptrDraggingEventOrig
Event object before start event editing.
CXTPCalendarEventPtr | m_ptrDraggingEventNew
Editing event object.
COleDateTimeSpan | m_spDraggingStartOffset
Start dragging operation offset from the beginning of the event.
CPoint | m_ptStartDragging
Request to start dragging operation from this point.
XTPCalendarDraggingMode | m_eDraggingMode
Editing event mode.
BOOL | m_bStartedClickInside
Is OnLButtonDown was inside view rect.
CXTPCalendarViewEventPtr | m_ptrEditingViewEvent
Currently editing subject event view or event view requested to edit subject by timeout.
CXTPCalendarViewEvent * | m_pLastEvent
Last selected event.
UINT | m_nTimerID_StartEditSubject
Timer ID of edit event subject request.
UINT | m_nTimerID_ShowToolTip
Timer ID of start show tooltip request.
CXTPCalendarControl * | m_pControl
Pointer to the owner control object.
CXTPCalendarViewEvents * | m_pSelectedEvents
Selected Events;.
XTP_CALENDAR_HITTESTINFO m_LastHitInfo
Last HitInfo data.
UINT | m_nKeyStateTimerID
Timer ID to check Keys state (like Control).
XTP_CALENDAR_VIEWSELECTION | m_selectedBlock
Current selection.
BOOL | m_bScrollV_Disabled
Is vertical scrolling disabled for a view.
BOOL | m_bScrollH_Disabled
Is horizontal scrolling disabled for a view.
CXTPCalendarResources * | m_pResources
Resources array.
CXTPCalendarPtrCollectionT< CXTPCalendarViewDay > | m_arDays
Stores the view day collection.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

This class implements a specific view portion of the Calendar control - called Timeline view.

Member Typedef Documentation

◆ TBase

CXTPCalendarView TBase

Base class type definition.

Constructor & Destructor Documentation

◆ CXTPCalendarTimeLineView()

CXTPCalendarTimeLineView ( CXTPCalendarControl * pCalendarControl )

Default object constructor.

Parameters
pCalendarControl Pointer to a CXTPCalendarControl object.

◆ ~CXTPCalendarTimeLineView()

virtual ~CXTPCalendarTimeLineView ( )
virtual

Default class destructor.

Handles class members deallocation.

Member Function Documentation

◆ _GetEvents()

virtual CXTPCalendarEventsPtr _GetEvents | ( | COleDateTime | dtStartDay,
 |  | COleDateTime | dtEndDay )
 protectedvirtual

Call this member function to get all events in a given range.

Parameters
dtStartDay | The start of the range.
dtEndDay | The end of the range.
Returns
A CXTPCalendarEventsPtr object.

◆ AdjustLayout()

virtual void AdjustLayout | ( | CDC * | pDC,
 |  | const CRect & | rcView,
 |  | BOOL | bCallPostAdjustLayout = TRUE )
 virtual

This member function is used to adjust the view's layout depending on the window's client dimensions and calls.

Parameters
pDC | Pointer to a valid device context.
rcView | A CRect that contains the bounding rectangle dimensions of the view.
bCallPostAdjustLayout | TRUE for calling additional post-adjustments.

Call Populate() prior to adjusting layout. Adjust layout of all sub-items.

Reimplemented from CXTPCalendarView.

◆ Draw()

virtual void Draw ( CDC * pDC )
virtual

This member function performs all of the drawing logic of the calendar view.

Parameters
pDC Pointer to a valid device context.

Reimplemented from CXTPCalendarView.

◆ Draw2()

virtual void Draw2 ( CDC * pDC )
virtual

This member function performs all of the drawing logic of the calendar view.

Draw2 is called by the calendar control instead of Draw when a theme is set.

Parameters
pDC Pointer to a valid device context.

Reimplemented from CXTPCalendarView.

◆ GetScrollBarInfoH()

virtual BOOL GetScrollBarInfoH | ( | SCROLLINFO * | pSI,
 |  | int * | pnScrollStep = NULL ) const
 virtual

This member function is used to retrieve information about a scrollbar's state.

Parameters
pSI | A pointer to a scrollbar information structure.
pnScrollStep | A pointer to an int to receive scroll step. Can be NULL.
Returns
A BOOL. TRUE if the horizontal scrollbar is enabled, otherwise FALSE.

Reimplemented from CXTPCalendarView.

◆ GetScrollBarInfoV()

virtual BOOL GetScrollBarInfoV ( SCROLLINFO * pSI ) const
virtual

This member function is used to retrieve information about a scrollbar's state.

Parameters
pSI A pointer to a scrollbar information structure.
Returns
A BOOL. TRUE if the vertical scrollbar is enabled, otherwise FALSE.

Reimplemented from CXTPCalendarView.

◆ GetStartViewDate()

virtual COleDateTime GetStartViewDate ( ) const
virtual

Call this member function to obtain the start view date.

Returns
A COleDateTime object that contains the day view date and time.

◆ GetTimeScale()

AFX_INLINE CXTPCalendarTimeLineViewTimeScale * GetTimeScale ( ) const

Call this member function to set the current time scale as an object.

Returns
A pointer to CXTPCalendarTimeLineViewTimeScale.

◆ GetTimeScaleID()

virtual int GetTimeScaleID ( ) const
virtual

Call this member function to get the current time scale ID.

Returns
An int that contains the current time scale ID.

◆ GetTooltipRect()

CRect GetTooltipRect | ( | const CPoint & | ptHit,
 |  | const XTP_CALENDAR_HITTESTINFO & | hitInfo ) const
 protectedvirtual

Call this member function to obtain the bounding rectangle of the tooltip space.

Tooltip rectangle is calculated based on the current mouse position.

Parameters
ptHit | CPoint& of mouse position.
hitInfo | XTP_CALENDAR_HITTESTINFO.
Returns
A CRect object with relative coordinates of the tooltip.

This member function returns a rectangle calculated as an event rect which the user currently holds a mouse on.

Reimplemented from CXTPCalendarView.

◆ GetViewDayDate()

virtual COleDateTime GetViewDayDate ( int nIndex ) const
virtual

Call this member function to obtain the date of the day view by the day's index.

Parameters
nIndex An int that contains the day view index in the view collection.

Indexed number starts from 0 and cannot be negative.

Returns
A COleDateTime object that contains the day view date and time.

Implements CXTPCalendarView.

◆ GetViewType()

AFX_INLINE XTPCalendarViewType GetViewType ( ) const
virtual

Call this member function to obtain the view type flag.

Returns
An XTPCalendarViewType object that contains the view type flag.
See also
XTPCalendarViewType

Implements CXTPCalendarView.

◆ HitTest()

virtual BOOL HitTest | ( | CPoint | pt,
 |  | XTP_CALENDAR_HITTESTINFO * | pHitTest ) const
 virtual

This member function is used to determine which view item, if any, is at a specified position index, and returns additional info in an XTP_CALENDAR_HITTESTINFO structure.

Parameters
pt | Coordinates of a point to test.
pHitTest | Pointer to an XTP_CALENDAR_HITTESTINFO structure.
Returns
TRUE if an item is found, otherwise FALSE.

Reimplemented from CXTPCalendarView.

◆ HitTestEx() [1/2]

virtual BOOL HitTestEx | ( | CPoint | pt,
 |  | XTP_CALENDAR_HITTESTINFO * | pHitTest ) const
 virtual

This member function is used to determine which view item, if any, is at a specified position index, and returns additional info in an XTP_CALENDAR_HITTESTINFO object.

Parameters
pt | A CPoint object that contains the coordinates of the point to test.
pHitTest | A pointer to the template parameter XTP_CALENDAR_HITTESTINFO object that contains information on the point to test.
Returns
TRUE if item found; FALSE otherwise.

Reimplemented from CXTPCalendarView.

◆ HitTestEx() [2/2]

virtual BOOL HitTestEx | ( | CPoint | pt,
 |  | XTP_CALENDAR_HITTESTINFO_TIMELINE_VIEW * | pHitTest ) const
 virtual

This member function is used to determine which view item, if any, is at a specified position index, and returns additional info in an XTP_CALENDAR_HITTESTINFO_TIMELINE_VIEW structure.

Parameters
pt | Coordinates of a point to test.
pHitTest | Pointer to an XTP_CALENDAR_HITTESTINFO_TIMELINE_VIEW structure.
Returns
TRUE if an item is found, otherwise FALSE.
See also
XTP_CALENDAR_HITTESTINFO_TIMELINE_VIEW

◆ OnScrollEnd()

virtual void OnScrollEnd ( int nBar )
protectedvirtual

This member function is used to force scroll to the end of the scroll range.

Parameters
nBar Standard 0 - 1 values (for vertical or horizontal scrollbar).

Reimplemented from CXTPCalendarView.

◆ ScrollH()

virtual void ScrollH | ( | int | nPos,
 |  | int | nPos_raw )
 virtual

This member function is used to scroll the content of a view.

Parameters
nPos | Position value.
nPos_raw | Raw position value.

Reimplemented from CXTPCalendarView.

◆ ScrollV()

virtual void ScrollV | ( | int | nPos,
 |  | int | nPos_raw )
 virtual

This member function is used to scroll the content of a view.

Parameters
nPos | Position value.
nPos_raw | Raw position value.

Reimplemented from CXTPCalendarView.

◆ SetStartViewDate()

virtual void SetStartViewDate ( COleDateTime dt )
virtual

Call this member function to set the start view date.

Parameters
dt Start view date as COleDateTime.

◆ SetTimeScaleID()

virtual void SetTimeScaleID ( int eTimeScaleParamsID )
virtual

Call this member function to set the current time scale.

Parameters
eTimeScaleParamsID An int or XTPEnumCalendarTimeScaleParamsID.

◆ ShowCalendarPopup()

void ShowCalendarPopup | ( | COleDateTime | dt,
 |  | CPoint | point )

This member function shows a pop-up DatePicker control.

Parameters
dt | The initial pop-up datetime selection.
point | The point to show the pop-up.

◆ ShowDay()

virtual void ShowDay | ( | const COleDateTime & | date,
 |  | BOOL | bSelect = TRUE )
 inlinevirtual

Scrolls the specified date into view and selects it if required.

Parameters
date | A datetime value to scroll into view.
bSelect | A flag to select the date or not.

Implements CXTPCalendarView.

The documentation for this class was generated from the following file:
  • XTPCalendarTimeLineView.h


Toolkit Pro: CXTPCalendarTimeLineViewEvent Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPCalendarTimeLineViewEvent Class Reference

This class represents an event timeline view portion of the CXTPCalendarViewEvent. More...

Inheritance diagram for CXTPCalendarTimeLineViewEvent:
[legend]

Public Member Functions

CXTPCalendarTimeLineViewEvent (CXTPCalendarEvent *pEvent, CXTPCalendarTimeLineViewGroup *pGroup)
Default object constructor.
void | CalcRect (CDC *pDC)
This member function is used to calculate a rectangle for an event.
CXTPCalendarTimeLineView * | GetView () const
This member function is used to obtain the owner view object.
CXTPCalendarTimeLineViewGroup * | GetViewGroup () const
Access function to get view group.
virtual CXTPCalendarViewGroup * | GetViewGroup_ () const
Access function to get view group.
virtual BOOL | HitTest (CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const
This member function is used to determine which view item, if any, is at a specified position index, and returns additional info in an XTP_CALENDAR_HITTESTINFO struct.
virtual BOOL | HitTestEx (CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const
This member function is used to determine which view item, if any, is at a specified position index, and returns additional info in an XTP_CALENDAR_HITTESTINFO template parameter.
virtual BOOL | IsVisible () const
This member function is used to get is group visible.
virtual BOOL | IsSelected () const
This member function is used to get is group selected.
virtual void | AdjustLayout (CDC *pDC, const CRect &rcEventMax, int nEventPlaceNumber)
This member function is used to adjust the view's layout.
virtual void | AdjustLayout2 (CDC *pDC, const CRect &rcEventMax, int nEventPlaceNumber)
This member function is used to adjust the view's layout with the theme used.
virtual void | Draw (CDC *pDC)
This member function is used to draw the view content using the specified device context.
virtual void | ChangeEventPlace (int nNewPlace)
This function is used to change the event place number.
virtual CXTPCalendarTimeLineViewPart * | GetPart () const
Access function to get the visual part of a CXTPCalendarTimeLineViewPart object.
virtual int | GetEventDurationInPixels () const
Access function to get event duration in pixels.
const CRect & | GetLastVisibleRect () const
Returns the rect in the client coordinates in which the event was drawn last time.
void | SetLastVisibleRect (const CRect &rc)
Sets the rect in the client coordinates in which the event was drawn last time.
- Public Member Functions inherited from CXTPCalendarViewEvent
CXTPCalendarViewEvent (CXTPCalendarEvent *pEvent, CXTPCalendarViewGroup *pViewGroup)
Default object constructor.
virtual | ~CXTPCalendarViewEvent ()
Default class destructor.
virtual CXTPCalendarEvent * | GetEvent () const
Call this member function to obtain the corresponding read only event object without increasing the object's reference counter.
virtual CXTPCalendarControl * | GetCalendarControl () const
Call this member function to obtain a pointer to the calendar control object.
virtual void | SetSelected (BOOL bSet=TRUE)
This member function is used to set the day view as select or unselected.
virtual BOOL | IsMultidayEvent () const
Call this member function to determine if the given event view is a multi-day event.
virtual CXTPCalendarViewEvent * | StartEditSubject ()
This member function is used to create and to show the subject editor.
virtual CString | GetEditingSubjectFromEditor () const
Call this member function to obtain an edited subject.
virtual CString | EndEditSubject ()
This member function is used to end the editing project, delete the subject editor, and to obtain the edited text.
virtual void | ShowToolTip ()
This member function is used to show a ToolTip rectangle.
virtual void | HideToolTip ()
This member function is used to hide the ToolTip rectangle.
virtual BOOL | IsEditingSubject () const
Call this member function to determine if the event's subject is currently being edited.
virtual CRect | GetSubjectEditorRect () const
This member function is used to obtain the subject editor rectangle coordinates.
virtual CWnd * | GetSubjectEditor () const
This member function is used to obtain the event's subject editor window.
virtual BOOL | IsShowingToolTip ()
Call this member function to determine if the event's tooltip is visible.
virtual CString | FormatEventTime (COleDateTime dtTime) const
This member function is used to format the event's time as a string with a predefined format.
virtual CRect | GetFirstClockRect () const
This member function is used to obtain the rectangle coordinates used for drawing a clock in the beginning of a multi day event.
virtual CRect | GetLastClockRect () const
This member function is used to obtain the rectangle coordinates used for drawing a clock in the end of a multi-day event.
virtual CRect | GetTextRect () const
This member function is used to obtain the rectangle coordinates used for displaying the event's subject.
virtual CRect | GetStartTimeRect () const
This member function is used to obtain the rectangle coordinates used for displaying a clock to show the start event time for single day events.
virtual CRect | GetEndTimeRect () const
This member function is used to obtain the rectangle coordinates for displaying a clock to show the end event time for single day events.
virtual CRect | GetViewEventRect () const
This member function is used to obtain the rectangle coordinates for the event's rectangle.
virtual CRect | GetViewEventRectMax () const
This member function is used to obtain the rectangle coordinates for the event's maximum rectangle dimensions.
virtual CRect | GetReminderGlyphRect () const
This member function is used to obtain the rectangle coordinates for displaying the remainder icon.
virtual CRect | GetRecurrenceGlyphRect () const
This member function is used to obtain the rectangle coordinates used for displaying the recurrence icon.
virtual CRect | GetMeetingGlyphRect () const
This member function obtains the rectangle coordinates for displaying the meeting icon.
virtual CRect | GetPrivateGlyphRect () const
This member function is used to obtain the rectangle coordinates used for displaying the private icon.
virtual BOOL | IsMultyDayTextAlign () const
This member function is used to obtain the flag to determine if multi-day text align mode is on.
virtual int | GetMultiDayEventFlags () const
This member function is used to obtain the multi-day event state flags.
virtual void | SetMultiDayEvent_MasterSlave (BOOL bMaster, CXTPCalendarViewEvent *pMasterView)
This member function is used to set the multi-day event Master/Slave state.
virtual void | AddMultiDayEvent_Slave (CXTPCalendarViewEvent *pSlaveView, int nMasterEventPlace)
This member function is used to add a Slave event view to the Master event view.
virtual void | SetTextOutOfBorders (BOOL bOutOfBorders)
This member function is used to set a flag to determine if the text size exceeds the event view bounds.
virtual BOOL | IsTextOutOfBorders () const
This member function is used to determine if the text size exceeds the event view bounds.
virtual int | GetEventPlaceNumber () const
This member function is used to obtain the place number of the event view.
virtual int | GetEventTimelinePlaceNumber () const
This member function is used to obtain the place number of the event in Timeline view.
CRect | GetEventRect () const
This member function is used to obtain the event view's bounding rectangle.
virtual void | OnPostAdjustLayout ()
This member function is used to perform additional adjustments in some kinds of views.
virtual void | AdjustSubjectEditor ()
This member function is used to perform adjustments of the subject editor area.
virtual CString | GetItemTextSubject () const
Call this function to get the item subject.
virtual CString | GetItemTextLocation () const
Call this function to get the item location.
virtual CString | GetItemTextBody () const
Call this function to get the item body.
virtual CString | GetItemTextStartTime () const
Call this function to get the item start time.
virtual CString | GetItemTextEndTime () const
Call this function to get the item end time.
virtual CString | GetItemText (DWORD dwItemFlag, LPCTSTR pcszDefaultText=NULL) const
Call this function to get the item text.
virtual CString | GetMarkupText () const
This member function is used to obtain markup template text.
virtual CXTPMarkupUIElement * | GetMarkupUIElement ()
This member function is used to get a stored CXTPMarkupUIElement object.
virtual int | CalcIconsRect (CRect rc)
This member function is used to adjust the icons rectangle used to draw the event view icons.
virtual BOOL | OnLButtonDown (UINT nFlags, CPoint point)
This member function is used to process left mouse button down events.
virtual BOOL | OnLButtonUp (UINT nFlags, CPoint point)
This member function is used to process left mouse button up events.
virtual BOOL | OnLButtonDblClk (UINT nFlags, CPoint point)
This member function is used to process left mouse button double click events.
virtual void | OnMouseMove (UINT nFlags, CPoint point)
This member function is used to process mouse movement events.
virtual BOOL | OnWndMsg (UINT message, WPARAM wParam, LPARAM lParam, LRESULT *pResult)
This method is called by framework after default message processing.
virtual UINT | SetTimer (UINT uTimeOut_ms)
This member function is used to create a timer event.
virtual void | KillTimer (UINT uTimerID)
This member function is used to destroy a timer event.
virtual BOOL | OnTimer (UINT_PTR uTimerID)
The framework calls this member function after each interval specified in the SetTimer member function.
virtual UINT | GetShowToolTipTimeOut () const
This member function is used to obtain the timeout value for displaying a tooltip.
virtual DWORD | GetSubjectEditorStyles () const
This member function is used to obtain the styles of the editor window.
virtual CFont * | GetSubjectEditorFont () const
This member function is used to obtain a pointer to the editor window font.
virtual void | OnBeforeDestroy ()
Called by the framework before the destroy() function is called.
- Public Member Functions inherited from CXTPCalendarWMHandler
CXTPCalendarWMHandler ()
Default object constructor.
virtual int | GetChildHandlersCount () const
This member function is used to obtain the number of CXTPCalendarWMHandler elements in the descendant handlers collection.
virtual CXTPCalendarWMHandler * | GetChildHandlerAt (int nIndex) const
Call this method to get a handler object at the specified numeric index.
virtual void | OnChar (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process keyboard events.
virtual void | OnKeyDown (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process key-down keyboard events.
virtual void | OnKeyUp (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process key-up keyboard events.
virtual BOOL | OnSysKeyDown (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process key-up keyboard events.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Attributes

CXTPCalendarTimeLineViewGroup * | m_pGroup
internal member to keep pointer to CXTPCalendarTimeLineViewGroup
int | m_nEventDurationInPixels
internal nmember to keep event duration in pixels value
- Protected Attributes inherited from CXTPCalendarViewEvent
CXTPCalendarEvent * m_ptrEvent
Pointer to the displayed event object.
BOOL | m_bSelected
Event view selected flag.
CXTPCalendarViewEvent * m_pMasterView
Pointer to Master event view object.
int | m_nEventPlaceNumber
Event view place number (sequential identifier).
int | m_nEventTimelinePlaceNumber
Event view place number in Timeline view.
UINT | m_nTimerID_ShowToolTip
Identifier of timer event to show tooltip with delay.
CXTPCalendarViewEventSubjectEditor * | m_pSubjectEditor
Pointer to the subject editor.
BOOL | m_bMultyDayTextAlign
Flag indicates special text alignment for a multi-day event.
BOOL | m_bTextOutOfBorders
Flag indicates text out of event borders.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCalendarViewEvent
static void AFX_CDECL | _MoveRectY (int nYbasePrev, int nYbaseNew, CRect &rRC)
This member function is used to move the rectangle vertically.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPCalendarViewEvent
CRect | m_rcEvent
Event view rectangle.
CRect | m_rcEventMax
Event view rectangle margins.
CRect | m_rcText
Rectangle to display event text in event view.
CSize | m_szText
Sizes of displayed text.
CRect | m_rcFirstClock
Rectangle to draw clock in the beginning of the first day of multi-day event.
CRect | m_rcLastClock
Rectangle to draw clock at the end of the last day of multi-day event.
CRect | m_rcStartTime
Rectangle to display start time day event view.
CRect | m_rcEndTime
Rectangle to display end time event view.
int | m_nMultiDayEventFlags
Multi-day event flags packed into integer by bitwise operations.
CRect | m_rcReminderGlyph
Rectangle to draw reminder glyph event view.
CRect | m_rcRecurrenceGlyph
Rectangle to draw recurrence glyph event view.
CRect | m_rcMeetingGlyph
Rectangle to draw meeting glyph event view.
CRect | m_rcPrivateGlyph
Rectangle to draw private glyph event view.
CRect | m_rcSubjectEditor
Subject editor rectangle.
CRect | m_rcToolTip
Tool tip rectangle.
CXTPMarkupUIElement * | m_pUIElement
Store pointer to CXTPMarkupUIElement object.
CString | m_strUIElementText
Store last markup text for which m_pUIElement object was updated.
- Protected Member Functions inherited from CXTPCalendarViewEvent
virtual void | AdjustMultidayEvent (CRect rcEventMax, int nEventPlaceNumber)
This member function is used to adjust a multi-day view's layout depending on the provided rectangle coordinates.
virtual CString | GetToolText ()
This member function is used to obtain tooltip text for the event view.

Detailed Description

This class represents an event timeline view portion of the CXTPCalendarViewEvent.

It represents a specific view of the event associated data according to various view types and display settings and provides basic functionality on this data using user input through keyboard and mouse. CXTPCalendarTimeLineViewEvent is a descendant of the CXTPCalendarViewEvent class.

Constructor & Destructor Documentation

◆ CXTPCalendarTimeLineViewEvent()

CXTPCalendarTimeLineViewEvent | ( | CXTPCalendarEvent * | pEvent,
 |  | CXTPCalendarTimeLineViewGroup * | pGroup )

Default object constructor.

Parameters
pEvent | A pointer to a CXTPCalendarEvent object.
pGroup | A pointer to a CXTPCalendarTimeLineViewGroup object.

Member Function Documentation

◆ AdjustLayout()

virtual void AdjustLayout | ( | CDC * | pDC,
 |  | const CRect & | rcEventMax,
 |  | int | nEventPlaceNumber )
 virtual

This member function is used to adjust the view's layout.

Parameters
pDC | A pointer to a valid device context.
rcEventMax | A CRect object that contains the rectangle coordinates that are used to draw the view.
nEventPlaceNumber | Ordinal number of event.

Reimplemented from CXTPCalendarViewEvent.

◆ AdjustLayout2()

virtual void AdjustLayout2 | ( | CDC * | pDC,
 |  | const CRect & | rcEventMax,
 |  | int | nEventPlaceNumber )
 inlinevirtual

This member function is used to adjust the view's layout with the theme used.

Parameters
pDC | A pointer to a valid device context.
rcEventMax | A CRect object that contains the rectangle coordinates that are used to draw the view.
nEventPlaceNumber | Ordinal number of event.

Implements CXTPCalendarViewEvent.

◆ CalcRect()

void CalcRect ( CDC * pDC )

This member function is used to calculate a rectangle for an event.

Parameters
pDC A pointer to a valid device context.

◆ ChangeEventPlace()

virtual void ChangeEventPlace ( int nNewPlace )
virtual

This function is used to change the event place number.

Parameters
nNewPlace new event place number.

Reimplemented from CXTPCalendarViewEvent.

◆ Draw()

virtual void Draw ( CDC * pDC )
virtual

This member function is used to draw the view content using the specified device context.

Parameters
pDC A pointer to a valid device context.

Implements CXTPCalendarViewEvent.

◆ GetEventDurationInPixels()

AFX_INLINE int GetEventDurationInPixels ( ) const
virtual

Access function to get event duration in pixels.

Returns
Event duration in pixels as int.

◆ GetLastVisibleRect()

AFX_INLINE const CRect & GetLastVisibleRect ( ) const

Returns the rect in the client coordinates in which the event was drawn last time.

GetLastVisibleRect and SetLastVisibleRect are workaround functions for HitTest in Timeline view. SetLastVisibleRects is called by the draw operation each time the event is drawn in timeline view. GetLastVisibleRect is used in the HitTest function to determine the HitTest info.

Returns
The last used rectangle for event drawing.

◆ GetPart()

virtual CXTPCalendarTimeLineViewPart * GetPart ( ) const
virtual

Access function to get the visual part of a CXTPCalendarTimeLineViewPart object.

Returns
Pointer to a CXTPCalendarTimeLineViewPart object.

◆ GetView()

CXTPCalendarTimeLineView * GetView ( ) const

This member function is used to obtain the owner view object.

Returns
A CXTPCalendarTimeLineView pointer to the owner view object.

◆ GetViewGroup()

CXTPCalendarTimeLineViewGroup * GetViewGroup ( ) const
inline

Access function to get view group.

Returns
Current view group as a pointer to CXTPCalendarTimeLineViewGroup.

◆ GetViewGroup_()

AFX_INLINE CXTPCalendarViewGroup * GetViewGroup_ ( ) const
virtual

Access function to get view group.

Returns
Current view group as a pointer to CXTPCalendarTimeLineViewGroup.

Implements CXTPCalendarViewEvent.

◆ HitTest()

virtual BOOL HitTest | ( | CPoint | pt,
 |  | XTP_CALENDAR_HITTESTINFO * | pHitTest ) const
 inlinevirtual

This member function is used to determine which view item, if any, is at a specified position index, and returns additional info in an XTP_CALENDAR_HITTESTINFO struct.

Parameters
pt | A CPoint that contains the coordinates of the point to test.
pHitTest | A pointer to an XTP_CALENDAR_HITTESTINFO structure that contains information about the point to test.
Returns
A BOOL. TRUE if the item is found. FALSE otherwise.
See also
XTP_CALENDAR_HITTESTINFO

Reimplemented from CXTPCalendarViewEvent.

◆ HitTestEx()

virtual BOOL HitTestEx | ( | CPoint | pt,
 |  | XTP_CALENDAR_HITTESTINFO * | pHitTest ) const
 inlinevirtual

This member function is used to determine which view item, if any, is at a specified position index, and returns additional info in an XTP_CALENDAR_HITTESTINFO template parameter.

Parameters
pt | A CPoint that contains the coordinates of the point to test.
pHitTest | A pointer to a XTP_CALENDAR_HITTESTINFO. Template parameter specifies the type of HitTest info structure.
Returns
TRUE if item is found. FALSE otherwise.
See also
XTP_CALENDAR_HITTESTINFO

Implements CXTPCalendarViewEvent.

◆ IsSelected()

virtual BOOL IsSelected ( ) const
virtual

This member function is used to get is group selected.

Returns
TRUE if object is selected, FALSE otherwise.

Reimplemented from CXTPCalendarViewEvent.

◆ IsVisible()

virtual BOOL IsVisible ( ) const
inlinevirtual

This member function is used to get is group visible.

Returns
TRUE if object is visible, FALSE otherwise.

Implements CXTPCalendarViewEvent.

◆ SetLastVisibleRect()

AFX_INLINE void SetLastVisibleRect ( const CRect & rc )

Sets the rect in the client coordinates in which the event was drawn last time.

Parameters
rc A new value of the last used draw rectangle.

GetLastVisibleRect and SetLastVisibleRect are workaround functions for HitTest in Timeline view. SetLastVisibleRects is called by the draw operation each time the event is drawn in timeline view. GetLastVisibleRect is used in the HitTest function to determine the HitTest info.

The documentation for this class was generated from the following file:
  • XTPCalendarTimeLineViewGroup.h


Toolkit Pro: CXTPCalendarTimeLineViewGroup Class Reference

Public Types | Public Member Functions | Protected Types | Protected Attributes | List of all members
CXTPCalendarTimeLineViewGroup Class Reference

This class represents an event timeline view portion of the CalendarViewGroup. More...

Inheritance diagram for CXTPCalendarTimeLineViewGroup:
[legend]

Public Types

typedef CXTPCalendarViewGroup TBase
Base class type definition.

Public Member Functions

CXTPCalendarTimeLineViewGroup (CXTPCalendarTimeLineView *pView, CXTPCalendarTimeLineViewGroup *pParentGroup=NULL)
Default object constructor.
virtual | ~CXTPCalendarTimeLineViewGroup ()
Default class destructor.
virtual void | Populate (COleDateTime dtDayDate)
This member function is used to populate the view with data for all event items contained in the view.
virtual void | Populate (CXTPCalendarEvents *pEvents)
This member function is used to populate the view with data for all event items contained in the view.
virtual void | AdjustLayout (CDC *pDC, const CRect &rcGroup)
This member function is used to adjust the view's layout depending on the provided rectangle and calls AdjustLayout() for all sub-items.
virtual void | Draw (CDC *pDC, int nOffset)
This member function is used to draw the group using the specified device context.
virtual void | Draw (CDC *pDC)
This member function is used to draw the group using the specified device context.
virtual BOOL | HitTest (CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const
This member function is used to determine which view item, if any, is at a specified position index, and returns additional info in a XTP_CALENDAR_HITTESTINFO struct.
virtual void | FillHitTestEx (XTP_CALENDAR_HITTESTINFO *pHitTest) const
This member function is used to fill the pHitTest structure members with the default values for the current day view object.
CXTPCalendarTimeLineView * | GetView () const
This member function is used to obtain the owner view object.
virtual CXTPCalendarTimeLineViewEvent * | GetViewEvent (int nIndex) const
Call this member function to obtain a pointer to the base CXTPCalendarViewEvent* object that corresponds to the event's index.
virtual CXTPCalendarViewDay * | GetViewDay_ () const
Call this member function to obtain a pointer to the containing CXTPCalendarViewDay object.
virtual CXTPCalendarControl * | GetCalendarControl () const
Call this member function to obtain a pointer to the calendar control object.
int | GetGroupHeight ()
Call this member function to obtain the current height of the group.
- Public Member Functions inherited from CXTPCalendarViewGroup
CXTPCalendarViewGroup (CXTPCalendarViewDay *pViewDay)
Default object constructor.
virtual | ~CXTPCalendarViewGroup ()
Default class destructor.
virtual CXTPCalendarResources * | GetResources () const
Obtain a pointer to a collection of Calendar Resources.
virtual CXTPCalendarData * | GetDataProvider () const
Returns data provider for this view group.
virtual void | AddResource (CXTPCalendarResource *pResource, BOOL bWithAddRef)
Adds a new Resource object into the collection of resources for this Group View.
virtual void | SetResources (CXTPCalendarResources *pResources)
Assigns a new Resources collection to this Group View.
virtual UINT | GetScheduleID () const
Returns default Schedule ID - the first existing one.
virtual void | AdjustLayout2 (CDC *pDC, const CRect &rcGroup)
This member function is used to adjust the view's layout depending on the provided rectangle and then calls AdjustLayout() for all of the sub-items.
virtual BOOL | HitTestEx (CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const
This member function is used to determine which view item, if any, is at the specified position index, and returns additional info in the XTP_CALENDAR_HITTESTINFO template object.
virtual CRect | GetRect () const
Call this member function to obtain the group's rectangle area.
virtual CRect | GetHeaderRect () const
Call this member function to obtain the group's header rectangle area.
virtual CRect | GetTooltipRect (const CPoint &ptHit, const XTP_CALENDAR_HITTESTINFO &hitInfo) const
Call this member function to obtain the bounding rectangle of the tooltip space (currently this is only "click to add new appointment").
int | GetViewEventsCount () const
Call this member function to obtain the number of event views in the day view collection.
CXTPCalendarViewEvent * | GetViewEvent_ (int nIndex) const
Call this member function to obtain a pointer to a CXTPCalendarViewEvent object associated with the event's index.
CXTPCalendarViewDay * | GetViewDay_ () const
Call this member function to obtain a pointer to the containing CXTPCalendarViewDay object.
virtual int | GetGroupIndex () const
This member function is used to obtain the index of the "this" pointer Group View in the Calendar Day View.
virtual CString | GetCaption () const
This member function is used to obtain a group's view caption.
virtual int | GetChildHandlersCount () const
This member function is used to obtain the number of event views elements in this Group View.
virtual CXTPCalendarWMHandler * | GetChildHandlerAt (int nIndex) const
Call this method to get an event view object at the specified numeric index.
virtual CXTPCalendarViewEvent * | GetViewEventByEvent_ (CXTPCalendarEvent *pEvent) const
Call this member function to obtain a pointer to a CXTPCalendarViewEvent object that is identified by the corresponding event object.
virtual CXTPCalendarViewEvent * | GetViewEventByPlace_ (int nEventPlace) const
Call this member function to obtain an event view object identified by its event place number.
virtual void | ExchangeEventPlace (CXTPCalendarViewEvent *pViewEvent, int nNewPlace)
This member function is used to exchange event view positions.
- Public Member Functions inherited from CXTPCalendarWMHandler
CXTPCalendarWMHandler ()
Default object constructor.
virtual BOOL | OnLButtonDown (UINT nFlags, CPoint point)
This member function is used to process left mouse button down events.
virtual BOOL | OnLButtonUp (UINT nFlags, CPoint point)
This member function is used to process left mouse button up events.
virtual BOOL | OnLButtonDblClk (UINT nFlags, CPoint point)
This member function is used to process left mouse button double click events.
virtual void | OnMouseMove (UINT nFlags, CPoint point)
This member function is used to process mouse movement events.
virtual void | OnChar (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process keyboard events.
virtual void | OnKeyDown (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process key-down keyboard events.
virtual void | OnKeyUp (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process key-up keyboard events.
virtual BOOL | OnSysKeyDown (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process key-up keyboard events.
virtual BOOL | OnTimer (UINT_PTR uTimerID)
The framework calls this member function after each interval specified in the SetTimer member function.
virtual BOOL | OnWndMsg (UINT message, WPARAM wParam, LPARAM lParam, LRESULT *pResult)
This method is called by framework after default message processing.
virtual void | OnPostAdjustLayout ()
This member function is used to perform additional adjustments in some kinds of views.
virtual void | OnBeforeDestroy ()
This member function is called by the framework before destroying the view.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Types

typedef CXTPCalendarPtrCollectionT< CXTPCalendarTimeLineViewEvent > TViewEventsCollection

Protected Attributes

CXTPCalendarTimeLineViewGroup * | m_pParentGroup
pointer to the owner view group object
CXTPCalendarTimeLineViewGroups * | m_pChildren
not used in current version - always NULL
- Protected Attributes inherited from CXTPCalendarViewGroup
XTP_VIEW_GROUP_LAYOUT | m_Layout
This group view client coordinates.
CXTPCalendarPtrCollectionT< CXTPCalendarViewEvent > | m_arEvents
Storage for events views.
CXTPCalendarResources * | m_pResources
An associated resource object.
CXTPCalendarViewDay * | m_pViewDay
Parent day view.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Member Functions inherited from CXTPCalendarViewGroup
virtual UINT | SetTimer (UINT uTimeOut_ms)
This member function is used to create a timer event.
virtual void | KillTimer (UINT uTimerID)
This member function is used to destroy a timer event.
virtual void | OnPrePopulate (CXTPCalendarEvents *pEvents)
This member function is used to allow some customization before show events.

Detailed Description

This class represents an event timeline view portion of the CalendarViewGroup.

It represents a specific view of the event associated data according to various view types and display settings and provides basic functionality on this data using user input through keyboard and mouse. CXTPCalendarTimeLineViewGroup is a descendant of the CXTPCalendarViewGroup class.

Member Typedef Documentation

◆ TViewEventsCollection

CXTPCalendarPtrCollectionT<CXTPCalendarTimeLineViewEvent> TViewEventsCollection
protected

Event views collection type definition.

Constructor & Destructor Documentation

◆ CXTPCalendarTimeLineViewGroup()

CXTPCalendarTimeLineViewGroup | ( | CXTPCalendarTimeLineView * | pView,
 |  | CXTPCalendarTimeLineViewGroup * | pParentGroup = NULL )

Default object constructor.

Parameters
pView | A pointer to a CXTPCalendarTimeLineView object.
pParentGroup | A pointer to a CXTPCalendarTimeLineViewGroup object.

Member Function Documentation

◆ AdjustLayout()

virtual void AdjustLayout | ( | CDC * | pDC,
 |  | const CRect & | rcGroup )
 virtual

This member function is used to adjust the view's layout depending on the provided rectangle and calls AdjustLayout() for all sub-items.

Parameters
pDC | A pointer to a valid device context.
rcGroup | rectangle used to draw the group.

Reimplemented from CXTPCalendarViewGroup.

◆ Draw() [1/2]

virtual void Draw ( CDC * pDC )
virtual

This member function is used to draw the group using the specified device context.

Parameters
pDC A pointer to a valid device context.

Reimplemented from CXTPCalendarViewGroup.

◆ Draw() [2/2]

virtual void Draw | ( | CDC * | pDC,
 |  | int | nOffset )
 virtual

This member function is used to draw the group using the specified device context.

Parameters
pDC | A pointer to a valid device context.
nOffset | Vertical offset to draw.

◆ FillHitTestEx()

virtual void FillHitTestEx ( XTP_CALENDAR_HITTESTINFO * pHitTest ) const
inlinevirtual

This member function is used to fill the pHitTest structure members with the default values for the current day view object.

Parameters
pHitTest A Pointer to an XTP_CALENDAR_HITTESTINFO structure.

This is a pure virtual function. This function must be defined in the derived class.

Implements CXTPCalendarViewGroup.

◆ GetCalendarControl()

virtual CXTPCalendarControl * GetCalendarControl ( ) const
virtual

Call this member function to obtain a pointer to the calendar control object.

Returns
A pointer to a CXTPCalendarControl object.

Reimplemented from CXTPCalendarViewGroup.

◆ GetGroupHeight()

int GetGroupHeight ( )

Call this member function to obtain the current height of the group.

Returns
An int that contains the current height of the group.

◆ GetView()

CXTPCalendarTimeLineView * GetView ( ) const
inline

This member function is used to obtain the owner view object.

Returns
A CXTPCalendarTimeLineView pointer to the owner view object.

◆ GetViewDay_()

virtual CXTPCalendarViewDay * GetViewDay_ ( ) const
inlinevirtual

Call this member function to obtain a pointer to the containing CXTPCalendarViewDay object.

Returns
A pointer to the CXTPCalendarViewDay object.

◆ GetViewEvent()

virtual CXTPCalendarTimeLineViewEvent * GetViewEvent ( int nIndex ) const
inlinevirtual

Call this member function to obtain a pointer to the base CXTPCalendarViewEvent* object that corresponds to the event's index.

Parameters
nIndex Index of the event in m_arEvents.
Returns
A pointer to the CXTPCalendarViewEvent object.

◆ HitTest()

virtual BOOL HitTest | ( | CPoint | pt,
 |  | XTP_CALENDAR_HITTESTINFO * | pHitTest ) const
 inlinevirtual

This member function is used to determine which view item, if any, is at a specified position index, and returns additional info in a XTP_CALENDAR_HITTESTINFO struct.

Parameters
pt | A CPoint that contains the coordinates of the point to test.
pHitTest | A pointer to a XTP_CALENDAR_HITTESTINFO structure that contains information about the point to test.
Returns
A BOOL. TRUE if the item is found. FALSE otherwise.
See also
XTP_CALENDAR_HITTESTINFO

Reimplemented from CXTPCalendarViewGroup.

◆ Populate() [1/2]

virtual void Populate ( COleDateTime dtDayDate )
inlinevirtual

This member function is used to populate the view with data for all event items contained in the view.

Parameters
dtDayDate A COleDateTime object that contains the day's date.

This function provides common functionality for all CXTPCalendarViewGroup - derived classes.

Reimplemented from CXTPCalendarViewGroup.

◆ Populate() [2/2]

virtual void Populate ( CXTPCalendarEvents * pEvents )
virtual

This member function is used to populate the view with data for all event items contained in the view.

Parameters
pEvents pointer to CXTPCalendarEvents.
The documentation for this class was generated from the following file:
  • XTPCalendarTimeLineViewGroup.h


Toolkit Pro: CXTPCalendarTimeLineViewGroups Class Reference

List of all members
CXTPCalendarTimeLineViewGroups Class Reference

This class represents a collection of CXTPCalendarTimeLineViewGroup objects. More...

Inheritance diagram for CXTPCalendarTimeLineViewGroups:
[legend]

Additional Inherited Members

- Public Member Functions inherited from CXTPCalendarPtrCollectionT< CXTPCalendarTimeLineViewGroup >
CXTPCalendarPtrCollectionT ()
Default collection constructor.
virtual | ~CXTPCalendarPtrCollectionT ()
Default collection destructor.
virtual int | GetCount () const
This member function is used to obtain the number of elements in the collection.
virtual void | Add (CXTPCalendarTimeLineViewGroup *pNewElement)
This member function adds a new element to the end of the array.
virtual void | Add (CXTPCalendarTimeLineViewGroup *pNewElement, BOOL bWithAddRef)
This member function adds a new element to the end of the array.
virtual void | SetAt (int nIndex, CXTPCalendarTimeLineViewGroup *pElement)
This member function is used to set a new element to the position specified in the nIndex parameter.
virtual int | Find (const CXTPCalendarTimeLineViewGroup *pElement) const
This member function finds an element index in the collection using its pointer.
virtual void | InsertAt (int nIndex, CXTPCalendarTimeLineViewGroup *pElement)
This member function is used to insert a new element at the position specified in the nIndex parameter.
virtual void | Append (const CXTPCalendarPtrCollectionT< CXTPCalendarTimeLineViewGroup > *pElementsArray)
This member function is used to add a new elements to the end of the array.
virtual void | SetSize (int nNewSize)
This member function is used to change the array size.
virtual CXTPCalendarTimeLineViewGroup * | GetAt (int nIndex) const
This member function returns an element at the specified numeric index.
virtual CXTPCalendarTimeLineViewGroup * | GetAt (int nIndex, BOOL bWithAddRef) const
This member function returns an element at the specified numeric index.
virtual void | RemoveAt (int nIndex)
This member function removes an element at the specified index from the array.
virtual void | Remove (CXTPCalendarTimeLineViewGroup *pElement)
This member function finds an element using its pointer and removes it from the array.
virtual void | RemoveAll ()
This member function is used to remove all of the elements from the array.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Types inherited from CXTPCalendarPtrCollectionT< CXTPCalendarTimeLineViewGroup >
typedef CXTPSmartPtrInternalT< CXTPCalendarTimeLineViewGroup > | TObjectPtr
Smart pointer type for stored objects.
- Protected Attributes inherited from CXTPCalendarPtrCollectionT< CXTPCalendarTimeLineViewGroup >
CArray< TObjectPtr, TObjectPtr & > | m_arElements
Objects storage.

Detailed Description

This class represents a collection of CXTPCalendarTimeLineViewGroup objects.

The documentation for this class was generated from the following file:
  • XTPCalendarTimeLineViewGroup.h


Toolkit Pro: CXTPCalendarTimeLineViewPart Class Reference

Public Member Functions | List of all members
CXTPCalendarTimeLineViewPart Class Reference

Helper base class to implement parts for calendar paint manager objects. More...

Inheritance diagram for CXTPCalendarTimeLineViewPart:
[legend]

Public Member Functions

CXTPCalendarTimeLineViewPart (CXTPCalendarViewPart *pParentPart=NULL)
Default object constructor.
virtual void | Draw (CDC *pDC, const CRect &rcRect, CXTPCalendarTimeLineView *pView)
This member function is used to draw the part content utilizing the specified device context.
virtual CSize | CalcEventSize (CDC *pDC, CXTPCalendarTimeLineViewEvent *pEventView)
This member function is used to calculate the rectangle needed to draw an event.
virtual void | DrawEvent (CDC *pDC, const CRect &rcEvents, CXTPCalendarTimeLineViewEvent *pEventView)
This member function is used to draw the event utilizing the specified device context.
- Public Member Functions inherited from CXTPCalendarViewPart
CXTPCalendarViewPart (CXTPCalendarViewPart *pParentPart=NULL)
Default constructor.
virtual | ~CXTPCalendarViewPart ()
Default destructor.
virtual void | RefreshMetrics ()
This member function is used to set graphical related parameters equal to the system settings.
virtual COLORREF | GetBackgroundColor ()
This member function is used to obtain the color used to fill the background of UI elements.
virtual COLORREF | GetTextColor ()
This member function is used to obtain the color used to display text.
virtual CFont & | GetTextFont ()
This member function is used to obtain a pointer to a CFont object that contains the font that is used for displaying the text.
void | DrawText (CDC *pDC, const CString &str, LPRECT lpRect, UINT nFormat, COLORREF clrText=COLORREF_NULL, CFont *pFont=NULL)
This member function is used to display the text using the custom font and color.
void | DrawLine_CenterLR (CDC *pDC, const CString &str, LPRECT lpRect, UINT nFormat)
This member function is used to draw a single line text in the center of the rect.
void | DrawLineEx (CDC *pDC, const CString &str, LPRECT lpRect, UINT nFormatNormal, UINT nFormatSmall)
This member function is used to draw a single line text in the rect.
CSize | GetTextExtent (CDC *pDC, const CString &str)
This member function is used to calculate the size of the area required to display the given text.
void | SetBackgroundColor (COLORREF clr)
This member function is used to set the new color used to fill the background.
void | SetTextColor (COLORREF clr)
This member function is used to set the new color used to display the text.
void | SetTextFont (LOGFONT *pLogFont)
This member function is used to set the new font used to display the text.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPCalendarViewPart
CXTPPaintManagerColor | m_clrTextColor
Stores color settings used to display text.
CXTPPaintManagerColor | m_clrBackground
Stores color settings used to to fill background of UI item.
CXTPCalendarViewPartFontValue | m_fntText
Stores font settings used to display text.
CXTPCalendarViewPart * | m_pParentPart
Pointer to the parent CXTPCalendarViewPart object.
CXTPCalendarPaintManager * | m_pPaintManager
Pointer to containing CXTPCalendarPaintManager object.
- Protected Member Functions inherited from CXTPCalendarViewPart

Detailed Description

Helper base class to implement parts for calendar paint manager objects.

Constructor & Destructor Documentation

◆ CXTPCalendarTimeLineViewPart()

CXTPCalendarTimeLineViewPart ( CXTPCalendarViewPart * pParentPart = NULL )
inline

Default object constructor.

Parameters
pParentPart Pointer to CXTPCalendarViewPart.

Member Function Documentation

◆ CalcEventSize()

virtual CSize CalcEventSize | ( | CDC * | pDC,
 |  | CXTPCalendarTimeLineViewEvent * | pEventView )
 inlinevirtual

This member function is used to calculate the rectangle needed to draw an event.

Parameters
pDC | Pointer to a valid device context.
pEventView | Pointer to CXTPCalendarTimeLineViewEvent.
Returns
CSize object needed to draw event.

◆ Draw()

virtual void Draw | ( | CDC * | pDC,
 |  | const CRect & | rcRect,
 |  | CXTPCalendarTimeLineView * | pView )
 inlinevirtual

This member function is used to draw the part content utilizing the specified device context.

Parameters
pDC | Pointer to a valid device context.
rcRect | Rectangle to use.
pView | Pointer to CXTPCalendarTimeLineView.

◆ DrawEvent()

virtual void DrawEvent | ( | CDC * | pDC,
 |  | const CRect & | rcEvents,
 |  | CXTPCalendarTimeLineViewEvent * | pEventView )
 inlinevirtual

This member function is used to draw the event utilizing the specified device context.

Parameters
pDC | Pointer to a valid device context.
rcEvents | Rectangle to use.
pEventView | Pointer to CXTPCalendarTimeLineViewEvent.
The documentation for this class was generated from the following file:
  • XTPCalendarViewPart.h


Toolkit Pro: CXTPCalendarTimeLineViewTimeScale Class Reference

Public Member Functions | Public Attributes | Protected Attributes | List of all members
CXTPCalendarTimeLineViewTimeScale Class Reference

This class implements a specific view portion of the Calendar control called Timeline view scale. More...

Inheritance diagram for CXTPCalendarTimeLineViewTimeScale:
[legend]

Public Member Functions

CXTPCalendarTimeLineViewTimeScale (CXTPCalendarTimeLineView *pView)
Default object constructor.
virtual | ~CXTPCalendarTimeLineViewTimeScale ()
Default class destructor.
CXTPCalendarTimeLineView * | GetView () const
This member function is used to obtain the owner view object.
virtual CXTPCalendarTLV_TimeScaleParams * | GetTimeScaleParams () const
Access function to get time scale params.
virtual void | SetTimeScaleParams (int eTimeScaleParamsID)
Access function to set time scale params from the predefined set XTPEnumCalendarTimeScaleParamsID.
virtual void | SetTimeScaleParams2 (CXTPCalendarTLV_TimeScaleParams *pSParams)
Access function to set time scale params from another CXTPCalendarTLV_TimeScaleParams object.
virtual COleDateTime | GetStartViewDate () const
Access function to get start view date value.
virtual void | SetStartViewDate (COleDateTime dt)
Access function to set start view date value.
virtual void | AdjustLayout (CRect rcParentRect)
This member function is used to adjust time scale layout depending on the provided parent rectangle.
virtual CRect | GetClientRect (int nYstart=0)
Access function to get client rectangle according to passed vertical start position.
virtual CRect | GetRect () const
Access function to get time scale rectangle.
virtual void | Draw (CDC *pDC)
This member function is used to draw the time scale for the specified device context.
virtual BOOL | HitTestEx (CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const
This member function is used to determine which view item, if any, is at a specified position index, and returns additional info in an XTP_CALENDAR_HITTESTINFO struct.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Public Attributes

CRect m_rcScale
internal member to keep time scale rectangle

Protected Attributes

CXTPCalendarTimeLineView * | m_pParentView
Internal pointer to parent view.
COleDateTime | m_dtStartViewDate
Internal datetime object to keep start view date.
CRect | m_rcRect
Internal member used for layout adjustment.
CXTPCalendarTLV_TimeScaleParams * | m_pTimeScaleParams
Internal pointer to CXTPCalendarTLV_TimeScaleParams.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

This class implements a specific view portion of the Calendar control called Timeline view scale.

Constructor & Destructor Documentation

◆ CXTPCalendarTimeLineViewTimeScale()

CXTPCalendarTimeLineViewTimeScale ( CXTPCalendarTimeLineView * pView )

Default object constructor.

Parameters
pView Pointer to the associated CXTPCalendarTimeLineView object.

◆ ~CXTPCalendarTimeLineViewTimeScale()

virtual ~CXTPCalendarTimeLineViewTimeScale ( )
virtual

Default class destructor.

Handles member items deallocation.

Member Function Documentation

◆ AdjustLayout()

virtual void AdjustLayout ( CRect rcParentRect )
virtual

This member function is used to adjust time scale layout depending on the provided parent rectangle.

Parameters
rcParentRect Provided parent rectangle.

◆ Draw()

virtual void Draw ( CDC * pDC )
virtual

This member function is used to draw the time scale for the specified device context.

Parameters
pDC A pointer to a valid device context.

◆ GetClientRect()

virtual CRect GetClientRect ( int nYstart = 0 )
virtual

Access function to get client rectangle according to passed vertical start position.

Parameters
nYstart Vertical start position.
Returns
Client rectangle as a CRect object.

◆ GetRect()

AFX_INLINE CRect GetRect ( ) const
virtual

Access function to get time scale rectangle.

Returns
Time scale rectangle as CRect object.

◆ GetStartViewDate()

AFX_INLINE COleDateTime GetStartViewDate ( ) const
virtual

Access function to get start view date value.

Returns
Start view date value as a COleDateTime object.

◆ GetTimeScaleParams()

AFX_INLINE CXTPCalendarTLV_TimeScaleParams * GetTimeScaleParams ( ) const
virtual

Access function to get time scale params.

Returns
Pointer to a CXTPCalendarTLV_TimeScaleParams object.

◆ GetView()

AFX_INLINE CXTPCalendarTimeLineView * GetView ( ) const

This member function is used to obtain the owner view object.

Returns
A CXTPCalendarTimeLineView pointer to the owner view object.

◆ HitTestEx()

virtual BOOL HitTestEx | ( | CPoint | pt,
 |  | XTP_CALENDAR_HITTESTINFO * | pHitTest ) const
 virtual

This member function is used to determine which view item, if any, is at a specified position index, and returns additional info in an XTP_CALENDAR_HITTESTINFO struct.

Parameters
pt | A CPoint that contains the coordinates of the point to test.
pHitTest | A pointer to an XTP_CALENDAR_HITTESTINFO structure that contains information about the point to test.
Returns
A BOOL. TRUE if the item is found, otherwise FALSE.
See also
XTP_CALENDAR_HITTESTINFO

◆ SetStartViewDate()

AFX_INLINE void SetStartViewDate ( COleDateTime dt )
virtual

Access function to set start view date value.

Parameters
dt New start view date value.

◆ SetTimeScaleParams()

virtual void SetTimeScaleParams ( int eTimeScaleParamsID )
virtual

Access function to set time scale params from the predefined set XTPEnumCalendarTimeScaleParamsID.

Parameters
eTimeScaleParamsID One of the time scale parameters defined by XTPEnumCalendarTimeScaleParamsID.

◆ SetTimeScaleParams2()

virtual void SetTimeScaleParams2 ( CXTPCalendarTLV_TimeScaleParams * pSParams )
virtual

Access function to set time scale params from another CXTPCalendarTLV_TimeScaleParams object.

Parameters
pSParams Pointer to a CXTPCalendarTLV_TimeScaleParams object.
The documentation for this class was generated from the following file:
  • XTPCalendarTimeLineViewTimeScale.h


Toolkit Pro: CXTPCalendarTimeLineViewTimeScalePart Class Reference

Public Member Functions | Public Attributes | List of all members
CXTPCalendarTimeLineViewTimeScalePart Class Reference

Helper base class to implement parts for calendar paint manager. More...

Inheritance diagram for CXTPCalendarTimeLineViewTimeScalePart:
[legend]

Public Member Functions

CXTPCalendarTimeLineViewTimeScalePart (CXTPCalendarViewPart *pParentPart=NULL)
Default object constructor.
virtual void | RefreshMetrics ()
This member function is used to set graphical related parameters equal to the system settings.
virtual int | CalcHeigt (CDC *pDC)
This member function is used to calculate height utilizing the specified device context.
virtual void | Draw (CDC *pDC, const CRect &rcRect, CXTPCalendarTimeLineView *pView)
This member function is used to draw the part content utilizing the specified device context.
virtual int | GetHeaderHeight ()
Access function to get header height.
virtual CString | GetHeaderDateFormat (int nLabelInterval)
Access function to get header date format.
virtual void | DrawHeader (CDC *pDC, const CRect &rcRect, CXTPCalendarTimeLineView *pView, int nLabelInterval)
This member function is used to draw the part content utilizing the specified device context.
- Public Member Functions inherited from CXTPCalendarViewPart
CXTPCalendarViewPart (CXTPCalendarViewPart *pParentPart=NULL)
Default constructor.
virtual | ~CXTPCalendarViewPart ()
Default destructor.
virtual COLORREF | GetBackgroundColor ()
This member function is used to obtain the color used to fill the background of UI elements.
virtual COLORREF | GetTextColor ()
This member function is used to obtain the color used to display text.
virtual CFont & | GetTextFont ()
This member function is used to obtain a pointer to a CFont object that contains the font that is used for displaying the text.
void | DrawText (CDC *pDC, const CString &str, LPRECT lpRect, UINT nFormat, COLORREF clrText=COLORREF_NULL, CFont *pFont=NULL)
This member function is used to display the text using the custom font and color.
void | DrawLine_CenterLR (CDC *pDC, const CString &str, LPRECT lpRect, UINT nFormat)
This member function is used to draw a single line text in the center of the rect.
void | DrawLineEx (CDC *pDC, const CString &str, LPRECT lpRect, UINT nFormatNormal, UINT nFormatSmall)
This member function is used to draw a single line text in the rect.
CSize | GetTextExtent (CDC *pDC, const CString &str)
This member function is used to calculate the size of the area required to display the given text.
void | SetBackgroundColor (COLORREF clr)
This member function is used to set the new color used to fill the background.
void | SetTextColor (COLORREF clr)
This member function is used to set the new color used to display the text.
void | SetTextFont (LOGFONT *pLogFont)
This member function is used to set the new font used to display the text.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Public Attributes

CXTPCalendarViewPartFontValue | m_fntScaleHeaderText
Time scale header text font.
- Public Attributes inherited from CXTPCalendarViewPart
CXTPPaintManagerColor | m_clrTextColor
Stores color settings used to display text.
CXTPPaintManagerColor | m_clrBackground
Stores color settings used to to fill background of UI item.
CXTPCalendarViewPartFontValue | m_fntText
Stores font settings used to display text.
CXTPCalendarViewPart * | m_pParentPart
Pointer to the parent CXTPCalendarViewPart object.
CXTPCalendarPaintManager * | m_pPaintManager
Pointer to containing CXTPCalendarPaintManager object.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Member Functions inherited from CXTPCalendarViewPart

Detailed Description

Helper base class to implement parts for calendar paint manager.

objects.

Constructor & Destructor Documentation

◆ CXTPCalendarTimeLineViewTimeScalePart()

CXTPCalendarTimeLineViewTimeScalePart ( CXTPCalendarViewPart * pParentPart = NULL )

Default object constructor.

Parameters
pParentPart Pointer to CXTPCalendarViewPart.

Member Function Documentation

◆ CalcHeigt()

virtual int CalcHeigt ( CDC * pDC )
virtual

This member function is used to calculate height utilizing the specified device context.

Parameters
pDC Pointer to a valid device context.
Returns
Calculated height as int.

◆ Draw()

virtual void Draw | ( | CDC * | pDC,
 |  | const CRect & | rcRect,
 |  | CXTPCalendarTimeLineView * | pView )
 virtual

This member function is used to draw the part content utilizing the specified device context.

Parameters
pDC | Pointer to a valid device context.
rcRect | Rectangle to use.
pView | Pointer to CXTPCalendarTimeLineView.

◆ DrawHeader()

virtual void DrawHeader | ( | CDC * | pDC,
 |  | const CRect & | rcRect,
 |  | CXTPCalendarTimeLineView * | pView,
 |  | int | nLabelInterval )
 virtual

This member function is used to draw the part content utilizing the specified device context.

Parameters
pDC | Pointer to a valid device context.
rcRect | Rectangle to use.
pView | Pointer to CXTPCalendarTimeLineView.
nLabelInterval | int param used to select format.

◆ GetHeaderDateFormat()

virtual CString GetHeaderDateFormat ( int nLabelInterval )
virtual

Access function to get header date format.

Parameters
nLabelInterval int param used to select format.
Returns
Current header date format as CString object.

◆ GetHeaderHeight()

virtual int GetHeaderHeight ( )
inlinevirtual

Access function to get header height.

Returns
Current header height as int.
The documentation for this class was generated from the following file:
  • XTPCalendarViewPart.h


Toolkit Pro: CXTPCalendarTimeZone Class Reference

Public Member Functions | Static Public Member Functions | Protected Attributes | List of all members
CXTPCalendarTimeZone Class Reference

This class extends the TIME_ZONE_INFORMATION structure. More...

Inheritance diagram for CXTPCalendarTimeZone:
[legend]

Public Member Functions

CXTPCalendarTimeZone (const TIME_ZONE_INFORMATION *pTZInfo=NULL)
Default object constructor.
CXTPCalendarTimeZone (const CXTPCalendarTimeZone *pTZInfoEx)
Default object constructor.
virtual | ~CXTPCalendarTimeZone ()
Default object destructor.
CString | GetDisplayString () const
Get a time zone display string value.
DWORD | GetIndex () const
Get a time zone order index value.
BOOL | IsEqual (const TIME_ZONE_INFORMATION *pTZI2) const
Compare 2 time zones data.
const CXTPCalendarTimeZone & | operator= (const CXTPCalendarTimeZone &rTZInfo)
Copy operator.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Static Public Member Functions

static CXTPCalendarTimeZonePtr AFX_CDECL | GetTimeZoneInfo (const TIME_ZONE_INFORMATION *pTZIdata)
Get full information about the specified time zone.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Protected Attributes

CString | m_strDisplayString
A time zone display string stored value.
DWORD | m_dwIndex
A time zone order index stored value.

Detailed Description

This class extends the TIME_ZONE_INFORMATION structure.

It has additional data members to represent full information about time zone. Also it implements some helper functions and OLE interface methods.

See also
TIME_ZONE_INFORMATION
CXTPCalendarTimeZones

MSDN Articles: INFO: Retrieving Time-Zone Information KB115231, Q115231

HOWTO: Change Time Zone Information Using Visual Basic KB221542, Q221542

Constructor & Destructor Documentation

◆ CXTPCalendarTimeZone() [1/2]

CXTPCalendarTimeZone ( const TIME_ZONE_INFORMATION * pTZInfo = NULL )

Default object constructor.

Parameters
pTZInfo Pointer to a TIME_ZONE_INFORMATION data to initialize created object data.
See also
~CXTPCalendarTimeZone()
TIME_ZONE_INFORMATION

◆ CXTPCalendarTimeZone() [2/2]

CXTPCalendarTimeZone ( const CXTPCalendarTimeZone * pTZInfoEx )

Default object constructor.

Parameters
pTZInfoEx Pointer to a source data object.
See also
~CXTPCalendarTimeZone()
TIME_ZONE_INFORMATION

◆ ~CXTPCalendarTimeZone()

virtual ~CXTPCalendarTimeZone ( )
virtual

Default object destructor.

See also
CXTPCalendarTimeZone()

Member Function Documentation

◆ GetDisplayString()

CString GetDisplayString ( ) const

Get a time zone display string value.

Returns
A string value like: "(GMT+02:00) Athens, Beirut, Istanbul, Minsk"

◆ GetIndex()

DWORD GetIndex ( ) const

Get a time zone order index value.

This index value is used to sort time zones in the right order.

Returns
A time zone order index value.

◆ GetTimeZoneInfo()

static CXTPCalendarTimeZonePtr AFX_CDECL GetTimeZoneInfo ( const TIME_ZONE_INFORMATION * pTZIdata )
static

Get full information about the specified time zone.

Parameters
pTZIdata Pointer to a time zone data object.

Retrieve additional information from the registry.

Returns
A smart pointer to a CXTPCalendarTimeZone object.
See also
CXTPCalendarTimeZones

◆ IsEqual()

BOOL IsEqual ( const TIME_ZONE_INFORMATION * pTZI2 ) const

Compare 2 time zones data.

Parameters
pTZI2 Points to a TIME_ZONE_INFORMATION object.
Returns
TRUE if time zones data related to the same time zone, otherwise - FALSE.

◆ operator=()

const CXTPCalendarTimeZone & operator= ( const CXTPCalendarTimeZone & rTZInfo )

Copy operator.

Parameters
rTZInfo Pointer to a source data object.
Returns
A Constant reference to updated object
See also
CXTPCalendarTimeZone()

Member Data Documentation

◆ m_dwIndex

DWORD m_dwIndex
protected

A time zone order index stored value.

◆ m_strDisplayString

CString m_strDisplayString
protected

A time zone display string stored value.

The documentation for this class was generated from the following file:
  • XTPCalendarTimeZoneHelper.h


Toolkit Pro: CXTPCalendarTimeZones Class Reference

Classes | Public Member Functions | Static Public Member Functions | Protected Attributes | List of all members
CXTPCalendarTimeZones Class Reference

This class represents a simple array collection of CXTPCalendarTimeZone objects. More...

Inheritance diagram for CXTPCalendarTimeZones:
[legend]

Classes

struct REGISTRY_TIMEZONE_INFORMATION
This structure represents a format of binary data stored in the "TZI" registry key. More...

Public Member Functions

CXTPCalendarTimeZones ()
Default object constructor.
virtual | ~CXTPCalendarTimeZones ()
Default object destructor.
BOOL | InitFromRegistry ()
Reads all time zones from the registry and adds them to the collection.
int | GetCount () const
This member function is used to obtain the number of elements in this collection.
CXTPCalendarTimeZone * | GetAt (long nIndex) const
Call this method to get an element at the specified numeric index.
CXTPCalendarTimeZone * | Find (const TIME_ZONE_INFORMATION *pTZI2) const
This method is used to find time zone information using a specified time zone's data.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Static Public Member Functions

static BOOL AFX_CDECL | GetRegStr (HKEY hKey, LPCTSTR pcszValueName, CString &rstrValue)
This method is used to read a string value from the registry.
static BOOL AFX_CDECL | GetRegBSTR (HKEY hKey, LPCWSTR pcszValueNameW, BSTR &rbstrValue)
This method is used to read a UNICODE string value from the registry.
static BOOL AFX_CDECL | GetRegDWORD (HKEY hKey, LPCTSTR pcszValueName, DWORD &rdwValue)
This method is used to read a DWORD value from the registry.
static BOOL AFX_CDECL | GetRegTZI (HKEY hKey, LPCTSTR pcszValueName, REGISTRY_TIMEZONE_INFORMATION &rRegTZI)
This method is used to read a time zone's information stored as a binary value in the registry.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Protected Attributes

CXTPCalendarPtrCollectionT< CXTPCalendarTimeZone > m_arTZInfo
Collection to store CXTPCalendarTimeZone object pointers;.

Detailed Description

This class represents a simple array collection of CXTPCalendarTimeZone objects.

Array indexes always start at position 0. An InitFromRegistry() method is used to read all time zones from the registry and add them to the collection. Also it implements some helper functions and OLE interface methods.

See also
TIME_ZONE_INFORMATION
CXTPCalendarTimeZone.

MSDN Articles: INFO: Retrieving Time-Zone Information KB115231, Q115231

HOWTO: Change Time Zone Information Using Visual Basic KB221542, Q221542

Constructor & Destructor Documentation

◆ CXTPCalendarTimeZones()

CXTPCalendarTimeZones ( )

Default object constructor.

See also
~CXTPCalendarTimeZones()

◆ ~CXTPCalendarTimeZones()

virtual ~CXTPCalendarTimeZones ( )
virtual

Default object destructor.

See also
CXTPCalendarTimeZones()

Member Function Documentation

◆ Find()

CXTPCalendarTimeZone * Find ( const TIME_ZONE_INFORMATION * pTZI2 ) const

This method is used to find time zone information using a specified time zone's data.

Parameters
pTZI2 Pointer to a time zone data object.
Returns
The pointer to the first object in the collection that matches the requested time zone. NULL if the such object is not found.

◆ GetAt()

CXTPCalendarTimeZone * GetAt ( long nIndex ) const

Call this method to get an element at the specified numeric index.

Parameters
nIndex An integer index that is greater than or equal to 0 and less than the value returned by GetCount.
Returns
The pointer to the CXTPCalendarTimeZone element currently at this index.
See also
GetCount()

◆ GetCount()

int GetCount ( ) const

This member function is used to obtain the number of elements in this collection.

Returns
An int that contains the number of items in the collection.
See also
GetAt()

◆ GetRegBSTR()

static BOOL AFX_CDECL GetRegBSTR | ( | HKEY | hKey,
 |  | LPCWSTR | pcszValueNameW,
 |  | BSTR & | rbstrValue )
 static

This method is used to read a UNICODE string value from the registry.

Parameters
hKey | [in] Parent key handle.
pcszValueNameW | [in] Value key name in the UNICODE format.
rbstrValue | [out] BSTR object reference to store value.

It is used to get UNICODE strings without conversion to MBCS. If the rbstrValue parameter is not NULL, the SysFreeString() API function is called to erase value.

Returns
TRUE if successful, otherwise - FALSE.
See also
GetRegStr()

◆ GetRegDWORD()

static BOOL AFX_CDECL GetRegDWORD | ( | HKEY | hKey,
 |  | LPCTSTR | pcszValueName,
 |  | DWORD & | rdwValue )
 static

This method is used to read a DWORD value from the registry.

Parameters
hKey | [in] Parent key handle.
pcszValueName | [in] Value key name.
rdwValue | [out] DWORD variable reference to store value.
Returns
TRUE - if successful, otherwise - FALSE.

◆ GetRegStr()

static BOOL AFX_CDECL GetRegStr | ( | HKEY | hKey,
 |  | LPCTSTR | pcszValueName,
 |  | CString & | rstrValue )
 static

This method is used to read a string value from the registry.

Parameters
hKey | [in] Parent key handle.
pcszValueName | [in] Value key name.
rstrValue | [out] CString object reference to store value.
Returns
TRUE if successful, otherwise - FALSE.
See also
GetRegBSTR()

◆ GetRegTZI()

static BOOL AFX_CDECL GetRegTZI | ( | HKEY | hKey,
 |  | LPCTSTR | pcszValueName,
 |  | REGISTRY_TIMEZONE_INFORMATION & | rRegTZI )
 static

This method is used to read a time zone's information stored as a binary value in the registry.

Parameters
hKey | [in] Parent key handle.
pcszValueName | [in] Value key name.
rRegTZI | [out] REGISTRY_TIMEZONE_INFORMATION object reference to store value.
Returns
TRUE - if successful, otherwise - FALSE.

◆ InitFromRegistry()

BOOL InitFromRegistry ( )

Reads all time zones from the registry and adds them to the collection.

Returns
TRUE - if all time zones were successfully read, otherwise - FALSE.
The documentation for this class was generated from the following file:
  • XTPCalendarTimeZoneHelper.h


Toolkit Pro: CXTPCalendarTimeZones::REGISTRY_TIMEZONE_INFORMATION Struct Reference

  • CXTPCalendarTimeZones
  • REGISTRY_TIMEZONE_INFORMATION
Public Attributes | List of all members
CXTPCalendarTimeZones::REGISTRY_TIMEZONE_INFORMATION Struct Reference

This structure represents a format of binary data stored in the "TZI" registry key. More...

Public Attributes

LONG | Bias
Current bias for local time translation on this computer, in minutes.
LONG | StandardBias
Bias value to be used during local time translations that occur during standard time.
LONG | DaylightBias
Bias value to be used during local time translations that occur during daylight saving time.
SYSTEMTIME | StandardDate
A SYSTEMTIME structure that contains a date and local time when the transition from daylight saving time to standard time occurs on this operating system.
SYSTEMTIME | DaylightDate
A SYSTEMTIME structure that contains a date and local time when the transition from standard time to daylight saving time occurs on this operating system.

Detailed Description

This structure represents a format of binary data stored in the "TZI" registry key.

See also
Microsoft KB115231, TIME_ZONE_INFORMATION
XTP_CALENDAR_TZIRegValName_DATA
XTP_CALENDAR_TIMEZONESKEY_NT
XTP_CALENDAR_TIMEZONESKEY_9X
The documentation for this struct was generated from the following file:
  • XTPCalendarTimeZoneHelper.h


Toolkit Pro: CXTPCalendarTip Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPCalendarTip Class Reference

The CXTPCalendarTip class emulates the functionality of a "tool tip" control. More...

Public Member Functions

CXTPCalendarTip ()
Constructs a CXTPCalendarTip object.
virtual | ~CXTPCalendarTip ()
Destroys a CXTPCalendarTip object and handles cleanup and deallocation.
virtual BOOL | Create (CWnd *pParentWnd)
This member function is used to create a report tip window.
CString | GetTooltipText () const
This member function is used to obtain the tooltip text string.
void | SetTooltipText (LPCTSTR str)
This member function is used to set the new tooltip text.
void | SetFont (CFont *pFont)
This member function is used to set the tooltip text font.
void | SetHoverRect (CRect rc)
This member function is used to set the coordinates of the tooltip hover rectangle.
CRect | GetHoverRect () const
This function is used to obtain the coordinates of a tooltip hover rectangle.
BOOL | IsAdvancedMode () const
This function is used to check whether advanced mode is enabled.
void | SetAdvancedMode (BOOL bMode=TRUE)
This function is used to set the advanced mode flag.
void | SetTheme (CXTPCalendarTheme *pTheme)
This member function sets (or disables) the new control drawing theme.
void | Activate (BOOL bActive, BOOL bAdvanced=FALSE)
Call this function to activate or deactivate a tool tip control.
CSize | CalcToolTipRect (BOOL bFull=FALSE)
This function is used to calculate the tooltip rectangle.

Protected Attributes

CRect | m_rcHover
Hover window coordinates.
CFont * | m_pFont
Font for displaying tooltip text.
CWnd * | m_pParentWnd
Pointer to the parent report window.
CString | m_strTooltipText
Tooltip text to display.
BOOL | m_bAdvancedMode
TRUE when advanced mode is on

CXTPCalendarTheme * | m_pTheme
Pointer to associated Theme object

Detailed Description

The CXTPCalendarTip class emulates the functionality of a "tool tip" control.

The CXTPCalendarTip class encapsulates the functionality of a "tip control", a small pop-up window that displays a single line of text describing the hidden text when hovering over an item on the report area.

 CXTPCalendarTip provides the functionality to control the
 the tip text, the size of the tip window itself, and the text
 font of the tip.

 This class is used by the Grid control internally.
See also
CXTPCalendarControl

Constructor & Destructor Documentation

◆ CXTPCalendarTip()

CXTPCalendarTip ( )

Constructs a CXTPCalendarTip object.

Construct a CXTPCalendarTip object in two steps. Call the constructor object and then call Create, which initializes the window and attaches it to the parent window.

Example:

Declare a local CXTPCalendarTip object.
CXTPCalendarTip wndTip;

// Declare a dynamic CXTPCalendarTip object.
CXTPCalendarTip* pTipWnd = new CXTPCalendarTip;
See also
CWnd
Create
Activate

Member Function Documentation

◆ Activate()

void Activate | ( | BOOL | bActive,
 |  | BOOL | bAdvanced = FALSE )

Call this function to activate or deactivate a tool tip control.

Parameters
bActive | A BOOL. Specifies whether the tool tip control is to be activated or deactivated.
bAdvanced | TRUE for advanced processing (Office2007 theme "add new appt")

If bActivate is TRUE, the control is activated. If FALSE, it is deactivated.

 When a tool tip control is active, the tool tip information
 appears when the cursor is on a tool that is registered with
 the control. When it is inactive, the tool tip information
 does not appear, even when the cursor is on a tool.

Example: See Create method example.

See also
Create
CXTPCalendarTip::CXTPCalendarTip
SetTooltipText

◆ CalcToolTipRect()

CSize CalcToolTipRect ( BOOL bFull = FALSE )

This function is used to calculate the tooltip rectangle.

Parameters
bFull A BOOL flag of the way of calculation.

Standard window DC, stored font and tooltip text are used.

Returns
Size of the tooltip rectangle.
See also
SetTooltipText
SetFont

◆ Create()

virtual BOOL Create ( CWnd * pParentWnd )
virtual

This member function is used to create a report tip window.

Parameters
pParentWnd A pointer to a CWnd that is the parent report control window.

Construct an object in two steps. Call the constructor object and then call Create(), which initializes the window and attaches it to the parent window.

Example:

void MyDialog::ShowToolTip(CRect rcTip, CXTPCalendarTip* pTipWnd)
{
   if (!pTipWnd->GetSafeHwnd())
   {
      pTipWnd->Create(this);
   }
   pTipWnd->SetHoverRect(rcTip);
   pTipWnd->Activate(TRUE);
}
Returns
TRUE if tip window is created successfully, FALSE otherwise.
See also
CXTPCalendarTip::CXTPCalendarTip
Activate

◆ GetHoverRect()

AFX_INLINE CRect GetHoverRect ( ) const

This function is used to obtain the coordinates of a tooltip hover rectangle.

Returns
The coordinates of the tooltip hover rectangle in parent window coordinates.
See also
SetHoverRect

◆ GetTooltipText()

AFX_INLINE CString GetTooltipText ( ) const

This member function is used to obtain the tooltip text string.

Returns
A CString that contains the current tooltip text.
See also
SetTooltipText

◆ IsAdvancedMode()

AFX_INLINE BOOL IsAdvancedMode ( ) const

This function is used to check whether advanced mode is enabled.

Advanced mode means left mouse click handling.

Returns
TRUE when advanced mode enabled (left mouse click handling).

◆ SetAdvancedMode()

AFX_INLINE void SetAdvancedMode ( BOOL bMode = TRUE )

This function is used to set the advanced mode flag.

Parameters
bMode a BOOL flag to set the mode as advanced or standard

◆ SetFont()

AFX_INLINE void SetFont ( CFont * pFont )

This member function is used to set the tooltip text font.

Parameters
pFont A pointer to a CFont object that contains the new font.

◆ SetHoverRect()

AFX_INLINE void SetHoverRect ( CRect rc )

This member function is used to set the coordinates of the tooltip hover rectangle.

Parameters
rc A CRect object that contains the new tooltip hover rectangle in the parent window coordinates.

Called this member function before activating the tooltip window.

See also
GetHoverRect

◆ SetTheme()

void SetTheme ( CXTPCalendarTheme * pTheme )

This member function sets (or disables) the new control drawing theme.

Parameters
pTheme A CXTPCalendarTheme pointer to the theme object. If pTheme is NULL - themes are disabled and regular painting is used.

◆ SetTooltipText()

AFX_INLINE void SetTooltipText ( LPCTSTR str )

This member function is used to set the new tooltip text.

Parameters
str An LPCSTR string that contains the new tooltip caption.

Call this member function before activating the tooltip window.

See also
GetTooltipText

Member Data Documentation

◆ m_pFont

CFont* m_pFont
protected

Font for displaying tooltip text.

◆ m_rcHover

CRect m_rcHover
protected

Hover window coordinates.

◆ m_strTooltipText

CString m_strTooltipText
protected

Tooltip text to display.

The documentation for this class was generated from the following file:
  • XTPCalendarTip.h


Toolkit Pro: CXTPCalendarTLV_TimeScaleParams Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPCalendarTLV_TimeScaleParams Class Referenceabstract

This class implements Timeline scale params. More...

Inheritance diagram for CXTPCalendarTLV_TimeScaleParams:
[legend]

Public Member Functions

CXTPCalendarTLV_TimeScaleParams (int nTimeScaleParamsID, CXTPCalendarTimeLineViewTimeScale *pTimeScale)
Default object constructor.
virtual | ~CXTPCalendarTLV_TimeScaleParams ()
Default class destructor.
CXTPCalendarTimeLineViewTimeScale * | GetParentTimeScale () const
Access function to get the current parent time scale object.
virtual int | GetTimeScaleParamsID () const
Access function to get the current time scale params ID.
virtual XTP_CALENDAR_TIMELINE_VIEW_SCALE | GetTimeLineViewScale () const
Access function to get the current time scale interval.
virtual COleDateTimeSpan | GetScaleInterval () const
Access function to get the current time scale interval.
virtual int | GetScaleIntervalWidth_px () const
Access function to get the current time scale inteval width.
virtual COleDateTimeSpan | GetTimePerPixel () const
Access function to get current time per pixel value.
virtual COleDateTime | CalcScaleIntervalBegin (COleDateTime dtStart)
Used to calculate scale interval initial position.
virtual CXTPCalendarTimeLineViewTimeScalePart * | GetPart () const =0
abstract function - real ones are: CXTPCalendarTimeLineViewTimeScalePart* CXTPCalendarTLV_TimeScaleParams_Day::GetPart() CXTPCalendarTimeLineViewTimeScalePart* CXTPCalendarTLV_TimeScaleParams_Week::GetPart() CXTPCalendarTimeLineViewTimeScalePart* CXTPCalendarTLV_TimeScaleParams_WorkWeek::GetPart() CXTPCalendarTimeLineViewTimeScalePart* CXTPCalendarTLV_TimeScaleParams_Month::GetPart()
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

void SetScaleInterval (int eType, int nValue)
This member function is used to set the time scale interval m_scaleInterval.

Protected Attributes

XTP_CALENDAR_TIMELINE_VIEW_SCALE | m_scaleInterval
Internal instance with m_eType and m_nValue.
int | m_nScaleIntervalWidth_px
Internal value for scale interval (by x).

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

This class implements Timeline scale params.

Constructor & Destructor Documentation

◆ CXTPCalendarTLV_TimeScaleParams()

CXTPCalendarTLV_TimeScaleParams | ( | int | nTimeScaleParamsID,
 |  | CXTPCalendarTimeLineViewTimeScale * | pTimeScale )

Default object constructor.

Parameters
nTimeScaleParamsID | Passed new params ID.
pTimeScale | Pointer to a CXTPCalendarTimeLineViewTimeScale object.

◆ ~CXTPCalendarTLV_TimeScaleParams()

virtual ~CXTPCalendarTLV_TimeScaleParams ( )
virtual

Default class destructor.

Handles member items deallocation.

Member Function Documentation

◆ CalcScaleIntervalBegin()

virtual COleDateTime CalcScaleIntervalBegin ( COleDateTime dtStart )
virtual

Used to calculate scale interval initial position.

Parameters
dtStart start time as a COleDateTime object.
Returns
Scale interval initial position as a COleDateTime object.

◆ GetParentTimeScale()

AFX_INLINE CXTPCalendarTimeLineViewTimeScale * GetParentTimeScale ( ) const

Access function to get the current parent time scale object.

Returns
Pointer to the current parent time scale object.

◆ GetPart()

virtual CXTPCalendarTimeLineViewTimeScalePart * GetPart ( ) const
pure virtual

abstract function - real ones are: CXTPCalendarTimeLineViewTimeScalePart* CXTPCalendarTLV_TimeScaleParams_Day::GetPart() CXTPCalendarTimeLineViewTimeScalePart* CXTPCalendarTLV_TimeScaleParams_Week::GetPart() CXTPCalendarTimeLineViewTimeScalePart* CXTPCalendarTLV_TimeScaleParams_WorkWeek::GetPart() CXTPCalendarTimeLineViewTimeScalePart* CXTPCalendarTLV_TimeScaleParams_Month::GetPart()

Returns
A pointer to a CXTPCalendarTimeLineViewTimeScalePart object.

Implemented in CXTPCalendarTLV_TimeScaleParams_Day, CXTPCalendarTLV_TimeScaleParams_Month, CXTPCalendarTLV_TimeScaleParams_Week, and CXTPCalendarTLV_TimeScaleParams_WorkWeek.

◆ GetScaleInterval()

virtual COleDateTimeSpan GetScaleInterval ( ) const
virtual

Access function to get the current time scale interval.

Returns
Interval as a COleDateTimeSpan object.

◆ GetScaleIntervalWidth_px()

AFX_INLINE int GetScaleIntervalWidth_px ( ) const
virtual

Access function to get the current time scale inteval width.

Returns
An int that contains the current time scale inteval width.

◆ GetTimeLineViewScale()

AFX_INLINE XTP_CALENDAR_TIMELINE_VIEW_SCALE GetTimeLineViewScale ( ) const
virtual

Access function to get the current time scale interval.

Returns
Interval as an XTP_CALENDAR_TIMELINE_VIEW_SCALE object.

◆ GetTimePerPixel()

virtual COleDateTimeSpan GetTimePerPixel ( ) const
virtual

Access function to get current time per pixel value.

Returns
Current time per pixel value as a COleDateTimeSpan object.

◆ GetTimeScaleParamsID()

AFX_INLINE int GetTimeScaleParamsID ( ) const
virtual

Access function to get the current time scale params ID.

Returns
An int that contains the current time scale params ID.

◆ SetScaleInterval()

void SetScaleInterval | ( | int | eType,
 |  | int | nValue )
 protected

This member function is used to set the time scale interval m_scaleInterval.

Parameters
eType | Passed to m_eType.
nValue | Passed to m_nValue.
The documentation for this class was generated from the following file:
  • XTPCalendarTimeLineViewTimeScale.h


Toolkit Pro: CXTPCalendarTLV_TimeScaleParams_Day Class Reference

Public Member Functions | List of all members
CXTPCalendarTLV_TimeScaleParams_Day Class Reference

This class implements Timeline scale params for Day case. More...

Inheritance diagram for CXTPCalendarTLV_TimeScaleParams_Day:
[legend]

Public Member Functions

CXTPCalendarTLV_TimeScaleParams_Day (CXTPCalendarTimeLineViewTimeScale *pTimeScale)
Default object constructor.
virtual | ~CXTPCalendarTLV_TimeScaleParams_Day ()
Default class destructor.
virtual CXTPCalendarTimeLineViewTimeScalePart * | GetPart () const
abstract function - real ones are: CXTPCalendarTimeLineViewTimeScalePart* CXTPCalendarTLV_TimeScaleParams_Day::GetPart() CXTPCalendarTimeLineViewTimeScalePart* CXTPCalendarTLV_TimeScaleParams_Week::GetPart() CXTPCalendarTimeLineViewTimeScalePart* CXTPCalendarTLV_TimeScaleParams_WorkWeek::GetPart() CXTPCalendarTimeLineViewTimeScalePart* CXTPCalendarTLV_TimeScaleParams_Month::GetPart()
- Public Member Functions inherited from CXTPCalendarTLV_TimeScaleParams
CXTPCalendarTLV_TimeScaleParams (int nTimeScaleParamsID, CXTPCalendarTimeLineViewTimeScale *pTimeScale)
Default object constructor.
virtual | ~CXTPCalendarTLV_TimeScaleParams ()
Default class destructor.
CXTPCalendarTimeLineViewTimeScale * | GetParentTimeScale () const
Access function to get the current parent time scale object.
virtual int | GetTimeScaleParamsID () const
Access function to get the current time scale params ID.
virtual XTP_CALENDAR_TIMELINE_VIEW_SCALE | GetTimeLineViewScale () const
Access function to get the current time scale interval.
virtual COleDateTimeSpan | GetScaleInterval () const
Access function to get the current time scale interval.
virtual int | GetScaleIntervalWidth_px () const
Access function to get the current time scale inteval width.
virtual COleDateTimeSpan | GetTimePerPixel () const
Access function to get current time per pixel value.
virtual COleDateTime | CalcScaleIntervalBegin (COleDateTime dtStart)
Used to calculate scale interval initial position.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Member Functions inherited from CXTPCalendarTLV_TimeScaleParams
void | SetScaleInterval (int eType, int nValue)
This member function is used to set the time scale interval m_scaleInterval.
- Protected Attributes inherited from CXTPCalendarTLV_TimeScaleParams
XTP_CALENDAR_TIMELINE_VIEW_SCALE | m_scaleInterval
Internal instance with m_eType and m_nValue.
int | m_nScaleIntervalWidth_px
Internal value for scale interval (by x).

Detailed Description

This class implements Timeline scale params for Day case.

Constructor & Destructor Documentation

◆ CXTPCalendarTLV_TimeScaleParams_Day()

CXTPCalendarTLV_TimeScaleParams_Day ( CXTPCalendarTimeLineViewTimeScale * pTimeScale )

Default object constructor.

Parameters
pTimeScale Pointer to a CXTPCalendarTimeLineViewTimeScale object.

◆ ~CXTPCalendarTLV_TimeScaleParams_Day()

virtual ~CXTPCalendarTLV_TimeScaleParams_Day ( )
virtual

Default class destructor.

Handles member items deallocation.

Member Function Documentation

◆ GetPart()

virtual CXTPCalendarTimeLineViewTimeScalePart * GetPart ( ) const
virtual

abstract function - real ones are: CXTPCalendarTimeLineViewTimeScalePart* CXTPCalendarTLV_TimeScaleParams_Day::GetPart() CXTPCalendarTimeLineViewTimeScalePart* CXTPCalendarTLV_TimeScaleParams_Week::GetPart() CXTPCalendarTimeLineViewTimeScalePart* CXTPCalendarTLV_TimeScaleParams_WorkWeek::GetPart() CXTPCalendarTimeLineViewTimeScalePart* CXTPCalendarTLV_TimeScaleParams_Month::GetPart()

Returns
A pointer to a CXTPCalendarTimeLineViewTimeScalePart object.

Implements CXTPCalendarTLV_TimeScaleParams.

The documentation for this class was generated from the following file:
  • XTPCalendarTimeLineViewTimeScale.h


Toolkit Pro: CXTPCalendarTLV_TimeScaleParams_Month Class Reference

Public Member Functions | List of all members
CXTPCalendarTLV_TimeScaleParams_Month Class Reference

This class implements Timeline scale params for Month case. More...

Inheritance diagram for CXTPCalendarTLV_TimeScaleParams_Month:
[legend]

Public Member Functions

CXTPCalendarTLV_TimeScaleParams_Month (CXTPCalendarTimeLineViewTimeScale *pTimeScale)
Default object constructor.
virtual | ~CXTPCalendarTLV_TimeScaleParams_Month ()
Default class destructor.
virtual CXTPCalendarTimeLineViewTimeScalePart * | GetPart () const
abstract function - real ones are: CXTPCalendarTimeLineViewTimeScalePart* CXTPCalendarTLV_TimeScaleParams_Day::GetPart() CXTPCalendarTimeLineViewTimeScalePart* CXTPCalendarTLV_TimeScaleParams_Week::GetPart() CXTPCalendarTimeLineViewTimeScalePart* CXTPCalendarTLV_TimeScaleParams_Month::GetPart()
- Public Member Functions inherited from CXTPCalendarTLV_TimeScaleParams
CXTPCalendarTLV_TimeScaleParams (int nTimeScaleParamsID, CXTPCalendarTimeLineViewTimeScale *pTimeScale)
Default object constructor.
virtual | ~CXTPCalendarTLV_TimeScaleParams ()
Default class destructor.
CXTPCalendarTimeLineViewTimeScale * | GetParentTimeScale () const
Access function to get the current parent time scale object.
virtual int | GetTimeScaleParamsID () const
Access function to get the current time scale params ID.
virtual XTP_CALENDAR_TIMELINE_VIEW_SCALE | GetTimeLineViewScale () const
Access function to get the current time scale interval.
virtual COleDateTimeSpan | GetScaleInterval () const
Access function to get the current time scale interval.
virtual int | GetScaleIntervalWidth_px () const
Access function to get the current time scale inteval width.
virtual COleDateTimeSpan | GetTimePerPixel () const
Access function to get current time per pixel value.
virtual COleDateTime | CalcScaleIntervalBegin (COleDateTime dtStart)
Used to calculate scale interval initial position.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Member Functions inherited from CXTPCalendarTLV_TimeScaleParams
void | SetScaleInterval (int eType, int nValue)
This member function is used to set the time scale interval m_scaleInterval.
- Protected Attributes inherited from CXTPCalendarTLV_TimeScaleParams
XTP_CALENDAR_TIMELINE_VIEW_SCALE | m_scaleInterval
Internal instance with m_eType and m_nValue.
int | m_nScaleIntervalWidth_px
Internal value for scale interval (by x).

Detailed Description

This class implements Timeline scale params for Month case.

Constructor & Destructor Documentation

◆ CXTPCalendarTLV_TimeScaleParams_Month()

CXTPCalendarTLV_TimeScaleParams_Month ( CXTPCalendarTimeLineViewTimeScale * pTimeScale )

Default object constructor.

Parameters
pTimeScale Pointer to a CXTPCalendarTimeLineViewTimeScale object.

◆ ~CXTPCalendarTLV_TimeScaleParams_Month()

virtual ~CXTPCalendarTLV_TimeScaleParams_Month ( )
virtual

Default class destructor.

Handles member items deallocation.

Member Function Documentation

◆ GetPart()

virtual CXTPCalendarTimeLineViewTimeScalePart * GetPart ( ) const
virtual

abstract function - real ones are: CXTPCalendarTimeLineViewTimeScalePart* CXTPCalendarTLV_TimeScaleParams_Day::GetPart() CXTPCalendarTimeLineViewTimeScalePart* CXTPCalendarTLV_TimeScaleParams_Week::GetPart() CXTPCalendarTimeLineViewTimeScalePart* CXTPCalendarTLV_TimeScaleParams_Month::GetPart()

Returns
A pointer to a CXTPCalendarTimeLineViewTimeScalePart object.

Implements CXTPCalendarTLV_TimeScaleParams.

The documentation for this class was generated from the following file:
  • XTPCalendarTimeLineViewTimeScale.h


Toolkit Pro: CXTPCalendarTLV_TimeScaleParams_Week Class Reference

Public Member Functions | List of all members
CXTPCalendarTLV_TimeScaleParams_Week Class Reference

This class implements Timeline scale params for Week case. More...

Inheritance diagram for CXTPCalendarTLV_TimeScaleParams_Week:
[legend]

Public Member Functions

CXTPCalendarTLV_TimeScaleParams_Week (CXTPCalendarTimeLineViewTimeScale *pTimeScale)
Default object constructor.
virtual | ~CXTPCalendarTLV_TimeScaleParams_Week ()
Default class destructor.
virtual CXTPCalendarTimeLineViewTimeScalePart * | GetPart () const
abstract function - real ones are: CXTPCalendarTimeLineViewTimeScalePart* CXTPCalendarTLV_TimeScaleParams_Day::GetPart() CXTPCalendarTimeLineViewTimeScalePart* CXTPCalendarTLV_TimeScaleParams_Week::GetPart() CXTPCalendarTimeLineViewTimeScalePart* CXTPCalendarTLV_TimeScaleParams_WorkWeek::GetPart() CXTPCalendarTimeLineViewTimeScalePart* CXTPCalendarTLV_TimeScaleParams_Month::GetPart()
- Public Member Functions inherited from CXTPCalendarTLV_TimeScaleParams
CXTPCalendarTLV_TimeScaleParams (int nTimeScaleParamsID, CXTPCalendarTimeLineViewTimeScale *pTimeScale)
Default object constructor.
virtual | ~CXTPCalendarTLV_TimeScaleParams ()
Default class destructor.
CXTPCalendarTimeLineViewTimeScale * | GetParentTimeScale () const
Access function to get the current parent time scale object.
virtual int | GetTimeScaleParamsID () const
Access function to get the current time scale params ID.
virtual XTP_CALENDAR_TIMELINE_VIEW_SCALE | GetTimeLineViewScale () const
Access function to get the current time scale interval.
virtual COleDateTimeSpan | GetScaleInterval () const
Access function to get the current time scale interval.
virtual int | GetScaleIntervalWidth_px () const
Access function to get the current time scale inteval width.
virtual COleDateTimeSpan | GetTimePerPixel () const
Access function to get current time per pixel value.
virtual COleDateTime | CalcScaleIntervalBegin (COleDateTime dtStart)
Used to calculate scale interval initial position.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Member Functions inherited from CXTPCalendarTLV_TimeScaleParams
void | SetScaleInterval (int eType, int nValue)
This member function is used to set the time scale interval m_scaleInterval.
- Protected Attributes inherited from CXTPCalendarTLV_TimeScaleParams
XTP_CALENDAR_TIMELINE_VIEW_SCALE | m_scaleInterval
Internal instance with m_eType and m_nValue.
int | m_nScaleIntervalWidth_px
Internal value for scale interval (by x).

Detailed Description

This class implements Timeline scale params for Week case.

Constructor & Destructor Documentation

◆ CXTPCalendarTLV_TimeScaleParams_Week()

CXTPCalendarTLV_TimeScaleParams_Week ( CXTPCalendarTimeLineViewTimeScale * pTimeScale )

Default object constructor.

Parameters
pTimeScale Pointer to a CXTPCalendarTimeLineViewTimeScale object.

◆ ~CXTPCalendarTLV_TimeScaleParams_Week()

virtual ~CXTPCalendarTLV_TimeScaleParams_Week ( )
virtual

Default class destructor.

Handles member items deallocation.

Member Function Documentation

◆ GetPart()

virtual CXTPCalendarTimeLineViewTimeScalePart * GetPart ( ) const
virtual

abstract function - real ones are: CXTPCalendarTimeLineViewTimeScalePart* CXTPCalendarTLV_TimeScaleParams_Day::GetPart() CXTPCalendarTimeLineViewTimeScalePart* CXTPCalendarTLV_TimeScaleParams_Week::GetPart() CXTPCalendarTimeLineViewTimeScalePart* CXTPCalendarTLV_TimeScaleParams_WorkWeek::GetPart() CXTPCalendarTimeLineViewTimeScalePart* CXTPCalendarTLV_TimeScaleParams_Month::GetPart()

Returns
A pointer to a CXTPCalendarTimeLineViewTimeScalePart object.

Implements CXTPCalendarTLV_TimeScaleParams.

The documentation for this class was generated from the following file:
  • XTPCalendarTimeLineViewTimeScale.h


Toolkit Pro: CXTPCalendarTLV_TimeScaleParams_WorkWeek Class Reference

Public Member Functions | List of all members
CXTPCalendarTLV_TimeScaleParams_WorkWeek Class Reference

This class implements Timeline scale params for WorkWeek case. More...

Inheritance diagram for CXTPCalendarTLV_TimeScaleParams_WorkWeek:
[legend]

Public Member Functions

CXTPCalendarTLV_TimeScaleParams_WorkWeek (CXTPCalendarTimeLineViewTimeScale *pTimeScale)
Default object constructor.
virtual | ~CXTPCalendarTLV_TimeScaleParams_WorkWeek ()
Default class destructor.
virtual CXTPCalendarTimeLineViewTimeScalePart * | GetPart () const
abstract function - real ones are: CXTPCalendarTimeLineViewTimeScalePart* CXTPCalendarTLV_TimeScaleParams_Day::GetPart() CXTPCalendarTimeLineViewTimeScalePart* CXTPCalendarTLV_TimeScaleParams_Week::GetPart() CXTPCalendarTimeLineViewTimeScalePart* CXTPCalendarTLV_TimeScaleParams_WorkWeek::GetPart() CXTPCalendarTimeLineViewTimeScalePart* CXTPCalendarTLV_TimeScaleParams_Month::GetPart()
- Public Member Functions inherited from CXTPCalendarTLV_TimeScaleParams
CXTPCalendarTLV_TimeScaleParams (int nTimeScaleParamsID, CXTPCalendarTimeLineViewTimeScale *pTimeScale)
Default object constructor.
virtual | ~CXTPCalendarTLV_TimeScaleParams ()
Default class destructor.
CXTPCalendarTimeLineViewTimeScale * | GetParentTimeScale () const
Access function to get the current parent time scale object.
virtual int | GetTimeScaleParamsID () const
Access function to get the current time scale params ID.
virtual XTP_CALENDAR_TIMELINE_VIEW_SCALE | GetTimeLineViewScale () const
Access function to get the current time scale interval.
virtual COleDateTimeSpan | GetScaleInterval () const
Access function to get the current time scale interval.
virtual int | GetScaleIntervalWidth_px () const
Access function to get the current time scale inteval width.
virtual COleDateTimeSpan | GetTimePerPixel () const
Access function to get current time per pixel value.
virtual COleDateTime | CalcScaleIntervalBegin (COleDateTime dtStart)
Used to calculate scale interval initial position.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Member Functions inherited from CXTPCalendarTLV_TimeScaleParams
void | SetScaleInterval (int eType, int nValue)
This member function is used to set the time scale interval m_scaleInterval.
- Protected Attributes inherited from CXTPCalendarTLV_TimeScaleParams
XTP_CALENDAR_TIMELINE_VIEW_SCALE | m_scaleInterval
Internal instance with m_eType and m_nValue.
int | m_nScaleIntervalWidth_px
Internal value for scale interval (by x).

Detailed Description

This class implements Timeline scale params for WorkWeek case.

Constructor & Destructor Documentation

◆ CXTPCalendarTLV_TimeScaleParams_WorkWeek()

CXTPCalendarTLV_TimeScaleParams_WorkWeek ( CXTPCalendarTimeLineViewTimeScale * pTimeScale )

Default object constructor.

Parameters
pTimeScale Pointer to a CXTPCalendarTimeLineViewTimeScale object.

◆ ~CXTPCalendarTLV_TimeScaleParams_WorkWeek()

virtual ~CXTPCalendarTLV_TimeScaleParams_WorkWeek ( )
virtual

Default class destructor.

Handles member items deallocation.

Member Function Documentation

◆ GetPart()

virtual CXTPCalendarTimeLineViewTimeScalePart * GetPart ( ) const
virtual

abstract function - real ones are: CXTPCalendarTimeLineViewTimeScalePart* CXTPCalendarTLV_TimeScaleParams_Day::GetPart() CXTPCalendarTimeLineViewTimeScalePart* CXTPCalendarTLV_TimeScaleParams_Week::GetPart() CXTPCalendarTimeLineViewTimeScalePart* CXTPCalendarTLV_TimeScaleParams_WorkWeek::GetPart() CXTPCalendarTimeLineViewTimeScalePart* CXTPCalendarTLV_TimeScaleParams_Month::GetPart()

Returns
A pointer to a CXTPCalendarTimeLineViewTimeScalePart object.

Implements CXTPCalendarTLV_TimeScaleParams.

The documentation for this class was generated from the following file:
  • XTPCalendarTimeLineViewTimeScale.h


Toolkit Pro: CXTPCalendarTypedPtrAutoDeleteArray< BASE_CLASS, PTR_TYPE > Class Template Reference

Public Types | Public Member Functions | List of all members
CXTPCalendarTypedPtrAutoDeleteArray< BASE_CLASS, PTR_TYPE > Class Template Reference

This class represents a simple array collection of objects pointers. More...

Inheritance diagram for CXTPCalendarTypedPtrAutoDeleteArray< BASE_CLASS, PTR_TYPE >:
[legend]

Public Types

typedef CTypedPtrArray< BASE_CLASS, PTR_TYPE > TBase
Base class type definition.

Public Member Functions

CXTPCalendarTypedPtrAutoDeleteArray ()
Default object constructor.
virtual | ~CXTPCalendarTypedPtrAutoDeleteArray ()
Default class destructor.
virtual void | RemoveAll ()
Removes all the elements from the array.

Detailed Description

template<class BASE_CLASS, class PTR_TYPE>
class CXTPCalendarTypedPtrAutoDeleteArray< BASE_CLASS, PTR_TYPE >

This class represents a simple array collection of objects pointers.

Parameters BASE_CLASS Base class of the typed pointer array class; must be an array class (CObArray or CPtrArray). PTR_TYPE Type of the elements stored in the base-class array.

Array indexes always start at position 0.

As with a C array, the access time for indexed element of this array is constant and is independent of the array size.

Overridden method RemoveAll() calls the delete operator for all non-NULL elements before calling the RemoveAll() method from the base class.

The RemoveAll() method is called from the array destructor too.

See also
CTypedPtrArray
CPtrArray
CObArray
CArray

Constructor & Destructor Documentation

◆ ~CXTPCalendarTypedPtrAutoDeleteArray()

template<class BASE_CLASS , class PTR_TYPE >
virtual ~CXTPCalendarTypedPtrAutoDeleteArray ( )
inlinevirtual

Default class destructor.

Handles member items deallocation.

Member Function Documentation

◆ RemoveAll()

template<class BASE_CLASS , class PTR_TYPE >
virtual void RemoveAll ( )
inlinevirtual

Removes all the elements from the array.

Removes all the pointers from the array and deletes all stored objects.

The documentation for this class was generated from the following file:
  • XTPCalendarPtrCollectionT.h


Toolkit Pro: CXTPCalendarTypedPtrAutoDeleteMap< KEY, TPtr > Class Template Reference

Public Member Functions | List of all members
CXTPCalendarTypedPtrAutoDeleteMap< KEY, TPtr > Class Template Reference

This class represents a simple map of typed keys to typed objects pointers. More...

Inheritance diagram for CXTPCalendarTypedPtrAutoDeleteMap< KEY, TPtr >:
[legend]

Public Member Functions

virtual | ~CXTPCalendarTypedPtrAutoDeleteMap ()
Default class destructor.
virtual void | RemoveAll (BOOL bDeletePtr=TRUE)
Removes all the elements from the map.
virtual void | SetAt (KEY key, TPtr pValue, BOOL bDeletePrevPtr=TRUE)
Add a new (key, value) pair.
TPtr & | operator[] (KEY key)
Lookup and add a new element if not there.
virtual BOOL | RemoveKey (KEY key, BOOL bDeletePtr=TRUE)
Removes element by its key.

Detailed Description

template<class KEY, class TPtr>
class CXTPCalendarTypedPtrAutoDeleteMap< KEY, TPtr >

This class represents a simple map of typed keys to typed objects pointers.

Overridden methods SetAt, operator[], RemoveKey, RemoveAll, call delete for previously stored elements.

Parameters KEY class to key values. TPtr A pointer type of stored objects.

Overridden method RemoveAll() calls the delete operator for all non-NULL spored elements before calling the RemoveAll() method from the base class.

The RemoveAll() method is called from the map destructor too.

See also
CMap

Constructor & Destructor Documentation

◆ ~CXTPCalendarTypedPtrAutoDeleteMap()

template<class KEY , class TPtr >
virtual ~CXTPCalendarTypedPtrAutoDeleteMap ( )
inlinevirtual

Default class destructor.

Handles member items deallocation.

Member Function Documentation

◆ operator[]()

template<class KEY , class TPtr >
TPtr & operator[] ( KEY key )
inline

Lookup and add a new element if not there.

Parameters
key A key.
Returns
A reference for value associated to a key (new value added if need).

◆ RemoveAll()

template<class KEY , class TPtr >
virtual void RemoveAll ( BOOL bDeletePtr = TRUE )
inlinevirtual

Removes all the elements from the map.

Parameters
bDeletePtr If TRUE, delete operator will be called for non-null elements. Default value is TRUE.

Removes all data from the map and deletes all stored objects if this is specified by the bDeletePtr parameter.

◆ RemoveKey()

template<class KEY , class TPtr >
virtual BOOL RemoveKey | ( | KEY | key,
 |  | BOOL | bDeletePtr = TRUE )
 inlinevirtual

Removes element by its key.

Parameters
key | A key.
bDeletePtr | If TRUE, delete operator will be called for not null element. Default value is TRUE.
Returns
TRUE if operation is successful, FALSE otherwise.

◆ SetAt()

template<class KEY , class TPtr >
virtual void SetAt | ( | KEY | key,
 |  | TPtr | pValue,
 |  | BOOL | bDeletePrevPtr = TRUE )
 inlinevirtual

Add a new (key, value) pair.

Parameters
key | A key.
pValue | A value.
bDeletePrevPtr | If TRUE, delete operator will be called for previous not null element.
The documentation for this class was generated from the following file:
  • XTPCalendarPtrCollectionT.h


Toolkit Pro: CXTPCalendarUIntArray Class Reference

Public Member Functions | List of all members
CXTPCalendarUIntArray Class Reference

This class represents the collection of UINT elements. More...

Inheritance diagram for CXTPCalendarUIntArray:
[legend]

Public Member Functions

int | Find (UINT uID) const
Call this member function to find an ID in the collection.
virtual BOOL | RemoveID (UINT uID)
Call this member function to remove an ID from the collection.
virtual CString | SaveToString () const
Call this member function to store collection data as a comma separated string.
virtual void | LoadFromString (LPCTSTR pcszData)
Call this member function to read collection data from a comma separated string.
virtual void | DoPropExchange (CXTPPropExchange *pPX, LPCTSTR pcszSection, LPCTSTR pcszElement)
Call this member function to Store/Load collection data using the specified data object.
- Public Member Functions inherited from CXTPArrayT< UINT, UINT >
CXTPArrayT ()
Default object constructor.
virtual | ~CXTPArrayT ()
Default object destructor.
virtual int | GetSize () const
This member function is used to obtain the number of elements in the collection.
virtual void | SetSize (int nNewSize, int nGrowBy=-1)
This member function is used to change the array size.
virtual UINT | GetAt (int nIndex) const
This member function returns an element at the specified numeric index.
virtual void | SetAt (int nIndex, UINT newElement)
This member function is used to set a new element to the position specified in the nIndex parameter.
virtual UINT & | ElementAt (int nIndex)
This member function returns a reference to element at the specified numeric index.
virtual const UINT * | GetData () const
This member function is used to Direct Access to the element data.
virtual UINT * | GetData ()
This member function is used to Direct Access to the element data.
virtual void | SetAtGrow (int nIndex, UINT newElement)
This member function is used to set a new element to the position specified in the nIndex parameter.
virtual int | Add (UINT newElement)
This member function adds a new element to the end of the array.
virtual int | Append (const CXTPArrayT &src)
This member function adds the elements from a specified array to the end of this array.
virtual void | Copy (const CXTPArrayT &src)
This member function overwrites the contents of this array with the contents of a specified array.
UINT | operator[] (int nIndex) const
This operator returns the array element at a specified numeric index.
UINT & | operator[] (int nIndex)
This operator returns a reference to the array element at a specified numeric index.
virtual void | InsertAt (int nIndex, UINT newElement, int nCount=1)
This member function is used to insert a number of copies of an element, specified by the nCount parameter, to the array starting at the position specified by the nIndex parameter.
virtual void | InsertAt (int nStartIndex, CXTPArrayT *pNewArray)
This member function is used to insert an array of elements to the array starting at the position specified by the nStartIndex parameter.
virtual void | RemoveAt (int nIndex, int nCount=1)
This member function is used to remove a number of array elements, specified by the nCount parameter, from the array starting at the position specified by the nIndex parameter.
virtual void | RemoveAll ()
This member function is used to remove all array elements from the array.
virtual int | FindElement (UINT nElement) const
Call this member function to find an element in the collection.
virtual void | AddIfNeed (UINT newElement)
Call this member function to add a specified element to the collection if it is not present already.
virtual BOOL | RemoveElement (UINT nElement)
Call this member function to remove all elements with a specified value from the collection.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Attributes inherited from CXTPArrayT< UINT, UINT >
CArray< UINT, UINT > | m_arElements
Elements storage.

Detailed Description

This class represents the collection of UINT elements.

It also implements some useful operations on elements.

Member Function Documentation

◆ DoPropExchange()

virtual void DoPropExchange | ( | CXTPPropExchange * | pPX,
 |  | LPCTSTR | pcszSection,
 |  | LPCTSTR | pcszElement )
 virtual

Call this member function to Store/Load collection data using the specified data object.

Parameters
pPX | Source or destination CXTPPropExchange data object reference.
pcszSection | Section name for elements set.
pcszElement | Element value property name.

This member function is used to either store event data to or load event data from storage.

Reimplemented in CXTPCalendarEventCategoryIDs, and CXTPCalendarIconIDs.

◆ Find()

int Find ( UINT uID ) const

Call this member function to find an ID in the collection.

Parameters
uID ID to find.
Returns
Zero-based index in the collection, or -1 if the element is not found.

◆ LoadFromString()

virtual void LoadFromString ( LPCTSTR pcszData )
virtual

Call this member function to read collection data from a comma separated string.

Parameters
pcszData String with collection data.
See also
SaveToString

◆ RemoveID()

virtual BOOL RemoveID ( UINT uID )
virtual

Call this member function to remove an ID from the collection.

Parameters
uID ID to remove.
Returns
TRUE if specified ID find and removed, FALSE otherwise.
See also
CArray::RemoveAt
CArray::RemoveAll

◆ SaveToString()

virtual CString SaveToString ( ) const
virtual

Call this member function to store collection data as a comma separated string.

Returns
Comma separated string with collection elements.
See also
LoadFromString
The documentation for this class was generated from the following file:
  • XTPCalendarEventLabel.h


Toolkit Pro: CXTPCalendarUtils Class Reference

Static Public Member Functions | List of all members
CXTPCalendarUtils Class Reference

Helper class with static member functions to perform common tasks with dates, events and other objects. More...

Static Public Member Functions

static int AFX_CDECL | GetLocaleLong (LCTYPE LCType)
This member function is used to retrieve information about a locale.
static CString AFX_CDECL | GetLocaleString (LCTYPE LCType, int nMaxLength=128)
This member function is used to retrieve information about a locale.
static CString AFX_CDECL | GetDateFormat (CONST SYSTEMTIME *lpDate, LPCTSTR lpFormat)
This member function is used to format a date as a date string for a LOCALE_USER_DEFAULT locale.
static CString AFX_CDECL | GetDateFormat (CONST COleDateTime &dtDate, LPCTSTR lpFormat)
This member function is used to format a date as a date string for a LOCALE_USER_DEFAULT locale.
static CString AFX_CDECL | GetTimeFormat (CONST SYSTEMTIME *lpTime, LPCTSTR lpFormat)
This member function is used to format a time as a time string for a LOCALE_USER_DEFAULT locale.
static CString AFX_CDECL | GetTimeFormat (CONST COleDateTime &dtTime, LPCTSTR lpFormat)
This member function is used to format a time as a time string for a LOCALE_USER_DEFAULT locale.
static CString AFX_CDECL | GetTimeFormat (int nHour, int nMinutes, LPCTSTR lpFormat)
This member function is used to format a time as a time string for a LOCALE_USER_DEFAULT locale.
static int AFX_CDECL | GetMaxMonthDay (COleDateTime dtDate)
This member function is used to calculate the maximum month day number for a specified Year and Month in the dtDate parameter.
static BOOL AFX_CDECL | ShiftDate_Month (COleDateTime &refDate, int nMonthCount)
This member function is used to shift the specified date for the specified number of months.
static BOOL AFX_CDECL | ShiftDate_Month (COleDateTime &refDate, int nMonthCount, int nMonthDay)
This member function is used to shift the specified date for the specified number of months.
static BOOL AFX_CDECL | ShiftDate_Year (COleDateTime &refDate, int nYearCount)
This member function is used to shift the specified date for the specified number of years.
static BOOL AFX_CDECL | ShiftDate_Year (COleDateTime &refDate, int nYearCount, int nMonthDay)
This member function is used to shift the specified date for the specified number of years.
static int AFX_CDECL | GetDurationMinutes (const COleDateTime &dtStart, const COleDateTime &dtEnd, BOOL bAllDayEvent)
This member function is used to determine the number of minutes between two DateTime objects.
static BOOL AFX_CDECL | UpdateMonthDay (COleDateTime &refDate, int nMonthDay)
This member function is used to safely update a month day in the specified date.
static const COleDateTime AFX_CDECL | UpdateTime (const COleDateTime &dtDate, int nHour, int nMinutes, int nSeconds)
This member function is used to update the time part for the specified DateTime value.
static const COleDateTime AFX_CDECL | UpdateTime (const COleDateTime &dtDate, const COleDateTime &dtTime)
This member function is used to update the time part for the specified DateTime value.
static const COleDateTime AFX_CDECL | SetTime_235959 (const COleDateTime &dtDateTime)
This member function is used to update the time part to 23:59.
static const COleDateTime AFX_CDECL | UpdateDate (const COleDateTime &dtTime, const COleDateTime &dtDate)
This member function is used to update the date part of the specified DateTime value.
static const COleDateTime AFX_CDECL | UpdateDate (const COleDateTime &dtTime, int nYear, int nMonth, int nDay)
This member function is used to update the date part of the specified DateTime value.
static const COleDateTime AFX_CDECL | ResetTime (const COleDateTime &dtDateTime)
This member function is used to reset (set to zero) the time part for the specified DateTime value.
static const COleDateTime AFX_CDECL | ResetTime (const DATE dtDateTime)
This member function is used to reset (set to zero) the time part for the specified DateTime value.
static const COleDateTime AFX_CDECL | ResetDate (const COleDateTime &dtDateTime)
This member function is used to reset (set to zero) the date part for the specified DateTime value.
static BOOL AFX_CDECL | IsEqual (const COleDateTime &dt1, const COleDateTime &dt2, BOOL bOneSecTimeDiff=FALSE)
This member function is used to compare two dates (and times).
static BOOL AFX_CDECL | IsZeroTime (const COleDateTime &dtDateTime)
This member function is used to determine if the time part is equal to zero.
static int AFX_CDECL | GetDiff_Months (const COleDateTime &dt1, const COleDateTime &dt2)
This member function is used to calculate differences between 2 dates in months.
static COleDateTime AFX_CDECL | RetriveEventEndDate (const CXTPCalendarEvent *pEvent)
Get event end date (date part only) value.
static COleDateTime AFX_CDECL | RetriveEventEndDate (const COleDateTime &dtStart, const COleDateTime &dtEnd)
Get event end date (date part only) value.
static int AFX_CDECL | GetEventPeriodDays (const COleDateTime &dtStart, const COleDateTime &dtEnd)
Call this member function to get an event duration as a number of days.
static BOOL AFX_CDECL | CalcDayOfMonth (COleDateTime &rdtDate, int nWhichDay, int nWhichDayMask)
This member function is used to calculate the day of the month from the provided COleDateTime object.
static int AFX_CDECL | GetDayOfWeekMask (int nWeekDay)
This member function is used to convert a sequential week day number (from 1 to 7) to a value from the enum XTPCalendarWeekDay.
static int AFX_CDECL | GetDayOfWeekIndex (int nDayOfWeekMask)
This member function is used to convert an XTPCalendarWeekDay enum value to a sequential week day number (from 1 to 7).
static int AFX_CDECL | GetDayOfWeekCount (int nDayOfWeekMask)
This member function is used to count the bits in the specified bit mask.
static int AFX_CDECL | GetDayOfWeekLocaleStringId (int nWeekDay)
Obtains locale string ID for a week day specified.
static int AFX_CDECL | MakeDaysOfWeekMask_Mo_ (int nEndWDay)
This member function is used to make the days mask from Monday until the specified day.
static COleDateTime AFX_CDECL | ShiftDateToWeekBegin (COleDateTime dtDate, int nFirstDayOfWeekIndex=1)
This member function is used to shift the specified date to the beginning of the week.
static int AFX_CDECL | GetWeekOfYear (COleDateTime dtDate, int nFirstDayOfWeekIndex=1)
This member function is used to calculate a week number of year.
static BOOL AFX_CDECL | SystemTimeToTzSpecificLocalTime (const TIME_ZONE_INFORMATION *pTZI, const SYSTEMTIME *pUTime, SYSTEMTIME *pTzTime)
The SystemTimeToTzSpecificLocalTime function converts a time in Coordinated Universal Time (UTC) to a specified time zone's corresponding local time.
static BOOL AFX_CDECL | IsWin9x ()
This function is used to determine if the program is running on Windows 9x operation system family.
static COleDateTimeSpan AFX_CDECL | Minutes2Span (int nMinutes)
Converts a number of minutes into its corresponding COleDateTimeSpan object.
static COleDateTime AFX_CDECL | GetCurrentTime ()
Returns current local time.
static void AFX_CDECL | OverrideTimeProvider (ITimeProvider *pTimeProvider)
Overrides the local time provider with the custom provider.
static void AFX_CDECL | ResetTimeProvider ()
Resets time provider to default which will use the current machine date time.
static CString AFX_CDECL | GetTimeFormatString_HrMin ()
Returns current time format string for hours and minutes.
static int AFX_CDECL | ParceTimeString_min (LPCTSTR pcszTime_HrMin)
Parse a time string like "18:20" or "7:15 pm" and returns time as total minutes.
static CString AFX_CDECL | FormatTimeDuration (int nMinutes, BOOL bRoundly)
Format time duration like "3 minutes" or "1 week".
static int AFX_CDECL | ParceTimeDuration_min (LPCTSTR pcszTimeDuration)
Parse a time duration string like "5 minutes", "2 hours", "1 day" or "3 weeks" and returns duration as total minutes.
static CString AFX_CDECL | LoadString (UINT nIDResource)
Loads string using XTPResourceManager.
static BOOL AFX_CDECL | LoadString2 (CString &rstrString, UINT nIDResource)
Loads string using XTPResourceManager.
static void AFX_CDECL | TextPrepareSingleline (CString &rstrString)
Prepares a string for single line display.
static LCID AFX_CDECL | GetActiveLCID ()
Returns active locale ID (current user locale or resource file locale).
static CFont *AFX_CDECL | GetMaxHeightFont (CArray< CFont *, CFont * > &arFonts, CDC *pDC, int *pnMaxHeight=NULL)
This function is used to determine a font with maximum symbols height in an array of fonts.
static BOOL AFX_CDECL | IsFormatChar (TCHAR t)
Call this function to check if a character is a format character (Mm Dd Yy).
static CString AFX_CDECL | RemoveFormatPart (CString strFormat, LPCTSTR lpszRemove)
Call this function to remove a portion from the time format part (Mm Dd Yy).
static CString AFX_CDECL | RemoveFormatPart (CString strFormat, TCHAR cRemove)
Call this function to remove a character from the time format part (Mm Dd Yy).
static void AFX_CDECL | StripFormat (CString &strFormat, int nIndex, int nRemove)
This function removes a fixed number of characters from the format string, starting at a particular index.
static double AFX_CDECL | _RoundDateTime_dbl (double dblDT)
This function is used to round date time values by adding (or subtracting) a half-second double value.
static double AFX_CDECL | _ResetTime_dbl (double dblDT)
This function is used to reset the time part.
static double AFX_CDECL | _ResetDate_dbl (double dblDT)
This function used is to reset the date part.
static BOOL AFX_CDECL | TrackMouseEvent (DWORD dwFlags, HWND hwndTrack, DWORD dwHoverTime=HOVER_DEFAULT)
The TrackMouseEvent function posts messages when the mouse pointer leaves a window or hovers over a window for a specified amount of time.
static int AFX_CDECL | GetFirstWeekOfYearDays ()
This function return number of days of the new year in the first week of this year.

Detailed Description

Helper class with static member functions to perform common tasks with dates, events and other objects.

Member Function Documentation

◆ _ResetDate_dbl()

AFX_INLINE double _ResetDate_dbl ( double dblDT )
static

This function used is to reset the date part.

Parameters
dblDT [in] A date time value in COLEDateTime double representation.
Returns
Time value (with zero date) in COLEDateTime double representation.

◆ _ResetTime_dbl()

AFX_INLINE double _ResetTime_dbl ( double dblDT )
static

This function is used to reset the time part.

Parameters
dblDT [in] A date time value in COLEDateTime double representation.
Returns
Date value (with zero time) in COLEDateTime double representation.

◆ _RoundDateTime_dbl()

AFX_INLINE double _RoundDateTime_dbl ( double dblDT )
static

This function is used to round date time values by adding (or subtracting) a half-second double value.

Parameters
dblDT [in] A date time value in COLEDateTime double representation.
Returns
Rounded date time value in COLEDateTime double representation.

◆ CalcDayOfMonth()

static BOOL AFX_CDECL CalcDayOfMonth | ( | COleDateTime & | rdtDate,
 |  | int | nWhichDay,
 |  | int | nWhichDayMask )
 static

This member function is used to calculate the day of the month from the provided COleDateTime object.

Parameters
rdtDate | A COleDateTime object that contains the date to update with the valid year and month parts.
nWhichDay | An int that contains the value from the enum XTPCalendarWeek. This parameter specifies the sequential number of the day. For example: First Friday.
nWhichDayMask | An int that contains the combination of values from the enums XTPCalendarWeekDay or the XTPCalendarWeekDay. This parameter, together with the nWhichDay parameter are used to specify the following logical values: Which Day of Month, Which WeekDay, Which WeekEndDay, Which day of week Su, Mo, ..., St. For example: Last day of Month, Second WeekEndDay, Fourth Monday.
Returns
A BOOL. TRUE if the value of this COleDateTime object was set successfully. FALSE otherwise.

◆ FormatTimeDuration()

static CString AFX_CDECL FormatTimeDuration | ( | int | nMinutes,
 |  | BOOL | bRoundly )
 static

Format time duration like "3 minutes" or "1 week".

Active locale setting are used.

Parameters
nMinutes | Duration in minutes.
bRoundly | If TRUE duration will be rounded to biggest scale, like 65 minutes will be formatted as "1 hour". If False duration will formatted exactly: 65 minutes as "65 minutes; 120 minutes as "2 hours". @return Time duration as string like "5 minutes", "2 hours", "1 day", "3 weeks".

◆ GetActiveLCID()

static LCID AFX_CDECL GetActiveLCID ( )
static

Returns active locale ID (current user locale or resource file locale).

Returns
LOCALE_USER_DEFAULT or resource file locale ID.
See also
CXTPResourceManager::GetResourcesLangID
LOCALE_USER_DEFAULT

◆ GetCurrentTime()

static COleDateTime AFX_CDECL GetCurrentTime ( )
static

Returns current local time.

Returns
COleDateTime object with the calculated local time value.

◆ GetDateFormat() [1/2]

static CString AFX_CDECL GetDateFormat | ( | CONST COleDateTime & | dtDate,
 |  | LPCTSTR | lpFormat )
 static

This member function is used to format a date as a date string for a LOCALE_USER_DEFAULT locale.

Parameters
dtDate | A date to be formatted.
lpFormat | Pointer to a format picture string that is used to form the date string. The format picture string must be zero terminated. If lpFormat is NULL, the function uses the date format of the specified locale.

The function formats either a specified date or the local system date.

Returns
A CString that contains the formatted date string.
See also
GetDateFormat

◆ GetDateFormat() [2/2]

static CString AFX_CDECL GetDateFormat | ( | CONST SYSTEMTIME * | lpDate,
 |  | LPCTSTR | lpFormat )
 static

This member function is used to format a date as a date string for a LOCALE_USER_DEFAULT locale.

Parameters
lpDate | Pointer to a SYSTEMTIME structure that contains the date information to be formatted. If this pointer is NULL, the function uses the current local system date.
lpFormat | Pointer to a format picture string that is used to form the date string. The format picture string must be zero terminated. If lpFormat is NULL, the function uses the date format of the specified locale.

The function formats either a specified date or the local system date.

Returns
A CString that contains the formatted date string.
See also
GetDateFormat

◆ GetDayOfWeekCount()

AFX_INLINE int GetDayOfWeekCount ( int nDayOfWeekMask )
static

This member function is used to count the bits in the specified bit mask.

Parameters
nDayOfWeekMask An int that contains the mask from the enum XTPCalendarWeekDay.
Returns
An int that contains the integer value of the day of the week contained in the bit mask.
See also
GetDayOfWeekMask
XTPCalendarWeekDay enum

◆ GetDayOfWeekIndex()

AFX_INLINE int GetDayOfWeekIndex ( int nDayOfWeekMask )
static

This member function is used to convert an XTPCalendarWeekDay enum value to a sequential week day number (from 1 to 7).

Parameters
nDayOfWeekMask An int that contains the value from the enum XTPCalendarWeekDay.
Returns
An int that contains the sequential week day number. 1-Sunday, 2-Monday, ...
See also
GetDayOfWeekMask
XTPCalendarWeekDay enum

◆ GetDayOfWeekLocaleStringId()

static int AFX_CDECL GetDayOfWeekLocaleStringId ( int nWeekDay )
static

Obtains locale string ID for a week day specified.

Parameters
nWeekDay An int that contains the sequential week day number. 1-Sunday, 2-Monday, ...
Returns
Locale string ID for a week day specified.
See also
GetDayOfWeekIndex
XTPCalendarWeekDay enum

◆ GetDayOfWeekMask()

AFX_INLINE int GetDayOfWeekMask ( int nWeekDay )
static

This member function is used to convert a sequential week day number (from 1 to 7) to a value from the enum XTPCalendarWeekDay.

Parameters
nWeekDay An int that contains the sequential week day number. 1-Sunday, 2-Monday, ...
Returns
An int that contains the corresponding value from the enum XTPCalendarWeekDay.
See also
GetDayOfWeekIndex
XTPCalendarWeekDay enum

◆ GetDiff_Months()

AFX_INLINE int GetDiff_Months | ( | const COleDateTime & | dt1,
 |  | const COleDateTime & | dt2 )
 static

This member function is used to calculate differences between 2 dates in months.

Parameters
dt1 | A COleDateTime object that contains the first DateTime value.
dt2 | A COleDateTime object that contains the second DateTime value.
Returns
Months difference for dt1 - dt2.
See also
COleDateTime overview

◆ GetDurationMinutes()

AFX_INLINE int GetDurationMinutes | ( | const COleDateTime & | dtStart,
 |  | const COleDateTime & | dtEnd,
 |  | BOOL | bAllDayEvent )
 static

This member function is used to determine the number of minutes between two DateTime objects.

Parameters
dtStart | A COleDateTime object that contains the beginning date.
dtEnd | A COleDateTime object that contains the end date.
bAllDayEvent | Calculate duration for all day event.

This is a utility function that is used to retrieve the number of minutes between two COleDateTime objects.

Returns
An int that contains the number of minutes between two DateTime objects.

◆ GetEventPeriodDays()

AFX_INLINE int GetEventPeriodDays | ( | const COleDateTime & | dtStart,
 |  | const COleDateTime & | dtEnd )
 static

Call this member function to get an event duration as a number of days.

Parameters
dtStart | Event start time.
dtEnd | Event end time.
Returns
Integer value of an event duration in days.
See also
CXTPCalendarEvent::GetDurationMinutes()
CXTPCalendarEvent::GetDuration()

◆ GetFirstWeekOfYearDays()

static int AFX_CDECL GetFirstWeekOfYearDays ( )
static

This function return number of days of the new year in the first week of this year.

Returns
Number of days of the new year in the first week of this year.

◆ GetLocaleLong()

static int AFX_CDECL GetLocaleLong ( LCTYPE LCType )
static

This member function is used to retrieve information about a locale.

Parameters
LCType An LCTYPE that specifies the type of locale information to retrieve. (for the LOCALE_USER_DEFAULT)
Returns
Integer value that contains the information about the locale.
See also
GetLocaleInfo

◆ GetLocaleString()

static CString AFX_CDECL GetLocaleString | ( | LCTYPE | LCType,
 |  | int | nMaxLength = 128 )
 static

This member function is used to retrieve information about a locale.

Parameters
LCType | An LCTYPE that specifies the type of locale information to retrieve. (for the LOCALE_USER_DEFAULT)
nMaxLength | An int that contains the maximum string size to allocate for the corresponding buffer.
Returns
String value.
See also
GetLocaleInfo

◆ GetMaxHeightFont()

static CFont *AFX_CDECL GetMaxHeightFont | ( | CArray< CFont *, CFont * > & | arFonts,
 |  | CDC * | pDC,
 |  | int * | pnMaxHeight = NULL )
 static

This function is used to determine a font with maximum symbols height in an array of fonts.

Parameters
arFonts | [in] A reference to an array of fonts.
pDC | [in] A pointer to a valid device context or NULL.
pnMaxHeight | [out] A pointer to an int variable to store maximum font height or NULL.

If pDC is not NULL - the font height in device logical units is used. Otherwise the LOGFONT.lfHeight member is used as font height.

Returns
A font from the provided array with maximum symbols height.

◆ GetMaxMonthDay()

AFX_INLINE int GetMaxMonthDay ( COleDateTime dtDate )
static

This member function is used to calculate the maximum month day number for a specified Year and Month in the dtDate parameter.

Parameters
dtDate A COleDateTime date value.
Returns
An int that contains the maximum month day number. (30, 31, 28, 29)

◆ GetTimeFormat() [1/3]

static CString AFX_CDECL GetTimeFormat | ( | CONST COleDateTime & | dtTime,
 |  | LPCTSTR | lpFormat )
 static

This member function is used to format a time as a time string for a LOCALE_USER_DEFAULT locale.

Parameters
dtTime | A time to be formatted.
lpFormat | A pointer to a format picture string that is used to form the time string. The format picture string must be zero terminated. If lpFormat is NULL, the function uses the time format of the specified locale.

The function formats either a specified time or the local system time.

Returns
A CString that contains the formatted time string.
See also
GetTimeFormat

◆ GetTimeFormat() [2/3]

static CString AFX_CDECL GetTimeFormat | ( | CONST SYSTEMTIME * | lpTime,
 |  | LPCTSTR | lpFormat )
 static

This member function is used to format a time as a time string for a LOCALE_USER_DEFAULT locale.

Parameters
lpTime | Pointer to a SYSTEMTIME structure that contains the time information to be formatted. If this pointer is NULL, the function uses the current local system time.
lpFormat | Pointer to a format picture string that is used to form the time string. The format picture string must be zero terminated. If lpFormat is NULL, the function uses the time format of the specified locale.

The function formats either a specified time or the local system time.

Returns
A CString that contains the formatted time string.
See also
GetTimeFormat

◆ GetTimeFormat() [3/3]

static CString AFX_CDECL GetTimeFormat | ( | int | nHour,
 |  | int | nMinutes,
 |  | LPCTSTR | lpFormat )
 static

This member function is used to format a time as a time string for a LOCALE_USER_DEFAULT locale.

Parameters
nHour | Hour of time to be formatted.
nMinutes | Minutes of time to be formatted.
lpFormat | Pointer to a format picture string that is used to form the time string. The format picture string must be zero terminated. If lpFormat is NULL, the function uses the time format of the specified locale.

The function formats either a specified time or the local system time.

Returns
A CString that contains the formatted time string.
See also
GetTimeFormat

◆ GetTimeFormatString_HrMin()

static CString AFX_CDECL GetTimeFormatString_HrMin ( )
static

Returns current time format string for hours and minutes.

Returns
A time format string like: 'HH:mm', 'hh:mm tt', 'h:m t', ...

◆ GetWeekOfYear()

static int AFX_CDECL GetWeekOfYear | ( | COleDateTime | dtDate,
 |  | int | nFirstDayOfWeekIndex = 1 )
 static

This member function is used to calculate a week number of year.

Parameters
dtDate | A COleDateTime object that contains the date to calculate the week of year.
nFirstDayOfWeekIndex | Index of the first day of week. Default value 1. 1-Sunday, 2-Monday, ...
Returns
A week number of year for the specified date.
See also
COleDateTime overview

◆ IsEqual()

static BOOL AFX_CDECL IsEqual | ( | const COleDateTime & | dt1,
 |  | const COleDateTime & | dt2,
 |  | BOOL | bOneSecTimeDiff = FALSE )
 static

This member function is used to compare two dates (and times).

Parameters
dt1 | A COleDateTime object that contains the first DateTime value.
dt2 | A COleDateTime object that contains the second DateTime value.
bOneSecTimeDiff | A BOOL. Used to set the precision of the compare operation. If TRUE, then one second precision is used. If FALSE, then half a second precision is used.
Returns
A BOOL. TRUE if the dates differ by less than or equal to the specified precision. FALSE otherwise.
See also
COleDateTime overview

◆ IsFormatChar()

static BOOL AFX_CDECL IsFormatChar ( TCHAR t )
static

Call this function to check if a character is a format character (Mm Dd Yy).

Parameters
t character.
Returns
TRUE if the input character is a format character, FALSE otherwise.

◆ IsWin9x()

static BOOL AFX_CDECL IsWin9x ( )
static

This function is used to determine if the program is running on Windows 9x operation system family.

Returns
TRUE for Windows 9x operation system, otherwise FALSE.

◆ IsZeroTime()

static BOOL AFX_CDECL IsZeroTime ( const COleDateTime & dtDateTime )
static

This member function is used to determine if the time part is equal to zero.

Parameters
dtDateTime A COleDateTime object that contains the value to check.
Returns
A BOOL. TRUE if the time part is equal to zero. FALSE otherwise.
See also
COleDateTime overview

◆ LoadString()

static CString AFX_CDECL LoadString ( UINT nIDResource )
static

Loads string using XTPResourceManager.

Parameters
nIDResource ID of the string in the resource.
Returns
Loaded string or an empty string.

◆ LoadString2()

static BOOL AFX_CDECL LoadString2 | ( | CString & | rstrString,
 |  | UINT | nIDResource )
 static

Loads string using XTPResourceManager.

Parameters
nIDResource | ID of the string in resource.
rstrString | [out] Reference to CString object to load string to.

If string with such ID is not present in the resource - rstrString is not changed.

Returns
TRUE if string loaded, FALSE otherwise.

◆ MakeDaysOfWeekMask_Mo_()

AFX_INLINE int MakeDaysOfWeekMask_Mo_ ( int nEndWDay )
static

This member function is used to make the days mask from Monday until the specified day.

Parameters
nEndWDay An int that contains the sequential week day number. 1-Sunday, 2-Monday, ...
Returns
An int that contains the values set from the enum XTPCalendarWeekDay.
See also
GetDayOfWeekIndex
XTPCalendarWeekDay enum

◆ Minutes2Span()

AFX_INLINE COleDateTimeSpan Minutes2Span ( int nMinutes )
static

Converts a number of minutes into its corresponding COleDateTimeSpan object.

Parameters
nMinutes A number of minutes in the time span.
Returns
Calculated COleDateTimeSpan object.

◆ OverrideTimeProvider()

static void AFX_CDECL OverrideTimeProvider ( ITimeProvider * pTimeProvider )
static

Overrides the local time provider with the custom provider.

The date-time returned by the custom provider will be used as the current time for calendar control. All calls to CXTPCalendarUtils::GetCurrentTime() from within calendar control will be routed to custom provider.

Parameters
pTimeProvider A new time provider interface pointer.
Returns
A pointer to an instance of custom time provider. The instance must remain until the time provider is reset by a ResetTimeProvider() call. The caller should free provider instance memory after a ResetTimeProvider() call.

◆ ParceTimeDuration_min()

static int AFX_CDECL ParceTimeDuration_min ( LPCTSTR pcszTimeDuration )
static

Parse a time duration string like "5 minutes", "2 hours", "1 day" or "3 weeks" and returns duration as total minutes.

Active locale setting are used.

Parameters
pcszTimeDuration time duration string like "5 minutes", "2 hours".
Returns
Time duration as total minutes.

◆ ParceTimeString_min()

static int AFX_CDECL ParceTimeString_min ( LPCTSTR pcszTime_HrMin )
static

Parse a time string like "18:20" or "7:15 pm" and returns time as total minutes.

Active locale setting are used.

Parameters
pcszTime_HrMin time string like "18:20" or "7:15 pm".
Returns
Time as total minutes.

◆ RemoveFormatPart() [1/2]

static CString AFX_CDECL RemoveFormatPart | ( | CString | strFormat,
 |  | LPCTSTR | lpszRemove )
 static

Call this function to remove a portion from the time format part (Mm Dd Yy).

Parameters
strFormat | The format string.
lpszRemove | String to remove.
Returns
The new string.

◆ RemoveFormatPart() [2/2]

static CString AFX_CDECL RemoveFormatPart | ( | CString | strFormat,
 |  | TCHAR | cRemove )
 static

Call this function to remove a character from the time format part (Mm Dd Yy).

Parameters
strFormat | The format string.
cRemove | TRUE to remove.
Returns
The new string.

◆ ResetDate()

AFX_INLINE const COleDateTime ResetDate ( const COleDateTime & dtDateTime )
static

This member function is used to reset (set to zero) the date part for the specified DateTime value.

Parameters
dtDateTime A COleDateTime DateTime value that contains the DateTime value to reset.
Returns
A COleDateTime object with the date part set equal to zero.
See also
COleDateTime overview

◆ ResetTime() [1/2]

AFX_INLINE const COleDateTime ResetTime ( const COleDateTime & dtDateTime )
static

This member function is used to reset (set to zero) the time part for the specified DateTime value.

Parameters
dtDateTime A COleDateTime object that contains the time value to reset.
Returns
A COleDateTime object with the time part set equal to zero.
See also
COleDateTime overview

◆ ResetTime() [2/2]

AFX_INLINE const COleDateTime ResetTime ( const DATE dtDateTime )
static

This member function is used to reset (set to zero) the time part for the specified DateTime value.

Parameters
dtDateTime A DATE object that contains the time value to reset.
Returns
A COleDateTime object with the time part set equal to zero.
See also
COleDateTime overview

◆ ResetTimeProvider()

static void AFX_CDECL ResetTimeProvider ( )
static

Resets time provider to default which will use the current machine date time.

Returns
void

◆ RetriveEventEndDate() [1/2]

AFX_INLINE COleDateTime RetriveEventEndDate | ( | const COleDateTime & | dtStart,
 |  | const COleDateTime & | dtEnd )
 static

Get event end date (date part only) value.

Parameters
dtStart | Event start time.
dtEnd | Event end time.

Useful when end DateTime has a zero time part and/or event start equal end.

Returns
Date part of the event end DateTime.
See also
COleDateTime overview

◆ RetriveEventEndDate() [2/2]

static COleDateTime AFX_CDECL RetriveEventEndDate ( const CXTPCalendarEvent * pEvent )
static

Get event end date (date part only) value.

Parameters
pEvent Event object.

Useful when end DateTime has a zero time part and/or event start equal end.

Returns
Date part of the event end DateTime.
See also
COleDateTime overview

◆ SetTime_235959()

AFX_INLINE const COleDateTime SetTime_235959 ( const COleDateTime & dtDateTime )
static

This member function is used to update the time part to 23:59.

Parameters
dtDateTime A COleDateTime object that contains the value used to update the time part.
Returns
A COleDateTime object that contains the updated time part.
See also
COleDateTime overview

◆ ShiftDate_Month() [1/2]

AFX_INLINE BOOL ShiftDate_Month | ( | COleDateTime & | refDate,
 |  | int | nMonthCount )
 static

This member function is used to shift the specified date for the specified number of months.

Parameters
refDate | A reference to the COleDateTime object to shift the date on.
nMonthCount | An int that contains the number of months shifted. Can be both positive and negative numbers.

This is a utility function that is used to shift the specified date for the specific number of months.

Returns
A BOOL. TRUE if the value of this COleDateTime object was set successfully. FALSE otherwise.
See also
COleDateTime overview

◆ ShiftDate_Month() [2/2]

AFX_INLINE BOOL ShiftDate_Month | ( | COleDateTime & | refDate,
 |  | int | nMonthCount,
 |  | int | nMonthDay )
 static

This member function is used to shift the specified date for the specified number of months.

Parameters
refDate | A reference to the COleDateTime object to shift the date on.
nMonthCount | An int that contains the number of months shifted. Can be both positive and negative numbers.
nMonthDay | An int that contains the day of the month to set for a resulting date. If nMonthDay is greater then the maximum month day in the result month, then the maximum possible day is set.

This is a utility function that is used to shift the specified date for the specific number of months.

Returns
A BOOL. TRUE if the value of this COleDateTime object was set successfully. FALSE otherwise.
See also
COleDateTime overview

◆ ShiftDate_Year() [1/2]

AFX_INLINE BOOL ShiftDate_Year | ( | COleDateTime & | refDate,
 |  | int | nYearCount )
 static

This member function is used to shift the specified date for the specified number of years.

Parameters
refDate | Reference to the COleDateTime object to shift the date on.
nYearCount | An int that contains the number of years to shift. Can be both positive and negative numbers.

This is a utility function that is used to shift the specified date the specified number of years.

Returns
A BOOL. TRUE if the value of this COleDateTime object is set successfully. FALSE otherwise.
See also
COleDateTime overview

◆ ShiftDate_Year() [2/2]

AFX_INLINE BOOL ShiftDate_Year | ( | COleDateTime & | refDate,
 |  | int | nYearCount,
 |  | int | nMonthDay )
 static

This member function is used to shift the specified date for the specified number of years.

Parameters
refDate | Reference to the COleDateTime object to shift the date on.
nYearCount | An int that contains the number of years to shift. Can be both positive and negative numbers.
nMonthDay | An int that contains the day of the month to set for the resulting date. If nMonthDay is greater then the maximum month day in the result month, then the maximum possible day is set.

This is a utility function that is used to shift the specified date the specified number of years.

Returns
A BOOL. TRUE if the value of this COleDateTime object is set successfully. FALSE otherwise.
See also
COleDateTime overview

◆ ShiftDateToWeekBegin()

AFX_INLINE COleDateTime ShiftDateToWeekBegin | ( | COleDateTime | dtDate,
 |  | int | nFirstDayOfWeekIndex = 1 )
 static

This member function is used to shift the specified date to the beginning of the week.

Parameters
dtDate | A COleDateTime object that contains the value to shift to the beginning of the week.
nFirstDayOfWeekIndex | Index of the first day of week. Default value 1. 1-Sunday, 2-Monday, ...
Returns
A COleDateTime object that contains the date of the first day of week before the specified date.
See also
COleDateTime overview

◆ StripFormat()

static void AFX_CDECL StripFormat | ( | CString & | strFormat,
 |  | int | nIndex,
 |  | int | nRemove )
 static

This function removes a fixed number of characters from the format string, starting at a particular index.

Parameters
strFormat | The format string.
nIndex | Starting index.
nRemove | The number of characters to remove.
Returns
void

◆ SystemTimeToTzSpecificLocalTime()

static BOOL AFX_CDECL SystemTimeToTzSpecificLocalTime | ( | const TIME_ZONE_INFORMATION * | pTZI,
 |  | const SYSTEMTIME * | pUTime,
 |  | SYSTEMTIME * | pTzTime )
 static

The SystemTimeToTzSpecificLocalTime function converts a time in Coordinated Universal Time (UTC) to a specified time zone's corresponding local time.

Parameters
pTZI | [in] Pointer to a TIME_ZONE_INFORMATION structure that specifies the time zone of interest.
pUTime | [in] Pointer to a SYSTEMTIME structure that specifies a UTC. The function converts this universal time to the specified time zone's corresponding local time.
pTzTime | [out] Pointer to a SYSTEMTIME structure that receives the local time information.
Returns
If the function succeeds, the return value is nonzero, and the function sets the members of the SYSTEMTIME structure pointed to by pTzTime to the appropriate local time values.
See also
SystemTimeToTzSpecificLocalTime() windows API function.

◆ TextPrepareSingleline()

static void AFX_CDECL TextPrepareSingleline ( CString & rstrString )
static

Prepares a string for single line display.

Parameters
rstrString [out] Reference to CString object to update.

Removes from the string not visible characters which are valid for multiline display, but not valid for singleline. Examples: '
'.

Returns
void
See also
DT_SINGLELINE

◆ TrackMouseEvent()

static BOOL AFX_CDECL TrackMouseEvent | ( | DWORD | dwFlags,
 |  | HWND | hwndTrack,
 |  | DWORD | dwHoverTime = HOVER_DEFAULT )
 static

The TrackMouseEvent function posts messages when the mouse pointer leaves a window or hovers over a window for a specified amount of time.

Parameters
dwFlags | Specifies the services requested.
hwndTrack | Specifies a handle to the window to track.
dwHoverTime | Specifies the hover time-out (if TME_HOVER was specified in dwFlags), in milliseconds. Can be HOVER_DEFAULT, which means to use the system default hover time-out.
Returns
If the function succeeds, the return value is nonzero.

◆ UpdateDate() [1/2]

AFX_INLINE const COleDateTime UpdateDate | ( | const COleDateTime & | dtTime,
 |  | const COleDateTime & | dtDate )
 static

This member function is used to update the date part of the specified DateTime value.

Parameters
dtTime | A COleDateTime object that contains the value used to update the date part.
dtDate | A COleDateTime object that contains the new date part.
Returns
A COleDateTime object that contains the updated date part.
See also
COleDateTime overview

◆ UpdateDate() [2/2]

AFX_INLINE const COleDateTime UpdateDate | ( | const COleDateTime & | dtTime,
 |  | int | nYear,
 |  | int | nMonth,
 |  | int | nDay )
 static

This member function is used to update the date part of the specified DateTime value.

Parameters
dtTime | A COleDateTime object that contains the value used to update the date part.
nYear | An int that contains the new Year used in the date part.
nMonth | An int that contains the new Minutes used in the the date part.
nDay | An int that contains the new Day used in the date part.
Returns
A COleDateTime object that contains the updated date part.
See also
COleDateTime overview

◆ UpdateMonthDay()

AFX_INLINE BOOL UpdateMonthDay | ( | COleDateTime & | refDate,
 |  | int | nMonthDay )
 static

This member function is used to safely update a month day in the specified date.

Parameters
refDate | Reference to the COleDateTime object to shift the date on.
nMonthDay | An int that contains the day of the month to set for the resulting date. If nMonthDay is greater then the maximum month day in the result month, then the maximum possible day is set.

This is utility function is used to update the month day in the specified date.

Returns
A BOOL. TRUE if the value of this COleDateTime object was set successfully. FALSE otherwise.
See also
COleDateTime overview

◆ UpdateTime() [1/2]

AFX_INLINE const COleDateTime UpdateTime | ( | const COleDateTime & | dtDate,
 |  | const COleDateTime & | dtTime )
 static

This member function is used to update the time part for the specified DateTime value.

Parameters
dtDate | A COleDateTime object that contains the value used to update the time part.
dtTime | A COleDateTime object that contains the new time part value.
Returns
A COleDateTime object that contains the updated time part.
See also
COleDateTime overview

◆ UpdateTime() [2/2]

AFX_INLINE const COleDateTime UpdateTime | ( | const COleDateTime & | dtDate,
 |  | int | nHour,
 |  | int | nMinutes,
 |  | int | nSeconds )
 static

This member function is used to update the time part for the specified DateTime value.

Parameters
dtDate | A COleDateTime object that contains the value that is used to update the time part.
nHour | An int that contains the new Hour in the time part.
nMinutes | An int that contains the new Minutes in the time part.
nSeconds | An int that contains the new Seconds in the time part.
Returns
A COleDateTime object that contains the updated time part.
See also
COleDateTime overview
The documentation for this class was generated from the following file:
  • XTPCalendarUtils.h


Toolkit Pro: CXTPCalendarView Class Reference

Classes | Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPCalendarView Class Referenceabstract

This class represents the view portion of the Calendar control. More...

Inheritance diagram for CXTPCalendarView:
[legend]

Classes

class | CSelectionChanged_ContextData
This class defines an internal structure used as a counter on selection changes, which is needed to redraw a view when necessary. More...
class | CSelectionChangedContext
Class CSelectionChangedContext is used to avoid multiple sending of an XTP_NC_CALENDAR_SELECTION_CHANGED notification for one selection changing operation. More...
struct | SEventTimeFormatInfo

Public Member Functions

UINT | GetDiscreteSelectionCount () const
This member function is used to get the number of selected events.
COleDateTime | GetDiscreteSelectionValue (UINT id) const
This member function gets a selected event by using its event ordinal number.
BOOL | AddToDiscreteSelection (UINT id)
This member function adds an event to the selection by using its event ordinal number.
BOOL | IsInDiscreteSelection (UINT id) const
This member function checks if an event is in the selection.
void | ClearDiscreteSelection ()
This member function is used to Clear Discrete Selection.
CXTPCalendarView (CXTPCalendarControl *pCalendarControl)
Default object constructor.
virtual | ~CXTPCalendarView ()
Default class destructor.
virtual XTPCalendarViewType | GetViewType () const =0
Call this member function to obtain the view type flag.
virtual void | Populate ()
This member function is used to populate the view with data for all items contained in the view.
virtual void | AdjustLayout (CDC *pDC, const CRect &rcView, BOOL bCallPostAdjustLayout=TRUE)
This member function is used to adjust the view's layout depending on the window client size and calls AdjustLayout() for all sub-items.
virtual void | AdjustLayout2 (CDC *pDC, const CRect &rcView, BOOL bCallPostAdjustLayout=TRUE)
This member function is used to adjust the view's layout depending on the window client size and calls AdjustLayout() for all sub-items.
virtual void | RedrawControl ()
This member function is used to perform the redrawing of the control's layout.
virtual void | ShowDay (const COleDateTime &date, BOOL bSelect=TRUE)=0
This member function is used to show the specified day in the calendar view.
virtual void | ScrollV (int nPos, int nPos_raw)
Scroll vertically.
virtual void | ScrollH (int nPos, int nPos_raw)
Scroll horizontally.
virtual void | OnScrollEnd (int nBar)
This member function is used to force scroll to the end of the scroll range.
virtual BOOL | GetScrollBarInfoV (SCROLLINFO *pSI) const
This member function is used to retrieve the information about a scroll bar state.
virtual BOOL | GetScrollBarInfoH (SCROLLINFO *pSI, int *pnScrollStep=NULL) const
This member function is used to retrieve the information about a scroll bar state.
virtual void | OnDraw (CDC *pDC)
This member function performs all of the drawing logic of the calendar view.
virtual void | Draw (CDC *pDC)
This member function is used to draw the view content using the specified device context.
virtual void | Draw2 (CDC *pDC)
This member function is used to draw the view content using the specified device context.
virtual BOOL | OnLButtonDown (UINT nFlags, CPoint point)
This member function is used to process left mouse button events.
virtual BOOL | OnLButtonUp (UINT nFlags, CPoint point)
This member function is used to process left mouse button events.
virtual void | OnMouseMove (UINT nFlags, CPoint point)
This member function is used to process mouse movement events.
virtual BOOL | OnLButtonDblClk (UINT nFlags, CPoint point)
This member function is used to process mouse double-click events.
virtual void | OnChar (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process keyboard events.
virtual void | OnKeyDown (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to processes keyboard events.
virtual BOOL | OnSysKeyDown (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process system keyboard events.
CRect | GetViewRect () const
Call this member function to obtain the view's bounding rectangle.
virtual int | GetChildHandlersCount () const
This member function is used to obtain the number of CXTPCalendarWMHandler elements in the descendant handlers collection.
virtual CXTPCalendarWMHandler * | GetChildHandlerAt (int nIndex) const
Call this method to get a handler object at the specified numeric index.
virtual int | GetViewDayCount () const
Call this member function to obtain the number of "day views" in the view collection.
virtual COleDateTime | GetViewDayDate (int nIndex) const =0
Call this member function to obtain the date of the day view by the day's index.
virtual CXTPCalendarViewDay * | GetViewDay_ (int nIndex) const
Call this member function to obtain the CXTPCalendarViewDay object by the day's index.
virtual CXTPCalendarViewDay * | _GetViewDay (const COleDateTime &dtDay) const
Call this member function to obtain the CXTPCalendarViewDay object by the day's index.
virtual BOOL | HitTest (CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const
This member function is used to determines which view item, if any, is at a specified position index, and returns additional information in the XTP_CALENDAR_HITTESTINFO argument.
virtual BOOL | HitTestEx (CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const
This member function is used to determine which view item, if any, is at a specified position index, and returns additional info in an XTP_CALENDAR_HITTESTINFO object.
virtual XTPCalendarDraggingMode | GetDraggingMode () const
Call this member function to determine the current dragging mode.
virtual CXTPCalendarPaintManager * | GetPaintManager () const
Call this member function to obtain the PaintManager object.
virtual CXTPCalendarTheme * | GetTheme () const
This member function obtains a pointer to the associated theme object.
CXTPCalendarControl * | GetCalendarControl () const
Call this member function to obtain a pointer to the Calendar Control object.
CXTPCalendarOptions * | GetCalendarOptions () const
Call this member function to get direct access to calendar options data.
virtual CXTPCalendarResources * | GetResources () const
Call this member function to obtain a pointer to the associated Calendar Resources collection object.
virtual void | SetResources (CXTPCalendarResources *pResources)
This member function sets the new Resources collection for the view.
virtual void | UnselectAllEvents ()
Call this member function to un-select all of the events of the current view.
virtual void | SelectEvent (CXTPCalendarEvent *pEvent, BOOL bSelect=TRUE)
This member function is used to select or un-select the provided event.
void | SelectViewEvent (CXTPCalendarViewEvent *pViewEvent, BOOL bSelect=TRUE)
This member function is used to select or un-select the provided event.
virtual void | SelectDay (CXTPCalendarViewDay *pDay, int nGroupIndex=0)
This member function is used to select or un-select the provided day, including all of the day's events.
virtual CXTPCalendarViewEvents * | GetSelectedViewEvents () const
Call this member function to obtain a pointer to a selected event's views.
virtual CXTPCalendarViewEventsPtr | GetSelectedEvents () const
Call this member function to obtain a pointer to a selected event's views collection.
CXTPCalendarViewEvent * | GetLastSelectedViewEvent () const
This member function is used to obtain the last selected event view.
virtual BOOL | HasSelectedViewEvent () const
Call this member function to determine if any view event is selected.
BOOL | IsSingleEventSelected () const
This member function is used to determine if just one event is selected.
int | FindLastSelectedDay () const
This member function is used to obtain the last selected day index.
COleDateTime | GetLastSelectedDate () const
This member function is used to obtain the last selected day date.
virtual BOOL | GetSelection (COleDateTime *pBegin=NULL, COleDateTime *pEnd=NULL, BOOL *pbAllDayEvent=NULL, int *pnGroupIndex=NULL, COleDateTimeSpan *pspSelectionResolution=NULL) const
This member function is used to obtain the view's selection.
void | SetSelection (const COleDateTime &dtBegin, const COleDateTime &dtEnd, BOOL bAllDayEvent=FALSE, int nGroupIndex=0)
This member function sets the new selection for the view.
void | ResetSelection ()
This member function resets the current selection - set it empty.
BOOL | SelectionContains (COleDateTime date, int nGroupIndex=-1, BOOL *pbAllDaySelection=NULL)
This member function is used to determine if a date time value is contained inside the selection.
virtual void | SelectDay (COleDateTime dtSelDay, int nGroupIndex=0)
This member function is used to select or un-select the day identified by the provided date.
virtual int | GetRowHeight () const
Call this member function to determine the row height required to display the event.
virtual CXTPCalendarEventsPtr | RetrieveDayEvents (CXTPCalendarResource *pRC, COleDateTime dtDay)
Call this member function to get the collection of the day's events.
virtual BOOL | IsEditingSubject () const
Call this member function to determine if the subject is in an editable mode.
virtual CRect | GetSubjectEditorRect () const
Call this member function to obtain the bounding rectangle of the subject editor.
virtual CRect | GetTooltipRect (const CPoint &ptHit, const XTP_CALENDAR_HITTESTINFO &hitInfo) const
Call this member function to obtain the bounding rectangle of the tooltip space (currently this is only "click to add new appointment").
virtual void | ShowToolTip (BOOL bShow=TRUE)
This member function is used to show/hide a ToolTip rectangle.
virtual UINT | GetShowToolTipTimeOut () const
This member function is used to obtain the timeout value for displaying a tooltip.
virtual void | OnUpdateEditingSubject (CString strNewSubject)
Call this member function to set the new subject text for the editing event.
virtual BOOL | CanUndo () const
Call this member function to determine if you can perform an undo operation for the subject editor.
virtual BOOL | CanRedo () const
Call this member function to determine if a redo operation is possible for the subject editor.
virtual BOOL | Undo ()
This member function is used to perform an Undo operation.
virtual BOOL | Redo ()
This member function is used to perform a Redo operation.
virtual void | EmptyUndoBuffer ()
This member function is used to erase the undo buffer.
virtual CString | FormatEventTime (COleDateTime dtTime) const
This member function is used to format the time using the provided format.
void | SetCustomTimeFormat (const CString &strFormat)
This member function is used to set custom time format for view.
void | ResetCustomTimeFormat ()
Reset custom time format to default.
virtual CString | GetDayHeaderFormat () const
Call this member function to determine the current format string.
virtual void | SetDayHeaderFormat (LPCTSTR sFmt)
Call this member function to set the day header format.
virtual BOOL | CanCut () const
Call this member function to determine if it is possible to perform a Cut operation.
virtual BOOL | CanCopy () const
Call this member function to determine if it is possible to perform a Copy operation.
virtual BOOL | CanPaste () const
Call this member function to determine if it is possible to perform a Paste operation.
virtual BOOL | Cut ()
This member function is used to perform a Cut operation.
virtual BOOL | Copy ()
This member function is used to perform a Copy operation.
virtual BOOL | Paste ()
This member function is used to perform a Paste operation.
virtual CXTPCalendarEvent * | GetDraggingEventOrig () const
This member function is used to obtain the event object before the start of the event editing (dragging).
virtual CXTPCalendarEvent * | GetDraggingEventNew () const
This member function is used to obtain the event object that is currently being edited.
virtual BOOL | SetDraggingEvent (CXTPCalendarEvent *pEventOrig)
This member function is used to prepare the event to event editing (dragging) operation.
virtual BOOL | CommitDraggingEvent ()
This member function is used to commit the event editing (dragging) operation.
virtual void | CancelDraggingEvent ()
This member function is used to cancel the event editing (dragging) operation.
virtual void | OnStartDragging (CPoint point, XTP_CALENDAR_HITTESTINFO *pHitTest)
This member function is used to start the event editing (dragging).
virtual BOOL | OnDragging (CPoint point, XTP_CALENDAR_HITTESTINFO *pHitTest)
This member function is used to perform the event editing (dragging) operation step.
virtual BOOL | OnEndDragging (CPoint point, XTP_CALENDAR_HITTESTINFO *pHitInfo)
This member function is used to finish the event editing (dragging) operation.
virtual void | StartEditSubject (CXTPCalendarViewEvent *pViewEvent)
This member function is used to start the event subject editing.
virtual void | EndEditSubject (XTPCalendarEndEditSubjectAction eAction, BOOL bUpdateControl=TRUE)
This member function is used to finish the event subject editing.
virtual UINT | GetStartEditSubjectTimeOut () const
This member function is used to obtain the time value after a mouse click event in the subject editing window.
virtual void | StartEditNewEventInplace (LPCTSTR pcszInitialSubject)
This member function is used to create a new event and start subject editing.
virtual CXTPCalendarViewEvent * | FindViewEvent (CXTPCalendarEvent *pEvent, COleDateTime dtDay) const
This member function is used to obtain the event view object for the specified event and day.
virtual CXTPCalendarViewEvent * | FindEventToEditByTAB (COleDateTime dtMinStart, BOOL bReverse, CXTPCalendarEvent *pAfterEvent=NULL)
This member function is used to obtain the next event view object used for editing events by pressing the TAB key.
virtual COleDateTime | GetNextTimeEditByTAB () const
This member function is used to obtain the next date and time to start the find event view for editing events using the TAB key.
virtual void | UpdateNextTimeEditByTAB (COleDateTime dtNext, BOOL bReverse, BOOL bReset=FALSE)
This member function is used to set the next date and time to start the find event view for editing events using the TAB key.
virtual void | ProcessDaySelection (XTP_CALENDAR_HITTESTINFO *pInfo, UINT nFlags)
This member function is used to process the days selection that are selected with the mouse.
virtual void | SelectDays (COleDateTime dtNewSel)
This member function is used to change the days selection depending on the previous state of the selection.
virtual void | ProcessEventSelection (XTP_CALENDAR_HITTESTINFO *pInfo, UINT nFlags)
This member function is used to process events that are selected with the mouse.
virtual void | EnableVScroll (BOOL bEnable=TRUE)
This member function(s) is used to disable or enable vertical or horizontal scrolling of the view (by date or time).
virtual void | EnableHScroll (BOOL bEnable=TRUE)
This member function(s) is used to disable or enable vertical or horizontal scrolling of the view (by date or time).
virtual BOOL | IsHScrollEnabled () const
This member function(s) is used to obtain the status of the vertical or horizontal scrolling features of the view (by date or time).
virtual BOOL | IsVScrollEnabled () const
This member function(s) is used to obtain the status of the vertical or horizontal scrolling features of the view (by date or time).
virtual void | SetDayHeaderFormatLong (LPCTSTR pcszCustomFormat)
This member function(s) is used to set the date format string for the day view.
virtual void | SetDayHeaderFormatMiddle (LPCTSTR pcszCustomFormat)
This member function(s) is used to set the date format string for the day view.
virtual void | SetDayHeaderFormatShort (LPCTSTR pcszCustomFormat)
This member function(s) is used to set the date format string for the day view.
virtual void | SetDayHeaderFormatShortest (LPCTSTR pcszCustomFormat)
This member function(s) is used to set the date format string for the day view.
virtual BOOL | IsTodayVisible () const
Call this member function to determine if Today is visible.
virtual CString | GetItemTextEventTimeMax () const
This member function is called by the calendar framework to retrieve an event time string of maximum length (to reserve space).
virtual void | CalculateHeaderFormat (CDC *pDC, int nWidth, CFont *pTextFont)
This member function creates the day header format string.
- Public Member Functions inherited from CXTPCalendarWMHandler
CXTPCalendarWMHandler ()
Default object constructor.
virtual void | OnKeyUp (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process key-up keyboard events.
virtual BOOL | OnWndMsg (UINT message, WPARAM wParam, LPARAM lParam, LRESULT *pResult)
This method is called by framework after default message processing.
virtual void | OnPostAdjustLayout ()
This member function is used to perform additional adjustments in some kinds of views.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

virtual UINT | SetTimer (UINT uTimeOut_ms)
This member function is used to create a timer event.
virtual void | KillTimer (UINT uTimerID)
This member function is used to destroy a timer event.
virtual BOOL | OnTimer (UINT_PTR uTimerID)
The framework calls this member function after each interval specified in the SetTimer member function.
virtual void | OnBeforeDestroy ()
This member function is called by the framework before destroying the view.
virtual void | OnActivateView (BOOL bActivate, CXTPCalendarView *pActivateView, CXTPCalendarView *pInactiveView)
This member function is called by the framework view when it is activated or deactivated.
virtual void | SendNotification (XTP_NOTIFY_CODE EventCode, WPARAM wParam=0, LPARAM lParam=0)
This member function is used to send a notification from the parent Calendar control.
virtual void | _CalculateEventTimeFormat ()
This member function is used to create the time format string.
virtual CString | _GetMaxWidthFormat (CDC *pDC, CString strFormat, BOOL bMonth) const
This function is used to calculate the max width of the date used in the specified format string.
virtual int | _GetMaxWidth (CDC *pDC, CString strFormat) const
This member function is used to calculate, in pixels, the max date width for the specified format string.
virtual void | _RemoveYearPart (CString &strFormat)
This member function is used to remove the year part from the specified format string.
virtual void | _ReadDefaultHeaderFormats ()
This member function is used to build day header date format default strings.
virtual CString | _GetDayHeaderFormat (int nLevel) const
This member function gets a custom or default day header date format string.
virtual BOOL | _CanSubjectEditor (UINT idEditCmd) const
This member function is used to determine if the specified editing operation command is possible for the event subject editor window.
virtual CWnd * | _GetSubjectEditorWnd () const
This member function is used to obtain a pointer to the event subject editor window.
virtual COleDataSource * | _CopySelectedEvents (DWORD dwCopyFlags=0)
This member function is used to copy selected events and CXTPCalendarEvent objects, to a COleDataSource object.
virtual CXTPCalendarEventsPtr | _ReadEventsFromClipboard (COleDataObject *pData, DWORD *pdwCopyFlags=NULL)
This member function is used to read events and CXTPCalendarEvent objects, from a COleDataSource object.
virtual COleDateTimeSpan | GetEventDurationMin () const
This member function is used to obtain the minimum event duration visible in the current view.
virtual BOOL | _Undo (CXTPCalendarEvent *pEvent=NULL)
This member function is used to perform an undo/redo operation for the specified event.
virtual XTPEnumCalendarUpdateResult | OnEventChanged_InDataProvider (XTP_NOTIFY_CODE nfCode, CXTPCalendarEvent *pEvent)
This member function handles the changing of an event in the associated data provider.
BOOL | _IsDragModeCopyMove (int eDragMode) const
This method is used to determine Copy or Move dragging mode.
BOOL | IsEditOperationDisabledNotify (XTPCalendarEditOperation eOperation, CXTPCalendarViewEvent *pEventView) const
This method is used to determine if specified editing operation is disabled.
BOOL | OnBeforeEditOperationNotify (XTPCalendarEditOperation eOperation, CXTPCalendarViewEvent *pEventView)
This method is used to customize or disable specified editing operation.
BOOL | OnBeforeEditOperationNotify (XTPCalendarEditOperation eOperation, CXTPCalendarViewEvents *pEventViews)
This method is used to customize or disable specified editing operation.
BOOL | OnBeforePasteNotify (CXTPCalendarEvent *pEvent, BOOL bPasteWillChangeExistingEvent)
This method is used to customize or disable paste editing operation.
BOOL | OnInPlaceCreateEvent (LPCTSTR pcszInitialSubject)
This method is used to customize or disable xtpCalendarEO_InPlaceCreateEvent editing operation.

Protected Attributes

CSelectionChanged_ContextData m_cntSelChanged
Counter on selection changes,.
int | m_eUndoMode
Undo mode, see XTPCalendarUndoMode.
BOOL | m_bResetUndoBuffer
Clean undo buffer before add next undo action.
CUndoBuffer * | m_pPrevUndoBuffer
Undo buffer data after last undo buffer clean.
CUndoBuffer * | m_pUndoBuffer
Undo buffer object.
XTP_VIEW_LAYOUT | m_Layout
Layout data.
SEventTimeFormatInfo | m_EventTimeFormat
Information used to format events times.
CString | m_strHeaderFormat
Day header active date format string.
CString | m_strDayHeaderFormatLong
Day header Long date format custom string.
CString | m_strDayHeaderFormatMiddle
Day header Middle date format custom string.
CString | m_strDayHeaderFormatShort
Day header Short date format custom string.
CString | m_strDayHeaderFormatShortest
Day header Shortest date format custom string.
CString | m_strDayHeaderFormatDefaultLong
Day header Long date format default string.
CString | m_strDayHeaderFormatDefaultMiddle
Day header Middle date format default string.
CString | m_strDayHeaderFormatDefaultShort
Day header Short date format default string.
CString | m_strDayHeaderFormatDefaultShortest
Day header Shortest date format default string.
CRect | m_rcView
Client rect.
CRect | m_rcTooltip
Last shown tooltip rect (while GetTooltipRect returns calculated currently required tooltip rect)
CXTPCalendarEventPtr | m_ptrDraggingEventOrig
Event object before start event editing.
CXTPCalendarEventPtr | m_ptrDraggingEventNew
Editing event object.
COleDateTimeSpan | m_spDraggingStartOffset
Start dragging operation offset from the beginning of the event.
CPoint | m_ptStartDragging
Request to start dragging operation from this point.
XTPCalendarDraggingMode | m_eDraggingMode
Editing event mode.
BOOL | m_bStartedClickInside
Is OnLButtonDown was inside view rect.
CXTPCalendarViewEventPtr | m_ptrEditingViewEvent
Currently editing subject event view or event view requested to edit subject by timeout.
CXTPCalendarViewEvent * | m_pLastEvent
Last selected event.
UINT | m_nTimerID_StartEditSubject
Timer ID of edit event subject request.
UINT | m_nTimerID_ShowToolTip
Timer ID of start show tooltip request.
CXTPCalendarControl * | m_pControl
Pointer to the owner control object.
CXTPCalendarViewEvents * | m_pSelectedEvents
Selected Events;.
XTP_CALENDAR_HITTESTINFO m_LastHitInfo
Last HitInfo data.
UINT | m_nKeyStateTimerID
Timer ID to check Keys state (like Control).
XTP_CALENDAR_VIEWSELECTION | m_selectedBlock
Current selection.
BOOL | m_bScrollV_Disabled
Is vertical scrolling disabled for a view.
BOOL | m_bScrollH_Disabled
Is horizontal scrolling disabled for a view.
CXTPCalendarResources * | m_pResources
Resources array.
CXTPCalendarPtrCollectionT< CXTPCalendarViewDay > | m_arDays
Stores the view day collection.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

This class represents the view portion of the Calendar control.

It represents a specific view of the Control's associated events data and provides basic functionality on the data using user input through the keyboard and mouse.

 The following predefined view implementations are available
 for the Calendar control:

 - Day and work week views : using CXTPCalendarDayView class.
 - Week view               : using CXTPCalendarWeekView class.
 - Month view              : using CXTPCalendarMonthView class.

 Furthermore, any type of user-defined view can also be implemented as
 a descendant of the CXTPCalendarView class.

 A typical Calendar View model consists of a collection of
 corresponding ViewDay's, which realizes the contents on a square
 of one day. ViewDay in its turn contains a collection of ViewEvent's
 for the particular day, each of them represents a view of an
 CXTPCalendarEvent object.
See also
CXTPCalendarDayView
CXTPCalendarWeekView
CXTPCalendarMonthView
CXTPCalendarViewDay
CXTPCalendarViewEvent

Constructor & Destructor Documentation

◆ CXTPCalendarView()

CXTPCalendarView ( CXTPCalendarControl * pCalendarControl )

Default object constructor.

Parameters
pCalendarControl - A Pointer to a CXTPCalendarControl object.
See also
~CXTPCalendarEvent()

◆ ~CXTPCalendarView()

virtual ~CXTPCalendarView ( )
virtual

Default class destructor.

Handles member items deallocation.

Member Function Documentation

◆ _CalculateEventTimeFormat()

virtual void _CalculateEventTimeFormat ( )
protectedvirtual

This member function is used to create the time format string.

Call this member function to create the time format string based on the current locale.

◆ _CanSubjectEditor()

virtual BOOL _CanSubjectEditor ( UINT idEditCmd ) const
protectedvirtual

This member function is used to determine if the specified editing operation command is possible for the event subject editor window.

Parameters
idEditCmd A UINT that contains the editing operation command ID: ID_EDIT_UNDO, ID_EDIT_CUT, ID_EDIT_COPY, or ID_EDIT_PASTE.

This function works correctly even when there is no subject editing mode.

Returns
A BOOL. TRUE - if the subject editing mode and specified editing operation are possible. FALSE otherwise.

◆ _CopySelectedEvents()

virtual COleDataSource * _CopySelectedEvents ( DWORD dwCopyFlags = 0 )
protectedvirtual

This member function is used to copy selected events and CXTPCalendarEvent objects, to a COleDataSource object.

Parameters
dwCopyFlags A DWORD that contains a set of flags from the enum XTPCalendarClipboardCopyFlags or user-defined values.

COleDataSource->SetClipboard method must be called to place data into the clipboard. Keep in mind - SetClipboard calls InternalRelease.

Returns
If there are selected events, then the function returns a pointer to a new COleDataSource object. If there are no selected events, then the function returns NULL.
See also
_ReadEventsFromClipboard
XTPCalendarClipboardCopyFlags
XTPCALENDARCTRL_CF_EVENT
COleDataSource

◆ _GetDayHeaderFormat()

virtual CString _GetDayHeaderFormat ( int nLevel ) const
protectedvirtual

This member function gets a custom or default day header date format string.

Parameters
nLevel Format width level: 0 - Long, 1 - Middle, 2 - Short, 3 - Shortest.

Returns m_strDayHeaderFormatXXX member value if is not empty, otherwise m_strDayHeaderFormatDefaultXXX member value is returned.

Returns
Active header date format string for the specified width level.
See also
m_strDayHeaderFormatDefaultLong
m_strDayHeaderFormatDefaultMiddle
m_strDayHeaderFormatDefaultShort
m_strDayHeaderFormatDefaultShortest
m_strDayHeaderFormatLong
m_strDayHeaderFormatMiddle
m_strDayHeaderFormatShort
m_strDayHeaderFormatShortest

◆ _GetMaxWidth()

virtual int _GetMaxWidth | ( | CDC * | pDC,
 |  | CString | strFormat ) const
 protectedvirtual

This member function is used to calculate, in pixels, the max date width for the specified format string.

Parameters
pDC | A pointer to a valid device context.
strFormat | A CString that contains the date format string.

Use this member function to calculate the maximum width of the date string.

Returns
An int that contains the maximum date width, in pixels.

◆ _GetMaxWidthFormat()

virtual CString _GetMaxWidthFormat | ( | CDC * | pDC,
 |  | CString | strFormat,
 |  | BOOL | bMonth ) const
 protectedvirtual

This function is used to calculate the max width of the date used in the specified format string.

Parameters
pDC | Pointer to a valid device context.
strFormat | A CString that contains the date format string.
bMonth | A BOOL. If TRUE, then calculate the max width for all the months in a year, otherwise calculate the max width for all week days.

Use this member function to calculate the header format width.

Returns
A CString containing the name of the month or the name of the day of the week that has the maximum width.

◆ _GetSubjectEditorWnd()

virtual CWnd * _GetSubjectEditorWnd ( ) const
protectedvirtual

This member function is used to obtain a pointer to the event subject editor window.

Works correctly even when not using a subject editing mode.

Returns
Pointer to the CWnd or NULL.

◆ _GetViewDay()

virtual CXTPCalendarViewDay * _GetViewDay ( const COleDateTime & dtDay ) const
virtual

Call this member function to obtain the CXTPCalendarViewDay object by the day's index.

Parameters
dtDay A day date to find.

Index numbers start with 0 and cannot be negative. This is a pure virtual function. This function must be defined in the derived class.

Returns
A pointer to a CXTPCalendarViewDay object.
See also
GetViewDayCount()

◆ _IsDragModeCopyMove()

AFX_INLINE BOOL _IsDragModeCopyMove ( int eDragMode ) const
protected

This method is used to determine Copy or Move dragging mode.

Parameters
eDragMode A value from enum XTPCalendarDraggingMode.
Returns
TRUE if eDragMode == xtpCalendaDragModeCopy or eDragMode == xtpCalendaDragModeMove.

◆ _ReadDefaultHeaderFormats()

virtual void _ReadDefaultHeaderFormats ( )
protectedvirtual

This member function is used to build day header date format default strings.

This member function read locale settings and fill m_strDayHeaderFormatDefaultXXX members.

See also
CalculateHeaderFormat()
m_strDayHeaderFormatDefaultLong
m_strDayHeaderFormatDefaultMiddle
m_strDayHeaderFormatDefaultShort
m_strDayHeaderFormatDefaultShortest

◆ _ReadEventsFromClipboard()

virtual CXTPCalendarEventsPtr _ReadEventsFromClipboard | ( | COleDataObject * | pData,
 |  | DWORD * | pdwCopyFlags = NULL )
 protectedvirtual

This member function is used to read events and CXTPCalendarEvent objects, from a COleDataSource object.

Parameters
pData | A COleDataObject pointer to the data object.
pdwCopyFlags | A pointer to a DWORD that contains the CopyFlags. These flags are set in the _CopySelectedEvents call. The flag values are from the XTPCalendarClipboardCopyFlags enum or are user-defined values.

COleDataSource->AttachClipboard method must be called to retrieve data from the clipboard.

Returns
A pointer to a CXTPCalendarEvents object. NULL - If there are no events in the clipboard. Otherwise, a pointer to a new CXTPCalendarEvents objects collection.
See also
_CopySelectedEvents
XTPCalendarClipboardCopyFlags
XTPCALENDARCTRL_CF_EVENT
COleDataSource

◆ _RemoveYearPart()

virtual void _RemoveYearPart ( CString & strFormat )
protectedvirtual

This member function is used to remove the year part from the specified format string.

Parameters
strFormat [IN/OUT] A CString object that contains the date format string reference.

This member function is used to calculate the header format.

◆ _Undo()

virtual BOOL _Undo ( CXTPCalendarEvent * pEvent = NULL )
protectedvirtual

This member function is used to perform an undo/redo operation for the specified event.

Parameters
pEvent A pointer to a CXTPCalendarEvent object that contains the undo/redo action.
Returns
A BOOL. TRUE if the undo operation is successful. FALSE otherwise.
See also
Undo
Redo
m_UndoBuffer
m_eUndoMode
XTPCalendarUndoMode

◆ AddToDiscreteSelection()

BOOL AddToDiscreteSelection ( UINT id )

This member function adds an event to the selection by using its event ordinal number.

Parameters
id event ordinal number.
Returns
TRUE if successful, otherwise FALSE.

◆ AdjustLayout()

virtual void AdjustLayout | ( | CDC * | pDC,
 |  | const CRect & | rcView,
 |  | BOOL | bCallPostAdjustLayout = TRUE )
 virtual

This member function is used to adjust the view's layout depending on the window client size and calls AdjustLayout() for all sub-items.

Parameters
pDC | Pointer to a valid device context.
rcView | A CRect that contains the coordinates for drawing the view.
bCallPostAdjustLayout | A BOOL. This is a flag that is used to call for additional adjustments. If TRUE, then additional adjustments are performed for multi-day events. If FALSE, then no additional adjustments are made.

Call Populate() prior adjusting layout. AdjustLayout2 is called by calendar control instead of AdjustLayout when theme is set.

Reimplemented in CXTPCalendarDayView, CXTPCalendarMonthView, CXTPCalendarTimeLineView, and CXTPCalendarWeekView.

◆ AdjustLayout2()

virtual void AdjustLayout2 | ( | CDC * | pDC,
 |  | const CRect & | rcView,
 |  | BOOL | bCallPostAdjustLayout = TRUE )
 virtual

This member function is used to adjust the view's layout depending on the window client size and calls AdjustLayout() for all sub-items.

Parameters
pDC | Pointer to a valid device context.
rcView | A CRect that contains the coordinates for drawing the view.
bCallPostAdjustLayout | A BOOL. This is a flag that is used to call for additional adjustments. If TRUE, then additional adjustments are performed for multi-day events. If FALSE, then no additional adjustments are made.

Call Populate() prior adjusting layout. AdjustLayout2 is called by calendar control instead of AdjustLayout when theme is set.

Reimplemented in CXTPCalendarDayView, CXTPCalendarMonthView, and CXTPCalendarWeekView.

◆ CalculateHeaderFormat()

virtual void CalculateHeaderFormat | ( | CDC * | pDC,
 |  | int | nWidth,
 |  | CFont * | pTextFont )
 virtual

This member function creates the day header format string.

Parameters
pDC | Pointer to a valid device context.
nWidth | An int that contains the day header width in pixels.
pTextFont | A pointer to a CFont object that is used to calculate the text dimensions.

Call this member function to create a day header format string based on the current locale.

◆ CanCopy()

virtual BOOL CanCopy ( ) const
virtual

Call this member function to determine if it is possible to perform a Copy operation.

This member function is used to determine the possibility of performing a Copy operation in the subject editor.

Returns
A BOOL. TRUE if the copy operation is possible. FALSE otherwise.

◆ CanCut()

virtual BOOL CanCut ( ) const
virtual

Call this member function to determine if it is possible to perform a Cut operation.

This member function is used to determine the possibility of performing a Cut operation in the subject editor.

Returns
A BOOL. TRUE if the cut operation is possible. FALSE otherwise.

◆ CanPaste()

virtual BOOL CanPaste ( ) const
virtual

Call this member function to determine if it is possible to perform a Paste operation.

This member function is used to determine the possibility of performing a Paste operation in the subject editor.

Returns
A BOOL. TRUE if the paste operation is possible. FALSE otherwise.

◆ CanRedo()

virtual BOOL CanRedo ( ) const
virtual

Call this member function to determine if a redo operation is possible for the subject editor.

Returns
A BOOL. TRUE if it is possible to perform a redo operation on the subject-editor. FALSE otherwise.

◆ CanUndo()

virtual BOOL CanUndo ( ) const
virtual

Call this member function to determine if you can perform an undo operation for the subject editor.

Returns
A BOOL. TRUE if there is the possibility to perform an undo operation. FALSE otherwise.

◆ CommitDraggingEvent()

virtual BOOL CommitDraggingEvent ( )
virtual

This member function is used to commit the event editing (dragging) operation.

Returns
A BOOL. TRUE if the event editing is successful. FALSE otherwise.

◆ Copy()

virtual BOOL Copy ( )
virtual

This member function is used to perform a Copy operation.

Call this member function to perform a Copy operation in the subject editor's window.

Returns
A BOOL. TRUE if the copy operation is successful. FALSE otherwise.

◆ Cut()

virtual BOOL Cut ( )
virtual

This member function is used to perform a Cut operation.

Call this member function to perform a Cut operation in the subject editor's window.

Returns
A BOOL. TRUE if the cut operation is successful. FALSE otherwise.

◆ Draw()

virtual void Draw ( CDC * pDC )
inlinevirtual

This member function is used to draw the view content using the specified device context.

Parameters
pDC A pointer to a valid device context.

Call AdjustLayout() before calling Draw(). Draw2 is called from OnDraw instead of Draw when theme is set.

See also
OnDraw
AdjustLayout

Reimplemented in CXTPCalendarDayView, CXTPCalendarMonthView, CXTPCalendarTimeLineView, and CXTPCalendarWeekView.

◆ Draw2()

virtual void Draw2 ( CDC * pDC )
inlinevirtual

This member function is used to draw the view content using the specified device context.

Parameters
pDC A pointer to a valid device context.

Call AdjustLayout() before calling Draw(). Draw2 is called from OnDraw instead of Draw when theme is set.

See also
OnDraw
AdjustLayout

Reimplemented in CXTPCalendarDayView, CXTPCalendarMonthView, CXTPCalendarTimeLineView, and CXTPCalendarWeekView.

◆ EnableHScroll()

AFX_INLINE void EnableHScroll ( BOOL bEnable = TRUE )
virtual

This member function(s) is used to disable or enable vertical or horizontal scrolling of the view (by date or time).

Parameters
bEnable Set TRUE to enable scrolling, FALSE to disable.

Vertical and horizontal scrolling are enabled by default.

◆ EnableVScroll()

AFX_INLINE void EnableVScroll ( BOOL bEnable = TRUE )
virtual

This member function(s) is used to disable or enable vertical or horizontal scrolling of the view (by date or time).

Parameters
bEnable Set TRUE to enable scrolling, FALSE to disable.

Vertical and horizontal scrolling are enabled by default.

◆ EndEditSubject()

virtual void EndEditSubject | ( | XTPCalendarEndEditSubjectAction | eAction,
 |  | BOOL | bUpdateControl = TRUE )
 virtual

This member function is used to finish the event subject editing.

Parameters
eAction | An XTPCalendarEndEditSubjectAction object that contains the value to commit or cancel the operation. See enum XTPCalendarEndEditSubjectAction.
bUpdateControl | A BOOL. If TRUE, then redraw the control immediately, otherwise perform only the specified action without redrawing.

◆ FindEventToEditByTAB()

virtual CXTPCalendarViewEvent * FindEventToEditByTAB | ( | COleDateTime | dtMinStart,
 |  | BOOL | bReverse,
 |  | CXTPCalendarEvent * | pAfterEvent = NULL )
 virtual

This member function is used to obtain the next event view object used for editing events by pressing the TAB key.

Parameters
dtMinStart | A COleDateTime object that contains the first date and time to start the search.
bReverse | If TRUE the reverse order is used, otherwise normal is used.
pAfterEvent | A CXTPCalendarEvent object that contains the last event object to search for.
Returns
A CXTPCalendarViewEvent object that contains the view object or NULL.
See also
GetNextTimeEditByTAB
UpdateNextTimeEditByTAB

Reimplemented in CXTPCalendarDayView.

◆ FindLastSelectedDay()

int FindLastSelectedDay ( ) const

This member function is used to obtain the last selected day index.

Returns
Index of the last selected day or -1.
See also
GetLastSelectedDate()

◆ FindViewEvent()

virtual CXTPCalendarViewEvent * FindViewEvent | ( | CXTPCalendarEvent * | pEvent,
 |  | COleDateTime | dtDay ) const
 virtual

This member function is used to obtain the event view object for the specified event and day.

Parameters
pEvent | A CXTPCalendarEvent object that contains the value to search for.
dtDay | A COleDateTime object that contains the day that corresponds to the event object.
Returns
A CXTPCalendarViewEvent object that contains the view object or NULL.

◆ FormatEventTime()

virtual CString FormatEventTime ( COleDateTime dtTime ) const
virtual

This member function is used to format the time using the provided format.

Parameters
dtTime Date-time value to format time part.
Returns
A CString object containing the formatted time string.

◆ GetCalendarControl()

AFX_INLINE CXTPCalendarControl * GetCalendarControl ( ) const

Call this member function to obtain a pointer to the Calendar Control object.

Returns
A pointer to the CXTPCalendarControl object.
See also
CXTPCalendarControl

◆ GetCalendarOptions()

CXTPCalendarOptions * GetCalendarOptions ( ) const

Call this member function to get direct access to calendar options data.

This member function wraps the CXTPCalendarData::GetCalendarOptions() method. If you read or change returned structure members, then no additional checks are made and no notifications are sent. The preferred way is to use CXTPCalendarControl options methods like GetWorkWeekMask(), SetWorkWeekMask(), GetFirstDayOfWeek(), SetFirstDayOfWeek(), ... etc.

Returns
A pointer to the calendar options data class CXTPCalendarOptions.
See also
CXTPCalendarOptions
CXTPCalendarData::GetCalendarOptions()

◆ GetChildHandlerAt()

virtual CXTPCalendarWMHandler * GetChildHandlerAt ( int nIndex ) const
virtual

Call this method to get a handler object at the specified numeric index.

Parameters
nIndex An integer index that is greater than or equal to 0 and less than the value returned by GetChildHandlersCount.

Returns the array element at the specified index.

Returns
The pointer to the CXTPCalendarWMHandler element currently at this index.

Reimplemented from CXTPCalendarWMHandler.

◆ GetChildHandlersCount()

AFX_INLINE int GetChildHandlersCount ( ) const
virtual

This member function is used to obtain the number of CXTPCalendarWMHandler elements in the descendant handlers collection.

Call this method to retrieve the number of elements in the array. Because indexes are zero-based, the size is 1 greater than the largest index.

Returns
A count of descendant handlers.
See also
CXTPCalendarWMHandler overview

Reimplemented from CXTPCalendarWMHandler.

◆ GetDayHeaderFormat()

AFX_INLINE CString GetDayHeaderFormat ( ) const
virtual

Call this member function to determine the current format string.

Returns
A CString object that contains the format string.

◆ GetDiscreteSelectionCount()

AFX_INLINE UINT GetDiscreteSelectionCount ( ) const

This member function is used to get the number of selected events.

Returns
A UINT that contains the number of selected events.

◆ GetDiscreteSelectionValue()

COleDateTime GetDiscreteSelectionValue ( UINT id ) const

This member function gets a selected event by using its event ordinal number.

Parameters
id event ordinal number.
Returns
COleDateTime selected event.

◆ GetDraggingEventNew()

virtual CXTPCalendarEvent * GetDraggingEventNew ( ) const
virtual

This member function is used to obtain the event object that is currently being edited.

(i.e. dragging)

Returns
A pointer to a CXTPCalendarEvent object or NULL.

◆ GetDraggingEventOrig()

virtual CXTPCalendarEvent * GetDraggingEventOrig ( ) const
virtual

This member function is used to obtain the event object before the start of the event editing (dragging).

Returns
A pointer to a CXTPCalendarEvent object before the start the event editing or NULL.

◆ GetDraggingMode()

AFX_INLINE XTPCalendarDraggingMode GetDraggingMode ( ) const
virtual

Call this member function to determine the current dragging mode.

Returns
An XTPCalendarDraggingModeFlag object that contains the current dragging mode.
See also
XTPCalendarDraggingMode

◆ GetEventDurationMin()

virtual COleDateTimeSpan GetEventDurationMin ( ) const
protectedvirtual

This member function is used to obtain the minimum event duration visible in the current view.

Returns
A COleDateTimeSpan object that contains the minimum duration of the event.

Reimplemented in CXTPCalendarDayView.

◆ GetItemTextEventTimeMax()

virtual CString GetItemTextEventTimeMax ( ) const
virtual

This member function is called by the calendar framework to retrieve an event time string of maximum length (to reserve space).

Returns
A maximum time string.

◆ GetLastSelectedDate()

COleDateTime GetLastSelectedDate ( ) const

This member function is used to obtain the last selected day date.

Returns
Date of the last selected day or the middle view day date.
See also
FindLastSelectedDay()
GetSelection()
SetSelection()

◆ GetLastSelectedViewEvent()

CXTPCalendarViewEvent * GetLastSelectedViewEvent ( ) const

This member function is used to obtain the last selected event view.

Returns
A pointer to the last selected event view or NULL.
See also
CXTPCalendarViewEvent
GetSelectedViewEvents()

◆ GetNextTimeEditByTAB()

virtual COleDateTime GetNextTimeEditByTAB ( ) const
virtual

This member function is used to obtain the next date and time to start the find event view for editing events using the TAB key.

Returns
A COleDateTime object that contains the next date and time.
See also
FindEventToEditByTAB
UpdateNextTimeEditByTAB

Reimplemented in CXTPCalendarDayView.

◆ GetPaintManager()

virtual CXTPCalendarPaintManager * GetPaintManager ( ) const
virtual

Call this member function to obtain the PaintManager object.

Returns
A pointer to the CXTPCalendarPaintManager object.
See also
CXTPCalendarPaintManager
GetTheme

◆ GetResources()

virtual CXTPCalendarResources * GetResources ( ) const
virtual

Call this member function to obtain a pointer to the associated Calendar Resources collection object.

Returns
A pointer to the CXTPCalendarResources collection object.
See also
CXTPCalendarResources overview
CXTPCalendarResource overview

◆ GetRowHeight()

AFX_INLINE int GetRowHeight ( ) const
virtual

Call this member function to determine the row height required to display the event.

Returns
An int that contains the height of the row required to display a single event.

◆ GetScrollBarInfoH()

virtual BOOL GetScrollBarInfoH | ( | SCROLLINFO * | pSI,
 |  | int * | pnScrollStep = NULL ) const
 inlinevirtual

This member function is used to retrieve the information about a scroll bar state.

Parameters
pSI | A SCROLLINFO pointer that contains information about the current state of the scroll bar.
pnScrollStep | A pointer to int to receive scroll step. Can be NULL.
Returns
A BOOL. The base class definition always returns FALSE. The derived class definition should return TRUE if the function is successful. Return FALSE otherwise.

Reimplemented in CXTPCalendarDayView, and CXTPCalendarTimeLineView.

◆ GetScrollBarInfoV()

virtual BOOL GetScrollBarInfoV ( SCROLLINFO * pSI ) const
inlinevirtual

This member function is used to retrieve the information about a scroll bar state.

Parameters
pSI A SCROLLINFO pointer that contains information about the current state of the scroll bar.
Returns
A BOOL. The base class definition always returns FALSE. The derived class definition should return TRUE if the function is successful. Returns FALSE otherwise.

Reimplemented in CXTPCalendarDayView, CXTPCalendarMonthView, CXTPCalendarTimeLineView, and CXTPCalendarWeekView.

◆ GetSelectedEvents()

virtual CXTPCalendarViewEventsPtr GetSelectedEvents ( ) const
virtual

Call this member function to obtain a pointer to a selected event's views collection.

This method returns one event view instance for one event. (multi-day events have a separate view event object for each day).

Returns
A smart pointer to a CXTPCalendarEvents object that contains the selected events.
See also
GetSelectedViewEvents()
CXTPCalendarViewEvents

◆ GetSelectedViewEvents()

virtual CXTPCalendarViewEvents * GetSelectedViewEvents ( ) const
virtual

Call this member function to obtain a pointer to a selected event's views.

This method may return a few event views instances for one event. (multi-day events have a separate view event object for each day).

Returns
A pointer to a CXTPCalendarViewEvents object that contains the selected event's views.
See also
CXTPCalendarViewEvents
CXTPCalendarViewDay
SelectDay(COleDateTime dtSelDay, BOOL bSelect)
GetSelectedEvents()

◆ GetSelection()

virtual BOOL GetSelection | ( | COleDateTime * | pBegin = NULL,
 |  | COleDateTime * | pEnd = NULL,
 |  | BOOL * | pbAllDayEvent = NULL,
 |  | int * | pnGroupIndex = NULL,
 |  | COleDateTimeSpan * | pspSelectionResolution = NULL ) const
 virtual

This member function is used to obtain the view's selection.

Parameters
pBegin | A pointer to the COleDateTime object that contains the beginning of the selection.
pEnd | A pointer to the COleDateTime object that contains the ending of the selection.
pbAllDayEvent | A pointer to the BOOL variable that contains the AllDayEvent attribute of the selection (used in the day view only).
pnGroupIndex | A pointer to int to receive group index.
pspSelectionResolution | A pointer to the COleDateTimeSpan object that contains the selection unit length. (i.e. 1 day, 1 Hour, ... 5 min)

Call this member function to fill the provided COleDateTime objects with the values of the selection beginning, ending, and selection unit length.

Returns
A BOOL. TRUE if the selection is returned successfully. FALSE otherwise.

Reimplemented in CXTPCalendarDayView.

◆ GetShowToolTipTimeOut()

AFX_INLINE UINT GetShowToolTipTimeOut ( ) const
virtual

This member function is used to obtain the timeout value for displaying a tooltip.

Returns
A UINT that contains the timeout value in milliseconds.

◆ GetStartEditSubjectTimeOut()

AFX_INLINE UINT GetStartEditSubjectTimeOut ( ) const
virtual

This member function is used to obtain the time value after a mouse click event in the subject editing window.

Returns
A UINT that contains the timeout value in milliseconds before the start event subject editing.

◆ GetSubjectEditorRect()

virtual CRect GetSubjectEditorRect ( ) const
virtual

Call this member function to obtain the bounding rectangle of the subject editor.

Returns
A CRect object that contains the current coordinates of the subject editor.

◆ GetTheme()

virtual CXTPCalendarTheme * GetTheme ( ) const
virtual

This member function obtains a pointer to the associated theme object.

It calls the CXTPCalendarControl::GetTheme() method.

Returns
A CXTPCalendarTheme pointer to the associated theme object or NULL.
See also
CXTPCalendarControl::GetTheme
GetPaintManager

◆ GetTooltipRect()

virtual CRect GetTooltipRect | ( | const CPoint & | ptHit,
 |  | const XTP_CALENDAR_HITTESTINFO & | hitInfo ) const
 virtual

Call this member function to obtain the bounding rectangle of the tooltip space (currently this is only "click to add new appointment").

Tooltip rectangle is calculated basing on the current mouse position

Parameters
ptHit | CPoint& of mouse position.
hitInfo | XTP_CALENDAR_HITTESTINFO.
Returns
A CRect object with relative coordinates of the tooltip.

Reimplemented in CXTPCalendarTimeLineView.

◆ GetViewDay_()

virtual CXTPCalendarViewDay * GetViewDay_ ( int nIndex ) const
virtual

Call this member function to obtain the CXTPCalendarViewDay object by the day's index.

Parameters
nIndex An int that is used as the day view index in the view collection.

Index numbers start with 0 and cannot be negative. This is a pure virtual function. This function must be defined in the derived class.

Returns
A pointer to a CXTPCalendarViewDay object.
See also
GetViewDayCount()

Reimplemented in CXTPCalendarMonthView.

◆ GetViewDayCount()

AFX_INLINE int GetViewDayCount ( ) const
virtual

Call this member function to obtain the number of "day views" in the view collection.

This is a pure virtual function. This function must be defined in the derived class.

Returns
An int that contains the the number of "day views" in the view collection.

◆ GetViewDayDate()

virtual COleDateTime GetViewDayDate ( int nIndex ) const
pure virtual

Call this member function to obtain the date of the day view by the day's index.

Parameters
nIndex An int that contains the day view index in the view collection.

Indexed number starts from 0 and cannot be negative. This is a pure virtual function. This function must be defined in the derived class.

Returns
A COleDateTime object that contains the day view date and time.
See also
GetViewDayCount()

Implemented in CXTPCalendarDayView, CXTPCalendarMonthView, CXTPCalendarTimeLineView, and CXTPCalendarWeekView.

◆ GetViewRect()

AFX_INLINE CRect GetViewRect ( ) const

Call this member function to obtain the view's bounding rectangle.

Returns
A CRect object that contains the view's bounding rectangle coordinates.

◆ GetViewType()

virtual XTPCalendarViewType GetViewType ( ) const
pure virtual

Call this member function to obtain the view type flag.

This is a pure virtual function. This function must be defined in the derived class.

Returns
A XTPCalendarViewType view type flag.
See also
XTPCalendarViewType

Implemented in CXTPCalendarDayView, CXTPCalendarTimeLineView, CXTPCalendarViewT< _TViewDay >, CXTPCalendarViewT< CXTPCalendarDayViewDay >, CXTPCalendarViewT< CXTPCalendarMonthViewDay >, and CXTPCalendarViewT< CXTPCalendarWeekViewDay >.

◆ HasSelectedViewEvent()

virtual BOOL HasSelectedViewEvent ( ) const
virtual

Call this member function to determine if any view event is selected.

Returns
TRUE if any view event is selected, FALSE otherwise.
See also
GetSelectedViewEvents

◆ HitTest()

virtual BOOL HitTest | ( | CPoint | pt,
 |  | XTP_CALENDAR_HITTESTINFO * | pHitTest ) const
 virtual

This member function is used to determines which view item, if any, is at a specified position index, and returns additional information in the XTP_CALENDAR_HITTESTINFO argument.

Parameters
pt | A CPoint that contains the coordinates of the point to test.
pHitTest | A pointer a XTP_CALENDAR_HITTESTINFO structure.

This is a pure virtual function. This function must be defined in the derived class.

Returns
A BOOL. TRUE if the item is found. FALSE otherwise.
See also
XTP_CALENDAR_HITTESTINFO

Reimplemented in CXTPCalendarTimeLineView.

◆ HitTestEx()

virtual BOOL HitTestEx | ( | CPoint | pt,
 |  | XTP_CALENDAR_HITTESTINFO * | pHitTest ) const
 virtual

This member function is used to determine which view item, if any, is at a specified position index, and returns additional info in an XTP_CALENDAR_HITTESTINFO object.

Parameters
pt | A CPoint object that contains the coordinates of the point to test.
pHitTest | A pointer to the template parameter XTP_CALENDAR_HITTESTINFO object that contains information on the point to test.
Returns
TRUE if item found; FALSE otherwise.

Reimplemented in CXTPCalendarDayView, and CXTPCalendarTimeLineView.

◆ IsEditingSubject()

AFX_INLINE BOOL IsEditingSubject ( ) const
virtual

Call this member function to determine if the subject is in an editable mode.

Returns
A BOOL. TRUE if the subject is ready for editing. FALSE otherwise.

◆ IsEditOperationDisabledNotify()

BOOL IsEditOperationDisabledNotify | ( | XTPCalendarEditOperation | eOperation,
 |  | CXTPCalendarViewEvent * | pEventView ) const
 protected

This method is used to determine if specified editing operation is disabled.

Parameters
eOperation | A value from enum XTPCalendarEditOperation.
pEventView | A pointer to event view.
Returns
TRUE if specified editing operation is disabled, otherwise FALSE.
See also
XTP_NC_CALENDAR_IS_EVENT_EDIT_OPERATION_DISABLED
XTP_NC_CALENDAR_BEFORE_EVENT_EDIT_OPERATION
XTPCalendarEditOperation

◆ IsHScrollEnabled()

AFX_INLINE BOOL IsHScrollEnabled ( ) const
virtual

This member function(s) is used to obtain the status of the vertical or horizontal scrolling features of the view (by date or time).

Returns
TRUE if scrolling enabled, FALSE otherwise.

◆ IsInDiscreteSelection()

BOOL IsInDiscreteSelection ( UINT id ) const

This member function checks if an event is in the selection.

Parameters
id event ordinal number.
Returns
BOOL flag (TRUE if present in selection, FALSE otherwise).

◆ IsSingleEventSelected()

BOOL IsSingleEventSelected ( ) const

This member function is used to determine if just one event is selected.

Returns
TRUE - if only one event is selected, FALSE - if no events are selected or if more than one event is selected.
See also
GetSelectedViewEvents()
SelectViewEvent()
SelectEvent()

◆ IsTodayVisible()

virtual BOOL IsTodayVisible ( ) const
virtual

Call this member function to determine if Today is visible.

Returns
A BOOL. TRUE if Today is visible, FALSE otherwise.

◆ IsVScrollEnabled()

AFX_INLINE BOOL IsVScrollEnabled ( ) const
virtual

This member function(s) is used to obtain the status of the vertical or horizontal scrolling features of the view (by date or time).

Returns
TRUE if scrolling enabled, FALSE otherwise.

◆ KillTimer()

virtual void KillTimer ( UINT uTimerID )
protectedvirtual

This member function is used to destroy a timer event.

Parameters
uTimerID A UINT that is used to specify the identifier of the timer.

◆ OnActivateView()

virtual void OnActivateView | ( | BOOL | bActivate,
 |  | CXTPCalendarView * | pActivateView,
 |  | CXTPCalendarView * | pInactiveView )
 protectedvirtual

This member function is called by the framework view when it is activated or deactivated.

Parameters
bActivate | Indicates whether the view is being activated or deactivated.
pActivateView | Points to the view object that is being activated.
pInactiveView | Points to the view object that is being deactivated.

Override this member function to handle activated/deactivated events.

See also
CXTPCalendarControl::SwitchActiveView(XTPCalendarViewType eView)
CXTPCalendarControl::SetActiveView(CXTPCalendarView* pView)

Reimplemented in CXTPCalendarDayView.

◆ OnBeforeEditOperationNotify() [1/2]

BOOL OnBeforeEditOperationNotify | ( | XTPCalendarEditOperation | eOperation,
 |  | CXTPCalendarViewEvent * | pEventView )
 protected

This method is used to customize or disable specified editing operation.

Parameters
eOperation | A value from enum XTPCalendarEditOperation.
pEventView | A pointer to event view.
Returns
TRUE if specified editing operation is disabled or handled, otherwise FALSE.
See also
XTP_NC_CALENDAR_IS_EVENT_EDIT_OPERATION_DISABLED
XTP_NC_CALENDAR_BEFORE_EVENT_EDIT_OPERATION
XTPCalendarEditOperation

◆ OnBeforeEditOperationNotify() [2/2]

BOOL OnBeforeEditOperationNotify | ( | XTPCalendarEditOperation | eOperation,
 |  | CXTPCalendarViewEvents * | pEventViews )
 protected

This method is used to customize or disable specified editing operation.

Parameters
eOperation | A value from enum XTPCalendarEditOperation.
pEventViews | A pointer to event views.
Returns
TRUE if specified editing operation is disabled or handled, otherwise FALSE.
See also
XTP_NC_CALENDAR_IS_EVENT_EDIT_OPERATION_DISABLED
XTP_NC_CALENDAR_BEFORE_EVENT_EDIT_OPERATION
XTPCalendarEditOperation

◆ OnBeforePasteNotify()

BOOL OnBeforePasteNotify | ( | CXTPCalendarEvent * | pEvent,
 |  | BOOL | bPasteWillChangeExistingEvent )
 protected

This method is used to customize or disable paste editing operation.

Parameters
pEvent | A pointer to an event prepared for paste.
bPasteWillChangeExistingEvent | If this parameter is TRUE, the new event will not be added. Instead, just the existing event will be updated. Used for creating recurrence event exceptions by cut operation.
Returns
TRUE if paste editing operation disabled or handled, otherwise FALSE.
See also
XTP_NC_CALENDAR_IS_EVENT_EDIT_OPERATION_DISABLED
XTP_NC_CALENDAR_BEFORE_EVENT_EDIT_OPERATION
XTPCalendarEditOperation

◆ OnChar()

virtual void OnChar | ( | UINT | nChar,
 |  | UINT | nRepCnt,
 |  | UINT | nFlags )
 virtual

This member function is used to process keyboard events.

Parameters
nChar | A UINT that contains the character code value of the key.
nRepCnt | A UINT that is used to count the number of times the keystroke is repeated as a result of the user holding down the key.
nFlags | A UINT that contains the Scan code, key-transition code, previous key state, and the context code.

This method is called by the CalendarControl when a keystroke translates to a nonsystem character.

Reimplemented from CXTPCalendarWMHandler.

◆ OnDragging()

virtual BOOL OnDragging | ( | CPoint | point,
 |  | XTP_CALENDAR_HITTESTINFO * | pHitTest )
 virtual

This member function is used to perform the event editing (dragging) operation step.

Parameters
point | A CPoint that contains the mouse position coordinates.
pHitTest | A pointer to an XTP_CALENDAR_HITTESTINFO struct that contains the HitTest results from the specified point.
Returns
TRUE if the operation is successful, FALSE otherwise.

Reimplemented in CXTPCalendarDayView.

◆ OnDraw()

virtual void OnDraw ( CDC * pDC )
virtual

This member function performs all of the drawing logic of the calendar view.

Parameters
pDC Pointer to a valid device context.

Reimplemented in CXTPCalendarDayView.

◆ OnEndDragging()

virtual BOOL OnEndDragging | ( | CPoint | point,
 |  | XTP_CALENDAR_HITTESTINFO * | pHitInfo )
 virtual

This member function is used to finish the event editing (dragging) operation.

Parameters
point | A CPoint that contains the mouse position coordinates.
pHitInfo | A pointer to an XTP_CALENDAR_HITTESTINFO struct that contains the HitTest results from the specified point.
Returns
TRUE if the operation is successful, FALSE otherwise.

Reimplemented in CXTPCalendarDayView.

◆ OnEventChanged_InDataProvider()

virtual XTPEnumCalendarUpdateResult OnEventChanged_InDataProvider | ( | XTP_NOTIFY_CODE | nfCode,
 |  | CXTPCalendarEvent * | pEvent )
 protectedvirtual

This member function handles the changing of an event in the associated data provider.

It performs all the necessary validation of this action and returns an update result.

Parameters
nfCode | Notification code of the data provider update operation.
pEvent | A pointer to a CXTPCalendarEvent object that was changed.
Returns
A code of the update action to be performed in the view.
See also
XTP_NOTIFY_CODE overview
XTPEnumCalendarUpdateResult overview

◆ OnInPlaceCreateEvent()

BOOL OnInPlaceCreateEvent ( LPCTSTR pcszInitialSubject )
protected

This method is used to customize or disable xtpCalendarEO_InPlaceCreateEvent editing operation.

Parameters
pcszInitialSubject A pointer to the string which contains the initial subject value for the new event (generally initial char).
Returns
TRUE if In-place create event editing operation is disabled or handled, otherwise FALSE.
See also
XTP_NC_CALENDAR_IS_EVENT_EDIT_OPERATION_DISABLED
XTP_NC_CALENDAR_BEFORE_EVENT_EDIT_OPERATION
XTPCalendarEditOperation

◆ OnKeyDown()

virtual void OnKeyDown | ( | UINT | nChar,
 |  | UINT | nRepCnt,
 |  | UINT | nFlags )
 virtual

This member function is used to processes keyboard events.

Parameters
nChar | A UINT that is used to identify the virtual key code of the given key.
nRepCnt | A UINT that is used to count the number of times the keystroke is repeated as a result of the user holding down the key.
nFlags | A UINT that contains the Scan code, key-transition code, previous key state, and the context code.

This method is called by the CalendarControl when the user presses keys on the keyboard.

Reimplemented from CXTPCalendarWMHandler.

Reimplemented in CXTPCalendarDayView, CXTPCalendarMonthView, and CXTPCalendarWeekView.

◆ OnLButtonDblClk()

virtual BOOL OnLButtonDblClk | ( | UINT | nFlags,
 |  | CPoint | point )
 virtual

This member function is used to process mouse double-click events.

Parameters
nFlags | A UINT that is used to indicate whether various virtual keys are down.
point | A CPoint that specifies the x- and y- coordinates of the cursor. These coordinates are always relative to the upper-left corner of the window.
Returns
TRUE if the message is handled properly, FALSE otherwise.

This method is called by the CalendarControl when the user presses, releases, and then presses the left mouse button again within the system's double-click time limit.

Reimplemented from CXTPCalendarWMHandler.

◆ OnLButtonDown()

virtual BOOL OnLButtonDown | ( | UINT | nFlags,
 |  | CPoint | point )
 virtual

This member function is used to process left mouse button events.

Parameters
nFlags | A UINT that is used to indicates whether various virtual keys are down.
point | A CPoint that specifies the x- and y- coordinates of the cursor. These coordinates are always relative to the upper-left corner of the window.
Returns
TRUE if the message is handled properly, FALSE otherwise.

This method is called by the CalendarControl when the user presses the left mouse button.

Reimplemented from CXTPCalendarWMHandler.

Reimplemented in CXTPCalendarDayView, and CXTPCalendarMonthView.

◆ OnLButtonUp()

virtual BOOL OnLButtonUp | ( | UINT | nFlags,
 |  | CPoint | point )
 virtual

This member function is used to process left mouse button events.

Parameters
nFlags | A UINT that is used to indicate whether various virtual keys are down.
point | A CPoint that specifies the x- and y- coordinates of the cursor. These coordinates are always relative to the upper-left corner of the window.
Returns
TRUE if the message is handled properly, FALSE otherwise.

This method is called by the CalendarControl when the user releases the left mouse button.

Reimplemented from CXTPCalendarWMHandler.

Reimplemented in CXTPCalendarDayView.

◆ OnMouseMove()

virtual void OnMouseMove | ( | UINT | nFlags,
 |  | CPoint | point )
 virtual

This member function is used to process mouse movement events.

Parameters
nFlags | A UINT that is used to indicate whether various virtual keys are down.
point | A CPoint that specifies the x- and y- coordinates of the cursor. These coordinates are always relative to the upper-left corner of the window.

This method is called by the CalendarControl when the user moves the mouse cursor or stylus.

Reimplemented from CXTPCalendarWMHandler.

Reimplemented in CXTPCalendarDayView, and CXTPCalendarMonthView.

◆ OnScrollEnd()

virtual void OnScrollEnd ( int nBar )
inlinevirtual

This member function is used to force scroll to the end of the scroll range.

Parameters
nBar standard 0 - 1 values (for vertical or horizontal scrollbar).

Reimplemented in CXTPCalendarTimeLineView.

◆ OnStartDragging()

virtual void OnStartDragging | ( | CPoint | point,
 |  | XTP_CALENDAR_HITTESTINFO * | pHitTest )
 virtual

This member function is used to start the event editing (dragging).

Parameters
point | A CPoint that contains the mouse position with the coordinates to start the event editing (dragging).
pHitTest | A pointer to an XTP_CALENDAR_HITTESTINFO struct that contains the HitTest results from a specified point.

Reimplemented in CXTPCalendarDayView.

◆ OnSysKeyDown()

virtual BOOL OnSysKeyDown | ( | UINT | nChar,
 |  | UINT | nRepCnt,
 |  | UINT | nFlags )
 virtual

This member function is used to process system keyboard events.

Parameters
nChar | A UINT that specifies the virtual key code of the given key.
nRepCnt | A UINT that contains the number of times the keystroke is repeated as a result of the user holding down the key.
nFlags | A UINT that contains the scan code, key-transition code, previous key state, and the context code.
Returns
TRUE if the message is handled properly, FALSE otherwise.

This method is called by the CalendarControl when the user presses keys on the keyboard.

Reimplemented from CXTPCalendarWMHandler.

◆ OnTimer()

virtual BOOL OnTimer ( UINT_PTR uTimerID )
protectedvirtual

The framework calls this member function after each interval specified in the SetTimer member function.

Parameters
uTimerID A UINT that is used to specify the identifier of the timer.
Returns
TRUE if the message is handled properly, FALSE otherwise.

Reimplemented from CXTPCalendarWMHandler.

Reimplemented in CXTPCalendarDayView.

◆ OnUpdateEditingSubject()

virtual void OnUpdateEditingSubject ( CString strNewSubject )
virtual

Call this member function to set the new subject text for the editing event.

Parameters
strNewSubject New subject value.

◆ Paste()

virtual BOOL Paste ( )
virtual

This member function is used to perform a Paste operation.

Call this member function to perform a Paste operation in the subject editor's window.

Returns
A BOOL. TRUE if the paste operation is successful. FALSE otherwise.

◆ ProcessDaySelection()

virtual void ProcessDaySelection | ( | XTP_CALENDAR_HITTESTINFO * | pInfo,
 |  | UINT | nFlags )
 virtual

This member function is used to process the days selection that are selected with the mouse.

Parameters
pInfo | A pointer to a XTP_CALENDAR_HITTESTINFO struct that contains HitTest information about the current mouse position.
nFlags | A UINT that contains the current state of the additional mouse and keyboard buttons. Like MK_SHIFT, ...
See also
SelectDays

Reimplemented in CXTPCalendarDayView.

◆ ProcessEventSelection()

virtual void ProcessEventSelection | ( | XTP_CALENDAR_HITTESTINFO * | pInfo,
 |  | UINT | nFlags )
 virtual

This member function is used to process events that are selected with the mouse.

Parameters
pInfo | A pointer to an XTP_CALENDAR_HITTESTINFO struct that contains HitTest information about current mouse position.
nFlags | A UINT that contains the current state of the additional mouse and keyboard buttons. Like MK_SHIFT, ...

◆ Redo()

virtual BOOL Redo ( )
virtual

This member function is used to perform a Redo operation.

Returns
A BOOL. TRUE if the redo operation is successful. FALSE otherwise.

◆ RedrawControl()

virtual void RedrawControl ( )
virtual

This member function is used to perform the redrawing of the control's layout.

Call AdjystLayout() prior to redrawing the control.

◆ ResetSelection()

void ResetSelection ( )

This member function resets the current selection - set it empty.

Call this member function to programmatically clear the current selection.

◆ RetrieveDayEvents()

virtual CXTPCalendarEventsPtr RetrieveDayEvents | ( | CXTPCalendarResource * | pRC,
 |  | COleDateTime | dtDay )
 virtual

Call this member function to get the collection of the day's events.

Parameters
pRC | A pointer to calendar resource object.
dtDay | A COleDateTime object that contains the day's date.
Returns
A pointer to a CXTPCalendarEvents object that contains the collection of the day's events.
See also
CXTPCalendarEvents

◆ ScrollH()

virtual void ScrollH | ( | int | nPos,
 |  | int | nPos_raw )
 inlinevirtual

Scroll horizontally.

Parameters
nPos | An int that contains the position value.
nPos_raw | An int that contains the raw position value.

This member function is used to horizontal scroll the contents of the view.

Reimplemented in CXTPCalendarDayView, and CXTPCalendarTimeLineView.

◆ ScrollV()

virtual void ScrollV | ( | int | nPos,
 |  | int | nPos_raw )
 inlinevirtual

Scroll vertically.

Parameters
nPos | An int that contains the position value.
nPos_raw | An int that contains the raw position value.

This member function is used to vertical scroll the contents of the view.

Reimplemented in CXTPCalendarDayView, CXTPCalendarMonthView, CXTPCalendarTimeLineView, and CXTPCalendarWeekView.

◆ SelectDay() [1/2]

virtual void SelectDay | ( | COleDateTime | dtSelDay,
 |  | int | nGroupIndex = 0 )
 virtual

This member function is used to select or un-select the day identified by the provided date.

Parameters
dtSelDay | A COleDateTime object that contains a date time value.
nGroupIndex | A group index to select.
See also
CXTPCalendarViewDay
SelectDay

◆ SelectDay() [2/2]

virtual void SelectDay | ( | CXTPCalendarViewDay * | pDay,
 |  | int | nGroupIndex = 0 )
 virtual

This member function is used to select or un-select the provided day, including all of the day's events.

Parameters
pDay | A pointer to a CXTPCalendarViewDay object.
nGroupIndex | A group index to select.
See also
CXTPCalendarViewDay
SelectDay(COleDateTime dtSelDay, BOOL bSelect)

Reimplemented in CXTPCalendarDayView.

◆ SelectDays()

virtual void SelectDays ( COleDateTime dtNewSel )
virtual

This member function is used to change the days selection depending on the previous state of the selection.

Parameters
dtNewSel A COleDateTime object that contains the day date where the selection has moved.

◆ SelectEvent()

virtual void SelectEvent | ( | CXTPCalendarEvent * | pEvent,
 |  | BOOL | bSelect = TRUE )
 virtual

This member function is used to select or un-select the provided event.

Parameters
pEvent | A pointer to the CXTPCalendarEvent object.
bSelect | A BOOL. If TRUE, then select the event. If FALSE, then un-select the event.

This method doesn't redraw control's window in order to avoid blinking when executed in groups (like selecting a number of events). So far, you'll have to call Calendar.RedrawControl after that.

See also
SelectViewEvent()
CXTPCalendarEvent

◆ SelectionContains()

BOOL SelectionContains | ( | COleDateTime | date,
 |  | int | nGroupIndex = -1,
 |  | BOOL * | pbAllDaySelection = NULL )

This member function is used to determine if a date time value is contained inside the selection.

Parameters
date | A COleDateTime object that contains a date time value.
nGroupIndex | A group index or -1 for any group.
pbAllDaySelection | A pointer to BOOL to receive is selection All Day.
Returns
TRUE - If date is contained inside the selection. FALSE otherwise.

◆ SelectViewEvent()

void SelectViewEvent | ( | CXTPCalendarViewEvent * | pViewEvent,
 |  | BOOL | bSelect = TRUE )

This member function is used to select or un-select the provided event.

Parameters
pViewEvent | A pointer to the CXTPCalendarViewEvent object.
bSelect | A BOOL. If TRUE, then select the event. If FALSE, then un-select the event.

This method doesn't redraw control's window in order to avoid blinking when executed in groups (like selecting a number of events). So far, you'll have to call Calendar.RedrawControl after that.

See also
SelectEvent()
CXTPCalendarViewEvent

◆ SendNotification()

virtual void SendNotification | ( | XTP_NOTIFY_CODE | EventCode,
 |  | WPARAM | wParam = 0,
 |  | LPARAM | lParam = 0 )
 protectedvirtual

This member function is used to send a notification from the parent Calendar control.

Parameters
EventCode | An XTP_NOTIFY_CODE that contains the specific code of the event.
wParam | A DWORD that contains the first custom parameter. Depends on the event type. See specific event description for details.
lParam | A DWORD that contains the second custom parameter. Depends on the event type. See specific event description for details.

This member function is called internally from inside the class when a notification is sent to all listeners.

See also
XTP_NOTIFY_CODE

◆ SetCustomTimeFormat()

void SetCustomTimeFormat ( const CString & strFormat )

This member function is used to set custom time format for view.

Events will use this format to show their times.

Parameters
strFormat format string specification. h Hours with no leading zero for single-digit hours; 12-hour clock hh Hours with leading zero for single-digit hours; 12-hour clock H Hours with no leading zero for single-digit hours; 24-hour clock HH Hours with leading zero for single-digit hours; 24-hour clock m Minutes with no leading zero for single-digit minutes mm Minutes with leading zero for single-digit minutes s Seconds with no leading zero for single-digit seconds ss Seconds with leading zero for single-digit seconds t One character time marker string, such as A or P tt Multi-character time marker string, such as AM or PM

◆ SetDayHeaderFormat()

AFX_INLINE void SetDayHeaderFormat ( LPCTSTR sFmt )
virtual

Call this member function to set the day header format.

Parameters
sFmt A CString object that contains the format string.

◆ SetDayHeaderFormatLong()

AFX_INLINE void SetDayHeaderFormatLong ( LPCTSTR pcszCustomFormat )
virtual

This member function(s) is used to set the date format string for the day view.

Parameters
pcszCustomFormat Date format string.

Long, Middle, Short and Shortest format strings are used for different header widths. Calendar control selects the longest format which can be drawn for active day header width. By default these format strings are built using locale settings and SetDayHeaderFormatXXX methods should be used to customize default settings.

◆ SetDayHeaderFormatMiddle()

AFX_INLINE void SetDayHeaderFormatMiddle ( LPCTSTR pcszCustomFormat )
virtual

This member function(s) is used to set the date format string for the day view.

Parameters
pcszCustomFormat Date format string.

Long, Middle, Short and Shortest format strings are used for different header widths. Calendar control selects the longest format which can be drawn for active day header width. By default these format strings are built using locale settings and SetDayHeaderFormatXXX methods should be used to customize default settings.

◆ SetDayHeaderFormatShort()

AFX_INLINE void SetDayHeaderFormatShort ( LPCTSTR pcszCustomFormat )
virtual

This member function(s) is used to set the date format string for the day view.

Parameters
pcszCustomFormat Date format string.

Long, Middle, Short and Shortest format strings are used for different header widths. Calendar control selects the longest format which can be drawn for active day header width. By default these format strings are built using locale settings and SetDayHeaderFormatXXX methods should be used to customize default settings.

◆ SetDayHeaderFormatShortest()

AFX_INLINE void SetDayHeaderFormatShortest ( LPCTSTR pcszCustomFormat )
virtual

This member function(s) is used to set the date format string for the day view.

Parameters
pcszCustomFormat Date format string.

Long, Middle, Short and Shortest format strings are used for different header widths. Calendar control selects the longest format which can be drawn for active day header width. By default these format strings are built using locale settings and SetDayHeaderFormatXXX methods should be used to customize default settings.

◆ SetDraggingEvent()

virtual BOOL SetDraggingEvent ( CXTPCalendarEvent * pEventOrig )
virtual

This member function is used to prepare the event to event editing (dragging) operation.

Returns
A BOOL. TRUE if the event editing is successful. FALSE otherwise.
Parameters
pEventOrig Pointer to an initial event for the dragging.

◆ SetResources()

virtual void SetResources ( CXTPCalendarResources * pResources )
virtual

This member function sets the new Resources collection for the view.

Parameters
pResources A pointer to the CXTPCalendarResources collection object.

Call this member function to programmatically set the new Resources collection for the view.

◆ SetSelection()

void SetSelection | ( | const COleDateTime & | dtBegin,
 |  | const COleDateTime & | dtEnd,
 |  | BOOL | bAllDayEvent = FALSE,
 |  | int | nGroupIndex = 0 )

This member function sets the new selection for the view.

Parameters
dtBegin | Selection beginning time.
dtEnd | Selection ending time.
bAllDayEvent | Selection AllDayEvent attribute (used in the day view only).
nGroupIndex | A group index.

Call this member function to programmatically set the new selection beginning and ending for the view.

◆ SetTimer()

virtual UINT SetTimer ( UINT uTimeOut_ms )
protectedvirtual

This member function is used to create a timer event.

Parameters
uTimeOut_ms A UINT that contains the duration of the timer event in milliseconds.
Returns
A UINT that contains the identifier of the timer.

◆ ShowDay()

virtual void ShowDay | ( | const COleDateTime & | date,
 |  | BOOL | bSelect = TRUE )
 pure virtual

This member function is used to show the specified day in the calendar view.

Parameters
date | A COleDateTime object that contains the date to show.
bSelect | TRUE to select the specified day after showing, FALSE otherwise. TRUE is the default value.

Call this member function to show only the specified day in the calendar view.

Implemented in CXTPCalendarDayView, CXTPCalendarMonthView, CXTPCalendarTimeLineView, and CXTPCalendarWeekView.

◆ ShowToolTip()

virtual void ShowToolTip ( BOOL bShow = TRUE )
virtual

This member function is used to show/hide a ToolTip rectangle.

Parameters
bShow TRUE to show a tooltip, FALSE to hide it.

◆ StartEditNewEventInplace()

virtual void StartEditNewEventInplace ( LPCTSTR pcszInitialSubject )
virtual

This member function is used to create a new event and start subject editing.

Parameters
pcszInitialSubject A pointer to the string which contains the initial subject value for the new event (generally initial char).

◆ StartEditSubject()

virtual void StartEditSubject ( CXTPCalendarViewEvent * pViewEvent )
virtual

This member function is used to start the event subject editing.

Parameters
pViewEvent A pointer to a CXTPCalendarViewEvent event view that is used to edit the subject.

◆ Undo()

virtual BOOL Undo ( )
virtual

This member function is used to perform an Undo operation.

Returns
A BOOL. TRUE if the undo operation is successful. FALSE otherwise.

◆ UpdateNextTimeEditByTAB()

virtual void UpdateNextTimeEditByTAB | ( | COleDateTime | dtNext,
 |  | BOOL | bReverse,
 |  | BOOL | bReset = FALSE )
 virtual

This member function is used to set the next date and time to start the find event view for editing events using the TAB key.

Parameters
dtNext | A COleDateTime object that contains the next date and time to start the find event view.
bReverse | If TRUE the reverse order is used, otherwise normal is used.
bReset | If TRUE the next time is set to the start (or end) iteration position.
See also
GetNextTimeEditByTAB
FindEventToEditByTAB

Reimplemented in CXTPCalendarDayView.

Member Data Documentation

◆ m_cntSelChanged

CSelectionChanged_ContextData m_cntSelChanged
protected

Counter on selection changes,.

is needed to redraw a view when necessary.

◆ m_LastHitInfo

XTP_CALENDAR_HITTESTINFO m_LastHitInfo
protected

Last HitInfo data.

It is used in CXTPCalendarView::OnMouseMove() for processing selecting, dragging and other operations.

◆ m_strDayHeaderFormatDefaultLong

CString m_strDayHeaderFormatDefaultLong
protected

Day header Long date format default string.

◆ m_strDayHeaderFormatDefaultShort

CString m_strDayHeaderFormatDefaultShort
protected

Day header Short date format default string.

◆ m_strDayHeaderFormatLong

CString m_strDayHeaderFormatLong
protected

Day header Long date format custom string.

◆ m_strDayHeaderFormatMiddle

CString m_strDayHeaderFormatMiddle
protected

Day header Middle date format custom string.

◆ m_strDayHeaderFormatShort

CString m_strDayHeaderFormatShort
protected

Day header Short date format custom string.

The documentation for this class was generated from the following file:
  • XTPCalendarView.h


Toolkit Pro: CXTPCalendarView::CSelectionChanged_ContextData Class Reference

  • CXTPCalendarView
  • CSelectionChanged_ContextData
Public Member Functions | Public Attributes | List of all members
CXTPCalendarView::CSelectionChanged_ContextData Class Reference

This class defines an internal structure used as a counter on selection changes, which is needed to redraw a view when necessary. More...

Public Member Functions

CSelectionChanged_ContextData ()
Default object constructor.

Public Attributes

int | m_nLockCount
Selection change notification global Lock counter.
int | m_nLockCount_Day
Days selection change notification Lock counter.
int | m_nLockCount_Event
Events selection change notification Lock counter.
BOOL | m_bRequest_Day
Days selection change send notification request.
BOOL | m_bRequest_Event
Events selection change send notification request.

Detailed Description

This class defines an internal structure used as a counter on selection changes, which is needed to redraw a view when necessary.

The documentation for this class was generated from the following file:
  • XTPCalendarView.h


Toolkit Pro: CXTPCalendarView::CSelectionChangedContext Class Reference

  • CXTPCalendarView
  • CSelectionChangedContext
Public Member Functions | List of all members
CXTPCalendarView::CSelectionChangedContext Class Reference

Class CSelectionChangedContext is used to avoid multiple sending of an XTP_NC_CALENDAR_SELECTION_CHANGED notification for one selection changing operation. More...

Public Member Functions

CSelectionChangedContext (CXTPCalendarView *pView, int eSelType=xtpCalendarSelectionUnknown)
Constructs a CSelectionChangedContext object.
virtual ~CSelectionChangedContext ()
Destroys a CSelectionChangedContext object and send notification(s) if this is last locker object.

Detailed Description

Class CSelectionChangedContext is used to avoid multiple sending of an XTP_NC_CALENDAR_SELECTION_CHANGED notification for one selection changing operation.

Constructor & Destructor Documentation

◆ CSelectionChangedContext()

CSelectionChangedContext | ( | CXTPCalendarView * | pView,
 |  | int | eSelType = xtpCalendarSelectionUnknown )

Constructs a CSelectionChangedContext object.

Parameters
pView | Pointer to parent CXTPCalendarView object.
eSelType | Value from enum XTPCalendarSelectionChanged. Changed selection type.

eSelType = xtpCalendarSelectionUnknown only lock sending notifications.

See also
XTP_NC_CALENDAR_SELECTION_CHANGED
The documentation for this class was generated from the following file:
  • XTPCalendarView.h


Toolkit Pro: CXTPCalendarView::SEventTimeFormatInfo Struct Reference

  • CXTPCalendarView
  • SEventTimeFormatInfo
Public Member Functions | Public Attributes | List of all members
CXTPCalendarView::SEventTimeFormatInfo Struct Reference

Public Member Functions

SEventTimeFormatInfo ()
Default object constructor.

Public Attributes

CString | strFormat
Time format string.
CString | strAM
AM symbol.
CString | strPM
PM symbol.
BOOL | b24_HFormat
Is 24 hours time format.

Detailed Description

This helper struct is used to group information which is necessary to format Start/End events times.

See also
FormatEventTime
_CalculateEventTimeFormat.

Member Data Documentation

◆ strAM

CString strAM

AM symbol.

◆ strFormat

CString strFormat

Time format string.

◆ strPM

CString strPM

PM symbol.

The documentation for this struct was generated from the following file:
  • XTPCalendarView.h


Toolkit Pro: CXTPCalendarViewDay Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPCalendarViewDay Class Referenceabstract

This class represents the day view portion of the CalendarView. More...

Inheritance diagram for CXTPCalendarViewDay:
[legend]

Public Member Functions

CXTPCalendarViewDay (const CXTPCalendarView *pView)
Default object constructor.
virtual | ~CXTPCalendarViewDay ()
Default class destructor.
virtual void | Populate (COleDateTime dtDayDate)
This member function is used to populate the view with data for all items contained in the view.
virtual void | AdjustLayout (CDC *pDC, const CRect &rcDay)
This member function is used to adjust the view's layout depending on the provided rectangle and then calls AdjustLayout() for all of the sub-items.
virtual void | Draw (CDC *pDC)
This member function is used to draw the view contents using the specified device context.
virtual int | GetChildHandlersCount () const
This member function is used to obtain the number of resource group views elements in the collection.
virtual CXTPCalendarWMHandler * | GetChildHandlerAt (int nIndex) const
Call this method to get a resource group view object at the specified numeric index.
virtual BOOL | HitTest (CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const
This member function is used to determine which view item, if any, is at the specified position index, and returns additional info in an XTP_CALENDAR_HITTESTINFO struct.
virtual BOOL | HitTestEx (CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const
This member function is used to determine which view item, if any, is at the specified position index, and returns additional info in the XTP_CALENDAR_HITTESTINFO template object.
virtual void | FillHitTestEx (XTP_CALENDAR_HITTESTINFO *pHitTest) const =0
This member function is used to fill the pHitTest structure members with the default values for the current day view object.
virtual CXTPCalendarView * | GetView_ () const
Call this member function to obtain a pointer to a CXTPCalendarView object.
virtual CXTPCalendarControl * | GetCalendarControl () const
Call this member function to obtain a pointer to a CXTPCalendarControl object.
virtual CXTPCalendarResources * | GetResources () const
Call this member function to obtain a pointer to the associated Calendar Resources collection object.
virtual void | SetResources (CXTPCalendarResources *pResources)
This member function sets the new Resources collection for the view day.
virtual int | GetViewEventsCount () const
Call this member function to obtain the number of event views in the day view collection.
virtual CXTPCalendarViewEvent * | GetViewEvent_ (int nIndex) const
Call this member function to obtain a pointer to a CXTPCalendarViewEvent object associated with the event's index.
int | GetViewGroupsCount () const
Call this member function to obtain the number of resource group views in the view day collection.
CXTPCalendarViewGroup * | GetViewGroup_ (int nIndex) const
Call this member function to obtain a pointer to a CXTPCalendarViewGroup object associated with the group's index.
virtual COleDateTime | GetDayDate () const
Call this member function to obtain a day date value.
virtual COleDateTime | SetDayDate (COleDateTime dtDayDate)
Call this member function to obtain the day date value.
virtual BOOL | ContainsInvisibleEvents () const
Call this member function to determine if there are any invisible event views.
virtual BOOL | ContainsInvisibleEventsUpdate ()
Call this member function to determine if there are any invisible event views and to calculate the rectangle for the ExpandSign.
virtual BOOL | IsSelected () const
Call this member function to determine if the day view is selected.
virtual void | SetSelected ()
This member function is used to set the day view as selected.
virtual CRect | GetDayRect () const
Call this member function to obtain the day view rectangle coordinates.
virtual void | SetDayRect (CRect rcDay)
This member function is used to set the day view rectangle coordinates.
virtual BOOL | IsExpanded () const
Call this member function to determine if there are invisible event views because the boundaries of the day view are hidden and if the day view should display the expand sign.
virtual CRect | GetExpandSignRect () const
Call this member function to obtain the expand sign rectangle.
virtual UINT | SetTimer (UINT uTimeOut_ms)
This member function is used to create a timer event.
virtual void | KillTimer (UINT uTimerID)
This member function is used to destroy a timer event.
virtual int | GetDayIndex () const
This member function is used to obtain the index of the "this" pointer day in the Calendar Day View.
virtual BOOL | UserAction_OnExpandDay (XTPCalendarExpandDayButton eButton)
This member function is used to process the user action xtpCalendarUserAction_OnExpandDay.
- Public Member Functions inherited from CXTPCalendarWMHandler
CXTPCalendarWMHandler ()
Default object constructor.
virtual BOOL | OnLButtonDown (UINT nFlags, CPoint point)
This member function is used to process left mouse button down events.
virtual BOOL | OnLButtonUp (UINT nFlags, CPoint point)
This member function is used to process left mouse button up events.
virtual BOOL | OnLButtonDblClk (UINT nFlags, CPoint point)
This member function is used to process left mouse button double click events.
virtual void | OnMouseMove (UINT nFlags, CPoint point)
This member function is used to process mouse movement events.
virtual void | OnChar (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process keyboard events.
virtual void | OnKeyDown (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process key-down keyboard events.
virtual void | OnKeyUp (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process key-up keyboard events.
virtual BOOL | OnSysKeyDown (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process key-up keyboard events.
virtual BOOL | OnTimer (UINT_PTR uTimerID)
The framework calls this member function after each interval specified in the SetTimer member function.
virtual BOOL | OnWndMsg (UINT message, WPARAM wParam, LPARAM lParam, LRESULT *pResult)
This method is called by framework after default message processing.
virtual void | OnPostAdjustLayout ()
This member function is used to perform additional adjustments in some kinds of views.
virtual void | OnBeforeDestroy ()
This member function is called by the framework before destroying the view.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

virtual void | OnPrePopulateDay ()
This member function is used to allow some customization before show events.
virtual CXTPCalendarViewGroup * | CreateGroup ()=0
This member function is used to create a new instance of a group.

Protected Attributes

XTP_VIEW_DAY_LAYOUT | m_Layout
Layout data.
COleDateTime | m_dtDate
Day date.
CXTPCalendarResources * | m_pResources
Resources array.
CXTPCalendarPtrCollectionT< CXTPCalendarViewGroup > | m_arViewGroups
Storage for views of groups.
CXTPCalendarView * | m_pView
Storage for a owner view.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

This class represents the day view portion of the CalendarView.

It represents a specific view of the CalendarView's associated events data grouped by one day and provides basic functionality on this data using user input through the keyboard and the mouse.

 These are the predefined view implementations available
 for the Calendar control:

 * Day and work week day views : Using the CXTPCalendarDayViewDay class.
 * Week day view               : Using the CXTPCalendarWeekViewDay class.
 * Month day view              : Using the CXTPCalendarMonthViewDay class.

 Furthermore, any user-defined day view may also be implemented as
 a descendant of the CXTPCalendarViewDay class.

 A typical day view model consists of a collection of ViewEvent's for
 the particular day, each of them represents a view of an CXTPCalendarEvent
 object.
See also
CXTPCalendarViewDayT
CXTPCalendarDayViewDay
CXTPCalendarWeekViewDay
CXTPCalendarMonthViewDay
CXTPCalendarView
CXTPCalendarViewEvent

Constructor & Destructor Documentation

◆ CXTPCalendarViewDay()

CXTPCalendarViewDay ( const CXTPCalendarView * pView )

Default object constructor.

Construct CXTPCalendarViewDay object.

Parameters
pView Pointer to CXTPCalendarView object.
See also
~CXTPCalendarViewDay()

◆ ~CXTPCalendarViewDay()

virtual ~CXTPCalendarViewDay ( )
virtual

Default class destructor.

Handles member item deallocation.

Member Function Documentation

◆ AdjustLayout()

virtual void AdjustLayout | ( | CDC * | pDC,
 |  | const CRect & | rcDay )
 virtual

This member function is used to adjust the view's layout depending on the provided rectangle and then calls AdjustLayout() for all of the sub-items.

Parameters
pDC | A pointer to a valid device context.
rcDay | A CRect object that contains the rectangle coordinates that are used to draw the view.

Call Populate(COleDateTime dtDayDate) prior to calling AdjustLayout().

Reimplemented in CXTPCalendarDayViewDay, CXTPCalendarMonthViewDay, CXTPCalendarViewDayT< _TView, _TViewGroup, XTP_CALENDAR_HITTESTINFO, _TPThis >, CXTPCalendarViewDayT< CXTPCalendarDayView, CXTPCalendarDayViewGroup, XTP_CALENDAR_HITTESTINFO, CXTPCalendarDayViewDay >, CXTPCalendarViewDayT< CXTPCalendarMonthView, CXTPCalendarMonthViewGroup, XTP_CALENDAR_HITTESTINFO, CXTPCalendarMonthViewDay >, CXTPCalendarViewDayT< CXTPCalendarWeekView, CXTPCalendarWeekViewGroup, XTP_CALENDAR_HITTESTINFO, CXTPCalendarWeekViewDay >, and CXTPCalendarWeekViewDay.

◆ ContainsInvisibleEvents()

virtual BOOL ContainsInvisibleEvents ( ) const
virtual

Call this member function to determine if there are any invisible event views.

This function is used for determining if the expanding signs are drawn.

Returns
A BOOL. TRUE if there is at least one event that is completely invisible. FALSE otherwise.

◆ ContainsInvisibleEventsUpdate()

virtual BOOL ContainsInvisibleEventsUpdate ( )
virtual

Call this member function to determine if there are any invisible event views and to calculate the rectangle for the ExpandSign.

Returns
TRUE if there are invisible event views. FALSE otherwise.
See also
CXTPCalendarViewDay::ContainsInvisibleEvents

◆ CreateGroup()

virtual CXTPCalendarViewGroup * CreateGroup ( )
protectedpure virtual

This member function is used to create a new instance of a group.

Returns
A newly created view group object pointer.

Implemented in CXTPCalendarViewDayT< _TView, _TViewGroup, XTP_CALENDAR_HITTESTINFO, _TPThis >, CXTPCalendarViewDayT< CXTPCalendarDayView, CXTPCalendarDayViewGroup, XTP_CALENDAR_HITTESTINFO, CXTPCalendarDayViewDay >, CXTPCalendarViewDayT< CXTPCalendarMonthView, CXTPCalendarMonthViewGroup, XTP_CALENDAR_HITTESTINFO, CXTPCalendarMonthViewDay >, and CXTPCalendarViewDayT< CXTPCalendarWeekView, CXTPCalendarWeekViewGroup, XTP_CALENDAR_HITTESTINFO, CXTPCalendarWeekViewDay >.

◆ Draw()

virtual void Draw ( CDC * pDC )
inlinevirtual

This member function is used to draw the view contents using the specified device context.

Parameters
pDC A pointer to a valid device context.

Call AdjustLayout() before calling Draw().

See also
AdjustLayout(CRect rcDay)

Reimplemented in CXTPCalendarDayViewDay, CXTPCalendarMonthViewDay, and CXTPCalendarWeekViewDay.

◆ FillHitTestEx()

virtual void FillHitTestEx ( XTP_CALENDAR_HITTESTINFO * pHitTest ) const
pure virtual

This member function is used to fill the pHitTest structure members with the default values for the current day view object.

Parameters
pHitTest A Pointer to a XTP_CALENDAR_HITTESTINFO structure.

This is a pure virtual function. This function must be defined in the derived class.

Implemented in CXTPCalendarDayViewDay, CXTPCalendarMonthViewDay, CXTPCalendarViewDayT< _TView, _TViewGroup, XTP_CALENDAR_HITTESTINFO, _TPThis >, CXTPCalendarViewDayT< CXTPCalendarDayView, CXTPCalendarDayViewGroup, XTP_CALENDAR_HITTESTINFO, CXTPCalendarDayViewDay >, CXTPCalendarViewDayT< CXTPCalendarMonthView, CXTPCalendarMonthViewGroup, XTP_CALENDAR_HITTESTINFO, CXTPCalendarMonthViewDay >, CXTPCalendarViewDayT< CXTPCalendarWeekView, CXTPCalendarWeekViewGroup, XTP_CALENDAR_HITTESTINFO, CXTPCalendarWeekViewDay >, and CXTPCalendarWeekViewDay.

◆ GetCalendarControl()

virtual CXTPCalendarControl * GetCalendarControl ( ) const
virtual

Call this member function to obtain a pointer to a CXTPCalendarControl object.

Returns
A pointer to a CXTPCalendarControl object.

◆ GetChildHandlerAt()

virtual CXTPCalendarWMHandler * GetChildHandlerAt ( int nIndex ) const
inlinevirtual

Call this method to get a resource group view object at the specified numeric index.

Parameters
nIndex An integer index that is greater than or equal to 0 and less than the value returned by GetChildHandlersCount.

Returns the array element at the specified index.

Returns
The pointer to the CXTPCalendarWMHandler element currently at this index.

Reimplemented from CXTPCalendarWMHandler.

◆ GetChildHandlersCount()

virtual int GetChildHandlersCount ( ) const
inlinevirtual

This member function is used to obtain the number of resource group views elements in the collection.

Call this method to retrieve the number of elements in the array. Because indexes are zero-based, the size is 1 greater than the largest index.

Returns
A count of resource group views elements.

Reimplemented from CXTPCalendarWMHandler.

◆ GetDayDate()

AFX_INLINE COleDateTime GetDayDate ( ) const
virtual

Call this member function to obtain a day date value.

Returns
A COleDateTime object containing the day's date.
See also
SetDayDate(COleDateTime dtDayDate)

◆ GetDayIndex()

virtual int GetDayIndex ( ) const
virtual

This member function is used to obtain the index of the "this" pointer day in the Calendar Day View.

Returns
An int that contains the index of the "this" day in the Calendar Day View.

◆ GetDayRect()

AFX_INLINE CRect GetDayRect ( ) const
virtual

Call this member function to obtain the day view rectangle coordinates.

Returns
A CRect object containing the day view rectangle coordinates.
See also
SetDayRect(CRect rcDay)

◆ GetExpandSignRect()

AFX_INLINE CRect GetExpandSignRect ( ) const
virtual

Call this member function to obtain the expand sign rectangle.

Returns
A CRect object that contains the expand sign rectangle's coordinates.

◆ GetResources()

virtual CXTPCalendarResources * GetResources ( ) const
virtual

Call this member function to obtain a pointer to the associated Calendar Resources collection object.

Returns
A pointer to the CXTPCalendarResources collection object.
See also
CXTPCalendarResources overview
CXTPCalendarResource overview

◆ GetView_()

AFX_INLINE CXTPCalendarView * GetView_ ( ) const
virtual

Call this member function to obtain a pointer to a CXTPCalendarView object.

This is a pure virtual function. This function must be defined in the derived class.

Returns
A pointer to a CXTPCalendarView object.

◆ GetViewEvent_()

virtual CXTPCalendarViewEvent * GetViewEvent_ ( int nIndex ) const
virtual

Call this member function to obtain a pointer to a CXTPCalendarViewEvent object associated with the event's index.

Parameters
nIndex An int that contains the event view index in the day view collection.

Index number starts with 0 and cannot be negative. This function is left for compatibility with previous versions and only for singe resource group mode.

Returns
A pointer to a CXTPCalendarViewEvent object.
See also
GetViewEventsCount()

◆ GetViewEventsCount()

virtual int GetViewEventsCount ( ) const
virtual

Call this member function to obtain the number of event views in the day view collection.

This function is left for compatibility with previous versions and only for singe resource group mode.

Returns
An int that contains the number of event views.

◆ GetViewGroup_()

AFX_INLINE CXTPCalendarViewGroup * GetViewGroup_ ( int nIndex ) const

Call this member function to obtain a pointer to a CXTPCalendarViewGroup object associated with the group's index.

Parameters
nIndex An int that contains the group view index in the day view collection.

Index number starts with 0 and cannot be negative. This is a pure virtual function. This function must be defined in the derived class.

Returns
A pointer to a CXTPCalendarViewGroup object.
See also
GetViewGroupsCount()

◆ GetViewGroupsCount()

AFX_INLINE int GetViewGroupsCount ( ) const

Call this member function to obtain the number of resource group views in the view day collection.

This is a pure virtual function. This function must be defined in the derived class.

Returns
An int that contains the number of event views.

◆ HitTest()

virtual BOOL HitTest | ( | CPoint | pt,
 |  | XTP_CALENDAR_HITTESTINFO * | pHitTest ) const
 virtual

This member function is used to determine which view item, if any, is at the specified position index, and returns additional info in an XTP_CALENDAR_HITTESTINFO struct.

Parameters
pt | A CPoint object that contains the coordinates of the point to test.
pHitTest | A pointer to an XTP_CALENDAR_HITTESTINFO struct that contains information about the point to test.

This is a pure virtual function. This function must be defined in the derived class.

Returns
A BOOL. TRUE if the item is found. FALSE otherwise.
See also
XTP_CALENDAR_HITTESTINFO

◆ HitTestEx()

virtual BOOL HitTestEx | ( | CPoint | pt,
 |  | XTP_CALENDAR_HITTESTINFO * | pHitTest ) const
 virtual

This member function is used to determine which view item, if any, is at the specified position index, and returns additional info in the XTP_CALENDAR_HITTESTINFO template object.

Parameters
pt | A CPoint that contains the coordinates of the point test.
pHitTest | A pointer to an XTP_CALENDAR_HITTESTINFO structure.

Implements standard functionality for the HitTestEx method.

Returns
A BOOL. TRUE if the item is found. FALSE otherwise.
See also
XTP_CALENDAR_HITTESTINFO

Reimplemented in CXTPCalendarMonthViewDay, and CXTPCalendarWeekViewDay.

◆ IsExpanded()

AFX_INLINE BOOL IsExpanded ( ) const
virtual

Call this member function to determine if there are invisible event views because the boundaries of the day view are hidden and if the day view should display the expand sign.

Returns
A BOOL. TRUE if there are invisible event views. FALSE otherwise.

◆ IsSelected()

virtual BOOL IsSelected ( ) const
virtual

Call this member function to determine if the day view is selected.

Returns
A BOOL. TRUE if the day view is selected. FALSE otherwise.
See also
SetSelected(bSet)

◆ KillTimer()

virtual void KillTimer ( UINT uTimerID )
virtual

This member function is used to destroy a timer event.

Parameters
uTimerID - A UINT that specifies the identifier of the timer.

◆ OnPrePopulateDay()

virtual void OnPrePopulateDay ( )
protectedvirtual

This member function is used to allow some customization before show events.

Default implementation sends an XTP_NC_CALENDAR_PREPOPULATE_DAY notification.

See also
XTP_NC_CALENDAR_PREPOPULATE

◆ Populate()

virtual void Populate ( COleDateTime dtDayDate )
virtual

This member function is used to populate the view with data for all items contained in the view.

Parameters
dtDayDate A COleDateTime object that contains the day's date.

This is a pure virtual function. This function must be defined in the derived class.

Reimplemented in CXTPCalendarDayViewDay.

◆ SetDayDate()

virtual COleDateTime SetDayDate ( COleDateTime dtDayDate )
virtual

Call this member function to obtain the day date value.

Parameters
dtDayDate A COleDateTime object that contains the new day's date value.
Returns
A COleDateTime object that contains the previous day's date value.
See also
GetDayDate()

◆ SetDayRect()

AFX_INLINE void SetDayRect ( CRect rcDay )
virtual

This member function is used to set the day view rectangle coordinates.

Parameters
rcDay A CRect object containing the new rectangle coordinates.
See also
GetDayRect()

◆ SetResources()

virtual void SetResources ( CXTPCalendarResources * pResources )
virtual

This member function sets the new Resources collection for the view day.

Parameters
pResources A pointer to the CXTPCalendarResources collection object.

Call this member function to programmatically set the new Resources collection for the view day.

◆ SetSelected()

virtual void SetSelected ( )
virtual

This member function is used to set the day view as selected.

See also
IsSelected()

Reimplemented in CXTPCalendarMonthViewDay.

◆ SetTimer()

virtual UINT SetTimer ( UINT uTimeOut_ms )
virtual

This member function is used to create a timer event.

Parameters
uTimeOut_ms A UINT that contains the duration of the timer in milliseconds.
Returns
A UINT that is the identifier of the timer.

◆ UserAction_OnExpandDay()

virtual BOOL UserAction_OnExpandDay ( XTPCalendarExpandDayButton eButton )
virtual

This member function is used to process the user action xtpCalendarUserAction_OnExpandDay.

Parameters
eButton [in] a button from which this action comes.

Implementation sends an XTP_NC_CALENDAR_USERACTION notification.

Returns
TRUE if action was handled by the user and default processing must be skipped, FALSE otherwise.
See also
XTP_NC_CALENDAR_USERACTION
The documentation for this class was generated from the following file:
  • XTPCalendarViewDay.h


Toolkit Pro: CXTPCalendarViewDayT< _TView, _TViewGroup, XTP_CALENDAR_HITTESTINFO, _TPThis > Class Template Reference

Public Types | Public Member Functions | Protected Member Functions | List of all members
CXTPCalendarViewDayT< _TView, _TViewGroup, XTP_CALENDAR_HITTESTINFO, _TPThis > Class Template Referenceabstract

This class template customizes, overrides and implements some functionality for the CXTPCalendarViewDay base class. More...

Inheritance diagram for CXTPCalendarViewDayT< _TView, _TViewGroup, XTP_CALENDAR_HITTESTINFO, _TPThis >:
[legend]

Public Types

typedef _TView TView

Public Member Functions

CXTPCalendarViewDayT (const _TView *pView)
Default object constructor.
virtual | ~CXTPCalendarViewDayT ()
Default class destructor.
virtual void | FillHitTestEx (XTP_CALENDAR_HITTESTINFO *pHitTest) const =0
This member function is used to fill the pHitTest structure members with the default values for the current day view object.
_TView * | GetView () const
This member function is used to obtain the owner view object.
virtual _TViewGroup * | GetViewGroup (int nIndex) const
Call this member function to obtain a pointer to the _TViewGroup object that corresponds to the resource's index.
virtual CXTPCalendarViewGroup * | CreateGroup ()
This member function is used to create a new instance of a group.
virtual void | AdjustLayout (CDC *pDC, const CRect &rcDay)
This member function is used to adjust the view's layout depending on the provided rectangle and then calls AdjustLayout() for all of the sub-items.
- Public Member Functions inherited from CXTPCalendarViewDay
CXTPCalendarViewDay (const CXTPCalendarView *pView)
Default object constructor.
virtual | ~CXTPCalendarViewDay ()
Default class destructor.
virtual void | Populate (COleDateTime dtDayDate)
This member function is used to populate the view with data for all items contained in the view.
virtual void | Draw (CDC *pDC)
This member function is used to draw the view contents using the specified device context.
virtual int | GetChildHandlersCount () const
This member function is used to obtain the number of resource group views elements in the collection.
virtual CXTPCalendarWMHandler * | GetChildHandlerAt (int nIndex) const
Call this method to get a resource group view object at the specified numeric index.
virtual BOOL | HitTest (CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const
This member function is used to determine which view item, if any, is at the specified position index, and returns additional info in an XTP_CALENDAR_HITTESTINFO struct.
virtual BOOL | HitTestEx (CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const
This member function is used to determine which view item, if any, is at the specified position index, and returns additional info in the XTP_CALENDAR_HITTESTINFO template object.
virtual CXTPCalendarView * | GetView_ () const
Call this member function to obtain a pointer to a CXTPCalendarView object.
virtual CXTPCalendarControl * | GetCalendarControl () const
Call this member function to obtain a pointer to a CXTPCalendarControl object.
virtual CXTPCalendarResources * | GetResources () const
Call this member function to obtain a pointer to the associated Calendar Resources collection object.
virtual void | SetResources (CXTPCalendarResources *pResources)
This member function sets the new Resources collection for the view day.
virtual int | GetViewEventsCount () const
Call this member function to obtain the number of event views in the day view collection.
virtual CXTPCalendarViewEvent * | GetViewEvent_ (int nIndex) const
Call this member function to obtain a pointer to a CXTPCalendarViewEvent object associated with the event's index.
int | GetViewGroupsCount () const
Call this member function to obtain the number of resource group views in the view day collection.
CXTPCalendarViewGroup * | GetViewGroup_ (int nIndex) const
Call this member function to obtain a pointer to a CXTPCalendarViewGroup object associated with the group's index.
virtual COleDateTime | GetDayDate () const
Call this member function to obtain a day date value.
virtual COleDateTime | SetDayDate (COleDateTime dtDayDate)
Call this member function to obtain the day date value.
virtual BOOL | ContainsInvisibleEvents () const
Call this member function to determine if there are any invisible event views.
virtual BOOL | ContainsInvisibleEventsUpdate ()
Call this member function to determine if there are any invisible event views and to calculate the rectangle for the ExpandSign.
virtual BOOL | IsSelected () const
Call this member function to determine if the day view is selected.
virtual void | SetSelected ()
This member function is used to set the day view as selected.
virtual CRect | GetDayRect () const
Call this member function to obtain the day view rectangle coordinates.
virtual void | SetDayRect (CRect rcDay)
This member function is used to set the day view rectangle coordinates.
virtual BOOL | IsExpanded () const
Call this member function to determine if there are invisible event views because the boundaries of the day view are hidden and if the day view should display the expand sign.
virtual CRect | GetExpandSignRect () const
Call this member function to obtain the expand sign rectangle.
virtual UINT | SetTimer (UINT uTimeOut_ms)
This member function is used to create a timer event.
virtual void | KillTimer (UINT uTimerID)
This member function is used to destroy a timer event.
virtual int | GetDayIndex () const
This member function is used to obtain the index of the "this" pointer day in the Calendar Day View.
virtual BOOL | UserAction_OnExpandDay (XTPCalendarExpandDayButton eButton)
This member function is used to process the user action xtpCalendarUserAction_OnExpandDay.
- Public Member Functions inherited from CXTPCalendarWMHandler
CXTPCalendarWMHandler ()
Default object constructor.
virtual BOOL | OnLButtonDown (UINT nFlags, CPoint point)
This member function is used to process left mouse button down events.
virtual BOOL | OnLButtonUp (UINT nFlags, CPoint point)
This member function is used to process left mouse button up events.
virtual BOOL | OnLButtonDblClk (UINT nFlags, CPoint point)
This member function is used to process left mouse button double click events.
virtual void | OnMouseMove (UINT nFlags, CPoint point)
This member function is used to process mouse movement events.
virtual void | OnChar (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process keyboard events.
virtual void | OnKeyDown (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process key-down keyboard events.
virtual void | OnKeyUp (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process key-up keyboard events.
virtual BOOL | OnSysKeyDown (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process key-up keyboard events.
virtual BOOL | OnTimer (UINT_PTR uTimerID)
The framework calls this member function after each interval specified in the SetTimer member function.
virtual BOOL | OnWndMsg (UINT message, WPARAM wParam, LPARAM lParam, LRESULT *pResult)
This method is called by framework after default message processing.
virtual void | OnPostAdjustLayout ()
This member function is used to perform additional adjustments in some kinds of views.
virtual void | OnBeforeDestroy ()
This member function is called by the framework before destroying the view.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

virtual _TPThis * | GetPThis ()=0
Call this member function to obtain the typed pointer to the last derived class in the class hierarchy.
- Protected Member Functions inherited from CXTPCalendarViewDay
virtual void | OnPrePopulateDay ()
This member function is used to allow some customization before show events.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Attributes inherited from CXTPCalendarViewDay
XTP_VIEW_DAY_LAYOUT | m_Layout
Layout data.
COleDateTime | m_dtDate
Day date.
CXTPCalendarResources * | m_pResources
Resources array.
CXTPCalendarPtrCollectionT< CXTPCalendarViewGroup > | m_arViewGroups
Storage for views of groups.
CXTPCalendarView * | m_pView
Storage for a owner view.

Detailed Description

template<class _TView, class _TViewGroup, class XTP_CALENDAR_HITTESTINFO, class _TPThis>
class CXTPCalendarViewDayT< _TView, _TViewGroup, XTP_CALENDAR_HITTESTINFO, _TPThis >

This class template customizes, overrides and implements some functionality for the CXTPCalendarViewDay base class.

It is used as a part of the calendar control framework to build the ViewDay layer of View->DayView->ViewDay typed objects hierarchy. These are template parameters: _TView - Type of owner View object. _TViewGroup - Type of View Resource objects stored in View Day. XTP_CALENDAR_HITTESTINFO - Type of HitTest struct, used as parameter in the member functions. _TPThis - The last derived class type in the class hierarchy.

 You must provide all of the above parameters.
See also
CXTPCalendarViewDay

Member Typedef Documentation

◆ TView

template<class _TView , class _TViewGroup , class XTP_CALENDAR_HITTESTINFO , class _TPThis >
_TView TView

Owner view class type definition.

Constructor & Destructor Documentation

◆ CXTPCalendarViewDayT()

template<class _TView , class _TViewGroup , class XTP_CALENDAR_HITTESTINFO , class _TPThis >
CXTPCalendarViewDayT ( const _TView * pView )
inline

Default object constructor.

Parameters
pView Pointer to owner view object.
See also
~CXTPCalendarViewDayT()

◆ ~CXTPCalendarViewDayT()

template<class _TView , class _TViewGroup , class XTP_CALENDAR_HITTESTINFO , class _TPThis >
virtual ~CXTPCalendarViewDayT ( )
inlinevirtual

Default class destructor.

Handles class members deallocation.

Member Function Documentation

◆ AdjustLayout()

template<class _TView , class _TViewGroup , class XTP_CALENDAR_HITTESTINFO , class _TPThis >
virtual void AdjustLayout | ( | CDC * | pDC,
 |  | const CRect & | rcDay )
 inlinevirtual

This member function is used to adjust the view's layout depending on the provided rectangle and then calls AdjustLayout() for all of the sub-items.

Parameters
pDC | A pointer to a valid device context.
rcDay | A CRect object that contains the rectangle coordinates that are used to draw the view.

Call Populate(COleDateTime dtDayDate) prior to calling AdjustLayout().

Reimplemented from CXTPCalendarViewDay.

Reimplemented in CXTPCalendarDayViewDay, CXTPCalendarMonthViewDay, and CXTPCalendarWeekViewDay.

◆ CreateGroup()

template<class _TView , class _TViewGroup , class XTP_CALENDAR_HITTESTINFO , class _TPThis >
virtual CXTPCalendarViewGroup * CreateGroup ( )
inlinevirtual

This member function is used to create a new instance of a group.

Returns
A newly created view group object pointer.

Implements CXTPCalendarViewDay.

◆ FillHitTestEx()

template<class _TView , class _TViewGroup , class XTP_CALENDAR_HITTESTINFO , class _TPThis >
virtual void FillHitTestEx ( XTP_CALENDAR_HITTESTINFO * pHitTest ) const
pure virtual

This member function is used to fill the pHitTest structure members with the default values for the current day view object.

Parameters
pHitTest A Pointer to an XTP_CALENDAR_HITTESTINFO structure.

This is a pure virtual function. This function must be defined in the derived class.

Implements CXTPCalendarViewDay.

Implemented in CXTPCalendarDayViewDay, CXTPCalendarMonthViewDay, and CXTPCalendarWeekViewDay.

◆ GetPThis()

template<class _TView , class _TViewGroup , class XTP_CALENDAR_HITTESTINFO , class _TPThis >
virtual _TPThis * GetPThis ( )
protectedpure virtual

Call this member function to obtain the typed pointer to the last derived class in the class hierarchy.

_TPThis - The last derived class type in the class hierarchy. This is a pure virtual function. This function must be defined in the derived class.

Returns
Pointer to this object as last derived class type.

Implemented in CXTPCalendarMonthViewDay, and CXTPCalendarWeekViewDay.

◆ GetView()

template<class _TView , class _TViewGroup , class XTP_CALENDAR_HITTESTINFO , class _TPThis >
_TView * GetView ( ) const
inline

This member function is used to obtain the owner view object.

Returns
A _TView template pointer to the owner view object.
See also
GetView_

◆ GetViewGroup()

template<class _TView , class _TViewGroup , class XTP_CALENDAR_HITTESTINFO , class _TPThis >
virtual _TViewGroup * GetViewGroup ( int nIndex ) const
inlinevirtual

Call this member function to obtain a pointer to the _TViewGroup object that corresponds to the resource's index.

Parameters
nIndex An int that contains the resource view index in the day view collection.
Returns
A pointer to a _TViewGroup template object.

Index number starts with 0 and cannot be negative.

See also
GetViewGroupsCount()
GetViewGroup_()
The documentation for this class was generated from the following file:
  • XTPCalendarViewDay.h


Toolkit Pro: CXTPCalendarViewEvent Class Reference

Public Member Functions | Static Public Member Functions | Public Attributes | Protected Member Functions | Protected Attributes | List of all members
CXTPCalendarViewEvent Class Referenceabstract

This class represents an event view portion of the CalendarViewGroup. More...

Inheritance diagram for CXTPCalendarViewEvent:
[legend]

Public Member Functions

CXTPCalendarViewEvent (CXTPCalendarEvent *pEvent, CXTPCalendarViewGroup *pViewGroup)
Default object constructor.
virtual | ~CXTPCalendarViewEvent ()
Default class destructor.
virtual BOOL | HitTest (CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const
This member function is used to determine which view item, if any, is at the specified position index, and returns additional info in the XTP_CALENDAR_HITTESTINFO struct.
virtual CXTPCalendarViewGroup * | GetViewGroup_ () const =0
Call this member function to obtain a pointer to the containing CXTPCalendarViewDay object.
virtual CXTPCalendarEvent * | GetEvent () const
Call this member function to obtain the corresponding read only event object without increasing the object's reference counter.
virtual CXTPCalendarControl * | GetCalendarControl () const
Call this member function to obtain a pointer to the calendar control object.
virtual BOOL | IsVisible () const =0
Call this member function to determine if this event view is visible on the screen.
virtual BOOL | IsSelected () const
Call this member function to determine if the given event view is selected.
virtual void | SetSelected (BOOL bSet=TRUE)
This member function is used to set the day view as select or unselected.
virtual BOOL | IsMultidayEvent () const
Call this member function to determine if the given event view is a multi-day event.
virtual CXTPCalendarViewEvent * | StartEditSubject ()
This member function is used to create and to show the subject editor.
virtual CString | GetEditingSubjectFromEditor () const
Call this member function to obtain an edited subject.
virtual CString | EndEditSubject ()
This member function is used to end the editing project, delete the subject editor, and to obtain the edited text.
virtual void | ShowToolTip ()
This member function is used to show a ToolTip rectangle.
virtual void | HideToolTip ()
This member function is used to hide the ToolTip rectangle.
virtual BOOL | IsEditingSubject () const
Call this member function to determine if the event's subject is currently being edited.
virtual CRect | GetSubjectEditorRect () const
This member function is used to obtain the subject editor rectangle coordinates.
virtual CWnd * | GetSubjectEditor () const
This member function is used to obtain the event's subject editor window.
virtual BOOL | IsShowingToolTip ()
Call this member function to determine if the event's tooltip is visible.
virtual CString | FormatEventTime (COleDateTime dtTime) const
This member function is used to format the event's time as a string with a predefined format.
virtual CRect | GetFirstClockRect () const
This member function is used to obtain the rectangle coordinates used for drawing a clock in the beginning of a multi day event.
virtual CRect | GetLastClockRect () const
This member function is used to obtain the rectangle coordinates used for drawing a clock in the end of a multi-day event.
virtual CRect | GetTextRect () const
This member function is used to obtain the rectangle coordinates used for displaying the event's subject.
virtual CRect | GetStartTimeRect () const
This member function is used to obtain the rectangle coordinates used for displaying a clock to show the start event time for single day events.
virtual CRect | GetEndTimeRect () const
This member function is used to obtain the rectangle coordinates for displaying a clock to show the end event time for single day events.
virtual CRect | GetViewEventRect () const
This member function is used to obtain the rectangle coordinates for the event's rectangle.
virtual CRect | GetViewEventRectMax () const
This member function is used to obtain the rectangle coordinates for the event's maximum rectangle dimensions.
virtual CRect | GetReminderGlyphRect () const
This member function is used to obtain the rectangle coordinates for displaying the remainder icon.
virtual CRect | GetRecurrenceGlyphRect () const
This member function is used to obtain the rectangle coordinates used for displaying the recurrence icon.
virtual CRect | GetMeetingGlyphRect () const
This member function obtains the rectangle coordinates for displaying the meeting icon.
virtual CRect | GetPrivateGlyphRect () const
This member function is used to obtain the rectangle coordinates used for displaying the private icon.
virtual BOOL | IsMultyDayTextAlign () const
This member function is used to obtain the flag to determine if multi-day text align mode is on.
virtual int | GetMultiDayEventFlags () const
This member function is used to obtain the multi-day event state flags.
virtual void | SetMultiDayEvent_MasterSlave (BOOL bMaster, CXTPCalendarViewEvent *pMasterView)
This member function is used to set the multi-day event Master/Slave state.
virtual void | AddMultiDayEvent_Slave (CXTPCalendarViewEvent *pSlaveView, int nMasterEventPlace)
This member function is used to add a Slave event view to the Master event view.
virtual void | SetTextOutOfBorders (BOOL bOutOfBorders)
This member function is used to set a flag to determine if the text size exceeds the event view bounds.
virtual BOOL | IsTextOutOfBorders () const
This member function is used to determine if the text size exceeds the event view bounds.
virtual int | GetEventPlaceNumber () const
This member function is used to obtain the place number of the event view.
virtual int | GetEventTimelinePlaceNumber () const
This member function is used to obtain the place number of the event in Timeline view.
CRect | GetEventRect () const
This member function is used to obtain the event view's bounding rectangle.
virtual void | AdjustLayout (CDC *pDC, const CRect &rcEventMax, int nEventPlaceNumber)
This member function is used to adjust the view's layout depending on the provided rectangle and calls AdjustLayout() for all sub-items.
virtual void | AdjustLayout2 (CDC *pDC, const CRect &rcEventMax, int nEventPlaceNumber)=0
This member function is used to adjust the view's layout when theme is set depending on the provided rectangle and calls AdjustLayout() for all sub-items.
virtual void | OnPostAdjustLayout ()
This member function is used to perform additional adjustments in some kinds of views.
virtual void | Draw (CDC *pDC)=0
This member function is used to draw the view content using the specified device context.
virtual void | AdjustSubjectEditor ()
This member function is used to perform adjustments of the subject editor area.
virtual CString | GetItemTextSubject () const
Call this function to get the item subject.
virtual CString | GetItemTextLocation () const
Call this function to get the item location.
virtual CString | GetItemTextBody () const
Call this function to get the item body.
virtual CString | GetItemTextStartTime () const
Call this function to get the item start time.
virtual CString | GetItemTextEndTime () const
Call this function to get the item end time.
virtual CString | GetItemText (DWORD dwItemFlag, LPCTSTR pcszDefaultText=NULL) const
Call this function to get the item text.
virtual CString | GetMarkupText () const
This member function is used to obtain markup template text.
virtual CXTPMarkupUIElement * | GetMarkupUIElement ()
This member function is used to get a stored CXTPMarkupUIElement object.
virtual BOOL | HitTestEx (CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const =0
This member function is used to determine which view item, if any, is at a specified position index, and returns additional info in an XTP_CALENDAR_HITTESTINFO template parameter.
virtual int | CalcIconsRect (CRect rc)
This member function is used to adjust the icons rectangle used to draw the event view icons.
virtual BOOL | OnLButtonDown (UINT nFlags, CPoint point)
This member function is used to process left mouse button down events.
virtual BOOL | OnLButtonUp (UINT nFlags, CPoint point)
This member function is used to process left mouse button up events.
virtual BOOL | OnLButtonDblClk (UINT nFlags, CPoint point)
This member function is used to process left mouse button double click events.
virtual void | OnMouseMove (UINT nFlags, CPoint point)
This member function is used to process mouse movement events.
virtual BOOL | OnWndMsg (UINT message, WPARAM wParam, LPARAM lParam, LRESULT *pResult)
This method is called by framework after default message processing.
virtual UINT | SetTimer (UINT uTimeOut_ms)
This member function is used to create a timer event.
virtual void | KillTimer (UINT uTimerID)
This member function is used to destroy a timer event.
virtual BOOL | OnTimer (UINT_PTR uTimerID)
The framework calls this member function after each interval specified in the SetTimer member function.
virtual UINT | GetShowToolTipTimeOut () const
This member function is used to obtain the timeout value for displaying a tooltip.
virtual DWORD | GetSubjectEditorStyles () const
This member function is used to obtain the styles of the editor window.
virtual CFont * | GetSubjectEditorFont () const
This member function is used to obtain a pointer to the editor window font.
virtual void | ChangeEventPlace (int nNewPlace)
This function is used to change the event place number.
virtual void | OnBeforeDestroy ()
Called by the framework before the destroy() function is called.
- Public Member Functions inherited from CXTPCalendarWMHandler
CXTPCalendarWMHandler ()
Default object constructor.
virtual int | GetChildHandlersCount () const
This member function is used to obtain the number of CXTPCalendarWMHandler elements in the descendant handlers collection.
virtual CXTPCalendarWMHandler * | GetChildHandlerAt (int nIndex) const
Call this method to get a handler object at the specified numeric index.
virtual void | OnChar (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process keyboard events.
virtual void | OnKeyDown (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process key-down keyboard events.
virtual void | OnKeyUp (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process key-up keyboard events.
virtual BOOL | OnSysKeyDown (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process key-up keyboard events.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Static Public Member Functions

static void AFX_CDECL | _MoveRectY (int nYbasePrev, int nYbaseNew, CRect &rRC)
This member function is used to move the rectangle vertically.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Public Attributes

CRect | m_rcEvent
Event view rectangle.
CRect | m_rcEventMax
Event view rectangle margins.
CRect | m_rcText
Rectangle to display event text in event view.
CSize | m_szText
Sizes of displayed text.
CRect | m_rcFirstClock
Rectangle to draw clock in the beginning of the first day of multi-day event.
CRect | m_rcLastClock
Rectangle to draw clock at the end of the last day of multi-day event.
CRect | m_rcStartTime
Rectangle to display start time day event view.
CRect | m_rcEndTime
Rectangle to display end time event view.
int | m_nMultiDayEventFlags
Multi-day event flags packed into integer by bitwise operations.
CRect | m_rcReminderGlyph
Rectangle to draw reminder glyph event view.
CRect | m_rcRecurrenceGlyph
Rectangle to draw recurrence glyph event view.
CRect | m_rcMeetingGlyph
Rectangle to draw meeting glyph event view.
CRect | m_rcPrivateGlyph
Rectangle to draw private glyph event view.
CRect | m_rcSubjectEditor
Subject editor rectangle.
CRect | m_rcToolTip
Tool tip rectangle.
CXTPMarkupUIElement * | m_pUIElement
Store pointer to CXTPMarkupUIElement object.
CString | m_strUIElementText
Store last markup text for which m_pUIElement object was updated.

Protected Member Functions

virtual void | AdjustMultidayEvent (CRect rcEventMax, int nEventPlaceNumber)
This member function is used to adjust a multi-day view's layout depending on the provided rectangle coordinates.
virtual CString | GetToolText ()
This member function is used to obtain tooltip text for the event view.

Protected Attributes

CXTPCalendarEvent * m_ptrEvent
Pointer to the displayed event object.
BOOL | m_bSelected
Event view selected flag.
CXTPCalendarViewEvent * m_pMasterView
Pointer to Master event view object.
int | m_nEventPlaceNumber
Event view place number (sequential identifier).
int | m_nEventTimelinePlaceNumber
Event view place number in Timeline view.
UINT | m_nTimerID_ShowToolTip
Identifier of timer event to show tooltip with delay.
CXTPCalendarViewEventSubjectEditor * | m_pSubjectEditor
Pointer to the subject editor.
BOOL | m_bMultyDayTextAlign
Flag indicates special text alignment for a multi-day event.
BOOL | m_bTextOutOfBorders
Flag indicates text out of event borders.

Detailed Description

This class represents an event view portion of the CalendarViewGroup.

It represents a specific view of the event associated data according to various view types and display settings and provides basic functionality on this data using user input through keyboard and mouse.

 These are the predefined view implementations available
 for the Calendar control:

 * Day and work week event views - Using the CXTPCalendarDayViewEvent class.
 * Week event view               - Using the CXTPCalendarWeekViewEvent class.
 * Month view view               - Using the CXTPCalendarMonthViewEvent class.

 Furthermore, any type of user-defined event view may also be implemented as
 a descendant of the CXTPCalendarViewEvent class.
See also
CXTPCalendarDayViewEvent
CXTPCalendarWeekViewEvent
CXTPCalendarMonthViewEvent
CXTPCalendarView
CXTPCalendarViewDay
CXTPCalendarViewGroup

Constructor & Destructor Documentation

◆ CXTPCalendarViewEvent()

CXTPCalendarViewEvent | ( | CXTPCalendarEvent * | pEvent,
 |  | CXTPCalendarViewGroup * | pViewGroup )

Default object constructor.

Parameters
pViewGroup | A pointer to a CXTPCalendarViewGroup object.
pEvent | A pointer to a CXTPCalendarEvent object.
See also
~CXTPCalendarViewEvent()

Member Function Documentation

◆ _MoveRectY()

static void AFX_CDECL _MoveRectY | ( | int | nYbasePrev,
 |  | int | nYbaseNew,
 |  | CRect & | rRC )
 static

This member function is used to move the rectangle vertically.

Parameters
nYbasePrev | An int that contains the previous position.
nYbaseNew | An int that contains the new position.
rRC | A CRect that contains the rectangle coordinates.
Returns
void

◆ AddMultiDayEvent_Slave()

virtual void AddMultiDayEvent_Slave | ( | CXTPCalendarViewEvent * | pSlaveView,
 |  | int | nMasterEventPlace )
 virtual

This member function is used to add a Slave event view to the Master event view.

Parameters
pSlaveView | A CXTPCalendarViewEvent pointer to the Slave event view object.
nMasterEventPlace | An int that contains the Master event place number.

For multi-day events only.

See also
SetMultiDayEvent_MasterSlave

◆ AdjustLayout()

virtual void AdjustLayout | ( | CDC * | pDC,
 |  | const CRect & | rcEventMax,
 |  | int | nEventPlaceNumber )
 virtual

This member function is used to adjust the view's layout depending on the provided rectangle and calls AdjustLayout() for all sub-items.

Parameters
pDC | A pointer to a valid device context.
rcEventMax | A CRect that contains the rectangle coordinates used to draw the view.
nEventPlaceNumber | An int that contains the sequential place number.

Call Populate(COleDateTime dtDayDate) prior to adjust layout.

Reimplemented in CXTPCalendarDayViewEvent, CXTPCalendarMonthViewEvent, CXTPCalendarTimeLineViewEvent, and CXTPCalendarWeekViewEvent.

◆ AdjustLayout2()

virtual void AdjustLayout2 | ( | CDC * | pDC,
 |  | const CRect & | rcEventMax,
 |  | int | nEventPlaceNumber )
 pure virtual

This member function is used to adjust the view's layout when theme is set depending on the provided rectangle and calls AdjustLayout() for all sub-items.

Parameters
pDC | A pointer to a valid device context.
rcEventMax | A CRect that contains the rectangle coordinates used to draw the view.
nEventPlaceNumber | An int that contains the sequential place number.

Implemented in CXTPCalendarDayViewEvent, CXTPCalendarMonthViewEvent, CXTPCalendarTimeLineViewEvent, and CXTPCalendarWeekViewEvent.

◆ AdjustMultidayEvent()

virtual void AdjustMultidayEvent | ( | CRect | rcEventMax,
 |  | int | nEventPlaceNumber )
 protectedvirtual

This member function is used to adjust a multi-day view's layout depending on the provided rectangle coordinates.

Parameters
rcEventMax | A CRect that contains the rectangle coordinates used to draw the view.
nEventPlaceNumber | An int that contains the sequential place number.

Call this member function to perform special adjustment of multi-day events that must be drawn together through a number of sequential days in some views. Call Populate(COleDateTime dtDayDate) prior to adjust layout.

◆ AdjustSubjectEditor()

virtual void AdjustSubjectEditor ( )
virtual

This member function is used to perform adjustments of the subject editor area.

Call this member function to perform adjustment of subject editor rectangle.

Reimplemented in CXTPCalendarDayViewEvent.

◆ CalcIconsRect()

virtual int CalcIconsRect ( CRect rc )
virtual

This member function is used to adjust the icons rectangle used to draw the event view icons.

Parameters
rc A CRect that contains the coordinates used to draw the view.
Returns
An integer denoting the width of the icon.

Call this member function to calculate rectangles used to draw event view icons depending on what glyphs must be drawn and based on the event view rect.

Reimplemented in CXTPCalendarWeekViewEvent.

◆ ChangeEventPlace()

virtual void ChangeEventPlace ( int nNewPlace )
virtual

This function is used to change the event place number.

Parameters
nNewPlace new event place number.

Reimplemented in CXTPCalendarDayViewEvent, and CXTPCalendarTimeLineViewEvent.

◆ Draw()

virtual void Draw ( CDC * pDC )
pure virtual

This member function is used to draw the view content using the specified device context.

Parameters
pDC A pointer to a valid device context.

Call AdjustLayout() before calling Draw(). This is a pure virtual function. This function must be defined in the derived class.

See also
AdjustLayout()

Implemented in CXTPCalendarDayViewEvent, CXTPCalendarMonthViewEvent, CXTPCalendarTimeLineViewEvent, and CXTPCalendarWeekViewEvent.

◆ EndEditSubject()

virtual CString EndEditSubject ( )
virtual

This member function is used to end the editing project, delete the subject editor, and to obtain the edited text.

Returns
A CString object containing the edited subject text.

◆ FormatEventTime()

virtual CString FormatEventTime ( COleDateTime dtTime ) const
virtual

This member function is used to format the event's time as a string with a predefined format.

Parameters
dtTime A COleDateTime time object that contains the value to format.
Returns
A CString object that contains the formatted time.

◆ GetCalendarControl()

virtual CXTPCalendarControl * GetCalendarControl ( ) const
virtual

Call this member function to obtain a pointer to the calendar control object.

Returns
A pointer to a CXTPCalendarControl object.

◆ GetEditingSubjectFromEditor()

virtual CString GetEditingSubjectFromEditor ( ) const
virtual

Call this member function to obtain an edited subject.

Returns
A CString object containing the edited subject.

◆ GetEndTimeRect()

AFX_INLINE CRect GetEndTimeRect ( ) const
virtual

This member function is used to obtain the rectangle coordinates for displaying a clock to show the end event time for single day events.

Returns
A CRect object containing the clocks rectangle.

◆ GetEvent()

AFX_INLINE CXTPCalendarEvent * GetEvent ( ) const
virtual

Call this member function to obtain the corresponding read only event object without increasing the object's reference counter.

Returns
A pointer to a CXTPCalendarEvent object.

◆ GetEventPlaceNumber()

AFX_INLINE int GetEventPlaceNumber ( ) const
virtual

This member function is used to obtain the place number of the event view.

Returns
An int that contains the event's view place number.

◆ GetEventRect()

AFX_INLINE CRect GetEventRect ( ) const

This member function is used to obtain the event view's bounding rectangle.

Use this member function to obtain the event view's bounding rectangle coordinates.

Returns
A CRect object with the bounding rectangle's coordinates.

◆ GetEventTimelinePlaceNumber()

AFX_INLINE int GetEventTimelinePlaceNumber ( ) const
virtual

This member function is used to obtain the place number of the event in Timeline view.

Returns
An int that contains the event's place number in Timeline view.

◆ GetFirstClockRect()

AFX_INLINE CRect GetFirstClockRect ( ) const
virtual

This member function is used to obtain the rectangle coordinates used for drawing a clock in the beginning of a multi day event.

Returns
A CRect object containing the clocks rectangle coordinates.

◆ GetItemText()

virtual CString GetItemText | ( | DWORD | dwItemFlag,
 |  | LPCTSTR | pcszDefaultText = NULL ) const
 virtual

Call this function to get the item text.

Parameters
dwItemFlag | [in] Flags from enum XTPCalendarGetItemText which specify event item.
pcszDefaultText | [in] Pointer to default item text or NULL to generate default text automatically.
Returns
A CString denoting the item text.

This is a virtual function.

◆ GetItemTextBody()

virtual CString GetItemTextBody ( ) const
virtual

Call this function to get the item body.

Returns
A CString denoting the item body.

This is a virtual function.

◆ GetItemTextEndTime()

virtual CString GetItemTextEndTime ( ) const
virtual

Call this function to get the item end time.

Returns
A CString denoting the item end time.

This is a virtual function.

◆ GetItemTextLocation()

virtual CString GetItemTextLocation ( ) const
virtual

Call this function to get the item location.

Returns
A CString denoting the item location.

This is a virtual function.

◆ GetItemTextStartTime()

virtual CString GetItemTextStartTime ( ) const
virtual

Call this function to get the item start time.

Returns
A CString denoting the item start time.

This is a virtual function.

◆ GetItemTextSubject()

virtual CString GetItemTextSubject ( ) const
virtual

Call this function to get the item subject.

Returns
A CString denoting the subject.

This is a virtual function.

◆ GetLastClockRect()

AFX_INLINE CRect GetLastClockRect ( ) const
virtual

This member function is used to obtain the rectangle coordinates used for drawing a clock in the end of a multi-day event.

Returns
A CRect object containing the clock's rectangle.

◆ GetMarkupText()

virtual CString GetMarkupText ( ) const
virtual

This member function is used to obtain markup template text.

It internally calls GetItemText to replace markup template parameters: [ul] [li] /Calendar/Events/Event/Subject [li] /Calendar/Events/Event/Location [li] /Calendar/Events/Event/Body [li] /Calendar/Events/Event/StartTime [li] /Calendar/Events/Event/EndTime

Returns
String with prepared markup text.

◆ GetMarkupUIElement()

virtual CXTPMarkupUIElement * GetMarkupUIElement ( )
virtual

This member function is used to get a stored CXTPMarkupUIElement object.

Returns
A pointer to a CXTPMarkupUIElement object.

◆ GetMeetingGlyphRect()

AFX_INLINE CRect GetMeetingGlyphRect ( ) const
virtual

This member function obtains the rectangle coordinates for displaying the meeting icon.

Returns
A CRect object containing the glyph rectangle.

◆ GetMultiDayEventFlags()

AFX_INLINE int GetMultiDayEventFlags ( ) const
virtual

This member function is used to obtain the multi-day event state flags.

Returns
An int that contains the event state flags.
See also
XTPCalendarMultiDayEventFlags

◆ GetPrivateGlyphRect()

AFX_INLINE CRect GetPrivateGlyphRect ( ) const
virtual

This member function is used to obtain the rectangle coordinates used for displaying the private icon.

Returns
A CRect object containing the glyph rectangle.

◆ GetRecurrenceGlyphRect()

AFX_INLINE CRect GetRecurrenceGlyphRect ( ) const
virtual

This member function is used to obtain the rectangle coordinates used for displaying the recurrence icon.

Returns
A CRect object containing the glyph rectangle.

◆ GetReminderGlyphRect()

AFX_INLINE CRect GetReminderGlyphRect ( ) const
virtual

This member function is used to obtain the rectangle coordinates for displaying the remainder icon.

Returns
A CRect object containing the glyph rectangle.

◆ GetShowToolTipTimeOut()

AFX_INLINE UINT GetShowToolTipTimeOut ( ) const
virtual

This member function is used to obtain the timeout value for displaying a tooltip.

Returns
A UINT that contains the value of the timeout in milliseconds.

◆ GetStartTimeRect()

AFX_INLINE CRect GetStartTimeRect ( ) const
virtual

This member function is used to obtain the rectangle coordinates used for displaying a clock to show the start event time for single day events.

Returns
A CRect object containing the clocks rectangle.

◆ GetSubjectEditor()

AFX_INLINE CWnd * GetSubjectEditor ( ) const
virtual

This member function is used to obtain the event's subject editor window.

Returns
A pointer to the CWnd or NULL.

◆ GetSubjectEditorFont()

AFX_INLINE CFont * GetSubjectEditorFont ( ) const
virtual

This member function is used to obtain a pointer to the editor window font.

Returns
A pointer to a CFont object that contains the editor window font.

Reimplemented in CXTPCalendarDayViewEvent, CXTPCalendarMonthViewEvent, and CXTPCalendarWeekViewEvent.

◆ GetSubjectEditorRect()

AFX_INLINE CRect GetSubjectEditorRect ( ) const
virtual

This member function is used to obtain the subject editor rectangle coordinates.

Returns
A CRect object containing the subject editor rectangle coordinates.

◆ GetSubjectEditorStyles()

AFX_INLINE DWORD GetSubjectEditorStyles ( ) const
virtual

This member function is used to obtain the styles of the editor window.

Returns
A DWORD that contains the value of the window styles.

Reimplemented in CXTPCalendarDayViewEvent.

◆ GetTextRect()

AFX_INLINE CRect GetTextRect ( ) const
virtual

This member function is used to obtain the rectangle coordinates used for displaying the event's subject.

Returns
A CRect object containing the text rectangle.

◆ GetToolText()

virtual CString GetToolText ( )
protectedvirtual

This member function is used to obtain tooltip text for the event view.

Returns
A CString object containing the tooltip text.

◆ GetViewEventRect()

AFX_INLINE CRect GetViewEventRect ( ) const
virtual

This member function is used to obtain the rectangle coordinates for the event's rectangle.

Returns
A CRect object containing the event's rectangle.

◆ GetViewEventRectMax()

AFX_INLINE CRect GetViewEventRectMax ( ) const
virtual

This member function is used to obtain the rectangle coordinates for the event's maximum rectangle dimensions.

Returns
A CRect object containing the event's maximum rectangle dimensions.

◆ GetViewGroup_()

virtual CXTPCalendarViewGroup * GetViewGroup_ ( ) const
pure virtual

Call this member function to obtain a pointer to the containing CXTPCalendarViewDay object.

Returns
A pointer to the CXTPCalendarViewDay object.

Implemented in CXTPCalendarTimeLineViewEvent, CXTPCalendarViewEventT< _TViewGroup >, CXTPCalendarViewEventT< CXTPCalendarDayViewGroup >, CXTPCalendarViewEventT< CXTPCalendarMonthViewGroup >, and CXTPCalendarViewEventT< CXTPCalendarWeekViewGroup >.

◆ HitTest()

virtual BOOL HitTest | ( | CPoint | pt,
 |  | XTP_CALENDAR_HITTESTINFO * | pHitTest ) const
 virtual

This member function is used to determine which view item, if any, is at the specified position index, and returns additional info in the XTP_CALENDAR_HITTESTINFO struct.

Parameters
pt | A CPoint that contains the coordinates of the point to test.
pHitTest | A pointer to an XTP_CALENDAR_HITTESTINFO structure.
Returns
A BOOL. TRUE if the item is found. FALSE otherwise.
See also
XTP_CALENDAR_HITTESTINFO

Reimplemented in CXTPCalendarTimeLineViewEvent.

◆ HitTestEx()

virtual BOOL HitTestEx | ( | CPoint | pt,
 |  | XTP_CALENDAR_HITTESTINFO * | pHitTest ) const
 pure virtual

This member function is used to determine which view item, if any, is at a specified position index, and returns additional info in an XTP_CALENDAR_HITTESTINFO template parameter.

Parameters
pt | A CPoint that contains the coordinates of the point to test.
pHitTest | A pointer to a XTP_CALENDAR_HITTESTINFO. Template parameter specifies the type of HitTest info structure.
Returns
TRUE if item is found. FALSE otherwise.
See also
XTP_CALENDAR_HITTESTINFO

Implemented in CXTPCalendarDayViewEvent, CXTPCalendarMonthViewEvent, CXTPCalendarTimeLineViewEvent, and CXTPCalendarWeekViewEvent.

◆ IsEditingSubject()

AFX_INLINE BOOL IsEditingSubject ( ) const
virtual

Call this member function to determine if the event's subject is currently being edited.

Returns
A BOOL. TRUE if the subject is being edited. FALSE otherwise.

◆ IsMultidayEvent()

virtual BOOL IsMultidayEvent ( ) const
virtual

Call this member function to determine if the given event view is a multi-day event.

Returns
A BOOL. TRUE if the event view is a multi-day event. FALSE otherwise.

Reimplemented in CXTPCalendarDayViewEvent.

◆ IsMultyDayTextAlign()

AFX_INLINE BOOL IsMultyDayTextAlign ( ) const
virtual

This member function is used to obtain the flag to determine if multi-day text align mode is on.

Multi-day text align mode means that all event items align to the center.

Returns
A BOOL. TRUE if multi-day text align mode is on. FALSE otherwise.

◆ IsSelected()

virtual BOOL IsSelected ( ) const
virtual

Call this member function to determine if the given event view is selected.

Returns
A BOOL. TRUE if the event view is selected. FALSE otherwise.
See also
SetSelected(bSet)

Reimplemented in CXTPCalendarTimeLineViewEvent.

◆ IsShowingToolTip()

virtual BOOL IsShowingToolTip ( )
virtual

Call this member function to determine if the event's tooltip is visible.

Returns
A BOOL. TRUE if the subject is visible. FALSE otherwise.

◆ IsTextOutOfBorders()

AFX_INLINE BOOL IsTextOutOfBorders ( ) const
virtual

This member function is used to determine if the text size exceeds the event view bounds.

Returns
A BOOL. TRUE if text size exceeds the event view bounds. FALSE otherwise.

◆ IsVisible()

virtual BOOL IsVisible ( ) const
pure virtual

Call this member function to determine if this event view is visible on the screen.

This is a pure virtual function. This function must be defined in the derived class.

Returns
A BOOL. TRUE if the event view is visible. FALSE otherwise.

Implemented in CXTPCalendarDayViewEvent, CXTPCalendarMonthViewEvent, CXTPCalendarTimeLineViewEvent, and CXTPCalendarWeekViewEvent.

◆ KillTimer()

virtual void KillTimer ( UINT uTimerID )
virtual

This member function is used to destroy a timer event.

Parameters
uTimerID A UINT that specifies the identifier of the timer.

For the derived classes. This member function should return TRUE if successful. FALSE otherwise.

◆ OnLButtonDblClk()

virtual BOOL OnLButtonDblClk | ( | UINT | nFlags,
 |  | CPoint | point )
 virtual

This member function is used to process left mouse button double click events.

Parameters
nFlags | An int that indicates whether various virtual keys are down.
point | A CPoint object that specifies the x- and y- coordinates of the cursor. These coordinates are always relative to the upper-left corner of the window.

This method is called by the CalendarView when the user double clicks the left mouse button.

Returns
TRUE if the message is handled properly, FALSE otherwise.

Reimplemented from CXTPCalendarWMHandler.

◆ OnLButtonDown()

virtual BOOL OnLButtonDown | ( | UINT | nFlags,
 |  | CPoint | point )
 virtual

This member function is used to process left mouse button down events.

Parameters
nFlags | An int that indicates whether various virtual keys are down.
point | A CPoint object that specifies the x- and y- coordinates of the cursor. These coordinates are always relative to the upper-left corner of the window.
Returns
TRUE if the message is handled properly, FALSE otherwise.

This method is called by the CalendarView when the user presses the left mouse button.

Reimplemented from CXTPCalendarWMHandler.

◆ OnLButtonUp()

virtual BOOL OnLButtonUp | ( | UINT | nFlags,
 |  | CPoint | point )
 virtual

This member function is used to process left mouse button up events.

Parameters
nFlags | An int that indicates whether various virtual keys are down.
point | A CPoint object that specifies the x- and y- coordinates of the cursor. These coordinates are always relative to the upper-left corner of the window.
Returns
TRUE if the message is handled properly, FALSE otherwise.

This method is called by the CalendarView when the user releases the left mouse button.

Reimplemented from CXTPCalendarWMHandler.

◆ OnMouseMove()

virtual void OnMouseMove | ( | UINT | nFlags,
 |  | CPoint | point )
 virtual

This member function is used to process mouse movement events.

Parameters
nFlags | A UINT that indicates whether various virtual keys are down.
point | A CPoint that specifies the x- and y- coordinate of the cursor. These coordinates are always relative to the upper-left corner of the window.

This method is called by the CalendarViewGroup when the user moves the mouse cursor or stylus.

Reimplemented from CXTPCalendarWMHandler.

◆ OnPostAdjustLayout()

virtual void OnPostAdjustLayout ( )
virtual

This member function is used to perform additional adjustments in some kinds of views.

Call this member function to perform additional adjustments after all adjustment activities are completed.

Reimplemented from CXTPCalendarWMHandler.

Reimplemented in CXTPCalendarDayViewEvent, CXTPCalendarMonthViewEvent, and CXTPCalendarWeekViewEvent.

◆ OnTimer()

virtual BOOL OnTimer ( UINT_PTR uTimerID )
virtual

The framework calls this member function after each interval specified in the SetTimer member function.

Parameters
uTimerID A UINT that specifies the identifier of the timer.
Returns
A BOOL. TRUE if successful. FALSE otherwise.

Reimplemented from CXTPCalendarWMHandler.

◆ OnWndMsg()

virtual BOOL OnWndMsg | ( | UINT | message,
 |  | WPARAM | wParam,
 |  | LPARAM | lParam,
 |  | LRESULT * | pResult )
 virtual

This method is called by framework after default message processing.

Parameters
message | Specifies the message to be sent.
wParam | Specifies additional message-dependent information.
lParam | Specifies additional message-dependent information.
pResult | The return value of WindowProc. Depends on the message; may be NULL.
Returns
TRUE if the message is handled properly, FALSE otherwise.

Reimplemented from CXTPCalendarWMHandler.

◆ SetMultiDayEvent_MasterSlave()

virtual void SetMultiDayEvent_MasterSlave | ( | BOOL | bMaster,
 |  | CXTPCalendarViewEvent * | pMasterView )
 virtual

This member function is used to set the multi-day event Master/Slave state.

Parameters
bMaster | A BOOL. Used to indicate Master or Slave state. TRUE if in the Master state. FALSE if in the Slave state.
pMasterView | A CXTPCalendarViewEvent pointer to the Master event view object.

Master/Slave states are used to draw a multi-day event. Such events are drawn not as a few events for a few days, but as one big event for a few days, or a few big events for a few days. For this purposes, the first event view in the chain is marked as Master and other events views in this chain are marked as Slave. Event view's chain is the set of events views which can be drawn continuously in the one row. On adjust layout process width of the Master event view, rect is extended to cover the last Slave event view rect in the chain and only the master event view is drawn because it covers Slave events views too. Slave events' views look hidden and they are used for adjusting process (to reserve place on the screen and for other purposes). One multi-day event can have few Master events. This depends on screen positions of days event parts.

See also
AddMultiDayEvent_Slave

◆ SetSelected()

virtual void SetSelected ( BOOL bSet = TRUE )
virtual

This member function is used to set the day view as select or unselected.

Parameters
bSet A BOOL. If TRUE, then set the flag as selected. Otherwise, set the flag as unselected.
See also
IsSelected()

◆ SetTextOutOfBorders()

AFX_INLINE void SetTextOutOfBorders ( BOOL bOutOfBorders )
virtual

This member function is used to set a flag to determine if the text size exceeds the event view bounds.

Parameters
bOutOfBorders A BOOL. TRUE if the text is out of the borders. FALSE otherwise.

◆ SetTimer()

virtual UINT SetTimer ( UINT uTimeOut_ms )
virtual

This member function is used to create a timer event.

Parameters
uTimeOut_ms A UINT that specifies the duration of the timer in milliseconds.
Returns
The identifier of the timer.

◆ StartEditSubject()

virtual CXTPCalendarViewEvent * StartEditSubject ( )
virtual

This member function is used to create and to show the subject editor.

Subject is created only for the Master event if the event is a multi-day event. If this member function is called for a slave event, then the editing process is passed to the master event.

Returns
A pointer to a CXTPCalendarViewEvent object for which editor is created.

Reimplemented in CXTPCalendarDayViewEvent.

Member Data Documentation

◆ m_bSelected

BOOL m_bSelected
protected

Event view selected flag.

◆ m_nEventPlaceNumber

int m_nEventPlaceNumber
protected

Event view place number (sequential identifier).

◆ m_nEventTimelinePlaceNumber

int m_nEventTimelinePlaceNumber
protected

Event view place number in Timeline view.

◆ m_nMultiDayEventFlags

int m_nMultiDayEventFlags

Multi-day event flags packed into integer by bitwise operations.

protected:

◆ m_pMasterView

CXTPCalendarViewEvent* m_pMasterView
protected

Pointer to Master event view object.

◆ m_ptrEvent

CXTPCalendarEvent* m_ptrEvent
protected

Pointer to the displayed event object.

The documentation for this class was generated from the following file:
  • XTPCalendarViewEvent.h


Toolkit Pro: CXTPCalendarViewEvents Class Reference

Public Member Functions | List of all members
CXTPCalendarViewEvents Class Reference

This class is used as a collection of Event View objects. More...

Inheritance diagram for CXTPCalendarViewEvents:
[legend]

Public Member Functions

CXTPCalendarViewEvents ()
Default class constructor.
virtual | ~CXTPCalendarViewEvents ()
Default class destructor.
virtual int | Find (const CXTPCalendarEvent *pEvent) const
This member function finds the first event view index in the collection using event object.
virtual void | Remove (CXTPCalendarEvent *pEvent)
This member function finds all event views for an event object and removes them from the array.
- Public Member Functions inherited from CXTPCalendarPtrCollectionT< CXTPCalendarViewEvent >
CXTPCalendarPtrCollectionT ()
Default collection constructor.
virtual | ~CXTPCalendarPtrCollectionT ()
Default collection destructor.
virtual int | GetCount () const
This member function is used to obtain the number of elements in the collection.
virtual void | Add (CXTPCalendarViewEvent *pNewElement)
This member function adds a new element to the end of the array.
virtual void | Add (CXTPCalendarViewEvent *pNewElement, BOOL bWithAddRef)
This member function adds a new element to the end of the array.
virtual void | SetAt (int nIndex, CXTPCalendarViewEvent *pElement)
This member function is used to set a new element to the position specified in the nIndex parameter.
virtual int | Find (const CXTPCalendarViewEvent *pElement) const
This member function finds an element index in the collection using its pointer.
virtual void | InsertAt (int nIndex, CXTPCalendarViewEvent *pElement)
This member function is used to insert a new element at the position specified in the nIndex parameter.
virtual void | Append (const CXTPCalendarPtrCollectionT< CXTPCalendarViewEvent > *pElementsArray)
This member function is used to add a new elements to the end of the array.
virtual void | SetSize (int nNewSize)
This member function is used to change the array size.
virtual CXTPCalendarViewEvent * | GetAt (int nIndex) const
This member function returns an element at the specified numeric index.
virtual CXTPCalendarViewEvent * | GetAt (int nIndex, BOOL bWithAddRef) const
This member function returns an element at the specified numeric index.
virtual void | RemoveAt (int nIndex)
This member function removes an element at the specified index from the array.
virtual void | Remove (CXTPCalendarViewEvent *pElement)
This member function finds an element using its pointer and removes it from the array.
virtual void | RemoveAll ()
This member function is used to remove all of the elements from the array.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Types inherited from CXTPCalendarPtrCollectionT< CXTPCalendarViewEvent >
typedef CXTPSmartPtrInternalT< CXTPCalendarViewEvent > | TObjectPtr
Smart pointer type for stored objects.
- Protected Attributes inherited from CXTPCalendarPtrCollectionT< CXTPCalendarViewEvent >
CArray< TObjectPtr, TObjectPtr & > | m_arElements
Objects storage.

Detailed Description

This class is used as a collection of Event View objects.

See also
CXTPCalendarPtrCollectionT

Member Function Documentation

◆ Find()

virtual int Find ( const CXTPCalendarEvent * pEvent ) const
virtual

This member function finds the first event view index in the collection using event object.

Parameters
pEvent - A pointer to a CXTPCalendarEvent object.
Returns
-1 if event view is not found, otherwise an integer index that is greater than or equal to 0 and less than the value returned by GetCount.

◆ Remove()

virtual void Remove ( CXTPCalendarEvent * pEvent )
virtual

This member function finds all event views for an event object and removes them from the array.

Parameters
pEvent A pointer to a CXTPCalendarEvent object.
The documentation for this class was generated from the following file:
  • XTPCalendarViewEvent.h


Toolkit Pro: CXTPCalendarViewEventSubjectEditor Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPCalendarViewEventSubjectEditor Class Reference

This class is used to edit an event subject. More...

Inheritance diagram for CXTPCalendarViewEventSubjectEditor:
[legend]

Public Member Functions

CXTPCalendarViewEventSubjectEditor (CXTPCalendarControl *pOwner)
Default object constructor.
virtual ~CXTPCalendarViewEventSubjectEditor ()
Default class destructor.

Protected Attributes

CXTPCalendarControl * m_pOwner
Stored pointer to the owner calendar control object.

Detailed Description

This class is used to edit an event subject.

All massages received by this window are sent to the parent calendar control before they are processed. Some of them are handled by parent calendar control object.

See also
CXTPCalendarControl::OnWndMsg_Children()

Constructor & Destructor Documentation

◆ CXTPCalendarViewEventSubjectEditor()

CXTPCalendarViewEventSubjectEditor ( CXTPCalendarControl * pOwner )

Default object constructor.

Parameters
pOwner A pointer to an owner calendar control object.
See also
~CXTPCalendarViewEventSubjectEditor()
The documentation for this class was generated from the following file:
  • XTPCalendarViewEvent.h


Toolkit Pro: CXTPCalendarViewEventSubjectEditorColored Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPCalendarViewEventSubjectEditorColored Class Reference

This class is used to edit event subject in Office 2007 Theme. More...

Inheritance diagram for CXTPCalendarViewEventSubjectEditorColored:
[legend]

Public Member Functions

CXTPCalendarViewEventSubjectEditorColored (CXTPCalendarControl *pOwner, CXTPCalendarViewEvent *pViewEvent, COLORREF clrBackground)
Default object constructor.
virtual | ~CXTPCalendarViewEventSubjectEditorColored ()
Default class destructor.
- Public Member Functions inherited from CXTPCalendarViewEventSubjectEditor
CXTPCalendarViewEventSubjectEditor (CXTPCalendarControl *pOwner)
Default object constructor.
virtual | ~CXTPCalendarViewEventSubjectEditor ()
Default class destructor.

Protected Attributes

CXTPCalendarViewEvent * | m_pViewEvent
Stored pointer to the editing event object.
CXTPPaintManagerColorGradient | m_grclrBk
Subject Editor background color (or gradient colors).
- Protected Attributes inherited from CXTPCalendarViewEventSubjectEditor
CXTPCalendarControl * | m_pOwner
Stored pointer to the owner calendar control object.

Detailed Description

This class is used to edit event subject in Office 2007 Theme.

This class is derived from the CXTPCalendarViewEventSubjectEditor and draw editor background in Office 2007 Theme event object style or use no background (transparent background).

See also
CXTPCalendarViewEventSubjectEditor

Constructor & Destructor Documentation

◆ CXTPCalendarViewEventSubjectEditorColored()

CXTPCalendarViewEventSubjectEditorColored | ( | CXTPCalendarControl * | pOwner,
 |  | CXTPCalendarViewEvent * | pViewEvent,
 |  | COLORREF | clrBackground )

Default object constructor.

Parameters
pOwner | A pointer to an owner calendar control object.
pViewEvent | A pointer to an editing event view object.
clrBackground | A COLORREF value that represents the background color
See also
~CXTPCalendarViewEventSubjectEditor2007()
The documentation for this class was generated from the following file:
  • XTPCalendarViewEvent.h


Toolkit Pro: CXTPCalendarViewEventT< _TViewGroup > Class Template Reference

Public Member Functions | List of all members
CXTPCalendarViewEventT< _TViewGroup > Class Template Reference

This class is used to build the ViewEvent layer of the DayView and ViewEvent hierarchies. More...

Inheritance diagram for CXTPCalendarViewEventT< _TViewGroup >:
[legend]

Public Member Functions

CXTPCalendarViewEventT (CXTPCalendarEvent *pEvent, _TViewGroup *pViewGroup)
Default object constructor.
virtual | ~CXTPCalendarViewEventT ()
Default class destructor.
virtual CXTPCalendarViewGroup * | GetViewGroup_ () const
This member function is used to obtain a base CXTPCalendarViewGroup* pointer to a corresponding DayView object.
_TViewGroup * | GetViewGroup () const
This member function is used to obtain a pointer to a DayView object.
- Public Member Functions inherited from CXTPCalendarViewEvent
CXTPCalendarViewEvent (CXTPCalendarEvent *pEvent, CXTPCalendarViewGroup *pViewGroup)
Default object constructor.
virtual | ~CXTPCalendarViewEvent ()
Default class destructor.
virtual BOOL | HitTest (CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const
This member function is used to determine which view item, if any, is at the specified position index, and returns additional info in the XTP_CALENDAR_HITTESTINFO struct.
virtual CXTPCalendarEvent * | GetEvent () const
Call this member function to obtain the corresponding read only event object without increasing the object's reference counter.
virtual CXTPCalendarControl * | GetCalendarControl () const
Call this member function to obtain a pointer to the calendar control object.
virtual BOOL | IsVisible () const =0
Call this member function to determine if this event view is visible on the screen.
virtual BOOL | IsSelected () const
Call this member function to determine if the given event view is selected.
virtual void | SetSelected (BOOL bSet=TRUE)
This member function is used to set the day view as select or unselected.
virtual BOOL | IsMultidayEvent () const
Call this member function to determine if the given event view is a multi-day event.
virtual CXTPCalendarViewEvent * | StartEditSubject ()
This member function is used to create and to show the subject editor.
virtual CString | GetEditingSubjectFromEditor () const
Call this member function to obtain an edited subject.
virtual CString | EndEditSubject ()
This member function is used to end the editing project, delete the subject editor, and to obtain the edited text.
virtual void | ShowToolTip ()
This member function is used to show a ToolTip rectangle.
virtual void | HideToolTip ()
This member function is used to hide the ToolTip rectangle.
virtual BOOL | IsEditingSubject () const
Call this member function to determine if the event's subject is currently being edited.
virtual CRect | GetSubjectEditorRect () const
This member function is used to obtain the subject editor rectangle coordinates.
virtual CWnd * | GetSubjectEditor () const
This member function is used to obtain the event's subject editor window.
virtual BOOL | IsShowingToolTip ()
Call this member function to determine if the event's tooltip is visible.
virtual CString | FormatEventTime (COleDateTime dtTime) const
This member function is used to format the event's time as a string with a predefined format.
virtual CRect | GetFirstClockRect () const
This member function is used to obtain the rectangle coordinates used for drawing a clock in the beginning of a multi day event.
virtual CRect | GetLastClockRect () const
This member function is used to obtain the rectangle coordinates used for drawing a clock in the end of a multi-day event.
virtual CRect | GetTextRect () const
This member function is used to obtain the rectangle coordinates used for displaying the event's subject.
virtual CRect | GetStartTimeRect () const
This member function is used to obtain the rectangle coordinates used for displaying a clock to show the start event time for single day events.
virtual CRect | GetEndTimeRect () const
This member function is used to obtain the rectangle coordinates for displaying a clock to show the end event time for single day events.
virtual CRect | GetViewEventRect () const
This member function is used to obtain the rectangle coordinates for the event's rectangle.
virtual CRect | GetViewEventRectMax () const
This member function is used to obtain the rectangle coordinates for the event's maximum rectangle dimensions.
virtual CRect | GetReminderGlyphRect () const
This member function is used to obtain the rectangle coordinates for displaying the remainder icon.
virtual CRect | GetRecurrenceGlyphRect () const
This member function is used to obtain the rectangle coordinates used for displaying the recurrence icon.
virtual CRect | GetMeetingGlyphRect () const
This member function obtains the rectangle coordinates for displaying the meeting icon.
virtual CRect | GetPrivateGlyphRect () const
This member function is used to obtain the rectangle coordinates used for displaying the private icon.
virtual BOOL | IsMultyDayTextAlign () const
This member function is used to obtain the flag to determine if multi-day text align mode is on.
virtual int | GetMultiDayEventFlags () const
This member function is used to obtain the multi-day event state flags.
virtual void | SetMultiDayEvent_MasterSlave (BOOL bMaster, CXTPCalendarViewEvent *pMasterView)
This member function is used to set the multi-day event Master/Slave state.
virtual void | AddMultiDayEvent_Slave (CXTPCalendarViewEvent *pSlaveView, int nMasterEventPlace)
This member function is used to add a Slave event view to the Master event view.
virtual void | SetTextOutOfBorders (BOOL bOutOfBorders)
This member function is used to set a flag to determine if the text size exceeds the event view bounds.
virtual BOOL | IsTextOutOfBorders () const
This member function is used to determine if the text size exceeds the event view bounds.
virtual int | GetEventPlaceNumber () const
This member function is used to obtain the place number of the event view.
virtual int | GetEventTimelinePlaceNumber () const
This member function is used to obtain the place number of the event in Timeline view.
CRect | GetEventRect () const
This member function is used to obtain the event view's bounding rectangle.
virtual void | AdjustLayout (CDC *pDC, const CRect &rcEventMax, int nEventPlaceNumber)
This member function is used to adjust the view's layout depending on the provided rectangle and calls AdjustLayout() for all sub-items.
virtual void | AdjustLayout2 (CDC *pDC, const CRect &rcEventMax, int nEventPlaceNumber)=0
This member function is used to adjust the view's layout when theme is set depending on the provided rectangle and calls AdjustLayout() for all sub-items.
virtual void | OnPostAdjustLayout ()
This member function is used to perform additional adjustments in some kinds of views.
virtual void | Draw (CDC *pDC)=0
This member function is used to draw the view content using the specified device context.
virtual void | AdjustSubjectEditor ()
This member function is used to perform adjustments of the subject editor area.
virtual CString | GetItemTextSubject () const
Call this function to get the item subject.
virtual CString | GetItemTextLocation () const
Call this function to get the item location.
virtual CString | GetItemTextBody () const
Call this function to get the item body.
virtual CString | GetItemTextStartTime () const
Call this function to get the item start time.
virtual CString | GetItemTextEndTime () const
Call this function to get the item end time.
virtual CString | GetItemText (DWORD dwItemFlag, LPCTSTR pcszDefaultText=NULL) const
Call this function to get the item text.
virtual CString | GetMarkupText () const
This member function is used to obtain markup template text.
virtual CXTPMarkupUIElement * | GetMarkupUIElement ()
This member function is used to get a stored CXTPMarkupUIElement object.
virtual BOOL | HitTestEx (CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const =0
This member function is used to determine which view item, if any, is at a specified position index, and returns additional info in an XTP_CALENDAR_HITTESTINFO template parameter.
virtual int | CalcIconsRect (CRect rc)
This member function is used to adjust the icons rectangle used to draw the event view icons.
virtual BOOL | OnLButtonDown (UINT nFlags, CPoint point)
This member function is used to process left mouse button down events.
virtual BOOL | OnLButtonUp (UINT nFlags, CPoint point)
This member function is used to process left mouse button up events.
virtual BOOL | OnLButtonDblClk (UINT nFlags, CPoint point)
This member function is used to process left mouse button double click events.
virtual void | OnMouseMove (UINT nFlags, CPoint point)
This member function is used to process mouse movement events.
virtual BOOL | OnWndMsg (UINT message, WPARAM wParam, LPARAM lParam, LRESULT *pResult)
This method is called by framework after default message processing.
virtual UINT | SetTimer (UINT uTimeOut_ms)
This member function is used to create a timer event.
virtual void | KillTimer (UINT uTimerID)
This member function is used to destroy a timer event.
virtual BOOL | OnTimer (UINT_PTR uTimerID)
The framework calls this member function after each interval specified in the SetTimer member function.
virtual UINT | GetShowToolTipTimeOut () const
This member function is used to obtain the timeout value for displaying a tooltip.
virtual DWORD | GetSubjectEditorStyles () const
This member function is used to obtain the styles of the editor window.
virtual CFont * | GetSubjectEditorFont () const
This member function is used to obtain a pointer to the editor window font.
virtual void | ChangeEventPlace (int nNewPlace)
This function is used to change the event place number.
virtual void | OnBeforeDestroy ()
Called by the framework before the destroy() function is called.
- Public Member Functions inherited from CXTPCalendarWMHandler
CXTPCalendarWMHandler ()
Default object constructor.
virtual int | GetChildHandlersCount () const
This member function is used to obtain the number of CXTPCalendarWMHandler elements in the descendant handlers collection.
virtual CXTPCalendarWMHandler * | GetChildHandlerAt (int nIndex) const
Call this method to get a handler object at the specified numeric index.
virtual void | OnChar (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process keyboard events.
virtual void | OnKeyDown (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process key-down keyboard events.
virtual void | OnKeyUp (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process key-up keyboard events.
virtual BOOL | OnSysKeyDown (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process key-up keyboard events.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCalendarViewEvent
static void AFX_CDECL | _MoveRectY (int nYbasePrev, int nYbaseNew, CRect &rRC)
This member function is used to move the rectangle vertically.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPCalendarViewEvent
CRect | m_rcEvent
Event view rectangle.
CRect | m_rcEventMax
Event view rectangle margins.
CRect | m_rcText
Rectangle to display event text in event view.
CSize | m_szText
Sizes of displayed text.
CRect | m_rcFirstClock
Rectangle to draw clock in the beginning of the first day of multi-day event.
CRect | m_rcLastClock
Rectangle to draw clock at the end of the last day of multi-day event.
CRect | m_rcStartTime
Rectangle to display start time day event view.
CRect | m_rcEndTime
Rectangle to display end time event view.
int | m_nMultiDayEventFlags
Multi-day event flags packed into integer by bitwise operations.
CRect | m_rcReminderGlyph
Rectangle to draw reminder glyph event view.
CRect | m_rcRecurrenceGlyph
Rectangle to draw recurrence glyph event view.
CRect | m_rcMeetingGlyph
Rectangle to draw meeting glyph event view.
CRect | m_rcPrivateGlyph
Rectangle to draw private glyph event view.
CRect | m_rcSubjectEditor
Subject editor rectangle.
CRect | m_rcToolTip
Tool tip rectangle.
CXTPMarkupUIElement * | m_pUIElement
Store pointer to CXTPMarkupUIElement object.
CString | m_strUIElementText
Store last markup text for which m_pUIElement object was updated.
- Protected Member Functions inherited from CXTPCalendarViewEvent
virtual void | AdjustMultidayEvent (CRect rcEventMax, int nEventPlaceNumber)
This member function is used to adjust a multi-day view's layout depending on the provided rectangle coordinates.
virtual CString | GetToolText ()
This member function is used to obtain tooltip text for the event view.
- Protected Attributes inherited from CXTPCalendarViewEvent
CXTPCalendarEvent * m_ptrEvent
Pointer to the displayed event object.
BOOL | m_bSelected
Event view selected flag.
CXTPCalendarViewEvent * m_pMasterView
Pointer to Master event view object.
int | m_nEventPlaceNumber
Event view place number (sequential identifier).
int | m_nEventTimelinePlaceNumber
Event view place number in Timeline view.
UINT | m_nTimerID_ShowToolTip
Identifier of timer event to show tooltip with delay.
CXTPCalendarViewEventSubjectEditor * | m_pSubjectEditor
Pointer to the subject editor.
BOOL | m_bMultyDayTextAlign
Flag indicates special text alignment for a multi-day event.
BOOL | m_bTextOutOfBorders
Flag indicates text out of event borders.

Detailed Description

template<class _TViewGroup>
class CXTPCalendarViewEventT< _TViewGroup >

This class is used to build the ViewEvent layer of the DayView and ViewEvent hierarchies.

This class template customizes, overrides and implements some functionality for the CXTPCalendarViewEvent base class. It is used as a part of the calendar control framework to build ViewEvent layer of View->DayView->ViewEvent typed objects hierarchy. These are the template parameters: _TViewGroup - Type of View Day objects stored in View

 All of the above parameters are required.
See also
CXTPCalendarViewEvent

Constructor & Destructor Documentation

◆ CXTPCalendarViewEventT()

template<class _TViewGroup >
CXTPCalendarViewEventT | ( | CXTPCalendarEvent * | pEvent,
 |  | _TViewGroup * | pViewGroup )
 inline

Default object constructor.

Parameters
pEvent | Pointer to a CXTPCalendarEvent object.
pViewGroup | Template parameter specifies type of View Day object.
See also
~CXTPCalendarViewEventT()

Member Function Documentation

◆ GetViewGroup()

template<class _TViewGroup >
_TViewGroup * GetViewGroup ( ) const
inline

This member function is used to obtain a pointer to a DayView object.

Call this member function to obtain a pointer to a DayView object which stores the ViewEvent. The _TViewGroup template parameter is used to determine the type of the returned pointer.

Returns
A pointer to a DayView object, the type of the returned pointer is determined by the _TViewGroup template parameter.
See also
GetViewGroup_()

◆ GetViewGroup_()

template<class _TViewGroup >
virtual CXTPCalendarViewGroup * GetViewGroup_ ( ) const
inlinevirtual

This member function is used to obtain a base CXTPCalendarViewGroup* pointer to a corresponding DayView object.

Call this member function to obtain a pointer to a DayView object which stores the ViewEvent.

Returns
A pointer to a base CXTPCalendarViewGroup object.
See also
GetViewGroup()

Implements CXTPCalendarViewEvent.

The documentation for this class was generated from the following file:
  • XTPCalendarViewEvent.h


Toolkit Pro: CXTPCalendarViewGroup Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPCalendarViewGroup Class Referenceabstract

Regular schema: More...

Inheritance diagram for CXTPCalendarViewGroup:
[legend]

Public Member Functions

CXTPCalendarViewGroup (CXTPCalendarViewDay *pViewDay)
Default object constructor.
virtual | ~CXTPCalendarViewGroup ()
Default class destructor.
virtual CXTPCalendarResources * | GetResources () const
Obtain a pointer to a collection of Calendar Resources.
virtual CXTPCalendarData * | GetDataProvider () const
Returns data provider for this view group.
virtual void | AddResource (CXTPCalendarResource *pResource, BOOL bWithAddRef)
Adds a new Resource object into the collection of resources for this Group View.
virtual void | SetResources (CXTPCalendarResources *pResources)
Assigns a new Resources collection to this Group View.
virtual UINT | GetScheduleID () const
Returns default Schedule ID - the first existing one.
virtual void | Populate (COleDateTime dtDayDate)
This member function is used to populate the view with data for all items contained in the view.
virtual void | AdjustLayout (CDC *pDC, const CRect &rcGroup)
This member function is used to adjust the view's layout depending on the provided rectangle and then calls AdjustLayout() for all of the sub-items.
virtual void | AdjustLayout2 (CDC *pDC, const CRect &rcGroup)
This member function is used to adjust the view's layout depending on the provided rectangle and then calls AdjustLayout() for all of the sub-items.
virtual void | Draw (CDC *pDC)
This member function is used to draw the view contents using the specified device context.
virtual BOOL | HitTest (CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const
This member function is used to determine which view item, if any, is at the specified position index, and returns additional info in an XTP_CALENDAR_HITTESTINFO struct.
virtual BOOL | HitTestEx (CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const
This member function is used to determine which view item, if any, is at the specified position index, and returns additional info in the XTP_CALENDAR_HITTESTINFO template object.
virtual void | FillHitTestEx (XTP_CALENDAR_HITTESTINFO *pHitTest) const =0
This member function is used to fill the pHitTest structure members with the default values for the current day view object.
virtual CRect | GetRect () const
Call this member function to obtain the group's rectangle area.
virtual CRect | GetHeaderRect () const
Call this member function to obtain the group's header rectangle area.
virtual CRect | GetTooltipRect (const CPoint &ptHit, const XTP_CALENDAR_HITTESTINFO &hitInfo) const
Call this member function to obtain the bounding rectangle of the tooltip space (currently this is only "click to add new appointment").
int | GetViewEventsCount () const
Call this member function to obtain the number of event views in the day view collection.
CXTPCalendarViewEvent * | GetViewEvent_ (int nIndex) const
Call this member function to obtain a pointer to a CXTPCalendarViewEvent object associated with the event's index.
CXTPCalendarViewDay * | GetViewDay_ () const
Call this member function to obtain a pointer to the containing CXTPCalendarViewDay object.
virtual int | GetGroupIndex () const
This member function is used to obtain the index of the "this" pointer Group View in the Calendar Day View.
virtual CString | GetCaption () const
This member function is used to obtain a group's view caption.
virtual int | GetChildHandlersCount () const
This member function is used to obtain the number of event views elements in this Group View.
virtual CXTPCalendarWMHandler * | GetChildHandlerAt (int nIndex) const
Call this method to get an event view object at the specified numeric index.
virtual CXTPCalendarViewEvent * | GetViewEventByEvent_ (CXTPCalendarEvent *pEvent) const
Call this member function to obtain a pointer to a CXTPCalendarViewEvent object that is identified by the corresponding event object.
virtual CXTPCalendarViewEvent * | GetViewEventByPlace_ (int nEventPlace) const
Call this member function to obtain an event view object identified by its event place number.
virtual CXTPCalendarControl * | GetCalendarControl () const
Call this member function to obtain a pointer to the calendar control object.
virtual void | ExchangeEventPlace (CXTPCalendarViewEvent *pViewEvent, int nNewPlace)
This member function is used to exchange event view positions.
- Public Member Functions inherited from CXTPCalendarWMHandler
CXTPCalendarWMHandler ()
Default object constructor.
virtual BOOL | OnLButtonDown (UINT nFlags, CPoint point)
This member function is used to process left mouse button down events.
virtual BOOL | OnLButtonUp (UINT nFlags, CPoint point)
This member function is used to process left mouse button up events.
virtual BOOL | OnLButtonDblClk (UINT nFlags, CPoint point)
This member function is used to process left mouse button double click events.
virtual void | OnMouseMove (UINT nFlags, CPoint point)
This member function is used to process mouse movement events.
virtual void | OnChar (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process keyboard events.
virtual void | OnKeyDown (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process key-down keyboard events.
virtual void | OnKeyUp (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process key-up keyboard events.
virtual BOOL | OnSysKeyDown (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process key-up keyboard events.
virtual BOOL | OnTimer (UINT_PTR uTimerID)
The framework calls this member function after each interval specified in the SetTimer member function.
virtual BOOL | OnWndMsg (UINT message, WPARAM wParam, LPARAM lParam, LRESULT *pResult)
This method is called by framework after default message processing.
virtual void | OnPostAdjustLayout ()
This member function is used to perform additional adjustments in some kinds of views.
virtual void | OnBeforeDestroy ()
This member function is called by the framework before destroying the view.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

virtual UINT | SetTimer (UINT uTimeOut_ms)
This member function is used to create a timer event.
virtual void | KillTimer (UINT uTimerID)
This member function is used to destroy a timer event.
virtual void | OnPrePopulate (CXTPCalendarEvents *pEvents)
This member function is used to allow some customization before show events.

Protected Attributes

XTP_VIEW_GROUP_LAYOUT | m_Layout
This group view client coordinates.
CXTPCalendarPtrCollectionT< CXTPCalendarViewEvent > | m_arEvents
Storage for events views.
CXTPCalendarResources * | m_pResources
An associated resource object.
CXTPCalendarViewDay * | m_pViewDay
Parent day view.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

Regular schema:

  • CalendarView consists of CalendarView(s)Day
  • CalendarViewDay consists of CalendarView(s)Resource
  • CalendarViewGroup contains CalendarView(s)Event

ViewGroup draws a single resource depending on the type of parent day view.

Constructor & Destructor Documentation

◆ CXTPCalendarViewGroup()

CXTPCalendarViewGroup ( CXTPCalendarViewDay * pViewDay )

Default object constructor.

Constructs a CXTPCalendarViewGroup object.

Parameters
pViewDay An associated view day object pointer.
See also
~CXTPCalendarViewGroup()

◆ ~CXTPCalendarViewGroup()

virtual ~CXTPCalendarViewGroup ( )
virtual

Default class destructor.

Handles member item deallocation.

Member Function Documentation

◆ AddResource()

virtual void AddResource | ( | CXTPCalendarResource * | pResource,
 |  | BOOL | bWithAddRef )
 virtual

Adds a new Resource object into the collection of resources for this Group View.

Parameters
pResource | Pointer to the added CXTPCalendarResource object.
bWithAddRef | Set this value to TRUE to increment the reference count of the inserted object, FALSE to insert object without incrementing reference count.
See also
CXTPCalendarResources::Add

◆ AdjustLayout()

virtual void AdjustLayout | ( | CDC * | pDC,
 |  | const CRect & | rcGroup )
 virtual

This member function is used to adjust the view's layout depending on the provided rectangle and then calls AdjustLayout() for all of the sub-items.

Parameters
pDC | Pointer to a valid device context.
rcGroup | A CRect object that contains the rectangle coordinates that are used to draw the view.

Call Populate(COleDateTime dtDayDate) prior to calling AdjustLayout(). AdjustLayout2 is called by calendar control instead of AdjustLayout when theme is set.

Reimplemented in CXTPCalendarDayViewGroup, and CXTPCalendarTimeLineViewGroup.

◆ AdjustLayout2()

virtual void AdjustLayout2 | ( | CDC * | pDC,
 |  | const CRect & | rcGroup )
 virtual

This member function is used to adjust the view's layout depending on the provided rectangle and then calls AdjustLayout() for all of the sub-items.

Parameters
pDC | Pointer to a valid device context.
rcGroup | A CRect object that contains the rectangle coordinates that are used to draw the view.

Call Populate(COleDateTime dtDayDate) prior to calling AdjustLayout(). AdjustLayout2 is called by calendar control instead of AdjustLayout when theme is set.

Reimplemented in CXTPCalendarDayViewGroup.

◆ Draw()

virtual void Draw ( CDC * pDC )
virtual

This member function is used to draw the view contents using the specified device context.

Parameters
pDC A pointer to a valid device context.

Call AdjustLayout() before calling Draw().

See also
AdjustLayout(CRect rcGroup)

Reimplemented in CXTPCalendarDayViewGroup, and CXTPCalendarTimeLineViewGroup.

◆ ExchangeEventPlace()

virtual void ExchangeEventPlace | ( | CXTPCalendarViewEvent * | pViewEvent,
 |  | int | nNewPlace )
 virtual

This member function is used to exchange event view positions.

Parameters
pViewEvent | A pointer to a CXTPCalendarViewEvent object.
nNewPlace | An int that contains the new event view position.

Each event view has a unique position number for the day. In the simple case, this is the row number used to draw the event view. This function is used to avoid duplicating position numbers.

See also
CXTPCalendarViewEvent::ChangeEventPlace
CXTPCalendarViewEvent::GetEventPlaceNumber
CXTPCalendarViewEvent::AddMultiDayEvent_Slave
CXTPCalendarViewEvent::AdjustLayout

◆ FillHitTestEx()

virtual void FillHitTestEx ( XTP_CALENDAR_HITTESTINFO * pHitTest ) const
pure virtual

This member function is used to fill the pHitTest structure members with the default values for the current day view object.

Parameters
pHitTest A Pointer to an XTP_CALENDAR_HITTESTINFO structure.

This is a pure virtual function. This function must be defined in the derived class.

Implemented in CXTPCalendarDayViewGroup, CXTPCalendarMonthViewGroup, CXTPCalendarTimeLineViewGroup, CXTPCalendarViewGroupT< _TViewDay, _TViewEvent, _TPThis >, CXTPCalendarViewGroupT< CXTPCalendarDayViewDay, CXTPCalendarDayViewEvent, CXTPCalendarDayViewGroup >, CXTPCalendarViewGroupT< CXTPCalendarMonthViewDay, CXTPCalendarMonthViewEvent, CXTPCalendarMonthViewGroup >, CXTPCalendarViewGroupT< CXTPCalendarWeekViewDay, CXTPCalendarWeekViewEvent, CXTPCalendarWeekViewGroup >, and CXTPCalendarWeekViewGroup.

◆ GetCalendarControl()

AFX_INLINE CXTPCalendarControl * GetCalendarControl ( ) const
virtual

Call this member function to obtain a pointer to the calendar control object.

Returns
A pointer to a CXTPCalendarControl object.

Reimplemented in CXTPCalendarTimeLineViewGroup.

◆ GetCaption()

virtual CString GetCaption ( ) const
virtual

This member function is used to obtain a group's view caption.

Returns
A CString object that contains the group's view caption.

◆ GetChildHandlerAt()

virtual CXTPCalendarWMHandler * GetChildHandlerAt ( int nIndex ) const
virtual

Call this method to get an event view object at the specified numeric index.

Parameters
nIndex An integer index that is greater than or equal to 0 and less than the value returned by GetChildHandlersCount.

Returns the array element at the specified index.

Returns
The pointer to the descendant of CXTPCalendarWMHandler element currently at this index.
See also
GetChildHandlersCount

Reimplemented from CXTPCalendarWMHandler.

◆ GetChildHandlersCount()

AFX_INLINE int GetChildHandlersCount ( ) const
virtual

This member function is used to obtain the number of event views elements in this Group View.

Call this method to retrieve the number of elements in the array of event views inside this Group View. Because indexes are zero-based, the size is 1 greater than the largest index.

Returns
A count of event views elements.
See also
GetChildHandlerAt

Reimplemented from CXTPCalendarWMHandler.

◆ GetDataProvider()

virtual CXTPCalendarData * GetDataProvider ( ) const
virtual

Returns data provider for this view group.

Returns
A pointer to the data provider object if it was previously set; otherwise, returns NULL.
See also
CXTPCalendarData overview

◆ GetGroupIndex()

virtual int GetGroupIndex ( ) const
virtual

This member function is used to obtain the index of the "this" pointer Group View in the Calendar Day View.

Returns
An int that contains the index of the "this" day in the Calendar Day View.

◆ GetHeaderRect()

virtual CRect GetHeaderRect ( ) const
inlinevirtual

Call this member function to obtain the group's header rectangle area.

Returns
A CRect that contains the rectangle coordinates of the group view header part in client coordinates of the parent's CXTPDatePickerControl object.
See also
GetRect

◆ GetRect()

virtual CRect GetRect ( ) const
inlinevirtual

Call this member function to obtain the group's rectangle area.

Returns
A CRect that contains the rectangle coordinates of the group view in client coordinates of the parent's CXTPDatePickerControl object.
See also
GetHeaderRect

◆ GetResources()

AFX_INLINE CXTPCalendarResources * GetResources ( ) const
virtual

Obtain a pointer to a collection of Calendar Resources.

Use this method to retrieve a pointer to the Calendar Resources collection of this Group View.

Returns
CXTPCalendarResources pointer.
See also
CXTPCalendarResources overview
SetResources
AddResource

◆ GetScheduleID()

virtual UINT GetScheduleID ( ) const
virtual

Returns default Schedule ID - the first existing one.

Returns
The first existing Schedule ID or XTP_CALENDAR_UNKNOWN_SCHEDULE_ID if not found.

◆ GetTooltipRect()

virtual CRect GetTooltipRect | ( | const CPoint & | ptHit,
 |  | const XTP_CALENDAR_HITTESTINFO & | hitInfo ) const
 virtual

Call this member function to obtain the bounding rectangle of the tooltip space (currently this is only "click to add new appointment").

Tooltip rectangle is calculated basing on the current mouse position

Parameters
ptHit | A CPoint of mouse coordinates.
hitInfo | An XTP_CALENDAR_HITTESTINFO object.
Returns
A CRect object with relative coordinates of the tooltip.

This member function always returns an empty rectangle. Actual tooltip rectangle is calculated by ViewGroups of specific views (currently DayView and MonthView are supported).

Reimplemented in CXTPCalendarDayViewGroup, and CXTPCalendarMonthViewGroup.

◆ GetViewDay_()

AFX_INLINE CXTPCalendarViewDay * GetViewDay_ ( ) const

Call this member function to obtain a pointer to the containing CXTPCalendarViewDay object.

Returns
A pointer to the CXTPCalendarViewDay object.

◆ GetViewEvent_()

AFX_INLINE CXTPCalendarViewEvent * GetViewEvent_ ( int nIndex ) const

Call this member function to obtain a pointer to a CXTPCalendarViewEvent object associated with the event's index.

Parameters
nIndex An int that contains the event view index in the day view collection.

Index number starts with 0 and cannot be negative. This is a pure virtual function. This function must be defined in the derived class.

Returns
A pointer to a CXTPCalendarViewEvent object.
See also
GetViewEventsCount()

◆ GetViewEventByEvent_()

virtual CXTPCalendarViewEvent * GetViewEventByEvent_ ( CXTPCalendarEvent * pEvent ) const
virtual

Call this member function to obtain a pointer to a CXTPCalendarViewEvent object that is identified by the corresponding event object.

Parameters
pEvent Pointer to a CXTPCalendarEvent object.
Returns
A pointer to a CXTPCalendarViewEvent object.
See also
CXTPCalendarEvent
CXTPCalendarViewEvent

◆ GetViewEventByPlace_()

virtual CXTPCalendarViewEvent * GetViewEventByPlace_ ( int nEventPlace ) const
virtual

Call this member function to obtain an event view object identified by its event place number.

Parameters
nEventPlace An int that contains the ViewEvent place identifier.
Returns
A pointer to a CXTPCalendarViewEvent object.
See also
CXTPCalendarEvent
CXTPCalendarViewEvent

◆ GetViewEventsCount()

AFX_INLINE int GetViewEventsCount ( ) const

Call this member function to obtain the number of event views in the day view collection.

This is a pure virtual function. This function must be defined in the derived class.

Returns
An int that contains the number of event views.

◆ HitTest()

virtual BOOL HitTest | ( | CPoint | pt,
 |  | XTP_CALENDAR_HITTESTINFO * | pHitTest ) const
 virtual

This member function is used to determine which view item, if any, is at the specified position index, and returns additional info in an XTP_CALENDAR_HITTESTINFO struct.

Parameters
pt | A CPoint object that contains the coordinates of the point to test.
pHitTest | A pointer to an XTP_CALENDAR_HITTESTINFO struct that contains information about the point to test.

This is a pure virtual function. This function must be defined in the derived class.

Returns
A BOOL. TRUE if the item is found. FALSE otherwise.
See also
XTP_CALENDAR_HITTESTINFO

Reimplemented in CXTPCalendarTimeLineViewGroup.

◆ HitTestEx()

virtual BOOL HitTestEx | ( | CPoint | pt,
 |  | XTP_CALENDAR_HITTESTINFO * | pHitTest ) const
 virtual

This member function is used to determine which view item, if any, is at the specified position index, and returns additional info in the XTP_CALENDAR_HITTESTINFO template object.

Parameters
pt | A CPoint that contains the coordinates of the point test.
pHitTest | A pointer to a XTP_CALENDAR_HITTESTINFO structure.

Implements standard functionality for the HitTestEx method.

Returns
A BOOL. TRUE if the item is found. FALSE otherwise.
See also
XTP_CALENDAR_HITTESTINFO

Reimplemented in CXTPCalendarDayViewGroup.

◆ KillTimer()

virtual void KillTimer ( UINT uTimerID )
protectedvirtual

This member function is used to destroy a timer event.

Parameters
uTimerID A UINT that specifies the identifier of the timer.

◆ OnPrePopulate()

virtual void OnPrePopulate ( CXTPCalendarEvents * pEvents )
protectedvirtual

This member function is used to allow some customization before show events.

Parameters
pEvents A pointer to events array to draw.

Default implementation sends an XTP_NC_CALENDAR_PREPOPULATE notification.

See also
XTP_NC_CALENDAR_PREPOPULATE

◆ Populate()

virtual void Populate ( COleDateTime dtDayDate )
virtual

This member function is used to populate the view with data for all items contained in the view.

Parameters
dtDayDate A COleDateTime object that contains the day's date.

This is a pure virtual function. This function must be defined in the derived class.

Reimplemented in CXTPCalendarTimeLineViewGroup.

◆ SetResources()

virtual void SetResources ( CXTPCalendarResources * pResources )
virtual

Assigns a new Resources collection to this Group View.

Parameters
pResources Pointer to the new Resources collection to be copied into internal collections of this Group View.
See also
GetResources
AddResource

◆ SetTimer()

virtual UINT SetTimer ( UINT uTimeOut_ms )
protectedvirtual

This member function is used to create a timer event.

Parameters
uTimeOut_ms A UINT that contains the duration of the timer in milliseconds.
Returns
A UINT that is the identifier of the timer.
The documentation for this class was generated from the following file:
  • XTPCalendarViewDay.h


Toolkit Pro: CXTPCalendarViewGroupT< _TViewDay, _TViewEvent, _TPThis > Class Template Reference

Public Types | Public Member Functions | Protected Member Functions | List of all members
CXTPCalendarViewGroupT< _TViewDay, _TViewEvent, _TPThis > Class Template Referenceabstract

This class template customizes, overrides and implements some functionality for the CXTPCalendarViewGroup base class. More...

Inheritance diagram for CXTPCalendarViewGroupT< _TViewDay, _TViewEvent, _TPThis >:
[legend]

Public Types

typedef _TViewDay TViewDay

Public Member Functions

CXTPCalendarViewGroupT (_TViewDay *pViewDay)
Default object constructor.
virtual | ~CXTPCalendarViewGroupT ()
Default class destructor.
virtual void | FillHitTestEx (XTP_CALENDAR_HITTESTINFO *pHitTest) const =0
This member function is used to fill the pHitTest structure members with the default values for the current group view object.
_TViewDay * | GetViewDay () const
This member function is used to obtain the owner view object.
virtual _TViewEvent * | GetViewEvent (int nIndex) const
Call this member function to obtain a pointer to the _TViewEvent object that corresponds to the event's index.
- Public Member Functions inherited from CXTPCalendarViewGroup
CXTPCalendarViewGroup (CXTPCalendarViewDay *pViewDay)
Default object constructor.
virtual | ~CXTPCalendarViewGroup ()
Default class destructor.
virtual CXTPCalendarResources * | GetResources () const
Obtain a pointer to a collection of Calendar Resources.
virtual CXTPCalendarData * | GetDataProvider () const
Returns data provider for this view group.
virtual void | AddResource (CXTPCalendarResource *pResource, BOOL bWithAddRef)
Adds a new Resource object into the collection of resources for this Group View.
virtual void | SetResources (CXTPCalendarResources *pResources)
Assigns a new Resources collection to this Group View.
virtual UINT | GetScheduleID () const
Returns default Schedule ID - the first existing one.
virtual void | Populate (COleDateTime dtDayDate)
This member function is used to populate the view with data for all items contained in the view.
virtual void | AdjustLayout (CDC *pDC, const CRect &rcGroup)
This member function is used to adjust the view's layout depending on the provided rectangle and then calls AdjustLayout() for all of the sub-items.
virtual void | AdjustLayout2 (CDC *pDC, const CRect &rcGroup)
This member function is used to adjust the view's layout depending on the provided rectangle and then calls AdjustLayout() for all of the sub-items.
virtual void | Draw (CDC *pDC)
This member function is used to draw the view contents using the specified device context.
virtual BOOL | HitTest (CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const
This member function is used to determine which view item, if any, is at the specified position index, and returns additional info in an XTP_CALENDAR_HITTESTINFO struct.
virtual BOOL | HitTestEx (CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const
This member function is used to determine which view item, if any, is at the specified position index, and returns additional info in the XTP_CALENDAR_HITTESTINFO template object.
virtual CRect | GetRect () const
Call this member function to obtain the group's rectangle area.
virtual CRect | GetHeaderRect () const
Call this member function to obtain the group's header rectangle area.
virtual CRect | GetTooltipRect (const CPoint &ptHit, const XTP_CALENDAR_HITTESTINFO &hitInfo) const
Call this member function to obtain the bounding rectangle of the tooltip space (currently this is only "click to add new appointment").
int | GetViewEventsCount () const
Call this member function to obtain the number of event views in the day view collection.
CXTPCalendarViewEvent * | GetViewEvent_ (int nIndex) const
Call this member function to obtain a pointer to a CXTPCalendarViewEvent object associated with the event's index.
CXTPCalendarViewDay * | GetViewDay_ () const
Call this member function to obtain a pointer to the containing CXTPCalendarViewDay object.
virtual int | GetGroupIndex () const
This member function is used to obtain the index of the "this" pointer Group View in the Calendar Day View.
virtual CString | GetCaption () const
This member function is used to obtain a group's view caption.
virtual int | GetChildHandlersCount () const
This member function is used to obtain the number of event views elements in this Group View.
virtual CXTPCalendarWMHandler * | GetChildHandlerAt (int nIndex) const
Call this method to get an event view object at the specified numeric index.
virtual CXTPCalendarViewEvent * | GetViewEventByEvent_ (CXTPCalendarEvent *pEvent) const
Call this member function to obtain a pointer to a CXTPCalendarViewEvent object that is identified by the corresponding event object.
virtual CXTPCalendarViewEvent * | GetViewEventByPlace_ (int nEventPlace) const
Call this member function to obtain an event view object identified by its event place number.
virtual CXTPCalendarControl * | GetCalendarControl () const
Call this member function to obtain a pointer to the calendar control object.
virtual void | ExchangeEventPlace (CXTPCalendarViewEvent *pViewEvent, int nNewPlace)
This member function is used to exchange event view positions.
- Public Member Functions inherited from CXTPCalendarWMHandler
CXTPCalendarWMHandler ()
Default object constructor.
virtual BOOL | OnLButtonDown (UINT nFlags, CPoint point)
This member function is used to process left mouse button down events.
virtual BOOL | OnLButtonUp (UINT nFlags, CPoint point)
This member function is used to process left mouse button up events.
virtual BOOL | OnLButtonDblClk (UINT nFlags, CPoint point)
This member function is used to process left mouse button double click events.
virtual void | OnMouseMove (UINT nFlags, CPoint point)
This member function is used to process mouse movement events.
virtual void | OnChar (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process keyboard events.
virtual void | OnKeyDown (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process key-down keyboard events.
virtual void | OnKeyUp (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process key-up keyboard events.
virtual BOOL | OnSysKeyDown (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process key-up keyboard events.
virtual BOOL | OnTimer (UINT_PTR uTimerID)
The framework calls this member function after each interval specified in the SetTimer member function.
virtual BOOL | OnWndMsg (UINT message, WPARAM wParam, LPARAM lParam, LRESULT *pResult)
This method is called by framework after default message processing.
virtual void | OnPostAdjustLayout ()
This member function is used to perform additional adjustments in some kinds of views.
virtual void | OnBeforeDestroy ()
This member function is called by the framework before destroying the view.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

virtual _TPThis * | GetPThis ()=0
Call this member function to obtain the typed pointer to the last derived class in the class hierarchy.
- Protected Member Functions inherited from CXTPCalendarViewGroup
virtual UINT | SetTimer (UINT uTimeOut_ms)
This member function is used to create a timer event.
virtual void | KillTimer (UINT uTimerID)
This member function is used to destroy a timer event.
virtual void | OnPrePopulate (CXTPCalendarEvents *pEvents)
This member function is used to allow some customization before show events.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Attributes inherited from CXTPCalendarViewGroup
XTP_VIEW_GROUP_LAYOUT | m_Layout
This group view client coordinates.
CXTPCalendarPtrCollectionT< CXTPCalendarViewEvent > | m_arEvents
Storage for events views.
CXTPCalendarResources * | m_pResources
An associated resource object.
CXTPCalendarViewDay * | m_pViewDay
Parent day view.

Detailed Description

template<class _TViewDay, class _TViewEvent, class _TPThis>
class CXTPCalendarViewGroupT< _TViewDay, _TViewEvent, _TPThis >

This class template customizes, overrides and implements some functionality for the CXTPCalendarViewGroup base class.

It is used as a part of the calendar control framework to build the ViewGroup layer of View->DayView->ViewDay->ViewGroup typed objects hierarchy. These are template parameters: _TView - Type of owner View object. _TViewEvent - Type of View Event objects stored in Group View. XTP_CALENDAR_HITTESTINFO - Type of HitTest struct, used as parameter in the member functions. _TPThis - The last derived class type in the class hierarchy.

 You must provide all of the above parameters.
See also
CXTPCalendarViewGroup

Member Typedef Documentation

◆ TViewDay

template<class _TViewDay , class _TViewEvent , class _TPThis >
_TViewDay TViewDay

Owner view class type definition.

Constructor & Destructor Documentation

◆ CXTPCalendarViewGroupT()

template<class _TViewDay , class _TViewEvent , class _TPThis >
CXTPCalendarViewGroupT ( _TViewDay * pViewDay )
inline

Default object constructor.

Parameters
pViewDay Pointer to owner view Day object.
See also
~CXTPCalendarViewGroupT()

◆ ~CXTPCalendarViewGroupT()

template<class _TViewDay , class _TViewEvent , class _TPThis >
virtual ~CXTPCalendarViewGroupT ( )
inlinevirtual

Default class destructor.

Handles class members deallocation.

Member Function Documentation

◆ FillHitTestEx()

template<class _TViewDay , class _TViewEvent , class _TPThis >
virtual void FillHitTestEx ( XTP_CALENDAR_HITTESTINFO * pHitTest ) const
pure virtual

This member function is used to fill the pHitTest structure members with the default values for the current group view object.

Parameters
pHitTest A Pointer to an XTP_CALENDAR_HITTESTINFO structure.

This is a pure virtual function. This function must be defined in the derived class.

Implements CXTPCalendarViewGroup.

Implemented in CXTPCalendarDayViewGroup, CXTPCalendarMonthViewGroup, and CXTPCalendarWeekViewGroup.

◆ GetPThis()

template<class _TViewDay , class _TViewEvent , class _TPThis >
virtual _TPThis * GetPThis ( )
protectedpure virtual

Call this member function to obtain the typed pointer to the last derived class in the class hierarchy.

_TPThis - The last derived class type in the class hierarchy. This is a pure virtual function. This function must be defined in the derived class.

Returns
Pointer to this object as last derived class type.

Implemented in CXTPCalendarMonthViewGroup.

◆ GetViewDay()

template<class _TViewDay , class _TViewEvent , class _TPThis >
_TViewDay * GetViewDay ( ) const
inline

This member function is used to obtain the owner view object.

Returns
A _TView template pointer to the owner view object.
See also
GetView_

◆ GetViewEvent()

template<class _TViewDay , class _TViewEvent , class _TPThis >
virtual _TViewEvent * GetViewEvent ( int nIndex ) const
inlinevirtual

Call this member function to obtain a pointer to the _TViewEvent object that corresponds to the event's index.

Parameters
nIndex An int that contains the event view index in the day view collection.
Returns
A pointer to a _TViewEvent template object.

Index number starts with 0 and cannot be negative.

See also
GetViewEventsCount()
GetViewEvent_()
The documentation for this class was generated from the following file:
  • XTPCalendarViewDay.h


Toolkit Pro: CXTPCalendarViewPart Class Reference

Public Member Functions | Public Attributes | List of all members
CXTPCalendarViewPart Class Reference

Helper base class to implement parts for calendar paint manager. More...

Inheritance diagram for CXTPCalendarViewPart:
[legend]

Public Member Functions

CXTPCalendarViewPart (CXTPCalendarViewPart *pParentPart=NULL)
Default constructor.
virtual | ~CXTPCalendarViewPart ()
Default destructor.
virtual void | RefreshMetrics ()
This member function is used to set graphical related parameters equal to the system settings.
virtual COLORREF | GetBackgroundColor ()
This member function is used to obtain the color used to fill the background of UI elements.
virtual COLORREF | GetTextColor ()
This member function is used to obtain the color used to display text.
virtual CFont & | GetTextFont ()
This member function is used to obtain a pointer to a CFont object that contains the font that is used for displaying the text.
void | DrawText (CDC *pDC, const CString &str, LPRECT lpRect, UINT nFormat, COLORREF clrText=COLORREF_NULL, CFont *pFont=NULL)
This member function is used to display the text using the custom font and color.
void | DrawLine_CenterLR (CDC *pDC, const CString &str, LPRECT lpRect, UINT nFormat)
This member function is used to draw a single line text in the center of the rect.
void | DrawLineEx (CDC *pDC, const CString &str, LPRECT lpRect, UINT nFormatNormal, UINT nFormatSmall)
This member function is used to draw a single line text in the rect.
CSize | GetTextExtent (CDC *pDC, const CString &str)
This member function is used to calculate the size of the area required to display the given text.
void | SetBackgroundColor (COLORREF clr)
This member function is used to set the new color used to fill the background.
void | SetTextColor (COLORREF clr)
This member function is used to set the new color used to display the text.
void | SetTextFont (LOGFONT *pLogFont)
This member function is used to set the new font used to display the text.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Public Attributes

CXTPPaintManagerColor | m_clrTextColor
Stores color settings used to display text.
CXTPPaintManagerColor | m_clrBackground
Stores color settings used to to fill background of UI item.
CXTPCalendarViewPartFontValue | m_fntText
Stores font settings used to display text.
CXTPCalendarViewPart * | m_pParentPart
Pointer to the parent CXTPCalendarViewPart object.
CXTPCalendarPaintManager * | m_pPaintManager
Pointer to containing CXTPCalendarPaintManager object.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

Helper base class to implement parts for calendar paint manager.

objects.

Constructor & Destructor Documentation

◆ CXTPCalendarViewPart()

CXTPCalendarViewPart ( CXTPCalendarViewPart * pParentPart = NULL )

Default constructor.

Parameters
pParentPart Pointer to parent class, can be NULL.

Member Function Documentation

◆ DrawLine_CenterLR()

void DrawLine_CenterLR | ( | CDC * | pDC,
 |  | const CString & | str,
 |  | LPRECT | lpRect,
 |  | UINT | nFormat )

This member function is used to draw a single line text in the center of the rect.

If rect width is not enough to draw all chars - text is aligned to left (or right, see nFormat) or the rect.

Parameters
pDC | A pointer to a valid device context.
str | A CString that contains the text to display.
lpRect | An LPRECT that contains the rectangle coordinates used to display the text.
nFormat | A UINT that contains additional format parameters as combination of flags: DT_VCENTER, DT_LEFT, DT_RIGHT or 0.

◆ DrawLineEx()

void DrawLineEx | ( | CDC * | pDC,
 |  | const CString & | str,
 |  | LPRECT | lpRect,
 |  | UINT | nFormatNormal,
 |  | UINT | nFormatSmall )

This member function is used to draw a single line text in the rect.

If rect width is not enough to draw all chars - nFormatSmall flags are used, otherwise nFormatNormal flags are used.

Parameters
pDC | A pointer to a valid device context.
str | A CString that contains the text to display.
lpRect | An LPRECT that contains the rectangle coordinates used to display the text.
nFormatNormal | A UINT that contains format parameters when rect width is enough to draw all text chars.
nFormatSmall | A UINT that contains format parameters when rect width is not enough to draw all text chars.

◆ DrawText()

void DrawText | ( | CDC * | pDC,
 |  | const CString & | str,
 |  | LPRECT | lpRect,
 |  | UINT | nFormat,
 |  | COLORREF | clrText = COLORREF_NULL,
 |  | CFont * | pFont = NULL )

This member function is used to display the text using the custom font and color.

Parameters
pDC | A pointer to a valid device context.
str | A CString that contains the text to display.
lpRect | An LPRECT that contains the rectangle coordinates used to display the text.
nFormat | A UINT that contains additional format parameters.
clrText | RGB value indicating text color, if COLORREF_NULL default color is used.
pFont | Points to a valid CFont object, if NULL default color is used.

◆ GetBackgroundColor()

virtual COLORREF GetBackgroundColor ( )
virtual

This member function is used to obtain the color used to fill the background of UI elements.

Returns
A COLORREF that contains the value of the background color.

◆ GetTextColor()

virtual COLORREF GetTextColor ( )
virtual

This member function is used to obtain the color used to display text.

Returns
A COLORREF that contains the value of text color.

◆ GetTextExtent()

CSize GetTextExtent | ( | CDC * | pDC,
 |  | const CString & | str )

This member function is used to calculate the size of the area required to display the given text.

Parameters
pDC | A pointer to a valid device context.
str | A CString that contains the string of text to display.
Returns
A CSize object that contains the dimensions required to display the text.

◆ GetTextFont()

virtual CFont & GetTextFont ( )
virtual

This member function is used to obtain a pointer to a CFont object that contains the font that is used for displaying the text.

Returns
A reference to a CFont object that contains the font used to display the text.

◆ SetBackgroundColor()

void SetBackgroundColor ( COLORREF clr )

This member function is used to set the new color used to fill the background.

Parameters
clr A COLORREF that contains the new color value.

◆ SetTextColor()

void SetTextColor ( COLORREF clr )

This member function is used to set the new color used to display the text.

Parameters
clr A COLORREF that contains the new color value.

◆ SetTextFont()

void SetTextFont ( LOGFONT * pLogFont )

This member function is used to set the new font used to display the text.

Parameters
pLogFont A pointer to a LOGFONT struct that contains the new font used to display the text.
The documentation for this class was generated from the following file:
  • XTPCalendarViewPart.h


Toolkit Pro: CXTPCalendarViewPartBrushValue Class Reference

Public Member Functions | List of all members
CXTPCalendarViewPartBrushValue Class Reference

Helper class provides functionality to manage brush value objects. More...

Inheritance diagram for CXTPCalendarViewPartBrushValue:
[legend]

Public Member Functions

~CXTPCalendarViewPartBrushValue ()
Handles object deallocation.
- Public Member Functions inherited from CXTPCalendarViewPartCustomizableValueT< CBrush >
CXTPCalendarViewPartCustomizableValueT ()
Default object constructor.
virtual | ~CXTPCalendarViewPartCustomizableValueT ()
Default object destructor.
virtual BOOL | IsDefaultValue () const
This member function is used to determine if the default value is set.
virtual BOOL | IsStandardValue () const
This member function determines if the standard value is set and used.
virtual BOOL | IsCustomValue () const
This member function determines if the custom value is set and used.
virtual void | SetStandardValue (CBrush *pValue, BOOL bAutoDelete)
This member function is used to set the standard value.
virtual void | SetCustomValue (CBrush *pValue, BOOL bAutoDelete)
This member function is used to set the custom value.
virtual void | SetDefaultValue ()
This member function is used to reset the custom value.
virtual CBrush * | GetValue () const
This member function is used to get the current value.
virtual CBrush * | GetStandardValue () const
This member function is use to get the standard value.
operator CBrush * () const
This member operator is used to get the current value.
CBrush * | operator-> ()
Get a current value object.
void | CopySettings (const CXTPCalendarViewPartCustomizableValueT< CBrush > &refSrc)
This member function is used to set the standard value using the current value from the specified object.

Additional Inherited Members

- Public Types inherited from CXTPCalendarViewPartCustomizableValueT< CBrush >
- Protected Member Functions inherited from CXTPCalendarViewPartCustomizableValueT< CBrush >
- Protected Attributes inherited from CXTPCalendarViewPartCustomizableValueT< CBrush >
CBrush * | m_pValueStandard
Stores default value.
BOOL | m_bAutoDelete_Standard
Call operator delete for the standard value.
CBrush * | m_pValueCustom
Stores custom value.
BOOL | m_bAutoDelete_Custom
Call operator delete for the custom value.

Detailed Description

Helper class provides functionality to manage brush value objects.

The documentation for this class was generated from the following file:
  • XTPCalendarViewPart.h


Toolkit Pro: CXTPCalendarViewPartCustomizableValueT< _TValue > Class Template Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPCalendarViewPartCustomizableValueT< _TValue > Class Template Reference

Helper class template provides functionality to manage customized values for the specified class objects. More...

Inheritance diagram for CXTPCalendarViewPartCustomizableValueT< _TValue >:
[legend]

Public Member Functions

CXTPCalendarViewPartCustomizableValueT ()
Default object constructor.
virtual | ~CXTPCalendarViewPartCustomizableValueT ()
Default object destructor.
virtual BOOL | IsDefaultValue () const
This member function is used to determine if the default value is set.
virtual BOOL | IsStandardValue () const
This member function determines if the standard value is set and used.
virtual BOOL | IsCustomValue () const
This member function determines if the custom value is set and used.
virtual void | SetStandardValue (_TValue *pValue, BOOL bAutoDelete)
This member function is used to set the standard value.
virtual void | SetCustomValue (_TValue *pValue, BOOL bAutoDelete)
This member function is used to set the custom value.
virtual void | SetDefaultValue ()
This member function is used to reset the custom value.
virtual _TValue * | GetValue () const
This member function is used to get the current value.
virtual _TValue * | GetStandardValue () const
This member function is use to get the standard value.
operator _TValue * () const
This member operator is used to get the current value.
_TValue * | operator-> ()
Get a current value object.
void | CopySettings (const CXTPCalendarViewPartCustomizableValueT< _TValue > &refSrc)
This member function is used to set the standard value using the current value from the specified object.

Protected Member Functions

virtual void | DeleteStandardValue ()
Implementation can override this method for standard value specific cleaup logic.
virtual void | DeleteCustomValue ()
Implementation can override this method for custom value specific cleaup logic.

Protected Attributes

_TValue * | m_pValueStandard
Stores default value.
BOOL | m_bAutoDelete_Standard
Call operator delete for the standard value.
_TValue * | m_pValueCustom
Stores custom value.
BOOL | m_bAutoDelete_Custom
Call operator delete for the custom value.

Detailed Description

template<class _TValue>
class CXTPCalendarViewPartCustomizableValueT< _TValue >

Helper class template provides functionality to manage customized values for the specified class objects.

Member Function Documentation

◆ CopySettings()

template<class _TValue >
void CopySettings ( const CXTPCalendarViewPartCustomizableValueT< _TValue > & refSrc )
inline

This member function is used to set the standard value using the current value from the specified object.

Parameters
refSrc Reference to a source object.
See also
SetStandardValue
SetCustomValue
SetDefaultValue
GetValue
IsStandardValue
IsCustomValue
GetStandardValue

◆ DeleteCustomValue()

template<class _TValue >
virtual void DeleteCustomValue ( )
inlineprotectedvirtual

Implementation can override this method for custom value specific cleaup logic.

The method is called from destructor so implementation must not use any implementation specific members.

◆ DeleteStandardValue()

template<class _TValue >
virtual void DeleteStandardValue ( )
inlineprotectedvirtual

Implementation can override this method for standard value specific cleaup logic.

The method is called from destructor so implementation must not use any implementation specific members.

◆ GetStandardValue()

template<class _TValue >
virtual _TValue * GetStandardValue ( ) const
inlinevirtual

This member function is use to get the standard value.

Returns
A pointer to the standard value.

Example: See example for SetCustomValue.

See also
SetStandardValue
SetCustomValue
SetDefaultValue
operator _TValue*

◆ GetValue()

template<class _TValue >
virtual _TValue * GetValue ( ) const
inlinevirtual

This member function is used to get the current value.

The default value is used if the custom value is not set. Otherwise, a custom value is used.

Returns
A pointer to the current value.

Example: See example for SetCustomValue.

See also
SetStandardValue
SetCustomValue
SetDefaultValue
operator _TValue*

◆ IsCustomValue()

template<class _TValue >
virtual BOOL IsCustomValue ( ) const
inlinevirtual

This member function determines if the custom value is set and used.

Returns
TRUE if custom value is set, otherwise FALSE.

◆ IsDefaultValue()

template<class _TValue >
virtual BOOL IsDefaultValue ( ) const
inlinevirtual

This member function is used to determine if the default value is set.

Returns
A BOOL. TRUE if the default value is set. FALSE otherwise.

◆ IsStandardValue()

template<class _TValue >
virtual BOOL IsStandardValue ( ) const
inlinevirtual

This member function determines if the standard value is set and used.

Returns
TRUE if standard value is set and custom value is not set, otherwise FALSE.

◆ operator _TValue *()

template<class _TValue >
operator _TValue * ( ) const
inline

This member operator is used to get the current value.

The default value is used if the custom value is not set. Otherwise, a custom value is used.

Returns
A pointer to the current value.

Example: See example for SetCustomValue.

See also
SetStandardValue
SetCustomValue
SetDefaultValue
GetValue

◆ operator->()

template<class _TValue >
_TValue * operator-> ( )
inline

Get a current value object.

Returns
Pointer to the current value object.

◆ SetCustomValue()

template<class _TValue >
virtual void SetCustomValue | ( | _TValue * | pValue,
 |  | BOOL | bAutoDelete )
 inlinevirtual

This member function is used to set the custom value.

Parameters
pValue | A pointer to a value object.
bAutoDelete | Set to TRUE if the value being set will be automatically deleted when no longer needed, otherwise set it to FALSE.

Call this member function to set the custom value. If set, this value is used instead of default value.

Example:

 class CMyClass

 {
 public:
    CMyClass();

    void Draw(CDC* pDC, CRect& rcRect, BOOL bCustom);
    // ...
    CXTPBrush m_brushBusy_Custom;

    CXTPCalendarViewPartBrushValue m_brushVal_auto;
    CXTPCalendarViewPartBrushValue m_brushVal_static;
 };

 CMyClass::CMyClass()
 {
    m_brushBusy_Custom.CreateSolidBrush(RGB(0, 0, 0xFF));

    m_brushVal_auto.SetStandardValue(new CBrush(RGB(0xFF, 0xFF, 0xFF)), TRUE);
    m_brushVal_static.SetStandardValue(&m_brushBusy_Custom, FALSE);
 }

 void CMyClass::Draw(CDC* pDC, CRect& rcRect, BOOL bCustom)
 {
    if (bCustom)
    {
        m_brushVal_auto.SetCustomValue(new CBrush(RGB(0, 0, 0)), TRUE);
        m_brushVal_static.SetCustomValue(new CBrush(RGB(255, 255, 255)), TRUE);
    }
    else
    {
        // Reset to standard value
        m_brushVal_auto.SetDefaultValue();
        m_brushVal_static.SetDefaultValue();
    }

    pDC->FillRect(&rcRect, (CBrush*)m_brushVal_auto);

    CBrush* pBrushOld = pDC->SelectObject(m_brushVal_static.GetValue());
    // ....
    pDC->SelectObject(pBrushOld);
 }
See also
SetStandardValue
SetDefaultValue

◆ SetDefaultValue()

template<class _TValue >
virtual void SetDefaultValue ( )
inlinevirtual

This member function is used to reset the custom value.

Call this member function to ensure that the default value is used and not the custom value. If the default value is not set - method does nothing.

Example: See example for SetCustomValue.

See also
SetStandardValue
SetCustomValue

◆ SetStandardValue()

template<class _TValue >
virtual void SetStandardValue | ( | _TValue * | pValue,
 |  | BOOL | bAutoDelete )
 inlinevirtual

This member function is used to set the standard value.

Parameters
pValue | A pointer to a value object.
bAutoDelete | Set to TRUE if the value being set will be automatically deleted when no longer needed, otherwise set it to FALSE.

Call this member function to set the standard value. This value is used as the default value if there is not a custom value set.

Example: See example for SetCustomValue.

See also
SetCustomValue
SetDefaultValue
The documentation for this class was generated from the following file:
  • XTPCalendarViewPart.h


Toolkit Pro: CXTPCalendarViewPartFontValue Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPCalendarViewPartFontValue Class Reference

Helper class provides functionality to manage font settings for various graphical elements of control. More...

Public Member Functions

CXTPCalendarViewPartFontValue ()
Default constructor.
BOOL | IsDefaultValue ()
This member function is used to determine if the default font value is set.
void | SetStandardValue (LOGFONT *pLogFont)
This member function is used to set the value for the standard font.
void | SetDefaultValue ()
This member function is used to delete the custom font and to set the default font value as the default font.
operator CFont & ()
This member function is use to overload the function call operator for the CXTPCalendarViewPartFontValue class.
operator CFont * ()
This member function is used to overload the function call operator for the CXTPCalendarViewPartFontValue class.
const CXTPCalendarViewPartFontValue & | operator= (LOGFONT *pLogFont)
This member function overloads the assignment operator for the CXTPCalendarViewPartFontValue class.
CFont * | operator-> ()
Get a current value object.

Protected Attributes

CXTPFont | m_xtpFontStandardValue
Stores default font.
CXTPFont | m_xtpFontCustomValue
Stores custom font.

Detailed Description

Helper class provides functionality to manage font settings for various graphical elements of control.

Member Function Documentation

◆ IsDefaultValue()

BOOL IsDefaultValue ( )

This member function is used to determine if the default font value is set.

Returns
A BOOL. TRUE if the default value is set. FALSE otherwise.

◆ operator CFont &()

operator CFont & ( )

This member function is use to overload the function call operator for the CXTPCalendarViewPartFontValue class.

Use the default font if the custom font does not work. Otherwise, use a custom font.

Returns
A reference to a CFont object that contains either the standard font value or the custom font value.

◆ operator CFont *()

operator CFont * ( )

This member function is used to overload the function call operator for the CXTPCalendarViewPartFontValue class.

Use the default font if the custom font does not work. Otherwise, use a custom font.

Returns
A pointer to a CFont object that contains either the standard font value or the custom font value.

◆ operator->()

CFont * operator-> ( )

Get a current value object.

Returns
Pointer to the current value object.

◆ operator=()

const CXTPCalendarViewPartFontValue & operator= ( LOGFONT * pLogFont )

This member function overloads the assignment operator for the CXTPCalendarViewPartFontValue class.

Parameters
pLogFont A pointer to a LOGFONT structure.

Creates a new custom font.

Returns
A reference to a CXTPCalendarViewPartFontValue.

◆ SetDefaultValue()

void SetDefaultValue ( )

This member function is used to delete the custom font and to set the default font value as the default font.

Call this member function to ensure that the default font is used and not the custom font.

◆ SetStandardValue()

void SetStandardValue ( LOGFONT * pLogFont )

This member function is used to set the value for the standard font.

Parameters
pLogFont A pointer to a LOGFONT structure that contains the standard font value.

Call this member function to set the standard font. This font is used as the default font if there is not a custom font value set.

The documentation for this class was generated from the following file:
  • XTPCalendarViewPart.h


Toolkit Pro: CXTPCalendarViewT< _TViewDay > Class Template Reference

Public Member Functions | List of all members
CXTPCalendarViewT< _TViewDay > Class Template Reference

This template class represents a view portion of the Calendar control. More...

Inheritance diagram for CXTPCalendarViewT< _TViewDay >:
[legend]

Public Member Functions

CXTPCalendarViewT (CXTPCalendarControl *pCalendarControl, XTPCalendarViewType nViewType)
Default object constructor.
virtual | ~CXTPCalendarViewT ()
Default class destructor.
virtual XTPCalendarViewType | GetViewType () const
Call this member function to obtain the view type flag.
virtual _TViewDay * | GetViewDay (int nIndex) const
Call this member function to obtain a _TViewDay object corresponding with the day's index.
- Public Member Functions inherited from CXTPCalendarView
UINT | GetDiscreteSelectionCount () const
This member function is used to get the number of selected events.
COleDateTime | GetDiscreteSelectionValue (UINT id) const
This member function gets a selected event by using its event ordinal number.
BOOL | AddToDiscreteSelection (UINT id)
This member function adds an event to the selection by using its event ordinal number.
BOOL | IsInDiscreteSelection (UINT id) const
This member function checks if an event is in the selection.
void | ClearDiscreteSelection ()
This member function is used to Clear Discrete Selection.
CXTPCalendarView (CXTPCalendarControl *pCalendarControl)
Default object constructor.
virtual | ~CXTPCalendarView ()
Default class destructor.
virtual void | Populate ()
This member function is used to populate the view with data for all items contained in the view.
virtual void | AdjustLayout (CDC *pDC, const CRect &rcView, BOOL bCallPostAdjustLayout=TRUE)
This member function is used to adjust the view's layout depending on the window client size and calls AdjustLayout() for all sub-items.
virtual void | AdjustLayout2 (CDC *pDC, const CRect &rcView, BOOL bCallPostAdjustLayout=TRUE)
This member function is used to adjust the view's layout depending on the window client size and calls AdjustLayout() for all sub-items.
virtual void | RedrawControl ()
This member function is used to perform the redrawing of the control's layout.
virtual void | ShowDay (const COleDateTime &date, BOOL bSelect=TRUE)=0
This member function is used to show the specified day in the calendar view.
virtual void | ScrollV (int nPos, int nPos_raw)
Scroll vertically.
virtual void | ScrollH (int nPos, int nPos_raw)
Scroll horizontally.
virtual void | OnScrollEnd (int nBar)
This member function is used to force scroll to the end of the scroll range.
virtual BOOL | GetScrollBarInfoV (SCROLLINFO *pSI) const
This member function is used to retrieve the information about a scroll bar state.
virtual BOOL | GetScrollBarInfoH (SCROLLINFO *pSI, int *pnScrollStep=NULL) const
This member function is used to retrieve the information about a scroll bar state.
virtual void | OnDraw (CDC *pDC)
This member function performs all of the drawing logic of the calendar view.
virtual void | Draw (CDC *pDC)
This member function is used to draw the view content using the specified device context.
virtual void | Draw2 (CDC *pDC)
This member function is used to draw the view content using the specified device context.
virtual BOOL | OnLButtonDown (UINT nFlags, CPoint point)
This member function is used to process left mouse button events.
virtual BOOL | OnLButtonUp (UINT nFlags, CPoint point)
This member function is used to process left mouse button events.
virtual void | OnMouseMove (UINT nFlags, CPoint point)
This member function is used to process mouse movement events.
virtual BOOL | OnLButtonDblClk (UINT nFlags, CPoint point)
This member function is used to process mouse double-click events.
virtual void | OnChar (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process keyboard events.
virtual void | OnKeyDown (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to processes keyboard events.
virtual BOOL | OnSysKeyDown (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process system keyboard events.
CRect | GetViewRect () const
Call this member function to obtain the view's bounding rectangle.
virtual int | GetChildHandlersCount () const
This member function is used to obtain the number of CXTPCalendarWMHandler elements in the descendant handlers collection.
virtual CXTPCalendarWMHandler * | GetChildHandlerAt (int nIndex) const
Call this method to get a handler object at the specified numeric index.
virtual int | GetViewDayCount () const
Call this member function to obtain the number of "day views" in the view collection.
virtual COleDateTime | GetViewDayDate (int nIndex) const =0
Call this member function to obtain the date of the day view by the day's index.
virtual CXTPCalendarViewDay * | GetViewDay_ (int nIndex) const
Call this member function to obtain the CXTPCalendarViewDay object by the day's index.
virtual CXTPCalendarViewDay * | _GetViewDay (const COleDateTime &dtDay) const
Call this member function to obtain the CXTPCalendarViewDay object by the day's index.
virtual BOOL | HitTest (CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const
This member function is used to determines which view item, if any, is at a specified position index, and returns additional information in the XTP_CALENDAR_HITTESTINFO argument.
virtual BOOL | HitTestEx (CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const
This member function is used to determine which view item, if any, is at a specified position index, and returns additional info in an XTP_CALENDAR_HITTESTINFO object.
virtual XTPCalendarDraggingMode | GetDraggingMode () const
Call this member function to determine the current dragging mode.
virtual CXTPCalendarPaintManager * | GetPaintManager () const
Call this member function to obtain the PaintManager object.
virtual CXTPCalendarTheme * | GetTheme () const
This member function obtains a pointer to the associated theme object.
CXTPCalendarControl * | GetCalendarControl () const
Call this member function to obtain a pointer to the Calendar Control object.
CXTPCalendarOptions * | GetCalendarOptions () const
Call this member function to get direct access to calendar options data.
virtual CXTPCalendarResources * | GetResources () const
Call this member function to obtain a pointer to the associated Calendar Resources collection object.
virtual void | SetResources (CXTPCalendarResources *pResources)
This member function sets the new Resources collection for the view.
virtual void | UnselectAllEvents ()
Call this member function to un-select all of the events of the current view.
virtual void | SelectEvent (CXTPCalendarEvent *pEvent, BOOL bSelect=TRUE)
This member function is used to select or un-select the provided event.
void | SelectViewEvent (CXTPCalendarViewEvent *pViewEvent, BOOL bSelect=TRUE)
This member function is used to select or un-select the provided event.
virtual void | SelectDay (CXTPCalendarViewDay *pDay, int nGroupIndex=0)
This member function is used to select or un-select the provided day, including all of the day's events.
virtual CXTPCalendarViewEvents * | GetSelectedViewEvents () const
Call this member function to obtain a pointer to a selected event's views.
virtual CXTPCalendarViewEventsPtr | GetSelectedEvents () const
Call this member function to obtain a pointer to a selected event's views collection.
CXTPCalendarViewEvent * | GetLastSelectedViewEvent () const
This member function is used to obtain the last selected event view.
virtual BOOL | HasSelectedViewEvent () const
Call this member function to determine if any view event is selected.
BOOL | IsSingleEventSelected () const
This member function is used to determine if just one event is selected.
int | FindLastSelectedDay () const
This member function is used to obtain the last selected day index.
COleDateTime | GetLastSelectedDate () const
This member function is used to obtain the last selected day date.
virtual BOOL | GetSelection (COleDateTime *pBegin=NULL, COleDateTime *pEnd=NULL, BOOL *pbAllDayEvent=NULL, int *pnGroupIndex=NULL, COleDateTimeSpan *pspSelectionResolution=NULL) const
This member function is used to obtain the view's selection.
void | SetSelection (const COleDateTime &dtBegin, const COleDateTime &dtEnd, BOOL bAllDayEvent=FALSE, int nGroupIndex=0)
This member function sets the new selection for the view.
void | ResetSelection ()
This member function resets the current selection - set it empty.
BOOL | SelectionContains (COleDateTime date, int nGroupIndex=-1, BOOL *pbAllDaySelection=NULL)
This member function is used to determine if a date time value is contained inside the selection.
virtual void | SelectDay (COleDateTime dtSelDay, int nGroupIndex=0)
This member function is used to select or un-select the day identified by the provided date.
virtual int | GetRowHeight () const
Call this member function to determine the row height required to display the event.
virtual CXTPCalendarEventsPtr | RetrieveDayEvents (CXTPCalendarResource *pRC, COleDateTime dtDay)
Call this member function to get the collection of the day's events.
virtual BOOL | IsEditingSubject () const
Call this member function to determine if the subject is in an editable mode.
virtual CRect | GetSubjectEditorRect () const
Call this member function to obtain the bounding rectangle of the subject editor.
virtual CRect | GetTooltipRect (const CPoint &ptHit, const XTP_CALENDAR_HITTESTINFO &hitInfo) const
Call this member function to obtain the bounding rectangle of the tooltip space (currently this is only "click to add new appointment").
virtual void | ShowToolTip (BOOL bShow=TRUE)
This member function is used to show/hide a ToolTip rectangle.
virtual UINT | GetShowToolTipTimeOut () const
This member function is used to obtain the timeout value for displaying a tooltip.
virtual void | OnUpdateEditingSubject (CString strNewSubject)
Call this member function to set the new subject text for the editing event.
virtual BOOL | CanUndo () const
Call this member function to determine if you can perform an undo operation for the subject editor.
virtual BOOL | CanRedo () const
Call this member function to determine if a redo operation is possible for the subject editor.
virtual BOOL | Undo ()
This member function is used to perform an Undo operation.
virtual BOOL | Redo ()
This member function is used to perform a Redo operation.
virtual void | EmptyUndoBuffer ()
This member function is used to erase the undo buffer.
virtual CString | FormatEventTime (COleDateTime dtTime) const
This member function is used to format the time using the provided format.
void | SetCustomTimeFormat (const CString &strFormat)
This member function is used to set custom time format for view.
void | ResetCustomTimeFormat ()
Reset custom time format to default.
virtual CString | GetDayHeaderFormat () const
Call this member function to determine the current format string.
virtual void | SetDayHeaderFormat (LPCTSTR sFmt)
Call this member function to set the day header format.
virtual BOOL | CanCut () const
Call this member function to determine if it is possible to perform a Cut operation.
virtual BOOL | CanCopy () const
Call this member function to determine if it is possible to perform a Copy operation.
virtual BOOL | CanPaste () const
Call this member function to determine if it is possible to perform a Paste operation.
virtual BOOL | Cut ()
This member function is used to perform a Cut operation.
virtual BOOL | Copy ()
This member function is used to perform a Copy operation.
virtual BOOL | Paste ()
This member function is used to perform a Paste operation.
virtual CXTPCalendarEvent * | GetDraggingEventOrig () const
This member function is used to obtain the event object before the start of the event editing (dragging).
virtual CXTPCalendarEvent * | GetDraggingEventNew () const
This member function is used to obtain the event object that is currently being edited.
virtual BOOL | SetDraggingEvent (CXTPCalendarEvent *pEventOrig)
This member function is used to prepare the event to event editing (dragging) operation.
virtual BOOL | CommitDraggingEvent ()
This member function is used to commit the event editing (dragging) operation.
virtual void | CancelDraggingEvent ()
This member function is used to cancel the event editing (dragging) operation.
virtual void | OnStartDragging (CPoint point, XTP_CALENDAR_HITTESTINFO *pHitTest)
This member function is used to start the event editing (dragging).
virtual BOOL | OnDragging (CPoint point, XTP_CALENDAR_HITTESTINFO *pHitTest)
This member function is used to perform the event editing (dragging) operation step.
virtual BOOL | OnEndDragging (CPoint point, XTP_CALENDAR_HITTESTINFO *pHitInfo)
This member function is used to finish the event editing (dragging) operation.
virtual void | StartEditSubject (CXTPCalendarViewEvent *pViewEvent)
This member function is used to start the event subject editing.
virtual void | EndEditSubject (XTPCalendarEndEditSubjectAction eAction, BOOL bUpdateControl=TRUE)
This member function is used to finish the event subject editing.
virtual UINT | GetStartEditSubjectTimeOut () const
This member function is used to obtain the time value after a mouse click event in the subject editing window.
virtual void | StartEditNewEventInplace (LPCTSTR pcszInitialSubject)
This member function is used to create a new event and start subject editing.
virtual CXTPCalendarViewEvent * | FindViewEvent (CXTPCalendarEvent *pEvent, COleDateTime dtDay) const
This member function is used to obtain the event view object for the specified event and day.
virtual CXTPCalendarViewEvent * | FindEventToEditByTAB (COleDateTime dtMinStart, BOOL bReverse, CXTPCalendarEvent *pAfterEvent=NULL)
This member function is used to obtain the next event view object used for editing events by pressing the TAB key.
virtual COleDateTime | GetNextTimeEditByTAB () const
This member function is used to obtain the next date and time to start the find event view for editing events using the TAB key.
virtual void | UpdateNextTimeEditByTAB (COleDateTime dtNext, BOOL bReverse, BOOL bReset=FALSE)
This member function is used to set the next date and time to start the find event view for editing events using the TAB key.
virtual void | ProcessDaySelection (XTP_CALENDAR_HITTESTINFO *pInfo, UINT nFlags)
This member function is used to process the days selection that are selected with the mouse.
virtual void | SelectDays (COleDateTime dtNewSel)
This member function is used to change the days selection depending on the previous state of the selection.
virtual void | ProcessEventSelection (XTP_CALENDAR_HITTESTINFO *pInfo, UINT nFlags)
This member function is used to process events that are selected with the mouse.
virtual void | EnableVScroll (BOOL bEnable=TRUE)
This member function(s) is used to disable or enable vertical or horizontal scrolling of the view (by date or time).
virtual void | EnableHScroll (BOOL bEnable=TRUE)
This member function(s) is used to disable or enable vertical or horizontal scrolling of the view (by date or time).
virtual BOOL | IsHScrollEnabled () const
This member function(s) is used to obtain the status of the vertical or horizontal scrolling features of the view (by date or time).
virtual BOOL | IsVScrollEnabled () const
This member function(s) is used to obtain the status of the vertical or horizontal scrolling features of the view (by date or time).
virtual void | SetDayHeaderFormatLong (LPCTSTR pcszCustomFormat)
This member function(s) is used to set the date format string for the day view.
virtual void | SetDayHeaderFormatMiddle (LPCTSTR pcszCustomFormat)
This member function(s) is used to set the date format string for the day view.
virtual void | SetDayHeaderFormatShort (LPCTSTR pcszCustomFormat)
This member function(s) is used to set the date format string for the day view.
virtual void | SetDayHeaderFormatShortest (LPCTSTR pcszCustomFormat)
This member function(s) is used to set the date format string for the day view.
virtual BOOL | IsTodayVisible () const
Call this member function to determine if Today is visible.
virtual CString | GetItemTextEventTimeMax () const
This member function is called by the calendar framework to retrieve an event time string of maximum length (to reserve space).
virtual void | CalculateHeaderFormat (CDC *pDC, int nWidth, CFont *pTextFont)
This member function creates the day header format string.
- Public Member Functions inherited from CXTPCalendarWMHandler
CXTPCalendarWMHandler ()
Default object constructor.
virtual void | OnKeyUp (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process key-up keyboard events.
virtual BOOL | OnWndMsg (UINT message, WPARAM wParam, LPARAM lParam, LRESULT *pResult)
This method is called by framework after default message processing.
virtual void | OnPostAdjustLayout ()
This member function is used to perform additional adjustments in some kinds of views.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Member Functions inherited from CXTPCalendarView
virtual UINT | SetTimer (UINT uTimeOut_ms)
This member function is used to create a timer event.
virtual void | KillTimer (UINT uTimerID)
This member function is used to destroy a timer event.
virtual BOOL | OnTimer (UINT_PTR uTimerID)
The framework calls this member function after each interval specified in the SetTimer member function.
virtual void | OnBeforeDestroy ()
This member function is called by the framework before destroying the view.
virtual void | OnActivateView (BOOL bActivate, CXTPCalendarView *pActivateView, CXTPCalendarView *pInactiveView)
This member function is called by the framework view when it is activated or deactivated.
virtual void | SendNotification (XTP_NOTIFY_CODE EventCode, WPARAM wParam=0, LPARAM lParam=0)
This member function is used to send a notification from the parent Calendar control.
virtual void | _CalculateEventTimeFormat ()
This member function is used to create the time format string.
virtual CString | _GetMaxWidthFormat (CDC *pDC, CString strFormat, BOOL bMonth) const
This function is used to calculate the max width of the date used in the specified format string.
virtual int | _GetMaxWidth (CDC *pDC, CString strFormat) const
This member function is used to calculate, in pixels, the max date width for the specified format string.
virtual void | _RemoveYearPart (CString &strFormat)
This member function is used to remove the year part from the specified format string.
virtual void | _ReadDefaultHeaderFormats ()
This member function is used to build day header date format default strings.
virtual CString | _GetDayHeaderFormat (int nLevel) const
This member function gets a custom or default day header date format string.
virtual BOOL | _CanSubjectEditor (UINT idEditCmd) const
This member function is used to determine if the specified editing operation command is possible for the event subject editor window.
virtual CWnd * | _GetSubjectEditorWnd () const
This member function is used to obtain a pointer to the event subject editor window.
virtual COleDataSource * | _CopySelectedEvents (DWORD dwCopyFlags=0)
This member function is used to copy selected events and CXTPCalendarEvent objects, to a COleDataSource object.
virtual CXTPCalendarEventsPtr | _ReadEventsFromClipboard (COleDataObject *pData, DWORD *pdwCopyFlags=NULL)
This member function is used to read events and CXTPCalendarEvent objects, from a COleDataSource object.
virtual COleDateTimeSpan | GetEventDurationMin () const
This member function is used to obtain the minimum event duration visible in the current view.
virtual BOOL | _Undo (CXTPCalendarEvent *pEvent=NULL)
This member function is used to perform an undo/redo operation for the specified event.
virtual XTPEnumCalendarUpdateResult | OnEventChanged_InDataProvider (XTP_NOTIFY_CODE nfCode, CXTPCalendarEvent *pEvent)
This member function handles the changing of an event in the associated data provider.
BOOL | _IsDragModeCopyMove (int eDragMode) const
This method is used to determine Copy or Move dragging mode.
BOOL | IsEditOperationDisabledNotify (XTPCalendarEditOperation eOperation, CXTPCalendarViewEvent *pEventView) const
This method is used to determine if specified editing operation is disabled.
BOOL | OnBeforeEditOperationNotify (XTPCalendarEditOperation eOperation, CXTPCalendarViewEvent *pEventView)
This method is used to customize or disable specified editing operation.
BOOL | OnBeforeEditOperationNotify (XTPCalendarEditOperation eOperation, CXTPCalendarViewEvents *pEventViews)
This method is used to customize or disable specified editing operation.
BOOL | OnBeforePasteNotify (CXTPCalendarEvent *pEvent, BOOL bPasteWillChangeExistingEvent)
This method is used to customize or disable paste editing operation.
BOOL | OnInPlaceCreateEvent (LPCTSTR pcszInitialSubject)
This method is used to customize or disable xtpCalendarEO_InPlaceCreateEvent editing operation.
- Protected Attributes inherited from CXTPCalendarView
CSelectionChanged_ContextData m_cntSelChanged
Counter on selection changes,.
int | m_eUndoMode
Undo mode, see XTPCalendarUndoMode.
BOOL | m_bResetUndoBuffer
Clean undo buffer before add next undo action.
CUndoBuffer * | m_pPrevUndoBuffer
Undo buffer data after last undo buffer clean.
CUndoBuffer * | m_pUndoBuffer
Undo buffer object.
XTP_VIEW_LAYOUT | m_Layout
Layout data.
SEventTimeFormatInfo | m_EventTimeFormat
Information used to format events times.
CString | m_strHeaderFormat
Day header active date format string.
CString | m_strDayHeaderFormatLong
Day header Long date format custom string.
CString | m_strDayHeaderFormatMiddle
Day header Middle date format custom string.
CString | m_strDayHeaderFormatShort
Day header Short date format custom string.
CString | m_strDayHeaderFormatShortest
Day header Shortest date format custom string.
CString | m_strDayHeaderFormatDefaultLong
Day header Long date format default string.
CString | m_strDayHeaderFormatDefaultMiddle
Day header Middle date format default string.
CString | m_strDayHeaderFormatDefaultShort
Day header Short date format default string.
CString | m_strDayHeaderFormatDefaultShortest
Day header Shortest date format default string.
CRect | m_rcView
Client rect.
CRect | m_rcTooltip
Last shown tooltip rect (while GetTooltipRect returns calculated currently required tooltip rect)
CXTPCalendarEventPtr | m_ptrDraggingEventOrig
Event object before start event editing.
CXTPCalendarEventPtr | m_ptrDraggingEventNew
Editing event object.
COleDateTimeSpan | m_spDraggingStartOffset
Start dragging operation offset from the beginning of the event.
CPoint | m_ptStartDragging
Request to start dragging operation from this point.
XTPCalendarDraggingMode | m_eDraggingMode
Editing event mode.
BOOL | m_bStartedClickInside
Is OnLButtonDown was inside view rect.
CXTPCalendarViewEventPtr | m_ptrEditingViewEvent
Currently editing subject event view or event view requested to edit subject by timeout.
CXTPCalendarViewEvent * | m_pLastEvent
Last selected event.
UINT | m_nTimerID_StartEditSubject
Timer ID of edit event subject request.
UINT | m_nTimerID_ShowToolTip
Timer ID of start show tooltip request.
CXTPCalendarControl * | m_pControl
Pointer to the owner control object.
CXTPCalendarViewEvents * | m_pSelectedEvents
Selected Events;.
XTP_CALENDAR_HITTESTINFO m_LastHitInfo
Last HitInfo data.
UINT | m_nKeyStateTimerID
Timer ID to check Keys state (like Control).
XTP_CALENDAR_VIEWSELECTION | m_selectedBlock
Current selection.
BOOL | m_bScrollV_Disabled
Is vertical scrolling disabled for a view.
BOOL | m_bScrollH_Disabled
Is horizontal scrolling disabled for a view.
CXTPCalendarResources * | m_pResources
Resources array.
CXTPCalendarPtrCollectionT< CXTPCalendarViewDay > | m_arDays
Stores the view day collection.

Detailed Description

template<class _TViewDay>
class CXTPCalendarViewT< _TViewDay >

This template class represents a view portion of the Calendar control.

It represents a specific view of the Control's associated events data and provides basic functionality on this data using user input through the keyboard and the mouse. It is used as a part of the calendar control framework to build the View layer of View->DayView->ViewEvent typed objects hierarchy. These are the template parameters: _TViewDay - Type of View Day objects stored in View. _TViewEvent - Type of View Event objects stored in View Day.

 You must provide all of the above parameters.

 These are the predefined view implementations available
 for the Calendar control:

 * Day and work week views - Using the CXTPCalendarDayView class.
 * Week view               - Using the CXTPCalendarWeekView class.
 * Month view              - Using the CXTPCalendarMonthView class.

 Furthermore, any type of user-defined view may also be implemented as
 a descendant of the CXTPCalendarView class.

 A typical Calendar View model consists of a collection of
 corresponding ViewDay's, which realizes the contents on a square
 of one day. ViewDay in turn contains a collection of ViewEvent's
 for the particular day, each of them represents a view of an
 CXTPCalendarEvent object.
See also
CXTPCalendarDayView
CXTPCalendarWeekView
CXTPCalendarMonthView
CXTPCalendarViewDay
CXTPCalendarViewEvent

Constructor & Destructor Documentation

◆ CXTPCalendarViewT()

template<class _TViewDay >
CXTPCalendarViewT | ( | CXTPCalendarControl * | pCalendarControl,
 |  | XTPCalendarViewType | nViewType )
 inline

Default object constructor.

Parameters
pCalendarControl | A pointer to a CXTPCalendarControlT object.
nViewType | An XTPCalendarViewType object that contains the view type identifier.
See also
XTPCalendarViewType
~CXTPCalendarEventT()

◆ ~CXTPCalendarViewT()

template<class _TViewDay >
virtual ~CXTPCalendarViewT ( )
inlinevirtual

Default class destructor.

Handles member item deallocation.

Member Function Documentation

◆ GetViewDay()

template<class _TViewDay >
virtual _TViewDay * GetViewDay ( int nIndex ) const
inlinevirtual

Call this member function to obtain a _TViewDay object corresponding with the day's index.

Parameters
nIndex An int that contains the day view index in the view collection.
Returns
If the day's index is valid, then the function returns a pointer to a _TViewDay object that corresponds with the day's index. Otherwise, the function returns NULL.

Index numbers start with 0 and cannot be negative.

See also
GetViewDayCount()

◆ GetViewType()

template<class _TViewDay >
virtual XTPCalendarViewType GetViewType ( ) const
inlinevirtual

Call this member function to obtain the view type flag.

Returns
An XTPCalendarViewType object that contains the view type flag.
See also
XTPCalendarViewType

Implements CXTPCalendarView.

Reimplemented in CXTPCalendarDayView.

The documentation for this class was generated from the following file:
  • XTPCalendarView.h


Toolkit Pro: CXTPCalendarVisualStudio2015Theme Class Reference

Public Member Functions | List of all members
CXTPCalendarVisualStudio2015Theme Class Reference

CXTPCalendarVisualStudio2015Theme is a CXTPCalendarOffice2013Theme derived class that represents the Visual Studio 2015 calendar theme. More...

Inheritance diagram for CXTPCalendarVisualStudio2015Theme:
[legend]

Public Member Functions

CXTPCalendarVisualStudio2015Theme ()
Default paint manager constructor.
virtual | ~CXTPCalendarVisualStudio2015Theme ()
Default paint manager destructor.
- Public Member Functions inherited from CXTPCalendarOffice2013Theme
CXTPCalendarOffice2013Theme ()
Default paint manager constructor.
virtual | ~CXTPCalendarOffice2013Theme ()
Default paint manager destructor.
virtual void | RefreshMetrics ()
This member function is used to initialize all drawing defaults.
virtual void | DrawHeader (CDC *pDC, CRect &rcHeader, BOOL bIsSelected, BOOL bIsCurrent, const CXTPPaintManagerColorGradient &grclr, COLORREF clrUnderLineHdr)
This member function is used to draw the Header.
virtual void | UpdateEventLabelsDefaultColors ()
This member function is called to update event label default colors.
virtual void | UpdateEventCategoriesDefaultColors ()
This member function is called to update event category default colors.
virtual void | UpdateGlyphs ()
Initializes Calendar images.
virtual COLORREF | GetEventBackColor (CXTPCalendarEvent *pEvent)
Call this member function to get the background color for the specified event.
virtual COLORREF | GetEventEdgeColor (CXTPCalendarEvent *pEvent)
Call this member function to get the edge color for the specified event.
- Public Member Functions inherited from CXTPCalendarOffice2000Theme
CXTPCalendarOffice2000Theme ()
Default paint manager constructor.
virtual | ~CXTPCalendarOffice2000Theme ()
Default paint manager destructor.
- Public Member Functions inherited from CXTPCalendarPaintManager
BEGIN_VIEW_PART (ControlPart, XTPCalendarViewPart) virtual void RefreshMetrics()
Paint manager's ControlPart is used as parent for the other parts of the control.
END_VIEW_PART (ControlPart) BEGIN_VIEW_PART(DayViewTimeScaleHeaderPart
This paint manager part is used to draw the time scale header, 'Now' line, and the expand signs for the Day View.
virtual void | OnDraw (CDC *pDC, CXTPCalendarDayView *pView, CRect rc, CString strText)
This member function is used to draw the time scale header.
virtual void | DrawNowLine (CDC *pDC, CXTPCalendarDayView *pView, CRect rc, int y, BOOL bDrawBk=FALSE)
This member function is used to draw the 'Now' line.
virtual void | DrawNowLine (CDC *pDC, CXTPCalendarDayView *pView, CXTPCalendarDayViewTimeScale *pScale, CRect rc, int y, BOOL bDrawBk=FALSE)
This member function is used to draw the 'Now' line.
virtual void | DrawExpandSigns (CDC *pDC, CXTPCalendarDayView *pView, const CRect &rcTSHours)
This member function is used to draw expand signs.
END_VIEW_PART (DayViewTimeScaleHeaderPart) BEGIN_VIEW_PART(DayViewTimeScaleCellPart
This paint manager part is used to draw time scale time cells for the Day View.
void | AdjustTimeFont (CDC *pDC, CRect rcCell)
This member function is used to adjust the time text font size.
void | CalcWidth (CDC *pDC, const CString &strHour, const CString &strMin, int nHourHeight, int &nWidth)
This member function is used to adjust the time text font size.
virtual void | DrawHourCell (CDC *pDC, CRect rc, CString strText, BOOL bFillBackground=TRUE, BOOL bCurrentTime=FALSE)
This member function is used to draw background of the time scale header.
virtual void | DrawBigHourCell (CDC *pDC, CRect rc, CString strHour, CString strMin, int nRowPerHour, BOOL bFillBackground=TRUE, BOOL bCurrentTime=FALSE)
This member function is used to draw the big hour cell.
END_VIEW_PART (DayViewTimeScaleCellPart) BEGIN_VIEW_PART(DayViewCellPart
This paint manager part is used as the base class for the parts which draw different kinds of no all-day-cells (work/non-work) for the Day View.
virtual void | GetParams (CXTPCalendarDayViewGroup *pViewGroup, XTP_CALENDAR_DAYVIEWCELL_PARAMS *rCellParams)
This member function is used to fill out cell parameters with default values.
virtual void | OnDraw (CDC *pDC, CXTPCalendarDayViewGroup *pViewGroup, CRect rc, const XTP_CALENDAR_DAYVIEWCELL_PARAMS &cellParams)
This member function is used to draw the day view with no all-day-cells.
END_VIEW_PART (DayViewCellPart) BEGIN_VIEW_PART(DayViewWorkCellPart
This paint manager part is used to draw a day view that contains no all day work time cells.
END_VIEW_PART (DayViewWorkCellPart) BEGIN_VIEW_PART(DayViewNonworkCellPart
This paint manager part is used to draw "no all day non-work" time cells for the Day View.
END_VIEW_PART (DayViewNonworkCellPart) BEGIN_VIEW_PART(DayMonthViewHeaderPart
This paint manager part is used to draw days headers for the Day View.
END_VIEW_PART (DayMonthViewHeaderPart) BEGIN_VIEW_PART(DayViewHeaderPart
This paint manager part is used to draw days headers for the Day View.
virtual DayMonthViewHeaderPart void | OnDraw (CDC *pDC, CXTPCalendarDayViewDay *pViewDay, CRect rc, CString strText)
This member function is used to draw the day header.
END_VIEW_PART (DayViewHeaderPart) BEGIN_VIEW_PART(DayViewGroupHeaderPart
This paint manager part is used to draw Groups headers for the Day View.
virtual DayMonthViewHeaderPart void | OnDraw (CDC *pDC, CXTPCalendarDayViewGroup *pViewGroup, CRect rc, CString strText)
This member function is used to draw the day header.
END_VIEW_PART (DayViewGroupHeaderPart) BEGIN_VIEW_PART(DayViewAllDayEventsPart
This paint manager part is used to draw all day events area for the Day View.
virtual void | OnDraw (CDC *pDC, CXTPCalendarDayViewGroup *pViewGroup, CRect rc, BOOL bSelected)
This member function is used to draw the all-day events area.
END_VIEW_PART (DayViewAllDayEventsPart) BEGIN_VIEW_PART(DayViewAllDayEventScrollIconsPart
This paint manager part is used to draw all day events scroll buttons if there are too many all day events.
virtual XTPCalendarViewPart void | OnDraw (CDC *pDC, CXTPCalendarDayViewGroup *pViewGroup, BOOL bDrawUp, BOOL bDrawDown, const CRect &rcIconUp, const CRect &rcIconDown, BOOL bHighlightUp, BOOL bHighlightDown)
This member function is used to draw scroll icons in all day events area.
END_VIEW_PART (DayViewAllDayEventScrollIconsPart) BEGIN_VIEW_PART(DayViewEventPart
This paint manager part is used to draw events for the Day View.
virtual void | OnDraw (CDC *pDC, CXTPCalendarDayViewEvent *pViewEvent)
This member function is used to draw an event.
END_VIEW_PART (DayViewEventPart) BEGIN_VIEW_PART(MonthViewGridPart
This paint manager part is used to draw days grid and to fill days cells background for the Month View.
virtual void | OnDrawGrid (CDC *pDC, CXTPCalendarMonthView *pMonthView)
This member function is used to draw the days grid and to fill the days cells background.
END_VIEW_PART (MonthViewGridPart) BEGIN_VIEW_PART(MonthViewHeaderPart
This paint manager part is used to draw week days headers for the Month View.
virtual DayMonthViewHeaderPart void | OnDraw (CDC *pDC, CXTPCalendarMonthView *pMonthView, CRect rc, int nCollIndex, CString strText)
This member function is used to draw the week day header.
END_VIEW_PART (MonthViewHeaderPart) BEGIN_VIEW_PART(MonthViewEventPart
This paint manager part is used to draw events and day dates for the Month View.
virtual void | OnDrawEvent (CDC *pDC, CXTPCalendarMonthViewEvent *pViewEvent)
This member function is used to draw an event.
virtual void | OnDrawDayDate (CDC *pDC, CRect rc, BOOL bToday, BOOL bSelected, BOOL bFirstMonthDay, CString strText)
This member function is used to draw the week day header.
END_VIEW_PART (MonthViewEventPart) BEGIN_VIEW_PART(WeekViewPart
This paint manager part is used to draw week days grid and headers for the Week View.
virtual void | OnDraw (CDC *pDC, CXTPCalendarWeekView *pWeekView)
This member function is used to draw an event.
virtual void | DrawDayHeader (CDC *pDC, CRect rcDay, int nHeaderHeight, CString strHeader, BOOL bIsCurrent=FALSE, BOOL bIsSelected=FALSE)
This member function is used to draw the day header.
END_VIEW_PART (WeekViewPart) BEGIN_VIEW_PART(WeekViewEventPart
This paint manager part is used to draw events for the Week View.
virtual void | OnDraw (CDC *pDC, CXTPCalendarWeekViewEvent *pWeekViewEvent)
This member function is used to draw the specified event.
virtual void | DrawBorder (CDC *pDC, CRect rcView, CXTPCalendarWeekViewEvent *pWeekViewEvent)
This member functions is used to draw the event border.
virtual int | DrawTimes (CDC *pDC, CXTPCalendarWeekViewEvent *pWeekViewEvent)
This member function is used to draw the event's times texts or icons.
virtual void | DrawSubj (CDC *pDC, CXTPCalendarWeekViewEvent *pWeekViewEvent)
This member function is used to draw the event subject.
END_VIEW_PART (WeekViewEventPart) BEGIN_VIEW_PART(TimeLineViewTimeScalePart_Day
This paint manager part is used to draw time scale for the Time Line view.
virtual void | DrawGroup (CDC *pDC, const CRect &rcRect, CXTPCalendarTimeLineViewGroup *pGroup)
Call this function to draw the time line view group.
virtual CSize | CalcEventSize (CDC *c, CXTPCalendarTimeLineViewEvent *pViewEvent)
Call this function to calculate the time line view event size.
virtual void | DrawEvent (CDC *pDC, const CRect &rcEvents, CXTPCalendarTimeLineViewEvent *pViewEvent)
Call this function to draw the event.
virtual void | _Init ()
Call this function to do the initializations.
virtual | ~CTimeLineViewPart ()
Destroys the CTimeLineViewPart object, does the cleanup.
CXTPCalendarPaintManager ()
Default paint manager constructor.
virtual | ~CXTPCalendarPaintManager ()
Default paint manager destructor.
virtual XTPCalendarTheme | GetPaintTheme () const
This member function is used to obtain the current paint theme.
virtual void | SetPaintTheme (XTPCalendarTheme ePaintTheme)
This member function is used to set the current paint theme.
virtual COLORREF | GetEventBackColor (CXTPCalendarEvent *pEvent, COLORREF crDefault)
Call this member function to get the background color for the specified event.
virtual void | DrawLine (CDC *pDC, int xPos, int yPos, int cx, int cy)
This member function is used to draw an arbitrary line.
virtual void | DrawHorizontalLine (CDC *pDC, int xPos, int yPos, int cx)
This member function is used to draw a Horizontal line.
virtual void | DrawVerticalLine (CDC *pDC, int xPos, int yPos, int cy)
This member function is used to draw a Vertical line.
virtual int | DrawClock (CDC *pDC, COleDateTime dtClockTime, CRect rcView, COLORREF clrBackground, XTPCalendarClockAlignFlags cafAlign)
This member function is used to draw the time as a clock.
virtual int | DrawBitmap (CImageList *pImageList, CDC *pDC, CRect rcView, int iIcon, UINT uFlags=0)
This member function is used to draw a bitmap from the provided ImageList.
virtual int | DrawBitmap (UINT nIDResource, CDC *pDC, CRect rcBitmap)
This member function is used to draw the bitmap using its resource id.
virtual int | DrawIconChar (CDC *pDC, CRect rc, TCHAR ch)
This member function is used to draw the Glyph symbol using special font.
virtual const CSize | GetExpandSignSize ()
This member function is used to obtain the horizontal and vertical size of the Expand Sign bitmap.
virtual CSize | GetClockSize ()
This member function is used to obtain the horizontal and vertical size of the Clock.
virtual void | SetControl (CXTPCalendarControl *pControl)
This member function is used to set the CXTPCalendarControl object for the CXTPCalendarPaintManager.
virtual void | DrawShadow (CDC *pDC, const CRect &rcRect)
Call this member function to draw the shadow regions around the rectangle.
virtual int | DrawIcons (CDC *pDC, CXTPCalendarViewEvent *pViewEvent)
Call this member function to draw icons corresponding to the event state.
virtual void | DrawHeader (CDC *pDC, CRect &rcHeader, BOOL bIsSelected, BOOL bIsCurrent)
This member function is used to draw the Header.
virtual void | DrawBusyStatus (CDC *pDC, CRect &rcRect, int eBusyStatus)
This member function is used to fill the area using the corresponding busy color or pattern.
virtual void | DrawBusyStatus (CDC *pDC, CRgn &rgnBusy, int eBusyStatus)
This member function is used to fill the area using the corresponding busy color or pattern.
void | EnableTheme (BOOL bEnableTheme)
This member function is used to enable a new theme.
BOOL | IsThemeEnabled ()
This member function is used to obtain the status of the theme.
XTPCurrentSystemTheme GetCurrentSystemTheme ()
Call this member function to determine the current Windows XP theme that is in use.
void | SetBusyStatusBrush (int nBusyStatus, CBrush *pBrush, BOOL bAutodeleteBrush)
Call this member function to set custom brush to draw event busy status.
CBrush * | GetBusyStatusBrush (int nBusyStatus)
Call this member function to get a brush to draw event busy status.
DWORD | GetAskItemTextFlags () const
This member function returns a set of flags which define calendar items to send an XTP_NC_CALENDAR_GETITEMTEXT notification.
void | SetAskItemTextFlags (DWORD dwFlags)
This member function is used to set flags which define calendar items to send an XTP_NC_CALENDAR_GETITEMTEXT notification.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPCalendarPaintManager
DayViewTimeScaleHeaderPart CXTPCalendarViewPartFontValue | m_fntTimeText
Time text font.
int | m_nHourWidth
Width of hour part of the text in pixels.
int | m_nMinWidth
Width of minutes (am/pm) part of the text in pixels.
BOOL | m_bShowMinutes
Show minutes in TS when '60 Minutes' is selected.
XTPCalendarViewPart CXTPPaintManagerColor | m_clrBackgroundSlave
Background secondary color.
CXTPPaintManagerColor | m_clrShadow
Cell background color.
CXTPPaintManagerColor | m_clrHour
Cell border color.
XTPCalendarViewPart CXTPPaintManagerColor | m_clrBackground2
Second background color which is used to fill days background.
XTPCalendarViewPart COLORREF | m_clrTextHighLightColor
Text color for the selected event.
COLORREF | m_clrMultiDayEventFrameColor
Multi-day event frame color.
COLORREF | m_clrClassicUnderline
Underline color for today day.
CXTPPaintManagerColorGradient | m_grclrClassicSelDay
Gradient color for today day.
COLORREF | m_clrTextNormalColor
Text color for the day header and some other elements.
COLORREF | m_clrHeaderBottomLine
Text color for the day header bottom line.
XTPCalendarTimeLineViewPart CXTPPaintManagerColor | m_clrEventBar
Event bar color.
CXTPPaintManagerColor m_clrEventBarLine
Event bar line color.
CXTPPaintManagerColor | m_clrEventBorderLine
Event border line color.
CXTPPaintManagerColor | m_clrTimeScaleBackground
Time scale background color.
CXTPPaintManagerColor | m_clrTimeScaleHightlite
Time scale highlight color.
CXTPPaintManagerColor m_clrTimeScaleText
The time scale text color.
CXTPPaintManagerColor | m_clrSelectedBackground
The selected background color.
CXTPPaintManagerColor m_clrSelectedText
The selected text color.
CXTPPaintManagerColor | m_clrBackground
The background color.
CXTPPaintManagerColor | m_clrText
The text color.
CXTPPaintManagerColor | m_clrWeekendBackground
Time scale weekend background color.
CXTPPaintManagerColor m_clrButtonFace
Stores standard Button Face color.
CXTPPaintManagerColor | m_clrButtonFaceText
Stores standard color to display text.
CXTPPaintManagerColor m_clrWindow
Stores standard windows color.
CXTPPaintManagerColor m_clrWindowText
Stores standard color to display window text.
CXTPPaintManagerColor m_clr3DShadow
Stores standard color to display shadow items.
CXTPPaintManagerColor | m_clrHighlight
Stores standard color to display highlighted items.
CXTPPaintManagerColor | m_clrBorders [4]
Stores border line color, left = 0, top = 1, right = 2, bottom = 3.
CXTPPaintManagerColorGradient | m_grclrToday
Gradient color of today's header.
CUIntArray | m_arStartCol
hold start column in each virtual page
CUIntArray | m_arStartRow
hold start row in each virtual page

int | m_PrintPageWidth
Print page width.
- Protected Types inherited from CXTPCalendarPaintManager
enum | XTPEnumExpandSigns { idxExpandSignUp = 0 , idxExpandSignDown = 1 }
Enumerates types of expand signs drawn on a day view. More...
enum XTPEnumEventGlyphs {
idxMeeting = 0 , idxPrivate = 1 , idxRecurrenceException = 2 , idxRecurrenceOccurrence = 3 ,
idxReminder = 4
}
Enumerates types of event glyphs. More...
- Protected Member Functions inherited from CXTPCalendarOffice2013Theme
- Protected Member Functions inherited from CXTPCalendarPaintManager
CXTPCalendarViewPart * | AddViewPart (CXTPCalendarViewPart *pPart)
Call this member function to add the specified ViewPart object to the parts list.
CXTPCalendarViewPartBrushValue * | _GetAtGrow_BusyStatusBrushValue (int eBusyStatus, BOOL bGrow)
Returns drawing brush value for a specific busy status.
virtual void | InitBusyStatusDefaultColors ()
Set default colors/patterns to fill Busy Status area.
- Protected Attributes inherited from CXTPCalendarOffice2013Theme
- Protected Attributes inherited from CXTPCalendarPaintManager
CList< CXTPCalendarViewPart *, CXTPCalendarViewPart * > | m_lstViewParts
Collection to store ViewParts objects.
CXTPImageManager * | m_pExpandSigns
Stores standard Expand Signs icons.
CXTPImageManager * m_pGlyphs
Stores standard glyphs for displaying events.
CFont * | m_pGlyphsFont
Stores standard glyphs font for displaying events.
CBitmap | m_bmpElsewherePattern
Stores standard bitmap pattern to draw Elsewhere event busy status.
CXTPBrush | m_xtpBrushElsewhere
Stores standard brush to draw Elsewhere event busy status.
CBitmap | m_bmpTentativePattern
Stores standard bitmap pattern to draw Tentative event busy status.
CXTPBrush | m_xtpBrushTentative
Stores standard brush to draw Tentative event busy status.
CXTPCalendarTypedPtrAutoDeleteArray< CPtrArray, CXTPCalendarViewPartBrushValue * > | m_arBusyStatusBrushes
Stores customizable brush values to draw Event Busy Status in the Day View.
CSize | m_szClockRect
Stores dimensions for a rectangle used to display the time as a clock glyph.
CXTPCalendarControl * | m_pControl
Stores a pointer to a CXTPCalendarControl object.
BOOL | m_bEnableTheme
True to enable Luna theme.
COLORREF | m_clrUnderLineHdr
Color of header's underline.
XTPCurrentSystemTheme | m_CurrSystemTheme
Current theme flag.
XTPCalendarTheme | m_nPaintTheme
Store the Paint Theme;.
DWORD | m_dwAskItemTextFlags
Store flag set to send XTP_NC_CALENDAR_GETITEMTEXT notification.

Detailed Description

CXTPCalendarVisualStudio2015Theme is a CXTPCalendarOffice2013Theme derived class that represents the Visual Studio 2015 calendar theme.

Constructor & Destructor Documentation

◆ CXTPCalendarVisualStudio2015Theme()

CXTPCalendarVisualStudio2015Theme ( )

Default paint manager constructor.

Handles initial initialization.

See also
RefreshMetrics()

◆ ~CXTPCalendarVisualStudio2015Theme()

virtual ~CXTPCalendarVisualStudio2015Theme ( )
virtual

Default paint manager destructor.

Handles member items deallocation.

The documentation for this class was generated from the following file:
  • XTPCalendarVisualStudio2015Theme.h


Toolkit Pro: CXTPCalendarVisualStudio2017Theme Class Reference

Public Member Functions | List of all members
CXTPCalendarVisualStudio2017Theme Class Reference

CXTPCalendarVisualStudio2017Theme is a CXTPCalendarOffice2013Theme derived class that represents the Visual Studio 2017 calendar theme. More...

Inheritance diagram for CXTPCalendarVisualStudio2017Theme:
[legend]

Public Member Functions

CXTPCalendarVisualStudio2017Theme ()
Default paint manager constructor.
virtual | ~CXTPCalendarVisualStudio2017Theme ()
Default paint manager destructor.
- Public Member Functions inherited from CXTPCalendarOffice2013Theme
CXTPCalendarOffice2013Theme ()
Default paint manager constructor.
virtual | ~CXTPCalendarOffice2013Theme ()
Default paint manager destructor.
virtual void | RefreshMetrics ()
This member function is used to initialize all drawing defaults.
virtual void | DrawHeader (CDC *pDC, CRect &rcHeader, BOOL bIsSelected, BOOL bIsCurrent, const CXTPPaintManagerColorGradient &grclr, COLORREF clrUnderLineHdr)
This member function is used to draw the Header.
virtual void | UpdateEventLabelsDefaultColors ()
This member function is called to update event label default colors.
virtual void | UpdateEventCategoriesDefaultColors ()
This member function is called to update event category default colors.
virtual void | UpdateGlyphs ()
Initializes Calendar images.
virtual COLORREF | GetEventBackColor (CXTPCalendarEvent *pEvent)
Call this member function to get the background color for the specified event.
virtual COLORREF | GetEventEdgeColor (CXTPCalendarEvent *pEvent)
Call this member function to get the edge color for the specified event.
- Public Member Functions inherited from CXTPCalendarOffice2000Theme
CXTPCalendarOffice2000Theme ()
Default paint manager constructor.
virtual | ~CXTPCalendarOffice2000Theme ()
Default paint manager destructor.
- Public Member Functions inherited from CXTPCalendarPaintManager
BEGIN_VIEW_PART (ControlPart, XTPCalendarViewPart) virtual void RefreshMetrics()
Paint manager's ControlPart is used as parent for the other parts of the control.
END_VIEW_PART (ControlPart) BEGIN_VIEW_PART(DayViewTimeScaleHeaderPart
This paint manager part is used to draw the time scale header, 'Now' line, and the expand signs for the Day View.
virtual void | OnDraw (CDC *pDC, CXTPCalendarDayView *pView, CRect rc, CString strText)
This member function is used to draw the time scale header.
virtual void | DrawNowLine (CDC *pDC, CXTPCalendarDayView *pView, CRect rc, int y, BOOL bDrawBk=FALSE)
This member function is used to draw the 'Now' line.
virtual void | DrawNowLine (CDC *pDC, CXTPCalendarDayView *pView, CXTPCalendarDayViewTimeScale *pScale, CRect rc, int y, BOOL bDrawBk=FALSE)
This member function is used to draw the 'Now' line.
virtual void | DrawExpandSigns (CDC *pDC, CXTPCalendarDayView *pView, const CRect &rcTSHours)
This member function is used to draw expand signs.
END_VIEW_PART (DayViewTimeScaleHeaderPart) BEGIN_VIEW_PART(DayViewTimeScaleCellPart
This paint manager part is used to draw time scale time cells for the Day View.
void | AdjustTimeFont (CDC *pDC, CRect rcCell)
This member function is used to adjust the time text font size.
void | CalcWidth (CDC *pDC, const CString &strHour, const CString &strMin, int nHourHeight, int &nWidth)
This member function is used to adjust the time text font size.
virtual void | DrawHourCell (CDC *pDC, CRect rc, CString strText, BOOL bFillBackground=TRUE, BOOL bCurrentTime=FALSE)
This member function is used to draw background of the time scale header.
virtual void | DrawBigHourCell (CDC *pDC, CRect rc, CString strHour, CString strMin, int nRowPerHour, BOOL bFillBackground=TRUE, BOOL bCurrentTime=FALSE)
This member function is used to draw the big hour cell.
END_VIEW_PART (DayViewTimeScaleCellPart) BEGIN_VIEW_PART(DayViewCellPart
This paint manager part is used as the base class for the parts which draw different kinds of no all-day-cells (work/non-work) for the Day View.
virtual void | GetParams (CXTPCalendarDayViewGroup *pViewGroup, XTP_CALENDAR_DAYVIEWCELL_PARAMS *rCellParams)
This member function is used to fill out cell parameters with default values.
virtual void | OnDraw (CDC *pDC, CXTPCalendarDayViewGroup *pViewGroup, CRect rc, const XTP_CALENDAR_DAYVIEWCELL_PARAMS &cellParams)
This member function is used to draw the day view with no all-day-cells.
END_VIEW_PART (DayViewCellPart) BEGIN_VIEW_PART(DayViewWorkCellPart
This paint manager part is used to draw a day view that contains no all day work time cells.
END_VIEW_PART (DayViewWorkCellPart) BEGIN_VIEW_PART(DayViewNonworkCellPart
This paint manager part is used to draw "no all day non-work" time cells for the Day View.
END_VIEW_PART (DayViewNonworkCellPart) BEGIN_VIEW_PART(DayMonthViewHeaderPart
This paint manager part is used to draw days headers for the Day View.
END_VIEW_PART (DayMonthViewHeaderPart) BEGIN_VIEW_PART(DayViewHeaderPart
This paint manager part is used to draw days headers for the Day View.
virtual DayMonthViewHeaderPart void | OnDraw (CDC *pDC, CXTPCalendarDayViewDay *pViewDay, CRect rc, CString strText)
This member function is used to draw the day header.
END_VIEW_PART (DayViewHeaderPart) BEGIN_VIEW_PART(DayViewGroupHeaderPart
This paint manager part is used to draw Groups headers for the Day View.
virtual DayMonthViewHeaderPart void | OnDraw (CDC *pDC, CXTPCalendarDayViewGroup *pViewGroup, CRect rc, CString strText)
This member function is used to draw the day header.
END_VIEW_PART (DayViewGroupHeaderPart) BEGIN_VIEW_PART(DayViewAllDayEventsPart
This paint manager part is used to draw all day events area for the Day View.
virtual void | OnDraw (CDC *pDC, CXTPCalendarDayViewGroup *pViewGroup, CRect rc, BOOL bSelected)
This member function is used to draw the all-day events area.
END_VIEW_PART (DayViewAllDayEventsPart) BEGIN_VIEW_PART(DayViewAllDayEventScrollIconsPart
This paint manager part is used to draw all day events scroll buttons if there are too many all day events.
virtual XTPCalendarViewPart void | OnDraw (CDC *pDC, CXTPCalendarDayViewGroup *pViewGroup, BOOL bDrawUp, BOOL bDrawDown, const CRect &rcIconUp, const CRect &rcIconDown, BOOL bHighlightUp, BOOL bHighlightDown)
This member function is used to draw scroll icons in all day events area.
END_VIEW_PART (DayViewAllDayEventScrollIconsPart) BEGIN_VIEW_PART(DayViewEventPart
This paint manager part is used to draw events for the Day View.
virtual void | OnDraw (CDC *pDC, CXTPCalendarDayViewEvent *pViewEvent)
This member function is used to draw an event.
END_VIEW_PART (DayViewEventPart) BEGIN_VIEW_PART(MonthViewGridPart
This paint manager part is used to draw days grid and to fill days cells background for the Month View.
virtual void | OnDrawGrid (CDC *pDC, CXTPCalendarMonthView *pMonthView)
This member function is used to draw the days grid and to fill the days cells background.
END_VIEW_PART (MonthViewGridPart) BEGIN_VIEW_PART(MonthViewHeaderPart
This paint manager part is used to draw week days headers for the Month View.
virtual DayMonthViewHeaderPart void | OnDraw (CDC *pDC, CXTPCalendarMonthView *pMonthView, CRect rc, int nCollIndex, CString strText)
This member function is used to draw the week day header.
END_VIEW_PART (MonthViewHeaderPart) BEGIN_VIEW_PART(MonthViewEventPart
This paint manager part is used to draw events and day dates for the Month View.
virtual void | OnDrawEvent (CDC *pDC, CXTPCalendarMonthViewEvent *pViewEvent)
This member function is used to draw an event.
virtual void | OnDrawDayDate (CDC *pDC, CRect rc, BOOL bToday, BOOL bSelected, BOOL bFirstMonthDay, CString strText)
This member function is used to draw the week day header.
END_VIEW_PART (MonthViewEventPart) BEGIN_VIEW_PART(WeekViewPart
This paint manager part is used to draw week days grid and headers for the Week View.
virtual void | OnDraw (CDC *pDC, CXTPCalendarWeekView *pWeekView)
This member function is used to draw an event.
virtual void | DrawDayHeader (CDC *pDC, CRect rcDay, int nHeaderHeight, CString strHeader, BOOL bIsCurrent=FALSE, BOOL bIsSelected=FALSE)
This member function is used to draw the day header.
END_VIEW_PART (WeekViewPart) BEGIN_VIEW_PART(WeekViewEventPart
This paint manager part is used to draw events for the Week View.
virtual void | OnDraw (CDC *pDC, CXTPCalendarWeekViewEvent *pWeekViewEvent)
This member function is used to draw the specified event.
virtual void | DrawBorder (CDC *pDC, CRect rcView, CXTPCalendarWeekViewEvent *pWeekViewEvent)
This member functions is used to draw the event border.
virtual int | DrawTimes (CDC *pDC, CXTPCalendarWeekViewEvent *pWeekViewEvent)
This member function is used to draw the event's times texts or icons.
virtual void | DrawSubj (CDC *pDC, CXTPCalendarWeekViewEvent *pWeekViewEvent)
This member function is used to draw the event subject.
END_VIEW_PART (WeekViewEventPart) BEGIN_VIEW_PART(TimeLineViewTimeScalePart_Day
This paint manager part is used to draw time scale for the Time Line view.
virtual void | DrawGroup (CDC *pDC, const CRect &rcRect, CXTPCalendarTimeLineViewGroup *pGroup)
Call this function to draw the time line view group.
virtual CSize | CalcEventSize (CDC *c, CXTPCalendarTimeLineViewEvent *pViewEvent)
Call this function to calculate the time line view event size.
virtual void | DrawEvent (CDC *pDC, const CRect &rcEvents, CXTPCalendarTimeLineViewEvent *pViewEvent)
Call this function to draw the event.
virtual void | _Init ()
Call this function to do the initializations.
virtual | ~CTimeLineViewPart ()
Destroys the CTimeLineViewPart object, does the cleanup.
CXTPCalendarPaintManager ()
Default paint manager constructor.
virtual | ~CXTPCalendarPaintManager ()
Default paint manager destructor.
virtual XTPCalendarTheme | GetPaintTheme () const
This member function is used to obtain the current paint theme.
virtual void | SetPaintTheme (XTPCalendarTheme ePaintTheme)
This member function is used to set the current paint theme.
virtual COLORREF | GetEventBackColor (CXTPCalendarEvent *pEvent, COLORREF crDefault)
Call this member function to get the background color for the specified event.
virtual void | DrawLine (CDC *pDC, int xPos, int yPos, int cx, int cy)
This member function is used to draw an arbitrary line.
virtual void | DrawHorizontalLine (CDC *pDC, int xPos, int yPos, int cx)
This member function is used to draw a Horizontal line.
virtual void | DrawVerticalLine (CDC *pDC, int xPos, int yPos, int cy)
This member function is used to draw a Vertical line.
virtual int | DrawClock (CDC *pDC, COleDateTime dtClockTime, CRect rcView, COLORREF clrBackground, XTPCalendarClockAlignFlags cafAlign)
This member function is used to draw the time as a clock.
virtual int | DrawBitmap (CImageList *pImageList, CDC *pDC, CRect rcView, int iIcon, UINT uFlags=0)
This member function is used to draw a bitmap from the provided ImageList.
virtual int | DrawBitmap (UINT nIDResource, CDC *pDC, CRect rcBitmap)
This member function is used to draw the bitmap using its resource id.
virtual int | DrawIconChar (CDC *pDC, CRect rc, TCHAR ch)
This member function is used to draw the Glyph symbol using special font.
virtual const CSize | GetExpandSignSize ()
This member function is used to obtain the horizontal and vertical size of the Expand Sign bitmap.
virtual CSize | GetClockSize ()
This member function is used to obtain the horizontal and vertical size of the Clock.
virtual void | SetControl (CXTPCalendarControl *pControl)
This member function is used to set the CXTPCalendarControl object for the CXTPCalendarPaintManager.
virtual void | DrawShadow (CDC *pDC, const CRect &rcRect)
Call this member function to draw the shadow regions around the rectangle.
virtual int | DrawIcons (CDC *pDC, CXTPCalendarViewEvent *pViewEvent)
Call this member function to draw icons corresponding to the event state.
virtual void | DrawHeader (CDC *pDC, CRect &rcHeader, BOOL bIsSelected, BOOL bIsCurrent)
This member function is used to draw the Header.
virtual void | DrawBusyStatus (CDC *pDC, CRect &rcRect, int eBusyStatus)
This member function is used to fill the area using the corresponding busy color or pattern.
virtual void | DrawBusyStatus (CDC *pDC, CRgn &rgnBusy, int eBusyStatus)
This member function is used to fill the area using the corresponding busy color or pattern.
void | EnableTheme (BOOL bEnableTheme)
This member function is used to enable a new theme.
BOOL | IsThemeEnabled ()
This member function is used to obtain the status of the theme.
XTPCurrentSystemTheme GetCurrentSystemTheme ()
Call this member function to determine the current Windows XP theme that is in use.
void | SetBusyStatusBrush (int nBusyStatus, CBrush *pBrush, BOOL bAutodeleteBrush)
Call this member function to set custom brush to draw event busy status.
CBrush * | GetBusyStatusBrush (int nBusyStatus)
Call this member function to get a brush to draw event busy status.
DWORD | GetAskItemTextFlags () const
This member function returns a set of flags which define calendar items to send an XTP_NC_CALENDAR_GETITEMTEXT notification.
void | SetAskItemTextFlags (DWORD dwFlags)
This member function is used to set flags which define calendar items to send an XTP_NC_CALENDAR_GETITEMTEXT notification.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPCalendarPaintManager
DayViewTimeScaleHeaderPart CXTPCalendarViewPartFontValue | m_fntTimeText
Time text font.
int | m_nHourWidth
Width of hour part of the text in pixels.
int | m_nMinWidth
Width of minutes (am/pm) part of the text in pixels.
BOOL | m_bShowMinutes
Show minutes in TS when '60 Minutes' is selected.
XTPCalendarViewPart CXTPPaintManagerColor | m_clrBackgroundSlave
Background secondary color.
CXTPPaintManagerColor | m_clrShadow
Cell background color.
CXTPPaintManagerColor | m_clrHour
Cell border color.
XTPCalendarViewPart CXTPPaintManagerColor | m_clrBackground2
Second background color which is used to fill days background.
XTPCalendarViewPart COLORREF | m_clrTextHighLightColor
Text color for the selected event.
COLORREF | m_clrMultiDayEventFrameColor
Multi-day event frame color.
COLORREF | m_clrClassicUnderline
Underline color for today day.
CXTPPaintManagerColorGradient | m_grclrClassicSelDay
Gradient color for today day.
COLORREF | m_clrTextNormalColor
Text color for the day header and some other elements.
COLORREF | m_clrHeaderBottomLine
Text color for the day header bottom line.
XTPCalendarTimeLineViewPart CXTPPaintManagerColor | m_clrEventBar
Event bar color.
CXTPPaintManagerColor m_clrEventBarLine
Event bar line color.
CXTPPaintManagerColor | m_clrEventBorderLine
Event border line color.
CXTPPaintManagerColor | m_clrTimeScaleBackground
Time scale background color.
CXTPPaintManagerColor | m_clrTimeScaleHightlite
Time scale highlight color.
CXTPPaintManagerColor m_clrTimeScaleText
The time scale text color.
CXTPPaintManagerColor | m_clrSelectedBackground
The selected background color.
CXTPPaintManagerColor m_clrSelectedText
The selected text color.
CXTPPaintManagerColor | m_clrBackground
The background color.
CXTPPaintManagerColor | m_clrText
The text color.
CXTPPaintManagerColor | m_clrWeekendBackground
Time scale weekend background color.
CXTPPaintManagerColor m_clrButtonFace
Stores standard Button Face color.
CXTPPaintManagerColor | m_clrButtonFaceText
Stores standard color to display text.
CXTPPaintManagerColor m_clrWindow
Stores standard windows color.
CXTPPaintManagerColor m_clrWindowText
Stores standard color to display window text.
CXTPPaintManagerColor m_clr3DShadow
Stores standard color to display shadow items.
CXTPPaintManagerColor | m_clrHighlight
Stores standard color to display highlighted items.
CXTPPaintManagerColor | m_clrBorders [4]
Stores border line color, left = 0, top = 1, right = 2, bottom = 3.
CXTPPaintManagerColorGradient | m_grclrToday
Gradient color of today's header.
CUIntArray | m_arStartCol
hold start column in each virtual page
CUIntArray | m_arStartRow
hold start row in each virtual page

int | m_PrintPageWidth
Print page width.
- Protected Types inherited from CXTPCalendarPaintManager
enum | XTPEnumExpandSigns { idxExpandSignUp = 0 , idxExpandSignDown = 1 }
Enumerates types of expand signs drawn on a day view. More...
enum XTPEnumEventGlyphs {
idxMeeting = 0 , idxPrivate = 1 , idxRecurrenceException = 2 , idxRecurrenceOccurrence = 3 ,
idxReminder = 4
}
Enumerates types of event glyphs. More...
- Protected Member Functions inherited from CXTPCalendarOffice2013Theme
- Protected Member Functions inherited from CXTPCalendarPaintManager
CXTPCalendarViewPart * | AddViewPart (CXTPCalendarViewPart *pPart)
Call this member function to add the specified ViewPart object to the parts list.
CXTPCalendarViewPartBrushValue * | _GetAtGrow_BusyStatusBrushValue (int eBusyStatus, BOOL bGrow)
Returns drawing brush value for a specific busy status.
virtual void | InitBusyStatusDefaultColors ()
Set default colors/patterns to fill Busy Status area.
- Protected Attributes inherited from CXTPCalendarOffice2013Theme
- Protected Attributes inherited from CXTPCalendarPaintManager
CList< CXTPCalendarViewPart *, CXTPCalendarViewPart * > | m_lstViewParts
Collection to store ViewParts objects.
CXTPImageManager * | m_pExpandSigns
Stores standard Expand Signs icons.
CXTPImageManager * m_pGlyphs
Stores standard glyphs for displaying events.
CFont * | m_pGlyphsFont
Stores standard glyphs font for displaying events.
CBitmap | m_bmpElsewherePattern
Stores standard bitmap pattern to draw Elsewhere event busy status.
CXTPBrush | m_xtpBrushElsewhere
Stores standard brush to draw Elsewhere event busy status.
CBitmap | m_bmpTentativePattern
Stores standard bitmap pattern to draw Tentative event busy status.
CXTPBrush | m_xtpBrushTentative
Stores standard brush to draw Tentative event busy status.
CXTPCalendarTypedPtrAutoDeleteArray< CPtrArray, CXTPCalendarViewPartBrushValue * > | m_arBusyStatusBrushes
Stores customizable brush values to draw Event Busy Status in the Day View.
CSize | m_szClockRect
Stores dimensions for a rectangle used to display the time as a clock glyph.
CXTPCalendarControl * | m_pControl
Stores a pointer to a CXTPCalendarControl object.
BOOL | m_bEnableTheme
True to enable Luna theme.
COLORREF | m_clrUnderLineHdr
Color of header's underline.
XTPCurrentSystemTheme | m_CurrSystemTheme
Current theme flag.
XTPCalendarTheme | m_nPaintTheme
Store the Paint Theme;.
DWORD | m_dwAskItemTextFlags
Store flag set to send XTP_NC_CALENDAR_GETITEMTEXT notification.

Detailed Description

CXTPCalendarVisualStudio2017Theme is a CXTPCalendarOffice2013Theme derived class that represents the Visual Studio 2017 calendar theme.

Constructor & Destructor Documentation

◆ CXTPCalendarVisualStudio2017Theme()

CXTPCalendarVisualStudio2017Theme ( )

Default paint manager constructor.

Handles initial initialization.

See also
RefreshMetrics()

◆ ~CXTPCalendarVisualStudio2017Theme()

virtual ~CXTPCalendarVisualStudio2017Theme ( )
virtual

Default paint manager destructor.

Handles member items deallocation.

The documentation for this class was generated from the following file:
  • XTPCalendarVisualStudio2017Theme.h


Toolkit Pro: CXTPCalendarVisualStudio2019Theme Class Reference

Public Member Functions | List of all members
CXTPCalendarVisualStudio2019Theme Class Reference

CXTPCalendarVisualStudio2019Theme is a CXTPCalendarOffice2013Theme derived class that represents the Visual Studio 2019 calendar theme. More...

Inheritance diagram for CXTPCalendarVisualStudio2019Theme:
[legend]

Public Member Functions

CXTPCalendarVisualStudio2019Theme ()
Default paint manager constructor.
virtual | ~CXTPCalendarVisualStudio2019Theme ()
Default paint manager destructor.
- Public Member Functions inherited from CXTPCalendarOffice2013Theme
CXTPCalendarOffice2013Theme ()
Default paint manager constructor.
virtual | ~CXTPCalendarOffice2013Theme ()
Default paint manager destructor.
virtual void | RefreshMetrics ()
This member function is used to initialize all drawing defaults.
virtual void | DrawHeader (CDC *pDC, CRect &rcHeader, BOOL bIsSelected, BOOL bIsCurrent, const CXTPPaintManagerColorGradient &grclr, COLORREF clrUnderLineHdr)
This member function is used to draw the Header.
virtual void | UpdateEventLabelsDefaultColors ()
This member function is called to update event label default colors.
virtual void | UpdateEventCategoriesDefaultColors ()
This member function is called to update event category default colors.
virtual void | UpdateGlyphs ()
Initializes Calendar images.
virtual COLORREF | GetEventBackColor (CXTPCalendarEvent *pEvent)
Call this member function to get the background color for the specified event.
virtual COLORREF | GetEventEdgeColor (CXTPCalendarEvent *pEvent)
Call this member function to get the edge color for the specified event.
- Public Member Functions inherited from CXTPCalendarOffice2000Theme
CXTPCalendarOffice2000Theme ()
Default paint manager constructor.
virtual | ~CXTPCalendarOffice2000Theme ()
Default paint manager destructor.
- Public Member Functions inherited from CXTPCalendarPaintManager
BEGIN_VIEW_PART (ControlPart, XTPCalendarViewPart) virtual void RefreshMetrics()
Paint manager's ControlPart is used as parent for the other parts of the control.
END_VIEW_PART (ControlPart) BEGIN_VIEW_PART(DayViewTimeScaleHeaderPart
This paint manager part is used to draw the time scale header, 'Now' line, and the expand signs for the Day View.
virtual void | OnDraw (CDC *pDC, CXTPCalendarDayView *pView, CRect rc, CString strText)
This member function is used to draw the time scale header.
virtual void | DrawNowLine (CDC *pDC, CXTPCalendarDayView *pView, CRect rc, int y, BOOL bDrawBk=FALSE)
This member function is used to draw the 'Now' line.
virtual void | DrawNowLine (CDC *pDC, CXTPCalendarDayView *pView, CXTPCalendarDayViewTimeScale *pScale, CRect rc, int y, BOOL bDrawBk=FALSE)
This member function is used to draw the 'Now' line.
virtual void | DrawExpandSigns (CDC *pDC, CXTPCalendarDayView *pView, const CRect &rcTSHours)
This member function is used to draw expand signs.
END_VIEW_PART (DayViewTimeScaleHeaderPart) BEGIN_VIEW_PART(DayViewTimeScaleCellPart
This paint manager part is used to draw time scale time cells for the Day View.
void | AdjustTimeFont (CDC *pDC, CRect rcCell)
This member function is used to adjust the time text font size.
void | CalcWidth (CDC *pDC, const CString &strHour, const CString &strMin, int nHourHeight, int &nWidth)
This member function is used to adjust the time text font size.
virtual void | DrawHourCell (CDC *pDC, CRect rc, CString strText, BOOL bFillBackground=TRUE, BOOL bCurrentTime=FALSE)
This member function is used to draw background of the time scale header.
virtual void | DrawBigHourCell (CDC *pDC, CRect rc, CString strHour, CString strMin, int nRowPerHour, BOOL bFillBackground=TRUE, BOOL bCurrentTime=FALSE)
This member function is used to draw the big hour cell.
END_VIEW_PART (DayViewTimeScaleCellPart) BEGIN_VIEW_PART(DayViewCellPart
This paint manager part is used as the base class for the parts which draw different kinds of no all-day-cells (work/non-work) for the Day View.
virtual void | GetParams (CXTPCalendarDayViewGroup *pViewGroup, XTP_CALENDAR_DAYVIEWCELL_PARAMS *rCellParams)
This member function is used to fill out cell parameters with default values.
virtual void | OnDraw (CDC *pDC, CXTPCalendarDayViewGroup *pViewGroup, CRect rc, const XTP_CALENDAR_DAYVIEWCELL_PARAMS &cellParams)
This member function is used to draw the day view with no all-day-cells.
END_VIEW_PART (DayViewCellPart) BEGIN_VIEW_PART(DayViewWorkCellPart
This paint manager part is used to draw a day view that contains no all day work time cells.
END_VIEW_PART (DayViewWorkCellPart) BEGIN_VIEW_PART(DayViewNonworkCellPart
This paint manager part is used to draw "no all day non-work" time cells for the Day View.
END_VIEW_PART (DayViewNonworkCellPart) BEGIN_VIEW_PART(DayMonthViewHeaderPart
This paint manager part is used to draw days headers for the Day View.
END_VIEW_PART (DayMonthViewHeaderPart) BEGIN_VIEW_PART(DayViewHeaderPart
This paint manager part is used to draw days headers for the Day View.
virtual DayMonthViewHeaderPart void | OnDraw (CDC *pDC, CXTPCalendarDayViewDay *pViewDay, CRect rc, CString strText)
This member function is used to draw the day header.
END_VIEW_PART (DayViewHeaderPart) BEGIN_VIEW_PART(DayViewGroupHeaderPart
This paint manager part is used to draw Groups headers for the Day View.
virtual DayMonthViewHeaderPart void | OnDraw (CDC *pDC, CXTPCalendarDayViewGroup *pViewGroup, CRect rc, CString strText)
This member function is used to draw the day header.
END_VIEW_PART (DayViewGroupHeaderPart) BEGIN_VIEW_PART(DayViewAllDayEventsPart
This paint manager part is used to draw all day events area for the Day View.
virtual void | OnDraw (CDC *pDC, CXTPCalendarDayViewGroup *pViewGroup, CRect rc, BOOL bSelected)
This member function is used to draw the all-day events area.
END_VIEW_PART (DayViewAllDayEventsPart) BEGIN_VIEW_PART(DayViewAllDayEventScrollIconsPart
This paint manager part is used to draw all day events scroll buttons if there are too many all day events.
virtual XTPCalendarViewPart void | OnDraw (CDC *pDC, CXTPCalendarDayViewGroup *pViewGroup, BOOL bDrawUp, BOOL bDrawDown, const CRect &rcIconUp, const CRect &rcIconDown, BOOL bHighlightUp, BOOL bHighlightDown)
This member function is used to draw scroll icons in all day events area.
END_VIEW_PART (DayViewAllDayEventScrollIconsPart) BEGIN_VIEW_PART(DayViewEventPart
This paint manager part is used to draw events for the Day View.
virtual void | OnDraw (CDC *pDC, CXTPCalendarDayViewEvent *pViewEvent)
This member function is used to draw an event.
END_VIEW_PART (DayViewEventPart) BEGIN_VIEW_PART(MonthViewGridPart
This paint manager part is used to draw days grid and to fill days cells background for the Month View.
virtual void | OnDrawGrid (CDC *pDC, CXTPCalendarMonthView *pMonthView)
This member function is used to draw the days grid and to fill the days cells background.
END_VIEW_PART (MonthViewGridPart) BEGIN_VIEW_PART(MonthViewHeaderPart
This paint manager part is used to draw week days headers for the Month View.
virtual DayMonthViewHeaderPart void | OnDraw (CDC *pDC, CXTPCalendarMonthView *pMonthView, CRect rc, int nCollIndex, CString strText)
This member function is used to draw the week day header.
END_VIEW_PART (MonthViewHeaderPart) BEGIN_VIEW_PART(MonthViewEventPart
This paint manager part is used to draw events and day dates for the Month View.
virtual void | OnDrawEvent (CDC *pDC, CXTPCalendarMonthViewEvent *pViewEvent)
This member function is used to draw an event.
virtual void | OnDrawDayDate (CDC *pDC, CRect rc, BOOL bToday, BOOL bSelected, BOOL bFirstMonthDay, CString strText)
This member function is used to draw the week day header.
END_VIEW_PART (MonthViewEventPart) BEGIN_VIEW_PART(WeekViewPart
This paint manager part is used to draw week days grid and headers for the Week View.
virtual void | OnDraw (CDC *pDC, CXTPCalendarWeekView *pWeekView)
This member function is used to draw an event.
virtual void | DrawDayHeader (CDC *pDC, CRect rcDay, int nHeaderHeight, CString strHeader, BOOL bIsCurrent=FALSE, BOOL bIsSelected=FALSE)
This member function is used to draw the day header.
END_VIEW_PART (WeekViewPart) BEGIN_VIEW_PART(WeekViewEventPart
This paint manager part is used to draw events for the Week View.
virtual void | OnDraw (CDC *pDC, CXTPCalendarWeekViewEvent *pWeekViewEvent)
This member function is used to draw the specified event.
virtual void | DrawBorder (CDC *pDC, CRect rcView, CXTPCalendarWeekViewEvent *pWeekViewEvent)
This member functions is used to draw the event border.
virtual int | DrawTimes (CDC *pDC, CXTPCalendarWeekViewEvent *pWeekViewEvent)
This member function is used to draw the event's times texts or icons.
virtual void | DrawSubj (CDC *pDC, CXTPCalendarWeekViewEvent *pWeekViewEvent)
This member function is used to draw the event subject.
END_VIEW_PART (WeekViewEventPart) BEGIN_VIEW_PART(TimeLineViewTimeScalePart_Day
This paint manager part is used to draw time scale for the Time Line view.
virtual void | DrawGroup (CDC *pDC, const CRect &rcRect, CXTPCalendarTimeLineViewGroup *pGroup)
Call this function to draw the time line view group.
virtual CSize | CalcEventSize (CDC *c, CXTPCalendarTimeLineViewEvent *pViewEvent)
Call this function to calculate the time line view event size.
virtual void | DrawEvent (CDC *pDC, const CRect &rcEvents, CXTPCalendarTimeLineViewEvent *pViewEvent)
Call this function to draw the event.
virtual void | _Init ()
Call this function to do the initializations.
virtual | ~CTimeLineViewPart ()
Destroys the CTimeLineViewPart object, does the cleanup.
CXTPCalendarPaintManager ()
Default paint manager constructor.
virtual | ~CXTPCalendarPaintManager ()
Default paint manager destructor.
virtual XTPCalendarTheme | GetPaintTheme () const
This member function is used to obtain the current paint theme.
virtual void | SetPaintTheme (XTPCalendarTheme ePaintTheme)
This member function is used to set the current paint theme.
virtual COLORREF | GetEventBackColor (CXTPCalendarEvent *pEvent, COLORREF crDefault)
Call this member function to get the background color for the specified event.
virtual void | DrawLine (CDC *pDC, int xPos, int yPos, int cx, int cy)
This member function is used to draw an arbitrary line.
virtual void | DrawHorizontalLine (CDC *pDC, int xPos, int yPos, int cx)
This member function is used to draw a Horizontal line.
virtual void | DrawVerticalLine (CDC *pDC, int xPos, int yPos, int cy)
This member function is used to draw a Vertical line.
virtual int | DrawClock (CDC *pDC, COleDateTime dtClockTime, CRect rcView, COLORREF clrBackground, XTPCalendarClockAlignFlags cafAlign)
This member function is used to draw the time as a clock.
virtual int | DrawBitmap (CImageList *pImageList, CDC *pDC, CRect rcView, int iIcon, UINT uFlags=0)
This member function is used to draw a bitmap from the provided ImageList.
virtual int | DrawBitmap (UINT nIDResource, CDC *pDC, CRect rcBitmap)
This member function is used to draw the bitmap using its resource id.
virtual int | DrawIconChar (CDC *pDC, CRect rc, TCHAR ch)
This member function is used to draw the Glyph symbol using special font.
virtual const CSize | GetExpandSignSize ()
This member function is used to obtain the horizontal and vertical size of the Expand Sign bitmap.
virtual CSize | GetClockSize ()
This member function is used to obtain the horizontal and vertical size of the Clock.
virtual void | SetControl (CXTPCalendarControl *pControl)
This member function is used to set the CXTPCalendarControl object for the CXTPCalendarPaintManager.
virtual void | DrawShadow (CDC *pDC, const CRect &rcRect)
Call this member function to draw the shadow regions around the rectangle.
virtual int | DrawIcons (CDC *pDC, CXTPCalendarViewEvent *pViewEvent)
Call this member function to draw icons corresponding to the event state.
virtual void | DrawHeader (CDC *pDC, CRect &rcHeader, BOOL bIsSelected, BOOL bIsCurrent)
This member function is used to draw the Header.
virtual void | DrawBusyStatus (CDC *pDC, CRect &rcRect, int eBusyStatus)
This member function is used to fill the area using the corresponding busy color or pattern.
virtual void | DrawBusyStatus (CDC *pDC, CRgn &rgnBusy, int eBusyStatus)
This member function is used to fill the area using the corresponding busy color or pattern.
void | EnableTheme (BOOL bEnableTheme)
This member function is used to enable a new theme.
BOOL | IsThemeEnabled ()
This member function is used to obtain the status of the theme.
XTPCurrentSystemTheme GetCurrentSystemTheme ()
Call this member function to determine the current Windows XP theme that is in use.
void | SetBusyStatusBrush (int nBusyStatus, CBrush *pBrush, BOOL bAutodeleteBrush)
Call this member function to set custom brush to draw event busy status.
CBrush * | GetBusyStatusBrush (int nBusyStatus)
Call this member function to get a brush to draw event busy status.
DWORD | GetAskItemTextFlags () const
This member function returns a set of flags which define calendar items to send an XTP_NC_CALENDAR_GETITEMTEXT notification.
void | SetAskItemTextFlags (DWORD dwFlags)
This member function is used to set flags which define calendar items to send an XTP_NC_CALENDAR_GETITEMTEXT notification.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPCalendarPaintManager
DayViewTimeScaleHeaderPart CXTPCalendarViewPartFontValue | m_fntTimeText
Time text font.
int | m_nHourWidth
Width of hour part of the text in pixels.
int | m_nMinWidth
Width of minutes (am/pm) part of the text in pixels.
BOOL | m_bShowMinutes
Show minutes in TS when '60 Minutes' is selected.
XTPCalendarViewPart CXTPPaintManagerColor | m_clrBackgroundSlave
Background secondary color.
CXTPPaintManagerColor | m_clrShadow
Cell background color.
CXTPPaintManagerColor | m_clrHour
Cell border color.
XTPCalendarViewPart CXTPPaintManagerColor | m_clrBackground2
Second background color which is used to fill days background.
XTPCalendarViewPart COLORREF | m_clrTextHighLightColor
Text color for the selected event.
COLORREF | m_clrMultiDayEventFrameColor
Multi-day event frame color.
COLORREF | m_clrClassicUnderline
Underline color for today day.
CXTPPaintManagerColorGradient | m_grclrClassicSelDay
Gradient color for today day.
COLORREF | m_clrTextNormalColor
Text color for the day header and some other elements.
COLORREF | m_clrHeaderBottomLine
Text color for the day header bottom line.
XTPCalendarTimeLineViewPart CXTPPaintManagerColor | m_clrEventBar
Event bar color.
CXTPPaintManagerColor m_clrEventBarLine
Event bar line color.
CXTPPaintManagerColor | m_clrEventBorderLine
Event border line color.
CXTPPaintManagerColor | m_clrTimeScaleBackground
Time scale background color.
CXTPPaintManagerColor | m_clrTimeScaleHightlite
Time scale highlight color.
CXTPPaintManagerColor m_clrTimeScaleText
The time scale text color.
CXTPPaintManagerColor | m_clrSelectedBackground
The selected background color.
CXTPPaintManagerColor m_clrSelectedText
The selected text color.
CXTPPaintManagerColor | m_clrBackground
The background color.
CXTPPaintManagerColor | m_clrText
The text color.
CXTPPaintManagerColor | m_clrWeekendBackground
Time scale weekend background color.
CXTPPaintManagerColor m_clrButtonFace
Stores standard Button Face color.
CXTPPaintManagerColor | m_clrButtonFaceText
Stores standard color to display text.
CXTPPaintManagerColor m_clrWindow
Stores standard windows color.
CXTPPaintManagerColor m_clrWindowText
Stores standard color to display window text.
CXTPPaintManagerColor m_clr3DShadow
Stores standard color to display shadow items.
CXTPPaintManagerColor | m_clrHighlight
Stores standard color to display highlighted items.
CXTPPaintManagerColor | m_clrBorders [4]
Stores border line color, left = 0, top = 1, right = 2, bottom = 3.
CXTPPaintManagerColorGradient | m_grclrToday
Gradient color of today's header.
CUIntArray | m_arStartCol
hold start column in each virtual page
CUIntArray | m_arStartRow
hold start row in each virtual page

int | m_PrintPageWidth
Print page width.
- Protected Types inherited from CXTPCalendarPaintManager
enum | XTPEnumExpandSigns { idxExpandSignUp = 0 , idxExpandSignDown = 1 }
Enumerates types of expand signs drawn on a day view. More...
enum XTPEnumEventGlyphs {
idxMeeting = 0 , idxPrivate = 1 , idxRecurrenceException = 2 , idxRecurrenceOccurrence = 3 ,
idxReminder = 4
}
Enumerates types of event glyphs. More...
- Protected Member Functions inherited from CXTPCalendarOffice2013Theme
- Protected Member Functions inherited from CXTPCalendarPaintManager
CXTPCalendarViewPart * | AddViewPart (CXTPCalendarViewPart *pPart)
Call this member function to add the specified ViewPart object to the parts list.
CXTPCalendarViewPartBrushValue * | _GetAtGrow_BusyStatusBrushValue (int eBusyStatus, BOOL bGrow)
Returns drawing brush value for a specific busy status.
virtual void | InitBusyStatusDefaultColors ()
Set default colors/patterns to fill Busy Status area.
- Protected Attributes inherited from CXTPCalendarOffice2013Theme
- Protected Attributes inherited from CXTPCalendarPaintManager
CList< CXTPCalendarViewPart *, CXTPCalendarViewPart * > | m_lstViewParts
Collection to store ViewParts objects.
CXTPImageManager * | m_pExpandSigns
Stores standard Expand Signs icons.
CXTPImageManager * m_pGlyphs
Stores standard glyphs for displaying events.
CFont * | m_pGlyphsFont
Stores standard glyphs font for displaying events.
CBitmap | m_bmpElsewherePattern
Stores standard bitmap pattern to draw Elsewhere event busy status.
CXTPBrush | m_xtpBrushElsewhere
Stores standard brush to draw Elsewhere event busy status.
CBitmap | m_bmpTentativePattern
Stores standard bitmap pattern to draw Tentative event busy status.
CXTPBrush | m_xtpBrushTentative
Stores standard brush to draw Tentative event busy status.
CXTPCalendarTypedPtrAutoDeleteArray< CPtrArray, CXTPCalendarViewPartBrushValue * > | m_arBusyStatusBrushes
Stores customizable brush values to draw Event Busy Status in the Day View.
CSize | m_szClockRect
Stores dimensions for a rectangle used to display the time as a clock glyph.
CXTPCalendarControl * | m_pControl
Stores a pointer to a CXTPCalendarControl object.
BOOL | m_bEnableTheme
True to enable Luna theme.
COLORREF | m_clrUnderLineHdr
Color of header's underline.
XTPCurrentSystemTheme | m_CurrSystemTheme
Current theme flag.
XTPCalendarTheme | m_nPaintTheme
Store the Paint Theme;.
DWORD | m_dwAskItemTextFlags
Store flag set to send XTP_NC_CALENDAR_GETITEMTEXT notification.

Detailed Description

CXTPCalendarVisualStudio2019Theme is a CXTPCalendarOffice2013Theme derived class that represents the Visual Studio 2019 calendar theme.

Constructor & Destructor Documentation

◆ CXTPCalendarVisualStudio2019Theme()

CXTPCalendarVisualStudio2019Theme ( )

Default paint manager constructor.

Handles initial initialization.

See also
RefreshMetrics()

◆ ~CXTPCalendarVisualStudio2019Theme()

virtual ~CXTPCalendarVisualStudio2019Theme ( )
virtual

Default paint manager destructor.

Handles member items deallocation.

The documentation for this class was generated from the following file:
  • XTPCalendarVisualStudio2019Theme.h


Toolkit Pro: CXTPCalendarVisualStudio2022Theme Class Reference

Public Member Functions | List of all members
CXTPCalendarVisualStudio2022Theme Class Reference

CXTPCalendarVisualStudio2022Theme is a CXTPCalendarOffice2013Theme derived class that represents the Visual Studio 2022 calendar theme. More...

Inheritance diagram for CXTPCalendarVisualStudio2022Theme:
[legend]

Public Member Functions

CXTPCalendarVisualStudio2022Theme ()
Default paint manager constructor.
virtual | ~CXTPCalendarVisualStudio2022Theme ()
Default paint manager destructor.
- Public Member Functions inherited from CXTPCalendarOffice2013Theme
CXTPCalendarOffice2013Theme ()
Default paint manager constructor.
virtual | ~CXTPCalendarOffice2013Theme ()
Default paint manager destructor.
virtual void | RefreshMetrics ()
This member function is used to initialize all drawing defaults.
virtual void | DrawHeader (CDC *pDC, CRect &rcHeader, BOOL bIsSelected, BOOL bIsCurrent, const CXTPPaintManagerColorGradient &grclr, COLORREF clrUnderLineHdr)
This member function is used to draw the Header.
virtual void | UpdateEventLabelsDefaultColors ()
This member function is called to update event label default colors.
virtual void | UpdateEventCategoriesDefaultColors ()
This member function is called to update event category default colors.
virtual void | UpdateGlyphs ()
Initializes Calendar images.
virtual COLORREF | GetEventBackColor (CXTPCalendarEvent *pEvent)
Call this member function to get the background color for the specified event.
virtual COLORREF | GetEventEdgeColor (CXTPCalendarEvent *pEvent)
Call this member function to get the edge color for the specified event.
- Public Member Functions inherited from CXTPCalendarOffice2000Theme
CXTPCalendarOffice2000Theme ()
Default paint manager constructor.
virtual | ~CXTPCalendarOffice2000Theme ()
Default paint manager destructor.
- Public Member Functions inherited from CXTPCalendarPaintManager
BEGIN_VIEW_PART (ControlPart, XTPCalendarViewPart) virtual void RefreshMetrics()
Paint manager's ControlPart is used as parent for the other parts of the control.
END_VIEW_PART (ControlPart) BEGIN_VIEW_PART(DayViewTimeScaleHeaderPart
This paint manager part is used to draw the time scale header, 'Now' line, and the expand signs for the Day View.
virtual void | OnDraw (CDC *pDC, CXTPCalendarDayView *pView, CRect rc, CString strText)
This member function is used to draw the time scale header.
virtual void | DrawNowLine (CDC *pDC, CXTPCalendarDayView *pView, CRect rc, int y, BOOL bDrawBk=FALSE)
This member function is used to draw the 'Now' line.
virtual void | DrawNowLine (CDC *pDC, CXTPCalendarDayView *pView, CXTPCalendarDayViewTimeScale *pScale, CRect rc, int y, BOOL bDrawBk=FALSE)
This member function is used to draw the 'Now' line.
virtual void | DrawExpandSigns (CDC *pDC, CXTPCalendarDayView *pView, const CRect &rcTSHours)
This member function is used to draw expand signs.
END_VIEW_PART (DayViewTimeScaleHeaderPart) BEGIN_VIEW_PART(DayViewTimeScaleCellPart
This paint manager part is used to draw time scale time cells for the Day View.
void | AdjustTimeFont (CDC *pDC, CRect rcCell)
This member function is used to adjust the time text font size.
void | CalcWidth (CDC *pDC, const CString &strHour, const CString &strMin, int nHourHeight, int &nWidth)
This member function is used to adjust the time text font size.
virtual void | DrawHourCell (CDC *pDC, CRect rc, CString strText, BOOL bFillBackground=TRUE, BOOL bCurrentTime=FALSE)
This member function is used to draw background of the time scale header.
virtual void | DrawBigHourCell (CDC *pDC, CRect rc, CString strHour, CString strMin, int nRowPerHour, BOOL bFillBackground=TRUE, BOOL bCurrentTime=FALSE)
This member function is used to draw the big hour cell.
END_VIEW_PART (DayViewTimeScaleCellPart) BEGIN_VIEW_PART(DayViewCellPart
This paint manager part is used as the base class for the parts which draw different kinds of no all-day-cells (work/non-work) for the Day View.
virtual void | GetParams (CXTPCalendarDayViewGroup *pViewGroup, XTP_CALENDAR_DAYVIEWCELL_PARAMS *rCellParams)
This member function is used to fill out cell parameters with default values.
virtual void | OnDraw (CDC *pDC, CXTPCalendarDayViewGroup *pViewGroup, CRect rc, const XTP_CALENDAR_DAYVIEWCELL_PARAMS &cellParams)
This member function is used to draw the day view with no all-day-cells.
END_VIEW_PART (DayViewCellPart) BEGIN_VIEW_PART(DayViewWorkCellPart
This paint manager part is used to draw a day view that contains no all day work time cells.
END_VIEW_PART (DayViewWorkCellPart) BEGIN_VIEW_PART(DayViewNonworkCellPart
This paint manager part is used to draw "no all day non-work" time cells for the Day View.
END_VIEW_PART (DayViewNonworkCellPart) BEGIN_VIEW_PART(DayMonthViewHeaderPart
This paint manager part is used to draw days headers for the Day View.
END_VIEW_PART (DayMonthViewHeaderPart) BEGIN_VIEW_PART(DayViewHeaderPart
This paint manager part is used to draw days headers for the Day View.
virtual DayMonthViewHeaderPart void | OnDraw (CDC *pDC, CXTPCalendarDayViewDay *pViewDay, CRect rc, CString strText)
This member function is used to draw the day header.
END_VIEW_PART (DayViewHeaderPart) BEGIN_VIEW_PART(DayViewGroupHeaderPart
This paint manager part is used to draw Groups headers for the Day View.
virtual DayMonthViewHeaderPart void | OnDraw (CDC *pDC, CXTPCalendarDayViewGroup *pViewGroup, CRect rc, CString strText)
This member function is used to draw the day header.
END_VIEW_PART (DayViewGroupHeaderPart) BEGIN_VIEW_PART(DayViewAllDayEventsPart
This paint manager part is used to draw all day events area for the Day View.
virtual void | OnDraw (CDC *pDC, CXTPCalendarDayViewGroup *pViewGroup, CRect rc, BOOL bSelected)
This member function is used to draw the all-day events area.
END_VIEW_PART (DayViewAllDayEventsPart) BEGIN_VIEW_PART(DayViewAllDayEventScrollIconsPart
This paint manager part is used to draw all day events scroll buttons if there are too many all day events.
virtual XTPCalendarViewPart void | OnDraw (CDC *pDC, CXTPCalendarDayViewGroup *pViewGroup, BOOL bDrawUp, BOOL bDrawDown, const CRect &rcIconUp, const CRect &rcIconDown, BOOL bHighlightUp, BOOL bHighlightDown)
This member function is used to draw scroll icons in all day events area.
END_VIEW_PART (DayViewAllDayEventScrollIconsPart) BEGIN_VIEW_PART(DayViewEventPart
This paint manager part is used to draw events for the Day View.
virtual void | OnDraw (CDC *pDC, CXTPCalendarDayViewEvent *pViewEvent)
This member function is used to draw an event.
END_VIEW_PART (DayViewEventPart) BEGIN_VIEW_PART(MonthViewGridPart
This paint manager part is used to draw days grid and to fill days cells background for the Month View.
virtual void | OnDrawGrid (CDC *pDC, CXTPCalendarMonthView *pMonthView)
This member function is used to draw the days grid and to fill the days cells background.
END_VIEW_PART (MonthViewGridPart) BEGIN_VIEW_PART(MonthViewHeaderPart
This paint manager part is used to draw week days headers for the Month View.
virtual DayMonthViewHeaderPart void | OnDraw (CDC *pDC, CXTPCalendarMonthView *pMonthView, CRect rc, int nCollIndex, CString strText)
This member function is used to draw the week day header.
END_VIEW_PART (MonthViewHeaderPart) BEGIN_VIEW_PART(MonthViewEventPart
This paint manager part is used to draw events and day dates for the Month View.
virtual void | OnDrawEvent (CDC *pDC, CXTPCalendarMonthViewEvent *pViewEvent)
This member function is used to draw an event.
virtual void | OnDrawDayDate (CDC *pDC, CRect rc, BOOL bToday, BOOL bSelected, BOOL bFirstMonthDay, CString strText)
This member function is used to draw the week day header.
END_VIEW_PART (MonthViewEventPart) BEGIN_VIEW_PART(WeekViewPart
This paint manager part is used to draw week days grid and headers for the Week View.
virtual void | OnDraw (CDC *pDC, CXTPCalendarWeekView *pWeekView)
This member function is used to draw an event.
virtual void | DrawDayHeader (CDC *pDC, CRect rcDay, int nHeaderHeight, CString strHeader, BOOL bIsCurrent=FALSE, BOOL bIsSelected=FALSE)
This member function is used to draw the day header.
END_VIEW_PART (WeekViewPart) BEGIN_VIEW_PART(WeekViewEventPart
This paint manager part is used to draw events for the Week View.
virtual void | OnDraw (CDC *pDC, CXTPCalendarWeekViewEvent *pWeekViewEvent)
This member function is used to draw the specified event.
virtual void | DrawBorder (CDC *pDC, CRect rcView, CXTPCalendarWeekViewEvent *pWeekViewEvent)
This member functions is used to draw the event border.
virtual int | DrawTimes (CDC *pDC, CXTPCalendarWeekViewEvent *pWeekViewEvent)
This member function is used to draw the event's times texts or icons.
virtual void | DrawSubj (CDC *pDC, CXTPCalendarWeekViewEvent *pWeekViewEvent)
This member function is used to draw the event subject.
END_VIEW_PART (WeekViewEventPart) BEGIN_VIEW_PART(TimeLineViewTimeScalePart_Day
This paint manager part is used to draw time scale for the Time Line view.
virtual void | DrawGroup (CDC *pDC, const CRect &rcRect, CXTPCalendarTimeLineViewGroup *pGroup)
Call this function to draw the time line view group.
virtual CSize | CalcEventSize (CDC *c, CXTPCalendarTimeLineViewEvent *pViewEvent)
Call this function to calculate the time line view event size.
virtual void | DrawEvent (CDC *pDC, const CRect &rcEvents, CXTPCalendarTimeLineViewEvent *pViewEvent)
Call this function to draw the event.
virtual void | _Init ()
Call this function to do the initializations.
virtual | ~CTimeLineViewPart ()
Destroys the CTimeLineViewPart object, does the cleanup.
CXTPCalendarPaintManager ()
Default paint manager constructor.
virtual | ~CXTPCalendarPaintManager ()
Default paint manager destructor.
virtual XTPCalendarTheme | GetPaintTheme () const
This member function is used to obtain the current paint theme.
virtual void | SetPaintTheme (XTPCalendarTheme ePaintTheme)
This member function is used to set the current paint theme.
virtual COLORREF | GetEventBackColor (CXTPCalendarEvent *pEvent, COLORREF crDefault)
Call this member function to get the background color for the specified event.
virtual void | DrawLine (CDC *pDC, int xPos, int yPos, int cx, int cy)
This member function is used to draw an arbitrary line.
virtual void | DrawHorizontalLine (CDC *pDC, int xPos, int yPos, int cx)
This member function is used to draw a Horizontal line.
virtual void | DrawVerticalLine (CDC *pDC, int xPos, int yPos, int cy)
This member function is used to draw a Vertical line.
virtual int | DrawClock (CDC *pDC, COleDateTime dtClockTime, CRect rcView, COLORREF clrBackground, XTPCalendarClockAlignFlags cafAlign)
This member function is used to draw the time as a clock.
virtual int | DrawBitmap (CImageList *pImageList, CDC *pDC, CRect rcView, int iIcon, UINT uFlags=0)
This member function is used to draw a bitmap from the provided ImageList.
virtual int | DrawBitmap (UINT nIDResource, CDC *pDC, CRect rcBitmap)
This member function is used to draw the bitmap using its resource id.
virtual int | DrawIconChar (CDC *pDC, CRect rc, TCHAR ch)
This member function is used to draw the Glyph symbol using special font.
virtual const CSize | GetExpandSignSize ()
This member function is used to obtain the horizontal and vertical size of the Expand Sign bitmap.
virtual CSize | GetClockSize ()
This member function is used to obtain the horizontal and vertical size of the Clock.
virtual void | SetControl (CXTPCalendarControl *pControl)
This member function is used to set the CXTPCalendarControl object for the CXTPCalendarPaintManager.
virtual void | DrawShadow (CDC *pDC, const CRect &rcRect)
Call this member function to draw the shadow regions around the rectangle.
virtual int | DrawIcons (CDC *pDC, CXTPCalendarViewEvent *pViewEvent)
Call this member function to draw icons corresponding to the event state.
virtual void | DrawHeader (CDC *pDC, CRect &rcHeader, BOOL bIsSelected, BOOL bIsCurrent)
This member function is used to draw the Header.
virtual void | DrawBusyStatus (CDC *pDC, CRect &rcRect, int eBusyStatus)
This member function is used to fill the area using the corresponding busy color or pattern.
virtual void | DrawBusyStatus (CDC *pDC, CRgn &rgnBusy, int eBusyStatus)
This member function is used to fill the area using the corresponding busy color or pattern.
void | EnableTheme (BOOL bEnableTheme)
This member function is used to enable a new theme.
BOOL | IsThemeEnabled ()
This member function is used to obtain the status of the theme.
XTPCurrentSystemTheme GetCurrentSystemTheme ()
Call this member function to determine the current Windows XP theme that is in use.
void | SetBusyStatusBrush (int nBusyStatus, CBrush *pBrush, BOOL bAutodeleteBrush)
Call this member function to set custom brush to draw event busy status.
CBrush * | GetBusyStatusBrush (int nBusyStatus)
Call this member function to get a brush to draw event busy status.
DWORD | GetAskItemTextFlags () const
This member function returns a set of flags which define calendar items to send an XTP_NC_CALENDAR_GETITEMTEXT notification.
void | SetAskItemTextFlags (DWORD dwFlags)
This member function is used to set flags which define calendar items to send an XTP_NC_CALENDAR_GETITEMTEXT notification.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPCalendarPaintManager
DayViewTimeScaleHeaderPart CXTPCalendarViewPartFontValue | m_fntTimeText
Time text font.
int | m_nHourWidth
Width of hour part of the text in pixels.
int | m_nMinWidth
Width of minutes (am/pm) part of the text in pixels.
BOOL | m_bShowMinutes
Show minutes in TS when '60 Minutes' is selected.
XTPCalendarViewPart CXTPPaintManagerColor | m_clrBackgroundSlave
Background secondary color.
CXTPPaintManagerColor | m_clrShadow
Cell background color.
CXTPPaintManagerColor | m_clrHour
Cell border color.
XTPCalendarViewPart CXTPPaintManagerColor | m_clrBackground2
Second background color which is used to fill days background.
XTPCalendarViewPart COLORREF | m_clrTextHighLightColor
Text color for the selected event.
COLORREF | m_clrMultiDayEventFrameColor
Multi-day event frame color.
COLORREF | m_clrClassicUnderline
Underline color for today day.
CXTPPaintManagerColorGradient | m_grclrClassicSelDay
Gradient color for today day.
COLORREF | m_clrTextNormalColor
Text color for the day header and some other elements.
COLORREF | m_clrHeaderBottomLine
Text color for the day header bottom line.
XTPCalendarTimeLineViewPart CXTPPaintManagerColor | m_clrEventBar
Event bar color.
CXTPPaintManagerColor m_clrEventBarLine
Event bar line color.
CXTPPaintManagerColor | m_clrEventBorderLine
Event border line color.
CXTPPaintManagerColor | m_clrTimeScaleBackground
Time scale background color.
CXTPPaintManagerColor | m_clrTimeScaleHightlite
Time scale highlight color.
CXTPPaintManagerColor m_clrTimeScaleText
The time scale text color.
CXTPPaintManagerColor | m_clrSelectedBackground
The selected background color.
CXTPPaintManagerColor m_clrSelectedText
The selected text color.
CXTPPaintManagerColor | m_clrBackground
The background color.
CXTPPaintManagerColor | m_clrText
The text color.
CXTPPaintManagerColor | m_clrWeekendBackground
Time scale weekend background color.
CXTPPaintManagerColor m_clrButtonFace
Stores standard Button Face color.
CXTPPaintManagerColor | m_clrButtonFaceText
Stores standard color to display text.
CXTPPaintManagerColor m_clrWindow
Stores standard windows color.
CXTPPaintManagerColor m_clrWindowText
Stores standard color to display window text.
CXTPPaintManagerColor m_clr3DShadow
Stores standard color to display shadow items.
CXTPPaintManagerColor | m_clrHighlight
Stores standard color to display highlighted items.
CXTPPaintManagerColor | m_clrBorders [4]
Stores border line color, left = 0, top = 1, right = 2, bottom = 3.
CXTPPaintManagerColorGradient | m_grclrToday
Gradient color of today's header.
CUIntArray | m_arStartCol
hold start column in each virtual page
CUIntArray | m_arStartRow
hold start row in each virtual page

int | m_PrintPageWidth
Print page width.
- Protected Types inherited from CXTPCalendarPaintManager
enum | XTPEnumExpandSigns { idxExpandSignUp = 0 , idxExpandSignDown = 1 }
Enumerates types of expand signs drawn on a day view. More...
enum XTPEnumEventGlyphs {
idxMeeting = 0 , idxPrivate = 1 , idxRecurrenceException = 2 , idxRecurrenceOccurrence = 3 ,
idxReminder = 4
}
Enumerates types of event glyphs. More...
- Protected Member Functions inherited from CXTPCalendarOffice2013Theme
- Protected Member Functions inherited from CXTPCalendarPaintManager
CXTPCalendarViewPart * | AddViewPart (CXTPCalendarViewPart *pPart)
Call this member function to add the specified ViewPart object to the parts list.
CXTPCalendarViewPartBrushValue * | _GetAtGrow_BusyStatusBrushValue (int eBusyStatus, BOOL bGrow)
Returns drawing brush value for a specific busy status.
virtual void | InitBusyStatusDefaultColors ()
Set default colors/patterns to fill Busy Status area.
- Protected Attributes inherited from CXTPCalendarOffice2013Theme
- Protected Attributes inherited from CXTPCalendarPaintManager
CList< CXTPCalendarViewPart *, CXTPCalendarViewPart * > | m_lstViewParts
Collection to store ViewParts objects.
CXTPImageManager * | m_pExpandSigns
Stores standard Expand Signs icons.
CXTPImageManager * m_pGlyphs
Stores standard glyphs for displaying events.
CFont * | m_pGlyphsFont
Stores standard glyphs font for displaying events.
CBitmap | m_bmpElsewherePattern
Stores standard bitmap pattern to draw Elsewhere event busy status.
CXTPBrush | m_xtpBrushElsewhere
Stores standard brush to draw Elsewhere event busy status.
CBitmap | m_bmpTentativePattern
Stores standard bitmap pattern to draw Tentative event busy status.
CXTPBrush | m_xtpBrushTentative
Stores standard brush to draw Tentative event busy status.
CXTPCalendarTypedPtrAutoDeleteArray< CPtrArray, CXTPCalendarViewPartBrushValue * > | m_arBusyStatusBrushes
Stores customizable brush values to draw Event Busy Status in the Day View.
CSize | m_szClockRect
Stores dimensions for a rectangle used to display the time as a clock glyph.
CXTPCalendarControl * | m_pControl
Stores a pointer to a CXTPCalendarControl object.
BOOL | m_bEnableTheme
True to enable Luna theme.
COLORREF | m_clrUnderLineHdr
Color of header's underline.
XTPCurrentSystemTheme | m_CurrSystemTheme
Current theme flag.
XTPCalendarTheme | m_nPaintTheme
Store the Paint Theme;.
DWORD | m_dwAskItemTextFlags
Store flag set to send XTP_NC_CALENDAR_GETITEMTEXT notification.

Detailed Description

CXTPCalendarVisualStudio2022Theme is a CXTPCalendarOffice2013Theme derived class that represents the Visual Studio 2022 calendar theme.

Constructor & Destructor Documentation

◆ CXTPCalendarVisualStudio2022Theme()

CXTPCalendarVisualStudio2022Theme ( )

Default paint manager constructor.

Handles initial initialization.

See also
RefreshMetrics()

◆ ~CXTPCalendarVisualStudio2022Theme()

virtual ~CXTPCalendarVisualStudio2022Theme ( )
virtual

Default paint manager destructor.

Handles member items deallocation.

The documentation for this class was generated from the following file:
  • XTPCalendarVisualStudio2022Theme.h


Toolkit Pro: CXTPCalendarWeekView Class Reference

Public Types | Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPCalendarWeekView Class Reference

This class implements a specific view portion of the Calendar control - called Week view. More...

Inheritance diagram for CXTPCalendarWeekView:
[legend]

Public Types

typedef CXTPCalendarViewT< CXTPCalendarWeekViewDay > TBase
Base class type definition.

Public Member Functions

CXTPCalendarWeekView (CXTPCalendarControl *pCalendarControl)
Default object constructor.
virtual | ~CXTPCalendarWeekView ()
Default class destructor.
virtual void | Populate ()
This member function is used to populate the view with data for all items contained in the view.
virtual void | ShowDay (const COleDateTime &date, BOOL bSelect=TRUE)
This member function is used to show the specified day in the calendar view.
virtual void | AdjustLayout (CDC *pDC, const CRect &rcView, BOOL bCallPostAdjustLayout=TRUE)
This member function is used to adjust the view's layout depending on the window's client size and also calls AdjustLayout() for all sub-items.
virtual void | AdjustLayout2 (CDC *pDC, const CRect &rcView, BOOL bCallPostAdjustLayout=TRUE)
This member function is used to adjust the view's layout depending on the window's client size and also calls AdjustLayout() for all sub-items.
virtual BOOL | GetScrollBarInfoV (SCROLLINFO *pSI) const
This member function is used to retrieve information about a scroll bar state.
virtual void | ScrollV (int nPos, int nPos_raw)
This member function is used to scroll the contents of a view.
virtual void | Draw (CDC *pDC)
This member function is used to draw the view contents using the specified device context.
virtual void | Draw2 (CDC *pDC)
This member function is used to draw the view contents using the specified device context.
virtual void | OnKeyDown (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process keyboard on-key-down events.
virtual COleDateTime | GetViewDayDate (int nIndex) const
Call this member function to obtain the date of a day view by the day's index.
int | GetDayHeaderHeight () const
This member function is used to obtain the header height of a day.
void | SetBeginDate (COleDateTime dtNewBeginDate)
This member function is used to set the date of a week's Monday.
COleDateTime | GetBeginDate () const
This member function is used to obtain the date of the current week's Monday.
int | GetDayWidth () const
This member function is used to obtain the width of a weeks day rectangle.
int | GetDayHeight () const
This member function is used to obtain the height of a weeks day rectangle.
- Public Member Functions inherited from CXTPCalendarViewT< CXTPCalendarWeekViewDay >
CXTPCalendarViewT (CXTPCalendarControl *pCalendarControl, XTPCalendarViewType nViewType)
Default object constructor.
virtual | ~CXTPCalendarViewT ()
Default class destructor.
virtual XTPCalendarViewType | GetViewType () const
Call this member function to obtain the view type flag.
virtual CXTPCalendarWeekViewDay * | GetViewDay (int nIndex) const
Call this member function to obtain a _TViewDay object corresponding with the day's index.
- Public Member Functions inherited from CXTPCalendarView
UINT | GetDiscreteSelectionCount () const
This member function is used to get the number of selected events.
COleDateTime | GetDiscreteSelectionValue (UINT id) const
This member function gets a selected event by using its event ordinal number.
BOOL | AddToDiscreteSelection (UINT id)
This member function adds an event to the selection by using its event ordinal number.
BOOL | IsInDiscreteSelection (UINT id) const
This member function checks if an event is in the selection.
void | ClearDiscreteSelection ()
This member function is used to Clear Discrete Selection.
CXTPCalendarView (CXTPCalendarControl *pCalendarControl)
Default object constructor.
virtual | ~CXTPCalendarView ()
Default class destructor.
virtual void | RedrawControl ()
This member function is used to perform the redrawing of the control's layout.
virtual void | ScrollH (int nPos, int nPos_raw)
Scroll horizontally.
virtual void | OnScrollEnd (int nBar)
This member function is used to force scroll to the end of the scroll range.
virtual BOOL | GetScrollBarInfoH (SCROLLINFO *pSI, int *pnScrollStep=NULL) const
This member function is used to retrieve the information about a scroll bar state.
virtual void | OnDraw (CDC *pDC)
This member function performs all of the drawing logic of the calendar view.
virtual BOOL | OnLButtonDown (UINT nFlags, CPoint point)
This member function is used to process left mouse button events.
virtual BOOL | OnLButtonUp (UINT nFlags, CPoint point)
This member function is used to process left mouse button events.
virtual void | OnMouseMove (UINT nFlags, CPoint point)
This member function is used to process mouse movement events.
virtual BOOL | OnLButtonDblClk (UINT nFlags, CPoint point)
This member function is used to process mouse double-click events.
virtual void | OnChar (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process keyboard events.
virtual BOOL | OnSysKeyDown (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process system keyboard events.
CRect | GetViewRect () const
Call this member function to obtain the view's bounding rectangle.
virtual int | GetChildHandlersCount () const
This member function is used to obtain the number of CXTPCalendarWMHandler elements in the descendant handlers collection.
virtual CXTPCalendarWMHandler * | GetChildHandlerAt (int nIndex) const
Call this method to get a handler object at the specified numeric index.
virtual int | GetViewDayCount () const
Call this member function to obtain the number of "day views" in the view collection.
virtual CXTPCalendarViewDay * | GetViewDay_ (int nIndex) const
Call this member function to obtain the CXTPCalendarViewDay object by the day's index.
virtual CXTPCalendarViewDay * | _GetViewDay (const COleDateTime &dtDay) const
Call this member function to obtain the CXTPCalendarViewDay object by the day's index.
virtual BOOL | HitTest (CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const
This member function is used to determines which view item, if any, is at a specified position index, and returns additional information in the XTP_CALENDAR_HITTESTINFO argument.
virtual BOOL | HitTestEx (CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const
This member function is used to determine which view item, if any, is at a specified position index, and returns additional info in an XTP_CALENDAR_HITTESTINFO object.
virtual XTPCalendarDraggingMode | GetDraggingMode () const
Call this member function to determine the current dragging mode.
virtual CXTPCalendarPaintManager * | GetPaintManager () const
Call this member function to obtain the PaintManager object.
virtual CXTPCalendarTheme * | GetTheme () const
This member function obtains a pointer to the associated theme object.
CXTPCalendarControl * | GetCalendarControl () const
Call this member function to obtain a pointer to the Calendar Control object.
CXTPCalendarOptions * | GetCalendarOptions () const
Call this member function to get direct access to calendar options data.
virtual CXTPCalendarResources * | GetResources () const
Call this member function to obtain a pointer to the associated Calendar Resources collection object.
virtual void | SetResources (CXTPCalendarResources *pResources)
This member function sets the new Resources collection for the view.
virtual void | UnselectAllEvents ()
Call this member function to un-select all of the events of the current view.
virtual void | SelectEvent (CXTPCalendarEvent *pEvent, BOOL bSelect=TRUE)
This member function is used to select or un-select the provided event.
void | SelectViewEvent (CXTPCalendarViewEvent *pViewEvent, BOOL bSelect=TRUE)
This member function is used to select or un-select the provided event.
virtual void | SelectDay (CXTPCalendarViewDay *pDay, int nGroupIndex=0)
This member function is used to select or un-select the provided day, including all of the day's events.
virtual CXTPCalendarViewEvents * | GetSelectedViewEvents () const
Call this member function to obtain a pointer to a selected event's views.
virtual CXTPCalendarViewEventsPtr | GetSelectedEvents () const
Call this member function to obtain a pointer to a selected event's views collection.
CXTPCalendarViewEvent * | GetLastSelectedViewEvent () const
This member function is used to obtain the last selected event view.
virtual BOOL | HasSelectedViewEvent () const
Call this member function to determine if any view event is selected.
BOOL | IsSingleEventSelected () const
This member function is used to determine if just one event is selected.
int | FindLastSelectedDay () const
This member function is used to obtain the last selected day index.
COleDateTime | GetLastSelectedDate () const
This member function is used to obtain the last selected day date.
virtual BOOL | GetSelection (COleDateTime *pBegin=NULL, COleDateTime *pEnd=NULL, BOOL *pbAllDayEvent=NULL, int *pnGroupIndex=NULL, COleDateTimeSpan *pspSelectionResolution=NULL) const
This member function is used to obtain the view's selection.
void | SetSelection (const COleDateTime &dtBegin, const COleDateTime &dtEnd, BOOL bAllDayEvent=FALSE, int nGroupIndex=0)
This member function sets the new selection for the view.
void | ResetSelection ()
This member function resets the current selection - set it empty.
BOOL | SelectionContains (COleDateTime date, int nGroupIndex=-1, BOOL *pbAllDaySelection=NULL)
This member function is used to determine if a date time value is contained inside the selection.
virtual void | SelectDay (COleDateTime dtSelDay, int nGroupIndex=0)
This member function is used to select or un-select the day identified by the provided date.
virtual int | GetRowHeight () const
Call this member function to determine the row height required to display the event.
virtual CXTPCalendarEventsPtr | RetrieveDayEvents (CXTPCalendarResource *pRC, COleDateTime dtDay)
Call this member function to get the collection of the day's events.
virtual BOOL | IsEditingSubject () const
Call this member function to determine if the subject is in an editable mode.
virtual CRect | GetSubjectEditorRect () const
Call this member function to obtain the bounding rectangle of the subject editor.
virtual CRect | GetTooltipRect (const CPoint &ptHit, const XTP_CALENDAR_HITTESTINFO &hitInfo) const
Call this member function to obtain the bounding rectangle of the tooltip space (currently this is only "click to add new appointment").
virtual void | ShowToolTip (BOOL bShow=TRUE)
This member function is used to show/hide a ToolTip rectangle.
virtual UINT | GetShowToolTipTimeOut () const
This member function is used to obtain the timeout value for displaying a tooltip.
virtual void | OnUpdateEditingSubject (CString strNewSubject)
Call this member function to set the new subject text for the editing event.
virtual BOOL | CanUndo () const
Call this member function to determine if you can perform an undo operation for the subject editor.
virtual BOOL | CanRedo () const
Call this member function to determine if a redo operation is possible for the subject editor.
virtual BOOL | Undo ()
This member function is used to perform an Undo operation.
virtual BOOL | Redo ()
This member function is used to perform a Redo operation.
virtual void | EmptyUndoBuffer ()
This member function is used to erase the undo buffer.
virtual CString | FormatEventTime (COleDateTime dtTime) const
This member function is used to format the time using the provided format.
void | SetCustomTimeFormat (const CString &strFormat)
This member function is used to set custom time format for view.
void | ResetCustomTimeFormat ()
Reset custom time format to default.
virtual CString | GetDayHeaderFormat () const
Call this member function to determine the current format string.
virtual void | SetDayHeaderFormat (LPCTSTR sFmt)
Call this member function to set the day header format.
virtual BOOL | CanCut () const
Call this member function to determine if it is possible to perform a Cut operation.
virtual BOOL | CanCopy () const
Call this member function to determine if it is possible to perform a Copy operation.
virtual BOOL | CanPaste () const
Call this member function to determine if it is possible to perform a Paste operation.
virtual BOOL | Cut ()
This member function is used to perform a Cut operation.
virtual BOOL | Copy ()
This member function is used to perform a Copy operation.
virtual BOOL | Paste ()
This member function is used to perform a Paste operation.
virtual CXTPCalendarEvent * | GetDraggingEventOrig () const
This member function is used to obtain the event object before the start of the event editing (dragging).
virtual CXTPCalendarEvent * | GetDraggingEventNew () const
This member function is used to obtain the event object that is currently being edited.
virtual BOOL | SetDraggingEvent (CXTPCalendarEvent *pEventOrig)
This member function is used to prepare the event to event editing (dragging) operation.
virtual BOOL | CommitDraggingEvent ()
This member function is used to commit the event editing (dragging) operation.
virtual void | CancelDraggingEvent ()
This member function is used to cancel the event editing (dragging) operation.
virtual void | OnStartDragging (CPoint point, XTP_CALENDAR_HITTESTINFO *pHitTest)
This member function is used to start the event editing (dragging).
virtual BOOL | OnDragging (CPoint point, XTP_CALENDAR_HITTESTINFO *pHitTest)
This member function is used to perform the event editing (dragging) operation step.
virtual BOOL | OnEndDragging (CPoint point, XTP_CALENDAR_HITTESTINFO *pHitInfo)
This member function is used to finish the event editing (dragging) operation.
virtual void | StartEditSubject (CXTPCalendarViewEvent *pViewEvent)
This member function is used to start the event subject editing.
virtual void | EndEditSubject (XTPCalendarEndEditSubjectAction eAction, BOOL bUpdateControl=TRUE)
This member function is used to finish the event subject editing.
virtual UINT | GetStartEditSubjectTimeOut () const
This member function is used to obtain the time value after a mouse click event in the subject editing window.
virtual void | StartEditNewEventInplace (LPCTSTR pcszInitialSubject)
This member function is used to create a new event and start subject editing.
virtual CXTPCalendarViewEvent * | FindViewEvent (CXTPCalendarEvent *pEvent, COleDateTime dtDay) const
This member function is used to obtain the event view object for the specified event and day.
virtual CXTPCalendarViewEvent * | FindEventToEditByTAB (COleDateTime dtMinStart, BOOL bReverse, CXTPCalendarEvent *pAfterEvent=NULL)
This member function is used to obtain the next event view object used for editing events by pressing the TAB key.
virtual COleDateTime | GetNextTimeEditByTAB () const
This member function is used to obtain the next date and time to start the find event view for editing events using the TAB key.
virtual void | UpdateNextTimeEditByTAB (COleDateTime dtNext, BOOL bReverse, BOOL bReset=FALSE)
This member function is used to set the next date and time to start the find event view for editing events using the TAB key.
virtual void | ProcessDaySelection (XTP_CALENDAR_HITTESTINFO *pInfo, UINT nFlags)
This member function is used to process the days selection that are selected with the mouse.
virtual void | SelectDays (COleDateTime dtNewSel)
This member function is used to change the days selection depending on the previous state of the selection.
virtual void | ProcessEventSelection (XTP_CALENDAR_HITTESTINFO *pInfo, UINT nFlags)
This member function is used to process events that are selected with the mouse.
virtual void | EnableVScroll (BOOL bEnable=TRUE)
This member function(s) is used to disable or enable vertical or horizontal scrolling of the view (by date or time).
virtual void | EnableHScroll (BOOL bEnable=TRUE)
This member function(s) is used to disable or enable vertical or horizontal scrolling of the view (by date or time).
virtual BOOL | IsHScrollEnabled () const
This member function(s) is used to obtain the status of the vertical or horizontal scrolling features of the view (by date or time).
virtual BOOL | IsVScrollEnabled () const
This member function(s) is used to obtain the status of the vertical or horizontal scrolling features of the view (by date or time).
virtual void | SetDayHeaderFormatLong (LPCTSTR pcszCustomFormat)
This member function(s) is used to set the date format string for the day view.
virtual void | SetDayHeaderFormatMiddle (LPCTSTR pcszCustomFormat)
This member function(s) is used to set the date format string for the day view.
virtual void | SetDayHeaderFormatShort (LPCTSTR pcszCustomFormat)
This member function(s) is used to set the date format string for the day view.
virtual void | SetDayHeaderFormatShortest (LPCTSTR pcszCustomFormat)
This member function(s) is used to set the date format string for the day view.
virtual BOOL | IsTodayVisible () const
Call this member function to determine if Today is visible.
virtual CString | GetItemTextEventTimeMax () const
This member function is called by the calendar framework to retrieve an event time string of maximum length (to reserve space).
virtual void | CalculateHeaderFormat (CDC *pDC, int nWidth, CFont *pTextFont)
This member function creates the day header format string.
- Public Member Functions inherited from CXTPCalendarWMHandler
CXTPCalendarWMHandler ()
Default object constructor.
virtual void | OnKeyUp (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process key-up keyboard events.
virtual BOOL | OnWndMsg (UINT message, WPARAM wParam, LPARAM lParam, LRESULT *pResult)
This method is called by framework after default message processing.
virtual void | OnPostAdjustLayout ()
This member function is used to perform additional adjustments in some kinds of views.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

virtual void | AdjustFirstDayOfWeek ()
Call this member function to adjust the first day of the week.
- Protected Member Functions inherited from CXTPCalendarView
virtual UINT | SetTimer (UINT uTimeOut_ms)
This member function is used to create a timer event.
virtual void | KillTimer (UINT uTimerID)
This member function is used to destroy a timer event.
virtual BOOL | OnTimer (UINT_PTR uTimerID)
The framework calls this member function after each interval specified in the SetTimer member function.
virtual void | OnBeforeDestroy ()
This member function is called by the framework before destroying the view.
virtual void | OnActivateView (BOOL bActivate, CXTPCalendarView *pActivateView, CXTPCalendarView *pInactiveView)
This member function is called by the framework view when it is activated or deactivated.
virtual void | SendNotification (XTP_NOTIFY_CODE EventCode, WPARAM wParam=0, LPARAM lParam=0)
This member function is used to send a notification from the parent Calendar control.
virtual void | _CalculateEventTimeFormat ()
This member function is used to create the time format string.
virtual CString | _GetMaxWidthFormat (CDC *pDC, CString strFormat, BOOL bMonth) const
This function is used to calculate the max width of the date used in the specified format string.
virtual int | _GetMaxWidth (CDC *pDC, CString strFormat) const
This member function is used to calculate, in pixels, the max date width for the specified format string.
virtual void | _RemoveYearPart (CString &strFormat)
This member function is used to remove the year part from the specified format string.
virtual void | _ReadDefaultHeaderFormats ()
This member function is used to build day header date format default strings.
virtual CString | _GetDayHeaderFormat (int nLevel) const
This member function gets a custom or default day header date format string.
virtual BOOL | _CanSubjectEditor (UINT idEditCmd) const
This member function is used to determine if the specified editing operation command is possible for the event subject editor window.
virtual CWnd * | _GetSubjectEditorWnd () const
This member function is used to obtain a pointer to the event subject editor window.
virtual COleDataSource * | _CopySelectedEvents (DWORD dwCopyFlags=0)
This member function is used to copy selected events and CXTPCalendarEvent objects, to a COleDataSource object.
virtual CXTPCalendarEventsPtr | _ReadEventsFromClipboard (COleDataObject *pData, DWORD *pdwCopyFlags=NULL)
This member function is used to read events and CXTPCalendarEvent objects, from a COleDataSource object.
virtual COleDateTimeSpan | GetEventDurationMin () const
This member function is used to obtain the minimum event duration visible in the current view.
virtual BOOL | _Undo (CXTPCalendarEvent *pEvent=NULL)
This member function is used to perform an undo/redo operation for the specified event.
virtual XTPEnumCalendarUpdateResult | OnEventChanged_InDataProvider (XTP_NOTIFY_CODE nfCode, CXTPCalendarEvent *pEvent)
This member function handles the changing of an event in the associated data provider.
BOOL | _IsDragModeCopyMove (int eDragMode) const
This method is used to determine Copy or Move dragging mode.
BOOL | IsEditOperationDisabledNotify (XTPCalendarEditOperation eOperation, CXTPCalendarViewEvent *pEventView) const
This method is used to determine if specified editing operation is disabled.
BOOL | OnBeforeEditOperationNotify (XTPCalendarEditOperation eOperation, CXTPCalendarViewEvent *pEventView)
This method is used to customize or disable specified editing operation.
BOOL | OnBeforeEditOperationNotify (XTPCalendarEditOperation eOperation, CXTPCalendarViewEvents *pEventViews)
This method is used to customize or disable specified editing operation.
BOOL | OnBeforePasteNotify (CXTPCalendarEvent *pEvent, BOOL bPasteWillChangeExistingEvent)
This method is used to customize or disable paste editing operation.
BOOL | OnInPlaceCreateEvent (LPCTSTR pcszInitialSubject)
This method is used to customize or disable xtpCalendarEO_InPlaceCreateEvent editing operation.

Protected Attributes

XTP_WEEK_VIEW_LAYOUT m_LayoutX
< data members

int | m_nCurrPos
Current scrollbar position.
COleDateTime | m_dtBeginDate
First date of week (Monday's date).
int | m_nFirstDayOfWeekIndex
Index for first weekday.
- Protected Attributes inherited from CXTPCalendarView
CSelectionChanged_ContextData m_cntSelChanged
Counter on selection changes,.
int | m_eUndoMode
Undo mode, see XTPCalendarUndoMode.
BOOL | m_bResetUndoBuffer
Clean undo buffer before add next undo action.
CUndoBuffer * | m_pPrevUndoBuffer
Undo buffer data after last undo buffer clean.
CUndoBuffer * | m_pUndoBuffer
Undo buffer object.
XTP_VIEW_LAYOUT | m_Layout
Layout data.
SEventTimeFormatInfo | m_EventTimeFormat
Information used to format events times.
CString | m_strHeaderFormat
Day header active date format string.
CString | m_strDayHeaderFormatLong
Day header Long date format custom string.
CString | m_strDayHeaderFormatMiddle
Day header Middle date format custom string.
CString | m_strDayHeaderFormatShort
Day header Short date format custom string.
CString | m_strDayHeaderFormatShortest
Day header Shortest date format custom string.
CString | m_strDayHeaderFormatDefaultLong
Day header Long date format default string.
CString | m_strDayHeaderFormatDefaultMiddle
Day header Middle date format default string.
CString | m_strDayHeaderFormatDefaultShort
Day header Short date format default string.
CString | m_strDayHeaderFormatDefaultShortest
Day header Shortest date format default string.
CRect | m_rcView
Client rect.
CRect | m_rcTooltip
Last shown tooltip rect (while GetTooltipRect returns calculated currently required tooltip rect)
CXTPCalendarEventPtr | m_ptrDraggingEventOrig
Event object before start event editing.
CXTPCalendarEventPtr | m_ptrDraggingEventNew
Editing event object.
COleDateTimeSpan | m_spDraggingStartOffset
Start dragging operation offset from the beginning of the event.
CPoint | m_ptStartDragging
Request to start dragging operation from this point.
XTPCalendarDraggingMode | m_eDraggingMode
Editing event mode.
BOOL | m_bStartedClickInside
Is OnLButtonDown was inside view rect.
CXTPCalendarViewEventPtr | m_ptrEditingViewEvent
Currently editing subject event view or event view requested to edit subject by timeout.
CXTPCalendarViewEvent * | m_pLastEvent
Last selected event.
UINT | m_nTimerID_StartEditSubject
Timer ID of edit event subject request.
UINT | m_nTimerID_ShowToolTip
Timer ID of start show tooltip request.
CXTPCalendarControl * | m_pControl
Pointer to the owner control object.
CXTPCalendarViewEvents * | m_pSelectedEvents
Selected Events;.
XTP_CALENDAR_HITTESTINFO m_LastHitInfo
Last HitInfo data.
UINT | m_nKeyStateTimerID
Timer ID to check Keys state (like Control).
XTP_CALENDAR_VIEWSELECTION | m_selectedBlock
Current selection.
BOOL | m_bScrollV_Disabled
Is vertical scrolling disabled for a view.
BOOL | m_bScrollH_Disabled
Is horizontal scrolling disabled for a view.
CXTPCalendarResources * | m_pResources
Resources array.
CXTPCalendarPtrCollectionT< CXTPCalendarViewDay > | m_arDays
Stores the view day collection.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

This class implements a specific view portion of the Calendar control - called Week view.

The Week view can be shown as one week, consisting of 7 days, as a normal week contains. Weekend days of the week are drawn compressed, which means that 2 weekend days will be drawn in a rectangle of a usual day. Each day is represented by a CXTPCalendarWeekViewDay class.

See also
CXTPCalendarView
CXTPCalendarDayView
CXTPCalendarMonthView
CXTPCalendarWeekViewDay
CXTPCalendarWeekViewEvent

Constructor & Destructor Documentation

◆ CXTPCalendarWeekView()

CXTPCalendarWeekView ( CXTPCalendarControl * pCalendarControl )

Default object constructor.

Parameters
pCalendarControl Pointer to CXTPCalendarControl object.
See also
~CXTPCalendarEvent()

◆ ~CXTPCalendarWeekView()

virtual ~CXTPCalendarWeekView ( )
virtual

Default class destructor.

Handles member items deallocation.

Member Function Documentation

◆ AdjustFirstDayOfWeek()

virtual void AdjustFirstDayOfWeek ( )
protectedvirtual

Call this member function to adjust the first day of the week.

The first day of the week depends on region.

◆ AdjustLayout()

virtual void AdjustLayout | ( | CDC * | pDC,
 |  | const CRect & | rcView,
 |  | BOOL | bCallPostAdjustLayout = TRUE )
 virtual

This member function is used to adjust the view's layout depending on the window's client size and also calls AdjustLayout() for all sub-items.

Parameters
pDC | A pointer to a valid device context.
rcView | A CRect that contains the rectangle coordinates used to draw the view.
bCallPostAdjustLayout | A BOOL. Flag used to call additional adjustments.

Call Populate() prior calling adjust AdjustLayout(). AdjustLayout2 is called by calendar control instead of AdjustLayout when theme is set.

Reimplemented from CXTPCalendarView.

◆ AdjustLayout2()

virtual void AdjustLayout2 | ( | CDC * | pDC,
 |  | const CRect & | rcView,
 |  | BOOL | bCallPostAdjustLayout = TRUE )
 virtual

This member function is used to adjust the view's layout depending on the window's client size and also calls AdjustLayout() for all sub-items.

Parameters
pDC | A pointer to a valid device context.
rcView | A CRect that contains the rectangle coordinates used to draw the view.
bCallPostAdjustLayout | A BOOL. Flag used to call additional adjustments.

Call Populate() prior calling adjust AdjustLayout(). AdjustLayout2 is called by calendar control instead of AdjustLayout when theme is set.

Reimplemented from CXTPCalendarView.

◆ Draw()

virtual void Draw ( CDC * pDC )
virtual

This member function is used to draw the view contents using the specified device context.

Parameters
pDC A pointer to a valid device context.

Call AdjustLayout() before calling Draw(). Draw2 is called by calendar control instead of Draw when theme is set.

See also
AdjustLayout().

Reimplemented from CXTPCalendarView.

◆ Draw2()

virtual void Draw2 ( CDC * pDC )
virtual

This member function is used to draw the view contents using the specified device context.

Parameters
pDC A pointer to a valid device context.

Call AdjustLayout() before calling Draw(). Draw2 is called by calendar control instead of Draw when theme is set.

See also
AdjustLayout().

Reimplemented from CXTPCalendarView.

◆ GetBeginDate()

AFX_INLINE COleDateTime GetBeginDate ( ) const

This member function is used to obtain the date of the current week's Monday.

Returns
A COleDateTime object that contains the current week's Monday date.
See also
SetBeginDate()

◆ GetDayHeaderHeight()

AFX_INLINE int GetDayHeaderHeight ( ) const

This member function is used to obtain the header height of a day.

Returns
An int that contains the height of a row required to display a single event.

◆ GetDayHeight()

AFX_INLINE int GetDayHeight ( ) const

This member function is used to obtain the height of a weeks day rectangle.

Returns
An int that contains the height of a day rectangle.

◆ GetDayWidth()

AFX_INLINE int GetDayWidth ( ) const

This member function is used to obtain the width of a weeks day rectangle.

Returns
An int that contains the width of a day rectangle.

◆ GetScrollBarInfoV()

virtual BOOL GetScrollBarInfoV ( SCROLLINFO * pSI ) const
virtual

This member function is used to retrieve information about a scroll bar state.

Parameters
pSI A pointer to a scrollbar information structure.
Returns
A BOOL. This function should return TRUE to indicate success. FALSE otherwise.

Reimplemented from CXTPCalendarView.

◆ GetViewDayDate()

virtual COleDateTime GetViewDayDate ( int nIndex ) const
virtual

Call this member function to obtain the date of a day view by the day's index.

Parameters
nIndex An int that contains the day view index in the view collection.

Index number starts with 0 and cannot be negative.

Returns
A COleDateTime object that contains the day view date and time.
See also
GetViewDayCount()

Implements CXTPCalendarView.

◆ OnKeyDown()

virtual void OnKeyDown | ( | UINT | nChar,
 |  | UINT | nRepCnt,
 |  | UINT | nFlags )
 virtual

This member function is used to process keyboard on-key-down events.

Parameters
nChar | A UINT that contains the virtual key code of the given key.
nRepCnt | A UINT that contains the number of times the keystroke is repeated as a result of the user holding down the key.
nFlags | A UINT that contains the scan code, key-transition code, previous key state, and the context code.

This method is called by the CalendarControl when the user presses keys on the keyboard.

Reimplemented from CXTPCalendarView.

◆ ScrollV()

virtual void ScrollV | ( | int | nPos,
 |  | int | nPos_raw )
 virtual

This member function is used to scroll the contents of a view.

Parameters
nPos | An int that contains the position value.
nPos_raw | An int that contains the raw position value.

ScrollV internally uses Populate() to fill the new view data.

See also
Populate().

Reimplemented from CXTPCalendarView.

◆ SetBeginDate()

void SetBeginDate ( COleDateTime dtNewBeginDate )

This member function is used to set the date of a week's Monday.

Parameters
dtNewBeginDate A COleDateTime object that contains the date of Monday.

Call this member function to set the date of a week to the Monday of the current week.

See also
GetBeginDate()

◆ ShowDay()

virtual void ShowDay | ( | const COleDateTime & | date,
 |  | BOOL | bSelect = TRUE )
 virtual

This member function is used to show the specified day in the calendar view.

Parameters
date | A COleDateTime object that contains the date to show.
bSelect | TRUE to select the specified day after showing, FALSE otherwise. TRUE is the default value.

Call this member function to show only the specified day in the calendar view.

Implements CXTPCalendarView.

Member Data Documentation

◆ m_LayoutX

XTP_WEEK_VIEW_LAYOUT m_LayoutX
protected

< data members

Layout data.

◆ m_nFirstDayOfWeekIndex

int m_nFirstDayOfWeekIndex
protected

Index for first weekday.

The documentation for this class was generated from the following file:
  • XTPCalendarWeekView.h


Toolkit Pro: CXTPCalendarWeekViewDay Class Reference

Public Types | Public Member Functions | Protected Member Functions | List of all members
CXTPCalendarWeekViewDay Class Reference

This class represents a day view portion of the CalendarWeekView. More...

Inheritance diagram for CXTPCalendarWeekViewDay:
[legend]

Public Types

typedef CXTPCalendarViewDayT< CXTPCalendarWeekView, CXTPCalendarWeekViewGroup, XTP_CALENDAR_HITTESTINFO, CXTPCalendarWeekViewDay > | TBase
Base class type definition.
- Public Types inherited from CXTPCalendarViewDayT< CXTPCalendarWeekView, CXTPCalendarWeekViewGroup, XTP_CALENDAR_HITTESTINFO, CXTPCalendarWeekViewDay >
typedef CXTPCalendarWeekView | TView

Public Member Functions

CXTPCalendarWeekViewDay (CXTPCalendarWeekView *pWeekView)
Default object constructor.
virtual | ~CXTPCalendarWeekViewDay ()
Default class destructor.
virtual void | FillHitTestEx (XTP_CALENDAR_HITTESTINFO *pInfo) const
This member function is used to fill an XTP_CALENDAR_HITTESTINFO structure.
virtual BOOL | HitTestEx (CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const
This member function is used to determine which view item, if any, is at the specified position index, and returns additional info in the XTP_CALENDAR_HITTESTINFO template object.
virtual void | AdjustLayout (CDC *pDC, const CRect &rcDay)
This member function is used to adjust the view's layout depending on the provided rectangle and also calls AdjustLayout() for all sub-items.
virtual void | AdjustLayout2 (CDC *pDC, const CRect &rcDay)
This member function is used to adjust the view's layout depending on the provided rectangle and also calls AdjustLayout() for all sub-items.
virtual void | Draw (CDC *pDC)
This member function is used to draw the view content using the specified device context.
CRect | GetDayEventsRect () const
This function is used to obtain a portion of a day rectangle used to draw event views.
virtual CString | GetCaption () const
This member function is used to obtain a single day's view caption.
- Public Member Functions inherited from CXTPCalendarViewDayT< CXTPCalendarWeekView, CXTPCalendarWeekViewGroup, XTP_CALENDAR_HITTESTINFO, CXTPCalendarWeekViewDay >
CXTPCalendarViewDayT (const CXTPCalendarWeekView *pView)
Default object constructor.
virtual | ~CXTPCalendarViewDayT ()
Default class destructor.
CXTPCalendarWeekView * | GetView () const
This member function is used to obtain the owner view object.
virtual CXTPCalendarWeekViewGroup * | GetViewGroup (int nIndex) const
Call this member function to obtain a pointer to the _TViewGroup object that corresponds to the resource's index.
virtual CXTPCalendarViewGroup * | CreateGroup ()
This member function is used to create a new instance of a group.
- Public Member Functions inherited from CXTPCalendarViewDay
CXTPCalendarViewDay (const CXTPCalendarView *pView)
Default object constructor.
virtual | ~CXTPCalendarViewDay ()
Default class destructor.
virtual void | Populate (COleDateTime dtDayDate)
This member function is used to populate the view with data for all items contained in the view.
virtual int | GetChildHandlersCount () const
This member function is used to obtain the number of resource group views elements in the collection.
virtual CXTPCalendarWMHandler * | GetChildHandlerAt (int nIndex) const
Call this method to get a resource group view object at the specified numeric index.
virtual BOOL | HitTest (CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const
This member function is used to determine which view item, if any, is at the specified position index, and returns additional info in an XTP_CALENDAR_HITTESTINFO struct.
virtual CXTPCalendarView * | GetView_ () const
Call this member function to obtain a pointer to a CXTPCalendarView object.
virtual CXTPCalendarControl * | GetCalendarControl () const
Call this member function to obtain a pointer to a CXTPCalendarControl object.
virtual CXTPCalendarResources * | GetResources () const
Call this member function to obtain a pointer to the associated Calendar Resources collection object.
virtual void | SetResources (CXTPCalendarResources *pResources)
This member function sets the new Resources collection for the view day.
virtual int | GetViewEventsCount () const
Call this member function to obtain the number of event views in the day view collection.
virtual CXTPCalendarViewEvent * | GetViewEvent_ (int nIndex) const
Call this member function to obtain a pointer to a CXTPCalendarViewEvent object associated with the event's index.
int | GetViewGroupsCount () const
Call this member function to obtain the number of resource group views in the view day collection.
CXTPCalendarViewGroup * | GetViewGroup_ (int nIndex) const
Call this member function to obtain a pointer to a CXTPCalendarViewGroup object associated with the group's index.
virtual COleDateTime | GetDayDate () const
Call this member function to obtain a day date value.
virtual COleDateTime | SetDayDate (COleDateTime dtDayDate)
Call this member function to obtain the day date value.
virtual BOOL | ContainsInvisibleEvents () const
Call this member function to determine if there are any invisible event views.
virtual BOOL | ContainsInvisibleEventsUpdate ()
Call this member function to determine if there are any invisible event views and to calculate the rectangle for the ExpandSign.
virtual BOOL | IsSelected () const
Call this member function to determine if the day view is selected.
virtual void | SetSelected ()
This member function is used to set the day view as selected.
virtual CRect | GetDayRect () const
Call this member function to obtain the day view rectangle coordinates.
virtual void | SetDayRect (CRect rcDay)
This member function is used to set the day view rectangle coordinates.
virtual BOOL | IsExpanded () const
Call this member function to determine if there are invisible event views because the boundaries of the day view are hidden and if the day view should display the expand sign.
virtual CRect | GetExpandSignRect () const
Call this member function to obtain the expand sign rectangle.
virtual UINT | SetTimer (UINT uTimeOut_ms)
This member function is used to create a timer event.
virtual void | KillTimer (UINT uTimerID)
This member function is used to destroy a timer event.
virtual int | GetDayIndex () const
This member function is used to obtain the index of the "this" pointer day in the Calendar Day View.
virtual BOOL | UserAction_OnExpandDay (XTPCalendarExpandDayButton eButton)
This member function is used to process the user action xtpCalendarUserAction_OnExpandDay.
- Public Member Functions inherited from CXTPCalendarWMHandler
CXTPCalendarWMHandler ()
Default object constructor.
virtual BOOL | OnLButtonUp (UINT nFlags, CPoint point)
This member function is used to process left mouse button up events.
virtual BOOL | OnLButtonDblClk (UINT nFlags, CPoint point)
This member function is used to process left mouse button double click events.
virtual void | OnChar (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process keyboard events.
virtual void | OnKeyDown (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process key-down keyboard events.
virtual void | OnKeyUp (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process key-up keyboard events.
virtual BOOL | OnSysKeyDown (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process key-up keyboard events.
virtual BOOL | OnTimer (UINT_PTR uTimerID)
The framework calls this member function after each interval specified in the SetTimer member function.
virtual BOOL | OnWndMsg (UINT message, WPARAM wParam, LPARAM lParam, LRESULT *pResult)
This method is called by framework after default message processing.
virtual void | OnPostAdjustLayout ()
This member function is used to perform additional adjustments in some kinds of views.
virtual void | OnBeforeDestroy ()
This member function is called by the framework before destroying the view.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

virtual BOOL | OnLButtonDown (UINT nFlags, CPoint point)
This member function is used to process left mouse button events.
virtual void | OnMouseMove (UINT nFlags, CPoint point)
This member function is used to process mouse movement events.
virtual CXTPCalendarWeekViewDay * | GetPThis ()
This member function is used to obtain a pointer to itself.
- Protected Member Functions inherited from CXTPCalendarViewDayT< CXTPCalendarWeekView, CXTPCalendarWeekViewGroup, XTP_CALENDAR_HITTESTINFO, CXTPCalendarWeekViewDay >
- Protected Member Functions inherited from CXTPCalendarViewDay
virtual void | OnPrePopulateDay ()
This member function is used to allow some customization before show events.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Attributes inherited from CXTPCalendarViewDay
XTP_VIEW_DAY_LAYOUT | m_Layout
Layout data.
COleDateTime | m_dtDate
Day date.
CXTPCalendarResources * | m_pResources
Resources array.
CXTPCalendarPtrCollectionT< CXTPCalendarViewGroup > | m_arViewGroups
Storage for views of groups.
CXTPCalendarView * | m_pView
Storage for a owner view.

Detailed Description

This class represents a day view portion of the CalendarWeekView.

It represents a specific view of the CalendarView's associated events data grouped by one day and provides basic functionality on this data using user input through the keyboard and mouse.

 CXTPCalendarWeekViewDay is based on the CXTPCalendarViewDayT template
 class. CXTPCalendarWeekViewDay inherits basic behavior from the
 CXTPCalendarViewDayT class. Furthermore, class CXTPCalendarWeekViewDay
 overlaps and adds some functionality for its own behavior and look.
See also
CXTPCalendarViewDay
CXTPCalendarViewDayT

Constructor & Destructor Documentation

◆ CXTPCalendarWeekViewDay()

CXTPCalendarWeekViewDay ( CXTPCalendarWeekView * pWeekView )

Default object constructor.

Constructs a CXTPCalendarWeekViewDay object.

Parameters
pWeekView Pointer to CXTPCalendarWeekView object.
See also
~CXTPCalendarWeekViewDay()

◆ ~CXTPCalendarWeekViewDay()

virtual ~CXTPCalendarWeekViewDay ( )
virtual

Default class destructor.

Handles member items deallocation.

Member Function Documentation

◆ AdjustLayout()

virtual void AdjustLayout | ( | CDC * | pDC,
 |  | const CRect & | rcDay )
 virtual

This member function is used to adjust the view's layout depending on the provided rectangle and also calls AdjustLayout() for all sub-items.

Parameters
pDC | A pointer to a valid device context.
rcDay | A CRect object that contains the rectangle coordinates used to draw the day view.

Call Populate(COleDateTime dtDayDate) prior to calling AdjustLayout().

Reimplemented from CXTPCalendarViewDayT< CXTPCalendarWeekView, CXTPCalendarWeekViewGroup, XTP_CALENDAR_HITTESTINFO, CXTPCalendarWeekViewDay >.

◆ AdjustLayout2()

virtual void AdjustLayout2 | ( | CDC * | pDC,
 |  | const CRect & | rcDay )
 virtual

This member function is used to adjust the view's layout depending on the provided rectangle and also calls AdjustLayout() for all sub-items.

Parameters
pDC | A pointer to a valid device context.
rcDay | A CRect object that contains the rectangle coordinates used to draw the day view.

Call Populate(COleDateTime dtDayDate) prior to calling AdjustLayout().

◆ Draw()

virtual void Draw ( CDC * pDC )
virtual

This member function is used to draw the view content using the specified device context.

Parameters
pDC A pointer to a valid device context.

Call AdjustLayout() before calling Draw().

See also
AdjustLayout(CRect rcDay)

Reimplemented from CXTPCalendarViewDay.

◆ FillHitTestEx()

virtual void FillHitTestEx ( XTP_CALENDAR_HITTESTINFO * pInfo ) const
virtual

This member function is used to fill an XTP_CALENDAR_HITTESTINFO structure.

Parameters
pInfo A pointer to an XTP_CALENDAR_HITTESTINFO struct.

Call this member function to gather hit test information from the week view.

See also
XTP_CALENDAR_HITTESTINFO

Implements CXTPCalendarViewDayT< CXTPCalendarWeekView, CXTPCalendarWeekViewGroup, XTP_CALENDAR_HITTESTINFO, CXTPCalendarWeekViewDay >.

◆ GetCaption()

virtual CString GetCaption ( ) const
virtual

This member function is used to obtain a single day's view caption.

Returns
A CString object that contains the day's view caption.

◆ GetDayEventsRect()

CRect GetDayEventsRect ( ) const

This function is used to obtain a portion of a day rectangle used to draw event views.

Returns
A CRect object that contains the rectangle coordinates.

◆ GetPThis()

AFX_INLINE CXTPCalendarWeekViewDay * GetPThis ( )
protectedvirtual

This member function is used to obtain a pointer to itself.

Returns
A pointer to a CXTPCalendarWeekViewDay object.

Implements CXTPCalendarViewDayT< CXTPCalendarWeekView, CXTPCalendarWeekViewGroup, XTP_CALENDAR_HITTESTINFO, CXTPCalendarWeekViewDay >.

◆ HitTestEx()

virtual BOOL HitTestEx | ( | CPoint | pt,
 |  | XTP_CALENDAR_HITTESTINFO * | pHitTest ) const
 virtual

This member function is used to determine which view item, if any, is at the specified position index, and returns additional info in the XTP_CALENDAR_HITTESTINFO template object.

Parameters
pt | A CPoint that contains the coordinates of the point test.
pHitTest | A pointer to an XTP_CALENDAR_HITTESTINFO structure.

Implements standard functionality for the HitTestEx method.

Returns
A BOOL. TRUE if the item is found. FALSE otherwise.
See also
XTP_CALENDAR_HITTESTINFO

Reimplemented from CXTPCalendarViewDay.

◆ OnLButtonDown()

virtual BOOL OnLButtonDown | ( | UINT | nFlags,
 |  | CPoint | point )
 protectedvirtual

This member function is used to process left mouse button events.

Parameters
nFlags | A UINT that is used to indicate whether various virtual keys are down.
point | A CPoint that specifies the x- and y- coordinates of the cursor. These coordinates are always relative to the upper-left corner of the window.
Returns
TRUE if the message is handled properly, FALSE otherwise.

This method is called by the CalendarControl when the user presses the left mouse button.

Reimplemented from CXTPCalendarWMHandler.

◆ OnMouseMove()

virtual void OnMouseMove | ( | UINT | nFlags,
 |  | CPoint | point )
 protectedvirtual

This member function is used to process mouse movement events.

Parameters
nFlags | A UINT that is used to indicate whether various virtual keys are down.
point | A CPoint that specifies the x- and y- coordinates of the cursor. These coordinates are always relative to the upper-left corner of the window.

This method is called by the CalendarControl when the user moves the mouse cursor or stylus.

Reimplemented from CXTPCalendarWMHandler.

The documentation for this class was generated from the following file:
  • XTPCalendarWeekViewDay.h


Toolkit Pro: CXTPCalendarWeekViewEvent Class Reference

Public Types | Public Member Functions | Protected Member Functions | List of all members
CXTPCalendarWeekViewEvent Class Reference

This class represents an event view portion of the CalendarWeekViewDay. More...

Inheritance diagram for CXTPCalendarWeekViewEvent:
[legend]

Public Types

typedef CXTPCalendarViewEventT< CXTPCalendarWeekViewGroup > TBase
Base class type definition.

Public Member Functions

CXTPCalendarWeekViewEvent (CXTPCalendarEvent *pEvent, CXTPCalendarWeekViewGroup *pViewGroup)
Default object constructor.
virtual | ~CXTPCalendarWeekViewEvent ()
Default class destructor.
virtual BOOL | HitTestEx (CPoint point, XTP_CALENDAR_HITTESTINFO *pInfo) const
This member function is used to fill an XTP_CALENDAR_HITTESTINFO structure.
virtual int | CalcIconsRect (CRect rc)
This member function is used to adjust rectangles used to draw event view icons.
virtual void | AdjustLayout (CDC *pDC, const CRect &rcEventMax, int nEventPlaceNumber)
This member function is used to adjust the view's layout depending on the provided rectangle and also calls AdjustLayout() for all sub-items.
virtual void | AdjustLayout2 (CDC *pDC, const CRect &rcEventMax, int nEventPlaceNumber)
This member function is used to adjust the view's layout depending on the provided rectangle and also calls AdjustLayout() for all sub-items.
virtual void | Draw (CDC *pDC)
This member function is used to draw the view content using the specified device context.
virtual BOOL | IsVisible () const
Call this member function to determine if the "view visible" flag is set.
CRect | GetViewRect ()
Call this member function to get the day view rectangle coordinates.
BOOL | IsShowEndTime () const
Call this member function to determine the value of the "show end time" flag.
BOOL | IsTimeAsClock () const
Call this member function to determine the value of the "show time as clock" flag.
virtual void | OnPostAdjustLayout ()
This member function is used to perform additional adjustments.
- Public Member Functions inherited from CXTPCalendarViewEventT< CXTPCalendarWeekViewGroup >
CXTPCalendarViewEventT (CXTPCalendarEvent *pEvent, CXTPCalendarWeekViewGroup *pViewGroup)
Default object constructor.
virtual | ~CXTPCalendarViewEventT ()
Default class destructor.
virtual CXTPCalendarViewGroup * | GetViewGroup_ () const
This member function is used to obtain a base CXTPCalendarViewGroup* pointer to a corresponding DayView object.
CXTPCalendarWeekViewGroup * | GetViewGroup () const
This member function is used to obtain a pointer to a DayView object.
- Public Member Functions inherited from CXTPCalendarViewEvent
CXTPCalendarViewEvent (CXTPCalendarEvent *pEvent, CXTPCalendarViewGroup *pViewGroup)
Default object constructor.
virtual | ~CXTPCalendarViewEvent ()
Default class destructor.
virtual BOOL | HitTest (CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const
This member function is used to determine which view item, if any, is at the specified position index, and returns additional info in the XTP_CALENDAR_HITTESTINFO struct.
virtual CXTPCalendarEvent * | GetEvent () const
Call this member function to obtain the corresponding read only event object without increasing the object's reference counter.
virtual CXTPCalendarControl * | GetCalendarControl () const
Call this member function to obtain a pointer to the calendar control object.
virtual BOOL | IsSelected () const
Call this member function to determine if the given event view is selected.
virtual void | SetSelected (BOOL bSet=TRUE)
This member function is used to set the day view as select or unselected.
virtual BOOL | IsMultidayEvent () const
Call this member function to determine if the given event view is a multi-day event.
virtual CXTPCalendarViewEvent * | StartEditSubject ()
This member function is used to create and to show the subject editor.
virtual CString | GetEditingSubjectFromEditor () const
Call this member function to obtain an edited subject.
virtual CString | EndEditSubject ()
This member function is used to end the editing project, delete the subject editor, and to obtain the edited text.
virtual void | ShowToolTip ()
This member function is used to show a ToolTip rectangle.
virtual void | HideToolTip ()
This member function is used to hide the ToolTip rectangle.
virtual BOOL | IsEditingSubject () const
Call this member function to determine if the event's subject is currently being edited.
virtual CRect | GetSubjectEditorRect () const
This member function is used to obtain the subject editor rectangle coordinates.
virtual CWnd * | GetSubjectEditor () const
This member function is used to obtain the event's subject editor window.
virtual BOOL | IsShowingToolTip ()
Call this member function to determine if the event's tooltip is visible.
virtual CString | FormatEventTime (COleDateTime dtTime) const
This member function is used to format the event's time as a string with a predefined format.
virtual CRect | GetFirstClockRect () const
This member function is used to obtain the rectangle coordinates used for drawing a clock in the beginning of a multi day event.
virtual CRect | GetLastClockRect () const
This member function is used to obtain the rectangle coordinates used for drawing a clock in the end of a multi-day event.
virtual CRect | GetTextRect () const
This member function is used to obtain the rectangle coordinates used for displaying the event's subject.
virtual CRect | GetStartTimeRect () const
This member function is used to obtain the rectangle coordinates used for displaying a clock to show the start event time for single day events.
virtual CRect | GetEndTimeRect () const
This member function is used to obtain the rectangle coordinates for displaying a clock to show the end event time for single day events.
virtual CRect | GetViewEventRect () const
This member function is used to obtain the rectangle coordinates for the event's rectangle.
virtual CRect | GetViewEventRectMax () const
This member function is used to obtain the rectangle coordinates for the event's maximum rectangle dimensions.
virtual CRect | GetReminderGlyphRect () const
This member function is used to obtain the rectangle coordinates for displaying the remainder icon.
virtual CRect | GetRecurrenceGlyphRect () const
This member function is used to obtain the rectangle coordinates used for displaying the recurrence icon.
virtual CRect | GetMeetingGlyphRect () const
This member function obtains the rectangle coordinates for displaying the meeting icon.
virtual CRect | GetPrivateGlyphRect () const
This member function is used to obtain the rectangle coordinates used for displaying the private icon.
virtual BOOL | IsMultyDayTextAlign () const
This member function is used to obtain the flag to determine if multi-day text align mode is on.
virtual int | GetMultiDayEventFlags () const
This member function is used to obtain the multi-day event state flags.
virtual void | SetMultiDayEvent_MasterSlave (BOOL bMaster, CXTPCalendarViewEvent *pMasterView)
This member function is used to set the multi-day event Master/Slave state.
virtual void | AddMultiDayEvent_Slave (CXTPCalendarViewEvent *pSlaveView, int nMasterEventPlace)
This member function is used to add a Slave event view to the Master event view.
virtual void | SetTextOutOfBorders (BOOL bOutOfBorders)
This member function is used to set a flag to determine if the text size exceeds the event view bounds.
virtual BOOL | IsTextOutOfBorders () const
This member function is used to determine if the text size exceeds the event view bounds.
virtual int | GetEventPlaceNumber () const
This member function is used to obtain the place number of the event view.
virtual int | GetEventTimelinePlaceNumber () const
This member function is used to obtain the place number of the event in Timeline view.
CRect | GetEventRect () const
This member function is used to obtain the event view's bounding rectangle.
virtual void | AdjustSubjectEditor ()
This member function is used to perform adjustments of the subject editor area.
virtual CString | GetItemTextSubject () const
Call this function to get the item subject.
virtual CString | GetItemTextLocation () const
Call this function to get the item location.
virtual CString | GetItemTextBody () const
Call this function to get the item body.
virtual CString | GetItemTextStartTime () const
Call this function to get the item start time.
virtual CString | GetItemTextEndTime () const
Call this function to get the item end time.
virtual CString | GetItemText (DWORD dwItemFlag, LPCTSTR pcszDefaultText=NULL) const
Call this function to get the item text.
virtual CString | GetMarkupText () const
This member function is used to obtain markup template text.
virtual CXTPMarkupUIElement * | GetMarkupUIElement ()
This member function is used to get a stored CXTPMarkupUIElement object.
virtual BOOL | OnLButtonDown (UINT nFlags, CPoint point)
This member function is used to process left mouse button down events.
virtual BOOL | OnLButtonUp (UINT nFlags, CPoint point)
This member function is used to process left mouse button up events.
virtual BOOL | OnLButtonDblClk (UINT nFlags, CPoint point)
This member function is used to process left mouse button double click events.
virtual void | OnMouseMove (UINT nFlags, CPoint point)
This member function is used to process mouse movement events.
virtual BOOL | OnWndMsg (UINT message, WPARAM wParam, LPARAM lParam, LRESULT *pResult)
This method is called by framework after default message processing.
virtual UINT | SetTimer (UINT uTimeOut_ms)
This member function is used to create a timer event.
virtual void | KillTimer (UINT uTimerID)
This member function is used to destroy a timer event.
virtual BOOL | OnTimer (UINT_PTR uTimerID)
The framework calls this member function after each interval specified in the SetTimer member function.
virtual UINT | GetShowToolTipTimeOut () const
This member function is used to obtain the timeout value for displaying a tooltip.
virtual DWORD | GetSubjectEditorStyles () const
This member function is used to obtain the styles of the editor window.
virtual void | ChangeEventPlace (int nNewPlace)
This function is used to change the event place number.
virtual void | OnBeforeDestroy ()
Called by the framework before the destroy() function is called.
- Public Member Functions inherited from CXTPCalendarWMHandler
CXTPCalendarWMHandler ()
Default object constructor.
virtual int | GetChildHandlersCount () const
This member function is used to obtain the number of CXTPCalendarWMHandler elements in the descendant handlers collection.
virtual CXTPCalendarWMHandler * | GetChildHandlerAt (int nIndex) const
Call this method to get a handler object at the specified numeric index.
virtual void | OnChar (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process keyboard events.
virtual void | OnKeyDown (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process key-down keyboard events.
virtual void | OnKeyUp (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process key-up keyboard events.
virtual BOOL | OnSysKeyDown (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process key-up keyboard events.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

virtual CFont * | GetSubjectEditorFont () const
Call this member function to determine the editor window font.
- Protected Member Functions inherited from CXTPCalendarViewEvent
virtual void | AdjustMultidayEvent (CRect rcEventMax, int nEventPlaceNumber)
This member function is used to adjust a multi-day view's layout depending on the provided rectangle coordinates.
virtual CString | GetToolText ()
This member function is used to obtain tooltip text for the event view.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCalendarViewEvent
static void AFX_CDECL | _MoveRectY (int nYbasePrev, int nYbaseNew, CRect &rRC)
This member function is used to move the rectangle vertically.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPCalendarViewEvent
CRect | m_rcEvent
Event view rectangle.
CRect | m_rcEventMax
Event view rectangle margins.
CRect | m_rcText
Rectangle to display event text in event view.
CSize | m_szText
Sizes of displayed text.
CRect | m_rcFirstClock
Rectangle to draw clock in the beginning of the first day of multi-day event.
CRect | m_rcLastClock
Rectangle to draw clock at the end of the last day of multi-day event.
CRect | m_rcStartTime
Rectangle to display start time day event view.
CRect | m_rcEndTime
Rectangle to display end time event view.
int | m_nMultiDayEventFlags
Multi-day event flags packed into integer by bitwise operations.
CRect | m_rcReminderGlyph
Rectangle to draw reminder glyph event view.
CRect | m_rcRecurrenceGlyph
Rectangle to draw recurrence glyph event view.
CRect | m_rcMeetingGlyph
Rectangle to draw meeting glyph event view.
CRect | m_rcPrivateGlyph
Rectangle to draw private glyph event view.
CRect | m_rcSubjectEditor
Subject editor rectangle.
CRect | m_rcToolTip
Tool tip rectangle.
CXTPMarkupUIElement * | m_pUIElement
Store pointer to CXTPMarkupUIElement object.
CString | m_strUIElementText
Store last markup text for which m_pUIElement object was updated.
- Protected Attributes inherited from CXTPCalendarViewEvent
CXTPCalendarEvent * m_ptrEvent
Pointer to the displayed event object.
BOOL | m_bSelected
Event view selected flag.
CXTPCalendarViewEvent * m_pMasterView
Pointer to Master event view object.
int | m_nEventPlaceNumber
Event view place number (sequential identifier).
int | m_nEventTimelinePlaceNumber
Event view place number in Timeline view.
UINT | m_nTimerID_ShowToolTip
Identifier of timer event to show tooltip with delay.
CXTPCalendarViewEventSubjectEditor * | m_pSubjectEditor
Pointer to the subject editor.
BOOL | m_bMultyDayTextAlign
Flag indicates special text alignment for a multi-day event.
BOOL | m_bTextOutOfBorders
Flag indicates text out of event borders.

Detailed Description

This class represents an event view portion of the CalendarWeekViewDay.

It represents a specific view of the event associated data according to various view types and display settings and provides basic functionality on this data using user input through the keyboard and mouse.

 CXTPCalendarWeekViewEvent is based on CXTPCalendarViewEventT template
 class. CXTPCalendarWeekViewEvent inherits basic behavior from CXTPCalendarViewEventT.
 Furthermore, CXTPCalendarWeekViewEvent overlaps some functionality in
 CXTPCalendarViewEventT and also adds some new functionality for its
 own behavior and look.
See also
CXTPCalendarViewEvent
CXTPCalendarViewEventT

Constructor & Destructor Documentation

◆ CXTPCalendarWeekViewEvent()

CXTPCalendarWeekViewEvent | ( | CXTPCalendarEvent * | pEvent,
 |  | CXTPCalendarWeekViewGroup * | pViewGroup )

Default object constructor.

Parameters
pViewGroup | A pointer to a CXTPCalendarWeekViewGroup object.
pEvent | A pointer to a CXTPCalendarEvent.
See also
~CXTPCalendarWeekViewDay()

Member Function Documentation

◆ AdjustLayout()

virtual void AdjustLayout | ( | CDC * | pDC,
 |  | const CRect & | rcEventMax,
 |  | int | nEventPlaceNumber )
 virtual

This member function is used to adjust the view's layout depending on the provided rectangle and also calls AdjustLayout() for all sub-items.

Parameters
pDC | A pointer to a valid device context.
rcEventMax | An int that contains the rectangle coordinates used to draw the view.
nEventPlaceNumber | An int that contains the sequential place number.

Call Populate(COleDateTime dtDayDate) prior calling AdjustLayout().

Reimplemented from CXTPCalendarViewEvent.

◆ AdjustLayout2()

virtual void AdjustLayout2 | ( | CDC * | pDC,
 |  | const CRect & | rcEventMax,
 |  | int | nEventPlaceNumber )
 virtual

This member function is used to adjust the view's layout depending on the provided rectangle and also calls AdjustLayout() for all sub-items.

Parameters
pDC | A pointer to a valid device context.
rcEventMax | An int that contains the rectangle coordinates used to draw the view.
nEventPlaceNumber | An int that contains the sequential place number.

Call Populate(COleDateTime dtDayDate) prior calling AdjustLayout().

Implements CXTPCalendarViewEvent.

◆ CalcIconsRect()

virtual int CalcIconsRect ( CRect rc )
virtual

This member function is used to adjust rectangles used to draw event view icons.

Parameters
rc A CRect that contains the rectangle coordinates used to draw the view.

Call this member function to calculate rectangles to draw event view icons. Depends on what glyphs should be drawn based on the event view rect.

Returns
An integer denoting the width of the icon.

Reimplemented from CXTPCalendarViewEvent.

◆ Draw()

virtual void Draw ( CDC * pDC )
virtual

This member function is used to draw the view content using the specified device context.

Parameters
pDC A pointer to a valid device context.

Call AdjustLayout() before calling Draw().

See also
AdjustLayout(CRect rcDay)

Implements CXTPCalendarViewEvent.

◆ GetSubjectEditorFont()

virtual CFont * GetSubjectEditorFont ( ) const
protectedvirtual

Call this member function to determine the editor window font.

Returns
A pointer to a CFont object that contains the editor window font.

Reimplemented from CXTPCalendarViewEvent.

◆ GetViewRect()

AFX_INLINE CRect GetViewRect ( )

Call this member function to get the day view rectangle coordinates.

Returns
A CRect object with the day rectangle coordinates.
See also
SetDayRect(CRect rcDay)

◆ HitTestEx()

virtual BOOL HitTestEx | ( | CPoint | point,
 |  | XTP_CALENDAR_HITTESTINFO * | pInfo ) const
 virtual

This member function is used to fill an XTP_CALENDAR_HITTESTINFO structure.

Parameters
point | A CPoint object that contains the point to test.
pInfo | A pointer to a XTP_CALENDAR_HITTESTINFO struct.
Returns
TRUE if the test is successful, FALSE otherwise.

Call this member function to gather hit test information from the day view.

See also
XTP_CALENDAR_HITTESTINFO

Implements CXTPCalendarViewEvent.

◆ IsShowEndTime()

BOOL IsShowEndTime ( ) const

Call this member function to determine the value of the "show end time" flag.

Returns
A BOOL. TRUE if "show end time" flag is set. FALSE otherwise.

◆ IsTimeAsClock()

BOOL IsTimeAsClock ( ) const

Call this member function to determine the value of the "show time as clock" flag.

Returns
A BOOL. TRUE if the "show time as clock" flag is set. FALSE otherwise.

◆ IsVisible()

virtual BOOL IsVisible ( ) const
virtual

Call this member function to determine if the "view visible" flag is set.

Returns
A BOOL. TRUE if the "view visible" is set. FALSE otherwise.

Implements CXTPCalendarViewEvent.

◆ OnPostAdjustLayout()

virtual void OnPostAdjustLayout ( )
virtual

This member function is used to perform additional adjustments.

Call this member function to perform additional adjustments after all adjustment activities are completed.

Reimplemented from CXTPCalendarViewEvent.

The documentation for this class was generated from the following file:
  • XTPCalendarWeekViewEvent.h


Toolkit Pro: CXTPCalendarWeekViewGroup Class Reference

Public Types | Public Member Functions | Protected Member Functions | List of all members
CXTPCalendarWeekViewGroup Class Reference

This class represents a single resource view portion of the Calendar Week View. More...

Inheritance diagram for CXTPCalendarWeekViewGroup:
[legend]

Public Types

typedef CXTPCalendarViewGroupT< CXTPCalendarWeekViewDay, CXTPCalendarWeekViewEvent, CXTPCalendarWeekViewGroup > | TBase
Base class type definition.
- Public Types inherited from CXTPCalendarViewGroupT< CXTPCalendarWeekViewDay, CXTPCalendarWeekViewEvent, CXTPCalendarWeekViewGroup >
typedef CXTPCalendarWeekViewDay | TViewDay

Public Member Functions

CXTPCalendarWeekViewGroup (CXTPCalendarWeekViewDay *pViewDay)
Default object constructor.
virtual | ~CXTPCalendarWeekViewGroup ()
Default class destructor.
- Public Member Functions inherited from CXTPCalendarViewGroupT< CXTPCalendarWeekViewDay, CXTPCalendarWeekViewEvent, CXTPCalendarWeekViewGroup >
CXTPCalendarViewGroupT (CXTPCalendarWeekViewDay *pViewDay)
Default object constructor.
virtual | ~CXTPCalendarViewGroupT ()
Default class destructor.
CXTPCalendarWeekViewDay * | GetViewDay () const
This member function is used to obtain the owner view object.
virtual CXTPCalendarWeekViewEvent * | GetViewEvent (int nIndex) const
Call this member function to obtain a pointer to the _TViewEvent object that corresponds to the event's index.
- Public Member Functions inherited from CXTPCalendarViewGroup
CXTPCalendarViewGroup (CXTPCalendarViewDay *pViewDay)
Default object constructor.
virtual | ~CXTPCalendarViewGroup ()
Default class destructor.
virtual CXTPCalendarResources * | GetResources () const
Obtain a pointer to a collection of Calendar Resources.
virtual CXTPCalendarData * | GetDataProvider () const
Returns data provider for this view group.
virtual void | AddResource (CXTPCalendarResource *pResource, BOOL bWithAddRef)
Adds a new Resource object into the collection of resources for this Group View.
virtual void | SetResources (CXTPCalendarResources *pResources)
Assigns a new Resources collection to this Group View.
virtual UINT | GetScheduleID () const
Returns default Schedule ID - the first existing one.
virtual void | Populate (COleDateTime dtDayDate)
This member function is used to populate the view with data for all items contained in the view.
virtual void | AdjustLayout (CDC *pDC, const CRect &rcGroup)
This member function is used to adjust the view's layout depending on the provided rectangle and then calls AdjustLayout() for all of the sub-items.
virtual void | AdjustLayout2 (CDC *pDC, const CRect &rcGroup)
This member function is used to adjust the view's layout depending on the provided rectangle and then calls AdjustLayout() for all of the sub-items.
virtual void | Draw (CDC *pDC)
This member function is used to draw the view contents using the specified device context.
virtual BOOL | HitTest (CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const
This member function is used to determine which view item, if any, is at the specified position index, and returns additional info in an XTP_CALENDAR_HITTESTINFO struct.
virtual BOOL | HitTestEx (CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const
This member function is used to determine which view item, if any, is at the specified position index, and returns additional info in the XTP_CALENDAR_HITTESTINFO template object.
virtual CRect | GetRect () const
Call this member function to obtain the group's rectangle area.
virtual CRect | GetHeaderRect () const
Call this member function to obtain the group's header rectangle area.
virtual CRect | GetTooltipRect (const CPoint &ptHit, const XTP_CALENDAR_HITTESTINFO &hitInfo) const
Call this member function to obtain the bounding rectangle of the tooltip space (currently this is only "click to add new appointment").
int | GetViewEventsCount () const
Call this member function to obtain the number of event views in the day view collection.
CXTPCalendarViewEvent * | GetViewEvent_ (int nIndex) const
Call this member function to obtain a pointer to a CXTPCalendarViewEvent object associated with the event's index.
CXTPCalendarViewDay * | GetViewDay_ () const
Call this member function to obtain a pointer to the containing CXTPCalendarViewDay object.
virtual int | GetGroupIndex () const
This member function is used to obtain the index of the "this" pointer Group View in the Calendar Day View.
virtual CString | GetCaption () const
This member function is used to obtain a group's view caption.
virtual int | GetChildHandlersCount () const
This member function is used to obtain the number of event views elements in this Group View.
virtual CXTPCalendarWMHandler * | GetChildHandlerAt (int nIndex) const
Call this method to get an event view object at the specified numeric index.
virtual CXTPCalendarViewEvent * | GetViewEventByEvent_ (CXTPCalendarEvent *pEvent) const
Call this member function to obtain a pointer to a CXTPCalendarViewEvent object that is identified by the corresponding event object.
virtual CXTPCalendarViewEvent * | GetViewEventByPlace_ (int nEventPlace) const
Call this member function to obtain an event view object identified by its event place number.
virtual CXTPCalendarControl * | GetCalendarControl () const
Call this member function to obtain a pointer to the calendar control object.
virtual void | ExchangeEventPlace (CXTPCalendarViewEvent *pViewEvent, int nNewPlace)
This member function is used to exchange event view positions.
- Public Member Functions inherited from CXTPCalendarWMHandler
CXTPCalendarWMHandler ()
Default object constructor.
virtual BOOL | OnLButtonDown (UINT nFlags, CPoint point)
This member function is used to process left mouse button down events.
virtual BOOL | OnLButtonUp (UINT nFlags, CPoint point)
This member function is used to process left mouse button up events.
virtual BOOL | OnLButtonDblClk (UINT nFlags, CPoint point)
This member function is used to process left mouse button double click events.
virtual void | OnMouseMove (UINT nFlags, CPoint point)
This member function is used to process mouse movement events.
virtual void | OnChar (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process keyboard events.
virtual void | OnKeyDown (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process key-down keyboard events.
virtual void | OnKeyUp (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process key-up keyboard events.
virtual BOOL | OnSysKeyDown (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process key-up keyboard events.
virtual BOOL | OnTimer (UINT_PTR uTimerID)
The framework calls this member function after each interval specified in the SetTimer member function.
virtual BOOL | OnWndMsg (UINT message, WPARAM wParam, LPARAM lParam, LRESULT *pResult)
This method is called by framework after default message processing.
virtual void | OnPostAdjustLayout ()
This member function is used to perform additional adjustments in some kinds of views.
virtual void | OnBeforeDestroy ()
This member function is called by the framework before destroying the view.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

virtual void | FillHitTestEx (XTP_CALENDAR_HITTESTINFO *pHitTest) const
This member function is used to fill an XTP_CALENDAR_HITTESTINFO structure.
- Protected Member Functions inherited from CXTPCalendarViewGroupT< CXTPCalendarWeekViewDay, CXTPCalendarWeekViewEvent, CXTPCalendarWeekViewGroup >
- Protected Member Functions inherited from CXTPCalendarViewGroup
virtual UINT | SetTimer (UINT uTimeOut_ms)
This member function is used to create a timer event.
virtual void | KillTimer (UINT uTimerID)
This member function is used to destroy a timer event.
virtual void | OnPrePopulate (CXTPCalendarEvents *pEvents)
This member function is used to allow some customization before show events.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Attributes inherited from CXTPCalendarViewGroup
XTP_VIEW_GROUP_LAYOUT | m_Layout
This group view client coordinates.
CXTPCalendarPtrCollectionT< CXTPCalendarViewEvent > | m_arEvents
Storage for events views.
CXTPCalendarResources * | m_pResources
An associated resource object.
CXTPCalendarViewDay * | m_pViewDay
Parent day view.

Detailed Description

This class represents a single resource view portion of the Calendar Week View.

It represents a specific view of the CalendarView's associated events data grouped by one day and one resource group. And provides basic functionality on this data using user input through keyboard and mouse.

See also
CXTPCalendarWeekViewDay

Constructor & Destructor Documentation

◆ CXTPCalendarWeekViewGroup()

CXTPCalendarWeekViewGroup ( CXTPCalendarWeekViewDay * pViewDay )

Default object constructor.

Construct CXTPCalendarWeekViewGroup object.

Parameters
pViewDay Pointer to CXTPCalendarWeekViewDay object.

◆ ~CXTPCalendarWeekViewGroup()

virtual ~CXTPCalendarWeekViewGroup ( )
virtual

Default class destructor.

Handles class members deallocation.

Member Function Documentation

◆ FillHitTestEx()

virtual void FillHitTestEx ( XTP_CALENDAR_HITTESTINFO * pHitTest ) const
protectedvirtual

This member function is used to fill an XTP_CALENDAR_HITTESTINFO structure.

Parameters
pHitTest A pointer to an XTP_CALENDAR_HITTESTINFO struct.

Call this member function to gather hit test information from the week view group.

See also
XTP_CALENDAR_HITTESTINFO

Implements CXTPCalendarViewGroupT< CXTPCalendarWeekViewDay, CXTPCalendarWeekViewEvent, CXTPCalendarWeekViewGroup >.

The documentation for this class was generated from the following file:
  • XTPCalendarWeekViewDay.h


Toolkit Pro: CXTPCalendarWMHandler Class Reference

Public Member Functions | List of all members
CXTPCalendarWMHandler Class Reference

This class helps to handle Windows messages (WM_*) processing portion of the Calendar control views. More...

Inheritance diagram for CXTPCalendarWMHandler:
[legend]

Public Member Functions

CXTPCalendarWMHandler ()
Default object constructor.
virtual int | GetChildHandlersCount () const
This member function is used to obtain the number of CXTPCalendarWMHandler elements in the descendant handlers collection.
virtual CXTPCalendarWMHandler * | GetChildHandlerAt (int nIndex) const
Call this method to get a handler object at the specified numeric index.
virtual BOOL | OnLButtonDown (UINT nFlags, CPoint point)
This member function is used to process left mouse button down events.
virtual BOOL | OnLButtonUp (UINT nFlags, CPoint point)
This member function is used to process left mouse button up events.
virtual BOOL | OnLButtonDblClk (UINT nFlags, CPoint point)
This member function is used to process left mouse button double click events.
virtual void | OnMouseMove (UINT nFlags, CPoint point)
This member function is used to process mouse movement events.
virtual void | OnChar (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process keyboard events.
virtual void | OnKeyDown (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process key-down keyboard events.
virtual void | OnKeyUp (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process key-up keyboard events.
virtual BOOL | OnSysKeyDown (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process key-up keyboard events.
virtual BOOL | OnTimer (UINT_PTR uTimerID)
The framework calls this member function after each interval specified in the SetTimer member function.
virtual BOOL | OnWndMsg (UINT message, WPARAM wParam, LPARAM lParam, LRESULT *pResult)
This method is called by framework after default message processing.
virtual void | OnPostAdjustLayout ()
This member function is used to perform additional adjustments in some kinds of views.
virtual void | OnBeforeDestroy ()
This member function is called by the framework before destroying the view.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

This class helps to handle Windows messages (WM_*) processing portion of the Calendar control views.

All calendar views are derived from this class. When a message is handled by main Calendar control window (CXTPCalendarControl class), it is then forwarded down to views by hierarchy. control -> day/week/month -> single day -> resource group -> event

Member Function Documentation

◆ GetChildHandlerAt()

virtual CXTPCalendarWMHandler * GetChildHandlerAt ( int nIndex ) const
virtual

Call this method to get a handler object at the specified numeric index.

Parameters
nIndex An integer index that is greater than or equal to 0 and less than the value returned by GetChildHandlersCount.

Returns the array element at the specified index.

Returns
The pointer to the CXTPCalendarWMHandler element currently at this index.

Reimplemented in CXTPCalendarCaptionBarTheme, CXTPCalendarView, CXTPCalendarViewDay, and CXTPCalendarViewGroup.

◆ GetChildHandlersCount()

virtual int GetChildHandlersCount ( ) const
virtual

This member function is used to obtain the number of CXTPCalendarWMHandler elements in the descendant handlers collection.

Call this method to retrieve the number of elements in the array. Because indexes are zero-based, the size is 1 greater than the largest index.

This number shows a count of single day views for a day/week/month view, a number of resource groups for a single day view, a number of event views for a resource group view, and so on.

Returns
A count of descendant handlers.
See also
CXTPCalendarWMHandler overview

Reimplemented in CXTPCalendarCaptionBarTheme, CXTPCalendarView, CXTPCalendarViewDay, and CXTPCalendarViewGroup.

◆ OnChar()

virtual void OnChar | ( | UINT | nChar,
 |  | UINT | nRepCnt,
 |  | UINT | nFlags )
 virtual

This member function is used to process keyboard events.

Parameters
nChar | A UINT that contains the character code value of the key.
nRepCnt | A UINT that is used to count the number of times the keystroke is repeated as a result of the user holding down the key.
nFlags | A UINT that contains the Scan code, key-transition code, previous key state, and the context code.

This method is called by the CalendarControl when a keystroke translates to a nonsystem character.

Reimplemented in CXTPCalendarView.

◆ OnKeyDown()

virtual void OnKeyDown | ( | UINT | nChar,
 |  | UINT | nRepCnt,
 |  | UINT | nFlags )
 virtual

This member function is used to process key-down keyboard events.

Parameters
nChar | A UINT that specifies the virtual key code of the given key.
nRepCnt | A UINT that specifies the number of times the keystroke is repeated as a result of the user holding down the key.
nFlags | A UINT that specifies the scan code, key-transition code, previous key state, and the context code.

This method is called by the CalendarView when the user presses keys on the keyboard.

Reimplemented in CXTPCalendarDayView, CXTPCalendarMonthView, CXTPCalendarView, CXTPCalendarWeekView, and CXTPScrollDateButtonPart.

◆ OnKeyUp()

virtual void OnKeyUp | ( | UINT | nChar,
 |  | UINT | nRepCnt,
 |  | UINT | nFlags )
 virtual

This member function is used to process key-up keyboard events.

Parameters
nChar | A UINT that specifies the virtual key code of the given key.
nRepCnt | A UINT that specifies the number of times the keystroke is repeated as a result of the user holding down the key.
nFlags | A UINT that specifies the scan code, key-transition code, previous key state, and the context code.

This method is called by the CalendarView when the user releases keys on the keyboard.

Reimplemented in CXTPScrollDateButtonPart.

◆ OnLButtonDblClk()

virtual BOOL OnLButtonDblClk | ( | UINT | nFlags,
 |  | CPoint | point )
 virtual

This member function is used to process left mouse button double click events.

Parameters
nFlags | An int that indicates whether various virtual keys are down.
point | A CPoint object that specifies the x- and y- coordinates of the cursor. These coordinates are always relative to the upper-left corner of the window.

This method is called by the CalendarView when the user double clicks the left mouse button.

Returns
TRUE if the message is handled properly, FALSE otherwise.

Reimplemented in CXTPCalendarDayViewGroup, CXTPCalendarView, and CXTPCalendarViewEvent.

◆ OnLButtonDown()

virtual BOOL OnLButtonDown | ( | UINT | nFlags,
 |  | CPoint | point )
 virtual

This member function is used to process left mouse button down events.

Parameters
nFlags | An int that indicates whether various virtual keys are down.
point | A CPoint object that specifies the x- and y- coordinates of the cursor. These coordinates are always relative to the upper-left corner of the window.
Returns
TRUE if the message is handled properly, FALSE otherwise.

This method is called by the CalendarView when the user presses the left mouse button.

Reimplemented in CXTPCalendarCaptionBarThemePart, CXTPCalendarDayView, CXTPCalendarDayViewGroup, CXTPCalendarMonthView, CXTPCalendarMonthViewDay, CXTPCalendarView, CXTPCalendarViewEvent, CXTPCalendarWeekViewDay, and CXTPScrollDateButtonPart.

◆ OnLButtonUp()

virtual BOOL OnLButtonUp | ( | UINT | nFlags,
 |  | CPoint | point )
 virtual

This member function is used to process left mouse button up events.

Parameters
nFlags | An int that indicates whether various virtual keys are down.
point | A CPoint object that specifies the x- and y- coordinates of the cursor. These coordinates are always relative to the upper-left corner of the window.
Returns
TRUE if the message is handled properly, FALSE otherwise.

This method is called by the CalendarView when the user releases the left mouse button.

Reimplemented in CXTPCalendarCaptionBarThemePart, CXTPCalendarDayView, CXTPCalendarView, and CXTPCalendarViewEvent.

◆ OnMouseMove()

virtual void OnMouseMove | ( | UINT | nFlags,
 |  | CPoint | point )
 virtual

This member function is used to process mouse movement events.

Parameters
nFlags | A UINT that indicates whether various virtual keys are down.
point | A CPoint object that specifies the x- and y- coordinates of the cursor. These coordinates are always relative to the upper-left corner of the window.

This method is called by the CalendarView when the user moves the mouse cursor or stylus.

Reimplemented in CXTPCalendarCaptionBarTheme, CXTPCalendarCaptionBarThemePart, CXTPCalendarDayView, CXTPCalendarDayViewDay, CXTPCalendarDayViewGroup, CXTPCalendarMonthView, CXTPCalendarMonthViewDay, CXTPCalendarView, CXTPCalendarViewEvent, and CXTPCalendarWeekViewDay.

◆ OnPostAdjustLayout()

virtual void OnPostAdjustLayout ( )
virtual

This member function is used to perform additional adjustments in some kinds of views.

Call this member function to perform additional adjustments after all adjustment activities are completed.

Reimplemented in CXTPCalendarDayViewEvent, CXTPCalendarMonthViewEvent, CXTPCalendarViewEvent, and CXTPCalendarWeekViewEvent.

◆ OnSysKeyDown()

virtual BOOL OnSysKeyDown | ( | UINT | nChar,
 |  | UINT | nRepCnt,
 |  | UINT | nFlags )
 virtual

This member function is used to process key-up keyboard events.

Parameters
nChar | A UINT that specifies the virtual key code of the given key.
nRepCnt | A UINT that specifies the number of times the keystroke is repeated as a result of the user holding down the key.
nFlags | A UINT that specifies the scan code, key-transition code, previous key state, and the context code.
Returns
TRUE if the message is handled properly, FALSE otherwise.

This method is called by the CalendarView when the user presses keys on the keyboard.

Reimplemented in CXTPCalendarView.

◆ OnTimer()

virtual BOOL OnTimer ( UINT_PTR uTimerID )
virtual

The framework calls this member function after each interval specified in the SetTimer member function.

Parameters
uTimerID A UINT that is used to specify the identifier of the timer.
Returns
TRUE if the message is handled properly, FALSE otherwise.

Reimplemented in CXTPCalendarCaptionBarTheme, CXTPCalendarDayView, CXTPCalendarView, and CXTPCalendarViewEvent.

◆ OnWndMsg()

virtual BOOL OnWndMsg | ( | UINT | message,
 |  | WPARAM | wParam,
 |  | LPARAM | lParam,
 |  | LRESULT * | pResult )
 virtual

This method is called by framework after default message processing.

Parameters
message | Specifies the message to be sent.
wParam | Specifies additional message-dependent information.
lParam | Specifies additional message-dependent information.
pResult | The return value of WindowProc. Depends on the message; may be NULL.
Returns
TRUE if the message is handled properly, FALSE otherwise.

Reimplemented in CXTPCalendarViewEvent.

The documentation for this class was generated from the following file:
  • XTPCalendarView.h


Toolkit Pro: CXTPCaption Class Reference

Public Member Functions | Public Attributes | Protected Member Functions | Protected Attributes | List of all members
CXTPCaption Class Reference

CXTPCaption is a CStatic derived class. More...

Public Member Functions

virtual | ~CXTPCaption ()
Destroys a CXTPCaption object, handles cleanup and deallocation.
CXTPCaption ()
Constructs a CXTPCaption object.
BOOL | SetTheme (XTPControlTheme eTheme)
Call this member to switch the visual theme of the control.
BOOL | SetTheme (CXTPCaptionTheme *pTheme)
Call this member to switch the visual theme of the control.
CXTPCaptionTheme * GetTheme ()
Call this member function to get a pointer to the currently selected theme.
bool | IsAppCaption () const
This member function is called to determine if the caption is configured to be used as the application's primary caption.
void | SetAppCaption (bool bAppCaption)
This member function is called to set the flag that indicates if the caption is the application's primary caption.
CXTPCaptionButton & GetCaptionButton ()
Call this member function to get a reference to the caption's close/pop-up button.
virtual void | SetCaptionColors (COLORREF clrBorder, COLORREF clrFace, COLORREF clrText)
This member function will set the caption bar border, background, and font colors.
void | SetOffice2003Colors (bool b2003Colors=true)
Call this member function to enable Office 2003 visualizations.
DWORD | GetCaptionStyle () const
Call this member function to retrieve the current style settings for the caption.
virtual void | ModifyCaptionStyle (int nBorderSize, CFont *pFont=NULL, LPCTSTR lpszWindText=NULL, HICON hIcon=NULL)
Modifies the caption title and appearance.
virtual void | SetChildWindow (CWnd *pChild, CWnd *pNotifyWnd)
Call this member function to set the child and notification windows for the caption bar.
virtual void | KillChildWindow ()
This member function is called to destroy the pop-up window and associated children.
virtual BOOL | ShowPopupWindow ()
This member function is called to display the pop-up window and associated children.
virtual void | UpdateCaption (LPCTSTR lpszWindowText, HICON hIcon)
This member function is called to update the text and icon for the caption bar.
virtual BOOL | Create (CWnd *pParentWnd, LPCTSTR lpszWindowName, DWORD dwExStyle=CPWS_EX_RAISED_EDGE, DWORD dwStyle=WS_VISIBLE|SS_CENTER|SS_CENTERIMAGE, const CRect &rect=CRect(0, 0, 0, 0), UINT nID=0xffff)
Creates and initializes the child window associated with the CXTPCaption object.
void | RefreshButton ()
This member function is called to refresh the caption button style.
const CString & | GetCaptionText ()
This member function retrieves the current caption title.
BOOL | HasCloseButton () const
Call this member function to see if the caption contains a close button.
virtual CRect | GetTextRect () const
This member function is called to determine the size and location of the text associated with the caption.

Public Attributes

int | m_nBorder
Size in pixels for the caption border.
COLORREF | m_clrBorder
An RGB value that represents the user-defined border color.
COLORREF | m_clrFace
An RGB value that represents the user-defined background color.
COLORREF | m_clrText
An RGB value that represents the user-defined font color.

Protected Member Functions

virtual void | DrawCaptionBack (CDC *pDC, CRect &rcItem)
This member function is called to draw the caption background.
virtual void | DrawCaptionText (CDC *pDC)
This member function is called to paint the caption text.
virtual void | DrawCaptionIcon (CDC *pDC, CRect &rcItem)
This member function is called to paint the caption icon.
virtual void | UpdateCaptionText (CDC *pDC)
This member function is called to update the caption text.
virtual CRect | GetButtonRect () const
This member function is called to determine the size and location of the button associated with the caption.
virtual void | RefreshMetrics ()
Call this member function to refresh theme colors and redraw the control.

Protected Attributes

int | m_nOffset
Size in pixels that the child window should leave for its caption area.
bool | m_bUserColors
true if the user has specified caption colors other than the default.
bool | m_bAppCaption
true if the caption is used as the application's primary caption.
CWnd * | m_pChildWnd
A CWnd pointer that represents the child window displayed in the pop-up window.
CWnd * | m_pParentView
A CWnd pointer that represents the child window's parent view.
CWnd * | m_pSplitterWnd
A CWnd pointer that represents the splitter window.
CSize | m_sizeIcon
Width and height of the caption icon area.
CRect | m_rcChild
Size of the child window displayed in the pop-up.
CRect | m_rcParent
Size of the child's parent view.
CRect | m_rcSplitter
Size of the splitter window.
DWORD | m_dwExStyle
Border style bits, either CPWS_EX_GROOVE_EDGE | CPWS_EX_RAISED_EDGE.
HICON | m_hIcon
User-defined icon handle.
CString | m_strCaption
Text that will be displayed in the caption.
CXTPCaptionButton | m_btnCaption
Button used to 'tack' the pop-up window back in place.
CXTPCaptionPopupWnd * | m_pPopupWnd
Pointer to the pop-up window.
CXTPCaptionTheme * | m_pTheme
Pointer to the current theme object.
BOOL | m_bSubclassed
TRUE if the window was sub-classed.

Detailed Description

CXTPCaption is a CStatic derived class.

It is used to create captions or info bars similar to those in Microsoft(r) Outlook.

Member Function Documentation

◆ Create()

virtual BOOL Create | ( | CWnd * | pParentWnd,
 |  | LPCTSTR | lpszWindowName,
 |  | DWORD | dwExStyle = CPWS_EX_RAISED_EDGE,
 |  | DWORD | dwStyle = WS_VISIBLE|SS_CENTER|SS_CENTERIMAGE,
 |  | const CRect & | rect = CRect(0, 0, 0, 0),
 |  | UINT | nID = 0xffff )
 virtual

Creates and initializes the child window associated with the CXTPCaption object.

Parameters
pParentWnd | Specifies the parent window.
lpszWindowName | Pointer to a NULL-terminated character string that contains the window name. This will be displayed in the caption area.
dwExStyle | Specifies caption bar style. See the Remarks section below for a complete list of available styles.
dwStyle | Specifies the control window style. Apply any combination of caption bar styles to the control.
rect | Specifies the position and size of the caption bar. It can be either a RECT structure or a CRect object.
nID | Specifies the caption bar control ID.

This method creates a caption bar window and attaches it to the CXTPCaption object. You construct a caption bar in two steps. First, call the constructor, which constructs the CXTPCaption object. Then call Create, which creates the Window's child window and attaches it to CXTPCaption. Create initializes the window class name and window name and registers values for its style, parent, and ID.

Styles to be added or removed can be combined by using the bitwise OR (|) operator. It can be one or more of the following: CPWS_EX_GROOVE_EDGE: Show the caption with a sunken border. CPWS_EX_RAISED_EDGE: Show the caption with a raised 3D border. CPWS_EX_CLOSEBUTTON: Caption has a close button.

Returns
TRUE if successful, otherwise FALSE.

◆ DrawCaptionBack()

virtual void DrawCaptionBack | ( | CDC * | pDC,
 |  | CRect & | rcItem )
 protectedvirtual

This member function is called to draw the caption background.

Parameters
pDC | A CDC pointer that represents the current device context.
rcItem | A CRect reference that represents the size of the area to paint.

◆ DrawCaptionIcon()

virtual void DrawCaptionIcon | ( | CDC * | pDC,
 |  | CRect & | rcItem )
 protectedvirtual

This member function is called to paint the caption icon.

Parameters
pDC | A CDC pointer that represents the current device context.
rcItem | A CRect reference that represents the size of the area to paint.

◆ DrawCaptionText()

virtual void DrawCaptionText ( CDC * pDC )
protectedvirtual

This member function is called to paint the caption text.

Parameters
pDC A CDC pointer that represents the current device context.

◆ GetButtonRect()

virtual CRect GetButtonRect ( ) const
protectedvirtual

This member function is called to determine the size and location of the button associated with the caption.

Returns
The size and location of the caption button, or an empty rect if no button is defined.

◆ GetCaptionButton()

CXTPCaptionButton & GetCaptionButton ( )

Call this member function to get a reference to the caption's close/pop-up button.

Returns
A reference to a CXTPCaptionButton object.

◆ GetCaptionStyle()

DWORD GetCaptionStyle ( ) const

Call this member function to retrieve the current style settings for the caption.

Returns
A DWORD value that represents the current style set for the caption.

◆ GetCaptionText()

const CString & GetCaptionText ( )

This member function retrieves the current caption title.

Returns
A reference to a CString object that contains the caption title.

◆ GetTextRect()

virtual CRect GetTextRect ( ) const
virtual

This member function is called to determine the size and location of the text associated with the caption.

Returns
The size and location of the caption text, or an empty rect if no text is defined.

◆ GetTheme()

CXTPCaptionTheme * GetTheme ( )

Call this member function to get a pointer to the currently selected theme.

Returns
A pointer to a CXTPCaptionTheme object representing the currently selected theme.

◆ HasCloseButton()

BOOL HasCloseButton ( ) const

Call this member function to see if the caption contains a close button.

Returns
TRUE if the caption contains a close button, otherwise FALSE.

◆ IsAppCaption()

bool IsAppCaption ( ) const
inline

This member function is called to determine if the caption is configured to be used as the application's primary caption.

Returns
true if the caption is configured to be used as the application's primary caption, otherwise false.

◆ ModifyCaptionStyle()

virtual void ModifyCaptionStyle | ( | int | nBorderSize,
 |  | CFont * | pFont = NULL,
 |  | LPCTSTR | lpszWindText = NULL,
 |  | HICON | hIcon = NULL )
 virtual

Modifies the caption title and appearance.

Parameters
nBorderSize | Specifies size in pixels of the banner border.
pFont | Specifies the new caption font.
lpszWindText | A NULL-terminated string specifying the new caption text.
hIcon | Handle of the icon to be drawn in the caption.

You can use this member function to set the border size that is drawn around the caption banner, the font that the caption will use, the caption text, and the icon to be displayed.

◆ SetAppCaption()

void SetAppCaption ( bool bAppCaption )
inline

This member function is called to set the flag that indicates if the caption is the application's primary caption.

Parameters
bAppCaption true to set the flag to indicate that the caption is the application's primary caption.

◆ SetCaptionColors()

virtual void SetCaptionColors | ( | COLORREF | clrBorder,
 |  | COLORREF | clrFace,
 |  | COLORREF | clrText )
 virtual

This member function will set the caption bar border, background, and font colors.

Parameters
clrBorder | An RGB value that represents the new border color.
clrFace | An RGB value that represents the new background color.
clrText | An RGB value that represents the new font color.

◆ SetChildWindow()

virtual void SetChildWindow | ( | CWnd * | pChild,
 |  | CWnd * | pNotifyWnd )
 virtual

Call this member function to set the child and notification windows for the caption bar.

Parameters
pChild | A CWnd pointer that represents the child window to be displayed in the pop-up window.
pNotifyWnd | A CWnd pointer that represents the window to receive notification messages.

◆ SetOffice2003Colors()

void SetOffice2003Colors ( bool b2003Colors = true )

Call this member function to enable Office 2003 visualizations.

Parameters
b2003Colors true to enable Office 2003 visualizations, false to disable.

◆ SetTheme() [1/2]

BOOL SetTheme ( CXTPCaptionTheme * pTheme )

Call this member to switch the visual theme of the control.

Parameters
pTheme New visual theme.
Returns
TRUE if successful; otherwise FALSE.

◆ SetTheme() [2/2]

BOOL SetTheme ( XTPControlTheme eTheme )

Call this member to switch the visual theme of the control.

Parameters
eTheme New visual theme. Can be any of the values listed in the Remarks section.
Returns
TRUE if successful; otherwise FALSE.

nStyle can be one of the following: xtpControlThemeDefault: Use default theme. xtpControlThemeOfficeXP: Use Office XP theme. xtpControlThemeOffice2003: Use Office 2003 theme.

◆ ShowPopupWindow()

virtual BOOL ShowPopupWindow ( )
virtual

This member function is called to display the pop-up window and associated children.

Returns
TRUE if the pop-up window is successfully displayed, otherwise FALSE.

◆ UpdateCaption()

virtual void UpdateCaption | ( | LPCTSTR | lpszWindowText,
 |  | HICON | hIcon )
 virtual

This member function is called to update the text and icon for the caption bar.

Parameters
lpszWindowText | A NULL-terminated string to display in the caption bar.
hIcon | Handle of the icon to display in the caption bar. It can be NULL.

◆ UpdateCaptionText()

virtual void UpdateCaptionText ( CDC * pDC )
protectedvirtual

This member function is called to update the caption text.

Parameters
pDC A CDC pointer that represents the current device context.

Member Data Documentation

◆ m_hIcon

HICON m_hIcon
protected

User-defined icon handle.

The default value is NULL.

◆ m_pSplitterWnd

CWnd* m_pSplitterWnd
protected

A CWnd pointer that represents the splitter window.

It is used to track size changes.

The documentation for this class was generated from the following file:
  • XTPCaption.h


Toolkit Pro: CXTPCaptionButton Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPCaptionButton Class Reference

CXTPCaptionButton is a CXTPButton derived class. More...

Inheritance diagram for CXTPCaptionButton:
[legend]

Public Member Functions

CXTPCaptionButton ()
Constructs a CXTPCaptionButton object.
CXTPCaption * GetCaption ()
This member function is called to retrieve a pointer to the parent caption.
void | SetCaption (CXTPCaption *pCaption)
This member function is called to set the pointer to the parent caption.
virtual BOOL | SetTheme (XTPControlTheme eTheme)
Call this member to switch the visual theme of the control.
virtual void | SetTheme (CXTPButtonTheme *pPaintManager)
Call this member to switch the visual theme of the control.
- Public Member Functions inherited from CXTPButton
CXTPButton ()
Constructs a CXTPButton object.
virtual | ~CXTPButton ()
Destroys a CXTPButton object, handles cleanup and deallocation.
BYTE | GetButtonStyle () const
Retrieves the button styles for this object.
virtual BOOL | IsPushed ()
Call this member function to determine if the the button is currently being pushed.
virtual BOOL | IsHighlighted ()
Call this member function to determine if the the button is currently being highlighted (mouse over).
virtual BOOL | GetChecked ()
Call this member function to determine if the checked state has been defined for the button control.
void | SetChecked (BOOL bChecked)
Sets the highlight state for the button control.
BOOL | GetFlatStyle () const
Gets the flat style appearance of the button control.
void | SetFlatStyle (BOOL bFlatStyle=TRUE)
Sets the flat style appearance of the button control.
BOOL | GetUseVisualStyle () const
Determines if the control is drawn using visual styles/SkinFramework, if supported.
void | SetUseVisualStyle (BOOL bUseVisualStyle=TRUE)
Enables Windows XP visual styles for the control.
long | GetBorderGap () const
Call this member function to retrieve the gap between the button's image and border.
void | SetBorderGap (int nBorderGap)
Call this member function to set the gap between the button's image and border.
XTPPushButtonStyle | GetPushButtonStyle () const
This function retrieves a flag from the XTPPushButtonStyle enumeration that specifies the current style of the button.
void | SetPushButtonStyle (XTPPushButtonStyle nPushButtonStyle)
This member function will set the display style for the button.
virtual int | GetTextAlignment () const
Gets the alignment of the text on the button control.
void | SetTextAlignment (DWORD dwAlignment)
Sets the alignment of the text on the button control.
virtual int | GetImageAlignment () const
Gets the alignment of the image on the button control.
void | SetImageAlignment (DWORD dwAlignment)
Sets the alignment of the image on the button control.
XTPButtonTextImageRelation | GetTextImageRelation () const
Gets the text and image relation in the button.
void | SetTextImageRelation (XTPButtonTextImageRelation relation)
Sets the text and image relation in the button.
long | GetImageGap () const
Call this member function to retrieve the gap between the button's text and image.
void | SetImageGap (int nImageGap)
Call this member function to set the gap between the button's text and image.
virtual CSize | GetImageSize ()
Call this member function to return the size of the image displayed for the button control.
virtual BOOL | IsDpiImageScalingEnabled () const
Call this member to check if DPI scaling of images is enabled.
virtual void | SetDpiImageScaling (BOOL bEnable)
Call this member to enable/disable DPI scaling of images.
CXTPImageManagerIcon * | GetIcon () const
Call this member function to return a pointer to the image manager for the button control.
virtual void | DrawImage (CDC *pDC, CRect rc)
This method is called to draw the image of the control.
XTPGroupBoxBorderStyle | GetBorderStyle () const
Gets the border style of the control.
void | SetBorderStyle (XTPGroupBoxBorderStyle style)
Sets the border style of the control.
BOOL | GetShowFocus () const
Gets whether a focus rectangle is drawn around the contents of a button when the button has focus.
void | SetShowFocus (BOOL bShowFocus)
Sets whether a focus rectangle is drawn around the contents of a button when the button has focus.
CXTPButtonTheme * GetTheme ()
Call this member function to get a pointer to the currently selected theme.
void | RedrawButton (BOOL bUpdateWindow=FALSE)
Redraws the button.
BOOL | IsDropDownStyle () const
This member function is called to determine if the buttons have a drop down arrow and if it is drop down style.
virtual CRect | GetButtonRect ()
This member function is called to determine the size and location of the button.
void | SetBuddy (CWnd *pWndBuddy, BOOL bMoveButton=TRUE)
Sets the control used as the buddy control.
void | SetTooltip (LPCTSTR lpszTooltip)
Associates tooltip text with the button.
CString | GetTooltip () const
Call this member to retrieve the button's tooltip.
CXTPToolTipContext * | GetToolTipContext () const
Call this method to get a pointer to the tooltip context.
virtual BOOL | SetIcon (CSize size, HICON hIcon, HICON hIconHot=NULL, BOOL bRedraw=TRUE)
This member function will set the normal and hot state icons for the push button.
virtual BOOL | SetIcon (CSize size, UINT nID, UINT nHotID=0, BOOL bRedraw=TRUE)
This member function will set the normal and hot state icons for the push button.
virtual BOOL | SetIcon (CSize size, LPCTSTR lpszID, LPCTSTR lpszHotID=NULL, BOOL bRedraw=TRUE)
This member function will set the normal and hot state icons for the push button.
BOOL | SetIcon (CSize size, CXTPImageManagerIcon *pIcon, BOOL bRedraw=TRUE)
This member function will set the normal and hot state icons for the push button.
virtual BOOL | SetIcon (CSize size, const CXTPImageManagerIconHandle &hIconHandle, const CXTPImageManagerIconHandle &hIconHotHandle, BOOL bRedraw=TRUE)
This member function will set the normal and hot state icons for the push button.
virtual BOOL | SetBitmap (CSize size, UINT nID, BOOL bRedraw=TRUE)
This member function will set the bitmap associated with the button.
virtual CString | GetButtonText ()
Call this member function to return the button's text minus the '&'.
CSize | GetGlyphSize (BOOL bCheckBox)
Retrieves the size of the check box glyph.
BOOL | IsPushButton () const
Determines if the button is a push button or a drop down button.
void | EnableMarkup (BOOL bEnableMarkup=TRUE)
Allows the use of a XAML snippet to be used for the text of panes in the control.
virtual COLORREF | GetButtonTextColor ()
Gets the button's text color.
virtual COLORREF | GetButtonBackColor ()
Gets the button's back color.
virtual void | InternalTextChanged ()
This member function is called when the text has changed.
CXTPMarkupContext * | GetMarkupContext () const
Retrieves a pointer to the markup context.
CXTPMarkupUIElement * GetMarkupUIElement ()
Call this method to get the markup element that renders the caption of the control.

Protected Attributes

CXTPCaption * | m_pCaption
A pointer to the parent CXTPCaption.
- Protected Attributes inherited from CXTPButton
CXTPMarkupContext * | m_pMarkupContext
Markup context.
CXTPMarkupUIElement * | m_pUIElement
Markup element pointer.
BOOL | m_bImageDPIScaling
TRUE if DPI scaling of images enabled.

Additional Inherited Members

- Public Attributes inherited from CXTPButton
BOOL | m_bPushed
TRUE if button was pressed.
BOOL | m_bHot
TRUE if mouse under button.
CXTPButtonTheme * | m_pTheme
Pointer to the current theme object.
BOOL | m_bChecked
TRUE if checked.
BOOL | m_bFlatStyle
TRUE to see the flat style.
BOOL | m_bUseVisualStyle
TRUE to use visual styles.
long | m_nImageAlignment
Image Alignment.
long | m_nBorderGap
Gap between the button edge and the image.
long | m_nPushButtonStyle
The style of the button.
BOOL | m_bEnableMarkup
TRUE to enable markup.
long | m_nImageGap
Gap between the button text and the image.
long | m_nTextImageRelation
Image and text orientation.
CXTPImageManagerIcon * | m_pIcon
Multiple state icon manager converts icon to different states.
CSize | m_szVectorIcon
Size of displayed image if vector icon is used.
long | m_nBorderStyle
Border style used.
BOOL | m_bShowFocus
TRUE to show the focus rectangle.
HWND | m_hWndBuddy
Handle to the buddy control.
CXTPToolTipContext * | m_pToolTipContext
TooltipContext.
CString | m_strTooltip
Tooltip of the item.
- Protected Member Functions inherited from CXTPButton
virtual void | OnDropDown ()
Occurs when the drop down button is dropped down.
virtual void | OnDraw (CDC *pDC)
This member function performs all of the drawing logic of the calendar control window.
void | DoDropDown ()
Manually drops down a drop down button.
virtual void | RefreshMetrics ()
Call this member function to refresh theme colors and redraw the control.

Detailed Description

CXTPCaptionButton is a CXTPButton derived class.

It is used by the CXTPCaption class to activate a CXTPCaptionPopupWnd window.

Member Function Documentation

◆ GetCaption()

CXTPCaption * GetCaption ( )
inline

This member function is called to retrieve a pointer to the parent caption.

Returns
A pointer to a CXTPCaption object.

◆ SetCaption()

void SetCaption ( CXTPCaption * pCaption )
inline

This member function is called to set the pointer to the parent caption.

Parameters
pCaption A pointer to a CXTPCaption object.

◆ SetTheme() [1/2]

virtual void SetTheme ( CXTPButtonTheme * pPaintManager )
virtual

Call this member to switch the visual theme of the control.

Parameters
pPaintManager A CXTPButtonTheme pointer to the theme object. If pPaintManager is NULL, then themes are disabled and the paint manager is used.

Reimplemented from CXTPButton.

◆ SetTheme() [2/2]

virtual BOOL SetTheme ( XTPControlTheme eTheme )
virtual

Call this member to switch the visual theme of the control.

Parameters
eTheme New visual theme. Can be any of the values listed in the Remarks section.

eTheme can be one of the following: xtpControlThemeDefault: Use default theme. xtpControlThemeFlat: Flat appearance style. xtpControlThemeUltraFlat: Ultra flat appearance style. xtpControlThemeOffice2000: Office 2000 appearance style. xtpControlThemeOfficeXP: Office XP appearance style. xtpControlThemeOffice2003: Office 2003 appearance style. xtpControlThemeResource: Office 2007 appearance style. xtpControlThemeVisualStudio2012Light: VS 2012 Light style theme. xtpControlThemeVisualStudio2012Dark: VS 2012 Dark style theme.

Returns
TRUE if successful, otherwise FALSE.

Reimplemented from CXTPButton.

The documentation for this class was generated from the following file:
  • XTPCaption.h


Toolkit Pro: CXTPCaptionButtonTheme Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPCaptionButtonTheme Class Reference

CXTPCaptionButtonTheme is derived from CXTPButtonTheme. More...

Inheritance diagram for CXTPCaptionButtonTheme:
[legend]

Public Member Functions

CXTPCaptionButtonTheme ()
Default class constructor.
- Public Member Functions inherited from CXTPButtonTheme
CXTPButtonTheme ()
Constructs a CXTPButtonTheme object.
virtual | ~CXTPButtonTheme ()
Destroys a CXTPButtonTheme object, handles cleanup and deallocation.
virtual void | DrawFocusRect (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the focus rectangle for the button.
virtual void | DrawButton (CDC *pDC, CXTPButton *pButton)
This member function is called to the button.
virtual void | DrawButtonVisualStyleBackground (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the styled background for the button.
virtual void | RefreshMetrics (CXTPButton *pButton)
This member function is called by the theme manager to refresh the visual styles used by each component's theme.
virtual void | DrawPushButtonText (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the text for the button.
virtual void | DrawPushButtonIcon (CDC *pDC, CXTPButton *pButton)
This member function draws the icon for the button, if one has been defined.
virtual void | DrawPushButtonDropDown (CDC *pDC, CXTPButton *pButton)
This member function draws the dropdown for the button, if one has been defined.
virtual void | DrawCheckBoxMark (CDC *pDC, CXTPButton *pButton)
This member function draws the check box mark for the button, if one has been defined.
virtual void | DrawRadioButtonMark (CDC *pDC, CXTPButton *pButton)
This member function draws the radio button mark for the button, if one has been defined.
void | DrawButtonText (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the text for the button.
virtual void | DrawGroupBox (CDC *pDC, CXTPButton *pButton)
This member function draws the group box for the button, if one has been defined.
- Public Member Functions inherited from CXTPControlTheme
CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme | GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

virtual void | DrawButtonText (CDC *pDC, CXTPButton *pButton)
Call this member function to draw the button caption text.
virtual COLORREF | GetTextColor (CXTPButton *pButton)
Call this member function to get the text color of the button caption.
virtual void | DrawButtonBackground (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the background for the button.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlTheme
static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPButtonTheme
CXTPPaintManagerColor | m_crTextDisabled
RGB value for disabled text color.
CXTPPaintManagerColor | m_crBorderHilite
RGB value for border highlight color.
CXTPPaintManagerColor | m_crBorderShadow
RGB value for border shadow color.
CXTPPaintManagerColor | m_crBorder3DHilite
RGB value for 3D border highlight color.
CXTPPaintManagerColor | m_crBorder3DShadow
RGB value for 3D border shadow color.
CXTPPaintManagerColor | m_crBack
RGB value for background color.
CXTPPaintManagerColor | m_crText
RGB value for text color.
CXTPPaintManagerColor | m_crTextCheck
RGB value for checked text color.
- Protected Attributes inherited from CXTPControlTheme
XTPControlTheme | m_nTheme
Currently selected theme style index.

Detailed Description

CXTPCaptionButtonTheme is derived from CXTPButtonTheme.

This class is used to set the caption for buttons.

Member Function Documentation

◆ DrawButtonBackground()

virtual void DrawButtonBackground | ( | CDC * | pDC,
 |  | CXTPButton * | pButton )
 protectedvirtual

This member function is called to draw the background for the button.

Parameters
pDC | A pointer to the target device context.
pButton | A pointer to a CXTPButton object.

Reimplemented from CXTPButtonTheme.

◆ DrawButtonText()

virtual void DrawButtonText | ( | CDC * | pDC,
 |  | CXTPButton * | pButton )
 protectedvirtual

Call this member function to draw the button caption text.

Parameters
pDC | A pointer to a valid device context.
pButton | A pointer to a valid CXTPButton object.

◆ GetTextColor()

virtual COLORREF GetTextColor ( CXTPButton * pButton )
protectedvirtual

Call this member function to get the text color of the button caption.

Parameters
pButton A pointer to a valid CXTPButton object.
Returns
An RGB value specifying the text color.

Reimplemented from CXTPButtonTheme.

The documentation for this class was generated from the following file:
  • XTPCaptionTheme.h


Toolkit Pro: CXTPCaptionButtonThemeOffice2003 Class Reference

Protected Member Functions | List of all members
CXTPCaptionButtonThemeOffice2003 Class Reference

Class CXTPCaptionButtonThemeOffice2003 is a CXTPButtonOffice2003Theme derived class. More...

Inheritance diagram for CXTPCaptionButtonThemeOffice2003:
[legend]

Protected Member Functions

virtual void | DrawButtonBackground (CDC *pDC, CXTPButton *pButton)
Call this member function to draw the background of the button caption.
virtual COLORREF | GetTextColor (CXTPButton *pButton)
Call this member function to get the text color of the button caption.

Additional Inherited Members

- Public Member Functions inherited from CXTPButtonThemeOffice2003
CXTPButtonThemeOffice2003 ()
Constructs a CXTPButtonThemeOffice2003 object.
void | RefreshMetrics (CXTPButton *pButton)
This member function is called by the theme manager to refresh the visual styles used by each component's theme.
- Public Member Functions inherited from CXTPButtonThemeOfficeXP
CXTPButtonThemeOfficeXP ()
Constructs a CXTPButtonThemeOfficeXP object.
void | RefreshMetrics (CXTPButton *pButton)
This member function is called by the theme manager to refresh the visual styles used by each component's theme.
- Public Member Functions inherited from CXTPButtonThemeUltraFlat
CXTPButtonThemeUltraFlat ()
Constructs a CXTPButtonThemeUltraFlat object.
virtual void | DrawGroupBox (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the group box for the button.
virtual void | DrawCheckBoxMark (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the check box mark for the button control.
virtual void | DrawRadioButtonMark (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the radio mark for the button control.
- Public Member Functions inherited from CXTPButtonTheme
CXTPButtonTheme ()
Constructs a CXTPButtonTheme object.
virtual | ~CXTPButtonTheme ()
Destroys a CXTPButtonTheme object, handles cleanup and deallocation.
virtual void | DrawFocusRect (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the focus rectangle for the button.
virtual void | DrawButton (CDC *pDC, CXTPButton *pButton)
This member function is called to the button.
virtual void | DrawButtonVisualStyleBackground (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the styled background for the button.
virtual void | DrawPushButtonText (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the text for the button.
virtual void | DrawPushButtonIcon (CDC *pDC, CXTPButton *pButton)
This member function draws the icon for the button, if one has been defined.
virtual void | DrawPushButtonDropDown (CDC *pDC, CXTPButton *pButton)
This member function draws the dropdown for the button, if one has been defined.
void | DrawButtonText (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the text for the button.
- Public Member Functions inherited from CXTPControlTheme
CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme | GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.
- Static Public Member Functions inherited from CXTPControlTheme
static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPButtonThemeOffice2003
- Public Attributes inherited from CXTPButtonThemeUltraFlat
CXTPPaintManagerColor | m_crBackHilite
RGB value for highlighted background color.
CXTPPaintManagerColor | m_crBackPushed
RGB value for pushed background color.
CXTPPaintManagerColor | m_crBackChecked
RGB value for when the control is checked.
CXTPPaintManagerColor | m_crBorderPushed
RGB value for border pushed color.
CXTPPaintManagerColor | m_crTextPushed
RGB value for pushed text color.
CXTPPaintManagerColor | m_crTextHilite
RGB value for highlighted text color.
CXTPPaintManagerColor | m_crCheckMark
RGB value for check mark color.
- Public Attributes inherited from CXTPButtonTheme
CXTPPaintManagerColor | m_crTextDisabled
RGB value for disabled text color.
CXTPPaintManagerColor | m_crBorderHilite
RGB value for border highlight color.
CXTPPaintManagerColor | m_crBorderShadow
RGB value for border shadow color.
CXTPPaintManagerColor | m_crBorder3DHilite
RGB value for 3D border highlight color.
CXTPPaintManagerColor | m_crBorder3DShadow
RGB value for 3D border shadow color.
CXTPPaintManagerColor | m_crBack
RGB value for background color.
CXTPPaintManagerColor | m_crText
RGB value for text color.
CXTPPaintManagerColor | m_crTextCheck
RGB value for checked text color.
- Protected Attributes inherited from CXTPControlTheme
XTPControlTheme | m_nTheme
Currently selected theme style index.

Detailed Description

Class CXTPCaptionButtonThemeOffice2003 is a CXTPButtonOffice2003Theme derived class.

This class is used to create a button caption that resembles an Office 2003 button caption.

Member Function Documentation

◆ DrawButtonBackground()

virtual void DrawButtonBackground | ( | CDC * | pDC,
 |  | CXTPButton * | pButton )
 protectedvirtual

Call this member function to draw the background of the button caption.

Parameters
pDC | A pointer to the target device context.
pButton | A pointer to a valid CXTPButton object.

Reimplemented from CXTPButtonThemeOffice2003.

◆ GetTextColor()

virtual COLORREF GetTextColor ( CXTPButton * pButton )
protectedvirtual

Call this member function to get the text color of the button caption.

Parameters
pButton A pointer to a valid CXTPButton object.
Returns
An RGB value specifying the text color.

Reimplemented from CXTPButtonTheme.

The documentation for this class was generated from the following file:
  • XTPCaptionButtonThemeOffice2003.h


Toolkit Pro: CXTPCaptionButtonThemeOfficeXP Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPCaptionButtonThemeOfficeXP Class Reference

Class CXTPCaptionButtonThemeOfficeXP is a CXTPButtonOfficeXPTheme derived class. More...

Inheritance diagram for CXTPCaptionButtonThemeOfficeXP:
[legend]

Public Member Functions

CXTPCaptionButtonThemeOfficeXP ()
Default class constructor.
- Public Member Functions inherited from CXTPButtonThemeOfficeXP
CXTPButtonThemeOfficeXP ()
Constructs a CXTPButtonThemeOfficeXP object.
void | RefreshMetrics (CXTPButton *pButton)
This member function is called by the theme manager to refresh the visual styles used by each component's theme.
- Public Member Functions inherited from CXTPButtonThemeUltraFlat
CXTPButtonThemeUltraFlat ()
Constructs a CXTPButtonThemeUltraFlat object.
virtual void | DrawGroupBox (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the group box for the button.
virtual void | DrawCheckBoxMark (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the check box mark for the button control.
virtual void | DrawRadioButtonMark (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the radio mark for the button control.
- Public Member Functions inherited from CXTPButtonTheme
CXTPButtonTheme ()
Constructs a CXTPButtonTheme object.
virtual | ~CXTPButtonTheme ()
Destroys a CXTPButtonTheme object, handles cleanup and deallocation.
virtual void | DrawFocusRect (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the focus rectangle for the button.
virtual void | DrawButton (CDC *pDC, CXTPButton *pButton)
This member function is called to the button.
virtual void | DrawButtonVisualStyleBackground (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the styled background for the button.
virtual void | DrawPushButtonText (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the text for the button.
virtual void | DrawPushButtonIcon (CDC *pDC, CXTPButton *pButton)
This member function draws the icon for the button, if one has been defined.
virtual void | DrawPushButtonDropDown (CDC *pDC, CXTPButton *pButton)
This member function draws the dropdown for the button, if one has been defined.
void | DrawButtonText (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the text for the button.
- Public Member Functions inherited from CXTPControlTheme
CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme | GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

virtual void | DrawButtonText (CDC *pDC, CXTPButton *pButton)
Call this member function to draw the button caption text.
virtual void | DrawButtonBackground (CDC *pDC, CXTPButton *pButton)
Call this member function to draw the background of the button caption.
virtual COLORREF | GetTextColor (CXTPButton *pButton)
Call this member function to get the text color of the button caption.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlTheme
static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPButtonThemeUltraFlat
CXTPPaintManagerColor | m_crBackHilite
RGB value for highlighted background color.
CXTPPaintManagerColor | m_crBackPushed
RGB value for pushed background color.
CXTPPaintManagerColor | m_crBackChecked
RGB value for when the control is checked.
CXTPPaintManagerColor | m_crBorderPushed
RGB value for border pushed color.
CXTPPaintManagerColor | m_crTextPushed
RGB value for pushed text color.
CXTPPaintManagerColor | m_crTextHilite
RGB value for highlighted text color.
CXTPPaintManagerColor | m_crCheckMark
RGB value for check mark color.
- Public Attributes inherited from CXTPButtonTheme
CXTPPaintManagerColor | m_crTextDisabled
RGB value for disabled text color.
CXTPPaintManagerColor | m_crBorderHilite
RGB value for border highlight color.
CXTPPaintManagerColor | m_crBorderShadow
RGB value for border shadow color.
CXTPPaintManagerColor | m_crBorder3DHilite
RGB value for 3D border highlight color.
CXTPPaintManagerColor | m_crBorder3DShadow
RGB value for 3D border shadow color.
CXTPPaintManagerColor | m_crBack
RGB value for background color.
CXTPPaintManagerColor | m_crText
RGB value for text color.
CXTPPaintManagerColor | m_crTextCheck
RGB value for checked text color.
- Protected Attributes inherited from CXTPControlTheme
XTPControlTheme | m_nTheme
Currently selected theme style index.

Detailed Description

Class CXTPCaptionButtonThemeOfficeXP is a CXTPButtonOfficeXPTheme derived class.

This class is used to create a button caption that resembles an Office XP button caption.

Constructor & Destructor Documentation

◆ CXTPCaptionButtonThemeOfficeXP()

CXTPCaptionButtonThemeOfficeXP ( )

Default class constructor.

Call this member function to construct a CXTPCaptionButtonThemeOfficeXP object.

Member Function Documentation

◆ DrawButtonBackground()

virtual void DrawButtonBackground | ( | CDC * | pDC,
 |  | CXTPButton * | pButton )
 protectedvirtual

Call this member function to draw the background of the button caption.

Parameters
pDC | A pointer to the target device context.
pButton | A pointer to a valid CXTPButton object.

Reimplemented from CXTPButtonThemeOfficeXP.

◆ DrawButtonText()

virtual void DrawButtonText | ( | CDC * | pDC,
 |  | CXTPButton * | pButton )
 protectedvirtual

Call this member function to draw the button caption text.

Parameters
pDC | A pointer to a valid device context.
pButton | A pointer to a valid CXTPButton object.

◆ GetTextColor()

virtual COLORREF GetTextColor ( CXTPButton * pButton )
protectedvirtual

Call this member function to get the text color of the button caption.

Parameters
pButton A pointer to a valid CXTPButton object.
Returns
An RGB value specifying the text color.

Reimplemented from CXTPButtonTheme.

The documentation for this class was generated from the following file:
  • XTPCaptionButtonThemeOfficeXP.h


Toolkit Pro: CXTPCaptionPopupWnd Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPCaptionPopupWnd Class Reference

CXTPCaptionPopupWnd is a CWnd derived class. More...

Public Member Functions

CXTPCaptionPopupWnd ()
Constructs a CXTPCaptionPopupWnd object.
virtual | ~CXTPCaptionPopupWnd ()
Destroys a CXTPCaptionPopupWnd object, handles cleanup and deallocation.
virtual BOOL | Create (const CRect &rect, CWnd *pParentWnd, CWnd *pChildWnd)
This member function is called to create and display the pop-up window.
virtual void | RecalcLayout ()
Call this member function to recalculate the layout of the caption and child window.
virtual BOOL | ResetParent ()
Call this member function to reset the parent of the child window back to its default.
virtual BOOL | SendCancelMessage ()
Call this member function to send a cancel message that will cause the pop-up to close.
void | SetTheme (XTPControlTheme nTheme)
Call this member to switch the visual theme of the control.

Protected Member Functions

BOOL RegisterWindowClass ()
Call this member function to register the window class for the pop-up window.

Protected Attributes

CWnd * | m_pParentWnd
A CWnd pointer that represents the parent window.
CWnd * | m_pChildWnd
A CWnd pointer that represents the child displayed in the pop-up.
CWnd * | m_pChildParent
A CWnd pointer that represents the parent of the child window.
CXTPCaption | m_Caption
Caption that is displayed when the window is active.
CXTPCaptionButton | m_CaptionButton
Close button associated with the caption.
CXTPIconHandle | m_hIconOn
Handle to a normal button icon.
CXTPIconHandle | m_hIconOff
Handle to a pressed button icon.

Detailed Description

CXTPCaptionPopupWnd is a CWnd derived class.

It is used by the CXTPCaption class to display a pop-up child window similar to Outlook(tm).

Member Function Documentation

◆ Create()

virtual BOOL Create | ( | const CRect & | rect,
 |  | CWnd * | pParentWnd,
 |  | CWnd * | pChildWnd )
 virtual

This member function is called to create and display the pop-up window.

Parameters
rect | A CRect reference that represents the size of the pop-up window.
pParentWnd | A CWnd pointer that represents the pop-up window.
pChildWnd | A CWnd pointer that represents the child to be displayed when the window is activated.
Returns
TRUE if successful, otherwise FALSE.

◆ RegisterWindowClass()

BOOL RegisterWindowClass ( )
protected

Call this member function to register the window class for the pop-up window.

Returns
TRUE if successful, otherwise FALSE.

◆ ResetParent()

virtual BOOL ResetParent ( )
virtual

Call this member function to reset the parent of the child window back to its default.

Returns
TRUE if successful, otherwise FALSE.

◆ SendCancelMessage()

virtual BOOL SendCancelMessage ( )
virtual

Call this member function to send a cancel message that will cause the pop-up to close.

Returns
TRUE if successful, otherwise FALSE.

◆ SetTheme()

void SetTheme ( XTPControlTheme nTheme )

Call this member to switch the visual theme of the control.

Parameters
nTheme New visual theme. Can be any of the values listed in the Remarks section.

nTheme can be one of the following: xtpControlThemeDefault: Standard appearance style. xtpControlThemeFlat: Flat appearance style. xtpControlThemeUltraFlat: Ultra flat appearance style. xtpControlThemeOffice2000: Office 2000 appearance style. xtpControlThemeOfficeXP: Office XP appearance style. xtpControlThemeOffice2003: Office 2003 appearance style. xtpControlThemeResource: Office 2007 appearance style. xtpControlThemeVisualStudio2012Light: VS 2012 Light style theme. xtpControlThemeVisualStudio2012Dark: VS 2012 Dark style theme.

The documentation for this class was generated from the following file:
  • XTPCaptionPopupWnd.h


Toolkit Pro: CXTPCaptionTheme Class Reference

Public Member Functions | Public Attributes | List of all members
CXTPCaptionTheme Class Reference

CXTPCaptionTheme is a CXTPControlTheme derived class used to control caption themes. More...

Inheritance diagram for CXTPCaptionTheme:
[legend]

Public Member Functions

CXTPCaptionTheme ()
Constructs a CXTPCaptionTheme object.
virtual void | RefreshMetrics (CXTPCaption *pCaption)
This function is called to set the edges of a caption to the system default colors for edge shadow and edge light.
virtual void | DrawCaptionBack (CDC *pDC, CXTPCaption *pCaption, CRect &rcItem)
Call this function to draw the background of the caption at the location specified in the rcItem rect.
virtual void | DrawCaptionText (CDC *pDC, CXTPCaption *pCaption)
Called by CXTPCaption to draw the caption text.
virtual void | DrawCaptionIcon (CDC *pDC, CXTPCaption *pCaption, CRect &rcItem)
Called by CXTPCaption to draw the caption icon.
- Public Member Functions inherited from CXTPControlTheme
CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme | GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Public Attributes

CXTPPaintManagerColor | m_clrEdgeShadow
The color of the edge shadow for the current theme.
CXTPPaintManagerColor | m_clrEdgeLight
The color of the edge light for the current theme.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlTheme
static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Attributes inherited from CXTPControlTheme
XTPControlTheme | m_nTheme
Currently selected theme style index.

Detailed Description

CXTPCaptionTheme is a CXTPControlTheme derived class used to control caption themes.

Custom themes may be derived from this class.

Member Function Documentation

◆ DrawCaptionBack()

virtual void DrawCaptionBack | ( | CDC * | pDC,
 |  | CXTPCaption * | pCaption,
 |  | CRect & | rcItem )
 virtual

Call this function to draw the background of the caption at the location specified in the rcItem rect.

Parameters
pDC | A CDC pointer that represents the current device context.
pCaption | A pointer to a CXTPCaption object.
rcItem | Location where the caption is drawn.

Reimplemented in CXTPCaptionThemeOffice2003, and CXTPCaptionThemeOfficeXP.

◆ DrawCaptionIcon()

virtual void DrawCaptionIcon | ( | CDC * | pDC,
 |  | CXTPCaption * | pCaption,
 |  | CRect & | rcItem )
 virtual

Called by CXTPCaption to draw the caption icon.

Parameters
pDC | A CDC pointer that represents the current device context.
pCaption | A pointer to a CXTPCaption object.
rcItem | Location where the caption is drawn.

Call this function to draw the icon on the caption. Only draws the icon if there is enough space between the caption borders.

◆ DrawCaptionText()

virtual void DrawCaptionText | ( | CDC * | pDC,
 |  | CXTPCaption * | pCaption )
 virtual

Called by CXTPCaption to draw the caption text.

Parameters
pDC | A CDC pointer that represents the current device context.
pCaption | A pointer to a CXTPCaption object.

◆ RefreshMetrics()

virtual void RefreshMetrics ( CXTPCaption * pCaption )
virtual

This function is called to set the edges of a caption to the system default colors for edge shadow and edge light.

Parameters
pCaption Pointer to the CXTPCaption object.
The documentation for this class was generated from the following file:
  • XTPCaptionTheme.h


Toolkit Pro: CXTPCaptionThemeOffice2003 Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPCaptionThemeOffice2003 Class Reference

CXTPCaptionThemeOffice2003 is derived from CXTPCaptionTheme. More...

Inheritance diagram for CXTPCaptionThemeOffice2003:
[legend]

Public Member Functions

CXTPCaptionThemeOffice2003 ()
Constructs a CXTPCaptionThemeOffice2003 object.
- Public Member Functions inherited from CXTPCaptionTheme
CXTPCaptionTheme ()
Constructs a CXTPCaptionTheme object.
virtual void | RefreshMetrics (CXTPCaption *pCaption)
This function is called to set the edges of a caption to the system default colors for edge shadow and edge light.
virtual void | DrawCaptionText (CDC *pDC, CXTPCaption *pCaption)
Called by CXTPCaption to draw the caption text.
virtual void | DrawCaptionIcon (CDC *pDC, CXTPCaption *pCaption, CRect &rcItem)
Called by CXTPCaption to draw the caption icon.
- Public Member Functions inherited from CXTPControlTheme
CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme | GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

virtual void DrawCaptionBack (CDC *pDC, CXTPCaption *pCaption, CRect &rcItem)
Call this function to draw the background of the caption.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlTheme
static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPCaptionTheme
CXTPPaintManagerColor | m_clrEdgeShadow
The color of the edge shadow for the current theme.
CXTPPaintManagerColor | m_clrEdgeLight
The color of the edge light for the current theme.
- Protected Attributes inherited from CXTPControlTheme
XTPControlTheme | m_nTheme
Currently selected theme style index.

Detailed Description

CXTPCaptionThemeOffice2003 is derived from CXTPCaptionTheme.

It is used to set the caption to an Office 2003 theme.

Member Function Documentation

◆ DrawCaptionBack()

virtual void DrawCaptionBack | ( | CDC * | pDC,
 |  | CXTPCaption * | pCaption,
 |  | CRect & | rcItem )
 protectedvirtual

Call this function to draw the background of the caption.

Parameters
pDC | A CDC pointer that represents the current device context.
pCaption | A pointer to a CXTPCaption object.
rcItem | CRect object with the size and location where the caption is drawn.

Reimplemented from CXTPCaptionTheme.

The documentation for this class was generated from the following file:
  • XTPCaptionTheme.h


Toolkit Pro: CXTPCaptionThemeOfficeXP Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPCaptionThemeOfficeXP Class Reference

CXTPCaptionThemeOfficeXP is derived from CXTPCaptionTheme. More...

Inheritance diagram for CXTPCaptionThemeOfficeXP:
[legend]

Public Member Functions

CXTPCaptionThemeOfficeXP ()
Constructs a CXTPCaptionThemeOfficeXP object.
- Public Member Functions inherited from CXTPCaptionTheme
CXTPCaptionTheme ()
Constructs a CXTPCaptionTheme object.
virtual void | RefreshMetrics (CXTPCaption *pCaption)
This function is called to set the edges of a caption to the system default colors for edge shadow and edge light.
virtual void | DrawCaptionText (CDC *pDC, CXTPCaption *pCaption)
Called by CXTPCaption to draw the caption text.
virtual void | DrawCaptionIcon (CDC *pDC, CXTPCaption *pCaption, CRect &rcItem)
Called by CXTPCaption to draw the caption icon.
- Public Member Functions inherited from CXTPControlTheme
CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme | GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

virtual void DrawCaptionBack (CDC *pDC, CXTPCaption *pCaption, CRect &rcItem)
Call this function to draw the background of the caption.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlTheme
static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPCaptionTheme
CXTPPaintManagerColor | m_clrEdgeShadow
The color of the edge shadow for the current theme.
CXTPPaintManagerColor | m_clrEdgeLight
The color of the edge light for the current theme.
- Protected Attributes inherited from CXTPControlTheme
XTPControlTheme | m_nTheme
Currently selected theme style index.

Detailed Description

CXTPCaptionThemeOfficeXP is derived from CXTPCaptionTheme.

It is used to set the caption to an Office XP theme.

Member Function Documentation

◆ DrawCaptionBack()

virtual void DrawCaptionBack | ( | CDC * | pDC,
 |  | CXTPCaption * | pCaption,
 |  | CRect & | rcItem )
 protectedvirtual

Call this function to draw the background of the caption.

Parameters
pDC | A CDC pointer that represents the current device context.
pCaption | A pointer to a CXTPCaption object.
rcItem | CRect object with the size and location where the caption is drawn.

Reimplemented from CXTPCaptionTheme.

The documentation for this class was generated from the following file:
  • XTPCaptionTheme.h


Toolkit Pro: CXTPChart2dDiagram Class Reference

Protected Member Functions | List of all members
CXTPChart2dDiagram Class Reference

The base class for all 2D diagrams. More...

Inheritance diagram for CXTPChart2dDiagram:
[legend]

Protected Member Functions

CXTPChart2dDiagram ()
Constructs a CXTPChartDiagram2D object.
- Protected Member Functions inherited from CXTPChartDiagram
CXTPChartDiagram ()
Constructs a CXTPChartDiagram object.
virtual BOOL | OnSeriesAdded (CXTPChartSeries *pSeries)
This function is called when a series is added to the series collection in the chart content object which has a collection of series.
void | OnSeriesRemoved (CXTPChartSeries *pSeries)
This function is called when a series is removed from the series collection in the chart content object which has a collection of series.
void | Release ()
Call this function to decrease the usage count of the object.
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.

Additional Inherited Members

- Public Member Functions inherited from CXTPChartDiagram
virtual CXTPChartDiagramView * | CreateView (CXTPChartDeviceContext *pDC, CXTPChartElementView *pParent)
Call this function to create a view of the diagram.
virtual void | CalculateSeriesLayout (CXTPChartDeviceContext *pDC, CXTPChartDiagramView *pView)
Call this function to calculate the series layout of the diagram.
const CXTPChartSeriesArray & | GetSeries () const
Call this function to get the series collection object.
virtual void | DoPropExchange (CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
- Public Member Functions inherited from CXTPChartPanel
CXTPChartPanel ()
Constructs a CXTPChartPanel object.
virtual | ~CXTPChartPanel ()
Destroys a CXTPChartMarker object, handles cleanup.
CXTPChartTitleCollection * | GetTitles () const
Call this function to get the the title collection object.
- Public Member Functions inherited from CXTPChartElement
CXTPChartElement ()
Constructs a CXTPChartElement object.
virtual | ~CXTPChartElement ()
Destroys a CXTPChartElement object, handles cleanup.
CXTPChartElement * | GetOwner () const
Call this function to get the owner element.
virtual void | OnChartChanged (XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic properties of the chart.
CXTPChartContent * | GetContent () const
Call this virtual function to get the chart content object.
CXTPChartAppearance * | GetAppearance () const
Call this function to get the the appearance of the chart.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.
- Public Attributes inherited from CXTPChartElement
- Protected Attributes inherited from CXTPChartDiagram
CXTPChartSeriesArray | m_arrSeries
The series collection.
- Protected Attributes inherited from CXTPChartPanel
- Protected Attributes inherited from CXTPChartElement

Detailed Description

The base class for all 2D diagrams.

The documentation for this class was generated from the following file:
  • XTPChartDiagram.h


Toolkit Pro: CXTPChart2dDrawingObjectFactory Class Reference

List of all members
CXTPChart2dDrawingObjectFactory Class Reference

Implements a 2D drawing object factory singleton. More...

Inheritance diagram for CXTPChart2dDrawingObjectFactory:
[legend]

Additional Inherited Members

- Public Member Functions inherited from CXTPChartDrawingObjectFactory
- Static Public Member Functions inherited from CXTPSingleton< CXTPChart2dDrawingObjectFactory >
static CXTPChart2dDrawingObjectFactory &AFX_CDECL Instance ()
Obtains encapsulated singleton instance reference.
- Static Public Member Functions inherited from CXTPChartDrawingObjectFactory
- Protected Member Functions inherited from CXTPChartDrawingObjectFactory

Detailed Description

Implements a 2D drawing object factory singleton.

See also
CXTPChartDrawingObjectFactory, CXTPChart3dDrawingObjectFactory
The documentation for this class was generated from the following file:
  • XTPChartDrawingObjectFactory.h


Toolkit Pro: CXTPChart3dBox Class Reference

Public Types | Public Member Functions | List of all members
CXTPChart3dBox Class Reference

Represents a 3D box build around included points and provides useful and fast operations. More...

Public Types

typedef CList< CXTPPoint3d, const CXTPPoint3d & > PointList
Point list collection type.

Public Member Functions

CXTPChart3dBox ()
Constructs an empty 3D box.
CXTPChart3dBox (const CXTPChart3dBox &rhs)
Constructs a copy of a provided 3D box.
CXTPChart3dBox & | operator= (const CXTPChart3dBox &rhs)
Performs box assignment in an efficient way.
BOOL | IsValid () const
Determines if a box is valid, e.i.
void | Include (const CXTPPoint3d &pt, BOOL bCenterCandidate=FALSE)
Includes a point into the box.
void | Include (double x, double y, double z, BOOL bCenterCandidate=FALSE)
Includes a point into the box.
void | Include (const CXTPChart3dBox &box)
Includes a box into the box.
const CXTPPoint3d & | GetMinPoint () const
Obtains a minimal point in the box, i.e.
const CXTPPoint3d & | GetMaxPoint () const
Obtains a maximal point in the box, i.e.
CXTPPoint3d | GetCenter (BOOL bAmongstCenterCandidates=FALSE) const
Computes a center of the box.
void | GetCorners (CXTPPoint3d(&pt)[8]) const
Obtains box corners coordinates.
const PointList & | GetCenterCandidates () const
Provides access to the list of center candidate points.

Detailed Description

Represents a 3D box build around included points and provides useful and fast operations.

Constructor & Destructor Documentation

◆ CXTPChart3dBox()

CXTPChart3dBox ( const CXTPChart3dBox & rhs )

Constructs a copy of a provided 3D box.

Parameters
rhs A box to be constructed from.

Member Function Documentation

◆ GetCenter()

CXTPPoint3d GetCenter ( BOOL bAmongstCenterCandidates = FALSE ) const

Computes a center of the box.

If bAmongstCenterCandidates is FALSE, then the center of the box is computed as a medium point between the minimal and maximal points. Otherwise the closest to the physical box center point added with CentedCandidate = TRUE is returned.

Parameters
bAmongstCenterCandidates If TRUE, only center candidate points are considered and the closest one to the physical center is returned.
Returns
A center box point.
See also
Include

◆ GetCenterCandidates()

AFX_INLINE const CXTPChart3dBox::PointList & GetCenterCandidates ( ) const

Provides access to the list of center candidate points.

Returns
A reference to the list of center candidate points.
See also
GetCenter

◆ GetCorners()

void GetCorners ( CXTPPoint3d(&) pt[8] ) const

Obtains box corners coordinates.

Parameters
pt An array of 3D box corners. The first 4 points represent the far box face along the Z axis. The next 4 points represent the close box face along the Z axis.

◆ GetMaxPoint()

AFX_INLINE const CXTPPoint3d & GetMaxPoint ( ) const

Obtains a maximal point in the box, i.e.

a point with the maximal coordinate value along 3D axes.

Returns
A point with maximal coordinates.

◆ GetMinPoint()

AFX_INLINE const CXTPPoint3d & GetMinPoint ( ) const

Obtains a minimal point in the box, i.e.

a point with the minimal coordinate value along 3D axes.

Returns
A point with minimal coordinates.

◆ Include() [1/3]

void Include ( const CXTPChart3dBox & box )

Includes a box into the box.

The inclusion assumes stretching to extreme points and copying only center candidates.

Parameters
box A box to include.
See also
GetCenter

◆ Include() [2/3]

void Include | ( | const CXTPPoint3d & | pt,
 |  | BOOL | bCenterCandidate = FALSE )

Includes a point into the box.

If the point exceeds any box side then the box size gets increased.

Parameters
pt | A point to include into the box.
bCenterCandidate | If TRUE, the point is considered a center candidate when GetCenter is called for center candidates.
See also
GetCenter

◆ Include() [3/3]

AFX_INLINE void Include | ( | double | x,
 |  | double | y,
 |  | double | z,
 |  | BOOL | bCenterCandidate = FALSE )

Includes a point into the box.

If the point exceeds any box side then the box size gets increased.

Parameters
x | X coordinate of a point to include into the box.
y | Y coordinate of a point to include into the box.
z | Z coordinate of a point to include into the box.
bCenterCandidate | If TRUE, the point is considered a center candidate when GetCenter is called for center candidates.
See also
GetCenter

◆ IsValid()

BOOL IsValid ( ) const

Determines if a box is valid, e.i.

minimal points are less than or equal to maximal points.

Returns
A BOOL value. TRUE if a box is valid, FALSE otherwise.

◆ operator=()

CXTPChart3dBox & operator= ( const CXTPChart3dBox & rhs )

Performs box assignment in an efficient way.

Parameters
rhs A box to be assigned to.
Returns
Self object reference.
The documentation for this class was generated from the following file:
  • XTPChartTypes.h


Toolkit Pro: CXTPChart3dDeviceCommand Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPChart3dDeviceCommand Class Reference

Defines a common implementation interface for chart 3D drawing commands. More...

Inheritance diagram for CXTPChart3dDeviceCommand:
[legend]

Public Member Functions

virtual BOOL | IsEnabled () const
Determines if the command is currently enabled.
- Public Member Functions inherited from CXTPChartDeviceCommand
CXTPChartDeviceCommand ()
Constructs a CXTPChartDeviceCommand object.
virtual | ~CXTPChartDeviceCommand ()
Destroys a CXTPChartDeviceCommand object, handles cleanup.
BOOL | IsCommitted () const
Determines if the execution of the command has been committed.
void | Commit ()
Commits the execution of the command.
int | GetChildCommandCount () const
Obtains the number of immediate children commands.
CXTPChartDeviceCommand * | GetChildCommand (int nIndex) const
Obtains immediate child command point by index.
CXTPChartDeviceCommand * | AddChildCommand (CXTPChartDeviceCommand *pCommand)
Call this function to add a child device command.
virtual void | Execute (CXTPChartDeviceContext *pDC)
Call this function to execute the drawing.
virtual void | BeforeExecute (CXTPChartDeviceContext *pDC)
This method gets called before a command is executed which allows for the customization of command behavior.
virtual void | AfterExecute (CXTPChartDeviceContext *pDC)
This method gets called after a command is executed which allows for the customization of command behavior.
virtual void | ExecuteOverride (CXTPChartDeviceContext *pDC)
Override this function to write the drawing code for specific objects.
UINT | GetPassNumber () const
Get the number of executions made by the command.
virtual CXTPChartElement * | HitTest (CPoint point, CXTPChartElement *pParent) const
Performs recursive hit testing of the element at the specified point.
virtual void | ApplySeriesStyle (CXTPChartSeriesStyle *pStyle)
Applies series style to the current element.
virtual void | Prepare (CXTPChartDeviceContext *pDC)
Performs inital preparation steps necessary for successful command execution.
virtual void | PrepareOverride (CXTPChartDeviceContext *pDC)
Derived implementation must override this method for implementing implementation specific preparation behavior.
void | SetEnabled (BOOL bEnabled=TRUE)
Enables/disable the command.
CXTPChartDeviceContext * | GetCurrentDC () const
Obtains device context pointer for which the command is currenly being prepared or executed.
void | BindView (CXTPChartElementView *pView)
Binds a view to the command object.
CXTPChartElementView * | GetBoundView () const
Obtains a bound view pointer or NULL if no view is bound.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.
- Public Member Functions inherited from CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents >
void | Subscribe (CXTPChartDeviceCommandEvents *pObserver, CXTPSubscriptionList< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > *pSubcriptionList=NULL)
Subscribes a unique observer for events.
void | Unsubscribe (CXTPChartDeviceCommandEvents *pObserver)
Unsubscribes an observer from events.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *))
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *))
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.

Protected Member Functions

CXTPChart3dDeviceCommand (XTPChart3dAntialiasingPolicy nAntialiasingPolicy)
Constructs a CXTPChart3dDeviceCommand object.
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.
- Protected Member Functions inherited from CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents >
CXTPObservable ()
Constructs an observable object.
~CXTPObservable ()
Handles observable object destruction.

Additional Inherited Members

- Protected Attributes inherited from CXTPChartDeviceCommand
CArray< CXTPChartDeviceCommand *, CXTPChartDeviceCommand * > m_arrChildren
< The array of child device commands.

Detailed Description

Defines a common implementation interface for chart 3D drawing commands.

Constructor & Destructor Documentation

◆ CXTPChart3dDeviceCommand()

CXTPChart3dDeviceCommand ( XTPChart3dAntialiasingPolicy nAntialiasingPolicy )
protected

Constructs a CXTPChart3dDeviceCommand object.

Parameters
nAntialiasingPolicy One of the antialiasing policies defined by the XTPChart3dAntialiasingPolicy enumeration.

Member Function Documentation

◆ IsEnabled()

virtual BOOL IsEnabled ( ) const
virtual

Determines if the command is currently enabled.

Returns
TRUE if the command is currently enabled, FALSE otherwise.

3D commands consider anti-aliasing policy and current device context rendering state in order to determine current enabled status. If device context is skipping anti-aliasing phase when calling this method then the policy is disregarded and the command is considered enabled unles it's been explicitly disabled by the user. If device context is in anti-alising od refault rendering state when this method is called the policy determines the command state unless it's been explicitly disabled by the user.

See also
SetEnabled, XTPChart3dAntialiasingPolicy

Reimplemented from CXTPChartDeviceCommand.

The documentation for this class was generated from the following file:
  • XTPChartDeviceCommand.h


Toolkit Pro: CXTPChart3dDeviceContext Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPChart3dDeviceContext Class Referenceabstract

A base implementation of 3D device context. More...

Inheritance diagram for CXTPChart3dDeviceContext:
[legend]

Public Member Functions

~CXTPChart3dDeviceContext ()
Destroys a CXTPChartDeviceContext object, handles cleanup.
virtual void | Rotate (const CXTPChart3dRotation &rotation)=0
Rotates current matrix.
virtual BOOL | Project (const CXTPPoint3d &pt3d, CPoint &pt2d, double *pdWinZ=NULL)=0
Projects 3D coordinates to 2D space point coordinates.
virtual BOOL | Project (const CXTPChart3dBox &box, CRect &rc)=0
Projects 3D coordinates to 2D space point coordinates.
virtual BOOL | Unproject (const CPoint &pt2d, CXTPPoint3d &pt3d, double dWinZ=0)=0
Projects 2D space point coordinates to 3D space point coordinate on the specified plane.
virtual void | Transform (CXTPPoint3d &v, const CXTPPoint3d *pTranslation=NULL, const CXTPChart3dRotation *pRotation=NULL)=0
Transforms vector or box coordinates.
virtual void | Transform (CXTPChart3dBox &box, const CXTPPoint3d *pTranslation=NULL, const CXTPChart3dRotation *pRotation=NULL)=0
Transforms vector or box coordinates.
virtual BOOL | DepthTest (CPoint point, double &dWinZ)=0
Performs depth dest for 2D point provided.
const CRect & | GetBounds () const
Obtains the device contains boundary rectangle.
BOOL | IsRenderingAntialiasing () const
Checks if the device context is currently rendering anti-aliasing.
BOOL | IsSkippingAntialiasing () const
Checks if the device context is skipping anti-aliasing rendering.
void | OnUpdateCameraState (const CXTPPoint3f &ptPosition, const CXTPPoint3f &ptFocal, const CXTPPoint3f &ptUpVector)
Is called when the camera state is updated.
void | SetModelDistanceLimits (float fMinDistance, float fMaxDistance)
Sets limits for distance between view point and scene center point.
void | SetLightPosition (const CXTPPoint3f &position)
Sets/obtains light position normalized vector where each component is within range [0..1].
const CXTPPoint3f & | GetLightPosition () const
Sets/obtains light position normalized vector where each component is within range [0..1].
void | SetLightAmbientColor (const CXTPChartColor &color)
Sets/obtains light ambient color.
const CXTPChartColor & | GetLightAmbientColor () const
Sets/obtains light ambient color.
void | SetLightDiffuseColor (const CXTPChartColor &color)
Sets/obtains light diffuse color.
const CXTPChartColor & | GetLightDiffuseColor () const
Sets/obtains light diffuse color.
void | SetLightSpecularColor (const CXTPChartColor &color)
Sets/obtains light specular color.
const CXTPChartColor & | GetLightSpecularColor () const
Sets/obtains light specular color.
void | SetLightModelAmbientColor (const CXTPChartColor &color)
Sets/obtains light model ambient color.
const CXTPChartColor & | GetLightModelAmbientColor () const
Sets/obtains light model ambient color.
void | SetMaterialEmissionColor (const CXTPChartColor &color)
Sets/obtains material emission color.
const CXTPChartColor & | GetMaterialEmissionColor () const
Sets/obtains material emission color.
void | SetMaterialDiffuseColor (const CXTPChartColor &color)
Sets/obtains material diffuse color.
const CXTPChartColor & | GetMaterialDiffuseColor () const
Sets/obtains material diffuse color.
void | SetMaterialSpecularColor (const CXTPChartColor &color)
Sets/obtains material specular color.
const CXTPChartColor & | GetMaterialSpecularColor () const
Sets/obtains material specular color.
void | SetMaterialShininess (float fShininess)
Sets/obtains material shininess factor, a value within range [0..1].
float | GetMaterialShininess () const
Sets/obtains material shininess factor, a value within range [0..1].
BOOL | GetAntialiasing () const
Enables/disables antialiasing if supported.
void | SetAntialiasing (BOOL bEnable=TRUE)
Enables/disables antialiasing if supported.
- Public Member Functions inherited from CXTPChartDeviceContext
virtual | ~CXTPChartDeviceContext ()=0
Destroys a CXTPChartDeviceContext object, handles cleanup.
virtual BOOL | Initialize ()
Initializes devices context.
virtual void | Execute (CXTPChartDeviceCommand *pCommand)
Call this function to trigger the drawing.
BOOL | Is3D () const
Determines if the derived device context is a 3D device context.
HDC | GetHDC () const
Call this function to get the windows device context.
CXTPChartContainer * | GetContainer () const
Provides access to the parent container object.
CXTPChartDrawingObjectFactory * | GetDrawingObjectFactory () const
Provides access to the drawing object factory used by the device context implementation.
virtual CXTPChartSizeF | MeasureString (const CXTPChartString *pText, CXTPChartFont *pFont)=0
Call this function to get the measurements of texts rendered in a device context using a specific font.
virtual CXTPChartSizeF | MeasureMarkupElement (CXTPMarkupUIElement *pMarkupUIElement, CXTPChartFont *pFont)=0
Measures the markup element size provided with the font set as the default font for the associated markup context.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

CXTPChart3dDeviceContext (CXTPChartContainer *pContainer, HDC hDC, CRect rcBounds, CXTPChartDrawingObjectFactory *pDrawingObjectFactory)
Constructs a CXTPChart3dDeviceContext object.
void ResetSavedCameraState ()
Resets saved camera state to default zero values.
- Protected Member Functions inherited from CXTPChartDeviceContext
CXTPChartDeviceContext (CXTPChartContainer *pContainer, HDC hDC, BOOL bIs3D, CXTPChartDrawingObjectFactory *pDrawingObjectFactory)
Constructs a CXTPChartDeviceContext object.

Protected Attributes

const CRect | m_rcBounds
Device context bounary rectangle.
BOOL | m_bRenderingAntialiasing
TRUE if currently rendering anti-aliasing.
BOOL | m_bSkippingAntialiasing
TRUE if skipping anti-aliasing rendering

struct CXTPChart3dDeviceContext::CameraState | m_cameraState
Saved camera state.
float | m_fMinModelDistance
Minimal distance allowed to the center of the scene.
float | m_fMaxModelDistance
Maximum distance allowed to the center of the scene.
CXTPPoint3f | m_ptLightPosition
Light position vector, each component is a normalized value in range [0..1].
CXTPChartColor m_clrLightAmbientColor
Light ambient color.
CXTPChartColor m_clrLightDiffuseColor
Light diffuse color.
CXTPChartColor m_clrLightSpecularColor
Light specular color.
CXTPChartColor m_clrLightModelAmbientColor
Light model ambient color.
CXTPChartColor m_clrMaterialEmissionColor
Material emission color.
CXTPChartColor m_clrMaterialDiffuseColor
Material diffuse color.
CXTPChartColor m_clrMaterialSpecularColor
Material specular color.
float | m_fMaterialShininess
Material shininess factor in range [0..1].
BOOL | m_bAntialiasing
Antialiasing flag

BOOL | m_bInitialPass
TRUE if the command tree is executed the very first time.
- Protected Attributes inherited from CXTPChartDeviceContext
const BOOL | m_bIs3D
TRUE identifies device context used for 3D rendering.
HDC | m_hDC
The windows device context.
CXTPChartContainer * | m_pContainer
Parent container pointer.
CXTPChartDrawingObjectFactory * | m_pDrawingObjectFactory
Drawing object factory pointer.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

A base implementation of 3D device context.

See also
CXTPChartDeviceContext

Constructor & Destructor Documentation

◆ CXTPChart3dDeviceContext()

CXTPChart3dDeviceContext | ( | CXTPChartContainer * | pContainer,
 |  | HDC | hDC,
 |  | CRect | rcBounds,
 |  | CXTPChartDrawingObjectFactory * | pDrawingObjectFactory )
 protected

Constructs a CXTPChart3dDeviceContext object.

Parameters
pContainer | Parent container pointer.
hDC | Handle to the windows device context.
rcBounds | Rectangle that defined device context boundaries.
pDrawingObjectFactory | Drawing object factory pointer.

Member Function Documentation

◆ DepthTest()

virtual BOOL DepthTest | ( | CPoint | point,
 |  | double & | dWinZ )
 pure virtual

Performs depth dest for 2D point provided.

Parameters
point | Viewport offset for which depth test is to be performed.
dWinZ | If succeeds the value contains the distance from the near (0) plane of the view frustum to the fist visible point.
Returns
TRUE if depth test is successful, FALSE otherwise.

◆ GetAntialiasing()

AFX_INLINE BOOL GetAntialiasing ( ) const

Enables/disables antialiasing if supported.

Returns
TRUE if antialiasing is enabled.

◆ GetBounds()

AFX_INLINE const CRect & GetBounds ( ) const

Obtains the device contains boundary rectangle.

Returns
The device contains boundary rectangle.

◆ GetLightAmbientColor()

AFX_INLINE const CXTPChartColor & GetLightAmbientColor ( ) const

Sets/obtains light ambient color.

Returns
Current light ambient color.

◆ GetLightDiffuseColor()

AFX_INLINE const CXTPChartColor & GetLightDiffuseColor ( ) const

Sets/obtains light diffuse color.

Returns
Current light diffuse color.

◆ GetLightModelAmbientColor()

AFX_INLINE const CXTPChartColor & GetLightModelAmbientColor ( ) const

Sets/obtains light model ambient color.

Returns
Current light model ambient color.

◆ GetLightPosition()

AFX_INLINE const CXTPPoint3f & GetLightPosition ( ) const

Sets/obtains light position normalized vector where each component is within range [0..1].

Returns
Current light vector.

◆ GetLightSpecularColor()

AFX_INLINE const CXTPChartColor & GetLightSpecularColor ( ) const

Sets/obtains light specular color.

Returns
Current light specular color.

◆ GetMaterialDiffuseColor()

AFX_INLINE const CXTPChartColor & GetMaterialDiffuseColor ( ) const

Sets/obtains material diffuse color.

Returns
Current material diffuse color.

◆ GetMaterialEmissionColor()

AFX_INLINE const CXTPChartColor & GetMaterialEmissionColor ( ) const

Sets/obtains material emission color.

Returns
Current material emission color.

◆ GetMaterialShininess()

AFX_INLINE float GetMaterialShininess ( ) const

Sets/obtains material shininess factor, a value within range [0..1].

Returns
Current material shininess factor.

◆ GetMaterialSpecularColor()

AFX_INLINE const CXTPChartColor & GetMaterialSpecularColor ( ) const

Sets/obtains material specular color.

Returns
Current material specular color.

◆ IsRenderingAntialiasing()

AFX_INLINE BOOL IsRenderingAntialiasing ( ) const

Checks if the device context is currently rendering anti-aliasing.

Returns
TRUE if the device context is currently rendering anti-aliasing, FALSE otherwise.
See also
IsSkippingAntialiasing

◆ IsSkippingAntialiasing()

AFX_INLINE BOOL IsSkippingAntialiasing ( ) const

Checks if the device context is skipping anti-aliasing rendering.

Returns
TRUE if the device context is skipping anti-aliasing rendering, FALSE otherwise.
See also
IsRenderingAntialiasing

◆ OnUpdateCameraState()

void OnUpdateCameraState | ( | const CXTPPoint3f & | ptPosition,
 |  | const CXTPPoint3f & | ptFocal,
 |  | const CXTPPoint3f & | ptUpVector )

Is called when the camera state is updated.

Parameters
ptPosition | New camera position.
ptFocal | New camera focal point.
ptUpVector | New camera up vector.

◆ Project() [1/2]

virtual BOOL Project | ( | const CXTPChart3dBox & | box,
 |  | CRect & | rc )
 pure virtual

Projects 3D coordinates to 2D space point coordinates.

Parameters
box | 3D box to map to the outer 2D rectangle.
rc | Resuylt 2D outer rectangle for the 3D box specified.
Returns
TRUE if coordinates are mapped successfully, FALSE otherwise.
See also
Unproject

◆ Project() [2/2]

virtual BOOL Project | ( | const CXTPPoint3d & | pt3d,
 |  | CPoint & | pt2d,
 |  | double * | pdWinZ = NULL )
 pure virtual

Projects 3D coordinates to 2D space point coordinates.

Parameters
pt3d | 3D space point coordinates.
pt2d | Result 2D space point coordinates.
pdWinZ | If specified the result value is within range 0..1 where 0 defines the near plane and 1 defines the far plane defined by the view frustum.
Returns
TRUE if coordinates are mapped successfully, FALSE otherwise.
See also
Unproject

◆ Rotate()

virtual void Rotate ( const CXTPChart3dRotation & rotation )
pure virtual

Rotates current matrix.

Parameters
rotation Matrix rotation arguments.

◆ SetAntialiasing()

AFX_INLINE void SetAntialiasing ( BOOL bEnable = TRUE )

Enables/disables antialiasing if supported.

Parameters
bEnable TRUE to enable antialiasing, FALSE to disable.

◆ SetLightAmbientColor()

AFX_INLINE void SetLightAmbientColor ( const CXTPChartColor & color )

Sets/obtains light ambient color.

Parameters
color New light ambient color.

◆ SetLightDiffuseColor()

AFX_INLINE void SetLightDiffuseColor ( const CXTPChartColor & color )

Sets/obtains light diffuse color.

Parameters
color New light diffuse color.

◆ SetLightModelAmbientColor()

AFX_INLINE void SetLightModelAmbientColor ( const CXTPChartColor & color )

Sets/obtains light model ambient color.

Parameters
color New light model ambient color.

◆ SetLightPosition()

AFX_INLINE void SetLightPosition ( const CXTPPoint3f & position )

Sets/obtains light position normalized vector where each component is within range [0..1].

Parameters
position New light vector.

◆ SetLightSpecularColor()

AFX_INLINE void SetLightSpecularColor ( const CXTPChartColor & color )

Sets/obtains light specular color.

Parameters
color New light specular color.

◆ SetMaterialDiffuseColor()

AFX_INLINE void SetMaterialDiffuseColor ( const CXTPChartColor & color )

Sets/obtains material diffuse color.

Parameters
color New material diffuse color.

◆ SetMaterialEmissionColor()

AFX_INLINE void SetMaterialEmissionColor ( const CXTPChartColor & color )

Sets/obtains material emission color.

Parameters
color New material emission color.

◆ SetMaterialShininess()

AFX_INLINE void SetMaterialShininess ( float fShininess )

Sets/obtains material shininess factor, a value within range [0..1].

Parameters
fShininess New opacity factor.

◆ SetMaterialSpecularColor()

AFX_INLINE void SetMaterialSpecularColor ( const CXTPChartColor & color )

Sets/obtains material specular color.

Parameters
color New material specular color.

◆ SetModelDistanceLimits()

AFX_INLINE void SetModelDistanceLimits | ( | float | fMinDistance,
 |  | float | fMaxDistance )

Sets limits for distance between view point and scene center point.

Parameters
fMinDistance | Minimal distance allowed.
fMaxDistance | Maximum distance allowed.

◆ Transform() [1/2]

virtual void Transform | ( | CXTPChart3dBox & | box,
 |  | const CXTPPoint3d * | pTranslation = NULL,
 |  | const CXTPChart3dRotation * | pRotation = NULL )
 pure virtual

Transforms vector or box coordinates.

Parameters
box | A box to transform.
pTranslation | Optional translation offsets to add to the vector or box vertices.
pRotation | Optional vector opr box vertices rotation parameters.

◆ Transform() [2/2]

virtual void Transform | ( | CXTPPoint3d & | v,
 |  | const CXTPPoint3d * | pTranslation = NULL,
 |  | const CXTPChart3dRotation * | pRotation = NULL )
 pure virtual

Transforms vector or box coordinates.

Parameters
v | A vector to transform.
pTranslation | Optional translation offsets to add to the vector or box vertices.
pRotation | Optional vector opr box vertices rotation parameters.

◆ Unproject()

virtual BOOL Unproject | ( | const CPoint & | pt2d,
 |  | CXTPPoint3d & | pt3d,
 |  | double | dWinZ = 0 )
 pure virtual

Projects 2D space point coordinates to 3D space point coordinate on the specified plane.

Parameters
pt2d | 2D space point coordinates.
pt3d | Result 3D space point coordinates.
dWinZ | Determines how far the point is from the near plane. The value must be within 0..1 range where 0 determines the near frustum plane and 1 determines the far plane.
Returns
TRUE is the coordinates are mapped successfully, FALSE otherwise.
See also
Project

Member Data Documentation

◆ m_clrLightAmbientColor

CXTPChartColor m_clrLightAmbientColor
protected

Light ambient color.

◆ m_clrLightDiffuseColor

CXTPChartColor m_clrLightDiffuseColor
protected

Light diffuse color.

◆ m_clrLightModelAmbientColor

CXTPChartColor m_clrLightModelAmbientColor
protected

Light model ambient color.

◆ m_clrLightSpecularColor

CXTPChartColor m_clrLightSpecularColor
protected

Light specular color.

◆ m_clrMaterialDiffuseColor

CXTPChartColor m_clrMaterialDiffuseColor
protected

Material diffuse color.

◆ m_clrMaterialEmissionColor

CXTPChartColor m_clrMaterialEmissionColor
protected

Material emission color.

◆ m_clrMaterialSpecularColor

CXTPChartColor m_clrMaterialSpecularColor
protected

Material specular color.

◆ m_rcBounds

const CRect m_rcBounds
protected

Device context bounary rectangle.

The documentation for this class was generated from the following file:
  • XTPChart3dDeviceContext.h


Toolkit Pro: CXTPChart3dDiagram Class Reference

Public Member Functions | Static Public Attributes | Protected Member Functions | List of all members
CXTPChart3dDiagram Class Reference

The base class for all 3D diagrams. More...

Inheritance diagram for CXTPChart3dDiagram:
[legend]

Public Member Functions

const CXTPPoint3f & | GetCameraPosition () const
Obtains camera coordinates in 3D space.
const CXTPMatrix< double > & | GetViewRotationMatrix () const
Obtains view rotation matrix.
void | SetArcBallBounds (double dWidth, double dHeight)
Sets boundaries for arc ball used for rotating the view.
BOOL | SetStartArcBallRotationPoint (POINT point)
Sets start arc ball rotation point.
BOOL | RotateArcBallToPoint (POINT point)
Rotates arc ball to the specified point.
void | ZoomArcBall (float fDelta)
Zooms arc ball in or out.
- Public Member Functions inherited from CXTPChartDiagram
virtual CXTPChartDiagramView * | CreateView (CXTPChartDeviceContext *pDC, CXTPChartElementView *pParent)
Call this function to create a view of the diagram.
virtual void | CalculateSeriesLayout (CXTPChartDeviceContext *pDC, CXTPChartDiagramView *pView)
Call this function to calculate the series layout of the diagram.
const CXTPChartSeriesArray & | GetSeries () const
Call this function to get the series collection object.
virtual void | DoPropExchange (CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
- Public Member Functions inherited from CXTPChartPanel
CXTPChartPanel ()
Constructs a CXTPChartPanel object.
virtual | ~CXTPChartPanel ()
Destroys a CXTPChartMarker object, handles cleanup.
CXTPChartTitleCollection * | GetTitles () const
Call this function to get the the title collection object.
- Public Member Functions inherited from CXTPChartElement
CXTPChartElement ()
Constructs a CXTPChartElement object.
virtual | ~CXTPChartElement ()
Destroys a CXTPChartElement object, handles cleanup.
CXTPChartElement * | GetOwner () const
Call this function to get the owner element.
virtual void | OnChartChanged (XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic properties of the chart.
CXTPChartContent * | GetContent () const
Call this virtual function to get the chart content object.
CXTPChartAppearance * | GetAppearance () const
Call this function to get the the appearance of the chart.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Static Public Attributes

static const float | m_fChartBoxSize
The side of the box in 3D space within which a chart is drawn.
static const int | m_nPrimitiveSize
The size of a primitive, the smallest part of a chart, e.g.
static const float | m_fMinModelDistance
The closest possible distance to the center of a model.
static const float | m_fMaxModelDistance
The farthest possible distance to the center of a model.

Protected Member Functions

CXTPChart3dDiagram ()
Constructs a CXTPChart3dDiagram object.
~CXTPChart3dDiagram ()
Handles CXTPChart3dDiagram object destruction.
- Protected Member Functions inherited from CXTPChartDiagram
CXTPChartDiagram ()
Constructs a CXTPChartDiagram object.
virtual BOOL | OnSeriesAdded (CXTPChartSeries *pSeries)
This function is called when a series is added to the series collection in the chart content object which has a collection of series.
void | OnSeriesRemoved (CXTPChartSeries *pSeries)
This function is called when a series is removed from the series collection in the chart content object which has a collection of series.
void | Release ()
Call this function to decrease the usage count of the object.
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.

Additional Inherited Members

- Public Attributes inherited from CXTPChartElement
- Protected Attributes inherited from CXTPChartDiagram
CXTPChartSeriesArray m_arrSeries
The series collection.
- Protected Attributes inherited from CXTPChartPanel
- Protected Attributes inherited from CXTPChartElement

Detailed Description

The base class for all 3D diagrams.

Member Function Documentation

◆ GetCameraPosition()

AFX_INLINE const CXTPPoint3f & GetCameraPosition ( ) const

Obtains camera coordinates in 3D space.

The camera is always directed to the center of the model.

Returns
Camera coordinates in 3D space.

◆ GetViewRotationMatrix()

AFX_INLINE const CXTPMatrix< double > & GetViewRotationMatrix ( ) const

Obtains view rotation matrix.

The matrix is used for rotating view and not the model itself.

Returns
View rotation matrix.

◆ RotateArcBallToPoint()

BOOL RotateArcBallToPoint ( POINT point )

Rotates arc ball to the specified point.

Parameters
point Specifies the relative x- and y- coordinates of the end rotation point.
Returns
TRUE if the rotation is completed, otherwise FALSE.

◆ SetArcBallBounds()

void SetArcBallBounds | ( | double | dWidth,
 |  | double | dHeight )

Sets boundaries for arc ball used for rotating the view.

Parameters
dWidth | Available width value.
dHeight | Available height value.

◆ SetStartArcBallRotationPoint()

BOOL SetStartArcBallRotationPoint ( POINT point )

Sets start arc ball rotation point.

Parameters
point Specifies the relative x- and y- coordinates of the start arc ball rotation point.
Returns
TRUE if the start rotation point is set, FALSE otherwise.

◆ ZoomArcBall()

void ZoomArcBall ( float fDelta )

Zooms arc ball in or out.

Parameters
fDelta The zooming distance. If positive, arc ball is zoomed in. If negative, arc ball is zoomed out.

Member Data Documentation

◆ m_nPrimitiveSize

const int m_nPrimitiveSize
static

The size of a primitive, the smallest part of a chart, e.g.

triangle side size.

The documentation for this class was generated from the following file:
  • XTPChartDiagram.h


Toolkit Pro: CXTPChart3dDiagramView Class Reference

Public Member Functions | List of all members
CXTPChart3dDiagramView Class Reference

This class represents the view of a chart diagram, which is a kind of CXTPChartElementView. More...

Inheritance diagram for CXTPChart3dDiagramView:
[legend]

Public Member Functions

CXTPChart3dDiagramView (CXTPChartDiagram *pDiagram, CXTPChartElementView *pParentView)
Constructs a CXTPChart3dDiagramView object.
virtual CXTPChartDeviceCommand * | CreateDeviceCommand (CXTPChartDeviceContext *pDC)
Creates a view device command.
- Public Member Functions inherited from CXTPChartDiagramView
CXTPChartDiagramView (CXTPChartDiagram *pDiagram, CXTPChartElementView *pParentView)
Constructs a CXTPChartDiagram object.
CRect | GetBounds () const
Call this function to get the bounds of the diagram.
CXTPChartDiagram * | GetDiagram () const
Call this function to get the diagram object associated with the view.
CXTPChartElementView * | GetLabelsView () const
Call this function to get the label view object associated with this diagram view.
CXTPChartElementView * | GetSeriesView () const
Call this function to get the series view object associated with this diagram view.
virtual void | CalculateView (CXTPChartDeviceContext *pDC, CRect rcBounds)
Call this function to calculate the view of the diagram.
virtual void | UpdateRange (CXTPChartDeviceContext *pDC)
Updates chart range.
virtual void | OnMouseWheel (UINT nFlags, short zDelta, CPoint pt)
Handles mouse wheel event.
virtual void | CreateView (CXTPChartDeviceContext *pDC)
Performs view initialization.
- Public Member Functions inherited from CXTPChartElementView
CXTPChartElementView (CXTPChartElementView *pParentView)
Constructs a CXTPChartElementView object.
CXTPChartElementView (CXTPChartElementView *pParentView, BOOL bAddToParent)
Constructs a CXTPChartElementView object.
CXTPChartElementView (CXTPChartContainer *pContainer)
Constructs a CXTPChartElementView object.
int | GetCount () const
Call this function to get the number of child views associated with this view.
CXTPChartElementView * | GetAt (int nIndex) const
Call this function to get a child view at a particular index.
CXTPChartElementView * | GetParentView () const
Call this function to get the parent view.
CXTPChartElementView * | AddChildView (CXTPChartElementView *pChildView)
Call this function to add a child view to the current view.
CXTPChartElementView ** GetChildren ()
Provides access to the collection of children elements owned by the view.
CRect | GetBounds () const
Obtains viewed object's bound rectangle.
CRect | GetBounds (BOOL bIncludingChildren) const
Obtains viewed object's bound rectangle.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Additional Inherited Members

- Public Attributes inherited from CXTPChartDiagramView
- Protected Member Functions inherited from CXTPChartDiagramView
- Protected Member Functions inherited from CXTPChartElementView
virtual | ~CXTPChartElementView ()
Destroys a CXTPChartElementView object, handles cleanup.
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.
- Protected Attributes inherited from CXTPChartDiagramView
CXTPChartDiagram * | m_pDiagram
Pointer to the associated diagram object.
CRect | m_rcBounds
The diagram bounds.
CXTPChartElementView * | m_pLabelsView
The label view.
CXTPChartElementView * | m_pSeriesView
The series view.
CXTPChartElementView * | m_pTitlesView
Titles View.
- Protected Attributes inherited from CXTPChartElementView
CArray< CXTPChartElementView *, CXTPChartElementView * > | m_arrChildren
The child view collection.
CXTPChartElementView * | m_pParentView
The parent view.
CXTPChartContainer * | m_pContainer
The parent container.
CRect | m_rcBounds
Bounding rectangle.

Detailed Description

This class represents the view of a chart diagram, which is a kind of CXTPChartElementView.

Constructor & Destructor Documentation

◆ CXTPChart3dDiagramView()

CXTPChart3dDiagramView | ( | CXTPChartDiagram * | pDiagram,
 |  | CXTPChartElementView * | pParentView )

Constructs a CXTPChart3dDiagramView object.

Parameters
pDiagram | A pointer to the chart diagram object.
pParentView | A pointer to the parent view.

Member Function Documentation

◆ CreateDeviceCommand()

virtual CXTPChartDeviceCommand * CreateDeviceCommand ( CXTPChartDeviceContext * pDC )
virtual

Creates a view device command.

Parameters
pDC Device context pointer for which a command is to be created.
Returns
A new view device command. A caller is responsible for deleting the command object.

Reimplemented from CXTPChartDiagramView.

The documentation for this class was generated from the following file:
  • XTPChartDiagramView.h


Toolkit Pro: CXTPChart3dDrawingObjectFactory Class Reference

List of all members
CXTPChart3dDrawingObjectFactory Class Reference

Implements a 3D drawing object factory singleton. More...

Inheritance diagram for CXTPChart3dDrawingObjectFactory:
[legend]

Additional Inherited Members

- Public Member Functions inherited from CXTPChartDrawingObjectFactory
- Static Public Member Functions inherited from CXTPSingleton< CXTPChart3dDrawingObjectFactory >
static CXTPChart3dDrawingObjectFactory &AFX_CDECL Instance ()
Obtains encapsulated singleton instance reference.
- Static Public Member Functions inherited from CXTPChartDrawingObjectFactory
- Protected Member Functions inherited from CXTPChartDrawingObjectFactory

Detailed Description

Implements a 3D drawing object factory singleton.

See also
CXTPChartDrawingObjectFactory, CXTPChart2dDrawingObjectFactory
The documentation for this class was generated from the following file:
  • XTPChartDrawingObjectFactory.h


Toolkit Pro: CXTPChart3dFunnelDeviceCommandEvents Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPChart3dFunnelDeviceCommandEvents Class Reference

Defines interface for 3D chart funnel device command event sink. More...

Inheritance diagram for CXTPChart3dFunnelDeviceCommandEvents:
[legend]

Public Member Functions

virtual void | OnSetConnectorPoints (CXTPChartDeviceCommand *pCommand, CXTPPoint3d ptShapeCenter, CXTPPoint3d ptOuterCenter)
Gets called when funnel connector points are computed.
- Public Member Functions inherited from CXTPChartDeviceCommandEvents
virtual void | OnBeforeExecute (CXTPChartDeviceCommand *pCommand, CXTPChartDeviceContext *pDC)
Notifies that a command has entered the BeforeExecute step.
virtual void | OnAfterExecute (CXTPChartDeviceCommand *pCommand, CXTPChartDeviceContext *pDC)
Notifies that a command has entered the AfterExecute step.
virtual void | OnUpdateBounds (CXTPChartDeviceCommand *pCommand, CRect rcBounds)
Notifies about updated boundaries for the command result.
void | OnUnsubscribe (CXTPChartDeviceCommand *pCommand)
Invoked when an event sink is to be unsubscribed from command events.

Protected Member Functions

CXTPChart3dFunnelDeviceCommandEvents ()
Constructs a CXTPChart3dFunnelDeviceCommandEvents object.
- Protected Member Functions inherited from CXTPChartDeviceCommandEvents
CXTPChartDeviceCommandEvents ()
Constructs an event sink.

Detailed Description

Defines interface for 3D chart funnel device command event sink.

Member Function Documentation

◆ OnSetConnectorPoints()

virtual void OnSetConnectorPoints | ( | CXTPChartDeviceCommand * | pCommand,
 |  | CXTPPoint3d | ptShapeCenter,
 |  | CXTPPoint3d | ptOuterCenter )
 virtual

Gets called when funnel connector points are computed.

Parameters
pCommand | The sender command.
ptShapeCenter | The coordinates of the physical shape center.
ptOuterCenter | The coordinates of the most outer horizontal shape center point.

Reimplemented in CXTPChart3dFunnelSeriesPointView.

The documentation for this class was generated from the following file:
  • XTPChart3dFunnelDeviceCommandEvents.h


Toolkit Pro: CXTPChart3dFunnelDiagram Class Reference

Public Member Functions | List of all members
CXTPChart3dFunnelDiagram Class Reference

This class abstracts the funnel diagram. More...

Inheritance diagram for CXTPChart3dFunnelDiagram:
[legend]

Public Member Functions

CXTPChart3dFunnelDiagram ()
Constructs a CXTPChart3dFunnelDiagram object.
virtual CXTPChartDiagramView * | CreateView (CXTPChartDeviceContext *pDC, CXTPChartElementView *pParent)
Call this function to create the view of the funnel diagram.
- Public Member Functions inherited from CXTPChartFunnelDiagramBase< BaseDiagram >
CXTPChartFunnelDiagramBase ()
Constructs a CXTPChartFunnelDiagramBase object.
virtual void | CalculateSeriesLayout (CXTPChartDeviceContext *pDC, CXTPChartDiagramView *pView)
Call this function to calculate the funnel series layout.

Detailed Description

This class abstracts the funnel diagram.

This class is a kind of CXTPChartDiagram.

Member Function Documentation

◆ CreateView()

virtual CXTPChartDiagramView * CreateView | ( | CXTPChartDeviceContext * | pDC,
 |  | CXTPChartElementView * | pParent )
 virtual

Call this function to create the view of the funnel diagram.

Parameters
pDC | A pointer to the chart device context.
pParent | A pointer to the parent view.
Returns
Returns a pointer to the associated diagram view object.

Implements CXTPChartFunnelDiagramBase< BaseDiagram >.

The documentation for this class was generated from the following file:
  • XTPChart3dFunnelDiagram.h


Toolkit Pro: CXTPChart3dFunnelDiagramView Class Reference

Public Member Functions | List of all members
CXTPChart3dFunnelDiagramView Class Reference

This class abstracts the view of a funnel diagram. More...

Inheritance diagram for CXTPChart3dFunnelDiagramView:
[legend]

Public Member Functions

CXTPChart3dFunnelDiagramView (CXTPChartDiagram *pDiagram, CXTPChartElementView *pParent)
Constructs a CXTPChart3dFunnelDiagramView object.
- Public Member Functions inherited from CXTPChart3dDiagramView
CXTPChart3dDiagramView (CXTPChartDiagram *pDiagram, CXTPChartElementView *pParentView)
Constructs a CXTPChart3dDiagramView object.
virtual CXTPChartDeviceCommand * | CreateDeviceCommand (CXTPChartDeviceContext *pDC)
Creates a view device command.
- Public Member Functions inherited from CXTPChartDiagramView
CXTPChartDiagramView (CXTPChartDiagram *pDiagram, CXTPChartElementView *pParentView)
Constructs a CXTPChartDiagram object.
CRect | GetBounds () const
Call this function to get the bounds of the diagram.
CXTPChartDiagram * | GetDiagram () const
Call this function to get the diagram object associated with the view.
CXTPChartElementView * | GetLabelsView () const
Call this function to get the label view object associated with this diagram view.
CXTPChartElementView * | GetSeriesView () const
Call this function to get the series view object associated with this diagram view.
virtual void | CalculateView (CXTPChartDeviceContext *pDC, CRect rcBounds)
Call this function to calculate the view of the diagram.
virtual void | UpdateRange (CXTPChartDeviceContext *pDC)
Updates chart range.
virtual void | OnMouseWheel (UINT nFlags, short zDelta, CPoint pt)
Handles mouse wheel event.
virtual void | CreateView (CXTPChartDeviceContext *pDC)
Performs view initialization.
- Public Member Functions inherited from CXTPChartElementView
CXTPChartElementView (CXTPChartElementView *pParentView)
Constructs a CXTPChartElementView object.
CXTPChartElementView (CXTPChartElementView *pParentView, BOOL bAddToParent)
Constructs a CXTPChartElementView object.
CXTPChartElementView (CXTPChartContainer *pContainer)
Constructs a CXTPChartElementView object.
int | GetCount () const
Call this function to get the number of child views associated with this view.
CXTPChartElementView * | GetAt (int nIndex) const
Call this function to get a child view at a particular index.
CXTPChartElementView * | GetParentView () const
Call this function to get the parent view.
CXTPChartElementView * | AddChildView (CXTPChartElementView *pChildView)
Call this function to add a child view to the current view.
CXTPChartElementView ** GetChildren ()
Provides access to the collection of children elements owned by the view.
CRect | GetBounds () const
Obtains viewed object's bound rectangle.
CRect | GetBounds (BOOL bIncludingChildren) const
Obtains viewed object's bound rectangle.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Additional Inherited Members

- Public Attributes inherited from CXTPChartDiagramView
- Protected Member Functions inherited from CXTPChartDiagramView
- Protected Member Functions inherited from CXTPChartElementView
virtual | ~CXTPChartElementView ()
Destroys a CXTPChartElementView object, handles cleanup.
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.
- Protected Attributes inherited from CXTPChartDiagramView
CXTPChartDiagram * | m_pDiagram
Pointer to the associated diagram object.
CRect | m_rcBounds
The diagram bounds.
CXTPChartElementView * | m_pLabelsView
The label view.
CXTPChartElementView * | m_pSeriesView
The series view.
CXTPChartElementView * | m_pTitlesView
Titles View.
- Protected Attributes inherited from CXTPChartElementView
CArray< CXTPChartElementView *, CXTPChartElementView * > | m_arrChildren
The child view collection.
CXTPChartElementView * | m_pParentView
The parent view.
CXTPChartContainer * | m_pContainer
The parent container.
CRect | m_rcBounds
Bounding rectangle.

Detailed Description

This class abstracts the view of a funnel diagram.

This class is a kind of CXTPChartDiagramView.

A funnel chart (or a circle graph) is a circular chart divided into sectors, illustrating percents. In a funnel chart, the arc length of each sector (and consequently its central angle and area), is proportional to the quantity it represents. Together, the sectors create a full disk.

Constructor & Destructor Documentation

◆ CXTPChart3dFunnelDiagramView()

CXTPChart3dFunnelDiagramView | ( | CXTPChartDiagram * | pDiagram,
 |  | CXTPChartElementView * | pParent )

Constructs a CXTPChart3dFunnelDiagramView object.

Parameters
pDiagram | A pointer to the funnel diagram object.
pParent | A pointer to the parent view.
The documentation for this class was generated from the following file:
  • XTPChart3dFunnelDiagramView.h


Toolkit Pro: CXTPChart3dFunnelSeriesLabel Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPChart3dFunnelSeriesLabel Class Reference

CXTPChartFunnelSeriesLabelBase is a kind of CXTPChart3dFunnelSeriesLabel. More...

Inheritance diagram for CXTPChart3dFunnelSeriesLabel:
[legend]

Public Member Functions

CXTPChart3dFunnelSeriesLabel ()
Constructs a CXTPChart3dFunnelSeriesLabel object.
- Public Member Functions inherited from CXTPChartFunnelSeriesLabelBase
CXTPChartFunnelSeriesLabelBase ()
Constructs a CXTPChartFunnelSeriesLabelBase object.
virtual | ~CXTPChartFunnelSeriesLabelBase ()
Destroys a CXTPChartFunnelSeriesLabelBase object, handles cleanup.
XTPChartFunnelLabelPosition | GetPosition () const
Call this function to get the label position.
void | SetPosition (XTPChartFunnelLabelPosition nPosition)
Call this function to set the label position.
CXTPChartFunnelSeriesStyleBase * | GetStyle () const
Call this function to get the basic style of the funnel series.
void | DoPropExchange (CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
BOOL | IsInside () const
Call this function to check whether the label is inside the funnel.
- Public Member Functions inherited from CXTPChartSeriesLabel
CXTPChartSeriesLabel ()
Constructs a CXTPChartSeriesLabel object.
virtual | ~CXTPChartSeriesLabel ()
Destroys a CXTPChartSeriesLabel object, handles cleanup.
void | SetTextColor (const CXTPChartColor &clrTextColor)
Call this function to set the text color of the label.
CXTPChartColor | GetTextColor () const
Call this function to get the apparent text color of the label.
CXTPChartFont * | GetFont () const
Call this function to get the font of the text label.
void | SetFont (CXTPChartFont *pFont)
Call this function to set the font of the text label.
void | SetShowLines (BOOL bShowLines)
Call this function to set the lines visibility.
BOOL | GetShowLines () const
Call this function to check if the lines are visible.
void | SetLineLength (int nLineLength)
Call this function to set the line length.
int | GetLineLength () const
Call this function to get the line length.
void | SetVisible (BOOL bVisible)
Call this function to set the label visibility.
BOOL | IsVisible () const
Call this function to check if the label is visible.
void | SetAntialiasing (BOOL bAntialiasing)
Call this function to set anti-aliasing ON or OFF.
BOOL | GetAntialiasing () const
Call this function to check if anti-aliasing is ON or OFF.
CXTPChartNumberFormat * | GetFormat () const
Call this function to get a pointer to CXTPChartNumberFormat that specifies how to convert numbers to strings.
void | SetFormat (LPCTSTR lpszFormat)
Obsolete method.
void | SetBackColor (const CXTPChartColor &clrBackColor)
Call this function to set the text color of the label.
CXTPChartColor | GetBackColor () const
Call this function to get the apparent text color of the label.
void | SetLineColor (const CXTPChartColor &clrBackColor)
Call this function to set the text color of the label.
CXTPChartColor | GetLineColor () const
Call this function to get the apparent text color of the label.
int | GetTransparency () const
Call this function to get the transparency of the filled area with respect to the background.
void | SetTransparency (int nTransparency)
Call this function to set the transparency of the filled area with respect to the background.
- Public Member Functions inherited from CXTPChartTextElement
- Public Member Functions inherited from CXTPChartElement
CXTPChartElement ()
Constructs a CXTPChartElement object.
virtual | ~CXTPChartElement ()
Destroys a CXTPChartElement object, handles cleanup.
virtual void | Release ()
Call this function to decrease the usage count of the object.
CXTPChartElement * | GetOwner () const
Call this function to get the owner element.
virtual void | OnChartChanged (XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic properties of the chart.
CXTPChartContent * | GetContent () const
Call this virtual function to get the chart content object.
CXTPChartAppearance * | GetAppearance () const
Call this function to get the the appearance of the chart.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Protected Member Functions

virtual CXTPChartElementView * CreateView (CXTPChartDeviceContext *pDC, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView)
This function creates the view of the funnel series.
- Protected Member Functions inherited from CXTPChartFunnelSeriesLabelBase
- Protected Member Functions inherited from CXTPChartSeriesLabel
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.

Additional Inherited Members

- Public Attributes inherited from CXTPChartElement
- Protected Attributes inherited from CXTPChartFunnelSeriesLabelBase
XTPChartFunnelLabelPosition | m_nPosition
The funnel label position.
- Protected Attributes inherited from CXTPChartSeriesLabel
CXTPChartColor | m_clrTextColor
The text color.
CXTPChartColor | m_clrBackColor
The background color.
CXTPChartColor | m_clrLineColor
The line color.
BOOL | m_bVisible
TRUE if the label is visible and FALSE if not.
CXTPChartFont * | m_pFont
The font of the label.
BOOL | m_bAntialiasing
TRUE if antialiasing enabled, FALSE if not.
BOOL | m_bShowLines
TRUE if the lines are visible, FALSE if not.
int | m_nLineLength
The line length.
CXTPChartBorder * | m_pBorder
Chart border object.
int | m_nTransparency
The transparency values range from 0 to 255.
- Protected Attributes inherited from CXTPChartElement

Detailed Description

CXTPChartFunnelSeriesLabelBase is a kind of CXTPChart3dFunnelSeriesLabel.

This class abstracts the label of a funnel series.

Member Function Documentation

◆ CreateView()

virtual CXTPChartElementView * CreateView | ( | CXTPChartDeviceContext * | pDC,
 |  | CXTPChartSeriesPointView * | pPointView,
 |  | CXTPChartElementView * | pParentView )
 protectedvirtual

This function creates the view of the funnel series.

Parameters
pDC | The chart device context object pointer.
pPointView | The series point view.
pParentView | Parent element view pointer.
Returns
Returns a pointer to the associated label view object.

Implements CXTPChartFunnelSeriesLabelBase.

The documentation for this class was generated from the following file:
  • XTPChart3dFunnelSeriesLabel.h


Toolkit Pro: CXTPChart3dFunnelSeriesLabelDeviceCommand Class Reference

Public Member Functions | List of all members
CXTPChart3dFunnelSeriesLabelDeviceCommand Class Reference

Implements 3D chart funnel series label device command. More...

Inheritance diagram for CXTPChart3dFunnelSeriesLabelDeviceCommand:
[legend]

Public Member Functions

CXTPChart3dFunnelSeriesLabelDeviceCommand (CXTPChart3dFunnelSeriesLabelView *pSeriesLabelView)
Constructs a CXTPChart3dFunnelSeriesLabelDeviceCommand object.
virtual void | ExecuteOverride (CXTPChartDeviceContext *pDC)
Override this function to write the drawing code for specific objects.
CXTPChart3dFunnelSeriesLabelView * | GetSeriesLabelView () const
Obtains label view object pointer.
BOOL | IsFailed () const
Checks whether command object is in a failed state.
void | SetFailed ()
Sets command object to a failed state.
CRect | GetLabelRect () const
Obtains label rectangle.
void | SetLabelRect (CRect rcLabel)
Sets label rectangle.
BOOL | ComputeConnectorVector (CXTPChart3dDeviceContext *pDC)
Computes connector vector.
void | ComputeLabel (CXTPChart3dDeviceContext *pDC)
Computes label.
double | GetConnectorLength () const
Determines connector length value.
void | SetConnectorLength (double dLength)
Sets connector length value.
double | GetConnectorEndpointVerticalOffset () const
Determines connector endpoint vertical offset value.
void | SetConnectorEndpointVerticalOffset (double yOffset)
Sets connector endpoint vertical offset value.
- Public Member Functions inherited from CXTPChart3dDeviceCommand
virtual BOOL | IsEnabled () const
Determines if the command is currently enabled.
- Public Member Functions inherited from CXTPChartDeviceCommand
CXTPChartDeviceCommand ()
Constructs a CXTPChartDeviceCommand object.
virtual | ~CXTPChartDeviceCommand ()
Destroys a CXTPChartDeviceCommand object, handles cleanup.
BOOL | IsCommitted () const
Determines if the execution of the command has been committed.
void | Commit ()
Commits the execution of the command.
int | GetChildCommandCount () const
Obtains the number of immediate children commands.
CXTPChartDeviceCommand * | GetChildCommand (int nIndex) const
Obtains immediate child command point by index.
CXTPChartDeviceCommand * | AddChildCommand (CXTPChartDeviceCommand *pCommand)
Call this function to add a child device command.
virtual void | Execute (CXTPChartDeviceContext *pDC)
Call this function to execute the drawing.
virtual void | BeforeExecute (CXTPChartDeviceContext *pDC)
This method gets called before a command is executed which allows for the customization of command behavior.
virtual void | AfterExecute (CXTPChartDeviceContext *pDC)
This method gets called after a command is executed which allows for the customization of command behavior.
UINT | GetPassNumber () const
Get the number of executions made by the command.
virtual CXTPChartElement * | HitTest (CPoint point, CXTPChartElement *pParent) const
Performs recursive hit testing of the element at the specified point.
virtual void | ApplySeriesStyle (CXTPChartSeriesStyle *pStyle)
Applies series style to the current element.
virtual void | Prepare (CXTPChartDeviceContext *pDC)
Performs inital preparation steps necessary for successful command execution.
virtual void | PrepareOverride (CXTPChartDeviceContext *pDC)
Derived implementation must override this method for implementing implementation specific preparation behavior.
void | SetEnabled (BOOL bEnabled=TRUE)
Enables/disable the command.
CXTPChartDeviceContext * | GetCurrentDC () const
Obtains device context pointer for which the command is currenly being prepared or executed.
void | BindView (CXTPChartElementView *pView)
Binds a view to the command object.
CXTPChartElementView * | GetBoundView () const
Obtains a bound view pointer or NULL if no view is bound.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.
- Public Member Functions inherited from CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents >
void | Subscribe (CXTPChartDeviceCommandEvents *pObserver, CXTPSubscriptionList< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > *pSubcriptionList=NULL)
Subscribes a unique observer for events.
void | Unsubscribe (CXTPChartDeviceCommandEvents *pObserver)
Unsubscribes an observer from events.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *))
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *))
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.

Additional Inherited Members

- Protected Member Functions inherited from CXTPChart3dDeviceCommand
CXTPChart3dDeviceCommand (XTPChart3dAntialiasingPolicy nAntialiasingPolicy)
Constructs a CXTPChart3dDeviceCommand object.
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.
- Protected Member Functions inherited from CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents >
CXTPObservable ()
Constructs an observable object.
~CXTPObservable ()
Handles observable object destruction.
- Protected Attributes inherited from CXTPChartDeviceCommand
CArray< CXTPChartDeviceCommand *, CXTPChartDeviceCommand * > m_arrChildren
< The array of child device commands.

Detailed Description

Implements 3D chart funnel series label device command.

Constructor & Destructor Documentation

◆ CXTPChart3dFunnelSeriesLabelDeviceCommand()

CXTPChart3dFunnelSeriesLabelDeviceCommand ( CXTPChart3dFunnelSeriesLabelView * pSeriesLabelView )

Constructs a CXTPChart3dFunnelSeriesLabelDeviceCommand object.

Parameters
pSeriesLabelView Associated series label view pointer.

Member Function Documentation

◆ ComputeConnectorVector()

BOOL ComputeConnectorVector ( CXTPChart3dDeviceContext * pDC )

Computes connector vector.

Parameters
pDC Target device context pointer.
Returns
TRUE if the vector is successfully computed, FALSE otherwise.

◆ ComputeLabel()

void ComputeLabel ( CXTPChart3dDeviceContext * pDC )

Computes label.

Parameters
pDC Target device context pointer.

◆ ExecuteOverride()

virtual void ExecuteOverride ( CXTPChartDeviceContext * pDC )
virtual

Override this function to write the drawing code for specific objects.

Parameters
pDC A pointer to the chart device context.

Reimplemented from CXTPChartDeviceCommand.

◆ GetConnectorEndpointVerticalOffset()

AFX_INLINE double GetConnectorEndpointVerticalOffset ( ) const

Determines connector endpoint vertical offset value.

Returns
Connector endpoint vertical offset value.
See also
SetConnectorEndpointVerticalOffset

◆ GetConnectorLength()

AFX_INLINE double GetConnectorLength ( ) const

Determines connector length value.

Returns
Connector length value.
See also
SetConnectorLength

◆ GetLabelRect()

AFX_INLINE CRect GetLabelRect ( ) const

Obtains label rectangle.

Returns
Label rectangle.
See also
SetLabelRect

◆ GetSeriesLabelView()

AFX_INLINE CXTPChart3dFunnelSeriesLabelView * GetSeriesLabelView ( ) const

Obtains label view object pointer.

Returns
Label view object pointer

◆ IsFailed()

AFX_INLINE BOOL IsFailed ( ) const

Checks whether command object is in a failed state.

Returns
TRUE if command object is in a failed state, FALSE otherwise.
See also
SetFailed

◆ SetConnectorEndpointVerticalOffset()

AFX_INLINE void SetConnectorEndpointVerticalOffset ( double yOffset )

Sets connector endpoint vertical offset value.

Parameters
yOffset New connector endpoint vertical offset value.
See also
GetConnectorEndpointVerticalOffset

◆ SetConnectorLength()

AFX_INLINE void SetConnectorLength ( double dLength )

Sets connector length value.

Parameters
dLength New connector length value.
See also
GetConnectorLength

◆ SetLabelRect()

AFX_INLINE void SetLabelRect ( CRect rcLabel )

Sets label rectangle.

Parameters
rcLabel Label rectangle.
See also
GetLabelRect
The documentation for this class was generated from the following file:
  • XTPChart3dFunnelSeriesLabelsViewDeviceCommand.h


Toolkit Pro: CXTPChart3dFunnelSeriesLabelsView Class Reference

Public Member Functions | List of all members
CXTPChart3dFunnelSeriesLabelsView Class Reference

Represents a view object for all funnel series labels. More...

Inheritance diagram for CXTPChart3dFunnelSeriesLabelsView:
[legend]

Public Member Functions

CXTPChart3dFunnelSeriesLabelsView (CXTPChartElementView *pParentView)
Constructs a view object.
virtual CXTPChartDeviceCommand * | CreateDeviceCommand (CXTPChartDeviceContext *pDC)
Creates view drawing device command for the device context specified.
void | ResolveOverlapping ()
Resolves label overlapping in an implementation specific way.
- Public Member Functions inherited from CXTPChartElementView
CXTPChartElementView (CXTPChartElementView *pParentView)
Constructs a CXTPChartElementView object.
CXTPChartElementView (CXTPChartElementView *pParentView, BOOL bAddToParent)
Constructs a CXTPChartElementView object.
CXTPChartElementView (CXTPChartContainer *pContainer)
Constructs a CXTPChartElementView object.
int | GetCount () const
Call this function to get the number of child views associated with this view.
CXTPChartElementView * | GetAt (int nIndex) const
Call this function to get a child view at a particular index.
CXTPChartElementView * | GetParentView () const
Call this function to get the parent view.
CXTPChartElementView * | AddChildView (CXTPChartElementView *pChildView)
Call this function to add a child view to the current view.
CXTPChartElementView ** GetChildren ()
Provides access to the collection of children elements owned by the view.
CRect | GetBounds () const
Obtains viewed object's bound rectangle.
CRect | GetBounds (BOOL bIncludingChildren) const
Obtains viewed object's bound rectangle.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Additional Inherited Members

- Protected Member Functions inherited from CXTPChartElementView
virtual | ~CXTPChartElementView ()
Destroys a CXTPChartElementView object, handles cleanup.
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.
- Protected Attributes inherited from CXTPChartElementView
CArray< CXTPChartElementView *, CXTPChartElementView * > | m_arrChildren
The child view collection.
CXTPChartElementView * | m_pParentView
The parent view.
CXTPChartContainer * | m_pContainer
The parent container.
CRect | m_rcBounds
Bounding rectangle.

Detailed Description

Represents a view object for all funnel series labels.

Constructor & Destructor Documentation

◆ CXTPChart3dFunnelSeriesLabelsView()

CXTPChart3dFunnelSeriesLabelsView ( CXTPChartElementView * pParentView )

Constructs a view object.

Parameters
pParentView Parent view pointer.

Member Function Documentation

◆ CreateDeviceCommand()

virtual CXTPChartDeviceCommand * CreateDeviceCommand ( CXTPChartDeviceContext * pDC )
virtual

Creates view drawing device command for the device context specified.

Parameters
pDC Device context pointer for which the drawing command is to be created.
Returns
A new instance of view drawing device command or NULL if no command is provided.

Reimplemented from CXTPChartElementView.

The documentation for this class was generated from the following file:
  • XTPChart3dFunnelSeriesLabel.h


Toolkit Pro: CXTPChart3dFunnelSeriesLabelsViewDeviceCommand Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPChart3dFunnelSeriesLabelsViewDeviceCommand Class Reference

Represents device command for all funnel series labels view. More...

Inheritance diagram for CXTPChart3dFunnelSeriesLabelsViewDeviceCommand:
[legend]

Public Member Functions

CXTPChart3dFunnelSeriesLabelsViewDeviceCommand (CXTPChart3dFunnelSeriesLabelsView *pSeriesLabelsView)
Constructs a command object instance.
virtual void | ExecuteOverride (CXTPChartDeviceContext *pDC)
Override this function to write the drawing code for specific objects.
- Public Member Functions inherited from CXTPChart3dDeviceCommand
virtual BOOL | IsEnabled () const
Determines if the command is currently enabled.
- Public Member Functions inherited from CXTPChartDeviceCommand
CXTPChartDeviceCommand ()
Constructs a CXTPChartDeviceCommand object.
virtual | ~CXTPChartDeviceCommand ()
Destroys a CXTPChartDeviceCommand object, handles cleanup.
BOOL | IsCommitted () const
Determines if the execution of the command has been committed.
void | Commit ()
Commits the execution of the command.
int | GetChildCommandCount () const
Obtains the number of immediate children commands.
CXTPChartDeviceCommand * | GetChildCommand (int nIndex) const
Obtains immediate child command point by index.
CXTPChartDeviceCommand * | AddChildCommand (CXTPChartDeviceCommand *pCommand)
Call this function to add a child device command.
virtual void | Execute (CXTPChartDeviceContext *pDC)
Call this function to execute the drawing.
virtual void | BeforeExecute (CXTPChartDeviceContext *pDC)
This method gets called before a command is executed which allows for the customization of command behavior.
virtual void | AfterExecute (CXTPChartDeviceContext *pDC)
This method gets called after a command is executed which allows for the customization of command behavior.
UINT | GetPassNumber () const
Get the number of executions made by the command.
virtual CXTPChartElement * | HitTest (CPoint point, CXTPChartElement *pParent) const
Performs recursive hit testing of the element at the specified point.
virtual void | ApplySeriesStyle (CXTPChartSeriesStyle *pStyle)
Applies series style to the current element.
virtual void | Prepare (CXTPChartDeviceContext *pDC)
Performs inital preparation steps necessary for successful command execution.
virtual void | PrepareOverride (CXTPChartDeviceContext *pDC)
Derived implementation must override this method for implementing implementation specific preparation behavior.
void | SetEnabled (BOOL bEnabled=TRUE)
Enables/disable the command.
CXTPChartDeviceContext * | GetCurrentDC () const
Obtains device context pointer for which the command is currenly being prepared or executed.
void | BindView (CXTPChartElementView *pView)
Binds a view to the command object.
CXTPChartElementView * | GetBoundView () const
Obtains a bound view pointer or NULL if no view is bound.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.
- Public Member Functions inherited from CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents >
void | Subscribe (CXTPChartDeviceCommandEvents *pObserver, CXTPSubscriptionList< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > *pSubcriptionList=NULL)
Subscribes a unique observer for events.
void | Unsubscribe (CXTPChartDeviceCommandEvents *pObserver)
Unsubscribes an observer from events.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *))
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *))
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.

Protected Attributes

CXTPChart3dFunnelSeriesLabelsView * | m_pSeriesLabelsView
View pointer.
- Protected Attributes inherited from CXTPChartDeviceCommand
CArray< CXTPChartDeviceCommand *, CXTPChartDeviceCommand * > | m_arrChildren
< The array of child device commands.

Additional Inherited Members

- Protected Member Functions inherited from CXTPChart3dDeviceCommand
CXTPChart3dDeviceCommand (XTPChart3dAntialiasingPolicy nAntialiasingPolicy)
Constructs a CXTPChart3dDeviceCommand object.
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.
- Protected Member Functions inherited from CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents >
CXTPObservable ()
Constructs an observable object.
~CXTPObservable ()
Handles observable object destruction.

Detailed Description

Represents device command for all funnel series labels view.

Constructor & Destructor Documentation

◆ CXTPChart3dFunnelSeriesLabelsViewDeviceCommand()

CXTPChart3dFunnelSeriesLabelsViewDeviceCommand ( CXTPChart3dFunnelSeriesLabelsView * pSeriesLabelsView )

Constructs a command object instance.

Parameters
pSeriesLabelsView View pointer.

Member Function Documentation

◆ ExecuteOverride()

virtual void ExecuteOverride ( CXTPChartDeviceContext * pDC )
virtual

Override this function to write the drawing code for specific objects.

Parameters
pDC A pointer to the chart device context.

Reimplemented from CXTPChartDeviceCommand.

The documentation for this class was generated from the following file:
  • XTPChart3dFunnelSeriesLabelsViewDeviceCommand.h


Toolkit Pro: CXTPChart3dFunnelSeriesLabelView Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPChart3dFunnelSeriesLabelView Class Reference

Represents a series label view object. More...

Inheritance diagram for CXTPChart3dFunnelSeriesLabelView:
[legend]

Public Member Functions

CXTPChart3dFunnelSeriesLabelView (CXTPChartSeriesLabel *pLabel, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView)
Constructs a view object.
~CXTPChart3dFunnelSeriesLabelView ()
Handles view object destruction.
virtual CXTPChartDeviceCommand * | CreateTranspositionDeviceCommand (CXTPChartDeviceContext *pDC)
Creates a label transposition device command object.
virtual CXTPChartDeviceCommand * | CreateDeviceCommand (CXTPChartDeviceContext *pDC)
Creates a label drawing device command object.
virtual CXTPChartDeviceCommand * | CreateConnectorDeviceCommand (CXTPChartDeviceContext *pDC)
Creates a label connector drawing device command object.
const CXTPPoint3d * | GetConnectorStartPoint () const
Obtains a previously set connector start point.
void | SetConnectorStartPoint (const CXTPPoint3d &point)
Sets the connector start point.
const CXTPPoint3d * | GetConnectorBendPoint () const
Obtains a previously set connector bend point.
void | SetConnectorBendPoint (const CXTPPoint3d &point)
Sets the connector bend point.
const CXTPPoint3d * | GetConnectorEndPoint () const
Obtains a previously set connector end point.
void | SetConnectorEndPoint (const CXTPPoint3d &point)
Sets the connector end point.
const CPoint * | GetLabelAnchorPoint () const
Obtains a previously set label anchor point.
void | SetLabelAnchorPoint (CPoint ptAnchor)
Sets the label anchor point.
const CPoint * | GetLabelAnchorOrigin () const
Obtains a previously set label anchor origin point.
void | SetLabelAnchorOrigin (CPoint ptAnchorOrigin)
Sets the label anchor origin point.
void | SetLeftDirected ()
Makes the label left directed.
BOOL | IsLeftDirected () const
Determies if the label is left directed.
void | SetRightDirected ()
Makes the label right directed.
BOOL | IsRightDirected () const
Determies if the label is right directed.
BOOL | IsConnectorVisible () const
Determines if the connector is visible.
void | SetConnectorVisible (BOOL bVisible=TRUE)
Sets connector visibility.
- Public Member Functions inherited from CXTPChartFunnelSeriesLabelViewBase
XTPChartFunnelLabelPosition | GetPosition () const
Obtains label position.

Protected Attributes

CXTPPoint3d * | m_ptStart
Connector start point or NULL if not set.
CXTPPoint3d * | m_ptBend
Connector bend point or NULL if not set.
CXTPPoint3d * | m_ptEnd
Connector end point or NULL if not set.
CPoint | m_ptLabelAnchor
Label anchor point.
CPoint | m_ptLabelAnchorOrigin
Label anchor point origin.
CXTPChart3dFunnelSeriesPointView * | m_p3dPointView
Point view.
BOOL | m_bLeftDirected
TRUE if label is to be left directed.
BOOL | m_bConnectorVisible
TRUE if connector is visible.

Additional Inherited Members

- Protected Member Functions inherited from CXTPChartFunnelSeriesLabelViewBase
CXTPChartFunnelSeriesLabelViewBase (CXTPChartSeriesLabel *pLabel, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView)
Constructs a CXTPChartFunnelSeriesLabelViewBase object.

Detailed Description

Represents a series label view object.

Constructor & Destructor Documentation

◆ CXTPChart3dFunnelSeriesLabelView()

CXTPChart3dFunnelSeriesLabelView | ( | CXTPChartSeriesLabel * | pLabel,
 |  | CXTPChartSeriesPointView * | pPointView,
 |  | CXTPChartElementView * | pParentView )

Constructs a view object.

Parameters
pLabel | Label model object pointer.
pPointView | Related point view object pointer.
pParentView | Parent view object pointer.

Member Function Documentation

◆ CreateConnectorDeviceCommand()

virtual CXTPChartDeviceCommand * CreateConnectorDeviceCommand ( CXTPChartDeviceContext * pDC )
virtual

Creates a label connector drawing device command object.

Parameters
pDC Target device context.
Returns
New label connector drawing device command object.

◆ CreateDeviceCommand()

virtual CXTPChartDeviceCommand * CreateDeviceCommand ( CXTPChartDeviceContext * pDC )
virtual

Creates a label drawing device command object.

Parameters
pDC Target device context.
Returns
New label drawing device command object.

Implements CXTPChartFunnelSeriesLabelViewBase.

◆ CreateTranspositionDeviceCommand()

virtual CXTPChartDeviceCommand * CreateTranspositionDeviceCommand ( CXTPChartDeviceContext * pDC )
virtual

Creates a label transposition device command object.

Parameters
pDC Target device context.
Returns
New label transposition device command object.

◆ GetConnectorBendPoint()

AFX_INLINE const CXTPPoint3d * GetConnectorBendPoint ( ) const

Obtains a previously set connector bend point.

Returns
Connector bend point or NULL if not set.
See also
SetConnectorBendPoint

◆ GetConnectorEndPoint()

AFX_INLINE const CXTPPoint3d * GetConnectorEndPoint ( ) const

Obtains a previously set connector end point.

Returns
Connector end point or NULL if not set.
See also
SetConnectorEndPoint

◆ GetConnectorStartPoint()

AFX_INLINE const CXTPPoint3d * GetConnectorStartPoint ( ) const

Obtains a previously set connector start point.

Returns
Connector start point or NULL if not set.
See also
SetConnectorStartPoint

◆ GetLabelAnchorOrigin()

const CPoint * GetLabelAnchorOrigin ( ) const

Obtains a previously set label anchor origin point.

Returns
Label anchor origin point or NULL if not set.
See also
SetLabelAnchorOrigin

◆ GetLabelAnchorPoint()

const CPoint * GetLabelAnchorPoint ( ) const

Obtains a previously set label anchor point.

Returns
Label anchor point or NULL if not set.
See also
SetLabelAnchorPoint

◆ IsConnectorVisible()

AFX_INLINE BOOL IsConnectorVisible ( ) const

Determines if the connector is visible.

Returns
TRUE if connector is visible, FALSE otherwise.
See also
SetConnectorVisible

◆ IsLeftDirected()

AFX_INLINE BOOL IsLeftDirected ( ) const

Determies if the label is left directed.

Returns
TRUE if left directed, FALSE otherwise.
See also
SetLeftDirected

◆ IsRightDirected()

AFX_INLINE BOOL IsRightDirected ( ) const

Determies if the label is right directed.

Returns
TRUE if right directed, FALSE otherwise.
See also
SetRightDirected

◆ SetConnectorBendPoint()

void SetConnectorBendPoint ( const CXTPPoint3d & point )

Sets the connector bend point.

Parameters
point New value of the connector bend point.
See also
GetConnectorBendPoint

◆ SetConnectorEndPoint()

void SetConnectorEndPoint ( const CXTPPoint3d & point )

Sets the connector end point.

Parameters
point New value of the connector end point.
See also
GetConnectorEndPoint

◆ SetConnectorStartPoint()

void SetConnectorStartPoint ( const CXTPPoint3d & point )

Sets the connector start point.

Parameters
point New value of the connector start point.
See also
GetConnectorStartPoint

◆ SetConnectorVisible()

AFX_INLINE void SetConnectorVisible ( BOOL bVisible = TRUE )

Sets connector visibility.

Parameters
bVisible TRUE to set the connector to visible, FALSE to hide the connector.
See also
SetConnectorVisible

◆ SetLabelAnchorOrigin()

AFX_INLINE void SetLabelAnchorOrigin ( CPoint ptAnchorOrigin )

Sets the label anchor origin point.

Parameters
ptAnchorOrigin New value of the label anchor origin point.
See also
GetLabelAnchorOrigin

◆ SetLabelAnchorPoint()

AFX_INLINE void SetLabelAnchorPoint ( CPoint ptAnchor )

Sets the label anchor point.

Parameters
ptAnchor New value of the label anchor point.
See also
GetLabelAnchorPoint

◆ SetLeftDirected()

AFX_INLINE void SetLeftDirected ( )

Makes the label left directed.

See also
IsLeftDirected

◆ SetRightDirected()

AFX_INLINE void SetRightDirected ( )

Makes the label right directed.

See also
IsRightDirected
The documentation for this class was generated from the following file:
  • XTPChart3dFunnelSeriesLabel.h


Toolkit Pro: CXTPChart3dFunnelSeriesPointView Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPChart3dFunnelSeriesPointView Class Reference

This class abstracts the view of a funnel series point. More...

Inheritance diagram for CXTPChart3dFunnelSeriesPointView:
[legend]

Public Member Functions

CXTPChart3dFunnelSeriesPointView (CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Constructs a CXTPChart3dFunnelSeriesPointView object.
virtual | ~CXTPChart3dFunnelSeriesPointView ()
Handles view destruction.
virtual void | CalculateLayout (int nIndex, int nCount, double dFrom, double dTo)
Use this function to calculate the layout of the funnel series point.
const CXTPPoint3d & | GetCenterShapeConnectorPoint () const
Obtains the shape center connector point.
const CXTPPoint3d & | GetOuterCenterConnectorPoint () const
Obtains the outer shape center connector point.
- Public Member Functions inherited from CXTPChartFunnelSeriesPointViewBase
CXTPChartFunnelSeriesPointViewBase (CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Constructs a CXTPChartFunnelSeriesPointView object.
CXTPChartFunnelSeriesPointViewBase (CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView, BOOL bAddToParent)
Constructs a CXTPChartFunnelSeriesPointView object.
virtual | ~CXTPChartFunnelSeriesPointViewBase ()
Destroys a CXTPChartFunnelSeriesPointView object, handle cleanup.
CXTPChartColor | GetBorderActualColor () const
Obtains border color value.
- Public Member Functions inherited from CXTPChartSeriesPointView
CXTPChartSeriesPointView (CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Constructs the view object.
CXTPChartSeriesPointView (CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView, BOOL bAddToParent)
Constructs the view object.
CXTPChartSeriesPoint * | GetPoint () const
Obtains point model object.
CXTPChartSeriesView * | GetSeriesView () const
Obtains parent series view.
CXTPChartColor | GetColor () const
Obtain view color values.
CXTPChartColor | GetColor2 () const
Obtain view color values.
double | GetInternalValue () const
Obtains point interval value.
virtual CXTPChartString | GetLegendName () const
This function returns the legend name.
virtual void | UpdateMinMaxRange (double &nMinValue, double &nMaxValue) const
Provides a default empty implementation for min/max range update request.
- Public Member Functions inherited from CXTPChartElementView
CXTPChartElementView (CXTPChartElementView *pParentView)
Constructs a CXTPChartElementView object.
CXTPChartElementView (CXTPChartElementView *pParentView, BOOL bAddToParent)
Constructs a CXTPChartElementView object.
CXTPChartElementView (CXTPChartContainer *pContainer)
Constructs a CXTPChartElementView object.
int | GetCount () const
Call this function to get the number of child views associated with this view.
CXTPChartElementView * | GetAt (int nIndex) const
Call this function to get a child view at a particular index.
CXTPChartElementView * | GetParentView () const
Call this function to get the parent view.
CXTPChartElementView * | AddChildView (CXTPChartElementView *pChildView)
Call this function to add a child view to the current view.
CXTPChartElementView ** GetChildren ()
Provides access to the collection of children elements owned by the view.
CRect | GetBounds () const
Obtains viewed object's bound rectangle.
CRect | GetBounds (BOOL bIncludingChildren) const
Obtains viewed object's bound rectangle.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.
- Public Member Functions inherited from CXTPChartLegendItemView
virtual | ~CXTPChartLegendItemView ()
Handles object destruction.

Protected Member Functions

virtual CXTPChartDeviceCommand * | CreateDeviceCommand (CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
virtual CXTPChartDeviceCommand * | CreateLegendDeviceCommand (CXTPChartDeviceContext *pDC, CRect rcBounds)
This function creates a label view drawing command object.
virtual void | OnUpdateBounds (CXTPChartDeviceCommand *pCommand, CRect rcBounds)
Notifies about updated boundaries of the command result.
virtual void | OnSetConnectorPoints (CXTPChartDeviceCommand *pCommand, CXTPPoint3d ptShapeCenter, CXTPPoint3d ptOuterCenter)
Gets called when funnel connector points are computed.
- Protected Member Functions inherited from CXTPChartFunnelSeriesPointViewBase
- Protected Member Functions inherited from CXTPChartElementView
virtual | ~CXTPChartElementView ()
Destroys a CXTPChartElementView object, handles cleanup.
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.

Additional Inherited Members

- Public Attributes inherited from CXTPChartFunnelSeriesPointViewBase
- Public Attributes inherited from CXTPChartSeriesPointView
double | m_dInternalValue
Point internal value.
- Protected Attributes inherited from CXTPChartFunnelSeriesPointViewBase
double | m_dValue
The value of the point.
- Protected Attributes inherited from CXTPChartSeriesPointView
CXTPChartSeriesPoint * | m_pPoint
Point model object pointer.
- Protected Attributes inherited from CXTPChartElementView
CArray< CXTPChartElementView *, CXTPChartElementView * > | m_arrChildren
The child view collection.
CXTPChartElementView * | m_pParentView
The parent view.
CXTPChartContainer * | m_pContainer
The parent container.
CRect | m_rcBounds
Bounding rectangle.

Detailed Description

This class abstracts the view of a funnel series point.

This class is a kind of CXTPChartSeriesPointView.

A funnel chart (or a circle graph) is a circular chart divided into sectors, illustrating percents. In a funnel chart, the arc length of each sector (and consequently its central angle and area), is proportional to the quantity it represents. Together, the sectors create a full disk.

Constructor & Destructor Documentation

◆ CXTPChart3dFunnelSeriesPointView()

CXTPChart3dFunnelSeriesPointView | ( | CXTPChartSeriesPoint * | pPoint,
 |  | CXTPChartElementView * | pParentView )

Constructs a CXTPChart3dFunnelSeriesPointView object.

Parameters
pPoint | Pointer to chart series point.
pParentView | Parent element view pointer.

Member Function Documentation

◆ CalculateLayout()

virtual void CalculateLayout | ( | int | nIndex,
 |  | int | nCount,
 |  | double | dFrom,
 |  | double | dTo )
 virtual

Use this function to calculate the layout of the funnel series point.

Parameters
nIndex | Point index.
nCount | Number of points.
dFrom | Point start value.
dTo | Value part point value end.

Reimplemented from CXTPChartFunnelSeriesPointViewBase.

◆ CreateDeviceCommand()

virtual CXTPChartDeviceCommand * CreateDeviceCommand ( CXTPChartDeviceContext * pDC )
protectedvirtual

This function creates a CXTPChartDeviceCommand object.

This object represents the rendering of the funnel series point.

Parameters
pDC Pointer to a CXTPChartDeviceContext object.
Returns
Returns a CXTPChartDeviceCommand object. This object handles the rendering of an element in the chart. Here it handles the drawing of the funnel series point.

Implements CXTPChartFunnelSeriesPointViewBase.

◆ CreateLegendDeviceCommand()

virtual CXTPChartDeviceCommand * CreateLegendDeviceCommand | ( | CXTPChartDeviceContext * | pDC,
 |  | CRect | rcBounds )
 protectedvirtual

This function creates a label view drawing command object.

Parameters
pDC | Pointer to a CXTPChartDeviceContext object.
rcBounds | The rectangular boundary of the legend.
Returns
Returns a new label view drawing command object.

Reimplemented from CXTPChartFunnelSeriesPointViewBase.

◆ GetCenterShapeConnectorPoint()

AFX_INLINE const CXTPPoint3d & GetCenterShapeConnectorPoint ( ) const

Obtains the shape center connector point.

Returns
Shape center connector point.
See also
GetOuterCenterConnectorPoint

◆ GetOuterCenterConnectorPoint()

AFX_INLINE const CXTPPoint3d & GetOuterCenterConnectorPoint ( ) const

Obtains the outer shape center connector point.

Returns
Outer shape center connector point.
See also
GetCenterShapeConnectorPoint

◆ OnSetConnectorPoints()

virtual void OnSetConnectorPoints | ( | CXTPChartDeviceCommand * | pCommand,
 |  | CXTPPoint3d | ptShapeCenter,
 |  | CXTPPoint3d | ptOuterCenter )
 protectedvirtual

Gets called when funnel connector points are computed.

Parameters
pCommand | The sender command.
ptShapeCenter | The coordinates of the physical shape center.
ptOuterCenter | The coordinates of the most outer horizontal shape center point.

Reimplemented from CXTPChart3dFunnelDeviceCommandEvents.

◆ OnUpdateBounds()

virtual void OnUpdateBounds | ( | CXTPChartDeviceCommand * | pCommand,
 |  | CRect | rcBounds )
 protectedvirtual

Notifies about updated boundaries of the command result.

Parameters
pCommand | Sender command pointer.
rcBounds | Updated bounray rectangle.

Reimplemented from CXTPChartDeviceCommandEvents.

The documentation for this class was generated from the following file:
  • XTPChart3dFunnelSeriesPointView.h


Toolkit Pro: CXTPChart3dFunnelSeriesStyle Class Reference

Public Member Functions | List of all members
CXTPChart3dFunnelSeriesStyle Class Reference

This class abstracts the basic style of a funnel series. More...

Inheritance diagram for CXTPChart3dFunnelSeriesStyle:
[legend]

Public Member Functions

CXTPChart3dFunnelSeriesStyle ()
Constructs a CXTPChart3dFunnelSeriesStyle object.
virtual CXTPChartDiagram * | CreateDiagram ()
Call this function to create the funnel diagram object.
virtual CXTPChartSeriesView * | CreateView (CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Call this function to create the view of the funnel series.
virtual BOOL | IsStyleDiagram (CXTPChartDiagram *pDiagram) const
Call this function to check whether the chart diagram object passed is a kind of CXTPChart3dFunnelDiagramBase/CXTPChart3dFunnelDiagramBase.
virtual void | DoPropExchange (CXTPPropExchange *pPX)
Call this member function to Store/Load an event using the specified data object.
int | GetBaseEdgeCount () const
Gets the number of base edges for the funnel.
void | SetBaseEdgeCount (int nEdgeCount)
Sets the number of base edges for the funnel.
- Public Member Functions inherited from CXTPChartFunnelSeriesStyleBase
CXTPChartFunnelSeriesStyleBase ()
Constructs a CXTPChartFunnelSeriesStyleBase object.
virtual | ~CXTPChartFunnelSeriesStyleBase ()
Destroys a CXTPChartFunnelSeriesStyleBase object, handle cleanup.
int | GetPointDistance () const
Gets point distance value.
void | SetPointDistance (int nPointDistance)
Sets point distance value.
double | GetHeightToWidthRatio () const
Gets height to width ratio of the funnel.
void | SetHeightToWidthRatio (double dRatio)
Sets height to width ratio of the funnel.
void | SetEqualHeight (BOOL bEqualHeight)
Sets equal height flag.
BOOL | IsEqualHeight () const
Gets equal height flag.
CXTPChartFillStyle * | GetFillStyle () const
Call this function to get the background fill style.
CXTPChartBorder * | GetBorder () const
Call this function to get the border object.
void | DoPropExchange (CXTPPropExchange *pPX)
Reads or writes this object from or to an archive.
- Public Member Functions inherited from CXTPChartSeriesStyle
CXTPChartSeriesStyle ()
Constructs a CXTPChartSeriesStyle object.
virtual | ~CXTPChartSeriesStyle ()
Destroys a CXTPChartSeriesStyle object, handles cleanup.
virtual CXTPChartSeriesLabel * | GetLabel () const
Call this method to gets the series label object.
virtual CXTPChartSeriesLabel * | SetLabel (CXTPChartSeriesLabel *pLabel)
Call this method to sets the series label object.
virtual CXTPChartErrorBar * | GetErrorBar () const
Call this method to gets the error bar object.
virtual CXTPChartErrorBar * | SetErrorBar (CXTPChartErrorBar *pErrorBar)
Call this method to sets the error bar object.
virtual CXTPChartColor | GetColor () const
Call this method to get the color of the series.
virtual void | SetColor (CXTPChartColor clr)
Call this method to set the color of the series.
virtual void | SetColorEach (BOOL bColorEach)
Call this method to set individual color for each point of the series.
virtual BOOL | IsColorEach () const
This method is called to check if individual color is used for each point of the series.
virtual CXTPChart3dRotation | Get3dRotation () const
Obtains rotation parameters for 3D chart.
virtual void | Set3dRotation (const CXTPChart3dRotation &rotation)
Sets rotation parameters for 3D chart.
virtual void | Set3dRotation (double dYaw, double dPitch, double dRoll)
Sets rotation parameters for 3D chart.
virtual BOOL | Is3dEdgeSmoothingEnabled () const
Enables/disables 3D edge smoothing.
virtual void | Enable3dEdgeSmoothing (BOOL bEnable=TRUE)
Enables/disables 3D edge smoothing.
virtual int | GetTransparency () const
Call this function to gets the transparency of the chart if it is supported by the chart type.
virtual void | SetTransparency (int nTransparency)
Call this function to sets the transparency of the chart if it is supported by the chart type.
virtual void | CorrectAxisSideMargins (CXTPChartAxis *pAxis, double nMinValue, double nMaxValue, double &nCorrection)
Provides default implementation for axis side margins correction.
virtual CXTPChartSeriesStyleAppearance * | GetStyleAppearance () const
Obtains associated style appearance pointer.
virtual void | ApplyTo (CXTPChartDeviceCommand *pCommand)
Applies the style to the command provided in case the command needs style specific details for correct drawing.
virtual int | GetSeriesPointValueIndex () const
Obtains the index of a point element for which an internal value can be otained.
- Public Member Functions inherited from CXTPChartElement
CXTPChartElement ()
Constructs a CXTPChartElement object.
virtual | ~CXTPChartElement ()
Destroys a CXTPChartElement object, handles cleanup.
virtual void | Release ()
Call this function to decrease the usage count of the object.
CXTPChartElement * | GetOwner () const
Call this function to get the owner element.
virtual void | OnChartChanged (XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic properties of the chart.
CXTPChartContent * | GetContent () const
Call this virtual function to get the chart content object.
CXTPChartAppearance * | GetAppearance () const
Call this function to get the the appearance of the chart.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Additional Inherited Members

- Public Attributes inherited from CXTPChartElement
- Protected Member Functions inherited from CXTPChartFunnelSeriesStyleBase
BOOL | IsStyleDiagram (CXTPChartDiagram *pDiagram) const
This method is called to ask style if series can be inserted in existing diagram.
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.
- Protected Attributes inherited from CXTPChartSeriesStyle
CXTPChartSeriesLabel * | m_pLabel
Label object.
CXTPChartErrorBar * | m_pErrorBar
Error bar object.
CXTPChartColor | m_clrColor
Custom color of series.
BOOL | m_bColorEach
TRUE to color each point.
int | m_nTransparency
The transparency value in the range 0..255.
CXTPChart3dRotation | m_Rotation3d
3D rotation
BOOL | m_bSmooth3dEdges
3D edge smoothing
- Protected Attributes inherited from CXTPChartElement

Detailed Description

This class abstracts the basic style of a funnel series.

This class is a kind of CXTPChartSeriesStyle.

A funnel chart (or a circle graph) is a circular chart divided into sectors, illustrating percents. In a funnel chart, the arc length of each sector (and consequently its central angle and area), is proportional to the quantity it represents. Together, the sectors create a full disk.

Member Function Documentation

◆ CreateDiagram()

virtual CXTPChartDiagram * CreateDiagram ( )
virtual

Call this function to create the funnel diagram object.

Returns
A pointer to a CXTPChartDiagram object which points to the newly created CXTPChart3dFunnelDiagramBase object.

Implements CXTPChartFunnelSeriesStyleBase.

◆ CreateView()

virtual CXTPChartSeriesView * CreateView | ( | CXTPChartSeries * | pSeries,
 |  | CXTPChartDiagramView * | pDiagramView )
 virtual

Call this function to create the view of the funnel series.

Parameters
pSeries | A pointer to the chart series object.
pDiagramView | A pointer to the diagram view object.
Returns
A pointer to the newly created 3D series view object.

Implements CXTPChartFunnelSeriesStyleBase.

◆ DoPropExchange()

virtual void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Call this member function to Store/Load an event using the specified data object.

Parameters
pPX Source or destination CXTPPropExchange data object reference.

This member function is used to store event data to or load event data from storage.

Reimplemented from CXTPChartSeriesStyle.

◆ GetBaseEdgeCount()

AFX_INLINE int GetBaseEdgeCount ( ) const

Gets the number of base edges for the funnel.

The number of edges must not be equal to 1 or 2. If 0 is used as edge count, then a round funnel (with no edges) will be drawn.

Returns
Current number of base edges.

◆ IsStyleDiagram()

virtual BOOL IsStyleDiagram ( CXTPChartDiagram * pDiagram ) const
virtual

Call this function to check whether the chart diagram object passed is a kind of CXTPChart3dFunnelDiagramBase/CXTPChart3dFunnelDiagramBase.

Parameters
pDiagram A pointer to a chart diagram, whose type is to be identified.
Returns
TRUE if the chart diagram is a funnel diagram, FALSE otherwise.

Reimplemented from CXTPChartSeriesStyle.

◆ SetBaseEdgeCount()

void SetBaseEdgeCount ( int nEdgeCount )

Sets the number of base edges for the funnel.

The number of edges must not be equal to 1 or 2. If 0 is used as edge count, then a round funnel (with no edges) will be drawn.

Parameters
nEdgeCount A new number of base edges.
The documentation for this class was generated from the following file:
  • XTPChart3dFunnelSeriesStyle.h


Toolkit Pro: CXTPChart3dFunnelSeriesView Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPChart3dFunnelSeriesView Class Reference

This class abstracts the view of a funnel series. More...

Inheritance diagram for CXTPChart3dFunnelSeriesView:
[legend]

Public Member Functions

CXTPChart3dFunnelSeriesView (CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Constructs a CXTPChart3dFunnelSeriesView object.
virtual void | CalculatePointLayout (CXTPChartDeviceContext *pDC, CRect rcBounds)
Call this function to calculate the funnel series point layout.
- Public Member Functions inherited from CXTPChartFunnelSeriesViewBase
CXTPChartFunnelSeriesViewBase (CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Constructs a CXTPChartFunnelSeriesViewBase object.
virtual | ~CXTPChartFunnelSeriesViewBase ()
Destroys a CXTPChartFunnelSeriesViewBase object, handle cleanup.
void | CalculateLabelLayout (CXTPChartDeviceContext *pDC)
Call this function to calculate the funnel series label layout.
virtual CXTPChartDiagramDomain * | CreateDiagramDomain (CXTPChartDeviceContext *pDC, CRect rcBounds)
Call this function to create the pie diagram domain object associated with this object.
virtual CXTPChartRectF | GetInnerBounds () const
Call this function to get the inner bounds of the diagram.
CXTPChartDiagramDomain * | GetDomain () const
Use this function to get the pie diagram domain object associated with this object.
int | GetMaxLabelWidth () const
Obtains maximum allowed label width.

Protected Member Functions

virtual CXTPChartSeriesPointView * | CreateSeriesPointView (CXTPChartDeviceContext *pDC, CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Use this function to create the funnel series point view object.
virtual CXTPChartDeviceCommand * | CreateDeviceCommand (CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
virtual CXTPChartDeviceCommand * | CreateLegendDeviceCommand (CXTPChartDeviceContext *pDC, CRect rcBounds)
Creates a legend drawing device command.
virtual CXTPChartDeviceCommand * | CreateLegendDeviceCommand (CXTPChartDeviceContext *pDC, CRect rcBounds, CXTPChartColor color1, CXTPChartColor color2, CXTPChartColor clrBorder)
These functions create a label view drawing command object.
- Protected Member Functions inherited from CXTPChartFunnelSeriesViewBase

Additional Inherited Members

- Protected Attributes inherited from CXTPChartFunnelSeriesViewBase
CXTPChartDiagramDomain * m_pDomain
Pointer to the diagram domain.

Detailed Description

This class abstracts the view of a funnel series.

This class is a kind of CXTPChartSeriesView.

A funnel chart (or a circle graph) is a circular chart divided into sectors, illustrating percents. In a funnel chart, the arc length of each sector (and consequently its central angle and area), is proportional to the quantity it represents. Together, the sectors create a full disk.

Constructor & Destructor Documentation

◆ CXTPChart3dFunnelSeriesView()

CXTPChart3dFunnelSeriesView | ( | CXTPChartSeries * | pSeries,
 |  | CXTPChartDiagramView * | pDiagramView )

Constructs a CXTPChart3dFunnelSeriesView object.

Parameters
pSeries | Pointer to the funnel series object.
pDiagramView | Pointer to the funnel diagram view.

Member Function Documentation

◆ CalculatePointLayout()

virtual void CalculatePointLayout | ( | CXTPChartDeviceContext * | pDC,
 |  | CRect | rcBounds )
 virtual

Call this function to calculate the funnel series point layout.

Parameters
pDC | Pointer to the chart device context.
rcBounds | The rectangular boundary.

Reimplemented from CXTPChartFunnelSeriesViewBase.

◆ CreateDeviceCommand()

virtual CXTPChartDeviceCommand * CreateDeviceCommand ( CXTPChartDeviceContext * pDC )
protectedvirtual

This function creates a CXTPChartDeviceCommand object.

This object represents the rendering of the funnel series.

Parameters
pDC Pointer to a CXTPChartDeviceContext object.
Returns
Returns a CXTPChartDeviceCommand object. This object handles the rendering of an element in the chart. Here it handles the drawing of the funnel series.

Implements CXTPChartFunnelSeriesViewBase.

◆ CreateLegendDeviceCommand() [1/2]

virtual CXTPChartDeviceCommand * CreateLegendDeviceCommand | ( | CXTPChartDeviceContext * | pDC,
 |  | CRect | rcBounds )
 protectedvirtual

Creates a legend drawing device command.

Parameters
pDC | Target device context.
rcBounds | Bounding rectangle.
Returns
A newly created command object pointer or NULL if not supported.

Implements CXTPChartFunnelSeriesViewBase.

◆ CreateLegendDeviceCommand() [2/2]

virtual CXTPChartDeviceCommand * CreateLegendDeviceCommand | ( | CXTPChartDeviceContext * | pDC,
 |  | CRect | rcBounds,
 |  | CXTPChartColor | color1,
 |  | CXTPChartColor | color2,
 |  | CXTPChartColor | clrBorder )
 protectedvirtual

These functions create a label view drawing command object.

Parameters
pDC | Pointer to a CXTPChartDeviceContext object.
rcBounds | The rectangular boundary of the legend.
color1 | 1-st gradient fill color.
color2 | 2-nd gradient fill color.
clrBorder | Border color.
Returns
Returns a new label view drawing command object.

Implements CXTPChartFunnelSeriesViewBase.

◆ CreateSeriesPointView()

virtual CXTPChartSeriesPointView * CreateSeriesPointView | ( | CXTPChartDeviceContext * | pDC,
 |  | CXTPChartSeriesPoint * | pPoint,
 |  | CXTPChartElementView * | pParentView )
 protectedvirtual

Use this function to create the funnel series point view object.

Parameters
pDC | Pointer to the chart device context.
pPoint | Pointer to the chart series point.
pParentView | Parent element view pointer.
Returns
A pointer to the chart series point view.

Implements CXTPChartFunnelSeriesViewBase.

The documentation for this class was generated from the following file:
  • XTPChart3dFunnelSeriesView.h


Toolkit Pro: CXTPChart3dLineDeviceCommand Class Reference

Protected Member Functions | Protected Attributes | List of all members
CXTPChart3dLineDeviceCommand Class Reference

Provides an interface for 3D line drawing device command. More...

Inheritance diagram for CXTPChart3dLineDeviceCommand:
[legend]

Protected Member Functions

CXTPChart3dLineDeviceCommand (const CXTPPoint3d &p1, const CXTPPoint3d &p2, const CXTPChartColor &color, int thickness)
Constructs a CXTPChart3dLineDeviceCommand object.
virtual CXTPChartElement * | HitTest (CPoint point, CXTPChartElement *pParent) const
Performs recursive hit testing of the element at the specified point.
virtual void | AfterExecute (CXTPChartDeviceContext *pDC)
This method gets called after a command is executed which allows for the customization of command behavior.
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.
- Protected Member Functions inherited from CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents >
CXTPObservable ()
Constructs an observable object.
~CXTPObservable ()
Handles observable object destruction.

Protected Attributes

CXTPPoint3d | m_p1
The first point.
CXTPPoint3d | m_p2
The second point.
CXTPChartColor | m_color
The line color.
int | m_nThickness
The thickness of the line.
- Protected Attributes inherited from CXTPChartDeviceCommand
CArray< CXTPChartDeviceCommand *, CXTPChartDeviceCommand * > | m_arrChildren
< The array of child device commands.

Additional Inherited Members

- Public Member Functions inherited from CXTPChartDeviceCommand
CXTPChartDeviceCommand ()
Constructs a CXTPChartDeviceCommand object.
virtual | ~CXTPChartDeviceCommand ()
Destroys a CXTPChartDeviceCommand object, handles cleanup.
BOOL | IsCommitted () const
Determines if the execution of the command has been committed.
void | Commit ()
Commits the execution of the command.
int | GetChildCommandCount () const
Obtains the number of immediate children commands.
CXTPChartDeviceCommand * | GetChildCommand (int nIndex) const
Obtains immediate child command point by index.
CXTPChartDeviceCommand * | AddChildCommand (CXTPChartDeviceCommand *pCommand)
Call this function to add a child device command.
virtual void | Execute (CXTPChartDeviceContext *pDC)
Call this function to execute the drawing.
virtual void | BeforeExecute (CXTPChartDeviceContext *pDC)
This method gets called before a command is executed which allows for the customization of command behavior.
virtual void | ExecuteOverride (CXTPChartDeviceContext *pDC)
Override this function to write the drawing code for specific objects.
UINT | GetPassNumber () const
Get the number of executions made by the command.
virtual void | ApplySeriesStyle (CXTPChartSeriesStyle *pStyle)
Applies series style to the current element.
virtual void | Prepare (CXTPChartDeviceContext *pDC)
Performs inital preparation steps necessary for successful command execution.
virtual void | PrepareOverride (CXTPChartDeviceContext *pDC)
Derived implementation must override this method for implementing implementation specific preparation behavior.
virtual BOOL | IsEnabled () const
Determines if the command is currently enabled.
void | SetEnabled (BOOL bEnabled=TRUE)
Enables/disable the command.
CXTPChartDeviceContext * | GetCurrentDC () const
Obtains device context pointer for which the command is currenly being prepared or executed.
void | BindView (CXTPChartElementView *pView)
Binds a view to the command object.
CXTPChartElementView * | GetBoundView () const
Obtains a bound view pointer or NULL if no view is bound.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.
- Public Member Functions inherited from CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents >
void | Subscribe (CXTPChartDeviceCommandEvents *pObserver, CXTPSubscriptionList< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > *pSubcriptionList=NULL)
Subscribes a unique observer for events.
void | Unsubscribe (CXTPChartDeviceCommandEvents *pObserver)
Unsubscribes an observer from events.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *))
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *))
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.

Detailed Description

Provides an interface for 3D line drawing device command.

Constructor & Destructor Documentation

◆ CXTPChart3dLineDeviceCommand()

CXTPChart3dLineDeviceCommand | ( | const CXTPPoint3d & | p1,
 |  | const CXTPPoint3d & | p2,
 |  | const CXTPChartColor & | color,
 |  | int | thickness )
 protected

Constructs a CXTPChart3dLineDeviceCommand object.

Parameters
p1 | Start point.
p2 | End point.
color | Line color.
thickness | Line thickness in pixels.

Member Function Documentation

◆ AfterExecute()

virtual void AfterExecute ( CXTPChartDeviceContext * pDC )
protectedvirtual

This method gets called after a command is executed which allows for the customization of command behavior.

Parameters
pDC A pointer to the chart device context.

Reimplemented from CXTPChartDeviceCommand.

◆ HitTest()

virtual CXTPChartElement * HitTest | ( | CPoint | point,
 |  | CXTPChartElement * | pParent ) const
 protectedvirtual

Performs recursive hit testing of the element at the specified point.

Parameters
point | Point in which an element is to be found.
pParent | Parent element pointer.
Returns
A pointer to the element found at the specified point or NULL if no element is found.

Reimplemented from CXTPChartDeviceCommand.

The documentation for this class was generated from the following file:
  • XTPChartLineDeviceCommand.h


Toolkit Pro: CXTPChart3dPie Class Reference

Public Member Functions | List of all members
CXTPChart3dPie Class Reference

This class abstracts a pie chart. More...

Inheritance diagram for CXTPChart3dPie:
[legend]

Public Member Functions

CXTPChart3dPie (double dStartAngle, double dFinishAngle, const CXTPChartEllipse &ellipse, int nDepthPercent, int nHolePercent, BOOL bStartGap=FALSE, BOOL bEndGap=FALSE)
Constructs a CXTPChart3dPie object.
virtual CXTPChartDeviceCommand * | CreatePieDeviceCommand (const CXTPChartColor &color, const CXTPChartColor &color2, const CXTPChartPointF &basePoint)
This function creates a CXTPChartDeviceCommand object.
virtual CXTPChartDeviceCommand * | CreateBoundedPieDeviceCommand (const CXTPChartColor &color, int nThickness, const CXTPChartPointF &basePoint)
This function creates a CXTPChartDeviceCommand object.
- Public Member Functions inherited from CXTPChartPieBase
virtual | ~CXTPChartPieBase ()
Destroys a CXTPChartPieBase object, handles cleanup and deallocation.
CXTPPoint3d | CalculateCenter (const CXTPChartPointF &basePoint) const
Call this function to calculate the ceter of the pie.
double | GetHalfAngle () const
Call this function to get the half angle of the pie slice.
double | GetStartAngle () const
Call this function to get the start angle of the pie slice.
CXTPChartPointF | GetFinishPoint () const
Call this function to get the finish/start point of the pie slice.
CXTPChartPointF | GetStartPoint () const
Call this function to get the finish/start point of the pie slice.
CXTPChartPointF | GetCenterPoint () const
Call this function to get the center point of the pie slice.
CXTPChartRectF | GetBounds () const
Call this function to get the bounding rectangle of the pie chart.
int | GetHolePercent () const
Call this function to get the hole percentage of the pie chart.

Additional Inherited Members

- Protected Member Functions inherited from CXTPChartPieBase
CXTPChartPieBase (double dStartAngle, double dFinishAngle, const CXTPChartEllipse &ellipse, int nDepthPercent, int nHolePercent)
Constructs a CXTPChartPieBase object.
void | UpdateBounds ()
Call this function to update the bounds of the pie when there is a change in the start angle and/or sweep angle.
- Protected Attributes inherited from CXTPChartPieBase
CXTPChartEllipse | m_ellipse
The ellipse associated with the pie chart.
double | m_dStartAngle
The start angle of the slice.
double | m_dSweepAngle
The sweep angle of the slice.
double | m_depth
The depth of the 3D pie.
int | m_nHolePercent
The hole percentage.
CXTPChartRectF | m_anchorBounds
The anchor bounds.

Detailed Description

This class abstracts a pie chart.

Constructor & Destructor Documentation

◆ CXTPChart3dPie()

CXTPChart3dPie | ( | double | dStartAngle,
 |  | double | dFinishAngle,
 |  | const CXTPChartEllipse & | ellipse,
 |  | int | nDepthPercent,
 |  | int | nHolePercent,
 |  | BOOL | bStartGap = FALSE,
 |  | BOOL | bEndGap = FALSE )

Constructs a CXTPChart3dPie object.

Parameters
dStartAngle | The start angle of the pie.
dFinishAngle | The finish angle of the pie.
ellipse | The ellipse associated with the pie.
nDepthPercent | The depth percentage, in case of 3D chart.
nHolePercent | The hole percentage.
bStartGap | TRUE if the point starts with a gap between points.
bEndGap | TRUE if the point ends with a gap between points.

Member Function Documentation

◆ CreateBoundedPieDeviceCommand()

virtual CXTPChartDeviceCommand * CreateBoundedPieDeviceCommand | ( | const CXTPChartColor & | color,
 |  | int | nThickness,
 |  | const CXTPChartPointF & | basePoint )
 virtual

This function creates a CXTPChartDeviceCommand object.

This object represents the rendering of the pie.

Parameters
color | The first color used for gradient pie.
basePoint | Reference to a CXTPChartPointF object.
nThickness | Thickness.
Returns
Returns a CXTPChartDeviceCommand object. This object handles the rendering of an element in the chart. Here it handles the drawing of the pie.

Implements CXTPChartPieBase.

◆ CreatePieDeviceCommand()

virtual CXTPChartDeviceCommand * CreatePieDeviceCommand | ( | const CXTPChartColor & | color,
 |  | const CXTPChartColor & | color2,
 |  | const CXTPChartPointF & | basePoint )
 virtual

This function creates a CXTPChartDeviceCommand object.

This object represents the rendering of the pie.

Parameters
color | The first color used for gradient pie.
color2 | The second color used for gradient pie.
basePoint | Reference to a CXTPChartPointF object.
Returns
Returns a CXTPChartDeviceCommand object. This object handles the rendering of an element in the chart. Here it handles the drawing of the pie.

Implements CXTPChartPieBase.

The documentation for this class was generated from the following file:
  • XTPChart3dPie.h


Toolkit Pro: CXTPChart3dPieDeviceCommand Class Reference

Protected Member Functions | List of all members
CXTPChart3dPieDeviceCommand Class Reference

Base class implementation for 3D pie chart device command. More...

Inheritance diagram for CXTPChart3dPieDeviceCommand:
[legend]

Protected Member Functions

CXTPChart3dPieDeviceCommand (XTPChart3dAntialiasingPolicy nAntialiasingPolicy, const CXTPPoint3d &ptCenter, double dMajorSemiAxis, double dMinorSemiAxis, double dStartAngle, double dSweepAngle, double dDepth, double nHolePercent)
Constructs a CXTPChartPieDeviceCommand object.
- Protected Member Functions inherited from CXTPChart3dDeviceCommand
CXTPChart3dDeviceCommand (XTPChart3dAntialiasingPolicy nAntialiasingPolicy)
Constructs a CXTPChart3dDeviceCommand object.
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.
- Protected Member Functions inherited from CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents >
CXTPObservable ()
Constructs an observable object.
~CXTPObservable ()
Handles observable object destruction.
- Protected Member Functions inherited from CXTPChartPieDeviceCommandImpl
virtual ~CXTPChartPieDeviceCommandImpl ()
Handles object destruction.

Additional Inherited Members

- Public Member Functions inherited from CXTPChart3dDeviceCommand
virtual BOOL | IsEnabled () const
Determines if the command is currently enabled.
- Public Member Functions inherited from CXTPChartDeviceCommand
CXTPChartDeviceCommand ()
Constructs a CXTPChartDeviceCommand object.
virtual | ~CXTPChartDeviceCommand ()
Destroys a CXTPChartDeviceCommand object, handles cleanup.
BOOL | IsCommitted () const
Determines if the execution of the command has been committed.
void | Commit ()
Commits the execution of the command.
int | GetChildCommandCount () const
Obtains the number of immediate children commands.
CXTPChartDeviceCommand * | GetChildCommand (int nIndex) const
Obtains immediate child command point by index.
CXTPChartDeviceCommand * | AddChildCommand (CXTPChartDeviceCommand *pCommand)
Call this function to add a child device command.
virtual void | Execute (CXTPChartDeviceContext *pDC)
Call this function to execute the drawing.
virtual void | BeforeExecute (CXTPChartDeviceContext *pDC)
This method gets called before a command is executed which allows for the customization of command behavior.
virtual void | AfterExecute (CXTPChartDeviceContext *pDC)
This method gets called after a command is executed which allows for the customization of command behavior.
virtual void | ExecuteOverride (CXTPChartDeviceContext *pDC)
Override this function to write the drawing code for specific objects.
UINT | GetPassNumber () const
Get the number of executions made by the command.
virtual CXTPChartElement * | HitTest (CPoint point, CXTPChartElement *pParent) const
Performs recursive hit testing of the element at the specified point.
virtual void | ApplySeriesStyle (CXTPChartSeriesStyle *pStyle)
Applies series style to the current element.
virtual void | Prepare (CXTPChartDeviceContext *pDC)
Performs inital preparation steps necessary for successful command execution.
virtual void | PrepareOverride (CXTPChartDeviceContext *pDC)
Derived implementation must override this method for implementing implementation specific preparation behavior.
void | SetEnabled (BOOL bEnabled=TRUE)
Enables/disable the command.
CXTPChartDeviceContext * | GetCurrentDC () const
Obtains device context pointer for which the command is currenly being prepared or executed.
void | BindView (CXTPChartElementView *pView)
Binds a view to the command object.
CXTPChartElementView * | GetBoundView () const
Obtains a bound view pointer or NULL if no view is bound.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.
- Public Member Functions inherited from CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents >
void | Subscribe (CXTPChartDeviceCommandEvents *pObserver, CXTPSubscriptionList< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > *pSubcriptionList=NULL)
Subscribes a unique observer for events.
void | Unsubscribe (CXTPChartDeviceCommandEvents *pObserver)
Unsubscribes an observer from events.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *))
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *))
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
- Protected Attributes inherited from CXTPChartDeviceCommand
CArray< CXTPChartDeviceCommand *, CXTPChartDeviceCommand * > | m_arrChildren
< The array of child device commands.
- Protected Attributes inherited from CXTPChartPieDeviceCommandImpl
CXTPPoint3d | m_ptCenter
The center point of the pie.
double | m_dMajorSemiAxis
The major semi axis of the ellipse.
double | m_dMinorSemiAxis
The minor semi axis of the ellipse.
double | m_dStartAngle
The start angle of the pie.
double | m_dSweepAngle
The sweep angle of the pie.
double | m_dDepth
The depth of the pie or torus.
double | m_dHolePercent
Determines the size of the hole when drawing a doughnut.
double | m_dInnerMajorSemiAxis
The inner size of the major semi axis of the ellipse.
double | m_dInnerMinorSemiAxis
The inner size of the minor semi axis of the ellipse.
double | m_dFacetSize
Facet size.
double | m_dRadius
Pie radius.
double | m_dCorrectedDepth
Pie corrected depth.
double | m_dInnerRadius
Pie inner radius.
BOOL | m_bDoughnut
TRUE indicates doughnut style.

Detailed Description

Base class implementation for 3D pie chart device command.

Constructor & Destructor Documentation

◆ CXTPChart3dPieDeviceCommand()

CXTPChart3dPieDeviceCommand | ( | XTPChart3dAntialiasingPolicy | nAntialiasingPolicy,
 |  | const CXTPPoint3d & | ptCenter,
 |  | double | dMajorSemiAxis,
 |  | double | dMinorSemiAxis,
 |  | double | dStartAngle,
 |  | double | dSweepAngle,
 |  | double | dDepth,
 |  | double | nHolePercent )
 protected

Constructs a CXTPChartPieDeviceCommand object.

Parameters
nAntialiasingPolicy | Anti-aliasing policy identifier that defines how command behavesdepending on device context rendering states in regards of anti-aliasing.
ptCenter | The center point of the pie.
dMajorSemiAxis | The major semi axis of the ellipse.
dMinorSemiAxis | The minor semi axis of the ellipse.
dStartAngle | The start angle of the pie.
dSweepAngle | The sweep angle of the pie.
dDepth | The depth of the pie or torus.
nHolePercent | Determines the size of the hole when drawing a doughnut.
The documentation for this class was generated from the following file:
  • XTPChartPieDeviceCommand.h


Toolkit Pro: CXTPChart3dPieDeviceCommandEvents Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPChart3dPieDeviceCommandEvents Class Reference

Defines interface for 3D chart pie device command event sink. More...

Inheritance diagram for CXTPChart3dPieDeviceCommandEvents:
[legend]

Public Member Functions

virtual void | OnSetConnectorPoints (CXTPChartDeviceCommand *pCommand, CXTPPoint3d ptShapeCenter, CXTPPoint3d ptOuterCenter)
Gets called when pie connector points are computed.
- Public Member Functions inherited from CXTPChartDeviceCommandEvents
virtual void | OnBeforeExecute (CXTPChartDeviceCommand *pCommand, CXTPChartDeviceContext *pDC)
Notifies that a command has entered the BeforeExecute step.
virtual void | OnAfterExecute (CXTPChartDeviceCommand *pCommand, CXTPChartDeviceContext *pDC)
Notifies that a command has entered the AfterExecute step.
virtual void | OnUpdateBounds (CXTPChartDeviceCommand *pCommand, CRect rcBounds)
Notifies about updated boundaries for the command result.
void | OnUnsubscribe (CXTPChartDeviceCommand *pCommand)
Invoked when an event sink is to be unsubscribed from command events.

Protected Member Functions

CXTPChart3dPieDeviceCommandEvents ()
Constructs a CXTPChart3dPieDeviceCommandEvents object.
- Protected Member Functions inherited from CXTPChartDeviceCommandEvents
CXTPChartDeviceCommandEvents ()
Constructs an event sink.

Detailed Description

Defines interface for 3D chart pie device command event sink.

Member Function Documentation

◆ OnSetConnectorPoints()

virtual void OnSetConnectorPoints | ( | CXTPChartDeviceCommand * | pCommand,
 |  | CXTPPoint3d | ptShapeCenter,
 |  | CXTPPoint3d | ptOuterCenter )
 virtual

Gets called when pie connector points are computed.

Parameters
pCommand | The sender command.
ptShapeCenter | The coordinates of the physical shape center.
ptOuterCenter | The coordinates of the most outer horizontal shape center point.

Reimplemented in CXTPChart3dPieSeriesPointView.

The documentation for this class was generated from the following file:
  • XTPChart3dPieDeviceCommandEvents.h


Toolkit Pro: CXTPChart3dPieDiagram Class Reference

Public Member Functions | List of all members
CXTPChart3dPieDiagram Class Reference

This class abstracts the pie diagram. More...

Inheritance diagram for CXTPChart3dPieDiagram:
[legend]

Public Member Functions

CXTPChart3dPieDiagram ()
Constructs a CXTPChart3dPieDiagram object.
virtual CXTPChartDiagramView * | CreateView (CXTPChartDeviceContext *pDC, CXTPChartElementView *pParent)
Call this function to create the view of the pie diagram.
- Public Member Functions inherited from CXTPChartPieDiagramBase< BaseDiagram >
virtual void | CalculateSeriesLayout (CXTPChartDeviceContext *pDC, CXTPChartDiagramView *pView)
Call this function to calculate the pie series layout.

Additional Inherited Members

- Protected Member Functions inherited from CXTPChartPieDiagramBase< BaseDiagram >
CXTPChartPieDiagramBase ()
Constructs a CXTPChart2dPieDiagramBase object.

Detailed Description

This class abstracts the pie diagram.

This class is a kind of CXTPChartDiagram.

A pie chart (or a circle graph) is a circular chart divided into sectors, illustrating percents. In a pie chart, the arc length of each sector (and consequently its central angle and area), is proportional to the quantity it represents. Together, the sectors create a full disk.

Member Function Documentation

◆ CreateView()

virtual CXTPChartDiagramView * CreateView | ( | CXTPChartDeviceContext * | pDC,
 |  | CXTPChartElementView * | pParent )
 virtual

Call this function to create the view of the pie diagram.

Parameters
pDC | A pointer to chart device context.
pParent | A pointer to the parent view.
Returns
Returns a pointer to the associated diagram view object.

Implements CXTPChartPieDiagramBase< BaseDiagram >.

The documentation for this class was generated from the following file:
  • XTPChart3dPieDiagram.h


Toolkit Pro: CXTPChart3dPieDiagramView Class Reference

Public Member Functions | List of all members
CXTPChart3dPieDiagramView Class Reference

This class abstracts the view of a pie diagram. More...

Inheritance diagram for CXTPChart3dPieDiagramView:
[legend]

Public Member Functions

CXTPChart3dPieDiagramView (CXTPChartDiagram *pDiagram, CXTPChartElementView *pParent)
Constructs a CXTPChart3dPieDiagramView object.
- Public Member Functions inherited from CXTPChart3dDiagramView
CXTPChart3dDiagramView (CXTPChartDiagram *pDiagram, CXTPChartElementView *pParentView)
Constructs a CXTPChart3dDiagramView object.
virtual CXTPChartDeviceCommand * | CreateDeviceCommand (CXTPChartDeviceContext *pDC)
Creates a view device command.
- Public Member Functions inherited from CXTPChartDiagramView
CXTPChartDiagramView (CXTPChartDiagram *pDiagram, CXTPChartElementView *pParentView)
Constructs a CXTPChartDiagram object.
CRect | GetBounds () const
Call this function to get the bounds of the diagram.
CXTPChartDiagram * | GetDiagram () const
Call this function to get the diagram object associated with the view.
CXTPChartElementView * | GetLabelsView () const
Call this function to get the label view object associated with this diagram view.
CXTPChartElementView * | GetSeriesView () const
Call this function to get the series view object associated with this diagram view.
virtual void | CalculateView (CXTPChartDeviceContext *pDC, CRect rcBounds)
Call this function to calculate the view of the diagram.
virtual void | UpdateRange (CXTPChartDeviceContext *pDC)
Updates chart range.
virtual void | OnMouseWheel (UINT nFlags, short zDelta, CPoint pt)
Handles mouse wheel event.
virtual void | CreateView (CXTPChartDeviceContext *pDC)
Performs view initialization.
- Public Member Functions inherited from CXTPChartElementView
CXTPChartElementView (CXTPChartElementView *pParentView)
Constructs a CXTPChartElementView object.
CXTPChartElementView (CXTPChartElementView *pParentView, BOOL bAddToParent)
Constructs a CXTPChartElementView object.
CXTPChartElementView (CXTPChartContainer *pContainer)
Constructs a CXTPChartElementView object.
int | GetCount () const
Call this function to get the number of child views associated with this view.
CXTPChartElementView * | GetAt (int nIndex) const
Call this function to get a child view at a particular index.
CXTPChartElementView * | GetParentView () const
Call this function to get the parent view.
CXTPChartElementView * | AddChildView (CXTPChartElementView *pChildView)
Call this function to add a child view to the current view.
CXTPChartElementView ** GetChildren ()
Provides access to the collection of children elements owned by the view.
CRect | GetBounds () const
Obtains viewed object's bound rectangle.
CRect | GetBounds (BOOL bIncludingChildren) const
Obtains viewed object's bound rectangle.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Additional Inherited Members

- Public Attributes inherited from CXTPChartDiagramView
- Protected Member Functions inherited from CXTPChartDiagramView
- Protected Member Functions inherited from CXTPChartElementView
virtual | ~CXTPChartElementView ()
Destroys a CXTPChartElementView object, handles cleanup.
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.
- Protected Attributes inherited from CXTPChartDiagramView
CXTPChartDiagram * | m_pDiagram
Pointer to the associated diagram object.
CRect | m_rcBounds
The diagram bounds.
CXTPChartElementView * | m_pLabelsView
The label view.
CXTPChartElementView * | m_pSeriesView
The series view.
CXTPChartElementView * | m_pTitlesView
Titles View.
- Protected Attributes inherited from CXTPChartElementView
CArray< CXTPChartElementView *, CXTPChartElementView * > | m_arrChildren
The child view collection.
CXTPChartElementView * | m_pParentView
The parent view.
CXTPChartContainer * | m_pContainer
The parent container.
CRect | m_rcBounds
Bounding rectangle.

Detailed Description

This class abstracts the view of a pie diagram.

This class is a kind of CXTPChartDiagramView.

A pie chart (or a circle graph) is a circular chart divided into sectors, illustrating percents. In a pie chart, the arc length of each sector (and consequently its central angle and area), is proportional to the quantity it represents. Together, the sectors create a full disk.

Constructor & Destructor Documentation

◆ CXTPChart3dPieDiagramView()

CXTPChart3dPieDiagramView | ( | CXTPChartDiagram * | pDiagram,
 |  | CXTPChartElementView * | pParent )

Constructs a CXTPChart3dPieDiagramView object.

Parameters
pDiagram | A pointer to the pie diagram object.
pParent | A pointer to the parent view.
The documentation for this class was generated from the following file:
  • XTPChart3dPieDiagramView.h


Toolkit Pro: CXTPChart3dPieSeriesLabel Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPChart3dPieSeriesLabel Class Reference

CXTPChartPieSeriesLabelBase is a kind of CXTPChart3dPieSeriesLabel. More...

Inheritance diagram for CXTPChart3dPieSeriesLabel:
[legend]

Public Member Functions

CXTPChart3dPieSeriesLabel ()
Constructs a CXTPChart3dPieSeriesLabel object.
- Public Member Functions inherited from CXTPChartPieSeriesLabelBase
CXTPChartPieSeriesLabelBase ()
Constructs a CXTPChartPieSeriesLabelBase object.
virtual | ~CXTPChartPieSeriesLabelBase ()
Destroys a CXTPChartPieSeriesLabelBase object, handles cleanup.
XTPChartPieLabelPosition | GetPosition () const
Call this function to get the label position.
void | SetPosition (XTPChartPieLabelPosition nPosition)
Call this function to set the label position.
CXTPChartPieSeriesStyleBase * | GetStyle () const
Call this function to get the basic style of the pie series.
void | DoPropExchange (CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
BOOL | IsInside () const
Call this function to check whether the label is inside the pie.
- Public Member Functions inherited from CXTPChartSeriesLabel
CXTPChartSeriesLabel ()
Constructs a CXTPChartSeriesLabel object.
virtual | ~CXTPChartSeriesLabel ()
Destroys a CXTPChartSeriesLabel object, handles cleanup.
void | SetTextColor (const CXTPChartColor &clrTextColor)
Call this function to set the text color of the label.
CXTPChartColor | GetTextColor () const
Call this function to get the apparent text color of the label.
CXTPChartFont * | GetFont () const
Call this function to get the font of the text label.
void | SetFont (CXTPChartFont *pFont)
Call this function to set the font of the text label.
void | SetShowLines (BOOL bShowLines)
Call this function to set the lines visibility.
BOOL | GetShowLines () const
Call this function to check if the lines are visible.
void | SetLineLength (int nLineLength)
Call this function to set the line length.
int | GetLineLength () const
Call this function to get the line length.
void | SetVisible (BOOL bVisible)
Call this function to set the label visibility.
BOOL | IsVisible () const
Call this function to check if the label is visible.
void | SetAntialiasing (BOOL bAntialiasing)
Call this function to set anti-aliasing ON or OFF.
BOOL | GetAntialiasing () const
Call this function to check if anti-aliasing is ON or OFF.
CXTPChartNumberFormat * | GetFormat () const
Call this function to get a pointer to CXTPChartNumberFormat that specifies how to convert numbers to strings.
void | SetFormat (LPCTSTR lpszFormat)
Obsolete method.
void | SetBackColor (const CXTPChartColor &clrBackColor)
Call this function to set the text color of the label.
CXTPChartColor | GetBackColor () const
Call this function to get the apparent text color of the label.
void | SetLineColor (const CXTPChartColor &clrBackColor)
Call this function to set the text color of the label.
CXTPChartColor | GetLineColor () const
Call this function to get the apparent text color of the label.
int | GetTransparency () const
Call this function to get the transparency of the filled area with respect to the background.
void | SetTransparency (int nTransparency)
Call this function to set the transparency of the filled area with respect to the background.
- Public Member Functions inherited from CXTPChartTextElement
- Public Member Functions inherited from CXTPChartElement
CXTPChartElement ()
Constructs a CXTPChartElement object.
virtual | ~CXTPChartElement ()
Destroys a CXTPChartElement object, handles cleanup.
virtual void | Release ()
Call this function to decrease the usage count of the object.
CXTPChartElement * | GetOwner () const
Call this function to get the owner element.
virtual void | OnChartChanged (XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic properties of the chart.
CXTPChartContent * | GetContent () const
Call this virtual function to get the chart content object.
CXTPChartAppearance * | GetAppearance () const
Call this function to get the the appearance of the chart.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Protected Member Functions

virtual CXTPChartElementView * CreateView (CXTPChartDeviceContext *pDC, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView)
This function creates the view of the pie series.
- Protected Member Functions inherited from CXTPChartPieSeriesLabelBase
- Protected Member Functions inherited from CXTPChartSeriesLabel
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.

Additional Inherited Members

- Public Attributes inherited from CXTPChartElement
- Protected Attributes inherited from CXTPChartPieSeriesLabelBase
XTPChartPieLabelPosition | m_nPosition
The pie label position.
- Protected Attributes inherited from CXTPChartSeriesLabel
CXTPChartColor | m_clrTextColor
The text color.
CXTPChartColor | m_clrBackColor
The background color.
CXTPChartColor | m_clrLineColor
The line color.
BOOL | m_bVisible
TRUE if the label is visible and FALSE if not.
CXTPChartFont * | m_pFont
The font of the label.
BOOL | m_bAntialiasing
TRUE if antialiasing enabled, FALSE if not.
BOOL | m_bShowLines
TRUE if the lines are visible, FALSE if not.
int | m_nLineLength
The line length.
CXTPChartBorder * | m_pBorder
Chart border object.
int | m_nTransparency
The transparency values range from 0 to 255.
- Protected Attributes inherited from CXTPChartElement

Detailed Description

CXTPChartPieSeriesLabelBase is a kind of CXTPChart3dPieSeriesLabel.

This class abstracts the label of a pie series.

Member Function Documentation

◆ CreateView()

virtual CXTPChartElementView * CreateView | ( | CXTPChartDeviceContext * | pDC,
 |  | CXTPChartSeriesPointView * | pPointView,
 |  | CXTPChartElementView * | pParentView )
 protectedvirtual

This function creates the view of the pie series.

Parameters
pDC | The chart device context object pointer.
pPointView | The series point view.
pParentView | Parent view pointer.
Returns
Returns a pointer to the associated label view object.

Implements CXTPChartPieSeriesLabelBase.

The documentation for this class was generated from the following file:
  • XTPChart3dPieSeriesLabel.h


Toolkit Pro: CXTPChart3dPieSeriesLabelDeviceCommand Class Reference

Public Member Functions | List of all members
CXTPChart3dPieSeriesLabelDeviceCommand Class Reference

Implements 3D chart pie series label device command. More...

Inheritance diagram for CXTPChart3dPieSeriesLabelDeviceCommand:
[legend]

Public Member Functions

CXTPChart3dPieSeriesLabelDeviceCommand (CXTPChart3dPieSeriesLabelView *pSeriesLabelView)
Constructs a CXTPChart3dPieSeriesLabelDeviceCommand object.
CXTPChart3dPieSeriesLabelView * | GetSeriesLabelView () const
Obtains the label view object pointer.
BOOL | IsBent () const
Returns TRUE if the label connector is bent.
BOOL | IsFailed () const
Checks whether the command object is in a failed state.
void | SetFailed ()
Sets the command object to a failed state.
CRect | GetLabelRect () const
Obtains the label rectangle.
void | SetLabelRect (CRect rcLabel)
Sets the label rectangle.
BOOL | ComputeConnectorVector (CXTPChart3dDeviceContext *pDC)
Computes the connector vector.
BOOL | ComputeConnectorBend (CXTPChart3dDeviceContext *pDC, CRect rcBoundaries)
Computes the connector bend.
void | ComputeLabel (CXTPChart3dDeviceContext *pDC)
Computes label.
double | GetConnectorLengthFactor () const
Determines the connector length factor value.
void | SetConnectorLengthFactor (double dFactor)
Sets the connector length factor value.
double | GetConnectorEndpointVerticalOffset () const
Determines the connector endpoint vertical offset value.
void | SetConnectorEndpointVerticalOffset (double yOffset)
Sets the connector endpoint vertical offset value.
BOOL | SetColumnAnchorVerticalPosition (CXTPChart3dDeviceContext *pDC, int y)
Sets the column anchor vertical position value.
- Public Member Functions inherited from CXTPChart3dDeviceCommand
virtual BOOL | IsEnabled () const
Determines if the command is currently enabled.
- Public Member Functions inherited from CXTPChartDeviceCommand
CXTPChartDeviceCommand ()
Constructs a CXTPChartDeviceCommand object.
virtual | ~CXTPChartDeviceCommand ()
Destroys a CXTPChartDeviceCommand object, handles cleanup.
BOOL | IsCommitted () const
Determines if the execution of the command has been committed.
void | Commit ()
Commits the execution of the command.
int | GetChildCommandCount () const
Obtains the number of immediate children commands.
CXTPChartDeviceCommand * | GetChildCommand (int nIndex) const
Obtains immediate child command point by index.
CXTPChartDeviceCommand * | AddChildCommand (CXTPChartDeviceCommand *pCommand)
Call this function to add a child device command.
virtual void | Execute (CXTPChartDeviceContext *pDC)
Call this function to execute the drawing.
virtual void | BeforeExecute (CXTPChartDeviceContext *pDC)
This method gets called before a command is executed which allows for the customization of command behavior.
virtual void | AfterExecute (CXTPChartDeviceContext *pDC)
This method gets called after a command is executed which allows for the customization of command behavior.
virtual void | ExecuteOverride (CXTPChartDeviceContext *pDC)
Override this function to write the drawing code for specific objects.
UINT | GetPassNumber () const
Get the number of executions made by the command.
virtual CXTPChartElement * | HitTest (CPoint point, CXTPChartElement *pParent) const
Performs recursive hit testing of the element at the specified point.
virtual void | ApplySeriesStyle (CXTPChartSeriesStyle *pStyle)
Applies series style to the current element.
virtual void | Prepare (CXTPChartDeviceContext *pDC)
Performs inital preparation steps necessary for successful command execution.
virtual void | PrepareOverride (CXTPChartDeviceContext *pDC)
Derived implementation must override this method for implementing implementation specific preparation behavior.
void | SetEnabled (BOOL bEnabled=TRUE)
Enables/disable the command.
CXTPChartDeviceContext * | GetCurrentDC () const
Obtains device context pointer for which the command is currenly being prepared or executed.
void | BindView (CXTPChartElementView *pView)
Binds a view to the command object.
CXTPChartElementView * | GetBoundView () const
Obtains a bound view pointer or NULL if no view is bound.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.
- Public Member Functions inherited from CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents >
void | Subscribe (CXTPChartDeviceCommandEvents *pObserver, CXTPSubscriptionList< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > *pSubcriptionList=NULL)
Subscribes a unique observer for events.
void | Unsubscribe (CXTPChartDeviceCommandEvents *pObserver)
Unsubscribes an observer from events.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *))
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *))
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.

Additional Inherited Members

- Protected Member Functions inherited from CXTPChart3dDeviceCommand
CXTPChart3dDeviceCommand (XTPChart3dAntialiasingPolicy nAntialiasingPolicy)
Constructs a CXTPChart3dDeviceCommand object.
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.
- Protected Member Functions inherited from CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents >
CXTPObservable ()
Constructs an observable object.
~CXTPObservable ()
Handles observable object destruction.
- Protected Attributes inherited from CXTPChartDeviceCommand
CArray< CXTPChartDeviceCommand *, CXTPChartDeviceCommand * > m_arrChildren
< The array of child device commands.

Detailed Description

Implements 3D chart pie series label device command.

Constructor & Destructor Documentation

◆ CXTPChart3dPieSeriesLabelDeviceCommand()

CXTPChart3dPieSeriesLabelDeviceCommand ( CXTPChart3dPieSeriesLabelView * pSeriesLabelView )

Constructs a CXTPChart3dPieSeriesLabelDeviceCommand object.

Parameters
pSeriesLabelView Associated series label view pointer.

Member Function Documentation

◆ ComputeConnectorBend()

BOOL ComputeConnectorBend | ( | CXTPChart3dDeviceContext * | pDC,
 |  | CRect | rcBoundaries )

Computes the connector bend.

Parameters
pDC | Target device context pointer.
rcBoundaries | Size of boundries.
Returns
TRUE if the bend is successfully computed, FALSE otherwise.

◆ ComputeConnectorVector()

BOOL ComputeConnectorVector ( CXTPChart3dDeviceContext * pDC )

Computes the connector vector.

Parameters
pDC Target device context pointer.
Returns
TRUE if the vector is successfully computed, FALSE otherwise.

◆ ComputeLabel()

void ComputeLabel ( CXTPChart3dDeviceContext * pDC )

Computes label.

Parameters
pDC Target device context pointer.

◆ GetConnectorEndpointVerticalOffset()

AFX_INLINE double GetConnectorEndpointVerticalOffset ( ) const

Determines the connector endpoint vertical offset value.

Returns
Connector endpoint vertical offset value.
See also
SetConnectorEndpointVerticalOffset

◆ GetConnectorLengthFactor()

AFX_INLINE double GetConnectorLengthFactor ( ) const

Determines the connector length factor value.

Returns
Connector length factor value.
See also
SetConnectorLengthFactor

◆ GetLabelRect()

AFX_INLINE CRect GetLabelRect ( ) const

Obtains the label rectangle.

Returns
Label rectangle.
See also
SetLabelRect

◆ GetSeriesLabelView()

AFX_INLINE CXTPChart3dPieSeriesLabelView * GetSeriesLabelView ( ) const

Obtains the label view object pointer.

Returns
Label view object pointer.

◆ IsBent()

BOOL IsBent ( ) const

Returns TRUE if the label connector is bent.

Returns
TRUE if the label connector is bent, FALSE otherwise.

◆ IsFailed()

AFX_INLINE BOOL IsFailed ( ) const

Checks whether the command object is in a failed state.

Returns
TRUE if the command object is in a failed state, FALSE otherwise.
See also
SetFailed

◆ SetColumnAnchorVerticalPosition()

BOOL SetColumnAnchorVerticalPosition | ( | CXTPChart3dDeviceContext * | pDC,
 |  | int | y )

Sets the column anchor vertical position value.

Parameters
pDC | Target device context.
y | New column anchor vertical position value.
Returns
TRUE if the new value is successfully computed and applied, FALSE otherwise.

◆ SetConnectorEndpointVerticalOffset()

AFX_INLINE void SetConnectorEndpointVerticalOffset ( double yOffset )

Sets the connector endpoint vertical offset value.

Parameters
yOffset New connector endpoint vertical offset value.
See also
GetConnectorEndpointVerticalOffset

◆ SetConnectorLengthFactor()

AFX_INLINE void SetConnectorLengthFactor ( double dFactor )

Sets the connector length factor value.

Parameters
dFactor New connector length factor value.
See also
GetConnectorLengthFactor

◆ SetLabelRect()

AFX_INLINE void SetLabelRect ( CRect rcLabel )

Sets the label rectangle.

Parameters
rcLabel Label rectangle.
See also
GetLabelRect
The documentation for this class was generated from the following file:
  • XTPChart3dPieSeriesLabelsViewDeviceCommand.h


Toolkit Pro: CXTPChart3dPieSeriesLabelsView Class Reference

Public Member Functions | List of all members
CXTPChart3dPieSeriesLabelsView Class Reference

Represents a view object for all pie series labels. More...

Inheritance diagram for CXTPChart3dPieSeriesLabelsView:
[legend]

Public Member Functions

CXTPChart3dPieSeriesLabelsView (CXTPChartElementView *pParentView)
Constructs a view object.
virtual CXTPChartDeviceCommand * | CreateDeviceCommand (CXTPChartDeviceContext *pDC)
Creates view drawing device command for the device context specified.
virtual void | ResolveOverlapping ()
Resolves label overlapping in an implementation specific way.
- Public Member Functions inherited from CXTPChartPieSeriesLabelsViewBase
- Public Member Functions inherited from CXTPChartElementView
CXTPChartElementView (CXTPChartElementView *pParentView)
Constructs a CXTPChartElementView object.
CXTPChartElementView (CXTPChartElementView *pParentView, BOOL bAddToParent)
Constructs a CXTPChartElementView object.
CXTPChartElementView (CXTPChartContainer *pContainer)
Constructs a CXTPChartElementView object.
int | GetCount () const
Call this function to get the number of child views associated with this view.
CXTPChartElementView * | GetAt (int nIndex) const
Call this function to get a child view at a particular index.
CXTPChartElementView * | GetParentView () const
Call this function to get the parent view.
CXTPChartElementView * | AddChildView (CXTPChartElementView *pChildView)
Call this function to add a child view to the current view.
CXTPChartElementView ** GetChildren ()
Provides access to the collection of children elements owned by the view.
CRect | GetBounds () const
Obtains viewed object's bound rectangle.
CRect | GetBounds (BOOL bIncludingChildren) const
Obtains viewed object's bound rectangle.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Additional Inherited Members

- Protected Member Functions inherited from CXTPChartPieSeriesLabelsViewBase
CXTPChartPieSeriesLabelsViewBase (CXTPChartElementView *pParentView)
Constructs a CXTPChartPieSeriesLabelsViewBase object.
- Protected Member Functions inherited from CXTPChartElementView
virtual | ~CXTPChartElementView ()
Destroys a CXTPChartElementView object, handles cleanup.
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.
- Protected Attributes inherited from CXTPChartElementView
CArray< CXTPChartElementView *, CXTPChartElementView * > | m_arrChildren
The child view collection.
CXTPChartElementView * | m_pParentView
The parent view.
CXTPChartContainer * | m_pContainer
The parent container.
CRect | m_rcBounds
Bounding rectangle.

Detailed Description

Represents a view object for all pie series labels.

Constructor & Destructor Documentation

◆ CXTPChart3dPieSeriesLabelsView()

CXTPChart3dPieSeriesLabelsView ( CXTPChartElementView * pParentView )

Constructs a view object.

Parameters
pParentView Parent view pointer.

Member Function Documentation

◆ CreateDeviceCommand()

virtual CXTPChartDeviceCommand * CreateDeviceCommand ( CXTPChartDeviceContext * pDC )
virtual

Creates view drawing device command for the device context specified.

Parameters
pDC Device context pointer for which the drawing command is to be created.
Returns
A new instance of view drawing device command or NULL if no command is provided.

Implements CXTPChartPieSeriesLabelsViewBase.

The documentation for this class was generated from the following file:
  • XTPChart3dPieSeriesLabel.h


Toolkit Pro: CXTPChart3dPieSeriesLabelsViewDeviceCommand Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPChart3dPieSeriesLabelsViewDeviceCommand Class Reference

Represents device command for all pie series labels view. More...

Inheritance diagram for CXTPChart3dPieSeriesLabelsViewDeviceCommand:
[legend]

Public Member Functions

CXTPChart3dPieSeriesLabelsViewDeviceCommand (CXTPChart3dPieSeriesLabelsView *pSeriesLabelsView)
Constructs a command object instance.
virtual void | ExecuteOverride (CXTPChartDeviceContext *pDC)
Override this function to write the drawing code for specific objects.
- Public Member Functions inherited from CXTPChart3dDeviceCommand
virtual BOOL | IsEnabled () const
Determines if the command is currently enabled.
- Public Member Functions inherited from CXTPChartDeviceCommand
CXTPChartDeviceCommand ()
Constructs a CXTPChartDeviceCommand object.
virtual | ~CXTPChartDeviceCommand ()
Destroys a CXTPChartDeviceCommand object, handles cleanup.
BOOL | IsCommitted () const
Determines if the execution of the command has been committed.
void | Commit ()
Commits the execution of the command.
int | GetChildCommandCount () const
Obtains the number of immediate children commands.
CXTPChartDeviceCommand * | GetChildCommand (int nIndex) const
Obtains immediate child command point by index.
CXTPChartDeviceCommand * | AddChildCommand (CXTPChartDeviceCommand *pCommand)
Call this function to add a child device command.
virtual void | Execute (CXTPChartDeviceContext *pDC)
Call this function to execute the drawing.
virtual void | BeforeExecute (CXTPChartDeviceContext *pDC)
This method gets called before a command is executed which allows for the customization of command behavior.
virtual void | AfterExecute (CXTPChartDeviceContext *pDC)
This method gets called after a command is executed which allows for the customization of command behavior.
UINT | GetPassNumber () const
Get the number of executions made by the command.
virtual CXTPChartElement * | HitTest (CPoint point, CXTPChartElement *pParent) const
Performs recursive hit testing of the element at the specified point.
virtual void | ApplySeriesStyle (CXTPChartSeriesStyle *pStyle)
Applies series style to the current element.
virtual void | Prepare (CXTPChartDeviceContext *pDC)
Performs inital preparation steps necessary for successful command execution.
virtual void | PrepareOverride (CXTPChartDeviceContext *pDC)
Derived implementation must override this method for implementing implementation specific preparation behavior.
void | SetEnabled (BOOL bEnabled=TRUE)
Enables/disable the command.
CXTPChartDeviceContext * | GetCurrentDC () const
Obtains device context pointer for which the command is currenly being prepared or executed.
void | BindView (CXTPChartElementView *pView)
Binds a view to the command object.
CXTPChartElementView * | GetBoundView () const
Obtains a bound view pointer or NULL if no view is bound.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.
- Public Member Functions inherited from CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents >
void | Subscribe (CXTPChartDeviceCommandEvents *pObserver, CXTPSubscriptionList< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > *pSubcriptionList=NULL)
Subscribes a unique observer for events.
void | Unsubscribe (CXTPChartDeviceCommandEvents *pObserver)
Unsubscribes an observer from events.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *))
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *))
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.

Protected Attributes

CXTPChart3dPieSeriesLabelsView * | m_pSeriesLabelsView
View pointer.
- Protected Attributes inherited from CXTPChartDeviceCommand
CArray< CXTPChartDeviceCommand *, CXTPChartDeviceCommand * > | m_arrChildren
< The array of child device commands.

Additional Inherited Members

- Protected Member Functions inherited from CXTPChart3dDeviceCommand
CXTPChart3dDeviceCommand (XTPChart3dAntialiasingPolicy nAntialiasingPolicy)
Constructs a CXTPChart3dDeviceCommand object.
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.
- Protected Member Functions inherited from CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents >
CXTPObservable ()
Constructs an observable object.
~CXTPObservable ()
Handles observable object destruction.

Detailed Description

Represents device command for all pie series labels view.

Constructor & Destructor Documentation

◆ CXTPChart3dPieSeriesLabelsViewDeviceCommand()

CXTPChart3dPieSeriesLabelsViewDeviceCommand ( CXTPChart3dPieSeriesLabelsView * pSeriesLabelsView )

Constructs a command object instance.

Parameters
pSeriesLabelsView View pointer.

Member Function Documentation

◆ ExecuteOverride()

virtual void ExecuteOverride ( CXTPChartDeviceContext * pDC )
virtual

Override this function to write the drawing code for specific objects.

Parameters
pDC A pointer to the chart device context.

Reimplemented from CXTPChartDeviceCommand.

The documentation for this class was generated from the following file:
  • XTPChart3dPieSeriesLabelsViewDeviceCommand.h


Toolkit Pro: CXTPChart3dPieSeriesLabelView Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPChart3dPieSeriesLabelView Class Reference

Represents a series label view object. More...

Inheritance diagram for CXTPChart3dPieSeriesLabelView:
[legend]

Public Member Functions

CXTPChart3dPieSeriesLabelView (CXTPChartSeriesLabel *pLabel, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView)
Constructs a view object.
~CXTPChart3dPieSeriesLabelView ()
Handles view object destruction.
virtual CXTPChartDeviceCommand * | CreateTranspositionDeviceCommand (CXTPChartDeviceContext *pDC)
Creates a label transposition device command object.
virtual CXTPChartDeviceCommand * | CreateDeviceCommand (CXTPChartDeviceContext *pDC)
Creates a label drawing device command object.
virtual CXTPChartDeviceCommand * | CreateConnectorDeviceCommand (CXTPChartDeviceContext *pDC)
Creates a label connector drawing device command object.
const CXTPPoint3d * | GetConnectorStartPoint () const
Obtains a previously set connector start point.
void | SetConnectorStartPoint (const CXTPPoint3d &point)
Sets the connector start point.
const CXTPPoint3d * | GetConnectorBendPoint () const
Obtains a previously set connector bend point.
void | SetConnectorBendPoint (const CXTPPoint3d &point)
Sets the connector bend point.
const CXTPPoint3d * | GetConnectorEndPoint () const
Obtains a previously set connector end point.
void | SetConnectorEndPoint (const CXTPPoint3d &point)
Sets the connector end point.
const CPoint * | GetLabelAnchorPoint () const
Obtains a previously set label anchor point.
void | SetLabelAnchorPoint (CPoint ptAnchor)
Sets the label anchor point.
const CPoint * | GetLabelAnchorOrigin () const
Obtains a previously set label anchor origin point.
void | SetLabelAnchorOrigin (CPoint ptAnchorOrigin)
Sets the label anchor origin point.
void | SetLeftDirected ()
Makes the label left directed.
BOOL | IsLeftDirected () const
Determies if the label is left directed.
void | SetRightDirected ()
Makes the label right directed.
BOOL | IsRightDirected () const
Determies if the label is right directed.
BOOL | IsConnectorVisible () const
Determines if the connector is visible.
void | SetConnectorVisible (BOOL bVisible=TRUE)
Sets the connector visibility.
- Public Member Functions inherited from CXTPChartPieSeriesLabelViewBase
XTPChartPieLabelPosition | GetPosition () const
Obtains label position.

Protected Attributes

CXTPPoint3d * | m_ptStart
Connector start point or NULL if not set.
CXTPPoint3d * | m_ptBend
Connector bend point or NULL if not set.
CXTPPoint3d * | m_ptEnd
Connector end point or NULL if not set.
CPoint | m_ptLabelAnchor
Label anchor point.
CPoint | m_ptLabelAnchorOrigin
Label anchor point origin.
CXTPChart3dPieSeriesPointView * | m_p3dPointView
Point view.
BOOL | m_bLeftDirected
TRUE if label is to be left directed.
BOOL | m_bConnectorVisible
TRUE if connector is visible.

Additional Inherited Members

- Protected Member Functions inherited from CXTPChartPieSeriesLabelViewBase
CXTPChartPieSeriesLabelViewBase (CXTPChartSeriesLabel *pLabel, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView)
Constructs a CXTPChartPieSeriesLabelViewBase object.

Detailed Description

Represents a series label view object.

Constructor & Destructor Documentation

◆ CXTPChart3dPieSeriesLabelView()

CXTPChart3dPieSeriesLabelView | ( | CXTPChartSeriesLabel * | pLabel,
 |  | CXTPChartSeriesPointView * | pPointView,
 |  | CXTPChartElementView * | pParentView )

Constructs a view object.

Parameters
pLabel | Label model object pointer.
pPointView | Related point view object pointer.
pParentView | Parent view object pointer.

Member Function Documentation

◆ CreateConnectorDeviceCommand()

virtual CXTPChartDeviceCommand * CreateConnectorDeviceCommand ( CXTPChartDeviceContext * pDC )
virtual

Creates a label connector drawing device command object.

Parameters
pDC Target device context.
Returns
New label connector drawing device command object.

Implements CXTPChartPieSeriesLabelViewBase.

◆ CreateDeviceCommand()

virtual CXTPChartDeviceCommand * CreateDeviceCommand ( CXTPChartDeviceContext * pDC )
virtual

Creates a label drawing device command object.

Parameters
pDC Target device context.
Returns
New label drawing device command object.

Implements CXTPChartPieSeriesLabelViewBase.

◆ CreateTranspositionDeviceCommand()

virtual CXTPChartDeviceCommand * CreateTranspositionDeviceCommand ( CXTPChartDeviceContext * pDC )
virtual

Creates a label transposition device command object.

Parameters
pDC Target device context.
Returns
New label transposition device command object.

◆ GetConnectorBendPoint()

AFX_INLINE const CXTPPoint3d * GetConnectorBendPoint ( ) const

Obtains a previously set connector bend point.

Returns
Connector bend point or NULL if not set.
See also
SetConnectorBendPoint

◆ GetConnectorEndPoint()

AFX_INLINE const CXTPPoint3d * GetConnectorEndPoint ( ) const

Obtains a previously set connector end point.

Returns
Connector end point or NULL if not set.
See also
SetConnectorEndPoint

◆ GetConnectorStartPoint()

AFX_INLINE const CXTPPoint3d * GetConnectorStartPoint ( ) const

Obtains a previously set connector start point.

Returns
Connector start point or NULL if not set.
See also
SetConnectorStartPoint

◆ GetLabelAnchorOrigin()

const CPoint * GetLabelAnchorOrigin ( ) const

Obtains a previously set label anchor origin point.

Returns
Label anchor origin point or NULL if not set.
See also
SetLabelAnchorOrigin

◆ GetLabelAnchorPoint()

const CPoint * GetLabelAnchorPoint ( ) const

Obtains a previously set label anchor point.

Returns
Label anchor point or NULL if not set.
See also
SetLabelAnchorPoint

◆ IsConnectorVisible()

AFX_INLINE BOOL IsConnectorVisible ( ) const

Determines if the connector is visible.

Returns
TRUE if connector is visible, FALSE otherwise.
See also
SetConnectorVisible

◆ IsLeftDirected()

AFX_INLINE BOOL IsLeftDirected ( ) const

Determies if the label is left directed.

Returns
TRUE if left directed, FALSE otherwise.
See also
SetLeftDirected

◆ IsRightDirected()

AFX_INLINE BOOL IsRightDirected ( ) const

Determies if the label is right directed.

Returns
TRUE if right directed, FALSE otherwise.
See also
SetRightDirected

◆ SetConnectorBendPoint()

void SetConnectorBendPoint ( const CXTPPoint3d & point )

Sets the connector bend point.

Parameters
point New value of the connector bend point.
See also
GetConnectorBendPoint

◆ SetConnectorEndPoint()

void SetConnectorEndPoint ( const CXTPPoint3d & point )

Sets the connector end point.

Parameters
point New value of the connector end point.
See also
GetConnectorEndPoint

◆ SetConnectorStartPoint()

void SetConnectorStartPoint ( const CXTPPoint3d & point )

Sets the connector start point.

Parameters
point New value of the connector start point.
See also
GetConnectorStartPoint

◆ SetConnectorVisible()

AFX_INLINE void SetConnectorVisible ( BOOL bVisible = TRUE )

Sets the connector visibility.

Parameters
bVisible A BOOL value. TRUE for making connector visible, FALSE to hide the connector.
See also
SetConnectorVisible

◆ SetLabelAnchorOrigin()

AFX_INLINE void SetLabelAnchorOrigin ( CPoint ptAnchorOrigin )

Sets the label anchor origin point.

Parameters
ptAnchorOrigin New value of the label anchor origin point.
See also
GetLabelAnchorOrigin

◆ SetLabelAnchorPoint()

AFX_INLINE void SetLabelAnchorPoint ( CPoint ptAnchor )

Sets the label anchor point.

Parameters
ptAnchor New value of the label anchor point.
See also
GetLabelAnchorPoint

◆ SetLeftDirected()

AFX_INLINE void SetLeftDirected ( )

Makes the label left directed.

See also
IsLeftDirected

◆ SetRightDirected()

AFX_INLINE void SetRightDirected ( )

Makes the label right directed.

See also
IsRightDirected
The documentation for this class was generated from the following file:
  • XTPChart3dPieSeriesLabel.h


Toolkit Pro: CXTPChart3dPieSeriesPointView Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPChart3dPieSeriesPointView Class Reference

This class abstracts the view of a pie series point. More...

Inheritance diagram for CXTPChart3dPieSeriesPointView:
[legend]

Public Member Functions

CXTPChart3dPieSeriesPointView (CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Constructs a CXTPChart3dPieSeriesPointView object.
virtual | ~CXTPChart3dPieSeriesPointView ()
Handles view destruction.
virtual void | CalculateLayout (double &dAngle)
Use this function to calculate the layout of the pie series point.
const CXTPPoint3d & | GetCenterShapeConnectorPoint () const
Obtains the shape center connector point.
const CXTPPoint3d & | GetOuterCenterConnectorPoint () const
Obtains the outer shape center connector point.
- Public Member Functions inherited from CXTPChartPieSeriesPointViewBase
virtual | ~CXTPChartPieSeriesPointViewBase ()
Destroys a CXTPChartPieSeriesPointViewBase object, handle cleanup.
CXTPChartPieBase * | GetPie () const
Use this function to get the pie for the point.
CXTPChartPointF | GetBasePoint () const
Use this function to obtain the base point value.
- Public Member Functions inherited from CXTPChartSeriesPointView
CXTPChartSeriesPointView (CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Constructs the view object.
CXTPChartSeriesPointView (CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView, BOOL bAddToParent)
Constructs the view object.
CXTPChartSeriesPoint * | GetPoint () const
Obtains point model object.
CXTPChartSeriesView * | GetSeriesView () const
Obtains parent series view.
CXTPChartColor | GetColor () const
Obtain view color values.
CXTPChartColor | GetColor2 () const
Obtain view color values.
double | GetInternalValue () const
Obtains point interval value.
virtual CXTPChartString | GetLegendName () const
This function returns the legend name.
virtual void | UpdateMinMaxRange (double &nMinValue, double &nMaxValue) const
Provides a default empty implementation for min/max range update request.
- Public Member Functions inherited from CXTPChartElementView
CXTPChartElementView (CXTPChartElementView *pParentView)
Constructs a CXTPChartElementView object.
CXTPChartElementView (CXTPChartElementView *pParentView, BOOL bAddToParent)
Constructs a CXTPChartElementView object.
CXTPChartElementView (CXTPChartContainer *pContainer)
Constructs a CXTPChartElementView object.
int | GetCount () const
Call this function to get the number of child views associated with this view.
CXTPChartElementView * | GetAt (int nIndex) const
Call this function to get a child view at a particular index.
CXTPChartElementView * | GetParentView () const
Call this function to get the parent view.
CXTPChartElementView * | AddChildView (CXTPChartElementView *pChildView)
Call this function to add a child view to the current view.
CXTPChartElementView ** GetChildren ()
Provides access to the collection of children elements owned by the view.
CRect | GetBounds () const
Obtains viewed object's bound rectangle.
CRect | GetBounds (BOOL bIncludingChildren) const
Obtains viewed object's bound rectangle.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.
- Public Member Functions inherited from CXTPChartLegendItemView
virtual | ~CXTPChartLegendItemView ()
Handles object destruction.

Protected Member Functions

virtual CXTPChartDeviceCommand * | CreateDeviceCommand (CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
virtual CXTPChartDeviceCommand * | CreateLegendDeviceCommand (CXTPChartDeviceContext *pDC, CRect rcBounds)
This function creates a label view drawing command object.
virtual void | OnUpdateBounds (CXTPChartDeviceCommand *pCommand, CRect rcBounds)
Notifies about updated boundaries of the command result.
virtual void | OnSetConnectorPoints (CXTPChartDeviceCommand *pCommand, CXTPPoint3d ptShapeCenter, CXTPPoint3d ptOuterCenter)
Gets called when pie connector points are computed.
- Protected Member Functions inherited from CXTPChartPieSeriesPointViewBase
CXTPChartPieSeriesPointViewBase (CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Constructs a CXTPChartPieSeriesPointViewBase object.
CXTPChartPieSeriesPointViewBase (CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView, BOOL bAddToParent)
Constructs a CXTPChartPieSeriesPointViewBase object.
- Protected Member Functions inherited from CXTPChartElementView
virtual | ~CXTPChartElementView ()
Destroys a CXTPChartElementView object, handles cleanup.
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.

Additional Inherited Members

- Public Attributes inherited from CXTPChartPieSeriesPointViewBase
- Public Attributes inherited from CXTPChartSeriesPointView
double | m_dInternalValue
Point internal value.
- Protected Attributes inherited from CXTPChartPieSeriesPointViewBase
- Protected Attributes inherited from CXTPChartSeriesPointView
CXTPChartSeriesPoint * | m_pPoint
Point model object pointer.
- Protected Attributes inherited from CXTPChartElementView
CArray< CXTPChartElementView *, CXTPChartElementView * > | m_arrChildren
The child view collection.
CXTPChartElementView * | m_pParentView
The parent view.
CXTPChartContainer * | m_pContainer
The parent container.
CRect | m_rcBounds
Bounding rectangle.

Detailed Description

This class abstracts the view of a pie series point.

This class is a kind of CXTPChartSeriesPointView.

A pie chart (or a circle graph) is a circular chart divided into sectors, illustrating percents. In a pie chart, the arc length of each sector (and consequently its central angle and area), is proportional to the quantity it represents. Together, the sectors create a full disk.

Constructor & Destructor Documentation

◆ CXTPChart3dPieSeriesPointView()

CXTPChart3dPieSeriesPointView | ( | CXTPChartSeriesPoint * | pPoint,
 |  | CXTPChartElementView * | pParentView )

Constructs a CXTPChart3dPieSeriesPointView object.

Parameters
pPoint | Pointer to the chart series point.
pParentView | The parent view of the axis.

Member Function Documentation

◆ CalculateLayout()

virtual void CalculateLayout ( double & dAngle )
virtual

Use this function to calculate the layout of the pie series point.

Parameters
dAngle The swipe angle of the sector(pie).

Implements CXTPChartPieSeriesPointViewBase.

◆ CreateDeviceCommand()

virtual CXTPChartDeviceCommand * CreateDeviceCommand ( CXTPChartDeviceContext * pDC )
protectedvirtual

This function creates a CXTPChartDeviceCommand object.

This object represents the rendering of the pie series point.

Parameters
pDC Pointer to a CXTPChartDeviceContext object.
Returns
Returns a CXTPChartDeviceCommand object. This object handles the rendering of an element in the chart. Here it handles the drawing of the pie series point.

Implements CXTPChartPieSeriesPointViewBase.

◆ CreateLegendDeviceCommand()

virtual CXTPChartDeviceCommand * CreateLegendDeviceCommand | ( | CXTPChartDeviceContext * | pDC,
 |  | CRect | rcBounds )
 protectedvirtual

This function creates a label view drawing command object.

Parameters
pDC | Pointer to a CXTPChartDeviceContext object.
rcBounds | The rectangular boundary of the legend.
Returns
Returns a new label view drawing command object.

Implements CXTPChartPieSeriesPointViewBase.

◆ GetCenterShapeConnectorPoint()

AFX_INLINE const CXTPPoint3d & GetCenterShapeConnectorPoint ( ) const

Obtains the shape center connector point.

Returns
Shape center connector point.
See also
GetOuterCenterConnectorPoint

◆ GetOuterCenterConnectorPoint()

AFX_INLINE const CXTPPoint3d & GetOuterCenterConnectorPoint ( ) const

Obtains the outer shape center connector point.

Returns
Outer shape center connector point.
See also
GetCenterShapeConnectorPoint

◆ OnSetConnectorPoints()

virtual void OnSetConnectorPoints | ( | CXTPChartDeviceCommand * | pCommand,
 |  | CXTPPoint3d | ptShapeCenter,
 |  | CXTPPoint3d | ptOuterCenter )
 protectedvirtual

Gets called when pie connector points are computed.

Parameters
pCommand | The sender command.
ptShapeCenter | The coordinates of the physical shape center.
ptOuterCenter | The coordinates of the most outer horizontal shape center point.

Reimplemented from CXTPChart3dPieDeviceCommandEvents.

◆ OnUpdateBounds()

virtual void OnUpdateBounds | ( | CXTPChartDeviceCommand * | pCommand,
 |  | CRect | rcBounds )
 protectedvirtual

Notifies about updated boundaries of the command result.

Parameters
pCommand | Sender command pointer.
rcBounds | Updated bounray rectangle.

Reimplemented from CXTPChartDeviceCommandEvents.

The documentation for this class was generated from the following file:
  • XTPChart3dPieSeriesPointView.h


Toolkit Pro: CXTPChart3dPieSeriesStyle Class Reference

Public Member Functions | List of all members
CXTPChart3dPieSeriesStyle Class Reference

This class abstracts the pie series style. More...

Inheritance diagram for CXTPChart3dPieSeriesStyle:
[legend]

Public Member Functions

CXTPChart3dPieSeriesStyle ()
Constructs a CXTPChart3dPieSeriesStyle object.
virtual CXTPChartDiagram * | CreateDiagram ()
Call this function to create the pie diagram object.
virtual CXTPChartSeriesView * | CreateView (CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Call this function to create the view of the pie series.
virtual CXTPChart3dRotation | Get3dRotation () const
Obtains rotation parameters for 3D chart.
virtual int | GetDepth () const
Obtains depth value.
void | SetDepth (int dDepth)
Sets depth value.
BOOL | IsTorus () const
Checks if the chart has to be drawn as a torus instead of a pie.
void | SetTorus (BOOL bTorus)
Sets torus appearance of the chart.
virtual void | DoPropExchange (CXTPPropExchange *pPX)
Call this member function to Store/Load an event using the specified data object.
- Public Member Functions inherited from CXTPChartPieSeriesStyleBase
int | GetHolePercent () const
Call this function to get the hole percent of the pie chart.
void | SetHolePercent (int nHolePercent)
Call this function to set the hole percent of the pie chart.
int | GetExplodedDistancePercent () const
Call this function to get the exploded distance percent of the pie chart.
void | SetExplodedDistancePercent (int nExplodedDistancePercent)
Call this function to set the exploded distance percent of the pie chart.
int | GetRotation () const
Call this function to get the rotation of the sectors of the pie chart.
void | SetRotation (int nRotation)
Call this function to set the rotation of the sectors of the pie chart.
void | DoPropExchange (CXTPPropExchange *pPX)
Call this member function to Store/Load an event using the specified data object.
CXTPChartBorder * | GetBorder () const
Obtains border object pointer.
CXTPChartColor | GetBorderActualColor () const
Obtains border color.
- Public Member Functions inherited from CXTPChartSeriesStyle
CXTPChartSeriesStyle ()
Constructs a CXTPChartSeriesStyle object.
virtual | ~CXTPChartSeriesStyle ()
Destroys a CXTPChartSeriesStyle object, handles cleanup.
virtual CXTPChartSeriesLabel * | GetLabel () const
Call this method to gets the series label object.
virtual CXTPChartSeriesLabel * | SetLabel (CXTPChartSeriesLabel *pLabel)
Call this method to sets the series label object.
virtual CXTPChartErrorBar * | GetErrorBar () const
Call this method to gets the error bar object.
virtual CXTPChartErrorBar * | SetErrorBar (CXTPChartErrorBar *pErrorBar)
Call this method to sets the error bar object.
virtual CXTPChartColor | GetColor () const
Call this method to get the color of the series.
virtual void | SetColor (CXTPChartColor clr)
Call this method to set the color of the series.
virtual void | SetColorEach (BOOL bColorEach)
Call this method to set individual color for each point of the series.
virtual BOOL | IsColorEach () const
This method is called to check if individual color is used for each point of the series.
virtual void | Set3dRotation (const CXTPChart3dRotation &rotation)
Sets rotation parameters for 3D chart.
virtual void | Set3dRotation (double dYaw, double dPitch, double dRoll)
Sets rotation parameters for 3D chart.
virtual BOOL | Is3dEdgeSmoothingEnabled () const
Enables/disables 3D edge smoothing.
virtual void | Enable3dEdgeSmoothing (BOOL bEnable=TRUE)
Enables/disables 3D edge smoothing.
virtual int | GetTransparency () const
Call this function to gets the transparency of the chart if it is supported by the chart type.
virtual void | SetTransparency (int nTransparency)
Call this function to sets the transparency of the chart if it is supported by the chart type.
virtual void | CorrectAxisSideMargins (CXTPChartAxis *pAxis, double nMinValue, double nMaxValue, double &nCorrection)
Provides default implementation for axis side margins correction.
virtual CXTPChartSeriesStyleAppearance * | GetStyleAppearance () const
Obtains associated style appearance pointer.
virtual void | ApplyTo (CXTPChartDeviceCommand *pCommand)
Applies the style to the command provided in case the command needs style specific details for correct drawing.
virtual int | GetSeriesPointValueIndex () const
Obtains the index of a point element for which an internal value can be otained.
- Public Member Functions inherited from CXTPChartElement
CXTPChartElement ()
Constructs a CXTPChartElement object.
virtual | ~CXTPChartElement ()
Destroys a CXTPChartElement object, handles cleanup.
virtual void | Release ()
Call this function to decrease the usage count of the object.
CXTPChartElement * | GetOwner () const
Call this function to get the owner element.
virtual void | OnChartChanged (XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic properties of the chart.
CXTPChartContent * | GetContent () const
Call this virtual function to get the chart content object.
CXTPChartAppearance * | GetAppearance () const
Call this function to get the the appearance of the chart.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Additional Inherited Members

- Public Attributes inherited from CXTPChartElement
- Protected Member Functions inherited from CXTPChartPieSeriesStyleBase
CXTPChartPieSeriesStyleBase ()
Constructs a CXTPChartPieSeriesStyleBase object.
virtual | ~CXTPChartPieSeriesStyleBase ()
Destroys a CXTPChartPieSeriesStyleBase object, handle cleanup.
virtual BOOL | IsStyleDiagram (CXTPChartDiagram *pDiagram) const
Call this function to check whether chart diagram object passed is a kind of CXTPChart2dPieDiagramBase/CXTPChart3dPieDiagramBase.
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.
- Protected Attributes inherited from CXTPChartPieSeriesStyleBase
int | m_nHolePercent
The hole percentage.
int | m_nExplodedDistancePercent
The exploded distance percentage.
int | m_nRotation
The sector rotation angle.
CXTPChartBorder * | m_pBorder
Associated border information.
- Protected Attributes inherited from CXTPChartSeriesStyle
CXTPChartSeriesLabel * | m_pLabel
Label object.
CXTPChartErrorBar * | m_pErrorBar
Error bar object.
CXTPChartColor | m_clrColor
Custom color of series.
BOOL | m_bColorEach
TRUE to color each point.
int | m_nTransparency
The transparency value in the range 0..255.
CXTPChart3dRotation | m_Rotation3d
3D rotation
BOOL | m_bSmooth3dEdges
3D edge smoothing
- Protected Attributes inherited from CXTPChartElement

Detailed Description

This class abstracts the pie series style.

This class is a kind of CXTPChartPieSeriesStyleBase.

A pie chart (or a circle graph) is a circular chart divided into sectors, illustrating percents. In a pie chart, the arc length of each sector (and consequently its central angle and area), is proportional to the quantity it represents. Together, the sectors create a full disk.

Member Function Documentation

◆ CreateDiagram()

virtual CXTPChartDiagram * CreateDiagram ( )
virtual

Call this function to create the pie diagram object.

Returns
A pointer to a CXTPChartDiagram object which points to the newly created CXTPChart3dPieDiagramBase object.

Implements CXTPChartPieSeriesStyleBase.

◆ CreateView()

virtual CXTPChartSeriesView * CreateView | ( | CXTPChartSeries * | pSeries,
 |  | CXTPChartDiagramView * | pDiagramView )
 virtual

Call this function to create the view of the pie series.

Parameters
pSeries | A pointer to the chart series object.
pDiagramView | A pointer to the diagram view object.
Returns
Returns a pointer to the associated series view object.

Implements CXTPChartPieSeriesStyleBase.

◆ DoPropExchange()

virtual void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Call this member function to Store/Load an event using the specified data object.

Parameters
pPX Source or destination CXTPPropExchange data object reference.

This member function is used to store event data to or load event data from storage.

Reimplemented from CXTPChartSeriesStyle.

◆ Get3dRotation()

virtual CXTPChart3dRotation Get3dRotation ( ) const
virtual

Obtains rotation parameters for 3D chart.

Returns
Rotation parameters for 3D chart.
See also
Set3dRotation

Reimplemented from CXTPChartSeriesStyle.

◆ GetDepth()

AFX_INLINE int GetDepth ( ) const
virtual

Obtains depth value.

Returns
Depth value.
See also
SetDepth

Reimplemented from CXTPChartPieSeriesStyleBase.

◆ IsTorus()

AFX_INLINE BOOL IsTorus ( ) const

Checks if the chart has to be drawn as a torus instead of a pie.

Returns
TRUE if the chart is to be drawn as a torus, FALSE otherwise.
See also
SetTorus

◆ SetDepth()

AFX_INLINE void SetDepth ( int dDepth )

Sets depth value.

Parameters
dDepth New depth value.
See also
GetDepth

◆ SetTorus()

AFX_INLINE void SetTorus ( BOOL bTorus )

Sets torus appearance of the chart.

Parameters
bTorus If TRUE, then the chart will be drawn as a torus. If FALSE, then the chart will be drawn as a pie.
See also
IsTorus
The documentation for this class was generated from the following file:
  • XTPChart3dPieSeriesStyle.h


Toolkit Pro: CXTPChart3dPieSeriesView Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPChart3dPieSeriesView Class Reference

This class abstracts the view of a pie series. More...

Inheritance diagram for CXTPChart3dPieSeriesView:
[legend]

Public Member Functions

CXTPChart3dPieSeriesView (CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Constructs a CXTPChart3dPieSeriesView object.
virtual void | CalculatePointLayout (CXTPChartDeviceContext *pDC, CRect rcBounds)
Call this function to calculate the pie series point layout.
- Public Member Functions inherited from CXTPChartPieSeriesViewBase
virtual | ~CXTPChartPieSeriesViewBase ()
Destroys a CXTPChartPieSeriesViewBase object, handle cleanup.
virtual void | CalculateLabelLayout (CXTPChartDeviceContext *pDC)
Call this function to calculate the pie series label layout.
virtual CXTPChartDiagramDomain * | CreateDiagramDomain (CXTPChartDeviceContext *pDC, CRect rcBounds)
Call this function to create the pie diagram domain object associated with this object.
CXTPChartRectF | GetInnerBounds () const
Call this function to get the inner bounds of the diagram.
CXTPChartDiagramDomain * | GetDomain () const
Use this function to get the pie diagram domain object associated with this object.
int | GetMaxLabelWidth () const
Obtains maximum allowed label width.

Protected Member Functions

virtual CXTPChartSeriesPointView * | CreateSeriesPointView (CXTPChartDeviceContext *pDC, CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Use this function to create the pie series point view object.
virtual CXTPChartDeviceCommand * | CreateDeviceCommand (CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
virtual CXTPChartDeviceCommand * | CreateLegendDeviceCommand (CXTPChartDeviceContext *pDC, CRect rcBounds)
Creates legend drawing device command.
- Protected Member Functions inherited from CXTPChartPieSeriesViewBase
CXTPChartPieSeriesViewBase (CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Constructs a CXTPChartPieSeriesViewBase object.

Detailed Description

This class abstracts the view of a pie series.

This class is a kind of CXTPChartSeriesView.

A pie chart (or a circle graph) is a circular chart divided into sectors, illustrating percents. In a pie chart, the arc length of each sector (and consequently its central angle and area), is proportional to the quantity it represents. Together, the sectors create a full disk.

Constructor & Destructor Documentation

◆ CXTPChart3dPieSeriesView()

CXTPChart3dPieSeriesView | ( | CXTPChartSeries * | pSeries,
 |  | CXTPChartDiagramView * | pDiagramView )

Constructs a CXTPChart3dPieSeriesView object.

Parameters
pSeries | Pointer to the pie series object.
pDiagramView | Pointer to the pie diagram view.

Member Function Documentation

◆ CalculatePointLayout()

virtual void CalculatePointLayout | ( | CXTPChartDeviceContext * | pDC,
 |  | CRect | rcBounds )
 virtual

Call this function to calculate the pie series point layout.

Parameters
pDC | Pointer to the chart device context.
rcBounds | The rectangular boundary.

Implements CXTPChartPieSeriesViewBase.

◆ CreateDeviceCommand()

virtual CXTPChartDeviceCommand * CreateDeviceCommand ( CXTPChartDeviceContext * pDC )
protectedvirtual

This function creates a CXTPChartDeviceCommand object.

This object represents the rendering of the pie series.

Parameters
pDC Pointer to a CXTPChartDeviceContext object.
Returns
Returns a CXTPChartDeviceCommand object. This object handles the rendering of an element in the chart. Here it handles the drawing of the pie series.

Implements CXTPChartPieSeriesViewBase.

◆ CreateLegendDeviceCommand()

virtual CXTPChartDeviceCommand * CreateLegendDeviceCommand | ( | CXTPChartDeviceContext * | pDC,
 |  | CRect | rcBounds )
 protectedvirtual

Creates legend drawing device command.

Parameters
pDC | Target device context.
rcBounds | Bounding rectangle.
Returns
A newly created command object pointer or NULL if not supported.

Implements CXTPChartPieSeriesViewBase.

◆ CreateSeriesPointView()

virtual CXTPChartSeriesPointView * CreateSeriesPointView | ( | CXTPChartDeviceContext * | pDC,
 |  | CXTPChartSeriesPoint * | pPoint,
 |  | CXTPChartElementView * | pParentView )
 protectedvirtual

Use this function to create the pie series point view object.

Parameters
pDC | Pointer to the chart device context.
pPoint | Pointer to the chart series point.
pParentView | Parent view pointer.
Returns
A pointer to the chart series point view.

Implements CXTPChartPieSeriesViewBase.

The documentation for this class was generated from the following file:
  • XTPChart3dPieSeriesView.h


Toolkit Pro: CXTPChart3dPyramidDeviceCommandEvents Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPChart3dPyramidDeviceCommandEvents Class Reference

Defines interface for 3D chart pyramid device command event sink. More...

Inheritance diagram for CXTPChart3dPyramidDeviceCommandEvents:
[legend]

Public Member Functions

virtual void | OnSetConnectorPoints (CXTPChartDeviceCommand *pCommand, CXTPPoint3d ptShapeCenter, CXTPPoint3d ptOuterCenter)
Gets called when pyramid connector points are computed.
- Public Member Functions inherited from CXTPChartDeviceCommandEvents
virtual void | OnBeforeExecute (CXTPChartDeviceCommand *pCommand, CXTPChartDeviceContext *pDC)
Notifies that a command has entered the BeforeExecute step.
virtual void | OnAfterExecute (CXTPChartDeviceCommand *pCommand, CXTPChartDeviceContext *pDC)
Notifies that a command has entered the AfterExecute step.
virtual void | OnUpdateBounds (CXTPChartDeviceCommand *pCommand, CRect rcBounds)
Notifies about updated boundaries for the command result.
void | OnUnsubscribe (CXTPChartDeviceCommand *pCommand)
Invoked when an event sink is to be unsubscribed from command events.

Protected Member Functions

CXTPChart3dPyramidDeviceCommandEvents ()
Constructs a CXTPChart3dPyramidDeviceCommandEvents object.
- Protected Member Functions inherited from CXTPChartDeviceCommandEvents
CXTPChartDeviceCommandEvents ()
Constructs an event sink.

Detailed Description

Defines interface for 3D chart pyramid device command event sink.

Member Function Documentation

◆ OnSetConnectorPoints()

virtual void OnSetConnectorPoints | ( | CXTPChartDeviceCommand * | pCommand,
 |  | CXTPPoint3d | ptShapeCenter,
 |  | CXTPPoint3d | ptOuterCenter )
 virtual

Gets called when pyramid connector points are computed.

Parameters
pCommand | The sender command.
ptShapeCenter | The coordinates of the physical shape center.
ptOuterCenter | The coordinates of the most outer horizontal shape center point.

Reimplemented in CXTPChart3dPyramidSeriesPointView.

The documentation for this class was generated from the following file:
  • XTPChart3dPyramidDeviceCommandEvents.h


Toolkit Pro: CXTPChart3dPyramidDiagram Class Reference

Public Member Functions | List of all members
CXTPChart3dPyramidDiagram Class Reference

This class abstracts the pyramid diagram. More...

Inheritance diagram for CXTPChart3dPyramidDiagram:
[legend]

Public Member Functions

CXTPChart3dPyramidDiagram ()
Constructs a CXTPChart3dPyramidDiagram object.
virtual CXTPChartDiagramView * | CreateView (CXTPChartDeviceContext *pDC, CXTPChartElementView *pParent)
Call this function to create the view of the pyramid diagram.
- Public Member Functions inherited from CXTPChartPyramidDiagramBase< BaseDiagram >
virtual void | CalculateSeriesLayout (CXTPChartDeviceContext *pDC, CXTPChartDiagramView *pView)
Call this function to calculate the pyramid series layout.

Additional Inherited Members

- Protected Member Functions inherited from CXTPChartPyramidDiagramBase< BaseDiagram >
CXTPChartPyramidDiagramBase ()
Constructs a CXTPChartPyramidDiagramBase object.

Detailed Description

This class abstracts the pyramid diagram.

This class is a kind of CXTPChartDiagram.

Member Function Documentation

◆ CreateView()

virtual CXTPChartDiagramView * CreateView | ( | CXTPChartDeviceContext * | pDC,
 |  | CXTPChartElementView * | pParent )
 virtual

Call this function to create the view of the pyramid diagram.

Parameters
pDC | A pointer to the chart device context.
pParent | A pointer to the parent view.
Returns
Returns a pointer to the associated diagram view object.

Implements CXTPChartPyramidDiagramBase< BaseDiagram >.

The documentation for this class was generated from the following file:
  • XTPChart3dPyramidDiagram.h


Toolkit Pro: CXTPChart3dPyramidDiagramView Class Reference

Public Member Functions | List of all members
CXTPChart3dPyramidDiagramView Class Reference

This class abstracts the view of a pyramid diagram. More...

Inheritance diagram for CXTPChart3dPyramidDiagramView:
[legend]

Public Member Functions

CXTPChart3dPyramidDiagramView (CXTPChartDiagram *pDiagram, CXTPChartElementView *pParent)
Constructs a CXTPChart3dPyramidDiagramView object.
- Public Member Functions inherited from CXTPChart3dDiagramView
CXTPChart3dDiagramView (CXTPChartDiagram *pDiagram, CXTPChartElementView *pParentView)
Constructs a CXTPChart3dDiagramView object.
virtual CXTPChartDeviceCommand * | CreateDeviceCommand (CXTPChartDeviceContext *pDC)
Creates a view device command.
- Public Member Functions inherited from CXTPChartDiagramView
CXTPChartDiagramView (CXTPChartDiagram *pDiagram, CXTPChartElementView *pParentView)
Constructs a CXTPChartDiagram object.
CRect | GetBounds () const
Call this function to get the bounds of the diagram.
CXTPChartDiagram * | GetDiagram () const
Call this function to get the diagram object associated with the view.
CXTPChartElementView * | GetLabelsView () const
Call this function to get the label view object associated with this diagram view.
CXTPChartElementView * | GetSeriesView () const
Call this function to get the series view object associated with this diagram view.
virtual void | CalculateView (CXTPChartDeviceContext *pDC, CRect rcBounds)
Call this function to calculate the view of the diagram.
virtual void | UpdateRange (CXTPChartDeviceContext *pDC)
Updates chart range.
virtual void | OnMouseWheel (UINT nFlags, short zDelta, CPoint pt)
Handles mouse wheel event.
virtual void | CreateView (CXTPChartDeviceContext *pDC)
Performs view initialization.
- Public Member Functions inherited from CXTPChartElementView
CXTPChartElementView (CXTPChartElementView *pParentView)
Constructs a CXTPChartElementView object.
CXTPChartElementView (CXTPChartElementView *pParentView, BOOL bAddToParent)
Constructs a CXTPChartElementView object.
CXTPChartElementView (CXTPChartContainer *pContainer)
Constructs a CXTPChartElementView object.
int | GetCount () const
Call this function to get the number of child views associated with this view.
CXTPChartElementView * | GetAt (int nIndex) const
Call this function to get a child view at a particular index.
CXTPChartElementView * | GetParentView () const
Call this function to get the parent view.
CXTPChartElementView * | AddChildView (CXTPChartElementView *pChildView)
Call this function to add a child view to the current view.
CXTPChartElementView ** GetChildren ()
Provides access to the collection of children elements owned by the view.
CRect | GetBounds () const
Obtains viewed object's bound rectangle.
CRect | GetBounds (BOOL bIncludingChildren) const
Obtains viewed object's bound rectangle.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Additional Inherited Members

- Public Attributes inherited from CXTPChartDiagramView
- Protected Member Functions inherited from CXTPChartDiagramView
- Protected Member Functions inherited from CXTPChartElementView
virtual | ~CXTPChartElementView ()
Destroys a CXTPChartElementView object, handles cleanup.
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.
- Protected Attributes inherited from CXTPChartDiagramView
CXTPChartDiagram * | m_pDiagram
Pointer to the associated diagram object.
CRect | m_rcBounds
The diagram bounds.
CXTPChartElementView * | m_pLabelsView
The label view.
CXTPChartElementView * | m_pSeriesView
The series view.
CXTPChartElementView * | m_pTitlesView
Titles View.
- Protected Attributes inherited from CXTPChartElementView
CArray< CXTPChartElementView *, CXTPChartElementView * > | m_arrChildren
The child view collection.
CXTPChartElementView * | m_pParentView
The parent view.
CXTPChartContainer * | m_pContainer
The parent container.
CRect | m_rcBounds
Bounding rectangle.

Detailed Description

This class abstracts the view of a pyramid diagram.

This class is a kind of CXTPChartDiagramView.

A pyramid chart (or a circle graph) is a circular chart divided into sectors, illustrating percents. In a pyramid chart, the arc length of each sector (and consequently its central angle and area), is proportional to the quantity it represents. Together, the sectors create a full disk.

Constructor & Destructor Documentation

◆ CXTPChart3dPyramidDiagramView()

CXTPChart3dPyramidDiagramView | ( | CXTPChartDiagram * | pDiagram,
 |  | CXTPChartElementView * | pParent )

Constructs a CXTPChart3dPyramidDiagramView object.

Parameters
pDiagram | A pointer to the pyramid diagram object.
pParent | A pointer to the parent view.
The documentation for this class was generated from the following file:
  • XTPChart3dPyramidDiagramView.h


Toolkit Pro: CXTPChart3dPyramidSeriesLabel Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPChart3dPyramidSeriesLabel Class Reference

CXTPChartPyramidSeriesLabelBase is a kind of CXTPChart3dPyramidSeriesLabel. More...

Inheritance diagram for CXTPChart3dPyramidSeriesLabel:
[legend]

Public Member Functions

CXTPChart3dPyramidSeriesLabel ()
Constructs a CXTPChart3dPyramidSeriesLabel object.
- Public Member Functions inherited from CXTPChartPyramidSeriesLabelBase
CXTPChartPyramidSeriesLabelBase ()
Constructs a CXTPChartPyramidSeriesLabelBase object.
virtual | ~CXTPChartPyramidSeriesLabelBase ()
Destroys a CXTPChartPyramidSeriesLabelBase object, handles cleanup.
XTPChartPyramidLabelPosition | GetPosition () const
Call this function to get the label position.
void | SetPosition (XTPChartPyramidLabelPosition nPosition)
Call this function to set the label position.
CXTPChartPyramidSeriesStyleBase * | GetStyle () const
Call this function to get the basic style of the pyramid series.
void | DoPropExchange (CXTPPropExchange *pPX)
Call this member function to Store/Load the properties of content using the specified data object.
BOOL | IsInside () const
Call this function to check whether the label is inside the pyramid.
- Public Member Functions inherited from CXTPChartSeriesLabel
CXTPChartSeriesLabel ()
Constructs a CXTPChartSeriesLabel object.
virtual | ~CXTPChartSeriesLabel ()
Destroys a CXTPChartSeriesLabel object, handles cleanup.
void | SetTextColor (const CXTPChartColor &clrTextColor)
Call this function to set the text color of the label.
CXTPChartColor | GetTextColor () const
Call this function to get the apparent text color of the label.
CXTPChartFont * | GetFont () const
Call this function to get the font of the text label.
void | SetFont (CXTPChartFont *pFont)
Call this function to set the font of the text label.
void | SetShowLines (BOOL bShowLines)
Call this function to set the lines visibility.
BOOL | GetShowLines () const
Call this function to check if the lines are visible.
void | SetLineLength (int nLineLength)
Call this function to set the line length.
int | GetLineLength () const
Call this function to get the line length.
void | SetVisible (BOOL bVisible)
Call this function to set the label visibility.
BOOL | IsVisible () const
Call this function to check if the label is visible.
void | SetAntialiasing (BOOL bAntialiasing)
Call this function to set anti-aliasing ON or OFF.
BOOL | GetAntialiasing () const
Call this function to check if anti-aliasing is ON or OFF.
CXTPChartNumberFormat * | GetFormat () const
Call this function to get a pointer to CXTPChartNumberFormat that specifies how to convert numbers to strings.
void | SetFormat (LPCTSTR lpszFormat)
Obsolete method.
void | SetBackColor (const CXTPChartColor &clrBackColor)
Call this function to set the text color of the label.
CXTPChartColor | GetBackColor () const
Call this function to get the apparent text color of the label.
void | SetLineColor (const CXTPChartColor &clrBackColor)
Call this function to set the text color of the label.
CXTPChartColor | GetLineColor () const
Call this function to get the apparent text color of the label.
int | GetTransparency () const
Call this function to get the transparency of the filled area with respect to the background.
void | SetTransparency (int nTransparency)
Call this function to set the transparency of the filled area with respect to the background.
- Public Member Functions inherited from CXTPChartTextElement
- Public Member Functions inherited from CXTPChartElement
CXTPChartElement ()
Constructs a CXTPChartElement object.
virtual | ~CXTPChartElement ()
Destroys a CXTPChartElement object, handles cleanup.
virtual void | Release ()
Call this function to decrease the usage count of the object.
CXTPChartElement * | GetOwner () const
Call this function to get the owner element.
virtual void | OnChartChanged (XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic properties of the chart.
CXTPChartContent * | GetContent () const
Call this virtual function to get the chart content object.
CXTPChartAppearance * | GetAppearance () const
Call this function to get the the appearance of the chart.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Protected Member Functions

virtual CXTPChartElementView * CreateView (CXTPChartDeviceContext *pDC, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView)
This function creates the view of the pyramid series.
- Protected Member Functions inherited from CXTPChartPyramidSeriesLabelBase
- Protected Member Functions inherited from CXTPChartSeriesLabel
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.

Additional Inherited Members

- Public Attributes inherited from CXTPChartElement
- Protected Attributes inherited from CXTPChartPyramidSeriesLabelBase
XTPChartPyramidLabelPosition | m_nPosition
The pyramid label position.
- Protected Attributes inherited from CXTPChartSeriesLabel
CXTPChartColor | m_clrTextColor
The text color.
CXTPChartColor | m_clrBackColor
The background color.
CXTPChartColor | m_clrLineColor
The line color.
BOOL | m_bVisible
TRUE if the label is visible and FALSE if not.
CXTPChartFont * | m_pFont
The font of the label.
BOOL | m_bAntialiasing
TRUE if antialiasing enabled, FALSE if not.
BOOL | m_bShowLines
TRUE if the lines are visible, FALSE if not.
int | m_nLineLength
The line length.
CXTPChartBorder * | m_pBorder
Chart border object.
int | m_nTransparency
The transparency values range from 0 to 255.
- Protected Attributes inherited from CXTPChartElement

Detailed Description

CXTPChartPyramidSeriesLabelBase is a kind of CXTPChart3dPyramidSeriesLabel.

This class abstracts the label of a pyramid series.

Member Function Documentation

◆ CreateView()

virtual CXTPChartElementView * CreateView | ( | CXTPChartDeviceContext * | pDC,
 |  | CXTPChartSeriesPointView * | pPointView,
 |  | CXTPChartElementView * | pParentView )
 protectedvirtual

This function creates the view of the pyramid series.

Parameters
pDC | The chart device context object pointer.
pPointView | The series point view.
pParentView | Parent element view pointer.
Returns
Returns a pointer to the associated label view object.

Implements CXTPChartPyramidSeriesLabelBase.

The documentation for this class was generated from the following file:
  • XTPChart3dPyramidSeriesLabel.h


Toolkit Pro: CXTPChart3dPyramidSeriesLabelDeviceCommand Class Reference

Public Member Functions | List of all members
CXTPChart3dPyramidSeriesLabelDeviceCommand Class Reference

Implements 3D chart pyramid series label device command. More...

Inheritance diagram for CXTPChart3dPyramidSeriesLabelDeviceCommand:
[legend]

Public Member Functions

CXTPChart3dPyramidSeriesLabelDeviceCommand (CXTPChart3dPyramidSeriesLabelView *pSeriesLabelView)
Constructs a CXTPChart3dPyramidSeriesLabelDeviceCommand object.
virtual void | ExecuteOverride (CXTPChartDeviceContext *pDC)
Override this function to write the drawing code for specific objects.
CXTPChart3dPyramidSeriesLabelView * | GetSeriesLabelView () const
Obtains the label view object pointer.
BOOL | IsFailed () const
Checks whether the command object is in a failed state.
void | SetFailed ()
Sets the command object to a failed state.
CRect | GetLabelRect () const
Obtains the label rectangle.
void | SetLabelRect (CRect rcLabel)
Sets the label rectangle.
BOOL | ComputeConnectorVector (CXTPChart3dDeviceContext *pDC)
Computes the connector vector.
void | ComputeLabel (CXTPChart3dDeviceContext *pDC)
Computes label.
double | GetConnectorLength () const
Determines the connector length value.
void | SetConnectorLength (double dLength)
Sets the connector length value.
double | GetConnectorEndpointVerticalOffset () const
Determines the connector endpoint vertical offset value.
void | SetConnectorEndpointVerticalOffset (double yOffset)
Sets the connector endpoint vertical offset value.
- Public Member Functions inherited from CXTPChart3dDeviceCommand
virtual BOOL | IsEnabled () const
Determines if the command is currently enabled.
- Public Member Functions inherited from CXTPChartDeviceCommand
CXTPChartDeviceCommand ()
Constructs a CXTPChartDeviceCommand object.
virtual | ~CXTPChartDeviceCommand ()
Destroys a CXTPChartDeviceCommand object, handles cleanup.
BOOL | IsCommitted () const
Determines if the execution of the command has been committed.
void | Commit ()
Commits the execution of the command.
int | GetChildCommandCount () const
Obtains the number of immediate children commands.
CXTPChartDeviceCommand * | GetChildCommand (int nIndex) const
Obtains immediate child command point by index.
CXTPChartDeviceCommand * | AddChildCommand (CXTPChartDeviceCommand *pCommand)
Call this function to add a child device command.
virtual void | Execute (CXTPChartDeviceContext *pDC)
Call this function to execute the drawing.
virtual void | BeforeExecute (CXTPChartDeviceContext *pDC)
This method gets called before a command is executed which allows for the customization of command behavior.
virtual void | AfterExecute (CXTPChartDeviceContext *pDC)
This method gets called after a command is executed which allows for the customization of command behavior.
UINT | GetPassNumber () const
Get the number of executions made by the command.
virtual CXTPChartElement * | HitTest (CPoint point, CXTPChartElement *pParent) const
Performs recursive hit testing of the element at the specified point.
virtual void | ApplySeriesStyle (CXTPChartSeriesStyle *pStyle)
Applies series style to the current element.
virtual void | Prepare (CXTPChartDeviceContext *pDC)
Performs inital preparation steps necessary for successful command execution.
virtual void | PrepareOverride (CXTPChartDeviceContext *pDC)
Derived implementation must override this method for implementing implementation specific preparation behavior.
void | SetEnabled (BOOL bEnabled=TRUE)
Enables/disable the command.
CXTPChartDeviceContext * | GetCurrentDC () const
Obtains device context pointer for which the command is currenly being prepared or executed.
void | BindView (CXTPChartElementView *pView)
Binds a view to the command object.
CXTPChartElementView * | GetBoundView () const
Obtains a bound view pointer or NULL if no view is bound.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.
- Public Member Functions inherited from CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents >
void | Subscribe (CXTPChartDeviceCommandEvents *pObserver, CXTPSubscriptionList< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > *pSubcriptionList=NULL)
Subscribes a unique observer for events.
void | Unsubscribe (CXTPChartDeviceCommandEvents *pObserver)
Unsubscribes an observer from events.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *))
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *))
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.

Additional Inherited Members

- Protected Member Functions inherited from CXTPChart3dDeviceCommand
CXTPChart3dDeviceCommand (XTPChart3dAntialiasingPolicy nAntialiasingPolicy)
Constructs a CXTPChart3dDeviceCommand object.
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.
- Protected Member Functions inherited from CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents >
CXTPObservable ()
Constructs an observable object.
~CXTPObservable ()
Handles observable object destruction.
- Protected Attributes inherited from CXTPChartDeviceCommand
CArray< CXTPChartDeviceCommand *, CXTPChartDeviceCommand * > m_arrChildren
< The array of child device commands.

Detailed Description

Implements 3D chart pyramid series label device command.

Constructor & Destructor Documentation

◆ CXTPChart3dPyramidSeriesLabelDeviceCommand()

CXTPChart3dPyramidSeriesLabelDeviceCommand ( CXTPChart3dPyramidSeriesLabelView * pSeriesLabelView )

Constructs a CXTPChart3dPyramidSeriesLabelDeviceCommand object.

Parameters
pSeriesLabelView Associated series label view pointer.

Member Function Documentation

◆ ComputeConnectorVector()

BOOL ComputeConnectorVector ( CXTPChart3dDeviceContext * pDC )

Computes the connector vector.

Parameters
pDC Target device context pointer.
Returns
TRUE if the vector is successfully computed, FALSE otherwise.

◆ ComputeLabel()

void ComputeLabel ( CXTPChart3dDeviceContext * pDC )

Computes label.

Parameters
pDC Target device context pointer.

◆ ExecuteOverride()

virtual void ExecuteOverride ( CXTPChartDeviceContext * pDC )
virtual

Override this function to write the drawing code for specific objects.

Parameters
pDC A pointer to the chart device context.

Reimplemented from CXTPChartDeviceCommand.

◆ GetConnectorEndpointVerticalOffset()

AFX_INLINE double GetConnectorEndpointVerticalOffset ( ) const

Determines the connector endpoint vertical offset value.

Returns
Connector endpoint vertical offset value.
See also
SetConnectorEndpointVerticalOffset

◆ GetConnectorLength()

AFX_INLINE double GetConnectorLength ( ) const

Determines the connector length value.

Returns
Connector length value.
See also
SetConnectorLength

◆ GetLabelRect()

AFX_INLINE CRect GetLabelRect ( ) const

Obtains the label rectangle.

Returns
Label rectangle.
See also
SetLabelRect

◆ GetSeriesLabelView()

AFX_INLINE CXTPChart3dPyramidSeriesLabelView * GetSeriesLabelView ( ) const

Obtains the label view object pointer.

Returns
Label view object pointer.

◆ IsFailed()

AFX_INLINE BOOL IsFailed ( ) const

Checks whether the command object is in a failed state.

Returns
TRUE if the command object is in a failed state, FALSE otherwise.
See also
SetFailed

◆ SetConnectorEndpointVerticalOffset()

AFX_INLINE void SetConnectorEndpointVerticalOffset ( double yOffset )

Sets the connector endpoint vertical offset value.

Parameters
yOffset New connector endpoint vertical offset value.
See also
GetConnectorEndpointVerticalOffset

◆ SetConnectorLength()

AFX_INLINE void SetConnectorLength ( double dLength )

Sets the connector length value.

Parameters
dLength New connector length value.
See also
GetConnectorLength

◆ SetLabelRect()

AFX_INLINE void SetLabelRect ( CRect rcLabel )

Sets the label rectangle.

Parameters
rcLabel Label rectangle.
See also
GetLabelRect
The documentation for this class was generated from the following file:
  • XTPChart3dPyramidSeriesLabelsViewDeviceCommand.h


Toolkit Pro: CXTPChart3dPyramidSeriesLabelsView Class Reference

Public Member Functions | List of all members
CXTPChart3dPyramidSeriesLabelsView Class Reference

Represents a view object for all pyramid series labels. More...

Inheritance diagram for CXTPChart3dPyramidSeriesLabelsView:
[legend]

Public Member Functions

CXTPChart3dPyramidSeriesLabelsView (CXTPChartElementView *pParentView)
Constructs view object.
virtual CXTPChartDeviceCommand * | CreateDeviceCommand (CXTPChartDeviceContext *pDC)
Creates view drawing device command for the device context specified.
void | ResolveOverlapping ()
Resolves label overlapping in an implementation specific way.
- Public Member Functions inherited from CXTPChartElementView
CXTPChartElementView (CXTPChartElementView *pParentView)
Constructs a CXTPChartElementView object.
CXTPChartElementView (CXTPChartElementView *pParentView, BOOL bAddToParent)
Constructs a CXTPChartElementView object.
CXTPChartElementView (CXTPChartContainer *pContainer)
Constructs a CXTPChartElementView object.
int | GetCount () const
Call this function to get the number of child views associated with this view.
CXTPChartElementView * | GetAt (int nIndex) const
Call this function to get a child view at a particular index.
CXTPChartElementView * | GetParentView () const
Call this function to get the parent view.
CXTPChartElementView * | AddChildView (CXTPChartElementView *pChildView)
Call this function to add a child view to the current view.
CXTPChartElementView ** GetChildren ()
Provides access to the collection of children elements owned by the view.
CRect | GetBounds () const
Obtains viewed object's bound rectangle.
CRect | GetBounds (BOOL bIncludingChildren) const
Obtains viewed object's bound rectangle.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Additional Inherited Members

- Protected Member Functions inherited from CXTPChartElementView
virtual | ~CXTPChartElementView ()
Destroys a CXTPChartElementView object, handles cleanup.
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.
- Protected Attributes inherited from CXTPChartElementView
CArray< CXTPChartElementView *, CXTPChartElementView * > | m_arrChildren
The child view collection.
CXTPChartElementView * | m_pParentView
The parent view.
CXTPChartContainer * | m_pContainer
The parent container.
CRect | m_rcBounds
Bounding rectangle.

Detailed Description

Represents a view object for all pyramid series labels.

Constructor & Destructor Documentation

◆ CXTPChart3dPyramidSeriesLabelsView()

CXTPChart3dPyramidSeriesLabelsView ( CXTPChartElementView * pParentView )

Constructs view object.

Parameters
pParentView Parent view pointer.

Member Function Documentation

◆ CreateDeviceCommand()

virtual CXTPChartDeviceCommand * CreateDeviceCommand ( CXTPChartDeviceContext * pDC )
virtual

Creates view drawing device command for the device context specified.

Parameters
pDC Device context pointer for which the drawing command is to be created.
Returns
A new instance of view drawing device command or NULL if no command is provided.

Reimplemented from CXTPChartElementView.

The documentation for this class was generated from the following file:
  • XTPChart3dPyramidSeriesLabel.h


Toolkit Pro: CXTPChart3dPyramidSeriesLabelsViewDeviceCommand Class Reference

Public Member Functions | List of all members
CXTPChart3dPyramidSeriesLabelsViewDeviceCommand Class Reference

Represents device command for all pyramid series labels view. More...

Inheritance diagram for CXTPChart3dPyramidSeriesLabelsViewDeviceCommand:
[legend]

Public Member Functions

CXTPChart3dPyramidSeriesLabelsViewDeviceCommand (CXTPChart3dPyramidSeriesLabelsView *pSeriesLabelsView)
Constructs a command object instance.
virtual void | ExecuteOverride (CXTPChartDeviceContext *pDC)
Override this function to write the drawing code for specific objects.
- Public Member Functions inherited from CXTPChart3dDeviceCommand
virtual BOOL | IsEnabled () const
Determines if the command is currently enabled.
- Public Member Functions inherited from CXTPChartDeviceCommand
CXTPChartDeviceCommand ()
Constructs a CXTPChartDeviceCommand object.
virtual | ~CXTPChartDeviceCommand ()
Destroys a CXTPChartDeviceCommand object, handles cleanup.
BOOL | IsCommitted () const
Determines if the execution of the command has been committed.
void | Commit ()
Commits the execution of the command.
int | GetChildCommandCount () const
Obtains the number of immediate children commands.
CXTPChartDeviceCommand * | GetChildCommand (int nIndex) const
Obtains immediate child command point by index.
CXTPChartDeviceCommand * | AddChildCommand (CXTPChartDeviceCommand *pCommand)
Call this function to add a child device command.
virtual void | Execute (CXTPChartDeviceContext *pDC)
Call this function to execute the drawing.
virtual void | BeforeExecute (CXTPChartDeviceContext *pDC)
This method gets called before a command is executed which allows for the customization of command behavior.
virtual void | AfterExecute (CXTPChartDeviceContext *pDC)
This method gets called after a command is executed which allows for the customization of command behavior.
UINT | GetPassNumber () const
Get the number of executions made by the command.
virtual CXTPChartElement * | HitTest (CPoint point, CXTPChartElement *pParent) const
Performs recursive hit testing of the element at the specified point.
virtual void | ApplySeriesStyle (CXTPChartSeriesStyle *pStyle)
Applies series style to the current element.
virtual void | Prepare (CXTPChartDeviceContext *pDC)
Performs inital preparation steps necessary for successful command execution.
virtual void | PrepareOverride (CXTPChartDeviceContext *pDC)
Derived implementation must override this method for implementing implementation specific preparation behavior.
void | SetEnabled (BOOL bEnabled=TRUE)
Enables/disable the command.
CXTPChartDeviceContext * | GetCurrentDC () const
Obtains device context pointer for which the command is currenly being prepared or executed.
void | BindView (CXTPChartElementView *pView)
Binds a view to the command object.
CXTPChartElementView * | GetBoundView () const
Obtains a bound view pointer or NULL if no view is bound.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.
- Public Member Functions inherited from CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents >
void | Subscribe (CXTPChartDeviceCommandEvents *pObserver, CXTPSubscriptionList< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > *pSubcriptionList=NULL)
Subscribes a unique observer for events.
void | Unsubscribe (CXTPChartDeviceCommandEvents *pObserver)
Unsubscribes an observer from events.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *))
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *))
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.

Additional Inherited Members

- Protected Member Functions inherited from CXTPChart3dDeviceCommand
CXTPChart3dDeviceCommand (XTPChart3dAntialiasingPolicy nAntialiasingPolicy)
Constructs a CXTPChart3dDeviceCommand object.
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.
- Protected Member Functions inherited from CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents >
CXTPObservable ()
Constructs an observable object.
~CXTPObservable ()
Handles observable object destruction.
- Protected Attributes inherited from CXTPChartDeviceCommand
CArray< CXTPChartDeviceCommand *, CXTPChartDeviceCommand * > m_arrChildren
< The array of child device commands.

Detailed Description

Represents device command for all pyramid series labels view.

Constructor & Destructor Documentation

◆ CXTPChart3dPyramidSeriesLabelsViewDeviceCommand()

CXTPChart3dPyramidSeriesLabelsViewDeviceCommand ( CXTPChart3dPyramidSeriesLabelsView * pSeriesLabelsView )

Constructs a command object instance.

Parameters
pSeriesLabelsView View pointer.

Member Function Documentation

◆ ExecuteOverride()

virtual void ExecuteOverride ( CXTPChartDeviceContext * pDC )
virtual

Override this function to write the drawing code for specific objects.

Parameters
pDC A pointer to the chart device context.

Reimplemented from CXTPChartDeviceCommand.

The documentation for this class was generated from the following file:
  • XTPChart3dPyramidSeriesLabelsViewDeviceCommand.h


Toolkit Pro: CXTPChart3dPyramidSeriesLabelView Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPChart3dPyramidSeriesLabelView Class Reference

Represents series label view object. More...

Inheritance diagram for CXTPChart3dPyramidSeriesLabelView:
[legend]

Public Member Functions

CXTPChart3dPyramidSeriesLabelView (CXTPChartSeriesLabel *pLabel, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView)
Constructs a view object.
~CXTPChart3dPyramidSeriesLabelView ()
Handles view object destruction.
virtual CXTPChartDeviceCommand * | CreateTranspositionDeviceCommand (CXTPChartDeviceContext *pDC)
Creates a label transposition device command object.
virtual CXTPChartDeviceCommand * | CreateDeviceCommand (CXTPChartDeviceContext *pDC)
Creates a label drawing device command object.
virtual CXTPChartDeviceCommand * | CreateConnectorDeviceCommand (CXTPChartDeviceContext *pDC)
Creates a label connector drawing device command object.
const CXTPPoint3d * | GetConnectorStartPoint () const
Obtains a previously set connector start point.
void | SetConnectorStartPoint (const CXTPPoint3d &point)
Sets the connector start point.
const CXTPPoint3d * | GetConnectorBendPoint () const
Obtains a previously set connector bend point.
void | SetConnectorBendPoint (const CXTPPoint3d &point)
Sets the connector bend point.
const CXTPPoint3d * | GetConnectorEndPoint () const
Obtains a previously set connector end point.
void | SetConnectorEndPoint (const CXTPPoint3d &point)
Sets the connector end point.
const CPoint * | GetLabelAnchorPoint () const
Obtains a previously set label anchor point.
void | SetLabelAnchorPoint (CPoint ptAnchor)
Sets the label anchor point.
const CPoint * | GetLabelAnchorOrigin () const
Obtains a previously set label anchor origin point.
void | SetLabelAnchorOrigin (CPoint ptAnchorOrigin)
Sets the label anchor origin point.
void | SetLeftDirected ()
Makes the label left directed.
BOOL | IsLeftDirected () const
Determies if the label is left directed.
void | SetRightDirected ()
Makes the label right directed.
BOOL | IsRightDirected () const
Determies if the label is right directed.
BOOL | IsConnectorVisible () const
Determines if the connector is visible.
void | SetConnectorVisible (BOOL bVisible=TRUE)
Sets connector visibility.
- Public Member Functions inherited from CXTPChartPyramidSeriesLabelViewBase
XTPChartPyramidLabelPosition | GetPosition () const
Obtains label position.

Protected Attributes

CXTPPoint3d * | m_ptStart
Connector start point or NULL if not set.
CXTPPoint3d * | m_ptBend
Connector bend point or NULL if not set.
CXTPPoint3d * | m_ptEnd
Connector end point or NULL if not set.
CPoint | m_ptLabelAnchor
Label anchor point.
CPoint | m_ptLabelAnchorOrigin
Label anchor point origin.
CXTPChart3dPyramidSeriesPointView * | m_p3dPointView
Point view.
BOOL | m_bLeftDirected
TRUE if label is to be left directed.
BOOL | m_bConnectorVisible
TRUE if connector is visible.

Additional Inherited Members

- Protected Member Functions inherited from CXTPChartPyramidSeriesLabelViewBase
CXTPChartPyramidSeriesLabelViewBase (CXTPChartSeriesLabel *pLabel, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView)
Constructs a CXTPChartPyramidSeriesLabelViewBase object.

Detailed Description

Represents series label view object.

Constructor & Destructor Documentation

◆ CXTPChart3dPyramidSeriesLabelView()

CXTPChart3dPyramidSeriesLabelView | ( | CXTPChartSeriesLabel * | pLabel,
 |  | CXTPChartSeriesPointView * | pPointView,
 |  | CXTPChartElementView * | pParentView )

Constructs a view object.

Parameters
pLabel | Label model object pointer.
pPointView | Related point view object pointer.
pParentView | Parent view object pointer.

Member Function Documentation

◆ CreateConnectorDeviceCommand()

virtual CXTPChartDeviceCommand * CreateConnectorDeviceCommand ( CXTPChartDeviceContext * pDC )
virtual

Creates a label connector drawing device command object.

Parameters
pDC Target device context.
Returns
New label connector drawing device command object.

◆ CreateDeviceCommand()

virtual CXTPChartDeviceCommand * CreateDeviceCommand ( CXTPChartDeviceContext * pDC )
virtual

Creates a label drawing device command object.

Parameters
pDC Target device context.
Returns
New label drawing device command object.

Implements CXTPChartPyramidSeriesLabelViewBase.

◆ CreateTranspositionDeviceCommand()

virtual CXTPChartDeviceCommand * CreateTranspositionDeviceCommand ( CXTPChartDeviceContext * pDC )
virtual

Creates a label transposition device command object.

Parameters
pDC Target device context.
Returns
New label transposition device command object.

◆ GetConnectorBendPoint()

AFX_INLINE const CXTPPoint3d * GetConnectorBendPoint ( ) const

Obtains a previously set connector bend point.

Returns
Connector bend point or NULL if not set.
See also
SetConnectorBendPoint

◆ GetConnectorEndPoint()

AFX_INLINE const CXTPPoint3d * GetConnectorEndPoint ( ) const

Obtains a previously set connector end point.

Returns
Connector end point or NULL if not set.
See also
SetConnectorEndPoint

◆ GetConnectorStartPoint()

AFX_INLINE const CXTPPoint3d * GetConnectorStartPoint ( ) const

Obtains a previously set connector start point.

Returns
Connector start point or NULL if not set.
See also
SetConnectorStartPoint

◆ GetLabelAnchorOrigin()

const CPoint * GetLabelAnchorOrigin ( ) const

Obtains a previously set label anchor origin point.

Returns
Label anchor origin point or NULL if not set.
See also
SetLabelAnchorOrigin

◆ GetLabelAnchorPoint()

const CPoint * GetLabelAnchorPoint ( ) const

Obtains a previously set label anchor point.

Returns
Label anchor point or NULL if not set.
See also
SetLabelAnchorPoint

◆ IsConnectorVisible()

AFX_INLINE BOOL IsConnectorVisible ( ) const

Determines if the connector is visible.

Returns
TRUE if connector is visible, FALSE otherwise.
See also
SetConnectorVisible

◆ IsLeftDirected()

AFX_INLINE BOOL IsLeftDirected ( ) const

Determies if the label is left directed.

Returns
TRUE if left directed, FALSE otherwise.
See also
SetLeftDirected

◆ IsRightDirected()

AFX_INLINE BOOL IsRightDirected ( ) const

Determies if the label is right directed.

Returns
TRUE if right directed, FALSE otherwise.
See also
SetRightDirected

◆ SetConnectorBendPoint()

void SetConnectorBendPoint ( const CXTPPoint3d & point )

Sets the connector bend point.

Parameters
point New value of the connector bend point.
See also
GetConnectorBendPoint

◆ SetConnectorEndPoint()

void SetConnectorEndPoint ( const CXTPPoint3d & point )

Sets the connector end point.

Parameters
point New value of the connector end point.
See also
GetConnectorEndPoint

◆ SetConnectorStartPoint()

void SetConnectorStartPoint ( const CXTPPoint3d & point )

Sets the connector start point.

Parameters
point New value of the connector start point.
See also
GetConnectorStartPoint

◆ SetConnectorVisible()

AFX_INLINE void SetConnectorVisible ( BOOL bVisible = TRUE )

Sets connector visibility.

Parameters
bVisible TRUE for making connector visible, FALSE otherwise.
See also
SetConnectorVisible

◆ SetLabelAnchorOrigin()

AFX_INLINE void SetLabelAnchorOrigin ( CPoint ptAnchorOrigin )

Sets the label anchor origin point.

Parameters
ptAnchorOrigin New value of the label anchor origin point.
See also
GetLabelAnchorOrigin

◆ SetLabelAnchorPoint()

AFX_INLINE void SetLabelAnchorPoint ( CPoint ptAnchor )

Sets the label anchor point.

Parameters
ptAnchor New value of the label anchor point.
See also
GetLabelAnchorPoint

◆ SetLeftDirected()

AFX_INLINE void SetLeftDirected ( )

Makes the label left directed.

See also
IsLeftDirected

◆ SetRightDirected()

AFX_INLINE void SetRightDirected ( )

Makes the label right directed.

See also
IsRightDirected
The documentation for this class was generated from the following file:
  • XTPChart3dPyramidSeriesLabel.h


Toolkit Pro: CXTPChart3dPyramidSeriesPointView Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPChart3dPyramidSeriesPointView Class Reference

This class abstracts the view of a pyramid series point. More...

Inheritance diagram for CXTPChart3dPyramidSeriesPointView:
[legend]

Public Member Functions

CXTPChart3dPyramidSeriesPointView (CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Constructs a CXTPChart3dPyramidSeriesPointView object.
virtual | ~CXTPChart3dPyramidSeriesPointView ()
Handles view destruction.
virtual void | CalculateLayout (int nIndex, int nCount, double dFrom, double dTo)
Use this function to calculate the layout of the pyramid series point.
const CXTPPoint3d & | GetCenterShapeConnectorPoint () const
Obtains the shape center connector point.
const CXTPPoint3d & | GetOuterCenterConnectorPoint () const
Obtains the outer shape center connector point.
- Public Member Functions inherited from CXTPChartPyramidSeriesPointViewBase
CXTPChartPyramidSeriesPointViewBase (CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Constructs a CXTPChartPyramidSeriesPointViewBase object.
CXTPChartPyramidSeriesPointViewBase (CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView, BOOL bAddToParent)
Constructs a CXTPChartPyramidSeriesPointViewBase object.
virtual | ~CXTPChartPyramidSeriesPointViewBase ()
Destroys a CXTPChartPyramidSeriesPointViewBase object, handles cleanup.
CXTPChartColor | GetBorderActualColor () const
Use this function to obtain the color value of the pyramid border.
- Public Member Functions inherited from CXTPChartSeriesPointView
CXTPChartSeriesPointView (CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Constructs the view object.
CXTPChartSeriesPointView (CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView, BOOL bAddToParent)
Constructs the view object.
CXTPChartSeriesPoint * | GetPoint () const
Obtains point model object.
CXTPChartSeriesView * | GetSeriesView () const
Obtains parent series view.
CXTPChartColor | GetColor () const
Obtain view color values.
CXTPChartColor | GetColor2 () const
Obtain view color values.
double | GetInternalValue () const
Obtains point interval value.
virtual CXTPChartString | GetLegendName () const
This function returns the legend name.
virtual void | UpdateMinMaxRange (double &nMinValue, double &nMaxValue) const
Provides a default empty implementation for min/max range update request.
- Public Member Functions inherited from CXTPChartElementView
CXTPChartElementView (CXTPChartElementView *pParentView)
Constructs a CXTPChartElementView object.
CXTPChartElementView (CXTPChartElementView *pParentView, BOOL bAddToParent)
Constructs a CXTPChartElementView object.
CXTPChartElementView (CXTPChartContainer *pContainer)
Constructs a CXTPChartElementView object.
int | GetCount () const
Call this function to get the number of child views associated with this view.
CXTPChartElementView * | GetAt (int nIndex) const
Call this function to get a child view at a particular index.
CXTPChartElementView * | GetParentView () const
Call this function to get the parent view.
CXTPChartElementView * | AddChildView (CXTPChartElementView *pChildView)
Call this function to add a child view to the current view.
CXTPChartElementView ** GetChildren ()
Provides access to the collection of children elements owned by the view.
CRect | GetBounds () const
Obtains viewed object's bound rectangle.
CRect | GetBounds (BOOL bIncludingChildren) const
Obtains viewed object's bound rectangle.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.
- Public Member Functions inherited from CXTPChartLegendItemView
virtual | ~CXTPChartLegendItemView ()
Handles object destruction.

Protected Member Functions

virtual CXTPChartDeviceCommand * | CreateDeviceCommand (CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
virtual CXTPChartDeviceCommand * | CreateLegendDeviceCommand (CXTPChartDeviceContext *pDC, CRect rcBounds)
This function creates a label view drawing command object.
virtual void | OnUpdateBounds (CXTPChartDeviceCommand *pCommand, CRect rcBounds)
Notifies about updated boundaries of the command result.
virtual void | OnSetConnectorPoints (CXTPChartDeviceCommand *pCommand, CXTPPoint3d ptShapeCenter, CXTPPoint3d ptOuterCenter)
Gets called when pyramid connector points are computed.
- Protected Member Functions inherited from CXTPChartPyramidSeriesPointViewBase
- Protected Member Functions inherited from CXTPChartElementView
virtual | ~CXTPChartElementView ()
Destroys a CXTPChartElementView object, handles cleanup.
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.

Additional Inherited Members

- Public Attributes inherited from CXTPChartSeriesPointView
double | m_dInternalValue
Point internal value.
- Protected Attributes inherited from CXTPChartPyramidSeriesPointViewBase
double | m_dValue
The value of the point.
- Protected Attributes inherited from CXTPChartSeriesPointView
CXTPChartSeriesPoint * | m_pPoint
Point model object pointer.
- Protected Attributes inherited from CXTPChartElementView
CArray< CXTPChartElementView *, CXTPChartElementView * > | m_arrChildren
The child view collection.
CXTPChartElementView * | m_pParentView
The parent view.
CXTPChartContainer * | m_pContainer
The parent container.
CRect | m_rcBounds
Bounding rectangle.

Detailed Description

This class abstracts the view of a pyramid series point.

This class is a kind of CXTPChartSeriesPointView.

A pyramid chart (or a circle graph) is a circular chart divided into sectors, illustrating percents. In a pyramid chart, the arc length of each sector (and consequently its central angle and area), is proportional to the quantity it represents. Together, the sectors create a full disk.

Constructor & Destructor Documentation

◆ CXTPChart3dPyramidSeriesPointView()

CXTPChart3dPyramidSeriesPointView | ( | CXTPChartSeriesPoint * | pPoint,
 |  | CXTPChartElementView * | pParentView )

Constructs a CXTPChart3dPyramidSeriesPointView object.

Parameters
pPoint | Pointer to the chart series point.
pParentView | Parent element view pointer.

Member Function Documentation

◆ CalculateLayout()

virtual void CalculateLayout | ( | int | nIndex,
 |  | int | nCount,
 |  | double | dFrom,
 |  | double | dTo )
 virtual

Use this function to calculate the layout of the pyramid series point.

Parameters
nIndex | Point index.
nCount | Total number of points.
dFrom | The percentage factor value in the range 0..1 of the inital pyramid point value.
dTo | The percentage factor value in the range 0..1 of the final pyramid point value.

Implements CXTPChartPyramidSeriesPointViewBase.

◆ CreateDeviceCommand()

virtual CXTPChartDeviceCommand * CreateDeviceCommand ( CXTPChartDeviceContext * pDC )
protectedvirtual

This function creates a CXTPChartDeviceCommand object.

This object represents the rendering of the pyramid series point.

Parameters
pDC Pointer to a CXTPChartDeviceContext object.
Returns
Returns a CXTPChartDeviceCommand object. This object handles the rendering of an element in the chart. Here it handles the drawing of the pyramid series point.

Implements CXTPChartPyramidSeriesPointViewBase.

◆ CreateLegendDeviceCommand()

virtual CXTPChartDeviceCommand * CreateLegendDeviceCommand | ( | CXTPChartDeviceContext * | pDC,
 |  | CRect | rcBounds )
 protectedvirtual

This function creates a label view drawing command object.

Parameters
pDC | Pointer to a CXTPChartDeviceContext object.
rcBounds | The rectangular boundary of the legend.
Returns
Returns a new label view drawing command object.

Reimplemented from CXTPChartPyramidSeriesPointViewBase.

◆ GetCenterShapeConnectorPoint()

AFX_INLINE const CXTPPoint3d & GetCenterShapeConnectorPoint ( ) const

Obtains the shape center connector point.

Returns
Shape center connector point.
See also
GetOuterCenterConnectorPoint

◆ GetOuterCenterConnectorPoint()

AFX_INLINE const CXTPPoint3d & GetOuterCenterConnectorPoint ( ) const

Obtains the outer shape center connector point.

Returns
Outer shape center connector point.
See also
GetCenterShapeConnectorPoint

◆ OnSetConnectorPoints()

virtual void OnSetConnectorPoints | ( | CXTPChartDeviceCommand * | pCommand,
 |  | CXTPPoint3d | ptShapeCenter,
 |  | CXTPPoint3d | ptOuterCenter )
 protectedvirtual

Gets called when pyramid connector points are computed.

Parameters
pCommand | The sender command.
ptShapeCenter | The coordinates of the physical shape center.
ptOuterCenter | The coordinates of the most outer horizontal shape center point.

Reimplemented from CXTPChart3dPyramidDeviceCommandEvents.

◆ OnUpdateBounds()

virtual void OnUpdateBounds | ( | CXTPChartDeviceCommand * | pCommand,
 |  | CRect | rcBounds )
 protectedvirtual

Notifies about updated boundaries of the command result.

Parameters
pCommand | Sender command pointer.
rcBounds | Updated bounray rectangle.

Reimplemented from CXTPChartDeviceCommandEvents.

The documentation for this class was generated from the following file:
  • XTPChart3dPyramidSeriesPointView.h


Toolkit Pro: CXTPChart3dPyramidSeriesStyle Class Reference

Public Member Functions | List of all members
CXTPChart3dPyramidSeriesStyle Class Reference

This class abstracts the basic style of a pyramid series. More...

Inheritance diagram for CXTPChart3dPyramidSeriesStyle:
[legend]

Public Member Functions

CXTPChart3dPyramidSeriesStyle ()
Constructs a CXTPChart3dPyramidSeriesStyle object.
virtual CXTPChartDiagram * | CreateDiagram ()
Call this function to create the pyramid diagram object.
virtual CXTPChartSeriesView * | CreateView (CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Call this function to create the view of the pyramid series.
virtual BOOL | IsStyleDiagram (CXTPChartDiagram *pDiagram) const
Call this function to check whether a chart diagram object passed is a kind of CXTPChart3dPyramidDiagramBase/CXTPChart3dPyramidDiagramBase.
virtual void | DoPropExchange (CXTPPropExchange *pPX)
Call this member function to Store/Load an event using the specified data object.
int | GetBaseEdgeCount () const
Gets the number of base edges for the pyramid.
void | SetBaseEdgeCount (int nEdgeCount)
Sets the number of base edges for the pyramid.
- Public Member Functions inherited from CXTPChartPyramidSeriesStyleBase
CXTPChartPyramidSeriesStyleBase ()
Constructs a CXTPChartPyramidSeriesStyleBase object.
virtual | ~CXTPChartPyramidSeriesStyleBase ()
Destroys a CXTPChartPyramidSeriesStyleBase object, handles cleanup.
int | GetPointDistance () const
Gets the distance bettween stacked pyramid point (a gap).
void | SetPointDistance (int nPointDistance)
Sets the distance bettween stacked pyramid point (a gap).
double | GetHeightToWidthRatio () const
Gets the the ratio value that determines whether a pyramid looks more stretched towards its cone or if it has a wider base.
void | SetHeightToWidthRatio (double dRatio)
Sets the the ratio value that determines whether a pyramid looks more stretched towards its cone or if it has a wider base.
CXTPChartFillStyle * | GetFillStyle () const
Call this function to get the background fill style.
CXTPChartBorder * | GetBorder () const
Obtains the border object pointer.
void | DoPropExchange (CXTPPropExchange *pPX)
Call this member function to Store/Load an event using the specified data object.
- Public Member Functions inherited from CXTPChartSeriesStyle
CXTPChartSeriesStyle ()
Constructs a CXTPChartSeriesStyle object.
virtual | ~CXTPChartSeriesStyle ()
Destroys a CXTPChartSeriesStyle object, handles cleanup.
virtual CXTPChartSeriesLabel * | GetLabel () const
Call this method to gets the series label object.
virtual CXTPChartSeriesLabel * | SetLabel (CXTPChartSeriesLabel *pLabel)
Call this method to sets the series label object.
virtual CXTPChartErrorBar * | GetErrorBar () const
Call this method to gets the error bar object.
virtual CXTPChartErrorBar * | SetErrorBar (CXTPChartErrorBar *pErrorBar)
Call this method to sets the error bar object.
virtual CXTPChartColor | GetColor () const
Call this method to get the color of the series.
virtual void | SetColor (CXTPChartColor clr)
Call this method to set the color of the series.
virtual void | SetColorEach (BOOL bColorEach)
Call this method to set individual color for each point of the series.
virtual BOOL | IsColorEach () const
This method is called to check if individual color is used for each point of the series.
virtual CXTPChart3dRotation | Get3dRotation () const
Obtains rotation parameters for 3D chart.
virtual void | Set3dRotation (const CXTPChart3dRotation &rotation)
Sets rotation parameters for 3D chart.
virtual void | Set3dRotation (double dYaw, double dPitch, double dRoll)
Sets rotation parameters for 3D chart.
virtual BOOL | Is3dEdgeSmoothingEnabled () const
Enables/disables 3D edge smoothing.
virtual void | Enable3dEdgeSmoothing (BOOL bEnable=TRUE)
Enables/disables 3D edge smoothing.
virtual int | GetTransparency () const
Call this function to gets the transparency of the chart if it is supported by the chart type.
virtual void | SetTransparency (int nTransparency)
Call this function to sets the transparency of the chart if it is supported by the chart type.
virtual void | CorrectAxisSideMargins (CXTPChartAxis *pAxis, double nMinValue, double nMaxValue, double &nCorrection)
Provides default implementation for axis side margins correction.
virtual CXTPChartSeriesStyleAppearance * | GetStyleAppearance () const
Obtains associated style appearance pointer.
virtual void | ApplyTo (CXTPChartDeviceCommand *pCommand)
Applies the style to the command provided in case the command needs style specific details for correct drawing.
virtual int | GetSeriesPointValueIndex () const
Obtains the index of a point element for which an internal value can be otained.
- Public Member Functions inherited from CXTPChartElement
CXTPChartElement ()
Constructs a CXTPChartElement object.
virtual | ~CXTPChartElement ()
Destroys a CXTPChartElement object, handles cleanup.
virtual void | Release ()
Call this function to decrease the usage count of the object.
CXTPChartElement * | GetOwner () const
Call this function to get the owner element.
virtual void | OnChartChanged (XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic properties of the chart.
CXTPChartContent * | GetContent () const
Call this virtual function to get the chart content object.
CXTPChartAppearance * | GetAppearance () const
Call this function to get the the appearance of the chart.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Additional Inherited Members

- Public Attributes inherited from CXTPChartElement
- Protected Member Functions inherited from CXTPChartPyramidSeriesStyleBase
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.
- Protected Attributes inherited from CXTPChartPyramidSeriesStyleBase
- Protected Attributes inherited from CXTPChartSeriesStyle
CXTPChartSeriesLabel * | m_pLabel
Label object.
CXTPChartErrorBar * | m_pErrorBar
Error bar object.
CXTPChartColor | m_clrColor
Custom color of series.
BOOL | m_bColorEach
TRUE to color each point.
int | m_nTransparency
The transparency value in the range 0..255.
CXTPChart3dRotation | m_Rotation3d
3D rotation
BOOL | m_bSmooth3dEdges
3D edge smoothing
- Protected Attributes inherited from CXTPChartElement

Detailed Description

This class abstracts the basic style of a pyramid series.

This class is a kind of CXTPChartSeriesStyle.

A pyramid chart (or a circle graph) is a circular chart divided into sectors, illustrating percents. In a pyramid chart, the arc length of each sector (and consequently its central angle and area), is proportional to the quantity it represents. Together, the sectors create a full disk.

Member Function Documentation

◆ CreateDiagram()

virtual CXTPChartDiagram * CreateDiagram ( )
virtual

Call this function to create the pyramid diagram object.

Returns
Returns a pointer to the associated diagram object.

Implements CXTPChartPyramidSeriesStyleBase.

◆ CreateView()

virtual CXTPChartSeriesView * CreateView | ( | CXTPChartSeries * | pSeries,
 |  | CXTPChartDiagramView * | pDiagramView )
 virtual

Call this function to create the view of the pyramid series.

Parameters
pSeries | A pointer to the chart series object.
pDiagramView | A pointer to the diagram view object.
Returns
Returns a pointer to the associated series view object.

Implements CXTPChartPyramidSeriesStyleBase.

◆ DoPropExchange()

virtual void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Call this member function to Store/Load an event using the specified data object.

Parameters
pPX Source or destination CXTPPropExchange data object reference.

This member function is used to store event data to or load event data from storage.

Reimplemented from CXTPChartSeriesStyle.

◆ GetBaseEdgeCount()

AFX_INLINE int GetBaseEdgeCount ( ) const

Gets the number of base edges for the pyramid.

The number of edges must not be equal to 1 or 2. If 0 is used as edge count the round pyramid (with no edges) will be drawn.

Returns
Current number of base edges.

◆ IsStyleDiagram()

virtual BOOL IsStyleDiagram ( CXTPChartDiagram * pDiagram ) const
virtual

Call this function to check whether a chart diagram object passed is a kind of CXTPChart3dPyramidDiagramBase/CXTPChart3dPyramidDiagramBase.

Parameters
pDiagram A pointer to a chart diagram, whose type is to be identified.
Returns
TRUE if the chart diagram is a pyramid diagram, FALSE otherwise.

Implements CXTPChartPyramidSeriesStyleBase.

◆ SetBaseEdgeCount()

void SetBaseEdgeCount ( int nEdgeCount )

Sets the number of base edges for the pyramid.

The number of edges must not be equal to 1 or 2. If 0 is used as edge count the round pyramid (with no edges) will be drawn.

Parameters
nEdgeCount A new number of base edges.
The documentation for this class was generated from the following file:
  • XTPChart3dPyramidSeriesStyle.h


Toolkit Pro: CXTPChart3dPyramidSeriesView Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPChart3dPyramidSeriesView Class Reference

This class abstracts the view of a pyramid series. More...

Inheritance diagram for CXTPChart3dPyramidSeriesView:
[legend]

Public Member Functions

CXTPChart3dPyramidSeriesView (CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Constructs a CXTPChart3dPyramidSeriesView object.
virtual void | CalculatePointLayout (CXTPChartDeviceContext *pDC, CRect rcBounds)
Call this function to calculate the pyramid series point layout.
- Public Member Functions inherited from CXTPChartPyramidSeriesViewBase
CXTPChartPyramidSeriesViewBase (CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Constructs a CXTPChartPyramidSeriesViewBase object.
virtual | ~CXTPChartPyramidSeriesViewBase ()
Destroys a CXTPChartPyramidSeriesViewBase object, handles cleanup.
void | CalculateLabelLayout (CXTPChartDeviceContext *pDC)
Call this function to calculate the pyramid series label layout.
virtual CXTPChartDiagramDomain * | CreateDiagramDomain (CXTPChartDeviceContext *pDC, CRect rcBounds)
Call this function to create the pyramid diagram domain object associated with this object.
virtual CXTPChartRectF | GetInnerBounds () const
Call this function to get the inner bounds of the diagram.
CXTPChartDiagramDomain * | GetDomain () const
Use this function to get the pyramid diagram domain object associated with this object.
int | GetMaxLabelWidth () const
Obtains the maximum allowed label width.

Protected Member Functions

virtual CXTPChartSeriesPointView * | CreateSeriesPointView (CXTPChartDeviceContext *pDC, CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Use this function to create the pyramid series point view object.
virtual CXTPChartDeviceCommand * | CreateDeviceCommand (CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
virtual CXTPChartDeviceCommand * | CreateLegendDeviceCommand (CXTPChartDeviceContext *pDC, CRect rcBounds)
Creates legend drawing device command.
virtual CXTPChartDeviceCommand * | CreateLegendDeviceCommand (CXTPChartDeviceContext *pDC, CRect rcBounds, CXTPChartColor color1, CXTPChartColor color2, CXTPChartColor clrBorder)
These functions create a label view drawing command object.
- Protected Member Functions inherited from CXTPChartPyramidSeriesViewBase

Additional Inherited Members

- Protected Attributes inherited from CXTPChartPyramidSeriesViewBase
CXTPChartDiagramDomain * m_pDomain
Pointer to the diagram domain.

Detailed Description

This class abstracts the view of a pyramid series.

This class is a kind of CXTPChartSeriesView.

A pyramid chart (or a circle graph) is a circular chart divided into sectors, illustrating percents. In a pyramid chart, the arc length of each sector (and consequently its central angle and area), is proportional to the quantity it represents. Together, the sectors create a full disk.

Constructor & Destructor Documentation

◆ CXTPChart3dPyramidSeriesView()

CXTPChart3dPyramidSeriesView | ( | CXTPChartSeries * | pSeries,
 |  | CXTPChartDiagramView * | pDiagramView )

Constructs a CXTPChart3dPyramidSeriesView object.

Parameters
pSeries | Pointer to the pyramid series object.
pDiagramView | Pointer to the pyramid diagram view.

Member Function Documentation

◆ CalculatePointLayout()

virtual void CalculatePointLayout | ( | CXTPChartDeviceContext * | pDC,
 |  | CRect | rcBounds )
 virtual

Call this function to calculate the pyramid series point layout.

Parameters
pDC | Pointer to the chart device context.
rcBounds | The rectangular boundary.

Implements CXTPChartPyramidSeriesViewBase.

◆ CreateDeviceCommand()

virtual CXTPChartDeviceCommand * CreateDeviceCommand ( CXTPChartDeviceContext * pDC )
protectedvirtual

This function creates a CXTPChartDeviceCommand object.

This object represents the rendering of the pyramid series.

Parameters
pDC Pointer to a CXTPChartDeviceContext object.
Returns
Returns a CXTPChartDeviceCommand object. This object handles the rendering of an element in the chart. Here it handles the drawing of the pyramid series.

Implements CXTPChartPyramidSeriesViewBase.

◆ CreateLegendDeviceCommand() [1/2]

virtual CXTPChartDeviceCommand * CreateLegendDeviceCommand | ( | CXTPChartDeviceContext * | pDC,
 |  | CRect | rcBounds )
 protectedvirtual

Creates legend drawing device command.

Parameters
pDC | Target device context.
rcBounds | Bounding rectangle.
Returns
A newly created command object pointer or NULL if not supported.

Implements CXTPChartPyramidSeriesViewBase.

◆ CreateLegendDeviceCommand() [2/2]

virtual CXTPChartDeviceCommand * CreateLegendDeviceCommand | ( | CXTPChartDeviceContext * | pDC,
 |  | CRect | rcBounds,
 |  | CXTPChartColor | color1,
 |  | CXTPChartColor | color2,
 |  | CXTPChartColor | clrBorder )
 protectedvirtual

These functions create a label view drawing command object.

Parameters
pDC | Pointer to a CXTPChartDeviceContext object.
rcBounds | The rectangular boundary of the legend.
color1 | 1-st gradient fill color.
color2 | 2-nd gradient fill color.
clrBorder | Border color.
Returns
Returns a new label view drawing command object.

Implements CXTPChartPyramidSeriesViewBase.

◆ CreateSeriesPointView()

virtual CXTPChartSeriesPointView * CreateSeriesPointView | ( | CXTPChartDeviceContext * | pDC,
 |  | CXTPChartSeriesPoint * | pPoint,
 |  | CXTPChartElementView * | pParentView )
 protectedvirtual

Use this function to create the pyramid series point view object.

Parameters
pDC | Pointer to chart device context.
pPoint | Pointer to chart series point.
pParentView | Parent element view pointer.
Returns
A pointer to the chart series point view.

Implements CXTPChartPyramidSeriesViewBase.

The documentation for this class was generated from the following file:
  • XTPChart3dPyramidSeriesView.h


Toolkit Pro: CXTPChart3dRotateDeviceCommand Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPChart3dRotateDeviceCommand Class Reference

Base class implementation for 3D chart rotation device command. More...

Inheritance diagram for CXTPChart3dRotateDeviceCommand:
[legend]

Public Member Functions

CXTPChart3dRotateDeviceCommand (const CXTPChart3dRotation &rotation)
Constructs a CXTPChart3dRotateDeviceCommand object.
CXTPChartElement * | HitTest (CPoint point, CXTPChartElement *pParent) const
Performs recursive hit testing of the element at the specified point.
- Public Member Functions inherited from CXTPChart3dDeviceCommand
virtual BOOL | IsEnabled () const
Determines if the command is currently enabled.
- Public Member Functions inherited from CXTPChartDeviceCommand
CXTPChartDeviceCommand ()
Constructs a CXTPChartDeviceCommand object.
virtual | ~CXTPChartDeviceCommand ()
Destroys a CXTPChartDeviceCommand object, handles cleanup.
BOOL | IsCommitted () const
Determines if the execution of the command has been committed.
void | Commit ()
Commits the execution of the command.
int | GetChildCommandCount () const
Obtains the number of immediate children commands.
CXTPChartDeviceCommand * | GetChildCommand (int nIndex) const
Obtains immediate child command point by index.
CXTPChartDeviceCommand * | AddChildCommand (CXTPChartDeviceCommand *pCommand)
Call this function to add a child device command.
virtual void | Execute (CXTPChartDeviceContext *pDC)
Call this function to execute the drawing.
virtual void | BeforeExecute (CXTPChartDeviceContext *pDC)
This method gets called before a command is executed which allows for the customization of command behavior.
virtual void | AfterExecute (CXTPChartDeviceContext *pDC)
This method gets called after a command is executed which allows for the customization of command behavior.
virtual void | ExecuteOverride (CXTPChartDeviceContext *pDC)
Override this function to write the drawing code for specific objects.
UINT | GetPassNumber () const
Get the number of executions made by the command.
virtual void | ApplySeriesStyle (CXTPChartSeriesStyle *pStyle)
Applies series style to the current element.
virtual void | Prepare (CXTPChartDeviceContext *pDC)
Performs inital preparation steps necessary for successful command execution.
virtual void | PrepareOverride (CXTPChartDeviceContext *pDC)
Derived implementation must override this method for implementing implementation specific preparation behavior.
void | SetEnabled (BOOL bEnabled=TRUE)
Enables/disable the command.
CXTPChartDeviceContext * | GetCurrentDC () const
Obtains device context pointer for which the command is currenly being prepared or executed.
void | BindView (CXTPChartElementView *pView)
Binds a view to the command object.
CXTPChartElementView * | GetBoundView () const
Obtains a bound view pointer or NULL if no view is bound.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.
- Public Member Functions inherited from CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents >
void | Subscribe (CXTPChartDeviceCommandEvents *pObserver, CXTPSubscriptionList< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > *pSubcriptionList=NULL)
Subscribes a unique observer for events.
void | Unsubscribe (CXTPChartDeviceCommandEvents *pObserver)
Unsubscribes an observer from events.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *))
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *))
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.

Protected Attributes

CXTPChart3dRotation | m_rotation
Rotation parameters.
- Protected Attributes inherited from CXTPChartDeviceCommand
CArray< CXTPChartDeviceCommand *, CXTPChartDeviceCommand * > | m_arrChildren
< The array of child device commands.

Additional Inherited Members

- Protected Member Functions inherited from CXTPChart3dDeviceCommand
CXTPChart3dDeviceCommand (XTPChart3dAntialiasingPolicy nAntialiasingPolicy)
Constructs a CXTPChart3dDeviceCommand object.
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.
- Protected Member Functions inherited from CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents >
CXTPObservable ()
Constructs an observable object.
~CXTPObservable ()
Handles observable object destruction.

Detailed Description

Base class implementation for 3D chart rotation device command.

Constructor & Destructor Documentation

◆ CXTPChart3dRotateDeviceCommand()

CXTPChart3dRotateDeviceCommand ( const CXTPChart3dRotation & rotation )

Constructs a CXTPChart3dRotateDeviceCommand object.

Parameters
rotation Rotation parameters.

Member Function Documentation

◆ HitTest()

CXTPChartElement * HitTest | ( | CPoint | point,
 |  | CXTPChartElement * | pParent ) const
 virtual

Performs recursive hit testing of the element at the specified point.

Parameters
point | Point in which an element is to be found.
pParent | Parent element pointer.
Returns
A pointer to the element found at the specified point or NULL if no element is found.

Reimplemented from CXTPChartDeviceCommand.

The documentation for this class was generated from the following file:
  • XTPChartTransformationDeviceCommand.h


Toolkit Pro: CXTPChart3dRotation Class Reference

Public Member Functions | Public Attributes | List of all members
CXTPChart3dRotation Class Reference

Represents a 3D rotation primitive for chart objects using Euler angles Yaw, Pitch and Roll in degrees. More...

Public Member Functions

CXTPChart3dRotation ()
Constructs a rotation object with no rotation by default.
CXTPChart3dRotation (const CXTPChart3dRotation &rhs)
Constructs a rotation object with no rotation by default.
CXTPChart3dRotation (double dYaw, double dPitch, double dRoll)
Constructs a rotation object with the provided rotation parameters.
BOOL | IsRotated () const
Checks if any rotation is applied.
void | SetFromString (LPCTSTR pString)
Reads rotation angle value from a string provided.
CXTPChart3dRotation & | operator= (const CXTPChart3dRotation &rhs)
Overloads default assignment operator.

Public Attributes

double | m_dYaw
Yaw angle value in degrees.
double | m_dPitch
Pitch angle value in degrees.
double | m_dRoll
Roll angle value in degrees.

Detailed Description

Represents a 3D rotation primitive for chart objects using Euler angles Yaw, Pitch and Roll in degrees.

Constructor & Destructor Documentation

◆ CXTPChart3dRotation() [1/2]

CXTPChart3dRotation ( const CXTPChart3dRotation & rhs )

Constructs a rotation object with no rotation by default.

Parameters
rhs Right-hand-side rotation object to copy data from.

◆ CXTPChart3dRotation() [2/2]

CXTPChart3dRotation | ( | double | dYaw,
 |  | double | dPitch,
 |  | double | dRoll )

Constructs a rotation object with the provided rotation parameters.

Parameters
dYaw | Yaw angle value in degrees.
dPitch | Pitch angle value in degrees.
dRoll | Roll angle value in degrees.

Member Function Documentation

◆ IsRotated()

AFX_INLINE BOOL IsRotated ( ) const

Checks if any rotation is applied.

Returns
A BOOL value. TRUE if any rotation is applied, FALSE otherwise.

◆ operator=()

AFX_INLINE CXTPChart3dRotation & operator= ( const CXTPChart3dRotation & rhs )

Overloads default assignment operator.

Assigns rotation components only.

Parameters
rhs Right-hand-side rotation object to copy data from.
Returns
Self reference

◆ SetFromString()

void SetFromString ( LPCTSTR pString )

Reads rotation angle value from a string provided.

The values are expected to be comma-separated, floating point values in the following order: "yaw, pitch, roll"

Parameters
pString A string value in "yaw, pitch, roll" format to parse.
The documentation for this class was generated from the following file:
  • XTPChartTypes.h


Toolkit Pro: CXTPChart3dTranslateDeviceCommand Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPChart3dTranslateDeviceCommand Class Reference

Base class implementation for 3D chart translation device command. More...

Inheritance diagram for CXTPChart3dTranslateDeviceCommand:
[legend]

Public Member Functions

CXTPChart3dTranslateDeviceCommand (double dx, double dy, double dz)
Constructs a CXTPChartTranslateDeviceCommand object.
- Public Member Functions inherited from CXTPChart3dDeviceCommand
virtual BOOL | IsEnabled () const
Determines if the command is currently enabled.
- Public Member Functions inherited from CXTPChartDeviceCommand
CXTPChartDeviceCommand ()
Constructs a CXTPChartDeviceCommand object.
virtual | ~CXTPChartDeviceCommand ()
Destroys a CXTPChartDeviceCommand object, handles cleanup.
BOOL | IsCommitted () const
Determines if the execution of the command has been committed.
void | Commit ()
Commits the execution of the command.
int | GetChildCommandCount () const
Obtains the number of immediate children commands.
CXTPChartDeviceCommand * | GetChildCommand (int nIndex) const
Obtains immediate child command point by index.
CXTPChartDeviceCommand * | AddChildCommand (CXTPChartDeviceCommand *pCommand)
Call this function to add a child device command.
virtual void | Execute (CXTPChartDeviceContext *pDC)
Call this function to execute the drawing.
virtual void | BeforeExecute (CXTPChartDeviceContext *pDC)
This method gets called before a command is executed which allows for the customization of command behavior.
virtual void | AfterExecute (CXTPChartDeviceContext *pDC)
This method gets called after a command is executed which allows for the customization of command behavior.
virtual void | ExecuteOverride (CXTPChartDeviceContext *pDC)
Override this function to write the drawing code for specific objects.
UINT | GetPassNumber () const
Get the number of executions made by the command.
virtual CXTPChartElement * | HitTest (CPoint point, CXTPChartElement *pParent) const
Performs recursive hit testing of the element at the specified point.
virtual void | ApplySeriesStyle (CXTPChartSeriesStyle *pStyle)
Applies series style to the current element.
virtual void | Prepare (CXTPChartDeviceContext *pDC)
Performs inital preparation steps necessary for successful command execution.
virtual void | PrepareOverride (CXTPChartDeviceContext *pDC)
Derived implementation must override this method for implementing implementation specific preparation behavior.
void | SetEnabled (BOOL bEnabled=TRUE)
Enables/disable the command.
CXTPChartDeviceContext * | GetCurrentDC () const
Obtains device context pointer for which the command is currenly being prepared or executed.
void | BindView (CXTPChartElementView *pView)
Binds a view to the command object.
CXTPChartElementView * | GetBoundView () const
Obtains a bound view pointer or NULL if no view is bound.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.
- Public Member Functions inherited from CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents >
void | Subscribe (CXTPChartDeviceCommandEvents *pObserver, CXTPSubscriptionList< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > *pSubcriptionList=NULL)
Subscribes a unique observer for events.
void | Unsubscribe (CXTPChartDeviceCommandEvents *pObserver)
Unsubscribes an observer from events.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *))
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *))
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.

Protected Attributes

double | m_dx
The change in X direction.
double | m_dy
The change in Y direction.
double | m_dz
The change in Z direction.
- Protected Attributes inherited from CXTPChartDeviceCommand
CArray< CXTPChartDeviceCommand *, CXTPChartDeviceCommand * > | m_arrChildren
< The array of child device commands.

Additional Inherited Members

- Protected Member Functions inherited from CXTPChart3dDeviceCommand
CXTPChart3dDeviceCommand (XTPChart3dAntialiasingPolicy nAntialiasingPolicy)
Constructs a CXTPChart3dDeviceCommand object.
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.
- Protected Member Functions inherited from CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents >
CXTPObservable ()
Constructs an observable object.
~CXTPObservable ()
Handles observable object destruction.

Detailed Description

Base class implementation for 3D chart translation device command.

Constructor & Destructor Documentation

◆ CXTPChart3dTranslateDeviceCommand()

CXTPChart3dTranslateDeviceCommand | ( | double | dx,
 |  | double | dy,
 |  | double | dz )

Constructs a CXTPChartTranslateDeviceCommand object.

Parameters
dx | The change in X direction
dy | The change in Y direction
dz | The change in Z direction
The documentation for this class was generated from the following file:
  • XTPChartTransformationDeviceCommand.h


Toolkit Pro: CXTPChartAppearance Class Reference

Public Member Functions | Static Public Member Functions | Protected Attributes | List of all members
CXTPChartAppearance Class Reference

This class represents the appearance of the chart. More...

Inheritance diagram for CXTPChartAppearance:
[legend]

Public Member Functions

CXTPChartAppearance (CXTPChartElement *pOwner)
Constructs a CXTPChartAppearance object.
virtual | ~CXTPChartAppearance ()
Destroys a CXTPChartAppearance object, handles cleanup.
CXTPChartDiagram2DAppearance * | GetDiagram2DAppearance () const
Call this function to get the 2D digram appearance object pointer of the chart.
CXTPChartDiagram3DAppearance * | GetDiagram3DAppearance () const
Call this function to get the 3D digram appearance object pointer of the chart.
CXTPChartContentAppearance * | GetContentAppearance () const
Call this function to get the content appearance object pointer of the chart.
CXTPChartFinanceStyleAppearance * | GetFinanceStyleAppearance () const
Call this function to get the finance series appearance object pointer of the chart.
CXTPChartSeriesStyleAppearance * | GetSeriesStyleAppearance () const
Call this function to get the series style appearance object pointer of the chart.
CXTPChartPieStyleAppearance * | GetPieStyleAppearance () const
Call this function to get the pie style appearance object pointer of the chart.
CXTPChartPalette * | GetPalette () const
Call this function to get the color palette object pointer of the chart.
void | DoPropExchange (CXTPPropExchange *pPX)
Call this member function to Store/Load the properties related to the appearance of a chart, here this function calls the DoPropExchange method of the constituent appearance elements.
BOOL | LoadAppearance (LPCTSTR lpszAppearance)
Call this function to load the properties from a resource XML.
BOOL | LoadPalette (LPCTSTR lpszPallete)
Call this function to load the chart palette values from a resource XML.
- Public Member Functions inherited from CXTPChartElementAppearance
CXTPChartElementAppearance (CXTPChartElement *pOwner)
Constructs a CXTPChartElementAppearance object.
virtual | ~CXTPChartElementAppearance ()
Destroys a CXTPChartElementAppearance object, handles cleanup.
virtual void | ApplyToDeviceContext (CXTPChartDeviceContext *pDC)
Applies implementation specific appearance settings to the device context provided.
- Public Member Functions inherited from CXTPChartElement
CXTPChartElement ()
Constructs a CXTPChartElement object.
virtual | ~CXTPChartElement ()
Destroys a CXTPChartElement object, handles cleanup.
virtual void | Release ()
Call this function to decrease the usage count of the object.
CXTPChartElement * | GetOwner () const
Call this function to get the owner element.
virtual void | OnChartChanged (XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic properties of the chart.
CXTPChartContent * | GetContent () const
Call this virtual function to get the chart content object.
CXTPChartAppearance * | GetAppearance () const
Call this function to get the the appearance of the chart.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Static Public Member Functions

static CXTPChartAppearance *AFX_CDECL GetAppearance (const CXTPChartElement *pElement)
Call this function to get the pointer to the chart appeance object.

Protected Attributes

CXTPChartDiagram2DAppearance * | m_pDiagram2DAppearance
Pointer to chart diagram 2d appearance object.
CXTPChartDiagram3DAppearance * | m_pDiagram3DAppearance
Pointer to chart diagram 3d appearance object.
CXTPChartContentAppearance * | m_pContentAppearance
Pointer to chart content appearance object.
CXTPChartPalette * | m_pPalette
Pointer to chart palette object.
CXTPChartFinanceStyleAppearance * | m_pFinanceStyleAppearance
Pointer to chart financial content appearance object.
CXTPChartPieStyleAppearance * | m_pPieStyleAppearance
Pointer to chart Pie content appearance object.
- Protected Attributes inherited from CXTPChartElement

Additional Inherited Members

- Public Attributes inherited from CXTPChartElement
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.

Detailed Description

This class represents the appearance of the chart.

Chart appearance determined by the 2D digram appearance, chart content appearance and the color palette used.

Constructor & Destructor Documentation

◆ CXTPChartAppearance()

CXTPChartAppearance ( CXTPChartElement * pOwner )

Constructs a CXTPChartAppearance object.

Parameters
pOwner Pointer to an owner element.

Member Function Documentation

◆ DoPropExchange()

void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Call this member function to Store/Load the properties related to the appearance of a chart, here this function calls the DoPropExchange method of the constituent appearance elements.

Parameters
pPX Source or destination CXTPPropExchange data object reference.

This member function is used to store or load property data to or from a storage.

Reimplemented from CXTPChartElement.

◆ GetAppearance()

static CXTPChartAppearance *AFX_CDECL GetAppearance ( const CXTPChartElement * pElement )
static

Call this function to get the pointer to the chart appeance object.

Parameters
pElement Pointer to CXTPChartElement element
Returns
Returns the pointer to CXTPChartAppearance object.

◆ GetContentAppearance()

AFX_INLINE CXTPChartContentAppearance * GetContentAppearance ( ) const

Call this function to get the content appearance object pointer of the chart.

Returns
Returns the pointer to CXTPChartContentAppearance object.

◆ GetDiagram2DAppearance()

AFX_INLINE CXTPChartDiagram2DAppearance * GetDiagram2DAppearance ( ) const

Call this function to get the 2D digram appearance object pointer of the chart.

Returns
Returns the pointer to CXTPChartDiagram2DAppearance object.

◆ GetDiagram3DAppearance()

AFX_INLINE CXTPChartDiagram3DAppearance * GetDiagram3DAppearance ( ) const

Call this function to get the 3D digram appearance object pointer of the chart.

Returns
Returns the pointer to CXTPChartDiagram3DAppearance object.

◆ GetFinanceStyleAppearance()

AFX_INLINE CXTPChartFinanceStyleAppearance * GetFinanceStyleAppearance ( ) const

Call this function to get the finance series appearance object pointer of the chart.

Returns
Returns the pointer to CXTPChartFinanceSeriesAppearance object.

◆ GetPalette()

AFX_INLINE CXTPChartPalette * GetPalette ( ) const

Call this function to get the color palette object pointer of the chart.

Returns
Returns the pointer to CXTPChartPalette object.

◆ GetPieStyleAppearance()

AFX_INLINE CXTPChartPieStyleAppearance * GetPieStyleAppearance ( ) const

Call this function to get the pie style appearance object pointer of the chart.

Returns
Returns the pointer to CXTPChartPieStyleAppearance object pointer.

◆ GetSeriesStyleAppearance()

AFX_INLINE CXTPChartSeriesStyleAppearance * GetSeriesStyleAppearance ( ) const

Call this function to get the series style appearance object pointer of the chart.

Returns
Returns the pointer to CXTPChartSeriesStyleAppearance object pointer.

◆ LoadAppearance()

BOOL LoadAppearance ( LPCTSTR lpszAppearance )

Call this function to load the properties from a resource XML.

Parameters
lpszAppearance A name of an appearance to be loaded.
Returns
BOOL value TRUE if the properties are loaded successfully, BOOL value FALSE if the function fails.

◆ LoadPalette()

BOOL LoadPalette ( LPCTSTR lpszPallete )

Call this function to load the chart palette values from a resource XML.

Parameters
lpszPallete A name of a pallette to be loaded.
Returns
BOOL value TRUE if the properties are loaded successfully, BOOL value FALSE if the function fails.
The documentation for this class was generated from the following file:
  • XTPChartAppearance.h


Toolkit Pro: CXTPChartAreaSeriesStyle Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPChartAreaSeriesStyle Class Reference

CXTPChartAreaSeriesStyle is a CXTPChartPointSeriesStyle derived class which represents the area series style. More...

Inheritance diagram for CXTPChartAreaSeriesStyle:
[legend]

Public Member Functions

CXTPChartAreaSeriesStyle ()
Constructs a CXTPChartAreaSeriesStyle object.
virtual | ~CXTPChartAreaSeriesStyle ()
Destroys a CXTPChartAreaSeriesStyle object, handles cleanup.
CXTPChartFillStyle * | GetFillStyle () const
Call this function to get the background fill style.
void | DoPropExchange (CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
int | GetTransparency () const
Call this function to get the transparency of the filled area with respect to the background.
void | SetTransparency (int nTransparency)
Call this function to set the transparency of the filled area with respect to the background.
BOOL | GetFillAcrossXAxis () const
Call this function to get the fill chart area indicator with respect to the background.
void | SetFillAcrossXAxis (BOOL nFillAcrossXAxis)
Call this function to set the fill chart area indicator with respect to the background.
- Public Member Functions inherited from CXTPChartPointSeriesStyle
CXTPChartPointSeriesStyle ()
Constructs a CXTPChartPointSeriesStyle object.
virtual | ~CXTPChartPointSeriesStyle ()
Destroys a CXTPChartPointSeriesStyle object, handles cleanup.
CXTPChartMarker * | GetMarker () const
Call this function to get the marker object associated with this CXTPChartPointSeriesStyle object.
void | DoPropExchange (CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
- Public Member Functions inherited from CXTPChartDiagram2DSeriesStyle
CXTPChartDiagram2DSeriesStyle ()
Constructs a CXTPChartDiagram2DSeriesStyle object.
virtual | ~CXTPChartDiagram2DSeriesStyle ()
Destroys a CXTPChartDiagram2DSeriesStyle object, handles cleanup.
virtual CXTPChartDiagram * | CreateDiagram ()
Call this function to create the diagram for this series.
virtual BOOL | IsStyleDiagram (CXTPChartDiagram *pDiagram) const
Call this function to check whether the chart diagram object passed is a kind of 2D diagram (CXTPChartDiagram2D object).
- Public Member Functions inherited from CXTPChartSeriesStyle
CXTPChartSeriesStyle ()
Constructs a CXTPChartSeriesStyle object.
virtual | ~CXTPChartSeriesStyle ()
Destroys a CXTPChartSeriesStyle object, handles cleanup.
virtual CXTPChartSeriesLabel * | GetLabel () const
Call this method to gets the series label object.
virtual CXTPChartSeriesLabel * | SetLabel (CXTPChartSeriesLabel *pLabel)
Call this method to sets the series label object.
virtual CXTPChartErrorBar * | GetErrorBar () const
Call this method to gets the error bar object.
virtual CXTPChartErrorBar * | SetErrorBar (CXTPChartErrorBar *pErrorBar)
Call this method to sets the error bar object.
virtual CXTPChartColor | GetColor () const
Call this method to get the color of the series.
virtual void | SetColor (CXTPChartColor clr)
Call this method to set the color of the series.
virtual void | SetColorEach (BOOL bColorEach)
Call this method to set individual color for each point of the series.
virtual BOOL | IsColorEach () const
This method is called to check if individual color is used for each point of the series.
virtual CXTPChart3dRotation | Get3dRotation () const
Obtains rotation parameters for 3D chart.
virtual void | Set3dRotation (const CXTPChart3dRotation &rotation)
Sets rotation parameters for 3D chart.
virtual void | Set3dRotation (double dYaw, double dPitch, double dRoll)
Sets rotation parameters for 3D chart.
virtual BOOL | Is3dEdgeSmoothingEnabled () const
Enables/disables 3D edge smoothing.
virtual void | Enable3dEdgeSmoothing (BOOL bEnable=TRUE)
Enables/disables 3D edge smoothing.
virtual void | CorrectAxisSideMargins (CXTPChartAxis *pAxis, double nMinValue, double nMaxValue, double &nCorrection)
Provides default implementation for axis side margins correction.
virtual CXTPChartSeriesStyleAppearance * | GetStyleAppearance () const
Obtains associated style appearance pointer.
virtual void | ApplyTo (CXTPChartDeviceCommand *pCommand)
Applies the style to the command provided in case the command needs style specific details for correct drawing.
virtual int | GetSeriesPointValueIndex () const
Obtains the index of a point element for which an internal value can be otained.
- Public Member Functions inherited from CXTPChartElement
CXTPChartElement ()
Constructs a CXTPChartElement object.
virtual | ~CXTPChartElement ()
Destroys a CXTPChartElement object, handles cleanup.
virtual void | Release ()
Call this function to decrease the usage count of the object.
CXTPChartElement * | GetOwner () const
Call this function to get the owner element.
virtual void | OnChartChanged (XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic properties of the chart.
CXTPChartContent * | GetContent () const
Call this virtual function to get the chart content object.
CXTPChartAppearance * | GetAppearance () const
Call this function to get the the appearance of the chart.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Protected Member Functions

virtual CXTPChartSeriesView * CreateView (CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Use this function to create a chart series view object.
- Protected Member Functions inherited from CXTPChartPointSeriesStyle
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.

Protected Attributes

int | m_nTransparency
The transparency values range from 0 to 255.
CXTPChartBorder * | m_pBorder
The chart border object pointer.
CXTPChartFillStyle * | m_pFillStyle
The chart background fill style.
BOOL | m_nFillAcrossXAxis
Fill chart area across X axis (under and over X axis)
- Protected Attributes inherited from CXTPChartPointSeriesStyle
- Protected Attributes inherited from CXTPChartDiagram2DSeriesStyle
int | m_nAxisIndexX
Holds index of secondary axisX, used when m_bSecondaryAxisX is TRUE.
int | m_nAxisIndexY
Holds index of secondary axisY, used when m_bSecondaryAxisY is TRUE.
- Protected Attributes inherited from CXTPChartSeriesStyle
CXTPChartSeriesLabel * | m_pLabel
Label object.
CXTPChartErrorBar * | m_pErrorBar
Error bar object.
CXTPChartColor | m_clrColor
Custom color of series.
BOOL | m_bColorEach
TRUE to color each point.
int | m_nTransparency
The transparency value in the range 0..255.
CXTPChart3dRotation | m_Rotation3d
3D rotation
BOOL | m_bSmooth3dEdges
3D edge smoothing
- Protected Attributes inherited from CXTPChartElement

Detailed Description

CXTPChartAreaSeriesStyle is a CXTPChartPointSeriesStyle derived class which represents the area series style.

Area series displays graphically the quantitative data in a chart. It displays a series as a set of points connected by a line or spline with all the area filled in below the line.

Member Function Documentation

◆ CreateView()

virtual CXTPChartSeriesView * CreateView | ( | CXTPChartSeries * | pSeries,
 |  | CXTPChartDiagramView * | pDiagramView )
 protectedvirtual

Use this function to create a chart series view object.

Parameters
pSeries | Pointer to a chart series object.
pDiagramView | Pointer to a chart diagram view object.
Returns
A pointer to the newly created CXTPChartSeriesView object.

CXTPChartSeriesView abstracts the view of a series.

Reimplemented from CXTPChartPointSeriesStyle.

Reimplemented in CXTPChartRangeSplineAreaSeriesStyle, CXTPChartSplineAreaSeriesStyle, CXTPChartStackedAreaSeriesStyle, CXTPChartStackedSplineAreaSeriesStyle, and CXTPChartStepAreaSeriesStyle.

◆ DoPropExchange()

void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Reads this object from or writes this object to an archive.

Parameters
pPX A CXTPPropExchange object to serialize to or from.

Reimplemented from CXTPChartSeriesStyle.

Reimplemented in CXTPChartStepAreaSeriesStyle.

◆ GetFillAcrossXAxis()

AFX_INLINE BOOL GetFillAcrossXAxis ( ) const

Call this function to get the fill chart area indicator with respect to the background.

Returns
Returns a BOOL value.

A value of TRUE means fill on both sides.

◆ GetFillStyle()

AFX_INLINE CXTPChartFillStyle * GetFillStyle ( ) const

Call this function to get the background fill style.

Returns
Returns a pointer to a CXTPChartFillStyle object, which abstracts various fill styles.

◆ GetTransparency()

AFX_INLINE int GetTransparency ( ) const
virtual

Call this function to get the transparency of the filled area with respect to the background.

Returns
Returns an integer whose values are from 0 to 255.

A value of 0 means fully transparent and a value of 255 means fully opaque.

Reimplemented from CXTPChartSeriesStyle.

◆ SetFillAcrossXAxis()

AFX_INLINE void SetFillAcrossXAxis ( BOOL nFillAcrossXAxis )

Call this function to set the fill chart area indicator with respect to the background.

Parameters
nFillAcrossXAxis a BOOL value.

A value of TRUE means fill on both sides.

◆ SetTransparency()

AFX_INLINE void SetTransparency ( int nTransparency )
virtual

Call this function to set the transparency of the filled area with respect to the background.

Parameters
nTransparency an integer whose values are from 0 to 255.

A value of 0 means fully transparent and a value of 255 means fully opaque.

Reimplemented from CXTPChartSeriesStyle.

The documentation for this class was generated from the following file:
  • XTPChartAreaSeriesStyle.h


Toolkit Pro: CXTPChartAreaSeriesView Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPChartAreaSeriesView Class Reference

CXTPChartAreaSeriesView is a kind of CXTPChartSeriesView. More...

Inheritance diagram for CXTPChartAreaSeriesView:
[legend]

Public Member Functions

CXTPChartAreaSeriesView (CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Constructs a CXTPChartAreaSeriesView object.

Protected Member Functions

CXTPChartSeriesPointView * | CreateSeriesPointView (CXTPChartDeviceContext *pDC, CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Call this function to create a chart area series point view object.
virtual CXTPChartDeviceCommand * | CreateDeviceCommand (CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
CXTPChartColor | GetActualColor () const
Call this function to get the actual color of the series.
CXTPChartColor | GetActualColor2 () const
Call this function to get the second actual color of the series.
CXTPChartColor | GetBorderActualColor () const
Call this function to get the actual color of the series border.
virtual CXTPChartDeviceCommand * | CreateLegendDeviceCommand (CXTPChartDeviceContext *pDC, CRect rcBounds)
This function creates a label view drawing command object.

Detailed Description

CXTPChartAreaSeriesView is a kind of CXTPChartSeriesView.

This class represents the view of the area series of a chart.

Area series displays graphically the quantitative data in a chart. It displays a series as a set of points connected by a line or spline with all the area filled in below the line.

Constructor & Destructor Documentation

◆ CXTPChartAreaSeriesView()

CXTPChartAreaSeriesView | ( | CXTPChartSeries * | pSeries,
 |  | CXTPChartDiagramView * | pDiagramView )

Constructs a CXTPChartAreaSeriesView object.

Parameters
pSeries | Pointer to a chart series object.
pDiagramView | Pointer to a chart diagram view object.

Member Function Documentation

◆ CreateDeviceCommand()

virtual CXTPChartDeviceCommand * CreateDeviceCommand ( CXTPChartDeviceContext * pDC )
protectedvirtual

This function creates a CXTPChartDeviceCommand object.

This object represents the rendering of an area series in the chart.

Parameters
pDC Pointer to a CXTPChartDeviceContext object.
Returns
Returns a CXTPChartDeviceCommand object. This polymorphic object handles the rendering of an element in the chart. Here it handles the drawing of the area series of the chart.

Reimplemented from CXTPChartElementView.

Reimplemented in CXTPChartRangeSplineAreaSeriesView, CXTPChartSplineAreaSeriesView, CXTPChartStackedAreaSeriesView, CXTPChartStackedSplineAreaSeriesView, and CXTPChartStepAreaSeriesView.

◆ CreateLegendDeviceCommand()

virtual CXTPChartDeviceCommand * CreateLegendDeviceCommand | ( | CXTPChartDeviceContext * | pDC,
 |  | CRect | rcBounds )
 protectedvirtual

This function creates a label view drawing command object.

Parameters
pDC | Pointer to a CXTPChartDeviceContext object.
rcBounds | The rectangular boundary of the legend.
Returns
Returns a new label view drawing command object.

Implements CXTPChartLegendItemView.

◆ CreateSeriesPointView()

CXTPChartSeriesPointView * CreateSeriesPointView | ( | CXTPChartDeviceContext * | pDC,
 |  | CXTPChartSeriesPoint * | pPoint,
 |  | CXTPChartElementView * | pParentView )
 protected

Call this function to create a chart area series point view object.

Parameters
pDC | Pointer to a chart device context object.
pPoint | Pointer to a chart series object.
pParentView | Parent view pointer.
Returns
A pointer to CXTPChartSeriesPointView which refers to the newly created CXTPChartPointSeriesPointView object.

CXTPChartSeriesPointView object abstracts the view of a point in a series.

◆ GetActualColor()

CXTPChartColor GetActualColor ( ) const
protected

Call this function to get the actual color of the series.

Returns
Returns the CXTPChartColor object representing an ARGB value.

◆ GetActualColor2()

CXTPChartColor GetActualColor2 ( ) const
protected

Call this function to get the second actual color of the series.

Returns
Returns the CXTPChartColor object representing an ARGB value.

◆ GetBorderActualColor()

CXTPChartColor GetBorderActualColor ( ) const
protected

Call this function to get the actual color of the series border.

Returns
Returns the CXTPChartColor object representing an ARGB value.
The documentation for this class was generated from the following file:
  • XTPChartAreaSeriesView.h


Toolkit Pro: CXTPChartAxis Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPChartAxis Class Referenceabstract

This abstract base class represents a chart axis as a kind of chart element. More...

Inheritance diagram for CXTPChartAxis:
[legend]

Public Member Functions

CXTPChartAxis (CXTPChartDiagram *pDiagram)
Constructs a CXTPChartAxis object.
virtual | ~CXTPChartAxis ()
Destroys a CXTPChartAxis object, handles cleanup.
virtual CXTPChartAxisView * | CreateView (CXTPChartDeviceContext *pDC, CXTPChartElementView *pParentView)
This function creates the view (CXTPChartAxisView)of the axis.
void | UpdateRange (CXTPChartDeviceContext *pDC, CXTPChartAxisView *pView)
This function updates the axis, with respect to the series values.
virtual BOOL | IsVertical () const =0
Override this method to tell that whether the axis is vertical.
virtual BOOL | IsValuesAxis () const =0
Override this method to tell that whether the axis is value type.
CXTPChartDiagram * | GetDiagram () const
Call this function to get the pointer to chart diagram 2D object associated with the chart axis object.
XTPChartScaleType | GetScaleType () const
Use this function to get the scale type used for the axis.
CXTPChartScaleTypeMap * | GetScaleTypeMap () const
Call this function to get the scale type map object associated with the axis.
virtual double | CalcSideMarginsValue (double nMinValue, double nMaxValue) const =0
Override this function to return the side margin value of the chart axis.
CXTPChartAxisRange * | GetRange () const
Use this function to get object which represents the range of the axis.
CXTPChartAxisLabel * | GetLabel () const
Call this function to get object which represents the label of the axis.
CXTPChartAxisGridLines * | GetGridLines () const
Use this function to get object which represents the axis gridlines.
CXTPChartAxisTickMarks * | GetTickMarks () const
Call this function to get the associated object which abstracts the axis tick marks.
CXTPChartAxisConstantLines * | GetConstantLines () const
Use this function to get the associated object which deals with constant lines parallel to the axis.
CXTPChartAxisCustomLabels * | GetCustomLabels () const
Use this function to get the associated object which deals with custom labels of aixs.
CXTPChartAxisStrips * | GetStrips () const
Call this function to get the associated object which deals with strips parallel to the axis.
CXTPChartAxisTitle * | GetTitle () const
Use this function to get the associated object which deals the axis title.
CXTPChartColor | GetActualColor () const
Gets the color of the axis.
CXTPChartColor | GetColor () const
Gets the color of the axis.
void | SetColor (const CXTPChartColor &color)
Sets the color of the axis.
CXTPChartColor | GetInterlacedColor () const
Gets the first interlaced strips color of the axis.
CXTPChartColor | GetActualInterlacedColor () const
Gets the first interlaced strips color of the axis.
void | SetInterlacedColor (const CXTPChartColor &color)
Sets the first interlaced strips color of the axis.
CXTPChartColor | GetInterlacedColor2 () const
Gets the second interlaced strips color of the axis.
CXTPChartColor | GetActualInterlacedColor2 () const
Gets the second interlaced strips color of the axis.
void | SetInterlacedColor2 (const CXTPChartColor &color)
Sets the second interlaced strips color of the axis.
CXTPChartFillStyle * | GetInterlacedFillStyle () const
Call this function to get the second interlaced strips background fill style.
XTPChartAxisAlignment | GetAlignment () const
Call this function to get the alignment of the axis.
void | SetAlignment (XTPChartAxisAlignment nAlignment)
Use this function to set the alignment of the axis.
BOOL | IsInterlaced () const
Call this function to get whether the interlaced strips are used.
void | SetInterlaced (BOOL bInterlaced)
Call this function to enable/disable the interlaced strips.
BOOL | IsVisible () const
Use this function to get whether the axis is visible.
void | SetVisible (BOOL bVisible)
Call this function to show/hide the axis.
int | GetThickness () const
Call this function to get the thickness of the axis line.
void | SetThickness (int nThicknes)
Call this function to set the thickness of the axis line.
int | GetIndex () const
Call this function to get index of the axis.
void | SetIndex (int nIndex)
Call this function to set the axis index.
void | SetMinorCount (int nMinorCount)
Call this function to set the minor count of the axis grid lines.
int | GetMinorCount () const
This function gives the minor count of the axis grid lines.
void | SetReversed (BOOL bRevered)
Use this function to reverse order the axis values.
BOOL | IsReversed () const
This function gives whether the axis points are reverse ordered or not.
CXTPChartAxisAppearance * | GetAppearance () const
This function returns the chart axis appeance object.
void | SetGridSpacingAuto (BOOL bGridSpacingAuto)
Sets value specifies whether space between grid lines in calculated automatically.
void | SetGridSpacing (double dGridSpacing)
Use this function to set the space between grid lines.
double | GetGridSpacing () const
Use this function to get the space between grid lines.
void | SetLogarithmic (BOOL bLogarithmic)
Set whether logarithmic scale should be used.
void | SetLogarithmicBase (double dLogarithmicBase)
Set logarithmic base when logarithmic scale is used.
void | SetDateTimeScaleUnit (XTPChartAxisDateTimeScaleUnit unit)
Call this method to set single unit for date time scale.
void | DoPropExchange (CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
- Public Member Functions inherited from CXTPChartElement
CXTPChartElement ()
Constructs a CXTPChartElement object.
virtual | ~CXTPChartElement ()
Destroys a CXTPChartElement object, handles cleanup.
virtual void | Release ()
Call this function to decrease the usage count of the object.
CXTPChartElement * | GetOwner () const
Call this function to get the owner element.
virtual void | OnChartChanged (XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic properties of the chart.
CXTPChartContent * | GetContent () const
Call this virtual function to get the chart content object.
CXTPChartAppearance * | GetAppearance () const
Call this function to get the the appearance of the chart.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Protected Attributes

CXTPChartDiagram * | m_pDiagram
The pointer to chart digram 2d object.
BOOL | m_bVisible
TRUE if the axis is visible, FALSE if invisible.
BOOL | m_bReversed
FALSE if the axis valus are in natural order, TRUE if it is in reverse order.
int | m_nThickness
The thickness of axis line.
int | m_nMinorCount
The number of minors present.
XTPChartAxisAlignment | m_nAlignment
The chart axis alignment, near or far.
CXTPChartColor m_clrColor
The chart color.
CXTPChartColor m_clrInterlacedColor
The first interlaced color.
CXTPChartColor m_clrInterlacedColor2
The second interlaced color.
CXTPChartFillStyle * m_pInterlacedFillStyle
The fill style of interlaced strips.
BOOL | m_bInterlaced
TRUE if the chart has interlaced strips parallel to the axis.
double | m_dGridSpacing
The spacing of the grid lines.
BOOL | m_bGridSpacingAuto
TURE if automatic spaceing of grid lines selected.FALSE for specific values.
BOOL | m_bLogarithmic
Logarithmic

double | m_dLogarithmicBase
Logarithic base.
CXTPChartAxisGridLines * m_pGridLines
Pointer to axis gridlines object.
CXTPChartAxisLabel * m_pLabel
Pointer to axis lable object.
CXTPChartAxisTitle * m_pTitle
Pointer to axis title object.
CXTPChartAxisTickMarks * m_pTickMarks
Pointer to axis tick marks object.
CXTPChartScaleTypeMap * m_pScaleTypeMap
Pointer to axis scale type object.
CXTPChartAxisRange * m_pRange
Pointer to axis range object.
CXTPChartAxisConstantLines * | m_pConstantLines
Pointer to axis constant lines object.
CXTPChartAxisCustomLabels * | m_pCustomLabels
Pointer to axis custom labels object.
CXTPChartAxisStrips * m_pStrips
Pointer to axis strips object.
XTPChartScaleType | m_nScaleType
Enumeated value denote the axis scale type.
- Protected Attributes inherited from CXTPChartElement

Additional Inherited Members

- Public Attributes inherited from CXTPChartElement
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.

Detailed Description

This abstract base class represents a chart axis as a kind of chart element.

It abstarcts all the features of a chart axis.

This is an abstract base class, act as the parent for the classes CXTPChartAxisX and CXTPChartAxisY.

Constructor & Destructor Documentation

◆ CXTPChartAxis()

CXTPChartAxis ( CXTPChartDiagram * pDiagram )

Constructs a CXTPChartAxis object.

Parameters
pDiagram Pointer to a CXTPChartDiagram2D object.

Member Function Documentation

◆ CalcSideMarginsValue()

virtual double CalcSideMarginsValue | ( | double | nMinValue,
 |  | double | nMaxValue ) const
 pure virtual

Override this function to return the side margin value of the chart axis.

Parameters
nMinValue | The minimum value of the chart axis.
nMaxValue | The maximum value of the chart axis.
Returns
Returns a double value, represents the margin.

Implemented in CXTPChartAxisX, CXTPChartAxisY, CXTPChartRadarAxisX, and CXTPChartRadarAxisY.

◆ CreateView()

virtual CXTPChartAxisView * CreateView | ( | CXTPChartDeviceContext * | pDC,
 |  | CXTPChartElementView * | pParentView )
 virtual

This function creates the view (CXTPChartAxisView)of the axis.

Parameters
pDC | The chart device context object pointer.
pParentView | The parent view of the axis.
Returns
Returns an pointer to CXTPChartAxisView object newly created.

Reimplemented in CXTPChartAxisX, CXTPChartAxisY, CXTPChartRadarAxisX, and CXTPChartRadarAxisY.

◆ DoPropExchange()

void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Reads this object from or writes this object to an archive.

Parameters
pPX A CXTPPropExchange object to serialize to or from.

Reimplemented from CXTPChartElement.

◆ GetActualColor()

CXTPChartColor GetActualColor ( ) const

Gets the color of the axis.

Returns
Returns the pointer to CXTPChartColor object, which give ARGB color value.

◆ GetActualInterlacedColor()

CXTPChartColor GetActualInterlacedColor ( ) const

Gets the first interlaced strips color of the axis.

Returns
Returns the pointer to CXTPChartColor object, which give ARGB color value.

◆ GetActualInterlacedColor2()

CXTPChartColor GetActualInterlacedColor2 ( ) const

Gets the second interlaced strips color of the axis.

Returns
Returns the pointer to CXTPChartColor object, which give ARGB color value.

◆ GetAlignment()

AFX_INLINE XTPChartAxisAlignment GetAlignment ( ) const

Call this function to get the alignment of the axis.

Returns
Returns an enumerated value XTPChartAxisAlignment,corresponding to the alignment selected.

Usage xtpChartAxisNear - for Y axis, near means left side of the chart for X axis it is the bottom side of the chart. xtpChartAxisFar - for Y axis, near means right side of the chart for X axis it is the top side of the chart.

◆ GetAppearance()

CXTPChartAxisAppearance * GetAppearance ( ) const

This function returns the chart axis appeance object.

Returns
The pointer to chart axis appeance object.

◆ GetColor()

CXTPChartColor GetColor ( ) const

Gets the color of the axis.

Returns
Returns the pointer to CXTPChartColor object, which give ARGB color value.

◆ GetConstantLines()

AFX_INLINE CXTPChartAxisConstantLines * GetConstantLines ( ) const

Use this function to get the associated object which deals with constant lines parallel to the axis.

Returns
Returns the pointer to the axis constant lines object.

◆ GetCustomLabels()

AFX_INLINE CXTPChartAxisCustomLabels * GetCustomLabels ( ) const

Use this function to get the associated object which deals with custom labels of aixs.

Returns
Returns the pointer to the axis custom labels object.

◆ GetDiagram()

AFX_INLINE CXTPChartDiagram * GetDiagram ( ) const

Call this function to get the pointer to chart diagram 2D object associated with the chart axis object.

Returns
Returns apointer to CXTPChartDiagram2D object.

◆ GetGridLines()

AFX_INLINE CXTPChartAxisGridLines * GetGridLines ( ) const

Use this function to get object which represents the axis gridlines.

Returns
Returns the pointer to the axis gridlines object.

CXTPChartAxisGridLines object handles the axis gridlines and its appearance.

◆ GetGridSpacing()

AFX_INLINE double GetGridSpacing ( ) const

Use this function to get the space between grid lines.

Returns
The space between grid lines.

◆ GetIndex()

AFX_INLINE int GetIndex ( ) const

Call this function to get index of the axis.

Returns
Returns an int value denoting the index of the axis.

◆ GetInterlacedColor()

CXTPChartColor GetInterlacedColor ( ) const

Gets the first interlaced strips color of the axis.

Returns
Returns the pointer to CXTPChartColor object, which give ARGB color value.

◆ GetInterlacedColor2()

CXTPChartColor GetInterlacedColor2 ( ) const

Gets the second interlaced strips color of the axis.

Returns
Returns the pointer to CXTPChartColor object, which give ARGB color value.

◆ GetInterlacedFillStyle()

CXTPChartFillStyle * GetInterlacedFillStyle ( ) const

Call this function to get the second interlaced strips background fill style.

Returns
Returns the pointer to CXTPChartFillStyle object, which abstracts various fill styles.

◆ GetLabel()

AFX_INLINE CXTPChartAxisLabel * GetLabel ( ) const

Call this function to get object which represents the label of the axis.

Returns
Returns the pointer to the axis label object.

CXTPChartAxisLabel object handles the chart label and its appearance.

◆ GetMinorCount()

AFX_INLINE int GetMinorCount ( ) const

This function gives the minor count of the axis grid lines.

Returns
The number of minor grid lines.

◆ GetRange()

AFX_INLINE CXTPChartAxisRange * GetRange ( ) const

Use this function to get object which represents the range of the axis.

Returns
Returns the pointer to the chart axis range object.

CXTPChartAxisRange object handles the range related things of an axis.

◆ GetScaleType()

AFX_INLINE XTPChartScaleType GetScaleType ( ) const

Use this function to get the scale type used for the axis.

Returns
Returns an enumerated value specifying the scale type used.

The main scale types are - Qualitative, Numerical, Date time.

◆ GetScaleTypeMap()

AFX_INLINE CXTPChartScaleTypeMap * GetScaleTypeMap ( ) const

Call this function to get the scale type map object associated with the axis.

Returns
Returns the pointer to a scale type map object.

CXTPChartScaleTypeMap object keep track of the apparent and internal(actual) value of a point in the axis.

◆ GetStrips()

AFX_INLINE CXTPChartAxisStrips * GetStrips ( ) const

Call this function to get the associated object which deals with strips parallel to the axis.

Returns
Returns the pointer to the axis strips object.

◆ GetThickness()

AFX_INLINE int GetThickness ( ) const

Call this function to get the thickness of the axis line.

Returns
Returns an int value denoting the thickness of the axis line.

◆ GetTickMarks()

AFX_INLINE CXTPChartAxisTickMarks * GetTickMarks ( ) const

Call this function to get the associated object which abstracts the axis tick marks.

Returns
Returns the pointer to the axis tick marks object.

CXTPChartAxisTickMarks object handles the axis tick marks and its appearance.

◆ GetTitle()

AFX_INLINE CXTPChartAxisTitle * GetTitle ( ) const

Use this function to get the associated object which deals the axis title.

Returns
Returns the pointer to the axis title object.

◆ IsInterlaced()

AFX_INLINE BOOL IsInterlaced ( ) const

Call this function to get whether the interlaced strips are used.

Returns
Returns TRUE if the interlaced strips are enabled, FALSE if it is not enabled.

◆ IsReversed()

AFX_INLINE BOOL IsReversed ( ) const

This function gives whether the axis points are reverse ordered or not.

Returns
TRUE for normal order, FALSE for reverse order.

◆ IsValuesAxis()

virtual BOOL IsValuesAxis ( ) const
pure virtual

Override this method to tell that whether the axis is value type.

Returns
Returns TRUE if the axis is value type, FALSE if the axis is not value type.

Implemented in CXTPChartAxisX, CXTPChartAxisY, CXTPChartRadarAxisX, and CXTPChartRadarAxisY.

◆ IsVertical()

virtual BOOL IsVertical ( ) const
pure virtual

Override this method to tell that whether the axis is vertical.

Returns
Returns TRUE if the axis is vertical, FALSE if the axis is not vertical.

Implemented in CXTPChartAxisX, CXTPChartAxisY, CXTPChartRadarAxisX, and CXTPChartRadarAxisY.

◆ IsVisible()

AFX_INLINE BOOL IsVisible ( ) const

Use this function to get whether the axis is visible.

Returns
Returns TRUE if the axis is visible, FALSE if the axis is not visible.

◆ SetAlignment()

AFX_INLINE void SetAlignment ( XTPChartAxisAlignment nAlignment )

Use this function to set the alignment of the axis.

Parameters
nAlignment enumerated value XTPChartAxisAlignment,corresponding to the alignment to be selected.

Usage xtpChartAxisNear - for Y axis, near means left side of the chart for X axis it is the bottom side of the chart. xtpChartAxisFar - for Y axis, near means right side of the chart for X axis it is the top side of the chart.

◆ SetColor()

AFX_INLINE void SetColor ( const CXTPChartColor & color )

Sets the color of the axis.

Parameters
color Color to be set.

◆ SetDateTimeScaleUnit()

AFX_INLINE void SetDateTimeScaleUnit ( XTPChartAxisDateTimeScaleUnit unit )

Call this method to set single unit for date time scale.

Parameters
unit new units to be set
See also
SetLogarithmic

◆ SetGridSpacing()

AFX_INLINE void SetGridSpacing ( double dGridSpacing )

Use this function to set the space between grid lines.

Parameters
dGridSpacing Space between grid lines.

Call SetGridSpacingAuto(FALSE) before.

◆ SetGridSpacingAuto()

AFX_INLINE void SetGridSpacingAuto ( BOOL bGridSpacingAuto )

Sets value specifies whether space between grid lines in calculated automatically.

Parameters
bGridSpacingAuto TRUE to calculate space between grid lines automatically

Call SetGridSpacing to set this space in case of bGridSpacingAuto = FALSE

◆ SetIndex()

AFX_INLINE void SetIndex ( int nIndex )

Call this function to set the axis index.

Parameters
nIndex The index of axis.

◆ SetInterlaced()

AFX_INLINE void SetInterlaced ( BOOL bInterlaced )

Call this function to enable/disable the interlaced strips.

Parameters
bInterlaced TRUE if the interlaced strips are to be enabled, FALSE to remove the interlaced strips.

◆ SetInterlacedColor()

AFX_INLINE void SetInterlacedColor ( const CXTPChartColor & color )

Sets the first interlaced strips color of the axis.

Parameters
color Color to be set.

◆ SetInterlacedColor2()

AFX_INLINE void SetInterlacedColor2 ( const CXTPChartColor & color )

Sets the second interlaced strips color of the axis.

Parameters
color Color to be set.

◆ SetLogarithmic()

AFX_INLINE void SetLogarithmic ( BOOL bLogarithmic )

Set whether logarithmic scale should be used.

Parameters
bLogarithmic TRUE to use logarithmic scale
See also
SetLogarithmicBase

◆ SetLogarithmicBase()

AFX_INLINE void SetLogarithmicBase ( double dLogarithmicBase )

Set logarithmic base when logarithmic scale is used.

Parameters
dLogarithmicBase logarithmic base
See also
SetLogarithmic

◆ SetMinorCount()

AFX_INLINE void SetMinorCount ( int nMinorCount )

Call this function to set the minor count of the axis grid lines.

Parameters
nMinorCount The number of minor grid lines.

◆ SetReversed()

AFX_INLINE void SetReversed ( BOOL bRevered )

Use this function to reverse order the axis values.

Parameters
bRevered TRUE for normal order, FALSE for reverse order.

◆ SetThickness()

AFX_INLINE void SetThickness ( int nThicknes )

Call this function to set the thickness of the axis line.

Parameters
nThicknes The thickness of the axis line.

◆ SetVisible()

AFX_INLINE void SetVisible ( BOOL bVisible )

Call this function to show/hide the axis.

Parameters
bVisible TRUE to make the axis visible, FALSE to hide the axis.

◆ UpdateRange()

void UpdateRange | ( | CXTPChartDeviceContext * | pDC,
 |  | CXTPChartAxisView * | pView )

This function updates the axis, with respect to the series values.

Parameters
pDC | A pointer to the device context
pView | Pointer to CXTPChartAxisView

Call this function whenever there is a change in series values.

Member Data Documentation

◆ m_clrColor

CXTPChartColor m_clrColor
protected

The chart color.

◆ m_clrInterlacedColor

CXTPChartColor m_clrInterlacedColor
protected

The first interlaced color.

◆ m_clrInterlacedColor2

CXTPChartColor m_clrInterlacedColor2
protected

The second interlaced color.

◆ m_pGridLines

CXTPChartAxisGridLines* m_pGridLines
protected

Pointer to axis gridlines object.

◆ m_pInterlacedFillStyle

CXTPChartFillStyle* m_pInterlacedFillStyle
protected

The fill style of interlaced strips.

◆ m_pLabel

CXTPChartAxisLabel* m_pLabel
protected

Pointer to axis lable object.

◆ m_pRange

CXTPChartAxisRange* m_pRange
protected

Pointer to axis range object.

◆ m_pScaleTypeMap

CXTPChartScaleTypeMap* m_pScaleTypeMap
protected

Pointer to axis scale type object.

◆ m_pStrips

CXTPChartAxisStrips* m_pStrips
protected

Pointer to axis strips object.

◆ m_pTickMarks

CXTPChartAxisTickMarks* m_pTickMarks
protected

Pointer to axis tick marks object.

◆ m_pTitle

CXTPChartAxisTitle* m_pTitle
protected

Pointer to axis title object.

The documentation for this class was generated from the following file:
  • XTPChartAxis.h


Toolkit Pro: CXTPChartAxisAppearance Class Reference

Public Member Functions | Public Attributes | List of all members
CXTPChartAxisAppearance Class Reference

This class represents the appearance of a chart axis.This class is is subclassed from CXTPChartElementAppearance class. More...

Inheritance diagram for CXTPChartAxisAppearance:
[legend]

Public Member Functions

CXTPChartAxisAppearance (CXTPChartElement *pOwner)
Constructs a CXTPChartAxisAppearance object.
virtual | ~CXTPChartAxisAppearance ()
Destroys a CXTPChartAxisAppearance object, handles cleanup.
void | DoPropExchange (CXTPPropExchange *pPX)
Call this member function to Store/Load the properties related to the appearance of a chart axis using the specified data object.
- Public Member Functions inherited from CXTPChartElementAppearance
CXTPChartElementAppearance (CXTPChartElement *pOwner)
Constructs a CXTPChartElementAppearance object.
virtual | ~CXTPChartElementAppearance ()
Destroys a CXTPChartElementAppearance object, handles cleanup.
virtual void | ApplyToDeviceContext (CXTPChartDeviceContext *pDC)
Applies implementation specific appearance settings to the device context provided.
- Public Member Functions inherited from CXTPChartElement
CXTPChartElement ()
Constructs a CXTPChartElement object.
virtual | ~CXTPChartElement ()
Destroys a CXTPChartElement object, handles cleanup.
virtual void | Release ()
Call this function to decrease the usage count of the object.
CXTPChartElement * | GetOwner () const
Call this function to get the owner element.
virtual void | OnChartChanged (XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic properties of the chart.
CXTPChartContent * | GetContent () const
Call this virtual function to get the chart content object.
CXTPChartAppearance * | GetAppearance () const
Call this function to get the the appearance of the chart.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Public Attributes

CXTPChartColor Color
The color of the axis.
CXTPChartColor InterlacedColor
The primary interlaced color.
CXTPChartColor InterlacedColor2
The secondary interlaced color.
CXTPChartFillStyle * | InterlacedFillStyle
The fill style used for interlacing.
CXTPChartColor GridLinesColor
The color of the grid lines.
CXTPChartColor | GridLinesMinorColor
The minor color of the grid lines.
CXTPChartColor | AxisLabelTextColor
The text color of the axis label.
CXTPChartColor | AxisTitleTextColor
The text color of the axis title.
CXTPChartColor | ConstantLineColor
The color of the contant line parallal to the axis.
CXTPChartColor ConstantLineTextColor
The text color of the contant color.
CXTPChartColor StripColor
The strip color.
CXTPChartColor | StripColor2
The strip gradient color.
- Public Attributes inherited from CXTPChartElement

Additional Inherited Members

- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.
- Protected Attributes inherited from CXTPChartElement

Detailed Description

This class represents the appearance of a chart axis.This class is is subclassed from CXTPChartElementAppearance class.

Constructor & Destructor Documentation

◆ CXTPChartAxisAppearance()

CXTPChartAxisAppearance ( CXTPChartElement * pOwner )

Constructs a CXTPChartAxisAppearance object.

Parameters
pOwner Pointer to an owner element.

Member Function Documentation

◆ DoPropExchange()

void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Call this member function to Store/Load the properties related to the appearance of a chart axis using the specified data object.

Parameters
pPX Source or destination CXTPPropExchange data object reference.

This member function is used to store or load property data to or from a storage.

Reimplemented from CXTPChartElement.

Member Data Documentation

◆ Color

CXTPChartColor Color

The color of the axis.

◆ ConstantLineTextColor

CXTPChartColor ConstantLineTextColor

The text color of the contant color.

◆ GridLinesColor

CXTPChartColor GridLinesColor

The color of the grid lines.

◆ InterlacedColor

CXTPChartColor InterlacedColor

The primary interlaced color.

◆ InterlacedColor2

CXTPChartColor InterlacedColor2

The secondary interlaced color.

◆ StripColor

CXTPChartColor StripColor

The strip color.

The documentation for this class was generated from the following file:
  • XTPChartAppearance.h


Toolkit Pro: CXTPChartAxisConstantLine Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPChartAxisConstantLine Class Reference

CXTPChartAxisConstantLine is a hybrid object derived from CXTPChartTextElement and CXTPChartLegendItemView. More...

Inheritance diagram for CXTPChartAxisConstantLine:
[legend]

Public Member Functions

CXTPChartAxisConstantLine ()
Constructs a CXTPChartAxisConstantLine object.
virtual | ~CXTPChartAxisConstantLine ()
Destroys a CXTPChartAxisConstantLine object, handles cleanup.
void | SetVisible (BOOL bVisible)
Call this function to set the visibility of the axis constant line.
BOOL | IsVisible () const
Call this function to check the visibility of the axis constant line.
void | SetLegendVisible (BOOL bVisible)
Call this function to set the visibility of the constant line legend item.
BOOL | IsLegendVisible () const
Call this function to check the visibility of the constant line legend item.
void | SetText (const CXTPChartString &lpszTitle)
Use this function to set the text of the constant line legend item.
CXTPChartString | GetText () const
Call this function to get the text of the constant line legend item.
void | SetTextColor (const CXTPChartColor &clrTextColor)
Use this function to set the text color of the constant line legend item.
CXTPChartColor | GetTextColor () const
Use this function to get the text color of the constant line legend item.
CXTPChartColor | GetActualTextColor () const
Use this function to get the actual text color of the constant line legend item.
CXTPChartFont * | GetFont () const
Use this function to get the font of the constant line legend item text.
void | SetFont (CXTPChartFont *pFont)
Use this function to set the font of the constant line legend item text.
void | SetAlignment (XTPChartStringAlignment nAlignment)
Use this function to set the text alignment of the constant line legend item text.
XTPChartStringAlignment | GetAlignment () const
Call this function to get the alignment of the constant line legend item text.
void | SetAntialiasing (BOOL bAntialiasing)
Call this function to set anti-aliasing ON or OFF.
BOOL | GetAntialiasing () const
Call this function to check if anti-aliasing is ON or OFF.
CXTPChartString | GetLegendName () const
Call this function to get the legend name.
void | SetLegendName (const CXTPChartString &strName)
Call this function to set the legend name.
CXTPChartLineStyle * | GetLineStyle () const
Call this function to get the constant line style.
CXTPChartString | GetAxisValue () const
Use this function to get the value of the constant line in the axis.
double | GetAxisValueInternal () const
Use this function to get the value of the constant line in the axis.
void | SetAxisValue (LPCTSTR lpszValue)
Call this function to set the value of the constant line in the axis.
void | SetAxisValue (double dValue)
Call this function to set the value of the constant line in the axis.
CXTPChartColor | GetActualColor () const
Use this function to get the value of the actual color of the constant line.
void | DoPropExchange (CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
- Public Member Functions inherited from CXTPChartTextElement
- Public Member Functions inherited from CXTPChartElement
CXTPChartElement ()
Constructs a CXTPChartElement object.
virtual | ~CXTPChartElement ()
Destroys a CXTPChartElement object, handles cleanup.
virtual void | Release ()
Call this function to decrease the usage count of the object.
CXTPChartElement * | GetOwner () const
Call this function to get the owner element.
virtual void | OnChartChanged (XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic properties of the chart.
CXTPChartContent * | GetContent () const
Call this virtual function to get the chart content object.
CXTPChartAppearance * | GetAppearance () const
Call this function to get the the appearance of the chart.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.
- Public Member Functions inherited from CXTPChartLegendItemView
virtual | ~CXTPChartLegendItemView ()
Handles object destruction.

Protected Member Functions

virtual CXTPChartDeviceCommand * CreateLegendDeviceCommand (CXTPChartDeviceContext *pDC, CRect rcBounds)
This function creates a CXTPChartDeviceCommand object.
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.

Protected Attributes

BOOL | m_bLegendVisible
TRUE if the legend is visible, FALSE if invisible.
BOOL | m_bVisible
TRUE if the constant line is visible, FALSE if invisible.
CXTPChartString | m_strText
The text of the constant line legend item.
CXTPChartString | m_strLegendName
The legend name.
CXTPChartString | m_strAxisValue
The string value of constant line parallel to an axis.
CXTPChartColor | m_clrTextColor
The text color of the constant line legend item.
CXTPChartColor | m_clrColor
The color of the constant line.
XTPChartStringAlignment | m_nAlignment
The text alignment of the constant line legend item.
BOOL | m_bAntialiasing
TRUE if anti-aliasing is used, FALSE if not using antialiasing.
CXTPChartFont * | m_pFont
The font used for the text of the constant line legend item.
BOOL | m_bShowTextBelow
TRUE if the text is below, FALSE if not.
BOOL | m_bShowBehind
TRUE if the text is behind, FALSE if not.
CXTPChartLineStyle * | m_pLineStyle
The chart line style object.
- Protected Attributes inherited from CXTPChartElement

Detailed Description

CXTPChartAxisConstantLine is a hybrid object derived from CXTPChartTextElement and CXTPChartLegendItemView.

This class represents a constant line parallel to an axis. Normally this class is owned by an axis object (CXTPChartAxis).

Member Function Documentation

◆ CreateLegendDeviceCommand()

virtual CXTPChartDeviceCommand * CreateLegendDeviceCommand | ( | CXTPChartDeviceContext * | pDC,
 |  | CRect | rcBounds )
 protectedvirtual

This function creates a CXTPChartDeviceCommand object.

This object represents the rendering of the legend item.

Parameters
pDC | Pointer to a CXTPChartDeviceContext object.
rcBounds | The bounding rectangle.
Returns
Returns a CXTPChartDeviceCommand object, this polymorphic object handles the rendering of an element in the chart. Here it handles the drawing of the legend item.

Implements CXTPChartLegendItemView.

◆ DoPropExchange()

void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Reads this object from or writes this object to an archive.

Parameters
pPX A CXTPPropExchange object to serialize to or from.

Reimplemented from CXTPChartElement.

◆ GetActualColor()

CXTPChartColor GetActualColor ( ) const

Use this function to get the value of the actual color of the constant line.

Returns
A CXTPChartColor object denoting the ARGB value.

◆ GetActualTextColor()

CXTPChartColor GetActualTextColor ( ) const

Use this function to get the actual text color of the constant line legend item.

Returns
The CXTPChartColor value for the actual text color.

◆ GetAlignment()

AFX_INLINE XTPChartStringAlignment GetAlignment ( ) const

Call this function to get the alignment of the constant line legend item text.

Returns
The XTPChartStringAlignment enumeration corresponding to the chosen alignment.

◆ GetAntialiasing()

AFX_INLINE BOOL GetAntialiasing ( ) const
virtual

Call this function to check if anti-aliasing is ON or OFF.

Anti-aliasing is the smoothing of sharp edges of text and drawing.

Returns
A BOOL value. TRUE if anti-aliasing is ON, FALSE if anti-aliasing is OFF.

Implements CXTPChartTextElement.

◆ GetAxisValue()

AFX_INLINE CXTPChartString GetAxisValue ( ) const

Use this function to get the value of the constant line in the axis.

Returns
A string/double denoting the axis value.

◆ GetAxisValueInternal()

AFX_INLINE double GetAxisValueInternal ( ) const

Use this function to get the value of the constant line in the axis.

Returns
A string/double denoting the axis value.

◆ GetFont()

AFX_INLINE CXTPChartFont * GetFont ( ) const
virtual

Use this function to get the font of the constant line legend item text.

Returns
The CXTPChartFont value of the font used to render the text.

Implements CXTPChartTextElement.

◆ GetLegendName()

CXTPChartString GetLegendName ( ) const
virtual

Call this function to get the legend name.

Returns
The string value of the legend name. Its type is CXTPChartString.

Implements CXTPChartLegendItemView.

◆ GetLineStyle()

AFX_INLINE CXTPChartLineStyle * GetLineStyle ( ) const

Call this function to get the constant line style.

Returns
The pointer to an object of type CXTPChartLineStyle.

◆ GetText()

AFX_INLINE CXTPChartString GetText ( ) const

Call this function to get the text of the constant line legend item.

Returns
The string value of the text. Its type is CXTPChartString.

◆ GetTextColor()

CXTPChartColor GetTextColor ( ) const

Use this function to get the text color of the constant line legend item.

Returns
The CXTPChartColor value of the text color.

◆ IsLegendVisible()

AFX_INLINE BOOL IsLegendVisible ( ) const

Call this function to check the visibility of the constant line legend item.

Returns
BOOL value. TRUE if the constant line legend item is visible, FALSE otherwise.

◆ IsVisible()

AFX_INLINE BOOL IsVisible ( ) const

Call this function to check the visibility of the axis constant line.

Returns
A BOOL value. TRUE if the axis constant line is visible, FALSE otherwise.

◆ SetAlignment()

void SetAlignment ( XTPChartStringAlignment nAlignment )

Use this function to set the text alignment of the constant line legend item text.

Parameters
nAlignment The enumerated value for the text alignment, the common alignments are near, far and center.

◆ SetAntialiasing()

AFX_INLINE void SetAntialiasing ( BOOL bAntialiasing )

Call this function to set anti-aliasing ON or OFF.

Anti-aliasing is the smoothing of sharp edges of text and drawing.

Parameters
bAntialiasing A BOOL value. TRUE to set anti-aliasing to ON, FALSE to set anti-aliasing to OFF.

◆ SetAxisValue() [1/2]

AFX_INLINE void SetAxisValue ( double dValue )

Call this function to set the value of the constant line in the axis.

Parameters
dValue A double denoting the axis value.

◆ SetAxisValue() [2/2]

AFX_INLINE void SetAxisValue ( LPCTSTR lpszValue )

Call this function to set the value of the constant line in the axis.

Parameters
lpszValue A string denoting the axis value.

◆ SetFont()

void SetFont ( CXTPChartFont * pFont )

Use this function to set the font of the constant line legend item text.

Parameters
pFont The CXTPChartFont value for the font to be used to render the text.

◆ SetLegendName()

AFX_INLINE void SetLegendName ( const CXTPChartString & strName )

Call this function to set the legend name.

Parameters
strName The string value for the legend name. Its type is CXTPChartString.

◆ SetLegendVisible()

AFX_INLINE void SetLegendVisible ( BOOL bVisible )

Call this function to set the visibility of the constant line legend item.

Parameters
bVisible A BOOL value. TRUE to set the constant line legend item to visible, FALSE to hide the constant line legend item.

◆ SetText()

void SetText ( const CXTPChartString & lpszTitle )

Use this function to set the text of the constant line legend item.

Parameters
lpszTitle The string value for the text. Its type is CXTPChartString.

◆ SetTextColor()

void SetTextColor ( const CXTPChartColor & clrTextColor )

Use this function to set the text color of the constant line legend item.

Parameters
clrTextColor The CXTPChartColor value for the text color.

◆ SetVisible()

AFX_INLINE void SetVisible ( BOOL bVisible )

Call this function to set the visibility of the axis constant line.

Parameters
bVisible BOOL value. TRUE to set the axis constant line to visible, FALSE to hide the axis constant line.
The documentation for this class was generated from the following file:
  • XTPChartAxisConstantLines.h


Toolkit Pro: CXTPChartAxisConstantLines Class Reference

Public Member Functions | List of all members
CXTPChartAxisConstantLines Class Reference

This class encapsulates a collection of CXTPChartAxisConstantLine objects. More...

Inheritance diagram for CXTPChartAxisConstantLines:
[legend]

Public Member Functions

CXTPChartAxisConstantLines (CXTPChartAxis *pAxis)
Constructs a CXTPChartAxisConstantLines object.
virtual | ~CXTPChartAxisConstantLines ()
Destroys a CXTPChartAxisConstantLines object, handles cleanup.
CXTPChartAxisConstantLine * | Add (CXTPChartAxisConstantLine *pConstantLine)
This function adds a new constant line to the collection of lines.
CXTPChartAxisConstantLine * | GetAt (int nIndex) const
Call this function to get the constant line object at a particular index in the collection.
void | DoPropExchange (CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
- Public Member Functions inherited from CXTPChartElementCollection
CXTPChartElementCollection ()
Constructs a CXTPChartElementCollection object.
~CXTPChartElementCollection ()
Destroys a CXTPChartElementCollection object, handles cleanup.
virtual void | RemoveAll ()
This function removes all the individual objects from this collection object.
virtual int | GetCount () const
Call this function to get the number of objects in the internal array of this object.
virtual void | RemoveAt (int nIndex)
Use this function to remove an object from the collection.
virtual void | Remove (CXTPChartElement *pElement)
Use this function to remove an object from the collection.
CXTPChartElement * | GetAt (int nIndex) const
Call this function to get an element by its index.
int | IndexOf (CXTPChartElement *pElement) const
Call this function to get the index of a specified element.
void | InsertAt (int nIndex, CXTPChartElement *pElement)
Call this method to add a new element to the collection.
virtual void | Release ()
Call this function to decrease the usage count of the object.
- Public Member Functions inherited from CXTPChartElement
CXTPChartElement ()
Constructs a CXTPChartElement object.
virtual | ~CXTPChartElement ()
Destroys a CXTPChartElement object, handles cleanup.
CXTPChartElement * | GetOwner () const
Call this function to get the owner element.
virtual void | OnChartChanged (XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic properties of the chart.
CXTPChartContent * | GetContent () const
Call this virtual function to get the chart content object.
CXTPChartAppearance * | GetAppearance () const
Call this function to get the the appearance of the chart.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Additional Inherited Members

- Public Attributes inherited from CXTPChartElement
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.
- Protected Attributes inherited from CXTPChartElementCollection
CArray< CXTPChartElement *, CXTPChartElement * > m_arrElements
Array of CXTPChartElement pointer.
- Protected Attributes inherited from CXTPChartElement

Detailed Description

This class encapsulates a collection of CXTPChartAxisConstantLine objects.

Constructor & Destructor Documentation

◆ CXTPChartAxisConstantLines()

CXTPChartAxisConstantLines ( CXTPChartAxis * pAxis )

Constructs a CXTPChartAxisConstantLines object.

Parameters
pAxis The pointer to a CXTPChartAxis object.

Member Function Documentation

◆ Add()

CXTPChartAxisConstantLine * Add ( CXTPChartAxisConstantLine * pConstantLine )

This function adds a new constant line to the collection of lines.

Parameters
pConstantLine The pointer to a CXTPChartAxisConstantLine object.
Returns
A newly added constant line object pointer.

◆ DoPropExchange()

void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Reads this object from or writes this object to an archive.

Parameters
pPX A CXTPPropExchange object to serialize to or from.

Reimplemented from CXTPChartElement.

◆ GetAt()

AFX_INLINE CXTPChartAxisConstantLine * GetAt ( int nIndex ) const

Call this function to get the constant line object at a particular index in the collection.

Parameters
nIndex The zero-based index of the item in the collection.
Returns
The pointer to the CXTPChartAxisConstantLine object at the index selected.
The documentation for this class was generated from the following file:
  • XTPChartAxisConstantLines.h


Toolkit Pro: CXTPChartAxisCustomLabel Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPChartAxisCustomLabel Class Reference

CXTPChartAxisCustomLabel is a CXTPChartElement derived class. More...

Inheritance diagram for CXTPChartAxisCustomLabel:
[legend]

Public Member Functions

CXTPChartAxisCustomLabel ()
Constructs a CXTPChartAxisCustomLabel object.
virtual | ~CXTPChartAxisCustomLabel ()
Destroys a CXTPChartAxisCustomLabel object, handles cleanup.
void | SetText (const CXTPChartString &lpszTitle)
Use this function to set the text of the custom label.
CXTPChartString | GetText () const
Call this function to get the text of the custom label.
CXTPChartString | GetAxisValue () const
Use this function to get the value of the constant line in the axis.
double | GetAxisValueInternal () const
Use this function to get the value of the constant line in the axis.
void | SetAxisValue (LPCTSTR lpszValue)
Call this function to set the value of the constant line in the axis.
void | SetAxisValue (double dValue)
Call this function to set the value of the constant line in the axis.
void | DoPropExchange (CXTPPropExchange *pPX)
Call this member function to Store/Load the label properties using the specified data object.
- Public Member Functions inherited from CXTPChartElement
CXTPChartElement ()
Constructs a CXTPChartElement object.
virtual | ~CXTPChartElement ()
Destroys a CXTPChartElement object, handles cleanup.
virtual void | Release ()
Call this function to decrease the usage count of the object.
CXTPChartElement * | GetOwner () const
Call this function to get the owner element.
virtual void | OnChartChanged (XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic properties of the chart.
CXTPChartContent * | GetContent () const
Call this virtual function to get the chart content object.
CXTPChartAppearance * | GetAppearance () const
Call this function to get the the appearance of the chart.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Protected Attributes

CXTPChartString | m_strText
The text of the item.
CXTPChartString | m_strAxisValue
The axis value.
- Protected Attributes inherited from CXTPChartElement

Additional Inherited Members

- Public Attributes inherited from CXTPChartElement
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.

Detailed Description

CXTPChartAxisCustomLabel is a CXTPChartElement derived class.

This class represents a custom label text on Axis (CXTPChartAxis).

Member Function Documentation

◆ DoPropExchange()

void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Call this member function to Store/Load the label properties using the specified data object.

Parameters
pPX Source or destination CXTPPropExchange data object reference.

This member function is used to store property data to or load property data from storage.

Reimplemented from CXTPChartElement.

◆ GetAxisValue()

AFX_INLINE CXTPChartString GetAxisValue ( ) const

Use this function to get the value of the constant line in the axis.

Returns
A string/double denoting the axis value.

◆ GetAxisValueInternal()

AFX_INLINE double GetAxisValueInternal ( ) const

Use this function to get the value of the constant line in the axis.

Returns
A string/double denoting the axis value.

◆ GetText()

AFX_INLINE CXTPChartString GetText ( ) const

Call this function to get the text of the custom label.

Returns
The string value for the item text. Its type is CXTPChartString.

◆ SetAxisValue() [1/2]

AFX_INLINE void SetAxisValue ( double dValue )

Call this function to set the value of the constant line in the axis.

Parameters
dValue A double denoting the axis value.

◆ SetAxisValue() [2/2]

AFX_INLINE void SetAxisValue ( LPCTSTR lpszValue )

Call this function to set the value of the constant line in the axis.

Parameters
lpszValue A string denoting the axis value.

◆ SetText()

void SetText ( const CXTPChartString & lpszTitle )

Use this function to set the text of the custom label.

Parameters
lpszTitle The string value for the new text. Its type is CXTPChartString.
The documentation for this class was generated from the following file:
  • XTPChartAxisCustomLabels.h


Toolkit Pro: CXTPChartAxisCustomLabels Class Reference

Public Member Functions | List of all members
CXTPChartAxisCustomLabels Class Reference

This class encapsulates a collection of CXTPChartAxisCustomLabel objects. More...

Inheritance diagram for CXTPChartAxisCustomLabels:
[legend]

Public Member Functions

CXTPChartAxisCustomLabels (CXTPChartAxis *pAxis)
Constructs a CXTPChartAxisCustomLabels object.
virtual | ~CXTPChartAxisCustomLabels ()
Destroys a CXTPChartAxisCustomLabels object, handles cleanup.
CXTPChartAxisCustomLabel * | Add (CXTPChartAxisCustomLabel *pCustomLabel)
This function adds a new custom label to the collection of labels.
CXTPChartAxisCustomLabel * | GetAt (int nIndex) const
Call this function to get the label object at a particular index in the collection.
void | DoPropExchange (CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
- Public Member Functions inherited from CXTPChartElementCollection
CXTPChartElementCollection ()
Constructs a CXTPChartElementCollection object.
~CXTPChartElementCollection ()
Destroys a CXTPChartElementCollection object, handles cleanup.
virtual void | RemoveAll ()
This function removes all the individual objects from this collection object.
virtual int | GetCount () const
Call this function to get the number of objects in the internal array of this object.
virtual void | RemoveAt (int nIndex)
Use this function to remove an object from the collection.
virtual void | Remove (CXTPChartElement *pElement)
Use this function to remove an object from the collection.
CXTPChartElement * | GetAt (int nIndex) const
Call this function to get an element by its index.
int | IndexOf (CXTPChartElement *pElement) const
Call this function to get the index of a specified element.
void | InsertAt (int nIndex, CXTPChartElement *pElement)
Call this method to add a new element to the collection.
virtual void | Release ()
Call this function to decrease the usage count of the object.
- Public Member Functions inherited from CXTPChartElement
CXTPChartElement ()
Constructs a CXTPChartElement object.
virtual | ~CXTPChartElement ()
Destroys a CXTPChartElement object, handles cleanup.
CXTPChartElement * | GetOwner () const
Call this function to get the owner element.
virtual void | OnChartChanged (XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic properties of the chart.
CXTPChartContent * | GetContent () const
Call this virtual function to get the chart content object.
CXTPChartAppearance * | GetAppearance () const
Call this function to get the the appearance of the chart.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Additional Inherited Members

- Public Attributes inherited from CXTPChartElement
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.
- Protected Attributes inherited from CXTPChartElementCollection
CArray< CXTPChartElement *, CXTPChartElement * > m_arrElements
Array of CXTPChartElement pointer.
- Protected Attributes inherited from CXTPChartElement

Detailed Description

This class encapsulates a collection of CXTPChartAxisCustomLabel objects.

Constructor & Destructor Documentation

◆ CXTPChartAxisCustomLabels()

CXTPChartAxisCustomLabels ( CXTPChartAxis * pAxis )

Constructs a CXTPChartAxisCustomLabels object.

Parameters
pAxis The pointer to a CXTPChartAxis object.

Member Function Documentation

◆ Add()

CXTPChartAxisCustomLabel * Add ( CXTPChartAxisCustomLabel * pCustomLabel )

This function adds a new custom label to the collection of labels.

Parameters
pCustomLabel The pointer to a CXTPChartAxisCustomLabel object.
Returns
A newly added custom label object pointer.

◆ DoPropExchange()

void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Reads this object from or writes this object to an archive.

Parameters
pPX A CXTPPropExchange object to serialize to or from.

Reimplemented from CXTPChartElement.

◆ GetAt()

AFX_INLINE CXTPChartAxisCustomLabel * GetAt ( int nIndex ) const

Call this function to get the label object at a particular index in the collection.

Parameters
nIndex The zero-based index of the item in the collection.
Returns
The pointer to the CXTPChartAxisCustomLabel object at the index selected.
The documentation for this class was generated from the following file:
  • XTPChartAxisCustomLabels.h


Toolkit Pro: CXTPChartAxisGridLines Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPChartAxisGridLines Class Reference

CXTPChartAxisGridLines is a kind of CXTPChartElement, This class represents the grid lines parallel to an axis. More...

Inheritance diagram for CXTPChartAxisGridLines:
[legend]

Public Member Functions

CXTPChartAxisGridLines (CXTPChartAxis *pAxis)
Constructs a CXTPChartAxisGridLines object.
virtual | ~CXTPChartAxisGridLines ()
Destroys a CXTPChartAxisGridLines object, handles cleanup.
BOOL | IsVisible () const
Call this function to check the visibility of the grid lines.
void | SetVisible (BOOL bVisible)
Call this function to set the visibility of the grid lines.
BOOL | IsMinorVisible () const
Call this function to check the visibility of the minor grid lines.
void | SetMinorVisible (BOOL bMinorVisible)
Call this function to set the visibility of the minor grid lines.
CXTPChartColor | GetColor () const
Use this function to get the color of the grid lines.
CXTPChartColor | GetMinorColor () const
Use this function to get the color of the minor grid lines.
CXTPChartLineStyle * | GetLineStyle () const
Use this function to get the grid line style used.
CXTPChartLineStyle * | GetMinorLineStyle () const
Use this function to get the minor grid line style used.
CXTPChartAxis * | GetAxis () const
Call this function to get the axis object to which the grid lines are associated.
void | DoPropExchange (CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
- Public Member Functions inherited from CXTPChartElement
CXTPChartElement ()
Constructs a CXTPChartElement object.
virtual | ~CXTPChartElement ()
Destroys a CXTPChartElement object, handles cleanup.
virtual void | Release ()
Call this function to decrease the usage count of the object.
CXTPChartElement * | GetOwner () const
Call this function to get the owner element.
virtual void | OnChartChanged (XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic properties of the chart.
CXTPChartContent * | GetContent () const
Call this virtual function to get the chart content object.
CXTPChartAppearance * | GetAppearance () const
Call this function to get the the appearance of the chart.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Protected Attributes

BOOL | m_bVisible
TRUE if the grid lines are visible, FALSE if not.
BOOL | m_bMinorVisible
TRUE if the minor grid lines are visible, FALSE if not.
CXTPChartColor | m_clrColor
ARGB value of the grid lines color.
CXTPChartColor | m_clrMinorColor
ARGB value of the minor grid lines color.
CXTPChartLineStyle * | m_pLineStyle
The grid line style.
CXTPChartLineStyle * | m_pMinorLineStyle
The minor grid line style.
- Protected Attributes inherited from CXTPChartElement

Additional Inherited Members

- Public Attributes inherited from CXTPChartElement
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.

Detailed Description

CXTPChartAxisGridLines is a kind of CXTPChartElement, This class represents the grid lines parallel to an axis.

Constructor & Destructor Documentation

◆ CXTPChartAxisGridLines()

CXTPChartAxisGridLines ( CXTPChartAxis * pAxis )

Constructs a CXTPChartAxisGridLines object.

Parameters
pAxis Pointer to a chart axis object.

Member Function Documentation

◆ DoPropExchange()

void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Reads this object from or writes this object to an archive.

Parameters
pPX A CXTPPropExchange object to serialize to or from.

Reimplemented from CXTPChartElement.

◆ GetAxis()

AFX_INLINE CXTPChartAxis * GetAxis ( ) const

Call this function to get the axis object to which the grid lines are associated.

Returns
A pointer to the CXTPChartAxis object representing the chart axis.

◆ GetColor()

CXTPChartColor GetColor ( ) const

Use this function to get the color of the grid lines.

Returns
A CXTPChartColor object representing the ARGB color value selected.

◆ GetLineStyle()

AFX_INLINE CXTPChartLineStyle * GetLineStyle ( ) const

Use this function to get the grid line style used.

Returns
A pointer to the CXTPChartLineStyle object representing the grid line style selected.

◆ GetMinorColor()

CXTPChartColor GetMinorColor ( ) const

Use this function to get the color of the minor grid lines.

Returns
A CXTPChartColor object representing the ARGB color value selected.

◆ GetMinorLineStyle()

AFX_INLINE CXTPChartLineStyle * GetMinorLineStyle ( ) const

Use this function to get the minor grid line style used.

Returns
A pointer to the CXTPChartLineStyle object representing the minor grid line style selected.

◆ IsMinorVisible()

AFX_INLINE BOOL IsMinorVisible ( ) const

Call this function to check the visibility of the minor grid lines.

Returns
A BOOL value. TRUE if the minor grid lines are visible, FALSE otherwise.

◆ IsVisible()

AFX_INLINE BOOL IsVisible ( ) const

Call this function to check the visibility of the grid lines.

Returns
A BOOL value. TRUE if the grid lines are visible, FALSE otherwise.

◆ SetMinorVisible()

AFX_INLINE void SetMinorVisible ( BOOL bMinorVisible )

Call this function to set the visibility of the minor grid lines.

Parameters
bMinorVisible A BOOL value. TRUE to set the minor grid lines to visible, FALSE to hide the minor grid lines.

◆ SetVisible()

AFX_INLINE void SetVisible ( BOOL bVisible )

Call this function to set the visibility of the grid lines.

Parameters
bVisible A BOOL value. TRUE to set the grid lines to visible, FALSE to hide the grid lines.
The documentation for this class was generated from the following file:
  • XTPChartAxisGridLines.h


Toolkit Pro: CXTPChartAxisLabel Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPChartAxisLabel Class Reference

CXTPChartAxisLabel is a kind of CXTPChartTextElement. More...

Inheritance diagram for CXTPChartAxisLabel:
[legend]

Public Member Functions

CXTPChartAxisLabel (CXTPChartAxis *pAxis)
Constructs a CXTPChartAxisLabel object.
virtual | ~CXTPChartAxisLabel ()
Destroys a CXTPChartAxisLabel object, handles cleanup.
void | SetTextColor (const CXTPChartColor &clrTextColor)
Call this function to set the text color of the axis label.
CXTPChartColor | GetTextColor () const
Call this function to get the apparent text color of the axis label.
CXTPChartColor | GetActualTextColor () const
Call this function to get the real text color of the axis label.
void | SetFont (CXTPChartFont *pFont)
Call this function to set the font of the axis label text.
CXTPChartFont * | GetFont () const
Call this function to get the font of the axis label.
int | GetAngle () const
Call this function to get the angle of the text label.
void | SetAngle (int nAgle)
Call this function to set the angle of the text label.
void | SetAntialiasing (BOOL bAntialiasing)
Call this function to set anti-aliasing ON or OFF.
BOOL | GetAntialiasing () const
Call this function to check if anti-aliasing is ON or OFF.
void | SetVisible (BOOL bVisible)
Call this function to set the visibility of the text label.
BOOL | IsVisible () const
Call this function to check the visibility of the text label.
CXTPChartNumberFormat * | GetFormat () const
Call this function to get a pointer to CXTPChartNumberFormat which specifies how to convert a number to a string.
void | SetFormat (LPCTSTR lpszFormat)
Obsolete method.
CXTPChartAxis * | GetAxis () const
Use this function to get the pointer to the axis object to which the label is associated.
void | DoPropExchange (CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
- Public Member Functions inherited from CXTPChartTextElement
- Public Member Functions inherited from CXTPChartElement
CXTPChartElement ()
Constructs a CXTPChartElement object.
virtual | ~CXTPChartElement ()
Destroys a CXTPChartElement object, handles cleanup.
virtual void | Release ()
Call this function to decrease the usage count of the object.
CXTPChartElement * | GetOwner () const
Call this function to get the owner element.
virtual void | OnChartChanged (XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic properties of the chart.
CXTPChartContent * | GetContent () const
Call this virtual function to get the chart content object.
CXTPChartAppearance * | GetAppearance () const
Call this function to get the the appearance of the chart.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Protected Attributes

CXTPChartColor | m_clrTextColor
The text color.
CXTPChartFont * | m_pFont
The font used to render the text.
BOOL | m_bVisible
TRUE if the label is visible, FALSE if not.
BOOL | m_bAntialiasing
TRUE if antialiasing enabled, FALSE if not.
int | m_nAngle
The angle of the label.
- Protected Attributes inherited from CXTPChartElement

Additional Inherited Members

- Public Attributes inherited from CXTPChartElement
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.

Detailed Description

CXTPChartAxisLabel is a kind of CXTPChartTextElement.

This class represents the text label on an axis.

This class is associated with a chart axis class.

Constructor & Destructor Documentation

◆ CXTPChartAxisLabel()

CXTPChartAxisLabel ( CXTPChartAxis * pAxis )

Constructs a CXTPChartAxisLabel object.

Parameters
pAxis Pointer to the associated chart axis object.

Member Function Documentation

◆ DoPropExchange()

void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Reads this object from or writes this object to an archive.

Parameters
pPX A CXTPPropExchange object to serialize to or from.

Reimplemented from CXTPChartElement.

◆ GetActualTextColor()

CXTPChartColor GetActualTextColor ( ) const

Call this function to get the real text color of the axis label.

Returns
A chart color object representing an ARGB value.

◆ GetAngle()

AFX_INLINE int GetAngle ( ) const

Call this function to get the angle of the text label.

Returns
An integer value representing the angle.

◆ GetAntialiasing()

AFX_INLINE BOOL GetAntialiasing ( ) const
virtual

Call this function to check if anti-aliasing is ON or OFF.

Anti-aliasing is the smoothing of sharp edges of text and drawing.

Returns
A BOOL value. TRUE if anti-aliasing is ON, FALSE if anti-aliasing is OFF.

Implements CXTPChartTextElement.

◆ GetAxis()

AFX_INLINE CXTPChartAxis * GetAxis ( ) const

Use this function to get the pointer to the axis object to which the label is associated.

Returns
A pointer to the axis object.

◆ GetFont()

AFX_INLINE CXTPChartFont * GetFont ( ) const
virtual

Call this function to get the font of the axis label.

Returns
A pointer to the chart font object.

Implements CXTPChartTextElement.

◆ GetFormat()

AFX_INLINE CXTPChartNumberFormat * GetFormat ( ) const

Call this function to get a pointer to CXTPChartNumberFormat which specifies how to convert a number to a string.

Returns
Pointer to a CXTPChartNumberFormat class.
See also
CXTPChartNumberFormat

◆ GetTextColor()

CXTPChartColor GetTextColor ( ) const

Call this function to get the apparent text color of the axis label.

Returns
A chart color object representing an ARGB value.

◆ IsVisible()

AFX_INLINE BOOL IsVisible ( ) const

Call this function to check the visibility of the text label.

Returns
A BOOL value. TRUE if the text label is visible, FALSE otherwise.

◆ SetAngle()

AFX_INLINE void SetAngle ( int nAgle )

Call this function to set the angle of the text label.

Parameters
nAgle An integer value representing the angle.

◆ SetAntialiasing()

AFX_INLINE void SetAntialiasing ( BOOL bAntialiasing )

Call this function to set anti-aliasing ON or OFF.

Anti-aliasing is the smoothing of sharp edges of text and drawing.

Parameters
bAntialiasing A BOOL value. TRUE to set anti-aliasing to ON, FALSE to set anti-aliasing to OFF.

◆ SetFont()

void SetFont ( CXTPChartFont * pFont )

Call this function to set the font of the axis label text.

Parameters
pFont The pointer to a chart font object.

◆ SetFormat()

void SetFormat ( LPCTSTR lpszFormat )

Obsolete method.

Use GetFormat()->SetPattern(lpszFormat) instead.

Parameters
lpszFormat New pattern to be set.
See also
CXTPChartNumberFormat

◆ SetTextColor()

void SetTextColor ( const CXTPChartColor & clrTextColor )

Call this function to set the text color of the axis label.

Parameters
clrTextColor A reference to a chart color object representing an ARGB value.

◆ SetVisible()

AFX_INLINE void SetVisible ( BOOL bVisible )

Call this function to set the visibility of the text label.

Parameters
bVisible A BOOL value. TRUE to set the text label to visible, FALSE to hide the text label.
The documentation for this class was generated from the following file:
  • XTPChartAxisLabel.h


Toolkit Pro: CXTPChartAxisRange Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPChartAxisRange Class Reference

This class represents the value range of the axis. More...

Inheritance diagram for CXTPChartAxisRange:
[legend]

Public Member Functions

CXTPChartAxisRange (CXTPChartAxis *pAxis)
Constructs a CXTPChartAxisRange object.
virtual | ~CXTPChartAxisRange ()
Destroys a CXTPChartAxisLabel object, handles cleanup.
void | UpdateRange (CXTPChartAxisView *pView)
This function updates the axis, with respect to the series values.
double | GetMaxValue () const
Call this function to get the maximum value of the axis.
double | GetMinValue () const
Call this function to get the minimum value of the axis.
void | SetMaxValue (double dMaxValue)
Call this function to set the maximum value of the axis.
void | SetMinValue (double dMinValue)
Call this function to set the minimum value of the axis.
void | SetAutoRange (BOOL bAutoRange)
Call this function to manually set the min and max values for the range.
double | GetViewMaxValue () const
Call this function to get the maximum value of axis.
double | GetViewMinValue () const
Call this function to get the minimum value of axis.
void | SetViewMaxValue (double dMaxValue)
Call this function to set the maximum value of axis.
void | SetViewMinValue (double dMinValue)
Call this function to set the minimum value of axis.
void | SetViewAutoRange (BOOL bAutoRange)
Call this function to manually set the min and max values for the range.
void | SetSideMargins (BOOL bSideMargins)
Call this function to enable or disable the side margins.
BOOL | GetSideMargins () const
Call this function to check if the side margins are enabled or disabled.
void | SetShowZeroLevel (BOOL bShowZeroLevel)
Call this function to enable or disable the zero level on the axis.
BOOL | GetShowZeroLevel () const
Call this function to check if the zero level is enabled or disabled.
void | DoPropExchange (CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
- Public Member Functions inherited from CXTPChartElement
CXTPChartElement ()
Constructs a CXTPChartElement object.
virtual | ~CXTPChartElement ()
Destroys a CXTPChartElement object, handles cleanup.
virtual void | Release ()
Call this function to decrease the usage count of the object.
CXTPChartElement * | GetOwner () const
Call this function to get the owner element.
virtual void | OnChartChanged (XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic properties of the chart.
CXTPChartContent * | GetContent () const
Call this virtual function to get the chart content object.
CXTPChartAppearance * | GetAppearance () const
Call this function to get the the appearance of the chart.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Protected Member Functions

void Correct (CXTPChartAxisView *pView)
This function updates range based on the various parameters affecting the axis range (e.g.
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.

Protected Attributes

CXTPChartAxis * | m_pAxis
Pointer to chart axis object.
double | m_nMinValue
The minimum value of the range.
double | m_nMaxValue
The maximum value of the range.
BOOL | m_bSideMargins
TRUE if the side margins are present and FALSE if not.
BOOL | m_bShowZeroLevel
TRUE if the zero level is shown on the axis and FALSE if not.
- Protected Attributes inherited from CXTPChartElement

Detailed Description

This class represents the value range of the axis.

This class is associated with a chart axis class.

Constructor & Destructor Documentation

◆ CXTPChartAxisRange()

CXTPChartAxisRange ( CXTPChartAxis * pAxis )

Constructs a CXTPChartAxisRange object.

Parameters
pAxis Pointer to the associated chart axis object.

Member Function Documentation

◆ Correct()

void Correct ( CXTPChartAxisView * pView )
protected

This function updates range based on the various parameters affecting the axis range (e.g.

size margins, showing zero level, etc.).

Parameters
pView Pointer to CXTPChartAxisView

◆ DoPropExchange()

void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Reads this object from or writes this object to an archive.

Parameters
pPX A CXTPPropExchange object to serialize to or from.

Reimplemented from CXTPChartElement.

◆ GetMaxValue()

AFX_INLINE double GetMaxValue ( ) const

Call this function to get the maximum value of the axis.

Returns
A double value which denotes the maximum value.

◆ GetMinValue()

AFX_INLINE double GetMinValue ( ) const

Call this function to get the minimum value of the axis.

Returns
A double value which denotes the minimum value.

◆ GetShowZeroLevel()

AFX_INLINE BOOL GetShowZeroLevel ( ) const

Call this function to check if the zero level is enabled or disabled.

Returns
A BOOL value. TRUE if the zero level is enabled, FALSE otherwise.

◆ GetSideMargins()

AFX_INLINE BOOL GetSideMargins ( ) const

Call this function to check if the side margins are enabled or disabled.

Returns
A BOOL value. TRUE if the side margins are enabled, FALSE otherwise.

◆ GetViewMaxValue()

AFX_INLINE double GetViewMaxValue ( ) const

Call this function to get the maximum value of axis.

Returns
A double value which denotes the maximum value.

◆ GetViewMinValue()

AFX_INLINE double GetViewMinValue ( ) const

Call this function to get the minimum value of axis.

Returns
A double value which denotes the minimum value.

◆ SetAutoRange()

void SetAutoRange ( BOOL bAutoRange )

Call this function to manually set the min and max values for the range.

Parameters
bAutoRange TRUE to allow manually set range, FALSE to calculate automatically.

◆ SetMaxValue()

void SetMaxValue ( double dMaxValue )

Call this function to set the maximum value of the axis.

Parameters
dMaxValue A double value which denotes the maximum value.

◆ SetMinValue()

void SetMinValue ( double dMinValue )

Call this function to set the minimum value of the axis.

Parameters
dMinValue A double value which denotes the minimum value.

◆ SetShowZeroLevel()

void SetShowZeroLevel ( BOOL bShowZeroLevel )

Call this function to enable or disable the zero level on the axis.

Parameters
bShowZeroLevel A BOOL value. TRUE to enable the zero level, FALSE to disable the zero level.

◆ SetSideMargins()

void SetSideMargins ( BOOL bSideMargins )

Call this function to enable or disable the side margins.

Parameters
bSideMargins A BOOL value. TRUE to enable the side margins, FALSE to disable the side margins.

◆ SetViewAutoRange()

void SetViewAutoRange ( BOOL bAutoRange )

Call this function to manually set the min and max values for the range.

Parameters
bAutoRange TRUE to allow manually set range, FALSE to calculate automatically.

◆ SetViewMaxValue()

void SetViewMaxValue ( double dMaxValue )

Call this function to set the maximum value of axis.

Parameters
dMaxValue A double value which denotes the maximum value.

◆ SetViewMinValue()

void SetViewMinValue ( double dMinValue )

Call this function to set the minimum value of axis.

Parameters
dMinValue A double value which denotes the minimum value.

◆ UpdateRange()

void UpdateRange ( CXTPChartAxisView * pView )

This function updates the axis, with respect to the series values.

Parameters
pView Pointer to CXTPChartAxisView

Call this function whenever there is a change in series values.

The documentation for this class was generated from the following file:
  • XTPChartAxisRange.h


Toolkit Pro: CXTPChartAxisStrip Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPChartAxisStrip Class Reference

This is a hybrid object of CXTPChartElement and CXTPChartLegendItemView. More...

Inheritance diagram for CXTPChartAxisStrip:
[legend]

Public Member Functions

CXTPChartAxisStrip ()
Constructs a CXTPChartAxisStrip object.
virtual | ~CXTPChartAxisStrip ()
Destroys a CXTPChartAxisStrip object, handles cleanup.
void | SetVisible (BOOL bVisible)
Use this function to set the visibility of the axis strip.
BOOL | IsVisible () const
Call this function to check the visibility of the axis strip.
void | SetLegendVisible (BOOL bVisible)
Use this function to set the visibility of the legend item.
BOOL | IsLegendVisible () const
Call this function to check the visibility of the legend item.
void | SetName (const CXTPChartString &lpszName)
Use this function to set the name for the axis strip.
CXTPChartString | GetName () const
Call this function to get the name of the axis strip.
void | SetLegendName (const CXTPChartString &lpszName)
Use this function to set the legend item name for the axis strip.
CXTPChartString | GetLegendName () const
Call this function get the legend item name of the axis strip.
CXTPChartFillStyle * | GetFillStyle () const
Call this function to get the fill style of the axis strip.
CXTPChartString | GetAxisMinValue () const
Call this function to get the minimum value of the strip in the axis.
double | GetAxisMinValueInternal () const
Call this function to get the minimum value of the strip in the axis.
void | SetAxisMinValue (LPCTSTR lpszValue)
Call this function to set the minimum value for the strip in the axis.
void | SetAxisMinValue (double dValue)
Call this function to set the minimum value for the strip in the axis.
CXTPChartString | GetAxisMaxValue () const
Call this function to get the maximum value of the strip in the axis.
void | SetAxisMaxValue (LPCTSTR lpszValue)
Call this function to get the maximum value for the strip in the axis.
CXTPChartColor | GetActualColor () const
Call this function to get the actual color of the axis strip.
CXTPChartColor | GetColor () const
Use this function to get the apparent color of the axis strip.
void | SetColor (const CXTPChartColor &color)
Call this function to set the color of the axis strip.
void | SetColor2 (const CXTPChartColor &color)
Call this function to set the color of the axis strip.
void | DoPropExchange (CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
- Public Member Functions inherited from CXTPChartElement
CXTPChartElement ()
Constructs a CXTPChartElement object.
virtual | ~CXTPChartElement ()
Destroys a CXTPChartElement object, handles cleanup.
virtual void | Release ()
Call this function to decrease the usage count of the object.
CXTPChartElement * | GetOwner () const
Call this function to get the owner element.
virtual void | OnChartChanged (XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic properties of the chart.
CXTPChartContent * | GetContent () const
Call this virtual function to get the chart content object.
CXTPChartAppearance * | GetAppearance () const
Call this function to get the the appearance of the chart.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.
- Public Member Functions inherited from CXTPChartLegendItemView
virtual | ~CXTPChartLegendItemView ()
Handles object destruction.

Protected Member Functions

virtual CXTPChartDeviceCommand * CreateLegendDeviceCommand (CXTPChartDeviceContext *pDC, CRect rcBounds)
This function creates a CXTPChartDeviceCommand object.
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.

Protected Attributes

BOOL | m_bLegendVisible
TRUE if the legend item is visible, FALSE if not visible.
BOOL | m_bVisible
TRUE if the strip is visible, FALSE if not visible.
CXTPChartString | m_strName
The name of the strip.
CXTPChartString | m_strLegendName
The name of the legend item.
CXTPChartString | m_strAxisMinValue
The minimum value of the strip in the axis.
CXTPChartString | m_strAxisMaxValue
The maximum value of the strip in the axis.
double | m_dAxisMinValue
The minimum value of the strip in the axis.
double | m_dAxisMaxValue
The maximum value of the strip in the axis.
CXTPChartColor | m_clrColor
The color of the strip.
CXTPChartColor | m_clrColor2
The color of the strip.
CXTPChartFillStyle * | m_pFillStyle
The fill style used for the background painting.
- Protected Attributes inherited from CXTPChartElement

Detailed Description

This is a hybrid object of CXTPChartElement and CXTPChartLegendItemView.

This class represents a strip parallel to an axis.

Member Function Documentation

◆ CreateLegendDeviceCommand()

virtual CXTPChartDeviceCommand * CreateLegendDeviceCommand | ( | CXTPChartDeviceContext * | pDC,
 |  | CRect | rcBounds )
 protectedvirtual

This function creates a CXTPChartDeviceCommand object.

This object represents the rendering of an axis strip in the chart.

Parameters
pDC | Pointer to a CXTPChartDeviceContext object.
rcBounds | The bounding rectangle of the axis strip.
Returns
Returns a CXTPChartDeviceCommand object. This object handles the rendering of an element in the chart. Here it handles the drawing of the axis strip.

Implements CXTPChartLegendItemView.

◆ DoPropExchange()

void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Reads this object from or writes this object to an archive.

Parameters
pPX A CXTPPropExchange object to serialize to or from.

Reimplemented from CXTPChartElement.

◆ GetActualColor()

CXTPChartColor GetActualColor ( ) const

Call this function to get the actual color of the axis strip.

Returns
A chart color object representing an ARGB value.

◆ GetAxisMaxValue()

AFX_INLINE CXTPChartString GetAxisMaxValue ( ) const

Call this function to get the maximum value of the strip in the axis.

Returns
Returns a string describing the maximum value of the strip in the axis.

◆ GetAxisMinValue()

AFX_INLINE CXTPChartString GetAxisMinValue ( ) const

Call this function to get the minimum value of the strip in the axis.

\

Returns
Returns a string/double describing the minimum value of the strip in the axis.

◆ GetAxisMinValueInternal()

AFX_INLINE double GetAxisMinValueInternal ( ) const

Call this function to get the minimum value of the strip in the axis.

\

Returns
Returns a string/double describing the minimum value of the strip in the axis.

◆ GetColor()

AFX_INLINE CXTPChartColor GetColor ( ) const

Use this function to get the apparent color of the axis strip.

Returns
A CXTPChartColor object representing the ARGB color value selected.

◆ GetFillStyle()

AFX_INLINE CXTPChartFillStyle * GetFillStyle ( ) const

Call this function to get the fill style of the axis strip.

Returns
Returns a pointer to a CXTPChartFillStyle object which represents the fill style of the axis strip.

◆ GetLegendName()

CXTPChartString GetLegendName ( ) const
virtual

Call this function get the legend item name of the axis strip.

Returns
A string value denoting the legend item name of the axis strip.

Implements CXTPChartLegendItemView.

◆ GetName()

AFX_INLINE CXTPChartString GetName ( ) const

Call this function to get the name of the axis strip.

Returns
A string value denoting the name of the axis strip.

◆ IsLegendVisible()

AFX_INLINE BOOL IsLegendVisible ( ) const

Call this function to check the visibility of the legend item.

Returns
A BOOL value. TRUE if the legend item is visible, FALSE otherwise.

◆ IsVisible()

AFX_INLINE BOOL IsVisible ( ) const

Call this function to check the visibility of the axis strip.

Returns
A BOOL value. TRUE if the axis strip is visible, FALSE otherwise.

◆ SetAxisMaxValue()

AFX_INLINE void SetAxisMaxValue ( LPCTSTR lpszValue )

Call this function to get the maximum value for the strip in the axis.

Parameters
lpszValue A string describing the maximum value of the strip in the axis.

◆ SetAxisMinValue() [1/2]

AFX_INLINE void SetAxisMinValue ( double dValue )

Call this function to set the minimum value for the strip in the axis.

Parameters
dValue A double describing the minimum value of the strip in the axis.

◆ SetAxisMinValue() [2/2]

AFX_INLINE void SetAxisMinValue ( LPCTSTR lpszValue )

Call this function to set the minimum value for the strip in the axis.

Parameters
lpszValue A string describing the minimum value of the strip in the axis.

◆ SetColor()

void SetColor ( const CXTPChartColor & color )

Call this function to set the color of the axis strip.

Parameters
color A chart color object representing an ARGB value.

◆ SetColor2()

void SetColor2 ( const CXTPChartColor & color )

Call this function to set the color of the axis strip.

Parameters
color A chart color object representing an ARGB value.

◆ SetLegendName()

AFX_INLINE void SetLegendName ( const CXTPChartString & lpszName )

Use this function to set the legend item name for the axis strip.

Parameters
lpszName - A string value denoting the legend item name of the axis strip.

◆ SetLegendVisible()

AFX_INLINE void SetLegendVisible ( BOOL bVisible )

Use this function to set the visibility of the legend item.

Parameters
bVisible A BOOL value. TRUE to set the legend item to visible, FALSE to hide the legend item.

◆ SetName()

void SetName ( const CXTPChartString & lpszName )

Use this function to set the name for the axis strip.

Parameters
lpszName A string value denoting the name of the axis strip.

◆ SetVisible()

AFX_INLINE void SetVisible ( BOOL bVisible )

Use this function to set the visibility of the axis strip.

Parameters
bVisible A BOOL value. TRUE to set the axis strip to visible, FALSE to hide the axis strip.
The documentation for this class was generated from the following file:
  • XTPChartAxisStrips.h


Toolkit Pro: CXTPChartAxisStrips Class Reference

Public Member Functions | List of all members
CXTPChartAxisStrips Class Reference

This class encapsulates a collection of chart axis strip objects. More...

Inheritance diagram for CXTPChartAxisStrips:
[legend]

Public Member Functions

CXTPChartAxisStrips (CXTPChartAxis *pAxis)
Constructs a CXTPChartAxisStrips object.
virtual | ~CXTPChartAxisStrips ()
Destroys a CXTPChartAxisStrip object, handles cleanup.
CXTPChartAxisStrip * | Add (CXTPChartAxisStrip *pStrip)
Call this function to add a new strip to the collection.
CXTPChartAxisStrip * | GetAt (int nIndex) const
Use this function to get a strip at a particular index in the strips collection.
void | DoPropExchange (CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
- Public Member Functions inherited from CXTPChartElementCollection
CXTPChartElementCollection ()
Constructs a CXTPChartElementCollection object.
~CXTPChartElementCollection ()
Destroys a CXTPChartElementCollection object, handles cleanup.
virtual void | RemoveAll ()
This function removes all the individual objects from this collection object.
virtual int | GetCount () const
Call this function to get the number of objects in the internal array of this object.
virtual void | RemoveAt (int nIndex)
Use this function to remove an object from the collection.
virtual void | Remove (CXTPChartElement *pElement)
Use this function to remove an object from the collection.
CXTPChartElement * | GetAt (int nIndex) const
Call this function to get an element by its index.
int | IndexOf (CXTPChartElement *pElement) const
Call this function to get the index of a specified element.
void | InsertAt (int nIndex, CXTPChartElement *pElement)
Call this method to add a new element to the collection.
virtual void | Release ()
Call this function to decrease the usage count of the object.
- Public Member Functions inherited from CXTPChartElement
CXTPChartElement ()
Constructs a CXTPChartElement object.
virtual | ~CXTPChartElement ()
Destroys a CXTPChartElement object, handles cleanup.
CXTPChartElement * | GetOwner () const
Call this function to get the owner element.
virtual void | OnChartChanged (XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic properties of the chart.
CXTPChartContent * | GetContent () const
Call this virtual function to get the chart content object.
CXTPChartAppearance * | GetAppearance () const
Call this function to get the the appearance of the chart.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Additional Inherited Members

- Public Attributes inherited from CXTPChartElement
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.
- Protected Attributes inherited from CXTPChartElementCollection
CArray< CXTPChartElement *, CXTPChartElement * > m_arrElements
Array of CXTPChartElement pointer.
- Protected Attributes inherited from CXTPChartElement

Detailed Description

This class encapsulates a collection of chart axis strip objects.

CXTPChartAxisStrips class is designed as a kind of CXTPChartElement.

Constructor & Destructor Documentation

◆ CXTPChartAxisStrips()

CXTPChartAxisStrips ( CXTPChartAxis * pAxis )

Constructs a CXTPChartAxisStrips object.

Parameters
pAxis The pointer to the chart axis object to which the strips are associated.

Member Function Documentation

◆ Add()

CXTPChartAxisStrip * Add ( CXTPChartAxisStrip * pStrip )

Call this function to add a new strip to the collection.

Parameters
pStrip A pointer to an axis strip object.
Returns
A newly added axis strip object pointer.

◆ DoPropExchange()

void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Reads this object from or writes this object to an archive.

Parameters
pPX A CXTPPropExchange object to serialize to or from.

Reimplemented from CXTPChartElement.

◆ GetAt()

AFX_INLINE CXTPChartAxisStrip * GetAt ( int nIndex ) const

Use this function to get a strip at a particular index in the strips collection.

Parameters
nIndex The zero-based index of the item of choice.
Returns
A pointer to the strip object in the selected index.
The documentation for this class was generated from the following file:
  • XTPChartAxisStrips.h


Toolkit Pro: CXTPChartAxisTickMarks Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPChartAxisTickMarks Class Reference

This class represents the tick marks in an axis. More...

Inheritance diagram for CXTPChartAxisTickMarks:
[legend]

Public Member Functions

CXTPChartAxisTickMarks (CXTPChartAxis *pAxis)
Constructs a CXTPChartAxisTickMarks object.
virtual | ~CXTPChartAxisTickMarks ()
Destroys a CXTPChartAxisTickMarks object, handles cleanup.
CXTPChartAxis * | GetAxis () const
This function returns a pointer to the CXTPChartAxis object associated with the axis tick mark object.
void | SetVisible (BOOL bVisible)
Call this function to set the visibility for the axis tick marks.
BOOL | IsVisible () const
Call this function to check the visibility of the axis tick marks.
void | SetMinorVisible (BOOL bVisible)
Call this function to set the visibility for the axis minor tick marks.
BOOL | IsMinorVisible () const
Call this function to check the visibility of the axis minor tick marks.
void | SetThickness (int nThickness)
Call this function to set the thickness of the tick marks.
int | GetThickness () const
Call this function to get the thickness of the tick marks.
void | SetMinorThickness (int nThickness)
Call this function to set the thickness of the minor tick marks.
int | GetMinorThickness () const
Call this function to get the thickness of the minor tick marks.
void | SetLength (int nLength)
Call this function to set the length of the tick marks.
int | GetLength () const
Call this function to get the length of the tick marks.
void | SetMinorLength (int nLength)
Call this function to set the length of the minor tick marks.
int | GetMinorLength () const
Call this function to get the length of the minor tick marks.
void | SetCrossAxis (BOOL bCrossAxis)
Call this function to set the tick marks to cross the axis.
BOOL | IsCrossAxis () const
Call this function to check if the tick marks cross the axis.
void | DoPropExchange (CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
- Public Member Functions inherited from CXTPChartElement
CXTPChartElement ()
Constructs a CXTPChartElement object.
virtual | ~CXTPChartElement ()
Destroys a CXTPChartElement object, handles cleanup.
virtual void | Release ()
Call this function to decrease the usage count of the object.
CXTPChartElement * | GetOwner () const
Call this function to get the owner element.
virtual void | OnChartChanged (XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic properties of the chart.
CXTPChartContent * | GetContent () const
Call this virtual function to get the chart content object.
CXTPChartAppearance * | GetAppearance () const
Call this function to get the the appearance of the chart.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Protected Attributes

BOOL | m_bVisible
TRUE if the tick marks are visible, FALSE if not.
BOOL | m_bMinorVisible
TRUE if the minor tick marks are visible, FALSE if not.
int | m_nThickness
The thickness of the tick marks.
int | m_nMinorThickness
The thickness of the minor tick marks.
int | m_nLength
The length of the tick marks.
int | m_nMinorLength
The length of the minor tick marks.
BOOL | m_bCrossAxis
TRUE if the tick marks are crossing the axis, FALSE if not.
- Protected Attributes inherited from CXTPChartElement

Additional Inherited Members

- Public Attributes inherited from CXTPChartElement
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.

Detailed Description

This class represents the tick marks in an axis.

It's a kind of chart element.

Constructor & Destructor Documentation

◆ CXTPChartAxisTickMarks()

CXTPChartAxisTickMarks ( CXTPChartAxis * pAxis )

Constructs a CXTPChartAxisTickMarks object.

Parameters
pAxis A pointer to the chart axis object to which these tick marks are associated with.

Member Function Documentation

◆ DoPropExchange()

void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Reads this object from or writes this object to an archive.

Parameters
pPX A CXTPPropExchange object to serialize to or from.

Reimplemented from CXTPChartElement.

◆ GetAxis()

AFX_INLINE CXTPChartAxis * GetAxis ( ) const

This function returns a pointer to the CXTPChartAxis object associated with the axis tick mark object.

Returns
Returns a pointer to the associated chart axis object.

◆ GetLength()

AFX_INLINE int GetLength ( ) const

Call this function to get the length of the tick marks.

Returns
An integer value denoting the length of the tick marks.

◆ GetMinorLength()

AFX_INLINE int GetMinorLength ( ) const

Call this function to get the length of the minor tick marks.

Returns
An integer value denoting the length of the minor tick marks.

◆ GetMinorThickness()

AFX_INLINE int GetMinorThickness ( ) const

Call this function to get the thickness of the minor tick marks.

Returns
An integer value denoting the thickness of the minor tick marks.

◆ GetThickness()

AFX_INLINE int GetThickness ( ) const

Call this function to get the thickness of the tick marks.

Returns
An integer value denoting the thickness of the tick marks.

◆ IsCrossAxis()

AFX_INLINE BOOL IsCrossAxis ( ) const

Call this function to check if the tick marks cross the axis.

Returns
A BOOL value. TRUE if the tick marks are crossing the axis, FALSE otherwise.

◆ IsMinorVisible()

AFX_INLINE BOOL IsMinorVisible ( ) const

Call this function to check the visibility of the axis minor tick marks.

Returns
A BOOL value. TRUE if the minor tick marks are visible, FALSE otherwise.

◆ IsVisible()

AFX_INLINE BOOL IsVisible ( ) const

Call this function to check the visibility of the axis tick marks.

Returns
A BOOL value. TRUE if the tick marks are visible, FALSE otherwise.

◆ SetCrossAxis()

AFX_INLINE void SetCrossAxis ( BOOL bCrossAxis )

Call this function to set the tick marks to cross the axis.

Parameters
bCrossAxis A BOOL value. TRUE to make the tick marks cross the axis, FALSE to make the tick marks normal.

◆ SetLength()

AFX_INLINE void SetLength ( int nLength )

Call this function to set the length of the tick marks.

Parameters
nLength An integer value denoting the length of the tick marks.

◆ SetMinorLength()

AFX_INLINE void SetMinorLength ( int nLength )

Call this function to set the length of the minor tick marks.

Parameters
nLength An integer value denoting the length of the minor tick marks.

◆ SetMinorThickness()

AFX_INLINE void SetMinorThickness ( int nThickness )

Call this function to set the thickness of the minor tick marks.

Parameters
nThickness An integer value denoting the thickness of the minor tick marks.

◆ SetMinorVisible()

AFX_INLINE void SetMinorVisible ( BOOL bVisible )

Call this function to set the visibility for the axis minor tick marks.

Parameters
bVisible A BOOL value. TRUE to set the minor tick marks to visible, FALSE to hide the minor tick marks.

◆ SetThickness()

AFX_INLINE void SetThickness ( int nThickness )

Call this function to set the thickness of the tick marks.

Parameters
nThickness An integer value denoting the thickness of the tick marks.

◆ SetVisible()

AFX_INLINE void SetVisible ( BOOL bVisible )

Call this function to set the visibility for the axis tick marks.

Parameters
bVisible A BOOL value. TRUE to set the tick marks to visible, FALSE to hide the tick marks.
The documentation for this class was generated from the following file:
  • XTPChartAxisTickMarks.h


Toolkit Pro: CXTPChartAxisTitle Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPChartAxisTitle Class Reference

This class represents the axis title. More...

Inheritance diagram for CXTPChartAxisTitle:
[legend]

Public Member Functions

CXTPChartAxisTitle (CXTPChartAxis *pAxis)
Constructs a CXTPChartAxisTitle object.
virtual | ~CXTPChartAxisTitle ()
Destroys a CXTPChartAxisTitle object, handles cleanup.
CXTPChartAxis * | GetAxis () const
This function returns a pointer to the CXTPChartAxis object associated with the axis title object.
void | SetText (LPCTSTR lpszTitle)
Call this function to set the axis title text.
CXTPChartString | GetText () const
Call this function to get the axis title text.
void | SetTextColor (const CXTPChartColor &clrTextColor)
Call this function to set the axis title text color.
CXTPChartColor | GetTextColor () const
Call this function to get the apparent axis title text color.
CXTPChartColor | GetActualTextColor () const
Call this function to get the actual text color of the axis title.
CXTPChartFont * | GetFont () const
Call this function to get the font of the axis title.
void | SetFont (CXTPChartFont *pFont)
Call this function to set the font of the title.
void | SetAlignment (XTPChartStringAlignment nAlignment)
Call this function to set the alignment of the title.
XTPChartStringAlignment | GetAlignment () const
Call this function to get the alignment of the axis title.
BOOL | IsVisible () const
Call this function to check the visibility of the axis title.
void | SetVisible (BOOL bVisible)
Call this function to set the visibility of the axis title.
void | SetAntialiasing (BOOL bAntialiasing)
Call this function to set anti-aliasing ON or OFF.
BOOL | GetAntialiasing () const
Call this function to check if anti-aliasing is ON or OFF.
void | DoPropExchange (CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
- Public Member Functions inherited from CXTPChartTextElement
- Public Member Functions inherited from CXTPChartElement
CXTPChartElement ()
Constructs a CXTPChartElement object.
virtual | ~CXTPChartElement ()
Destroys a CXTPChartElement object, handles cleanup.
virtual void | Release ()
Call this function to decrease the usage count of the object.
CXTPChartElement * | GetOwner () const
Call this function to get the owner element.
virtual void | OnChartChanged (XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic properties of the chart.
CXTPChartContent * | GetContent () const
Call this virtual function to get the chart content object.
CXTPChartAppearance * | GetAppearance () const
Call this function to get the the appearance of the chart.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Protected Attributes

CXTPChartString | m_strText
The axis title value.
CXTPChartColor | m_clrTextColor
The text color.
BOOL | m_bVisible
TRUE if the axis title is visible and FALSE if invisible.
CXTPChartFont * | m_pFont
Pointer to the associated font object.
BOOL | m_bAntialiasing
TRUE if the antialiasing ON and FALSE if antialiasing OFF.
XTPChartStringAlignment | m_nAlignment
The axis title alignment.
- Protected Attributes inherited from CXTPChartElement

Additional Inherited Members

- Public Attributes inherited from CXTPChartElement
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.

Detailed Description

This class represents the axis title.

This object is a kind of chart element.

Constructor & Destructor Documentation

◆ CXTPChartAxisTitle()

CXTPChartAxisTitle ( CXTPChartAxis * pAxis )

Constructs a CXTPChartAxisTitle object.

Parameters
pAxis A pointer to the chart axis object to which the title is associated with.

Member Function Documentation

◆ DoPropExchange()

void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Reads this object from or writes this object to an archive.

Parameters
pPX A CXTPPropExchange object to serialize to or from.

Reimplemented from CXTPChartElement.

◆ GetActualTextColor()

CXTPChartColor GetActualTextColor ( ) const

Call this function to get the actual text color of the axis title.

Returns
Returns a CXTPChartColor object denoting the actual text color in ARGB.

◆ GetAlignment()

AFX_INLINE XTPChartStringAlignment GetAlignment ( ) const

Call this function to get the alignment of the axis title.

Returns
An enumerated value representing the title alignment.

The normal alignments are near, far and center.

◆ GetAntialiasing()

AFX_INLINE BOOL GetAntialiasing ( ) const
virtual

Call this function to check if anti-aliasing is ON or OFF.

Anti-aliasing is the smoothing of sharp edges of text and drawing.

Returns
A BOOL value. TRUE if anti-aliasing is ON, FALSE if anti-aliasing is OFF.

Implements CXTPChartTextElement.

◆ GetAxis()

AFX_INLINE CXTPChartAxis * GetAxis ( ) const

This function returns a pointer to the CXTPChartAxis object associated with the axis title object.

Returns
Returns a pointer to the associated chart axis object.

◆ GetFont()

AFX_INLINE CXTPChartFont * GetFont ( ) const
virtual

Call this function to get the font of the axis title.

Returns
A pointer to a CXTPChartFont object denoting the font used.

Implements CXTPChartTextElement.

◆ GetText()

AFX_INLINE CXTPChartString GetText ( ) const

Call this function to get the axis title text.

Returns
Returns a string representing the axis title text. Its type is CXTPChartString.

◆ GetTextColor()

CXTPChartColor GetTextColor ( ) const

Call this function to get the apparent axis title text color.

Returns
Returns a CXTPChartColor object denoting the apparent text color in ARGB.

◆ IsVisible()

AFX_INLINE BOOL IsVisible ( ) const

Call this function to check the visibility of the axis title.

Returns
A BOOL value. TRUE if the axis title is visible, FALSE otherwise.

◆ SetAlignment()

void SetAlignment ( XTPChartStringAlignment nAlignment )

Call this function to set the alignment of the title.

Parameters
nAlignment An enumerated value representing the title alignment.

The normal alignments are near, far and center.

◆ SetAntialiasing()

AFX_INLINE void SetAntialiasing ( BOOL bAntialiasing )

Call this function to set anti-aliasing ON or OFF.

Anti-aliasing is the smoothing of sharp edges of text and drawing.

Parameters
bAntialiasing A BOOL value. TRUE to set anti-aliasing to ON, FALSE to set anti-aliasing to OFF.

◆ SetFont()

void SetFont ( CXTPChartFont * pFont )

Call this function to set the font of the title.

Parameters
pFont A pointer to a chart font object.

◆ SetText()

void SetText ( LPCTSTR lpszTitle )

Call this function to set the axis title text.

Parameters
lpszTitle A string representing the axis title text.

◆ SetTextColor()

void SetTextColor ( const CXTPChartColor & clrTextColor )

Call this function to set the axis title text color.

Parameters
clrTextColor Text color value.

◆ SetVisible()

void SetVisible ( BOOL bVisible )

Call this function to set the visibility of the axis title.

Parameters
bVisible A BOOL value. TRUE to set the axis title to visible, FALSE to hide the axis title.
The documentation for this class was generated from the following file:
  • XTPChartAxisTitle.h


Toolkit Pro: CXTPChartAxisViewTick Class Reference

Public Attributes | List of all members
CXTPChartAxisViewTick Class Reference

This class represents a tick mark in the axis. More...

Public Attributes

double | m_dValue
The value of the tick mark.
CXTPChartString | m_strLabel
The tick mark label.
CSize | m_szBounds
The boundary.
CXTPChartSizeF | m_szLabel
The size of the label.

Detailed Description

This class represents a tick mark in the axis.

The documentation for this class was generated from the following file:
  • XTPChartAxisView.h


Toolkit Pro: CXTPChartAxisX Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPChartAxisX Class Reference

CXTPChartAxisX is a derived class from the CXTPChartAxis class and represents the X axis of a chart. More...

Inheritance diagram for CXTPChartAxisX:
[legend]

Public Member Functions

CXTPChartAxisX (CXTPChartDiagram2D *pDiagram)
Constructs a CXTPChartAxisX object.
virtual BOOL | IsVertical () const
This method overrides the base class member and determines if the X axis is vertical.
virtual BOOL | IsValuesAxis () const
This method overrides the base class member and determines if the X axis is value type.
virtual double | CalcSideMarginsValue (double nMinValue, double nMaxValue) const
This method overrides the base class member and returns the side margin value of the chart's X axis.
- Public Member Functions inherited from CXTPChartAxis
CXTPChartAxis (CXTPChartDiagram *pDiagram)
Constructs a CXTPChartAxis object.
virtual | ~CXTPChartAxis ()
Destroys a CXTPChartAxis object, handles cleanup.
void | UpdateRange (CXTPChartDeviceContext *pDC, CXTPChartAxisView *pView)
This function updates the axis, with respect to the series values.
CXTPChartDiagram * | GetDiagram () const
Call this function to get the pointer to chart diagram 2D object associated with the chart axis object.
XTPChartScaleType | GetScaleType () const
Use this function to get the scale type used for the axis.
CXTPChartScaleTypeMap * | GetScaleTypeMap () const
Call this function to get the scale type map object associated with the axis.
CXTPChartAxisRange * | GetRange () const
Use this function to get object which represents the range of the axis.
CXTPChartAxisLabel * | GetLabel () const
Call this function to get object which represents the label of the axis.
CXTPChartAxisGridLines * | GetGridLines () const
Use this function to get object which represents the axis gridlines.
CXTPChartAxisTickMarks * | GetTickMarks () const
Call this function to get the associated object which abstracts the axis tick marks.
CXTPChartAxisConstantLines * | GetConstantLines () const
Use this function to get the associated object which deals with constant lines parallel to the axis.
CXTPChartAxisCustomLabels * | GetCustomLabels () const
Use this function to get the associated object which deals with custom labels of aixs.
CXTPChartAxisStrips * | GetStrips () const
Call this function to get the associated object which deals with strips parallel to the axis.
CXTPChartAxisTitle * | GetTitle () const
Use this function to get the associated object which deals the axis title.
CXTPChartColor | GetActualColor () const
Gets the color of the axis.
CXTPChartColor | GetColor () const
Gets the color of the axis.
void | SetColor (const CXTPChartColor &color)
Sets the color of the axis.
CXTPChartColor | GetInterlacedColor () const
Gets the first interlaced strips color of the axis.
CXTPChartColor | GetActualInterlacedColor () const
Gets the first interlaced strips color of the axis.
void | SetInterlacedColor (const CXTPChartColor &color)
Sets the first interlaced strips color of the axis.
CXTPChartColor | GetInterlacedColor2 () const
Gets the second interlaced strips color of the axis.
CXTPChartColor | GetActualInterlacedColor2 () const
Gets the second interlaced strips color of the axis.
void | SetInterlacedColor2 (const CXTPChartColor &color)
Sets the second interlaced strips color of the axis.
CXTPChartFillStyle * | GetInterlacedFillStyle () const
Call this function to get the second interlaced strips background fill style.
XTPChartAxisAlignment | GetAlignment () const
Call this function to get the alignment of the axis.
void | SetAlignment (XTPChartAxisAlignment nAlignment)
Use this function to set the alignment of the axis.
BOOL | IsInterlaced () const
Call this function to get whether the interlaced strips are used.
void | SetInterlaced (BOOL bInterlaced)
Call this function to enable/disable the interlaced strips.
BOOL | IsVisible () const
Use this function to get whether the axis is visible.
void | SetVisible (BOOL bVisible)
Call this function to show/hide the axis.
int | GetThickness () const
Call this function to get the thickness of the axis line.
void | SetThickness (int nThicknes)
Call this function to set the thickness of the axis line.
int | GetIndex () const
Call this function to get index of the axis.
void | SetIndex (int nIndex)
Call this function to set the axis index.
void | SetMinorCount (int nMinorCount)
Call this function to set the minor count of the axis grid lines.
int | GetMinorCount () const
This function gives the minor count of the axis grid lines.
void | SetReversed (BOOL bRevered)
Use this function to reverse order the axis values.
BOOL | IsReversed () const
This function gives whether the axis points are reverse ordered or not.
CXTPChartAxisAppearance * | GetAppearance () const
This function returns the chart axis appeance object.
void | SetGridSpacingAuto (BOOL bGridSpacingAuto)
Sets value specifies whether space between grid lines in calculated automatically.
void | SetGridSpacing (double dGridSpacing)
Use this function to set the space between grid lines.
double | GetGridSpacing () const
Use this function to get the space between grid lines.
void | SetLogarithmic (BOOL bLogarithmic)
Set whether logarithmic scale should be used.
void | SetLogarithmicBase (double dLogarithmicBase)
Set logarithmic base when logarithmic scale is used.
void | SetDateTimeScaleUnit (XTPChartAxisDateTimeScaleUnit unit)
Call this method to set single unit for date time scale.
void | DoPropExchange (CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
- Public Member Functions inherited from CXTPChartElement
CXTPChartElement ()
Constructs a CXTPChartElement object.
virtual | ~CXTPChartElement ()
Destroys a CXTPChartElement object, handles cleanup.
virtual void | Release ()
Call this function to decrease the usage count of the object.
CXTPChartElement * | GetOwner () const
Call this function to get the owner element.
virtual void | OnChartChanged (XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic properties of the chart.
CXTPChartContent * | GetContent () const
Call this virtual function to get the chart content object.
CXTPChartAppearance * | GetAppearance () const
Call this function to get the the appearance of the chart.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Protected Member Functions

virtual CXTPChartAxisView * CreateView (CXTPChartDeviceContext *pDC, CXTPChartElementView *pParentView)
This function creates the view (CXTPChartAxisView) of the axis.
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.

Additional Inherited Members

- Public Attributes inherited from CXTPChartElement
- Protected Attributes inherited from CXTPChartAxis
CXTPChartDiagram * | m_pDiagram
The pointer to chart digram 2d object.
BOOL | m_bVisible
TRUE if the axis is visible, FALSE if invisible.
BOOL | m_bReversed
FALSE if the axis valus are in natural order, TRUE if it is in reverse order.
int | m_nThickness
The thickness of axis line.
int | m_nMinorCount
The number of minors present.
XTPChartAxisAlignment | m_nAlignment
The chart axis alignment, near or far.
CXTPChartColor m_clrColor
The chart color.
CXTPChartColor m_clrInterlacedColor
The first interlaced color.
CXTPChartColor m_clrInterlacedColor2
The second interlaced color.
CXTPChartFillStyle * m_pInterlacedFillStyle
The fill style of interlaced strips.
BOOL | m_bInterlaced
TRUE if the chart has interlaced strips parallel to the axis.
double | m_dGridSpacing
The spacing of the grid lines.
BOOL | m_bGridSpacingAuto
TURE if automatic spaceing of grid lines selected.FALSE for specific values.
BOOL | m_bLogarithmic
Logarithmic

double | m_dLogarithmicBase
Logarithic base.
CXTPChartAxisGridLines * m_pGridLines
Pointer to axis gridlines object.
CXTPChartAxisLabel * m_pLabel
Pointer to axis lable object.
CXTPChartAxisTitle * m_pTitle
Pointer to axis title object.
CXTPChartAxisTickMarks * m_pTickMarks
Pointer to axis tick marks object.
CXTPChartScaleTypeMap * m_pScaleTypeMap
Pointer to axis scale type object.
CXTPChartAxisRange * m_pRange
Pointer to axis range object.
CXTPChartAxisConstantLines * | m_pConstantLines
Pointer to axis constant lines object.
CXTPChartAxisCustomLabels * | m_pCustomLabels
Pointer to axis custom labels object.
CXTPChartAxisStrips * m_pStrips
Pointer to axis strips object.
XTPChartScaleType | m_nScaleType
Enumeated value denote the axis scale type.
- Protected Attributes inherited from CXTPChartElement

Detailed Description

CXTPChartAxisX is a derived class from the CXTPChartAxis class and represents the X axis of a chart.

It includes the features specific to the X axis of a chart.

Constructor & Destructor Documentation

◆ CXTPChartAxisX()

CXTPChartAxisX ( CXTPChartDiagram2D * pDiagram )

Constructs a CXTPChartAxisX object.

Parameters
pDiagram Pointer to a CXTPChartDiagram2D object.

Member Function Documentation

◆ CalcSideMarginsValue()

virtual double CalcSideMarginsValue | ( | double | nMinValue,
 |  | double | nMaxValue ) const
 virtual

This method overrides the base class member and returns the side margin value of the chart's X axis.

Parameters
nMinValue | The minimum value of the chart's X axis.
nMaxValue | The maximum value of the chart's X axis.
Returns
Returns a double value that represents the margin.

Implements CXTPChartAxis.

◆ CreateView()

virtual CXTPChartAxisView * CreateView | ( | CXTPChartDeviceContext * | pDC,
 |  | CXTPChartElementView * | pParentView )
 protectedvirtual

This function creates the view (CXTPChartAxisView) of the axis.

Parameters
pDC | The chart device context object pointer.
pParentView | The parent view of the axis.
Returns
Returns a pointer to the newly created CXTPChartAxisView object.

Reimplemented from CXTPChartAxis.

◆ IsValuesAxis()

virtual BOOL IsValuesAxis ( ) const
virtual

This method overrides the base class member and determines if the X axis is value type.

Returns
Returns TRUE if the X axis is value type, FALSE if the X axis is not value type.

Implements CXTPChartAxis.

◆ IsVertical()

virtual BOOL IsVertical ( ) const
virtual

This method overrides the base class member and determines if the X axis is vertical.

Returns
Returns TRUE if the X axis is vertical, FALSE if the X axis is not vertical.

Implements CXTPChartAxis.

The documentation for this class was generated from the following file:
  • XTPChartAxis.h


Toolkit Pro: CXTPChartAxisY Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPChartAxisY Class Reference

CXTPChartAxisY is a derived class from the CXTPChartAxis class and represents the Y axis of a chart. More...

Inheritance diagram for CXTPChartAxisY:
[legend]

Public Member Functions

CXTPChartAxisY (CXTPChartDiagram2D *pDiagram)
Constructs a CXTPChartAxisY object.
virtual BOOL | IsVertical () const
This method overrides the base class member and determines if the Y axis is vertical.
virtual BOOL | IsValuesAxis () const
This method overrides the base class member and determines if the Y axis is value type.
virtual double | CalcSideMarginsValue (double nMinValue, double nMaxValue) const
This method overrides the base class member and returns the side margin value of the chart's Y axis.
- Public Member Functions inherited from CXTPChartAxis
CXTPChartAxis (CXTPChartDiagram *pDiagram)
Constructs a CXTPChartAxis object.
virtual | ~CXTPChartAxis ()
Destroys a CXTPChartAxis object, handles cleanup.
void | UpdateRange (CXTPChartDeviceContext *pDC, CXTPChartAxisView *pView)
This function updates the axis, with respect to the series values.
CXTPChartDiagram * | GetDiagram () const
Call this function to get the pointer to chart diagram 2D object associated with the chart axis object.
XTPChartScaleType | GetScaleType () const
Use this function to get the scale type used for the axis.
CXTPChartScaleTypeMap * | GetScaleTypeMap () const
Call this function to get the scale type map object associated with the axis.
CXTPChartAxisRange * | GetRange () const
Use this function to get object which represents the range of the axis.
CXTPChartAxisLabel * | GetLabel () const
Call this function to get object which represents the label of the axis.
CXTPChartAxisGridLines * | GetGridLines () const
Use this function to get object which represents the axis gridlines.
CXTPChartAxisTickMarks * | GetTickMarks () const
Call this function to get the associated object which abstracts the axis tick marks.
CXTPChartAxisConstantLines * | GetConstantLines () const
Use this function to get the associated object which deals with constant lines parallel to the axis.
CXTPChartAxisCustomLabels * | GetCustomLabels () const
Use this function to get the associated object which deals with custom labels of aixs.
CXTPChartAxisStrips * | GetStrips () const
Call this function to get the associated object which deals with strips parallel to the axis.
CXTPChartAxisTitle * | GetTitle () const
Use this function to get the associated object which deals the axis title.
CXTPChartColor | GetActualColor () const
Gets the color of the axis.
CXTPChartColor | GetColor () const
Gets the color of the axis.
void | SetColor (const CXTPChartColor &color)
Sets the color of the axis.
CXTPChartColor | GetInterlacedColor () const
Gets the first interlaced strips color of the axis.
CXTPChartColor | GetActualInterlacedColor () const
Gets the first interlaced strips color of the axis.
void | SetInterlacedColor (const CXTPChartColor &color)
Sets the first interlaced strips color of the axis.
CXTPChartColor | GetInterlacedColor2 () const
Gets the second interlaced strips color of the axis.
CXTPChartColor | GetActualInterlacedColor2 () const
Gets the second interlaced strips color of the axis.
void | SetInterlacedColor2 (const CXTPChartColor &color)
Sets the second interlaced strips color of the axis.
CXTPChartFillStyle * | GetInterlacedFillStyle () const
Call this function to get the second interlaced strips background fill style.
XTPChartAxisAlignment | GetAlignment () const
Call this function to get the alignment of the axis.
void | SetAlignment (XTPChartAxisAlignment nAlignment)
Use this function to set the alignment of the axis.
BOOL | IsInterlaced () const
Call this function to get whether the interlaced strips are used.
void | SetInterlaced (BOOL bInterlaced)
Call this function to enable/disable the interlaced strips.
BOOL | IsVisible () const
Use this function to get whether the axis is visible.
void | SetVisible (BOOL bVisible)
Call this function to show/hide the axis.
int | GetThickness () const
Call this function to get the thickness of the axis line.
void | SetThickness (int nThicknes)
Call this function to set the thickness of the axis line.
int | GetIndex () const
Call this function to get index of the axis.
void | SetIndex (int nIndex)
Call this function to set the axis index.
void | SetMinorCount (int nMinorCount)
Call this function to set the minor count of the axis grid lines.
int | GetMinorCount () const
This function gives the minor count of the axis grid lines.
void | SetReversed (BOOL bRevered)
Use this function to reverse order the axis values.
BOOL | IsReversed () const
This function gives whether the axis points are reverse ordered or not.
CXTPChartAxisAppearance * | GetAppearance () const
This function returns the chart axis appeance object.
void | SetGridSpacingAuto (BOOL bGridSpacingAuto)
Sets value specifies whether space between grid lines in calculated automatically.
void | SetGridSpacing (double dGridSpacing)
Use this function to set the space between grid lines.
double | GetGridSpacing () const
Use this function to get the space between grid lines.
void | SetLogarithmic (BOOL bLogarithmic)
Set whether logarithmic scale should be used.
void | SetLogarithmicBase (double dLogarithmicBase)
Set logarithmic base when logarithmic scale is used.
void | SetDateTimeScaleUnit (XTPChartAxisDateTimeScaleUnit unit)
Call this method to set single unit for date time scale.
void | DoPropExchange (CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
- Public Member Functions inherited from CXTPChartElement
CXTPChartElement ()
Constructs a CXTPChartElement object.
virtual | ~CXTPChartElement ()
Destroys a CXTPChartElement object, handles cleanup.
virtual void | Release ()
Call this function to decrease the usage count of the object.
CXTPChartElement * | GetOwner () const
Call this function to get the owner element.
virtual void | OnChartChanged (XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic properties of the chart.
CXTPChartContent * | GetContent () const
Call this virtual function to get the chart content object.
CXTPChartAppearance * | GetAppearance () const
Call this function to get the the appearance of the chart.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Protected Member Functions

virtual CXTPChartAxisView * CreateView (CXTPChartDeviceContext *pDC, CXTPChartElementView *pParentView)
This function creates the view (CXTPChartAxisView) of the axis.
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.

Additional Inherited Members

- Public Attributes inherited from CXTPChartElement
- Protected Attributes inherited from CXTPChartAxis
CXTPChartDiagram * | m_pDiagram
The pointer to chart digram 2d object.
BOOL | m_bVisible
TRUE if the axis is visible, FALSE if invisible.
BOOL | m_bReversed
FALSE if the axis valus are in natural order, TRUE if it is in reverse order.
int | m_nThickness
The thickness of axis line.
int | m_nMinorCount
The number of minors present.
XTPChartAxisAlignment | m_nAlignment
The chart axis alignment, near or far.
CXTPChartColor m_clrColor
The chart color.
CXTPChartColor m_clrInterlacedColor
The first interlaced color.
CXTPChartColor m_clrInterlacedColor2
The second interlaced color.
CXTPChartFillStyle * m_pInterlacedFillStyle
The fill style of interlaced strips.
BOOL | m_bInterlaced
TRUE if the chart has interlaced strips parallel to the axis.
double | m_dGridSpacing
The spacing of the grid lines.
BOOL | m_bGridSpacingAuto
TURE if automatic spaceing of grid lines selected.FALSE for specific values.
BOOL | m_bLogarithmic
Logarithmic

double | m_dLogarithmicBase
Logarithic base.
CXTPChartAxisGridLines * m_pGridLines
Pointer to axis gridlines object.
CXTPChartAxisLabel * m_pLabel
Pointer to axis lable object.
CXTPChartAxisTitle * m_pTitle
Pointer to axis title object.
CXTPChartAxisTickMarks * m_pTickMarks
Pointer to axis tick marks object.
CXTPChartScaleTypeMap * m_pScaleTypeMap
Pointer to axis scale type object.
CXTPChartAxisRange * m_pRange
Pointer to axis range object.
CXTPChartAxisConstantLines * | m_pConstantLines
Pointer to axis constant lines object.
CXTPChartAxisCustomLabels * | m_pCustomLabels
Pointer to axis custom labels object.
CXTPChartAxisStrips * m_pStrips
Pointer to axis strips object.
XTPChartScaleType | m_nScaleType
Enumeated value denote the axis scale type.
- Protected Attributes inherited from CXTPChartElement

Detailed Description

CXTPChartAxisY is a derived class from the CXTPChartAxis class and represents the Y axis of a chart.

It includes the features specific to the Y axis of a chart.

Constructor & Destructor Documentation

◆ CXTPChartAxisY()

CXTPChartAxisY ( CXTPChartDiagram2D * pDiagram )

Constructs a CXTPChartAxisY object.

Parameters
pDiagram Pointer to a CXTPChartDiagram2D object.

Member Function Documentation

◆ CalcSideMarginsValue()

virtual double CalcSideMarginsValue | ( | double | nMinValue,
 |  | double | nMaxValue ) const
 virtual

This method overrides the base class member and returns the side margin value of the chart's Y axis.

Parameters
nMinValue | The minimum value of the chart's Y axis.
nMaxValue | The maximum value of the chart's Y axis.
Returns
Returns a double value that represents the margin.

Implements CXTPChartAxis.

◆ CreateView()

virtual CXTPChartAxisView * CreateView | ( | CXTPChartDeviceContext * | pDC,
 |  | CXTPChartElementView * | pParentView )
 protectedvirtual

This function creates the view (CXTPChartAxisView) of the axis.

Parameters
pDC | The chart device context object pointer.
pParentView | The parent view of the axis.
Returns
Returns a pointer to the newly created CXTPChartAxisView object.

Reimplemented from CXTPChartAxis.

◆ IsValuesAxis()

virtual BOOL IsValuesAxis ( ) const
virtual

This method overrides the base class member and determines if the Y axis is value type.

Returns
Returns TRUE if the Y axis is value type, FALSE if the Y axis is not value type.

Implements CXTPChartAxis.

◆ IsVertical()

virtual BOOL IsVertical ( ) const
virtual

This method overrides the base class member and determines if the Y axis is vertical.

Returns
Returns TRUE if the Y axis is vertical, FALSE if the Y axis is not vertical.

Implements CXTPChartAxis.

The documentation for this class was generated from the following file:
  • XTPChartAxis.h


Toolkit Pro: CXTPChartBarSeriesErrorBarView Class Reference

Public Member Functions | List of all members
CXTPChartBarSeriesErrorBarView Class Reference

This class abstracts the view of the label of a bar series. More...

Public Member Functions

CXTPChartBarSeriesErrorBarView (CXTPChartErrorBar *pErrorBar, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView)
Constructs a CXTPChartBarSeriesErrorBarView object.

Detailed Description

This class abstracts the view of the label of a bar series.

It is a kind of point series label view.

Constructor & Destructor Documentation

◆ CXTPChartBarSeriesErrorBarView()

CXTPChartBarSeriesErrorBarView | ( | CXTPChartErrorBar * | pErrorBar,
 |  | CXTPChartSeriesPointView * | pPointView,
 |  | CXTPChartElementView * | pParentView )

Constructs a CXTPChartBarSeriesErrorBarView object.

Parameters
pErrorBar | Pointer to the error bar object.
pPointView | Pointer to chart series point view.
pParentView | The pointer to the parent view object.
The documentation for this class was generated from the following file:
  • XTPChartBarSeriesErrorBar.h


Toolkit Pro: CXTPChartBarSeriesLabel Class Reference

Public Member Functions | List of all members
CXTPChartBarSeriesLabel Class Reference

This class abstracts the label of a bar series. More...

Inheritance diagram for CXTPChartBarSeriesLabel:
[legend]

Public Member Functions

CXTPChartBarSeriesLabel ()
Constructs a CXTPChartBarSeriesLabel object.
virtual | ~CXTPChartBarSeriesLabel ()
Destroys a CXTPChartBarSeriesLabel object, handles cleanup.
virtual CXTPChartElementView * | CreateView (CXTPChartDeviceContext *pDC, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView)
This function creates the view of the bar series label.
void | DoPropExchange (CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
- Public Member Functions inherited from CXTPChartDiagram2DSeriesLabel
CXTPChartDiagram2DSeriesLabel ()
Constructs a CXTPChartDiagram2DSeriesLabel object.
virtual | ~CXTPChartDiagram2DSeriesLabel ()
Destroys a CXTPChartDiagram2DSeriesLabel object, handles cleanup.
void | DoPropExchange (CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
- Public Member Functions inherited from CXTPChartSeriesLabel
CXTPChartSeriesLabel ()
Constructs a CXTPChartSeriesLabel object.
virtual | ~CXTPChartSeriesLabel ()
Destroys a CXTPChartSeriesLabel object, handles cleanup.
void | SetTextColor (const CXTPChartColor &clrTextColor)
Call this function to set the text color of the label.
CXTPChartColor | GetTextColor () const
Call this function to get the apparent text color of the label.
CXTPChartFont * | GetFont () const
Call this function to get the font of the text label.
void | SetFont (CXTPChartFont *pFont)
Call this function to set the font of the text label.
void | SetShowLines (BOOL bShowLines)
Call this function to set the lines visibility.
BOOL | GetShowLines () const
Call this function to check if the lines are visible.
void | SetLineLength (int nLineLength)
Call this function to set the line length.
int | GetLineLength () const
Call this function to get the line length.
void | SetVisible (BOOL bVisible)
Call this function to set the label visibility.
BOOL | IsVisible () const
Call this function to check if the label is visible.
void | SetAntialiasing (BOOL bAntialiasing)
Call this function to set anti-aliasing ON or OFF.
BOOL | GetAntialiasing () const
Call this function to check if anti-aliasing is ON or OFF.
CXTPChartNumberFormat * | GetFormat () const
Call this function to get a pointer to CXTPChartNumberFormat that specifies how to convert numbers to strings.
void | SetFormat (LPCTSTR lpszFormat)
Obsolete method.
void | SetBackColor (const CXTPChartColor &clrBackColor)
Call this function to set the text color of the label.
CXTPChartColor | GetBackColor () const
Call this function to get the apparent text color of the label.
void | SetLineColor (const CXTPChartColor &clrBackColor)
Call this function to set the text color of the label.
CXTPChartColor | GetLineColor () const
Call this function to get the apparent text color of the label.
int | GetTransparency () const
Call this function to get the transparency of the filled area with respect to the background.
void | SetTransparency (int nTransparency)
Call this function to set the transparency of the filled area with respect to the background.
- Public Member Functions inherited from CXTPChartTextElement
- Public Member Functions inherited from CXTPChartElement
CXTPChartElement ()
Constructs a CXTPChartElement object.
virtual | ~CXTPChartElement ()
Destroys a CXTPChartElement object, handles cleanup.
virtual void | Release ()
Call this function to decrease the usage count of the object.
CXTPChartElement * | GetOwner () const
Call this function to get the owner element.
virtual void | OnChartChanged (XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic properties of the chart.
CXTPChartContent * | GetContent () const
Call this virtual function to get the chart content object.
CXTPChartAppearance * | GetAppearance () const
Call this function to get the the appearance of the chart.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Additional Inherited Members

- Public Attributes inherited from CXTPChartElement
- Protected Member Functions inherited from CXTPChartSeriesLabel
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.
- Protected Attributes inherited from CXTPChartSeriesLabel
CXTPChartColor | m_clrTextColor
The text color.
CXTPChartColor | m_clrBackColor
The background color.
CXTPChartColor | m_clrLineColor
The line color.
BOOL | m_bVisible
TRUE if the label is visible and FALSE if not.
CXTPChartFont * | m_pFont
The font of the label.
BOOL | m_bAntialiasing
TRUE if antialiasing enabled, FALSE if not.
BOOL | m_bShowLines
TRUE if the lines are visible, FALSE if not.
int | m_nLineLength
The line length.
CXTPChartBorder * | m_pBorder
Chart border object.
int | m_nTransparency
The transparency values range from 0 to 255.
- Protected Attributes inherited from CXTPChartElement

Detailed Description

This class abstracts the label of a bar series.

It is a kind of point series label.

Member Function Documentation

◆ CreateView()

virtual CXTPChartElementView * CreateView | ( | CXTPChartDeviceContext * | pDC,
 |  | CXTPChartSeriesPointView * | pPointView,
 |  | CXTPChartElementView * | pParentView )
 virtual

This function creates the view of the bar series label.

Parameters
pDC | The device context.
pPointView | A pointer to the series point view object.
pParentView | Parent view pointer.
Returns
A pointer to a CXTPChartElementView object, which is polymorphic to CXTPChartBarSeriesLabelView.

Reimplemented from CXTPChartSeriesLabel.

◆ DoPropExchange()

void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Reads this object from or writes this object to an archive.

Parameters
pPX A CXTPPropExchange object to serialize to or from.

Reimplemented from CXTPChartSeriesLabel.

The documentation for this class was generated from the following file:
  • XTPChartBarSeriesLabel.h


Toolkit Pro: CXTPChartBarSeriesLabelView Class Reference

Public Member Functions | List of all members
CXTPChartBarSeriesLabelView Class Reference

This class abstracts the view of the label of a bar series. More...

Inheritance diagram for CXTPChartBarSeriesLabelView:
[legend]

Public Member Functions

CXTPChartBarSeriesLabelView (CXTPChartSeriesLabel *pLabel, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView)
Constructs a CXTPChartBarSeriesLabel object.
virtual CXTPChartPointF | GetAnchorPoint () const
This function calculates the anchor point of the label stem.
virtual CXTPChartDeviceCommand * | CreateDeviceCommand (CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
virtual CXTPChartDeviceCommand * | CreateDeviceCommand (CXTPChartDeviceContext *pDC, CXTPChartPointF ptCenterPoint)
This function creates a CXTPChartDeviceCommand object.
virtual CXTPChartDeviceCommand * | CreateDeviceCommand (CXTPChartDeviceContext *pDC, CXTPChartPointF ptCenterPoint, const CXTPChartString &text)
This function creates a CXTPChartDeviceCommand object.
virtual CXTPChartDeviceCommand * | CreateDeviceCommand (CXTPChartDeviceContext *pDC, const CXTPChartPointF &ptAnchorPoint, double dAnchorAngle, const CXTPChartString &text)
This function creates a CXTPChartDeviceCommand object.
- Public Member Functions inherited from CXTPChartDiagram2DSeriesLabelView
CXTPChartDiagram2DSeriesLabelView (CXTPChartSeriesLabel *pLabel, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView)
Constructs a CXTPChartDiagram2DSeriesLabelView object.

Detailed Description

This class abstracts the view of the label of a bar series.

It is a kind of point series label view.

Constructor & Destructor Documentation

◆ CXTPChartBarSeriesLabelView()

CXTPChartBarSeriesLabelView | ( | CXTPChartSeriesLabel * | pLabel,
 |  | CXTPChartSeriesPointView * | pPointView,
 |  | CXTPChartElementView * | pParentView )

Constructs a CXTPChartBarSeriesLabel object.

Parameters
pLabel | Pointer chart series label.
pPointView | Pointer to chart series point view.
pParentView | Parent view pointer.

Member Function Documentation

◆ CreateDeviceCommand() [1/4]

virtual CXTPChartDeviceCommand * CreateDeviceCommand ( CXTPChartDeviceContext * pDC )
virtual

This function creates a CXTPChartDeviceCommand object.

This object represents the rendering of the chart series label.

Parameters
pDC Pointer to a CXTPChartDeviceContext object.
Returns
Returns a pointer to a CXTPChartDeviceCommand object. This polymorphic object handles the rendering of an element in the chart. Here it handles the drawing of the chart series label.

Reimplemented from CXTPChartDiagram2DSeriesLabelView.

◆ CreateDeviceCommand() [2/4]

virtual CXTPChartDeviceCommand * CreateDeviceCommand | ( | CXTPChartDeviceContext * | pDC,
 |  | const CXTPChartPointF & | ptAnchorPoint,
 |  | double | dAnchorAngle,
 |  | const CXTPChartString & | text )
 virtual

This function creates a CXTPChartDeviceCommand object.

This object represents the rendering of the chart series label.

Parameters
pDC | Pointer to a CXTPChartDeviceContext object.
text | Text.
ptAnchorPoint | Anchor point.
dAnchorAngle | Anchor angle.
Returns
Returns a pointer to a CXTPChartDeviceCommand object. This polymorphic object handles the rendering of an element in the chart. Here it handles the drawing of the chart series label.

Reimplemented from CXTPChartDiagram2DSeriesLabelView.

◆ CreateDeviceCommand() [3/4]

virtual CXTPChartDeviceCommand * CreateDeviceCommand | ( | CXTPChartDeviceContext * | pDC,
 |  | CXTPChartPointF | ptCenterPoint )
 virtual

This function creates a CXTPChartDeviceCommand object.

This object represents the rendering of the chart series label.

Parameters
pDC | Pointer to a CXTPChartDeviceContext object.
ptCenterPoint | Center point.
Returns
Returns a pointer to a CXTPChartDeviceCommand object. This polymorphic object handles the rendering of an element in the chart. Here it handles the drawing of the chart series label.

Reimplemented from CXTPChartDiagram2DSeriesLabelView.

◆ CreateDeviceCommand() [4/4]

virtual CXTPChartDeviceCommand * CreateDeviceCommand | ( | CXTPChartDeviceContext * | pDC,
 |  | CXTPChartPointF | ptCenterPoint,
 |  | const CXTPChartString & | text )
 virtual

This function creates a CXTPChartDeviceCommand object.

This object represents the rendering of the chart series label.

Parameters
pDC | Pointer to a CXTPChartDeviceContext object.
ptCenterPoint | Center point.
text | Text.
Returns
Returns a pointer to a CXTPChartDeviceCommand object. This polymorphic object handles the rendering of an element in the chart. Here it handles the drawing of the chart series label.

Reimplemented from CXTPChartDiagram2DSeriesLabelView.

◆ GetAnchorPoint()

virtual CXTPChartPointF GetAnchorPoint ( ) const
virtual

This function calculates the anchor point of the label stem.

Returns
A CXTPChartPointF object denoting the anchor point.

Reimplemented from CXTPChartDiagram2DSeriesLabelView.

The documentation for this class was generated from the following file:
  • XTPChartBarSeriesLabel.h


Toolkit Pro: CXTPChartBarSeriesPointView Class Reference

Public Member Functions | List of all members
CXTPChartBarSeriesPointView Class Reference

This class represents the view of a bar series point, which is a kind of CXTPChartPointSeriesPointView. More...

Inheritance diagram for CXTPChartBarSeriesPointView:
[legend]

Public Member Functions

CXTPChartBarSeriesPointView (CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Constructs a CXTPChartBarSeriesPointView object.
virtual CXTPChartDeviceCommand * | CreateDeviceCommand (CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
virtual CXTPChartDeviceCommand * | CreateLegendDeviceCommand (CXTPChartDeviceContext *pDC, CRect rcBounds)
This function creates a label view drawing command object.
- Public Member Functions inherited from CXTPChartSeriesPointView
CXTPChartSeriesPointView (CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Constructs the view object.
CXTPChartSeriesPointView (CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView, BOOL bAddToParent)
Constructs the view object.
CXTPChartSeriesPoint * | GetPoint () const
Obtains point model object.
CXTPChartSeriesView * | GetSeriesView () const
Obtains parent series view.
CXTPChartColor | GetColor () const
Obtain view color values.
CXTPChartColor | GetColor2 () const
Obtain view color values.
double | GetInternalValue () const
Obtains point interval value.
virtual CXTPChartString | GetLegendName () const
This function returns the legend name.
virtual void | UpdateMinMaxRange (double &nMinValue, double &nMaxValue) const
Provides a default empty implementation for min/max range update request.
- Public Member Functions inherited from CXTPChartElementView
CXTPChartElementView (CXTPChartElementView *pParentView)
Constructs a CXTPChartElementView object.
CXTPChartElementView (CXTPChartElementView *pParentView, BOOL bAddToParent)
Constructs a CXTPChartElementView object.
CXTPChartElementView (CXTPChartContainer *pContainer)
Constructs a CXTPChartElementView object.
int | GetCount () const
Call this function to get the number of child views associated with this view.
CXTPChartElementView * | GetAt (int nIndex) const
Call this function to get a child view at a particular index.
CXTPChartElementView * | GetParentView () const
Call this function to get the parent view.
CXTPChartElementView * | AddChildView (CXTPChartElementView *pChildView)
Call this function to add a child view to the current view.
CXTPChartElementView ** GetChildren ()
Provides access to the collection of children elements owned by the view.
CRect | GetBounds () const
Obtains viewed object's bound rectangle.
CRect | GetBounds (BOOL bIncludingChildren) const
Obtains viewed object's bound rectangle.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.
- Public Member Functions inherited from CXTPChartLegendItemView
virtual | ~CXTPChartLegendItemView ()
Handles object destruction.

Additional Inherited Members

- Public Attributes inherited from CXTPChartSeriesPointView
double | m_dInternalValue
Point internal value.
- Protected Member Functions inherited from CXTPChartElementView
virtual | ~CXTPChartElementView ()
Destroys a CXTPChartElementView object, handles cleanup.
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.
- Protected Attributes inherited from CXTPChartSeriesPointView
CXTPChartSeriesPoint * | m_pPoint
Point model object pointer.
- Protected Attributes inherited from CXTPChartElementView
CArray< CXTPChartElementView *, CXTPChartElementView * > | m_arrChildren
The child view collection.
CXTPChartElementView * | m_pParentView
The parent view.
CXTPChartContainer * | m_pContainer
The parent container.
CRect | m_rcBounds
Bounding rectangle.

Detailed Description

This class represents the view of a bar series point, which is a kind of CXTPChartPointSeriesPointView.

Constructor & Destructor Documentation

◆ CXTPChartBarSeriesPointView()

CXTPChartBarSeriesPointView | ( | CXTPChartSeriesPoint * | pPoint,
 |  | CXTPChartElementView * | pParentView )

Constructs a CXTPChartBarSeriesPointView object.

Parameters
pPoint | A pointer to the chart series point object.
pParentView | Parent view pointer.

Member Function Documentation

◆ CreateDeviceCommand()

virtual CXTPChartDeviceCommand * CreateDeviceCommand ( CXTPChartDeviceContext * pDC )
virtual

This function creates a CXTPChartDeviceCommand object.

This object represents the rendering of a bar series point.

Parameters
pDC Pointer to a CXTPChartDeviceContext object.
Returns
Returns a CXTPChartDeviceCommand object. This object handles the rendering of the bar series point.

Reimplemented from CXTPChartElementView.

Reimplemented in CXTPChartRangeBarSeriesPointView, and CXTPChartStackedBarSeriesPointView.

◆ CreateLegendDeviceCommand()

virtual CXTPChartDeviceCommand * CreateLegendDeviceCommand | ( | CXTPChartDeviceContext * | pDC,
 |  | CRect | rcBounds )
 virtual

This function creates a label view drawing command object.

Parameters
pDC | Pointer to a CXTPChartDeviceContext object.
rcBounds | The rectangular boundary of the legend.
Returns
Returns a new label view drawing command object.

Reimplemented from CXTPChartSeriesPointView.

The documentation for this class was generated from the following file:
  • XTPChartBarSeriesView.h


Toolkit Pro: CXTPChartBarSeriesStyle Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPChartBarSeriesStyle Class Reference

This class represents a bar series style for the chart, which is a kind of CXTPChartSeriesStyle. More...

Inheritance diagram for CXTPChartBarSeriesStyle:
[legend]

Public Member Functions

CXTPChartBarSeriesStyle ()
Constructs a CXTPChartBarSeriesStyle object.
virtual | ~CXTPChartBarSeriesStyle ()
Destroys a CXTPChartBarSeriesStyle object, handles cleanup.
void | DoPropExchange (CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
double | GetBarWidth () const
Call this function to get the width of the bar.
void | SetBarWidth (double dWidth)
Call this function to set the width of the bar.
- Public Member Functions inherited from CXTPChartDiagram2DSeriesStyle
CXTPChartDiagram2DSeriesStyle ()
Constructs a CXTPChartDiagram2DSeriesStyle object.
virtual | ~CXTPChartDiagram2DSeriesStyle ()
Destroys a CXTPChartDiagram2DSeriesStyle object, handles cleanup.
void | DoPropExchange (CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
virtual CXTPChartDiagram * | CreateDiagram ()
Call this function to create the diagram for this series.
virtual BOOL | IsStyleDiagram (CXTPChartDiagram *pDiagram) const
Call this function to check whether the chart diagram object passed is a kind of 2D diagram (CXTPChartDiagram2D object).
- Public Member Functions inherited from CXTPChartSeriesStyle
CXTPChartSeriesStyle ()
Constructs a CXTPChartSeriesStyle object.
virtual | ~CXTPChartSeriesStyle ()
Destroys a CXTPChartSeriesStyle object, handles cleanup.
virtual CXTPChartSeriesLabel * | GetLabel () const
Call this method to gets the series label object.
virtual CXTPChartSeriesLabel * | SetLabel (CXTPChartSeriesLabel *pLabel)
Call this method to sets the series label object.
virtual CXTPChartErrorBar * | GetErrorBar () const
Call this method to gets the error bar object.
virtual CXTPChartErrorBar * | SetErrorBar (CXTPChartErrorBar *pErrorBar)
Call this method to sets the error bar object.
virtual CXTPChartColor | GetColor () const
Call this method to get the color of the series.
virtual void | SetColor (CXTPChartColor clr)
Call this method to set the color of the series.
virtual void | SetColorEach (BOOL bColorEach)
Call this method to set individual color for each point of the series.
virtual BOOL | IsColorEach () const
This method is called to check if individual color is used for each point of the series.
virtual CXTPChart3dRotation | Get3dRotation () const
Obtains rotation parameters for 3D chart.
virtual void | Set3dRotation (const CXTPChart3dRotation &rotation)
Sets rotation parameters for 3D chart.
virtual void | Set3dRotation (double dYaw, double dPitch, double dRoll)
Sets rotation parameters for 3D chart.
virtual BOOL | Is3dEdgeSmoothingEnabled () const
Enables/disables 3D edge smoothing.
virtual void | Enable3dEdgeSmoothing (BOOL bEnable=TRUE)
Enables/disables 3D edge smoothing.
virtual int | GetTransparency () const
Call this function to gets the transparency of the chart if it is supported by the chart type.
virtual void | SetTransparency (int nTransparency)
Call this function to sets the transparency of the chart if it is supported by the chart type.
virtual CXTPChartSeriesStyleAppearance * | GetStyleAppearance () const
Obtains associated style appearance pointer.
virtual void | ApplyTo (CXTPChartDeviceCommand *pCommand)
Applies the style to the command provided in case the command needs style specific details for correct drawing.
virtual int | GetSeriesPointValueIndex () const
Obtains the index of a point element for which an internal value can be otained.
- Public Member Functions inherited from CXTPChartElement
CXTPChartElement ()
Constructs a CXTPChartElement object.
virtual | ~CXTPChartElement ()
Destroys a CXTPChartElement object, handles cleanup.
virtual void | Release ()
Call this function to decrease the usage count of the object.
CXTPChartElement * | GetOwner () const
Call this function to get the owner element.
virtual void | OnChartChanged (XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic properties of the chart.
CXTPChartContent * | GetContent () const
Call this virtual function to get the chart content object.
CXTPChartAppearance * | GetAppearance () const
Call this function to get the the appearance of the chart.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Protected Member Functions

virtual CXTPChartSeriesView * | CreateView (CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Call this function to create the view of the bar series.
virtual void | CorrectAxisSideMargins (CXTPChartAxis *pAxis, double nMinValue, double nMaxValue, double &nCorrection)
Call this function to correct the axis side margins.
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.

Additional Inherited Members

- Public Attributes inherited from CXTPChartElement
- Protected Attributes inherited from CXTPChartDiagram2DSeriesStyle
int | m_nAxisIndexX
Holds index of secondary axisX, used when m_bSecondaryAxisX is TRUE.
int | m_nAxisIndexY
Holds index of secondary axisY, used when m_bSecondaryAxisY is TRUE.
- Protected Attributes inherited from CXTPChartSeriesStyle
CXTPChartSeriesLabel * | m_pLabel
Label object.
CXTPChartErrorBar * | m_pErrorBar
Error bar object.
CXTPChartColor | m_clrColor
Custom color of series.
BOOL | m_bColorEach
TRUE to color each point.
int | m_nTransparency
The transparency value in the range 0..255.
CXTPChart3dRotation | m_Rotation3d
3D rotation
BOOL | m_bSmooth3dEdges
3D edge smoothing
- Protected Attributes inherited from CXTPChartElement

Detailed Description

This class represents a bar series style for the chart, which is a kind of CXTPChartSeriesStyle.

A bar chart or bar graph is a chart with rectangular bars with lengths proportional to the values that they represent. Bar charts are used for comparing two or more values that were taken over time or on different conditions, usually on small data sets.

Member Function Documentation

◆ CorrectAxisSideMargins()

virtual void CorrectAxisSideMargins | ( | CXTPChartAxis * | pAxis,
 |  | double | nMinValue,
 |  | double | nMaxValue,
 |  | double & | nCorrection )
 protectedvirtual

Call this function to correct the axis side margins.

Parameters
pAxis | A pointer to the chart axis object, to which this object is associated with.
nMinValue | A double specifying the minimum value.
nMaxValue | A double specifying the maximum value.
nCorrection | A reference to a double object, which specifies the correction applied.

Reimplemented from CXTPChartSeriesStyle.

Reimplemented in CXTPChartStackedBarSeriesStyle.

◆ CreateView()

virtual CXTPChartSeriesView * CreateView | ( | CXTPChartSeries * | pSeries,
 |  | CXTPChartDiagramView * | pDiagramView )
 protectedvirtual

Call this function to create the view of the bar series.

Parameters
pSeries | A pointer to the chart series object, to which this object is associated with.
pDiagramView | A pointer to the chart diagram view object, to which this object is associated with.
Returns
A pointer to CXTPChartSeriesView. Refers to the newly created CXTPChartBarSeriesView object.

Implements CXTPChartSeriesStyle.

Reimplemented in CXTPChartGanttSeriesStyle, CXTPChartRangeBarSeriesStyle, and CXTPChartStackedBarSeriesStyle.

◆ DoPropExchange()

void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Reads this object from or writes this object to an archive.

Parameters
pPX A CXTPPropExchange object to serialize to or from.

Reimplemented from CXTPChartSeriesStyle.

Reimplemented in CXTPChartGanttSeriesStyle, CXTPChartRangeBarSeriesStyle, and CXTPChartStackedBarSeriesStyle.

◆ GetBarWidth()

AFX_INLINE double GetBarWidth ( ) const

Call this function to get the width of the bar.

Returns
A double value specifying the width of the bar.

◆ SetBarWidth()

AFX_INLINE void SetBarWidth ( double dWidth )

Call this function to set the width of the bar.

Parameters
dWidth A double value specifying the width of the bar.
The documentation for this class was generated from the following file:
  • XTPChartBarSeriesStyle.h


Toolkit Pro: CXTPChartBarSeriesView Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPChartBarSeriesView Class Reference

This class represents the view of a bar series, which is a kind of CXTPChartSeriesView. More...

Inheritance diagram for CXTPChartBarSeriesView:
[legend]

Public Member Functions

CXTPChartBarSeriesView (CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Constructs a CXTPChartBarSeriesView object.

Protected Member Functions

CXTPChartSeriesPointView * | CreateSeriesPointView (CXTPChartDeviceContext *pDC, CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Call this function to create a view of the bar series point.
void | BeforeUpdateRange (CXTPChartDeviceContext *pDC)
Call this function to calculate the layout of the bar series.
virtual CXTPChartDeviceCommand * | CreateLegendDeviceCommand (CXTPChartDeviceContext *pDC, CRect rcBounds)
This function creates a label view drawing command object.

Protected Attributes

int | m_nBarCount
The bar count in the series.
int | m_nBarIndex
The index of the bar series.

Detailed Description

This class represents the view of a bar series, which is a kind of CXTPChartSeriesView.

Constructor & Destructor Documentation

◆ CXTPChartBarSeriesView()

CXTPChartBarSeriesView | ( | CXTPChartSeries * | pSeries,
 |  | CXTPChartDiagramView * | pDiagramView )

Constructs a CXTPChartBarSeriesView object.

Parameters
pSeries | A pointer to the chart series object.
pDiagramView | A pointer to the diagram view object.

Member Function Documentation

◆ BeforeUpdateRange()

void BeforeUpdateRange ( CXTPChartDeviceContext * pDC )
protected

Call this function to calculate the layout of the bar series.

Parameters
pDC A pointer to the chart device context.

◆ CreateLegendDeviceCommand()

virtual CXTPChartDeviceCommand * CreateLegendDeviceCommand | ( | CXTPChartDeviceContext * | pDC,
 |  | CRect | rcBounds )
 protectedvirtual

This function creates a label view drawing command object.

Parameters
pDC | Pointer to a CXTPChartDeviceContext object.
rcBounds | The rectangular boundary of the legend.
Returns
Returns a new label view drawing command object.

Implements CXTPChartLegendItemView.

◆ CreateSeriesPointView()

CXTPChartSeriesPointView * CreateSeriesPointView | ( | CXTPChartDeviceContext * | pDC,
 |  | CXTPChartSeriesPoint * | pPoint,
 |  | CXTPChartElementView * | pParentView )
 protected

Call this function to create a view of the bar series point.

Parameters
pDC | A pointer to the chart device context.
pPoint | A pointer to the chart series point object.
pParentView | Parent view pointer.
Returns
A pointer to CXTPChartSeriesPointView, which refers to the newly created CXTPChartBarSeriesPointView object.
The documentation for this class was generated from the following file:
  • XTPChartBarSeriesView.h


Toolkit Pro: CXTPChartBorder Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPChartBorder Class Reference

This class abstracts the border of a chart, it is a kind of chart element. More...

Inheritance diagram for CXTPChartBorder:
[legend]

Public Member Functions

CXTPChartBorder (CXTPChartElement *pOwner)
Constructs a CXTPChartBorder object.
virtual | ~CXTPChartBorder ()
Destroys a CXTPChartBorder object, handles cleanup.
BOOL | IsVisible () const
Call this function to check whether the chart border is visible or not.
CXTPChartColor | GetColor () const
This function returns the color of the border.
int | GetThickness () const
Call this function to get the thickness of the chart border.
void | SetThickness (int Thickness)
Call this function to set the thickness of the chart border.
virtual CXTPChartDeviceCommand * | CreateDeviceCommand (const CXTPChartRectF &rcBounds, const CXTPChartColor &color)
This function creates a CXTPChartDeviceCommand object, this object represents the rendering of the border of the chart.
virtual CXTPChartDeviceCommand * | CreateInnerBorderDeviceCommand (const CXTPChartRectF &rcBounds, const CXTPChartColor &color)
This function creates a CXTPChartDeviceCommand object, this object represents the rendering of the border of the chart.
void | DoPropExchange (CXTPPropExchange *pPX)
Call this member function to store/Load the properties of chart boundary object using the specified data object.
- Public Member Functions inherited from CXTPChartElement
CXTPChartElement ()
Constructs a CXTPChartElement object.
virtual | ~CXTPChartElement ()
Destroys a CXTPChartElement object, handles cleanup.
virtual void | Release ()
Call this function to decrease the usage count of the object.
CXTPChartElement * | GetOwner () const
Call this function to get the owner element.
virtual void | OnChartChanged (XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic properties of the chart.
CXTPChartContent * | GetContent () const
Call this virtual function to get the chart content object.
CXTPChartAppearance * | GetAppearance () const
Call this function to get the the appearance of the chart.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Protected Attributes

CXTPChartColor | m_clrColor
The boundary color.
int | m_nThickness
The thickness of the boundary.
BOOL | m_bVisible
TRUE if the boundary is visible, FALSE if invisible.
- Protected Attributes inherited from CXTPChartElement

Additional Inherited Members

- Public Attributes inherited from CXTPChartElement
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.

Detailed Description

This class abstracts the border of a chart, it is a kind of chart element.

Constructor & Destructor Documentation

◆ CXTPChartBorder()

CXTPChartBorder ( CXTPChartElement * pOwner )

Constructs a CXTPChartBorder object.

Parameters
pOwner The owner element of this element.

Member Function Documentation

◆ CreateDeviceCommand()

virtual CXTPChartDeviceCommand * CreateDeviceCommand | ( | const CXTPChartRectF & | rcBounds,
 |  | const CXTPChartColor & | color )
 virtual

This function creates a CXTPChartDeviceCommand object, this object represents the rendering of the border of the chart.

Parameters
rcBounds | The bounding rectange.
color | Reference to a chart color object.
Returns
Returns a pointer to CXTPChartDeviceCommand object, this polymorphic object handles the rendering of an element in the chart. Here it handles the drawing of the border of the chart.

◆ CreateInnerBorderDeviceCommand()

virtual CXTPChartDeviceCommand * CreateInnerBorderDeviceCommand | ( | const CXTPChartRectF & | rcBounds,
 |  | const CXTPChartColor & | color )
 virtual

This function creates a CXTPChartDeviceCommand object, this object represents the rendering of the border of the chart.

Parameters
rcBounds | The bounding rectange.
color | Reference to a chart color object.
Returns
Returns a pointer to CXTPChartDeviceCommand object, this polymorphic object handles the rendering of an element in the chart. Here it handles the drawing of the border of the chart.

◆ DoPropExchange()

void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Call this member function to store/Load the properties of chart boundary object using the specified data object.

Parameters
pPX Source or destination CXTPPropExchange data object reference.

This member function is used to store or load property data to or from a storage.

Reimplemented from CXTPChartElement.

◆ GetColor()

AFX_INLINE CXTPChartColor GetColor ( ) const

This function returns the color of the border.

Returns
A CXTPChartColor object denote the ARGB value of the border.

◆ GetThickness()

AFX_INLINE int GetThickness ( ) const

Call this function to get the thickness of the chart border.

Returns
An integer value tells the thickness of the border.

◆ IsVisible()

AFX_INLINE BOOL IsVisible ( ) const

Call this function to check whether the chart border is visible or not.

Returns
A BOOL value of TURE if the border is visible and FALSE if the not.

◆ SetThickness()

AFX_INLINE void SetThickness ( int Thickness )

Call this function to set the thickness of the chart border.

Parameters
Thickness Thickness to be set.
The documentation for this class was generated from the following file:
  • XTPChartBorder.h


Toolkit Pro: CXTPChartBoundedCircleDeviceCommand Class Reference

Protected Member Functions | Protected Attributes | List of all members
CXTPChartBoundedCircleDeviceCommand Class Reference

This class represents a bounded circle device command, which is a kind of CXTPChartDeviceCommand. More...

Inheritance diagram for CXTPChartBoundedCircleDeviceCommand:
[legend]

Protected Member Functions

CXTPChartBoundedCircleDeviceCommand (const CXTPChartPointF &center, double radius, const CXTPChartColor &color, int thickness)
Constructs a CXTPChartBoundedCircleDeviceCommand object.
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.
- Protected Member Functions inherited from CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents >
CXTPObservable ()
Constructs an observable object.
~CXTPObservable ()
Handles observable object destruction.

Protected Attributes

CXTPChartColor | m_color
The color of the cirular boundary.
int | m_thickness
The thickness of the circular boundary.
CXTPChartPointF | m_center
The center point of the circle.
double | m_radius
The radius of the circle.
- Protected Attributes inherited from CXTPChartDeviceCommand
CArray< CXTPChartDeviceCommand *, CXTPChartDeviceCommand * > | m_arrChildren
< The array of child device commands.

Additional Inherited Members

- Public Member Functions inherited from CXTPChartDeviceCommand
CXTPChartDeviceCommand ()
Constructs a CXTPChartDeviceCommand object.
virtual | ~CXTPChartDeviceCommand ()
Destroys a CXTPChartDeviceCommand object, handles cleanup.
BOOL | IsCommitted () const
Determines if the execution of the command has been committed.
void | Commit ()
Commits the execution of the command.
int | GetChildCommandCount () const
Obtains the number of immediate children commands.
CXTPChartDeviceCommand * | GetChildCommand (int nIndex) const
Obtains immediate child command point by index.
CXTPChartDeviceCommand * | AddChildCommand (CXTPChartDeviceCommand *pCommand)
Call this function to add a child device command.
virtual void | Execute (CXTPChartDeviceContext *pDC)
Call this function to execute the drawing.
virtual void | BeforeExecute (CXTPChartDeviceContext *pDC)
This method gets called before a command is executed which allows for the customization of command behavior.
virtual void | AfterExecute (CXTPChartDeviceContext *pDC)
This method gets called after a command is executed which allows for the customization of command behavior.
virtual void | ExecuteOverride (CXTPChartDeviceContext *pDC)
Override this function to write the drawing code for specific objects.
UINT | GetPassNumber () const
Get the number of executions made by the command.
virtual CXTPChartElement * | HitTest (CPoint point, CXTPChartElement *pParent) const
Performs recursive hit testing of the element at the specified point.
virtual void | ApplySeriesStyle (CXTPChartSeriesStyle *pStyle)
Applies series style to the current element.
virtual void | Prepare (CXTPChartDeviceContext *pDC)
Performs inital preparation steps necessary for successful command execution.
virtual void | PrepareOverride (CXTPChartDeviceContext *pDC)
Derived implementation must override this method for implementing implementation specific preparation behavior.
virtual BOOL | IsEnabled () const
Determines if the command is currently enabled.
void | SetEnabled (BOOL bEnabled=TRUE)
Enables/disable the command.
CXTPChartDeviceContext * | GetCurrentDC () const
Obtains device context pointer for which the command is currenly being prepared or executed.
void | BindView (CXTPChartElementView *pView)
Binds a view to the command object.
CXTPChartElementView * | GetBoundView () const
Obtains a bound view pointer or NULL if no view is bound.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.
- Public Member Functions inherited from CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents >
void | Subscribe (CXTPChartDeviceCommandEvents *pObserver, CXTPSubscriptionList< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > *pSubcriptionList=NULL)
Subscribes a unique observer for events.
void | Unsubscribe (CXTPChartDeviceCommandEvents *pObserver)
Unsubscribes an observer from events.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *))
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *))
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.

Detailed Description

This class represents a bounded circle device command, which is a kind of CXTPChartDeviceCommand.

It specifically handles the rendering of circular shapes in a chart.

Constructor & Destructor Documentation

◆ CXTPChartBoundedCircleDeviceCommand()

CXTPChartBoundedCircleDeviceCommand | ( | const CXTPChartPointF & | center,
 |  | double | radius,
 |  | const CXTPChartColor & | color,
 |  | int | thickness )
 protected

Constructs a CXTPChartBoundedCircleDeviceCommand object.

Parameters
center | The center point of the circle.
radius | The radius of the circle.
color | The color of boundary.
thickness | The thickness of the boundary.
The documentation for this class was generated from the following file:
  • XTPChartCircleDeviceCommand.h


Toolkit Pro: CXTPChartBoundedPolygonDeviceCommand Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPChartBoundedPolygonDeviceCommand Class Reference

Base class implementation for 2D chart bounded polygon device command. More...

Inheritance diagram for CXTPChartBoundedPolygonDeviceCommand:
[legend]

Public Member Functions

CXTPChartBoundedPolygonDeviceCommand (const CXTPChartPoints &points, const CXTPChartColor &color, int thickness)
Constructs a CXTPChartBoundedPolygonDeviceCommand object.
- Public Member Functions inherited from CXTPChartDeviceCommand
CXTPChartDeviceCommand ()
Constructs a CXTPChartDeviceCommand object.
virtual | ~CXTPChartDeviceCommand ()
Destroys a CXTPChartDeviceCommand object, handles cleanup.
BOOL | IsCommitted () const
Determines if the execution of the command has been committed.
void | Commit ()
Commits the execution of the command.
int | GetChildCommandCount () const
Obtains the number of immediate children commands.
CXTPChartDeviceCommand * | GetChildCommand (int nIndex) const
Obtains immediate child command point by index.
CXTPChartDeviceCommand * | AddChildCommand (CXTPChartDeviceCommand *pCommand)
Call this function to add a child device command.
virtual void | Execute (CXTPChartDeviceContext *pDC)
Call this function to execute the drawing.
virtual void | BeforeExecute (CXTPChartDeviceContext *pDC)
This method gets called before a command is executed which allows for the customization of command behavior.
virtual void | AfterExecute (CXTPChartDeviceContext *pDC)
This method gets called after a command is executed which allows for the customization of command behavior.
virtual void | ExecuteOverride (CXTPChartDeviceContext *pDC)
Override this function to write the drawing code for specific objects.
UINT | GetPassNumber () const
Get the number of executions made by the command.
virtual CXTPChartElement * | HitTest (CPoint point, CXTPChartElement *pParent) const
Performs recursive hit testing of the element at the specified point.
virtual void | ApplySeriesStyle (CXTPChartSeriesStyle *pStyle)
Applies series style to the current element.
virtual void | Prepare (CXTPChartDeviceContext *pDC)
Performs inital preparation steps necessary for successful command execution.
virtual void | PrepareOverride (CXTPChartDeviceContext *pDC)
Derived implementation must override this method for implementing implementation specific preparation behavior.
virtual BOOL | IsEnabled () const
Determines if the command is currently enabled.
void | SetEnabled (BOOL bEnabled=TRUE)
Enables/disable the command.
CXTPChartDeviceContext * | GetCurrentDC () const
Obtains device context pointer for which the command is currenly being prepared or executed.
void | BindView (CXTPChartElementView *pView)
Binds a view to the command object.
CXTPChartElementView * | GetBoundView () const
Obtains a bound view pointer or NULL if no view is bound.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.
- Public Member Functions inherited from CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents >
void | Subscribe (CXTPChartDeviceCommandEvents *pObserver, CXTPSubscriptionList< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > *pSubcriptionList=NULL)
Subscribes a unique observer for events.
void | Unsubscribe (CXTPChartDeviceCommandEvents *pObserver)
Unsubscribes an observer from events.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *))
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *))
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.

Protected Attributes

CXTPChartPoints | m_points
The points which form the spline polygon.
CXTPChartColor | m_color
The color of the rectangle border.
int | m_thickness
The thickness of the rectangle border.
- Protected Attributes inherited from CXTPChartDeviceCommand
CArray< CXTPChartDeviceCommand *, CXTPChartDeviceCommand * > | m_arrChildren
< The array of child device commands.

Additional Inherited Members

- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.
- Protected Member Functions inherited from CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents >
CXTPObservable ()
Constructs an observable object.
~CXTPObservable ()
Handles observable object destruction.

Detailed Description

Base class implementation for 2D chart bounded polygon device command.

Constructor & Destructor Documentation

◆ CXTPChartBoundedPolygonDeviceCommand()

CXTPChartBoundedPolygonDeviceCommand | ( | const CXTPChartPoints & | points,
 |  | const CXTPChartColor & | color,
 |  | int | thickness )

Constructs a CXTPChartBoundedPolygonDeviceCommand object.

Parameters
points | Point collection used for drawing polygon.
color | The color of the rectangle border.
thickness | The thickness of the rectangular border.
The documentation for this class was generated from the following file:
  • XTPChartPolygonDeviceCommand.h


Toolkit Pro: CXTPChartBoundedTextDeviceCommand Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPChartBoundedTextDeviceCommand Class Reference

This class represents a bounded text device command, which is a kind of CXTPChartDeviceCommand. More...

Inheritance diagram for CXTPChartBoundedTextDeviceCommand:
[legend]

Public Member Functions

CXTPChartBoundedTextDeviceCommand (const CXTPChartString &strText, CXTPChartFont *pFont, const CXTPChartColor &color, const CXTPChartRectF &rectangle)
Constructs a CXTPChartBoundedTextDeviceCommand object.
virtual CXTPChartElement * | HitTest (CPoint point, CXTPChartElement *pParent) const
Performs recursive hit testing of the element at the specified point.
- Public Member Functions inherited from CXTPChartDeviceCommand
CXTPChartDeviceCommand ()
Constructs a CXTPChartDeviceCommand object.
virtual | ~CXTPChartDeviceCommand ()
Destroys a CXTPChartDeviceCommand object, handles cleanup.
BOOL | IsCommitted () const
Determines if the execution of the command has been committed.
void | Commit ()
Commits the execution of the command.
int | GetChildCommandCount () const
Obtains the number of immediate children commands.
CXTPChartDeviceCommand * | GetChildCommand (int nIndex) const
Obtains immediate child command point by index.
CXTPChartDeviceCommand * | AddChildCommand (CXTPChartDeviceCommand *pCommand)
Call this function to add a child device command.
virtual void | Execute (CXTPChartDeviceContext *pDC)
Call this function to execute the drawing.
virtual void | BeforeExecute (CXTPChartDeviceContext *pDC)
This method gets called before a command is executed which allows for the customization of command behavior.
virtual void | AfterExecute (CXTPChartDeviceContext *pDC)
This method gets called after a command is executed which allows for the customization of command behavior.
UINT | GetPassNumber () const
Get the number of executions made by the command.
virtual void | ApplySeriesStyle (CXTPChartSeriesStyle *pStyle)
Applies series style to the current element.
virtual void | Prepare (CXTPChartDeviceContext *pDC)
Performs inital preparation steps necessary for successful command execution.
virtual void | PrepareOverride (CXTPChartDeviceContext *pDC)
Derived implementation must override this method for implementing implementation specific preparation behavior.
virtual BOOL | IsEnabled () const
Determines if the command is currently enabled.
void | SetEnabled (BOOL bEnabled=TRUE)
Enables/disable the command.
CXTPChartDeviceContext * | GetCurrentDC () const
Obtains device context pointer for which the command is currenly being prepared or executed.
void | BindView (CXTPChartElementView *pView)
Binds a view to the command object.
CXTPChartElementView * | GetBoundView () const
Obtains a bound view pointer or NULL if no view is bound.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.
- Public Member Functions inherited from CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents >
void | Subscribe (CXTPChartDeviceCommandEvents *pObserver, CXTPSubscriptionList< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > *pSubcriptionList=NULL)
Subscribes a unique observer for events.
void | Unsubscribe (CXTPChartDeviceCommandEvents *pObserver)
Unsubscribes an observer from events.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *))
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *))
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.

Protected Attributes

CXTPChartRectF | m_rect
The bounding rectangle of the text.
- Protected Attributes inherited from CXTPChartTextDeviceCommand
CXTPChartString | m_strText
The string to be rendered.
CXTPChartFont * | m_pFont
The font used to render the text.
CXTPChartColor | m_color
The color of the text.
- Protected Attributes inherited from CXTPChartDeviceCommand
CArray< CXTPChartDeviceCommand *, CXTPChartDeviceCommand * > | m_arrChildren
< The array of child device commands.

Additional Inherited Members

- Protected Member Functions inherited from CXTPChartTextDeviceCommand
CXTPChartTextDeviceCommand (const CXTPChartString &strText, CXTPChartFont *pFont, const CXTPChartColor &color)
Constructs a CXTPChartTextDeviceCommand object.
virtual void | ExecuteOverride (CXTPChartDeviceContext *pDC)
This is a virtual function override of base class CXTPChartDeviceContext.
virtual void | ExecuteInternal (CXTPChartDeviceContext *pDC)
This function does the actual drawing of the chart element to which this device command is associated with.
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.
- Protected Member Functions inherited from CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents >
CXTPObservable ()
Constructs an observable object.
~CXTPObservable ()
Handles observable object destruction.

Detailed Description

This class represents a bounded text device command, which is a kind of CXTPChartDeviceCommand.

It handles the rendering of bounded texts in a chart.

Constructor & Destructor Documentation

◆ CXTPChartBoundedTextDeviceCommand()

CXTPChartBoundedTextDeviceCommand | ( | const CXTPChartString & | strText,
 |  | CXTPChartFont * | pFont,
 |  | const CXTPChartColor & | color,
 |  | const CXTPChartRectF & | rectangle )

Constructs a CXTPChartBoundedTextDeviceCommand object.

Parameters
strText | The text to be rendered.
pFont | The font used to render.
color | The color of the text.
rectangle | The text bounds.

Member Function Documentation

◆ HitTest()

virtual CXTPChartElement * HitTest | ( | CPoint | point,
 |  | CXTPChartElement * | pParent ) const
 virtual

Performs recursive hit testing of the element at the specified point.

Parameters
point | Point in which an element is to be found.
pParent | Parent element pointer.
Returns
A pointer to the element found at the specified point or NULL if no element is found.

Reimplemented from CXTPChartDeviceCommand.

The documentation for this class was generated from the following file:
  • XTPChartTextDeviceCommand.h


Toolkit Pro: CXTPChartBubbleSeriesLabel Class Reference

Public Member Functions | List of all members
CXTPChartBubbleSeriesLabel Class Reference

CXTPChartBubbleSeriesLabel is a kind of CXTPChartSeriesLabel. More...

Inheritance diagram for CXTPChartBubbleSeriesLabel:
[legend]

Public Member Functions

CXTPChartBubbleSeriesLabel ()
Constructs a CXTPChartBubbleSeriesLabel object.
virtual | ~CXTPChartBubbleSeriesLabel ()
Destroys a CXTPChartBubbleSeriesLabel object, handles cleanup.
virtual CXTPChartElementView * | CreateView (CXTPChartDeviceContext *pDC, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView)
This function creates the view (CXTPChartBubbleSeriesLabelView) of the bubble series.
- Public Member Functions inherited from CXTPChartSeriesLabel
CXTPChartSeriesLabel ()
Constructs a CXTPChartSeriesLabel object.
virtual | ~CXTPChartSeriesLabel ()
Destroys a CXTPChartSeriesLabel object, handles cleanup.
void | SetTextColor (const CXTPChartColor &clrTextColor)
Call this function to set the text color of the label.
CXTPChartColor | GetTextColor () const
Call this function to get the apparent text color of the label.
CXTPChartFont * | GetFont () const
Call this function to get the font of the text label.
void | SetFont (CXTPChartFont *pFont)
Call this function to set the font of the text label.
void | SetShowLines (BOOL bShowLines)
Call this function to set the lines visibility.
BOOL | GetShowLines () const
Call this function to check if the lines are visible.
void | SetLineLength (int nLineLength)
Call this function to set the line length.
int | GetLineLength () const
Call this function to get the line length.
void | SetVisible (BOOL bVisible)
Call this function to set the label visibility.
BOOL | IsVisible () const
Call this function to check if the label is visible.
void | SetAntialiasing (BOOL bAntialiasing)
Call this function to set anti-aliasing ON or OFF.
BOOL | GetAntialiasing () const
Call this function to check if anti-aliasing is ON or OFF.
CXTPChartNumberFormat * | GetFormat () const
Call this function to get a pointer to CXTPChartNumberFormat that specifies how to convert numbers to strings.
void | SetFormat (LPCTSTR lpszFormat)
Obsolete method.
void | SetBackColor (const CXTPChartColor &clrBackColor)
Call this function to set the text color of the label.
CXTPChartColor | GetBackColor () const
Call this function to get the apparent text color of the label.
void | SetLineColor (const CXTPChartColor &clrBackColor)
Call this function to set the text color of the label.
CXTPChartColor | GetLineColor () const
Call this function to get the apparent text color of the label.
int | GetTransparency () const
Call this function to get the transparency of the filled area with respect to the background.
void | SetTransparency (int nTransparency)
Call this function to set the transparency of the filled area with respect to the background.
virtual void | DoPropExchange (CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
- Public Member Functions inherited from CXTPChartTextElement
- Public Member Functions inherited from CXTPChartElement
CXTPChartElement ()
Constructs a CXTPChartElement object.
virtual | ~CXTPChartElement ()
Destroys a CXTPChartElement object, handles cleanup.
virtual void | Release ()
Call this function to decrease the usage count of the object.
CXTPChartElement * | GetOwner () const
Call this function to get the owner element.
virtual void | OnChartChanged (XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic properties of the chart.
CXTPChartContent * | GetContent () const
Call this virtual function to get the chart content object.
CXTPChartAppearance * | GetAppearance () const
Call this function to get the the appearance of the chart.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Additional Inherited Members

- Public Attributes inherited from CXTPChartElement
- Protected Member Functions inherited from CXTPChartSeriesLabel
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.
- Protected Attributes inherited from CXTPChartSeriesLabel
CXTPChartColor | m_clrTextColor
The text color.
CXTPChartColor | m_clrBackColor
The background color.
CXTPChartColor | m_clrLineColor
The line color.
BOOL | m_bVisible
TRUE if the label is visible and FALSE if not.
CXTPChartFont * | m_pFont
The font of the label.
BOOL | m_bAntialiasing
TRUE if antialiasing enabled, FALSE if not.
BOOL | m_bShowLines
TRUE if the lines are visible, FALSE if not.
int | m_nLineLength
The line length.
CXTPChartBorder * | m_pBorder
Chart border object.
int | m_nTransparency
The transparency values range from 0 to 255.
- Protected Attributes inherited from CXTPChartElement

Detailed Description

CXTPChartBubbleSeriesLabel is a kind of CXTPChartSeriesLabel.

This class abstracts the label of a bubble series.

Member Function Documentation

◆ CreateView()

virtual CXTPChartElementView * CreateView | ( | CXTPChartDeviceContext * | pDC,
 |  | CXTPChartSeriesPointView * | pPointView,
 |  | CXTPChartElementView * | pParentView )
 virtual

This function creates the view (CXTPChartBubbleSeriesLabelView) of the bubble series.

Parameters
pDC | The chart device context object pointer.
pPointView | The seris point view.
pParentView | Parent view pointer.
Returns
Returns a pointer to the associated label view object.

Reimplemented from CXTPChartSeriesLabel.

The documentation for this class was generated from the following file:
  • XTPChartBubbleSeriesLabel.h


Toolkit Pro: CXTPChartBubbleSeriesLabelView Class Reference

Public Member Functions | List of all members
CXTPChartBubbleSeriesLabelView Class Reference

CXTPChartBubbleSeriesLabelView is a kind of CXTPChartSeriesLabelView. More...

Inheritance diagram for CXTPChartBubbleSeriesLabelView:
[legend]

Public Member Functions

CXTPChartBubbleSeriesLabelView (CXTPChartSeriesLabel *pLabel, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView)
Constructs a CXTPChartBubbleSeriesLabelView object.
virtual CXTPChartDeviceCommand * | CreateDeviceCommand (CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
virtual CXTPChartDeviceCommand * | CreateDeviceCommand (CXTPChartDeviceContext *pDC, CXTPChartPointF ptCenterPoint)
This function creates a CXTPChartDeviceCommand object.
virtual CXTPChartDeviceCommand * | CreateDeviceCommand (CXTPChartDeviceContext *pDC, CXTPChartPointF ptCenterPoint, const CXTPChartString &text)
This function creates a CXTPChartDeviceCommand object.
virtual CXTPChartDeviceCommand * | CreateDeviceCommand (CXTPChartDeviceContext *pDC, const CXTPChartPointF &ptAnchorPoint, double dAnchorAngle, const CXTPChartString &text)
This function creates a CXTPChartDeviceCommand object.
- Public Member Functions inherited from CXTPChartDiagram2DSeriesLabelView
CXTPChartDiagram2DSeriesLabelView (CXTPChartSeriesLabel *pLabel, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView)
Constructs a CXTPChartDiagram2DSeriesLabelView object.
virtual CXTPChartPointF | GetAnchorPoint () const
This function calculates the anchor point of the label stem.

Detailed Description

CXTPChartBubbleSeriesLabelView is a kind of CXTPChartSeriesLabelView.

This class abstracts the view of a bubble series label.

Constructor & Destructor Documentation

◆ CXTPChartBubbleSeriesLabelView()

CXTPChartBubbleSeriesLabelView | ( | CXTPChartSeriesLabel * | pLabel,
 |  | CXTPChartSeriesPointView * | pPointView,
 |  | CXTPChartElementView * | pParentView )

Constructs a CXTPChartBubbleSeriesLabelView object.

Parameters
pLabel | A pointer to the chart series label object.
pPointView | A pointer to the chart series point view object.
pParentView | Parent view pointer.

Member Function Documentation

◆ CreateDeviceCommand() [1/4]

virtual CXTPChartDeviceCommand * CreateDeviceCommand ( CXTPChartDeviceContext * pDC )
virtual

This function creates a CXTPChartDeviceCommand object.

This object represents the rendering of a bubble series label.

Parameters
pDC Pointer to a CXTPChartDeviceContext object.
Returns
Returns a CXTPChartDeviceCommand object. This object handles the rendering of an element in the chart. Here it handles the drawing of the bubble series label.

Reimplemented from CXTPChartDiagram2DSeriesLabelView.

◆ CreateDeviceCommand() [2/4]

virtual CXTPChartDeviceCommand * CreateDeviceCommand | ( | CXTPChartDeviceContext * | pDC,
 |  | const CXTPChartPointF & | ptAnchorPoint,
 |  | double | dAnchorAngle,
 |  | const CXTPChartString & | text )
 virtual

This function creates a CXTPChartDeviceCommand object.

This object represents the rendering of the chart series label.

Parameters
pDC | Pointer to a CXTPChartDeviceContext object.
text | Text.
ptAnchorPoint | Anchor point.
dAnchorAngle | Anchor angle.
Returns
Returns a pointer to a CXTPChartDeviceCommand object. This polymorphic object handles the rendering of an element in the chart. Here it handles the drawing of the chart series label.

Reimplemented from CXTPChartDiagram2DSeriesLabelView.

◆ CreateDeviceCommand() [3/4]

virtual CXTPChartDeviceCommand * CreateDeviceCommand | ( | CXTPChartDeviceContext * | pDC,
 |  | CXTPChartPointF | ptCenterPoint )
 virtual

This function creates a CXTPChartDeviceCommand object.

This object represents the rendering of the chart series label.

Parameters
pDC | Pointer to a CXTPChartDeviceContext object.
ptCenterPoint | Center point.
Returns
Returns a pointer to a CXTPChartDeviceCommand object. This polymorphic object handles the rendering of an element in the chart. Here it handles the drawing of the chart series label.

Reimplemented from CXTPChartDiagram2DSeriesLabelView.

◆ CreateDeviceCommand() [4/4]

virtual CXTPChartDeviceCommand * CreateDeviceCommand | ( | CXTPChartDeviceContext * | pDC,
 |  | CXTPChartPointF | ptCenterPoint,
 |  | const CXTPChartString & | text )
 virtual

This function creates a CXTPChartDeviceCommand object.

This object represents the rendering of the chart series label.

Parameters
pDC | Pointer to a CXTPChartDeviceContext object.
ptCenterPoint | Center point.
text | Text.
Returns
Returns a pointer to a CXTPChartDeviceCommand object. This polymorphic object handles the rendering of an element in the chart. Here it handles the drawing of the chart series label.

Reimplemented from CXTPChartDiagram2DSeriesLabelView.

The documentation for this class was generated from the following file:
  • XTPChartBubbleSeriesLabel.h


Toolkit Pro: CXTPChartBubbleSeriesPointView Class Reference

Public Member Functions | List of all members
CXTPChartBubbleSeriesPointView Class Reference

This class represents the view of a bubble series point, which is a kind of CXTPChartPointSeriesPointView. More...

Inheritance diagram for CXTPChartBubbleSeriesPointView:
[legend]

Public Member Functions

CXTPChartBubbleSeriesPointView (CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Constructs a CXTPChartBubbleSeriesPointView object.
virtual CXTPChartDeviceCommand * | CreateDeviceCommand (CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
CXTPChartColor | GetActualColor () const
Call this function to get the actual color.
CXTPChartColor | GetActualColor2 () const
Call this function to get the second actual color.
- Public Member Functions inherited from CXTPChartPointSeriesPointView
CXTPChartPointSeriesPointView (CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Constructs a CXTPChartPointSeriesPointView object.
virtual CXTPChartDeviceCommand * | CreateLegendDeviceCommand (CXTPChartDeviceContext *pDC, CRect rcBounds)
This function creates a label view drawing command object.
CXTPChartPointF | GetScreenPoint () const
Call this function to get the screen point from the series point.
- Public Member Functions inherited from CXTPChartSeriesPointView
CXTPChartSeriesPointView (CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Constructs the view object.
CXTPChartSeriesPointView (CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView, BOOL bAddToParent)
Constructs the view object.
CXTPChartSeriesPoint * | GetPoint () const
Obtains point model object.
CXTPChartSeriesView * | GetSeriesView () const
Obtains parent series view.
CXTPChartColor | GetColor () const
Obtain view color values.
CXTPChartColor | GetColor2 () const
Obtain view color values.
double | GetInternalValue () const
Obtains point interval value.
virtual CXTPChartString | GetLegendName () const
This function returns the legend name.
virtual void | UpdateMinMaxRange (double &nMinValue, double &nMaxValue) const
Provides a default empty implementation for min/max range update request.
- Public Member Functions inherited from CXTPChartElementView
CXTPChartElementView (CXTPChartElementView *pParentView)
Constructs a CXTPChartElementView object.
CXTPChartElementView (CXTPChartElementView *pParentView, BOOL bAddToParent)
Constructs a CXTPChartElementView object.
CXTPChartElementView (CXTPChartContainer *pContainer)
Constructs a CXTPChartElementView object.
int | GetCount () const
Call this function to get the number of child views associated with this view.
CXTPChartElementView * | GetAt (int nIndex) const
Call this function to get a child view at a particular index.
CXTPChartElementView * | GetParentView () const
Call this function to get the parent view.
CXTPChartElementView * | AddChildView (CXTPChartElementView *pChildView)
Call this function to add a child view to the current view.
CXTPChartElementView ** GetChildren ()
Provides access to the collection of children elements owned by the view.
CRect | GetBounds () const
Obtains viewed object's bound rectangle.
CRect | GetBounds (BOOL bIncludingChildren) const
Obtains viewed object's bound rectangle.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.
- Public Member Functions inherited from CXTPChartLegendItemView
virtual | ~CXTPChartLegendItemView ()
Handles object destruction.

Additional Inherited Members

- Public Attributes inherited from CXTPChartSeriesPointView
double | m_dInternalValue
Point internal value.
- Protected Member Functions inherited from CXTPChartElementView
virtual | ~CXTPChartElementView ()
Destroys a CXTPChartElementView object, handles cleanup.
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.
- Protected Attributes inherited from CXTPChartSeriesPointView
CXTPChartSeriesPoint * | m_pPoint
Point model object pointer.
- Protected Attributes inherited from CXTPChartElementView
CArray< CXTPChartElementView *, CXTPChartElementView * > | m_arrChildren
The child view collection.
CXTPChartElementView * | m_pParentView
The parent view.
CXTPChartContainer * | m_pContainer
The parent container.
CRect | m_rcBounds
Bounding rectangle.

Detailed Description

This class represents the view of a bubble series point, which is a kind of CXTPChartPointSeriesPointView.

A bubble chart is a type of chart where each plotted entity is defined in terms of three distinct numeric parameters. Bubble charts can facilitate the understanding of the social, economical, medical, and other scientific relationships.

Constructor & Destructor Documentation

◆ CXTPChartBubbleSeriesPointView()

CXTPChartBubbleSeriesPointView | ( | CXTPChartSeriesPoint * | pPoint,
 |  | CXTPChartElementView * | pParentView )

Constructs a CXTPChartBubbleSeriesPointView object.

Parameters
pPoint | A pointer to the chart series point object.
pParentView | The parent view of the axis.

Member Function Documentation

◆ CreateDeviceCommand()

virtual CXTPChartDeviceCommand * CreateDeviceCommand ( CXTPChartDeviceContext * pDC )
virtual

This function creates a CXTPChartDeviceCommand object.

This object represents the rendering of a bubble series point.

Parameters
pDC Pointer to a CXTPChartDeviceContext object.
Returns
Returns a CXTPChartPolygonAntialiasingDeviceCommand object. This object handles the rendering of an element in the chart. Here it handles the drawing of the bubble series point.

Reimplemented from CXTPChartPointSeriesPointView.

◆ GetActualColor()

CXTPChartColor GetActualColor ( ) const

Call this function to get the actual color.

Returns
A CXTPChartColor object representing an ARGB value.

◆ GetActualColor2()

CXTPChartColor GetActualColor2 ( ) const

Call this function to get the second actual color.

Returns
A CXTPChartColor object representing an ARGB value.
The documentation for this class was generated from the following file:
  • XTPChartBubbleSeriesStyle.h


Toolkit Pro: CXTPChartBubbleSeriesStyle Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPChartBubbleSeriesStyle Class Reference

This class represents a bubble series style, which is a kind of CXTPChartPointSeriesStyle. More...

Inheritance diagram for CXTPChartBubbleSeriesStyle:
[legend]

Public Member Functions

CXTPChartBubbleSeriesStyle ()
Constructs a CXTPChartBubbleSeriesStyle object.
virtual | ~CXTPChartBubbleSeriesStyle ()
Destroys a CXTPChartBubbleSeriesStyle object, handles cleanup.
double | GetMinSize () const
Gets the miminum bubble size value.
void | SetMinSize (double dMinSize)
Sets the miminum bubble size value.
double | GetMaxSize () const
Gets the maximum bubble size value.
void | SetMaxSize (double dMinSize)
Sets the maximum bubble size value.
virtual int | GetSeriesPointValueIndex () const
Obtains the index of a point element for which an internal value can be otained.
virtual void | DoPropExchange (CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
- Public Member Functions inherited from CXTPChartPointSeriesStyle
CXTPChartPointSeriesStyle ()
Constructs a CXTPChartPointSeriesStyle object.
virtual | ~CXTPChartPointSeriesStyle ()
Destroys a CXTPChartPointSeriesStyle object, handles cleanup.
CXTPChartMarker * | GetMarker () const
Call this function to get the marker object associated with this CXTPChartPointSeriesStyle object.
void | DoPropExchange (CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
- Public Member Functions inherited from CXTPChartDiagram2DSeriesStyle
CXTPChartDiagram2DSeriesStyle ()
Constructs a CXTPChartDiagram2DSeriesStyle object.
virtual | ~CXTPChartDiagram2DSeriesStyle ()
Destroys a CXTPChartDiagram2DSeriesStyle object, handles cleanup.
virtual CXTPChartDiagram * | CreateDiagram ()
Call this function to create the diagram for this series.
virtual BOOL | IsStyleDiagram (CXTPChartDiagram *pDiagram) const
Call this function to check whether the chart diagram object passed is a kind of 2D diagram (CXTPChartDiagram2D object).
- Public Member Functions inherited from CXTPChartSeriesStyle
CXTPChartSeriesStyle ()
Constructs a CXTPChartSeriesStyle object.
virtual | ~CXTPChartSeriesStyle ()
Destroys a CXTPChartSeriesStyle object, handles cleanup.
virtual CXTPChartSeriesLabel * | GetLabel () const
Call this method to gets the series label object.
virtual CXTPChartSeriesLabel * | SetLabel (CXTPChartSeriesLabel *pLabel)
Call this method to sets the series label object.
virtual CXTPChartErrorBar * | GetErrorBar () const
Call this method to gets the error bar object.
virtual CXTPChartErrorBar * | SetErrorBar (CXTPChartErrorBar *pErrorBar)
Call this method to sets the error bar object.
virtual CXTPChartColor | GetColor () const
Call this method to get the color of the series.
virtual void | SetColor (CXTPChartColor clr)
Call this method to set the color of the series.
virtual void | SetColorEach (BOOL bColorEach)
Call this method to set individual color for each point of the series.
virtual BOOL | IsColorEach () const
This method is called to check if individual color is used for each point of the series.
virtual CXTPChart3dRotation | Get3dRotation () const
Obtains rotation parameters for 3D chart.
virtual void | Set3dRotation (const CXTPChart3dRotation &rotation)
Sets rotation parameters for 3D chart.
virtual void | Set3dRotation (double dYaw, double dPitch, double dRoll)
Sets rotation parameters for 3D chart.
virtual BOOL | Is3dEdgeSmoothingEnabled () const
Enables/disables 3D edge smoothing.
virtual void | Enable3dEdgeSmoothing (BOOL bEnable=TRUE)
Enables/disables 3D edge smoothing.
virtual int | GetTransparency () const
Call this function to gets the transparency of the chart if it is supported by the chart type.
virtual void | SetTransparency (int nTransparency)
Call this function to sets the transparency of the chart if it is supported by the chart type.
virtual CXTPChartSeriesStyleAppearance * | GetStyleAppearance () const
Obtains associated style appearance pointer.
virtual void | ApplyTo (CXTPChartDeviceCommand *pCommand)
Applies the style to the command provided in case the command needs style specific details for correct drawing.
- Public Member Functions inherited from CXTPChartElement
CXTPChartElement ()
Constructs a CXTPChartElement object.
virtual | ~CXTPChartElement ()
Destroys a CXTPChartElement object, handles cleanup.
virtual void | Release ()
Call this function to decrease the usage count of the object.
CXTPChartElement * | GetOwner () const
Call this function to get the owner element.
virtual void | OnChartChanged (XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic properties of the chart.
CXTPChartContent * | GetContent () const
Call this virtual function to get the chart content object.
CXTPChartAppearance * | GetAppearance () const
Call this function to get the the appearance of the chart.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Protected Member Functions

virtual CXTPChartSeriesView * | CreateView (CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Call this function to create a view of the bubble series.
void | CorrectAxisSideMargins (CXTPChartAxis *pAxis, double nMinValue, double nMaxValue, double &nCorrection)
Call this function to correct the axis side margins.
- Protected Member Functions inherited from CXTPChartPointSeriesStyle
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.

Additional Inherited Members

- Public Attributes inherited from CXTPChartElement
- Protected Attributes inherited from CXTPChartPointSeriesStyle
- Protected Attributes inherited from CXTPChartDiagram2DSeriesStyle
int | m_nAxisIndexX
Holds index of secondary axisX, used when m_bSecondaryAxisX is TRUE.
int | m_nAxisIndexY
Holds index of secondary axisY, used when m_bSecondaryAxisY is TRUE.
- Protected Attributes inherited from CXTPChartSeriesStyle
CXTPChartSeriesLabel * | m_pLabel
Label object.
CXTPChartErrorBar * | m_pErrorBar
Error bar object.
CXTPChartColor | m_clrColor
Custom color of series.
BOOL | m_bColorEach
TRUE to color each point.
int | m_nTransparency
The transparency value in the range 0..255.
CXTPChart3dRotation | m_Rotation3d
3D rotation
BOOL | m_bSmooth3dEdges
3D edge smoothing
- Protected Attributes inherited from CXTPChartElement

Detailed Description

This class represents a bubble series style, which is a kind of CXTPChartPointSeriesStyle.

A bubble chart is a type of chart where each plotted entity is defined in terms of three distinct numeric parameters. Bubble charts can facilitate the understanding of the social, economical, medical, and other scientific relationships.

Member Function Documentation

◆ CorrectAxisSideMargins()

void CorrectAxisSideMargins | ( | CXTPChartAxis * | pAxis,
 |  | double | nMinValue,
 |  | double | nMaxValue,
 |  | double & | nCorrection )
 protectedvirtual

Call this function to correct the axis side margins.

Parameters
pAxis | A pointer to the chart axis object to which this object is associated with.
nMinValue | A double specifying the minimum value.
nMaxValue | A double specifying the maximum value.
nCorrection | A reference to a double object which specifies the correction applied.

Reimplemented from CXTPChartSeriesStyle.

◆ CreateView()

virtual CXTPChartSeriesView * CreateView | ( | CXTPChartSeries * | pSeries,
 |  | CXTPChartDiagramView * | pDiagramView )
 protectedvirtual

Call this function to create a view of the bubble series.

Parameters
pSeries | A pointer to chart series object.
pDiagramView | A pointer to the diagram view object.
Returns
Returns a pointer to the associated series view object.

Reimplemented from CXTPChartPointSeriesStyle.

◆ DoPropExchange()

virtual void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Reads this object from or writes this object to an archive.

Parameters
pPX A CXTPPropExchange object to serialize to or from.

Reimplemented from CXTPChartSeriesStyle.

◆ GetMaxSize()

AFX_INLINE double GetMaxSize ( ) const

Gets the maximum bubble size value.

Returns
The current maximum bubble size value.

◆ GetMinSize()

AFX_INLINE double GetMinSize ( ) const

Gets the miminum bubble size value.

Returns
The current minimum bubble size value.

◆ GetSeriesPointValueIndex()

AFX_INLINE int GetSeriesPointValueIndex ( ) const
virtual

Obtains the index of a point element for which an internal value can be otained.

Returns
The index of a point element for which an internal value can be otained.

Reimplemented from CXTPChartSeriesStyle.

◆ SetMaxSize()

AFX_INLINE void SetMaxSize ( double dMinSize )

Sets the maximum bubble size value.

Parameters
dMinSize The maximum bubble size value.

◆ SetMinSize()

AFX_INLINE void SetMinSize ( double dMinSize )

Sets the miminum bubble size value.

Parameters
dMinSize The miminum bubble size value.
The documentation for this class was generated from the following file:
  • XTPChartBubbleSeriesStyle.h


Toolkit Pro: CXTPChartBubbleSeriesView Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPChartBubbleSeriesView Class Reference

This class represents the view of a bubble series, which is a kind of CXTPChartSeriesView. More...

Inheritance diagram for CXTPChartBubbleSeriesView:
[legend]

Public Member Functions

CXTPChartBubbleSeriesView (CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Constructs a CXTPChartBubbleSeriesView object.
- Public Member Functions inherited from CXTPChartPointSeriesView
CXTPChartPointSeriesView (CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Constructs a CXTPChartPointSeriesView object.
virtual CXTPChartDeviceCommand * CreateLegendDeviceCommand (CXTPChartDeviceContext *pDC, CRect rcBounds)
This function creates a label view drawing command object.

Protected Member Functions

CXTPChartSeriesPointView * | CreateSeriesPointView (CXTPChartDeviceContext *pDC, CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Call this function to create a view of the bubble series point.
virtual CXTPChartDeviceCommand * | CreateDeviceCommand (CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
void | CreatePointsView (CXTPChartDeviceContext *pDC)
Creates the view object.
- Protected Member Functions inherited from CXTPChartPointSeriesView
CXTPChartSeriesPointView * | CreateSeriesPointView (CXTPChartDeviceContext *pDC, CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Call this function to create a view of the series points.

Detailed Description

This class represents the view of a bubble series, which is a kind of CXTPChartSeriesView.

A bubble chart is a type of chart where each plotted entity is defined in terms of three distinct numeric parameters. Bubble charts can facilitate the understanding of the social, economical, medical, and other scientific relationships.

Constructor & Destructor Documentation

◆ CXTPChartBubbleSeriesView()

CXTPChartBubbleSeriesView | ( | CXTPChartSeries * | pSeries,
 |  | CXTPChartDiagramView * | pDiagramView )

Constructs a CXTPChartBubbleSeriesView object.

Parameters
pSeries | A pointer to the chart series object.
pDiagramView | A pointer to the diagram view object.

Member Function Documentation

◆ CreateDeviceCommand()

virtual CXTPChartDeviceCommand * CreateDeviceCommand ( CXTPChartDeviceContext * pDC )
protectedvirtual

This function creates a CXTPChartDeviceCommand object.

This object represents the rendering of a bubble series.

Parameters
pDC Pointer to a CXTPChartDeviceContext object.
Returns
Returns a CXTPChartDeviceCommand object. This object handles the rendering of an element in the chart. Here it handles the drawing of the bubble series.

Reimplemented from CXTPChartElementView.

◆ CreatePointsView()

void CreatePointsView ( CXTPChartDeviceContext * pDC )
protected

Creates the view object.

Parameters
pDC Target device context pointers.

◆ CreateSeriesPointView()

CXTPChartSeriesPointView * CreateSeriesPointView | ( | CXTPChartDeviceContext * | pDC,
 |  | CXTPChartSeriesPoint * | pPoint,
 |  | CXTPChartElementView * | pParentView )
 protected

Call this function to create a view of the bubble series point.

Parameters
pDC | A pointer to chart device context.
pPoint | A pointer to the chart series point object.
pParentView | Parent view pointer.
Returns
Returns a pointer to the associated series point view object.
The documentation for this class was generated from the following file:
  • XTPChartBubbleSeriesStyle.h


Toolkit Pro: CXTPChartCandleStickSeriesPointView Class Reference

Public Member Functions | List of all members
CXTPChartCandleStickSeriesPointView Class Reference

This class represents the view of a candle stick series point, which is a kind of CXTPChartSeriesPointView. More...

Inheritance diagram for CXTPChartCandleStickSeriesPointView:
[legend]

Public Member Functions

CXTPChartCandleStickSeriesPointView (CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Constructs a CXTPChartCandleStickSeriesPointView object.
virtual CXTPChartDeviceCommand * | CreateDeviceCommand (CXTPChartDeviceContext *pDC)
Call this function to create a CXTPChartDeviceCommand object.
CXTPChartPointF | GetScreenPoint (int nIndex)
Call this function to get the screen point from a series index.
- Public Member Functions inherited from CXTPChartSeriesPointView
CXTPChartSeriesPointView (CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Constructs the view object.
CXTPChartSeriesPointView (CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView, BOOL bAddToParent)
Constructs the view object.
CXTPChartSeriesPoint * | GetPoint () const
Obtains point model object.
CXTPChartSeriesView * | GetSeriesView () const
Obtains parent series view.
CXTPChartColor | GetColor () const
Obtain view color values.
CXTPChartColor | GetColor2 () const
Obtain view color values.
double | GetInternalValue () const
Obtains point interval value.
virtual CXTPChartString | GetLegendName () const
This function returns the legend name.
virtual CXTPChartDeviceCommand * | CreateLegendDeviceCommand (CXTPChartDeviceContext *pDC, CRect rcBounds)
This function creates a CXTPChartDeviceCommand object.
virtual void | UpdateMinMaxRange (double &nMinValue, double &nMaxValue) const
Provides a default empty implementation for min/max range update request.
- Public Member Functions inherited from CXTPChartElementView
CXTPChartElementView (CXTPChartElementView *pParentView)
Constructs a CXTPChartElementView object.
CXTPChartElementView (CXTPChartElementView *pParentView, BOOL bAddToParent)
Constructs a CXTPChartElementView object.
CXTPChartElementView (CXTPChartContainer *pContainer)
Constructs a CXTPChartElementView object.
int | GetCount () const
Call this function to get the number of child views associated with this view.
CXTPChartElementView * | GetAt (int nIndex) const
Call this function to get a child view at a particular index.
CXTPChartElementView * | GetParentView () const
Call this function to get the parent view.
CXTPChartElementView * | AddChildView (CXTPChartElementView *pChildView)
Call this function to add a child view to the current view.
CXTPChartElementView ** GetChildren ()
Provides access to the collection of children elements owned by the view.
CRect | GetBounds () const
Obtains viewed object's bound rectangle.
CRect | GetBounds (BOOL bIncludingChildren) const
Obtains viewed object's bound rectangle.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.
- Public Member Functions inherited from CXTPChartLegendItemView
virtual | ~CXTPChartLegendItemView ()
Handles object destruction.

Additional Inherited Members

- Public Attributes inherited from CXTPChartSeriesPointView
double | m_dInternalValue
Point internal value.
- Protected Member Functions inherited from CXTPChartElementView
virtual | ~CXTPChartElementView ()
Destroys a CXTPChartElementView object, handles cleanup.
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.
- Protected Attributes inherited from CXTPChartSeriesPointView
CXTPChartSeriesPoint * | m_pPoint
Point model object pointer.
- Protected Attributes inherited from CXTPChartElementView
CArray< CXTPChartElementView *, CXTPChartElementView * > | m_arrChildren
The child view collection.
CXTPChartElementView * | m_pParentView
The parent view.
CXTPChartContainer * | m_pContainer
The parent container.
CRect | m_rcBounds
Bounding rectangle.

Detailed Description

This class represents the view of a candle stick series point, which is a kind of CXTPChartSeriesPointView.

Constructor & Destructor Documentation

◆ CXTPChartCandleStickSeriesPointView()

CXTPChartCandleStickSeriesPointView | ( | CXTPChartSeriesPoint * | pPoint,
 |  | CXTPChartElementView * | pParentView )

Constructs a CXTPChartCandleStickSeriesPointView object.

Parameters
pPoint | A pointer to a chart series point object.
pParentView | Parent view pointer.

Member Function Documentation

◆ CreateDeviceCommand()

virtual CXTPChartDeviceCommand * CreateDeviceCommand ( CXTPChartDeviceContext * pDC )
virtual

Call this function to create a CXTPChartDeviceCommand object.

This object handles the rendering of the candlestick series point.

Parameters
pDC Pointer to a CXTPChartDeviceContext object.
Returns
Returns a CXTPChartDeviceCommand object. This object handles the rendering of an element in the chart. Here it handles the drawing of a candlestick series point.

Reimplemented from CXTPChartElementView.

◆ GetScreenPoint()

CXTPChartPointF GetScreenPoint ( int nIndex )

Call this function to get the screen point from a series index.

Parameters
nIndex An integer value denoting the index.
Returns
Returns a screen point object, CXTPChartPointF.
The documentation for this class was generated from the following file:
  • XTPChartCandleStickSeriesStyle.h


Toolkit Pro: CXTPChartCandleStickSeriesStyle Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPChartCandleStickSeriesStyle Class Reference

This class represents a candle stick series style, which is a kind of CXTPChartHighLowSeriesStyle. More...

Inheritance diagram for CXTPChartCandleStickSeriesStyle:
[legend]

Public Member Functions

CXTPChartCandleStickSeriesStyle ()
Constructs a CXTPChartCandleStickSeriesStyle object.
virtual | ~CXTPChartCandleStickSeriesStyle ()
Destroys a CXTPChartBubbleSeriesLabel object, handles cleanup.
- Public Member Functions inherited from CXTPChartHighLowSeriesStyle
CXTPChartHighLowSeriesStyle ()
Constructs a CXTPChartHighLowSeriesStyle object.
virtual | ~CXTPChartHighLowSeriesStyle ()
Destroys a CXTPChartHighLowSeriesStyle object, handles cleanup.
void | SetLineThickness (int nLineThickness)
Call this function to set the line thickness of stock ticks.
int | GetLineThickness () const
Call this function to get the line thickness of stock ticks.
CXTPChartColor | GetCustomUpColor () const
Call this function to get the user-defined up day color of stock ticks.
CXTPChartColor | GetCustomDownColor () const
Call this function to get the user-defined down day color of stock ticks.
CXTPChartColor | GetUpColor () const
Call this function to get the up day color of stock ticks.
CXTPChartColor | GetDownColor () const
Call this function to get the down day color of stock ticks.
- Public Member Functions inherited from CXTPChartDiagram2DSeriesStyle
CXTPChartDiagram2DSeriesStyle ()
Constructs a CXTPChartDiagram2DSeriesStyle object.
virtual | ~CXTPChartDiagram2DSeriesStyle ()
Destroys a CXTPChartDiagram2DSeriesStyle object, handles cleanup.
void | DoPropExchange (CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
virtual CXTPChartDiagram * | CreateDiagram ()
Call this function to create the diagram for this series.
virtual BOOL | IsStyleDiagram (CXTPChartDiagram *pDiagram) const
Call this function to check whether the chart diagram object passed is a kind of 2D diagram (CXTPChartDiagram2D object).
- Public Member Functions inherited from CXTPChartSeriesStyle
CXTPChartSeriesStyle ()
Constructs a CXTPChartSeriesStyle object.
virtual | ~CXTPChartSeriesStyle ()
Destroys a CXTPChartSeriesStyle object, handles cleanup.
virtual CXTPChartSeriesLabel * | GetLabel () const
Call this method to gets the series label object.
virtual CXTPChartSeriesLabel * | SetLabel (CXTPChartSeriesLabel *pLabel)
Call this method to sets the series label object.
virtual CXTPChartErrorBar * | GetErrorBar () const
Call this method to gets the error bar object.
virtual CXTPChartErrorBar * | SetErrorBar (CXTPChartErrorBar *pErrorBar)
Call this method to sets the error bar object.
virtual CXTPChartColor | GetColor () const
Call this method to get the color of the series.
virtual void | SetColor (CXTPChartColor clr)
Call this method to set the color of the series.
virtual void | SetColorEach (BOOL bColorEach)
Call this method to set individual color for each point of the series.
virtual BOOL | IsColorEach () const
This method is called to check if individual color is used for each point of the series.
virtual CXTPChart3dRotation | Get3dRotation () const
Obtains rotation parameters for 3D chart.
virtual void | Set3dRotation (const CXTPChart3dRotation &rotation)
Sets rotation parameters for 3D chart.
virtual void | Set3dRotation (double dYaw, double dPitch, double dRoll)
Sets rotation parameters for 3D chart.
virtual BOOL | Is3dEdgeSmoothingEnabled () const
Enables/disables 3D edge smoothing.
virtual void | Enable3dEdgeSmoothing (BOOL bEnable=TRUE)
Enables/disables 3D edge smoothing.
virtual int | GetTransparency () const
Call this function to gets the transparency of the chart if it is supported by the chart type.
virtual void | SetTransparency (int nTransparency)
Call this function to sets the transparency of the chart if it is supported by the chart type.
virtual void | CorrectAxisSideMargins (CXTPChartAxis *pAxis, double nMinValue, double nMaxValue, double &nCorrection)
Provides default implementation for axis side margins correction.
virtual CXTPChartSeriesStyleAppearance * | GetStyleAppearance () const
Obtains associated style appearance pointer.
virtual void | ApplyTo (CXTPChartDeviceCommand *pCommand)
Applies the style to the command provided in case the command needs style specific details for correct drawing.
virtual int | GetSeriesPointValueIndex () const
Obtains the index of a point element for which an internal value can be otained.
- Public Member Functions inherited from CXTPChartElement
CXTPChartElement ()
Constructs a CXTPChartElement object.
virtual | ~CXTPChartElement ()
Destroys a CXTPChartElement object, handles cleanup.
virtual void | Release ()
Call this function to decrease the usage count of the object.
CXTPChartElement * | GetOwner () const
Call this function to get the owner element.
virtual void | OnChartChanged (XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic properties of the chart.
CXTPChartContent * | GetContent () const
Call this virtual function to get the chart content object.
CXTPChartAppearance * | GetAppearance () const
Call this function to get the the appearance of the chart.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Protected Member Functions

virtual CXTPChartSeriesView * CreateView (CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Call this function to create the view of the candlestick series.
- Protected Member Functions inherited from CXTPChartHighLowSeriesStyle
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.

Additional Inherited Members

- Public Attributes inherited from CXTPChartElement
- Protected Attributes inherited from CXTPChartHighLowSeriesStyle
int | m_nLineThickness
The stock tick line thickness.
CXTPChartColor | m_clrDownColor
User-defined down day color.
CXTPChartColor | m_clrUpColor
User-defined up day color.
- Protected Attributes inherited from CXTPChartDiagram2DSeriesStyle
int | m_nAxisIndexX
Holds index of secondary axisX, used when m_bSecondaryAxisX is TRUE.
int | m_nAxisIndexY
Holds index of secondary axisY, used when m_bSecondaryAxisY is TRUE.
- Protected Attributes inherited from CXTPChartSeriesStyle
CXTPChartSeriesLabel * | m_pLabel
Label object.
CXTPChartErrorBar * | m_pErrorBar
Error bar object.
CXTPChartColor | m_clrColor
Custom color of series.
BOOL | m_bColorEach
TRUE to color each point.
int | m_nTransparency
The transparency value in the range 0..255.
CXTPChart3dRotation | m_Rotation3d
3D rotation
BOOL | m_bSmooth3dEdges
3D edge smoothing
- Protected Attributes inherited from CXTPChartElement

Detailed Description

This class represents a candle stick series style, which is a kind of CXTPChartHighLowSeriesStyle.

A candlestick chart is a style of bar-chart used primarily to describe price movements of a security (finance), derivative, or currency over time. It is a combination of a line-chart and a bar-chart, in that each bar represents the range of price movement over a given time interval. It is most often used in technical analysis of equity and currency price patterns.

Member Function Documentation

◆ CreateView()

virtual CXTPChartSeriesView * CreateView | ( | CXTPChartSeries * | pSeries,
 |  | CXTPChartDiagramView * | pDiagramView )
 protectedvirtual

Call this function to create the view of the candlestick series.

Parameters
pSeries | A pointer to the chart series object.
pDiagramView | Pointer to a chart diagram view object.
Returns
The newly created CXTPChartCandleStickSeriesView pointer, which is a kind of CXTPChartSeriesView*.

Reimplemented from CXTPChartHighLowSeriesStyle.

The documentation for this class was generated from the following file:
  • XTPChartCandleStickSeriesStyle.h


Toolkit Pro: CXTPChartCandleStickSeriesView Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPChartCandleStickSeriesView Class Reference

This class represents the view of a candle stick series, which is a kind of CXTPChartSeriesView. More...

Public Member Functions

CXTPChartCandleStickSeriesView (CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Constructs a CXTPChartCandleStickSeriesView object.

Protected Member Functions

CXTPChartSeriesPointView * | CreateSeriesPointView (CXTPChartDeviceContext *pDC, CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Call this function to create a new candlestick series point view object.
virtual CXTPChartDeviceCommand * | CreateLegendDeviceCommand (CXTPChartDeviceContext *pDC, CRect rcBounds)
This function creates a label view drawing command object.

Detailed Description

This class represents the view of a candle stick series, which is a kind of CXTPChartSeriesView.

A candlestick chart is a style of bar-chart used primarily to describe price movements of a security (finance), derivative, or currency over time. It is a combination of a line-chart and a bar-chart, in that each bar represents the range of price movement over a given time interval. It is most often used in technical analysis of equity and currency price patterns.

Constructor & Destructor Documentation

◆ CXTPChartCandleStickSeriesView()

CXTPChartCandleStickSeriesView | ( | CXTPChartSeries * | pSeries,
 |  | CXTPChartDiagramView * | pDiagramView )

Constructs a CXTPChartCandleStickSeriesView object.

Parameters
pSeries | The chart series object pointer to which this object is associated with.
pDiagramView | The pointer to the diagram view.

Member Function Documentation

◆ CreateLegendDeviceCommand()

virtual CXTPChartDeviceCommand * CreateLegendDeviceCommand | ( | CXTPChartDeviceContext * | pDC,
 |  | CRect | rcBounds )
 protectedvirtual

This function creates a label view drawing command object.

Parameters
pDC | Pointer to a CXTPChartDeviceContext object.
rcBounds | The rectangular boundary of the legend.
Returns
Returns a new label view drawing command object.

Implements CXTPChartLegendItemView.

◆ CreateSeriesPointView()

CXTPChartSeriesPointView * CreateSeriesPointView | ( | CXTPChartDeviceContext * | pDC,
 |  | CXTPChartSeriesPoint * | pPoint,
 |  | CXTPChartElementView * | pParentView )
 protected

Call this function to create a new candlestick series point view object.

Parameters
pDC | Pointer to a CXTPChartDeviceContext object.
pPoint | The pointer to the chart series point object.
pParentView | The pointer to the parent view object.
Returns
A pointer to CXTPChartCandleStickSeriesPointView, which is a kind of CXTPChartSeriesPointView.
The documentation for this class was generated from the following file:
  • XTPChartCandleStickSeriesStyle.h


Toolkit Pro: CXTPChartCircleDeviceCommand Class Reference

Protected Member Functions | Protected Attributes | List of all members
CXTPChartCircleDeviceCommand Class Reference

This class is the base class for all circle device commands. More...

Inheritance diagram for CXTPChartCircleDeviceCommand:
[legend]

Protected Member Functions

CXTPChartCircleDeviceCommand (const CXTPChartPointF &center, double radius)
Constructs a CXTPChartCircleDeviceCommand object.
CXTPChartElement * HitTest (CPoint point, CXTPChartElement *pParent) const
Performs recursive hit testing of the element at the specified point.
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.
- Protected Member Functions inherited from CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents >
CXTPObservable ()
Constructs an observable object.
~CXTPObservable ()
Handles observable object destruction.

Protected Attributes

CXTPChartPointF | m_center
The center of the circle.
double | m_radius
The radius of the circle.
- Protected Attributes inherited from CXTPChartDeviceCommand
CArray< CXTPChartDeviceCommand *, CXTPChartDeviceCommand * > | m_arrChildren
< The array of child device commands.

Additional Inherited Members

- Public Member Functions inherited from CXTPChartDeviceCommand
CXTPChartDeviceCommand ()
Constructs a CXTPChartDeviceCommand object.
virtual | ~CXTPChartDeviceCommand ()
Destroys a CXTPChartDeviceCommand object, handles cleanup.
BOOL | IsCommitted () const
Determines if the execution of the command has been committed.
void | Commit ()
Commits the execution of the command.
int | GetChildCommandCount () const
Obtains the number of immediate children commands.
CXTPChartDeviceCommand * | GetChildCommand (int nIndex) const
Obtains immediate child command point by index.
CXTPChartDeviceCommand * | AddChildCommand (CXTPChartDeviceCommand *pCommand)
Call this function to add a child device command.
virtual void | Execute (CXTPChartDeviceContext *pDC)
Call this function to execute the drawing.
virtual void | BeforeExecute (CXTPChartDeviceContext *pDC)
This method gets called before a command is executed which allows for the customization of command behavior.
virtual void | AfterExecute (CXTPChartDeviceContext *pDC)
This method gets called after a command is executed which allows for the customization of command behavior.
virtual void | ExecuteOverride (CXTPChartDeviceContext *pDC)
Override this function to write the drawing code for specific objects.
UINT | GetPassNumber () const
Get the number of executions made by the command.
virtual void | ApplySeriesStyle (CXTPChartSeriesStyle *pStyle)
Applies series style to the current element.
virtual void | Prepare (CXTPChartDeviceContext *pDC)
Performs inital preparation steps necessary for successful command execution.
virtual void | PrepareOverride (CXTPChartDeviceContext *pDC)
Derived implementation must override this method for implementing implementation specific preparation behavior.
virtual BOOL | IsEnabled () const
Determines if the command is currently enabled.
void | SetEnabled (BOOL bEnabled=TRUE)
Enables/disable the command.
CXTPChartDeviceContext * | GetCurrentDC () const
Obtains device context pointer for which the command is currenly being prepared or executed.
void | BindView (CXTPChartElementView *pView)
Binds a view to the command object.
CXTPChartElementView * | GetBoundView () const
Obtains a bound view pointer or NULL if no view is bound.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.
- Public Member Functions inherited from CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents >
void | Subscribe (CXTPChartDeviceCommandEvents *pObserver, CXTPSubscriptionList< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > *pSubcriptionList=NULL)
Subscribes a unique observer for events.
void | Unsubscribe (CXTPChartDeviceCommandEvents *pObserver)
Unsubscribes an observer from events.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *))
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *))
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.

Detailed Description

This class is the base class for all circle device commands.

Constructor & Destructor Documentation

◆ CXTPChartCircleDeviceCommand()

CXTPChartCircleDeviceCommand | ( | const CXTPChartPointF & | center,
 |  | double | radius )
 protected

Constructs a CXTPChartCircleDeviceCommand object.

Parameters
center | Circle center coordinates.
radius | Circle radius value.

Member Function Documentation

◆ HitTest()

CXTPChartElement * HitTest | ( | CPoint | point,
 |  | CXTPChartElement * | pParent ) const
 protectedvirtual

Performs recursive hit testing of the element at the specified point.

Parameters
point | Point in which an element is to be found.
pParent | Parent element pointer.
Returns
A pointer to the element found at the specified point or NULL if no element is found.

Reimplemented from CXTPChartDeviceCommand.

The documentation for this class was generated from the following file:
  • XTPChartCircleDeviceCommand.h


Toolkit Pro: CXTPChartClipDeviceCommand Class Reference

Protected Member Functions | Protected Attributes | List of all members
CXTPChartClipDeviceCommand Class Reference

Base class implementation for 2D chart clipping device command. More...

Inheritance diagram for CXTPChartClipDeviceCommand:
[legend]

Protected Member Functions

CXTPChartClipDeviceCommand (CRect rcClip)
Constructs a CXTPChartClipDeviceCommand object.
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.
- Protected Member Functions inherited from CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents >
CXTPObservable ()
Constructs an observable object.
~CXTPObservable ()
Handles observable object destruction.

Protected Attributes

CRect | m_rcClip
The clipping rectangle.
- Protected Attributes inherited from CXTPChartDeviceCommand
CArray< CXTPChartDeviceCommand *, CXTPChartDeviceCommand * > | m_arrChildren
< The array of child device commands.

Additional Inherited Members

- Public Member Functions inherited from CXTPChartDeviceCommand
CXTPChartDeviceCommand ()
Constructs a CXTPChartDeviceCommand object.
virtual | ~CXTPChartDeviceCommand ()
Destroys a CXTPChartDeviceCommand object, handles cleanup.
BOOL | IsCommitted () const
Determines if the execution of the command has been committed.
void | Commit ()
Commits the execution of the command.
int | GetChildCommandCount () const
Obtains the number of immediate children commands.
CXTPChartDeviceCommand * | GetChildCommand (int nIndex) const
Obtains immediate child command point by index.
CXTPChartDeviceCommand * | AddChildCommand (CXTPChartDeviceCommand *pCommand)
Call this function to add a child device command.
virtual void | Execute (CXTPChartDeviceContext *pDC)
Call this function to execute the drawing.
virtual void | BeforeExecute (CXTPChartDeviceContext *pDC)
This method gets called before a command is executed which allows for the customization of command behavior.
virtual void | AfterExecute (CXTPChartDeviceContext *pDC)
This method gets called after a command is executed which allows for the customization of command behavior.
virtual void | ExecuteOverride (CXTPChartDeviceContext *pDC)
Override this function to write the drawing code for specific objects.
UINT | GetPassNumber () const
Get the number of executions made by the command.
virtual CXTPChartElement * | HitTest (CPoint point, CXTPChartElement *pParent) const
Performs recursive hit testing of the element at the specified point.
virtual void | ApplySeriesStyle (CXTPChartSeriesStyle *pStyle)
Applies series style to the current element.
virtual void | Prepare (CXTPChartDeviceContext *pDC)
Performs inital preparation steps necessary for successful command execution.
virtual void | PrepareOverride (CXTPChartDeviceContext *pDC)
Derived implementation must override this method for implementing implementation specific preparation behavior.
virtual BOOL | IsEnabled () const
Determines if the command is currently enabled.
void | SetEnabled (BOOL bEnabled=TRUE)
Enables/disable the command.
CXTPChartDeviceContext * | GetCurrentDC () const
Obtains device context pointer for which the command is currenly being prepared or executed.
void | BindView (CXTPChartElementView *pView)
Binds a view to the command object.
CXTPChartElementView * | GetBoundView () const
Obtains a bound view pointer or NULL if no view is bound.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.
- Public Member Functions inherited from CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents >
void | Subscribe (CXTPChartDeviceCommandEvents *pObserver, CXTPSubscriptionList< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > *pSubcriptionList=NULL)
Subscribes a unique observer for events.
void | Unsubscribe (CXTPChartDeviceCommandEvents *pObserver)
Unsubscribes an observer from events.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *))
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *))
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.

Detailed Description

Base class implementation for 2D chart clipping device command.

Constructor & Destructor Documentation

◆ CXTPChartClipDeviceCommand()

CXTPChartClipDeviceCommand ( CRect rcClip )
protected

Constructs a CXTPChartClipDeviceCommand object.

Parameters
rcClip Clip rectangle.
The documentation for this class was generated from the following file:
  • XTPChartTransformationDeviceCommand.h


Toolkit Pro: CXTPChartColor Class Reference

Public Types | Public Member Functions | Static Public Member Functions | Protected Attributes | List of all members
CXTPChartColor Class Reference

This class abstracts a color entity. More...

Public Types

enum | { AlphaShift = 24 , RedShift = 16 , GreenShift = 8 , BlueShift = 0 }
Enumeration for shift count of A, R, G, B components. More...
enum | { AlphaMask = 0xff000000 , RedMask = 0x00ff0000 , GreenMask = 0x0000ff00 , BlueMask = 0x000000ff }
Enumeration for bit mask of A, R, G, B components. More...

Public Member Functions

CXTPChartColor ()
Default constructor, creates a CXTPChartColor object and initializes the values.
CXTPChartColor (BYTE r, BYTE g, BYTE b)
Overloaded constructor, creates an opaque color object from the specified Red, Green, Blue values.
CXTPChartColor (BYTE a, BYTE r, BYTE g, BYTE b)
Overloaded constructor, creates a color object from the specified Red, Green, Blue values.
CXTPChartColor (ARGB argb)
Overloaded constructor, creates a color object from the specified premultiplied ARGB values.
BYTE | GetAlpha () const
Call this function to get the alpha channel value of the color.
BYTE | GetA () const
Call this function to get the alpha channel value of the color.
BYTE | GetRed () const
Call this function to get the RED channel value of the color.
BYTE | GetR () const
Call this function to get the RED channel value of the color.
BYTE | GetGreen () const
Call this function to get the GREEN channel value of the color.
BYTE | GetG () const
Call this function to get the GREEN channel value of the color.
BYTE | GetBlue () const
Call this function to get the BLUE channel value of the color.
BYTE | GetB () const
Call this function to get the BLUE channel value of the color.
float | ClampA () const
Clamps alpha color component to range 0..1.
float | ClampR () const
Clamps red color component to range 0..1.
float | ClampG () const
Clamps green color component to range 0..1.
float | ClampB () const
Clamps blue color component to range 0..1.
ARGB | GetValue () const
Call this function to get the ARGB value of the color object.
VOID | SetValue (ARGB argb)
Call this function to set the ARGB value of the color object.
VOID | SetFromCOLORREF (COLORREF rgb)
Call this function to set the opaque color value from a COLORREF value.
void | SetFromString (LPCTSTR lpsz)
Call this function to set the color value from a string value.
COLORREF | ToCOLORREF () const
Call this function to convert the object to a COLORREF value.
BOOL | IsEmpty () const
Call this function to check whether the color object is empty.
CXTPChartColor | GetDarkColor () const
Obtains a "darker" color for the current color.

Static Public Member Functions

static ARGB AFX_CDECL MakeARGB (BYTE a, BYTE r, BYTE g, BYTE b)
Call this static function to assemble A, R, G, B values into a 32-bit integer ARGB value.

Protected Attributes

ARGB Argb
The 32 bit color value.

Detailed Description

This class abstracts a color entity.

This object consists of an ARGB value which represents a color.

Member Enumeration Documentation

◆ anonymous enum

anonymous enum

Enumeration for shift count of A, R, G, B components.

Enumerator
AlphaShift | Alpha component bit offset.
RedShift | Red component bit offset.
GreenShift | Green component bit offset.
BlueShift | Blue component bit offset.

◆ anonymous enum

anonymous enum

Enumeration for bit mask of A, R, G, B components.

Enumerator
AlphaMask | Alpha component bit mask.
RedMask | Red component bit mask.
GreenMask | Green component bit mask.
BlueMask | Blue component bit mask.

Constructor & Destructor Documentation

◆ CXTPChartColor() [1/3]

CXTPChartColor | ( | BYTE | r,
 |  | BYTE | g,
 |  | BYTE | b )
 inline

Overloaded constructor, creates an opaque color object from the specified Red, Green, Blue values.

Parameters
r | Red value.
g | Green value.
b | Blue value.

The alpha channel value is set to 255. Hence the color is 100% opaque. Color values are not premultiplied.

◆ CXTPChartColor() [2/3]

CXTPChartColor | ( | BYTE | a,
 |  | BYTE | r,
 |  | BYTE | g,
 |  | BYTE | b )
 inline

Overloaded constructor, creates a color object from the specified Red, Green, Blue values.

Parameters
r | Red value.
g | Green value.
b | Blue value.
a | Aplha value.

Color values are not premultiplied.

◆ CXTPChartColor() [3/3]

CXTPChartColor ( ARGB argb )
inline

Overloaded constructor, creates a color object from the specified premultiplied ARGB values.

Parameters
argb The ARGB value.

Member Function Documentation

◆ ClampA()

float ClampA ( ) const
inline

Clamps alpha color component to range 0..1.

Returns
Alpha component value clamped to range 0..1.

◆ ClampB()

float ClampB ( ) const
inline

Clamps blue color component to range 0..1.

Returns
Blue component value clamped to range 0..1.

◆ ClampG()

float ClampG ( ) const
inline

Clamps green color component to range 0..1.

Returns
Green component value clamped to range 0..1.

◆ ClampR()

float ClampR ( ) const
inline

Clamps red color component to range 0..1.

Returns
Red component value clamped to range 0..1.

◆ GetA()

BYTE GetA ( ) const
inline

Call this function to get the alpha channel value of the color.

Returns
A BYTE value specifying the alpha value. The range is from 0 to 255.

◆ GetAlpha()

BYTE GetAlpha ( ) const
inline

Call this function to get the alpha channel value of the color.

Returns
A BYTE value specifying the alpha value. The range is from 0 to 255.

◆ GetB()

BYTE GetB ( ) const
inline

Call this function to get the BLUE channel value of the color.

Returns
A BYTE value specifying the BLUE value. The range is from 0 to 255.

◆ GetBlue()

BYTE GetBlue ( ) const
inline

Call this function to get the BLUE channel value of the color.

Returns
A BYTE value specifying the BLUE value. The range is from 0 to 255.

◆ GetDarkColor()

CXTPChartColor GetDarkColor ( ) const

Obtains a "darker" color for the current color.

Returns
A "darker" color value.

◆ GetG()

BYTE GetG ( ) const
inline

Call this function to get the GREEN channel value of the color.

Returns
A BYTE value specifying the GREEN value. The range is from 0 to 255.

◆ GetGreen()

BYTE GetGreen ( ) const
inline

Call this function to get the GREEN channel value of the color.

Returns
A BYTE value specifying the GREEN value. The range is from 0 to 255.

◆ GetR()

BYTE GetR ( ) const
inline

Call this function to get the RED channel value of the color.

Returns
A BYTE value specifying the RED value. The range is from 0 to 255.

◆ GetRed()

BYTE GetRed ( ) const
inline

Call this function to get the RED channel value of the color.

Returns
A BYTE value specifying the RED value. The range is from 0 to 255.

◆ GetValue()

ARGB GetValue ( ) const
inline

Call this function to get the ARGB value of the color object.

Returns
An ARGB value specifying the color.

◆ IsEmpty()

BOOL IsEmpty ( ) const
inline

Call this function to check whether the color object is empty.

Returns
A BOOL value. TRUE if the object is empty, FALSE otherwise.

◆ MakeARGB()

static ARGB AFX_CDECL MakeARGB | ( | BYTE | a,
 |  | BYTE | r,
 |  | BYTE | g,
 |  | BYTE | b )
 inlinestatic

Call this static function to assemble A, R, G, B values into a 32-bit integer ARGB value.

Parameters
a | The Alpha value.
r | The Red value
g | The Green value
b | The Blue value
Returns
A 32 bit ARGB value.

◆ SetFromCOLORREF()

VOID SetFromCOLORREF ( COLORREF rgb )
inline

Call this function to set the opaque color value from a COLORREF value.

Parameters
rgb A RGB value specifying the color.

The alpha channel value is set to 255. Hence the color is 100% opaque.

Returns
void

◆ SetFromString()

void SetFromString ( LPCTSTR lpsz )

Call this function to set the color value from a string value.

Parameters
lpsz The string contains the color values in a specified format.

The format should be "100,100,100,100" for ARGB values or "100,100,100" for opaque color values

◆ SetValue()

VOID SetValue ( ARGB argb )
inline

Call this function to set the ARGB value of the color object.

Parameters
argb An ARGB value specifying the color.
Returns
void

◆ ToCOLORREF()

COLORREF ToCOLORREF ( ) const
inline

Call this function to convert the object to a COLORREF value.

Returns
An ARGB value specifying the color.
The documentation for this class was generated from the following file:
  • XTPChartTypes.h


Toolkit Pro: CXTPChartContainer Class Reference

Public Member Functions | List of all members
CXTPChartContainer Class Referenceabstract

This class represents the chart container. More...

Inheritance diagram for CXTPChartContainer:
[legend]

Public Member Functions

CXTPChartContainer ()
Constructs a CXTPChartContainer object.
virtual | ~CXTPChartContainer ()
Destroys a CXTPChartContainer object, handles cleanup.
virtual CWnd * | GetControl ()=0
Obtains Chart control's window object.
virtual void | OnChartChanged (XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this function to trigger a re-painting when there is a change in the intrinsic properties of the chart.
virtual void | SetCapture (CXTPChartElementView *pView)
This method is called to set capture to view.
void | BeginFrequentUpdates ()
Enters a mode in which a container is expected to be frequently updated.
BOOL | IsBeingFrequentlyUpdated () const
Determines if the container is currently being frequently updated.
void | EndFrequentUpdates (XTPChartUpdateOptions updateOptions=xtpChartUpdateRedraw)
Leave the frequent update mode and performs the final update.

Detailed Description

This class represents the chart container.

This class acts as a container for the chart content.

Member Function Documentation

◆ BeginFrequentUpdates()

void BeginFrequentUpdates ( )

Enters a mode in which a container is expected to be frequently updated.

See also
EndFrequentUpdates, IsBeingFrequentlyUpdated

◆ EndFrequentUpdates()

void EndFrequentUpdates ( XTPChartUpdateOptions updateOptions = xtpChartUpdateRedraw )

Leave the frequent update mode and performs the final update.

Parameters
updateOptions The final update type.
See also
BeginFrequentUpdates, IsBeingFrequentlyUpdated

◆ GetControl()

virtual CWnd * GetControl ( )
pure virtual

Obtains Chart control's window object.

Returns
Chart control's window object pointer.

Implemented in CXTPChartControl.

◆ IsBeingFrequentlyUpdated()

AFX_INLINE BOOL IsBeingFrequentlyUpdated ( ) const

Determines if the container is currently being frequently updated.

Returns
TRUE if the container is currently being frequently updated, FALSE otherwise.
See also
BeginFrequentUpdates, EndFrequentUpdates

◆ OnChartChanged()

virtual void OnChartChanged ( XTPChartUpdateOptions updateOptions = xtpChartUpdateView )
virtual

Call this function to trigger a re-painting when there is a change in the intrinsic properties of the chart.

Parameters
updateOptions Options which indicate the kind of change performed.

Reimplemented in CXTPChartControl.

◆ SetCapture()

virtual void SetCapture ( CXTPChartElementView * pView )
virtual

This method is called to set capture to view.

Parameters
pView View that will receive all mouse messages.

Reimplemented in CXTPChartControl.

The documentation for this class was generated from the following file:
  • XTPChartElement.h


Toolkit Pro: CXTPChartContent Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPChartContent Class Reference

This class represents chart content, which is a kind of CXTPChartElement. More...

Inheritance diagram for CXTPChartContent:
[legend]

Public Member Functions

CXTPChartContent ()
Constructs a CXTPChartContent object.
virtual | ~CXTPChartContent ()
Destroys a CXTPChartContent object, handles cleanup.
CXTPChartTitleCollection * | GetTitles () const
Call this function to get the title collection object.
CXTPChartSeriesCollection * | GetSeries () const
Call this function to get the series collection object.
CXTPChartLegend * | GetLegend () const
Call this function to get the chart legend object.
CXTPChartDiagram * | GetPrimaryDiagram () const
Call this function to get the primary diagram of the chart.
CXTPChartPanelCollection * | GetPanels () const
Call this function to get the panels of the chart.
CXTPChartAppearance * | GetAppearance () const
Call this function to get the appearance of the chart.
CXTPChartBorder * | GetBorder () const
Call this function to get the border of the chart.
void | DrawContent (CXTPChartDeviceContext *pDC, CRect rcBounds)
Call this function to draw the chart content.
CXTPChartDeviceCommand * | CreateDeviceComand (CXTPChartDeviceContext *pDC, CRect rcBounds)
Call this function to create the device command tree.
CXTPChartDeviceContext * | CreateDeviceContext (CXTPChartContainer *pContainer, HDC hDC, CRect rcBounds, BOOL bWindowDC)
Call this function to create the device context for the drawing.
CXTPChartColor | GetBackgroundColor () const
Call this function to get the background color of the chart content.
void | SetBackgroundColor (const CXTPChartColor &clr)
Call this function to set the background color of the chart content.
CXTPChartColor | GetActualBackgroundColor () const
Call this function to get the appearance background color of the chart content.
CXTPChartColor | GetActualBorderColor () const
Call this function to get the appearance border color.
virtual void | OnChartChanged (XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this function whenever a change occurs in the chart content.
virtual void | DoPropExchange (CXTPPropExchange *pPX)
Call this member function to Store/Load the properties of content using the specified data object.
int | GetPanelDistance () const
Call this function to get the distance between 2 panels.
void | SetPanelDistance (int nDistance)
Call this function to set the distance between 2 panels.
XTPChartPanelDirection | GetPanelDirection () const
Call this function to get the layout direction of panels either top-to-bottom or left-to-right.
void | SetPanelDirection (XTPChartPanelDirection nDirection)
Call this function to set the layout direction of panels either top-to-bottom or left-to-right.
void | EnableMarkup (BOOL bEnable=TRUE)
Call this method to enable markup for tab captions.
CXTPMarkupContext * | GetMarkupContext () const
Retrieves a pointer to the markup context.
- Public Member Functions inherited from CXTPChartElement
CXTPChartElement ()
Constructs a CXTPChartElement object.
virtual | ~CXTPChartElement ()
Destroys a CXTPChartElement object, handles cleanup.
virtual void | Release ()
Call this function to decrease the usage count of the object.
CXTPChartElement * | GetOwner () const
Call this function to get the owner element.
CXTPChartContent * | GetContent () const
Call this virtual function to get the chart content object.
CXTPChartAppearance * | GetAppearance () const
Call this function to get the the appearance of the chart.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Protected Member Functions

virtual CXTPChartContentView * | CreateView (CXTPChartDeviceContext *pDC, CRect rcBounds)
Call this function to calculate the view of the chart content.
void | UpdateDiagram ()
Call this function to update the color of the points from the palette.
virtual void | OnSeriesStyleChanged (CXTPChartSeries *pSeries)
Call this function to update the chart content whenever there is a change in the series style.
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.

Protected Attributes

CXTPChartPanelCollection * | m_pPanels
The panel collection.
CXTPChartTitleCollection * | m_pTitles
The title collection.
CXTPChartSeriesCollection * | m_pSeries
The series collection.
CXTPChartLegend * | m_pLegend
The legend object.
CXTPChartAppearance * | m_pAppearance
The chart appearance object.
CXTPChartBorder * | m_pBorder
The chart border.
CXTPChartColor | m_clrBackground
The chart background color.
CXTPMarkupContext * | m_pMarkupContext
Markup context.
int | m_nPanelDistance
Panel distance.
XTPChartPanelDirection | m_nPanelDirection
Panel direction.
- Protected Attributes inherited from CXTPChartElement

Detailed Description

This class represents chart content, which is a kind of CXTPChartElement.

This class has a panel collection, a series collection, a title collection and a legend.

Member Function Documentation

◆ CreateDeviceComand()

CXTPChartDeviceCommand * CreateDeviceComand | ( | CXTPChartDeviceContext * | pDC,
 |  | CRect | rcBounds )

Call this function to create the device command tree.

Parameters
pDC | Pointer to a valid device context.
rcBounds | The rectangle of the device context.
Returns
A pointer to a CXTPChartDeviceCommand object root of Command tree.

◆ CreateDeviceContext()

CXTPChartDeviceContext * CreateDeviceContext | ( | CXTPChartContainer * | pContainer,
 |  | HDC | hDC,
 |  | CRect | rcBounds,
 |  | BOOL | bWindowDC )

Call this function to create the device context for the drawing.

Parameters
hDC | The GDI device context HANDLE.
rcBounds | The rectangle of the device context.
bWindowDC | TRUE to use Window device context.
pContainer | Pointer to a chart container object.
Returns
A pointer to a CXTPChartDeviceContext object.

◆ CreateView()

virtual CXTPChartContentView * CreateView | ( | CXTPChartDeviceContext * | pDC,
 |  | CRect | rcBounds )
 protectedvirtual

Call this function to calculate the view of the chart content.

Parameters
pDC | Pointer to the chart device context object.
rcBounds | The bounding rectangle.
Returns
A newly created content view object pointer.

◆ DoPropExchange()

virtual void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Call this member function to Store/Load the properties of content using the specified data object.

Parameters
pPX Source or destination CXTPPropExchange data object reference.

This member function is used to store property data to or load property data from storage.

Reimplemented from CXTPChartElement.

◆ DrawContent()

void DrawContent | ( | CXTPChartDeviceContext * | pDC,
 |  | CRect | rcBounds )

Call this function to draw the chart content.

Parameters
pDC | A pointer to the chart device context object.
rcBounds | The bound of the chart content.

◆ EnableMarkup()

void EnableMarkup ( BOOL bEnable = TRUE )

Call this method to enable markup for tab captions.

Parameters
bEnable TRUE to enable markup.

◆ GetActualBackgroundColor()

CXTPChartColor GetActualBackgroundColor ( ) const

Call this function to get the appearance background color of the chart content.

Returns
A CXTPChartColor object which describes an ARGB value.

Call SetBackgroundColor to set a custom background color. If a custom background color is not set, then a color from current appearance will be used.

◆ GetActualBorderColor()

CXTPChartColor GetActualBorderColor ( ) const

Call this function to get the appearance border color.

Returns
A CXTPChartColor object which describes an ARGB value.

◆ GetAppearance()

AFX_INLINE CXTPChartAppearance * GetAppearance ( ) const

Call this function to get the appearance of the chart.

Returns
A pointer to a CXTPChartAppearance object.

◆ GetBackgroundColor()

CXTPChartColor GetBackgroundColor ( ) const

Call this function to get the background color of the chart content.

Returns
A CXTPChartColor object which describes an ARGB value.

◆ GetBorder()

AFX_INLINE CXTPChartBorder * GetBorder ( ) const

Call this function to get the border of the chart.

Returns
A pointer to a CXTPChartBorder object.

◆ GetLegend()

AFX_INLINE CXTPChartLegend * GetLegend ( ) const

Call this function to get the chart legend object.

Returns
A pointer to a CXTPChartLegend object.

◆ GetMarkupContext()

AFX_INLINE CXTPMarkupContext * GetMarkupContext ( ) const

Retrieves a pointer to the markup context.

Returns
A pointer to a CXTPMarkupContext object.

◆ GetPanelDirection()

AFX_INLINE XTPChartPanelDirection GetPanelDirection ( ) const

Call this function to get the layout direction of panels either top-to-bottom or left-to-right.

Returns
XTPChartPanelDirection value indicating the layout direction of panels (xtpChartPanelVertical/xtpChartPanelHorizontal)

◆ GetPanelDistance()

AFX_INLINE int GetPanelDistance ( ) const

Call this function to get the distance between 2 panels.

Returns
Distance between 2 panels.

10 pixels is used by default.

◆ GetPanels()

AFX_INLINE CXTPChartPanelCollection * GetPanels ( ) const

Call this function to get the panels of the chart.

Returns
A pointer to a CXTPChartPanelCollection object.

◆ GetPrimaryDiagram()

CXTPChartDiagram * GetPrimaryDiagram ( ) const

Call this function to get the primary diagram of the chart.

It is the diagram of the first panel.

Returns
A pointer to a CXTPChartDiagram object.

◆ GetSeries()

AFX_INLINE CXTPChartSeriesCollection * GetSeries ( ) const

Call this function to get the series collection object.

Returns
A pointer to a CXTPChartSeriesCollection object.

◆ GetTitles()

AFX_INLINE CXTPChartTitleCollection * GetTitles ( ) const

Call this function to get the title collection object.

Returns
A pointer to a CXTPChartTitleCollection object.

◆ OnChartChanged()

virtual void OnChartChanged ( XTPChartUpdateOptions updateOptions = xtpChartUpdateView )
virtual

Call this function whenever a change occurs in the chart content.

This call causes a redraw.

Parameters
updateOptions Options which indicate the kind of change performed.

Reimplemented from CXTPChartElement.

◆ OnSeriesStyleChanged()

virtual void OnSeriesStyleChanged ( CXTPChartSeries * pSeries )
protectedvirtual

Call this function to update the chart content whenever there is a change in the series style.

Parameters
pSeries A pointer to a chart series object.

◆ SetBackgroundColor()

AFX_INLINE void SetBackgroundColor ( const CXTPChartColor & clr )

Call this function to set the background color of the chart content.

Parameters
clr Color of the background.

◆ SetPanelDirection()

AFX_INLINE void SetPanelDirection ( XTPChartPanelDirection nDirection )

Call this function to set the layout direction of panels either top-to-bottom or left-to-right.

Parameters
nDirection XTPChartPanelDirection value indicating the layout direction of panels (xtpChartPanelVertical/xtpChartPanelHorizontal)

◆ SetPanelDistance()

AFX_INLINE void SetPanelDistance ( int nDistance )

Call this function to set the distance between 2 panels.

Parameters
nDistance New distance to be set.
The documentation for this class was generated from the following file:
  • XTPChartContent.h


Toolkit Pro: CXTPChartContentAppearance Class Reference

Public Member Functions | Public Attributes | Protected Attributes | List of all members
CXTPChartContentAppearance Class Reference

This class represents the appearance of a chart content. More...

Inheritance diagram for CXTPChartContentAppearance:
[legend]

Public Member Functions

CXTPChartContentAppearance (CXTPChartElement *pOwner)
Constructs a CXTPChartContentAppearance object.
virtual | ~CXTPChartContentAppearance ()
Destroys a CXTPChartContentAppearance object, handles cleanup.
void | DoPropExchange (CXTPPropExchange *pPX)
Call this member function to Store/Load the properties related to the appearance of a chart content using the specified data object.
CXTPChartTitleAppearance * | GetTitleAppearance () const
Call this function to get the title appearance object pointer.
CXTPChartLegendAppearance * | GetLegendAppearance () const
Call this function to get the legend appearance object pointer.
- Public Member Functions inherited from CXTPChartElementAppearance
CXTPChartElementAppearance (CXTPChartElement *pOwner)
Constructs a CXTPChartElementAppearance object.
virtual | ~CXTPChartElementAppearance ()
Destroys a CXTPChartElementAppearance object, handles cleanup.
virtual void | ApplyToDeviceContext (CXTPChartDeviceContext *pDC)
Applies implementation specific appearance settings to the device context provided.
- Public Member Functions inherited from CXTPChartElement
CXTPChartElement ()
Constructs a CXTPChartElement object.
virtual | ~CXTPChartElement ()
Destroys a CXTPChartElement object, handles cleanup.
virtual void | Release ()
Call this function to decrease the usage count of the object.
CXTPChartElement * | GetOwner () const
Call this function to get the owner element.
virtual void | OnChartChanged (XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic properties of the chart.
CXTPChartContent * | GetContent () const
Call this virtual function to get the chart content object.
CXTPChartAppearance * | GetAppearance () const
Call this function to get the the appearance of the chart.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Public Attributes

CXTPChartColor | BackgroundColor
The background color of the chart.
CXTPChartColor | BorderColor
The border color of the chart.
- Public Attributes inherited from CXTPChartElement

Protected Attributes

CXTPChartTitleAppearance * | m_pTitleAppearance
Pointer to the chart title appearance object.
CXTPChartLegendAppearance * | m_pLegendAppearance
Pointer to the legend appearance object.
- Protected Attributes inherited from CXTPChartElement

Additional Inherited Members

- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.

Detailed Description

This class represents the appearance of a chart content.

This class is is subclassed from CXTPChartElementAppearance class.

Constructor & Destructor Documentation

◆ CXTPChartContentAppearance()

CXTPChartContentAppearance ( CXTPChartElement * pOwner )

Constructs a CXTPChartContentAppearance object.

Parameters
pOwner Pointer to an owner element.

Member Function Documentation

◆ DoPropExchange()

void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Call this member function to Store/Load the properties related to the appearance of a chart content using the specified data object.

Parameters
pPX Source or destination CXTPPropExchange data object reference.

This member function is used to store or load property data to or from a storage.

Reimplemented from CXTPChartElement.

◆ GetLegendAppearance()

AFX_INLINE CXTPChartLegendAppearance * GetLegendAppearance ( ) const

Call this function to get the legend appearance object pointer.

Returns
Returns the pointer to CXTPChartLegendAppearance object.

◆ GetTitleAppearance()

AFX_INLINE CXTPChartTitleAppearance * GetTitleAppearance ( ) const

Call this function to get the title appearance object pointer.

Returns
Returns the pointer to CXTPChartTitleAppearance object.
The documentation for this class was generated from the following file:
  • XTPChartAppearance.h


Toolkit Pro: CXTPChartContentView Class Reference

Public Member Functions | Public Attributes | Protected Attributes | List of all members
CXTPChartContentView Class Reference

This class represents the view of the chart content, which is a kind of CXTPChartElementView. More...

Inheritance diagram for CXTPChartContentView:
[legend]

Public Member Functions

CXTPChartContentView (CXTPChartContainer *pContainer, CXTPChartContent *pContent)
Constructs a CXTPChartContentView object.
void | CreateView (CXTPChartDeviceContext *pDC)
Call this function to create various child view objects which constitute the view of the chart content.
void | CalculateView (CXTPChartDeviceContext *pDC, CRect rcBounds)
Call this function to calculate the view/layout of the chart content with respect to a bounding rectangle.
CXTPChartLegendView * | GetLegendView () const
Call this function to get the legend view object associated with this object.
CXTPChartDiagramView * | HitTestDiagramView (CPoint pt) const
Call this function to determine the current DiagramView under point.
virtual CXTPChartDeviceCommand * | CreateDeviceCommand (CXTPChartDeviceContext *pDC)
Call this function to create the device command for this object.
- Public Member Functions inherited from CXTPChartElementView
CXTPChartElementView (CXTPChartElementView *pParentView)
Constructs a CXTPChartElementView object.
CXTPChartElementView (CXTPChartElementView *pParentView, BOOL bAddToParent)
Constructs a CXTPChartElementView object.
CXTPChartElementView (CXTPChartContainer *pContainer)
Constructs a CXTPChartElementView object.
int | GetCount () const
Call this function to get the number of child views associated with this view.
CXTPChartElementView * | GetAt (int nIndex) const
Call this function to get a child view at a particular index.
CXTPChartElementView * | GetParentView () const
Call this function to get the parent view.
CXTPChartElementView * | AddChildView (CXTPChartElementView *pChildView)
Call this function to add a child view to the current view.
CXTPChartElementView ** GetChildren ()
Provides access to the collection of children elements owned by the view.
CRect | GetBounds () const
Obtains viewed object's bound rectangle.
CRect | GetBounds (BOOL bIncludingChildren) const
Obtains viewed object's bound rectangle.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Public Attributes

CXTPChartLegendView * | m_pLegendView
The legend view.
CXTPChartElementView * | m_pTitlesView
The titles view.
CXTPChartElementView * | m_pDiagramView
The diagram view.

Protected Attributes

CRect | m_rcBounds
The bounds.
CXTPChartContent * | m_pContent
The chart content.
- Protected Attributes inherited from CXTPChartElementView
CArray< CXTPChartElementView *, CXTPChartElementView * > | m_arrChildren
The child view collection.
CXTPChartElementView * | m_pParentView
The parent view.
CXTPChartContainer * | m_pContainer
The parent container.
CRect | m_rcBounds
Bounding rectangle.

Additional Inherited Members

- Protected Member Functions inherited from CXTPChartElementView
virtual ~CXTPChartElementView ()
Destroys a CXTPChartElementView object, handles cleanup.
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.

Detailed Description

This class represents the view of the chart content, which is a kind of CXTPChartElementView.

Constructor & Destructor Documentation

◆ CXTPChartContentView()

CXTPChartContentView | ( | CXTPChartContainer * | pContainer,
 |  | CXTPChartContent * | pContent )

Constructs a CXTPChartContentView object.

Parameters
pContainer | Pointer to a chart container object.
pContent | Pointer to a chart content object.

Member Function Documentation

◆ CalculateView()

void CalculateView | ( | CXTPChartDeviceContext * | pDC,
 |  | CRect | rcBounds )

Call this function to calculate the view/layout of the chart content with respect to a bounding rectangle.

Parameters
pDC | Pointer to a chart device context.
rcBounds | The bounding rectangle.

◆ CreateDeviceCommand()

virtual CXTPChartDeviceCommand * CreateDeviceCommand ( CXTPChartDeviceContext * pDC )
virtual

Call this function to create the device command for this object.

Parameters
pDC The device context.
Returns
A pointer to a chart device context object.

Reimplemented from CXTPChartElementView.

◆ CreateView()

void CreateView ( CXTPChartDeviceContext * pDC )

Call this function to create various child view objects which constitute the view of the chart content.

Parameters
pDC Pointer to a chart device context.

◆ GetLegendView()

CXTPChartLegendView * GetLegendView ( ) const

Call this function to get the legend view object associated with this object.

Returns
Pointer to a chart legend view object.

◆ HitTestDiagramView()

CXTPChartDiagramView * HitTestDiagramView ( CPoint pt ) const

Call this function to determine the current DiagramView under point.

Parameters
pt Position to hit test.
Returns
Pointer to a CXTPChartDiagramView view object.
The documentation for this class was generated from the following file:
  • XTPChartContentView.h


Toolkit Pro: CXTPChartControl Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPChartControl Class Reference

CXTPChartControl is a CWnd derived class. More...

Inheritance diagram for CXTPChartControl:
[legend]

Public Member Functions

CXTPChartControl ()
Constructs a CXTPChartControl object.
virtual | ~CXTPChartControl ()
Destroys a CXTPChartControl object, handles cleanup.
CXTPChartContent * | GetContent () const
Call this function to get the pointer to the chart content object.
virtual CWnd * | GetControl ()
Obtains Chart control's window object.
void | OnChartChanged (XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this function whenever a change occurs in the chart content.
BOOL | RegisterWindowClass (HINSTANCE hInstance=NULL)
Registers the window class if it has not already been registered.
CXTPChartElement * | HitTest (CPoint point) const
Call this method to hit test the element under the cursor.
BOOL | PrintToDC (HDC hDC, CRect rcBounds)
Call this method to draw chart to a device context.
BOOL | CopyToClipboard (CSize szSize)
Call this method to copy chart image to clipboard.
BOOL | SaveAsImage (LPCTSTR lpszFilePath, CSize szBounds)
Call this method to save chart to a file as an image.
void | SetContent (CXTPChartContent *pContent)
Call this method to set the content of the chart control.
void | SetUpdateWindow (BOOL bUpdateWindow)
Call this method to enable/disable automatic chart updates when a change is detected.
CXTPToolTipContext * | GetToolTipContext () const
Call this method to get a pointer to the tooltip context.
void | EnableToolTips (BOOL bEnable)
Call this method to enable chart tooltips.
void | SetCapture (CXTPChartElementView *pView)
Call this method to set capture to view.
- Public Member Functions inherited from CXTPChartContainer
CXTPChartContainer ()
Constructs a CXTPChartContainer object.
virtual | ~CXTPChartContainer ()
Destroys a CXTPChartContainer object, handles cleanup.
void | BeginFrequentUpdates ()
Enters a mode in which a container is expected to be frequently updated.
BOOL | IsBeingFrequentlyUpdated () const
Determines if the container is currently being frequently updated.
void | EndFrequentUpdates (XTPChartUpdateOptions updateOptions=xtpChartUpdateRedraw)
Leave the frequent update mode and performs the final update.

Protected Attributes

CXTPChartContent * | m_pContent
Chart Content.
CBitmap | m_bmpCache
Bitmap Cache.
CXTPChartDrawThreadDeviceCommand * | m_pCommand
Root of Chart Command tree.
CXTPChartContentView * | m_pContentView
Current Content View.
DWORD | m_dwUpdateOptions
Update options.
CXTPToolTipContext * | m_pToolTipContext
Tooltip Context.
CXTPChartDrawThread * | m_pDrawThread
Helper draw thread that render 3D Charts.
CXTPChartElementView * | m_pCaptureView
Captured View.
BOOL | m_bUpdateWindow
UpdateWindow flag.

Detailed Description

CXTPChartControl is a CWnd derived class.

It represents the main window that contains the chart content and draws the chart.

Member Function Documentation

◆ CopyToClipboard()

BOOL CopyToClipboard ( CSize szSize )

Call this method to copy chart image to clipboard.

Parameters
szSize Chart image size to put to clipboard.
Returns
TRUE if successful, FALSE otherwise.

◆ EnableToolTips()

void EnableToolTips ( BOOL bEnable )

Call this method to enable chart tooltips.

Parameters
bEnable TRUE to enable chart tooltips.

◆ GetContent()

AFX_INLINE CXTPChartContent * GetContent ( ) const

Call this function to get the pointer to the chart content object.

Returns
A pointer to a CXTPChartContent object.

◆ GetControl()

virtual CWnd * GetControl ( )
virtual

Obtains Chart control's window object.

Returns
Chart control's window object pointer.

Implements CXTPChartContainer.

◆ GetToolTipContext()

AFX_INLINE CXTPToolTipContext * GetToolTipContext ( ) const

Call this method to get a pointer to the tooltip context.

Returns
A pointer to the tooltip context.

◆ HitTest()

CXTPChartElement * HitTest ( CPoint point ) const

Call this method to hit test the element under the cursor.

Parameters
point Position to hit test.
Returns
Pointer to a CXTPChartElement element under position.

◆ OnChartChanged()

void OnChartChanged ( XTPChartUpdateOptions updateOptions = xtpChartUpdateView )
virtual

Call this function whenever a change occurs in the chart content.

This call causes a redraw.

Parameters
updateOptions Options which indicate the kind of change performed.

Reimplemented from CXTPChartContainer.

◆ PrintToDC()

BOOL PrintToDC | ( | HDC | hDC,
 |  | CRect | rcBounds )

Call this method to draw chart to a device context.

Parameters
hDC | Device context to draw to.
rcBounds | Bounding position for chart.
Returns
TRUE if successful, FALSE otherwise.

◆ RegisterWindowClass()

BOOL RegisterWindowClass ( HINSTANCE hInstance = NULL )

Registers the window class if it has not already been registered.

Parameters
hInstance Instance of the resource where the control is located.
Returns
TRUE if the window class was successfully registered, FALSE otherwise.

◆ SaveAsImage()

BOOL SaveAsImage | ( | LPCTSTR | lpszFilePath,
 |  | CSize | szBounds )

Call this method to save chart to a file as an image.

Parameters
lpszFilePath | File path to save.
szBounds | Bounding size for chart.
Returns
TRUE if successful, FALSE otherwise.

◆ SetCapture()

void SetCapture ( CXTPChartElementView * pView )
virtual

Call this method to set capture to view.

Parameters
pView View that will receive all mouse messages.

Reimplemented from CXTPChartContainer.

◆ SetContent()

void SetContent ( CXTPChartContent * pContent )

Call this method to set the content of the chart control.

Parameters
pContent Pointer to new content.

◆ SetUpdateWindow()

AFX_INLINE void SetUpdateWindow ( BOOL bUpdateWindow )

Call this method to enable/disable automatic chart updates when a change is detected.

Parameters
bUpdateWindow TRUE to call UpdateWindow after each change.

Automatic chart updates are disabled by default requiring manual updates after chart changes are made. Frequent changes made with automatic chart updates enabled can result in decreased performance.

The documentation for this class was generated from the following file:
  • XTPChartControl.h


Toolkit Pro: CXTPChartDateTimeScaleTypeMap Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPChartDateTimeScaleTypeMap Class Reference

This class is a kind of CXTPChartScaleTypeMap, which abstracts a date-time scale type for an axis. More...

Inheritance diagram for CXTPChartDateTimeScaleTypeMap:
[legend]

Public Member Functions

virtual CXTPChartString | InternalToValue (CXTPChartNumberFormat *pFromat, double dValue) const
Use this function to convert a double value to a string.
virtual double | ValueToInternal (const CXTPChartString &strValue) const
Use this function to convert a value string to to an internal type.
- Public Member Functions inherited from CXTPChartScaleTypeMap
CXTPChartScaleTypeMap (CXTPChartAxis *pAxis)
Constructs a CXTPChartScaleTypeMap object.
virtual | ~CXTPChartScaleTypeMap ()
Destroys a CXTPChartScaleTypeMap object, handles cleanup.
CXTPChartAxis * | GetAxis () const
Call this function to get the axis object to which this object is associated with.
virtual void | UpdateSeries (CXTPChartAxisView *pAxisView)
Call this function when there is a change in the values of the series or a change in the scale.
virtual void | UpdateSeries (CXTPChartSeries *pSeries)
Call this function when there is a change in the values of the series or a change in the scale.
- Public Member Functions inherited from CXTPChartElement
CXTPChartElement ()
Constructs a CXTPChartElement object.
virtual | ~CXTPChartElement ()
Destroys a CXTPChartElement object, handles cleanup.
virtual void | Release ()
Call this function to decrease the usage count of the object.
CXTPChartElement * | GetOwner () const
Call this function to get the owner element.
virtual void | OnChartChanged (XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic properties of the chart.
CXTPChartContent * | GetContent () const
Call this virtual function to get the chart content object.
CXTPChartAppearance * | GetAppearance () const
Call this function to get the the appearance of the chart.
virtual void | DoPropExchange (CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Protected Member Functions

void UpdateSeriesPointArgument (CXTPChartSeriesPoint *pPoint)
Call this function to update a point argument in a series point.
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPChartScaleTypeMap
static CXTPChartScaleTypeMap *AFX_CDECL Create (CXTPChartAxis *pAxis)
Call this function to create a scale type map object.
- Public Attributes inherited from CXTPChartElement
- Protected Attributes inherited from CXTPChartElement

Detailed Description

This class is a kind of CXTPChartScaleTypeMap, which abstracts a date-time scale type for an axis.

Member Function Documentation

◆ InternalToValue()

virtual CXTPChartString InternalToValue | ( | CXTPChartNumberFormat * | pFromat,
 |  | double | dValue ) const
 virtual

Use this function to convert a double value to a string.

This actually converts the internal representation of data to a more meaningful value.

Parameters
pFromat | Conversion format to use.
dValue | Value to format.
Returns
A CXTPChartString object representing the string value.

Implements CXTPChartScaleTypeMap.

◆ UpdateSeriesPointArgument()

void UpdateSeriesPointArgument ( CXTPChartSeriesPoint * pPoint )
protectedvirtual

Call this function to update a point argument in a series point.

Parameters
pPoint A pointer to the chart series point object.

Reimplemented from CXTPChartScaleTypeMap.

◆ ValueToInternal()

virtual double ValueToInternal ( const CXTPChartString & strValue ) const
virtual

Use this function to convert a value string to to an internal type.

Parameters
strValue Value to be set.
Returns
A double representing the internal value.

Implements CXTPChartScaleTypeMap.

The documentation for this class was generated from the following file:
  • XTPChartScaleTypeMap.h


Toolkit Pro: CXTPChartDeviceCommand Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPChartDeviceCommand Class Reference

Defines a common implementation interface for chart drawing commands. More...

Inheritance diagram for CXTPChartDeviceCommand:
[legend]

Public Member Functions

CXTPChartDeviceCommand ()
Constructs a CXTPChartDeviceCommand object.
virtual | ~CXTPChartDeviceCommand ()
Destroys a CXTPChartDeviceCommand object, handles cleanup.
BOOL | IsCommitted () const
Determines if the execution of the command has been committed.
void | Commit ()
Commits the execution of the command.
int | GetChildCommandCount () const
Obtains the number of immediate children commands.
CXTPChartDeviceCommand * | GetChildCommand (int nIndex) const
Obtains immediate child command point by index.
CXTPChartDeviceCommand * | AddChildCommand (CXTPChartDeviceCommand *pCommand)
Call this function to add a child device command.
virtual void | Execute (CXTPChartDeviceContext *pDC)
Call this function to execute the drawing.
virtual void | BeforeExecute (CXTPChartDeviceContext *pDC)
This method gets called before a command is executed which allows for the customization of command behavior.
virtual void | AfterExecute (CXTPChartDeviceContext *pDC)
This method gets called after a command is executed which allows for the customization of command behavior.
virtual void | ExecuteOverride (CXTPChartDeviceContext *pDC)
Override this function to write the drawing code for specific objects.
UINT | GetPassNumber () const
Get the number of executions made by the command.
virtual CXTPChartElement * | HitTest (CPoint point, CXTPChartElement *pParent) const
Performs recursive hit testing of the element at the specified point.
virtual void | ApplySeriesStyle (CXTPChartSeriesStyle *pStyle)
Applies series style to the current element.
virtual void | Prepare (CXTPChartDeviceContext *pDC)
Performs inital preparation steps necessary for successful command execution.
virtual void | PrepareOverride (CXTPChartDeviceContext *pDC)
Derived implementation must override this method for implementing implementation specific preparation behavior.
virtual BOOL | IsEnabled () const
Determines if the command is currently enabled.
void | SetEnabled (BOOL bEnabled=TRUE)
Enables/disable the command.
CXTPChartDeviceContext * | GetCurrentDC () const
Obtains device context pointer for which the command is currenly being prepared or executed.
void | BindView (CXTPChartElementView *pView)
Binds a view to the command object.
CXTPChartElementView * | GetBoundView () const
Obtains a bound view pointer or NULL if no view is bound.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.
- Public Member Functions inherited from CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents >
void | Subscribe (CXTPChartDeviceCommandEvents *pObserver, CXTPSubscriptionList< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > *pSubcriptionList=NULL)
Subscribes a unique observer for events.
void | Unsubscribe (CXTPChartDeviceCommandEvents *pObserver)
Unsubscribes an observer from events.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *))
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *))
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.

Protected Attributes

CArray< CXTPChartDeviceCommand *, CXTPChartDeviceCommand * > m_arrChildren
< The array of child device commands.

Additional Inherited Members

- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.
- Protected Member Functions inherited from CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents >
CXTPObservable ()
Constructs an observable object.
~CXTPObservable ()
Handles observable object destruction.

Detailed Description

Defines a common implementation interface for chart drawing commands.

Member Function Documentation

◆ AddChildCommand()

CXTPChartDeviceCommand * AddChildCommand ( CXTPChartDeviceCommand * pCommand )

Call this function to add a child device command.

Parameters
pCommand A pointer to the child device command.

A device command object keeps an array of child device commands. An instruction to execute the drawing of the parent object triggers the drawing of children as well.

Returns
A newly added command object pointer.

◆ AfterExecute()

virtual void AfterExecute ( CXTPChartDeviceContext * pDC )
virtual

This method gets called after a command is executed which allows for the customization of command behavior.

Parameters
pDC A pointer to the chart device context.

Reimplemented in CXTPChart3dLineDeviceCommand, and CXTPChartPolygonAntialiasingDeviceCommand.

◆ ApplySeriesStyle()

virtual void ApplySeriesStyle ( CXTPChartSeriesStyle * pStyle )
virtual

Applies series style to the current element.

Parameters
pStyle Series style to apply.

◆ BeforeExecute()

virtual void BeforeExecute ( CXTPChartDeviceContext * pDC )
virtual

This method gets called before a command is executed which allows for the customization of command behavior.

Parameters
pDC A pointer to the chart device context.

Reimplemented in CXTPChartPolygonAntialiasingDeviceCommand.

◆ BindView()

void BindView ( CXTPChartElementView * pView )

Binds a view to the command object.

The view reference is held until another view is bound.

Parameters
pView A view pointer. If another view is bound its reference is released. NULL unbinds the current view.

◆ Commit()

AFX_INLINE void Commit ( )

Commits the execution of the command.

A command cannot be modified after being committed.

See also
IsCommitted

◆ Execute()

virtual void Execute ( CXTPChartDeviceContext * pDC )
virtual

Call this function to execute the drawing.

Parameters
pDC A pointer to the chart device context.

An instruction to execute the drawing of the parent object triggers the drawing of children as well.

◆ ExecuteOverride()

virtual void ExecuteOverride ( CXTPChartDeviceContext * pDC )
virtual

Override this function to write the drawing code for specific objects.

Parameters
pDC A pointer to the chart device context.

Reimplemented in CXTPChart3dFunnelSeriesLabelDeviceCommand, CXTPChart3dFunnelSeriesLabelsViewDeviceCommand, CXTPChart3dPieSeriesLabelsViewDeviceCommand, CXTPChart3dPyramidSeriesLabelDeviceCommand, CXTPChart3dPyramidSeriesLabelsViewDeviceCommand, and CXTPChartTextDeviceCommand.

◆ GetBoundView()

AFX_INLINE CXTPChartElementView * GetBoundView ( ) const

Obtains a bound view pointer or NULL if no view is bound.

Returns
A bound view pointer or NULL if no view is bound.

◆ GetChildCommand()

CXTPChartDeviceCommand * GetChildCommand ( int nIndex ) const

Obtains immediate child command point by index.

Parameters
nIndex Child command index. Must not exceed value returned by GetChildCommandCount call.
Returns
Child command pointer or NULL if no child command is defined at the specified location.
See also
GetChildCommandCount

◆ GetChildCommandCount()

int GetChildCommandCount ( ) const

Obtains the number of immediate children commands.

Returns
The number of immediate children commands.
See also
GetChildCommand

◆ GetCurrentDC()

AFX_INLINE CXTPChartDeviceContext * GetCurrentDC ( ) const

Obtains device context pointer for which the command is currenly being prepared or executed.

Returns
Device context pointer for which the command is currently being prepared or executed or NULL if no preparation or execution is in progress.

◆ GetPassNumber()

AFX_INLINE UINT GetPassNumber ( ) const

Get the number of executions made by the command.

Returns
The number of executions made by the command.

◆ HitTest()

virtual CXTPChartElement * HitTest | ( | CPoint | point,
 |  | CXTPChartElement * | pParent ) const
 virtual

Performs recursive hit testing of the element at the specified point.

Parameters
point | Point in which an element is to be found.
pParent | Parent element pointer.
Returns
A pointer to the element found at the specified point or NULL if no element is found.

Reimplemented in CXTPChart3dLineDeviceCommand, CXTPChart3dRotateDeviceCommand, CXTPChartBoundedTextDeviceCommand, CXTPChartCircleDeviceCommand, CXTPChartHitTestElementCommand, CXTPChartLineDeviceCommand, CXTPChartMarkupElementDeviceCommand, CXTPChartRectangleDeviceCommand, and CXTPChartRotateDeviceCommand.

◆ IsCommitted()

AFX_INLINE BOOL IsCommitted ( ) const

Determines if the execution of the command has been committed.

Returns
TRUE if the execution of the command has been committed, FALSE otherwise.
See also
Commit

◆ IsEnabled()

virtual BOOL IsEnabled ( ) const
virtual

Determines if the command is currently enabled.

Returns
TRUE if the command is currently enabled, FALSE otherwise.
See also
SetEnabled

Reimplemented in CXTPChart3dDeviceCommand.

◆ Prepare()

virtual void Prepare ( CXTPChartDeviceContext * pDC )
virtual

Performs inital preparation steps necessary for successful command execution.

Parameters
pDC Device context pointer for which the command is to be prepared.
See also
PrepareOverride

◆ PrepareOverride()

virtual void PrepareOverride ( CXTPChartDeviceContext * pDC )
virtual

Derived implementation must override this method for implementing implementation specific preparation behavior.

Parameters
pDC Device context pointer for which the command is to be prepared.
See also
Prepare

◆ SetEnabled()

AFX_INLINE void SetEnabled ( BOOL bEnabled = TRUE )

Enables/disable the command.

Parameters
bEnabled TRUE to enable the command, FALSE to disable the command.
The documentation for this class was generated from the following file:
  • XTPChartDeviceCommand.h


Toolkit Pro: CXTPChartDeviceCommandEvents Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPChartDeviceCommandEvents Class Reference

Defines a callback interface for a chart device command event sink. More...

Inheritance diagram for CXTPChartDeviceCommandEvents:
[legend]

Public Member Functions

virtual void | OnBeforeExecute (CXTPChartDeviceCommand *pCommand, CXTPChartDeviceContext *pDC)
Notifies that a command has entered the BeforeExecute step.
virtual void | OnAfterExecute (CXTPChartDeviceCommand *pCommand, CXTPChartDeviceContext *pDC)
Notifies that a command has entered the AfterExecute step.
virtual void | OnUpdateBounds (CXTPChartDeviceCommand *pCommand, CRect rcBounds)
Notifies about updated boundaries for the command result.
void | OnUnsubscribe (CXTPChartDeviceCommand *pCommand)
Invoked when an event sink is to be unsubscribed from command events.

Protected Member Functions

CXTPChartDeviceCommandEvents ()
Constructs an event sink.

Detailed Description

Defines a callback interface for a chart device command event sink.

See also
CXTPChartDeviceCommand

Member Function Documentation

◆ OnAfterExecute()

virtual void OnAfterExecute | ( | CXTPChartDeviceCommand * | pCommand,
 |  | CXTPChartDeviceContext * | pDC )
 virtual

Notifies that a command has entered the AfterExecute step.

Parameters
pCommand | Sender command pointer.
pDC | Device context pointer for which a command has been executed.

◆ OnBeforeExecute()

virtual void OnBeforeExecute | ( | CXTPChartDeviceCommand * | pCommand,
 |  | CXTPChartDeviceContext * | pDC )
 virtual

Notifies that a command has entered the BeforeExecute step.

Parameters
pCommand | Sender command pointer.
pDC | Device context pointer for which a command is being executed.

◆ OnUnsubscribe()

void OnUnsubscribe ( CXTPChartDeviceCommand * pCommand )

Invoked when an event sink is to be unsubscribed from command events.

Parameters
pCommand Sender command pointer.

◆ OnUpdateBounds()

virtual void OnUpdateBounds | ( | CXTPChartDeviceCommand * | pCommand,
 |  | CRect | rcBounds )
 virtual

Notifies about updated boundaries for the command result.

Parameters
pCommand | Sender command pointer.
rcBounds | Updated boundary rectangle.

Reimplemented in CXTPChart3dFunnelSeriesPointView, CXTPChart3dPieSeriesPointView, and CXTPChart3dPyramidSeriesPointView.

The documentation for this class was generated from the following file:
  • XTPChartDeviceCommand.h


Toolkit Pro: CXTPChartDeviceContext Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPChartDeviceContext Class Referenceabstract

This class abstracts a device context. More...

Inheritance diagram for CXTPChartDeviceContext:
[legend]

Public Member Functions

virtual | ~CXTPChartDeviceContext ()=0
Destroys a CXTPChartDeviceContext object, handles cleanup.
virtual BOOL | Initialize ()
Initializes devices context.
virtual void | Execute (CXTPChartDeviceCommand *pCommand)
Call this function to trigger the drawing.
BOOL | Is3D () const
Determines if the derived device context is a 3D device context.
HDC | GetHDC () const
Call this function to get the windows device context.
CXTPChartContainer * | GetContainer () const
Provides access to the parent container object.
CXTPChartDrawingObjectFactory * | GetDrawingObjectFactory () const
Provides access to the drawing object factory used by the device context implementation.
virtual CXTPChartSizeF | MeasureString (const CXTPChartString *pText, CXTPChartFont *pFont)=0
Call this function to get the measurements of texts rendered in a device context using a specific font.
virtual CXTPChartSizeF | MeasureMarkupElement (CXTPMarkupUIElement *pMarkupUIElement, CXTPChartFont *pFont)=0
Measures the markup element size provided with the font set as the default font for the associated markup context.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

CXTPChartDeviceContext (CXTPChartContainer *pContainer, HDC hDC, BOOL bIs3D, CXTPChartDrawingObjectFactory *pDrawingObjectFactory)
Constructs a CXTPChartDeviceContext object.

Protected Attributes

const BOOL | m_bIs3D
TRUE identifies device context used for 3D rendering.
HDC | m_hDC
The windows device context.
CXTPChartContainer * | m_pContainer
Parent container pointer.
CXTPChartDrawingObjectFactory * | m_pDrawingObjectFactory
Drawing object factory pointer.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

This class abstracts a device context.

A device context stores, retrieves, and modifies the attributes of graphic objects and specifies graphic modes. This class is a kind of CXTPCmdTarget to enhance the MFC command routing.

Constructor & Destructor Documentation

◆ CXTPChartDeviceContext()

CXTPChartDeviceContext | ( | CXTPChartContainer * | pContainer,
 |  | HDC | hDC,
 |  | BOOL | bIs3D,
 |  | CXTPChartDrawingObjectFactory * | pDrawingObjectFactory )
 protected

Constructs a CXTPChartDeviceContext object.

Parameters
pContainer | Parent container pointer.
hDC | Handle to the windows device context.
bIs3D | TRUE identifies device context used for 3D rendering.
pDrawingObjectFactory | Drawing object factory pointer.
See also
CXTPChart2dDrawingObjectFactory, CXTPChart3dDrawingObjectFactory

Member Function Documentation

◆ Execute()

virtual void Execute ( CXTPChartDeviceCommand * pCommand )
virtual

Call this function to trigger the drawing.

Parameters
pCommand A pointer to chart device command object.

◆ GetContainer()

AFX_INLINE CXTPChartContainer * GetContainer ( ) const

Provides access to the parent container object.

Returns
Parent container object pointer.

◆ GetDrawingObjectFactory()

AFX_INLINE CXTPChartDrawingObjectFactory * GetDrawingObjectFactory ( ) const

Provides access to the drawing object factory used by the device context implementation.

Returns
Drawing object factory instance pointer.

◆ GetHDC()

AFX_INLINE HDC GetHDC ( ) const

Call this function to get the windows device context.

Returns
A handle to the windows device context.

◆ Initialize()

virtual BOOL Initialize ( )
virtual

Initializes devices context.

Returns
TRUE if initialization is successful.

◆ Is3D()

AFX_INLINE BOOL Is3D ( ) const

Determines if the derived device context is a 3D device context.

Returns
TRUE if the derived device context is a 3D device context, FALSE otherwise.

◆ MeasureMarkupElement()

virtual CXTPChartSizeF MeasureMarkupElement | ( | CXTPMarkupUIElement * | pMarkupUIElement,
 |  | CXTPChartFont * | pFont )
 pure virtual

Measures the markup element size provided with the font set as the default font for the associated markup context.

Parameters
pMarkupUIElement | Markup element pointer to measure.
pFont | A default markup context font pointer.
Returns
Measured markup element size or empty size in case of an error.

◆ MeasureString()

virtual CXTPChartSizeF MeasureString | ( | const CXTPChartString * | pText,
 |  | CXTPChartFont * | pFont )
 pure virtual

Call this function to get the measurements of texts rendered in a device context using a specific font.

Parameters
pText | The string to be measured.
pFont | Pointer to chart font object.
Returns
Returns mesurements of texts rendered in a device context using a specific font
The documentation for this class was generated from the following file:
  • XTPChartDeviceContext.h


Toolkit Pro: CXTPChartDiagram Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPChartDiagram Class Reference

This class represents a chart diagram, which is a kind of CXTPChartElement. More...

Inheritance diagram for CXTPChartDiagram:
[legend]

Public Member Functions

virtual CXTPChartDiagramView * | CreateView (CXTPChartDeviceContext *pDC, CXTPChartElementView *pParent)
Call this function to create a view of the diagram.
virtual void | CalculateSeriesLayout (CXTPChartDeviceContext *pDC, CXTPChartDiagramView *pView)
Call this function to calculate the series layout of the diagram.
const CXTPChartSeriesArray & | GetSeries () const
Call this function to get the series collection object.
virtual void | DoPropExchange (CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
- Public Member Functions inherited from CXTPChartPanel
CXTPChartPanel ()
Constructs a CXTPChartPanel object.
virtual | ~CXTPChartPanel ()
Destroys a CXTPChartMarker object, handles cleanup.
CXTPChartTitleCollection * | GetTitles () const
Call this function to get the the title collection object.
- Public Member Functions inherited from CXTPChartElement
CXTPChartElement ()
Constructs a CXTPChartElement object.
virtual | ~CXTPChartElement ()
Destroys a CXTPChartElement object, handles cleanup.
CXTPChartElement * | GetOwner () const
Call this function to get the owner element.
virtual void | OnChartChanged (XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic properties of the chart.
CXTPChartContent * | GetContent () const
Call this virtual function to get the chart content object.
CXTPChartAppearance * | GetAppearance () const
Call this function to get the the appearance of the chart.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Protected Member Functions

CXTPChartDiagram ()
Constructs a CXTPChartDiagram object.
virtual BOOL | OnSeriesAdded (CXTPChartSeries *pSeries)
This function is called when a series is added to the series collection in the chart content object which has a collection of series.
void | OnSeriesRemoved (CXTPChartSeries *pSeries)
This function is called when a series is removed from the series collection in the chart content object which has a collection of series.
void | Release ()
Call this function to decrease the usage count of the object.
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.

Protected Attributes

CXTPChartSeriesArray m_arrSeries
The series collection.
- Protected Attributes inherited from CXTPChartPanel
- Protected Attributes inherited from CXTPChartElement

Detailed Description

This class represents a chart diagram, which is a kind of CXTPChartElement.

Member Function Documentation

◆ CalculateSeriesLayout()

virtual void CalculateSeriesLayout | ( | CXTPChartDeviceContext * | pDC,
 |  | CXTPChartDiagramView * | pView )
 virtual

Call this function to calculate the series layout of the diagram.

Parameters
pDC | The chart device context.
pView | A pointer to the diagram view object.

This is a virtual function, so sub classes can give their type specific implementation for this function.

◆ CreateView()

virtual CXTPChartDiagramView * CreateView | ( | CXTPChartDeviceContext * | pDC,
 |  | CXTPChartElementView * | pParent )
 virtual

Call this function to create a view of the diagram.

Parameters
pDC | The chart device context.
pParent | A pointer to the parent view object.
Returns
A pointer to a CXTPChartDiagramView object.

This is a virtual function, so sub classes can give their type specific implementation for this function.

Reimplemented in CXTPChartDiagram2D, and CXTPChartRadarDiagram.

◆ DoPropExchange()

virtual void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Reads this object from or writes this object to an archive.

Parameters
pPX A CXTPPropExchange object to serialize to or from.

Reimplemented from CXTPChartPanel.

Reimplemented in CXTPChartDiagram2D, and CXTPChartRadarDiagram.

◆ GetSeries()

AFX_INLINE const CXTPChartSeriesArray & GetSeries ( ) const

Call this function to get the series collection object.

Returns
A reference to a CXTPChartSeriesArray object.

◆ OnSeriesAdded()

virtual BOOL OnSeriesAdded ( CXTPChartSeries * pSeries )
protectedvirtual

This function is called when a series is added to the series collection in the chart content object which has a collection of series.

Parameters
pSeries A pointer to a chart series object.
Returns
Returns True when the series is added, otherwise False

◆ OnSeriesRemoved()

void OnSeriesRemoved ( CXTPChartSeries * pSeries )
protected

This function is called when a series is removed from the series collection in the chart content object which has a collection of series.

Parameters
pSeries A pointer to a chart series object.
The documentation for this class was generated from the following file:
  • XTPChartDiagram.h


Toolkit Pro: CXTPChartDiagram2D Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPChartDiagram2D Class Reference

This class represents a chart 2D diagram, which is a kind of CXTPChartDiagram. More...

Inheritance diagram for CXTPChartDiagram2D:
[legend]

Public Member Functions

CXTPChartDiagram2D ()
Constructs a CXTPChartDiagram2D object.
virtual | ~CXTPChartDiagram2D ()
Destroys a CXTPChartDiagram2D object, handles cleanup.
CXTPChartAxis * | GetAxisX () const
Call this function to get the X axis associated with the 2D diagram.
CXTPChartAxis * | GetAxisY () const
Call this function to get the Y axis associated with the 2D diagram.
CXTPChartAxis * | GetSecondaryAxisX () const
Call this function to get the secondary X axis associated with the 2D diagram if any.
CXTPChartAxis * | GetSecondaryAxisY () const
Call this function to get the secondary Y axis associated with the 2D diagram if any.
CXTPChartDiagram2DPane * | GetPane () const
Gets the pane to which this object is associated with.
void | SetPane (CXTPChartDiagram2DPane *pPane)
Sets the pane to which this object is associated with.
CXTPChartDiagram2DAppearance * | GetAppearance () const
Call this function to get the diagram appearance object associated with this object.
virtual CXTPChartDiagramView * | CreateView (CXTPChartDeviceContext *pDC, CXTPChartElementView *pParent)
Call this function to create the view of a 2D diagram object.
void | DoPropExchange (CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
- Public Member Functions inherited from CXTPChartDiagram
virtual void | CalculateSeriesLayout (CXTPChartDeviceContext *pDC, CXTPChartDiagramView *pView)
Call this function to calculate the series layout of the diagram.
const CXTPChartSeriesArray & | GetSeries () const
Call this function to get the series collection object.
- Public Member Functions inherited from CXTPChartPanel
CXTPChartPanel ()
Constructs a CXTPChartPanel object.
virtual | ~CXTPChartPanel ()
Destroys a CXTPChartMarker object, handles cleanup.
CXTPChartTitleCollection * | GetTitles () const
Call this function to get the the title collection object.
- Public Member Functions inherited from CXTPChartElement
CXTPChartElement ()
Constructs a CXTPChartElement object.
virtual | ~CXTPChartElement ()
Destroys a CXTPChartElement object, handles cleanup.
CXTPChartElement * | GetOwner () const
Call this function to get the owner element.
virtual void | OnChartChanged (XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic properties of the chart.
CXTPChartContent * | GetContent () const
Call this virtual function to get the chart content object.
CXTPChartAppearance * | GetAppearance () const
Call this function to get the the appearance of the chart.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Protected Member Functions

void | UpdateLayout (CXTPChartDeviceContext *pDC, CXTPChartDiagramView *pView, CRect rcBounds)
Call this function to update the layout if there are some changes in the diagram.
- Protected Member Functions inherited from CXTPChartDiagram
CXTPChartDiagram ()
Constructs a CXTPChartDiagram object.
virtual BOOL | OnSeriesAdded (CXTPChartSeries *pSeries)
This function is called when a series is added to the series collection in the chart content object which has a collection of series.
void | OnSeriesRemoved (CXTPChartSeries *pSeries)
This function is called when a series is removed from the series collection in the chart content object which has a collection of series.
void | Release ()
Call this function to decrease the usage count of the object.
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.

Protected Attributes

CXTPChartDiagram2DPane * | m_pPane
The pointer to diagram pane object.
- Protected Attributes inherited from CXTPChartDiagram
CXTPChartSeriesArray | m_arrSeries
The series collection.
- Protected Attributes inherited from CXTPChartPanel
- Protected Attributes inherited from CXTPChartElement

Detailed Description

This class represents a chart 2D diagram, which is a kind of CXTPChartDiagram.

Member Function Documentation

◆ CreateView()

virtual CXTPChartDiagramView * CreateView | ( | CXTPChartDeviceContext * | pDC,
 |  | CXTPChartElementView * | pParent )
 virtual

Call this function to create the view of a 2D diagram object.

Parameters
pDC | A pointer to a chart device context object.
pParent | A pointer to the parent view.
Returns
A pointer to a CXTPChartDiagramView object.

Reimplemented from CXTPChartDiagram.

◆ DoPropExchange()

void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Reads this object from or writes this object to an archive.

Parameters
pPX A CXTPPropExchange object to serialize to or from.

Reimplemented from CXTPChartDiagram.

◆ GetAppearance()

CXTPChartDiagram2DAppearance * GetAppearance ( ) const

Call this function to get the diagram appearance object associated with this object.

Returns
A pointer to a CXTPChartDiagram2DAppearance object.

◆ GetAxisX()

CXTPChartAxis * GetAxisX ( ) const

Call this function to get the X axis associated with the 2D diagram.

Returns
A pointer to a CXTPChartAxis object. The specific type is CXTPChartAxisX.

◆ GetAxisY()

CXTPChartAxis * GetAxisY ( ) const

Call this function to get the Y axis associated with the 2D diagram.

Returns
A pointer to a CXTPChartAxis object. The specific type is CXTPChartAxisY.

◆ GetPane()

AFX_INLINE CXTPChartDiagram2DPane * GetPane ( ) const

Gets the pane to which this object is associated with.

Returns
A pointer to a CXTPChartDiagram2DPane object.

◆ GetSecondaryAxisX()

CXTPChartAxis * GetSecondaryAxisX ( ) const

Call this function to get the secondary X axis associated with the 2D diagram if any.

Returns
A pointer to a CXTPChartAxis object. The specific type is CXTPChartAxisX.

◆ GetSecondaryAxisY()

CXTPChartAxis * GetSecondaryAxisY ( ) const

Call this function to get the secondary Y axis associated with the 2D diagram if any.

Returns
A pointer to a CXTPChartAxis object. The specific type is CXTPChartAxisX.

◆ SetPane()

void SetPane ( CXTPChartDiagram2DPane * pPane )

Sets the pane to which this object is associated with.

Parameters
pPane Pointer to a CXTPChartDiagram2DPane object.

◆ UpdateLayout()

void UpdateLayout | ( | CXTPChartDeviceContext * | pDC,
 |  | CXTPChartDiagramView * | pView,
 |  | CRect | rcBounds )
 protected

Call this function to update the layout if there are some changes in the diagram.

Parameters
pDC | A pointer to a chart device context object.
pView | A pointer to the associated diagram view object.
rcBounds | The rectangular diagram boundary.
The documentation for this class was generated from the following file:
  • XTPChartDiagram2D.h


Toolkit Pro: CXTPChartDiagram2DAppearance Class Reference

Public Member Functions | Public Attributes | Protected Attributes | List of all members
CXTPChartDiagram2DAppearance Class Reference

This class represents the appearance of diagram in 2D. More...

Inheritance diagram for CXTPChartDiagram2DAppearance:
[legend]

Public Member Functions

CXTPChartDiagram2DAppearance (CXTPChartElement *pOwner)
Constructs a CXTPChartDiagram2DAppearance object.
virtual | ~CXTPChartDiagram2DAppearance ()
Destroys a CXTPChartDiagram2DAppearance object, handles cleanup.
void | DoPropExchange (CXTPPropExchange *pPX)
Call this member function to Store/Load the properties related to the appearance of a diagram in 2D, using the specified data object.
CXTPChartAxisAppearance * | GetAxisAppearance () const
Obtains axis appearance object pointer.
- Public Member Functions inherited from CXTPChartElementAppearance
CXTPChartElementAppearance (CXTPChartElement *pOwner)
Constructs a CXTPChartElementAppearance object.
virtual | ~CXTPChartElementAppearance ()
Destroys a CXTPChartElementAppearance object, handles cleanup.
virtual void | ApplyToDeviceContext (CXTPChartDeviceContext *pDC)
Applies implementation specific appearance settings to the device context provided.
- Public Member Functions inherited from CXTPChartElement
CXTPChartElement ()
Constructs a CXTPChartElement object.
virtual | ~CXTPChartElement ()
Destroys a CXTPChartElement object, handles cleanup.
virtual void | Release ()
Call this function to decrease the usage count of the object.
CXTPChartElement * | GetOwner () const
Call this function to get the owner element.
virtual void | OnChartChanged (XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic properties of the chart.
CXTPChartContent * | GetContent () const
Call this virtual function to get the chart content object.
CXTPChartAppearance * | GetAppearance () const
Call this function to get the the appearance of the chart.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Public Attributes

CXTPChartColor | BackgroundColor
The first background color of the diagram.
CXTPChartColor | BackgroundColor2
The second background color of the diagram.
CXTPChartColor | BorderColor
The border color of the diagram.
CXTPChartFillStyle * | BackgroundFillStyle
The background fill style of the diagram.
- Public Attributes inherited from CXTPChartElement

Protected Attributes

CXTPChartAxisAppearance * m_pAxisAppearance
Pointer to the chart axis appearance object.
- Protected Attributes inherited from CXTPChartElement

Additional Inherited Members

- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.

Detailed Description

This class represents the appearance of diagram in 2D.

This class is subclassed from CXTPChartElementAppearance class.

Constructor & Destructor Documentation

◆ CXTPChartDiagram2DAppearance()

CXTPChartDiagram2DAppearance ( CXTPChartElement * pOwner )

Constructs a CXTPChartDiagram2DAppearance object.

Parameters
pOwner Pointer to an owner element.

Member Function Documentation

◆ DoPropExchange()

void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Call this member function to Store/Load the properties related to the appearance of a diagram in 2D, using the specified data object.

Parameters
pPX Source or destination CXTPPropExchange data object reference.

This member function is used to store or load property data to or from a storage.

Reimplemented from CXTPChartElement.

◆ GetAxisAppearance()

AFX_INLINE CXTPChartAxisAppearance * GetAxisAppearance ( ) const

Obtains axis appearance object pointer.

Returns
Axis appearance object pointer.
The documentation for this class was generated from the following file:
  • XTPChartAppearance.h


Toolkit Pro: CXTPChartDiagram2DAxisView Class Reference

Public Member Functions | Public Attributes | Protected Member Functions | Protected Attributes | List of all members
CXTPChartDiagram2DAxisView Class Reference

This class abstracts the view of a chart axis and its child items in a bounding rectangle context. More...

Public Member Functions

CXTPChartDiagram2DAxisView (CXTPChartAxis *pAxis, CXTPChartElementView *pParentView)
Constructs a CXTPChartDiagram2DAxisView object.
~CXTPChartDiagram2DAxisView ()
Destroys a CXTPChartDiagram2DAxisView object, handles cleanup and deallocation.
virtual CXTPChartDeviceCommand * | CreateDeviceCommand (CXTPChartDeviceContext *pDC)
Override this function to create a CXTPChartDeviceCommand object.
virtual CXTPChartDeviceCommand * | CreateGridLinesDeviceCommand (CXTPChartDeviceContext *pDC, CRect rcPane)
This function creates a CXTPChartDeviceCommand object.
virtual CXTPChartDeviceCommand * | CreateInterlacedDeviceCommand (CXTPChartDeviceContext *pDC, CRect rcPane)
This function creates a CXTPChartDeviceCommand object.
virtual CXTPChartDeviceCommand * | CreateTickMarksDeviceCommand (CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
virtual CXTPChartDeviceCommand * | CreateLabelsDeviceCommand (CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
virtual CXTPChartDeviceCommand * | CreateTitleDeviceCommand (CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
virtual CXTPChartDeviceCommand * | CreateConstantLinesDeviceCommand (CXTPChartDeviceContext *pDC, CRect rcPane, BOOL bBehind)
This function creates a CXTPChartDeviceCommand object.
virtual CXTPChartDeviceCommand * | CreateStripsDeviceCommand (CXTPChartDeviceContext *pDC, CRect rcPane)
This function creates a CXTPChartDeviceCommand object.
void | CreateView (CXTPChartDeviceContext *pDC)
Call this function to create the chart axis view.
void | CalcSize (CXTPChartDeviceContext *pDC, CRect rcDiagram)
This function calculates the size of an axis, including its constituent elements (e.g.
void | SetBounds (CXTPChartDeviceContext *pDC, CRect rcBounds)
This function sets the bounds for the axis.
double | ValueToPoint (double nValue) const
Call this function to get a point on the axis from a value within the range.
double | DistanceToPoint (double nDistance) const
Call this function to get the distance of a point from the axis origin.
int | GetSize () const
This function returns the size of the axis.
BOOL | IsVertical () const
This function checks if the axis is vertical.

Public Attributes

CArray< CXTPChartAxisViewTick, CXTPChartAxisViewTick & > m_arrTicks
The collection of tick marks.

Protected Member Functions

void CreateTickMarks (CXTPChartDeviceContext *pDC, CRect rcDiagram)
This function creates the axis tick marks.

Protected Attributes

CRect | m_rcBounds
The diagram boundary.
int | m_nSize
The axis size;.

Detailed Description

This class abstracts the view of a chart axis and its child items in a bounding rectangle context.

Constructor & Destructor Documentation

◆ CXTPChartDiagram2DAxisView()

CXTPChartDiagram2DAxisView | ( | CXTPChartAxis * | pAxis,
 |  | CXTPChartElementView * | pParentView )

Constructs a CXTPChartDiagram2DAxisView object.

Parameters
pAxis | Pointer to a CXTPChartAxis object.
pParentView | Pointer to a CXTPChartElementView object.

Member Function Documentation

◆ CalcSize()

void CalcSize | ( | CXTPChartDeviceContext * | pDC,
 |  | CRect | rcDiagram )

This function calculates the size of an axis, including its constituent elements (e.g.

tick marks, labels, axis title, etc.).

Parameters
pDC | The chart device context object.
rcDiagram | The rectangle of the diagram.

◆ CreateConstantLinesDeviceCommand()

virtual CXTPChartDeviceCommand * CreateConstantLinesDeviceCommand | ( | CXTPChartDeviceContext * | pDC,
 |  | CRect | rcPane,
 |  | BOOL | bBehind )
 virtual

This function creates a CXTPChartDeviceCommand object.

This object represents the rendering of the constant lines perpendicular to an axis.

Parameters
pDC | Pointer to a CXTPChartDeviceContext object.
rcPane | The bounding rectange.
bBehind | TRUE for behind
Returns
Returns a pointer to a CXTPChartDeviceCommand object. This polymorphic object handles the rendering of an element in the chart. Here it handles the drawing of the constant lines perpendicular to an axis.

◆ CreateDeviceCommand()

virtual CXTPChartDeviceCommand * CreateDeviceCommand ( CXTPChartDeviceContext * pDC )
virtual

Override this function to create a CXTPChartDeviceCommand object.

This object represents the rendering of an axis in the chart.

Parameters
pDC Pointer to a CXTPChartDeviceContext object.
Returns
Returns a CXTPChartDeviceCommand object. This object handles the rendering of an element in the chart. Here it handles the drawing of an axis.

Reimplemented from CXTPChartElementView.

◆ CreateGridLinesDeviceCommand()

virtual CXTPChartDeviceCommand * CreateGridLinesDeviceCommand | ( | CXTPChartDeviceContext * | pDC,
 |  | CRect | rcPane )
 virtual

This function creates a CXTPChartDeviceCommand object.

This object represents the rendering of the grid lines in a chart axis.

Parameters
pDC | Pointer to a CXTPChartDeviceContext object.
rcPane | The bounding rectange.
Returns
Returns a pointer to a CXTPChartDeviceCommand object. This polymorphic object handles the rendering of an element in the chart. Here it handles the drawing of the grid lines in a chart axis.

◆ CreateInterlacedDeviceCommand()

virtual CXTPChartDeviceCommand * CreateInterlacedDeviceCommand | ( | CXTPChartDeviceContext * | pDC,
 |  | CRect | rcPane )
 virtual

This function creates a CXTPChartDeviceCommand object.

This object represents the rendering of the interlaced strips in the chart.

Parameters
pDC | Pointer to a CXTPChartDeviceContext object.
rcPane | The bounding rectange.
Returns
Returns a pointer to a CXTPChartDeviceCommand object. This polymorphic object handles the rendering of an element in the chart. Here it handles the drawing of the interlaced strips in the chart.

◆ CreateLabelsDeviceCommand()

virtual CXTPChartDeviceCommand * CreateLabelsDeviceCommand ( CXTPChartDeviceContext * pDC )
virtual

This function creates a CXTPChartDeviceCommand object.

This object represents the rendering of the labels in the axis.

Parameters
pDC Pointer to a CXTPChartDeviceContext object.
Returns
Returns a pointer to a CXTPChartDeviceCommand object. This polymorphic object handles the rendering of an element in the chart. Here it handles the drawing of the labels in the axis.

◆ CreateStripsDeviceCommand()

virtual CXTPChartDeviceCommand * CreateStripsDeviceCommand | ( | CXTPChartDeviceContext * | pDC,
 |  | CRect | rcPane )
 virtual

This function creates a CXTPChartDeviceCommand object.

This object represents the rendering of the strips parallel to an axis.

Parameters
pDC | Pointer to a CXTPChartDeviceContext object.
rcPane | The bounding rectange.
Returns
Returns a pointer to a CXTPChartDeviceCommand object. This polymorphic object handles the rendering of an element in the chart. Here it handles the drawing of the strips parallel to an axis.

◆ CreateTickMarks()

void CreateTickMarks | ( | CXTPChartDeviceContext * | pDC,
 |  | CRect | rcDiagram )
 protected

This function creates the axis tick marks.

Parameters
pDC | The device context.
rcDiagram | The bounding rectangle of the diagram.

◆ CreateTickMarksDeviceCommand()

virtual CXTPChartDeviceCommand * CreateTickMarksDeviceCommand ( CXTPChartDeviceContext * pDC )
virtual

This function creates a CXTPChartDeviceCommand object.

This object represents the rendering of the tick marks in the axis.

Parameters
pDC Pointer to a CXTPChartDeviceContext object.
Returns
Returns a pointer to a CXTPChartDeviceCommand object. This polymorphic object handles the rendering of an element in the chart. Here it handles the drawing of the tick marks in the axis.

◆ CreateTitleDeviceCommand()

virtual CXTPChartDeviceCommand * CreateTitleDeviceCommand ( CXTPChartDeviceContext * pDC )
virtual

This function creates a CXTPChartDeviceCommand object.

This object represents the rendering of the axis title.

Parameters
pDC Pointer to a CXTPChartDeviceContext object.
Returns
Returns a pointer to a CXTPChartDeviceCommand object. This polymorphic object handles the rendering of an element in the chart. Here it handles the drawing of the axis title.

◆ CreateView()

void CreateView ( CXTPChartDeviceContext * pDC )

Call this function to create the chart axis view.

Parameters
pDC The chart device context object.

This function creates the view of an axis and its constituent elements (e.g. tick marks, labels, axis title, etc.).

◆ DistanceToPoint()

double DistanceToPoint ( double nDistance ) const

Call this function to get the distance of a point from the axis origin.

Parameters
nDistance A point within the axis range.
Returns
Returns distance to the point from axis origin

◆ GetSize()

AFX_INLINE int GetSize ( ) const

This function returns the size of the axis.

Returns
The last computed axis size value. If the axis size value has not been computed yet, a value of 0 will be returned instead.

◆ IsVertical()

BOOL IsVertical ( ) const

This function checks if the axis is vertical.

Returns
A BOOL value. TRUE if the axis is vertical, FALSE if the axis is horizontal.

◆ SetBounds()

void SetBounds | ( | CXTPChartDeviceContext * | pDC,
 |  | CRect | rcBounds )

This function sets the bounds for the axis.

Parameters
pDC | The chart device context object.
rcBounds | The bounding rectangle.

◆ ValueToPoint()

double ValueToPoint ( double nValue ) const

Call this function to get a point on the axis from a value within the range.

Parameters
nValue A point within the axis range.
Returns
Returns a point on the axis from a value within the range
The documentation for this class was generated from the following file:
  • XTPChartAxisView.h


Toolkit Pro: CXTPChartDiagram2DSeriesLabel Class Reference

Public Member Functions | List of all members
CXTPChartDiagram2DSeriesLabel Class Reference

This class abstracts the label of a point series. More...

Inheritance diagram for CXTPChartDiagram2DSeriesLabel:
[legend]

Public Member Functions

CXTPChartDiagram2DSeriesLabel ()
Constructs a CXTPChartDiagram2DSeriesLabel object.
virtual | ~CXTPChartDiagram2DSeriesLabel ()
Destroys a CXTPChartDiagram2DSeriesLabel object, handles cleanup.
void | DoPropExchange (CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
- Public Member Functions inherited from CXTPChartSeriesLabel
CXTPChartSeriesLabel ()
Constructs a CXTPChartSeriesLabel object.
virtual | ~CXTPChartSeriesLabel ()
Destroys a CXTPChartSeriesLabel object, handles cleanup.
void | SetTextColor (const CXTPChartColor &clrTextColor)
Call this function to set the text color of the label.
CXTPChartColor | GetTextColor () const
Call this function to get the apparent text color of the label.
CXTPChartFont * | GetFont () const
Call this function to get the font of the text label.
void | SetFont (CXTPChartFont *pFont)
Call this function to set the font of the text label.
void | SetShowLines (BOOL bShowLines)
Call this function to set the lines visibility.
BOOL | GetShowLines () const
Call this function to check if the lines are visible.
void | SetLineLength (int nLineLength)
Call this function to set the line length.
int | GetLineLength () const
Call this function to get the line length.
void | SetVisible (BOOL bVisible)
Call this function to set the label visibility.
BOOL | IsVisible () const
Call this function to check if the label is visible.
void | SetAntialiasing (BOOL bAntialiasing)
Call this function to set anti-aliasing ON or OFF.
BOOL | GetAntialiasing () const
Call this function to check if anti-aliasing is ON or OFF.
CXTPChartNumberFormat * | GetFormat () const
Call this function to get a pointer to CXTPChartNumberFormat that specifies how to convert numbers to strings.
void | SetFormat (LPCTSTR lpszFormat)
Obsolete method.
void | SetBackColor (const CXTPChartColor &clrBackColor)
Call this function to set the text color of the label.
CXTPChartColor | GetBackColor () const
Call this function to get the apparent text color of the label.
void | SetLineColor (const CXTPChartColor &clrBackColor)
Call this function to set the text color of the label.
CXTPChartColor | GetLineColor () const
Call this function to get the apparent text color of the label.
int | GetTransparency () const
Call this function to get the transparency of the filled area with respect to the background.
void | SetTransparency (int nTransparency)
Call this function to set the transparency of the filled area with respect to the background.
- Public Member Functions inherited from CXTPChartTextElement
- Public Member Functions inherited from CXTPChartElement
CXTPChartElement ()
Constructs a CXTPChartElement object.
virtual | ~CXTPChartElement ()
Destroys a CXTPChartElement object, handles cleanup.
virtual void | Release ()
Call this function to decrease the usage count of the object.
CXTPChartElement * | GetOwner () const
Call this function to get the owner element.
virtual void | OnChartChanged (XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic properties of the chart.
CXTPChartContent * | GetContent () const
Call this virtual function to get the chart content object.
CXTPChartAppearance * | GetAppearance () const
Call this function to get the the appearance of the chart.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Additional Inherited Members

- Public Attributes inherited from CXTPChartElement
- Protected Member Functions inherited from CXTPChartSeriesLabel
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.
- Protected Attributes inherited from CXTPChartSeriesLabel
CXTPChartColor | m_clrTextColor
The text color.
CXTPChartColor | m_clrBackColor
The background color.
CXTPChartColor | m_clrLineColor
The line color.
BOOL | m_bVisible
TRUE if the label is visible and FALSE if not.
CXTPChartFont * | m_pFont
The font of the label.
BOOL | m_bAntialiasing
TRUE if antialiasing enabled, FALSE if not.
BOOL | m_bShowLines
TRUE if the lines are visible, FALSE if not.
int | m_nLineLength
The line length.
CXTPChartBorder * | m_pBorder
Chart border object.
int | m_nTransparency
The transparency values range from 0 to 255.
- Protected Attributes inherited from CXTPChartElement

Detailed Description

This class abstracts the label of a point series.

It is a kind of chart series label.

Member Function Documentation

◆ DoPropExchange()

void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Reads this object from or writes this object to an archive.

Parameters
pPX A CXTPPropExchange object to serialize to or from.

Reimplemented from CXTPChartSeriesLabel.

Reimplemented in CXTPChartPointSeriesLabel, CXTPChartRangeAreaSeriesLabel, and CXTPChartRangeBarSeriesLabel.

The documentation for this class was generated from the following file:
  • XTPChartDiagram2DSeriesLabel.h


Toolkit Pro: CXTPChartDiagram2DSeriesLabelView Class Reference

Public Member Functions | List of all members
CXTPChartDiagram2DSeriesLabelView Class Reference

This class abstracts the view of the label of a point series. More...

Inheritance diagram for CXTPChartDiagram2DSeriesLabelView:
[legend]

Public Member Functions

CXTPChartDiagram2DSeriesLabelView (CXTPChartSeriesLabel *pLabel, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView)
Constructs a CXTPChartDiagram2DSeriesLabelView object.
virtual CXTPChartDeviceCommand * | CreateDeviceCommand (CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
virtual CXTPChartDeviceCommand * | CreateDeviceCommand (CXTPChartDeviceContext *pDC, CXTPChartPointF ptCenterPoint)
This function creates a CXTPChartDeviceCommand object.
virtual CXTPChartDeviceCommand * | CreateDeviceCommand (CXTPChartDeviceContext *pDC, CXTPChartPointF ptCenterPoint, const CXTPChartString &text)
This function creates a CXTPChartDeviceCommand object.
virtual CXTPChartDeviceCommand * | CreateDeviceCommand (CXTPChartDeviceContext *pDC, const CXTPChartPointF &ptAnchorPoint, double dAnchorAngle, const CXTPChartString &text)
This function creates a CXTPChartDeviceCommand object.
virtual CXTPChartPointF | GetAnchorPoint () const
This function calculates the anchor point of the label stem.

Detailed Description

This class abstracts the view of the label of a point series.

It is a kind of chart series label view.

Constructor & Destructor Documentation

◆ CXTPChartDiagram2DSeriesLabelView()

CXTPChartDiagram2DSeriesLabelView | ( | CXTPChartSeriesLabel * | pLabel,
 |  | CXTPChartSeriesPointView * | pPointView,
 |  | CXTPChartElementView * | pParentView )

Constructs a CXTPChartDiagram2DSeriesLabelView object.

Parameters
pLabel | The pointer to a chart series label object.
pPointView | A pointer to a chart series view.
pParentView | Parent view pointer.

Member Function Documentation

◆ CreateDeviceCommand() [1/4]

virtual CXTPChartDeviceCommand * CreateDeviceCommand ( CXTPChartDeviceContext * pDC )
virtual

This function creates a CXTPChartDeviceCommand object.

This object represents the rendering of the chart series label.

Parameters
pDC Pointer to a CXTPChartDeviceContext object.
Returns
Returns a pointer to a CXTPChartDeviceCommand object. This polymorphic object handles the rendering of an element in the chart. Here it handles the drawing of the chart series label.

Reimplemented from CXTPChartElementView.

Reimplemented in CXTPChartBarSeriesLabelView, CXTPChartBubbleSeriesLabelView, CXTPChartRangeAreaSeriesLabelView, and CXTPChartRangeBarSeriesLabelView.

◆ CreateDeviceCommand() [2/4]

virtual CXTPChartDeviceCommand * CreateDeviceCommand | ( | CXTPChartDeviceContext * | pDC,
 |  | const CXTPChartPointF & | ptAnchorPoint,
 |  | double | dAnchorAngle,
 |  | const CXTPChartString & | text )
 virtual

This function creates a CXTPChartDeviceCommand object.

This object represents the rendering of the chart series label.

Parameters
pDC | Pointer to a CXTPChartDeviceContext object.
text | Text.
ptAnchorPoint | Anchor point.
dAnchorAngle | Anchor angle.
Returns
Returns a pointer to a CXTPChartDeviceCommand object. This polymorphic object handles the rendering of an element in the chart. Here it handles the drawing of the chart series label.

Reimplemented in CXTPChartBarSeriesLabelView, CXTPChartBubbleSeriesLabelView, and CXTPChartRangeBarSeriesLabelView.

◆ CreateDeviceCommand() [3/4]

virtual CXTPChartDeviceCommand * CreateDeviceCommand | ( | CXTPChartDeviceContext * | pDC,
 |  | CXTPChartPointF | ptCenterPoint )
 virtual

This function creates a CXTPChartDeviceCommand object.

This object represents the rendering of the chart series label.

Parameters
pDC | Pointer to a CXTPChartDeviceContext object.
ptCenterPoint | Center point.
Returns
Returns a pointer to a CXTPChartDeviceCommand object. This polymorphic object handles the rendering of an element in the chart. Here it handles the drawing of the chart series label.

Reimplemented in CXTPChartBarSeriesLabelView, CXTPChartBubbleSeriesLabelView, and CXTPChartRangeBarSeriesLabelView.

◆ CreateDeviceCommand() [4/4]

virtual CXTPChartDeviceCommand * CreateDeviceCommand | ( | CXTPChartDeviceContext * | pDC,
 |  | CXTPChartPointF | ptCenterPoint,
 |  | const CXTPChartString & | text )
 virtual

This function creates a CXTPChartDeviceCommand object.

This object represents the rendering of the chart series label.

Parameters
pDC | Pointer to a CXTPChartDeviceContext object.
ptCenterPoint | Center point.
text | Text.
Returns
Returns a pointer to a CXTPChartDeviceCommand object. This polymorphic object handles the rendering of an element in the chart. Here it handles the drawing of the chart series label.

Reimplemented in CXTPChartBarSeriesLabelView, CXTPChartBubbleSeriesLabelView, and CXTPChartRangeBarSeriesLabelView.

◆ GetAnchorPoint()

virtual CXTPChartPointF GetAnchorPoint ( ) const
virtual

This function calculates the anchor point of the label stem.

Returns
A CXTPChartPointF object denoting the anchor point.

Reimplemented in CXTPChartBarSeriesLabelView, CXTPChartPointSeriesLabelView, CXTPChartRangeAreaSeriesLabelView, and CXTPChartRangeBarSeriesLabelView.

The documentation for this class was generated from the following file:
  • XTPChartDiagram2DSeriesLabel.h


Toolkit Pro: CXTPChartDiagram2DSeriesStyle Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPChartDiagram2DSeriesStyle Class Reference

This class represents a line series style, which is a kind of CXTPChartSeriesStyle. More...

Inheritance diagram for CXTPChartDiagram2DSeriesStyle:
[legend]

Public Member Functions

CXTPChartDiagram2DSeriesStyle ()
Constructs a CXTPChartDiagram2DSeriesStyle object.
virtual | ~CXTPChartDiagram2DSeriesStyle ()
Destroys a CXTPChartDiagram2DSeriesStyle object, handles cleanup.
void | DoPropExchange (CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
virtual CXTPChartDiagram * | CreateDiagram ()
Call this function to create the diagram for this series.
virtual BOOL | IsStyleDiagram (CXTPChartDiagram *pDiagram) const
Call this function to check whether the chart diagram object passed is a kind of 2D diagram (CXTPChartDiagram2D object).
- Public Member Functions inherited from CXTPChartSeriesStyle
CXTPChartSeriesStyle ()
Constructs a CXTPChartSeriesStyle object.
virtual | ~CXTPChartSeriesStyle ()
Destroys a CXTPChartSeriesStyle object, handles cleanup.
virtual CXTPChartSeriesLabel * | GetLabel () const
Call this method to gets the series label object.
virtual CXTPChartSeriesLabel * | SetLabel (CXTPChartSeriesLabel *pLabel)
Call this method to sets the series label object.
virtual CXTPChartErrorBar * | GetErrorBar () const
Call this method to gets the error bar object.
virtual CXTPChartErrorBar * | SetErrorBar (CXTPChartErrorBar *pErrorBar)
Call this method to sets the error bar object.
virtual CXTPChartColor | GetColor () const
Call this method to get the color of the series.
virtual void | SetColor (CXTPChartColor clr)
Call this method to set the color of the series.
virtual void | SetColorEach (BOOL bColorEach)
Call this method to set individual color for each point of the series.
virtual BOOL | IsColorEach () const
This method is called to check if individual color is used for each point of the series.
virtual CXTPChart3dRotation | Get3dRotation () const
Obtains rotation parameters for 3D chart.
virtual void | Set3dRotation (const CXTPChart3dRotation &rotation)
Sets rotation parameters for 3D chart.
virtual void | Set3dRotation (double dYaw, double dPitch, double dRoll)
Sets rotation parameters for 3D chart.
virtual BOOL | Is3dEdgeSmoothingEnabled () const
Enables/disables 3D edge smoothing.
virtual void | Enable3dEdgeSmoothing (BOOL bEnable=TRUE)
Enables/disables 3D edge smoothing.
virtual int | GetTransparency () const
Call this function to gets the transparency of the chart if it is supported by the chart type.
virtual void | SetTransparency (int nTransparency)
Call this function to sets the transparency of the chart if it is supported by the chart type.
virtual void | CorrectAxisSideMargins (CXTPChartAxis *pAxis, double nMinValue, double nMaxValue, double &nCorrection)
Provides default implementation for axis side margins correction.
virtual CXTPChartSeriesStyleAppearance * | GetStyleAppearance () const
Obtains associated style appearance pointer.
virtual void | ApplyTo (CXTPChartDeviceCommand *pCommand)
Applies the style to the command provided in case the command needs style specific details for correct drawing.
virtual int | GetSeriesPointValueIndex () const
Obtains the index of a point element for which an internal value can be otained.
virtual CXTPChartSeriesView * | CreateView (CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)=0
This virtual method is called to create a new view associated with the current style.
- Public Member Functions inherited from CXTPChartElement
CXTPChartElement ()
Constructs a CXTPChartElement object.
virtual | ~CXTPChartElement ()
Destroys a CXTPChartElement object, handles cleanup.
virtual void | Release ()
Call this function to decrease the usage count of the object.
CXTPChartElement * | GetOwner () const
Call this function to get the owner element.
virtual void | OnChartChanged (XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic properties of the chart.
CXTPChartContent * | GetContent () const
Call this virtual function to get the chart content object.
CXTPChartAppearance * | GetAppearance () const
Call this function to get the the appearance of the chart.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Protected Attributes

int | m_nAxisIndexX
Holds index of secondary axisX, used when m_bSecondaryAxisX is TRUE.
int | m_nAxisIndexY
Holds index of secondary axisY, used when m_bSecondaryAxisY is TRUE.
- Protected Attributes inherited from CXTPChartSeriesStyle
CXTPChartSeriesLabel * | m_pLabel
Label object.
CXTPChartErrorBar * | m_pErrorBar
Error bar object.
CXTPChartColor | m_clrColor
Custom color of series.
BOOL | m_bColorEach
TRUE to color each point.
int | m_nTransparency
The transparency value in the range 0..255.
CXTPChart3dRotation | m_Rotation3d
3D rotation
BOOL | m_bSmooth3dEdges
3D edge smoothing
- Protected Attributes inherited from CXTPChartElement

Additional Inherited Members

- Public Attributes inherited from CXTPChartElement
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.

Detailed Description

This class represents a line series style, which is a kind of CXTPChartSeriesStyle.

A point chart is a type of graph which displays information as a series of data points. It is a basic type of chart common in many fields.

Member Function Documentation

◆ CreateDiagram()

virtual CXTPChartDiagram * CreateDiagram ( )
virtual

Call this function to create the diagram for this series.

Returns
A pointer to a CXTPChartDiagram object which points to the newly created CXTPChartDiagram2D object.

Reimplemented from CXTPChartSeriesStyle.

◆ DoPropExchange()

void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Reads this object from or writes this object to an archive.

Parameters
pPX A CXTPPropExchange object to serialize to or from.

Reimplemented from CXTPChartSeriesStyle.

Reimplemented in CXTPChartFastLineSeriesStyle, CXTPChartGanttSeriesStyle, CXTPChartLineSeriesStyle, CXTPChartPointSeriesStyle, CXTPChartRangeBarSeriesStyle, CXTPChartStackedBarSeriesStyle, CXTPChartStepAreaSeriesStyle, and CXTPChartStepLineSeriesStyle.

◆ IsStyleDiagram()

virtual BOOL IsStyleDiagram ( CXTPChartDiagram * pDiagram ) const
virtual

Call this function to check whether the chart diagram object passed is a kind of 2D diagram (CXTPChartDiagram2D object).

Parameters
pDiagram A pointer to a chart diagram whose type is to be identified.
Returns
A BOOL value. TRUE if the chart diagram is a 2D diagram, FALSE otherwise.

Reimplemented from CXTPChartSeriesStyle.

The documentation for this class was generated from the following file:
  • XTPChartDiagram2DSeriesStyle.h


Toolkit Pro: CXTPChartDiagram2DView Class Reference

Public Member Functions | Public Attributes | List of all members
CXTPChartDiagram2DView Class Reference

This class represents the view of a chart 2D diagram, which is a kind of CXTPChartDiagramView. More...

Inheritance diagram for CXTPChartDiagram2DView:
[legend]

Public Member Functions

CXTPChartDiagram2DView (CXTPChartDiagram *pDiagram, CXTPChartElementView *pParent)
Constructs a CXTPChartDiagram2DView object.
CXTPChartDiagram2DPaneView * | GetPaneView () const
Call this function to get the diagram pane view object to which this CXTPChartDiagram2DView object is associated with.
void | CreateView (CXTPChartDeviceContext *pDC)
Call this function to create the view of the 2D diagram.
void | CalculateView (CXTPChartDeviceContext *pDC, CRect rcBounds)
Call this function to calculate the layout based on a rectangular boundary.
void | UpdateRange (CXTPChartDeviceContext *pDC)
Updates chart range.
void | AddAxisView (CXTPChartDeviceContext *pDC, CXTPChartElementView *pParentView, CXTPChartAxis *pAxis)
Use this function to add an axis view to the diagram view.
virtual CXTPChartDeviceCommand * | CreateDeviceCommand (CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
CXTPChartAxisView * | GetAxisView (CXTPChartAxis *pAxis) const
Call this function to get the view for an axis object.
virtual void | OnMouseWheel (UINT nFlags, short zDelta, CPoint pt)
Handles mouse wheel event.
- Public Member Functions inherited from CXTPChartDiagramView
CXTPChartDiagramView (CXTPChartDiagram *pDiagram, CXTPChartElementView *pParentView)
Constructs a CXTPChartDiagram object.
CRect | GetBounds () const
Call this function to get the bounds of the diagram.
CXTPChartDiagram * | GetDiagram () const
Call this function to get the diagram object associated with the view.
CXTPChartElementView * | GetLabelsView () const
Call this function to get the label view object associated with this diagram view.
CXTPChartElementView * | GetSeriesView () const
Call this function to get the series view object associated with this diagram view.
- Public Member Functions inherited from CXTPChartElementView
CXTPChartElementView (CXTPChartElementView *pParentView)
Constructs a CXTPChartElementView object.
CXTPChartElementView (CXTPChartElementView *pParentView, BOOL bAddToParent)
Constructs a CXTPChartElementView object.
CXTPChartElementView (CXTPChartContainer *pContainer)
Constructs a CXTPChartElementView object.
int | GetCount () const
Call this function to get the number of child views associated with this view.
CXTPChartElementView * | GetAt (int nIndex) const
Call this function to get a child view at a particular index.
CXTPChartElementView * | GetParentView () const
Call this function to get the parent view.
CXTPChartElementView * | AddChildView (CXTPChartElementView *pChildView)
Call this function to add a child view to the current view.
CXTPChartElementView ** GetChildren ()
Provides access to the collection of children elements owned by the view.
CRect | GetBounds () const
Obtains viewed object's bound rectangle.
CRect | GetBounds (BOOL bIncludingChildren) const
Obtains viewed object's bound rectangle.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Public Attributes

CXTPChartElementView * | m_pAxisViews
The axis view.
CXTPChartDiagram2DPaneView * | m_pPaneView
The pane view.
- Public Attributes inherited from CXTPChartDiagramView

Additional Inherited Members

- Protected Member Functions inherited from CXTPChartDiagramView
- Protected Member Functions inherited from CXTPChartElementView
virtual | ~CXTPChartElementView ()
Destroys a CXTPChartElementView object, handles cleanup.
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.
- Protected Attributes inherited from CXTPChartDiagramView
CXTPChartDiagram * | m_pDiagram
Pointer to the associated diagram object.
CRect | m_rcBounds
The diagram bounds.
CXTPChartElementView * | m_pLabelsView
The label view.
CXTPChartElementView * | m_pSeriesView
The series view.
CXTPChartElementView * | m_pTitlesView
Titles View.
- Protected Attributes inherited from CXTPChartElementView
CArray< CXTPChartElementView *, CXTPChartElementView * > | m_arrChildren
The child view collection.
CXTPChartElementView * | m_pParentView
The parent view.
CXTPChartContainer * | m_pContainer
The parent container.
CRect | m_rcBounds
Bounding rectangle.

Detailed Description

This class represents the view of a chart 2D diagram, which is a kind of CXTPChartDiagramView.

Constructor & Destructor Documentation

◆ CXTPChartDiagram2DView()

CXTPChartDiagram2DView | ( | CXTPChartDiagram * | pDiagram,
 |  | CXTPChartElementView * | pParent )

Constructs a CXTPChartDiagram2DView object.

Parameters
pDiagram | A pointer to the chart diagram object.
pParent | A pointer to the parent view object.

Member Function Documentation

◆ AddAxisView()

void AddAxisView | ( | CXTPChartDeviceContext * | pDC,
 |  | CXTPChartElementView * | pParentView,
 |  | CXTPChartAxis * | pAxis )

Use this function to add an axis view to the diagram view.

boundary.

Parameters
pDC | A pointer to the chart device context.
pParentView | The parent view of the axis view.
pAxis | A pointer to the axis object whose view is to be added.

◆ CalculateView()

void CalculateView | ( | CXTPChartDeviceContext * | pDC,
 |  | CRect | rcBounds )
 virtual

Call this function to calculate the layout based on a rectangular boundary.

Parameters
pDC | A pointer to the chart device context.
rcBounds | The diagram boundary.

Reimplemented from CXTPChartDiagramView.

◆ CreateDeviceCommand()

virtual CXTPChartDeviceCommand * CreateDeviceCommand ( CXTPChartDeviceContext * pDC )
virtual

This function creates a CXTPChartDeviceCommand object.

This object represents the rendering of the chart element.

Parameters
pDC Pointer to a CXTPChartDeviceContext object.
Returns
Returns a CXTPChartDeviceCommand object. This object handles the rendering of an element in the chart. Derived class objects will return more specific device command objects according to their type.

This is a virtual function, so sub-classes can override this function and can give specific implementations according to their type.

Reimplemented from CXTPChartDiagramView.

◆ CreateView()

void CreateView ( CXTPChartDeviceContext * pDC )
virtual

Call this function to create the view of the 2D diagram.

Parameters
pDC A pointer to the chart device context.

Reimplemented from CXTPChartDiagramView.

◆ GetAxisView()

CXTPChartAxisView * GetAxisView ( CXTPChartAxis * pAxis ) const

Call this function to get the view for an axis object.

Parameters
pAxis A pointer to the axis object whose view is to be returned.
Returns
The view for the specified axis object.

◆ GetPaneView()

AFX_INLINE CXTPChartDiagram2DPaneView * GetPaneView ( ) const

Call this function to get the diagram pane view object to which this CXTPChartDiagram2DView object is associated with.

Returns
Returns diagram pane view object

◆ OnMouseWheel()

virtual void OnMouseWheel | ( | UINT | nFlags,
 |  | short | zDelta,
 |  | CPoint | pt )
 virtual

Handles mouse wheel event.

Parameters
nFlags | Indicates whether various virtual keys are down.
zDelta | Indicates distance rotated.
pt | Specifies the x- and y-coordinate of the cursor.

Reimplemented from CXTPChartDiagramView.

◆ UpdateRange()

void UpdateRange ( CXTPChartDeviceContext * pDC )
virtual

Updates chart range.

Parameters
pDC Target device context.

Reimplemented from CXTPChartDiagramView.

The documentation for this class was generated from the following file:
  • XTPChartDiagram2DView.h


Toolkit Pro: CXTPChartDiagram3DAppearance Class Reference

Public Member Functions | Public Attributes | Static Public Attributes | List of all members
CXTPChartDiagram3DAppearance Class Reference

This class represents the appearance of diagram in 3D. More...

Inheritance diagram for CXTPChartDiagram3DAppearance:
[legend]

Public Member Functions

CXTPChartDiagram3DAppearance (CXTPChartElement *pOwner)
Constructs a CXTPChartDiagram3DAppearance object.
virtual | ~CXTPChartDiagram3DAppearance ()
Destroys a CXTPChartDiagram3DAppearance object, handles cleanup.
void | DoPropExchange (CXTPPropExchange *pPX)
Call this member function to Store/Load the properties related to the appearance of a diagram in 3D, using the specified data object.
virtual void | ApplyToDeviceContext (CXTPChartDeviceContext *pDC)
Applies implementation specific appearance settings to the device context provided.
- Public Member Functions inherited from CXTPChartElementAppearance
CXTPChartElementAppearance (CXTPChartElement *pOwner)
Constructs a CXTPChartElementAppearance object.
virtual | ~CXTPChartElementAppearance ()
Destroys a CXTPChartElementAppearance object, handles cleanup.
- Public Member Functions inherited from CXTPChartElement
CXTPChartElement ()
Constructs a CXTPChartElement object.
virtual | ~CXTPChartElement ()
Destroys a CXTPChartElement object, handles cleanup.
virtual void | Release ()
Call this function to decrease the usage count of the object.
CXTPChartElement * | GetOwner () const
Call this function to get the owner element.
virtual void | OnChartChanged (XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic properties of the chart.
CXTPChartContent * | GetContent () const
Call this virtual function to get the chart content object.
CXTPChartAppearance * | GetAppearance () const
Call this function to get the the appearance of the chart.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Public Attributes

CXTPChartColor | LightAmbientColor
Light ambient color.
CXTPChartColor | LightDiffuseColor
Light diffuse color.
CXTPChartColor | LightSpecularColor
Light specular color.
CXTPChartColor | LightModelAmbientColor
Light model ambient color.
CXTPChartColor | MaterialEmissionColor
Material emission color.
CXTPChartColor | MaterialDiffuseColor
Material diffuse color.
CXTPChartColor | MaterialSpecularColor
Material specular color.
float | MaterialShininess
Material shininess factor in range [0..1].
BOOL | Antialiasing
Antialiasing enable flag.
- Public Attributes inherited from CXTPChartElement

Static Public Attributes

static const CXTPPoint3f | DefaultLightPosition
Default light position vector, each component is a normalized value in range [0..1].
static const CXTPChartColor | DefaultLightAmbientColor
Default light ambient color.
static const CXTPChartColor | DefaultLightDiffuseColor
Default light diffuse color.
static const CXTPChartColor | DefaultLightSpecularColor
Default light specular color.
static const CXTPChartColor | DefaultLightModelAmbientColor
Default light model ambient color.
static const CXTPChartColor | DefaultMaterialEmissionColor
Default material emission color.
static const CXTPChartColor | DefaultMaterialDiffuseColor
Default material diffuse color.
static const CXTPChartColor | DefaultMaterialSpecularColor
Default material specular color.
static const float | DefaultMaterialShininess
Default material shininess factor in range [0..1].
static const BOOL | DefaultAntialiasing
Default antialiasing enable flag.

Additional Inherited Members

- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.
- Protected Attributes inherited from CXTPChartElement

Detailed Description

This class represents the appearance of diagram in 3D.

This class is subclassed from CXTPChartElementAppearance class.

Constructor & Destructor Documentation

◆ CXTPChartDiagram3DAppearance()

CXTPChartDiagram3DAppearance ( CXTPChartElement * pOwner )

Constructs a CXTPChartDiagram3DAppearance object.

Parameters
pOwner Pointer to an owner element.

Member Function Documentation

◆ ApplyToDeviceContext()

virtual void ApplyToDeviceContext ( CXTPChartDeviceContext * pDC )
virtual

Applies implementation specific appearance settings to the device context provided.

Parameters
pDC Target device context pointer.

Reimplemented from CXTPChartElementAppearance.

◆ DoPropExchange()

void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Call this member function to Store/Load the properties related to the appearance of a diagram in 3D, using the specified data object.

Parameters
pPX Source or destination CXTPPropExchange data object reference.

This member function is used to store or load property data to or from a storage.

Reimplemented from CXTPChartElement.

The documentation for this class was generated from the following file:
  • XTPChartAppearance.h


Toolkit Pro: CXTPChartDiagramDomain Class Reference

Public Member Functions | List of all members
CXTPChartDiagramDomain Class Reference

Represents a virtual diagram rectangular domain area. More...

Public Member Functions

CXTPChartDiagramDomain (const CXTPChartRectF &rcInnerBounds)
Constructs a diagram domain.
const CXTPChartRectF & GetInnerBounds () const
Determines the domain area boundary rectangle.

Detailed Description

Represents a virtual diagram rectangular domain area.

Constructor & Destructor Documentation

◆ CXTPChartDiagramDomain()

AFX_INLINE CXTPChartDiagramDomain ( const CXTPChartRectF & rcInnerBounds )

Constructs a diagram domain.

Parameters
rcInnerBounds Rectangle value that defines domain area.

Member Function Documentation

◆ GetInnerBounds()

AFX_INLINE const CXTPChartRectF & GetInnerBounds ( ) const

Determines the domain area boundary rectangle.

Returns
Domain area boundary rectangle
The documentation for this class was generated from the following file:
  • XTPChartDiagram.h


Toolkit Pro: CXTPChartDiagramView Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPChartDiagramView Class Reference

This class represents the view of a chart diagram, which is a kind of CXTPChartElementView. More...

Inheritance diagram for CXTPChartDiagramView:
[legend]

Public Member Functions

CXTPChartDiagramView (CXTPChartDiagram *pDiagram, CXTPChartElementView *pParentView)
Constructs a CXTPChartDiagram object.
CRect | GetBounds () const
Call this function to get the bounds of the diagram.
CXTPChartDiagram * | GetDiagram () const
Call this function to get the diagram object associated with the view.
CXTPChartElementView * | GetLabelsView () const
Call this function to get the label view object associated with this diagram view.
CXTPChartElementView * | GetSeriesView () const
Call this function to get the series view object associated with this diagram view.
virtual void | CalculateView (CXTPChartDeviceContext *pDC, CRect rcBounds)
Call this function to calculate the view of the diagram.
virtual void | UpdateRange (CXTPChartDeviceContext *pDC)
Updates chart range.
virtual void | OnMouseWheel (UINT nFlags, short zDelta, CPoint pt)
Handles mouse wheel event.
virtual void | CreateView (CXTPChartDeviceContext *pDC)
Performs view initialization.
- Public Member Functions inherited from CXTPChartElementView
CXTPChartElementView (CXTPChartElementView *pParentView)
Constructs a CXTPChartElementView object.
CXTPChartElementView (CXTPChartElementView *pParentView, BOOL bAddToParent)
Constructs a CXTPChartElementView object.
CXTPChartElementView (CXTPChartContainer *pContainer)
Constructs a CXTPChartElementView object.
int | GetCount () const
Call this function to get the number of child views associated with this view.
CXTPChartElementView * | GetAt (int nIndex) const
Call this function to get a child view at a particular index.
CXTPChartElementView * | GetParentView () const
Call this function to get the parent view.
CXTPChartElementView * | AddChildView (CXTPChartElementView *pChildView)
Call this function to add a child view to the current view.
CXTPChartElementView ** GetChildren ()
Provides access to the collection of children elements owned by the view.
CRect | GetBounds () const
Obtains viewed object's bound rectangle.
CRect | GetBounds (BOOL bIncludingChildren) const
Obtains viewed object's bound rectangle.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Protected Member Functions

virtual CXTPChartDeviceCommand * | CreateDeviceCommand (CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
- Protected Member Functions inherited from CXTPChartElementView
virtual | ~CXTPChartElementView ()
Destroys a CXTPChartElementView object, handles cleanup.
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.

Protected Attributes

CXTPChartDiagram * | m_pDiagram
Pointer to the associated diagram object.
CRect | m_rcBounds
The diagram bounds.
CXTPChartElementView * | m_pLabelsView
The label view.
CXTPChartElementView * | m_pSeriesView
The series view.
CXTPChartElementView * | m_pTitlesView
Titles View.
- Protected Attributes inherited from CXTPChartElementView
CArray< CXTPChartElementView *, CXTPChartElementView * > | m_arrChildren
The child view collection.
CXTPChartElementView * | m_pParentView
The parent view.
CXTPChartContainer * | m_pContainer
The parent container.
CRect | m_rcBounds
Bounding rectangle.

Detailed Description

This class represents the view of a chart diagram, which is a kind of CXTPChartElementView.

Constructor & Destructor Documentation

◆ CXTPChartDiagramView()

CXTPChartDiagramView | ( | CXTPChartDiagram * | pDiagram,
 |  | CXTPChartElementView * | pParentView )

Constructs a CXTPChartDiagram object.

Parameters
pDiagram | A pointer to the chart diagram object.
pParentView | A pointer to the parent view.

Member Function Documentation

◆ CalculateView()

virtual void CalculateView | ( | CXTPChartDeviceContext * | pDC,
 |  | CRect | rcBounds )
 virtual

Call this function to calculate the view of the diagram.

Parameters
pDC | Pointer to the chart device context object.
rcBounds | The bounding rectangle.

This is a virtual function, so sub classes can give their type specific implementation for this function.

Reimplemented in CXTPChartDiagram2DView, and CXTPChartRadarDiagramView.

◆ CreateDeviceCommand()

virtual CXTPChartDeviceCommand * CreateDeviceCommand ( CXTPChartDeviceContext * pDC )
protectedvirtual

This function creates a CXTPChartDeviceCommand object.

This object represents the rendering of the chart element.

Parameters
pDC Pointer to a CXTPChartDeviceContext object.
Returns
Returns a CXTPChartDeviceCommand object. This object handles the rendering of an element in the chart. Derived class objects will return more specific device command objects according to their type.

This is a virtual function, so sub-classes can override this function and can give specific implementations according to their type.

Reimplemented from CXTPChartElementView.

Reimplemented in CXTPChart3dDiagramView, CXTPChartDiagram2DView, and CXTPChartRadarDiagramView.

◆ CreateView()

virtual void CreateView ( CXTPChartDeviceContext * pDC )
virtual

Performs view initialization.

Parameters
pDC Target device context.

Reimplemented in CXTPChartDiagram2DView, and CXTPChartRadarDiagramView.

◆ GetBounds()

AFX_INLINE CRect GetBounds ( ) const

Call this function to get the bounds of the diagram.

Returns
A CRect object containing the bounds of the diagram.

◆ GetDiagram()

AFX_INLINE CXTPChartDiagram * GetDiagram ( ) const

Call this function to get the diagram object associated with the view.

Returns
A CXTPChartDiagram pointer. The actual type could be CXTPChartDiagram2D or CXTPChartDiagram3D.

◆ GetLabelsView()

AFX_INLINE CXTPChartElementView * GetLabelsView ( ) const

Call this function to get the label view object associated with this diagram view.

Returns
A CXTPChartElementView pointer representing the label view.

◆ GetSeriesView()

AFX_INLINE CXTPChartElementView * GetSeriesView ( ) const

Call this function to get the series view object associated with this diagram view.

Returns
A CXTPChartElementView pointer representing the series view.

◆ OnMouseWheel()

virtual void OnMouseWheel | ( | UINT | nFlags,
 |  | short | zDelta,
 |  | CPoint | pt )
 virtual

Handles mouse wheel event.

Parameters
nFlags | Indicates whether various virtual keys are down.
zDelta | Indicates distance rotated.
pt | Specifies the x- and y-coordinate of the cursor.

Reimplemented in CXTPChartDiagram2DView.

◆ UpdateRange()

virtual void UpdateRange ( CXTPChartDeviceContext * pDC )
virtual

Updates chart range.

Parameters
pDC Target device context.

Reimplemented in CXTPChartDiagram2DView, and CXTPChartRadarDiagramView.

The documentation for this class was generated from the following file:
  • XTPChartDiagramView.h


Toolkit Pro: CXTPChartDrawingObjectFactory Class Reference

List of all members
CXTPChartDrawingObjectFactory Class Referenceabstract

Provides a set of factory methods for creating drawing device commands and a base class interface for an abstract drawing object factory. More...

Inheritance diagram for CXTPChartDrawingObjectFactory:
[legend]

Detailed Description

Provides a set of factory methods for creating drawing device commands and a base class interface for an abstract drawing object factory.

See also
CXTPChart2dDrawingObjectFactory, CXTPChart3dDrawingObjectFactory
The documentation for this class was generated from the following file:
  • XTPChartDrawingObjectFactory.h


Toolkit Pro: CXTPChartElement Class Reference

Public Member Functions | List of all members
CXTPChartElement Class Reference

This class abstracts a chart element, this class acts as a base class for all chart elements. More...

Inheritance diagram for CXTPChartElement:
[legend]

Public Member Functions

CXTPChartElement ()
Constructs a CXTPChartElement object.
virtual | ~CXTPChartElement ()
Destroys a CXTPChartElement object, handles cleanup.
virtual void | Release ()
Call this function to decrease the usage count of the object.
CXTPChartElement * | GetOwner () const
Call this function to get the owner element.
virtual void | OnChartChanged (XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic properties of the chart.
CXTPChartContent * | GetContent () const
Call this virtual function to get the chart content object.
CXTPChartAppearance * | GetAppearance () const
Call this function to get the the appearance of the chart.
virtual void | DoPropExchange (CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Additional Inherited Members

- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.

Detailed Description

This class abstracts a chart element, this class acts as a base class for all chart elements.

This is an MFC class, which has capacity to route Windows command messages. Each element has an owner element.

Member Function Documentation

◆ DoPropExchange()

virtual void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Reads this object from or writes this object to an archive.

Parameters
pPX A CXTPPropExchange object to serialize to or from.

Reimplemented in CXTPChart3dFunnelSeriesStyle, CXTPChart3dPieSeriesStyle, CXTPChart3dPyramidSeriesStyle, CXTPChartAppearance, CXTPChartAreaSeriesStyle, CXTPChartAxis, CXTPChartAxisAppearance, CXTPChartAxisConstantLine, CXTPChartAxisConstantLines, CXTPChartAxisCustomLabel, CXTPChartAxisCustomLabels, CXTPChartAxisGridLines, CXTPChartAxisLabel, CXTPChartAxisRange, CXTPChartAxisStrip, CXTPChartAxisStrips, CXTPChartAxisTickMarks, CXTPChartAxisTitle, CXTPChartBarSeriesLabel, CXTPChartBarSeriesStyle, CXTPChartBorder, CXTPChartBubbleSeriesStyle, CXTPChartContent, CXTPChartContentAppearance, CXTPChartDiagram2D, CXTPChartDiagram2DAppearance, CXTPChartDiagram2DSeriesLabel, CXTPChartDiagram2DSeriesStyle, CXTPChartDiagram3DAppearance, CXTPChartDiagram, CXTPChartFastLineSeriesStyle, CXTPChartFinanceStyleAppearance, CXTPChartFunnelSeriesLabelBase, CXTPChartFunnelSeriesStyleBase, CXTPChartGanttSeriesStyle, CXTPChartLegend, CXTPChartLegendAppearance, CXTPChartLineSeriesStyle, CXTPChartMarker, CXTPChartNumberFormat, CXTPChartPalette, CXTPChartPanel, CXTPChartPanelCollection, CXTPChartPieSeriesLabelBase, CXTPChartPieSeriesStyleBase, CXTPChartPieStyleAppearance, CXTPChartPointSeriesLabel, CXTPChartPointSeriesStyle, CXTPChartPyramidSeriesLabelBase, CXTPChartPyramidSeriesStyleBase, CXTPChartRadarAreaSeriesStyle, CXTPChartRadarDiagram, CXTPChartRadarDiagramSeriesStyle, CXTPChartRadarLineSeriesStyle, CXTPChartRadarPointSeriesLabel, CXTPChartRadarPointSeriesStyle, CXTPChartRangeAreaSeriesLabel, CXTPChartRangeBarSeriesLabel, CXTPChartRangeBarSeriesStyle, CXTPChartSeries, CXTPChartSeriesCollection, CXTPChartSeriesLabel, CXTPChartSeriesPoint, CXTPChartSeriesPointCollection, CXTPChartSeriesStyle, CXTPChartStackedBarSeriesStyle, CXTPChartStepAreaSeriesStyle, CXTPChartStepLineSeriesStyle, CXTPChartTitle, CXTPChartTitleAppearance, and CXTPChartTitleCollection.

◆ GetAppearance()

CXTPChartAppearance * GetAppearance ( ) const

Call this function to get the the appearance of the chart.

Returns
A pointer to a CXTPChartAppearance object.

◆ GetContent()

CXTPChartContent * GetContent ( ) const

Call this virtual function to get the chart content object.

Returns
A pointer to the chart content object.

A chart content object is an aggregate of various chart components like panels, titles, series, legend etc.

◆ GetOwner()

AFX_INLINE CXTPChartElement * GetOwner ( ) const

Call this function to get the owner element.

Returns
Returns the parent CXTPChartElement.

◆ OnChartChanged()

virtual void OnChartChanged ( XTPChartUpdateOptions updateOptions = xtpChartUpdateView )
virtual

Call this virtual function to trigger a re-painting when there is a change in the intrinsic properties of the chart.

Parameters
updateOptions Options which indicate the kind of change performed.

Reimplemented in CXTPChartContent.

The documentation for this class was generated from the following file:
  • XTPChartElement.h


Toolkit Pro: CXTPChartElementAppearance Class Reference

Public Member Functions | List of all members
CXTPChartElementAppearance Class Reference

This class represents the appearance of a chart element. More...

Inheritance diagram for CXTPChartElementAppearance:
[legend]

Public Member Functions

CXTPChartElementAppearance (CXTPChartElement *pOwner)
Constructs a CXTPChartElementAppearance object.
virtual | ~CXTPChartElementAppearance ()
Destroys a CXTPChartElementAppearance object, handles cleanup.
virtual void | ApplyToDeviceContext (CXTPChartDeviceContext *pDC)
Applies implementation specific appearance settings to the device context provided.
- Public Member Functions inherited from CXTPChartElement
CXTPChartElement ()
Constructs a CXTPChartElement object.
virtual | ~CXTPChartElement ()
Destroys a CXTPChartElement object, handles cleanup.
virtual void | Release ()
Call this function to decrease the usage count of the object.
CXTPChartElement * | GetOwner () const
Call this function to get the owner element.
virtual void | OnChartChanged (XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic properties of the chart.
CXTPChartContent * | GetContent () const
Call this virtual function to get the chart content object.
CXTPChartAppearance * | GetAppearance () const
Call this function to get the the appearance of the chart.
virtual void | DoPropExchange (CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Additional Inherited Members

- Public Attributes inherited from CXTPChartElement
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.
- Protected Attributes inherited from CXTPChartElement

Detailed Description

This class represents the appearance of a chart element.

Constructor & Destructor Documentation

◆ CXTPChartElementAppearance()

CXTPChartElementAppearance ( CXTPChartElement * pOwner )

Constructs a CXTPChartElementAppearance object.

Parameters
pOwner Pointer to an owner element.

Member Function Documentation

◆ ApplyToDeviceContext()

virtual void ApplyToDeviceContext ( CXTPChartDeviceContext * pDC )
virtual

Applies implementation specific appearance settings to the device context provided.

Parameters
pDC Target device context pointer.

Reimplemented in CXTPChartDiagram3DAppearance.

The documentation for this class was generated from the following file:
  • XTPChartAppearance.h


Toolkit Pro: CXTPChartElementCollection Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPChartElementCollection Class Reference

This class abstracts a chart collection. More...

Inheritance diagram for CXTPChartElementCollection:
[legend]

Public Member Functions

CXTPChartElementCollection ()
Constructs a CXTPChartElementCollection object.
~CXTPChartElementCollection ()
Destroys a CXTPChartElementCollection object, handles cleanup.
virtual void | RemoveAll ()
This function removes all the individual objects from this collection object.
virtual int | GetCount () const
Call this function to get the number of objects in the internal array of this object.
virtual void | RemoveAt (int nIndex)
Use this function to remove an object from the collection.
virtual void | Remove (CXTPChartElement *pElement)
Use this function to remove an object from the collection.
CXTPChartElement * | GetAt (int nIndex) const
Call this function to get an element by its index.
int | IndexOf (CXTPChartElement *pElement) const
Call this function to get the index of a specified element.
void | InsertAt (int nIndex, CXTPChartElement *pElement)
Call this method to add a new element to the collection.
virtual void | Release ()
Call this function to decrease the usage count of the object.
- Public Member Functions inherited from CXTPChartElement
CXTPChartElement ()
Constructs a CXTPChartElement object.
virtual | ~CXTPChartElement ()
Destroys a CXTPChartElement object, handles cleanup.
CXTPChartElement * | GetOwner () const
Call this function to get the owner element.
virtual void | OnChartChanged (XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic properties of the chart.
CXTPChartContent * | GetContent () const
Call this virtual function to get the chart content object.
CXTPChartAppearance * | GetAppearance () const
Call this function to get the the appearance of the chart.
virtual void | DoPropExchange (CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Protected Attributes

CArray< CXTPChartElement *, CXTPChartElement * > m_arrElements
Array of CXTPChartElement pointer.
- Protected Attributes inherited from CXTPChartElement

Additional Inherited Members

- Public Attributes inherited from CXTPChartElement
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.

Detailed Description

This class abstracts a chart collection.

This class is a kind of CXTPChartElement class.

This class acts as an abstract base class for collection objects such as a collection of points, titles, panels, strips.

Member Function Documentation

◆ GetAt()

AFX_INLINE CXTPChartElement * GetAt ( int nIndex ) const

Call this function to get an element by its index.

Parameters
nIndex Index of the object to get.
Returns
Element by its index.

◆ GetCount()

AFX_INLINE int GetCount ( ) const
virtual

Call this function to get the number of objects in the internal array of this object.

Returns
The number of point elements present in this object.

◆ IndexOf()

int IndexOf ( CXTPChartElement * pElement ) const

Call this function to get the index of a specified element.

Parameters
pElement Object to test.
Returns
Index of pElement inside internal collection.

◆ InsertAt()

void InsertAt | ( | int | nIndex,
 |  | CXTPChartElement * | pElement )

Call this method to add a new element to the collection.

Parameters
pElement | Object to add.
nIndex | Index of object to add.

◆ Remove()

virtual void Remove ( CXTPChartElement * pElement )
virtual

Use this function to remove an object from the collection.

Parameters
pElement Object to remove.

◆ RemoveAll()

virtual void RemoveAll ( )
virtual

This function removes all the individual objects from this collection object.

See also
RemoveAt

◆ RemoveAt()

virtual void RemoveAt ( int nIndex )
virtual

Use this function to remove an object from the collection.

Parameters
nIndex Index of the object to remove.
The documentation for this class was generated from the following file:
  • XTPChartElement.h


Toolkit Pro: CXTPChartElementView Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPChartElementView Class Reference

This class represents the view of a chart element. More...

Inheritance diagram for CXTPChartElementView:
[legend]

Public Member Functions

CXTPChartElementView (CXTPChartElementView *pParentView)
Constructs a CXTPChartElementView object.
CXTPChartElementView (CXTPChartElementView *pParentView, BOOL bAddToParent)
Constructs a CXTPChartElementView object.
CXTPChartElementView (CXTPChartContainer *pContainer)
Constructs a CXTPChartElementView object.
int | GetCount () const
Call this function to get the number of child views associated with this view.
CXTPChartElementView * | GetAt (int nIndex) const
Call this function to get a child view at a particular index.
virtual CXTPChartDeviceCommand * | CreateDeviceCommand (CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
CXTPChartElementView * | GetParentView () const
Call this function to get the parent view.
CXTPChartElementView * | AddChildView (CXTPChartElementView *pChildView)
Call this function to add a child view to the current view.
CXTPChartElementView ** GetChildren ()
Provides access to the collection of children elements owned by the view.
CRect | GetBounds () const
Obtains viewed object's bound rectangle.
CRect | GetBounds (BOOL bIncludingChildren) const
Obtains viewed object's bound rectangle.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Protected Member Functions

virtual ~CXTPChartElementView ()
Destroys a CXTPChartElementView object, handles cleanup.
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.

Protected Attributes

CArray< CXTPChartElementView *, CXTPChartElementView * > | m_arrChildren
The child view collection.
CXTPChartElementView * | m_pParentView
The parent view.
CXTPChartContainer * | m_pContainer
The parent container.
CRect | m_rcBounds
Bounding rectangle.

Detailed Description

This class represents the view of a chart element.

All views have a parent view and one or more child views.

This a base class for the views of various chart elements like axis, legend, diagram, tick marks etc.

Constructor & Destructor Documentation

◆ CXTPChartElementView() [1/3]

CXTPChartElementView ( CXTPChartElementView * pParentView )

Constructs a CXTPChartElementView object.

Parameters
pParentView A pointer to the parent view.

◆ CXTPChartElementView() [2/3]

CXTPChartElementView | ( | CXTPChartElementView * | pParentView,
 |  | BOOL | bAddToParent )

Constructs a CXTPChartElementView object.

Parameters
pParentView | A pointer to the parent view.
bAddToParent | If TRUE, then the view will be added to parent's child elements.

◆ CXTPChartElementView() [3/3]

CXTPChartElementView ( CXTPChartContainer * pContainer )

Constructs a CXTPChartElementView object.

Parameters
pContainer Parent container pointer.

Member Function Documentation

◆ AddChildView()

CXTPChartElementView * AddChildView ( CXTPChartElementView * pChildView )

Call this function to add a child view to the current view.

Parameters
pChildView A pointer to a chart element view object.
Returns
Adds a child view to current view

◆ CreateDeviceCommand()

virtual CXTPChartDeviceCommand * CreateDeviceCommand ( CXTPChartDeviceContext * pDC )
virtual

This function creates a CXTPChartDeviceCommand object.

This object represents the rendering of the chart element.

Parameters
pDC Pointer to a CXTPChartDeviceContext object.
Returns
Returns a CXTPChartDeviceCommand object. This object handles the rendering of an element in the chart. Derived class objects will return more specific device command objects according to their type.

This is a virtual function, so sub-classes can override this function and can give specific implementations according to their type.

Reimplemented in CXTPChart3dDiagramView, CXTPChart3dFunnelSeriesLabelsView, CXTPChart3dFunnelSeriesLabelView, CXTPChart3dFunnelSeriesPointView, CXTPChart3dFunnelSeriesView, CXTPChart3dPieSeriesLabelsView, CXTPChart3dPieSeriesLabelView, CXTPChart3dPieSeriesPointView, CXTPChart3dPieSeriesView, CXTPChart3dPyramidSeriesLabelsView, CXTPChart3dPyramidSeriesLabelView, CXTPChart3dPyramidSeriesPointView, CXTPChart3dPyramidSeriesView, CXTPChartAreaSeriesView, CXTPChartBarSeriesLabelView, CXTPChartBarSeriesPointView, CXTPChartBubbleSeriesLabelView, CXTPChartBubbleSeriesPointView, CXTPChartBubbleSeriesView, CXTPChartCandleStickSeriesPointView, CXTPChartContentView, CXTPChartDiagram2DAxisView, CXTPChartDiagram2DSeriesLabelView, CXTPChartDiagram2DView, CXTPChartDiagramView, CXTPChartFastLineSeriesView, CXTPChartFunnelSeriesLabelView, CXTPChartFunnelSeriesLabelViewBase, CXTPChartFunnelSeriesPointView, CXTPChartFunnelSeriesPointViewBase, CXTPChartFunnelSeriesView, CXTPChartFunnelSeriesViewBase, CXTPChartHighLowSeriesPointView, CXTPChartLegendView, CXTPChartLineSeriesView, CXTPChartPieSeriesLabelsView, CXTPChartPieSeriesLabelsViewBase, CXTPChartPieSeriesLabelView, CXTPChartPieSeriesLabelViewBase, CXTPChartPieSeriesPointView, CXTPChartPieSeriesPointViewBase, CXTPChartPieSeriesView, CXTPChartPieSeriesViewBase, CXTPChartPointSeriesPointView, CXTPChartPyramidSeriesLabelView, CXTPChartPyramidSeriesLabelViewBase, CXTPChartPyramidSeriesPointView, CXTPChartPyramidSeriesPointViewBase, CXTPChartPyramidSeriesView, CXTPChartPyramidSeriesViewBase, CXTPChartRadarAreaSeriesView, CXTPChartRadarAxisXView, CXTPChartRadarAxisYView, CXTPChartRadarDiagramView, CXTPChartRadarLineSeriesView, CXTPChartRadarPointSeriesLabelView, CXTPChartRadarPointSeriesPointView, CXTPChartRadarSplineAreaSeriesView, CXTPChartRadarSplineSeriesView, CXTPChartRangeAreaSeriesLabelView, CXTPChartRangeBarSeriesLabelView, CXTPChartRangeBarSeriesPointView, CXTPChartRangeSplineAreaSeriesPointView, CXTPChartRangeSplineAreaSeriesView, CXTPChartSplineAreaSeriesView, CXTPChartSplineSeriesView, CXTPChartStackedAreaSeriesView, CXTPChartStackedBarSeriesPointView, CXTPChartStackedSplineAreaSeriesView, CXTPChartStepAreaSeriesView, and CXTPChartStepLineSeriesView.

◆ GetAt()

AFX_INLINE CXTPChartElementView * GetAt ( int nIndex ) const

Call this function to get a child view at a particular index.

Parameters
nIndex Point index.
Returns
A pointer to a chart element view object.

◆ GetBounds() [1/2]

AFX_INLINE CRect GetBounds ( ) const

Obtains viewed object's bound rectangle.

Returns
Viewed object's bound rectangle.

◆ GetBounds() [2/2]

CRect GetBounds ( BOOL bIncludingChildren ) const

Obtains viewed object's bound rectangle.

Parameters
bIncludingChildren If TRUE, the bounding rectangle will include all children objects' rectangles.
Returns
Viewed object's bound rectangle.

◆ GetChildren()

AFX_INLINE CXTPChartElementView ** GetChildren ( )

Provides access to the collection of children elements owned by the view.

Returns
A pointer to the first element in the collection. The total number of elements can be determined by use GetCount method.
See also
GetCount

◆ GetCount()

AFX_INLINE int GetCount ( ) const

Call this function to get the number of child views associated with this view.

Returns
An integer specifying the number of children.

◆ GetParentView()

AFX_INLINE CXTPChartElementView * GetParentView ( ) const

Call this function to get the parent view.

Returns
A pointer to a chart element view object.
The documentation for this class was generated from the following file:
  • XTPChartElementView.h


Toolkit Pro: CXTPChartEllipse Class Reference

Public Member Functions | Public Attributes | List of all members
CXTPChartEllipse Class Reference

This class abstracts an ellipse. More...

Public Member Functions

CXTPChartEllipse ()
Constructs a CXTPChartEllipse object.
CXTPChartEllipse (const CXTPPoint3d &ptCenter, double dMajorSemiaxis, double dMinorSemiaxis)
Overloaded constructor, creates a CXTPChartSplineSeriesView object.
double | GetArea () const
Call this function to get the area of the ellipse.
CXTPPoint3d | GetCenter () const
Call this function to get the center of the ellipse.
double | CalcEllipseSectorFinishAngle (double areaSector, double startAngle) const
Call this function to get the finish angle from a start angle and area of a sector.
CXTPPoint3d | Polar2Cartesian (double angle, double radius) const
Call this function to convert polar coordinates to Cartesian co-ordinates.
double | CalcEllipseRadius (double angle) const
Call this function to calculate the radius of the ellipse from the given angle.
CXTPPoint3d | CalcEllipsePoint (double angle) const
Call this function to calculate the ellipse Cartesian point on a given angle.
double | CalcEllipseSectorArea (double startAngle, double finishAngle) const
Call this function to calculate the sector area from a start angle and finish angle.
double | CalcEllipseAngleFromCircleAngle (double angle) const
Call this function to calculate the ellipse angle from the circle angle.
CXTPPoint3d | ApplyCenterPoint (const CXTPPoint3d &point) const
Call this function to apply the center point of the ellipse.

Public Attributes

CXTPPoint3d | m_ptCenter
The center of the ellipse.
double | m_dMajorSemiaxis
The major semi axis of the ellipse.
double | m_dMinorSemiaxis
The minor semi axis of the ellipse.
double | m_dArea
The area of the ellipse.

Detailed Description

This class abstracts an ellipse.

Constructor & Destructor Documentation

◆ CXTPChartEllipse()

CXTPChartEllipse | ( | const CXTPPoint3d & | ptCenter,
 |  | double | dMajorSemiaxis,
 |  | double | dMinorSemiaxis )

Overloaded constructor, creates a CXTPChartSplineSeriesView object.

Parameters
ptCenter | The center point of the ellipse.
dMajorSemiaxis | The length of the major semi axis.
dMinorSemiaxis | The length of the minor semi axis.

Member Function Documentation

◆ ApplyCenterPoint()

CXTPPoint3d ApplyCenterPoint ( const CXTPPoint3d & point ) const

Call this function to apply the center point of the ellipse.

Parameters
point The center point.
Returns
A CXTPPoint3d value specifying the new center point.

◆ CalcEllipseAngleFromCircleAngle()

double CalcEllipseAngleFromCircleAngle ( double angle ) const

Call this function to calculate the ellipse angle from the circle angle.

Parameters
angle The circle angle.
Returns
A double value ellipse angle.

◆ CalcEllipsePoint()

CXTPPoint3d CalcEllipsePoint ( double angle ) const

Call this function to calculate the ellipse Cartesian point on a given angle.

Parameters
angle The angle in degrees.
Returns
A CXTPPoint3d denoting the Cartesian coordinate.

◆ CalcEllipseRadius()

double CalcEllipseRadius ( double angle ) const

Call this function to calculate the radius of the ellipse from the given angle.

Parameters
angle The angle in degrees.
Returns
A double value specifying the radius of the ellipse.

◆ CalcEllipseSectorArea()

double CalcEllipseSectorArea | ( | double | startAngle,
 |  | double | finishAngle ) const

Call this function to calculate the sector area from a start angle and finish angle.

Parameters
startAngle | The start angle in degree.
finishAngle | The finish angle in degree.
Returns
A double value specifying the sector area.

◆ CalcEllipseSectorFinishAngle()

double CalcEllipseSectorFinishAngle | ( | double | areaSector,
 |  | double | startAngle ) const

Call this function to get the finish angle from a start angle and area of a sector.

Parameters
areaSector | Area sector value
startAngle | The start angle in degree
Returns
A double value specifying the finish angle.

◆ GetArea()

AFX_INLINE double GetArea ( ) const

Call this function to get the area of the ellipse.

Returns
A double value specifying the area of the ellipse.

◆ GetCenter()

AFX_INLINE CXTPPoint3d GetCenter ( ) const

Call this function to get the center of the ellipse.

Returns
A CXTPPoint3d value specifying the center point of the ellipse.

◆ Polar2Cartesian()

CXTPPoint3d Polar2Cartesian | ( | double | angle,
 |  | double | radius ) const

Call this function to convert polar coordinates to Cartesian co-ordinates.

Parameters
angle | The angle in degrees.
radius | The radius of the point.
Returns
A CXTPPoint3d specifying the Cartesian co-ordinate.
The documentation for this class was generated from the following file:
  • XTPChartPie.h


Toolkit Pro: CXTPChartFastLineSeriesStyle Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPChartFastLineSeriesStyle Class Reference

This class represents a line series style, which is a kind of CXTPChartPointSeriesStyle. More...

Inheritance diagram for CXTPChartFastLineSeriesStyle:
[legend]

Public Member Functions

CXTPChartFastLineSeriesStyle ()
Constructs a CXTPChartFastLineSeriesStyle object.
virtual | ~CXTPChartFastLineSeriesStyle ()
Destroys a CXTPChartFastLineSeriesStyle object, handles cleanup.
CXTPChartLineStyle * | GetLineStyle () const
Call this function to get the line style of the line series.
BOOL | GetAntialiasing () const
Enables/disables antialiasing if supported.
void | SetAntialiasing (BOOL bEnable=TRUE)
Enables/disables antialiasing if supported.
- Public Member Functions inherited from CXTPChartDiagram2DSeriesStyle
CXTPChartDiagram2DSeriesStyle ()
Constructs a CXTPChartDiagram2DSeriesStyle object.
virtual | ~CXTPChartDiagram2DSeriesStyle ()
Destroys a CXTPChartDiagram2DSeriesStyle object, handles cleanup.
virtual CXTPChartDiagram * | CreateDiagram ()
Call this function to create the diagram for this series.
virtual BOOL | IsStyleDiagram (CXTPChartDiagram *pDiagram) const
Call this function to check whether the chart diagram object passed is a kind of 2D diagram (CXTPChartDiagram2D object).
- Public Member Functions inherited from CXTPChartSeriesStyle
CXTPChartSeriesStyle ()
Constructs a CXTPChartSeriesStyle object.
virtual | ~CXTPChartSeriesStyle ()
Destroys a CXTPChartSeriesStyle object, handles cleanup.
virtual CXTPChartSeriesLabel * | GetLabel () const
Call this method to gets the series label object.
virtual CXTPChartSeriesLabel * | SetLabel (CXTPChartSeriesLabel *pLabel)
Call this method to sets the series label object.
virtual CXTPChartErrorBar * | GetErrorBar () const
Call this method to gets the error bar object.
virtual CXTPChartErrorBar * | SetErrorBar (CXTPChartErrorBar *pErrorBar)
Call this method to sets the error bar object.
virtual CXTPChartColor | GetColor () const
Call this method to get the color of the series.
virtual void | SetColor (CXTPChartColor clr)
Call this method to set the color of the series.
virtual void | SetColorEach (BOOL bColorEach)
Call this method to set individual color for each point of the series.
virtual BOOL | IsColorEach () const
This method is called to check if individual color is used for each point of the series.
virtual CXTPChart3dRotation | Get3dRotation () const
Obtains rotation parameters for 3D chart.
virtual void | Set3dRotation (const CXTPChart3dRotation &rotation)
Sets rotation parameters for 3D chart.
virtual void | Set3dRotation (double dYaw, double dPitch, double dRoll)
Sets rotation parameters for 3D chart.
virtual BOOL | Is3dEdgeSmoothingEnabled () const
Enables/disables 3D edge smoothing.
virtual void | Enable3dEdgeSmoothing (BOOL bEnable=TRUE)
Enables/disables 3D edge smoothing.
virtual int | GetTransparency () const
Call this function to gets the transparency of the chart if it is supported by the chart type.
virtual void | SetTransparency (int nTransparency)
Call this function to sets the transparency of the chart if it is supported by the chart type.
virtual void | CorrectAxisSideMargins (CXTPChartAxis *pAxis, double nMinValue, double nMaxValue, double &nCorrection)
Provides default implementation for axis side margins correction.
virtual CXTPChartSeriesStyleAppearance * | GetStyleAppearance () const
Obtains associated style appearance pointer.
virtual void | ApplyTo (CXTPChartDeviceCommand *pCommand)
Applies the style to the command provided in case the command needs style specific details for correct drawing.
virtual int | GetSeriesPointValueIndex () const
Obtains the index of a point element for which an internal value can be otained.
- Public Member Functions inherited from CXTPChartElement
CXTPChartElement ()
Constructs a CXTPChartElement object.
virtual | ~CXTPChartElement ()
Destroys a CXTPChartElement object, handles cleanup.
virtual void | Release ()
Call this function to decrease the usage count of the object.
CXTPChartElement * | GetOwner () const
Call this function to get the owner element.
virtual void | OnChartChanged (XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic properties of the chart.
CXTPChartContent * | GetContent () const
Call this virtual function to get the chart content object.
CXTPChartAppearance * | GetAppearance () const
Call this function to get the the appearance of the chart.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Protected Member Functions

virtual CXTPChartSeriesView * | CreateView (CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Call this function to create a view of the line series.
void | DoPropExchange (CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.

Protected Attributes

CXTPChartLineStyle * | m_pLineStyle
The line style.
- Protected Attributes inherited from CXTPChartDiagram2DSeriesStyle
int | m_nAxisIndexX
Holds index of secondary axisX, used when m_bSecondaryAxisX is TRUE.
int | m_nAxisIndexY
Holds index of secondary axisY, used when m_bSecondaryAxisY is TRUE.
- Protected Attributes inherited from CXTPChartSeriesStyle
CXTPChartSeriesLabel * | m_pLabel
Label object.
CXTPChartErrorBar * | m_pErrorBar
Error bar object.
CXTPChartColor | m_clrColor
Custom color of series.
BOOL | m_bColorEach
TRUE to color each point.
int | m_nTransparency
The transparency value in the range 0..255.
CXTPChart3dRotation | m_Rotation3d
3D rotation
BOOL | m_bSmooth3dEdges
3D edge smoothing
- Protected Attributes inherited from CXTPChartElement

Detailed Description

This class represents a line series style, which is a kind of CXTPChartPointSeriesStyle.

A line chart or line graph is a type of graph which displays information as a series of data points connected by straight line segments. It is a basic type of chart common in many fields.

Member Function Documentation

◆ CreateView()

virtual CXTPChartSeriesView * CreateView | ( | CXTPChartSeries * | pSeries,
 |  | CXTPChartDiagramView * | pDiagramView )
 protectedvirtual

Call this function to create a view of the line series.

Parameters
pSeries | A pointer to the chart series object.
pDiagramView | A pointer to the diagram view object.
Returns
Returns a pointer to the associated series view object.

Implements CXTPChartSeriesStyle.

◆ DoPropExchange()

void DoPropExchange ( CXTPPropExchange * pPX )
protectedvirtual

Reads this object from or writes this object to an archive.

Parameters
pPX A CXTPPropExchange object to serialize to or from.

Reimplemented from CXTPChartDiagram2DSeriesStyle.

◆ GetAntialiasing()

AFX_INLINE BOOL GetAntialiasing ( ) const

Enables/disables antialiasing if supported.

Returns
TRUE if antialiasing is enabled, FALSE otherwise.

◆ GetLineStyle()

AFX_INLINE CXTPChartLineStyle * GetLineStyle ( ) const

Call this function to get the line style of the line series.

Returns
A pointer to a chart line style object.

◆ SetAntialiasing()

AFX_INLINE void SetAntialiasing ( BOOL bEnable = TRUE )

Enables/disables antialiasing if supported.

Parameters
bEnable TRUE to enable antialiasing, FALSE to disable.
The documentation for this class was generated from the following file:
  • XTPChartFastLineSeriesStyle.h


Toolkit Pro: CXTPChartFastLineSeriesView Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPChartFastLineSeriesView Class Reference

This class represents the view of a line series, which is a kind of CXTPChartSeriesView. More...

Public Member Functions

CXTPChartFastLineSeriesView (CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Constructs a CXTPChartLineSeriesView object.

Protected Member Functions

CXTPChartSeriesPointView * | CreateSeriesPointView (CXTPChartDeviceContext *pDC, CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Call this function to create a view of the line series point.
virtual CXTPChartDeviceCommand * | CreateDeviceCommand (CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
virtual CXTPChartDeviceCommand * | CreateLegendDeviceCommand (CXTPChartDeviceContext *pDC, CRect rcBounds)
This function creates a label view drawing command object.
void | CreatePointsView (CXTPChartDeviceContext *pDC)
Creates the view object.

Detailed Description

This class represents the view of a line series, which is a kind of CXTPChartSeriesView.

Constructor & Destructor Documentation

◆ CXTPChartFastLineSeriesView()

CXTPChartFastLineSeriesView | ( | CXTPChartSeries * | pSeries,
 |  | CXTPChartDiagramView * | pDiagramView )

Constructs a CXTPChartLineSeriesView object.

Parameters
pSeries | A pointer to the chart series object.
pDiagramView | A pointer to the diagram view object.

Member Function Documentation

◆ CreateDeviceCommand()

virtual CXTPChartDeviceCommand * CreateDeviceCommand ( CXTPChartDeviceContext * pDC )
protectedvirtual

This function creates a CXTPChartDeviceCommand object.

This object represents the rendering of a line series.

Parameters
pDC Pointer to a CXTPChartDeviceContext object.
Returns
Returns a CXTPChartDeviceCommand object. This object handles the rendering of an element in the chart. Here it handles the drawing of the line series.

Reimplemented from CXTPChartElementView.

◆ CreateLegendDeviceCommand()

virtual CXTPChartDeviceCommand * CreateLegendDeviceCommand | ( | CXTPChartDeviceContext * | pDC,
 |  | CRect | rcBounds )
 protectedvirtual

This function creates a label view drawing command object.

Parameters
pDC | Pointer to a CXTPChartDeviceContext object.
rcBounds | The rectangular boundary of the legend.
Returns
Returns a new label view drawing command object.

Implements CXTPChartLegendItemView.

◆ CreatePointsView()

void CreatePointsView ( CXTPChartDeviceContext * pDC )
protected

Creates the view object.

Parameters
pDC Target device context pointers.

◆ CreateSeriesPointView()

CXTPChartSeriesPointView * CreateSeriesPointView | ( | CXTPChartDeviceContext * | pDC,
 |  | CXTPChartSeriesPoint * | pPoint,
 |  | CXTPChartElementView * | pParentView )
 protected

Call this function to create a view of the line series point.

Parameters
pDC | A pointer to the chart device context.
pPoint | A pointer to the chart series point object.
pParentView | Parent view pointer.
Returns
Returns a pointer to the associated series point view object.
The documentation for this class was generated from the following file:
  • XTPChartFastLineSeriesStyle.h


Toolkit Pro: CXTPChartFillStyle Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPChartFillStyle Class Reference

This class abstracts a fill style used to fill the background of various chart elements. More...

Inheritance diagram for CXTPChartFillStyle:
[legend]

Public Member Functions

CXTPChartFillStyle (CXTPChartElement *pOwner)
Constructs a CXTPChartFillStyle object.
void | Release ()
Call this function to delete the object.
void | SetFillMode (XTPChartFillMode nFillMode)
Call this function to set a filling mode.
XTPChartFillMode | GetFillMode () const
Call this function to get a filling mode.
void | SetGradientAngle (XTPChartGradientAngle nAngle)
Call this function to set the angle for gradient filling.
XTPChartGradientAngle | GetGradientAngle () const
Call this function to get the angle for gradient filling.
void | SetHatchStyle (XTPChartHatchStyle nStyle)
Call this function to set the hatch style used for filling the background of a particular chart entity.
XTPChartHatchStyle | GetHatchStyle () const
Call this function to get the hatch style used for filling the background of a particular chart entity.
virtual CXTPChartDeviceCommand * | CreateDeviceCommand (const CXTPChartRectF &bounds, const CXTPChartColor &color, const CXTPChartColor &color2)
This function creates a CXTPChartDeviceCommand object, this object represents the rendering of an element in the chart.
virtual CXTPChartDeviceCommand * | CreateDeviceCommand (const CXTPChartPoints &arrPoints, const CXTPChartColor &color, const CXTPChartColor &color2)
This function creates a CXTPChartDeviceCommand object, this object represents the rendering of an element in the chart.
virtual CXTPChartDeviceCommand * | CreateCircleDeviceCommand (const CXTPChartPointF &center, double radius, const CXTPChartColor &color, const CXTPChartColor &color2)
This function creates a CXTPChartDeviceCommand object, this object represents the rendering of an element in the chart.
virtual CXTPChartDeviceCommand * | CreateSplineDeviceCommand (const CXTPChartPoints &arrPoints, const CXTPChartColor &color, const CXTPChartColor &color2, BOOL bTwoSides=FALSE)
This function creates a CXTPChartDeviceCommand object for rendering, of a spline.
void | DoPropExchange (CXTPPropExchange *pPX)
Call this member function to Store/Load the properties of fill style object using the specified data object.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Attributes

CXTPChartElement * | m_pOwner
The owner element.
XTPChartFillMode | m_nFillMode
The background fill mode.
XTPChartGradientAngle | m_nGradientAngle
The gradient angle.
XTPChartHatchStyle | m_nHatchStyle
The hatch style used.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

This class abstracts a fill style used to fill the background of various chart elements.

Constructor & Destructor Documentation

◆ CXTPChartFillStyle()

CXTPChartFillStyle ( CXTPChartElement * pOwner )

Constructs a CXTPChartFillStyle object.

Parameters
pOwner The pointer to a chart element which owns this fill style object.

Member Function Documentation

◆ CreateCircleDeviceCommand()

virtual CXTPChartDeviceCommand * CreateCircleDeviceCommand | ( | const CXTPChartPointF & | center,
 |  | double | radius,
 |  | const CXTPChartColor & | color,
 |  | const CXTPChartColor & | color2 )
 virtual

This function creates a CXTPChartDeviceCommand object, this object represents the rendering of an element in the chart.

Parameters
radius | The radius of the circle.
center | The center point of the circle.
color | The first color used in drawing.
color2 | The second color used in drawing.
Returns
Returns CXTPChartDeviceCommand object, this object handles the rendering of an element in the chart.

◆ CreateDeviceCommand() [1/2]

virtual CXTPChartDeviceCommand * CreateDeviceCommand | ( | const CXTPChartPoints & | arrPoints,
 |  | const CXTPChartColor & | color,
 |  | const CXTPChartColor & | color2 )
 virtual

This function creates a CXTPChartDeviceCommand object, this object represents the rendering of an element in the chart.

Parameters
arrPoints | The array of points which form a polygonal element.
color | The first color used in drawing.
color2 | The second color used in drawing.
Returns
Returns CXTPChartDeviceCommand object, this object handles the rendering of an element in the chart.

◆ CreateDeviceCommand() [2/2]

virtual CXTPChartDeviceCommand * CreateDeviceCommand | ( | const CXTPChartRectF & | bounds,
 |  | const CXTPChartColor & | color,
 |  | const CXTPChartColor & | color2 )
 virtual

This function creates a CXTPChartDeviceCommand object, this object represents the rendering of an element in the chart.

Parameters
bounds | The rectangular boundary, within the limit the drawing has to be done.
color | The first color used in drawing.
color2 | The second color used in drawing.
Returns
Returns CXTPChartDeviceCommand object, this object handles the rendering of an element in the chart.

◆ CreateSplineDeviceCommand()

virtual CXTPChartDeviceCommand * CreateSplineDeviceCommand | ( | const CXTPChartPoints & | arrPoints,
 |  | const CXTPChartColor & | color,
 |  | const CXTPChartColor & | color2,
 |  | BOOL | bTwoSides = FALSE )
 virtual

This function creates a CXTPChartDeviceCommand object for rendering, of a spline.

Parameters
arrPoints | The array of points which form a spline element.
color | The first color used in drawing.
color2 | The second color used in drawing.
bTwoSides | TRUE for two sides.
Returns
Returns CXTPChartDeviceCommand object, this object handles the rendering of an element in the chart.

◆ DoPropExchange()

void DoPropExchange ( CXTPPropExchange * pPX )

Call this member function to Store/Load the properties of fill style object using the specified data object.

Parameters
pPX Source or destination CXTPPropExchange data object reference.

This member function is used to store or load property data to or from a storage.

◆ GetFillMode()

AFX_INLINE XTPChartFillMode GetFillMode ( ) const

Call this function to get a filling mode.

Returns
The enumerated value specifying the current fill mode.

The fill modes used in XTP chart are Empty,Solid,Gradient and Hatch.

◆ GetGradientAngle()

AFX_INLINE XTPChartGradientAngle GetGradientAngle ( ) const

Call this function to get the angle for gradient filling.

Returns
An enumerated value specifying the current angle of gradient.

The common gradient angle are 0, 45, 90, 135, 180, 225, 270, 315.

◆ GetHatchStyle()

AFX_INLINE XTPChartHatchStyle GetHatchStyle ( ) const

Call this function to get the hatch style used for filling the background of a particular chart entity.

Returns
An enumerated value specifying the hatch style currently using.

◆ SetFillMode()

void SetFillMode ( XTPChartFillMode nFillMode )

Call this function to set a filling mode.

Parameters
nFillMode The enumerated value specifying the fill mode of choice.

The fill modes used in XTP chart are Empty,Solid,Gradient and Hatch.

◆ SetGradientAngle()

void SetGradientAngle ( XTPChartGradientAngle nAngle )

Call this function to set the angle for gradient filling.

Parameters
nAngle The angle of the label stem.

The common gradient angle are 0, 45, 90, 135, 180, 225, 270, 315.

◆ SetHatchStyle()

void SetHatchStyle ( XTPChartHatchStyle nStyle )

Call this function to set the hatch style used for filling the background of a particular chart entity.

Parameters
nStyle The enumerated value specifying the hatch style of choice.
The documentation for this class was generated from the following file:
  • XTPChartFillStyle.h


Toolkit Pro: CXTPChartFinanceStyleAppearance Class Reference

Public Member Functions | Public Attributes | List of all members
CXTPChartFinanceStyleAppearance Class Reference

This class represents the finance series appearance of the chart. More...

Public Member Functions

CXTPChartFinanceStyleAppearance (CXTPChartElement *pOwner)
Constructs a CXTPChartFinanceStyleAppearance object.
virtual | ~CXTPChartFinanceStyleAppearance ()
Destroys a CXTPChartFinanceStyleAppearance object, handles cleanup.
void | DoPropExchange (CXTPPropExchange *pPX)
Call this member function to Store/Load the properties related to the appearance of a diagram in 2D, using the specified data object.

Public Attributes

CXTPChartColor | UpColor
Up day line color.
CXTPChartColor | DownColor
Down day line Color.

Detailed Description

This class represents the finance series appearance of the chart.

Chart appearance determined by the 2D digram appearance, chart content appearance and the color palette used.

Constructor & Destructor Documentation

◆ CXTPChartFinanceStyleAppearance()

CXTPChartFinanceStyleAppearance ( CXTPChartElement * pOwner )

Constructs a CXTPChartFinanceStyleAppearance object.

Parameters
pOwner Pointer to an owner element.

Member Function Documentation

◆ DoPropExchange()

void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Call this member function to Store/Load the properties related to the appearance of a diagram in 2D, using the specified data object.

Parameters
pPX Source or destination CXTPPropExchange data object reference.

This member function is used to store or load property data to or from a storage.

Reimplemented from CXTPChartElement.

The documentation for this class was generated from the following file:
  • XTPChartAppearance.h


Toolkit Pro: CXTPChartFont Class Reference

Public Member Functions | Static Public Member Functions | Public Attributes | List of all members
CXTPChartFont Class Reference

This class abstracts a font entity. More...

Inheritance diagram for CXTPChartFont:
[legend]

Public Member Functions

CXTPChartFont ()
Default constructor, creates a CXTPChartFont object and initializes the values.
CXTPChartFont (LOGFONT *pLogFont)
Overloaded constructor, creates a font object from the LOGFONT structure.
virtual | ~CXTPChartFont ()
Destructor, does the cleaning.
void | SetLogFont (LOGFONT *lf)
Call this function to set the LOGFONT for this object.
void | Release ()
Call this function to do the cleanup.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Static Public Member Functions

static CXTPChartFont *AFX_CDECL | GetTahoma18 ()
Call this static function to get Tahoma font with size 18.
static CXTPChartFont *AFX_CDECL | GetTahoma12 ()
Call this static function to get Tahoma font with size 12.
static CXTPChartFont *AFX_CDECL | GetTahoma8 ()
Call this static function to get Tahoma font with size 8.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Public Attributes

LOGFONT m_lf
The LOGFONT variable.

Detailed Description

This class abstracts a font entity.

Constructor & Destructor Documentation

◆ CXTPChartFont()

CXTPChartFont ( LOGFONT * pLogFont )

Overloaded constructor, creates a font object from the LOGFONT structure.

Parameters
pLogFont A pointer to the LOGFONT structure.

Member Function Documentation

◆ GetTahoma12()

static CXTPChartFont *AFX_CDECL GetTahoma12 ( )
static

Call this static function to get Tahoma font with size 12.

Returns
A pointer to the CXTPChartFont object.

This function creates a new CXTPChartFont and set the underlying font to Tahoma with size 12.

◆ GetTahoma18()

static CXTPChartFont *AFX_CDECL GetTahoma18 ( )
static

Call this static function to get Tahoma font with size 18.

Returns
A pointer to the CXTPChartFont object.

This function creates a new CXTPChartFont and set the underlying font to Tahoma with size 18.

◆ GetTahoma8()

static CXTPChartFont *AFX_CDECL GetTahoma8 ( )
static

Call this static function to get Tahoma font with size 8.

Returns
A pointer to the CXTPChartFont object.

This function creates a new CXTPChartFont and set the underlying font to Tahoma with size 8.

◆ SetLogFont()

void SetLogFont ( LOGFONT * lf )

Call this function to set the LOGFONT for this object.

Parameters
lf A pointer to the LOGFONT structure.
The documentation for this class was generated from the following file:
  • XTPChartTypes.h


Toolkit Pro: CXTPChartFunnelDiagram Class Reference

Public Member Functions | List of all members
CXTPChartFunnelDiagram Class Reference

This class abstracts the funnel diagram. More...

Inheritance diagram for CXTPChartFunnelDiagram:
[legend]

Public Member Functions

CXTPChartFunnelDiagram ()
Constructs a CXTPChartFunnelDiagram object.
virtual CXTPChartDiagramView * | CreateView (CXTPChartDeviceContext *pDC, CXTPChartElementView *pParent)
Call this function to create the view of the funnel diagram.
- Public Member Functions inherited from CXTPChartFunnelDiagramBase< BaseDiagram >
CXTPChartFunnelDiagramBase ()
Constructs a CXTPChartFunnelDiagramBase object.
virtual void | CalculateSeriesLayout (CXTPChartDeviceContext *pDC, CXTPChartDiagramView *pView)
Call this function to calculate the funnel series layout.

Detailed Description

This class abstracts the funnel diagram.

This class is a kind of CXTPChartDiagram.

A funnel chart (or a circle graph) is a circular chart divided into sectors, illustrating percents. In a funnel chart, the arc length of each sector (and consequently its central angle and area), is proportional to the quantity it represents. Together, the sectors create a full disk.

Member Function Documentation

◆ CreateView()

virtual CXTPChartDiagramView * CreateView | ( | CXTPChartDeviceContext * | pDC,
 |  | CXTPChartElementView * | pParent )
 virtual

Call this function to create the view of the funnel diagram.

Parameters
pDC | A pointer to chart device context.
pParent | A pointer to the parent view.
Returns
A pointer to a CXTPChartDiagramView object which points to the newly created CXTPChartFunnelDiagramView object.

Implements CXTPChartFunnelDiagramBase< BaseDiagram >.

The documentation for this class was generated from the following file:
  • XTPChart2dFunnelDiagram.h


Toolkit Pro: CXTPChartFunnelDiagramBase< BaseDiagram > Class Template Reference

Public Member Functions | List of all members
CXTPChartFunnelDiagramBase< BaseDiagram > Class Template Referenceabstract

This class abstracts the funnel diagram. More...

Inheritance diagram for CXTPChartFunnelDiagramBase< BaseDiagram >:
[legend]

Public Member Functions

CXTPChartFunnelDiagramBase ()
Constructs a CXTPChartFunnelDiagramBase object.
virtual CXTPChartDiagramView * | CreateView (CXTPChartDeviceContext *pDC, CXTPChartElementView *pParent)=0
Call this function to create the view of the funnel diagram.
virtual void | CalculateSeriesLayout (CXTPChartDeviceContext *pDC, CXTPChartDiagramView *pView)
Call this function to calculate the funnel series layout.

Detailed Description

template<class BaseDiagram>
class CXTPChartFunnelDiagramBase< BaseDiagram >

This class abstracts the funnel diagram.

This class is a kind of CXTPChartDiagram.

A funnel chart (or a circle graph) is a circular chart divided into sectors, illustrating percents. In a funnel chart, the arc length of each sector (and consequently its central angle and area), is proportional to the quantity it represents. Together, the sectors create a full disk.

Member Function Documentation

◆ CalculateSeriesLayout()

template<class BaseDiagram >
AFX_INLINE void CalculateSeriesLayout | ( | CXTPChartDeviceContext * | pDC,
 |  | CXTPChartDiagramView * | pView )
 virtual

Call this function to calculate the funnel series layout.

Parameters
pDC | A pointer to the chart device context.
pView | A pointer to the diagram view.

◆ CreateView()

template<class BaseDiagram >
virtual CXTPChartDiagramView * CreateView | ( | CXTPChartDeviceContext * | pDC,
 |  | CXTPChartElementView * | pParent )
 pure virtual

Call this function to create the view of the funnel diagram.

Parameters
pDC | A pointer to the chart device context.
pParent | A pointer to the parent view.
Returns
A pointer to a CXTPChartDiagramView object which points to the newly created CXTPChartFunnelDiagramView object.

Implemented in CXTPChart3dFunnelDiagram, and CXTPChartFunnelDiagram.

The documentation for this class was generated from the following file:
  • XTPChartFunnelDiagramBase.h


Toolkit Pro: CXTPChartFunnelDiagramView Class Reference

Public Member Functions | List of all members
CXTPChartFunnelDiagramView Class Reference

This class abstracts the view of a funnel diagram. More...

Inheritance diagram for CXTPChartFunnelDiagramView:
[legend]

Public Member Functions

CXTPChartFunnelDiagramView (CXTPChartDiagram *pDiagram, CXTPChartElementView *pParent)
Constructs a CXTPChartFunnelDiagramView object.
- Public Member Functions inherited from CXTPChartDiagramView
CXTPChartDiagramView (CXTPChartDiagram *pDiagram, CXTPChartElementView *pParentView)
Constructs a CXTPChartDiagram object.
CRect | GetBounds () const
Call this function to get the bounds of the diagram.
CXTPChartDiagram * | GetDiagram () const
Call this function to get the diagram object associated with the view.
CXTPChartElementView * | GetLabelsView () const
Call this function to get the label view object associated with this diagram view.
CXTPChartElementView * | GetSeriesView () const
Call this function to get the series view object associated with this diagram view.
virtual void | CalculateView (CXTPChartDeviceContext *pDC, CRect rcBounds)
Call this function to calculate the view of the diagram.
virtual void | UpdateRange (CXTPChartDeviceContext *pDC)
Updates chart range.
virtual void | OnMouseWheel (UINT nFlags, short zDelta, CPoint pt)
Handles mouse wheel event.
virtual void | CreateView (CXTPChartDeviceContext *pDC)
Performs view initialization.
- Public Member Functions inherited from CXTPChartElementView
CXTPChartElementView (CXTPChartElementView *pParentView)
Constructs a CXTPChartElementView object.
CXTPChartElementView (CXTPChartElementView *pParentView, BOOL bAddToParent)
Constructs a CXTPChartElementView object.
CXTPChartElementView (CXTPChartContainer *pContainer)
Constructs a CXTPChartElementView object.
int | GetCount () const
Call this function to get the number of child views associated with this view.
CXTPChartElementView * | GetAt (int nIndex) const
Call this function to get a child view at a particular index.
CXTPChartElementView * | GetParentView () const
Call this function to get the parent view.
CXTPChartElementView * | AddChildView (CXTPChartElementView *pChildView)
Call this function to add a child view to the current view.
CXTPChartElementView ** GetChildren ()
Provides access to the collection of children elements owned by the view.
CRect | GetBounds () const
Obtains viewed object's bound rectangle.
CRect | GetBounds (BOOL bIncludingChildren) const
Obtains viewed object's bound rectangle.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Additional Inherited Members

- Public Attributes inherited from CXTPChartDiagramView
- Protected Member Functions inherited from CXTPChartDiagramView
virtual CXTPChartDeviceCommand * | CreateDeviceCommand (CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
- Protected Member Functions inherited from CXTPChartElementView
virtual | ~CXTPChartElementView ()
Destroys a CXTPChartElementView object, handles cleanup.
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.
- Protected Attributes inherited from CXTPChartDiagramView
CXTPChartDiagram * | m_pDiagram
Pointer to the associated diagram object.
CRect | m_rcBounds
The diagram bounds.
CXTPChartElementView * | m_pLabelsView
The label view.
CXTPChartElementView * | m_pSeriesView
The series view.
CXTPChartElementView * | m_pTitlesView
Titles View.
- Protected Attributes inherited from CXTPChartElementView
CArray< CXTPChartElementView *, CXTPChartElementView * > | m_arrChildren
The child view collection.
CXTPChartElementView * | m_pParentView
The parent view.
CXTPChartContainer * | m_pContainer
The parent container.
CRect | m_rcBounds
Bounding rectangle.

Detailed Description

This class abstracts the view of a funnel diagram.

This class is a kind of CXTPChartDiagramView.

A funnel chart (or a circle graph) is a circular chart divided into sectors, illustrating percents. In a funnel chart, the arc length of each sector (and consequently its central angle and area), is proportional to the quantity it represents. Together, the sectors create a full disk.

Constructor & Destructor Documentation

◆ CXTPChartFunnelDiagramView()

CXTPChartFunnelDiagramView | ( | CXTPChartDiagram * | pDiagram,
 |  | CXTPChartElementView * | pParent )

Constructs a CXTPChartFunnelDiagramView object.

Parameters
pDiagram | A pointer to funnel diagram object.
pParent | A pointer to the parent view.
The documentation for this class was generated from the following file:
  • XTPChart2dFunnelDiagramView.h


Toolkit Pro: CXTPChartFunnelSeriesLabel Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPChartFunnelSeriesLabel Class Reference

CXTPChartFunnelSeriesLabel is a kind of CXTPChartSeriesLabel. More...

Inheritance diagram for CXTPChartFunnelSeriesLabel:
[legend]

Public Member Functions

CXTPChartFunnelSeriesLabel ()
Constructs a CXTPChartFunnelSeriesLabel object.
CXTPChartFunnelSeriesStyle * | GetStyle () const
Call this function to get the basic style of the funnel series.
- Public Member Functions inherited from CXTPChartFunnelSeriesLabelBase
CXTPChartFunnelSeriesLabelBase ()
Constructs a CXTPChartFunnelSeriesLabelBase object.
virtual | ~CXTPChartFunnelSeriesLabelBase ()
Destroys a CXTPChartFunnelSeriesLabelBase object, handles cleanup.
XTPChartFunnelLabelPosition | GetPosition () const
Call this function to get the label position.
void | SetPosition (XTPChartFunnelLabelPosition nPosition)
Call this function to set the label position.
CXTPChartFunnelSeriesStyleBase * | GetStyle () const
Call this function to get the basic style of the funnel series.
void | DoPropExchange (CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
BOOL | IsInside () const
Call this function to check whether the label is inside the funnel.
- Public Member Functions inherited from CXTPChartSeriesLabel
CXTPChartSeriesLabel ()
Constructs a CXTPChartSeriesLabel object.
virtual | ~CXTPChartSeriesLabel ()
Destroys a CXTPChartSeriesLabel object, handles cleanup.
void | SetTextColor (const CXTPChartColor &clrTextColor)
Call this function to set the text color of the label.
CXTPChartColor | GetTextColor () const
Call this function to get the apparent text color of the label.
CXTPChartFont * | GetFont () const
Call this function to get the font of the text label.
void | SetFont (CXTPChartFont *pFont)
Call this function to set the font of the text label.
void | SetShowLines (BOOL bShowLines)
Call this function to set the lines visibility.
BOOL | GetShowLines () const
Call this function to check if the lines are visible.
void | SetLineLength (int nLineLength)
Call this function to set the line length.
int | GetLineLength () const
Call this function to get the line length.
void | SetVisible (BOOL bVisible)
Call this function to set the label visibility.
BOOL | IsVisible () const
Call this function to check if the label is visible.
void | SetAntialiasing (BOOL bAntialiasing)
Call this function to set anti-aliasing ON or OFF.
BOOL | GetAntialiasing () const
Call this function to check if anti-aliasing is ON or OFF.
CXTPChartNumberFormat * | GetFormat () const
Call this function to get a pointer to CXTPChartNumberFormat that specifies how to convert numbers to strings.
void | SetFormat (LPCTSTR lpszFormat)
Obsolete method.
void | SetBackColor (const CXTPChartColor &clrBackColor)
Call this function to set the text color of the label.
CXTPChartColor | GetBackColor () const
Call this function to get the apparent text color of the label.
void | SetLineColor (const CXTPChartColor &clrBackColor)
Call this function to set the text color of the label.
CXTPChartColor | GetLineColor () const
Call this function to get the apparent text color of the label.
int | GetTransparency () const
Call this function to get the transparency of the filled area with respect to the background.
void | SetTransparency (int nTransparency)
Call this function to set the transparency of the filled area with respect to the background.
- Public Member Functions inherited from CXTPChartTextElement
- Public Member Functions inherited from CXTPChartElement
CXTPChartElement ()
Constructs a CXTPChartElement object.
virtual | ~CXTPChartElement ()
Destroys a CXTPChartElement object, handles cleanup.
virtual void | Release ()
Call this function to decrease the usage count of the object.
CXTPChartElement * | GetOwner () const
Call this function to get the owner element.
virtual void | OnChartChanged (XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic properties of the chart.
CXTPChartContent * | GetContent () const
Call this virtual function to get the chart content object.
CXTPChartAppearance * | GetAppearance () const
Call this function to get the the appearance of the chart.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Protected Member Functions

virtual CXTPChartElementView * CreateView (CXTPChartDeviceContext *pDC, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView)
This function creates the view of the funnel series.
- Protected Member Functions inherited from CXTPChartFunnelSeriesLabelBase
- Protected Member Functions inherited from CXTPChartSeriesLabel
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.

Additional Inherited Members

- Public Attributes inherited from CXTPChartElement
- Protected Attributes inherited from CXTPChartFunnelSeriesLabelBase
XTPChartFunnelLabelPosition | m_nPosition
The funnel label position.
- Protected Attributes inherited from CXTPChartSeriesLabel
CXTPChartColor | m_clrTextColor
The text color.
CXTPChartColor | m_clrBackColor
The background color.
CXTPChartColor | m_clrLineColor
The line color.
BOOL | m_bVisible
TRUE if the label is visible and FALSE if not.
CXTPChartFont * | m_pFont
The font of the label.
BOOL | m_bAntialiasing
TRUE if antialiasing enabled, FALSE if not.
BOOL | m_bShowLines
TRUE if the lines are visible, FALSE if not.
int | m_nLineLength
The line length.
CXTPChartBorder * | m_pBorder
Chart border object.
int | m_nTransparency
The transparency values range from 0 to 255.
- Protected Attributes inherited from CXTPChartElement

Detailed Description

CXTPChartFunnelSeriesLabel is a kind of CXTPChartSeriesLabel.

This class abstracts the label of a funnel series.

Member Function Documentation

◆ CreateView()

virtual CXTPChartElementView * CreateView | ( | CXTPChartDeviceContext * | pDC,
 |  | CXTPChartSeriesPointView * | pPointView,
 |  | CXTPChartElementView * | pParentView )
 protectedvirtual

This function creates the view of the funnel series.

Parameters
pDC | The chart device context object pointer.
pPointView | The series point view.
pParentView | Parent view pointer.
Returns
Returns a pointer to the associated label view object.

Implements CXTPChartFunnelSeriesLabelBase.

◆ GetStyle()

CXTPChartFunnelSeriesStyle * GetStyle ( ) const

Call this function to get the basic style of the funnel series.

Returns
A pointer to a CXTPChartFunnelSeriesStyle object.
The documentation for this class was generated from the following file:
  • XTPChart2dFunnelSeriesLabel.h


Toolkit Pro: CXTPChartFunnelSeriesLabelBase Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPChartFunnelSeriesLabelBase Class Referenceabstract

CXTPChartFunnelSeriesLabelBase is a kind of CXTPChartSeriesLabel. More...

Inheritance diagram for CXTPChartFunnelSeriesLabelBase:
[legend]

Public Member Functions

CXTPChartFunnelSeriesLabelBase ()
Constructs a CXTPChartFunnelSeriesLabelBase object.
virtual | ~CXTPChartFunnelSeriesLabelBase ()
Destroys a CXTPChartFunnelSeriesLabelBase object, handles cleanup.
XTPChartFunnelLabelPosition | GetPosition () const
Call this function to get the label position.
void | SetPosition (XTPChartFunnelLabelPosition nPosition)
Call this function to set the label position.
CXTPChartFunnelSeriesStyleBase * | GetStyle () const
Call this function to get the basic style of the funnel series.
void | DoPropExchange (CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
BOOL | IsInside () const
Call this function to check whether the label is inside the funnel.
- Public Member Functions inherited from CXTPChartSeriesLabel
CXTPChartSeriesLabel ()
Constructs a CXTPChartSeriesLabel object.
virtual | ~CXTPChartSeriesLabel ()
Destroys a CXTPChartSeriesLabel object, handles cleanup.
void | SetTextColor (const CXTPChartColor &clrTextColor)
Call this function to set the text color of the label.
CXTPChartColor | GetTextColor () const
Call this function to get the apparent text color of the label.
CXTPChartFont * | GetFont () const
Call this function to get the font of the text label.
void | SetFont (CXTPChartFont *pFont)
Call this function to set the font of the text label.
void | SetShowLines (BOOL bShowLines)
Call this function to set the lines visibility.
BOOL | GetShowLines () const
Call this function to check if the lines are visible.
void | SetLineLength (int nLineLength)
Call this function to set the line length.
int | GetLineLength () const
Call this function to get the line length.
void | SetVisible (BOOL bVisible)
Call this function to set the label visibility.
BOOL | IsVisible () const
Call this function to check if the label is visible.
void | SetAntialiasing (BOOL bAntialiasing)
Call this function to set anti-aliasing ON or OFF.
BOOL | GetAntialiasing () const
Call this function to check if anti-aliasing is ON or OFF.
CXTPChartNumberFormat * | GetFormat () const
Call this function to get a pointer to CXTPChartNumberFormat that specifies how to convert numbers to strings.
void | SetFormat (LPCTSTR lpszFormat)
Obsolete method.
void | SetBackColor (const CXTPChartColor &clrBackColor)
Call this function to set the text color of the label.
CXTPChartColor | GetBackColor () const
Call this function to get the apparent text color of the label.
void | SetLineColor (const CXTPChartColor &clrBackColor)
Call this function to set the text color of the label.
CXTPChartColor | GetLineColor () const
Call this function to get the apparent text color of the label.
int | GetTransparency () const
Call this function to get the transparency of the filled area with respect to the background.
void | SetTransparency (int nTransparency)
Call this function to set the transparency of the filled area with respect to the background.
- Public Member Functions inherited from CXTPChartTextElement
- Public Member Functions inherited from CXTPChartElement
CXTPChartElement ()
Constructs a CXTPChartElement object.
virtual | ~CXTPChartElement ()
Destroys a CXTPChartElement object, handles cleanup.
virtual void | Release ()
Call this function to decrease the usage count of the object.
CXTPChartElement * | GetOwner () const
Call this function to get the owner element.
virtual void | OnChartChanged (XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic properties of the chart.
CXTPChartContent * | GetContent () const
Call this virtual function to get the chart content object.
CXTPChartAppearance * | GetAppearance () const
Call this function to get the the appearance of the chart.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Protected Member Functions

virtual CXTPChartElementView * CreateView (CXTPChartDeviceContext *pDC, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView)=0
This function creates the view of the funnel series.
- Protected Member Functions inherited from CXTPChartSeriesLabel
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.

Protected Attributes

XTPChartFunnelLabelPosition | m_nPosition
The funnel label position.
- Protected Attributes inherited from CXTPChartSeriesLabel
CXTPChartColor | m_clrTextColor
The text color.
CXTPChartColor | m_clrBackColor
The background color.
CXTPChartColor | m_clrLineColor
The line color.
BOOL | m_bVisible
TRUE if the label is visible and FALSE if not.
CXTPChartFont * | m_pFont
The font of the label.
BOOL | m_bAntialiasing
TRUE if antialiasing enabled, FALSE if not.
BOOL | m_bShowLines
TRUE if the lines are visible, FALSE if not.
int | m_nLineLength
The line length.
CXTPChartBorder * | m_pBorder
Chart border object.
int | m_nTransparency
The transparency values range from 0 to 255.
- Protected Attributes inherited from CXTPChartElement

Detailed Description

CXTPChartFunnelSeriesLabelBase is a kind of CXTPChartSeriesLabel.

This class abstracts the label of a funnel series.

Member Function Documentation

◆ CreateView()

virtual CXTPChartElementView * CreateView | ( | CXTPChartDeviceContext * | pDC,
 |  | CXTPChartSeriesPointView * | pPointView,
 |  | CXTPChartElementView * | pParentView )
 protectedpure virtual

This function creates the view of the funnel series.

Parameters
pDC | The chart device context object pointer.
pPointView | The series point view.
pParentView | Parent view pointer.
Returns
Returns a pointer to the associated label view object.

Reimplemented from CXTPChartSeriesLabel.

Implemented in CXTPChart3dFunnelSeriesLabel, and CXTPChartFunnelSeriesLabel.

◆ DoPropExchange()

void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Reads this object from or writes this object to an archive.

Parameters
pPX A CXTPPropExchange object to serialize to or from.

Reimplemented from CXTPChartSeriesLabel.

◆ GetPosition()

AFX_INLINE XTPChartFunnelLabelPosition GetPosition ( ) const

Call this function to get the label position.

Returns
A funnel label position object describing the position of the funnel label.

◆ GetStyle()

CXTPChartFunnelSeriesStyleBase * GetStyle ( ) const

Call this function to get the basic style of the funnel series.

Returns
A pointer to a CXTPChartFunnelSeriesStyle object.

◆ IsInside()

BOOL IsInside ( ) const

Call this function to check whether the label is inside the funnel.

Returns
A BOOL value. TRUE if the label is inside the funnel, FALSE otherwise.

◆ SetPosition()

AFX_INLINE void SetPosition ( XTPChartFunnelLabelPosition nPosition )

Call this function to set the label position.

Parameters
nPosition A funnel label position object describing the position of the funnel label.
The documentation for this class was generated from the following file:
  • XTPChartFunnelSeriesLabelBase.h


Toolkit Pro: CXTPChartFunnelSeriesLabelView Class Reference

Public Member Functions | List of all members
CXTPChartFunnelSeriesLabelView Class Reference

Defines 2D series label view. More...

Inheritance diagram for CXTPChartFunnelSeriesLabelView:
[legend]

Public Member Functions

CXTPChartFunnelSeriesLabelView (CXTPChartSeriesLabel *pLabel, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView)
Constructs a CXTPChartFunnelSeriesLabelView object.
virtual CXTPChartDeviceCommand * | CreateDeviceCommand (CXTPChartDeviceContext *pDC)
Creates a view drawing device command for the device context specified.
- Public Member Functions inherited from CXTPChartFunnelSeriesLabelViewBase
XTPChartFunnelLabelPosition | GetPosition () const
Obtains label position.

Additional Inherited Members

- Protected Member Functions inherited from CXTPChartFunnelSeriesLabelViewBase
CXTPChartFunnelSeriesLabelViewBase (CXTPChartSeriesLabel *pLabel, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView)
Constructs a CXTPChartFunnelSeriesLabelViewBase object.

Detailed Description

Defines 2D series label view.

Constructor & Destructor Documentation

◆ CXTPChartFunnelSeriesLabelView()

CXTPChartFunnelSeriesLabelView | ( | CXTPChartSeriesLabel * | pLabel,
 |  | CXTPChartSeriesPointView * | pPointView,
 |  | CXTPChartElementView * | pParentView )

Constructs a CXTPChartFunnelSeriesLabelView object.

Parameters
pLabel | Associated label model pointer.
pPointView | Point view object pointer associated with the label.
pParentView | Parent view pointer.

Member Function Documentation

◆ CreateDeviceCommand()

virtual CXTPChartDeviceCommand * CreateDeviceCommand ( CXTPChartDeviceContext * pDC )
virtual

Creates a view drawing device command for the device context specified.

Parameters
pDC Device context pointer for which the drawing command is to be created.
Returns
A new instance of view drawing device command or NULL if no command is provided.

Implements CXTPChartFunnelSeriesLabelViewBase.

The documentation for this class was generated from the following file:
  • XTPChart2dFunnelSeriesLabel.h


Toolkit Pro: CXTPChartFunnelSeriesLabelViewBase Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPChartFunnelSeriesLabelViewBase Class Referenceabstract

This class abstracts the view of a funnel series label. More...

Inheritance diagram for CXTPChartFunnelSeriesLabelViewBase:
[legend]

Public Member Functions

XTPChartFunnelLabelPosition | GetPosition () const
Obtains label position.
virtual CXTPChartDeviceCommand * | CreateDeviceCommand (CXTPChartDeviceContext *pDC)=0
Creates view drawing device command for the device context specified.

Protected Member Functions

CXTPChartFunnelSeriesLabelViewBase (CXTPChartSeriesLabel *pLabel, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView)
Constructs a CXTPChartFunnelSeriesLabelViewBase object.

Detailed Description

This class abstracts the view of a funnel series label.

Constructor & Destructor Documentation

◆ CXTPChartFunnelSeriesLabelViewBase()

CXTPChartFunnelSeriesLabelViewBase | ( | CXTPChartSeriesLabel * | pLabel,
 |  | CXTPChartSeriesPointView * | pPointView,
 |  | CXTPChartElementView * | pParentView )
 protected

Constructs a CXTPChartFunnelSeriesLabelViewBase object.

Parameters
pLabel | Associated label model pointer.
pPointView | Point view object pointer associated with the label.
pParentView | Parent view pointer.

Member Function Documentation

◆ CreateDeviceCommand()

virtual CXTPChartDeviceCommand * CreateDeviceCommand ( CXTPChartDeviceContext * pDC )
pure virtual

Creates view drawing device command for the device context specified.

Parameters
pDC Device context pointer for which the drawing command is to be created.
Returns
A new instance of view drawing device command or NULL if no command is provided.

Reimplemented from CXTPChartElementView.

Implemented in CXTPChart3dFunnelSeriesLabelView, and CXTPChartFunnelSeriesLabelView.

◆ GetPosition()

XTPChartFunnelLabelPosition GetPosition ( ) const

Obtains label position.

Returns
Label position.
The documentation for this class was generated from the following file:
  • XTPChartFunnelSeriesLabelBase.h


Toolkit Pro: CXTPChartFunnelSeriesPointView Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPChartFunnelSeriesPointView Class Reference

This class abstracts the view of a funnel series point. More...

Inheritance diagram for CXTPChartFunnelSeriesPointView:
[legend]

Public Member Functions

CXTPChartFunnelSeriesPointView (CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Constructs a CXTPChartFunnelSeriesPointView object.
CXTPChartFunnelSeriesPointView (CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView, BOOL bAddToParent)
Constructs a CXTPChartFunnelSeriesPointView object.
- Public Member Functions inherited from CXTPChartFunnelSeriesPointViewBase
CXTPChartFunnelSeriesPointViewBase (CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Constructs a CXTPChartFunnelSeriesPointView object.
CXTPChartFunnelSeriesPointViewBase (CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView, BOOL bAddToParent)
Constructs a CXTPChartFunnelSeriesPointView object.
virtual | ~CXTPChartFunnelSeriesPointViewBase ()
Destroys a CXTPChartFunnelSeriesPointView object, handle cleanup.
virtual void | CalculateLayout (int nIndex, int nCount, double dFrom, double dTo)
Use this function to calculate the layout of the funnel series point.
CXTPChartColor | GetBorderActualColor () const
Obtains border color value.
- Public Member Functions inherited from CXTPChartSeriesPointView
CXTPChartSeriesPointView (CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Constructs the view object.
CXTPChartSeriesPointView (CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView, BOOL bAddToParent)
Constructs the view object.
CXTPChartSeriesPoint * | GetPoint () const
Obtains point model object.
CXTPChartSeriesView * | GetSeriesView () const
Obtains parent series view.
CXTPChartColor | GetColor () const
Obtain view color values.
CXTPChartColor | GetColor2 () const
Obtain view color values.
double | GetInternalValue () const
Obtains point interval value.
virtual CXTPChartString | GetLegendName () const
This function returns the legend name.
virtual void | UpdateMinMaxRange (double &nMinValue, double &nMaxValue) const
Provides a default empty implementation for min/max range update request.
- Public Member Functions inherited from CXTPChartElementView
CXTPChartElementView (CXTPChartElementView *pParentView)
Constructs a CXTPChartElementView object.
CXTPChartElementView (CXTPChartElementView *pParentView, BOOL bAddToParent)
Constructs a CXTPChartElementView object.
CXTPChartElementView (CXTPChartContainer *pContainer)
Constructs a CXTPChartElementView object.
int | GetCount () const
Call this function to get the number of child views associated with this view.
CXTPChartElementView * | GetAt (int nIndex) const
Call this function to get a child view at a particular index.
CXTPChartElementView * | GetParentView () const
Call this function to get the parent view.
CXTPChartElementView * | AddChildView (CXTPChartElementView *pChildView)
Call this function to add a child view to the current view.
CXTPChartElementView ** GetChildren ()
Provides access to the collection of children elements owned by the view.
CRect | GetBounds () const
Obtains viewed object's bound rectangle.
CRect | GetBounds (BOOL bIncludingChildren) const
Obtains viewed object's bound rectangle.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.
- Public Member Functions inherited from CXTPChartLegendItemView
virtual | ~CXTPChartLegendItemView ()
Handles object destruction.

Protected Member Functions

virtual CXTPChartDeviceCommand * | CreateDeviceCommand (CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
- Protected Member Functions inherited from CXTPChartFunnelSeriesPointViewBase
virtual CXTPChartDeviceCommand * | CreateLegendDeviceCommand (CXTPChartDeviceContext *pDC, CRect rcBounds)
This function creates a label view drawing command object.
- Protected Member Functions inherited from CXTPChartElementView
virtual | ~CXTPChartElementView ()
Destroys a CXTPChartElementView object, handles cleanup.
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.

Additional Inherited Members

- Public Attributes inherited from CXTPChartFunnelSeriesPointViewBase
- Public Attributes inherited from CXTPChartSeriesPointView
double | m_dInternalValue
Point internal value.
- Protected Attributes inherited from CXTPChartFunnelSeriesPointViewBase
double | m_dValue
The value of the point.
- Protected Attributes inherited from CXTPChartSeriesPointView
CXTPChartSeriesPoint * | m_pPoint
Point model object pointer.
- Protected Attributes inherited from CXTPChartElementView
CArray< CXTPChartElementView *, CXTPChartElementView * > | m_arrChildren
The child view collection.
CXTPChartElementView * | m_pParentView
The parent view.
CXTPChartContainer * | m_pContainer
The parent container.
CRect | m_rcBounds
Bounding rectangle.

Detailed Description

This class abstracts the view of a funnel series point.

This class is a kind of CXTPChartSeriesPointView.

A funnel chart (or a circle graph) is a circular chart divided into sectors, illustrating percents. In a funnel chart, the arc length of each sector (and consequently its central angle and area), is proportional to the quantity it represents. Together, the sectors create a full disk.

Constructor & Destructor Documentation

◆ CXTPChartFunnelSeriesPointView() [1/2]

CXTPChartFunnelSeriesPointView | ( | CXTPChartSeriesPoint * | pPoint,
 |  | CXTPChartElementView * | pParentView )

Constructs a CXTPChartFunnelSeriesPointView object.

Parameters
pPoint | Pointer to a chart series point.
pParentView | The parent view of the axis.

◆ CXTPChartFunnelSeriesPointView() [2/2]

CXTPChartFunnelSeriesPointView | ( | CXTPChartSeriesPoint * | pPoint,
 |  | CXTPChartElementView * | pParentView,
 |  | BOOL | bAddToParent )

Constructs a CXTPChartFunnelSeriesPointView object.

Parameters
pPoint | Pointer to a chart series point.
bAddToParent | If TRUE the view will be be added to parent's child view list.
pParentView | The parent view of the axis.

Member Function Documentation

◆ CreateDeviceCommand()

virtual CXTPChartDeviceCommand * CreateDeviceCommand ( CXTPChartDeviceContext * pDC )
protectedvirtual

This function creates a CXTPChartDeviceCommand object.

This object represents the rendering of the funnel series point.

Parameters
pDC Pointer to a CXTPChartDeviceContext object.
Returns
Returns a CXTPChartDeviceCommand object. This object handles the rendering of an element in the chart. Here it handles the drawing of the funnel series point.

Implements CXTPChartFunnelSeriesPointViewBase.

The documentation for this class was generated from the following file:
  • XTPChart2dFunnelSeriesPointView.h


Toolkit Pro: CXTPChartFunnelSeriesPointViewBase Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPChartFunnelSeriesPointViewBase Class Referenceabstract

This class abstracts the view of a funnel series point. More...

Inheritance diagram for CXTPChartFunnelSeriesPointViewBase:
[legend]

Public Member Functions

CXTPChartFunnelSeriesPointViewBase (CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Constructs a CXTPChartFunnelSeriesPointView object.
CXTPChartFunnelSeriesPointViewBase (CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView, BOOL bAddToParent)
Constructs a CXTPChartFunnelSeriesPointView object.
virtual | ~CXTPChartFunnelSeriesPointViewBase ()
Destroys a CXTPChartFunnelSeriesPointView object, handle cleanup.
virtual void | CalculateLayout (int nIndex, int nCount, double dFrom, double dTo)
Use this function to calculate the layout of the funnel series point.
CXTPChartColor | GetBorderActualColor () const
Obtains border color value.
- Public Member Functions inherited from CXTPChartSeriesPointView
CXTPChartSeriesPointView (CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Constructs the view object.
CXTPChartSeriesPointView (CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView, BOOL bAddToParent)
Constructs the view object.
CXTPChartSeriesPoint * | GetPoint () const
Obtains point model object.
CXTPChartSeriesView * | GetSeriesView () const
Obtains parent series view.
CXTPChartColor | GetColor () const
Obtain view color values.
CXTPChartColor | GetColor2 () const
Obtain view color values.
double | GetInternalValue () const
Obtains point interval value.
virtual CXTPChartString | GetLegendName () const
This function returns the legend name.
virtual void | UpdateMinMaxRange (double &nMinValue, double &nMaxValue) const
Provides a default empty implementation for min/max range update request.
- Public Member Functions inherited from CXTPChartElementView
CXTPChartElementView (CXTPChartElementView *pParentView)
Constructs a CXTPChartElementView object.
CXTPChartElementView (CXTPChartElementView *pParentView, BOOL bAddToParent)
Constructs a CXTPChartElementView object.
CXTPChartElementView (CXTPChartContainer *pContainer)
Constructs a CXTPChartElementView object.
int | GetCount () const
Call this function to get the number of child views associated with this view.
CXTPChartElementView * | GetAt (int nIndex) const
Call this function to get a child view at a particular index.
CXTPChartElementView * | GetParentView () const
Call this function to get the parent view.
CXTPChartElementView * | AddChildView (CXTPChartElementView *pChildView)
Call this function to add a child view to the current view.
CXTPChartElementView ** GetChildren ()
Provides access to the collection of children elements owned by the view.
CRect | GetBounds () const
Obtains viewed object's bound rectangle.
CRect | GetBounds (BOOL bIncludingChildren) const
Obtains viewed object's bound rectangle.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.
- Public Member Functions inherited from CXTPChartLegendItemView
virtual | ~CXTPChartLegendItemView ()
Handles object destruction.

Protected Member Functions

virtual CXTPChartDeviceCommand * | CreateDeviceCommand (CXTPChartDeviceContext *pDC)=0
This function creates a CXTPChartDeviceCommand object.
virtual CXTPChartDeviceCommand * | CreateLegendDeviceCommand (CXTPChartDeviceContext *pDC, CRect rcBounds)
This function creates a label view drawing command object.
- Protected Member Functions inherited from CXTPChartElementView
virtual | ~CXTPChartElementView ()
Destroys a CXTPChartElementView object, handles cleanup.
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.

Protected Attributes

double | m_dValue
The value of the point.
- Protected Attributes inherited from CXTPChartSeriesPointView
CXTPChartSeriesPoint * | m_pPoint
Point model object pointer.
- Protected Attributes inherited from CXTPChartElementView
CArray< CXTPChartElementView *, CXTPChartElementView * > | m_arrChildren
The child view collection.
CXTPChartElementView * | m_pParentView
The parent view.
CXTPChartContainer * | m_pContainer
The parent container.
CRect | m_rcBounds
Bounding rectangle.

Additional Inherited Members

- Public Attributes inherited from CXTPChartSeriesPointView
double m_dInternalValue
Point internal value.

Detailed Description

This class abstracts the view of a funnel series point.

This class is a kind of CXTPChartSeriesPointView.

A funnel chart (or a circle graph) is a circular chart divided into sectors, illustrating percents. In a funnel chart, the arc length of each sector (and consequently its central angle and area), is proportional to the quantity it represents. Together, the sectors create a full disk.

Constructor & Destructor Documentation

◆ CXTPChartFunnelSeriesPointViewBase() [1/2]

CXTPChartFunnelSeriesPointViewBase | ( | CXTPChartSeriesPoint * | pPoint,
 |  | CXTPChartElementView * | pParentView )

Constructs a CXTPChartFunnelSeriesPointView object.

Parameters
pPoint | Pointer to chart series point.
pParentView | The pointer to the parent view object.

◆ CXTPChartFunnelSeriesPointViewBase() [2/2]

CXTPChartFunnelSeriesPointViewBase | ( | CXTPChartSeriesPoint * | pPoint,
 |  | CXTPChartElementView * | pParentView,
 |  | BOOL | bAddToParent )

Constructs a CXTPChartFunnelSeriesPointView object.

Parameters
pPoint | Pointer to chart series point.
pParentView | The pointer to the parent view object.
bAddToParent | If TRUE the view will be be added to parent's child view list.

Member Function Documentation

◆ CalculateLayout()

virtual void CalculateLayout | ( | int | nIndex,
 |  | int | nCount,
 |  | double | dFrom,
 |  | double | dTo )
 virtual

Use this function to calculate the layout of the funnel series point.

Parameters
nIndex | Point index.
nCount | Number of points.
dFrom | Point start value.
dTo | Value part point value end.

Reimplemented in CXTPChart3dFunnelSeriesPointView.

◆ CreateDeviceCommand()

virtual CXTPChartDeviceCommand * CreateDeviceCommand ( CXTPChartDeviceContext * pDC )
protectedpure virtual

This function creates a CXTPChartDeviceCommand object.

This object represents the rendering of the funnel series point.

Parameters
pDC Pointer to a CXTPChartDeviceContext object.
Returns
Returns a CXTPChartDeviceCommand object. This object handles the rendering of an element in the chart. Here it handles the drawing of the funnel series point.

Reimplemented from CXTPChartElementView.

Implemented in CXTPChart3dFunnelSeriesPointView, and CXTPChartFunnelSeriesPointView.

◆ CreateLegendDeviceCommand()

virtual CXTPChartDeviceCommand * CreateLegendDeviceCommand | ( | CXTPChartDeviceContext * | pDC,
 |  | CRect | rcBounds )
 protectedvirtual

This function creates a label view drawing command object.

Parameters
pDC | Pointer to a CXTPChartDeviceContext object.
rcBounds | The rectangular boundary of the legend.
Returns
Returns a new label view drawing command object.

Reimplemented from CXTPChartSeriesPointView.

Reimplemented in CXTPChart3dFunnelSeriesPointView.

◆ GetBorderActualColor()

CXTPChartColor GetBorderActualColor ( ) const

Obtains border color value.

Returns
Border color value.
The documentation for this class was generated from the following file:
  • XTPChartFunnelSeriesPointViewBase.h


Toolkit Pro: CXTPChartFunnelSeriesStyle Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPChartFunnelSeriesStyle Class Reference

This class abstracts the basic style of a funnel series. More...

Inheritance diagram for CXTPChartFunnelSeriesStyle:
[legend]

Public Member Functions

CXTPChartFunnelSeriesStyle ()
Constructs a CXTPChartFunnelSeriesStyleBase object.
- Public Member Functions inherited from CXTPChartFunnelSeriesStyleBase
CXTPChartFunnelSeriesStyleBase ()
Constructs a CXTPChartFunnelSeriesStyleBase object.
virtual | ~CXTPChartFunnelSeriesStyleBase ()
Destroys a CXTPChartFunnelSeriesStyleBase object, handle cleanup.
int | GetPointDistance () const
Gets point distance value.
void | SetPointDistance (int nPointDistance)
Sets point distance value.
double | GetHeightToWidthRatio () const
Gets height to width ratio of the funnel.
void | SetHeightToWidthRatio (double dRatio)
Sets height to width ratio of the funnel.
void | SetEqualHeight (BOOL bEqualHeight)
Sets equal height flag.
BOOL | IsEqualHeight () const
Gets equal height flag.
CXTPChartFillStyle * | GetFillStyle () const
Call this function to get the background fill style.
CXTPChartBorder * | GetBorder () const
Call this function to get the border object.
void | DoPropExchange (CXTPPropExchange *pPX)
Reads or writes this object from or to an archive.
- Public Member Functions inherited from CXTPChartSeriesStyle
CXTPChartSeriesStyle ()
Constructs a CXTPChartSeriesStyle object.
virtual | ~CXTPChartSeriesStyle ()
Destroys a CXTPChartSeriesStyle object, handles cleanup.
virtual CXTPChartSeriesLabel * | GetLabel () const
Call this method to gets the series label object.
virtual CXTPChartSeriesLabel * | SetLabel (CXTPChartSeriesLabel *pLabel)
Call this method to sets the series label object.
virtual CXTPChartErrorBar * | GetErrorBar () const
Call this method to gets the error bar object.
virtual CXTPChartErrorBar * | SetErrorBar (CXTPChartErrorBar *pErrorBar)
Call this method to sets the error bar object.
virtual CXTPChartColor | GetColor () const
Call this method to get the color of the series.
virtual void | SetColor (CXTPChartColor clr)
Call this method to set the color of the series.
virtual void | SetColorEach (BOOL bColorEach)
Call this method to set individual color for each point of the series.
virtual BOOL | IsColorEach () const
This method is called to check if individual color is used for each point of the series.
virtual CXTPChart3dRotation | Get3dRotation () const
Obtains rotation parameters for 3D chart.
virtual void | Set3dRotation (const CXTPChart3dRotation &rotation)
Sets rotation parameters for 3D chart.
virtual void | Set3dRotation (double dYaw, double dPitch, double dRoll)
Sets rotation parameters for 3D chart.
virtual BOOL | Is3dEdgeSmoothingEnabled () const
Enables/disables 3D edge smoothing.
virtual void | Enable3dEdgeSmoothing (BOOL bEnable=TRUE)
Enables/disables 3D edge smoothing.
virtual int | GetTransparency () const
Call this function to gets the transparency of the chart if it is supported by the chart type.
virtual void | SetTransparency (int nTransparency)
Call this function to sets the transparency of the chart if it is supported by the chart type.
virtual void | CorrectAxisSideMargins (CXTPChartAxis *pAxis, double nMinValue, double nMaxValue, double &nCorrection)
Provides default implementation for axis side margins correction.
virtual CXTPChartSeriesStyleAppearance * | GetStyleAppearance () const
Obtains associated style appearance pointer.
virtual void | ApplyTo (CXTPChartDeviceCommand *pCommand)
Applies the style to the command provided in case the command needs style specific details for correct drawing.
virtual int | GetSeriesPointValueIndex () const
Obtains the index of a point element for which an internal value can be otained.
- Public Member Functions inherited from CXTPChartElement
CXTPChartElement ()
Constructs a CXTPChartElement object.
virtual | ~CXTPChartElement ()
Destroys a CXTPChartElement object, handles cleanup.
virtual void | Release ()
Call this function to decrease the usage count of the object.
CXTPChartElement * | GetOwner () const
Call this function to get the owner element.
virtual void | OnChartChanged (XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic properties of the chart.
CXTPChartContent * | GetContent () const
Call this virtual function to get the chart content object.
CXTPChartAppearance * | GetAppearance () const
Call this function to get the the appearance of the chart.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Protected Member Functions

CXTPChartDiagram * CreateDiagram ()
Call this function to create the diagram for this series.
CXTPChartSeriesView * | CreateView (CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Call this function to create the view of the funnel series.
virtual BOOL | IsStyleDiagram (CXTPChartDiagram *pDiagram) const
Call this function to check whether the chart diagram object passed is a kind of CXTPChart3dFunnelDiagramBase/CXTPChart3dFunnelDiagramBase.
- Protected Member Functions inherited from CXTPChartFunnelSeriesStyleBase
BOOL | IsStyleDiagram (CXTPChartDiagram *pDiagram) const
This method is called to ask style if series can be inserted in existing diagram.
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.

Additional Inherited Members

- Public Attributes inherited from CXTPChartElement
- Protected Attributes inherited from CXTPChartSeriesStyle
CXTPChartSeriesLabel * | m_pLabel
Label object.
CXTPChartErrorBar * | m_pErrorBar
Error bar object.
CXTPChartColor | m_clrColor
Custom color of series.
BOOL | m_bColorEach
TRUE to color each point.
int | m_nTransparency
The transparency value in the range 0..255.
CXTPChart3dRotation | m_Rotation3d
3D rotation
BOOL | m_bSmooth3dEdges
3D edge smoothing
- Protected Attributes inherited from CXTPChartElement

Detailed Description

This class abstracts the basic style of a funnel series.

This class is a kind of CXTPChartSeriesStyle.

A funnel chart (or a circle graph) is a circular chart divided into sectors, illustrating percents. In a funnel chart, the arc length of each sector (and consequently its central angle and area), is proportional to the quantity it represents. Together, the sectors create a full disk.

Member Function Documentation

◆ CreateDiagram()

CXTPChartDiagram * CreateDiagram ( )
protectedvirtual

Call this function to create the diagram for this series.

Returns
A pointer to a CXTPChartDiagram object which points to the newly created CXTPChartDiagram2D object.

Implements CXTPChartFunnelSeriesStyleBase.

◆ CreateView()

CXTPChartSeriesView * CreateView | ( | CXTPChartSeries * | pSeries,
 |  | CXTPChartDiagramView * | pDiagramView )
 protectedvirtual

Call this function to create the view of the funnel series.

Parameters
pSeries | A pointer to a chart series object.
pDiagramView | A pointer to the diagram view object.
Returns
A pointer to the newly created 2D series view object.

Implements CXTPChartFunnelSeriesStyleBase.

◆ IsStyleDiagram()

virtual BOOL IsStyleDiagram ( CXTPChartDiagram * pDiagram ) const
protectedvirtual

Call this function to check whether the chart diagram object passed is a kind of CXTPChart3dFunnelDiagramBase/CXTPChart3dFunnelDiagramBase.

Parameters
pDiagram A pointer to a chart diagram, whose type is to be identified.
Returns
TRUE if the chart diagram is a funnel diagram, FALSE otherwise.

Reimplemented from CXTPChartSeriesStyle.

The documentation for this class was generated from the following file:
  • XTPChart2dFunnelSeriesStyle.h


Toolkit Pro: CXTPChartFunnelSeriesStyleBase Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPChartFunnelSeriesStyleBase Class Referenceabstract

This class abstracts the basic style of a funnel serie.This class is a kind of CXTPChartSeriesStyle. More...

Inheritance diagram for CXTPChartFunnelSeriesStyleBase:
[legend]

Public Member Functions

CXTPChartFunnelSeriesStyleBase ()
Constructs a CXTPChartFunnelSeriesStyleBase object.
virtual | ~CXTPChartFunnelSeriesStyleBase ()
Destroys a CXTPChartFunnelSeriesStyleBase object, handle cleanup.
int | GetPointDistance () const
Gets point distance value.
void | SetPointDistance (int nPointDistance)
Sets point distance value.
double | GetHeightToWidthRatio () const
Gets height to width ratio of the funnel.
void | SetHeightToWidthRatio (double dRatio)
Sets height to width ratio of the funnel.
void | SetEqualHeight (BOOL bEqualHeight)
Sets equal height flag.
BOOL | IsEqualHeight () const
Gets equal height flag.
CXTPChartFillStyle * | GetFillStyle () const
Call this function to get the background fill style.
CXTPChartBorder * | GetBorder () const
Call this function to get the border object.
void | DoPropExchange (CXTPPropExchange *pPX)
Reads or writes this object from or to an archive.
- Public Member Functions inherited from CXTPChartSeriesStyle
CXTPChartSeriesStyle ()
Constructs a CXTPChartSeriesStyle object.
virtual | ~CXTPChartSeriesStyle ()
Destroys a CXTPChartSeriesStyle object, handles cleanup.
virtual CXTPChartSeriesLabel * | GetLabel () const
Call this method to gets the series label object.
virtual CXTPChartSeriesLabel * | SetLabel (CXTPChartSeriesLabel *pLabel)
Call this method to sets the series label object.
virtual CXTPChartErrorBar * | GetErrorBar () const
Call this method to gets the error bar object.
virtual CXTPChartErrorBar * | SetErrorBar (CXTPChartErrorBar *pErrorBar)
Call this method to sets the error bar object.
virtual CXTPChartColor | GetColor () const
Call this method to get the color of the series.
virtual void | SetColor (CXTPChartColor clr)
Call this method to set the color of the series.
virtual void | SetColorEach (BOOL bColorEach)
Call this method to set individual color for each point of the series.
virtual BOOL | IsColorEach () const
This method is called to check if individual color is used for each point of the series.
virtual CXTPChart3dRotation | Get3dRotation () const
Obtains rotation parameters for 3D chart.
virtual void | Set3dRotation (const CXTPChart3dRotation &rotation)
Sets rotation parameters for 3D chart.
virtual void | Set3dRotation (double dYaw, double dPitch, double dRoll)
Sets rotation parameters for 3D chart.
virtual BOOL | Is3dEdgeSmoothingEnabled () const
Enables/disables 3D edge smoothing.
virtual void | Enable3dEdgeSmoothing (BOOL bEnable=TRUE)
Enables/disables 3D edge smoothing.
virtual int | GetTransparency () const
Call this function to gets the transparency of the chart if it is supported by the chart type.
virtual void | SetTransparency (int nTransparency)
Call this function to sets the transparency of the chart if it is supported by the chart type.
virtual void | CorrectAxisSideMargins (CXTPChartAxis *pAxis, double nMinValue, double nMaxValue, double &nCorrection)
Provides default implementation for axis side margins correction.
virtual CXTPChartSeriesStyleAppearance * | GetStyleAppearance () const
Obtains associated style appearance pointer.
virtual void | ApplyTo (CXTPChartDeviceCommand *pCommand)
Applies the style to the command provided in case the command needs style specific details for correct drawing.
virtual int | GetSeriesPointValueIndex () const
Obtains the index of a point element for which an internal value can be otained.
- Public Member Functions inherited from CXTPChartElement
CXTPChartElement ()
Constructs a CXTPChartElement object.
virtual | ~CXTPChartElement ()
Destroys a CXTPChartElement object, handles cleanup.
virtual void | Release ()
Call this function to decrease the usage count of the object.
CXTPChartElement * | GetOwner () const
Call this function to get the owner element.
virtual void | OnChartChanged (XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic properties of the chart.
CXTPChartContent * | GetContent () const
Call this virtual function to get the chart content object.
CXTPChartAppearance * | GetAppearance () const
Call this function to get the the appearance of the chart.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Protected Member Functions

CXTPChartDiagram * | CreateDiagram ()=0
This method is called to allow style create diagram object.
CXTPChartSeriesView * | CreateView (CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)=0
This virtual method is called to create new view associated with current style.
BOOL | IsStyleDiagram (CXTPChartDiagram *pDiagram) const
This method is called to ask style if series can be inserted in existing diagram.
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.

Additional Inherited Members

- Public Attributes inherited from CXTPChartElement
- Protected Attributes inherited from CXTPChartSeriesStyle
CXTPChartSeriesLabel * | m_pLabel
Label object.
CXTPChartErrorBar * | m_pErrorBar
Error bar object.
CXTPChartColor | m_clrColor
Custom color of series.
BOOL | m_bColorEach
TRUE to color each point.
int | m_nTransparency
The transparency value in the range 0..255.
CXTPChart3dRotation | m_Rotation3d
3D rotation
BOOL | m_bSmooth3dEdges
3D edge smoothing
- Protected Attributes inherited from CXTPChartElement

Detailed Description

This class abstracts the basic style of a funnel serie.This class is a kind of CXTPChartSeriesStyle.

A funnel chart (or a circle graph) is a circular chart divided into sectors, illustrating percents. In a funnel chart, the arc length of each sector (and consequently its central angle and area), is proportional to the quantity it represents. Together, the sectors create a full disk.

Member Function Documentation

◆ CreateDiagram()

CXTPChartDiagram * CreateDiagram ( )
protectedpure virtual

This method is called to allow style create diagram object.

Returns
New diagram object that will contain series.

Reimplemented from CXTPChartSeriesStyle.

Implemented in CXTPChart3dFunnelSeriesStyle, and CXTPChartFunnelSeriesStyle.

◆ CreateView()

CXTPChartSeriesView * CreateView | ( | CXTPChartSeries * | pSeries,
 |  | CXTPChartDiagramView * | pDiagramView )
 protectedpure virtual

This virtual method is called to create new view associated with current style.

Parameters
pSeries | Series associated with style
pDiagramView | Parent diagram view
Returns
Pointer to new CXTPChartSeriesView object.

Implements CXTPChartSeriesStyle.

Implemented in CXTPChart3dFunnelSeriesStyle, and CXTPChartFunnelSeriesStyle.

◆ DoPropExchange()

void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Reads or writes this object from or to an archive.

Parameters
pPX A CXTPPropExchange object to serialize to or from.

Reimplemented from CXTPChartSeriesStyle.

◆ GetBorder()

AFX_INLINE CXTPChartBorder * GetBorder ( ) const

Call this function to get the border object.

Returns
Border object pointer.

◆ GetFillStyle()

AFX_INLINE CXTPChartFillStyle * GetFillStyle ( ) const

Call this function to get the background fill style.

Returns
Returns the pointer to CXTPChartFillStyle object, which abstracts various fill styles.

◆ GetHeightToWidthRatio()

AFX_INLINE double GetHeightToWidthRatio ( ) const

Gets height to width ratio of the funnel.

Returns
Current ratio value.

◆ GetPointDistance()

AFX_INLINE int GetPointDistance ( ) const

Gets point distance value.

Returns
Current distance value.

◆ IsEqualHeight()

AFX_INLINE BOOL IsEqualHeight ( ) const

Gets equal height flag.

Returns
Current equal height flag.

◆ IsStyleDiagram()

BOOL IsStyleDiagram ( CXTPChartDiagram * pDiagram ) const
protectedvirtual

This method is called to ask style if series can be inserted in existing diagram.

Parameters
pDiagram Diagram to check
Returns
TRUE if Series can be inserted to Diagram

Reimplemented from CXTPChartSeriesStyle.

◆ SetEqualHeight()

AFX_INLINE void SetEqualHeight ( BOOL bEqualHeight )

Sets equal height flag.

Parameters
bEqualHeight TRUE to make funnel points to have equal heights, otherwise FALSE.

◆ SetHeightToWidthRatio()

AFX_INLINE void SetHeightToWidthRatio ( double dRatio )

Sets height to width ratio of the funnel.

Parameters
dRatio Ratio value.

◆ SetPointDistance()

AFX_INLINE void SetPointDistance ( int nPointDistance )

Sets point distance value.

Parameters
nPointDistance Distance value.
The documentation for this class was generated from the following file:
  • XTPChartFunnelSeriesStyleBase.h


Toolkit Pro: CXTPChartFunnelSeriesView Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPChartFunnelSeriesView Class Reference

This class abstracts the view of a funnel series. More...

Inheritance diagram for CXTPChartFunnelSeriesView:
[legend]

Public Member Functions

CXTPChartFunnelSeriesView (CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Constructs a CXTPChartFunnelSeriesView object.
void | CalculatePointLayout (CXTPChartDeviceContext *pDC, CRect rcBounds)
Call this function to calculate the funnel series point layout.
virtual CXTPChartDeviceCommand * | CreateLegendDeviceCommand (CXTPChartDeviceContext *pDC, CRect rcBounds, CXTPChartColor color1, CXTPChartColor color2, CXTPChartColor clrBorder)
This function creates a label view drawing command object.
- Public Member Functions inherited from CXTPChartFunnelSeriesViewBase
CXTPChartFunnelSeriesViewBase (CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Constructs a CXTPChartFunnelSeriesViewBase object.
virtual | ~CXTPChartFunnelSeriesViewBase ()
Destroys a CXTPChartFunnelSeriesViewBase object, handle cleanup.
void | CalculateLabelLayout (CXTPChartDeviceContext *pDC)
Call this function to calculate the funnel series label layout.
virtual CXTPChartDiagramDomain * | CreateDiagramDomain (CXTPChartDeviceContext *pDC, CRect rcBounds)
Call this function to create the pie diagram domain object associated with this object.
CXTPChartDiagramDomain * | GetDomain () const
Use this function to get the pie diagram domain object associated with this object.
int | GetMaxLabelWidth () const
Obtains maximum allowed label width.

Protected Member Functions

virtual CXTPChartRectF | GetInnerBounds () const
Call this function to get the inner bounds of the diagram.
virtual CXTPChartSeriesPointView * | CreateSeriesPointView (CXTPChartDeviceContext *pDC, CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Use this function to create the funnel series point view object.
virtual CXTPChartDeviceCommand * | CreateDeviceCommand (CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
virtual CXTPChartDeviceCommand * | CreateLegendDeviceCommand (CXTPChartDeviceContext *pDC, CRect rcBounds)
This function creates a label view drawing command object.
- Protected Member Functions inherited from CXTPChartFunnelSeriesViewBase

Additional Inherited Members

- Protected Attributes inherited from CXTPChartFunnelSeriesViewBase
CXTPChartDiagramDomain * m_pDomain
Pointer to the diagram domain.

Detailed Description

This class abstracts the view of a funnel series.

This class is a kind of CXTPChartSeriesView.

A funnel chart (or a circle graph) is a circular chart divided into sectors, illustrating percents. In a funnel chart, the arc length of each sector (and consequently its central angle and area), is proportional to the quantity it represents. Together, the sectors create a full disk.

Constructor & Destructor Documentation

◆ CXTPChartFunnelSeriesView()

CXTPChartFunnelSeriesView | ( | CXTPChartSeries * | pSeries,
 |  | CXTPChartDiagramView * | pDiagramView )

Constructs a CXTPChartFunnelSeriesView object.

Parameters
pSeries | Pointer to a funnel series object.
pDiagramView | Pointer to the funnel diagram view.

Member Function Documentation

◆ CalculatePointLayout()

void CalculatePointLayout | ( | CXTPChartDeviceContext * | pDC,
 |  | CRect | rcBounds )
 virtual

Call this function to calculate the funnel series point layout.

Parameters
pDC | Pointer to the chart device context.
rcBounds | The rectangular boundary.

Reimplemented from CXTPChartFunnelSeriesViewBase.

◆ CreateDeviceCommand()

virtual CXTPChartDeviceCommand * CreateDeviceCommand ( CXTPChartDeviceContext * pDC )
protectedvirtual

This function creates a CXTPChartDeviceCommand object.

This object represents the rendering of the funnel series.

Parameters
pDC Pointer to a CXTPChartDeviceContext object.
Returns
Returns a CXTPChartDeviceCommand object. This object handles the rendering of an element in the chart. Here it handles the drawing of the funnel series.

Implements CXTPChartFunnelSeriesViewBase.

◆ CreateLegendDeviceCommand() [1/2]

virtual CXTPChartDeviceCommand * CreateLegendDeviceCommand | ( | CXTPChartDeviceContext * | pDC,
 |  | CRect | rcBounds )
 protectedvirtual

This function creates a label view drawing command object.

Parameters
pDC | Pointer to a CXTPChartDeviceContext object.
rcBounds | The rectangular boundary of the legend.
Returns
Returns a new label view drawing command object.

Implements CXTPChartFunnelSeriesViewBase.

◆ CreateLegendDeviceCommand() [2/2]

virtual CXTPChartDeviceCommand * CreateLegendDeviceCommand | ( | CXTPChartDeviceContext * | pDC,
 |  | CRect | rcBounds,
 |  | CXTPChartColor | color1,
 |  | CXTPChartColor | color2,
 |  | CXTPChartColor | clrBorder )
 virtual

This function creates a label view drawing command object.

Parameters
pDC | Pointer to a CXTPChartDeviceContext object.
rcBounds | The rectangular boundary of the legend.
color1 | First gradient color.
color2 | Second gradient color.
clrBorder | Border color.
Returns
Returns a new label view drawing command object.

Implements CXTPChartFunnelSeriesViewBase.

◆ CreateSeriesPointView()

virtual CXTPChartSeriesPointView * CreateSeriesPointView | ( | CXTPChartDeviceContext * | pDC,
 |  | CXTPChartSeriesPoint * | pPoint,
 |  | CXTPChartElementView * | pParentView )
 protectedvirtual

Use this function to create the funnel series point view object.

Parameters
pDC | Pointer to a chart device context.
pPoint | Pointer to a chart series point.
pParentView | Parent view pointer.
Returns
A pointer to the chart series point view.

Implements CXTPChartFunnelSeriesViewBase.

◆ GetInnerBounds()

virtual CXTPChartRectF GetInnerBounds ( ) const
protectedvirtual

Call this function to get the inner bounds of the diagram.

Returns
A chart rect object denoting the rectangular boundary.

Reimplemented from CXTPChartFunnelSeriesViewBase.

The documentation for this class was generated from the following file:
  • XTPChart2dFunnelSeriesView.h


Toolkit Pro: CXTPChartFunnelSeriesViewBase Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPChartFunnelSeriesViewBase Class Referenceabstract

This class abstracts the view of a funnel series.This class is a kind of CXTPChartSeriesView. More...

Inheritance diagram for CXTPChartFunnelSeriesViewBase:
[legend]

Public Member Functions

CXTPChartFunnelSeriesViewBase (CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Constructs a CXTPChartFunnelSeriesViewBase object.
virtual | ~CXTPChartFunnelSeriesViewBase ()
Destroys a CXTPChartFunnelSeriesViewBase object, handle cleanup.
virtual void | CalculatePointLayout (CXTPChartDeviceContext *pDC, CRect rcBounds)
Call this function to calculate the funnel series point layout.
void | CalculateLabelLayout (CXTPChartDeviceContext *pDC)
Call this function to calculate the funnel series label layout.
virtual CXTPChartDiagramDomain * | CreateDiagramDomain (CXTPChartDeviceContext *pDC, CRect rcBounds)
Call this function to create the pie diagram domain object associated with this object.
virtual CXTPChartRectF | GetInnerBounds () const
Call this function to get the inner bounds of the diagram.
CXTPChartDiagramDomain * | GetDomain () const
Use this function to get the pie diagram domain object associated with this object.
int | GetMaxLabelWidth () const
Obtains maximum allowed label width.
virtual CXTPChartDeviceCommand * | CreateLegendDeviceCommand (CXTPChartDeviceContext *pDC, CRect rcBounds, CXTPChartColor color1, CXTPChartColor color2, CXTPChartColor clrBorder)=0
This function creates a label view drawing command object.

Protected Member Functions

virtual CXTPChartSeriesPointView * | CreateSeriesPointView (CXTPChartDeviceContext *pDC, CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)=0
Use this function to create the funnel series point view object.
virtual CXTPChartDeviceCommand * | CreateDeviceCommand (CXTPChartDeviceContext *pDC)=0
This function creates a CXTPChartDeviceCommand object, this object represents the rendering of the funnel series.
virtual CXTPChartDeviceCommand * | CreateLegendDeviceCommand (CXTPChartDeviceContext *pDC, CRect rcBounds)=0
This function creates a label view drawing command object.

Protected Attributes

CXTPChartDiagramDomain * m_pDomain
Pointer to the diagram domain.

Detailed Description

This class abstracts the view of a funnel series.This class is a kind of CXTPChartSeriesView.

A funnel chart (or a circle graph) is a circular chart divided into sectors, illustrating percents. In a funnel chart, the arc length of each sector (and consequently its central angle and area), is proportional to the quantity it represents. Together, the sectors create a full disk.

Constructor & Destructor Documentation

◆ CXTPChartFunnelSeriesViewBase()

CXTPChartFunnelSeriesViewBase | ( | CXTPChartSeries * | pSeries,
 |  | CXTPChartDiagramView * | pDiagramView )

Constructs a CXTPChartFunnelSeriesViewBase object.

Parameters
pSeries | Pointer to funnel series object.
pDiagramView | Pointer to the funnel diagram view.

Member Function Documentation

◆ CalculateLabelLayout()

void CalculateLabelLayout ( CXTPChartDeviceContext * pDC )

Call this function to calculate the funnel series label layout.

Parameters
pDC Pointer to the chart device context.

◆ CalculatePointLayout()

virtual void CalculatePointLayout | ( | CXTPChartDeviceContext * | pDC,
 |  | CRect | rcBounds )
 virtual

Call this function to calculate the funnel series point layout.

Parameters
pDC | Pointer to the chart device context.
rcBounds | The rectangular boundary.

Reimplemented in CXTPChart3dFunnelSeriesView, and CXTPChartFunnelSeriesView.

◆ CreateDeviceCommand()

virtual CXTPChartDeviceCommand * CreateDeviceCommand ( CXTPChartDeviceContext * pDC )
protectedpure virtual

This function creates a CXTPChartDeviceCommand object, this object represents the rendering of the funnel series.

Parameters
pDC Pointer to a CXTPChartDeviceContext object.
Returns
Returns CXTPChartDeviceCommand object, this object handles the rendering of an element in the chart. Here it handles the drawing of the funnel series.

Reimplemented from CXTPChartElementView.

Implemented in CXTPChart3dFunnelSeriesView, and CXTPChartFunnelSeriesView.

◆ CreateDiagramDomain()

virtual CXTPChartDiagramDomain * CreateDiagramDomain | ( | CXTPChartDeviceContext * | pDC,
 |  | CRect | rcBounds )
 virtual

Call this function to create the pie diagram domain object associated with this object.

Parameters
rcBounds | The rectangular boundary of the diagram.
pDC | Pointer to the chart device context.
Returns
A pointer to the chart diagram domain object.

◆ CreateLegendDeviceCommand() [1/2]

virtual CXTPChartDeviceCommand * CreateLegendDeviceCommand | ( | CXTPChartDeviceContext * | pDC,
 |  | CRect | rcBounds )
 protectedpure virtual

This function creates a label view drawing command object.

Parameters
pDC | Pointer to a CXTPChartDeviceContext object.
rcBounds | The rectangular boundary of the legend.
Returns
Returns a new label view drawing command object.

Implements CXTPChartLegendItemView.

Implemented in CXTPChart3dFunnelSeriesView, and CXTPChartFunnelSeriesView.

◆ CreateLegendDeviceCommand() [2/2]

virtual CXTPChartDeviceCommand * CreateLegendDeviceCommand | ( | CXTPChartDeviceContext * | pDC,
 |  | CRect | rcBounds,
 |  | CXTPChartColor | color1,
 |  | CXTPChartColor | color2,
 |  | CXTPChartColor | clrBorder )
 pure virtual

This function creates a label view drawing command object.

Parameters
pDC | Pointer to a CXTPChartDeviceContext object.
rcBounds | The rectangular boundary of the legend.
color1 | First gradient color.
color2 | Second gradient color.
clrBorder | A COLORREF valueobject that representrscontains the border color
Returns
Returns a new label view drawing command object.

Implemented in CXTPChart3dFunnelSeriesView, and CXTPChartFunnelSeriesView.

◆ CreateSeriesPointView()

virtual CXTPChartSeriesPointView * CreateSeriesPointView | ( | CXTPChartDeviceContext * | pDC,
 |  | CXTPChartSeriesPoint * | pPoint,
 |  | CXTPChartElementView * | pParentView )
 protectedpure virtual

Use this function to create the funnel series point view object.

Parameters
pDC | Pointer to chart device context.
pPoint | Pointer to chart series point.
pParentView | Parent view pointer.
Returns
A pointer to the chart series point view.

Implemented in CXTPChart3dFunnelSeriesView, and CXTPChartFunnelSeriesView.

◆ GetDomain()

AFX_INLINE CXTPChartDiagramDomain * GetDomain ( ) const

Use this function to get the pie diagram domain object associated with this object.

Returns
A pointer to the chart diagram domain object.

◆ GetInnerBounds()

virtual CXTPChartRectF GetInnerBounds ( ) const
virtual

Call this function to get the inner bounds of the diagram.

Returns
A chart rect object denoting the rectangular boundary.

Reimplemented in CXTPChartFunnelSeriesView.

◆ GetMaxLabelWidth()

AFX_INLINE int GetMaxLabelWidth ( ) const

Obtains maximum allowed label width.

Returns
Maximum allowed label width.
The documentation for this class was generated from the following file:
  • XTPChartFunnelSeriesViewBase.h


Toolkit Pro: CXTPChartGanttSeriesPointView Class Reference

Public Member Functions | List of all members
CXTPChartGanttSeriesPointView Class Reference

This class represents the view of a Gantt series point, which is a kind of CXTPChartPointSeriesPointView. More...

Inheritance diagram for CXTPChartGanttSeriesPointView:
[legend]

Public Member Functions

CXTPChartGanttSeriesPointView (CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Constructs a CXTPChartGanttSeriesPointView object.
- Public Member Functions inherited from CXTPChartRangeBarSeriesPointView
CXTPChartRangeBarSeriesPointView (CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Constructs a CXTPChartRangeBarSeriesPointView object.
virtual CXTPChartDeviceCommand * | CreateDeviceCommand (CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
virtual void | UpdateMinMaxRange (double &nMinValue, double &nMaxValue) const
Provides a default empty implementation for min/max range update request.
- Public Member Functions inherited from CXTPChartBarSeriesPointView
CXTPChartBarSeriesPointView (CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Constructs a CXTPChartBarSeriesPointView object.
virtual CXTPChartDeviceCommand * | CreateLegendDeviceCommand (CXTPChartDeviceContext *pDC, CRect rcBounds)
This function creates a label view drawing command object.
- Public Member Functions inherited from CXTPChartSeriesPointView
CXTPChartSeriesPointView (CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Constructs the view object.
CXTPChartSeriesPointView (CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView, BOOL bAddToParent)
Constructs the view object.
CXTPChartSeriesPoint * | GetPoint () const
Obtains point model object.
CXTPChartSeriesView * | GetSeriesView () const
Obtains parent series view.
CXTPChartColor | GetColor () const
Obtain view color values.
CXTPChartColor | GetColor2 () const
Obtain view color values.
double | GetInternalValue () const
Obtains point interval value.
virtual CXTPChartString | GetLegendName () const
This function returns the legend name.
- Public Member Functions inherited from CXTPChartElementView
CXTPChartElementView (CXTPChartElementView *pParentView)
Constructs a CXTPChartElementView object.
CXTPChartElementView (CXTPChartElementView *pParentView, BOOL bAddToParent)
Constructs a CXTPChartElementView object.
CXTPChartElementView (CXTPChartContainer *pContainer)
Constructs a CXTPChartElementView object.
int | GetCount () const
Call this function to get the number of child views associated with this view.
CXTPChartElementView * | GetAt (int nIndex) const
Call this function to get a child view at a particular index.
CXTPChartElementView * | GetParentView () const
Call this function to get the parent view.
CXTPChartElementView * | AddChildView (CXTPChartElementView *pChildView)
Call this function to add a child view to the current view.
CXTPChartElementView ** GetChildren ()
Provides access to the collection of children elements owned by the view.
CRect | GetBounds () const
Obtains viewed object's bound rectangle.
CRect | GetBounds (BOOL bIncludingChildren) const
Obtains viewed object's bound rectangle.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.
- Public Member Functions inherited from CXTPChartLegendItemView
virtual | ~CXTPChartLegendItemView ()
Handles object destruction.

Additional Inherited Members

- Public Attributes inherited from CXTPChartSeriesPointView
double | m_dInternalValue
Point internal value.
- Protected Member Functions inherited from CXTPChartElementView
virtual | ~CXTPChartElementView ()
Destroys a CXTPChartElementView object, handles cleanup.
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.
- Protected Attributes inherited from CXTPChartSeriesPointView
CXTPChartSeriesPoint * | m_pPoint
Point model object pointer.
- Protected Attributes inherited from CXTPChartElementView
CArray< CXTPChartElementView *, CXTPChartElementView * > | m_arrChildren
The child view collection.
CXTPChartElementView * | m_pParentView
The parent view.
CXTPChartContainer * | m_pContainer
The parent container.
CRect | m_rcBounds
Bounding rectangle.

Detailed Description

This class represents the view of a Gantt series point, which is a kind of CXTPChartPointSeriesPointView.

Constructor & Destructor Documentation

◆ CXTPChartGanttSeriesPointView()

CXTPChartGanttSeriesPointView | ( | CXTPChartSeriesPoint * | pPoint,
 |  | CXTPChartElementView * | pParentView )

Constructs a CXTPChartGanttSeriesPointView object.

Parameters
pPoint | A pointer to the chart series point object.
pParentView | Parent view pointer.
The documentation for this class was generated from the following file:
  • XTPChartGanttSeriesStyle.h


Toolkit Pro: CXTPChartGanttSeriesStyle Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPChartGanttSeriesStyle Class Reference

This class represents a Gantt series style for the chart, which is a kind of CXTPChartBarSeriesStyle. More...

Inheritance diagram for CXTPChartGanttSeriesStyle:
[legend]

Public Member Functions

CXTPChartGanttSeriesStyle ()
Constructs a CXTPChartGanttSeriesStyle object.
virtual | ~CXTPChartGanttSeriesStyle ()
Destroys a CXTPChartGanttSeriesStyle object, handles cleanup.
void | DoPropExchange (CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
- Public Member Functions inherited from CXTPChartRangeBarSeriesStyle
CXTPChartRangeBarSeriesStyle ()
Constructs a CXTPChartRangeBarSeriesStyle object.
virtual | ~CXTPChartRangeBarSeriesStyle ()
Destroys a CXTPChartRangeBarSeriesStyle object, handles cleanup.
void | DoPropExchange (CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
- Public Member Functions inherited from CXTPChartBarSeriesStyle
CXTPChartBarSeriesStyle ()
Constructs a CXTPChartBarSeriesStyle object.
virtual | ~CXTPChartBarSeriesStyle ()
Destroys a CXTPChartBarSeriesStyle object, handles cleanup.
double | GetBarWidth () const
Call this function to get the width of the bar.
void | SetBarWidth (double dWidth)
Call this function to set the width of the bar.
- Public Member Functions inherited from CXTPChartDiagram2DSeriesStyle
CXTPChartDiagram2DSeriesStyle ()
Constructs a CXTPChartDiagram2DSeriesStyle object.
virtual | ~CXTPChartDiagram2DSeriesStyle ()
Destroys a CXTPChartDiagram2DSeriesStyle object, handles cleanup.
virtual CXTPChartDiagram * | CreateDiagram ()
Call this function to create the diagram for this series.
virtual BOOL | IsStyleDiagram (CXTPChartDiagram *pDiagram) const
Call this function to check whether the chart diagram object passed is a kind of 2D diagram (CXTPChartDiagram2D object).
- Public Member Functions inherited from CXTPChartSeriesStyle
CXTPChartSeriesStyle ()
Constructs a CXTPChartSeriesStyle object.
virtual | ~CXTPChartSeriesStyle ()
Destroys a CXTPChartSeriesStyle object, handles cleanup.
virtual CXTPChartSeriesLabel * | GetLabel () const
Call this method to gets the series label object.
virtual CXTPChartSeriesLabel * | SetLabel (CXTPChartSeriesLabel *pLabel)
Call this method to sets the series label object.
virtual CXTPChartErrorBar * | GetErrorBar () const
Call this method to gets the error bar object.
virtual CXTPChartErrorBar * | SetErrorBar (CXTPChartErrorBar *pErrorBar)
Call this method to sets the error bar object.
virtual CXTPChartColor | GetColor () const
Call this method to get the color of the series.
virtual void | SetColor (CXTPChartColor clr)
Call this method to set the color of the series.
virtual void | SetColorEach (BOOL bColorEach)
Call this method to set individual color for each point of the series.
virtual BOOL | IsColorEach () const
This method is called to check if individual color is used for each point of the series.
virtual CXTPChart3dRotation | Get3dRotation () const
Obtains rotation parameters for 3D chart.
virtual void | Set3dRotation (const CXTPChart3dRotation &rotation)
Sets rotation parameters for 3D chart.
virtual void | Set3dRotation (double dYaw, double dPitch, double dRoll)
Sets rotation parameters for 3D chart.
virtual BOOL | Is3dEdgeSmoothingEnabled () const
Enables/disables 3D edge smoothing.
virtual void | Enable3dEdgeSmoothing (BOOL bEnable=TRUE)
Enables/disables 3D edge smoothing.
virtual int | GetTransparency () const
Call this function to gets the transparency of the chart if it is supported by the chart type.
virtual void | SetTransparency (int nTransparency)
Call this function to sets the transparency of the chart if it is supported by the chart type.
virtual CXTPChartSeriesStyleAppearance * | GetStyleAppearance () const
Obtains associated style appearance pointer.
virtual void | ApplyTo (CXTPChartDeviceCommand *pCommand)
Applies the style to the command provided in case the command needs style specific details for correct drawing.
virtual int | GetSeriesPointValueIndex () const
Obtains the index of a point element for which an internal value can be otained.
- Public Member Functions inherited from CXTPChartElement
CXTPChartElement ()
Constructs a CXTPChartElement object.
virtual | ~CXTPChartElement ()
Destroys a CXTPChartElement object, handles cleanup.
virtual void | Release ()
Call this function to decrease the usage count of the object.
CXTPChartElement * | GetOwner () const
Call this function to get the owner element.
virtual void | OnChartChanged (XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic properties of the chart.
CXTPChartContent * | GetContent () const
Call this virtual function to get the chart content object.
CXTPChartAppearance * | GetAppearance () const
Call this function to get the the appearance of the chart.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Protected Member Functions

virtual CXTPChartSeriesView * | CreateView (CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Call this function to create the view of the Gantt series.
- Protected Member Functions inherited from CXTPChartRangeBarSeriesStyle
- Protected Member Functions inherited from CXTPChartBarSeriesStyle
virtual void | CorrectAxisSideMargins (CXTPChartAxis *pAxis, double nMinValue, double nMaxValue, double &nCorrection)
Call this function to correct the axis side margins.
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.

Additional Inherited Members

- Public Attributes inherited from CXTPChartElement
- Protected Attributes inherited from CXTPChartRangeBarSeriesStyle
- Protected Attributes inherited from CXTPChartBarSeriesStyle
- Protected Attributes inherited from CXTPChartDiagram2DSeriesStyle
int | m_nAxisIndexX
Holds index of secondary axisX, used when m_bSecondaryAxisX is TRUE.
int | m_nAxisIndexY
Holds index of secondary axisY, used when m_bSecondaryAxisY is TRUE.
- Protected Attributes inherited from CXTPChartSeriesStyle
CXTPChartSeriesLabel * | m_pLabel
Label object.
CXTPChartErrorBar * | m_pErrorBar
Error bar object.
CXTPChartColor | m_clrColor
Custom color of series.
BOOL | m_bColorEach
TRUE to color each point.
int | m_nTransparency
The transparency value in the range 0..255.
CXTPChart3dRotation | m_Rotation3d
3D rotation
BOOL | m_bSmooth3dEdges
3D edge smoothing
- Protected Attributes inherited from CXTPChartElement

Detailed Description

This class represents a Gantt series style for the chart, which is a kind of CXTPChartBarSeriesStyle.

A Gantt chart or Gantt graph is a chart with rectangular Gantts with lengths proportional to the values that they represent. Gantt charts are used for comparing two or more values that were taken over time or on different conditions, usually on small data sets.

Member Function Documentation

◆ CreateView()

virtual CXTPChartSeriesView * CreateView | ( | CXTPChartSeries * | pSeries,
 |  | CXTPChartDiagramView * | pDiagramView )
 protectedvirtual

Call this function to create the view of the Gantt series.

Parameters
pSeries | A pointer to the chart series object to which this object is associated with.
pDiagramView | A pointer to the chart diagram view object to which this object is associated with.
Returns
Returns a pointer to the associated series view object.

Reimplemented from CXTPChartRangeBarSeriesStyle.

◆ DoPropExchange()

void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Reads this object from or writes this object to an archive.

Parameters
pPX A CXTPPropExchange object to serialize to or from.

Reimplemented from CXTPChartBarSeriesStyle.

The documentation for this class was generated from the following file:
  • XTPChartGanttSeriesStyle.h


Toolkit Pro: CXTPChartGanttSeriesView Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPChartGanttSeriesView Class Reference

This class represents the view of a Gantt series, which is a kind of CXTPChartSeriesView. More...

Inheritance diagram for CXTPChartGanttSeriesView:
[legend]

Public Member Functions

CXTPChartGanttSeriesView (CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Constructs a CXTPChartGanttSeriesView object.
- Public Member Functions inherited from CXTPChartRangeBarSeriesView
CXTPChartRangeBarSeriesView (CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Constructs a CXTPChartRangeBarSeriesView object.
- Public Member Functions inherited from CXTPChartBarSeriesView
CXTPChartBarSeriesView (CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Constructs a CXTPChartBarSeriesView object.

Protected Member Functions

CXTPChartSeriesPointView * | CreateSeriesPointView (CXTPChartDeviceContext *pDC, CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Call this function to create a view of the Gantt series point.
- Protected Member Functions inherited from CXTPChartRangeBarSeriesView
CXTPChartSeriesPointView * | CreateSeriesPointView (CXTPChartDeviceContext *pDC, CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Call this function to create a view of the RangeBar series point.
- Protected Member Functions inherited from CXTPChartBarSeriesView
CXTPChartSeriesPointView * | CreateSeriesPointView (CXTPChartDeviceContext *pDC, CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Call this function to create a view of the bar series point.
void | BeforeUpdateRange (CXTPChartDeviceContext *pDC)
Call this function to calculate the layout of the bar series.
virtual CXTPChartDeviceCommand * | CreateLegendDeviceCommand (CXTPChartDeviceContext *pDC, CRect rcBounds)
This function creates a label view drawing command object.

Additional Inherited Members

- Protected Attributes inherited from CXTPChartBarSeriesView
int | m_nBarCount
The bar count in the series.
int | m_nBarIndex
The index of the bar series.

Detailed Description

This class represents the view of a Gantt series, which is a kind of CXTPChartSeriesView.

Constructor & Destructor Documentation

◆ CXTPChartGanttSeriesView()

CXTPChartGanttSeriesView | ( | CXTPChartSeries * | pSeries,
 |  | CXTPChartDiagramView * | pDiagramView )

Constructs a CXTPChartGanttSeriesView object.

Parameters
pSeries | A pointer to the chart series object.
pDiagramView | A pointer to the diagram view object.

Member Function Documentation

◆ CreateSeriesPointView()

CXTPChartSeriesPointView * CreateSeriesPointView | ( | CXTPChartDeviceContext * | pDC,
 |  | CXTPChartSeriesPoint * | pPoint,
 |  | CXTPChartElementView * | pParentView )
 protected

Call this function to create a view of the Gantt series point.

Parameters
pDC | A pointer to chart device context.
pPoint | A pointer to the chart series point object.
pParentView | Parent view pointer.
Returns
Returns a pointer to the series point view object.
The documentation for this class was generated from the following file:
  • XTPChartGanttSeriesStyle.h


Toolkit Pro: CXTPChartHighLowSeriesPointView Class Reference

Public Member Functions | List of all members
CXTPChartHighLowSeriesPointView Class Reference

This class abstracts the view of the stock series point of the chart. More...

Inheritance diagram for CXTPChartHighLowSeriesPointView:
[legend]

Public Member Functions

CXTPChartHighLowSeriesPointView (CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Constructs a CXTPChartHighLowSeriesPointView object.
virtual CXTPChartDeviceCommand * | CreateDeviceCommand (CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
CXTPChartPointF | GetScreenPoint (int nIndex)
Call this function to get the screen point from a point index.
- Public Member Functions inherited from CXTPChartSeriesPointView
CXTPChartSeriesPointView (CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Constructs the view object.
CXTPChartSeriesPointView (CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView, BOOL bAddToParent)
Constructs the view object.
CXTPChartSeriesPoint * | GetPoint () const
Obtains point model object.
CXTPChartSeriesView * | GetSeriesView () const
Obtains parent series view.
CXTPChartColor | GetColor () const
Obtain view color values.
CXTPChartColor | GetColor2 () const
Obtain view color values.
double | GetInternalValue () const
Obtains point interval value.
virtual CXTPChartString | GetLegendName () const
This function returns the legend name.
virtual CXTPChartDeviceCommand * | CreateLegendDeviceCommand (CXTPChartDeviceContext *pDC, CRect rcBounds)
This function creates a CXTPChartDeviceCommand object.
virtual void | UpdateMinMaxRange (double &nMinValue, double &nMaxValue) const
Provides a default empty implementation for min/max range update request.
- Public Member Functions inherited from CXTPChartElementView
CXTPChartElementView (CXTPChartElementView *pParentView)
Constructs a CXTPChartElementView object.
CXTPChartElementView (CXTPChartElementView *pParentView, BOOL bAddToParent)
Constructs a CXTPChartElementView object.
CXTPChartElementView (CXTPChartContainer *pContainer)
Constructs a CXTPChartElementView object.
int | GetCount () const
Call this function to get the number of child views associated with this view.
CXTPChartElementView * | GetAt (int nIndex) const
Call this function to get a child view at a particular index.
CXTPChartElementView * | GetParentView () const
Call this function to get the parent view.
CXTPChartElementView * | AddChildView (CXTPChartElementView *pChildView)
Call this function to add a child view to the current view.
CXTPChartElementView ** GetChildren ()
Provides access to the collection of children elements owned by the view.
CRect | GetBounds () const
Obtains viewed object's bound rectangle.
CRect | GetBounds (BOOL bIncludingChildren) const
Obtains viewed object's bound rectangle.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.
- Public Member Functions inherited from CXTPChartLegendItemView
virtual | ~CXTPChartLegendItemView ()
Handles object destruction.

Additional Inherited Members

- Public Attributes inherited from CXTPChartSeriesPointView
double | m_dInternalValue
Point internal value.
- Protected Member Functions inherited from CXTPChartElementView
virtual | ~CXTPChartElementView ()
Destroys a CXTPChartElementView object, handles cleanup.
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.
- Protected Attributes inherited from CXTPChartSeriesPointView
CXTPChartSeriesPoint * | m_pPoint
Point model object pointer.
- Protected Attributes inherited from CXTPChartElementView
CArray< CXTPChartElementView *, CXTPChartElementView * > | m_arrChildren
The child view collection.
CXTPChartElementView * | m_pParentView
The parent view.
CXTPChartContainer * | m_pContainer
The parent container.
CRect | m_rcBounds
Bounding rectangle.

Detailed Description

This class abstracts the view of the stock series point of the chart.

Objects of this class are a kind of series point view object of a chart.

Stock charts are used primarily to describe price movements of a security (finance), derivative, or currency over time.

Constructor & Destructor Documentation

◆ CXTPChartHighLowSeriesPointView()

CXTPChartHighLowSeriesPointView | ( | CXTPChartSeriesPoint * | pPoint,
 |  | CXTPChartElementView * | pParentView )

Constructs a CXTPChartHighLowSeriesPointView object.

Parameters
pPoint | A pointer to chart series point object.
pParentView | Parent view pointer.

Member Function Documentation

◆ CreateDeviceCommand()

virtual CXTPChartDeviceCommand * CreateDeviceCommand ( CXTPChartDeviceContext * pDC )
virtual

This function creates a CXTPChartDeviceCommand object.

This object represents the rendering of a stock chart series point.

Parameters
pDC Pointer to a CXTPChartDeviceContext object.
Returns
Returns a CXTPChartDeviceCommand object. This object handles the rendering of an element in the chart. Here it handles the drawing of the stock chart series point.

Reimplemented from CXTPChartElementView.

◆ GetScreenPoint()

CXTPChartPointF GetScreenPoint ( int nIndex )

Call this function to get the screen point from a point index.

Parameters
nIndex A zero-based index of the point in the series.
Returns
A CXTPChartPointF object specifying the coordinates of the point in the chosen index of the series.
The documentation for this class was generated from the following file:
  • XTPChartHighLowSeriesStyle.h


Toolkit Pro: CXTPChartHighLowSeriesStyle Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPChartHighLowSeriesStyle Class Reference

This class represents the stock series style in the chart. More...

Inheritance diagram for CXTPChartHighLowSeriesStyle:
[legend]

Public Member Functions

CXTPChartHighLowSeriesStyle ()
Constructs a CXTPChartHighLowSeriesStyle object.
virtual | ~CXTPChartHighLowSeriesStyle ()
Destroys a CXTPChartHighLowSeriesStyle object, handles cleanup.
void | SetLineThickness (int nLineThickness)
Call this function to set the line thickness of stock ticks.
int | GetLineThickness () const
Call this function to get the line thickness of stock ticks.
CXTPChartColor | GetCustomUpColor () const
Call this function to get the user-defined up day color of stock ticks.
CXTPChartColor | GetCustomDownColor () const
Call this function to get the user-defined down day color of stock ticks.
CXTPChartColor | GetUpColor () const
Call this function to get the up day color of stock ticks.
CXTPChartColor | GetDownColor () const
Call this function to get the down day color of stock ticks.
- Public Member Functions inherited from CXTPChartDiagram2DSeriesStyle
CXTPChartDiagram2DSeriesStyle ()
Constructs a CXTPChartDiagram2DSeriesStyle object.
virtual | ~CXTPChartDiagram2DSeriesStyle ()
Destroys a CXTPChartDiagram2DSeriesStyle object, handles cleanup.
void | DoPropExchange (CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
virtual CXTPChartDiagram * | CreateDiagram ()
Call this function to create the diagram for this series.
virtual BOOL | IsStyleDiagram (CXTPChartDiagram *pDiagram) const
Call this function to check whether the chart diagram object passed is a kind of 2D diagram (CXTPChartDiagram2D object).
- Public Member Functions inherited from CXTPChartSeriesStyle
CXTPChartSeriesStyle ()
Constructs a CXTPChartSeriesStyle object.
virtual | ~CXTPChartSeriesStyle ()
Destroys a CXTPChartSeriesStyle object, handles cleanup.
virtual CXTPChartSeriesLabel * | GetLabel () const
Call this method to gets the series label object.
virtual CXTPChartSeriesLabel * | SetLabel (CXTPChartSeriesLabel *pLabel)
Call this method to sets the series label object.
virtual CXTPChartErrorBar * | GetErrorBar () const
Call this method to gets the error bar object.
virtual CXTPChartErrorBar * | SetErrorBar (CXTPChartErrorBar *pErrorBar)
Call this method to sets the error bar object.
virtual CXTPChartColor | GetColor () const
Call this method to get the color of the series.
virtual void | SetColor (CXTPChartColor clr)
Call this method to set the color of the series.
virtual void | SetColorEach (BOOL bColorEach)
Call this method to set individual color for each point of the series.
virtual BOOL | IsColorEach () const
This method is called to check if individual color is used for each point of the series.
virtual CXTPChart3dRotation | Get3dRotation () const
Obtains rotation parameters for 3D chart.
virtual void | Set3dRotation (const CXTPChart3dRotation &rotation)
Sets rotation parameters for 3D chart.
virtual void | Set3dRotation (double dYaw, double dPitch, double dRoll)
Sets rotation parameters for 3D chart.
virtual BOOL | Is3dEdgeSmoothingEnabled () const
Enables/disables 3D edge smoothing.
virtual void | Enable3dEdgeSmoothing (BOOL bEnable=TRUE)
Enables/disables 3D edge smoothing.
virtual int | GetTransparency () const
Call this function to gets the transparency of the chart if it is supported by the chart type.
virtual void | SetTransparency (int nTransparency)
Call this function to sets the transparency of the chart if it is supported by the chart type.
virtual void | CorrectAxisSideMargins (CXTPChartAxis *pAxis, double nMinValue, double nMaxValue, double &nCorrection)
Provides default implementation for axis side margins correction.
virtual CXTPChartSeriesStyleAppearance * | GetStyleAppearance () const
Obtains associated style appearance pointer.
virtual void | ApplyTo (CXTPChartDeviceCommand *pCommand)
Applies the style to the command provided in case the command needs style specific details for correct drawing.
virtual int | GetSeriesPointValueIndex () const
Obtains the index of a point element for which an internal value can be otained.
- Public Member Functions inherited from CXTPChartElement
CXTPChartElement ()
Constructs a CXTPChartElement object.
virtual | ~CXTPChartElement ()
Destroys a CXTPChartElement object, handles cleanup.
virtual void | Release ()
Call this function to decrease the usage count of the object.
CXTPChartElement * | GetOwner () const
Call this function to get the owner element.
virtual void | OnChartChanged (XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic properties of the chart.
CXTPChartContent * | GetContent () const
Call this virtual function to get the chart content object.
CXTPChartAppearance * | GetAppearance () const
Call this function to get the the appearance of the chart.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Protected Member Functions

virtual CXTPChartSeriesView * CreateView (CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Call this function to create the view of the stock series.
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.

Protected Attributes

int | m_nLineThickness
The stock tick line thickness.
CXTPChartColor | m_clrDownColor
User-defined down day color.
CXTPChartColor | m_clrUpColor
User-defined up day color.
- Protected Attributes inherited from CXTPChartDiagram2DSeriesStyle
int | m_nAxisIndexX
Holds index of secondary axisX, used when m_bSecondaryAxisX is TRUE.
int | m_nAxisIndexY
Holds index of secondary axisY, used when m_bSecondaryAxisY is TRUE.
- Protected Attributes inherited from CXTPChartSeriesStyle
CXTPChartSeriesLabel * | m_pLabel
Label object.
CXTPChartErrorBar * | m_pErrorBar
Error bar object.
CXTPChartColor | m_clrColor
Custom color of series.
BOOL | m_bColorEach
TRUE to color each point.
int | m_nTransparency
The transparency value in the range 0..255.
CXTPChart3dRotation | m_Rotation3d
3D rotation
BOOL | m_bSmooth3dEdges
3D edge smoothing
- Protected Attributes inherited from CXTPChartElement

Detailed Description

This class represents the stock series style in the chart.

Objects of this class are a kind of series style of a chart.

Stock charts are used primarily to describe price movements of a security (finance), derivative, or currency over time.

Member Function Documentation

◆ CreateView()

virtual CXTPChartSeriesView * CreateView | ( | CXTPChartSeries * | pSeries,
 |  | CXTPChartDiagramView * | pDiagramView )
 protectedvirtual

Call this function to create the view of the stock series.

Parameters
pSeries | A pointer to the chart series object.
pDiagramView | Pointer to a chart diagram view object.
Returns
A pointer to a CXTPChartHighLowSeriesView object, which is a kind of CXTPChartSeriesView.

Implements CXTPChartSeriesStyle.

Reimplemented in CXTPChartCandleStickSeriesStyle.

◆ GetCustomDownColor()

AFX_INLINE CXTPChartColor GetCustomDownColor ( ) const

Call this function to get the user-defined down day color of stock ticks.

Returns
An CXTPChartColor object representing a 32 bit ARGB value.

◆ GetCustomUpColor()

AFX_INLINE CXTPChartColor GetCustomUpColor ( ) const

Call this function to get the user-defined up day color of stock ticks.

Returns
An CXTPChartColor object representing a 32 bit ARGB value.

◆ GetDownColor()

CXTPChartColor GetDownColor ( ) const

Call this function to get the down day color of stock ticks.

Returns
An CXTPChartColor object representing a 32 bit ARGB value.

◆ GetLineThickness()

AFX_INLINE int GetLineThickness ( ) const

Call this function to get the line thickness of stock ticks.

Returns
An integer value for the thickness of the tick lines currently used.

◆ GetUpColor()

CXTPChartColor GetUpColor ( ) const

Call this function to get the up day color of stock ticks.

Returns
An CXTPChartColor object representing a 32 bit ARGB value.

◆ SetLineThickness()

AFX_INLINE void SetLineThickness ( int nLineThickness )

Call this function to set the line thickness of stock ticks.

Parameters
nLineThickness The thickness of the tick lines.
The documentation for this class was generated from the following file:
  • XTPChartHighLowSeriesStyle.h


Toolkit Pro: CXTPChartHighLowSeriesView Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPChartHighLowSeriesView Class Reference

This class abstracts the view of the stock series of the chart. More...

Public Member Functions

CXTPChartHighLowSeriesView (CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Constructs a CXTPChartHighLowSeriesView object.

Protected Member Functions

CXTPChartSeriesPointView * | CreateSeriesPointView (CXTPChartDeviceContext *pDC, CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Call this function to create a stock series point view object.
virtual CXTPChartDeviceCommand * | CreateLegendDeviceCommand (CXTPChartDeviceContext *pDC, CRect rcBounds)
This function creates a label view drawing command object.

Detailed Description

This class abstracts the view of the stock series of the chart.

Objects of this class are a kind of series view object of a chart.

Stock charts are used primarily to describe price movements of a security (finance), derivative, or currency over time.

Constructor & Destructor Documentation

◆ CXTPChartHighLowSeriesView()

CXTPChartHighLowSeriesView | ( | CXTPChartSeries * | pSeries,
 |  | CXTPChartDiagramView * | pDiagramView )

Constructs a CXTPChartHighLowSeriesView object.

Parameters
pSeries | A pointer to a chart series object.
pDiagramView | A pointer to a chart diagram view object.

Member Function Documentation

◆ CreateLegendDeviceCommand()

virtual CXTPChartDeviceCommand * CreateLegendDeviceCommand | ( | CXTPChartDeviceContext * | pDC,
 |  | CRect | rcBounds )
 protectedvirtual

This function creates a label view drawing command object.

Parameters
pDC | Pointer to a CXTPChartDeviceContext object.
rcBounds | The rectangular boundary of the legend.
Returns
Returns a new label view drawing command object.

Implements CXTPChartLegendItemView.

◆ CreateSeriesPointView()

CXTPChartSeriesPointView * CreateSeriesPointView | ( | CXTPChartDeviceContext * | pDC,
 |  | CXTPChartSeriesPoint * | pPoint,
 |  | CXTPChartElementView * | pParentView )
 protected

Call this function to create a stock series point view object.

Parameters
pDC | A pointer to a chart device context.
pPoint | A pointer to a chart series point object.
pParentView | Parent view pointer.
Returns
A pointer to a stock chart series point view object.
The documentation for this class was generated from the following file:
  • XTPChartHighLowSeriesStyle.h


Toolkit Pro: CXTPChartHitTestElementCommand Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPChartHitTestElementCommand Class Reference

Defines a base class interface for a 2D hit test command. More...

Inheritance diagram for CXTPChartHitTestElementCommand:
[legend]

Public Member Functions

CXTPChartHitTestElementCommand (CXTPChartElement *pElement)
Constructs a CXTPChartHitTestElementCommand object instance.
CXTPChartHitTestElementCommand (CXTPChartElement *pElement, const CRect &rcBounds)
Constructs a CXTPChartHitTestElementCommand object instance.
CXTPChartHitTestElementCommand (CXTPChartElement *pElement, const CXTPChartRectF &rcBounds)
Constructs a CXTPChartHitTestElementCommand object instance.
virtual CXTPChartElement * | HitTest (CPoint point, CXTPChartElement *pParent) const
Performs recursive hit testing of the element at the specified point.
- Public Member Functions inherited from CXTPChartDeviceCommand
CXTPChartDeviceCommand ()
Constructs a CXTPChartDeviceCommand object.
virtual | ~CXTPChartDeviceCommand ()
Destroys a CXTPChartDeviceCommand object, handles cleanup.
BOOL | IsCommitted () const
Determines if the execution of the command has been committed.
void | Commit ()
Commits the execution of the command.
int | GetChildCommandCount () const
Obtains the number of immediate children commands.
CXTPChartDeviceCommand * | GetChildCommand (int nIndex) const
Obtains immediate child command point by index.
CXTPChartDeviceCommand * | AddChildCommand (CXTPChartDeviceCommand *pCommand)
Call this function to add a child device command.
virtual void | Execute (CXTPChartDeviceContext *pDC)
Call this function to execute the drawing.
virtual void | BeforeExecute (CXTPChartDeviceContext *pDC)
This method gets called before a command is executed which allows for the customization of command behavior.
virtual void | AfterExecute (CXTPChartDeviceContext *pDC)
This method gets called after a command is executed which allows for the customization of command behavior.
virtual void | ExecuteOverride (CXTPChartDeviceContext *pDC)
Override this function to write the drawing code for specific objects.
UINT | GetPassNumber () const
Get the number of executions made by the command.
virtual void | ApplySeriesStyle (CXTPChartSeriesStyle *pStyle)
Applies series style to the current element.
virtual void | Prepare (CXTPChartDeviceContext *pDC)
Performs inital preparation steps necessary for successful command execution.
virtual void | PrepareOverride (CXTPChartDeviceContext *pDC)
Derived implementation must override this method for implementing implementation specific preparation behavior.
virtual BOOL | IsEnabled () const
Determines if the command is currently enabled.
void | SetEnabled (BOOL bEnabled=TRUE)
Enables/disable the command.
CXTPChartDeviceContext * | GetCurrentDC () const
Obtains device context pointer for which the command is currenly being prepared or executed.
void | BindView (CXTPChartElementView *pView)
Binds a view to the command object.
CXTPChartElementView * | GetBoundView () const
Obtains a bound view pointer or NULL if no view is bound.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.
- Public Member Functions inherited from CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents >
void | Subscribe (CXTPChartDeviceCommandEvents *pObserver, CXTPSubscriptionList< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > *pSubcriptionList=NULL)
Subscribes a unique observer for events.
void | Unsubscribe (CXTPChartDeviceCommandEvents *pObserver)
Unsubscribes an observer from events.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *))
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *))
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.

Protected Attributes

CXTPChartElement * | m_pElement
Chart element pointer for which hit testing is to be performed.
CRect | m_rcBounds
Hit test boundary rectangle.
- Protected Attributes inherited from CXTPChartDeviceCommand
CArray< CXTPChartDeviceCommand *, CXTPChartDeviceCommand * > | m_arrChildren
< The array of child device commands.

Additional Inherited Members

- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.
- Protected Member Functions inherited from CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents >
CXTPObservable ()
Constructs an observable object.
~CXTPObservable ()
Handles observable object destruction.

Detailed Description

Defines a base class interface for a 2D hit test command.

Constructor & Destructor Documentation

◆ CXTPChartHitTestElementCommand() [1/3]

CXTPChartHitTestElementCommand ( CXTPChartElement * pElement )

Constructs a CXTPChartHitTestElementCommand object instance.

Parameters
pElement Chart element pointer for which hit testing is to be performed including all its children elements recursively.

◆ CXTPChartHitTestElementCommand() [2/3]

CXTPChartHitTestElementCommand | ( | CXTPChartElement * | pElement,
 |  | const CRect & | rcBounds )

Constructs a CXTPChartHitTestElementCommand object instance.

Parameters
pElement | Chart element pointer for which hit testing is to be performed including all its children elements recursively.
rcBounds | Hit test boundary rectangle.

◆ CXTPChartHitTestElementCommand() [3/3]

CXTPChartHitTestElementCommand | ( | CXTPChartElement * | pElement,
 |  | const CXTPChartRectF & | rcBounds )

Constructs a CXTPChartHitTestElementCommand object instance.

Parameters
pElement | Chart element pointer for which hit testing is to be performed including all its children elements recursively.
rcBounds | Hit test boundary rectangle.

Member Function Documentation

◆ HitTest()

virtual CXTPChartElement * HitTest | ( | CPoint | point,
 |  | CXTPChartElement * | pParent ) const
 virtual

Performs recursive hit testing of the element at the specified point.

Parameters
point | Point in which an element is to be found.
pParent | Parent element pointer.
Returns
A pointer to the element found at the specified point or NULL if no element is found.

Reimplemented from CXTPChartDeviceCommand.

The documentation for this class was generated from the following file:
  • XTPChartDeviceCommand.h


Toolkit Pro: CXTPChartLegend Class Reference

Public Member Functions | Public Attributes | Protected Member Functions | List of all members
CXTPChartLegend Class Reference

This class represents a chart legend as a kind of chart element. More...

Inheritance diagram for CXTPChartLegend:
[legend]

Public Member Functions

CXTPChartLegend (CXTPChartContent *pOwner)
Constructs a CXTPChartLegend object.
virtual | ~CXTPChartLegend ()
Destroys a CXTPChartLegend object, handles cleanup.
BOOL | IsVisible () const
Call this function to see whether the legend is visible.
void | SetVisible (BOOL bVisible)
Call this function to set the legend visible/invisible.
CXTPChartFont * | GetFont () const
This function returns the CXTPChartFont object pointer associated with the CXTPChartLegend object.
void | SetFont (CXTPChartFont *pFont)
Call this function, to set the font for the legend.
BOOL | IsMarkerVisible () const
This function returns whether the marker is visible.
void | SetMarkerVisible (BOOL bVisible)
Call this function to set the marker visible/invisible.
CSize | GetMarkerSize () const
Call this function to get the marker size (width and height).
void | SetMarkerSize (CSize sz)
Call this function to set the marker size.
void | SetTextColor (const CXTPChartColor &clrTextColor)
Call this function to set the text color of the legend.
CXTPChartColor | GetTextColor () const
Call this function to get the current text color.
CXTPChartColor | GetActualTextColor () const
Call this function to get the actual text color.
void | SetBackgroundColor (const CXTPChartColor &clrBackgroundColor)
Call this function to set the background color of the legend.
CXTPChartColor | GetBackgroundColor () const
Call this function to get the current background color.
CXTPChartColor | GetActualBackgroundColor () const
Call this function to get the actual background color of the legend.
CXTPChartColor | GetActualBorderColor () const
Call this function to get the actual border color of the legend.
void | SetAntialiasing (BOOL bAntialiasing)
Call this function to set anti-aliasing ON or OFF.
BOOL | GetAntialiasing () const
Call this function to check if anti-aliasing is ON or OFF.
CXTPChartFillStyle * | GetFillStyle () const
Call this function to get the fill style.
CXTPChartBorder * | GetBorder () const
Call this function to get the legend border.
void | SetHorizontalAlignment (XTPChartLegendAlignment nAlignment)
Call this function to set the legend's horizontal alignment.
XTPChartLegendAlignment | GetHorizontalAlignment () const
Call this function to get the legend's horizontal alignment.
void | SetVerticalAlignment (XTPChartLegendAlignment nAlignment)
Call this function to set the legend's vertical alignment.
XTPChartLegendAlignment | GetVerticalAlignment () const
Call this function to get the legend's vertical alignment.
void | SetDirection (XTPChartLegendDirection nDirection)
Call this function to set the legend's direction.
XTPChartLegendDirection | GetDirection () const
Call this function to get the legend's direction.
virtual CXTPChartLegendView * | CreateView (CXTPChartDeviceContext *pDC, CXTPChartElementView *pParentView)
This function creates the view (CXTPChartLegendView) of the legend.
void | SetSortDirection (XTPChartLegendSortDirection value)
This function sets sort direction of legend.
XTPChartLegendSortDirection | GetSortDirection () const
This function return sort direction of legend.
- Public Member Functions inherited from CXTPChartTextElement
- Public Member Functions inherited from CXTPChartElement
CXTPChartElement ()
Constructs a CXTPChartElement object.
virtual | ~CXTPChartElement ()
Destroys a CXTPChartElement object, handles cleanup.
virtual void | Release ()
Call this function to decrease the usage count of the object.
CXTPChartElement * | GetOwner () const
Call this function to get the owner element.
virtual void | OnChartChanged (XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic properties of the chart.
CXTPChartContent * | GetContent () const
Call this virtual function to get the chart content object.
CXTPChartAppearance * | GetAppearance () const
Call this function to get the the appearance of the chart.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Public Attributes

BOOL | m_bVisible
TRUE if the legend is visible.
BOOL | m_bAntialiasing
TRUE if antialiasing is turned ON.
CXTPChartBorder * | m_pBorder
Pointer to chart border object.
CXTPChartFillStyle * | m_pFillStyle
Pointer to chart fill style object.
CXTPChartFont * | m_pFont
Pointer to font object.
CSize | m_szMarkerSize
Size of the marker.
CXTPChartColor | m_clrBackgroundColor
Chart background color.
CXTPChartColor | m_clrTextColor
Chart text color.
BOOL | m_bMarkerVisible
TRUE if marker is visible.
int | m_nColumnCount
Column Count.
XTPChartLegendAlignment | m_nHorizontalAlignment
Legend horizontal alignment.
XTPChartLegendAlignment | m_nVerticalAlignment
Legend vertical alignment.
XTPChartLegendDirection | m_nDirection
Legend orientation.
XTPChartLegendSortDirection | m_nSortDirection
Legend sorting direction.
- Public Attributes inherited from CXTPChartElement

Protected Member Functions

virtual void DoPropExchange (CXTPPropExchange *pPX)
Call this member function to Store/Load the properties of a legend object using the specified data object.
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.

Detailed Description

This class represents a chart legend as a kind of chart element.

It abstracts all the features of a chart legend.

Constructor & Destructor Documentation

◆ CXTPChartLegend()

CXTPChartLegend ( CXTPChartContent * pOwner )

Constructs a CXTPChartLegend object.

Parameters
pOwner Pointer to the CXTPChartContent object which owns this legend.

Member Function Documentation

◆ CreateView()

virtual CXTPChartLegendView * CreateView | ( | CXTPChartDeviceContext * | pDC,
 |  | CXTPChartElementView * | pParentView )
 virtual

This function creates the view (CXTPChartLegendView) of the legend.

Parameters
pDC | The chart device context object pointer.
pParentView | The parent view of the legend.
Returns
Returns a pointer to the newly created CXTPChartLegendView object.

◆ DoPropExchange()

virtual void DoPropExchange ( CXTPPropExchange * pPX )
protectedvirtual

Call this member function to Store/Load the properties of a legend object using the specified data object.

Parameters
pPX Source or destination CXTPPropExchange data object reference.

This member function is used to store property data to or load property data from storage.

Reimplemented from CXTPChartElement.

◆ GetActualBackgroundColor()

CXTPChartColor GetActualBackgroundColor ( ) const

Call this function to get the actual background color of the legend.

Returns
Returns a CXTPChartColor object, which gives the ARGB value of the actual background color.

◆ GetActualBorderColor()

CXTPChartColor GetActualBorderColor ( ) const

Call this function to get the actual border color of the legend.

Returns
Returns a CXTPChartColor object, which gives the ARGB value of the actual border color.

◆ GetActualTextColor()

CXTPChartColor GetActualTextColor ( ) const

Call this function to get the actual text color.

Returns
Returns a CXTPChartColor object, which gives the ARGB value of the actual text color.

◆ GetAntialiasing()

AFX_INLINE BOOL GetAntialiasing ( ) const
virtual

Call this function to check if anti-aliasing is ON or OFF.

Anti-aliasing is the smoothing of sharp edges of text and drawing.

Returns
A BOOL value. TRUE if anti-aliasing is ON, FALSE if anti-aliasing is OFF.

Implements CXTPChartTextElement.

◆ GetBackgroundColor()

CXTPChartColor GetBackgroundColor ( ) const

Call this function to get the current background color.

Returns
Returns a CXTPChartColor object, which gives the ARGB value of the current background color.

◆ GetBorder()

AFX_INLINE CXTPChartBorder * GetBorder ( ) const

Call this function to get the legend border.

Returns
Returns a pointer to a CXTPChartBorder object, which represents the border of the legend.

◆ GetDirection()

AFX_INLINE XTPChartLegendDirection GetDirection ( ) const

Call this function to get the legend's direction.

Either top to bottom or left to right.

Returns
Returns an enumerated value XTPChartLegendDirection, which represents the the direction of the legend.

◆ GetFillStyle()

AFX_INLINE CXTPChartFillStyle * GetFillStyle ( ) const

Call this function to get the fill style.

Returns
Returns a pointer to a CXTPChartFillStyle object, which represents the fill style of the legend.

◆ GetFont()

AFX_INLINE CXTPChartFont * GetFont ( ) const
virtual

This function returns the CXTPChartFont object pointer associated with the CXTPChartLegend object.

Returns
Returns a pointer to CXTPChartFont.

Implements CXTPChartTextElement.

◆ GetHorizontalAlignment()

AFX_INLINE XTPChartLegendAlignment GetHorizontalAlignment ( ) const

Call this function to get the legend's horizontal alignment.

Returns
Returns an enumerated value XTPChartLegendAlignment, which represents the the kind of horizontal alignment chosen.

◆ GetMarkerSize()

AFX_INLINE CSize GetMarkerSize ( ) const

Call this function to get the marker size (width and height).

Returns
Returns a CSize object, which gives the size of the marker.

◆ GetSortDirection()

AFX_INLINE XTPChartLegendSortDirection GetSortDirection ( ) const

This function return sort direction of legend.

Returns
Returns sort direction value.

◆ GetTextColor()

CXTPChartColor GetTextColor ( ) const

Call this function to get the current text color.

Returns
Returns a CXTPChartColor object, which gives the ARGB value of the current text color.

◆ GetVerticalAlignment()

AFX_INLINE XTPChartLegendAlignment GetVerticalAlignment ( ) const

Call this function to get the legend's vertical alignment.

Returns
Returns an enumerated value XTPChartLegendAlignment, which represents the the kind of vertical alignment chosen.

◆ IsMarkerVisible()

AFX_INLINE BOOL IsMarkerVisible ( ) const

This function returns whether the marker is visible.

Returns
Returns a BOOL value. TRUE if the marker is visible, FALSE otherwise.

◆ IsVisible()

AFX_INLINE BOOL IsVisible ( ) const

Call this function to see whether the legend is visible.

Returns
Returns a BOOL value. TRUE if the legend is visible, FALSE otherwise.

◆ SetAntialiasing()

AFX_INLINE void SetAntialiasing ( BOOL bAntialiasing )

Call this function to set anti-aliasing ON or OFF.

Anti-aliasing is the smoothing of sharp edges of text and drawing.

Parameters
bAntialiasing A BOOL value. TRUE to set anti-aliasing to ON, FALSE to set anti-aliasing to OFF.

◆ SetBackgroundColor()

void SetBackgroundColor ( const CXTPChartColor & clrBackgroundColor )

Call this function to set the background color of the legend.

Parameters
clrBackgroundColor A CXTPChartColor object representing the ARGB value of the color of choice.

◆ SetDirection()

AFX_INLINE void SetDirection ( XTPChartLegendDirection nDirection )

Call this function to set the legend's direction.

Either top to bottom or left to right.

Parameters
nDirection value indicating the layout direction of panels

◆ SetFont()

void SetFont ( CXTPChartFont * pFont )

Call this function, to set the font for the legend.

Parameters
pFont A CXTPChartFont object, represents the type of font.

◆ SetHorizontalAlignment()

AFX_INLINE void SetHorizontalAlignment ( XTPChartLegendAlignment nAlignment )

Call this function to set the legend's horizontal alignment.

Parameters
nAlignment An enumerated value representing the legend alignment.

◆ SetMarkerSize()

AFX_INLINE void SetMarkerSize ( CSize sz )

Call this function to set the marker size.

Parameters
sz A CSize object representing the width and height of the marker.

◆ SetMarkerVisible()

AFX_INLINE void SetMarkerVisible ( BOOL bVisible )

Call this function to set the marker visible/invisible.

Parameters
bVisible A BOOL value. TRUE to set the marker visible, FALSE to hide the marker.

◆ SetSortDirection()

AFX_INLINE void SetSortDirection ( XTPChartLegendSortDirection value )

This function sets sort direction of legend.

Parameters
value sort direction value.

◆ SetTextColor()

void SetTextColor ( const CXTPChartColor & clrTextColor )

Call this function to set the text color of the legend.

Parameters
clrTextColor A CXTPChartColor object representing the ARGB value of the color of choice.

◆ SetVerticalAlignment()

AFX_INLINE void SetVerticalAlignment ( XTPChartLegendAlignment nAlignment )

Call this function to set the legend's vertical alignment.

Parameters
nAlignment An enumerated value representing the legend alignment.

◆ SetVisible()

AFX_INLINE void SetVisible ( BOOL bVisible )

Call this function to set the legend visible/invisible.

Parameters
bVisible A BOOL value. TRUE to set the legend visible, FALSE to hide the legend.
The documentation for this class was generated from the following file:
  • XTPChartLegend.h


Toolkit Pro: CXTPChartLegendAppearance Class Reference

Public Member Functions | Public Attributes | List of all members
CXTPChartLegendAppearance Class Reference

This class represents the appearance of a chart legend. More...

Inheritance diagram for CXTPChartLegendAppearance:
[legend]

Public Member Functions

CXTPChartLegendAppearance (CXTPChartElement *pOwner)
Constructs a CXTPChartLegendAppearance object.
void | DoPropExchange (CXTPPropExchange *pPX)
Call this member function to Store/Load the properties related to the appearance of a chart legend using the specified data object.
- Public Member Functions inherited from CXTPChartElementAppearance
CXTPChartElementAppearance (CXTPChartElement *pOwner)
Constructs a CXTPChartElementAppearance object.
virtual | ~CXTPChartElementAppearance ()
Destroys a CXTPChartElementAppearance object, handles cleanup.
virtual void | ApplyToDeviceContext (CXTPChartDeviceContext *pDC)
Applies implementation specific appearance settings to the device context provided.
- Public Member Functions inherited from CXTPChartElement
CXTPChartElement ()
Constructs a CXTPChartElement object.
virtual | ~CXTPChartElement ()
Destroys a CXTPChartElement object, handles cleanup.
virtual void | Release ()
Call this function to decrease the usage count of the object.
CXTPChartElement * | GetOwner () const
Call this function to get the owner element.
virtual void | OnChartChanged (XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic properties of the chart.
CXTPChartContent * | GetContent () const
Call this virtual function to get the chart content object.
CXTPChartAppearance * | GetAppearance () const
Call this function to get the the appearance of the chart.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Public Attributes

CXTPChartColor | TextColor
The legend text color.
CXTPChartColor | BackgroundColor
The legend background color.
CXTPChartColor | BorderColor
The legend border color.
- Public Attributes inherited from CXTPChartElement

Additional Inherited Members

- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.
- Protected Attributes inherited from CXTPChartElement

Detailed Description

This class represents the appearance of a chart legend.

Constructor & Destructor Documentation

◆ CXTPChartLegendAppearance()

CXTPChartLegendAppearance ( CXTPChartElement * pOwner )

Constructs a CXTPChartLegendAppearance object.

Parameters
pOwner Pointer to an owner element.

Member Function Documentation

◆ DoPropExchange()

void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Call this member function to Store/Load the properties related to the appearance of a chart legend using the specified data object.

Parameters
pPX Source or destination CXTPPropExchange data object reference.

This member function is used to store or load property data to or from a storage.

Reimplemented from CXTPChartElement.

The documentation for this class was generated from the following file:
  • XTPChartAppearance.h


Toolkit Pro: CXTPChartLegendItemView Class Reference

Public Member Functions | List of all members
CXTPChartLegendItemView Class Referenceabstract

CXTPChartLegendItemView is an abstract base class which represents a chart legend item. More...

Inheritance diagram for CXTPChartLegendItemView:
[legend]

Public Member Functions

virtual | ~CXTPChartLegendItemView ()
Handles object destruction.
virtual CXTPChartString | GetLegendName () const =0
This function returns the legend name.
virtual CXTPChartDeviceCommand * | CreateLegendDeviceCommand (CXTPChartDeviceContext *pDC, CRect rcBounds)=0
This function creates a CXTPChartDeviceCommand object, this object represents the rendering of a legend item in the chart.

Detailed Description

CXTPChartLegendItemView is an abstract base class which represents a chart legend item.

This class can also act as a multiple inheritance base class.

Member Function Documentation

◆ CreateLegendDeviceCommand()

virtual CXTPChartDeviceCommand * CreateLegendDeviceCommand | ( | CXTPChartDeviceContext * | pDC,
 |  | CRect | rcBounds )
 pure virtual

This function creates a CXTPChartDeviceCommand object, this object represents the rendering of a legend item in the chart.

Parameters
pDC | Pointer to a valid device context.
rcBounds | The bounding rectange.
Returns
Returns a CXTPChartDeviceCommand object. This object handles the rendering of an element in the chart. Here it handles the drawing of the legend item.

Implemented in CXTPChart3dFunnelSeriesPointView, CXTPChart3dFunnelSeriesView, CXTPChart3dPieSeriesPointView, CXTPChart3dPieSeriesView, CXTPChart3dPyramidSeriesPointView, CXTPChart3dPyramidSeriesView, CXTPChartAreaSeriesView, CXTPChartAxisConstantLine, CXTPChartAxisStrip, CXTPChartBarSeriesPointView, CXTPChartBarSeriesView, CXTPChartCandleStickSeriesView, CXTPChartFastLineSeriesView, CXTPChartFunnelSeriesPointViewBase, CXTPChartFunnelSeriesView, CXTPChartFunnelSeriesViewBase, CXTPChartHighLowSeriesView, CXTPChartLineSeriesView, CXTPChartPieSeriesPointView, CXTPChartPieSeriesPointViewBase, CXTPChartPieSeriesView, CXTPChartPieSeriesViewBase, CXTPChartPointSeriesPointView, CXTPChartPointSeriesView, CXTPChartPyramidSeriesPointViewBase, CXTPChartPyramidSeriesView, CXTPChartPyramidSeriesViewBase, CXTPChartRadarAreaSeriesView, CXTPChartRadarLineSeriesView, CXTPChartRadarPointSeriesPointView, CXTPChartRadarPointSeriesView, CXTPChartSeriesPointView, CXTPChartStepLineSeriesPointView, and CXTPChartStepLineSeriesView.

◆ GetLegendName()

virtual CXTPChartString GetLegendName ( ) const
pure virtual

This function returns the legend name.

It is a pure virtual function so it should be implemented in the derived classes.

Returns
Returns the legend name represented by the CXTPChartString class.

Implemented in CXTPChartAxisConstantLine, CXTPChartAxisStrip, and CXTPChartSeriesPointView.

The documentation for this class was generated from the following file:
  • XTPChartLegendItem.h


Toolkit Pro: CXTPChartLegendView Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPChartLegendView Class Reference

This class abstracts the view of a legend and its child items in a bounding rectangle context. More...

Inheritance diagram for CXTPChartLegendView:
[legend]

Public Member Functions

CXTPChartLegendView (CXTPChartLegend *pLegend, CXTPChartElementView *pParentView)
Constructs a CXTPChartLegendView object.
virtual | ~CXTPChartLegendView ()
Destroys a CXTPChartLegendView object, handles cleanup.
virtual CXTPChartDeviceCommand * | CreateDeviceCommand (CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
void | CalculateView (CXTPChartDeviceContext *pDC, CRect &rcChart)
This function calculates the legend location in the chart based on the state of the CXTPChartLegend object and adjusts the chart layout accordingly.
CSize | CalcSize (CXTPChartDeviceContext *pDC)
This member function calculates the legend's width and height based on the number of legend items present.
void | AddItem (CXTPChartLegendItemView *pItem, double minimum=0, double maximum=0)
Call this function to add a new legend item.
- Public Member Functions inherited from CXTPChartElementView
CXTPChartElementView (CXTPChartElementView *pParentView)
Constructs a CXTPChartElementView object.
CXTPChartElementView (CXTPChartElementView *pParentView, BOOL bAddToParent)
Constructs a CXTPChartElementView object.
CXTPChartElementView (CXTPChartContainer *pContainer)
Constructs a CXTPChartElementView object.
int | GetCount () const
Call this function to get the number of child views associated with this view.
CXTPChartElementView * | GetAt (int nIndex) const
Call this function to get a child view at a particular index.
CXTPChartElementView * | GetParentView () const
Call this function to get the parent view.
CXTPChartElementView * | AddChildView (CXTPChartElementView *pChildView)
Call this function to add a child view to the current view.
CXTPChartElementView ** GetChildren ()
Provides access to the collection of children elements owned by the view.
CRect | GetBounds () const
Obtains viewed object's bound rectangle.
CRect | GetBounds (BOOL bIncludingChildren) const
Obtains viewed object's bound rectangle.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Protected Attributes

CXTPChartLegend * | m_pLegend
Pointer to the legend object.
CRect | m_rcBounds
The bounding rectangle of the legend.
CArray< CHARTLEGEND_ITEM, CHARTLEGEND_ITEM > | m_arrItems
The list of legend items.
- Protected Attributes inherited from CXTPChartElementView
CArray< CXTPChartElementView *, CXTPChartElementView * > | m_arrChildren
The child view collection.
CXTPChartElementView * | m_pParentView
The parent view.
CXTPChartContainer * | m_pContainer
The parent container.
CRect | m_rcBounds
Bounding rectangle.

Additional Inherited Members

- Protected Member Functions inherited from CXTPChartElementView
virtual ~CXTPChartElementView ()
Destroys a CXTPChartElementView object, handles cleanup.
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.

Detailed Description

This class abstracts the view of a legend and its child items in a bounding rectangle context.

Constructor & Destructor Documentation

◆ CXTPChartLegendView()

CXTPChartLegendView | ( | CXTPChartLegend * | pLegend,
 |  | CXTPChartElementView * | pParentView )

Constructs a CXTPChartLegendView object.

Parameters
pLegend | Pointer to a CXTPChartLegend object.
pParentView | Pointer to a CXTPChartElementView object.

Member Function Documentation

◆ AddItem()

void AddItem | ( | CXTPChartLegendItemView * | pItem,
 |  | double | minimum = 0,
 |  | double | maximum = 0 )

Call this function to add a new legend item.

Parameters
pItem | Pointer to a CXTPChartLegendItemView object.
minimum | minimum of the point collection.
maximum | maximum of the point collection.

◆ CalcSize()

CSize CalcSize ( CXTPChartDeviceContext * pDC )

This member function calculates the legend's width and height based on the number of legend items present.

Parameters
pDC Pointer to a CXTPChartDeviceContext object.
Returns
The return value is a CSize object representing the height and width of the legend.

◆ CalculateView()

void CalculateView | ( | CXTPChartDeviceContext * | pDC,
 |  | CRect & | rcChart )

This function calculates the legend location in the chart based on the state of the CXTPChartLegend object and adjusts the chart layout accordingly.

Parameters
pDC | Pointer to a CXTPChartDeviceContext object.
rcChart | The chart bounding rectangle.

◆ CreateDeviceCommand()

virtual CXTPChartDeviceCommand * CreateDeviceCommand ( CXTPChartDeviceContext * pDC )
virtual

This function creates a CXTPChartDeviceCommand object.

This object represents the rendering of a legend in the chart.

Parameters
pDC Pointer to a CXTPChartDeviceContext object.
Returns
Returns a CXTPChartDeviceCommand object. This object handles the rendering of an element in the chart. Here it handles the drawing of the legend.

Reimplemented from CXTPChartElementView.

The documentation for this class was generated from the following file:
  • XTPChartLegendView.h


Toolkit Pro: CXTPChartLineDeviceCommand Class Reference

Protected Member Functions | Protected Attributes | List of all members
CXTPChartLineDeviceCommand Class Reference

Provides an interface for 2D line drawing device command. More...

Inheritance diagram for CXTPChartLineDeviceCommand:
[legend]

Protected Member Functions

CXTPChartLineDeviceCommand (const CXTPPoint2f &p1, const CXTPPoint2f &p2, const CXTPChartColor &color, int thickness)
Constructs a CXTPChartLineDeviceCommand object.
virtual CXTPChartElement * HitTest (CPoint point, CXTPChartElement *pParent) const
Performs recursive hit testing of the element at the specified point.
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.
- Protected Member Functions inherited from CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents >
CXTPObservable ()
Constructs an observable object.
~CXTPObservable ()
Handles observable object destruction.

Protected Attributes

CXTPPoint2f | m_p1
The first point.
CXTPPoint2f | m_p2
The second point.
CXTPChartColor | m_color
The line color.
int | m_nThickness
The thickness of the line.
- Protected Attributes inherited from CXTPChartDeviceCommand
CArray< CXTPChartDeviceCommand *, CXTPChartDeviceCommand * > | m_arrChildren
< The array of child device commands.

Additional Inherited Members

- Public Member Functions inherited from CXTPChartDeviceCommand
CXTPChartDeviceCommand ()
Constructs a CXTPChartDeviceCommand object.
virtual | ~CXTPChartDeviceCommand ()
Destroys a CXTPChartDeviceCommand object, handles cleanup.
BOOL | IsCommitted () const
Determines if the execution of the command has been committed.
void | Commit ()
Commits the execution of the command.
int | GetChildCommandCount () const
Obtains the number of immediate children commands.
CXTPChartDeviceCommand * | GetChildCommand (int nIndex) const
Obtains immediate child command point by index.
CXTPChartDeviceCommand * | AddChildCommand (CXTPChartDeviceCommand *pCommand)
Call this function to add a child device command.
virtual void | Execute (CXTPChartDeviceContext *pDC)
Call this function to execute the drawing.
virtual void | BeforeExecute (CXTPChartDeviceContext *pDC)
This method gets called before a command is executed which allows for the customization of command behavior.
virtual void | AfterExecute (CXTPChartDeviceContext *pDC)
This method gets called after a command is executed which allows for the customization of command behavior.
virtual void | ExecuteOverride (CXTPChartDeviceContext *pDC)
Override this function to write the drawing code for specific objects.
UINT | GetPassNumber () const
Get the number of executions made by the command.
virtual void | ApplySeriesStyle (CXTPChartSeriesStyle *pStyle)
Applies series style to the current element.
virtual void | Prepare (CXTPChartDeviceContext *pDC)
Performs inital preparation steps necessary for successful command execution.
virtual void | PrepareOverride (CXTPChartDeviceContext *pDC)
Derived implementation must override this method for implementing implementation specific preparation behavior.
virtual BOOL | IsEnabled () const
Determines if the command is currently enabled.
void | SetEnabled (BOOL bEnabled=TRUE)
Enables/disable the command.
CXTPChartDeviceContext * | GetCurrentDC () const
Obtains device context pointer for which the command is currenly being prepared or executed.
void | BindView (CXTPChartElementView *pView)
Binds a view to the command object.
CXTPChartElementView * | GetBoundView () const
Obtains a bound view pointer or NULL if no view is bound.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.
- Public Member Functions inherited from CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents >
void | Subscribe (CXTPChartDeviceCommandEvents *pObserver, CXTPSubscriptionList< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > *pSubcriptionList=NULL)
Subscribes a unique observer for events.
void | Unsubscribe (CXTPChartDeviceCommandEvents *pObserver)
Unsubscribes an observer from events.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *))
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *))
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.

Detailed Description

Provides an interface for 2D line drawing device command.

Constructor & Destructor Documentation

◆ CXTPChartLineDeviceCommand()

CXTPChartLineDeviceCommand | ( | const CXTPPoint2f & | p1,
 |  | const CXTPPoint2f & | p2,
 |  | const CXTPChartColor & | color,
 |  | int | thickness )
 protected

Constructs a CXTPChartLineDeviceCommand object.

Parameters
p1 | Start point.
p2 | End point.
color | Line color.
thickness | Line thickness in pixels.

Member Function Documentation

◆ HitTest()

virtual CXTPChartElement * HitTest | ( | CPoint | point,
 |  | CXTPChartElement * | pParent ) const
 protectedvirtual

Performs recursive hit testing of the element at the specified point.

Parameters
point | Point in which an element is to be found.
pParent | Parent element pointer.
Returns
A pointer to the element found at the specified point or NULL if no element is found.

Reimplemented from CXTPChartDeviceCommand.

The documentation for this class was generated from the following file:
  • XTPChartLineDeviceCommand.h


Toolkit Pro: CXTPChartLineSeriesErrorBarView Class Reference

Public Member Functions | List of all members
CXTPChartLineSeriesErrorBarView Class Reference

This class abstracts the view of the label of a bar series, it is a kind of point series label view. More...

Public Member Functions

CXTPChartLineSeriesErrorBarView (CXTPChartErrorBar *pErrorBar, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView)
Constructs a CXTPChartLineSeriesErrorBarView object.

Detailed Description

This class abstracts the view of the label of a bar series, it is a kind of point series label view.

Constructor & Destructor Documentation

◆ CXTPChartLineSeriesErrorBarView()

CXTPChartLineSeriesErrorBarView | ( | CXTPChartErrorBar * | pErrorBar,
 |  | CXTPChartSeriesPointView * | pPointView,
 |  | CXTPChartElementView * | pParentView )

Constructs a CXTPChartLineSeriesErrorBarView object.

Parameters
pErrorBar | Pointer to the error bar object.
pPointView | Pointer to the chart series point view.
pParentView | Parent view pointer.
The documentation for this class was generated from the following file:
  • XTPChartLineSeriesErrorBar.h


Toolkit Pro: CXTPChartLineSeriesStyle Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPChartLineSeriesStyle Class Reference

This class represents a line series style, which is a kind of CXTPChartPointSeriesStyle. More...

Inheritance diagram for CXTPChartLineSeriesStyle:
[legend]

Public Member Functions

CXTPChartLineSeriesStyle ()
Constructs a CXTPChartLineSeriesStyle object.
virtual | ~CXTPChartLineSeriesStyle ()
Destroys a CXTPChartLineSeriesStyle object, handles cleanup.
CXTPChartLineStyle * | GetLineStyle () const
Call this function to get the line style of the line series.
- Public Member Functions inherited from CXTPChartPointSeriesStyle
CXTPChartPointSeriesStyle ()
Constructs a CXTPChartPointSeriesStyle object.
virtual | ~CXTPChartPointSeriesStyle ()
Destroys a CXTPChartPointSeriesStyle object, handles cleanup.
CXTPChartMarker * | GetMarker () const
Call this function to get the marker object associated with this CXTPChartPointSeriesStyle object.
void | DoPropExchange (CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
- Public Member Functions inherited from CXTPChartDiagram2DSeriesStyle
CXTPChartDiagram2DSeriesStyle ()
Constructs a CXTPChartDiagram2DSeriesStyle object.
virtual | ~CXTPChartDiagram2DSeriesStyle ()
Destroys a CXTPChartDiagram2DSeriesStyle object, handles cleanup.
virtual CXTPChartDiagram * | CreateDiagram ()
Call this function to create the diagram for this series.
virtual BOOL | IsStyleDiagram (CXTPChartDiagram *pDiagram) const
Call this function to check whether the chart diagram object passed is a kind of 2D diagram (CXTPChartDiagram2D object).
- Public Member Functions inherited from CXTPChartSeriesStyle
CXTPChartSeriesStyle ()
Constructs a CXTPChartSeriesStyle object.
virtual | ~CXTPChartSeriesStyle ()
Destroys a CXTPChartSeriesStyle object, handles cleanup.
virtual CXTPChartSeriesLabel * | GetLabel () const
Call this method to gets the series label object.
virtual CXTPChartSeriesLabel * | SetLabel (CXTPChartSeriesLabel *pLabel)
Call this method to sets the series label object.
virtual CXTPChartErrorBar * | GetErrorBar () const
Call this method to gets the error bar object.
virtual CXTPChartErrorBar * | SetErrorBar (CXTPChartErrorBar *pErrorBar)
Call this method to sets the error bar object.
virtual CXTPChartColor | GetColor () const
Call this method to get the color of the series.
virtual void | SetColor (CXTPChartColor clr)
Call this method to set the color of the series.
virtual void | SetColorEach (BOOL bColorEach)
Call this method to set individual color for each point of the series.
virtual BOOL | IsColorEach () const
This method is called to check if individual color is used for each point of the series.
virtual CXTPChart3dRotation | Get3dRotation () const
Obtains rotation parameters for 3D chart.
virtual void | Set3dRotation (const CXTPChart3dRotation &rotation)
Sets rotation parameters for 3D chart.
virtual void | Set3dRotation (double dYaw, double dPitch, double dRoll)
Sets rotation parameters for 3D chart.
virtual BOOL | Is3dEdgeSmoothingEnabled () const
Enables/disables 3D edge smoothing.
virtual void | Enable3dEdgeSmoothing (BOOL bEnable=TRUE)
Enables/disables 3D edge smoothing.
virtual int | GetTransparency () const
Call this function to gets the transparency of the chart if it is supported by the chart type.
virtual void | SetTransparency (int nTransparency)
Call this function to sets the transparency of the chart if it is supported by the chart type.
virtual void | CorrectAxisSideMargins (CXTPChartAxis *pAxis, double nMinValue, double nMaxValue, double &nCorrection)
Provides default implementation for axis side margins correction.
virtual CXTPChartSeriesStyleAppearance * | GetStyleAppearance () const
Obtains associated style appearance pointer.
virtual void | ApplyTo (CXTPChartDeviceCommand *pCommand)
Applies the style to the command provided in case the command needs style specific details for correct drawing.
virtual int | GetSeriesPointValueIndex () const
Obtains the index of a point element for which an internal value can be otained.
- Public Member Functions inherited from CXTPChartElement
CXTPChartElement ()
Constructs a CXTPChartElement object.
virtual | ~CXTPChartElement ()
Destroys a CXTPChartElement object, handles cleanup.
virtual void | Release ()
Call this function to decrease the usage count of the object.
CXTPChartElement * | GetOwner () const
Call this function to get the owner element.
virtual void | OnChartChanged (XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic properties of the chart.
CXTPChartContent * | GetContent () const
Call this virtual function to get the chart content object.
CXTPChartAppearance * | GetAppearance () const
Call this function to get the the appearance of the chart.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Protected Member Functions

virtual CXTPChartSeriesView * | CreateView (CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Call this function to create a view of the line series.
void | DoPropExchange (CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
- Protected Member Functions inherited from CXTPChartPointSeriesStyle
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.

Protected Attributes

CXTPChartLineStyle * | m_pLineStyle
The line style.
- Protected Attributes inherited from CXTPChartPointSeriesStyle
- Protected Attributes inherited from CXTPChartDiagram2DSeriesStyle
int | m_nAxisIndexX
Holds index of secondary axisX, used when m_bSecondaryAxisX is TRUE.
int | m_nAxisIndexY
Holds index of secondary axisY, used when m_bSecondaryAxisY is TRUE.
- Protected Attributes inherited from CXTPChartSeriesStyle
CXTPChartSeriesLabel * | m_pLabel
Label object.
CXTPChartErrorBar * | m_pErrorBar
Error bar object.
CXTPChartColor | m_clrColor
Custom color of series.
BOOL | m_bColorEach
TRUE to color each point.
int | m_nTransparency
The transparency value in the range 0..255.
CXTPChart3dRotation | m_Rotation3d
3D rotation
BOOL | m_bSmooth3dEdges
3D edge smoothing
- Protected Attributes inherited from CXTPChartElement

Detailed Description

This class represents a line series style, which is a kind of CXTPChartPointSeriesStyle.

A line chart or line graph is a type of graph which displays information as a series of data points connected by straight line segments. It is a basic type of chart common in many fields.

Member Function Documentation

◆ CreateView()

virtual CXTPChartSeriesView * CreateView | ( | CXTPChartSeries * | pSeries,
 |  | CXTPChartDiagramView * | pDiagramView )
 protectedvirtual

Call this function to create a view of the line series.

Parameters
pSeries | A pointer to the chart series object.
pDiagramView | A pointer to the diagram view object.
Returns
Returns a pointer to the associated series view object.

Reimplemented from CXTPChartPointSeriesStyle.

Reimplemented in CXTPChartScatterLineSeriesStyle, CXTPChartSplineSeriesStyle, and CXTPChartStepLineSeriesStyle.

◆ DoPropExchange()

void DoPropExchange ( CXTPPropExchange * pPX )
protectedvirtual

Reads this object from or writes this object to an archive.

Parameters
pPX A CXTPPropExchange object to serialize to or from.

Reimplemented from CXTPChartDiagram2DSeriesStyle.

Reimplemented in CXTPChartStepLineSeriesStyle.

◆ GetLineStyle()

AFX_INLINE CXTPChartLineStyle * GetLineStyle ( ) const

Call this function to get the line style of the line series.

Returns
A pointer to chart line style object.
The documentation for this class was generated from the following file:
  • XTPChartLineSeriesStyle.h


Toolkit Pro: CXTPChartLineSeriesView Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPChartLineSeriesView Class Reference

This class represents the view of a line series, which is a kind of CXTPChartSeriesView. More...

Inheritance diagram for CXTPChartLineSeriesView:
[legend]

Public Member Functions

CXTPChartLineSeriesView (CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView, BOOL bSortPoints=TRUE)
Constructs a CXTPChartLineSeriesView object.

Protected Member Functions

CXTPChartSeriesPointView * | CreateSeriesPointView (CXTPChartDeviceContext *pDC, CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Call this function to create a view of the line series point.
virtual CXTPChartDeviceCommand * | CreateDeviceCommand (CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
virtual CXTPChartDeviceCommand * | CreateLegendDeviceCommand (CXTPChartDeviceContext *pDC, CRect rcBounds)
This function creates a label view drawing command object.

Detailed Description

This class represents the view of a line series, which is a kind of CXTPChartSeriesView.

Constructor & Destructor Documentation

◆ CXTPChartLineSeriesView()

CXTPChartLineSeriesView | ( | CXTPChartSeries * | pSeries,
 |  | CXTPChartDiagramView * | pDiagramView,
 |  | BOOL | bSortPoints = TRUE )

Constructs a CXTPChartLineSeriesView object.

Parameters
pSeries | A pointer to the chart series object.
pDiagramView | A pointer to the diagram view object.
bSortPoints | TRUE to sort points.

Member Function Documentation

◆ CreateDeviceCommand()

virtual CXTPChartDeviceCommand * CreateDeviceCommand ( CXTPChartDeviceContext * pDC )
protectedvirtual

This function creates a CXTPChartDeviceCommand object.

This object represents the rendering of a line series.

Parameters
pDC Pointer to a CXTPChartDeviceContext object.
Returns
Returns a CXTPChartDeviceCommand object. This object handles the rendering of an element in the chart. Here it handles the drawing of the line series.

Reimplemented from CXTPChartElementView.

Reimplemented in CXTPChartSplineSeriesView.

◆ CreateLegendDeviceCommand()

virtual CXTPChartDeviceCommand * CreateLegendDeviceCommand | ( | CXTPChartDeviceContext * | pDC,
 |  | CRect | rcBounds )
 protectedvirtual

This function creates a label view drawing command object.

Parameters
pDC | Pointer to a CXTPChartDeviceContext object.
rcBounds | The rectangular boundary of the legend.
Returns
Returns a new label view drawing command object.

Implements CXTPChartLegendItemView.

◆ CreateSeriesPointView()

CXTPChartSeriesPointView * CreateSeriesPointView | ( | CXTPChartDeviceContext * | pDC,
 |  | CXTPChartSeriesPoint * | pPoint,
 |  | CXTPChartElementView * | pParentView )
 protected

Call this function to create a view of the line series point.

Parameters
pDC | A pointer to chart device context.
pPoint | A pointer to the chart series point object.
pParentView | Parent view pointer.
Returns
Returns a pointer to the associated series point view object.
The documentation for this class was generated from the following file:
  • XTPChartLineSeriesStyle.h


Toolkit Pro: CXTPChartLineStyle Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPChartLineStyle Class Reference

This class represents a chart line style, which is a kind of CXTPCmdTarget. More...

Inheritance diagram for CXTPChartLineStyle:
[legend]

Public Member Functions

CXTPChartLineStyle (CXTPChartElement *pOwner)
Constructs a CXTPChartLineStyle object.
void | Release ()
Call this function to release the object once the object is no more relevant.
void | SetThickness (int nThickness)
Call this function to set the thickness of the line.
int | GetThickness () const
Call this function to get the thickness of the line.
void | SetDashStyle (XTPChartDashStyle nDashStyle)
Call this function to set dash line style.
XTPChartDashStyle | GetDashStyle () const
Call this function to get the dash line style.
virtual CXTPChartDeviceCommand * | CreateDeviceCommand (const CXTPChartPointF &point1, const CXTPChartPointF &point2, const CXTPChartColor &color)
This function creates a CXTPChartDeviceCommand object, this object represents the rendering of a line.
virtual CXTPChartDeviceCommand * | CreateDeviceCommand (const CXTPChartPoints &points, const CXTPChartColor &color)
This function creates a CXTPChartDeviceCommand object, this object represents the rendering of a line.
virtual CXTPChartDeviceCommand * | CreateSplineDeviceCommand (const CXTPChartPoints &points, const CXTPChartColor &color)
This function creates a CXTPChartDeviceCommand object, this object represents the rendering of a spline.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Attributes

int | m_nThickness
The line thickness.
XTPChartDashStyle | m_nDashStyle
The dash style.
CXTPChartElement * | m_pOwner
The owner element.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

This class represents a chart line style, which is a kind of CXTPCmdTarget.

Constructor & Destructor Documentation

◆ CXTPChartLineStyle()

CXTPChartLineStyle ( CXTPChartElement * pOwner )

Constructs a CXTPChartLineStyle object.

Parameters
pOwner The owner element.

Member Function Documentation

◆ CreateDeviceCommand() [1/2]

virtual CXTPChartDeviceCommand * CreateDeviceCommand | ( | const CXTPChartPointF & | point1,
 |  | const CXTPChartPointF & | point2,
 |  | const CXTPChartColor & | color )
 virtual

This function creates a CXTPChartDeviceCommand object, this object represents the rendering of a line.

Parameters
point1 | The start point of the line.
point2 | The end point of the line.
color | The color of the line.
Returns
Returns CXTPChartDeviceCommand object, this object handles the rendering of an element in the chart. Here it handles the drawing of a line.

◆ CreateDeviceCommand() [2/2]

virtual CXTPChartDeviceCommand * CreateDeviceCommand | ( | const CXTPChartPoints & | points,
 |  | const CXTPChartColor & | color )
 virtual

This function creates a CXTPChartDeviceCommand object, this object represents the rendering of a line.

Parameters
points | Line points collection.
color | The color of the line.
Returns
Returns CXTPChartDeviceCommand object, this object handles the rendering of an element in the chart. Here it handles the drawing of a line.

◆ CreateSplineDeviceCommand()

virtual CXTPChartDeviceCommand * CreateSplineDeviceCommand | ( | const CXTPChartPoints & | points,
 |  | const CXTPChartColor & | color )
 virtual

This function creates a CXTPChartDeviceCommand object, this object represents the rendering of a spline.

Parameters
points | The points which form the spline.
color | The color of the line.
Returns
Returns CXTPChartDeviceCommand object, this object handles the rendering of an element in the chart. Here it handles the drawing of a spline.

◆ GetDashStyle()

AFX_INLINE XTPChartDashStyle GetDashStyle ( ) const

Call this function to get the dash line style.

Returns
An enumerated value specifying the line style.

◆ GetThickness()

AFX_INLINE int GetThickness ( ) const

Call this function to get the thickness of the line.

Returns
An integer value denoting the line thickness.

◆ SetDashStyle()

void SetDashStyle ( XTPChartDashStyle nDashStyle )

Call this function to set dash line style.

Parameters
nDashStyle An enumerated value specifying the line style of choice.

◆ SetThickness()

void SetThickness ( int nThickness )

Call this function to set the thickness of the line.

Parameters
nThickness The integer value denoting the line thickness.
The documentation for this class was generated from the following file:
  • XTPChartLineStyle.h


Toolkit Pro: CXTPChartMarker Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPChartMarker Class Reference

This class abstracts a marker used in marking the points in a point series style chart. More...

Inheritance diagram for CXTPChartMarker:
[legend]

Public Member Functions

CXTPChartMarker (CXTPChartSeriesStyle *pOwner)
Constructs a CXTPChartMarker object.
virtual | ~CXTPChartMarker ()
Destroys a CXTPChartMarker object, handles cleanup.
virtual void | DoPropExchange (CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
virtual CXTPChartDeviceCommand * | CreateDeviceCommand (CXTPChartDeviceContext *pDC, const CXTPChartPointF &point, CXTPChartColor color, CXTPChartColor color2, CXTPChartColor colorBorder)
This function creates a CXTPChartDeviceCommand object.
virtual CXTPChartDeviceCommand * | CreateDeviceCommand (CXTPChartDeviceContext *pDC, const CXTPChartPointF &point, int nWidth, CXTPChartColor color, CXTPChartColor color2, CXTPChartColor colorBorder)
This function creates a CXTPChartDeviceCommand object.
- Public Member Functions inherited from CXTPChartElement
CXTPChartElement ()
Constructs a CXTPChartElement object.
virtual | ~CXTPChartElement ()
Destroys a CXTPChartElement object, handles cleanup.
virtual void | Release ()
Call this function to decrease the usage count of the object.
CXTPChartElement * | GetOwner () const
Call this function to get the owner element.
virtual void | OnChartChanged (XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic properties of the chart.
CXTPChartContent * | GetContent () const
Call this virtual function to get the chart content object.
CXTPChartAppearance * | GetAppearance () const
Call this function to get the the appearance of the chart.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Protected Attributes

BOOL | m_bBorderVisible
TRUE if the border is visible, FALSE if the border is invisible.
CXTPChartColor | m_clrBorderColor
The color of the marker border.
CXTPChartColor | m_clrColor
The first color of the marker gradient.
XTPChartMarkerType | m_nType
The Marker Type.
int | m_nSize
The size of the marker.
BOOL | m_bVisible
TRUE if the marker is visible and FALSE if the marker is invisible.
- Protected Attributes inherited from CXTPChartElement

Additional Inherited Members

- Public Attributes inherited from CXTPChartElement
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.

Detailed Description

This class abstracts a marker used in marking the points in a point series style chart.

Objects class is a kind of CXTPChartElement.

XTPChartMarkerType enumeration defines the various marking styles possible with this marker object.

Constructor & Destructor Documentation

◆ CXTPChartMarker()

CXTPChartMarker ( CXTPChartSeriesStyle * pOwner )

Constructs a CXTPChartMarker object.

Parameters
pOwner A pointer to the chart series style object which owns this object.

Member Function Documentation

◆ CreateDeviceCommand() [1/2]

virtual CXTPChartDeviceCommand * CreateDeviceCommand | ( | CXTPChartDeviceContext * | pDC,
 |  | const CXTPChartPointF & | point,
 |  | CXTPChartColor | color,
 |  | CXTPChartColor | color2,
 |  | CXTPChartColor | colorBorder )
 virtual

This function creates a CXTPChartDeviceCommand object.

This object represents the rendering of a point marker in the point series chart.

Parameters
pDC | Pointer to a CXTPChartDeviceContext object.
point | The center point of the marker.
color | The first color of the gradient.
color2 | The second color of the gradient.
colorBorder | The border color of the marker.
Returns
Returns a CXTPChartDeviceCommand object. This object handles the rendering of an element in the chart. Here it handles the drawing of the marker point.

◆ CreateDeviceCommand() [2/2]

virtual CXTPChartDeviceCommand * CreateDeviceCommand | ( | CXTPChartDeviceContext * | pDC,
 |  | const CXTPChartPointF & | point,
 |  | int | nWidth,
 |  | CXTPChartColor | color,
 |  | CXTPChartColor | color2,
 |  | CXTPChartColor | colorBorder )
 virtual

This function creates a CXTPChartDeviceCommand object.

This object represents the rendering of a point marker in the point series chart.

Parameters
pDC | Pointer to a CXTPChartDeviceContext object.
point | The center point of the marker.
nWidth | The width of the marker.
color | The first color of the marker gradient.
color2 | The second color of the marker gradient.
colorBorder | The border color of the marker.
Returns
Returns a CXTPChartDeviceCommand object. This object handles the rendering of an element in the chart. Here it handles the drawing of the marker point.

◆ DoPropExchange()

virtual void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Reads this object from or writes this object to an archive.

Parameters
pPX A CXTPPropExchange object to serialize to or from.

Reimplemented from CXTPChartElement.

The documentation for this class was generated from the following file:
  • XTPChartMarker.h


Toolkit Pro: CXTPChartMarkupElementDeviceCommand Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPChartMarkupElementDeviceCommand Class Reference

Implements 2D markup element drawing device command. More...

Inheritance diagram for CXTPChartMarkupElementDeviceCommand:
[legend]

Public Member Functions

CXTPChartMarkupElementDeviceCommand (CXTPMarkupUIElement *pMarkupUIElement, CXTPChartFont *pFont, const CXTPChartColor &color, const CXTPChartRectF &rectangle)
Constructs a CXTPChartMarkupElementDeviceCommand object.
~CXTPChartMarkupElementDeviceCommand ()
HAndles object deallocation.
CXTPChartElement * | HitTest (CPoint point, CXTPChartElement *pParent) const
Performs recursive hit testing of the element at the specified point.
- Public Member Functions inherited from CXTPChartDeviceCommand
CXTPChartDeviceCommand ()
Constructs a CXTPChartDeviceCommand object.
virtual | ~CXTPChartDeviceCommand ()
Destroys a CXTPChartDeviceCommand object, handles cleanup.
BOOL | IsCommitted () const
Determines if the execution of the command has been committed.
void | Commit ()
Commits the execution of the command.
int | GetChildCommandCount () const
Obtains the number of immediate children commands.
CXTPChartDeviceCommand * | GetChildCommand (int nIndex) const
Obtains immediate child command point by index.
CXTPChartDeviceCommand * | AddChildCommand (CXTPChartDeviceCommand *pCommand)
Call this function to add a child device command.
virtual void | Execute (CXTPChartDeviceContext *pDC)
Call this function to execute the drawing.
virtual void | BeforeExecute (CXTPChartDeviceContext *pDC)
This method gets called before a command is executed which allows for the customization of command behavior.
virtual void | AfterExecute (CXTPChartDeviceContext *pDC)
This method gets called after a command is executed which allows for the customization of command behavior.
virtual void | ExecuteOverride (CXTPChartDeviceContext *pDC)
Override this function to write the drawing code for specific objects.
UINT | GetPassNumber () const
Get the number of executions made by the command.
virtual void | ApplySeriesStyle (CXTPChartSeriesStyle *pStyle)
Applies series style to the current element.
virtual void | Prepare (CXTPChartDeviceContext *pDC)
Performs inital preparation steps necessary for successful command execution.
virtual void | PrepareOverride (CXTPChartDeviceContext *pDC)
Derived implementation must override this method for implementing implementation specific preparation behavior.
virtual BOOL | IsEnabled () const
Determines if the command is currently enabled.
void | SetEnabled (BOOL bEnabled=TRUE)
Enables/disable the command.
CXTPChartDeviceContext * | GetCurrentDC () const
Obtains device context pointer for which the command is currenly being prepared or executed.
void | BindView (CXTPChartElementView *pView)
Binds a view to the command object.
CXTPChartElementView * | GetBoundView () const
Obtains a bound view pointer or NULL if no view is bound.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.
- Public Member Functions inherited from CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents >
void | Subscribe (CXTPChartDeviceCommandEvents *pObserver, CXTPSubscriptionList< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > *pSubcriptionList=NULL)
Subscribes a unique observer for events.
void | Unsubscribe (CXTPChartDeviceCommandEvents *pObserver)
Unsubscribes an observer from events.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *))
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *))
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.

Protected Attributes

CXTPChartRectF | m_rect
The bounding rectangle of the text.
CXTPMarkupUIElement * | m_pMarkupUIElement
Markup element to draw.
CXTPChartColor | m_color
The default color of the text.
CXTPChartFont * | m_pFont
The default font of the text.
- Protected Attributes inherited from CXTPChartDeviceCommand
CArray< CXTPChartDeviceCommand *, CXTPChartDeviceCommand * > | m_arrChildren
< The array of child device commands.

Additional Inherited Members

- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.
- Protected Member Functions inherited from CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents >
CXTPObservable ()
Constructs an observable object.
~CXTPObservable ()
Handles observable object destruction.

Detailed Description

Implements 2D markup element drawing device command.

Constructor & Destructor Documentation

◆ CXTPChartMarkupElementDeviceCommand()

CXTPChartMarkupElementDeviceCommand | ( | CXTPMarkupUIElement * | pMarkupUIElement,
 |  | CXTPChartFont * | pFont,
 |  | const CXTPChartColor & | color,
 |  | const CXTPChartRectF & | rectangle )

Constructs a CXTPChartMarkupElementDeviceCommand object.

Parameters
pMarkupUIElement | Markup element pointer to draw.
pFont | The default font used to render.
color | The default color of the text.
rectangle | The text bounds.

Member Function Documentation

◆ HitTest()

CXTPChartElement * HitTest | ( | CPoint | point,
 |  | CXTPChartElement * | pParent ) const
 virtual

Performs recursive hit testing of the element at the specified point.

Parameters
point | Point in which an element is to be found.
pParent | Parent element pointer.
Returns
A pointer to the element found at the specified point or NULL if no element is found.

Reimplemented from CXTPChartDeviceCommand.

The documentation for this class was generated from the following file:
  • XTPChartTextDeviceCommand.h


Toolkit Pro: CXTPChartNumberFormat Class Reference

Public Member Functions | Static Public Member Functions | Protected Attributes | List of all members
CXTPChartNumberFormat Class Reference

This class helper is used to format number to string. More...

Inheritance diagram for CXTPChartNumberFormat:
[legend]

Public Member Functions

CXTPChartNumberFormat (CXTPChartElement *pOwner)
Constructs a CXTPChartNumberFormat object.
virtual | ~CXTPChartNumberFormat ()
Destroys a CXTPChartNumberFormat object, handles cleanup.
CString | GetPattern () const
void | SetPattern (LPCTSTR lpszPattern)
Call this method to set a new pattern.
XTPChartNumberFormatCategory | GetCategory () const
void | SetCategory (XTPChartNumberFormatCategory nCategory)
Call this method to specify format category of double value (Number, Currency, Percent, Scientific, etc.).
int | GetDecimalPlaces () const
void | SetDecimalPlaces (int nDecimalPlaces)
Call this method to set number of digits after decimal points.
BOOL | GetUseThousandSeparator () const
void | SetUseThousandSeparator (BOOL bThousandSeparator)
Call this method to use thousand separator for xtpChartNumber category of numbers.
LCID | GetLocale () const
void | SetLocale (LCID nLocale)
Call this method to specify locale that will be used to format numbers.
CString | GetCurrencySymbol () const
void | SetCurrencySymbol (LPCTSTR lpszCurrencySymbol)
Call this method to set a new currency symbol for the xtpChartCurrency category.
virtual CString | FormatNumber (double dValue) const
Call this method to format number to string.
virtual CString | FormatString (LPCTSTR lpszValue) const
Call this method to format string.
virtual CString | FormatDate (COleDateTime &dt) const
Call this method to format COleDateTime value to string.
virtual CString | FormatPoint (CXTPChartSeriesPoint *pSeriesPoint, double dValue) const
Call this method to format value to string.
void | DoPropExchange (CXTPPropExchange *pPX)
Call this member function to store/Load the properties of chart boundary object using the specified data object.
- Public Member Functions inherited from CXTPChartElement
CXTPChartElement ()
Constructs a CXTPChartElement object.
virtual | ~CXTPChartElement ()
Destroys a CXTPChartElement object, handles cleanup.
virtual void | Release ()
Call this function to decrease the usage count of the object.
CXTPChartElement * | GetOwner () const
Call this function to get the owner element.
virtual void | OnChartChanged (XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic properties of the chart.
CXTPChartContent * | GetContent () const
Call this virtual function to get the chart content object.
CXTPChartAppearance * | GetAppearance () const
Call this function to get the the appearance of the chart.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Static Public Member Functions

static BOOL AFX_CDECL | IsUseResourceFileLocale ()
Determines which locale is to be used as an active locale: current user locale or resource file locale.
static void AFX_CDECL | SetUseResourceFileLocale (BOOL bUseResourceFileLocale)
Used to set which locale is to be used as an the active locale: current user locale or resource file locale.
static LCID AFX_CDECL | GetActiveLCID ()
Returns active locale ID (current user locale or resource file locale).

Protected Attributes

CString | m_strPattern
Format pattern.
XTPChartNumberFormatCategory | m_nCategory
Format category.
int | m_nDecimalPlaces
Number of digits after decimal places.
BOOL | m_bUseThousandSeparator
TRUE to separate thousands.
LCID | m_nLocale
Current locale.
CString | m_strCurrencySymbol
Currency symbol.
- Protected Attributes inherited from CXTPChartElement

Additional Inherited Members

- Public Attributes inherited from CXTPChartElement
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.

Detailed Description

This class helper is used to format number to string.

Constructor & Destructor Documentation

◆ CXTPChartNumberFormat()

CXTPChartNumberFormat ( CXTPChartElement * pOwner )

Constructs a CXTPChartNumberFormat object.

Parameters
pOwner The owner element of this element.

Member Function Documentation

◆ DoPropExchange()

void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Call this member function to store/Load the properties of chart boundary object using the specified data object.

Parameters
pPX Source or destination CXTPPropExchange data object reference.

This member function is used to store property data to or load property data from storage.

Reimplemented from CXTPChartElement.

◆ FormatDate()

virtual CString FormatDate ( COleDateTime & dt ) const
virtual

Call this method to format COleDateTime value to string.

Parameters
dt Value to format.
Returns
Returns COleDateTime value as a string

◆ FormatNumber()

virtual CString FormatNumber ( double dValue ) const
virtual

Call this method to format number to string.

Parameters
dValue Value to format.
Returns
Returns number to string

◆ FormatPoint()

virtual CString FormatPoint | ( | CXTPChartSeriesPoint * | pSeriesPoint,
 |  | double | dValue ) const
 virtual

Call this method to format value to string.

Parameters
pSeriesPoint | Series Point.
dValue | Value to format.
Returns
Returns value as a string

◆ FormatString()

virtual CString FormatString ( LPCTSTR lpszValue ) const
virtual

Call this method to format string.

Parameters
lpszValue Value to format.
Returns
Returns formatted string

◆ GetActiveLCID()

static LCID AFX_CDECL GetActiveLCID ( )
static

Returns active locale ID (current user locale or resource file locale).

Returns
LOCALE_USER_DEFAULT or resource file locale ID.
See also
IsUseResourceFileLocale, SetUseResourceFileLocale, CXTPResourceManager::GetResourcesLangID, LOCALE_USER_DEFAULT

◆ GetCategory()

AFX_INLINE XTPChartNumberFormatCategory GetCategory ( ) const
Returns
Returns format category.

◆ GetCurrencySymbol()

AFX_INLINE CString GetCurrencySymbol ( ) const
Returns
Returns used currency symbol for xtpChartCurrency category.

◆ GetDecimalPlaces()

AFX_INLINE int GetDecimalPlaces ( ) const
Returns
Returns number of digits after decimal point.

This method returns -1 if locale specified number should be used.

◆ GetLocale()

AFX_INLINE LCID GetLocale ( ) const
Returns
Returns active locale to be used to format numbers.

◆ GetPattern()

AFX_INLINE CString GetPattern ( ) const
Returns
Returns string representing format pattern.

◆ GetUseThousandSeparator()

AFX_INLINE BOOL GetUseThousandSeparator ( ) const
Returns
Returns TRUE if Thousand Separator (, or ' ') should be used.

◆ IsUseResourceFileLocale()

static BOOL AFX_CDECL IsUseResourceFileLocale ( )
static

Determines which locale is to be used as an active locale: current user locale or resource file locale.

Returns
TRUE if a resource file locale is used as an active locale, FALSE otherwise.
See also
SetUseResourceFileLocale, CXTPResourceManager::GetResourcesLangID, GetActiveLCID, LOCALE_USER_DEFAULT

◆ SetCategory()

AFX_INLINE void SetCategory ( XTPChartNumberFormatCategory nCategory )

Call this method to specify format category of double value (Number, Currency, Percent, Scientific, etc.).

Parameters
nCategory New category to be set.

◆ SetCurrencySymbol()

AFX_INLINE void SetCurrencySymbol ( LPCTSTR lpszCurrencySymbol )

Call this method to set a new currency symbol for the xtpChartCurrency category.

Parameters
lpszCurrencySymbol New currency symbol. Can be empty string to use active locale.

◆ SetDecimalPlaces()

AFX_INLINE void SetDecimalPlaces ( int nDecimalPlaces )

Call this method to set number of digits after decimal points.

Parameters
nDecimalPlaces Non-negative number specified number of digits after decimal points, or -1 to use locale value.

◆ SetLocale()

AFX_INLINE void SetLocale ( LCID nLocale )

Call this method to specify locale that will be used to format numbers.

Parameters
nLocale New locale to be set.

◆ SetPattern()

AFX_INLINE void SetPattern ( LPCTSTR lpszPattern )

Call this method to set a new pattern.

Parameters
lpszPattern new pattern to be set.

You can specify C++ kind of format pattern: lf, g or {V} to use Active Locale.

Example: pFormat->SetPattern(_T("Wasted {V} Dollars");

◆ SetUseResourceFileLocale()

static void AFX_CDECL SetUseResourceFileLocale ( BOOL bUseResourceFileLocale )
static

Used to set which locale is to be used as an the active locale: current user locale or resource file locale.

Parameters
bUseResourceFileLocale If TRUE, the resource file locale will be used, if FALSE, the current user locale will be used.
Returns
If TRUE, the resource file locale will be used, if FALSE, the current user locale will be used
See also
IsUseResourceFileLocale, CXTPResourceManager::GetResourcesLangID, GetActiveLCID, LOCALE_USER_DEFAULT

◆ SetUseThousandSeparator()

AFX_INLINE void SetUseThousandSeparator ( BOOL bThousandSeparator )

Call this method to use thousand separator for xtpChartNumber category of numbers.

Parameters
bThousandSeparator TRUE to use thousand separator.

Member Data Documentation

◆ m_nDecimalPlaces

int m_nDecimalPlaces
protected

Number of digits after decimal places.

-1 to use default

The documentation for this class was generated from the following file:
  • XTPChartNumberFormat.h


Toolkit Pro: CXTPChartNumericalScaleTypeMap Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPChartNumericalScaleTypeMap Class Reference

This class is a kind of CXTPChartScaleTypeMap, which abstracts a numeric scale type for an axis. More...

Inheritance diagram for CXTPChartNumericalScaleTypeMap:
[legend]

Public Member Functions

CXTPChartNumericalScaleTypeMap (CXTPChartAxis *pAxis)
Constructs a CXTPChartNumericalScaleTypeMap object.
virtual CXTPChartString | InternalToValue (CXTPChartNumberFormat *pFromat, double dValue) const
Use this function to convert a double value to a string.
virtual double | ValueToInternal (const CXTPChartString &strValue) const
Use this function to convert a value string to an internal type.
- Public Member Functions inherited from CXTPChartScaleTypeMap
CXTPChartScaleTypeMap (CXTPChartAxis *pAxis)
Constructs a CXTPChartScaleTypeMap object.
virtual | ~CXTPChartScaleTypeMap ()
Destroys a CXTPChartScaleTypeMap object, handles cleanup.
CXTPChartAxis * | GetAxis () const
Call this function to get the axis object to which this object is associated with.
virtual void | UpdateSeries (CXTPChartAxisView *pAxisView)
Call this function when there is a change in the values of the series or a change in the scale.
virtual void | UpdateSeries (CXTPChartSeries *pSeries)
Call this function when there is a change in the values of the series or a change in the scale.
- Public Member Functions inherited from CXTPChartElement
CXTPChartElement ()
Constructs a CXTPChartElement object.
virtual | ~CXTPChartElement ()
Destroys a CXTPChartElement object, handles cleanup.
virtual void | Release ()
Call this function to decrease the usage count of the object.
CXTPChartElement * | GetOwner () const
Call this function to get the owner element.
virtual void | OnChartChanged (XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic properties of the chart.
CXTPChartContent * | GetContent () const
Call this virtual function to get the chart content object.
CXTPChartAppearance * | GetAppearance () const
Call this function to get the the appearance of the chart.
virtual void | DoPropExchange (CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Protected Member Functions

void UpdateSeriesPointArgument (CXTPChartSeriesPoint *pPoint)
Call this function when there is a change in the values of the series or a change in the scale.
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.

Protected Attributes

double | m_dMinValue
The minimum value.
double | m_dMaxValue
The maximum value.
- Protected Attributes inherited from CXTPChartElement

Additional Inherited Members

- Static Public Member Functions inherited from CXTPChartScaleTypeMap
static CXTPChartScaleTypeMap *AFX_CDECL Create (CXTPChartAxis *pAxis)
Call this function to create a scale type map object.
- Public Attributes inherited from CXTPChartElement

Detailed Description

This class is a kind of CXTPChartScaleTypeMap, which abstracts a numeric scale type for an axis.

Constructor & Destructor Documentation

◆ CXTPChartNumericalScaleTypeMap()

CXTPChartNumericalScaleTypeMap ( CXTPChartAxis * pAxis )

Constructs a CXTPChartNumericalScaleTypeMap object.

Parameters
pAxis Pointer to the associated chart axis object.

Member Function Documentation

◆ InternalToValue()

virtual CXTPChartString InternalToValue | ( | CXTPChartNumberFormat * | pFromat,
 |  | double | dValue ) const
 virtual

Use this function to convert a double value to a string.

This actually converts the internal representation of data to a more meaningful value.

Parameters
dValue | Value to format.
pFromat | Conversion format to use.
Returns
A CXTPChartString object representing the string value.

Implements CXTPChartScaleTypeMap.

◆ UpdateSeriesPointArgument()

void UpdateSeriesPointArgument ( CXTPChartSeriesPoint * pPoint )
protectedvirtual

Call this function when there is a change in the values of the series or a change in the scale.

Parameters
pPoint Pointer to a CXTPChartSeriesPoint object.

Reimplemented from CXTPChartScaleTypeMap.

◆ ValueToInternal()

virtual double ValueToInternal ( const CXTPChartString & strValue ) const
virtual

Use this function to convert a value string to an internal type.

Parameters
strValue Value to be set.
Returns
A double representing the internal value.

Implements CXTPChartScaleTypeMap.

The documentation for this class was generated from the following file:
  • XTPChartScaleTypeMap.h


Toolkit Pro: CXTPChartObject Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPChartObject Class Reference

A base class for all chart objects. More...

Inheritance diagram for CXTPChartObject:
[legend]

Public Member Functions

BOOL Is3D () const
Determines if a derived object is used in 3D mode.

Protected Member Functions

CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.

Detailed Description

A base class for all chart objects.

Constructor & Destructor Documentation

◆ CXTPChartObject()

AFX_INLINE CXTPChartObject ( BOOL bIs3D )
protected

Constructs an empty chart object.

Parameters
bIs3D By default all derived objects are assumed to work in 2D mode which corresponds to FALSE used as a value for this parameter. However if a derived object is associated with 3D mode, e.g. a command the render 3D graphics or 3D device context, this value must be TRUE.

Member Function Documentation

◆ Is3D()

AFX_INLINE BOOL Is3D ( ) const

Determines if a derived object is used in 3D mode.

Returns
TRUE if a derived object is used in 3D mode, FALSE otherwise.
The documentation for this class was generated from the following file:
  • XTPChartElement.h


Toolkit Pro: CXTPChartPalette Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPChartPalette Class Reference

This class abstracts a color palette. More...

Inheritance diagram for CXTPChartPalette:
[legend]

Public Member Functions

CXTPChartPalette (CXTPChartElement *pOwner)
Constructs a CXTPChartPalette object.
virtual | ~CXTPChartPalette ()
Destroys a CXTPChartPalette object, handles cleanup.
CXTPChartColor | GetColor (int nIndex) const
Call this function to get the first color at a particular index in the palette.
CXTPChartColor | GetColor2 (int nIndex) const
Call this function to get the second color at a particular index in the palette.
int | GetCount () const
Call this function to get number of entris in the palette.
CXTPChartPaletteEntries & GetEntries ()
Call this function to get the palette entries.
void | DoPropExchange (CXTPPropExchange *pPX)
Call this member function to Store/Load the properties of palette object using the specified data object.
- Public Member Functions inherited from CXTPChartElement
CXTPChartElement ()
Constructs a CXTPChartElement object.
virtual | ~CXTPChartElement ()
Destroys a CXTPChartElement object, handles cleanup.
virtual void | Release ()
Call this function to decrease the usage count of the object.
CXTPChartElement * | GetOwner () const
Call this function to get the owner element.
virtual void | OnChartChanged (XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic properties of the chart.
CXTPChartContent * | GetContent () const
Call this virtual function to get the chart content object.
CXTPChartAppearance * | GetAppearance () const
Call this function to get the the appearance of the chart.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Protected Attributes

CXTPChartPaletteEntries m_arrEntries
The palette entry collection object.
- Protected Attributes inherited from CXTPChartElement

Additional Inherited Members

- Public Attributes inherited from CXTPChartElement
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.

Detailed Description

This class abstracts a color palette.

Constructor & Destructor Documentation

◆ CXTPChartPalette()

CXTPChartPalette ( CXTPChartElement * pOwner )

Constructs a CXTPChartPalette object.

Parameters
pOwner The owner element of the palette object.

Member Function Documentation

◆ DoPropExchange()

void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Call this member function to Store/Load the properties of palette object using the specified data object.

Parameters
pPX Source or destination CXTPPropExchange data object reference.

This member function is used to store or load property data to or from a storage.

Reimplemented from CXTPChartElement.

◆ GetColor()

CXTPChartColor GetColor ( int nIndex ) const

Call this function to get the first color at a particular index in the palette.

Parameters
nIndex The zero-based index of the required palette entry.
Returns
Returns color

◆ GetColor2()

CXTPChartColor GetColor2 ( int nIndex ) const

Call this function to get the second color at a particular index in the palette.

Parameters
nIndex The zero-based index of the required palette entry.
Returns
Returns second color

◆ GetCount()

AFX_INLINE int GetCount ( ) const

Call this function to get number of entris in the palette.

Returns
An integer value specifying the number of entries in the palette.

◆ GetEntries()

AFX_INLINE CXTPChartPaletteEntries & GetEntries ( )

Call this function to get the palette entries.

Returns
A reference to the palette entry collection member.
The documentation for this class was generated from the following file:
  • XTPChartPalette.h


Toolkit Pro: CXTPChartPaletteEntry Class Reference

List of all members
CXTPChartPaletteEntry Class Reference

This class represents a palette entry, which abstracts two 32 bit color values of type ARGB. More...

Detailed Description

This class represents a palette entry, which abstracts two 32 bit color values of type ARGB.

The documentation for this class was generated from the following file:
  • XTPChartPalette.h


Toolkit Pro: CXTPChartPanel Class Reference

Public Member Functions | List of all members
CXTPChartPanel Class Reference

This class abstracts a chart panel. More...

Inheritance diagram for CXTPChartPanel:
[legend]

Public Member Functions

CXTPChartPanel ()
Constructs a CXTPChartPanel object.
virtual | ~CXTPChartPanel ()
Destroys a CXTPChartMarker object, handles cleanup.
CXTPChartTitleCollection * | GetTitles () const
Call this function to get the the title collection object.
virtual void | DoPropExchange (CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
- Public Member Functions inherited from CXTPChartElement
CXTPChartElement ()
Constructs a CXTPChartElement object.
virtual | ~CXTPChartElement ()
Destroys a CXTPChartElement object, handles cleanup.
virtual void | Release ()
Call this function to decrease the usage count of the object.
CXTPChartElement * | GetOwner () const
Call this function to get the owner element.
virtual void | OnChartChanged (XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic properties of the chart.
CXTPChartContent * | GetContent () const
Call this virtual function to get the chart content object.
CXTPChartAppearance * | GetAppearance () const
Call this function to get the the appearance of the chart.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Additional Inherited Members

- Public Attributes inherited from CXTPChartElement
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.
- Protected Attributes inherited from CXTPChartElement

Detailed Description

This class abstracts a chart panel.

It is used in panel charts.

Panel Charts are charts that have multiple regions which compare similar data sets side by side (in separate panels) rather than right on top of each other. Essentially a single chart is repeated across a grid, with different data sets in each instance of the chart.

Member Function Documentation

◆ DoPropExchange()

virtual void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Reads this object from or writes this object to an archive.

Parameters
pPX A CXTPPropExchange object to serialize to or from.

Reimplemented from CXTPChartElement.

Reimplemented in CXTPChartDiagram2D, CXTPChartDiagram, and CXTPChartRadarDiagram.

◆ GetTitles()

AFX_INLINE CXTPChartTitleCollection * GetTitles ( ) const

Call this function to get the the title collection object.

Returns
A pointer to a CXTPChartTitleCollection object.
The documentation for this class was generated from the following file:
  • XTPChartPanel.h


Toolkit Pro: CXTPChartPanelCollection Class Reference

Public Member Functions | List of all members
CXTPChartPanelCollection Class Reference

This class abstracts a chart panel collection. More...

Inheritance diagram for CXTPChartPanelCollection:
[legend]

Public Member Functions

CXTPChartPanelCollection (CXTPChartContent *pOwner)
Constructs a CXTPChartPanelCollection object.
virtual | ~CXTPChartPanelCollection ()
Destroys a CXTPChartPanelCollection object, handles cleanup.
CXTPChartPanel * | Add (CXTPChartPanel *pPanel)
Call this function to add a panel to the collection.
CXTPChartPanel * | GetAt (int nIndex) const
Call this function to get the panel at a particular index in the collection.
void | DoPropExchange (CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
- Public Member Functions inherited from CXTPChartElementCollection
CXTPChartElementCollection ()
Constructs a CXTPChartElementCollection object.
~CXTPChartElementCollection ()
Destroys a CXTPChartElementCollection object, handles cleanup.
virtual void | RemoveAll ()
This function removes all the individual objects from this collection object.
virtual int | GetCount () const
Call this function to get the number of objects in the internal array of this object.
virtual void | RemoveAt (int nIndex)
Use this function to remove an object from the collection.
virtual void | Remove (CXTPChartElement *pElement)
Use this function to remove an object from the collection.
CXTPChartElement * | GetAt (int nIndex) const
Call this function to get an element by its index.
int | IndexOf (CXTPChartElement *pElement) const
Call this function to get the index of a specified element.
void | InsertAt (int nIndex, CXTPChartElement *pElement)
Call this method to add a new element to the collection.
virtual void | Release ()
Call this function to decrease the usage count of the object.
- Public Member Functions inherited from CXTPChartElement
CXTPChartElement ()
Constructs a CXTPChartElement object.
virtual | ~CXTPChartElement ()
Destroys a CXTPChartElement object, handles cleanup.
CXTPChartElement * | GetOwner () const
Call this function to get the owner element.
virtual void | OnChartChanged (XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic properties of the chart.
CXTPChartContent * | GetContent () const
Call this virtual function to get the chart content object.
CXTPChartAppearance * | GetAppearance () const
Call this function to get the the appearance of the chart.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Additional Inherited Members

- Public Attributes inherited from CXTPChartElement
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.
- Protected Attributes inherited from CXTPChartElementCollection
CArray< CXTPChartElement *, CXTPChartElement * > m_arrElements
Array of CXTPChartElement pointer.
- Protected Attributes inherited from CXTPChartElement

Detailed Description

This class abstracts a chart panel collection.

It is used in panel charts.

Panel Charts are charts that have multiple regions which compare similar data sets side by side (in separate panels) rather than right on top of each other. Essentially a single chart is repeated across a grid, with different data sets in each instance of the chart.

Constructor & Destructor Documentation

◆ CXTPChartPanelCollection()

CXTPChartPanelCollection ( CXTPChartContent * pOwner )

Constructs a CXTPChartPanelCollection object.

Parameters
pOwner Pointer to an owner element.

Member Function Documentation

◆ Add()

CXTPChartPanel * Add ( CXTPChartPanel * pPanel )

Call this function to add a panel to the collection.

Parameters
pPanel A pointer to the panel object which is to be added.
Returns
Adds a panel to collection

◆ DoPropExchange()

void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Reads this object from or writes this object to an archive.

Parameters
pPX A CXTPPropExchange object to serialize to or from.

Reimplemented from CXTPChartElement.

◆ GetAt()

AFX_INLINE CXTPChartPanel * GetAt ( int nIndex ) const

Call this function to get the panel at a particular index in the collection.

Parameters
nIndex Zero-based index of the panel to be fetched.
Returns
A pointer to the chart panel object.
The documentation for this class was generated from the following file:
  • XTPChartPanel.h


Toolkit Pro: CXTPChartPie Class Reference

Public Member Functions | List of all members
CXTPChartPie Class Reference

This class abstracts a pie chart. More...

Inheritance diagram for CXTPChartPie:
[legend]

Public Member Functions

CXTPChartPie (double dStartAngle, double dFinishAngle, const CXTPChartEllipse &ellipse, int nDepthPercent, int nHolePercent)
Constructs a CXTPChartPieBase object.
virtual CXTPChartDeviceCommand * | CreatePieDeviceCommand (const CXTPChartColor &color, const CXTPChartColor &color2, const CXTPChartPointF &basePoint)
This function creates a CXTPChartDeviceCommand object.
virtual CXTPChartDeviceCommand * | CreateBoundedPieDeviceCommand (const CXTPChartColor &color, int nThickness, const CXTPChartPointF &basePoint)
This function creates a CXTPChartDeviceCommand object.
- Public Member Functions inherited from CXTPChartPieBase
virtual | ~CXTPChartPieBase ()
Destroys a CXTPChartPieBase object, handles cleanup and deallocation.
CXTPPoint3d | CalculateCenter (const CXTPChartPointF &basePoint) const
Call this function to calculate the ceter of the pie.
double | GetHalfAngle () const
Call this function to get the half angle of the pie slice.
double | GetStartAngle () const
Call this function to get the start angle of the pie slice.
CXTPChartPointF | GetFinishPoint () const
Call this function to get the finish/start point of the pie slice.
CXTPChartPointF | GetStartPoint () const
Call this function to get the finish/start point of the pie slice.
CXTPChartPointF | GetCenterPoint () const
Call this function to get the center point of the pie slice.
CXTPChartRectF | GetBounds () const
Call this function to get the bounding rectangle of the pie chart.
int | GetHolePercent () const
Call this function to get the hole percentage of the pie chart.

Additional Inherited Members

- Protected Member Functions inherited from CXTPChartPieBase
CXTPChartPieBase (double dStartAngle, double dFinishAngle, const CXTPChartEllipse &ellipse, int nDepthPercent, int nHolePercent)
Constructs a CXTPChartPieBase object.
void | UpdateBounds ()
Call this function to update the bounds of the pie when there is a change in the start angle and/or sweep angle.
- Protected Attributes inherited from CXTPChartPieBase
CXTPChartEllipse | m_ellipse
The ellipse associated with the pie chart.
double | m_dStartAngle
The start angle of the slice.
double | m_dSweepAngle
The sweep angle of the slice.
double | m_depth
The depth of the 3D pie.
int | m_nHolePercent
The hole percentage.
CXTPChartRectF | m_anchorBounds
The anchor bounds.

Detailed Description

This class abstracts a pie chart.

Constructor & Destructor Documentation

◆ CXTPChartPie()

CXTPChartPie | ( | double | dStartAngle,
 |  | double | dFinishAngle,
 |  | const CXTPChartEllipse & | ellipse,
 |  | int | nDepthPercent,
 |  | int | nHolePercent )

Constructs a CXTPChartPieBase object.

Parameters
dStartAngle | The start angle of the pie.
dFinishAngle | The finish angle of the pie.
ellipse | The ellipse associated with the pie.
nDepthPercent | The depth percentage, in case of 3D chart.
nHolePercent | The hole percentage.

Member Function Documentation

◆ CreateBoundedPieDeviceCommand()

virtual CXTPChartDeviceCommand * CreateBoundedPieDeviceCommand | ( | const CXTPChartColor & | color,
 |  | int | nThickness,
 |  | const CXTPChartPointF & | basePoint )
 virtual

This function creates a CXTPChartDeviceCommand object.

This object represents the rendering of the pie.

Parameters
color | The first color used for gradient pie.
basePoint | Reference to a CXTPChartPointF object.
nThickness | Thickness.
Returns
Returns a CXTPChartDeviceCommand object. This object handles the rendering of an element in the chart. Here it handles the drawing of the pie.

Implements CXTPChartPieBase.

◆ CreatePieDeviceCommand()

virtual CXTPChartDeviceCommand * CreatePieDeviceCommand | ( | const CXTPChartColor & | color,
 |  | const CXTPChartColor & | color2,
 |  | const CXTPChartPointF & | basePoint )
 virtual

This function creates a CXTPChartDeviceCommand object.

This object represents the rendering of the pie.

Parameters
color | The first color used for gradient pie.
color2 | The second color used for gradient pie.
basePoint | Reference to a CXTPChartPointF object.
Returns
Returns a CXTPChartDeviceCommand object. This object handles the rendering of an element in the chart. Here it handles the drawing of the pie.

Implements CXTPChartPieBase.

The documentation for this class was generated from the following file:
  • XTPChart2dPie.h


Toolkit Pro: CXTPChartPieBase Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPChartPieBase Class Referenceabstract

This class abstracts a pie chart. More...

Inheritance diagram for CXTPChartPieBase:
[legend]

Public Member Functions

virtual | ~CXTPChartPieBase ()
Destroys a CXTPChartPieBase object, handles cleanup and deallocation.
CXTPPoint3d | CalculateCenter (const CXTPChartPointF &basePoint) const
Call this function to calculate the ceter of the pie.
virtual CXTPChartDeviceCommand * | CreatePieDeviceCommand (const CXTPChartColor &color, const CXTPChartColor &color2, const CXTPChartPointF &basePoint)=0
This function creates a CXTPChartDeviceCommand object.
virtual CXTPChartDeviceCommand * | CreateBoundedPieDeviceCommand (const CXTPChartColor &color, int nThickness, const CXTPChartPointF &basePoint)=0
This function creates a CXTPChartDeviceCommand object.
double | GetHalfAngle () const
Call this function to get the half angle of the pie slice.
double | GetStartAngle () const
Call this function to get the start angle of the pie slice.
CXTPChartPointF | GetFinishPoint () const
Call this function to get the finish/start point of the pie slice.
CXTPChartPointF | GetStartPoint () const
Call this function to get the finish/start point of the pie slice.
CXTPChartPointF | GetCenterPoint () const
Call this function to get the center point of the pie slice.
CXTPChartRectF | GetBounds () const
Call this function to get the bounding rectangle of the pie chart.
int | GetHolePercent () const
Call this function to get the hole percentage of the pie chart.

Protected Member Functions

CXTPChartPieBase (double dStartAngle, double dFinishAngle, const CXTPChartEllipse &ellipse, int nDepthPercent, int nHolePercent)
Constructs a CXTPChartPieBase object.
void UpdateBounds ()
Call this function to update the bounds of the pie when there is a change in the start angle and/or sweep angle.

Protected Attributes

CXTPChartEllipse | m_ellipse
The ellipse associated with the pie chart.
double | m_dStartAngle
The start angle of the slice.
double | m_dSweepAngle
The sweep angle of the slice.
double | m_depth
The depth of the 3D pie.
int | m_nHolePercent
The hole percentage.
CXTPChartRectF | m_anchorBounds
The anchor bounds.

Detailed Description

This class abstracts a pie chart.

Constructor & Destructor Documentation

◆ CXTPChartPieBase()

CXTPChartPieBase | ( | double | dStartAngle,
 |  | double | dFinishAngle,
 |  | const CXTPChartEllipse & | ellipse,
 |  | int | nDepthPercent,
 |  | int | nHolePercent )
 protected

Constructs a CXTPChartPieBase object.

Parameters
dStartAngle | The start angle of the pie.
dFinishAngle | The finish angle of the pie.
ellipse | The ellipse associated with the pie.
nDepthPercent | The depth percentage, in case of 3D chart.
nHolePercent | The hole percentage.

Member Function Documentation

◆ CalculateCenter()

CXTPPoint3d CalculateCenter ( const CXTPChartPointF & basePoint ) const

Call this function to calculate the ceter of the pie.

Parameters
basePoint The base point in the diagram.
Returns
A CXTPPoint3d object denoting the center point of the pie.

◆ CreateBoundedPieDeviceCommand()

virtual CXTPChartDeviceCommand * CreateBoundedPieDeviceCommand | ( | const CXTPChartColor & | color,
 |  | int | nThickness,
 |  | const CXTPChartPointF & | basePoint )
 pure virtual

This function creates a CXTPChartDeviceCommand object.

This object represents the rendering of the pie.

Parameters
color | The first color used for gradient pie.
basePoint | Reference to a CXTPChartPointF object.
nThickness | Thickness.
Returns
Returns a CXTPChartDeviceCommand object. This object handles the rendering of an element in the chart. Here it handles the drawing of the pie.

Implemented in CXTPChart3dPie, and CXTPChartPie.

◆ CreatePieDeviceCommand()

virtual CXTPChartDeviceCommand * CreatePieDeviceCommand | ( | const CXTPChartColor & | color,
 |  | const CXTPChartColor & | color2,
 |  | const CXTPChartPointF & | basePoint )
 pure virtual

This function creates a CXTPChartDeviceCommand object.

This object represents the rendering of the pie.

Parameters
color | The first color used for gradient pie.
color2 | The second color used for gradient pie.
basePoint | Reference to a CXTPChartPointF object.
Returns
Returns a CXTPChartDeviceCommand object. This object handles the rendering of an element in the chart. Here it handles the drawing of the pie.

Implemented in CXTPChart3dPie, and CXTPChartPie.

◆ GetBounds()

CXTPChartRectF GetBounds ( ) const

Call this function to get the bounding rectangle of the pie chart.

Returns
A CXTPChartRectF object specifying the bounds.

◆ GetCenterPoint()

CXTPChartPointF GetCenterPoint ( ) const

Call this function to get the center point of the pie slice.

Returns
A CXTPChartPointF object specifying the center point.

◆ GetFinishPoint()

CXTPChartPointF GetFinishPoint ( ) const

Call this function to get the finish/start point of the pie slice.

Returns
A CXTPChartPointF object specifying the finish/start point.

◆ GetHalfAngle()

double GetHalfAngle ( ) const

Call this function to get the half angle of the pie slice.

Returns
A double specifying the half angle.

◆ GetHolePercent()

AFX_INLINE int GetHolePercent ( ) const

Call this function to get the hole percentage of the pie chart.

Returns
An integer specifying the percentage of hole in the pie chart.

◆ GetStartAngle()

AFX_INLINE double GetStartAngle ( ) const

Call this function to get the start angle of the pie slice.

Returns
A double specifying the start angle.

◆ GetStartPoint()

CXTPChartPointF GetStartPoint ( ) const

Call this function to get the finish/start point of the pie slice.

Returns
A CXTPChartPointF object specifying the finish/start point.
The documentation for this class was generated from the following file:
  • XTPChartPie.h


Toolkit Pro: CXTPChartPieDeviceCommand Class Reference

Protected Member Functions | List of all members
CXTPChartPieDeviceCommand Class Reference

Base class implementation for 2D pie chart device command. More...

Inheritance diagram for CXTPChartPieDeviceCommand:
[legend]

Protected Member Functions

CXTPChartPieDeviceCommand (const CXTPPoint3d &ptCenter, double dMajorSemiAxis, double dMinorSemiAxis, double dStartAngle, double dSweepAngle, double dDepth, double nHolePercent)
Constructs a CXTPChartPieDeviceCommand object.
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.
- Protected Member Functions inherited from CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents >
CXTPObservable ()
Constructs an observable object.
~CXTPObservable ()
Handles observable object destruction.
- Protected Member Functions inherited from CXTPChartPieDeviceCommandImpl
virtual ~CXTPChartPieDeviceCommandImpl ()
Handles object destruction.

Additional Inherited Members

- Public Member Functions inherited from CXTPChartDeviceCommand
CXTPChartDeviceCommand ()
Constructs a CXTPChartDeviceCommand object.
virtual | ~CXTPChartDeviceCommand ()
Destroys a CXTPChartDeviceCommand object, handles cleanup.
BOOL | IsCommitted () const
Determines if the execution of the command has been committed.
void | Commit ()
Commits the execution of the command.
int | GetChildCommandCount () const
Obtains the number of immediate children commands.
CXTPChartDeviceCommand * | GetChildCommand (int nIndex) const
Obtains immediate child command point by index.
CXTPChartDeviceCommand * | AddChildCommand (CXTPChartDeviceCommand *pCommand)
Call this function to add a child device command.
virtual void | Execute (CXTPChartDeviceContext *pDC)
Call this function to execute the drawing.
virtual void | BeforeExecute (CXTPChartDeviceContext *pDC)
This method gets called before a command is executed which allows for the customization of command behavior.
virtual void | AfterExecute (CXTPChartDeviceContext *pDC)
This method gets called after a command is executed which allows for the customization of command behavior.
virtual void | ExecuteOverride (CXTPChartDeviceContext *pDC)
Override this function to write the drawing code for specific objects.
UINT | GetPassNumber () const
Get the number of executions made by the command.
virtual CXTPChartElement * | HitTest (CPoint point, CXTPChartElement *pParent) const
Performs recursive hit testing of the element at the specified point.
virtual void | ApplySeriesStyle (CXTPChartSeriesStyle *pStyle)
Applies series style to the current element.
virtual void | Prepare (CXTPChartDeviceContext *pDC)
Performs inital preparation steps necessary for successful command execution.
virtual void | PrepareOverride (CXTPChartDeviceContext *pDC)
Derived implementation must override this method for implementing implementation specific preparation behavior.
virtual BOOL | IsEnabled () const
Determines if the command is currently enabled.
void | SetEnabled (BOOL bEnabled=TRUE)
Enables/disable the command.
CXTPChartDeviceContext * | GetCurrentDC () const
Obtains device context pointer for which the command is currenly being prepared or executed.
void | BindView (CXTPChartElementView *pView)
Binds a view to the command object.
CXTPChartElementView * | GetBoundView () const
Obtains a bound view pointer or NULL if no view is bound.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.
- Public Member Functions inherited from CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents >
void | Subscribe (CXTPChartDeviceCommandEvents *pObserver, CXTPSubscriptionList< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > *pSubcriptionList=NULL)
Subscribes a unique observer for events.
void | Unsubscribe (CXTPChartDeviceCommandEvents *pObserver)
Unsubscribes an observer from events.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *))
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *))
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
- Protected Attributes inherited from CXTPChartDeviceCommand
CArray< CXTPChartDeviceCommand *, CXTPChartDeviceCommand * > | m_arrChildren
< The array of child device commands.
- Protected Attributes inherited from CXTPChartPieDeviceCommandImpl
CXTPPoint3d | m_ptCenter
The center point of the pie.
double | m_dMajorSemiAxis
The major semi axis of the ellipse.
double | m_dMinorSemiAxis
The minor semi axis of the ellipse.
double | m_dStartAngle
The start angle of the pie.
double | m_dSweepAngle
The sweep angle of the pie.
double | m_dDepth
The depth of the pie or torus.
double | m_dHolePercent
Determines the size of the hole when drawing a doughnut.
double | m_dInnerMajorSemiAxis
The inner size of the major semi axis of the ellipse.
double | m_dInnerMinorSemiAxis
The inner size of the minor semi axis of the ellipse.
double | m_dFacetSize
Facet size.
double | m_dRadius
Pie radius.
double | m_dCorrectedDepth
Pie corrected depth.
double | m_dInnerRadius
Pie inner radius.
BOOL | m_bDoughnut
TRUE indicates doughnut style.

Detailed Description

Base class implementation for 2D pie chart device command.

Constructor & Destructor Documentation

◆ CXTPChartPieDeviceCommand()

CXTPChartPieDeviceCommand | ( | const CXTPPoint3d & | ptCenter,
 |  | double | dMajorSemiAxis,
 |  | double | dMinorSemiAxis,
 |  | double | dStartAngle,
 |  | double | dSweepAngle,
 |  | double | dDepth,
 |  | double | nHolePercent )
 protected

Constructs a CXTPChartPieDeviceCommand object.

Parameters
ptCenter | The center point of the pie.
dMajorSemiAxis | The major semi axis of the ellipse.
dMinorSemiAxis | The minor semi axis of the ellipse.
dStartAngle | The start angle of the pie.
dSweepAngle | The sweep angle of the pie.
dDepth | The depth of the pie or torus.
nHolePercent | Determines the size of the hole when drawing a doughnut.
The documentation for this class was generated from the following file:
  • XTPChartPieDeviceCommand.h


Toolkit Pro: CXTPChartPieDeviceCommandImpl Class Reference

Public Attributes | Protected Member Functions | List of all members
CXTPChartPieDeviceCommandImpl Class Reference

This class is a common implementation for a pie chart device command. More...

Inheritance diagram for CXTPChartPieDeviceCommandImpl:
[legend]

Public Attributes

CXTPPoint3d | m_ptCenter
The center point of the pie.
double | m_dMajorSemiAxis
The major semi axis of the ellipse.
double | m_dMinorSemiAxis
The minor semi axis of the ellipse.
double | m_dStartAngle
The start angle of the pie.
double | m_dSweepAngle
The sweep angle of the pie.
double | m_dDepth
The depth of the pie or torus.
double | m_dHolePercent
Determines the size of the hole when drawing a doughnut.
double | m_dInnerMajorSemiAxis
The inner size of the major semi axis of the ellipse.
double | m_dInnerMinorSemiAxis
The inner size of the minor semi axis of the ellipse.
double | m_dFacetSize
Facet size.
double | m_dRadius
Pie radius.
double | m_dCorrectedDepth
Pie corrected depth.
double | m_dInnerRadius
Pie inner radius.
BOOL | m_bDoughnut
TRUE indicates doughnut style.

Protected Member Functions

virtual ~CXTPChartPieDeviceCommandImpl ()
Handles object destruction.

Detailed Description

This class is a common implementation for a pie chart device command.

The documentation for this class was generated from the following file:
  • XTPChartPieDeviceCommand.h


Toolkit Pro: CXTPChartPieDiagram Class Reference

Public Member Functions | List of all members
CXTPChartPieDiagram Class Reference

This class abstracts the pie diagram. More...

Inheritance diagram for CXTPChartPieDiagram:
[legend]

Public Member Functions

CXTPChartPieDiagram ()
Constructs a CXTPChartPieDiagram object.
virtual CXTPChartDiagramView * | CreateView (CXTPChartDeviceContext *pDC, CXTPChartElementView *pParent)
Call this function to create the view of the pie diagram.
- Public Member Functions inherited from CXTPChartPieDiagramBase< BaseDiagram >
virtual void | CalculateSeriesLayout (CXTPChartDeviceContext *pDC, CXTPChartDiagramView *pView)
Call this function to calculate the pie series layout.

Additional Inherited Members

- Protected Member Functions inherited from CXTPChartPieDiagramBase< BaseDiagram >
CXTPChartPieDiagramBase ()
Constructs a CXTPChart2dPieDiagramBase object.

Detailed Description

This class abstracts the pie diagram.

This class is a kind of CXTPChartDiagram.

A pie chart (or a circle graph) is a circular chart divided into sectors, illustrating percents. In a pie chart, the arc length of each sector (and consequently its central angle and area), is proportional to the quantity it represents. Together, the sectors create a full disk.

Member Function Documentation

◆ CreateView()

virtual CXTPChartDiagramView * CreateView | ( | CXTPChartDeviceContext * | pDC,
 |  | CXTPChartElementView * | pParent )
 virtual

Call this function to create the view of the pie diagram.

Parameters
pDC | A pointer to the chart device context.
pParent | A pointer to the parent view.
Returns
Returns a pointer to the associated diagram view object.

Implements CXTPChartPieDiagramBase< BaseDiagram >.

The documentation for this class was generated from the following file:
  • XTPChart2dPieDiagram.h


Toolkit Pro: CXTPChartPieDiagramBase< BaseDiagram > Class Template Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPChartPieDiagramBase< BaseDiagram > Class Template Referenceabstract

This class abstracts the pie diagram. More...

Inheritance diagram for CXTPChartPieDiagramBase< BaseDiagram >:
[legend]

Public Member Functions

virtual CXTPChartDiagramView * | CreateView (CXTPChartDeviceContext *pDC, CXTPChartElementView *pParent)=0
Call this function to create the view of the pie diagram.
virtual void | CalculateSeriesLayout (CXTPChartDeviceContext *pDC, CXTPChartDiagramView *pView)
Call this function to calculate the pie series layout.

Protected Member Functions

CXTPChartPieDiagramBase ()
Constructs a CXTPChart2dPieDiagramBase object.

Detailed Description

template<class BaseDiagram>
class CXTPChartPieDiagramBase< BaseDiagram >

This class abstracts the pie diagram.

This class is a kind of CXTPChartDiagram.

A pie chart (or a circle graph) is a circular chart divided into sectors, illustrating percents. In a pie chart, the arc length of each sector (and consequently its central angle and area), is proportional to the quantity it represents. Together, the sectors create a full disk.

Member Function Documentation

◆ CalculateSeriesLayout()

template<class BaseDiagram >
AFX_INLINE void CalculateSeriesLayout | ( | CXTPChartDeviceContext * | pDC,
 |  | CXTPChartDiagramView * | pView )
 virtual

Call this function to calculate the pie series layout.

Parameters
pDC | A pointer to the chart device context.
pView | A pointer to the diagram view.

◆ CreateView()

template<class BaseDiagram >
virtual CXTPChartDiagramView * CreateView | ( | CXTPChartDeviceContext * | pDC,
 |  | CXTPChartElementView * | pParent )
 pure virtual

Call this function to create the view of the pie diagram.

Parameters
pDC | A pointer to the chart device context.
pParent | A pointer to the parent view.
Returns
Returns a pointer to the associated diagram view object.

Implemented in CXTPChart3dPieDiagram, and CXTPChartPieDiagram.

The documentation for this class was generated from the following file:
  • XTPChartPieDiagramBase.h


Toolkit Pro: CXTPChartPieDiagramView Class Reference

Public Member Functions | List of all members
CXTPChartPieDiagramView Class Reference

This class abstracts the view of a pie diagram. More...

Inheritance diagram for CXTPChartPieDiagramView:
[legend]

Public Member Functions

CXTPChartPieDiagramView (CXTPChartDiagram *pDiagram, CXTPChartElementView *pParent)
Constructs a CXTPChartPieDiagramView object.
- Public Member Functions inherited from CXTPChartDiagramView
CXTPChartDiagramView (CXTPChartDiagram *pDiagram, CXTPChartElementView *pParentView)
Constructs a CXTPChartDiagram object.
CRect | GetBounds () const
Call this function to get the bounds of the diagram.
CXTPChartDiagram * | GetDiagram () const
Call this function to get the diagram object associated with the view.
CXTPChartElementView * | GetLabelsView () const
Call this function to get the label view object associated with this diagram view.
CXTPChartElementView * | GetSeriesView () const
Call this function to get the series view object associated with this diagram view.
virtual void | CalculateView (CXTPChartDeviceContext *pDC, CRect rcBounds)
Call this function to calculate the view of the diagram.
virtual void | UpdateRange (CXTPChartDeviceContext *pDC)
Updates chart range.
virtual void | OnMouseWheel (UINT nFlags, short zDelta, CPoint pt)
Handles mouse wheel event.
virtual void | CreateView (CXTPChartDeviceContext *pDC)
Performs view initialization.
- Public Member Functions inherited from CXTPChartElementView
CXTPChartElementView (CXTPChartElementView *pParentView)
Constructs a CXTPChartElementView object.
CXTPChartElementView (CXTPChartElementView *pParentView, BOOL bAddToParent)
Constructs a CXTPChartElementView object.
CXTPChartElementView (CXTPChartContainer *pContainer)
Constructs a CXTPChartElementView object.
int | GetCount () const
Call this function to get the number of child views associated with this view.
CXTPChartElementView * | GetAt (int nIndex) const
Call this function to get a child view at a particular index.
CXTPChartElementView * | GetParentView () const
Call this function to get the parent view.
CXTPChartElementView * | AddChildView (CXTPChartElementView *pChildView)
Call this function to add a child view to the current view.
CXTPChartElementView ** GetChildren ()
Provides access to the collection of children elements owned by the view.
CRect | GetBounds () const
Obtains viewed object's bound rectangle.
CRect | GetBounds (BOOL bIncludingChildren) const
Obtains viewed object's bound rectangle.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Additional Inherited Members

- Public Attributes inherited from CXTPChartDiagramView
- Protected Member Functions inherited from CXTPChartDiagramView
virtual CXTPChartDeviceCommand * | CreateDeviceCommand (CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
- Protected Member Functions inherited from CXTPChartElementView
virtual | ~CXTPChartElementView ()
Destroys a CXTPChartElementView object, handles cleanup.
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.
- Protected Attributes inherited from CXTPChartDiagramView
CXTPChartDiagram * | m_pDiagram
Pointer to the associated diagram object.
CRect | m_rcBounds
The diagram bounds.
CXTPChartElementView * | m_pLabelsView
The label view.
CXTPChartElementView * | m_pSeriesView
The series view.
CXTPChartElementView * | m_pTitlesView
Titles View.
- Protected Attributes inherited from CXTPChartElementView
CArray< CXTPChartElementView *, CXTPChartElementView * > | m_arrChildren
The child view collection.
CXTPChartElementView * | m_pParentView
The parent view.
CXTPChartContainer * | m_pContainer
The parent container.
CRect | m_rcBounds
Bounding rectangle.

Detailed Description

This class abstracts the view of a pie diagram.

This class is a kind of CXTPChartDiagramView.

A pie chart (or a circle graph) is a circular chart divided into sectors, illustrating percents. In a pie chart, the arc length of each sector (and consequently its central angle and area), is proportional to the quantity it represents. Together, the sectors create a full disk.

Constructor & Destructor Documentation

◆ CXTPChartPieDiagramView()

CXTPChartPieDiagramView | ( | CXTPChartDiagram * | pDiagram,
 |  | CXTPChartElementView * | pParent )

Constructs a CXTPChartPieDiagramView object.

Parameters
pDiagram | A pointer to the pie diagram object.
pParent | A pointer to the parent view.
The documentation for this class was generated from the following file:
  • XTPChart2dPieDiagramView.h


Toolkit Pro: CXTPChartPieSeriesLabel Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPChartPieSeriesLabel Class Reference

CXTPChartPieSeriesLabelBase is a kind of CXTPChartPieSeriesLabel. More...

Inheritance diagram for CXTPChartPieSeriesLabel:
[legend]

Public Member Functions

CXTPChartPieSeriesLabel ()
Constructs a CXTPChartPieSeriesLabel object.
CXTPChartPointF | CalculateAnchorPointAndAngles (CXTPChartPieSeriesPointViewBase *pPointView, int borderThickness, double &lineAngle)
Call this function to calculate the anchor points and angles of the pie label stem.
- Public Member Functions inherited from CXTPChartPieSeriesLabelBase
CXTPChartPieSeriesLabelBase ()
Constructs a CXTPChartPieSeriesLabelBase object.
virtual | ~CXTPChartPieSeriesLabelBase ()
Destroys a CXTPChartPieSeriesLabelBase object, handles cleanup.
XTPChartPieLabelPosition | GetPosition () const
Call this function to get the label position.
void | SetPosition (XTPChartPieLabelPosition nPosition)
Call this function to set the label position.
CXTPChartPieSeriesStyleBase * | GetStyle () const
Call this function to get the basic style of the pie series.
void | DoPropExchange (CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
BOOL | IsInside () const
Call this function to check whether the label is inside the pie.
- Public Member Functions inherited from CXTPChartSeriesLabel
CXTPChartSeriesLabel ()
Constructs a CXTPChartSeriesLabel object.
virtual | ~CXTPChartSeriesLabel ()
Destroys a CXTPChartSeriesLabel object, handles cleanup.
void | SetTextColor (const CXTPChartColor &clrTextColor)
Call this function to set the text color of the label.
CXTPChartColor | GetTextColor () const
Call this function to get the apparent text color of the label.
CXTPChartFont * | GetFont () const
Call this function to get the font of the text label.
void | SetFont (CXTPChartFont *pFont)
Call this function to set the font of the text label.
void | SetShowLines (BOOL bShowLines)
Call this function to set the lines visibility.
BOOL | GetShowLines () const
Call this function to check if the lines are visible.
void | SetLineLength (int nLineLength)
Call this function to set the line length.
int | GetLineLength () const
Call this function to get the line length.
void | SetVisible (BOOL bVisible)
Call this function to set the label visibility.
BOOL | IsVisible () const
Call this function to check if the label is visible.
void | SetAntialiasing (BOOL bAntialiasing)
Call this function to set anti-aliasing ON or OFF.
BOOL | GetAntialiasing () const
Call this function to check if anti-aliasing is ON or OFF.
CXTPChartNumberFormat * | GetFormat () const
Call this function to get a pointer to CXTPChartNumberFormat that specifies how to convert numbers to strings.
void | SetFormat (LPCTSTR lpszFormat)
Obsolete method.
void | SetBackColor (const CXTPChartColor &clrBackColor)
Call this function to set the text color of the label.
CXTPChartColor | GetBackColor () const
Call this function to get the apparent text color of the label.
void | SetLineColor (const CXTPChartColor &clrBackColor)
Call this function to set the text color of the label.
CXTPChartColor | GetLineColor () const
Call this function to get the apparent text color of the label.
int | GetTransparency () const
Call this function to get the transparency of the filled area with respect to the background.
void | SetTransparency (int nTransparency)
Call this function to set the transparency of the filled area with respect to the background.
- Public Member Functions inherited from CXTPChartTextElement
- Public Member Functions inherited from CXTPChartElement
CXTPChartElement ()
Constructs a CXTPChartElement object.
virtual | ~CXTPChartElement ()
Destroys a CXTPChartElement object, handles cleanup.
virtual void | Release ()
Call this function to decrease the usage count of the object.
CXTPChartElement * | GetOwner () const
Call this function to get the owner element.
virtual void | OnChartChanged (XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic properties of the chart.
CXTPChartContent * | GetContent () const
Call this virtual function to get the chart content object.
CXTPChartAppearance * | GetAppearance () const
Call this function to get the the appearance of the chart.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Protected Member Functions

virtual CXTPChartElementView * CreateView (CXTPChartDeviceContext *pDC, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView)
This function creates the view of the pie series.
- Protected Member Functions inherited from CXTPChartPieSeriesLabelBase
- Protected Member Functions inherited from CXTPChartSeriesLabel
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.

Additional Inherited Members

- Public Attributes inherited from CXTPChartElement
- Protected Attributes inherited from CXTPChartPieSeriesLabelBase
XTPChartPieLabelPosition | m_nPosition
The pie label position.
- Protected Attributes inherited from CXTPChartSeriesLabel
CXTPChartColor | m_clrTextColor
The text color.
CXTPChartColor | m_clrBackColor
The background color.
CXTPChartColor | m_clrLineColor
The line color.
BOOL | m_bVisible
TRUE if the label is visible and FALSE if not.
CXTPChartFont * | m_pFont
The font of the label.
BOOL | m_bAntialiasing
TRUE if antialiasing enabled, FALSE if not.
BOOL | m_bShowLines
TRUE if the lines are visible, FALSE if not.
int | m_nLineLength
The line length.
CXTPChartBorder * | m_pBorder
Chart border object.
int | m_nTransparency
The transparency values range from 0 to 255.
- Protected Attributes inherited from CXTPChartElement

Detailed Description

CXTPChartPieSeriesLabelBase is a kind of CXTPChartPieSeriesLabel.

This class abstracts the label of a pie series.

Member Function Documentation

◆ CalculateAnchorPointAndAngles()

CXTPChartPointF CalculateAnchorPointAndAngles | ( | CXTPChartPieSeriesPointViewBase * | pPointView,
 |  | int | borderThickness,
 |  | double & | lineAngle )

Call this function to calculate the anchor points and angles of the pie label stem.

Parameters
pPointView | The pie series point view.
borderThickness | The border thickness of the label.
lineAngle | The line(stem) angle, out param.
Returns
Returns a CXTPChartPointF object denoting the anchor point.

◆ CreateView()

virtual CXTPChartElementView * CreateView | ( | CXTPChartDeviceContext * | pDC,
 |  | CXTPChartSeriesPointView * | pPointView,
 |  | CXTPChartElementView * | pParentView )
 protectedvirtual

This function creates the view of the pie series.

Parameters
pDC | The chart device context object pointer.
pPointView | The series point view.
pParentView | The pointer to the parent view object.
Returns
Returns a pointer to the associated label view object.

Implements CXTPChartPieSeriesLabelBase.

The documentation for this class was generated from the following file:
  • XTPChart2dPieSeriesLabel.h


Toolkit Pro: CXTPChartPieSeriesLabelBase Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPChartPieSeriesLabelBase Class Referenceabstract

CXTPChartPieSeriesLabelBase is a kind of CXTPChartSeriesLabel. More...

Inheritance diagram for CXTPChartPieSeriesLabelBase:
[legend]

Public Member Functions

CXTPChartPieSeriesLabelBase ()
Constructs a CXTPChartPieSeriesLabelBase object.
virtual | ~CXTPChartPieSeriesLabelBase ()
Destroys a CXTPChartPieSeriesLabelBase object, handles cleanup.
XTPChartPieLabelPosition | GetPosition () const
Call this function to get the label position.
void | SetPosition (XTPChartPieLabelPosition nPosition)
Call this function to set the label position.
CXTPChartPieSeriesStyleBase * | GetStyle () const
Call this function to get the basic style of the pie series.
void | DoPropExchange (CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
BOOL | IsInside () const
Call this function to check whether the label is inside the pie.
- Public Member Functions inherited from CXTPChartSeriesLabel
CXTPChartSeriesLabel ()
Constructs a CXTPChartSeriesLabel object.
virtual | ~CXTPChartSeriesLabel ()
Destroys a CXTPChartSeriesLabel object, handles cleanup.
void | SetTextColor (const CXTPChartColor &clrTextColor)
Call this function to set the text color of the label.
CXTPChartColor | GetTextColor () const
Call this function to get the apparent text color of the label.
CXTPChartFont * | GetFont () const
Call this function to get the font of the text label.
void | SetFont (CXTPChartFont *pFont)
Call this function to set the font of the text label.
void | SetShowLines (BOOL bShowLines)
Call this function to set the lines visibility.
BOOL | GetShowLines () const
Call this function to check if the lines are visible.
void | SetLineLength (int nLineLength)
Call this function to set the line length.
int | GetLineLength () const
Call this function to get the line length.
void | SetVisible (BOOL bVisible)
Call this function to set the label visibility.
BOOL | IsVisible () const
Call this function to check if the label is visible.
void | SetAntialiasing (BOOL bAntialiasing)
Call this function to set anti-aliasing ON or OFF.
BOOL | GetAntialiasing () const
Call this function to check if anti-aliasing is ON or OFF.
CXTPChartNumberFormat * | GetFormat () const
Call this function to get a pointer to CXTPChartNumberFormat that specifies how to convert numbers to strings.
void | SetFormat (LPCTSTR lpszFormat)
Obsolete method.
void | SetBackColor (const CXTPChartColor &clrBackColor)
Call this function to set the text color of the label.
CXTPChartColor | GetBackColor () const
Call this function to get the apparent text color of the label.
void | SetLineColor (const CXTPChartColor &clrBackColor)
Call this function to set the text color of the label.
CXTPChartColor | GetLineColor () const
Call this function to get the apparent text color of the label.
int | GetTransparency () const
Call this function to get the transparency of the filled area with respect to the background.
void | SetTransparency (int nTransparency)
Call this function to set the transparency of the filled area with respect to the background.
- Public Member Functions inherited from CXTPChartTextElement
- Public Member Functions inherited from CXTPChartElement
CXTPChartElement ()
Constructs a CXTPChartElement object.
virtual | ~CXTPChartElement ()
Destroys a CXTPChartElement object, handles cleanup.
virtual void | Release ()
Call this function to decrease the usage count of the object.
CXTPChartElement * | GetOwner () const
Call this function to get the owner element.
virtual void | OnChartChanged (XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic properties of the chart.
CXTPChartContent * | GetContent () const
Call this virtual function to get the chart content object.
CXTPChartAppearance * | GetAppearance () const
Call this function to get the the appearance of the chart.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Protected Member Functions

virtual CXTPChartElementView * CreateView (CXTPChartDeviceContext *pDC, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView)=0
This function creates the view of the pie series.
- Protected Member Functions inherited from CXTPChartSeriesLabel
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.

Protected Attributes

XTPChartPieLabelPosition | m_nPosition
The pie label position.
- Protected Attributes inherited from CXTPChartSeriesLabel
CXTPChartColor | m_clrTextColor
The text color.
CXTPChartColor | m_clrBackColor
The background color.
CXTPChartColor | m_clrLineColor
The line color.
BOOL | m_bVisible
TRUE if the label is visible and FALSE if not.
CXTPChartFont * | m_pFont
The font of the label.
BOOL | m_bAntialiasing
TRUE if antialiasing enabled, FALSE if not.
BOOL | m_bShowLines
TRUE if the lines are visible, FALSE if not.
int | m_nLineLength
The line length.
CXTPChartBorder * | m_pBorder
Chart border object.
int | m_nTransparency
The transparency values range from 0 to 255.
- Protected Attributes inherited from CXTPChartElement

Detailed Description

CXTPChartPieSeriesLabelBase is a kind of CXTPChartSeriesLabel.

This class abstracts the label of a pie series.

Member Function Documentation

◆ CreateView()

virtual CXTPChartElementView * CreateView | ( | CXTPChartDeviceContext * | pDC,
 |  | CXTPChartSeriesPointView * | pPointView,
 |  | CXTPChartElementView * | pParentView )
 protectedpure virtual

This function creates the view of the pie series.

Parameters
pDC | The chart device context object pointer.
pPointView | The series point view.
pParentView | Parent view pointer.
Returns
Returns a pointer to the associated label view object.

Reimplemented from CXTPChartSeriesLabel.

Implemented in CXTPChart3dPieSeriesLabel, and CXTPChartPieSeriesLabel.

◆ DoPropExchange()

void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Reads this object from or writes this object to an archive.

Parameters
pPX A CXTPPropExchange object to serialize to or from.

Reimplemented from CXTPChartSeriesLabel.

◆ GetPosition()

AFX_INLINE XTPChartPieLabelPosition GetPosition ( ) const

Call this function to get the label position.

Returns
A pie label position object describing the position of the pie label.

◆ GetStyle()

CXTPChartPieSeriesStyleBase * GetStyle ( ) const

Call this function to get the basic style of the pie series.

Returns
A pointer to a CXTPChartPieSeriesStyleBase object.

◆ IsInside()

BOOL IsInside ( ) const

Call this function to check whether the label is inside the pie.

Returns
Returns TRUE if the label is inside the pie, FALSE otherwise.

◆ SetPosition()

AFX_INLINE void SetPosition ( XTPChartPieLabelPosition nPosition )

Call this function to set the label position.

Parameters
nPosition A pie label position object describing the position of the pie label.
The documentation for this class was generated from the following file:
  • XTPChartPieSeriesLabelBase.h


Toolkit Pro: CXTPChartPieSeriesLabelsView Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPChartPieSeriesLabelsView Class Reference

Defines 2D series label collection view. More...

Inheritance diagram for CXTPChartPieSeriesLabelsView:
[legend]

Public Member Functions

CXTPChartPieSeriesLabelsView (CXTPChartElementView *pParentView)
Constructs a CXTPChartPieSeriesLabelsView object.
virtual CXTPChartDeviceCommand * | CreateDeviceCommand (CXTPChartDeviceContext *pDC)
Creates a view drawing device command for the device context specified.
virtual void | ResolveOverlapping ()
Resolves label overlapping in an implementation specific way.
- Public Member Functions inherited from CXTPChartPieSeriesLabelsViewBase
- Public Member Functions inherited from CXTPChartElementView
CXTPChartElementView (CXTPChartElementView *pParentView)
Constructs a CXTPChartElementView object.
CXTPChartElementView (CXTPChartElementView *pParentView, BOOL bAddToParent)
Constructs a CXTPChartElementView object.
CXTPChartElementView (CXTPChartContainer *pContainer)
Constructs a CXTPChartElementView object.
int | GetCount () const
Call this function to get the number of child views associated with this view.
CXTPChartElementView * | GetAt (int nIndex) const
Call this function to get a child view at a particular index.
CXTPChartElementView * | GetParentView () const
Call this function to get the parent view.
CXTPChartElementView * | AddChildView (CXTPChartElementView *pChildView)
Call this function to add a child view to the current view.
CXTPChartElementView ** GetChildren ()
Provides access to the collection of children elements owned by the view.
CRect | GetBounds () const
Obtains viewed object's bound rectangle.
CRect | GetBounds (BOOL bIncludingChildren) const
Obtains viewed object's bound rectangle.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Protected Member Functions

void | ResolveOverlappingColumn (CArray< CXTPChartPieSeriesLabelView *, CXTPChartPieSeriesLabelView * > &arrColumn)
Resolves label overlapping for column mode.
- Protected Member Functions inherited from CXTPChartPieSeriesLabelsViewBase
CXTPChartPieSeriesLabelsViewBase (CXTPChartElementView *pParentView)
Constructs a CXTPChartPieSeriesLabelsViewBase object.
- Protected Member Functions inherited from CXTPChartElementView
virtual | ~CXTPChartElementView ()
Destroys a CXTPChartElementView object, handles cleanup.
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.

Additional Inherited Members

- Protected Attributes inherited from CXTPChartElementView
CArray< CXTPChartElementView *, CXTPChartElementView * > | m_arrChildren
The child view collection.
CXTPChartElementView * | m_pParentView
The parent view.
CXTPChartContainer * | m_pContainer
The parent container.
CRect | m_rcBounds
Bounding rectangle.

Detailed Description

Defines 2D series label collection view.

Constructor & Destructor Documentation

◆ CXTPChartPieSeriesLabelsView()

CXTPChartPieSeriesLabelsView ( CXTPChartElementView * pParentView )

Constructs a CXTPChartPieSeriesLabelsView object.

Parameters
pParentView Parent view pointer.

Member Function Documentation

◆ CreateDeviceCommand()

virtual CXTPChartDeviceCommand * CreateDeviceCommand ( CXTPChartDeviceContext * pDC )
virtual

Creates a view drawing device command for the device context specified.

Parameters
pDC Device context pointer for which the drawing command is to be created.
Returns
A new instance of view drawing device command or NULL if no command is provided.

Implements CXTPChartPieSeriesLabelsViewBase.

◆ ResolveOverlappingColumn()

void ResolveOverlappingColumn ( CArray< CXTPChartPieSeriesLabelView *, CXTPChartPieSeriesLabelView * > & arrColumn )
protected

Resolves label overlapping for column mode.

Parameters
arrColumn Label collumn array reference.
The documentation for this class was generated from the following file:
  • XTPChart2dPieSeriesLabel.h


Toolkit Pro: CXTPChartPieSeriesLabelsViewBase Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPChartPieSeriesLabelsViewBase Class Referenceabstract

Defines a base class interface for series label collection view. More...

Inheritance diagram for CXTPChartPieSeriesLabelsViewBase:
[legend]

Public Member Functions

virtual CXTPChartDeviceCommand * | CreateDeviceCommand (CXTPChartDeviceContext *pDC)=0
Creates view drawing device command for the device context specified.
virtual void | ResolveOverlapping ()=0
Resolves label overlapping in an implementation specific way.
- Public Member Functions inherited from CXTPChartElementView
CXTPChartElementView (CXTPChartElementView *pParentView)
Constructs a CXTPChartElementView object.
CXTPChartElementView (CXTPChartElementView *pParentView, BOOL bAddToParent)
Constructs a CXTPChartElementView object.
CXTPChartElementView (CXTPChartContainer *pContainer)
Constructs a CXTPChartElementView object.
int | GetCount () const
Call this function to get the number of child views associated with this view.
CXTPChartElementView * | GetAt (int nIndex) const
Call this function to get a child view at a particular index.
CXTPChartElementView * | GetParentView () const
Call this function to get the parent view.
CXTPChartElementView * | AddChildView (CXTPChartElementView *pChildView)
Call this function to add a child view to the current view.
CXTPChartElementView ** GetChildren ()
Provides access to the collection of children elements owned by the view.
CRect | GetBounds () const
Obtains viewed object's bound rectangle.
CRect | GetBounds (BOOL bIncludingChildren) const
Obtains viewed object's bound rectangle.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Protected Member Functions

CXTPChartPieSeriesLabelsViewBase (CXTPChartElementView *pParentView)
Constructs a CXTPChartPieSeriesLabelsViewBase object.
- Protected Member Functions inherited from CXTPChartElementView
virtual ~CXTPChartElementView ()
Destroys a CXTPChartElementView object, handles cleanup.
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.

Additional Inherited Members

- Protected Attributes inherited from CXTPChartElementView
CArray< CXTPChartElementView *, CXTPChartElementView * > | m_arrChildren
The child view collection.
CXTPChartElementView * | m_pParentView
The parent view.
CXTPChartContainer * | m_pContainer
The parent container.
CRect | m_rcBounds
Bounding rectangle.

Detailed Description

Defines a base class interface for series label collection view.

Constructor & Destructor Documentation

◆ CXTPChartPieSeriesLabelsViewBase()

CXTPChartPieSeriesLabelsViewBase ( CXTPChartElementView * pParentView )
protected

Constructs a CXTPChartPieSeriesLabelsViewBase object.

Parameters
pParentView Parent view pointer.

Member Function Documentation

◆ CreateDeviceCommand()

virtual CXTPChartDeviceCommand * CreateDeviceCommand ( CXTPChartDeviceContext * pDC )
pure virtual

Creates view drawing device command for the device context specified.

Parameters
pDC Device context pointer for which the drawing command is to be created.
Returns
A new instance of view drawing device command or NULL if no command is provided.

Reimplemented from CXTPChartElementView.

Implemented in CXTPChart3dPieSeriesLabelsView, and CXTPChartPieSeriesLabelsView.

The documentation for this class was generated from the following file:
  • XTPChartPieSeriesLabelBase.h


Toolkit Pro: CXTPChartPieSeriesLabelView Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPChartPieSeriesLabelView Class Reference

Defines 2D series label view. More...

Inheritance diagram for CXTPChartPieSeriesLabelView:
[legend]

Public Member Functions

CXTPChartPieSeriesLabelView (CXTPChartSeriesLabel *pLabel, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView)
Constructs a CXTPChartPieSeriesLabelView object.
void | CalculateLayout (CXTPChartDeviceContext *pDC)
Calculates label and connector layout for the device context specified.
virtual CXTPChartDeviceCommand * | CreateConnectorDeviceCommand (CXTPChartDeviceContext *pDC)
Creates connector drawing device command for the device context specified.
virtual CXTPChartDeviceCommand * | CreateDeviceCommand (CXTPChartDeviceContext *pDC)
Creates view drawing device command for the device context specified.
- Public Member Functions inherited from CXTPChartPieSeriesLabelViewBase
XTPChartPieLabelPosition | GetPosition () const
Obtains label position.

Protected Attributes

CXTPChartRectF | m_rcBounds
The determined boundary rectange.
CXTPChartPointF | m_ptStartPoint
The determined connector start point.
double | m_dLineAngle
The determined connector line angle.

Additional Inherited Members

- Protected Member Functions inherited from CXTPChartPieSeriesLabelViewBase
CXTPChartPieSeriesLabelViewBase (CXTPChartSeriesLabel *pLabel, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView)
Constructs a CXTPChartPieSeriesLabelViewBase object.

Detailed Description

Defines 2D series label view.

Constructor & Destructor Documentation

◆ CXTPChartPieSeriesLabelView()

CXTPChartPieSeriesLabelView | ( | CXTPChartSeriesLabel * | pLabel,
 |  | CXTPChartSeriesPointView * | pPointView,
 |  | CXTPChartElementView * | pParentView )

Constructs a CXTPChartPieSeriesLabelView object.

Parameters
pLabel | Associated label model pointer.
pPointView | Point view object pointer associated with the label.
pParentView | Parent view pointer.

Member Function Documentation

◆ CalculateLayout()

void CalculateLayout ( CXTPChartDeviceContext * pDC )

Calculates label and connector layout for the device context specified.

Parameters
pDC Device context pointer.

◆ CreateConnectorDeviceCommand()

virtual CXTPChartDeviceCommand * CreateConnectorDeviceCommand ( CXTPChartDeviceContext * pDC )
virtual

Creates connector drawing device command for the device context specified.

Parameters
pDC Device context pointer for which the drawing command is to be created.
Returns
A new instance of connector drawing device command or NULL if no command is provided.

Implements CXTPChartPieSeriesLabelViewBase.

◆ CreateDeviceCommand()

virtual CXTPChartDeviceCommand * CreateDeviceCommand ( CXTPChartDeviceContext * pDC )
virtual

Creates view drawing device command for the device context specified.

Parameters
pDC Device context pointer for which the drawing command is to be created.
Returns
A new instance of view drawing device command or NULL if no command is provided.

Implements CXTPChartPieSeriesLabelViewBase.

The documentation for this class was generated from the following file:
  • XTPChart2dPieSeriesLabel.h


Toolkit Pro: CXTPChartPieSeriesLabelViewBase Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPChartPieSeriesLabelViewBase Class Referenceabstract

Defines a base class interface for series label view. More...

Inheritance diagram for CXTPChartPieSeriesLabelViewBase:
[legend]

Public Member Functions

XTPChartPieLabelPosition | GetPosition () const
Obtains label position.
virtual CXTPChartDeviceCommand * | CreateDeviceCommand (CXTPChartDeviceContext *pDC)=0
Creates view drawing device command for the device context specified.
virtual CXTPChartDeviceCommand * | CreateConnectorDeviceCommand (CXTPChartDeviceContext *pDC)=0
Creates connector drawing device command for the device context specified.

Protected Member Functions

CXTPChartPieSeriesLabelViewBase (CXTPChartSeriesLabel *pLabel, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView)
Constructs a CXTPChartPieSeriesLabelViewBase object.

Detailed Description

Defines a base class interface for series label view.

Constructor & Destructor Documentation

◆ CXTPChartPieSeriesLabelViewBase()

CXTPChartPieSeriesLabelViewBase | ( | CXTPChartSeriesLabel * | pLabel,
 |  | CXTPChartSeriesPointView * | pPointView,
 |  | CXTPChartElementView * | pParentView )
 protected

Constructs a CXTPChartPieSeriesLabelViewBase object.

Parameters
pLabel | Associated label model pointer.
pPointView | Point view object pointer associated with the label.
pParentView | Parent view pointer.

Member Function Documentation

◆ CreateConnectorDeviceCommand()

virtual CXTPChartDeviceCommand * CreateConnectorDeviceCommand ( CXTPChartDeviceContext * pDC )
pure virtual

Creates connector drawing device command for the device context specified.

Parameters
pDC Device context pointer for which the drawing command is to be created.
Returns
A new instance of connector drawing device command or NULL if no command is provided.

Implemented in CXTPChart3dPieSeriesLabelView, and CXTPChartPieSeriesLabelView.

◆ CreateDeviceCommand()

virtual CXTPChartDeviceCommand * CreateDeviceCommand ( CXTPChartDeviceContext * pDC )
pure virtual

Creates view drawing device command for the device context specified.

Parameters
pDC Device context pointer for which the drawing command is to be created.
Returns
A new instance of view drawing device command or NULL if no command is provided.

Reimplemented from CXTPChartElementView.

Implemented in CXTPChart3dPieSeriesLabelView, and CXTPChartPieSeriesLabelView.

◆ GetPosition()

XTPChartPieLabelPosition GetPosition ( ) const

Obtains label position.

Returns
Label position.
The documentation for this class was generated from the following file:
  • XTPChartPieSeriesLabelBase.h


Toolkit Pro: CXTPChartPieSeriesPointView Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPChartPieSeriesPointView Class Reference

This class abstracts the view of a pie series point. More...

Inheritance diagram for CXTPChartPieSeriesPointView:
[legend]

Public Member Functions

CXTPChartPieSeriesPointView (CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Constructs a CXTPChartPieSeriesPointView object.
CXTPChartPieSeriesPointView (CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView, BOOL bAddToParent)
Constructs a CXTPChartPieSeriesPointView object.
virtual void | CalculateLayout (double &dAngle)
Use this function to calculate the layout of the pie series point.
- Public Member Functions inherited from CXTPChartPieSeriesPointViewBase
virtual | ~CXTPChartPieSeriesPointViewBase ()
Destroys a CXTPChartPieSeriesPointViewBase object, handle cleanup.
CXTPChartPieBase * | GetPie () const
Use this function to get the pie for the point.
CXTPChartPointF | GetBasePoint () const
Use this function to obtain the base point value.
- Public Member Functions inherited from CXTPChartSeriesPointView
CXTPChartSeriesPointView (CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Constructs the view object.
CXTPChartSeriesPointView (CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView, BOOL bAddToParent)
Constructs the view object.
CXTPChartSeriesPoint * | GetPoint () const
Obtains point model object.
CXTPChartSeriesView * | GetSeriesView () const
Obtains parent series view.
CXTPChartColor | GetColor () const
Obtain view color values.
CXTPChartColor | GetColor2 () const
Obtain view color values.
double | GetInternalValue () const
Obtains point interval value.
virtual CXTPChartString | GetLegendName () const
This function returns the legend name.
virtual void | UpdateMinMaxRange (double &nMinValue, double &nMaxValue) const
Provides a default empty implementation for min/max range update request.
- Public Member Functions inherited from CXTPChartElementView
CXTPChartElementView (CXTPChartElementView *pParentView)
Constructs a CXTPChartElementView object.
CXTPChartElementView (CXTPChartElementView *pParentView, BOOL bAddToParent)
Constructs a CXTPChartElementView object.
CXTPChartElementView (CXTPChartContainer *pContainer)
Constructs a CXTPChartElementView object.
int | GetCount () const
Call this function to get the number of child views associated with this view.
CXTPChartElementView * | GetAt (int nIndex) const
Call this function to get a child view at a particular index.
CXTPChartElementView * | GetParentView () const
Call this function to get the parent view.
CXTPChartElementView * | AddChildView (CXTPChartElementView *pChildView)
Call this function to add a child view to the current view.
CXTPChartElementView ** GetChildren ()
Provides access to the collection of children elements owned by the view.
CRect | GetBounds () const
Obtains viewed object's bound rectangle.
CRect | GetBounds (BOOL bIncludingChildren) const
Obtains viewed object's bound rectangle.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.
- Public Member Functions inherited from CXTPChartLegendItemView
virtual | ~CXTPChartLegendItemView ()
Handles object destruction.

Protected Member Functions

virtual CXTPChartDeviceCommand * | CreateDeviceCommand (CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
virtual CXTPChartDeviceCommand * | CreateLegendDeviceCommand (CXTPChartDeviceContext *pDC, CRect rcBounds)
This function creates a label view drawing command object.
- Protected Member Functions inherited from CXTPChartPieSeriesPointViewBase
CXTPChartPieSeriesPointViewBase (CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Constructs a CXTPChartPieSeriesPointViewBase object.
CXTPChartPieSeriesPointViewBase (CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView, BOOL bAddToParent)
Constructs a CXTPChartPieSeriesPointViewBase object.
- Protected Member Functions inherited from CXTPChartElementView
virtual | ~CXTPChartElementView ()
Destroys a CXTPChartElementView object, handles cleanup.
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.

Additional Inherited Members

- Public Attributes inherited from CXTPChartPieSeriesPointViewBase
- Public Attributes inherited from CXTPChartSeriesPointView
double | m_dInternalValue
Point internal value.
- Protected Attributes inherited from CXTPChartPieSeriesPointViewBase
- Protected Attributes inherited from CXTPChartSeriesPointView
CXTPChartSeriesPoint * | m_pPoint
Point model object pointer.
- Protected Attributes inherited from CXTPChartElementView
CArray< CXTPChartElementView *, CXTPChartElementView * > | m_arrChildren
The child view collection.
CXTPChartElementView * | m_pParentView
The parent view.
CXTPChartContainer * | m_pContainer
The parent container.
CRect | m_rcBounds
Bounding rectangle.

Detailed Description

This class abstracts the view of a pie series point.

This class is a kind of CXTPChartSeriesPointView.

A pie chart (or a circle graph) is a circular chart divided into sectors, illustrating percents. In a pie chart, the arc length of each sector (and consequently its central angle and area), is proportional to the quantity it represents. Together, the sectors create a full disk.

Constructor & Destructor Documentation

◆ CXTPChartPieSeriesPointView() [1/2]

CXTPChartPieSeriesPointView | ( | CXTPChartSeriesPoint * | pPoint,
 |  | CXTPChartElementView * | pParentView )

Constructs a CXTPChartPieSeriesPointView object.

Parameters
pPoint | Pointer to a chart series point.
pParentView | A pointer to the parent view.

◆ CXTPChartPieSeriesPointView() [2/2]

CXTPChartPieSeriesPointView | ( | CXTPChartSeriesPoint * | pPoint,
 |  | CXTPChartElementView * | pParentView,
 |  | BOOL | bAddToParent )

Constructs a CXTPChartPieSeriesPointView object.

Parameters
pPoint | Pointer to a chart series point.
pParentView | A pointer to the parent view.
bAddToParent | If TRUE the view will be be added to parent's child view list.

Member Function Documentation

◆ CalculateLayout()

virtual void CalculateLayout ( double & dAngle )
virtual

Use this function to calculate the layout of the pie series point.

Parameters
dAngle The swipe angle of the sector(pie).

Implements CXTPChartPieSeriesPointViewBase.

◆ CreateDeviceCommand()

virtual CXTPChartDeviceCommand * CreateDeviceCommand ( CXTPChartDeviceContext * pDC )
protectedvirtual

This function creates a CXTPChartDeviceCommand object.

This object represents the rendering of the pie series point.

Parameters
pDC Pointer to a CXTPChartDeviceContext object.
Returns
Returns a CXTPChartDeviceCommand object. This object handles the rendering of an element in the chart. Here it handles the drawing of the pie series point.

Implements CXTPChartPieSeriesPointViewBase.

◆ CreateLegendDeviceCommand()

virtual CXTPChartDeviceCommand * CreateLegendDeviceCommand | ( | CXTPChartDeviceContext * | pDC,
 |  | CRect | rcBounds )
 protectedvirtual

This function creates a label view drawing command object.

Parameters
pDC | Pointer to a CXTPChartDeviceContext object.
rcBounds | The rectangular boundary of the legend.
Returns
Returns a new label view drawing command object.

Implements CXTPChartPieSeriesPointViewBase.

The documentation for this class was generated from the following file:
  • XTPChart2dPieSeriesPointView.h


Toolkit Pro: CXTPChartPieSeriesPointViewBase Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPChartPieSeriesPointViewBase Class Referenceabstract

This class abstracts the view of a pie series point. More...

Inheritance diagram for CXTPChartPieSeriesPointViewBase:
[legend]

Public Member Functions

virtual | ~CXTPChartPieSeriesPointViewBase ()
Destroys a CXTPChartPieSeriesPointViewBase object, handle cleanup.
virtual void | CalculateLayout (double &dAngle)=0
Use this function to calculate the layout of the pie series point.
CXTPChartPieBase * | GetPie () const
Use this function to get the pie for the point.
CXTPChartPointF | GetBasePoint () const
Use this function to obtain the base point value.
virtual CXTPChartDeviceCommand * | CreateDeviceCommand (CXTPChartDeviceContext *pDC)=0
This function creates a CXTPChartDeviceCommand object.
virtual CXTPChartDeviceCommand * | CreateLegendDeviceCommand (CXTPChartDeviceContext *pDC, CRect rcBounds)=0
This function creates a label view drawing command object.
- Public Member Functions inherited from CXTPChartSeriesPointView
CXTPChartSeriesPointView (CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Constructs the view object.
CXTPChartSeriesPointView (CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView, BOOL bAddToParent)
Constructs the view object.
CXTPChartSeriesPoint * | GetPoint () const
Obtains point model object.
CXTPChartSeriesView * | GetSeriesView () const
Obtains parent series view.
CXTPChartColor | GetColor () const
Obtain view color values.
CXTPChartColor | GetColor2 () const
Obtain view color values.
double | GetInternalValue () const
Obtains point interval value.
virtual CXTPChartString | GetLegendName () const
This function returns the legend name.
virtual void | UpdateMinMaxRange (double &nMinValue, double &nMaxValue) const
Provides a default empty implementation for min/max range update request.
- Public Member Functions inherited from CXTPChartElementView
CXTPChartElementView (CXTPChartElementView *pParentView)
Constructs a CXTPChartElementView object.
CXTPChartElementView (CXTPChartElementView *pParentView, BOOL bAddToParent)
Constructs a CXTPChartElementView object.
CXTPChartElementView (CXTPChartContainer *pContainer)
Constructs a CXTPChartElementView object.
int | GetCount () const
Call this function to get the number of child views associated with this view.
CXTPChartElementView * | GetAt (int nIndex) const
Call this function to get a child view at a particular index.
CXTPChartElementView * | GetParentView () const
Call this function to get the parent view.
CXTPChartElementView * | AddChildView (CXTPChartElementView *pChildView)
Call this function to add a child view to the current view.
CXTPChartElementView ** GetChildren ()
Provides access to the collection of children elements owned by the view.
CRect | GetBounds () const
Obtains viewed object's bound rectangle.
CRect | GetBounds (BOOL bIncludingChildren) const
Obtains viewed object's bound rectangle.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.
- Public Member Functions inherited from CXTPChartLegendItemView
virtual | ~CXTPChartLegendItemView ()
Handles object destruction.

Protected Member Functions

CXTPChartPieSeriesPointViewBase (CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Constructs a CXTPChartPieSeriesPointViewBase object.
CXTPChartPieSeriesPointViewBase (CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView, BOOL bAddToParent)
Constructs a CXTPChartPieSeriesPointViewBase object.
- Protected Member Functions inherited from CXTPChartElementView
virtual ~CXTPChartElementView ()
Destroys a CXTPChartElementView object, handles cleanup.
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.

Additional Inherited Members

- Public Attributes inherited from CXTPChartSeriesPointView
double | m_dInternalValue
Point internal value.
- Protected Attributes inherited from CXTPChartSeriesPointView
CXTPChartSeriesPoint * | m_pPoint
Point model object pointer.
- Protected Attributes inherited from CXTPChartElementView
CArray< CXTPChartElementView *, CXTPChartElementView * > | m_arrChildren
The child view collection.
CXTPChartElementView * | m_pParentView
The parent view.
CXTPChartContainer * | m_pContainer
The parent container.
CRect | m_rcBounds
Bounding rectangle.

Detailed Description

This class abstracts the view of a pie series point.

This class is a kind of CXTPChartSeriesPointView.

A pie chart (or a circle graph) is a circular chart divided into sectors, illustrating percents. In a pie chart, the arc length of each sector (and consequently its central angle and area), is proportional to the quantity it represents. Together, the sectors create a full disk.

Constructor & Destructor Documentation

◆ CXTPChartPieSeriesPointViewBase() [1/2]

CXTPChartPieSeriesPointViewBase | ( | CXTPChartSeriesPoint * | pPoint,
 |  | CXTPChartElementView * | pParentView )
 protected

Constructs a CXTPChartPieSeriesPointViewBase object.

Parameters
pPoint | Pointer to the chart series point.
pParentView | Pointer to the parent view object.

◆ CXTPChartPieSeriesPointViewBase() [2/2]

CXTPChartPieSeriesPointViewBase | ( | CXTPChartSeriesPoint * | pPoint,
 |  | CXTPChartElementView * | pParentView,
 |  | BOOL | bAddToParent )
 protected

Constructs a CXTPChartPieSeriesPointViewBase object.

Parameters
pPoint | Pointer to the chart series point.
pParentView | Pointer to the parent view object.
bAddToParent | If TRUE the view will be be added to parent's child view list.

Member Function Documentation

◆ CalculateLayout()

virtual void CalculateLayout ( double & dAngle )
pure virtual

Use this function to calculate the layout of the pie series point.

Parameters
dAngle The swipe angle of the sector(pie).

Implemented in CXTPChart3dPieSeriesPointView, and CXTPChartPieSeriesPointView.

◆ CreateDeviceCommand()

virtual CXTPChartDeviceCommand * CreateDeviceCommand ( CXTPChartDeviceContext * pDC )
pure virtual

This function creates a CXTPChartDeviceCommand object.

This object represents the rendering of the pie series point.

Parameters
pDC Pointer to a CXTPChartDeviceContext object.
Returns
Returns a CXTPChartDeviceCommand object. This object handles the rendering of an element in the chart. Here it handles the drawing of the pie series point.

Reimplemented from CXTPChartElementView.

Implemented in CXTPChart3dPieSeriesPointView, and CXTPChartPieSeriesPointView.

◆ CreateLegendDeviceCommand()

virtual CXTPChartDeviceCommand * CreateLegendDeviceCommand | ( | CXTPChartDeviceContext * | pDC,
 |  | CRect | rcBounds )
 pure virtual

This function creates a label view drawing command object.

Parameters
pDC | Pointer to a CXTPChartDeviceContext object.
rcBounds | The rectangular boundary of the legend.
Returns
Returns a new label view drawing command object.

Reimplemented from CXTPChartSeriesPointView.

Implemented in CXTPChart3dPieSeriesPointView, and CXTPChartPieSeriesPointView.

◆ GetBasePoint()

AFX_INLINE CXTPChartPointF GetBasePoint ( ) const

Use this function to obtain the base point value.

Returns
The base point value.

◆ GetPie()

AFX_INLINE CXTPChartPieBase * GetPie ( ) const

Use this function to get the pie for the point.

Returns
A pointer CXTPChartPieBase object which represents a pie.
The documentation for this class was generated from the following file:
  • XTPChartPieSeriesPointViewBase.h


Toolkit Pro: CXTPChartPieSeriesStyle Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPChartPieSeriesStyle Class Reference

This class abstracts the pie series style. More...

Inheritance diagram for CXTPChartPieSeriesStyle:
[legend]

Public Member Functions

CXTPChartPieSeriesStyle ()
Constructs a CXTPChartPieSeriesStyle object.
- Public Member Functions inherited from CXTPChartPieSeriesStyleBase
int | GetHolePercent () const
Call this function to get the hole percent of the pie chart.
void | SetHolePercent (int nHolePercent)
Call this function to set the hole percent of the pie chart.
int | GetExplodedDistancePercent () const
Call this function to get the exploded distance percent of the pie chart.
void | SetExplodedDistancePercent (int nExplodedDistancePercent)
Call this function to set the exploded distance percent of the pie chart.
int | GetRotation () const
Call this function to get the rotation of the sectors of the pie chart.
void | SetRotation (int nRotation)
Call this function to set the rotation of the sectors of the pie chart.
virtual int | GetDepth () const
Call this function to get the depth of 3D pie chart.
void | DoPropExchange (CXTPPropExchange *pPX)
Call this member function to Store/Load an event using the specified data object.
CXTPChartBorder * | GetBorder () const
Obtains border object pointer.
CXTPChartColor | GetBorderActualColor () const
Obtains border color.
- Public Member Functions inherited from CXTPChartSeriesStyle
CXTPChartSeriesStyle ()
Constructs a CXTPChartSeriesStyle object.
virtual | ~CXTPChartSeriesStyle ()
Destroys a CXTPChartSeriesStyle object, handles cleanup.
virtual CXTPChartSeriesLabel * | GetLabel () const
Call this method to gets the series label object.
virtual CXTPChartSeriesLabel * | SetLabel (CXTPChartSeriesLabel *pLabel)
Call this method to sets the series label object.
virtual CXTPChartErrorBar * | GetErrorBar () const
Call this method to gets the error bar object.
virtual CXTPChartErrorBar * | SetErrorBar (CXTPChartErrorBar *pErrorBar)
Call this method to sets the error bar object.
virtual CXTPChartColor | GetColor () const
Call this method to get the color of the series.
virtual void | SetColor (CXTPChartColor clr)
Call this method to set the color of the series.
virtual void | SetColorEach (BOOL bColorEach)
Call this method to set individual color for each point of the series.
virtual BOOL | IsColorEach () const
This method is called to check if individual color is used for each point of the series.
virtual CXTPChart3dRotation | Get3dRotation () const
Obtains rotation parameters for 3D chart.
virtual void | Set3dRotation (const CXTPChart3dRotation &rotation)
Sets rotation parameters for 3D chart.
virtual void | Set3dRotation (double dYaw, double dPitch, double dRoll)
Sets rotation parameters for 3D chart.
virtual BOOL | Is3dEdgeSmoothingEnabled () const
Enables/disables 3D edge smoothing.
virtual void | Enable3dEdgeSmoothing (BOOL bEnable=TRUE)
Enables/disables 3D edge smoothing.
virtual int | GetTransparency () const
Call this function to gets the transparency of the chart if it is supported by the chart type.
virtual void | SetTransparency (int nTransparency)
Call this function to sets the transparency of the chart if it is supported by the chart type.
virtual void | CorrectAxisSideMargins (CXTPChartAxis *pAxis, double nMinValue, double nMaxValue, double &nCorrection)
Provides default implementation for axis side margins correction.
virtual CXTPChartSeriesStyleAppearance * | GetStyleAppearance () const
Obtains associated style appearance pointer.
virtual void | ApplyTo (CXTPChartDeviceCommand *pCommand)
Applies the style to the command provided in case the command needs style specific details for correct drawing.
virtual int | GetSeriesPointValueIndex () const
Obtains the index of a point element for which an internal value can be otained.
- Public Member Functions inherited from CXTPChartElement
CXTPChartElement ()
Constructs a CXTPChartElement object.
virtual | ~CXTPChartElement ()
Destroys a CXTPChartElement object, handles cleanup.
virtual void | Release ()
Call this function to decrease the usage count of the object.
CXTPChartElement * | GetOwner () const
Call this function to get the owner element.
virtual void | OnChartChanged (XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic properties of the chart.
CXTPChartContent * | GetContent () const
Call this virtual function to get the chart content object.
CXTPChartAppearance * | GetAppearance () const
Call this function to get the the appearance of the chart.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Protected Member Functions

virtual CXTPChartDiagram * | CreateDiagram ()
Call this function to create the pie diagram object.
virtual CXTPChartSeriesView * | CreateView (CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Call this function to create the view of the pie series.
- Protected Member Functions inherited from CXTPChartPieSeriesStyleBase
CXTPChartPieSeriesStyleBase ()
Constructs a CXTPChartPieSeriesStyleBase object.
virtual | ~CXTPChartPieSeriesStyleBase ()
Destroys a CXTPChartPieSeriesStyleBase object, handle cleanup.
virtual BOOL | IsStyleDiagram (CXTPChartDiagram *pDiagram) const
Call this function to check whether chart diagram object passed is a kind of CXTPChart2dPieDiagramBase/CXTPChart3dPieDiagramBase.
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.

Additional Inherited Members

- Public Attributes inherited from CXTPChartElement
- Protected Attributes inherited from CXTPChartPieSeriesStyleBase
int | m_nHolePercent
The hole percentage.
int | m_nExplodedDistancePercent
The exploded distance percentage.
int | m_nRotation
The sector rotation angle.
CXTPChartBorder * | m_pBorder
Associated border information.
- Protected Attributes inherited from CXTPChartSeriesStyle
CXTPChartSeriesLabel * | m_pLabel
Label object.
CXTPChartErrorBar * | m_pErrorBar
Error bar object.
CXTPChartColor | m_clrColor
Custom color of series.
BOOL | m_bColorEach
TRUE to color each point.
int | m_nTransparency
The transparency value in the range 0..255.
CXTPChart3dRotation | m_Rotation3d
3D rotation
BOOL | m_bSmooth3dEdges
3D edge smoothing
- Protected Attributes inherited from CXTPChartElement

Detailed Description

This class abstracts the pie series style.

This class is a kind of CXTPChartPieSeriesStyleBase.

A pie chart (or a circle graph) is a circular chart divided into sectors, illustrating percents. In a pie chart, the arc length of each sector (and consequently its central angle and area), is proportional to the quantity it represents. Together, the sectors create a full disk.

Member Function Documentation

◆ CreateDiagram()

virtual CXTPChartDiagram * CreateDiagram ( )
protectedvirtual

Call this function to create the pie diagram object.

Returns
A pointer to a CXTPChartDiagram object which points to the newly created CXTPChart2dPieDiagramBase object.

Implements CXTPChartPieSeriesStyleBase.

◆ CreateView()

virtual CXTPChartSeriesView * CreateView | ( | CXTPChartSeries * | pSeries,
 |  | CXTPChartDiagramView * | pDiagramView )
 protectedvirtual

Call this function to create the view of the pie series.

Parameters
pSeries | A pointer to the chart series object.
pDiagramView | A pointer to the diagram view object.
Returns
Returns a pointer to the associated series view object.

Implements CXTPChartPieSeriesStyleBase.

The documentation for this class was generated from the following file:
  • XTPChart2dPieSeriesStyle.h


Toolkit Pro: CXTPChartPieSeriesStyleBase Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPChartPieSeriesStyleBase Class Referenceabstract

This class abstracts the basic style of a pie serie.This class is a kind of CXTPChartSeriesStyle. More...

Inheritance diagram for CXTPChartPieSeriesStyleBase:
[legend]

Public Member Functions

int | GetHolePercent () const
Call this function to get the hole percent of the pie chart.
void | SetHolePercent (int nHolePercent)
Call this function to set the hole percent of the pie chart.
int | GetExplodedDistancePercent () const
Call this function to get the exploded distance percent of the pie chart.
void | SetExplodedDistancePercent (int nExplodedDistancePercent)
Call this function to set the exploded distance percent of the pie chart.
int | GetRotation () const
Call this function to get the rotation of the sectors of the pie chart.
void | SetRotation (int nRotation)
Call this function to set the rotation of the sectors of the pie chart.
virtual int | GetDepth () const
Call this function to get the depth of 3D pie chart.
void | DoPropExchange (CXTPPropExchange *pPX)
Call this member function to Store/Load an event using the specified data object.
CXTPChartBorder * | GetBorder () const
Obtains border object pointer.
CXTPChartColor | GetBorderActualColor () const
Obtains border color.
- Public Member Functions inherited from CXTPChartSeriesStyle
CXTPChartSeriesStyle ()
Constructs a CXTPChartSeriesStyle object.
virtual | ~CXTPChartSeriesStyle ()
Destroys a CXTPChartSeriesStyle object, handles cleanup.
virtual CXTPChartSeriesLabel * | GetLabel () const
Call this method to gets the series label object.
virtual CXTPChartSeriesLabel * | SetLabel (CXTPChartSeriesLabel *pLabel)
Call this method to sets the series label object.
virtual CXTPChartErrorBar * | GetErrorBar () const
Call this method to gets the error bar object.
virtual CXTPChartErrorBar * | SetErrorBar (CXTPChartErrorBar *pErrorBar)
Call this method to sets the error bar object.
virtual CXTPChartColor | GetColor () const
Call this method to get the color of the series.
virtual void | SetColor (CXTPChartColor clr)
Call this method to set the color of the series.
virtual void | SetColorEach (BOOL bColorEach)
Call this method to set individual color for each point of the series.
virtual BOOL | IsColorEach () const
This method is called to check if individual color is used for each point of the series.
virtual CXTPChart3dRotation | Get3dRotation () const
Obtains rotation parameters for 3D chart.
virtual void | Set3dRotation (const CXTPChart3dRotation &rotation)
Sets rotation parameters for 3D chart.
virtual void | Set3dRotation (double dYaw, double dPitch, double dRoll)
Sets rotation parameters for 3D chart.
virtual BOOL | Is3dEdgeSmoothingEnabled () const
Enables/disables 3D edge smoothing.
virtual void | Enable3dEdgeSmoothing (BOOL bEnable=TRUE)
Enables/disables 3D edge smoothing.
virtual int | GetTransparency () const
Call this function to gets the transparency of the chart if it is supported by the chart type.
virtual void | SetTransparency (int nTransparency)
Call this function to sets the transparency of the chart if it is supported by the chart type.
virtual void | CorrectAxisSideMargins (CXTPChartAxis *pAxis, double nMinValue, double nMaxValue, double &nCorrection)
Provides default implementation for axis side margins correction.
virtual CXTPChartSeriesStyleAppearance * | GetStyleAppearance () const
Obtains associated style appearance pointer.
virtual void | ApplyTo (CXTPChartDeviceCommand *pCommand)
Applies the style to the command provided in case the command needs style specific details for correct drawing.
virtual int | GetSeriesPointValueIndex () const
Obtains the index of a point element for which an internal value can be otained.
- Public Member Functions inherited from CXTPChartElement
CXTPChartElement ()
Constructs a CXTPChartElement object.
virtual | ~CXTPChartElement ()
Destroys a CXTPChartElement object, handles cleanup.
virtual void | Release ()
Call this function to decrease the usage count of the object.
CXTPChartElement * | GetOwner () const
Call this function to get the owner element.
virtual void | OnChartChanged (XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic properties of the chart.
CXTPChartContent * | GetContent () const
Call this virtual function to get the chart content object.
CXTPChartAppearance * | GetAppearance () const
Call this function to get the the appearance of the chart.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Protected Member Functions

CXTPChartPieSeriesStyleBase ()
Constructs a CXTPChartPieSeriesStyleBase object.
virtual | ~CXTPChartPieSeriesStyleBase ()
Destroys a CXTPChartPieSeriesStyleBase object, handle cleanup.
virtual CXTPChartDiagram * | CreateDiagram ()=0
Call this function to create the pie diagram object.
virtual CXTPChartSeriesView * | CreateView (CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)=0
Call this function to create the view of the pie series.
virtual BOOL | IsStyleDiagram (CXTPChartDiagram *pDiagram) const
Call this function to check whether chart diagram object passed is a kind of CXTPChart2dPieDiagramBase/CXTPChart3dPieDiagramBase.
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.

Protected Attributes

int | m_nHolePercent
The hole percentage.
int | m_nExplodedDistancePercent
The exploded distance percentage.
int | m_nRotation
The sector rotation angle.
CXTPChartBorder * | m_pBorder
Associated border information.
- Protected Attributes inherited from CXTPChartSeriesStyle
CXTPChartSeriesLabel * | m_pLabel
Label object.
CXTPChartErrorBar * | m_pErrorBar
Error bar object.
CXTPChartColor | m_clrColor
Custom color of series.
BOOL | m_bColorEach
TRUE to color each point.
int | m_nTransparency
The transparency value in the range 0..255.
CXTPChart3dRotation | m_Rotation3d
3D rotation
BOOL | m_bSmooth3dEdges
3D edge smoothing
- Protected Attributes inherited from CXTPChartElement

Detailed Description

This class abstracts the basic style of a pie serie.This class is a kind of CXTPChartSeriesStyle.

A pie chart (or a circle graph) is a circular chart divided into sectors, illustrating percents. In a pie chart, the arc length of each sector (and consequently its central angle and area), is proportional to the quantity it represents. Together, the sectors create a full disk.

Member Function Documentation

◆ CreateDiagram()

virtual CXTPChartDiagram * CreateDiagram ( )
protectedpure virtual

Call this function to create the pie diagram object.

Returns
A pointer to CXTPChartDiagram object which points to a newly created CXTPChart2dPieDiagramBase/CXTPChart3dPieDiagramBase object.

Reimplemented from CXTPChartSeriesStyle.

Implemented in CXTPChart3dPieSeriesStyle, and CXTPChartPieSeriesStyle.

◆ CreateView()

virtual CXTPChartSeriesView * CreateView | ( | CXTPChartSeries * | pSeries,
 |  | CXTPChartDiagramView * | pDiagramView )
 protectedpure virtual

Call this function to create the view of the pie series.

Parameters
pSeries | A pointer to chart series object.
pDiagramView | A pointer to the diagram view object.
Returns
A pointer to CXTPChartSeriesView object which points to a newly created CXTPChartPieSeriesViewBase object.

Implements CXTPChartSeriesStyle.

Implemented in CXTPChart3dPieSeriesStyle, and CXTPChartPieSeriesStyle.

◆ DoPropExchange()

void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Call this member function to Store/Load an event using the specified data object.

Parameters
pPX Source or destination CXTPPropExchange data object reference.

This member function is used to store or load event data to or from a storage.

Reimplemented from CXTPChartSeriesStyle.

◆ GetBorder()

AFX_INLINE CXTPChartBorder * GetBorder ( ) const

Obtains border object pointer.

Returns
Associated border object pointer.

◆ GetBorderActualColor()

CXTPChartColor GetBorderActualColor ( ) const

Obtains border color.

Returns
Border color value.

◆ GetDepth()

virtual int GetDepth ( ) const
virtual

Call this function to get the depth of 3D pie chart.

Returns
An integer value specifying the depth of 3D pie chart.

Reimplemented in CXTPChart3dPieSeriesStyle.

◆ GetExplodedDistancePercent()

AFX_INLINE int GetExplodedDistancePercent ( ) const

Call this function to get the exploded distance percent of the pie chart.

Returns
An integer value specifying the hole percentage.

A chart with one or more sectors separated from the rest of the disk is known as an exploded pie chart.

◆ GetHolePercent()

AFX_INLINE int GetHolePercent ( ) const

Call this function to get the hole percent of the pie chart.

Returns
An integer value specifying the hole percentage.

◆ GetRotation()

AFX_INLINE int GetRotation ( ) const

Call this function to get the rotation of the sectors of the pie chart.

Returns
An integer value specifying the rotation angle in degree.

◆ IsStyleDiagram()

virtual BOOL IsStyleDiagram ( CXTPChartDiagram * pDiagram ) const
protectedvirtual

Call this function to check whether chart diagram object passed is a kind of CXTPChart2dPieDiagramBase/CXTPChart3dPieDiagramBase.

Parameters
pDiagram A pointer to a chart diagram, whose type is to be identified.
Returns
TRUE if the chart diagram is a pie diagram and FALSE if not.

Reimplemented from CXTPChartSeriesStyle.

◆ SetExplodedDistancePercent()

AFX_INLINE void SetExplodedDistancePercent ( int nExplodedDistancePercent )

Call this function to set the exploded distance percent of the pie chart.

Parameters
nExplodedDistancePercent An integer value specifying the exploded distance percentage.

A chart with one or more sectors separated from the rest of the disk is known as an exploded pie chart.

◆ SetHolePercent()

AFX_INLINE void SetHolePercent ( int nHolePercent )

Call this function to set the hole percent of the pie chart.

Parameters
nHolePercent An integer value specifying the hole percentage.

◆ SetRotation()

AFX_INLINE void SetRotation ( int nRotation )

Call this function to set the rotation of the sectors of the pie chart.

Parameters
nRotation An integer value specifying the rotation angle in degree.
The documentation for this class was generated from the following file:
  • XTPChartPieSeriesStyleBase.h


Toolkit Pro: CXTPChartPieSeriesView Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPChartPieSeriesView Class Reference

This class abstracts the view of a pie series. More...

Inheritance diagram for CXTPChartPieSeriesView:
[legend]

Public Member Functions

CXTPChartPieSeriesView (CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Constructs a CXTPChartPieSeriesView object.
virtual void | CalculatePointLayout (CXTPChartDeviceContext *pDC, CRect rcBounds)
Call this function to calculate the pie series point layout.
- Public Member Functions inherited from CXTPChartPieSeriesViewBase
virtual | ~CXTPChartPieSeriesViewBase ()
Destroys a CXTPChartPieSeriesViewBase object, handle cleanup.
virtual void | CalculateLabelLayout (CXTPChartDeviceContext *pDC)
Call this function to calculate the pie series label layout.
virtual CXTPChartDiagramDomain * | CreateDiagramDomain (CXTPChartDeviceContext *pDC, CRect rcBounds)
Call this function to create the pie diagram domain object associated with this object.
CXTPChartRectF | GetInnerBounds () const
Call this function to get the inner bounds of the diagram.
CXTPChartDiagramDomain * | GetDomain () const
Use this function to get the pie diagram domain object associated with this object.
int | GetMaxLabelWidth () const
Obtains maximum allowed label width.

Protected Member Functions

virtual CXTPChartSeriesPointView * | CreateSeriesPointView (CXTPChartDeviceContext *pDC, CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Use this function to create the pie series point view object.
virtual CXTPChartDeviceCommand * | CreateDeviceCommand (CXTPChartDeviceContext *pDC)
This function creates a view drawing command object.
virtual CXTPChartDeviceCommand * | CreateLegendDeviceCommand (CXTPChartDeviceContext *pDC, CRect rcBounds)
This function creates a label view drawing command object.
- Protected Member Functions inherited from CXTPChartPieSeriesViewBase
CXTPChartPieSeriesViewBase (CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Constructs a CXTPChartPieSeriesViewBase object.

Detailed Description

This class abstracts the view of a pie series.

This class is a kind of CXTPChartSeriesView.

A pie chart (or a circle graph) is a circular chart divided into sectors, illustrating percents. In a pie chart, the arc length of each sector (and consequently its central angle and area), is proportional to the quantity it represents. Together, the sectors create a full disk.

Constructor & Destructor Documentation

◆ CXTPChartPieSeriesView()

CXTPChartPieSeriesView | ( | CXTPChartSeries * | pSeries,
 |  | CXTPChartDiagramView * | pDiagramView )

Constructs a CXTPChartPieSeriesView object.

Parameters
pSeries | Pointer to the pie series object.
pDiagramView | Pointer to the pie diagram view.

Member Function Documentation

◆ CalculatePointLayout()

virtual void CalculatePointLayout | ( | CXTPChartDeviceContext * | pDC,
 |  | CRect | rcBounds )
 virtual

Call this function to calculate the pie series point layout.

Parameters
pDC | Pointer to the chart device context.
rcBounds | The rectangular boundary.

Implements CXTPChartPieSeriesViewBase.

◆ CreateDeviceCommand()

virtual CXTPChartDeviceCommand * CreateDeviceCommand ( CXTPChartDeviceContext * pDC )
protectedvirtual

This function creates a view drawing command object.

This object represents the rendering of the pie series.

Parameters
pDC Pointer to a CXTPChartDeviceContext object.
Returns
Returns a CXTPChartDeviceCommand object. This object handles the rendering of an element in the chart. Here it handles the drawing of the pie series.

Implements CXTPChartPieSeriesViewBase.

◆ CreateLegendDeviceCommand()

virtual CXTPChartDeviceCommand * CreateLegendDeviceCommand | ( | CXTPChartDeviceContext * | pDC,
 |  | CRect | rcBounds )
 protectedvirtual

This function creates a label view drawing command object.

Parameters
pDC | Pointer to a CXTPChartDeviceContext object.
rcBounds | The rectangular boundary of the legend.
Returns
Returns a new label view drawing command object.

Implements CXTPChartPieSeriesViewBase.

◆ CreateSeriesPointView()

virtual CXTPChartSeriesPointView * CreateSeriesPointView | ( | CXTPChartDeviceContext * | pDC,
 |  | CXTPChartSeriesPoint * | pPoint,
 |  | CXTPChartElementView * | pParentView )
 protectedvirtual

Use this function to create the pie series point view object.

Parameters
pDC | Pointer to the chart device context.
pPoint | Pointer to the chart series point.
pParentView | The pointer to the parent view object.
Returns
A pointer to the chart series point view.

Implements CXTPChartPieSeriesViewBase.

The documentation for this class was generated from the following file:
  • XTPChart2dPieSeriesView.h


Toolkit Pro: CXTPChartPieSeriesViewBase Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPChartPieSeriesViewBase Class Referenceabstract

This class abstracts the view of a pie series. More...

Inheritance diagram for CXTPChartPieSeriesViewBase:
[legend]

Public Member Functions

virtual | ~CXTPChartPieSeriesViewBase ()
Destroys a CXTPChartPieSeriesViewBase object, handle cleanup.
virtual void | CalculatePointLayout (CXTPChartDeviceContext *pDC, CRect rcBounds)=0
Call this function to calculate the pie series point layout.
virtual void | CalculateLabelLayout (CXTPChartDeviceContext *pDC)
Call this function to calculate the pie series label layout.
virtual CXTPChartDiagramDomain * | CreateDiagramDomain (CXTPChartDeviceContext *pDC, CRect rcBounds)
Call this function to create the pie diagram domain object associated with this object.
CXTPChartRectF | GetInnerBounds () const
Call this function to get the inner bounds of the diagram.
CXTPChartDiagramDomain * | GetDomain () const
Use this function to get the pie diagram domain object associated with this object.
int | GetMaxLabelWidth () const
Obtains maximum allowed label width.

Protected Member Functions

CXTPChartPieSeriesViewBase (CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Constructs a CXTPChartPieSeriesViewBase object.
virtual CXTPChartSeriesPointView * | CreateSeriesPointView (CXTPChartDeviceContext *pDC, CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)=0
Use this function to create the pie series point view object.
virtual CXTPChartDeviceCommand * | CreateDeviceCommand (CXTPChartDeviceContext *pDC)=0
This function creates a CXTPChartDeviceCommand object.
virtual CXTPChartDeviceCommand * | CreateLegendDeviceCommand (CXTPChartDeviceContext *pDC, CRect rcBounds)=0
This function creates a label view drawing command object.

Detailed Description

This class abstracts the view of a pie series.

This class is a kind of CXTPChartSeriesView.

A pie chart (or a circle graph) is a circular chart divided into sectors, illustrating percents. In a pie chart, the arc length of each sector (and consequently its central angle and area), is proportional to the quantity it represents. Together, the sectors create a full disk.

Constructor & Destructor Documentation

◆ CXTPChartPieSeriesViewBase()

CXTPChartPieSeriesViewBase | ( | CXTPChartSeries * | pSeries,
 |  | CXTPChartDiagramView * | pDiagramView )
 protected

Constructs a CXTPChartPieSeriesViewBase object.

Parameters
pSeries | Pointer to pie series object.
pDiagramView | Pointer to the pie diagram view.

Member Function Documentation

◆ CalculateLabelLayout()

virtual void CalculateLabelLayout ( CXTPChartDeviceContext * pDC )
virtual

Call this function to calculate the pie series label layout.

Parameters
pDC Pointer to the chart device context.

◆ CalculatePointLayout()

virtual void CalculatePointLayout | ( | CXTPChartDeviceContext * | pDC,
 |  | CRect | rcBounds )
 pure virtual

Call this function to calculate the pie series point layout.

Parameters
pDC | Pointer to the chart device context.
rcBounds | The rectangular boundary.

Implemented in CXTPChart3dPieSeriesView, and CXTPChartPieSeriesView.

◆ CreateDeviceCommand()

virtual CXTPChartDeviceCommand * CreateDeviceCommand ( CXTPChartDeviceContext * pDC )
protectedpure virtual

This function creates a CXTPChartDeviceCommand object.

This object represents the rendering of the pie series.

Parameters
pDC Pointer to a CXTPChartDeviceContext object.
Returns
Returns a CXTPChartDeviceCommand object. This object handles the rendering of an element in the chart. Here it handles the drawing of the pie series.

Reimplemented from CXTPChartElementView.

Implemented in CXTPChart3dPieSeriesView, and CXTPChartPieSeriesView.

◆ CreateDiagramDomain()

virtual CXTPChartDiagramDomain * CreateDiagramDomain | ( | CXTPChartDeviceContext * | pDC,
 |  | CRect | rcBounds )
 virtual

Call this function to create the pie diagram domain object associated with this object.

Parameters
rcBounds | The rectangular boundary of the diagram.
pDC | Pointer to the chart device context.
Returns
A pointer to the chart diagram domain object.

◆ CreateLegendDeviceCommand()

virtual CXTPChartDeviceCommand * CreateLegendDeviceCommand | ( | CXTPChartDeviceContext * | pDC,
 |  | CRect | rcBounds )
 protectedpure virtual

This function creates a label view drawing command object.

Parameters
pDC | Pointer to a CXTPChartDeviceContext object.
rcBounds | The rectangular boundary of the legend.
Returns
Returns a new label view drawing command object.

Implements CXTPChartLegendItemView.

Implemented in CXTPChart3dPieSeriesView, and CXTPChartPieSeriesView.

◆ CreateSeriesPointView()

virtual CXTPChartSeriesPointView * CreateSeriesPointView | ( | CXTPChartDeviceContext * | pDC,
 |  | CXTPChartSeriesPoint * | pPoint,
 |  | CXTPChartElementView * | pParentView )
 protectedpure virtual

Use this function to create the pie series point view object.

Parameters
pDC | Pointer to chart device context.
pPoint | Pointer to chart series point.
pParentView | Parent view pointer.
Returns
A pointer to the chart series point view.

Implemented in CXTPChart3dPieSeriesView, and CXTPChartPieSeriesView.

◆ GetDomain()

AFX_INLINE CXTPChartDiagramDomain * GetDomain ( ) const

Use this function to get the pie diagram domain object associated with this object.

Returns
A pointer to the chart diagram domain object.

◆ GetInnerBounds()

CXTPChartRectF GetInnerBounds ( ) const

Call this function to get the inner bounds of the diagram.

Returns
A chart rect object denoting the rectangular boundary.

◆ GetMaxLabelWidth()

AFX_INLINE int GetMaxLabelWidth ( ) const

Obtains maximum allowed label width.

Returns
Maximum allowed label width.
The documentation for this class was generated from the following file:
  • XTPChartPieSeriesViewBase.h


Toolkit Pro: CXTPChartPieStyleAppearance Class Reference

Public Member Functions | Public Attributes | List of all members
CXTPChartPieStyleAppearance Class Reference

This class represents the pie series appearance of the chart. More...

Public Member Functions

CXTPChartPieStyleAppearance (CXTPChartElement *pOwner)
Constructs a CXTPChartPieStyleAppearance object.
virtual | ~CXTPChartPieStyleAppearance ()
Destroys a CXTPChartPieStyleAppearance object, handles cleanup.
void | DoPropExchange (CXTPPropExchange *pPX)
Call this member function to Store/Load the properties related to the appearance of a diagram in 2D, using the specified data object.

Public Attributes

CXTPChartColor BorderColor
Border color.

Detailed Description

This class represents the pie series appearance of the chart.

Chart appearance determined by the 2D digram appearance, chart content appearance and the color palette used.

Constructor & Destructor Documentation

◆ CXTPChartPieStyleAppearance()

CXTPChartPieStyleAppearance ( CXTPChartElement * pOwner )

Constructs a CXTPChartPieStyleAppearance object.

Parameters
pOwner Pointer to an owner element.

Member Function Documentation

◆ DoPropExchange()

void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Call this member function to Store/Load the properties related to the appearance of a diagram in 2D, using the specified data object.

Parameters
pPX Source or destination CXTPPropExchange data object reference.

This member function is used to store or load property data to or from a storage.

Reimplemented from CXTPChartElement.

The documentation for this class was generated from the following file:
  • XTPChartAppearance.h


Toolkit Pro: CXTPChartPointSeriesErrorBarView Class Reference

Public Member Functions | List of all members
CXTPChartPointSeriesErrorBarView Class Reference

This class abstracts the view of the label of a bar series. More...

Public Member Functions

CXTPChartPointSeriesErrorBarView (CXTPChartErrorBar *pErrorBar, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView)
Constructs a CXTPChartPointSeriesErrorBarView object.

Detailed Description

This class abstracts the view of the label of a bar series.

It is a kind of point series label view.

Constructor & Destructor Documentation

◆ CXTPChartPointSeriesErrorBarView()

CXTPChartPointSeriesErrorBarView | ( | CXTPChartErrorBar * | pErrorBar,
 |  | CXTPChartSeriesPointView * | pPointView,
 |  | CXTPChartElementView * | pParentView )

Constructs a CXTPChartPointSeriesErrorBarView object.

Parameters
pErrorBar | Pointer to the error bar object.
pPointView | Pointer to chart series point view.
pParentView | Parent view pointer.
The documentation for this class was generated from the following file:
  • XTPChartPointSeriesErrorBar.h


Toolkit Pro: CXTPChartPointSeriesLabel Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPChartPointSeriesLabel Class Reference

This class abstracts the label of a point series. More...

Inheritance diagram for CXTPChartPointSeriesLabel:
[legend]

Public Member Functions

CXTPChartPointSeriesLabel ()
Constructs a CXTPChartPointSeriesLabel object.
virtual | ~CXTPChartPointSeriesLabel ()
Destroys a CXTPChartPointSeriesLabel object, handles cleanup.
void | SetAngle (int nAngle)
Call this function to set the angle of the label stem.
int | GetAngle () const
Call this function to get the angle of the label stem.
void | DoPropExchange (CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
virtual CXTPChartElementView * | CreateView (CXTPChartDeviceContext *pDC, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView)
This function creates the view of the label.
- Public Member Functions inherited from CXTPChartDiagram2DSeriesLabel
CXTPChartDiagram2DSeriesLabel ()
Constructs a CXTPChartDiagram2DSeriesLabel object.
virtual | ~CXTPChartDiagram2DSeriesLabel ()
Destroys a CXTPChartDiagram2DSeriesLabel object, handles cleanup.
- Public Member Functions inherited from CXTPChartSeriesLabel
CXTPChartSeriesLabel ()
Constructs a CXTPChartSeriesLabel object.
virtual | ~CXTPChartSeriesLabel ()
Destroys a CXTPChartSeriesLabel object, handles cleanup.
void | SetTextColor (const CXTPChartColor &clrTextColor)
Call this function to set the text color of the label.
CXTPChartColor | GetTextColor () const
Call this function to get the apparent text color of the label.
CXTPChartFont * | GetFont () const
Call this function to get the font of the text label.
void | SetFont (CXTPChartFont *pFont)
Call this function to set the font of the text label.
void | SetShowLines (BOOL bShowLines)
Call this function to set the lines visibility.
BOOL | GetShowLines () const
Call this function to check if the lines are visible.
void | SetLineLength (int nLineLength)
Call this function to set the line length.
int | GetLineLength () const
Call this function to get the line length.
void | SetVisible (BOOL bVisible)
Call this function to set the label visibility.
BOOL | IsVisible () const
Call this function to check if the label is visible.
void | SetAntialiasing (BOOL bAntialiasing)
Call this function to set anti-aliasing ON or OFF.
BOOL | GetAntialiasing () const
Call this function to check if anti-aliasing is ON or OFF.
CXTPChartNumberFormat * | GetFormat () const
Call this function to get a pointer to CXTPChartNumberFormat that specifies how to convert numbers to strings.
void | SetFormat (LPCTSTR lpszFormat)
Obsolete method.
void | SetBackColor (const CXTPChartColor &clrBackColor)
Call this function to set the text color of the label.
CXTPChartColor | GetBackColor () const
Call this function to get the apparent text color of the label.
void | SetLineColor (const CXTPChartColor &clrBackColor)
Call this function to set the text color of the label.
CXTPChartColor | GetLineColor () const
Call this function to get the apparent text color of the label.
int | GetTransparency () const
Call this function to get the transparency of the filled area with respect to the background.
void | SetTransparency (int nTransparency)
Call this function to set the transparency of the filled area with respect to the background.
- Public Member Functions inherited from CXTPChartTextElement
- Public Member Functions inherited from CXTPChartElement
CXTPChartElement ()
Constructs a CXTPChartElement object.
virtual | ~CXTPChartElement ()
Destroys a CXTPChartElement object, handles cleanup.
virtual void | Release ()
Call this function to decrease the usage count of the object.
CXTPChartElement * | GetOwner () const
Call this function to get the owner element.
virtual void | OnChartChanged (XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic properties of the chart.
CXTPChartContent * | GetContent () const
Call this virtual function to get the chart content object.
CXTPChartAppearance * | GetAppearance () const
Call this function to get the the appearance of the chart.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Protected Attributes

int | m_nAngle
The stem angle.
- Protected Attributes inherited from CXTPChartSeriesLabel
CXTPChartColor | m_clrTextColor
The text color.
CXTPChartColor | m_clrBackColor
The background color.
CXTPChartColor | m_clrLineColor
The line color.
BOOL | m_bVisible
TRUE if the label is visible and FALSE if not.
CXTPChartFont * | m_pFont
The font of the label.
BOOL | m_bAntialiasing
TRUE if antialiasing enabled, FALSE if not.
BOOL | m_bShowLines
TRUE if the lines are visible, FALSE if not.
int | m_nLineLength
The line length.
CXTPChartBorder * | m_pBorder
Chart border object.
int | m_nTransparency
The transparency values range from 0 to 255.
- Protected Attributes inherited from CXTPChartElement

Additional Inherited Members

- Public Attributes inherited from CXTPChartElement
- Protected Member Functions inherited from CXTPChartSeriesLabel
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.

Detailed Description

This class abstracts the label of a point series.

It is a kind of chart series label.

Member Function Documentation

◆ CreateView()

virtual CXTPChartElementView * CreateView | ( | CXTPChartDeviceContext * | pDC,
 |  | CXTPChartSeriesPointView * | pPointView,
 |  | CXTPChartElementView * | pParentView )
 virtual

This function creates the view of the label.

Parameters
pDC | The device context.
pPointView | A pointer to the series point view object.
pParentView | A pointer to the parent view object.
Returns
Returns a pointer to the associated label view object.

Reimplemented from CXTPChartSeriesLabel.

Reimplemented in CXTPChartRangeAreaSeriesLabel.

◆ DoPropExchange()

void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Reads this object from or writes this object to an archive.

Parameters
pPX A CXTPPropExchange object to serialize to or from.

Reimplemented from CXTPChartDiagram2DSeriesLabel.

Reimplemented in CXTPChartRangeAreaSeriesLabel.

◆ GetAngle()

AFX_INLINE int GetAngle ( ) const

Call this function to get the angle of the label stem.

Returns
An intger value denoting angle of the label stem.

◆ SetAngle()

AFX_INLINE void SetAngle ( int nAngle )

Call this function to set the angle of the label stem.

Parameters
nAngle The angle of the label stem.
The documentation for this class was generated from the following file:
  • XTPChartPointSeriesLabel.h


Toolkit Pro: CXTPChartPointSeriesLabelView Class Reference

Public Member Functions | List of all members
CXTPChartPointSeriesLabelView Class Reference

This class abstracts the view of the label of a point series. More...

Inheritance diagram for CXTPChartPointSeriesLabelView:
[legend]

Public Member Functions

CXTPChartPointSeriesLabelView (CXTPChartSeriesLabel *pLabel, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView)
Constructs a CXTPChartPointSeriesLabelView object.
virtual CXTPChartPointF | GetAnchorPoint () const
This function calculates the anchor point of the label stem.
- Public Member Functions inherited from CXTPChartDiagram2DSeriesLabelView
CXTPChartDiagram2DSeriesLabelView (CXTPChartSeriesLabel *pLabel, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView)
Constructs a CXTPChartDiagram2DSeriesLabelView object.
virtual CXTPChartDeviceCommand * | CreateDeviceCommand (CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
virtual CXTPChartDeviceCommand * | CreateDeviceCommand (CXTPChartDeviceContext *pDC, CXTPChartPointF ptCenterPoint)
This function creates a CXTPChartDeviceCommand object.
virtual CXTPChartDeviceCommand * | CreateDeviceCommand (CXTPChartDeviceContext *pDC, CXTPChartPointF ptCenterPoint, const CXTPChartString &text)
This function creates a CXTPChartDeviceCommand object.
virtual CXTPChartDeviceCommand * | CreateDeviceCommand (CXTPChartDeviceContext *pDC, const CXTPChartPointF &ptAnchorPoint, double dAnchorAngle, const CXTPChartString &text)
This function creates a CXTPChartDeviceCommand object.

Detailed Description

This class abstracts the view of the label of a point series.

It is a kind of chart series label view.

Constructor & Destructor Documentation

◆ CXTPChartPointSeriesLabelView()

CXTPChartPointSeriesLabelView | ( | CXTPChartSeriesLabel * | pLabel,
 |  | CXTPChartSeriesPointView * | pPointView,
 |  | CXTPChartElementView * | pParentView )

Constructs a CXTPChartPointSeriesLabelView object.

Parameters
pLabel | The pointer to chart series label object.
pPointView | A pointer to chart series view.
pParentView | Parent view pointer.

Member Function Documentation

◆ GetAnchorPoint()

virtual CXTPChartPointF GetAnchorPoint ( ) const
virtual

This function calculates the anchor point of the label stem.

Returns
A CXTPChartPointF object denoting the anchor point.

Reimplemented from CXTPChartDiagram2DSeriesLabelView.

Reimplemented in CXTPChartRangeAreaSeriesLabelView.

The documentation for this class was generated from the following file:
  • XTPChartPointSeriesLabelView.h


Toolkit Pro: CXTPChartPointSeriesPointView Class Reference

Public Member Functions | List of all members
CXTPChartPointSeriesPointView Class Reference

This class represents the view of a point series point, which is a kind of CXTPChartSeriesPointView. More...

Inheritance diagram for CXTPChartPointSeriesPointView:
[legend]

Public Member Functions

CXTPChartPointSeriesPointView (CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Constructs a CXTPChartPointSeriesPointView object.
virtual CXTPChartDeviceCommand * | CreateDeviceCommand (CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
virtual CXTPChartDeviceCommand * | CreateLegendDeviceCommand (CXTPChartDeviceContext *pDC, CRect rcBounds)
This function creates a label view drawing command object.
CXTPChartPointF | GetScreenPoint () const
Call this function to get the screen point from the series point.
- Public Member Functions inherited from CXTPChartSeriesPointView
CXTPChartSeriesPointView (CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Constructs the view object.
CXTPChartSeriesPointView (CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView, BOOL bAddToParent)
Constructs the view object.
CXTPChartSeriesPoint * | GetPoint () const
Obtains point model object.
CXTPChartSeriesView * | GetSeriesView () const
Obtains parent series view.
CXTPChartColor | GetColor () const
Obtain view color values.
CXTPChartColor | GetColor2 () const
Obtain view color values.
double | GetInternalValue () const
Obtains point interval value.
virtual CXTPChartString | GetLegendName () const
This function returns the legend name.
virtual void | UpdateMinMaxRange (double &nMinValue, double &nMaxValue) const
Provides a default empty implementation for min/max range update request.
- Public Member Functions inherited from CXTPChartElementView
CXTPChartElementView (CXTPChartElementView *pParentView)
Constructs a CXTPChartElementView object.
CXTPChartElementView (CXTPChartElementView *pParentView, BOOL bAddToParent)
Constructs a CXTPChartElementView object.
CXTPChartElementView (CXTPChartContainer *pContainer)
Constructs a CXTPChartElementView object.
int | GetCount () const
Call this function to get the number of child views associated with this view.
CXTPChartElementView * | GetAt (int nIndex) const
Call this function to get a child view at a particular index.
CXTPChartElementView * | GetParentView () const
Call this function to get the parent view.
CXTPChartElementView * | AddChildView (CXTPChartElementView *pChildView)
Call this function to add a child view to the current view.
CXTPChartElementView ** GetChildren ()
Provides access to the collection of children elements owned by the view.
CRect | GetBounds () const
Obtains viewed object's bound rectangle.
CRect | GetBounds (BOOL bIncludingChildren) const
Obtains viewed object's bound rectangle.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.
- Public Member Functions inherited from CXTPChartLegendItemView
virtual | ~CXTPChartLegendItemView ()
Handles object destruction.

Additional Inherited Members

- Public Attributes inherited from CXTPChartSeriesPointView
double | m_dInternalValue
Point internal value.
- Protected Member Functions inherited from CXTPChartElementView
virtual | ~CXTPChartElementView ()
Destroys a CXTPChartElementView object, handles cleanup.
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.
- Protected Attributes inherited from CXTPChartSeriesPointView
CXTPChartSeriesPoint * | m_pPoint
Point model object pointer.
- Protected Attributes inherited from CXTPChartElementView
CArray< CXTPChartElementView *, CXTPChartElementView * > | m_arrChildren
The child view collection.
CXTPChartElementView * | m_pParentView
The parent view.
CXTPChartContainer * | m_pContainer
The parent container.
CRect | m_rcBounds
Bounding rectangle.

Detailed Description

This class represents the view of a point series point, which is a kind of CXTPChartSeriesPointView.

Constructor & Destructor Documentation

◆ CXTPChartPointSeriesPointView()

CXTPChartPointSeriesPointView | ( | CXTPChartSeriesPoint * | pPoint,
 |  | CXTPChartElementView * | pParentView )

Constructs a CXTPChartPointSeriesPointView object.

Parameters
pPoint | A pointer to the chart series point.
pParentView | Parent view pointer.

Member Function Documentation

◆ CreateDeviceCommand()

virtual CXTPChartDeviceCommand * CreateDeviceCommand ( CXTPChartDeviceContext * pDC )
virtual

This function creates a CXTPChartDeviceCommand object.

This object represents the rendering of the series point.

Parameters
pDC Pointer to a CXTPChartDeviceContext object.
Returns
Returns a CXTPChartDeviceCommand object. This object handles the rendering of an element in the chart. Here it handles the drawing of the series point.

Reimplemented from CXTPChartElementView.

Reimplemented in CXTPChartBubbleSeriesPointView, and CXTPChartRangeSplineAreaSeriesPointView.

◆ CreateLegendDeviceCommand()

virtual CXTPChartDeviceCommand * CreateLegendDeviceCommand | ( | CXTPChartDeviceContext * | pDC,
 |  | CRect | rcBounds )
 virtual

This function creates a label view drawing command object.

Parameters
pDC | Pointer to a CXTPChartDeviceContext object.
rcBounds | The rectangular boundary of the legend.
Returns
Returns a new label view drawing command object.

Reimplemented from CXTPChartSeriesPointView.

Reimplemented in CXTPChartStepLineSeriesPointView.

◆ GetScreenPoint()

CXTPChartPointF GetScreenPoint ( ) const

Call this function to get the screen point from the series point.

Returns
Returns a screen point object CXTPChartPointF.
The documentation for this class was generated from the following file:
  • XTPChartPointSeriesView.h


Toolkit Pro: CXTPChartPointSeriesStyle Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPChartPointSeriesStyle Class Reference

This class represents a line series style, which is a kind of CXTPChartSeriesStyle. More...

Inheritance diagram for CXTPChartPointSeriesStyle:
[legend]

Public Member Functions

CXTPChartPointSeriesStyle ()
Constructs a CXTPChartPointSeriesStyle object.
virtual | ~CXTPChartPointSeriesStyle ()
Destroys a CXTPChartPointSeriesStyle object, handles cleanup.
CXTPChartMarker * | GetMarker () const
Call this function to get the marker object associated with this CXTPChartPointSeriesStyle object.
void | DoPropExchange (CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
- Public Member Functions inherited from CXTPChartDiagram2DSeriesStyle
CXTPChartDiagram2DSeriesStyle ()
Constructs a CXTPChartDiagram2DSeriesStyle object.
virtual | ~CXTPChartDiagram2DSeriesStyle ()
Destroys a CXTPChartDiagram2DSeriesStyle object, handles cleanup.
virtual CXTPChartDiagram * | CreateDiagram ()
Call this function to create the diagram for this series.
virtual BOOL | IsStyleDiagram (CXTPChartDiagram *pDiagram) const
Call this function to check whether the chart diagram object passed is a kind of 2D diagram (CXTPChartDiagram2D object).
- Public Member Functions inherited from CXTPChartSeriesStyle
CXTPChartSeriesStyle ()
Constructs a CXTPChartSeriesStyle object.
virtual | ~CXTPChartSeriesStyle ()
Destroys a CXTPChartSeriesStyle object, handles cleanup.
virtual CXTPChartSeriesLabel * | GetLabel () const
Call this method to gets the series label object.
virtual CXTPChartSeriesLabel * | SetLabel (CXTPChartSeriesLabel *pLabel)
Call this method to sets the series label object.
virtual CXTPChartErrorBar * | GetErrorBar () const
Call this method to gets the error bar object.
virtual CXTPChartErrorBar * | SetErrorBar (CXTPChartErrorBar *pErrorBar)
Call this method to sets the error bar object.
virtual CXTPChartColor | GetColor () const
Call this method to get the color of the series.
virtual void | SetColor (CXTPChartColor clr)
Call this method to set the color of the series.
virtual void | SetColorEach (BOOL bColorEach)
Call this method to set individual color for each point of the series.
virtual BOOL | IsColorEach () const
This method is called to check if individual color is used for each point of the series.
virtual CXTPChart3dRotation | Get3dRotation () const
Obtains rotation parameters for 3D chart.
virtual void | Set3dRotation (const CXTPChart3dRotation &rotation)
Sets rotation parameters for 3D chart.
virtual void | Set3dRotation (double dYaw, double dPitch, double dRoll)
Sets rotation parameters for 3D chart.
virtual BOOL | Is3dEdgeSmoothingEnabled () const
Enables/disables 3D edge smoothing.
virtual void | Enable3dEdgeSmoothing (BOOL bEnable=TRUE)
Enables/disables 3D edge smoothing.
virtual int | GetTransparency () const
Call this function to gets the transparency of the chart if it is supported by the chart type.
virtual void | SetTransparency (int nTransparency)
Call this function to sets the transparency of the chart if it is supported by the chart type.
virtual void | CorrectAxisSideMargins (CXTPChartAxis *pAxis, double nMinValue, double nMaxValue, double &nCorrection)
Provides default implementation for axis side margins correction.
virtual CXTPChartSeriesStyleAppearance * | GetStyleAppearance () const
Obtains associated style appearance pointer.
virtual void | ApplyTo (CXTPChartDeviceCommand *pCommand)
Applies the style to the command provided in case the command needs style specific details for correct drawing.
virtual int | GetSeriesPointValueIndex () const
Obtains the index of a point element for which an internal value can be otained.
- Public Member Functions inherited from CXTPChartElement
CXTPChartElement ()
Constructs a CXTPChartElement object.
virtual | ~CXTPChartElement ()
Destroys a CXTPChartElement object, handles cleanup.
virtual void | Release ()
Call this function to decrease the usage count of the object.
CXTPChartElement * | GetOwner () const
Call this function to get the owner element.
virtual void | OnChartChanged (XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic properties of the chart.
CXTPChartContent * | GetContent () const
Call this virtual function to get the chart content object.
CXTPChartAppearance * | GetAppearance () const
Call this function to get the the appearance of the chart.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Protected Member Functions

virtual CXTPChartSeriesView * CreateView (CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Call this function to create a view of the point series.
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.

Additional Inherited Members

- Public Attributes inherited from CXTPChartElement
- Protected Attributes inherited from CXTPChartDiagram2DSeriesStyle
int | m_nAxisIndexX
Holds index of secondary axisX, used when m_bSecondaryAxisX is TRUE.
int | m_nAxisIndexY
Holds index of secondary axisY, used when m_bSecondaryAxisY is TRUE.
- Protected Attributes inherited from CXTPChartSeriesStyle
CXTPChartSeriesLabel * | m_pLabel
Label object.
CXTPChartErrorBar * | m_pErrorBar
Error bar object.
CXTPChartColor | m_clrColor
Custom color of series.
BOOL | m_bColorEach
TRUE to color each point.
int | m_nTransparency
The transparency value in the range 0..255.
CXTPChart3dRotation | m_Rotation3d
3D rotation
BOOL | m_bSmooth3dEdges
3D edge smoothing
- Protected Attributes inherited from CXTPChartElement

Detailed Description

This class represents a line series style, which is a kind of CXTPChartSeriesStyle.

A point chart is a type of graph which displays information as a series of data points. It is a basic type of chart common in many fields.

Member Function Documentation

◆ CreateView()

virtual CXTPChartSeriesView * CreateView | ( | CXTPChartSeries * | pSeries,
 |  | CXTPChartDiagramView * | pDiagramView )
 protectedvirtual

Call this function to create a view of the point series.

Parameters
pSeries | A pointer to chart series object.
pDiagramView | A pointer to the diagram view object.
Returns
Returns a pointer to the associated series view object.

Implements CXTPChartSeriesStyle.

Reimplemented in CXTPChartAreaSeriesStyle, CXTPChartBubbleSeriesStyle, CXTPChartLineSeriesStyle, CXTPChartRangeSplineAreaSeriesStyle, CXTPChartScatterLineSeriesStyle, CXTPChartSplineAreaSeriesStyle, CXTPChartSplineSeriesStyle, CXTPChartStackedAreaSeriesStyle, CXTPChartStackedSplineAreaSeriesStyle, CXTPChartStepAreaSeriesStyle, and CXTPChartStepLineSeriesStyle.

◆ DoPropExchange()

void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Reads this object from or writes this object to an archive.

Parameters
pPX A CXTPPropExchange object to serialize to or from.

Reimplemented from CXTPChartDiagram2DSeriesStyle.

Reimplemented in CXTPChartStepAreaSeriesStyle, and CXTPChartStepLineSeriesStyle.

◆ GetMarker()

AFX_INLINE CXTPChartMarker * GetMarker ( ) const

Call this function to get the marker object associated with this CXTPChartPointSeriesStyle object.

Returns
A pointer to a CXTPChartMarker object.
The documentation for this class was generated from the following file:
  • XTPChartPointSeriesStyle.h


Toolkit Pro: CXTPChartPointSeriesView Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPChartPointSeriesView Class Reference

This class represents the view of a point series, which is a kind of CXTPChartSeriesView. More...

Inheritance diagram for CXTPChartPointSeriesView:
[legend]

Public Member Functions

CXTPChartPointSeriesView (CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Constructs a CXTPChartPointSeriesView object.
virtual CXTPChartDeviceCommand * CreateLegendDeviceCommand (CXTPChartDeviceContext *pDC, CRect rcBounds)
This function creates a label view drawing command object.

Protected Member Functions

CXTPChartSeriesPointView * CreateSeriesPointView (CXTPChartDeviceContext *pDC, CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Call this function to create a view of the series points.

Detailed Description

This class represents the view of a point series, which is a kind of CXTPChartSeriesView.

Constructor & Destructor Documentation

◆ CXTPChartPointSeriesView()

CXTPChartPointSeriesView | ( | CXTPChartSeries * | pSeries,
 |  | CXTPChartDiagramView * | pDiagramView )

Constructs a CXTPChartPointSeriesView object.

Parameters
pSeries | A pointer to the chart series object.
pDiagramView | A pointer to the diagram view object.

Member Function Documentation

◆ CreateLegendDeviceCommand()

virtual CXTPChartDeviceCommand * CreateLegendDeviceCommand | ( | CXTPChartDeviceContext * | pDC,
 |  | CRect | rcBounds )
 virtual

This function creates a label view drawing command object.

Parameters
pDC | Pointer to a CXTPChartDeviceContext object.
rcBounds | The rectangular boundary of the legend.
Returns
Returns a new label view drawing command object.

Implements CXTPChartLegendItemView.

◆ CreateSeriesPointView()

CXTPChartSeriesPointView * CreateSeriesPointView | ( | CXTPChartDeviceContext * | pDC,
 |  | CXTPChartSeriesPoint * | pPoint,
 |  | CXTPChartElementView * | pParentView )
 protected

Call this function to create a view of the series points.

Parameters
pDC | A pointer to chart device context.
pPoint | A pointer to the chart series point object.
pParentView | Parent view pointer.
Returns
Returns a pointer to the associated series point view object.
The documentation for this class was generated from the following file:
  • XTPChartPointSeriesView.h


Toolkit Pro: CXTPChartPolygonAntialiasingDeviceCommand Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPChartPolygonAntialiasingDeviceCommand Class Referenceabstract

Base class implementation for 2D chart antialiased polygon device command. More...

Inheritance diagram for CXTPChartPolygonAntialiasingDeviceCommand:
[legend]

Public Member Functions

CXTPChartPolygonAntialiasingDeviceCommand (BOOL bAntiAlias=TRUE)
Constructs a CXTPChartPolygonAntialiasingDeviceCommand object.
virtual void | BeforeExecute (CXTPChartDeviceContext *pDC)=0
This method gets called before a command is executed which allows for the customization of command behavior.
virtual void | AfterExecute (CXTPChartDeviceContext *pDC)=0
This method gets called after a command is executed which allows for the customization of command behavior.
- Public Member Functions inherited from CXTPChartDeviceCommand
CXTPChartDeviceCommand ()
Constructs a CXTPChartDeviceCommand object.
virtual | ~CXTPChartDeviceCommand ()
Destroys a CXTPChartDeviceCommand object, handles cleanup.
BOOL | IsCommitted () const
Determines if the execution of the command has been committed.
void | Commit ()
Commits the execution of the command.
int | GetChildCommandCount () const
Obtains the number of immediate children commands.
CXTPChartDeviceCommand * | GetChildCommand (int nIndex) const
Obtains immediate child command point by index.
CXTPChartDeviceCommand * | AddChildCommand (CXTPChartDeviceCommand *pCommand)
Call this function to add a child device command.
virtual void | Execute (CXTPChartDeviceContext *pDC)
Call this function to execute the drawing.
virtual void | ExecuteOverride (CXTPChartDeviceContext *pDC)
Override this function to write the drawing code for specific objects.
UINT | GetPassNumber () const
Get the number of executions made by the command.
virtual CXTPChartElement * | HitTest (CPoint point, CXTPChartElement *pParent) const
Performs recursive hit testing of the element at the specified point.
virtual void | ApplySeriesStyle (CXTPChartSeriesStyle *pStyle)
Applies series style to the current element.
virtual void | Prepare (CXTPChartDeviceContext *pDC)
Performs inital preparation steps necessary for successful command execution.
virtual void | PrepareOverride (CXTPChartDeviceContext *pDC)
Derived implementation must override this method for implementing implementation specific preparation behavior.
virtual BOOL | IsEnabled () const
Determines if the command is currently enabled.
void | SetEnabled (BOOL bEnabled=TRUE)
Enables/disable the command.
CXTPChartDeviceContext * | GetCurrentDC () const
Obtains device context pointer for which the command is currenly being prepared or executed.
void | BindView (CXTPChartElementView *pView)
Binds a view to the command object.
CXTPChartElementView * | GetBoundView () const
Obtains a bound view pointer or NULL if no view is bound.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.
- Public Member Functions inherited from CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents >
void | Subscribe (CXTPChartDeviceCommandEvents *pObserver, CXTPSubscriptionList< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > *pSubcriptionList=NULL)
Subscribes a unique observer for events.
void | Unsubscribe (CXTPChartDeviceCommandEvents *pObserver)
Unsubscribes an observer from events.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *))
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *))
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.

Protected Attributes

BOOL | m_bAntiAlias
TRUE if antialiasing enabled, FALSE if not.
- Protected Attributes inherited from CXTPChartDeviceCommand
CArray< CXTPChartDeviceCommand *, CXTPChartDeviceCommand * > | m_arrChildren
< The array of child device commands.

Additional Inherited Members

- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.
- Protected Member Functions inherited from CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents >
CXTPObservable ()
Constructs an observable object.
~CXTPObservable ()
Handles observable object destruction.

Detailed Description

Base class implementation for 2D chart antialiased polygon device command.

Constructor & Destructor Documentation

◆ CXTPChartPolygonAntialiasingDeviceCommand()

CXTPChartPolygonAntialiasingDeviceCommand ( BOOL bAntiAlias = TRUE )

Constructs a CXTPChartPolygonAntialiasingDeviceCommand object.

Parameters
bAntiAlias A BOOL value. TRUE to enable antialiasing, FALSE to disable antialiasing. The default value is TRUE.

Member Function Documentation

◆ AfterExecute()

virtual void AfterExecute ( CXTPChartDeviceContext * pDC )
pure virtual

This method gets called after a command is executed which allows for the customization of command behavior.

Parameters
pDC A pointer to the chart native device context.

Reimplemented from CXTPChartDeviceCommand.

◆ BeforeExecute()

virtual void BeforeExecute ( CXTPChartDeviceContext * pDC )
pure virtual

This method gets called before a command is executed which allows for the customization of command behavior.

Parameters
pDC A pointer to the chart native device context.

Reimplemented from CXTPChartDeviceCommand.

The documentation for this class was generated from the following file:
  • XTPChartPolygonDeviceCommand.h


Toolkit Pro: CXTPChartPolygonDeviceCommand Class Reference

Protected Member Functions | Protected Attributes | List of all members
CXTPChartPolygonDeviceCommand Class Reference

Base class implementation for 2D chart polygon device command. More...

Inheritance diagram for CXTPChartPolygonDeviceCommand:
[legend]

Protected Member Functions

CXTPChartPolygonDeviceCommand (const CXTPChartPoints &points)
Constructs a CXTPChartPolygonDeviceCommand object.
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.
- Protected Member Functions inherited from CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents >
CXTPObservable ()
Constructs an observable object.
~CXTPObservable ()
Handles observable object destruction.

Protected Attributes

CXTPChartPoints | m_points
The points which form the polygon.
CXTPChartRectF | m_bounds
The rectanglur broundary of the polygon.
- Protected Attributes inherited from CXTPChartDeviceCommand
CArray< CXTPChartDeviceCommand *, CXTPChartDeviceCommand * > | m_arrChildren
< The array of child device commands.

Additional Inherited Members

- Public Member Functions inherited from CXTPChartDeviceCommand
CXTPChartDeviceCommand ()
Constructs a CXTPChartDeviceCommand object.
virtual | ~CXTPChartDeviceCommand ()
Destroys a CXTPChartDeviceCommand object, handles cleanup.
BOOL | IsCommitted () const
Determines if the execution of the command has been committed.
void | Commit ()
Commits the execution of the command.
int | GetChildCommandCount () const
Obtains the number of immediate children commands.
CXTPChartDeviceCommand * | GetChildCommand (int nIndex) const
Obtains immediate child command point by index.
CXTPChartDeviceCommand * | AddChildCommand (CXTPChartDeviceCommand *pCommand)
Call this function to add a child device command.
virtual void | Execute (CXTPChartDeviceContext *pDC)
Call this function to execute the drawing.
virtual void | BeforeExecute (CXTPChartDeviceContext *pDC)
This method gets called before a command is executed which allows for the customization of command behavior.
virtual void | AfterExecute (CXTPChartDeviceContext *pDC)
This method gets called after a command is executed which allows for the customization of command behavior.
virtual void | ExecuteOverride (CXTPChartDeviceContext *pDC)
Override this function to write the drawing code for specific objects.
UINT | GetPassNumber () const
Get the number of executions made by the command.
virtual CXTPChartElement * | HitTest (CPoint point, CXTPChartElement *pParent) const
Performs recursive hit testing of the element at the specified point.
virtual void | ApplySeriesStyle (CXTPChartSeriesStyle *pStyle)
Applies series style to the current element.
virtual void | Prepare (CXTPChartDeviceContext *pDC)
Performs inital preparation steps necessary for successful command execution.
virtual void | PrepareOverride (CXTPChartDeviceContext *pDC)
Derived implementation must override this method for implementing implementation specific preparation behavior.
virtual BOOL | IsEnabled () const
Determines if the command is currently enabled.
void | SetEnabled (BOOL bEnabled=TRUE)
Enables/disable the command.
CXTPChartDeviceContext * | GetCurrentDC () const
Obtains device context pointer for which the command is currenly being prepared or executed.
void | BindView (CXTPChartElementView *pView)
Binds a view to the command object.
CXTPChartElementView * | GetBoundView () const
Obtains a bound view pointer or NULL if no view is bound.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.
- Public Member Functions inherited from CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents >
void | Subscribe (CXTPChartDeviceCommandEvents *pObserver, CXTPSubscriptionList< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > *pSubcriptionList=NULL)
Subscribes a unique observer for events.
void | Unsubscribe (CXTPChartDeviceCommandEvents *pObserver)
Unsubscribes an observer from events.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *))
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *))
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.

Detailed Description

Base class implementation for 2D chart polygon device command.

Constructor & Destructor Documentation

◆ CXTPChartPolygonDeviceCommand()

CXTPChartPolygonDeviceCommand ( const CXTPChartPoints & points )
protected

Constructs a CXTPChartPolygonDeviceCommand object.

Parameters
points Point collection used for drawing polygon.
The documentation for this class was generated from the following file:
  • XTPChartPolygonDeviceCommand.h


Toolkit Pro: CXTPChartPolylineDeviceCommand Class Reference

Protected Member Functions | Protected Attributes | List of all members
CXTPChartPolylineDeviceCommand Class Reference

Provides an interface for 2D poly-line drawing device command. More...

Inheritance diagram for CXTPChartPolylineDeviceCommand:
[legend]

Protected Member Functions

CXTPChartPolylineDeviceCommand (const CXTPChartPoints &p, int thickness)
Constructs a CXTPChartPolylineDeviceCommand object.
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.
- Protected Member Functions inherited from CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents >
CXTPObservable ()
Constructs an observable object.
~CXTPObservable ()
Handles observable object destruction.

Protected Attributes

CXTPChartPoints | m_p
A collection of poly-line points.
int | m_nThickness
Line thickness in pixels.
- Protected Attributes inherited from CXTPChartDeviceCommand
CArray< CXTPChartDeviceCommand *, CXTPChartDeviceCommand * > | m_arrChildren
< The array of child device commands.

Additional Inherited Members

- Public Member Functions inherited from CXTPChartDeviceCommand
CXTPChartDeviceCommand ()
Constructs a CXTPChartDeviceCommand object.
virtual | ~CXTPChartDeviceCommand ()
Destroys a CXTPChartDeviceCommand object, handles cleanup.
BOOL | IsCommitted () const
Determines if the execution of the command has been committed.
void | Commit ()
Commits the execution of the command.
int | GetChildCommandCount () const
Obtains the number of immediate children commands.
CXTPChartDeviceCommand * | GetChildCommand (int nIndex) const
Obtains immediate child command point by index.
CXTPChartDeviceCommand * | AddChildCommand (CXTPChartDeviceCommand *pCommand)
Call this function to add a child device command.
virtual void | Execute (CXTPChartDeviceContext *pDC)
Call this function to execute the drawing.
virtual void | BeforeExecute (CXTPChartDeviceContext *pDC)
This method gets called before a command is executed which allows for the customization of command behavior.
virtual void | AfterExecute (CXTPChartDeviceContext *pDC)
This method gets called after a command is executed which allows for the customization of command behavior.
virtual void | ExecuteOverride (CXTPChartDeviceContext *pDC)
Override this function to write the drawing code for specific objects.
UINT | GetPassNumber () const
Get the number of executions made by the command.
virtual CXTPChartElement * | HitTest (CPoint point, CXTPChartElement *pParent) const
Performs recursive hit testing of the element at the specified point.
virtual void | ApplySeriesStyle (CXTPChartSeriesStyle *pStyle)
Applies series style to the current element.
virtual void | Prepare (CXTPChartDeviceContext *pDC)
Performs inital preparation steps necessary for successful command execution.
virtual void | PrepareOverride (CXTPChartDeviceContext *pDC)
Derived implementation must override this method for implementing implementation specific preparation behavior.
virtual BOOL | IsEnabled () const
Determines if the command is currently enabled.
void | SetEnabled (BOOL bEnabled=TRUE)
Enables/disable the command.
CXTPChartDeviceContext * | GetCurrentDC () const
Obtains device context pointer for which the command is currenly being prepared or executed.
void | BindView (CXTPChartElementView *pView)
Binds a view to the command object.
CXTPChartElementView * | GetBoundView () const
Obtains a bound view pointer or NULL if no view is bound.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.
- Public Member Functions inherited from CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents >
void | Subscribe (CXTPChartDeviceCommandEvents *pObserver, CXTPSubscriptionList< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > *pSubcriptionList=NULL)
Subscribes a unique observer for events.
void | Unsubscribe (CXTPChartDeviceCommandEvents *pObserver)
Unsubscribes an observer from events.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *))
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *))
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.

Detailed Description

Provides an interface for 2D poly-line drawing device command.

Constructor & Destructor Documentation

◆ CXTPChartPolylineDeviceCommand()

CXTPChartPolylineDeviceCommand | ( | const CXTPChartPoints & | p,
 |  | int | thickness )
 protected

Constructs a CXTPChartPolylineDeviceCommand object.

Parameters
p | A collection of poly-line points.
thickness | Line thickness in pixels.
The documentation for this class was generated from the following file:
  • XTPChartLineDeviceCommand.h


Toolkit Pro: CXTPChartPyramidDiagram Class Reference

Public Member Functions | List of all members
CXTPChartPyramidDiagram Class Reference

This class abstracts the pyramid diagram. More...

Inheritance diagram for CXTPChartPyramidDiagram:
[legend]

Public Member Functions

CXTPChartPyramidDiagram ()
Constructs a CXTPChartPyramidDiagram object.
virtual CXTPChartDiagramView * | CreateView (CXTPChartDeviceContext *pDC, CXTPChartElementView *pParent)
Call this function to create the view of the pyramid diagram.
- Public Member Functions inherited from CXTPChartPyramidDiagramBase< BaseDiagram >
virtual void | CalculateSeriesLayout (CXTPChartDeviceContext *pDC, CXTPChartDiagramView *pView)
Call this function to calculate the pyramid series layout.

Additional Inherited Members

- Protected Member Functions inherited from CXTPChartPyramidDiagramBase< BaseDiagram >
CXTPChartPyramidDiagramBase ()
Constructs a CXTPChartPyramidDiagramBase object.

Detailed Description

This class abstracts the pyramid diagram.

This class is a kind of CXTPChartDiagram.

Member Function Documentation

◆ CreateView()

virtual CXTPChartDiagramView * CreateView | ( | CXTPChartDeviceContext * | pDC,
 |  | CXTPChartElementView * | pParent )
 virtual

Call this function to create the view of the pyramid diagram.

Parameters
pDC | A pointer to chart device context.
pParent | A pointer to the parent view.
Returns
Returns a pointer to the associated diagram view object.

Implements CXTPChartPyramidDiagramBase< BaseDiagram >.

The documentation for this class was generated from the following file:
  • XTPChart2dPyramidDiagram.h


Toolkit Pro: CXTPChartPyramidDiagramBase< BaseDiagram > Class Template Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPChartPyramidDiagramBase< BaseDiagram > Class Template Referenceabstract

This class abstracts the pyramid diagram. More...

Inheritance diagram for CXTPChartPyramidDiagramBase< BaseDiagram >:
[legend]

Public Member Functions

virtual CXTPChartDiagramView * | CreateView (CXTPChartDeviceContext *pDC, CXTPChartElementView *pParent)=0
Call this function to create the view of the pyramid diagram.
virtual void | CalculateSeriesLayout (CXTPChartDeviceContext *pDC, CXTPChartDiagramView *pView)
Call this function to calculate the pyramid series layout.

Protected Member Functions

CXTPChartPyramidDiagramBase ()
Constructs a CXTPChartPyramidDiagramBase object.

Detailed Description

template<class BaseDiagram>
class CXTPChartPyramidDiagramBase< BaseDiagram >

This class abstracts the pyramid diagram.

Member Function Documentation

◆ CalculateSeriesLayout()

template<class BaseDiagram >
AFX_INLINE void CalculateSeriesLayout | ( | CXTPChartDeviceContext * | pDC,
 |  | CXTPChartDiagramView * | pView )
 virtual

Call this function to calculate the pyramid series layout.

Parameters
pDC | A pointer to the chart device context.
pView | A pointer to the diagram view.

◆ CreateView()

template<class BaseDiagram >
virtual CXTPChartDiagramView * CreateView | ( | CXTPChartDeviceContext * | pDC,
 |  | CXTPChartElementView * | pParent )
 pure virtual

Call this function to create the view of the pyramid diagram.

Parameters
pDC | A pointer to the chart device context.
pParent | A pointer to the parent view.
Returns
Returns a pointer to the associated diagram view object.

Implemented in CXTPChart3dPyramidDiagram, and CXTPChartPyramidDiagram.

The documentation for this class was generated from the following file:
  • XTPChartPyramidDiagramBase.h


Toolkit Pro: CXTPChartPyramidDiagramView Class Reference

Public Member Functions | List of all members
CXTPChartPyramidDiagramView Class Reference

This class abstracts the view of a pyramid diagram. More...

Inheritance diagram for CXTPChartPyramidDiagramView:
[legend]

Public Member Functions

CXTPChartPyramidDiagramView (CXTPChartDiagram *pDiagram, CXTPChartElementView *pParent)
Constructs a CXTPChartPyramidDiagramView object.
- Public Member Functions inherited from CXTPChartDiagramView
CXTPChartDiagramView (CXTPChartDiagram *pDiagram, CXTPChartElementView *pParentView)
Constructs a CXTPChartDiagram object.
CRect | GetBounds () const
Call this function to get the bounds of the diagram.
CXTPChartDiagram * | GetDiagram () const
Call this function to get the diagram object associated with the view.
CXTPChartElementView * | GetLabelsView () const
Call this function to get the label view object associated with this diagram view.
CXTPChartElementView * | GetSeriesView () const
Call this function to get the series view object associated with this diagram view.
virtual void | CalculateView (CXTPChartDeviceContext *pDC, CRect rcBounds)
Call this function to calculate the view of the diagram.
virtual void | UpdateRange (CXTPChartDeviceContext *pDC)
Updates chart range.
virtual void | OnMouseWheel (UINT nFlags, short zDelta, CPoint pt)
Handles mouse wheel event.
virtual void | CreateView (CXTPChartDeviceContext *pDC)
Performs view initialization.
- Public Member Functions inherited from CXTPChartElementView
CXTPChartElementView (CXTPChartElementView *pParentView)
Constructs a CXTPChartElementView object.
CXTPChartElementView (CXTPChartElementView *pParentView, BOOL bAddToParent)
Constructs a CXTPChartElementView object.
CXTPChartElementView (CXTPChartContainer *pContainer)
Constructs a CXTPChartElementView object.
int | GetCount () const
Call this function to get the number of child views associated with this view.
CXTPChartElementView * | GetAt (int nIndex) const
Call this function to get a child view at a particular index.
CXTPChartElementView * | GetParentView () const
Call this function to get the parent view.
CXTPChartElementView * | AddChildView (CXTPChartElementView *pChildView)
Call this function to add a child view to the current view.
CXTPChartElementView ** GetChildren ()
Provides access to the collection of children elements owned by the view.
CRect | GetBounds () const
Obtains viewed object's bound rectangle.
CRect | GetBounds (BOOL bIncludingChildren) const
Obtains viewed object's bound rectangle.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Additional Inherited Members

- Public Attributes inherited from CXTPChartDiagramView
- Protected Member Functions inherited from CXTPChartDiagramView
virtual CXTPChartDeviceCommand * | CreateDeviceCommand (CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
- Protected Member Functions inherited from CXTPChartElementView
virtual | ~CXTPChartElementView ()
Destroys a CXTPChartElementView object, handles cleanup.
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.
- Protected Attributes inherited from CXTPChartDiagramView
CXTPChartDiagram * | m_pDiagram
Pointer to the associated diagram object.
CRect | m_rcBounds
The diagram bounds.
CXTPChartElementView * | m_pLabelsView
The label view.
CXTPChartElementView * | m_pSeriesView
The series view.
CXTPChartElementView * | m_pTitlesView
Titles View.
- Protected Attributes inherited from CXTPChartElementView
CArray< CXTPChartElementView *, CXTPChartElementView * > | m_arrChildren
The child view collection.
CXTPChartElementView * | m_pParentView
The parent view.
CXTPChartContainer * | m_pContainer
The parent container.
CRect | m_rcBounds
Bounding rectangle.

Detailed Description

This class abstracts the view of a pyramid diagram.

This class is a kind of CXTPChartDiagramView.

A pyramid chart (or a circle graph) is a circular chart divided into sectors, illustrating percents. In a pyramid chart, the arc length of each sector (and consequently its central angle and area), is proportional to the quantity it represents. Together, the sectors create a full disk.

Constructor & Destructor Documentation

◆ CXTPChartPyramidDiagramView()

CXTPChartPyramidDiagramView | ( | CXTPChartDiagram * | pDiagram,
 |  | CXTPChartElementView * | pParent )

Constructs a CXTPChartPyramidDiagramView object.

Parameters
pDiagram | A pointer to the pyramid diagram object.
pParent | A pointer to the parent view.
The documentation for this class was generated from the following file:
  • XTPChart2dPyramidDiagramView.h


Toolkit Pro: CXTPChartPyramidSeriesLabel Class Reference

Protected Member Functions | List of all members
CXTPChartPyramidSeriesLabel Class Reference

CXTPChartPyramidSeriesLabel is a kind of CXTPChartSeriesLabel. More...

Inheritance diagram for CXTPChartPyramidSeriesLabel:
[legend]

Protected Member Functions

virtual CXTPChartElementView * CreateView (CXTPChartDeviceContext *pDC, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView)
This function creates the view of the pyramid series.
- Protected Member Functions inherited from CXTPChartPyramidSeriesLabelBase
- Protected Member Functions inherited from CXTPChartSeriesLabel
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.

Additional Inherited Members

- Public Member Functions inherited from CXTPChartPyramidSeriesLabelBase
CXTPChartPyramidSeriesLabelBase ()
Constructs a CXTPChartPyramidSeriesLabelBase object.
virtual | ~CXTPChartPyramidSeriesLabelBase ()
Destroys a CXTPChartPyramidSeriesLabelBase object, handles cleanup.
XTPChartPyramidLabelPosition | GetPosition () const
Call this function to get the label position.
void | SetPosition (XTPChartPyramidLabelPosition nPosition)
Call this function to set the label position.
CXTPChartPyramidSeriesStyleBase * | GetStyle () const
Call this function to get the basic style of the pyramid series.
void | DoPropExchange (CXTPPropExchange *pPX)
Call this member function to Store/Load the properties of content using the specified data object.
BOOL | IsInside () const
Call this function to check whether the label is inside the pyramid.
- Public Member Functions inherited from CXTPChartSeriesLabel
CXTPChartSeriesLabel ()
Constructs a CXTPChartSeriesLabel object.
virtual | ~CXTPChartSeriesLabel ()
Destroys a CXTPChartSeriesLabel object, handles cleanup.
void | SetTextColor (const CXTPChartColor &clrTextColor)
Call this function to set the text color of the label.
CXTPChartColor | GetTextColor () const
Call this function to get the apparent text color of the label.
CXTPChartFont * | GetFont () const
Call this function to get the font of the text label.
void | SetFont (CXTPChartFont *pFont)
Call this function to set the font of the text label.
void | SetShowLines (BOOL bShowLines)
Call this function to set the lines visibility.
BOOL | GetShowLines () const
Call this function to check if the lines are visible.
void | SetLineLength (int nLineLength)
Call this function to set the line length.
int | GetLineLength () const
Call this function to get the line length.
void | SetVisible (BOOL bVisible)
Call this function to set the label visibility.
BOOL | IsVisible () const
Call this function to check if the label is visible.
void | SetAntialiasing (BOOL bAntialiasing)
Call this function to set anti-aliasing ON or OFF.
BOOL | GetAntialiasing () const
Call this function to check if anti-aliasing is ON or OFF.
CXTPChartNumberFormat * | GetFormat () const
Call this function to get a pointer to CXTPChartNumberFormat that specifies how to convert numbers to strings.
void | SetFormat (LPCTSTR lpszFormat)
Obsolete method.
void | SetBackColor (const CXTPChartColor &clrBackColor)
Call this function to set the text color of the label.
CXTPChartColor | GetBackColor () const
Call this function to get the apparent text color of the label.
void | SetLineColor (const CXTPChartColor &clrBackColor)
Call this function to set the text color of the label.
CXTPChartColor | GetLineColor () const
Call this function to get the apparent text color of the label.
int | GetTransparency () const
Call this function to get the transparency of the filled area with respect to the background.
void | SetTransparency (int nTransparency)
Call this function to set the transparency of the filled area with respect to the background.
- Public Member Functions inherited from CXTPChartTextElement
- Public Member Functions inherited from CXTPChartElement
CXTPChartElement ()
Constructs a CXTPChartElement object.
virtual | ~CXTPChartElement ()
Destroys a CXTPChartElement object, handles cleanup.
virtual void | Release ()
Call this function to decrease the usage count of the object.
CXTPChartElement * | GetOwner () const
Call this function to get the owner element.
virtual void | OnChartChanged (XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic properties of the chart.
CXTPChartContent * | GetContent () const
Call this virtual function to get the chart content object.
CXTPChartAppearance * | GetAppearance () const
Call this function to get the the appearance of the chart.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.
- Public Attributes inherited from CXTPChartElement
- Protected Attributes inherited from CXTPChartPyramidSeriesLabelBase
XTPChartPyramidLabelPosition | m_nPosition
The pyramid label position.
- Protected Attributes inherited from CXTPChartSeriesLabel
CXTPChartColor | m_clrTextColor
The text color.
CXTPChartColor | m_clrBackColor
The background color.
CXTPChartColor | m_clrLineColor
The line color.
BOOL | m_bVisible
TRUE if the label is visible and FALSE if not.
CXTPChartFont * | m_pFont
The font of the label.
BOOL | m_bAntialiasing
TRUE if antialiasing enabled, FALSE if not.
BOOL | m_bShowLines
TRUE if the lines are visible, FALSE if not.
int | m_nLineLength
The line length.
CXTPChartBorder * | m_pBorder
Chart border object.
int | m_nTransparency
The transparency values range from 0 to 255.
- Protected Attributes inherited from CXTPChartElement

Detailed Description

CXTPChartPyramidSeriesLabel is a kind of CXTPChartSeriesLabel.

This class abstracts the label of a pyramid series.

Member Function Documentation

◆ CreateView()

virtual CXTPChartElementView * CreateView | ( | CXTPChartDeviceContext * | pDC,
 |  | CXTPChartSeriesPointView * | pPointView,
 |  | CXTPChartElementView * | pParentView )
 protectedvirtual

This function creates the view of the pyramid series.

Parameters
pDC | The chart device context object pointer.
pPointView | The series point view.
pParentView | Parent view pointer.
Returns
Returns a pointer to the associated label view object.

Implements CXTPChartPyramidSeriesLabelBase.

The documentation for this class was generated from the following file:
  • XTPChart2dPyramidSeriesLabel.h


Toolkit Pro: CXTPChartPyramidSeriesLabelBase Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPChartPyramidSeriesLabelBase Class Referenceabstract

This class abstracts the pyramid series label. More...

Inheritance diagram for CXTPChartPyramidSeriesLabelBase:
[legend]

Public Member Functions

CXTPChartPyramidSeriesLabelBase ()
Constructs a CXTPChartPyramidSeriesLabelBase object.
virtual | ~CXTPChartPyramidSeriesLabelBase ()
Destroys a CXTPChartPyramidSeriesLabelBase object, handles cleanup.
XTPChartPyramidLabelPosition | GetPosition () const
Call this function to get the label position.
void | SetPosition (XTPChartPyramidLabelPosition nPosition)
Call this function to set the label position.
CXTPChartPyramidSeriesStyleBase * | GetStyle () const
Call this function to get the basic style of the pyramid series.
void | DoPropExchange (CXTPPropExchange *pPX)
Call this member function to Store/Load the properties of content using the specified data object.
BOOL | IsInside () const
Call this function to check whether the label is inside the pyramid.
- Public Member Functions inherited from CXTPChartSeriesLabel
CXTPChartSeriesLabel ()
Constructs a CXTPChartSeriesLabel object.
virtual | ~CXTPChartSeriesLabel ()
Destroys a CXTPChartSeriesLabel object, handles cleanup.
void | SetTextColor (const CXTPChartColor &clrTextColor)
Call this function to set the text color of the label.
CXTPChartColor | GetTextColor () const
Call this function to get the apparent text color of the label.
CXTPChartFont * | GetFont () const
Call this function to get the font of the text label.
void | SetFont (CXTPChartFont *pFont)
Call this function to set the font of the text label.
void | SetShowLines (BOOL bShowLines)
Call this function to set the lines visibility.
BOOL | GetShowLines () const
Call this function to check if the lines are visible.
void | SetLineLength (int nLineLength)
Call this function to set the line length.
int | GetLineLength () const
Call this function to get the line length.
void | SetVisible (BOOL bVisible)
Call this function to set the label visibility.
BOOL | IsVisible () const
Call this function to check if the label is visible.
void | SetAntialiasing (BOOL bAntialiasing)
Call this function to set anti-aliasing ON or OFF.
BOOL | GetAntialiasing () const
Call this function to check if anti-aliasing is ON or OFF.
CXTPChartNumberFormat * | GetFormat () const
Call this function to get a pointer to CXTPChartNumberFormat that specifies how to convert numbers to strings.
void | SetFormat (LPCTSTR lpszFormat)
Obsolete method.
void | SetBackColor (const CXTPChartColor &clrBackColor)
Call this function to set the text color of the label.
CXTPChartColor | GetBackColor () const
Call this function to get the apparent text color of the label.
void | SetLineColor (const CXTPChartColor &clrBackColor)
Call this function to set the text color of the label.
CXTPChartColor | GetLineColor () const
Call this function to get the apparent text color of the label.
int | GetTransparency () const
Call this function to get the transparency of the filled area with respect to the background.
void | SetTransparency (int nTransparency)
Call this function to set the transparency of the filled area with respect to the background.
- Public Member Functions inherited from CXTPChartTextElement
- Public Member Functions inherited from CXTPChartElement
CXTPChartElement ()
Constructs a CXTPChartElement object.
virtual | ~CXTPChartElement ()
Destroys a CXTPChartElement object, handles cleanup.
virtual void | Release ()
Call this function to decrease the usage count of the object.
CXTPChartElement * | GetOwner () const
Call this function to get the owner element.
virtual void | OnChartChanged (XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic properties of the chart.
CXTPChartContent * | GetContent () const
Call this virtual function to get the chart content object.
CXTPChartAppearance * | GetAppearance () const
Call this function to get the the appearance of the chart.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Protected Member Functions

virtual CXTPChartElementView * CreateView (CXTPChartDeviceContext *pDC, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView)=0
This function creates the view of the pyramid series.
- Protected Member Functions inherited from CXTPChartSeriesLabel
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.

Protected Attributes

XTPChartPyramidLabelPosition | m_nPosition
The pyramid label position.
- Protected Attributes inherited from CXTPChartSeriesLabel
CXTPChartColor | m_clrTextColor
The text color.
CXTPChartColor | m_clrBackColor
The background color.
CXTPChartColor | m_clrLineColor
The line color.
BOOL | m_bVisible
TRUE if the label is visible and FALSE if not.
CXTPChartFont * | m_pFont
The font of the label.
BOOL | m_bAntialiasing
TRUE if antialiasing enabled, FALSE if not.
BOOL | m_bShowLines
TRUE if the lines are visible, FALSE if not.
int | m_nLineLength
The line length.
CXTPChartBorder * | m_pBorder
Chart border object.
int | m_nTransparency
The transparency values range from 0 to 255.
- Protected Attributes inherited from CXTPChartElement

Detailed Description

This class abstracts the pyramid series label.

Member Function Documentation

◆ CreateView()

virtual CXTPChartElementView * CreateView | ( | CXTPChartDeviceContext * | pDC,
 |  | CXTPChartSeriesPointView * | pPointView,
 |  | CXTPChartElementView * | pParentView )
 protectedpure virtual

This function creates the view of the pyramid series.

Parameters
pDC | The chart device context object pointer.
pPointView | The series point view.
pParentView | Parent element view.
Returns
Returns a pointer to the associated label view object.

Reimplemented from CXTPChartSeriesLabel.

Implemented in CXTPChart3dPyramidSeriesLabel, and CXTPChartPyramidSeriesLabel.

◆ DoPropExchange()

void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Call this member function to Store/Load the properties of content using the specified data object.

Parameters
pPX Source or destination CXTPPropExchange data object reference.

This member function is used to store property data to or load property data from storage.

Reimplemented from CXTPChartSeriesLabel.

◆ GetPosition()

AFX_INLINE XTPChartPyramidLabelPosition GetPosition ( ) const

Call this function to get the label position.

Returns
A pyramid label position object describing the position of the pyramid label.

◆ GetStyle()

CXTPChartPyramidSeriesStyleBase * GetStyle ( ) const

Call this function to get the basic style of the pyramid series.

Returns
A pointer to a CXTPChartPyramidSeriesStyleBase object.

◆ IsInside()

BOOL IsInside ( ) const

Call this function to check whether the label is inside the pyramid.

Returns
Returns TRUE if the label is inside the pyramid, FALSE otherwise.

◆ SetPosition()

AFX_INLINE void SetPosition ( XTPChartPyramidLabelPosition nPosition )

Call this function to set the label position.

Parameters
nPosition A pyramid label position object describing the position of the pyramid label.
The documentation for this class was generated from the following file:
  • XTPChartPyramidSeriesLabelBase.h


Toolkit Pro: CXTPChartPyramidSeriesLabelView Class Reference

Public Member Functions | List of all members
CXTPChartPyramidSeriesLabelView Class Reference

Defines 2D series label view. More...

Inheritance diagram for CXTPChartPyramidSeriesLabelView:
[legend]

Public Member Functions

CXTPChartPyramidSeriesLabelView (CXTPChartSeriesLabel *pLabel, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView)
Constructs a CXTPChartPyramidSeriesLabelView object.
virtual CXTPChartDeviceCommand * | CreateDeviceCommand (CXTPChartDeviceContext *pDC)
Creates view drawing device command for the device context specified.
- Public Member Functions inherited from CXTPChartPyramidSeriesLabelViewBase
XTPChartPyramidLabelPosition | GetPosition () const
Obtains label position.

Additional Inherited Members

- Protected Member Functions inherited from CXTPChartPyramidSeriesLabelViewBase
CXTPChartPyramidSeriesLabelViewBase (CXTPChartSeriesLabel *pLabel, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView)
Constructs a CXTPChartPyramidSeriesLabelViewBase object.

Detailed Description

Defines 2D series label view.

Constructor & Destructor Documentation

◆ CXTPChartPyramidSeriesLabelView()

CXTPChartPyramidSeriesLabelView | ( | CXTPChartSeriesLabel * | pLabel,
 |  | CXTPChartSeriesPointView * | pPointView,
 |  | CXTPChartElementView * | pParentView )

Constructs a CXTPChartPyramidSeriesLabelView object.

Parameters
pLabel | Associated label model pointer.
pPointView | Point view object pointer associated with the label.
pParentView | Parent view pointer.

Member Function Documentation

◆ CreateDeviceCommand()

virtual CXTPChartDeviceCommand * CreateDeviceCommand ( CXTPChartDeviceContext * pDC )
virtual

Creates view drawing device command for the device context specified.

Parameters
pDC Device context pointer for which the drawing command is to be created.
Returns
A new instance of view drawing device command or NULL if no command is provided.

Implements CXTPChartPyramidSeriesLabelViewBase.

The documentation for this class was generated from the following file:
  • XTPChart2dPyramidSeriesLabel.h


Toolkit Pro: CXTPChartPyramidSeriesLabelViewBase Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPChartPyramidSeriesLabelViewBase Class Referenceabstract

This class abstracts the view of a pyramid series label. More...

Inheritance diagram for CXTPChartPyramidSeriesLabelViewBase:
[legend]

Public Member Functions

XTPChartPyramidLabelPosition | GetPosition () const
Obtains label position.
virtual CXTPChartDeviceCommand * | CreateDeviceCommand (CXTPChartDeviceContext *pDC)=0
Creates view drawing device command for the device context specified.

Protected Member Functions

CXTPChartPyramidSeriesLabelViewBase (CXTPChartSeriesLabel *pLabel, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView)
Constructs a CXTPChartPyramidSeriesLabelViewBase object.

Detailed Description

This class abstracts the view of a pyramid series label.

Constructor & Destructor Documentation

◆ CXTPChartPyramidSeriesLabelViewBase()

CXTPChartPyramidSeriesLabelViewBase | ( | CXTPChartSeriesLabel * | pLabel,
 |  | CXTPChartSeriesPointView * | pPointView,
 |  | CXTPChartElementView * | pParentView )
 protected

Constructs a CXTPChartPyramidSeriesLabelViewBase object.

Parameters
pLabel | Associated label model pointer.
pPointView | Point view object pointer associated with the label.
pParentView | Parent view pointer.

Member Function Documentation

◆ CreateDeviceCommand()

virtual CXTPChartDeviceCommand * CreateDeviceCommand ( CXTPChartDeviceContext * pDC )
pure virtual

Creates view drawing device command for the device context specified.

Parameters
pDC Device context pointer for which the drawing command is to be created.
Returns
A new instance of view drawing device command or NULL if no command is provided.

Reimplemented from CXTPChartElementView.

Implemented in CXTPChart3dPyramidSeriesLabelView, and CXTPChartPyramidSeriesLabelView.

◆ GetPosition()

XTPChartPyramidLabelPosition GetPosition ( ) const

Obtains label position.

Returns
Label position.
The documentation for this class was generated from the following file:
  • XTPChartPyramidSeriesLabelBase.h


Toolkit Pro: CXTPChartPyramidSeriesPointView Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPChartPyramidSeriesPointView Class Reference

This class abstracts the view of a pyramid series point. More...

Inheritance diagram for CXTPChartPyramidSeriesPointView:
[legend]

Public Member Functions

CXTPChartPyramidSeriesPointView (CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Constructs a CXTPChartPyramidSeriesPointView object.
CXTPChartPyramidSeriesPointView (CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView, BOOL bAddToParent)
Constructs a CXTPChartPyramidSeriesPointView object.
void | CalculateLayout (int nIndex, int nCount, double dFrom, double dTo)
Use this function to calculate the layout of the pyramid series point.
- Public Member Functions inherited from CXTPChartPyramidSeriesPointViewBase
CXTPChartPyramidSeriesPointViewBase (CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Constructs a CXTPChartPyramidSeriesPointViewBase object.
CXTPChartPyramidSeriesPointViewBase (CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView, BOOL bAddToParent)
Constructs a CXTPChartPyramidSeriesPointViewBase object.
virtual | ~CXTPChartPyramidSeriesPointViewBase ()
Destroys a CXTPChartPyramidSeriesPointViewBase object, handles cleanup.
CXTPChartColor | GetBorderActualColor () const
Use this function to obtain the color value of the pyramid border.
- Public Member Functions inherited from CXTPChartSeriesPointView
CXTPChartSeriesPointView (CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Constructs the view object.
CXTPChartSeriesPointView (CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView, BOOL bAddToParent)
Constructs the view object.
CXTPChartSeriesPoint * | GetPoint () const
Obtains point model object.
CXTPChartSeriesView * | GetSeriesView () const
Obtains parent series view.
CXTPChartColor | GetColor () const
Obtain view color values.
CXTPChartColor | GetColor2 () const
Obtain view color values.
double | GetInternalValue () const
Obtains point interval value.
virtual CXTPChartString | GetLegendName () const
This function returns the legend name.
virtual void | UpdateMinMaxRange (double &nMinValue, double &nMaxValue) const
Provides a default empty implementation for min/max range update request.
- Public Member Functions inherited from CXTPChartElementView
CXTPChartElementView (CXTPChartElementView *pParentView)
Constructs a CXTPChartElementView object.
CXTPChartElementView (CXTPChartElementView *pParentView, BOOL bAddToParent)
Constructs a CXTPChartElementView object.
CXTPChartElementView (CXTPChartContainer *pContainer)
Constructs a CXTPChartElementView object.
int | GetCount () const
Call this function to get the number of child views associated with this view.
CXTPChartElementView * | GetAt (int nIndex) const
Call this function to get a child view at a particular index.
CXTPChartElementView * | GetParentView () const
Call this function to get the parent view.
CXTPChartElementView * | AddChildView (CXTPChartElementView *pChildView)
Call this function to add a child view to the current view.
CXTPChartElementView ** GetChildren ()
Provides access to the collection of children elements owned by the view.
CRect | GetBounds () const
Obtains viewed object's bound rectangle.
CRect | GetBounds (BOOL bIncludingChildren) const
Obtains viewed object's bound rectangle.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.
- Public Member Functions inherited from CXTPChartLegendItemView
virtual | ~CXTPChartLegendItemView ()
Handles object destruction.

Protected Member Functions

virtual CXTPChartDeviceCommand * | CreateDeviceCommand (CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
- Protected Member Functions inherited from CXTPChartPyramidSeriesPointViewBase
virtual CXTPChartDeviceCommand * | CreateLegendDeviceCommand (CXTPChartDeviceContext *pDC, CRect rcBounds)
This function creates a label view drawing command object.
- Protected Member Functions inherited from CXTPChartElementView
virtual | ~CXTPChartElementView ()
Destroys a CXTPChartElementView object, handles cleanup.
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.

Additional Inherited Members

- Public Attributes inherited from CXTPChartSeriesPointView
double | m_dInternalValue
Point internal value.
- Protected Attributes inherited from CXTPChartPyramidSeriesPointViewBase
double | m_dValue
The value of the point.
- Protected Attributes inherited from CXTPChartSeriesPointView
CXTPChartSeriesPoint * | m_pPoint
Point model object pointer.
- Protected Attributes inherited from CXTPChartElementView
CArray< CXTPChartElementView *, CXTPChartElementView * > | m_arrChildren
The child view collection.
CXTPChartElementView * | m_pParentView
The parent view.
CXTPChartContainer * | m_pContainer
The parent container.
CRect | m_rcBounds
Bounding rectangle.

Detailed Description

This class abstracts the view of a pyramid series point.

This class is a kind of CXTPChartSeriesPointView.

A pyramid chart (or a circle graph) is a circular chart divided into sectors, illustrating percents. In a pyramid chart, the arc length of each sector (and consequently its central angle and area), is proportional to the quantity it represents. Together, the sectors create a full disk.

Constructor & Destructor Documentation

◆ CXTPChartPyramidSeriesPointView() [1/2]

CXTPChartPyramidSeriesPointView | ( | CXTPChartSeriesPoint * | pPoint,
 |  | CXTPChartElementView * | pParentView )

Constructs a CXTPChartPyramidSeriesPointView object.

Parameters
pPoint | Pointer to chart series point.
pParentView | Parent element view pointer.

◆ CXTPChartPyramidSeriesPointView() [2/2]

CXTPChartPyramidSeriesPointView | ( | CXTPChartSeriesPoint * | pPoint,
 |  | CXTPChartElementView * | pParentView,
 |  | BOOL | bAddToParent )

Constructs a CXTPChartPyramidSeriesPointView object.

Parameters
pPoint | Pointer to chart series point.
pParentView | Parent element view pointer.
bAddToParent | If TRUE the view will be be added to parent's child view list.

Member Function Documentation

◆ CalculateLayout()

void CalculateLayout | ( | int | nIndex,
 |  | int | nCount,
 |  | double | dFrom,
 |  | double | dTo )
 virtual

Use this function to calculate the layout of the pyramid series point.

Parameters
nIndex | Point index.
nCount | Number of points.
dFrom | Point start value.
dTo | Value part point value end.

Implements CXTPChartPyramidSeriesPointViewBase.

◆ CreateDeviceCommand()

virtual CXTPChartDeviceCommand * CreateDeviceCommand ( CXTPChartDeviceContext * pDC )
protectedvirtual

This function creates a CXTPChartDeviceCommand object.

This object represents the rendering of the pyramid series point.

Parameters
pDC Pointer to a CXTPChartDeviceContext object.
Returns
Returns a CXTPChartDeviceCommand object. This object handles the rendering of an element in the chart. Here it handles the drawing of the pyramid series point.

Implements CXTPChartPyramidSeriesPointViewBase.

The documentation for this class was generated from the following file:
  • XTPChart2dPyramidSeriesPointView.h


Toolkit Pro: CXTPChartPyramidSeriesPointViewBase Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPChartPyramidSeriesPointViewBase Class Referenceabstract

This class abstracts the view of a pyramid series point. More...

Inheritance diagram for CXTPChartPyramidSeriesPointViewBase:
[legend]

Public Member Functions

CXTPChartPyramidSeriesPointViewBase (CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Constructs a CXTPChartPyramidSeriesPointViewBase object.
CXTPChartPyramidSeriesPointViewBase (CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView, BOOL bAddToParent)
Constructs a CXTPChartPyramidSeriesPointViewBase object.
virtual | ~CXTPChartPyramidSeriesPointViewBase ()
Destroys a CXTPChartPyramidSeriesPointViewBase object, handles cleanup.
virtual void | CalculateLayout (int nIndex, int nCount, double dFrom, double dTo)=0
Use this function to calculate the layout of the pyramid series point.
CXTPChartColor | GetBorderActualColor () const
Use this function to obtain the color value of the pyramid border.
- Public Member Functions inherited from CXTPChartSeriesPointView
CXTPChartSeriesPointView (CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Constructs the view object.
CXTPChartSeriesPointView (CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView, BOOL bAddToParent)
Constructs the view object.
CXTPChartSeriesPoint * | GetPoint () const
Obtains point model object.
CXTPChartSeriesView * | GetSeriesView () const
Obtains parent series view.
CXTPChartColor | GetColor () const
Obtain view color values.
CXTPChartColor | GetColor2 () const
Obtain view color values.
double | GetInternalValue () const
Obtains point interval value.
virtual CXTPChartString | GetLegendName () const
This function returns the legend name.
virtual void | UpdateMinMaxRange (double &nMinValue, double &nMaxValue) const
Provides a default empty implementation for min/max range update request.
- Public Member Functions inherited from CXTPChartElementView
CXTPChartElementView (CXTPChartElementView *pParentView)
Constructs a CXTPChartElementView object.
CXTPChartElementView (CXTPChartElementView *pParentView, BOOL bAddToParent)
Constructs a CXTPChartElementView object.
CXTPChartElementView (CXTPChartContainer *pContainer)
Constructs a CXTPChartElementView object.
int | GetCount () const
Call this function to get the number of child views associated with this view.
CXTPChartElementView * | GetAt (int nIndex) const
Call this function to get a child view at a particular index.
CXTPChartElementView * | GetParentView () const
Call this function to get the parent view.
CXTPChartElementView * | AddChildView (CXTPChartElementView *pChildView)
Call this function to add a child view to the current view.
CXTPChartElementView ** GetChildren ()
Provides access to the collection of children elements owned by the view.
CRect | GetBounds () const
Obtains viewed object's bound rectangle.
CRect | GetBounds (BOOL bIncludingChildren) const
Obtains viewed object's bound rectangle.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.
- Public Member Functions inherited from CXTPChartLegendItemView
virtual | ~CXTPChartLegendItemView ()
Handles object destruction.

Protected Member Functions

virtual CXTPChartDeviceCommand * | CreateDeviceCommand (CXTPChartDeviceContext *pDC)=0
This function creates a CXTPChartDeviceCommand object.
virtual CXTPChartDeviceCommand * | CreateLegendDeviceCommand (CXTPChartDeviceContext *pDC, CRect rcBounds)
This function creates a label view drawing command object.
- Protected Member Functions inherited from CXTPChartElementView
virtual | ~CXTPChartElementView ()
Destroys a CXTPChartElementView object, handles cleanup.
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.

Protected Attributes

double | m_dValue
The value of the point.
- Protected Attributes inherited from CXTPChartSeriesPointView
CXTPChartSeriesPoint * | m_pPoint
Point model object pointer.
- Protected Attributes inherited from CXTPChartElementView
CArray< CXTPChartElementView *, CXTPChartElementView * > | m_arrChildren
The child view collection.
CXTPChartElementView * | m_pParentView
The parent view.
CXTPChartContainer * | m_pContainer
The parent container.
CRect | m_rcBounds
Bounding rectangle.

Additional Inherited Members

- Public Attributes inherited from CXTPChartSeriesPointView
double m_dInternalValue
Point internal value.

Detailed Description

This class abstracts the view of a pyramid series point.

Constructor & Destructor Documentation

◆ CXTPChartPyramidSeriesPointViewBase() [1/2]

CXTPChartPyramidSeriesPointViewBase | ( | CXTPChartSeriesPoint * | pPoint,
 |  | CXTPChartElementView * | pParentView )

Constructs a CXTPChartPyramidSeriesPointViewBase object.

Parameters
pPoint | Pointer to the chart series point.
pParentView | Parent element view pointer.

◆ CXTPChartPyramidSeriesPointViewBase() [2/2]

CXTPChartPyramidSeriesPointViewBase | ( | CXTPChartSeriesPoint * | pPoint,
 |  | CXTPChartElementView * | pParentView,
 |  | BOOL | bAddToParent )

Constructs a CXTPChartPyramidSeriesPointViewBase object.

Parameters
pPoint | Pointer to the chart series point.
pParentView | Parent element view pointer.
bAddToParent | If TRUE the view will be be added to parent's child view list.

Member Function Documentation

◆ CalculateLayout()

virtual void CalculateLayout | ( | int | nIndex,
 |  | int | nCount,
 |  | double | dFrom,
 |  | double | dTo )
 pure virtual

Use this function to calculate the layout of the pyramid series point.

Parameters
nIndex | Point index.
nCount | Total number of points.
dFrom | The percentage factor value in the range 0..1 of the inital pyramid point value.
dTo | The percentage factor value in the range 0..1 of the final pyramid point value.

Implemented in CXTPChart3dPyramidSeriesPointView, and CXTPChartPyramidSeriesPointView.

◆ CreateDeviceCommand()

virtual CXTPChartDeviceCommand * CreateDeviceCommand ( CXTPChartDeviceContext * pDC )
protectedpure virtual

This function creates a CXTPChartDeviceCommand object.

This object represents the rendering of the pyramid series point.

Parameters
pDC Pointer to a CXTPChartDeviceContext object.
Returns
Returns a CXTPChartDeviceCommand object. This object handles the rendering of an element in the chart. Here it handles the drawing of the pyramid series point.

Reimplemented from CXTPChartElementView.

Implemented in CXTPChart3dPyramidSeriesPointView, and CXTPChartPyramidSeriesPointView.

◆ CreateLegendDeviceCommand()

virtual CXTPChartDeviceCommand * CreateLegendDeviceCommand | ( | CXTPChartDeviceContext * | pDC,
 |  | CRect | rcBounds )
 protectedvirtual

This function creates a label view drawing command object.

Parameters
pDC | Pointer to a CXTPChartDeviceContext object.
rcBounds | The rectangular boundary of the legend.
Returns
Returns a new label view drawing command object.

Reimplemented from CXTPChartSeriesPointView.

Reimplemented in CXTPChart3dPyramidSeriesPointView.

◆ GetBorderActualColor()

CXTPChartColor GetBorderActualColor ( ) const

Use this function to obtain the color value of the pyramid border.

Returns
Border color value.
The documentation for this class was generated from the following file:
  • XTPChartPyramidSeriesPointViewBase.h


Toolkit Pro: CXTPChartPyramidSeriesStyle Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPChartPyramidSeriesStyle Class Reference

This class abstracts the basic style of a pyramid series. More...

Inheritance diagram for CXTPChartPyramidSeriesStyle:
[legend]

Public Member Functions

CXTPChartPyramidSeriesStyle ()
Constructs a CXTPChartPyramidSeriesStyle object.
- Public Member Functions inherited from CXTPChartPyramidSeriesStyleBase
CXTPChartPyramidSeriesStyleBase ()
Constructs a CXTPChartPyramidSeriesStyleBase object.
virtual | ~CXTPChartPyramidSeriesStyleBase ()
Destroys a CXTPChartPyramidSeriesStyleBase object, handles cleanup.
int | GetPointDistance () const
Gets the distance bettween stacked pyramid point (a gap).
void | SetPointDistance (int nPointDistance)
Sets the distance bettween stacked pyramid point (a gap).
double | GetHeightToWidthRatio () const
Gets the the ratio value that determines whether a pyramid looks more stretched towards its cone or if it has a wider base.
void | SetHeightToWidthRatio (double dRatio)
Sets the the ratio value that determines whether a pyramid looks more stretched towards its cone or if it has a wider base.
CXTPChartFillStyle * | GetFillStyle () const
Call this function to get the background fill style.
CXTPChartBorder * | GetBorder () const
Obtains the border object pointer.
void | DoPropExchange (CXTPPropExchange *pPX)
Call this member function to Store/Load an event using the specified data object.
- Public Member Functions inherited from CXTPChartSeriesStyle
CXTPChartSeriesStyle ()
Constructs a CXTPChartSeriesStyle object.
virtual | ~CXTPChartSeriesStyle ()
Destroys a CXTPChartSeriesStyle object, handles cleanup.
virtual CXTPChartSeriesLabel * | GetLabel () const
Call this method to gets the series label object.
virtual CXTPChartSeriesLabel * | SetLabel (CXTPChartSeriesLabel *pLabel)
Call this method to sets the series label object.
virtual CXTPChartErrorBar * | GetErrorBar () const
Call this method to gets the error bar object.
virtual CXTPChartErrorBar * | SetErrorBar (CXTPChartErrorBar *pErrorBar)
Call this method to sets the error bar object.
virtual CXTPChartColor | GetColor () const
Call this method to get the color of the series.
virtual void | SetColor (CXTPChartColor clr)
Call this method to set the color of the series.
virtual void | SetColorEach (BOOL bColorEach)
Call this method to set individual color for each point of the series.
virtual BOOL | IsColorEach () const
This method is called to check if individual color is used for each point of the series.
virtual CXTPChart3dRotation | Get3dRotation () const
Obtains rotation parameters for 3D chart.
virtual void | Set3dRotation (const CXTPChart3dRotation &rotation)
Sets rotation parameters for 3D chart.
virtual void | Set3dRotation (double dYaw, double dPitch, double dRoll)
Sets rotation parameters for 3D chart.
virtual BOOL | Is3dEdgeSmoothingEnabled () const
Enables/disables 3D edge smoothing.
virtual void | Enable3dEdgeSmoothing (BOOL bEnable=TRUE)
Enables/disables 3D edge smoothing.
virtual int | GetTransparency () const
Call this function to gets the transparency of the chart if it is supported by the chart type.
virtual void | SetTransparency (int nTransparency)
Call this function to sets the transparency of the chart if it is supported by the chart type.
virtual void | CorrectAxisSideMargins (CXTPChartAxis *pAxis, double nMinValue, double nMaxValue, double &nCorrection)
Provides default implementation for axis side margins correction.
virtual CXTPChartSeriesStyleAppearance * | GetStyleAppearance () const
Obtains associated style appearance pointer.
virtual void | ApplyTo (CXTPChartDeviceCommand *pCommand)
Applies the style to the command provided in case the command needs style specific details for correct drawing.
virtual int | GetSeriesPointValueIndex () const
Obtains the index of a point element for which an internal value can be otained.
- Public Member Functions inherited from CXTPChartElement
CXTPChartElement ()
Constructs a CXTPChartElement object.
virtual | ~CXTPChartElement ()
Destroys a CXTPChartElement object, handles cleanup.
virtual void | Release ()
Call this function to decrease the usage count of the object.
CXTPChartElement * | GetOwner () const
Call this function to get the owner element.
virtual void | OnChartChanged (XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic properties of the chart.
CXTPChartContent * | GetContent () const
Call this virtual function to get the chart content object.
CXTPChartAppearance * | GetAppearance () const
Call this function to get the the appearance of the chart.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Protected Member Functions

virtual CXTPChartDiagram * | CreateDiagram ()
Call this function to create the pyramid diagram object.
virtual CXTPChartSeriesView * | CreateView (CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Call this function to create the view of the pyramid series.
virtual BOOL | IsStyleDiagram (CXTPChartDiagram *pDiagram) const
Call this function to check whether a chart diagram object passed is a kind of CXTPChart2dPyramidDiagramBase/CXTPChart3dPyramidDiagramBase.
- Protected Member Functions inherited from CXTPChartPyramidSeriesStyleBase
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.

Additional Inherited Members

- Public Attributes inherited from CXTPChartElement
- Protected Attributes inherited from CXTPChartPyramidSeriesStyleBase
- Protected Attributes inherited from CXTPChartSeriesStyle
CXTPChartSeriesLabel * | m_pLabel
Label object.
CXTPChartErrorBar * | m_pErrorBar
Error bar object.
CXTPChartColor | m_clrColor
Custom color of series.
BOOL | m_bColorEach
TRUE to color each point.
int | m_nTransparency
The transparency value in the range 0..255.
CXTPChart3dRotation | m_Rotation3d
3D rotation
BOOL | m_bSmooth3dEdges
3D edge smoothing
- Protected Attributes inherited from CXTPChartElement

Detailed Description

This class abstracts the basic style of a pyramid series.

This class is a kind of CXTPChartSeriesStyle.

A pyramid chart (or a circle graph) is a circular chart divided into sectors, illustrating percents. In a pyramid chart, the arc length of each sector (and consequently its central angle and area), is proportional to the quantity it represents. Together, the sectors create a full disk.

Member Function Documentation

◆ CreateDiagram()

virtual CXTPChartDiagram * CreateDiagram ( )
protectedvirtual

Call this function to create the pyramid diagram object.

Returns
Returns a pointer to the associated diagram object.

Implements CXTPChartPyramidSeriesStyleBase.

◆ CreateView()

virtual CXTPChartSeriesView * CreateView | ( | CXTPChartSeries * | pSeries,
 |  | CXTPChartDiagramView * | pDiagramView )
 protectedvirtual

Call this function to create the view of the pyramid series.

Parameters
pSeries | A pointer to the chart series object.
pDiagramView | A pointer to the diagram view object.
Returns
Returns a pointer to the associated series view object.

Implements CXTPChartPyramidSeriesStyleBase.

◆ IsStyleDiagram()

virtual BOOL IsStyleDiagram ( CXTPChartDiagram * pDiagram ) const
protectedvirtual

Call this function to check whether a chart diagram object passed is a kind of CXTPChart2dPyramidDiagramBase/CXTPChart3dPyramidDiagramBase.

Parameters
pDiagram A pointer to a chart diagram whose type is to be identified.
Returns
TRUE if the chart diagram is a pyramid diagram, FALSE otherwise.

Implements CXTPChartPyramidSeriesStyleBase.

The documentation for this class was generated from the following file:
  • XTPChart2dPyramidSeriesStyle.h


Toolkit Pro: CXTPChartPyramidSeriesStyleBase Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPChartPyramidSeriesStyleBase Class Referenceabstract

This class abstracts the basic style of a pyramid series. More...

Inheritance diagram for CXTPChartPyramidSeriesStyleBase:
[legend]

Public Member Functions

CXTPChartPyramidSeriesStyleBase ()
Constructs a CXTPChartPyramidSeriesStyleBase object.
virtual | ~CXTPChartPyramidSeriesStyleBase ()
Destroys a CXTPChartPyramidSeriesStyleBase object, handles cleanup.
int | GetPointDistance () const
Gets the distance bettween stacked pyramid point (a gap).
void | SetPointDistance (int nPointDistance)
Sets the distance bettween stacked pyramid point (a gap).
double | GetHeightToWidthRatio () const
Gets the the ratio value that determines whether a pyramid looks more stretched towards its cone or if it has a wider base.
void | SetHeightToWidthRatio (double dRatio)
Sets the the ratio value that determines whether a pyramid looks more stretched towards its cone or if it has a wider base.
CXTPChartFillStyle * | GetFillStyle () const
Call this function to get the background fill style.
CXTPChartBorder * | GetBorder () const
Obtains the border object pointer.
void | DoPropExchange (CXTPPropExchange *pPX)
Call this member function to Store/Load an event using the specified data object.
- Public Member Functions inherited from CXTPChartSeriesStyle
CXTPChartSeriesStyle ()
Constructs a CXTPChartSeriesStyle object.
virtual | ~CXTPChartSeriesStyle ()
Destroys a CXTPChartSeriesStyle object, handles cleanup.
virtual CXTPChartSeriesLabel * | GetLabel () const
Call this method to gets the series label object.
virtual CXTPChartSeriesLabel * | SetLabel (CXTPChartSeriesLabel *pLabel)
Call this method to sets the series label object.
virtual CXTPChartErrorBar * | GetErrorBar () const
Call this method to gets the error bar object.
virtual CXTPChartErrorBar * | SetErrorBar (CXTPChartErrorBar *pErrorBar)
Call this method to sets the error bar object.
virtual CXTPChartColor | GetColor () const
Call this method to get the color of the series.
virtual void | SetColor (CXTPChartColor clr)
Call this method to set the color of the series.
virtual void | SetColorEach (BOOL bColorEach)
Call this method to set individual color for each point of the series.
virtual BOOL | IsColorEach () const
This method is called to check if individual color is used for each point of the series.
virtual CXTPChart3dRotation | Get3dRotation () const
Obtains rotation parameters for 3D chart.
virtual void | Set3dRotation (const CXTPChart3dRotation &rotation)
Sets rotation parameters for 3D chart.
virtual void | Set3dRotation (double dYaw, double dPitch, double dRoll)
Sets rotation parameters for 3D chart.
virtual BOOL | Is3dEdgeSmoothingEnabled () const
Enables/disables 3D edge smoothing.
virtual void | Enable3dEdgeSmoothing (BOOL bEnable=TRUE)
Enables/disables 3D edge smoothing.
virtual int | GetTransparency () const
Call this function to gets the transparency of the chart if it is supported by the chart type.
virtual void | SetTransparency (int nTransparency)
Call this function to sets the transparency of the chart if it is supported by the chart type.
virtual void | CorrectAxisSideMargins (CXTPChartAxis *pAxis, double nMinValue, double nMaxValue, double &nCorrection)
Provides default implementation for axis side margins correction.
virtual CXTPChartSeriesStyleAppearance * | GetStyleAppearance () const
Obtains associated style appearance pointer.
virtual void | ApplyTo (CXTPChartDeviceCommand *pCommand)
Applies the style to the command provided in case the command needs style specific details for correct drawing.
virtual int | GetSeriesPointValueIndex () const
Obtains the index of a point element for which an internal value can be otained.
- Public Member Functions inherited from CXTPChartElement
CXTPChartElement ()
Constructs a CXTPChartElement object.
virtual | ~CXTPChartElement ()
Destroys a CXTPChartElement object, handles cleanup.
virtual void | Release ()
Call this function to decrease the usage count of the object.
CXTPChartElement * | GetOwner () const
Call this function to get the owner element.
virtual void | OnChartChanged (XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic properties of the chart.
CXTPChartContent * | GetContent () const
Call this virtual function to get the chart content object.
CXTPChartAppearance * | GetAppearance () const
Call this function to get the the appearance of the chart.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Protected Member Functions

virtual CXTPChartDiagram * | CreateDiagram ()=0
Call this function to create the pyramid diagram object.
virtual CXTPChartSeriesView * | CreateView (CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)=0
Call this function to create the view of the pyramid series.
virtual BOOL | IsStyleDiagram (CXTPChartDiagram *pDiagram) const =0
Call this function to check whether a chart diagram object passed is a kind of CXTPChart2dPyramidDiagramBase/CXTPChart3dPyramidDiagramBase.
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.

Additional Inherited Members

- Public Attributes inherited from CXTPChartElement
- Protected Attributes inherited from CXTPChartSeriesStyle
CXTPChartSeriesLabel * | m_pLabel
Label object.
CXTPChartErrorBar * | m_pErrorBar
Error bar object.
CXTPChartColor | m_clrColor
Custom color of series.
BOOL | m_bColorEach
TRUE to color each point.
int | m_nTransparency
The transparency value in the range 0..255.
CXTPChart3dRotation | m_Rotation3d
3D rotation
BOOL | m_bSmooth3dEdges
3D edge smoothing
- Protected Attributes inherited from CXTPChartElement

Detailed Description

This class abstracts the basic style of a pyramid series.

Member Function Documentation

◆ CreateDiagram()

virtual CXTPChartDiagram * CreateDiagram ( )
protectedpure virtual

Call this function to create the pyramid diagram object.

Returns
A pointer to CXTPChartDiagram object which points to a newly created CXTPChart2dPyramidDiagramBase/CXTPChart3dPyramidDiagramBase object.

Reimplemented from CXTPChartSeriesStyle.

Implemented in CXTPChart3dPyramidSeriesStyle, and CXTPChartPyramidSeriesStyle.

◆ CreateView()

virtual CXTPChartSeriesView * CreateView | ( | CXTPChartSeries * | pSeries,
 |  | CXTPChartDiagramView * | pDiagramView )
 protectedpure virtual

Call this function to create the view of the pyramid series.

Parameters
pSeries | A pointer to the chart series object.
pDiagramView | A pointer to the diagram view object.
Returns
Returns a pointer to the associated series view object.

Implements CXTPChartSeriesStyle.

Implemented in CXTPChart3dPyramidSeriesStyle, and CXTPChartPyramidSeriesStyle.

◆ DoPropExchange()

void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Call this member function to Store/Load an event using the specified data object.

Parameters
pPX Source or destination CXTPPropExchange data object reference.

This member function is used to store event data to or load event data from storage.

Reimplemented from CXTPChartSeriesStyle.

◆ GetBorder()

AFX_INLINE CXTPChartBorder * GetBorder ( ) const

Obtains the border object pointer.

Returns
Associated border object pointer.

◆ GetFillStyle()

AFX_INLINE CXTPChartFillStyle * GetFillStyle ( ) const

Call this function to get the background fill style.

Returns
Returns the pointer to a CXTPChartFillStyle object, which abstracts various fill styles.

◆ GetHeightToWidthRatio()

AFX_INLINE double GetHeightToWidthRatio ( ) const

Gets the the ratio value that determines whether a pyramid looks more stretched towards its cone or if it has a wider base.

If the ratio value is less than 1, then the pyramid's base is wider than its height. If the ratio value is greater than 1, then the pyramid's base width is less than pyramid's height, making tall and acute.

Returns
Current ratio value.

◆ GetPointDistance()

AFX_INLINE int GetPointDistance ( ) const

Gets the distance bettween stacked pyramid point (a gap).

Returns
Current distance value in pixels.

◆ IsStyleDiagram()

virtual BOOL IsStyleDiagram ( CXTPChartDiagram * pDiagram ) const
protectedpure virtual

Call this function to check whether a chart diagram object passed is a kind of CXTPChart2dPyramidDiagramBase/CXTPChart3dPyramidDiagramBase.

Parameters
pDiagram A pointer to a chart diagram, whose type is to be identified.
Returns
TRUE if the chart diagram is a pyramid diagram, FALSE otherwise.

Reimplemented from CXTPChartSeriesStyle.

Implemented in CXTPChart3dPyramidSeriesStyle, and CXTPChartPyramidSeriesStyle.

◆ SetHeightToWidthRatio()

AFX_INLINE void SetHeightToWidthRatio ( double dRatio )

Sets the the ratio value that determines whether a pyramid looks more stretched towards its cone or if it has a wider base.

If the ratio value is less than 1, then the pyramid's base is wider than its height. If the ratio value is greater than 1, then the pyramid's base width is less than pyramid's height, making tall and acute.

Parameters
dRatio A new ratio value.

◆ SetPointDistance()

AFX_INLINE void SetPointDistance ( int nPointDistance )

Sets the distance bettween stacked pyramid point (a gap).

Parameters
nPointDistance Distance value in pixels.
The documentation for this class was generated from the following file:
  • XTPChartPyramidSeriesStyleBase.h


Toolkit Pro: CXTPChartPyramidSeriesView Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPChartPyramidSeriesView Class Reference

This class abstracts the view of a pyramid series. More...

Inheritance diagram for CXTPChartPyramidSeriesView:
[legend]

Public Member Functions

CXTPChartPyramidSeriesView (CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Constructs a CXTPChartPyramidSeriesView object.
virtual void | CalculatePointLayout (CXTPChartDeviceContext *pDC, CRect rcBounds)
Call this function to calculate the pyramid series point layout.
virtual CXTPChartDeviceCommand * | CreateLegendDeviceCommand (CXTPChartDeviceContext *pDC, CRect rcBounds, CXTPChartColor color1, CXTPChartColor color2, CXTPChartColor clrBorder)
This function creates a label view drawing command object.
- Public Member Functions inherited from CXTPChartPyramidSeriesViewBase
CXTPChartPyramidSeriesViewBase (CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Constructs a CXTPChartPyramidSeriesViewBase object.
virtual | ~CXTPChartPyramidSeriesViewBase ()
Destroys a CXTPChartPyramidSeriesViewBase object, handles cleanup.
void | CalculateLabelLayout (CXTPChartDeviceContext *pDC)
Call this function to calculate the pyramid series label layout.
virtual CXTPChartDiagramDomain * | CreateDiagramDomain (CXTPChartDeviceContext *pDC, CRect rcBounds)
Call this function to create the pyramid diagram domain object associated with this object.
CXTPChartDiagramDomain * | GetDomain () const
Use this function to get the pyramid diagram domain object associated with this object.
int | GetMaxLabelWidth () const
Obtains the maximum allowed label width.

Protected Member Functions

virtual CXTPChartRectF | GetInnerBounds () const
Call this function to get the inner bounds of the diagram.
virtual CXTPChartSeriesPointView * | CreateSeriesPointView (CXTPChartDeviceContext *pDC, CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Use this function to create the pyramid series point view object.
virtual CXTPChartDeviceCommand * | CreateDeviceCommand (CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
virtual CXTPChartDeviceCommand * | CreateLegendDeviceCommand (CXTPChartDeviceContext *pDC, CRect rcBounds)
This function creates a label view drawing command object.
- Protected Member Functions inherited from CXTPChartPyramidSeriesViewBase

Additional Inherited Members

- Protected Attributes inherited from CXTPChartPyramidSeriesViewBase
CXTPChartDiagramDomain * m_pDomain
Pointer to the diagram domain.

Detailed Description

This class abstracts the view of a pyramid series.

This class is a kind of CXTPChartSeriesView.

A pyramid chart (or a circle graph) is a circular chart divided into sectors, illustrating percents. In a pyramid chart, the arc length of each sector (and consequently its central angle and area), is proportional to the quantity it represents. Together, the sectors create a full disk.

Constructor & Destructor Documentation

◆ CXTPChartPyramidSeriesView()

CXTPChartPyramidSeriesView | ( | CXTPChartSeries * | pSeries,
 |  | CXTPChartDiagramView * | pDiagramView )

Constructs a CXTPChartPyramidSeriesView object.

Parameters
pSeries | Pointer to the pyramid series object.
pDiagramView | Pointer to the pyramid diagram view.

Member Function Documentation

◆ CalculatePointLayout()

virtual void CalculatePointLayout | ( | CXTPChartDeviceContext * | pDC,
 |  | CRect | rcBounds )
 virtual

Call this function to calculate the pyramid series point layout.

Parameters
pDC | Pointer to the chart device context.
rcBounds | The rectangular boundary.

Implements CXTPChartPyramidSeriesViewBase.

◆ CreateDeviceCommand()

virtual CXTPChartDeviceCommand * CreateDeviceCommand ( CXTPChartDeviceContext * pDC )
protectedvirtual

This function creates a CXTPChartDeviceCommand object.

This object represents the rendering of the pyramid series.

Parameters
pDC Pointer to a CXTPChartDeviceContext object.
Returns
Returns a CXTPChartDeviceCommand object. This object handles the rendering of an element in the chart. Here it handles the drawing of the pyramid series.

Implements CXTPChartPyramidSeriesViewBase.

◆ CreateLegendDeviceCommand() [1/2]

virtual CXTPChartDeviceCommand * CreateLegendDeviceCommand | ( | CXTPChartDeviceContext * | pDC,
 |  | CRect | rcBounds )
 protectedvirtual

This function creates a label view drawing command object.

Parameters
pDC | Pointer to a CXTPChartDeviceContext object.
rcBounds | The rectangular boundary of the legend.
Returns
Returns a new label view drawing command object.

Implements CXTPChartPyramidSeriesViewBase.

◆ CreateLegendDeviceCommand() [2/2]

virtual CXTPChartDeviceCommand * CreateLegendDeviceCommand | ( | CXTPChartDeviceContext * | pDC,
 |  | CRect | rcBounds,
 |  | CXTPChartColor | color1,
 |  | CXTPChartColor | color2,
 |  | CXTPChartColor | clrBorder )
 virtual

This function creates a label view drawing command object.

Parameters
pDC | Pointer to a CXTPChartDeviceContext object.
rcBounds | The rectangular boundary of the legend.
color1 | 1-st gradient fill color.
color2 | 2-nd gradient fill color.
clrBorder | Border color.
Returns
Returns a new label view drawing command object.

Implements CXTPChartPyramidSeriesViewBase.

◆ CreateSeriesPointView()

virtual CXTPChartSeriesPointView * CreateSeriesPointView | ( | CXTPChartDeviceContext * | pDC,
 |  | CXTPChartSeriesPoint * | pPoint,
 |  | CXTPChartElementView * | pParentView )
 protectedvirtual

Use this function to create the pyramid series point view object.

Parameters
pDC | Pointer to the chart device context.
pPoint | Pointer to the chart series point.
pParentView | Parent element view pointer.
Returns
A pointer to the chart series point view.

Implements CXTPChartPyramidSeriesViewBase.

◆ GetInnerBounds()

virtual CXTPChartRectF GetInnerBounds ( ) const
protectedvirtual

Call this function to get the inner bounds of the diagram.

Returns
A chart rect object denoting the rectangular boundary.

Reimplemented from CXTPChartPyramidSeriesViewBase.

The documentation for this class was generated from the following file:
  • XTPChart2dPyramidSeriesView.h


Toolkit Pro: CXTPChartPyramidSeriesViewBase Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPChartPyramidSeriesViewBase Class Referenceabstract

This class abstracts the view of a pyramid series. More...

Inheritance diagram for CXTPChartPyramidSeriesViewBase:
[legend]

Public Member Functions

CXTPChartPyramidSeriesViewBase (CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Constructs a CXTPChartPyramidSeriesViewBase object.
virtual | ~CXTPChartPyramidSeriesViewBase ()
Destroys a CXTPChartPyramidSeriesViewBase object, handles cleanup.
virtual void | CalculatePointLayout (CXTPChartDeviceContext *pDC, CRect rcBounds)=0
Call this function to calculate the pyramid series point layout.
void | CalculateLabelLayout (CXTPChartDeviceContext *pDC)
Call this function to calculate the pyramid series label layout.
virtual CXTPChartDiagramDomain * | CreateDiagramDomain (CXTPChartDeviceContext *pDC, CRect rcBounds)
Call this function to create the pyramid diagram domain object associated with this object.
virtual CXTPChartRectF | GetInnerBounds () const
Call this function to get the inner bounds of the diagram.
CXTPChartDiagramDomain * | GetDomain () const
Use this function to get the pyramid diagram domain object associated with this object.
int | GetMaxLabelWidth () const
Obtains the maximum allowed label width.
virtual CXTPChartDeviceCommand * | CreateLegendDeviceCommand (CXTPChartDeviceContext *pDC, CRect rcBounds, CXTPChartColor color1, CXTPChartColor color2, CXTPChartColor clrBorder)=0
These functions create a label view drawing command object.

Protected Member Functions

virtual CXTPChartSeriesPointView * | CreateSeriesPointView (CXTPChartDeviceContext *pDC, CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)=0
Use this function to create the pyramid series point view object.
virtual CXTPChartDeviceCommand * | CreateDeviceCommand (CXTPChartDeviceContext *pDC)=0
This function creates a CXTPChartDeviceCommand object.
virtual CXTPChartDeviceCommand * | CreateLegendDeviceCommand (CXTPChartDeviceContext *pDC, CRect rcBounds)=0
These functions create a label view drawing command object.

Protected Attributes

CXTPChartDiagramDomain * m_pDomain
Pointer to the diagram domain.

Detailed Description

This class abstracts the view of a pyramid series.

Constructor & Destructor Documentation

◆ CXTPChartPyramidSeriesViewBase()

CXTPChartPyramidSeriesViewBase | ( | CXTPChartSeries * | pSeries,
 |  | CXTPChartDiagramView * | pDiagramView )

Constructs a CXTPChartPyramidSeriesViewBase object.

Parameters
pSeries | Pointer to the pyramid series object.
pDiagramView | Pointer to the pyramid diagram view.

Member Function Documentation

◆ CalculateLabelLayout()

void CalculateLabelLayout ( CXTPChartDeviceContext * pDC )

Call this function to calculate the pyramid series label layout.

Parameters
pDC Pointer to the chart device context.

◆ CalculatePointLayout()

virtual void CalculatePointLayout | ( | CXTPChartDeviceContext * | pDC,
 |  | CRect | rcBounds )
 pure virtual

Call this function to calculate the pyramid series point layout.

Parameters
pDC | Pointer to the chart device context.
rcBounds | The rectangular boundary.

Implemented in CXTPChart3dPyramidSeriesView, and CXTPChartPyramidSeriesView.

◆ CreateDeviceCommand()

virtual CXTPChartDeviceCommand * CreateDeviceCommand ( CXTPChartDeviceContext * pDC )
protectedpure virtual

This function creates a CXTPChartDeviceCommand object.

This object represents the rendering of the pyramid series.

Parameters
pDC Pointer to a CXTPChartDeviceContext object.
Returns
Returns a CXTPChartDeviceCommand object. This object handles the rendering of an element in the chart. Here it handles the drawing of the pyramid series.

Reimplemented from CXTPChartElementView.

Implemented in CXTPChart3dPyramidSeriesView, and CXTPChartPyramidSeriesView.

◆ CreateDiagramDomain()

virtual CXTPChartDiagramDomain * CreateDiagramDomain | ( | CXTPChartDeviceContext * | pDC,
 |  | CRect | rcBounds )
 virtual

Call this function to create the pyramid diagram domain object associated with this object.

Parameters
pDC | Pointer to the chart device context.
rcBounds | The rectangular boundary of the diagram.
Returns
A pointer to the chart diagram domain object.

◆ CreateLegendDeviceCommand() [1/2]

virtual CXTPChartDeviceCommand * CreateLegendDeviceCommand | ( | CXTPChartDeviceContext * | pDC,
 |  | CRect | rcBounds )
 protectedpure virtual

These functions create a label view drawing command object.

Parameters
pDC | Pointer to a CXTPChartDeviceContext object.
rcBounds | The rectangular boundary of the legend.
Returns
Returns a new label view drawing command object.

Implements CXTPChartLegendItemView.

Implemented in CXTPChart3dPyramidSeriesView, and CXTPChartPyramidSeriesView.

◆ CreateLegendDeviceCommand() [2/2]

virtual CXTPChartDeviceCommand * CreateLegendDeviceCommand | ( | CXTPChartDeviceContext * | pDC,
 |  | CRect | rcBounds,
 |  | CXTPChartColor | color1,
 |  | CXTPChartColor | color2,
 |  | CXTPChartColor | clrBorder )
 pure virtual

These functions create a label view drawing command object.

Parameters
pDC | Pointer to a CXTPChartDeviceContext object.
rcBounds | The rectangular boundary of the legend.
color1 | 1-st gradient fill color.
color2 | 2-nd gradient fill color.
clrBorder | Border color.
Returns
Returns a new label view drawing command object.

Implemented in CXTPChart3dPyramidSeriesView, and CXTPChartPyramidSeriesView.

◆ CreateSeriesPointView()

virtual CXTPChartSeriesPointView * CreateSeriesPointView | ( | CXTPChartDeviceContext * | pDC,
 |  | CXTPChartSeriesPoint * | pPoint,
 |  | CXTPChartElementView * | pParentView )
 protectedpure virtual

Use this function to create the pyramid series point view object.

Parameters
pDC | Pointer to the chart device context.
pPoint | Pointer to the chart series point.
pParentView | Parent element view pointer.
Returns
A pointer to the chart series point view.

Implemented in CXTPChart3dPyramidSeriesView, and CXTPChartPyramidSeriesView.

◆ GetDomain()

AFX_INLINE CXTPChartDiagramDomain * GetDomain ( ) const

Use this function to get the pyramid diagram domain object associated with this object.

Returns
A pointer to the chart diagram domain object.

◆ GetInnerBounds()

virtual CXTPChartRectF GetInnerBounds ( ) const
virtual

Call this function to get the inner bounds of the diagram.

Returns
A chart rect object denoting the rectangular boundary.

Reimplemented in CXTPChartPyramidSeriesView.

◆ GetMaxLabelWidth()

AFX_INLINE int GetMaxLabelWidth ( ) const

Obtains the maximum allowed label width.

Returns
Maximum allowed label width.
The documentation for this class was generated from the following file:
  • XTPChartPyramidSeriesViewBase.h


Toolkit Pro: CXTPChartQualitativeScaleTypeMap Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPChartQualitativeScaleTypeMap Class Reference

This class abstracts a scale type map, which represents qualitative values. More...

Inheritance diagram for CXTPChartQualitativeScaleTypeMap:
[legend]

Public Member Functions

CXTPChartQualitativeScaleTypeMap (CXTPChartAxis *pAxis)
Constructs a CXTPChartQualitativeScaleTypeMap object.
virtual | ~CXTPChartQualitativeScaleTypeMap ()
Destroys a CXTPChartQualitativeScaleTypeMap object, handles cleanup.
virtual CXTPChartString | InternalToValue (CXTPChartNumberFormat *pFromat, double dValue) const
Use this function to convert a double value to a string.
virtual double | ValueToInternal (const CXTPChartString &strValue) const
Use this function to convert a value string to an internal type.
virtual void | UpdateSeries (CXTPChartAxisView *pAxisView)
Call this function when there is a change in the values of the series or a change in the scale.
- Public Member Functions inherited from CXTPChartScaleTypeMap
CXTPChartScaleTypeMap (CXTPChartAxis *pAxis)
Constructs a CXTPChartScaleTypeMap object.
virtual | ~CXTPChartScaleTypeMap ()
Destroys a CXTPChartScaleTypeMap object, handles cleanup.
CXTPChartAxis * | GetAxis () const
Call this function to get the axis object to which this object is associated with.
- Public Member Functions inherited from CXTPChartElement
CXTPChartElement ()
Constructs a CXTPChartElement object.
virtual | ~CXTPChartElement ()
Destroys a CXTPChartElement object, handles cleanup.
virtual void | Release ()
Call this function to decrease the usage count of the object.
CXTPChartElement * | GetOwner () const
Call this function to get the owner element.
virtual void | OnChartChanged (XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic properties of the chart.
CXTPChartContent * | GetContent () const
Call this virtual function to get the chart content object.
CXTPChartAppearance * | GetAppearance () const
Call this function to get the the appearance of the chart.
virtual void | DoPropExchange (CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Protected Member Functions

void | UpdateSeries (CXTPChartSeries *pSeries)
Call this function when there is a change in the values of the series or a change in the scale.
void | UpdateSeriesPointArgument (CXTPChartSeriesPoint *pPoint)
Call this function to update a point argument in a series point.
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.

Protected Attributes

double | m_dMinValue
The minimum value.
double | m_dMaxValue
The maximum value.
CStorage * | m_pStorage
The storage.
- Protected Attributes inherited from CXTPChartElement

Additional Inherited Members

- Static Public Member Functions inherited from CXTPChartScaleTypeMap
static CXTPChartScaleTypeMap *AFX_CDECL Create (CXTPChartAxis *pAxis)
Call this function to create a scale type map object.
- Public Attributes inherited from CXTPChartElement

Detailed Description

This class abstracts a scale type map, which represents qualitative values.

This class is a kind of CXTPChartScaleTypeMap.

Constructor & Destructor Documentation

◆ CXTPChartQualitativeScaleTypeMap()

CXTPChartQualitativeScaleTypeMap ( CXTPChartAxis * pAxis )

Constructs a CXTPChartQualitativeScaleTypeMap object.

Parameters
pAxis Pointer to the associated chart axis object.

Member Function Documentation

◆ InternalToValue()

virtual CXTPChartString InternalToValue | ( | CXTPChartNumberFormat * | pFromat,
 |  | double | dValue ) const
 virtual

Use this function to convert a double value to a string.

This actually converts the internal representation of data to a more meaningful value.

Parameters
pFromat | Conversion format to use.
dValue | Value to format.
Returns
A CXTPChartString object representing the string value.

Implements CXTPChartScaleTypeMap.

◆ UpdateSeries() [1/2]

virtual void UpdateSeries ( CXTPChartAxisView * pAxisView )
virtual

Call this function when there is a change in the values of the series or a change in the scale.

Parameters
pAxisView Pointer to a CXTPChartAxisView object.

Reimplemented from CXTPChartScaleTypeMap.

◆ UpdateSeries() [2/2]

void UpdateSeries ( CXTPChartSeries * pSeries )
protectedvirtual

Call this function when there is a change in the values of the series or a change in the scale.

Parameters
pSeries A pointer to the chart series object.

Reimplemented from CXTPChartScaleTypeMap.

◆ UpdateSeriesPointArgument()

void UpdateSeriesPointArgument ( CXTPChartSeriesPoint * pPoint )
protectedvirtual

Call this function to update a point argument in a series point.

Parameters
pPoint A pointer to the chart series point object.

Reimplemented from CXTPChartScaleTypeMap.

◆ ValueToInternal()

virtual double ValueToInternal ( const CXTPChartString & strValue ) const
virtual

Use this function to convert a value string to an internal type.

Parameters
strValue Value to be set.
Returns
A double representing the internal value.

Implements CXTPChartScaleTypeMap.

The documentation for this class was generated from the following file:
  • XTPChartScaleTypeMap.h


Toolkit Pro: CXTPChartRadarAreaSeriesStyle Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPChartRadarAreaSeriesStyle Class Reference

This class represents a line series style, which is a kind of CXTPChartSeriesStyle. More...

Inheritance diagram for CXTPChartRadarAreaSeriesStyle:
[legend]

Public Member Functions

CXTPChartRadarAreaSeriesStyle ()
Constructs a CXTPChartRadarAreaSeriesStyle object.
virtual | ~CXTPChartRadarAreaSeriesStyle ()
Destroys a CXTPChartRadarAreaSeriesStyle object, handles cleanup.
void | DoPropExchange (CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
CXTPChartFillStyle * | GetFillStyle () const
Call this function to get the background fill style.
int | GetTransparency () const
Call this function to get the transparency of the filled area with respect to the background.
void | SetTransparency (int nTransparency)
Call this function to set the transparency of the filled area with respect to the background.
- Public Member Functions inherited from CXTPChartRadarPointSeriesStyle
CXTPChartRadarPointSeriesStyle ()
Constructs a CXTPChartRadarPointSeriesStyle object.
virtual | ~CXTPChartRadarPointSeriesStyle ()
Destroys a CXTPChartRadarPointSeriesStyle object, handles cleanup.
CXTPChartMarker * | GetMarker () const
Call this function to get the marker object associated with this CXTPChartRadarPointSeriesStyle object.
void | DoPropExchange (CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
- Public Member Functions inherited from CXTPChartRadarDiagramSeriesStyle
CXTPChartRadarDiagramSeriesStyle ()
Constructs a CXTPChartRadarDiagramSeriesStyle object.
virtual | ~CXTPChartRadarDiagramSeriesStyle ()
Destroys a CXTPChartRadarDiagramSeriesStyle object, handles cleanup.
virtual CXTPChartDiagram * | CreateDiagram ()
Call this function to create the diagram for this series.
virtual BOOL | IsStyleDiagram (CXTPChartDiagram *pDiagram) const
Call this function to check whether the chart diagram object passed is a kind of 2D diagram (CXTPChartDiagram2D object).
- Public Member Functions inherited from CXTPChartSeriesStyle
CXTPChartSeriesStyle ()
Constructs a CXTPChartSeriesStyle object.
virtual | ~CXTPChartSeriesStyle ()
Destroys a CXTPChartSeriesStyle object, handles cleanup.
virtual CXTPChartSeriesLabel * | GetLabel () const
Call this method to gets the series label object.
virtual CXTPChartSeriesLabel * | SetLabel (CXTPChartSeriesLabel *pLabel)
Call this method to sets the series label object.
virtual CXTPChartErrorBar * | GetErrorBar () const
Call this method to gets the error bar object.
virtual CXTPChartErrorBar * | SetErrorBar (CXTPChartErrorBar *pErrorBar)
Call this method to sets the error bar object.
virtual CXTPChartColor | GetColor () const
Call this method to get the color of the series.
virtual void | SetColor (CXTPChartColor clr)
Call this method to set the color of the series.
virtual void | SetColorEach (BOOL bColorEach)
Call this method to set individual color for each point of the series.
virtual BOOL | IsColorEach () const
This method is called to check if individual color is used for each point of the series.
virtual CXTPChart3dRotation | Get3dRotation () const
Obtains rotation parameters for 3D chart.
virtual void | Set3dRotation (const CXTPChart3dRotation &rotation)
Sets rotation parameters for 3D chart.
virtual void | Set3dRotation (double dYaw, double dPitch, double dRoll)
Sets rotation parameters for 3D chart.
virtual BOOL | Is3dEdgeSmoothingEnabled () const
Enables/disables 3D edge smoothing.
virtual void | Enable3dEdgeSmoothing (BOOL bEnable=TRUE)
Enables/disables 3D edge smoothing.
virtual void | CorrectAxisSideMargins (CXTPChartAxis *pAxis, double nMinValue, double nMaxValue, double &nCorrection)
Provides default implementation for axis side margins correction.
virtual CXTPChartSeriesStyleAppearance * | GetStyleAppearance () const
Obtains associated style appearance pointer.
virtual void | ApplyTo (CXTPChartDeviceCommand *pCommand)
Applies the style to the command provided in case the command needs style specific details for correct drawing.
virtual int | GetSeriesPointValueIndex () const
Obtains the index of a point element for which an internal value can be otained.
- Public Member Functions inherited from CXTPChartElement
CXTPChartElement ()
Constructs a CXTPChartElement object.
virtual | ~CXTPChartElement ()
Destroys a CXTPChartElement object, handles cleanup.
virtual void | Release ()
Call this function to decrease the usage count of the object.
CXTPChartElement * | GetOwner () const
Call this function to get the owner element.
virtual void | OnChartChanged (XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic properties of the chart.
CXTPChartContent * | GetContent () const
Call this virtual function to get the chart content object.
CXTPChartAppearance * | GetAppearance () const
Call this function to get the the appearance of the chart.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Protected Member Functions

virtual CXTPChartSeriesView * CreateView (CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Call this function to create a view of the point series.
- Protected Member Functions inherited from CXTPChartRadarPointSeriesStyle
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.

Protected Attributes

int | m_nTransparency
The transparency values range from 0 to 255.
CXTPChartBorder * | m_pBorder
The chart border object pointer.
CXTPChartFillStyle * | m_pFillStyle
The chart background fill style.
- Protected Attributes inherited from CXTPChartRadarPointSeriesStyle
- Protected Attributes inherited from CXTPChartSeriesStyle
CXTPChartSeriesLabel * | m_pLabel
Label object.
CXTPChartErrorBar * | m_pErrorBar
Error bar object.
CXTPChartColor | m_clrColor
Custom color of series.
BOOL | m_bColorEach
TRUE to color each point.
int | m_nTransparency
The transparency value in the range 0..255.
CXTPChart3dRotation | m_Rotation3d
3D rotation
BOOL | m_bSmooth3dEdges
3D edge smoothing
- Protected Attributes inherited from CXTPChartElement

Detailed Description

This class represents a line series style, which is a kind of CXTPChartSeriesStyle.

A point chart is a type of graph which displays information as a series of data points. It is a basic type of chart common in many fields.

Member Function Documentation

◆ CreateView()

virtual CXTPChartSeriesView * CreateView | ( | CXTPChartSeries * | pSeries,
 |  | CXTPChartDiagramView * | pDiagramView )
 protectedvirtual

Call this function to create a view of the point series.

Parameters
pSeries | A pointer to the chart series object.
pDiagramView | A pointer to the diagram view object.
Returns
Returns a pointer to the associated series view object.

Reimplemented from CXTPChartRadarPointSeriesStyle.

Reimplemented in CXTPChartRadarSplineAreaSeriesStyle.

◆ DoPropExchange()

void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Reads this object from or writes this object to an archive.

Parameters
pPX A CXTPPropExchange object to serialize to or from.

Reimplemented from CXTPChartSeriesStyle.

◆ GetFillStyle()

AFX_INLINE CXTPChartFillStyle * GetFillStyle ( ) const

Call this function to get the background fill style.

Returns
Returns the pointer to a CXTPChartFillStyle object, which abstracts various fill styles.

◆ GetTransparency()

AFX_INLINE int GetTransparency ( ) const
virtual

Call this function to get the transparency of the filled area with respect to the background.

Returns
Returns an integer whose values are from 0 to 255.

A value of 0 means fully transparent and 255 means fully opaque.

Reimplemented from CXTPChartSeriesStyle.

◆ SetTransparency()

AFX_INLINE void SetTransparency ( int nTransparency )
virtual

Call this function to set the transparency of the filled area with respect to the background.

Parameters
nTransparency an integer whose values are from 0 to 255.

A value of 0 means fully transparent and 255 means fully opaque.

Reimplemented from CXTPChartSeriesStyle.

The documentation for this class was generated from the following file:
  • XTPChartRadarAreaSeriesStyle.h


Toolkit Pro: CXTPChartRadarAreaSeriesView Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPChartRadarAreaSeriesView Class Reference

This class represents the view of a point series, which is a kind of CXTPChartSeriesView. More...

Inheritance diagram for CXTPChartRadarAreaSeriesView:
[legend]

Public Member Functions

CXTPChartRadarAreaSeriesView (CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Constructs a CXTPChartPointSeriesView object.
CXTPChartColor | GetActualColor () const
Call this function to get the actual color of the series.
CXTPChartColor | GetActualColor2 () const
Call this function to get the second actual color of the series.
CXTPChartColor | GetBorderActualColor () const
Call this function to get the actual color of the series border.
virtual CXTPChartDeviceCommand * | CreateLegendDeviceCommand (CXTPChartDeviceContext *pDC, CRect rcBounds)
This function creates a label view drawing command object.

Protected Member Functions

CXTPChartSeriesPointView * | CreateSeriesPointView (CXTPChartDeviceContext *pDC, CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Call this function to create a view of the series points.
virtual CXTPChartDeviceCommand * | CreateDeviceCommand (CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.

Detailed Description

This class represents the view of a point series, which is a kind of CXTPChartSeriesView.

Constructor & Destructor Documentation

◆ CXTPChartRadarAreaSeriesView()

CXTPChartRadarAreaSeriesView | ( | CXTPChartSeries * | pSeries,
 |  | CXTPChartDiagramView * | pDiagramView )

Constructs a CXTPChartPointSeriesView object.

Parameters
pSeries | A pointer to the chart series object.
pDiagramView | A pointer to the diagram view object.

Member Function Documentation

◆ CreateDeviceCommand()

virtual CXTPChartDeviceCommand * CreateDeviceCommand ( CXTPChartDeviceContext * pDC )
protectedvirtual

This function creates a CXTPChartDeviceCommand object.

This object represents the rendering of the chart element.

Parameters
pDC Pointer to a CXTPChartDeviceContext object.
Returns
Returns a CXTPChartDeviceCommand object. This object handles the rendering of an element in the chart. Derived class objects will return more specific device command objects according to their type.

This is a virtual function, so sub-classes can override this function and can give specific implementations according to their type.

Reimplemented from CXTPChartElementView.

Reimplemented in CXTPChartRadarSplineAreaSeriesView.

◆ CreateLegendDeviceCommand()

virtual CXTPChartDeviceCommand * CreateLegendDeviceCommand | ( | CXTPChartDeviceContext * | pDC,
 |  | CRect | rcBounds )
 virtual

This function creates a label view drawing command object.

Parameters
pDC | Pointer to a CXTPChartDeviceContext object.
rcBounds | The rectangular boundary of the legend.
Returns
Returns a new label view drawing command object.

Implements CXTPChartLegendItemView.

◆ CreateSeriesPointView()

CXTPChartSeriesPointView * CreateSeriesPointView | ( | CXTPChartDeviceContext * | pDC,
 |  | CXTPChartSeriesPoint * | pPoint,
 |  | CXTPChartElementView * | pParentView )
 protected

Call this function to create a view of the series points.

Parameters
pDC | A pointer to the chart device context.
pPoint | A pointer to the chart series point object.
pParentView | Parent view pointer.
Returns
Returns a pointer to the chart series point view object.

◆ GetActualColor()

CXTPChartColor GetActualColor ( ) const

Call this function to get the actual color of the series.

Returns
Returns the CXTPChartColor object representing an ARGB value.

◆ GetActualColor2()

CXTPChartColor GetActualColor2 ( ) const

Call this function to get the second actual color of the series.

Returns
Returns the CXTPChartColor object representing an ARGB value.

◆ GetBorderActualColor()

CXTPChartColor GetBorderActualColor ( ) const

Call this function to get the actual color of the series border.

Returns
Returns the CXTPChartColor object representing an ARGB value.
The documentation for this class was generated from the following file:
  • XTPChartRadarAreaSeriesView.h


Toolkit Pro: CXTPChartRadarAxisView Class Reference

Public Member Functions | List of all members
CXTPChartRadarAxisView Class Referenceabstract

This class abstracts the view of a chart axis and its child items in a bounding rectangle context. More...

Inheritance diagram for CXTPChartRadarAxisView:
[legend]

Public Member Functions

CXTPChartRadarAxisView (CXTPChartAxis *pAxis, CXTPChartElementView *pParentView)
Constructs a CXTPChartRadarAxisView object.
~CXTPChartRadarAxisView ()
Destroys a CXTPChartRadarAxisView object, handles cleanup and deallocation.

Detailed Description

This class abstracts the view of a chart axis and its child items in a bounding rectangle context.

Constructor & Destructor Documentation

◆ CXTPChartRadarAxisView()

AFX_INLINE CXTPChartRadarAxisView | ( | CXTPChartAxis * | pAxis,
 |  | CXTPChartElementView * | pParentView )

Constructs a CXTPChartRadarAxisView object.

Parameters
pAxis | Pointer to a CXTPChartAxis object.
pParentView | Pointer to a CXTPChartElementView object.
The documentation for this class was generated from the following file:
  • XTPChartRadarAxisView.h


Toolkit Pro: CXTPChartRadarAxisX Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPChartRadarAxisX Class Reference

CXTPChartRadarAxisX is a derived class from the CXTPChartAxis class and represents the X axis of a chart. More...

Inheritance diagram for CXTPChartRadarAxisX:
[legend]

Public Member Functions

CXTPChartRadarAxisX (CXTPChartRadarDiagram *pDiagram)
Constructs a CXTPChartAxisX object.
virtual BOOL | IsVertical () const
This method overrides the base class member and determines if the X axis is vertical.
virtual BOOL | IsValuesAxis () const
This method overrides the base class member and determines if the X axis is value type.
virtual double | CalcSideMarginsValue (double nMinValue, double nMaxValue) const
This method overrides the base class member and returns the side margin value of the chart's X axis.
BOOL | IsDirectionClockwise () const
This function returns the direction of the axis.
void | SetDirectionClockwise (BOOL bDirectionClockwise)
This function sets the direction of the axis.
- Public Member Functions inherited from CXTPChartAxis
CXTPChartAxis (CXTPChartDiagram *pDiagram)
Constructs a CXTPChartAxis object.
virtual | ~CXTPChartAxis ()
Destroys a CXTPChartAxis object, handles cleanup.
void | UpdateRange (CXTPChartDeviceContext *pDC, CXTPChartAxisView *pView)
This function updates the axis, with respect to the series values.
CXTPChartDiagram * | GetDiagram () const
Call this function to get the pointer to chart diagram 2D object associated with the chart axis object.
XTPChartScaleType | GetScaleType () const
Use this function to get the scale type used for the axis.
CXTPChartScaleTypeMap * | GetScaleTypeMap () const
Call this function to get the scale type map object associated with the axis.
CXTPChartAxisRange * | GetRange () const
Use this function to get object which represents the range of the axis.
CXTPChartAxisLabel * | GetLabel () const
Call this function to get object which represents the label of the axis.
CXTPChartAxisGridLines * | GetGridLines () const
Use this function to get object which represents the axis gridlines.
CXTPChartAxisTickMarks * | GetTickMarks () const
Call this function to get the associated object which abstracts the axis tick marks.
CXTPChartAxisConstantLines * | GetConstantLines () const
Use this function to get the associated object which deals with constant lines parallel to the axis.
CXTPChartAxisCustomLabels * | GetCustomLabels () const
Use this function to get the associated object which deals with custom labels of aixs.
CXTPChartAxisStrips * | GetStrips () const
Call this function to get the associated object which deals with strips parallel to the axis.
CXTPChartAxisTitle * | GetTitle () const
Use this function to get the associated object which deals the axis title.
CXTPChartColor | GetActualColor () const
Gets the color of the axis.
CXTPChartColor | GetColor () const
Gets the color of the axis.
void | SetColor (const CXTPChartColor &color)
Sets the color of the axis.
CXTPChartColor | GetInterlacedColor () const
Gets the first interlaced strips color of the axis.
CXTPChartColor | GetActualInterlacedColor () const
Gets the first interlaced strips color of the axis.
void | SetInterlacedColor (const CXTPChartColor &color)
Sets the first interlaced strips color of the axis.
CXTPChartColor | GetInterlacedColor2 () const
Gets the second interlaced strips color of the axis.
CXTPChartColor | GetActualInterlacedColor2 () const
Gets the second interlaced strips color of the axis.
void | SetInterlacedColor2 (const CXTPChartColor &color)
Sets the second interlaced strips color of the axis.
CXTPChartFillStyle * | GetInterlacedFillStyle () const
Call this function to get the second interlaced strips background fill style.
XTPChartAxisAlignment | GetAlignment () const
Call this function to get the alignment of the axis.
void | SetAlignment (XTPChartAxisAlignment nAlignment)
Use this function to set the alignment of the axis.
BOOL | IsInterlaced () const
Call this function to get whether the interlaced strips are used.
void | SetInterlaced (BOOL bInterlaced)
Call this function to enable/disable the interlaced strips.
BOOL | IsVisible () const
Use this function to get whether the axis is visible.
void | SetVisible (BOOL bVisible)
Call this function to show/hide the axis.
int | GetThickness () const
Call this function to get the thickness of the axis line.
void | SetThickness (int nThicknes)
Call this function to set the thickness of the axis line.
int | GetIndex () const
Call this function to get index of the axis.
void | SetIndex (int nIndex)
Call this function to set the axis index.
void | SetMinorCount (int nMinorCount)
Call this function to set the minor count of the axis grid lines.
int | GetMinorCount () const
This function gives the minor count of the axis grid lines.
void | SetReversed (BOOL bRevered)
Use this function to reverse order the axis values.
BOOL | IsReversed () const
This function gives whether the axis points are reverse ordered or not.
CXTPChartAxisAppearance * | GetAppearance () const
This function returns the chart axis appeance object.
void | SetGridSpacingAuto (BOOL bGridSpacingAuto)
Sets value specifies whether space between grid lines in calculated automatically.
void | SetGridSpacing (double dGridSpacing)
Use this function to set the space between grid lines.
double | GetGridSpacing () const
Use this function to get the space between grid lines.
void | SetLogarithmic (BOOL bLogarithmic)
Set whether logarithmic scale should be used.
void | SetLogarithmicBase (double dLogarithmicBase)
Set logarithmic base when logarithmic scale is used.
void | SetDateTimeScaleUnit (XTPChartAxisDateTimeScaleUnit unit)
Call this method to set single unit for date time scale.
void | DoPropExchange (CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
- Public Member Functions inherited from CXTPChartElement
CXTPChartElement ()
Constructs a CXTPChartElement object.
virtual | ~CXTPChartElement ()
Destroys a CXTPChartElement object, handles cleanup.
virtual void | Release ()
Call this function to decrease the usage count of the object.
CXTPChartElement * | GetOwner () const
Call this function to get the owner element.
virtual void | OnChartChanged (XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic properties of the chart.
CXTPChartContent * | GetContent () const
Call this virtual function to get the chart content object.
CXTPChartAppearance * | GetAppearance () const
Call this function to get the the appearance of the chart.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Protected Member Functions

virtual CXTPChartAxisView * CreateView (CXTPChartDeviceContext *pDC, CXTPChartElementView *pParentView)
This function creates the view (CXTPChartAxisView) of the axis.
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.

Protected Attributes

BOOL | m_bDirectionClockwise
The direction of the axis.
- Protected Attributes inherited from CXTPChartAxis
CXTPChartDiagram * | m_pDiagram
The pointer to chart digram 2d object.
BOOL | m_bVisible
TRUE if the axis is visible, FALSE if invisible.
BOOL | m_bReversed
FALSE if the axis valus are in natural order, TRUE if it is in reverse order.
int | m_nThickness
The thickness of axis line.
int | m_nMinorCount
The number of minors present.
XTPChartAxisAlignment | m_nAlignment
The chart axis alignment, near or far.
CXTPChartColor m_clrColor
The chart color.
CXTPChartColor m_clrInterlacedColor
The first interlaced color.
CXTPChartColor m_clrInterlacedColor2
The second interlaced color.
CXTPChartFillStyle * m_pInterlacedFillStyle
The fill style of interlaced strips.
BOOL | m_bInterlaced
TRUE if the chart has interlaced strips parallel to the axis.
double | m_dGridSpacing
The spacing of the grid lines.
BOOL | m_bGridSpacingAuto
TURE if automatic spaceing of grid lines selected.FALSE for specific values.
BOOL | m_bLogarithmic
Logarithmic

double | m_dLogarithmicBase
Logarithic base.
CXTPChartAxisGridLines * m_pGridLines
Pointer to axis gridlines object.
CXTPChartAxisLabel * m_pLabel
Pointer to axis lable object.
CXTPChartAxisTitle * m_pTitle
Pointer to axis title object.
CXTPChartAxisTickMarks * m_pTickMarks
Pointer to axis tick marks object.
CXTPChartScaleTypeMap * m_pScaleTypeMap
Pointer to axis scale type object.
CXTPChartAxisRange * m_pRange
Pointer to axis range object.
CXTPChartAxisConstantLines * | m_pConstantLines
Pointer to axis constant lines object.
CXTPChartAxisCustomLabels * | m_pCustomLabels
Pointer to axis custom labels object.
CXTPChartAxisStrips * m_pStrips
Pointer to axis strips object.
XTPChartScaleType | m_nScaleType
Enumeated value denote the axis scale type.
- Protected Attributes inherited from CXTPChartElement

Detailed Description

CXTPChartRadarAxisX is a derived class from the CXTPChartAxis class and represents the X axis of a chart.

It includes the features specific to the X axis of a chart.

Constructor & Destructor Documentation

◆ CXTPChartRadarAxisX()

CXTPChartRadarAxisX ( CXTPChartRadarDiagram * pDiagram )

Constructs a CXTPChartAxisX object.

Parameters
pDiagram Pointer to a CXTPChartRadarDiagram object.

Member Function Documentation

◆ CalcSideMarginsValue()

virtual double CalcSideMarginsValue | ( | double | nMinValue,
 |  | double | nMaxValue ) const
 virtual

This method overrides the base class member and returns the side margin value of the chart's X axis.

Parameters
nMinValue | The minimum value of the chart's X axis.
nMaxValue | The maximum value of the chart's X axis.
Returns
Returns a double value that represents the margin.

Implements CXTPChartAxis.

◆ CreateView()

virtual CXTPChartAxisView * CreateView | ( | CXTPChartDeviceContext * | pDC,
 |  | CXTPChartElementView * | pParentView )
 protectedvirtual

This function creates the view (CXTPChartAxisView) of the axis.

Parameters
pDC | The chart device context object pointer.
pParentView | The parent view of the axis.
Returns
Returns a pointer to the newly created CXTPChartAxisView object.

Reimplemented from CXTPChartAxis.

◆ IsDirectionClockwise()

BOOL IsDirectionClockwise ( ) const

This function returns the direction of the axis.

Returns
A BOOL value. TRUE if the direction of the axis is clockwise, FALSE if the direction of the axis is counterclockwise.

TRUE/clockwise is the default value for the direction of the axis.

See also
SetDirectionClockwise

◆ IsValuesAxis()

virtual BOOL IsValuesAxis ( ) const
virtual

This method overrides the base class member and determines if the X axis is value type.

Returns
Returns TRUE if the X axis is value type, FALSE if the X axis is not value type.

Implements CXTPChartAxis.

◆ IsVertical()

virtual BOOL IsVertical ( ) const
virtual

This method overrides the base class member and determines if the X axis is vertical.

Returns
Returns TRUE if the X axis is vertical, FALSE if the X axis is not vertical.

Implements CXTPChartAxis.

◆ SetDirectionClockwise()

void SetDirectionClockwise ( BOOL bDirectionClockwise )

This function sets the direction of the axis.

Parameters
bDirectionClockwise A new value for the axis direction. TRUE to set the direction of the axis to clockwise, FALSE to set the direction of the axis to counterclockwise.

TRUE/clockwise is the default value for the direction of the axis.

See also
IsDirectionClockwise

Member Data Documentation

◆ m_bDirectionClockwise

BOOL m_bDirectionClockwise
protected

The direction of the axis.

Default is TRUE (clockwise).

The documentation for this class was generated from the following file:
  • XTPChartRadarAxis.h


Toolkit Pro: CXTPChartRadarAxisXView Class Reference

Public Member Functions | Public Attributes | Protected Member Functions | Protected Attributes | List of all members
CXTPChartRadarAxisXView Class Reference

This class abstracts the view of a chart axis and its child items in a bounding rectangle context. More...

Inheritance diagram for CXTPChartRadarAxisXView:
[legend]

Public Member Functions

CXTPChartRadarAxisXView (CXTPChartAxis *pAxis, CXTPChartElementView *pParentView)
Constructs a CXTPChartRadarAxisXView object.
~CXTPChartRadarAxisXView ()
Destroys a CXTPChartRadarAxisXView object, handles cleanup and deallocation.
virtual CXTPChartDeviceCommand * | CreateDeviceCommand (CXTPChartDeviceContext *pDC)
Override this function to create a CXTPChartDeviceCommand object.
virtual CXTPChartDeviceCommand * | CreateGridLinesDeviceCommand (CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
virtual CXTPChartDeviceCommand * | CreateInterlacedDeviceCommand (CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
virtual CXTPChartDeviceCommand * | CreateTickMarksDeviceCommand (CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
virtual CXTPChartDeviceCommand * | CreateLabelsDeviceCommand (CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
virtual CXTPChartDeviceCommand * | CreateConstantLinesDeviceCommand (CXTPChartDeviceContext *pDC, BOOL bBehind)
This function creates a CXTPChartDeviceCommand object.
virtual CXTPChartDeviceCommand * | CreateStripsDeviceCommand (CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
void | CreateView (CXTPChartDeviceContext *pDC)
Call this function to create a chart axis view.
void | CalcSize (CXTPChartDeviceContext *pDC, CRect rcDiagram)
This function calculates the size of an axis, including its constituent elements (e.g.
void | SetBounds (CXTPChartDeviceContext *pDC, CRect rcBounds)
This function sets the bounds for the axis.
int | GetSize () const
This function returns the size of the axis.
- Public Member Functions inherited from CXTPChartRadarAxisView
CXTPChartRadarAxisView (CXTPChartAxis *pAxis, CXTPChartElementView *pParentView)
Constructs a CXTPChartRadarAxisView object.
~CXTPChartRadarAxisView ()
Destroys a CXTPChartRadarAxisView object, handles cleanup and deallocation.

Public Attributes

CArray< CXTPChartRadarAxisXViewTick, CXTPChartRadarAxisXViewTick & > m_arrTicks
The collection of tick marks.

Protected Member Functions

void CreateTickMarks (CXTPChartDeviceContext *pDC)
This function creates the axis tick marks.

Protected Attributes

CRect | m_rcBounds
The diagram boundary.
int | m_nSize
The axis size;.

Detailed Description

This class abstracts the view of a chart axis and its child items in a bounding rectangle context.

Constructor & Destructor Documentation

◆ CXTPChartRadarAxisXView()

CXTPChartRadarAxisXView | ( | CXTPChartAxis * | pAxis,
 |  | CXTPChartElementView * | pParentView )

Constructs a CXTPChartRadarAxisXView object.

Parameters
pAxis | Pointer to a CXTPChartAxis object.
pParentView | Pointer to a CXTPChartElementView object.

Member Function Documentation

◆ CalcSize()

void CalcSize | ( | CXTPChartDeviceContext * | pDC,
 |  | CRect | rcDiagram )

This function calculates the size of an axis, including its constituent elements (e.g.

tick marks, labels, axis title, etc.).

Parameters
pDC | The chart device context object.
rcDiagram | The rectangle of the diagram.

◆ CreateConstantLinesDeviceCommand()

virtual CXTPChartDeviceCommand * CreateConstantLinesDeviceCommand | ( | CXTPChartDeviceContext * | pDC,
 |  | BOOL | bBehind )
 virtual

This function creates a CXTPChartDeviceCommand object.

This object represents the rendering of the constant lines perpendicular to an axis.

Parameters
pDC | Pointer to a CXTPChartDeviceContext object.
bBehind | TRUE for behind
Returns
Returns a pointer to a CXTPChartDeviceCommand object. This polymorphic object handles the rendering of an element in the chart. Here it handles the drawing of the constant lines perpendicular to an axis.

Implements CXTPChartRadarAxisView.

◆ CreateDeviceCommand()

virtual CXTPChartDeviceCommand * CreateDeviceCommand ( CXTPChartDeviceContext * pDC )
virtual

Override this function to create a CXTPChartDeviceCommand object.

This object represents the rendering of an axis in the chart.

Parameters
pDC Pointer to a CXTPChartDeviceContext object.
Returns
Returns a CXTPChartDeviceCommand object. This object handles the rendering of an element in the chart. Here it handles the drawing of an axis.

Reimplemented from CXTPChartElementView.

◆ CreateGridLinesDeviceCommand()

virtual CXTPChartDeviceCommand * CreateGridLinesDeviceCommand ( CXTPChartDeviceContext * pDC )
virtual

This function creates a CXTPChartDeviceCommand object.

This object represents the rendering of the grid lines in the chart axis.

Parameters
pDC Pointer to a CXTPChartDeviceContext object.
Returns
Returns a pointer to a CXTPChartDeviceCommand object. This polymorphic object handles the rendering of an element in the chart. Here it handles the drawing of the grid lines in an axis.

Implements CXTPChartRadarAxisView.

◆ CreateInterlacedDeviceCommand()

virtual CXTPChartDeviceCommand * CreateInterlacedDeviceCommand ( CXTPChartDeviceContext * pDC )
virtual

This function creates a CXTPChartDeviceCommand object.

This object represents the rendering of the interlaced strips in the chart.

Parameters
pDC Pointer to a CXTPChartDeviceContext object.
Returns
Returns a pointer to a CXTPChartDeviceCommand object. This polymorphic object handles the rendering of an element in the chart. Here it handles the drawing of the interlaced strips in the chart.

Implements CXTPChartRadarAxisView.

◆ CreateLabelsDeviceCommand()

virtual CXTPChartDeviceCommand * CreateLabelsDeviceCommand ( CXTPChartDeviceContext * pDC )
virtual

This function creates a CXTPChartDeviceCommand object.

This object represents the rendering of the labels in the axis.

Parameters
pDC Pointer to a CXTPChartDeviceContext object.
Returns
Returns a pointer to a CXTPChartDeviceCommand object. This polymorphic object handles the rendering of an element in the chart. Here it handles the drawing of the labels in the axis.

◆ CreateStripsDeviceCommand()

virtual CXTPChartDeviceCommand * CreateStripsDeviceCommand ( CXTPChartDeviceContext * pDC )
virtual

This function creates a CXTPChartDeviceCommand object.

This object represents the rendering of the strips parallel to an axis.

Parameters
pDC Pointer to a CXTPChartDeviceContext object.
Returns
Returns a pointer to a CXTPChartDeviceCommand object. This polymorphic object handles the rendering of an element in the chart. Here it handles the drawing of the strips parallel to an axis.

Implements CXTPChartRadarAxisView.

◆ CreateTickMarks()

void CreateTickMarks ( CXTPChartDeviceContext * pDC )
protected

This function creates the axis tick marks.

Parameters
pDC The device context.

◆ CreateTickMarksDeviceCommand()

virtual CXTPChartDeviceCommand * CreateTickMarksDeviceCommand ( CXTPChartDeviceContext * pDC )
virtual

This function creates a CXTPChartDeviceCommand object.

This object represents the rendering of the tick marks in the axis.

Parameters
pDC Pointer to a CXTPChartDeviceContext object.
Returns
Returns a pointer to a CXTPChartDeviceCommand object. This polymorphic object handles the rendering of an element in the chart. Here it handles the drawing of the tick marks in the axis.

◆ CreateView()

void CreateView ( CXTPChartDeviceContext * pDC )

Call this function to create a chart axis view.

Parameters
pDC The chart device context object.

This function creates the view of an axis and its constituent elements (e.g. tick marks, labels, axis title, etc.).

◆ GetSize()

AFX_INLINE int GetSize ( ) const

This function returns the size of the axis.

Returns
The last computed axis size value. If the axis size value has not been computed yet, a value of 0 will be returned instead.

◆ SetBounds()

void SetBounds | ( | CXTPChartDeviceContext * | pDC,
 |  | CRect | rcBounds )

This function sets the bounds for the axis.

Parameters
pDC | The chart device context object.
rcBounds | The bounding rectangle.
The documentation for this class was generated from the following file:
  • XTPChartRadarAxisXView.h


Toolkit Pro: CXTPChartRadarAxisXViewTick Class Reference

Public Attributes | List of all members
CXTPChartRadarAxisXViewTick Class Reference

This class represents a tick mark in the axis. More...

Public Attributes

double | m_dValue
The value of the tick mark.
CXTPChartString | m_strLabel
The tick mark label.
CSize | m_szBounds
The boundary.
CXTPChartSizeF | m_szLabel
The size of the label.

Detailed Description

This class represents a tick mark in the axis.

The documentation for this class was generated from the following file:
  • XTPChartRadarAxisXView.h


Toolkit Pro: CXTPChartRadarAxisY Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPChartRadarAxisY Class Reference

CXTPChartRadarAxisY is a derived class from the CXTPChartAxis class and represents the Y axis of a chart. More...

Inheritance diagram for CXTPChartRadarAxisY:
[legend]

Public Member Functions

CXTPChartRadarAxisY (CXTPChartRadarDiagram *pDiagram)
Constructs a CXTPChartAxisY object.
virtual BOOL | IsVertical () const
This method overrides the base class member and determines if the Y axis is vertical.
virtual BOOL | IsValuesAxis () const
This method overrides the base class member and determines if the Y axis is value type.
virtual double | CalcSideMarginsValue (double nMinValue, double nMaxValue) const
This method overrides the base class member and returns the side margin value of the chart's Y axis.
- Public Member Functions inherited from CXTPChartAxis
CXTPChartAxis (CXTPChartDiagram *pDiagram)
Constructs a CXTPChartAxis object.
virtual | ~CXTPChartAxis ()
Destroys a CXTPChartAxis object, handles cleanup.
void | UpdateRange (CXTPChartDeviceContext *pDC, CXTPChartAxisView *pView)
This function updates the axis, with respect to the series values.
CXTPChartDiagram * | GetDiagram () const
Call this function to get the pointer to chart diagram 2D object associated with the chart axis object.
XTPChartScaleType | GetScaleType () const
Use this function to get the scale type used for the axis.
CXTPChartScaleTypeMap * | GetScaleTypeMap () const
Call this function to get the scale type map object associated with the axis.
CXTPChartAxisRange * | GetRange () const
Use this function to get object which represents the range of the axis.
CXTPChartAxisLabel * | GetLabel () const
Call this function to get object which represents the label of the axis.
CXTPChartAxisGridLines * | GetGridLines () const
Use this function to get object which represents the axis gridlines.
CXTPChartAxisTickMarks * | GetTickMarks () const
Call this function to get the associated object which abstracts the axis tick marks.
CXTPChartAxisConstantLines * | GetConstantLines () const
Use this function to get the associated object which deals with constant lines parallel to the axis.
CXTPChartAxisCustomLabels * | GetCustomLabels () const
Use this function to get the associated object which deals with custom labels of aixs.
CXTPChartAxisStrips * | GetStrips () const
Call this function to get the associated object which deals with strips parallel to the axis.
CXTPChartAxisTitle * | GetTitle () const
Use this function to get the associated object which deals the axis title.
CXTPChartColor | GetActualColor () const
Gets the color of the axis.
CXTPChartColor | GetColor () const
Gets the color of the axis.
void | SetColor (const CXTPChartColor &color)
Sets the color of the axis.
CXTPChartColor | GetInterlacedColor () const
Gets the first interlaced strips color of the axis.
CXTPChartColor | GetActualInterlacedColor () const
Gets the first interlaced strips color of the axis.
void | SetInterlacedColor (const CXTPChartColor &color)
Sets the first interlaced strips color of the axis.
CXTPChartColor | GetInterlacedColor2 () const
Gets the second interlaced strips color of the axis.
CXTPChartColor | GetActualInterlacedColor2 () const
Gets the second interlaced strips color of the axis.
void | SetInterlacedColor2 (const CXTPChartColor &color)
Sets the second interlaced strips color of the axis.
CXTPChartFillStyle * | GetInterlacedFillStyle () const
Call this function to get the second interlaced strips background fill style.
XTPChartAxisAlignment | GetAlignment () const
Call this function to get the alignment of the axis.
void | SetAlignment (XTPChartAxisAlignment nAlignment)
Use this function to set the alignment of the axis.
BOOL | IsInterlaced () const
Call this function to get whether the interlaced strips are used.
void | SetInterlaced (BOOL bInterlaced)
Call this function to enable/disable the interlaced strips.
BOOL | IsVisible () const
Use this function to get whether the axis is visible.
void | SetVisible (BOOL bVisible)
Call this function to show/hide the axis.
int | GetThickness () const
Call this function to get the thickness of the axis line.
void | SetThickness (int nThicknes)
Call this function to set the thickness of the axis line.
int | GetIndex () const
Call this function to get index of the axis.
void | SetIndex (int nIndex)
Call this function to set the axis index.
void | SetMinorCount (int nMinorCount)
Call this function to set the minor count of the axis grid lines.
int | GetMinorCount () const
This function gives the minor count of the axis grid lines.
void | SetReversed (BOOL bRevered)
Use this function to reverse order the axis values.
BOOL | IsReversed () const
This function gives whether the axis points are reverse ordered or not.
CXTPChartAxisAppearance * | GetAppearance () const
This function returns the chart axis appeance object.
void | SetGridSpacingAuto (BOOL bGridSpacingAuto)
Sets value specifies whether space between grid lines in calculated automatically.
void | SetGridSpacing (double dGridSpacing)
Use this function to set the space between grid lines.
double | GetGridSpacing () const
Use this function to get the space between grid lines.
void | SetLogarithmic (BOOL bLogarithmic)
Set whether logarithmic scale should be used.
void | SetLogarithmicBase (double dLogarithmicBase)
Set logarithmic base when logarithmic scale is used.
void | SetDateTimeScaleUnit (XTPChartAxisDateTimeScaleUnit unit)
Call this method to set single unit for date time scale.
void | DoPropExchange (CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
- Public Member Functions inherited from CXTPChartElement
CXTPChartElement ()
Constructs a CXTPChartElement object.
virtual | ~CXTPChartElement ()
Destroys a CXTPChartElement object, handles cleanup.
virtual void | Release ()
Call this function to decrease the usage count of the object.
CXTPChartElement * | GetOwner () const
Call this function to get the owner element.
virtual void | OnChartChanged (XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic properties of the chart.
CXTPChartContent * | GetContent () const
Call this virtual function to get the chart content object.
CXTPChartAppearance * | GetAppearance () const
Call this function to get the the appearance of the chart.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Protected Member Functions

virtual CXTPChartAxisView * CreateView (CXTPChartDeviceContext *pDC, CXTPChartElementView *pParentView)
This function creates the view (CXTPChartAxisView) of the axis.
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.

Additional Inherited Members

- Public Attributes inherited from CXTPChartElement
- Protected Attributes inherited from CXTPChartAxis
CXTPChartDiagram * | m_pDiagram
The pointer to chart digram 2d object.
BOOL | m_bVisible
TRUE if the axis is visible, FALSE if invisible.
BOOL | m_bReversed
FALSE if the axis valus are in natural order, TRUE if it is in reverse order.
int | m_nThickness
The thickness of axis line.
int | m_nMinorCount
The number of minors present.
XTPChartAxisAlignment | m_nAlignment
The chart axis alignment, near or far.
CXTPChartColor m_clrColor
The chart color.
CXTPChartColor m_clrInterlacedColor
The first interlaced color.
CXTPChartColor m_clrInterlacedColor2
The second interlaced color.
CXTPChartFillStyle * m_pInterlacedFillStyle
The fill style of interlaced strips.
BOOL | m_bInterlaced
TRUE if the chart has interlaced strips parallel to the axis.
double | m_dGridSpacing
The spacing of the grid lines.
BOOL | m_bGridSpacingAuto
TURE if automatic spaceing of grid lines selected.FALSE for specific values.
BOOL | m_bLogarithmic
Logarithmic

double | m_dLogarithmicBase
Logarithic base.
CXTPChartAxisGridLines * m_pGridLines
Pointer to axis gridlines object.
CXTPChartAxisLabel * m_pLabel
Pointer to axis lable object.
CXTPChartAxisTitle * m_pTitle
Pointer to axis title object.
CXTPChartAxisTickMarks * m_pTickMarks
Pointer to axis tick marks object.
CXTPChartScaleTypeMap * m_pScaleTypeMap
Pointer to axis scale type object.
CXTPChartAxisRange * m_pRange
Pointer to axis range object.
CXTPChartAxisConstantLines * | m_pConstantLines
Pointer to axis constant lines object.
CXTPChartAxisCustomLabels * | m_pCustomLabels
Pointer to axis custom labels object.
CXTPChartAxisStrips * m_pStrips
Pointer to axis strips object.
XTPChartScaleType | m_nScaleType
Enumeated value denote the axis scale type.
- Protected Attributes inherited from CXTPChartElement

Detailed Description

CXTPChartRadarAxisY is a derived class from the CXTPChartAxis class and represents the Y axis of a chart.

It includes the features specific to the Y axis of a chart.

Constructor & Destructor Documentation

◆ CXTPChartRadarAxisY()

CXTPChartRadarAxisY ( CXTPChartRadarDiagram * pDiagram )

Constructs a CXTPChartAxisY object.

Parameters
pDiagram Pointer to a CXTPChartRadarDiagram object.

Member Function Documentation

◆ CalcSideMarginsValue()

virtual double CalcSideMarginsValue | ( | double | nMinValue,
 |  | double | nMaxValue ) const
 virtual

This method overrides the base class member and returns the side margin value of the chart's Y axis.

Parameters
nMinValue | The minimum value of the chart's Y axis.
nMaxValue | The maximum value of the chart's Y axis.
Returns
Returns a double value that represents the margin.

Implements CXTPChartAxis.

◆ CreateView()

virtual CXTPChartAxisView * CreateView | ( | CXTPChartDeviceContext * | pDC,
 |  | CXTPChartElementView * | pParentView )
 protectedvirtual

This function creates the view (CXTPChartAxisView) of the axis.

Parameters
pDC | The chart device context object pointer.
pParentView | The parent view of the axis.
Returns
Returns a pointer to the newly created CXTPChartAxisView object.

Reimplemented from CXTPChartAxis.

◆ IsValuesAxis()

virtual BOOL IsValuesAxis ( ) const
virtual

This method overrides the base class member and determines if the Y axis is value type.

Returns
Returns TRUE if the Y axis is value type, FALSE if the Y axis is not value type.

Implements CXTPChartAxis.

◆ IsVertical()

virtual BOOL IsVertical ( ) const
virtual

This method overrides the base class member and determines if the Y axis is vertical.

Returns
Returns TRUE if the Y axis is vertical, FALSE if the Y axis is not vertical.

Implements CXTPChartAxis.

The documentation for this class was generated from the following file:
  • XTPChartRadarAxis.h


Toolkit Pro: CXTPChartRadarAxisYView Class Reference

Public Member Functions | Public Attributes | Protected Member Functions | Protected Attributes | List of all members
CXTPChartRadarAxisYView Class Reference

This class abstracts the view of a chart axis and its child items in a bounding rectangle context. More...

Inheritance diagram for CXTPChartRadarAxisYView:
[legend]

Public Member Functions

CXTPChartRadarAxisYView (CXTPChartAxis *pAxis, CXTPChartElementView *pParentView)
Constructs a CXTPChartRadarAxisYView object.
~CXTPChartRadarAxisYView ()
Destroys a CXTPChartRadarAxisYView object, handles cleanup and deallocation.
virtual CXTPChartDeviceCommand * | CreateDeviceCommand (CXTPChartDeviceContext *pDC)
Override this function to create a CXTPChartDeviceCommand object.
virtual CXTPChartDeviceCommand * | CreateGridLinesDeviceCommand (CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
virtual CXTPChartDeviceCommand * | CreateInterlacedDeviceCommand (CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
virtual CXTPChartDeviceCommand * | CreateTickMarksDeviceCommand (CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
virtual CXTPChartDeviceCommand * | CreateLabelsDeviceCommand (CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
virtual CXTPChartDeviceCommand * | CreateTitleDeviceCommand (CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
virtual CXTPChartDeviceCommand * | CreateConstantLinesDeviceCommand (CXTPChartDeviceContext *pDC, BOOL bBehind)
This function creates a CXTPChartDeviceCommand object.
virtual CXTPChartDeviceCommand * | CreateStripsDeviceCommand (CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
void | CreateView (CXTPChartDeviceContext *pDC)
Call this function to create a chart axis view.
void | CalcSize (CXTPChartDeviceContext *pDC, CRect rcDiagram)
This function calculates the size of an axis, including its constituent elements (e.g.
void | SetBounds (CXTPChartDeviceContext *pDC, CRect rcBounds)
This function sets the bounds for the axis.
int | GetSize () const
This function returns the size of the axis.
- Public Member Functions inherited from CXTPChartRadarAxisView
CXTPChartRadarAxisView (CXTPChartAxis *pAxis, CXTPChartElementView *pParentView)
Constructs a CXTPChartRadarAxisView object.
~CXTPChartRadarAxisView ()
Destroys a CXTPChartRadarAxisView object, handles cleanup and deallocation.

Public Attributes

CArray< CXTPChartRadarAxisYViewTick, CXTPChartRadarAxisYViewTick & > m_arrTicks
The collection of tick marks.

Protected Member Functions

void CreateTickMarks (CXTPChartDeviceContext *pDC, CRect rcDiagram)
This function creates the axis tick marks.

Protected Attributes

CRect | m_rcBounds
The diagram boundary.
CRect | m_rcPaneBounds
The diagram boundary.
int | m_nSize
The axis size;.

Detailed Description

This class abstracts the view of a chart axis and its child items in a bounding rectangle context.

Constructor & Destructor Documentation

◆ CXTPChartRadarAxisYView()

CXTPChartRadarAxisYView | ( | CXTPChartAxis * | pAxis,
 |  | CXTPChartElementView * | pParentView )

Constructs a CXTPChartRadarAxisYView object.

Parameters
pAxis | Pointer to a CXTPChartAxis object.
pParentView | Pointer to a CXTPChartElementView object.

Member Function Documentation

◆ CalcSize()

void CalcSize | ( | CXTPChartDeviceContext * | pDC,
 |  | CRect | rcDiagram )

This function calculates the size of an axis, including its constituent elements (e.g.

tick marks, labels, axis title, etc.).

Parameters
pDC | The chart device context object.
rcDiagram | The rectangle of the diagram.

◆ CreateConstantLinesDeviceCommand()

virtual CXTPChartDeviceCommand * CreateConstantLinesDeviceCommand | ( | CXTPChartDeviceContext * | pDC,
 |  | BOOL | bBehind )
 virtual

This function creates a CXTPChartDeviceCommand object.

This object represents the rendering of the constant lines perpendicular to an axis.

Parameters
pDC | Pointer to a CXTPChartDeviceContext object.
bBehind | TRUE for behind
Returns
Returns a pointer to a CXTPChartDeviceCommand object. This polymorphic object handles the rendering of an element in the chart. Here it handles the drawing of the constant lines perpendicular to an axis.

Implements CXTPChartRadarAxisView.

◆ CreateDeviceCommand()

virtual CXTPChartDeviceCommand * CreateDeviceCommand ( CXTPChartDeviceContext * pDC )
virtual

Override this function to create a CXTPChartDeviceCommand object.

This object represents the rendering of an axis in the chart.

Parameters
pDC Pointer to a CXTPChartDeviceContext object.
Returns
Returns a CXTPChartDeviceCommand object. This object handles the rendering of an element in the chart. Here it handles the drawing of an axis.

Reimplemented from CXTPChartElementView.

◆ CreateGridLinesDeviceCommand()

virtual CXTPChartDeviceCommand * CreateGridLinesDeviceCommand ( CXTPChartDeviceContext * pDC )
virtual

This function creates a CXTPChartDeviceCommand object.

This object represents the rendering of the grid lines in the chart axis.

Parameters
pDC Pointer to a CXTPChartDeviceContext object.
Returns
Returns a pointer to a CXTPChartDeviceCommand object. This polymorphic object handles the rendering of an element in the chart. Here it handles the drawing of the grid lines in an axis.

Implements CXTPChartRadarAxisView.

◆ CreateInterlacedDeviceCommand()

virtual CXTPChartDeviceCommand * CreateInterlacedDeviceCommand ( CXTPChartDeviceContext * pDC )
virtual

This function creates a CXTPChartDeviceCommand object.

This object represents the rendering of the interlaced strips in the chart.

Parameters
pDC Pointer to a CXTPChartDeviceContext object.
Returns
Returns a pointer to a CXTPChartDeviceCommand object. This polymorphic object handles the rendering of an element in the chart. Here it handles the drawing of the interlaced strips in the chart.

Implements CXTPChartRadarAxisView.

◆ CreateLabelsDeviceCommand()

virtual CXTPChartDeviceCommand * CreateLabelsDeviceCommand ( CXTPChartDeviceContext * pDC )
virtual

This function creates a CXTPChartDeviceCommand object.

This object represents the rendering of the labels in the axis.

Parameters
pDC Pointer to a CXTPChartDeviceContext object.
Returns
Returns a pointer to a CXTPChartDeviceCommand object. This polymorphic object handles the rendering of an element in the chart. Here it handles the drawing of the labels in the axis.

◆ CreateStripsDeviceCommand()

virtual CXTPChartDeviceCommand * CreateStripsDeviceCommand ( CXTPChartDeviceContext * pDC )
virtual

This function creates a CXTPChartDeviceCommand object.

This object represents the rendering of the strips parallel to an axis.

Parameters
pDC Pointer to a CXTPChartDeviceContext object.
Returns
Returns a pointer to a CXTPChartDeviceCommand object. This polymorphic object handles the rendering of an element in the chart. Here it handles the drawing of the strips parallel to an axis.

Implements CXTPChartRadarAxisView.

◆ CreateTickMarks()

void CreateTickMarks | ( | CXTPChartDeviceContext * | pDC,
 |  | CRect | rcDiagram )
 protected

This function creates the axis tick marks.

Parameters
pDC | The device context.
rcDiagram | The bounding rectangle of the diagram.

◆ CreateTickMarksDeviceCommand()

virtual CXTPChartDeviceCommand * CreateTickMarksDeviceCommand ( CXTPChartDeviceContext * pDC )
virtual

This function creates a CXTPChartDeviceCommand object.

This object represents the rendering of the tick marks in the axis.

Parameters
pDC Pointer to a CXTPChartDeviceContext object.
Returns
Returns a pointer to a CXTPChartDeviceCommand object. This polymorphic object handles the rendering of an element in the chart. Here it handles the drawing of the tick marks in the axis.

◆ CreateTitleDeviceCommand()

virtual CXTPChartDeviceCommand * CreateTitleDeviceCommand ( CXTPChartDeviceContext * pDC )
virtual

This function creates a CXTPChartDeviceCommand object.

This object represents the rendering of the axis title.

Parameters
pDC Pointer to a CXTPChartDeviceContext object.
Returns
Returns a pointer to a CXTPChartDeviceCommand object. This polymorphic object handles the rendering of an element in the chart. Here it handles the drawing of the axis title.

◆ CreateView()

void CreateView ( CXTPChartDeviceContext * pDC )

Call this function to create a chart axis view.

Parameters
pDC The chart device context object.

This function creates the view of an axis and its constituent elements like constant lines and strips.

◆ GetSize()

AFX_INLINE int GetSize ( ) const

This function returns the size of the axis.

Returns
The last computed axis size value. If the axis size value has not been computed yet, a value of 0 will be returned instead.

◆ SetBounds()

void SetBounds | ( | CXTPChartDeviceContext * | pDC,
 |  | CRect | rcBounds )

This function sets the bounds for the axis.

Parameters
pDC | The chart device context object.
rcBounds | The bounding rectangle.
The documentation for this class was generated from the following file:
  • XTPChartRadarAxisYView.h


Toolkit Pro: CXTPChartRadarAxisYViewTick Class Reference

Public Attributes | List of all members
CXTPChartRadarAxisYViewTick Class Reference

This class represents a tick mark in the axis. More...

Public Attributes

double | m_dValue
The value of the tick mark.
CXTPChartString | m_strLabel
The tick mark label.
CSize | m_szBounds
The boundary.
CXTPChartSizeF | m_szLabel
The size of the label.

Detailed Description

This class represents a tick mark in the axis.

The documentation for this class was generated from the following file:
  • XTPChartRadarAxisYView.h


Toolkit Pro: CXTPChartRadarDiagram Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPChartRadarDiagram Class Reference

This class represents a chart 2D diagram, which is a kind of CXTPChartDiagram. More...

Inheritance diagram for CXTPChartRadarDiagram:
[legend]

Public Member Functions

CXTPChartRadarDiagram ()
Constructs a CXTPChartRadarDiagram object.
virtual | ~CXTPChartRadarDiagram ()
Destroys a CXTPChartRadarDiagram object, handles cleanup.
CXTPChartAxis * | GetAxisX () const
Call this function to get the X axis associated with the 2D diagram.
CXTPChartAxis * | GetAxisY () const
Call this function to get the Y axis associated with the 2D diagram.
CXTPChartDiagram2DAppearance * | GetAppearance () const
Call this function to get the diagram appearance object associated with this object.
virtual CXTPChartDiagramView * | CreateView (CXTPChartDeviceContext *pDC, CXTPChartElementView *pParent)
Call this function to create the view of the 2D diagram object.
void | DoPropExchange (CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
- Public Member Functions inherited from CXTPChartDiagram
virtual void | CalculateSeriesLayout (CXTPChartDeviceContext *pDC, CXTPChartDiagramView *pView)
Call this function to calculate the series layout of the diagram.
const CXTPChartSeriesArray & | GetSeries () const
Call this function to get the series collection object.
- Public Member Functions inherited from CXTPChartPanel
CXTPChartPanel ()
Constructs a CXTPChartPanel object.
virtual | ~CXTPChartPanel ()
Destroys a CXTPChartMarker object, handles cleanup.
CXTPChartTitleCollection * | GetTitles () const
Call this function to get the the title collection object.
- Public Member Functions inherited from CXTPChartElement
CXTPChartElement ()
Constructs a CXTPChartElement object.
virtual | ~CXTPChartElement ()
Destroys a CXTPChartElement object, handles cleanup.
CXTPChartElement * | GetOwner () const
Call this function to get the owner element.
virtual void | OnChartChanged (XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic properties of the chart.
CXTPChartContent * | GetContent () const
Call this virtual function to get the chart content object.
CXTPChartAppearance * | GetAppearance () const
Call this function to get the the appearance of the chart.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Protected Member Functions

void | UpdateLayout (CXTPChartDeviceContext *pDC, CXTPChartDiagramView *pView, CRect rcBounds)
Call this function to update the layout if there are some changes in the diagram.
- Protected Member Functions inherited from CXTPChartDiagram
CXTPChartDiagram ()
Constructs a CXTPChartDiagram object.
virtual BOOL | OnSeriesAdded (CXTPChartSeries *pSeries)
This function is called when a series is added to the series collection in the chart content object which has a collection of series.
void | OnSeriesRemoved (CXTPChartSeries *pSeries)
This function is called when a series is removed from the series collection in the chart content object which has a collection of series.
void | Release ()
Call this function to decrease the usage count of the object.
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.

Protected Attributes

CXTPChartAxis * | m_pAxisX
The pointer to X axis object.
CXTPChartAxis * | m_pAxisY
The pointer to Y axis object.
- Protected Attributes inherited from CXTPChartDiagram
CXTPChartSeriesArray | m_arrSeries
The series collection.
- Protected Attributes inherited from CXTPChartPanel
- Protected Attributes inherited from CXTPChartElement

Detailed Description

This class represents a chart 2D diagram, which is a kind of CXTPChartDiagram.

Member Function Documentation

◆ CreateView()

virtual CXTPChartDiagramView * CreateView | ( | CXTPChartDeviceContext * | pDC,
 |  | CXTPChartElementView * | pParent )
 virtual

Call this function to create the view of the 2D diagram object.

Parameters
pDC | A pointer to a chart device context object.
pParent | A pointer to the parent view.
Returns
A pointer to a CXTPChartDiagramView object.

Reimplemented from CXTPChartDiagram.

◆ DoPropExchange()

void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Reads this object from or writes this object to an archive.

Parameters
pPX A CXTPPropExchange object to serialize to or from.

Reimplemented from CXTPChartDiagram.

◆ GetAppearance()

CXTPChartDiagram2DAppearance * GetAppearance ( ) const

Call this function to get the diagram appearance object associated with this object.

Returns
A pointer to a CXTPChartRadarDiagramAppearance object.

◆ GetAxisX()

AFX_INLINE CXTPChartAxis * GetAxisX ( ) const

Call this function to get the X axis associated with the 2D diagram.

Returns
A pointer to a CXTPChartAxis object, the specific type is CXTPChartAxisX.

◆ GetAxisY()

AFX_INLINE CXTPChartAxis * GetAxisY ( ) const

Call this function to get the Y axis associated with the 2D diagram.

Returns
A pointer to a CXTPChartAxis object, the specific type is CXTPChartAxisY.

◆ UpdateLayout()

void UpdateLayout | ( | CXTPChartDeviceContext * | pDC,
 |  | CXTPChartDiagramView * | pView,
 |  | CRect | rcBounds )
 protected

Call this function to update the layout if there are some changes in the diagram.

Parameters
pDC | A pointer to a chart device context object.
pView | A pointer to the associated diagram view object.
rcBounds | The rectangular diagram boundary.
The documentation for this class was generated from the following file:
  • XTPChartRadarDiagram.h


Toolkit Pro: CXTPChartRadarDiagramSeriesStyle Class Reference

Public Member Functions | List of all members
CXTPChartRadarDiagramSeriesStyle Class Reference

This class represents a base radar series style, which is a kind of CXTPChartSeriesStyle. More...

Inheritance diagram for CXTPChartRadarDiagramSeriesStyle:
[legend]

Public Member Functions

CXTPChartRadarDiagramSeriesStyle ()
Constructs a CXTPChartRadarDiagramSeriesStyle object.
virtual | ~CXTPChartRadarDiagramSeriesStyle ()
Destroys a CXTPChartRadarDiagramSeriesStyle object, handles cleanup.
void | DoPropExchange (CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
virtual CXTPChartDiagram * | CreateDiagram ()
Call this function to create the diagram for this series.
virtual BOOL | IsStyleDiagram (CXTPChartDiagram *pDiagram) const
Call this function to check whether the chart diagram object passed is a kind of 2D diagram (CXTPChartDiagram2D object).
- Public Member Functions inherited from CXTPChartSeriesStyle
CXTPChartSeriesStyle ()
Constructs a CXTPChartSeriesStyle object.
virtual | ~CXTPChartSeriesStyle ()
Destroys a CXTPChartSeriesStyle object, handles cleanup.
virtual CXTPChartSeriesLabel * | GetLabel () const
Call this method to gets the series label object.
virtual CXTPChartSeriesLabel * | SetLabel (CXTPChartSeriesLabel *pLabel)
Call this method to sets the series label object.
virtual CXTPChartErrorBar * | GetErrorBar () const
Call this method to gets the error bar object.
virtual CXTPChartErrorBar * | SetErrorBar (CXTPChartErrorBar *pErrorBar)
Call this method to sets the error bar object.
virtual CXTPChartColor | GetColor () const
Call this method to get the color of the series.
virtual void | SetColor (CXTPChartColor clr)
Call this method to set the color of the series.
virtual void | SetColorEach (BOOL bColorEach)
Call this method to set individual color for each point of the series.
virtual BOOL | IsColorEach () const
This method is called to check if individual color is used for each point of the series.
virtual CXTPChart3dRotation | Get3dRotation () const
Obtains rotation parameters for 3D chart.
virtual void | Set3dRotation (const CXTPChart3dRotation &rotation)
Sets rotation parameters for 3D chart.
virtual void | Set3dRotation (double dYaw, double dPitch, double dRoll)
Sets rotation parameters for 3D chart.
virtual BOOL | Is3dEdgeSmoothingEnabled () const
Enables/disables 3D edge smoothing.
virtual void | Enable3dEdgeSmoothing (BOOL bEnable=TRUE)
Enables/disables 3D edge smoothing.
virtual int | GetTransparency () const
Call this function to gets the transparency of the chart if it is supported by the chart type.
virtual void | SetTransparency (int nTransparency)
Call this function to sets the transparency of the chart if it is supported by the chart type.
virtual void | CorrectAxisSideMargins (CXTPChartAxis *pAxis, double nMinValue, double nMaxValue, double &nCorrection)
Provides default implementation for axis side margins correction.
virtual CXTPChartSeriesStyleAppearance * | GetStyleAppearance () const
Obtains associated style appearance pointer.
virtual void | ApplyTo (CXTPChartDeviceCommand *pCommand)
Applies the style to the command provided in case the command needs style specific details for correct drawing.
virtual int | GetSeriesPointValueIndex () const
Obtains the index of a point element for which an internal value can be otained.
virtual CXTPChartSeriesView * | CreateView (CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)=0
This virtual method is called to create a new view associated with the current style.
- Public Member Functions inherited from CXTPChartElement
CXTPChartElement ()
Constructs a CXTPChartElement object.
virtual | ~CXTPChartElement ()
Destroys a CXTPChartElement object, handles cleanup.
virtual void | Release ()
Call this function to decrease the usage count of the object.
CXTPChartElement * | GetOwner () const
Call this function to get the owner element.
virtual void | OnChartChanged (XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic properties of the chart.
CXTPChartContent * | GetContent () const
Call this virtual function to get the chart content object.
CXTPChartAppearance * | GetAppearance () const
Call this function to get the the appearance of the chart.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Additional Inherited Members

- Public Attributes inherited from CXTPChartElement
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.
- Protected Attributes inherited from CXTPChartSeriesStyle
CXTPChartSeriesLabel * | m_pLabel
Label object.
CXTPChartErrorBar * | m_pErrorBar
Error bar object.
CXTPChartColor | m_clrColor
Custom color of series.
BOOL | m_bColorEach
TRUE to color each point.
int | m_nTransparency
The transparency value in the range 0..255.
CXTPChart3dRotation | m_Rotation3d
3D rotation
BOOL | m_bSmooth3dEdges
3D edge smoothing
- Protected Attributes inherited from CXTPChartElement

Detailed Description

This class represents a base radar series style, which is a kind of CXTPChartSeriesStyle.

A point chart is a type of graph, which displays information as a series of data points. It is a basic type of chart common in many fields.

Member Function Documentation

◆ CreateDiagram()

virtual CXTPChartDiagram * CreateDiagram ( )
virtual

Call this function to create the diagram for this series.

Returns
A pointer to a CXTPChartDiagram object which points to the newly created CXTPChartDiagram2D object.

Reimplemented from CXTPChartSeriesStyle.

◆ DoPropExchange()

void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Reads this object from or writes this object to an archive.

Parameters
pPX A CXTPPropExchange object to serialize to or from.

Reimplemented from CXTPChartSeriesStyle.

Reimplemented in CXTPChartRadarLineSeriesStyle, and CXTPChartRadarPointSeriesStyle.

◆ IsStyleDiagram()

virtual BOOL IsStyleDiagram ( CXTPChartDiagram * pDiagram ) const
virtual

Call this function to check whether the chart diagram object passed is a kind of 2D diagram (CXTPChartDiagram2D object).

Parameters
pDiagram A pointer to a chart diagram whose type is to be identified.
Returns
A BOOL value. TRUE if the chart diagram object passed is a 2D diagram, FALSE otherwise.

Reimplemented from CXTPChartSeriesStyle.

The documentation for this class was generated from the following file:
  • XTPChartRadarDiagramSeriesStyle.h


Toolkit Pro: CXTPChartRadarDiagramView Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPChartRadarDiagramView Class Reference

This class represents the view of a chart 2D diagram, which is a kind of CXTPChartDiagramView. More...

Inheritance diagram for CXTPChartRadarDiagramView:
[legend]

Public Member Functions

CXTPChartRadarDiagramView (CXTPChartDiagram *pDiagram, CXTPChartElementView *pParent)
Constructs a CXTPChartRadarDiagramView object.
void | CreateView (CXTPChartDeviceContext *pDC)
Call this function to create the view of the 2D diagram.
void | CalculateView (CXTPChartDeviceContext *pDC, CRect rcBounds)
Call this function to calculate the layout based on a rectangular boundary.
void | UpdateRange (CXTPChartDeviceContext *pDC)
Updates chart range.
virtual CXTPChartDeviceCommand * | CreateDeviceCommand (CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
CXTPChartRadarAxisView * | GetAxisView (CXTPChartAxis *pAxis) const
Call this function to get the view for an axis object.
- Public Member Functions inherited from CXTPChartDiagramView
CXTPChartDiagramView (CXTPChartDiagram *pDiagram, CXTPChartElementView *pParentView)
Constructs a CXTPChartDiagram object.
CRect | GetBounds () const
Call this function to get the bounds of the diagram.
CXTPChartDiagram * | GetDiagram () const
Call this function to get the diagram object associated with the view.
CXTPChartElementView * | GetLabelsView () const
Call this function to get the label view object associated with this diagram view.
CXTPChartElementView * | GetSeriesView () const
Call this function to get the series view object associated with this diagram view.
virtual void | OnMouseWheel (UINT nFlags, short zDelta, CPoint pt)
Handles mouse wheel event.
- Public Member Functions inherited from CXTPChartElementView
CXTPChartElementView (CXTPChartElementView *pParentView)
Constructs a CXTPChartElementView object.
CXTPChartElementView (CXTPChartElementView *pParentView, BOOL bAddToParent)
Constructs a CXTPChartElementView object.
CXTPChartElementView (CXTPChartContainer *pContainer)
Constructs a CXTPChartElementView object.
int | GetCount () const
Call this function to get the number of child views associated with this view.
CXTPChartElementView * | GetAt (int nIndex) const
Call this function to get a child view at a particular index.
CXTPChartElementView * | GetParentView () const
Call this function to get the parent view.
CXTPChartElementView * | AddChildView (CXTPChartElementView *pChildView)
Call this function to add a child view to the current view.
CXTPChartElementView ** GetChildren ()
Provides access to the collection of children elements owned by the view.
CRect | GetBounds () const
Obtains viewed object's bound rectangle.
CRect | GetBounds (BOOL bIncludingChildren) const
Obtains viewed object's bound rectangle.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Protected Member Functions

CXTPChartRadarAxisView * | AddAxisView (CXTPChartDeviceContext *pDC, CXTPChartElementView *pParentView, CXTPChartAxis *pAxis)
Use this function to add an axis view to the diagram view boundary.
- Protected Member Functions inherited from CXTPChartDiagramView
- Protected Member Functions inherited from CXTPChartElementView
virtual | ~CXTPChartElementView ()
Destroys a CXTPChartElementView object, handles cleanup.
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.

Protected Attributes

CXTPChartElementView * | m_pAxisViews
The axis view.
- Protected Attributes inherited from CXTPChartDiagramView
CXTPChartDiagram * | m_pDiagram
Pointer to the associated diagram object.
CRect | m_rcBounds
The diagram bounds.
CXTPChartElementView * | m_pLabelsView
The label view.
CXTPChartElementView * | m_pSeriesView
The series view.
CXTPChartElementView * | m_pTitlesView
Titles View.
- Protected Attributes inherited from CXTPChartElementView
CArray< CXTPChartElementView *, CXTPChartElementView * > | m_arrChildren
The child view collection.
CXTPChartElementView * | m_pParentView
The parent view.
CXTPChartContainer * | m_pContainer
The parent container.
CRect | m_rcBounds
Bounding rectangle.

Detailed Description

This class represents the view of a chart 2D diagram, which is a kind of CXTPChartDiagramView.

Constructor & Destructor Documentation

◆ CXTPChartRadarDiagramView()

CXTPChartRadarDiagramView | ( | CXTPChartDiagram * | pDiagram,
 |  | CXTPChartElementView * | pParent )

Constructs a CXTPChartRadarDiagramView object.

Parameters
pDiagram | A pointer to the chart diagram object.
pParent | A pointer to the parent view object.

Member Function Documentation

◆ AddAxisView()

CXTPChartRadarAxisView * AddAxisView | ( | CXTPChartDeviceContext * | pDC,
 |  | CXTPChartElementView * | pParentView,
 |  | CXTPChartAxis * | pAxis )
 protected

Use this function to add an axis view to the diagram view boundary.

Parameters
pDC | A pointer to the chart device context.
pParentView | The parent view of the axis view.
pAxis | A pointer to the axis object whose view is to be added.
Returns
Adds an axis viwe to diagram view boundary

◆ CalculateView()

void CalculateView | ( | CXTPChartDeviceContext * | pDC,
 |  | CRect | rcBounds )
 virtual

Call this function to calculate the layout based on a rectangular boundary.

Parameters
pDC | A pointer to the chart device context.
rcBounds | The diagram boundary.

Reimplemented from CXTPChartDiagramView.

◆ CreateDeviceCommand()

virtual CXTPChartDeviceCommand * CreateDeviceCommand ( CXTPChartDeviceContext * pDC )
virtual

This function creates a CXTPChartDeviceCommand object.

This object represents the rendering of the chart element.

Parameters
pDC Pointer to a CXTPChartDeviceContext object.
Returns
Returns a CXTPChartDeviceCommand object. This object handles the rendering of an element in the chart. Derived class objects will return more specific device command objects according to their type.

This is a virtual function, so sub-classes can override this function and can give specific implementations according to their type.

Reimplemented from CXTPChartDiagramView.

◆ CreateView()

void CreateView ( CXTPChartDeviceContext * pDC )
virtual

Call this function to create the view of the 2D diagram.

Parameters
pDC A pointer to the chart device context.

Reimplemented from CXTPChartDiagramView.

◆ GetAxisView()

CXTPChartRadarAxisView * GetAxisView ( CXTPChartAxis * pAxis ) const

Call this function to get the view for an axis object.

Parameters
pAxis A pointer to the axis object whose view is to be returned.
Returns
The view for the specified axis object.

◆ UpdateRange()

void UpdateRange ( CXTPChartDeviceContext * pDC )
virtual

Updates chart range.

Parameters
pDC Target device context.

Reimplemented from CXTPChartDiagramView.

The documentation for this class was generated from the following file:
  • XTPChartRadarDiagramView.h


Toolkit Pro: CXTPChartRadarLineSeriesStyle Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPChartRadarLineSeriesStyle Class Reference

This class represents a line series style, which is a kind of CXTPChartSeriesStyle. More...

Inheritance diagram for CXTPChartRadarLineSeriesStyle:
[legend]

Public Member Functions

CXTPChartRadarLineSeriesStyle ()
Constructs a CXTPChartRadarLineSeriesStyle object.
virtual | ~CXTPChartRadarLineSeriesStyle ()
Destroys a CXTPChartRadarLineSeriesStyle object, handles cleanup.
void | DoPropExchange (CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
CXTPChartLineStyle * | GetLineStyle () const
Call this function to get the line style of the line series.
- Public Member Functions inherited from CXTPChartRadarPointSeriesStyle
CXTPChartRadarPointSeriesStyle ()
Constructs a CXTPChartRadarPointSeriesStyle object.
virtual | ~CXTPChartRadarPointSeriesStyle ()
Destroys a CXTPChartRadarPointSeriesStyle object, handles cleanup.
CXTPChartMarker * | GetMarker () const
Call this function to get the marker object associated with this CXTPChartRadarPointSeriesStyle object.
void | DoPropExchange (CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
- Public Member Functions inherited from CXTPChartRadarDiagramSeriesStyle
CXTPChartRadarDiagramSeriesStyle ()
Constructs a CXTPChartRadarDiagramSeriesStyle object.
virtual | ~CXTPChartRadarDiagramSeriesStyle ()
Destroys a CXTPChartRadarDiagramSeriesStyle object, handles cleanup.
virtual CXTPChartDiagram * | CreateDiagram ()
Call this function to create the diagram for this series.
virtual BOOL | IsStyleDiagram (CXTPChartDiagram *pDiagram) const
Call this function to check whether the chart diagram object passed is a kind of 2D diagram (CXTPChartDiagram2D object).
- Public Member Functions inherited from CXTPChartSeriesStyle
CXTPChartSeriesStyle ()
Constructs a CXTPChartSeriesStyle object.
virtual | ~CXTPChartSeriesStyle ()
Destroys a CXTPChartSeriesStyle object, handles cleanup.
virtual CXTPChartSeriesLabel * | GetLabel () const
Call this method to gets the series label object.
virtual CXTPChartSeriesLabel * | SetLabel (CXTPChartSeriesLabel *pLabel)
Call this method to sets the series label object.
virtual CXTPChartErrorBar * | GetErrorBar () const
Call this method to gets the error bar object.
virtual CXTPChartErrorBar * | SetErrorBar (CXTPChartErrorBar *pErrorBar)
Call this method to sets the error bar object.
virtual CXTPChartColor | GetColor () const
Call this method to get the color of the series.
virtual void | SetColor (CXTPChartColor clr)
Call this method to set the color of the series.
virtual void | SetColorEach (BOOL bColorEach)
Call this method to set individual color for each point of the series.
virtual BOOL | IsColorEach () const
This method is called to check if individual color is used for each point of the series.
virtual CXTPChart3dRotation | Get3dRotation () const
Obtains rotation parameters for 3D chart.
virtual void | Set3dRotation (const CXTPChart3dRotation &rotation)
Sets rotation parameters for 3D chart.
virtual void | Set3dRotation (double dYaw, double dPitch, double dRoll)
Sets rotation parameters for 3D chart.
virtual BOOL | Is3dEdgeSmoothingEnabled () const
Enables/disables 3D edge smoothing.
virtual void | Enable3dEdgeSmoothing (BOOL bEnable=TRUE)
Enables/disables 3D edge smoothing.
virtual int | GetTransparency () const
Call this function to gets the transparency of the chart if it is supported by the chart type.
virtual void | SetTransparency (int nTransparency)
Call this function to sets the transparency of the chart if it is supported by the chart type.
virtual void | CorrectAxisSideMargins (CXTPChartAxis *pAxis, double nMinValue, double nMaxValue, double &nCorrection)
Provides default implementation for axis side margins correction.
virtual CXTPChartSeriesStyleAppearance * | GetStyleAppearance () const
Obtains associated style appearance pointer.
virtual void | ApplyTo (CXTPChartDeviceCommand *pCommand)
Applies the style to the command provided in case the command needs style specific details for correct drawing.
virtual int | GetSeriesPointValueIndex () const
Obtains the index of a point element for which an internal value can be otained.
- Public Member Functions inherited from CXTPChartElement
CXTPChartElement ()
Constructs a CXTPChartElement object.
virtual | ~CXTPChartElement ()
Destroys a CXTPChartElement object, handles cleanup.
virtual void | Release ()
Call this function to decrease the usage count of the object.
CXTPChartElement * | GetOwner () const
Call this function to get the owner element.
virtual void | OnChartChanged (XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic properties of the chart.
CXTPChartContent * | GetContent () const
Call this virtual function to get the chart content object.
CXTPChartAppearance * | GetAppearance () const
Call this function to get the the appearance of the chart.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Protected Member Functions

virtual CXTPChartSeriesView * CreateView (CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Call this function to create the view of the point series.
- Protected Member Functions inherited from CXTPChartRadarPointSeriesStyle
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.

Additional Inherited Members

- Public Attributes inherited from CXTPChartElement
- Protected Attributes inherited from CXTPChartRadarPointSeriesStyle
- Protected Attributes inherited from CXTPChartSeriesStyle
CXTPChartSeriesLabel * | m_pLabel
Label object.
CXTPChartErrorBar * | m_pErrorBar
Error bar object.
CXTPChartColor | m_clrColor
Custom color of series.
BOOL | m_bColorEach
TRUE to color each point.
int | m_nTransparency
The transparency value in the range 0..255.
CXTPChart3dRotation | m_Rotation3d
3D rotation
BOOL | m_bSmooth3dEdges
3D edge smoothing
- Protected Attributes inherited from CXTPChartElement

Detailed Description

This class represents a line series style, which is a kind of CXTPChartSeriesStyle.

A point chart is a type of graph, which displays information as a series of data points. It is a basic type of chart common in many fields.

Member Function Documentation

◆ CreateView()

virtual CXTPChartSeriesView * CreateView | ( | CXTPChartSeries * | pSeries,
 |  | CXTPChartDiagramView * | pDiagramView )
 protectedvirtual

Call this function to create the view of the point series.

Parameters
pSeries | A pointer to the chart series object.
pDiagramView | A pointer to the diagram view object.
Returns
Returns a pointer to the associated series view object.

Reimplemented from CXTPChartRadarPointSeriesStyle.

Reimplemented in CXTPChartRadarSplineSeriesStyle.

◆ DoPropExchange()

void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Reads this object from or writes this object to an archive.

Parameters
pPX A CXTPPropExchange object to serialize to or from.

Reimplemented from CXTPChartRadarDiagramSeriesStyle.

◆ GetLineStyle()

AFX_INLINE CXTPChartLineStyle * GetLineStyle ( ) const

Call this function to get the line style of the line series.

Returns
A pointer to the chart line style object.
The documentation for this class was generated from the following file:
  • XTPChartRadarLineSeriesStyle.h


Toolkit Pro: CXTPChartRadarLineSeriesView Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPChartRadarLineSeriesView Class Reference

This class represents the view of a point series, which is a kind of CXTPChartSeriesView. More...

Inheritance diagram for CXTPChartRadarLineSeriesView:
[legend]

Public Member Functions

CXTPChartRadarLineSeriesView (CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Constructs a CXTPChartPointSeriesView object.

Protected Member Functions

CXTPChartSeriesPointView * | CreateSeriesPointView (CXTPChartDeviceContext *pDC, CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Call this function to create the view of the series points.
virtual CXTPChartDeviceCommand * | CreateDeviceCommand (CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
virtual CXTPChartDeviceCommand * | CreateLegendDeviceCommand (CXTPChartDeviceContext *pDC, CRect rcBounds)
This function creates a label view drawing command object.

Detailed Description

This class represents the view of a point series, which is a kind of CXTPChartSeriesView.

Constructor & Destructor Documentation

◆ CXTPChartRadarLineSeriesView()

CXTPChartRadarLineSeriesView | ( | CXTPChartSeries * | pSeries,
 |  | CXTPChartDiagramView * | pDiagramView )

Constructs a CXTPChartPointSeriesView object.

Parameters
pSeries | A pointer to the chart series object.
pDiagramView | A pointer to the diagram view object.

Member Function Documentation

◆ CreateDeviceCommand()

virtual CXTPChartDeviceCommand * CreateDeviceCommand ( CXTPChartDeviceContext * pDC )
protectedvirtual

This function creates a CXTPChartDeviceCommand object.

This object represents the rendering of the pie series.

Parameters
pDC Pointer to a CXTPChartDeviceContext object.
Returns
Returns a CXTPChartDeviceCommand object. This object handles the rendering of an element in the chart. Here it handles the drawing of the pie series.

Reimplemented from CXTPChartElementView.

Reimplemented in CXTPChartRadarSplineSeriesView.

◆ CreateLegendDeviceCommand()

virtual CXTPChartDeviceCommand * CreateLegendDeviceCommand | ( | CXTPChartDeviceContext * | pDC,
 |  | CRect | rcBounds )
 protectedvirtual

This function creates a label view drawing command object.

Parameters
pDC | Pointer to a CXTPChartDeviceContext object.
rcBounds | The rectangular boundary of the legend.
Returns
Returns a new label view drawing command object.

Implements CXTPChartLegendItemView.

◆ CreateSeriesPointView()

CXTPChartSeriesPointView * CreateSeriesPointView | ( | CXTPChartDeviceContext * | pDC,
 |  | CXTPChartSeriesPoint * | pPoint,
 |  | CXTPChartElementView * | pParentView )
 protected

Call this function to create the view of the series points.

Parameters
pDC | A pointer to the chart device context.
pPoint | A pointer to the chart series point object.
pParentView | Parent view pointer.
Returns
Returns a pointer to the chart series point view object.
The documentation for this class was generated from the following file:
  • XTPChartRadarLineSeriesView.h


Toolkit Pro: CXTPChartRadarPointSeriesLabel Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPChartRadarPointSeriesLabel Class Reference

This class abstracts the label of a point series. More...

Inheritance diagram for CXTPChartRadarPointSeriesLabel:
[legend]

Public Member Functions

CXTPChartRadarPointSeriesLabel ()
Constructs a CXTPChartRadarPointSeriesLabel object.
virtual | ~CXTPChartRadarPointSeriesLabel ()
Destroys a CXTPChartRadarPointSeriesLabel object, handles cleanup.
void | DoPropExchange (CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
void | SetAngle (int nAngle)
Call this function to set the angle of the label stem.
int | GetAngle () const
Call this function to get the angle of the label stem.
- Public Member Functions inherited from CXTPChartSeriesLabel
CXTPChartSeriesLabel ()
Constructs a CXTPChartSeriesLabel object.
virtual | ~CXTPChartSeriesLabel ()
Destroys a CXTPChartSeriesLabel object, handles cleanup.
void | SetTextColor (const CXTPChartColor &clrTextColor)
Call this function to set the text color of the label.
CXTPChartColor | GetTextColor () const
Call this function to get the apparent text color of the label.
CXTPChartFont * | GetFont () const
Call this function to get the font of the text label.
void | SetFont (CXTPChartFont *pFont)
Call this function to set the font of the text label.
void | SetShowLines (BOOL bShowLines)
Call this function to set the lines visibility.
BOOL | GetShowLines () const
Call this function to check if the lines are visible.
void | SetLineLength (int nLineLength)
Call this function to set the line length.
int | GetLineLength () const
Call this function to get the line length.
void | SetVisible (BOOL bVisible)
Call this function to set the label visibility.
BOOL | IsVisible () const
Call this function to check if the label is visible.
void | SetAntialiasing (BOOL bAntialiasing)
Call this function to set anti-aliasing ON or OFF.
BOOL | GetAntialiasing () const
Call this function to check if anti-aliasing is ON or OFF.
CXTPChartNumberFormat * | GetFormat () const
Call this function to get a pointer to CXTPChartNumberFormat that specifies how to convert numbers to strings.
void | SetFormat (LPCTSTR lpszFormat)
Obsolete method.
void | SetBackColor (const CXTPChartColor &clrBackColor)
Call this function to set the text color of the label.
CXTPChartColor | GetBackColor () const
Call this function to get the apparent text color of the label.
void | SetLineColor (const CXTPChartColor &clrBackColor)
Call this function to set the text color of the label.
CXTPChartColor | GetLineColor () const
Call this function to get the apparent text color of the label.
int | GetTransparency () const
Call this function to get the transparency of the filled area with respect to the background.
void | SetTransparency (int nTransparency)
Call this function to set the transparency of the filled area with respect to the background.
- Public Member Functions inherited from CXTPChartTextElement
- Public Member Functions inherited from CXTPChartElement
CXTPChartElement ()
Constructs a CXTPChartElement object.
virtual | ~CXTPChartElement ()
Destroys a CXTPChartElement object, handles cleanup.
virtual void | Release ()
Call this function to decrease the usage count of the object.
CXTPChartElement * | GetOwner () const
Call this function to get the owner element.
virtual void | OnChartChanged (XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic properties of the chart.
CXTPChartContent * | GetContent () const
Call this virtual function to get the chart content object.
CXTPChartAppearance * | GetAppearance () const
Call this function to get the the appearance of the chart.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Protected Attributes

int | m_nAngle
The stem angle.
- Protected Attributes inherited from CXTPChartSeriesLabel
CXTPChartColor | m_clrTextColor
The text color.
CXTPChartColor | m_clrBackColor
The background color.
CXTPChartColor | m_clrLineColor
The line color.
BOOL | m_bVisible
TRUE if the label is visible and FALSE if not.
CXTPChartFont * | m_pFont
The font of the label.
BOOL | m_bAntialiasing
TRUE if antialiasing enabled, FALSE if not.
BOOL | m_bShowLines
TRUE if the lines are visible, FALSE if not.
int | m_nLineLength
The line length.
CXTPChartBorder * | m_pBorder
Chart border object.
int | m_nTransparency
The transparency values range from 0 to 255.
- Protected Attributes inherited from CXTPChartElement

Additional Inherited Members

- Public Attributes inherited from CXTPChartElement
- Protected Member Functions inherited from CXTPChartSeriesLabel
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.

Detailed Description

This class abstracts the label of a point series.

It is a kind of chart series label.

Member Function Documentation

◆ DoPropExchange()

void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Reads this object from or writes this object to an archive.

Parameters
pPX A CXTPPropExchange object to serialize to or from.

Reimplemented from CXTPChartSeriesLabel.

◆ GetAngle()

AFX_INLINE int GetAngle ( ) const

Call this function to get the angle of the label stem.

Returns
An intger value denoting the angle of the label stem.

◆ SetAngle()

AFX_INLINE void SetAngle ( int nAngle )

Call this function to set the angle of the label stem.

Parameters
nAngle The angle of the label stem.
The documentation for this class was generated from the following file:
  • XTPChartRadarPointSeriesLabel.h


Toolkit Pro: CXTPChartRadarPointSeriesLabelView Class Reference

Public Member Functions | List of all members
CXTPChartRadarPointSeriesLabelView Class Reference

This class abstracts the view of the label of a point series, it is a kind of chart series label view. More...

Public Member Functions

CXTPChartRadarPointSeriesLabelView (CXTPChartSeriesLabel *pLabel, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView)
Constructs a CXTPChartRadarPointSeriesLabelView object.
virtual CXTPChartDeviceCommand * | CreateDeviceCommand (CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
virtual CXTPChartDeviceCommand * | CreateDeviceCommand (CXTPChartDeviceContext *pDC, const CXTPChartPointF &ptAnchorPoint, double dAnchorAngle, const CXTPChartString &text)
This function creates a CXTPChartDeviceCommand object.
virtual CXTPChartPointF | GetAnchorPoint () const
This function calculates the anchor point of the label stem.

Detailed Description

This class abstracts the view of the label of a point series, it is a kind of chart series label view.

Constructor & Destructor Documentation

◆ CXTPChartRadarPointSeriesLabelView()

CXTPChartRadarPointSeriesLabelView | ( | CXTPChartSeriesLabel * | pLabel,
 |  | CXTPChartSeriesPointView * | pPointView,
 |  | CXTPChartElementView * | pParentView )

Constructs a CXTPChartRadarPointSeriesLabelView object.

Parameters
pLabel | The pointer to the chart series label object.
pPointView | A pointer to the chart series view.
pParentView | Parent view pointer.

Member Function Documentation

◆ CreateDeviceCommand() [1/2]

virtual CXTPChartDeviceCommand * CreateDeviceCommand ( CXTPChartDeviceContext * pDC )
virtual

This function creates a CXTPChartDeviceCommand object.

This object represents the rendering of the chart series label.

Parameters
pDC Pointer to a CXTPChartDeviceContext object.
Returns
Returns a pointer to a CXTPChartDeviceCommand object. This polymorphic object handles the rendering of an element in the chart. Here it handles the drawing of the chart series label.

Reimplemented from CXTPChartElementView.

◆ CreateDeviceCommand() [2/2]

virtual CXTPChartDeviceCommand * CreateDeviceCommand | ( | CXTPChartDeviceContext * | pDC,
 |  | const CXTPChartPointF & | ptAnchorPoint,
 |  | double | dAnchorAngle,
 |  | const CXTPChartString & | text )
 virtual

This function creates a CXTPChartDeviceCommand object.

This object represents the rendering of the chart series label.

Parameters
pDC | Pointer to a CXTPChartDeviceContext object.
ptAnchorPoint | Anchor point.
dAnchorAngle | Anchor angle.
text | Text.
Returns
Returns a pointer to a CXTPChartDeviceCommand object. This polymorphic object handles the rendering of an element in the chart. Here it handles the drawing of the chart series label.

◆ GetAnchorPoint()

virtual CXTPChartPointF GetAnchorPoint ( ) const
virtual

This function calculates the anchor point of the label stem.

Returns
A CXTPChartPointF object denoting the anchor point.
The documentation for this class was generated from the following file:
  • XTPChartRadarPointSeriesLabel.h


Toolkit Pro: CXTPChartRadarPointSeriesPointView Class Reference

Public Member Functions | List of all members
CXTPChartRadarPointSeriesPointView Class Reference

This class represents the view of a point series point, which is a kind of CXTPChartSeriesPointView. More...

Inheritance diagram for CXTPChartRadarPointSeriesPointView:
[legend]

Public Member Functions

CXTPChartRadarPointSeriesPointView (CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Constructs a CXTPChartPointSeriesPointView object.
virtual CXTPChartDeviceCommand * | CreateDeviceCommand (CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
virtual CXTPChartDeviceCommand * | CreateLegendDeviceCommand (CXTPChartDeviceContext *pDC, CRect rcBounds)
This function creates a label view drawing command object.
CXTPChartPointF | GetScreenPoint () const
Call this function to get the screen point from the series point.
- Public Member Functions inherited from CXTPChartSeriesPointView
CXTPChartSeriesPointView (CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Constructs the view object.
CXTPChartSeriesPointView (CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView, BOOL bAddToParent)
Constructs the view object.
CXTPChartSeriesPoint * | GetPoint () const
Obtains point model object.
CXTPChartSeriesView * | GetSeriesView () const
Obtains parent series view.
CXTPChartColor | GetColor () const
Obtain view color values.
CXTPChartColor | GetColor2 () const
Obtain view color values.
double | GetInternalValue () const
Obtains point interval value.
virtual CXTPChartString | GetLegendName () const
This function returns the legend name.
virtual void | UpdateMinMaxRange (double &nMinValue, double &nMaxValue) const
Provides a default empty implementation for min/max range update request.
- Public Member Functions inherited from CXTPChartElementView
CXTPChartElementView (CXTPChartElementView *pParentView)
Constructs a CXTPChartElementView object.
CXTPChartElementView (CXTPChartElementView *pParentView, BOOL bAddToParent)
Constructs a CXTPChartElementView object.
CXTPChartElementView (CXTPChartContainer *pContainer)
Constructs a CXTPChartElementView object.
int | GetCount () const
Call this function to get the number of child views associated with this view.
CXTPChartElementView * | GetAt (int nIndex) const
Call this function to get a child view at a particular index.
CXTPChartElementView * | GetParentView () const
Call this function to get the parent view.
CXTPChartElementView * | AddChildView (CXTPChartElementView *pChildView)
Call this function to add a child view to the current view.
CXTPChartElementView ** GetChildren ()
Provides access to the collection of children elements owned by the view.
CRect | GetBounds () const
Obtains viewed object's bound rectangle.
CRect | GetBounds (BOOL bIncludingChildren) const
Obtains viewed object's bound rectangle.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.
- Public Member Functions inherited from CXTPChartLegendItemView
virtual | ~CXTPChartLegendItemView ()
Handles object destruction.

Additional Inherited Members

- Public Attributes inherited from CXTPChartSeriesPointView
double | m_dInternalValue
Point internal value.
- Protected Member Functions inherited from CXTPChartElementView
virtual | ~CXTPChartElementView ()
Destroys a CXTPChartElementView object, handles cleanup.
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.
- Protected Attributes inherited from CXTPChartSeriesPointView
CXTPChartSeriesPoint * | m_pPoint
Point model object pointer.
- Protected Attributes inherited from CXTPChartElementView
CArray< CXTPChartElementView *, CXTPChartElementView * > | m_arrChildren
The child view collection.
CXTPChartElementView * | m_pParentView
The parent view.
CXTPChartContainer * | m_pContainer
The parent container.
CRect | m_rcBounds
Bounding rectangle.

Detailed Description

This class represents the view of a point series point, which is a kind of CXTPChartSeriesPointView.

Constructor & Destructor Documentation

◆ CXTPChartRadarPointSeriesPointView()

CXTPChartRadarPointSeriesPointView | ( | CXTPChartSeriesPoint * | pPoint,
 |  | CXTPChartElementView * | pParentView )

Constructs a CXTPChartPointSeriesPointView object.

Parameters
pPoint | A pointer to the chart series point.
pParentView | Parent view pointer.

Member Function Documentation

◆ CreateDeviceCommand()

virtual CXTPChartDeviceCommand * CreateDeviceCommand ( CXTPChartDeviceContext * pDC )
virtual

This function creates a CXTPChartDeviceCommand object.

This object represents the rendering of the series point.

Parameters
pDC Pointer to a CXTPChartDeviceContext object.
Returns
Returns a CXTPChartDeviceCommand object. This object handles the rendering of an element in the chart. Here it handles the drawing of the series point.

Reimplemented from CXTPChartElementView.

◆ CreateLegendDeviceCommand()

virtual CXTPChartDeviceCommand * CreateLegendDeviceCommand | ( | CXTPChartDeviceContext * | pDC,
 |  | CRect | rcBounds )
 virtual

This function creates a label view drawing command object.

Parameters
pDC | Pointer to a CXTPChartDeviceContext object.
rcBounds | The rectangular boundary of the legend.
Returns
Returns a new label view drawing command object.

Reimplemented from CXTPChartSeriesPointView.

◆ GetScreenPoint()

CXTPChartPointF GetScreenPoint ( ) const

Call this function to get the screen point from the series point.

Returns
Returns a screen point object CXTPChartPointF.
The documentation for this class was generated from the following file:
  • XTPChartRadarPointSeriesView.h


Toolkit Pro: CXTPChartRadarPointSeriesStyle Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPChartRadarPointSeriesStyle Class Reference

This class represents a line series style, which is a kind of CXTPChartSeriesStyle. More...

Inheritance diagram for CXTPChartRadarPointSeriesStyle:
[legend]

Public Member Functions

CXTPChartRadarPointSeriesStyle ()
Constructs a CXTPChartRadarPointSeriesStyle object.
virtual | ~CXTPChartRadarPointSeriesStyle ()
Destroys a CXTPChartRadarPointSeriesStyle object, handles cleanup.
CXTPChartMarker * | GetMarker () const
Call this function to get the marker object associated with this CXTPChartRadarPointSeriesStyle object.
void | DoPropExchange (CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
- Public Member Functions inherited from CXTPChartRadarDiagramSeriesStyle
CXTPChartRadarDiagramSeriesStyle ()
Constructs a CXTPChartRadarDiagramSeriesStyle object.
virtual | ~CXTPChartRadarDiagramSeriesStyle ()
Destroys a CXTPChartRadarDiagramSeriesStyle object, handles cleanup.
virtual CXTPChartDiagram * | CreateDiagram ()
Call this function to create the diagram for this series.
virtual BOOL | IsStyleDiagram (CXTPChartDiagram *pDiagram) const
Call this function to check whether the chart diagram object passed is a kind of 2D diagram (CXTPChartDiagram2D object).
- Public Member Functions inherited from CXTPChartSeriesStyle
CXTPChartSeriesStyle ()
Constructs a CXTPChartSeriesStyle object.
virtual | ~CXTPChartSeriesStyle ()
Destroys a CXTPChartSeriesStyle object, handles cleanup.
virtual CXTPChartSeriesLabel * | GetLabel () const
Call this method to gets the series label object.
virtual CXTPChartSeriesLabel * | SetLabel (CXTPChartSeriesLabel *pLabel)
Call this method to sets the series label object.
virtual CXTPChartErrorBar * | GetErrorBar () const
Call this method to gets the error bar object.
virtual CXTPChartErrorBar * | SetErrorBar (CXTPChartErrorBar *pErrorBar)
Call this method to sets the error bar object.
virtual CXTPChartColor | GetColor () const
Call this method to get the color of the series.
virtual void | SetColor (CXTPChartColor clr)
Call this method to set the color of the series.
virtual void | SetColorEach (BOOL bColorEach)
Call this method to set individual color for each point of the series.
virtual BOOL | IsColorEach () const
This method is called to check if individual color is used for each point of the series.
virtual CXTPChart3dRotation | Get3dRotation () const
Obtains rotation parameters for 3D chart.
virtual void | Set3dRotation (const CXTPChart3dRotation &rotation)
Sets rotation parameters for 3D chart.
virtual void | Set3dRotation (double dYaw, double dPitch, double dRoll)
Sets rotation parameters for 3D chart.
virtual BOOL | Is3dEdgeSmoothingEnabled () const
Enables/disables 3D edge smoothing.
virtual void | Enable3dEdgeSmoothing (BOOL bEnable=TRUE)
Enables/disables 3D edge smoothing.
virtual int | GetTransparency () const
Call this function to gets the transparency of the chart if it is supported by the chart type.
virtual void | SetTransparency (int nTransparency)
Call this function to sets the transparency of the chart if it is supported by the chart type.
virtual void | CorrectAxisSideMargins (CXTPChartAxis *pAxis, double nMinValue, double nMaxValue, double &nCorrection)
Provides default implementation for axis side margins correction.
virtual CXTPChartSeriesStyleAppearance * | GetStyleAppearance () const
Obtains associated style appearance pointer.
virtual void | ApplyTo (CXTPChartDeviceCommand *pCommand)
Applies the style to the command provided in case the command needs style specific details for correct drawing.
virtual int | GetSeriesPointValueIndex () const
Obtains the index of a point element for which an internal value can be otained.
- Public Member Functions inherited from CXTPChartElement
CXTPChartElement ()
Constructs a CXTPChartElement object.
virtual | ~CXTPChartElement ()
Destroys a CXTPChartElement object, handles cleanup.
virtual void | Release ()
Call this function to decrease the usage count of the object.
CXTPChartElement * | GetOwner () const
Call this function to get the owner element.
virtual void | OnChartChanged (XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic properties of the chart.
CXTPChartContent * | GetContent () const
Call this virtual function to get the chart content object.
CXTPChartAppearance * | GetAppearance () const
Call this function to get the the appearance of the chart.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Protected Member Functions

virtual CXTPChartSeriesView * CreateView (CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Call this function to create a view of the point series.
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.

Additional Inherited Members

- Public Attributes inherited from CXTPChartElement
- Protected Attributes inherited from CXTPChartSeriesStyle
CXTPChartSeriesLabel * | m_pLabel
Label object.
CXTPChartErrorBar * | m_pErrorBar
Error bar object.
CXTPChartColor | m_clrColor
Custom color of series.
BOOL | m_bColorEach
TRUE to color each point.
int | m_nTransparency
The transparency value in the range 0..255.
CXTPChart3dRotation | m_Rotation3d
3D rotation
BOOL | m_bSmooth3dEdges
3D edge smoothing
- Protected Attributes inherited from CXTPChartElement

Detailed Description

This class represents a line series style, which is a kind of CXTPChartSeriesStyle.

A point chart is a type of graph, which displays information as a series of data points. It is a basic type of chart common in many fields.

Member Function Documentation

◆ CreateView()

virtual CXTPChartSeriesView * CreateView | ( | CXTPChartSeries * | pSeries,
 |  | CXTPChartDiagramView * | pDiagramView )
 protectedvirtual

Call this function to create a view of the point series.

Parameters
pSeries | A pointer to the chart series object.
pDiagramView | A pointer to the diagram view object.
Returns
Returns a pointer to the associated series view object.

Implements CXTPChartSeriesStyle.

Reimplemented in CXTPChartRadarAreaSeriesStyle, CXTPChartRadarLineSeriesStyle, CXTPChartRadarSplineAreaSeriesStyle, and CXTPChartRadarSplineSeriesStyle.

◆ DoPropExchange()

void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Reads this object from or writes this object to an archive.

Parameters
pPX A CXTPPropExchange object to serialize to or from.

Reimplemented from CXTPChartRadarDiagramSeriesStyle.

◆ GetMarker()

AFX_INLINE CXTPChartMarker * GetMarker ( ) const

Call this function to get the marker object associated with this CXTPChartRadarPointSeriesStyle object.

Returns
A pointer to the CXTPChartMarker object.
The documentation for this class was generated from the following file:
  • XTPChartRadarPointSeriesStyle.h


Toolkit Pro: CXTPChartRadarPointSeriesView Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPChartRadarPointSeriesView Class Reference

This class represents the view of a point series, which is a kind of CXTPChartSeriesView. More...

Public Member Functions

CXTPChartRadarPointSeriesView (CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Constructs a CXTPChartPointSeriesView object.
virtual CXTPChartDeviceCommand * CreateLegendDeviceCommand (CXTPChartDeviceContext *pDC, CRect rcBounds)
This function creates a label view drawing command object.

Protected Member Functions

CXTPChartSeriesPointView * CreateSeriesPointView (CXTPChartDeviceContext *pDC, CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Call this function to create a view of the series point.

Detailed Description

This class represents the view of a point series, which is a kind of CXTPChartSeriesView.

Constructor & Destructor Documentation

◆ CXTPChartRadarPointSeriesView()

CXTPChartRadarPointSeriesView | ( | CXTPChartSeries * | pSeries,
 |  | CXTPChartDiagramView * | pDiagramView )

Constructs a CXTPChartPointSeriesView object.

Parameters
pSeries | A pointer to the chart series object.
pDiagramView | A pointer to the diagram view object.

Member Function Documentation

◆ CreateLegendDeviceCommand()

virtual CXTPChartDeviceCommand * CreateLegendDeviceCommand | ( | CXTPChartDeviceContext * | pDC,
 |  | CRect | rcBounds )
 virtual

This function creates a label view drawing command object.

Parameters
pDC | Pointer to a CXTPChartDeviceContext object.
rcBounds | The rectangular boundary of the legend.
Returns
Returns a new label view drawing command object.

Implements CXTPChartLegendItemView.

◆ CreateSeriesPointView()

CXTPChartSeriesPointView * CreateSeriesPointView | ( | CXTPChartDeviceContext * | pDC,
 |  | CXTPChartSeriesPoint * | pPoint,
 |  | CXTPChartElementView * | pParentView )
 protected

Call this function to create a view of the series point.

Parameters
pDC | A pointer to the chart device context.
pPoint | A pointer to the chart series point object.
pParentView | Parent view pointer.
Returns
Returns a pointer to the series point view object.
The documentation for this class was generated from the following file:
  • XTPChartRadarPointSeriesView.h


Toolkit Pro: CXTPChartRadarSplineAreaSeriesStyle Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPChartRadarSplineAreaSeriesStyle Class Reference

This class represents a spline area series style, which is a kind of CXTPChartRadarAreaSeriesStyle. More...

Inheritance diagram for CXTPChartRadarSplineAreaSeriesStyle:
[legend]

Public Member Functions

CXTPChartRadarSplineAreaSeriesStyle ()
Constructs a CXTPChartRadarSplineAreaSeriesStyle object.
virtual | ~CXTPChartRadarSplineAreaSeriesStyle ()
Destroys a CXTPChartRadarSplineAreaSeriesStyle object, handles cleanup.
- Public Member Functions inherited from CXTPChartRadarAreaSeriesStyle
CXTPChartRadarAreaSeriesStyle ()
Constructs a CXTPChartRadarAreaSeriesStyle object.
virtual | ~CXTPChartRadarAreaSeriesStyle ()
Destroys a CXTPChartRadarAreaSeriesStyle object, handles cleanup.
void | DoPropExchange (CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
CXTPChartFillStyle * | GetFillStyle () const
Call this function to get the background fill style.
int | GetTransparency () const
Call this function to get the transparency of the filled area with respect to the background.
void | SetTransparency (int nTransparency)
Call this function to set the transparency of the filled area with respect to the background.
- Public Member Functions inherited from CXTPChartRadarPointSeriesStyle
CXTPChartRadarPointSeriesStyle ()
Constructs a CXTPChartRadarPointSeriesStyle object.
virtual | ~CXTPChartRadarPointSeriesStyle ()
Destroys a CXTPChartRadarPointSeriesStyle object, handles cleanup.
CXTPChartMarker * | GetMarker () const
Call this function to get the marker object associated with this CXTPChartRadarPointSeriesStyle object.
void | DoPropExchange (CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
- Public Member Functions inherited from CXTPChartRadarDiagramSeriesStyle
CXTPChartRadarDiagramSeriesStyle ()
Constructs a CXTPChartRadarDiagramSeriesStyle object.
virtual | ~CXTPChartRadarDiagramSeriesStyle ()
Destroys a CXTPChartRadarDiagramSeriesStyle object, handles cleanup.
virtual CXTPChartDiagram * | CreateDiagram ()
Call this function to create the diagram for this series.
virtual BOOL | IsStyleDiagram (CXTPChartDiagram *pDiagram) const
Call this function to check whether the chart diagram object passed is a kind of 2D diagram (CXTPChartDiagram2D object).
- Public Member Functions inherited from CXTPChartSeriesStyle
CXTPChartSeriesStyle ()
Constructs a CXTPChartSeriesStyle object.
virtual | ~CXTPChartSeriesStyle ()
Destroys a CXTPChartSeriesStyle object, handles cleanup.
virtual CXTPChartSeriesLabel * | GetLabel () const
Call this method to gets the series label object.
virtual CXTPChartSeriesLabel * | SetLabel (CXTPChartSeriesLabel *pLabel)
Call this method to sets the series label object.
virtual CXTPChartErrorBar * | GetErrorBar () const
Call this method to gets the error bar object.
virtual CXTPChartErrorBar * | SetErrorBar (CXTPChartErrorBar *pErrorBar)
Call this method to sets the error bar object.
virtual CXTPChartColor | GetColor () const
Call this method to get the color of the series.
virtual void | SetColor (CXTPChartColor clr)
Call this method to set the color of the series.
virtual void | SetColorEach (BOOL bColorEach)
Call this method to set individual color for each point of the series.
virtual BOOL | IsColorEach () const
This method is called to check if individual color is used for each point of the series.
virtual CXTPChart3dRotation | Get3dRotation () const
Obtains rotation parameters for 3D chart.
virtual void | Set3dRotation (const CXTPChart3dRotation &rotation)
Sets rotation parameters for 3D chart.
virtual void | Set3dRotation (double dYaw, double dPitch, double dRoll)
Sets rotation parameters for 3D chart.
virtual BOOL | Is3dEdgeSmoothingEnabled () const
Enables/disables 3D edge smoothing.
virtual void | Enable3dEdgeSmoothing (BOOL bEnable=TRUE)
Enables/disables 3D edge smoothing.
virtual void | CorrectAxisSideMargins (CXTPChartAxis *pAxis, double nMinValue, double nMaxValue, double &nCorrection)
Provides default implementation for axis side margins correction.
virtual CXTPChartSeriesStyleAppearance * | GetStyleAppearance () const
Obtains associated style appearance pointer.
virtual void | ApplyTo (CXTPChartDeviceCommand *pCommand)
Applies the style to the command provided in case the command needs style specific details for correct drawing.
virtual int | GetSeriesPointValueIndex () const
Obtains the index of a point element for which an internal value can be otained.
- Public Member Functions inherited from CXTPChartElement
CXTPChartElement ()
Constructs a CXTPChartElement object.
virtual | ~CXTPChartElement ()
Destroys a CXTPChartElement object, handles cleanup.
virtual void | Release ()
Call this function to decrease the usage count of the object.
CXTPChartElement * | GetOwner () const
Call this function to get the owner element.
virtual void | OnChartChanged (XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic properties of the chart.
CXTPChartContent * | GetContent () const
Call this virtual function to get the chart content object.
CXTPChartAppearance * | GetAppearance () const
Call this function to get the the appearance of the chart.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Protected Member Functions

virtual CXTPChartSeriesView * CreateView (CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Use this function to create a spline area series view object.
- Protected Member Functions inherited from CXTPChartRadarAreaSeriesStyle
- Protected Member Functions inherited from CXTPChartRadarPointSeriesStyle
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.

Additional Inherited Members

- Public Attributes inherited from CXTPChartElement
- Protected Attributes inherited from CXTPChartRadarAreaSeriesStyle
int | m_nTransparency
The transparency values range from 0 to 255.
CXTPChartBorder * | m_pBorder
The chart border object pointer.
CXTPChartFillStyle * | m_pFillStyle
The chart background fill style.
- Protected Attributes inherited from CXTPChartRadarPointSeriesStyle
- Protected Attributes inherited from CXTPChartSeriesStyle
CXTPChartSeriesLabel * | m_pLabel
Label object.
CXTPChartErrorBar * | m_pErrorBar
Error bar object.
CXTPChartColor | m_clrColor
Custom color of series.
BOOL | m_bColorEach
TRUE to color each point.
int | m_nTransparency
The transparency value in the range 0..255.
CXTPChart3dRotation | m_Rotation3d
3D rotation
BOOL | m_bSmooth3dEdges
3D edge smoothing
- Protected Attributes inherited from CXTPChartElement

Detailed Description

This class represents a spline area series style, which is a kind of CXTPChartRadarAreaSeriesStyle.

Spline area series displays graphically the quantitative data in a chart. It displays a series as a set of points connected by a spline with all the area filled in below the line.

Member Function Documentation

◆ CreateView()

virtual CXTPChartSeriesView * CreateView | ( | CXTPChartSeries * | pSeries,
 |  | CXTPChartDiagramView * | pDiagramView )
 protectedvirtual

Use this function to create a spline area series view object.

Parameters
pSeries | Pointer to a chart series object.
pDiagramView | Pointer to a chart diagram view object.
Returns
Returns a pointer to the associated series view object.

CXTPChartRadarSplineAreaSeriesView class abstracts the view of a spine area series.

Reimplemented from CXTPChartRadarAreaSeriesStyle.

The documentation for this class was generated from the following file:
  • XTPChartRadarSplineAreaSeriesStyle.h


Toolkit Pro: CXTPChartRadarSplineAreaSeriesView Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPChartRadarSplineAreaSeriesView Class Reference

CXTPChartRadarSplineAreaSeriesView is a kind of CXTPChartSeriesView. More...

Inheritance diagram for CXTPChartRadarSplineAreaSeriesView:
[legend]

Public Member Functions

CXTPChartRadarSplineAreaSeriesView (CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Constructs a CXTPChartRadarSplineAreaSeriesView object.
- Public Member Functions inherited from CXTPChartRadarAreaSeriesView
CXTPChartRadarAreaSeriesView (CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Constructs a CXTPChartPointSeriesView object.
CXTPChartColor | GetActualColor () const
Call this function to get the actual color of the series.
CXTPChartColor | GetActualColor2 () const
Call this function to get the second actual color of the series.
CXTPChartColor | GetBorderActualColor () const
Call this function to get the actual color of the series border.
virtual CXTPChartDeviceCommand * | CreateLegendDeviceCommand (CXTPChartDeviceContext *pDC, CRect rcBounds)
This function creates a label view drawing command object.

Protected Member Functions

CXTPChartSeriesPointView * | CreateSeriesPointView (CXTPChartDeviceContext *pDC, CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Call this function to create a spline area series point view object.
virtual CXTPChartDeviceCommand * | CreateDeviceCommand (CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
- Protected Member Functions inherited from CXTPChartRadarAreaSeriesView
CXTPChartSeriesPointView * | CreateSeriesPointView (CXTPChartDeviceContext *pDC, CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Call this function to create a view of the series points.

Detailed Description

CXTPChartRadarSplineAreaSeriesView is a kind of CXTPChartSeriesView.

This class represents the view of the area series of a chart.

Spline area series displays graphically the quantitative data in a chart. It displays a series as a set of points connected by a spline with all the area filled in below the line.

Constructor & Destructor Documentation

◆ CXTPChartRadarSplineAreaSeriesView()

CXTPChartRadarSplineAreaSeriesView | ( | CXTPChartSeries * | pSeries,
 |  | CXTPChartDiagramView * | pDiagramView )

Constructs a CXTPChartRadarSplineAreaSeriesView object.

Parameters
pSeries | Pointer to a chart series object.
pDiagramView | Pointer to a chart diagram view object.

Member Function Documentation

◆ CreateDeviceCommand()

virtual CXTPChartDeviceCommand * CreateDeviceCommand ( CXTPChartDeviceContext * pDC )
protectedvirtual

This function creates a CXTPChartDeviceCommand object.

This object represents the rendering of a spline area series in the chart.

Parameters
pDC Pointer to a CXTPChartDeviceContext object.
Returns
A CXTPChartDeviceCommand object. This polymorphic object handles the rendering of an element in the chart. Here it handles the drawing of the spline area series of the chart.

Reimplemented from CXTPChartRadarAreaSeriesView.

◆ CreateSeriesPointView()

CXTPChartSeriesPointView * CreateSeriesPointView | ( | CXTPChartDeviceContext * | pDC,
 |  | CXTPChartSeriesPoint * | pPoint,
 |  | CXTPChartElementView * | pParentView )
 protected

Call this function to create a spline area series point view object.

Parameters
pDC | Pointer to a chart device context object.
pPoint | Pointer to a chart series object.
pParentView | Parent view pointer.
Returns
Returns a pointer to the series point view object.

CXTPChartSeriesPointView object abstracts the view of a point in a series.

The documentation for this class was generated from the following file:
  • XTPChartRadarSplineAreaSeriesStyle.h


Toolkit Pro: CXTPChartRadarSplineSeriesStyle Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPChartRadarSplineSeriesStyle Class Reference

This class represents the spline series style in the chart. More...

Inheritance diagram for CXTPChartRadarSplineSeriesStyle:
[legend]

Public Member Functions

CXTPChartRadarSplineSeriesStyle ()
Constructs a CXTPChartRadarSplineSeriesStyle object.
virtual | ~CXTPChartRadarSplineSeriesStyle ()
Destroys a CXTPChartRadarSplineSeriesStyle object, handles cleanup.
- Public Member Functions inherited from CXTPChartRadarLineSeriesStyle
CXTPChartRadarLineSeriesStyle ()
Constructs a CXTPChartRadarLineSeriesStyle object.
virtual | ~CXTPChartRadarLineSeriesStyle ()
Destroys a CXTPChartRadarLineSeriesStyle object, handles cleanup.
void | DoPropExchange (CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
CXTPChartLineStyle * | GetLineStyle () const
Call this function to get the line style of the line series.
- Public Member Functions inherited from CXTPChartRadarPointSeriesStyle
CXTPChartRadarPointSeriesStyle ()
Constructs a CXTPChartRadarPointSeriesStyle object.
virtual | ~CXTPChartRadarPointSeriesStyle ()
Destroys a CXTPChartRadarPointSeriesStyle object, handles cleanup.
CXTPChartMarker * | GetMarker () const
Call this function to get the marker object associated with this CXTPChartRadarPointSeriesStyle object.
void | DoPropExchange (CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
- Public Member Functions inherited from CXTPChartRadarDiagramSeriesStyle
CXTPChartRadarDiagramSeriesStyle ()
Constructs a CXTPChartRadarDiagramSeriesStyle object.
virtual | ~CXTPChartRadarDiagramSeriesStyle ()
Destroys a CXTPChartRadarDiagramSeriesStyle object, handles cleanup.
virtual CXTPChartDiagram * | CreateDiagram ()
Call this function to create the diagram for this series.
virtual BOOL | IsStyleDiagram (CXTPChartDiagram *pDiagram) const
Call this function to check whether the chart diagram object passed is a kind of 2D diagram (CXTPChartDiagram2D object).
- Public Member Functions inherited from CXTPChartSeriesStyle
CXTPChartSeriesStyle ()
Constructs a CXTPChartSeriesStyle object.
virtual | ~CXTPChartSeriesStyle ()
Destroys a CXTPChartSeriesStyle object, handles cleanup.
virtual CXTPChartSeriesLabel * | GetLabel () const
Call this method to gets the series label object.
virtual CXTPChartSeriesLabel * | SetLabel (CXTPChartSeriesLabel *pLabel)
Call this method to sets the series label object.
virtual CXTPChartErrorBar * | GetErrorBar () const
Call this method to gets the error bar object.
virtual CXTPChartErrorBar * | SetErrorBar (CXTPChartErrorBar *pErrorBar)
Call this method to sets the error bar object.
virtual CXTPChartColor | GetColor () const
Call this method to get the color of the series.
virtual void | SetColor (CXTPChartColor clr)
Call this method to set the color of the series.
virtual void | SetColorEach (BOOL bColorEach)
Call this method to set individual color for each point of the series.
virtual BOOL | IsColorEach () const
This method is called to check if individual color is used for each point of the series.
virtual CXTPChart3dRotation | Get3dRotation () const
Obtains rotation parameters for 3D chart.
virtual void | Set3dRotation (const CXTPChart3dRotation &rotation)
Sets rotation parameters for 3D chart.
virtual void | Set3dRotation (double dYaw, double dPitch, double dRoll)
Sets rotation parameters for 3D chart.
virtual BOOL | Is3dEdgeSmoothingEnabled () const
Enables/disables 3D edge smoothing.
virtual void | Enable3dEdgeSmoothing (BOOL bEnable=TRUE)
Enables/disables 3D edge smoothing.
virtual int | GetTransparency () const
Call this function to gets the transparency of the chart if it is supported by the chart type.
virtual void | SetTransparency (int nTransparency)
Call this function to sets the transparency of the chart if it is supported by the chart type.
virtual void | CorrectAxisSideMargins (CXTPChartAxis *pAxis, double nMinValue, double nMaxValue, double &nCorrection)
Provides default implementation for axis side margins correction.
virtual CXTPChartSeriesStyleAppearance * | GetStyleAppearance () const
Obtains associated style appearance pointer.
virtual void | ApplyTo (CXTPChartDeviceCommand *pCommand)
Applies the style to the command provided in case the command needs style specific details for correct drawing.
virtual int | GetSeriesPointValueIndex () const
Obtains the index of a point element for which an internal value can be otained.
- Public Member Functions inherited from CXTPChartElement
CXTPChartElement ()
Constructs a CXTPChartElement object.
virtual | ~CXTPChartElement ()
Destroys a CXTPChartElement object, handles cleanup.
virtual void | Release ()
Call this function to decrease the usage count of the object.
CXTPChartElement * | GetOwner () const
Call this function to get the owner element.
virtual void | OnChartChanged (XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic properties of the chart.
CXTPChartContent * | GetContent () const
Call this virtual function to get the chart content object.
CXTPChartAppearance * | GetAppearance () const
Call this function to get the the appearance of the chart.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Protected Member Functions

virtual CXTPChartSeriesView * CreateView (CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Call this function to create a view of the spline series.
- Protected Member Functions inherited from CXTPChartRadarLineSeriesStyle
- Protected Member Functions inherited from CXTPChartRadarPointSeriesStyle
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.

Additional Inherited Members

- Public Attributes inherited from CXTPChartElement
- Protected Attributes inherited from CXTPChartRadarLineSeriesStyle
- Protected Attributes inherited from CXTPChartRadarPointSeriesStyle
- Protected Attributes inherited from CXTPChartSeriesStyle
CXTPChartSeriesLabel * | m_pLabel
Label object.
CXTPChartErrorBar * | m_pErrorBar
Error bar object.
CXTPChartColor | m_clrColor
Custom color of series.
BOOL | m_bColorEach
TRUE to color each point.
int | m_nTransparency
The transparency value in the range 0..255.
CXTPChart3dRotation | m_Rotation3d
3D rotation
BOOL | m_bSmooth3dEdges
3D edge smoothing
- Protected Attributes inherited from CXTPChartElement

Detailed Description

This class represents the spline series style in the chart.

Objects of this class are a kind of point series style of a chart.

Member Function Documentation

◆ CreateView()

virtual CXTPChartSeriesView * CreateView | ( | CXTPChartSeries * | pSeries,
 |  | CXTPChartDiagramView * | pDiagramView )
 protectedvirtual

Call this function to create a view of the spline series.

Parameters
pSeries | A pointer to chart series object.
pDiagramView | A pointer to the diagram view object.
Returns
Returns a pointer to the associated series view object.

Reimplemented from CXTPChartRadarLineSeriesStyle.

The documentation for this class was generated from the following file:
  • XTPChartRadarSplineSeriesStyle.h


Toolkit Pro: CXTPChartRadarSplineSeriesView Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPChartRadarSplineSeriesView Class Reference

This class represents the view of a spline series, which is a kind of CXTPChartSeriesView. More...

Inheritance diagram for CXTPChartRadarSplineSeriesView:
[legend]

Public Member Functions

CXTPChartRadarSplineSeriesView (CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Constructs a CXTPChartRadarSplineSeriesView object.
- Public Member Functions inherited from CXTPChartRadarLineSeriesView
CXTPChartRadarLineSeriesView (CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Constructs a CXTPChartPointSeriesView object.

Protected Member Functions

CXTPChartSeriesPointView * | CreateSeriesPointView (CXTPChartDeviceContext *pDC, CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Call this function to create a view of the spline series point.
virtual CXTPChartDeviceCommand * | CreateDeviceCommand (CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
- Protected Member Functions inherited from CXTPChartRadarLineSeriesView
CXTPChartSeriesPointView * | CreateSeriesPointView (CXTPChartDeviceContext *pDC, CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Call this function to create the view of the series points.
virtual CXTPChartDeviceCommand * | CreateLegendDeviceCommand (CXTPChartDeviceContext *pDC, CRect rcBounds)
This function creates a label view drawing command object.

Detailed Description

This class represents the view of a spline series, which is a kind of CXTPChartSeriesView.

Constructor & Destructor Documentation

◆ CXTPChartRadarSplineSeriesView()

CXTPChartRadarSplineSeriesView | ( | CXTPChartSeries * | pSeries,
 |  | CXTPChartDiagramView * | pDiagramView )

Constructs a CXTPChartRadarSplineSeriesView object.

Parameters
pSeries | A pointer to the chart series object.
pDiagramView | A pointer to the diagram view object.

Member Function Documentation

◆ CreateDeviceCommand()

virtual CXTPChartDeviceCommand * CreateDeviceCommand ( CXTPChartDeviceContext * pDC )
protectedvirtual

This function creates a CXTPChartDeviceCommand object.

This object represents the rendering of a spline series.

Parameters
pDC Pointer to a CXTPChartDeviceContext object.
Returns
Returns a CXTPChartDeviceCommand object. This object handles the rendering of an element in the chart. Here it handles the drawing of the spline series.

Reimplemented from CXTPChartRadarLineSeriesView.

◆ CreateSeriesPointView()

CXTPChartSeriesPointView * CreateSeriesPointView | ( | CXTPChartDeviceContext * | pDC,
 |  | CXTPChartSeriesPoint * | pPoint,
 |  | CXTPChartElementView * | pParentView )
 protected

Call this function to create a view of the spline series point.

Parameters
pDC | A pointer to the chart device context.
pPoint | A pointer to the chart series point object.
pParentView | Parent view pointer.
Returns
Returns a pointer to the series point view object.
The documentation for this class was generated from the following file:
  • XTPChartRadarSplineSeriesStyle.h


Toolkit Pro: CXTPChartRangeAreaSeriesLabel Class Reference

Public Member Functions | List of all members
CXTPChartRangeAreaSeriesLabel Class Reference

This class abstracts the label of a bar series. More...

Inheritance diagram for CXTPChartRangeAreaSeriesLabel:
[legend]

Public Member Functions

CXTPChartRangeAreaSeriesLabel ()
Constructs a CXTPChartRangeAreaSeriesLabel object.
virtual | ~CXTPChartRangeAreaSeriesLabel ()
Destroys a CXTPChartRangeAreaSeriesLabel object, handles cleanup.
virtual CXTPChartElementView * | CreateView (CXTPChartDeviceContext *pDC, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView)
This function creates the view of the bar series label.
void | DoPropExchange (CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
- Public Member Functions inherited from CXTPChartPointSeriesLabel
CXTPChartPointSeriesLabel ()
Constructs a CXTPChartPointSeriesLabel object.
virtual | ~CXTPChartPointSeriesLabel ()
Destroys a CXTPChartPointSeriesLabel object, handles cleanup.
void | SetAngle (int nAngle)
Call this function to set the angle of the label stem.
int | GetAngle () const
Call this function to get the angle of the label stem.
- Public Member Functions inherited from CXTPChartDiagram2DSeriesLabel
CXTPChartDiagram2DSeriesLabel ()
Constructs a CXTPChartDiagram2DSeriesLabel object.
virtual | ~CXTPChartDiagram2DSeriesLabel ()
Destroys a CXTPChartDiagram2DSeriesLabel object, handles cleanup.
- Public Member Functions inherited from CXTPChartSeriesLabel
CXTPChartSeriesLabel ()
Constructs a CXTPChartSeriesLabel object.
virtual | ~CXTPChartSeriesLabel ()
Destroys a CXTPChartSeriesLabel object, handles cleanup.
void | SetTextColor (const CXTPChartColor &clrTextColor)
Call this function to set the text color of the label.
CXTPChartColor | GetTextColor () const
Call this function to get the apparent text color of the label.
CXTPChartFont * | GetFont () const
Call this function to get the font of the text label.
void | SetFont (CXTPChartFont *pFont)
Call this function to set the font of the text label.
void | SetShowLines (BOOL bShowLines)
Call this function to set the lines visibility.
BOOL | GetShowLines () const
Call this function to check if the lines are visible.
void | SetLineLength (int nLineLength)
Call this function to set the line length.
int | GetLineLength () const
Call this function to get the line length.
void | SetVisible (BOOL bVisible)
Call this function to set the label visibility.
BOOL | IsVisible () const
Call this function to check if the label is visible.
void | SetAntialiasing (BOOL bAntialiasing)
Call this function to set anti-aliasing ON or OFF.
BOOL | GetAntialiasing () const
Call this function to check if anti-aliasing is ON or OFF.
CXTPChartNumberFormat * | GetFormat () const
Call this function to get a pointer to CXTPChartNumberFormat that specifies how to convert numbers to strings.
void | SetFormat (LPCTSTR lpszFormat)
Obsolete method.
void | SetBackColor (const CXTPChartColor &clrBackColor)
Call this function to set the text color of the label.
CXTPChartColor | GetBackColor () const
Call this function to get the apparent text color of the label.
void | SetLineColor (const CXTPChartColor &clrBackColor)
Call this function to set the text color of the label.
CXTPChartColor | GetLineColor () const
Call this function to get the apparent text color of the label.
int | GetTransparency () const
Call this function to get the transparency of the filled area with respect to the background.
void | SetTransparency (int nTransparency)
Call this function to set the transparency of the filled area with respect to the background.
- Public Member Functions inherited from CXTPChartTextElement
- Public Member Functions inherited from CXTPChartElement
CXTPChartElement ()
Constructs a CXTPChartElement object.
virtual | ~CXTPChartElement ()
Destroys a CXTPChartElement object, handles cleanup.
virtual void | Release ()
Call this function to decrease the usage count of the object.
CXTPChartElement * | GetOwner () const
Call this function to get the owner element.
virtual void | OnChartChanged (XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic properties of the chart.
CXTPChartContent * | GetContent () const
Call this virtual function to get the chart content object.
CXTPChartAppearance * | GetAppearance () const
Call this function to get the the appearance of the chart.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Additional Inherited Members

- Public Attributes inherited from CXTPChartElement
- Protected Member Functions inherited from CXTPChartSeriesLabel
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.
- Protected Attributes inherited from CXTPChartPointSeriesLabel
int | m_nAngle
The stem angle.
- Protected Attributes inherited from CXTPChartSeriesLabel
CXTPChartColor | m_clrTextColor
The text color.
CXTPChartColor | m_clrBackColor
The background color.
CXTPChartColor | m_clrLineColor
The line color.
BOOL | m_bVisible
TRUE if the label is visible and FALSE if not.
CXTPChartFont * | m_pFont
The font of the label.
BOOL | m_bAntialiasing
TRUE if antialiasing enabled, FALSE if not.
BOOL | m_bShowLines
TRUE if the lines are visible, FALSE if not.
int | m_nLineLength
The line length.
CXTPChartBorder * | m_pBorder
Chart border object.
int | m_nTransparency
The transparency values range from 0 to 255.
- Protected Attributes inherited from CXTPChartElement

Detailed Description

This class abstracts the label of a bar series.

It is a kind of point series label.

Member Function Documentation

◆ CreateView()

virtual CXTPChartElementView * CreateView | ( | CXTPChartDeviceContext * | pDC,
 |  | CXTPChartSeriesPointView * | pPointView,
 |  | CXTPChartElementView * | pParentView )
 virtual

This function creates the view of the bar series label.

Parameters
pDC | The device context.
pPointView | A pointer to the series point view object.
pParentView | The pointer to the parent view object.
Returns
A pointer to a CXTPChartElementView object, which is polymorphic to CXTPChartRangeAreaSeriesLabelView.

Reimplemented from CXTPChartPointSeriesLabel.

◆ DoPropExchange()

void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Reads this object from or writes this object to an archive.

Parameters
pPX A CXTPPropExchange object to serialize to or from.

Reimplemented from CXTPChartPointSeriesLabel.

The documentation for this class was generated from the following file:
  • XTPChartRangeAreaSeriesLabel.h


Toolkit Pro: CXTPChartRangeAreaSeriesLabelView Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPChartRangeAreaSeriesLabelView Class Reference

This class abstracts the view of the label of a bar series. More...

Inheritance diagram for CXTPChartRangeAreaSeriesLabelView:
[legend]

Public Member Functions

CXTPChartRangeAreaSeriesLabelView (CXTPChartSeriesLabel *pLabel, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView)
Constructs a CXTPChartRangeAreaSeriesLabel object.
virtual CXTPChartPointF | GetAnchorPoint () const
This function calculates the anchor point of the label stem.
- Public Member Functions inherited from CXTPChartPointSeriesLabelView
CXTPChartPointSeriesLabelView (CXTPChartSeriesLabel *pLabel, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView)
Constructs a CXTPChartPointSeriesLabelView object.
- Public Member Functions inherited from CXTPChartDiagram2DSeriesLabelView
CXTPChartDiagram2DSeriesLabelView (CXTPChartSeriesLabel *pLabel, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView)
Constructs a CXTPChartDiagram2DSeriesLabelView object.
virtual CXTPChartDeviceCommand * | CreateDeviceCommand (CXTPChartDeviceContext *pDC, CXTPChartPointF ptCenterPoint)
This function creates a CXTPChartDeviceCommand object.
virtual CXTPChartDeviceCommand * | CreateDeviceCommand (CXTPChartDeviceContext *pDC, CXTPChartPointF ptCenterPoint, const CXTPChartString &text)
This function creates a CXTPChartDeviceCommand object.
virtual CXTPChartDeviceCommand * | CreateDeviceCommand (CXTPChartDeviceContext *pDC, const CXTPChartPointF &ptAnchorPoint, double dAnchorAngle, const CXTPChartString &text)
This function creates a CXTPChartDeviceCommand object.

Protected Member Functions

virtual CXTPChartDeviceCommand * CreateDeviceCommand (CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
- Protected Member Functions inherited from CXTPChartDiagram2DSeriesLabelView

Detailed Description

This class abstracts the view of the label of a bar series.

It is a kind of point series label view.

Constructor & Destructor Documentation

◆ CXTPChartRangeAreaSeriesLabelView()

CXTPChartRangeAreaSeriesLabelView | ( | CXTPChartSeriesLabel * | pLabel,
 |  | CXTPChartSeriesPointView * | pPointView,
 |  | CXTPChartElementView * | pParentView )

Constructs a CXTPChartRangeAreaSeriesLabel object.

Parameters
pLabel | Pointer chart series label.
pPointView | Pointer to chart series point view.
pParentView | The pointer to the parent view object.

Member Function Documentation

◆ CreateDeviceCommand()

virtual CXTPChartDeviceCommand * CreateDeviceCommand ( CXTPChartDeviceContext * pDC )
protectedvirtual

This function creates a CXTPChartDeviceCommand object.

This object represents the rendering of the chart series label.

Parameters
pDC Pointer to a CXTPChartDeviceContext object.
Returns
Returns a pointer to a CXTPChartDeviceCommand object. This polymorphic object handles the rendering of an element in the chart. Here it handles the drawing of the chart series label.

Reimplemented from CXTPChartDiagram2DSeriesLabelView.

◆ GetAnchorPoint()

virtual CXTPChartPointF GetAnchorPoint ( ) const
virtual

This function calculates the anchor point of the label stem.

Returns
A CXTPChartPointF object denoting the anchor point.

Reimplemented from CXTPChartPointSeriesLabelView.

The documentation for this class was generated from the following file:
  • XTPChartRangeAreaSeriesLabel.h


Toolkit Pro: CXTPChartRangeBarSeriesLabel Class Reference

Public Member Functions | List of all members
CXTPChartRangeBarSeriesLabel Class Reference

This class abstracts the label of a bar series. More...

Inheritance diagram for CXTPChartRangeBarSeriesLabel:
[legend]

Public Member Functions

CXTPChartRangeBarSeriesLabel ()
Constructs a CXTPChartRangeBarSeriesLabel object.
virtual | ~CXTPChartRangeBarSeriesLabel ()
Destroys a CXTPChartRangeBarSeriesLabel object, handles cleanup.
virtual CXTPChartElementView * | CreateView (CXTPChartDeviceContext *pDC, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView)
This function create the view of the bar series label.
void | DoPropExchange (CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
- Public Member Functions inherited from CXTPChartDiagram2DSeriesLabel
CXTPChartDiagram2DSeriesLabel ()
Constructs a CXTPChartDiagram2DSeriesLabel object.
virtual | ~CXTPChartDiagram2DSeriesLabel ()
Destroys a CXTPChartDiagram2DSeriesLabel object, handles cleanup.
- Public Member Functions inherited from CXTPChartSeriesLabel
CXTPChartSeriesLabel ()
Constructs a CXTPChartSeriesLabel object.
virtual | ~CXTPChartSeriesLabel ()
Destroys a CXTPChartSeriesLabel object, handles cleanup.
void | SetTextColor (const CXTPChartColor &clrTextColor)
Call this function to set the text color of the label.
CXTPChartColor | GetTextColor () const
Call this function to get the apparent text color of the label.
CXTPChartFont * | GetFont () const
Call this function to get the font of the text label.
void | SetFont (CXTPChartFont *pFont)
Call this function to set the font of the text label.
void | SetShowLines (BOOL bShowLines)
Call this function to set the lines visibility.
BOOL | GetShowLines () const
Call this function to check if the lines are visible.
void | SetLineLength (int nLineLength)
Call this function to set the line length.
int | GetLineLength () const
Call this function to get the line length.
void | SetVisible (BOOL bVisible)
Call this function to set the label visibility.
BOOL | IsVisible () const
Call this function to check if the label is visible.
void | SetAntialiasing (BOOL bAntialiasing)
Call this function to set anti-aliasing ON or OFF.
BOOL | GetAntialiasing () const
Call this function to check if anti-aliasing is ON or OFF.
CXTPChartNumberFormat * | GetFormat () const
Call this function to get a pointer to CXTPChartNumberFormat that specifies how to convert numbers to strings.
void | SetFormat (LPCTSTR lpszFormat)
Obsolete method.
void | SetBackColor (const CXTPChartColor &clrBackColor)
Call this function to set the text color of the label.
CXTPChartColor | GetBackColor () const
Call this function to get the apparent text color of the label.
void | SetLineColor (const CXTPChartColor &clrBackColor)
Call this function to set the text color of the label.
CXTPChartColor | GetLineColor () const
Call this function to get the apparent text color of the label.
int | GetTransparency () const
Call this function to get the transparency of the filled area with respect to the background.
void | SetTransparency (int nTransparency)
Call this function to set the transparency of the filled area with respect to the background.
- Public Member Functions inherited from CXTPChartTextElement
- Public Member Functions inherited from CXTPChartElement
CXTPChartElement ()
Constructs a CXTPChartElement object.
virtual | ~CXTPChartElement ()
Destroys a CXTPChartElement object, handles cleanup.
virtual void | Release ()
Call this function to decrease the usage count of the object.
CXTPChartElement * | GetOwner () const
Call this function to get the owner element.
virtual void | OnChartChanged (XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic properties of the chart.
CXTPChartContent * | GetContent () const
Call this virtual function to get the chart content object.
CXTPChartAppearance * | GetAppearance () const
Call this function to get the the appearance of the chart.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Additional Inherited Members

- Public Attributes inherited from CXTPChartElement
- Protected Member Functions inherited from CXTPChartSeriesLabel
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.
- Protected Attributes inherited from CXTPChartSeriesLabel
CXTPChartColor | m_clrTextColor
The text color.
CXTPChartColor | m_clrBackColor
The background color.
CXTPChartColor | m_clrLineColor
The line color.
BOOL | m_bVisible
TRUE if the label is visible and FALSE if not.
CXTPChartFont * | m_pFont
The font of the label.
BOOL | m_bAntialiasing
TRUE if antialiasing enabled, FALSE if not.
BOOL | m_bShowLines
TRUE if the lines are visible, FALSE if not.
int | m_nLineLength
The line length.
CXTPChartBorder * | m_pBorder
Chart border object.
int | m_nTransparency
The transparency values range from 0 to 255.
- Protected Attributes inherited from CXTPChartElement

Detailed Description

This class abstracts the label of a bar series.

It is a kind of point series label.

Member Function Documentation

◆ CreateView()

virtual CXTPChartElementView * CreateView | ( | CXTPChartDeviceContext * | pDC,
 |  | CXTPChartSeriesPointView * | pPointView,
 |  | CXTPChartElementView * | pParentView )
 virtual

This function create the view of the bar series label.

Parameters
pDC | The device context.
pPointView | A pointer to the series point view object.
pParentView | Parent view pointer.
Returns
Returns a pointer to the associated label view object.

Reimplemented from CXTPChartSeriesLabel.

◆ DoPropExchange()

void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Reads this object from or writes this object to an archive.

Parameters
pPX A CXTPPropExchange object to serialize to or from.

Reimplemented from CXTPChartDiagram2DSeriesLabel.

The documentation for this class was generated from the following file:
  • XTPChartRangeBarSeriesLabel.h


Toolkit Pro: CXTPChartRangeBarSeriesLabelView Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPChartRangeBarSeriesLabelView Class Reference

This class abstracts the view of the label of a bar series. More...

Inheritance diagram for CXTPChartRangeBarSeriesLabelView:
[legend]

Public Member Functions

CXTPChartRangeBarSeriesLabelView (CXTPChartSeriesLabel *pLabel, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView)
Constructs a CXTPChartRangeBarSeriesLabel object.
virtual CXTPChartPointF GetAnchorPoint () const
This function calculates the anchor point of the label stem.
- Public Member Functions inherited from CXTPChartDiagram2DSeriesLabelView
CXTPChartDiagram2DSeriesLabelView (CXTPChartSeriesLabel *pLabel, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView)
Constructs a CXTPChartDiagram2DSeriesLabelView object.

Protected Member Functions

virtual CXTPChartDeviceCommand * | CreateDeviceCommand (CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
virtual CXTPChartDeviceCommand * | CreateDeviceCommand (CXTPChartDeviceContext *pDC, CXTPChartPointF ptCenterPoint)
This function creates a CXTPChartDeviceCommand object.
virtual CXTPChartDeviceCommand * | CreateDeviceCommand (CXTPChartDeviceContext *pDC, CXTPChartPointF ptCenterPoint, const CXTPChartString &text)
This function creates a CXTPChartDeviceCommand object.
virtual CXTPChartDeviceCommand * | CreateDeviceCommand (CXTPChartDeviceContext *pDC, const CXTPChartPointF &ptAnchorPoint, double dAnchorAngle, const CXTPChartString &text)
This function creates a CXTPChartDeviceCommand object.
- Protected Member Functions inherited from CXTPChartDiagram2DSeriesLabelView

Detailed Description

This class abstracts the view of the label of a bar series.

It is a kind of point series label view.

Constructor & Destructor Documentation

◆ CXTPChartRangeBarSeriesLabelView()

CXTPChartRangeBarSeriesLabelView | ( | CXTPChartSeriesLabel * | pLabel,
 |  | CXTPChartSeriesPointView * | pPointView,
 |  | CXTPChartElementView * | pParentView )

Constructs a CXTPChartRangeBarSeriesLabel object.

Parameters
pLabel | Pointer to the chart series label.
pPointView | Pointer to the chart series point view.
pParentView | Parent view pointer.

Member Function Documentation

◆ CreateDeviceCommand() [1/4]

virtual CXTPChartDeviceCommand * CreateDeviceCommand ( CXTPChartDeviceContext * pDC )
protectedvirtual

This function creates a CXTPChartDeviceCommand object.

This object represents the rendering of the chart series label.

Parameters
pDC Pointer to a CXTPChartDeviceContext object.
Returns
Returns a pointer to a CXTPChartDeviceCommand object. This polymorphic object handles the rendering of an element in the chart. Here it handles the drawing of the chart series label.

Reimplemented from CXTPChartDiagram2DSeriesLabelView.

◆ CreateDeviceCommand() [2/4]

virtual CXTPChartDeviceCommand * CreateDeviceCommand | ( | CXTPChartDeviceContext * | pDC,
 |  | const CXTPChartPointF & | ptAnchorPoint,
 |  | double | dAnchorAngle,
 |  | const CXTPChartString & | text )
 protectedvirtual

This function creates a CXTPChartDeviceCommand object.

This object represents the rendering of the chart series label.

Parameters
pDC | Pointer to a CXTPChartDeviceContext object.
text | Text.
ptAnchorPoint | Anchor point.
dAnchorAngle | Anchor angle.
Returns
Returns a pointer to a CXTPChartDeviceCommand object. This polymorphic object handles the rendering of an element in the chart. Here it handles the drawing of the chart series label.

Reimplemented from CXTPChartDiagram2DSeriesLabelView.

◆ CreateDeviceCommand() [3/4]

virtual CXTPChartDeviceCommand * CreateDeviceCommand | ( | CXTPChartDeviceContext * | pDC,
 |  | CXTPChartPointF | ptCenterPoint )
 protectedvirtual

This function creates a CXTPChartDeviceCommand object.

This object represents the rendering of the chart series label.

Parameters
pDC | Pointer to a CXTPChartDeviceContext object.
ptCenterPoint | Center point.
Returns
Returns a pointer to a CXTPChartDeviceCommand object. This polymorphic object handles the rendering of an element in the chart. Here it handles the drawing of the chart series label.

Reimplemented from CXTPChartDiagram2DSeriesLabelView.

◆ CreateDeviceCommand() [4/4]

virtual CXTPChartDeviceCommand * CreateDeviceCommand | ( | CXTPChartDeviceContext * | pDC,
 |  | CXTPChartPointF | ptCenterPoint,
 |  | const CXTPChartString & | text )
 protectedvirtual

This function creates a CXTPChartDeviceCommand object.

This object represents the rendering of the chart series label.

Parameters
pDC | Pointer to a CXTPChartDeviceContext object.
ptCenterPoint | Center point.
text | Text.
Returns
Returns a pointer to a CXTPChartDeviceCommand object. This polymorphic object handles the rendering of an element in the chart. Here it handles the drawing of the chart series label.

Reimplemented from CXTPChartDiagram2DSeriesLabelView.

◆ GetAnchorPoint()

virtual CXTPChartPointF GetAnchorPoint ( ) const
virtual

This function calculates the anchor point of the label stem.

Returns
A CXTPChartPointF object denoting the anchor point.

Reimplemented from CXTPChartDiagram2DSeriesLabelView.

The documentation for this class was generated from the following file:
  • XTPChartRangeBarSeriesLabel.h


Toolkit Pro: CXTPChartRangeBarSeriesPointView Class Reference

Public Member Functions | List of all members
CXTPChartRangeBarSeriesPointView Class Reference

This class represents the view of a RangeBar series point, which is a kind of CXTPChartPointSeriesPointView. More...

Inheritance diagram for CXTPChartRangeBarSeriesPointView:
[legend]

Public Member Functions

CXTPChartRangeBarSeriesPointView (CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Constructs a CXTPChartRangeBarSeriesPointView object.
virtual CXTPChartDeviceCommand * | CreateDeviceCommand (CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
virtual void | UpdateMinMaxRange (double &nMinValue, double &nMaxValue) const
Provides a default empty implementation for min/max range update request.
- Public Member Functions inherited from CXTPChartBarSeriesPointView
CXTPChartBarSeriesPointView (CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Constructs a CXTPChartBarSeriesPointView object.
virtual CXTPChartDeviceCommand * | CreateLegendDeviceCommand (CXTPChartDeviceContext *pDC, CRect rcBounds)
This function creates a label view drawing command object.
- Public Member Functions inherited from CXTPChartSeriesPointView
CXTPChartSeriesPointView (CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Constructs the view object.
CXTPChartSeriesPointView (CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView, BOOL bAddToParent)
Constructs the view object.
CXTPChartSeriesPoint * | GetPoint () const
Obtains point model object.
CXTPChartSeriesView * | GetSeriesView () const
Obtains parent series view.
CXTPChartColor | GetColor () const
Obtain view color values.
CXTPChartColor | GetColor2 () const
Obtain view color values.
double | GetInternalValue () const
Obtains point interval value.
virtual CXTPChartString | GetLegendName () const
This function returns the legend name.
- Public Member Functions inherited from CXTPChartElementView
CXTPChartElementView (CXTPChartElementView *pParentView)
Constructs a CXTPChartElementView object.
CXTPChartElementView (CXTPChartElementView *pParentView, BOOL bAddToParent)
Constructs a CXTPChartElementView object.
CXTPChartElementView (CXTPChartContainer *pContainer)
Constructs a CXTPChartElementView object.
int | GetCount () const
Call this function to get the number of child views associated with this view.
CXTPChartElementView * | GetAt (int nIndex) const
Call this function to get a child view at a particular index.
CXTPChartElementView * | GetParentView () const
Call this function to get the parent view.
CXTPChartElementView * | AddChildView (CXTPChartElementView *pChildView)
Call this function to add a child view to the current view.
CXTPChartElementView ** GetChildren ()
Provides access to the collection of children elements owned by the view.
CRect | GetBounds () const
Obtains viewed object's bound rectangle.
CRect | GetBounds (BOOL bIncludingChildren) const
Obtains viewed object's bound rectangle.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.
- Public Member Functions inherited from CXTPChartLegendItemView
virtual | ~CXTPChartLegendItemView ()
Handles object destruction.

Additional Inherited Members

- Public Attributes inherited from CXTPChartSeriesPointView
double | m_dInternalValue
Point internal value.
- Protected Member Functions inherited from CXTPChartElementView
virtual | ~CXTPChartElementView ()
Destroys a CXTPChartElementView object, handles cleanup.
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.
- Protected Attributes inherited from CXTPChartSeriesPointView
CXTPChartSeriesPoint * | m_pPoint
Point model object pointer.
- Protected Attributes inherited from CXTPChartElementView
CArray< CXTPChartElementView *, CXTPChartElementView * > | m_arrChildren
The child view collection.
CXTPChartElementView * | m_pParentView
The parent view.
CXTPChartContainer * | m_pContainer
The parent container.
CRect | m_rcBounds
Bounding rectangle.

Detailed Description

This class represents the view of a RangeBar series point, which is a kind of CXTPChartPointSeriesPointView.

Constructor & Destructor Documentation

◆ CXTPChartRangeBarSeriesPointView()

CXTPChartRangeBarSeriesPointView | ( | CXTPChartSeriesPoint * | pPoint,
 |  | CXTPChartElementView * | pParentView )

Constructs a CXTPChartRangeBarSeriesPointView object.

Parameters
pPoint | A pointer to the chart series point object.
pParentView | Parent view pointer.

Member Function Documentation

◆ CreateDeviceCommand()

virtual CXTPChartDeviceCommand * CreateDeviceCommand ( CXTPChartDeviceContext * pDC )
virtual

This function creates a CXTPChartDeviceCommand object.

This object represents the rendering of a bar series point.

Parameters
pDC Pointer to a CXTPChartDeviceContext object.
Returns
Returns a CXTPChartDeviceCommand object. This object handles the rendering of the bar series point.

Reimplemented from CXTPChartBarSeriesPointView.

◆ UpdateMinMaxRange()

virtual void UpdateMinMaxRange | ( | double & | nMinValue,
 |  | double & | nMaxValue ) const
 virtual

Provides a default empty implementation for min/max range update request.

Parameters
nMinValue | The updated minimal value.
nMaxValue | The updated maximal value.

Reimplemented from CXTPChartSeriesPointView.

The documentation for this class was generated from the following file:
  • XTPChartRangeBarSeriesView.h


Toolkit Pro: CXTPChartRangeBarSeriesStyle Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPChartRangeBarSeriesStyle Class Reference

This class represents a RangeBar series style for the chart, which is a kind of CXTPChartBarSeriesStyle. More...

Inheritance diagram for CXTPChartRangeBarSeriesStyle:
[legend]

Public Member Functions

CXTPChartRangeBarSeriesStyle ()
Constructs a CXTPChartRangeBarSeriesStyle object.
virtual | ~CXTPChartRangeBarSeriesStyle ()
Destroys a CXTPChartRangeBarSeriesStyle object, handles cleanup.
void | DoPropExchange (CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
- Public Member Functions inherited from CXTPChartBarSeriesStyle
CXTPChartBarSeriesStyle ()
Constructs a CXTPChartBarSeriesStyle object.
virtual | ~CXTPChartBarSeriesStyle ()
Destroys a CXTPChartBarSeriesStyle object, handles cleanup.
double | GetBarWidth () const
Call this function to get the width of the bar.
void | SetBarWidth (double dWidth)
Call this function to set the width of the bar.
- Public Member Functions inherited from CXTPChartDiagram2DSeriesStyle
CXTPChartDiagram2DSeriesStyle ()
Constructs a CXTPChartDiagram2DSeriesStyle object.
virtual | ~CXTPChartDiagram2DSeriesStyle ()
Destroys a CXTPChartDiagram2DSeriesStyle object, handles cleanup.
virtual CXTPChartDiagram * | CreateDiagram ()
Call this function to create the diagram for this series.
virtual BOOL | IsStyleDiagram (CXTPChartDiagram *pDiagram) const
Call this function to check whether the chart diagram object passed is a kind of 2D diagram (CXTPChartDiagram2D object).
- Public Member Functions inherited from CXTPChartSeriesStyle
CXTPChartSeriesStyle ()
Constructs a CXTPChartSeriesStyle object.
virtual | ~CXTPChartSeriesStyle ()
Destroys a CXTPChartSeriesStyle object, handles cleanup.
virtual CXTPChartSeriesLabel * | GetLabel () const
Call this method to gets the series label object.
virtual CXTPChartSeriesLabel * | SetLabel (CXTPChartSeriesLabel *pLabel)
Call this method to sets the series label object.
virtual CXTPChartErrorBar * | GetErrorBar () const
Call this method to gets the error bar object.
virtual CXTPChartErrorBar * | SetErrorBar (CXTPChartErrorBar *pErrorBar)
Call this method to sets the error bar object.
virtual CXTPChartColor | GetColor () const
Call this method to get the color of the series.
virtual void | SetColor (CXTPChartColor clr)
Call this method to set the color of the series.
virtual void | SetColorEach (BOOL bColorEach)
Call this method to set individual color for each point of the series.
virtual BOOL | IsColorEach () const
This method is called to check if individual color is used for each point of the series.
virtual CXTPChart3dRotation | Get3dRotation () const
Obtains rotation parameters for 3D chart.
virtual void | Set3dRotation (const CXTPChart3dRotation &rotation)
Sets rotation parameters for 3D chart.
virtual void | Set3dRotation (double dYaw, double dPitch, double dRoll)
Sets rotation parameters for 3D chart.
virtual BOOL | Is3dEdgeSmoothingEnabled () const
Enables/disables 3D edge smoothing.
virtual void | Enable3dEdgeSmoothing (BOOL bEnable=TRUE)
Enables/disables 3D edge smoothing.
virtual int | GetTransparency () const
Call this function to gets the transparency of the chart if it is supported by the chart type.
virtual void | SetTransparency (int nTransparency)
Call this function to sets the transparency of the chart if it is supported by the chart type.
virtual CXTPChartSeriesStyleAppearance * | GetStyleAppearance () const
Obtains associated style appearance pointer.
virtual void | ApplyTo (CXTPChartDeviceCommand *pCommand)
Applies the style to the command provided in case the command needs style specific details for correct drawing.
virtual int | GetSeriesPointValueIndex () const
Obtains the index of a point element for which an internal value can be otained.
- Public Member Functions inherited from CXTPChartElement
CXTPChartElement ()
Constructs a CXTPChartElement object.
virtual | ~CXTPChartElement ()
Destroys a CXTPChartElement object, handles cleanup.
virtual void | Release ()
Call this function to decrease the usage count of the object.
CXTPChartElement * | GetOwner () const
Call this function to get the owner element.
virtual void | OnChartChanged (XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic properties of the chart.
CXTPChartContent * | GetContent () const
Call this virtual function to get the chart content object.
CXTPChartAppearance * | GetAppearance () const
Call this function to get the the appearance of the chart.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Protected Member Functions

virtual CXTPChartSeriesView * | CreateView (CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Call this function to create the view of the RangeBar series.
- Protected Member Functions inherited from CXTPChartBarSeriesStyle
virtual void | CorrectAxisSideMargins (CXTPChartAxis *pAxis, double nMinValue, double nMaxValue, double &nCorrection)
Call this function to correct the axis side margins.
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.

Additional Inherited Members

- Public Attributes inherited from CXTPChartElement
- Protected Attributes inherited from CXTPChartBarSeriesStyle
- Protected Attributes inherited from CXTPChartDiagram2DSeriesStyle
int | m_nAxisIndexX
Holds index of secondary axisX, used when m_bSecondaryAxisX is TRUE.
int | m_nAxisIndexY
Holds index of secondary axisY, used when m_bSecondaryAxisY is TRUE.
- Protected Attributes inherited from CXTPChartSeriesStyle
CXTPChartSeriesLabel * | m_pLabel
Label object.
CXTPChartErrorBar * | m_pErrorBar
Error bar object.
CXTPChartColor | m_clrColor
Custom color of series.
BOOL | m_bColorEach
TRUE to color each point.
int | m_nTransparency
The transparency value in the range 0..255.
CXTPChart3dRotation | m_Rotation3d
3D rotation
BOOL | m_bSmooth3dEdges
3D edge smoothing
- Protected Attributes inherited from CXTPChartElement

Detailed Description

This class represents a RangeBar series style for the chart, which is a kind of CXTPChartBarSeriesStyle.

A RangeBar chart or RangeBar graph is a chart with rectangular RangeBars with lengths proportional to the values that they represent. RangeBar charts are used for comparing two or more values that were taken over time or on different conditions, usually on small data sets.

Member Function Documentation

◆ CreateView()

virtual CXTPChartSeriesView * CreateView | ( | CXTPChartSeries * | pSeries,
 |  | CXTPChartDiagramView * | pDiagramView )
 protectedvirtual

Call this function to create the view of the RangeBar series.

Parameters
pSeries | A pointer to the chart series object to which this object is associated with.
pDiagramView | A pointer to the chart diagram view object to which this object is associated with.
Returns
Returns a pointer to the associated series view object.

Reimplemented from CXTPChartBarSeriesStyle.

Reimplemented in CXTPChartGanttSeriesStyle.

◆ DoPropExchange()

void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Reads this object from or writes this object to an archive.

Parameters
pPX A CXTPPropExchange object to serialize to or from.

Reimplemented from CXTPChartBarSeriesStyle.

The documentation for this class was generated from the following file:
  • XTPChartRangeBarSeriesStyle.h


Toolkit Pro: CXTPChartRangeBarSeriesView Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPChartRangeBarSeriesView Class Reference

This class represents the view of a RangeBar series, which is a kind of CXTPChartSeriesView. More...

Inheritance diagram for CXTPChartRangeBarSeriesView:
[legend]

Public Member Functions

CXTPChartRangeBarSeriesView (CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Constructs a CXTPChartRangeBarSeriesView object.
- Public Member Functions inherited from CXTPChartBarSeriesView
CXTPChartBarSeriesView (CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Constructs a CXTPChartBarSeriesView object.

Protected Member Functions

CXTPChartSeriesPointView * | CreateSeriesPointView (CXTPChartDeviceContext *pDC, CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Call this function to create a view of the RangeBar series point.
- Protected Member Functions inherited from CXTPChartBarSeriesView
CXTPChartSeriesPointView * | CreateSeriesPointView (CXTPChartDeviceContext *pDC, CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Call this function to create a view of the bar series point.
void | BeforeUpdateRange (CXTPChartDeviceContext *pDC)
Call this function to calculate the layout of the bar series.
virtual CXTPChartDeviceCommand * | CreateLegendDeviceCommand (CXTPChartDeviceContext *pDC, CRect rcBounds)
This function creates a label view drawing command object.

Additional Inherited Members

- Protected Attributes inherited from CXTPChartBarSeriesView
int | m_nBarCount
The bar count in the series.
int | m_nBarIndex
The index of the bar series.

Detailed Description

This class represents the view of a RangeBar series, which is a kind of CXTPChartSeriesView.

Constructor & Destructor Documentation

◆ CXTPChartRangeBarSeriesView()

CXTPChartRangeBarSeriesView | ( | CXTPChartSeries * | pSeries,
 |  | CXTPChartDiagramView * | pDiagramView )

Constructs a CXTPChartRangeBarSeriesView object.

Parameters
pSeries | A pointer to the chart series object.
pDiagramView | A pointer to the diagram view object.

Member Function Documentation

◆ CreateSeriesPointView()

CXTPChartSeriesPointView * CreateSeriesPointView | ( | CXTPChartDeviceContext * | pDC,
 |  | CXTPChartSeriesPoint * | pPoint,
 |  | CXTPChartElementView * | pParentView )
 protected

Call this function to create a view of the RangeBar series point.

Parameters
pDC | A pointer to the chart device context.
pPoint | A pointer to the chart series point object.
pParentView | Parent view pointer.
Returns
Returns a pointer to the series point view object.
The documentation for this class was generated from the following file:
  • XTPChartRangeBarSeriesView.h


Toolkit Pro: CXTPChartRangeSplineAreaSeriesPointView Class Reference

Public Member Functions | List of all members
CXTPChartRangeSplineAreaSeriesPointView Class Reference

This class represents the view of a RangeBar series point, which is a kind of CXTPChartPointSeriesPointView. More...

Inheritance diagram for CXTPChartRangeSplineAreaSeriesPointView:
[legend]

Public Member Functions

CXTPChartRangeSplineAreaSeriesPointView (CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Constructs a CXTPChartRangeBarSeriesPointView object.
virtual void | UpdateMinMaxRange (double &nMinValue, double &nMaxValue) const
Provides a default empty implementation for min/max range update request.
virtual CXTPChartDeviceCommand * | CreateDeviceCommand (CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
- Public Member Functions inherited from CXTPChartPointSeriesPointView
CXTPChartPointSeriesPointView (CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Constructs a CXTPChartPointSeriesPointView object.
virtual CXTPChartDeviceCommand * | CreateLegendDeviceCommand (CXTPChartDeviceContext *pDC, CRect rcBounds)
This function creates a label view drawing command object.
CXTPChartPointF | GetScreenPoint () const
Call this function to get the screen point from the series point.
- Public Member Functions inherited from CXTPChartSeriesPointView
CXTPChartSeriesPointView (CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Constructs the view object.
CXTPChartSeriesPointView (CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView, BOOL bAddToParent)
Constructs the view object.
CXTPChartSeriesPoint * | GetPoint () const
Obtains point model object.
CXTPChartSeriesView * | GetSeriesView () const
Obtains parent series view.
CXTPChartColor | GetColor () const
Obtain view color values.
CXTPChartColor | GetColor2 () const
Obtain view color values.
double | GetInternalValue () const
Obtains point interval value.
virtual CXTPChartString | GetLegendName () const
This function returns the legend name.
- Public Member Functions inherited from CXTPChartElementView
CXTPChartElementView (CXTPChartElementView *pParentView)
Constructs a CXTPChartElementView object.
CXTPChartElementView (CXTPChartElementView *pParentView, BOOL bAddToParent)
Constructs a CXTPChartElementView object.
CXTPChartElementView (CXTPChartContainer *pContainer)
Constructs a CXTPChartElementView object.
int | GetCount () const
Call this function to get the number of child views associated with this view.
CXTPChartElementView * | GetAt (int nIndex) const
Call this function to get a child view at a particular index.
CXTPChartElementView * | GetParentView () const
Call this function to get the parent view.
CXTPChartElementView * | AddChildView (CXTPChartElementView *pChildView)
Call this function to add a child view to the current view.
CXTPChartElementView ** GetChildren ()
Provides access to the collection of children elements owned by the view.
CRect | GetBounds () const
Obtains viewed object's bound rectangle.
CRect | GetBounds (BOOL bIncludingChildren) const
Obtains viewed object's bound rectangle.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.
- Public Member Functions inherited from CXTPChartLegendItemView
virtual | ~CXTPChartLegendItemView ()
Handles object destruction.

Additional Inherited Members

- Public Attributes inherited from CXTPChartSeriesPointView
double | m_dInternalValue
Point internal value.
- Protected Member Functions inherited from CXTPChartElementView
virtual | ~CXTPChartElementView ()
Destroys a CXTPChartElementView object, handles cleanup.
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.
- Protected Attributes inherited from CXTPChartSeriesPointView
CXTPChartSeriesPoint * | m_pPoint
Point model object pointer.
- Protected Attributes inherited from CXTPChartElementView
CArray< CXTPChartElementView *, CXTPChartElementView * > | m_arrChildren
The child view collection.
CXTPChartElementView * | m_pParentView
The parent view.
CXTPChartContainer * | m_pContainer
The parent container.
CRect | m_rcBounds
Bounding rectangle.

Detailed Description

This class represents the view of a RangeBar series point, which is a kind of CXTPChartPointSeriesPointView.

Constructor & Destructor Documentation

◆ CXTPChartRangeSplineAreaSeriesPointView()

CXTPChartRangeSplineAreaSeriesPointView | ( | CXTPChartSeriesPoint * | pPoint,
 |  | CXTPChartElementView * | pParentView )

Constructs a CXTPChartRangeBarSeriesPointView object.

Parameters
pPoint | A pointer to the chart series point object.
pParentView | Parent view pointer.

Member Function Documentation

◆ CreateDeviceCommand()

virtual CXTPChartDeviceCommand * CreateDeviceCommand ( CXTPChartDeviceContext * pDC )
virtual

This function creates a CXTPChartDeviceCommand object.

This object represents the rendering of an area series in the chart.

Parameters
pDC Pointer to a CXTPChartDeviceContext object.
Returns
Returns a CXTPChartDeviceCommand object. This polymorphic object handles the rendering of an element in the chart. Here it handles the drawing of the area series of the chart.

Reimplemented from CXTPChartPointSeriesPointView.

◆ UpdateMinMaxRange()

virtual void UpdateMinMaxRange | ( | double & | nMinValue,
 |  | double & | nMaxValue ) const
 virtual

Provides a default empty implementation for min/max range update request.

Parameters
nMinValue | The updated minimal value.
nMaxValue | The updated maximal value.

Reimplemented from CXTPChartSeriesPointView.

The documentation for this class was generated from the following file:
  • XTPChartRangeSplineAreaSeriesStyle.h


Toolkit Pro: CXTPChartRangeSplineAreaSeriesStyle Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPChartRangeSplineAreaSeriesStyle Class Reference

CXTPChartRangeSplineAreaSeriesStyle is a CXTPChartAreaSeriesStyle derived class which represents the area series style. More...

Inheritance diagram for CXTPChartRangeSplineAreaSeriesStyle:
[legend]

Public Member Functions

CXTPChartRangeSplineAreaSeriesStyle ()
Constructs a CXTPChartRangeSplineAreaSeriesStyle object.
virtual | ~CXTPChartRangeSplineAreaSeriesStyle ()
Destroys a CXTPChartRangeSplineAreaSeriesStyle object, handles cleanup.
- Public Member Functions inherited from CXTPChartAreaSeriesStyle
CXTPChartAreaSeriesStyle ()
Constructs a CXTPChartAreaSeriesStyle object.
virtual | ~CXTPChartAreaSeriesStyle ()
Destroys a CXTPChartAreaSeriesStyle object, handles cleanup.
CXTPChartFillStyle * | GetFillStyle () const
Call this function to get the background fill style.
void | DoPropExchange (CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
int | GetTransparency () const
Call this function to get the transparency of the filled area with respect to the background.
void | SetTransparency (int nTransparency)
Call this function to set the transparency of the filled area with respect to the background.
BOOL | GetFillAcrossXAxis () const
Call this function to get the fill chart area indicator with respect to the background.
void | SetFillAcrossXAxis (BOOL nFillAcrossXAxis)
Call this function to set the fill chart area indicator with respect to the background.
- Public Member Functions inherited from CXTPChartPointSeriesStyle
CXTPChartPointSeriesStyle ()
Constructs a CXTPChartPointSeriesStyle object.
virtual | ~CXTPChartPointSeriesStyle ()
Destroys a CXTPChartPointSeriesStyle object, handles cleanup.
CXTPChartMarker * | GetMarker () const
Call this function to get the marker object associated with this CXTPChartPointSeriesStyle object.
void | DoPropExchange (CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
- Public Member Functions inherited from CXTPChartDiagram2DSeriesStyle
CXTPChartDiagram2DSeriesStyle ()
Constructs a CXTPChartDiagram2DSeriesStyle object.
virtual | ~CXTPChartDiagram2DSeriesStyle ()
Destroys a CXTPChartDiagram2DSeriesStyle object, handles cleanup.
virtual CXTPChartDiagram * | CreateDiagram ()
Call this function to create the diagram for this series.
virtual BOOL | IsStyleDiagram (CXTPChartDiagram *pDiagram) const
Call this function to check whether the chart diagram object passed is a kind of 2D diagram (CXTPChartDiagram2D object).
- Public Member Functions inherited from CXTPChartSeriesStyle
CXTPChartSeriesStyle ()
Constructs a CXTPChartSeriesStyle object.
virtual | ~CXTPChartSeriesStyle ()
Destroys a CXTPChartSeriesStyle object, handles cleanup.
virtual CXTPChartSeriesLabel * | GetLabel () const
Call this method to gets the series label object.
virtual CXTPChartSeriesLabel * | SetLabel (CXTPChartSeriesLabel *pLabel)
Call this method to sets the series label object.
virtual CXTPChartErrorBar * | GetErrorBar () const
Call this method to gets the error bar object.
virtual CXTPChartErrorBar * | SetErrorBar (CXTPChartErrorBar *pErrorBar)
Call this method to sets the error bar object.
virtual CXTPChartColor | GetColor () const
Call this method to get the color of the series.
virtual void | SetColor (CXTPChartColor clr)
Call this method to set the color of the series.
virtual void | SetColorEach (BOOL bColorEach)
Call this method to set individual color for each point of the series.
virtual BOOL | IsColorEach () const
This method is called to check if individual color is used for each point of the series.
virtual CXTPChart3dRotation | Get3dRotation () const
Obtains rotation parameters for 3D chart.
virtual void | Set3dRotation (const CXTPChart3dRotation &rotation)
Sets rotation parameters for 3D chart.
virtual void | Set3dRotation (double dYaw, double dPitch, double dRoll)
Sets rotation parameters for 3D chart.
virtual BOOL | Is3dEdgeSmoothingEnabled () const
Enables/disables 3D edge smoothing.
virtual void | Enable3dEdgeSmoothing (BOOL bEnable=TRUE)
Enables/disables 3D edge smoothing.
virtual void | CorrectAxisSideMargins (CXTPChartAxis *pAxis, double nMinValue, double nMaxValue, double &nCorrection)
Provides default implementation for axis side margins correction.
virtual CXTPChartSeriesStyleAppearance * | GetStyleAppearance () const
Obtains associated style appearance pointer.
virtual void | ApplyTo (CXTPChartDeviceCommand *pCommand)
Applies the style to the command provided in case the command needs style specific details for correct drawing.
virtual int | GetSeriesPointValueIndex () const
Obtains the index of a point element for which an internal value can be otained.
- Public Member Functions inherited from CXTPChartElement
CXTPChartElement ()
Constructs a CXTPChartElement object.
virtual | ~CXTPChartElement ()
Destroys a CXTPChartElement object, handles cleanup.
virtual void | Release ()
Call this function to decrease the usage count of the object.
CXTPChartElement * | GetOwner () const
Call this function to get the owner element.
virtual void | OnChartChanged (XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic properties of the chart.
CXTPChartContent * | GetContent () const
Call this virtual function to get the chart content object.
CXTPChartAppearance * | GetAppearance () const
Call this function to get the the appearance of the chart.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Protected Member Functions

virtual CXTPChartSeriesView * CreateView (CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Use this function to create a chart series view object.
- Protected Member Functions inherited from CXTPChartAreaSeriesStyle
- Protected Member Functions inherited from CXTPChartPointSeriesStyle
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.

Additional Inherited Members

- Public Attributes inherited from CXTPChartElement
- Protected Attributes inherited from CXTPChartAreaSeriesStyle
int | m_nTransparency
The transparency values range from 0 to 255.
CXTPChartBorder * | m_pBorder
The chart border object pointer.
CXTPChartFillStyle * | m_pFillStyle
The chart background fill style.
BOOL | m_nFillAcrossXAxis
Fill chart area across X axis (under and over X axis)
- Protected Attributes inherited from CXTPChartPointSeriesStyle
- Protected Attributes inherited from CXTPChartDiagram2DSeriesStyle
int | m_nAxisIndexX
Holds index of secondary axisX, used when m_bSecondaryAxisX is TRUE.
int | m_nAxisIndexY
Holds index of secondary axisY, used when m_bSecondaryAxisY is TRUE.
- Protected Attributes inherited from CXTPChartSeriesStyle
CXTPChartSeriesLabel * | m_pLabel
Label object.
CXTPChartErrorBar * | m_pErrorBar
Error bar object.
CXTPChartColor | m_clrColor
Custom color of series.
BOOL | m_bColorEach
TRUE to color each point.
int | m_nTransparency
The transparency value in the range 0..255.
CXTPChart3dRotation | m_Rotation3d
3D rotation
BOOL | m_bSmooth3dEdges
3D edge smoothing
- Protected Attributes inherited from CXTPChartElement

Detailed Description

CXTPChartRangeSplineAreaSeriesStyle is a CXTPChartAreaSeriesStyle derived class which represents the area series style.

Area series displays graphically the quantitative data in a chart. It displays a series as a set of points connected by a line or spline with all the area filled in below the line.

Member Function Documentation

◆ CreateView()

virtual CXTPChartSeriesView * CreateView | ( | CXTPChartSeries * | pSeries,
 |  | CXTPChartDiagramView * | pDiagramView )
 protectedvirtual

Use this function to create a chart series view object.

Parameters
pSeries | Pointer to a chart series object.
pDiagramView | Pointer to a chart diagram view object.
Returns
A pointer to the newly created CXTPChartSeriesView object.

CXTPChartSeriesView abstracts the view of a series.

Reimplemented from CXTPChartAreaSeriesStyle.

The documentation for this class was generated from the following file:
  • XTPChartRangeSplineAreaSeriesStyle.h


Toolkit Pro: CXTPChartRangeSplineAreaSeriesView Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPChartRangeSplineAreaSeriesView Class Reference

CXTPChartRangeSplineAreaSeriesView is a kind of CXTPChartAreaSeriesView. More...

Inheritance diagram for CXTPChartRangeSplineAreaSeriesView:
[legend]

Public Member Functions

CXTPChartRangeSplineAreaSeriesView (CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Constructs a CXTPChartRangeSplineAreaSeriesView object.
- Public Member Functions inherited from CXTPChartAreaSeriesView
CXTPChartAreaSeriesView (CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Constructs a CXTPChartAreaSeriesView object.

Protected Member Functions

virtual CXTPChartDeviceCommand * | CreateDeviceCommand (CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
- Protected Member Functions inherited from CXTPChartAreaSeriesView
CXTPChartSeriesPointView * | CreateSeriesPointView (CXTPChartDeviceContext *pDC, CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Call this function to create a chart area series point view object.
CXTPChartColor | GetActualColor () const
Call this function to get the actual color of the series.
CXTPChartColor | GetActualColor2 () const
Call this function to get the second actual color of the series.
CXTPChartColor | GetBorderActualColor () const
Call this function to get the actual color of the series border.
virtual CXTPChartDeviceCommand * | CreateLegendDeviceCommand (CXTPChartDeviceContext *pDC, CRect rcBounds)
This function creates a label view drawing command object.

Detailed Description

CXTPChartRangeSplineAreaSeriesView is a kind of CXTPChartAreaSeriesView.

This class represents the view of the area series of a chart.

Area series displays graphically the quantitative data in a chart. It displays a series as a set of points connected by a line or spline with all the area filled in below the line.

Constructor & Destructor Documentation

◆ CXTPChartRangeSplineAreaSeriesView()

CXTPChartRangeSplineAreaSeriesView | ( | CXTPChartSeries * | pSeries,
 |  | CXTPChartDiagramView * | pDiagramView )

Constructs a CXTPChartRangeSplineAreaSeriesView object.

Parameters
pSeries | Pointer to a chart series object.
pDiagramView | Pointer to a chart diagram view object.

Member Function Documentation

◆ CreateDeviceCommand()

virtual CXTPChartDeviceCommand * CreateDeviceCommand ( CXTPChartDeviceContext * pDC )
protectedvirtual

This function creates a CXTPChartDeviceCommand object.

This object represents the rendering of an area series in the chart.

Parameters
pDC Pointer to a CXTPChartDeviceContext object.
Returns
Returns a CXTPChartDeviceCommand object. This polymorphic object handles the rendering of an element in the chart. Here it handles the drawing of the area series of the chart.

Reimplemented from CXTPChartAreaSeriesView.

The documentation for this class was generated from the following file:
  • XTPChartRangeSplineAreaSeriesStyle.h


Toolkit Pro: CXTPChartRectangleDeviceCommand Class Reference

Protected Member Functions | Protected Attributes | List of all members
CXTPChartRectangleDeviceCommand Class Reference

Base class implementation for 2D chart rectangle device command. More...

Inheritance diagram for CXTPChartRectangleDeviceCommand:
[legend]

Protected Member Functions

CXTPChartRectangleDeviceCommand (const CXTPChartRectF &rect)
Constructs a CXTPChartRectangleDeviceCommand object.
CXTPChartElement * HitTest (CPoint point, CXTPChartElement *pParent) const
Performs recursive hit testing of the element at the specified point.
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.
- Protected Member Functions inherited from CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents >
CXTPObservable ()
Constructs an observable object.
~CXTPObservable ()
Handles observable object destruction.

Protected Attributes

CXTPChartRectF | m_rect
The bounds of the rectangle.
- Protected Attributes inherited from CXTPChartDeviceCommand
CArray< CXTPChartDeviceCommand *, CXTPChartDeviceCommand * > | m_arrChildren
< The array of child device commands.

Additional Inherited Members

- Public Member Functions inherited from CXTPChartDeviceCommand
CXTPChartDeviceCommand ()
Constructs a CXTPChartDeviceCommand object.
virtual | ~CXTPChartDeviceCommand ()
Destroys a CXTPChartDeviceCommand object, handles cleanup.
BOOL | IsCommitted () const
Determines if the execution of the command has been committed.
void | Commit ()
Commits the execution of the command.
int | GetChildCommandCount () const
Obtains the number of immediate children commands.
CXTPChartDeviceCommand * | GetChildCommand (int nIndex) const
Obtains immediate child command point by index.
CXTPChartDeviceCommand * | AddChildCommand (CXTPChartDeviceCommand *pCommand)
Call this function to add a child device command.
virtual void | Execute (CXTPChartDeviceContext *pDC)
Call this function to execute the drawing.
virtual void | BeforeExecute (CXTPChartDeviceContext *pDC)
This method gets called before a command is executed which allows for the customization of command behavior.
virtual void | AfterExecute (CXTPChartDeviceContext *pDC)
This method gets called after a command is executed which allows for the customization of command behavior.
virtual void | ExecuteOverride (CXTPChartDeviceContext *pDC)
Override this function to write the drawing code for specific objects.
UINT | GetPassNumber () const
Get the number of executions made by the command.
virtual void | ApplySeriesStyle (CXTPChartSeriesStyle *pStyle)
Applies series style to the current element.
virtual void | Prepare (CXTPChartDeviceContext *pDC)
Performs inital preparation steps necessary for successful command execution.
virtual void | PrepareOverride (CXTPChartDeviceContext *pDC)
Derived implementation must override this method for implementing implementation specific preparation behavior.
virtual BOOL | IsEnabled () const
Determines if the command is currently enabled.
void | SetEnabled (BOOL bEnabled=TRUE)
Enables/disable the command.
CXTPChartDeviceContext * | GetCurrentDC () const
Obtains device context pointer for which the command is currenly being prepared or executed.
void | BindView (CXTPChartElementView *pView)
Binds a view to the command object.
CXTPChartElementView * | GetBoundView () const
Obtains a bound view pointer or NULL if no view is bound.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.
- Public Member Functions inherited from CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents >
void | Subscribe (CXTPChartDeviceCommandEvents *pObserver, CXTPSubscriptionList< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > *pSubcriptionList=NULL)
Subscribes a unique observer for events.
void | Unsubscribe (CXTPChartDeviceCommandEvents *pObserver)
Unsubscribes an observer from events.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *))
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *))
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.

Detailed Description

Base class implementation for 2D chart rectangle device command.

Constructor & Destructor Documentation

◆ CXTPChartRectangleDeviceCommand()

CXTPChartRectangleDeviceCommand ( const CXTPChartRectF & rect )
protected

Constructs a CXTPChartRectangleDeviceCommand object.

Parameters
rect The rectangular area to be rendered by the device command.

Member Function Documentation

◆ HitTest()

CXTPChartElement * HitTest | ( | CPoint | point,
 |  | CXTPChartElement * | pParent ) const
 protectedvirtual

Performs recursive hit testing of the element at the specified point.

Parameters
point | Point in which an element is to be found.
pParent | Parent element pointer.
Returns
A pointer to the element found at the specified point or NULL if no element is found.

Reimplemented from CXTPChartDeviceCommand.

The documentation for this class was generated from the following file:
  • XTPChartRectangleDeviceCommand.h


Toolkit Pro: CXTPChartRotateDeviceCommand Class Reference

Protected Member Functions | Protected Attributes | List of all members
CXTPChartRotateDeviceCommand Class Reference

Base class implementation for 2D chart rotation device command. More...

Inheritance diagram for CXTPChartRotateDeviceCommand:
[legend]

Protected Member Functions

CXTPChartRotateDeviceCommand (float fAngle)
Constructs a CXTPChartRotateDeviceCommand object.
CXTPChartRotateDeviceCommand (float fAngle, const CXTPPoint3d &rotateVector)
Constructs a CXTPChartRotateDeviceCommand object.
CXTPChartElement * HitTest (CPoint point, CXTPChartElement *pParent) const
Performs recursive hit testing of the element at the specified point.
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.
- Protected Member Functions inherited from CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents >
CXTPObservable ()
Constructs an observable object.
~CXTPObservable ()
Handles observable object destruction.

Protected Attributes

float | m_fAngle
The angle of rotation.
CXTPPoint3d | m_ptRotateVector
The rotation vector.
- Protected Attributes inherited from CXTPChartDeviceCommand
CArray< CXTPChartDeviceCommand *, CXTPChartDeviceCommand * > | m_arrChildren
< The array of child device commands.

Additional Inherited Members

- Public Member Functions inherited from CXTPChartDeviceCommand
CXTPChartDeviceCommand ()
Constructs a CXTPChartDeviceCommand object.
virtual | ~CXTPChartDeviceCommand ()
Destroys a CXTPChartDeviceCommand object, handles cleanup.
BOOL | IsCommitted () const
Determines if the execution of the command has been committed.
void | Commit ()
Commits the execution of the command.
int | GetChildCommandCount () const
Obtains the number of immediate children commands.
CXTPChartDeviceCommand * | GetChildCommand (int nIndex) const
Obtains immediate child command point by index.
CXTPChartDeviceCommand * | AddChildCommand (CXTPChartDeviceCommand *pCommand)
Call this function to add a child device command.
virtual void | Execute (CXTPChartDeviceContext *pDC)
Call this function to execute the drawing.
virtual void | BeforeExecute (CXTPChartDeviceContext *pDC)
This method gets called before a command is executed which allows for the customization of command behavior.
virtual void | AfterExecute (CXTPChartDeviceContext *pDC)
This method gets called after a command is executed which allows for the customization of command behavior.
virtual void | ExecuteOverride (CXTPChartDeviceContext *pDC)
Override this function to write the drawing code for specific objects.
UINT | GetPassNumber () const
Get the number of executions made by the command.
virtual void | ApplySeriesStyle (CXTPChartSeriesStyle *pStyle)
Applies series style to the current element.
virtual void | Prepare (CXTPChartDeviceContext *pDC)
Performs inital preparation steps necessary for successful command execution.
virtual void | PrepareOverride (CXTPChartDeviceContext *pDC)
Derived implementation must override this method for implementing implementation specific preparation behavior.
virtual BOOL | IsEnabled () const
Determines if the command is currently enabled.
void | SetEnabled (BOOL bEnabled=TRUE)
Enables/disable the command.
CXTPChartDeviceContext * | GetCurrentDC () const
Obtains device context pointer for which the command is currenly being prepared or executed.
void | BindView (CXTPChartElementView *pView)
Binds a view to the command object.
CXTPChartElementView * | GetBoundView () const
Obtains a bound view pointer or NULL if no view is bound.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.
- Public Member Functions inherited from CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents >
void | Subscribe (CXTPChartDeviceCommandEvents *pObserver, CXTPSubscriptionList< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > *pSubcriptionList=NULL)
Subscribes a unique observer for events.
void | Unsubscribe (CXTPChartDeviceCommandEvents *pObserver)
Unsubscribes an observer from events.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *))
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *))
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.

Detailed Description

Base class implementation for 2D chart rotation device command.

Constructor & Destructor Documentation

◆ CXTPChartRotateDeviceCommand() [1/2]

CXTPChartRotateDeviceCommand ( float fAngle )
protected

Constructs a CXTPChartRotateDeviceCommand object.

Parameters
fAngle The angle of rotation.

◆ CXTPChartRotateDeviceCommand() [2/2]

CXTPChartRotateDeviceCommand | ( | float | fAngle,
 |  | const CXTPPoint3d & | rotateVector )
 protected

Constructs a CXTPChartRotateDeviceCommand object.

Parameters
fAngle | The angle of rotation.
rotateVector | The vector to be rotated.

Member Function Documentation

◆ HitTest()

CXTPChartElement * HitTest | ( | CPoint | point,
 |  | CXTPChartElement * | pParent ) const
 protectedvirtual

Performs recursive hit testing of the element at the specified point.

Parameters
point | Point in which an element is to be found.
pParent | Parent element pointer.
Returns
A pointer to the element found at the specified point or NULL if no element is found.

Reimplemented from CXTPChartDeviceCommand.

The documentation for this class was generated from the following file:
  • XTPChartTransformationDeviceCommand.h


Toolkit Pro: CXTPChartRotatedTextPainterBase Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPChartRotatedTextPainterBase Class Referenceabstract

This abstract base class represents a rotated text painter which is used for drawing various rotated text elements in the chart. More...

Inheritance diagram for CXTPChartRotatedTextPainterBase:
[legend]

Public Member Functions

virtual CXTPChartDeviceCommand * | CreateDeviceCommand (CXTPChartDeviceContext *pDC, const CXTPChartColor &color)
This function creates a CXTPChartDeviceCommand object.
void | SetBasePoint (CPoint pt)
Set base point of the text.
CXTPChartRectF CalculateBounds ()
Call this function to calculate the bounds of the text.
CRect | GetInitialTextRect ()
Call this function to calculate the bounds of the text.
virtual CPoint | CalculateLeftTopPoint ()=0
Call this function to calculate the left top point of the text.
virtual XTPChartTextRotation | CalculateRotation ()=0
Use this function to calculate the rotation of the text.
void | CalculatePoints (XTPChartTextRotation rotation, CRect rect, float angle, float points[4][2])
Computes text rectangle points taking into account text rotation.
- Public Member Functions inherited from CXTPChartTextPainterBase
virtual | ~CXTPChartTextPainterBase ()
Destroys a CXTPChartTextPainterBase object, handles cleanup.
CRect | GetRoundedBounds ()
Call this function to get the rounded bounds of the text.

Protected Member Functions

CXTPChartRotatedTextPainterBase (CXTPChartDeviceContext *pDC, const CXTPChartString &text, CXTPChartTextElement *pTextProvider, CPoint ptBase=CPoint(0, 0))
Constructs a CXTPChartRotatedTextPainterBase object.
- Protected Member Functions inherited from CXTPChartTextPainterBase
CXTPChartTextPainterBase (CXTPChartDeviceContext *pDC, const CXTPChartString &text, CXTPChartTextElement *pTextProvider)
Constructs a CXTPChartTextPainterBase object.

Protected Attributes

CPoint | m_ptBasePoint
The base point of the text.
float | m_fAngle
The angle of text rotation.
- Protected Attributes inherited from CXTPChartTextPainterBase
CXTPChartString | m_strText
The text to be painted.
CXTPChartSizeF | m_szTextSize
The measurements of the text.
CXTPChartTextElement * | m_pTextProvider
The chart element which owns the text.
int | m_nHeight
The height of the text.
int | m_nWidth
The width of the text.
CRect | m_rcRoundedBounds
The rounded bounds of the text.
CXTPChartRectF | m_rcBounds
The bounds of the text.

Detailed Description

This abstract base class represents a rotated text painter which is used for drawing various rotated text elements in the chart.

This is a kind of CXTPChartTextPainterBase.

Constructor & Destructor Documentation

◆ CXTPChartRotatedTextPainterBase()

CXTPChartRotatedTextPainterBase | ( | CXTPChartDeviceContext * | pDC,
 |  | const CXTPChartString & | text,
 |  | CXTPChartTextElement * | pTextProvider,
 |  | CPoint | ptBase = CPoint(0, 0) )
 protected

Constructs a CXTPChartRotatedTextPainterBase object.

Parameters
pDC | Pointer to the chart device context.
text | The text to be rendered.
pTextProvider | The element which owns the text.
ptBase | The base point of the text.

Member Function Documentation

◆ CalculateBounds()

CXTPChartRectF CalculateBounds ( )
virtual

Call this function to calculate the bounds of the text.

Returns
A CXTPChartRectF object specifying the bounds.

Implements CXTPChartTextPainterBase.

◆ CalculateLeftTopPoint()

virtual CPoint CalculateLeftTopPoint ( )
pure virtual

Call this function to calculate the left top point of the text.

Returns
A CXTPChartRectF object specifying the bounds.

This is a pure virtual function, so give meaningful implementation to this function within derived classes.

Implemented in CXTPChartRotatedTextPainterNearLine.

◆ CalculatePoints()

void CalculatePoints | ( | XTPChartTextRotation | rotation,
 |  | CRect | rect,
 |  | float | angle,
 |  | float | points[4][2] )

Computes text rectangle points taking into account text rotation.

Parameters
rotation | Text rotation type.
rect | Text rectangle.
angle | The angle of rotation.
points | On return contains coordinates of the rotated text rectangle corners.

◆ CalculateRotation()

virtual XTPChartTextRotation CalculateRotation ( )
pure virtual

Use this function to calculate the rotation of the text.

Returns
An enumerated value, XTPChartTextRotation specifies the text rotation type.

This is a pure virtual function, so give meaningful implementation to this function within derived classes.

Implemented in CXTPChartRotatedTextPainterNearLine.

◆ CreateDeviceCommand()

virtual CXTPChartDeviceCommand * CreateDeviceCommand | ( | CXTPChartDeviceContext * | pDC,
 |  | const CXTPChartColor & | color )
 virtual

This function creates a CXTPChartDeviceCommand object.

This object represents the rendering of a rotated text.

Parameters
pDC | Pointer to a CXTPChartDeviceContext object.
color | The color of the text.
Returns
Returns a CXTPChartDeviceCommand object. This object handles the rendering of an element in the chart. Here it handles the drawing of a rotated text.

◆ GetInitialTextRect()

CRect GetInitialTextRect ( )

Call this function to calculate the bounds of the text.

Returns
A CXTPChartRectF object specifying the bounds.

◆ SetBasePoint()

void SetBasePoint ( CPoint pt )

Set base point of the text.

Parameters
pt The base point of the text.
The documentation for this class was generated from the following file:
  • XTPChartTextPainter.h


Toolkit Pro: CXTPChartRotatedTextPainterNearLine Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPChartRotatedTextPainterNearLine Class Reference

This abstract base class renders a rotated text near a line which is used for drawing various rotated text elements near lines in the chart. More...

Inheritance diagram for CXTPChartRotatedTextPainterNearLine:
[legend]

Public Member Functions

CXTPChartRotatedTextPainterNearLine (CXTPChartDeviceContext *pDC, const CXTPChartString &text, CXTPChartTextElement *pTextProvider, CPoint ptBase, XTPChartNearTextPosition position, float fAngle)
Constructs a CXTPChartRotatedTextPainterNearLine object.
CPoint | CalculateLeftTopPoint ()
Use this function to calculate the left top point of the text.
XTPChartTextRotation CalculateRotation ()
Use this function to calculate the rotation of the text.
- Public Member Functions inherited from CXTPChartRotatedTextPainterBase
virtual CXTPChartDeviceCommand * | CreateDeviceCommand (CXTPChartDeviceContext *pDC, const CXTPChartColor &color)
This function creates a CXTPChartDeviceCommand object.
void | SetBasePoint (CPoint pt)
Set base point of the text.
CXTPChartRectF CalculateBounds ()
Call this function to calculate the bounds of the text.
CRect | GetInitialTextRect ()
Call this function to calculate the bounds of the text.
void | CalculatePoints (XTPChartTextRotation rotation, CRect rect, float angle, float points[4][2])
Computes text rectangle points taking into account text rotation.
- Public Member Functions inherited from CXTPChartTextPainterBase
virtual | ~CXTPChartTextPainterBase ()
Destroys a CXTPChartTextPainterBase object, handles cleanup.
CRect | GetRoundedBounds ()
Call this function to get the rounded bounds of the text.

Protected Attributes

XTPChartNearTextPosition | m_nNearPosition
The near text position.
- Protected Attributes inherited from CXTPChartRotatedTextPainterBase
CPoint | m_ptBasePoint
The base point of the text.
float | m_fAngle
The angle of text rotation.
- Protected Attributes inherited from CXTPChartTextPainterBase
CXTPChartString | m_strText
The text to be painted.
CXTPChartSizeF | m_szTextSize
The measurements of the text.
CXTPChartTextElement * | m_pTextProvider
The chart element which owns the text.
int | m_nHeight
The height of the text.
int | m_nWidth
The width of the text.
CRect | m_rcRoundedBounds
The rounded bounds of the text.
CXTPChartRectF | m_rcBounds
The bounds of the text.

Additional Inherited Members

- Protected Member Functions inherited from CXTPChartRotatedTextPainterBase
CXTPChartRotatedTextPainterBase (CXTPChartDeviceContext *pDC, const CXTPChartString &text, CXTPChartTextElement *pTextProvider, CPoint ptBase=CPoint(0, 0))
Constructs a CXTPChartRotatedTextPainterBase object.
- Protected Member Functions inherited from CXTPChartTextPainterBase
CXTPChartTextPainterBase (CXTPChartDeviceContext *pDC, const CXTPChartString &text, CXTPChartTextElement *pTextProvider)
Constructs a CXTPChartTextPainterBase object.

Detailed Description

This abstract base class renders a rotated text near a line which is used for drawing various rotated text elements near lines in the chart.

This is a kind of CXTPChartTextPainterBase.

Constructor & Destructor Documentation

◆ CXTPChartRotatedTextPainterNearLine()

CXTPChartRotatedTextPainterNearLine | ( | CXTPChartDeviceContext * | pDC,
 |  | const CXTPChartString & | text,
 |  | CXTPChartTextElement * | pTextProvider,
 |  | CPoint | ptBase,
 |  | XTPChartNearTextPosition | position,
 |  | float | fAngle )

Constructs a CXTPChartRotatedTextPainterNearLine object.

Parameters
pDC | Pointer to the chart device context.
text | The text to be rendered.
pTextProvider | The element which owns the text.
ptBase | The base point of the text.
position | An enumerated value specifying the near text position.
fAngle | The angle of rotation.

Member Function Documentation

◆ CalculateLeftTopPoint()

CPoint CalculateLeftTopPoint ( )
virtual

Use this function to calculate the left top point of the text.

Returns
A CPoint object specifying the left top.

Implements CXTPChartRotatedTextPainterBase.

◆ CalculateRotation()

XTPChartTextRotation CalculateRotation ( )
virtual

Use this function to calculate the rotation of the text.

Returns
An enumerated value, XTPChartTextRotation specifies the text rotation type.

Implements CXTPChartRotatedTextPainterBase.

The documentation for this class was generated from the following file:
  • XTPChartTextPainter.h


Toolkit Pro: CXTPChartScaleTypeMap Class Reference

Public Member Functions | Static Public Member Functions | List of all members
CXTPChartScaleTypeMap Class Referenceabstract

This class abstracts a scale type map. More...

Inheritance diagram for CXTPChartScaleTypeMap:
[legend]

Public Member Functions

CXTPChartScaleTypeMap (CXTPChartAxis *pAxis)
Constructs a CXTPChartScaleTypeMap object.
virtual | ~CXTPChartScaleTypeMap ()
Destroys a CXTPChartScaleTypeMap object, handles cleanup.
CXTPChartAxis * | GetAxis () const
Call this function to get the axis object to which this object is associated with.
virtual void | UpdateSeries (CXTPChartAxisView *pAxisView)
Call this function when there is a change in the values of the series or a change in the scale.
virtual void | UpdateSeries (CXTPChartSeries *pSeries)
Call this function when there is a change in the values of the series or a change in the scale.
virtual void | UpdateSeriesPointArgument (CXTPChartSeriesPoint *pPoint)
Call this function when there is a change in the values of the series or a change in the scale.
virtual CXTPChartString | InternalToValue (CXTPChartNumberFormat *pFromat, double dValue) const =0
Use this function to convert a double value to a string.
virtual double | ValueToInternal (const CXTPChartString &strValue) const =0
Use this function to convert a value string to an internal type.
- Public Member Functions inherited from CXTPChartElement
CXTPChartElement ()
Constructs a CXTPChartElement object.
virtual | ~CXTPChartElement ()
Destroys a CXTPChartElement object, handles cleanup.
virtual void | Release ()
Call this function to decrease the usage count of the object.
CXTPChartElement * | GetOwner () const
Call this function to get the owner element.
virtual void | OnChartChanged (XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic properties of the chart.
CXTPChartContent * | GetContent () const
Call this virtual function to get the chart content object.
CXTPChartAppearance * | GetAppearance () const
Call this function to get the the appearance of the chart.
virtual void | DoPropExchange (CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Static Public Member Functions

static CXTPChartScaleTypeMap *AFX_CDECL Create (CXTPChartAxis *pAxis)
Call this function to create a scale type map object.

Additional Inherited Members

- Public Attributes inherited from CXTPChartElement
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.
- Protected Attributes inherited from CXTPChartElement

Detailed Description

This class abstracts a scale type map.

It acts as an abstract base for various specialized scale type classes.

Constructor & Destructor Documentation

◆ CXTPChartScaleTypeMap()

CXTPChartScaleTypeMap ( CXTPChartAxis * pAxis )

Constructs a CXTPChartScaleTypeMap object.

Parameters
pAxis Pointer to the associated chart axis object.

Member Function Documentation

◆ Create()

static CXTPChartScaleTypeMap *AFX_CDECL Create ( CXTPChartAxis * pAxis )
static

Call this function to create a scale type map object.

Parameters
pAxis A pointer to a chart axis object.

This is a static function.

Returns
Returns scale type map object

◆ GetAxis()

AFX_INLINE CXTPChartAxis * GetAxis ( ) const

Call this function to get the axis object to which this object is associated with.

Returns
A pointer to a chart axis object.

◆ InternalToValue()

virtual CXTPChartString InternalToValue | ( | CXTPChartNumberFormat * | pFromat,
 |  | double | dValue ) const
 pure virtual

Use this function to convert a double value to a string.

This actually converts the internal representation of data to a more meaningful value.

Parameters
pFromat | Conversion format to use.
dValue | Value to format.
Returns
A CXTPChartString object representing the string value.

Implemented in CXTPChartDateTimeScaleTypeMap, CXTPChartNumericalScaleTypeMap, CXTPChartQualitativeScaleTypeMap, and CXTPChartTimeScaleTypeMap.

◆ UpdateSeries() [1/2]

virtual void UpdateSeries ( CXTPChartAxisView * pAxisView )
virtual

Call this function when there is a change in the values of the series or a change in the scale.

Parameters
pAxisView Pointer to a CXTPChartAxisView object.

Reimplemented in CXTPChartQualitativeScaleTypeMap.

◆ UpdateSeries() [2/2]

virtual void UpdateSeries ( CXTPChartSeries * pSeries )
virtual

Call this function when there is a change in the values of the series or a change in the scale.

Parameters
pSeries Pointer to a CXTPChartSeries object.

Reimplemented in CXTPChartQualitativeScaleTypeMap.

◆ UpdateSeriesPointArgument()

virtual void UpdateSeriesPointArgument ( CXTPChartSeriesPoint * pPoint )
virtual

Call this function when there is a change in the values of the series or a change in the scale.

Parameters
pPoint Pointer to a CXTPChartSeriesPoint object.

Reimplemented in CXTPChartDateTimeScaleTypeMap, CXTPChartNumericalScaleTypeMap, CXTPChartQualitativeScaleTypeMap, and CXTPChartTimeScaleTypeMap.

◆ ValueToInternal()

virtual double ValueToInternal ( const CXTPChartString & strValue ) const
pure virtual

Use this function to convert a value string to an internal type.

Parameters
strValue Value to be set.
Returns
A double representing the internal value.

Implemented in CXTPChartDateTimeScaleTypeMap, CXTPChartNumericalScaleTypeMap, CXTPChartQualitativeScaleTypeMap, and CXTPChartTimeScaleTypeMap.

The documentation for this class was generated from the following file:
  • XTPChartScaleTypeMap.h


Toolkit Pro: CXTPChartScatterLineSeriesStyle Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPChartScatterLineSeriesStyle Class Reference

This class represents a line series style, which is a kind of CXTPChartPointSeriesStyle. More...

Inheritance diagram for CXTPChartScatterLineSeriesStyle:
[legend]

Public Member Functions

CXTPChartScatterLineSeriesStyle ()
Constructs a CXTPChartScatterLineSeriesStyle object.
virtual | ~CXTPChartScatterLineSeriesStyle ()
Destroys a CXTPChartScatterLineSeriesStyle object, handles cleanup.
- Public Member Functions inherited from CXTPChartLineSeriesStyle
CXTPChartLineSeriesStyle ()
Constructs a CXTPChartLineSeriesStyle object.
virtual | ~CXTPChartLineSeriesStyle ()
Destroys a CXTPChartLineSeriesStyle object, handles cleanup.
CXTPChartLineStyle * | GetLineStyle () const
Call this function to get the line style of the line series.
- Public Member Functions inherited from CXTPChartPointSeriesStyle
CXTPChartPointSeriesStyle ()
Constructs a CXTPChartPointSeriesStyle object.
virtual | ~CXTPChartPointSeriesStyle ()
Destroys a CXTPChartPointSeriesStyle object, handles cleanup.
CXTPChartMarker * | GetMarker () const
Call this function to get the marker object associated with this CXTPChartPointSeriesStyle object.
void | DoPropExchange (CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
- Public Member Functions inherited from CXTPChartDiagram2DSeriesStyle
CXTPChartDiagram2DSeriesStyle ()
Constructs a CXTPChartDiagram2DSeriesStyle object.
virtual | ~CXTPChartDiagram2DSeriesStyle ()
Destroys a CXTPChartDiagram2DSeriesStyle object, handles cleanup.
virtual CXTPChartDiagram * | CreateDiagram ()
Call this function to create the diagram for this series.
virtual BOOL | IsStyleDiagram (CXTPChartDiagram *pDiagram) const
Call this function to check whether the chart diagram object passed is a kind of 2D diagram (CXTPChartDiagram2D object).
- Public Member Functions inherited from CXTPChartSeriesStyle
CXTPChartSeriesStyle ()
Constructs a CXTPChartSeriesStyle object.
virtual | ~CXTPChartSeriesStyle ()
Destroys a CXTPChartSeriesStyle object, handles cleanup.
virtual CXTPChartSeriesLabel * | GetLabel () const
Call this method to gets the series label object.
virtual CXTPChartSeriesLabel * | SetLabel (CXTPChartSeriesLabel *pLabel)
Call this method to sets the series label object.
virtual CXTPChartErrorBar * | GetErrorBar () const
Call this method to gets the error bar object.
virtual CXTPChartErrorBar * | SetErrorBar (CXTPChartErrorBar *pErrorBar)
Call this method to sets the error bar object.
virtual CXTPChartColor | GetColor () const
Call this method to get the color of the series.
virtual void | SetColor (CXTPChartColor clr)
Call this method to set the color of the series.
virtual void | SetColorEach (BOOL bColorEach)
Call this method to set individual color for each point of the series.
virtual BOOL | IsColorEach () const
This method is called to check if individual color is used for each point of the series.
virtual CXTPChart3dRotation | Get3dRotation () const
Obtains rotation parameters for 3D chart.
virtual void | Set3dRotation (const CXTPChart3dRotation &rotation)
Sets rotation parameters for 3D chart.
virtual void | Set3dRotation (double dYaw, double dPitch, double dRoll)
Sets rotation parameters for 3D chart.
virtual BOOL | Is3dEdgeSmoothingEnabled () const
Enables/disables 3D edge smoothing.
virtual void | Enable3dEdgeSmoothing (BOOL bEnable=TRUE)
Enables/disables 3D edge smoothing.
virtual int | GetTransparency () const
Call this function to gets the transparency of the chart if it is supported by the chart type.
virtual void | SetTransparency (int nTransparency)
Call this function to sets the transparency of the chart if it is supported by the chart type.
virtual void | CorrectAxisSideMargins (CXTPChartAxis *pAxis, double nMinValue, double nMaxValue, double &nCorrection)
Provides default implementation for axis side margins correction.
virtual CXTPChartSeriesStyleAppearance * | GetStyleAppearance () const
Obtains associated style appearance pointer.
virtual void | ApplyTo (CXTPChartDeviceCommand *pCommand)
Applies the style to the command provided in case the command needs style specific details for correct drawing.
virtual int | GetSeriesPointValueIndex () const
Obtains the index of a point element for which an internal value can be otained.
- Public Member Functions inherited from CXTPChartElement
CXTPChartElement ()
Constructs a CXTPChartElement object.
virtual | ~CXTPChartElement ()
Destroys a CXTPChartElement object, handles cleanup.
virtual void | Release ()
Call this function to decrease the usage count of the object.
CXTPChartElement * | GetOwner () const
Call this function to get the owner element.
virtual void | OnChartChanged (XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic properties of the chart.
CXTPChartContent * | GetContent () const
Call this virtual function to get the chart content object.
CXTPChartAppearance * | GetAppearance () const
Call this function to get the the appearance of the chart.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Protected Member Functions

virtual CXTPChartSeriesView * | CreateView (CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Call this function to create a view of the line series.
- Protected Member Functions inherited from CXTPChartLineSeriesStyle
void | DoPropExchange (CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
- Protected Member Functions inherited from CXTPChartPointSeriesStyle
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.

Additional Inherited Members

- Public Attributes inherited from CXTPChartElement
- Protected Attributes inherited from CXTPChartLineSeriesStyle
CXTPChartLineStyle * | m_pLineStyle
The line style.
- Protected Attributes inherited from CXTPChartPointSeriesStyle
- Protected Attributes inherited from CXTPChartDiagram2DSeriesStyle
int | m_nAxisIndexX
Holds index of secondary axisX, used when m_bSecondaryAxisX is TRUE.
int | m_nAxisIndexY
Holds index of secondary axisY, used when m_bSecondaryAxisY is TRUE.
- Protected Attributes inherited from CXTPChartSeriesStyle
CXTPChartSeriesLabel * | m_pLabel
Label object.
CXTPChartErrorBar * | m_pErrorBar
Error bar object.
CXTPChartColor | m_clrColor
Custom color of series.
BOOL | m_bColorEach
TRUE to color each point.
int | m_nTransparency
The transparency value in the range 0..255.
CXTPChart3dRotation | m_Rotation3d
3D rotation
BOOL | m_bSmooth3dEdges
3D edge smoothing
- Protected Attributes inherited from CXTPChartElement

Detailed Description

This class represents a line series style, which is a kind of CXTPChartPointSeriesStyle.

A line chart or line graph is a type of graph, which displays information as a series of data points connected by straight line segments. It is a basic type of chart common in many fields.

Member Function Documentation

◆ CreateView()

virtual CXTPChartSeriesView * CreateView | ( | CXTPChartSeries * | pSeries,
 |  | CXTPChartDiagramView * | pDiagramView )
 protectedvirtual

Call this function to create a view of the line series.

Parameters
pSeries | A pointer to the chart series object.
pDiagramView | A pointer to the diagram view object.
Returns
Returns a pointer to the associated series view object.

Reimplemented from CXTPChartLineSeriesStyle.

The documentation for this class was generated from the following file:
  • XTPChartScatterLineSeriesStyle.h


Toolkit Pro: CXTPChartSeries Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPChartSeries Class Reference

This class represents a series in the chart, which is a kind of CXTPChartElement. More...

Inheritance diagram for CXTPChartSeries:
[legend]

Public Member Functions

CXTPChartSeries ()
Constructs a CXTPChartSeries object.
virtual | ~CXTPChartSeries ()
Destroys a CXTPChartSeries object, handles cleanup.
CXTPChartLegendItem * | GetLegendItem () const
Call this function to get the legend item of the series.
CXTPChartSeriesPointCollection * | GetPoints () const
Call this function to gets the the collection of the series points.
void | SetPoints (CXTPChartSeriesPointCollection *pPoints)
Call this function to sets the the collection of the series points.
CXTPChartSeriesStyle * | GetStyle () const
Use this function to get the series style of the chart series.
CXTPChartSeriesStyle * | SetStyle (CXTPChartSeriesStyle *pView)
Call this function to set the series style of the chart series.
BOOL | SetDiagram (CXTPChartDiagram *pDiagram)
Use this function to set the diagram object associated with this object.
CXTPChartDiagram * | GetDiagram () const
Call this function to get the diagram object associated with this object.
void | SetArgumentScaleType (XTPChartScaleType scaleType)
Use this function to set the scale type used for the argument.
XTPChartScaleType | GetArgumentScaleType () const
Call this function to get the scale type used for the argument.
void | SetValueScaleType (XTPChartScaleType scaleType)
Use this function to set the scale type used for the value.
XTPChartScaleType | GetValueScaleType () const
Call this function to get the scale type used for the value.
int | GetPaletteIndex () const
Use this function to get the palette index.
void | SetName (LPCTSTR lpszName)
Call this function to set the name of the chart series.
CXTPChartString | GetName () const
Use this function to get the name of the chart series.
void | SetLegendText (LPCTSTR lpszLegendText)
Call this function to set the name of the legend item.
CXTPChartString | GetLegendText () const
Use this function to get the name of the legend item.
CXTPChartNumberFormat * | GetPointLegendFormat () const
Call this function to get a pointer to CXTPChartNumberFormat that specifies how to convert numbers to strings for the legend.
void | SetPointLegendFormat (LPCTSTR lpszFormat)
Obsolete method.
void | SetVisible (BOOL bVisible)
Use this function to set the series visible/invisible.
BOOL | IsVisible () const
Call this function to check if the series is visible.
void | SetLegendVisible (BOOL bVisible)
Use this function to set the legend item visible/invisible.
BOOL | IsLegendVisible () const
Call this function to check if the legend item is visible.
virtual void | DoPropExchange (CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
void | Release ()
Call this function to decrease the usage count of the object.
- Public Member Functions inherited from CXTPChartElement
CXTPChartElement ()
Constructs a CXTPChartElement object.
virtual | ~CXTPChartElement ()
Destroys a CXTPChartElement object, handles cleanup.
CXTPChartElement * | GetOwner () const
Call this function to get the owner element.
virtual void | OnChartChanged (XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic properties of the chart.
CXTPChartContent * | GetContent () const
Call this virtual function to get the chart content object.
CXTPChartAppearance * | GetAppearance () const
Call this function to get the the appearance of the chart.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Protected Attributes

CXTPChartLegendItem * | m_pLegendItem
The legend item.
CXTPChartSeriesStyle * | m_pStyle
The series style object.
CXTPChartSeriesPointCollection * | m_pPoints
The collection of points which form the series.
XTPChartScaleType | m_nArgumentScaleType
The scale type of the argument.
XTPChartScaleType | m_nValueScaleType
The scale type of the value.
CXTPChartDiagram * | m_pDiagram
The diagram object.
CXTPChartString | m_strName
The name of the series.
CXTPChartString | m_strLegendText
The legend text of the series.
CXTPChartNumberFormat * | m_pPointLegendFormat
The legend text format of the series.
BOOL | m_bVisible
TRUE if the series visible and FALSE if it is invisible.
BOOL | m_bLegendVisible
TRUE if the legend item is visible, FALSE if not visible.
int | m_nPaletteIndex
The palette index.
- Protected Attributes inherited from CXTPChartElement

Additional Inherited Members

- Public Attributes inherited from CXTPChartElement
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.

Detailed Description

This class represents a series in the chart, which is a kind of CXTPChartElement.

Member Function Documentation

◆ DoPropExchange()

virtual void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Reads this object from or writes this object to an archive.

Parameters
pPX A CXTPPropExchange object to serialize to or from.

Reimplemented from CXTPChartElement.

◆ GetArgumentScaleType()

AFX_INLINE XTPChartScaleType GetArgumentScaleType ( ) const

Call this function to get the scale type used for the argument.

Returns
An enumerated value specifying the scale type used. The common scale types used are Qualitative, Numerical and DateTime.

◆ GetDiagram()

AFX_INLINE CXTPChartDiagram * GetDiagram ( ) const

Call this function to get the diagram object associated with this object.

Returns
A pointer to a CXTPChartDiagram object. The type of the specific object depends on the diagram type using, eg:2D or 3D diagram.

◆ GetLegendItem()

CXTPChartLegendItem * GetLegendItem ( ) const

Call this function to get the legend item of the series.

Returns
Pointer to the CXTPChartLegendItem object of this series.

◆ GetLegendText()

AFX_INLINE CXTPChartString GetLegendText ( ) const

Use this function to get the name of the legend item.

Returns
Returns the name of the legend item

◆ GetName()

AFX_INLINE CXTPChartString GetName ( ) const

Use this function to get the name of the chart series.

Returns
A LPCSTR value specifying the name of the series.

◆ GetPaletteIndex()

AFX_INLINE int GetPaletteIndex ( ) const

Use this function to get the palette index.

Returns
An integer value specifying the palette index.

◆ GetPointLegendFormat()

AFX_INLINE CXTPChartNumberFormat * GetPointLegendFormat ( ) const

Call this function to get a pointer to CXTPChartNumberFormat that specifies how to convert numbers to strings for the legend.

Returns
Pointer to CXTPChartNumberFormat class
See also
CXTPChartNumberFormat

◆ GetPoints()

AFX_INLINE CXTPChartSeriesPointCollection * GetPoints ( ) const

Call this function to gets the the collection of the series points.

Returns
A pointer to a CXTPChartSeriesPointCollection object.

◆ GetStyle()

AFX_INLINE CXTPChartSeriesStyle * GetStyle ( ) const

Use this function to get the series style of the chart series.

Returns
A pointer to a CXTPChartSeriesStyle object. The type of the specific object depends on the style of series chosen, eg: bar style, bubble style etc.

◆ GetValueScaleType()

AFX_INLINE XTPChartScaleType GetValueScaleType ( ) const

Call this function to get the scale type used for the value.

Returns
An enumerated value specifying the scale type used. The common scale types used are Qualitative, Numerical and DateTime.

◆ IsLegendVisible()

AFX_INLINE BOOL IsLegendVisible ( ) const

Call this function to check if the legend item is visible.

Returns
A BOOL value. TRUE if the legend item is visible, FALSE otherwise.

◆ IsVisible()

AFX_INLINE BOOL IsVisible ( ) const

Call this function to check if the series is visible.

Returns
A BOOL value. TRUE if the series is visible, FALSE otherwise.

◆ SetArgumentScaleType()

AFX_INLINE void SetArgumentScaleType ( XTPChartScaleType scaleType )

Use this function to set the scale type used for the argument.

Parameters
scaleType An enumerated value specifying the scale type used. The common scale types used are Qualitative, Numerical and DateTime.

◆ SetDiagram()

BOOL SetDiagram ( CXTPChartDiagram * pDiagram )

Use this function to set the diagram object associated with this object.

Parameters
pDiagram A pointer to a CXTPChartDiagram object. The type of the specific object depends on the diagram type chosen, eg:2D or 3D diagram.
Returns
TRUE if operation is completed successfully, FALSE otherwise.

◆ SetLegendText()

AFX_INLINE void SetLegendText ( LPCTSTR lpszLegendText )

Call this function to set the name of the legend item.

Parameters
lpszLegendText A LPCSTR value specifying the name of the legend item for this series.

◆ SetLegendVisible()

AFX_INLINE void SetLegendVisible ( BOOL bVisible )

Use this function to set the legend item visible/invisible.

Parameters
bVisible A BOOL value. TRUE to make the legend item visible, FALSE to hide the legend item.

◆ SetName()

AFX_INLINE void SetName ( LPCTSTR lpszName )

Call this function to set the name of the chart series.

Parameters
lpszName A LPCSTR value specifying the name of the series.

◆ SetPointLegendFormat()

void SetPointLegendFormat ( LPCTSTR lpszFormat )

Obsolete method.

Use GetPointLegendFormat()->SetPattern(lpszFormat) instead.

Parameters
lpszFormat New Pattern to be set
See also
CXTPChartNumberFormat

◆ SetPoints()

void SetPoints ( CXTPChartSeriesPointCollection * pPoints )

Call this function to sets the the collection of the series points.

Parameters
pPoints new series point collection object pointer.

◆ SetStyle()

CXTPChartSeriesStyle * SetStyle ( CXTPChartSeriesStyle * pView )

Call this function to set the series style of the chart series.

Parameters
pView A pointer to a CXTPChartSeriesStyle object. The type of the specific object depends on the style of series chosen, eg: bar style, bubble style etc.
Returns
Set series style of the chart series

◆ SetValueScaleType()

AFX_INLINE void SetValueScaleType ( XTPChartScaleType scaleType )

Use this function to set the scale type used for the value.

Parameters
scaleType An enumerated value specifying the scale type used. The common scale types used are Qualitative, Numerical and DateTime.

◆ SetVisible()

AFX_INLINE void SetVisible ( BOOL bVisible )

Use this function to set the series visible/invisible.

Parameters
bVisible A BOOL value. TRUE to make the series visible, FALSE to hide the series.
The documentation for this class was generated from the following file:
  • XTPChartSeries.h


Toolkit Pro: CXTPChartSeriesCollection Class Reference

Public Member Functions | List of all members
CXTPChartSeriesCollection Class Reference

This class represents the collection of series in the chart, which is a kind of CXTPChartElement. More...

Inheritance diagram for CXTPChartSeriesCollection:
[legend]

Public Member Functions

CXTPChartSeriesCollection (CXTPChartContent *pOwner)
Constructs a CXTPChartSeriesCollection object.
virtual | ~CXTPChartSeriesCollection ()
Destroys a CXTPChartSeriesCollection object, handles cleanup.
CXTPChartSeries * | Add (CXTPChartSeries *pSeries)
Call this function to add a series to the collection.
CXTPChartSeries * | GetAt (int nIndex) const
Call this function to get a series at a particular index in the series collection.
virtual void | DoPropExchange (CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
- Public Member Functions inherited from CXTPChartElementCollection
CXTPChartElementCollection ()
Constructs a CXTPChartElementCollection object.
~CXTPChartElementCollection ()
Destroys a CXTPChartElementCollection object, handles cleanup.
virtual void | RemoveAll ()
This function removes all the individual objects from this collection object.
virtual int | GetCount () const
Call this function to get the number of objects in the internal array of this object.
virtual void | RemoveAt (int nIndex)
Use this function to remove an object from the collection.
virtual void | Remove (CXTPChartElement *pElement)
Use this function to remove an object from the collection.
CXTPChartElement * | GetAt (int nIndex) const
Call this function to get an element by its index.
int | IndexOf (CXTPChartElement *pElement) const
Call this function to get the index of a specified element.
void | InsertAt (int nIndex, CXTPChartElement *pElement)
Call this method to add a new element to the collection.
virtual void | Release ()
Call this function to decrease the usage count of the object.
- Public Member Functions inherited from CXTPChartElement
CXTPChartElement ()
Constructs a CXTPChartElement object.
virtual | ~CXTPChartElement ()
Destroys a CXTPChartElement object, handles cleanup.
CXTPChartElement * | GetOwner () const
Call this function to get the owner element.
virtual void | OnChartChanged (XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic properties of the chart.
CXTPChartContent * | GetContent () const
Call this virtual function to get the chart content object.
CXTPChartAppearance * | GetAppearance () const
Call this function to get the the appearance of the chart.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Additional Inherited Members

- Public Attributes inherited from CXTPChartElement
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.
- Protected Attributes inherited from CXTPChartElementCollection
CArray< CXTPChartElement *, CXTPChartElement * > m_arrElements
Array of CXTPChartElement pointer.
- Protected Attributes inherited from CXTPChartElement

Detailed Description

This class represents the collection of series in the chart, which is a kind of CXTPChartElement.

Constructor & Destructor Documentation

◆ CXTPChartSeriesCollection()

CXTPChartSeriesCollection ( CXTPChartContent * pOwner )

Constructs a CXTPChartSeriesCollection object.

Parameters
pOwner A pointer to the chart container object which owns the series collection.

Member Function Documentation

◆ Add()

CXTPChartSeries * Add ( CXTPChartSeries * pSeries )

Call this function to add a series to the collection.

Parameters
pSeries A pointer to the chart series which is to be added to the collection.
Returns
A newly added series object pointer.

◆ DoPropExchange()

virtual void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Reads this object from or writes this object to an archive.

Parameters
pPX A CXTPPropExchange object to serialize to or from.

Reimplemented from CXTPChartElement.

◆ GetAt()

AFX_INLINE CXTPChartSeries * GetAt ( int nIndex ) const

Call this function to get a series at a particular index in the series collection.

Parameters
nIndex Point index.
Returns
A pointer to a chart series object.
The documentation for this class was generated from the following file:
  • XTPChartSeries.h


Toolkit Pro: CXTPChartSeriesLabel Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPChartSeriesLabel Class Reference

This class abstracts the label of a series. More...

Inheritance diagram for CXTPChartSeriesLabel:
[legend]

Public Member Functions

CXTPChartSeriesLabel ()
Constructs a CXTPChartSeriesLabel object.
virtual | ~CXTPChartSeriesLabel ()
Destroys a CXTPChartSeriesLabel object, handles cleanup.
void | SetTextColor (const CXTPChartColor &clrTextColor)
Call this function to set the text color of the label.
CXTPChartColor | GetTextColor () const
Call this function to get the apparent text color of the label.
CXTPChartFont * | GetFont () const
Call this function to get the font of the text label.
void | SetFont (CXTPChartFont *pFont)
Call this function to set the font of the text label.
void | SetShowLines (BOOL bShowLines)
Call this function to set the lines visibility.
BOOL | GetShowLines () const
Call this function to check if the lines are visible.
void | SetLineLength (int nLineLength)
Call this function to set the line length.
int | GetLineLength () const
Call this function to get the line length.
void | SetVisible (BOOL bVisible)
Call this function to set the label visibility.
BOOL | IsVisible () const
Call this function to check if the label is visible.
void | SetAntialiasing (BOOL bAntialiasing)
Call this function to set anti-aliasing ON or OFF.
BOOL | GetAntialiasing () const
Call this function to check if anti-aliasing is ON or OFF.
CXTPChartNumberFormat * | GetFormat () const
Call this function to get a pointer to CXTPChartNumberFormat that specifies how to convert numbers to strings.
void | SetFormat (LPCTSTR lpszFormat)
Obsolete method.
void | SetBackColor (const CXTPChartColor &clrBackColor)
Call this function to set the text color of the label.
CXTPChartColor | GetBackColor () const
Call this function to get the apparent text color of the label.
void | SetLineColor (const CXTPChartColor &clrBackColor)
Call this function to set the text color of the label.
CXTPChartColor | GetLineColor () const
Call this function to get the apparent text color of the label.
int | GetTransparency () const
Call this function to get the transparency of the filled area with respect to the background.
void | SetTransparency (int nTransparency)
Call this function to set the transparency of the filled area with respect to the background.
virtual void | DoPropExchange (CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
- Public Member Functions inherited from CXTPChartTextElement
- Public Member Functions inherited from CXTPChartElement
CXTPChartElement ()
Constructs a CXTPChartElement object.
virtual | ~CXTPChartElement ()
Destroys a CXTPChartElement object, handles cleanup.
virtual void | Release ()
Call this function to decrease the usage count of the object.
CXTPChartElement * | GetOwner () const
Call this function to get the owner element.
virtual void | OnChartChanged (XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic properties of the chart.
CXTPChartContent * | GetContent () const
Call this virtual function to get the chart content object.
CXTPChartAppearance * | GetAppearance () const
Call this function to get the the appearance of the chart.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Protected Attributes

CXTPChartColor | m_clrTextColor
The text color.
CXTPChartColor | m_clrBackColor
The background color.
CXTPChartColor | m_clrLineColor
The line color.
BOOL | m_bVisible
TRUE if the label is visible and FALSE if not.
CXTPChartFont * | m_pFont
The font of the label.
BOOL | m_bAntialiasing
TRUE if antialiasing enabled, FALSE if not.
BOOL | m_bShowLines
TRUE if the lines are visible, FALSE if not.
int | m_nLineLength
The line length.
CXTPChartBorder * | m_pBorder
Chart border object.
int | m_nTransparency
The transparency values range from 0 to 255.
- Protected Attributes inherited from CXTPChartElement

Additional Inherited Members

- Public Attributes inherited from CXTPChartElement
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.

Detailed Description

This class abstracts the label of a series.

It is a kind of chart text element.

Member Function Documentation

◆ DoPropExchange()

virtual void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Reads this object from or writes this object to an archive.

Parameters
pPX A CXTPPropExchange object to serialize to or from.

Reimplemented from CXTPChartElement.

Reimplemented in CXTPChartBarSeriesLabel, CXTPChartDiagram2DSeriesLabel, CXTPChartFunnelSeriesLabelBase, CXTPChartPieSeriesLabelBase, CXTPChartPointSeriesLabel, CXTPChartPyramidSeriesLabelBase, CXTPChartRadarPointSeriesLabel, CXTPChartRangeAreaSeriesLabel, and CXTPChartRangeBarSeriesLabel.

◆ GetAntialiasing()

AFX_INLINE BOOL GetAntialiasing ( ) const
virtual

Call this function to check if anti-aliasing is ON or OFF.

Anti-aliasing is the smoothing of sharp edges of text and drawing.

Returns
A BOOL value. TRUE if anti-aliasing is ON, FALSE if anti-aliasing is OFF.

Implements CXTPChartTextElement.

◆ GetBackColor()

AFX_INLINE CXTPChartColor GetBackColor ( ) const

Call this function to get the apparent text color of the label.

Returns
A 32 bit color value specifying the color.

◆ GetFont()

AFX_INLINE CXTPChartFont * GetFont ( ) const
virtual

Call this function to get the font of the text label.

Returns
A CXTPChartFont object describing the font used.

Implements CXTPChartTextElement.

◆ GetFormat()

AFX_INLINE CXTPChartNumberFormat * GetFormat ( ) const

Call this function to get a pointer to CXTPChartNumberFormat that specifies how to convert numbers to strings.

Returns
Pointer to CXTPChartNumberFormat class.
See also
CXTPChartNumberFormat

◆ GetLineColor()

AFX_INLINE CXTPChartColor GetLineColor ( ) const

Call this function to get the apparent text color of the label.

Returns
A 32 bit color value specifying the color.

◆ GetLineLength()

AFX_INLINE int GetLineLength ( ) const

Call this function to get the line length.

Returns
An integer value specifying the line length.

◆ GetShowLines()

AFX_INLINE BOOL GetShowLines ( ) const

Call this function to check if the lines are visible.

Returns
A BOOL value. TRUE if the lines are visible, FALSE otherwise.

◆ GetTextColor()

AFX_INLINE CXTPChartColor GetTextColor ( ) const

Call this function to get the apparent text color of the label.

Returns
A 32 bit color value specifying the color.

◆ GetTransparency()

AFX_INLINE int GetTransparency ( ) const

Call this function to get the transparency of the filled area with respect to the background.

Returns
Returns an integer whose values are from 0 to 255.

A value of 0 means fully transparent and a value of 255 means fully opaque.

◆ IsVisible()

AFX_INLINE BOOL IsVisible ( ) const

Call this function to check if the label is visible.

Returns
A BOOL value. TRUE if the label is visible, FALSE otherwise.

◆ SetAntialiasing()

AFX_INLINE void SetAntialiasing ( BOOL bAntialiasing )

Call this function to set anti-aliasing ON or OFF.

Anti-aliasing is the smoothing of sharp edges of text and drawing.

Parameters
bAntialiasing A BOOL value. TRUE to set anti-aliasing to ON, FALSE to set anti-aliasing to OFF.

◆ SetBackColor()

AFX_INLINE void SetBackColor ( const CXTPChartColor & clrBackColor )

Call this function to set the text color of the label.

Parameters
clrBackColor An RGB value representing back color.

◆ SetFont()

void SetFont ( CXTPChartFont * pFont )

Call this function to set the font of the text label.

Parameters
pFont A pointer to a CXTPChartFont object describing the font of choice.

◆ SetFormat()

void SetFormat ( LPCTSTR lpszFormat )

Obsolete method.

Use GetFormat()->SetPattern(lpszFormat) instead.

Parameters
lpszFormat New Pattern to be set.
See also
CXTPChartNumberFormat

◆ SetLineColor()

AFX_INLINE void SetLineColor ( const CXTPChartColor & clrBackColor )

Call this function to set the text color of the label.

Parameters
clrBackColor An RGB value representing back color.

◆ SetLineLength()

AFX_INLINE void SetLineLength ( int nLineLength )

Call this function to set the line length.

Parameters
nLineLength An integer value specifying the line length.

◆ SetShowLines()

AFX_INLINE void SetShowLines ( BOOL bShowLines )

Call this function to set the lines visibility.

Parameters
bShowLines A BOOL value. TRUE to set the lines to visible, FALSE to hide the lines.

◆ SetTextColor()

AFX_INLINE void SetTextColor ( const CXTPChartColor & clrTextColor )

Call this function to set the text color of the label.

Parameters
clrTextColor A 32 bit color value specifying the color of choice.

◆ SetTransparency()

AFX_INLINE void SetTransparency ( int nTransparency )

Call this function to set the transparency of the filled area with respect to the background.

Parameters
nTransparency an integer whose values are from 0 to 255.

A value of 0 means fully transparent and a value of 255 means fully opaque.

◆ SetVisible()

AFX_INLINE void SetVisible ( BOOL bVisible )

Call this function to set the label visibility.

Parameters
bVisible A BOOL value. TRUE to set the label to visible, FALSE to hide the label.
The documentation for this class was generated from the following file:
  • XTPChartSeriesLabel.h


Toolkit Pro: CXTPChartSeriesPoint Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPChartSeriesPoint Class Reference

CXTPChartSeriesPoint is a kind of CXTPChartElement. More...

Inheritance diagram for CXTPChartSeriesPoint:
[legend]

Public Member Functions

CXTPChartSeriesPoint ()
Default constructor, makes a CXTPChartSeriesPoint object.
CXTPChartSeriesPoint (const CXTPChartString &strArgument, double dValue)
Overloaded constructor makes a CXTPChartSeriesPoint object.
CXTPChartSeriesPoint (double dArgument, double dValue)
Constructor makes a CXTPChartSeriesPoint object from the parameters.
CXTPChartSeriesPoint (double dArgument, double dValue1, double dValue2)
Constructor overload which makes a CXTPChartSeriesPoint object from an argument and a pair of values.
CXTPChartSeriesPoint (const CXTPChartString &strArgument, double dValue1, double dValue2)
Constructor overload which makes a CXTPChartSeriesPoint object from an argument and a pair of values.
CXTPChartSeriesPoint (const CXTPChartString &strArgument, double dValue1, double dValue2, double dValue3, double dValue4)
Constructor overload which makes a CXTPChartSeriesPoint object from an argument and four values.
CXTPChartSeriesPoint (double dArgument, double dValue1, double dValue2, double dValue3, double dValue4)
Constructor overload which makes a CXTPChartSeriesPoint object from an argument and four values.
virtual | ~CXTPChartSeriesPoint ()
Destroys a CXTPChartSeriesPoint object, handles cleanup.
double | GetValue (int nIndex) const
Gets the value at a specified index.
void | SetValue (int nIndex, double dValue)
Sets the value at a specified index.
CXTPChartString | GetArgument () const
This function returns the string argument of a point.
double | GetArgumentValue () const
Gets the double value of the argument of a point.
void | SetArgumentValue (double dArgument)
Sets the double value of the argument of a point.
double | GetInternalArgumentValue () const
Gets the double value of the string argument of a point.
void | SetInternalArgumentValue (double dInternalArgument)
Sets the double value of the string argument of a point.
int | GetPaletteIndex () const
This function returns the palette index used.
CXTPChartSeriesPoint * | GetPreviousPoint () const
This function returns the previous point in the series.
CXTPChartSeriesPoint * | GetNextPoint () const
This function returns the next point in the series.
void | SetLegendText (LPCTSTR lpszLegendText)
Sets new point legend text.
CXTPChartString | GetLegendText () const
Obtains current point legend text.
int | GetValueLength () const
Gets the current value length in characters.
void | SetValueLength (int nLength)
Sets the current value length in characters.
void | SetTooltipText (LPCTSTR lpszTooltip)
Call this member to set the tooltip of the action.
CXTPChartString | GetTooltipText () const
Call this member to get the action's tooltip.
void | SetLabelText (LPCTSTR lpszLabelText)
Sets point label text.
CXTPChartString | GetLabelText () const
Gets point label text.
virtual void | DoPropExchange (CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
- Public Member Functions inherited from CXTPChartElement
CXTPChartElement ()
Constructs a CXTPChartElement object.
virtual | ~CXTPChartElement ()
Destroys a CXTPChartElement object, handles cleanup.
virtual void | Release ()
Call this function to decrease the usage count of the object.
CXTPChartElement * | GetOwner () const
Call this function to get the owner element.
virtual void | OnChartChanged (XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic properties of the chart.
CXTPChartContent * | GetContent () const
Call this virtual function to get the chart content object.
CXTPChartAppearance * | GetAppearance () const
Call this function to get the the appearance of the chart.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Protected Member Functions

void CommonConstruct ()
This function handles so internal, argument type conversions.
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.

Protected Attributes

CXTPChartString | m_strArgument
String argument.
double | m_dArgument
Double value of argument.
double | m_dValues [4]
The array of values.
int | m_nLength
The size of the array, m_dValues.
double | m_dInternalArgument
The double value of the string argument.
int | m_nPaletteIndex
The chosen palette index.
int | m_nIndex
Number of elements present in the array m_dValues.
CXTPChartString | m_strLegentText
Text to show in legend.
- Protected Attributes inherited from CXTPChartElement

Detailed Description

CXTPChartSeriesPoint is a kind of CXTPChartElement.

This class represents chart series point.

Constructor & Destructor Documentation

◆ CXTPChartSeriesPoint() [1/6]

CXTPChartSeriesPoint | ( | const CXTPChartString & | strArgument,
 |  | double | dValue )

Overloaded constructor makes a CXTPChartSeriesPoint object.

Parameters
strArgument | CXTPChartString denoting the argument.
dValue | A double value for the point.

◆ CXTPChartSeriesPoint() [2/6]

CXTPChartSeriesPoint | ( | double | dArgument,
 |  | double | dValue )

Constructor makes a CXTPChartSeriesPoint object from the parameters.

Parameters
dArgument | A double value denoting the argument.
dValue | A double value for the point.

◆ CXTPChartSeriesPoint() [3/6]

CXTPChartSeriesPoint | ( | double | dArgument,
 |  | double | dValue1,
 |  | double | dValue2 )

Constructor overload which makes a CXTPChartSeriesPoint object from an argument and a pair of values.

Parameters
dArgument | Double value denoting the argument.
dValue1 | First value for the point.
dValue2 | Second value for the point.

◆ CXTPChartSeriesPoint() [4/6]

CXTPChartSeriesPoint | ( | const CXTPChartString & | strArgument,
 |  | double | dValue1,
 |  | double | dValue2 )

Constructor overload which makes a CXTPChartSeriesPoint object from an argument and a pair of values.

Parameters
strArgument | CXTPChartString denoting the argument.
dValue1 | First value for the point.
dValue2 | Second value for the point.

◆ CXTPChartSeriesPoint() [5/6]

CXTPChartSeriesPoint | ( | const CXTPChartString & | strArgument,
 |  | double | dValue1,
 |  | double | dValue2,
 |  | double | dValue3,
 |  | double | dValue4 )

Constructor overload which makes a CXTPChartSeriesPoint object from an argument and four values.

Parameters
strArgument | String value denoting the argument.
dValue1 | Double value for the point.
dValue2 | Second value for the point.
dValue3 | Third value for the point.
dValue4 | Fourth value for the point.

◆ CXTPChartSeriesPoint() [6/6]

CXTPChartSeriesPoint | ( | double | dArgument,
 |  | double | dValue1,
 |  | double | dValue2,
 |  | double | dValue3,
 |  | double | dValue4 )

Constructor overload which makes a CXTPChartSeriesPoint object from an argument and four values.

Parameters
dArgument | Double value denoting the argument.
dValue1 | Double value for the point.
dValue2 | Second value for the point.
dValue3 | Third value for the point.
dValue4 | Fourth value for the point.

Member Function Documentation

◆ DoPropExchange()

virtual void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Reads this object from or writes this object to an archive.

Parameters
pPX A CXTPPropExchange object to serialize to or from.

Reimplemented from CXTPChartElement.

◆ GetArgument()

AFX_INLINE CXTPChartString GetArgument ( ) const

This function returns the string argument of a point.

Returns
A CXTPChartString value argument of the point.

◆ GetArgumentValue()

AFX_INLINE double GetArgumentValue ( ) const

Gets the double value of the argument of a point.

Returns
A double value argument of the point.

◆ GetInternalArgumentValue()

AFX_INLINE double GetInternalArgumentValue ( ) const

Gets the double value of the string argument of a point.

Returns
A double value corresponding to the string argument of the point.

◆ GetLabelText()

AFX_INLINE CXTPChartString GetLabelText ( ) const

Gets point label text.

Returns
Current label text string.

◆ GetLegendText()

AFX_INLINE CXTPChartString GetLegendText ( ) const

Obtains current point legend text.

Returns
Current point legent text.
See also
SetLegendText

◆ GetNextPoint()

CXTPChartSeriesPoint * GetNextPoint ( ) const

This function returns the next point in the series.

Returns
A CXTPChartSeriesPoint pointer corresponding to the next point in the series.

◆ GetPaletteIndex()

AFX_INLINE int GetPaletteIndex ( ) const

This function returns the palette index used.

Returns
An int value corresponding to the chosen palette index.

◆ GetPreviousPoint()

CXTPChartSeriesPoint * GetPreviousPoint ( ) const

This function returns the previous point in the series.

Returns
A CXTPChartSeriesPoint pointer corresponding to the previous point in the series.

◆ GetTooltipText()

AFX_INLINE CXTPChartString GetTooltipText ( ) const

Call this member to get the action's tooltip.

Returns
Tooltip of the control.

◆ GetValue()

double GetValue ( int nIndex ) const

Gets the value at a specified index.

Parameters
nIndex Zero-based index.
Returns
The double value at the specified index.

◆ GetValueLength()

AFX_INLINE int GetValueLength ( ) const

Gets the current value length in characters.

Returns
Number of characters of the current value.

◆ SetArgumentValue()

AFX_INLINE void SetArgumentValue ( double dArgument )

Sets the double value of the argument of a point.

Parameters
dArgument Double value to be set.

◆ SetInternalArgumentValue()

AFX_INLINE void SetInternalArgumentValue ( double dInternalArgument )

Sets the double value of the string argument of a point.

Parameters
dInternalArgument Double value to be set.

◆ SetLabelText()

AFX_INLINE void SetLabelText ( LPCTSTR lpszLabelText )

Sets point label text.

Parameters
lpszLabelText Label text pointer.

◆ SetLegendText()

AFX_INLINE void SetLegendText ( LPCTSTR lpszLegendText )

Sets new point legend text.

Parameters
lpszLegendText New legend text pointer.
See also
GetLegendText

◆ SetTooltipText()

AFX_INLINE void SetTooltipText ( LPCTSTR lpszTooltip )

Call this member to set the tooltip of the action.

Parameters
lpszTooltip Tooltip to be set.
See also
SetCaption, SetDescription, SetPrompt

◆ SetValue()

void SetValue | ( | int | nIndex,
 |  | double | dValue )

Sets the value at a specified index.

Parameters
nIndex | Zero-based index.
dValue | Double value to be set.

◆ SetValueLength()

AFX_INLINE void SetValueLength ( int nLength )

Sets the current value length in characters.

Parameters
nLength New length of the value.
The documentation for this class was generated from the following file:
  • XTPChartSeriesPoint.h


Toolkit Pro: CXTPChartSeriesPointCollection Class Reference

Public Member Functions | List of all members
CXTPChartSeriesPointCollection Class Reference

CXTPChartSeriesPointCollection class represents a collection of chart series points. More...

Inheritance diagram for CXTPChartSeriesPointCollection:
[legend]

Public Member Functions

CXTPChartSeriesPointCollection ()
Constructs CXTPChartSeriesPointCollection object.
virtual | ~CXTPChartSeriesPointCollection ()
Destroys a CXTPChartSeriesPointCollection object, handles cleanup.
CXTPChartSeriesPoint * Add (CXTPChartSeriesPoint *pPoint)
This function adds a point represented by the class CXTPChartSeriesPoint to the internal array of points.
virtual CXTPChartSeriesPoint * | GetAt (int nIndex) const
Call this function to get the pointer to the CXTPChartSeriesPoint object at a particular index.
void | AddPoints (int nCount)
Call this method to add a batch of points.
virtual double | GetArithmeticMean (int nValue) const
Call this method to get the arithmetic mean of the point collection.
virtual double | GetVariance (int nValue) const
Call this method to get the variance of the point collection.
virtual double | GetStandardDeviation (int nValue) const
Call this method to get the standard deviation of the point collection.
virtual double | GetMovingAverage (int nValue, int nFrom, int nTo) const
Call this method to get the moving average of the point collection.
virtual double | GetMinimum (int nValue) const
Call this method to get the minimum of the point collection.
virtual double | GetMaximum (int nValue) const
Call this method to get the maximum of the point collection.
virtual void | DoPropExchange (CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
- Public Member Functions inherited from CXTPChartElementCollection
CXTPChartElementCollection ()
Constructs a CXTPChartElementCollection object.
~CXTPChartElementCollection ()
Destroys a CXTPChartElementCollection object, handles cleanup.
virtual void | RemoveAll ()
This function removes all the individual objects from this collection object.
virtual int | GetCount () const
Call this function to get the number of objects in the internal array of this object.
virtual void | RemoveAt (int nIndex)
Use this function to remove an object from the collection.
virtual void | Remove (CXTPChartElement *pElement)
Use this function to remove an object from the collection.
CXTPChartElement * | GetAt (int nIndex) const
Call this function to get an element by its index.
int | IndexOf (CXTPChartElement *pElement) const
Call this function to get the index of a specified element.
void | InsertAt (int nIndex, CXTPChartElement *pElement)
Call this method to add a new element to the collection.
virtual void | Release ()
Call this function to decrease the usage count of the object.
- Public Member Functions inherited from CXTPChartElement
CXTPChartElement ()
Constructs a CXTPChartElement object.
virtual | ~CXTPChartElement ()
Destroys a CXTPChartElement object, handles cleanup.
CXTPChartElement * | GetOwner () const
Call this function to get the owner element.
virtual void | OnChartChanged (XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic properties of the chart.
CXTPChartContent * | GetContent () const
Call this virtual function to get the chart content object.
CXTPChartAppearance * | GetAppearance () const
Call this function to get the the appearance of the chart.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Additional Inherited Members

- Public Attributes inherited from CXTPChartElement
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.
- Protected Attributes inherited from CXTPChartElementCollection
CArray< CXTPChartElement *, CXTPChartElement * > m_arrElements
Array of CXTPChartElement pointer.
- Protected Attributes inherited from CXTPChartElement

Detailed Description

CXTPChartSeriesPointCollection class represents a collection of chart series points.

Member Function Documentation

◆ Add()

CXTPChartSeriesPoint * Add ( CXTPChartSeriesPoint * pPoint )

This function adds a point represented by the class CXTPChartSeriesPoint to the internal array of points.

Parameters
pPoint The pointer to a CXTPChartSeriesPoint object.
Returns
The pointer to the CXTPChartSeriesPoint object, which is added to the object array.

◆ AddPoints()

void AddPoints ( int nCount )

Call this method to add a batch of points.

Parameters
nCount Number of points to add.

This method is an optimized way to add a large number of points; memory will be allocated once for all of them.

◆ DoPropExchange()

virtual void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Reads this object from or writes this object to an archive.

Parameters
pPX A CXTPPropExchange object to serialize to or from.

Reimplemented from CXTPChartElement.

◆ GetArithmeticMean()

virtual double GetArithmeticMean ( int nValue ) const
virtual

Call this method to get the arithmetic mean of the point collection.

Parameters
nValue Index of the value.
Returns
The arithmetic mean of the series collection.

◆ GetAt()

AFX_INLINE CXTPChartSeriesPoint * GetAt ( int nIndex ) const
virtual

Call this function to get the pointer to the CXTPChartSeriesPoint object at a particular index.

Parameters
nIndex The zero-based index.
Returns
The pointer to the CXTPChartSeriesPoint object, which stays at the index nIndex.

◆ GetMaximum()

virtual double GetMaximum ( int nValue ) const
virtual

Call this method to get the maximum of the point collection.

Parameters
nValue Index of the value.
Returns
Returns maximum

◆ GetMinimum()

virtual double GetMinimum ( int nValue ) const
virtual

Call this method to get the minimum of the point collection.

Parameters
nValue Index of the value.
Returns
Returns minimum

◆ GetMovingAverage()

virtual double GetMovingAverage | ( | int | nValue,
 |  | int | nFrom,
 |  | int | nTo ) const
 virtual

Call this method to get the moving average of the point collection.

Parameters
nValue | Index of the value.
nFrom | Index of the point.
nTo | Index of the point.
Returns
The moving average of the series collection.

◆ GetStandardDeviation()

virtual double GetStandardDeviation ( int nValue ) const
virtual

Call this method to get the standard deviation of the point collection.

Parameters
nValue Index of the value.
Returns
The standard deviation of the series collection.

◆ GetVariance()

virtual double GetVariance ( int nValue ) const
virtual

Call this method to get the variance of the point collection.

Parameters
nValue Index of the value.
Returns
The variance of the series collection.
The documentation for this class was generated from the following file:
  • XTPChartSeriesPoint.h


Toolkit Pro: CXTPChartSeriesPointView Class Reference

Public Member Functions | Public Attributes | Protected Attributes | List of all members
CXTPChartSeriesPointView Class Reference

Represents chart series point view. More...

Inheritance diagram for CXTPChartSeriesPointView:
[legend]

Public Member Functions

CXTPChartSeriesPointView (CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Constructs the view object.
CXTPChartSeriesPointView (CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView, BOOL bAddToParent)
Constructs the view object.
CXTPChartSeriesPoint * | GetPoint () const
Obtains point model object.
CXTPChartSeriesView * | GetSeriesView () const
Obtains parent series view.
CXTPChartColor | GetColor () const
Obtain view color values.
CXTPChartColor | GetColor2 () const
Obtain view color values.
double | GetInternalValue () const
Obtains point interval value.
virtual CXTPChartString | GetLegendName () const
This function returns the legend name.
virtual CXTPChartDeviceCommand * | CreateLegendDeviceCommand (CXTPChartDeviceContext *pDC, CRect rcBounds)
This function creates a CXTPChartDeviceCommand object.
virtual void | UpdateMinMaxRange (double &nMinValue, double &nMaxValue) const
Provides a default empty implementation for min/max range update request.
- Public Member Functions inherited from CXTPChartElementView
CXTPChartElementView (CXTPChartElementView *pParentView)
Constructs a CXTPChartElementView object.
CXTPChartElementView (CXTPChartElementView *pParentView, BOOL bAddToParent)
Constructs a CXTPChartElementView object.
CXTPChartElementView (CXTPChartContainer *pContainer)
Constructs a CXTPChartElementView object.
int | GetCount () const
Call this function to get the number of child views associated with this view.
CXTPChartElementView * | GetAt (int nIndex) const
Call this function to get a child view at a particular index.
virtual CXTPChartDeviceCommand * | CreateDeviceCommand (CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
CXTPChartElementView * | GetParentView () const
Call this function to get the parent view.
CXTPChartElementView * | AddChildView (CXTPChartElementView *pChildView)
Call this function to add a child view to the current view.
CXTPChartElementView ** GetChildren ()
Provides access to the collection of children elements owned by the view.
CRect | GetBounds () const
Obtains viewed object's bound rectangle.
CRect | GetBounds (BOOL bIncludingChildren) const
Obtains viewed object's bound rectangle.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.
- Public Member Functions inherited from CXTPChartLegendItemView
virtual | ~CXTPChartLegendItemView ()
Handles object destruction.

Public Attributes

double m_dInternalValue
Point internal value.

Protected Attributes

CXTPChartSeriesPoint * | m_pPoint
Point model object pointer.
- Protected Attributes inherited from CXTPChartElementView
CArray< CXTPChartElementView *, CXTPChartElementView * > | m_arrChildren
The child view collection.
CXTPChartElementView * | m_pParentView
The parent view.
CXTPChartContainer * | m_pContainer
The parent container.
CRect | m_rcBounds
Bounding rectangle.

Additional Inherited Members

- Protected Member Functions inherited from CXTPChartElementView
virtual ~CXTPChartElementView ()
Destroys a CXTPChartElementView object, handles cleanup.
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.

Detailed Description

Represents chart series point view.

Constructor & Destructor Documentation

◆ CXTPChartSeriesPointView() [1/2]

CXTPChartSeriesPointView | ( | CXTPChartSeriesPoint * | pPoint,
 |  | CXTPChartElementView * | pParentView )

Constructs the view object.

Parameters
pPoint | Point model object pointer.
pParentView | Parent view pointer.

◆ CXTPChartSeriesPointView() [2/2]

CXTPChartSeriesPointView | ( | CXTPChartSeriesPoint * | pPoint,
 |  | CXTPChartElementView * | pParentView,
 |  | BOOL | bAddToParent )

Constructs the view object.

Parameters
pPoint | Point model object pointer.
pParentView | Parent view pointer.
bAddToParent | If TRUE, the view will be added to parent's child elements.

Member Function Documentation

◆ CreateLegendDeviceCommand()

virtual CXTPChartDeviceCommand * CreateLegendDeviceCommand | ( | CXTPChartDeviceContext * | pDC,
 |  | CRect | rcBounds )
 virtual

This function creates a CXTPChartDeviceCommand object.

This object represents the rendering of a legend item in the chart.

Parameters
rcBounds | The bounding rectange.
pDC | Pointer to a valid device context.
Returns
Returns a CXTPChartDeviceCommand object. This object handles the rendering of an element in the chart. Here it handles the drawing of the legend item.

Implements CXTPChartLegendItemView.

Reimplemented in CXTPChart3dFunnelSeriesPointView, CXTPChart3dPieSeriesPointView, CXTPChart3dPyramidSeriesPointView, CXTPChartBarSeriesPointView, CXTPChartFunnelSeriesPointViewBase, CXTPChartPieSeriesPointView, CXTPChartPieSeriesPointViewBase, CXTPChartPointSeriesPointView, CXTPChartPyramidSeriesPointViewBase, CXTPChartRadarPointSeriesPointView, and CXTPChartStepLineSeriesPointView.

◆ GetColor()

CXTPChartColor GetColor ( ) const

Obtain view color values.

Returns
View color value.

◆ GetColor2()

CXTPChartColor GetColor2 ( ) const

Obtain view color values.

Returns
View color value.

◆ GetInternalValue()

AFX_INLINE double GetInternalValue ( ) const

Obtains point interval value.

Returns
Point interval value.

◆ GetLegendName()

virtual CXTPChartString GetLegendName ( ) const
virtual

This function returns the legend name.

It is a pure virtual function so it should be implemented in the derived classes.

Returns
Returns the legend name represented by the CXTPChartString class.

Implements CXTPChartLegendItemView.

◆ GetPoint()

AFX_INLINE CXTPChartSeriesPoint * GetPoint ( ) const

Obtains point model object.

Returns
Point model object pointer.

◆ GetSeriesView()

CXTPChartSeriesView * GetSeriesView ( ) const

Obtains parent series view.

Returns
Parent series view pointer.

◆ UpdateMinMaxRange()

AFX_INLINE void UpdateMinMaxRange | ( | double & | nMinValue,
 |  | double & | nMaxValue ) const
 virtual

Provides a default empty implementation for min/max range update request.

Parameters
nMinValue | The updated minimal value.
nMaxValue | The updated maximal value.

Reimplemented in CXTPChartRangeBarSeriesPointView, and CXTPChartRangeSplineAreaSeriesPointView.

The documentation for this class was generated from the following file:
  • XTPChartSeriesPointView.h


Toolkit Pro: CXTPChartSeriesStyle Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPChartSeriesStyle Class Referenceabstract

CXTPChartSeriesStyle is a CXTPChartElement derived class. More...

Inheritance diagram for CXTPChartSeriesStyle:
[legend]

Public Member Functions

CXTPChartSeriesStyle ()
Constructs a CXTPChartSeriesStyle object.
virtual | ~CXTPChartSeriesStyle ()
Destroys a CXTPChartSeriesStyle object, handles cleanup.
virtual CXTPChartSeriesLabel * | GetLabel () const
Call this method to gets the series label object.
virtual CXTPChartSeriesLabel * | SetLabel (CXTPChartSeriesLabel *pLabel)
Call this method to sets the series label object.
virtual CXTPChartErrorBar * | GetErrorBar () const
Call this method to gets the error bar object.
virtual CXTPChartErrorBar * | SetErrorBar (CXTPChartErrorBar *pErrorBar)
Call this method to sets the error bar object.
virtual CXTPChartDiagram * | CreateDiagram ()
Implementations can override this method to customize the creation of a diagram object.
virtual BOOL | IsStyleDiagram (CXTPChartDiagram *pDiagram) const
Implementations should override this method to customize the logic of checking diagram compatibility with the chart style.
virtual CXTPChartColor | GetColor () const
Call this method to get the color of the series.
virtual void | SetColor (CXTPChartColor clr)
Call this method to set the color of the series.
virtual void | SetColorEach (BOOL bColorEach)
Call this method to set individual color for each point of the series.
virtual BOOL | IsColorEach () const
This method is called to check if individual color is used for each point of the series.
virtual CXTPChart3dRotation | Get3dRotation () const
Obtains rotation parameters for 3D chart.
virtual void | Set3dRotation (const CXTPChart3dRotation &rotation)
Sets rotation parameters for 3D chart.
virtual void | Set3dRotation (double dYaw, double dPitch, double dRoll)
Sets rotation parameters for 3D chart.
virtual BOOL | Is3dEdgeSmoothingEnabled () const
Enables/disables 3D edge smoothing.
virtual void | Enable3dEdgeSmoothing (BOOL bEnable=TRUE)
Enables/disables 3D edge smoothing.
virtual int | GetTransparency () const
Call this function to gets the transparency of the chart if it is supported by the chart type.
virtual void | SetTransparency (int nTransparency)
Call this function to sets the transparency of the chart if it is supported by the chart type.
virtual void | CorrectAxisSideMargins (CXTPChartAxis *pAxis, double nMinValue, double nMaxValue, double &nCorrection)
Provides default implementation for axis side margins correction.
virtual CXTPChartSeriesStyleAppearance * | GetStyleAppearance () const
Obtains associated style appearance pointer.
virtual void | ApplyTo (CXTPChartDeviceCommand *pCommand)
Applies the style to the command provided in case the command needs style specific details for correct drawing.
virtual int | GetSeriesPointValueIndex () const
Obtains the index of a point element for which an internal value can be otained.
virtual void | DoPropExchange (CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
virtual CXTPChartSeriesView * | CreateView (CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)=0
This virtual method is called to create a new view associated with the current style.
- Public Member Functions inherited from CXTPChartElement
CXTPChartElement ()
Constructs a CXTPChartElement object.
virtual | ~CXTPChartElement ()
Destroys a CXTPChartElement object, handles cleanup.
virtual void | Release ()
Call this function to decrease the usage count of the object.
CXTPChartElement * | GetOwner () const
Call this function to get the owner element.
virtual void | OnChartChanged (XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic properties of the chart.
CXTPChartContent * | GetContent () const
Call this virtual function to get the chart content object.
CXTPChartAppearance * | GetAppearance () const
Call this function to get the the appearance of the chart.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Protected Attributes

CXTPChartSeriesLabel * | m_pLabel
Label object.
CXTPChartErrorBar * | m_pErrorBar
Error bar object.
CXTPChartColor | m_clrColor
Custom color of series.
BOOL | m_bColorEach
TRUE to color each point.
int | m_nTransparency
The transparency value in the range 0..255.
CXTPChart3dRotation | m_Rotation3d
3D rotation
BOOL | m_bSmooth3dEdges
3D edge smoothing
- Protected Attributes inherited from CXTPChartElement

Additional Inherited Members

- Public Attributes inherited from CXTPChartElement
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.

Detailed Description

CXTPChartSeriesStyle is a CXTPChartElement derived class.

It is the base class for all Styles for the Chart.

Member Function Documentation

◆ ApplyTo()

virtual void ApplyTo ( CXTPChartDeviceCommand * pCommand )
virtual

Applies the style to the command provided in case the command needs style specific details for correct drawing.

Parameters
pCommand Command pointer for which the style is to be applied.

◆ CorrectAxisSideMargins()

virtual void CorrectAxisSideMargins | ( | CXTPChartAxis * | pAxis,
 |  | double | nMinValue,
 |  | double | nMaxValue,
 |  | double & | nCorrection )
 virtual

Provides default implementation for axis side margins correction.

Parameters
pAxis | Axis pointer.
nMinValue | Minimal acceptable value.
nMaxValue | Maximal acceptable value.
nCorrection | Result new correction value.

Reimplemented in CXTPChartBarSeriesStyle, CXTPChartBubbleSeriesStyle, and CXTPChartStackedBarSeriesStyle.

◆ CreateDiagram()

AFX_INLINE CXTPChartDiagram * CreateDiagram ( )
virtual

Implementations can override this method to customize the creation of a diagram object.

Returns
New diagram object that will contain the series.

Reimplemented in CXTPChart3dFunnelSeriesStyle, CXTPChart3dPieSeriesStyle, CXTPChart3dPyramidSeriesStyle, CXTPChartDiagram2DSeriesStyle, CXTPChartFunnelSeriesStyle, CXTPChartFunnelSeriesStyleBase, CXTPChartPieSeriesStyle, CXTPChartPieSeriesStyleBase, CXTPChartPyramidSeriesStyle, CXTPChartPyramidSeriesStyleBase, and CXTPChartRadarDiagramSeriesStyle.

◆ CreateView()

virtual CXTPChartSeriesView * CreateView | ( | CXTPChartSeries * | pSeries,
 |  | CXTPChartDiagramView * | pDiagramView )
 pure virtual

This virtual method is called to create a new view associated with the current style.

Parameters
pSeries | Series associated with the style.
pDiagramView | Parent diagram view.
Returns
Pointer to a new CXTPChartSeriesView object.

Implemented in CXTPChart3dFunnelSeriesStyle, CXTPChart3dPieSeriesStyle, CXTPChart3dPyramidSeriesStyle, CXTPChartAreaSeriesStyle, CXTPChartBarSeriesStyle, CXTPChartBubbleSeriesStyle, CXTPChartCandleStickSeriesStyle, CXTPChartFastLineSeriesStyle, CXTPChartFunnelSeriesStyle, CXTPChartFunnelSeriesStyleBase, CXTPChartGanttSeriesStyle, CXTPChartHighLowSeriesStyle, CXTPChartLineSeriesStyle, CXTPChartPieSeriesStyle, CXTPChartPieSeriesStyleBase, CXTPChartPointSeriesStyle, CXTPChartPyramidSeriesStyle, CXTPChartPyramidSeriesStyleBase, CXTPChartRadarAreaSeriesStyle, CXTPChartRadarLineSeriesStyle, CXTPChartRadarPointSeriesStyle, CXTPChartRadarSplineAreaSeriesStyle, CXTPChartRadarSplineSeriesStyle, CXTPChartRangeBarSeriesStyle, CXTPChartRangeSplineAreaSeriesStyle, CXTPChartScatterLineSeriesStyle, CXTPChartSplineAreaSeriesStyle, CXTPChartSplineSeriesStyle, CXTPChartStackedAreaSeriesStyle, CXTPChartStackedBarSeriesStyle, CXTPChartStackedSplineAreaSeriesStyle, CXTPChartStepAreaSeriesStyle, and CXTPChartStepLineSeriesStyle.

◆ DoPropExchange()

virtual void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Reads this object from or writes this object to an archive.

Parameters
pPX A CXTPPropExchange object to serialize to or from.

Reimplemented from CXTPChartElement.

Reimplemented in CXTPChart3dFunnelSeriesStyle, CXTPChart3dPieSeriesStyle, CXTPChart3dPyramidSeriesStyle, CXTPChartAreaSeriesStyle, CXTPChartBarSeriesStyle, CXTPChartBubbleSeriesStyle, CXTPChartDiagram2DSeriesStyle, CXTPChartFastLineSeriesStyle, CXTPChartFunnelSeriesStyleBase, CXTPChartGanttSeriesStyle, CXTPChartLineSeriesStyle, CXTPChartPieSeriesStyleBase, CXTPChartPointSeriesStyle, CXTPChartPyramidSeriesStyleBase, CXTPChartRadarAreaSeriesStyle, CXTPChartRadarDiagramSeriesStyle, CXTPChartRadarLineSeriesStyle, CXTPChartRadarPointSeriesStyle, CXTPChartRangeBarSeriesStyle, CXTPChartStackedBarSeriesStyle, CXTPChartStepAreaSeriesStyle, and CXTPChartStepLineSeriesStyle.

◆ Enable3dEdgeSmoothing()

AFX_INLINE void Enable3dEdgeSmoothing ( BOOL bEnable = TRUE )
virtual

Enables/disables 3D edge smoothing.

Parameters
bEnable TRUE to enable 3D edge smoothing, FALSE to disable 3D edge smoothing.

◆ Get3dRotation()

AFX_INLINE CXTPChart3dRotation Get3dRotation ( ) const
virtual

Obtains rotation parameters for 3D chart.

Returns
Rotation parameters for 3D chart.
See also
Set3dRotation

Reimplemented in CXTPChart3dPieSeriesStyle.

◆ GetColor()

AFX_INLINE CXTPChartColor GetColor ( ) const
virtual

Call this method to get the color of the series.

Returns
The color of the series. If default appearance color is used, then CXTPChartColor::Empty will be returned.

◆ GetErrorBar()

AFX_INLINE CXTPChartErrorBar * GetErrorBar ( ) const
virtual

Call this method to gets the error bar object.

Returns
Pointer to CXTPChartErrorBar that contains the properties for the error bar.

◆ GetLabel()

AFX_INLINE CXTPChartSeriesLabel * GetLabel ( ) const
virtual

Call this method to gets the series label object.

Returns
Pointer to CXTPChartSeriesLabel that contains the properties for the label.

◆ GetSeriesPointValueIndex()

AFX_INLINE int GetSeriesPointValueIndex ( ) const
virtual

Obtains the index of a point element for which an internal value can be otained.

Returns
The index of a point element for which an internal value can be otained

Reimplemented in CXTPChartBubbleSeriesStyle.

◆ GetStyleAppearance()

virtual CXTPChartSeriesStyleAppearance * GetStyleAppearance ( ) const
virtual

Obtains associated style appearance pointer.

Returns
Style appearance pointer

◆ GetTransparency()

AFX_INLINE int GetTransparency ( ) const
virtual

Call this function to gets the transparency of the chart if it is supported by the chart type.

Returns
An integer value denoting the transparency of the chart with a range from 0-255.

Reimplemented in CXTPChartAreaSeriesStyle, and CXTPChartRadarAreaSeriesStyle.

◆ Is3dEdgeSmoothingEnabled()

AFX_INLINE BOOL Is3dEdgeSmoothingEnabled ( ) const
virtual

Enables/disables 3D edge smoothing.

Returns
TRUE if edge smoothing is enabled, FALSE otherwise.

◆ IsColorEach()

AFX_INLINE BOOL IsColorEach ( ) const
virtual

This method is called to check if individual color is used for each point of the series.

Returns
True if color is used

◆ IsStyleDiagram()

virtual BOOL IsStyleDiagram ( CXTPChartDiagram * pDiagram ) const
virtual

Implementations should override this method to customize the logic of checking diagram compatibility with the chart style.

By default, all diagrams are deemed incompatible, i.e. return FALSE.

Parameters
pDiagram Diagram to check.
Returns
TRUE if the series can be inserted in the diagram object.

Reimplemented in CXTPChart3dFunnelSeriesStyle, CXTPChart3dPyramidSeriesStyle, CXTPChartDiagram2DSeriesStyle, CXTPChartFunnelSeriesStyle, CXTPChartFunnelSeriesStyleBase, CXTPChartPieSeriesStyleBase, CXTPChartPyramidSeriesStyle, CXTPChartPyramidSeriesStyleBase, and CXTPChartRadarDiagramSeriesStyle.

◆ Set3dRotation() [1/2]

AFX_INLINE void Set3dRotation ( const CXTPChart3dRotation & rotation )
virtual

Sets rotation parameters for 3D chart.

Parameters
rotation Rotation parameters in degrees.
See also
GetRotation

◆ Set3dRotation() [2/2]

AFX_INLINE void Set3dRotation | ( | double | dYaw,
 |  | double | dPitch,
 |  | double | dRoll )
 virtual

Sets rotation parameters for 3D chart.

Parameters
dYaw | Yaw angle value in degrees.
dPitch | Pitch angle value in degrees.
dRoll | Roll angle value in degrees.
See also
GetRotation

◆ SetColor()

AFX_INLINE void SetColor ( CXTPChartColor clr )
virtual

Call this method to set the color of the series.

Parameters
clr New Color to be set. It can be CXTPChartColor::Empty to use the default appearance color.

◆ SetColorEach()

AFX_INLINE void SetColorEach ( BOOL bColorEach )
virtual

Call this method to set individual color for each point of the series.

Parameters
bColorEach TRUE if individual color should be used for each point of the series.

◆ SetErrorBar()

virtual CXTPChartErrorBar * SetErrorBar ( CXTPChartErrorBar * pErrorBar )
virtual

Call this method to sets the error bar object.

Parameters
pErrorBar A pointer to a new error bar object to set.
Returns
Pointer to CXTPChartErrorBar that contains the properties for the error bar.

◆ SetLabel()

virtual CXTPChartSeriesLabel * SetLabel ( CXTPChartSeriesLabel * pLabel )
virtual

Call this method to sets the series label object.

Parameters
pLabel A new label object to set.
Returns
Pointer to CXTPChartSeriesLabel that contains the properties for the label.

◆ SetTransparency()

AFX_INLINE void SetTransparency ( int nTransparency )
virtual

Call this function to sets the transparency of the chart if it is supported by the chart type.

Parameters
nTransparency An integer value denoting the transparency of the chart with a range from 0-255.

Reimplemented in CXTPChartAreaSeriesStyle, and CXTPChartRadarAreaSeriesStyle.

The documentation for this class was generated from the following file:
  • XTPChartSeriesStyle.h


Toolkit Pro: CXTPChartSolidSplinePolygonDeviceCommand Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPChartSolidSplinePolygonDeviceCommand Class Reference

Base class implementation for 2D chart solid spline polygon device command. More...

Inheritance diagram for CXTPChartSolidSplinePolygonDeviceCommand:
[legend]

Public Member Functions

CXTPChartSolidSplinePolygonDeviceCommand (const CXTPChartColor &color, BOOL bTwoSides=FALSE)
Constructs a CXTPChartSolidSplinePolygonDeviceCommand object.
- Public Member Functions inherited from CXTPChartDeviceCommand
CXTPChartDeviceCommand ()
Constructs a CXTPChartDeviceCommand object.
virtual | ~CXTPChartDeviceCommand ()
Destroys a CXTPChartDeviceCommand object, handles cleanup.
BOOL | IsCommitted () const
Determines if the execution of the command has been committed.
void | Commit ()
Commits the execution of the command.
int | GetChildCommandCount () const
Obtains the number of immediate children commands.
CXTPChartDeviceCommand * | GetChildCommand (int nIndex) const
Obtains immediate child command point by index.
CXTPChartDeviceCommand * | AddChildCommand (CXTPChartDeviceCommand *pCommand)
Call this function to add a child device command.
virtual void | Execute (CXTPChartDeviceContext *pDC)
Call this function to execute the drawing.
virtual void | BeforeExecute (CXTPChartDeviceContext *pDC)
This method gets called before a command is executed which allows for the customization of command behavior.
virtual void | AfterExecute (CXTPChartDeviceContext *pDC)
This method gets called after a command is executed which allows for the customization of command behavior.
virtual void | ExecuteOverride (CXTPChartDeviceContext *pDC)
Override this function to write the drawing code for specific objects.
UINT | GetPassNumber () const
Get the number of executions made by the command.
virtual CXTPChartElement * | HitTest (CPoint point, CXTPChartElement *pParent) const
Performs recursive hit testing of the element at the specified point.
virtual void | ApplySeriesStyle (CXTPChartSeriesStyle *pStyle)
Applies series style to the current element.
virtual void | Prepare (CXTPChartDeviceContext *pDC)
Performs inital preparation steps necessary for successful command execution.
virtual void | PrepareOverride (CXTPChartDeviceContext *pDC)
Derived implementation must override this method for implementing implementation specific preparation behavior.
virtual BOOL | IsEnabled () const
Determines if the command is currently enabled.
void | SetEnabled (BOOL bEnabled=TRUE)
Enables/disable the command.
CXTPChartDeviceContext * | GetCurrentDC () const
Obtains device context pointer for which the command is currenly being prepared or executed.
void | BindView (CXTPChartElementView *pView)
Binds a view to the command object.
CXTPChartElementView * | GetBoundView () const
Obtains a bound view pointer or NULL if no view is bound.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.
- Public Member Functions inherited from CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents >
void | Subscribe (CXTPChartDeviceCommandEvents *pObserver, CXTPSubscriptionList< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > *pSubcriptionList=NULL)
Subscribes a unique observer for events.
void | Unsubscribe (CXTPChartDeviceCommandEvents *pObserver)
Unsubscribes an observer from events.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *))
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *))
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.

Protected Attributes

CXTPChartColor | m_color
The fill color of the spline polygon.
BOOL | m_bTwoSides
Unused.
- Protected Attributes inherited from CXTPChartDeviceCommand
CArray< CXTPChartDeviceCommand *, CXTPChartDeviceCommand * > | m_arrChildren
< The array of child device commands.

Additional Inherited Members

- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.
- Protected Member Functions inherited from CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents >
CXTPObservable ()
Constructs an observable object.
~CXTPObservable ()
Handles observable object destruction.

Detailed Description

Base class implementation for 2D chart solid spline polygon device command.

Constructor & Destructor Documentation

◆ CXTPChartSolidSplinePolygonDeviceCommand()

CXTPChartSolidSplinePolygonDeviceCommand | ( | const CXTPChartColor & | color,
 |  | BOOL | bTwoSides = FALSE )

Constructs a CXTPChartSolidSplinePolygonDeviceCommand object.

Parameters
color | The fill color of the solid spline.
bTwoSides | Unused. Reserved.

Member Data Documentation

◆ m_bTwoSides

BOOL m_bTwoSides
protected

Unused.

Reserved.

The documentation for this class was generated from the following file:
  • XTPChartPolygonDeviceCommand.h


Toolkit Pro: CXTPChartSplineAreaSeriesStyle Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPChartSplineAreaSeriesStyle Class Reference

This class represents a spline area series style, which is a kind of CXTPChartAreaSeriesStyle. More...

Inheritance diagram for CXTPChartSplineAreaSeriesStyle:
[legend]

Public Member Functions

CXTPChartSplineAreaSeriesStyle ()
Constructs a CXTPChartSplineAreaSeriesStyle object.
virtual | ~CXTPChartSplineAreaSeriesStyle ()
Destroys a CXTPChartSplineAreaSeriesStyle object, handles cleanup.
- Public Member Functions inherited from CXTPChartAreaSeriesStyle
CXTPChartAreaSeriesStyle ()
Constructs a CXTPChartAreaSeriesStyle object.
virtual | ~CXTPChartAreaSeriesStyle ()
Destroys a CXTPChartAreaSeriesStyle object, handles cleanup.
CXTPChartFillStyle * | GetFillStyle () const
Call this function to get the background fill style.
void | DoPropExchange (CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
int | GetTransparency () const
Call this function to get the transparency of the filled area with respect to the background.
void | SetTransparency (int nTransparency)
Call this function to set the transparency of the filled area with respect to the background.
BOOL | GetFillAcrossXAxis () const
Call this function to get the fill chart area indicator with respect to the background.
void | SetFillAcrossXAxis (BOOL nFillAcrossXAxis)
Call this function to set the fill chart area indicator with respect to the background.
- Public Member Functions inherited from CXTPChartPointSeriesStyle
CXTPChartPointSeriesStyle ()
Constructs a CXTPChartPointSeriesStyle object.
virtual | ~CXTPChartPointSeriesStyle ()
Destroys a CXTPChartPointSeriesStyle object, handles cleanup.
CXTPChartMarker * | GetMarker () const
Call this function to get the marker object associated with this CXTPChartPointSeriesStyle object.
void | DoPropExchange (CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
- Public Member Functions inherited from CXTPChartDiagram2DSeriesStyle
CXTPChartDiagram2DSeriesStyle ()
Constructs a CXTPChartDiagram2DSeriesStyle object.
virtual | ~CXTPChartDiagram2DSeriesStyle ()
Destroys a CXTPChartDiagram2DSeriesStyle object, handles cleanup.
virtual CXTPChartDiagram * | CreateDiagram ()
Call this function to create the diagram for this series.
virtual BOOL | IsStyleDiagram (CXTPChartDiagram *pDiagram) const
Call this function to check whether the chart diagram object passed is a kind of 2D diagram (CXTPChartDiagram2D object).
- Public Member Functions inherited from CXTPChartSeriesStyle
CXTPChartSeriesStyle ()
Constructs a CXTPChartSeriesStyle object.
virtual | ~CXTPChartSeriesStyle ()
Destroys a CXTPChartSeriesStyle object, handles cleanup.
virtual CXTPChartSeriesLabel * | GetLabel () const
Call this method to gets the series label object.
virtual CXTPChartSeriesLabel * | SetLabel (CXTPChartSeriesLabel *pLabel)
Call this method to sets the series label object.
virtual CXTPChartErrorBar * | GetErrorBar () const
Call this method to gets the error bar object.
virtual CXTPChartErrorBar * | SetErrorBar (CXTPChartErrorBar *pErrorBar)
Call this method to sets the error bar object.
virtual CXTPChartColor | GetColor () const
Call this method to get the color of the series.
virtual void | SetColor (CXTPChartColor clr)
Call this method to set the color of the series.
virtual void | SetColorEach (BOOL bColorEach)
Call this method to set individual color for each point of the series.
virtual BOOL | IsColorEach () const
This method is called to check if individual color is used for each point of the series.
virtual CXTPChart3dRotation | Get3dRotation () const
Obtains rotation parameters for 3D chart.
virtual void | Set3dRotation (const CXTPChart3dRotation &rotation)
Sets rotation parameters for 3D chart.
virtual void | Set3dRotation (double dYaw, double dPitch, double dRoll)
Sets rotation parameters for 3D chart.
virtual BOOL | Is3dEdgeSmoothingEnabled () const
Enables/disables 3D edge smoothing.
virtual void | Enable3dEdgeSmoothing (BOOL bEnable=TRUE)
Enables/disables 3D edge smoothing.
virtual void | CorrectAxisSideMargins (CXTPChartAxis *pAxis, double nMinValue, double nMaxValue, double &nCorrection)
Provides default implementation for axis side margins correction.
virtual CXTPChartSeriesStyleAppearance * | GetStyleAppearance () const
Obtains associated style appearance pointer.
virtual void | ApplyTo (CXTPChartDeviceCommand *pCommand)
Applies the style to the command provided in case the command needs style specific details for correct drawing.
virtual int | GetSeriesPointValueIndex () const
Obtains the index of a point element for which an internal value can be otained.
- Public Member Functions inherited from CXTPChartElement
CXTPChartElement ()
Constructs a CXTPChartElement object.
virtual | ~CXTPChartElement ()
Destroys a CXTPChartElement object, handles cleanup.
virtual void | Release ()
Call this function to decrease the usage count of the object.
CXTPChartElement * | GetOwner () const
Call this function to get the owner element.
virtual void | OnChartChanged (XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic properties of the chart.
CXTPChartContent * | GetContent () const
Call this virtual function to get the chart content object.
CXTPChartAppearance * | GetAppearance () const
Call this function to get the the appearance of the chart.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Protected Member Functions

virtual CXTPChartSeriesView * CreateView (CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Use this function to create a spline area series view object.
- Protected Member Functions inherited from CXTPChartAreaSeriesStyle
- Protected Member Functions inherited from CXTPChartPointSeriesStyle
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.

Additional Inherited Members

- Public Attributes inherited from CXTPChartElement
- Protected Attributes inherited from CXTPChartAreaSeriesStyle
int | m_nTransparency
The transparency values range from 0 to 255.
CXTPChartBorder * | m_pBorder
The chart border object pointer.
CXTPChartFillStyle * | m_pFillStyle
The chart background fill style.
BOOL | m_nFillAcrossXAxis
Fill chart area across X axis (under and over X axis)
- Protected Attributes inherited from CXTPChartPointSeriesStyle
- Protected Attributes inherited from CXTPChartDiagram2DSeriesStyle
int | m_nAxisIndexX
Holds index of secondary axisX, used when m_bSecondaryAxisX is TRUE.
int | m_nAxisIndexY
Holds index of secondary axisY, used when m_bSecondaryAxisY is TRUE.
- Protected Attributes inherited from CXTPChartSeriesStyle
CXTPChartSeriesLabel * | m_pLabel
Label object.
CXTPChartErrorBar * | m_pErrorBar
Error bar object.
CXTPChartColor | m_clrColor
Custom color of series.
BOOL | m_bColorEach
TRUE to color each point.
int | m_nTransparency
The transparency value in the range 0..255.
CXTPChart3dRotation | m_Rotation3d
3D rotation
BOOL | m_bSmooth3dEdges
3D edge smoothing
- Protected Attributes inherited from CXTPChartElement

Detailed Description

This class represents a spline area series style, which is a kind of CXTPChartAreaSeriesStyle.

Spline area series displays graphically the quantitative data in a chart. It displays a series as a set of points connected by a spline with all the area filled in below the line.

Member Function Documentation

◆ CreateView()

virtual CXTPChartSeriesView * CreateView | ( | CXTPChartSeries * | pSeries,
 |  | CXTPChartDiagramView * | pDiagramView )
 protectedvirtual

Use this function to create a spline area series view object.

Parameters
pSeries | Pointer to a chart series object.
pDiagramView | Pointer to a chart diagram view object.
Returns
A pointer to CXTPChartSeriesView which refers to the newly created CXTPChartSplineAreaSeriesView object.

CXTPChartSplineAreaSeriesView class abstracts the view of a spine area series.

Reimplemented from CXTPChartAreaSeriesStyle.

The documentation for this class was generated from the following file:
  • XTPChartSplineAreaSeriesStyle.h


Toolkit Pro: CXTPChartSplineAreaSeriesView Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPChartSplineAreaSeriesView Class Reference

CXTPChartSplineAreaSeriesView is a kind of CXTPChartSeriesView. More...

Inheritance diagram for CXTPChartSplineAreaSeriesView:
[legend]

Public Member Functions

CXTPChartSplineAreaSeriesView (CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Constructs a CXTPChartSplineAreaSeriesView object.
- Public Member Functions inherited from CXTPChartAreaSeriesView
CXTPChartAreaSeriesView (CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Constructs a CXTPChartAreaSeriesView object.

Protected Member Functions

CXTPChartSeriesPointView * | CreateSeriesPointView (CXTPChartDeviceContext *pDC, CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Call this function to create a spline area series point view object.
virtual CXTPChartDeviceCommand * | CreateDeviceCommand (CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
- Protected Member Functions inherited from CXTPChartAreaSeriesView
CXTPChartSeriesPointView * | CreateSeriesPointView (CXTPChartDeviceContext *pDC, CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Call this function to create a chart area series point view object.
CXTPChartColor | GetActualColor () const
Call this function to get the actual color of the series.
CXTPChartColor | GetActualColor2 () const
Call this function to get the second actual color of the series.
CXTPChartColor | GetBorderActualColor () const
Call this function to get the actual color of the series border.
virtual CXTPChartDeviceCommand * | CreateLegendDeviceCommand (CXTPChartDeviceContext *pDC, CRect rcBounds)
This function creates a label view drawing command object.

Detailed Description

CXTPChartSplineAreaSeriesView is a kind of CXTPChartSeriesView.

This class represents the view of the area series of a chart.

Spline area series displays graphically the quantitative data in a chart. It displays a series as a set of points connected by a spline with all the area filled in below the line.

Constructor & Destructor Documentation

◆ CXTPChartSplineAreaSeriesView()

CXTPChartSplineAreaSeriesView | ( | CXTPChartSeries * | pSeries,
 |  | CXTPChartDiagramView * | pDiagramView )

Constructs a CXTPChartSplineAreaSeriesView object.

Parameters
pSeries | Pointer to a chart series object.
pDiagramView | Pointer to a chart diagram view object.

Member Function Documentation

◆ CreateDeviceCommand()

virtual CXTPChartDeviceCommand * CreateDeviceCommand ( CXTPChartDeviceContext * pDC )
protectedvirtual

This function creates a CXTPChartDeviceCommand object.

This object represents the rendering of a spline area series in the chart.

Parameters
pDC Pointer to a CXTPChartDeviceContext object.
Returns
A CXTPChartDeviceCommand object. This polymorphic object handles the rendering of an element in the chart. Here it handles the drawing of the spline area series of the chart.

Reimplemented from CXTPChartAreaSeriesView.

◆ CreateSeriesPointView()

CXTPChartSeriesPointView * CreateSeriesPointView | ( | CXTPChartDeviceContext * | pDC,
 |  | CXTPChartSeriesPoint * | pPoint,
 |  | CXTPChartElementView * | pParentView )
 protected

Call this function to create a spline area series point view object.

Parameters
pDC | Pointer to a chart device context object.
pPoint | Pointer to a chart series object.
pParentView | The parent view of the axis.
Returns
A pointer to CXTPChartSeriesPointView which refers to the newly created CXTPChartPointSeriesPointView object.

CXTPChartSeriesPointView object abstracts the view of a point in a series.

The documentation for this class was generated from the following file:
  • XTPChartSplineAreaSeriesStyle.h


Toolkit Pro: CXTPChartSplineDeviceCommand Class Reference

Protected Member Functions | Protected Attributes | List of all members
CXTPChartSplineDeviceCommand Class Reference

Provides an interface for 2D spline drawing device command. More...

Inheritance diagram for CXTPChartSplineDeviceCommand:
[legend]

Protected Member Functions

CXTPChartSplineDeviceCommand (const CXTPChartPoints &p, int thickness)
Constructs a CXTPChartSplineDeviceCommand object.
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.
- Protected Member Functions inherited from CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents >
CXTPObservable ()
Constructs an observable object.
~CXTPObservable ()
Handles observable object destruction.

Protected Attributes

CXTPChartPoints | m_p
A collection of spline points.
int | m_nThickness
Line thickness in pixels.
- Protected Attributes inherited from CXTPChartDeviceCommand
CArray< CXTPChartDeviceCommand *, CXTPChartDeviceCommand * > | m_arrChildren
< The array of child device commands.

Additional Inherited Members

- Public Member Functions inherited from CXTPChartDeviceCommand
CXTPChartDeviceCommand ()
Constructs a CXTPChartDeviceCommand object.
virtual | ~CXTPChartDeviceCommand ()
Destroys a CXTPChartDeviceCommand object, handles cleanup.
BOOL | IsCommitted () const
Determines if the execution of the command has been committed.
void | Commit ()
Commits the execution of the command.
int | GetChildCommandCount () const
Obtains the number of immediate children commands.
CXTPChartDeviceCommand * | GetChildCommand (int nIndex) const
Obtains immediate child command point by index.
CXTPChartDeviceCommand * | AddChildCommand (CXTPChartDeviceCommand *pCommand)
Call this function to add a child device command.
virtual void | Execute (CXTPChartDeviceContext *pDC)
Call this function to execute the drawing.
virtual void | BeforeExecute (CXTPChartDeviceContext *pDC)
This method gets called before a command is executed which allows for the customization of command behavior.
virtual void | AfterExecute (CXTPChartDeviceContext *pDC)
This method gets called after a command is executed which allows for the customization of command behavior.
virtual void | ExecuteOverride (CXTPChartDeviceContext *pDC)
Override this function to write the drawing code for specific objects.
UINT | GetPassNumber () const
Get the number of executions made by the command.
virtual CXTPChartElement * | HitTest (CPoint point, CXTPChartElement *pParent) const
Performs recursive hit testing of the element at the specified point.
virtual void | ApplySeriesStyle (CXTPChartSeriesStyle *pStyle)
Applies series style to the current element.
virtual void | Prepare (CXTPChartDeviceContext *pDC)
Performs inital preparation steps necessary for successful command execution.
virtual void | PrepareOverride (CXTPChartDeviceContext *pDC)
Derived implementation must override this method for implementing implementation specific preparation behavior.
virtual BOOL | IsEnabled () const
Determines if the command is currently enabled.
void | SetEnabled (BOOL bEnabled=TRUE)
Enables/disable the command.
CXTPChartDeviceContext * | GetCurrentDC () const
Obtains device context pointer for which the command is currenly being prepared or executed.
void | BindView (CXTPChartElementView *pView)
Binds a view to the command object.
CXTPChartElementView * | GetBoundView () const
Obtains a bound view pointer or NULL if no view is bound.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.
- Public Member Functions inherited from CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents >
void | Subscribe (CXTPChartDeviceCommandEvents *pObserver, CXTPSubscriptionList< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > *pSubcriptionList=NULL)
Subscribes a unique observer for events.
void | Unsubscribe (CXTPChartDeviceCommandEvents *pObserver)
Unsubscribes an observer from events.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *))
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *))
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.

Detailed Description

Provides an interface for 2D spline drawing device command.

Constructor & Destructor Documentation

◆ CXTPChartSplineDeviceCommand()

CXTPChartSplineDeviceCommand | ( | const CXTPChartPoints & | p,
 |  | int | thickness )
 protected

Constructs a CXTPChartSplineDeviceCommand object.

Parameters
p | A collection of spline points.
thickness | Line thickness in pixels.
The documentation for this class was generated from the following file:
  • XTPChartLineDeviceCommand.h


Toolkit Pro: CXTPChartSplineSeriesStyle Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPChartSplineSeriesStyle Class Reference

This class represents the spline series style in the chart. More...

Inheritance diagram for CXTPChartSplineSeriesStyle:
[legend]

Public Member Functions

CXTPChartSplineSeriesStyle ()
Constructs a CXTPChartSplineSeriesStyle object.
virtual | ~CXTPChartSplineSeriesStyle ()
Destroys a CXTPChartSplineSeriesStyle object, handles cleanup.
- Public Member Functions inherited from CXTPChartLineSeriesStyle
CXTPChartLineSeriesStyle ()
Constructs a CXTPChartLineSeriesStyle object.
virtual | ~CXTPChartLineSeriesStyle ()
Destroys a CXTPChartLineSeriesStyle object, handles cleanup.
CXTPChartLineStyle * | GetLineStyle () const
Call this function to get the line style of the line series.
- Public Member Functions inherited from CXTPChartPointSeriesStyle
CXTPChartPointSeriesStyle ()
Constructs a CXTPChartPointSeriesStyle object.
virtual | ~CXTPChartPointSeriesStyle ()
Destroys a CXTPChartPointSeriesStyle object, handles cleanup.
CXTPChartMarker * | GetMarker () const
Call this function to get the marker object associated with this CXTPChartPointSeriesStyle object.
void | DoPropExchange (CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
- Public Member Functions inherited from CXTPChartDiagram2DSeriesStyle
CXTPChartDiagram2DSeriesStyle ()
Constructs a CXTPChartDiagram2DSeriesStyle object.
virtual | ~CXTPChartDiagram2DSeriesStyle ()
Destroys a CXTPChartDiagram2DSeriesStyle object, handles cleanup.
virtual CXTPChartDiagram * | CreateDiagram ()
Call this function to create the diagram for this series.
virtual BOOL | IsStyleDiagram (CXTPChartDiagram *pDiagram) const
Call this function to check whether the chart diagram object passed is a kind of 2D diagram (CXTPChartDiagram2D object).
- Public Member Functions inherited from CXTPChartSeriesStyle
CXTPChartSeriesStyle ()
Constructs a CXTPChartSeriesStyle object.
virtual | ~CXTPChartSeriesStyle ()
Destroys a CXTPChartSeriesStyle object, handles cleanup.
virtual CXTPChartSeriesLabel * | GetLabel () const
Call this method to gets the series label object.
virtual CXTPChartSeriesLabel * | SetLabel (CXTPChartSeriesLabel *pLabel)
Call this method to sets the series label object.
virtual CXTPChartErrorBar * | GetErrorBar () const
Call this method to gets the error bar object.
virtual CXTPChartErrorBar * | SetErrorBar (CXTPChartErrorBar *pErrorBar)
Call this method to sets the error bar object.
virtual CXTPChartColor | GetColor () const
Call this method to get the color of the series.
virtual void | SetColor (CXTPChartColor clr)
Call this method to set the color of the series.
virtual void | SetColorEach (BOOL bColorEach)
Call this method to set individual color for each point of the series.
virtual BOOL | IsColorEach () const
This method is called to check if individual color is used for each point of the series.
virtual CXTPChart3dRotation | Get3dRotation () const
Obtains rotation parameters for 3D chart.
virtual void | Set3dRotation (const CXTPChart3dRotation &rotation)
Sets rotation parameters for 3D chart.
virtual void | Set3dRotation (double dYaw, double dPitch, double dRoll)
Sets rotation parameters for 3D chart.
virtual BOOL | Is3dEdgeSmoothingEnabled () const
Enables/disables 3D edge smoothing.
virtual void | Enable3dEdgeSmoothing (BOOL bEnable=TRUE)
Enables/disables 3D edge smoothing.
virtual int | GetTransparency () const
Call this function to gets the transparency of the chart if it is supported by the chart type.
virtual void | SetTransparency (int nTransparency)
Call this function to sets the transparency of the chart if it is supported by the chart type.
virtual void | CorrectAxisSideMargins (CXTPChartAxis *pAxis, double nMinValue, double nMaxValue, double &nCorrection)
Provides default implementation for axis side margins correction.
virtual CXTPChartSeriesStyleAppearance * | GetStyleAppearance () const
Obtains associated style appearance pointer.
virtual void | ApplyTo (CXTPChartDeviceCommand *pCommand)
Applies the style to the command provided in case the command needs style specific details for correct drawing.
virtual int | GetSeriesPointValueIndex () const
Obtains the index of a point element for which an internal value can be otained.
- Public Member Functions inherited from CXTPChartElement
CXTPChartElement ()
Constructs a CXTPChartElement object.
virtual | ~CXTPChartElement ()
Destroys a CXTPChartElement object, handles cleanup.
virtual void | Release ()
Call this function to decrease the usage count of the object.
CXTPChartElement * | GetOwner () const
Call this function to get the owner element.
virtual void | OnChartChanged (XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic properties of the chart.
CXTPChartContent * | GetContent () const
Call this virtual function to get the chart content object.
CXTPChartAppearance * | GetAppearance () const
Call this function to get the the appearance of the chart.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Protected Member Functions

virtual CXTPChartSeriesView * | CreateView (CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Call this function to create a view of the spline series.
- Protected Member Functions inherited from CXTPChartLineSeriesStyle
void | DoPropExchange (CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
- Protected Member Functions inherited from CXTPChartPointSeriesStyle
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.

Additional Inherited Members

- Public Attributes inherited from CXTPChartElement
- Protected Attributes inherited from CXTPChartLineSeriesStyle
CXTPChartLineStyle * | m_pLineStyle
The line style.
- Protected Attributes inherited from CXTPChartPointSeriesStyle
- Protected Attributes inherited from CXTPChartDiagram2DSeriesStyle
int | m_nAxisIndexX
Holds index of secondary axisX, used when m_bSecondaryAxisX is TRUE.
int | m_nAxisIndexY
Holds index of secondary axisY, used when m_bSecondaryAxisY is TRUE.
- Protected Attributes inherited from CXTPChartSeriesStyle
CXTPChartSeriesLabel * | m_pLabel
Label object.
CXTPChartErrorBar * | m_pErrorBar
Error bar object.
CXTPChartColor | m_clrColor
Custom color of series.
BOOL | m_bColorEach
TRUE to color each point.
int | m_nTransparency
The transparency value in the range 0..255.
CXTPChart3dRotation | m_Rotation3d
3D rotation
BOOL | m_bSmooth3dEdges
3D edge smoothing
- Protected Attributes inherited from CXTPChartElement

Detailed Description

This class represents the spline series style in the chart.

Objects of this class are a kind of point series style of a chart.

Member Function Documentation

◆ CreateView()

virtual CXTPChartSeriesView * CreateView | ( | CXTPChartSeries * | pSeries,
 |  | CXTPChartDiagramView * | pDiagramView )
 protectedvirtual

Call this function to create a view of the spline series.

Parameters
pSeries | A pointer to the chart series object.
pDiagramView | A pointer to the diagram view object.
Returns
Returns a pointer to the associated series view object.

Reimplemented from CXTPChartLineSeriesStyle.

The documentation for this class was generated from the following file:
  • XTPChartSplineSeriesStyle.h


Toolkit Pro: CXTPChartSplineSeriesView Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPChartSplineSeriesView Class Reference

This class represents the view of a spline series, which is a kind of CXTPChartSeriesView. More...

Inheritance diagram for CXTPChartSplineSeriesView:
[legend]

Public Member Functions

CXTPChartSplineSeriesView (CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Constructs a CXTPChartSplineSeriesView object.
- Public Member Functions inherited from CXTPChartLineSeriesView
CXTPChartLineSeriesView (CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView, BOOL bSortPoints=TRUE)
Constructs a CXTPChartLineSeriesView object.

Protected Member Functions

CXTPChartSeriesPointView * | CreateSeriesPointView (CXTPChartDeviceContext *pDC, CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Call this function to create a view of the spline series point.
virtual CXTPChartDeviceCommand * | CreateDeviceCommand (CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
- Protected Member Functions inherited from CXTPChartLineSeriesView
CXTPChartSeriesPointView * | CreateSeriesPointView (CXTPChartDeviceContext *pDC, CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Call this function to create a view of the line series point.
virtual CXTPChartDeviceCommand * | CreateLegendDeviceCommand (CXTPChartDeviceContext *pDC, CRect rcBounds)
This function creates a label view drawing command object.

Detailed Description

This class represents the view of a spline series, which is a kind of CXTPChartSeriesView.

Constructor & Destructor Documentation

◆ CXTPChartSplineSeriesView()

CXTPChartSplineSeriesView | ( | CXTPChartSeries * | pSeries,
 |  | CXTPChartDiagramView * | pDiagramView )

Constructs a CXTPChartSplineSeriesView object.

Parameters
pSeries | A pointer to the chart series object.
pDiagramView | A pointer to the diagram view object.

Member Function Documentation

◆ CreateDeviceCommand()

virtual CXTPChartDeviceCommand * CreateDeviceCommand ( CXTPChartDeviceContext * pDC )
protectedvirtual

This function creates a CXTPChartDeviceCommand object.

This object represents the rendering of a spline series.

Parameters
pDC Pointer to a CXTPChartDeviceContext object.
Returns
Returns a CXTPChartDeviceCommand object. This object handles the rendering of an element in the chart. Here it handles the drawing of the spline series.

Reimplemented from CXTPChartLineSeriesView.

◆ CreateSeriesPointView()

CXTPChartSeriesPointView * CreateSeriesPointView | ( | CXTPChartDeviceContext * | pDC,
 |  | CXTPChartSeriesPoint * | pPoint,
 |  | CXTPChartElementView * | pParentView )
 protected

Call this function to create a view of the spline series point.

Parameters
pDC | A pointer to the chart device context.
pPoint | A pointer to the chart series point object.
pParentView | The parent view of the axis.
Returns
Returns a pointer to the associated series point view object.
The documentation for this class was generated from the following file:
  • XTPChartSplineSeriesStyle.h


Toolkit Pro: CXTPChartStackedAreaSeriesStyle Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPChartStackedAreaSeriesStyle Class Reference

CXTPChartStackedAreaSeriesStyle is a CXTPChartAreaSeriesStyle derived class which represents the area series style. More...

Inheritance diagram for CXTPChartStackedAreaSeriesStyle:
[legend]

Public Member Functions

CXTPChartStackedAreaSeriesStyle ()
Constructs a CXTPChartStackedAreaSeriesStyle object.
virtual | ~CXTPChartStackedAreaSeriesStyle ()
Destroys a CXTPChartStackedAreaSeriesStyle object, handles cleanup.
- Public Member Functions inherited from CXTPChartAreaSeriesStyle
CXTPChartAreaSeriesStyle ()
Constructs a CXTPChartAreaSeriesStyle object.
virtual | ~CXTPChartAreaSeriesStyle ()
Destroys a CXTPChartAreaSeriesStyle object, handles cleanup.
CXTPChartFillStyle * | GetFillStyle () const
Call this function to get the background fill style.
void | DoPropExchange (CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
int | GetTransparency () const
Call this function to get the transparency of the filled area with respect to the background.
void | SetTransparency (int nTransparency)
Call this function to set the transparency of the filled area with respect to the background.
BOOL | GetFillAcrossXAxis () const
Call this function to get the fill chart area indicator with respect to the background.
void | SetFillAcrossXAxis (BOOL nFillAcrossXAxis)
Call this function to set the fill chart area indicator with respect to the background.
- Public Member Functions inherited from CXTPChartPointSeriesStyle
CXTPChartPointSeriesStyle ()
Constructs a CXTPChartPointSeriesStyle object.
virtual | ~CXTPChartPointSeriesStyle ()
Destroys a CXTPChartPointSeriesStyle object, handles cleanup.
CXTPChartMarker * | GetMarker () const
Call this function to get the marker object associated with this CXTPChartPointSeriesStyle object.
void | DoPropExchange (CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
- Public Member Functions inherited from CXTPChartDiagram2DSeriesStyle
CXTPChartDiagram2DSeriesStyle ()
Constructs a CXTPChartDiagram2DSeriesStyle object.
virtual | ~CXTPChartDiagram2DSeriesStyle ()
Destroys a CXTPChartDiagram2DSeriesStyle object, handles cleanup.
virtual CXTPChartDiagram * | CreateDiagram ()
Call this function to create the diagram for this series.
virtual BOOL | IsStyleDiagram (CXTPChartDiagram *pDiagram) const
Call this function to check whether the chart diagram object passed is a kind of 2D diagram (CXTPChartDiagram2D object).
- Public Member Functions inherited from CXTPChartSeriesStyle
CXTPChartSeriesStyle ()
Constructs a CXTPChartSeriesStyle object.
virtual | ~CXTPChartSeriesStyle ()
Destroys a CXTPChartSeriesStyle object, handles cleanup.
virtual CXTPChartSeriesLabel * | GetLabel () const
Call this method to gets the series label object.
virtual CXTPChartSeriesLabel * | SetLabel (CXTPChartSeriesLabel *pLabel)
Call this method to sets the series label object.
virtual CXTPChartErrorBar * | GetErrorBar () const
Call this method to gets the error bar object.
virtual CXTPChartErrorBar * | SetErrorBar (CXTPChartErrorBar *pErrorBar)
Call this method to sets the error bar object.
virtual CXTPChartColor | GetColor () const
Call this method to get the color of the series.
virtual void | SetColor (CXTPChartColor clr)
Call this method to set the color of the series.
virtual void | SetColorEach (BOOL bColorEach)
Call this method to set individual color for each point of the series.
virtual BOOL | IsColorEach () const
This method is called to check if individual color is used for each point of the series.
virtual CXTPChart3dRotation | Get3dRotation () const
Obtains rotation parameters for 3D chart.
virtual void | Set3dRotation (const CXTPChart3dRotation &rotation)
Sets rotation parameters for 3D chart.
virtual void | Set3dRotation (double dYaw, double dPitch, double dRoll)
Sets rotation parameters for 3D chart.
virtual BOOL | Is3dEdgeSmoothingEnabled () const
Enables/disables 3D edge smoothing.
virtual void | Enable3dEdgeSmoothing (BOOL bEnable=TRUE)
Enables/disables 3D edge smoothing.
virtual void | CorrectAxisSideMargins (CXTPChartAxis *pAxis, double nMinValue, double nMaxValue, double &nCorrection)
Provides default implementation for axis side margins correction.
virtual CXTPChartSeriesStyleAppearance * | GetStyleAppearance () const
Obtains associated style appearance pointer.
virtual void | ApplyTo (CXTPChartDeviceCommand *pCommand)
Applies the style to the command provided in case the command needs style specific details for correct drawing.
virtual int | GetSeriesPointValueIndex () const
Obtains the index of a point element for which an internal value can be otained.
- Public Member Functions inherited from CXTPChartElement
CXTPChartElement ()
Constructs a CXTPChartElement object.
virtual | ~CXTPChartElement ()
Destroys a CXTPChartElement object, handles cleanup.
virtual void | Release ()
Call this function to decrease the usage count of the object.
CXTPChartElement * | GetOwner () const
Call this function to get the owner element.
virtual void | OnChartChanged (XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic properties of the chart.
CXTPChartContent * | GetContent () const
Call this virtual function to get the chart content object.
CXTPChartAppearance * | GetAppearance () const
Call this function to get the the appearance of the chart.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Protected Member Functions

virtual CXTPChartSeriesView * CreateView (CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Use this function to create a chart series view object.
- Protected Member Functions inherited from CXTPChartAreaSeriesStyle
- Protected Member Functions inherited from CXTPChartPointSeriesStyle
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.

Additional Inherited Members

- Public Attributes inherited from CXTPChartElement
- Protected Attributes inherited from CXTPChartAreaSeriesStyle
int | m_nTransparency
The transparency values range from 0 to 255.
CXTPChartBorder * | m_pBorder
The chart border object pointer.
CXTPChartFillStyle * | m_pFillStyle
The chart background fill style.
BOOL | m_nFillAcrossXAxis
Fill chart area across X axis (under and over X axis)
- Protected Attributes inherited from CXTPChartPointSeriesStyle
- Protected Attributes inherited from CXTPChartDiagram2DSeriesStyle
int | m_nAxisIndexX
Holds index of secondary axisX, used when m_bSecondaryAxisX is TRUE.
int | m_nAxisIndexY
Holds index of secondary axisY, used when m_bSecondaryAxisY is TRUE.
- Protected Attributes inherited from CXTPChartSeriesStyle
CXTPChartSeriesLabel * | m_pLabel
Label object.
CXTPChartErrorBar * | m_pErrorBar
Error bar object.
CXTPChartColor | m_clrColor
Custom color of series.
BOOL | m_bColorEach
TRUE to color each point.
int | m_nTransparency
The transparency value in the range 0..255.
CXTPChart3dRotation | m_Rotation3d
3D rotation
BOOL | m_bSmooth3dEdges
3D edge smoothing
- Protected Attributes inherited from CXTPChartElement

Detailed Description

CXTPChartStackedAreaSeriesStyle is a CXTPChartAreaSeriesStyle derived class which represents the area series style.

Area series displays graphically the quantitative data in a chart. It displays a series as a set of points connected by a line or spline with all the area filled in below the line.

Member Function Documentation

◆ CreateView()

virtual CXTPChartSeriesView * CreateView | ( | CXTPChartSeries * | pSeries,
 |  | CXTPChartDiagramView * | pDiagramView )
 protectedvirtual

Use this function to create a chart series view object.

Parameters
pSeries | Pointer to a chart series object.
pDiagramView | Pointer to a chart diagram view object.
Returns
A pointer to the newly created CXTPChartSeriesView object.

CXTPChartSeriesView abstracts the view of a series.

Reimplemented from CXTPChartAreaSeriesStyle.

Reimplemented in CXTPChartStackedSplineAreaSeriesStyle.

The documentation for this class was generated from the following file:
  • XTPChartStackedAreaSeriesStyle.h


Toolkit Pro: CXTPChartStackedAreaSeriesView Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPChartStackedAreaSeriesView Class Reference

CXTPChartStackedAreaSeriesView is a kind of CXTPChartSeriesView. More...

Inheritance diagram for CXTPChartStackedAreaSeriesView:
[legend]

Public Member Functions

CXTPChartStackedAreaSeriesView (CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Constructs a CXTPChartStackedAreaSeriesView object.
- Public Member Functions inherited from CXTPChartAreaSeriesView
CXTPChartAreaSeriesView (CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Constructs a CXTPChartAreaSeriesView object.

Protected Member Functions

CXTPChartSeriesPointView * | CreateSeriesPointView (CXTPChartDeviceContext *pDC, CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Call this function to create a chart area series point view object.
virtual CXTPChartDeviceCommand * | CreateDeviceCommand (CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
- Protected Member Functions inherited from CXTPChartAreaSeriesView
CXTPChartSeriesPointView * | CreateSeriesPointView (CXTPChartDeviceContext *pDC, CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Call this function to create a chart area series point view object.
CXTPChartColor | GetActualColor () const
Call this function to get the actual color of the series.
CXTPChartColor | GetActualColor2 () const
Call this function to get the second actual color of the series.
CXTPChartColor | GetBorderActualColor () const
Call this function to get the actual color of the series border.
virtual CXTPChartDeviceCommand * | CreateLegendDeviceCommand (CXTPChartDeviceContext *pDC, CRect rcBounds)
This function creates a label view drawing command object.

Detailed Description

CXTPChartStackedAreaSeriesView is a kind of CXTPChartSeriesView.

This class represents the view of the area series of a chart.

Area series displays graphically the quantitative data in a chart. It displays a series as a set of points connected by a line or spline with all the area filled in below the line.

Constructor & Destructor Documentation

◆ CXTPChartStackedAreaSeriesView()

CXTPChartStackedAreaSeriesView | ( | CXTPChartSeries * | pSeries,
 |  | CXTPChartDiagramView * | pDiagramView )

Constructs a CXTPChartStackedAreaSeriesView object.

Parameters
pSeries | Pointer to a chart series object.
pDiagramView | Pointer to a chart diagram view object.

Member Function Documentation

◆ CreateDeviceCommand()

virtual CXTPChartDeviceCommand * CreateDeviceCommand ( CXTPChartDeviceContext * pDC )
protectedvirtual

This function creates a CXTPChartDeviceCommand object.

This object represents the rendering of an area series in the chart.

Parameters
pDC Pointer to a CXTPChartDeviceContext object.
Returns
Returns a CXTPChartDeviceCommand object. This polymorphic object handles the rendering of an element in the chart. Here it handles the drawing of the area series of the chart.

Reimplemented from CXTPChartAreaSeriesView.

Reimplemented in CXTPChartStackedSplineAreaSeriesView.

◆ CreateSeriesPointView()

CXTPChartSeriesPointView * CreateSeriesPointView | ( | CXTPChartDeviceContext * | pDC,
 |  | CXTPChartSeriesPoint * | pPoint,
 |  | CXTPChartElementView * | pParentView )
 protected

Call this function to create a chart area series point view object.

Parameters
pDC | Pointer to a chart device context object.
pPoint | Pointer to a chart series object.
pParentView | The parent view of the axis.
Returns
A pointer to CXTPChartSeriesPointView which refers to the newly created CXTPChartPointSeriesPointView object.

CXTPChartSeriesPointView object abstracts the view of a point in a series.

The documentation for this class was generated from the following file:
  • XTPChartStackedAreaSeriesStyle.h


Toolkit Pro: CXTPChartStackedBarSeriesPointView Class Reference

Public Member Functions | List of all members
CXTPChartStackedBarSeriesPointView Class Reference

This class represents the view of a bar series point, which is a kind of CXTPChartPointSeriesPointView. More...

Inheritance diagram for CXTPChartStackedBarSeriesPointView:
[legend]

Public Member Functions

CXTPChartStackedBarSeriesPointView (CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Constructs a CXTPChartStackedBarSeriesPointView object.
virtual CXTPChartDeviceCommand * | CreateDeviceCommand (CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
- Public Member Functions inherited from CXTPChartBarSeriesPointView
CXTPChartBarSeriesPointView (CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Constructs a CXTPChartBarSeriesPointView object.
virtual CXTPChartDeviceCommand * | CreateLegendDeviceCommand (CXTPChartDeviceContext *pDC, CRect rcBounds)
This function creates a label view drawing command object.
- Public Member Functions inherited from CXTPChartSeriesPointView
CXTPChartSeriesPointView (CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Constructs the view object.
CXTPChartSeriesPointView (CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView, BOOL bAddToParent)
Constructs the view object.
CXTPChartSeriesPoint * | GetPoint () const
Obtains point model object.
CXTPChartSeriesView * | GetSeriesView () const
Obtains parent series view.
CXTPChartColor | GetColor () const
Obtain view color values.
CXTPChartColor | GetColor2 () const
Obtain view color values.
double | GetInternalValue () const
Obtains point interval value.
virtual CXTPChartString | GetLegendName () const
This function returns the legend name.
virtual void | UpdateMinMaxRange (double &nMinValue, double &nMaxValue) const
Provides a default empty implementation for min/max range update request.
- Public Member Functions inherited from CXTPChartElementView
CXTPChartElementView (CXTPChartElementView *pParentView)
Constructs a CXTPChartElementView object.
CXTPChartElementView (CXTPChartElementView *pParentView, BOOL bAddToParent)
Constructs a CXTPChartElementView object.
CXTPChartElementView (CXTPChartContainer *pContainer)
Constructs a CXTPChartElementView object.
int | GetCount () const
Call this function to get the number of child views associated with this view.
CXTPChartElementView * | GetAt (int nIndex) const
Call this function to get a child view at a particular index.
CXTPChartElementView * | GetParentView () const
Call this function to get the parent view.
CXTPChartElementView * | AddChildView (CXTPChartElementView *pChildView)
Call this function to add a child view to the current view.
CXTPChartElementView ** GetChildren ()
Provides access to the collection of children elements owned by the view.
CRect | GetBounds () const
Obtains viewed object's bound rectangle.
CRect | GetBounds (BOOL bIncludingChildren) const
Obtains viewed object's bound rectangle.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.
- Public Member Functions inherited from CXTPChartLegendItemView
virtual | ~CXTPChartLegendItemView ()
Handles object destruction.

Additional Inherited Members

- Public Attributes inherited from CXTPChartSeriesPointView
double | m_dInternalValue
Point internal value.
- Protected Member Functions inherited from CXTPChartElementView
virtual | ~CXTPChartElementView ()
Destroys a CXTPChartElementView object, handles cleanup.
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.
- Protected Attributes inherited from CXTPChartSeriesPointView
CXTPChartSeriesPoint * | m_pPoint
Point model object pointer.
- Protected Attributes inherited from CXTPChartElementView
CArray< CXTPChartElementView *, CXTPChartElementView * > | m_arrChildren
The child view collection.
CXTPChartElementView * | m_pParentView
The parent view.
CXTPChartContainer * | m_pContainer
The parent container.
CRect | m_rcBounds
Bounding rectangle.

Detailed Description

This class represents the view of a bar series point, which is a kind of CXTPChartPointSeriesPointView.

Constructor & Destructor Documentation

◆ CXTPChartStackedBarSeriesPointView()

CXTPChartStackedBarSeriesPointView | ( | CXTPChartSeriesPoint * | pPoint,
 |  | CXTPChartElementView * | pParentView )

Constructs a CXTPChartStackedBarSeriesPointView object.

Parameters
pPoint | A pointer to the chart series point object.
pParentView | Parent view pointer.

Member Function Documentation

◆ CreateDeviceCommand()

virtual CXTPChartDeviceCommand * CreateDeviceCommand ( CXTPChartDeviceContext * pDC )
virtual

This function creates a CXTPChartDeviceCommand object.

This object represents the rendering of a bar series point.

Parameters
pDC Pointer to a CXTPChartDeviceContext object.
Returns
Returns a CXTPChartDeviceCommand object. This object handles the rendering of the bar series point.

Reimplemented from CXTPChartBarSeriesPointView.

The documentation for this class was generated from the following file:
  • XTPChartStackedBarSeriesStyle.h


Toolkit Pro: CXTPChartStackedBarSeriesStyle Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPChartStackedBarSeriesStyle Class Reference

This class represents a bar series style for the chart, which is a kind of CXTPChartSeriesStyle. More...

Inheritance diagram for CXTPChartStackedBarSeriesStyle:
[legend]

Public Member Functions

CXTPChartStackedBarSeriesStyle ()
Constructs a CXTPChartStackedBarSeriesStyle object.
virtual | ~CXTPChartStackedBarSeriesStyle ()
Destroys a CXTPChartStackedBarSeriesStyle object, handles cleanup.
void | DoPropExchange (CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
- Public Member Functions inherited from CXTPChartBarSeriesStyle
CXTPChartBarSeriesStyle ()
Constructs a CXTPChartBarSeriesStyle object.
virtual | ~CXTPChartBarSeriesStyle ()
Destroys a CXTPChartBarSeriesStyle object, handles cleanup.
double | GetBarWidth () const
Call this function to get the width of the bar.
void | SetBarWidth (double dWidth)
Call this function to set the width of the bar.
- Public Member Functions inherited from CXTPChartDiagram2DSeriesStyle
CXTPChartDiagram2DSeriesStyle ()
Constructs a CXTPChartDiagram2DSeriesStyle object.
virtual | ~CXTPChartDiagram2DSeriesStyle ()
Destroys a CXTPChartDiagram2DSeriesStyle object, handles cleanup.
virtual CXTPChartDiagram * | CreateDiagram ()
Call this function to create the diagram for this series.
virtual BOOL | IsStyleDiagram (CXTPChartDiagram *pDiagram) const
Call this function to check whether the chart diagram object passed is a kind of 2D diagram (CXTPChartDiagram2D object).
- Public Member Functions inherited from CXTPChartSeriesStyle
CXTPChartSeriesStyle ()
Constructs a CXTPChartSeriesStyle object.
virtual | ~CXTPChartSeriesStyle ()
Destroys a CXTPChartSeriesStyle object, handles cleanup.
virtual CXTPChartSeriesLabel * | GetLabel () const
Call this method to gets the series label object.
virtual CXTPChartSeriesLabel * | SetLabel (CXTPChartSeriesLabel *pLabel)
Call this method to sets the series label object.
virtual CXTPChartErrorBar * | GetErrorBar () const
Call this method to gets the error bar object.
virtual CXTPChartErrorBar * | SetErrorBar (CXTPChartErrorBar *pErrorBar)
Call this method to sets the error bar object.
virtual CXTPChartColor | GetColor () const
Call this method to get the color of the series.
virtual void | SetColor (CXTPChartColor clr)
Call this method to set the color of the series.
virtual void | SetColorEach (BOOL bColorEach)
Call this method to set individual color for each point of the series.
virtual BOOL | IsColorEach () const
This method is called to check if individual color is used for each point of the series.
virtual CXTPChart3dRotation | Get3dRotation () const
Obtains rotation parameters for 3D chart.
virtual void | Set3dRotation (const CXTPChart3dRotation &rotation)
Sets rotation parameters for 3D chart.
virtual void | Set3dRotation (double dYaw, double dPitch, double dRoll)
Sets rotation parameters for 3D chart.
virtual BOOL | Is3dEdgeSmoothingEnabled () const
Enables/disables 3D edge smoothing.
virtual void | Enable3dEdgeSmoothing (BOOL bEnable=TRUE)
Enables/disables 3D edge smoothing.
virtual int | GetTransparency () const
Call this function to gets the transparency of the chart if it is supported by the chart type.
virtual void | SetTransparency (int nTransparency)
Call this function to sets the transparency of the chart if it is supported by the chart type.
virtual CXTPChartSeriesStyleAppearance * | GetStyleAppearance () const
Obtains associated style appearance pointer.
virtual void | ApplyTo (CXTPChartDeviceCommand *pCommand)
Applies the style to the command provided in case the command needs style specific details for correct drawing.
virtual int | GetSeriesPointValueIndex () const
Obtains the index of a point element for which an internal value can be otained.
- Public Member Functions inherited from CXTPChartElement
CXTPChartElement ()
Constructs a CXTPChartElement object.
virtual | ~CXTPChartElement ()
Destroys a CXTPChartElement object, handles cleanup.
virtual void | Release ()
Call this function to decrease the usage count of the object.
CXTPChartElement * | GetOwner () const
Call this function to get the owner element.
virtual void | OnChartChanged (XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic properties of the chart.
CXTPChartContent * | GetContent () const
Call this virtual function to get the chart content object.
CXTPChartAppearance * | GetAppearance () const
Call this function to get the the appearance of the chart.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Protected Member Functions

virtual CXTPChartSeriesView * | CreateView (CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Call this function to create the view of the bar series.
virtual void | CorrectAxisSideMargins (CXTPChartAxis *pAxis, double nMinValue, double nMaxValue, double &nCorrection)
Call this function to correct the axis side margins.
- Protected Member Functions inherited from CXTPChartBarSeriesStyle
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.

Additional Inherited Members

- Public Attributes inherited from CXTPChartElement
- Protected Attributes inherited from CXTPChartBarSeriesStyle
- Protected Attributes inherited from CXTPChartDiagram2DSeriesStyle
int | m_nAxisIndexX
Holds index of secondary axisX, used when m_bSecondaryAxisX is TRUE.
int | m_nAxisIndexY
Holds index of secondary axisY, used when m_bSecondaryAxisY is TRUE.
- Protected Attributes inherited from CXTPChartSeriesStyle
CXTPChartSeriesLabel * | m_pLabel
Label object.
CXTPChartErrorBar * | m_pErrorBar
Error bar object.
CXTPChartColor | m_clrColor
Custom color of series.
BOOL | m_bColorEach
TRUE to color each point.
int | m_nTransparency
The transparency value in the range 0..255.
CXTPChart3dRotation | m_Rotation3d
3D rotation
BOOL | m_bSmooth3dEdges
3D edge smoothing
- Protected Attributes inherited from CXTPChartElement

Detailed Description

This class represents a bar series style for the chart, which is a kind of CXTPChartSeriesStyle.

A bar chart or bar graph is a chart with rectangular bars with lengths proportional to the values that they represent. Bar charts are used for comparing two or more values that were taken over time or on different conditions, usually on small data sets.

Member Function Documentation

◆ CorrectAxisSideMargins()

virtual void CorrectAxisSideMargins | ( | CXTPChartAxis * | pAxis,
 |  | double | nMinValue,
 |  | double | nMaxValue,
 |  | double & | nCorrection )
 protectedvirtual

Call this function to correct the axis side margins.

Parameters
pAxis | A pointer to the chart axis object, to which this object is associated with.
nMinValue | A double specifying the minimum value.
nMaxValue | A double specifying the maximum value.
nCorrection | A reference to a double object, which specifies the correction applied.

Reimplemented from CXTPChartBarSeriesStyle.

◆ CreateView()

virtual CXTPChartSeriesView * CreateView | ( | CXTPChartSeries * | pSeries,
 |  | CXTPChartDiagramView * | pDiagramView )
 protectedvirtual

Call this function to create the view of the bar series.

Parameters
pSeries | A pointer to the chart series object to which this object is associated with.
pDiagramView | A pointer to the chart diagram view object to which this object is associated with.
Returns
A pointer to CXTPChartSeriesView. Refers to the newly created CXTPChartStackedBarSeriesView object.

Reimplemented from CXTPChartBarSeriesStyle.

◆ DoPropExchange()

void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Reads this object from or writes this object to an archive.

Parameters
pPX A CXTPPropExchange object to serialize to or from.

Reimplemented from CXTPChartBarSeriesStyle.

The documentation for this class was generated from the following file:
  • XTPChartStackedBarSeriesStyle.h


Toolkit Pro: CXTPChartStackedBarSeriesView Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPChartStackedBarSeriesView Class Reference

This class represents the view of a bar series, which is a kind of CXTPChartSeriesView. More...

Inheritance diagram for CXTPChartStackedBarSeriesView:
[legend]

Public Member Functions

CXTPChartStackedBarSeriesView (CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Constructs a CXTPChartStackedBarSeriesView object.
- Public Member Functions inherited from CXTPChartBarSeriesView
CXTPChartBarSeriesView (CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Constructs a CXTPChartBarSeriesView object.

Protected Member Functions

CXTPChartSeriesPointView * | CreateSeriesPointView (CXTPChartDeviceContext *pDC, CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Call this function to create a view of the bar series point.
void | UpdateRange (CXTPChartDeviceContext *pDC)
Call this function to calculate the layout of the bar series.
- Protected Member Functions inherited from CXTPChartBarSeriesView
CXTPChartSeriesPointView * | CreateSeriesPointView (CXTPChartDeviceContext *pDC, CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Call this function to create a view of the bar series point.
void | BeforeUpdateRange (CXTPChartDeviceContext *pDC)
Call this function to calculate the layout of the bar series.
virtual CXTPChartDeviceCommand * | CreateLegendDeviceCommand (CXTPChartDeviceContext *pDC, CRect rcBounds)
This function creates a label view drawing command object.

Additional Inherited Members

- Protected Attributes inherited from CXTPChartBarSeriesView
int | m_nBarCount
The bar count in the series.
int | m_nBarIndex
The index of the bar series.

Detailed Description

This class represents the view of a bar series, which is a kind of CXTPChartSeriesView.

Constructor & Destructor Documentation

◆ CXTPChartStackedBarSeriesView()

CXTPChartStackedBarSeriesView | ( | CXTPChartSeries * | pSeries,
 |  | CXTPChartDiagramView * | pDiagramView )

Constructs a CXTPChartStackedBarSeriesView object.

Parameters
pSeries | A pointer to the chart series object.
pDiagramView | A pointer to the diagram view object.

Member Function Documentation

◆ CreateSeriesPointView()

CXTPChartSeriesPointView * CreateSeriesPointView | ( | CXTPChartDeviceContext * | pDC,
 |  | CXTPChartSeriesPoint * | pPoint,
 |  | CXTPChartElementView * | pParentView )
 protected

Call this function to create a view of the bar series point.

Parameters
pDC | A pointer to the chart device context.
pPoint | A pointer to the chart series point object.
pParentView | Parent view pointer.
Returns
A pointer to CXTPChartSeriesPointView, which refers to the newly created CXTPChartStackedBarSeriesPointView object.

◆ UpdateRange()

void UpdateRange ( CXTPChartDeviceContext * pDC )
protected

Call this function to calculate the layout of the bar series.

Parameters
pDC A pointer to the chart device context.
The documentation for this class was generated from the following file:
  • XTPChartStackedBarSeriesStyle.h


Toolkit Pro: CXTPChartStackedSplineAreaSeriesStyle Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPChartStackedSplineAreaSeriesStyle Class Reference

CXTPChartStackedSplineAreaSeriesStyle is a CXTPChartStackedAreaSeriesStyle derived class which represents the area series style. More...

Inheritance diagram for CXTPChartStackedSplineAreaSeriesStyle:
[legend]

Public Member Functions

CXTPChartStackedSplineAreaSeriesStyle ()
Constructs a CXTPChartStackedSplineAreaSeriesStyle object.
virtual | ~CXTPChartStackedSplineAreaSeriesStyle ()
Destroys a CXTPChartStackedSplineAreaSeriesStyle object, handles cleanup.
- Public Member Functions inherited from CXTPChartStackedAreaSeriesStyle
CXTPChartStackedAreaSeriesStyle ()
Constructs a CXTPChartStackedAreaSeriesStyle object.
virtual | ~CXTPChartStackedAreaSeriesStyle ()
Destroys a CXTPChartStackedAreaSeriesStyle object, handles cleanup.
- Public Member Functions inherited from CXTPChartAreaSeriesStyle
CXTPChartAreaSeriesStyle ()
Constructs a CXTPChartAreaSeriesStyle object.
virtual | ~CXTPChartAreaSeriesStyle ()
Destroys a CXTPChartAreaSeriesStyle object, handles cleanup.
CXTPChartFillStyle * | GetFillStyle () const
Call this function to get the background fill style.
void | DoPropExchange (CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
int | GetTransparency () const
Call this function to get the transparency of the filled area with respect to the background.
void | SetTransparency (int nTransparency)
Call this function to set the transparency of the filled area with respect to the background.
BOOL | GetFillAcrossXAxis () const
Call this function to get the fill chart area indicator with respect to the background.
void | SetFillAcrossXAxis (BOOL nFillAcrossXAxis)
Call this function to set the fill chart area indicator with respect to the background.
- Public Member Functions inherited from CXTPChartPointSeriesStyle
CXTPChartPointSeriesStyle ()
Constructs a CXTPChartPointSeriesStyle object.
virtual | ~CXTPChartPointSeriesStyle ()
Destroys a CXTPChartPointSeriesStyle object, handles cleanup.
CXTPChartMarker * | GetMarker () const
Call this function to get the marker object associated with this CXTPChartPointSeriesStyle object.
void | DoPropExchange (CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
- Public Member Functions inherited from CXTPChartDiagram2DSeriesStyle
CXTPChartDiagram2DSeriesStyle ()
Constructs a CXTPChartDiagram2DSeriesStyle object.
virtual | ~CXTPChartDiagram2DSeriesStyle ()
Destroys a CXTPChartDiagram2DSeriesStyle object, handles cleanup.
virtual CXTPChartDiagram * | CreateDiagram ()
Call this function to create the diagram for this series.
virtual BOOL | IsStyleDiagram (CXTPChartDiagram *pDiagram) const
Call this function to check whether the chart diagram object passed is a kind of 2D diagram (CXTPChartDiagram2D object).
- Public Member Functions inherited from CXTPChartSeriesStyle
CXTPChartSeriesStyle ()
Constructs a CXTPChartSeriesStyle object.
virtual | ~CXTPChartSeriesStyle ()
Destroys a CXTPChartSeriesStyle object, handles cleanup.
virtual CXTPChartSeriesLabel * | GetLabel () const
Call this method to gets the series label object.
virtual CXTPChartSeriesLabel * | SetLabel (CXTPChartSeriesLabel *pLabel)
Call this method to sets the series label object.
virtual CXTPChartErrorBar * | GetErrorBar () const
Call this method to gets the error bar object.
virtual CXTPChartErrorBar * | SetErrorBar (CXTPChartErrorBar *pErrorBar)
Call this method to sets the error bar object.
virtual CXTPChartColor | GetColor () const
Call this method to get the color of the series.
virtual void | SetColor (CXTPChartColor clr)
Call this method to set the color of the series.
virtual void | SetColorEach (BOOL bColorEach)
Call this method to set individual color for each point of the series.
virtual BOOL | IsColorEach () const
This method is called to check if individual color is used for each point of the series.
virtual CXTPChart3dRotation | Get3dRotation () const
Obtains rotation parameters for 3D chart.
virtual void | Set3dRotation (const CXTPChart3dRotation &rotation)
Sets rotation parameters for 3D chart.
virtual void | Set3dRotation (double dYaw, double dPitch, double dRoll)
Sets rotation parameters for 3D chart.
virtual BOOL | Is3dEdgeSmoothingEnabled () const
Enables/disables 3D edge smoothing.
virtual void | Enable3dEdgeSmoothing (BOOL bEnable=TRUE)
Enables/disables 3D edge smoothing.
virtual void | CorrectAxisSideMargins (CXTPChartAxis *pAxis, double nMinValue, double nMaxValue, double &nCorrection)
Provides default implementation for axis side margins correction.
virtual CXTPChartSeriesStyleAppearance * | GetStyleAppearance () const
Obtains associated style appearance pointer.
virtual void | ApplyTo (CXTPChartDeviceCommand *pCommand)
Applies the style to the command provided in case the command needs style specific details for correct drawing.
virtual int | GetSeriesPointValueIndex () const
Obtains the index of a point element for which an internal value can be otained.
- Public Member Functions inherited from CXTPChartElement
CXTPChartElement ()
Constructs a CXTPChartElement object.
virtual | ~CXTPChartElement ()
Destroys a CXTPChartElement object, handles cleanup.
virtual void | Release ()
Call this function to decrease the usage count of the object.
CXTPChartElement * | GetOwner () const
Call this function to get the owner element.
virtual void | OnChartChanged (XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic properties of the chart.
CXTPChartContent * | GetContent () const
Call this virtual function to get the chart content object.
CXTPChartAppearance * | GetAppearance () const
Call this function to get the the appearance of the chart.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Protected Member Functions

virtual CXTPChartSeriesView * CreateView (CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Use this function to create a chart series view object.
- Protected Member Functions inherited from CXTPChartStackedAreaSeriesStyle
- Protected Member Functions inherited from CXTPChartAreaSeriesStyle
- Protected Member Functions inherited from CXTPChartPointSeriesStyle
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.

Additional Inherited Members

- Public Attributes inherited from CXTPChartElement
- Protected Attributes inherited from CXTPChartStackedAreaSeriesStyle
- Protected Attributes inherited from CXTPChartAreaSeriesStyle
int | m_nTransparency
The transparency values range from 0 to 255.
CXTPChartBorder * | m_pBorder
The chart border object pointer.
CXTPChartFillStyle * | m_pFillStyle
The chart background fill style.
BOOL | m_nFillAcrossXAxis
Fill chart area across X axis (under and over X axis)
- Protected Attributes inherited from CXTPChartPointSeriesStyle
- Protected Attributes inherited from CXTPChartDiagram2DSeriesStyle
int | m_nAxisIndexX
Holds index of secondary axisX, used when m_bSecondaryAxisX is TRUE.
int | m_nAxisIndexY
Holds index of secondary axisY, used when m_bSecondaryAxisY is TRUE.
- Protected Attributes inherited from CXTPChartSeriesStyle
CXTPChartSeriesLabel * | m_pLabel
Label object.
CXTPChartErrorBar * | m_pErrorBar
Error bar object.
CXTPChartColor | m_clrColor
Custom color of series.
BOOL | m_bColorEach
TRUE to color each point.
int | m_nTransparency
The transparency value in the range 0..255.
CXTPChart3dRotation | m_Rotation3d
3D rotation
BOOL | m_bSmooth3dEdges
3D edge smoothing
- Protected Attributes inherited from CXTPChartElement

Detailed Description

CXTPChartStackedSplineAreaSeriesStyle is a CXTPChartStackedAreaSeriesStyle derived class which represents the area series style.

Area series displays graphically the quantitative data in a chart. It displays a series as a set of points connected by a line or spline with all the area filled in below the line.

Member Function Documentation

◆ CreateView()

virtual CXTPChartSeriesView * CreateView | ( | CXTPChartSeries * | pSeries,
 |  | CXTPChartDiagramView * | pDiagramView )
 protectedvirtual

Use this function to create a chart series view object.

Parameters
pSeries | Pointer to a chart series object.
pDiagramView | Pointer to a chart diagram view object.
Returns
A pointer to the newly created CXTPChartSeriesView object.

CXTPChartSeriesView abstracts the view of a series.

Reimplemented from CXTPChartStackedAreaSeriesStyle.

The documentation for this class was generated from the following file:
  • XTPChartStackedSplineAreaSeriesStyle.h


Toolkit Pro: CXTPChartStackedSplineAreaSeriesView Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPChartStackedSplineAreaSeriesView Class Reference

CXTPChartStackedSplineAreaSeriesView is a kind of CXTPChartSeriesView. More...

Inheritance diagram for CXTPChartStackedSplineAreaSeriesView:
[legend]

Public Member Functions

CXTPChartStackedSplineAreaSeriesView (CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Constructs a CXTPChartStackedSplineAreaSeriesView object.
- Public Member Functions inherited from CXTPChartStackedAreaSeriesView
CXTPChartStackedAreaSeriesView (CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Constructs a CXTPChartStackedAreaSeriesView object.
- Public Member Functions inherited from CXTPChartAreaSeriesView
CXTPChartAreaSeriesView (CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Constructs a CXTPChartAreaSeriesView object.

Protected Member Functions

virtual CXTPChartDeviceCommand * | CreateDeviceCommand (CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
- Protected Member Functions inherited from CXTPChartStackedAreaSeriesView
CXTPChartSeriesPointView * | CreateSeriesPointView (CXTPChartDeviceContext *pDC, CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Call this function to create a chart area series point view object.
- Protected Member Functions inherited from CXTPChartAreaSeriesView
CXTPChartSeriesPointView * | CreateSeriesPointView (CXTPChartDeviceContext *pDC, CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Call this function to create a chart area series point view object.
CXTPChartColor | GetActualColor () const
Call this function to get the actual color of the series.
CXTPChartColor | GetActualColor2 () const
Call this function to get the second actual color of the series.
CXTPChartColor | GetBorderActualColor () const
Call this function to get the actual color of the series border.
virtual CXTPChartDeviceCommand * | CreateLegendDeviceCommand (CXTPChartDeviceContext *pDC, CRect rcBounds)
This function creates a label view drawing command object.

Detailed Description

CXTPChartStackedSplineAreaSeriesView is a kind of CXTPChartSeriesView.

This class represents the view of the area series of a chart.

Area series displays graphically the quantitative data in a chart. It displays a series as a set of points connected by a line or spline with all the area filled in below the line.

Constructor & Destructor Documentation

◆ CXTPChartStackedSplineAreaSeriesView()

CXTPChartStackedSplineAreaSeriesView | ( | CXTPChartSeries * | pSeries,
 |  | CXTPChartDiagramView * | pDiagramView )

Constructs a CXTPChartStackedSplineAreaSeriesView object.

Parameters
pSeries | Pointer to a chart series object.
pDiagramView | Pointer to a chart diagram view object.

Member Function Documentation

◆ CreateDeviceCommand()

virtual CXTPChartDeviceCommand * CreateDeviceCommand ( CXTPChartDeviceContext * pDC )
protectedvirtual

This function creates a CXTPChartDeviceCommand object.

This object represents the rendering of an area series in the chart.

Parameters
pDC Pointer to a CXTPChartDeviceContext object.
Returns
Returns a CXTPChartDeviceCommand object. This polymorphic object handles the rendering of an element in the chart. Here it handles the drawing of the area series of the chart.

Reimplemented from CXTPChartStackedAreaSeriesView.

The documentation for this class was generated from the following file:
  • XTPChartStackedSplineAreaSeriesStyle.h


Toolkit Pro: CXTPChartStepAreaSeriesStyle Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPChartStepAreaSeriesStyle Class Reference

This class represents a StepArea series style, which is a kind of CXTPChartAreaSeriesStyle. More...

Inheritance diagram for CXTPChartStepAreaSeriesStyle:
[legend]

Public Member Functions

CXTPChartStepAreaSeriesStyle ()
Constructs a CXTPChartStepAreaSeriesStyle object.
virtual | ~CXTPChartStepAreaSeriesStyle ()
Destroys a CXTPChartStepAreaSeriesStyle object, handles cleanup.
- Public Member Functions inherited from CXTPChartAreaSeriesStyle
CXTPChartAreaSeriesStyle ()
Constructs a CXTPChartAreaSeriesStyle object.
virtual | ~CXTPChartAreaSeriesStyle ()
Destroys a CXTPChartAreaSeriesStyle object, handles cleanup.
CXTPChartFillStyle * | GetFillStyle () const
Call this function to get the background fill style.
int | GetTransparency () const
Call this function to get the transparency of the filled area with respect to the background.
void | SetTransparency (int nTransparency)
Call this function to set the transparency of the filled area with respect to the background.
BOOL | GetFillAcrossXAxis () const
Call this function to get the fill chart area indicator with respect to the background.
void | SetFillAcrossXAxis (BOOL nFillAcrossXAxis)
Call this function to set the fill chart area indicator with respect to the background.
- Public Member Functions inherited from CXTPChartPointSeriesStyle
CXTPChartPointSeriesStyle ()
Constructs a CXTPChartPointSeriesStyle object.
virtual | ~CXTPChartPointSeriesStyle ()
Destroys a CXTPChartPointSeriesStyle object, handles cleanup.
CXTPChartMarker * | GetMarker () const
Call this function to get the marker object associated with this CXTPChartPointSeriesStyle object.
- Public Member Functions inherited from CXTPChartDiagram2DSeriesStyle
CXTPChartDiagram2DSeriesStyle ()
Constructs a CXTPChartDiagram2DSeriesStyle object.
virtual | ~CXTPChartDiagram2DSeriesStyle ()
Destroys a CXTPChartDiagram2DSeriesStyle object, handles cleanup.
virtual CXTPChartDiagram * | CreateDiagram ()
Call this function to create the diagram for this series.
virtual BOOL | IsStyleDiagram (CXTPChartDiagram *pDiagram) const
Call this function to check whether the chart diagram object passed is a kind of 2D diagram (CXTPChartDiagram2D object).
- Public Member Functions inherited from CXTPChartSeriesStyle
CXTPChartSeriesStyle ()
Constructs a CXTPChartSeriesStyle object.
virtual | ~CXTPChartSeriesStyle ()
Destroys a CXTPChartSeriesStyle object, handles cleanup.
virtual CXTPChartSeriesLabel * | GetLabel () const
Call this method to gets the series label object.
virtual CXTPChartSeriesLabel * | SetLabel (CXTPChartSeriesLabel *pLabel)
Call this method to sets the series label object.
virtual CXTPChartErrorBar * | GetErrorBar () const
Call this method to gets the error bar object.
virtual CXTPChartErrorBar * | SetErrorBar (CXTPChartErrorBar *pErrorBar)
Call this method to sets the error bar object.
virtual CXTPChartColor | GetColor () const
Call this method to get the color of the series.
virtual void | SetColor (CXTPChartColor clr)
Call this method to set the color of the series.
virtual void | SetColorEach (BOOL bColorEach)
Call this method to set individual color for each point of the series.
virtual BOOL | IsColorEach () const
This method is called to check if individual color is used for each point of the series.
virtual CXTPChart3dRotation | Get3dRotation () const
Obtains rotation parameters for 3D chart.
virtual void | Set3dRotation (const CXTPChart3dRotation &rotation)
Sets rotation parameters for 3D chart.
virtual void | Set3dRotation (double dYaw, double dPitch, double dRoll)
Sets rotation parameters for 3D chart.
virtual BOOL | Is3dEdgeSmoothingEnabled () const
Enables/disables 3D edge smoothing.
virtual void | Enable3dEdgeSmoothing (BOOL bEnable=TRUE)
Enables/disables 3D edge smoothing.
virtual void | CorrectAxisSideMargins (CXTPChartAxis *pAxis, double nMinValue, double nMaxValue, double &nCorrection)
Provides default implementation for axis side margins correction.
virtual CXTPChartSeriesStyleAppearance * | GetStyleAppearance () const
Obtains associated style appearance pointer.
virtual void | ApplyTo (CXTPChartDeviceCommand *pCommand)
Applies the style to the command provided in case the command needs style specific details for correct drawing.
virtual int | GetSeriesPointValueIndex () const
Obtains the index of a point element for which an internal value can be otained.
- Public Member Functions inherited from CXTPChartElement
CXTPChartElement ()
Constructs a CXTPChartElement object.
virtual | ~CXTPChartElement ()
Destroys a CXTPChartElement object, handles cleanup.
virtual void | Release ()
Call this function to decrease the usage count of the object.
CXTPChartElement * | GetOwner () const
Call this function to get the owner element.
virtual void | OnChartChanged (XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic properties of the chart.
CXTPChartContent * | GetContent () const
Call this virtual function to get the chart content object.
CXTPChartAppearance * | GetAppearance () const
Call this function to get the the appearance of the chart.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Protected Member Functions

virtual CXTPChartSeriesView * | CreateView (CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Call this function to create a view of the StepArea series.
void | DoPropExchange (CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
- Protected Member Functions inherited from CXTPChartAreaSeriesStyle
- Protected Member Functions inherited from CXTPChartPointSeriesStyle
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.

Additional Inherited Members

- Public Attributes inherited from CXTPChartElement
- Protected Attributes inherited from CXTPChartAreaSeriesStyle
int | m_nTransparency
The transparency values range from 0 to 255.
CXTPChartBorder * | m_pBorder
The chart border object pointer.
CXTPChartFillStyle * | m_pFillStyle
The chart background fill style.
BOOL | m_nFillAcrossXAxis
Fill chart area across X axis (under and over X axis)
- Protected Attributes inherited from CXTPChartPointSeriesStyle
- Protected Attributes inherited from CXTPChartDiagram2DSeriesStyle
int | m_nAxisIndexX
Holds index of secondary axisX, used when m_bSecondaryAxisX is TRUE.
int | m_nAxisIndexY
Holds index of secondary axisY, used when m_bSecondaryAxisY is TRUE.
- Protected Attributes inherited from CXTPChartSeriesStyle
CXTPChartSeriesLabel * | m_pLabel
Label object.
CXTPChartErrorBar * | m_pErrorBar
Error bar object.
CXTPChartColor | m_clrColor
Custom color of series.
BOOL | m_bColorEach
TRUE to color each point.
int | m_nTransparency
The transparency value in the range 0..255.
CXTPChart3dRotation | m_Rotation3d
3D rotation
BOOL | m_bSmooth3dEdges
3D edge smoothing
- Protected Attributes inherited from CXTPChartElement

Detailed Description

This class represents a StepArea series style, which is a kind of CXTPChartAreaSeriesStyle.

A Step Line chart or StepArea graph is a type of graph which displays information as a series of data points connected by straight Step Line segments. It is a basic type of chart common in many fields.

Member Function Documentation

◆ CreateView()

virtual CXTPChartSeriesView * CreateView | ( | CXTPChartSeries * | pSeries,
 |  | CXTPChartDiagramView * | pDiagramView )
 protectedvirtual

Call this function to create a view of the StepArea series.

Parameters
pSeries | A pointer to chart series object.
pDiagramView | A pointer to the diagram view object.
Returns
A pointer to CXTPChartStepAreaSeriesView object which is a kind of CXTPChartSeriesView.

Reimplemented from CXTPChartAreaSeriesStyle.

◆ DoPropExchange()

void DoPropExchange ( CXTPPropExchange * pPX )
protectedvirtual

Reads this object from or writes this object to an archive.

Parameters
pPX A CXTPPropExchange object to serialize to or from.

Reimplemented from CXTPChartAreaSeriesStyle.

The documentation for this class was generated from the following file:
  • XTPChartStepAreaSeriesStyle.h


Toolkit Pro: CXTPChartStepAreaSeriesView Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPChartStepAreaSeriesView Class Reference

This class represents the view of a StepArea series, which is a kind of CXTPChartSeriesView. More...

Inheritance diagram for CXTPChartStepAreaSeriesView:
[legend]

Public Member Functions

CXTPChartStepAreaSeriesView (CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Constructs a CXTPChartStepAreaSeriesView object.
- Public Member Functions inherited from CXTPChartAreaSeriesView
CXTPChartAreaSeriesView (CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Constructs a CXTPChartAreaSeriesView object.

Protected Member Functions

virtual CXTPChartDeviceCommand * | CreateDeviceCommand (CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
- Protected Member Functions inherited from CXTPChartAreaSeriesView
CXTPChartSeriesPointView * | CreateSeriesPointView (CXTPChartDeviceContext *pDC, CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Call this function to create a chart area series point view object.
CXTPChartColor | GetActualColor () const
Call this function to get the actual color of the series.
CXTPChartColor | GetActualColor2 () const
Call this function to get the second actual color of the series.
CXTPChartColor | GetBorderActualColor () const
Call this function to get the actual color of the series border.
virtual CXTPChartDeviceCommand * | CreateLegendDeviceCommand (CXTPChartDeviceContext *pDC, CRect rcBounds)
This function creates a label view drawing command object.

Detailed Description

This class represents the view of a StepArea series, which is a kind of CXTPChartSeriesView.

Constructor & Destructor Documentation

◆ CXTPChartStepAreaSeriesView()

CXTPChartStepAreaSeriesView | ( | CXTPChartSeries * | pSeries,
 |  | CXTPChartDiagramView * | pDiagramView )

Constructs a CXTPChartStepAreaSeriesView object.

Parameters
pSeries | A pointer to the chart series object.
pDiagramView | A pointer to the diagram view object.

Member Function Documentation

◆ CreateDeviceCommand()

virtual CXTPChartDeviceCommand * CreateDeviceCommand ( CXTPChartDeviceContext * pDC )
protectedvirtual

This function creates a CXTPChartDeviceCommand object.

This object represents the rendering of a StepArea series.

Parameters
pDC Pointer to a CXTPChartDeviceContext object.
Returns
Returns a CXTPChartDeviceCommand object. This object handles the rendering of an element in the chart. Here it handles the drawing of the StepArea series.

Reimplemented from CXTPChartAreaSeriesView.

The documentation for this class was generated from the following file:
  • XTPChartStepAreaSeriesStyle.h


Toolkit Pro: CXTPChartStepLineSeriesPointView Class Reference

Public Member Functions | List of all members
CXTPChartStepLineSeriesPointView Class Reference

This class represents the view of a step line series point, which is a kind of CXTPChartSeriesPointView. More...

Inheritance diagram for CXTPChartStepLineSeriesPointView:
[legend]

Public Member Functions

CXTPChartStepLineSeriesPointView (CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Constructs a point view object.
virtual CXTPChartDeviceCommand * | CreateLegendDeviceCommand (CXTPChartDeviceContext *pDC, CRect rcBounds)
This function creates a label view drawing command object.
- Public Member Functions inherited from CXTPChartPointSeriesPointView
CXTPChartPointSeriesPointView (CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Constructs a CXTPChartPointSeriesPointView object.
virtual CXTPChartDeviceCommand * | CreateDeviceCommand (CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
CXTPChartPointF | GetScreenPoint () const
Call this function to get the screen point from the series point.
- Public Member Functions inherited from CXTPChartSeriesPointView
CXTPChartSeriesPointView (CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Constructs the view object.
CXTPChartSeriesPointView (CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView, BOOL bAddToParent)
Constructs the view object.
CXTPChartSeriesPoint * | GetPoint () const
Obtains point model object.
CXTPChartSeriesView * | GetSeriesView () const
Obtains parent series view.
CXTPChartColor | GetColor () const
Obtain view color values.
CXTPChartColor | GetColor2 () const
Obtain view color values.
double | GetInternalValue () const
Obtains point interval value.
virtual CXTPChartString | GetLegendName () const
This function returns the legend name.
virtual void | UpdateMinMaxRange (double &nMinValue, double &nMaxValue) const
Provides a default empty implementation for min/max range update request.
- Public Member Functions inherited from CXTPChartElementView
CXTPChartElementView (CXTPChartElementView *pParentView)
Constructs a CXTPChartElementView object.
CXTPChartElementView (CXTPChartElementView *pParentView, BOOL bAddToParent)
Constructs a CXTPChartElementView object.
CXTPChartElementView (CXTPChartContainer *pContainer)
Constructs a CXTPChartElementView object.
int | GetCount () const
Call this function to get the number of child views associated with this view.
CXTPChartElementView * | GetAt (int nIndex) const
Call this function to get a child view at a particular index.
CXTPChartElementView * | GetParentView () const
Call this function to get the parent view.
CXTPChartElementView * | AddChildView (CXTPChartElementView *pChildView)
Call this function to add a child view to the current view.
CXTPChartElementView ** GetChildren ()
Provides access to the collection of children elements owned by the view.
CRect | GetBounds () const
Obtains viewed object's bound rectangle.
CRect | GetBounds (BOOL bIncludingChildren) const
Obtains viewed object's bound rectangle.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.
- Public Member Functions inherited from CXTPChartLegendItemView
virtual | ~CXTPChartLegendItemView ()
Handles object destruction.

Additional Inherited Members

- Public Attributes inherited from CXTPChartSeriesPointView
double | m_dInternalValue
Point internal value.
- Protected Member Functions inherited from CXTPChartElementView
virtual | ~CXTPChartElementView ()
Destroys a CXTPChartElementView object, handles cleanup.
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.
- Protected Attributes inherited from CXTPChartSeriesPointView
CXTPChartSeriesPoint * | m_pPoint
Point model object pointer.
- Protected Attributes inherited from CXTPChartElementView
CArray< CXTPChartElementView *, CXTPChartElementView * > | m_arrChildren
The child view collection.
CXTPChartElementView * | m_pParentView
The parent view.
CXTPChartContainer * | m_pContainer
The parent container.
CRect | m_rcBounds
Bounding rectangle.

Detailed Description

This class represents the view of a step line series point, which is a kind of CXTPChartSeriesPointView.

Constructor & Destructor Documentation

◆ CXTPChartStepLineSeriesPointView()

CXTPChartStepLineSeriesPointView | ( | CXTPChartSeriesPoint * | pPoint,
 |  | CXTPChartElementView * | pParentView )

Constructs a point view object.

Parameters
pPoint | Associated point object pointer.
pParentView | Parent view object pointer.

Member Function Documentation

◆ CreateLegendDeviceCommand()

virtual CXTPChartDeviceCommand * CreateLegendDeviceCommand | ( | CXTPChartDeviceContext * | pDC,
 |  | CRect | rcBounds )
 virtual

This function creates a label view drawing command object.

Parameters
pDC | Pointer to a CXTPChartDeviceContext object.
rcBounds | The rectangular boundary of the legend.
Returns
Returns a new label view drawing command object.

Reimplemented from CXTPChartPointSeriesPointView.

The documentation for this class was generated from the following file:
  • XTPChartStepLineSeriesStyle.h


Toolkit Pro: CXTPChartStepLineSeriesStyle Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPChartStepLineSeriesStyle Class Reference

This class represents a StepLine series style, which is a kind of CXTPChartLineSeriesStyle. More...

Inheritance diagram for CXTPChartStepLineSeriesStyle:
[legend]

Public Member Functions

CXTPChartStepLineSeriesStyle ()
Constructs a CXTPChartStepLineSeriesStyle object.
virtual | ~CXTPChartStepLineSeriesStyle ()
Destroys a CXTPChartStepLineSeriesStyle object, handles cleanup.
BOOL | GetInvertedStep () const
Gets inverted step flag.
void | SetInvertedStep (BOOL bInvertedStep)
Sets inverted step flag.
- Public Member Functions inherited from CXTPChartLineSeriesStyle
CXTPChartLineSeriesStyle ()
Constructs a CXTPChartLineSeriesStyle object.
virtual | ~CXTPChartLineSeriesStyle ()
Destroys a CXTPChartLineSeriesStyle object, handles cleanup.
CXTPChartLineStyle * | GetLineStyle () const
Call this function to get the line style of the line series.
- Public Member Functions inherited from CXTPChartPointSeriesStyle
CXTPChartPointSeriesStyle ()
Constructs a CXTPChartPointSeriesStyle object.
virtual | ~CXTPChartPointSeriesStyle ()
Destroys a CXTPChartPointSeriesStyle object, handles cleanup.
CXTPChartMarker * | GetMarker () const
Call this function to get the marker object associated with this CXTPChartPointSeriesStyle object.
- Public Member Functions inherited from CXTPChartDiagram2DSeriesStyle
CXTPChartDiagram2DSeriesStyle ()
Constructs a CXTPChartDiagram2DSeriesStyle object.
virtual | ~CXTPChartDiagram2DSeriesStyle ()
Destroys a CXTPChartDiagram2DSeriesStyle object, handles cleanup.
virtual CXTPChartDiagram * | CreateDiagram ()
Call this function to create the diagram for this series.
virtual BOOL | IsStyleDiagram (CXTPChartDiagram *pDiagram) const
Call this function to check whether the chart diagram object passed is a kind of 2D diagram (CXTPChartDiagram2D object).
- Public Member Functions inherited from CXTPChartSeriesStyle
CXTPChartSeriesStyle ()
Constructs a CXTPChartSeriesStyle object.
virtual | ~CXTPChartSeriesStyle ()
Destroys a CXTPChartSeriesStyle object, handles cleanup.
virtual CXTPChartSeriesLabel * | GetLabel () const
Call this method to gets the series label object.
virtual CXTPChartSeriesLabel * | SetLabel (CXTPChartSeriesLabel *pLabel)
Call this method to sets the series label object.
virtual CXTPChartErrorBar * | GetErrorBar () const
Call this method to gets the error bar object.
virtual CXTPChartErrorBar * | SetErrorBar (CXTPChartErrorBar *pErrorBar)
Call this method to sets the error bar object.
virtual CXTPChartColor | GetColor () const
Call this method to get the color of the series.
virtual void | SetColor (CXTPChartColor clr)
Call this method to set the color of the series.
virtual void | SetColorEach (BOOL bColorEach)
Call this method to set individual color for each point of the series.
virtual BOOL | IsColorEach () const
This method is called to check if individual color is used for each point of the series.
virtual CXTPChart3dRotation | Get3dRotation () const
Obtains rotation parameters for 3D chart.
virtual void | Set3dRotation (const CXTPChart3dRotation &rotation)
Sets rotation parameters for 3D chart.
virtual void | Set3dRotation (double dYaw, double dPitch, double dRoll)
Sets rotation parameters for 3D chart.
virtual BOOL | Is3dEdgeSmoothingEnabled () const
Enables/disables 3D edge smoothing.
virtual void | Enable3dEdgeSmoothing (BOOL bEnable=TRUE)
Enables/disables 3D edge smoothing.
virtual int | GetTransparency () const
Call this function to gets the transparency of the chart if it is supported by the chart type.
virtual void | SetTransparency (int nTransparency)
Call this function to sets the transparency of the chart if it is supported by the chart type.
virtual void | CorrectAxisSideMargins (CXTPChartAxis *pAxis, double nMinValue, double nMaxValue, double &nCorrection)
Provides default implementation for axis side margins correction.
virtual CXTPChartSeriesStyleAppearance * | GetStyleAppearance () const
Obtains associated style appearance pointer.
virtual void | ApplyTo (CXTPChartDeviceCommand *pCommand)
Applies the style to the command provided in case the command needs style specific details for correct drawing.
virtual int | GetSeriesPointValueIndex () const
Obtains the index of a point element for which an internal value can be otained.
- Public Member Functions inherited from CXTPChartElement
CXTPChartElement ()
Constructs a CXTPChartElement object.
virtual | ~CXTPChartElement ()
Destroys a CXTPChartElement object, handles cleanup.
virtual void | Release ()
Call this function to decrease the usage count of the object.
CXTPChartElement * | GetOwner () const
Call this function to get the owner element.
virtual void | OnChartChanged (XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic properties of the chart.
CXTPChartContent * | GetContent () const
Call this virtual function to get the chart content object.
CXTPChartAppearance * | GetAppearance () const
Call this function to get the the appearance of the chart.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Protected Member Functions

virtual CXTPChartSeriesView * | CreateView (CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Call this function to create view of the StepLine series.
void | DoPropExchange (CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
- Protected Member Functions inherited from CXTPChartLineSeriesStyle
- Protected Member Functions inherited from CXTPChartPointSeriesStyle
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.

Additional Inherited Members

- Public Attributes inherited from CXTPChartElement
- Protected Attributes inherited from CXTPChartLineSeriesStyle
CXTPChartLineStyle * | m_pLineStyle
The line style.
- Protected Attributes inherited from CXTPChartPointSeriesStyle
- Protected Attributes inherited from CXTPChartDiagram2DSeriesStyle
int | m_nAxisIndexX
Holds index of secondary axisX, used when m_bSecondaryAxisX is TRUE.
int | m_nAxisIndexY
Holds index of secondary axisY, used when m_bSecondaryAxisY is TRUE.
- Protected Attributes inherited from CXTPChartSeriesStyle
CXTPChartSeriesLabel * | m_pLabel
Label object.
CXTPChartErrorBar * | m_pErrorBar
Error bar object.
CXTPChartColor | m_clrColor
Custom color of series.
BOOL | m_bColorEach
TRUE to color each point.
int | m_nTransparency
The transparency value in the range 0..255.
CXTPChart3dRotation | m_Rotation3d
3D rotation
BOOL | m_bSmooth3dEdges
3D edge smoothing
- Protected Attributes inherited from CXTPChartElement

Detailed Description

This class represents a StepLine series style, which is a kind of CXTPChartLineSeriesStyle.

A Step Line chart or StepLine graph is a type of graph, which displays information as a series of data points connected by straight Step Line segments. It is a basic type of chart common in many fields.

Member Function Documentation

◆ CreateView()

virtual CXTPChartSeriesView * CreateView | ( | CXTPChartSeries * | pSeries,
 |  | CXTPChartDiagramView * | pDiagramView )
 protectedvirtual

Call this function to create view of the StepLine series.

Parameters
pSeries | A pointer to the chart series object.
pDiagramView | A pointer to the diagram view object.
Returns
Returns a pointer to the associated series view object.

Reimplemented from CXTPChartLineSeriesStyle.

◆ DoPropExchange()

void DoPropExchange ( CXTPPropExchange * pPX )
protectedvirtual

Reads this object from or writes this object to an archive.

Parameters
pPX A CXTPPropExchange object to serialize to or from.

Reimplemented from CXTPChartLineSeriesStyle.

◆ GetInvertedStep()

AFX_INLINE BOOL GetInvertedStep ( ) const

Gets inverted step flag.

Returns
Current inverted step flag value.

◆ SetInvertedStep()

AFX_INLINE void SetInvertedStep ( BOOL bInvertedStep )

Sets inverted step flag.

Parameters
bInvertedStep TRUE to invert step, otherwise FALSE.
The documentation for this class was generated from the following file:
  • XTPChartStepLineSeriesStyle.h


Toolkit Pro: CXTPChartStepLineSeriesView Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPChartStepLineSeriesView Class Reference

This class represents the view of a StepLine series, which is a kind of CXTPChartSeriesView. More...

Public Member Functions

CXTPChartStepLineSeriesView (CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Constructs a CXTPChartStepLineSeriesView object.

Protected Member Functions

CXTPChartSeriesPointView * | CreateSeriesPointView (CXTPChartDeviceContext *pDC, CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Call this function to create a view of the StepLine series point.
virtual CXTPChartDeviceCommand * | CreateDeviceCommand (CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
virtual CXTPChartDeviceCommand * | CreateLegendDeviceCommand (CXTPChartDeviceContext *pDC, CRect rcBounds)
This function creates a label view drawing command object.

Detailed Description

This class represents the view of a StepLine series, which is a kind of CXTPChartSeriesView.

Constructor & Destructor Documentation

◆ CXTPChartStepLineSeriesView()

CXTPChartStepLineSeriesView | ( | CXTPChartSeries * | pSeries,
 |  | CXTPChartDiagramView * | pDiagramView )

Constructs a CXTPChartStepLineSeriesView object.

Parameters
pSeries | A pointer to the chart series object.
pDiagramView | A pointer to the diagram view object.

Member Function Documentation

◆ CreateDeviceCommand()

virtual CXTPChartDeviceCommand * CreateDeviceCommand ( CXTPChartDeviceContext * pDC )
protectedvirtual

This function creates a CXTPChartDeviceCommand object.

This object represents the rendering of a StepLine series.

Parameters
pDC Pointer to a CXTPChartDeviceContext object.
Returns
Returns a CXTPChartDeviceCommand object. This object handles the rendering of an element in the chart. Here it handles the drawing of the StepLine series.

Reimplemented from CXTPChartElementView.

◆ CreateLegendDeviceCommand()

virtual CXTPChartDeviceCommand * CreateLegendDeviceCommand | ( | CXTPChartDeviceContext * | pDC,
 |  | CRect | rcBounds )
 protectedvirtual

This function creates a label view drawing command object.

Parameters
pDC | Pointer to a CXTPChartDeviceContext object.
rcBounds | The rectangular boundary of the legend.
Returns
Returns a new label view drawing command object.

Implements CXTPChartLegendItemView.

◆ CreateSeriesPointView()

CXTPChartSeriesPointView * CreateSeriesPointView | ( | CXTPChartDeviceContext * | pDC,
 |  | CXTPChartSeriesPoint * | pPoint,
 |  | CXTPChartElementView * | pParentView )
 protected

Call this function to create a view of the StepLine series point.

Parameters
pDC | A pointer to the chart device context.
pPoint | A pointer to the chart series point object.
pParentView | Parent view pointer.
Returns
Returns a pointer to the associated series point view object.
The documentation for this class was generated from the following file:
  • XTPChartStepLineSeriesStyle.h


Toolkit Pro: CXTPChartStrings Class Reference

Public Member Functions | List of all members
CXTPChartStrings Class Reference

This class is a collection class of strings. More...

Public Member Functions

int IndexOf (const CXTPChartString &strValue) const
Use this function to get the zero-based index of an arbitrary string in the collection.

Detailed Description

This class is a collection class of strings.

It is a kind of CArray which is specialized into an array of strings.

Member Function Documentation

◆ IndexOf()

int IndexOf ( const CXTPChartString & strValue ) const

Use this function to get the zero-based index of an arbitrary string in the collection.

Parameters
strValue A reference to the sting object whose index is to be determined.
Returns
Returns index
The documentation for this class was generated from the following file:
  • XTPChartScaleTypeMap.h


Toolkit Pro: CXTPChartTextAntialiasingDeviceCommand Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPChartTextAntialiasingDeviceCommand Class Reference

This class represents a text device command, which is a kind of CXTPChartDeviceCommand. More...

Inheritance diagram for CXTPChartTextAntialiasingDeviceCommand:
[legend]

Public Member Functions

CXTPChartTextAntialiasingDeviceCommand (BOOL bAntialias=TRUE)
Constructs a CXTPChartTextAntialiasingDeviceCommand object.
- Public Member Functions inherited from CXTPChartDeviceCommand
CXTPChartDeviceCommand ()
Constructs a CXTPChartDeviceCommand object.
virtual | ~CXTPChartDeviceCommand ()
Destroys a CXTPChartDeviceCommand object, handles cleanup.
BOOL | IsCommitted () const
Determines if the execution of the command has been committed.
void | Commit ()
Commits the execution of the command.
int | GetChildCommandCount () const
Obtains the number of immediate children commands.
CXTPChartDeviceCommand * | GetChildCommand (int nIndex) const
Obtains immediate child command point by index.
CXTPChartDeviceCommand * | AddChildCommand (CXTPChartDeviceCommand *pCommand)
Call this function to add a child device command.
virtual void | Execute (CXTPChartDeviceContext *pDC)
Call this function to execute the drawing.
virtual void | BeforeExecute (CXTPChartDeviceContext *pDC)
This method gets called before a command is executed which allows for the customization of command behavior.
virtual void | AfterExecute (CXTPChartDeviceContext *pDC)
This method gets called after a command is executed which allows for the customization of command behavior.
virtual void | ExecuteOverride (CXTPChartDeviceContext *pDC)
Override this function to write the drawing code for specific objects.
UINT | GetPassNumber () const
Get the number of executions made by the command.
virtual CXTPChartElement * | HitTest (CPoint point, CXTPChartElement *pParent) const
Performs recursive hit testing of the element at the specified point.
virtual void | ApplySeriesStyle (CXTPChartSeriesStyle *pStyle)
Applies series style to the current element.
virtual void | Prepare (CXTPChartDeviceContext *pDC)
Performs inital preparation steps necessary for successful command execution.
virtual void | PrepareOverride (CXTPChartDeviceContext *pDC)
Derived implementation must override this method for implementing implementation specific preparation behavior.
virtual BOOL | IsEnabled () const
Determines if the command is currently enabled.
void | SetEnabled (BOOL bEnabled=TRUE)
Enables/disable the command.
CXTPChartDeviceContext * | GetCurrentDC () const
Obtains device context pointer for which the command is currenly being prepared or executed.
void | BindView (CXTPChartElementView *pView)
Binds a view to the command object.
CXTPChartElementView * | GetBoundView () const
Obtains a bound view pointer or NULL if no view is bound.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.
- Public Member Functions inherited from CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents >
void | Subscribe (CXTPChartDeviceCommandEvents *pObserver, CXTPSubscriptionList< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > *pSubcriptionList=NULL)
Subscribes a unique observer for events.
void | Unsubscribe (CXTPChartDeviceCommandEvents *pObserver)
Unsubscribes an observer from events.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *))
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *))
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.

Protected Attributes

BOOL | m_bAntiAlias
TRUE if antialiasing is enabled, FALSE if antialiasing is not used.
- Protected Attributes inherited from CXTPChartDeviceCommand
CArray< CXTPChartDeviceCommand *, CXTPChartDeviceCommand * > | m_arrChildren
< The array of child device commands.

Additional Inherited Members

- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.
- Protected Member Functions inherited from CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents >
CXTPObservable ()
Constructs an observable object.
~CXTPObservable ()
Handles observable object destruction.

Detailed Description

This class represents a text device command, which is a kind of CXTPChartDeviceCommand.

This class handles the smoothing of texts in chart by using antialising.

Constructor & Destructor Documentation

◆ CXTPChartTextAntialiasingDeviceCommand()

CXTPChartTextAntialiasingDeviceCommand ( BOOL bAntialias = TRUE )

Constructs a CXTPChartTextAntialiasingDeviceCommand object.

Parameters
bAntialias A BOOL value. TRUE to enable antialiasing, FALSE to disable antialiasing. The default value is TRUE.
The documentation for this class was generated from the following file:
  • XTPChartTextDeviceCommand.h


Toolkit Pro: CXTPChartTextDeviceCommand Class Reference

Protected Member Functions | Protected Attributes | List of all members
CXTPChartTextDeviceCommand Class Reference

This class represents a text device command, which is a kind of CXTPChartDeviceCommand. More...

Inheritance diagram for CXTPChartTextDeviceCommand:
[legend]

Protected Member Functions

CXTPChartTextDeviceCommand (const CXTPChartString &strText, CXTPChartFont *pFont, const CXTPChartColor &color)
Constructs a CXTPChartTextDeviceCommand object.
virtual void | ExecuteOverride (CXTPChartDeviceContext *pDC)
This is a virtual function override of base class CXTPChartDeviceContext.
virtual void | ExecuteInternal (CXTPChartDeviceContext *pDC)
This function does the actual drawing of the chart element to which this device command is associated with.
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.
- Protected Member Functions inherited from CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents >
CXTPObservable ()
Constructs an observable object.
~CXTPObservable ()
Handles observable object destruction.

Protected Attributes

CXTPChartString | m_strText
The string to be rendered.
CXTPChartFont * | m_pFont
The font used to render the text.
CXTPChartColor | m_color
The color of the text.
- Protected Attributes inherited from CXTPChartDeviceCommand
CArray< CXTPChartDeviceCommand *, CXTPChartDeviceCommand * > | m_arrChildren
< The array of child device commands.

Additional Inherited Members

- Public Member Functions inherited from CXTPChartDeviceCommand
CXTPChartDeviceCommand ()
Constructs a CXTPChartDeviceCommand object.
virtual | ~CXTPChartDeviceCommand ()
Destroys a CXTPChartDeviceCommand object, handles cleanup.
BOOL | IsCommitted () const
Determines if the execution of the command has been committed.
void | Commit ()
Commits the execution of the command.
int | GetChildCommandCount () const
Obtains the number of immediate children commands.
CXTPChartDeviceCommand * | GetChildCommand (int nIndex) const
Obtains immediate child command point by index.
CXTPChartDeviceCommand * | AddChildCommand (CXTPChartDeviceCommand *pCommand)
Call this function to add a child device command.
virtual void | Execute (CXTPChartDeviceContext *pDC)
Call this function to execute the drawing.
virtual void | BeforeExecute (CXTPChartDeviceContext *pDC)
This method gets called before a command is executed which allows for the customization of command behavior.
virtual void | AfterExecute (CXTPChartDeviceContext *pDC)
This method gets called after a command is executed which allows for the customization of command behavior.
UINT | GetPassNumber () const
Get the number of executions made by the command.
virtual CXTPChartElement * | HitTest (CPoint point, CXTPChartElement *pParent) const
Performs recursive hit testing of the element at the specified point.
virtual void | ApplySeriesStyle (CXTPChartSeriesStyle *pStyle)
Applies series style to the current element.
virtual void | Prepare (CXTPChartDeviceContext *pDC)
Performs inital preparation steps necessary for successful command execution.
virtual void | PrepareOverride (CXTPChartDeviceContext *pDC)
Derived implementation must override this method for implementing implementation specific preparation behavior.
virtual BOOL | IsEnabled () const
Determines if the command is currently enabled.
void | SetEnabled (BOOL bEnabled=TRUE)
Enables/disable the command.
CXTPChartDeviceContext * | GetCurrentDC () const
Obtains device context pointer for which the command is currenly being prepared or executed.
void | BindView (CXTPChartElementView *pView)
Binds a view to the command object.
CXTPChartElementView * | GetBoundView () const
Obtains a bound view pointer or NULL if no view is bound.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.
- Public Member Functions inherited from CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents >
void | Subscribe (CXTPChartDeviceCommandEvents *pObserver, CXTPSubscriptionList< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > *pSubcriptionList=NULL)
Subscribes a unique observer for events.
void | Unsubscribe (CXTPChartDeviceCommandEvents *pObserver)
Unsubscribes an observer from events.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *))
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *))
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.

Detailed Description

This class represents a text device command, which is a kind of CXTPChartDeviceCommand.

It specifically handles the rendering of texts in a chart.

Constructor & Destructor Documentation

◆ CXTPChartTextDeviceCommand()

CXTPChartTextDeviceCommand | ( | const CXTPChartString & | strText,
 |  | CXTPChartFont * | pFont,
 |  | const CXTPChartColor & | color )
 protected

Constructs a CXTPChartTextDeviceCommand object.

Parameters
strText | The text to be rendered.
pFont | The font used to render.
color | The color of the text.

Member Function Documentation

◆ ExecuteInternal()

virtual void ExecuteInternal ( CXTPChartDeviceContext * pDC )
protectedvirtual

This function does the actual drawing of the chart element to which this device command is associated with.

Here it renders the text.

Parameters
pDC The device context of the chart.

◆ ExecuteOverride()

virtual void ExecuteOverride ( CXTPChartDeviceContext * pDC )
protectedvirtual

This is a virtual function override of base class CXTPChartDeviceContext.

This function acts polymorphically to do the actual drawing of the chart element to which this device command is associated with.

Parameters
pDC The device context of the chart.

Reimplemented from CXTPChartDeviceCommand.

The documentation for this class was generated from the following file:
  • XTPChartTextDeviceCommand.h


Toolkit Pro: CXTPChartTextElement Class Reference

Public Member Functions | List of all members
CXTPChartTextElement Class Referenceabstract

This class abstracts a chart text element. More...

Inheritance diagram for CXTPChartTextElement:
[legend]

Public Member Functions

virtual CXTPChartFont * | GetFont () const =0
Call this function to get the font of the text element.
virtual BOOL | GetAntialiasing () const =0
Call this function to check if anti-aliasing is ON or OFF.
- Public Member Functions inherited from CXTPChartElement
CXTPChartElement ()
Constructs a CXTPChartElement object.
virtual | ~CXTPChartElement ()
Destroys a CXTPChartElement object, handles cleanup.
virtual void | Release ()
Call this function to decrease the usage count of the object.
CXTPChartElement * | GetOwner () const
Call this function to get the owner element.
virtual void | OnChartChanged (XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic properties of the chart.
CXTPChartContent * | GetContent () const
Call this virtual function to get the chart content object.
CXTPChartAppearance * | GetAppearance () const
Call this function to get the the appearance of the chart.
virtual void | DoPropExchange (CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Additional Inherited Members

- Public Attributes inherited from CXTPChartElement
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.
- Protected Attributes inherited from CXTPChartElement

Detailed Description

This class abstracts a chart text element.

This class is a kind of CXTPChartElement class.

This class acts as an abstract base class for various specialized chart text elements like axis label, axis title etc.

Member Function Documentation

◆ GetAntialiasing()

virtual BOOL GetAntialiasing ( ) const
pure virtual

Call this function to check if anti-aliasing is ON or OFF.

Anti-aliasing is the smoothing of sharp edges of text and drawing.

Returns
A BOOL value. TRUE if anti-aliasing is ON, FALSE if anti-aliasing is OFF.

Implemented in CXTPChartAxisConstantLine, CXTPChartAxisLabel, CXTPChartAxisTitle, CXTPChartLegend, CXTPChartSeriesLabel, and CXTPChartTitle.

◆ GetFont()

virtual CXTPChartFont * GetFont ( ) const
pure virtual

Call this function to get the font of the text element.

Returns
A pointer to a chart font object, which holds the current font of the text element.

Implemented in CXTPChartAxisConstantLine, CXTPChartAxisLabel, CXTPChartAxisTitle, CXTPChartLegend, CXTPChartSeriesLabel, and CXTPChartTitle.

The documentation for this class was generated from the following file:
  • XTPChartElement.h


Toolkit Pro: CXTPChartTextPainter Class Reference

Public Member Functions | List of all members
CXTPChartTextPainter Class Reference

This class represents a text painter which is used for drawing various text elements in the chart. More...

Inheritance diagram for CXTPChartTextPainter:
[legend]

Public Member Functions

CXTPChartTextPainter (CXTPChartDeviceContext *pDC, const CXTPChartString &text, CXTPChartTextElement *pTextProvider)
Constructs a CXTPChartTextPainterBase object.
virtual CXTPChartDeviceCommand * | CreateDeviceCommand (CXTPChartDeviceContext *pDC, const CXTPChartColor &color)
This function creates a CXTPChartDeviceCommand object.
CXTPChartRectF CalculateBounds ()
Call this function to calculate the bounds of the text.
- Public Member Functions inherited from CXTPChartTextPainterBase
virtual | ~CXTPChartTextPainterBase ()
Destroys a CXTPChartTextPainterBase object, handles cleanup.
CRect | GetRoundedBounds ()
Call this function to get the rounded bounds of the text.

Additional Inherited Members

- Protected Member Functions inherited from CXTPChartTextPainterBase
CXTPChartTextPainterBase (CXTPChartDeviceContext *pDC, const CXTPChartString &text, CXTPChartTextElement *pTextProvider)
Constructs a CXTPChartTextPainterBase object.
- Protected Attributes inherited from CXTPChartTextPainterBase
CXTPChartString | m_strText
The text to be painted.
CXTPChartSizeF | m_szTextSize
The measurements of the text.
CXTPChartTextElement * | m_pTextProvider
The chart element which owns the text.
int | m_nHeight
The height of the text.
int | m_nWidth
The width of the text.
CRect | m_rcRoundedBounds
The rounded bounds of the text.
CXTPChartRectF | m_rcBounds
The bounds of the text.

Detailed Description

This class represents a text painter which is used for drawing various text elements in the chart.

This is a kind of CXTPChartTextPainterBase.

Constructor & Destructor Documentation

◆ CXTPChartTextPainter()

CXTPChartTextPainter | ( | CXTPChartDeviceContext * | pDC,
 |  | const CXTPChartString & | text,
 |  | CXTPChartTextElement * | pTextProvider )

Constructs a CXTPChartTextPainterBase object.

Parameters
text | The text to be rendered.
pTextProvider | The element which owns the text.
pDC | Pointer to a valid device context.

Member Function Documentation

◆ CalculateBounds()

CXTPChartRectF CalculateBounds ( )
virtual

Call this function to calculate the bounds of the text.

Returns
A CXTPChartRectF object specifying the bounds.

Implements CXTPChartTextPainterBase.

◆ CreateDeviceCommand()

virtual CXTPChartDeviceCommand * CreateDeviceCommand | ( | CXTPChartDeviceContext * | pDC,
 |  | const CXTPChartColor & | color )
 virtual

This function creates a CXTPChartDeviceCommand object.

This object represents the rendering of a text.

Parameters
pDC | Pointer to a CXTPChartDeviceContext object.
color | The color of the text.
Returns
Returns a CXTPChartDeviceCommand object. This object handles the rendering of an element in the chart. Here it handles the drawing of a text.
The documentation for this class was generated from the following file:
  • XTPChartTextPainter.h


Toolkit Pro: CXTPChartTextPainterBase Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPChartTextPainterBase Class Referenceabstract

This abstract class represents a text painter which is used for drawing various text elements in the chart. More...

Inheritance diagram for CXTPChartTextPainterBase:
[legend]

Public Member Functions

virtual | ~CXTPChartTextPainterBase ()
Destroys a CXTPChartTextPainterBase object, handles cleanup.
CRect | GetRoundedBounds ()
Call this function to get the rounded bounds of the text.

Protected Member Functions

CXTPChartTextPainterBase (CXTPChartDeviceContext *pDC, const CXTPChartString &text, CXTPChartTextElement *pTextProvider)
Constructs a CXTPChartTextPainterBase object.
virtual CXTPChartRectF CalculateBounds ()=0
Call this function to calculate the bounds of the text.

Protected Attributes

CXTPChartString | m_strText
The text to be painted.
CXTPChartSizeF | m_szTextSize
The measurements of the text.
CXTPChartTextElement * | m_pTextProvider
The chart element which owns the text.
int | m_nHeight
The height of the text.
int | m_nWidth
The width of the text.
CRect | m_rcRoundedBounds
The rounded bounds of the text.
CXTPChartRectF | m_rcBounds
The bounds of the text.

Detailed Description

This abstract class represents a text painter which is used for drawing various text elements in the chart.

Constructor & Destructor Documentation

◆ CXTPChartTextPainterBase()

CXTPChartTextPainterBase | ( | CXTPChartDeviceContext * | pDC,
 |  | const CXTPChartString & | text,
 |  | CXTPChartTextElement * | pTextProvider )
 protected

Constructs a CXTPChartTextPainterBase object.

Parameters
text | The text to be rendered.
pDC | Pointer to a valid device context.
pTextProvider | The element which owns the text.

Member Function Documentation

◆ CalculateBounds()

virtual CXTPChartRectF CalculateBounds ( )
protectedpure virtual

Call this function to calculate the bounds of the text.

Returns
A CXTPChartRectF object specifying the rounded bounds.

This is a pure virtual function, so give meaningful implementation to this function within derived classes.

Implemented in CXTPChartRotatedTextPainterBase, and CXTPChartTextPainter.

◆ GetRoundedBounds()

CRect GetRoundedBounds ( )

Call this function to get the rounded bounds of the text.

Returns
A CRect object specifying the rounded bounds.
The documentation for this class was generated from the following file:
  • XTPChartTextPainter.h


Toolkit Pro: CXTPChartTimeScaleTypeMap Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPChartTimeScaleTypeMap Class Reference

This class is a kind of CXTPChartScaleTypeMap, which abstracts a time scale type for an axis. More...

Inheritance diagram for CXTPChartTimeScaleTypeMap:
[legend]

Public Member Functions

virtual CXTPChartString | InternalToValue (CXTPChartNumberFormat *pFromat, double dValue) const
Use this function to convert a double value to a string.
virtual double | ValueToInternal (const CXTPChartString &strValue) const
Use this function to convert a value string to to an internal type.
- Public Member Functions inherited from CXTPChartScaleTypeMap
CXTPChartScaleTypeMap (CXTPChartAxis *pAxis)
Constructs a CXTPChartScaleTypeMap object.
virtual | ~CXTPChartScaleTypeMap ()
Destroys a CXTPChartScaleTypeMap object, handles cleanup.
CXTPChartAxis * | GetAxis () const
Call this function to get the axis object to which this object is associated with.
virtual void | UpdateSeries (CXTPChartAxisView *pAxisView)
Call this function when there is a change in the values of the series or a change in the scale.
virtual void | UpdateSeries (CXTPChartSeries *pSeries)
Call this function when there is a change in the values of the series or a change in the scale.
- Public Member Functions inherited from CXTPChartElement
CXTPChartElement ()
Constructs a CXTPChartElement object.
virtual | ~CXTPChartElement ()
Destroys a CXTPChartElement object, handles cleanup.
virtual void | Release ()
Call this function to decrease the usage count of the object.
CXTPChartElement * | GetOwner () const
Call this function to get the owner element.
virtual void | OnChartChanged (XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic properties of the chart.
CXTPChartContent * | GetContent () const
Call this virtual function to get the chart content object.
CXTPChartAppearance * | GetAppearance () const
Call this function to get the the appearance of the chart.
virtual void | DoPropExchange (CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Protected Member Functions

void UpdateSeriesPointArgument (CXTPChartSeriesPoint *pPoint)
Call this function to update a point argument in a series point.
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPChartScaleTypeMap
static CXTPChartScaleTypeMap *AFX_CDECL Create (CXTPChartAxis *pAxis)
Call this function to create a scale type map object.
- Public Attributes inherited from CXTPChartElement
- Protected Attributes inherited from CXTPChartElement

Detailed Description

This class is a kind of CXTPChartScaleTypeMap, which abstracts a time scale type for an axis.

Member Function Documentation

◆ InternalToValue()

virtual CXTPChartString InternalToValue | ( | CXTPChartNumberFormat * | pFromat,
 |  | double | dValue ) const
 virtual

Use this function to convert a double value to a string.

This actually converts the internal representation of data to a more meaningful value.

Parameters
pFromat | Conversion format to use.
dValue | Value to format.
Returns
A CXTPChartString object representing the string value.

Implements CXTPChartScaleTypeMap.

◆ UpdateSeriesPointArgument()

void UpdateSeriesPointArgument ( CXTPChartSeriesPoint * pPoint )
protectedvirtual

Call this function to update a point argument in a series point.

Parameters
pPoint A pointer to the chart series point object.

Reimplemented from CXTPChartScaleTypeMap.

◆ ValueToInternal()

virtual double ValueToInternal ( const CXTPChartString & strValue ) const
virtual

Use this function to convert a value string to to an internal type.

Parameters
strValue Value to be set.
Returns
A double representing the internal value.

Implements CXTPChartScaleTypeMap.

The documentation for this class was generated from the following file:
  • XTPChartScaleTypeMap.h


Toolkit Pro: CXTPChartTitle Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPChartTitle Class Reference

This class represents a chart title. More...

Inheritance diagram for CXTPChartTitle:
[legend]

Public Member Functions

CXTPChartTitle ()
Constructs a CXTPChartTitle object.
virtual | ~CXTPChartTitle ()
Destroys a CXTPChartTitle object, handles cleanup.
void | SetVisible (BOOL bVisible)
Call this function to set the visibility of the title.
BOOL | IsVisible () const
Call this function to check if the title is visible.
void | SetText (LPCTSTR lpszTitle)
Call this function to set the text of the title.
CXTPChartString | GetText () const
Call this function to get the text of the title.
void | SetTextColor (const CXTPChartColor &clrTextColor)
Call this method to set the custom text color of the title.
CXTPChartColor | GetTextColor () const
Call this method to get the custom text color of the title.
CXTPChartColor | GetActualTextColor () const
Call this method to get the actual text color of the title.
void | SetFont (CXTPChartFont *pFont)
Call this method to set the font of the title.
CXTPChartFont * | GetFont () const
Call this method to get the font for the title.
void | SetDocking (XTPChartDocking nDocking)
Call this method to set the docking position of the title.
XTPChartDocking | GetDocking () const
Call this method to get the docking position of the title.
void | SetIndent (int nIndent)
Call this method to set the indent between 2 titles.
int | GetIndent () const
Call this method to get the indent between 2 titles.
void | SetAlignment (XTPChartStringAlignment nAlignment)
Call this method to set the text alignment of the title.
XTPChartStringAlignment | GetAlignment () const
Call this method to get the text alignment of the title.
void | SetAntialiasing (BOOL bAntialiasing)
Call this function to set anti-aliasing ON or OFF.
BOOL | GetAntialiasing () const
Call this function to check if anti-aliasing is ON or OFF.
int | GetTextAngle () const
This method calculates text angle according to the current docking position.
void | DoPropExchange (CXTPPropExchange *pPX)
Call this member function to Store/Load the properties of a title object using the specified data object.
- Public Member Functions inherited from CXTPChartTextElement
- Public Member Functions inherited from CXTPChartElement
CXTPChartElement ()
Constructs a CXTPChartElement object.
virtual | ~CXTPChartElement ()
Destroys a CXTPChartElement object, handles cleanup.
virtual void | Release ()
Call this function to decrease the usage count of the object.
CXTPChartElement * | GetOwner () const
Call this function to get the owner element.
virtual void | OnChartChanged (XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic properties of the chart.
CXTPChartContent * | GetContent () const
Call this virtual function to get the chart content object.
CXTPChartAppearance * | GetAppearance () const
Call this function to get the the appearance of the chart.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Protected Attributes

CXTPChartString | m_strText
Text of the title.
CXTPChartColor | m_clrTextColor
Text color.
BOOL | m_bVisible
TRUE if title is visible.
CXTPChartFont * | m_pFont
Font of the title.
BOOL | m_bAntialiasing
Antialiasing flag.
XTPChartDocking | m_nDocking
Current docking position of the title.
int | m_nIndent
Indent between 2 titles.
int | m_nInnerIndent
Inner indent.
XTPChartStringAlignment | m_nAlignment
Text alignment.
- Protected Attributes inherited from CXTPChartElement

Additional Inherited Members

- Public Attributes inherited from CXTPChartElement
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.

Detailed Description

This class represents a chart title.

Member Function Documentation

◆ DoPropExchange()

void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Call this member function to Store/Load the properties of a title object using the specified data object.

Parameters
pPX Source or destination CXTPPropExchange data object reference.

This member function is used to store property data to or load property data from storage.

Reimplemented from CXTPChartElement.

◆ GetActualTextColor()

CXTPChartColor GetActualTextColor ( ) const

Call this method to get the actual text color of the title.

Returns
The actual text color of the title.
See also
GetTextColor

◆ GetAlignment()

AFX_INLINE XTPChartStringAlignment GetAlignment ( ) const

Call this method to get the text alignment of the title.

Text alignment of the title. It can be one of the following: xtpChartAlignNear, xtpChartAlignCenter, xtpChartAlignFar.

Returns
Returns text alignment of title
See also
SetAlignment

◆ GetAntialiasing()

AFX_INLINE BOOL GetAntialiasing ( ) const
virtual

Call this function to check if anti-aliasing is ON or OFF.

Anti-aliasing is the smoothing of sharp edges of text and drawing.

Returns
A BOOL value. TRUE if anti-aliasing is ON, FALSE if anti-aliasing is OFF.

Implements CXTPChartTextElement.

◆ GetDocking()

AFX_INLINE XTPChartDocking GetDocking ( ) const

Call this method to get the docking position of the title.

Returns
Docking position of title. It can be one of the following: xtpChartDockTop, xtpChartDockBottom, xtpChartDockLeft, xtpChartDockRight.
See also
SetDocking

◆ GetFont()

AFX_INLINE CXTPChartFont * GetFont ( ) const
virtual

Call this method to get the font for the title.

Returns
Pointer to a CXTPChartFont object that holds font information.
See also
SetFont

Implements CXTPChartTextElement.

◆ GetIndent()

AFX_INLINE int GetIndent ( ) const

Call this method to get the indent between 2 titles.

Returns
Indent between 2 titles.
See also
GetIndent

◆ GetText()

AFX_INLINE CXTPChartString GetText ( ) const

Call this function to get the text of the title.

Returns
Text of the title.
See also
SetText

◆ GetTextAngle()

int GetTextAngle ( ) const

This method calculates text angle according to the current docking position.

Returns
Returns text angle
See also
GetDocking

◆ GetTextColor()

CXTPChartColor GetTextColor ( ) const

Call this method to get the custom text color of the title.

Returns
The text color of the title. If default appearance color is used, then CXTPChartColor::Empty will be returned.
See also
SetTextColor

◆ IsVisible()

AFX_INLINE BOOL IsVisible ( ) const

Call this function to check if the title is visible.

Returns
A BOOL value. TRUE if the title is visible, FALSE otherwise.

◆ SetAlignment()

void SetAlignment ( XTPChartStringAlignment nAlignment )

Call this method to set the text alignment of the title.

Parameters
nAlignment New text alignment to be set. It can be one of the following: xtpChartAlignNear, xtpChartAlignCenter, xtpChartAlignFar.
See also
GetAlignment

◆ SetAntialiasing()

AFX_INLINE void SetAntialiasing ( BOOL bAntialiasing )

Call this function to set anti-aliasing ON or OFF.

Anti-aliasing is the smoothing of sharp edges of text and drawing.

Parameters
bAntialiasing A BOOL value. TRUE to set anti-aliasing to ON, FALSE to set anti-aliasing to OFF.

◆ SetDocking()

void SetDocking ( XTPChartDocking nDocking )

Call this method to set the docking position of the title.

Parameters
nDocking docking position of the title. It can be one of the following: xtpChartDockTop, xtpChartDockBottom, xtpChartDockLeft, xtpChartDockRight.
See also
GetDocking

◆ SetFont()

void SetFont ( CXTPChartFont * pFont )

Call this method to set the font of the title.

Parameters
pFont New font to be set.
See also
GetFont

◆ SetIndent()

void SetIndent ( int nIndent )

Call this method to set the indent between 2 titles.

Parameters
nIndent New indent to be set.
See also
GetIndent

◆ SetText()

void SetText ( LPCTSTR lpszTitle )

Call this function to set the text of the title.

Parameters
lpszTitle New text of the title.
See also
GetText

◆ SetTextColor()

void SetTextColor ( const CXTPChartColor & clrTextColor )

Call this method to set the custom text color of the title.

Parameters
clrTextColor New text color of the title. It can be CXTPChartColor::Empty to use the default appearance color.
See also
GetTextColor

◆ SetVisible()

AFX_INLINE void SetVisible ( BOOL bVisible )

Call this function to set the visibility of the title.

Parameters
bVisible A BOOL value. TRUE to set the title to visible, FALSE to hide the title.
The documentation for this class was generated from the following file:
  • XTPChartTitle.h


Toolkit Pro: CXTPChartTitleAppearance Class Reference

Public Member Functions | List of all members
CXTPChartTitleAppearance Class Reference

This class represents the appearance of a chart title. More...

Inheritance diagram for CXTPChartTitleAppearance:
[legend]

Public Member Functions

CXTPChartTitleAppearance (CXTPChartElement *pOwner)
Constructs a CXTPChartTitleAppearance object.
void | DoPropExchange (CXTPPropExchange *pPX)
Call this member function to Store/Load the properties related to the appearance of a chart title using the specified data object.
- Public Member Functions inherited from CXTPChartElementAppearance
CXTPChartElementAppearance (CXTPChartElement *pOwner)
Constructs a CXTPChartElementAppearance object.
virtual | ~CXTPChartElementAppearance ()
Destroys a CXTPChartElementAppearance object, handles cleanup.
virtual void | ApplyToDeviceContext (CXTPChartDeviceContext *pDC)
Applies implementation specific appearance settings to the device context provided.
- Public Member Functions inherited from CXTPChartElement
CXTPChartElement ()
Constructs a CXTPChartElement object.
virtual | ~CXTPChartElement ()
Destroys a CXTPChartElement object, handles cleanup.
virtual void | Release ()
Call this function to decrease the usage count of the object.
CXTPChartElement * | GetOwner () const
Call this function to get the owner element.
virtual void | OnChartChanged (XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic properties of the chart.
CXTPChartContent * | GetContent () const
Call this virtual function to get the chart content object.
CXTPChartAppearance * | GetAppearance () const
Call this function to get the the appearance of the chart.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Additional Inherited Members

- Public Attributes inherited from CXTPChartElement
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.
- Protected Attributes inherited from CXTPChartElement

Detailed Description

This class represents the appearance of a chart title.

Constructor & Destructor Documentation

◆ CXTPChartTitleAppearance()

CXTPChartTitleAppearance ( CXTPChartElement * pOwner )

Constructs a CXTPChartTitleAppearance object.

Parameters
pOwner Pointer to an owner element.

Member Function Documentation

◆ DoPropExchange()

void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Call this member function to Store/Load the properties related to the appearance of a chart title using the specified data object.

Parameters
pPX Source or destination CXTPPropExchange data object reference.

This member function is used to store or load property data to or from a storage.

Reimplemented from CXTPChartElement.

The documentation for this class was generated from the following file:
  • XTPChartAppearance.h


Toolkit Pro: CXTPChartTitleCollection Class Reference

Public Member Functions | List of all members
CXTPChartTitleCollection Class Reference

CXTPChartTitleCollection represents a collection of chart titles. More...

Inheritance diagram for CXTPChartTitleCollection:
[legend]

Public Member Functions

CXTPChartTitleCollection (CXTPChartElement *pOwner)
Constructs a CXTPChartTitleCollection object.
virtual | ~CXTPChartTitleCollection ()
Destroys a CXTPChartTitleCollection object, handles cleanup.
CXTPChartTitle * | Add (CXTPChartTitle *pTitle)
Call this method to add a new title.
CXTPChartTitle * | GetAt (int nIndex) const
Call this method to get a title by its index.
virtual void | DoPropExchange (CXTPPropExchange *pPX)
Call this member function to Store/Load the properties of a title object using the specified data object.
- Public Member Functions inherited from CXTPChartElementCollection
CXTPChartElementCollection ()
Constructs a CXTPChartElementCollection object.
~CXTPChartElementCollection ()
Destroys a CXTPChartElementCollection object, handles cleanup.
virtual void | RemoveAll ()
This function removes all the individual objects from this collection object.
virtual int | GetCount () const
Call this function to get the number of objects in the internal array of this object.
virtual void | RemoveAt (int nIndex)
Use this function to remove an object from the collection.
virtual void | Remove (CXTPChartElement *pElement)
Use this function to remove an object from the collection.
CXTPChartElement * | GetAt (int nIndex) const
Call this function to get an element by its index.
int | IndexOf (CXTPChartElement *pElement) const
Call this function to get the index of a specified element.
void | InsertAt (int nIndex, CXTPChartElement *pElement)
Call this method to add a new element to the collection.
virtual void | Release ()
Call this function to decrease the usage count of the object.
- Public Member Functions inherited from CXTPChartElement
CXTPChartElement ()
Constructs a CXTPChartElement object.
virtual | ~CXTPChartElement ()
Destroys a CXTPChartElement object, handles cleanup.
CXTPChartElement * | GetOwner () const
Call this function to get the owner element.
virtual void | OnChartChanged (XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic properties of the chart.
CXTPChartContent * | GetContent () const
Call this virtual function to get the chart content object.
CXTPChartAppearance * | GetAppearance () const
Call this function to get the the appearance of the chart.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.

Additional Inherited Members

- Public Attributes inherited from CXTPChartElement
- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.
- Protected Attributes inherited from CXTPChartElementCollection
CArray< CXTPChartElement *, CXTPChartElement * > m_arrElements
Array of CXTPChartElement pointer.
- Protected Attributes inherited from CXTPChartElement

Detailed Description

CXTPChartTitleCollection represents a collection of chart titles.

Constructor & Destructor Documentation

◆ CXTPChartTitleCollection()

CXTPChartTitleCollection ( CXTPChartElement * pOwner )

Constructs a CXTPChartTitleCollection object.

Parameters
pOwner Owner object.

Member Function Documentation

◆ Add()

CXTPChartTitle * Add ( CXTPChartTitle * pTitle )

Call this method to add a new title.

Parameters
pTitle New title to add.
Returns
An added title object pointer.

◆ DoPropExchange()

virtual void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Call this member function to Store/Load the properties of a title object using the specified data object.

Parameters
pPX Source or destination CXTPPropExchange data object reference.

This member function is used to store property data to or load property data from storage.

Reimplemented from CXTPChartElement.

◆ GetAt()

AFX_INLINE CXTPChartTitle * GetAt ( int nIndex ) const

Call this method to get a title by its index.

Parameters
nIndex Index of the title to get.
Returns
Returns title by its index
The documentation for this class was generated from the following file:
  • XTPChartTitle.h


Toolkit Pro: CXTPChartTranslateDeviceCommand Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPChartTranslateDeviceCommand Class Reference

Base class implementation for 2D chart translation device command. More...

Inheritance diagram for CXTPChartTranslateDeviceCommand:
[legend]

Public Member Functions

CXTPChartTranslateDeviceCommand (double dx, double dy)
Constructs a CXTPChartTranslateDeviceCommand object.
- Public Member Functions inherited from CXTPChartDeviceCommand
CXTPChartDeviceCommand ()
Constructs a CXTPChartDeviceCommand object.
virtual | ~CXTPChartDeviceCommand ()
Destroys a CXTPChartDeviceCommand object, handles cleanup.
BOOL | IsCommitted () const
Determines if the execution of the command has been committed.
void | Commit ()
Commits the execution of the command.
int | GetChildCommandCount () const
Obtains the number of immediate children commands.
CXTPChartDeviceCommand * | GetChildCommand (int nIndex) const
Obtains immediate child command point by index.
CXTPChartDeviceCommand * | AddChildCommand (CXTPChartDeviceCommand *pCommand)
Call this function to add a child device command.
virtual void | Execute (CXTPChartDeviceContext *pDC)
Call this function to execute the drawing.
virtual void | BeforeExecute (CXTPChartDeviceContext *pDC)
This method gets called before a command is executed which allows for the customization of command behavior.
virtual void | AfterExecute (CXTPChartDeviceContext *pDC)
This method gets called after a command is executed which allows for the customization of command behavior.
virtual void | ExecuteOverride (CXTPChartDeviceContext *pDC)
Override this function to write the drawing code for specific objects.
UINT | GetPassNumber () const
Get the number of executions made by the command.
virtual CXTPChartElement * | HitTest (CPoint point, CXTPChartElement *pParent) const
Performs recursive hit testing of the element at the specified point.
virtual void | ApplySeriesStyle (CXTPChartSeriesStyle *pStyle)
Applies series style to the current element.
virtual void | Prepare (CXTPChartDeviceContext *pDC)
Performs inital preparation steps necessary for successful command execution.
virtual void | PrepareOverride (CXTPChartDeviceContext *pDC)
Derived implementation must override this method for implementing implementation specific preparation behavior.
virtual BOOL | IsEnabled () const
Determines if the command is currently enabled.
void | SetEnabled (BOOL bEnabled=TRUE)
Enables/disable the command.
CXTPChartDeviceContext * | GetCurrentDC () const
Obtains device context pointer for which the command is currenly being prepared or executed.
void | BindView (CXTPChartElementView *pView)
Binds a view to the command object.
CXTPChartElementView * | GetBoundView () const
Obtains a bound view pointer or NULL if no view is bound.
- Public Member Functions inherited from CXTPChartObject
BOOL | Is3D () const
Determines if a derived object is used in 3D mode.
- Public Member Functions inherited from CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents >
void | Subscribe (CXTPChartDeviceCommandEvents *pObserver, CXTPSubscriptionList< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > *pSubcriptionList=NULL)
Subscribes a unique observer for events.
void | Unsubscribe (CXTPChartDeviceCommandEvents *pObserver)
Unsubscribes an observer from events.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *))
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *))
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.

Protected Attributes

double | m_dx
The change in X direction.
double | m_dy
The change in Y direction.
- Protected Attributes inherited from CXTPChartDeviceCommand
CArray< CXTPChartDeviceCommand *, CXTPChartDeviceCommand * > | m_arrChildren
< The array of child device commands.

Additional Inherited Members

- Protected Member Functions inherited from CXTPChartObject
CXTPChartObject ()
Constructs an empty chart object.
CXTPChartObject (BOOL bIs3D)
Constructs an empty chart object.
- Protected Member Functions inherited from CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents >
CXTPObservable ()
Constructs an observable object.
~CXTPObservable ()
Handles observable object destruction.

Detailed Description

Base class implementation for 2D chart translation device command.

Constructor & Destructor Documentation

◆ CXTPChartTranslateDeviceCommand()

CXTPChartTranslateDeviceCommand | ( | double | dx,
 |  | double | dy )

Constructs a CXTPChartTranslateDeviceCommand object.

Parameters
dx | The change in X direction
dy | The change in Y direction
The documentation for this class was generated from the following file:
  • XTPChartTransformationDeviceCommand.h


Toolkit Pro: CXTPCheckboxButtonPart Class Reference

Public Member Functions | List of all members
CXTPCheckboxButtonPart Class Reference

This class implements Checkbox button part of the SwitchViewBar. More...

Inheritance diagram for CXTPCheckboxButtonPart:
[legend]

Public Member Functions

virtual void | AdjustLayout (CDC *pDC, const CRect &rcRect)
This member function is used to adjust the object's layout depending on the provided bounding rectangle.
virtual void | RefreshMetrics ()
Performs refreshing of graphical related parameters from system settings.
virtual void | Draw (CDC *pDC)
This member function is used to draw the part content utilizing the specified device context.
- Public Member Functions inherited from CXTPCalendarCaptionBarThemePart
CXTPCalendarCaptionBarThemePart (CXTPCalendarCaptionBarTheme *pTheme, int nPartID)
Default object constructor.
virtual | ~CXTPCalendarCaptionBarThemePart ()
Default object destructor.
virtual void | Redraw (BOOL bUpdateNow=FALSE)
This member function initiates the CalendarCaptionBar control's redrawing.
virtual BOOL | HitTest (const CPoint &pt) const
This member function is used to determine is the specified point over visible object rectangle.
virtual CXTPCalendarCaptionBarTheme * | GetTheme () const
This member function is used to obtain pointer to parent CXTPCalendarCaptionBarTheme object.
virtual XTPCalendarTheme | GetPaintTheme () const
This member function is used to obtain current paint theme.
virtual int | GetPartID () const
This member function is used to obtain an object identifier.
virtual CRect | GetRect () const
This member function is used to obtain an object rectangle.
virtual CString | GetText () const
This member function is used to obtain an object text.
virtual void | SetText (LPCTSTR pcszText)
This member function is used to set object text.
virtual BOOL | IsVisible () const
This member function is used to get is part object visible.
virtual void | SetVisible (BOOL bVisible)
This member function is used to set visible object's state.
virtual int | GetCheck () const
This member function is used to get checked state.
virtual void | SetCheck (int nCheck)
This member function is used to set checked state.
int | GetState () const
This member function is used to get object state (flags from CXTPCalendarCaptionBarThemePart::EStates enum).
virtual void | SetState (int nState)
This member function is used to set object state as set of flags from CXTPCalendarCaptionBarThemePart::EStates enum.
virtual COLORREF | GetTextColor ()
This member function is used to get object text color.
CXTPCalendarCaptionBarPaintManager * | GetPaintManager () const
Gets the paint manager.
virtual void | OnMouseMove (UINT nFlags, CPoint point)
This member function is used to processes mouse movement events.
virtual BOOL | OnLButtonDown (UINT nFlags, CPoint point)
This member function is used to process left mouse button down events.
virtual BOOL | OnLButtonUp (UINT nFlags, CPoint point)
This member function is used to process left mouse button up events.
- Public Member Functions inherited from CXTPCalendarWMHandler
CXTPCalendarWMHandler ()
Default object constructor.
virtual int | GetChildHandlersCount () const
This member function is used to obtain the number of CXTPCalendarWMHandler elements in the descendant handlers collection.
virtual CXTPCalendarWMHandler * | GetChildHandlerAt (int nIndex) const
Call this method to get a handler object at the specified numeric index.
virtual BOOL | OnLButtonDblClk (UINT nFlags, CPoint point)
This member function is used to process left mouse button double click events.
virtual void | OnChar (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process keyboard events.
virtual void | OnKeyDown (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process key-down keyboard events.
virtual void | OnKeyUp (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process key-up keyboard events.
virtual BOOL | OnSysKeyDown (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process key-up keyboard events.
virtual BOOL | OnTimer (UINT_PTR uTimerID)
The framework calls this member function after each interval specified in the SetTimer member function.
virtual BOOL | OnWndMsg (UINT message, WPARAM wParam, LPARAM lParam, LRESULT *pResult)
This method is called by framework after default message processing.
virtual void | OnPostAdjustLayout ()
This member function is used to perform additional adjustments in some kinds of views.
virtual void | OnBeforeDestroy ()
This member function is called by the framework before destroying the view.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPCalendarCaptionBarThemePart
CXTPPaintManagerColor | m_clrTextColor
Store the object's text color.
CRect | m_rcRect
Store a Part rectangle.
int | m_nState
Store a Part state.
CString | m_strText
Store a Part text.
- Protected Attributes inherited from CXTPCalendarCaptionBarThemePart
CXTPCalendarCaptionBarTheme * | m_pTheme
Store pointer to a parent theme object.
int | m_nPartID
Store a Part ID.
BOOL | m_bVisible
Store a Part visible state.

Detailed Description

This class implements Checkbox button part of the SwitchViewBar.

See also
CXTPCalendarCaptionBarThemePart

Member Function Documentation

◆ AdjustLayout()

virtual void AdjustLayout | ( | CDC * | pDC,
 |  | const CRect & | rcRect )
 virtual

This member function is used to adjust the object's layout depending on the provided bounding rectangle.

Parameters
pDC | Pointer to a valid device context (may be NULL).
rcRect | A CRect object containing the dimensions of the bounding rectangle for this part.

Reimplemented from CXTPCalendarCaptionBarThemePart.

◆ Draw()

virtual void Draw ( CDC * pDC )
virtual

This member function is used to draw the part content utilizing the specified device context.

Parameters
pDC Pointer to a valid device context.

Reimplemented from CXTPCalendarCaptionBarThemePart.

◆ RefreshMetrics()

virtual void RefreshMetrics ( )
virtual

Performs refreshing of graphical related parameters from system settings.

Base implementation do nothing.

Reimplemented from CXTPCalendarCaptionBarThemePart.

The documentation for this class was generated from the following file:
  • XTPCalendarCaptionBarThemePart.h


Toolkit Pro: CXTPCheckListBox Class Reference

Classes | Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPCheckListBox Class Reference

The CXTPCheckListBox class is a CXTPListBox derived class. More...

Inheritance diagram for CXTPCheckListBox:
[legend]

Classes

class CCheckListState
CCheckListState is a helper class used by CXTPCheckListBox that contains information about the checkbox image that is used by the check list box. More...

Public Member Functions

CXTPCheckListBox (BOOL bListBox3D=FALSE)
Constructs a CXTPCheckListBox object.
virtual | ~CXTPCheckListBox ()
Destroys a CXTPCheckListBox object, handles cleanup and deallocation.
virtual BOOL | Create (DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID)
Creates the Windows checklist box and attaches it to the CXTPListBox object.
void | SetCheckStyle (UINT nStyle)
Call this function to set the style of check boxes in the checklist box.
UINT | GetCheckStyle ()
Retrieves the CXTPCheckListBox style.
void | SetCheck (int nIndex, int nCheck)
Call this function to set the check box of the item specified by nIndex.
int | GetCheck (int nIndex)
Call this function to determine the check state of an item.
void | Enable (int nIndex, BOOL bEnabled=TRUE)
Call this function to enable/disable a checklist box item.
BOOL | IsEnabled (int nIndex)
Call this function to determine whether or not an item is enabled.
virtual CRect | OnGetCheckPosition (CRect rectItem, CRect rectCheckBox)
The framework calls this function to get the position and size of the check box in an item.
- Public Member Functions inherited from CXTPListBox
CXTPListBox ()
Constructs a CXTPListBox object.
virtual | ~CXTPListBox ()
Destroys a CXTPListBox object, handles cleanup and deallocation.
virtual void | Initialize (bool bAutoFont=true)
Call this member function to initialize the list box.
virtual COLORREF | GetBackColor ()
Called to retrieve the background color for the list box.
void | SetListStyle (XTPListBoxStyle style)
Call this method to set the style of the list box.
XTPListBoxStyle | GetListStyle () const
Call this method to retrieve the style of the list box.
void | SetTheme (XTPControlTheme nTheme)
This member function sets the drawing theme for the control.
virtual void | RefreshMetrics ()
Call this member function to refresh theme colors and redraw the control.
BOOL | HasFocus () const
Call this member function to determine if the list box control has input focus.

Protected Member Functions

virtual void | Init ()
This member function is called by the CXTPListBase class to perform initialization when a window is created or sub-classed.
virtual int | GetFontHeight ()
Retrieves the height for the font used by the check list box.
virtual int | PreCompareItem (LPCOMPAREITEMSTRUCT lpCompareItemStruct)
Called by the framework to determine the relative position of a new item in the check list box.
virtual int | CalcMinimumItemHeight ()
Called by the check list box to determine the minimum height for each item in the check list box.
virtual int | CheckFromPoint (CPoint point, BOOL &bInCheck)
Call this function to determine if a left mouse click occurred in the check box to the left of a list box item.
virtual void | PreDrawItem (LPDRAWITEMSTRUCT lpDrawItemStruct)
Called to paint the control to an off screen device context for a themed application.
virtual void | PreMeasureItem (LPMEASUREITEMSTRUCT lpMeasureItemStruct)
This function is called to measure the size of the item in the list box for proper handling of an owner drawn list box.
virtual void | PreDeleteItem (LPDELETEITEMSTRUCT lpDeleteItemStruct)
This function is called so that an owner drawn list box control can properly handle the delete item message WM_DELETEITEM.
virtual void | SetSelectionCheck (int nCheck)
Call this function to check all items in the list box that are currently highlighted and not disabled.
virtual void | InvalidateCheck (int nIndex)
Called by CXTPCheckListBox to redraw a check box.
virtual void | InvalidateItem (int nIndex)
Called by CXTPCheckListBox to redraw an item.
bool | PreDrawItemThemed (CDC *pDC, DRAWITEMSTRUCT &drawItem, int nCheck, int cyItem)
Called to paint the control to an off screen device context for a themed application.
void | PreDrawItemNonThemed (CDC *pDC, DRAWITEMSTRUCT &drawItem, int nCheck, int cyItem)
Called to paint the control to an off screen device context for a non-themed application.
- Protected Member Functions inherited from CXTPListBox
BOOL | TryItemFromPoint (CPoint pt, BOOL &bOutside, int &nIndex) const
This method determines the list box item nearest to the point specified in pt when there is at least one item in the list box.

Protected Attributes

int | m_cyText
Represents the text height for the check list box.
UINT | m_nStyle
Specifies the style for the check list box.
CCheckListState | m_checkListState
Holds the check mark image information.
CXTPWinThemeWrapper * | m_themeHelper
Used for drawing a Windows XP themed checkbox.
BOOL | m_bLastItemDrawnThemed
TRUE if the last item drawn was themed.

Additional Inherited Members

- Public Attributes inherited from CXTPListBox
CXTPListBoxTheme * | m_pTheme
Pointer to the currently active theme.
XTPControlTheme | m_theme
List box theme.
int | m_nItemHeight
Height of the items.
int | m_nTextPadding
Text padding.
int | m_nHotItem
Hot item index.

Detailed Description

The CXTPCheckListBox class is a CXTPListBox derived class.

It provides the functionality of an Office style checklist box. A "checklist box" displays a list of items such as filenames. Each item in the list has a check box next to it that the user can either check or clear.

CXTPCheckListBox is only for owner-drawn controls because the list contains more than text strings. At its simplest, a checklist box contains text strings and check boxes, but you do not need to have text at all. For example, you could have a list of small bitmaps with a check box next to each item.

To create your own checklist box, you must derive your own class from CXTPCheckListBox. To derive your own class, write a constructor for the derived class, then call Create.

If your checklist box is a default checklist box (a list of strings with the default-sized check boxes to the left of each), you can use the default CXTPCheckListBox::DrawItem to draw the checklist box. Otherwise, you must override the CListBox::CompareItem function and the CXTPCheckListBox::DrawItem and CXTPCheckListBox::MeasureItem functions.

Constructor & Destructor Documentation

◆ CXTPCheckListBox()

CXTPCheckListBox ( BOOL bListBox3D = FALSE )

Constructs a CXTPCheckListBox object.

Parameters
bListBox3D TRUE to use 3D list box checkmarks.

Member Function Documentation

◆ CalcMinimumItemHeight()

virtual int CalcMinimumItemHeight ( )
protectedvirtual

Called by the check list box to determine the minimum height for each item in the check list box.

Returns
An integer that represents the minimum item height.

◆ CheckFromPoint()

virtual int CheckFromPoint | ( | CPoint | point,
 |  | BOOL & | bInCheck )
 protectedvirtual

Call this function to determine if a left mouse click occurred in the check box to the left of a list box item.

Parameters
point | A CPoint object that specifies the x- and y- coordinates where the left mouse button was clicked.
bInCheck | TRUE if the current list box item is checked.
Returns
The index of the list box item that was checked. If no list box item was checked, then return -1.

◆ Create()

virtual BOOL Create | ( | DWORD | dwStyle,
 |  | const RECT & | rect,
 |  | CWnd * | pParentWnd,
 |  | UINT | nID )
 virtual

Creates the Windows checklist box and attaches it to the CXTPListBox object.

Parameters
dwStyle | Specifies the style of the checklist box. The style must be either LBS_OWNERDRAWFIXED (all items in the list are the same height) or LBS_OWNERDRAWVARIABLE (items in the list are of varying heights). This style can be combined with other list-box styles.
rect | Specifies the checklist-box size and position. Can be either a CRect object or a RECT structure.
pParentWnd | Specifies the checklist box's parent window (usually a CDialog object). It must not be NULL.
nID | Specifies the checklist box's control ID.
Returns
Nonzero if successful, otherwise 0.

◆ Enable()

void Enable | ( | int | nIndex,
 |  | BOOL | bEnabled = TRUE )

Call this function to enable/disable a checklist box item.

Parameters
nIndex | Index of the checklist box item to be enabled.
bEnabled | TRUE to enable the checklist box item, FALSE to disable.

◆ GetCheck()

int GetCheck ( int nIndex )

Call this function to determine the check state of an item.

Parameters
nIndex Index of the item whose check status is to be retrieved.
Returns
Zero if the item is not checked, 1 if it is checked, and 2 if it is indeterminate.

◆ GetCheckStyle()

UINT GetCheckStyle ( )

Retrieves the CXTPCheckListBox style.

Call this function to get the checklist box's style. For information on possible styles, see SetCheckStyle.

Returns
The style of the control's check boxes.
See also
SetCheckStyle

◆ GetFontHeight()

virtual int GetFontHeight ( )
protectedvirtual

Retrieves the height for the font used by the check list box.

Returns
An integer that represents the font height.

◆ InvalidateCheck()

virtual void InvalidateCheck ( int nIndex )
protectedvirtual

Called by CXTPCheckListBox to redraw a check box.

Parameters
nIndex Integer value that specifies the index of the value to invalidate.

This member function determines the size of the bounding rectangle of the selected item's check box. Then it calls invalidate rectangle so that the background of the rectangle is redrawn during the next WM_PAINT message.

◆ InvalidateItem()

virtual void InvalidateItem ( int nIndex )
protectedvirtual

Called by CXTPCheckListBox to redraw an item.

Parameters
nIndex Integer value that specifies the index of the value to invalidate.

This member function determines the size of the bounding rectangle of the selected item. Then it calls invalidate rectangle so that the item's background is redrawn during the next WM_PAINT message.

◆ IsEnabled()

BOOL IsEnabled ( int nIndex )

Call this function to determine whether or not an item is enabled.

Parameters
nIndex Index of the item.
Returns
Nonzero if the item is enabled, otherwise 0.

◆ OnGetCheckPosition()

virtual CRect OnGetCheckPosition | ( | CRect | rectItem,
 |  | CRect | rectCheckBox )
 virtual

The framework calls this function to get the position and size of the check box in an item.

Parameters
rectItem | The position and size of the list item.
rectCheckBox | The default position and size of an item's check box.

The default implementation only returns the default position and size of the check box (rectCheckBox). By default, a check box is aligned in the upper-left corner of an item and is the standard check box size. There may be cases where you want the check boxes on the right or want a larger or smaller check box. In these cases, override OnGetCheckPosition to change the check box position and size within the item.

Example: The following function overrides the default and puts the check box on the right of the item, makes it the same height as the item (minus a pixel offset at the top and bottom), and makes it the standard check box width:

CRect CMyCheckListBox::OnGetCheckPosition(CRect rectItem, CRect rectCheckBox)
{
   CRect rectMyCheckBox;
   rectMyCheckBox.top = rectItem.top -1;
   rectMyCheckBox.bottom = rectItem.bottom -1;
   rectMyCheckBox.right = rectItem.right -1;
   rectMyCheckBox.left = rectItem.right -1 rectCheckBox.Width();
   return rectMyCheckBox;
}
Returns
The position and size of an item's check box.

◆ PreCompareItem()

virtual int PreCompareItem ( LPCOMPAREITEMSTRUCT lpCompareItemStruct )
protectedvirtual

Called by the framework to determine the relative position of a new item in the check list box.

Parameters
lpCompareItemStruct Pointer to a COMPAREITEMSTRUCT struct.
Returns
Indicates the relative position of the two items described in the COMPAREITEMSTRUCT structure. It may be any of the following values:

-1: Item 1 sorts before item 2. 0: Item 1 and item 2 sort the same. 1: Item 1 sorts after item 2.

See CWnd::OnCompareItem for a description of the COMPAREITEMSTRUCT structure.

◆ PreDeleteItem()

virtual void PreDeleteItem ( LPDELETEITEMSTRUCT lpDeleteItemStruct )
protectedvirtual

This function is called so that an owner drawn list box control can properly handle the delete item message WM_DELETEITEM.

Parameters
lpDeleteItemStruct A LPDELETEITEMSTRUCT struct that contains information about the items to delete. The DELETEITEMSTRUCT structure has the following form:
typedef struct tagDELETEITEMSTRUCT {
   UINT CtlType;
   UINT CtlID;
   UINT itemID;
   HWND hwndItem;
   UINT itemData;
} DELETEITEMSTRUCT;

The DELETEITEMSTRUCT structure describes a deleted owner-drawn list box or combobox item.

◆ PreDrawItem()

virtual void PreDrawItem ( LPDRAWITEMSTRUCT lpDrawItemStruct )
protectedvirtual

Called to paint the control to an off screen device context for a themed application.

Parameters
lpDrawItemStruct Contains information about the item to draw. The DRAWITEMSTRUCT structure provides information that the owner window must have to determine how to paint an owner-drawn control or menu item.
typedef struct tagDRAWITEMSTRUCT {
   UINT   CtlType;
   UINT   CtlID;
   UINT   itemID;
   UINT   itemAction;
   UINT   itemState;
   HWND   hwndItem;
   HDC    hDC;
   RECT   rcItem;
   DWORD  itemData;
} DRAWITEMSTRUCT;

Call this function to pre-draw the item to a memory DC or to the ThemeManager. This prevents flickering of the window during drawing.

◆ PreDrawItemNonThemed()

void PreDrawItemNonThemed | ( | CDC * | pDC,
 |  | DRAWITEMSTRUCT & | drawItem,
 |  | int | nCheck,
 |  | int | cyItem )
 protected

Called to paint the control to an off screen device context for a non-themed application.

Parameters
pDC | A CDC pointer that represents the current device context.
drawItem | A DRAWITEMSTRUCT that contains information about the item to draw. This is necessary because the list box is an owner drawn control.
nCheck | Integer value that specifies the check state. 1 for checked, 0 for not checked, and 2 for intermediate.
cyItem | The vertical position of the item in the list box.

Call this function to pre-draw an item in a non-themed application. This is used to prevent flickering when re-drawing the control.

◆ PreDrawItemThemed()

bool PreDrawItemThemed | ( | CDC * | pDC,
 |  | DRAWITEMSTRUCT & | drawItem,
 |  | int | nCheck,
 |  | int | cyItem )
 protected

Called to paint the control to an off screen device context for a themed application.

Parameters
pDC | A CDC pointer that represents the current device context.
drawItem | A DRAWITEMSTRUCT that contains information about the item to draw. This is necessary because the list box is an owner drawn control.
nCheck | Integer value that specifies the check state. 1 for checked, 0 for not checked, and 2 for intermediate.
cyItem | The vertical position of the item in the list box.

Call this function to pre-draw an item in a themed application. This is used to prevent flickering when re-drawing the control.

Returns
Returns true if the item is successfully drawn, otherwise false. Also, if the application is not themed, then this function returns false.

◆ PreMeasureItem()

virtual void PreMeasureItem ( LPMEASUREITEMSTRUCT lpMeasureItemStruct )
protectedvirtual

This function is called to measure the size of the item in the list box for proper handling of an owner drawn list box.

Parameters
lpMeasureItemStruct A LPMEASUREITEMSTRUCT struct. The MEASUREITEMSTRUCT structure informs Windows of the dimensions of an owner-drawn control or menu item. This allows Windows to process user interaction with the control correctly. Failure to fill out the proper members in the MEASUREITEMSTRUCT structure will cause improper operation of the control.
typedef struct tagMEASUREITEMSTRUCT {
   UINT   CtlType;
   UINT   CtlID;
   UINT   itemID;
   UINT   itemWidth;
   UINT   itemHeight;
   DWORD  itemData
} MEASUREITEMSTRUCT;

itemWidth specifies the width of a menu item. The owner of the owner-draw menu item must fill this member before it returns from the message.

itemHeight specifies the height of an individual item in a list box or a menu. The owner of the owner-draw combobox, list box, or menu item must fill out this member before it returns from the message. The maximum height of a list box item is 255.

◆ SetCheck()

void SetCheck | ( | int | nIndex,
 |  | int | nCheck )

Call this function to set the check box of the item specified by nIndex.

Parameters
nIndex | Index of the item whose check box is to be set.
nCheck | State of the check box: 0 for clear, 1 for checked, and 2 for indeterminate.

◆ SetCheckStyle()

void SetCheckStyle ( UINT nStyle )

Call this function to set the style of check boxes in the checklist box.

Parameters
nStyle Determines the style of check boxes in the checklist box. See the Remarks section for available styles.

Styles to be added or removed can be combined by using the bitwise OR (|) operator. It can be one of the following: BS_3STATE: Same as a check box, except that the box can be dimmed as well as checked. The dimmed state typically is used to show that a check box has been disabled. BS_AUTO3STATE: Same as a three-state check box, except that the box changes its state when the user selects it. BS_AUTOCHECKBOX: Same as a check box, except that a check mark appears in the check box when the user selects the box. The check mark disappears the next time that the user selects the box. BS_CHECKBOX: Creates a small square that has text displayed to its right (unless this style is combined with the BS_LEFTTEXT style). For information on these styles, see Button Styles.

◆ SetSelectionCheck()

virtual void SetSelectionCheck ( int nCheck )
protectedvirtual

Call this function to check all items in the list box that are currently highlighted and not disabled.

Parameters
nCheck Integer value that specifies the check state. 1 for checked, 0 for not checked, and 2 for intermediate.
The documentation for this class was generated from the following file:
  • XTPCheckListBox.h


Toolkit Pro: CXTPCheckListBox::CCheckListState Class Reference

  • CXTPCheckListBox
  • CCheckListState
Public Member Functions | Public Attributes | List of all members
CXTPCheckListBox::CCheckListState Class Reference

CCheckListState is a helper class used by CXTPCheckListBox that contains information about the checkbox image that is used by the check list box. More...

Public Member Functions

CCheckListState (BOOL bListBox3D)
Constructs a CCheckListState object.
void | Draw (CDC *pDC, int nCheck, CPoint pt, CSize sz)
Draws the state icon.
virtual | ~CCheckListState ()
Destroys a CCheckListState object, handles cleanup and deallocation.

Public Attributes

CSize | m_sizeCheck
Width and height of the check mark bitmap.
CSize | m_sizeCheckThemed
Width and height of the check mark themed image.

Detailed Description

CCheckListState is a helper class used by CXTPCheckListBox that contains information about the checkbox image that is used by the check list box.

Constructor & Destructor Documentation

◆ CCheckListState()

CCheckListState ( BOOL bListBox3D )

Constructs a CCheckListState object.

Parameters
bListBox3D TRUE to use 3D list box checkmarks.

Member Function Documentation

◆ Draw()

void Draw | ( | CDC * | pDC,
 |  | int | nCheck,
 |  | CPoint | pt,
 |  | CSize | sz )

Draws the state icon.

Parameters
pDC | A CDC pointer.
nCheck | Checkbox state.
pt | A CPoint object that specifies the x- and y- coordinates of the drawing.
sz | Size of the checkbox item.
The documentation for this class was generated from the following file:
  • XTPCheckListBox.h


Toolkit Pro: CXTPClientCursorPos Class Reference

Public Member Functions | List of all members
CXTPClientCursorPos Class Reference

CXTPClientCursorPos is a helper class used to retrieve the cursor position in client coordinates. More...

Public Member Functions

CXTPClientCursorPos (CWnd *pWnd)
Constructs a CXTPClientCursorPos object used to retrieve the cursor position in client coordinates.

Detailed Description

CXTPClientCursorPos is a helper class used to retrieve the cursor position in client coordinates.

Constructor & Destructor Documentation

◆ CXTPClientCursorPos()

CXTPClientCursorPos ( CWnd * pWnd )

Constructs a CXTPClientCursorPos object used to retrieve the cursor position in client coordinates.

Parameters
pWnd Pointer to the window that contains the client area to get the cursor position for.
The documentation for this class was generated from the following file:
  • XTPDrawHelpers.h


Toolkit Pro: CXTPClientRect Class Reference

Public Member Functions | List of all members
CXTPClientRect Class Reference

CXTPClientRect is a helper class used to retrieve the client area for a specified window. More...

Public Member Functions

CXTPClientRect (HWND hWnd)
Constructs a CXTPClientRect object used to retrieve the client area for the specified window.
CXTPClientRect (const CWnd *pWnd)
Constructs a CXTPClientRect object used to retrieve the client area for the specified window.

Detailed Description

CXTPClientRect is a helper class used to retrieve the client area for a specified window.

Constructor & Destructor Documentation

◆ CXTPClientRect() [1/2]

CXTPClientRect ( HWND hWnd )

Constructs a CXTPClientRect object used to retrieve the client area for the specified window.

Parameters
hWnd Handle to the window to retrieve the client area for.

◆ CXTPClientRect() [2/2]

CXTPClientRect ( const CWnd * pWnd )

Constructs a CXTPClientRect object used to retrieve the client area for the specified window.

Parameters
pWnd Points to the window to retrieve the client area for.
The documentation for this class was generated from the following file:
  • XTPDrawHelpers.h


Toolkit Pro: CXTPCmdTarget Class Reference

Public Member Functions | Static Public Member Functions | List of all members
CXTPCmdTarget Class Reference

The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issues and limitations of CCmdTarget. More...

Inheritance diagram for CXTPCmdTarget:
[legend]

Public Member Functions

CXTPCmdTarget ()
Constructs command target instance.

Static Public Member Functions

static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issues and limitations of CCmdTarget.

Member Function Documentation

◆ FromIDispatchSafe()

static CCmdTarget *AFX_CDECL FromIDispatchSafe ( IDispatch * pDisp )
static

Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Unlike CCmdTarget::FromIDispatch that has side-effects in certain configurations FromIDispatchSafe guaranties correct CCmdTarget pointer as a result value if an object that provides IDispatch interface is either derived from CXTPCmdTarget or only exposes IXTPCmdTargetProvider interface. If the object does not expose IXTPCmdTargetProvider interface the implementation fall back to CCmdTarget::FromIDispatch.

Parameters
pDisp IDispatch pointer for which CCmdTarget pointer is to be obtained.
Returns
Obtained CCmdTarget pointer value or NULL when it cannot be obtained.
The documentation for this class was generated from the following file:
  • XTPFramework.h


Toolkit Pro: CXTPColorBase Class Reference

Public Types | Public Member Functions | Static Public Member Functions | Public Attributes | Protected Member Functions | Protected Attributes | Static Protected Attributes | List of all members
CXTPColorBase Class Reference

CXTPColorBase is a CStatic derived base class. More...

Inheritance diagram for CXTPColorBase:
[legend]

Public Types

enum FocusedControl { focusNone , focusColorWheel , focusLumination }
Enumeration used to determine window focus. More...

Public Member Functions

CXTPColorBase ()
Constructs a CXTPColorBase object.
virtual | ~CXTPColorBase ()
Destroys a CXTPColorBase object, handles cleanup and deallocation.
virtual void | UpdateCursorPos (CPoint point)
Call this member function to update the cursor position.

Static Public Member Functions

static void AFX_CDECL | RGBtoHSL (COLORREF color, double *h, double *s, double *l)
This member function is called to convert an RGB color value to an HSL value.
static COLORREF AFX_CDECL | HLStoRGB (double h, double l, double s)
This member function is called to convert an HLS value to an RGB color value.

Public Attributes

double | m_nLum
Current illumination value.
double | m_nSat
Current saturation value.
double | m_nHue
Current hue value.
CPoint | m_ptMousePos
Current mouse position relative to the device context.

Protected Member Functions

virtual bool Init ()
This member function is called by the CXTPColorBase class to perform initialization when the window is created or sub-classed.

Protected Attributes

bool m_bPreSubclassInit
true when initializing from PreSubclassWindow.

Static Protected Attributes

static FocusedControl m_eHasFocus
Determines which property page has input focus.

Detailed Description

CXTPColorBase is a CStatic derived base class.

It is used to create custom color selection windows.

Member Enumeration Documentation

◆ FocusedControl

enum FocusedControl

Enumeration used to determine window focus.

FocusControl type defines the constants used by CXTPColorBase for determining which area of the color window control has focus.

See also
CXTPColorBase
focusNone, focusColorWheel, focusLumination>
Enumerator
focusNone | Color window does not have input focus.
focusColorWheel | Color wheel window has focus.
focusLumination | Lumination window has focus.

Member Function Documentation

◆ HLStoRGB()

static COLORREF AFX_CDECL HLStoRGB | ( | double | h,
 |  | double | l,
 |  | double | s )
 static

This member function is called to convert an HLS value to an RGB color value.

Parameters
h | Represents the color hue.
l | Represents the color illumination.
s | Represents the color saturation.
Returns
A COLORREF value.

◆ Init()

virtual bool Init ( )
protectedvirtual

This member function is called by the CXTPColorBase class to perform initialization when the window is created or sub-classed.

Returns
TRUE if the window was successfully initialized, otherwise FALSE.

◆ RGBtoHSL()

static void AFX_CDECL RGBtoHSL | ( | COLORREF | color,
 |  | double * | h,
 |  | double * | s,
 |  | double * | l )
 static

This member function is called to convert an RGB color value to an HSL value.

Parameters
color | An RGB value that represents the value to convert to HSL.
h | Represents the color hue.
s | Represents the color saturation.
l | Represents the color illumination.
Returns

◆ UpdateCursorPos()

virtual void UpdateCursorPos ( CPoint point )
virtual

Call this member function to update the cursor position.

Parameters
point Current cursor location relative to the device context.

Reimplemented in CXTPColorLum, and CXTPColorWnd.

The documentation for this class was generated from the following file:
  • XTPColorPageCustom.h


Toolkit Pro: CXTPColorDialog Class Reference

Public Member Functions | Static Public Member Functions | Protected Attributes | List of all members
CXTPColorDialog Class Reference

CXTPColorDialog is a CPropertySheet derived class. More...

Public Member Functions

CXTPColorDialog (COLORREF clrNew, COLORREF clrCurrent, DWORD dwFlags=0L, CWnd *pWndParent=NULL)
Constructs a CXTPColorDialog object.
virtual | ~CXTPColorDialog ()
Destroys a CXTPColorDialog object, handles cleanup and deallocation.
void | SetNewColor (COLORREF clr, BOOL bNotify=TRUE)
Sets the active color for the dialog.
void | SetCurrentColor (COLORREF clr)
Call this function to set the new color selection to the color value specified in 'clr'.
COLORREF | GetCurrentColor ()
Call this member function to retrieve the RGB information for the current color.
COLORREF | GetColor ()
Call this member function to retrieve the RGB information for the color that the user selected.
BOOL | CopyToClipboard (const CString &strText)
Call this member function to copy the string specified by 'strText' to the Windows clipboard.
virtual void | CalculateRects ()
Calculates the size of the dialog's tab control.

Static Public Member Functions

static CString AFX_CDECL RGBtoHex (COLORREF clr)
This member function returns a CString object that represents the HEX conversion for the specified RGB color.

Protected Attributes

DWORD | m_dwStyle
Styles for the dialog.
CEdit | m_wndHexEdit
Edit window to display the color hex value.
CXTPEyeDropper | m_wndEyeDropper
Eye dropper control.
CRect | m_rcNew
Size of the rectangle that represents the new color.
CRect | m_rcCurrent
Size of the rectangle that represents the current color.
COLORREF | m_clrNew
A COLORREF value that contains the RGB information for the new color.
COLORREF | m_clrCurrent
A COLORREF value that contains the RGB information for the current color.

Detailed Description

CXTPColorDialog is a CPropertySheet derived class.

It is an Office(tm) style color dialog and can be used as a drop in replacement for the MFC CColorDialog API.

Constructor & Destructor Documentation

◆ CXTPColorDialog()

CXTPColorDialog | ( | COLORREF | clrNew,
 |  | COLORREF | clrCurrent,
 |  | DWORD | dwFlags = 0L,
 |  | CWnd * | pWndParent = NULL )

Constructs a CXTPColorDialog object.

Parameters
clrNew | An RGB value that represents the new color selection.
clrCurrent | An RGB value that represents the default color selection.
dwFlags | Style for color dialog. See the Remarks section for available styles.
pWndParent | A pointer to the dialog box's parent or owner window.

Styles to be added or removed can be combined by using the bitwise OR (|) operator. It can be one or more of the following: CPS_XTP_SHOW3DSELECTION: Displays the color selection box with a 3D raised border. CPS_XTP_SHOWHEXVALUE: Displays the hex equivalent of the selected color.

See also
CXTPColorPopup::Create, CXTPColorSelectorCtrl::Create, CXTPColorPicker::ModifyCPStyle

Member Function Documentation

◆ CalculateRects()

virtual void CalculateRects ( )
virtual

Calculates the size of the dialog's tab control.

This function is used to calculate the size of the dialog's tab control, the first tab item, the size of the OK button, and the size of the cancel button. Then, resize the tab control to fit on the dialog. Also, reposition the OK and Cancel buttons. Next, reposition the Hex-Display. Finally, resize the property sheet.

◆ CopyToClipboard()

BOOL CopyToClipboard ( const CString & strText )

Call this member function to copy the string specified by 'strText' to the Windows clipboard.

Parameters
strText A NULL-terminated string.
Returns
TRUE if successful, otherwise FALSE.

◆ GetColor()

COLORREF GetColor ( )

Call this member function to retrieve the RGB information for the color that the user selected.

Returns
A COLORREF value that contains the RGB information for the new color selected in the color dialog box.

◆ GetCurrentColor()

COLORREF GetCurrentColor ( )

Call this member function to retrieve the RGB information for the current color.

Returns
A COLORREF value that contains the RGB information for the current color specified when the dialog was instantiated.

◆ RGBtoHex()

static CString AFX_CDECL RGBtoHex ( COLORREF clr )
static

This member function returns a CString object that represents the HEX conversion for the specified RGB color.

Parameters
clr An RGB value that represents the color.
Returns
A CString object.

◆ SetCurrentColor()

void SetCurrentColor ( COLORREF clr )

Call this function to set the new color selection to the color value specified in 'clr'.

Parameters
clr An RGB value that represents the color.

◆ SetNewColor()

void SetNewColor | ( | COLORREF | clr,
 |  | BOOL | bNotify = TRUE )

Sets the active color for the dialog.

Parameters
clr | An RGB value that represents the color.
bNotify | TRUE to notify tab pages of a color change.

Call this member function to set the current color selection to the color value specified in 'clr'. The dialog box will automatically update the user's selection based on the value of the 'clr' parameter.

The documentation for this class was generated from the following file:
  • XTPColorDialog.h


Toolkit Pro: CXTPColorHex Class Reference

Classes | Public Member Functions | Protected Types | Protected Member Functions | Protected Attributes | List of all members
CXTPColorHex Class Reference

CXTPColorHex is a CStatic derived class. More...

Classes

class CRgnCell
CRgnCell is a CRgn derived class used by the CXTPColorHex to create individual color cells. More...

Public Member Functions

CXTPColorHex ()
Constructs a CXTPColorHex object.
virtual | ~CXTPColorHex ()
Destroys a CXTPColorHex object, handles cleanup and deallocation.
COLORREF | ColorFromPoint (CPoint point)
Call this member function to retrieve RGB information for the color found at a location specified by 'point'.
CRgnCell * | GetColorCell (int iIndex)
Call this member function to retrieve a pointer to a CRgnCell object that represents information for a color cell specified by either the list 'iIndex' or RGB 'color'.
CRgnCell * | GetColorCell (COLORREF color)
Call this member function to retrieve a pointer to a CRgnCell object that represents information for a color cell specified by either the list 'iIndex' or RGB 'color'.
BOOL | SetSelectedColor (int iIndex, BOOL bNotify=TRUE)
Call this member function to set the selected color using either the list 'iIndex' or RGB 'color'.
BOOL | SetSelectedColor (COLORREF color, BOOL bNotify=TRUE)
Call this member function to set the selected color using either the list 'iIndex' or RGB 'color'.
COLORREF | GetSelectedColor () const
Call this member function to return the currently selected color.

Protected Types

typedef CList< CRgnCell *, CRgnCell * > CRgnCellList
List for maintaining CRgnCell objects.

Protected Member Functions

virtual bool | Init ()
This member function is called by the CXTPColorHex class to perform initialization when the window is created or sub-classed.
BOOL | UpdateSelection (CPoint point, BOOL bNotify=TRUE)
This member function updates the color selection based on the x- and y- coordinates specified by 'point'.
BOOL | UpdateSelection (CRgnCell *pCell, BOOL bNotify=TRUE)
This member function updates the color selection based on the x- and y- coordinates specified by 'point'.
virtual bool | IsValidColor (COLORREF color) const
This member function is called to determine if a specified color is defined in the color array.
void | CreateCellArray ()
This member function is called by the CXTPColorHex class to build the array of color cells used to render the hex color control.

Protected Attributes

CBitmap | m_bmpPicker
Background device context.
bool | m_bPreSubclassInit
true when initializing from PreSubclassWindow.
COLORREF | m_clrColor
A COLORREF value that contains the RGB information for the current color.
CRgnCellList | m_rgnList
Array of CRgnCellList objects that represent displayed color cells.
CRgnCell * | m_pCell
Pointer to a CRgnCell object that represents the currently selected color.

Detailed Description

CXTPColorHex is a CStatic derived class.

It displays a color selection grid used by CXTPColorPageStandard.

Member Typedef Documentation

◆ CRgnCellList

CList<CRgnCell*, CRgnCell*> CRgnCellList
protected

List for maintaining CRgnCell objects.

CList definition used by the CXTPColorHex control to maintain a list of CRgnCell objects representing each color cell in the hex color control.

See also
CXTPColorHex, CRgnCell

Member Function Documentation

◆ ColorFromPoint()

COLORREF ColorFromPoint ( CPoint point )

Call this member function to retrieve RGB information for the color found at a location specified by 'point'.

Parameters
point Represents the x- and y- coordinates of the cell to retrieve RGB color information for.
Returns
A COLORREF value.

◆ GetColorCell() [1/2]

CRgnCell * GetColorCell ( COLORREF color )

Call this member function to retrieve a pointer to a CRgnCell object that represents information for a color cell specified by either the list 'iIndex' or RGB 'color'.

Parameters
color An RGB value that represents the color.
Returns
A pointer to a CRgnCell object.

◆ GetColorCell() [2/2]

CRgnCell * GetColorCell ( int iIndex )

Call this member function to retrieve a pointer to a CRgnCell object that represents information for a color cell specified by either the list 'iIndex' or RGB 'color'.

Parameters
iIndex Index into m_rgnList list.
Returns
A pointer to a CRgnCell object.

◆ GetSelectedColor()

COLORREF GetSelectedColor ( ) const

Call this member function to return the currently selected color.

Returns
An RGB color value that represents the currently selected color.

◆ Init()

virtual bool Init ( )
protectedvirtual

This member function is called by the CXTPColorHex class to perform initialization when the window is created or sub-classed.

Returns
TRUE if the window was successfully initialized, otherwise FALSE.

◆ IsValidColor()

virtual bool IsValidColor ( COLORREF color ) const
protectedvirtual

This member function is called to determine if a specified color is defined in the color array.

Parameters
color A COLORREF value to check.
Returns
true if the specified color is defined in the color array, otherwise false.

◆ SetSelectedColor() [1/2]

BOOL SetSelectedColor | ( | COLORREF | color,
 |  | BOOL | bNotify = TRUE )

Call this member function to set the selected color using either the list 'iIndex' or RGB 'color'.

Parameters
color | An RGB value that represents the color.
bNotify | TRUE to send a WM_XTP_UPDATECOLOR notification to the owner window indicating that the color has changed.
Returns
TRUE if the color cell was selected, otherwise FALSE.

◆ SetSelectedColor() [2/2]

BOOL SetSelectedColor | ( | int | iIndex,
 |  | BOOL | bNotify = TRUE )

Call this member function to set the selected color using either the list 'iIndex' or RGB 'color'.

Parameters
iIndex | Index into m_rgnList list.
bNotify | TRUE to send a WM_XTP_UPDATECOLOR notification to the owner window indicating that the color has changed.
Returns
TRUE if the color cell was selected, otherwise FALSE.

◆ UpdateSelection() [1/2]

BOOL UpdateSelection | ( | CPoint | point,
 |  | BOOL | bNotify = TRUE )
 protected

This member function updates the color selection based on the x- and y- coordinates specified by 'point'.

Parameters
point | Current x- and y- coordinates of the color to select.
bNotify | TRUE to send a WM_XTP_UPDATECOLOR notification to the owner window indicating that the color has changed.
Returns
TRUE if successful; otherwise FALSE.

◆ UpdateSelection() [2/2]

BOOL UpdateSelection | ( | CRgnCell * | pCell,
 |  | BOOL | bNotify = TRUE )
 protected

This member function updates the color selection based on the x- and y- coordinates specified by 'point'.

Parameters
pCell | Pointer a CRgnCell object to select.
bNotify | TRUE to send a WM_XTP_UPDATECOLOR notification to the owner window indicating that the color has changed.
Returns
TRUE if successful; otherwise FALSE.
The documentation for this class was generated from the following file:
  • XTPColorPageStandard.h


Toolkit Pro: CXTPColorHex::CRgnCell Class Reference

  • CXTPColorHex
  • CRgnCell
Classes | Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPColorHex::CRgnCell Class Reference

CRgnCell is a CRgn derived class used by the CXTPColorHex to create individual color cells. More...

Classes

struct CTX_DATA
Contains pre-computed hexagon data for both small and big hexagons. More...

Public Member Functions

CRgnCell (const CTX_DATA &data, CXTPRectF &rect, COLORREF color, float u, float d)
Constructs a CRgnCell object.
CRgnCell (const CTX_DATA &data, CXTPRectF &rect, COLORREF color, float u, float d, float x, float y, BOOL bLarge=FALSE)
Constructs a CRgnCell object.

Protected Member Functions

virtual BOOL | DrawCell (CDC *pDC)
Used by the CRgnCell to render each color cell.
virtual BOOL | DrawSelection (CDC *pDC)
Used by the CRgnCell to display a selection around the active color cell.

Protected Attributes

int | m_iCell [2]
Index array that indicates which cell should be selected when the up or down arrow key is pressed.
COLORREF | m_color
An RGB value that represents the color of the cell.
CXTPRectF | m_rect
Represents the size and position of the color cell.
CXTPPoint2f | m_pts [6]
CPoint array that represents the x- and y- coordinates for each vertex of the cell's polygon.

Detailed Description

CRgnCell is a CRgn derived class used by the CXTPColorHex to create individual color cells.

Constructor & Destructor Documentation

◆ CRgnCell() [1/2]

CRgnCell | ( | const CTX_DATA & | data,
 |  | CXTPRectF & | rect,
 |  | COLORREF | color,
 |  | float | u,
 |  | float | d )

Constructs a CRgnCell object.

Parameters
data | Pre-computed data.
rect | Returns a reference to a CRect object that represents the size and position of the color cell.
color | An RGB value that represents the color of the cell to draw.
u | Index of the cell to be selected when VK_UP is pressed.
d | Index of the cell to be selected when VK_DOWN is pressed.

◆ CRgnCell() [2/2]

CRgnCell | ( | const CTX_DATA & | data,
 |  | CXTPRectF & | rect,
 |  | COLORREF | color,
 |  | float | u,
 |  | float | d,
 |  | float | x,
 |  | float | y,
 |  | BOOL | bLarge = FALSE )

Constructs a CRgnCell object.

Parameters
data | Pre-computed data.
rect | Returns a reference to a CRect object that represents the size and position of the color cell.
color | An RGB value that represents the color of the cell to draw.
u | Index of the cell to be selected when VK_UP is pressed.
d | Index of the cell to be selected when VK_DOWN is pressed.
x | Specifies the left position of CRgnCell.
y | Specifies the top of CRgnCell.
bLarge | TRUE if the cell size is large.

Member Function Documentation

◆ DrawCell()

virtual BOOL DrawCell ( CDC * pDC )
protectedvirtual

Used by the CRgnCell to render each color cell.

Parameters
pDC A CDC pointer that represents the current device context.
Returns
TRUE if the color cell was successfully drawn, otherwise FALSE.

◆ DrawSelection()

virtual BOOL DrawSelection ( CDC * pDC )
protectedvirtual

Used by the CRgnCell to display a selection around the active color cell.

Parameters
pDC A CDC pointer that represents the current device context.
Returns
TRUE if the color cell was successfully drawn, otherwise FALSE.
The documentation for this class was generated from the following file:
  • XTPColorPageStandard.h


Toolkit Pro: CXTPColorHex::CRgnCell::CTX_DATA Struct Reference

  • CXTPColorHex
  • CRgnCell
  • CTX_DATA
Classes | Public Attributes | List of all members
CXTPColorHex::CRgnCell::CTX_DATA Struct Reference

Contains pre-computed hexagon data for both small and big hexagons. More...

Classes

struct HEXAGON_DATA
Describes pre-computed hexagon data. More...

Public Attributes

HEXAGON_DATA | lg
Large hexagon data.
HEXAGON_DATA | sm
Small hexagon data.

Detailed Description

Contains pre-computed hexagon data for both small and big hexagons.

The documentation for this struct was generated from the following file:
  • XTPColorPageStandard.h


Toolkit Pro: CXTPColorHex::CRgnCell::CTX_DATA::HEXAGON_DATA Struct Reference

  • CXTPColorHex
  • CRgnCell
  • CTX_DATA
  • HEXAGON_DATA
Public Attributes | List of all members
CXTPColorHex::CRgnCell::CTX_DATA::HEXAGON_DATA Struct Reference

Describes pre-computed hexagon data. More...

Public Attributes

float | width
Hexagon width.
float | half
Hexagon half.
float | height
Hexagon height.
float | roof
Hexagon roof.
float | side
Hexagon side.

Detailed Description

Describes pre-computed hexagon data.

The documentation for this struct was generated from the following file:
  • XTPColorPageStandard.h


Toolkit Pro: CXTPColorLum Class Reference

Public Member Functions | List of all members
CXTPColorLum Class Reference

CXTPColorLum is a CXTPColorBase derived class. More...

Inheritance diagram for CXTPColorLum:
[legend]

Public Member Functions

CXTPColorLum ()
Constructs a CXTPColorLum object.
virtual | ~CXTPColorLum ()
Destroys a CXTPColorLum object, handles cleanup and deallocation.
virtual void | SetColor (double nHue, double nSat)
Call this member function to set the color for the selection window.
virtual void | UpdateCursorPos (CPoint point)
Call this member function to update the cursor position.
void | DrawSliderArrow (CDC *pDC)
This member function is called to draw the indicator arrow.
void | DrawLuminanceBar (CDC *pDC)
This member function is called to draw the selection bar.
void | SetLuminance (double l)
This member function is called to set the luminance for the color window.
void | GetLumBarRect (CRect &rect)
This member function is called to retrieve the display size of the luminance bar.
- Public Member Functions inherited from CXTPColorBase
CXTPColorBase ()
Constructs a CXTPColorBase object.
virtual | ~CXTPColorBase ()
Destroys a CXTPColorBase object, handles cleanup and deallocation.

Additional Inherited Members

- Public Types inherited from CXTPColorBase
enum | FocusedControl { focusNone , focusColorWheel , focusLumination }
Enumeration used to determine window focus. More...
- Static Public Member Functions inherited from CXTPColorBase
static void AFX_CDECL | RGBtoHSL (COLORREF color, double *h, double *s, double *l)
This member function is called to convert an RGB color value to an HSL value.
static COLORREF AFX_CDECL | HLStoRGB (double h, double l, double s)
This member function is called to convert an HLS value to an RGB color value.
- Public Attributes inherited from CXTPColorBase
double | m_nLum
Current illumination value.
double | m_nSat
Current saturation value.
double | m_nHue
Current hue value.
CPoint | m_ptMousePos
Current mouse position relative to the device context.
- Protected Member Functions inherited from CXTPColorBase
virtual bool | Init ()
This member function is called by the CXTPColorBase class to perform initialization when the window is created or sub-classed.
- Protected Attributes inherited from CXTPColorBase
bool | m_bPreSubclassInit
true when initializing from PreSubclassWindow.
- Static Protected Attributes inherited from CXTPColorBase
static FocusedControl | m_eHasFocus
Determines which property page has input focus.

Detailed Description

CXTPColorLum is a CXTPColorBase derived class.

It is used to create a color luminance selection bar.

Member Function Documentation

◆ DrawLuminanceBar()

void DrawLuminanceBar ( CDC * pDC )

This member function is called to draw the selection bar.

Parameters
pDC A CDC pointer that represents the current device context.

◆ DrawSliderArrow()

void DrawSliderArrow ( CDC * pDC )

This member function is called to draw the indicator arrow.

Parameters
pDC A CDC pointer that represents the current device context.

◆ GetLumBarRect()

void GetLumBarRect ( CRect & rect )

This member function is called to retrieve the display size of the luminance bar.

Parameters
rect Address to a CRect object.

◆ SetColor()

virtual void SetColor | ( | double | nHue,
 |  | double | nSat )
 virtual

Call this member function to set the color for the selection window.

Parameters
nHue | Current hue value that represents the color.
nSat | Current saturation value that represents the color.

◆ SetLuminance()

void SetLuminance ( double l )

This member function is called to set the luminance for the color window.

Parameters
l Represents the new luminance value to set.

◆ UpdateCursorPos()

virtual void UpdateCursorPos ( CPoint point )
virtual

Call this member function to update the cursor position.

Parameters
point Current cursor location relative to the device context.

Reimplemented from CXTPColorBase.

The documentation for this class was generated from the following file:
  • XTPColorPageCustom.h


Toolkit Pro: CXTPColorManager Class Reference

Public Types | Public Member Functions | Public Attributes | List of all members
CXTPColorManager Class Reference

CXTPColorManager is a stand alone class. More...

Inheritance diagram for CXTPColorManager:
[legend]

Public Types

typedef DWORD(__stdcall *) PFNGETSYSCOLOR(int nIndex)
Application-defined callback function used with the SetGetSysColorPtr function.

Public Member Functions

void | RefreshColors (BOOL bResetCustomColors=TRUE)
This function will refresh the display element colors defined in the CXTPColorManager object.
COLORREF | GetColor (int nIndex) const
Retrieves the current color of the specified XP display element.
COLORREF | GetLunaColor (int nIndex) const
Call this member function to get the Luna color specified by nIndex.
COLORREF | LightColor (COLORREF clrLight, COLORREF clrDark, int nDelta) const
Call this member function to blend the light and dark colors by the amount specified in nDelta.
void | DisableLunaColors (BOOL bDisable=TRUE)
Call this member function to disable the luna (Blue, Olive and Green) colors for Office 2003 theme for Windows XP and later operating systems.
BOOL | IsLunaColorsDisabled () const
Determines if Luna colors for Office 2003 style is disabled.
void | SetColor (int nIndex, COLORREF clrValue)
Call this member to set the color for the specified index.
void | SetColors (int cElements, const int *lpaElements, const COLORREF *lpaRgbValues)
Call this member to set the colors for each element to the color in the specified color array.
void | RefreshLunaColors ()
Call this member to set the Office 2003 Luna colors for each element to correspond with the current Windows XP visual style.
XTPCurrentSystemTheme | GetCurrentSystemTheme () const
Call this member function to determine the current Windows XP theme in use.
XTPCurrentSystemTheme | GetWinThemeWrapperTheme () const
Call this member function to determine the current Windows XP theme in use.
void | SetLunaTheme (XTPCurrentSystemTheme systemTheme)
Call this method to force system theme.
void | SetGetSysColorPtr (PFNGETSYSCOLOR pfnGetSysColor)
This method replace standard GetSysColor to application defined.
BOOL | IsLowResolution (HDC hDC=0)
Call this member function to determine if the system display is set to low resolution.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Public Attributes

CXTPPaintManagerColorGradient | grcCaption
Office 2003 Caption gradient color.
CXTPPaintManagerColorGradient | grcDockBar
Office 2003 Dockbar gradient color.
CXTPPaintManagerColorGradient | grcShortcutBarGripper
Office 2003 Shortcut bar gripper.
CXTPPaintManagerColorGradient | grcToolBar
Office 2003 ToolBar gradient color.
CXTPPaintManagerColorGradient | grcMenu
Office 2003 Menu sidebar gradient color.
CXTPPaintManagerColorGradient | grcMenuExpanded
Office 2003 Expanded menu sidebar gradient color.
CXTPPaintManagerColorGradient | grcMenuItemPopup
Office 2003 Menu item pop-up gradient color.
CXTPPaintManagerColorGradient | grcLunaChecked
Office 2003 checked button gradient color.
CXTPPaintManagerColorGradient | grcLunaPushed
Office 2003 pushed button gradient color.
CXTPPaintManagerColorGradient | grcLunaSelected
Office 2003 selected button gradient color.
BOOL | m_bEnableLunaBlueForRoyaleTheme
TRUE if Office2003 blue theme will be used for xtpSystemThemeRoyale.
BOOL | m_bEnableLunaBlueForAeroTheme
TRUE if Office2003 blue theme will be used for xtpSystemThemeAero.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

CXTPColorManager is a stand alone class.

This object is used for manipulation of RGB values.

See also
XTPColorManager

Member Typedef Documentation

◆ PFNGETSYSCOLOR

DWORD(__stdcall *) PFNGETSYSCOLOR(int nIndex)

Application-defined callback function used with the SetGetSysColorPtr function.

See also
SetGetSysColorPtr

Member Function Documentation

◆ DisableLunaColors()

void DisableLunaColors ( BOOL bDisable = TRUE )

Call this member function to disable the luna (Blue, Olive and Green) colors for Office 2003 theme for Windows XP and later operating systems.

Parameters
bDisable TRUE to disable luna colors, otherwise FALSE.

◆ GetColor()

COLORREF GetColor ( int nIndex ) const

Retrieves the current color of the specified XP display element.

Parameters
nIndex Specifies the display element whose color is to be retrieved. This parameter can be one of the following values displayed in the table below:

Display elements are the parts of a window and the display that appear on the system display screen. The function returns the red, green, blue (RGB) color value of the given element. To provide a consistent look to all Windows applications, the operating system provides and maintains global settings that define the colors of various aspects of the display. These settings as a group are sometimes referred to as a "color scheme." To view the current color settings, click Control Panel, double-click the Display icon, and then click the "Appearance" tab.

Constant                      Value  Description<
----------------------------------------------------------------------------------
COLOR_SCROLLBAR                   0  Scroll bar color
COLOR_BACKGROUND                  1  Desktop color
COLOR_ACTIVECAPTION               2  Color of the title bar for the active window,
                                     Specifies the left side color in the color
                                     gradient of an active window's title bar if
                                     the gradient effect is enabled.
COLOR_INACTIVECAPTION             3  Color of the title bar for the inactive window,
                                     Specifies the left side color in the color
                                     gradient of an inactive window's title bar if
                                     the gradient effect is enabled.
COLOR_MENU                        4  Menu background color
COLOR_WINDOW                      5  Window background color
COLOR_WINDOWFRAME                 6  Window frame color
COLOR_MENUTEXT                    7  Color of text on menus
COLOR_WINDOWTEXT                  8  Color of text in windows
COLOR_CAPTIONTEXT                 9  Color of text in caption, size box, and scroll arrow
COLOR_ACTIVEBORDER                10 Border color of active window
COLOR_INACTIVEBORDER              11 Border color of inactive window
COLOR_APPWORKSPACE                12 Background color of multiple-document interface
                                     (MDI) applications
COLOR_HIGHLIGHT                   13 Background color of items selected in a control
COLOR_HIGHLIGHTTEXT               14 Text color of items selected in a control
COLOR_BTNFACE                     15 Background color for three-dimensional display
                                     elements and for dialog box backgrounds.
COLOR_BTNSHADOW                   16 Color of shading on the edge of command buttons
COLOR_GRAYTEXT                    17 Grayed (disabled) text
COLOR_BTNTEXT                     18 Text color on push buttons
COLOR_INACTIVECAPTIONTEXT         19 Color of text in an inactive caption
COLOR_BTNHIGHLIGHT                20 Highlight color for 3-D display elements
COLOR_3DDKSHADOW                  21 Darkest shadow color for 3-D display
elements COLOR_3DLIGHT            22 Second lightest 3-D color after 3DHighlight,
                                     Light color for three-dimensional display elements
                                     (for edges facing the light source.)
COLOR_INFOTEXT                    23 Color of text in ToolTips
COLOR_INFOBK                      24 Background color of ToolTips
COLOR_HOTLIGHT                    26 Color for a hot-tracked item. Single clicking a
                                     hot-tracked item executes the item.
COLOR_GRADIENTACTIVECAPTION       27 Right side color in the color gradient of an active
                                     window's title bar. COLOR_ACTIVECAPTION specifies
                                     the left side color.
COLOR_GRADIENTINACTIVECAPTION     28 Right side color in the color gradient of an inactive
                                     window's title bar. COLOR_INACTIVECAPTION specifies
                                     the left side color.
XPCOLOR_TOOLBAR_FACE              30 Office XP Style toolbar background color.
XPCOLOR_HIGHLIGHT                 31 Office XP Style menu item selected color.
XPCOLOR_HIGHLIGHT_BORDER          32 Office XP Style menu item selected border color.
XPCOLOR_HIGHLIGHT_PUSHED          33 Office XP Style menu item pushed color.
XPCOLOR_ICONSHADDOW               34 Office XP Style menu item icon shadow.
XPCOLOR_GRAYTEXT                  35 Office XP Style menu item disabled text color.
XPCOLOR_HIGHLIGHT_CHECKED         36 Office XP Style menu item checked color.
XPCOLOR_HIGHLIGHT_CHECKED_BORDER  37 An RGB value that represents the Office XP Style menu
                                     item checked border color.
XPCOLOR_TOOLBAR_GRIPPER           38 Office XP Style toolbar gripper color.
XPCOLOR_SEPARATOR                 39 Office XP Style toolbar separator color.
XPCOLOR_DISABLED                  40 Office XP Style menu icon disabled color.
XPCOLOR_MENUBAR_FACE              41 Office XP Style menu item57- text background color.
XPCOLOR_MENUBAR_EXPANDED          42 Office XP Style hidden menu commands background color.
XPCOLOR_MENUBAR_BORDER            43 Office XP Style menu border color.
XPCOLOR_MENUBAR_TEXT              44 Office XP Style menu item text color.
XPCOLOR_HIGHLIGHT_TEXT            45 Office XP Style menu item selected text color.
XPCOLOR_CHECKED_TEXT              45 Office XP Style color for text displayed in a
                                     checked button.
XPCOLOR_TOOLBAR_TEXT              46 Office XP Style toolbar text color.
XPCOLOR_PUSHED_TEXT               47 Office XP Style toolbar pushed text color.
XPCOLOR_TAB_INACTIVE_BACK         48 Office XP Style inactive tab background color.
XPCOLOR_TAB_INACTIVE_TEXT         49 Office XP Style inactive tab text color.
XPCOLOR_HIGHLIGHT_PUSHED_BORDER   50 An RGB value that represents the Office XP Style
                                     border color for pushed in 3D elements.
XPCOLOR_3DFACE                    51 Office XP Style face color for three- dimensional
                                     display elements and for dialog box backgrounds.
XPCOLOR_3DSHADOW                  52 Office XP Style shadow color for three-dimensional
                                     display elements (for edges facing away from the
                                     light source).
XPCOLOR_EDITCTRLBORDER            53 Office XP Style color for the border color of edit
                                     controls.
XPCOLOR_FRAME                     54 Office 2003 frame color.
XPCOLOR_SPLITTER_FACE             55 Office XP Style splitter face color.
XPCOLOR_LABEL                     56 Color for label control (xtpControlLabel)
XPCOLOR_STATICFRAME               57 Static frame color
XPCOLOR_HIGHLIGHT_DISABLED_BORDER 58 Highlighted disabled border color
XPCOLOR_SHADOW_FACTOR             59 Shadow factor color
XPCOLOR_TOOLBAR_GRAYTEXT          60 Toolbar gray text color
XPCOLOR_FLOATBAR_BORDER           61 Floatbar border color
XPCOLOR_LAST                      62 The last color value
Returns
The red, green, blue (RGB) color value of the given element.

◆ GetCurrentSystemTheme()

XTPCurrentSystemTheme GetCurrentSystemTheme ( ) const

Call this member function to determine the current Windows XP theme in use.

Returns
A XTPCurrentSystemTheme enumeration that represents the current Windows theme in use, can be one of the following values: xtpSystemThemeUnknown: Indicates no known theme in use. xtpSystemThemeBlue: Indicates blue theme in use. xtpSystemThemeOlive: Indicates olive theme in use. xtpSystemThemeSilver: Indicates silver theme in use.
See also
SetLunaTheme, RefreshLunaColors

◆ GetLunaColor()

COLORREF GetLunaColor ( int nIndex ) const

Call this member function to get the Luna color specified by nIndex.

Parameters
nIndex Specifies the display element whose color is to be retrieved.
Returns
An RGB color value representing the Luna color.

◆ GetWinThemeWrapperTheme()

XTPCurrentSystemTheme GetWinThemeWrapperTheme ( ) const

Call this member function to determine the current Windows XP theme in use.

Returns
A XTPCurrentSystemTheme enumeration that represents the current Windows theme in use, can be one of the following values: xtpSystemThemeUnknown: Indicates no known theme in use. xtpSystemThemeBlue: Indicates blue theme in use. xtpSystemThemeOlive: Indicates olive theme in use. xtpSystemThemeSilver: Indicates silver theme in use.

◆ IsLowResolution()

BOOL IsLowResolution ( HDC hDC = 0 )

Call this member function to determine if the system display is set to low resolution.

Parameters
hDC Handle to a device context, if NULL the desktop window device context is used.
Returns
TRUE if the system display is set to low resolution, otherwise FALSE.

◆ IsLunaColorsDisabled()

BOOL IsLunaColorsDisabled ( ) const

Determines if Luna colors for Office 2003 style is disabled.

Returns
TRUE if the luna colors are disabled, otherwise FALSE.

◆ LightColor()

COLORREF LightColor | ( | COLORREF | clrLight,
 |  | COLORREF | clrDark,
 |  | int | nDelta ) const

Call this member function to blend the light and dark colors by the amount specified in nDelta.

Parameters
clrLight | RGB light color
clrDark | RGB dark color
nDelta | Amount saturation to blend colors.
Returns
An RGB color value representing the two blended colors.

◆ RefreshColors()

void RefreshColors ( BOOL bResetCustomColors = TRUE )

This function will refresh the display element colors defined in the CXTPColorManager object.

Parameters
bResetCustomColors If FALSE, all custom colors will remain unchanged.

◆ RefreshLunaColors()

void RefreshLunaColors ( )

Call this member to set the Office 2003 Luna colors for each element to correspond with the current Windows XP visual style.

See also
SetColor, SetColors

◆ SetColor()

void SetColor | ( | int | nIndex,
 |  | COLORREF | clrValue )

Call this member to set the color for the specified index.

See GetColor for a complete list of index values.

Parameters
nIndex | Color index.
clrValue | RGB color value to set.
See also
SetColors

◆ SetColors()

void SetColors | ( | int | cElements,
 |  | const int * | lpaElements,
 |  | const COLORREF * | lpaRgbValues )

Call this member to set the colors for each element to the color in the specified color array.

Parameters
cElements | Number of elements in array.
lpaElements | Array of elements.
lpaRgbValues | Array of RGB values.
See also
SetColor

◆ SetGetSysColorPtr()

void SetGetSysColorPtr ( PFNGETSYSCOLOR pfnGetSysColor )

This method replace standard GetSysColor to application defined.

Parameters
pfnGetSysColor Pointer to the PFNGETSYSCOLOR procedure

◆ SetLunaTheme()

void SetLunaTheme ( XTPCurrentSystemTheme systemTheme )

Call this method to force system theme.

Parameters
systemTheme theme to use. Can be any of the values listed in the Remarks section.

Theme can be one of the following: xtpSystemThemeUnknown: Disables luna theme support. xtpSystemThemeBlue: Enables blue theme. xtpSystemThemeOlive: Enables olive theme. xtpSystemThemeSilver: Enables silver theme.

The documentation for this class was generated from the following file:
  • XTPColorManager.h


Toolkit Pro: CXTPColorPageCustom Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPColorPageCustom Class Reference

CXTPColorPageCustom is derived from CPropertyPage. More...

Public Member Functions

CXTPColorPageCustom (CXTPColorDialog *pParentSheet=NULL)
Constructs a CXTPColorPageCustom object.
virtual | ~CXTPColorPageCustom ()
Destroys a CXTPColorPageCustom object, handles cleanup and deallocation.
void | RGBtoHSL (COLORREF color, int *xtFocusLumination, int *sat, int *hue)
This member function is called to retrieve the HSL values of the RGB specified by color.

Protected Attributes

CXTPColorDialog * m_pParentSheet
Pointer to the parent property sheet.

Detailed Description

CXTPColorPageCustom is derived from CPropertyPage.

It is used to create a CXTPColorPageCustom dialog.

Constructor & Destructor Documentation

◆ CXTPColorPageCustom()

CXTPColorPageCustom ( CXTPColorDialog * pParentSheet = NULL )

Constructs a CXTPColorPageCustom object.

Parameters
pParentSheet A pointer to the parent sheet.

Member Function Documentation

◆ RGBtoHSL()

void RGBtoHSL | ( | COLORREF | color,
 |  | int * | xtFocusLumination,
 |  | int * | sat,
 |  | int * | hue )

This member function is called to retrieve the HSL values of the RGB specified by color.

Parameters
color | An RGB value that represents the color.
xtFocusLumination | Address of the integer to receive the illumination value (0-255).
sat | Address of the integer to receive the saturation value (0-255).
hue | Address of the integer to receive the hue value (0-255).
The documentation for this class was generated from the following file:
  • XTPColorPageCustom.h


Toolkit Pro: CXTPColorPageStandard Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPColorPageStandard Class Reference

CXTPColorPageStandard is derived from CPropertyPage. More...

Public Member Functions

CXTPColorPageStandard (CXTPColorDialog *pParentSheet=NULL)
Constructs a CXTPColorPageStandard object.
virtual | ~CXTPColorPageStandard ()
Destroys a CXTPColorPageStandard object, handles cleanup and deallocation.
void | SetColor (COLORREF clr)
This member function is called to set the selected color for the page.

Protected Attributes

CXTPColorHex | m_colorHex
ColorHex control.
CXTPColorDialog * | m_pParentSheet
Pointer to the parent property sheet.

Detailed Description

CXTPColorPageStandard is derived from CPropertyPage.

It is used to create a CXTPColorPageStandard dialog.

Constructor & Destructor Documentation

◆ CXTPColorPageStandard()

CXTPColorPageStandard ( CXTPColorDialog * pParentSheet = NULL )

Constructs a CXTPColorPageStandard object.

Parameters
pParentSheet Pointer to the parent property sheet.

Member Function Documentation

◆ SetColor()

void SetColor ( COLORREF clr )

This member function is called to set the selected color for the page.

Parameters
clr An RGB value that represents the color.
The documentation for this class was generated from the following file:
  • XTPColorPageStandard.h


Toolkit Pro: CXTPColorPicker Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPColorPicker Class Reference

CXTPColorPicker is a CXTPButton derived class. More...

Inheritance diagram for CXTPColorPicker:
[legend]

Public Member Functions

CXTPColorPicker ()
Constructs a CXTPColorPicker object.
virtual | ~CXTPColorPicker ()
Destroys a CXTPColorPicker object, handles cleanup and deallocation.
BOOL | SetThemeColors (XTP_PICK_BUTTON *pColors=NULL, int nCount=10, LPCTSTR lpszTitle=NULL, UINT *pStringIDs=NULL, int ppShadeMatrix[6][10]=NULL)
Called to initialize the theme colors for the color selector.
BOOL | SetThemeColors (XTP_PICK_BUTTON *pColors, int nCount, LPCTSTR lpszTitle, LPCTSTR *ppszStrings, int ppShadeMatrix[6][10])
Called to initialize the theme colors for the color selector.
BOOL | SetStandardColors (XTP_PICK_BUTTON *pColors=NULL, int nCount=10, int nCols=10, LPCTSTR lpszTitle=NULL)
Called to initialize the standard colors for the color selector.
virtual void | SetColor (COLORREF clr)
This member function will set the color value for the color picker.
virtual COLORREF | GetColor () const
This member function will return the currently selected color.
virtual void | ShowText (BOOL bShowText)
This member function will display any text associated with the color picker button control.
virtual BOOL | IsTextShown () const
This member function will determine if text is displayed for the color picker button control.
virtual void | ShowTextInColor (BOOL bColorText)
This member function will display any text associated with the color picker button control in color.
virtual BOOL | IsTextInColor () const
This member function will determine if the text for the color picker button control is displayed in color.
virtual void | SetDefaultColor (COLORREF clrDefault)
This member function will set the default RGB color value for the color picker.
virtual COLORREF | GetDefaultColor () const
This member function will return the default RGB color value for the color picker.
virtual void | ModifyCPStyle (DWORD dwRemove, DWORD dwAdd)
Call this member function to modify the color picker display style.
virtual void | ShowPopupWindow ()
This member function will activate the color picker and display the color pop-up window.
void | SetColors (XTP_PICK_BUTTON *pColors, int nCount, int nCols=8, LPCTSTR lpszTitle=NULL)
Call this method to set custom colors for the color picker.
CXTPPickBtnArray & GetThemeColors ()
Called to retrieve a reference to the theme color button array.
CXTPPickBtnArray & GetStandardColors ()
Called to retrieve a reference to the standard color button array.
void | ShowCaptions (BOOL bShow)
Call to show/hide captions for the color selector.
virtual BOOL | IsPushed ()
Call this member function to determine if the the button is currently being pushed.
- Public Member Functions inherited from CXTPButton
CXTPButton ()
Constructs a CXTPButton object.
virtual | ~CXTPButton ()
Destroys a CXTPButton object, handles cleanup and deallocation.
BYTE | GetButtonStyle () const
Retrieves the button styles for this object.
virtual BOOL | IsHighlighted ()
Call this member function to determine if the the button is currently being highlighted (mouse over).
virtual BOOL | GetChecked ()
Call this member function to determine if the checked state has been defined for the button control.
void | SetChecked (BOOL bChecked)
Sets the highlight state for the button control.
BOOL | GetFlatStyle () const
Gets the flat style appearance of the button control.
void | SetFlatStyle (BOOL bFlatStyle=TRUE)
Sets the flat style appearance of the button control.
BOOL | GetUseVisualStyle () const
Determines if the control is drawn using visual styles/SkinFramework, if supported.
void | SetUseVisualStyle (BOOL bUseVisualStyle=TRUE)
Enables Windows XP visual styles for the control.
long | GetBorderGap () const
Call this member function to retrieve the gap between the button's image and border.
void | SetBorderGap (int nBorderGap)
Call this member function to set the gap between the button's image and border.
XTPPushButtonStyle | GetPushButtonStyle () const
This function retrieves a flag from the XTPPushButtonStyle enumeration that specifies the current style of the button.
void | SetPushButtonStyle (XTPPushButtonStyle nPushButtonStyle)
This member function will set the display style for the button.
virtual int | GetTextAlignment () const
Gets the alignment of the text on the button control.
void | SetTextAlignment (DWORD dwAlignment)
Sets the alignment of the text on the button control.
virtual int | GetImageAlignment () const
Gets the alignment of the image on the button control.
void | SetImageAlignment (DWORD dwAlignment)
Sets the alignment of the image on the button control.
XTPButtonTextImageRelation | GetTextImageRelation () const
Gets the text and image relation in the button.
void | SetTextImageRelation (XTPButtonTextImageRelation relation)
Sets the text and image relation in the button.
long | GetImageGap () const
Call this member function to retrieve the gap between the button's text and image.
void | SetImageGap (int nImageGap)
Call this member function to set the gap between the button's text and image.
virtual CSize | GetImageSize ()
Call this member function to return the size of the image displayed for the button control.
virtual BOOL | IsDpiImageScalingEnabled () const
Call this member to check if DPI scaling of images is enabled.
virtual void | SetDpiImageScaling (BOOL bEnable)
Call this member to enable/disable DPI scaling of images.
CXTPImageManagerIcon * | GetIcon () const
Call this member function to return a pointer to the image manager for the button control.
virtual void | DrawImage (CDC *pDC, CRect rc)
This method is called to draw the image of the control.
XTPGroupBoxBorderStyle | GetBorderStyle () const
Gets the border style of the control.
void | SetBorderStyle (XTPGroupBoxBorderStyle style)
Sets the border style of the control.
BOOL | GetShowFocus () const
Gets whether a focus rectangle is drawn around the contents of a button when the button has focus.
void | SetShowFocus (BOOL bShowFocus)
Sets whether a focus rectangle is drawn around the contents of a button when the button has focus.
virtual BOOL | SetTheme (XTPControlTheme eTheme)
Call this member to switch the visual theme of the control.
virtual void | SetTheme (CXTPButtonTheme *pPaintManager)
Call this member to switch the visual theme of the control.
CXTPButtonTheme * GetTheme ()
Call this member function to get a pointer to the currently selected theme.
void | RedrawButton (BOOL bUpdateWindow=FALSE)
Redraws the button.
BOOL | IsDropDownStyle () const
This member function is called to determine if the buttons have a drop down arrow and if it is drop down style.
virtual CRect | GetButtonRect ()
This member function is called to determine the size and location of the button.
void | SetBuddy (CWnd *pWndBuddy, BOOL bMoveButton=TRUE)
Sets the control used as the buddy control.
void | SetTooltip (LPCTSTR lpszTooltip)
Associates tooltip text with the button.
CString | GetTooltip () const
Call this member to retrieve the button's tooltip.
CXTPToolTipContext * | GetToolTipContext () const
Call this method to get a pointer to the tooltip context.
virtual BOOL | SetIcon (CSize size, HICON hIcon, HICON hIconHot=NULL, BOOL bRedraw=TRUE)
This member function will set the normal and hot state icons for the push button.
virtual BOOL | SetIcon (CSize size, UINT nID, UINT nHotID=0, BOOL bRedraw=TRUE)
This member function will set the normal and hot state icons for the push button.
virtual BOOL | SetIcon (CSize size, LPCTSTR lpszID, LPCTSTR lpszHotID=NULL, BOOL bRedraw=TRUE)
This member function will set the normal and hot state icons for the push button.
BOOL | SetIcon (CSize size, CXTPImageManagerIcon *pIcon, BOOL bRedraw=TRUE)
This member function will set the normal and hot state icons for the push button.
virtual BOOL | SetIcon (CSize size, const CXTPImageManagerIconHandle &hIconHandle, const CXTPImageManagerIconHandle &hIconHotHandle, BOOL bRedraw=TRUE)
This member function will set the normal and hot state icons for the push button.
virtual BOOL | SetBitmap (CSize size, UINT nID, BOOL bRedraw=TRUE)
This member function will set the bitmap associated with the button.
virtual CString | GetButtonText ()
Call this member function to return the button's text minus the '&'.
CSize | GetGlyphSize (BOOL bCheckBox)
Retrieves the size of the check box glyph.
BOOL | IsPushButton () const
Determines if the button is a push button or a drop down button.
void | EnableMarkup (BOOL bEnableMarkup=TRUE)
Allows the use of a XAML snippet to be used for the text of panes in the control.
virtual COLORREF | GetButtonTextColor ()
Gets the button's text color.
virtual COLORREF | GetButtonBackColor ()
Gets the button's back color.
virtual void | InternalTextChanged ()
This member function is called when the text has changed.
CXTPMarkupContext * | GetMarkupContext () const
Retrieves a pointer to the markup context.
CXTPMarkupUIElement * GetMarkupUIElement ()
Call this method to get the markup element that renders the caption of the control.

Protected Member Functions

virtual COLORREF | GetContrastColor () const
Retrieves the background contrast color for the CXTPColorPicker.
- Protected Member Functions inherited from CXTPButton
virtual void | OnDropDown ()
Occurs when the drop down button is dropped down.
virtual void | OnDraw (CDC *pDC)
This member function performs all of the drawing logic of the calendar control window.
void | DoDropDown ()
Manually drops down a drop down button.
virtual void | RefreshMetrics ()
Call this member function to refresh theme colors and redraw the control.

Protected Attributes

BOOL | m_bShowText
TRUE if the color picker displays text.
BOOL | m_bColorText
TRUE if the color picker text is colorized; only valid if m_bShowText is TRUE.
BOOL | m_bPopupActive
TRUE if the pop-up window is currently active.
DWORD | m_dwPopup
Represents the style for the color picker.
COLORREF | m_clrSelected
An RGB value that represents the color for the display color.
COLORREF | m_clrDefault
An RGB value that represents the color for the default color.
CString | m_strTitleTheme
Represents the title for theme colors caption.
CString | m_strTitleStandard
Represents the title for standard colors caption.
CString | m_strTitleCustom
Custom colors title.
BOOL | m_bCaptions
TRUE to display color captions.
CXTPPickBtnArray | m_arThemeColors
Theme color array.
CXTPPickBtnArray | m_arStandardColors
Standard color array.
XTP_PICK_BUTTON * | m_pExtendedColors
Custom colors.
int | m_nExtendedColors
Custom colors count.
int | m_nCols
Number of columns in the color pop-up window.
- Protected Attributes inherited from CXTPButton
CXTPMarkupContext * | m_pMarkupContext
Markup context.
CXTPMarkupUIElement * | m_pUIElement
Markup element pointer.
BOOL | m_bImageDPIScaling
TRUE if DPI scaling of images enabled.

Additional Inherited Members

- Public Attributes inherited from CXTPButton
BOOL | m_bPushed
TRUE if button was pressed.
BOOL | m_bHot
TRUE if mouse under button.
CXTPButtonTheme * | m_pTheme
Pointer to the current theme object.
BOOL | m_bChecked
TRUE if checked.
BOOL | m_bFlatStyle
TRUE to see the flat style.
BOOL | m_bUseVisualStyle
TRUE to use visual styles.
long | m_nImageAlignment
Image Alignment.
long | m_nBorderGap
Gap between the button edge and the image.
long | m_nPushButtonStyle
The style of the button.
BOOL | m_bEnableMarkup
TRUE to enable markup.
long | m_nImageGap
Gap between the button text and the image.
long | m_nTextImageRelation
Image and text orientation.
CXTPImageManagerIcon * | m_pIcon
Multiple state icon manager converts icon to different states.
CSize | m_szVectorIcon
Size of displayed image if vector icon is used.
long | m_nBorderStyle
Border style used.
BOOL | m_bShowFocus
TRUE to show the focus rectangle.
HWND | m_hWndBuddy
Handle to the buddy control.
CXTPToolTipContext * | m_pToolTipContext
TooltipContext.
CString | m_strTooltip
Tooltip of the item.

Detailed Description

CXTPColorPicker is a CXTPButton derived class.

It displays a color picker pop-up window (CXTPColorPopup) for Office(tm) style color selection.

Member Function Documentation

◆ GetColor()

virtual COLORREF GetColor ( ) const
virtual

This member function will return the currently selected color.

Returns
An RGB color value that represents the currently selected color.

◆ GetContrastColor()

virtual COLORREF GetContrastColor ( ) const
protectedvirtual

Retrieves the background contrast color for the CXTPColorPicker.

Returns
An RGB value of either BLACK or WHITE.

This member function is called to return the contrast color for the color picker button. The contrast color is used when text is displayed to contrast with the currently selected color. For example, if the currently selected color is WHITE, then BLACK would be returned so the text is legible.

◆ GetDefaultColor()

virtual COLORREF GetDefaultColor ( ) const
virtual

This member function will return the default RGB color value for the color picker.

Returns
An RGB value that represents the default color value for the color picker.

◆ GetStandardColors()

CXTPPickBtnArray & GetStandardColors ( )

Called to retrieve a reference to the standard color button array.

Returns
Reference to a CXTPPickBtnArray object representing the standard color array for the color selector control.

◆ GetThemeColors()

CXTPPickBtnArray & GetThemeColors ( )

Called to retrieve a reference to the theme color button array.

Returns
Reference to a CXTPPickBtnArray object representing the theme color array for the color selector control.

◆ IsPushed()

virtual BOOL IsPushed ( )
virtual

Call this member function to determine if the the button is currently being pushed.

Returns
TRUE if the button is currently being pushed, otherwise FALSE.

Reimplemented from CXTPButton.

◆ IsTextInColor()

virtual BOOL IsTextInColor ( ) const
virtual

This member function will determine if the text for the color picker button control is displayed in color.

Returns
TRUE if the button text is in color, otherwise FALSE.

◆ IsTextShown()

virtual BOOL IsTextShown ( ) const
virtual

This member function will determine if text is displayed for the color picker button control.

Returns
TRUE if the color picker displays text, otherwise FALSE.

◆ ModifyCPStyle()

virtual void ModifyCPStyle | ( | DWORD | dwRemove,
 |  | DWORD | dwAdd )
 virtual

Call this member function to modify the color picker display style.

Parameters
dwRemove | Specifies the window styles to be removed during style modification.
dwAdd | Specifies the window styles to be added during style modification.

Styles to be added or removed can be combined by using the bitwise OR (|) operator. It can be one or more of the following: CPS_XTP_NOFILL: Displays a "No Fill" button rather than the default Automatic Color button. CPS_XTP_EXTENDED: Displays 40 extended colors rather than the default 16 colors. CPS_XTP_MORECOLORS: Displays a "More Colors" button which will display a CXTPColorDialog. CPS_XTP_NOAUTOMATIC: Do not display an "Automatic Color" button. CPS_XTP_RECENTCOLORS: Displays a recently used color list for the control. CPS_XTP_RIGHTALIGN: The pop-up window is displayed right aligned. CPS_XTP_COLORBORDERS: The pop-up window displays color boxes with color borders. CPS_XTP_SHOW3DSELECTION: Displays the color selection box with a 3D raised border in CXTPColorDialog. CPS_XTP_SHOWHEXVALUE: Displays the hex equivalent of the selected color. CPS_XTP_SHOWEYEDROPPER: Displays the eye dropper box to allow selecting any color on the screen.

See also
CXTPColorPopup::Create, CXTPColorSelectorCtrl::Create

◆ SetColor()

virtual void SetColor ( COLORREF clr )
virtual

This member function will set the color value for the color picker.

Parameters
clr An RGB value that represents the new RGB color for the control.

◆ SetColors()

void SetColors | ( | XTP_PICK_BUTTON * | pColors,
 |  | int | nCount,
 |  | int | nCols = 8,
 |  | LPCTSTR | lpszTitle = NULL )

Call this method to set custom colors for the color picker.

Parameters
pColors | Static array of colors and tooltips.
nCount | Number of colors.
nCols | Number of columns to show.
lpszTitle | Custom title for colors displayed.

◆ SetDefaultColor()

virtual void SetDefaultColor ( COLORREF clrDefault )
virtual

This member function will set the default RGB color value for the color picker.

Parameters
clrDefault An RGB value that represents the default color for the color picker.

◆ SetStandardColors()

BOOL SetStandardColors | ( | XTP_PICK_BUTTON * | pColors = NULL,
 |  | int | nCount = 10,
 |  | int | nCols = 10,
 |  | LPCTSTR | lpszTitle = NULL )

Called to initialize the standard colors for the color selector.

The colors passed in must be an array of 10 colors.

Parameters
pColors | Array of colors and tooltips.
nCount | Number of colors in the array.
nCols | Number of columns to display.
lpszTitle | Title used for theme colors caption.
Returns
TRUE if successful, otherwise FALSE. Example: Here is an example of how use SetThemeColors:
XTP_PICK_BUTTON _StdColors[] =
{
   { RGB(192,   0,   0), XTP_IDS_CLR_DARK_RED    },
   { RGB(255,   0,   0), XTP_IDS_CLR_RED         },
   { RGB(255, 192,   0), XTP_IDS_CLR_ORANGE      },
   { RGB(255, 255,   0), XTP_IDS_CLR_YELLOW      },
   { RGB(146, 208,  80), XTP_IDS_CLR_LIGHT_GREEN },
   { RGB(  0, 176,  80), XTP_IDS_CLR_GREEN       },
   { RGB(  0, 176, 240), XTP_IDS_CLR_LIGHT_BLUE  },
   { RGB(  0, 112, 192), XTP_IDS_CLR_BLUE        },
   { RGB(  0,  32,  96), XTP_IDS_CLR_DARK_BLUE   },
   { RGB(112,  48, 160), XTP_IDS_CLR_PURPLE      },
};

SetStandardColors(_StdColors, _countof(_StdColors));

◆ SetThemeColors() [1/2]

BOOL SetThemeColors | ( | XTP_PICK_BUTTON * | pColors,
 |  | int | nCount,
 |  | LPCTSTR | lpszTitle,
 |  | LPCTSTR * | ppszStrings,
 |  | int | ppShadeMatrix[6][10] )

Called to initialize the theme colors for the color selector.

The colors passed in must be an array of 10 colors. Additional values can be passed in, such as an array of 10 string resource IDs and a 6 x 10 shading matrix used to adjust each of the 10 theme colors passed in.

Parameters
pColors | Array of colors and tooltips.
nCount | Number of colors in the array.
lpszTitle | Title used for theme colors caption.
ppszStrings | Array of strings representing each color's description. Values cannot be NULL. Array size must match nCount.
ppShadeMatrix | 6 x 10 matrix array that specifies 6 rows of shading by 10 colums. If NULL, then default values are used.
Returns
TRUE if successful, otherwise FALSE. Example: Here is an example of how use SetThemeColors:
XTP_PICK_BUTTON _ThemeColors[] =
{
   { RGB(255, 255, 255), XTP_IDS_CLR_WHITE    },
   { RGB(  0,   0,   0), XTP_IDS_CLR_BLACK    },
   { RGB(231, 230, 230), XTP_IDS_CLR_GRAY25   },
   { RGB( 68,  84, 106), XTP_IDS_CLR_BLUEGRAY },
   { RGB( 91, 155, 213), XTP_IDS_CLR_BLUE     },
   { RGB(237, 125,  49), XTP_IDS_CLR_ORANGE   },
   { RGB(165, 165, 165), XTP_IDS_CLR_GRAY50   },
   { RGB(255, 192,   0), XTP_IDS_CLR_GOLD     },
   { RGB( 68, 114, 196), XTP_IDS_CLR_BLUE     },
   { RGB(112, 173,  71), XTP_IDS_CLR_GREEN    },
};

UINT _StringIDs[10] =
{
   XTP_IDS_BACKGROUND1,
   XTP_IDS_TEXT1,
   XTP_IDS_BACKGROUND2,
   XTP_IDS_TEXT2,
   XTP_IDS_ACCENT1,
   XTP_IDS_ACCENT2,
   XTP_IDS_ACCENT3,
   XTP_IDS_ACCENT4,
   XTP_IDS_ACCENT5,
   XTP_IDS_ACCENT6,
};

int _Shade[6][10] =
{
   {   0,   0,   0,   0,   0,   0,   0,   0,   0,   0 },
   {  -5, +50, -10, +80, +80, +80, +80, +80, +80, +80 },
   { -15, +35, -25, +60, +60, +60, +60, +60, +60, +60 },
   { -25, +25, -50, +40, +40, +40, +40, +40, +40, +40 },
   { -35, +15, -75, -25, -25, -25, -25, -25, -25, -25 },
   { -50, + 5, -90, -50, -50, -50, -50, -50, -50, -50 },
};

SetThemeColors(_ThemeColors, _countof(_ThemeColors), _StringIDs, _Shade);

◆ SetThemeColors() [2/2]

BOOL SetThemeColors | ( | XTP_PICK_BUTTON * | pColors = NULL,
 |  | int | nCount = 10,
 |  | LPCTSTR | lpszTitle = NULL,
 |  | UINT * | pStringIDs = NULL,
 |  | int | ppShadeMatrix[6][10] = NULL )

Called to initialize the theme colors for the color selector.

The colors passed in must be an array of 10 colors. Additional values can be passed in, such as an array of 10 string resource IDs and a 6 x 10 shading matrix used to adjust each of the 10 theme colors passed in.

Parameters
pColors | Array of colors and tooltips.
nCount | Number of colors in the array.
lpszTitle | Title used for theme colors caption.
pStringIDs | Array of resource IDs representing each color's description. If NULL, then default values are used. Array size must match nCount.
ppShadeMatrix | 6 x 10 matrix array that specifies 6 rows of shading by 10 colums. If NULL, then default values are used.
Returns
TRUE if successful, otherwise FALSE. Example: Here is an example of how use SetThemeColors:
XTP_PICK_BUTTON _ThemeColors[] =
{
   { RGB(255, 255, 255), XTP_IDS_CLR_WHITE    },
   { RGB(  0,   0,   0), XTP_IDS_CLR_BLACK    },
   { RGB(231, 230, 230), XTP_IDS_CLR_GRAY25   },
   { RGB( 68,  84, 106), XTP_IDS_CLR_BLUEGRAY },
   { RGB( 91, 155, 213), XTP_IDS_CLR_BLUE     },
   { RGB(237, 125,  49), XTP_IDS_CLR_ORANGE   },
   { RGB(165, 165, 165), XTP_IDS_CLR_GRAY50   },
   { RGB(255, 192,   0), XTP_IDS_CLR_GOLD     },
   { RGB( 68, 114, 196), XTP_IDS_CLR_BLUE     },
   { RGB(112, 173,  71), XTP_IDS_CLR_GREEN    },
};

UINT _StringIDs[10] =
{
   XTP_IDS_BACKGROUND1,
   XTP_IDS_TEXT1,
   XTP_IDS_BACKGROUND2,
   XTP_IDS_TEXT2,
   XTP_IDS_ACCENT1,
   XTP_IDS_ACCENT2,
   XTP_IDS_ACCENT3,
   XTP_IDS_ACCENT4,
   XTP_IDS_ACCENT5,
   XTP_IDS_ACCENT6,
};

int _Shade[6][10] =
{
   {   0,   0,   0,   0,   0,   0,   0,   0,   0,   0 },
   {  -5, +50, -10, +80, +80, +80, +80, +80, +80, +80 },
   { -15, +35, -25, +60, +60, +60, +60, +60, +60, +60 },
   { -25, +25, -50, +40, +40, +40, +40, +40, +40, +40 },
   { -35, +15, -75, -25, -25, -25, -25, -25, -25, -25 },
   { -50, + 5, -90, -50, -50, -50, -50, -50, -50, -50 },
};

SetThemeColors(_ThemeColors, _countof(_ThemeColors), _StringIDs, _Shade);

◆ ShowCaptions()

void ShowCaptions ( BOOL bShow )

Call to show/hide captions for the color selector.

Parameters
bShow TRUE to show captions, FALSE to hide.

◆ ShowText()

virtual void ShowText ( BOOL bShowText )
virtual

This member function will display any text associated with the color picker button control.

If the button has text, it will be displayed.

Parameters
bShowText TRUE to display button text.

◆ ShowTextInColor()

virtual void ShowTextInColor ( BOOL bColorText )
virtual

This member function will display any text associated with the color picker button control in color.

Parameters
bColorText TRUE to display the button text in color.
The documentation for this class was generated from the following file:
  • XTPColorPicker.h


Toolkit Pro: CXTPColorPopup Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPColorPopup Class Reference

CXTPColorPopup is a CXTPColorSelectorCtrl derived class. More...

Inheritance diagram for CXTPColorPopup:
[legend]

Public Member Functions

CXTPColorPopup (BOOL bAutoDelete=FALSE, LPARAM callerParam=0)
Constructs a CXTPColorPopup object.
virtual | ~CXTPColorPopup ()
Destroys a CXTPColorPopup object, handles cleanup and deallocation.
virtual BOOL | Create (CRect &rect, CWnd *pParentWnd, DWORD dwPopup, COLORREF clrColor, COLORREF clrDefault=CLR_DEFAULT)
This member function handles the creation of the color pop-up window.
void | AddListener (HWND hwndListener)
This member function adds a window that picker notifications are sent to.
void | DisplayShadow (BOOL bDisplayShadow=TRUE)
Enables/disables pop-up window shadow.
- Public Member Functions inherited from CXTPColorSelectorCtrl
CXTPColorSelectorCtrl ()
Constructs a CXTPColorSelectorCtrl object.
virtual | ~CXTPColorSelectorCtrl ()
Destroys a CXTPColorSelectorCtrl object, handles cleanup and deallocation.
CString | GetThemeTip (LPCTSTR lpszColor, LPCTSTR lpszDesc, int nShade)
Called to create a tooltip for a theme color using the specified string resource ID and shading that were originally passed into SetThemeColors.
BOOL | SetThemeColors (XTP_PICK_BUTTON *pColors=NULL, int nCount=10, LPCTSTR lpszTitle=NULL, UINT *pStringIDs=NULL, int ppShadeMatrix[6][10]=NULL)
Called to initialize the theme colors for the color selector.
BOOL | SetThemeColors (XTP_PICK_BUTTON *pColors, int nCount, LPCTSTR lpszTitle, LPCTSTR *ppszStrings, int ppShadeMatrix[6][10])
Called to initialize the theme colors for the color selector.
BOOL | SetThemeColors (CXTPPickBtnArray &arColors, int nCols=10, LPCTSTR lpszTitle=NULL)
Called to initialize the theme colors for the color selector.
BOOL | SetStandardColors (XTP_PICK_BUTTON *pColors=NULL, int nCount=10, int nCols=10, LPCTSTR lpszTitle=NULL)
Called to initialize the standard colors for the color selector.
BOOL | SetStandardColors (CXTPPickBtnArray &arColors, int nCols=10, LPCTSTR lpszTitle=NULL)
Called to initialize the standard colors for the color selector.
void | SetColors (XTP_PICK_BUTTON *pColors, int nCount, int nCols=8, LPCTSTR lpszTitle=NULL)
Call this method to set custom colors for the color picker.
CXTPPickBtnArray & GetThemeColors ()
Called to retrieve a reference to the theme color button array.
CXTPPickBtnArray & GetStandardColors ()
Called to retrieve a reference to the standard color button array.
int | GetCurSel (COLOR_CELL *pColorCell)
This member function will return the index of the currently selected color and will initialize 'pColorCell' struct.
void | SetCurSel (int nIndex)
This member function will select a button based upon its index.
BOOL | Create (CRect rect, CWnd *pParentWnd, DWORD dwPopup, COLORREF clrColor, COLORREF clrDefault=CLR_DEFAULT)
This member function handles the creation of the color pop-up window.
void | AddListener (HWND hwndListener)
This member function adds a window to send color picker notifications to.
void | RemoveListener (HWND hwndListener)
This member function removes a window from the notification list.
virtual void | SelectColorCell (COLOR_CELL *pColorCell)
This member function is called to select a color cell.
void | SelectColor (COLORREF clr)
This member function is called to select a color cell.
COLOR_CELL * | GetCellFromIndex (int iIndex)
This member function is called to retrieve a COLOR_CELL struct from the color cell array.
void | SetBorders (int l=0, int t=0, int r=0, int b=0)
This member function is called to set the size of the borders for the control.
bool | IsColorDlgVisible ()
Call this member function to determine if the color selection dialog is visible.
BOOL | IsColorStatic (CDC *pDC) const
Call this member function to determine if the ColorSelector control is used in a dialog or used in a toolbar.
BOOL | SetTheme (XTPControlTheme eTheme)
Call this member function to switch the visual theme of the control.
BOOL | SetTheme (CXTPColorSelectorCtrlTheme *pTheme)
Call this member function to switch the visual theme of the control.
CXTPColorSelectorCtrlTheme * GetTheme ()
Call this member function to retrieve a pointer to the currently selected theme.
CSize | GetButtonSize () const
Call this member function to retrieve the size of a single color button.
int | GetNumCols () const
Call this member function to retrieve the number of columns displayed.
CRect | GetBorderRect () const
Call this member function to retrieve the size of the control border.
DWORD | GetPopupStyle () const
Call this member function to retrieve the pop-up style for the color selector control.
BOOL | ModifyPopupStyle (DWORD dwRemove, DWORD dwAdd)
Call this member function to modify the color selector style.
XTP_PICK_BUTTON * GetExtendedColors ()
Call this member function to retrieve the array of custom colors defined for the color selector control.
int | GetExtendedCount () const
Call this member function to retrieve the number of items in the custom color array.
int | GetCurSel () const
Call this member function to retrieve the index of the currently selected color.
int | GetPressed () const
Call this member function to retrieve the the index of the currently pressed color.
COLORREF | GetDefColor () const
Call this member function to retrieve the default color defined for the control.
COLORREF | GetCurColor () const
Call this member function to retrieve the currently selected color for the control.
CToolTipCtrl & | GetToolTipCtrl ()
Call this member function to retrieve a reference to the tooltip for the control.
CColorCellList & GetColorCellList ()
Call this member function to retrieve a reference to the cell list array for the control.
CString | GetThemeTitle ()
Call this member function to retrieve the string set for the theme caption.
CString | GetStandardTitle ()
Call this member function to retrieve the string set for the standard caption.
CString | GetCustomTitle ()
Call this member function to retrieve the string set for the custom caption.
BOOL | HasCaptions () const
Call this member function to determine if captions are used for the color selector.
void | ShowCaptions (BOOL bShow)
Call this member function to show/hide captions for the color selector.

Protected Member Functions

virtual void | EndSelection (int nCurSel)
This member function will finish the selection process for the color box or button in the color pop-up window.
- Protected Member Functions inherited from CXTPColorSelectorCtrl
BOOL | SetColors (CXTPPickBtnArray &arColors, const XTP_PICK_BUTTON *pColors, const int nCount)
Called to initialize the object specified by arColors using the data contained in the array specified by pColors.
void | DrawColorSelector (CDC *pDC)
This member function is called to draw the color selector.
BOOL | LookUpColor (const COLORREF crFind)
This member function is called to determine if the specified color is already in the ColorDialog's MRU list or in the standard colors list.
virtual void | OnEndSelection (int nCurSel, LPARAM callerParam)
This member function is called to finish the selection process for the color box or button in the color pop-up window.
virtual CSize | CalcSize ()
This method is called to calculate the size of the Selector to fit all buttons.
virtual void | RefreshMetrics ()
Call this member function to refresh theme colors and redraw the control.

Protected Attributes

BOOL | m_bAutoDelete
TRUE if the pop-up window is to be self deleting.
BOOL | m_bDisplayShadow
TRUE if the pop-up window will render its shadow.
CRect | m_rcExclude
Area to exclude from shadow display.
const LPARAM | m_callerParam
Caller parameter that will be reported back as an LPARAM of all.
CXTPShadowManager * | m_pShadowManager
notification messages.
- Protected Attributes inherited from CXTPColorSelectorCtrl
int | m_nCols
Number of columns in the color pop-up window.
int | m_nCurSel
Currently selected index.
int | m_nPressed
Pressed button.
BOOL | m_bCaptions
TRUE to display color captions.
CWnd * | m_pParentWnd
Pointer to the parent window for the pop-up window.
CRect | m_rcWnd
Rect for the pop-up window.
CRect | m_rcBorders
Control borders.
DWORD | m_dwPopup
Color pop-up window style.
CPoint | m_point
Last known cursor position.
CString | m_strTitleTheme
Represents the title for the theme colors caption.
CString | m_strTitleStandard
Represents the title for the standard colors caption.
CString | m_strTitleCustom
Custom colors title.
COLORREF | m_clrColor
An RGB value that represents the currently selected color.
COLORREF | m_clrDefault
An RGB value that represents the default color for the pop-up window.
CToolTipCtrl | m_tooltip
Tooltip control.
CListenerArray | m_listeners
Array of listener windows to be sent notifications.
CColorCellList | m_arCells
Array of color items.
CXTPColorDialog * | m_pColorDlg
Pointer to the color selection dialog when visible.
CXTPColorSelectorCtrlTheme * | m_pTheme
Pointer to the current theme.
XTP_PICK_BUTTON * | m_pExtendedColors
Custom colors.
int | m_nExtendedColors
Custom colors count.
CXTPPickBtnArray | m_arThemeColors
Theme color array.
CXTPPickBtnArray | m_arStandardColors
Standard color array.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPColorSelectorCtrl
static void AFX_CDECL | SetRecentColors (const CUIntArray &arRecentColors, LPCTSTR lpszTitle=NULL)
Call this member function to initialize the recently used color list for the color selector.
static CUIntArray &AFX_CDECL | GetRecentColors ()
Call this member function to retrieve a reference to the recently used color array.
static void AFX_CDECL | AddRecentColor (COLORREF clrRecent)
This member function will add a color to the user-defined color list.
static void AFX_CDECL | ResetRecentColors ()
Resets the recently used color list.
- Static Public Attributes inherited from CXTPColorSelectorCtrl
static CUIntArray | m_arRecentColors
Array of recently used colors.
static CString | m_strTitleRecent
Represents the title for the recent colors caption.
- Protected Types inherited from CXTPColorSelectorCtrl
typedef CList< COLOR_CELL *, COLOR_CELL * > | CColorCellList
List for maintaining COLOR_CELL structures.
typedef CArray< HWND, HWND > | CListenerArray
Array of listener windows to send notifications to.

Detailed Description

CXTPColorPopup is a CXTPColorSelectorCtrl derived class.

It is used to create a CXTPColorPopup window that will allow a user to select colors and add custom colors to a color list.

Constructor & Destructor Documentation

◆ CXTPColorPopup()

CXTPColorPopup | ( | BOOL | bAutoDelete = FALSE,
 |  | LPARAM | callerParam = 0 )

Constructs a CXTPColorPopup object.

Parameters
bAutoDelete | TRUE if the color picker window is to be self deleting.
callerParam | Caller parameter; it will be reported back as an LPARAM of color pop-up notification messages.

Member Function Documentation

◆ AddListener()

void AddListener ( HWND hwndListener )

This member function adds a window that picker notifications are sent to.

Parameters
hwndListener A handle to the listener window. Messages will be sent to it.

◆ Create()

virtual BOOL Create | ( | CRect & | rect,
 |  | CWnd * | pParentWnd,
 |  | DWORD | dwPopup,
 |  | COLORREF | clrColor,
 |  | COLORREF | clrDefault = CLR_DEFAULT )
 virtual

This member function handles the creation of the color pop-up window.

Parameters
rect | A reference to a CRect object that represents the size of the color pop-up window.
pParentWnd | Pointer to the parent window for the color pop-up.
dwPopup | Style for the pop-up window. See the Remarks section for a complete list of available styles.
clrColor | An RGB value that represents the currently selected color for the pop-up window.
clrDefault | Specifies the default color for the color pop-up. If the current style includes CPS_NOFILL, then this parameter is ignored.

Styles to be added or removed can be combined by using the bitwise OR (|) operator. It can be one or more of the following: CPS_XTP_NOFILL: The color picker will display a No Fill button rather than the default Automatic Color button. CPS_XTP_EXTENDED: The color picker will display 40 extended colors rather than the default 16 colors. CPS_XTP_MORECOLORS: The color picker will display a More Colors button which will display a CXTPColorDialog. CPS_XTP_SHOW3DSELECTION: Displays the color selection box with a 3D raised border in CXTPColorDialog. CPS_XTP_SHOWHEXVALUE: Displays the hex equivalent of the selected color. CPS_XTP_SHOWEYEDROPPER: Displays the eye dropper box to allow for selecting any color on the screen.

Returns
TRUE if successful, otherwise FALSE.
See also
CXTPColorPicker::ModifyCPStyle, CXTPColorSelectorCtrl::Create

◆ DisplayShadow()

void DisplayShadow ( BOOL bDisplayShadow = TRUE )

Enables/disables pop-up window shadow.

Parameters
bDisplayShadow Flag that tells if the shadow is to be displayed. TRUE to enable the shadow, FALSE to disable.

This member function enables/disables the drawing of pop-up shadows. Call this function after instantiating the color pop-up as a part of an object's initialization. Do not call it after pop-up creation because doing so may cause unpredictable results.

◆ EndSelection()

virtual void EndSelection ( int nCurSel )
protectedvirtual

This member function will finish the selection process for the color box or button in the color pop-up window.

Parameters
nCurSel Current index of the selected color box or button in the color pop-up window.

Reimplemented from CXTPColorSelectorCtrl.

The documentation for this class was generated from the following file:
  • XTPColorPopup.h


Toolkit Pro: CXTPColorSelectorCtrl Class Reference

Classes | Public Member Functions | Static Public Member Functions | Static Public Attributes | Protected Types | Protected Member Functions | Protected Attributes | List of all members
CXTPColorSelectorCtrl Class Reference

CXTPColorSelectorCtrl is a CWnd derived class. More...

Inheritance diagram for CXTPColorSelectorCtrl:
[legend]

Classes

struct COLOR_CELL
COLOR_CELL structure is used by the CXTPColorSelectorCtrl class to maintain information about a particular color cell. More...

Public Member Functions

CXTPColorSelectorCtrl ()
Constructs a CXTPColorSelectorCtrl object.
virtual | ~CXTPColorSelectorCtrl ()
Destroys a CXTPColorSelectorCtrl object, handles cleanup and deallocation.
CString | GetThemeTip (LPCTSTR lpszColor, LPCTSTR lpszDesc, int nShade)
Called to create a tooltip for a theme color using the specified string resource ID and shading that were originally passed into SetThemeColors.
BOOL | SetThemeColors (XTP_PICK_BUTTON *pColors=NULL, int nCount=10, LPCTSTR lpszTitle=NULL, UINT *pStringIDs=NULL, int ppShadeMatrix[6][10]=NULL)
Called to initialize the theme colors for the color selector.
BOOL | SetThemeColors (XTP_PICK_BUTTON *pColors, int nCount, LPCTSTR lpszTitle, LPCTSTR *ppszStrings, int ppShadeMatrix[6][10])
Called to initialize the theme colors for the color selector.
BOOL | SetThemeColors (CXTPPickBtnArray &arColors, int nCols=10, LPCTSTR lpszTitle=NULL)
Called to initialize the theme colors for the color selector.
BOOL | SetStandardColors (XTP_PICK_BUTTON *pColors=NULL, int nCount=10, int nCols=10, LPCTSTR lpszTitle=NULL)
Called to initialize the standard colors for the color selector.
BOOL | SetStandardColors (CXTPPickBtnArray &arColors, int nCols=10, LPCTSTR lpszTitle=NULL)
Called to initialize the standard colors for the color selector.
void | SetColors (XTP_PICK_BUTTON *pColors, int nCount, int nCols=8, LPCTSTR lpszTitle=NULL)
Call this method to set custom colors for the color picker.
CXTPPickBtnArray & GetThemeColors ()
Called to retrieve a reference to the theme color button array.
CXTPPickBtnArray & GetStandardColors ()
Called to retrieve a reference to the standard color button array.
int | GetCurSel (COLOR_CELL *pColorCell)
This member function will return the index of the currently selected color and will initialize 'pColorCell' struct.
void | SetCurSel (int nIndex)
This member function will select a button based upon its index.
BOOL | Create (CRect rect, CWnd *pParentWnd, DWORD dwPopup, COLORREF clrColor, COLORREF clrDefault=CLR_DEFAULT)
This member function handles the creation of the color pop-up window.
void | AddListener (HWND hwndListener)
This member function adds a window to send color picker notifications to.
void | RemoveListener (HWND hwndListener)
This member function removes a window from the notification list.
virtual void | SelectColorCell (COLOR_CELL *pColorCell)
This member function is called to select a color cell.
void | SelectColor (COLORREF clr)
This member function is called to select a color cell.
COLOR_CELL * | GetCellFromIndex (int iIndex)
This member function is called to retrieve a COLOR_CELL struct from the color cell array.
void | SetBorders (int l=0, int t=0, int r=0, int b=0)
This member function is called to set the size of the borders for the control.
bool | IsColorDlgVisible ()
Call this member function to determine if the color selection dialog is visible.
BOOL | IsColorStatic (CDC *pDC) const
Call this member function to determine if the ColorSelector control is used in a dialog or used in a toolbar.
BOOL | SetTheme (XTPControlTheme eTheme)
Call this member function to switch the visual theme of the control.
BOOL | SetTheme (CXTPColorSelectorCtrlTheme *pTheme)
Call this member function to switch the visual theme of the control.
CXTPColorSelectorCtrlTheme * GetTheme ()
Call this member function to retrieve a pointer to the currently selected theme.
CSize | GetButtonSize () const
Call this member function to retrieve the size of a single color button.
int | GetNumCols () const
Call this member function to retrieve the number of columns displayed.
CRect | GetBorderRect () const
Call this member function to retrieve the size of the control border.
DWORD | GetPopupStyle () const
Call this member function to retrieve the pop-up style for the color selector control.
BOOL | ModifyPopupStyle (DWORD dwRemove, DWORD dwAdd)
Call this member function to modify the color selector style.
XTP_PICK_BUTTON * GetExtendedColors ()
Call this member function to retrieve the array of custom colors defined for the color selector control.
int | GetExtendedCount () const
Call this member function to retrieve the number of items in the custom color array.
int | GetCurSel () const
Call this member function to retrieve the index of the currently selected color.
int | GetPressed () const
Call this member function to retrieve the the index of the currently pressed color.
COLORREF | GetDefColor () const
Call this member function to retrieve the default color defined for the control.
COLORREF | GetCurColor () const
Call this member function to retrieve the currently selected color for the control.
CToolTipCtrl & | GetToolTipCtrl ()
Call this member function to retrieve a reference to the tooltip for the control.
CColorCellList & GetColorCellList ()
Call this member function to retrieve a reference to the cell list array for the control.
CString | GetThemeTitle ()
Call this member function to retrieve the string set for the theme caption.
CString | GetStandardTitle ()
Call this member function to retrieve the string set for the standard caption.
CString | GetCustomTitle ()
Call this member function to retrieve the string set for the custom caption.
BOOL | HasCaptions () const
Call this member function to determine if captions are used for the color selector.
void | ShowCaptions (BOOL bShow)
Call this member function to show/hide captions for the color selector.

Static Public Member Functions

static void AFX_CDECL | SetRecentColors (const CUIntArray &arRecentColors, LPCTSTR lpszTitle=NULL)
Call this member function to initialize the recently used color list for the color selector.
static CUIntArray &AFX_CDECL | GetRecentColors ()
Call this member function to retrieve a reference to the recently used color array.
static void AFX_CDECL | AddRecentColor (COLORREF clrRecent)
This member function will add a color to the user-defined color list.
static void AFX_CDECL | ResetRecentColors ()
Resets the recently used color list.

Static Public Attributes

static CUIntArray | m_arRecentColors
Array of recently used colors.
static CString | m_strTitleRecent
Represents the title for the recent colors caption.

Protected Types

typedef CList< COLOR_CELL *, COLOR_CELL * > | CColorCellList
List for maintaining COLOR_CELL structures.
typedef CArray< HWND, HWND > | CListenerArray
Array of listener windows to send notifications to.

Protected Member Functions

BOOL | SetColors (CXTPPickBtnArray &arColors, const XTP_PICK_BUTTON *pColors, const int nCount)
Called to initialize the object specified by arColors using the data contained in the array specified by pColors.
void | DrawColorSelector (CDC *pDC)
This member function is called to draw the color selector.
virtual void | EndSelection (int nCurSel)
This member function will finish the selection process for the color box or button in the color pop-up window.
BOOL | LookUpColor (const COLORREF crFind)
This member function is called to determine if the specified color is already in the ColorDialog's MRU list or in the standard colors list.
virtual void | OnEndSelection (int nCurSel, LPARAM callerParam)
This member function is called to finish the selection process for the color box or button in the color pop-up window.
virtual CSize | CalcSize ()
This method is called to calculate the size of the Selector to fit all buttons.
virtual void | RefreshMetrics ()
Call this member function to refresh theme colors and redraw the control.

Protected Attributes

int | m_nCols
Number of columns in the color pop-up window.
int | m_nCurSel
Currently selected index.
int | m_nPressed
Pressed button.
BOOL | m_bCaptions
TRUE to display color captions.
CWnd * | m_pParentWnd
Pointer to the parent window for the pop-up window.
CRect | m_rcWnd
Rect for the pop-up window.
CRect | m_rcBorders
Control borders.
DWORD | m_dwPopup
Color pop-up window style.
CPoint | m_point
Last known cursor position.
CString | m_strTitleTheme
Represents the title for the theme colors caption.
CString | m_strTitleStandard
Represents the title for the standard colors caption.
CString | m_strTitleCustom
Custom colors title.
COLORREF | m_clrColor
An RGB value that represents the currently selected color.
COLORREF | m_clrDefault
An RGB value that represents the default color for the pop-up window.
CToolTipCtrl | m_tooltip
Tooltip control.
CListenerArray | m_listeners
Array of listener windows to be sent notifications.
CColorCellList | m_arCells
Array of color items.
CXTPColorDialog * | m_pColorDlg
Pointer to the color selection dialog when visible.
CXTPColorSelectorCtrlTheme * | m_pTheme
Pointer to the current theme.
XTP_PICK_BUTTON * | m_pExtendedColors
Custom colors.
int | m_nExtendedColors
Custom colors count.
CXTPPickBtnArray | m_arThemeColors
Theme color array.
CXTPPickBtnArray | m_arStandardColors
Standard color array.

Detailed Description

CXTPColorSelectorCtrl is a CWnd derived class.

It is used to create a CXTPColorSelectorCtrl control that will allow a user to select colors.

Member Typedef Documentation

◆ CColorCellList

CList<COLOR_CELL*, COLOR_CELL*> CColorCellList
protected

List for maintaining COLOR_CELL structures.

CList definition used by the CXTPColorSelectorCtrl class to maintain a list of COLOR_CELL structures representing each color item in the color selector control.

See also
CXTPColorSelectorCtrl, COLOR_CELL

◆ CListenerArray

CArray<HWND, HWND> CListenerArray
protected

Array of listener windows to send notifications to.

CArray definition used by the CXTPColorSelectorCtrl class to maintain a list of window handles that receive notification messages that are sent when an event occurs in the control.

See also
CXTPColorSelectorCtrl

Member Function Documentation

◆ AddListener()

void AddListener ( HWND hwndListener )

This member function adds a window to send color picker notifications to.

Parameters
hwndListener A handle to the listener window. Messages will be sent to it.

◆ AddRecentColor()

static void AFX_CDECL AddRecentColor ( COLORREF clrRecent )
static

This member function will add a color to the user-defined color list.

Parameters
clrRecent An RGB value that represents the recently used color to be added to the recent color list.
Returns

◆ CalcSize()

virtual CSize CalcSize ( )
protectedvirtual

This method is called to calculate the size of the Selector to fit all buttons.

Returns
Size of the Selector to fit all buttons.

◆ Create()

BOOL Create | ( | CRect | rect,
 |  | CWnd * | pParentWnd,
 |  | DWORD | dwPopup,
 |  | COLORREF | clrColor,
 |  | COLORREF | clrDefault = CLR_DEFAULT )

This member function handles the creation of the color pop-up window.

Parameters
rect | A reference to a CRect object that represents the size of the color pop-up window.
pParentWnd | Pointer to the parent window for the color pop-up.
dwPopup | Style for the pop-up window. See the Remarks section for a complete list of available styles.
clrColor | An RGB value that represents the currently selected color for the pop-up window.
clrDefault | Specifies the default color for the color pop-up. If the current style includes CPS_NOFILL, then this parameter is ignored.

Styles to be added or removed can be combined by using the bitwise OR (|) operator. It can be one or more of the following: CPS_XTP_NOFILL: Displays a "No Fill" button rather than the default Automatic Color button. CPS_XTP_EXTENDED: Displays 40 extended colors rather than the default 16 colors. CPS_XTP_MORECOLORS: Displays a "More Colors" button which will display a CXTPColorDialog. CPS_XTP_NOAUTOMATIC: Do not display an "Automatic Color" button. CPS_XTP_RECENTCOLORS: Displays a recently used color list for the control. CPS_XTP_RIGHTALIGN: The pop-up window is displayed right aligned. CPS_XTP_COLORBORDERS: The pop-up window displays color boxes with color borders.

Returns
TRUE if successful, otherwise FALSE.
See also
CXTPColorPicker::ModifyCPStyle, CXTPColorPopup::Create

◆ DrawColorSelector()

void DrawColorSelector ( CDC * pDC )
protected

This member function is called to draw the color selector.

Parameters
pDC A CDC pointer that represents the current device context.

◆ EndSelection()

virtual void EndSelection ( int nCurSel )
protectedvirtual

This member function will finish the selection process for the color box or button in the color pop-up window.

Parameters
nCurSel Current index of the selected color box or button in the color pop-up window.

Reimplemented in CXTPColorPopup.

◆ GetBorderRect()

CRect GetBorderRect ( ) const

Call this member function to retrieve the size of the control border.

Returns
A CRect representing the size of the control border.

◆ GetButtonSize()

CSize GetButtonSize ( ) const

Call this member function to retrieve the size of a single color button.

Returns
A CSize object representing the size of a single color button.

◆ GetCellFromIndex()

COLOR_CELL * GetCellFromIndex ( int iIndex )

This member function is called to retrieve a COLOR_CELL struct from the color cell array.

Parameters
iIndex Index into the color cell array.
Returns
A pointer to a COLOR_CELL object.

◆ GetColorCellList()

CColorCellList & GetColorCellList ( )

Call this member function to retrieve a reference to the cell list array for the control.

Returns
A reference to a CColorCellList object.

◆ GetCurColor()

COLORREF GetCurColor ( ) const

Call this member function to retrieve the currently selected color for the control.

Returns
An RGB value representing the currently selected color.

◆ GetCurSel() [1/2]

int GetCurSel ( ) const

Call this member function to retrieve the index of the currently selected color.

Returns
An integer representing the currently selected color.

◆ GetCurSel() [2/2]

int GetCurSel ( COLOR_CELL * pColorCell )

This member function will return the index of the currently selected color and will initialize 'pColorCell' struct.

Parameters
pColorCell Receives a pointer to the currently selected button.
Returns
The zero (0) based index of the currently selected button.

◆ GetCustomTitle()

CString GetCustomTitle ( )

Call this member function to retrieve the string set for the custom caption.

Returns
A string representing the custom caption.

◆ GetDefColor()

COLORREF GetDefColor ( ) const

Call this member function to retrieve the default color defined for the control.

Returns
An RGB value representing the default color.

◆ GetExtendedColors()

XTP_PICK_BUTTON * GetExtendedColors ( )

Call this member function to retrieve the array of custom colors defined for the color selector control.

Returns
A pointer to an XTP_PICK_BUTTON* array representing custom colors defined for the control.

◆ GetExtendedCount()

int GetExtendedCount ( ) const

Call this member function to retrieve the number of items in the custom color array.

Returns
An integer representing the number of items in the color array.

◆ GetNumCols()

int GetNumCols ( ) const

Call this member function to retrieve the number of columns displayed.

Returns
An integer value representing the number of columns.

◆ GetPopupStyle()

DWORD GetPopupStyle ( ) const

Call this member function to retrieve the pop-up style for the color selector control.

Returns
A DWORD value representing the pop-up style set for the control. Can be one or more of the following values: CPS_XTP_NOFILL: Displays a "No Fill" button rather than the default Automatic Color button. CPS_XTP_EXTENDED: Displays 40 extended colors rather than the default 16 colors. CPS_XTP_MORECOLORS: Displays a "More Colors" button which will display a CXTPColorDialog. CPS_XTP_NOAUTOMATIC: Do not display an "Automatic Color" button. CPS_XTP_RECENTCOLORS: Displays a recently used color list for the control. CPS_XTP_RIGHTALIGN: The pop-up window is displayed right aligned. CPS_XTP_COLORBORDERS: The pop-up window displays color boxes with color borders.

◆ GetPressed()

int GetPressed ( ) const

Call this member function to retrieve the the index of the currently pressed color.

Returns
An integer representing the currently pressed color.

◆ GetRecentColors()

static CUIntArray &AFX_CDECL GetRecentColors ( )
static

Call this member function to retrieve a reference to the recently used color array.

Returns
A reference to a CUIintArray object that represents an array of recently used COLORREF values.

◆ GetStandardColors()

CXTPPickBtnArray & GetStandardColors ( )

Called to retrieve a reference to the standard color button array.

Returns
Reference to a CXTPPickBtnArray object representing the standard color array for the color selector control.

◆ GetStandardTitle()

CString GetStandardTitle ( )

Call this member function to retrieve the string set for the standard caption.

Returns
A string representing the standard caption.

◆ GetTheme()

CXTPColorSelectorCtrlTheme * GetTheme ( )

Call this member function to retrieve a pointer to the currently selected theme.

Returns
A pointer to a CXTPColorSelectorCtrlTheme object representing the currently selected theme.

◆ GetThemeColors()

CXTPPickBtnArray & GetThemeColors ( )

Called to retrieve a reference to the theme color button array.

Returns
Reference to a CXTPPickBtnArray object representing the theme color array for the color selector control.

◆ GetThemeTip()

CString GetThemeTip | ( | LPCTSTR | lpszColor,
 |  | LPCTSTR | lpszDesc,
 |  | int | nShade )

Called to create a tooltip for a theme color using the specified string resource ID and shading that were originally passed into SetThemeColors.

Parameters
lpszColor | Name of the color.
lpszDesc | Description of the color.
nShade | Percentage that the color has been lightened or darkened.
Returns
A string representing the tooltip for the theme color.

◆ GetThemeTitle()

CString GetThemeTitle ( )

Call this member function to retrieve the string set for the theme caption.

Returns
A string representing the theme caption.

◆ GetToolTipCtrl()

CToolTipCtrl & GetToolTipCtrl ( )

Call this member function to retrieve a reference to the tooltip for the control.

Returns
A reference to a CToolTipCtl obbject.

◆ HasCaptions()

BOOL HasCaptions ( ) const

Call this member function to determine if captions are used for the color selector.

Returns
TRUE if themes are used, otherwise FALSE.

◆ IsColorDlgVisible()

bool IsColorDlgVisible ( )

Call this member function to determine if the color selection dialog is visible.

Returns
true if the color selection dialog is visible, otherwise false.

◆ IsColorStatic()

BOOL IsColorStatic ( CDC * pDC ) const

Call this member function to determine if the ColorSelector control is used in a dialog or used in a toolbar.

Parameters
pDC Device context of the control.
Returns
TRUE if the ColorSelector control is used in a dialog, or FALSE if the ColorSelector control is used in a toolbar.

◆ LookUpColor()

BOOL LookUpColor ( const COLORREF crFind )
protected

This member function is called to determine if the specified color is already in the ColorDialog's MRU list or in the standard colors list.

Parameters
crFind A const COLORREF value.
Returns
TRUE if the color is found, otherwise FALSE.

◆ ModifyPopupStyle()

BOOL ModifyPopupStyle | ( | DWORD | dwRemove,
 |  | DWORD | dwAdd )

Call this member function to modify the color selector style.

Styles to be added or removed can be combined by using the bitwise OR (|) operator. Can be one or more of the following values: CPS_XTP_NOFILL: Displays a "No Fill" button rather than the default Automatic Color button. CPS_XTP_EXTENDED: Displays 40 extended colors rather than the default 16 colors. CPS_XTP_MORECOLORS: Displays a "More Colors" button which will display a CXTPColorDialog. CPS_XTP_NOAUTOMATIC: Do not display an "Automatic Color" button. CPS_XTP_RECENTCOLORS: Displays a recently used color list for the control. CPS_XTP_RIGHTALIGN: The pop-up window is displayed right aligned. CPS_XTP_COLORBORDERS: The pop-up window displays color boxes with color borders.

Parameters
dwRemove | Specifies styles to be removed during style modification.
dwAdd | Specifies styles to be added during style modification.
Returns
Nonzero if style was successfully modified, otherwise 0.

◆ OnEndSelection()

virtual void OnEndSelection | ( | int | nCurSel,
 |  | LPARAM | callerParam )
 protectedvirtual

This member function is called to finish the selection process for the color box or button in the color pop-up window.

Parameters
nCurSel | Current index of the selected color box or button in the color pop-up window.
callerParam | User-defined value to be passed to listeners.

Override this method to pass user-defined data to the listener windows that receive notification messages.

◆ RemoveListener()

void RemoveListener ( HWND hwndListener )

This member function removes a window from the notification list.

Parameters
hwndListener A handle to the listener window to remove.

◆ ResetRecentColors()

static void AFX_CDECL ResetRecentColors ( )
static

Resets the recently used color list.

Call this member function to remove all colors from the recently used color list.

Returns

◆ SelectColor()

void SelectColor ( COLORREF clr )

This member function is called to select a color cell.

Parameters
clr Color of the selected cell.

◆ SelectColorCell()

virtual void SelectColorCell ( COLOR_CELL * pColorCell )
virtual

This member function is called to select a color cell.

Parameters
pColorCell Pointer to a COLOR_CELL object.

◆ SetBorders()

void SetBorders | ( | int | l = 0,
 |  | int | t = 0,
 |  | int | r = 0,
 |  | int | b = 0 )

This member function is called to set the size of the borders for the control.

Parameters
l | Specifies the left position.
t | Specifies the top position.
r | Specifies the right position.
b | Specifies the bottom position.

◆ SetColors() [1/2]

BOOL SetColors | ( | CXTPPickBtnArray & | arColors,
 |  | const XTP_PICK_BUTTON * | pColors,
 |  | const int | nCount )
 protected

Called to initialize the object specified by arColors using the data contained in the array specified by pColors.

Parameters
arColors | Reference to an array to be initalized.
pColors | Array of XTP_PICK_BUTTON structures.
nCount | Number of items contained in pColors.
Returns
TRUE if the array specified by arColors has been successfully initialized, otherwise FALSE.

◆ SetColors() [2/2]

void SetColors | ( | XTP_PICK_BUTTON * | pColors,
 |  | int | nCount,
 |  | int | nCols = 8,
 |  | LPCTSTR | lpszTitle = NULL )

Call this method to set custom colors for the color picker.

Parameters
pColors | Static array of colors and tooltips.
nCount | Number of colors.
nCols | Number of columns to show.
lpszTitle | Custom title for colors displayed.

◆ SetCurSel()

void SetCurSel ( int nIndex )

This member function will select a button based upon its index.

Parameters
nIndex An integer value that represents the zero (0) based index of the button to be selected.

◆ SetRecentColors()

static void AFX_CDECL SetRecentColors | ( | const CUIntArray & | arRecentColors,
 |  | LPCTSTR | lpszTitle = NULL )
 static

Call this member function to initialize the recently used color list for the color selector.

Parameters
arRecentColors | Reference to a CUIntArray object that contains an array of COLORREF values.
lpszTitle | Title used for the recent colors caption.
Returns

◆ SetStandardColors() [1/2]

BOOL SetStandardColors | ( | CXTPPickBtnArray & | arColors,
 |  | int | nCols = 10,
 |  | LPCTSTR | lpszTitle = NULL )

Called to initialize the standard colors for the color selector.

Parameters
arColors | Array of colors used to initialize the standard
nCols | Number of columns to show.
lpszTitle | Title used for theme colors caption. colors.
Returns
TRUE if successful, otherwise FALSE. Example: Here is an example of how to use SetThemeColors:
XTP_PICK_BUTTON _StdColors[] =
{
   { RGB(192,   0,   0), XTP_IDS_CLR_DARK_RED    },
   { RGB(255,   0,   0), XTP_IDS_CLR_RED         },
   { RGB(255, 192,   0), XTP_IDS_CLR_ORANGE      },
   { RGB(255, 255,   0), XTP_IDS_CLR_YELLOW      },
   { RGB(146, 208,  80), XTP_IDS_CLR_LIGHT_GREEN },
   { RGB(  0, 176,  80), XTP_IDS_CLR_GREEN       },
   { RGB(  0, 176, 240), XTP_IDS_CLR_LIGHT_BLUE  },
   { RGB(  0, 112, 192), XTP_IDS_CLR_BLUE        },
   { RGB(  0,  32,  96), XTP_IDS_CLR_DARK_BLUE   },
   { RGB(112,  48, 160), XTP_IDS_CLR_PURPLE      },
};

SetStandardColors(_StdColors, _countof(_StdColors));

◆ SetStandardColors() [2/2]

BOOL SetStandardColors | ( | XTP_PICK_BUTTON * | pColors = NULL,
 |  | int | nCount = 10,
 |  | int | nCols = 10,
 |  | LPCTSTR | lpszTitle = NULL )

Called to initialize the standard colors for the color selector.

Parameters
pColors | Array of colors and tooltips.
nCount | Number of colors in the array.
nCols | Number of columns to show.
lpszTitle | Title used for theme colors caption.
Returns
TRUE if successful, otherwise FALSE. Example: Here is an example of how to use SetThemeColors:
XTP_PICK_BUTTON _StdColors[] =
{
   { RGB(192,   0,   0), XTP_IDS_CLR_DARK_RED    },
   { RGB(255,   0,   0), XTP_IDS_CLR_RED         },
   { RGB(255, 192,   0), XTP_IDS_CLR_ORANGE      },
   { RGB(255, 255,   0), XTP_IDS_CLR_YELLOW      },
   { RGB(146, 208,  80), XTP_IDS_CLR_LIGHT_GREEN },
   { RGB(  0, 176,  80), XTP_IDS_CLR_GREEN       },
   { RGB(  0, 176, 240), XTP_IDS_CLR_LIGHT_BLUE  },
   { RGB(  0, 112, 192), XTP_IDS_CLR_BLUE        },
   { RGB(  0,  32,  96), XTP_IDS_CLR_DARK_BLUE   },
   { RGB(112,  48, 160), XTP_IDS_CLR_PURPLE      },
};

SetStandardColors(_StdColors, _countof(_StdColors));

◆ SetTheme() [1/2]

BOOL SetTheme ( CXTPColorSelectorCtrlTheme * pTheme )

Call this member function to switch the visual theme of the control.

Parameters
pTheme Pointer to the new control theme.

eTheme can be one of the following values: xtpControlThemeDefault: Use default theme. xtpControlThemeOfficeXP: Use Office XP theme. xtpControlThemeOffice2003: Use Office 2003 theme. xtpControlThemeResource: Use Office 2007 theme.

Returns
TRUE if successful, otherwise FALSE.

◆ SetTheme() [2/2]

BOOL SetTheme ( XTPControlTheme eTheme )

Call this member function to switch the visual theme of the control.

Parameters
eTheme New window theme. Can be any of the values listed in the Remarks section.

eTheme can be one of the following values: xtpControlThemeDefault: Use default theme. xtpControlThemeOfficeXP: Use Office XP theme. xtpControlThemeOffice2003: Use Office 2003 theme. xtpControlThemeResource: Use Office 2007 theme.

Returns
TRUE if successful, otherwise FALSE.

◆ SetThemeColors() [1/3]

BOOL SetThemeColors | ( | CXTPPickBtnArray & | arColors,
 |  | int | nCols = 10,
 |  | LPCTSTR | lpszTitle = NULL )

Called to initialize the theme colors for the color selector.

The colors passed in must be an array of 10 colors. Additional values can be passed in such as an array of 10 string resource IDs and a 6 x 10 shading matrix used to adjust each of the 10 theme colors passed in.

Parameters
arColors | Array of colors used to initialize the theme
nCols | Number of columns displayed.
lpszTitle | Title used for theme colors caption. colors.
Returns
TRUE if successful, otherwise FALSE. Example: Here is an example of how to use SetThemeColors:
XTP_PICK_BUTTON _ThemeColors[] =
{
   { RGB(255, 255, 255), XTP_IDS_CLR_WHITE    },
   { RGB(  0,   0,   0), XTP_IDS_CLR_BLACK    },
   { RGB(231, 230, 230), XTP_IDS_CLR_GRAY25   },
   { RGB( 68,  84, 106), XTP_IDS_CLR_BLUEGRAY },
   { RGB( 91, 155, 213), XTP_IDS_CLR_BLUE     },
   { RGB(237, 125,  49), XTP_IDS_CLR_ORANGE   },
   { RGB(165, 165, 165), XTP_IDS_CLR_GRAY50   },
   { RGB(255, 192,   0), XTP_IDS_CLR_GOLD     },
   { RGB( 68, 114, 196), XTP_IDS_CLR_BLUE     },
   { RGB(112, 173,  71), XTP_IDS_CLR_GREEN    },
};

UINT _StringIDs[10] =
{
   XTP_IDS_BACKGROUND1,
   XTP_IDS_TEXT1,
   XTP_IDS_BACKGROUND2,
   XTP_IDS_TEXT2,
   XTP_IDS_ACCENT1,
   XTP_IDS_ACCENT2,
   XTP_IDS_ACCENT3,
   XTP_IDS_ACCENT4,
   XTP_IDS_ACCENT5,
   XTP_IDS_ACCENT6,
};

int _Shade[6][10] =
{
   {   0,   0,   0,   0,   0,   0,   0,   0,   0,   0 },
   {  -5, +50, -10, +80, +80, +80, +80, +80, +80, +80 },
   { -15, +35, -25, +60, +60, +60, +60, +60, +60, +60 },
   { -25, +25, -50, +40, +40, +40, +40, +40, +40, +40 },
   { -35, +15, -75, -25, -25, -25, -25, -25, -25, -25 },
   { -50, + 5, -90, -50, -50, -50, -50, -50, -50, -50 },
};

SetThemeColors(_ThemeColors, _countof(_ThemeColors), _StringIDs, _Shade);

◆ SetThemeColors() [2/3]

BOOL SetThemeColors | ( | XTP_PICK_BUTTON * | pColors,
 |  | int | nCount,
 |  | LPCTSTR | lpszTitle,
 |  | LPCTSTR * | ppszStrings,
 |  | int | ppShadeMatrix[6][10] )

Called to initialize the theme colors for the color selector.

The colors passed in must be an array of 10 colors. Additional values can be passed in such as an array of 10 string resource IDs and a 6 x 10 shading matrix used to adjust each of the 10 theme colors passed in.

Parameters
pColors | Array of colors and tooltips.
nCount | Number of colors in the array.
lpszTitle | Title used for theme colors caption.
ppszStrings | Array of strings representing each color's description. Values cannot be NULL. Array size must match nCount.
ppShadeMatrix | 6 x 10 matrix array that specifies 6 rows of shading by 10 colums. If NULL, then default values are used.
Returns
TRUE if successful, otherwise FALSE. Example: Here is an example of how to use SetThemeColors:
XTP_PICK_BUTTON _ThemeColors[] =
{
   { RGB(255, 255, 255), XTP_IDS_CLR_WHITE    },
   { RGB(  0,   0,   0), XTP_IDS_CLR_BLACK    },
   { RGB(231, 230, 230), XTP_IDS_CLR_GRAY25   },
   { RGB( 68,  84, 106), XTP_IDS_CLR_BLUEGRAY },
   { RGB( 91, 155, 213), XTP_IDS_CLR_BLUE     },
   { RGB(237, 125,  49), XTP_IDS_CLR_ORANGE   },
   { RGB(165, 165, 165), XTP_IDS_CLR_GRAY50   },
   { RGB(255, 192,   0), XTP_IDS_CLR_GOLD     },
   { RGB( 68, 114, 196), XTP_IDS_CLR_BLUE     },
   { RGB(112, 173,  71), XTP_IDS_CLR_GREEN    },
};

UINT _StringIDs[10] =
{
   XTP_IDS_BACKGROUND1,
   XTP_IDS_TEXT1,
   XTP_IDS_BACKGROUND2,
   XTP_IDS_TEXT2,
   XTP_IDS_ACCENT1,
   XTP_IDS_ACCENT2,
   XTP_IDS_ACCENT3,
   XTP_IDS_ACCENT4,
   XTP_IDS_ACCENT5,
   XTP_IDS_ACCENT6,
};

int _Shade[6][10] =
{
   {   0,   0,   0,   0,   0,   0,   0,   0,   0,   0 },
   {  -5, +50, -10, +80, +80, +80, +80, +80, +80, +80 },
   { -15, +35, -25, +60, +60, +60, +60, +60, +60, +60 },
   { -25, +25, -50, +40, +40, +40, +40, +40, +40, +40 },
   { -35, +15, -75, -25, -25, -25, -25, -25, -25, -25 },
   { -50, + 5, -90, -50, -50, -50, -50, -50, -50, -50 },
};

SetThemeColors(_ThemeColors, _countof(_ThemeColors), _StringIDs, _Shade);

◆ SetThemeColors() [3/3]

BOOL SetThemeColors | ( | XTP_PICK_BUTTON * | pColors = NULL,
 |  | int | nCount = 10,
 |  | LPCTSTR | lpszTitle = NULL,
 |  | UINT * | pStringIDs = NULL,
 |  | int | ppShadeMatrix[6][10] = NULL )

Called to initialize the theme colors for the color selector.

The colors passed in must be an array of 10 colors. Additional values can be passed in such as an array of 10 string resource IDs and a 6 x 10 shading matrix used to adjust each of the 10 theme colors passed in.

Parameters
pColors | Array of colors and tooltips.
nCount | Number of colors in the array.
lpszTitle | Title used for theme colors caption.
pStringIDs | Array of resource IDs representing each color's description. If NULL, then default values are used. Array size must match nCount.
ppShadeMatrix | 6 x 10 matrix array that specifies 6 rows of shading by 10 colums. If NULL, then default values are used.
Returns
TRUE if successful, otherwise FALSE. Example: Here is an example of how to use SetThemeColors:
XTP_PICK_BUTTON _ThemeColors[] =
{
   { RGB(255, 255, 255), XTP_IDS_CLR_WHITE    },
   { RGB(  0,   0,   0), XTP_IDS_CLR_BLACK    },
   { RGB(231, 230, 230), XTP_IDS_CLR_GRAY25   },
   { RGB( 68,  84, 106), XTP_IDS_CLR_BLUEGRAY },
   { RGB( 91, 155, 213), XTP_IDS_CLR_BLUE     },
   { RGB(237, 125,  49), XTP_IDS_CLR_ORANGE   },
   { RGB(165, 165, 165), XTP_IDS_CLR_GRAY50   },
   { RGB(255, 192,   0), XTP_IDS_CLR_GOLD     },
   { RGB( 68, 114, 196), XTP_IDS_CLR_BLUE     },
   { RGB(112, 173,  71), XTP_IDS_CLR_GREEN    },
};

UINT _StringIDs[10] =
{
   XTP_IDS_BACKGROUND1,
   XTP_IDS_TEXT1,
   XTP_IDS_BACKGROUND2,
   XTP_IDS_TEXT2,
   XTP_IDS_ACCENT1,
   XTP_IDS_ACCENT2,
   XTP_IDS_ACCENT3,
   XTP_IDS_ACCENT4,
   XTP_IDS_ACCENT5,
   XTP_IDS_ACCENT6,
};

int _Shade[6][10] =
{
   {   0,   0,   0,   0,   0,   0,   0,   0,   0,   0 },
   {  -5, +50, -10, +80, +80, +80, +80, +80, +80, +80 },
   { -15, +35, -25, +60, +60, +60, +60, +60, +60, +60 },
   { -25, +25, -50, +40, +40, +40, +40, +40, +40, +40 },
   { -35, +15, -75, -25, -25, -25, -25, -25, -25, -25 },
   { -50, + 5, -90, -50, -50, -50, -50, -50, -50, -50 },
};

SetThemeColors(_ThemeColors, _countof(_ThemeColors), _StringIDs, _Shade);

◆ ShowCaptions()

void ShowCaptions ( BOOL bShow )

Call this member function to show/hide captions for the color selector.

Parameters
bShow TRUE to show captions, FALSE to hide.
The documentation for this class was generated from the following file:
  • XTPColorSelectorCtrl.h


Toolkit Pro: CXTPColorSelectorCtrl::COLOR_CELL Struct Reference

  • CXTPColorSelectorCtrl
  • COLOR_CELL
Public Attributes | List of all members
CXTPColorSelectorCtrl::COLOR_CELL Struct Reference

COLOR_CELL structure is used by the CXTPColorSelectorCtrl class to maintain information about a particular color cell. More...

Public Attributes

UINT | nID
Command ID of the color cell.
UINT | nIndex
Index of the color cell.
bool | bChecked
true if the cell is checked.
CRect | rect
Size of the color cell.
CRect | rcBorder
Determines what borders are drawn.
DWORD | dwStyle
Color picker style for the cell.
TCHAR | szText [256]
Tooltip text displayed for the color cell.
COLORREF | clr
An RGB value that represents the color of the cell.

Detailed Description

COLOR_CELL structure is used by the CXTPColorSelectorCtrl class to maintain information about a particular color cell.

See also
CXTPColorSelectorCtrl
The documentation for this struct was generated from the following file:
  • XTPColorSelectorCtrl.h


Toolkit Pro: CXTPColorSelectorCtrlTheme Class Reference

Public Member Functions | Public Attributes | List of all members
CXTPColorSelectorCtrlTheme Class Reference

CXTPColorSelectorCtrlTheme is derived from CXTPControlThemeManagerStyle to handle theme specific visualizations for the CXTPColorSelectorCtrl class. More...

Inheritance diagram for CXTPColorSelectorCtrlTheme:
[legend]

Public Member Functions

CXTPColorSelectorCtrlTheme ()
Constructs a CXTPColorSelectorCtrlTheme object.
virtual void | RefreshMetrics (CXTPColorSelectorCtrl *pOwner)
This member function is called by the theme manager to refresh the visual styles used by each component's theme.
virtual void | FillBackground (CDC *pDC, CXTPColorSelectorCtrl *pOwner, const CRect &rect)
Call this member function to draw the background of the ColorSelector control.
virtual void | DrawColorCell (CDC *pDC, CXTPColorSelectorCtrl *pOwner, CXTPColorSelectorCtrl::COLOR_CELL *pColorCell, BOOL bHighlight, BOOL bPressed)
This member function is called to draw the cell specified by 'pColorCell'.
virtual void | DrawColorSelector (CDC *pDC, CXTPColorSelectorCtrl *pOwner)
This member function is called to draw the color selector.
virtual CSize | CalcSize (CXTPColorSelectorCtrl *pOwner)
Called to determine the size of the color selector window.
virtual BOOL | CreateAutoButton (CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked)
Called to add the 'Automatic Color' button to the color selector control.
virtual BOOL | CreateExtendedButtons (CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked)
Called to add default color buttons to the color selector control.
virtual BOOL | CreateThemeButtons (CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked)
Called to add theme and standard buttons to the color selector control.
virtual BOOL | CreateColorButtons (CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked)
Called to determine if theme or default color buttons should be added.
virtual BOOL | CreateRecentColorButtons (CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked)
Called to add recent colors to the color selector control.
virtual BOOL | CreateMoreButton (CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked)
Called to add a 'More Colors' button to the color selector control.
virtual CSize | GetButtonSize () const
Call to retrieve the size of a single color button.
- Public Member Functions inherited from CXTPControlTheme
CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme | GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Public Attributes

int | m_nAutoButton
Height of the Automatic/More Colors buttons.
int | m_nCaption
Height of a caption that is displayed in the control.
int | m_nMargin
Size for default margin spacing.
CRect | m_rcThemeText
Size and location of the 'Theme Colors' caption area text.
CRect | m_rcRecentText
Size and location of the 'Recent Colors' caption area text.
CRect | m_rcStandardText
Size and location of the 'Standard Colors' caption area text.
CSize | m_sizeButton
cx and cy size for a color picker button.
BOOL | m_bThinBorder
TRUE to use thin borders.
COLORREF | m_crBorder
An RGB value representing the border color.
COLORREF | m_crBorderHilight
An RGB value for border highlight color.
COLORREF | m_crBorderPressed
An RGB value for border pressed color.
COLORREF | m_crBack
An RGB value for background color.
COLORREF | m_crBackPressed
An RGB value for pressed background color.
COLORREF | m_crBackHilight
An RGB value for background highlight color.
COLORREF | m_crBackChecked
An RGB value for checked background color.
COLORREF | m_crText
An RGB value for text color.
COLORREF | m_crTextPressed
An RGB value for text pressed color.
COLORREF | m_crPopupBorder
An RGB value for the pop-up border.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlTheme
static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Attributes inherited from CXTPControlTheme
XTPControlTheme | m_nTheme
Currently selected theme style index.

Detailed Description

CXTPColorSelectorCtrlTheme is derived from CXTPControlThemeManagerStyle to handle theme specific visualizations for the CXTPColorSelectorCtrl class.

Member Function Documentation

◆ CalcSize()

virtual CSize CalcSize ( CXTPColorSelectorCtrl * pOwner )
virtual

Called to determine the size of the color selector window.

Parameters
pOwner A pointer to the parent CXTPColorSelectorCtrl object.
Returns
A CSize object containing the width and height for the control.

Reimplemented in CXTPColorSelectorCtrlThemeOffice2013.

◆ CreateAutoButton()

virtual BOOL CreateAutoButton | ( | CXTPColorSelectorCtrl * | pOwner,
 |  | int & | nIndex,
 |  | const int | x,
 |  | int & | y,
 |  | const int | cx,
 |  | bool & | bChecked )
 virtual

Called to add the 'Automatic Color' button to the color selector control.

Parameters
pOwner | A pointer to the parent CXTPColorSelectorCtrl object.
nIndex | Reference to an integer representing the next available index in the color cell array.
x | Specifies the starting coordinates for the left edge.
y | Specifies the starting coordinates for the top edge.
cx | Specifies the width of the client area.
bChecked | TRUE when a color button has been checked.
Returns
TRUE if the 'Automatic Color' button was successfully created, otherwise FALSE.

Reimplemented in CXTPColorSelectorCtrlThemeOffice2013.

◆ CreateColorButtons()

virtual BOOL CreateColorButtons | ( | CXTPColorSelectorCtrl * | pOwner,
 |  | int & | nIndex,
 |  | const int | x,
 |  | int & | y,
 |  | const int | cx,
 |  | bool & | bChecked )
 virtual

Called to determine if theme or default color buttons should be added.

Parameters
pOwner | A pointer to the parent CXTPColorSelectorCtrl object.
nIndex | Reference to an integer representing the next available index in the color cell array.
x | Specifies starting coordinates for the left edge.
y | Specifies starting coordinates for the top edge.
cx | Specifies the width of the client area.
bChecked | TRUE when a color button has been checked.
Returns
TRUE if successful, otherwise FALSE.

◆ CreateExtendedButtons()

virtual BOOL CreateExtendedButtons | ( | CXTPColorSelectorCtrl * | pOwner,
 |  | int & | nIndex,
 |  | const int | x,
 |  | int & | y,
 |  | const int | cx,
 |  | bool & | bChecked )
 virtual

Called to add default color buttons to the color selector control.

Parameters
pOwner | A pointer to the parent CXTPColorSelectorCtrl object.
nIndex | Reference to an integer representing the next available index in the color cell array.
x | Specifies starting coordinates for the left edge.
y | Specifies starting coordinates for the top edge.
cx | Specifies the width of the client area.
bChecked | TRUE when a color button has been checked.
Returns
TRUE if successful, otherwise FALSE.

Reimplemented in CXTPColorSelectorCtrlThemeOffice2013.

◆ CreateMoreButton()

virtual BOOL CreateMoreButton | ( | CXTPColorSelectorCtrl * | pOwner,
 |  | int & | nIndex,
 |  | const int | x,
 |  | int & | y,
 |  | const int | cx,
 |  | bool & | bChecked )
 virtual

Called to add a 'More Colors' button to the color selector control.

Parameters
pOwner | A pointer to the parent CXTPColorSelectorCtrl object.
nIndex | Reference to an integer representing the next available index in the color cell array.
x | Specifies starting coordinates for the left edge.
y | Specifies starting coordinates for the top edge.
cx | Specifies the width of the client area.
bChecked | TRUE when a color button has been checked.
Returns
TRUE if successful, otherwise FALSE.

Reimplemented in CXTPColorSelectorCtrlThemeOffice2013.

◆ CreateRecentColorButtons()

virtual BOOL CreateRecentColorButtons | ( | CXTPColorSelectorCtrl * | pOwner,
 |  | int & | nIndex,
 |  | const int | x,
 |  | int & | y,
 |  | const int | cx,
 |  | bool & | bChecked )
 virtual

Called to add recent colors to the color selector control.

Parameters
pOwner | A pointer to the parent CXTPColorSelectorCtrl object.
nIndex | Reference to an integer representing the next available index in the color cell array.
x | Specifies starting coordinates for the left edge.
y | Specifies starting coordinates for the top edge.
cx | Specifies the width of the client area.
bChecked | TRUE when a color button has been checked.
Returns
TRUE if successful, otherwise FALSE.

Reimplemented in CXTPColorSelectorCtrlThemeOffice2013.

◆ CreateThemeButtons()

virtual BOOL CreateThemeButtons | ( | CXTPColorSelectorCtrl * | pOwner,
 |  | int & | nIndex,
 |  | const int | x,
 |  | int & | y,
 |  | const int | cx,
 |  | bool & | bChecked )
 virtual

Called to add theme and standard buttons to the color selector control.

Parameters
pOwner | A pointer to the parent CXTPColorSelectorCtrl object.
nIndex | Reference to an integer representing the next available index in the color cell array.
x | Specifies starting coordinates for the left edge.
y | Specifies starting coordinates for the top edge.
cx | Specifies the width of the client area.
bChecked | TRUE when a color button has been checked.
Returns
TRUE if successful, otherwise FALSE.

Reimplemented in CXTPColorSelectorCtrlThemeOffice2013.

◆ DrawColorCell()

virtual void DrawColorCell | ( | CDC * | pDC,
 |  | CXTPColorSelectorCtrl * | pOwner,
 |  | CXTPColorSelectorCtrl::COLOR_CELL * | pColorCell,
 |  | BOOL | bHighlight,
 |  | BOOL | bPressed )
 virtual

This member function is called to draw the cell specified by 'pColorCell'.

Parameters
pDC | A CDC pointer that represents the current device context.
pOwner | A pointer to the parent CXTPColorSelectorCtrl object.
pColorCell | A COLOR_CELL object.
bHighlight | TRUE if the mouse is over the cell.
bPressed | TRUE if the cell is pressed.

Reimplemented in CXTPColorSelectorCtrlThemeOffice2013, and CXTPColorSelectorCtrlThemeVisualStudio2015.

◆ DrawColorSelector()

virtual void DrawColorSelector | ( | CDC * | pDC,
 |  | CXTPColorSelectorCtrl * | pOwner )
 virtual

This member function is called to draw the color selector.

Parameters
pDC | A CDC pointer that represents the current device context.
pOwner | A pointer to the parent CXTPColorSelectorCtrl object.

Reimplemented in CXTPColorSelectorCtrlThemeOffice2013.

◆ FillBackground()

virtual void FillBackground | ( | CDC * | pDC,
 |  | CXTPColorSelectorCtrl * | pOwner,
 |  | const CRect & | rect )
 virtual

Call this member function to draw the background of the ColorSelector control.

Parameters
pDC | A pointer to a valid device context.
pOwner | A pointer to the parent CXTPColorSelectorCtrl object.
rect | A CRect object that contains the dimensions of the area to fill.

◆ GetButtonSize()

virtual CSize GetButtonSize ( ) const
virtual

Call to retrieve the size of a single color button.

Returns
A CSize object representing the size of a single color button.

◆ RefreshMetrics()

virtual void RefreshMetrics ( CXTPColorSelectorCtrl * pOwner )
virtual

This member function is called by the theme manager to refresh the visual styles used by each component's theme.

Parameters
pOwner A pointer to the parent CXTPColorSelectorCtrl object.

Reimplemented in CXTPColorSelectorCtrlThemeOffice2003, CXTPColorSelectorCtrlThemeOffice2013, CXTPColorSelectorCtrlThemeOfficeXP, CXTPColorSelectorCtrlThemeResource, and CXTPColorSelectorCtrlThemeVisualStudio2015.

The documentation for this class was generated from the following file:
  • XTPColorSelectorCtrl.h


Toolkit Pro: CXTPColorSelectorCtrlThemeNativeWindows10 Class Reference

Public Member Functions | List of all members
CXTPColorSelectorCtrlThemeNativeWindows10 Class Reference

CXTPColorSelectorCtrlThemeNativeWindows10 is derived from CXTPColorSelectorCtrlThemeVisualStudio2015 to handle theme specific visualizations for the CXTPColorSelectorCtrl class. More...

Inheritance diagram for CXTPColorSelectorCtrlThemeNativeWindows10:
[legend]

Public Member Functions

CXTPColorSelectorCtrlThemeNativeWindows10 ()
Default constructor.
- Public Member Functions inherited from CXTPColorSelectorCtrlThemeVisualStudio2015
CXTPColorSelectorCtrlThemeVisualStudio2015 ()
Default constructor.
virtual void | RefreshMetrics (CXTPColorSelectorCtrl *pOwner)
Called by the theme manager to refresh the visual styles used by each component's theme.
virtual void | DrawColorCell (CDC *pDC, CXTPColorSelectorCtrl *pOwner, CXTPColorSelectorCtrl::COLOR_CELL *pColorCell, BOOL bHighlight, BOOL bPressed)
This member function is called to draw the cell specified by 'pColorCell'.
- Public Member Functions inherited from CXTPColorSelectorCtrlThemeOffice2013
CXTPColorSelectorCtrlThemeOffice2013 ()
Default constructor.
virtual void | DrawBorder (CDC *pDC, CRect rcItem, CRect rcBorder, COLORREF crBorder)
This member function is called to draw the cell specified by 'pColorCell'.
virtual void | DrawColor (CDC *pDC, CXTPColorSelectorCtrl *pOwner, CXTPColorSelectorCtrl::COLOR_CELL *pColorCell, CRect rcItem, BOOL bChecked, BOOL bHighlight, BOOL bPressed)
Called to draw a color cell for the color selector control.
virtual void | DrawColorSelector (CDC *pDC, CXTPColorSelectorCtrl *pOwner)
This member function is called to draw the color selector.
virtual CSize | CalcSize (CXTPColorSelectorCtrl *pOwner)
Called to determine the size of the color selector window.
virtual BOOL | CreateAutoButton (CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked)
Called to add the 'Automatic Color' button to the color selector control.
virtual BOOL | CreateExtendedButtons (CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked)
Called to add default color buttons to the color selector control.
virtual BOOL | CreateThemeButtons (CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked)
Called to add theme and standard buttons to the color selector control.
virtual BOOL | CreateRecentColorButtons (CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked)
Called to add recent colors to the color selector control.
virtual BOOL | CreateMoreButton (CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked)
Called to add a 'More Colors' button to the color selector control.
- Public Member Functions inherited from CXTPColorSelectorCtrlTheme
CXTPColorSelectorCtrlTheme ()
Constructs a CXTPColorSelectorCtrlTheme object.
virtual void | FillBackground (CDC *pDC, CXTPColorSelectorCtrl *pOwner, const CRect &rect)
Call this member function to draw the background of the ColorSelector control.
virtual BOOL | CreateColorButtons (CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked)
Called to determine if theme or default color buttons should be added.
virtual CSize | GetButtonSize () const
Call to retrieve the size of a single color button.
- Public Member Functions inherited from CXTPControlTheme
CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme | GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlTheme
static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPColorSelectorCtrlTheme
int | m_nAutoButton
Height of the Automatic/More Colors buttons.
int | m_nCaption
Height of a caption that is displayed in the control.
int | m_nMargin
Size for default margin spacing.
CRect | m_rcThemeText
Size and location of the 'Theme Colors' caption area text.
CRect | m_rcRecentText
Size and location of the 'Recent Colors' caption area text.
CRect | m_rcStandardText
Size and location of the 'Standard Colors' caption area text.
CSize | m_sizeButton
cx and cy size for a color picker button.
BOOL | m_bThinBorder
TRUE to use thin borders.
COLORREF | m_crBorder
An RGB value representing the border color.
COLORREF | m_crBorderHilight
An RGB value for border highlight color.
COLORREF | m_crBorderPressed
An RGB value for border pressed color.
COLORREF | m_crBack
An RGB value for background color.
COLORREF | m_crBackPressed
An RGB value for pressed background color.
COLORREF | m_crBackHilight
An RGB value for background highlight color.
COLORREF | m_crBackChecked
An RGB value for checked background color.
COLORREF | m_crText
An RGB value for text color.
COLORREF | m_crTextPressed
An RGB value for text pressed color.
COLORREF | m_crPopupBorder
An RGB value for the pop-up border.
- Protected Attributes inherited from CXTPColorSelectorCtrlThemeOffice2013
COLORREF | m_crTitleText
An RGB value representing the title text color.
COLORREF | m_crTitleBack
An RGB value representing the title background color.
COLORREF | m_crBorderInside
An RGB value representing the inside border highlight color.
- Protected Attributes inherited from CXTPControlTheme
XTPControlTheme | m_nTheme
Currently selected theme style index.

Detailed Description

CXTPColorSelectorCtrlThemeNativeWindows10 is derived from CXTPColorSelectorCtrlThemeVisualStudio2015 to handle theme specific visualizations for the CXTPColorSelectorCtrl class.

The documentation for this class was generated from the following file:
  • XTPColorSelectorCtrl.h


Toolkit Pro: CXTPColorSelectorCtrlThemeNativeWindows11 Class Reference

Public Member Functions | List of all members
CXTPColorSelectorCtrlThemeNativeWindows11 Class Reference

CXTPColorSelectorCtrlThemeNativeWindows11 is derived from CXTPColorSelectorCtrlThemeVisualStudio2015 to handle theme specific visualizations for the CXTPColorSelectorCtrl class. More...

Inheritance diagram for CXTPColorSelectorCtrlThemeNativeWindows11:
[legend]

Public Member Functions

CXTPColorSelectorCtrlThemeNativeWindows11 ()
Default constructor.
- Public Member Functions inherited from CXTPColorSelectorCtrlThemeVisualStudio2015
CXTPColorSelectorCtrlThemeVisualStudio2015 ()
Default constructor.
virtual void | RefreshMetrics (CXTPColorSelectorCtrl *pOwner)
Called by the theme manager to refresh the visual styles used by each component's theme.
virtual void | DrawColorCell (CDC *pDC, CXTPColorSelectorCtrl *pOwner, CXTPColorSelectorCtrl::COLOR_CELL *pColorCell, BOOL bHighlight, BOOL bPressed)
This member function is called to draw the cell specified by 'pColorCell'.
- Public Member Functions inherited from CXTPColorSelectorCtrlThemeOffice2013
CXTPColorSelectorCtrlThemeOffice2013 ()
Default constructor.
virtual void | DrawBorder (CDC *pDC, CRect rcItem, CRect rcBorder, COLORREF crBorder)
This member function is called to draw the cell specified by 'pColorCell'.
virtual void | DrawColor (CDC *pDC, CXTPColorSelectorCtrl *pOwner, CXTPColorSelectorCtrl::COLOR_CELL *pColorCell, CRect rcItem, BOOL bChecked, BOOL bHighlight, BOOL bPressed)
Called to draw a color cell for the color selector control.
virtual void | DrawColorSelector (CDC *pDC, CXTPColorSelectorCtrl *pOwner)
This member function is called to draw the color selector.
virtual CSize | CalcSize (CXTPColorSelectorCtrl *pOwner)
Called to determine the size of the color selector window.
virtual BOOL | CreateAutoButton (CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked)
Called to add the 'Automatic Color' button to the color selector control.
virtual BOOL | CreateExtendedButtons (CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked)
Called to add default color buttons to the color selector control.
virtual BOOL | CreateThemeButtons (CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked)
Called to add theme and standard buttons to the color selector control.
virtual BOOL | CreateRecentColorButtons (CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked)
Called to add recent colors to the color selector control.
virtual BOOL | CreateMoreButton (CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked)
Called to add a 'More Colors' button to the color selector control.
- Public Member Functions inherited from CXTPColorSelectorCtrlTheme
CXTPColorSelectorCtrlTheme ()
Constructs a CXTPColorSelectorCtrlTheme object.
virtual void | FillBackground (CDC *pDC, CXTPColorSelectorCtrl *pOwner, const CRect &rect)
Call this member function to draw the background of the ColorSelector control.
virtual BOOL | CreateColorButtons (CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked)
Called to determine if theme or default color buttons should be added.
virtual CSize | GetButtonSize () const
Call to retrieve the size of a single color button.
- Public Member Functions inherited from CXTPControlTheme
CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme | GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlTheme
static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPColorSelectorCtrlTheme
int | m_nAutoButton
Height of the Automatic/More Colors buttons.
int | m_nCaption
Height of a caption that is displayed in the control.
int | m_nMargin
Size for default margin spacing.
CRect | m_rcThemeText
Size and location of the 'Theme Colors' caption area text.
CRect | m_rcRecentText
Size and location of the 'Recent Colors' caption area text.
CRect | m_rcStandardText
Size and location of the 'Standard Colors' caption area text.
CSize | m_sizeButton
cx and cy size for a color picker button.
BOOL | m_bThinBorder
TRUE to use thin borders.
COLORREF | m_crBorder
An RGB value representing the border color.
COLORREF | m_crBorderHilight
An RGB value for border highlight color.
COLORREF | m_crBorderPressed
An RGB value for border pressed color.
COLORREF | m_crBack
An RGB value for background color.
COLORREF | m_crBackPressed
An RGB value for pressed background color.
COLORREF | m_crBackHilight
An RGB value for background highlight color.
COLORREF | m_crBackChecked
An RGB value for checked background color.
COLORREF | m_crText
An RGB value for text color.
COLORREF | m_crTextPressed
An RGB value for text pressed color.
COLORREF | m_crPopupBorder
An RGB value for the pop-up border.
- Protected Attributes inherited from CXTPColorSelectorCtrlThemeOffice2013
COLORREF | m_crTitleText
An RGB value representing the title text color.
COLORREF | m_crTitleBack
An RGB value representing the title background color.
COLORREF | m_crBorderInside
An RGB value representing the inside border highlight color.
- Protected Attributes inherited from CXTPControlTheme
XTPControlTheme | m_nTheme
Currently selected theme style index.

Detailed Description

CXTPColorSelectorCtrlThemeNativeWindows11 is derived from CXTPColorSelectorCtrlThemeVisualStudio2015 to handle theme specific visualizations for the CXTPColorSelectorCtrl class.

The documentation for this class was generated from the following file:
  • XTPColorSelectorCtrl.h


Toolkit Pro: CXTPColorSelectorCtrlThemeOffice2003 Class Reference

Public Member Functions | List of all members
CXTPColorSelectorCtrlThemeOffice2003 Class Reference

CXTPColorSelectorCtrlThemeOffice2003 is derived from CXTPColorSelectorCtrlThemeOfficeXP to handle theme specific visualizations for the CXTPColorSelectorCtrl class. More...

Inheritance diagram for CXTPColorSelectorCtrlThemeOffice2003:
[legend]

Public Member Functions

CXTPColorSelectorCtrlThemeOffice2003 ()
Constructs a CXTPColorSelectorCtrlThemeOffice2003 object.
virtual void | RefreshMetrics (CXTPColorSelectorCtrl *pOwner)
This member function is called by the theme manager to refresh the visual styles used by each component's theme.
- Public Member Functions inherited from CXTPColorSelectorCtrlThemeOfficeXP
CXTPColorSelectorCtrlThemeOfficeXP ()
Constructs a CXTPColorSelectorCtrlThemeOfficeXP object.
- Public Member Functions inherited from CXTPColorSelectorCtrlTheme
CXTPColorSelectorCtrlTheme ()
Constructs a CXTPColorSelectorCtrlTheme object.
virtual void | FillBackground (CDC *pDC, CXTPColorSelectorCtrl *pOwner, const CRect &rect)
Call this member function to draw the background of the ColorSelector control.
virtual void | DrawColorCell (CDC *pDC, CXTPColorSelectorCtrl *pOwner, CXTPColorSelectorCtrl::COLOR_CELL *pColorCell, BOOL bHighlight, BOOL bPressed)
This member function is called to draw the cell specified by 'pColorCell'.
virtual void | DrawColorSelector (CDC *pDC, CXTPColorSelectorCtrl *pOwner)
This member function is called to draw the color selector.
virtual CSize | CalcSize (CXTPColorSelectorCtrl *pOwner)
Called to determine the size of the color selector window.
virtual BOOL | CreateAutoButton (CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked)
Called to add the 'Automatic Color' button to the color selector control.
virtual BOOL | CreateExtendedButtons (CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked)
Called to add default color buttons to the color selector control.
virtual BOOL | CreateThemeButtons (CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked)
Called to add theme and standard buttons to the color selector control.
virtual BOOL | CreateColorButtons (CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked)
Called to determine if theme or default color buttons should be added.
virtual BOOL | CreateRecentColorButtons (CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked)
Called to add recent colors to the color selector control.
virtual BOOL | CreateMoreButton (CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked)
Called to add a 'More Colors' button to the color selector control.
virtual CSize | GetButtonSize () const
Call to retrieve the size of a single color button.
- Public Member Functions inherited from CXTPControlTheme
CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme | GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlTheme
static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPColorSelectorCtrlTheme
int | m_nAutoButton
Height of the Automatic/More Colors buttons.
int | m_nCaption
Height of a caption that is displayed in the control.
int | m_nMargin
Size for default margin spacing.
CRect | m_rcThemeText
Size and location of the 'Theme Colors' caption area text.
CRect | m_rcRecentText
Size and location of the 'Recent Colors' caption area text.
CRect | m_rcStandardText
Size and location of the 'Standard Colors' caption area text.
CSize | m_sizeButton
cx and cy size for a color picker button.
BOOL | m_bThinBorder
TRUE to use thin borders.
COLORREF | m_crBorder
An RGB value representing the border color.
COLORREF | m_crBorderHilight
An RGB value for border highlight color.
COLORREF | m_crBorderPressed
An RGB value for border pressed color.
COLORREF | m_crBack
An RGB value for background color.
COLORREF | m_crBackPressed
An RGB value for pressed background color.
COLORREF | m_crBackHilight
An RGB value for background highlight color.
COLORREF | m_crBackChecked
An RGB value for checked background color.
COLORREF | m_crText
An RGB value for text color.
COLORREF | m_crTextPressed
An RGB value for text pressed color.
COLORREF | m_crPopupBorder
An RGB value for the pop-up border.
- Protected Attributes inherited from CXTPControlTheme
XTPControlTheme | m_nTheme
Currently selected theme style index.

Detailed Description

CXTPColorSelectorCtrlThemeOffice2003 is derived from CXTPColorSelectorCtrlThemeOfficeXP to handle theme specific visualizations for the CXTPColorSelectorCtrl class.

Member Function Documentation

◆ RefreshMetrics()

virtual void RefreshMetrics ( CXTPColorSelectorCtrl * pOwner )
virtual

This member function is called by the theme manager to refresh the visual styles used by each component's theme.

Parameters
pOwner A pointer to the parent CXTPColorSelectorCtrl object.

Reimplemented from CXTPColorSelectorCtrlThemeOfficeXP.

The documentation for this class was generated from the following file:
  • XTPColorSelectorCtrl.h


Toolkit Pro: CXTPColorSelectorCtrlThemeOffice2013 Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPColorSelectorCtrlThemeOffice2013 Class Reference

CXTPColorSelectorCtrlThemeOffice2013 is derived from CXTPColorSelectorCtrlTheme to handle theme specific visualizations for the CXTPColorSelectorCtrl class. More...

Inheritance diagram for CXTPColorSelectorCtrlThemeOffice2013:
[legend]

Public Member Functions

CXTPColorSelectorCtrlThemeOffice2013 ()
Default constructor.
virtual void | RefreshMetrics (CXTPColorSelectorCtrl *pOwner)
This member function is called by the theme manager to refresh the visual styles used by each component's theme.
virtual void | DrawBorder (CDC *pDC, CRect rcItem, CRect rcBorder, COLORREF crBorder)
This member function is called to draw the cell specified by 'pColorCell'.
virtual void | DrawColor (CDC *pDC, CXTPColorSelectorCtrl *pOwner, CXTPColorSelectorCtrl::COLOR_CELL *pColorCell, CRect rcItem, BOOL bChecked, BOOL bHighlight, BOOL bPressed)
Called to draw a color cell for the color selector control.
virtual void | DrawColorCell (CDC *pDC, CXTPColorSelectorCtrl *pOwner, CXTPColorSelectorCtrl::COLOR_CELL *pColorCell, BOOL bHighlight, BOOL bPressed)
This member function is called to draw the cell specified by 'pColorCell'.
virtual void | DrawColorSelector (CDC *pDC, CXTPColorSelectorCtrl *pOwner)
This member function is called to draw the color selector.
virtual CSize | CalcSize (CXTPColorSelectorCtrl *pOwner)
Called to determine the size of the color selector window.
virtual BOOL | CreateAutoButton (CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked)
Called to add the 'Automatic Color' button to the color selector control.
virtual BOOL | CreateExtendedButtons (CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked)
Called to add default color buttons to the color selector control.
virtual BOOL | CreateThemeButtons (CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked)
Called to add theme and standard buttons to the color selector control.
virtual BOOL | CreateRecentColorButtons (CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked)
Called to add recent colors to the color selector control.
virtual BOOL | CreateMoreButton (CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked)
Called to add a 'More Colors' button to the color selector control.
- Public Member Functions inherited from CXTPColorSelectorCtrlTheme
CXTPColorSelectorCtrlTheme ()
Constructs a CXTPColorSelectorCtrlTheme object.
virtual void | FillBackground (CDC *pDC, CXTPColorSelectorCtrl *pOwner, const CRect &rect)
Call this member function to draw the background of the ColorSelector control.
virtual BOOL | CreateColorButtons (CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked)
Called to determine if theme or default color buttons should be added.
virtual CSize | GetButtonSize () const
Call to retrieve the size of a single color button.
- Public Member Functions inherited from CXTPControlTheme
CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme | GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Attributes

COLORREF | m_crTitleText
An RGB value representing the title text color.
COLORREF | m_crTitleBack
An RGB value representing the title background color.
COLORREF | m_crBorderInside
An RGB value representing the inside border highlight color.
- Protected Attributes inherited from CXTPControlTheme
XTPControlTheme | m_nTheme
Currently selected theme style index.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlTheme
static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPColorSelectorCtrlTheme
int | m_nAutoButton
Height of the Automatic/More Colors buttons.
int | m_nCaption
Height of a caption that is displayed in the control.
int | m_nMargin
Size for default margin spacing.
CRect | m_rcThemeText
Size and location of the 'Theme Colors' caption area text.
CRect | m_rcRecentText
Size and location of the 'Recent Colors' caption area text.
CRect | m_rcStandardText
Size and location of the 'Standard Colors' caption area text.
CSize | m_sizeButton
cx and cy size for a color picker button.
BOOL | m_bThinBorder
TRUE to use thin borders.
COLORREF | m_crBorder
An RGB value representing the border color.
COLORREF | m_crBorderHilight
An RGB value for border highlight color.
COLORREF | m_crBorderPressed
An RGB value for border pressed color.
COLORREF | m_crBack
An RGB value for background color.
COLORREF | m_crBackPressed
An RGB value for pressed background color.
COLORREF | m_crBackHilight
An RGB value for background highlight color.
COLORREF | m_crBackChecked
An RGB value for checked background color.
COLORREF | m_crText
An RGB value for text color.
COLORREF | m_crTextPressed
An RGB value for text pressed color.
COLORREF | m_crPopupBorder
An RGB value for the pop-up border.

Detailed Description

CXTPColorSelectorCtrlThemeOffice2013 is derived from CXTPColorSelectorCtrlTheme to handle theme specific visualizations for the CXTPColorSelectorCtrl class.

Member Function Documentation

◆ CalcSize()

virtual CSize CalcSize ( CXTPColorSelectorCtrl * pOwner )
virtual

Called to determine the size of the color selector window.

Parameters
pOwner A pointer to the parent CXTPColorSelectorCtrl object.
Returns
A CSize object containing the width and height for the control.

Reimplemented from CXTPColorSelectorCtrlTheme.

◆ CreateAutoButton()

virtual BOOL CreateAutoButton | ( | CXTPColorSelectorCtrl * | pOwner,
 |  | int & | nIndex,
 |  | const int | x,
 |  | int & | y,
 |  | const int | cx,
 |  | bool & | bChecked )
 virtual

Called to add the 'Automatic Color' button to the color selector control.

Parameters
pOwner | A pointer to the parent CXTPColorSelectorCtrl object.
nIndex | Reference to an integer representing the next available index in the color cell array.
x | Specifies starting coordinates for the left edge.
y | Specifies starting coordinates for the top edge.
cx | Specifies the width of the client area.
bChecked | TRUE when a color button has been checked.
Returns
TRUE if the 'Automatic Color' button was successfully created, otherwise FALSE.

Reimplemented from CXTPColorSelectorCtrlTheme.

◆ CreateExtendedButtons()

virtual BOOL CreateExtendedButtons | ( | CXTPColorSelectorCtrl * | pOwner,
 |  | int & | nIndex,
 |  | const int | x,
 |  | int & | y,
 |  | const int | cx,
 |  | bool & | bChecked )
 virtual

Called to add default color buttons to the color selector control.

Parameters
pOwner | A pointer to the parent CXTPColorSelectorCtrl object.
nIndex | Reference to an integer representing the next available index in the color cell array.
x | Specifies starting coordinates for the left edge.
y | Specifies starting coordinates for the top edge.
cx | Specifies the width of the client area.
bChecked | TRUE when a color button has been checked.
Returns
TRUE if successful, otherwise FALSE.

Reimplemented from CXTPColorSelectorCtrlTheme.

◆ CreateMoreButton()

virtual BOOL CreateMoreButton | ( | CXTPColorSelectorCtrl * | pOwner,
 |  | int & | nIndex,
 |  | const int | x,
 |  | int & | y,
 |  | const int | cx,
 |  | bool & | bChecked )
 virtual

Called to add a 'More Colors' button to the color selector control.

Parameters
pOwner | A pointer to the parent CXTPColorSelectorCtrl object.
nIndex | Reference to an integer representing the next available index in the color cell array.
x | Specifies starting coordinates for the left edge.
y | Specifies starting coordinates for the top edge.
cx | Specifies the width of the client area.
bChecked | TRUE when a color button has been checked.
Returns
TRUE if successful, otherwise FALSE.

Reimplemented from CXTPColorSelectorCtrlTheme.

◆ CreateRecentColorButtons()

virtual BOOL CreateRecentColorButtons | ( | CXTPColorSelectorCtrl * | pOwner,
 |  | int & | nIndex,
 |  | const int | x,
 |  | int & | y,
 |  | const int | cx,
 |  | bool & | bChecked )
 virtual

Called to add recent colors to the color selector control.

Parameters
pOwner | A pointer to the parent CXTPColorSelectorCtrl object.
nIndex | Reference to an integer representing the next available index in the color cell array.
x | Specifies starting coordinates for the left edge.
y | Specifies starting coordinates for the top edge.
cx | Specifies the width of the client area.
bChecked | TRUE when a color button has been checked.
Returns
TRUE if successful, otherwise FALSE.

Reimplemented from CXTPColorSelectorCtrlTheme.

◆ CreateThemeButtons()

virtual BOOL CreateThemeButtons | ( | CXTPColorSelectorCtrl * | pOwner,
 |  | int & | nIndex,
 |  | const int | x,
 |  | int & | y,
 |  | const int | cx,
 |  | bool & | bChecked )
 virtual

Called to add theme and standard buttons to the color selector control.

Parameters
pOwner | A pointer to the parent CXTPColorSelectorCtrl object.
nIndex | Reference to an integer representing the next available index in the color cell array.
x | Specifies starting coordinates for the left edge.
y | Specifies starting coordinates for the top edge.
cx | Specifies the width of the client area.
bChecked | TRUE when a color button has been checked.
Returns
TRUE if successful, otherwise FALSE.

Reimplemented from CXTPColorSelectorCtrlTheme.

◆ DrawBorder()

virtual void DrawBorder | ( | CDC * | pDC,
 |  | CRect | rcItem,
 |  | CRect | rcBorder,
 |  | COLORREF | crBorder )
 virtual

This member function is called to draw the cell specified by 'pColorCell'.

Parameters
pDC | A CDC pointer that represents the current device context.
rcItem | Specifies the size of the border to draw.
rcBorder | Specifies left, top, right and bottom borders. 1 = draw border, 0 = do not draw border.
crBorder | An RGB value specifying the border color to draw.

◆ DrawColor()

virtual void DrawColor | ( | CDC * | pDC,
 |  | CXTPColorSelectorCtrl * | pOwner,
 |  | CXTPColorSelectorCtrl::COLOR_CELL * | pColorCell,
 |  | CRect | rcItem,
 |  | BOOL | bChecked,
 |  | BOOL | bHighlight,
 |  | BOOL | bPressed )
 virtual

Called to draw a color cell for the color selector control.

Parameters
pDC | A CDC pointer that represents the current device context.
pOwner | A pointer to the parent CXTPColorSelectorCtrl object.
pColorCell | A COLOR_CELL object.
rcItem | Size and location of the color cell to draw.
bHighlight | TRUE if the color should be drawn highlighted.
bChecked | TRUE if the color should be drawn checked.
bPressed | TRUE if the color should be drawn pressed.

◆ DrawColorCell()

virtual void DrawColorCell | ( | CDC * | pDC,
 |  | CXTPColorSelectorCtrl * | pOwner,
 |  | CXTPColorSelectorCtrl::COLOR_CELL * | pColorCell,
 |  | BOOL | bHighlight,
 |  | BOOL | bPressed )
 virtual

This member function is called to draw the cell specified by 'pColorCell'.

Parameters
pDC | A CDC pointer that represents the current device context.
pOwner | A pointer to the parent CXTPColorSelectorCtrl object.
pColorCell | A COLOR_CELL object.
bHighlight | TRUE if the mouse is over the cell.
bPressed | TRUE if the cell is pressed.

Reimplemented from CXTPColorSelectorCtrlTheme.

Reimplemented in CXTPColorSelectorCtrlThemeVisualStudio2015.

◆ DrawColorSelector()

virtual void DrawColorSelector | ( | CDC * | pDC,
 |  | CXTPColorSelectorCtrl * | pOwner )
 virtual

This member function is called to draw the color selector.

Parameters
pDC | A CDC pointer that represents the current device context.
pOwner | A pointer to the parent CXTPColorSelectorCtrl object.

Reimplemented from CXTPColorSelectorCtrlTheme.

◆ RefreshMetrics()

virtual void RefreshMetrics ( CXTPColorSelectorCtrl * pOwner )
virtual

This member function is called by the theme manager to refresh the visual styles used by each component's theme.

Parameters
pOwner A pointer to the parent CXTPColorSelectorCtrl object.

Reimplemented from CXTPColorSelectorCtrlTheme.

Reimplemented in CXTPColorSelectorCtrlThemeVisualStudio2015.

The documentation for this class was generated from the following file:
  • XTPColorSelectorCtrl.h


Toolkit Pro: CXTPColorSelectorCtrlThemeOfficeXP Class Reference

Public Member Functions | List of all members
CXTPColorSelectorCtrlThemeOfficeXP Class Reference

CXTPColorSelectorCtrlThemeOfficeXP is derived from CXTPColorSelectorCtrlTheme to handle theme specific visualizations for the CXTPColorSelectorCtrl class. More...

Inheritance diagram for CXTPColorSelectorCtrlThemeOfficeXP:
[legend]

Public Member Functions

CXTPColorSelectorCtrlThemeOfficeXP ()
Constructs a CXTPColorSelectorCtrlThemeOfficeXP object.
virtual void | RefreshMetrics (CXTPColorSelectorCtrl *pOwner)
This member function is called by the theme manager to refresh the visual styles used by each component's theme.
- Public Member Functions inherited from CXTPColorSelectorCtrlTheme
CXTPColorSelectorCtrlTheme ()
Constructs a CXTPColorSelectorCtrlTheme object.
virtual void | FillBackground (CDC *pDC, CXTPColorSelectorCtrl *pOwner, const CRect &rect)
Call this member function to draw the background of the ColorSelector control.
virtual void | DrawColorCell (CDC *pDC, CXTPColorSelectorCtrl *pOwner, CXTPColorSelectorCtrl::COLOR_CELL *pColorCell, BOOL bHighlight, BOOL bPressed)
This member function is called to draw the cell specified by 'pColorCell'.
virtual void | DrawColorSelector (CDC *pDC, CXTPColorSelectorCtrl *pOwner)
This member function is called to draw the color selector.
virtual CSize | CalcSize (CXTPColorSelectorCtrl *pOwner)
Called to determine the size of the color selector window.
virtual BOOL | CreateAutoButton (CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked)
Called to add the 'Automatic Color' button to the color selector control.
virtual BOOL | CreateExtendedButtons (CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked)
Called to add default color buttons to the color selector control.
virtual BOOL | CreateThemeButtons (CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked)
Called to add theme and standard buttons to the color selector control.
virtual BOOL | CreateColorButtons (CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked)
Called to determine if theme or default color buttons should be added.
virtual BOOL | CreateRecentColorButtons (CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked)
Called to add recent colors to the color selector control.
virtual BOOL | CreateMoreButton (CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked)
Called to add a 'More Colors' button to the color selector control.
virtual CSize | GetButtonSize () const
Call to retrieve the size of a single color button.
- Public Member Functions inherited from CXTPControlTheme
CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme | GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlTheme
static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPColorSelectorCtrlTheme
int | m_nAutoButton
Height of the Automatic/More Colors buttons.
int | m_nCaption
Height of a caption that is displayed in the control.
int | m_nMargin
Size for default margin spacing.
CRect | m_rcThemeText
Size and location of the 'Theme Colors' caption area text.
CRect | m_rcRecentText
Size and location of the 'Recent Colors' caption area text.
CRect | m_rcStandardText
Size and location of the 'Standard Colors' caption area text.
CSize | m_sizeButton
cx and cy size for a color picker button.
BOOL | m_bThinBorder
TRUE to use thin borders.
COLORREF | m_crBorder
An RGB value representing the border color.
COLORREF | m_crBorderHilight
An RGB value for border highlight color.
COLORREF | m_crBorderPressed
An RGB value for border pressed color.
COLORREF | m_crBack
An RGB value for background color.
COLORREF | m_crBackPressed
An RGB value for pressed background color.
COLORREF | m_crBackHilight
An RGB value for background highlight color.
COLORREF | m_crBackChecked
An RGB value for checked background color.
COLORREF | m_crText
An RGB value for text color.
COLORREF | m_crTextPressed
An RGB value for text pressed color.
COLORREF | m_crPopupBorder
An RGB value for the pop-up border.
- Protected Attributes inherited from CXTPControlTheme
XTPControlTheme | m_nTheme
Currently selected theme style index.

Detailed Description

CXTPColorSelectorCtrlThemeOfficeXP is derived from CXTPColorSelectorCtrlTheme to handle theme specific visualizations for the CXTPColorSelectorCtrl class.

Member Function Documentation

◆ RefreshMetrics()

virtual void RefreshMetrics ( CXTPColorSelectorCtrl * pOwner )
virtual

This member function is called by the theme manager to refresh the visual styles used by each component's theme.

Parameters
pOwner A pointer to the parent CXTPColorSelectorCtrl object.

Reimplemented from CXTPColorSelectorCtrlTheme.

Reimplemented in CXTPColorSelectorCtrlThemeOffice2003, and CXTPColorSelectorCtrlThemeResource.

The documentation for this class was generated from the following file:
  • XTPColorSelectorCtrl.h


Toolkit Pro: CXTPColorSelectorCtrlThemeResource Class Reference

Public Member Functions | List of all members
CXTPColorSelectorCtrlThemeResource Class Reference

CXTPColorSelectorCtrlThemeResource is derived from CXTPColorSelectorCtrlThemeOfficeXP to handle theme specific visualizations for the CXTPColorSelectorCtrl class. More...

Inheritance diagram for CXTPColorSelectorCtrlThemeResource:
[legend]

Public Member Functions

CXTPColorSelectorCtrlThemeResource ()
Constructs a CXTPColorSelectorCtrlThemeResource object.
virtual void | RefreshMetrics (CXTPColorSelectorCtrl *pOwner)
This member function is called by the theme manager to refresh the visual styles used by each component's theme.
- Public Member Functions inherited from CXTPColorSelectorCtrlThemeOfficeXP
CXTPColorSelectorCtrlThemeOfficeXP ()
Constructs a CXTPColorSelectorCtrlThemeOfficeXP object.
- Public Member Functions inherited from CXTPColorSelectorCtrlTheme
CXTPColorSelectorCtrlTheme ()
Constructs a CXTPColorSelectorCtrlTheme object.
virtual void | FillBackground (CDC *pDC, CXTPColorSelectorCtrl *pOwner, const CRect &rect)
Call this member function to draw the background of the ColorSelector control.
virtual void | DrawColorCell (CDC *pDC, CXTPColorSelectorCtrl *pOwner, CXTPColorSelectorCtrl::COLOR_CELL *pColorCell, BOOL bHighlight, BOOL bPressed)
This member function is called to draw the cell specified by 'pColorCell'.
virtual void | DrawColorSelector (CDC *pDC, CXTPColorSelectorCtrl *pOwner)
This member function is called to draw the color selector.
virtual CSize | CalcSize (CXTPColorSelectorCtrl *pOwner)
Called to determine the size of the color selector window.
virtual BOOL | CreateAutoButton (CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked)
Called to add the 'Automatic Color' button to the color selector control.
virtual BOOL | CreateExtendedButtons (CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked)
Called to add default color buttons to the color selector control.
virtual BOOL | CreateThemeButtons (CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked)
Called to add theme and standard buttons to the color selector control.
virtual BOOL | CreateColorButtons (CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked)
Called to determine if theme or default color buttons should be added.
virtual BOOL | CreateRecentColorButtons (CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked)
Called to add recent colors to the color selector control.
virtual BOOL | CreateMoreButton (CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked)
Called to add a 'More Colors' button to the color selector control.
virtual CSize | GetButtonSize () const
Call to retrieve the size of a single color button.
- Public Member Functions inherited from CXTPControlTheme
CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme | GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlTheme
static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPColorSelectorCtrlTheme
int | m_nAutoButton
Height of the Automatic/More Colors buttons.
int | m_nCaption
Height of a caption that is displayed in the control.
int | m_nMargin
Size for default margin spacing.
CRect | m_rcThemeText
Size and location of the 'Theme Colors' caption area text.
CRect | m_rcRecentText
Size and location of the 'Recent Colors' caption area text.
CRect | m_rcStandardText
Size and location of the 'Standard Colors' caption area text.
CSize | m_sizeButton
cx and cy size for a color picker button.
BOOL | m_bThinBorder
TRUE to use thin borders.
COLORREF | m_crBorder
An RGB value representing the border color.
COLORREF | m_crBorderHilight
An RGB value for border highlight color.
COLORREF | m_crBorderPressed
An RGB value for border pressed color.
COLORREF | m_crBack
An RGB value for background color.
COLORREF | m_crBackPressed
An RGB value for pressed background color.
COLORREF | m_crBackHilight
An RGB value for background highlight color.
COLORREF | m_crBackChecked
An RGB value for checked background color.
COLORREF | m_crText
An RGB value for text color.
COLORREF | m_crTextPressed
An RGB value for text pressed color.
COLORREF | m_crPopupBorder
An RGB value for the pop-up border.
- Protected Attributes inherited from CXTPControlTheme
XTPControlTheme | m_nTheme
Currently selected theme style index.

Detailed Description

CXTPColorSelectorCtrlThemeResource is derived from CXTPColorSelectorCtrlThemeOfficeXP to handle theme specific visualizations for the CXTPColorSelectorCtrl class.

Member Function Documentation

◆ RefreshMetrics()

virtual void RefreshMetrics ( CXTPColorSelectorCtrl * pOwner )
virtual

This member function is called by the theme manager to refresh the visual styles used by each component's theme.

Parameters
pOwner A pointer to the parent CXTPColorSelectorCtrl object.

Reimplemented from CXTPColorSelectorCtrlThemeOfficeXP.

The documentation for this class was generated from the following file:
  • XTPColorSelectorCtrl.h


Toolkit Pro: CXTPColorSelectorCtrlThemeVisualStudio2015 Class Reference

Public Member Functions | List of all members
CXTPColorSelectorCtrlThemeVisualStudio2015 Class Reference

CXTPColorSelectorCtrlThemeVisualStudio2015 is derived from CXTPColorSelectorCtrlThemeOffice2013 to handle theme specific visualizations for the CXTPColorSelectorCtrl class. More...

Inheritance diagram for CXTPColorSelectorCtrlThemeVisualStudio2015:
[legend]

Public Member Functions

CXTPColorSelectorCtrlThemeVisualStudio2015 ()
Default constructor.
virtual void | RefreshMetrics (CXTPColorSelectorCtrl *pOwner)
Called by the theme manager to refresh the visual styles used by each component's theme.
virtual void | DrawColorCell (CDC *pDC, CXTPColorSelectorCtrl *pOwner, CXTPColorSelectorCtrl::COLOR_CELL *pColorCell, BOOL bHighlight, BOOL bPressed)
This member function is called to draw the cell specified by 'pColorCell'.
- Public Member Functions inherited from CXTPColorSelectorCtrlThemeOffice2013
CXTPColorSelectorCtrlThemeOffice2013 ()
Default constructor.
virtual void | DrawBorder (CDC *pDC, CRect rcItem, CRect rcBorder, COLORREF crBorder)
This member function is called to draw the cell specified by 'pColorCell'.
virtual void | DrawColor (CDC *pDC, CXTPColorSelectorCtrl *pOwner, CXTPColorSelectorCtrl::COLOR_CELL *pColorCell, CRect rcItem, BOOL bChecked, BOOL bHighlight, BOOL bPressed)
Called to draw a color cell for the color selector control.
virtual void | DrawColorSelector (CDC *pDC, CXTPColorSelectorCtrl *pOwner)
This member function is called to draw the color selector.
virtual CSize | CalcSize (CXTPColorSelectorCtrl *pOwner)
Called to determine the size of the color selector window.
virtual BOOL | CreateAutoButton (CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked)
Called to add the 'Automatic Color' button to the color selector control.
virtual BOOL | CreateExtendedButtons (CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked)
Called to add default color buttons to the color selector control.
virtual BOOL | CreateThemeButtons (CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked)
Called to add theme and standard buttons to the color selector control.
virtual BOOL | CreateRecentColorButtons (CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked)
Called to add recent colors to the color selector control.
virtual BOOL | CreateMoreButton (CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked)
Called to add a 'More Colors' button to the color selector control.
- Public Member Functions inherited from CXTPColorSelectorCtrlTheme
CXTPColorSelectorCtrlTheme ()
Constructs a CXTPColorSelectorCtrlTheme object.
virtual void | FillBackground (CDC *pDC, CXTPColorSelectorCtrl *pOwner, const CRect &rect)
Call this member function to draw the background of the ColorSelector control.
virtual BOOL | CreateColorButtons (CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked)
Called to determine if theme or default color buttons should be added.
virtual CSize | GetButtonSize () const
Call to retrieve the size of a single color button.
- Public Member Functions inherited from CXTPControlTheme
CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme | GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlTheme
static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPColorSelectorCtrlTheme
int | m_nAutoButton
Height of the Automatic/More Colors buttons.
int | m_nCaption
Height of a caption that is displayed in the control.
int | m_nMargin
Size for default margin spacing.
CRect | m_rcThemeText
Size and location of the 'Theme Colors' caption area text.
CRect | m_rcRecentText
Size and location of the 'Recent Colors' caption area text.
CRect | m_rcStandardText
Size and location of the 'Standard Colors' caption area text.
CSize | m_sizeButton
cx and cy size for a color picker button.
BOOL | m_bThinBorder
TRUE to use thin borders.
COLORREF | m_crBorder
An RGB value representing the border color.
COLORREF | m_crBorderHilight
An RGB value for border highlight color.
COLORREF | m_crBorderPressed
An RGB value for border pressed color.
COLORREF | m_crBack
An RGB value for background color.
COLORREF | m_crBackPressed
An RGB value for pressed background color.
COLORREF | m_crBackHilight
An RGB value for background highlight color.
COLORREF | m_crBackChecked
An RGB value for checked background color.
COLORREF | m_crText
An RGB value for text color.
COLORREF | m_crTextPressed
An RGB value for text pressed color.
COLORREF | m_crPopupBorder
An RGB value for the pop-up border.
- Protected Attributes inherited from CXTPColorSelectorCtrlThemeOffice2013
COLORREF | m_crTitleText
An RGB value representing the title text color.
COLORREF | m_crTitleBack
An RGB value representing the title background color.
COLORREF | m_crBorderInside
An RGB value representing the inside border highlight color.
- Protected Attributes inherited from CXTPControlTheme
XTPControlTheme | m_nTheme
Currently selected theme style index.

Detailed Description

CXTPColorSelectorCtrlThemeVisualStudio2015 is derived from CXTPColorSelectorCtrlThemeOffice2013 to handle theme specific visualizations for the CXTPColorSelectorCtrl class.

Member Function Documentation

◆ DrawColorCell()

virtual void DrawColorCell | ( | CDC * | pDC,
 |  | CXTPColorSelectorCtrl * | pOwner,
 |  | CXTPColorSelectorCtrl::COLOR_CELL * | pColorCell,
 |  | BOOL | bHighlight,
 |  | BOOL | bPressed )
 virtual

This member function is called to draw the cell specified by 'pColorCell'.

Parameters
pDC | A CDC pointer that represents the current device context.
pOwner | A pointer to the parent CXTPColorSelectorCtrl object.
pColorCell | A COLOR_CELL object.
bHighlight | TRUE if the mouse is over the cell.
bPressed | TRUE if the cell is pressed.

Reimplemented from CXTPColorSelectorCtrlThemeOffice2013.

◆ RefreshMetrics()

virtual void RefreshMetrics ( CXTPColorSelectorCtrl * pOwner )
virtual

Called by the theme manager to refresh the visual styles used by each component's theme.

Parameters
pOwner A pointer to the parent CXTPColorSelectorCtrl object.

Reimplemented from CXTPColorSelectorCtrlThemeOffice2013.

The documentation for this class was generated from the following file:
  • XTPColorSelectorCtrl.h


Toolkit Pro: CXTPColorSelectorCtrlThemeVisualStudio2017 Class Reference

Public Member Functions | List of all members
CXTPColorSelectorCtrlThemeVisualStudio2017 Class Reference

CXTPColorSelectorCtrlThemeVisualStudio2017 is derived from CXTPColorSelectorCtrlThemeVisualStudio2015 to handle theme specific visualizations for the CXTPColorSelectorCtrl class. More...

Inheritance diagram for CXTPColorSelectorCtrlThemeVisualStudio2017:
[legend]

Public Member Functions

CXTPColorSelectorCtrlThemeVisualStudio2017 ()
Default constructor.
- Public Member Functions inherited from CXTPColorSelectorCtrlThemeVisualStudio2015
CXTPColorSelectorCtrlThemeVisualStudio2015 ()
Default constructor.
virtual void | RefreshMetrics (CXTPColorSelectorCtrl *pOwner)
Called by the theme manager to refresh the visual styles used by each component's theme.
virtual void | DrawColorCell (CDC *pDC, CXTPColorSelectorCtrl *pOwner, CXTPColorSelectorCtrl::COLOR_CELL *pColorCell, BOOL bHighlight, BOOL bPressed)
This member function is called to draw the cell specified by 'pColorCell'.
- Public Member Functions inherited from CXTPColorSelectorCtrlThemeOffice2013
CXTPColorSelectorCtrlThemeOffice2013 ()
Default constructor.
virtual void | DrawBorder (CDC *pDC, CRect rcItem, CRect rcBorder, COLORREF crBorder)
This member function is called to draw the cell specified by 'pColorCell'.
virtual void | DrawColor (CDC *pDC, CXTPColorSelectorCtrl *pOwner, CXTPColorSelectorCtrl::COLOR_CELL *pColorCell, CRect rcItem, BOOL bChecked, BOOL bHighlight, BOOL bPressed)
Called to draw a color cell for the color selector control.
virtual void | DrawColorSelector (CDC *pDC, CXTPColorSelectorCtrl *pOwner)
This member function is called to draw the color selector.
virtual CSize | CalcSize (CXTPColorSelectorCtrl *pOwner)
Called to determine the size of the color selector window.
virtual BOOL | CreateAutoButton (CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked)
Called to add the 'Automatic Color' button to the color selector control.
virtual BOOL | CreateExtendedButtons (CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked)
Called to add default color buttons to the color selector control.
virtual BOOL | CreateThemeButtons (CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked)
Called to add theme and standard buttons to the color selector control.
virtual BOOL | CreateRecentColorButtons (CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked)
Called to add recent colors to the color selector control.
virtual BOOL | CreateMoreButton (CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked)
Called to add a 'More Colors' button to the color selector control.
- Public Member Functions inherited from CXTPColorSelectorCtrlTheme
CXTPColorSelectorCtrlTheme ()
Constructs a CXTPColorSelectorCtrlTheme object.
virtual void | FillBackground (CDC *pDC, CXTPColorSelectorCtrl *pOwner, const CRect &rect)
Call this member function to draw the background of the ColorSelector control.
virtual BOOL | CreateColorButtons (CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked)
Called to determine if theme or default color buttons should be added.
virtual CSize | GetButtonSize () const
Call to retrieve the size of a single color button.
- Public Member Functions inherited from CXTPControlTheme
CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme | GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlTheme
static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPColorSelectorCtrlTheme
int | m_nAutoButton
Height of the Automatic/More Colors buttons.
int | m_nCaption
Height of a caption that is displayed in the control.
int | m_nMargin
Size for default margin spacing.
CRect | m_rcThemeText
Size and location of the 'Theme Colors' caption area text.
CRect | m_rcRecentText
Size and location of the 'Recent Colors' caption area text.
CRect | m_rcStandardText
Size and location of the 'Standard Colors' caption area text.
CSize | m_sizeButton
cx and cy size for a color picker button.
BOOL | m_bThinBorder
TRUE to use thin borders.
COLORREF | m_crBorder
An RGB value representing the border color.
COLORREF | m_crBorderHilight
An RGB value for border highlight color.
COLORREF | m_crBorderPressed
An RGB value for border pressed color.
COLORREF | m_crBack
An RGB value for background color.
COLORREF | m_crBackPressed
An RGB value for pressed background color.
COLORREF | m_crBackHilight
An RGB value for background highlight color.
COLORREF | m_crBackChecked
An RGB value for checked background color.
COLORREF | m_crText
An RGB value for text color.
COLORREF | m_crTextPressed
An RGB value for text pressed color.
COLORREF | m_crPopupBorder
An RGB value for the pop-up border.
- Protected Attributes inherited from CXTPColorSelectorCtrlThemeOffice2013
COLORREF | m_crTitleText
An RGB value representing the title text color.
COLORREF | m_crTitleBack
An RGB value representing the title background color.
COLORREF | m_crBorderInside
An RGB value representing the inside border highlight color.
- Protected Attributes inherited from CXTPControlTheme
XTPControlTheme | m_nTheme
Currently selected theme style index.

Detailed Description

CXTPColorSelectorCtrlThemeVisualStudio2017 is derived from CXTPColorSelectorCtrlThemeVisualStudio2015 to handle theme specific visualizations for the CXTPColorSelectorCtrl class.

The documentation for this class was generated from the following file:
  • XTPColorSelectorCtrl.h


Toolkit Pro: CXTPColorSelectorCtrlThemeVisualStudio2019 Class Reference

Public Member Functions | List of all members
CXTPColorSelectorCtrlThemeVisualStudio2019 Class Reference

CXTPColorSelectorCtrlThemeVisualStudio2019 is derived from CXTPColorSelectorCtrlThemeVisualStudio2015 to handle theme specific visualizations for the CXTPColorSelectorCtrl class. More...

Inheritance diagram for CXTPColorSelectorCtrlThemeVisualStudio2019:
[legend]

Public Member Functions

CXTPColorSelectorCtrlThemeVisualStudio2019 ()
Default constructor.
- Public Member Functions inherited from CXTPColorSelectorCtrlThemeVisualStudio2015
CXTPColorSelectorCtrlThemeVisualStudio2015 ()
Default constructor.
virtual void | RefreshMetrics (CXTPColorSelectorCtrl *pOwner)
Called by the theme manager to refresh the visual styles used by each component's theme.
virtual void | DrawColorCell (CDC *pDC, CXTPColorSelectorCtrl *pOwner, CXTPColorSelectorCtrl::COLOR_CELL *pColorCell, BOOL bHighlight, BOOL bPressed)
This member function is called to draw the cell specified by 'pColorCell'.
- Public Member Functions inherited from CXTPColorSelectorCtrlThemeOffice2013
CXTPColorSelectorCtrlThemeOffice2013 ()
Default constructor.
virtual void | DrawBorder (CDC *pDC, CRect rcItem, CRect rcBorder, COLORREF crBorder)
This member function is called to draw the cell specified by 'pColorCell'.
virtual void | DrawColor (CDC *pDC, CXTPColorSelectorCtrl *pOwner, CXTPColorSelectorCtrl::COLOR_CELL *pColorCell, CRect rcItem, BOOL bChecked, BOOL bHighlight, BOOL bPressed)
Called to draw a color cell for the color selector control.
virtual void | DrawColorSelector (CDC *pDC, CXTPColorSelectorCtrl *pOwner)
This member function is called to draw the color selector.
virtual CSize | CalcSize (CXTPColorSelectorCtrl *pOwner)
Called to determine the size of the color selector window.
virtual BOOL | CreateAutoButton (CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked)
Called to add the 'Automatic Color' button to the color selector control.
virtual BOOL | CreateExtendedButtons (CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked)
Called to add default color buttons to the color selector control.
virtual BOOL | CreateThemeButtons (CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked)
Called to add theme and standard buttons to the color selector control.
virtual BOOL | CreateRecentColorButtons (CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked)
Called to add recent colors to the color selector control.
virtual BOOL | CreateMoreButton (CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked)
Called to add a 'More Colors' button to the color selector control.
- Public Member Functions inherited from CXTPColorSelectorCtrlTheme
CXTPColorSelectorCtrlTheme ()
Constructs a CXTPColorSelectorCtrlTheme object.
virtual void | FillBackground (CDC *pDC, CXTPColorSelectorCtrl *pOwner, const CRect &rect)
Call this member function to draw the background of the ColorSelector control.
virtual BOOL | CreateColorButtons (CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked)
Called to determine if theme or default color buttons should be added.
virtual CSize | GetButtonSize () const
Call to retrieve the size of a single color button.
- Public Member Functions inherited from CXTPControlTheme
CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme | GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlTheme
static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPColorSelectorCtrlTheme
int | m_nAutoButton
Height of the Automatic/More Colors buttons.
int | m_nCaption
Height of a caption that is displayed in the control.
int | m_nMargin
Size for default margin spacing.
CRect | m_rcThemeText
Size and location of the 'Theme Colors' caption area text.
CRect | m_rcRecentText
Size and location of the 'Recent Colors' caption area text.
CRect | m_rcStandardText
Size and location of the 'Standard Colors' caption area text.
CSize | m_sizeButton
cx and cy size for a color picker button.
BOOL | m_bThinBorder
TRUE to use thin borders.
COLORREF | m_crBorder
An RGB value representing the border color.
COLORREF | m_crBorderHilight
An RGB value for border highlight color.
COLORREF | m_crBorderPressed
An RGB value for border pressed color.
COLORREF | m_crBack
An RGB value for background color.
COLORREF | m_crBackPressed
An RGB value for pressed background color.
COLORREF | m_crBackHilight
An RGB value for background highlight color.
COLORREF | m_crBackChecked
An RGB value for checked background color.
COLORREF | m_crText
An RGB value for text color.
COLORREF | m_crTextPressed
An RGB value for text pressed color.
COLORREF | m_crPopupBorder
An RGB value for the pop-up border.
- Protected Attributes inherited from CXTPColorSelectorCtrlThemeOffice2013
COLORREF | m_crTitleText
An RGB value representing the title text color.
COLORREF | m_crTitleBack
An RGB value representing the title background color.
COLORREF | m_crBorderInside
An RGB value representing the inside border highlight color.
- Protected Attributes inherited from CXTPControlTheme
XTPControlTheme | m_nTheme
Currently selected theme style index.

Detailed Description

CXTPColorSelectorCtrlThemeVisualStudio2019 is derived from CXTPColorSelectorCtrlThemeVisualStudio2015 to handle theme specific visualizations for the CXTPColorSelectorCtrl class.

The documentation for this class was generated from the following file:
  • XTPColorSelectorCtrl.h


Toolkit Pro: CXTPColorSelectorCtrlThemeVisualStudio2022 Class Reference

Public Member Functions | List of all members
CXTPColorSelectorCtrlThemeVisualStudio2022 Class Reference

CXTPColorSelectorCtrlThemeVisualStudio2022 is derived from CXTPColorSelectorCtrlThemeVisualStudio2015 to handle theme specific visualizations for the CXTPColorSelectorCtrl class. More...

Inheritance diagram for CXTPColorSelectorCtrlThemeVisualStudio2022:
[legend]

Public Member Functions

CXTPColorSelectorCtrlThemeVisualStudio2022 ()
Default constructor.
- Public Member Functions inherited from CXTPColorSelectorCtrlThemeVisualStudio2015
CXTPColorSelectorCtrlThemeVisualStudio2015 ()
Default constructor.
virtual void | RefreshMetrics (CXTPColorSelectorCtrl *pOwner)
Called by the theme manager to refresh the visual styles used by each component's theme.
virtual void | DrawColorCell (CDC *pDC, CXTPColorSelectorCtrl *pOwner, CXTPColorSelectorCtrl::COLOR_CELL *pColorCell, BOOL bHighlight, BOOL bPressed)
This member function is called to draw the cell specified by 'pColorCell'.
- Public Member Functions inherited from CXTPColorSelectorCtrlThemeOffice2013
CXTPColorSelectorCtrlThemeOffice2013 ()
Default constructor.
virtual void | DrawBorder (CDC *pDC, CRect rcItem, CRect rcBorder, COLORREF crBorder)
This member function is called to draw the cell specified by 'pColorCell'.
virtual void | DrawColor (CDC *pDC, CXTPColorSelectorCtrl *pOwner, CXTPColorSelectorCtrl::COLOR_CELL *pColorCell, CRect rcItem, BOOL bChecked, BOOL bHighlight, BOOL bPressed)
Called to draw a color cell for the color selector control.
virtual void | DrawColorSelector (CDC *pDC, CXTPColorSelectorCtrl *pOwner)
This member function is called to draw the color selector.
virtual CSize | CalcSize (CXTPColorSelectorCtrl *pOwner)
Called to determine the size of the color selector window.
virtual BOOL | CreateAutoButton (CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked)
Called to add the 'Automatic Color' button to the color selector control.
virtual BOOL | CreateExtendedButtons (CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked)
Called to add default color buttons to the color selector control.
virtual BOOL | CreateThemeButtons (CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked)
Called to add theme and standard buttons to the color selector control.
virtual BOOL | CreateRecentColorButtons (CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked)
Called to add recent colors to the color selector control.
virtual BOOL | CreateMoreButton (CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked)
Called to add a 'More Colors' button to the color selector control.
- Public Member Functions inherited from CXTPColorSelectorCtrlTheme
CXTPColorSelectorCtrlTheme ()
Constructs a CXTPColorSelectorCtrlTheme object.
virtual void | FillBackground (CDC *pDC, CXTPColorSelectorCtrl *pOwner, const CRect &rect)
Call this member function to draw the background of the ColorSelector control.
virtual BOOL | CreateColorButtons (CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked)
Called to determine if theme or default color buttons should be added.
virtual CSize | GetButtonSize () const
Call to retrieve the size of a single color button.
- Public Member Functions inherited from CXTPControlTheme
CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme | GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlTheme
static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPColorSelectorCtrlTheme
int | m_nAutoButton
Height of the Automatic/More Colors buttons.
int | m_nCaption
Height of a caption that is displayed in the control.
int | m_nMargin
Size for default margin spacing.
CRect | m_rcThemeText
Size and location of the 'Theme Colors' caption area text.
CRect | m_rcRecentText
Size and location of the 'Recent Colors' caption area text.
CRect | m_rcStandardText
Size and location of the 'Standard Colors' caption area text.
CSize | m_sizeButton
cx and cy size for a color picker button.
BOOL | m_bThinBorder
TRUE to use thin borders.
COLORREF | m_crBorder
An RGB value representing the border color.
COLORREF | m_crBorderHilight
An RGB value for border highlight color.
COLORREF | m_crBorderPressed
An RGB value for border pressed color.
COLORREF | m_crBack
An RGB value for background color.
COLORREF | m_crBackPressed
An RGB value for pressed background color.
COLORREF | m_crBackHilight
An RGB value for background highlight color.
COLORREF | m_crBackChecked
An RGB value for checked background color.
COLORREF | m_crText
An RGB value for text color.
COLORREF | m_crTextPressed
An RGB value for text pressed color.
COLORREF | m_crPopupBorder
An RGB value for the pop-up border.
- Protected Attributes inherited from CXTPColorSelectorCtrlThemeOffice2013
COLORREF | m_crTitleText
An RGB value representing the title text color.
COLORREF | m_crTitleBack
An RGB value representing the title background color.
COLORREF | m_crBorderInside
An RGB value representing the inside border highlight color.
- Protected Attributes inherited from CXTPControlTheme
XTPControlTheme | m_nTheme
Currently selected theme style index.

Detailed Description

CXTPColorSelectorCtrlThemeVisualStudio2022 is derived from CXTPColorSelectorCtrlThemeVisualStudio2015 to handle theme specific visualizations for the CXTPColorSelectorCtrl class.

The documentation for this class was generated from the following file:
  • XTPColorSelectorCtrl.h


Toolkit Pro: CXTPColorSetCaptionButton Class Reference

Public Member Functions | Public Attributes | List of all members
CXTPColorSetCaptionButton Class Reference

Default theme caption button color set. More...

Public Member Functions

virtual | ~CXTPColorSetCaptionButton ()
Handles object destruction.
virtual void | RefreshMetrics (CString strSectionName)
Called to update caption button theme colors.

Public Attributes

CXTPPaintManagerColor | m_clrBackground
Background color.
CXTPPaintManagerColor | m_clrOutline
Outline color.
CXTPPaintManagerColor | m_clrFill
Fill color.

Detailed Description

Default theme caption button color set.

Member Function Documentation

◆ RefreshMetrics()

virtual void RefreshMetrics ( CString strSectionName )
virtual

Called to update caption button theme colors.

Parameters
strSectionName Name of the INI section that contains caption button color definitions.
The documentation for this class was generated from the following file:
  • XTPTheme.h


Toolkit Pro: CXTPColorSetStateButton Class Reference

Public Member Functions | Public Attributes | List of all members
CXTPColorSetStateButton Class Referenceabstract

Base class used to define various state colors used by command bar buttons text, background and border. More...

Inheritance diagram for CXTPColorSetStateButton:
[legend]

Public Member Functions

virtual void RefreshColors ()=0
Call this member function to refresh the colors from predefined Section and Key values located in the theme INI file for loaded resource DLL.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Public Attributes

CXTPPaintManagerColor clrText
Text Normal color.
CXTPPaintManagerColor clrTextHighlight
Text Highlight color.
CXTPPaintManagerColor clrTextPushed
Text Pushed color.
CXTPPaintManagerColor clrTextDisabled
Text Disabled color.
CXTPPaintManagerColor clrTextChecked
Text Checked color.
CXTPPaintManagerColor | clrTextCheckedHighlight
Text Checked highlight color.
CXTPPaintManagerColor clrBack
Background Normal color.
CXTPPaintManagerColor clrBackHighlight
Background Highlight color.
CXTPPaintManagerColor clrBackPushed
Background Pushed color.
CXTPPaintManagerColor clrBackDisabled
Background Disabled color.
CXTPPaintManagerColor clrBackChecked
Background Checked color.
CXTPPaintManagerColor | clrBackCheckedHighlight
Background Checked highlight color.
CXTPPaintManagerColor clrBorder
Border Normal color.
CXTPPaintManagerColor clrBorderHighlight
Border Highlight color.
CXTPPaintManagerColor clrBorderPushed
Border Pushed color.
CXTPPaintManagerColor clrBorderDisabled
Border Disabled color.
CXTPPaintManagerColor clrBorderChecked
Border Checked color.
CXTPPaintManagerColor | clrBorderCheckedHighlight
Border Checked highlight color.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

Base class used to define various state colors used by command bar buttons text, background and border.

Member Data Documentation

◆ clrBack

CXTPPaintManagerColor clrBack

Background Normal color.

◆ clrBackChecked

CXTPPaintManagerColor clrBackChecked

Background Checked color.

◆ clrBackDisabled

CXTPPaintManagerColor clrBackDisabled

Background Disabled color.

◆ clrBackHighlight

CXTPPaintManagerColor clrBackHighlight

Background Highlight color.

◆ clrBackPushed

CXTPPaintManagerColor clrBackPushed

Background Pushed color.

◆ clrBorder

CXTPPaintManagerColor clrBorder

Border Normal color.

◆ clrBorderChecked

CXTPPaintManagerColor clrBorderChecked

Border Checked color.

◆ clrBorderDisabled

CXTPPaintManagerColor clrBorderDisabled

Border Disabled color.

◆ clrBorderHighlight

CXTPPaintManagerColor clrBorderHighlight

Border Highlight color.

◆ clrBorderPushed

CXTPPaintManagerColor clrBorderPushed

Border Pushed color.

◆ clrText

CXTPPaintManagerColor clrText

Text Normal color.

◆ clrTextChecked

CXTPPaintManagerColor clrTextChecked

Text Checked color.

◆ clrTextDisabled

CXTPPaintManagerColor clrTextDisabled

Text Disabled color.

◆ clrTextHighlight

CXTPPaintManagerColor clrTextHighlight

Text Highlight color.

◆ clrTextPushed

CXTPPaintManagerColor clrTextPushed

Text Pushed color.

The documentation for this class was generated from the following file:
  • XTPCommandBarsColorSetOffice2013.h


Toolkit Pro: CXTPColorSetStateCheckBox Class Reference

Public Member Functions | List of all members
CXTPColorSetStateCheckBox Class Reference

Helper class used to define various state colors used by check box and radio button controls. More...

Public Member Functions

virtual | ~CXTPColorSetStateCheckBox ()
Handles object destruction.
virtual void | RefreshColors ()
Call this member function to refresh the colors from predefined Section and Key values located in the theme INI file for loaded resource DLL.

Detailed Description

Helper class used to define various state colors used by check box and radio button controls.

The documentation for this class was generated from the following file:
  • XTPCommandBarsColorSetOffice2013.h


Toolkit Pro: CXTPColorSetStateCheckMark Class Reference

Public Member Functions | Public Attributes | List of all members
CXTPColorSetStateCheckMark Class Reference

Helper class used to define various state colors used by command bar check marks foreground and background. More...

Public Member Functions

virtual | ~CXTPColorSetStateCheckMark ()
Handles object destruction.
virtual void | RefreshColors ()
Call this member function to refresh the colors from predefined Section and Key values located in the theme INI file for loaded resource DLL.

Public Attributes

CXTPPaintManagerColor clrCheck
Foreground Normal color.
CXTPPaintManagerColor clrCheckHighlight
Foreground Highlight color.
CXTPPaintManagerColor clrCheckPushed
Foreground Pushed color.
CXTPPaintManagerColor clrCheckDisabled
Foreground Disabled color.
CXTPPaintManagerColor clrBack
Background Normal color.
CXTPPaintManagerColor clrBackHighlight
Background Highlight color.
CXTPPaintManagerColor clrBackPushed
Background Pushed color.
CXTPPaintManagerColor clrBackDisabled
Background Disabled color.

Detailed Description

Helper class used to define various state colors used by command bar check marks foreground and background.

Member Data Documentation

◆ clrBack

CXTPPaintManagerColor clrBack

Background Normal color.

◆ clrBackDisabled

CXTPPaintManagerColor clrBackDisabled

Background Disabled color.

◆ clrBackHighlight

CXTPPaintManagerColor clrBackHighlight

Background Highlight color.

◆ clrBackPushed

CXTPPaintManagerColor clrBackPushed

Background Pushed color.

◆ clrCheck

CXTPPaintManagerColor clrCheck

Foreground Normal color.

◆ clrCheckDisabled

CXTPPaintManagerColor clrCheckDisabled

Foreground Disabled color.

◆ clrCheckPushed

CXTPPaintManagerColor clrCheckPushed

Foreground Pushed color.

The documentation for this class was generated from the following file:
  • XTPCommandBarsColorSetOffice2013.h


Toolkit Pro: CXTPColorSetStateComboBox Class Reference

Public Member Functions | Public Attributes | List of all members
CXTPColorSetStateComboBox Class Reference

Helper class used to define various state colors used by command bar glyphs. More...

Public Member Functions

virtual | ~CXTPColorSetStateComboBox ()
Handles object destruction.
virtual void | RefreshColors ()
Call this member function to refresh the colors from predefined Section and Key values located in the theme INI file for loaded resource DLL.

Public Attributes

CXTPPaintManagerColor | clrBack
ComboBox normal background color.
CXTPPaintManagerColor | clrBackHighlight
ComboBox highlight background color.
CXTPPaintManagerColor | clrBackDropped
ComboBox dropped background color.
CXTPPaintManagerColor | clrBackDisabled
ComboBox disabled background color.
CXTPPaintManagerColor | clrBorder
ComboBox normal border color.
CXTPPaintManagerColor | clrBorderHighlight
ComboBox highlight border color.
CXTPPaintManagerColor | clrBorderDropped
ComboBox dropped border color.
CXTPPaintManagerColor | clrBorderDisabled
ComboBox disabled border color.
CXTPPaintManagerColor | clrDropDownBack
Drop down ComboBox normal background color.
CXTPPaintManagerColor | clrDropDownBackHighlight
Drop down ComboBox highlight background color.
CXTPPaintManagerColor | clrDropDownBackDropped
Drop down ComboBox dropped background color.
CXTPPaintManagerColor | clrDropDownBackDisabled
Drop down ComboBox disabled background color.
CXTPPaintManagerColor clrDropDownBorder
Drop down ComboBox normal border color.
CXTPPaintManagerColor | clrDropDownBorderHighlight
Drop down ComboBox highlight border color.
CXTPPaintManagerColor | clrDropDownBorderDropped
Drop down ComboBox dropped border color.
CXTPPaintManagerColor | clrDropDownBorderDisabled
Drop down ComboBox disabled border color.
CXTPPaintManagerColor clrDropDownMarker
Drop down ComboBox normal marker color.
CXTPPaintManagerColor | clrDropDownMarkerHighlight
Drop down ComboBox highlight marker color.
CXTPPaintManagerColor | clrDropDownMarkerDropped
Drop down ComboBox dropped marker color.
CXTPPaintManagerColor | clrDropDownMarkerDisabled
Drop down ComboBox disabled marker color.

Detailed Description

Helper class used to define various state colors used by command bar glyphs.

Member Data Documentation

◆ clrDropDownBorder

CXTPPaintManagerColor clrDropDownBorder

Drop down ComboBox normal border color.

◆ clrDropDownMarker

CXTPPaintManagerColor clrDropDownMarker

Drop down ComboBox normal marker color.

The documentation for this class was generated from the following file:
  • XTPCommandBarsColorSetOffice2013.h


Toolkit Pro: CXTPColorSetStateMenu Class Reference

Public Member Functions | Public Attributes | List of all members
CXTPColorSetStateMenu Class Reference

Color set class used to define various state colors used by command bar menus. More...

Inheritance diagram for CXTPColorSetStateMenu:
[legend]

Public Member Functions

virtual void RefreshColors ()
Call this member function to refresh the colors from predefined Section and Key values located in the theme INI file for loaded resource DLL.
- Public Member Functions inherited from CXTPColorSetStateButton
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Public Attributes

CXTPPaintManagerColor clrMenuBack
Menu background color.
CXTPPaintManagerColor clrMenuBorder
Menu border color.
CXTPPaintManagerColor | clrGripper
Menu item icon strip background color.
CXTPPaintManagerColorGradient clrSeparator
Separator dark and light colors.
- Public Attributes inherited from CXTPColorSetStateButton
CXTPPaintManagerColor clrText
Text Normal color.
CXTPPaintManagerColor clrTextHighlight
Text Highlight color.
CXTPPaintManagerColor clrTextPushed
Text Pushed color.
CXTPPaintManagerColor clrTextDisabled
Text Disabled color.
CXTPPaintManagerColor clrTextChecked
Text Checked color.
CXTPPaintManagerColor | clrTextCheckedHighlight
Text Checked highlight color.
CXTPPaintManagerColor clrBack
Background Normal color.
CXTPPaintManagerColor clrBackHighlight
Background Highlight color.
CXTPPaintManagerColor clrBackPushed
Background Pushed color.
CXTPPaintManagerColor clrBackDisabled
Background Disabled color.
CXTPPaintManagerColor clrBackChecked
Background Checked color.
CXTPPaintManagerColor | clrBackCheckedHighlight
Background Checked highlight color.
CXTPPaintManagerColor clrBorder
Border Normal color.
CXTPPaintManagerColor clrBorderHighlight
Border Highlight color.
CXTPPaintManagerColor clrBorderPushed
Border Pushed color.
CXTPPaintManagerColor clrBorderDisabled
Border Disabled color.
CXTPPaintManagerColor clrBorderChecked
Border Checked color.
CXTPPaintManagerColor | clrBorderCheckedHighlight
Border Checked highlight color.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

Color set class used to define various state colors used by command bar menus.

Member Data Documentation

◆ clrMenuBack

CXTPPaintManagerColor clrMenuBack

Menu background color.

◆ clrMenuBorder

CXTPPaintManagerColor clrMenuBorder

Menu border color.

◆ clrSeparator

CXTPPaintManagerColorGradient clrSeparator

Separator dark and light colors.

The documentation for this class was generated from the following file:
  • XTPCommandBarsColorSetOffice2013.h


Toolkit Pro: CXTPColorSetStateMenuTitleBar Class Reference

List of all members
CXTPColorSetStateMenuTitleBar Class Reference

Color set class used to define various state colors used by command bar menu title bars. More...

Inheritance diagram for CXTPColorSetStateMenuTitleBar:
[legend]

Additional Inherited Members

- Public Member Functions inherited from CXTPColorSetStateButton
virtual void | RefreshColors ()=0
Call this member function to refresh the colors from predefined Section and Key values located in the theme INI file for loaded resource DLL.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPColorSetStateButton
CXTPPaintManagerColor clrText
Text Normal color.
CXTPPaintManagerColor clrTextHighlight
Text Highlight color.
CXTPPaintManagerColor clrTextPushed
Text Pushed color.
CXTPPaintManagerColor clrTextDisabled
Text Disabled color.
CXTPPaintManagerColor clrTextChecked
Text Checked color.
CXTPPaintManagerColor | clrTextCheckedHighlight
Text Checked highlight color.
CXTPPaintManagerColor clrBack
Background Normal color.
CXTPPaintManagerColor clrBackHighlight
Background Highlight color.
CXTPPaintManagerColor clrBackPushed
Background Pushed color.
CXTPPaintManagerColor clrBackDisabled
Background Disabled color.
CXTPPaintManagerColor clrBackChecked
Background Checked color.
CXTPPaintManagerColor | clrBackCheckedHighlight
Background Checked highlight color.
CXTPPaintManagerColor clrBorder
Border Normal color.
CXTPPaintManagerColor clrBorderHighlight
Border Highlight color.
CXTPPaintManagerColor clrBorderPushed
Border Pushed color.
CXTPPaintManagerColor clrBorderDisabled
Border Disabled color.
CXTPPaintManagerColor clrBorderChecked
Border Checked color.
CXTPPaintManagerColor | clrBorderCheckedHighlight
Border Checked highlight color.

Detailed Description

Color set class used to define various state colors used by command bar menu title bars.

The documentation for this class was generated from the following file:
  • XTPCommandBarsColorSetOffice2013.h


Toolkit Pro: CXTPColorSetStateRibbon Class Reference

Public Member Functions | Public Attributes | List of all members
CXTPColorSetStateRibbon Class Reference

Color set class used to define various state colors used by command bar ribbon. More...

Inheritance diagram for CXTPColorSetStateRibbon:
[legend]

Public Member Functions

virtual void RefreshColors ()
Call this member function to refresh the colors from predefined Section and Key values located in the theme INI file for loaded resource DLL.
- Public Member Functions inherited from CXTPColorSetStateButton
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Public Attributes

CXTPPaintManagerColor | clrTabTextInactive
Ribbon tab inactive text color;

CXTPPaintManagerColor | clrTabBackInactive
Ribbon tab inactive background color;.
- Public Attributes inherited from CXTPColorSetStateButton
CXTPPaintManagerColor clrText
Text Normal color.
CXTPPaintManagerColor clrTextHighlight
Text Highlight color.
CXTPPaintManagerColor clrTextPushed
Text Pushed color.
CXTPPaintManagerColor clrTextDisabled
Text Disabled color.
CXTPPaintManagerColor clrTextChecked
Text Checked color.
CXTPPaintManagerColor | clrTextCheckedHighlight
Text Checked highlight color.
CXTPPaintManagerColor clrBack
Background Normal color.
CXTPPaintManagerColor clrBackHighlight
Background Highlight color.
CXTPPaintManagerColor clrBackPushed
Background Pushed color.
CXTPPaintManagerColor clrBackDisabled
Background Disabled color.
CXTPPaintManagerColor clrBackChecked
Background Checked color.
CXTPPaintManagerColor | clrBackCheckedHighlight
Background Checked highlight color.
CXTPPaintManagerColor clrBorder
Border Normal color.
CXTPPaintManagerColor clrBorderHighlight
Border Highlight color.
CXTPPaintManagerColor clrBorderPushed
Border Pushed color.
CXTPPaintManagerColor clrBorderDisabled
Border Disabled color.
CXTPPaintManagerColor clrBorderChecked
Border Checked color.
CXTPPaintManagerColor | clrBorderCheckedHighlight
Border Checked highlight color.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

Color set class used to define various state colors used by command bar ribbon.

The documentation for this class was generated from the following file:
  • XTPCommandBarsColorSetOffice2013.h


Toolkit Pro: CXTPColorSetStateToolbar Class Reference

Public Member Functions | Public Attributes | List of all members
CXTPColorSetStateToolbar Class Reference

Color set class used to define various state colors used by command bar toolbars. More...

Inheritance diagram for CXTPColorSetStateToolbar:
[legend]

Public Member Functions

virtual void RefreshColors ()
Call this member function to refresh the colors from predefined Section and Key values located in the theme INI file for loaded resource DLL.
- Public Member Functions inherited from CXTPColorSetStateButton
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Public Attributes

CXTPPaintManagerColor clrToolbarBack
Toolbar background color.
CXTPPaintManagerColor clrToolbarActiveBack
Toolbar active background color.
CXTPPaintManagerColor clrToolbarInactiveBack
Toolbar inactive background color.
CXTPPaintManagerColor clrToolbarBorder
Toolbar border color.
CXTPPaintManagerColor clrToolbarActiveBorder
Toolbar active border color.
CXTPPaintManagerColor clrToolbarInactiveBorder
Toolbar inactive border color.
CXTPPaintManagerColor clrEditBorder
Toolbar edit control border color.
CXTPPaintManagerColor clrGripper
Toolbar gripper color.
CXTPPaintManagerColor clrDisabledIcon
Toolbar disabled icon color.
CXTPPaintManagerColorGradient clrSeparator
Separator dark and light colors.
- Public Attributes inherited from CXTPColorSetStateButton
CXTPPaintManagerColor clrText
Text Normal color.
CXTPPaintManagerColor clrTextHighlight
Text Highlight color.
CXTPPaintManagerColor clrTextPushed
Text Pushed color.
CXTPPaintManagerColor clrTextDisabled
Text Disabled color.
CXTPPaintManagerColor clrTextChecked
Text Checked color.
CXTPPaintManagerColor | clrTextCheckedHighlight
Text Checked highlight color.
CXTPPaintManagerColor clrBack
Background Normal color.
CXTPPaintManagerColor clrBackHighlight
Background Highlight color.
CXTPPaintManagerColor clrBackPushed
Background Pushed color.
CXTPPaintManagerColor clrBackDisabled
Background Disabled color.
CXTPPaintManagerColor clrBackChecked
Background Checked color.
CXTPPaintManagerColor | clrBackCheckedHighlight
Background Checked highlight color.
CXTPPaintManagerColor clrBorder
Border Normal color.
CXTPPaintManagerColor clrBorderHighlight
Border Highlight color.
CXTPPaintManagerColor clrBorderPushed
Border Pushed color.
CXTPPaintManagerColor clrBorderDisabled
Border Disabled color.
CXTPPaintManagerColor clrBorderChecked
Border Checked color.
CXTPPaintManagerColor | clrBorderCheckedHighlight
Border Checked highlight color.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

Color set class used to define various state colors used by command bar toolbars.

Member Data Documentation

◆ clrDisabledIcon

CXTPPaintManagerColor clrDisabledIcon

Toolbar disabled icon color.

◆ clrEditBorder

CXTPPaintManagerColor clrEditBorder

Toolbar edit control border color.

◆ clrGripper

CXTPPaintManagerColor clrGripper

Toolbar gripper color.

◆ clrSeparator

CXTPPaintManagerColorGradient clrSeparator

Separator dark and light colors.

◆ clrToolbarActiveBack

CXTPPaintManagerColor clrToolbarActiveBack

Toolbar active background color.

◆ clrToolbarActiveBorder

CXTPPaintManagerColor clrToolbarActiveBorder

Toolbar active border color.

◆ clrToolbarBack

CXTPPaintManagerColor clrToolbarBack

Toolbar background color.

◆ clrToolbarBorder

CXTPPaintManagerColor clrToolbarBorder

Toolbar border color.

◆ clrToolbarInactiveBack

CXTPPaintManagerColor clrToolbarInactiveBack

Toolbar inactive background color.

◆ clrToolbarInactiveBorder

CXTPPaintManagerColor clrToolbarInactiveBorder

Toolbar inactive border color.

The documentation for this class was generated from the following file:
  • XTPCommandBarsColorSetOffice2013.h


Toolkit Pro: CXTPColorWnd Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPColorWnd Class Reference

CXTPColorWnd is a CXTPColorBase derived class. More...

Inheritance diagram for CXTPColorWnd:
[legend]

Public Member Functions

CXTPColorWnd ()
Constructs a CXTPColorWnd object.
virtual | ~CXTPColorWnd ()
Destroys a CXTPColorWnd object, handles cleanup and deallocation.
virtual void | SetColor (double nHue, double nSat)
Call this member function to set the color for the selection window.
virtual void | UpdateCursorPos (CPoint point)
Call this member function to update the cursor position.
void | DrawCrossHair (CDC *pDC)
This member function is called to update the crosshair cursor.
void | SetHue (double h)
This member function is called to set the hue for the color window.
void | SetSaturation (double s)
This member function is called to set the saturation for the color window.
- Public Member Functions inherited from CXTPColorBase
CXTPColorBase ()
Constructs a CXTPColorBase object.
virtual | ~CXTPColorBase ()
Destroys a CXTPColorBase object, handles cleanup and deallocation.

Protected Attributes

CBitmap | m_bmpPicker
Background device context.
- Protected Attributes inherited from CXTPColorBase
bool | m_bPreSubclassInit
true when initializing from PreSubclassWindow.

Additional Inherited Members

- Public Types inherited from CXTPColorBase
enum | FocusedControl { focusNone , focusColorWheel , focusLumination }
Enumeration used to determine window focus. More...
- Static Public Member Functions inherited from CXTPColorBase
static void AFX_CDECL | RGBtoHSL (COLORREF color, double *h, double *s, double *l)
This member function is called to convert an RGB color value to an HSL value.
static COLORREF AFX_CDECL | HLStoRGB (double h, double l, double s)
This member function is called to convert an HLS value to an RGB color value.
- Public Attributes inherited from CXTPColorBase
double | m_nLum
Current illumination value.
double | m_nSat
Current saturation value.
double | m_nHue
Current hue value.
CPoint | m_ptMousePos
Current mouse position relative to the device context.
- Protected Member Functions inherited from CXTPColorBase
virtual bool | Init ()
This member function is called by the CXTPColorBase class to perform initialization when the window is created or sub-classed.
- Static Protected Attributes inherited from CXTPColorBase
static FocusedControl | m_eHasFocus
Determines which property page has input focus.

Detailed Description

CXTPColorWnd is a CXTPColorBase derived class.

It is used to create a color selection window.

Member Function Documentation

◆ DrawCrossHair()

void DrawCrossHair ( CDC * pDC )

This member function is called to update the crosshair cursor.

Parameters
pDC A CDC pointer that represents the current device context.

◆ SetColor()

virtual void SetColor | ( | double | nHue,
 |  | double | nSat )
 virtual

Call this member function to set the color for the selection window.

Parameters
nHue | Current hue value that represents the color.
nSat | Current saturation value that represents the color.

◆ SetHue()

void SetHue ( double h )

This member function is called to set the hue for the color window.

Parameters
h Represents the new hue value to set.

◆ SetSaturation()

void SetSaturation ( double s )

This member function is called to set the saturation for the color window.

Parameters
s Represents the new saturation value to set.

◆ UpdateCursorPos()

virtual void UpdateCursorPos ( CPoint point )
virtual

Call this member function to update the cursor position.

Parameters
point Current cursor location relative to the device context.

Reimplemented from CXTPColorBase.

The documentation for this class was generated from the following file:
  • XTPColorPageCustom.h


Toolkit Pro: CXTPComboBox Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPComboBox Class Reference

The CXTPComboBox class provides the functionality of a themed Windows combobox. More...

Inheritance diagram for CXTPComboBox:
[legend]

Public Member Functions

CXTPComboBox ()
Constructs a CXTPComboBox object.
virtual | ~CXTPComboBox ()
Destroys a CXTPComboBox object, handles cleanup and deallocation.
virtual void | Initialize (bool bAutoFont=true)
Call this member function to initialize the combobox.
BOOL | SetTheme (XTPControlTheme nTheme)
Call this member function to switch the visual theme of the control.
virtual void | SetTheme (CXTPComboBoxTheme *pTheme)
This member function is called to set the theme for the combobox control using the theme specified by pTheme.
CXTPComboBoxTheme * GetTheme ()
Call this member function to retrieve a pointer to the current theme used by the combobox.
const CXTPComboBoxTheme * | GetTheme () const
Call this member function to retrieve a pointer to the current theme used by the combobox.
void | RedrawComboBox (BOOL bUpdateWindow=FALSE)
Redraws the button.
BOOL | GetFlatStyle () const
Gets the flat style appearance of the combobox.
void | SetFlatStyle (BOOL bFlatStyle=TRUE)
Sets the flat style appearance of the button control.
BOOL | GetUseVisualStyle () const
Determines if the control is drawn using visual styles/SkinFramework, if supported.
void | SetUseVisualStyle (BOOL bUseVisualStyle=TRUE)
Enables Windows XP visual styles for the control.
void | EnableAutoCompletion (BOOL bEnable=TRUE)
This member function enables/disables auto-completion.
virtual void | SetBackColor (COLORREF crBack)
Call this member function to set the background color for the CXTPComboBox control.
COLORREF | GetBackColor () const
Call this member function to retrieve the background color of the CXTPComboBox control.
virtual void | SetTextColor (COLORREF crText)
Call this member function to set the text color for the CXTPComboBox control.
COLORREF | GetTextColor () const
Call this member function to retrieve the text color of the CXTPComboBox control.
void | RefreshMetrics ()
This member function is called to update the color, text, and other visual elements of the control.
BOOL | IsFocused () const
Call this member function to determine if the combobox has input focus.
BOOL | IsHighlighted () const
Call this member function to determine if the combobox state is highilghted, meaning that the mouse cursor is currently hovering over the control.
BOOL | IsDroppedDown () const
Call this member function to determine if the combobox is currently dropped down.
HBRUSH | GetClientBrush (CDC *pDC)
Call this member function to retrieve a handle to the client background brush.
CRect | GetComboBoxRect () const
Call this member function to retrieve the size of the combobox in client coordinates.
void | SetHighlighted (BOOL bHot)
This member fuction is called to set the highlighted state for the combobox.
void | EnableMarkup (BOOL bEnableMarkup=TRUE)
Allows the use of a XAML snippet to be used for the text of panes in the control.

Protected Member Functions

void | RedrawFocusedFrame ()
Called by the framework to redraw the focused frame for the combobox.
BOOL | NeedRedraw ()
Called by the framework to determine if the combobox needs to be redrawn.

Protected Attributes

BOOL | m_bPreSubclassInit
TRUE if the control has been subclassed.
BOOL | m_bUseVisualStyle
TRUE to use Windows themes.
BOOL | m_bFlatStyle
TRUE to draw the control using flat styles.
BOOL | m_bHighlighted
TRUE when the combobox is highlighted.
BOOL | m_bFocused
TRUE when the combobox has input focus.
BOOL | m_bAutoComp
TRUE when the combobox is using the auto-complete feature.
BOOL | m_bDisableAC
TRUE to disable auto-complete temporarily.
CXTPComboBoxTheme * | m_pTheme
Pointer to the current theme object.
CXTPComboBoxEditCtrl * | m_pWndEdit
Pointer to the edit-control for the combobox.
BOOL | m_bEnableMarkup
TRUE to enable markup.
CXTPMarkupContext * | m_pMarkupContext
Markup context.

Detailed Description

The CXTPComboBox class provides the functionality of a themed Windows combobox.

Member Function Documentation

◆ EnableAutoCompletion()

void EnableAutoCompletion ( BOOL bEnable = TRUE )

This member function enables/disables auto-completion.

Parameters
bEnable TRUE to enable auto-completion, FALSE to disable auto-completion. By default, this parameter is TRUE.

◆ EnableMarkup()

void EnableMarkup ( BOOL bEnableMarkup = TRUE )

Allows the use of a XAML snippet to be used for the text of panes in the control.

Parameters
bEnableMarkup TRUE to enable markup, FALSE to disable markup.

◆ GetBackColor()

COLORREF GetBackColor ( ) const

Call this member function to retrieve the background color of the CXTPComboBox control.

Returns
An RGB color value representing the background color of the CXTPComboBox control.
See also
SetTextColor, SetBackColor, GetTextColor

◆ GetClientBrush()

HBRUSH GetClientBrush ( CDC * pDC )

Call this member function to retrieve a handle to the client background brush.

Parameters
pDC Pointer to a valid device context.
Returns
A HBRUSH handle representing the client background brush.

◆ GetComboBoxRect()

CRect GetComboBoxRect ( ) const

Call this member function to retrieve the size of the combobox in client coordinates.

Returns
A CRect object representing the client size for the combobox.

◆ GetFlatStyle()

BOOL GetFlatStyle ( ) const

Gets the flat style appearance of the combobox.

The control will appear flat until the mouse pointer moves over it, at which point it appears three-dimensional.

Returns
TRUE if the flat style is used, otherwise FALSE.

◆ GetTextColor()

COLORREF GetTextColor ( ) const

Call this member function to retrieve the text color of the CXTPComboBox control.

Returns
An RGB color value representing the text color of the CXTPComboBox control.
See also
SetTextColor, SetBackColor, GetBackColor

◆ GetTheme() [1/2]

CXTPComboBoxTheme * GetTheme ( )

Call this member function to retrieve a pointer to the current theme used by the combobox.

Returns
A CXTPComboBoxTheme pointer, or NULL if no theme is set.

◆ GetTheme() [2/2]

const CXTPComboBoxTheme * GetTheme ( ) const

Call this member function to retrieve a pointer to the current theme used by the combobox.

Returns
A CXTPComboBoxTheme pointer, or NULL if no theme is set.

◆ GetUseVisualStyle()

BOOL GetUseVisualStyle ( ) const

Determines if the control is drawn using visual styles/SkinFramework, if supported.

This method enables Windows XP visual styles for the control. This Control will draw using visual styles if both the control and the operating system support it. Visual styles and SkinFramework skins are specifications for the appearance of controls. GetUseVisualStyle determines whether to use the currently set Windows XP visual style. If using SkinFramework, then it determines whether to use the currently set style of the SkinFramework.

Returns
TRUE if the currently set Windows XP visual style will be used to theme the control. If using SkinFramework, then the currently set style of the SkinFramework will be used to skin the control. FALSE if the currently set appearance/style in the OS will be used.

◆ Initialize()

virtual void Initialize ( bool bAutoFont = true )
virtual

Call this member function to initialize the combobox.

This method should be called directly after creating or sub-classing the control.

Parameters
bAutoFont true to enable automatic font initialization.

◆ IsDroppedDown()

BOOL IsDroppedDown ( ) const

Call this member function to determine if the combobox is currently dropped down.

Prefer calling this method intead of getting result of CB_GETDROPPEDSTATE message which may produce false positive results.

Returns
TRUE if the combobox state is dropped down.

◆ IsFocused()

BOOL IsFocused ( ) const

Call this member function to determine if the combobox has input focus.

Returns
TRUE if the combobox has input focus, otherwise FALSE.

◆ IsHighlighted()

BOOL IsHighlighted ( ) const

Call this member function to determine if the combobox state is highilghted, meaning that the mouse cursor is currently hovering over the control.

Returns
TRUE if the combobox state is highlighted, otherwise FALSE.

◆ NeedRedraw()

BOOL NeedRedraw ( )
protected

Called by the framework to determine if the combobox needs to be redrawn.

Returns
TRUE if the combobox needs to be redrawn.

◆ RedrawComboBox()

void RedrawComboBox ( BOOL bUpdateWindow = FALSE )

Redraws the button.

Parameters
bUpdateWindow TRUE to notify the parent window.

◆ SetBackColor()

virtual void SetBackColor ( COLORREF crBack )
virtual

Call this member function to set the background color for the CXTPComboBox control.

Parameters
crBack An RGB color value representing the background color for the CXTPComboBox control.
See also
SetTextColor, GetBackColor, GetTextColor

◆ SetFlatStyle()

void SetFlatStyle ( BOOL bFlatStyle = TRUE )

Sets the flat style appearance of the button control.

Parameters
bFlatStyle TRUE to use the flat style, otherwise FALSE.

The control will appear flat until the mouse pointer moves over it, at which point it appears three-dimensional.

◆ SetHighlighted()

void SetHighlighted ( BOOL bHot )

This member fuction is called to set the highlighted state for the combobox.

Parameters
bHot TRUE to set the combobox state to highlighted.

◆ SetTextColor()

virtual void SetTextColor ( COLORREF crText )
virtual

Call this member function to set the text color for the CXTPComboBox control.

Parameters
crText An RGB value representing the text color for the CXTPComboBox control.
See also
SetBackColor, GetBackColor, GetTextColor

◆ SetTheme() [1/2]

virtual void SetTheme ( CXTPComboBoxTheme * pTheme )
virtual

This member function is called to set the theme for the combobox control using the theme specified by pTheme.

Parameters
pTheme Pointer to a valid CXTPComboBox theme object.

◆ SetTheme() [2/2]

BOOL SetTheme ( XTPControlTheme nTheme )

Call this member function to switch the visual theme of the control.

Parameters
nTheme New visual theme. Can be any of the values listed in the Remarks section.
Returns
TRUE if successful, otherwise FALSE.

nTheme can be one of the theme IDs specified by XTPControlTheme.

See also
XTPControlTheme

◆ SetUseVisualStyle()

void SetUseVisualStyle ( BOOL bUseVisualStyle = TRUE )

Enables Windows XP visual styles for the control.

This method enables Windows XP visual styles for the control. This Control will draw using visual styles if both the control and the operating system support it. Visual styles and SkinFramework skins are specifications for the appearance of controls. GetUseVisualStyle determines whether to use the currently set Windows XP visual style. If using SkinFramework, then it determines whether to use the currently set style of the SkinFramework.

Parameters
bUseVisualStyle TRUE if the currently set Windows XP visual style will be used to theme the control. If using SkinFramework, then the currently set style of the SkinFramework will be used to skin the control. FALSE if the currently set appearance/style in the OS will be used.

Member Data Documentation

◆ m_bFlatStyle

BOOL m_bFlatStyle
protected

TRUE to draw the control using flat styles.

This is mostly deprecated; use SetTheme() instead.

The documentation for this class was generated from the following file:
  • XTPComboBox.h


Toolkit Pro: CXTPComboBoxEditCtrl Class Reference

CXTPComboBoxEditCtrl Class Reference

Used by the CXTPComboBox object to subclass the edit-box portion of the control. More...

Detailed Description

Used by the CXTPComboBox object to subclass the edit-box portion of the control.

The documentation for this class was generated from the following file:
  • XTPComboBoxEditCtrl.h


Toolkit Pro: CXTPComboBoxTheme Class Reference

Public Member Functions | Public Attributes | Protected Member Functions | Protected Attributes | List of all members
CXTPComboBoxTheme Class Reference

CXTPComboBoxTheme is a class used to perform ComboBox Theme drawing tasks. More...

Inheritance diagram for CXTPComboBoxTheme:
[legend]

Public Member Functions

CXTPComboBoxTheme ()
Default constructor.
virtual | ~CXTPComboBoxTheme ()
Destructor handles cleanup and deallocation.
virtual void | FillSolidRect (HDC hdc, int x, int y, int cx, int cy, HBRUSH hBrush)
Called by the combobox to fill a rectangle using the brush specifed by hBrush.
virtual void | DrawFrame (HDC hdc, LPRECT lprc, int nSize, HBRUSH hBrush)
Called by the combobox to draw a frame rectangle using the brush specified by hBrush.
virtual BOOL | DrawComboBox (CDC *pDC, CXTPComboBox *pComboBox)
Called by the framework to draw the combobox control.
virtual void | DrawBackground (CDC *pDC, CXTPComboBox *pComboBox)
This member function is called to draw the combobox background.
virtual void | DrawButton (CDC *pDC, CXTPComboBox *pComboBox, CRect rcBtn)
Called by the paint manager to draw the button portion of the combobox control.
virtual void | DrawButtonTriangle (CDC *pDC, CXTPComboBox *pComboBox, CRect rcBtn)
Called by the paint manager to draw the drop down arrow for the combobox drop button.
virtual void | RefreshMetrics (CXTPComboBox *pComboBox)
This member function is called by the theme manager to refresh the visual styles used by each component's theme.
COLORREF | GetBackColor () const
Call this member function to retrieve the background color of the CXTPComboBox control.
COLORREF | SetBackColor (COLORREF clrBackground)
Call this member function to set the background color for the CXTPComboBox control.
void | ResetBackColor ()
Call this member function to reset the background color for the CXTPComboBox control.
COLORREF | GetTextColor () const
Call this member function to retrieve the text color of the CXTPComboBox control.
COLORREF | SetTextColor (COLORREF clrText)
Call this member function to set the text color for the CXTPComboBox control.
void | ResetTextColor ()
Call this member function to reset the text color for the CXTPComboBox control.
const CBrush & | GetBackgroundBrush () const
Call this member function to retrieve a reference to a CBrush object used to draw the combobox background.
- Public Member Functions inherited from CXTPControlTheme
CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme | GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Public Attributes

CXTPPaintManagerColor | m_clrBorderDisabled
RGB value used to draw the disabled border color.
CXTPPaintManagerColor | m_clrBorderHot
RGB value used to draw the hilighted border color.
CXTPPaintManagerColor | m_clrBorderNormal
RGB value used to draw the normal border color.
CXTPPaintManagerColor | m_clrButtonPressed
RGB value used to draw the pressed button color.
CXTPPaintManagerColor | m_clrButtonHot
RGB value used to draw the highlighted button color.
CXTPPaintManagerColor | m_clrButtonNormal
RGB value used to draw the normal button color.
CXTPPaintManagerColor | m_clrButtonArrowPressed
RGB value used to draw the pressed button arrow color.
CXTPPaintManagerColor | m_clrButtonArrowHot
RGB value used to draw the highlighted button arrow color.
CXTPPaintManagerColor | m_clrButtonArrowNormal
RGB value used to draw the normal button arrow color.
CXTPPaintManagerColor | m_clrBackground
RGB color value representing background color.
CXTPPaintManagerColor | m_clrBackDisabled
RGB color value representing disabled background color.
CXTPPaintManagerColor | m_clrBackHighlight
RGB color value representing highlight background color.
CXTPPaintManagerColor | m_clrText
RGB color value representing text color.
CXTPPaintManagerColor | m_clrTextDisabled
RGB color value representing disabled text color.
CXTPPaintManagerColor | m_clrTextHighlight
RGB color value representing highlight text color.
CXTPPaintManagerColorGradient | m_grcButton
RGB value used to draw the button gradient color.
CXTPPaintManagerColorGradient | m_grcButtonHilite
RGB value used to draw the button highlighted gradient color.
CXTPPaintManagerColorGradient | m_grcButtonPushed
RGB value used to draw the button pushed gradient color.

Protected Member Functions

void UpdateBackgroundBrush ()
Called by the framework to update the color value used by the combobox background brush.

Protected Attributes

int | m_nThumbWidth
Size in pixels of the drop button width.
CXTPBrush | m_xtpBrushBackground
Brush used by the combobox to fill the background color.
CXTPWinThemeWrapper * | m_themeComboBox
Windows API wrapper used to draw windows theme.
- Protected Attributes inherited from CXTPControlTheme
XTPControlTheme | m_nTheme
Currently selected theme style index.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlTheme
static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

CXTPComboBoxTheme is a class used to perform ComboBox Theme drawing tasks.

This is the base class for all combobox themes.

Member Function Documentation

◆ DrawBackground()

virtual void DrawBackground | ( | CDC * | pDC,
 |  | CXTPComboBox * | pComboBox )
 virtual

This member function is called to draw the combobox background.

Parameters
pDC | Pointer to a valid device context.
pComboBox | Pointer to the combobox to be drawn.

Reimplemented in CXTPComboBoxThemeOffice2000, CXTPComboBoxThemeOffice2003, CXTPComboBoxThemeOffice2013, and CXTPComboBoxThemeOfficeXPFlat.

◆ DrawButton()

virtual void DrawButton | ( | CDC * | pDC,
 |  | CXTPComboBox * | pComboBox,
 |  | CRect | rcBtn )
 virtual

Called by the paint manager to draw the button portion of the combobox control.

Parameters
pDC | Pointer to the device context for the combobox.
pComboBox | Pointer to a CXTPComboBox object.
rcBtn | Size of the button to draw.

Reimplemented in CXTPComboBoxThemeNativeWindows10, CXTPComboBoxThemeNativeWindows11, CXTPComboBoxThemeOffice2000, CXTPComboBoxThemeOffice2003, CXTPComboBoxThemeOffice2013, CXTPComboBoxThemeOfficeXPFlat, CXTPComboBoxThemeVisualStudio2012, CXTPComboBoxThemeVisualStudio2015, CXTPComboBoxThemeVisualStudio2017, CXTPComboBoxThemeVisualStudio2019, and CXTPComboBoxThemeVisualStudio2022.

◆ DrawButtonTriangle()

virtual void DrawButtonTriangle | ( | CDC * | pDC,
 |  | CXTPComboBox * | pComboBox,
 |  | CRect | rcBtn )
 virtual

Called by the paint manager to draw the drop down arrow for the combobox drop button.

Parameters
pDC | Pointer to the device context for the combobox.
pComboBox | Pointer to a CXTPComboBox object.
rcBtn | Size of the button to draw.

Reimplemented in CXTPComboBoxThemeOffice2013.

◆ DrawComboBox()

virtual BOOL DrawComboBox | ( | CDC * | pDC,
 |  | CXTPComboBox * | pComboBox )
 virtual

Called by the framework to draw the combobox control.

Parameters
pDC | Pointer to a valid device context.
pComboBox | Pointer to the CXTPComboBox object to be drawn.
Returns
TRUE if successful; otherwise FALSE.

Reimplemented in CXTPComboBoxThemeDefault, and CXTPComboBoxThemeResource.

◆ DrawFrame()

virtual void DrawFrame | ( | HDC | hdc,
 |  | LPRECT | lprc,
 |  | int | nSize,
 |  | HBRUSH | hBrush )
 virtual

Called by the combobox to draw a frame rectangle using the brush specified by hBrush.

Parameters
hdc | Handle to a valid device context.
lprc | Pointer to a RECT structure representing the size of rectangle to draw.
nSize | Width in pixels of the rectangle borders.
hBrush | Handle to a HBRUSH object representing the border fill color.

◆ FillSolidRect()

virtual void FillSolidRect | ( | HDC | hdc,
 |  | int | x,
 |  | int | y,
 |  | int | cx,
 |  | int | cy,
 |  | HBRUSH | hBrush )
 virtual

Called by the combobox to fill a rectangle using the brush specifed by hBrush.

Parameters
hdc | Handle to a valid device context.
x | Left side of the rectangle to draw.
y | Top side of the rectangle to draw.
cx | Width of the rectangle to draw.
cy | Height of the rectangle to draw.
hBrush | Handle to a HBRUSH object representing the background fill color.

◆ GetBackColor()

COLORREF GetBackColor ( ) const

Call this member function to retrieve the background color of the CXTPComboBox control.

Returns
An RGB color value representing the background color of the CXTPComboBox control.
See also
SetTextColor, ResetTextColor, SetBackColor, GetTextColor

◆ GetBackgroundBrush()

const CBrush & GetBackgroundBrush ( ) const

Call this member function to retrieve a reference to a CBrush object used to draw the combobox background.

Returns
A reference to a CBrush object used to draw the combobox background.

◆ GetTextColor()

COLORREF GetTextColor ( ) const

Call this member function to retrieve the text color of the CXTPComboBox control.

Returns
An RGB color value representing the text color of the CXTPComboBox control.
See also
SetTextColor, ResetTextColor, SetBackColor, GetBackColor

◆ RefreshMetrics()

virtual void RefreshMetrics ( CXTPComboBox * pComboBox )
virtual

This member function is called by the theme manager to refresh the visual styles used by each component's theme.

Parameters
pComboBox Pointer to a CXTPComboBox object.

Reimplemented in CXTPComboBoxThemeDefault, CXTPComboBoxThemeNativeWindows10, CXTPComboBoxThemeNativeWindows11, CXTPComboBoxThemeOffice2000, CXTPComboBoxThemeOffice2003, CXTPComboBoxThemeOffice2013, CXTPComboBoxThemeOfficeXPFlat, CXTPComboBoxThemeResource, CXTPComboBoxThemeVisualStudio2010, CXTPComboBoxThemeVisualStudio2012, CXTPComboBoxThemeVisualStudio2015, CXTPComboBoxThemeVisualStudio2017, CXTPComboBoxThemeVisualStudio2019, CXTPComboBoxThemeVisualStudio2022, and CXTPComboBoxThemeVisualStudio.

◆ ResetBackColor()

void ResetBackColor ( )

Call this member function to reset the background color for the CXTPComboBox control.

See also
GetTextColor, SetTextColor, GetBackColor, GetTextColor

◆ ResetTextColor()

void ResetTextColor ( )

Call this member function to reset the text color for the CXTPComboBox control.

See also
GetTextColor, SetTextColor, SetBackColor, GetBackColor

◆ SetBackColor()

COLORREF SetBackColor ( COLORREF clrBackground )

Call this member function to set the background color for the CXTPComboBox control.

Parameters
clrBackground An RGB color value representing the background color for the CXTPComboBox control.
Returns
An RGB color value representing the previous background color for the CXTPComboBox control.
See also
SetTextColor, ResetTextColor, GetBackColor, GetTextColor

◆ SetTextColor()

COLORREF SetTextColor ( COLORREF clrText )

Call this member function to set the text color for the CXTPComboBox control.

Parameters
clrText An RGB color value representing the text color for the CXTPComboBox control.
Returns
An RGB color value representing the previous text color for the CXTPComboBox control.
See also
GetTextColor, ResetTextColor, SetBackColor, GetBackColor
The documentation for this class was generated from the following file:
  • XTPComboBoxTheme.h


Toolkit Pro: CXTPComboBoxThemeDefault Class Reference

Public Member Functions | List of all members
CXTPComboBoxThemeDefault Class Reference

Used as the paint manager for a combobox control to render a default appearance. More...

Inheritance diagram for CXTPComboBoxThemeDefault:
[legend]

Public Member Functions

CXTPComboBoxThemeDefault ()
Default constructor.
virtual | ~CXTPComboBoxThemeDefault ()
Destructor handles cleanup and deallocation.
virtual BOOL | DrawComboBox (CDC *pDC, CXTPComboBox *pComboBox)
Called by the framework to draw the combobox control.
virtual void | RefreshMetrics (CXTPComboBox *pComboBox)
This member function is called by the theme manager to refresh the visual styles used by each component's theme.
- Public Member Functions inherited from CXTPComboBoxTheme
CXTPComboBoxTheme ()
Default constructor.
virtual | ~CXTPComboBoxTheme ()
Destructor handles cleanup and deallocation.
virtual void | FillSolidRect (HDC hdc, int x, int y, int cx, int cy, HBRUSH hBrush)
Called by the combobox to fill a rectangle using the brush specifed by hBrush.
virtual void | DrawFrame (HDC hdc, LPRECT lprc, int nSize, HBRUSH hBrush)
Called by the combobox to draw a frame rectangle using the brush specified by hBrush.
virtual void | DrawBackground (CDC *pDC, CXTPComboBox *pComboBox)
This member function is called to draw the combobox background.
virtual void | DrawButton (CDC *pDC, CXTPComboBox *pComboBox, CRect rcBtn)
Called by the paint manager to draw the button portion of the combobox control.
virtual void | DrawButtonTriangle (CDC *pDC, CXTPComboBox *pComboBox, CRect rcBtn)
Called by the paint manager to draw the drop down arrow for the combobox drop button.
COLORREF | GetBackColor () const
Call this member function to retrieve the background color of the CXTPComboBox control.
COLORREF | SetBackColor (COLORREF clrBackground)
Call this member function to set the background color for the CXTPComboBox control.
void | ResetBackColor ()
Call this member function to reset the background color for the CXTPComboBox control.
COLORREF | GetTextColor () const
Call this member function to retrieve the text color of the CXTPComboBox control.
COLORREF | SetTextColor (COLORREF clrText)
Call this member function to set the text color for the CXTPComboBox control.
void | ResetTextColor ()
Call this member function to reset the text color for the CXTPComboBox control.
const CBrush & | GetBackgroundBrush () const
Call this member function to retrieve a reference to a CBrush object used to draw the combobox background.
- Public Member Functions inherited from CXTPControlTheme
CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme | GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlTheme
static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPComboBoxTheme
CXTPPaintManagerColor | m_clrBorderDisabled
RGB value used to draw the disabled border color.
CXTPPaintManagerColor | m_clrBorderHot
RGB value used to draw the hilighted border color.
CXTPPaintManagerColor | m_clrBorderNormal
RGB value used to draw the normal border color.
CXTPPaintManagerColor | m_clrButtonPressed
RGB value used to draw the pressed button color.
CXTPPaintManagerColor | m_clrButtonHot
RGB value used to draw the highlighted button color.
CXTPPaintManagerColor | m_clrButtonNormal
RGB value used to draw the normal button color.
CXTPPaintManagerColor | m_clrButtonArrowPressed
RGB value used to draw the pressed button arrow color.
CXTPPaintManagerColor | m_clrButtonArrowHot
RGB value used to draw the highlighted button arrow color.
CXTPPaintManagerColor | m_clrButtonArrowNormal
RGB value used to draw the normal button arrow color.
CXTPPaintManagerColor | m_clrBackground
RGB color value representing background color.
CXTPPaintManagerColor | m_clrBackDisabled
RGB color value representing disabled background color.
CXTPPaintManagerColor | m_clrBackHighlight
RGB color value representing highlight background color.
CXTPPaintManagerColor | m_clrText
RGB color value representing text color.
CXTPPaintManagerColor | m_clrTextDisabled
RGB color value representing disabled text color.
CXTPPaintManagerColor | m_clrTextHighlight
RGB color value representing highlight text color.
CXTPPaintManagerColorGradient | m_grcButton
RGB value used to draw the button gradient color.
CXTPPaintManagerColorGradient | m_grcButtonHilite
RGB value used to draw the button highlighted gradient color.
CXTPPaintManagerColorGradient | m_grcButtonPushed
RGB value used to draw the button pushed gradient color.
- Protected Member Functions inherited from CXTPComboBoxTheme
void | UpdateBackgroundBrush ()
Called by the framework to update the color value used by the combobox background brush.
- Protected Attributes inherited from CXTPComboBoxTheme
int | m_nThumbWidth
Size in pixels of the drop button width.
CXTPBrush | m_xtpBrushBackground
Brush used by the combobox to fill the background color.
CXTPWinThemeWrapper * | m_themeComboBox
Windows API wrapper used to draw windows theme.
- Protected Attributes inherited from CXTPControlTheme
XTPControlTheme | m_nTheme
Currently selected theme style index.

Detailed Description

Used as the paint manager for a combobox control to render a default appearance.

Member Function Documentation

◆ DrawComboBox()

virtual BOOL DrawComboBox | ( | CDC * | pDC,
 |  | CXTPComboBox * | pComboBox )
 virtual

Called by the framework to draw the combobox control.

Parameters
pDC | Pointer to a valid device context.
pComboBox | Pointer to the CXTPComboBox object to be drawn.
Returns
TRUE if successful; otherwise FALSE.

Reimplemented from CXTPComboBoxTheme.

◆ RefreshMetrics()

virtual void RefreshMetrics ( CXTPComboBox * pComboBox )
virtual

This member function is called by the theme manager to refresh the visual styles used by each component's theme.

Parameters
pComboBox Pointer to a CXTPComboBox object.

Reimplemented from CXTPComboBoxTheme.

The documentation for this class was generated from the following file:
  • XTPComboBoxThemeDefault.h


Toolkit Pro: CXTPComboBoxThemeNativeWindows10 Class Reference

Public Member Functions | List of all members
CXTPComboBoxThemeNativeWindows10 Class Reference

Used as the paint manager for a combobox control to render a Native Windows 10 appearance. More...

Inheritance diagram for CXTPComboBoxThemeNativeWindows10:
[legend]

Public Member Functions

CXTPComboBoxThemeNativeWindows10 ()
Default constructor.
virtual | ~CXTPComboBoxThemeNativeWindows10 ()
Destructor handles cleanup and deallocation.
virtual void | RefreshMetrics (CXTPComboBox *pComboBox)
This member function is called by the theme manager to refresh the visual styles used by each component's theme.
virtual void | DrawButton (CDC *pDC, CXTPComboBox *pComboBox, CRect rcBtn)
Called by the paint manager to draw the button portion of the combobox control.
- Public Member Functions inherited from CXTPComboBoxThemeOffice2013
CXTPComboBoxThemeOffice2013 ()
Default constructor.
virtual | ~CXTPComboBoxThemeOffice2013 ()
Destructor handles cleanup and deallocation.
virtual void | DrawButtonTriangle (CDC *pDC, CXTPComboBox *pComboBox, CRect rcBtn)
Called by the paint manager to draw the drop down arrow for the combobox drop button.
virtual void | DrawBackground (CDC *pDC, CXTPComboBox *pComboBox)
This member function is called to draw the combobox background.
- Public Member Functions inherited from CXTPComboBoxThemeVisualStudio
CXTPComboBoxThemeVisualStudio ()
Default constructor.
virtual | ~CXTPComboBoxThemeVisualStudio ()
Destructor handles cleanup and deallocation.
- Public Member Functions inherited from CXTPComboBoxThemeOffice2003
CXTPComboBoxThemeOffice2003 ()
Default constructor.
virtual | ~CXTPComboBoxThemeOffice2003 ()
Destructor handles cleanup and deallocation.
- Public Member Functions inherited from CXTPComboBoxTheme
CXTPComboBoxTheme ()
Default constructor.
virtual | ~CXTPComboBoxTheme ()
Destructor handles cleanup and deallocation.
virtual void | FillSolidRect (HDC hdc, int x, int y, int cx, int cy, HBRUSH hBrush)
Called by the combobox to fill a rectangle using the brush specifed by hBrush.
virtual void | DrawFrame (HDC hdc, LPRECT lprc, int nSize, HBRUSH hBrush)
Called by the combobox to draw a frame rectangle using the brush specified by hBrush.
virtual BOOL | DrawComboBox (CDC *pDC, CXTPComboBox *pComboBox)
Called by the framework to draw the combobox control.
COLORREF | GetBackColor () const
Call this member function to retrieve the background color of the CXTPComboBox control.
COLORREF | SetBackColor (COLORREF clrBackground)
Call this member function to set the background color for the CXTPComboBox control.
void | ResetBackColor ()
Call this member function to reset the background color for the CXTPComboBox control.
COLORREF | GetTextColor () const
Call this member function to retrieve the text color of the CXTPComboBox control.
COLORREF | SetTextColor (COLORREF clrText)
Call this member function to set the text color for the CXTPComboBox control.
void | ResetTextColor ()
Call this member function to reset the text color for the CXTPComboBox control.
const CBrush & | GetBackgroundBrush () const
Call this member function to retrieve a reference to a CBrush object used to draw the combobox background.
- Public Member Functions inherited from CXTPControlTheme
CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme | GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlTheme
static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPComboBoxTheme
CXTPPaintManagerColor | m_clrBorderDisabled
RGB value used to draw the disabled border color.
CXTPPaintManagerColor | m_clrBorderHot
RGB value used to draw the hilighted border color.
CXTPPaintManagerColor | m_clrBorderNormal
RGB value used to draw the normal border color.
CXTPPaintManagerColor | m_clrButtonPressed
RGB value used to draw the pressed button color.
CXTPPaintManagerColor | m_clrButtonHot
RGB value used to draw the highlighted button color.
CXTPPaintManagerColor | m_clrButtonNormal
RGB value used to draw the normal button color.
CXTPPaintManagerColor | m_clrButtonArrowPressed
RGB value used to draw the pressed button arrow color.
CXTPPaintManagerColor | m_clrButtonArrowHot
RGB value used to draw the highlighted button arrow color.
CXTPPaintManagerColor | m_clrButtonArrowNormal
RGB value used to draw the normal button arrow color.
CXTPPaintManagerColor | m_clrBackground
RGB color value representing background color.
CXTPPaintManagerColor | m_clrBackDisabled
RGB color value representing disabled background color.
CXTPPaintManagerColor | m_clrBackHighlight
RGB color value representing highlight background color.
CXTPPaintManagerColor | m_clrText
RGB color value representing text color.
CXTPPaintManagerColor | m_clrTextDisabled
RGB color value representing disabled text color.
CXTPPaintManagerColor | m_clrTextHighlight
RGB color value representing highlight text color.
CXTPPaintManagerColorGradient | m_grcButton
RGB value used to draw the button gradient color.
CXTPPaintManagerColorGradient | m_grcButtonHilite
RGB value used to draw the button highlighted gradient color.
CXTPPaintManagerColorGradient | m_grcButtonPushed
RGB value used to draw the button pushed gradient color.
- Protected Member Functions inherited from CXTPComboBoxTheme
void | UpdateBackgroundBrush ()
Called by the framework to update the color value used by the combobox background brush.
- Protected Attributes inherited from CXTPComboBoxThemeOffice2013
CXTPPaintManagerColor | m_clrButtonDisabled
Drop down button disabled color.
CXTPPaintManagerColor | m_clrButtonArrowDisabled
Drop down arrow disabled color.
- Protected Attributes inherited from CXTPComboBoxThemeOffice2003
- Protected Attributes inherited from CXTPComboBoxTheme
int | m_nThumbWidth
Size in pixels of the drop button width.
CXTPBrush | m_xtpBrushBackground
Brush used by the combobox to fill the background color.
CXTPWinThemeWrapper * | m_themeComboBox
Windows API wrapper used to draw windows theme.
- Protected Attributes inherited from CXTPControlTheme
XTPControlTheme | m_nTheme
Currently selected theme style index.

Detailed Description

Used as the paint manager for a combobox control to render a Native Windows 10 appearance.

Member Function Documentation

◆ DrawButton()

virtual void DrawButton | ( | CDC * | pDC,
 |  | CXTPComboBox * | pComboBox,
 |  | CRect | rcBtn )
 virtual

Called by the paint manager to draw the button portion of the combobox control.

Parameters
pDC | Pointer to the device context for the combobox.
pComboBox | Pointer to a CXTPComboBox object.
rcBtn | Size of the button to draw.

Reimplemented from CXTPComboBoxThemeOffice2013.

◆ RefreshMetrics()

virtual void RefreshMetrics ( CXTPComboBox * pComboBox )
virtual

This member function is called by the theme manager to refresh the visual styles used by each component's theme.

Parameters
pComboBox Pointer to a CXTPComboBox object.

Reimplemented from CXTPComboBoxThemeOffice2013.

The documentation for this class was generated from the following file:
  • XTPComboBoxThemeNativeWindows10.h


Toolkit Pro: CXTPComboBoxThemeNativeWindows11 Class Reference

Public Member Functions | List of all members
CXTPComboBoxThemeNativeWindows11 Class Reference

Used as the paint manager for a combobox control to render a Native Windows 10 appearance. More...

Inheritance diagram for CXTPComboBoxThemeNativeWindows11:
[legend]

Public Member Functions

CXTPComboBoxThemeNativeWindows11 ()
Default constructor.
virtual | ~CXTPComboBoxThemeNativeWindows11 ()
Destructor handles cleanup and deallocation.
virtual void | RefreshMetrics (CXTPComboBox *pComboBox)
This member function is called by the theme manager to refresh the visual styles used by each component's theme.
virtual void | DrawButton (CDC *pDC, CXTPComboBox *pComboBox, CRect rcBtn)
Called by the paint manager to draw the button portion of the combobox control.
- Public Member Functions inherited from CXTPComboBoxThemeOffice2013
CXTPComboBoxThemeOffice2013 ()
Default constructor.
virtual | ~CXTPComboBoxThemeOffice2013 ()
Destructor handles cleanup and deallocation.
virtual void | DrawButtonTriangle (CDC *pDC, CXTPComboBox *pComboBox, CRect rcBtn)
Called by the paint manager to draw the drop down arrow for the combobox drop button.
virtual void | DrawBackground (CDC *pDC, CXTPComboBox *pComboBox)
This member function is called to draw the combobox background.
- Public Member Functions inherited from CXTPComboBoxThemeVisualStudio
CXTPComboBoxThemeVisualStudio ()
Default constructor.
virtual | ~CXTPComboBoxThemeVisualStudio ()
Destructor handles cleanup and deallocation.
- Public Member Functions inherited from CXTPComboBoxThemeOffice2003
CXTPComboBoxThemeOffice2003 ()
Default constructor.
virtual | ~CXTPComboBoxThemeOffice2003 ()
Destructor handles cleanup and deallocation.
- Public Member Functions inherited from CXTPComboBoxTheme
CXTPComboBoxTheme ()
Default constructor.
virtual | ~CXTPComboBoxTheme ()
Destructor handles cleanup and deallocation.
virtual void | FillSolidRect (HDC hdc, int x, int y, int cx, int cy, HBRUSH hBrush)
Called by the combobox to fill a rectangle using the brush specifed by hBrush.
virtual void | DrawFrame (HDC hdc, LPRECT lprc, int nSize, HBRUSH hBrush)
Called by the combobox to draw a frame rectangle using the brush specified by hBrush.
virtual BOOL | DrawComboBox (CDC *pDC, CXTPComboBox *pComboBox)
Called by the framework to draw the combobox control.
COLORREF | GetBackColor () const
Call this member function to retrieve the background color of the CXTPComboBox control.
COLORREF | SetBackColor (COLORREF clrBackground)
Call this member function to set the background color for the CXTPComboBox control.
void | ResetBackColor ()
Call this member function to reset the background color for the CXTPComboBox control.
COLORREF | GetTextColor () const
Call this member function to retrieve the text color of the CXTPComboBox control.
COLORREF | SetTextColor (COLORREF clrText)
Call this member function to set the text color for the CXTPComboBox control.
void | ResetTextColor ()
Call this member function to reset the text color for the CXTPComboBox control.
const CBrush & | GetBackgroundBrush () const
Call this member function to retrieve a reference to a CBrush object used to draw the combobox background.
- Public Member Functions inherited from CXTPControlTheme
CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme | GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlTheme
static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPComboBoxTheme
CXTPPaintManagerColor | m_clrBorderDisabled
RGB value used to draw the disabled border color.
CXTPPaintManagerColor | m_clrBorderHot
RGB value used to draw the hilighted border color.
CXTPPaintManagerColor | m_clrBorderNormal
RGB value used to draw the normal border color.
CXTPPaintManagerColor | m_clrButtonPressed
RGB value used to draw the pressed button color.
CXTPPaintManagerColor | m_clrButtonHot
RGB value used to draw the highlighted button color.
CXTPPaintManagerColor | m_clrButtonNormal
RGB value used to draw the normal button color.
CXTPPaintManagerColor | m_clrButtonArrowPressed
RGB value used to draw the pressed button arrow color.
CXTPPaintManagerColor | m_clrButtonArrowHot
RGB value used to draw the highlighted button arrow color.
CXTPPaintManagerColor | m_clrButtonArrowNormal
RGB value used to draw the normal button arrow color.
CXTPPaintManagerColor | m_clrBackground
RGB color value representing background color.
CXTPPaintManagerColor | m_clrBackDisabled
RGB color value representing disabled background color.
CXTPPaintManagerColor | m_clrBackHighlight
RGB color value representing highlight background color.
CXTPPaintManagerColor | m_clrText
RGB color value representing text color.
CXTPPaintManagerColor | m_clrTextDisabled
RGB color value representing disabled text color.
CXTPPaintManagerColor | m_clrTextHighlight
RGB color value representing highlight text color.
CXTPPaintManagerColorGradient | m_grcButton
RGB value used to draw the button gradient color.
CXTPPaintManagerColorGradient | m_grcButtonHilite
RGB value used to draw the button highlighted gradient color.
CXTPPaintManagerColorGradient | m_grcButtonPushed
RGB value used to draw the button pushed gradient color.
- Protected Member Functions inherited from CXTPComboBoxTheme
void | UpdateBackgroundBrush ()
Called by the framework to update the color value used by the combobox background brush.
- Protected Attributes inherited from CXTPComboBoxThemeOffice2013
CXTPPaintManagerColor | m_clrButtonDisabled
Drop down button disabled color.
CXTPPaintManagerColor | m_clrButtonArrowDisabled
Drop down arrow disabled color.
- Protected Attributes inherited from CXTPComboBoxThemeOffice2003
- Protected Attributes inherited from CXTPComboBoxTheme
int | m_nThumbWidth
Size in pixels of the drop button width.
CXTPBrush | m_xtpBrushBackground
Brush used by the combobox to fill the background color.
CXTPWinThemeWrapper * | m_themeComboBox
Windows API wrapper used to draw windows theme.
- Protected Attributes inherited from CXTPControlTheme
XTPControlTheme | m_nTheme
Currently selected theme style index.

Detailed Description

Used as the paint manager for a combobox control to render a Native Windows 10 appearance.

Member Function Documentation

◆ DrawButton()

virtual void DrawButton | ( | CDC * | pDC,
 |  | CXTPComboBox * | pComboBox,
 |  | CRect | rcBtn )
 virtual

Called by the paint manager to draw the button portion of the combobox control.

Parameters
pDC | Pointer to the device context for the combobox.
pComboBox | Pointer to a CXTPComboBox object.
rcBtn | Size of the button to draw.

Reimplemented from CXTPComboBoxThemeOffice2013.

◆ RefreshMetrics()

virtual void RefreshMetrics ( CXTPComboBox * pComboBox )
virtual

This member function is called by the theme manager to refresh the visual styles used by each component's theme.

Parameters
pComboBox Pointer to a CXTPComboBox object.

Reimplemented from CXTPComboBoxThemeOffice2013.

The documentation for this class was generated from the following file:
  • XTPComboBoxThemeNativeWindows11.h


Toolkit Pro: CXTPComboBoxThemeOffice2000 Class Reference

Public Member Functions | List of all members
CXTPComboBoxThemeOffice2000 Class Reference

Used as the paint manager for a combobox control to render an Office 2000 appearance. More...

Inheritance diagram for CXTPComboBoxThemeOffice2000:
[legend]

Public Member Functions

CXTPComboBoxThemeOffice2000 ()
Default constructor.
virtual | ~CXTPComboBoxThemeOffice2000 ()
Destructor handles cleanup and deallocation.
virtual void | DrawBackground (CDC *pDC, CXTPComboBox *pComboBox)
This member function is called to draw the combobox background.
virtual void | DrawButton (CDC *pDC, CXTPComboBox *pComboBox, CRect rcBtn)
Called by the paint manager to draw the button portion of the combobox control.
virtual void | RefreshMetrics (CXTPComboBox *pComboBox)
This member function is called by the theme manager to refresh the visual styles used by each component's theme.
- Public Member Functions inherited from CXTPComboBoxTheme
CXTPComboBoxTheme ()
Default constructor.
virtual | ~CXTPComboBoxTheme ()
Destructor handles cleanup and deallocation.
virtual void | FillSolidRect (HDC hdc, int x, int y, int cx, int cy, HBRUSH hBrush)
Called by the combobox to fill a rectangle using the brush specifed by hBrush.
virtual void | DrawFrame (HDC hdc, LPRECT lprc, int nSize, HBRUSH hBrush)
Called by the combobox to draw a frame rectangle using the brush specified by hBrush.
virtual BOOL | DrawComboBox (CDC *pDC, CXTPComboBox *pComboBox)
Called by the framework to draw the combobox control.
virtual void | DrawButtonTriangle (CDC *pDC, CXTPComboBox *pComboBox, CRect rcBtn)
Called by the paint manager to draw the drop down arrow for the combobox drop button.
COLORREF | GetBackColor () const
Call this member function to retrieve the background color of the CXTPComboBox control.
COLORREF | SetBackColor (COLORREF clrBackground)
Call this member function to set the background color for the CXTPComboBox control.
void | ResetBackColor ()
Call this member function to reset the background color for the CXTPComboBox control.
COLORREF | GetTextColor () const
Call this member function to retrieve the text color of the CXTPComboBox control.
COLORREF | SetTextColor (COLORREF clrText)
Call this member function to set the text color for the CXTPComboBox control.
void | ResetTextColor ()
Call this member function to reset the text color for the CXTPComboBox control.
const CBrush & | GetBackgroundBrush () const
Call this member function to retrieve a reference to a CBrush object used to draw the combobox background.
- Public Member Functions inherited from CXTPControlTheme
CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme | GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlTheme
static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPComboBoxTheme
CXTPPaintManagerColor | m_clrBorderDisabled
RGB value used to draw the disabled border color.
CXTPPaintManagerColor | m_clrBorderHot
RGB value used to draw the hilighted border color.
CXTPPaintManagerColor | m_clrBorderNormal
RGB value used to draw the normal border color.
CXTPPaintManagerColor | m_clrButtonPressed
RGB value used to draw the pressed button color.
CXTPPaintManagerColor | m_clrButtonHot
RGB value used to draw the highlighted button color.
CXTPPaintManagerColor | m_clrButtonNormal
RGB value used to draw the normal button color.
CXTPPaintManagerColor | m_clrButtonArrowPressed
RGB value used to draw the pressed button arrow color.
CXTPPaintManagerColor | m_clrButtonArrowHot
RGB value used to draw the highlighted button arrow color.
CXTPPaintManagerColor | m_clrButtonArrowNormal
RGB value used to draw the normal button arrow color.
CXTPPaintManagerColor | m_clrBackground
RGB color value representing background color.
CXTPPaintManagerColor | m_clrBackDisabled
RGB color value representing disabled background color.
CXTPPaintManagerColor | m_clrBackHighlight
RGB color value representing highlight background color.
CXTPPaintManagerColor | m_clrText
RGB color value representing text color.
CXTPPaintManagerColor | m_clrTextDisabled
RGB color value representing disabled text color.
CXTPPaintManagerColor | m_clrTextHighlight
RGB color value representing highlight text color.
CXTPPaintManagerColorGradient | m_grcButton
RGB value used to draw the button gradient color.
CXTPPaintManagerColorGradient | m_grcButtonHilite
RGB value used to draw the button highlighted gradient color.
CXTPPaintManagerColorGradient | m_grcButtonPushed
RGB value used to draw the button pushed gradient color.
- Protected Member Functions inherited from CXTPComboBoxTheme
void | UpdateBackgroundBrush ()
Called by the framework to update the color value used by the combobox background brush.
- Protected Attributes inherited from CXTPComboBoxTheme
int | m_nThumbWidth
Size in pixels of the drop button width.
CXTPBrush | m_xtpBrushBackground
Brush used by the combobox to fill the background color.
CXTPWinThemeWrapper * | m_themeComboBox
Windows API wrapper used to draw windows theme.
- Protected Attributes inherited from CXTPControlTheme
XTPControlTheme | m_nTheme
Currently selected theme style index.

Detailed Description

Used as the paint manager for a combobox control to render an Office 2000 appearance.

Member Function Documentation

◆ DrawBackground()

virtual void DrawBackground | ( | CDC * | pDC,
 |  | CXTPComboBox * | pComboBox )
 virtual

This member function is called to draw the combobox background.

Parameters
pDC | Pointer to a valid device context.
pComboBox | Pointer to the combobox to be drawn.

Reimplemented from CXTPComboBoxTheme.

◆ DrawButton()

virtual void DrawButton | ( | CDC * | pDC,
 |  | CXTPComboBox * | pComboBox,
 |  | CRect | rcBtn )
 virtual

Called by the paint manager to draw the button portion of the combobox control.

Parameters
pDC | Pointer to the device context for the combobox.
pComboBox | Pointer to a CXTPComboBox object.
rcBtn | Size of the button to draw.

Reimplemented from CXTPComboBoxTheme.

◆ RefreshMetrics()

virtual void RefreshMetrics ( CXTPComboBox * pComboBox )
virtual

This member function is called by the theme manager to refresh the visual styles used by each component's theme.

Parameters
pComboBox Pointer to a CXTPComboBox object.

Reimplemented from CXTPComboBoxTheme.

The documentation for this class was generated from the following file:
  • XTPComboBoxThemeOffice2000.h


Toolkit Pro: CXTPComboBoxThemeOffice2003 Class Reference

Public Member Functions | List of all members
CXTPComboBoxThemeOffice2003 Class Reference

Used as the paint manager for a combobox control to render an Office 2003 appearance. More...

Inheritance diagram for CXTPComboBoxThemeOffice2003:
[legend]

Public Member Functions

CXTPComboBoxThemeOffice2003 ()
Default constructor.
virtual | ~CXTPComboBoxThemeOffice2003 ()
Destructor handles cleanup and deallocation.
virtual void | DrawBackground (CDC *pDC, CXTPComboBox *pComboBox)
This member function is called to draw the combobox background.
virtual void | DrawButton (CDC *pDC, CXTPComboBox *pComboBox, CRect rcBtn)
Called by the paint manager to draw the button portion of the combobox control.
virtual void | RefreshMetrics (CXTPComboBox *pComboBox)
This member function is called by the theme manager to refresh the visual styles used by each component's theme.
- Public Member Functions inherited from CXTPComboBoxTheme
CXTPComboBoxTheme ()
Default constructor.
virtual | ~CXTPComboBoxTheme ()
Destructor handles cleanup and deallocation.
virtual void | FillSolidRect (HDC hdc, int x, int y, int cx, int cy, HBRUSH hBrush)
Called by the combobox to fill a rectangle using the brush specifed by hBrush.
virtual void | DrawFrame (HDC hdc, LPRECT lprc, int nSize, HBRUSH hBrush)
Called by the combobox to draw a frame rectangle using the brush specified by hBrush.
virtual BOOL | DrawComboBox (CDC *pDC, CXTPComboBox *pComboBox)
Called by the framework to draw the combobox control.
virtual void | DrawButtonTriangle (CDC *pDC, CXTPComboBox *pComboBox, CRect rcBtn)
Called by the paint manager to draw the drop down arrow for the combobox drop button.
COLORREF | GetBackColor () const
Call this member function to retrieve the background color of the CXTPComboBox control.
COLORREF | SetBackColor (COLORREF clrBackground)
Call this member function to set the background color for the CXTPComboBox control.
void | ResetBackColor ()
Call this member function to reset the background color for the CXTPComboBox control.
COLORREF | GetTextColor () const
Call this member function to retrieve the text color of the CXTPComboBox control.
COLORREF | SetTextColor (COLORREF clrText)
Call this member function to set the text color for the CXTPComboBox control.
void | ResetTextColor ()
Call this member function to reset the text color for the CXTPComboBox control.
const CBrush & | GetBackgroundBrush () const
Call this member function to retrieve a reference to a CBrush object used to draw the combobox background.
- Public Member Functions inherited from CXTPControlTheme
CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme | GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlTheme
static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPComboBoxTheme
CXTPPaintManagerColor | m_clrBorderDisabled
RGB value used to draw the disabled border color.
CXTPPaintManagerColor | m_clrBorderHot
RGB value used to draw the hilighted border color.
CXTPPaintManagerColor | m_clrBorderNormal
RGB value used to draw the normal border color.
CXTPPaintManagerColor | m_clrButtonPressed
RGB value used to draw the pressed button color.
CXTPPaintManagerColor | m_clrButtonHot
RGB value used to draw the highlighted button color.
CXTPPaintManagerColor | m_clrButtonNormal
RGB value used to draw the normal button color.
CXTPPaintManagerColor | m_clrButtonArrowPressed
RGB value used to draw the pressed button arrow color.
CXTPPaintManagerColor | m_clrButtonArrowHot
RGB value used to draw the highlighted button arrow color.
CXTPPaintManagerColor | m_clrButtonArrowNormal
RGB value used to draw the normal button arrow color.
CXTPPaintManagerColor | m_clrBackground
RGB color value representing background color.
CXTPPaintManagerColor | m_clrBackDisabled
RGB color value representing disabled background color.
CXTPPaintManagerColor | m_clrBackHighlight
RGB color value representing highlight background color.
CXTPPaintManagerColor | m_clrText
RGB color value representing text color.
CXTPPaintManagerColor | m_clrTextDisabled
RGB color value representing disabled text color.
CXTPPaintManagerColor | m_clrTextHighlight
RGB color value representing highlight text color.
CXTPPaintManagerColorGradient | m_grcButton
RGB value used to draw the button gradient color.
CXTPPaintManagerColorGradient | m_grcButtonHilite
RGB value used to draw the button highlighted gradient color.
CXTPPaintManagerColorGradient | m_grcButtonPushed
RGB value used to draw the button pushed gradient color.
- Protected Member Functions inherited from CXTPComboBoxTheme
void | UpdateBackgroundBrush ()
Called by the framework to update the color value used by the combobox background brush.
- Protected Attributes inherited from CXTPComboBoxTheme
int | m_nThumbWidth
Size in pixels of the drop button width.
CXTPBrush | m_xtpBrushBackground
Brush used by the combobox to fill the background color.
CXTPWinThemeWrapper * | m_themeComboBox
Windows API wrapper used to draw windows theme.
- Protected Attributes inherited from CXTPControlTheme
XTPControlTheme | m_nTheme
Currently selected theme style index.

Detailed Description

Used as the paint manager for a combobox control to render an Office 2003 appearance.

Member Function Documentation

◆ DrawBackground()

virtual void DrawBackground | ( | CDC * | pDC,
 |  | CXTPComboBox * | pComboBox )
 virtual

This member function is called to draw the combobox background.

Parameters
pDC | Pointer to a valid device context.
pComboBox | Pointer to the combobox to be drawn.

Reimplemented from CXTPComboBoxTheme.

Reimplemented in CXTPComboBoxThemeOffice2013.

◆ DrawButton()

virtual void DrawButton | ( | CDC * | pDC,
 |  | CXTPComboBox * | pComboBox,
 |  | CRect | rcBtn )
 virtual

Called by the paint manager to draw the button portion of the combobox control.

Parameters
pDC | Pointer to the device context for the combobox.
pComboBox | Pointer to a CXTPComboBox object.
rcBtn | Size of the button to draw.

Reimplemented from CXTPComboBoxTheme.

Reimplemented in CXTPComboBoxThemeNativeWindows10, CXTPComboBoxThemeNativeWindows11, CXTPComboBoxThemeOffice2013, CXTPComboBoxThemeVisualStudio2012, CXTPComboBoxThemeVisualStudio2015, CXTPComboBoxThemeVisualStudio2017, CXTPComboBoxThemeVisualStudio2019, and CXTPComboBoxThemeVisualStudio2022.

◆ RefreshMetrics()

virtual void RefreshMetrics ( CXTPComboBox * pComboBox )
virtual

This member function is called by the theme manager to refresh the visual styles used by each component's theme.

Parameters
pComboBox Pointer to a CXTPComboBox object.

Reimplemented from CXTPComboBoxTheme.

Reimplemented in CXTPComboBoxThemeNativeWindows10, CXTPComboBoxThemeNativeWindows11, CXTPComboBoxThemeOffice2013, CXTPComboBoxThemeVisualStudio2010, CXTPComboBoxThemeVisualStudio2012, CXTPComboBoxThemeVisualStudio2015, CXTPComboBoxThemeVisualStudio2017, CXTPComboBoxThemeVisualStudio2019, CXTPComboBoxThemeVisualStudio2022, and CXTPComboBoxThemeVisualStudio.

The documentation for this class was generated from the following file:
  • XTPComboBoxThemeOffice2003.h


Toolkit Pro: CXTPComboBoxThemeOffice2013 Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPComboBoxThemeOffice2013 Class Reference

Used as the paint manager for a combobox control to render an Office 2013 appearance. More...

Inheritance diagram for CXTPComboBoxThemeOffice2013:
[legend]

Public Member Functions

CXTPComboBoxThemeOffice2013 ()
Default constructor.
virtual | ~CXTPComboBoxThemeOffice2013 ()
Destructor handles cleanup and deallocation.
virtual void | RefreshMetrics (CXTPComboBox *pComboBox)
This member function is called by the theme manager to refresh the visual styles used by each component's theme.
virtual void | DrawButton (CDC *pDC, CXTPComboBox *pComboBox, CRect rcBtn)
Called by the paint manager to draw the button portion of the combobox control.
virtual void | DrawButtonTriangle (CDC *pDC, CXTPComboBox *pComboBox, CRect rcBtn)
Called by the paint manager to draw the drop down arrow for the combobox drop button.
virtual void | DrawBackground (CDC *pDC, CXTPComboBox *pComboBox)
This member function is called to draw the combobox background.
- Public Member Functions inherited from CXTPComboBoxThemeVisualStudio
CXTPComboBoxThemeVisualStudio ()
Default constructor.
virtual | ~CXTPComboBoxThemeVisualStudio ()
Destructor handles cleanup and deallocation.
- Public Member Functions inherited from CXTPComboBoxThemeOffice2003
CXTPComboBoxThemeOffice2003 ()
Default constructor.
virtual | ~CXTPComboBoxThemeOffice2003 ()
Destructor handles cleanup and deallocation.
- Public Member Functions inherited from CXTPComboBoxTheme
CXTPComboBoxTheme ()
Default constructor.
virtual | ~CXTPComboBoxTheme ()
Destructor handles cleanup and deallocation.
virtual void | FillSolidRect (HDC hdc, int x, int y, int cx, int cy, HBRUSH hBrush)
Called by the combobox to fill a rectangle using the brush specifed by hBrush.
virtual void | DrawFrame (HDC hdc, LPRECT lprc, int nSize, HBRUSH hBrush)
Called by the combobox to draw a frame rectangle using the brush specified by hBrush.
virtual BOOL | DrawComboBox (CDC *pDC, CXTPComboBox *pComboBox)
Called by the framework to draw the combobox control.
COLORREF | GetBackColor () const
Call this member function to retrieve the background color of the CXTPComboBox control.
COLORREF | SetBackColor (COLORREF clrBackground)
Call this member function to set the background color for the CXTPComboBox control.
void | ResetBackColor ()
Call this member function to reset the background color for the CXTPComboBox control.
COLORREF | GetTextColor () const
Call this member function to retrieve the text color of the CXTPComboBox control.
COLORREF | SetTextColor (COLORREF clrText)
Call this member function to set the text color for the CXTPComboBox control.
void | ResetTextColor ()
Call this member function to reset the text color for the CXTPComboBox control.
const CBrush & | GetBackgroundBrush () const
Call this member function to retrieve a reference to a CBrush object used to draw the combobox background.
- Public Member Functions inherited from CXTPControlTheme
CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme | GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Attributes

CXTPPaintManagerColor | m_clrButtonDisabled
Drop down button disabled color.
CXTPPaintManagerColor | m_clrButtonArrowDisabled
Drop down arrow disabled color.
- Protected Attributes inherited from CXTPComboBoxThemeOffice2003
- Protected Attributes inherited from CXTPComboBoxTheme
int | m_nThumbWidth
Size in pixels of the drop button width.
CXTPBrush | m_xtpBrushBackground
Brush used by the combobox to fill the background color.
CXTPWinThemeWrapper * | m_themeComboBox
Windows API wrapper used to draw windows theme.
- Protected Attributes inherited from CXTPControlTheme
XTPControlTheme | m_nTheme
Currently selected theme style index.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlTheme
static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPComboBoxTheme
CXTPPaintManagerColor | m_clrBorderDisabled
RGB value used to draw the disabled border color.
CXTPPaintManagerColor | m_clrBorderHot
RGB value used to draw the hilighted border color.
CXTPPaintManagerColor | m_clrBorderNormal
RGB value used to draw the normal border color.
CXTPPaintManagerColor | m_clrButtonPressed
RGB value used to draw the pressed button color.
CXTPPaintManagerColor | m_clrButtonHot
RGB value used to draw the highlighted button color.
CXTPPaintManagerColor | m_clrButtonNormal
RGB value used to draw the normal button color.
CXTPPaintManagerColor | m_clrButtonArrowPressed
RGB value used to draw the pressed button arrow color.
CXTPPaintManagerColor | m_clrButtonArrowHot
RGB value used to draw the highlighted button arrow color.
CXTPPaintManagerColor | m_clrButtonArrowNormal
RGB value used to draw the normal button arrow color.
CXTPPaintManagerColor | m_clrBackground
RGB color value representing background color.
CXTPPaintManagerColor | m_clrBackDisabled
RGB color value representing disabled background color.
CXTPPaintManagerColor | m_clrBackHighlight
RGB color value representing highlight background color.
CXTPPaintManagerColor | m_clrText
RGB color value representing text color.
CXTPPaintManagerColor | m_clrTextDisabled
RGB color value representing disabled text color.
CXTPPaintManagerColor | m_clrTextHighlight
RGB color value representing highlight text color.
CXTPPaintManagerColorGradient | m_grcButton
RGB value used to draw the button gradient color.
CXTPPaintManagerColorGradient | m_grcButtonHilite
RGB value used to draw the button highlighted gradient color.
CXTPPaintManagerColorGradient | m_grcButtonPushed
RGB value used to draw the button pushed gradient color.
- Protected Member Functions inherited from CXTPComboBoxTheme
void | UpdateBackgroundBrush ()
Called by the framework to update the color value used by the combobox background brush.

Detailed Description

Used as the paint manager for a combobox control to render an Office 2013 appearance.

Member Function Documentation

◆ DrawBackground()

virtual void DrawBackground | ( | CDC * | pDC,
 |  | CXTPComboBox * | pComboBox )
 virtual

This member function is called to draw the combobox background.

Parameters
pDC | Pointer to a valid device context.
pComboBox | Pointer to the combobox to be drawn.

Reimplemented from CXTPComboBoxThemeOffice2003.

◆ DrawButton()

virtual void DrawButton | ( | CDC * | pDC,
 |  | CXTPComboBox * | pComboBox,
 |  | CRect | rcBtn )
 virtual

Called by the paint manager to draw the button portion of the combobox control.

Parameters
pDC | Pointer to the device context for the combobox.
pComboBox | Pointer to a CXTPComboBox object.
rcBtn | Size of the button to draw.

Reimplemented from CXTPComboBoxThemeOffice2003.

Reimplemented in CXTPComboBoxThemeNativeWindows10, CXTPComboBoxThemeNativeWindows11, CXTPComboBoxThemeVisualStudio2015, CXTPComboBoxThemeVisualStudio2017, CXTPComboBoxThemeVisualStudio2019, and CXTPComboBoxThemeVisualStudio2022.

◆ DrawButtonTriangle()

virtual void DrawButtonTriangle | ( | CDC * | pDC,
 |  | CXTPComboBox * | pComboBox,
 |  | CRect | rcBtn )
 virtual

Called by the paint manager to draw the drop down arrow for the combobox drop button.

Parameters
pDC | Pointer to the device context for the combobox.
pComboBox | Pointer to a CXTPComboBox object.
rcBtn | Size of the button to draw.

Reimplemented from CXTPComboBoxTheme.

◆ RefreshMetrics()

virtual void RefreshMetrics ( CXTPComboBox * pComboBox )
virtual

This member function is called by the theme manager to refresh the visual styles used by each component's theme.

Parameters
pComboBox Pointer to a CXTPComboBox object.

Reimplemented from CXTPComboBoxThemeVisualStudio.

Reimplemented in CXTPComboBoxThemeNativeWindows10, CXTPComboBoxThemeNativeWindows11, CXTPComboBoxThemeVisualStudio2015, CXTPComboBoxThemeVisualStudio2017, CXTPComboBoxThemeVisualStudio2019, and CXTPComboBoxThemeVisualStudio2022.

The documentation for this class was generated from the following file:
  • XTPComboBoxThemeOffice2013.h


Toolkit Pro: CXTPComboBoxThemeOfficeXPFlat Class Reference

Public Member Functions | Public Attributes | List of all members
CXTPComboBoxThemeOfficeXPFlat Class Reference

Used as the paint manager for a combobox control to render an Office XP Flat appearance. More...

Inheritance diagram for CXTPComboBoxThemeOfficeXPFlat:
[legend]

Public Member Functions

CXTPComboBoxThemeOfficeXPFlat (XTPControlTheme nTheme)
Default constructor.
virtual | ~CXTPComboBoxThemeOfficeXPFlat ()
Destructor handles cleanup and deallocation.
virtual void | DrawBackground (CDC *pDC, CXTPComboBox *pComboBox)
Called by the paint manager to draw the background for the combobox control.
virtual void | DrawButton (CDC *pDC, CXTPComboBox *pComboBox, CRect rcBtn)
Called by the paint manager to draw the button portion of the combobox control.
virtual void | RefreshMetrics (CXTPComboBox *pComboBox)
This member function is called by the theme manager to refresh the visual styles used by each component's theme.
- Public Member Functions inherited from CXTPComboBoxTheme
CXTPComboBoxTheme ()
Default constructor.
virtual | ~CXTPComboBoxTheme ()
Destructor handles cleanup and deallocation.
virtual void | FillSolidRect (HDC hdc, int x, int y, int cx, int cy, HBRUSH hBrush)
Called by the combobox to fill a rectangle using the brush specifed by hBrush.
virtual void | DrawFrame (HDC hdc, LPRECT lprc, int nSize, HBRUSH hBrush)
Called by the combobox to draw a frame rectangle using the brush specified by hBrush.
virtual BOOL | DrawComboBox (CDC *pDC, CXTPComboBox *pComboBox)
Called by the framework to draw the combobox control.
virtual void | DrawButtonTriangle (CDC *pDC, CXTPComboBox *pComboBox, CRect rcBtn)
Called by the paint manager to draw the drop down arrow for the combobox drop button.
COLORREF | GetBackColor () const
Call this member function to retrieve the background color of the CXTPComboBox control.
COLORREF | SetBackColor (COLORREF clrBackground)
Call this member function to set the background color for the CXTPComboBox control.
void | ResetBackColor ()
Call this member function to reset the background color for the CXTPComboBox control.
COLORREF | GetTextColor () const
Call this member function to retrieve the text color of the CXTPComboBox control.
COLORREF | SetTextColor (COLORREF clrText)
Call this member function to set the text color for the CXTPComboBox control.
void | ResetTextColor ()
Call this member function to reset the text color for the CXTPComboBox control.
const CBrush & | GetBackgroundBrush () const
Call this member function to retrieve a reference to a CBrush object used to draw the combobox background.
- Public Member Functions inherited from CXTPControlTheme
CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme | GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Public Attributes

XTPControlTheme | m_nTheme
Office XP, Flat or Ultra Flat.
- Public Attributes inherited from CXTPComboBoxTheme
CXTPPaintManagerColor | m_clrBorderDisabled
RGB value used to draw the disabled border color.
CXTPPaintManagerColor | m_clrBorderHot
RGB value used to draw the hilighted border color.
CXTPPaintManagerColor | m_clrBorderNormal
RGB value used to draw the normal border color.
CXTPPaintManagerColor | m_clrButtonPressed
RGB value used to draw the pressed button color.
CXTPPaintManagerColor | m_clrButtonHot
RGB value used to draw the highlighted button color.
CXTPPaintManagerColor | m_clrButtonNormal
RGB value used to draw the normal button color.
CXTPPaintManagerColor | m_clrButtonArrowPressed
RGB value used to draw the pressed button arrow color.
CXTPPaintManagerColor | m_clrButtonArrowHot
RGB value used to draw the highlighted button arrow color.
CXTPPaintManagerColor | m_clrButtonArrowNormal
RGB value used to draw the normal button arrow color.
CXTPPaintManagerColor | m_clrBackground
RGB color value representing background color.
CXTPPaintManagerColor | m_clrBackDisabled
RGB color value representing disabled background color.
CXTPPaintManagerColor | m_clrBackHighlight
RGB color value representing highlight background color.
CXTPPaintManagerColor | m_clrText
RGB color value representing text color.
CXTPPaintManagerColor | m_clrTextDisabled
RGB color value representing disabled text color.
CXTPPaintManagerColor | m_clrTextHighlight
RGB color value representing highlight text color.
CXTPPaintManagerColorGradient | m_grcButton
RGB value used to draw the button gradient color.
CXTPPaintManagerColorGradient | m_grcButtonHilite
RGB value used to draw the button highlighted gradient color.
CXTPPaintManagerColorGradient | m_grcButtonPushed
RGB value used to draw the button pushed gradient color.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlTheme
static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Member Functions inherited from CXTPComboBoxTheme
void | UpdateBackgroundBrush ()
Called by the framework to update the color value used by the combobox background brush.
- Protected Attributes inherited from CXTPComboBoxTheme
int | m_nThumbWidth
Size in pixels of the drop button width.
CXTPBrush | m_xtpBrushBackground
Brush used by the combobox to fill the background color.
CXTPWinThemeWrapper * | m_themeComboBox
Windows API wrapper used to draw windows theme.
- Protected Attributes inherited from CXTPControlTheme
XTPControlTheme | m_nTheme
Currently selected theme style index.

Detailed Description

Used as the paint manager for a combobox control to render an Office XP Flat appearance.

Constructor & Destructor Documentation

◆ CXTPComboBoxThemeOfficeXPFlat()

CXTPComboBoxThemeOfficeXPFlat ( XTPControlTheme nTheme )

Default constructor.

Parameters
nTheme New visual theme. Can be any of the values listed

Member Function Documentation

◆ DrawBackground()

virtual void DrawBackground | ( | CDC * | pDC,
 |  | CXTPComboBox * | pComboBox )
 virtual

Called by the paint manager to draw the background for the combobox control.

Parameters
pDC | Pointer to the device context for the combobox.
pComboBox | Pointer to a CXTPComboBox object.

Reimplemented from CXTPComboBoxTheme.

◆ DrawButton()

virtual void DrawButton | ( | CDC * | pDC,
 |  | CXTPComboBox * | pComboBox,
 |  | CRect | rcBtn )
 virtual

Called by the paint manager to draw the button portion of the combobox control.

Parameters
pDC | Pointer to the device context for the combobox.
pComboBox | Pointer to a CXTPComboBox object.
rcBtn | Size of the button to draw.

Reimplemented from CXTPComboBoxTheme.

◆ RefreshMetrics()

virtual void RefreshMetrics ( CXTPComboBox * pComboBox )
virtual

This member function is called by the theme manager to refresh the visual styles used by each component's theme.

Parameters
pComboBox Pointer to a CXTPComboBox object.

Reimplemented from CXTPComboBoxTheme.

The documentation for this class was generated from the following file:
  • XTPComboBoxThemeOfficeXPFlat.h


Toolkit Pro: CXTPComboBoxThemeResource Class Reference

Public Member Functions | List of all members
CXTPComboBoxThemeResource Class Reference

Used as the paint manager for a combobox control to render a resource appearance. More...

Inheritance diagram for CXTPComboBoxThemeResource:
[legend]

Public Member Functions

CXTPComboBoxThemeResource ()
Default constructor.
virtual | ~CXTPComboBoxThemeResource ()
Destructor handles cleanup and deallocation.
virtual BOOL | DrawComboBox (CDC *pDC, CXTPComboBox *pComboBox)
Called by the framework to draw the combobox control.
virtual void | RefreshMetrics (CXTPComboBox *pComboBox)
This member function is called by the theme manager to refresh the visual styles used by each component's theme.
- Public Member Functions inherited from CXTPComboBoxTheme
CXTPComboBoxTheme ()
Default constructor.
virtual | ~CXTPComboBoxTheme ()
Destructor handles cleanup and deallocation.
virtual void | FillSolidRect (HDC hdc, int x, int y, int cx, int cy, HBRUSH hBrush)
Called by the combobox to fill a rectangle using the brush specifed by hBrush.
virtual void | DrawFrame (HDC hdc, LPRECT lprc, int nSize, HBRUSH hBrush)
Called by the combobox to draw a frame rectangle using the brush specified by hBrush.
virtual void | DrawBackground (CDC *pDC, CXTPComboBox *pComboBox)
This member function is called to draw the combobox background.
virtual void | DrawButton (CDC *pDC, CXTPComboBox *pComboBox, CRect rcBtn)
Called by the paint manager to draw the button portion of the combobox control.
virtual void | DrawButtonTriangle (CDC *pDC, CXTPComboBox *pComboBox, CRect rcBtn)
Called by the paint manager to draw the drop down arrow for the combobox drop button.
COLORREF | GetBackColor () const
Call this member function to retrieve the background color of the CXTPComboBox control.
COLORREF | SetBackColor (COLORREF clrBackground)
Call this member function to set the background color for the CXTPComboBox control.
void | ResetBackColor ()
Call this member function to reset the background color for the CXTPComboBox control.
COLORREF | GetTextColor () const
Call this member function to retrieve the text color of the CXTPComboBox control.
COLORREF | SetTextColor (COLORREF clrText)
Call this member function to set the text color for the CXTPComboBox control.
void | ResetTextColor ()
Call this member function to reset the text color for the CXTPComboBox control.
const CBrush & | GetBackgroundBrush () const
Call this member function to retrieve a reference to a CBrush object used to draw the combobox background.
- Public Member Functions inherited from CXTPControlTheme
CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme | GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlTheme
static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPComboBoxTheme
CXTPPaintManagerColor | m_clrBorderDisabled
RGB value used to draw the disabled border color.
CXTPPaintManagerColor | m_clrBorderHot
RGB value used to draw the hilighted border color.
CXTPPaintManagerColor | m_clrBorderNormal
RGB value used to draw the normal border color.
CXTPPaintManagerColor | m_clrButtonPressed
RGB value used to draw the pressed button color.
CXTPPaintManagerColor | m_clrButtonHot
RGB value used to draw the highlighted button color.
CXTPPaintManagerColor | m_clrButtonNormal
RGB value used to draw the normal button color.
CXTPPaintManagerColor | m_clrButtonArrowPressed
RGB value used to draw the pressed button arrow color.
CXTPPaintManagerColor | m_clrButtonArrowHot
RGB value used to draw the highlighted button arrow color.
CXTPPaintManagerColor | m_clrButtonArrowNormal
RGB value used to draw the normal button arrow color.
CXTPPaintManagerColor | m_clrBackground
RGB color value representing background color.
CXTPPaintManagerColor | m_clrBackDisabled
RGB color value representing disabled background color.
CXTPPaintManagerColor | m_clrBackHighlight
RGB color value representing highlight background color.
CXTPPaintManagerColor | m_clrText
RGB color value representing text color.
CXTPPaintManagerColor | m_clrTextDisabled
RGB color value representing disabled text color.
CXTPPaintManagerColor | m_clrTextHighlight
RGB color value representing highlight text color.
CXTPPaintManagerColorGradient | m_grcButton
RGB value used to draw the button gradient color.
CXTPPaintManagerColorGradient | m_grcButtonHilite
RGB value used to draw the button highlighted gradient color.
CXTPPaintManagerColorGradient | m_grcButtonPushed
RGB value used to draw the button pushed gradient color.
- Protected Member Functions inherited from CXTPComboBoxTheme
void | UpdateBackgroundBrush ()
Called by the framework to update the color value used by the combobox background brush.
- Protected Attributes inherited from CXTPComboBoxTheme
int | m_nThumbWidth
Size in pixels of the drop button width.
CXTPBrush | m_xtpBrushBackground
Brush used by the combobox to fill the background color.
CXTPWinThemeWrapper * | m_themeComboBox
Windows API wrapper used to draw windows theme.
- Protected Attributes inherited from CXTPControlTheme
XTPControlTheme | m_nTheme
Currently selected theme style index.

Detailed Description

Used as the paint manager for a combobox control to render a resource appearance.

Member Function Documentation

◆ DrawComboBox()

virtual BOOL DrawComboBox | ( | CDC * | pDC,
 |  | CXTPComboBox * | pComboBox )
 virtual

Called by the framework to draw the combobox control.

Parameters
pDC | Pointer to a valid device context.
pComboBox | Pointer to the CXTPComboBox object to be drawn.
Returns
TRUE if successful; otherwise FALSE.

Reimplemented from CXTPComboBoxTheme.

◆ RefreshMetrics()

virtual void RefreshMetrics ( CXTPComboBox * pComboBox )
virtual

This member function is called by the theme manager to refresh the visual styles used by each component's theme.

Parameters
pComboBox Pointer to a CXTPComboBox object.

Reimplemented from CXTPComboBoxTheme.

The documentation for this class was generated from the following file:
  • XTPComboBoxThemeResource.h


Toolkit Pro: CXTPComboBoxThemeVisualStudio Class Reference

Public Member Functions | List of all members
CXTPComboBoxThemeVisualStudio Class Reference

Used as the paint manager for a combobox control to render a Visual Studio appearance. More...

Inheritance diagram for CXTPComboBoxThemeVisualStudio:
[legend]

Public Member Functions

CXTPComboBoxThemeVisualStudio ()
Default constructor.
virtual | ~CXTPComboBoxThemeVisualStudio ()
Destructor handles cleanup and deallocation.
virtual void | RefreshMetrics (CXTPComboBox *pComboBox)
This member function is called by the theme manager to refresh the visual styles used by each component's theme.
- Public Member Functions inherited from CXTPComboBoxThemeOffice2003
CXTPComboBoxThemeOffice2003 ()
Default constructor.
virtual | ~CXTPComboBoxThemeOffice2003 ()
Destructor handles cleanup and deallocation.
virtual void | DrawBackground (CDC *pDC, CXTPComboBox *pComboBox)
This member function is called to draw the combobox background.
virtual void | DrawButton (CDC *pDC, CXTPComboBox *pComboBox, CRect rcBtn)
Called by the paint manager to draw the button portion of the combobox control.
- Public Member Functions inherited from CXTPComboBoxTheme
CXTPComboBoxTheme ()
Default constructor.
virtual | ~CXTPComboBoxTheme ()
Destructor handles cleanup and deallocation.
virtual void | FillSolidRect (HDC hdc, int x, int y, int cx, int cy, HBRUSH hBrush)
Called by the combobox to fill a rectangle using the brush specifed by hBrush.
virtual void | DrawFrame (HDC hdc, LPRECT lprc, int nSize, HBRUSH hBrush)
Called by the combobox to draw a frame rectangle using the brush specified by hBrush.
virtual BOOL | DrawComboBox (CDC *pDC, CXTPComboBox *pComboBox)
Called by the framework to draw the combobox control.
virtual void | DrawButtonTriangle (CDC *pDC, CXTPComboBox *pComboBox, CRect rcBtn)
Called by the paint manager to draw the drop down arrow for the combobox drop button.
COLORREF | GetBackColor () const
Call this member function to retrieve the background color of the CXTPComboBox control.
COLORREF | SetBackColor (COLORREF clrBackground)
Call this member function to set the background color for the CXTPComboBox control.
void | ResetBackColor ()
Call this member function to reset the background color for the CXTPComboBox control.
COLORREF | GetTextColor () const
Call this member function to retrieve the text color of the CXTPComboBox control.
COLORREF | SetTextColor (COLORREF clrText)
Call this member function to set the text color for the CXTPComboBox control.
void | ResetTextColor ()
Call this member function to reset the text color for the CXTPComboBox control.
const CBrush & | GetBackgroundBrush () const
Call this member function to retrieve a reference to a CBrush object used to draw the combobox background.
- Public Member Functions inherited from CXTPControlTheme
CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme | GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlTheme
static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPComboBoxTheme
CXTPPaintManagerColor | m_clrBorderDisabled
RGB value used to draw the disabled border color.
CXTPPaintManagerColor | m_clrBorderHot
RGB value used to draw the hilighted border color.
CXTPPaintManagerColor | m_clrBorderNormal
RGB value used to draw the normal border color.
CXTPPaintManagerColor | m_clrButtonPressed
RGB value used to draw the pressed button color.
CXTPPaintManagerColor | m_clrButtonHot
RGB value used to draw the highlighted button color.
CXTPPaintManagerColor | m_clrButtonNormal
RGB value used to draw the normal button color.
CXTPPaintManagerColor | m_clrButtonArrowPressed
RGB value used to draw the pressed button arrow color.
CXTPPaintManagerColor | m_clrButtonArrowHot
RGB value used to draw the highlighted button arrow color.
CXTPPaintManagerColor | m_clrButtonArrowNormal
RGB value used to draw the normal button arrow color.
CXTPPaintManagerColor | m_clrBackground
RGB color value representing background color.
CXTPPaintManagerColor | m_clrBackDisabled
RGB color value representing disabled background color.
CXTPPaintManagerColor | m_clrBackHighlight
RGB color value representing highlight background color.
CXTPPaintManagerColor | m_clrText
RGB color value representing text color.
CXTPPaintManagerColor | m_clrTextDisabled
RGB color value representing disabled text color.
CXTPPaintManagerColor | m_clrTextHighlight
RGB color value representing highlight text color.
CXTPPaintManagerColorGradient | m_grcButton
RGB value used to draw the button gradient color.
CXTPPaintManagerColorGradient | m_grcButtonHilite
RGB value used to draw the button highlighted gradient color.
CXTPPaintManagerColorGradient | m_grcButtonPushed
RGB value used to draw the button pushed gradient color.
- Protected Member Functions inherited from CXTPComboBoxTheme
void | UpdateBackgroundBrush ()
Called by the framework to update the color value used by the combobox background brush.
- Protected Attributes inherited from CXTPComboBoxThemeOffice2003
- Protected Attributes inherited from CXTPComboBoxTheme
int | m_nThumbWidth
Size in pixels of the drop button width.
CXTPBrush | m_xtpBrushBackground
Brush used by the combobox to fill the background color.
CXTPWinThemeWrapper * | m_themeComboBox
Windows API wrapper used to draw windows theme.
- Protected Attributes inherited from CXTPControlTheme
XTPControlTheme | m_nTheme
Currently selected theme style index.

Detailed Description

Used as the paint manager for a combobox control to render a Visual Studio appearance.

Member Function Documentation

◆ RefreshMetrics()

virtual void RefreshMetrics ( CXTPComboBox * pComboBox )
virtual

This member function is called by the theme manager to refresh the visual styles used by each component's theme.

Parameters
pComboBox Pointer to a CXTPComboBox object.

Reimplemented from CXTPComboBoxThemeOffice2003.

Reimplemented in CXTPComboBoxThemeNativeWindows10, CXTPComboBoxThemeNativeWindows11, CXTPComboBoxThemeOffice2013, CXTPComboBoxThemeVisualStudio2010, CXTPComboBoxThemeVisualStudio2012, CXTPComboBoxThemeVisualStudio2015, CXTPComboBoxThemeVisualStudio2017, CXTPComboBoxThemeVisualStudio2019, and CXTPComboBoxThemeVisualStudio2022.

The documentation for this class was generated from the following file:
  • XTPComboBoxThemeVisualStudio.h


Toolkit Pro: CXTPComboBoxThemeVisualStudio2010 Class Reference

Public Member Functions | List of all members
CXTPComboBoxThemeVisualStudio2010 Class Reference

Used as the paint manager for a combobox control to render a Visual Studio 2010 appearance. More...

Inheritance diagram for CXTPComboBoxThemeVisualStudio2010:
[legend]

Public Member Functions

CXTPComboBoxThemeVisualStudio2010 ()
Default constructor.
virtual | ~CXTPComboBoxThemeVisualStudio2010 ()
Destructor handles cleanup and deallocation.
virtual void | RefreshMetrics (CXTPComboBox *pComboBox)
This member function is called by the theme manager to refresh the visual styles used by each component's theme.
- Public Member Functions inherited from CXTPComboBoxThemeVisualStudio
CXTPComboBoxThemeVisualStudio ()
Default constructor.
virtual | ~CXTPComboBoxThemeVisualStudio ()
Destructor handles cleanup and deallocation.
- Public Member Functions inherited from CXTPComboBoxThemeOffice2003
CXTPComboBoxThemeOffice2003 ()
Default constructor.
virtual | ~CXTPComboBoxThemeOffice2003 ()
Destructor handles cleanup and deallocation.
virtual void | DrawBackground (CDC *pDC, CXTPComboBox *pComboBox)
This member function is called to draw the combobox background.
virtual void | DrawButton (CDC *pDC, CXTPComboBox *pComboBox, CRect rcBtn)
Called by the paint manager to draw the button portion of the combobox control.
- Public Member Functions inherited from CXTPComboBoxTheme
CXTPComboBoxTheme ()
Default constructor.
virtual | ~CXTPComboBoxTheme ()
Destructor handles cleanup and deallocation.
virtual void | FillSolidRect (HDC hdc, int x, int y, int cx, int cy, HBRUSH hBrush)
Called by the combobox to fill a rectangle using the brush specifed by hBrush.
virtual void | DrawFrame (HDC hdc, LPRECT lprc, int nSize, HBRUSH hBrush)
Called by the combobox to draw a frame rectangle using the brush specified by hBrush.
virtual BOOL | DrawComboBox (CDC *pDC, CXTPComboBox *pComboBox)
Called by the framework to draw the combobox control.
virtual void | DrawButtonTriangle (CDC *pDC, CXTPComboBox *pComboBox, CRect rcBtn)
Called by the paint manager to draw the drop down arrow for the combobox drop button.
COLORREF | GetBackColor () const
Call this member function to retrieve the background color of the CXTPComboBox control.
COLORREF | SetBackColor (COLORREF clrBackground)
Call this member function to set the background color for the CXTPComboBox control.
void | ResetBackColor ()
Call this member function to reset the background color for the CXTPComboBox control.
COLORREF | GetTextColor () const
Call this member function to retrieve the text color of the CXTPComboBox control.
COLORREF | SetTextColor (COLORREF clrText)
Call this member function to set the text color for the CXTPComboBox control.
void | ResetTextColor ()
Call this member function to reset the text color for the CXTPComboBox control.
const CBrush & | GetBackgroundBrush () const
Call this member function to retrieve a reference to a CBrush object used to draw the combobox background.
- Public Member Functions inherited from CXTPControlTheme
CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme | GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlTheme
static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPComboBoxTheme
CXTPPaintManagerColor | m_clrBorderDisabled
RGB value used to draw the disabled border color.
CXTPPaintManagerColor | m_clrBorderHot
RGB value used to draw the hilighted border color.
CXTPPaintManagerColor | m_clrBorderNormal
RGB value used to draw the normal border color.
CXTPPaintManagerColor | m_clrButtonPressed
RGB value used to draw the pressed button color.
CXTPPaintManagerColor | m_clrButtonHot
RGB value used to draw the highlighted button color.
CXTPPaintManagerColor | m_clrButtonNormal
RGB value used to draw the normal button color.
CXTPPaintManagerColor | m_clrButtonArrowPressed
RGB value used to draw the pressed button arrow color.
CXTPPaintManagerColor | m_clrButtonArrowHot
RGB value used to draw the highlighted button arrow color.
CXTPPaintManagerColor | m_clrButtonArrowNormal
RGB value used to draw the normal button arrow color.
CXTPPaintManagerColor | m_clrBackground
RGB color value representing background color.
CXTPPaintManagerColor | m_clrBackDisabled
RGB color value representing disabled background color.
CXTPPaintManagerColor | m_clrBackHighlight
RGB color value representing highlight background color.
CXTPPaintManagerColor | m_clrText
RGB color value representing text color.
CXTPPaintManagerColor | m_clrTextDisabled
RGB color value representing disabled text color.
CXTPPaintManagerColor | m_clrTextHighlight
RGB color value representing highlight text color.
CXTPPaintManagerColorGradient | m_grcButton
RGB value used to draw the button gradient color.
CXTPPaintManagerColorGradient | m_grcButtonHilite
RGB value used to draw the button highlighted gradient color.
CXTPPaintManagerColorGradient | m_grcButtonPushed
RGB value used to draw the button pushed gradient color.
- Protected Member Functions inherited from CXTPComboBoxTheme
void | UpdateBackgroundBrush ()
Called by the framework to update the color value used by the combobox background brush.
- Protected Attributes inherited from CXTPComboBoxThemeOffice2003
- Protected Attributes inherited from CXTPComboBoxTheme
int | m_nThumbWidth
Size in pixels of the drop button width.
CXTPBrush | m_xtpBrushBackground
Brush used by the combobox to fill the background color.
CXTPWinThemeWrapper * | m_themeComboBox
Windows API wrapper used to draw windows theme.
- Protected Attributes inherited from CXTPControlTheme
XTPControlTheme | m_nTheme
Currently selected theme style index.

Detailed Description

Used as the paint manager for a combobox control to render a Visual Studio 2010 appearance.

Member Function Documentation

◆ RefreshMetrics()

virtual void RefreshMetrics ( CXTPComboBox * pComboBox )
virtual

This member function is called by the theme manager to refresh the visual styles used by each component's theme.

Parameters
pComboBox Pointer to a CXTPComboBox object.

Reimplemented from CXTPComboBoxThemeVisualStudio.

The documentation for this class was generated from the following file:
  • XTPComboBoxThemeVisualStudio2010.h


Toolkit Pro: CXTPComboBoxThemeVisualStudio2012 Class Reference

Public Member Functions | List of all members
CXTPComboBoxThemeVisualStudio2012 Class Reference

Used as the paint manager for a combobox control to render a Visual Studio 2012 appearance. More...

Inheritance diagram for CXTPComboBoxThemeVisualStudio2012:
[legend]

Public Member Functions

CXTPComboBoxThemeVisualStudio2012 (BOOL bLight)
Default constructor.
virtual | ~CXTPComboBoxThemeVisualStudio2012 ()
Destructor handles cleanup and deallocation.
virtual void | RefreshMetrics (CXTPComboBox *pComboBox)
This member function is called by the theme manager to refresh the visual styles used by each component's theme.
virtual void | DrawButton (CDC *pDC, CXTPComboBox *pComboBox, CRect rcBtn)
Called by the paint manager to draw the button portion of the combobox control.
- Public Member Functions inherited from CXTPComboBoxThemeVisualStudio
CXTPComboBoxThemeVisualStudio ()
Default constructor.
virtual | ~CXTPComboBoxThemeVisualStudio ()
Destructor handles cleanup and deallocation.
- Public Member Functions inherited from CXTPComboBoxThemeOffice2003
CXTPComboBoxThemeOffice2003 ()
Default constructor.
virtual | ~CXTPComboBoxThemeOffice2003 ()
Destructor handles cleanup and deallocation.
virtual void | DrawBackground (CDC *pDC, CXTPComboBox *pComboBox)
This member function is called to draw the combobox background.
- Public Member Functions inherited from CXTPComboBoxTheme
CXTPComboBoxTheme ()
Default constructor.
virtual | ~CXTPComboBoxTheme ()
Destructor handles cleanup and deallocation.
virtual void | FillSolidRect (HDC hdc, int x, int y, int cx, int cy, HBRUSH hBrush)
Called by the combobox to fill a rectangle using the brush specifed by hBrush.
virtual void | DrawFrame (HDC hdc, LPRECT lprc, int nSize, HBRUSH hBrush)
Called by the combobox to draw a frame rectangle using the brush specified by hBrush.
virtual BOOL | DrawComboBox (CDC *pDC, CXTPComboBox *pComboBox)
Called by the framework to draw the combobox control.
virtual void | DrawButtonTriangle (CDC *pDC, CXTPComboBox *pComboBox, CRect rcBtn)
Called by the paint manager to draw the drop down arrow for the combobox drop button.
COLORREF | GetBackColor () const
Call this member function to retrieve the background color of the CXTPComboBox control.
COLORREF | SetBackColor (COLORREF clrBackground)
Call this member function to set the background color for the CXTPComboBox control.
void | ResetBackColor ()
Call this member function to reset the background color for the CXTPComboBox control.
COLORREF | GetTextColor () const
Call this member function to retrieve the text color of the CXTPComboBox control.
COLORREF | SetTextColor (COLORREF clrText)
Call this member function to set the text color for the CXTPComboBox control.
void | ResetTextColor ()
Call this member function to reset the text color for the CXTPComboBox control.
const CBrush & | GetBackgroundBrush () const
Call this member function to retrieve a reference to a CBrush object used to draw the combobox background.
- Public Member Functions inherited from CXTPControlTheme
CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme | GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlTheme
static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPComboBoxTheme
CXTPPaintManagerColor | m_clrBorderDisabled
RGB value used to draw the disabled border color.
CXTPPaintManagerColor | m_clrBorderHot
RGB value used to draw the hilighted border color.
CXTPPaintManagerColor | m_clrBorderNormal
RGB value used to draw the normal border color.
CXTPPaintManagerColor | m_clrButtonPressed
RGB value used to draw the pressed button color.
CXTPPaintManagerColor | m_clrButtonHot
RGB value used to draw the highlighted button color.
CXTPPaintManagerColor | m_clrButtonNormal
RGB value used to draw the normal button color.
CXTPPaintManagerColor | m_clrButtonArrowPressed
RGB value used to draw the pressed button arrow color.
CXTPPaintManagerColor | m_clrButtonArrowHot
RGB value used to draw the highlighted button arrow color.
CXTPPaintManagerColor | m_clrButtonArrowNormal
RGB value used to draw the normal button arrow color.
CXTPPaintManagerColor | m_clrBackground
RGB color value representing background color.
CXTPPaintManagerColor | m_clrBackDisabled
RGB color value representing disabled background color.
CXTPPaintManagerColor | m_clrBackHighlight
RGB color value representing highlight background color.
CXTPPaintManagerColor | m_clrText
RGB color value representing text color.
CXTPPaintManagerColor | m_clrTextDisabled
RGB color value representing disabled text color.
CXTPPaintManagerColor | m_clrTextHighlight
RGB color value representing highlight text color.
CXTPPaintManagerColorGradient | m_grcButton
RGB value used to draw the button gradient color.
CXTPPaintManagerColorGradient | m_grcButtonHilite
RGB value used to draw the button highlighted gradient color.
CXTPPaintManagerColorGradient | m_grcButtonPushed
RGB value used to draw the button pushed gradient color.
- Protected Member Functions inherited from CXTPComboBoxTheme
void | UpdateBackgroundBrush ()
Called by the framework to update the color value used by the combobox background brush.
- Protected Attributes inherited from CXTPComboBoxThemeOffice2003
- Protected Attributes inherited from CXTPComboBoxTheme
int | m_nThumbWidth
Size in pixels of the drop button width.
CXTPBrush | m_xtpBrushBackground
Brush used by the combobox to fill the background color.
CXTPWinThemeWrapper * | m_themeComboBox
Windows API wrapper used to draw windows theme.
- Protected Attributes inherited from CXTPControlTheme
XTPControlTheme | m_nTheme
Currently selected theme style index.

Detailed Description

Used as the paint manager for a combobox control to render a Visual Studio 2012 appearance.

Constructor & Destructor Documentation

◆ CXTPComboBoxThemeVisualStudio2012()

CXTPComboBoxThemeVisualStudio2012 ( BOOL bLight )

Default constructor.

Parameters
bLight TRUE to use Light theme, FALSE to use Dark theme.

Member Function Documentation

◆ DrawButton()

virtual void DrawButton | ( | CDC * | pDC,
 |  | CXTPComboBox * | pComboBox,
 |  | CRect | rcBtn )
 virtual

Called by the paint manager to draw the button portion of the combobox control.

Parameters
pDC | Pointer to the device context for the combobox.
pComboBox | Pointer to a CXTPComboBox object.
rcBtn | Size of the button to draw.

Reimplemented from CXTPComboBoxThemeOffice2003.

◆ RefreshMetrics()

virtual void RefreshMetrics ( CXTPComboBox * pComboBox )
virtual

This member function is called by the theme manager to refresh the visual styles used by each component's theme.

Parameters
pComboBox Pointer to a CXTPComboBox object.

Reimplemented from CXTPComboBoxThemeVisualStudio.

The documentation for this class was generated from the following file:
  • XTPComboBoxThemeVisualStudio2012.h


Toolkit Pro: CXTPComboBoxThemeVisualStudio2015 Class Reference

Public Member Functions | List of all members
CXTPComboBoxThemeVisualStudio2015 Class Reference

Used as the paint manager for a combobox control to render a Visual Studio 2015 appearance. More...

Inheritance diagram for CXTPComboBoxThemeVisualStudio2015:
[legend]

Public Member Functions

CXTPComboBoxThemeVisualStudio2015 ()
Default constructor.
virtual | ~CXTPComboBoxThemeVisualStudio2015 ()
Destructor handles cleanup and deallocation.
virtual void | RefreshMetrics (CXTPComboBox *pComboBox)
This member function is called by the theme manager to refresh the visual styles used by each component's theme.
virtual void | DrawButton (CDC *pDC, CXTPComboBox *pComboBox, CRect rcBtn)
Called by the paint manager to draw the button portion of the combobox control.
- Public Member Functions inherited from CXTPComboBoxThemeOffice2013
CXTPComboBoxThemeOffice2013 ()
Default constructor.
virtual | ~CXTPComboBoxThemeOffice2013 ()
Destructor handles cleanup and deallocation.
virtual void | DrawButtonTriangle (CDC *pDC, CXTPComboBox *pComboBox, CRect rcBtn)
Called by the paint manager to draw the drop down arrow for the combobox drop button.
virtual void | DrawBackground (CDC *pDC, CXTPComboBox *pComboBox)
This member function is called to draw the combobox background.
- Public Member Functions inherited from CXTPComboBoxThemeVisualStudio
CXTPComboBoxThemeVisualStudio ()
Default constructor.
virtual | ~CXTPComboBoxThemeVisualStudio ()
Destructor handles cleanup and deallocation.
- Public Member Functions inherited from CXTPComboBoxThemeOffice2003
CXTPComboBoxThemeOffice2003 ()
Default constructor.
virtual | ~CXTPComboBoxThemeOffice2003 ()
Destructor handles cleanup and deallocation.
- Public Member Functions inherited from CXTPComboBoxTheme
CXTPComboBoxTheme ()
Default constructor.
virtual | ~CXTPComboBoxTheme ()
Destructor handles cleanup and deallocation.
virtual void | FillSolidRect (HDC hdc, int x, int y, int cx, int cy, HBRUSH hBrush)
Called by the combobox to fill a rectangle using the brush specifed by hBrush.
virtual void | DrawFrame (HDC hdc, LPRECT lprc, int nSize, HBRUSH hBrush)
Called by the combobox to draw a frame rectangle using the brush specified by hBrush.
virtual BOOL | DrawComboBox (CDC *pDC, CXTPComboBox *pComboBox)
Called by the framework to draw the combobox control.
COLORREF | GetBackColor () const
Call this member function to retrieve the background color of the CXTPComboBox control.
COLORREF | SetBackColor (COLORREF clrBackground)
Call this member function to set the background color for the CXTPComboBox control.
void | ResetBackColor ()
Call this member function to reset the background color for the CXTPComboBox control.
COLORREF | GetTextColor () const
Call this member function to retrieve the text color of the CXTPComboBox control.
COLORREF | SetTextColor (COLORREF clrText)
Call this member function to set the text color for the CXTPComboBox control.
void | ResetTextColor ()
Call this member function to reset the text color for the CXTPComboBox control.
const CBrush & | GetBackgroundBrush () const
Call this member function to retrieve a reference to a CBrush object used to draw the combobox background.
- Public Member Functions inherited from CXTPControlTheme
CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme | GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlTheme
static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPComboBoxTheme
CXTPPaintManagerColor | m_clrBorderDisabled
RGB value used to draw the disabled border color.
CXTPPaintManagerColor | m_clrBorderHot
RGB value used to draw the hilighted border color.
CXTPPaintManagerColor | m_clrBorderNormal
RGB value used to draw the normal border color.
CXTPPaintManagerColor | m_clrButtonPressed
RGB value used to draw the pressed button color.
CXTPPaintManagerColor | m_clrButtonHot
RGB value used to draw the highlighted button color.
CXTPPaintManagerColor | m_clrButtonNormal
RGB value used to draw the normal button color.
CXTPPaintManagerColor | m_clrButtonArrowPressed
RGB value used to draw the pressed button arrow color.
CXTPPaintManagerColor | m_clrButtonArrowHot
RGB value used to draw the highlighted button arrow color.
CXTPPaintManagerColor | m_clrButtonArrowNormal
RGB value used to draw the normal button arrow color.
CXTPPaintManagerColor | m_clrBackground
RGB color value representing background color.
CXTPPaintManagerColor | m_clrBackDisabled
RGB color value representing disabled background color.
CXTPPaintManagerColor | m_clrBackHighlight
RGB color value representing highlight background color.
CXTPPaintManagerColor | m_clrText
RGB color value representing text color.
CXTPPaintManagerColor | m_clrTextDisabled
RGB color value representing disabled text color.
CXTPPaintManagerColor | m_clrTextHighlight
RGB color value representing highlight text color.
CXTPPaintManagerColorGradient | m_grcButton
RGB value used to draw the button gradient color.
CXTPPaintManagerColorGradient | m_grcButtonHilite
RGB value used to draw the button highlighted gradient color.
CXTPPaintManagerColorGradient | m_grcButtonPushed
RGB value used to draw the button pushed gradient color.
- Protected Member Functions inherited from CXTPComboBoxTheme
void | UpdateBackgroundBrush ()
Called by the framework to update the color value used by the combobox background brush.
- Protected Attributes inherited from CXTPComboBoxThemeOffice2013
CXTPPaintManagerColor | m_clrButtonDisabled
Drop down button disabled color.
CXTPPaintManagerColor | m_clrButtonArrowDisabled
Drop down arrow disabled color.
- Protected Attributes inherited from CXTPComboBoxThemeOffice2003
- Protected Attributes inherited from CXTPComboBoxTheme
int | m_nThumbWidth
Size in pixels of the drop button width.
CXTPBrush | m_xtpBrushBackground
Brush used by the combobox to fill the background color.
CXTPWinThemeWrapper * | m_themeComboBox
Windows API wrapper used to draw windows theme.
- Protected Attributes inherited from CXTPControlTheme
XTPControlTheme | m_nTheme
Currently selected theme style index.

Detailed Description

Used as the paint manager for a combobox control to render a Visual Studio 2015 appearance.

Member Function Documentation

◆ DrawButton()

virtual void DrawButton | ( | CDC * | pDC,
 |  | CXTPComboBox * | pComboBox,
 |  | CRect | rcBtn )
 virtual

Called by the paint manager to draw the button portion of the combobox control.

Parameters
pDC | Pointer to the device context for the combobox.
pComboBox | Pointer to a CXTPComboBox object.
rcBtn | Size of the button to draw.

Reimplemented from CXTPComboBoxThemeOffice2013.

◆ RefreshMetrics()

virtual void RefreshMetrics ( CXTPComboBox * pComboBox )
virtual

This member function is called by the theme manager to refresh the visual styles used by each component's theme.

Parameters
pComboBox Pointer to a CXTPComboBox object.

Reimplemented from CXTPComboBoxThemeOffice2013.

The documentation for this class was generated from the following file:
  • XTPComboBoxThemeVisualStudio2015.h


Toolkit Pro: CXTPComboBoxThemeVisualStudio2017 Class Reference

Public Member Functions | List of all members
CXTPComboBoxThemeVisualStudio2017 Class Reference

Used as the paint manager for a combobox control to render a Visual Studio 2017 appearance. More...

Inheritance diagram for CXTPComboBoxThemeVisualStudio2017:
[legend]

Public Member Functions

CXTPComboBoxThemeVisualStudio2017 ()
Default constructor.
virtual | ~CXTPComboBoxThemeVisualStudio2017 ()
Destructor handles cleanup and deallocation.
virtual void | RefreshMetrics (CXTPComboBox *pComboBox)
This member function is called by the theme manager to refresh the visual styles used by each component's theme.
virtual void | DrawButton (CDC *pDC, CXTPComboBox *pComboBox, CRect rcBtn)
Called by the paint manager to draw the button portion of the combobox control.
- Public Member Functions inherited from CXTPComboBoxThemeOffice2013
CXTPComboBoxThemeOffice2013 ()
Default constructor.
virtual | ~CXTPComboBoxThemeOffice2013 ()
Destructor handles cleanup and deallocation.
virtual void | DrawButtonTriangle (CDC *pDC, CXTPComboBox *pComboBox, CRect rcBtn)
Called by the paint manager to draw the drop down arrow for the combobox drop button.
virtual void | DrawBackground (CDC *pDC, CXTPComboBox *pComboBox)
This member function is called to draw the combobox background.
- Public Member Functions inherited from CXTPComboBoxThemeVisualStudio
CXTPComboBoxThemeVisualStudio ()
Default constructor.
virtual | ~CXTPComboBoxThemeVisualStudio ()
Destructor handles cleanup and deallocation.
- Public Member Functions inherited from CXTPComboBoxThemeOffice2003
CXTPComboBoxThemeOffice2003 ()
Default constructor.
virtual | ~CXTPComboBoxThemeOffice2003 ()
Destructor handles cleanup and deallocation.
- Public Member Functions inherited from CXTPComboBoxTheme
CXTPComboBoxTheme ()
Default constructor.
virtual | ~CXTPComboBoxTheme ()
Destructor handles cleanup and deallocation.
virtual void | FillSolidRect (HDC hdc, int x, int y, int cx, int cy, HBRUSH hBrush)
Called by the combobox to fill a rectangle using the brush specifed by hBrush.
virtual void | DrawFrame (HDC hdc, LPRECT lprc, int nSize, HBRUSH hBrush)
Called by the combobox to draw a frame rectangle using the brush specified by hBrush.
virtual BOOL | DrawComboBox (CDC *pDC, CXTPComboBox *pComboBox)
Called by the framework to draw the combobox control.
COLORREF | GetBackColor () const
Call this member function to retrieve the background color of the CXTPComboBox control.
COLORREF | SetBackColor (COLORREF clrBackground)
Call this member function to set the background color for the CXTPComboBox control.
void | ResetBackColor ()
Call this member function to reset the background color for the CXTPComboBox control.
COLORREF | GetTextColor () const
Call this member function to retrieve the text color of the CXTPComboBox control.
COLORREF | SetTextColor (COLORREF clrText)
Call this member function to set the text color for the CXTPComboBox control.
void | ResetTextColor ()
Call this member function to reset the text color for the CXTPComboBox control.
const CBrush & | GetBackgroundBrush () const
Call this member function to retrieve a reference to a CBrush object used to draw the combobox background.
- Public Member Functions inherited from CXTPControlTheme
CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme | GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlTheme
static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPComboBoxTheme
CXTPPaintManagerColor | m_clrBorderDisabled
RGB value used to draw the disabled border color.
CXTPPaintManagerColor | m_clrBorderHot
RGB value used to draw the hilighted border color.
CXTPPaintManagerColor | m_clrBorderNormal
RGB value used to draw the normal border color.
CXTPPaintManagerColor | m_clrButtonPressed
RGB value used to draw the pressed button color.
CXTPPaintManagerColor | m_clrButtonHot
RGB value used to draw the highlighted button color.
CXTPPaintManagerColor | m_clrButtonNormal
RGB value used to draw the normal button color.
CXTPPaintManagerColor | m_clrButtonArrowPressed
RGB value used to draw the pressed button arrow color.
CXTPPaintManagerColor | m_clrButtonArrowHot
RGB value used to draw the highlighted button arrow color.
CXTPPaintManagerColor | m_clrButtonArrowNormal
RGB value used to draw the normal button arrow color.
CXTPPaintManagerColor | m_clrBackground
RGB color value representing background color.
CXTPPaintManagerColor | m_clrBackDisabled
RGB color value representing disabled background color.
CXTPPaintManagerColor | m_clrBackHighlight
RGB color value representing highlight background color.
CXTPPaintManagerColor | m_clrText
RGB color value representing text color.
CXTPPaintManagerColor | m_clrTextDisabled
RGB color value representing disabled text color.
CXTPPaintManagerColor | m_clrTextHighlight
RGB color value representing highlight text color.
CXTPPaintManagerColorGradient | m_grcButton
RGB value used to draw the button gradient color.
CXTPPaintManagerColorGradient | m_grcButtonHilite
RGB value used to draw the button highlighted gradient color.
CXTPPaintManagerColorGradient | m_grcButtonPushed
RGB value used to draw the button pushed gradient color.
- Protected Member Functions inherited from CXTPComboBoxTheme
void | UpdateBackgroundBrush ()
Called by the framework to update the color value used by the combobox background brush.
- Protected Attributes inherited from CXTPComboBoxThemeOffice2013
CXTPPaintManagerColor | m_clrButtonDisabled
Drop down button disabled color.
CXTPPaintManagerColor | m_clrButtonArrowDisabled
Drop down arrow disabled color.
- Protected Attributes inherited from CXTPComboBoxThemeOffice2003
- Protected Attributes inherited from CXTPComboBoxTheme
int | m_nThumbWidth
Size in pixels of the drop button width.
CXTPBrush | m_xtpBrushBackground
Brush used by the combobox to fill the background color.
CXTPWinThemeWrapper * | m_themeComboBox
Windows API wrapper used to draw windows theme.
- Protected Attributes inherited from CXTPControlTheme
XTPControlTheme | m_nTheme
Currently selected theme style index.

Detailed Description

Used as the paint manager for a combobox control to render a Visual Studio 2017 appearance.

Member Function Documentation

◆ DrawButton()

virtual void DrawButton | ( | CDC * | pDC,
 |  | CXTPComboBox * | pComboBox,
 |  | CRect | rcBtn )
 virtual

Called by the paint manager to draw the button portion of the combobox control.

Parameters
pDC | Pointer to the device context for the combobox.
pComboBox | Pointer to a CXTPComboBox object.
rcBtn | Size of the button to draw.

Reimplemented from CXTPComboBoxThemeOffice2013.

◆ RefreshMetrics()

virtual void RefreshMetrics ( CXTPComboBox * pComboBox )
virtual

This member function is called by the theme manager to refresh the visual styles used by each component's theme.

Parameters
pComboBox Pointer to a CXTPComboBox object.

Reimplemented from CXTPComboBoxThemeOffice2013.

The documentation for this class was generated from the following file:
  • XTPComboBoxThemeVisualStudio2017.h


Toolkit Pro: CXTPComboBoxThemeVisualStudio2019 Class Reference

Public Member Functions | List of all members
CXTPComboBoxThemeVisualStudio2019 Class Reference

Used as the paint manager for a combobox control to render a Visual Studio 2019 appearance. More...

Inheritance diagram for CXTPComboBoxThemeVisualStudio2019:
[legend]

Public Member Functions

CXTPComboBoxThemeVisualStudio2019 ()
Default constructor.
virtual | ~CXTPComboBoxThemeVisualStudio2019 ()
Destructor handles cleanup and deallocation.
virtual void | RefreshMetrics (CXTPComboBox *pComboBox)
This member function is called by the theme manager to refresh the visual styles used by each component's theme.
virtual void | DrawButton (CDC *pDC, CXTPComboBox *pComboBox, CRect rcBtn)
Called by the paint manager to draw the button portion of the combobox control.
- Public Member Functions inherited from CXTPComboBoxThemeOffice2013
CXTPComboBoxThemeOffice2013 ()
Default constructor.
virtual | ~CXTPComboBoxThemeOffice2013 ()
Destructor handles cleanup and deallocation.
virtual void | DrawButtonTriangle (CDC *pDC, CXTPComboBox *pComboBox, CRect rcBtn)
Called by the paint manager to draw the drop down arrow for the combobox drop button.
virtual void | DrawBackground (CDC *pDC, CXTPComboBox *pComboBox)
This member function is called to draw the combobox background.
- Public Member Functions inherited from CXTPComboBoxThemeVisualStudio
CXTPComboBoxThemeVisualStudio ()
Default constructor.
virtual | ~CXTPComboBoxThemeVisualStudio ()
Destructor handles cleanup and deallocation.
- Public Member Functions inherited from CXTPComboBoxThemeOffice2003
CXTPComboBoxThemeOffice2003 ()
Default constructor.
virtual | ~CXTPComboBoxThemeOffice2003 ()
Destructor handles cleanup and deallocation.
- Public Member Functions inherited from CXTPComboBoxTheme
CXTPComboBoxTheme ()
Default constructor.
virtual | ~CXTPComboBoxTheme ()
Destructor handles cleanup and deallocation.
virtual void | FillSolidRect (HDC hdc, int x, int y, int cx, int cy, HBRUSH hBrush)
Called by the combobox to fill a rectangle using the brush specifed by hBrush.
virtual void | DrawFrame (HDC hdc, LPRECT lprc, int nSize, HBRUSH hBrush)
Called by the combobox to draw a frame rectangle using the brush specified by hBrush.
virtual BOOL | DrawComboBox (CDC *pDC, CXTPComboBox *pComboBox)
Called by the framework to draw the combobox control.
COLORREF | GetBackColor () const
Call this member function to retrieve the background color of the CXTPComboBox control.
COLORREF | SetBackColor (COLORREF clrBackground)
Call this member function to set the background color for the CXTPComboBox control.
void | ResetBackColor ()
Call this member function to reset the background color for the CXTPComboBox control.
COLORREF | GetTextColor () const
Call this member function to retrieve the text color of the CXTPComboBox control.
COLORREF | SetTextColor (COLORREF clrText)
Call this member function to set the text color for the CXTPComboBox control.
void | ResetTextColor ()
Call this member function to reset the text color for the CXTPComboBox control.
const CBrush & | GetBackgroundBrush () const
Call this member function to retrieve a reference to a CBrush object used to draw the combobox background.
- Public Member Functions inherited from CXTPControlTheme
CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme | GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlTheme
static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPComboBoxTheme
CXTPPaintManagerColor | m_clrBorderDisabled
RGB value used to draw the disabled border color.
CXTPPaintManagerColor | m_clrBorderHot
RGB value used to draw the hilighted border color.
CXTPPaintManagerColor | m_clrBorderNormal
RGB value used to draw the normal border color.
CXTPPaintManagerColor | m_clrButtonPressed
RGB value used to draw the pressed button color.
CXTPPaintManagerColor | m_clrButtonHot
RGB value used to draw the highlighted button color.
CXTPPaintManagerColor | m_clrButtonNormal
RGB value used to draw the normal button color.
CXTPPaintManagerColor | m_clrButtonArrowPressed
RGB value used to draw the pressed button arrow color.
CXTPPaintManagerColor | m_clrButtonArrowHot
RGB value used to draw the highlighted button arrow color.
CXTPPaintManagerColor | m_clrButtonArrowNormal
RGB value used to draw the normal button arrow color.
CXTPPaintManagerColor | m_clrBackground
RGB color value representing background color.
CXTPPaintManagerColor | m_clrBackDisabled
RGB color value representing disabled background color.
CXTPPaintManagerColor | m_clrBackHighlight
RGB color value representing highlight background color.
CXTPPaintManagerColor | m_clrText
RGB color value representing text color.
CXTPPaintManagerColor | m_clrTextDisabled
RGB color value representing disabled text color.
CXTPPaintManagerColor | m_clrTextHighlight
RGB color value representing highlight text color.
CXTPPaintManagerColorGradient | m_grcButton
RGB value used to draw the button gradient color.
CXTPPaintManagerColorGradient | m_grcButtonHilite
RGB value used to draw the button highlighted gradient color.
CXTPPaintManagerColorGradient | m_grcButtonPushed
RGB value used to draw the button pushed gradient color.
- Protected Member Functions inherited from CXTPComboBoxTheme
void | UpdateBackgroundBrush ()
Called by the framework to update the color value used by the combobox background brush.
- Protected Attributes inherited from CXTPComboBoxThemeOffice2013
CXTPPaintManagerColor | m_clrButtonDisabled
Drop down button disabled color.
CXTPPaintManagerColor | m_clrButtonArrowDisabled
Drop down arrow disabled color.
- Protected Attributes inherited from CXTPComboBoxThemeOffice2003
- Protected Attributes inherited from CXTPComboBoxTheme
int | m_nThumbWidth
Size in pixels of the drop button width.
CXTPBrush | m_xtpBrushBackground
Brush used by the combobox to fill the background color.
CXTPWinThemeWrapper * | m_themeComboBox
Windows API wrapper used to draw windows theme.
- Protected Attributes inherited from CXTPControlTheme
XTPControlTheme | m_nTheme
Currently selected theme style index.

Detailed Description

Used as the paint manager for a combobox control to render a Visual Studio 2019 appearance.

Member Function Documentation

◆ DrawButton()

virtual void DrawButton | ( | CDC * | pDC,
 |  | CXTPComboBox * | pComboBox,
 |  | CRect | rcBtn )
 virtual

Called by the paint manager to draw the button portion of the combobox control.

Parameters
pDC | Pointer to the device context for the combobox.
pComboBox | Pointer to a CXTPComboBox object.
rcBtn | Size of the button to draw.

Reimplemented from CXTPComboBoxThemeOffice2013.

◆ RefreshMetrics()

virtual void RefreshMetrics ( CXTPComboBox * pComboBox )
virtual

This member function is called by the theme manager to refresh the visual styles used by each component's theme.

Parameters
pComboBox Pointer to a CXTPComboBox object.

Reimplemented from CXTPComboBoxThemeOffice2013.

The documentation for this class was generated from the following file:
  • XTPComboBoxThemeVisualStudio2019.h


Toolkit Pro: CXTPComboBoxThemeVisualStudio2022 Class Reference

Public Member Functions | List of all members
CXTPComboBoxThemeVisualStudio2022 Class Reference

Used as the paint manager for a combobox control to render a Visual Studio 2022 appearance. More...

Inheritance diagram for CXTPComboBoxThemeVisualStudio2022:
[legend]

Public Member Functions

CXTPComboBoxThemeVisualStudio2022 ()
Default constructor.
virtual | ~CXTPComboBoxThemeVisualStudio2022 ()
Destructor handles cleanup and deallocation.
virtual void | RefreshMetrics (CXTPComboBox *pComboBox)
This member function is called by the theme manager to refresh the visual styles used by each component's theme.
virtual void | DrawButton (CDC *pDC, CXTPComboBox *pComboBox, CRect rcBtn)
Called by the paint manager to draw the button portion of the combobox control.
- Public Member Functions inherited from CXTPComboBoxThemeOffice2013
CXTPComboBoxThemeOffice2013 ()
Default constructor.
virtual | ~CXTPComboBoxThemeOffice2013 ()
Destructor handles cleanup and deallocation.
virtual void | DrawButtonTriangle (CDC *pDC, CXTPComboBox *pComboBox, CRect rcBtn)
Called by the paint manager to draw the drop down arrow for the combobox drop button.
virtual void | DrawBackground (CDC *pDC, CXTPComboBox *pComboBox)
This member function is called to draw the combobox background.
- Public Member Functions inherited from CXTPComboBoxThemeVisualStudio
CXTPComboBoxThemeVisualStudio ()
Default constructor.
virtual | ~CXTPComboBoxThemeVisualStudio ()
Destructor handles cleanup and deallocation.
- Public Member Functions inherited from CXTPComboBoxThemeOffice2003
CXTPComboBoxThemeOffice2003 ()
Default constructor.
virtual | ~CXTPComboBoxThemeOffice2003 ()
Destructor handles cleanup and deallocation.
- Public Member Functions inherited from CXTPComboBoxTheme
CXTPComboBoxTheme ()
Default constructor.
virtual | ~CXTPComboBoxTheme ()
Destructor handles cleanup and deallocation.
virtual void | FillSolidRect (HDC hdc, int x, int y, int cx, int cy, HBRUSH hBrush)
Called by the combobox to fill a rectangle using the brush specifed by hBrush.
virtual void | DrawFrame (HDC hdc, LPRECT lprc, int nSize, HBRUSH hBrush)
Called by the combobox to draw a frame rectangle using the brush specified by hBrush.
virtual BOOL | DrawComboBox (CDC *pDC, CXTPComboBox *pComboBox)
Called by the framework to draw the combobox control.
COLORREF | GetBackColor () const
Call this member function to retrieve the background color of the CXTPComboBox control.
COLORREF | SetBackColor (COLORREF clrBackground)
Call this member function to set the background color for the CXTPComboBox control.
void | ResetBackColor ()
Call this member function to reset the background color for the CXTPComboBox control.
COLORREF | GetTextColor () const
Call this member function to retrieve the text color of the CXTPComboBox control.
COLORREF | SetTextColor (COLORREF clrText)
Call this member function to set the text color for the CXTPComboBox control.
void | ResetTextColor ()
Call this member function to reset the text color for the CXTPComboBox control.
const CBrush & | GetBackgroundBrush () const
Call this member function to retrieve a reference to a CBrush object used to draw the combobox background.
- Public Member Functions inherited from CXTPControlTheme
CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme | GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlTheme
static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPComboBoxTheme
CXTPPaintManagerColor | m_clrBorderDisabled
RGB value used to draw the disabled border color.
CXTPPaintManagerColor | m_clrBorderHot
RGB value used to draw the hilighted border color.
CXTPPaintManagerColor | m_clrBorderNormal
RGB value used to draw the normal border color.
CXTPPaintManagerColor | m_clrButtonPressed
RGB value used to draw the pressed button color.
CXTPPaintManagerColor | m_clrButtonHot
RGB value used to draw the highlighted button color.
CXTPPaintManagerColor | m_clrButtonNormal
RGB value used to draw the normal button color.
CXTPPaintManagerColor | m_clrButtonArrowPressed
RGB value used to draw the pressed button arrow color.
CXTPPaintManagerColor | m_clrButtonArrowHot
RGB value used to draw the highlighted button arrow color.
CXTPPaintManagerColor | m_clrButtonArrowNormal
RGB value used to draw the normal button arrow color.
CXTPPaintManagerColor | m_clrBackground
RGB color value representing background color.
CXTPPaintManagerColor | m_clrBackDisabled
RGB color value representing disabled background color.
CXTPPaintManagerColor | m_clrBackHighlight
RGB color value representing highlight background color.
CXTPPaintManagerColor | m_clrText
RGB color value representing text color.
CXTPPaintManagerColor | m_clrTextDisabled
RGB color value representing disabled text color.
CXTPPaintManagerColor | m_clrTextHighlight
RGB color value representing highlight text color.
CXTPPaintManagerColorGradient | m_grcButton
RGB value used to draw the button gradient color.
CXTPPaintManagerColorGradient | m_grcButtonHilite
RGB value used to draw the button highlighted gradient color.
CXTPPaintManagerColorGradient | m_grcButtonPushed
RGB value used to draw the button pushed gradient color.
- Protected Member Functions inherited from CXTPComboBoxTheme
void | UpdateBackgroundBrush ()
Called by the framework to update the color value used by the combobox background brush.
- Protected Attributes inherited from CXTPComboBoxThemeOffice2013
CXTPPaintManagerColor | m_clrButtonDisabled
Drop down button disabled color.
CXTPPaintManagerColor | m_clrButtonArrowDisabled
Drop down arrow disabled color.
- Protected Attributes inherited from CXTPComboBoxThemeOffice2003
- Protected Attributes inherited from CXTPComboBoxTheme
int | m_nThumbWidth
Size in pixels of the drop button width.
CXTPBrush | m_xtpBrushBackground
Brush used by the combobox to fill the background color.
CXTPWinThemeWrapper * | m_themeComboBox
Windows API wrapper used to draw windows theme.
- Protected Attributes inherited from CXTPControlTheme
XTPControlTheme | m_nTheme
Currently selected theme style index.

Detailed Description

Used as the paint manager for a combobox control to render a Visual Studio 2022 appearance.

Member Function Documentation

◆ DrawButton()

virtual void DrawButton | ( | CDC * | pDC,
 |  | CXTPComboBox * | pComboBox,
 |  | CRect | rcBtn )
 virtual

Called by the paint manager to draw the button portion of the combobox control.

Parameters
pDC | Pointer to the device context for the combobox.
pComboBox | Pointer to a CXTPComboBox object.
rcBtn | Size of the button to draw.

Reimplemented from CXTPComboBoxThemeOffice2013.

◆ RefreshMetrics()

virtual void RefreshMetrics ( CXTPComboBox * pComboBox )
virtual

This member function is called by the theme manager to refresh the visual styles used by each component's theme.

Parameters
pComboBox Pointer to a CXTPComboBox object.

Reimplemented from CXTPComboBoxThemeOffice2013.

The documentation for this class was generated from the following file:
  • XTPComboBoxThemeVisualStudio2022.h


Toolkit Pro: CXTPComInitializer Class Reference

Public Member Functions | List of all members
CXTPComInitializer Class Reference

Initializes COM and increments and holds COM initialization reference counter for the thread where constructed. More...

Public Member Functions

CXTPComInitializer (int xtpComInit=xtpComInitAppDefault)
Initializes COM for the calling thread.
~CXTPComInitializer ()
Decrements COM reference counter and uninitializes COM for the calling thread if it holds the last COM reference.
HRESULT | GetInitializationStatus () const
Obtains COM initialization status code.
int | GetInitFlags () const
Obtains COM initialization flags.

Detailed Description

Initializes COM and increments and holds COM initialization reference counter for the thread where constructed.

Constructor & Destructor Documentation

◆ CXTPComInitializer()

CXTPComInitializer ( int xtpComInit = xtpComInitAppDefault )

Initializes COM for the calling thread.

Parameters
xtpComInit COM/OLE initialization method.
See also
XTPComInit

Member Function Documentation

◆ GetInitFlags()

int GetInitFlags ( ) const

Obtains COM initialization flags.

Returns
COM initialization flags.
See also
XTPComInit

◆ GetInitializationStatus()

HRESULT GetInitializationStatus ( ) const

Obtains COM initialization status code.

Returns
COM initialization status code.
The documentation for this class was generated from the following file:
  • XTPSystemHelpers.h


Toolkit Pro: CXTPCommandBar Class Reference

Public Member Functions | Public Attributes | Static Public Attributes | Protected Member Functions | Protected Attributes | List of all members
CXTPCommandBar Class Reference

CXTPCommandBar is a CWnd derived class. More...

Inheritance diagram for CXTPCommandBar:
[legend]

Public Member Functions

int | IsTrackingMode () const
Call this member to get the tracking state.
CXTPControls * | GetControls () const
Call this member to get the controls collection.
void | SetControls (CXTPControls *pControls)
Call this member to set the controls collection of the command bar.
XTPBarType | GetType () const
Call this member to get the type of the command bar.
void | SetTextOrientation (XTPBarTextOrientation nTextOrientation)
Call this member to change text orientation.
XTPBarTextOrientation | GetTextOrientation () const
Call this member to get the text orientation.
XTPBarPosition | GetPosition () const
Call this member to get the position of the command bar.
void | DelayLayout ()
Call this member to recalculate the layout.
virtual void | DelayRedraw ()
Call this member to redraw the command bar.
virtual BOOL | SetTrackingMode (int bMode, BOOL bSelectFirst=TRUE, BOOL bKeyboard=FALSE)
Call this member to change the tracking state.
virtual BOOL | LoadMenu (CMenu *pMenu, BOOL bRemoveControls=TRUE)
Call this member to convert menu items to command bar controls.
CXTPControl * | GetControl (int nIndex) const
Call this member to return the control at the specified index.
int | GetControlCount () const
Call this member to get the count of the controls.
virtual BOOL | SetSelected (int nSelected, BOOL bKeyboard=FALSE)
Call this member to select the specified control.
CXTPControl * | GetSelected () const
Call this member to get the currently selected control.
BOOL | SetPopuped (int nPopuped, BOOL bKeyboard=FALSE)
Call this member to pop-up the specified control.
void | SetTitle (LPCTSTR lpszTitle)
Call this member to set a title for this command bar.
CString | GetTitle () const
Call this member to get a title for this command bar.
CXTPCommandBars * | GetCommandBars () const
Call this member to get the command bar's object.
void | SetCommandBars (CXTPCommandBars *pCommandBars)
Call this member to set the command bar's object.
CWnd * | GetSite () const
Call this member to get the command bar's site.
CFrameWnd * | GetFrameSite () const
Call this member to get the command bar's site as CFrameWnd.
void | SetFlags (DWORD dwFlagsAdd, DWORD dwFlagsRemove=0)
Call this member to set the command bar's flags.
BOOL | SetButtons (UINT *pButtons, int nCount)
Call this member to set the controls from the button array.
virtual BOOL | LoadToolBar (UINT nIDResource, BOOL bLoadIcons=TRUE)
Call this member function to load the toolbar specified by nIDResource.
void | SetIconSize (CSize size)
Call this function to set the size of the actual bitmapped images to be added to a toolbar.
virtual CSize | GetIconSize () const
Call this member function to get the size of the toolbar icon.
CSize | GetLargeIconSize (BOOL bAutoSize) const
Call this method to get the large icon size of the toolbar.
void | SetButtonSize (CSize size)
Sets the size of the buttons in the command bar.
virtual CSize | GetButtonSize () const
Call this function to get the size of the command bar button.
void | ShowTextBelowIcons (BOOL bTextBelow=TRUE)
Call this member to show the caption below control's icon.
BOOL | IsTextBelowIcons () const
Checks whether the caption is below the control's icon.
virtual BOOL | Popup (CXTPControlPopup *pControlPopup, BOOL bSelectFirst=FALSE)
This method is called to pop-up the command bar.
HWND | GetTrackFocus () const
Call this method to retrieve the current focused control.
void | SetTrackFocus (HWND hwnd)
Call this method to set focus to the window.
virtual void | SetVisible (BOOL bVisible)
Call this method to set the visibility state of the control.
virtual BOOL | IsVisible () const
Returns a Boolean value indicating if the command bar is visible.
virtual BOOL | SetPosition (XTPBarPosition barPosition)
Call this member function to set the position of the command bar.
int | FindAccel (TCHAR chAccel) const
Call this method to get the index of the control with the specified accelerator character.
int | FindAccelEx (UINT chAccel, BOOL &bSelectOnly) const
Call this method to get the index of the control with the specified accelerator character.
BOOL | IsCustomizeMode () const
Call this method to check if the command bars are in customize mode.
virtual DROPEFFECT | OnCustomizeDragEnter (CXTPControl *pDataObject, CPoint point)
This member is called when a control is entered into the command bar.
virtual void | OnCustomizeDragLeave ()
This method is called when a control leaves the command bar.
virtual DROPEFFECT | OnCustomizeDragOver (CXTPControl *pDataObject, CPoint point)
This member is called when control is over the command bar.
virtual void | OnCustomizeDrop (CXTPControl *pDataObject, DROPEFFECT &dropEffect, CPoint ptDrop, CPoint ptDrag)
This method is called when a control is dropped to the command bar.
virtual BOOL | IsCustomizable () const
Call this method to check if the command bar is customizable.
BOOL | IsCustomizeDialogPresent () const
Call this method to check if the command bar is present in Customize dialog.
void | EnableCustomization (BOOL bEnable=TRUE)
Call this method to enable/disable customization of the command bar.
virtual void | OnRecalcLayout ()
This method is called to recalculate the command bar layout.
virtual void | OnTrackLost ()
Call this method to remove the tracking state of the command bar.
virtual void | OnTrackEnter ()
Call this method to track the command bar.
CWnd * | GetOwnerSite () const
Call this method to retrieve the owner window of the command bar.
void | InvalidateParents ()
Call this method to redraw all parent command bars.
DWORD | GetFlags () const
Call this method to retrieve the current behavior modification flags of the command bar.
UINT | GetBarID () const
Call this method to retrieve the identifier of the command bar.
void | SetBarID (UINT nID)
Call this method to set the identifier of the command bar.
virtual void | OnControlSelected (BOOL bSelected, CXTPControl *pControl)
This method is called when a child control becomes selected.
BOOL | SetStatusText (const CString &strDescription)
This method is called to set the description context.
void | SetCommandBarData (DWORD_PTR dwData)
This method sets the 32-bit value associated with the command bar.
DWORD_PTR | GetCommandBarData () const
This method retrieves the application-supplied, 32-bit value associated with the command bar.
virtual CXTPCommandBar * | GetParentCommandBar () const
This method retrieves the parent command bar.
CXTPCommandBar * | GetRootParent () const
Call this method to retrieve the top-level parent command bar.
CXTPPaintManager * | GetPaintManager () const
Call this method to retrieve the paint manager.
CXTPImageManager * | GetImageManager () const
Call this method to retrieve the image manager.
void | SetWidth (int nWidth)
Call this member to set the width of the floated or pop-up toolbar.
int | GetWidth () const
Call this member to get the width of the floated or pop-up toolbar.
void | SetPaintManager (CXTPPaintManager *pPaintManager)
Call this member to set the specified paint manager.
void | SetImageManager (CXTPImageManager *pImageManager)
Call this member to set the specified image manager.
BOOL | IsLayoutRTL () const
Call this member function to determine if the command bar layout is Right-to-Left (RTL).
virtual BOOL | IsDialogBar () const
Call this member function to determine if the command bar is a CXTPDialogBar.
virtual BOOL | IsRibbonBar () const
Call this member function to determine if the command bar is a CXTPRibbonBar.
virtual BOOL | IsMenuTitleBar () const
Call this member function to determine if the command bar is a CXTPMenuTitleBar.
virtual BOOL | IsPopupBar () const
Call this member function to determine if the command bar is a CXTPPopupBar.
virtual void | DoPropExchange (CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
virtual BOOL | IsKeyboardCuesVisible () const
Determines if underlines are visible in the command bar control.
void | SetGrabFocus (BOOL bGrabFocus)
This method is called internally to prevent the command bar from grabbing edit focus.
virtual void | Redraw (LPCRECT lpRect=0, BOOL bAnimate=TRUE)
The framework calls this member function to redraw the command bar.
virtual void | DrawCommandBar (CDC *pDC, CRect rcClipBox)
This method is called to draw the command bar in the given context.
void | EnableAnimation (BOOL bEnable=TRUE)
Call this method to enable animation for the command bar.
void | EnableDoubleBuffer (BOOL bEnable=TRUE)
Call this method to enable double buffer for toolbar drawing.
BOOL | IsAnimationEnabled () const
Determines if animation is enabled for the specified command bar.
virtual int | OnHookMessage (HWND hWnd, UINT nMessage, WPARAM &wParam, LPARAM &lParam, LRESULT &lResult)
This member function is called by WindowProc, or is called during message reflection.
virtual void | EnsureVisible (CXTPControl *pControl)
Call this method to ensure that a specified control is visible on the toolbar.
XTPButtonStyle | GetDefaultButtonStyle () const
Call this method to retrieve the default button style of the command bar.
void | SetDefaultButtonStyle (XTPButtonStyle buttonStyle)
Call this method to set the default button style of the command bar.
void | LockRedraw ()
Call this method to freeze redrawing until UnlockRedraw is called.
void | UnlockRedraw ()
Call this method to unfreeze redrawing.
void | SetShowGripper (BOOL bShow)
Call this method to set the visibility of the command bar's gripper.
BOOL | GetShowGripper () const
Call this method to check if the command bar's gripper is visible.
virtual CRect | GetBorders ()
This method is called to get the border margins of the command bar.
virtual void | FillCommandBarEntry (CDC *pDC)
This method is called to draw the background of the command bar.
virtual BOOL | IsResizable () const
Specifies whether the pop-up gallery can be resized by the user.
BOOL | IsKeyboardTipsVisible () const
Call this method to check if keyboard tips are visible for the command bar.
virtual void | CreateKeyboardTips ()
This method is called to create a keyboard tips collection for the command bar.
void | OnKeyboardTipChar (UINT chAccel)
This method is called when the user presses a key while keyboard tips are visible.
virtual void | OnKeyboardTip (CXTPCommandBarKeyboardTip *pTip)
This method is called when a keyboard tip is found for the command bar.
void | HideKeyboardTips ()
Call this method to hide keyboard tips.
void | LockMouseMove (CXTPControl *pControl)
Locks the mouse cursor for a specified control.
void | UnlockMouseMove ()
Unlocks the mouse cursor.
- Public Member Functions inherited from CXTPHookManagerHookAble
CXTPHookManagerHookAble ()
Constructs a CXTPHookManagerHookAble object.
virtual | ~CXTPHookManagerHookAble ()
Destroys a CXTPHookManagerHookAble object, handles cleanup and deallocation.
virtual int | OnPostHookMessage (HWND hWnd, UINT nMessage, WPARAM &wParam, LPARAM &lParam, LRESULT &lResult)
This member function is called after a message has been processed by default window procedure.
virtual void | OnHookAttached (HWND hWnd)
This member function is called right after a hook is attached to the window.
virtual void | OnHookDetached ()
This member function is called right before a hook is to be detached from the window.

Public Attributes

int | m_nStateFlags
State of the command bars.
BOOL | m_bComboBar
TRUE if it is combobox list.
BOOL | m_bTrackOnHover
TRUE to select item if mouse stay over control.
- Public Attributes inherited from CXTPHookManagerHookAble
BOOL | m_bAutoDestroy
TRUE to automatically delete hook.

Static Public Attributes

static int | s_nHoverDelay
Hover delay time.
static int | s_nExpandDelay
Expand delay time.
static int | s_nExpandHoverDelay
Expand hover delay.

Protected Member Functions

CXTPCommandBar ()
Constructs a CXTPCommandBar object.
virtual | ~CXTPCommandBar ()
Destroys a CXTPCommandBar object, handles cleanup and deallocation.
virtual BOOL | OnHookKeyDown (UINT nChar, LPARAM lParam)
The framework calls this member function when a non-system key is pressed.
virtual CSize | CalcDynamicLayout (int nLength, DWORD dwMode)
This method is called to get the size of the command bar.
virtual BOOL | ProcessSpecialKey (XTPSpecialKey key)
This method is called to process special keys.
virtual void | OnControlsChanged ()
This method is called when the controls array is changed.
virtual void | Copy (CXTPCommandBar *pCommandBar, BOOL bRecursive=FALSE)
This method makes a copy of the command bar.
virtual int | OnMouseHitTest (CPoint pt)
This method is called to determine mouse hit code.
virtual void | UpdateShortcuts ()
Updates the control's shortcuts.
UINT | GetActiveDocTemplate () const
Retrieves the active MDI document template.
virtual void | GenerateCommandBarList (DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam)
This method is called to assign self identifiers for the serialization process.
virtual void | RestoreCommandBarList (CXTPCommandBarList *pCommandBarList)
This method is called in the serialization process to restore pop-ups from a list of command bars.
BOOL | IsHelpMode () const
Determines if the parent frame is in help mode.
virtual void | OnRemoved ()
This method is called when a toolbar is removed from the command bars collection.

Protected Attributes

BOOL | m_bGrabFocus
TRUE to grab current focus.
int | m_nMRUWidth
Recent width.
int | m_nSelected
Selected control index.
int | m_nPopuped
Pop-up'ed control index.
HWND | m_hwndFocus
The handle of the window that currently has focus.
UINT | m_nBarID
Command bar's identifier.
BOOL | m_bTracking
TRUE if the command bar is in tracking mode.
CWnd * | m_pSite
Command bar's site.
DWORD | m_nIdleFlags
Idle flags.
DWORD | m_dwFlags
Command bar's flags.
DWORD | m_dwStyle
Command bar's styles.
CString | m_strTitle
Command bar's caption.
XTPBarType | m_barType
Type of the command bar.
CXTPControls * | m_pControls
A pointer to controls collection.
XTPBarPosition | m_barPosition
Position of the command bar.
CXTPCommandBars * | m_pCommandBars
parent command bars class.
CWnd * | m_pOwner
Owner window.
CSize | m_szIcons
Size of the command bar's icons.
CSize | m_szButtons
Size of the command bar's buttons.
BOOL | m_bTextBelow
TRUE if text is shown below the CommandBar buttons.
BOOL | m_bExecOnRButton
TRUE if the control button is executed on a right-click.
BOOL | m_bIgnoreUpdateHandler
TRUE to skip update handler for all child controls.
BOOL | m_bRecursePopup
TRUE if pop-up bar was opened recursively.
BOOL | m_bKeyboardSelect
TRUE if last item was selected by keyboard.
BOOL | m_bCloseable
TRUE if the CommandBar can be closed and-or Hidden.
BOOL | m_bCustomizable
TRUE if command bar is customizable.
CRect | m_rcMarker
Marker position.
BOOL | m_bVerticalMarker
TRUE to draw marker vertically.
DWORD_PTR | m_dwData
The 32-bit value associated with the command bar.
UINT * | m_pReturnCmd
Return command holder.
BOOL | m_bCustomizeDialogPresent
TRUE if the command bar is present in Customize dialog.
BOOL | m_bAnimatePopup
TRUE to animate pop-up bar.
BOOL | m_nLockRedraw
TRUE if all drawing routines skipped.
CXTPPaintManager * | m_pPaintManager
Selected paint manager for command bar.
CXTPImageManager * | m_pImageManager
Selected image manager for command bar.
BOOL | m_bMultiLine
True if multi line commandbar.
XTPButtonStyle | m_buttonStyle
Default button Style.
XTPBarTextOrientation | m_nTextOrientation
Commandbar text orientation.
CXTPToolTipContext * | m_pToolTipContext
Tool tip Context.
CXTPCommandBarAnimation * | m_pAnimation
Animation context.
CSize | m_szButtonSpacing
Spacing used between toolbar buttons.

Detailed Description

CXTPCommandBar is a CWnd derived class.

It represents the parent class for command bars.

Member Function Documentation

◆ CalcDynamicLayout()

AFX_INLINE CSize CalcDynamicLayout | ( | int | nLength,
 |  | DWORD | dwMode )
 protectedvirtual

This method is called to get the size of the command bar.

Parameters
nLength | The requested dimension of the control bar, either horizontal or vertical depending on dwMode.
dwMode | See CControlBar::CalcDynamicLayout for the list of supported flags.
Returns
The size of the command bar.

Reimplemented in CXTPDialogBar, CXTPPopupBar, CXTPPopupToolBar, CXTPRibbonSystemPopupBar, CXTPRibbonSystemPopupBarPage, CXTPRibbonTabPopupToolBar, CXTPTabToolBar, and CXTPToolBar.

◆ Copy()

virtual void Copy | ( | CXTPCommandBar * | pCommandBar,
 |  | BOOL | bRecursive = FALSE )
 protectedvirtual

This method makes a copy of the command bar.

Parameters
pCommandBar | Command bar to be copied.
bRecursive | TRUE to copy recursively.

Reimplemented in CXTPControlComboBoxList, CXTPControlFontComboBoxList, CXTPMenuBar, CXTPPopupBar, and CXTPToolBar.

◆ CreateKeyboardTips()

virtual void CreateKeyboardTips ( )
virtual

This method is called to create a keyboard tips collection for the command bar.

See also
IsKeyboardTipsVisible

Reimplemented in CXTPRibbonTabPopupToolBar.

◆ DoPropExchange()

virtual void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Reads this object from or writes this object to an archive.

Parameters
pPX A CXTPPropExchange object to serialize to or from.

Reimplemented in CXTPControlComboBoxList, CXTPControlFontComboBoxList, CXTPMenuBar, CXTPPopupBar, and CXTPToolBar.

◆ DrawCommandBar()

virtual void DrawCommandBar | ( | CDC * | pDC,
 |  | CRect | rcClipBox )
 virtual

This method is called to draw the command bar in the given context.

Parameters
pDC | Pointer to a valid device context.
rcClipBox | The rectangular area of the control that is invalid.

Reimplemented in CXTPControlComboBoxList, CXTPPopupBar, CXTPRibbonBar, CXTPRibbonTabPopupToolBar, and CXTPTabToolBar.

◆ EnableAnimation()

void EnableAnimation ( BOOL bEnable = TRUE )

Call this method to enable animation for the command bar.

Parameters
bEnable TRUE to enable animation, FALSE to disable.

◆ EnableCustomization()

AFX_INLINE void EnableCustomization ( BOOL bEnable = TRUE )

Call this method to enable/disable customization of the command bar.

Parameters
bEnable TRUE to enable customization, FALSE to disable customization.

◆ EnableDoubleBuffer()

void EnableDoubleBuffer ( BOOL bEnable = TRUE )

Call this method to enable double buffer for toolbar drawing.

Parameters
bEnable TRUE to enable double buffer for toolbar drawing.
See also
EnableAnimation

◆ EnsureVisible()

virtual void EnsureVisible ( CXTPControl * pControl )
virtual

Call this method to ensure that a specified control is visible on the toolbar.

Parameters
pControl Pointer to the CXTPControl object whose visibility must be ensured.

Reimplemented in CXTPRibbonBar, and CXTPRibbonTabPopupToolBar.

◆ FillCommandBarEntry()

virtual void FillCommandBarEntry ( CDC * pDC )
virtual

This method is called to draw the background of the command bar.

Parameters
pDC Pointer to the device context to draw.
See also
DrawCommandBar

Reimplemented in CXTPRibbonSystemPopupBar.

◆ FindAccel()

int FindAccel ( TCHAR chAccel ) const

Call this method to get the index of the control with the specified accelerator character.

Parameters
chAccel Character to find.
Returns
Index of the control with the specified accelerator character.

◆ FindAccelEx()

int FindAccelEx | ( | UINT | chAccel,
 |  | BOOL & | bSelectOnly ) const

Call this method to get the index of the control with the specified accelerator character.

Parameters
chAccel | Character to find.
bSelectOnly | TRUE to select only.
Returns
Index of the control with the specified accelerator character.

◆ GenerateCommandBarList()

virtual void GenerateCommandBarList | ( | DWORD & | nID,
 |  | CXTPCommandBarList * | pCommandBarList,
 |  | XTP_COMMANDBARS_PROPEXCHANGE_PARAM * | pParam )
 protectedvirtual

This method is called to assign self identifiers for the serialization process.

Parameters
nID | Identifier to assign.
pCommandBarList | List of CommandBars.
pParam | Address of a XTP_COMMANDBARS_PROPEXCHANGE_PARAM structure.

Reimplemented in CXTPMenuBar.

◆ GetActiveDocTemplate()

UINT GetActiveDocTemplate ( ) const
protected

Retrieves the active MDI document template.

This method calls CXTPCommandBars::GetActiveDocTemplate.

Returns
Active document template identifier.
See also
CXTPCommandBars::GetActiveDocTemplate

◆ GetBarID()

AFX_INLINE UINT GetBarID ( ) const

Call this method to retrieve the identifier of the command bar.

Returns
Identifier of the command bar.

◆ GetBorders()

virtual CRect GetBorders ( )
virtual

This method is called to get the border margins of the command bar.

Returns
A CRect object containing the border margins of the command bar.

Reimplemented in CXTPPopupBar, CXTPRibbonSystemPopupBar, CXTPTabToolBar, and CXTPToolBar.

◆ GetButtonSize()

virtual CSize GetButtonSize ( ) const
virtual

Call this function to get the size of the command bar button.

Returns
The width and height values of the command bar button.

Reimplemented in CXTPRibbonBar, and CXTPRibbonTabPopupToolBar.

◆ GetCommandBarData()

AFX_INLINE DWORD_PTR GetCommandBarData ( ) const

This method retrieves the application-supplied, 32-bit value associated with the command bar.

Returns
The 32-bit value associated with the command bar.
See also
SetCommandBarData

◆ GetCommandBars()

CXTPCommandBars * GetCommandBars ( ) const

Call this member to get the command bar's object.

Returns
A CXTPCommandBars pointer (can be NULL).

◆ GetControl()

CXTPControl * GetControl ( int nIndex ) const

Call this member to return the control at the specified index.

Parameters
nIndex An integer index.
Returns
The CXTPControl pointer currently at this index.
See also
GetControls, CXTPControls::GetAt

◆ GetControlCount()

int GetControlCount ( ) const

Call this member to get the count of the controls.

Returns
The count of the controls.

◆ GetControls()

AFX_INLINE CXTPControls * GetControls ( ) const

Call this member to get the controls collection.

Returns
A CXTPControls pointer.

◆ GetDefaultButtonStyle()

AFX_INLINE XTPButtonStyle GetDefaultButtonStyle ( ) const

Call this method to retrieve the default button style of the command bar.

Returns
XTPButtonStyle value representing the default button style.
See also
SetDefaultButtonStyle

◆ GetFlags()

AFX_INLINE DWORD GetFlags ( ) const

Call this method to retrieve the current behavior modification flags of the command bar.

Returns
Flags of the command bar that are currently in effect.

◆ GetFrameSite()

CFrameWnd * GetFrameSite ( ) const

Call this member to get the command bar's site as CFrameWnd.

Returns
The command bar's site (can be NULL).

◆ GetIconSize()

virtual CSize GetIconSize ( ) const
virtual

Call this member function to get the size of the toolbar icon.

Returns
The size of the toolbar icon.
See also
GetLargeIconSize

Reimplemented in CXTPRibbonBar, and CXTPRibbonTabPopupToolBar.

◆ GetImageManager()

CXTPImageManager * GetImageManager ( ) const

Call this method to retrieve the image manager.

Returns
A pointer to a CXTPImageManager object.

◆ GetLargeIconSize()

CSize GetLargeIconSize ( BOOL bAutoSize ) const

Call this method to get the large icon size of the toolbar.

Parameters
bAutoSize TRUE to adjust size using current DPI mode.
Returns
CSize value containing the size of large toolbar icons.
See also
GetIconSize

◆ GetOwnerSite()

CWnd * GetOwnerSite ( ) const

Call this method to retrieve the owner window of the command bar.

Returns
A pointer to a CWnd object.

◆ GetPaintManager()

CXTPPaintManager * GetPaintManager ( ) const

Call this method to retrieve the paint manager.

Returns
A pointer to a CXTPPaintManager object.

◆ GetParentCommandBar()

AFX_INLINE CXTPCommandBar * GetParentCommandBar ( ) const
virtual

This method retrieves the parent command bar.

Returns
A pointer to a CXTPCommandBar object.

Reimplemented in CXTPPopupBar.

◆ GetPosition()

AFX_INLINE XTPBarPosition GetPosition ( ) const

Call this member to get the position of the command bar.

Returns
The position of the command bar.
See also
XTPBarPosition, GetType

◆ GetRootParent()

CXTPCommandBar * GetRootParent ( ) const

Call this method to retrieve the top-level parent command bar.

Returns
A pointer to the top-level CXTPCommandBar object.

◆ GetSelected()

AFX_INLINE CXTPControl * GetSelected ( ) const

Call this member to get the currently selected control.

Returns
Pointer to a CXTPControl object containing the currently selected control.

◆ GetShowGripper()

BOOL GetShowGripper ( ) const

Call this method to check if the command bar's gripper is visible.

Returns
TRUE if the gripper is visible, otherwise FALSE.
See also
SetShowGripper

◆ GetSite()

CWnd * GetSite ( ) const

Call this member to get the command bar's site.

Returns
Command bar's site (cannot be NULL).

◆ GetTextOrientation()

AFX_INLINE XTPBarTextOrientation GetTextOrientation ( ) const

Call this member to get the text orientation.

Returns
Returns text orientation

◆ GetTitle()

AFX_INLINE CString GetTitle ( ) const

Call this member to get a title for this command bar.

Returns
The title of the command bar.

◆ GetTrackFocus()

AFX_INLINE HWND GetTrackFocus ( ) const

Call this method to retrieve the current focused control.

Returns
Window handle of the focused control.

◆ GetType()

AFX_INLINE XTPBarType GetType ( ) const

Call this member to get the type of the command bar.

Returns
The type of the command bar. It can be one of the following: xtpBarTypeMenuBar Indicates the command bar is a menu bar (CXTPMenuBar) xtpBarTypeNormal Indicates the command bar is a simple toolbar (CXTPToolBar) xtpBarTypePopup Indicates the command bar is a pop-up bar (CXTPPopupBar)
See also
XTPBarType, GetPosition

◆ GetWidth()

int GetWidth ( ) const

Call this member to get the width of the floated or pop-up toolbar.

Returns
The width, in pixels, of the floated or pop-up toolbar.

◆ HideKeyboardTips()

void HideKeyboardTips ( )

Call this method to hide keyboard tips.

See also
IsKeyboardTipsVisible

◆ IsAnimationEnabled()

BOOL IsAnimationEnabled ( ) const

Determines if animation is enabled for the specified command bar.

Returns
TRUE if animation is enabled, otherwise FALSE.
See also
EnableAnimation

◆ IsCustomizable()

AFX_INLINE BOOL IsCustomizable ( ) const
virtual

Call this method to check if the command bar is customizable.

Returns
TRUE if the command bar is customizable, otherwise FALSE.

Reimplemented in CXTPControlComboBoxList.

◆ IsCustomizeDialogPresent()

AFX_INLINE BOOL IsCustomizeDialogPresent ( ) const

Call this method to check if the command bar is present in Customize dialog.

Returns
TRUE if the command bar is present in Customize dialog, otherwise FALSE.

◆ IsCustomizeMode()

BOOL IsCustomizeMode ( ) const

Call this method to check if the command bars are in customize mode.

Returns
TRUE if the command bars are in customize mode, otherwise FALSE.

◆ IsDialogBar()

AFX_INLINE BOOL IsDialogBar ( ) const
virtual

Call this member function to determine if the command bar is a CXTPDialogBar.

Returns
TRUE if the command bar is a CXTPDialogBar, otherwise FALSE.
See also
CXTPToolBar, CXTPDialogBar

Reimplemented in CXTPDialogBar.

◆ IsHelpMode()

BOOL IsHelpMode ( ) const
protected

Determines if the parent frame is in help mode.

Returns
True if it's in help mode. false otherwise

◆ IsKeyboardCuesVisible()

virtual BOOL IsKeyboardCuesVisible ( ) const
virtual

Determines if underlines are visible in the command bar control.

Returns
TRUE if underlines are visible in the command bar control, otherwise FALSE.

Reimplemented in CXTPRibbonBar, and CXTPRibbonTabPopupToolBar.

◆ IsKeyboardTipsVisible()

BOOL IsKeyboardTipsVisible ( ) const

Call this method to check if keyboard tips are visible for the command bar.

Returns
TRUE if keyboard tips are visible for the command bar, otherwise FALSE.
See also
CreateKeyboardTips

◆ IsLayoutRTL()

BOOL IsLayoutRTL ( ) const

Call this member function to determine if the command bar layout is Right-to-Left (RTL).

Returns
TRUE if the command bar layout is RTL, otherwise FALSE.

◆ IsMenuTitleBar()

AFX_INLINE BOOL IsMenuTitleBar ( ) const
virtual

Call this member function to determine if the command bar is a CXTPMenuTitleBar.

Returns
TRUE if the command bar is a CXTPMenuTitleBar, otherwise FALSE.
See also
CXTPCommandBar, CXTPMenuTitleBar

◆ IsPopupBar()

AFX_INLINE BOOL IsPopupBar ( ) const
virtual

Call this member function to determine if the command bar is a CXTPPopupBar.

Returns
TRUE if the command bar is a CXTPPopupBar, otherwise FALSE.
See also
CXTPCommandBar, CXTPPopupBar

Reimplemented in CXTPPopupBar.

◆ IsResizable()

AFX_INLINE BOOL IsResizable ( ) const
virtual

Specifies whether the pop-up gallery can be resized by the user.

Returns
TRUE if the pop-up gallery can be resized by the user, otherwise FALSE.
See also
XTPGalleryResizable

Reimplemented in CXTPPopupBar.

◆ IsRibbonBar()

AFX_INLINE BOOL IsRibbonBar ( ) const
virtual

Call this member function to determine if the command bar is a CXTPRibbonBar.

Returns
TRUE if the command bar is a CXTPRibbonBar, otherwise FALSE.
See also
CXTPCommandBar, CXTPRibbonBar

Reimplemented in CXTPRibbonBar.

◆ IsTextBelowIcons()

BOOL IsTextBelowIcons ( ) const

Checks whether the caption is below the control's icon.

Returns
TRUE if the caption is below the icon, otherwise FALSE.

◆ IsTrackingMode()

AFX_INLINE int IsTrackingMode ( ) const

Call this member to get the tracking state.

Returns
TRUE if the command bar is in the tracking mode.

◆ IsVisible()

AFX_INLINE BOOL IsVisible ( ) const
virtual

Returns a Boolean value indicating if the command bar is visible.

Returns
TRUE if the command bar is visible; FALSE if the command bar is hidden.

Reimplemented in CXTPPopupBar, and CXTPToolBar.

◆ LoadMenu()

virtual BOOL LoadMenu | ( | CMenu * | pMenu,
 |  | BOOL | bRemoveControls = TRUE )
 virtual

Call this member to convert menu items to command bar controls.

Parameters
pMenu | Menu to be converted.
bRemoveControls | TRUE to remove all controls first.
Returns
TRUE if the method was successful; otherwise FALSE.

◆ LoadToolBar()

virtual BOOL LoadToolBar | ( | UINT | nIDResource,
 |  | BOOL | bLoadIcons = TRUE )
 virtual

Call this member function to load the toolbar specified by nIDResource.

Parameters
nIDResource | Resource ID of the toolbar to be loaded.
bLoadIcons | TRUE if the toolbar icons are to be used by CXTPImageManager.
Returns
Nonzero if successful; otherwise 0.
See also
LoadMenu, SetButtons.

Reimplemented in CXTPToolBar.

◆ LockMouseMove()

void LockMouseMove ( CXTPControl * pControl )

Locks the mouse cursor for a specified control.

Parameters
pControl Pointer to a CXTPControl object.

◆ LockRedraw()

AFX_INLINE void LockRedraw ( )

Call this method to freeze redrawing until UnlockRedraw is called.

See also
UnlockRedraw

◆ OnControlSelected()

virtual void OnControlSelected | ( | BOOL | bSelected,
 |  | CXTPControl * | pControl )
 virtual

This method is called when a child control becomes selected.

Parameters
bSelected | TRUE when control becomes selected.
pControl | Pointer to a CXTPControl object.

◆ OnCustomizeDragEnter()

virtual DROPEFFECT OnCustomizeDragEnter | ( | CXTPControl * | pDataObject,
 |  | CPoint | point )
 virtual

This member is called when a control is entered into the command bar.

Parameters
pDataObject | Pointer to a CXTPControl object.
point | Point to test.
Returns
DROPEFFECT enumerator.

◆ OnCustomizeDragOver()

virtual DROPEFFECT OnCustomizeDragOver | ( | CXTPControl * | pDataObject,
 |  | CPoint | point )
 virtual

This member is called when control is over the command bar.

Parameters
pDataObject | Pointer to a CXTPControl object.
point | Point to test.
Returns
DROPEFFECT enumerator.

◆ OnCustomizeDrop()

virtual void OnCustomizeDrop | ( | CXTPControl * | pDataObject,
 |  | DROPEFFECT & | dropEffect,
 |  | CPoint | ptDrop,
 |  | CPoint | ptDrag )
 virtual

This method is called when a control is dropped to the command bar.

Parameters
pDataObject | Pointer to a CXTPControl object.
dropEffect | DROPEFFECT enumerator.
ptDrop | Point where the user dropped the control.
ptDrag | Point where the user started dragging the control.

Reimplemented in CXTPTabToolBar.

◆ OnHookKeyDown()

virtual BOOL OnHookKeyDown | ( | UINT | nChar,
 |  | LPARAM | lParam )
 protectedvirtual

The framework calls this member function when a non-system key is pressed.

Parameters
nChar | Specifies the virtual key code of the given key.
lParam | Specifies additional message-dependent information.
Returns
TRUE if the key was handled, otherwise returns FALSE.

Reimplemented in CXTPControlComboBoxList, CXTPMiniToolBar, CXTPPopupBar, and CXTPToolBar.

◆ OnHookMessage()

virtual int OnHookMessage | ( | HWND | hWnd,
 |  | UINT | nMessage,
 |  | WPARAM & | wParam,
 |  | LPARAM & | lParam,
 |  | LRESULT & | lResult )
 virtual

This member function is called by WindowProc, or is called during message reflection.

Parameters
hWnd | Window handle message belongs to.
nMessage | Specifies the message to be sent.
wParam | Specifies additional message-dependent information.
lParam | Specifies additional message-dependent information.
lResult | The return value of WindowProc. Depends on the message; may be NULL.
Returns
A non-zero value if a hooked message is processed, 0 otherwise.

Reimplemented from CXTPHookManagerHookAble.

Reimplemented in CXTPControlComboBoxList, CXTPMenuBar, and CXTPRibbonBackstageView.

◆ OnKeyboardTip()

virtual void OnKeyboardTip ( CXTPCommandBarKeyboardTip * pTip )
virtual

This method is called when a keyboard tip is found for the command bar.

Parameters
pTip Keyboard tip that was found for the commandbar.
See also
OnKeyboardTipChar

Reimplemented in CXTPRibbonTabPopupToolBar.

◆ OnKeyboardTipChar()

void OnKeyboardTipChar ( UINT chAccel )

This method is called when the user presses a key while keyboard tips are visible.

Parameters
chAccel Virtual key.
See also
OnKeyboardTip

◆ OnMouseHitTest()

virtual int OnMouseHitTest ( CPoint pt )
protectedvirtual

This method is called to determine mouse hit code.

Parameters
pt Position to test.
Returns
HTCLIENT if the pointer belongs to the client area, otherwise HTNOWHERE.

Reimplemented in CXTPDialogBar.

◆ Popup()

virtual BOOL Popup | ( | CXTPControlPopup * | pControlPopup,
 |  | BOOL | bSelectFirst = FALSE )
 virtual

This method is called to pop-up the command bar.

Parameters
pControlPopup | Points to a CXTPControlPopup object.
bSelectFirst | TRUE to select the first item.
Returns
TRUE if successful, otherwise FALSE.

Reimplemented in CXTPControlComboBoxList, CXTPPopupBar, and CXTPRibbonBackstageView.

◆ ProcessSpecialKey()

virtual BOOL ProcessSpecialKey ( XTPSpecialKey key )
protectedvirtual

This method is called to process special keys.

Parameters
key Special keys enumerator. Can be any of the values listed in the Remarks section.

CXTPCommandBar maps key passed as parameter of OnKeyDown to XTPSpecialKey enumerator and call ProcessSpecialKey.

The key parameter can be one of the following: xtpKeyNext: Indicates that the RIGHT or DOWN key was pressed. Next control must be selected. xtpKeyPrev: Indicates that the LEFT or UP key was pressed. Previous control must be selected. xtpKeyBack: Indicates that the LEFT key was pressed for pop-up bar. Current sub-menu must be closed. xtpKeyPopup: Indicates that the RIGHT key was pressed for pop-up bar. Sub-menu must be opened. xtpKeyEscape: Indicates that the ESCAPE key was pressed. xtpKeyReturn: Indicates that the RETURN key was pressed. xtpKeyHome: Indicates that the HOME key was pressed. First control must be selected. xtpKeyEnd: Indicates that the END key was pressed. Last control must be selected.

Returns
TRUE if the key was handled, otherwise FALSE.

Reimplemented in CXTPRibbonTabPopupToolBar.

◆ Redraw()

virtual void Redraw | ( | LPCRECT | lpRect = 0,
 |  | BOOL | bAnimate = TRUE )
 virtual

The framework calls this member function to redraw the command bar.

Parameters
lpRect | The rectangular area of the bar that is invalid.
bAnimate | TRUE to animate changes in the bounding rectangle.

◆ RestoreCommandBarList()

virtual void RestoreCommandBarList ( CXTPCommandBarList * pCommandBarList )
protectedvirtual

This method is called in the serialization process to restore pop-ups from a list of command bars.

Parameters
pCommandBarList List of command bars.

Reimplemented in CXTPMenuBar.

◆ SetBarID()

AFX_INLINE void SetBarID ( UINT nID )

Call this method to set the identifier of the command bar.

Parameters
nID Identifier to set.

◆ SetButtons()

BOOL SetButtons | ( | UINT * | pButtons,
 |  | int | nCount )

Call this member to set the controls from the button array.

Parameters
pButtons | Pointer to an array of command IDs. It cannot be NULL.
nCount | Number of elements in the array pointed to by pButtons.
Returns
Nonzero if successful; otherwise 0.
See also
LoadToolBar, LoadMenu.

◆ SetButtonSize()

AFX_INLINE void SetButtonSize ( CSize size )

Sets the size of the buttons in the command bar.

Parameters
size Width and height, in pixels, of the buttons.

The button size must always be at least as large as the bitmap size it encloses. This function must be called only before adding any bitmaps to the command bar. If the application does not explicitly set the button size, it is set to the default size.

◆ SetCommandBarData()

AFX_INLINE void SetCommandBarData ( DWORD_PTR dwData )

This method sets the 32-bit value associated with the command bar.

Parameters
dwData Contains the new 32-bit value to associate with the command bar.
See also
GetCommandBarData

◆ SetCommandBars()

AFX_INLINE void SetCommandBars ( CXTPCommandBars * pCommandBars )

Call this member to set the command bar's object.

Parameters
pCommandBars CXTPCommandBars to be set.

◆ SetControls()

void SetControls ( CXTPControls * pControls )

Call this member to set the controls collection of the command bar.

Parameters
pControls New controls to be set.
See also
GetControls

◆ SetDefaultButtonStyle()

AFX_INLINE void SetDefaultButtonStyle ( XTPButtonStyle buttonStyle )

Call this method to set the default button style of the command bar.

Parameters
buttonStyle XTPButtonStyle value representing the default button style.
See also
GetDefaultButtonStyle

◆ SetFlags()

void SetFlags | ( | DWORD | dwFlagsAdd,
 |  | DWORD | dwFlagsRemove = 0 )

Call this member to set the command bar's flags.

Parameters
dwFlagsAdd | Flags to be added.
dwFlagsRemove | Flags to be removed.

dwFlagsAdd and dwFlagsRemove can be combination of XTPToolBarFlags and XTPMenuBarFlags.

Use the bitwise-OR (|) operator to combine the flags.

xtpFlagAlignTop: Allows docking at the top of the client area. xtpFlagAlignBottom: Allows docking at the bottom of the client area. xtpFlagAlignLeft: Allows docking on the left side of the client area. xtpFlagAlignRight: Allows docking on the right side of the client area. xtpFlagAlignAny: Allows docking on any side of the client area. xtpFlagFloating: Allows floating. xtpFlagHideWrap: Allow to hide wrapped controls. xtpFlagStretched: Bar is stretched. xtpFlagStretchedShared: Bar is stretched, but does not fill a whole row. xtpFlagSmartLayout: Smart layout is enabled. xtpFlagHideMinimizeBox: To hide minimize box. xtpFlagHideMaximizeBox: To hide maximize box. xtpFlagIgnoreSetMenuMessage: To ignore MDI menus. xtpFlagHideClose: To hide close button. xtpFlagHideMDIButtons: Specifies to hide all MDI buttons displayed on the Command Bar. xtpFlagAddMDISysPopup: To add system MDI pop-up bar. Specifies to add system MDI pop-up menu to the Menu Bar. This will appear as an icon to the far left of the Menu Bar and will display the MDI menu bar options when clicked.

See also
XTPMenuBarFlags, XTPToolBarFlags

◆ SetGrabFocus()

AFX_INLINE void SetGrabFocus ( BOOL bGrabFocus )

This method is called internally to prevent the command bar from grabbing edit focus.

Parameters
bGrabFocus FALSE to prevent the command bar from grabbing edit focus.

◆ SetIconSize()

AFX_INLINE void SetIconSize ( CSize size )

Call this function to set the size of the actual bitmapped images to be added to a toolbar.

Parameters
size Width and height, in pixels, of the toolbar's icons.

◆ SetImageManager()

void SetImageManager ( CXTPImageManager * pImageManager )

Call this member to set the specified image manager.

Parameters
pImageManager Pointer to a CXTPImageManager object to be set.

◆ SetPaintManager()

void SetPaintManager ( CXTPPaintManager * pPaintManager )

Call this member to set the specified paint manager.

Parameters
pPaintManager Pointer to a CXTPPaintManager object to be set.

◆ SetPopuped()

BOOL SetPopuped | ( | int | nPopuped,
 |  | BOOL | bKeyboard = FALSE )

Call this member to pop-up the specified control.

Parameters
nPopuped | An integer index of the item to be popped.
bKeyboard | TRUE if the item is popped by the keyboard.
Returns
TRUE if the method was successful; otherwise FALSE.

◆ SetPosition()

AFX_INLINE BOOL SetPosition ( XTPBarPosition barPosition )
virtual

Call this member function to set the position of the command bar.

Parameters
barPosition Position of the command bar.
Returns
TRUE if successful; otherwise FALSE.

Reimplemented in CXTPToolBar.

◆ SetSelected()

virtual BOOL SetSelected | ( | int | nSelected,
 |  | BOOL | bKeyboard = FALSE )
 virtual

Call this member to select the specified control.

Parameters
nSelected | An integer index of the item to be selected.
bKeyboard | TRUE if the item was selected using the keyboard.
Returns
TRUE if the method was successful; otherwise FALSE.

Reimplemented in CXTPPopupBar.

◆ SetShowGripper()

void SetShowGripper ( BOOL bShow )

Call this method to set the visibility of the command bar's gripper.

Parameters
bShow TRUE to show the gripper, FALSE to hide the gripper.
See also
GetShowGripper

◆ SetStatusText()

BOOL SetStatusText ( const CString & strDescription )

This method is called to set the description context.

Parameters
strDescription Description string.
Returns
TRUE if successful, otherwise FALSE

◆ SetTextOrientation()

AFX_INLINE void SetTextOrientation ( XTPBarTextOrientation nTextOrientation )

Call this member to change text orientation.

Parameters
nTextOrientation xtpBarTextHorizontal to draw text horizontally, xtpBarTextVertical to draw text vertically.

◆ SetTitle()

AFX_INLINE void SetTitle ( LPCTSTR lpszTitle )

Call this member to set a title for this command bar.

Parameters
lpszTitle Title to be set.

◆ SetTrackFocus()

AFX_INLINE void SetTrackFocus ( HWND hwnd )

Call this method to set focus to the window.

Parameters
hwnd Window handle of the focused control

◆ SetTrackingMode()

virtual BOOL SetTrackingMode | ( | int | bMode,
 |  | BOOL | bSelectFirst = TRUE,
 |  | BOOL | bKeyboard = FALSE )
 virtual

Call this member to change the tracking state.

Parameters
bMode | TRUE to set the tracking mode; otherwise FALSE.
bSelectFirst | TRUE to select the first item.
bKeyboard | TRUE if the item is popped by the keyboard.
Returns
TRUE if the method was successful, otherwise FALSE.
See also
IsTrackingMode.

Reimplemented in CXTPControlComboBoxList, CXTPPopupBar, CXTPRibbonBackstageView, and CXTPRibbonTabPopupToolBar.

◆ SetVisible()

AFX_INLINE void SetVisible ( BOOL bVisible )
virtual

Call this method to set the visibility state of the control.

Parameters
bVisible TRUE to set control visible.

Reimplemented in CXTPRibbonBar, and CXTPToolBar.

◆ SetWidth()

void SetWidth ( int nWidth )

Call this member to set the width of the floated or pop-up toolbar.

Parameters
nWidth Width of the floated or pop-up toolbar.

◆ ShowTextBelowIcons()

void ShowTextBelowIcons ( BOOL bTextBelow = TRUE )

Call this member to show the caption below control's icon.

Parameters
bTextBelow TRUE to show the caption below the icon.

◆ UnlockRedraw()

AFX_INLINE void UnlockRedraw ( )

Call this method to unfreeze redrawing.

See also
LockRedraw

Member Data Documentation

◆ m_bRecursePopup

BOOL m_bRecursePopup
protected

TRUE if pop-up bar was opened recursively.

See TPM_RECURSE flag description.

The documentation for this class was generated from the following file:
  • XTPCommandBar.h


Toolkit Pro: CXTPCommandBarEditCtrl Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPCommandBarEditCtrl Class Reference

CXTPCommandBarEditCtrl is a CEdit derived class. More...

Inheritance diagram for CXTPCommandBarEditCtrl:
[legend]

Public Member Functions

CXTPCommandBarEditCtrl ()
Constructs a CXTPCommandBarEditCtrl object.
virtual BOOL | OnCmdMsg (UINT nID, int nCode, void *pExtra, AFX_CMDHANDLERINFO *pHandlerInfo)
Called by the framework to route and dispatch command messages and to handle the update of command user-interface objects.
virtual BOOL | OnCommand (WPARAM wParam, LPARAM lParam)
The framework calls this member function when the user selects an item from a menu, when a child control sends a notification message, or when an accelerator keystroke is translated.
virtual BOOL | ShowContextMenu (CXTPControl *pControl, CPoint point)
This member function displays a pop-up context menu.
virtual BOOL | CreateEdit (DWORD dwStyle, CWnd *pParentWnd)
This member function displays a pop-up context menu.
BOOL | IsDialogCode (UINT nChar, LPARAM lParam)
This method determines whether the specified character is intended for an edit.
void | GetWindowTextEx (CString &rString)
Returns window text of edit.
void | SetWindowTextEx (LPCTSTR lpszString)
Sets the window text of edit.
BOOL | IsImeMode () const
Determines if the Input Method Editor(IME) is being used.

Protected Member Functions

CRichEditContext & | GetRichEditContext ()
Call this method to get rich edit version information.
BOOL | IsCommandEnabled (UINT nID)
Determines if edit command is enabled.

Protected Attributes

BOOL | m_bImeMode
TRUE if IME editor is currently enabled.
BOOL | m_bComposited
TRUE if control is AERO composited.
BOOL | m_bIgonoreEditChanged
Don't send OnEditChanged.

Detailed Description

CXTPCommandBarEditCtrl is a CEdit derived class.

It is for internal usage only.

Member Function Documentation

◆ CreateEdit()

virtual BOOL CreateEdit | ( | DWORD | dwStyle,
 |  | CWnd * | pParentWnd )
 virtual

This member function displays a pop-up context menu.

Parameters
dwStyle | Specifies object's style flags.
pParentWnd | Pointer to the parent window.
Returns
TRUE if successful, otherwise FALSE.

◆ GetRichEditContext()

CRichEditContext & GetRichEditContext ( )
protected

Call this method to get rich edit version information.

Returns
Returns rich edit version information

◆ GetWindowTextEx()

void GetWindowTextEx ( CString & rString )

Returns window text of edit.

Parameters
rString String to return text.

◆ IsCommandEnabled()

BOOL IsCommandEnabled ( UINT nID )
protected

Determines if edit command is enabled.

Parameters
nID Edit command.
Returns
TRUE if edit command is enabled, otherwise FALSE.

◆ IsDialogCode()

BOOL IsDialogCode | ( | UINT | nChar,
 |  | LPARAM | lParam )

This method determines whether the specified character is intended for an edit.

If it is, this method processes the message.

Parameters
nChar | Specifies the virtual key code of the given key.
lParam | Specifies additional message-dependent information.
Returns
TRUE if successful, otherwise FALSE.

◆ IsImeMode()

BOOL IsImeMode ( ) const

Determines if the Input Method Editor(IME) is being used.

Returns
TRUE if the Input Method Editor(IME) is being used, otherwise FALSE.

◆ OnCmdMsg()

virtual BOOL OnCmdMsg | ( | UINT | nID,
 |  | int | nCode,
 |  | void * | pExtra,
 |  | AFX_CMDHANDLERINFO * | pHandlerInfo )
 virtual

Called by the framework to route and dispatch command messages and to handle the update of command user-interface objects.

Parameters
nID | Contains the command ID.
nCode | Identifies the command notification code.
pExtra | Used according to the value of nCode.
pHandlerInfo | If not NULL, OnCmdMsg fills in the pTarget and pmf members of the pHandlerInfo structure instead of dispatching the command. Typically, this parameter should be NULL.
Returns
Nonzero if the message is handled; otherwise 0.

◆ OnCommand()

virtual BOOL OnCommand | ( | WPARAM | wParam,
 |  | LPARAM | lParam )
 virtual

The framework calls this member function when the user selects an item from a menu, when a child control sends a notification message, or when an accelerator keystroke is translated.

Parameters
wParam | The low-order word of wParam identifies the command ID of the menu item, control, or accelerator. The high-order word of wParam specifies the notification message if the message is from a control. If the message is from an accelerator, the high-order word is 1. If the message is from a menu, the high-order word is 0.
lParam | Specifies additional message-dependent information.
Returns
An application returns nonzero if it processes this message; otherwise 0.

◆ SetWindowTextEx()

void SetWindowTextEx ( LPCTSTR lpszString )

Sets the window text of edit.

Parameters
lpszString String to set text.

◆ ShowContextMenu()

virtual BOOL ShowContextMenu | ( | CXTPControl * | pControl,
 |  | CPoint | point )
 virtual

This member function displays a pop-up context menu.

Parameters
pControl | Pointer to a CXTPControl control.
point | CPoint object specifies x- and y- coordinates.
Returns
TRUE if successful, otherwise FALSE.
The documentation for this class was generated from the following file:
  • XTPControlEdit.h


Toolkit Pro: CXTPCommandBarKeyboardTip Class Reference

Public Member Functions | Public Attributes | List of all members
CXTPCommandBarKeyboardTip Class Reference

CXTPCommandBarKeyboardTip is a CWnd derived class which represents a keyboard tip single window. More...

Public Member Functions

CXTPCommandBarKeyboardTip (CXTPCommandBars *pCommandBars, CCmdTarget *pOwner, LPCTSTR lpszCaption, CPoint pt, DWORD dwAlign, BOOL bEnabled)
Constructs a CXTPCommandBarKeyboardTip object.

Public Attributes

CString | m_strTip
Tooltip.
CString | m_strCaption
Caption.
CString | m_strPrefix
Caption.
CCmdTarget * | m_pOwner
Owner object.
CPoint | m_pt
Client coordinates.
BOOL | m_bEnabled
Enabled flag.
BOOL | m_bVisible
TRUE if visible.
CXTPCommandBars * | m_pCommandBars
Parent CXTPCommandBars object.
DWORD | m_dwAlign
Tip align.
BOOL | m_bExplicit
TRUE when user specify manually KeyTip; FALSE if calculated automatically.

Detailed Description

CXTPCommandBarKeyboardTip is a CWnd derived class which represents a keyboard tip single window.

Constructor & Destructor Documentation

◆ CXTPCommandBarKeyboardTip()

CXTPCommandBarKeyboardTip | ( | CXTPCommandBars * | pCommandBars,
 |  | CCmdTarget * | pOwner,
 |  | LPCTSTR | lpszCaption,
 |  | CPoint | pt,
 |  | DWORD | dwAlign,
 |  | BOOL | bEnabled )

Constructs a CXTPCommandBarKeyboardTip object.

Parameters
pCommandBars | CXTPCommandBars parent object.
pOwner | Owner object.
lpszCaption | Caption of control.
pt | Client coordinates.
dwAlign | Align of tip.
bEnabled | TRUE if keyboard tip is enabled.
The documentation for this class was generated from the following file:
  • XTPCommandBarKeyboardTip.h


Toolkit Pro: CXTPCommandBarList Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPCommandBarList Class Reference

CXTPCommandBarList is a CList derived class. More...

Inheritance diagram for CXTPCommandBarList:
[legend]

Public Member Functions

CXTPCommandBarList (CXTPCommandBars *pCommandBars)
Constructs a CXTPCommandBarList object.
virtual | ~CXTPCommandBarList ()
Destroys a CXTPCommandBarList object, handles cleanup and deallocation.
CXTPCommandBar * | FindCommandBar (UINT nBarID) const
Call this method to find the command bar with the specified identifier.
CXTPCommandBars * | GetCommandBars () const
Call this method to get the CXTPCommandBars parent object attached to the list.
CXTPCommandBar * | GetAt (int nIndex) const
Call this method to get the command bar at the specified index in the list.
int | GetCount () const
Call this method to get the number of command bars in the list.
virtual CXTPCommandBar * | Add (CXTPCommandBar *pCommandBar)
Call this method to add a new command bar to the list.
BOOL | Lookup (CXTPCommandBar *pCommandBar) const
Call this method to check if a specified command bar is in the list.
void | RemoveAll ()
Call this method to remove all command bars from the list.
void | Remove (CXTPCommandBar *pCommandBar)
Call this method to remove a specified command bar from the list.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Attributes

CXTPCommandBars * | m_pCommandBars
Parent CXTPCommandBars object.
CArray< CXTPCommandBar *, CXTPCommandBar * > | m_arrBars
Array of CommandBars.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

CXTPCommandBarList is a CList derived class.

It is used as a collection of CXTPCommandBar classes.

Constructor & Destructor Documentation

◆ CXTPCommandBarList()

CXTPCommandBarList ( CXTPCommandBars * pCommandBars )
inline

Constructs a CXTPCommandBarList object.

Parameters
pCommandBars Parent CXTPCommandBars pointer.

Member Function Documentation

◆ Add()

virtual CXTPCommandBar * Add ( CXTPCommandBar * pCommandBar )
virtual

Call this method to add a new command bar to the list.

Parameters
pCommandBar Pointer to the CXTPCommandBar object to be added.
Returns
Pointer to the newly added CXTPCommandBar object.
See also
GetAt, GetCount

Reimplemented in CXTPCommandBarsContextMenus.

◆ FindCommandBar()

CXTPCommandBar * FindCommandBar ( UINT nBarID ) const

Call this method to find the command bar with the specified identifier.

Parameters
nBarID Identifier of the command bar to find.
Returns
A pointer to a CXTPCommandBar object.

◆ GetAt()

CXTPCommandBar * GetAt ( int nIndex ) const

Call this method to get the command bar at the specified index in the list.

Parameters
nIndex Index of the command bar to return.
Returns
Pointer to the CXTPCommandBar object.
See also
GetCount

◆ GetCommandBars()

CXTPCommandBars * GetCommandBars ( ) const
inline

Call this method to get the CXTPCommandBars parent object attached to the list.

Returns
Pointer to the CXTPCommandBars parent object.
See also
CXTPCommandBars, CXTPCommandBar

◆ GetCount()

int GetCount ( ) const

Call this method to get the number of command bars in the list.

Returns
Number of command bars in the list.
See also
GetAt

◆ Lookup()

BOOL Lookup ( CXTPCommandBar * pCommandBar ) const

Call this method to check if a specified command bar is in the list.

Parameters
pCommandBar Pointer to the CXTPCommandBar object to check.
Returns
TRUE if the CXTPCommandBar object is in the list, otherwise FALSE.

◆ Remove()

void Remove ( CXTPCommandBar * pCommandBar )

Call this method to remove a specified command bar from the list.

Parameters
pCommandBar Pointer to the CXTPCommandBar object to be removed.
See also
RemoveAll

◆ RemoveAll()

void RemoveAll ( )

Call this method to remove all command bars from the list.

See also
Remove
The documentation for this class was generated from the following file:
  • XTPCommandBarList.h


Toolkit Pro: CXTPCommandBars Class Reference

Classes | Public Member Functions | Static Public Member Functions | Public Attributes | Protected Member Functions | Protected Attributes | Static Protected Attributes | List of all members
CXTPCommandBars Class Reference

CXTPCommandBars is a standalone class. More...

Inheritance diagram for CXTPCommandBars:
[legend]

Classes

struct KEYBOARDTIPS
Keyboard tips information. More...

Public Member Functions

CXTPMenuTitleBar * | SetMenuTitleBar (LPCTSTR strName, UINT nID, INT nIconID=-1)
Call this member to create a title menu bar.
CXTPMenuTitleBar * | GetMenuTitleBar () const
Call this member to get the title menu bar.
CXTPMenuBar * | SetMenu (LPCTSTR lpszName, UINT nID)
Call this member to create a menu bar.
CXTPToolBar * | Add (LPCTSTR lpszName, XTPBarPosition nBarPosition, CRuntimeClass *pToolbarClass=NULL)
Call this member to add a new toolbar.
CXTPToolBar * | Add (CXTPToolBar *pToolBar, LPCTSTR strName, XTPBarPosition nBarPosition)
Call this member to add a new toolbar.
virtual CXTPMenuBar * | GetMenuBar () const
Call this member to get the active menu bar.
CXTPToolBar * | GetToolBar (UINT nID) const
Call this member to get the toolbar with the specified identifier.
CWnd * | GetSite () const
Call this member to get the site of the command bars.
CXTPDockBar * | GetDockBar (XTPBarPosition barPosition) const
Call this member to get the dock bar at the specified position.
void | RedrawCommandBars ()
Call this member to redraw the command bars.
void | InvalidateCommandBars ()
Call this member to invalidate the command bars.
virtual void | RecalcFrameLayout (BOOL bDelay=FALSE)
Call this member to recalculate site layout.
CXTPControl * | FindControl (XTPControlType type, UINT nId, BOOL bVisible, BOOL bRecursive) const
Call this member to find the specified control.
BOOL | TrackPopupMenu (UINT nBarID, UINT nFlags, int xPos, int yPos, LPCRECT rcExclude=NULL)
Call this member to display a floating pop-up menu at the specified location.
BOOL | TrackPopupMenuEx (CMenu *pMenu, UINT nFlags, int xPos, int yPos, CWnd *pWndOwner=NULL, LPTPMPARAMS lptpm=NULL)
Call this member to display a floating pop-up menu at the specified location.
CXTPCommandBarsContextMenus * | GetContextMenus () const
Retrieves list of available context menus.
CXTPCommandBarsOptions * | GetCommandBarsOptions () const
Call this member to retrieve the options of the command bars.
void | SaveBarState (LPCTSTR lpszProfileName, BOOL bOnlyCustomized=TRUE)
Call this function to save the state information to the registry or .INI file.
void | LoadBarState (LPCTSTR lpszProfileName, BOOL bSilent=FALSE)
Call this function to retrieve state information from the registry or .INI file.
void | SaveOptions (LPCTSTR lpszProfileName)
Call this function to save the command bars options.
void | LoadOptions (LPCTSTR lpszProfileName)
Call this function to restore the options of the command bars.
void | SerializeBarState (CArchive &ar, BOOL bSerializeControls=FALSE, BOOL bOnlyCustomized=TRUE, BOOL bSilent=FALSE)
Call this function to either read command bars from or write command bars to an archive.
CXTPShortcutManager * | GetShortcutManager () const
Call this function to get the ShortcutManager class pointer.
void | SetShortcutManager (CXTPShortcutManager *pShortcutManager)
Call this function to set a custom shortcut manager class.
void | DoPropExchange (CXTPPropExchange *pPX, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam=NULL)
Either reads this object from or writes this object to storage.
void | LoadDesignerBars (CArchive &ar, UINT nSchemaVersion=_XTP_SCHEMA_CURRENT)
Call this member function to load designer command bars from an archive.
void | LoadDesignerBars (CXTPPropExchange *pPX)
Call this member function to load designer command bars from an archive.
void | HideCommands (const UINT *pCommands, int nCount)
This member function adds the specified commands to the list of menu items to hide until activated by clicking on the chevron.
void | HideCommand (UINT nCommand)
This member function adds the specified command to the list of menu items to hide until activated by clicking on the chevron.
virtual BOOL | IsCommandHidden (UINT nCommand)
Call this member function to retrieve if the command is hidden until activated by clicking on the chevron.
virtual BOOL | IsControlHidden (CXTPControl *pControl)
Call this member function to retrieve if the control is hidden and of type CXTPControlPopup when bAutoHideUnusedPopups is TRUE.
void | SetCommandUsed (UINT nCommand)
Call this member function to set the command activated by the user.
void | ResetUsageData ()
Call this member function to restore the state of the hidden commands.
virtual UINT | GetActiveDocTemplate ()
Retrieves the active MDI document template.
void | OnSetPreviewMode (BOOL bPreview)
Call this member function to set the application's command bars into and out of print-preview mode.
void | UpdateCommandBars () const
Sends WM_IDLEUPDATECMDUI message to all tool bars.
BOOL | IsAllCaps () const
Gets an all-caps flag value that causes command bars to draw all titles uppercase if the flag is set.
void | SetAllCaps (BOOL bAllCaps)
Sets an all-caps flag value that causes command bars to draw all titles uppercase if the flag is set.
BOOL | IsLayoutRTL () const
Determines if right-to-left (RTL) mode is set.
void | SetLayoutRTL (BOOL bRightToLeft)
Specifies if right-to-left (RTL) mode should be set.
BOOL | PreTranslateFrameMessage (MSG *pMsg)
Call this method to process frame messages.
BOOL | OnFrameWndMsg (UINT message, WPARAM wParam, LPARAM lParam, LRESULT *pResult)
Call this method to process frame messages.
virtual void | ContextMenu (CXTPToolBar *pToolBar, CPoint point)
This method shows the context menu for toolbars.
virtual CXTPPopupBar * | GetToolbarsPopup ()
This method creates a context menu for toolbars.
virtual void | GetHiddenControls (CXTPToolBar *pToolBar, CXTPCommandBar *pExpandBar)
Call this method to create an expand bar.
virtual void | GetAddOrRemovePopup (CXTPToolBar *pToolBar, CXTPCommandBar *pExpandBar)
Call this method to create customized controls.
void | SetSite (CWnd *pFrame)
This method is called to set the site window.
CXTPDockBar * | CanDock (CPoint pt, CXTPDockBar *pMainDock=NULL) const
Call this member to retrieve the dock bar at the specified point.
void | EnableDocking ()
This member is called to create dock bars.
int | GetCount () const
Call this member to get the toolbar count.
CXTPToolBar * | GetAt (int nIndex) const
Call this member to retrieve a toolbar with a specified index.
BOOL | SetToolBarFocus (CXTPToolBar *pCommandBar, BOOL bNext=FALSE)
This method is called to activate a toolbar.
BOOL | IsCustomizeMode () const
Call this member to check if command bars are in customize mode.
void | SetCustomizeMode (BOOL bMode)
Call this member to set command bars to customize mode.
BOOL | IsQuickCustomizeMode () const
Call this member to check if command bars are in quick customize mode.
void | SetQuickCustomizeMode (BOOL bMode)
Call this member to set command bars to quick customize mode.
CXTPCustomizeDropSource * | GetDropSource () const
Call this member to retrieve the CXTPCustomizeDropSource helper class for customization.
void | SetDragControl (CCmdTarget *pControl)
This member is called when the customized control changes.
CCmdTarget * | GetDragControl () const
Call this member to retrieve the current customized control.
BOOL | IsCustomizeAvail () const
Call this member to retrieve if the customize is avail.
void | EnableCustomization (BOOL bCustomizeAvail)
Call this member to enable/disable customization.
void | Remove (CXTPToolBar *pToolBar)
Call this member to remove the toolbar.
void | RemoveAll ()
Call this member to remove all toolbars.
BOOL | DockCommandBar (CXTPToolBar *pBar, LPRECT lpRect, CXTPDockBar *pDockBar)
Call this member to dock a toolbar to the specified dockbar.
BOOL | DockCommandBar (CXTPToolBar *pBar, XTPBarPosition barPosition)
Call this member to dock a toolbar to the specified dockbar.
void | SetPaintManager (CXTPPaintManager *pPaintManager)
Call this member to set the specified paint manager.
void | SetTheme (XTPPaintTheme paintTheme)
Call this member to set the specified paint manager.
void | SetImageManager (CXTPImageManager *pImageManager)
Call this member to set the specified image manager.
CXTPPaintManager * | GetPaintManager () const
Call this member to retrieve the paint manager of the command bars.
CXTPImageManager * | GetImageManager () const
Call this member to retrieve the image manager of the command bars.
void | ToggleVisible (int nIndex)
Call this member to show/hide the toolbar.
void | SetCustomizationDataFileName (LPCTSTR lpszFile)
Call this method to set the customization file path.
void | EnableDefaultResetCustomizedToolbarChoice (BOOL bEnable, BOOL bDefaultYes)
Enables/disables the default choice for the Reset Customized Toolbar message.
CXTPReBar * | GetFrameReBar () const
This method finds the rebar of the frame.
CXTPToolTipContext * | GetToolTipContext () const
Call this method to get a pointer to the tooltip context.
int | FindIndex (CXTPToolBar *pToolBar) const
Call this member to find the index of the specified toolbar.
void | ClosePopups () const
Call this member to close all pop-up windows.
CXTPStatusBar * | GetStatusBar () const
Call this member to get a reference to the status bar object.
virtual CXTPToolBar * | AddCustomBar (LPCTSTR lpcstrCaption, UINT nID, BOOL bTearOffBar=FALSE)
This method is called to add a custom toolbar.
virtual void | OnTrackingModeChanged (CXTPCommandBar *pCommandBar, int bMode)
This method is called when the tracking mode of a command bar changes.
CXTPMouseManager * | GetMouseManager () const
Call this method to get the CXTPMouseManager pointer for command bars.
CXTPKeyboardManager * | GetKeyboardManager () const
Call this method to get the GetKeyboardManager pointer for command bars.
BOOL | OnFrameAccel (UINT chAccel)
This method is called when the user press Alt + char.
int | GetHelpTrackingId () const
Determines the Help identifier of a control under the mouse cursor.
void | ShowKeyboardCues (BOOL bShow)
This method is called to show the keyboard cues of controls.
CXTPControlActions * | GetActions () const
Call this method to get the actions list for command bars.
void | EnableActions (BOOL bEnableActions=TRUE)
Call this method to let command bars automatically add actions for new commands.
BOOL | IsActionsEnabled () const
Determines if the EnableActions method was called.
CXTPControlAction * | CreateAction (int nId)
Call this method to create a new action for a specified ID.
CXTPControlAction * | FindAction (int nId) const
Call this method to find an action for a specified ID.
void | EnableFrameTheme (BOOL bEnable=TRUE)
Call this method to enable/disable Office 2007 frame.
BOOL | IsEnableFrameTheme ()
Call this method to check if Office 2007 frame is enabled.
void | EnableToolbarComposition (BOOL bEnable=TRUE)
Call this method to enable Office 2007 frame and toolbar composition.
CXTPCommandBarsFrameHook * | GetFrameHook () const
Gets the CXTPCommandBarsFrameHook hook window used to skin the frame.
void | SetFrameHook (CXTPCommandBarsFrameHook *pFrameHook)
Sets the CXTPCommandBarsFrameHook hook window used to skin the frame.
BOOL | IsDwmEnabled () const
Determines if Vista Glass Effect is enabled for Ribbon Bar.
void | SetFontHeight (int nFontHeight)
Call this method to set a custom font height for command bars.
int | GetFontHeight () const
Call this method to get the font height used for Ribbon Bar.
void | ShowKeyboardTips (CXTPCommandBar *pCommandBar, int nLevel=1)
This method is called to show keyboard tips for the commandbar.
void | HideKeyboardTips ()
Removes all keyboard tips.
virtual void | CreateKeyboardTips (CXTPCommandBar *pCommandBar)
This method is called to create a keyboard tips collection for command bar.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Static Public Member Functions

static BOOL AFX_CDECL | TrackPopupMenu (CMenu *pMenu, UINT nFlags, int xPos, int yPos, CWnd *pWnd, LPCRECT rcExclude=NULL, CWnd *pWndOwner=NULL, CXTPCommandBars *pCommandBars=NULL)
Call this member to display a floating pop-up menu at the specified location.
static BOOL AFX_CDECL | TrackPopupMenu (CXTPPopupBar *pPopupBar, UINT nFlags, int xPos, int yPos, CWnd *pWnd, LPCRECT rcExclude=NULL, CWnd *pWndOwner=NULL)
Call this member to display a floating pop-up menu at the specified location.
static CXTPCommandBars *AFX_CDECL | CreateCommandBars ()
This member creates command bars.
static void AFX_CDECL | SetToolBarClass (CRuntimeClass *pToolBarClass)
Call this method to set the default toolbar class.
static void AFX_CDECL | SetDockBarClass (CRuntimeClass *pDockBarClass)
Call this method to set the default dock bar class.
static void AFX_CDECL | SetMenuBarClass (CRuntimeClass *pMenuBarClass)
Call this method to set the default menu bar class.
static void AFX_CDECL | SetMenuTitleBarClass (CRuntimeClass *pMenuTitleBarClass)
Call this method to set the default menu bar class.
static void AFX_CDECL | SetPopupBarClass (CRuntimeClass *pPopupBarClass)
Call this method to set the default pop-up bar class.
static void AFX_CDECL | SetPopupToolBarClass (CRuntimeClass *pPopupToolBarClass)
Call this method to set the default pop-up toolbar class.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Public Attributes

CXTPControls * | m_pDesignerControls
Designer controls if used.
BOOL | m_bIgnoreShiftMenuKey
if set menus will ignore Shift+Alt key combinations
BOOL | m_bDesignerMode
TRUE if command bars in designer mode.

Protected Member Functions

CXTPCommandBars ()
Constructs a CXTPCommandBars object.
virtual | ~CXTPCommandBars ()
Destroys a CXTPCommandBars object, handles cleanup and deallocation.
BOOL | FloatCommandBar (CXTPToolBar *pBar)
Call this member function to float a CXTPToolBar.
void | GetDockState (CXTPDockState &state)
Call this member function to store state information about the frame window's control bars in a CXTPDockState object.
void | SetDockState (CXTPDockState &state)
Call this member function to apply state information stored in a CXTPDockState object to the frame window's control bars.
virtual void | OnToolBarAdded (CXTPToolBar *pToolBar)
This method is called when a toolbar is added.
virtual void | OnToolBarRemoved (CXTPToolBar *pToolBar)
This method is called when a toolbar is removed.

Protected Attributes

CXTPCustomizeDropSource * | m_pDropSource
Customize helper class.
CXTPPaintManager * | m_pPaintManager
Paint manager.
CXTPImageManager * | m_pImageManager
Image manager.
CCmdTarget * | m_pDragSelected
Customize control.
int | m_nDefaultMenuID
Default menu resource.
BOOL | m_bCustomizeMode
Customize mode.
BOOL | m_bCustomizeAvail
TRUE if customize available.
BOOL | m_bEnableActions
True if actions was enabled.
BOOL | m_bQuickCustomizeMode
TRUE if command bars in quick customization mode.
BOOL | m_bDefaultResetCustomizedToolbarChoiceEnabled
TRUE if default choice is enabled.
BOOL | m_bDefaultResetCustomizedToolbarChoice
TRUE if default choice is Yes.
CString | m_strControlsFileName
File name to be used to store user customization.
CXTPCommandBarsOptions * | m_pOptions
Command bars' options.
CXTPCommandBarsContextMenus * | m_pContextMenus
Context menu collection.
CArray< CXTPToolBar *, CXTPToolBar * > | m_arrBars
Toolbars list.
CXTPDockBar * | m_pDocks [4]
DockBars list.
CWnd * | m_pFrame
Parent frame of command bars.
CXTPToolTipContext * | m_pToolTipContext
Tooltip Context.
CXTPMouseManager * | m_pMouseManager
Mouse manager of command bars.
CXTPKeyboardManager * | m_pKeyboardManager
Keyboard manager of command bars.
BOOL | m_bKeyboardCuesVisible
TRUE if menu underlines is currently visible.
CXTPShortcutManager * | m_pShortcutManager
Shortcut Manager of command bars.
int | m_nIDHelpTracking
Selected control.
CXTPControlActions * | m_pActions
Actions collection.
CXTPCommandBarsFrameHook * | m_pFrameHook
Frame hook pointer for enabled frame theme.
BOOL | m_bInternalFrameHook
TRUE if frame hook object is owned internally.

Static Protected Attributes

static CRuntimeClass * | m_pToolBarClass
Default toolbar class.
static CRuntimeClass * | m_pMenuBarClass
Default menubar class.
static CRuntimeClass * | m_pMenuTitleBarClass
Default menu titlebar class.
static CRuntimeClass * | m_pPopupBarClass
Default pop-up bar class.
static CRuntimeClass * | m_pPopupToolBarClass
Default pop-up bar class.
static CRuntimeClass * | m_pDockBarClass
Default dockbar class.

Detailed Description

CXTPCommandBars is a standalone class.

It allows developers to manipulate toolbars and pop-up bars.

See also
CXTPCommandBar, CXTPToolBar, CXTPCommandBarsOptions

Member Function Documentation

◆ Add() [1/2]

CXTPToolBar * Add | ( | CXTPToolBar * | pToolBar,
 |  | LPCTSTR | strName,
 |  | XTPBarPosition | nBarPosition )

Call this member to add a new toolbar.

Parameters
strName | Attribute name.
nBarPosition | Position of toolbar to be created.
pToolBar | Pointer to a CXTPToolBar object.

CommandBars will create a new toolbar with pToolbarClass runtime class if it specified. If not, then m_pToolBarClass will be used.

Call SetToolBarClass to set the default runtime class for toolbars.

Returns
A CXTPToolBar object if successful; otherwise NULL.
See also
SetMenu, SetToolBarClass

◆ Add() [2/2]

CXTPToolBar * Add | ( | LPCTSTR | lpszName,
 |  | XTPBarPosition | nBarPosition,
 |  | CRuntimeClass * | pToolbarClass = NULL )

Call this member to add a new toolbar.

Parameters
lpszName | Title of the toolbar.
nBarPosition | Position of toolbar to be created.
pToolbarClass | Runtime class of toolbar to create

CommandBars will create a new toolbar with pToolbarClass runtime class if it specified. If not, then m_pToolBarClass will be used.

Call SetToolBarClass to set the default runtime class for toolbars.

Returns
A CXTPToolBar object if successful; otherwise NULL.
See also
SetMenu, SetToolBarClass

◆ AddCustomBar()

virtual CXTPToolBar * AddCustomBar | ( | LPCTSTR | lpcstrCaption,
 |  | UINT | nID,
 |  | BOOL | bTearOffBar = FALSE )
 virtual

This method is called to add a custom toolbar.

Parameters
lpcstrCaption | Title of the toolbar.
nID | Toolbar ID.
bTearOffBar | TRUE if toolbar is tear-off.
Returns
A CXTPToolBar object if successful; otherwise NULL.
See also
Add

◆ CanDock()

CXTPDockBar * CanDock | ( | CPoint | pt,
 |  | CXTPDockBar * | pMainDock = NULL ) const

Call this member to retrieve the dock bar at the specified point.

Parameters
pt | Point to test.
pMainDock | CXTPDockBar class currently docked in.
Returns
A pointer to a CXTPDockBar object.

◆ ContextMenu()

virtual void ContextMenu | ( | CXTPToolBar * | pToolBar,
 |  | CPoint | point )
 virtual

This method shows the context menu for toolbars.

Parameters
pToolBar | Pointer to a CXTPToolBar object.
point | Position of the menu to show.

◆ CreateAction()

CXTPControlAction * CreateAction ( int nId )

Call this method to create a new action for a specified ID.

Parameters
nId Identifier of the action to create.
Returns
Returns new action for specified ID

◆ CreateCommandBars()

static CXTPCommandBars *AFX_CDECL CreateCommandBars ( )
static

This member creates command bars.

Returns
A pointer to a CXTPCommandBars object.

◆ CreateKeyboardTips()

virtual void CreateKeyboardTips ( CXTPCommandBar * pCommandBar )
virtual

This method is called to create a keyboard tips collection for command bar.

Parameters
pCommandBar Owner of keyboard tips.
See also
IsKeyboardTipsVisible

◆ DockCommandBar() [1/2]

BOOL DockCommandBar | ( | CXTPToolBar * | pBar,
 |  | LPRECT | lpRect,
 |  | CXTPDockBar * | pDockBar )

Call this member to dock a toolbar to the specified dockbar.

Parameters
pBar | Pointer to a CXTPToolBar object.
lpRect | Position to dock.
pDockBar | Dock bar needed to be docked.
Returns
TRUE if the toolbar was successfully docked, FALSE if the bar could not be docked.

◆ DockCommandBar() [2/2]

BOOL DockCommandBar | ( | CXTPToolBar * | pBar,
 |  | XTPBarPosition | barPosition )

Call this member to dock a toolbar to the specified dockbar.

Parameters
pBar | Pointer to a CXTPToolBar object.
barPosition | Position to dock.
Returns
TRUE if the toolbar was successfully docked, FALSE if the bar could not be docked.

◆ DoPropExchange()

void DoPropExchange | ( | CXTPPropExchange * | pPX,
 |  | XTP_COMMANDBARS_PROPEXCHANGE_PARAM * | pParam = NULL )

Either reads this object from or writes this object to storage.

Parameters
pPX | A CXTPPropExchange object to serialize to or from.
pParam | Exchange options.

Example:

XTP_COMMANDBARS_PROPEXCHANGE_PARAM param;
param.bSerializeControls = TRUE;
// Serialize to XML
CXTPPropExchangeXMLNode px(FALSE, 0, _T("Settings"));
CXTPPropExchangeSection pxCommandBars(px.GetSection(_T("CommandBars")));
GetCommandBars()->DoPropExchange(&pxCommandBars, &param);
px.SaveToFile(m_strIniFileName);
See also
CXTPPropExchange, XTP_COMMANDBARS_PROPEXCHANGE_PARAM

◆ EnableActions()

void EnableActions ( BOOL bEnableActions = TRUE )

Call this method to let command bars automatically add actions for new commands.

Parameters
bEnableActions TRUE to enable actions, FALSE otherwise.

◆ EnableCustomization()

AFX_INLINE void EnableCustomization ( BOOL bCustomizeAvail )

Call this member to enable/disable customization.

Parameters
bCustomizeAvail TRUE to enable customization; FALSE to disable.

◆ EnableDefaultResetCustomizedToolbarChoice()

AFX_INLINE void EnableDefaultResetCustomizedToolbarChoice | ( | BOOL | bEnable,
 |  | BOOL | bDefaultYes )

Enables/disables the default choice for the Reset Customized Toolbar message.

Parameters
bEnable | TRUE to enable the default choice, FALSE to disable the default choice.
bDefaultYes | If TRUE, then the default choice will be "Yes". Otherwise "No".

◆ EnableFrameTheme()

void EnableFrameTheme ( BOOL bEnable = TRUE )

Call this method to enable/disable Office 2007 frame.

Parameters
bEnable TRUE to enable Office 2007 frame, FALSE to disable Office 2007 frame.
See also
IsFrameThemeEnabled, EnableToolbarComposition

◆ EnableToolbarComposition()

void EnableToolbarComposition ( BOOL bEnable = TRUE )

Call this method to enable Office 2007 frame and toolbar composition.

Parameters
bEnable TRUE to enable Office 2007 frame and toolbar composition, FALSE to disable Office 2007 frame and toolbar composition.
See also
IsFrameThemeEnabled, EnableFrameTheme

◆ FindAction()

CXTPControlAction * FindAction ( int nId ) const

Call this method to find an action for a specified ID.

Parameters
nId Identifier of the action to find.
Returns
Returns action for specified ID

◆ FindControl()

CXTPControl * FindControl | ( | XTPControlType | type,
 |  | UINT | nId,
 |  | BOOL | bVisible,
 |  | BOOL | bRecursive ) const

Call this member to find the specified control.

Parameters
type | Type of the control to find.
nId | Control's identifier.
bVisible | Control's visibility.
bRecursive | To find in the nested command bars.
Returns
The CXTPControl object if successful; otherwise NULL.

◆ FindIndex()

int FindIndex ( CXTPToolBar * pToolBar ) const

Call this member to find the index of the specified toolbar.

Parameters
pToolBar Pointer to a CXTPToolBar object.
Returns
The index of the matching item.

◆ FloatCommandBar()

BOOL FloatCommandBar ( CXTPToolBar * pBar )
protected

Call this member function to float a CXTPToolBar.

Parameters
pBar Pointer to a valid CXTPToolBar object.
Returns
TRUE if the CXTPToolBar was successfully floated, otherwise FALSE.

◆ GetActions()

AFX_INLINE CXTPControlActions * GetActions ( ) const

Call this method to get the actions list for command bars.

Returns
Returns action list for command bars

◆ GetActiveDocTemplate()

virtual UINT GetActiveDocTemplate ( )
virtual

Retrieves the active MDI document template.

Returns
Active document template identifier.

◆ GetAddOrRemovePopup()

virtual void GetAddOrRemovePopup | ( | CXTPToolBar * | pToolBar,
 |  | CXTPCommandBar * | pExpandBar )
 virtual

Call this method to create customized controls.

Parameters
pToolBar | Pointer to a CXTPToolBar object.
pExpandBar | Pointer to a CXTPCommandBar object.

◆ GetAt()

CXTPToolBar * GetAt ( int nIndex ) const

Call this member to retrieve a toolbar with a specified index.

Parameters
nIndex Index of the toolbar.
Returns
A pointer to a CXTPToolBar object.

◆ GetCommandBarsOptions()

AFX_INLINE CXTPCommandBarsOptions * GetCommandBarsOptions ( ) const

Call this member to retrieve the options of the command bars.

Returns
Command Bars options.

◆ GetContextMenus()

AFX_INLINE CXTPCommandBarsContextMenus * GetContextMenus ( ) const

Retrieves list of available context menus.

Returns
Command Bars context menus.

◆ GetCount()

AFX_INLINE int GetCount ( ) const

Call this member to get the toolbar count.

Returns
Number of the toolbars.

◆ GetDockBar()

AFX_INLINE CXTPDockBar * GetDockBar ( XTPBarPosition barPosition ) const

Call this member to get the dock bar at the specified position.

Parameters
barPosition Position of the dockbar.
Returns
A CXTPDockBar pointer.

◆ GetDockState()

void GetDockState ( CXTPDockState & state )
protected

Call this member function to store state information about the frame window's control bars in a CXTPDockState object.

Parameters
state Contains the current state of the frame window's control bars upon return.

◆ GetDragControl()

CCmdTarget * GetDragControl ( ) const

Call this member to retrieve the current customized control.

Returns
A pointer to a CXTPControl object.

◆ GetDropSource()

AFX_INLINE CXTPCustomizeDropSource * GetDropSource ( ) const

Call this member to retrieve the CXTPCustomizeDropSource helper class for customization.

Returns
A pointer to a CXTPCustomizeDropSource object.

◆ GetFontHeight()

int GetFontHeight ( ) const

Call this method to get the font height used for Ribbon Bar.

Returns
The font height used for Ribbon Bar.

◆ GetFrameHook()

AFX_INLINE CXTPCommandBarsFrameHook * GetFrameHook ( ) const

Gets the CXTPCommandBarsFrameHook hook window used to skin the frame.

Returns
Returns CXTPCommandBarsFrameHook hook window
See also
EnableFrameTheme

◆ GetFrameReBar()

CXTPReBar * GetFrameReBar ( ) const

This method finds the rebar of the frame.

Returns
CXTPReBar pointer if the rebar was found; otherwise NULL.

◆ GetHelpTrackingId()

AFX_INLINE int GetHelpTrackingId ( ) const

Determines the Help identifier of a control under the mouse cursor.

Returns
Identifier of the control under the mouse cursor.
See also
CXTPControl::SetHelpId

◆ GetHiddenControls()

virtual void GetHiddenControls | ( | CXTPToolBar * | pToolBar,
 |  | CXTPCommandBar * | pExpandBar )
 virtual

Call this method to create an expand bar.

Parameters
pToolBar | Pointer to a CXTPToolBar object.
pExpandBar | Pointer to a CXTPCommandBar object.

◆ GetImageManager()

CXTPImageManager * GetImageManager ( ) const

Call this member to retrieve the image manager of the command bars.

Returns
A pointer to a CXTPImageManager object.

◆ GetKeyboardManager()

CXTPKeyboardManager * GetKeyboardManager ( ) const

Call this method to get the GetKeyboardManager pointer for command bars.

Returns
Pointer to a GetKeyboardManager object.
See also
CXTPMouseManager

◆ GetMenuBar()

virtual CXTPMenuBar * GetMenuBar ( ) const
virtual

Call this member to get the active menu bar.

Returns
A CXTPMenuBar pointer associated with the menu bar.

◆ GetMenuTitleBar()

CXTPMenuTitleBar * GetMenuTitleBar ( ) const

Call this member to get the title menu bar.

Returns
A CXTPMenuTitleBar pointer associated with the title menu bar.

◆ GetMouseManager()

CXTPMouseManager * GetMouseManager ( ) const

Call this method to get the CXTPMouseManager pointer for command bars.

Returns
Pointer to a CXTPMouseManager object.
See also
GetKeyboardManager

◆ GetPaintManager()

CXTPPaintManager * GetPaintManager ( ) const

Call this member to retrieve the paint manager of the command bars.

Returns
A pointer to a CXTPPaintManager object.

◆ GetShortcutManager()

CXTPShortcutManager * GetShortcutManager ( ) const

Call this function to get the ShortcutManager class pointer.

Returns
Pointer to the current shortcut manager.
See also
SetShortcutManager

◆ GetSite()

AFX_INLINE CWnd * GetSite ( ) const

Call this member to get the site of the command bars.

Returns
A CFrameWnd pointer representing the site of the command bars.

◆ GetStatusBar()

CXTPStatusBar * GetStatusBar ( ) const

Call this member to get a reference to the status bar object.

Returns
Pointer to the CXTPStatusBar object.

◆ GetToolBar()

CXTPToolBar * GetToolBar ( UINT nID ) const

Call this member to get the toolbar with the specified identifier.

Parameters
nID An integer identifier.
Returns
The CXTPToolBar pointer.

◆ GetToolbarsPopup()

virtual CXTPPopupBar * GetToolbarsPopup ( )
virtual

This method creates a context menu for toolbars.

Returns
A CXTPPopupBar object containing a list of toolbars.

◆ GetToolTipContext()

CXTPToolTipContext * GetToolTipContext ( ) const

Call this method to get a pointer to the tooltip context.

Returns
A pointer to the tooltip context.

◆ HideCommand()

void HideCommand ( UINT nCommand )

This member function adds the specified command to the list of menu items to hide until activated by clicking on the chevron.

Parameters
nCommand The command ID of a menu item to hide.

◆ HideCommands()

void HideCommands | ( | const UINT * | pCommands,
 |  | int | nCount )

This member function adds the specified commands to the list of menu items to hide until activated by clicking on the chevron.

Parameters
pCommands | An array of command IDs, or menu items, to hide.
nCount | Size of the array passed in.

The command will not be displayed in pop-up menus until the user clicks on the "expand menu" chevron or after a short delay when bShowFullAfterDelay is TRUE. Note: bAlwaysShowFullMenus must set to FALSE to hide the hidden commands

◆ HideKeyboardTips()

void HideKeyboardTips ( )

Removes all keyboard tips.

See also
ShowKeyboardTips

◆ IsActionsEnabled()

AFX_INLINE BOOL IsActionsEnabled ( ) const

Determines if the EnableActions method was called.

Returns
TRUE if the EnableActions method was called, otherwise FALSE.

◆ IsAllCaps()

AFX_INLINE BOOL IsAllCaps ( ) const

Gets an all-caps flag value that causes command bars to draw all titles uppercase if the flag is set.

Returns
Current all-caps flag value.

◆ IsCommandHidden()

virtual BOOL IsCommandHidden ( UINT nCommand )
virtual

Call this member function to retrieve if the command is hidden until activated by clicking on the chevron.

I.e. Infrequently used commands.

Parameters
nCommand Command id to check.

The command will not be displayed in pop-up menus until the user clicks on the "expand menu" chevron or after a short delay when bShowFullAfterDelay is TRUE. Note: bAlwaysShowFullMenus must set to FALSE to hide the hidden commands

Returns
TRUE if the command item is hidden; otherwise returns FALSE.

◆ IsControlHidden()

virtual BOOL IsControlHidden ( CXTPControl * pControl )
virtual

Call this member function to retrieve if the control is hidden and of type CXTPControlPopup when bAutoHideUnusedPopups is TRUE.

Parameters
pControl Control pointer to check.

If bAutoHideUnusedPopups is FALSE, then this member performs the same action as IsCommandHidden. Override this member to provide a custom intelligent menu scheme.

Returns
TRUE if the control item is hidden; otherwise returns FALSE.

◆ IsCustomizeAvail()

AFX_INLINE BOOL IsCustomizeAvail ( ) const

Call this member to retrieve if the customize is avail.

Returns
TRUE if customize is avail; otherwise FALSE.

◆ IsCustomizeMode()

AFX_INLINE BOOL IsCustomizeMode ( ) const

Call this member to check if command bars are in customize mode.

Returns
TRUE if command bars are in customize mode, otherwise FALSE.

◆ IsDwmEnabled()

BOOL IsDwmEnabled ( ) const

Determines if Vista Glass Effect is enabled for Ribbon Bar.

Returns
TRUE if Vista Glass Effect is enabled for Ribbon Bar, otherwise FALSE.

◆ IsEnableFrameTheme()

BOOL IsEnableFrameTheme ( )

Call this method to check if Office 2007 frame is enabled.

Returns
TRUE if Office 2007 frame is enabled, otherwise FALSE.
See also
IsFrameThemeEnabled, EnableToolbarComposition

◆ IsLayoutRTL()

BOOL IsLayoutRTL ( ) const

Determines if right-to-left (RTL) mode is set.

Returns
TRUE if text is displayed using right-to-left (RTL) reading-order properties.

◆ IsQuickCustomizeMode()

AFX_INLINE BOOL IsQuickCustomizeMode ( ) const

Call this member to check if command bars are in quick customize mode.

Returns
TRUE if command bars are in quick customize mode, otherwise FALSE.
See also
SetQuickCustomizeMode

◆ LoadBarState()

void LoadBarState | ( | LPCTSTR | lpszProfileName,
 |  | BOOL | bSilent = FALSE )

Call this function to retrieve state information from the registry or .INI file.

Parameters
lpszProfileName | Points to a null-terminated string that specifies the name of a section in the initialization file or a key in the Windows registry where state information is stored.
bSilent | TRUE to disable user notifications when command bars are restored to their original state.
See also
SaveBarState, DoPropExchange

◆ LoadDesignerBars() [1/2]

void LoadDesignerBars | ( | CArchive & | ar,
 |  | UINT | nSchemaVersion = _XTP_SCHEMA_CURRENT )

Call this member function to load designer command bars from an archive.

Parameters
ar | A CArchive object to serialize to or from.
nSchemaVersion | Schema version number that indicates the version of the serialized CommandBars data, if it is known. The default value _XTP_SCHEMA_CURRENT assumes that the CommandBars data have been created using the current version and hence is fully compatible. If the schema version number does not match the actual schema version number used for generating the CommandBars data then the behavior is undefined and it may result in crashes and memory access issues.
See also
CXTPPropExchange, CXTPPropExchange::SetSchema

◆ LoadDesignerBars() [2/2]

void LoadDesignerBars ( CXTPPropExchange * pPX )

Call this member function to load designer command bars from an archive.

Parameters
pPX A CXTPPropExchange object to serialize to or from.
See also
CXTPPropExchange, CXTPPropExchange::SetSchema

◆ LoadOptions()

void LoadOptions ( LPCTSTR lpszProfileName )

Call this function to restore the options of the command bars.

Parameters
lpszProfileName Points to a null-terminated string that specifies the name of a section in the initialization file or a key in the Windows registry where state information is stored.
See also
SaveOptions, DoPropExchange

◆ OnFrameAccel()

BOOL OnFrameAccel ( UINT chAccel )

This method is called when the user press Alt + char.

Parameters
chAccel Character that was pressed.
Returns
TRUE if command bars processed this character, otherwise FALSE.

◆ OnFrameWndMsg()

BOOL OnFrameWndMsg | ( | UINT | message,
 |  | WPARAM | wParam,
 |  | LPARAM | lParam,
 |  | LRESULT * | pResult )

Call this method to process frame messages.

CXTPFrameWndBase derived classes call this method automatically.

Parameters
message | Specifies the message to be sent.
wParam | Specifies additional message-dependent information.
lParam | Specifies additional message-dependent information.
pResult | The return value of WindowProc. Depends on the message; may be NULL.
Returns
TRUE if the message was handled; otherwise FALSE.

◆ OnSetPreviewMode()

void OnSetPreviewMode ( BOOL bPreview )

Call this member function to set the application's command bars into and out of print-preview mode.

Parameters
bPreview Specifies whether or not to place the application in print-preview mode. Set to TRUE to place in print preview, FALSE to cancel preview mode.

◆ OnToolBarAdded()

virtual void OnToolBarAdded ( CXTPToolBar * pToolBar )
protectedvirtual

This method is called when a toolbar is added.

Parameters
pToolBar Pointer to the toolbar.

◆ OnToolBarRemoved()

virtual void OnToolBarRemoved ( CXTPToolBar * pToolBar )
protectedvirtual

This method is called when a toolbar is removed.

Parameters
pToolBar Pointer to the toolbar.

◆ OnTrackingModeChanged()

virtual void OnTrackingModeChanged | ( | CXTPCommandBar * | pCommandBar,
 |  | int | bMode )
 virtual

This method is called when the tracking mode of a command bar changes.

Parameters
pCommandBar | Pointer to the command bar whose mode has changed.
bMode | The new mode that the commandbar changed to.

◆ PreTranslateFrameMessage()

BOOL PreTranslateFrameMessage ( MSG * pMsg )

Call this method to process frame messages.

CXTPFrameWndBase derived classes call this method automatically.

Parameters
pMsg Points to an MSG object.
Returns
TRUE if the message was handled; otherwise FALSE.

◆ RecalcFrameLayout()

virtual void RecalcFrameLayout ( BOOL bDelay = FALSE )
virtual

Call this member to recalculate site layout.

Parameters
bDelay TRUE to delay dock site layout until remaining framework items have been initialized completely.

◆ Remove()

void Remove ( CXTPToolBar * pToolBar )

Call this member to remove the toolbar.

Parameters
pToolBar Points to a CXTPToolBar object to remove.

◆ SaveBarState()

void SaveBarState | ( | LPCTSTR | lpszProfileName,
 |  | BOOL | bOnlyCustomized = TRUE )

Call this function to save the state information to the registry or .INI file.

Parameters
lpszProfileName | Points to a null-terminated string that specifies the name of a section in the initialization file or a key in the Windows registry where state information is stored.
bOnlyCustomized | TRUE to save only the state for customized command bar items.
See also
LoadBarState, DoPropExchange

◆ SaveOptions()

void SaveOptions ( LPCTSTR lpszProfileName )

Call this function to save the command bars options.

Parameters
lpszProfileName Points to a null-terminated string that specifies the name of a section in the initialization file or a key in the Windows registry where state information is stored.
See also
LoadOptions, DoPropExchange

◆ SerializeBarState()

void SerializeBarState | ( | CArchive & | ar,
 |  | BOOL | bSerializeControls = FALSE,
 |  | BOOL | bOnlyCustomized = TRUE,
 |  | BOOL | bSilent = FALSE )

Call this function to either read command bars from or write command bars to an archive.

Parameters
ar | A CArchive object to serialize to or from.
bSerializeControls | TRUE to store controls information.
bOnlyCustomized | TRUE to store each command bar only if it was customized by the user.
bSilent | TRUE to disable user notifications when command bars are restored to their original state.
See also
DoPropExchange

◆ SetAllCaps()

AFX_INLINE void SetAllCaps ( BOOL bAllCaps )

Sets an all-caps flag value that causes command bars to draw all titles uppercase if the flag is set.

Parameters
bAllCaps TRUE to make all command bars title uppercase.

◆ SetCommandUsed()

void SetCommandUsed ( UINT nCommand )

Call this member function to set the command activated by the user.

Parameters
nCommand Command ID to set.

◆ SetCustomizationDataFileName()

AFX_INLINE void SetCustomizationDataFileName ( LPCTSTR lpszFile )

Call this method to set the customization file path.

Parameters
lpszFile Path to customization file information.

CommandBars can't store to registry customization information greater than 16kb, so it creates a file with user customization information. If a file is not specified, then the current directory will be used to save customization.

Example:

if (GetAppDataFolder(strAppDataFolder))
{
    CreateDirectory(strAppDataFolder + _T("\\") + AfxGetApp()->m_pszAppName, NULL);

    // Set customization path as "\Documents and Settings\user\Application
    Data\CustomThemes\CommandBars"
    GetCommandBars()->SetCustomizationDataFileName(strAppDataFolder + _T("\") +
    AfxGetApp()->m_pszAppName + _T("\") + lpszProfileName);
}

◆ SetCustomizeMode()

void SetCustomizeMode ( BOOL bMode )

Call this member to set command bars to customize mode.

Parameters
bMode TRUE to set command bars to customize mode.

◆ SetDockBarClass()

AFX_INLINE void SetDockBarClass ( CRuntimeClass * pDockBarClass )
static

Call this method to set the default dock bar class.

Parameters
pDockBarClass Runtime class of dock bars to be added.
Returns
void

◆ SetDockState()

void SetDockState ( CXTPDockState & state )
protected

Call this member function to apply state information stored in a CXTPDockState object to the frame window's control bars.

Parameters
state Apply the stored state to the frame window's control bars.

◆ SetDragControl()

void SetDragControl ( CCmdTarget * pControl )

This member is called when the customized control changes.

Parameters
pControl Pointer to a CXTPControl object.

◆ SetFontHeight()

void SetFontHeight ( int nFontHeight )

Call this method to set a custom font height for command bars.

Parameters
nFontHeight Font height to set.

◆ SetFrameHook()

AFX_INLINE void SetFrameHook ( CXTPCommandBarsFrameHook * pFrameHook )

Sets the CXTPCommandBarsFrameHook hook window used to skin the frame.

Parameters
pFrameHook Hook window object pointer
See also
EnableFrameTheme

◆ SetImageManager()

void SetImageManager ( CXTPImageManager * pImageManager )

Call this member to set the specified image manager.

Parameters
pImageManager Pointer to a CXTPPaintManager object.

◆ SetLayoutRTL()

void SetLayoutRTL ( BOOL bRightToLeft )

Specifies if right-to-left (RTL) mode should be set.

Parameters
bRightToLeft TRUE to display text using right-to-left (RTL) reading-order properties.

◆ SetMenu()

CXTPMenuBar * SetMenu | ( | LPCTSTR | lpszName,
 |  | UINT | nID )

Call this member to create a menu bar.

Parameters
lpszName | Title of the menu bar.
nID | Menu identifier to be loaded.
Returns
A CXTPMenuBar object if successful; otherwise NULL.
See also
Add

◆ SetMenuBarClass()

AFX_INLINE void SetMenuBarClass ( CRuntimeClass * pMenuBarClass )
static

Call this method to set the default menu bar class.

Parameters
pMenuBarClass Runtime class of menu bars to be added.
Returns
void

◆ SetMenuTitleBar()

CXTPMenuTitleBar * SetMenuTitleBar | ( | LPCTSTR | strName,
 |  | UINT | nID,
 |  | INT | nIconID = -1 )

Call this member to create a title menu bar.

Parameters
lpszName | Title of the title menu bar.
nID | Menu identifier to be loaded.
Returns
A CXTPMenuTitleBar object if successful; otherwise NULL.
See also
Add

◆ SetMenuTitleBarClass()

AFX_INLINE void SetMenuTitleBarClass ( CRuntimeClass * pMenuTitleBarClass )
static

Call this method to set the default menu bar class.

Parameters
pMenuTitleBarClass Runtime class of menu bars to be added.

◆ SetPaintManager()

void SetPaintManager ( CXTPPaintManager * pPaintManager )

Call this member to set the specified paint manager.

Parameters
pPaintManager Pointer to a CXTPPaintManager object.

◆ SetPopupBarClass()

AFX_INLINE void SetPopupBarClass ( CRuntimeClass * pPopupBarClass )
static

Call this method to set the default pop-up bar class.

Parameters
pPopupBarClass Runtime class of pop-up bars to be added.
Returns
void

◆ SetPopupToolBarClass()

AFX_INLINE void SetPopupToolBarClass ( CRuntimeClass * pPopupToolBarClass )
static

Call this method to set the default pop-up toolbar class.

Parameters
pPopupToolBarClass Runtime class of pop-up toolbars to be added.
Returns
void

◆ SetQuickCustomizeMode()

void SetQuickCustomizeMode ( BOOL bMode )

Call this member to set command bars to quick customize mode.

Parameters
bMode TRUE to set command bars to quick customize mode.
See also
IsQuickCustomizeMode

◆ SetShortcutManager()

void SetShortcutManager ( CXTPShortcutManager * pShortcutManager )

Call this function to set a custom shortcut manager class.

Parameters
pShortcutManager New ShortcutManager to be set.
See also
GetShortcutManager

◆ SetSite()

void SetSite ( CWnd * pFrame )

This method is called to set the site window.

Parameters
pFrame Points to a CWnd object.

◆ SetTheme()

void SetTheme ( XTPPaintTheme paintTheme )

Call this member to set the specified paint manager.

Parameters
paintTheme Visual theme to be set.

◆ SetToolBarClass()

AFX_INLINE void SetToolBarClass ( CRuntimeClass * pToolBarClass )
static

Call this method to set the default toolbar class.

Parameters
pToolBarClass Runtime class of toolbars to be added.

Example:

class CSystemToolBar : public CXTPToolBar
{
    DECALRE_DYNCREATE(CSystemToolBar)

    ....

}

pCommandBars->SetToolBarClass(RUNTIME_CLASS(CSystemToolBar));

CXTPToolBar* pToolBar = pCommandBars->Add("New ToolBar", xtpBarTop);
ASSERT_KINDOF(CSystemToolBar, pToolBar);
Returns
void
See also
SetMenuBarClass, SetPopupBarClass

◆ SetToolBarFocus()

BOOL SetToolBarFocus | ( | CXTPToolBar * | pCommandBar,
 |  | BOOL | bNext = FALSE )

This method is called to activate a toolbar.

Parameters
pCommandBar | Toolbar to activate.
bNext | TRUE to set focus to the next toolbar.
Returns
TRUE if successful; otherwise FALSE.

◆ ShowKeyboardCues()

void ShowKeyboardCues ( BOOL bShow )

This method is called to show the keyboard cues of controls.

Parameters
bShow TRUE to show keyboard cues.

◆ ShowKeyboardTips()

void ShowKeyboardTips | ( | CXTPCommandBar * | pCommandBar,
 |  | int | nLevel = 1 )

This method is called to show keyboard tips for the commandbar.

Parameters
pCommandBar | Owner of keyboard tips.
nLevel | Keyboard tip level (for RibbonBar).
See also
HideKeyboardTips

◆ ToggleVisible()

void ToggleVisible ( int nIndex )

Call this member to show/hide the toolbar.

Parameters
nIndex Index of the toolbar to show or hide.

◆ TrackPopupMenu() [1/3]

static BOOL AFX_CDECL TrackPopupMenu | ( | CMenu * | pMenu,
 |  | UINT | nFlags,
 |  | int | xPos,
 |  | int | yPos,
 |  | CWnd * | pWnd,
 |  | LPCRECT | rcExclude = NULL,
 |  | CWnd * | pWndOwner = NULL,
 |  | CXTPCommandBars * | pCommandBars = NULL )
 static

Call this member to display a floating pop-up menu at the specified location.

Parameters
pMenu | Menu to be popped up.
nFlags | Reserved, currently not used.
xPos | Specifies the horizontal position in screen coordinates of the pop-up menu.
yPos | Specifies the vertical position in screen coordinates of the top of the menu on the screen.
pWnd | Identifies the window that owns the pop-up menu. This window receives all WM_COMMAND messages from the menu.
rcExclude | Reserved, currently not used.
pWndOwner | Pointer to a CWnd object.
pCommandBars | Pointer to a CXTPCommandBars object. screen the menu should not overlap. This parameter can be NULL.
Returns
TRUE if successful; otherwise FALSE.

Example:

void CCustomThemesView::OnRButtonDown(UINT nFlags, CPoint point)
{
   ClientToScreen(&point);

   CMenu menu;
   VERIFY(XTPResourceManager()->LoadMenu(&menu, IDR_MAINFRAME));

   // get a pointer to the application window.
   CXTPMDIFrameWnd* pMainWnd = DYNAMIC_DOWNCAST(
   CXTPMDIFrameWnd, AfxGetMainWnd());

   if (!pMainWnd)
      return;

   // get a pointer to the CXTPCommandBars object.
   CXTPCommandBars* pCommandBars = pMainWnd->GetCommandBars();

   if (!pCommandBars)
      return;

   // display context menu.
   CXTPCommandBars::TrackPopupMenu(&menu, TPM_RIGHTBUTTON,
   point.x, point.y, pMainWnd, 0, 0, pCommandBars);
}

◆ TrackPopupMenu() [2/3]

static BOOL AFX_CDECL TrackPopupMenu | ( | CXTPPopupBar * | pPopupBar,
 |  | UINT | nFlags,
 |  | int | xPos,
 |  | int | yPos,
 |  | CWnd * | pWnd,
 |  | LPCRECT | rcExclude = NULL,
 |  | CWnd * | pWndOwner = NULL )
 static

Call this member to display a floating pop-up menu at the specified location.

Parameters
nFlags | Reserved, currently not used.
xPos | Specifies the horizontal position in screen coordinates of the pop-up menu.
yPos | Specifies the vertical position in screen coordinates of the top of the menu on the screen.
pPopupBar | Pointer to a CXTPPopupBar object.
pWnd | Identifies the window that owns the pop-up menu. This window receives all WM_COMMAND messages from the menu.
rcExclude | Reserved, currently not used.
pWndOwner | Pointer to a CWnd object. screen the menu should not overlap. This parameter can be NULL.
Returns
TRUE if successful; otherwise FALSE.

Example:

void CCustomThemesView::OnRButtonDown(UINT nFlags, CPoint point)
{
        ClientToScreen(&point);

        CMenu menu;
        VERIFY(XTPResourceManager()->LoadMenu(&menu, IDR_MAINFRAME));

        // get a pointer to the application window.
        CXTPMDIFrameWnd* pMainWnd = DYNAMIC_DOWNCAST(
        CXTPMDIFrameWnd, AfxGetMainWnd());

        if (!pMainWnd)
            return;

        // get a pointer to the CXTPCommandBars object.
        CXTPCommandBars* pCommandBars = pMainWnd->GetCommandBars();

        if (!pCommandBars)
            return;

        // display context menu.
        CXTPCommandBars::TrackPopupMenu(&menu, TPM_RIGHTBUTTON,
        point.x, point.y, pMainWnd, 0, 0, pCommandBars);
}

◆ TrackPopupMenu() [3/3]

BOOL TrackPopupMenu | ( | UINT | nBarID,
 |  | UINT | nFlags,
 |  | int | xPos,
 |  | int | yPos,
 |  | LPCRECT | rcExclude = NULL )

Call this member to display a floating pop-up menu at the specified location.

Parameters
nFlags | Reserved, currently not used.
xPos | Specifies the horizontal position in screen coordinates of the pop-up menu.
yPos | Specifies the vertical position in screen coordinates of the top of the menu on the screen.
rcExclude | Reserved, currently not used.
nBarID | Identifier CommandBar to track.
Returns
TRUE if successful; otherwise FALSE.

Example:

void CCustomThemesView::OnRButtonDown(UINT nFlags, CPoint point)
{
        ClientToScreen(&point);

        CMenu menu;
        VERIFY(XTPResourceManager()->LoadMenu(&menu, IDR_MAINFRAME));

        // get a pointer to the application window.
        CXTPMDIFrameWnd* pMainWnd = DYNAMIC_DOWNCAST(
        CXTPMDIFrameWnd, AfxGetMainWnd());

        if (!pMainWnd)
            return;

        // get a pointer to the CXTPCommandBars object.
        CXTPCommandBars* pCommandBars = pMainWnd->GetCommandBars();

        if (!pCommandBars)
            return;

        // display context menu.
        CXTPCommandBars::TrackPopupMenu(&menu, TPM_RIGHTBUTTON,
        point.x, point.y, pMainWnd, 0, 0, pCommandBars);
}

◆ TrackPopupMenuEx()

BOOL TrackPopupMenuEx | ( | CMenu * | pMenu,
 |  | UINT | nFlags,
 |  | int | xPos,
 |  | int | yPos,
 |  | CWnd * | pWndOwner = NULL,
 |  | LPTPMPARAMS | lptpm = NULL )

Call this member to display a floating pop-up menu at the specified location.

Parameters
pMenu | Menu to be popped up.
nFlags | Reserved, currently not used.
xPos | Specifies the horizontal position in screen coordinates of the pop-up menu.
yPos | Specifies the vertical position in screen coordinates of the top of the menu on the screen.
pWndOwner | Pointer to a CWnd object.
lptpm | Pointer to a TPMPARAMS structure that specifies an area of the screen the menu should not overlap. This parameter can be NULL.
Returns
TRUE if successful; otherwise FALSE.

Example:

void CCustomThemesView::OnRButtonDown(UINT nFlags, CPoint point)
{
        ClientToScreen(&point);

        CMenu menu;
        VERIFY(XTPResourceManager()->LoadMenu(&menu, IDR_MAINFRAME));

        // get a pointer to the application window.
        CXTPMDIFrameWnd* pMainWnd = DYNAMIC_DOWNCAST(
        CXTPMDIFrameWnd, AfxGetMainWnd());

        if (!pMainWnd)
            return;

        // get a pointer to the CXTPCommandBars object.
        CXTPCommandBars* pCommandBars = pMainWnd->GetCommandBars();

        if (!pCommandBars)
            return;

        // display context menu.
        CXTPCommandBars::TrackPopupMenu(&menu, TPM_RIGHTBUTTON,
        point.x, point.y, pMainWnd, 0, 0, pCommandBars);
}
The documentation for this class was generated from the following file:
  • XTPCommandBars.h


Toolkit Pro: CXTPCommandBars::KEYBOARDTIPS Struct Reference

  • CXTPCommandBars
  • KEYBOARDTIPS
Public Attributes | List of all members
CXTPCommandBars::KEYBOARDTIPS Struct Reference

Keyboard tips information. More...

Public Attributes

CArray< CXTPCommandBarKeyboardTip *, CXTPCommandBarKeyboardTip * > | arr
Keyboard tips collection.
int | nLevel
Keyboard tip level (for RibbonBar)
int | nKey
Keys was pressed already.

Detailed Description

Keyboard tips information.

The documentation for this struct was generated from the following file:
  • XTPCommandBars.h


Toolkit Pro: CXTPCommandBarsContextMenus Class Reference

Public Member Functions | List of all members
CXTPCommandBarsContextMenus Class Reference

CXTPCommandBarsContextMenus is CXTPCommandBarList derived class which represents a collection of context menus. More...

Inheritance diagram for CXTPCommandBarsContextMenus:
[legend]

Public Member Functions

CXTPCommandBarsContextMenus (CXTPCommandBars *pCommandBars)
Constructs a CXTPCommandBarsContextMenus object.
CXTPCommandBar * | Add (UINT nIDBar)
Call this method to add a new context menu to the collection.
CXTPCommandBar * | Add (UINT nIDBar, UINT nIDMenuResource, int nSubMenu)
Call this method to add a new context menu to the collection.
CXTPCommandBar * | Add (CXTPCommandBar *pCommandBar)
Call this method to add a new context menu to the collection.
CXTPCommandBar * | Add (UINT nIDBar, LPCTSTR lpszTitle, CMenu *pSubMenu)
Call this method to add a new context menu to the collection.
- Public Member Functions inherited from CXTPCommandBarList
CXTPCommandBarList (CXTPCommandBars *pCommandBars)
Constructs a CXTPCommandBarList object.
virtual | ~CXTPCommandBarList ()
Destroys a CXTPCommandBarList object, handles cleanup and deallocation.
CXTPCommandBar * | FindCommandBar (UINT nBarID) const
Call this method to find the command bar with the specified identifier.
CXTPCommandBars * | GetCommandBars () const
Call this method to get the CXTPCommandBars parent object attached to the list.
CXTPCommandBar * | GetAt (int nIndex) const
Call this method to get the command bar at the specified index in the list.
int | GetCount () const
Call this method to get the number of command bars in the list.
BOOL | Lookup (CXTPCommandBar *pCommandBar) const
Call this method to check if a specified command bar is in the list.
void | RemoveAll ()
Call this method to remove all command bars from the list.
void | Remove (CXTPCommandBar *pCommandBar)
Call this method to remove a specified command bar from the list.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Attributes inherited from CXTPCommandBarList
CXTPCommandBars * | m_pCommandBars
Parent CXTPCommandBars object.
CArray< CXTPCommandBar *, CXTPCommandBar * > | m_arrBars
Array of CommandBars.

Detailed Description

CXTPCommandBarsContextMenus is CXTPCommandBarList derived class which represents a collection of context menus.

Constructor & Destructor Documentation

◆ CXTPCommandBarsContextMenus()

CXTPCommandBarsContextMenus ( CXTPCommandBars * pCommandBars )

Constructs a CXTPCommandBarsContextMenus object.

Parameters
pCommandBars Pointer to the CXTPCommandBars parent object.

Member Function Documentation

◆ Add() [1/4]

CXTPCommandBar * Add ( CXTPCommandBar * pCommandBar )
virtual

Call this method to add a new context menu to the collection.

Parameters
pCommandBar Command bar to be added.
Returns
Pointer to the newly added context menu.

Reimplemented from CXTPCommandBarList.

◆ Add() [2/4]

CXTPCommandBar * Add ( UINT nIDBar )

Call this method to add a new context menu to the collection.

Parameters
nIDBar Menu resource identifier.
Returns
Pointer to the newly added context menu.

◆ Add() [3/4]

CXTPCommandBar * Add | ( | UINT | nIDBar,
 |  | LPCTSTR | lpszTitle,
 |  | CMenu * | pSubMenu )

Call this method to add a new context menu to the collection.

Parameters
nIDBar | Menu resource identifier.
lpszTitle | Caption of context menu.
pSubMenu | Context menu to convert.
Returns
Pointer to the newly added context menu.

◆ Add() [4/4]

CXTPCommandBar * Add | ( | UINT | nIDBar,
 |  | UINT | nIDMenuResource,
 |  | int | nSubMenu )

Call this method to add a new context menu to the collection.

Parameters
nIDBar | Menu resource identifier.
nSubMenu | Index of submenu to add.
nIDMenuResource | Menu resource ID.
Returns
Pointer to the newly added context menu.
The documentation for this class was generated from the following file:
  • XTPCommandBarsContextMenus.h


Toolkit Pro: CXTPCommandBarScrollBarCtrl Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPCommandBarScrollBarCtrl Class Reference

CXTPCommandBarScrollBarCtrl is a CScrollBar derived class. More...

Inheritance diagram for CXTPCommandBarScrollBarCtrl:
[legend]

Public Member Functions

CXTPCommandBarScrollBarCtrl ()
Constructs a CXTPCommandBarScrollBarCtrl object.
virtual | ~CXTPCommandBarScrollBarCtrl ()
Destroys a CXTPCommandBarScrollBarCtrl object, handles cleanup and deallocation.
void | SetCommandBars (CXTPCommandBars *pCommandBars)
Call this member to set the command bars object.
- Public Member Functions inherited from CXTPScrollBarCtrl
CXTPScrollBarCtrl ()
Constructs a CXTPScrollBarCtrl object.
virtual | ~CXTPScrollBarCtrl ()
Destroys a CXTPScrollBarCtrl object, handles cleanup and deallocation.
void | SetTheme (XTPScrollBarTheme theme)
Sets the scrollbar theme.
virtual void | RefreshMetrics ()
This member is called to update color, text and other visual elements of the control.
virtual void | GetScrollInfo (SCROLLINFO *psi)
The GetScrollInfo function retrieves the parameters of a scroll bar, including the minimum and maximum scrolling positions, the page size, and the position of the scroll box (thumb)
- Public Member Functions inherited from CXTPScrollBase
CXTPScrollBase ()
Constructs a CXTPScrollBase object.
virtual | ~CXTPScrollBase ()
Destroys a CXTPScrollBase object, handles cleanup and deallocation.
void | SetScrollBarStyle (XTPScrollBarStyle scrollStyle)
Call this method to set the style of the scrollbar.
XTPScrollBarStyle | GetScrollBarStyle () const
Call this method to get the style of the scrollbar.
XTP_SCROLLBAR_TRACKINFO * | GetScrollBarTrackInfo () const
Call this method to get XTP_SCROLLBAR_TRACKINFO information.
XTP_SCROLLBAR_POSINFO * GetScrollBarPosInfo ()
Call this method to get XTP_SCROLLBAR_POSINFO information.
virtual CWnd * | GetParentWindow () const =0
Retrieves parent window of scrollbar.
int | HitTestScrollBar (POINT pt) const
Call this method to check ScrollBar part under pointer.
CRect | GetScrollBarPartRect (int nPart) const
Gets the bounding rectangle of a specified part of the scrollbar.
void | PerformTrackInit (HWND hWnd, CPoint point, XTP_SCROLLBAR_POSINFO *pSBInfo, BOOL bDirect)
Call this method to start scrollbar tracking.
XTP_SLIDERTICKS * | GetTicks () const
Gets the ticks in the slider.
void | SetTicks (double *pTicks, int nCount)
Call this method to set ticks for the slider.
HBRUSH | GetCltColor (CDC *pDC) const
Call this method to get the scroll bar control color.
BOOL | IsSlider () const
Call this member function to determine if the scrollbar is a slider control.
virtual BOOL | IsScrollBarEnabled () const =0
Determines if the scrollbar is enabled.
virtual CRect | GetScrollBarRect ()=0
Obtains the rectangle occupied by the scrollbar in client coordinates.
virtual void | RedrawScrollBar ()=0
Forces the scrollbar to redraw itself.

Protected Member Functions

virtual CXTPScrollBarPaintManager * | GetScrollBarPaintManager () const
Obtains a pointer to the associated scrollbar paint manager.
- Protected Member Functions inherited from CXTPScrollBarCtrl
void | Init ()
This member function is called from OnInitDialog or OnInitialUpdate to initialize the control.
XTP_SCROLLBAR_TRACKINFO * GetScrollBarTrackInfo ()
Call this method to get XTP_SCROLLBAR_TRACKINFO information.
XTP_SCROLLBAR_POSINFO * GetScrollBarPosInfo ()
Call this method to get XTP_SCROLLBAR_POSINFO information.

Protected Attributes

CXTPCommandBars * | m_pCommandBars
Parent CommandBars object.
- Protected Attributes inherited from CXTPScrollBarCtrl
BOOL | m_bPreSubclassInit
TRUE is sub-classed.
- Protected Attributes inherited from CXTPScrollBase
XTP_SCROLLBAR_POSINFO | m_spi
ScrollBar position.
XTP_SCROLLBAR_TRACKINFO * | m_pSBTrack
ScrollBar tracking.
XTP_SLIDERTICKS * | m_pTicks
Slider Ticks.
XTPScrollBarStyle | m_scrollBarStyle
ScrollBar style.
BOOL | m_bAnimation
TRUE if animation enabled.
int | m_nTimerElapse
Scroll delay.

Detailed Description

CXTPCommandBarScrollBarCtrl is a CScrollBar derived class.

Member Function Documentation

◆ GetScrollBarPaintManager()

virtual CXTPScrollBarPaintManager * GetScrollBarPaintManager ( ) const
protectedvirtual

Obtains a pointer to the associated scrollbar paint manager.

Returns
A pointer to the associated scrollbar paint manager

Reimplemented from CXTPScrollBarCtrl.

◆ SetCommandBars()

AFX_INLINE void SetCommandBars ( CXTPCommandBars * pCommandBars )

Call this member to set the command bars object.

Parameters
pCommandBars CXTPCommandBars to be set.
The documentation for this class was generated from the following file:
  • XTPCommandBarScrollBarCtrl.h


Toolkit Pro: CXTPCommandBarsFrameHook Class Reference

Public Member Functions | Public Attributes | Static Public Attributes | Protected Member Functions | Protected Attributes | List of all members
CXTPCommandBarsFrameHook Class Reference

CXTPCommandBarsFrameHook is a CXTPHookManagerHookAble derived class. More...

Inheritance diagram for CXTPCommandBarsFrameHook:
[legend]

Public Member Functions

CXTPCommandBarsFrameHook ()
Constructs a CXTPCommandBarsFrameHook object.
~CXTPCommandBarsFrameHook ()
Destroys a CXTPCommandBarsFrameHook object, handles cleanup and deallocation.
void | EnableFrameTheme (CXTPCommandBars *pCommandBars)
Call this method to enable frame theming.
void | EnableFrameTheme (CWnd *pSite, CXTPPaintManager *pPaintManager)
Call this method to enable frame theming.
void | EnableFrameTheme (CWnd *pSite, CXTPCommandBars *pCommandBars)
Call this method to enable frame theming.
void | DisableFrameTheme ()
Call this method to disable frame theming.
CWnd * | GetSite () const
CXTPPaintManager * | GetPaintManager () const
CXTPFramePaintManager * | GetFramePaintManager () const
Call this method to retrieve the paint manager of the frame.
BOOL | IsCaptionVisible () const
Determines if caption of skinned window is visible.
BOOL | IsFrameActive () const
Determines if Skinned window is active.
void | RecalcFrameLayout ()
Recalculates borders and region of frame.
void | DelayRecalcFrameLayout ()
Recalculates borders and region of frame with small delay.
void | RedrawRibbonBar ()
Redraw ribbon bar if found.
void | RedrawMenuTitleBar ()
Redraw MenuTitleBar bar if found.
void | RedrawFrame ()
Redraws frame of skinned window.
BOOL | IsFrameHasStatusBar (int *pnStatusHeight=NULL) const
Determines if frame has skinned scrollbar to draw rounded rects.
BOOL | IsMDIMaximized () const
Determines if frame is maximized child window.
CXTPControls * | GetCaptionButtons () const
Returns collection of caption buttons.
int | GetCaptionHeight () const
Calculates height of caption.
CRect | CalcFrameBorder () const
Calculates size of frame borders.
BOOL | IsDwmEnabled () const
Determines if Vista AERO theme is enabled.
void | DisableDwm ()
Disables Vista AERO theme.
DWORD | GetSiteStyle () const
Returns style of site window.
DWORD | GetSiteExStyle () const
Returns extended style of site window.
void | DrawRibbonFramePart (CDC *pDC)
This method is called to draw the ribbon frame if EnableFrameTheme was not called.
void | UpdateDwmClientArea ()
Updates the invalidated portions of the DWM client area.
BOOL | EnableShadow ()
Enables the previously disabled frame shadow.
void | DisableShadow ()
Disables frame shadow if enabled.
CXTPFrameShadow * | GetShadow () const
Obtains frame shadow pointer.
- Public Member Functions inherited from CXTPHookManagerHookAble
CXTPHookManagerHookAble ()
Constructs a CXTPHookManagerHookAble object.
virtual | ~CXTPHookManagerHookAble ()
Destroys a CXTPHookManagerHookAble object, handles cleanup and deallocation.
virtual int | OnPostHookMessage (HWND hWnd, UINT nMessage, WPARAM &wParam, LPARAM &lParam, LRESULT &lResult)
This member function is called after a message has been processed by default window procedure.
virtual void | OnHookAttached (HWND hWnd)
This member function is called right after a hook is attached to the window.
virtual void | OnHookDetached ()
This member function is called right before a hook is to be detached from the window.

Public Attributes

BOOL | m_bLockNCPaint
TRUE to disable repaint of non-client area.
- Public Attributes inherited from CXTPHookManagerHookAble
BOOL | m_bAutoDestroy
TRUE to automatically delete hook.

Static Public Attributes

static UINT m_nMsgQueryFrameHook
Helper message to determine if Hook was attached.

Protected Member Functions

virtual int | OnHookMessage (HWND hWnd, UINT nMessage, WPARAM &wParam, LPARAM &lParam, LRESULT &lResult)
This member function is called by WindowProc, or is called during message reflection.
virtual void | OnUpdateMDIChildrenTheme ()
Gets invoked for MDI children windows as a result to call to CXTPMDIFrameWnd::UpdateMDIChildrenTheme.

Protected Attributes

HWND | m_hwndSite
Skinned window handle

CXTPRibbonBar * | m_pRibbonBar
Child Ribbonbar object

CXTPMenuTitleBar * | m_pMenuTitleBar
Child MenuTitleBar object.
CXTPCommandBars * | m_pCommandBars
Attached commandbars object

CXTPPaintManager * | m_pPaintManager
PaintManager used to draw frame.
BOOL | m_bUseGlobalPaintManager
If TRUE, a global paint manager has to be used to draw frame.
BOOL | m_bActive
TRUE if frame is active

CSize | m_szFrameRegion
Previous size of window

BOOL | m_bDelayReclalcLayout
TRUE to recalculate layout after small delay

CXTPControls * | m_pCaptionButtons
Caption buttons

CXTPControl * | m_pSelected
Selected caption button

BOOL | m_bButtonPressed
Pressed caption button

BOOL | m_bThemeFrameEnabled
TRUE if skinning is enabled

BOOL | m_bInUpdateFrame
TRUE if UpdateFrame method is executed

BOOL | m_bDwmEnabled
TRUE if Vista AERO theme is enabled

BOOL | m_bBeingDestructed
TRUE if class instance is being destructed

CXTPFrameShadow * m_pShadow
Optional.

Detailed Description

CXTPCommandBarsFrameHook is a CXTPHookManagerHookAble derived class.

It is a helper for Office 2007 window skinning.

Member Function Documentation

◆ CalcFrameBorder()

CRect CalcFrameBorder ( ) const

Calculates size of frame borders.

Returns
Size of frame borders in pixels
See also
GetCaptionHeight

◆ DisableShadow()

void DisableShadow ( )

Disables frame shadow if enabled.

See also
EnableShadow, GetShadow

◆ DrawRibbonFramePart()

void DrawRibbonFramePart ( CDC * pDC )

This method is called to draw the ribbon frame if EnableFrameTheme was not called.

Parameters
pDC Pointer to a valid device context.

◆ EnableFrameTheme() [1/3]

void EnableFrameTheme | ( | CWnd * | pSite,
 |  | CXTPCommandBars * | pCommandBars )

Call this method to enable frame theming.

Parameters
pSite | Window to theme
pCommandBars | Parent CommandBars object

◆ EnableFrameTheme() [2/3]

void EnableFrameTheme | ( | CWnd * | pSite,
 |  | CXTPPaintManager * | pPaintManager )

Call this method to enable frame theming.

Parameters
pSite | Window to theme
pPaintManager | Paint manager used to theme window

◆ EnableFrameTheme() [3/3]

void EnableFrameTheme ( CXTPCommandBars * pCommandBars )

Call this method to enable frame theming.

Parameters
pCommandBars Parent CommandBars object

◆ EnableShadow()

BOOL EnableShadow ( )

Enables the previously disabled frame shadow.

Returns
TRUE if a shadow has been successfully enabled, otherwise FALSE.
See also
DisableShadow, GetShadow

◆ GetCaptionButtons()

AFX_INLINE CXTPControls * GetCaptionButtons ( ) const

Returns collection of caption buttons.

Returns
Collection of caption buttons.

◆ GetCaptionHeight()

int GetCaptionHeight ( ) const

Calculates height of caption.

Returns
Height of caption in pixels
See also
GetFrameBorder

◆ GetFramePaintManager()

CXTPFramePaintManager * GetFramePaintManager ( ) const

Call this method to retrieve the paint manager of the frame.

Returns
A pointer to a CXTPPaintManager object.

◆ GetPaintManager()

CXTPPaintManager * GetPaintManager ( ) const
Returns
Returns Paint Manager used to skin window

◆ GetShadow()

CXTPFrameShadow * GetShadow ( ) const

Obtains frame shadow pointer.

Returns
A valid frame shadow pointer if frame shadow is supported and enabled, otherwise the return value is NULL.
See also
EnableShadow, DisableShadow

◆ GetSite()

AFX_INLINE CWnd * GetSite ( ) const
Returns
Returns Skinned window

◆ GetSiteExStyle()

DWORD GetSiteExStyle ( ) const

Returns extended style of site window.

Returns
Extended style of site window.

◆ GetSiteStyle()

DWORD GetSiteStyle ( ) const

Returns style of site window.

Returns
Style of site window.

◆ IsCaptionVisible()

BOOL IsCaptionVisible ( ) const

Determines if caption of skinned window is visible.

Returns
True if visible, false if not

◆ IsDwmEnabled()

AFX_INLINE BOOL IsDwmEnabled ( ) const

Determines if Vista AERO theme is enabled.

Returns
TRUE if Vista AERO theme is enabled

◆ IsFrameActive()

AFX_INLINE BOOL IsFrameActive ( ) const

Determines if Skinned window is active.

Returns
True if active, false if not

◆ IsFrameHasStatusBar()

BOOL IsFrameHasStatusBar ( int * pnStatusHeight = NULL ) const

Determines if frame has skinned scrollbar to draw rounded rects.

Parameters
pnStatusHeight Height of status bar to return.
Returns
TRUE if frame has skinned status bar.
See also
IsMDIMaximized

◆ IsMDIMaximized()

BOOL IsMDIMaximized ( ) const

Determines if frame is maximized child window.

Returns
TRUE if frame is maximized child window.

◆ OnHookMessage()

virtual int OnHookMessage | ( | HWND | hWnd,
 |  | UINT | nMessage,
 |  | WPARAM & | wParam,
 |  | LPARAM & | lParam,
 |  | LRESULT & | lResult )
 protectedvirtual

This member function is called by WindowProc, or is called during message reflection.

Parameters
hWnd | Window handle that the message belongs to.
nMessage | Specifies the message to be sent.
wParam | Specifies additional message-dependent information.
lParam | Specifies additional message-dependent information.
lResult | The return value of WindowProc. Depends on the message; may be NULL.
Returns
TRUE if message was processed.

Reimplemented from CXTPHookManagerHookAble.

◆ RedrawFrame()

void RedrawFrame ( )

Redraws frame of skinned window.

See also
RedrawRibbonBar

◆ RedrawMenuTitleBar()

void RedrawMenuTitleBar ( )

Redraw MenuTitleBar bar if found.

See also
MenuTitleBar

◆ RedrawRibbonBar()

void RedrawRibbonBar ( )

Redraw ribbon bar if found.

See also
RedrawFrame

Member Data Documentation

◆ m_pShadow

CXTPFrameShadow* m_pShadow
mutableprotected

Optional.

Frame shadow pointer.

The documentation for this class was generated from the following file:
  • XTPFrameHook.h


Toolkit Pro: CXTPCommandBarsModernUITheme Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPCommandBarsModernUITheme Class Reference

The CXTPCommandBarsModernUITheme class is the base class for the Modern UI themes for Command Bars. More...

Inheritance diagram for CXTPCommandBarsModernUITheme:
[legend]

Public Member Functions

CXTPCommandBarsModernUITheme ()
Constructs a CXTPCommandBarsModernUITheme object.
virtual | ~CXTPCommandBarsModernUITheme ()
Destroys a CXTPCommandBarsModernUITheme object, handles cleanup and deallocation.
virtual CXTPFramePaintManager * | GetFramePaintManager ()
Returns paint manager used to draw frames.
virtual CXTPRibbonPaintManager * | GetRibbonPaintManager ()
Retrieves the ribbon paint manager.
virtual CXTPMarkupContext * | GetMarkupContext ()
Retrieves a pointer to the markup context.
- Public Member Functions inherited from CXTPCommandBarsOfficeXPTheme
CXTPCommandBarsOfficeXPTheme ()
Constructs a CXTPCommandBarsOfficeXPTheme object.
virtual void | FillCommandBarEntry (CDC *pDC, CXTPCommandBar *pBar)
This method is called to fill the command bar's face.
virtual COLORREF | GetRectangleTextColor (BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition)
This method retrieves a buttons text color.
virtual CSize | DrawCommandBarGripper (CDC *pDC, CXTPCommandBar *pBar, BOOL bDraw=TRUE)
This method is called to draw the command bar's gripper.
virtual CSize | DrawCommandBarSeparator (CDC *pDC, CXTPCommandBar *pBar, CXTPControl *pControl, BOOL bDraw=TRUE)
This method is called to draw a command bar's separator.
virtual CSize | DrawListBoxControl (CDC *pDC, CXTPControl *pButton, CRect rc, BOOL bSelected, BOOL bDraw, CXTPCommandBars *pCommandBars=0)
This method is called to draw the control placed on the ListBox.
virtual void | AdjustExcludeRect (CRect &rc, CXTPControl *pControl, BOOL bVertical)
This method is called to determine the offset of a pop-up bar.
virtual CSize | DrawTearOffGripper (CDC *pDC, CRect rcGripper, BOOL bSelected, BOOL bDraw)
This method is called to draw a tear-off gripper of a pop-up bar.
virtual void | DrawPopupResizeGripper (CDC *pDC, CRect rcGripper, int nFlags)
This method is called to draw a resize gripper of a pop-up bar.
virtual CSize | DrawDialogBarGripper (CDC *pDC, CXTPDialogBar *pBar, BOOL bDraw)
Call this member to draw the gripper of a dialog bar.
- Public Member Functions inherited from CXTPPaintManager
virtual void | SetImageHandle (HMODULE hResource, LPCTSTR lpszIniFileName)
Specifies the resource that contains the bitmaps to be loaded for the theme.
CSize | DrawControl (CDC *pDC, CXTPControl *pButton, BOOL bDraw=TRUE)
This method is called to draw the control.
virtual CSize | DrawControlToolBarParent (CDC *pDC, CXTPControl *pButton, BOOL bDraw)
This method is called to draw the control placed on the toolbar.
virtual COLORREF | GetControlEditBackColor (CXTPControl *pControl)
This method returns the edit control back color to draw.
virtual void | DrawControlEntry (CDC *pDC, CXTPControl *pButton)
This method is called to fill the control's face.
virtual COLORREF | GetControlTextColor (CXTPControl *pButton)
Call this method to get the control text color to draw.
virtual COLORREF | GetControlBackColor (CXTPControl *pButton)
Call this method to get the control back color to draw.
virtual void | DrawGalleryItemBack (CDC *pDC, CRect rcItem, BOOL bEnabled, BOOL bSelected, BOOL bPressed, BOOL bChecked, XTPBarType barType)
This method is called to draw the background for a gallery menu item.
virtual void | DrawCommandBarGroupSeparator (CDC *pDC, CXTPCommandBar *pBar, CXTPControl *pLeftControl, CXTPControl *pRightControl, BOOL bDraw=TRUE)
This method is called to draw a command bar's group separator.
virtual void | FillDockBar (CDC *pDC, CXTPDockBar *pBar)
This method is called to fill a dock bar.
virtual void | FillWorkspace (CDC *pDC, CRect rc, CRect rcExclude)
This method is called to fill a workspace.
int | GetShadowOptions () const
Determines the kind of shadow to use.
virtual void | DrawExpandGlyph (CDC *pDC, CXTPControl *pButton, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clr)
Draw expand or hidden glyphs for a button.
virtual void | DrawExpandGlyph (CDC *pDC, CXTPControl *pButton, COLORREF clr, BOOL bVertical)
Draw expand or hidden glyphs for a button.
virtual void | DrawHiddenGlyph (CDC *pDC, CXTPControl *pButton, COLORREF clr, BOOL bVertical)
Draw expand or hidden glyphs for a button.
virtual CSize | DrawSpecialControl (CDC *pDC, XTPSpecialControl controlType, CXTPControl *pButton, CXTPCommandBar *pBar, BOOL bDraw, LPVOID lpParam)
This method is called to draw the specified controls.
virtual CRect | GetCommandBarBorders (CXTPCommandBar *pBar)
This method is called to retrieve the command bar's borders.
virtual CRect | GetSplitButtonCommandRect (CXTPControl *pButton)
Determines split button command rectangle.
virtual void | SetCommandBarRegion (CXTPCommandBar *pCommandBar)
Call this method to set the bounding region of a pop-up bar.
XTPPaintTheme GetCurrentTheme ()
Call this member to get the current visual theme.
virtual BOOL | RequiresResourceImages ()
Used by the paint manager to determine if the theme requires a resource DLL to load image and color information.
virtual CFont * | GetControlFont (CXTPControl *pControl)
Call this member to retrieve the font of the command bar control.
virtual CFont * | GetCommandBarFont (CXTPCommandBar *pCommandBar)
Call this member to retrieve the font of the command bar.
virtual XTPBarTextOrientation | GetControlTextOrientation (CXTPControl *pControl)
Call this member to determine how to draw text.
virtual void | UpdateFonts ()
Refreshes the fonts to use.
virtual void | UpdateColors ()
Refreshes the standard colors to use.
void | SetCommandBarsFontIndirect (LOGFONT *pLogFont, BOOL bUseStandardFont=FALSE)
Call this member to set command bar's font.
CFont * | GetRegularFont ()
Returns the general font.
CFont * | GetRegularBoldFont ()
Returns the general bold font.
CFont * | GetIconFont ()
Returns the icon font.
CFont * | GetSmCaptionFont ()
Call this method to retrieve the caption of a floating mini frame.
void | UseOfficeFont (bool bUseOfficeFont)
Call this method to use Tahoma font despite system metrics.
int | GetControlHeight () const
This method returns the common controls height.
virtual CSize | GetDefaultCommandBarSize (CXTPCommandBar *pBar)
Computes default command bar size taking into account command bar font.
void | Rectangle (CDC *pDC, LPCRECT rc, int nPen, const int nBrush)
Draws a rectangle.
void | Rectangle (CDC *pDC, LPCRECT rc, COLORREF clrPen, COLORREF clrBrush)
Draws a rectangle.
void | RoundRect (CDC *pDC, LPCRECT rc, COLORREF clrPen, COLORREF clrBrush)
Draws a rectangle.
void | Draw3dRect (CDC *pDC, LPCRECT rc, int nTopLeft, int nBottomRight)
Call this member function to draw a three-dimensional rectangle.
void | Draw3dRect (CDC *pDC, LPCRECT rc, int frameThickness, COLORREF clrPen, COLORREF clrBrush)
Call this member function to draw a rectangle with predetermined thickness.
virtual void | DrawPopupBarCheckMark (CDC *pDC, CRect rcCheck, BOOL bEnabled, COLORREF clr)
Call this member function to draw a check mark.
void | DrawCheckMark (CDC *pDC, CRect rcCheck, COLORREF clr=0)
Call this member function to draw a check mark.
virtual void | DrawPopupBarRadioMark (CDC *pDC, CRect rcCheck, BOOL bEnabled, COLORREF clr)
Call this member function to draw a radio button.
virtual void | DrawComboExpandMark (CDC *pDC, CRect rc, COLORREF clr)
Call this member function to draw a combobox expand symbol.
virtual void | DrawControlMDIButton (CDC *pDC, CXTPControlButton *pButton)
Call this member function to draw menu MDI buttons.
void | Line (CDC *pDC, CPoint p0, CPoint p1)
Draws a line.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1, const int nPen)
Draws a line.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1, COLORREF clrPen)
Draws a line.
void | HorizontalLine (CDC *pDC, int x0, int y0, int x1, COLORREF clrPen)
Call this member function to draw a horizontal line using the specified coordinages and RGB color value.
void | VerticalLine (CDC *pDC, int x0, int y0, int y1, COLORREF clrPen)
Call this member function to draw a vertical line using the specified coordinages and RGB color value.
virtual void | DrawDropDownGlyph (CDC *pDC, CXTPControl *pControl, CPoint pt, BOOL bSelected, BOOL bPopuped, BOOL bEnabled, BOOL bVert)
This member function is called to draw a split button expand symbol.
void | Pixel (CDC *pDC, int xPos, int yPos, int nPen)
Sets the pixel at the point.
void | GradientFill (CDC *pDC, LPRECT lpRect, COLORREF crFrom, COLORREF crTo, BOOL bHorz, LPCRECT lpRectClip=NULL)
Gradient fills the rectangle.
XTP_COMMANDBARS_ICONSINFO * GetIconsInfo ()
virtual void | Animate (CDC *pDestDC, CDC *pSrcDC, CRect rc, XTPAnimationType animationType)
This method is called to animate the pop-up bar.
virtual void | AnimateExpanding (CXTPCommandBar *pCommandBar, CDC *pDestDC, CDC *pSrcDC, BOOL bExpandDown)
This method is called to animate the expanding process.
void | SetAnimationDelay (int nAnimationSteps, int nAnimationTime)
Call this method to set animation delay.
COLORREF | GetXtremeColor (UINT nIndex)
This function retrieves the current color of the specified XP display element.
void | SetColors (int cElements, CONST INT *lpaElements, CONST COLORREF *lpaRgbValues)
Call this member to set the colors for each element to the color in the specified color array.
CSize | DrawControlText (CDC *pDC, CXTPControl *pControl, CRect rcText, BOOL bDraw, BOOL bVert, BOOL bCentered, BOOL bTriangled)
This method is called to draw control text.
virtual void | UpdateRTLCaption (CString &strCaption)
This method is called to prepare a caption for Right-To-Left draw.
XTPCurrentSystemTheme GetCurrentSystemTheme ()
Call this member function to determine the current Windows XP theme in use.
void | SetLunaTheme (XTPCurrentSystemTheme systemTheme)
Call this method to force system theme.
virtual int | GetPopupBarGripperWidth (CXTPCommandBar *pBar)
Calculates the gripper of a pop-up bar.
virtual CXTPControlGalleryPaintManager * | GetGalleryPaintManager () const
Retrieves paint manager used to draw galleries.
virtual CXTPScrollBarPaintManager * | GetScrollBarPaintManager () const
Retrieves paint manager used to draw scrollbars.
virtual CXTPSliderPaintManager * | GetSliderPaintManager () const
Retrieves paint manager used to draw slider panes.
virtual CXTPProgressPaintManager * | GetProgressPaintManager () const
Retrieves paint manager used to draw progress bars.
virtual CXTPStatusBarPaintManager * | GetStatusBarPaintManager ()
Retrieves paint manager used to draw the status bar.
virtual CXTPMessageBarPaintManager * | GetMessageBarPaintManager ()
Retrieves paint manager used to draw message bars.
CXTPShadowManager * | GetShadowManager () const
Retrieves shadow manager used to draw shadows.
BOOL | IsUseSystemAccentColorEnabled () const
Determines whether xtpApplicationUseSystemAccentColor application ambient property is set.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.
- Public Member Functions inherited from CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents >
void | Subscribe (IXTPPaintManagerEvents *pObserver, CXTPSubscriptionList< CXTPPaintManager, IXTPPaintManagerEvents > *pSubcriptionList=NULL)
Subscribes a unique observer for events.
void | Unsubscribe (IXTPPaintManagerEvents *pObserver)
Unsubscribes an observer from events.
void | Notify (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *))
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *))
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.

Protected Member Functions

virtual void | RefreshMetrics ()
This method is called to refresh the visual metrics of the manager.
- Protected Member Functions inherited from CXTPCommandBarsOfficeXPTheme
virtual void | DrawPopupBarGripper (CDC *pDC, int xPos, int yPos, int cx, int cy, BOOL bExpanded=FALSE)
This method is called to draw a pop-up bar's right gripper.
virtual CSize | DrawControlPopupParent (CDC *pDC, CXTPControl *pButton, BOOL bDraw)
This method is called to draw the control placed on the pop-up bar.
virtual void | DrawRectangle (CDC *pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition)
This method is called to fill the control's face.
virtual void | DrawRectangle (CDC *pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition, int nID)
This method is called to fill the control's face.
virtual BOOL | DrawRectangle (CDC *pDC, CXTPControl *pButton)
This method is called to fill the control's face.
virtual void | DrawImage (CDC *pDC, CPoint pt, CSize sz, CXTPImageManagerIcon *pImage, BOOL bSelected, BOOL bPressed, BOOL bEnabled=TRUE, BOOL bChecked=FALSE, BOOL bPopuped=FALSE, BOOL bToolBarImage=TRUE)
This method is called to draw the image of the control.
virtual CSize | DrawControlComboBox (CDC *pDC, CXTPControlComboBox *pComboBox, BOOL bDraw)
This method is called to draw the control.
virtual CSize | DrawControlEdit (CDC *pDC, CXTPControlEdit *pEdit, BOOL bDraw)
This method is called to draw the control.
void | FillIntersectRect (CDC *pDC, CXTPPopupBar *pPopupBar, COLORREF clr)
Draws intersect rectangle of a pop-up bar and its control.
virtual XTPPaintTheme | BaseTheme ()
Retrieves the base theme of the manager.
virtual void | DrawSplitButtonFrame (CDC *pDC, CXTPControl *pButton, CRect rc)
This method is called to draw the frame for the SplitButton control.
virtual CSize | DrawControlCheckBoxMark (CDC *pDC, CRect rc, BOOL bDraw, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled)
This method is called to draw a check box mark area.
virtual CSize | DrawControlCheckBoxMark (CDC *pDC, CXTPControl *pButton, CRect rc, BOOL bDraw)
This method is called to draw a check box mark area.
virtual CSize | DrawControlRadioButtonMark (CDC *pDC, CRect rc, BOOL bDraw, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled)
This method is called to draw a radio button mark area.
- Protected Member Functions inherited from CXTPPaintManager
CXTPPaintManager ()
Constructs a CXTPPaintManager object.
virtual | ~CXTPPaintManager ()
Destroys a CXTPPaintManager object, handles cleanup and deallocation.
- Protected Member Functions inherited from CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents >
CXTPObservable ()
Constructs an observable object.
~CXTPObservable ()
Handles observable object destruction.

Protected Attributes

CXTPMarkupContext * | m_pMarkupContext
Points to a valid markup context object.
CXTPResourceImages * | m_pImages
Points to a valid resource images object.
- Protected Attributes inherited from CXTPPaintManager
CXTPFont | m_xtpFontRegular
Regular font.
CXTPFont | m_xtpFontRegularBold
Regular bold font.
CXTPFont | m_xtpFontVert
Vertical font.
CXTPFont | m_xtpFontVertBold
Vertical font.
int | m_nEditHeight
Edit text height.
int | m_nFontHeight
Custom font height (optional).
BOOL | m_bUseStandardFont
TRUE to use system font.
BOOL | m_bEmbossedDisabledText
TRUE to draw disabled text embossed.
CXTPWinThemeWrapper * | m_themeStatusBar
StatusBar theme helper.
CXTPWinThemeWrapper * | m_themeButton
Buttons theme helper.
XTPPaintTheme | m_themeCurrent
Current theme.
XTP_COMMANDBARS_ICONSINFO | m_iconsInfo
Specific icons options.
int | m_nAnimationSteps
Steps of the animation.
int | m_nAnimationTime
Time of the animation.
BOOL | m_bShowKeyboardCues
TRUE to show keyboard cues - deprecated.
CXTPPaintManagerColor | m_arrColor [XPCOLOR_LAST+1]
Self colors array.
XTPCurrentSystemTheme | m_systemTheme
Current system theme.
CXTPShadowManager * | m_pShadowManager
Shadow manager.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPPaintManager
static CXTPPaintManager *AFX_CDECL | GetInstanceAddRef ()
Obtains a pointer to a global paint manager object and increments its reference counter.
static void AFX_CDECL | ReleaseInstance ()
Decrements global paint manager's reference counter and deletes its instance when the reference counter reaches 0.
static CXTPPaintManager *AFX_CDECL | CreateTheme (XTPPaintTheme paintTheme)
Creates a new CXTPPaintManager object.
static void AFX_CDECL | SetTheme (XTPPaintTheme paintTheme)
Call this member to switch the visual theme of the Command Bars.
static void AFX_CDECL | SetCustomTheme (CXTPPaintManager *pTheme)
Call this member to set a custom theme.
static void AFX_CDECL | Triangle (CDC *pDC, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clr)
Draws a triangle.
static BOOL AFX_CDECL | FontExists (LPCTSTR lpszFaceName)
Determines if a specified font exists in the system.
static void AFX_CDECL | StripMnemonics (CString &strClear)
This member function will search a string, strip off the mnemonic '&', and reformat the string.
static CXTPPaintManager *AFX_CDECL | GetGlobalPaintManager ()
Call this method to get the pointer to the global paint manager.
static void AFX_CDECL | SetGlobalPaintManager (CXTPPaintManager *pPaintManager)
Call this method to set the pointer to the global paint manager.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPPaintManager
COLORREF | m_clrMessageBarText
Message bar text color.
CRect | m_rcMessageBarMargin
Margin of the message bar.
CXTPFramePaintManager * | m_pFramePaintManager
Frame paint manager.
CXTPStatusBarPaintManager * | m_pStatusBarPaintManager
Paint manager of the status bar.
CXTPRibbonPaintManager * | m_pRibbonPaintManager
Ribbon paint Manager.
CXTPControlGalleryPaintManager * | m_pGalleryPaintManager
Gallery paint manager.
CXTPProgressPaintManager * | m_pProgressPaintManager
Progress bar paint manager.
CXTPSliderPaintManager * | m_pSliderPaintManager
Slider pane paint manager.
CXTPScrollBarPaintManager * | m_pScrollBarPaintManager
Scrollbar paint manager.
CXTPPaintManagerColorGradient | m_clrDisabledIcon
Disabled icons color.
CXTPPaintManagerColor | m_clrFloatingGripper
Gripper color of floating toolbar.
CXTPPaintManagerColor | m_clrFloatingGripperText
Gripper text color of floating toolbar.
BOOL | m_bThickCheckMark
TRUE to draw thick check mark.
BOOL | m_bShowShadow
TRUE to show shadow.
BOOL | m_bThemedStatusBar
TRUE to draw status bar using WinXP theme.
BOOL | m_bThemedCheckBox
TRUE to draw check box using WinXP theme.
BOOL | m_bClearTypeTextQuality
TRUE to enable ClearType text for the font.
BOOL | m_bFlatToolBar
TRUE to draw toolbars flat.
BOOL | m_bFlatMenuBar
TRUE to draw menubar flat.
int | m_nPopupBarTextPadding
Distance between gripper and control text.
BOOL | m_bSelectImageInPopupBar
TRUE to select image as in explorer theme.
BOOL | m_bEnableAnimation
TRUE to enable animation for all toolbars.
BOOL | m_bOffice2007Padding
TRUE if Office2007 metrics used.
BOOL | m_bOffsetPopupLabelText
TRUE if labels in pop-ups drawn with offset.
BOOL | m_bWrapCaptionBelowText
Wrap text for xtpButtonIconAndCaptionBelow buttons.
CXTPPaintManagerFont | m_fontSmCaption
Small caption font.
CXTPPaintManagerFont | m_fontIcon
Icon font.
CXTPPaintManagerFont | m_fontIconBold
Icon bold font.
CXTPPaintManagerFont | m_fontToolTip
Tooltip font.
int | m_nSplitButtonDropDownWidth
Split button drop down width in toolbars.
int | m_nSplitButtonDropDownHeight
Split button drop down height in toolbars.
int | m_nSplitButtonPopupWidth
Split button drop down width in pop-ups.
BOOL | m_bAutoResizeIcons
TRUE to automatically resize icons using current DPI.
int | m_nStatusBarMinHeight
Minimum height for the status bar.
PVOID | m_pfnSetLayeredWindowAttributes
point to Transparency proc in USER32.dll module.
CRect | m_rcStatusBarBorder
Bounding rectangle of the status bar border.
BOOL | m_bUseOfficeFont
TRUE to use Tahoma font.
CString | m_strOfficeFont
Office font.
int | m_nTextHeight
Regular text field height (not font height).

Detailed Description

The CXTPCommandBarsModernUITheme class is the base class for the Modern UI themes for Command Bars.

See also
CXTPPaintManager::SetTheme

Member Function Documentation

◆ GetFramePaintManager()

AFX_INLINE CXTPFramePaintManager * GetFramePaintManager ( )
virtual

Returns paint manager used to draw frames.

Returns
Paint manager used to draw frames.

Reimplemented from CXTPPaintManager.

◆ GetMarkupContext()

AFX_INLINE CXTPMarkupContext * GetMarkupContext ( )
virtual

Retrieves a pointer to the markup context.

Returns
A pointer to a CXTPMarkupContext object.

◆ GetRibbonPaintManager()

AFX_INLINE CXTPRibbonPaintManager * GetRibbonPaintManager ( )
virtual

Retrieves the ribbon paint manager.

Returns
A pointer to a CXTPRibbonPaintManager object.

Reimplemented from CXTPPaintManager.

The documentation for this class was generated from the following file:
  • XTPCommandBarsModernUITheme.h


Toolkit Pro: CXTPCommandBarsNativeWindows10Theme Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPCommandBarsNativeWindows10Theme Class Reference

The CXTPCommandBarsNativeWindows10Theme class is used to enable a Native Windows 10 style theme for Command Bars. More...

Inheritance diagram for CXTPCommandBarsNativeWindows10Theme:
[legend]

Public Member Functions

CXTPCommandBarsNativeWindows10Theme ()
Constructs a CXTPCommandBarsNativeWindows10Theme object.
virtual | ~CXTPCommandBarsNativeWindows10Theme ()
Destroys a CXTPCommandBarsNativeWindows10Theme object, handles cleanup and deallocation.
virtual void | SetStateColor (COLORREF clrState=COLORREF_NULL)
Call this member function to set the application state color for the frame border and status bar.
virtual COLORREF | GetStateColor () const
Call this member function to gets the application state color for the frame border and status bar.
- Public Member Functions inherited from CXTPCommandBarsOffice2013Theme
CXTPCommandBarsOffice2013Theme ()
Constructs a CXTPCommandBarsOffice2013Theme object.
virtual | ~CXTPCommandBarsOffice2013Theme ()
Destroys a CXTPCommandBarsOffice2013Theme object, handles cleanup and deallocation.
virtual XTPPaintTheme | BaseTheme ()
Retrieves the base theme of the manager.
virtual void | FillCommandBarEntry (CDC *pDC, CXTPCommandBar *pBar)
This method is called to fill the command bar's face.
virtual void | FillDockBar (CDC *pDC, CXTPDockBar *pBar)
This method is called to fill a dock bar.
virtual void | DrawCommandBarGroupSeparator (CDC *pDC, CXTPCommandBar *pBar, CXTPControl *pLeftControl, CXTPControl *pRightControl, BOOL bDraw)
This method is called to draw a command bar's group separator.
virtual CSize | DrawControlEdit (CDC *pDC, CXTPControlEdit *pEdit, BOOL bDraw)
This method is called to draw the control.
virtual void | FillWorkspace (CDC *pDC, CRect rc, CRect rcExclude)
Draws workspace space.
virtual BOOL | RequiresResourceImages ()
Used by the paint manager to determine if the theme requires a resource DLL to load image and color information.
virtual COLORREF | GetControlEditBackColor (CXTPControl *pControl)
This method returns the edit control back color to draw.
- Public Member Functions inherited from CXTPCommandBarsModernUITheme
CXTPCommandBarsModernUITheme ()
Constructs a CXTPCommandBarsModernUITheme object.
virtual | ~CXTPCommandBarsModernUITheme ()
Destroys a CXTPCommandBarsModernUITheme object, handles cleanup and deallocation.
virtual CXTPFramePaintManager * | GetFramePaintManager ()
Returns paint manager used to draw frames.
virtual CXTPRibbonPaintManager * | GetRibbonPaintManager ()
Retrieves the ribbon paint manager.
virtual CXTPMarkupContext * | GetMarkupContext ()
Retrieves a pointer to the markup context.
- Public Member Functions inherited from CXTPCommandBarsOfficeXPTheme
CXTPCommandBarsOfficeXPTheme ()
Constructs a CXTPCommandBarsOfficeXPTheme object.
virtual CSize | DrawListBoxControl (CDC *pDC, CXTPControl *pButton, CRect rc, BOOL bSelected, BOOL bDraw, CXTPCommandBars *pCommandBars=0)
This method is called to draw the control placed on the ListBox.
virtual void | AdjustExcludeRect (CRect &rc, CXTPControl *pControl, BOOL bVertical)
This method is called to determine the offset of a pop-up bar.
virtual CSize | DrawTearOffGripper (CDC *pDC, CRect rcGripper, BOOL bSelected, BOOL bDraw)
This method is called to draw a tear-off gripper of a pop-up bar.
virtual void | DrawPopupResizeGripper (CDC *pDC, CRect rcGripper, int nFlags)
This method is called to draw a resize gripper of a pop-up bar.
virtual CSize | DrawDialogBarGripper (CDC *pDC, CXTPDialogBar *pBar, BOOL bDraw)
Call this member to draw the gripper of a dialog bar.
- Public Member Functions inherited from CXTPPaintManager
virtual void | SetImageHandle (HMODULE hResource, LPCTSTR lpszIniFileName)
Specifies the resource that contains the bitmaps to be loaded for the theme.
CSize | DrawControl (CDC *pDC, CXTPControl *pButton, BOOL bDraw=TRUE)
This method is called to draw the control.
virtual CSize | DrawControlToolBarParent (CDC *pDC, CXTPControl *pButton, BOOL bDraw)
This method is called to draw the control placed on the toolbar.
virtual void | DrawControlEntry (CDC *pDC, CXTPControl *pButton)
This method is called to fill the control's face.
int | GetShadowOptions () const
Determines the kind of shadow to use.
virtual CSize | DrawSpecialControl (CDC *pDC, XTPSpecialControl controlType, CXTPControl *pButton, CXTPCommandBar *pBar, BOOL bDraw, LPVOID lpParam)
This method is called to draw the specified controls.
virtual CRect | GetCommandBarBorders (CXTPCommandBar *pBar)
This method is called to retrieve the command bar's borders.
virtual CRect | GetSplitButtonCommandRect (CXTPControl *pButton)
Determines split button command rectangle.
virtual void | SetCommandBarRegion (CXTPCommandBar *pCommandBar)
Call this method to set the bounding region of a pop-up bar.
XTPPaintTheme GetCurrentTheme ()
Call this member to get the current visual theme.
virtual CFont * | GetControlFont (CXTPControl *pControl)
Call this member to retrieve the font of the command bar control.
virtual CFont * | GetCommandBarFont (CXTPCommandBar *pCommandBar)
Call this member to retrieve the font of the command bar.
virtual XTPBarTextOrientation | GetControlTextOrientation (CXTPControl *pControl)
Call this member to determine how to draw text.
virtual void | UpdateFonts ()
Refreshes the fonts to use.
virtual void | UpdateColors ()
Refreshes the standard colors to use.
void | SetCommandBarsFontIndirect (LOGFONT *pLogFont, BOOL bUseStandardFont=FALSE)
Call this member to set command bar's font.
CFont * | GetRegularFont ()
Returns the general font.
CFont * | GetRegularBoldFont ()
Returns the general bold font.
CFont * | GetIconFont ()
Returns the icon font.
CFont * | GetSmCaptionFont ()
Call this method to retrieve the caption of a floating mini frame.
void | UseOfficeFont (bool bUseOfficeFont)
Call this method to use Tahoma font despite system metrics.
int | GetControlHeight () const
This method returns the common controls height.
virtual CSize | GetDefaultCommandBarSize (CXTPCommandBar *pBar)
Computes default command bar size taking into account command bar font.
void | Rectangle (CDC *pDC, LPCRECT rc, int nPen, const int nBrush)
Draws a rectangle.
void | Rectangle (CDC *pDC, LPCRECT rc, COLORREF clrPen, COLORREF clrBrush)
Draws a rectangle.
void | RoundRect (CDC *pDC, LPCRECT rc, COLORREF clrPen, COLORREF clrBrush)
Draws a rectangle.
void | Draw3dRect (CDC *pDC, LPCRECT rc, int nTopLeft, int nBottomRight)
Call this member function to draw a three-dimensional rectangle.
void | Draw3dRect (CDC *pDC, LPCRECT rc, int frameThickness, COLORREF clrPen, COLORREF clrBrush)
Call this member function to draw a rectangle with predetermined thickness.
virtual void | DrawPopupBarCheckMark (CDC *pDC, CRect rcCheck, BOOL bEnabled, COLORREF clr)
Call this member function to draw a check mark.
void | DrawCheckMark (CDC *pDC, CRect rcCheck, COLORREF clr=0)
Call this member function to draw a check mark.
virtual void | DrawPopupBarRadioMark (CDC *pDC, CRect rcCheck, BOOL bEnabled, COLORREF clr)
Call this member function to draw a radio button.
virtual void | DrawComboExpandMark (CDC *pDC, CRect rc, COLORREF clr)
Call this member function to draw a combobox expand symbol.
void | Line (CDC *pDC, CPoint p0, CPoint p1)
Draws a line.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1, const int nPen)
Draws a line.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1, COLORREF clrPen)
Draws a line.
void | HorizontalLine (CDC *pDC, int x0, int y0, int x1, COLORREF clrPen)
Call this member function to draw a horizontal line using the specified coordinages and RGB color value.
void | VerticalLine (CDC *pDC, int x0, int y0, int y1, COLORREF clrPen)
Call this member function to draw a vertical line using the specified coordinages and RGB color value.
void | Pixel (CDC *pDC, int xPos, int yPos, int nPen)
Sets the pixel at the point.
void | GradientFill (CDC *pDC, LPRECT lpRect, COLORREF crFrom, COLORREF crTo, BOOL bHorz, LPCRECT lpRectClip=NULL)
Gradient fills the rectangle.
XTP_COMMANDBARS_ICONSINFO * GetIconsInfo ()
virtual void | Animate (CDC *pDestDC, CDC *pSrcDC, CRect rc, XTPAnimationType animationType)
This method is called to animate the pop-up bar.
virtual void | AnimateExpanding (CXTPCommandBar *pCommandBar, CDC *pDestDC, CDC *pSrcDC, BOOL bExpandDown)
This method is called to animate the expanding process.
void | SetAnimationDelay (int nAnimationSteps, int nAnimationTime)
Call this method to set animation delay.
COLORREF | GetXtremeColor (UINT nIndex)
This function retrieves the current color of the specified XP display element.
void | SetColors (int cElements, CONST INT *lpaElements, CONST COLORREF *lpaRgbValues)
Call this member to set the colors for each element to the color in the specified color array.
CSize | DrawControlText (CDC *pDC, CXTPControl *pControl, CRect rcText, BOOL bDraw, BOOL bVert, BOOL bCentered, BOOL bTriangled)
This method is called to draw control text.
virtual void | UpdateRTLCaption (CString &strCaption)
This method is called to prepare a caption for Right-To-Left draw.
XTPCurrentSystemTheme GetCurrentSystemTheme ()
Call this member function to determine the current Windows XP theme in use.
void | SetLunaTheme (XTPCurrentSystemTheme systemTheme)
Call this method to force system theme.
virtual int | GetPopupBarGripperWidth (CXTPCommandBar *pBar)
Calculates the gripper of a pop-up bar.
virtual CXTPControlGalleryPaintManager * | GetGalleryPaintManager () const
Retrieves paint manager used to draw galleries.
virtual CXTPScrollBarPaintManager * | GetScrollBarPaintManager () const
Retrieves paint manager used to draw scrollbars.
virtual CXTPSliderPaintManager * | GetSliderPaintManager () const
Retrieves paint manager used to draw slider panes.
virtual CXTPProgressPaintManager * | GetProgressPaintManager () const
Retrieves paint manager used to draw progress bars.
virtual CXTPStatusBarPaintManager * | GetStatusBarPaintManager ()
Retrieves paint manager used to draw the status bar.
virtual CXTPMessageBarPaintManager * | GetMessageBarPaintManager ()
Retrieves paint manager used to draw message bars.
CXTPShadowManager * | GetShadowManager () const
Retrieves shadow manager used to draw shadows.
BOOL | IsUseSystemAccentColorEnabled () const
Determines whether xtpApplicationUseSystemAccentColor application ambient property is set.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.
- Public Member Functions inherited from CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents >
void | Subscribe (IXTPPaintManagerEvents *pObserver, CXTPSubscriptionList< CXTPPaintManager, IXTPPaintManagerEvents > *pSubcriptionList=NULL)
Subscribes a unique observer for events.
void | Unsubscribe (IXTPPaintManagerEvents *pObserver)
Unsubscribes an observer from events.
void | Notify (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *))
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *))
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.

Protected Member Functions

virtual void | DrawSplitButtonFrame (CDC *pDC, CXTPControl *pButton, CRect rc)
This method is called to draw the frame for the SplitButton control.
virtual void | DrawRectangle (CDC *pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition)
This method is called to fill the control's face.
virtual void | DrawRectangle (CDC *pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition, int nID)
This method is called to fill the control's face.
virtual BOOL | DrawRectangle (CDC *pDC, CXTPControl *pButton)
This method is called to fill the control's face.
virtual COLORREF | GetControlTextColor (CXTPControl *pButton)
This method returns the control text color to draw.
virtual void | DrawGalleryItemBack (CDC *pDC, CRect rcItem, BOOL bEnabled, BOOL bSelected, BOOL bPressed, BOOL bChecked, XTPBarType barType)
This method is called to draw the background for a gallery menu item.
virtual void | DrawCheckRect (CDC *pDC, CRect rc, COLORREF clrFore, COLORREF clrBack)
Helper class called by DrawRectangle to render a checkmark background and border.
virtual CSize | DrawCommandBarGripper (CDC *pDC, CXTPCommandBar *pBar, BOOL bDraw=TRUE)
This method is called to draw the command bar's gripper.
virtual CSize | DrawControlComboBox (CDC *pDC, CXTPControlComboBox *pComboBox, BOOL bDraw)
This method is called to draw the control.
- Protected Member Functions inherited from CXTPCommandBarsOffice2013Theme
virtual void | RefreshMetrics ()
This method is called to refresh the visual metrics of the manager.
virtual void | RefreshStandardColors ()
Called to update the standard colors used by the framework.
virtual COLORREF | GetRectangleTextColor (BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition)
This method retrieves a buttons text color.
virtual COLORREF | GetControlBackColor (CXTPControl *pButton)
Call this method to get the control back color to draw.
void | DrawFrameBorder (CDC *pDC, CRect rc, int nBorderThickness, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition)
This method is called to fill the border of the control's face.
virtual void | DrawPopupBarGripper (CDC *pDC, int xPos, int yPos, int cx, int cy, BOOL bExpanded=FALSE)
This method is called to draw a pop-up bar's right gripper.
virtual void | DrawDropDownGlyph (CDC *pDC, CXTPControl *pControl, CPoint pt, BOOL bSelected, BOOL bPopuped, BOOL bEnabled, BOOL bVert)
This member function is called to draw a split button expand symbol.
virtual CSize | DrawCommandBarSeparator (CDC *pDC, CXTPCommandBar *pBar, CXTPControl *pControl, BOOL bDraw=TRUE)
This method is called to draw a command bar's separator.
virtual void | DrawExpandGlyph (CDC *pDC, CXTPControl *pButton, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clr)
Draw expand or hidden glyphs for a button.
virtual void | DrawHiddenGlyph (CDC *pDC, CXTPControl *pButton, COLORREF clr, BOOL bVertical)
Draw expand or hidden glyphs for a button.
virtual void | DrawExpandGlyph (CDC *pDC, CXTPControl *pButton, COLORREF clr, BOOL bVertical)
Draw expand or hidden glyphs for a button.
virtual CSize | DrawControlCheckBoxMark (CDC *pDC, CXTPControl *pButton, CRect rc, BOOL bDraw)
This method is called to draw a check box mark area.
virtual CSize | DrawControlCheckBoxMark (CDC *pDC, CRect rc, BOOL bDraw, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled)
This method is called to draw a check box mark area.
virtual CSize | DrawControlRadioButtonMark (CDC *pDC, CRect rc, BOOL bDraw, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled)
This method is called to draw a radio button mark area.
virtual void | DrawControlMDIButton (CDC *pDC, CXTPControlButton *pButton)
Call this member function to draw Menu MDI buttons.
- Protected Member Functions inherited from CXTPCommandBarsModernUITheme
- Protected Member Functions inherited from CXTPCommandBarsOfficeXPTheme
virtual CSize | DrawControlPopupParent (CDC *pDC, CXTPControl *pButton, BOOL bDraw)
This method is called to draw the control placed on the pop-up bar.
virtual void | DrawImage (CDC *pDC, CPoint pt, CSize sz, CXTPImageManagerIcon *pImage, BOOL bSelected, BOOL bPressed, BOOL bEnabled=TRUE, BOOL bChecked=FALSE, BOOL bPopuped=FALSE, BOOL bToolBarImage=TRUE)
This method is called to draw the image of the control.
void | FillIntersectRect (CDC *pDC, CXTPPopupBar *pPopupBar, COLORREF clr)
Draws intersect rectangle of a pop-up bar and its control.
- Protected Member Functions inherited from CXTPPaintManager
CXTPPaintManager ()
Constructs a CXTPPaintManager object.
virtual | ~CXTPPaintManager ()
Destroys a CXTPPaintManager object, handles cleanup and deallocation.
- Protected Member Functions inherited from CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents >
CXTPObservable ()
Constructs an observable object.
~CXTPObservable ()
Handles observable object destruction.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPPaintManager
static CXTPPaintManager *AFX_CDECL | GetInstanceAddRef ()
Obtains a pointer to a global paint manager object and increments its reference counter.
static void AFX_CDECL | ReleaseInstance ()
Decrements global paint manager's reference counter and deletes its instance when the reference counter reaches 0.
static CXTPPaintManager *AFX_CDECL | CreateTheme (XTPPaintTheme paintTheme)
Creates a new CXTPPaintManager object.
static void AFX_CDECL | SetTheme (XTPPaintTheme paintTheme)
Call this member to switch the visual theme of the Command Bars.
static void AFX_CDECL | SetCustomTheme (CXTPPaintManager *pTheme)
Call this member to set a custom theme.
static void AFX_CDECL | Triangle (CDC *pDC, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clr)
Draws a triangle.
static BOOL AFX_CDECL | FontExists (LPCTSTR lpszFaceName)
Determines if a specified font exists in the system.
static void AFX_CDECL | StripMnemonics (CString &strClear)
This member function will search a string, strip off the mnemonic '&', and reformat the string.
static CXTPPaintManager *AFX_CDECL | GetGlobalPaintManager ()
Call this method to get the pointer to the global paint manager.
static void AFX_CDECL | SetGlobalPaintManager (CXTPPaintManager *pPaintManager)
Call this method to set the pointer to the global paint manager.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPPaintManager
COLORREF | m_clrMessageBarText
Message bar text color.
CRect | m_rcMessageBarMargin
Margin of the message bar.
CXTPFramePaintManager * | m_pFramePaintManager
Frame paint manager.
CXTPStatusBarPaintManager * | m_pStatusBarPaintManager
Paint manager of the status bar.
CXTPRibbonPaintManager * | m_pRibbonPaintManager
Ribbon paint Manager.
CXTPControlGalleryPaintManager * | m_pGalleryPaintManager
Gallery paint manager.
CXTPProgressPaintManager * | m_pProgressPaintManager
Progress bar paint manager.
CXTPSliderPaintManager * | m_pSliderPaintManager
Slider pane paint manager.
CXTPScrollBarPaintManager * | m_pScrollBarPaintManager
Scrollbar paint manager.
CXTPPaintManagerColorGradient | m_clrDisabledIcon
Disabled icons color.
CXTPPaintManagerColor | m_clrFloatingGripper
Gripper color of floating toolbar.
CXTPPaintManagerColor | m_clrFloatingGripperText
Gripper text color of floating toolbar.
BOOL | m_bThickCheckMark
TRUE to draw thick check mark.
BOOL | m_bShowShadow
TRUE to show shadow.
BOOL | m_bThemedStatusBar
TRUE to draw status bar using WinXP theme.
BOOL | m_bThemedCheckBox
TRUE to draw check box using WinXP theme.
BOOL | m_bClearTypeTextQuality
TRUE to enable ClearType text for the font.
BOOL | m_bFlatToolBar
TRUE to draw toolbars flat.
BOOL | m_bFlatMenuBar
TRUE to draw menubar flat.
int | m_nPopupBarTextPadding
Distance between gripper and control text.
BOOL | m_bSelectImageInPopupBar
TRUE to select image as in explorer theme.
BOOL | m_bEnableAnimation
TRUE to enable animation for all toolbars.
BOOL | m_bOffice2007Padding
TRUE if Office2007 metrics used.
BOOL | m_bOffsetPopupLabelText
TRUE if labels in pop-ups drawn with offset.
BOOL | m_bWrapCaptionBelowText
Wrap text for xtpButtonIconAndCaptionBelow buttons.
CXTPPaintManagerFont | m_fontSmCaption
Small caption font.
CXTPPaintManagerFont | m_fontIcon
Icon font.
CXTPPaintManagerFont | m_fontIconBold
Icon bold font.
CXTPPaintManagerFont | m_fontToolTip
Tooltip font.
int | m_nSplitButtonDropDownWidth
Split button drop down width in toolbars.
int | m_nSplitButtonDropDownHeight
Split button drop down height in toolbars.
int | m_nSplitButtonPopupWidth
Split button drop down width in pop-ups.
BOOL | m_bAutoResizeIcons
TRUE to automatically resize icons using current DPI.
int | m_nStatusBarMinHeight
Minimum height for the status bar.
PVOID | m_pfnSetLayeredWindowAttributes
point to Transparency proc in USER32.dll module.
CRect | m_rcStatusBarBorder
Bounding rectangle of the status bar border.
BOOL | m_bUseOfficeFont
TRUE to use Tahoma font.
CString | m_strOfficeFont
Office font.
int | m_nTextHeight
Regular text field height (not font height).
- Protected Attributes inherited from CXTPCommandBarsOffice2013Theme
BOOL | m_bIntersect
TRUE to draw pop-up bar intersect rectangle.
CXTPColorSetStateMenu | m_csMenu
State colors used by Menu items.
CXTPColorSetStateMenuTitleBar | m_csMenuTitleBar
State colors used by MenuTitleBar items.
CXTPColorSetStateRibbon | m_csRibbon
State colors used by Ribbon group buttons.
CXTPColorSetStateToolbar | m_csToolbar
State colors used by Toolbar buttons.
CXTPColorSetStateCheckMark | m_csCheckMark
State colors used by Menu Check Marks.
CXTPColorSetStateComboBox | m_csComboBox
State colors used by ComboBox control.
CXTPColorSetStateCheckBox | m_csCheckBox
State colors used by Check Box and Radio Button controls.
CXTPPaintManagerColor | m_clrBack
CommandBars background color;.
CXTPPaintManagerColor | m_clrGlyph
Glyph Normal color.
CXTPPaintManagerColor | m_clrGlyphHighlight
Glyph Highlight color.
CXTPPaintManagerColor | m_clrGlyphPushed
Glyph Pushed color.
CXTPPaintManagerColor | m_clrGlyphDisabled
Glyph Disabled color.
CXTPPaintManagerColor | m_clrMessageBarText
Message bar text color.
CXTPPaintManagerColor | m_clrBtnFace
Button background color.
CXTPPaintManagerColor | m_clr3DShadow
Button shadow color.
CXTPPaintManagerColor | m_clrHighlight
Button highlight color.
CXTPPaintManagerColor | m_clrCaptionButtonFill
Text color for frame caption buttons.
CXTPPaintManagerColorGradient | m_clrWorkspace
Workspace area gradient color.
- Protected Attributes inherited from CXTPCommandBarsModernUITheme
CXTPMarkupContext * | m_pMarkupContext
Points to a valid markup context object.
CXTPResourceImages * | m_pImages
Points to a valid resource images object.
- Protected Attributes inherited from CXTPPaintManager
CXTPFont | m_xtpFontRegular
Regular font.
CXTPFont | m_xtpFontRegularBold
Regular bold font.
CXTPFont | m_xtpFontVert
Vertical font.
CXTPFont | m_xtpFontVertBold
Vertical font.
int | m_nEditHeight
Edit text height.
int | m_nFontHeight
Custom font height (optional).
BOOL | m_bUseStandardFont
TRUE to use system font.
BOOL | m_bEmbossedDisabledText
TRUE to draw disabled text embossed.
CXTPWinThemeWrapper * | m_themeStatusBar
StatusBar theme helper.
CXTPWinThemeWrapper * | m_themeButton
Buttons theme helper.
XTPPaintTheme | m_themeCurrent
Current theme.
XTP_COMMANDBARS_ICONSINFO | m_iconsInfo
Specific icons options.
int | m_nAnimationSteps
Steps of the animation.
int | m_nAnimationTime
Time of the animation.
BOOL | m_bShowKeyboardCues
TRUE to show keyboard cues - deprecated.
CXTPPaintManagerColor | m_arrColor [XPCOLOR_LAST+1]
Self colors array.
XTPCurrentSystemTheme | m_systemTheme
Current system theme.
CXTPShadowManager * | m_pShadowManager
Shadow manager.

Detailed Description

The CXTPCommandBarsNativeWindows10Theme class is used to enable a Native Windows 10 style theme for Command Bars.

See also
CXTPPaintManager::SetTheme

Member Function Documentation

◆ DrawCheckRect()

virtual void DrawCheckRect | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | COLORREF | clrFore,
 |  | COLORREF | clrBack )
 protectedvirtual

Helper class called by DrawRectangle to render a checkmark background and border.

Parameters
pDC | Pointer to a valid device context
rc | Rectangle to draw.
clrFore | RGB color value used to draw border.
clrBack | RGB color value used to draw background.

◆ DrawCommandBarGripper()

virtual CSize DrawCommandBarGripper | ( | CDC * | pDC,
 |  | CXTPCommandBar * | pBar,
 |  | BOOL | bDraw = TRUE )
 protectedvirtual

This method is called to draw the command bar's gripper.

Parameters
pDC | Pointer to a valid device context.
pBar | Pointer to a CXTPCommandBar object.
bDraw | TRUE to draw; FALSE to retrieve the size of the gripper.
Returns
Size of the gripper.

Reimplemented from CXTPCommandBarsOffice2013Theme.

◆ DrawControlComboBox()

virtual CSize DrawControlComboBox | ( | CDC * | pDC,
 |  | CXTPControlComboBox * | pComboBox,
 |  | BOOL | bDraw )
 protectedvirtual

This method is called to draw the control.

Parameters
pDC | Pointer to a valid device context
bDraw | TRUE to draw; FALSE to retrieve the size of the control.
pComboBox | CXTPControlComboBox pointer need to draw.
Returns
Size of the control.

Reimplemented from CXTPCommandBarsOffice2013Theme.

◆ DrawGalleryItemBack()

virtual void DrawGalleryItemBack | ( | CDC * | pDC,
 |  | CRect | rcItem,
 |  | BOOL | bEnabled,
 |  | BOOL | bSelected,
 |  | BOOL | bPressed,
 |  | BOOL | bChecked,
 |  | XTPBarType | barType )
 protectedvirtual

This method is called to draw the background for a gallery menu item.

Parameters
pDC | Pointer to a valid device context.
rcItem | CRect object specifying the size of the area.
bSelected | TRUE if the control is selected.
bPressed | TRUE if the control is pushed.
bEnabled | TRUE if the control is enabled.
bChecked | TRUE if the control is checked.
barType | Parent's bar type.

Reimplemented from CXTPCommandBarsOffice2013Theme.

◆ DrawRectangle() [1/3]

virtual void DrawRectangle | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | BOOL | bSelected,
 |  | BOOL | bPressed,
 |  | BOOL | bEnabled,
 |  | BOOL | bChecked,
 |  | BOOL | bPopuped,
 |  | XTPBarType | barType,
 |  | XTPBarPosition | barPosition )
 protectedvirtual

This method is called to fill the control's face.

Parameters
pDC | Pointer to a valid device context
rc | Rectangle to draw.
bSelected | TRUE if the control is selected.
bPressed | TRUE if the control is pushed.
bEnabled | TRUE if the control is enabled.
bChecked | TRUE if the control is checked.
bPopuped | TRUE if the control is pop-up'ed.
barType | Parent's bar type.
barPosition | Parent's bar position.

Reimplemented from CXTPCommandBarsOffice2013Theme.

◆ DrawRectangle() [2/3]

virtual void DrawRectangle | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | BOOL | bSelected,
 |  | BOOL | bPressed,
 |  | BOOL | bEnabled,
 |  | BOOL | bChecked,
 |  | BOOL | bPopuped,
 |  | XTPBarType | barType,
 |  | XTPBarPosition | barPosition,
 |  | int | nID )
 protectedvirtual

This method is called to fill the control's face.

Parameters
pDC | Pointer to a valid device context
rc | Rectangle to draw.
bSelected | TRUE if the control is selected.
bPressed | TRUE if the control is pushed.
bEnabled | TRUE if the control is enabled.
bChecked | TRUE if the control is checked.
bPopuped | TRUE if the control is pop-up'ed.
barType | Parent's bar type.
barPosition | Parent's bar position.
nID | Bar's control ID.

Reimplemented from CXTPCommandBarsOffice2013Theme.

◆ DrawRectangle() [3/3]

virtual BOOL DrawRectangle | ( | CDC * | pDC,
 |  | CXTPControl * | pButton )
 protectedvirtual

This method is called to fill the control's face.

Parameters
pDC | Pointer to a valid device context.
pButton | pointer to a button
Returns
TRUE if the rectange was drawn, otherwise FALSE.

Reimplemented from CXTPCommandBarsOffice2013Theme.

◆ DrawSplitButtonFrame()

virtual void DrawSplitButtonFrame | ( | CDC * | pDC,
 |  | CXTPControl * | pButton,
 |  | CRect | rc )
 protectedvirtual

This method is called to draw the frame for the SplitButton control.

Parameters
pDC | Pointer to a valid device context.
pButton | Pointer to a CXTPControl object.
rc | Bounding rectangle to draw.

Reimplemented from CXTPCommandBarsOffice2013Theme.

◆ GetControlTextColor()

virtual COLORREF GetControlTextColor ( CXTPControl * pButton )
protectedvirtual

This method returns the control text color to draw.

Parameters
pButton Pointer to a CXTPControl object to draw.
Returns
Returns control text color

Reimplemented from CXTPCommandBarsOffice2013Theme.

◆ GetStateColor()

virtual COLORREF GetStateColor ( ) const
virtual

Call this member function to gets the application state color for the frame border and status bar.

Returns
Returns application state color

◆ SetStateColor()

virtual void SetStateColor ( COLORREF clrState = COLORREF_NULL )
virtual

Call this member function to set the application state color for the frame border and status bar.

Parameters
clrState COLORREF value representing the application state color. Use COLORREF_NULL to reset back to default color.
The documentation for this class was generated from the following file:
  • XTPCommandBarsNativeWindows10Theme.h


Toolkit Pro: CXTPCommandBarsNativeWindows11Theme Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPCommandBarsNativeWindows11Theme Class Reference

The CXTPCommandBarsNativeWindows11Theme class is used to enable a Native Windows 10 style theme for Command Bars. More...

Inheritance diagram for CXTPCommandBarsNativeWindows11Theme:
[legend]

Public Member Functions

CXTPCommandBarsNativeWindows11Theme ()
Constructs a CXTPCommandBarsNativeWindows11Theme object.
virtual | ~CXTPCommandBarsNativeWindows11Theme ()
Destroys a CXTPCommandBarsNativeWindows11Theme object, handles cleanup and deallocation.
virtual void | FillCommandBarEntry (CDC *pDC, CXTPCommandBar *pBar)
This method is called to fill the command bar's face.
virtual void | FillDockBar (CDC *pDC, CXTPDockBar *pBar)
This method is called to fill a dock bar.
virtual void | SetStateColor (COLORREF clrState=COLORREF_NULL)
Call this member function to set the application state color for the frame border and status bar.
virtual COLORREF | GetStateColor () const
Call this member function to gets the application state color for the frame border and status bar.
virtual CRect | GetCommandBarBorders (CXTPCommandBar *pBar)
This method is called to retrieve the command bar's borders.
- Public Member Functions inherited from CXTPCommandBarsOffice2013Theme
CXTPCommandBarsOffice2013Theme ()
Constructs a CXTPCommandBarsOffice2013Theme object.
virtual | ~CXTPCommandBarsOffice2013Theme ()
Destroys a CXTPCommandBarsOffice2013Theme object, handles cleanup and deallocation.
virtual XTPPaintTheme | BaseTheme ()
Retrieves the base theme of the manager.
virtual void | DrawCommandBarGroupSeparator (CDC *pDC, CXTPCommandBar *pBar, CXTPControl *pLeftControl, CXTPControl *pRightControl, BOOL bDraw)
This method is called to draw a command bar's group separator.
virtual CSize | DrawControlEdit (CDC *pDC, CXTPControlEdit *pEdit, BOOL bDraw)
This method is called to draw the control.
virtual void | FillWorkspace (CDC *pDC, CRect rc, CRect rcExclude)
Draws workspace space.
virtual BOOL | RequiresResourceImages ()
Used by the paint manager to determine if the theme requires a resource DLL to load image and color information.
virtual COLORREF | GetControlEditBackColor (CXTPControl *pControl)
This method returns the edit control back color to draw.
- Public Member Functions inherited from CXTPCommandBarsModernUITheme
CXTPCommandBarsModernUITheme ()
Constructs a CXTPCommandBarsModernUITheme object.
virtual | ~CXTPCommandBarsModernUITheme ()
Destroys a CXTPCommandBarsModernUITheme object, handles cleanup and deallocation.
virtual CXTPFramePaintManager * | GetFramePaintManager ()
Returns paint manager used to draw frames.
virtual CXTPRibbonPaintManager * | GetRibbonPaintManager ()
Retrieves the ribbon paint manager.
virtual CXTPMarkupContext * | GetMarkupContext ()
Retrieves a pointer to the markup context.
- Public Member Functions inherited from CXTPCommandBarsOfficeXPTheme
CXTPCommandBarsOfficeXPTheme ()
Constructs a CXTPCommandBarsOfficeXPTheme object.
virtual CSize | DrawListBoxControl (CDC *pDC, CXTPControl *pButton, CRect rc, BOOL bSelected, BOOL bDraw, CXTPCommandBars *pCommandBars=0)
This method is called to draw the control placed on the ListBox.
virtual void | AdjustExcludeRect (CRect &rc, CXTPControl *pControl, BOOL bVertical)
This method is called to determine the offset of a pop-up bar.
virtual CSize | DrawTearOffGripper (CDC *pDC, CRect rcGripper, BOOL bSelected, BOOL bDraw)
This method is called to draw a tear-off gripper of a pop-up bar.
virtual void | DrawPopupResizeGripper (CDC *pDC, CRect rcGripper, int nFlags)
This method is called to draw a resize gripper of a pop-up bar.
virtual CSize | DrawDialogBarGripper (CDC *pDC, CXTPDialogBar *pBar, BOOL bDraw)
Call this member to draw the gripper of a dialog bar.
- Public Member Functions inherited from CXTPPaintManager
virtual void | SetImageHandle (HMODULE hResource, LPCTSTR lpszIniFileName)
Specifies the resource that contains the bitmaps to be loaded for the theme.
CSize | DrawControl (CDC *pDC, CXTPControl *pButton, BOOL bDraw=TRUE)
This method is called to draw the control.
virtual CSize | DrawControlToolBarParent (CDC *pDC, CXTPControl *pButton, BOOL bDraw)
This method is called to draw the control placed on the toolbar.
virtual void | DrawControlEntry (CDC *pDC, CXTPControl *pButton)
This method is called to fill the control's face.
int | GetShadowOptions () const
Determines the kind of shadow to use.
virtual CSize | DrawSpecialControl (CDC *pDC, XTPSpecialControl controlType, CXTPControl *pButton, CXTPCommandBar *pBar, BOOL bDraw, LPVOID lpParam)
This method is called to draw the specified controls.
virtual CRect | GetSplitButtonCommandRect (CXTPControl *pButton)
Determines split button command rectangle.
virtual void | SetCommandBarRegion (CXTPCommandBar *pCommandBar)
Call this method to set the bounding region of a pop-up bar.
XTPPaintTheme GetCurrentTheme ()
Call this member to get the current visual theme.
virtual CFont * | GetControlFont (CXTPControl *pControl)
Call this member to retrieve the font of the command bar control.
virtual CFont * | GetCommandBarFont (CXTPCommandBar *pCommandBar)
Call this member to retrieve the font of the command bar.
virtual XTPBarTextOrientation | GetControlTextOrientation (CXTPControl *pControl)
Call this member to determine how to draw text.
virtual void | UpdateFonts ()
Refreshes the fonts to use.
virtual void | UpdateColors ()
Refreshes the standard colors to use.
void | SetCommandBarsFontIndirect (LOGFONT *pLogFont, BOOL bUseStandardFont=FALSE)
Call this member to set command bar's font.
CFont * | GetRegularFont ()
Returns the general font.
CFont * | GetRegularBoldFont ()
Returns the general bold font.
CFont * | GetIconFont ()
Returns the icon font.
CFont * | GetSmCaptionFont ()
Call this method to retrieve the caption of a floating mini frame.
void | UseOfficeFont (bool bUseOfficeFont)
Call this method to use Tahoma font despite system metrics.
int | GetControlHeight () const
This method returns the common controls height.
virtual CSize | GetDefaultCommandBarSize (CXTPCommandBar *pBar)
Computes default command bar size taking into account command bar font.
void | Rectangle (CDC *pDC, LPCRECT rc, int nPen, const int nBrush)
Draws a rectangle.
void | Rectangle (CDC *pDC, LPCRECT rc, COLORREF clrPen, COLORREF clrBrush)
Draws a rectangle.
void | RoundRect (CDC *pDC, LPCRECT rc, COLORREF clrPen, COLORREF clrBrush)
Draws a rectangle.
void | Draw3dRect (CDC *pDC, LPCRECT rc, int nTopLeft, int nBottomRight)
Call this member function to draw a three-dimensional rectangle.
void | Draw3dRect (CDC *pDC, LPCRECT rc, int frameThickness, COLORREF clrPen, COLORREF clrBrush)
Call this member function to draw a rectangle with predetermined thickness.
virtual void | DrawPopupBarCheckMark (CDC *pDC, CRect rcCheck, BOOL bEnabled, COLORREF clr)
Call this member function to draw a check mark.
void | DrawCheckMark (CDC *pDC, CRect rcCheck, COLORREF clr=0)
Call this member function to draw a check mark.
virtual void | DrawPopupBarRadioMark (CDC *pDC, CRect rcCheck, BOOL bEnabled, COLORREF clr)
Call this member function to draw a radio button.
virtual void | DrawComboExpandMark (CDC *pDC, CRect rc, COLORREF clr)
Call this member function to draw a combobox expand symbol.
void | Line (CDC *pDC, CPoint p0, CPoint p1)
Draws a line.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1, const int nPen)
Draws a line.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1, COLORREF clrPen)
Draws a line.
void | HorizontalLine (CDC *pDC, int x0, int y0, int x1, COLORREF clrPen)
Call this member function to draw a horizontal line using the specified coordinages and RGB color value.
void | VerticalLine (CDC *pDC, int x0, int y0, int y1, COLORREF clrPen)
Call this member function to draw a vertical line using the specified coordinages and RGB color value.
void | Pixel (CDC *pDC, int xPos, int yPos, int nPen)
Sets the pixel at the point.
void | GradientFill (CDC *pDC, LPRECT lpRect, COLORREF crFrom, COLORREF crTo, BOOL bHorz, LPCRECT lpRectClip=NULL)
Gradient fills the rectangle.
XTP_COMMANDBARS_ICONSINFO * GetIconsInfo ()
virtual void | Animate (CDC *pDestDC, CDC *pSrcDC, CRect rc, XTPAnimationType animationType)
This method is called to animate the pop-up bar.
virtual void | AnimateExpanding (CXTPCommandBar *pCommandBar, CDC *pDestDC, CDC *pSrcDC, BOOL bExpandDown)
This method is called to animate the expanding process.
void | SetAnimationDelay (int nAnimationSteps, int nAnimationTime)
Call this method to set animation delay.
COLORREF | GetXtremeColor (UINT nIndex)
This function retrieves the current color of the specified XP display element.
void | SetColors (int cElements, CONST INT *lpaElements, CONST COLORREF *lpaRgbValues)
Call this member to set the colors for each element to the color in the specified color array.
CSize | DrawControlText (CDC *pDC, CXTPControl *pControl, CRect rcText, BOOL bDraw, BOOL bVert, BOOL bCentered, BOOL bTriangled)
This method is called to draw control text.
virtual void | UpdateRTLCaption (CString &strCaption)
This method is called to prepare a caption for Right-To-Left draw.
XTPCurrentSystemTheme GetCurrentSystemTheme ()
Call this member function to determine the current Windows XP theme in use.
void | SetLunaTheme (XTPCurrentSystemTheme systemTheme)
Call this method to force system theme.
virtual int | GetPopupBarGripperWidth (CXTPCommandBar *pBar)
Calculates the gripper of a pop-up bar.
virtual CXTPControlGalleryPaintManager * | GetGalleryPaintManager () const
Retrieves paint manager used to draw galleries.
virtual CXTPScrollBarPaintManager * | GetScrollBarPaintManager () const
Retrieves paint manager used to draw scrollbars.
virtual CXTPSliderPaintManager * | GetSliderPaintManager () const
Retrieves paint manager used to draw slider panes.
virtual CXTPProgressPaintManager * | GetProgressPaintManager () const
Retrieves paint manager used to draw progress bars.
virtual CXTPStatusBarPaintManager * | GetStatusBarPaintManager ()
Retrieves paint manager used to draw the status bar.
virtual CXTPMessageBarPaintManager * | GetMessageBarPaintManager ()
Retrieves paint manager used to draw message bars.
CXTPShadowManager * | GetShadowManager () const
Retrieves shadow manager used to draw shadows.
BOOL | IsUseSystemAccentColorEnabled () const
Determines whether xtpApplicationUseSystemAccentColor application ambient property is set.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.
- Public Member Functions inherited from CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents >
void | Subscribe (IXTPPaintManagerEvents *pObserver, CXTPSubscriptionList< CXTPPaintManager, IXTPPaintManagerEvents > *pSubcriptionList=NULL)
Subscribes a unique observer for events.
void | Unsubscribe (IXTPPaintManagerEvents *pObserver)
Unsubscribes an observer from events.
void | Notify (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *))
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *))
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.

Protected Member Functions

virtual void | RefreshMetrics ()
This method is called to refresh the visual metrics of the manager.
virtual void | DrawSplitButtonFrame (CDC *pDC, CXTPControl *pButton, CRect rc)
This method is called to draw the frame for the SplitButton control.
virtual void | DrawRectangle (CDC *pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition)
This method is called to fill the control's face.
virtual void | DrawRectangle (CDC *pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition, int nID)
This method is called to fill the control's face.
virtual BOOL | DrawRectangle (CDC *pDC, CXTPControl *pButton)
This method is called to fill the control's face.
virtual COLORREF | GetControlTextColor (CXTPControl *pButton)
This method returns the control text color to draw.
virtual void | DrawGalleryItemBack (CDC *pDC, CRect rcItem, BOOL bEnabled, BOOL bSelected, BOOL bPressed, BOOL bChecked, XTPBarType barType)
This method is called to draw the background for a gallery menu item.
virtual void | DrawCheckRect (CDC *pDC, CRect rc, COLORREF clrFore, COLORREF clrBack)
Helper class called by DrawRectangle to render a checkmark background and border.
virtual CSize | DrawCommandBarGripper (CDC *pDC, CXTPCommandBar *pBar, BOOL bDraw=TRUE)
This method is called to draw the command bar's gripper.
virtual CSize | DrawControlComboBox (CDC *pDC, CXTPControlComboBox *pComboBox, BOOL bDraw)
This method is called to draw the control.
- Protected Member Functions inherited from CXTPCommandBarsOffice2013Theme
virtual void | RefreshStandardColors ()
Called to update the standard colors used by the framework.
virtual COLORREF | GetRectangleTextColor (BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition)
This method retrieves a buttons text color.
virtual COLORREF | GetControlBackColor (CXTPControl *pButton)
Call this method to get the control back color to draw.
void | DrawFrameBorder (CDC *pDC, CRect rc, int nBorderThickness, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition)
This method is called to fill the border of the control's face.
virtual void | DrawPopupBarGripper (CDC *pDC, int xPos, int yPos, int cx, int cy, BOOL bExpanded=FALSE)
This method is called to draw a pop-up bar's right gripper.
virtual void | DrawDropDownGlyph (CDC *pDC, CXTPControl *pControl, CPoint pt, BOOL bSelected, BOOL bPopuped, BOOL bEnabled, BOOL bVert)
This member function is called to draw a split button expand symbol.
virtual CSize | DrawCommandBarSeparator (CDC *pDC, CXTPCommandBar *pBar, CXTPControl *pControl, BOOL bDraw=TRUE)
This method is called to draw a command bar's separator.
virtual void | DrawExpandGlyph (CDC *pDC, CXTPControl *pButton, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clr)
Draw expand or hidden glyphs for a button.
virtual void | DrawHiddenGlyph (CDC *pDC, CXTPControl *pButton, COLORREF clr, BOOL bVertical)
Draw expand or hidden glyphs for a button.
virtual void | DrawExpandGlyph (CDC *pDC, CXTPControl *pButton, COLORREF clr, BOOL bVertical)
Draw expand or hidden glyphs for a button.
virtual CSize | DrawControlCheckBoxMark (CDC *pDC, CXTPControl *pButton, CRect rc, BOOL bDraw)
This method is called to draw a check box mark area.
virtual CSize | DrawControlCheckBoxMark (CDC *pDC, CRect rc, BOOL bDraw, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled)
This method is called to draw a check box mark area.
virtual CSize | DrawControlRadioButtonMark (CDC *pDC, CRect rc, BOOL bDraw, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled)
This method is called to draw a radio button mark area.
virtual void | DrawControlMDIButton (CDC *pDC, CXTPControlButton *pButton)
Call this member function to draw Menu MDI buttons.
- Protected Member Functions inherited from CXTPCommandBarsModernUITheme
- Protected Member Functions inherited from CXTPCommandBarsOfficeXPTheme
virtual CSize | DrawControlPopupParent (CDC *pDC, CXTPControl *pButton, BOOL bDraw)
This method is called to draw the control placed on the pop-up bar.
virtual void | DrawImage (CDC *pDC, CPoint pt, CSize sz, CXTPImageManagerIcon *pImage, BOOL bSelected, BOOL bPressed, BOOL bEnabled=TRUE, BOOL bChecked=FALSE, BOOL bPopuped=FALSE, BOOL bToolBarImage=TRUE)
This method is called to draw the image of the control.
void | FillIntersectRect (CDC *pDC, CXTPPopupBar *pPopupBar, COLORREF clr)
Draws intersect rectangle of a pop-up bar and its control.
- Protected Member Functions inherited from CXTPPaintManager
CXTPPaintManager ()
Constructs a CXTPPaintManager object.
virtual | ~CXTPPaintManager ()
Destroys a CXTPPaintManager object, handles cleanup and deallocation.
- Protected Member Functions inherited from CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents >
CXTPObservable ()
Constructs an observable object.
~CXTPObservable ()
Handles observable object destruction.

Protected Attributes

CXTPPaintManagerColor | m_clrActiveBack
CommandBars background color when window is active.
CXTPPaintManagerColor | m_clrInactiveBack
CommandBars background color when window is inactive.
- Protected Attributes inherited from CXTPCommandBarsOffice2013Theme
BOOL | m_bIntersect
TRUE to draw pop-up bar intersect rectangle.
CXTPColorSetStateMenu | m_csMenu
State colors used by Menu items.
CXTPColorSetStateMenuTitleBar | m_csMenuTitleBar
State colors used by MenuTitleBar items.
CXTPColorSetStateRibbon | m_csRibbon
State colors used by Ribbon group buttons.
CXTPColorSetStateToolbar | m_csToolbar
State colors used by Toolbar buttons.
CXTPColorSetStateCheckMark | m_csCheckMark
State colors used by Menu Check Marks.
CXTPColorSetStateComboBox | m_csComboBox
State colors used by ComboBox control.
CXTPColorSetStateCheckBox | m_csCheckBox
State colors used by Check Box and Radio Button controls.
CXTPPaintManagerColor | m_clrBack
CommandBars background color;.
CXTPPaintManagerColor | m_clrGlyph
Glyph Normal color.
CXTPPaintManagerColor | m_clrGlyphHighlight
Glyph Highlight color.
CXTPPaintManagerColor | m_clrGlyphPushed
Glyph Pushed color.
CXTPPaintManagerColor | m_clrGlyphDisabled
Glyph Disabled color.
CXTPPaintManagerColor | m_clrMessageBarText
Message bar text color.
CXTPPaintManagerColor | m_clrBtnFace
Button background color.
CXTPPaintManagerColor | m_clr3DShadow
Button shadow color.
CXTPPaintManagerColor | m_clrHighlight
Button highlight color.
CXTPPaintManagerColor | m_clrCaptionButtonFill
Text color for frame caption buttons.
CXTPPaintManagerColorGradient | m_clrWorkspace
Workspace area gradient color.
- Protected Attributes inherited from CXTPCommandBarsModernUITheme
CXTPMarkupContext * | m_pMarkupContext
Points to a valid markup context object.
CXTPResourceImages * | m_pImages
Points to a valid resource images object.
- Protected Attributes inherited from CXTPPaintManager
CXTPFont | m_xtpFontRegular
Regular font.
CXTPFont | m_xtpFontRegularBold
Regular bold font.
CXTPFont | m_xtpFontVert
Vertical font.
CXTPFont | m_xtpFontVertBold
Vertical font.
int | m_nEditHeight
Edit text height.
int | m_nFontHeight
Custom font height (optional).
BOOL | m_bUseStandardFont
TRUE to use system font.
BOOL | m_bEmbossedDisabledText
TRUE to draw disabled text embossed.
CXTPWinThemeWrapper * | m_themeStatusBar
StatusBar theme helper.
CXTPWinThemeWrapper * | m_themeButton
Buttons theme helper.
XTPPaintTheme | m_themeCurrent
Current theme.
XTP_COMMANDBARS_ICONSINFO | m_iconsInfo
Specific icons options.
int | m_nAnimationSteps
Steps of the animation.
int | m_nAnimationTime
Time of the animation.
BOOL | m_bShowKeyboardCues
TRUE to show keyboard cues - deprecated.
CXTPPaintManagerColor | m_arrColor [XPCOLOR_LAST+1]
Self colors array.
XTPCurrentSystemTheme | m_systemTheme
Current system theme.
CXTPShadowManager * | m_pShadowManager
Shadow manager.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPPaintManager
static CXTPPaintManager *AFX_CDECL | GetInstanceAddRef ()
Obtains a pointer to a global paint manager object and increments its reference counter.
static void AFX_CDECL | ReleaseInstance ()
Decrements global paint manager's reference counter and deletes its instance when the reference counter reaches 0.
static CXTPPaintManager *AFX_CDECL | CreateTheme (XTPPaintTheme paintTheme)
Creates a new CXTPPaintManager object.
static void AFX_CDECL | SetTheme (XTPPaintTheme paintTheme)
Call this member to switch the visual theme of the Command Bars.
static void AFX_CDECL | SetCustomTheme (CXTPPaintManager *pTheme)
Call this member to set a custom theme.
static void AFX_CDECL | Triangle (CDC *pDC, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clr)
Draws a triangle.
static BOOL AFX_CDECL | FontExists (LPCTSTR lpszFaceName)
Determines if a specified font exists in the system.
static void AFX_CDECL | StripMnemonics (CString &strClear)
This member function will search a string, strip off the mnemonic '&', and reformat the string.
static CXTPPaintManager *AFX_CDECL | GetGlobalPaintManager ()
Call this method to get the pointer to the global paint manager.
static void AFX_CDECL | SetGlobalPaintManager (CXTPPaintManager *pPaintManager)
Call this method to set the pointer to the global paint manager.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPPaintManager
COLORREF | m_clrMessageBarText
Message bar text color.
CRect | m_rcMessageBarMargin
Margin of the message bar.
CXTPFramePaintManager * | m_pFramePaintManager
Frame paint manager.
CXTPStatusBarPaintManager * | m_pStatusBarPaintManager
Paint manager of the status bar.
CXTPRibbonPaintManager * | m_pRibbonPaintManager
Ribbon paint Manager.
CXTPControlGalleryPaintManager * | m_pGalleryPaintManager
Gallery paint manager.
CXTPProgressPaintManager * | m_pProgressPaintManager
Progress bar paint manager.
CXTPSliderPaintManager * | m_pSliderPaintManager
Slider pane paint manager.
CXTPScrollBarPaintManager * | m_pScrollBarPaintManager
Scrollbar paint manager.
CXTPPaintManagerColorGradient | m_clrDisabledIcon
Disabled icons color.
CXTPPaintManagerColor | m_clrFloatingGripper
Gripper color of floating toolbar.
CXTPPaintManagerColor | m_clrFloatingGripperText
Gripper text color of floating toolbar.
BOOL | m_bThickCheckMark
TRUE to draw thick check mark.
BOOL | m_bShowShadow
TRUE to show shadow.
BOOL | m_bThemedStatusBar
TRUE to draw status bar using WinXP theme.
BOOL | m_bThemedCheckBox
TRUE to draw check box using WinXP theme.
BOOL | m_bClearTypeTextQuality
TRUE to enable ClearType text for the font.
BOOL | m_bFlatToolBar
TRUE to draw toolbars flat.
BOOL | m_bFlatMenuBar
TRUE to draw menubar flat.
int | m_nPopupBarTextPadding
Distance between gripper and control text.
BOOL | m_bSelectImageInPopupBar
TRUE to select image as in explorer theme.
BOOL | m_bEnableAnimation
TRUE to enable animation for all toolbars.
BOOL | m_bOffice2007Padding
TRUE if Office2007 metrics used.
BOOL | m_bOffsetPopupLabelText
TRUE if labels in pop-ups drawn with offset.
BOOL | m_bWrapCaptionBelowText
Wrap text for xtpButtonIconAndCaptionBelow buttons.
CXTPPaintManagerFont | m_fontSmCaption
Small caption font.
CXTPPaintManagerFont | m_fontIcon
Icon font.
CXTPPaintManagerFont | m_fontIconBold
Icon bold font.
CXTPPaintManagerFont | m_fontToolTip
Tooltip font.
int | m_nSplitButtonDropDownWidth
Split button drop down width in toolbars.
int | m_nSplitButtonDropDownHeight
Split button drop down height in toolbars.
int | m_nSplitButtonPopupWidth
Split button drop down width in pop-ups.
BOOL | m_bAutoResizeIcons
TRUE to automatically resize icons using current DPI.
int | m_nStatusBarMinHeight
Minimum height for the status bar.
PVOID | m_pfnSetLayeredWindowAttributes
point to Transparency proc in USER32.dll module.
CRect | m_rcStatusBarBorder
Bounding rectangle of the status bar border.
BOOL | m_bUseOfficeFont
TRUE to use Tahoma font.
CString | m_strOfficeFont
Office font.
int | m_nTextHeight
Regular text field height (not font height).

Detailed Description

The CXTPCommandBarsNativeWindows11Theme class is used to enable a Native Windows 10 style theme for Command Bars.

See also
CXTPPaintManager::SetTheme

Member Function Documentation

◆ DrawCheckRect()

virtual void DrawCheckRect | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | COLORREF | clrFore,
 |  | COLORREF | clrBack )
 protectedvirtual

Helper class called by DrawRectangle to render a checkmark background and border.

Parameters
pDC | Pointer to a valid device context
rc | Rectangle to draw.
clrFore | RGB color value used to draw border.
clrBack | RGB color value used to draw background.

◆ DrawCommandBarGripper()

virtual CSize DrawCommandBarGripper | ( | CDC * | pDC,
 |  | CXTPCommandBar * | pBar,
 |  | BOOL | bDraw = TRUE )
 protectedvirtual

This method is called to draw the command bar's gripper.

Parameters
pDC | Pointer to a valid device context.
pBar | Pointer to a CXTPCommandBar object.
bDraw | TRUE to draw; FALSE to retrieve the size of the gripper.
Returns
Size of the gripper.

Reimplemented from CXTPCommandBarsOffice2013Theme.

◆ DrawControlComboBox()

virtual CSize DrawControlComboBox | ( | CDC * | pDC,
 |  | CXTPControlComboBox * | pComboBox,
 |  | BOOL | bDraw )
 protectedvirtual

This method is called to draw the control.

Parameters
pDC | Pointer to a valid device context
bDraw | TRUE to draw; FALSE to retrieve the size of the control.
pComboBox | CXTPControlComboBox pointer need to draw.
Returns
Size of the control.

Reimplemented from CXTPCommandBarsOffice2013Theme.

◆ DrawGalleryItemBack()

virtual void DrawGalleryItemBack | ( | CDC * | pDC,
 |  | CRect | rcItem,
 |  | BOOL | bEnabled,
 |  | BOOL | bSelected,
 |  | BOOL | bPressed,
 |  | BOOL | bChecked,
 |  | XTPBarType | barType )
 protectedvirtual

This method is called to draw the background for a gallery menu item.

Parameters
pDC | Pointer to a valid device context.
rcItem | CRect object specifying the size of the area.
bSelected | TRUE if the control is selected.
bPressed | TRUE if the control is pushed.
bEnabled | TRUE if the control is enabled.
bChecked | TRUE if the control is checked.
barType | Parent's bar type.

Reimplemented from CXTPCommandBarsOffice2013Theme.

◆ DrawRectangle() [1/3]

virtual void DrawRectangle | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | BOOL | bSelected,
 |  | BOOL | bPressed,
 |  | BOOL | bEnabled,
 |  | BOOL | bChecked,
 |  | BOOL | bPopuped,
 |  | XTPBarType | barType,
 |  | XTPBarPosition | barPosition )
 protectedvirtual

This method is called to fill the control's face.

Parameters
pDC | Pointer to a valid device context
rc | Rectangle to draw.
bSelected | TRUE if the control is selected.
bPressed | TRUE if the control is pushed.
bEnabled | TRUE if the control is enabled.
bChecked | TRUE if the control is checked.
bPopuped | TRUE if the control is pop-up'ed.
barType | Parent's bar type.
barPosition | Parent's bar position.

Reimplemented from CXTPCommandBarsOffice2013Theme.

◆ DrawRectangle() [2/3]

virtual void DrawRectangle | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | BOOL | bSelected,
 |  | BOOL | bPressed,
 |  | BOOL | bEnabled,
 |  | BOOL | bChecked,
 |  | BOOL | bPopuped,
 |  | XTPBarType | barType,
 |  | XTPBarPosition | barPosition,
 |  | int | nID )
 protectedvirtual

This method is called to fill the control's face.

Parameters
pDC | Pointer to a valid device context
rc | Rectangle to draw.
bSelected | TRUE if the control is selected.
bPressed | TRUE if the control is pushed.
bEnabled | TRUE if the control is enabled.
bChecked | TRUE if the control is checked.
bPopuped | TRUE if the control is pop-up'ed.
barType | Parent's bar type.
barPosition | Parent's bar position.
nID | Bar's control ID.

Reimplemented from CXTPCommandBarsOffice2013Theme.

◆ DrawRectangle() [3/3]

virtual BOOL DrawRectangle | ( | CDC * | pDC,
 |  | CXTPControl * | pButton )
 protectedvirtual

This method is called to fill the control's face.

Parameters
pDC | Pointer to a valid device context.
pButton | pointer to a button
Returns
TRUE if the rectange was drawn, otherwise FALSE.

Reimplemented from CXTPCommandBarsOffice2013Theme.

◆ DrawSplitButtonFrame()

virtual void DrawSplitButtonFrame | ( | CDC * | pDC,
 |  | CXTPControl * | pButton,
 |  | CRect | rc )
 protectedvirtual

This method is called to draw the frame for the SplitButton control.

Parameters
pDC | Pointer to a valid device context.
pButton | Pointer to a CXTPControl object.
rc | Bounding rectangle to draw.

Reimplemented from CXTPCommandBarsOffice2013Theme.

◆ FillCommandBarEntry()

virtual void FillCommandBarEntry | ( | CDC * | pDC,
 |  | CXTPCommandBar * | pBar )
 virtual

This method is called to fill the command bar's face.

Parameters
pDC | Pointer to a valid device context.
pBar | Pointer to a CXTPCommandBar object to draw.

Reimplemented from CXTPCommandBarsOffice2013Theme.

◆ FillDockBar()

virtual void FillDockBar | ( | CDC * | pDC,
 |  | CXTPDockBar * | pBar )
 virtual

This method is called to fill a dock bar.

Parameters
pDC | Pointer to a valid device context.
pBar | Pointer to a CXTPDockBar object.

Reimplemented from CXTPCommandBarsOffice2013Theme.

◆ GetCommandBarBorders()

virtual CRect GetCommandBarBorders ( CXTPCommandBar * pBar )
virtual

This method is called to retrieve the command bar's borders.

Parameters
pBar Pointer to a CXTPCommandBar object.
Returns
Borders of the command bar.

Reimplemented from CXTPPaintManager.

◆ GetControlTextColor()

virtual COLORREF GetControlTextColor ( CXTPControl * pButton )
protectedvirtual

This method returns the control text color to draw.

Parameters
pButton Pointer to a CXTPControl object to draw.
Returns
Returns control text color

Reimplemented from CXTPCommandBarsOffice2013Theme.

◆ GetStateColor()

virtual COLORREF GetStateColor ( ) const
virtual

Call this member function to gets the application state color for the frame border and status bar.

Returns
Returns application state color

◆ SetStateColor()

virtual void SetStateColor ( COLORREF clrState = COLORREF_NULL )
virtual

Call this member function to set the application state color for the frame border and status bar.

Parameters
clrState COLORREF value representing the application state color. Use COLORREF_NULL to reset back to default color.
The documentation for this class was generated from the following file:
  • XTPCommandBarsNativeWindows11Theme.h


Toolkit Pro: CXTPCommandBarsNativeXPTheme Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPCommandBarsNativeXPTheme Class Reference

The CXTPCommandBarsNativeXPTheme class is used to enable a Native Windows XP style theme for Command Bars. More...

Inheritance diagram for CXTPCommandBarsNativeXPTheme:
[legend]

Public Member Functions

CXTPCommandBarsNativeXPTheme ()
Constructs a CXTPCommandBarsNativeXPTheme object.
~CXTPCommandBarsNativeXPTheme ()
Destroys a CXTPCommandBarsNativeXPTheme object, handles cleanup and deallocation.
- Public Member Functions inherited from CXTPCommandBarsOffice2000Theme
CXTPCommandBarsOffice2000Theme ()
Constructs a CXTPCommandBarsOffice2000Theme object.
virtual CRect | GetCommandBarBorders (CXTPCommandBar *pBar)
This method is called to retrieve the command bar's borders.
virtual CSize | DrawListBoxControl (CDC *pDC, CXTPControl *pButton, CRect rc, BOOL bSelected, BOOL bDraw, CXTPCommandBars *pCommandBars=0)
This method is called to draw the control placed on the ListBox.
virtual CSize | DrawTearOffGripper (CDC *pDC, CRect rcGripper, BOOL bSelected, BOOL bDraw)
This method is called to draw a tear-off gripper of a pop-up bar.
virtual void | DrawPopupResizeGripper (CDC *pDC, CRect rcGripper, int nFlags)
This method is called to draw the pop-up bar resize gripper.
- Public Member Functions inherited from CXTPPaintManager
virtual void | SetImageHandle (HMODULE hResource, LPCTSTR lpszIniFileName)
Specifies the resource that contains the bitmaps to be loaded for the theme.
CSize | DrawControl (CDC *pDC, CXTPControl *pButton, BOOL bDraw=TRUE)
This method is called to draw the control.
virtual CSize | DrawControlToolBarParent (CDC *pDC, CXTPControl *pButton, BOOL bDraw)
This method is called to draw the control placed on the toolbar.
virtual COLORREF | GetControlEditBackColor (CXTPControl *pControl)
This method returns the edit control back color to draw.
virtual COLORREF | GetControlBackColor (CXTPControl *pButton)
Call this method to get the control back color to draw.
virtual void | DrawGalleryItemBack (CDC *pDC, CRect rcItem, BOOL bEnabled, BOOL bSelected, BOOL bPressed, BOOL bChecked, XTPBarType barType)
This method is called to draw the background for a gallery menu item.
virtual void | DrawCommandBarGroupSeparator (CDC *pDC, CXTPCommandBar *pBar, CXTPControl *pLeftControl, CXTPControl *pRightControl, BOOL bDraw=TRUE)
This method is called to draw a command bar's group separator.
virtual void | FillWorkspace (CDC *pDC, CRect rc, CRect rcExclude)
This method is called to fill a workspace.
int | GetShadowOptions () const
Determines the kind of shadow to use.
virtual void | DrawExpandGlyph (CDC *pDC, CXTPControl *pButton, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clr)
Draw expand or hidden glyphs for a button.
virtual void | DrawExpandGlyph (CDC *pDC, CXTPControl *pButton, COLORREF clr, BOOL bVertical)
Draw expand or hidden glyphs for a button.
virtual void | DrawHiddenGlyph (CDC *pDC, CXTPControl *pButton, COLORREF clr, BOOL bVertical)
Draw expand or hidden glyphs for a button.
virtual CRect | GetSplitButtonCommandRect (CXTPControl *pButton)
Determines split button command rectangle.
virtual void | SetCommandBarRegion (CXTPCommandBar *pCommandBar)
Call this method to set the bounding region of a pop-up bar.
virtual CSize | DrawControlCheckBoxMark (CDC *pDC, CRect rc, BOOL bDraw, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled)
This method is called to draw a check box mark area.
virtual CSize | DrawControlCheckBoxMark (CDC *pDC, CXTPControl *pButton, CRect rc, BOOL bDraw)
This method is called to draw a check box mark area.
virtual CSize | DrawControlRadioButtonMark (CDC *pDC, CRect rc, BOOL bDraw, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled)
This method is called to draw a radio button mark area.
XTPPaintTheme GetCurrentTheme ()
Call this member to get the current visual theme.
virtual BOOL | RequiresResourceImages ()
Used by the paint manager to determine if the theme requires a resource DLL to load image and color information.
virtual CFont * | GetControlFont (CXTPControl *pControl)
Call this member to retrieve the font of the command bar control.
virtual CFont * | GetCommandBarFont (CXTPCommandBar *pCommandBar)
Call this member to retrieve the font of the command bar.
virtual XTPBarTextOrientation | GetControlTextOrientation (CXTPControl *pControl)
Call this member to determine how to draw text.
virtual void | UpdateFonts ()
Refreshes the fonts to use.
virtual void | UpdateColors ()
Refreshes the standard colors to use.
void | SetCommandBarsFontIndirect (LOGFONT *pLogFont, BOOL bUseStandardFont=FALSE)
Call this member to set command bar's font.
CFont * | GetRegularFont ()
Returns the general font.
CFont * | GetRegularBoldFont ()
Returns the general bold font.
CFont * | GetIconFont ()
Returns the icon font.
CFont * | GetSmCaptionFont ()
Call this method to retrieve the caption of a floating mini frame.
void | UseOfficeFont (bool bUseOfficeFont)
Call this method to use Tahoma font despite system metrics.
int | GetControlHeight () const
This method returns the common controls height.
virtual CSize | GetDefaultCommandBarSize (CXTPCommandBar *pBar)
Computes default command bar size taking into account command bar font.
void | Rectangle (CDC *pDC, LPCRECT rc, int nPen, const int nBrush)
Draws a rectangle.
void | Rectangle (CDC *pDC, LPCRECT rc, COLORREF clrPen, COLORREF clrBrush)
Draws a rectangle.
void | RoundRect (CDC *pDC, LPCRECT rc, COLORREF clrPen, COLORREF clrBrush)
Draws a rectangle.
void | Draw3dRect (CDC *pDC, LPCRECT rc, int nTopLeft, int nBottomRight)
Call this member function to draw a three-dimensional rectangle.
void | Draw3dRect (CDC *pDC, LPCRECT rc, int frameThickness, COLORREF clrPen, COLORREF clrBrush)
Call this member function to draw a rectangle with predetermined thickness.
void | DrawCheckMark (CDC *pDC, CRect rcCheck, COLORREF clr=0)
Call this member function to draw a check mark.
virtual void | DrawComboExpandMark (CDC *pDC, CRect rc, COLORREF clr)
Call this member function to draw a combobox expand symbol.
void | Line (CDC *pDC, CPoint p0, CPoint p1)
Draws a line.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1, const int nPen)
Draws a line.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1, COLORREF clrPen)
Draws a line.
void | HorizontalLine (CDC *pDC, int x0, int y0, int x1, COLORREF clrPen)
Call this member function to draw a horizontal line using the specified coordinages and RGB color value.
void | VerticalLine (CDC *pDC, int x0, int y0, int y1, COLORREF clrPen)
Call this member function to draw a vertical line using the specified coordinages and RGB color value.
virtual void | DrawDropDownGlyph (CDC *pDC, CXTPControl *pControl, CPoint pt, BOOL bSelected, BOOL bPopuped, BOOL bEnabled, BOOL bVert)
This member function is called to draw a split button expand symbol.
void | Pixel (CDC *pDC, int xPos, int yPos, int nPen)
Sets the pixel at the point.
void | GradientFill (CDC *pDC, LPRECT lpRect, COLORREF crFrom, COLORREF crTo, BOOL bHorz, LPCRECT lpRectClip=NULL)
Gradient fills the rectangle.
XTP_COMMANDBARS_ICONSINFO * GetIconsInfo ()
virtual void | Animate (CDC *pDestDC, CDC *pSrcDC, CRect rc, XTPAnimationType animationType)
This method is called to animate the pop-up bar.
virtual void | AnimateExpanding (CXTPCommandBar *pCommandBar, CDC *pDestDC, CDC *pSrcDC, BOOL bExpandDown)
This method is called to animate the expanding process.
void | SetAnimationDelay (int nAnimationSteps, int nAnimationTime)
Call this method to set animation delay.
COLORREF | GetXtremeColor (UINT nIndex)
This function retrieves the current color of the specified XP display element.
void | SetColors (int cElements, CONST INT *lpaElements, CONST COLORREF *lpaRgbValues)
Call this member to set the colors for each element to the color in the specified color array.
CSize | DrawControlText (CDC *pDC, CXTPControl *pControl, CRect rcText, BOOL bDraw, BOOL bVert, BOOL bCentered, BOOL bTriangled)
This method is called to draw control text.
virtual void | UpdateRTLCaption (CString &strCaption)
This method is called to prepare a caption for Right-To-Left draw.
XTPCurrentSystemTheme GetCurrentSystemTheme ()
Call this member function to determine the current Windows XP theme in use.
void | SetLunaTheme (XTPCurrentSystemTheme systemTheme)
Call this method to force system theme.
virtual CXTPControlGalleryPaintManager * | GetGalleryPaintManager () const
Retrieves paint manager used to draw galleries.
virtual CXTPScrollBarPaintManager * | GetScrollBarPaintManager () const
Retrieves paint manager used to draw scrollbars.
virtual CXTPSliderPaintManager * | GetSliderPaintManager () const
Retrieves paint manager used to draw slider panes.
virtual CXTPProgressPaintManager * | GetProgressPaintManager () const
Retrieves paint manager used to draw progress bars.
virtual CXTPFramePaintManager * | GetFramePaintManager ()
Retrieves paint manager used to draw frames.
virtual CXTPStatusBarPaintManager * | GetStatusBarPaintManager ()
Retrieves paint manager used to draw the status bar.
virtual CXTPRibbonPaintManager * | GetRibbonPaintManager ()
Retrieves the ribbon paint manager.
virtual CXTPMessageBarPaintManager * | GetMessageBarPaintManager ()
Retrieves paint manager used to draw message bars.
CXTPShadowManager * | GetShadowManager () const
Retrieves shadow manager used to draw shadows.
BOOL | IsUseSystemAccentColorEnabled () const
Determines whether xtpApplicationUseSystemAccentColor application ambient property is set.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.
- Public Member Functions inherited from CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents >
void | Subscribe (IXTPPaintManagerEvents *pObserver, CXTPSubscriptionList< CXTPPaintManager, IXTPPaintManagerEvents > *pSubcriptionList=NULL)
Subscribes a unique observer for events.
void | Unsubscribe (IXTPPaintManagerEvents *pObserver)
Unsubscribes an observer from events.
void | Notify (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *))
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *))
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.

Protected Member Functions

virtual void | RefreshMetrics ()
This method is called to refresh the visual metrics of the manager.
virtual void | FillCommandBarEntry (CDC *pDC, CXTPCommandBar *pBar)
This method is called to fill the command bar's face.
virtual void | DrawRectangle (CDC *pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition)
This method is called to fill the control's face.
virtual BOOL | DrawRectangle (CDC *pDC, CXTPControl *pButton)
This method is called to fill the control's face.
void | DrawControlEntry (CDC *pDC, CXTPControl *pButton)
This method is called to fill the control's face.
COLORREF | GetControlTextColor (CXTPControl *pButton)
This method returns the control text color to draw.
virtual CSize | DrawCommandBarGripper (CDC *pDC, CXTPCommandBar *pBar, BOOL bDraw=TRUE)
This method is called to draw the command bar's gripper.
virtual void | FillDockBar (CDC *pDC, CXTPDockBar *pBar)
This method is called to fill a dockbar.
void | FillDockBarRect (CDC *pDC, CWnd *pWnd, CWnd *pFrame)
This method is called to fill a dockbar.
void | AdjustExcludeRect (CRect &rc, CXTPControl *pControl, BOOL bVertical)
This method is called to determine the offset of a pop-up bar.
void | DrawSplitButtonFrame (CDC *pDC, CXTPControl *pButton, CRect rcButton)
Draws a split button frame.
virtual void | DrawControlEditFrame (CDC *pDC, CRect rc, BOOL bEnabled, BOOL bSelected)
This method is called to draw the frame of edit control.
virtual void | DrawControlComboBoxButton (CDC *pDC, CRect rcBtn, BOOL bEnabled, BOOL bSelected, BOOL bDropped)
This method is called to draw the button of a combobox control.
virtual CSize | DrawDialogBarGripper (CDC *pDC, CXTPDialogBar *pBar, BOOL bDraw)
Call this member to draw the gripper of a dialog bar.
virtual CSize | DrawCommandBarSeparator (CDC *pDC, CXTPCommandBar *pBar, CXTPControl *pControl, BOOL bDraw=TRUE)
This method is called to draw a command bar's separator.
virtual COLORREF | GetRectangleTextColor (BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition)
This method retrieves a buttons text color.
virtual XTPPaintTheme | BaseTheme ()
Retrieves the base theme of the manager.
BOOL | IsThemeEnabled () const
Determines if WinXP theme is enabled.
virtual void | DrawControlEditSpin (CDC *pDC, CXTPControlEdit *pControlEdit)
This method draws edit control spin buttons.
virtual CSize | DrawSpecialControl (CDC *pDC, XTPSpecialControl controlType, CXTPControl *pButton, CXTPCommandBar *pBar, BOOL bDraw, LPVOID lpParam)
This method is called to draw the specified controls.
virtual void | DrawPopupBarGripper (CDC *pDC, int xPos, int yPos, int cx, int cy, BOOL bExpanded=FALSE)
This method is called to draw a pop-up bar's right gripper.
virtual void | DrawPopupBarCheckMark (CDC *pDC, CRect rcCheck, BOOL bEnabled, COLORREF clr)
Call this member function to draw a check mark.
virtual void | DrawPopupBarRadioMark (CDC *pDC, CRect rcCheck, BOOL bEnabled, COLORREF clr)
Call this member function to draw a radio button.
virtual int | GetPopupBarGripperWidth (CXTPCommandBar *pBar)
Calculates the gripper of a pop-up bar.
virtual void | DrawControlMDIButton (CDC *pDC, CXTPControlButton *pButton)
Call this member function to draw Menu MDI buttons.
- Protected Member Functions inherited from CXTPCommandBarsOffice2000Theme
virtual CSize | DrawControlPopupParent (CDC *pDC, CXTPControl *pButton, BOOL bDraw)
This method is called to draw the control placed on the pop-up bar.
virtual void | DrawImage (CDC *pDC, CPoint pt, CSize sz, CXTPImageManagerIcon *pImage, BOOL bSelected, BOOL bPressed, BOOL bEnabled=TRUE, BOOL bChecked=FALSE, BOOL bPopuped=FALSE, BOOL bToolBarImage=TRUE)
This method is called to draw the image of the control.
virtual CSize | DrawControlComboBox (CDC *pDC, CXTPControlComboBox *pComboBox, BOOL bDraw)
This method is called to draw the control.
virtual CSize | DrawControlEdit (CDC *pDC, CXTPControlEdit *pEdit, BOOL bDraw)
This method is called to draw the control.
- Protected Member Functions inherited from CXTPPaintManager
CXTPPaintManager ()
Constructs a CXTPPaintManager object.
virtual | ~CXTPPaintManager ()
Destroys a CXTPPaintManager object, handles cleanup and deallocation.
- Protected Member Functions inherited from CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents >
CXTPObservable ()
Constructs an observable object.
~CXTPObservable ()
Handles observable object destruction.

Protected Attributes

CXTPWinThemeWrapper * | m_themeRebar
Rebar theme helper.
CXTPWinThemeWrapper * | m_themeToolbar
Toolbar theme helper.
CXTPWinThemeWrapper * | m_themeCombo
ComboBox theme helper.
CXTPWinThemeWrapper * | m_themeWindow
Window theme helper.
CXTPWinThemeWrapper * | m_themeSpin
Window theme helper.
CXTPWinThemeWrapper * | m_themeMenu
Menu theme helper.
COLORREF | m_clrEdgeShadowColor
Color of toolbar bottom line.
COLORREF | m_clrEdgeHighLightColor
Color of toolbar top line.
BOOL | m_bFlatMenus
TRUE if OS flat menu option enabled.
COLORREF | m_clrSelectedText
Selected text color.
COLORREF | m_clrPressedText
Pressed text color.
- Protected Attributes inherited from CXTPCommandBarsOffice2000Theme
int | m_nPopupBarText
Pop-up bar text index.
- Protected Attributes inherited from CXTPPaintManager
CXTPFont | m_xtpFontRegular
Regular font.
CXTPFont | m_xtpFontRegularBold
Regular bold font.
CXTPFont | m_xtpFontVert
Vertical font.
CXTPFont | m_xtpFontVertBold
Vertical font.
int | m_nEditHeight
Edit text height.
int | m_nFontHeight
Custom font height (optional).
BOOL | m_bUseStandardFont
TRUE to use system font.
BOOL | m_bEmbossedDisabledText
TRUE to draw disabled text embossed.
CXTPWinThemeWrapper * | m_themeStatusBar
StatusBar theme helper.
CXTPWinThemeWrapper * | m_themeButton
Buttons theme helper.
XTPPaintTheme | m_themeCurrent
Current theme.
XTP_COMMANDBARS_ICONSINFO | m_iconsInfo
Specific icons options.
int | m_nAnimationSteps
Steps of the animation.
int | m_nAnimationTime
Time of the animation.
BOOL | m_bShowKeyboardCues
TRUE to show keyboard cues - deprecated.
CXTPPaintManagerColor | m_arrColor [XPCOLOR_LAST+1]
Self colors array.
XTPCurrentSystemTheme | m_systemTheme
Current system theme.
CXTPShadowManager * | m_pShadowManager
Shadow manager.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPPaintManager
static CXTPPaintManager *AFX_CDECL | GetInstanceAddRef ()
Obtains a pointer to a global paint manager object and increments its reference counter.
static void AFX_CDECL | ReleaseInstance ()
Decrements global paint manager's reference counter and deletes its instance when the reference counter reaches 0.
static CXTPPaintManager *AFX_CDECL | CreateTheme (XTPPaintTheme paintTheme)
Creates a new CXTPPaintManager object.
static void AFX_CDECL | SetTheme (XTPPaintTheme paintTheme)
Call this member to switch the visual theme of the Command Bars.
static void AFX_CDECL | SetCustomTheme (CXTPPaintManager *pTheme)
Call this member to set a custom theme.
static void AFX_CDECL | Triangle (CDC *pDC, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clr)
Draws a triangle.
static BOOL AFX_CDECL | FontExists (LPCTSTR lpszFaceName)
Determines if a specified font exists in the system.
static void AFX_CDECL | StripMnemonics (CString &strClear)
This member function will search a string, strip off the mnemonic '&', and reformat the string.
static CXTPPaintManager *AFX_CDECL | GetGlobalPaintManager ()
Call this method to get the pointer to the global paint manager.
static void AFX_CDECL | SetGlobalPaintManager (CXTPPaintManager *pPaintManager)
Call this method to set the pointer to the global paint manager.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPPaintManager
COLORREF | m_clrMessageBarText
Message bar text color.
CRect | m_rcMessageBarMargin
Margin of the message bar.
CXTPFramePaintManager * | m_pFramePaintManager
Frame paint manager.
CXTPStatusBarPaintManager * | m_pStatusBarPaintManager
Paint manager of the status bar.
CXTPRibbonPaintManager * | m_pRibbonPaintManager
Ribbon paint Manager.
CXTPControlGalleryPaintManager * | m_pGalleryPaintManager
Gallery paint manager.
CXTPProgressPaintManager * | m_pProgressPaintManager
Progress bar paint manager.
CXTPSliderPaintManager * | m_pSliderPaintManager
Slider pane paint manager.
CXTPScrollBarPaintManager * | m_pScrollBarPaintManager
Scrollbar paint manager.
CXTPPaintManagerColorGradient | m_clrDisabledIcon
Disabled icons color.
CXTPPaintManagerColor | m_clrFloatingGripper
Gripper color of floating toolbar.
CXTPPaintManagerColor | m_clrFloatingGripperText
Gripper text color of floating toolbar.
BOOL | m_bThickCheckMark
TRUE to draw thick check mark.
BOOL | m_bShowShadow
TRUE to show shadow.
BOOL | m_bThemedStatusBar
TRUE to draw status bar using WinXP theme.
BOOL | m_bThemedCheckBox
TRUE to draw check box using WinXP theme.
BOOL | m_bClearTypeTextQuality
TRUE to enable ClearType text for the font.
BOOL | m_bFlatToolBar
TRUE to draw toolbars flat.
BOOL | m_bFlatMenuBar
TRUE to draw menubar flat.
int | m_nPopupBarTextPadding
Distance between gripper and control text.
BOOL | m_bSelectImageInPopupBar
TRUE to select image as in explorer theme.
BOOL | m_bEnableAnimation
TRUE to enable animation for all toolbars.
BOOL | m_bOffice2007Padding
TRUE if Office2007 metrics used.
BOOL | m_bOffsetPopupLabelText
TRUE if labels in pop-ups drawn with offset.
BOOL | m_bWrapCaptionBelowText
Wrap text for xtpButtonIconAndCaptionBelow buttons.
CXTPPaintManagerFont | m_fontSmCaption
Small caption font.
CXTPPaintManagerFont | m_fontIcon
Icon font.
CXTPPaintManagerFont | m_fontIconBold
Icon bold font.
CXTPPaintManagerFont | m_fontToolTip
Tooltip font.
int | m_nSplitButtonDropDownWidth
Split button drop down width in toolbars.
int | m_nSplitButtonDropDownHeight
Split button drop down height in toolbars.
int | m_nSplitButtonPopupWidth
Split button drop down width in pop-ups.
BOOL | m_bAutoResizeIcons
TRUE to automatically resize icons using current DPI.
int | m_nStatusBarMinHeight
Minimum height for the status bar.
PVOID | m_pfnSetLayeredWindowAttributes
point to Transparency proc in USER32.dll module.
CRect | m_rcStatusBarBorder
Bounding rectangle of the status bar border.
BOOL | m_bUseOfficeFont
TRUE to use Tahoma font.
CString | m_strOfficeFont
Office font.
int | m_nTextHeight
Regular text field height (not font height).

Detailed Description

The CXTPCommandBarsNativeXPTheme class is used to enable a Native Windows XP style theme for Command Bars.

See also
CXTPPaintManager::SetTheme

Member Function Documentation

◆ AdjustExcludeRect()

void AdjustExcludeRect | ( | CRect & | rc,
 |  | CXTPControl * | pControl,
 |  | BOOL | bVertical )
 protectedvirtual

This method is called to determine the offset of a pop-up bar.

Parameters
rc | Control's bounding rectangle.
pControl | Pointer to a CXTPControl object.
bVertical | TRUE if the control is docked vertically.

Reimplemented from CXTPCommandBarsOffice2000Theme.

◆ BaseTheme()

virtual XTPPaintTheme BaseTheme ( )
inlineprotectedvirtual

Retrieves the base theme of the manager.

Returns
The base theme of the manager.

Reimplemented from CXTPCommandBarsOffice2000Theme.

◆ DrawCommandBarGripper()

virtual CSize DrawCommandBarGripper | ( | CDC * | pDC,
 |  | CXTPCommandBar * | pBar,
 |  | BOOL | bDraw = TRUE )
 protectedvirtual

This method is called to draw the command bar's gripper.

Parameters
pDC | Pointer to a valid device context.
pBar | Pointer to a CXTPCommandBar object.
bDraw | TRUE to draw; FALSE to retrieve the size of the gripper.
Returns
Size of the gripper.

Reimplemented from CXTPCommandBarsOffice2000Theme.

◆ DrawCommandBarSeparator()

virtual CSize DrawCommandBarSeparator | ( | CDC * | pDC,
 |  | CXTPCommandBar * | pBar,
 |  | CXTPControl * | pControl,
 |  | BOOL | bDraw = TRUE )
 protectedvirtual

This method is called to draw a command bar's separator.

Parameters
pDC | Pointer to a valid device context.
pBar | Pointer to a CXTPCommandBar object.
pControl | Pointer to a CXTPControl object.
bDraw | TRUE to draw; FALSE to retrieve the size of the separator.
Returns
Size of the separator.

Reimplemented from CXTPCommandBarsOffice2000Theme.

◆ DrawControlComboBoxButton()

virtual void DrawControlComboBoxButton | ( | CDC * | pDC,
 |  | CRect | rcBtn,
 |  | BOOL | bEnabled,
 |  | BOOL | bSelected,
 |  | BOOL | bDropped )
 protectedvirtual

This method is called to draw the button of a combobox control.

Parameters
pDC | Points to a valid device context.
rcBtn | Button bounding rectangle.
bEnabled | TRUE if combobox is enabled.
bSelected | TRUE if combobox is selected.
bDropped | TRUE if combobox is dropped.

Reimplemented from CXTPCommandBarsOffice2000Theme.

◆ DrawControlEditFrame()

virtual void DrawControlEditFrame | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | BOOL | bEnabled,
 |  | BOOL | bSelected )
 protectedvirtual

This method is called to draw the frame of edit control.

Parameters
pDC | Points to a valid device context.
rc | CRect object specifying the size of the area.
bEnabled | TRUE if control is enabled.
bSelected | TRUE if control is selected.

Reimplemented from CXTPCommandBarsOffice2000Theme.

◆ DrawControlEditSpin()

virtual void DrawControlEditSpin | ( | CDC * | pDC,
 |  | CXTPControlEdit * | pControlEdit )
 protectedvirtual

This method draws edit control spin buttons.

Parameters
pDC | Pointer to device context.
pControlEdit | Edit control.

Reimplemented from CXTPCommandBarsOffice2000Theme.

◆ DrawControlEntry()

void DrawControlEntry | ( | CDC * | pDC,
 |  | CXTPControl * | pButton )
 protectedvirtual

This method is called to fill the control's face.

Parameters
pDC | Pointer to a valid device context.
pButton | Pointer to a CXTPControl object to draw.

Reimplemented from CXTPPaintManager.

◆ DrawControlMDIButton()

virtual void DrawControlMDIButton | ( | CDC * | pDC,
 |  | CXTPControlButton * | pButton )
 protectedvirtual

Call this member function to draw Menu MDI buttons.

Parameters
pDC | Pointer to a valid device context.
pButton | Button to draw.

Reimplemented from CXTPPaintManager.

◆ DrawDialogBarGripper()

virtual CSize DrawDialogBarGripper | ( | CDC * | pDC,
 |  | CXTPDialogBar * | pBar,
 |  | BOOL | bDraw )
 protectedvirtual

Call this member to draw the gripper of a dialog bar.

Parameters
pDC | Pointer to a valid device context.
pBar | Dialog Bar pointer.
bDraw | TRUE to draw gripper, FALSE to calculate size.
Returns
Size of gripper to be drawn.

Reimplemented from CXTPCommandBarsOffice2000Theme.

◆ DrawPopupBarCheckMark()

virtual void DrawPopupBarCheckMark | ( | CDC * | pDC,
 |  | CRect | rcCheck,
 |  | BOOL | bEnabled,
 |  | COLORREF | clr )
 protectedvirtual

Call this member function to draw a check mark.

Parameters
pDC | Pointer to a valid device context.
rcCheck | Specifies the rectangle in logical units.
clr | Color to fill.
bEnabled | TRUE to enable, FALSE to disable the button.

Reimplemented from CXTPPaintManager.

◆ DrawPopupBarGripper()

virtual void DrawPopupBarGripper | ( | CDC * | pDC,
 |  | int | xPos,
 |  | int | yPos,
 |  | int | cx,
 |  | int | cy,
 |  | BOOL | bExpanded = FALSE )
 protectedvirtual

This method is called to draw a pop-up bar's right gripper.

Parameters
pDC | Points to a valid device context.
xPos | Specifies the logical x coordinate of the upper-left corner of the rectangle.
yPos | Specifies the logical y coordinate of the upper-left corner of the destination rectangle.
cx | Specifies the width of the rectangle.
cy | Specifies the height of the rectangle.
bExpanded | TRUE if expanded.

Reimplemented from CXTPPaintManager.

◆ DrawPopupBarRadioMark()

virtual void DrawPopupBarRadioMark | ( | CDC * | pDC,
 |  | CRect | rcCheck,
 |  | BOOL | bEnabled,
 |  | COLORREF | clr )
 protectedvirtual

Call this member function to draw a radio button.

Parameters
pDC | Pointer to a valid device context.
rcCheck | Specifies the rectangle in logical units.
clr | Color to fill.
bEnabled | TRUE to enable, FALSE to disable the button.

Reimplemented from CXTPPaintManager.

◆ DrawRectangle() [1/2]

virtual void DrawRectangle | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | BOOL | bSelected,
 |  | BOOL | bPressed,
 |  | BOOL | bEnabled,
 |  | BOOL | bChecked,
 |  | BOOL | bPopuped,
 |  | XTPBarType | barType,
 |  | XTPBarPosition | barPosition )
 protectedvirtual

This method is called to fill the control's face.

Parameters
pDC | Pointer to a valid device context.
rc | Rectangle to draw.
bSelected | TRUE if the control is selected.
bPressed | TRUE if the control is pushed.
bEnabled | TRUE if the control is enabled.
bChecked | TRUE if the control is checked.
bPopuped | TRUE if the control is pop-up'ed.
barType | Parent's bar type
barPosition | Parent's bar position.

Reimplemented from CXTPCommandBarsOffice2000Theme.

◆ DrawRectangle() [2/2]

virtual BOOL DrawRectangle | ( | CDC * | pDC,
 |  | CXTPControl * | pButton )
 protectedvirtual

This method is called to fill the control's face.

Parameters
pDC | Pointer to a valid device context
pButton | pointer to a button
Returns
TRUE if the rectangle was drawn, otherwise returns FALSE.

Reimplemented from CXTPCommandBarsOffice2000Theme.

◆ DrawSpecialControl()

virtual CSize DrawSpecialControl | ( | CDC * | pDC,
 |  | XTPSpecialControl | controlType,
 |  | CXTPControl * | pButton,
 |  | CXTPCommandBar * | pBar,
 |  | BOOL | bDraw,
 |  | LPVOID | lpParam )
 protectedvirtual

This method is called to draw the specified controls.

Parameters
pDC | Pointer to a valid device context.
controlType | Special control enumerator.
pButton | Pointer to a CXTPControl object to draw.
pBar | Parent CXTPCommandBar object.
bDraw | TRUE to draw; FALSE to retrieve the size of the control.
lpParam | Specified parameter.
Returns
Size of the control.

Reimplemented from CXTPCommandBarsOffice2000Theme.

◆ DrawSplitButtonFrame()

void DrawSplitButtonFrame | ( | CDC * | pDC,
 |  | CXTPControl * | pButton,
 |  | CRect | rcButton )
 protectedvirtual

Draws a split button frame.

Parameters
pDC | Pointer to a valid device context.
pButton | Pointer to the split button to draw.
rcButton | Bounding rectangle to draw.

Reimplemented from CXTPCommandBarsOffice2000Theme.

◆ FillCommandBarEntry()

virtual void FillCommandBarEntry | ( | CDC * | pDC,
 |  | CXTPCommandBar * | pBar )
 protectedvirtual

This method is called to fill the command bar's face.

Parameters
pDC | Pointer to a valid device context.
pBar | Pointer to a CXTPCommandBar object to draw.

Reimplemented from CXTPCommandBarsOffice2000Theme.

◆ FillDockBar()

virtual void FillDockBar | ( | CDC * | pDC,
 |  | CXTPDockBar * | pBar )
 protectedvirtual

This method is called to fill a dockbar.

Parameters
pDC | Pointer to a valid device context.
pBar | Pointer to a CXTPDockBar object.

Reimplemented from CXTPPaintManager.

◆ FillDockBarRect()

void FillDockBarRect | ( | CDC * | pDC,
 |  | CWnd * | pWnd,
 |  | CWnd * | pFrame )
 protected

This method is called to fill a dockbar.

Parameters
pDC | Points to a valid device context.
pWnd | Client area to fill.
pFrame | Parent frame window.

◆ GetControlTextColor()

COLORREF GetControlTextColor ( CXTPControl * pButton )
protectedvirtual

This method returns the control text color to draw.

Parameters
pButton Pointer to a CXTPControl object to draw.
Returns
Returns application state color

Reimplemented from CXTPPaintManager.

◆ GetPopupBarGripperWidth()

virtual int GetPopupBarGripperWidth ( CXTPCommandBar * pBar )
protectedvirtual

Calculates the gripper of a pop-up bar.

Parameters
pBar Pop-up bar.
Returns
Width of the gripper to draw.

Reimplemented from CXTPPaintManager.

◆ GetRectangleTextColor()

virtual COLORREF GetRectangleTextColor | ( | BOOL | bSelected,
 |  | BOOL | bPressed,
 |  | BOOL | bEnabled,
 |  | BOOL | bChecked,
 |  | BOOL | bPopuped,
 |  | XTPBarType | barType,
 |  | XTPBarPosition | barPosition )
 protectedvirtual

This method retrieves a buttons text color.

Parameters
bSelected | TRUE if the control is selected.
bPressed | TRUE if the control is pushed.
bEnabled | TRUE if the control is enabled.
bChecked | TRUE if the control is checked.
bPopuped | TRUE if the control is pop-up'ed.
barType | Parent's bar type.
barPosition | Parent's bar position.
Returns
Returns buttons text color

Reimplemented from CXTPCommandBarsOffice2000Theme.

◆ IsThemeEnabled()

BOOL IsThemeEnabled ( ) const
protected

Determines if WinXP theme is enabled.

Returns
TRUE if WinXP theme is enabled, FALSE otherwise.
The documentation for this class was generated from the following file:
  • XTPCommandBarsNativeXPTheme.h


Toolkit Pro: CXTPCommandBarsOffice2000Theme Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPCommandBarsOffice2000Theme Class Reference

The CXTPCommandBarsOffice2000Theme class is used to enable an Office 2000 style theme for Command Bars. More...

Inheritance diagram for CXTPCommandBarsOffice2000Theme:
[legend]

Public Member Functions

CXTPCommandBarsOffice2000Theme ()
Constructs a CXTPCommandBarsOffice2000Theme object.
virtual void | RefreshMetrics ()
This method is called to refresh the visual metrics of the manager.
virtual void | FillCommandBarEntry (CDC *pDC, CXTPCommandBar *pBar)
This method is called to fill the command bar's face.
virtual COLORREF | GetRectangleTextColor (BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition)
This method retrieves a buttons text color.
virtual CSize | DrawCommandBarGripper (CDC *pDC, CXTPCommandBar *pBar, BOOL bDraw=TRUE)
This method is called to draw the command bar's gripper.
virtual CSize | DrawCommandBarSeparator (CDC *pDC, CXTPCommandBar *pBar, CXTPControl *pControl, BOOL bDraw=TRUE)
This method is called to draw a command bar's separator.
virtual void | AdjustExcludeRect (CRect &rc, CXTPControl *pControl, BOOL bVertical)
This method is called to determine the offset of a pop-up bar.
virtual CRect | GetCommandBarBorders (CXTPCommandBar *pBar)
This method is called to retrieve the command bar's borders.
virtual CSize | DrawListBoxControl (CDC *pDC, CXTPControl *pButton, CRect rc, BOOL bSelected, BOOL bDraw, CXTPCommandBars *pCommandBars=0)
This method is called to draw the control placed on the ListBox.
virtual CSize | DrawSpecialControl (CDC *pDC, XTPSpecialControl controlType, CXTPControl *pButton, CXTPCommandBar *pBar, BOOL bDraw, LPVOID lpParam)
This method is called to draw the specified controls.
virtual CSize | DrawTearOffGripper (CDC *pDC, CRect rcGripper, BOOL bSelected, BOOL bDraw)
This method is called to draw a tear-off gripper of a pop-up bar.
virtual void | DrawPopupResizeGripper (CDC *pDC, CRect rcGripper, int nFlags)
This method is called to draw the pop-up bar resize gripper.
- Public Member Functions inherited from CXTPPaintManager
virtual void | SetImageHandle (HMODULE hResource, LPCTSTR lpszIniFileName)
Specifies the resource that contains the bitmaps to be loaded for the theme.
CSize | DrawControl (CDC *pDC, CXTPControl *pButton, BOOL bDraw=TRUE)
This method is called to draw the control.
virtual CSize | DrawControlToolBarParent (CDC *pDC, CXTPControl *pButton, BOOL bDraw)
This method is called to draw the control placed on the toolbar.
virtual COLORREF | GetControlEditBackColor (CXTPControl *pControl)
This method returns the edit control back color to draw.
virtual void | DrawControlEntry (CDC *pDC, CXTPControl *pButton)
This method is called to fill the control's face.
virtual COLORREF | GetControlTextColor (CXTPControl *pButton)
Call this method to get the control text color to draw.
virtual COLORREF | GetControlBackColor (CXTPControl *pButton)
Call this method to get the control back color to draw.
virtual void | DrawGalleryItemBack (CDC *pDC, CRect rcItem, BOOL bEnabled, BOOL bSelected, BOOL bPressed, BOOL bChecked, XTPBarType barType)
This method is called to draw the background for a gallery menu item.
virtual void | DrawCommandBarGroupSeparator (CDC *pDC, CXTPCommandBar *pBar, CXTPControl *pLeftControl, CXTPControl *pRightControl, BOOL bDraw=TRUE)
This method is called to draw a command bar's group separator.
virtual void | FillDockBar (CDC *pDC, CXTPDockBar *pBar)
This method is called to fill a dock bar.
virtual void | FillWorkspace (CDC *pDC, CRect rc, CRect rcExclude)
This method is called to fill a workspace.
int | GetShadowOptions () const
Determines the kind of shadow to use.
virtual void | DrawExpandGlyph (CDC *pDC, CXTPControl *pButton, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clr)
Draw expand or hidden glyphs for a button.
virtual void | DrawExpandGlyph (CDC *pDC, CXTPControl *pButton, COLORREF clr, BOOL bVertical)
Draw expand or hidden glyphs for a button.
virtual void | DrawHiddenGlyph (CDC *pDC, CXTPControl *pButton, COLORREF clr, BOOL bVertical)
Draw expand or hidden glyphs for a button.
virtual CRect | GetSplitButtonCommandRect (CXTPControl *pButton)
Determines split button command rectangle.
virtual void | SetCommandBarRegion (CXTPCommandBar *pCommandBar)
Call this method to set the bounding region of a pop-up bar.
virtual CSize | DrawControlCheckBoxMark (CDC *pDC, CRect rc, BOOL bDraw, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled)
This method is called to draw a check box mark area.
virtual CSize | DrawControlCheckBoxMark (CDC *pDC, CXTPControl *pButton, CRect rc, BOOL bDraw)
This method is called to draw a check box mark area.
virtual CSize | DrawControlRadioButtonMark (CDC *pDC, CRect rc, BOOL bDraw, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled)
This method is called to draw a radio button mark area.
virtual void | DrawPopupBarGripper (CDC *pDC, int xPos, int yPos, int cx, int cy, BOOL bExpanded=FALSE)
This method is called to draw a pop-up bar's right gripper.
XTPPaintTheme GetCurrentTheme ()
Call this member to get the current visual theme.
virtual BOOL | RequiresResourceImages ()
Used by the paint manager to determine if the theme requires a resource DLL to load image and color information.
virtual CFont * | GetControlFont (CXTPControl *pControl)
Call this member to retrieve the font of the command bar control.
virtual CFont * | GetCommandBarFont (CXTPCommandBar *pCommandBar)
Call this member to retrieve the font of the command bar.
virtual XTPBarTextOrientation | GetControlTextOrientation (CXTPControl *pControl)
Call this member to determine how to draw text.
virtual void | UpdateFonts ()
Refreshes the fonts to use.
virtual void | UpdateColors ()
Refreshes the standard colors to use.
void | SetCommandBarsFontIndirect (LOGFONT *pLogFont, BOOL bUseStandardFont=FALSE)
Call this member to set command bar's font.
CFont * | GetRegularFont ()
Returns the general font.
CFont * | GetRegularBoldFont ()
Returns the general bold font.
CFont * | GetIconFont ()
Returns the icon font.
CFont * | GetSmCaptionFont ()
Call this method to retrieve the caption of a floating mini frame.
void | UseOfficeFont (bool bUseOfficeFont)
Call this method to use Tahoma font despite system metrics.
int | GetControlHeight () const
This method returns the common controls height.
virtual CSize | GetDefaultCommandBarSize (CXTPCommandBar *pBar)
Computes default command bar size taking into account command bar font.
void | Rectangle (CDC *pDC, LPCRECT rc, int nPen, const int nBrush)
Draws a rectangle.
void | Rectangle (CDC *pDC, LPCRECT rc, COLORREF clrPen, COLORREF clrBrush)
Draws a rectangle.
void | RoundRect (CDC *pDC, LPCRECT rc, COLORREF clrPen, COLORREF clrBrush)
Draws a rectangle.
void | Draw3dRect (CDC *pDC, LPCRECT rc, int nTopLeft, int nBottomRight)
Call this member function to draw a three-dimensional rectangle.
void | Draw3dRect (CDC *pDC, LPCRECT rc, int frameThickness, COLORREF clrPen, COLORREF clrBrush)
Call this member function to draw a rectangle with predetermined thickness.
virtual void | DrawPopupBarCheckMark (CDC *pDC, CRect rcCheck, BOOL bEnabled, COLORREF clr)
Call this member function to draw a check mark.
void | DrawCheckMark (CDC *pDC, CRect rcCheck, COLORREF clr=0)
Call this member function to draw a check mark.
virtual void | DrawPopupBarRadioMark (CDC *pDC, CRect rcCheck, BOOL bEnabled, COLORREF clr)
Call this member function to draw a radio button.
virtual void | DrawComboExpandMark (CDC *pDC, CRect rc, COLORREF clr)
Call this member function to draw a combobox expand symbol.
virtual void | DrawControlMDIButton (CDC *pDC, CXTPControlButton *pButton)
Call this member function to draw menu MDI buttons.
void | Line (CDC *pDC, CPoint p0, CPoint p1)
Draws a line.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1, const int nPen)
Draws a line.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1, COLORREF clrPen)
Draws a line.
void | HorizontalLine (CDC *pDC, int x0, int y0, int x1, COLORREF clrPen)
Call this member function to draw a horizontal line using the specified coordinages and RGB color value.
void | VerticalLine (CDC *pDC, int x0, int y0, int y1, COLORREF clrPen)
Call this member function to draw a vertical line using the specified coordinages and RGB color value.
virtual void | DrawDropDownGlyph (CDC *pDC, CXTPControl *pControl, CPoint pt, BOOL bSelected, BOOL bPopuped, BOOL bEnabled, BOOL bVert)
This member function is called to draw a split button expand symbol.
void | Pixel (CDC *pDC, int xPos, int yPos, int nPen)
Sets the pixel at the point.
void | GradientFill (CDC *pDC, LPRECT lpRect, COLORREF crFrom, COLORREF crTo, BOOL bHorz, LPCRECT lpRectClip=NULL)
Gradient fills the rectangle.
XTP_COMMANDBARS_ICONSINFO * GetIconsInfo ()
virtual void | Animate (CDC *pDestDC, CDC *pSrcDC, CRect rc, XTPAnimationType animationType)
This method is called to animate the pop-up bar.
virtual void | AnimateExpanding (CXTPCommandBar *pCommandBar, CDC *pDestDC, CDC *pSrcDC, BOOL bExpandDown)
This method is called to animate the expanding process.
void | SetAnimationDelay (int nAnimationSteps, int nAnimationTime)
Call this method to set animation delay.
COLORREF | GetXtremeColor (UINT nIndex)
This function retrieves the current color of the specified XP display element.
void | SetColors (int cElements, CONST INT *lpaElements, CONST COLORREF *lpaRgbValues)
Call this member to set the colors for each element to the color in the specified color array.
CSize | DrawControlText (CDC *pDC, CXTPControl *pControl, CRect rcText, BOOL bDraw, BOOL bVert, BOOL bCentered, BOOL bTriangled)
This method is called to draw control text.
virtual void | UpdateRTLCaption (CString &strCaption)
This method is called to prepare a caption for Right-To-Left draw.
XTPCurrentSystemTheme GetCurrentSystemTheme ()
Call this member function to determine the current Windows XP theme in use.
void | SetLunaTheme (XTPCurrentSystemTheme systemTheme)
Call this method to force system theme.
virtual int | GetPopupBarGripperWidth (CXTPCommandBar *pBar)
Calculates the gripper of a pop-up bar.
virtual CXTPControlGalleryPaintManager * | GetGalleryPaintManager () const
Retrieves paint manager used to draw galleries.
virtual CXTPScrollBarPaintManager * | GetScrollBarPaintManager () const
Retrieves paint manager used to draw scrollbars.
virtual CXTPSliderPaintManager * | GetSliderPaintManager () const
Retrieves paint manager used to draw slider panes.
virtual CXTPProgressPaintManager * | GetProgressPaintManager () const
Retrieves paint manager used to draw progress bars.
virtual CXTPFramePaintManager * | GetFramePaintManager ()
Retrieves paint manager used to draw frames.
virtual CXTPStatusBarPaintManager * | GetStatusBarPaintManager ()
Retrieves paint manager used to draw the status bar.
virtual CXTPRibbonPaintManager * | GetRibbonPaintManager ()
Retrieves the ribbon paint manager.
virtual CXTPMessageBarPaintManager * | GetMessageBarPaintManager ()
Retrieves paint manager used to draw message bars.
CXTPShadowManager * | GetShadowManager () const
Retrieves shadow manager used to draw shadows.
BOOL | IsUseSystemAccentColorEnabled () const
Determines whether xtpApplicationUseSystemAccentColor application ambient property is set.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.
- Public Member Functions inherited from CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents >
void | Subscribe (IXTPPaintManagerEvents *pObserver, CXTPSubscriptionList< CXTPPaintManager, IXTPPaintManagerEvents > *pSubcriptionList=NULL)
Subscribes a unique observer for events.
void | Unsubscribe (IXTPPaintManagerEvents *pObserver)
Unsubscribes an observer from events.
void | Notify (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *))
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *))
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.

Protected Member Functions

virtual CSize | DrawControlPopupParent (CDC *pDC, CXTPControl *pButton, BOOL bDraw)
This method is called to draw the control placed on the pop-up bar.
virtual void | DrawSplitButtonFrame (CDC *pDC, CXTPControl *pButton, CRect rcButton)
Draws split button frame.
virtual void | DrawRectangle (CDC *pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition)
This method is called to fill the control's face.
virtual BOOL | DrawRectangle (CDC *pDC, CXTPControl *pButton)
This method is called to fill the control's face.
virtual void | DrawImage (CDC *pDC, CPoint pt, CSize sz, CXTPImageManagerIcon *pImage, BOOL bSelected, BOOL bPressed, BOOL bEnabled=TRUE, BOOL bChecked=FALSE, BOOL bPopuped=FALSE, BOOL bToolBarImage=TRUE)
This method is called to draw the image of the control.
virtual CSize | DrawControlComboBox (CDC *pDC, CXTPControlComboBox *pComboBox, BOOL bDraw)
This method is called to draw the control.
virtual CSize | DrawControlEdit (CDC *pDC, CXTPControlEdit *pEdit, BOOL bDraw)
This method is called to draw the control.
virtual CSize | DrawDialogBarGripper (CDC *pDC, CXTPDialogBar *pBar, BOOL bDraw)
Call this member to draw the gripper of a dialog bar.
virtual void | DrawControlEditFrame (CDC *pDC, CRect rc, BOOL bEnabled, BOOL bSelected)
This method is called to draw the frame of an edit control.
virtual void | DrawControlComboBoxButton (CDC *pDC, CRect rcBtn, BOOL bEnabled, BOOL bSelected, BOOL bDropped)
This method is called to draw the button of a combobox control.
virtual void | DrawControlEditSpin (CDC *pDC, CXTPControlEdit *pControlEdit)
This method draws edit control spin buttons.
virtual XTPPaintTheme | BaseTheme ()
Retrieves the base theme of the manager.
- Protected Member Functions inherited from CXTPPaintManager
CXTPPaintManager ()
Constructs a CXTPPaintManager object.
virtual | ~CXTPPaintManager ()
Destroys a CXTPPaintManager object, handles cleanup and deallocation.
- Protected Member Functions inherited from CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents >
CXTPObservable ()
Constructs an observable object.
~CXTPObservable ()
Handles observable object destruction.

Protected Attributes

int | m_nPopupBarText
Pop-up bar text index.
- Protected Attributes inherited from CXTPPaintManager
CXTPFont | m_xtpFontRegular
Regular font.
CXTPFont | m_xtpFontRegularBold
Regular bold font.
CXTPFont | m_xtpFontVert
Vertical font.
CXTPFont | m_xtpFontVertBold
Vertical font.
int | m_nEditHeight
Edit text height.
int | m_nFontHeight
Custom font height (optional).
BOOL | m_bUseStandardFont
TRUE to use system font.
BOOL | m_bEmbossedDisabledText
TRUE to draw disabled text embossed.
CXTPWinThemeWrapper * | m_themeStatusBar
StatusBar theme helper.
CXTPWinThemeWrapper * | m_themeButton
Buttons theme helper.
XTPPaintTheme | m_themeCurrent
Current theme.
XTP_COMMANDBARS_ICONSINFO | m_iconsInfo
Specific icons options.
int | m_nAnimationSteps
Steps of the animation.
int | m_nAnimationTime
Time of the animation.
BOOL | m_bShowKeyboardCues
TRUE to show keyboard cues - deprecated.
CXTPPaintManagerColor | m_arrColor [XPCOLOR_LAST+1]
Self colors array.
XTPCurrentSystemTheme | m_systemTheme
Current system theme.
CXTPShadowManager * | m_pShadowManager
Shadow manager.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPPaintManager
static CXTPPaintManager *AFX_CDECL | GetInstanceAddRef ()
Obtains a pointer to a global paint manager object and increments its reference counter.
static void AFX_CDECL | ReleaseInstance ()
Decrements global paint manager's reference counter and deletes its instance when the reference counter reaches 0.
static CXTPPaintManager *AFX_CDECL | CreateTheme (XTPPaintTheme paintTheme)
Creates a new CXTPPaintManager object.
static void AFX_CDECL | SetTheme (XTPPaintTheme paintTheme)
Call this member to switch the visual theme of the Command Bars.
static void AFX_CDECL | SetCustomTheme (CXTPPaintManager *pTheme)
Call this member to set a custom theme.
static void AFX_CDECL | Triangle (CDC *pDC, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clr)
Draws a triangle.
static BOOL AFX_CDECL | FontExists (LPCTSTR lpszFaceName)
Determines if a specified font exists in the system.
static void AFX_CDECL | StripMnemonics (CString &strClear)
This member function will search a string, strip off the mnemonic '&', and reformat the string.
static CXTPPaintManager *AFX_CDECL | GetGlobalPaintManager ()
Call this method to get the pointer to the global paint manager.
static void AFX_CDECL | SetGlobalPaintManager (CXTPPaintManager *pPaintManager)
Call this method to set the pointer to the global paint manager.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPPaintManager
COLORREF | m_clrMessageBarText
Message bar text color.
CRect | m_rcMessageBarMargin
Margin of the message bar.
CXTPFramePaintManager * | m_pFramePaintManager
Frame paint manager.
CXTPStatusBarPaintManager * | m_pStatusBarPaintManager
Paint manager of the status bar.
CXTPRibbonPaintManager * | m_pRibbonPaintManager
Ribbon paint Manager.
CXTPControlGalleryPaintManager * | m_pGalleryPaintManager
Gallery paint manager.
CXTPProgressPaintManager * | m_pProgressPaintManager
Progress bar paint manager.
CXTPSliderPaintManager * | m_pSliderPaintManager
Slider pane paint manager.
CXTPScrollBarPaintManager * | m_pScrollBarPaintManager
Scrollbar paint manager.
CXTPPaintManagerColorGradient | m_clrDisabledIcon
Disabled icons color.
CXTPPaintManagerColor | m_clrFloatingGripper
Gripper color of floating toolbar.
CXTPPaintManagerColor | m_clrFloatingGripperText
Gripper text color of floating toolbar.
BOOL | m_bThickCheckMark
TRUE to draw thick check mark.
BOOL | m_bShowShadow
TRUE to show shadow.
BOOL | m_bThemedStatusBar
TRUE to draw status bar using WinXP theme.
BOOL | m_bThemedCheckBox
TRUE to draw check box using WinXP theme.
BOOL | m_bClearTypeTextQuality
TRUE to enable ClearType text for the font.
BOOL | m_bFlatToolBar
TRUE to draw toolbars flat.
BOOL | m_bFlatMenuBar
TRUE to draw menubar flat.
int | m_nPopupBarTextPadding
Distance between gripper and control text.
BOOL | m_bSelectImageInPopupBar
TRUE to select image as in explorer theme.
BOOL | m_bEnableAnimation
TRUE to enable animation for all toolbars.
BOOL | m_bOffice2007Padding
TRUE if Office2007 metrics used.
BOOL | m_bOffsetPopupLabelText
TRUE if labels in pop-ups drawn with offset.
BOOL | m_bWrapCaptionBelowText
Wrap text for xtpButtonIconAndCaptionBelow buttons.
CXTPPaintManagerFont | m_fontSmCaption
Small caption font.
CXTPPaintManagerFont | m_fontIcon
Icon font.
CXTPPaintManagerFont | m_fontIconBold
Icon bold font.
CXTPPaintManagerFont | m_fontToolTip
Tooltip font.
int | m_nSplitButtonDropDownWidth
Split button drop down width in toolbars.
int | m_nSplitButtonDropDownHeight
Split button drop down height in toolbars.
int | m_nSplitButtonPopupWidth
Split button drop down width in pop-ups.
BOOL | m_bAutoResizeIcons
TRUE to automatically resize icons using current DPI.
int | m_nStatusBarMinHeight
Minimum height for the status bar.
PVOID | m_pfnSetLayeredWindowAttributes
point to Transparency proc in USER32.dll module.
CRect | m_rcStatusBarBorder
Bounding rectangle of the status bar border.
BOOL | m_bUseOfficeFont
TRUE to use Tahoma font.
CString | m_strOfficeFont
Office font.
int | m_nTextHeight
Regular text field height (not font height).

Detailed Description

The CXTPCommandBarsOffice2000Theme class is used to enable an Office 2000 style theme for Command Bars.

See also
CXTPPaintManager::SetTheme

Member Function Documentation

◆ AdjustExcludeRect()

virtual void AdjustExcludeRect | ( | CRect & | rc,
 |  | CXTPControl * | pControl,
 |  | BOOL | bVertical )
 virtual

This method is called to determine the offset of a pop-up bar.

Parameters
rc | Control's bounding rectangle.
pControl | Pointer to a CXTPControl object.
bVertical | TRUE if the control is docked vertically.

Implements CXTPPaintManager.

Reimplemented in CXTPCommandBarsNativeXPTheme.

◆ BaseTheme()

virtual XTPPaintTheme BaseTheme ( )
inlineprotectedvirtual

Retrieves the base theme of the manager.

Returns
Returns the base theme.

Implements CXTPPaintManager.

Reimplemented in CXTPCommandBarsNativeXPTheme.

◆ DrawCommandBarGripper()

virtual CSize DrawCommandBarGripper | ( | CDC * | pDC,
 |  | CXTPCommandBar * | pBar,
 |  | BOOL | bDraw = TRUE )
 virtual

This method is called to draw the command bar's gripper.

Parameters
pDC | Pointer to a valid device context.
pBar | Pointer to a CXTPCommandBar object.
bDraw | TRUE to draw; FALSE to retrieve the size of the gripper.
Returns
Size of the gripper.

Reimplemented from CXTPPaintManager.

Reimplemented in CXTPCommandBarsNativeXPTheme.

◆ DrawCommandBarSeparator()

virtual CSize DrawCommandBarSeparator | ( | CDC * | pDC,
 |  | CXTPCommandBar * | pBar,
 |  | CXTPControl * | pControl,
 |  | BOOL | bDraw = TRUE )
 virtual

This method is called to draw a command bar's separator.

Parameters
pDC | Pointer to a valid device context.
pBar | Pointer to a CXTPCommandBar object.
pControl | Pointer to a CXTPControl object.
bDraw | TRUE to draw; FALSE to retrieve the size of the separator.
Returns
Size of the separator.

Implements CXTPPaintManager.

Reimplemented in CXTPCommandBarsNativeXPTheme.

◆ DrawControlComboBox()

virtual CSize DrawControlComboBox | ( | CDC * | pDC,
 |  | CXTPControlComboBox * | pComboBox,
 |  | BOOL | bDraw )
 protectedvirtual

This method is called to draw the control.

Parameters
pDC | Pointer to a valid device context
pComboBox | ComboBox to draw.
bDraw | TRUE to draw; FALSE to retrieve the size of the control.
Returns
Size of the control.

Reimplemented from CXTPPaintManager.

◆ DrawControlComboBoxButton()

virtual void DrawControlComboBoxButton | ( | CDC * | pDC,
 |  | CRect | rcBtn,
 |  | BOOL | bEnabled,
 |  | BOOL | bSelected,
 |  | BOOL | bDropped )
 protectedvirtual

This method is called to draw the button of a combobox control.

Parameters
pDC | Pointer to a valid device context.
rcBtn | Button bounding rectangle.
bEnabled | TRUE if combobox is enabled.
bSelected | TRUE if combobox is selected.
bDropped | TRUE if combobox is dropped.

Reimplemented in CXTPCommandBarsNativeXPTheme.

◆ DrawControlEdit()

virtual CSize DrawControlEdit | ( | CDC * | pDC,
 |  | CXTPControlEdit * | pEdit,
 |  | BOOL | bDraw )
 protectedvirtual

This method is called to draw the control.

Parameters
pDC | Pointer to a valid device context
bDraw | TRUE to draw; FALSE to retrieve the size of the control.
pEdit | Edit control to draw.
Returns
Size of the control.

Reimplemented from CXTPPaintManager.

◆ DrawControlEditFrame()

virtual void DrawControlEditFrame | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | BOOL | bEnabled,
 |  | BOOL | bSelected )
 protectedvirtual

This method is called to draw the frame of an edit control.

Parameters
pDC | Pointer to a valid device context.
rc | CRect object specifying size of area.
bEnabled | TRUE if control is enabled.
bSelected | TRUE if control is selected.

Reimplemented in CXTPCommandBarsNativeXPTheme.

◆ DrawControlEditSpin()

virtual void DrawControlEditSpin | ( | CDC * | pDC,
 |  | CXTPControlEdit * | pControlEdit )
 protectedvirtual

This method draws edit control spin buttons.

Parameters
pDC | Pointer to a valid device context.
pControlEdit | Edit control.

Reimplemented in CXTPCommandBarsNativeXPTheme.

◆ DrawControlPopupParent()

virtual CSize DrawControlPopupParent | ( | CDC * | pDC,
 |  | CXTPControl * | pButton,
 |  | BOOL | bDraw )
 protectedvirtual

This method is called to draw the control placed on the pop-up bar.

Parameters
pDC | Pointer to a valid device context.
pButton | Pointer to a CXTPControl object.
bDraw | TRUE to draw; FALSE to retrieve the size of the control.
Returns
Size of the control.

Reimplemented from CXTPPaintManager.

◆ DrawDialogBarGripper()

virtual CSize DrawDialogBarGripper | ( | CDC * | pDC,
 |  | CXTPDialogBar * | pBar,
 |  | BOOL | bDraw )
 protectedvirtual

Call this member to draw the gripper of a dialog bar.

Parameters
pDC | Pointer to a valid device context.
pBar | Dialog Bar pointer.
bDraw | TRUE to draw the gripper, FALSE to calculate size.
Returns
Size of the gripper to be drawn.

Implements CXTPPaintManager.

Reimplemented in CXTPCommandBarsNativeXPTheme.

◆ DrawImage()

virtual void DrawImage | ( | CDC * | pDC,
 |  | CPoint | pt,
 |  | CSize | sz,
 |  | CXTPImageManagerIcon * | pImage,
 |  | BOOL | bSelected,
 |  | BOOL | bPressed,
 |  | BOOL | bEnabled = TRUE,
 |  | BOOL | bChecked = FALSE,
 |  | BOOL | bPopuped = FALSE,
 |  | BOOL | bToolBarImage = TRUE )
 protectedvirtual

This method is called to draw the image of the control.

Parameters
pDC | Pointer to a valid device context.
pt | Position to draw.
sz | Size of the image.
pImage | Pointer to a CXTPImageManagerIcon object.
bSelected | TRUE if the control is selected.
bPressed | TRUE if the control is pushed.
bEnabled | TRUE if the control is enabled.
bChecked | TRUE if the control is checked.
bPopuped | TRUE if the control is pop-up'ed.
bToolBarImage | TRUE if it is a toolbar image.

Implements CXTPPaintManager.

◆ DrawListBoxControl()

virtual CSize DrawListBoxControl | ( | CDC * | pDC,
 |  | CXTPControl * | pButton,
 |  | CRect | rc,
 |  | BOOL | bSelected,
 |  | BOOL | bDraw,
 |  | CXTPCommandBars * | pCommandBars = 0 )
 virtual

This method is called to draw the control placed on the ListBox.

Parameters
pDC | Pointer to a valid device context.
pButton | Pointer to a CXTPControl object.
rc | Bounding rectangle to draw.
bSelected | TRUE if the control is selected.
bDraw | TRUE to draw; FALSE to retrieve the size of the control.
pCommandBars | CommandBars object which metrics need to use.
Returns
Size of the control.

Implements CXTPPaintManager.

◆ DrawPopupResizeGripper()

virtual void DrawPopupResizeGripper | ( | CDC * | pDC,
 |  | CRect | rcGripper,
 |  | int | nFlags )
 virtual

This method is called to draw the pop-up bar resize gripper.

Parameters
pDC | Pointer to a valid device context.
rcGripper | Bounding rectangle of the gripper.
nFlags | Position of resize gripper

Implements CXTPPaintManager.

◆ DrawRectangle() [1/2]

virtual void DrawRectangle | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | BOOL | bSelected,
 |  | BOOL | bPressed,
 |  | BOOL | bEnabled,
 |  | BOOL | bChecked,
 |  | BOOL | bPopuped,
 |  | XTPBarType | barType,
 |  | XTPBarPosition | barPosition )
 protectedvirtual

This method is called to fill the control's face.

Parameters
pDC | Pointer to a valid device context.
rc | Rectangle to draw.
bSelected | TRUE if the control is selected.
bPressed | TRUE if the control is pushed.
bEnabled | TRUE if the control is enabled.
bChecked | TRUE if the control is checked.
bPopuped | TRUE if the control is pop-up'ed.
barType | Parent's bar type.
barPosition | Parent's bar position.

Implements CXTPPaintManager.

Reimplemented in CXTPCommandBarsNativeXPTheme.

◆ DrawRectangle() [2/2]

virtual BOOL DrawRectangle | ( | CDC * | pDC,
 |  | CXTPControl * | pButton )
 protectedvirtual

This method is called to fill the control's face.

Parameters
pDC | Pointer to a valid device context.
pButton | pointer to a button
Returns
TRUE if the rectange was drawn, otherwise FALSE.

Reimplemented from CXTPPaintManager.

Reimplemented in CXTPCommandBarsNativeXPTheme.

◆ DrawSpecialControl()

virtual CSize DrawSpecialControl | ( | CDC * | pDC,
 |  | XTPSpecialControl | controlType,
 |  | CXTPControl * | pButton,
 |  | CXTPCommandBar * | pBar,
 |  | BOOL | bDraw,
 |  | LPVOID | lpParam )
 virtual

This method is called to draw the specified controls.

Parameters
pDC | Pointer to a valid device context.
controlType | Special control enumerator.
pButton | Pointer to a CXTPControl object to draw.
pBar | Parent CXTPCommandBar object.
bDraw | TRUE to draw; FALSE to retrieve the size of the control.
lpParam | Specified parameter.
Returns
Size of the control.
See also
XTPSpecialControl

Reimplemented from CXTPPaintManager.

Reimplemented in CXTPCommandBarsNativeXPTheme.

◆ DrawSplitButtonFrame()

virtual void DrawSplitButtonFrame | ( | CDC * | pDC,
 |  | CXTPControl * | pButton,
 |  | CRect | rcButton )
 protectedvirtual

Draws split button frame.

Parameters
pDC | Pointer to a valid device context.
pButton | Pointer to the split button to draw.
rcButton | Bounding rectangle to draw.

Implements CXTPPaintManager.

Reimplemented in CXTPCommandBarsNativeXPTheme.

◆ DrawTearOffGripper()

virtual CSize DrawTearOffGripper | ( | CDC * | pDC,
 |  | CRect | rcGripper,
 |  | BOOL | bSelected,
 |  | BOOL | bDraw )
 virtual

This method is called to draw a tear-off gripper of a pop-up bar.

Parameters
pDC | Pointer to a valid device context.
rcGripper | Bounding rectangle of the gripper.
bSelected | TRUE if the gripper is selected.
bDraw | TRUE to draw; FALSE to retrieve the size of the gripper.
Returns
Size of the gripper.

Implements CXTPPaintManager.

◆ FillCommandBarEntry()

virtual void FillCommandBarEntry | ( | CDC * | pDC,
 |  | CXTPCommandBar * | pBar )
 virtual

This method is called to fill the command bar's face.

Parameters
pDC | Pointer to a valid device context
pBar | Pointer to a CXTPCommandBar object to draw.

Implements CXTPPaintManager.

Reimplemented in CXTPCommandBarsNativeXPTheme.

◆ GetCommandBarBorders()

virtual CRect GetCommandBarBorders ( CXTPCommandBar * pBar )
virtual

This method is called to retrieve the command bar's borders.

Parameters
pBar Pointer to the CXTPCommandBar object that the borders need to get.
Returns
Borders of the command bar.

Reimplemented from CXTPPaintManager.

◆ GetRectangleTextColor()

virtual COLORREF GetRectangleTextColor | ( | BOOL | bSelected,
 |  | BOOL | bPressed,
 |  | BOOL | bEnabled,
 |  | BOOL | bChecked,
 |  | BOOL | bPopuped,
 |  | XTPBarType | barType,
 |  | XTPBarPosition | barPosition )
 virtual

This method retrieves a buttons text color.

Parameters
bSelected | TRUE if the control is selected.
bPressed | TRUE if the control is pushed.
bEnabled | TRUE if the control is enabled.
bChecked | TRUE if the control is checked.
bPopuped | TRUE if the control is pop-up'ed.
barType | Parent's bar type.
barPosition | Parent's bar position.
Returns
Returns buttons text color

Implements CXTPPaintManager.

Reimplemented in CXTPCommandBarsNativeXPTheme.

The documentation for this class was generated from the following file:
  • XTPCommandBarsOffice2000Theme.h


Toolkit Pro: CXTPCommandBarsOffice2003Theme Class Reference

Public Member Functions | Static Public Member Functions | Public Attributes | Protected Member Functions | List of all members
CXTPCommandBarsOffice2003Theme Class Reference

The CXTPCommandBarsOffice2003Theme class is used to enable an Office 2003 style theme for Command Bars. More...

Inheritance diagram for CXTPCommandBarsOffice2003Theme:
[legend]

Public Member Functions

CXTPCommandBarsOffice2003Theme ()
Constructs a CXTPCommandBarsOffice2003Theme object.
virtual | ~CXTPCommandBarsOffice2003Theme ()
Destroys a CXTPCommandBarsOffice2003Theme object, handles cleanup and deallocation.
void | ExcludeCorners (CDC *pDC, CRect rc)
This method creates a new clipping region that consists of the existing clipping region minus the corners rectangles.
- Public Member Functions inherited from CXTPCommandBarsOfficeXPTheme
CXTPCommandBarsOfficeXPTheme ()
Constructs a CXTPCommandBarsOfficeXPTheme object.
virtual COLORREF | GetRectangleTextColor (BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition)
This method retrieves a buttons text color.
virtual CSize | DrawListBoxControl (CDC *pDC, CXTPControl *pButton, CRect rc, BOOL bSelected, BOOL bDraw, CXTPCommandBars *pCommandBars=0)
This method is called to draw the control placed on the ListBox.
virtual void | AdjustExcludeRect (CRect &rc, CXTPControl *pControl, BOOL bVertical)
This method is called to determine the offset of a pop-up bar.
virtual void | DrawPopupResizeGripper (CDC *pDC, CRect rcGripper, int nFlags)
This method is called to draw a resize gripper of a pop-up bar.
- Public Member Functions inherited from CXTPPaintManager
virtual void | SetImageHandle (HMODULE hResource, LPCTSTR lpszIniFileName)
Specifies the resource that contains the bitmaps to be loaded for the theme.
CSize | DrawControl (CDC *pDC, CXTPControl *pButton, BOOL bDraw=TRUE)
This method is called to draw the control.
virtual CSize | DrawControlToolBarParent (CDC *pDC, CXTPControl *pButton, BOOL bDraw)
This method is called to draw the control placed on the toolbar.
virtual COLORREF | GetControlEditBackColor (CXTPControl *pControl)
This method returns the edit control back color to draw.
virtual void | DrawControlEntry (CDC *pDC, CXTPControl *pButton)
This method is called to fill the control's face.
virtual COLORREF | GetControlTextColor (CXTPControl *pButton)
Call this method to get the control text color to draw.
virtual COLORREF | GetControlBackColor (CXTPControl *pButton)
Call this method to get the control back color to draw.
virtual void | DrawGalleryItemBack (CDC *pDC, CRect rcItem, BOOL bEnabled, BOOL bSelected, BOOL bPressed, BOOL bChecked, XTPBarType barType)
This method is called to draw the background for a gallery menu item.
virtual void | DrawCommandBarGroupSeparator (CDC *pDC, CXTPCommandBar *pBar, CXTPControl *pLeftControl, CXTPControl *pRightControl, BOOL bDraw=TRUE)
This method is called to draw a command bar's group separator.
virtual void | FillWorkspace (CDC *pDC, CRect rc, CRect rcExclude)
This method is called to fill a workspace.
int | GetShadowOptions () const
Determines the kind of shadow to use.
virtual void | DrawExpandGlyph (CDC *pDC, CXTPControl *pButton, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clr)
Draw expand or hidden glyphs for a button.
virtual void | DrawExpandGlyph (CDC *pDC, CXTPControl *pButton, COLORREF clr, BOOL bVertical)
Draw expand or hidden glyphs for a button.
virtual void | DrawHiddenGlyph (CDC *pDC, CXTPControl *pButton, COLORREF clr, BOOL bVertical)
Draw expand or hidden glyphs for a button.
virtual CRect | GetSplitButtonCommandRect (CXTPControl *pButton)
Determines split button command rectangle.
virtual void | SetCommandBarRegion (CXTPCommandBar *pCommandBar)
Call this method to set the bounding region of a pop-up bar.
XTPPaintTheme GetCurrentTheme ()
Call this member to get the current visual theme.
virtual BOOL | RequiresResourceImages ()
Used by the paint manager to determine if the theme requires a resource DLL to load image and color information.
virtual CFont * | GetControlFont (CXTPControl *pControl)
Call this member to retrieve the font of the command bar control.
virtual CFont * | GetCommandBarFont (CXTPCommandBar *pCommandBar)
Call this member to retrieve the font of the command bar.
virtual XTPBarTextOrientation | GetControlTextOrientation (CXTPControl *pControl)
Call this member to determine how to draw text.
virtual void | UpdateFonts ()
Refreshes the fonts to use.
virtual void | UpdateColors ()
Refreshes the standard colors to use.
void | SetCommandBarsFontIndirect (LOGFONT *pLogFont, BOOL bUseStandardFont=FALSE)
Call this member to set command bar's font.
CFont * | GetRegularFont ()
Returns the general font.
CFont * | GetRegularBoldFont ()
Returns the general bold font.
CFont * | GetIconFont ()
Returns the icon font.
CFont * | GetSmCaptionFont ()
Call this method to retrieve the caption of a floating mini frame.
void | UseOfficeFont (bool bUseOfficeFont)
Call this method to use Tahoma font despite system metrics.
int | GetControlHeight () const
This method returns the common controls height.
virtual CSize | GetDefaultCommandBarSize (CXTPCommandBar *pBar)
Computes default command bar size taking into account command bar font.
void | Rectangle (CDC *pDC, LPCRECT rc, int nPen, const int nBrush)
Draws a rectangle.
void | Rectangle (CDC *pDC, LPCRECT rc, COLORREF clrPen, COLORREF clrBrush)
Draws a rectangle.
void | RoundRect (CDC *pDC, LPCRECT rc, COLORREF clrPen, COLORREF clrBrush)
Draws a rectangle.
void | Draw3dRect (CDC *pDC, LPCRECT rc, int nTopLeft, int nBottomRight)
Call this member function to draw a three-dimensional rectangle.
void | Draw3dRect (CDC *pDC, LPCRECT rc, int frameThickness, COLORREF clrPen, COLORREF clrBrush)
Call this member function to draw a rectangle with predetermined thickness.
virtual void | DrawPopupBarCheckMark (CDC *pDC, CRect rcCheck, BOOL bEnabled, COLORREF clr)
Call this member function to draw a check mark.
void | DrawCheckMark (CDC *pDC, CRect rcCheck, COLORREF clr=0)
Call this member function to draw a check mark.
virtual void | DrawPopupBarRadioMark (CDC *pDC, CRect rcCheck, BOOL bEnabled, COLORREF clr)
Call this member function to draw a radio button.
virtual void | DrawComboExpandMark (CDC *pDC, CRect rc, COLORREF clr)
Call this member function to draw a combobox expand symbol.
virtual void | DrawControlMDIButton (CDC *pDC, CXTPControlButton *pButton)
Call this member function to draw menu MDI buttons.
void | Line (CDC *pDC, CPoint p0, CPoint p1)
Draws a line.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1, const int nPen)
Draws a line.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1, COLORREF clrPen)
Draws a line.
void | HorizontalLine (CDC *pDC, int x0, int y0, int x1, COLORREF clrPen)
Call this member function to draw a horizontal line using the specified coordinages and RGB color value.
void | VerticalLine (CDC *pDC, int x0, int y0, int y1, COLORREF clrPen)
Call this member function to draw a vertical line using the specified coordinages and RGB color value.
virtual void | DrawDropDownGlyph (CDC *pDC, CXTPControl *pControl, CPoint pt, BOOL bSelected, BOOL bPopuped, BOOL bEnabled, BOOL bVert)
This member function is called to draw a split button expand symbol.
void | Pixel (CDC *pDC, int xPos, int yPos, int nPen)
Sets the pixel at the point.
void | GradientFill (CDC *pDC, LPRECT lpRect, COLORREF crFrom, COLORREF crTo, BOOL bHorz, LPCRECT lpRectClip=NULL)
Gradient fills the rectangle.
XTP_COMMANDBARS_ICONSINFO * GetIconsInfo ()
virtual void | Animate (CDC *pDestDC, CDC *pSrcDC, CRect rc, XTPAnimationType animationType)
This method is called to animate the pop-up bar.
virtual void | AnimateExpanding (CXTPCommandBar *pCommandBar, CDC *pDestDC, CDC *pSrcDC, BOOL bExpandDown)
This method is called to animate the expanding process.
void | SetAnimationDelay (int nAnimationSteps, int nAnimationTime)
Call this method to set animation delay.
COLORREF | GetXtremeColor (UINT nIndex)
This function retrieves the current color of the specified XP display element.
void | SetColors (int cElements, CONST INT *lpaElements, CONST COLORREF *lpaRgbValues)
Call this member to set the colors for each element to the color in the specified color array.
CSize | DrawControlText (CDC *pDC, CXTPControl *pControl, CRect rcText, BOOL bDraw, BOOL bVert, BOOL bCentered, BOOL bTriangled)
This method is called to draw control text.
virtual void | UpdateRTLCaption (CString &strCaption)
This method is called to prepare a caption for Right-To-Left draw.
XTPCurrentSystemTheme GetCurrentSystemTheme ()
Call this member function to determine the current Windows XP theme in use.
void | SetLunaTheme (XTPCurrentSystemTheme systemTheme)
Call this method to force system theme.
virtual int | GetPopupBarGripperWidth (CXTPCommandBar *pBar)
Calculates the gripper of a pop-up bar.
virtual CXTPControlGalleryPaintManager * | GetGalleryPaintManager () const
Retrieves paint manager used to draw galleries.
virtual CXTPScrollBarPaintManager * | GetScrollBarPaintManager () const
Retrieves paint manager used to draw scrollbars.
virtual CXTPSliderPaintManager * | GetSliderPaintManager () const
Retrieves paint manager used to draw slider panes.
virtual CXTPProgressPaintManager * | GetProgressPaintManager () const
Retrieves paint manager used to draw progress bars.
virtual CXTPFramePaintManager * | GetFramePaintManager ()
Retrieves paint manager used to draw frames.
virtual CXTPStatusBarPaintManager * | GetStatusBarPaintManager ()
Retrieves paint manager used to draw the status bar.
virtual CXTPRibbonPaintManager * | GetRibbonPaintManager ()
Retrieves the ribbon paint manager.
virtual CXTPMessageBarPaintManager * | GetMessageBarPaintManager ()
Retrieves paint manager used to draw message bars.
CXTPShadowManager * | GetShadowManager () const
Retrieves shadow manager used to draw shadows.
BOOL | IsUseSystemAccentColorEnabled () const
Determines whether xtpApplicationUseSystemAccentColor application ambient property is set.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.
- Public Member Functions inherited from CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents >
void | Subscribe (IXTPPaintManagerEvents *pObserver, CXTPSubscriptionList< CXTPPaintManager, IXTPPaintManagerEvents > *pSubcriptionList=NULL)
Subscribes a unique observer for events.
void | Unsubscribe (IXTPPaintManagerEvents *pObserver)
Unsubscribes an observer from events.
void | Notify (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *))
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *))
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.

Static Public Member Functions

static HBITMAP AFX_CDECL | GetModernBitmap (UINT nIDResource)
Loads bitmap specified by nIDResource and converts its colors.
static BOOL AFX_CDECL | LoadModernToolbarIcons (UINT nIDResource)
Loads bitmap specified by nIDResource and adds it to ImageManager.
static BOOL AFX_CDECL | LoadModernToolbarIcons (UINT nIDResource, UINT *pCommands, int nCount, CSize szIcon=CSize(16, 15))
Loads bitmap specified by nIDResource and adds it to ImageManager.
- Static Public Member Functions inherited from CXTPPaintManager
static CXTPPaintManager *AFX_CDECL | GetInstanceAddRef ()
Obtains a pointer to a global paint manager object and increments its reference counter.
static void AFX_CDECL | ReleaseInstance ()
Decrements global paint manager's reference counter and deletes its instance when the reference counter reaches 0.
static CXTPPaintManager *AFX_CDECL | CreateTheme (XTPPaintTheme paintTheme)
Creates a new CXTPPaintManager object.
static void AFX_CDECL | SetTheme (XTPPaintTheme paintTheme)
Call this member to switch the visual theme of the Command Bars.
static void AFX_CDECL | SetCustomTheme (CXTPPaintManager *pTheme)
Call this member to set a custom theme.
static void AFX_CDECL | Triangle (CDC *pDC, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clr)
Draws a triangle.
static BOOL AFX_CDECL | FontExists (LPCTSTR lpszFaceName)
Determines if a specified font exists in the system.
static void AFX_CDECL | StripMnemonics (CString &strClear)
This member function will search a string, strip off the mnemonic '&', and reformat the string.
static CXTPPaintManager *AFX_CDECL | GetGlobalPaintManager ()
Call this method to get the pointer to the global paint manager.
static void AFX_CDECL | SetGlobalPaintManager (CXTPPaintManager *pPaintManager)
Call this method to set the pointer to the global paint manager.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Public Attributes

CXTPPaintManagerColorGradient | m_clrDockBar
Color of dockbar face.
CXTPPaintManagerColorGradient | m_clrCommandBar
Color of commandbar face.
CXTPPaintManagerColorGradient | m_clrToolbarExpand
Toolbar Expand button color.
CXTPPaintManagerColorGradient | m_clrMenuExpand
MenuBar Expand button color.
CXTPPaintManagerColorGradient | m_clrMenuExpandedGripper
Color of pop-up bar gripper.
CXTPPaintManagerColorGradient | m_clrMenuGripper
Color of the pop-up menu gripper.
CXTPPaintManagerColorGradient | m_clrPopupControl
color of pop-up control
CXTPPaintManagerColor | m_clrToolbarShadow
Toolbar bottom shadow color.
CXTPPaintManagerColor | m_clrTearOffGripper
TearOff gripper color.
BOOL | m_bLunaTheme
TRUE if luna theme is active.
BOOL | m_bPlainSeparators
TRUE to draw plain separators.
CImageList | m_ilGradientCircle
Gradient circle holder.
CXTPPaintManagerColorGradient | m_grcLunaChecked
Background color of checked button.
CXTPPaintManagerColorGradient | m_grcLunaPushed
Background color of pushed button.
CXTPPaintManagerColorGradient | m_grcLunaSelected
Background color of selected button.
- Public Attributes inherited from CXTPPaintManager
COLORREF | m_clrMessageBarText
Message bar text color.
CRect | m_rcMessageBarMargin
Margin of the message bar.
CXTPFramePaintManager * | m_pFramePaintManager
Frame paint manager.
CXTPStatusBarPaintManager * | m_pStatusBarPaintManager
Paint manager of the status bar.
CXTPRibbonPaintManager * | m_pRibbonPaintManager
Ribbon paint Manager.
CXTPControlGalleryPaintManager * | m_pGalleryPaintManager
Gallery paint manager.
CXTPProgressPaintManager * | m_pProgressPaintManager
Progress bar paint manager.
CXTPSliderPaintManager * | m_pSliderPaintManager
Slider pane paint manager.
CXTPScrollBarPaintManager * | m_pScrollBarPaintManager
Scrollbar paint manager.
CXTPPaintManagerColorGradient | m_clrDisabledIcon
Disabled icons color.
CXTPPaintManagerColor | m_clrFloatingGripper
Gripper color of floating toolbar.
CXTPPaintManagerColor | m_clrFloatingGripperText
Gripper text color of floating toolbar.
BOOL | m_bThickCheckMark
TRUE to draw thick check mark.
BOOL | m_bShowShadow
TRUE to show shadow.
BOOL | m_bThemedStatusBar
TRUE to draw status bar using WinXP theme.
BOOL | m_bThemedCheckBox
TRUE to draw check box using WinXP theme.
BOOL | m_bClearTypeTextQuality
TRUE to enable ClearType text for the font.
BOOL | m_bFlatToolBar
TRUE to draw toolbars flat.
BOOL | m_bFlatMenuBar
TRUE to draw menubar flat.
int | m_nPopupBarTextPadding
Distance between gripper and control text.
BOOL | m_bSelectImageInPopupBar
TRUE to select image as in explorer theme.
BOOL | m_bEnableAnimation
TRUE to enable animation for all toolbars.
BOOL | m_bOffice2007Padding
TRUE if Office2007 metrics used.
BOOL | m_bOffsetPopupLabelText
TRUE if labels in pop-ups drawn with offset.
BOOL | m_bWrapCaptionBelowText
Wrap text for xtpButtonIconAndCaptionBelow buttons.
CXTPPaintManagerFont | m_fontSmCaption
Small caption font.
CXTPPaintManagerFont | m_fontIcon
Icon font.
CXTPPaintManagerFont | m_fontIconBold
Icon bold font.
CXTPPaintManagerFont | m_fontToolTip
Tooltip font.
int | m_nSplitButtonDropDownWidth
Split button drop down width in toolbars.
int | m_nSplitButtonDropDownHeight
Split button drop down height in toolbars.
int | m_nSplitButtonPopupWidth
Split button drop down width in pop-ups.
BOOL | m_bAutoResizeIcons
TRUE to automatically resize icons using current DPI.
int | m_nStatusBarMinHeight
Minimum height for the status bar.
PVOID | m_pfnSetLayeredWindowAttributes
point to Transparency proc in USER32.dll module.
CRect | m_rcStatusBarBorder
Bounding rectangle of the status bar border.
BOOL | m_bUseOfficeFont
TRUE to use Tahoma font.
CString | m_strOfficeFont
Office font.
int | m_nTextHeight
Regular text field height (not font height).

Protected Member Functions

virtual void | RefreshMetrics ()
This method is called to refresh the visual metrics of the manager.
virtual void | DrawPopupBarGripper (CDC *pDC, int xPos, int yPos, int cx, int cy, BOOL bExpanded=FALSE)
This method is called to draw a pop-up bar's right gripper.
virtual void | FillDockBar (CDC *pDC, CXTPDockBar *pBar)
This method is called to fill a dockbar.
virtual void | FillCommandBarEntry (CDC *pDC, CXTPCommandBar *pBar)
This method is called to fill the command bar's face.
virtual CSize | DrawCommandBarSeparator (CDC *pDC, CXTPCommandBar *pBar, CXTPControl *pControl, BOOL bDraw=TRUE)
This method is called to draw a command bar's separator.
virtual CSize | DrawCommandBarGripper (CDC *pDC, CXTPCommandBar *pBar, BOOL bDraw=TRUE)
This method is called to draw the command bar's gripper.
virtual void | DrawRectangle (CDC *pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition)
This method is called to fill the control's face.
virtual void | DrawRectangle (CDC *pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition, int nID)
This method is called to fill the control's face.
virtual BOOL | DrawRectangle (CDC *pDC, CXTPControl *pButton)
This method is called to fill the control's face.
virtual CSize | DrawSpecialControl (CDC *pDC, XTPSpecialControl controlType, CXTPControl *pButton, CXTPCommandBar *pBar, BOOL bDraw, LPVOID lpParam)
This method is called to draw the specified controls.
virtual CRect | GetCommandBarBorders (CXTPCommandBar *pBar)
This method is called to retrieve the command bar's borders.
virtual CSize | DrawTearOffGripper (CDC *pDC, CRect rcGripper, BOOL bSelected, BOOL bDraw)
This method is called to draw the tear-off gripper of a pop-up bar.
virtual CSize | DrawDialogBarGripper (CDC *pDC, CXTPDialogBar *pBar, BOOL bDraw)
Call this member to draw the gripper of a dialog bar.
virtual XTPPaintTheme | BaseTheme ()
Retrieves the base theme of the manager.
void | CreateGradientCircle ()
Generates an expanded bitmap used for CXTPPopupBar.
virtual BOOL | HasFloatingBarGradientEntry (CXTPCommandBar *pBar)
Returns TRUE if a floating toolbar is drawn with a gradient background.
- Protected Member Functions inherited from CXTPCommandBarsOfficeXPTheme
virtual CSize | DrawControlPopupParent (CDC *pDC, CXTPControl *pButton, BOOL bDraw)
This method is called to draw the control placed on the pop-up bar.
virtual void | DrawImage (CDC *pDC, CPoint pt, CSize sz, CXTPImageManagerIcon *pImage, BOOL bSelected, BOOL bPressed, BOOL bEnabled=TRUE, BOOL bChecked=FALSE, BOOL bPopuped=FALSE, BOOL bToolBarImage=TRUE)
This method is called to draw the image of the control.
virtual CSize | DrawControlComboBox (CDC *pDC, CXTPControlComboBox *pComboBox, BOOL bDraw)
This method is called to draw the control.
virtual CSize | DrawControlEdit (CDC *pDC, CXTPControlEdit *pEdit, BOOL bDraw)
This method is called to draw the control.
void | FillIntersectRect (CDC *pDC, CXTPPopupBar *pPopupBar, COLORREF clr)
Draws intersect rectangle of a pop-up bar and its control.
virtual void | DrawSplitButtonFrame (CDC *pDC, CXTPControl *pButton, CRect rc)
This method is called to draw the frame for the SplitButton control.
virtual CSize | DrawControlCheckBoxMark (CDC *pDC, CRect rc, BOOL bDraw, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled)
This method is called to draw a check box mark area.
virtual CSize | DrawControlCheckBoxMark (CDC *pDC, CXTPControl *pButton, CRect rc, BOOL bDraw)
This method is called to draw a check box mark area.
virtual CSize | DrawControlRadioButtonMark (CDC *pDC, CRect rc, BOOL bDraw, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled)
This method is called to draw a radio button mark area.
- Protected Member Functions inherited from CXTPPaintManager
CXTPPaintManager ()
Constructs a CXTPPaintManager object.
virtual | ~CXTPPaintManager ()
Destroys a CXTPPaintManager object, handles cleanup and deallocation.
- Protected Member Functions inherited from CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents >
CXTPObservable ()
Constructs an observable object.
~CXTPObservable ()
Handles observable object destruction.

Additional Inherited Members

- Protected Attributes inherited from CXTPPaintManager
CXTPFont | m_xtpFontRegular
Regular font.
CXTPFont | m_xtpFontRegularBold
Regular bold font.
CXTPFont | m_xtpFontVert
Vertical font.
CXTPFont | m_xtpFontVertBold
Vertical font.
int | m_nEditHeight
Edit text height.
int | m_nFontHeight
Custom font height (optional).
BOOL | m_bUseStandardFont
TRUE to use system font.
BOOL | m_bEmbossedDisabledText
TRUE to draw disabled text embossed.
CXTPWinThemeWrapper * | m_themeStatusBar
StatusBar theme helper.
CXTPWinThemeWrapper * | m_themeButton
Buttons theme helper.
XTPPaintTheme | m_themeCurrent
Current theme.
XTP_COMMANDBARS_ICONSINFO | m_iconsInfo
Specific icons options.
int | m_nAnimationSteps
Steps of the animation.
int | m_nAnimationTime
Time of the animation.
BOOL | m_bShowKeyboardCues
TRUE to show keyboard cues - deprecated.
CXTPPaintManagerColor | m_arrColor [XPCOLOR_LAST+1]
Self colors array.
XTPCurrentSystemTheme | m_systemTheme
Current system theme.
CXTPShadowManager * | m_pShadowManager
Shadow manager.

Detailed Description

The CXTPCommandBarsOffice2003Theme class is used to enable an Office 2003 style theme for Command Bars.

See also
CXTPPaintManager::SetTheme

Member Function Documentation

◆ BaseTheme()

virtual XTPPaintTheme BaseTheme ( )
inlineprotectedvirtual

Retrieves the base theme of the manager.

Returns
Returns the base theme.

Reimplemented from CXTPCommandBarsOfficeXPTheme.

Reimplemented in CXTPResourceTheme, CXTPRibbonTheme, CXTPVisualStudio2005Theme, CXTPVisualStudio2008Theme, and CXTPVisualStudio2010Theme.

◆ DrawCommandBarGripper()

virtual CSize DrawCommandBarGripper | ( | CDC * | pDC,
 |  | CXTPCommandBar * | pBar,
 |  | BOOL | bDraw = TRUE )
 protectedvirtual

This method is called to draw the command bar's gripper.

Parameters
pDC | Pointer to a valid device context
pBar | Pointer to a CXTPCommandBar object
bDraw | TRUE to draw; FALSE to retrieve the size of the gripper.
Returns
Size of the gripper.

Reimplemented from CXTPCommandBarsOfficeXPTheme.

Reimplemented in CXTPRibbonTheme.

◆ DrawCommandBarSeparator()

virtual CSize DrawCommandBarSeparator | ( | CDC * | pDC,
 |  | CXTPCommandBar * | pBar,
 |  | CXTPControl * | pControl,
 |  | BOOL | bDraw = TRUE )
 protectedvirtual

This method is called to draw a command bar's separator.

Parameters
pDC | Pointer to a valid device context.
pBar | Pointer to a CXTPCommandBar object.
pControl | Pointer to a CXTPControl object.
bDraw | TRUE to draw; FALSE to retrieve the size of the separator.
Returns
Size of the separator.

Reimplemented from CXTPCommandBarsOfficeXPTheme.

Reimplemented in CXTPRibbonTheme, CXTPVisualStudio2008Theme, and CXTPVisualStudio2010Theme.

◆ DrawDialogBarGripper()

virtual CSize DrawDialogBarGripper | ( | CDC * | pDC,
 |  | CXTPDialogBar * | pBar,
 |  | BOOL | bDraw )
 protectedvirtual

Call this member to draw the gripper of a dialog bar.

Parameters
pDC | Pointer to a valid device context.
pBar | Dialog Bar pointer.
bDraw | TRUE to draw the gripper, FALSE to calculate size.
Returns
Size of the gripper to be drawn.

Reimplemented from CXTPCommandBarsOfficeXPTheme.

◆ DrawPopupBarGripper()

virtual void DrawPopupBarGripper | ( | CDC * | pDC,
 |  | int | xPos,
 |  | int | yPos,
 |  | int | cx,
 |  | int | cy,
 |  | BOOL | bExpanded = FALSE )
 protectedvirtual

This method is called to draw a pop-up bar's right gripper.

Parameters
pDC | Pointer to a valid device context.
xPos | Specifies the logical x coordinate of the upper-left corner of the rectangle.
yPos | Specifies the logical y coordinate of the upper-left corner of the destination rectangle.
cx | Specifies the width of the rectangle.
cy | Specifies the height of the rectangle.
bExpanded | TRUE if expanded, otherwise FALSE.

Reimplemented from CXTPCommandBarsOfficeXPTheme.

Reimplemented in CXTPRibbonTheme, CXTPVisualStudio2008Theme, and CXTPVisualStudio2010Theme.

◆ DrawRectangle() [1/3]

virtual void DrawRectangle | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | BOOL | bSelected,
 |  | BOOL | bPressed,
 |  | BOOL | bEnabled,
 |  | BOOL | bChecked,
 |  | BOOL | bPopuped,
 |  | XTPBarType | barType,
 |  | XTPBarPosition | barPosition )
 protectedvirtual

This method is called to fill the control's face.

Parameters
pDC | Pointer to a valid device context.
rc | Rectangle to draw.
bSelected | TRUE if the control is selected.
bPressed | TRUE if the control is pushed.
bEnabled | TRUE if the control is enabled.
bChecked | TRUE if the control is checked.
bPopuped | TRUE if the control is pop-up'ed.
barType | Parent's bar type.
barPosition | Parent's bar position.

Reimplemented from CXTPCommandBarsOfficeXPTheme.

Reimplemented in CXTPRibbonTheme, CXTPVisualStudio2008Theme, and CXTPVisualStudio2010Theme.

◆ DrawRectangle() [2/3]

virtual void DrawRectangle | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | BOOL | bSelected,
 |  | BOOL | bPressed,
 |  | BOOL | bEnabled,
 |  | BOOL | bChecked,
 |  | BOOL | bPopuped,
 |  | XTPBarType | barType,
 |  | XTPBarPosition | barPosition,
 |  | int | nID )
 protectedvirtual

This method is called to fill the control's face.

Parameters
pDC | Pointer to a valid device context.
rc | Rectangle to draw.
bSelected | TRUE if the control is selected.
bPressed | TRUE if the control is pushed.
bEnabled | TRUE if the control is enabled.
bChecked | TRUE if the control is checked.
bPopuped | TRUE if the control is pop-up'ed.
barType | Parent's bar type.
barPosition | Parent's bar position.
nID | Bar's control ID.

Reimplemented from CXTPCommandBarsOfficeXPTheme.

Reimplemented in CXTPRibbonTheme, CXTPVisualStudio2008Theme, and CXTPVisualStudio2010Theme.

◆ DrawRectangle() [3/3]

virtual BOOL DrawRectangle | ( | CDC * | pDC,
 |  | CXTPControl * | pButton )
 protectedvirtual

This method is called to fill the control's face.

Parameters
pDC | Pointer to a valid device context.
pButton | pointer to a button
Returns
TRUE if the rectange was drawn, otherwise FALSE.

Reimplemented from CXTPCommandBarsOfficeXPTheme.

Reimplemented in CXTPRibbonTheme, CXTPVisualStudio2008Theme, and CXTPVisualStudio2010Theme.

◆ DrawSpecialControl()

virtual CSize DrawSpecialControl | ( | CDC * | pDC,
 |  | XTPSpecialControl | controlType,
 |  | CXTPControl * | pButton,
 |  | CXTPCommandBar * | pBar,
 |  | BOOL | bDraw,
 |  | LPVOID | lpParam )
 protectedvirtual

This method is called to draw the specified controls.

Parameters
pDC | Pointer to a valid device context.
controlType | Special control enumerator.
pButton | Pointer to a CXTPControl object to draw.
pBar | Parent CXTPCommandBar object.
bDraw | TRUE to draw; FALSE to retrieve the size of the control.
lpParam | Specified parameter.
Returns
Size of the control.
See also
XTPSpecialControl

Reimplemented from CXTPPaintManager.

Reimplemented in CXTPRibbonTheme.

◆ DrawTearOffGripper()

virtual CSize DrawTearOffGripper | ( | CDC * | pDC,
 |  | CRect | rcGripper,
 |  | BOOL | bSelected,
 |  | BOOL | bDraw )
 protectedvirtual

This method is called to draw the tear-off gripper of a pop-up bar.

Parameters
pDC | Pointer to a valid device context.
rcGripper | Bounding rectangle of the gripper.
bSelected | TRUE if the gripper is selected.
bDraw | TRUE to draw; FALSE to retrieve the size of the gripper.
Returns
Size of the gripper.

Reimplemented from CXTPCommandBarsOfficeXPTheme.

◆ ExcludeCorners()

void ExcludeCorners | ( | CDC * | pDC,
 |  | CRect | rc )

This method creates a new clipping region that consists of the existing clipping region minus the corners rectangles.

Parameters
pDC | Pointer to a valid device context.
rc | CRect object specifying size of area.

◆ FillCommandBarEntry()

virtual void FillCommandBarEntry | ( | CDC * | pDC,
 |  | CXTPCommandBar * | pBar )
 protectedvirtual

This method is called to fill the command bar's face.

Parameters
pDC | Pointer to a valid device context.
pBar | Pointer to a CXTPCommandBar object to draw.

Reimplemented from CXTPCommandBarsOfficeXPTheme.

Reimplemented in CXTPRibbonTheme, and CXTPVisualStudio2010Theme.

◆ FillDockBar()

virtual void FillDockBar | ( | CDC * | pDC,
 |  | CXTPDockBar * | pBar )
 protectedvirtual

This method is called to fill a dockbar.

Parameters
pDC | Pointer to a valid device context.
pBar | Pointer to a CXTPDockBar object.

Reimplemented from CXTPPaintManager.

◆ GetCommandBarBorders()

virtual CRect GetCommandBarBorders ( CXTPCommandBar * pBar )
protectedvirtual

This method is called to retrieve the command bar's borders.

Parameters
pBar Pointer to the CXTPCommandBar object that the borders need to get.
Returns
Borders of the command bar.

Reimplemented from CXTPPaintManager.

Reimplemented in CXTPVisualStudio2008Theme, and CXTPVisualStudio2010Theme.

◆ GetModernBitmap()

static HBITMAP AFX_CDECL GetModernBitmap ( UINT nIDResource )
static

Loads bitmap specified by nIDResource and converts its colors.

Parameters
nIDResource Specifies bitmap resource ID.
Returns
Handle to bitmap with loaded bitmap.

◆ HasFloatingBarGradientEntry()

virtual BOOL HasFloatingBarGradientEntry ( CXTPCommandBar * pBar )
protectedvirtual

Returns TRUE if a floating toolbar is drawn with a gradient background.

Parameters
pBar Toolbar to check.
Returns
TRUE if the Toolbar has a gradient background, otherwise FALSE.

◆ LoadModernToolbarIcons() [1/2]

static BOOL AFX_CDECL LoadModernToolbarIcons ( UINT nIDResource )
static

Loads bitmap specified by nIDResource and adds it to ImageManager.

Parameters
nIDResource Specifies bitmap resource ID.
Returns
Returns TRUE if successful, FALSE otherwise
See also
GetModernBitmap, CXTPImageManager

◆ LoadModernToolbarIcons() [2/2]

static BOOL AFX_CDECL LoadModernToolbarIcons | ( | UINT | nIDResource,
 |  | UINT * | pCommands,
 |  | int | nCount,
 |  | CSize | szIcon = CSize(16, 15) )
 static

Loads bitmap specified by nIDResource and adds it to ImageManager.

Parameters
nIDResource | Specifies bitmap resource ID.
pCommands | Pointer to an array of IDs.
nCount | Number of elements in the array pointed to by lpIDArray.
szIcon | Size of the icons.
Returns
Returns TRUE if successful, FALSE otherwise
See also
GetModernBitmap, CXTPImageManager
The documentation for this class was generated from the following file:
  • XTPCommandBarsOffice2003Theme.h


Toolkit Pro: CXTPCommandBarsOffice2013Theme Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPCommandBarsOffice2013Theme Class Reference

The CXTPCommandBarsOffice2013Theme class is used to enable an Office 2013 style theme for Command Bars. More...

Inheritance diagram for CXTPCommandBarsOffice2013Theme:
[legend]

Public Member Functions

CXTPCommandBarsOffice2013Theme ()
Constructs a CXTPCommandBarsOffice2013Theme object.
virtual | ~CXTPCommandBarsOffice2013Theme ()
Destroys a CXTPCommandBarsOffice2013Theme object, handles cleanup and deallocation.
virtual XTPPaintTheme | BaseTheme ()
Retrieves the base theme of the manager.
virtual BOOL | DrawRectangle (CDC *pDC, CXTPControl *pButton)
This method is called to fill the control's face.
virtual void | FillCommandBarEntry (CDC *pDC, CXTPCommandBar *pBar)
This method is called to fill the command bar's face.
virtual void | FillDockBar (CDC *pDC, CXTPDockBar *pBar)
This method is called to fill a dock bar.
virtual void | DrawCommandBarGroupSeparator (CDC *pDC, CXTPCommandBar *pBar, CXTPControl *pLeftControl, CXTPControl *pRightControl, BOOL bDraw)
This method is called to draw a command bar's group separator.
virtual CSize | DrawControlEdit (CDC *pDC, CXTPControlEdit *pEdit, BOOL bDraw)
This method is called to draw the control.
virtual void | FillWorkspace (CDC *pDC, CRect rc, CRect rcExclude)
Draws workspace space.
virtual BOOL | RequiresResourceImages ()
Used by the paint manager to determine if the theme requires a resource DLL to load image and color information.
virtual COLORREF | GetControlEditBackColor (CXTPControl *pControl)
This method returns the edit control back color to draw.
virtual void | DrawGalleryItemBack (CDC *pDC, CRect rcItem, BOOL bEnabled, BOOL bSelected, BOOL bPressed, BOOL bChecked, XTPBarType barType)
This method is called to draw the background for a gallery menu item.
- Public Member Functions inherited from CXTPCommandBarsModernUITheme
CXTPCommandBarsModernUITheme ()
Constructs a CXTPCommandBarsModernUITheme object.
virtual | ~CXTPCommandBarsModernUITheme ()
Destroys a CXTPCommandBarsModernUITheme object, handles cleanup and deallocation.
virtual CXTPFramePaintManager * | GetFramePaintManager ()
Returns paint manager used to draw frames.
virtual CXTPRibbonPaintManager * | GetRibbonPaintManager ()
Retrieves the ribbon paint manager.
virtual CXTPMarkupContext * | GetMarkupContext ()
Retrieves a pointer to the markup context.
- Public Member Functions inherited from CXTPCommandBarsOfficeXPTheme
CXTPCommandBarsOfficeXPTheme ()
Constructs a CXTPCommandBarsOfficeXPTheme object.
virtual CSize | DrawListBoxControl (CDC *pDC, CXTPControl *pButton, CRect rc, BOOL bSelected, BOOL bDraw, CXTPCommandBars *pCommandBars=0)
This method is called to draw the control placed on the ListBox.
virtual void | AdjustExcludeRect (CRect &rc, CXTPControl *pControl, BOOL bVertical)
This method is called to determine the offset of a pop-up bar.
virtual CSize | DrawTearOffGripper (CDC *pDC, CRect rcGripper, BOOL bSelected, BOOL bDraw)
This method is called to draw a tear-off gripper of a pop-up bar.
virtual void | DrawPopupResizeGripper (CDC *pDC, CRect rcGripper, int nFlags)
This method is called to draw a resize gripper of a pop-up bar.
virtual CSize | DrawDialogBarGripper (CDC *pDC, CXTPDialogBar *pBar, BOOL bDraw)
Call this member to draw the gripper of a dialog bar.
- Public Member Functions inherited from CXTPPaintManager
virtual void | SetImageHandle (HMODULE hResource, LPCTSTR lpszIniFileName)
Specifies the resource that contains the bitmaps to be loaded for the theme.
CSize | DrawControl (CDC *pDC, CXTPControl *pButton, BOOL bDraw=TRUE)
This method is called to draw the control.
virtual CSize | DrawControlToolBarParent (CDC *pDC, CXTPControl *pButton, BOOL bDraw)
This method is called to draw the control placed on the toolbar.
virtual void | DrawControlEntry (CDC *pDC, CXTPControl *pButton)
This method is called to fill the control's face.
int | GetShadowOptions () const
Determines the kind of shadow to use.
virtual CSize | DrawSpecialControl (CDC *pDC, XTPSpecialControl controlType, CXTPControl *pButton, CXTPCommandBar *pBar, BOOL bDraw, LPVOID lpParam)
This method is called to draw the specified controls.
virtual CRect | GetCommandBarBorders (CXTPCommandBar *pBar)
This method is called to retrieve the command bar's borders.
virtual CRect | GetSplitButtonCommandRect (CXTPControl *pButton)
Determines split button command rectangle.
virtual void | SetCommandBarRegion (CXTPCommandBar *pCommandBar)
Call this method to set the bounding region of a pop-up bar.
XTPPaintTheme GetCurrentTheme ()
Call this member to get the current visual theme.
virtual CFont * | GetControlFont (CXTPControl *pControl)
Call this member to retrieve the font of the command bar control.
virtual CFont * | GetCommandBarFont (CXTPCommandBar *pCommandBar)
Call this member to retrieve the font of the command bar.
virtual XTPBarTextOrientation | GetControlTextOrientation (CXTPControl *pControl)
Call this member to determine how to draw text.
virtual void | UpdateFonts ()
Refreshes the fonts to use.
virtual void | UpdateColors ()
Refreshes the standard colors to use.
void | SetCommandBarsFontIndirect (LOGFONT *pLogFont, BOOL bUseStandardFont=FALSE)
Call this member to set command bar's font.
CFont * | GetRegularFont ()
Returns the general font.
CFont * | GetRegularBoldFont ()
Returns the general bold font.
CFont * | GetIconFont ()
Returns the icon font.
CFont * | GetSmCaptionFont ()
Call this method to retrieve the caption of a floating mini frame.
void | UseOfficeFont (bool bUseOfficeFont)
Call this method to use Tahoma font despite system metrics.
int | GetControlHeight () const
This method returns the common controls height.
virtual CSize | GetDefaultCommandBarSize (CXTPCommandBar *pBar)
Computes default command bar size taking into account command bar font.
void | Rectangle (CDC *pDC, LPCRECT rc, int nPen, const int nBrush)
Draws a rectangle.
void | Rectangle (CDC *pDC, LPCRECT rc, COLORREF clrPen, COLORREF clrBrush)
Draws a rectangle.
void | RoundRect (CDC *pDC, LPCRECT rc, COLORREF clrPen, COLORREF clrBrush)
Draws a rectangle.
void | Draw3dRect (CDC *pDC, LPCRECT rc, int nTopLeft, int nBottomRight)
Call this member function to draw a three-dimensional rectangle.
void | Draw3dRect (CDC *pDC, LPCRECT rc, int frameThickness, COLORREF clrPen, COLORREF clrBrush)
Call this member function to draw a rectangle with predetermined thickness.
virtual void | DrawPopupBarCheckMark (CDC *pDC, CRect rcCheck, BOOL bEnabled, COLORREF clr)
Call this member function to draw a check mark.
void | DrawCheckMark (CDC *pDC, CRect rcCheck, COLORREF clr=0)
Call this member function to draw a check mark.
virtual void | DrawPopupBarRadioMark (CDC *pDC, CRect rcCheck, BOOL bEnabled, COLORREF clr)
Call this member function to draw a radio button.
virtual void | DrawComboExpandMark (CDC *pDC, CRect rc, COLORREF clr)
Call this member function to draw a combobox expand symbol.
void | Line (CDC *pDC, CPoint p0, CPoint p1)
Draws a line.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1, const int nPen)
Draws a line.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1, COLORREF clrPen)
Draws a line.
void | HorizontalLine (CDC *pDC, int x0, int y0, int x1, COLORREF clrPen)
Call this member function to draw a horizontal line using the specified coordinages and RGB color value.
void | VerticalLine (CDC *pDC, int x0, int y0, int y1, COLORREF clrPen)
Call this member function to draw a vertical line using the specified coordinages and RGB color value.
void | Pixel (CDC *pDC, int xPos, int yPos, int nPen)
Sets the pixel at the point.
void | GradientFill (CDC *pDC, LPRECT lpRect, COLORREF crFrom, COLORREF crTo, BOOL bHorz, LPCRECT lpRectClip=NULL)
Gradient fills the rectangle.
XTP_COMMANDBARS_ICONSINFO * GetIconsInfo ()
virtual void | Animate (CDC *pDestDC, CDC *pSrcDC, CRect rc, XTPAnimationType animationType)
This method is called to animate the pop-up bar.
virtual void | AnimateExpanding (CXTPCommandBar *pCommandBar, CDC *pDestDC, CDC *pSrcDC, BOOL bExpandDown)
This method is called to animate the expanding process.
void | SetAnimationDelay (int nAnimationSteps, int nAnimationTime)
Call this method to set animation delay.
COLORREF | GetXtremeColor (UINT nIndex)
This function retrieves the current color of the specified XP display element.
void | SetColors (int cElements, CONST INT *lpaElements, CONST COLORREF *lpaRgbValues)
Call this member to set the colors for each element to the color in the specified color array.
CSize | DrawControlText (CDC *pDC, CXTPControl *pControl, CRect rcText, BOOL bDraw, BOOL bVert, BOOL bCentered, BOOL bTriangled)
This method is called to draw control text.
virtual void | UpdateRTLCaption (CString &strCaption)
This method is called to prepare a caption for Right-To-Left draw.
XTPCurrentSystemTheme GetCurrentSystemTheme ()
Call this member function to determine the current Windows XP theme in use.
void | SetLunaTheme (XTPCurrentSystemTheme systemTheme)
Call this method to force system theme.
virtual int | GetPopupBarGripperWidth (CXTPCommandBar *pBar)
Calculates the gripper of a pop-up bar.
virtual CXTPControlGalleryPaintManager * | GetGalleryPaintManager () const
Retrieves paint manager used to draw galleries.
virtual CXTPScrollBarPaintManager * | GetScrollBarPaintManager () const
Retrieves paint manager used to draw scrollbars.
virtual CXTPSliderPaintManager * | GetSliderPaintManager () const
Retrieves paint manager used to draw slider panes.
virtual CXTPProgressPaintManager * | GetProgressPaintManager () const
Retrieves paint manager used to draw progress bars.
virtual CXTPStatusBarPaintManager * | GetStatusBarPaintManager ()
Retrieves paint manager used to draw the status bar.
virtual CXTPMessageBarPaintManager * | GetMessageBarPaintManager ()
Retrieves paint manager used to draw message bars.
CXTPShadowManager * | GetShadowManager () const
Retrieves shadow manager used to draw shadows.
BOOL | IsUseSystemAccentColorEnabled () const
Determines whether xtpApplicationUseSystemAccentColor application ambient property is set.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.
- Public Member Functions inherited from CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents >
void | Subscribe (IXTPPaintManagerEvents *pObserver, CXTPSubscriptionList< CXTPPaintManager, IXTPPaintManagerEvents > *pSubcriptionList=NULL)
Subscribes a unique observer for events.
void | Unsubscribe (IXTPPaintManagerEvents *pObserver)
Unsubscribes an observer from events.
void | Notify (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *))
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *))
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.

Protected Member Functions

virtual void | RefreshMetrics ()
This method is called to refresh the visual metrics of the manager.
virtual void | RefreshStandardColors ()
Called to update the standard colors used by the framework.
virtual COLORREF | GetRectangleTextColor (BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition)
This method retrieves a buttons text color.
virtual COLORREF | GetControlTextColor (CXTPControl *pButton)
This method retrieves a buttons text color.
virtual COLORREF | GetControlBackColor (CXTPControl *pButton)
Call this method to get the control back color to draw.
virtual void | DrawRectangle (CDC *pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition)
This method is called to fill the control's face.
virtual void | DrawRectangle (CDC *pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition, int nID)
This method is called to fill the control's face.
void | DrawFrameBorder (CDC *pDC, CRect rc, int nBorderThickness, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition)
This method is called to fill the border of the control's face.
virtual void | DrawPopupBarGripper (CDC *pDC, int xPos, int yPos, int cx, int cy, BOOL bExpanded=FALSE)
This method is called to draw a pop-up bar's right gripper.
virtual CSize | DrawCommandBarGripper (CDC *pDC, CXTPCommandBar *pBar, BOOL bDraw=TRUE)
This method is called to draw the command bar's gripper.
virtual CSize | DrawControlComboBox (CDC *pDC, CXTPControlComboBox *pComboBox, BOOL bDraw)
This method is called to draw the control.
virtual void | DrawDropDownGlyph (CDC *pDC, CXTPControl *pControl, CPoint pt, BOOL bSelected, BOOL bPopuped, BOOL bEnabled, BOOL bVert)
This member function is called to draw a split button expand symbol.
virtual CSize | DrawCommandBarSeparator (CDC *pDC, CXTPCommandBar *pBar, CXTPControl *pControl, BOOL bDraw=TRUE)
This method is called to draw a command bar's separator.
virtual void | DrawExpandGlyph (CDC *pDC, CXTPControl *pButton, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clr)
Draw expand or hidden glyphs for a button.
virtual void | DrawHiddenGlyph (CDC *pDC, CXTPControl *pButton, COLORREF clr, BOOL bVertical)
Draw expand or hidden glyphs for a button.
virtual void | DrawExpandGlyph (CDC *pDC, CXTPControl *pButton, COLORREF clr, BOOL bVertical)
Draw expand or hidden glyphs for a button.
virtual CSize | DrawControlCheckBoxMark (CDC *pDC, CXTPControl *pButton, CRect rc, BOOL bDraw)
This method is called to draw a check box mark area.
virtual CSize | DrawControlCheckBoxMark (CDC *pDC, CRect rc, BOOL bDraw, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled)
This method is called to draw a check box mark area.
virtual CSize | DrawControlRadioButtonMark (CDC *pDC, CRect rc, BOOL bDraw, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled)
This method is called to draw a radio button mark area.
virtual void | DrawSplitButtonFrame (CDC *pDC, CXTPControl *pButton, CRect rc)
This method is called to draw the frame for the SplitButton control.
virtual void | DrawControlMDIButton (CDC *pDC, CXTPControlButton *pButton)
Call this member function to draw Menu MDI buttons.
- Protected Member Functions inherited from CXTPCommandBarsModernUITheme
- Protected Member Functions inherited from CXTPCommandBarsOfficeXPTheme
virtual CSize | DrawControlPopupParent (CDC *pDC, CXTPControl *pButton, BOOL bDraw)
This method is called to draw the control placed on the pop-up bar.
virtual void | DrawImage (CDC *pDC, CPoint pt, CSize sz, CXTPImageManagerIcon *pImage, BOOL bSelected, BOOL bPressed, BOOL bEnabled=TRUE, BOOL bChecked=FALSE, BOOL bPopuped=FALSE, BOOL bToolBarImage=TRUE)
This method is called to draw the image of the control.
void | FillIntersectRect (CDC *pDC, CXTPPopupBar *pPopupBar, COLORREF clr)
Draws intersect rectangle of a pop-up bar and its control.
- Protected Member Functions inherited from CXTPPaintManager
CXTPPaintManager ()
Constructs a CXTPPaintManager object.
virtual | ~CXTPPaintManager ()
Destroys a CXTPPaintManager object, handles cleanup and deallocation.
- Protected Member Functions inherited from CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents >
CXTPObservable ()
Constructs an observable object.
~CXTPObservable ()
Handles observable object destruction.

Protected Attributes

BOOL | m_bIntersect
TRUE to draw pop-up bar intersect rectangle.
CXTPColorSetStateMenu | m_csMenu
State colors used by Menu items.
CXTPColorSetStateMenuTitleBar | m_csMenuTitleBar
State colors used by MenuTitleBar items.
CXTPColorSetStateRibbon | m_csRibbon
State colors used by Ribbon group buttons.
CXTPColorSetStateToolbar | m_csToolbar
State colors used by Toolbar buttons.
CXTPColorSetStateCheckMark | m_csCheckMark
State colors used by Menu Check Marks.
CXTPColorSetStateComboBox | m_csComboBox
State colors used by ComboBox control.
CXTPColorSetStateCheckBox | m_csCheckBox
State colors used by Check Box and Radio Button controls.
CXTPPaintManagerColor | m_clrBack
CommandBars background color;.
CXTPPaintManagerColor | m_clrGlyph
Glyph Normal color.
CXTPPaintManagerColor | m_clrGlyphHighlight
Glyph Highlight color.
CXTPPaintManagerColor | m_clrGlyphPushed
Glyph Pushed color.
CXTPPaintManagerColor | m_clrGlyphDisabled
Glyph Disabled color.
CXTPPaintManagerColor | m_clrMessageBarText
Message bar text color.
CXTPPaintManagerColor | m_clrBtnFace
Button background color.
CXTPPaintManagerColor | m_clr3DShadow
Button shadow color.
CXTPPaintManagerColor | m_clrHighlight
Button highlight color.
CXTPPaintManagerColor | m_clrCaptionButtonFill
Text color for frame caption buttons.
CXTPPaintManagerColorGradient | m_clrWorkspace
Workspace area gradient color.
- Protected Attributes inherited from CXTPCommandBarsModernUITheme
CXTPMarkupContext * | m_pMarkupContext
Points to a valid markup context object.
CXTPResourceImages * | m_pImages
Points to a valid resource images object.
- Protected Attributes inherited from CXTPPaintManager
CXTPFont | m_xtpFontRegular
Regular font.
CXTPFont | m_xtpFontRegularBold
Regular bold font.
CXTPFont | m_xtpFontVert
Vertical font.
CXTPFont | m_xtpFontVertBold
Vertical font.
int | m_nEditHeight
Edit text height.
int | m_nFontHeight
Custom font height (optional).
BOOL | m_bUseStandardFont
TRUE to use system font.
BOOL | m_bEmbossedDisabledText
TRUE to draw disabled text embossed.
CXTPWinThemeWrapper * | m_themeStatusBar
StatusBar theme helper.
CXTPWinThemeWrapper * | m_themeButton
Buttons theme helper.
XTPPaintTheme | m_themeCurrent
Current theme.
XTP_COMMANDBARS_ICONSINFO | m_iconsInfo
Specific icons options.
int | m_nAnimationSteps
Steps of the animation.
int | m_nAnimationTime
Time of the animation.
BOOL | m_bShowKeyboardCues
TRUE to show keyboard cues - deprecated.
CXTPPaintManagerColor | m_arrColor [XPCOLOR_LAST+1]
Self colors array.
XTPCurrentSystemTheme | m_systemTheme
Current system theme.
CXTPShadowManager * | m_pShadowManager
Shadow manager.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPPaintManager
static CXTPPaintManager *AFX_CDECL | GetInstanceAddRef ()
Obtains a pointer to a global paint manager object and increments its reference counter.
static void AFX_CDECL | ReleaseInstance ()
Decrements global paint manager's reference counter and deletes its instance when the reference counter reaches 0.
static CXTPPaintManager *AFX_CDECL | CreateTheme (XTPPaintTheme paintTheme)
Creates a new CXTPPaintManager object.
static void AFX_CDECL | SetTheme (XTPPaintTheme paintTheme)
Call this member to switch the visual theme of the Command Bars.
static void AFX_CDECL | SetCustomTheme (CXTPPaintManager *pTheme)
Call this member to set a custom theme.
static void AFX_CDECL | Triangle (CDC *pDC, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clr)
Draws a triangle.
static BOOL AFX_CDECL | FontExists (LPCTSTR lpszFaceName)
Determines if a specified font exists in the system.
static void AFX_CDECL | StripMnemonics (CString &strClear)
This member function will search a string, strip off the mnemonic '&', and reformat the string.
static CXTPPaintManager *AFX_CDECL | GetGlobalPaintManager ()
Call this method to get the pointer to the global paint manager.
static void AFX_CDECL | SetGlobalPaintManager (CXTPPaintManager *pPaintManager)
Call this method to set the pointer to the global paint manager.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPPaintManager
COLORREF | m_clrMessageBarText
Message bar text color.
CRect | m_rcMessageBarMargin
Margin of the message bar.
CXTPFramePaintManager * | m_pFramePaintManager
Frame paint manager.
CXTPStatusBarPaintManager * | m_pStatusBarPaintManager
Paint manager of the status bar.
CXTPRibbonPaintManager * | m_pRibbonPaintManager
Ribbon paint Manager.
CXTPControlGalleryPaintManager * | m_pGalleryPaintManager
Gallery paint manager.
CXTPProgressPaintManager * | m_pProgressPaintManager
Progress bar paint manager.
CXTPSliderPaintManager * | m_pSliderPaintManager
Slider pane paint manager.
CXTPScrollBarPaintManager * | m_pScrollBarPaintManager
Scrollbar paint manager.
CXTPPaintManagerColorGradient | m_clrDisabledIcon
Disabled icons color.
CXTPPaintManagerColor | m_clrFloatingGripper
Gripper color of floating toolbar.
CXTPPaintManagerColor | m_clrFloatingGripperText
Gripper text color of floating toolbar.
BOOL | m_bThickCheckMark
TRUE to draw thick check mark.
BOOL | m_bShowShadow
TRUE to show shadow.
BOOL | m_bThemedStatusBar
TRUE to draw status bar using WinXP theme.
BOOL | m_bThemedCheckBox
TRUE to draw check box using WinXP theme.
BOOL | m_bClearTypeTextQuality
TRUE to enable ClearType text for the font.
BOOL | m_bFlatToolBar
TRUE to draw toolbars flat.
BOOL | m_bFlatMenuBar
TRUE to draw menubar flat.
int | m_nPopupBarTextPadding
Distance between gripper and control text.
BOOL | m_bSelectImageInPopupBar
TRUE to select image as in explorer theme.
BOOL | m_bEnableAnimation
TRUE to enable animation for all toolbars.
BOOL | m_bOffice2007Padding
TRUE if Office2007 metrics used.
BOOL | m_bOffsetPopupLabelText
TRUE if labels in pop-ups drawn with offset.
BOOL | m_bWrapCaptionBelowText
Wrap text for xtpButtonIconAndCaptionBelow buttons.
CXTPPaintManagerFont | m_fontSmCaption
Small caption font.
CXTPPaintManagerFont | m_fontIcon
Icon font.
CXTPPaintManagerFont | m_fontIconBold
Icon bold font.
CXTPPaintManagerFont | m_fontToolTip
Tooltip font.
int | m_nSplitButtonDropDownWidth
Split button drop down width in toolbars.
int | m_nSplitButtonDropDownHeight
Split button drop down height in toolbars.
int | m_nSplitButtonPopupWidth
Split button drop down width in pop-ups.
BOOL | m_bAutoResizeIcons
TRUE to automatically resize icons using current DPI.
int | m_nStatusBarMinHeight
Minimum height for the status bar.
PVOID | m_pfnSetLayeredWindowAttributes
point to Transparency proc in USER32.dll module.
CRect | m_rcStatusBarBorder
Bounding rectangle of the status bar border.
BOOL | m_bUseOfficeFont
TRUE to use Tahoma font.
CString | m_strOfficeFont
Office font.
int | m_nTextHeight
Regular text field height (not font height).

Detailed Description

The CXTPCommandBarsOffice2013Theme class is used to enable an Office 2013 style theme for Command Bars.

See also
CXTPPaintManager::SetTheme

Member Function Documentation

◆ BaseTheme()

AFX_INLINE XTPPaintTheme BaseTheme ( )
virtual

Retrieves the base theme of the manager.

Returns
Returns the base theme of the manager.

Reimplemented from CXTPCommandBarsOfficeXPTheme.

◆ DrawCommandBarGripper()

virtual CSize DrawCommandBarGripper | ( | CDC * | pDC,
 |  | CXTPCommandBar * | pBar,
 |  | BOOL | bDraw = TRUE )
 protectedvirtual

This method is called to draw the command bar's gripper.

Parameters
pDC | Pointer to a valid device context.
pBar | Pointer to a CXTPCommandBar object.
bDraw | TRUE to draw; FALSE to retrieve the size of the gripper.
Returns
Size of the gripper.

Reimplemented from CXTPCommandBarsOfficeXPTheme.

Reimplemented in CXTPCommandBarsNativeWindows10Theme, CXTPCommandBarsNativeWindows11Theme, CXTPCommandBarsVisualStudio2015Theme, CXTPCommandBarsVisualStudio2017Theme, CXTPCommandBarsVisualStudio2019Theme, and CXTPCommandBarsVisualStudio2022Theme.

◆ DrawCommandBarGroupSeparator()

virtual void DrawCommandBarGroupSeparator | ( | CDC * | pDC,
 |  | CXTPCommandBar * | pBar,
 |  | CXTPControl * | pLeftControl,
 |  | CXTPControl * | pRightControl,
 |  | BOOL | bDraw )
 virtual

This method is called to draw a command bar's group separator.

Parameters
pDC | Pointer to a valid device context.
pBar | Pointer to a CXTPCommandBar object.
pLeftControl | Pointer to a left CXTPControl object.
pRightControl | Pointer to a right CXTPControl object.
bDraw | TRUE to draw; FALSE to retrieve the size of the separator.

Reimplemented from CXTPPaintManager.

◆ DrawCommandBarSeparator()

virtual CSize DrawCommandBarSeparator | ( | CDC * | pDC,
 |  | CXTPCommandBar * | pBar,
 |  | CXTPControl * | pControl,
 |  | BOOL | bDraw = TRUE )
 protectedvirtual

This method is called to draw a command bar's separator.

Parameters
pDC | Pointer to a valid device context.
pBar | Pointer to a CXTPCommandBar object.
pControl | Pointer to a CXTPControl object.
bDraw | TRUE to draw; FALSE to retrieve the size of the separator.
Returns
Size of the separator.

Reimplemented from CXTPCommandBarsOfficeXPTheme.

◆ DrawControlCheckBoxMark() [1/2]

virtual CSize DrawControlCheckBoxMark | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | BOOL | bDraw,
 |  | BOOL | bSelected,
 |  | BOOL | bPressed,
 |  | BOOL | bChecked,
 |  | BOOL | bEnabled )
 protectedvirtual

This method is called to draw a check box mark area.

Parameters
pDC | Pointer to a valid device context.
rc | Bounding rectangle.
bDraw | TRUE to draw; FALSE to find size.
bSelected | TRUE if control is selected.
bPressed | TRUE if control is pressed.
bChecked | TRUE if control is checked.
bEnabled | TRUE if control is enabled.
Returns
Size of check box mark.

Reimplemented from CXTPCommandBarsOfficeXPTheme.

◆ DrawControlCheckBoxMark() [2/2]

virtual CSize DrawControlCheckBoxMark | ( | CDC * | pDC,
 |  | CXTPControl * | pButton,
 |  | CRect | rc,
 |  | BOOL | bDraw )
 protectedvirtual

This method is called to draw a check box mark area.

Parameters
pDC | Pointer to a valid device context.
pButton | Pointer to the checkbox control.
rc | Bounding rectangle of the check box itself (not control).
bDraw | TRUE to draw; FALSE to find size.
Returns
Size of check box mark.

Reimplemented from CXTPCommandBarsOfficeXPTheme.

◆ DrawControlComboBox()

virtual CSize DrawControlComboBox | ( | CDC * | pDC,
 |  | CXTPControlComboBox * | pComboBox,
 |  | BOOL | bDraw )
 protectedvirtual

This method is called to draw the control.

Parameters
pDC | Pointer to a valid device context.
bDraw | TRUE to draw; FALSE to retrieve the size of the control.
pComboBox | Pointer to the CXTPControlComboBox object to draw.
Returns
Size of the control.

Reimplemented from CXTPCommandBarsOfficeXPTheme.

Reimplemented in CXTPCommandBarsNativeWindows10Theme, CXTPCommandBarsNativeWindows11Theme, CXTPCommandBarsVisualStudio2015Theme, CXTPCommandBarsVisualStudio2017Theme, CXTPCommandBarsVisualStudio2019Theme, and CXTPCommandBarsVisualStudio2022Theme.

◆ DrawControlEdit()

virtual CSize DrawControlEdit | ( | CDC * | pDC,
 |  | CXTPControlEdit * | pEdit,
 |  | BOOL | bDraw )
 virtual

This method is called to draw the control.

Parameters
pDC | Pointer to a valid device context.
bDraw | TRUE to draw; FALSE to retrieve the size of the control.
pEdit | Edit control to draw.
Returns
Size of the control.

Reimplemented from CXTPCommandBarsOfficeXPTheme.

◆ DrawControlMDIButton()

virtual void DrawControlMDIButton | ( | CDC * | pDC,
 |  | CXTPControlButton * | pButton )
 protectedvirtual

Call this member function to draw Menu MDI buttons.

Parameters
pDC | Pointer to a valid device context.
pButton | Button to draw.

Reimplemented from CXTPPaintManager.

◆ DrawControlRadioButtonMark()

virtual CSize DrawControlRadioButtonMark | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | BOOL | bDraw,
 |  | BOOL | bSelected,
 |  | BOOL | bPressed,
 |  | BOOL | bChecked,
 |  | BOOL | bEnabled )
 protectedvirtual

This method is called to draw a radio button mark area.

Parameters
pDC | Pointer to a valid device context.
rc | Bounding rectangle.
bDraw | TRUE to draw; FALSE to find size.
bSelected | TRUE if control is selected.
bPressed | TRUE if control is pressed.
bChecked | TRUE if control is checked.
bEnabled | TRUE if control is enabled.
Returns
Size of radio button mark.

Reimplemented from CXTPCommandBarsOfficeXPTheme.

◆ DrawDropDownGlyph()

virtual void DrawDropDownGlyph | ( | CDC * | pDC,
 |  | CXTPControl * | pControl,
 |  | CPoint | pt,
 |  | BOOL | bSelected,
 |  | BOOL | bPopuped,
 |  | BOOL | bEnabled,
 |  | BOOL | bVert )
 protectedvirtual

This member function is called to draw a split button expand symbol.

Parameters
pDC | Pointer to a valid device context.
pControl | Pointer to a CXTPControl object.
pt | Position of the expand symbol.
bSelected | TRUE if the control is selected.
bPopuped | TRUE if the control is pop-up'ed.
bEnabled | TRUE if the control is enabled.
bVert | TRUE if control is vertical.

Reimplemented from CXTPPaintManager.

◆ DrawExpandGlyph() [1/2]

virtual void DrawExpandGlyph | ( | CDC * | pDC,
 |  | CXTPControl * | pButton,
 |  | COLORREF | clr,
 |  | BOOL | bVertical )
 protectedvirtual

Draw expand or hidden glyphs for a button.

Parameters
pDC | Output device context pointer.
pButton | Target button pointer.
clr | Glyph color.
bVertical | TRUE if vertically positioned glyph is to be drawn.

Reimplemented from CXTPPaintManager.

◆ DrawExpandGlyph() [2/2]

virtual void DrawExpandGlyph | ( | CDC * | pDC,
 |  | CXTPControl * | pButton,
 |  | CPoint | pt0,
 |  | CPoint | pt1,
 |  | CPoint | pt2,
 |  | COLORREF | clr )
 protectedvirtual

Draw expand or hidden glyphs for a button.

Parameters
pDC | Output device context pointer.
pButton | Target button pointer.
pt0 | Expand glyph triangle coordinates.
pt1 | Expand glyph triangle coordinates.
pt2 | Expand glyph triangle coordinates.
clr | Glyph color.

Reimplemented from CXTPPaintManager.

◆ DrawFrameBorder()

void DrawFrameBorder | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | int | nBorderThickness,
 |  | BOOL | bSelected,
 |  | BOOL | bPressed,
 |  | BOOL | bEnabled,
 |  | BOOL | bChecked,
 |  | BOOL | bPopuped,
 |  | XTPBarType | barType,
 |  | XTPBarPosition | barPosition )
 protected

This method is called to fill the border of the control's face.

Parameters
pDC | Pointer to a valid device context.
rc | Rectangle to draw.
bSelected | TRUE if the control is selected.
bPressed | TRUE if the control is pushed.
bEnabled | TRUE if the control is enabled.
bChecked | TRUE if the control is checked.
bPopuped | TRUE if the control is pop-up'ed.
barType | Parent's bar type.
barPosition | Parent's bar position.
nBorderThickness | Border thickness value.

◆ DrawGalleryItemBack()

virtual void DrawGalleryItemBack | ( | CDC * | pDC,
 |  | CRect | rcItem,
 |  | BOOL | bEnabled,
 |  | BOOL | bSelected,
 |  | BOOL | bPressed,
 |  | BOOL | bChecked,
 |  | XTPBarType | barType )
 virtual

This method is called to draw the background for a gallery menu item.

Parameters
pDC | Pointer to a valid device context.
rcItem | CRect object specifying the size of the area.
bSelected | TRUE if the control is selected.
bPressed | TRUE if the control is pushed.
bEnabled | TRUE if the control is enabled.
bChecked | TRUE if the control is checked.
barType | Parent's bar type.

Reimplemented from CXTPPaintManager.

Reimplemented in CXTPCommandBarsNativeWindows10Theme, CXTPCommandBarsNativeWindows11Theme, CXTPCommandBarsVisualStudio2015Theme, CXTPCommandBarsVisualStudio2017Theme, CXTPCommandBarsVisualStudio2019Theme, and CXTPCommandBarsVisualStudio2022Theme.

◆ DrawHiddenGlyph()

virtual void DrawHiddenGlyph | ( | CDC * | pDC,
 |  | CXTPControl * | pButton,
 |  | COLORREF | clr,
 |  | BOOL | bVertical )
 protectedvirtual

Draw expand or hidden glyphs for a button.

Parameters
pDC | Output device context pointer.
pButton | Target button pointer.
clr | Glyph color.
bVertical | TRUE if vertically positioned glyph is to be drawn.

Reimplemented from CXTPPaintManager.

◆ DrawPopupBarGripper()

virtual void DrawPopupBarGripper | ( | CDC * | pDC,
 |  | int | xPos,
 |  | int | yPos,
 |  | int | cx,
 |  | int | cy,
 |  | BOOL | bExpanded = FALSE )
 protectedvirtual

This method is called to draw a pop-up bar's right gripper.

Parameters
pDC | Pointer to a valid device context.
xPos | Specifies the logical x coordinate of the upper-left corner of the rectangle.
yPos | Specifies the logical y coordinate of the upper-left corner of the destination rectangle.
cx | Specifies the width of the rectangle.
cy | Specifies the height of the rectangle.
bExpanded | TRUE if expanded.

Reimplemented from CXTPCommandBarsOfficeXPTheme.

◆ DrawRectangle() [1/3]

virtual void DrawRectangle | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | BOOL | bSelected,
 |  | BOOL | bPressed,
 |  | BOOL | bEnabled,
 |  | BOOL | bChecked,
 |  | BOOL | bPopuped,
 |  | XTPBarType | barType,
 |  | XTPBarPosition | barPosition )
 protectedvirtual

This method is called to fill the control's face.

Parameters
pDC | Pointer to a valid device context.
rc | Rectangle to draw.
bSelected | TRUE if the control is selected.
bPressed | TRUE if the control is pushed.
bEnabled | TRUE if the control is enabled.
bChecked | TRUE if the control is checked.
bPopuped | TRUE if the control is pop-up'ed.
barType | Parent's bar type.
barPosition | Parent's bar position.

Reimplemented from CXTPCommandBarsOfficeXPTheme.

Reimplemented in CXTPCommandBarsNativeWindows10Theme, CXTPCommandBarsNativeWindows11Theme, CXTPCommandBarsVisualStudio2015Theme, CXTPCommandBarsVisualStudio2017Theme, CXTPCommandBarsVisualStudio2019Theme, and CXTPCommandBarsVisualStudio2022Theme.

◆ DrawRectangle() [2/3]

virtual void DrawRectangle | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | BOOL | bSelected,
 |  | BOOL | bPressed,
 |  | BOOL | bEnabled,
 |  | BOOL | bChecked,
 |  | BOOL | bPopuped,
 |  | XTPBarType | barType,
 |  | XTPBarPosition | barPosition,
 |  | int | nID )
 protectedvirtual

This method is called to fill the control's face.

Parameters
pDC | Pointer to a valid device context.
rc | Rectangle to draw.
bSelected | TRUE if the control is selected.
bPressed | TRUE if the control is pushed.
bEnabled | TRUE if the control is enabled.
bChecked | TRUE if the control is checked.
bPopuped | TRUE if the control is pop-up'ed.
barType | Parent's bar type.
barPosition | Parent's bar position.
nID | Bar's control ID.

Reimplemented from CXTPCommandBarsOfficeXPTheme.

Reimplemented in CXTPCommandBarsNativeWindows10Theme, CXTPCommandBarsNativeWindows11Theme, CXTPCommandBarsVisualStudio2015Theme, CXTPCommandBarsVisualStudio2017Theme, CXTPCommandBarsVisualStudio2019Theme, and CXTPCommandBarsVisualStudio2022Theme.

◆ DrawRectangle() [3/3]

virtual BOOL DrawRectangle | ( | CDC * | pDC,
 |  | CXTPControl * | pButton )
 virtual

This method is called to fill the control's face.

Parameters
pDC | Pointer to a valid device context.
pButton | Pointer to a CXTPControl object to draw.
Returns
TRUE if the rectangle was drawn, otherwise FALSE.

Reimplemented from CXTPCommandBarsOfficeXPTheme.

Reimplemented in CXTPCommandBarsNativeWindows10Theme, CXTPCommandBarsNativeWindows11Theme, CXTPCommandBarsVisualStudio2015Theme, CXTPCommandBarsVisualStudio2017Theme, CXTPCommandBarsVisualStudio2019Theme, and CXTPCommandBarsVisualStudio2022Theme.

◆ DrawSplitButtonFrame()

virtual void DrawSplitButtonFrame | ( | CDC * | pDC,
 |  | CXTPControl * | pButton,
 |  | CRect | rc )
 protectedvirtual

This method is called to draw the frame for the SplitButton control.

Parameters
pDC | Pointer to a valid device context.
pButton | Pointer to a CXTPControl object.
rc | Bounding rectangle to draw.

Reimplemented from CXTPCommandBarsOfficeXPTheme.

Reimplemented in CXTPCommandBarsNativeWindows10Theme, CXTPCommandBarsNativeWindows11Theme, CXTPCommandBarsVisualStudio2015Theme, CXTPCommandBarsVisualStudio2017Theme, CXTPCommandBarsVisualStudio2019Theme, and CXTPCommandBarsVisualStudio2022Theme.

◆ FillCommandBarEntry()

virtual void FillCommandBarEntry | ( | CDC * | pDC,
 |  | CXTPCommandBar * | pBar )
 virtual

This method is called to fill the command bar's face.

Parameters
pDC | Pointer to a valid device context.
pBar | Pointer to a CXTPCommandBar object to draw.

Reimplemented from CXTPCommandBarsOfficeXPTheme.

Reimplemented in CXTPCommandBarsNativeWindows11Theme.

◆ FillDockBar()

virtual void FillDockBar | ( | CDC * | pDC,
 |  | CXTPDockBar * | pBar )
 virtual

This method is called to fill a dock bar.

Parameters
pDC | Pointer to a valid device context.
pBar | Pointer to a CXTPDockBar object.

Reimplemented from CXTPPaintManager.

Reimplemented in CXTPCommandBarsNativeWindows11Theme.

◆ FillWorkspace()

virtual void FillWorkspace | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | CRect | rcExclude )
 virtual

Draws workspace space.

Parameters
pDC | Pointer to a valid device context.
rc | Bounding rectangle.
rcExclude | Excluded rectangle.

Reimplemented from CXTPPaintManager.

◆ GetControlBackColor()

virtual COLORREF GetControlBackColor ( CXTPControl * pButton )
protectedvirtual

Call this method to get the control back color to draw.

Parameters
pButton Pointer to a CXTPControl object to draw.
Returns
The control back color to draw.

Reimplemented from CXTPPaintManager.

◆ GetControlEditBackColor()

virtual COLORREF GetControlEditBackColor ( CXTPControl * pControl )
virtual

This method returns the edit control back color to draw.

Parameters
pControl Pointer to the CXTPControl object to get the back color from.
Returns
Edit control back color.

Reimplemented from CXTPPaintManager.

◆ GetControlTextColor()

virtual COLORREF GetControlTextColor ( CXTPControl * pButton )
protectedvirtual

This method retrieves a buttons text color.

Parameters
pButton Pointer to the button.
Returns
returns buttons text color

Reimplemented from CXTPPaintManager.

Reimplemented in CXTPCommandBarsNativeWindows10Theme, CXTPCommandBarsNativeWindows11Theme, CXTPCommandBarsVisualStudio2015Theme, CXTPCommandBarsVisualStudio2017Theme, CXTPCommandBarsVisualStudio2019Theme, and CXTPCommandBarsVisualStudio2022Theme.

◆ GetRectangleTextColor()

virtual COLORREF GetRectangleTextColor | ( | BOOL | bSelected,
 |  | BOOL | bPressed,
 |  | BOOL | bEnabled,
 |  | BOOL | bChecked,
 |  | BOOL | bPopuped,
 |  | XTPBarType | barType,
 |  | XTPBarPosition | barPosition )
 protectedvirtual

This method retrieves a buttons text color.

Parameters
bSelected | TRUE if the control is selected.
bPressed | TRUE if the control is pushed.
bEnabled | TRUE if the control is enabled.
bChecked | TRUE if the control is checked.
bPopuped | TRUE if the control is pop-up'ed.
barType | Parent's bar type.
barPosition | Parent's bar position.
Returns
Returns buttons text color

Reimplemented from CXTPCommandBarsOfficeXPTheme.

◆ RefreshStandardColors()

virtual void RefreshStandardColors ( )
protectedvirtual

Called to update the standard colors used by the framework.

See also
CXTPPaintManager::GetXtremeColor(UINT nIndex)

◆ RequiresResourceImages()

AFX_INLINE BOOL RequiresResourceImages ( )
virtual

Used by the paint manager to determine if the theme requires a resource DLL to load image and color information.

Returns
Returns TRUE if the theme requires a resource DLL, otherwise FALSE.

Reimplemented from CXTPPaintManager.

The documentation for this class was generated from the following file:
  • XTPCommandBarsOffice2013Theme.h


Toolkit Pro: CXTPCommandBarsOfficeXPTheme Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPCommandBarsOfficeXPTheme Class Reference

The CXTPCommandBarsOfficeXPTheme class is used to enable an Office XP style theme for Command Bars. More...

Inheritance diagram for CXTPCommandBarsOfficeXPTheme:
[legend]

Public Member Functions

CXTPCommandBarsOfficeXPTheme ()
Constructs a CXTPCommandBarsOfficeXPTheme object.
virtual void | FillCommandBarEntry (CDC *pDC, CXTPCommandBar *pBar)
This method is called to fill the command bar's face.
virtual COLORREF | GetRectangleTextColor (BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition)
This method retrieves a buttons text color.
virtual CSize | DrawCommandBarGripper (CDC *pDC, CXTPCommandBar *pBar, BOOL bDraw=TRUE)
This method is called to draw the command bar's gripper.
virtual CSize | DrawCommandBarSeparator (CDC *pDC, CXTPCommandBar *pBar, CXTPControl *pControl, BOOL bDraw=TRUE)
This method is called to draw a command bar's separator.
virtual CSize | DrawListBoxControl (CDC *pDC, CXTPControl *pButton, CRect rc, BOOL bSelected, BOOL bDraw, CXTPCommandBars *pCommandBars=0)
This method is called to draw the control placed on the ListBox.
virtual void | AdjustExcludeRect (CRect &rc, CXTPControl *pControl, BOOL bVertical)
This method is called to determine the offset of a pop-up bar.
virtual CSize | DrawTearOffGripper (CDC *pDC, CRect rcGripper, BOOL bSelected, BOOL bDraw)
This method is called to draw a tear-off gripper of a pop-up bar.
virtual void | DrawPopupResizeGripper (CDC *pDC, CRect rcGripper, int nFlags)
This method is called to draw a resize gripper of a pop-up bar.
virtual CSize | DrawDialogBarGripper (CDC *pDC, CXTPDialogBar *pBar, BOOL bDraw)
Call this member to draw the gripper of a dialog bar.
- Public Member Functions inherited from CXTPPaintManager
virtual void | SetImageHandle (HMODULE hResource, LPCTSTR lpszIniFileName)
Specifies the resource that contains the bitmaps to be loaded for the theme.
CSize | DrawControl (CDC *pDC, CXTPControl *pButton, BOOL bDraw=TRUE)
This method is called to draw the control.
virtual CSize | DrawControlToolBarParent (CDC *pDC, CXTPControl *pButton, BOOL bDraw)
This method is called to draw the control placed on the toolbar.
virtual COLORREF | GetControlEditBackColor (CXTPControl *pControl)
This method returns the edit control back color to draw.
virtual void | DrawControlEntry (CDC *pDC, CXTPControl *pButton)
This method is called to fill the control's face.
virtual COLORREF | GetControlTextColor (CXTPControl *pButton)
Call this method to get the control text color to draw.
virtual COLORREF | GetControlBackColor (CXTPControl *pButton)
Call this method to get the control back color to draw.
virtual void | DrawGalleryItemBack (CDC *pDC, CRect rcItem, BOOL bEnabled, BOOL bSelected, BOOL bPressed, BOOL bChecked, XTPBarType barType)
This method is called to draw the background for a gallery menu item.
virtual void | DrawCommandBarGroupSeparator (CDC *pDC, CXTPCommandBar *pBar, CXTPControl *pLeftControl, CXTPControl *pRightControl, BOOL bDraw=TRUE)
This method is called to draw a command bar's group separator.
virtual void | FillDockBar (CDC *pDC, CXTPDockBar *pBar)
This method is called to fill a dock bar.
virtual void | FillWorkspace (CDC *pDC, CRect rc, CRect rcExclude)
This method is called to fill a workspace.
virtual void | RefreshMetrics ()
This method is called to refresh the visual metrics of the manager.
int | GetShadowOptions () const
Determines the kind of shadow to use.
virtual void | DrawExpandGlyph (CDC *pDC, CXTPControl *pButton, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clr)
Draw expand or hidden glyphs for a button.
virtual void | DrawExpandGlyph (CDC *pDC, CXTPControl *pButton, COLORREF clr, BOOL bVertical)
Draw expand or hidden glyphs for a button.
virtual void | DrawHiddenGlyph (CDC *pDC, CXTPControl *pButton, COLORREF clr, BOOL bVertical)
Draw expand or hidden glyphs for a button.
virtual CSize | DrawSpecialControl (CDC *pDC, XTPSpecialControl controlType, CXTPControl *pButton, CXTPCommandBar *pBar, BOOL bDraw, LPVOID lpParam)
This method is called to draw the specified controls.
virtual CRect | GetCommandBarBorders (CXTPCommandBar *pBar)
This method is called to retrieve the command bar's borders.
virtual CRect | GetSplitButtonCommandRect (CXTPControl *pButton)
Determines split button command rectangle.
virtual void | SetCommandBarRegion (CXTPCommandBar *pCommandBar)
Call this method to set the bounding region of a pop-up bar.
XTPPaintTheme GetCurrentTheme ()
Call this member to get the current visual theme.
virtual BOOL | RequiresResourceImages ()
Used by the paint manager to determine if the theme requires a resource DLL to load image and color information.
virtual CFont * | GetControlFont (CXTPControl *pControl)
Call this member to retrieve the font of the command bar control.
virtual CFont * | GetCommandBarFont (CXTPCommandBar *pCommandBar)
Call this member to retrieve the font of the command bar.
virtual XTPBarTextOrientation | GetControlTextOrientation (CXTPControl *pControl)
Call this member to determine how to draw text.
virtual void | UpdateFonts ()
Refreshes the fonts to use.
virtual void | UpdateColors ()
Refreshes the standard colors to use.
void | SetCommandBarsFontIndirect (LOGFONT *pLogFont, BOOL bUseStandardFont=FALSE)
Call this member to set command bar's font.
CFont * | GetRegularFont ()
Returns the general font.
CFont * | GetRegularBoldFont ()
Returns the general bold font.
CFont * | GetIconFont ()
Returns the icon font.
CFont * | GetSmCaptionFont ()
Call this method to retrieve the caption of a floating mini frame.
void | UseOfficeFont (bool bUseOfficeFont)
Call this method to use Tahoma font despite system metrics.
int | GetControlHeight () const
This method returns the common controls height.
virtual CSize | GetDefaultCommandBarSize (CXTPCommandBar *pBar)
Computes default command bar size taking into account command bar font.
void | Rectangle (CDC *pDC, LPCRECT rc, int nPen, const int nBrush)
Draws a rectangle.
void | Rectangle (CDC *pDC, LPCRECT rc, COLORREF clrPen, COLORREF clrBrush)
Draws a rectangle.
void | RoundRect (CDC *pDC, LPCRECT rc, COLORREF clrPen, COLORREF clrBrush)
Draws a rectangle.
void | Draw3dRect (CDC *pDC, LPCRECT rc, int nTopLeft, int nBottomRight)
Call this member function to draw a three-dimensional rectangle.
void | Draw3dRect (CDC *pDC, LPCRECT rc, int frameThickness, COLORREF clrPen, COLORREF clrBrush)
Call this member function to draw a rectangle with predetermined thickness.
virtual void | DrawPopupBarCheckMark (CDC *pDC, CRect rcCheck, BOOL bEnabled, COLORREF clr)
Call this member function to draw a check mark.
void | DrawCheckMark (CDC *pDC, CRect rcCheck, COLORREF clr=0)
Call this member function to draw a check mark.
virtual void | DrawPopupBarRadioMark (CDC *pDC, CRect rcCheck, BOOL bEnabled, COLORREF clr)
Call this member function to draw a radio button.
virtual void | DrawComboExpandMark (CDC *pDC, CRect rc, COLORREF clr)
Call this member function to draw a combobox expand symbol.
virtual void | DrawControlMDIButton (CDC *pDC, CXTPControlButton *pButton)
Call this member function to draw menu MDI buttons.
void | Line (CDC *pDC, CPoint p0, CPoint p1)
Draws a line.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1, const int nPen)
Draws a line.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1, COLORREF clrPen)
Draws a line.
void | HorizontalLine (CDC *pDC, int x0, int y0, int x1, COLORREF clrPen)
Call this member function to draw a horizontal line using the specified coordinages and RGB color value.
void | VerticalLine (CDC *pDC, int x0, int y0, int y1, COLORREF clrPen)
Call this member function to draw a vertical line using the specified coordinages and RGB color value.
virtual void | DrawDropDownGlyph (CDC *pDC, CXTPControl *pControl, CPoint pt, BOOL bSelected, BOOL bPopuped, BOOL bEnabled, BOOL bVert)
This member function is called to draw a split button expand symbol.
void | Pixel (CDC *pDC, int xPos, int yPos, int nPen)
Sets the pixel at the point.
void | GradientFill (CDC *pDC, LPRECT lpRect, COLORREF crFrom, COLORREF crTo, BOOL bHorz, LPCRECT lpRectClip=NULL)
Gradient fills the rectangle.
XTP_COMMANDBARS_ICONSINFO * GetIconsInfo ()
virtual void | Animate (CDC *pDestDC, CDC *pSrcDC, CRect rc, XTPAnimationType animationType)
This method is called to animate the pop-up bar.
virtual void | AnimateExpanding (CXTPCommandBar *pCommandBar, CDC *pDestDC, CDC *pSrcDC, BOOL bExpandDown)
This method is called to animate the expanding process.
void | SetAnimationDelay (int nAnimationSteps, int nAnimationTime)
Call this method to set animation delay.
COLORREF | GetXtremeColor (UINT nIndex)
This function retrieves the current color of the specified XP display element.
void | SetColors (int cElements, CONST INT *lpaElements, CONST COLORREF *lpaRgbValues)
Call this member to set the colors for each element to the color in the specified color array.
CSize | DrawControlText (CDC *pDC, CXTPControl *pControl, CRect rcText, BOOL bDraw, BOOL bVert, BOOL bCentered, BOOL bTriangled)
This method is called to draw control text.
virtual void | UpdateRTLCaption (CString &strCaption)
This method is called to prepare a caption for Right-To-Left draw.
XTPCurrentSystemTheme GetCurrentSystemTheme ()
Call this member function to determine the current Windows XP theme in use.
void | SetLunaTheme (XTPCurrentSystemTheme systemTheme)
Call this method to force system theme.
virtual int | GetPopupBarGripperWidth (CXTPCommandBar *pBar)
Calculates the gripper of a pop-up bar.
virtual CXTPControlGalleryPaintManager * | GetGalleryPaintManager () const
Retrieves paint manager used to draw galleries.
virtual CXTPScrollBarPaintManager * | GetScrollBarPaintManager () const
Retrieves paint manager used to draw scrollbars.
virtual CXTPSliderPaintManager * | GetSliderPaintManager () const
Retrieves paint manager used to draw slider panes.
virtual CXTPProgressPaintManager * | GetProgressPaintManager () const
Retrieves paint manager used to draw progress bars.
virtual CXTPFramePaintManager * | GetFramePaintManager ()
Retrieves paint manager used to draw frames.
virtual CXTPStatusBarPaintManager * | GetStatusBarPaintManager ()
Retrieves paint manager used to draw the status bar.
virtual CXTPRibbonPaintManager * | GetRibbonPaintManager ()
Retrieves the ribbon paint manager.
virtual CXTPMessageBarPaintManager * | GetMessageBarPaintManager ()
Retrieves paint manager used to draw message bars.
CXTPShadowManager * | GetShadowManager () const
Retrieves shadow manager used to draw shadows.
BOOL | IsUseSystemAccentColorEnabled () const
Determines whether xtpApplicationUseSystemAccentColor application ambient property is set.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.
- Public Member Functions inherited from CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents >
void | Subscribe (IXTPPaintManagerEvents *pObserver, CXTPSubscriptionList< CXTPPaintManager, IXTPPaintManagerEvents > *pSubcriptionList=NULL)
Subscribes a unique observer for events.
void | Unsubscribe (IXTPPaintManagerEvents *pObserver)
Unsubscribes an observer from events.
void | Notify (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *))
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *))
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.

Protected Member Functions

virtual void | DrawPopupBarGripper (CDC *pDC, int xPos, int yPos, int cx, int cy, BOOL bExpanded=FALSE)
This method is called to draw a pop-up bar's right gripper.
virtual CSize | DrawControlPopupParent (CDC *pDC, CXTPControl *pButton, BOOL bDraw)
This method is called to draw the control placed on the pop-up bar.
virtual void | DrawRectangle (CDC *pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition)
This method is called to fill the control's face.
virtual void | DrawRectangle (CDC *pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition, int nID)
This method is called to fill the control's face.
virtual BOOL | DrawRectangle (CDC *pDC, CXTPControl *pButton)
This method is called to fill the control's face.
virtual void | DrawImage (CDC *pDC, CPoint pt, CSize sz, CXTPImageManagerIcon *pImage, BOOL bSelected, BOOL bPressed, BOOL bEnabled=TRUE, BOOL bChecked=FALSE, BOOL bPopuped=FALSE, BOOL bToolBarImage=TRUE)
This method is called to draw the image of the control.
virtual CSize | DrawControlComboBox (CDC *pDC, CXTPControlComboBox *pComboBox, BOOL bDraw)
This method is called to draw the control.
virtual CSize | DrawControlEdit (CDC *pDC, CXTPControlEdit *pEdit, BOOL bDraw)
This method is called to draw the control.
void | FillIntersectRect (CDC *pDC, CXTPPopupBar *pPopupBar, COLORREF clr)
Draws intersect rectangle of a pop-up bar and its control.
virtual XTPPaintTheme | BaseTheme ()
Retrieves the base theme of the manager.
virtual void | DrawSplitButtonFrame (CDC *pDC, CXTPControl *pButton, CRect rc)
This method is called to draw the frame for the SplitButton control.
virtual CSize | DrawControlCheckBoxMark (CDC *pDC, CRect rc, BOOL bDraw, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled)
This method is called to draw a check box mark area.
virtual CSize | DrawControlCheckBoxMark (CDC *pDC, CXTPControl *pButton, CRect rc, BOOL bDraw)
This method is called to draw a check box mark area.
virtual CSize | DrawControlRadioButtonMark (CDC *pDC, CRect rc, BOOL bDraw, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled)
This method is called to draw a radio button mark area.
- Protected Member Functions inherited from CXTPPaintManager
CXTPPaintManager ()
Constructs a CXTPPaintManager object.
virtual | ~CXTPPaintManager ()
Destroys a CXTPPaintManager object, handles cleanup and deallocation.
- Protected Member Functions inherited from CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents >
CXTPObservable ()
Constructs an observable object.
~CXTPObservable ()
Handles observable object destruction.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPPaintManager
static CXTPPaintManager *AFX_CDECL | GetInstanceAddRef ()
Obtains a pointer to a global paint manager object and increments its reference counter.
static void AFX_CDECL | ReleaseInstance ()
Decrements global paint manager's reference counter and deletes its instance when the reference counter reaches 0.
static CXTPPaintManager *AFX_CDECL | CreateTheme (XTPPaintTheme paintTheme)
Creates a new CXTPPaintManager object.
static void AFX_CDECL | SetTheme (XTPPaintTheme paintTheme)
Call this member to switch the visual theme of the Command Bars.
static void AFX_CDECL | SetCustomTheme (CXTPPaintManager *pTheme)
Call this member to set a custom theme.
static void AFX_CDECL | Triangle (CDC *pDC, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clr)
Draws a triangle.
static BOOL AFX_CDECL | FontExists (LPCTSTR lpszFaceName)
Determines if a specified font exists in the system.
static void AFX_CDECL | StripMnemonics (CString &strClear)
This member function will search a string, strip off the mnemonic '&', and reformat the string.
static CXTPPaintManager *AFX_CDECL | GetGlobalPaintManager ()
Call this method to get the pointer to the global paint manager.
static void AFX_CDECL | SetGlobalPaintManager (CXTPPaintManager *pPaintManager)
Call this method to set the pointer to the global paint manager.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPPaintManager
COLORREF | m_clrMessageBarText
Message bar text color.
CRect | m_rcMessageBarMargin
Margin of the message bar.
CXTPFramePaintManager * | m_pFramePaintManager
Frame paint manager.
CXTPStatusBarPaintManager * | m_pStatusBarPaintManager
Paint manager of the status bar.
CXTPRibbonPaintManager * | m_pRibbonPaintManager
Ribbon paint Manager.
CXTPControlGalleryPaintManager * | m_pGalleryPaintManager
Gallery paint manager.
CXTPProgressPaintManager * | m_pProgressPaintManager
Progress bar paint manager.
CXTPSliderPaintManager * | m_pSliderPaintManager
Slider pane paint manager.
CXTPScrollBarPaintManager * | m_pScrollBarPaintManager
Scrollbar paint manager.
CXTPPaintManagerColorGradient | m_clrDisabledIcon
Disabled icons color.
CXTPPaintManagerColor | m_clrFloatingGripper
Gripper color of floating toolbar.
CXTPPaintManagerColor | m_clrFloatingGripperText
Gripper text color of floating toolbar.
BOOL | m_bThickCheckMark
TRUE to draw thick check mark.
BOOL | m_bShowShadow
TRUE to show shadow.
BOOL | m_bThemedStatusBar
TRUE to draw status bar using WinXP theme.
BOOL | m_bThemedCheckBox
TRUE to draw check box using WinXP theme.
BOOL | m_bClearTypeTextQuality
TRUE to enable ClearType text for the font.
BOOL | m_bFlatToolBar
TRUE to draw toolbars flat.
BOOL | m_bFlatMenuBar
TRUE to draw menubar flat.
int | m_nPopupBarTextPadding
Distance between gripper and control text.
BOOL | m_bSelectImageInPopupBar
TRUE to select image as in explorer theme.
BOOL | m_bEnableAnimation
TRUE to enable animation for all toolbars.
BOOL | m_bOffice2007Padding
TRUE if Office2007 metrics used.
BOOL | m_bOffsetPopupLabelText
TRUE if labels in pop-ups drawn with offset.
BOOL | m_bWrapCaptionBelowText
Wrap text for xtpButtonIconAndCaptionBelow buttons.
CXTPPaintManagerFont | m_fontSmCaption
Small caption font.
CXTPPaintManagerFont | m_fontIcon
Icon font.
CXTPPaintManagerFont | m_fontIconBold
Icon bold font.
CXTPPaintManagerFont | m_fontToolTip
Tooltip font.
int | m_nSplitButtonDropDownWidth
Split button drop down width in toolbars.
int | m_nSplitButtonDropDownHeight
Split button drop down height in toolbars.
int | m_nSplitButtonPopupWidth
Split button drop down width in pop-ups.
BOOL | m_bAutoResizeIcons
TRUE to automatically resize icons using current DPI.
int | m_nStatusBarMinHeight
Minimum height for the status bar.
PVOID | m_pfnSetLayeredWindowAttributes
point to Transparency proc in USER32.dll module.
CRect | m_rcStatusBarBorder
Bounding rectangle of the status bar border.
BOOL | m_bUseOfficeFont
TRUE to use Tahoma font.
CString | m_strOfficeFont
Office font.
int | m_nTextHeight
Regular text field height (not font height).
- Protected Attributes inherited from CXTPPaintManager
CXTPFont | m_xtpFontRegular
Regular font.
CXTPFont | m_xtpFontRegularBold
Regular bold font.
CXTPFont | m_xtpFontVert
Vertical font.
CXTPFont | m_xtpFontVertBold
Vertical font.
int | m_nEditHeight
Edit text height.
int | m_nFontHeight
Custom font height (optional).
BOOL | m_bUseStandardFont
TRUE to use system font.
BOOL | m_bEmbossedDisabledText
TRUE to draw disabled text embossed.
CXTPWinThemeWrapper * | m_themeStatusBar
StatusBar theme helper.
CXTPWinThemeWrapper * | m_themeButton
Buttons theme helper.
XTPPaintTheme | m_themeCurrent
Current theme.
XTP_COMMANDBARS_ICONSINFO | m_iconsInfo
Specific icons options.
int | m_nAnimationSteps
Steps of the animation.
int | m_nAnimationTime
Time of the animation.
BOOL | m_bShowKeyboardCues
TRUE to show keyboard cues - deprecated.
CXTPPaintManagerColor | m_arrColor [XPCOLOR_LAST+1]
Self colors array.
XTPCurrentSystemTheme | m_systemTheme
Current system theme.
CXTPShadowManager * | m_pShadowManager
Shadow manager.

Detailed Description

The CXTPCommandBarsOfficeXPTheme class is used to enable an Office XP style theme for Command Bars.

See also
CXTPPaintManager::SetTheme

Member Function Documentation

◆ AdjustExcludeRect()

virtual void AdjustExcludeRect | ( | CRect & | rc,
 |  | CXTPControl * | pControl,
 |  | BOOL | bVertical )
 virtual

This method is called to determine the offset of a pop-up bar.

Parameters
rc | Control's bounding rectangle.
pControl | Pointer to a CXTPControl object.
bVertical | TRUE if the control is docked vertically.

Implements CXTPPaintManager.

Reimplemented in CXTPRibbonTheme, CXTPVisualStudio2008Theme, and CXTPVisualStudio2010Theme.

◆ BaseTheme()

virtual XTPPaintTheme BaseTheme ( )
inlineprotectedvirtual

Retrieves the base theme of the manager.

Returns
Returns the base theme.

Implements CXTPPaintManager.

Reimplemented in CXTPCommandBarsOffice2003Theme, CXTPCommandBarsOffice2013Theme, CXTPCommandBarsVisualStudio2012Theme, CXTPResourceTheme, CXTPRibbonTheme, CXTPVisualStudio2005Theme, CXTPVisualStudio2008Theme, and CXTPVisualStudio2010Theme.

◆ DrawCommandBarGripper()

virtual CSize DrawCommandBarGripper | ( | CDC * | pDC,
 |  | CXTPCommandBar * | pBar,
 |  | BOOL | bDraw = TRUE )
 virtual

This method is called to draw the command bar's gripper.

Parameters
pDC | Pointer to a valid device context.
pBar | Pointer to a CXTPCommandBar object.
bDraw | TRUE to draw; FALSE to retrieve the size of the gripper.
Returns
Size of the gripper.

Reimplemented from CXTPPaintManager.

Reimplemented in CXTPCommandBarsNativeWindows10Theme, CXTPCommandBarsNativeWindows11Theme, CXTPCommandBarsOffice2003Theme, CXTPCommandBarsOffice2013Theme, CXTPCommandBarsVisualStudio2012Theme, CXTPCommandBarsVisualStudio2015Theme, CXTPCommandBarsVisualStudio2017Theme, CXTPCommandBarsVisualStudio2019Theme, CXTPCommandBarsVisualStudio2022Theme, and CXTPRibbonTheme.

◆ DrawCommandBarSeparator()

virtual CSize DrawCommandBarSeparator | ( | CDC * | pDC,
 |  | CXTPCommandBar * | pBar,
 |  | CXTPControl * | pControl,
 |  | BOOL | bDraw = TRUE )
 virtual

This method is called to draw a command bar's separator.

Parameters
pDC | Pointer to a valid device context.
pBar | Pointer to a CXTPCommandBar object.
pControl | Pointer to a CXTPControl object.
bDraw | TRUE to draw; FALSE to retrieve the size of the separator.
Returns
Size of the separator.

Implements CXTPPaintManager.

Reimplemented in CXTPCommandBarsOffice2003Theme, CXTPCommandBarsOffice2013Theme, CXTPCommandBarsVisualStudio2012Theme, CXTPRibbonTheme, CXTPVisualStudio2008Theme, and CXTPVisualStudio2010Theme.

◆ DrawControlCheckBoxMark() [1/2]

virtual CSize DrawControlCheckBoxMark | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | BOOL | bDraw,
 |  | BOOL | bSelected,
 |  | BOOL | bPressed,
 |  | BOOL | bChecked,
 |  | BOOL | bEnabled )
 protectedvirtual

This method is called to draw a check box mark area.

Parameters
pDC | Pointer to a valid device context.
rc | Bounding rectangle.
bDraw | TRUE to draw; FALSE to find size.
bSelected | TRUE if control is selected.
bPressed | TRUE if control is pressed.
bChecked | TRUE if control is checked.
bEnabled | TRUE if control is enabled.
Returns
Size of the check box mark.

Reimplemented from CXTPPaintManager.

Reimplemented in CXTPCommandBarsOffice2013Theme, and CXTPCommandBarsVisualStudio2012Theme.

◆ DrawControlCheckBoxMark() [2/2]

virtual CSize DrawControlCheckBoxMark | ( | CDC * | pDC,
 |  | CXTPControl * | pButton,
 |  | CRect | rc,
 |  | BOOL | bDraw )
 protectedvirtual

This method is called to draw a check box mark area.

Parameters
pDC | Pointer to a valid device context.
pButton | Pointer to the checkbox control.
rc | Bounding rectangle of the check box itself (not control).
bDraw | TRUE to draw; FALSE to find size.
Returns
Size of the check box mark

Reimplemented from CXTPPaintManager.

Reimplemented in CXTPCommandBarsOffice2013Theme.

◆ DrawControlComboBox()

virtual CSize DrawControlComboBox | ( | CDC * | pDC,
 |  | CXTPControlComboBox * | pComboBox,
 |  | BOOL | bDraw )
 protectedvirtual

This method is called to draw the control.

Parameters
pDC | Pointer to a valid device context.
bDraw | TRUE to draw; FALSE to retrieve the size of the control.
pComboBox | Pointer to a CXTPControlComboBox object to draw.
Returns
Size of the control.

Reimplemented from CXTPPaintManager.

Reimplemented in CXTPCommandBarsNativeWindows10Theme, CXTPCommandBarsNativeWindows11Theme, CXTPCommandBarsOffice2013Theme, CXTPCommandBarsVisualStudio2012Theme, CXTPCommandBarsVisualStudio2015Theme, CXTPCommandBarsVisualStudio2017Theme, CXTPCommandBarsVisualStudio2019Theme, CXTPCommandBarsVisualStudio2022Theme, and CXTPRibbonTheme.

◆ DrawControlEdit()

virtual CSize DrawControlEdit | ( | CDC * | pDC,
 |  | CXTPControlEdit * | pEdit,
 |  | BOOL | bDraw )
 protectedvirtual

This method is called to draw the control.

Parameters
pDC | Pointer to a valid device context.
bDraw | TRUE to draw; FALSE to retrieve the size of the control.
pEdit | Edit control to draw.
Returns
Size of the control.

Reimplemented from CXTPPaintManager.

Reimplemented in CXTPCommandBarsOffice2013Theme, and CXTPRibbonTheme.

◆ DrawControlPopupParent()

virtual CSize DrawControlPopupParent | ( | CDC * | pDC,
 |  | CXTPControl * | pButton,
 |  | BOOL | bDraw )
 protectedvirtual

This method is called to draw the control placed on the pop-up bar.

Parameters
pDC | Pointer to a valid device context.
pButton | Pointer to a CXTPControl object.
bDraw | TRUE to draw; FALSE to retrieve the size of the control.
Returns
Size of the control.

Reimplemented from CXTPPaintManager.

◆ DrawControlRadioButtonMark()

virtual CSize DrawControlRadioButtonMark | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | BOOL | bDraw,
 |  | BOOL | bSelected,
 |  | BOOL | bPressed,
 |  | BOOL | bChecked,
 |  | BOOL | bEnabled )
 protectedvirtual

This method is called to draw a radio button mark area.

Parameters
pDC | Pointer to a valid device context.
rc | Bounding rectangle.
bDraw | TRUE to draw; FALSE to find size.
bSelected | TRUE if control is selected.
bPressed | TRUE if control is pressed.
bChecked | TRUE if control is checked.
bEnabled | TRUE if control is enabled.
Returns
Size of the radio button mark.

Reimplemented from CXTPPaintManager.

Reimplemented in CXTPCommandBarsOffice2013Theme.

◆ DrawDialogBarGripper()

virtual CSize DrawDialogBarGripper | ( | CDC * | pDC,
 |  | CXTPDialogBar * | pBar,
 |  | BOOL | bDraw )
 virtual

Call this member to draw the gripper of a dialog bar.

Parameters
pDC | Pointer to a valid device context.
pBar | Dialog Bar pointer.
bDraw | TRUE to draw gripper, FALSE to calculate size.
Returns
Size of gripper to be drawn.

Implements CXTPPaintManager.

Reimplemented in CXTPCommandBarsOffice2003Theme.

◆ DrawImage()

virtual void DrawImage | ( | CDC * | pDC,
 |  | CPoint | pt,
 |  | CSize | sz,
 |  | CXTPImageManagerIcon * | pImage,
 |  | BOOL | bSelected,
 |  | BOOL | bPressed,
 |  | BOOL | bEnabled = TRUE,
 |  | BOOL | bChecked = FALSE,
 |  | BOOL | bPopuped = FALSE,
 |  | BOOL | bToolBarImage = TRUE )
 protectedvirtual

This method is called to draw the image of the control.

Parameters
pDC | Pointer to a valid device context.
pt | Position to draw.
sz | Size of the image.
pImage | Pointer to a CXTPImageManagerIcon object.
bSelected | TRUE if the control is selected.
bPressed | TRUE if the control is pushed.
bEnabled | TRUE if the control is enabled.
bChecked | TRUE if the control is checked.
bPopuped | TRUE if the control is pop-up'ed.
bToolBarImage | TRUE if it is a toolbar image.

Implements CXTPPaintManager.

◆ DrawListBoxControl()

virtual CSize DrawListBoxControl | ( | CDC * | pDC,
 |  | CXTPControl * | pButton,
 |  | CRect | rc,
 |  | BOOL | bSelected,
 |  | BOOL | bDraw,
 |  | CXTPCommandBars * | pCommandBars = 0 )
 virtual

This method is called to draw the control placed on the ListBox.

Parameters
pDC | Pointer to a valid device context.
pButton | Pointer to a CXTPControl object.
rc | Bounding rectangle to draw.
bSelected | TRUE if the control is selected.
bDraw | TRUE to draw; FALSE to retrieve the size of the control.
pCommandBars | CommandBars object which metrics need to use.
Returns
Size of the control.

Implements CXTPPaintManager.

◆ DrawPopupBarGripper()

virtual void DrawPopupBarGripper | ( | CDC * | pDC,
 |  | int | xPos,
 |  | int | yPos,
 |  | int | cx,
 |  | int | cy,
 |  | BOOL | bExpanded = FALSE )
 protectedvirtual

This method is called to draw a pop-up bar's right gripper.

Parameters
pDC | Pointer to a valid device context.
xPos | Specifies the logical x coordinate of the upper-left corner of the rectangle.
yPos | Specifies the logical y coordinate of the upper-left corner of the destination rectangle.
cx | Specifies the width of the rectangle.
cy | Specifies the height of the rectangle.
bExpanded | TRUE if expanded.

Reimplemented from CXTPPaintManager.

Reimplemented in CXTPCommandBarsOffice2003Theme, CXTPCommandBarsOffice2013Theme, CXTPCommandBarsVisualStudio2012Theme, CXTPRibbonTheme, CXTPVisualStudio2008Theme, and CXTPVisualStudio2010Theme.

◆ DrawPopupResizeGripper()

virtual void DrawPopupResizeGripper | ( | CDC * | pDC,
 |  | CRect | rcGripper,
 |  | int | nFlags )
 virtual

This method is called to draw a resize gripper of a pop-up bar.

Parameters
pDC | Pointer to a valid device context
rcGripper | Bounding rectangle of the gripper.
nFlags | Position of the resize gripper.

Implements CXTPPaintManager.

Reimplemented in CXTPRibbonTheme.

◆ DrawRectangle() [1/3]

virtual void DrawRectangle | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | BOOL | bSelected,
 |  | BOOL | bPressed,
 |  | BOOL | bEnabled,
 |  | BOOL | bChecked,
 |  | BOOL | bPopuped,
 |  | XTPBarType | barType,
 |  | XTPBarPosition | barPosition )
 protectedvirtual

This method is called to fill the control's face.

Parameters
pDC | Pointer to a valid device context.
rc | Rectangle to draw.
bSelected | TRUE if the control is selected.
bPressed | TRUE if the control is pushed.
bEnabled | TRUE if the control is enabled.
bChecked | TRUE if the control is checked.
bPopuped | TRUE if the control is pop-up'ed.
barType | Parent's bar type.
barPosition | Parent's bar position.

Implements CXTPPaintManager.

Reimplemented in CXTPCommandBarsNativeWindows10Theme, CXTPCommandBarsNativeWindows11Theme, CXTPCommandBarsOffice2003Theme, CXTPCommandBarsOffice2013Theme, CXTPCommandBarsVisualStudio2012Theme, CXTPCommandBarsVisualStudio2015Theme, CXTPCommandBarsVisualStudio2017Theme, CXTPCommandBarsVisualStudio2019Theme, CXTPCommandBarsVisualStudio2022Theme, CXTPRibbonTheme, CXTPVisualStudio2008Theme, and CXTPVisualStudio2010Theme.

◆ DrawRectangle() [2/3]

virtual void DrawRectangle | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | BOOL | bSelected,
 |  | BOOL | bPressed,
 |  | BOOL | bEnabled,
 |  | BOOL | bChecked,
 |  | BOOL | bPopuped,
 |  | XTPBarType | barType,
 |  | XTPBarPosition | barPosition,
 |  | int | nID )
 protectedvirtual

This method is called to fill the control's face.

Parameters
pDC | Pointer to a valid device context.
rc | Rectangle to draw.
bSelected | TRUE if the control is selected.
bPressed | TRUE if the control is pushed.
bEnabled | TRUE if the control is enabled.
bChecked | TRUE if the control is checked.
bPopuped | TRUE if the control is pop-up'ed.
barType | Parent's bar type.
barPosition | Parent's bar position.
nID | Bar's control ID.

Reimplemented in CXTPCommandBarsNativeWindows10Theme, CXTPCommandBarsNativeWindows11Theme, CXTPCommandBarsOffice2003Theme, CXTPCommandBarsOffice2013Theme, CXTPCommandBarsVisualStudio2012Theme, CXTPCommandBarsVisualStudio2015Theme, CXTPCommandBarsVisualStudio2017Theme, CXTPCommandBarsVisualStudio2019Theme, CXTPCommandBarsVisualStudio2022Theme, CXTPRibbonTheme, CXTPVisualStudio2008Theme, and CXTPVisualStudio2010Theme.

◆ DrawRectangle() [3/3]

virtual BOOL DrawRectangle | ( | CDC * | pDC,
 |  | CXTPControl * | pButton )
 protectedvirtual

This method is called to fill the control's face.

Parameters
pDC | Pointer to a valid device context.
pButton | Pointer to the button.
Returns
TRUE if the rectangle was drawn, otherwise returns FALSE.

Reimplemented from CXTPPaintManager.

Reimplemented in CXTPCommandBarsNativeWindows10Theme, CXTPCommandBarsNativeWindows11Theme, CXTPCommandBarsOffice2003Theme, CXTPCommandBarsOffice2013Theme, CXTPCommandBarsVisualStudio2012Theme, CXTPCommandBarsVisualStudio2015Theme, CXTPCommandBarsVisualStudio2017Theme, CXTPCommandBarsVisualStudio2019Theme, CXTPCommandBarsVisualStudio2022Theme, CXTPRibbonTheme, CXTPVisualStudio2008Theme, and CXTPVisualStudio2010Theme.

◆ DrawSplitButtonFrame()

virtual void DrawSplitButtonFrame | ( | CDC * | pDC,
 |  | CXTPControl * | pButton,
 |  | CRect | rc )
 protectedvirtual

This method is called to draw the frame for the SplitButton control.

Parameters
pDC | Pointer to a valid device context.
pButton | Pointer to a CXTPControl object.
rc | Bounding rectangle to draw.

Implements CXTPPaintManager.

Reimplemented in CXTPCommandBarsNativeWindows10Theme, CXTPCommandBarsNativeWindows11Theme, CXTPCommandBarsOffice2013Theme, CXTPCommandBarsVisualStudio2012Theme, CXTPCommandBarsVisualStudio2015Theme, CXTPCommandBarsVisualStudio2017Theme, CXTPCommandBarsVisualStudio2019Theme, CXTPCommandBarsVisualStudio2022Theme, and CXTPRibbonTheme.

◆ DrawTearOffGripper()

virtual CSize DrawTearOffGripper | ( | CDC * | pDC,
 |  | CRect | rcGripper,
 |  | BOOL | bSelected,
 |  | BOOL | bDraw )
 virtual

This method is called to draw a tear-off gripper of a pop-up bar.

Parameters
pDC | Pointer to a valid device context.
rcGripper | Bounding rectangle of the gripper.
bSelected | TRUE if the gripper is selected.
bDraw | TRUE to draw; FALSE to retrieve the size of the gripper.
Returns
Size of the gripper.

Implements CXTPPaintManager.

Reimplemented in CXTPCommandBarsOffice2003Theme.

◆ FillCommandBarEntry()

virtual void FillCommandBarEntry | ( | CDC * | pDC,
 |  | CXTPCommandBar * | pBar )
 virtual

This method is called to fill the command bar's face.

Parameters
pDC | Pointer to a valid device context.
pBar | Pointer to a CXTPCommandBar object to draw.

Implements CXTPPaintManager.

Reimplemented in CXTPCommandBarsNativeWindows11Theme, CXTPCommandBarsOffice2003Theme, CXTPCommandBarsOffice2013Theme, CXTPCommandBarsVisualStudio2012Theme, CXTPRibbonTheme, and CXTPVisualStudio2010Theme.

◆ FillIntersectRect()

void FillIntersectRect | ( | CDC * | pDC,
 |  | CXTPPopupBar * | pPopupBar,
 |  | COLORREF | clr )
 protected

Draws intersect rectangle of a pop-up bar and its control.

Parameters
pDC | Pointer to a valid device context.
pPopupBar | Pop-up bar pointer.
clr | COLORREF specifies RGB color value.

◆ GetRectangleTextColor()

virtual COLORREF GetRectangleTextColor | ( | BOOL | bSelected,
 |  | BOOL | bPressed,
 |  | BOOL | bEnabled,
 |  | BOOL | bChecked,
 |  | BOOL | bPopuped,
 |  | XTPBarType | barType,
 |  | XTPBarPosition | barPosition )
 virtual

This method retrieves a buttons text color.

Parameters
bSelected | TRUE if the control is selected.
bPressed | TRUE if the control is pushed.
bEnabled | TRUE if the control is enabled.
bChecked | TRUE if the control is checked.
bPopuped | TRUE if the control is pop-up'ed.
barType | Parent's bar type.
barPosition | Parent's bar position.
Returns
Returns buttons text color

Implements CXTPPaintManager.

Reimplemented in CXTPCommandBarsOffice2013Theme, CXTPResourceTheme, CXTPRibbonTheme, CXTPVisualStudio2008Theme, and CXTPVisualStudio2010Theme.

The documentation for this class was generated from the following file:
  • XTPCommandBarsOfficeXPTheme.h


Toolkit Pro: CXTPCommandBarsOptions Class Reference

Public Member Functions | Public Attributes | Protected Attributes | List of all members
CXTPCommandBarsOptions Class Reference

Options of the command bars. More...

Inheritance diagram for CXTPCommandBarsOptions:
[legend]

Public Member Functions

CXTPCommandBarsOptions ()
Constructs an CXTPCommandBarsOptions object.
void | Serialize (CArchive &ar)
Either reads options from or writes options to an archive.
void | DoPropExchange (CXTPPropExchange *pPX, BOOL bUserOptionsOnly=FALSE)
Either reads options from or writes options to an archive.
void | ShowKeyboardCues (XTPKeyboardCuesShow keyboardCues)
Call this method to enable/disable menu underlines.
XTPKeyboardCuesShow | GetShowKeyboardCues () const
Call this method to get menu underlines state.
BOOL | IsDpiBitmapScalingEnabled () const
Gets DPI bitmap scaling flag.
void | EnableDpiBitmapScaling (BOOL bEnable=TRUE)
Sets DPI bitmap scaling flag.
BOOL | IsDpiGalleryItemScalingEnabled () const
Gets DPI gallery item scaling flag.
void | EnableDpiGalleryItemScaling (BOOL bEnable=TRUE)
Sets DPI gallery item scaling flag.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Public Attributes

BOOL | bAlwaysShowFullMenus
TRUE to show full menus always.
BOOL | bShowFullAfterDelay
TRUE to show full menus after short delay.
BOOL | bToolBarScreenTips
TRUE to show toolbar's tooltips.
BOOL | bToolBarAccelTips
TRUE to add accelerators to tooltips.
BOOL | bLargeIcons
TRUE to use large toolbars icons.
BOOL | bSyncFloatingBars
TRUE to hide floating bars when site frame deactivated.
BOOL | bShowExpandButtonAlways
TRUE to show expand buttons always.
BOOL | bDblClickFloat
TRUE to make toolbar floating be double-clicking.
BOOL | bShowTextBelowIcons
TRUE to show captions below icons.
BOOL | bAltDragCustomization
Allows users to change a toolbar button's position by dragging it while holding down ALT.
BOOL | bDirtyState
TRUE if the user has done any type of customization to menus or toolbars.
BOOL | bShowPopupBarToolTips
TRUE to display ToolTips for controls in pop-up menus.
BOOL | bShowContextMenuAccelerators
TRUE to show accelerators in context menus.
XTPAnimationType | animationType
Animation type.
BOOL | bAutoUpdateShortcuts
TRUE to update shortcuts from accelerator table.
DWORD | keyboardCuesUse
Keyboard cues used.
BOOL | bFlyByStatus
Status bar displays information about the button.
CSize | szIcons
Size of the normal icons.
CSize | szLargeIcons
Size of the large icons.
CSize | szPopupIcons
Size of icons displayed in pop-up menus.
BOOL | bUseAltNumPadKeys
TRUE to allow activate menu with Alt + num pad key.
BOOL | bUseSystemSaveBitsStyle
TRUE to use CS_SAVEBITS class style for pop-ups and shadows.
BOOL | bDisableCommandIfNoHandler
TRUE to disable commands if no handler is presented.
BOOL | bWrapLargePopups
Wrap controls for large pop-ups instead scroll them.
CMap< UINT, UINT, BOOL, BOOL > | m_mapHiddenCommands
Hidden command array.
CMap< UINT, UINT, BOOL, BOOL > | m_mapUsedCommands
Used commands array.
BOOL | bShowKeyboardTips
TRUE to use keyboard tips.
BOOL | bShowMiniToolbarTips
TRUE to show tips for controls in a mini toolbar, default is FALSE.
BOOL | bShowPopupButtonsSelectedToolbarOnly
TRUE to show only popup with current icons only.

Protected Attributes

BOOL | m_bAutoScaleDpiGalleryItems
TRUE by default.
BOOL | m_bAutoScaleDpiToolbarIcons
FALSE by default.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

Options of the command bars.

See also
CXTPCommandBars::GetCommandBarsOptions

Example:

pCommandBars->GetCommandBarsOptions()->animationType = xtpAnimateFade;

Member Function Documentation

◆ DoPropExchange()

void DoPropExchange | ( | CXTPPropExchange * | pPX,
 |  | BOOL | bUserOptionsOnly = FALSE )

Either reads options from or writes options to an archive.

Parameters
pPX | A CXTPPropExchange object to serialize to or from.
bUserOptionsOnly | TRUE to serialize user's options only.

◆ EnableDpiBitmapScaling()

void EnableDpiBitmapScaling ( BOOL bEnable = TRUE )

Sets DPI bitmap scaling flag.

If enabled, all raster icons and bitmaps used in the control will be stretched automatically if DPI scaling factor for control's window isn't equal to 100%. The default value is derived from CXTPDpi::IsDpiBitmapScalingEnabled. Once changed the new value will be used.

Parameters
bEnable TRUE to enable bitmaps scaling, FALSE to disable.

◆ EnableDpiGalleryItemScaling()

void EnableDpiGalleryItemScaling ( BOOL bEnable = TRUE )

Sets DPI gallery item scaling flag.

If enabled, the gallery items will be scaled automaticaly according to the current DPI scaling.

Parameters
bEnable TRUE to enable gallery item scaling, FALSE to disable.

◆ GetShowKeyboardCues()

XTPKeyboardCuesShow GetShowKeyboardCues ( ) const

Call this method to get menu underlines state.

Returns
Returns one of the following: xtpKeyboardCuesShowAlways - Show keyboard cues always. xtpKeyboardCuesShowNever - Show keyboard cues always. xtpKeyboardCuesShowWindowsDefault - System defined.

◆ IsDpiBitmapScalingEnabled()

BOOL IsDpiBitmapScalingEnabled ( ) const

Gets DPI bitmap scaling flag.

If enabled, all raster icons and bitmaps used in the control will be stretched automatically if DPI scaling factor for control's window isn't equal to 100%. The default value is derived from CXTPDpi::IsDpiBitmapScalingEnabled. Once changed the new value will be used.

Returns
The current value of the DPI bitmap scaling flag for the control.

◆ IsDpiGalleryItemScalingEnabled()

BOOL IsDpiGalleryItemScalingEnabled ( ) const

Gets DPI gallery item scaling flag.

If enabled, the gallery items will be scaled automaticaly according to the current DPI scaling.

Returns
The current value of the DPI gallery item scaling.

◆ Serialize()

void Serialize ( CArchive & ar )

Either reads options from or writes options to an archive.

Parameters
ar A CArchive object to serialize to or from.

◆ ShowKeyboardCues()

void ShowKeyboardCues ( XTPKeyboardCuesShow keyboardCues )

Call this method to enable/disable menu underlines.

Parameters
keyboardCues Determines if menu underlines are enabled.

keyboardCues parameter can be one of the following: xtpKeyboardCuesShowAlways Show keyboard cues always. xtpKeyboardCuesShowNever Show keyboard cues always. xtpKeyboardCuesShowWindowsDefault System defined.

Member Data Documentation

◆ bDirtyState

BOOL bDirtyState

TRUE if the user has done any type of customization to menus or toolbars.

(I.e. Moving a toolbar or adding a new button). After a load or save of the BarStae this is set to FALSE.

◆ m_bAutoScaleDpiGalleryItems

BOOL m_bAutoScaleDpiGalleryItems
protected

TRUE by default.

Enables scaling of ribbon gallery items (both inline and displayed in pop-up).

◆ m_bAutoScaleDpiToolbarIcons

BOOL m_bAutoScaleDpiToolbarIcons
protected

FALSE by default.

Enables scaling of toolbar (on ribbon as well) buttons icons.

The documentation for this class was generated from the following file:
  • XTPCommandBarsOptions.h


Toolkit Pro: CXTPCommandBarsSiteBase< TBase > Class Template Reference

Public Member Functions | List of all members
CXTPCommandBarsSiteBase< TBase > Class Template Reference

CXTPCommandBarsSiteBase is a standalone class. More...

Inheritance diagram for CXTPCommandBarsSiteBase< TBase >:
[legend]

Public Member Functions

CXTPCommandBarsSiteBase ()
Constructs a CXTPCommandBarsSiteBase object.
~CXTPCommandBarsSiteBase ()
Destroys a CXTPCommandBarsSiteBase object, handles cleanup and deallocation.
virtual BOOL | InitCommandBars (CRuntimeClass *pCommandBarsClass=RUNTIME_CLASS(CXTPCommandBars))
Creates command bars.
void | DockRightOf (CXTPToolBar *pBarToDock, CXTPToolBar *pBarOnLeft)
This member function will re-dock a toolbar specified by 'pBarToDock' to the right of a newly docked toolbar specified by 'pBarOnLeft'.
virtual void | SaveCommandBars (LPCTSTR lpszProfileName)
Call this function to save the state information to the registry or .INI file.
virtual void | LoadCommandBars (LPCTSTR lpszProfileName, BOOL bSilent=FALSE)
Call this function to retrieve state information from the registry or .INI file.
CXTPCommandBars * | GetCommandBars () const
Call this member to retrieve a pointer to the CommandBars object.

Detailed Description

template<class TBase>
class CXTPCommandBarsSiteBase< TBase >

CXTPCommandBarsSiteBase is a standalone class.

It represents a site for a Command Bars object.

Member Function Documentation

◆ DockRightOf()

template<class TBase >
void DockRightOf | ( | CXTPToolBar * | pBarToDock,
 |  | CXTPToolBar * | pBarOnLeft )
 inline

This member function will re-dock a toolbar specified by 'pBarToDock' to the right of a newly docked toolbar specified by 'pBarOnLeft'.

Parameters
pBarToDock | A CXTPToolBar pointer to the toolbar to be docked.
pBarOnLeft | A CXTPToolBar pointer to the already docked toolbar.

◆ GetCommandBars()

template<class TBase >
CXTPCommandBars * GetCommandBars ( ) const
inline

Call this member to retrieve a pointer to the CommandBars object.

Returns
A pointer to the CommandBars object.

◆ InitCommandBars()

template<class TBase >
virtual BOOL InitCommandBars ( CRuntimeClass * pCommandBarsClass = RUNTIME_CLASS(CXTPCommandBars) )
inlinevirtual

Creates command bars.

Parameters
pCommandBarsClass Custom runtime class of CommandBars. It can be used if you want to override some methods of the CXTPCommandBars class.
Returns
Nonzero if successful, otherwise 0.

◆ LoadCommandBars()

template<class TBase >
virtual void LoadCommandBars | ( | LPCTSTR | lpszProfileName,
 |  | BOOL | bSilent = FALSE )
 inlinevirtual

Call this function to retrieve state information from the registry or .INI file.

Parameters
lpszProfileName | Pointer to a null-terminated string that specifies the name of a section in the initialization file or a key in the Windows registry where state information is stored.
bSilent | TRUE to disable user notifications when command bars are restored to their original state.

◆ SaveCommandBars()

template<class TBase >
virtual void SaveCommandBars ( LPCTSTR lpszProfileName )
inlinevirtual

Call this function to save the state information to the registry or .INI file.

Parameters
lpszProfileName Pointer to a null-terminated string that specifies the name of a section in the initialization file or a key in the Windows registry where state information is stored.
The documentation for this class was generated from the following file:
  • XTPFrameWnd.h


Toolkit Pro: CXTPCommandBarsVisualStudio2012Theme Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPCommandBarsVisualStudio2012Theme Class Reference

The CXTPCommandBarsVisualStudio2012Theme class is used to enable a Visual Studio 2012 theme for Command Bars. More...

Inheritance diagram for CXTPCommandBarsVisualStudio2012Theme:
[legend]

Public Member Functions

CXTPCommandBarsVisualStudio2012Theme (XTPPaintTheme paintTheme=xtpThemeVisualStudio2012Light)
Constructs a CXTPCommandBarsVisualStudio2012Theme object.
virtual | ~CXTPCommandBarsVisualStudio2012Theme ()
Destroys a CXTPCommandBarsVisualStudio2012Theme object, handles cleanup and deallocation.
virtual void | RefreshMetrics ()
This method is called to refresh the visual metrics of the manager.
virtual CSize | DrawCommandBarGripper (CDC *pDC, CXTPCommandBar *pBar, BOOL bDraw=TRUE)
This method is called to draw the command bar's gripper.
virtual COLORREF | GetControlEditBackColor (CXTPControl *pControl)
This method returns the edit control back color to draw.
virtual CSize | DrawControlComboBox (CDC *pDC, CXTPControlComboBox *pControlCombo, BOOL bDraw)
This method is called to draw the control.
virtual void | FillDockBar (CDC *pDC, CXTPDockBar *pBar)
This method is called to fill a dock bar.
virtual void | FillCommandBarEntry (CDC *pDC, CXTPCommandBar *pBar)
This method is called to fill the command bar's face.
virtual void | DrawRectangle (CDC *pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition)
This method is called to fill the control's face.
virtual void | DrawRectangle (CDC *pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition, int nID)
This method is called to fill the control's face.
virtual BOOL | DrawRectangle (CDC *pDC, CXTPControl *pButton)
This method is called to fill the control's face.
virtual void | DrawPopupBarGripper (CDC *pDC, int xPos, int yPos, int cx, int cy, BOOL bExpanded)
This method is called to draw a pop-up bar's right gripper.
virtual void | DrawExpandGlyph (CDC *pDC, CXTPControl *pButton, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clr)
Draw expand or hidden glyphs for a button.
virtual void | DrawExpandGlyph (CDC *pDC, CXTPControl *pButton, COLORREF clr, BOOL bVertical)
Draw expand or hidden glyphs for a button.
virtual void | DrawHiddenGlyph (CDC *pDC, CXTPControl *pButton, COLORREF clr, BOOL bVertical)
Draw expand or hidden glyphs for a button.
virtual void | DrawDropDownGlyph (CDC *pDC, CXTPControl *pControl, CPoint pt, BOOL bSelected, BOOL bPopuped, BOOL bEnabled, BOOL bVert)
This member function is called to draw a split button expand symbol.
virtual CSize | DrawCommandBarSeparator (CDC *pDC, CXTPCommandBar *pBar, CXTPControl *pControl, BOOL bDraw=TRUE)
This method is called to draw a command bar's separator.
virtual void | DrawSplitButtonFrame (CDC *pDC, CXTPControl *pButton, CRect rc)
This method is called to draw the frame for the SplitButton control.
virtual XTPPaintTheme | BaseTheme ()
Retrieves the base theme of the manager.
- Public Member Functions inherited from CXTPCommandBarsModernUITheme
CXTPCommandBarsModernUITheme ()
Constructs a CXTPCommandBarsModernUITheme object.
virtual | ~CXTPCommandBarsModernUITheme ()
Destroys a CXTPCommandBarsModernUITheme object, handles cleanup and deallocation.
virtual CXTPFramePaintManager * | GetFramePaintManager ()
Returns paint manager used to draw frames.
virtual CXTPRibbonPaintManager * | GetRibbonPaintManager ()
Retrieves the ribbon paint manager.
virtual CXTPMarkupContext * | GetMarkupContext ()
Retrieves a pointer to the markup context.
- Public Member Functions inherited from CXTPCommandBarsOfficeXPTheme
CXTPCommandBarsOfficeXPTheme ()
Constructs a CXTPCommandBarsOfficeXPTheme object.
virtual COLORREF | GetRectangleTextColor (BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition)
This method retrieves a buttons text color.
virtual CSize | DrawListBoxControl (CDC *pDC, CXTPControl *pButton, CRect rc, BOOL bSelected, BOOL bDraw, CXTPCommandBars *pCommandBars=0)
This method is called to draw the control placed on the ListBox.
virtual void | AdjustExcludeRect (CRect &rc, CXTPControl *pControl, BOOL bVertical)
This method is called to determine the offset of a pop-up bar.
virtual CSize | DrawTearOffGripper (CDC *pDC, CRect rcGripper, BOOL bSelected, BOOL bDraw)
This method is called to draw a tear-off gripper of a pop-up bar.
virtual void | DrawPopupResizeGripper (CDC *pDC, CRect rcGripper, int nFlags)
This method is called to draw a resize gripper of a pop-up bar.
virtual CSize | DrawDialogBarGripper (CDC *pDC, CXTPDialogBar *pBar, BOOL bDraw)
Call this member to draw the gripper of a dialog bar.
- Public Member Functions inherited from CXTPPaintManager
virtual void | SetImageHandle (HMODULE hResource, LPCTSTR lpszIniFileName)
Specifies the resource that contains the bitmaps to be loaded for the theme.
CSize | DrawControl (CDC *pDC, CXTPControl *pButton, BOOL bDraw=TRUE)
This method is called to draw the control.
virtual CSize | DrawControlToolBarParent (CDC *pDC, CXTPControl *pButton, BOOL bDraw)
This method is called to draw the control placed on the toolbar.
virtual void | DrawControlEntry (CDC *pDC, CXTPControl *pButton)
This method is called to fill the control's face.
virtual COLORREF | GetControlTextColor (CXTPControl *pButton)
Call this method to get the control text color to draw.
virtual COLORREF | GetControlBackColor (CXTPControl *pButton)
Call this method to get the control back color to draw.
virtual void | DrawGalleryItemBack (CDC *pDC, CRect rcItem, BOOL bEnabled, BOOL bSelected, BOOL bPressed, BOOL bChecked, XTPBarType barType)
This method is called to draw the background for a gallery menu item.
virtual void | DrawCommandBarGroupSeparator (CDC *pDC, CXTPCommandBar *pBar, CXTPControl *pLeftControl, CXTPControl *pRightControl, BOOL bDraw=TRUE)
This method is called to draw a command bar's group separator.
virtual void | FillWorkspace (CDC *pDC, CRect rc, CRect rcExclude)
This method is called to fill a workspace.
int | GetShadowOptions () const
Determines the kind of shadow to use.
virtual CSize | DrawSpecialControl (CDC *pDC, XTPSpecialControl controlType, CXTPControl *pButton, CXTPCommandBar *pBar, BOOL bDraw, LPVOID lpParam)
This method is called to draw the specified controls.
virtual CRect | GetCommandBarBorders (CXTPCommandBar *pBar)
This method is called to retrieve the command bar's borders.
virtual CRect | GetSplitButtonCommandRect (CXTPControl *pButton)
Determines split button command rectangle.
virtual void | SetCommandBarRegion (CXTPCommandBar *pCommandBar)
Call this method to set the bounding region of a pop-up bar.
XTPPaintTheme GetCurrentTheme ()
Call this member to get the current visual theme.
virtual CFont * | GetControlFont (CXTPControl *pControl)
Call this member to retrieve the font of the command bar control.
virtual CFont * | GetCommandBarFont (CXTPCommandBar *pCommandBar)
Call this member to retrieve the font of the command bar.
virtual XTPBarTextOrientation | GetControlTextOrientation (CXTPControl *pControl)
Call this member to determine how to draw text.
virtual void | UpdateFonts ()
Refreshes the fonts to use.
virtual void | UpdateColors ()
Refreshes the standard colors to use.
void | SetCommandBarsFontIndirect (LOGFONT *pLogFont, BOOL bUseStandardFont=FALSE)
Call this member to set command bar's font.
CFont * | GetRegularFont ()
Returns the general font.
CFont * | GetRegularBoldFont ()
Returns the general bold font.
CFont * | GetIconFont ()
Returns the icon font.
CFont * | GetSmCaptionFont ()
Call this method to retrieve the caption of a floating mini frame.
void | UseOfficeFont (bool bUseOfficeFont)
Call this method to use Tahoma font despite system metrics.
int | GetControlHeight () const
This method returns the common controls height.
virtual CSize | GetDefaultCommandBarSize (CXTPCommandBar *pBar)
Computes default command bar size taking into account command bar font.
void | Rectangle (CDC *pDC, LPCRECT rc, int nPen, const int nBrush)
Draws a rectangle.
void | Rectangle (CDC *pDC, LPCRECT rc, COLORREF clrPen, COLORREF clrBrush)
Draws a rectangle.
void | RoundRect (CDC *pDC, LPCRECT rc, COLORREF clrPen, COLORREF clrBrush)
Draws a rectangle.
void | Draw3dRect (CDC *pDC, LPCRECT rc, int nTopLeft, int nBottomRight)
Call this member function to draw a three-dimensional rectangle.
void | Draw3dRect (CDC *pDC, LPCRECT rc, int frameThickness, COLORREF clrPen, COLORREF clrBrush)
Call this member function to draw a rectangle with predetermined thickness.
virtual void | DrawPopupBarCheckMark (CDC *pDC, CRect rcCheck, BOOL bEnabled, COLORREF clr)
Call this member function to draw a check mark.
void | DrawCheckMark (CDC *pDC, CRect rcCheck, COLORREF clr=0)
Call this member function to draw a check mark.
virtual void | DrawPopupBarRadioMark (CDC *pDC, CRect rcCheck, BOOL bEnabled, COLORREF clr)
Call this member function to draw a radio button.
virtual void | DrawComboExpandMark (CDC *pDC, CRect rc, COLORREF clr)
Call this member function to draw a combobox expand symbol.
virtual void | DrawControlMDIButton (CDC *pDC, CXTPControlButton *pButton)
Call this member function to draw menu MDI buttons.
void | Line (CDC *pDC, CPoint p0, CPoint p1)
Draws a line.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1, const int nPen)
Draws a line.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1, COLORREF clrPen)
Draws a line.
void | HorizontalLine (CDC *pDC, int x0, int y0, int x1, COLORREF clrPen)
Call this member function to draw a horizontal line using the specified coordinages and RGB color value.
void | VerticalLine (CDC *pDC, int x0, int y0, int y1, COLORREF clrPen)
Call this member function to draw a vertical line using the specified coordinages and RGB color value.
void | Pixel (CDC *pDC, int xPos, int yPos, int nPen)
Sets the pixel at the point.
void | GradientFill (CDC *pDC, LPRECT lpRect, COLORREF crFrom, COLORREF crTo, BOOL bHorz, LPCRECT lpRectClip=NULL)
Gradient fills the rectangle.
XTP_COMMANDBARS_ICONSINFO * GetIconsInfo ()
virtual void | Animate (CDC *pDestDC, CDC *pSrcDC, CRect rc, XTPAnimationType animationType)
This method is called to animate the pop-up bar.
virtual void | AnimateExpanding (CXTPCommandBar *pCommandBar, CDC *pDestDC, CDC *pSrcDC, BOOL bExpandDown)
This method is called to animate the expanding process.
void | SetAnimationDelay (int nAnimationSteps, int nAnimationTime)
Call this method to set animation delay.
COLORREF | GetXtremeColor (UINT nIndex)
This function retrieves the current color of the specified XP display element.
void | SetColors (int cElements, CONST INT *lpaElements, CONST COLORREF *lpaRgbValues)
Call this member to set the colors for each element to the color in the specified color array.
CSize | DrawControlText (CDC *pDC, CXTPControl *pControl, CRect rcText, BOOL bDraw, BOOL bVert, BOOL bCentered, BOOL bTriangled)
This method is called to draw control text.
virtual void | UpdateRTLCaption (CString &strCaption)
This method is called to prepare a caption for Right-To-Left draw.
XTPCurrentSystemTheme GetCurrentSystemTheme ()
Call this member function to determine the current Windows XP theme in use.
void | SetLunaTheme (XTPCurrentSystemTheme systemTheme)
Call this method to force system theme.
virtual int | GetPopupBarGripperWidth (CXTPCommandBar *pBar)
Calculates the gripper of a pop-up bar.
virtual CXTPControlGalleryPaintManager * | GetGalleryPaintManager () const
Retrieves paint manager used to draw galleries.
virtual CXTPScrollBarPaintManager * | GetScrollBarPaintManager () const
Retrieves paint manager used to draw scrollbars.
virtual CXTPSliderPaintManager * | GetSliderPaintManager () const
Retrieves paint manager used to draw slider panes.
virtual CXTPProgressPaintManager * | GetProgressPaintManager () const
Retrieves paint manager used to draw progress bars.
virtual CXTPStatusBarPaintManager * | GetStatusBarPaintManager ()
Retrieves paint manager used to draw the status bar.
virtual CXTPMessageBarPaintManager * | GetMessageBarPaintManager ()
Retrieves paint manager used to draw message bars.
CXTPShadowManager * | GetShadowManager () const
Retrieves shadow manager used to draw shadows.
BOOL | IsUseSystemAccentColorEnabled () const
Determines whether xtpApplicationUseSystemAccentColor application ambient property is set.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.
- Public Member Functions inherited from CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents >
void | Subscribe (IXTPPaintManagerEvents *pObserver, CXTPSubscriptionList< CXTPPaintManager, IXTPPaintManagerEvents > *pSubcriptionList=NULL)
Subscribes a unique observer for events.
void | Unsubscribe (IXTPPaintManagerEvents *pObserver)
Unsubscribes an observer from events.
void | Notify (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *))
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *))
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.

Protected Member Functions

virtual CSize | DrawControlCheckBoxMark (CDC *pDC, CRect rc, BOOL bDraw, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled)
This method is called to draw a check box mark area.
virtual BOOL | RequiresResourceImages ()
Used by the paint manager to determine if the theme requires a resource DLL to load image and color information.
- Protected Member Functions inherited from CXTPCommandBarsModernUITheme
- Protected Member Functions inherited from CXTPCommandBarsOfficeXPTheme
virtual CSize | DrawControlPopupParent (CDC *pDC, CXTPControl *pButton, BOOL bDraw)
This method is called to draw the control placed on the pop-up bar.
virtual void | DrawImage (CDC *pDC, CPoint pt, CSize sz, CXTPImageManagerIcon *pImage, BOOL bSelected, BOOL bPressed, BOOL bEnabled=TRUE, BOOL bChecked=FALSE, BOOL bPopuped=FALSE, BOOL bToolBarImage=TRUE)
This method is called to draw the image of the control.
virtual CSize | DrawControlEdit (CDC *pDC, CXTPControlEdit *pEdit, BOOL bDraw)
This method is called to draw the control.
void | FillIntersectRect (CDC *pDC, CXTPPopupBar *pPopupBar, COLORREF clr)
Draws intersect rectangle of a pop-up bar and its control.
virtual CSize | DrawControlCheckBoxMark (CDC *pDC, CXTPControl *pButton, CRect rc, BOOL bDraw)
This method is called to draw a check box mark area.
virtual CSize | DrawControlRadioButtonMark (CDC *pDC, CRect rc, BOOL bDraw, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled)
This method is called to draw a radio button mark area.
- Protected Member Functions inherited from CXTPPaintManager
CXTPPaintManager ()
Constructs a CXTPPaintManager object.
virtual | ~CXTPPaintManager ()
Destroys a CXTPPaintManager object, handles cleanup and deallocation.
- Protected Member Functions inherited from CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents >
CXTPObservable ()
Constructs an observable object.
~CXTPObservable ()
Handles observable object destruction.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPPaintManager
static CXTPPaintManager *AFX_CDECL | GetInstanceAddRef ()
Obtains a pointer to a global paint manager object and increments its reference counter.
static void AFX_CDECL | ReleaseInstance ()
Decrements global paint manager's reference counter and deletes its instance when the reference counter reaches 0.
static CXTPPaintManager *AFX_CDECL | CreateTheme (XTPPaintTheme paintTheme)
Creates a new CXTPPaintManager object.
static void AFX_CDECL | SetTheme (XTPPaintTheme paintTheme)
Call this member to switch the visual theme of the Command Bars.
static void AFX_CDECL | SetCustomTheme (CXTPPaintManager *pTheme)
Call this member to set a custom theme.
static void AFX_CDECL | Triangle (CDC *pDC, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clr)
Draws a triangle.
static BOOL AFX_CDECL | FontExists (LPCTSTR lpszFaceName)
Determines if a specified font exists in the system.
static void AFX_CDECL | StripMnemonics (CString &strClear)
This member function will search a string, strip off the mnemonic '&', and reformat the string.
static CXTPPaintManager *AFX_CDECL | GetGlobalPaintManager ()
Call this method to get the pointer to the global paint manager.
static void AFX_CDECL | SetGlobalPaintManager (CXTPPaintManager *pPaintManager)
Call this method to set the pointer to the global paint manager.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPPaintManager
COLORREF | m_clrMessageBarText
Message bar text color.
CRect | m_rcMessageBarMargin
Margin of the message bar.
CXTPFramePaintManager * | m_pFramePaintManager
Frame paint manager.
CXTPStatusBarPaintManager * | m_pStatusBarPaintManager
Paint manager of the status bar.
CXTPRibbonPaintManager * | m_pRibbonPaintManager
Ribbon paint Manager.
CXTPControlGalleryPaintManager * | m_pGalleryPaintManager
Gallery paint manager.
CXTPProgressPaintManager * | m_pProgressPaintManager
Progress bar paint manager.
CXTPSliderPaintManager * | m_pSliderPaintManager
Slider pane paint manager.
CXTPScrollBarPaintManager * | m_pScrollBarPaintManager
Scrollbar paint manager.
CXTPPaintManagerColorGradient | m_clrDisabledIcon
Disabled icons color.
CXTPPaintManagerColor | m_clrFloatingGripper
Gripper color of floating toolbar.
CXTPPaintManagerColor | m_clrFloatingGripperText
Gripper text color of floating toolbar.
BOOL | m_bThickCheckMark
TRUE to draw thick check mark.
BOOL | m_bShowShadow
TRUE to show shadow.
BOOL | m_bThemedStatusBar
TRUE to draw status bar using WinXP theme.
BOOL | m_bThemedCheckBox
TRUE to draw check box using WinXP theme.
BOOL | m_bClearTypeTextQuality
TRUE to enable ClearType text for the font.
BOOL | m_bFlatToolBar
TRUE to draw toolbars flat.
BOOL | m_bFlatMenuBar
TRUE to draw menubar flat.
int | m_nPopupBarTextPadding
Distance between gripper and control text.
BOOL | m_bSelectImageInPopupBar
TRUE to select image as in explorer theme.
BOOL | m_bEnableAnimation
TRUE to enable animation for all toolbars.
BOOL | m_bOffice2007Padding
TRUE if Office2007 metrics used.
BOOL | m_bOffsetPopupLabelText
TRUE if labels in pop-ups drawn with offset.
BOOL | m_bWrapCaptionBelowText
Wrap text for xtpButtonIconAndCaptionBelow buttons.
CXTPPaintManagerFont | m_fontSmCaption
Small caption font.
CXTPPaintManagerFont | m_fontIcon
Icon font.
CXTPPaintManagerFont | m_fontIconBold
Icon bold font.
CXTPPaintManagerFont | m_fontToolTip
Tooltip font.
int | m_nSplitButtonDropDownWidth
Split button drop down width in toolbars.
int | m_nSplitButtonDropDownHeight
Split button drop down height in toolbars.
int | m_nSplitButtonPopupWidth
Split button drop down width in pop-ups.
BOOL | m_bAutoResizeIcons
TRUE to automatically resize icons using current DPI.
int | m_nStatusBarMinHeight
Minimum height for the status bar.
PVOID | m_pfnSetLayeredWindowAttributes
point to Transparency proc in USER32.dll module.
CRect | m_rcStatusBarBorder
Bounding rectangle of the status bar border.
BOOL | m_bUseOfficeFont
TRUE to use Tahoma font.
CString | m_strOfficeFont
Office font.
int | m_nTextHeight
Regular text field height (not font height).
- Protected Attributes inherited from CXTPCommandBarsModernUITheme
CXTPMarkupContext * | m_pMarkupContext
Points to a valid markup context object.
CXTPResourceImages * | m_pImages
Points to a valid resource images object.
- Protected Attributes inherited from CXTPPaintManager
CXTPFont | m_xtpFontRegular
Regular font.
CXTPFont | m_xtpFontRegularBold
Regular bold font.
CXTPFont | m_xtpFontVert
Vertical font.
CXTPFont | m_xtpFontVertBold
Vertical font.
int | m_nEditHeight
Edit text height.
int | m_nFontHeight
Custom font height (optional).
BOOL | m_bUseStandardFont
TRUE to use system font.
BOOL | m_bEmbossedDisabledText
TRUE to draw disabled text embossed.
CXTPWinThemeWrapper * | m_themeStatusBar
StatusBar theme helper.
CXTPWinThemeWrapper * | m_themeButton
Buttons theme helper.
XTPPaintTheme | m_themeCurrent
Current theme.
XTP_COMMANDBARS_ICONSINFO | m_iconsInfo
Specific icons options.
int | m_nAnimationSteps
Steps of the animation.
int | m_nAnimationTime
Time of the animation.
BOOL | m_bShowKeyboardCues
TRUE to show keyboard cues - deprecated.
CXTPPaintManagerColor | m_arrColor [XPCOLOR_LAST+1]
Self colors array.
XTPCurrentSystemTheme | m_systemTheme
Current system theme.
CXTPShadowManager * | m_pShadowManager
Shadow manager.

Detailed Description

The CXTPCommandBarsVisualStudio2012Theme class is used to enable a Visual Studio 2012 theme for Command Bars.

See also
CXTPPaintManager::SetTheme

Constructor & Destructor Documentation

◆ CXTPCommandBarsVisualStudio2012Theme()

CXTPCommandBarsVisualStudio2012Theme ( XTPPaintTheme paintTheme = xtpThemeVisualStudio2012Light )
explicit

Constructs a CXTPCommandBarsVisualStudio2012Theme object.

Parameters
paintTheme Theme to be set.

Member Function Documentation

◆ BaseTheme()

virtual XTPPaintTheme BaseTheme ( )
inlinevirtual

Retrieves the base theme of the manager.

Returns
The base theme of the manager.

Reimplemented from CXTPCommandBarsOfficeXPTheme.

◆ DrawCommandBarGripper()

virtual CSize DrawCommandBarGripper | ( | CDC * | pDC,
 |  | CXTPCommandBar * | pBar,
 |  | BOOL | bDraw = TRUE )
 virtual

This method is called to draw the command bar's gripper.

Parameters
pDC | Pointer to a valid device context.
pBar | Pointer to a CXTPCommandBar object.
bDraw | TRUE to draw; FALSE to retrieve the size of the gripper.
Returns
Size of the gripper.

Reimplemented from CXTPCommandBarsOfficeXPTheme.

◆ DrawCommandBarSeparator()

virtual CSize DrawCommandBarSeparator | ( | CDC * | pDC,
 |  | CXTPCommandBar * | pBar,
 |  | CXTPControl * | pControl,
 |  | BOOL | bDraw = TRUE )
 virtual

This method is called to draw a command bar's separator.

Parameters
pDC | Pointer to a valid device context.
pBar | Pointer to a CXTPCommandBar object.
pControl | Pointer to a CXTPControl object.
bDraw | TRUE to draw; FALSE to retrieve the size of the separator.
Returns
Size of the separator.

Reimplemented from CXTPCommandBarsOfficeXPTheme.

◆ DrawControlCheckBoxMark()

virtual CSize DrawControlCheckBoxMark | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | BOOL | bDraw,
 |  | BOOL | bSelected,
 |  | BOOL | bPressed,
 |  | BOOL | bChecked,
 |  | BOOL | bEnabled )
 protectedvirtual

This method is called to draw a check box mark area.

Parameters
pDC | Pointer to a valid device context.
rc | Bounding rectangle.
bDraw | TRUE to draw; FALSE to find size.
bSelected | TRUE if control is selected.
bPressed | TRUE if control is pressed.
bChecked | TRUE if control is checked.
bEnabled | TRUE if control is enabled.
Returns
Size of check box mark.

Reimplemented from CXTPCommandBarsOfficeXPTheme.

◆ DrawControlComboBox()

virtual CSize DrawControlComboBox | ( | CDC * | pDC,
 |  | CXTPControlComboBox * | pComboBox,
 |  | BOOL | bDraw )
 virtual

This method is called to draw the control.

Parameters
pDC | Pointer to a valid device context.
bDraw | TRUE to draw; FALSE to retrieve the size of the control.
pComboBox | Pointer to a CXTPControlComboBox object to draw.
Returns
Size of the control.

Reimplemented from CXTPCommandBarsOfficeXPTheme.

◆ DrawDropDownGlyph()

virtual void DrawDropDownGlyph | ( | CDC * | pDC,
 |  | CXTPControl * | pControl,
 |  | CPoint | pt,
 |  | BOOL | bSelected,
 |  | BOOL | bPopuped,
 |  | BOOL | bEnabled,
 |  | BOOL | bVert )
 virtual

This member function is called to draw a split button expand symbol.

Parameters
pDC | Pointer to a valid device context.
pControl | Pointer to a CXTPControl object.
pt | Position of expand symbol.
bSelected | TRUE if the control is selected.
bPopuped | TRUE if the control is pop-up'ed.
bEnabled | TRUE if the control is enabled.
bVert | TRUE if control is vertical.

Reimplemented from CXTPPaintManager.

◆ DrawExpandGlyph() [1/2]

virtual void DrawExpandGlyph | ( | CDC * | pDC,
 |  | CXTPControl * | pButton,
 |  | COLORREF | clr,
 |  | BOOL | bVertical )
 virtual

Draw expand or hidden glyphs for a button.

Parameters
pButton | Target button pointer.
pDC | Output device context pointer.
clr | Glyph color.
bVertical | TRUE if vertically positioned glyph is to be drawn.

Reimplemented from CXTPPaintManager.

◆ DrawExpandGlyph() [2/2]

virtual void DrawExpandGlyph | ( | CDC * | pDC,
 |  | CXTPControl * | pButton,
 |  | CPoint | pt0,
 |  | CPoint | pt1,
 |  | CPoint | pt2,
 |  | COLORREF | clr )
 virtual

Draw expand or hidden glyphs for a button.

Parameters
pDC | Output device context pointer.
pButton | Target button pointer.
pt0 | Expand glyph triangle coordinates.
pt1 | Expand glyph triangle coordinates.
pt2 | Expand glyph triangle coordinates.
clr | Glyph color.

Reimplemented from CXTPPaintManager.

◆ DrawHiddenGlyph()

virtual void DrawHiddenGlyph | ( | CDC * | pDC,
 |  | CXTPControl * | pButton,
 |  | COLORREF | clr,
 |  | BOOL | bVertical )
 virtual

Draw expand or hidden glyphs for a button.

Parameters
pDC | Output device context pointer.
pButton | Target button pointer.
clr | Glyph color.
bVertical | TRUE if vertically positioned glyph is to be drawn.

Reimplemented from CXTPPaintManager.

◆ DrawPopupBarGripper()

virtual void DrawPopupBarGripper | ( | CDC * | pDC,
 |  | int | xPos,
 |  | int | yPos,
 |  | int | cx,
 |  | int | cy,
 |  | BOOL | bExpanded )
 virtual

This method is called to draw a pop-up bar's right gripper.

Parameters
pDC | Pointer to a valid device context.
xPos | Specifies the logical x coordinate of the upper-left corner of the rectangle.
yPos | Specifies the logical y coordinate of the upper-left corner of the destination rectangle.
cx | Specifies the width of the rectangle.
cy | Specifies the height of the rectangle.
bExpanded | TRUE if expanded.

Reimplemented from CXTPCommandBarsOfficeXPTheme.

◆ DrawRectangle() [1/3]

virtual void DrawRectangle | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | BOOL | bSelected,
 |  | BOOL | bPressed,
 |  | BOOL | bEnabled,
 |  | BOOL | bChecked,
 |  | BOOL | bPopuped,
 |  | XTPBarType | barType,
 |  | XTPBarPosition | barPosition )
 virtual

This method is called to fill the control's face.

Parameters
pDC | Pointer to a valid device context.
rc | Rectangle to draw.
bSelected | TRUE if the control is selected.
bPressed | TRUE if the control is pushed.
bEnabled | TRUE if the control is enabled.
bChecked | TRUE if the control is checked.
bPopuped | TRUE if the control is pop-up'ed.
barType | Parent's bar type.
barPosition | Parent's bar position.

Reimplemented from CXTPCommandBarsOfficeXPTheme.

◆ DrawRectangle() [2/3]

virtual void DrawRectangle | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | BOOL | bSelected,
 |  | BOOL | bPressed,
 |  | BOOL | bEnabled,
 |  | BOOL | bChecked,
 |  | BOOL | bPopuped,
 |  | XTPBarType | barType,
 |  | XTPBarPosition | barPosition,
 |  | int | nID )
 virtual

This method is called to fill the control's face.

Parameters
pDC | Pointer to a valid device context.
rc | Rectangle to draw.
bSelected | TRUE if the control is selected.
bPressed | TRUE if the control is pushed.
bEnabled | TRUE if the control is enabled.
bChecked | TRUE if the control is checked.
bPopuped | TRUE if the control is pop-up'ed.
barType | Parent's bar type.
barPosition | Parent's bar position.
nID | Bar's control ID.

Reimplemented from CXTPCommandBarsOfficeXPTheme.

◆ DrawRectangle() [3/3]

virtual BOOL DrawRectangle | ( | CDC * | pDC,
 |  | CXTPControl * | pButton )
 virtual

This method is called to fill the control's face.

Parameters
pDC | Pointer to a valid device context.
pButton | pointer to a button
Returns
TRUE if the rectange was drawn, otherwise returns FALSE.

Reimplemented from CXTPCommandBarsOfficeXPTheme.

◆ DrawSplitButtonFrame()

virtual void DrawSplitButtonFrame | ( | CDC * | pDC,
 |  | CXTPControl * | pButton,
 |  | CRect | rc )
 virtual

This method is called to draw the frame for the SplitButton control.

Parameters
pDC | Pointer to a valid device context.
pButton | Pointer to a CXTPControl object.
rc | Bounding rectangle to draw.

Reimplemented from CXTPCommandBarsOfficeXPTheme.

◆ FillCommandBarEntry()

virtual void FillCommandBarEntry | ( | CDC * | pDC,
 |  | CXTPCommandBar * | pBar )
 virtual

This method is called to fill the command bar's face.

Parameters
pDC | Pointer to a valid device context.
pBar | Pointer to a CXTPCommandBar object to draw.

Reimplemented from CXTPCommandBarsOfficeXPTheme.

◆ FillDockBar()

virtual void FillDockBar | ( | CDC * | pDC,
 |  | CXTPDockBar * | pBar )
 virtual

This method is called to fill a dock bar.

Parameters
pDC | Pointer to a valid device context.
pBar | Pointer to a CXTPDockBar object.

Reimplemented from CXTPPaintManager.

◆ GetControlEditBackColor()

virtual COLORREF GetControlEditBackColor ( CXTPControl * pControl )
virtual

This method returns the edit control back color to draw.

Parameters
pControl Pointer to a CXTPControl object to get the back color from.
Returns
Edit control back color.

Reimplemented from CXTPPaintManager.

◆ RequiresResourceImages()

AFX_INLINE BOOL RequiresResourceImages ( )
protectedvirtual

Used by the paint manager to determine if the theme requires a resource DLL to load image and color information.

Returns
Returns TRUE if the theme requires a resource DLL, otherwise FALSE.

Reimplemented from CXTPPaintManager.

The documentation for this class was generated from the following file:
  • XTPCommandBarsVisualStudio2012Theme.h


Toolkit Pro: CXTPCommandBarsVisualStudio2015Theme Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPCommandBarsVisualStudio2015Theme Class Reference

The CXTPCommandBarsVisualStudio2015Theme class is used to enable a Visual Studio 2015 style theme for Command Bars. More...

Inheritance diagram for CXTPCommandBarsVisualStudio2015Theme:
[legend]

Public Member Functions

CXTPCommandBarsVisualStudio2015Theme ()
Constructs a CXTPCommandBarsVisualStudio2015Theme object.
virtual | ~CXTPCommandBarsVisualStudio2015Theme ()
Destroys a CXTPCommandBarsVisualStudio2015Theme object, handles cleanup and deallocation.
virtual void | SetStateColor (COLORREF clrState=COLORREF_NULL)
Call this member function to set the application state color for the frame border and status bar.
virtual COLORREF | GetStateColor () const
Call this member function to get the application state color for the frame border and status bar.
- Public Member Functions inherited from CXTPCommandBarsOffice2013Theme
CXTPCommandBarsOffice2013Theme ()
Constructs a CXTPCommandBarsOffice2013Theme object.
virtual | ~CXTPCommandBarsOffice2013Theme ()
Destroys a CXTPCommandBarsOffice2013Theme object, handles cleanup and deallocation.
virtual XTPPaintTheme | BaseTheme ()
Retrieves the base theme of the manager.
virtual void | FillCommandBarEntry (CDC *pDC, CXTPCommandBar *pBar)
This method is called to fill the command bar's face.
virtual void | FillDockBar (CDC *pDC, CXTPDockBar *pBar)
This method is called to fill a dock bar.
virtual void | DrawCommandBarGroupSeparator (CDC *pDC, CXTPCommandBar *pBar, CXTPControl *pLeftControl, CXTPControl *pRightControl, BOOL bDraw)
This method is called to draw a command bar's group separator.
virtual CSize | DrawControlEdit (CDC *pDC, CXTPControlEdit *pEdit, BOOL bDraw)
This method is called to draw the control.
virtual void | FillWorkspace (CDC *pDC, CRect rc, CRect rcExclude)
Draws workspace space.
virtual BOOL | RequiresResourceImages ()
Used by the paint manager to determine if the theme requires a resource DLL to load image and color information.
virtual COLORREF | GetControlEditBackColor (CXTPControl *pControl)
This method returns the edit control back color to draw.
- Public Member Functions inherited from CXTPCommandBarsModernUITheme
CXTPCommandBarsModernUITheme ()
Constructs a CXTPCommandBarsModernUITheme object.
virtual | ~CXTPCommandBarsModernUITheme ()
Destroys a CXTPCommandBarsModernUITheme object, handles cleanup and deallocation.
virtual CXTPFramePaintManager * | GetFramePaintManager ()
Returns paint manager used to draw frames.
virtual CXTPRibbonPaintManager * | GetRibbonPaintManager ()
Retrieves the ribbon paint manager.
virtual CXTPMarkupContext * | GetMarkupContext ()
Retrieves a pointer to the markup context.
- Public Member Functions inherited from CXTPCommandBarsOfficeXPTheme
CXTPCommandBarsOfficeXPTheme ()
Constructs a CXTPCommandBarsOfficeXPTheme object.
virtual CSize | DrawListBoxControl (CDC *pDC, CXTPControl *pButton, CRect rc, BOOL bSelected, BOOL bDraw, CXTPCommandBars *pCommandBars=0)
This method is called to draw the control placed on the ListBox.
virtual void | AdjustExcludeRect (CRect &rc, CXTPControl *pControl, BOOL bVertical)
This method is called to determine the offset of a pop-up bar.
virtual CSize | DrawTearOffGripper (CDC *pDC, CRect rcGripper, BOOL bSelected, BOOL bDraw)
This method is called to draw a tear-off gripper of a pop-up bar.
virtual void | DrawPopupResizeGripper (CDC *pDC, CRect rcGripper, int nFlags)
This method is called to draw a resize gripper of a pop-up bar.
virtual CSize | DrawDialogBarGripper (CDC *pDC, CXTPDialogBar *pBar, BOOL bDraw)
Call this member to draw the gripper of a dialog bar.
- Public Member Functions inherited from CXTPPaintManager
virtual void | SetImageHandle (HMODULE hResource, LPCTSTR lpszIniFileName)
Specifies the resource that contains the bitmaps to be loaded for the theme.
CSize | DrawControl (CDC *pDC, CXTPControl *pButton, BOOL bDraw=TRUE)
This method is called to draw the control.
virtual CSize | DrawControlToolBarParent (CDC *pDC, CXTPControl *pButton, BOOL bDraw)
This method is called to draw the control placed on the toolbar.
virtual void | DrawControlEntry (CDC *pDC, CXTPControl *pButton)
This method is called to fill the control's face.
int | GetShadowOptions () const
Determines the kind of shadow to use.
virtual CSize | DrawSpecialControl (CDC *pDC, XTPSpecialControl controlType, CXTPControl *pButton, CXTPCommandBar *pBar, BOOL bDraw, LPVOID lpParam)
This method is called to draw the specified controls.
virtual CRect | GetCommandBarBorders (CXTPCommandBar *pBar)
This method is called to retrieve the command bar's borders.
virtual CRect | GetSplitButtonCommandRect (CXTPControl *pButton)
Determines split button command rectangle.
virtual void | SetCommandBarRegion (CXTPCommandBar *pCommandBar)
Call this method to set the bounding region of a pop-up bar.
XTPPaintTheme GetCurrentTheme ()
Call this member to get the current visual theme.
virtual CFont * | GetControlFont (CXTPControl *pControl)
Call this member to retrieve the font of the command bar control.
virtual CFont * | GetCommandBarFont (CXTPCommandBar *pCommandBar)
Call this member to retrieve the font of the command bar.
virtual XTPBarTextOrientation | GetControlTextOrientation (CXTPControl *pControl)
Call this member to determine how to draw text.
virtual void | UpdateFonts ()
Refreshes the fonts to use.
virtual void | UpdateColors ()
Refreshes the standard colors to use.
void | SetCommandBarsFontIndirect (LOGFONT *pLogFont, BOOL bUseStandardFont=FALSE)
Call this member to set command bar's font.
CFont * | GetRegularFont ()
Returns the general font.
CFont * | GetRegularBoldFont ()
Returns the general bold font.
CFont * | GetIconFont ()
Returns the icon font.
CFont * | GetSmCaptionFont ()
Call this method to retrieve the caption of a floating mini frame.
void | UseOfficeFont (bool bUseOfficeFont)
Call this method to use Tahoma font despite system metrics.
int | GetControlHeight () const
This method returns the common controls height.
virtual CSize | GetDefaultCommandBarSize (CXTPCommandBar *pBar)
Computes default command bar size taking into account command bar font.
void | Rectangle (CDC *pDC, LPCRECT rc, int nPen, const int nBrush)
Draws a rectangle.
void | Rectangle (CDC *pDC, LPCRECT rc, COLORREF clrPen, COLORREF clrBrush)
Draws a rectangle.
void | RoundRect (CDC *pDC, LPCRECT rc, COLORREF clrPen, COLORREF clrBrush)
Draws a rectangle.
void | Draw3dRect (CDC *pDC, LPCRECT rc, int nTopLeft, int nBottomRight)
Call this member function to draw a three-dimensional rectangle.
void | Draw3dRect (CDC *pDC, LPCRECT rc, int frameThickness, COLORREF clrPen, COLORREF clrBrush)
Call this member function to draw a rectangle with predetermined thickness.
virtual void | DrawPopupBarCheckMark (CDC *pDC, CRect rcCheck, BOOL bEnabled, COLORREF clr)
Call this member function to draw a check mark.
void | DrawCheckMark (CDC *pDC, CRect rcCheck, COLORREF clr=0)
Call this member function to draw a check mark.
virtual void | DrawPopupBarRadioMark (CDC *pDC, CRect rcCheck, BOOL bEnabled, COLORREF clr)
Call this member function to draw a radio button.
virtual void | DrawComboExpandMark (CDC *pDC, CRect rc, COLORREF clr)
Call this member function to draw a combobox expand symbol.
void | Line (CDC *pDC, CPoint p0, CPoint p1)
Draws a line.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1, const int nPen)
Draws a line.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1, COLORREF clrPen)
Draws a line.
void | HorizontalLine (CDC *pDC, int x0, int y0, int x1, COLORREF clrPen)
Call this member function to draw a horizontal line using the specified coordinages and RGB color value.
void | VerticalLine (CDC *pDC, int x0, int y0, int y1, COLORREF clrPen)
Call this member function to draw a vertical line using the specified coordinages and RGB color value.
void | Pixel (CDC *pDC, int xPos, int yPos, int nPen)
Sets the pixel at the point.
void | GradientFill (CDC *pDC, LPRECT lpRect, COLORREF crFrom, COLORREF crTo, BOOL bHorz, LPCRECT lpRectClip=NULL)
Gradient fills the rectangle.
XTP_COMMANDBARS_ICONSINFO * GetIconsInfo ()
virtual void | Animate (CDC *pDestDC, CDC *pSrcDC, CRect rc, XTPAnimationType animationType)
This method is called to animate the pop-up bar.
virtual void | AnimateExpanding (CXTPCommandBar *pCommandBar, CDC *pDestDC, CDC *pSrcDC, BOOL bExpandDown)
This method is called to animate the expanding process.
void | SetAnimationDelay (int nAnimationSteps, int nAnimationTime)
Call this method to set animation delay.
COLORREF | GetXtremeColor (UINT nIndex)
This function retrieves the current color of the specified XP display element.
void | SetColors (int cElements, CONST INT *lpaElements, CONST COLORREF *lpaRgbValues)
Call this member to set the colors for each element to the color in the specified color array.
CSize | DrawControlText (CDC *pDC, CXTPControl *pControl, CRect rcText, BOOL bDraw, BOOL bVert, BOOL bCentered, BOOL bTriangled)
This method is called to draw control text.
virtual void | UpdateRTLCaption (CString &strCaption)
This method is called to prepare a caption for Right-To-Left draw.
XTPCurrentSystemTheme GetCurrentSystemTheme ()
Call this member function to determine the current Windows XP theme in use.
void | SetLunaTheme (XTPCurrentSystemTheme systemTheme)
Call this method to force system theme.
virtual int | GetPopupBarGripperWidth (CXTPCommandBar *pBar)
Calculates the gripper of a pop-up bar.
virtual CXTPControlGalleryPaintManager * | GetGalleryPaintManager () const
Retrieves paint manager used to draw galleries.
virtual CXTPScrollBarPaintManager * | GetScrollBarPaintManager () const
Retrieves paint manager used to draw scrollbars.
virtual CXTPSliderPaintManager * | GetSliderPaintManager () const
Retrieves paint manager used to draw slider panes.
virtual CXTPProgressPaintManager * | GetProgressPaintManager () const
Retrieves paint manager used to draw progress bars.
virtual CXTPStatusBarPaintManager * | GetStatusBarPaintManager ()
Retrieves paint manager used to draw the status bar.
virtual CXTPMessageBarPaintManager * | GetMessageBarPaintManager ()
Retrieves paint manager used to draw message bars.
CXTPShadowManager * | GetShadowManager () const
Retrieves shadow manager used to draw shadows.
BOOL | IsUseSystemAccentColorEnabled () const
Determines whether xtpApplicationUseSystemAccentColor application ambient property is set.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.
- Public Member Functions inherited from CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents >
void | Subscribe (IXTPPaintManagerEvents *pObserver, CXTPSubscriptionList< CXTPPaintManager, IXTPPaintManagerEvents > *pSubcriptionList=NULL)
Subscribes a unique observer for events.
void | Unsubscribe (IXTPPaintManagerEvents *pObserver)
Unsubscribes an observer from events.
void | Notify (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *))
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *))
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.

Protected Member Functions

virtual void | DrawSplitButtonFrame (CDC *pDC, CXTPControl *pButton, CRect rc)
This method is called to draw the frame for the SplitButton control.
virtual void | DrawRectangle (CDC *pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition)
This method is called to fill the control's face.
virtual void | DrawRectangle (CDC *pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition, int nID)
This method is called to fill the control's face.
virtual BOOL | DrawRectangle (CDC *pDC, CXTPControl *pButton)
This method is called to fill the control's face.
virtual COLORREF | GetControlTextColor (CXTPControl *pButton)
This method returns the control text color to draw.
virtual void | DrawGalleryItemBack (CDC *pDC, CRect rcItem, BOOL bEnabled, BOOL bSelected, BOOL bPressed, BOOL bChecked, XTPBarType barType)
This method is called to draw the background for a gallery menu item.
virtual void | DrawCheckRect (CDC *pDC, CRect rc, COLORREF clrFore, COLORREF clrBack)
Helper class called by DrawRectangle to render a checkmark background and border.
virtual CSize | DrawCommandBarGripper (CDC *pDC, CXTPCommandBar *pBar, BOOL bDraw=TRUE)
This method is called to draw the command bar's gripper.
virtual CSize | DrawControlComboBox (CDC *pDC, CXTPControlComboBox *pComboBox, BOOL bDraw)
This method is called to draw the control.
- Protected Member Functions inherited from CXTPCommandBarsOffice2013Theme
virtual void | RefreshMetrics ()
This method is called to refresh the visual metrics of the manager.
virtual void | RefreshStandardColors ()
Called to update the standard colors used by the framework.
virtual COLORREF | GetRectangleTextColor (BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition)
This method retrieves a buttons text color.
virtual COLORREF | GetControlBackColor (CXTPControl *pButton)
Call this method to get the control back color to draw.
void | DrawFrameBorder (CDC *pDC, CRect rc, int nBorderThickness, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition)
This method is called to fill the border of the control's face.
virtual void | DrawPopupBarGripper (CDC *pDC, int xPos, int yPos, int cx, int cy, BOOL bExpanded=FALSE)
This method is called to draw a pop-up bar's right gripper.
virtual void | DrawDropDownGlyph (CDC *pDC, CXTPControl *pControl, CPoint pt, BOOL bSelected, BOOL bPopuped, BOOL bEnabled, BOOL bVert)
This member function is called to draw a split button expand symbol.
virtual CSize | DrawCommandBarSeparator (CDC *pDC, CXTPCommandBar *pBar, CXTPControl *pControl, BOOL bDraw=TRUE)
This method is called to draw a command bar's separator.
virtual void | DrawExpandGlyph (CDC *pDC, CXTPControl *pButton, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clr)
Draw expand or hidden glyphs for a button.
virtual void | DrawHiddenGlyph (CDC *pDC, CXTPControl *pButton, COLORREF clr, BOOL bVertical)
Draw expand or hidden glyphs for a button.
virtual void | DrawExpandGlyph (CDC *pDC, CXTPControl *pButton, COLORREF clr, BOOL bVertical)
Draw expand or hidden glyphs for a button.
virtual CSize | DrawControlCheckBoxMark (CDC *pDC, CXTPControl *pButton, CRect rc, BOOL bDraw)
This method is called to draw a check box mark area.
virtual CSize | DrawControlCheckBoxMark (CDC *pDC, CRect rc, BOOL bDraw, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled)
This method is called to draw a check box mark area.
virtual CSize | DrawControlRadioButtonMark (CDC *pDC, CRect rc, BOOL bDraw, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled)
This method is called to draw a radio button mark area.
virtual void | DrawControlMDIButton (CDC *pDC, CXTPControlButton *pButton)
Call this member function to draw Menu MDI buttons.
- Protected Member Functions inherited from CXTPCommandBarsModernUITheme
- Protected Member Functions inherited from CXTPCommandBarsOfficeXPTheme
virtual CSize | DrawControlPopupParent (CDC *pDC, CXTPControl *pButton, BOOL bDraw)
This method is called to draw the control placed on the pop-up bar.
virtual void | DrawImage (CDC *pDC, CPoint pt, CSize sz, CXTPImageManagerIcon *pImage, BOOL bSelected, BOOL bPressed, BOOL bEnabled=TRUE, BOOL bChecked=FALSE, BOOL bPopuped=FALSE, BOOL bToolBarImage=TRUE)
This method is called to draw the image of the control.
void | FillIntersectRect (CDC *pDC, CXTPPopupBar *pPopupBar, COLORREF clr)
Draws intersect rectangle of a pop-up bar and its control.
- Protected Member Functions inherited from CXTPPaintManager
CXTPPaintManager ()
Constructs a CXTPPaintManager object.
virtual | ~CXTPPaintManager ()
Destroys a CXTPPaintManager object, handles cleanup and deallocation.
- Protected Member Functions inherited from CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents >
CXTPObservable ()
Constructs an observable object.
~CXTPObservable ()
Handles observable object destruction.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPPaintManager
static CXTPPaintManager *AFX_CDECL | GetInstanceAddRef ()
Obtains a pointer to a global paint manager object and increments its reference counter.
static void AFX_CDECL | ReleaseInstance ()
Decrements global paint manager's reference counter and deletes its instance when the reference counter reaches 0.
static CXTPPaintManager *AFX_CDECL | CreateTheme (XTPPaintTheme paintTheme)
Creates a new CXTPPaintManager object.
static void AFX_CDECL | SetTheme (XTPPaintTheme paintTheme)
Call this member to switch the visual theme of the Command Bars.
static void AFX_CDECL | SetCustomTheme (CXTPPaintManager *pTheme)
Call this member to set a custom theme.
static void AFX_CDECL | Triangle (CDC *pDC, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clr)
Draws a triangle.
static BOOL AFX_CDECL | FontExists (LPCTSTR lpszFaceName)
Determines if a specified font exists in the system.
static void AFX_CDECL | StripMnemonics (CString &strClear)
This member function will search a string, strip off the mnemonic '&', and reformat the string.
static CXTPPaintManager *AFX_CDECL | GetGlobalPaintManager ()
Call this method to get the pointer to the global paint manager.
static void AFX_CDECL | SetGlobalPaintManager (CXTPPaintManager *pPaintManager)
Call this method to set the pointer to the global paint manager.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPPaintManager
COLORREF | m_clrMessageBarText
Message bar text color.
CRect | m_rcMessageBarMargin
Margin of the message bar.
CXTPFramePaintManager * | m_pFramePaintManager
Frame paint manager.
CXTPStatusBarPaintManager * | m_pStatusBarPaintManager
Paint manager of the status bar.
CXTPRibbonPaintManager * | m_pRibbonPaintManager
Ribbon paint Manager.
CXTPControlGalleryPaintManager * | m_pGalleryPaintManager
Gallery paint manager.
CXTPProgressPaintManager * | m_pProgressPaintManager
Progress bar paint manager.
CXTPSliderPaintManager * | m_pSliderPaintManager
Slider pane paint manager.
CXTPScrollBarPaintManager * | m_pScrollBarPaintManager
Scrollbar paint manager.
CXTPPaintManagerColorGradient | m_clrDisabledIcon
Disabled icons color.
CXTPPaintManagerColor | m_clrFloatingGripper
Gripper color of floating toolbar.
CXTPPaintManagerColor | m_clrFloatingGripperText
Gripper text color of floating toolbar.
BOOL | m_bThickCheckMark
TRUE to draw thick check mark.
BOOL | m_bShowShadow
TRUE to show shadow.
BOOL | m_bThemedStatusBar
TRUE to draw status bar using WinXP theme.
BOOL | m_bThemedCheckBox
TRUE to draw check box using WinXP theme.
BOOL | m_bClearTypeTextQuality
TRUE to enable ClearType text for the font.
BOOL | m_bFlatToolBar
TRUE to draw toolbars flat.
BOOL | m_bFlatMenuBar
TRUE to draw menubar flat.
int | m_nPopupBarTextPadding
Distance between gripper and control text.
BOOL | m_bSelectImageInPopupBar
TRUE to select image as in explorer theme.
BOOL | m_bEnableAnimation
TRUE to enable animation for all toolbars.
BOOL | m_bOffice2007Padding
TRUE if Office2007 metrics used.
BOOL | m_bOffsetPopupLabelText
TRUE if labels in pop-ups drawn with offset.
BOOL | m_bWrapCaptionBelowText
Wrap text for xtpButtonIconAndCaptionBelow buttons.
CXTPPaintManagerFont | m_fontSmCaption
Small caption font.
CXTPPaintManagerFont | m_fontIcon
Icon font.
CXTPPaintManagerFont | m_fontIconBold
Icon bold font.
CXTPPaintManagerFont | m_fontToolTip
Tooltip font.
int | m_nSplitButtonDropDownWidth
Split button drop down width in toolbars.
int | m_nSplitButtonDropDownHeight
Split button drop down height in toolbars.
int | m_nSplitButtonPopupWidth
Split button drop down width in pop-ups.
BOOL | m_bAutoResizeIcons
TRUE to automatically resize icons using current DPI.
int | m_nStatusBarMinHeight
Minimum height for the status bar.
PVOID | m_pfnSetLayeredWindowAttributes
point to Transparency proc in USER32.dll module.
CRect | m_rcStatusBarBorder
Bounding rectangle of the status bar border.
BOOL | m_bUseOfficeFont
TRUE to use Tahoma font.
CString | m_strOfficeFont
Office font.
int | m_nTextHeight
Regular text field height (not font height).
- Protected Attributes inherited from CXTPCommandBarsOffice2013Theme
BOOL | m_bIntersect
TRUE to draw pop-up bar intersect rectangle.
CXTPColorSetStateMenu | m_csMenu
State colors used by Menu items.
CXTPColorSetStateMenuTitleBar | m_csMenuTitleBar
State colors used by MenuTitleBar items.
CXTPColorSetStateRibbon | m_csRibbon
State colors used by Ribbon group buttons.
CXTPColorSetStateToolbar | m_csToolbar
State colors used by Toolbar buttons.
CXTPColorSetStateCheckMark | m_csCheckMark
State colors used by Menu Check Marks.
CXTPColorSetStateComboBox | m_csComboBox
State colors used by ComboBox control.
CXTPColorSetStateCheckBox | m_csCheckBox
State colors used by Check Box and Radio Button controls.
CXTPPaintManagerColor | m_clrBack
CommandBars background color;.
CXTPPaintManagerColor | m_clrGlyph
Glyph Normal color.
CXTPPaintManagerColor | m_clrGlyphHighlight
Glyph Highlight color.
CXTPPaintManagerColor | m_clrGlyphPushed
Glyph Pushed color.
CXTPPaintManagerColor | m_clrGlyphDisabled
Glyph Disabled color.
CXTPPaintManagerColor | m_clrMessageBarText
Message bar text color.
CXTPPaintManagerColor | m_clrBtnFace
Button background color.
CXTPPaintManagerColor | m_clr3DShadow
Button shadow color.
CXTPPaintManagerColor | m_clrHighlight
Button highlight color.
CXTPPaintManagerColor | m_clrCaptionButtonFill
Text color for frame caption buttons.
CXTPPaintManagerColorGradient | m_clrWorkspace
Workspace area gradient color.
- Protected Attributes inherited from CXTPCommandBarsModernUITheme
CXTPMarkupContext * | m_pMarkupContext
Points to a valid markup context object.
CXTPResourceImages * | m_pImages
Points to a valid resource images object.
- Protected Attributes inherited from CXTPPaintManager
CXTPFont | m_xtpFontRegular
Regular font.
CXTPFont | m_xtpFontRegularBold
Regular bold font.
CXTPFont | m_xtpFontVert
Vertical font.
CXTPFont | m_xtpFontVertBold
Vertical font.
int | m_nEditHeight
Edit text height.
int | m_nFontHeight
Custom font height (optional).
BOOL | m_bUseStandardFont
TRUE to use system font.
BOOL | m_bEmbossedDisabledText
TRUE to draw disabled text embossed.
CXTPWinThemeWrapper * | m_themeStatusBar
StatusBar theme helper.
CXTPWinThemeWrapper * | m_themeButton
Buttons theme helper.
XTPPaintTheme | m_themeCurrent
Current theme.
XTP_COMMANDBARS_ICONSINFO | m_iconsInfo
Specific icons options.
int | m_nAnimationSteps
Steps of the animation.
int | m_nAnimationTime
Time of the animation.
BOOL | m_bShowKeyboardCues
TRUE to show keyboard cues - deprecated.
CXTPPaintManagerColor | m_arrColor [XPCOLOR_LAST+1]
Self colors array.
XTPCurrentSystemTheme | m_systemTheme
Current system theme.
CXTPShadowManager * | m_pShadowManager
Shadow manager.

Detailed Description

The CXTPCommandBarsVisualStudio2015Theme class is used to enable a Visual Studio 2015 style theme for Command Bars.

See also
CXTPPaintManager::SetTheme

Member Function Documentation

◆ DrawCheckRect()

virtual void DrawCheckRect | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | COLORREF | clrFore,
 |  | COLORREF | clrBack )
 protectedvirtual

Helper class called by DrawRectangle to render a checkmark background and border.

Parameters
pDC | Pointer to a valid device context.
rc | Rectangle to draw.
clrFore | RGB color value used to draw border.
clrBack | RGB color value used to draw background.

◆ DrawCommandBarGripper()

virtual CSize DrawCommandBarGripper | ( | CDC * | pDC,
 |  | CXTPCommandBar * | pBar,
 |  | BOOL | bDraw = TRUE )
 protectedvirtual

This method is called to draw the command bar's gripper.

Parameters
pDC | Pointer to a valid device context.
pBar | Pointer to a CXTPCommandBar object.
bDraw | TRUE to draw; FALSE to retrieve the size of the gripper.
Returns
Size of the gripper.

Reimplemented from CXTPCommandBarsOffice2013Theme.

◆ DrawControlComboBox()

virtual CSize DrawControlComboBox | ( | CDC * | pDC,
 |  | CXTPControlComboBox * | pComboBox,
 |  | BOOL | bDraw )
 protectedvirtual

This method is called to draw the control.

Parameters
pDC | Pointer to a valid device context.
bDraw | TRUE to draw; FALSE to retrieve the size of the control.
pComboBox | A pointer to a CXTPControlComboBox object to draw.
Returns
Size of the control.

Reimplemented from CXTPCommandBarsOffice2013Theme.

◆ DrawGalleryItemBack()

virtual void DrawGalleryItemBack | ( | CDC * | pDC,
 |  | CRect | rcItem,
 |  | BOOL | bEnabled,
 |  | BOOL | bSelected,
 |  | BOOL | bPressed,
 |  | BOOL | bChecked,
 |  | XTPBarType | barType )
 protectedvirtual

This method is called to draw the background for a gallery menu item.

Parameters
pDC | Pointer to a valid device context.
rcItem | Reference to item area rectangle coordinates.
bSelected | TRUE if the control is selected.
bPressed | TRUE if the control is pushed.
bEnabled | TRUE if the control is enabled.
bChecked | TRUE if the control is checked.
barType | Parent's bar type.

Reimplemented from CXTPCommandBarsOffice2013Theme.

◆ DrawRectangle() [1/3]

virtual void DrawRectangle | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | BOOL | bSelected,
 |  | BOOL | bPressed,
 |  | BOOL | bEnabled,
 |  | BOOL | bChecked,
 |  | BOOL | bPopuped,
 |  | XTPBarType | barType,
 |  | XTPBarPosition | barPosition )
 protectedvirtual

This method is called to fill the control's face.

Parameters
pDC | Pointer to a valid device context.
rc | Rectangle to draw.
bSelected | TRUE if the control is selected.
bPressed | TRUE if the control is pushed.
bEnabled | TRUE if the control is enabled.
bChecked | TRUE if the control is checked.
bPopuped | TRUE if the control is pop-up'ed.
barType | Parent's bar type.
barPosition | Parent's bar position.

Reimplemented from CXTPCommandBarsOffice2013Theme.

◆ DrawRectangle() [2/3]

virtual void DrawRectangle | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | BOOL | bSelected,
 |  | BOOL | bPressed,
 |  | BOOL | bEnabled,
 |  | BOOL | bChecked,
 |  | BOOL | bPopuped,
 |  | XTPBarType | barType,
 |  | XTPBarPosition | barPosition,
 |  | int | nID )
 protectedvirtual

This method is called to fill the control's face.

Parameters
pDC | Pointer to a valid device context.
rc | Rectangle to draw.
bSelected | TRUE if the control is selected.
bPressed | TRUE if the control is pushed.
bEnabled | TRUE if the control is enabled.
bChecked | TRUE if the control is checked.
bPopuped | TRUE if the control is pop-up'ed.
barType | Parent's bar type.
barPosition | Parent's bar position.
nID | Bar's control ID.

Reimplemented from CXTPCommandBarsOffice2013Theme.

◆ DrawRectangle() [3/3]

virtual BOOL DrawRectangle | ( | CDC * | pDC,
 |  | CXTPControl * | pButton )
 protectedvirtual

This method is called to fill the control's face.

Parameters
pDC | Pointer to a valid device context.
pButton | pointer to a button
Returns
TRUE if the rectange was drawn, otherwise FALSE.

Reimplemented from CXTPCommandBarsOffice2013Theme.

◆ DrawSplitButtonFrame()

virtual void DrawSplitButtonFrame | ( | CDC * | pDC,
 |  | CXTPControl * | pButton,
 |  | CRect | rc )
 protectedvirtual

This method is called to draw the frame for the SplitButton control.

Parameters
pDC | Pointer to a valid device context.
pButton | Pointer to a CXTPControl object.
rc | Bounding rectangle to draw.

Reimplemented from CXTPCommandBarsOffice2013Theme.

◆ GetControlTextColor()

virtual COLORREF GetControlTextColor ( CXTPControl * pButton )
protectedvirtual

This method returns the control text color to draw.

Parameters
pButton Points to a CXTPControl object to draw.
Returns
Returns control text color

Reimplemented from CXTPCommandBarsOffice2013Theme.

◆ GetStateColor()

virtual COLORREF GetStateColor ( ) const
virtual

Call this member function to get the application state color for the frame border and status bar.

Returns
COLORREF value representing the application state color.

◆ SetStateColor()

virtual void SetStateColor ( COLORREF clrState = COLORREF_NULL )
virtual

Call this member function to set the application state color for the frame border and status bar.

Parameters
clrState COLORREF value representing the application state color. Use COLORREF_NULL to reset back to default color.
The documentation for this class was generated from the following file:
  • XTPCommandBarsVisualStudio2015Theme.h


Toolkit Pro: CXTPCommandBarsVisualStudio2017Theme Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPCommandBarsVisualStudio2017Theme Class Reference

The CXTPCommandBarsVisualStudio2017Theme class is used to enable a Visual Studio 2017 style theme for Command Bars. More...

Inheritance diagram for CXTPCommandBarsVisualStudio2017Theme:
[legend]

Public Member Functions

CXTPCommandBarsVisualStudio2017Theme ()
Constructs a CXTPCommandBarsVisualStudio2017Theme object.
virtual | ~CXTPCommandBarsVisualStudio2017Theme ()
Destroys a CXTPCommandBarsVisualStudio2017Theme object, handles cleanup and deallocation.
virtual void | SetStateColor (COLORREF clrState=COLORREF_NULL)
Call this member function to set the application state color for the frame border and status bar.
virtual COLORREF | GetStateColor () const
Call this member function to get the application state color for the frame border and status bar.
- Public Member Functions inherited from CXTPCommandBarsOffice2013Theme
CXTPCommandBarsOffice2013Theme ()
Constructs a CXTPCommandBarsOffice2013Theme object.
virtual | ~CXTPCommandBarsOffice2013Theme ()
Destroys a CXTPCommandBarsOffice2013Theme object, handles cleanup and deallocation.
virtual XTPPaintTheme | BaseTheme ()
Retrieves the base theme of the manager.
virtual void | FillCommandBarEntry (CDC *pDC, CXTPCommandBar *pBar)
This method is called to fill the command bar's face.
virtual void | FillDockBar (CDC *pDC, CXTPDockBar *pBar)
This method is called to fill a dock bar.
virtual void | DrawCommandBarGroupSeparator (CDC *pDC, CXTPCommandBar *pBar, CXTPControl *pLeftControl, CXTPControl *pRightControl, BOOL bDraw)
This method is called to draw a command bar's group separator.
virtual CSize | DrawControlEdit (CDC *pDC, CXTPControlEdit *pEdit, BOOL bDraw)
This method is called to draw the control.
virtual void | FillWorkspace (CDC *pDC, CRect rc, CRect rcExclude)
Draws workspace space.
virtual BOOL | RequiresResourceImages ()
Used by the paint manager to determine if the theme requires a resource DLL to load image and color information.
virtual COLORREF | GetControlEditBackColor (CXTPControl *pControl)
This method returns the edit control back color to draw.
- Public Member Functions inherited from CXTPCommandBarsModernUITheme
CXTPCommandBarsModernUITheme ()
Constructs a CXTPCommandBarsModernUITheme object.
virtual | ~CXTPCommandBarsModernUITheme ()
Destroys a CXTPCommandBarsModernUITheme object, handles cleanup and deallocation.
virtual CXTPFramePaintManager * | GetFramePaintManager ()
Returns paint manager used to draw frames.
virtual CXTPRibbonPaintManager * | GetRibbonPaintManager ()
Retrieves the ribbon paint manager.
virtual CXTPMarkupContext * | GetMarkupContext ()
Retrieves a pointer to the markup context.
- Public Member Functions inherited from CXTPCommandBarsOfficeXPTheme
CXTPCommandBarsOfficeXPTheme ()
Constructs a CXTPCommandBarsOfficeXPTheme object.
virtual CSize | DrawListBoxControl (CDC *pDC, CXTPControl *pButton, CRect rc, BOOL bSelected, BOOL bDraw, CXTPCommandBars *pCommandBars=0)
This method is called to draw the control placed on the ListBox.
virtual void | AdjustExcludeRect (CRect &rc, CXTPControl *pControl, BOOL bVertical)
This method is called to determine the offset of a pop-up bar.
virtual CSize | DrawTearOffGripper (CDC *pDC, CRect rcGripper, BOOL bSelected, BOOL bDraw)
This method is called to draw a tear-off gripper of a pop-up bar.
virtual void | DrawPopupResizeGripper (CDC *pDC, CRect rcGripper, int nFlags)
This method is called to draw a resize gripper of a pop-up bar.
virtual CSize | DrawDialogBarGripper (CDC *pDC, CXTPDialogBar *pBar, BOOL bDraw)
Call this member to draw the gripper of a dialog bar.
- Public Member Functions inherited from CXTPPaintManager
virtual void | SetImageHandle (HMODULE hResource, LPCTSTR lpszIniFileName)
Specifies the resource that contains the bitmaps to be loaded for the theme.
CSize | DrawControl (CDC *pDC, CXTPControl *pButton, BOOL bDraw=TRUE)
This method is called to draw the control.
virtual CSize | DrawControlToolBarParent (CDC *pDC, CXTPControl *pButton, BOOL bDraw)
This method is called to draw the control placed on the toolbar.
virtual void | DrawControlEntry (CDC *pDC, CXTPControl *pButton)
This method is called to fill the control's face.
int | GetShadowOptions () const
Determines the kind of shadow to use.
virtual CSize | DrawSpecialControl (CDC *pDC, XTPSpecialControl controlType, CXTPControl *pButton, CXTPCommandBar *pBar, BOOL bDraw, LPVOID lpParam)
This method is called to draw the specified controls.
virtual CRect | GetCommandBarBorders (CXTPCommandBar *pBar)
This method is called to retrieve the command bar's borders.
virtual CRect | GetSplitButtonCommandRect (CXTPControl *pButton)
Determines split button command rectangle.
virtual void | SetCommandBarRegion (CXTPCommandBar *pCommandBar)
Call this method to set the bounding region of a pop-up bar.
XTPPaintTheme GetCurrentTheme ()
Call this member to get the current visual theme.
virtual CFont * | GetControlFont (CXTPControl *pControl)
Call this member to retrieve the font of the command bar control.
virtual CFont * | GetCommandBarFont (CXTPCommandBar *pCommandBar)
Call this member to retrieve the font of the command bar.
virtual XTPBarTextOrientation | GetControlTextOrientation (CXTPControl *pControl)
Call this member to determine how to draw text.
virtual void | UpdateFonts ()
Refreshes the fonts to use.
virtual void | UpdateColors ()
Refreshes the standard colors to use.
void | SetCommandBarsFontIndirect (LOGFONT *pLogFont, BOOL bUseStandardFont=FALSE)
Call this member to set command bar's font.
CFont * | GetRegularFont ()
Returns the general font.
CFont * | GetRegularBoldFont ()
Returns the general bold font.
CFont * | GetIconFont ()
Returns the icon font.
CFont * | GetSmCaptionFont ()
Call this method to retrieve the caption of a floating mini frame.
void | UseOfficeFont (bool bUseOfficeFont)
Call this method to use Tahoma font despite system metrics.
int | GetControlHeight () const
This method returns the common controls height.
virtual CSize | GetDefaultCommandBarSize (CXTPCommandBar *pBar)
Computes default command bar size taking into account command bar font.
void | Rectangle (CDC *pDC, LPCRECT rc, int nPen, const int nBrush)
Draws a rectangle.
void | Rectangle (CDC *pDC, LPCRECT rc, COLORREF clrPen, COLORREF clrBrush)
Draws a rectangle.
void | RoundRect (CDC *pDC, LPCRECT rc, COLORREF clrPen, COLORREF clrBrush)
Draws a rectangle.
void | Draw3dRect (CDC *pDC, LPCRECT rc, int nTopLeft, int nBottomRight)
Call this member function to draw a three-dimensional rectangle.
void | Draw3dRect (CDC *pDC, LPCRECT rc, int frameThickness, COLORREF clrPen, COLORREF clrBrush)
Call this member function to draw a rectangle with predetermined thickness.
virtual void | DrawPopupBarCheckMark (CDC *pDC, CRect rcCheck, BOOL bEnabled, COLORREF clr)
Call this member function to draw a check mark.
void | DrawCheckMark (CDC *pDC, CRect rcCheck, COLORREF clr=0)
Call this member function to draw a check mark.
virtual void | DrawPopupBarRadioMark (CDC *pDC, CRect rcCheck, BOOL bEnabled, COLORREF clr)
Call this member function to draw a radio button.
virtual void | DrawComboExpandMark (CDC *pDC, CRect rc, COLORREF clr)
Call this member function to draw a combobox expand symbol.
void | Line (CDC *pDC, CPoint p0, CPoint p1)
Draws a line.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1, const int nPen)
Draws a line.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1, COLORREF clrPen)
Draws a line.
void | HorizontalLine (CDC *pDC, int x0, int y0, int x1, COLORREF clrPen)
Call this member function to draw a horizontal line using the specified coordinages and RGB color value.
void | VerticalLine (CDC *pDC, int x0, int y0, int y1, COLORREF clrPen)
Call this member function to draw a vertical line using the specified coordinages and RGB color value.
void | Pixel (CDC *pDC, int xPos, int yPos, int nPen)
Sets the pixel at the point.
void | GradientFill (CDC *pDC, LPRECT lpRect, COLORREF crFrom, COLORREF crTo, BOOL bHorz, LPCRECT lpRectClip=NULL)
Gradient fills the rectangle.
XTP_COMMANDBARS_ICONSINFO * GetIconsInfo ()
virtual void | Animate (CDC *pDestDC, CDC *pSrcDC, CRect rc, XTPAnimationType animationType)
This method is called to animate the pop-up bar.
virtual void | AnimateExpanding (CXTPCommandBar *pCommandBar, CDC *pDestDC, CDC *pSrcDC, BOOL bExpandDown)
This method is called to animate the expanding process.
void | SetAnimationDelay (int nAnimationSteps, int nAnimationTime)
Call this method to set animation delay.
COLORREF | GetXtremeColor (UINT nIndex)
This function retrieves the current color of the specified XP display element.
void | SetColors (int cElements, CONST INT *lpaElements, CONST COLORREF *lpaRgbValues)
Call this member to set the colors for each element to the color in the specified color array.
CSize | DrawControlText (CDC *pDC, CXTPControl *pControl, CRect rcText, BOOL bDraw, BOOL bVert, BOOL bCentered, BOOL bTriangled)
This method is called to draw control text.
virtual void | UpdateRTLCaption (CString &strCaption)
This method is called to prepare a caption for Right-To-Left draw.
XTPCurrentSystemTheme GetCurrentSystemTheme ()
Call this member function to determine the current Windows XP theme in use.
void | SetLunaTheme (XTPCurrentSystemTheme systemTheme)
Call this method to force system theme.
virtual int | GetPopupBarGripperWidth (CXTPCommandBar *pBar)
Calculates the gripper of a pop-up bar.
virtual CXTPControlGalleryPaintManager * | GetGalleryPaintManager () const
Retrieves paint manager used to draw galleries.
virtual CXTPScrollBarPaintManager * | GetScrollBarPaintManager () const
Retrieves paint manager used to draw scrollbars.
virtual CXTPSliderPaintManager * | GetSliderPaintManager () const
Retrieves paint manager used to draw slider panes.
virtual CXTPProgressPaintManager * | GetProgressPaintManager () const
Retrieves paint manager used to draw progress bars.
virtual CXTPStatusBarPaintManager * | GetStatusBarPaintManager ()
Retrieves paint manager used to draw the status bar.
virtual CXTPMessageBarPaintManager * | GetMessageBarPaintManager ()
Retrieves paint manager used to draw message bars.
CXTPShadowManager * | GetShadowManager () const
Retrieves shadow manager used to draw shadows.
BOOL | IsUseSystemAccentColorEnabled () const
Determines whether xtpApplicationUseSystemAccentColor application ambient property is set.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.
- Public Member Functions inherited from CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents >
void | Subscribe (IXTPPaintManagerEvents *pObserver, CXTPSubscriptionList< CXTPPaintManager, IXTPPaintManagerEvents > *pSubcriptionList=NULL)
Subscribes a unique observer for events.
void | Unsubscribe (IXTPPaintManagerEvents *pObserver)
Unsubscribes an observer from events.
void | Notify (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *))
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *))
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.

Protected Member Functions

virtual void | DrawSplitButtonFrame (CDC *pDC, CXTPControl *pButton, CRect rc)
This method is called to draw the frame for the SplitButton control.
virtual void | DrawRectangle (CDC *pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition)
This method is called to fill the control's face.
virtual void | DrawRectangle (CDC *pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition, int nID)
This method is called to fill the control's face.
virtual BOOL | DrawRectangle (CDC *pDC, CXTPControl *pButton)
This method is called to fill the control's face.
virtual COLORREF | GetControlTextColor (CXTPControl *pButton)
This method returns the control text color to draw.
virtual void | DrawGalleryItemBack (CDC *pDC, CRect rcItem, BOOL bEnabled, BOOL bSelected, BOOL bPressed, BOOL bChecked, XTPBarType barType)
This method is called to draw the background for a gallery menu item.
virtual void | DrawCheckRect (CDC *pDC, CRect rc, COLORREF clrFore, COLORREF clrBack)
Helper class called by DrawRectangle to render a checkmark background and border.
virtual CSize | DrawCommandBarGripper (CDC *pDC, CXTPCommandBar *pBar, BOOL bDraw=TRUE)
This method is called to draw the command bar's gripper.
virtual CSize | DrawControlComboBox (CDC *pDC, CXTPControlComboBox *pComboBox, BOOL bDraw)
This method is called to draw the control.
- Protected Member Functions inherited from CXTPCommandBarsOffice2013Theme
virtual void | RefreshMetrics ()
This method is called to refresh the visual metrics of the manager.
virtual void | RefreshStandardColors ()
Called to update the standard colors used by the framework.
virtual COLORREF | GetRectangleTextColor (BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition)
This method retrieves a buttons text color.
virtual COLORREF | GetControlBackColor (CXTPControl *pButton)
Call this method to get the control back color to draw.
void | DrawFrameBorder (CDC *pDC, CRect rc, int nBorderThickness, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition)
This method is called to fill the border of the control's face.
virtual void | DrawPopupBarGripper (CDC *pDC, int xPos, int yPos, int cx, int cy, BOOL bExpanded=FALSE)
This method is called to draw a pop-up bar's right gripper.
virtual void | DrawDropDownGlyph (CDC *pDC, CXTPControl *pControl, CPoint pt, BOOL bSelected, BOOL bPopuped, BOOL bEnabled, BOOL bVert)
This member function is called to draw a split button expand symbol.
virtual CSize | DrawCommandBarSeparator (CDC *pDC, CXTPCommandBar *pBar, CXTPControl *pControl, BOOL bDraw=TRUE)
This method is called to draw a command bar's separator.
virtual void | DrawExpandGlyph (CDC *pDC, CXTPControl *pButton, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clr)
Draw expand or hidden glyphs for a button.
virtual void | DrawHiddenGlyph (CDC *pDC, CXTPControl *pButton, COLORREF clr, BOOL bVertical)
Draw expand or hidden glyphs for a button.
virtual void | DrawExpandGlyph (CDC *pDC, CXTPControl *pButton, COLORREF clr, BOOL bVertical)
Draw expand or hidden glyphs for a button.
virtual CSize | DrawControlCheckBoxMark (CDC *pDC, CXTPControl *pButton, CRect rc, BOOL bDraw)
This method is called to draw a check box mark area.
virtual CSize | DrawControlCheckBoxMark (CDC *pDC, CRect rc, BOOL bDraw, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled)
This method is called to draw a check box mark area.
virtual CSize | DrawControlRadioButtonMark (CDC *pDC, CRect rc, BOOL bDraw, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled)
This method is called to draw a radio button mark area.
virtual void | DrawControlMDIButton (CDC *pDC, CXTPControlButton *pButton)
Call this member function to draw Menu MDI buttons.
- Protected Member Functions inherited from CXTPCommandBarsModernUITheme
- Protected Member Functions inherited from CXTPCommandBarsOfficeXPTheme
virtual CSize | DrawControlPopupParent (CDC *pDC, CXTPControl *pButton, BOOL bDraw)
This method is called to draw the control placed on the pop-up bar.
virtual void | DrawImage (CDC *pDC, CPoint pt, CSize sz, CXTPImageManagerIcon *pImage, BOOL bSelected, BOOL bPressed, BOOL bEnabled=TRUE, BOOL bChecked=FALSE, BOOL bPopuped=FALSE, BOOL bToolBarImage=TRUE)
This method is called to draw the image of the control.
void | FillIntersectRect (CDC *pDC, CXTPPopupBar *pPopupBar, COLORREF clr)
Draws intersect rectangle of a pop-up bar and its control.
- Protected Member Functions inherited from CXTPPaintManager
CXTPPaintManager ()
Constructs a CXTPPaintManager object.
virtual | ~CXTPPaintManager ()
Destroys a CXTPPaintManager object, handles cleanup and deallocation.
- Protected Member Functions inherited from CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents >
CXTPObservable ()
Constructs an observable object.
~CXTPObservable ()
Handles observable object destruction.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPPaintManager
static CXTPPaintManager *AFX_CDECL | GetInstanceAddRef ()
Obtains a pointer to a global paint manager object and increments its reference counter.
static void AFX_CDECL | ReleaseInstance ()
Decrements global paint manager's reference counter and deletes its instance when the reference counter reaches 0.
static CXTPPaintManager *AFX_CDECL | CreateTheme (XTPPaintTheme paintTheme)
Creates a new CXTPPaintManager object.
static void AFX_CDECL | SetTheme (XTPPaintTheme paintTheme)
Call this member to switch the visual theme of the Command Bars.
static void AFX_CDECL | SetCustomTheme (CXTPPaintManager *pTheme)
Call this member to set a custom theme.
static void AFX_CDECL | Triangle (CDC *pDC, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clr)
Draws a triangle.
static BOOL AFX_CDECL | FontExists (LPCTSTR lpszFaceName)
Determines if a specified font exists in the system.
static void AFX_CDECL | StripMnemonics (CString &strClear)
This member function will search a string, strip off the mnemonic '&', and reformat the string.
static CXTPPaintManager *AFX_CDECL | GetGlobalPaintManager ()
Call this method to get the pointer to the global paint manager.
static void AFX_CDECL | SetGlobalPaintManager (CXTPPaintManager *pPaintManager)
Call this method to set the pointer to the global paint manager.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPPaintManager
COLORREF | m_clrMessageBarText
Message bar text color.
CRect | m_rcMessageBarMargin
Margin of the message bar.
CXTPFramePaintManager * | m_pFramePaintManager
Frame paint manager.
CXTPStatusBarPaintManager * | m_pStatusBarPaintManager
Paint manager of the status bar.
CXTPRibbonPaintManager * | m_pRibbonPaintManager
Ribbon paint Manager.
CXTPControlGalleryPaintManager * | m_pGalleryPaintManager
Gallery paint manager.
CXTPProgressPaintManager * | m_pProgressPaintManager
Progress bar paint manager.
CXTPSliderPaintManager * | m_pSliderPaintManager
Slider pane paint manager.
CXTPScrollBarPaintManager * | m_pScrollBarPaintManager
Scrollbar paint manager.
CXTPPaintManagerColorGradient | m_clrDisabledIcon
Disabled icons color.
CXTPPaintManagerColor | m_clrFloatingGripper
Gripper color of floating toolbar.
CXTPPaintManagerColor | m_clrFloatingGripperText
Gripper text color of floating toolbar.
BOOL | m_bThickCheckMark
TRUE to draw thick check mark.
BOOL | m_bShowShadow
TRUE to show shadow.
BOOL | m_bThemedStatusBar
TRUE to draw status bar using WinXP theme.
BOOL | m_bThemedCheckBox
TRUE to draw check box using WinXP theme.
BOOL | m_bClearTypeTextQuality
TRUE to enable ClearType text for the font.
BOOL | m_bFlatToolBar
TRUE to draw toolbars flat.
BOOL | m_bFlatMenuBar
TRUE to draw menubar flat.
int | m_nPopupBarTextPadding
Distance between gripper and control text.
BOOL | m_bSelectImageInPopupBar
TRUE to select image as in explorer theme.
BOOL | m_bEnableAnimation
TRUE to enable animation for all toolbars.
BOOL | m_bOffice2007Padding
TRUE if Office2007 metrics used.
BOOL | m_bOffsetPopupLabelText
TRUE if labels in pop-ups drawn with offset.
BOOL | m_bWrapCaptionBelowText
Wrap text for xtpButtonIconAndCaptionBelow buttons.
CXTPPaintManagerFont | m_fontSmCaption
Small caption font.
CXTPPaintManagerFont | m_fontIcon
Icon font.
CXTPPaintManagerFont | m_fontIconBold
Icon bold font.
CXTPPaintManagerFont | m_fontToolTip
Tooltip font.
int | m_nSplitButtonDropDownWidth
Split button drop down width in toolbars.
int | m_nSplitButtonDropDownHeight
Split button drop down height in toolbars.
int | m_nSplitButtonPopupWidth
Split button drop down width in pop-ups.
BOOL | m_bAutoResizeIcons
TRUE to automatically resize icons using current DPI.
int | m_nStatusBarMinHeight
Minimum height for the status bar.
PVOID | m_pfnSetLayeredWindowAttributes
point to Transparency proc in USER32.dll module.
CRect | m_rcStatusBarBorder
Bounding rectangle of the status bar border.
BOOL | m_bUseOfficeFont
TRUE to use Tahoma font.
CString | m_strOfficeFont
Office font.
int | m_nTextHeight
Regular text field height (not font height).
- Protected Attributes inherited from CXTPCommandBarsOffice2013Theme
BOOL | m_bIntersect
TRUE to draw pop-up bar intersect rectangle.
CXTPColorSetStateMenu | m_csMenu
State colors used by Menu items.
CXTPColorSetStateMenuTitleBar | m_csMenuTitleBar
State colors used by MenuTitleBar items.
CXTPColorSetStateRibbon | m_csRibbon
State colors used by Ribbon group buttons.
CXTPColorSetStateToolbar | m_csToolbar
State colors used by Toolbar buttons.
CXTPColorSetStateCheckMark | m_csCheckMark
State colors used by Menu Check Marks.
CXTPColorSetStateComboBox | m_csComboBox
State colors used by ComboBox control.
CXTPColorSetStateCheckBox | m_csCheckBox
State colors used by Check Box and Radio Button controls.
CXTPPaintManagerColor | m_clrBack
CommandBars background color;.
CXTPPaintManagerColor | m_clrGlyph
Glyph Normal color.
CXTPPaintManagerColor | m_clrGlyphHighlight
Glyph Highlight color.
CXTPPaintManagerColor | m_clrGlyphPushed
Glyph Pushed color.
CXTPPaintManagerColor | m_clrGlyphDisabled
Glyph Disabled color.
CXTPPaintManagerColor | m_clrMessageBarText
Message bar text color.
CXTPPaintManagerColor | m_clrBtnFace
Button background color.
CXTPPaintManagerColor | m_clr3DShadow
Button shadow color.
CXTPPaintManagerColor | m_clrHighlight
Button highlight color.
CXTPPaintManagerColor | m_clrCaptionButtonFill
Text color for frame caption buttons.
CXTPPaintManagerColorGradient | m_clrWorkspace
Workspace area gradient color.
- Protected Attributes inherited from CXTPCommandBarsModernUITheme
CXTPMarkupContext * | m_pMarkupContext
Points to a valid markup context object.
CXTPResourceImages * | m_pImages
Points to a valid resource images object.
- Protected Attributes inherited from CXTPPaintManager
CXTPFont | m_xtpFontRegular
Regular font.
CXTPFont | m_xtpFontRegularBold
Regular bold font.
CXTPFont | m_xtpFontVert
Vertical font.
CXTPFont | m_xtpFontVertBold
Vertical font.
int | m_nEditHeight
Edit text height.
int | m_nFontHeight
Custom font height (optional).
BOOL | m_bUseStandardFont
TRUE to use system font.
BOOL | m_bEmbossedDisabledText
TRUE to draw disabled text embossed.
CXTPWinThemeWrapper * | m_themeStatusBar
StatusBar theme helper.
CXTPWinThemeWrapper * | m_themeButton
Buttons theme helper.
XTPPaintTheme | m_themeCurrent
Current theme.
XTP_COMMANDBARS_ICONSINFO | m_iconsInfo
Specific icons options.
int | m_nAnimationSteps
Steps of the animation.
int | m_nAnimationTime
Time of the animation.
BOOL | m_bShowKeyboardCues
TRUE to show keyboard cues - deprecated.
CXTPPaintManagerColor | m_arrColor [XPCOLOR_LAST+1]
Self colors array.
XTPCurrentSystemTheme | m_systemTheme
Current system theme.
CXTPShadowManager * | m_pShadowManager
Shadow manager.

Detailed Description

The CXTPCommandBarsVisualStudio2017Theme class is used to enable a Visual Studio 2017 style theme for Command Bars.

See also
CXTPPaintManager::SetTheme

Member Function Documentation

◆ DrawCheckRect()

virtual void DrawCheckRect | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | COLORREF | clrFore,
 |  | COLORREF | clrBack )
 protectedvirtual

Helper class called by DrawRectangle to render a checkmark background and border.

Parameters
pDC | Pointer to a valid device context.
rc | Rectangle to draw.
clrFore | RGB color value used to draw border.
clrBack | RGB color value used to draw background.

◆ DrawCommandBarGripper()

virtual CSize DrawCommandBarGripper | ( | CDC * | pDC,
 |  | CXTPCommandBar * | pBar,
 |  | BOOL | bDraw = TRUE )
 protectedvirtual

This method is called to draw the command bar's gripper.

Parameters
pDC | Pointer to a valid device context.
pBar | Pointer to a CXTPCommandBar object.
bDraw | TRUE to draw; FALSE to retrieve the size of the gripper.
Returns
Size of the gripper.

Reimplemented from CXTPCommandBarsOffice2013Theme.

◆ DrawControlComboBox()

virtual CSize DrawControlComboBox | ( | CDC * | pDC,
 |  | CXTPControlComboBox * | pComboBox,
 |  | BOOL | bDraw )
 protectedvirtual

This method is called to draw the control.

Parameters
pDC | Pointer to a valid device context.
bDraw | TRUE to draw; FALSE to retrieve the size of the control.
pComboBox | A pointer to a CXTPControlComboBox object to draw.
Returns
Size of the control.

Reimplemented from CXTPCommandBarsOffice2013Theme.

◆ DrawGalleryItemBack()

virtual void DrawGalleryItemBack | ( | CDC * | pDC,
 |  | CRect | rcItem,
 |  | BOOL | bEnabled,
 |  | BOOL | bSelected,
 |  | BOOL | bPressed,
 |  | BOOL | bChecked,
 |  | XTPBarType | barType )
 protectedvirtual

This method is called to draw the background for a gallery menu item.

Parameters
pDC | Pointer to a valid device context.
rcItem | Reference to item area rectangle coordinates.
bSelected | TRUE if the control is selected.
bPressed | TRUE if the control is pushed.
bEnabled | TRUE if the control is enabled.
bChecked | TRUE if the control is checked.
barType | Parent's bar type.

Reimplemented from CXTPCommandBarsOffice2013Theme.

◆ DrawRectangle() [1/3]

virtual void DrawRectangle | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | BOOL | bSelected,
 |  | BOOL | bPressed,
 |  | BOOL | bEnabled,
 |  | BOOL | bChecked,
 |  | BOOL | bPopuped,
 |  | XTPBarType | barType,
 |  | XTPBarPosition | barPosition )
 protectedvirtual

This method is called to fill the control's face.

Parameters
pDC | Pointer to a valid device context.
rc | Rectangle to draw.
bSelected | TRUE if the control is selected.
bPressed | TRUE if the control is pushed.
bEnabled | TRUE if the control is enabled.
bChecked | TRUE if the control is checked.
bPopuped | TRUE if the control is pop-up'ed.
barType | Parent's bar type.
barPosition | Parent's bar position.

Reimplemented from CXTPCommandBarsOffice2013Theme.

◆ DrawRectangle() [2/3]

virtual void DrawRectangle | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | BOOL | bSelected,
 |  | BOOL | bPressed,
 |  | BOOL | bEnabled,
 |  | BOOL | bChecked,
 |  | BOOL | bPopuped,
 |  | XTPBarType | barType,
 |  | XTPBarPosition | barPosition,
 |  | int | nID )
 protectedvirtual

This method is called to fill the control's face.

Parameters
pDC | Pointer to a valid device context.
rc | Rectangle to draw.
bSelected | TRUE if the control is selected.
bPressed | TRUE if the control is pushed.
bEnabled | TRUE if the control is enabled.
bChecked | TRUE if the control is checked.
bPopuped | TRUE if the control is pop-up'ed.
barType | Parent's bar type.
barPosition | Parent's bar position.
nID | Bar's control ID.

Reimplemented from CXTPCommandBarsOffice2013Theme.

◆ DrawRectangle() [3/3]

virtual BOOL DrawRectangle | ( | CDC * | pDC,
 |  | CXTPControl * | pButton )
 protectedvirtual

This method is called to fill the control's face.

Parameters
pDC | Pointer to a valid device context.
pButton | pointer to a button
Returns
TRUE if the rectange was drawn, otherwise FALSE.

Reimplemented from CXTPCommandBarsOffice2013Theme.

◆ DrawSplitButtonFrame()

virtual void DrawSplitButtonFrame | ( | CDC * | pDC,
 |  | CXTPControl * | pButton,
 |  | CRect | rc )
 protectedvirtual

This method is called to draw the frame for the SplitButton control.

Parameters
pDC | Pointer to a valid device context.
pButton | Pointer to a CXTPControl object.
rc | Bounding rectangle to draw.

Reimplemented from CXTPCommandBarsOffice2013Theme.

◆ GetControlTextColor()

virtual COLORREF GetControlTextColor ( CXTPControl * pButton )
protectedvirtual

This method returns the control text color to draw.

Parameters
pButton Points to a CXTPControl object to draw.
Returns
Returns control text color

Reimplemented from CXTPCommandBarsOffice2013Theme.

◆ GetStateColor()

virtual COLORREF GetStateColor ( ) const
virtual

Call this member function to get the application state color for the frame border and status bar.

Returns
COLORREF value representing the application state color.

◆ SetStateColor()

virtual void SetStateColor ( COLORREF clrState = COLORREF_NULL )
virtual

Call this member function to set the application state color for the frame border and status bar.

Parameters
clrState COLORREF value representing the application state color. Use COLORREF_NULL to reset back to default color.
The documentation for this class was generated from the following file:
  • XTPCommandBarsVisualStudio2017Theme.h


Toolkit Pro: CXTPCommandBarsVisualStudio2019Theme Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPCommandBarsVisualStudio2019Theme Class Reference

The CXTPCommandBarsVisualStudio2019Theme class is used to enable a Visual Studio 2019 style theme for Command Bars. More...

Inheritance diagram for CXTPCommandBarsVisualStudio2019Theme:
[legend]

Public Member Functions

CXTPCommandBarsVisualStudio2019Theme ()
Constructs a CXTPCommandBarsVisualStudio2019Theme object.
virtual | ~CXTPCommandBarsVisualStudio2019Theme ()
Destroys a CXTPCommandBarsVisualStudio2019Theme object, handles cleanup and deallocation.
virtual void | SetStateColor (COLORREF clrState=COLORREF_NULL)
Call this member function to set the application state color for the frame border and status bar.
virtual COLORREF | GetStateColor () const
Call this member function to get the application state color for the frame border and status bar.
- Public Member Functions inherited from CXTPCommandBarsOffice2013Theme
CXTPCommandBarsOffice2013Theme ()
Constructs a CXTPCommandBarsOffice2013Theme object.
virtual | ~CXTPCommandBarsOffice2013Theme ()
Destroys a CXTPCommandBarsOffice2013Theme object, handles cleanup and deallocation.
virtual XTPPaintTheme | BaseTheme ()
Retrieves the base theme of the manager.
virtual void | FillCommandBarEntry (CDC *pDC, CXTPCommandBar *pBar)
This method is called to fill the command bar's face.
virtual void | FillDockBar (CDC *pDC, CXTPDockBar *pBar)
This method is called to fill a dock bar.
virtual void | DrawCommandBarGroupSeparator (CDC *pDC, CXTPCommandBar *pBar, CXTPControl *pLeftControl, CXTPControl *pRightControl, BOOL bDraw)
This method is called to draw a command bar's group separator.
virtual CSize | DrawControlEdit (CDC *pDC, CXTPControlEdit *pEdit, BOOL bDraw)
This method is called to draw the control.
virtual void | FillWorkspace (CDC *pDC, CRect rc, CRect rcExclude)
Draws workspace space.
virtual BOOL | RequiresResourceImages ()
Used by the paint manager to determine if the theme requires a resource DLL to load image and color information.
virtual COLORREF | GetControlEditBackColor (CXTPControl *pControl)
This method returns the edit control back color to draw.
- Public Member Functions inherited from CXTPCommandBarsModernUITheme
CXTPCommandBarsModernUITheme ()
Constructs a CXTPCommandBarsModernUITheme object.
virtual | ~CXTPCommandBarsModernUITheme ()
Destroys a CXTPCommandBarsModernUITheme object, handles cleanup and deallocation.
virtual CXTPFramePaintManager * | GetFramePaintManager ()
Returns paint manager used to draw frames.
virtual CXTPRibbonPaintManager * | GetRibbonPaintManager ()
Retrieves the ribbon paint manager.
virtual CXTPMarkupContext * | GetMarkupContext ()
Retrieves a pointer to the markup context.
- Public Member Functions inherited from CXTPCommandBarsOfficeXPTheme
CXTPCommandBarsOfficeXPTheme ()
Constructs a CXTPCommandBarsOfficeXPTheme object.
virtual CSize | DrawListBoxControl (CDC *pDC, CXTPControl *pButton, CRect rc, BOOL bSelected, BOOL bDraw, CXTPCommandBars *pCommandBars=0)
This method is called to draw the control placed on the ListBox.
virtual void | AdjustExcludeRect (CRect &rc, CXTPControl *pControl, BOOL bVertical)
This method is called to determine the offset of a pop-up bar.
virtual CSize | DrawTearOffGripper (CDC *pDC, CRect rcGripper, BOOL bSelected, BOOL bDraw)
This method is called to draw a tear-off gripper of a pop-up bar.
virtual void | DrawPopupResizeGripper (CDC *pDC, CRect rcGripper, int nFlags)
This method is called to draw a resize gripper of a pop-up bar.
virtual CSize | DrawDialogBarGripper (CDC *pDC, CXTPDialogBar *pBar, BOOL bDraw)
Call this member to draw the gripper of a dialog bar.
- Public Member Functions inherited from CXTPPaintManager
virtual void | SetImageHandle (HMODULE hResource, LPCTSTR lpszIniFileName)
Specifies the resource that contains the bitmaps to be loaded for the theme.
CSize | DrawControl (CDC *pDC, CXTPControl *pButton, BOOL bDraw=TRUE)
This method is called to draw the control.
virtual CSize | DrawControlToolBarParent (CDC *pDC, CXTPControl *pButton, BOOL bDraw)
This method is called to draw the control placed on the toolbar.
virtual void | DrawControlEntry (CDC *pDC, CXTPControl *pButton)
This method is called to fill the control's face.
int | GetShadowOptions () const
Determines the kind of shadow to use.
virtual CSize | DrawSpecialControl (CDC *pDC, XTPSpecialControl controlType, CXTPControl *pButton, CXTPCommandBar *pBar, BOOL bDraw, LPVOID lpParam)
This method is called to draw the specified controls.
virtual CRect | GetCommandBarBorders (CXTPCommandBar *pBar)
This method is called to retrieve the command bar's borders.
virtual CRect | GetSplitButtonCommandRect (CXTPControl *pButton)
Determines split button command rectangle.
virtual void | SetCommandBarRegion (CXTPCommandBar *pCommandBar)
Call this method to set the bounding region of a pop-up bar.
XTPPaintTheme GetCurrentTheme ()
Call this member to get the current visual theme.
virtual CFont * | GetControlFont (CXTPControl *pControl)
Call this member to retrieve the font of the command bar control.
virtual CFont * | GetCommandBarFont (CXTPCommandBar *pCommandBar)
Call this member to retrieve the font of the command bar.
virtual XTPBarTextOrientation | GetControlTextOrientation (CXTPControl *pControl)
Call this member to determine how to draw text.
virtual void | UpdateFonts ()
Refreshes the fonts to use.
virtual void | UpdateColors ()
Refreshes the standard colors to use.
void | SetCommandBarsFontIndirect (LOGFONT *pLogFont, BOOL bUseStandardFont=FALSE)
Call this member to set command bar's font.
CFont * | GetRegularFont ()
Returns the general font.
CFont * | GetRegularBoldFont ()
Returns the general bold font.
CFont * | GetIconFont ()
Returns the icon font.
CFont * | GetSmCaptionFont ()
Call this method to retrieve the caption of a floating mini frame.
void | UseOfficeFont (bool bUseOfficeFont)
Call this method to use Tahoma font despite system metrics.
int | GetControlHeight () const
This method returns the common controls height.
virtual CSize | GetDefaultCommandBarSize (CXTPCommandBar *pBar)
Computes default command bar size taking into account command bar font.
void | Rectangle (CDC *pDC, LPCRECT rc, int nPen, const int nBrush)
Draws a rectangle.
void | Rectangle (CDC *pDC, LPCRECT rc, COLORREF clrPen, COLORREF clrBrush)
Draws a rectangle.
void | RoundRect (CDC *pDC, LPCRECT rc, COLORREF clrPen, COLORREF clrBrush)
Draws a rectangle.
void | Draw3dRect (CDC *pDC, LPCRECT rc, int nTopLeft, int nBottomRight)
Call this member function to draw a three-dimensional rectangle.
void | Draw3dRect (CDC *pDC, LPCRECT rc, int frameThickness, COLORREF clrPen, COLORREF clrBrush)
Call this member function to draw a rectangle with predetermined thickness.
virtual void | DrawPopupBarCheckMark (CDC *pDC, CRect rcCheck, BOOL bEnabled, COLORREF clr)
Call this member function to draw a check mark.
void | DrawCheckMark (CDC *pDC, CRect rcCheck, COLORREF clr=0)
Call this member function to draw a check mark.
virtual void | DrawPopupBarRadioMark (CDC *pDC, CRect rcCheck, BOOL bEnabled, COLORREF clr)
Call this member function to draw a radio button.
virtual void | DrawComboExpandMark (CDC *pDC, CRect rc, COLORREF clr)
Call this member function to draw a combobox expand symbol.
void | Line (CDC *pDC, CPoint p0, CPoint p1)
Draws a line.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1, const int nPen)
Draws a line.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1, COLORREF clrPen)
Draws a line.
void | HorizontalLine (CDC *pDC, int x0, int y0, int x1, COLORREF clrPen)
Call this member function to draw a horizontal line using the specified coordinages and RGB color value.
void | VerticalLine (CDC *pDC, int x0, int y0, int y1, COLORREF clrPen)
Call this member function to draw a vertical line using the specified coordinages and RGB color value.
void | Pixel (CDC *pDC, int xPos, int yPos, int nPen)
Sets the pixel at the point.
void | GradientFill (CDC *pDC, LPRECT lpRect, COLORREF crFrom, COLORREF crTo, BOOL bHorz, LPCRECT lpRectClip=NULL)
Gradient fills the rectangle.
XTP_COMMANDBARS_ICONSINFO * GetIconsInfo ()
virtual void | Animate (CDC *pDestDC, CDC *pSrcDC, CRect rc, XTPAnimationType animationType)
This method is called to animate the pop-up bar.
virtual void | AnimateExpanding (CXTPCommandBar *pCommandBar, CDC *pDestDC, CDC *pSrcDC, BOOL bExpandDown)
This method is called to animate the expanding process.
void | SetAnimationDelay (int nAnimationSteps, int nAnimationTime)
Call this method to set animation delay.
COLORREF | GetXtremeColor (UINT nIndex)
This function retrieves the current color of the specified XP display element.
void | SetColors (int cElements, CONST INT *lpaElements, CONST COLORREF *lpaRgbValues)
Call this member to set the colors for each element to the color in the specified color array.
CSize | DrawControlText (CDC *pDC, CXTPControl *pControl, CRect rcText, BOOL bDraw, BOOL bVert, BOOL bCentered, BOOL bTriangled)
This method is called to draw control text.
virtual void | UpdateRTLCaption (CString &strCaption)
This method is called to prepare a caption for Right-To-Left draw.
XTPCurrentSystemTheme GetCurrentSystemTheme ()
Call this member function to determine the current Windows XP theme in use.
void | SetLunaTheme (XTPCurrentSystemTheme systemTheme)
Call this method to force system theme.
virtual int | GetPopupBarGripperWidth (CXTPCommandBar *pBar)
Calculates the gripper of a pop-up bar.
virtual CXTPControlGalleryPaintManager * | GetGalleryPaintManager () const
Retrieves paint manager used to draw galleries.
virtual CXTPScrollBarPaintManager * | GetScrollBarPaintManager () const
Retrieves paint manager used to draw scrollbars.
virtual CXTPSliderPaintManager * | GetSliderPaintManager () const
Retrieves paint manager used to draw slider panes.
virtual CXTPProgressPaintManager * | GetProgressPaintManager () const
Retrieves paint manager used to draw progress bars.
virtual CXTPStatusBarPaintManager * | GetStatusBarPaintManager ()
Retrieves paint manager used to draw the status bar.
virtual CXTPMessageBarPaintManager * | GetMessageBarPaintManager ()
Retrieves paint manager used to draw message bars.
CXTPShadowManager * | GetShadowManager () const
Retrieves shadow manager used to draw shadows.
BOOL | IsUseSystemAccentColorEnabled () const
Determines whether xtpApplicationUseSystemAccentColor application ambient property is set.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.
- Public Member Functions inherited from CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents >
void | Subscribe (IXTPPaintManagerEvents *pObserver, CXTPSubscriptionList< CXTPPaintManager, IXTPPaintManagerEvents > *pSubcriptionList=NULL)
Subscribes a unique observer for events.
void | Unsubscribe (IXTPPaintManagerEvents *pObserver)
Unsubscribes an observer from events.
void | Notify (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *))
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *))
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.

Protected Member Functions

virtual void | DrawSplitButtonFrame (CDC *pDC, CXTPControl *pButton, CRect rc)
This method is called to draw the frame for the SplitButton control.
virtual void | DrawRectangle (CDC *pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition)
This method is called to fill the control's face.
virtual void | DrawRectangle (CDC *pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition, int nID)
This method is called to fill the control's face.
virtual BOOL | DrawRectangle (CDC *pDC, CXTPControl *pButton)
This method is called to fill the control's face.
virtual COLORREF | GetControlTextColor (CXTPControl *pButton)
This method returns the control text color to draw.
virtual void | DrawGalleryItemBack (CDC *pDC, CRect rcItem, BOOL bEnabled, BOOL bSelected, BOOL bPressed, BOOL bChecked, XTPBarType barType)
This method is called to draw the background for a gallery menu item.
virtual void | DrawCheckRect (CDC *pDC, CRect rc, COLORREF clrFore, COLORREF clrBack)
Helper class called by DrawRectangle to render a checkmark background and border.
virtual CSize | DrawCommandBarGripper (CDC *pDC, CXTPCommandBar *pBar, BOOL bDraw=TRUE)
This method is called to draw the command bar's gripper.
virtual CSize | DrawControlComboBox (CDC *pDC, CXTPControlComboBox *pComboBox, BOOL bDraw)
This method is called to draw the control.
- Protected Member Functions inherited from CXTPCommandBarsOffice2013Theme
virtual void | RefreshMetrics ()
This method is called to refresh the visual metrics of the manager.
virtual void | RefreshStandardColors ()
Called to update the standard colors used by the framework.
virtual COLORREF | GetRectangleTextColor (BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition)
This method retrieves a buttons text color.
virtual COLORREF | GetControlBackColor (CXTPControl *pButton)
Call this method to get the control back color to draw.
void | DrawFrameBorder (CDC *pDC, CRect rc, int nBorderThickness, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition)
This method is called to fill the border of the control's face.
virtual void | DrawPopupBarGripper (CDC *pDC, int xPos, int yPos, int cx, int cy, BOOL bExpanded=FALSE)
This method is called to draw a pop-up bar's right gripper.
virtual void | DrawDropDownGlyph (CDC *pDC, CXTPControl *pControl, CPoint pt, BOOL bSelected, BOOL bPopuped, BOOL bEnabled, BOOL bVert)
This member function is called to draw a split button expand symbol.
virtual CSize | DrawCommandBarSeparator (CDC *pDC, CXTPCommandBar *pBar, CXTPControl *pControl, BOOL bDraw=TRUE)
This method is called to draw a command bar's separator.
virtual void | DrawExpandGlyph (CDC *pDC, CXTPControl *pButton, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clr)
Draw expand or hidden glyphs for a button.
virtual void | DrawHiddenGlyph (CDC *pDC, CXTPControl *pButton, COLORREF clr, BOOL bVertical)
Draw expand or hidden glyphs for a button.
virtual void | DrawExpandGlyph (CDC *pDC, CXTPControl *pButton, COLORREF clr, BOOL bVertical)
Draw expand or hidden glyphs for a button.
virtual CSize | DrawControlCheckBoxMark (CDC *pDC, CXTPControl *pButton, CRect rc, BOOL bDraw)
This method is called to draw a check box mark area.
virtual CSize | DrawControlCheckBoxMark (CDC *pDC, CRect rc, BOOL bDraw, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled)
This method is called to draw a check box mark area.
virtual CSize | DrawControlRadioButtonMark (CDC *pDC, CRect rc, BOOL bDraw, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled)
This method is called to draw a radio button mark area.
virtual void | DrawControlMDIButton (CDC *pDC, CXTPControlButton *pButton)
Call this member function to draw Menu MDI buttons.
- Protected Member Functions inherited from CXTPCommandBarsModernUITheme
- Protected Member Functions inherited from CXTPCommandBarsOfficeXPTheme
virtual CSize | DrawControlPopupParent (CDC *pDC, CXTPControl *pButton, BOOL bDraw)
This method is called to draw the control placed on the pop-up bar.
virtual void | DrawImage (CDC *pDC, CPoint pt, CSize sz, CXTPImageManagerIcon *pImage, BOOL bSelected, BOOL bPressed, BOOL bEnabled=TRUE, BOOL bChecked=FALSE, BOOL bPopuped=FALSE, BOOL bToolBarImage=TRUE)
This method is called to draw the image of the control.
void | FillIntersectRect (CDC *pDC, CXTPPopupBar *pPopupBar, COLORREF clr)
Draws intersect rectangle of a pop-up bar and its control.
- Protected Member Functions inherited from CXTPPaintManager
CXTPPaintManager ()
Constructs a CXTPPaintManager object.
virtual | ~CXTPPaintManager ()
Destroys a CXTPPaintManager object, handles cleanup and deallocation.
- Protected Member Functions inherited from CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents >
CXTPObservable ()
Constructs an observable object.
~CXTPObservable ()
Handles observable object destruction.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPPaintManager
static CXTPPaintManager *AFX_CDECL | GetInstanceAddRef ()
Obtains a pointer to a global paint manager object and increments its reference counter.
static void AFX_CDECL | ReleaseInstance ()
Decrements global paint manager's reference counter and deletes its instance when the reference counter reaches 0.
static CXTPPaintManager *AFX_CDECL | CreateTheme (XTPPaintTheme paintTheme)
Creates a new CXTPPaintManager object.
static void AFX_CDECL | SetTheme (XTPPaintTheme paintTheme)
Call this member to switch the visual theme of the Command Bars.
static void AFX_CDECL | SetCustomTheme (CXTPPaintManager *pTheme)
Call this member to set a custom theme.
static void AFX_CDECL | Triangle (CDC *pDC, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clr)
Draws a triangle.
static BOOL AFX_CDECL | FontExists (LPCTSTR lpszFaceName)
Determines if a specified font exists in the system.
static void AFX_CDECL | StripMnemonics (CString &strClear)
This member function will search a string, strip off the mnemonic '&', and reformat the string.
static CXTPPaintManager *AFX_CDECL | GetGlobalPaintManager ()
Call this method to get the pointer to the global paint manager.
static void AFX_CDECL | SetGlobalPaintManager (CXTPPaintManager *pPaintManager)
Call this method to set the pointer to the global paint manager.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPPaintManager
COLORREF | m_clrMessageBarText
Message bar text color.
CRect | m_rcMessageBarMargin
Margin of the message bar.
CXTPFramePaintManager * | m_pFramePaintManager
Frame paint manager.
CXTPStatusBarPaintManager * | m_pStatusBarPaintManager
Paint manager of the status bar.
CXTPRibbonPaintManager * | m_pRibbonPaintManager
Ribbon paint Manager.
CXTPControlGalleryPaintManager * | m_pGalleryPaintManager
Gallery paint manager.
CXTPProgressPaintManager * | m_pProgressPaintManager
Progress bar paint manager.
CXTPSliderPaintManager * | m_pSliderPaintManager
Slider pane paint manager.
CXTPScrollBarPaintManager * | m_pScrollBarPaintManager
Scrollbar paint manager.
CXTPPaintManagerColorGradient | m_clrDisabledIcon
Disabled icons color.
CXTPPaintManagerColor | m_clrFloatingGripper
Gripper color of floating toolbar.
CXTPPaintManagerColor | m_clrFloatingGripperText
Gripper text color of floating toolbar.
BOOL | m_bThickCheckMark
TRUE to draw thick check mark.
BOOL | m_bShowShadow
TRUE to show shadow.
BOOL | m_bThemedStatusBar
TRUE to draw status bar using WinXP theme.
BOOL | m_bThemedCheckBox
TRUE to draw check box using WinXP theme.
BOOL | m_bClearTypeTextQuality
TRUE to enable ClearType text for the font.
BOOL | m_bFlatToolBar
TRUE to draw toolbars flat.
BOOL | m_bFlatMenuBar
TRUE to draw menubar flat.
int | m_nPopupBarTextPadding
Distance between gripper and control text.
BOOL | m_bSelectImageInPopupBar
TRUE to select image as in explorer theme.
BOOL | m_bEnableAnimation
TRUE to enable animation for all toolbars.
BOOL | m_bOffice2007Padding
TRUE if Office2007 metrics used.
BOOL | m_bOffsetPopupLabelText
TRUE if labels in pop-ups drawn with offset.
BOOL | m_bWrapCaptionBelowText
Wrap text for xtpButtonIconAndCaptionBelow buttons.
CXTPPaintManagerFont | m_fontSmCaption
Small caption font.
CXTPPaintManagerFont | m_fontIcon
Icon font.
CXTPPaintManagerFont | m_fontIconBold
Icon bold font.
CXTPPaintManagerFont | m_fontToolTip
Tooltip font.
int | m_nSplitButtonDropDownWidth
Split button drop down width in toolbars.
int | m_nSplitButtonDropDownHeight
Split button drop down height in toolbars.
int | m_nSplitButtonPopupWidth
Split button drop down width in pop-ups.
BOOL | m_bAutoResizeIcons
TRUE to automatically resize icons using current DPI.
int | m_nStatusBarMinHeight
Minimum height for the status bar.
PVOID | m_pfnSetLayeredWindowAttributes
point to Transparency proc in USER32.dll module.
CRect | m_rcStatusBarBorder
Bounding rectangle of the status bar border.
BOOL | m_bUseOfficeFont
TRUE to use Tahoma font.
CString | m_strOfficeFont
Office font.
int | m_nTextHeight
Regular text field height (not font height).
- Protected Attributes inherited from CXTPCommandBarsOffice2013Theme
BOOL | m_bIntersect
TRUE to draw pop-up bar intersect rectangle.
CXTPColorSetStateMenu | m_csMenu
State colors used by Menu items.
CXTPColorSetStateMenuTitleBar | m_csMenuTitleBar
State colors used by MenuTitleBar items.
CXTPColorSetStateRibbon | m_csRibbon
State colors used by Ribbon group buttons.
CXTPColorSetStateToolbar | m_csToolbar
State colors used by Toolbar buttons.
CXTPColorSetStateCheckMark | m_csCheckMark
State colors used by Menu Check Marks.
CXTPColorSetStateComboBox | m_csComboBox
State colors used by ComboBox control.
CXTPColorSetStateCheckBox | m_csCheckBox
State colors used by Check Box and Radio Button controls.
CXTPPaintManagerColor | m_clrBack
CommandBars background color;.
CXTPPaintManagerColor | m_clrGlyph
Glyph Normal color.
CXTPPaintManagerColor | m_clrGlyphHighlight
Glyph Highlight color.
CXTPPaintManagerColor | m_clrGlyphPushed
Glyph Pushed color.
CXTPPaintManagerColor | m_clrGlyphDisabled
Glyph Disabled color.
CXTPPaintManagerColor | m_clrMessageBarText
Message bar text color.
CXTPPaintManagerColor | m_clrBtnFace
Button background color.
CXTPPaintManagerColor | m_clr3DShadow
Button shadow color.
CXTPPaintManagerColor | m_clrHighlight
Button highlight color.
CXTPPaintManagerColor | m_clrCaptionButtonFill
Text color for frame caption buttons.
CXTPPaintManagerColorGradient | m_clrWorkspace
Workspace area gradient color.
- Protected Attributes inherited from CXTPCommandBarsModernUITheme
CXTPMarkupContext * | m_pMarkupContext
Points to a valid markup context object.
CXTPResourceImages * | m_pImages
Points to a valid resource images object.
- Protected Attributes inherited from CXTPPaintManager
CXTPFont | m_xtpFontRegular
Regular font.
CXTPFont | m_xtpFontRegularBold
Regular bold font.
CXTPFont | m_xtpFontVert
Vertical font.
CXTPFont | m_xtpFontVertBold
Vertical font.
int | m_nEditHeight
Edit text height.
int | m_nFontHeight
Custom font height (optional).
BOOL | m_bUseStandardFont
TRUE to use system font.
BOOL | m_bEmbossedDisabledText
TRUE to draw disabled text embossed.
CXTPWinThemeWrapper * | m_themeStatusBar
StatusBar theme helper.
CXTPWinThemeWrapper * | m_themeButton
Buttons theme helper.
XTPPaintTheme | m_themeCurrent
Current theme.
XTP_COMMANDBARS_ICONSINFO | m_iconsInfo
Specific icons options.
int | m_nAnimationSteps
Steps of the animation.
int | m_nAnimationTime
Time of the animation.
BOOL | m_bShowKeyboardCues
TRUE to show keyboard cues - deprecated.
CXTPPaintManagerColor | m_arrColor [XPCOLOR_LAST+1]
Self colors array.
XTPCurrentSystemTheme | m_systemTheme
Current system theme.
CXTPShadowManager * | m_pShadowManager
Shadow manager.

Detailed Description

The CXTPCommandBarsVisualStudio2019Theme class is used to enable a Visual Studio 2019 style theme for Command Bars.

See also
CXTPPaintManager::SetTheme

Member Function Documentation

◆ DrawCheckRect()

virtual void DrawCheckRect | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | COLORREF | clrFore,
 |  | COLORREF | clrBack )
 protectedvirtual

Helper class called by DrawRectangle to render a checkmark background and border.

Parameters
pDC | Pointer to a valid device context.
rc | Rectangle to draw.
clrFore | RGB color value used to draw border.
clrBack | RGB color value used to draw background.

◆ DrawCommandBarGripper()

virtual CSize DrawCommandBarGripper | ( | CDC * | pDC,
 |  | CXTPCommandBar * | pBar,
 |  | BOOL | bDraw = TRUE )
 protectedvirtual

This method is called to draw the command bar's gripper.

Parameters
pDC | Pointer to a valid device context.
pBar | Pointer to a CXTPCommandBar object.
bDraw | TRUE to draw; FALSE to retrieve the size of the gripper.
Returns
Size of the gripper.

Reimplemented from CXTPCommandBarsOffice2013Theme.

◆ DrawControlComboBox()

virtual CSize DrawControlComboBox | ( | CDC * | pDC,
 |  | CXTPControlComboBox * | pComboBox,
 |  | BOOL | bDraw )
 protectedvirtual

This method is called to draw the control.

Parameters
pDC | Pointer to a valid device context.
bDraw | TRUE to draw; FALSE to retrieve the size of the control.
pComboBox | A pointer to a CXTPControlComboBox object to draw.
Returns
Size of the control.

Reimplemented from CXTPCommandBarsOffice2013Theme.

◆ DrawGalleryItemBack()

virtual void DrawGalleryItemBack | ( | CDC * | pDC,
 |  | CRect | rcItem,
 |  | BOOL | bEnabled,
 |  | BOOL | bSelected,
 |  | BOOL | bPressed,
 |  | BOOL | bChecked,
 |  | XTPBarType | barType )
 protectedvirtual

This method is called to draw the background for a gallery menu item.

Parameters
pDC | Pointer to a valid device context.
rcItem | Reference to item area rectangle coordinates.
bSelected | TRUE if the control is selected.
bPressed | TRUE if the control is pushed.
bEnabled | TRUE if the control is enabled.
bChecked | TRUE if the control is checked.
barType | Parent's bar type.

Reimplemented from CXTPCommandBarsOffice2013Theme.

◆ DrawRectangle() [1/3]

virtual void DrawRectangle | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | BOOL | bSelected,
 |  | BOOL | bPressed,
 |  | BOOL | bEnabled,
 |  | BOOL | bChecked,
 |  | BOOL | bPopuped,
 |  | XTPBarType | barType,
 |  | XTPBarPosition | barPosition )
 protectedvirtual

This method is called to fill the control's face.

Parameters
pDC | Pointer to a valid device context.
rc | Rectangle to draw.
bSelected | TRUE if the control is selected.
bPressed | TRUE if the control is pushed.
bEnabled | TRUE if the control is enabled.
bChecked | TRUE if the control is checked.
bPopuped | TRUE if the control is pop-up'ed.
barType | Parent's bar type.
barPosition | Parent's bar position.

Reimplemented from CXTPCommandBarsOffice2013Theme.

◆ DrawRectangle() [2/3]

virtual void DrawRectangle | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | BOOL | bSelected,
 |  | BOOL | bPressed,
 |  | BOOL | bEnabled,
 |  | BOOL | bChecked,
 |  | BOOL | bPopuped,
 |  | XTPBarType | barType,
 |  | XTPBarPosition | barPosition,
 |  | int | nID )
 protectedvirtual

This method is called to fill the control's face.

Parameters
pDC | Pointer to a valid device context.
rc | Rectangle to draw.
bSelected | TRUE if the control is selected.
bPressed | TRUE if the control is pushed.
bEnabled | TRUE if the control is enabled.
bChecked | TRUE if the control is checked.
bPopuped | TRUE if the control is pop-up'ed.
barType | Parent's bar type.
barPosition | Parent's bar position.
nID | Bar's control ID.

Reimplemented from CXTPCommandBarsOffice2013Theme.

◆ DrawRectangle() [3/3]

virtual BOOL DrawRectangle | ( | CDC * | pDC,
 |  | CXTPControl * | pButton )
 protectedvirtual

This method is called to fill the control's face.

Parameters
pDC | Pointer to a valid device context.
pButton | pointer to a button
Returns
TRUE if the rectange was drawn, otherwise FALSE.

Reimplemented from CXTPCommandBarsOffice2013Theme.

◆ DrawSplitButtonFrame()

virtual void DrawSplitButtonFrame | ( | CDC * | pDC,
 |  | CXTPControl * | pButton,
 |  | CRect | rc )
 protectedvirtual

This method is called to draw the frame for the SplitButton control.

Parameters
pDC | Pointer to a valid device context.
pButton | Pointer to a CXTPControl object.
rc | Bounding rectangle to draw.

Reimplemented from CXTPCommandBarsOffice2013Theme.

◆ GetControlTextColor()

virtual COLORREF GetControlTextColor ( CXTPControl * pButton )
protectedvirtual

This method returns the control text color to draw.

Parameters
pButton Points to a CXTPControl object to draw.
Returns
Returns control text color

Reimplemented from CXTPCommandBarsOffice2013Theme.

◆ GetStateColor()

virtual COLORREF GetStateColor ( ) const
virtual

Call this member function to get the application state color for the frame border and status bar.

Returns
COLORREF value representing the application state color.

◆ SetStateColor()

virtual void SetStateColor ( COLORREF clrState = COLORREF_NULL )
virtual

Call this member function to set the application state color for the frame border and status bar.

Parameters
clrState COLORREF value representing the application state color. Use COLORREF_NULL to reset back to default color.
The documentation for this class was generated from the following file:
  • XTPCommandBarsVisualStudio2019Theme.h


Toolkit Pro: CXTPCommandBarsVisualStudio2022Theme Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPCommandBarsVisualStudio2022Theme Class Reference

The CXTPCommandBarsVisualStudio2022Theme class is used to enable a Visual Studio 2022 style theme for Command Bars. More...

Inheritance diagram for CXTPCommandBarsVisualStudio2022Theme:
[legend]

Public Member Functions

CXTPCommandBarsVisualStudio2022Theme ()
Constructs a CXTPCommandBarsVisualStudio2022Theme object.
virtual | ~CXTPCommandBarsVisualStudio2022Theme ()
Destroys a CXTPCommandBarsVisualStudio2022Theme object, handles cleanup and deallocation.
virtual void | SetStateColor (COLORREF clrState=COLORREF_NULL)
Call this member function to set the application state color for the frame border and status bar.
virtual COLORREF | GetStateColor () const
Call this member function to get the application state color for the frame border and status bar.
- Public Member Functions inherited from CXTPCommandBarsOffice2013Theme
CXTPCommandBarsOffice2013Theme ()
Constructs a CXTPCommandBarsOffice2013Theme object.
virtual | ~CXTPCommandBarsOffice2013Theme ()
Destroys a CXTPCommandBarsOffice2013Theme object, handles cleanup and deallocation.
virtual XTPPaintTheme | BaseTheme ()
Retrieves the base theme of the manager.
virtual void | FillCommandBarEntry (CDC *pDC, CXTPCommandBar *pBar)
This method is called to fill the command bar's face.
virtual void | FillDockBar (CDC *pDC, CXTPDockBar *pBar)
This method is called to fill a dock bar.
virtual void | DrawCommandBarGroupSeparator (CDC *pDC, CXTPCommandBar *pBar, CXTPControl *pLeftControl, CXTPControl *pRightControl, BOOL bDraw)
This method is called to draw a command bar's group separator.
virtual CSize | DrawControlEdit (CDC *pDC, CXTPControlEdit *pEdit, BOOL bDraw)
This method is called to draw the control.
virtual void | FillWorkspace (CDC *pDC, CRect rc, CRect rcExclude)
Draws workspace space.
virtual BOOL | RequiresResourceImages ()
Used by the paint manager to determine if the theme requires a resource DLL to load image and color information.
virtual COLORREF | GetControlEditBackColor (CXTPControl *pControl)
This method returns the edit control back color to draw.
- Public Member Functions inherited from CXTPCommandBarsModernUITheme
CXTPCommandBarsModernUITheme ()
Constructs a CXTPCommandBarsModernUITheme object.
virtual | ~CXTPCommandBarsModernUITheme ()
Destroys a CXTPCommandBarsModernUITheme object, handles cleanup and deallocation.
virtual CXTPFramePaintManager * | GetFramePaintManager ()
Returns paint manager used to draw frames.
virtual CXTPRibbonPaintManager * | GetRibbonPaintManager ()
Retrieves the ribbon paint manager.
virtual CXTPMarkupContext * | GetMarkupContext ()
Retrieves a pointer to the markup context.
- Public Member Functions inherited from CXTPCommandBarsOfficeXPTheme
CXTPCommandBarsOfficeXPTheme ()
Constructs a CXTPCommandBarsOfficeXPTheme object.
virtual CSize | DrawListBoxControl (CDC *pDC, CXTPControl *pButton, CRect rc, BOOL bSelected, BOOL bDraw, CXTPCommandBars *pCommandBars=0)
This method is called to draw the control placed on the ListBox.
virtual void | AdjustExcludeRect (CRect &rc, CXTPControl *pControl, BOOL bVertical)
This method is called to determine the offset of a pop-up bar.
virtual CSize | DrawTearOffGripper (CDC *pDC, CRect rcGripper, BOOL bSelected, BOOL bDraw)
This method is called to draw a tear-off gripper of a pop-up bar.
virtual void | DrawPopupResizeGripper (CDC *pDC, CRect rcGripper, int nFlags)
This method is called to draw a resize gripper of a pop-up bar.
virtual CSize | DrawDialogBarGripper (CDC *pDC, CXTPDialogBar *pBar, BOOL bDraw)
Call this member to draw the gripper of a dialog bar.
- Public Member Functions inherited from CXTPPaintManager
virtual void | SetImageHandle (HMODULE hResource, LPCTSTR lpszIniFileName)
Specifies the resource that contains the bitmaps to be loaded for the theme.
CSize | DrawControl (CDC *pDC, CXTPControl *pButton, BOOL bDraw=TRUE)
This method is called to draw the control.
virtual CSize | DrawControlToolBarParent (CDC *pDC, CXTPControl *pButton, BOOL bDraw)
This method is called to draw the control placed on the toolbar.
virtual void | DrawControlEntry (CDC *pDC, CXTPControl *pButton)
This method is called to fill the control's face.
int | GetShadowOptions () const
Determines the kind of shadow to use.
virtual CSize | DrawSpecialControl (CDC *pDC, XTPSpecialControl controlType, CXTPControl *pButton, CXTPCommandBar *pBar, BOOL bDraw, LPVOID lpParam)
This method is called to draw the specified controls.
virtual CRect | GetCommandBarBorders (CXTPCommandBar *pBar)
This method is called to retrieve the command bar's borders.
virtual CRect | GetSplitButtonCommandRect (CXTPControl *pButton)
Determines split button command rectangle.
virtual void | SetCommandBarRegion (CXTPCommandBar *pCommandBar)
Call this method to set the bounding region of a pop-up bar.
XTPPaintTheme GetCurrentTheme ()
Call this member to get the current visual theme.
virtual CFont * | GetControlFont (CXTPControl *pControl)
Call this member to retrieve the font of the command bar control.
virtual CFont * | GetCommandBarFont (CXTPCommandBar *pCommandBar)
Call this member to retrieve the font of the command bar.
virtual XTPBarTextOrientation | GetControlTextOrientation (CXTPControl *pControl)
Call this member to determine how to draw text.
virtual void | UpdateFonts ()
Refreshes the fonts to use.
virtual void | UpdateColors ()
Refreshes the standard colors to use.
void | SetCommandBarsFontIndirect (LOGFONT *pLogFont, BOOL bUseStandardFont=FALSE)
Call this member to set command bar's font.
CFont * | GetRegularFont ()
Returns the general font.
CFont * | GetRegularBoldFont ()
Returns the general bold font.
CFont * | GetIconFont ()
Returns the icon font.
CFont * | GetSmCaptionFont ()
Call this method to retrieve the caption of a floating mini frame.
void | UseOfficeFont (bool bUseOfficeFont)
Call this method to use Tahoma font despite system metrics.
int | GetControlHeight () const
This method returns the common controls height.
virtual CSize | GetDefaultCommandBarSize (CXTPCommandBar *pBar)
Computes default command bar size taking into account command bar font.
void | Rectangle (CDC *pDC, LPCRECT rc, int nPen, const int nBrush)
Draws a rectangle.
void | Rectangle (CDC *pDC, LPCRECT rc, COLORREF clrPen, COLORREF clrBrush)
Draws a rectangle.
void | RoundRect (CDC *pDC, LPCRECT rc, COLORREF clrPen, COLORREF clrBrush)
Draws a rectangle.
void | Draw3dRect (CDC *pDC, LPCRECT rc, int nTopLeft, int nBottomRight)
Call this member function to draw a three-dimensional rectangle.
void | Draw3dRect (CDC *pDC, LPCRECT rc, int frameThickness, COLORREF clrPen, COLORREF clrBrush)
Call this member function to draw a rectangle with predetermined thickness.
virtual void | DrawPopupBarCheckMark (CDC *pDC, CRect rcCheck, BOOL bEnabled, COLORREF clr)
Call this member function to draw a check mark.
void | DrawCheckMark (CDC *pDC, CRect rcCheck, COLORREF clr=0)
Call this member function to draw a check mark.
virtual void | DrawPopupBarRadioMark (CDC *pDC, CRect rcCheck, BOOL bEnabled, COLORREF clr)
Call this member function to draw a radio button.
virtual void | DrawComboExpandMark (CDC *pDC, CRect rc, COLORREF clr)
Call this member function to draw a combobox expand symbol.
void | Line (CDC *pDC, CPoint p0, CPoint p1)
Draws a line.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1, const int nPen)
Draws a line.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1, COLORREF clrPen)
Draws a line.
void | HorizontalLine (CDC *pDC, int x0, int y0, int x1, COLORREF clrPen)
Call this member function to draw a horizontal line using the specified coordinages and RGB color value.
void | VerticalLine (CDC *pDC, int x0, int y0, int y1, COLORREF clrPen)
Call this member function to draw a vertical line using the specified coordinages and RGB color value.
void | Pixel (CDC *pDC, int xPos, int yPos, int nPen)
Sets the pixel at the point.
void | GradientFill (CDC *pDC, LPRECT lpRect, COLORREF crFrom, COLORREF crTo, BOOL bHorz, LPCRECT lpRectClip=NULL)
Gradient fills the rectangle.
XTP_COMMANDBARS_ICONSINFO * GetIconsInfo ()
virtual void | Animate (CDC *pDestDC, CDC *pSrcDC, CRect rc, XTPAnimationType animationType)
This method is called to animate the pop-up bar.
virtual void | AnimateExpanding (CXTPCommandBar *pCommandBar, CDC *pDestDC, CDC *pSrcDC, BOOL bExpandDown)
This method is called to animate the expanding process.
void | SetAnimationDelay (int nAnimationSteps, int nAnimationTime)
Call this method to set animation delay.
COLORREF | GetXtremeColor (UINT nIndex)
This function retrieves the current color of the specified XP display element.
void | SetColors (int cElements, CONST INT *lpaElements, CONST COLORREF *lpaRgbValues)
Call this member to set the colors for each element to the color in the specified color array.
CSize | DrawControlText (CDC *pDC, CXTPControl *pControl, CRect rcText, BOOL bDraw, BOOL bVert, BOOL bCentered, BOOL bTriangled)
This method is called to draw control text.
virtual void | UpdateRTLCaption (CString &strCaption)
This method is called to prepare a caption for Right-To-Left draw.
XTPCurrentSystemTheme GetCurrentSystemTheme ()
Call this member function to determine the current Windows XP theme in use.
void | SetLunaTheme (XTPCurrentSystemTheme systemTheme)
Call this method to force system theme.
virtual int | GetPopupBarGripperWidth (CXTPCommandBar *pBar)
Calculates the gripper of a pop-up bar.
virtual CXTPControlGalleryPaintManager * | GetGalleryPaintManager () const
Retrieves paint manager used to draw galleries.
virtual CXTPScrollBarPaintManager * | GetScrollBarPaintManager () const
Retrieves paint manager used to draw scrollbars.
virtual CXTPSliderPaintManager * | GetSliderPaintManager () const
Retrieves paint manager used to draw slider panes.
virtual CXTPProgressPaintManager * | GetProgressPaintManager () const
Retrieves paint manager used to draw progress bars.
virtual CXTPStatusBarPaintManager * | GetStatusBarPaintManager ()
Retrieves paint manager used to draw the status bar.
virtual CXTPMessageBarPaintManager * | GetMessageBarPaintManager ()
Retrieves paint manager used to draw message bars.
CXTPShadowManager * | GetShadowManager () const
Retrieves shadow manager used to draw shadows.
BOOL | IsUseSystemAccentColorEnabled () const
Determines whether xtpApplicationUseSystemAccentColor application ambient property is set.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.
- Public Member Functions inherited from CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents >
void | Subscribe (IXTPPaintManagerEvents *pObserver, CXTPSubscriptionList< CXTPPaintManager, IXTPPaintManagerEvents > *pSubcriptionList=NULL)
Subscribes a unique observer for events.
void | Unsubscribe (IXTPPaintManagerEvents *pObserver)
Unsubscribes an observer from events.
void | Notify (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *))
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *))
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.

Protected Member Functions

virtual void | DrawSplitButtonFrame (CDC *pDC, CXTPControl *pButton, CRect rc)
This method is called to draw the frame for the SplitButton control.
virtual void | DrawRectangle (CDC *pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition)
This method is called to fill the control's face.
virtual void | DrawRectangle (CDC *pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition, int nID)
This method is called to fill the control's face.
virtual BOOL | DrawRectangle (CDC *pDC, CXTPControl *pButton)
This method is called to fill the control's face.
virtual COLORREF | GetControlTextColor (CXTPControl *pButton)
This method returns the control text color to draw.
virtual void | DrawGalleryItemBack (CDC *pDC, CRect rcItem, BOOL bEnabled, BOOL bSelected, BOOL bPressed, BOOL bChecked, XTPBarType barType)
This method is called to draw the background for a gallery menu item.
virtual void | DrawCheckRect (CDC *pDC, CRect rc, COLORREF clrFore, COLORREF clrBack)
Helper class called by DrawRectangle to render a checkmark background and border.
virtual CSize | DrawCommandBarGripper (CDC *pDC, CXTPCommandBar *pBar, BOOL bDraw=TRUE)
This method is called to draw the command bar's gripper.
virtual CSize | DrawControlComboBox (CDC *pDC, CXTPControlComboBox *pComboBox, BOOL bDraw)
This method is called to draw the control.
- Protected Member Functions inherited from CXTPCommandBarsOffice2013Theme
virtual void | RefreshMetrics ()
This method is called to refresh the visual metrics of the manager.
virtual void | RefreshStandardColors ()
Called to update the standard colors used by the framework.
virtual COLORREF | GetRectangleTextColor (BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition)
This method retrieves a buttons text color.
virtual COLORREF | GetControlBackColor (CXTPControl *pButton)
Call this method to get the control back color to draw.
void | DrawFrameBorder (CDC *pDC, CRect rc, int nBorderThickness, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition)
This method is called to fill the border of the control's face.
virtual void | DrawPopupBarGripper (CDC *pDC, int xPos, int yPos, int cx, int cy, BOOL bExpanded=FALSE)
This method is called to draw a pop-up bar's right gripper.
virtual void | DrawDropDownGlyph (CDC *pDC, CXTPControl *pControl, CPoint pt, BOOL bSelected, BOOL bPopuped, BOOL bEnabled, BOOL bVert)
This member function is called to draw a split button expand symbol.
virtual CSize | DrawCommandBarSeparator (CDC *pDC, CXTPCommandBar *pBar, CXTPControl *pControl, BOOL bDraw=TRUE)
This method is called to draw a command bar's separator.
virtual void | DrawExpandGlyph (CDC *pDC, CXTPControl *pButton, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clr)
Draw expand or hidden glyphs for a button.
virtual void | DrawHiddenGlyph (CDC *pDC, CXTPControl *pButton, COLORREF clr, BOOL bVertical)
Draw expand or hidden glyphs for a button.
virtual void | DrawExpandGlyph (CDC *pDC, CXTPControl *pButton, COLORREF clr, BOOL bVertical)
Draw expand or hidden glyphs for a button.
virtual CSize | DrawControlCheckBoxMark (CDC *pDC, CXTPControl *pButton, CRect rc, BOOL bDraw)
This method is called to draw a check box mark area.
virtual CSize | DrawControlCheckBoxMark (CDC *pDC, CRect rc, BOOL bDraw, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled)
This method is called to draw a check box mark area.
virtual CSize | DrawControlRadioButtonMark (CDC *pDC, CRect rc, BOOL bDraw, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled)
This method is called to draw a radio button mark area.
virtual void | DrawControlMDIButton (CDC *pDC, CXTPControlButton *pButton)
Call this member function to draw Menu MDI buttons.
- Protected Member Functions inherited from CXTPCommandBarsModernUITheme
- Protected Member Functions inherited from CXTPCommandBarsOfficeXPTheme
virtual CSize | DrawControlPopupParent (CDC *pDC, CXTPControl *pButton, BOOL bDraw)
This method is called to draw the control placed on the pop-up bar.
virtual void | DrawImage (CDC *pDC, CPoint pt, CSize sz, CXTPImageManagerIcon *pImage, BOOL bSelected, BOOL bPressed, BOOL bEnabled=TRUE, BOOL bChecked=FALSE, BOOL bPopuped=FALSE, BOOL bToolBarImage=TRUE)
This method is called to draw the image of the control.
void | FillIntersectRect (CDC *pDC, CXTPPopupBar *pPopupBar, COLORREF clr)
Draws intersect rectangle of a pop-up bar and its control.
- Protected Member Functions inherited from CXTPPaintManager
CXTPPaintManager ()
Constructs a CXTPPaintManager object.
virtual | ~CXTPPaintManager ()
Destroys a CXTPPaintManager object, handles cleanup and deallocation.
- Protected Member Functions inherited from CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents >
CXTPObservable ()
Constructs an observable object.
~CXTPObservable ()
Handles observable object destruction.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPPaintManager
static CXTPPaintManager *AFX_CDECL | GetInstanceAddRef ()
Obtains a pointer to a global paint manager object and increments its reference counter.
static void AFX_CDECL | ReleaseInstance ()
Decrements global paint manager's reference counter and deletes its instance when the reference counter reaches 0.
static CXTPPaintManager *AFX_CDECL | CreateTheme (XTPPaintTheme paintTheme)
Creates a new CXTPPaintManager object.
static void AFX_CDECL | SetTheme (XTPPaintTheme paintTheme)
Call this member to switch the visual theme of the Command Bars.
static void AFX_CDECL | SetCustomTheme (CXTPPaintManager *pTheme)
Call this member to set a custom theme.
static void AFX_CDECL | Triangle (CDC *pDC, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clr)
Draws a triangle.
static BOOL AFX_CDECL | FontExists (LPCTSTR lpszFaceName)
Determines if a specified font exists in the system.
static void AFX_CDECL | StripMnemonics (CString &strClear)
This member function will search a string, strip off the mnemonic '&', and reformat the string.
static CXTPPaintManager *AFX_CDECL | GetGlobalPaintManager ()
Call this method to get the pointer to the global paint manager.
static void AFX_CDECL | SetGlobalPaintManager (CXTPPaintManager *pPaintManager)
Call this method to set the pointer to the global paint manager.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPPaintManager
COLORREF | m_clrMessageBarText
Message bar text color.
CRect | m_rcMessageBarMargin
Margin of the message bar.
CXTPFramePaintManager * | m_pFramePaintManager
Frame paint manager.
CXTPStatusBarPaintManager * | m_pStatusBarPaintManager
Paint manager of the status bar.
CXTPRibbonPaintManager * | m_pRibbonPaintManager
Ribbon paint Manager.
CXTPControlGalleryPaintManager * | m_pGalleryPaintManager
Gallery paint manager.
CXTPProgressPaintManager * | m_pProgressPaintManager
Progress bar paint manager.
CXTPSliderPaintManager * | m_pSliderPaintManager
Slider pane paint manager.
CXTPScrollBarPaintManager * | m_pScrollBarPaintManager
Scrollbar paint manager.
CXTPPaintManagerColorGradient | m_clrDisabledIcon
Disabled icons color.
CXTPPaintManagerColor | m_clrFloatingGripper
Gripper color of floating toolbar.
CXTPPaintManagerColor | m_clrFloatingGripperText
Gripper text color of floating toolbar.
BOOL | m_bThickCheckMark
TRUE to draw thick check mark.
BOOL | m_bShowShadow
TRUE to show shadow.
BOOL | m_bThemedStatusBar
TRUE to draw status bar using WinXP theme.
BOOL | m_bThemedCheckBox
TRUE to draw check box using WinXP theme.
BOOL | m_bClearTypeTextQuality
TRUE to enable ClearType text for the font.
BOOL | m_bFlatToolBar
TRUE to draw toolbars flat.
BOOL | m_bFlatMenuBar
TRUE to draw menubar flat.
int | m_nPopupBarTextPadding
Distance between gripper and control text.
BOOL | m_bSelectImageInPopupBar
TRUE to select image as in explorer theme.
BOOL | m_bEnableAnimation
TRUE to enable animation for all toolbars.
BOOL | m_bOffice2007Padding
TRUE if Office2007 metrics used.
BOOL | m_bOffsetPopupLabelText
TRUE if labels in pop-ups drawn with offset.
BOOL | m_bWrapCaptionBelowText
Wrap text for xtpButtonIconAndCaptionBelow buttons.
CXTPPaintManagerFont | m_fontSmCaption
Small caption font.
CXTPPaintManagerFont | m_fontIcon
Icon font.
CXTPPaintManagerFont | m_fontIconBold
Icon bold font.
CXTPPaintManagerFont | m_fontToolTip
Tooltip font.
int | m_nSplitButtonDropDownWidth
Split button drop down width in toolbars.
int | m_nSplitButtonDropDownHeight
Split button drop down height in toolbars.
int | m_nSplitButtonPopupWidth
Split button drop down width in pop-ups.
BOOL | m_bAutoResizeIcons
TRUE to automatically resize icons using current DPI.
int | m_nStatusBarMinHeight
Minimum height for the status bar.
PVOID | m_pfnSetLayeredWindowAttributes
point to Transparency proc in USER32.dll module.
CRect | m_rcStatusBarBorder
Bounding rectangle of the status bar border.
BOOL | m_bUseOfficeFont
TRUE to use Tahoma font.
CString | m_strOfficeFont
Office font.
int | m_nTextHeight
Regular text field height (not font height).
- Protected Attributes inherited from CXTPCommandBarsOffice2013Theme
BOOL | m_bIntersect
TRUE to draw pop-up bar intersect rectangle.
CXTPColorSetStateMenu | m_csMenu
State colors used by Menu items.
CXTPColorSetStateMenuTitleBar | m_csMenuTitleBar
State colors used by MenuTitleBar items.
CXTPColorSetStateRibbon | m_csRibbon
State colors used by Ribbon group buttons.
CXTPColorSetStateToolbar | m_csToolbar
State colors used by Toolbar buttons.
CXTPColorSetStateCheckMark | m_csCheckMark
State colors used by Menu Check Marks.
CXTPColorSetStateComboBox | m_csComboBox
State colors used by ComboBox control.
CXTPColorSetStateCheckBox | m_csCheckBox
State colors used by Check Box and Radio Button controls.
CXTPPaintManagerColor | m_clrBack
CommandBars background color;.
CXTPPaintManagerColor | m_clrGlyph
Glyph Normal color.
CXTPPaintManagerColor | m_clrGlyphHighlight
Glyph Highlight color.
CXTPPaintManagerColor | m_clrGlyphPushed
Glyph Pushed color.
CXTPPaintManagerColor | m_clrGlyphDisabled
Glyph Disabled color.
CXTPPaintManagerColor | m_clrMessageBarText
Message bar text color.
CXTPPaintManagerColor | m_clrBtnFace
Button background color.
CXTPPaintManagerColor | m_clr3DShadow
Button shadow color.
CXTPPaintManagerColor | m_clrHighlight
Button highlight color.
CXTPPaintManagerColor | m_clrCaptionButtonFill
Text color for frame caption buttons.
CXTPPaintManagerColorGradient | m_clrWorkspace
Workspace area gradient color.
- Protected Attributes inherited from CXTPCommandBarsModernUITheme
CXTPMarkupContext * | m_pMarkupContext
Points to a valid markup context object.
CXTPResourceImages * | m_pImages
Points to a valid resource images object.
- Protected Attributes inherited from CXTPPaintManager
CXTPFont | m_xtpFontRegular
Regular font.
CXTPFont | m_xtpFontRegularBold
Regular bold font.
CXTPFont | m_xtpFontVert
Vertical font.
CXTPFont | m_xtpFontVertBold
Vertical font.
int | m_nEditHeight
Edit text height.
int | m_nFontHeight
Custom font height (optional).
BOOL | m_bUseStandardFont
TRUE to use system font.
BOOL | m_bEmbossedDisabledText
TRUE to draw disabled text embossed.
CXTPWinThemeWrapper * | m_themeStatusBar
StatusBar theme helper.
CXTPWinThemeWrapper * | m_themeButton
Buttons theme helper.
XTPPaintTheme | m_themeCurrent
Current theme.
XTP_COMMANDBARS_ICONSINFO | m_iconsInfo
Specific icons options.
int | m_nAnimationSteps
Steps of the animation.
int | m_nAnimationTime
Time of the animation.
BOOL | m_bShowKeyboardCues
TRUE to show keyboard cues - deprecated.
CXTPPaintManagerColor | m_arrColor [XPCOLOR_LAST+1]
Self colors array.
XTPCurrentSystemTheme | m_systemTheme
Current system theme.
CXTPShadowManager * | m_pShadowManager
Shadow manager.

Detailed Description

The CXTPCommandBarsVisualStudio2022Theme class is used to enable a Visual Studio 2022 style theme for Command Bars.

See also
CXTPPaintManager::SetTheme

Member Function Documentation

◆ DrawCheckRect()

virtual void DrawCheckRect | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | COLORREF | clrFore,
 |  | COLORREF | clrBack )
 protectedvirtual

Helper class called by DrawRectangle to render a checkmark background and border.

Parameters
pDC | Pointer to a valid device context.
rc | Rectangle to draw.
clrFore | RGB color value used to draw border.
clrBack | RGB color value used to draw background.

◆ DrawCommandBarGripper()

virtual CSize DrawCommandBarGripper | ( | CDC * | pDC,
 |  | CXTPCommandBar * | pBar,
 |  | BOOL | bDraw = TRUE )
 protectedvirtual

This method is called to draw the command bar's gripper.

Parameters
pDC | Pointer to a valid device context.
pBar | Pointer to a CXTPCommandBar object.
bDraw | TRUE to draw; FALSE to retrieve the size of the gripper.
Returns
Size of the gripper.

Reimplemented from CXTPCommandBarsOffice2013Theme.

◆ DrawControlComboBox()

virtual CSize DrawControlComboBox | ( | CDC * | pDC,
 |  | CXTPControlComboBox * | pComboBox,
 |  | BOOL | bDraw )
 protectedvirtual

This method is called to draw the control.

Parameters
pDC | Pointer to a valid device context.
bDraw | TRUE to draw; FALSE to retrieve the size of the control.
pComboBox | A pointer to a CXTPControlComboBox object to draw.
Returns
Size of the control.

Reimplemented from CXTPCommandBarsOffice2013Theme.

◆ DrawGalleryItemBack()

virtual void DrawGalleryItemBack | ( | CDC * | pDC,
 |  | CRect | rcItem,
 |  | BOOL | bEnabled,
 |  | BOOL | bSelected,
 |  | BOOL | bPressed,
 |  | BOOL | bChecked,
 |  | XTPBarType | barType )
 protectedvirtual

This method is called to draw the background for a gallery menu item.

Parameters
pDC | Pointer to a valid device context.
rcItem | Reference to item area rectangle coordinates.
bSelected | TRUE if the control is selected.
bPressed | TRUE if the control is pushed.
bEnabled | TRUE if the control is enabled.
bChecked | TRUE if the control is checked.
barType | Parent's bar type.

Reimplemented from CXTPCommandBarsOffice2013Theme.

◆ DrawRectangle() [1/3]

virtual void DrawRectangle | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | BOOL | bSelected,
 |  | BOOL | bPressed,
 |  | BOOL | bEnabled,
 |  | BOOL | bChecked,
 |  | BOOL | bPopuped,
 |  | XTPBarType | barType,
 |  | XTPBarPosition | barPosition )
 protectedvirtual

This method is called to fill the control's face.

Parameters
pDC | Pointer to a valid device context.
rc | Rectangle to draw.
bSelected | TRUE if the control is selected.
bPressed | TRUE if the control is pushed.
bEnabled | TRUE if the control is enabled.
bChecked | TRUE if the control is checked.
bPopuped | TRUE if the control is pop-up'ed.
barType | Parent's bar type.
barPosition | Parent's bar position.

Reimplemented from CXTPCommandBarsOffice2013Theme.

◆ DrawRectangle() [2/3]

virtual void DrawRectangle | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | BOOL | bSelected,
 |  | BOOL | bPressed,
 |  | BOOL | bEnabled,
 |  | BOOL | bChecked,
 |  | BOOL | bPopuped,
 |  | XTPBarType | barType,
 |  | XTPBarPosition | barPosition,
 |  | int | nID )
 protectedvirtual

This method is called to fill the control's face.

Parameters
pDC | Pointer to a valid device context.
rc | Rectangle to draw.
bSelected | TRUE if the control is selected.
bPressed | TRUE if the control is pushed.
bEnabled | TRUE if the control is enabled.
bChecked | TRUE if the control is checked.
bPopuped | TRUE if the control is pop-up'ed.
barType | Parent's bar type.
barPosition | Parent's bar position.
nID | Bar's control ID.

Reimplemented from CXTPCommandBarsOffice2013Theme.

◆ DrawRectangle() [3/3]

virtual BOOL DrawRectangle | ( | CDC * | pDC,
 |  | CXTPControl * | pButton )
 protectedvirtual

This method is called to fill the control's face.

Parameters
pDC | Pointer to a valid device context.
pButton | pointer to a button
Returns
TRUE if the rectange was drawn, otherwise FALSE.

Reimplemented from CXTPCommandBarsOffice2013Theme.

◆ DrawSplitButtonFrame()

virtual void DrawSplitButtonFrame | ( | CDC * | pDC,
 |  | CXTPControl * | pButton,
 |  | CRect | rc )
 protectedvirtual

This method is called to draw the frame for the SplitButton control.

Parameters
pDC | Pointer to a valid device context.
pButton | Pointer to a CXTPControl object.
rc | Bounding rectangle to draw.

Reimplemented from CXTPCommandBarsOffice2013Theme.

◆ GetControlTextColor()

virtual COLORREF GetControlTextColor ( CXTPControl * pButton )
protectedvirtual

This method returns the control text color to draw.

Parameters
pButton Points to a CXTPControl object to draw.
Returns
Returns control text color

Reimplemented from CXTPCommandBarsOffice2013Theme.

◆ GetStateColor()

virtual COLORREF GetStateColor ( ) const
virtual

Call this member function to get the application state color for the frame border and status bar.

Returns
COLORREF value representing the application state color.

◆ SetStateColor()

virtual void SetStateColor ( COLORREF clrState = COLORREF_NULL )
virtual

Call this member function to set the application state color for the frame border and status bar.

Parameters
clrState COLORREF value representing the application state color. Use COLORREF_NULL to reset back to default color.
The documentation for this class was generated from the following file:
  • XTPCommandBarsVisualStudio2022Theme.h


Toolkit Pro: CXTPCommonPicturePreviewProvider Class Reference

List of all members
CXTPCommonPicturePreviewProvider Class Reference

Provides a preview handler for the common picture file types: BMP, PNG, TIF, TIFF, ICO, JPEG, JPG, EXIF, WMF, EMF. More...

Inheritance diagram for CXTPCommonPicturePreviewProvider:
[legend]

Additional Inherited Members

- Public Member Functions inherited from IXTPPreviewProvider
virtual | ~IXTPPreviewProvider ()
Handles object destruction.
- Protected Member Functions inherited from CXTPPreviewProviderBase
CXTPPreviewProviderBase ()
Handles object construction.
void | BindHost (IXTPPreviewHost &host)
The method is called by the host preview control when the provider is initially bound to the host.
IXTPPreviewHost & | GetHost () const
Obtains the preview host interface that the provider is bound to.

Detailed Description

Provides a preview handler for the common picture file types: BMP, PNG, TIF, TIFF, ICO, JPEG, JPG, EXIF, WMF, EMF.

See also
CXTPSystemPreviewProvider, CXTPGifPreviewProvider, CXTPMsgPreviewProvider, CXTPTextPreviewProvider, CXTPXamlPreviewProvider
The documentation for this class was generated from the following file:
  • XTPCommonPicturePreviewProvider.h


Toolkit Pro: CXTPControl Class Reference

Public Member Functions | Static Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPControl Class Reference

CXTPControl is a CXTPCmdTarget derived class. More...

Inheritance diagram for CXTPControl:
[legend]

Public Member Functions

void | SetStyle (XTPButtonStyle buttonStyle)
Call this member to set the style of the control.
XTPButtonStyle | GetStyle () const
Call this member to get the control's style.
void | SetCaption (LPCTSTR lpszCaption)
Call this member to set the caption of the control.
void | SetCaption (UINT nIDCaption)
Call this member to set the caption of the control.
virtual CString | GetCaption () const
Call this member to get the control's caption.
void | SetShortcutText (LPCTSTR lpszShortcutText)
Call this member to set the shortcut string to the control.
CString | GetShortcutText () const
Call this member to get the control's shortcut.
void | SetDescription (LPCTSTR lpszDescription)
Call this member to set the description of the control.
virtual CString | GetDescription () const
Call this member to get the control's description.
void | SetTooltip (LPCTSTR lpszTooltip)
Call this member to set the tooltip of the control.
virtual CString | GetTooltip () const
Call this member to get the control's tooltip.
void | SetKeyboardTip (LPCTSTR lpszKeyboardTip)
Call this member to set the keyboard tip to the control.
CString | GetKeyboardTip () const
Call this member to get the keyboard tip.
void | SetCustomShortcutText (LPCTSTR lpszCustomShortcutText)
Call this member to set the text displayed for the shortcut in a pop-up menu.
CString | GetCustomShortcutText () const
Call this member to get the control's text displayed for the shortcut in a pop-up menu.
void | SetParameter (LPCTSTR lpszParameter)
Call this member to set the parameter of the control.
CString | GetParameter () const
Call this member to get the control's parameter.
void | SetID (int nId)
Call this member to set the identifier of the control.
int | GetID () const
Call this member to get the control's identifier.
long | GetIndex () const
Call this member to get the index of the control.
void | SetIconId (int nId)
Call this member to set the control icon's identifier.
int | GetIconId () const
Call this member to get the icon's identifier.
void | SetHelpId (int nId)
Call this member to set the control help identifier.
int | GetHelpId () const
Call this member to get the help identifier.
virtual void | SetBeginGroup (BOOL bBeginGroup)
Call this member to begin a new group using a separator.
BOOL | GetBeginGroup () const
Call this member to determine if the control has a separator.
virtual void | SetEnabled (BOOL bEnabled)
Call this member to enable/disable the control.
BOOL | GetEnabled () const
Call this member to check if the control is enabled.
virtual void | OnEnabledChanged ()
This method is called when a control's enabled state is changed.
virtual void | SetChecked (BOOL bChecked)
Call this member to set the checked state of the control.
BOOL | GetChecked () const
Call this member to get the checked state of the control.
virtual int | GetSelected () const
Call this member to check if the control is selected.
void | SetOnQuickAccess (BOOL bOnQuicAccess=FALSE)
Call this member to set whether a control should be a part of the Quick Access panel.
BOOL | IsOnQuickAccess () const
Call this member to check if a control is a part of the Quick Access panel.
virtual void | SetFocused (BOOL bFocused)
Call this member to set the focused state of the control.
virtual BOOL | IsFocused () const
Call this member to check the focused state of the control.
void | SetPressed (BOOL bPressed)
Call this member to set the pressed state of the control.
virtual BOOL | GetPressed () const
Call this member to check the pressed state of the control.
virtual void | SetRect (CRect rcControl)
This member is called to set the bounding rectangle of the control.
CRect | GetRect () const
Call this member to get the bounding rectangle of the control.
CXTPCommandBar * | GetParent () const
Call this member to get the parent command bar.
virtual BOOL | IsVisible (DWORD dwSkipFlags=0) const
Call this member to determine if the control is visible.
virtual BOOL | IsCaptionVisible () const
Call this member to determine if the caption of the control is visible.
void | SetVisible (BOOL bVisible)
Call this member to set the visibility of the control.
CXTPControls * | GetControls () const
Call this member to get the parent controls collection.
XTPControlType | GetType () const
Call this member to get the control's type.
void | SetFlags (DWORD dwFlags)
Call this member to set the flags of the control.
DWORD | GetFlags () const
Call this member to retrieve control special flags.
void | SetTag (DWORD_PTR dwTag)
This method sets the 32-bit value associated with the control.
DWORD_PTR | GetTag () const
This method retrieves the application-supplied, 32-bit value associated with the control.
virtual BOOL | Compare (CXTPControl *pOther)
Call this member to compare controls.
virtual CXTPCommandBar * | GetCommandBar () const
Call this member to get the child command bar.
void | SetCloseSubMenuOnClick (BOOL bCloseOnClick)
Call this member function to enable/disable the closing of sub-menus when a control is clicked in the menu.
BOOL | GetCloseSubMenuOnClick () const
Call this member function to check if sub-menus will close as soon as a control is clicked.
void | SetExecuteOnPressInterval (int nExecuteOnPressInterval)
Call this method to set the delay (in milliseconds) between WM_COMMAND messages while a button is pressed by the user.
int | GetExecuteOnPressInterval () const
Call this method to get the delay (in milliseconds) between WM_COMMAND messages while a button is pressed by the user.
CXTPRibbonGroup * | GetRibbonGroup () const
Returns the ribbon group that the control belongs to.
virtual BOOL | IsTransparent () const
Determines if the control needs to draw its background.
void | SetHideWrap (BOOL bHide)
This method is called to hide the control.
virtual void | SetHideFlags (DWORD dwFlags)
This method is called to hide the control.
BOOL | SetHideFlag (XTPControlHideFlags dwFlag, BOOL bSet)
Call this member to set/remove hide flags.
DWORD | GetHideFlags () const
Call this method to retrieve hidden flags.
CRect | GetRowRect () const
Call this method to retrieve the position of the control's row.
BOOL | GetWrap () const
Call this method to check if the control is wrapped.
void | SetRowRect (CRect rcRow)
Call this method to set the row of the control.
void | SetWrap (BOOL bWrap)
Call this member to set the control to wrapped.
BOOL | GetExpanded () const
Call this member to check if the control is expanded.
BOOL | IsCursorOver () const
Call this member to determine if the mouse pointer is over the control.
virtual void | OnExecute ()
This method is called when the control is executed.
virtual CSize | GetSize (CDC *pDC)
This method is called to determine the size of the control.
virtual void | Draw (CDC *pDC)
This method is called to draw the control.
virtual void | OnCalcDynamicSize (DWORD dwMode)
This method is called before recalculating the parent command bar size to calculate the dimensions of the control.
void | DelayRedrawParent ()
Call this method to redraw the parent command bar.
void | DelayLayoutParent ()
Call this method to recalculate the parent command bar size.
void | SetCategory (LPCTSTR lpszCategory)
Call this method to set the category of the control.
CString | GetCategory () const
Call this method to retrieve the category of the control.
CXTPImageManager * | GetImageManager () const
Call this method to retrieve the image manager.
CXTPPaintManager * | GetPaintManager () const
Call this method to retrieve the paint manager.
virtual CXTPImageManagerIcon * | GetImage (int nWidth=16) const
Call this method to retrieve the image of the control.
void | AssignDocTemplate (UINT nIDResource)
Call this method to assign a document template to the control.
void | ExcludeDocTemplate (UINT nIDResource)
Call this method to exclude the document template from control.
BOOL | IsItemDefault () const
Call this method to check if a control is a default menu item.
void | SetItemDefault (BOOL bDefault)
Call this method to set a control to be a default menu item.
BOOL | IsTemporary () const
Call this method to determine if a control is temporary.
void | Reset ()
Call this member to reset the icon and caption of a control to its default settings before it was customized by the user.
void | SetPrompt (LPCTSTR lpszPrompt)
Call this member to load a string from a STRINGTABLE resource to set the tooltip and description of a control.
void | SetCustomIcon (HICON hIcon)
Call this member to set a custom icon to this control.
virtual void | DoPropExchange (CXTPPropExchange *pPX)
Either reads this object from or writes this object to an archive.
virtual void | OnUnderlineActivate ()
This method is called when the user activates the control using its underline.
virtual BOOL | GetPopuped () const
Call this member to get the control's pop-up state.
void | RedrawParent (BOOL bAnimate=TRUE)
This method is called to redraw the parent command bar.
LRESULT | NotifySite (UINT code)
This method is called to send message code to the parent site window.
LRESULT | NotifySite (UINT code, NMXTPCONTROL *pNM)
This method is called to send message code to the parent site window.
LRESULT | NotifySite (CWnd *pSite, UINT code, NMXTPCONTROL *pNM)
This method is called to send message code to the parent site window.
virtual void | SetAction (CXTPControlAction *pAction)
Call this method to manually assign an action for control.
CXTPControlAction * | GetAction () const
Call this method to retrieve an action associated with control.
virtual void | OnThemeChanged ()
This method is called when the paint manager theme is changed.
virtual void | SetWidth (int nWidth)
Call this member to set the width of the control.
virtual void | SetHeight (int nHeight)
Call this member to set the height of the control.
int | GetWidth () const
Call this member to get the width of the control.
int | GetHeight () const
Call this member to get the height of the control.
BOOL | HasDwmCompositedRect () const
This method is called to determine if control has a Vista DWM transparent area.
virtual CSize | GetButtonSize () const
Call this function to get the size of the command bar button.
virtual CSize | GetIconSize () const
Call this member function to get the size of a toolbar icon.
void | SetIconSize (CSize szIcon)
Call this member function to set the size of an icon for an individual control.
virtual void | Copy (CXTPControl *pControl, BOOL bRecursive=FALSE)
This method is called to copy the control.
virtual void | OnClick (BOOL bKeyboard=FALSE, CPoint pt=CPoint(0, 0))
This method is called when the user clicks the control.
virtual BOOL | IsCustomizeMovable () const
This method is called to determine if control can be repositioned in customize mode.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Static Public Member Functions

static CXTPControl *AFX_CDECL | FromUI (CCmdUI *pCmdUI)
Call this member to retrieve CXTPControl from a CCmdUI structure.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Protected Member Functions

CXTPControl ()
Constructs a CXTPControl object.
virtual | ~CXTPControl ()
Destroys a CXTPControl object, handles cleanup and deallocation.
virtual BOOL | IsFocusable () const
This method is called to check if the control can accept focus.
void | SetIndex (int nIndex)
This method is called to assign the order of the control in the controls list.
void | SetExpanded (BOOL bExpanded)
This method is called to set the control's expanded state.
virtual BOOL | OnHookKeyDown (UINT nChar, LPARAM lParam)
This method is called when a non-system key is pressed.
virtual BOOL | OnHookMouseWheel (UINT nFlags, short zDelta, CPoint point)
This method is called when the user rotates the mouse wheel.
virtual void | SetParent (CXTPCommandBar *pParent)
This method is called to assign a parent command bar object.
void | ScreenToClient (CPoint *point)
The ScreenToClient function converts the screen coordinates of a specified point on the screen.
void | ClickToolBarButton (CRect rcActiveRect=CRect(0, 0, 0, 0))
This helper method is called when the user clicks the toolbar's button.
virtual BOOL | OnSetPopup (BOOL bPopup)
This method is called to pop-up the control.
virtual void | OnLButtonUp (CPoint point)
This member is called when the user releases the left mouse button.
virtual void | OnLButtonDown (CPoint point)
This member is called when the user presses the left mouse button down.
virtual BOOL | OnRButtonDown (CPoint point)
This member is called when the user press the right mouse button.
virtual BOOL | OnRButtonUp (CPoint point)
This member is called when the user releases the right mouse button.
virtual BOOL | OnLButtonDblClk (CPoint point)
This member is called when the user double-clicks the left mouse button.
virtual void | OnMouseMove (CPoint point)
This member is called when the mouse cursor moves.
virtual void | OnMouseHover ()
Called after the mouse hovers over the control.
virtual BOOL | OnSetSelected (int bSelected)
This method is called when the control becomes selected.
BOOL | IsCustomizeMode () const
Call this method to determine if command bars is in customize mode.
virtual void | CustomizeStartDrag (CPoint point)
This member is called when the user starts to drag the control in customize mode.
virtual BOOL | CustomizeStartResize (CPoint point)
This method is called when user starts to resize control in customize mode.
virtual void | OnCustomizeDragOver (CXTPControl *pDataObject, CPoint point, DROPEFFECT &dropEffect)
This member is called when the user moves the mouse over the control.
virtual BOOL | DoCustomDragOver (CXTPCommandBar *pCommandBar, CPoint point, DROPEFFECT &dropEffect)
The implementation may implement a custom drag over handling logic in this method.
virtual BOOL | IsCustomizeResizeAllow () const
This member checks if the user can resize the control.
virtual int | GetCustomizeMinWidth () const
Retrieves the available minimum width of control.
virtual int | GetCustomizeMinHeight () const
Retrieves available minimum height of the control.
void | OnCustomizeMouseMove (CPoint point)
This member is called when the mouse cursor moves in customized mode.
virtual void | OnIdleUpdate ()
This virtual method is called in idle-time processing.
virtual void | OnRemoved ()
This method is called when a control is removed from the parent controls collection.
virtual INT_PTR | OnToolHitTest (CPoint point, TOOLINFO *pTI) const
The framework calls this member function to determine whether a point is in the bounding rectangle of the specified tool.
virtual void | RestoreCommandBarList (CXTPCommandBarList *pCommandBarList)
This method is called from LoadCommandBars to restore controls and its child command bars.
virtual void | GenerateCommandBarList (DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam)
This method is called from SaveCommandBars to save all child command bars.
virtual void | OnActionChanged (int nProperty)
This method is called when an action property is changed.
virtual void | OnActionChanging (int nProperty)
This method is called when an action property is about to be changed.
virtual void | OnCaptionChanged ()
This method is called when the control's caption is changed.
BOOL | IsLayoutRTL () const
Determines if right-to-left (RTL) mode is set.
BOOL | IsLayoutChanged ()
Call this member to determine if the layout has changed (RTL to LTR or LTR to RLT).

Protected Attributes

DWORD_PTR | m_nTag
Control tag.
int | m_nIndex
Index of the control.
int | m_nId
Identifier of the control.
int | m_nIconId
Identifier of the control's image.
int | m_nHelpId
Help identifier.
int | m_nCustomIconId
Identifier of the control's custom image.
BOOL | m_bWrap
TRUE if the control is wrapped.
BOOL | m_bBeginGroup
TRUE if the control starts new group.
BOOL | m_bEnabled
TRUE if the control is enabled.
BOOL | m_bChecked
TRUE if the control is checked.
BOOL | m_bSelected
TRUE if the control is selected.
BOOL | m_bPressed
TRUE if the control is pushed.
BOOL | m_bTemporary
TRUE if the control is temporary.
BOOL | m_bOnQuickAccess
TRUE if the control is a part of Quick Access panel.
CRect | m_rcRow
Bounding rectangle of the control's row.
CRect | m_rcControl
Bounding rectangle of the control.
DWORD | m_dwHideFlags
Hidden flags.
DWORD | m_dwFlags
Flags of the control.
CString | m_strCaption
Caption of the control.
CString | m_strCustomCaption
User-defined caption.
CString | m_strShortcutText
Shortcut text.
CString | m_strShortcutTextAuto
Shortcut text.
CString | m_strTooltipText
Tooltip text.
CString | m_strDescriptionText
Description text.
CString | m_strParameter
Parameter text.
CString | m_strKeyboardTip
Keyboard tip.
CXTPControls * | m_pControls
Parent control collection.
XTPControlType | m_controlType
Type of the control.
CXTPCommandBar * | m_pParent
The Parent command bar.
BOOL | m_bExpanded
TRUE if the control is expanded.
CString | m_strCategory
Category of the control.
BOOL | m_bDefaultItem
TRUE if the item is default pop-up item.
CDocTemplateMap | m_mapDocTemplatesAssigned
Assigned templates.
CDocTemplateMap | m_mapDocTemplatesExcluded
Excluded templates.
XTPButtonStyle | m_buttonStyle
Button Style.
XTPButtonStyle | m_buttonCustomStyle
User-defined style of button.
XTPButtonStyle | m_buttonRibbonStyle
User-defined style of button.
BOOL | m_bCloseSubMenuOnClick
TRUE is sub-menus are closed as soon as a control is clicked.
CXTPRibbonGroup * | m_pRibbonGroup
Ribbon group of control.
CXTPControlAction * | m_pAction
Action of the control.
int | m_nWidth
Width of the control.
int | m_nHeight
Height of the control.
int | m_nExecuteOnPressInterval
Delay between each message when control is pressed.
CSize | m_szIcon
The size of the icon used for the control.
BOOL | m_bLayoutRTL
Indicate does last layout is RTL.

Detailed Description

CXTPControl is a CXTPCmdTarget derived class.

It represents the parent class for the command bar's controls.

Member Function Documentation

◆ AssignDocTemplate()

AFX_INLINE void AssignDocTemplate ( UINT nIDResource )

Call this method to assign a document template to the control.

Assigned control will be shown only when the child MDI window is activated with the assigned document template.

Parameters
nIDResource Document template identifier.
See also
AssignDocTemplate

◆ ClickToolBarButton()

void ClickToolBarButton ( CRect rcActiveRect = CRect(0, 0, 0, 0) )
protected

This helper method is called when the user clicks the toolbar's button.

Parameters
rcActiveRect Rectangle of the control.

◆ Compare()

virtual BOOL Compare ( CXTPControl * pOther )
virtual

Call this member to compare controls.

Parameters
pOther The control to compare with.
Returns
TRUE if the controls are identical, otherwise FALSE.

Reimplemented in CXTPControlComboBox, CXTPControlEdit, and CXTPControlPopup.

◆ Copy()

virtual void Copy | ( | CXTPControl * | pControl,
 |  | BOOL | bRecursive = FALSE )
 virtual

This method is called to copy the control.

Parameters
pControl | Pointer to a source CXTPControl object.
bRecursive | TRUE to copy recursively.

Reimplemented in CXTPControlButton, CXTPControlButtonColor, CXTPControlComboBox, CXTPControlCustom, CXTPControlEdit, CXTPControlGallery, CXTPControlListBox, CXTPControlPopup, CXTPControlPopupColor, CXTPControlProgress, CXTPControlSelector, CXTPControlStatic, and CXTPRibbonControlTab.

◆ CustomizeStartDrag()

virtual void CustomizeStartDrag ( CPoint point )
protectedvirtual

This member is called when the user starts to drag the control in customize mode.

Parameters
point Specifies the x- and y- coordinates of the cursor.
See also
IsCustomizeMode, CustomizeStartResize

◆ CustomizeStartResize()

virtual BOOL CustomizeStartResize ( CPoint point )
protectedvirtual

This method is called when user starts to resize control in customize mode.

Parameters
point Specifies the x- and y- coordinates of the cursor.
Returns
TRUE if control processes this event, otherwise FALSE.
See also
IsCustomizeMode, CustomizeStartDrag, GetCustomizeMinWidth

◆ DoCustomDragOver()

virtual BOOL DoCustomDragOver | ( | CXTPCommandBar * | pCommandBar,
 |  | CPoint | point,
 |  | DROPEFFECT & | dropEffect )
 protectedvirtual

The implementation may implement a custom drag over handling logic in this method.

Parameters
pCommandBar | Pointer to a CXTPCommandBar object.
point | Mouse position.
dropEffect | DROPEFFECT enumerator.
Returns
TRUE if custom implementation handles drag over, otherwise FALSE.

Reimplemented in CXTPControlCustom, CXTPControlOleItems, CXTPControlPopup, CXTPControlRecentFileList, CXTPControlToolbars, CXTPControlWindowList, and CXTPRibbonControlSystemRecentFileList.

◆ DoPropExchange()

virtual void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Either reads this object from or writes this object to an archive.

Parameters
pPX A CXTPPropExchange object to serialize to or from.

Reimplemented in CXTPControlButton, CXTPControlButtonColor, CXTPControlComboBox, CXTPControlCustom, CXTPControlEdit, CXTPControlGallery, CXTPControlListBox, CXTPControlPopup, CXTPControlProgress, CXTPControlSelector, CXTPControlStatic, and CXTPRibbonControlTab.

◆ Draw()

virtual void Draw ( CDC * pDC )
virtual

This method is called to draw the control.

Parameters
pDC Pointer to a valid device context.

Reimplemented in CXTPControlBitmap, CXTPControlButtonColor, CXTPControlColorSelector, CXTPControlCustom, CXTPControlHyperlink, CXTPControlListBox, CXTPControlMarkupLabel, CXTPControlProgress, CXTPControlSelector, CXTPControlStatic, CXTPControlTabWorkspace, CXTPRibbonControlSystemButton, CXTPRibbonControlSystemPopupBarButton, CXTPRibbonControlSystemPopupBarListCaption, CXTPRibbonControlSystemPopupBarListItem, CXTPRibbonControlSystemPopupBarPinableListItem, and CXTPRibbonControlTab.

◆ ExcludeDocTemplate()

AFX_INLINE void ExcludeDocTemplate ( UINT nIDResource )

Call this method to exclude the document template from control.

Control will be shown only when the child MDI window is activated and the document template is not excluded.

Parameters
nIDResource Document template identifier.
See also
ExcludeDocTemplate

◆ FromUI()

static CXTPControl *AFX_CDECL FromUI ( CCmdUI * pCmdUI )
static

Call this member to retrieve CXTPControl from a CCmdUI structure.

Parameters
pCmdUI Address of the CCmdUI structure.
Returns
CXTPControl from the CCmdUI structure.

◆ GenerateCommandBarList()

virtual void GenerateCommandBarList | ( | DWORD & | nID,
 |  | CXTPCommandBarList * | pCommandBarList,
 |  | XTP_COMMANDBARS_PROPEXCHANGE_PARAM * | pParam )
 protectedvirtual

This method is called from SaveCommandBars to save all child command bars.

Parameters
nID | Current Identifier counter.
pCommandBarList | List of saved command bars.
pParam | Serialize parameters.
See also
RestoreCommandBarList

◆ GetAction()

AFX_INLINE CXTPControlAction * GetAction ( ) const

Call this method to retrieve an action associated with control.

Returns
Action associated with control.
See also
CXTPControlAction, SetAction

◆ GetBeginGroup()

AFX_INLINE BOOL GetBeginGroup ( ) const

Call this member to determine if the control has a separator.

Returns
TRUE if the control starts a new group; otherwise FALSE.

◆ GetButtonSize()

virtual CSize GetButtonSize ( ) const
virtual

Call this function to get the size of the command bar button.

Returns
The width and height values of the command bar button.

Reimplemented in CXTPRibbonControlSystemPopupBarButton.

◆ GetCaption()

AFX_INLINE CString GetCaption ( ) const
virtual

Call this member to get the control's caption.

Returns
The caption of the control.

Reimplemented in CXTPControlPopup, and CXTPRibbonControlSystemButton.

◆ GetCategory()

AFX_INLINE CString GetCategory ( ) const

Call this method to retrieve the category of the control.

Returns
Category of the control.

◆ GetChecked()

AFX_INLINE BOOL GetChecked ( ) const

Call this member to get the checked state of the control.

Returns
TRUE if the control is checked, otherwise FALSE.

◆ GetCloseSubMenuOnClick()

AFX_INLINE BOOL GetCloseSubMenuOnClick ( ) const

Call this member function to check if sub-menus will close as soon as a control is clicked.

Returns
TRUE if the sub-menu will close when a control is clicked. FALSE if the sub-menu will remain open after a control is clicked.
See also
SetCloseSubMenuOnClick

◆ GetCommandBar()

AFX_INLINE CXTPCommandBar * GetCommandBar ( ) const
virtual

Call this member to get the child command bar.

Returns
A pointer to the child command bar.

Reimplemented in CXTPControlPopup.

◆ GetControls()

AFX_INLINE CXTPControls * GetControls ( ) const

Call this member to get the parent controls collection.

Returns
A CXTPControls pointer to the parent controls.

◆ GetCustomizeMinHeight()

AFX_INLINE int GetCustomizeMinHeight ( ) const
protectedvirtual

Retrieves available minimum height of the control.

This method is called in CustomizeStartResize to retrieve the height of available rectangles of a resized control.

Returns
Returns zero by default.
See also
CXTPControlComboBox::GetCustomizeMinHeight, CXTPControlEdit::GetCustomizeMinHeight

◆ GetCustomizeMinWidth()

AFX_INLINE int GetCustomizeMinWidth ( ) const
protectedvirtual

Retrieves the available minimum width of control.

This method is called in CustomizeStartResize to retrieve the width of available rectangles of a resized control.

Returns
Returns zero by default.
See also
CXTPControlComboBox::GetCustomizeMinWidth, CXTPControlEdit::GetCustomizeMinWidth

Reimplemented in CXTPControlComboBox, and CXTPControlEdit.

◆ GetCustomShortcutText()

AFX_INLINE CString GetCustomShortcutText ( ) const

Call this member to get the control's text displayed for the shortcut in a pop-up menu.

Returns
The keyboard tip of the control.

◆ GetDescription()

AFX_INLINE CString GetDescription ( ) const
virtual

Call this member to get the control's description.

Returns
The description of the control.

◆ GetEnabled()

BOOL GetEnabled ( ) const

Call this member to check if the control is enabled.

Returns
TRUE if the control is enabled, otherwise FALSE.

◆ GetExecuteOnPressInterval()

AFX_INLINE int GetExecuteOnPressInterval ( ) const

Call this method to get the delay (in milliseconds) between WM_COMMAND messages while a button is pressed by the user.

Returns
The delay (in milliseconds) between each message.
See also
SetExecuteOnPressInterval

◆ GetExpanded()

AFX_INLINE BOOL GetExpanded ( ) const

Call this member to check if the control is expanded.

Returns
TRUE if the control is expanded; otherwise FALSE.

◆ GetFlags()

DWORD GetFlags ( ) const

Call this member to retrieve control special flags.

Returns
Control special flags.
See also
SetFlags, XTPControlFlags

◆ GetHeight()

AFX_INLINE int GetHeight ( ) const

Call this member to get the height of the control.

Returns
Height of the control in pixels.
See also
GetWidth

◆ GetHelpId()

AFX_INLINE int GetHelpId ( ) const

Call this member to get the help identifier.

Returns
Help identifier of the control.

◆ GetHideFlags()

AFX_INLINE DWORD GetHideFlags ( ) const

Call this method to retrieve hidden flags.

Returns
Flags of the control's visibility.

HideFlags will tell how a control was hidden if it is hidden or why it is not visible. Most of these flags are read only and should not be set by the developer. There is only one situation where you should set these flags manually. xtpHideCustomize is the only flag that should ever be manually set. You would do this when you want the control to initially be hidden but still exist in the customize pop-up of a toolbar. This will cause the control to appear in the Add and Remove Buttons pop-up without a check mark indicating that it is currently hidden. This flag will automatically be set when a command is hidden this way.

See also
XTPControlHideFlags

◆ GetIconId()

AFX_INLINE int GetIconId ( ) const

Call this member to get the icon's identifier.

Returns
An icon's identifier of the control.

◆ GetIconSize()

virtual CSize GetIconSize ( ) const
virtual

Call this member function to get the size of a toolbar icon.

Returns
Returns size of toolbar icon
See also
GetButtonSize

Reimplemented in CXTPRibbonControlSystemPopupBarButton.

◆ GetID()

AFX_INLINE int GetID ( ) const

Call this member to get the control's identifier.

Returns
The identifier of the control.

◆ GetImage()

virtual CXTPImageManagerIcon * GetImage ( int nWidth = 16 ) const
virtual

Call this method to retrieve the image of the control.

Parameters
nWidth Width of the image to retrieve.
Returns
A pointer to a CXTPImageManagerIcon object.

◆ GetImageManager()

CXTPImageManager * GetImageManager ( ) const

Call this method to retrieve the image manager.

Returns
A pointer to a CXTPImageManager object.

◆ GetIndex()

AFX_INLINE long GetIndex ( ) const

Call this member to get the index of the control.

Returns
The index of the control.

◆ GetKeyboardTip()

AFX_INLINE CString GetKeyboardTip ( ) const

Call this member to get the keyboard tip.

Returns
The keyboard tip of the control.

◆ GetPaintManager()

CXTPPaintManager * GetPaintManager ( ) const

Call this method to retrieve the paint manager.

Returns
A pointer to a CXTPPaintManager object.

◆ GetParameter()

AFX_INLINE CString GetParameter ( ) const

Call this member to get the control's parameter.

Returns
The parameter of the control.
See also
GetTag, SetParameter

◆ GetParent()

AFX_INLINE CXTPCommandBar * GetParent ( ) const

Call this member to get the parent command bar.

Returns
The parent command bar object.

◆ GetPopuped()

AFX_INLINE BOOL GetPopuped ( ) const
virtual

Call this member to get the control's pop-up state.

Returns
TRUE if the control is a pop-up, otherwise FALSE.

Reimplemented in CXTPControlPopup.

◆ GetPressed()

AFX_INLINE BOOL GetPressed ( ) const
virtual

Call this member to check the pressed state of the control.

Returns
TRUE if the control is pressed, otherwise FALSE.

◆ GetRect()

AFX_INLINE CRect GetRect ( ) const

Call this member to get the bounding rectangle of the control.

Returns
The bounding rectangle of the control.

◆ GetRibbonGroup()

AFX_INLINE CXTPRibbonGroup * GetRibbonGroup ( ) const

Returns the ribbon group that the control belongs to.

Returns
If the control belongs to a ribbon group, then the CXTPRibbonGroup that the control belongs to is returned. If the control does not belong to a ribbon group, then NULL is returned.
See also
CXTPRibbonBar::RebuildControls

◆ GetRowRect()

AFX_INLINE CRect GetRowRect ( ) const

Call this method to retrieve the position of the control's row.

Returns
Bounding rectangle of the control's row.

◆ GetSelected()

AFX_INLINE int GetSelected ( ) const
virtual

Call this member to check if the control is selected.

Returns
TRUE if the control is selected; otherwise FALSE.

◆ GetShortcutText()

AFX_INLINE CString GetShortcutText ( ) const

Call this member to get the control's shortcut.

Returns
The shortcut of the control.

◆ GetSize()

virtual CSize GetSize ( CDC * pDC )
virtual

This method is called to determine the size of the control.

Parameters
pDC Pointer to a valid device context.
Returns
A CSize object containing the size of the control.

Reimplemented in CXTPControlBitmap, CXTPControlButtonColor, CXTPControlColorSelector, CXTPControlCustom, CXTPControlHyperlink, CXTPControlListBox, CXTPControlMarkupLabel, CXTPControlProgress, CXTPControlSelector, CXTPControlStatic, CXTPControlTabWorkspace, CXTPRibbonControlSystemButton, CXTPRibbonControlSystemPopupBarButton, CXTPRibbonControlSystemPopupBarListCaption, and CXTPRibbonControlSystemPopupBarListItem.

◆ GetStyle()

XTPButtonStyle GetStyle ( ) const

Call this member to get the control's style.

Returns
The style of the control.

◆ GetTag()

AFX_INLINE DWORD_PTR GetTag ( ) const

This method retrieves the application-supplied, 32-bit value associated with the control.

Returns
The 32-bit value associated with the control.

◆ GetTooltip()

AFX_INLINE CString GetTooltip ( ) const
virtual

Call this member to get the control's tooltip.

Returns
Tooltip of the control.

◆ GetType()

AFX_INLINE XTPControlType GetType ( ) const

Call this member to get the control's type.

Returns
The type of the control. It can be one of the following: xtpControlButton: Indicates the control is a simple button (CXTPControlButton). xtpControlPopup: Indicates the control is a simple pop-up button (CXTPControlPopup). xtpControlButtonPopup: Indicates the control is a pop-up button with icon (CXTPControlPopup). xtpControlSplitButtonPopup: Indicates the control is a split button pop-up (CXTPControlPopup). xtpControlComboBox: Indicates the control is a combobox (CXTPControlComboBox). xtpControlEdit: Indicates the control is an edit control (CXTPControlEdit). xtpControlLabel: Indicates the control is a label (CXTPControlLabel).

◆ GetWidth()

AFX_INLINE int GetWidth ( ) const

Call this member to get the width of the control.

Returns
Width of the control in pixels.
See also
GetHeight

◆ GetWrap()

AFX_INLINE BOOL GetWrap ( ) const

Call this method to check if the control is wrapped.

Returns
TRUE if the control is wrapped; otherwise FALSE.
See also
SetWrap

◆ HasDwmCompositedRect()

BOOL HasDwmCompositedRect ( ) const

This method is called to determine if control has a Vista DWM transparent area.

Returns
TRUE if control has a Vista DWM transparent area, otherwise FALSE.

◆ IsCaptionVisible()

virtual BOOL IsCaptionVisible ( ) const
virtual

Call this member to determine if the caption of the control is visible.

Returns
TRUE if the caption of the control is visible.

Reimplemented in CXTPControlComboBox, and CXTPControlEdit.

◆ IsCursorOver()

BOOL IsCursorOver ( ) const

Call this member to determine if the mouse pointer is over the control.

Returns
TRUE if the mouse cursor is over the control; otherwise FALSE.

◆ IsCustomizeMode()

BOOL IsCustomizeMode ( ) const
protected

Call this method to determine if command bars is in customize mode.

Returns
TRUE if command bars is in Customize mode; otherwise FALSE.

◆ IsCustomizeMovable()

virtual BOOL IsCustomizeMovable ( ) const
virtual

This method is called to determine if control can be repositioned in customize mode.

Returns
True if in customize mode, false otherwise
See also
xtpFlagNoMovable

◆ IsCustomizeResizeAllow()

virtual BOOL IsCustomizeResizeAllow ( ) const
protectedvirtual

This member checks if the user can resize the control.

Returns
TRUE if the user can resize the control, otherwise FALSE.

Reimplemented in CXTPControlComboBox, and CXTPControlEdit.

◆ IsFocusable()

AFX_INLINE BOOL IsFocusable ( ) const
protectedvirtual

This method is called to check if the control can accept focus.

Returns
TRUE if the control can accept focus, otherwise FALSE.
See also
SetFocused, IsFocused

Reimplemented in CXTPControlComboBox, CXTPControlEdit, and CXTPRibbonControlTab.

◆ IsFocused()

AFX_INLINE BOOL IsFocused ( ) const
virtual

Call this member to check the focused state of the control.

Returns
TRUE if the control is focused, otherwise FALSE.

Reimplemented in CXTPControlCheckBox, CXTPControlComboBox, CXTPControlEdit, CXTPControlListBox, CXTPControlRadioButton, and CXTPRibbonControlTab.

◆ IsItemDefault()

BOOL IsItemDefault ( ) const

Call this method to check if a control is a default menu item.

Returns
TRUE if the control is a default menu item, otherwise FALSE.

A default menu item will appear in bold text.

See also
SetItemDefault

◆ IsLayoutChanged()

BOOL IsLayoutChanged ( )
protected

Call this member to determine if the layout has changed (RTL to LTR or LTR to RLT).

Returns
TRUE if the layout has changed, otherwise FALSE.

◆ IsLayoutRTL()

BOOL IsLayoutRTL ( ) const
protected

Determines if right-to-left (RTL) mode is set.

Returns
TRUE if text is displayed using right-to-left (RTL) reading-order properties.

◆ IsOnQuickAccess()

AFX_INLINE BOOL IsOnQuickAccess ( ) const

Call this member to check if a control is a part of the Quick Access panel.

Returns
TRUE if the control is a part of the Quick Access panel; otherwise FALSE.

◆ IsTemporary()

AFX_INLINE BOOL IsTemporary ( ) const

Call this method to determine if a control is temporary.

Temporary controls will not be saved to the system registry when the application is closed (If the CommandBars layout is saved).

Returns
TRUE if the control is temporary, otherwise FALSE.

◆ IsTransparent()

virtual BOOL IsTransparent ( ) const
inlinevirtual

Determines if the control needs to draw its background.

Returns
TRUE if the paint manager must skip filling the background of the control.

Reimplemented in CXTPControlGallery, and CXTPRibbonControlSystemPopupBarButton.

◆ IsVisible()

AFX_INLINE BOOL IsVisible ( DWORD dwSkipFlags = 0 ) const
virtual

Call this member to determine if the control is visible.

Parameters
dwSkipFlags Combination of XTPControlHideFlags that can be ignored.
Returns
TRUE if the control is visible, otherwise FALSE.
See also
XTPControlHideFlags, GetHideFlags

◆ NotifySite() [1/3]

LRESULT NotifySite | ( | CWnd * | pSite,
 |  | UINT | code,
 |  | NMXTPCONTROL * | pNM )

This method is called to send message code to the parent site window.

Parameters
code | Message to be sent.
pNM | Structure that is passed as a parameter in the CBN_XTP_EXECUTE message.
pSite | Parent window of commandbar.
Returns
Results.

◆ NotifySite() [2/3]

LRESULT NotifySite ( UINT code )

This method is called to send message code to the parent site window.

Parameters
code Message to be sent.
Returns
Results.

◆ NotifySite() [3/3]

LRESULT NotifySite | ( | UINT | code,
 |  | NMXTPCONTROL * | pNM )

This method is called to send message code to the parent site window.

Parameters
code | Message to be sent.
pNM | Structure that is passed as a parameter in the CBN_XTP_EXECUTE message.
Returns
Results.

◆ OnActionChanged()

virtual void OnActionChanged ( int nProperty )
protectedvirtual

This method is called when an action property is changed.

Parameters
nProperty Property of the action.
See also
OnActionChanging

Reimplemented in CXTPControlComboBox, CXTPControlCustom, and CXTPControlEdit.

◆ OnActionChanging()

AFX_INLINE void OnActionChanging ( int nProperty )
protectedvirtual

This method is called when an action property is about to be changed.

Parameters
nProperty Property of the action.
See also
OnActionChanged

Reimplemented in CXTPControlComboBox, and CXTPControlEdit.

◆ OnCalcDynamicSize()

AFX_INLINE void OnCalcDynamicSize ( DWORD dwMode )
virtual

This method is called before recalculating the parent command bar size to calculate the dimensions of the control.

Parameters
dwMode Flags used to determine the height and width of the dynamic command bar. See Remarks section for a list of values.

The following predefined flags are used to determine the height and width of the dynamic command bar. Use the bitwise-OR (|) operator to combine the flags.

LM_STRETCH: Indicates whether the command bar should be stretched to the size of the frame. Set if the bar is not a docking bar (not available for docking). Not set when the bar is docked or floating (available for docking). If set, LM_STRETCH returns dimensions based on LM_HORZ state. LM_STRETCH works similarly to the bStretch parameter used in CalcFixedLayout; see that member function for more information about the relationship between stretching and orientation. LM_HORZ: Indicates that the bar is horizontally or vertically oriented. Set if the bar is horizontally oriented, and if it is vertically oriented, it is not set. LM_HORZ works similarly to the the bHorz parameter used in CalcFixedLayout; see that member function for more information about the relationship between stretching and orientation. LM_MRUWIDTH: Most Recently Used Dynamic Width. Uses the remembered most recently used width. LM_HORZDOCK: Horizontal Docked Dimensions. Returns the dynamic size with the largest width. LM_VERTDOCK: Vertical Docked Dimensions. Returns the dynamic size with the largest height. LM_COMMIT: Resets LM_MRUWIDTH to the current width of the floating command bar.

The framework calls this member function to calculate the dimensions of a dynamic command bar.

Override this member function to provide your own layout in classes you derive from CXTPControl. XTP classes derived from CXTPControl, such as CXTPControlComboBox, override this member function to provide their own implementation.

See also
CXTPControlComboBox, CXTPControlCustom, CXTPControlEdit, CXTPControlWindowList, CXTPControlWorkspaceActions, CXTPControlToolbars, CXTPControlOleItems, CXTPControlRecentFileList, CXTPControlSelector, CXTPControlListBox

Reimplemented in CXTPControlComboBox, CXTPControlCustom, CXTPControlEdit, CXTPControlGallery, CXTPControlListBox, CXTPControlOleItems, CXTPControlRecentFileList, CXTPControlSelector, CXTPControlToolbars, CXTPControlWindowList, CXTPControlWorkspaceActions, and CXTPRibbonControlSystemRecentFileList.

◆ OnClick()

AFX_INLINE void OnClick | ( | BOOL | bKeyboard = FALSE,
 |  | CPoint | pt = CPoint(0, 0) )
 virtual

This method is called when the user clicks the control.

Parameters
bKeyboard | TRUE if the control is selected using the keyboard.
pt | Mouse cursor position.

Reimplemented in CXTPControlButton, CXTPControlColorSelector, CXTPControlComboBox, CXTPControlCustom, CXTPControlEdit, CXTPControlHyperlink, CXTPControlListBox, CXTPControlPopup, CXTPControlProgress, and CXTPControlTabWorkspace.

◆ OnCustomizeDragOver()

virtual void OnCustomizeDragOver | ( | CXTPControl * | pDataObject,
 |  | CPoint | point,
 |  | DROPEFFECT & | dropEffect )
 protectedvirtual

This member is called when the user moves the mouse over the control.

Parameters
pDataObject | Pointer to a CXTPControl object.
point | Mouse position.
dropEffect | DROPEFFECT enumerator.

Reimplemented in CXTPControlPopup.

◆ OnCustomizeMouseMove()

void OnCustomizeMouseMove ( CPoint point )
protected

This member is called when the mouse cursor moves in customized mode.

Parameters
point Specifies the x- and y- coordinates of the cursor.

◆ OnHookKeyDown()

AFX_INLINE BOOL OnHookKeyDown | ( | UINT | nChar,
 |  | LPARAM | lParam )
 protectedvirtual

This method is called when a non-system key is pressed.

Parameters
nChar | Specifies the virtual key code of the given key.
lParam | Specifies additional message-dependent information.
Returns
TRUE if the key was handled, otherwise FALSE.

Reimplemented in CXTPControlCheckBox, CXTPControlComboBox, CXTPControlEdit, CXTPControlListBox, CXTPControlRadioButton, and CXTPRibbonControlTab.

◆ OnHookMouseWheel()

AFX_INLINE BOOL OnHookMouseWheel | ( | UINT | nFlags,
 |  | short | zDelta,
 |  | CPoint | point )
 protectedvirtual

This method is called when the user rotates the mouse wheel.

Parameters
nFlags | Indicates whether various virtual keys are down.
zDelta | Indicates distance rotated.
point | Specifies the x- and y- coordinates of the cursor.
Returns
TRUE if the key was handled, otherwise FALSE.

◆ OnLButtonDblClk()

virtual BOOL OnLButtonDblClk ( CPoint point )
protectedvirtual

This member is called when the user double-clicks the left mouse button.

Parameters
point Specifies the x- and y- coordinates of the cursor.
Returns
TRUE if successful; otherwise FALSE.

Reimplemented in CXTPControlPopup, and CXTPRibbonControlSystemButton.

◆ OnLButtonDown()

virtual void OnLButtonDown ( CPoint point )
protectedvirtual

This member is called when the user presses the left mouse button down.

Parameters
point Specifies the x- and y- coordinates of the cursor.

◆ OnLButtonUp()

AFX_INLINE void OnLButtonUp ( CPoint point )
protectedvirtual

This member is called when the user releases the left mouse button.

Parameters
point Specifies the x- and y- coordinates of the cursor.

Reimplemented in CXTPControlButton, CXTPControlColorSelector, CXTPControlPopup, CXTPControlSelector, and CXTPRibbonControlSystemPopupBarPinableListItem.

◆ OnMouseMove()

AFX_INLINE void OnMouseMove ( CPoint point )
protectedvirtual

This member is called when the mouse cursor moves.

Parameters
point Specifies the x- and y- coordinates of the cursor.

Reimplemented in CXTPControlColorSelector, CXTPControlComboBox, CXTPControlEdit, CXTPControlHyperlink, CXTPControlPopup, CXTPControlSelector, CXTPControlTabWorkspace, and CXTPRibbonControlSystemPopupBarPinableListItem.

◆ OnRButtonDown()

AFX_INLINE BOOL OnRButtonDown ( CPoint point )
protectedvirtual

This member is called when the user press the right mouse button.

Parameters
point Specifies the x- and y- coordinates of the cursor.
Returns
True if right mouse button is preseed down, otherwise false

◆ OnRButtonUp()

AFX_INLINE BOOL OnRButtonUp ( CPoint point )
protectedvirtual

This member is called when the user releases the right mouse button.

Parameters
point Specifies the x- and y- coordinates of the cursor.
Returns
True when right mouse button is released, otherwise false

◆ OnSetPopup()

AFX_INLINE BOOL OnSetPopup ( BOOL bPopup )
protectedvirtual

This method is called to pop-up the control.

Parameters
bPopup TRUE to set pop-up.
Returns
TRUE if successful; otherwise FALSE.

Reimplemented in CXTPControlComboBox, CXTPControlPopup, and CXTPControlSizeComboBox.

◆ OnSetSelected()

virtual BOOL OnSetSelected ( int bSelected )
protectedvirtual

This method is called when the control becomes selected.

Parameters
bSelected TRUE if the control becomes selected.
Returns
TRUE if successful, otherwise FALSE.

Reimplemented in CXTPControlColorSelector, CXTPControlComboBox, CXTPControlEdit, CXTPControlListBox, CXTPControlPopup, CXTPControlSelector, CXTPRibbonControlSystemPopupBarPinableListItem, and CXTPRibbonControlTab.

◆ OnToolHitTest()

AFX_INLINE INT_PTR OnToolHitTest | ( | CPoint | point,
 |  | TOOLINFO * | pTI ) const
 protectedvirtual

The framework calls this member function to determine whether a point is in the bounding rectangle of the specified tool.

Parameters
point | Specifies the x- and y- coordinates of the cursor. These coordinates are always relative to the upper-left corner of the window.
pTI | A pointer to a TOOLINFO structure.
Returns
If the tooltip control was found, the window control ID will be returned. If the tooltip control was not found, a value of -1 will be returned.

Reimplemented in CXTPControlColorSelector, and CXTPControlTabWorkspace.

◆ RedrawParent()

void RedrawParent ( BOOL bAnimate = TRUE )

This method is called to redraw the parent command bar.

Parameters
bAnimate TRUE to animate changes.

◆ Reset()

void Reset ( )

Call this member to reset the icon and caption of a control to its default settings before it was customized by the user.

The caption and icon of a control is customized while in customization mode.

See also
SetCustomIcon, m_strCustomCaption

◆ RestoreCommandBarList()

virtual void RestoreCommandBarList ( CXTPCommandBarList * pCommandBarList )
protectedvirtual

This method is called from LoadCommandBars to restore controls and its child command bars.

Parameters
pCommandBarList Command bars collection that contains all the command bars to be restored.
See also
GenerateCommandBarList

Reimplemented in CXTPControlPopup.

◆ ScreenToClient()

void ScreenToClient ( CPoint * point )
protected

The ScreenToClient function converts the screen coordinates of a specified point on the screen.

Parameters
point Pointer to a CPoint object that specifies the screen coordinates to be converted.

◆ SetAction()

virtual void SetAction ( CXTPControlAction * pAction )
virtual

Call this method to manually assign an action for control.

Parameters
pAction Action to assign.
See also
CXTPControlAction, GetAction

◆ SetBeginGroup()

AFX_INLINE void SetBeginGroup ( BOOL bBeginGroup )
virtual

Call this member to begin a new group using a separator.

Parameters
bBeginGroup TRUE if the control starts a new group.

◆ SetCaption() [1/2]

void SetCaption ( LPCTSTR lpszCaption )

Call this member to set the caption of the control.

Parameters
lpszCaption Caption to be set.
See also
SetPrompt, SetDescription, SetTooltip

◆ SetCaption() [2/2]

void SetCaption ( UINT nIDCaption )

Call this member to set the caption of the control.

Parameters
nIDCaption Caption resource identifier.
See also
SetPrompt, SetDescription, SetTooltip

◆ SetCategory()

AFX_INLINE void SetCategory ( LPCTSTR lpszCategory )

Call this method to set the category of the control.

Parameters
lpszCategory Category of the control.

◆ SetChecked()

AFX_INLINE void SetChecked ( BOOL bChecked )
virtual

Call this member to set the checked state of the control.

If the control does not have an xtpFlagManualUpdate flag, you must call the SetCheck member of CCmdUI in the ON_UPDATE_COMMAND_UI handler.

Parameters
bChecked TRUE to set the control to checked.
See also
GetChecked, SetEnabled

◆ SetCloseSubMenuOnClick()

AFX_INLINE void SetCloseSubMenuOnClick ( BOOL bCloseOnClick )

Call this member function to enable/disable the closing of sub-menus when a control is clicked in the menu.

Parameters
bCloseOnClick TRUE if the sub-menu will close when a control is clicked. FALSE if the sub-menu will remain open after a control is clicked.
See also
GetCloseSubMenuOnClick

◆ SetCustomIcon()

void SetCustomIcon ( HICON hIcon )

Call this member to set a custom icon to this control.

Parameters
hIcon HICON object containing the icon to set to this control.
See also
Reset

◆ SetCustomShortcutText()

AFX_INLINE void SetCustomShortcutText ( LPCTSTR lpszCustomShortcutText )

Call this member to set the text displayed for the shortcut in a pop-up menu.

Parameters
lpszCustomShortcutText Keyboard tip to be set.

◆ SetDescription()

AFX_INLINE void SetDescription ( LPCTSTR lpszDescription )

Call this member to set the description of the control.

Parameters
lpszDescription Description to be set.
See also
SetCaption, SetPrompt, SetTooltip

◆ SetEnabled()

AFX_INLINE void SetEnabled ( BOOL bEnabled )
virtual

Call this member to enable/disable the control.

If the control does not have an xtpFlagManualUpdate flag, you must call the Enable member of CCmdUI in the ON_UPDATE_COMMAND_UI handler.

Parameters
bEnabled TRUE to enable the control, FALSE to disable the control.
See also
GetEnabled, SetChecked

◆ SetExecuteOnPressInterval()

AFX_INLINE void SetExecuteOnPressInterval ( int nExecuteOnPressInterval )

Call this method to set the delay (in milliseconds) between WM_COMMAND messages while a button is pressed by the user.

Parameters
nExecuteOnPressInterval The delay (in milliseconds) between each message.
See also
GetExecuteOnPressInterval

◆ SetExpanded()

void SetExpanded ( BOOL bExpanded )
protected

This method is called to set the control's expanded state.

Parameters
bExpanded TRUE to set the control to expanded.

◆ SetFlags()

void SetFlags ( DWORD dwFlags )

Call this member to set the flags of the control.

Parameters
dwFlags Control flags.

Flags to be added or removed can be combined by using the bitwise OR (|) operator. It can be one or more of the following: xtpFlagRightAlign: Indicates the control is right aligned. xtpFlagSkipFocus: Indicates the control does not have focus. xtpFlagLeftPopup: Indicates the child bar should pop-up on the left. xtpFlagManualUpdate: Indicates the control is manually updated. xtpFlagNoMovable: Indicates the control's customization is disabled. xtpFlagControlStretched: Indicates the control is stretched in the parent command bar.

See also
GetFlags, XTPControlFlags

◆ SetFocused()

AFX_INLINE void SetFocused ( BOOL bFocused )
virtual

Call this member to set the focused state of the control.

Parameters
bFocused TRUE to set the control to focused.

Reimplemented in CXTPControlComboBox, CXTPControlEdit, and CXTPRibbonControlTab.

◆ SetHeight()

AFX_INLINE void SetHeight ( int nHeight )
virtual

Call this member to set the height of the control.

Parameters
nHeight The height of the control.

◆ SetHelpId()

AFX_INLINE void SetHelpId ( int nId )

Call this member to set the control help identifier.

Parameters
nId Help identifier to be set.

◆ SetHideFlag()

AFX_INLINE BOOL SetHideFlag | ( | XTPControlHideFlags | dwFlag,
 |  | BOOL | bSet )

Call this member to set/remove hide flags.

Parameters
dwFlag | XTPControlHideFlags type of flag to set/remove.
bSet | TRUE to set flag; FALSE to remove.

SetHideFlag will tell how a control was hidden if it is hidden or why it is not visible. Most of these flags are read only and should not be set by the developer.

Returns
TRUE if flags were changed, otherwise FALSE.
See also
XTPControlHideFlags, SetHideFlags

◆ SetHideFlags()

AFX_INLINE void SetHideFlags ( DWORD dwFlags )
virtual

This method is called to hide the control.

Parameters
dwFlags Reasons to hide.

HideFlags will tell how a control was hidden if it is hidden or why it is not visible. Most of these flags are read only and should not be set by the developer. There is only one situation where you should set these flags manually. xtpHideCustomize is the only flag that should ever be manually set. You would do this when you want the control to initially be hidden but still exist in the customize pop-up of a toolbar. This will cause the control to appear in the Add and Remove Buttons pop-up without a check mark indicating that it is currently hidden. This flag will automatically be set when a command is hidden this way.

See also
XTPControlHideFlags

Reimplemented in CXTPControlComboBox, CXTPControlCustom, and CXTPControlEdit.

◆ SetHideWrap()

AFX_INLINE void SetHideWrap ( BOOL bHide )

This method is called to hide the control.

Parameters
bHide TRUE to set hide state.

◆ SetIconId()

AFX_INLINE void SetIconId ( int nId )

Call this member to set the control icon's identifier.

Parameters
nId Icon's identifier to be set.

◆ SetIconSize()

AFX_INLINE void SetIconSize ( CSize szIcon )

Call this member function to set the size of an icon for an individual control.

Parameters
szIcon Desired size of the icon.
See also
GetIconSize, GetButtonSize

◆ SetID()

void SetID ( int nId )

Call this member to set the identifier of the control.

Parameters
nId Identifier to be set.

◆ SetIndex()

void SetIndex ( int nIndex )
inlineprotected

This method is called to assign the order of the control in the controls list.

Parameters
nIndex Index of the control.

◆ SetItemDefault()

void SetItemDefault ( BOOL bDefault )

Call this method to set a control to be a default menu item.

Parameters
bDefault TRUE to set the control to be a default menu item.

A default menu item will appear in bold text.

See also
IsItemDefault

◆ SetKeyboardTip()

AFX_INLINE void SetKeyboardTip ( LPCTSTR lpszKeyboardTip )

Call this member to set the keyboard tip to the control.

Parameters
lpszKeyboardTip Keyboard tip to be set.

◆ SetOnQuickAccess()

AFX_INLINE void SetOnQuickAccess ( BOOL bOnQuicAccess = FALSE )

Call this member to set whether a control should be a part of the Quick Access panel.

Parameters
bOnQuicAccess True for quick access.

◆ SetParameter()

AFX_INLINE void SetParameter ( LPCTSTR lpszParameter )

Call this member to set the parameter of the control.

Parameters
lpszParameter Parameter to be set.

This method sets the CString value associated with the control. Use SetTag to set the numeric parameter.

See also
SetTag, GetParameter

◆ SetParent()

virtual void SetParent ( CXTPCommandBar * pParent )
inlineprotectedvirtual

This method is called to assign a parent command bar object.

Parameters
pParent Pointer to a CXTPCommandBar object.

Reimplemented in CXTPControlComboBox, CXTPControlEdit, and CXTPControlListBox.

◆ SetPressed()

AFX_INLINE void SetPressed ( BOOL bPressed )

Call this member to set the pressed state of the control.

Parameters
bPressed TRUE to set the control to pressed.

◆ SetPrompt()

void SetPrompt ( LPCTSTR lpszPrompt )

Call this member to load a string from a STRINGTABLE resource to set the tooltip and description of a control.

Parameters
lpszPrompt String from resource file that contains the tooltip and description of the item. The Caption will be set to use the tooltip text. The tooltip and description must be separated by "\n" if both are included. You can omit the description and both the tooltip and description will be set to the same value.

Resource strings are in the format "Description\nToolTip".

Note: The caption is set to the value of the tooltip when this member is called.

See also
SetCaption, SetDescription, SetTooltip

◆ SetRect()

AFX_INLINE void SetRect ( CRect rcControl )
virtual

This member is called to set the bounding rectangle of the control.

Parameters
rcControl Bounding rectangle of the control.

Reimplemented in CXTPControlComboBox, CXTPControlCustom, CXTPControlEdit, CXTPControlListBox, and CXTPControlTabWorkspace.

◆ SetRowRect()

AFX_INLINE void SetRowRect ( CRect rcRow )

Call this method to set the row of the control.

Parameters
rcRow Rectangle of the control's row.

◆ SetShortcutText()

AFX_INLINE void SetShortcutText ( LPCTSTR lpszShortcutText )

Call this member to set the shortcut string to the control.

Parameters
lpszShortcutText Shortcut to be set.

◆ SetStyle()

AFX_INLINE void SetStyle ( XTPButtonStyle buttonStyle )

Call this member to set the style of the control.

Parameters
buttonStyle The style to be set. Can be any of the values listed in the Remarks section.

buttonStyle parameter can be one of the following: xtpButtonAutomatic: Indicates the default style. xtpButtonCaption: Indicates caption drawing only. xtpButtonIcon: Indicates icon drawing only. xtpButtonIconAndCaption: Indicates icon and caption drawing.

◆ SetTag()

AFX_INLINE void SetTag ( DWORD_PTR dwTag )

This method sets the 32-bit value associated with the control.

Parameters
dwTag The new 32-bit value to associate with the control.

◆ SetTooltip()

AFX_INLINE void SetTooltip ( LPCTSTR lpszTooltip )

Call this member to set the tooltip of the control.

Parameters
lpszTooltip Tooltip to be set.
See also
SetCaption, SetDescription, SetPrompt

◆ SetVisible()

void SetVisible ( BOOL bVisible )

Call this member to set the visibility of the control.

Parameters
bVisible TRUE to set the control to visible, FALSE to set the control to hidden.

◆ SetWidth()

AFX_INLINE void SetWidth ( int nWidth )
virtual

Call this member to set the width of the control.

Parameters
nWidth The width of the control.

Reimplemented in CXTPControlListBox, and CXTPControlStatic.

◆ SetWrap()

AFX_INLINE void SetWrap ( BOOL bWrap )

Call this member to set the control to wrapped.

Parameters
bWrap TRUE to set the control to wrapped.
See also
GetWrap
The documentation for this class was generated from the following file:
  • XTPControl.h


Toolkit Pro: CXTPControlAction Class Reference

Public Member Functions | Public Attributes | Protected Member Functions | Protected Attributes | List of all members
CXTPControlAction Class Reference

CXTPControlAction is a CXTPCmdTarget derived class. More...

Inheritance diagram for CXTPControlAction:
[legend]

Public Member Functions

void | SetCaption (LPCTSTR lpszCaption)
Call this member to set the caption of the action.
void | SetCaption (UINT nIDCaption)
Call this member to set the caption of the action.
int | GetID () const
Call this member to get the action's identifier.
CString | GetCaption () const
Call this member to get the action's caption.
void | SetDescription (LPCTSTR lpszDescription)
Call this member to set the description of the action.
void | SetPrompt (LPCTSTR lpszPrompt)
Call this member to load a string from a STRINGTABLE resource to set the tooltip and description of a action.
CString | GetDescription () const
Call this member to get the action's description.
void | SetIconId (int nId)
Call this member to set the action icon's identifier.
int | GetIconId () const
Call this member to get the icon's identifier.
void | SetHelpId (int nId)
Call this member to set the action help identifier.
int | GetHelpId () const
Call this member to get the help identifier.
void | SetEnabled (BOOL bEnabled)
Call this member to enable or disable the action.
BOOL | GetEnabled () const
Call this member to get the state of the action.
void | SetChecked (BOOL bChecked)
Call this member to set the checked state of an action.
BOOL | GetChecked () const
Call this member to get the checked state of an action.
BOOL | IsVisible () const
Call this member to get the visibility of an action.
void | SetVisible (BOOL bVisible)
Call this member to set the visibility of an action.
void | SetTag (DWORD_PTR dwTag)
This method sets the 32-bit value associated with the action.
DWORD_PTR | GetTag () const
This method retrieves the application-supplied, 32-bit value associated with the action.
void | SetCategory (LPCTSTR lpszCategory)
Call this method to set the category of the action.
CString | GetCategory () const
Call this method to retrieve the category of the action.
void | SetTooltip (LPCTSTR lpszTooltip)
Call this member to set the tooltip of the action.
CString | GetTooltip () const
Call this member to get the action's tooltip.
void | SetShortcutText (LPCTSTR lpszShortcutText)
Call this member to set the shortcut string to the action.
CString | GetShortcutText () const
Call this member to get the action's shortcut.
void | SetCustomShortcutText (LPCTSTR lpszCustomShortcutText)
Call this member to set the custom shortcut string to the action.
CString | GetCustomShortcutText () const
Call this member to get the action's custom shortcut text.
void | SetKeyboardTip (LPCTSTR lpszKeyboardTip)
Call this member to set the keyboard tip to the action.
CString | GetKeyboardTip () const
Call this member to get the action's keyboard tip.
void | SetEditHint (LPCTSTR lpszEditHint)
Call this member to set the grayed-out text displayed in the edit and combo controls which provides a helpful description of what the control is used for.
CString | GetEditHint () const
Call this member to get the grayed-out text displayed in the edit and combo controls which provides a helpful description of what the control is used for.
void | SetKey (LPCTSTR lpszKey)
"String" version of the ID given to a command in the CommandBars Designer (For use with CommandBars designed in the CommandBars Designer Studio).
CString | GetKey () const
Gets the "string" version of the ID given to a command in the CommandBars Designer (For use with CommandBars designed in the CommandBars Designer Studio).
CXTPCommandBars * | GetCommandBars () const
Call this member to get a pointer to the owner CommandBars.
CXTPControl * | GetControl (int nIndex) const
Call this member to get a control associated with an action.
int | GetCount () const
Call this member to get the number of controls associated with an action.
void | RedrawControls ()
Call this member to redraw all controls associated with actions.
void | RepositionControls ()
Call this member to reposition all controls associated with actions.
void | DoPropExchange (CXTPPropExchange *pPX)
Either reads this object from or writes this object to an archive.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Public Attributes

CCmdTarget * m_pTarget
Parameter of action.

Protected Member Functions

CXTPControlAction (CXTPControlActions *pActions)
Constructs a CXTPControlAction object.
~CXTPControlAction ()
Destroys a CXTPControlAction object, handles cleanup and deallocation.
void | AddControl (CXTPControl *pControl)
This method is called when a new control is attached to an action.
void | RemoveControl (CXTPControl *pControl)
This method is called to remove a control from the actions list.
void | OnRemoved ()
This method is called before an action is removed.
void | OnChanged (int nProperty)
This method is called when the property of an action is changed.
void | OnChanging (int nProperty)
This method is called when the property of an action is about to be changed.

Protected Attributes

DWORD_PTR | m_nTag
Action tag.
int | m_nId
Identifier of the action.
int | m_nIconId
Identifier of the action's image.
int | m_nHelpId
Help identifier.
BOOL | m_bEnabled
TRUE if the action is enabled.
BOOL | m_bChecked
TRUE if the action is checked.
BOOL | m_bVisible
TRUE if the action is visible.
CString | m_strCaption
Caption of the action.
CString | m_strTooltipText
Tooltip text.
CString | m_strDescriptionText
Description text.
CString | m_strCategory
Category of the action.
CString | m_strShortcutText
Shortcut text.
CString | m_strEditHint
Edit Hint for Combo and Edit Controls.
CString | m_strKeyboardTip
Keyboard tip.
CString | m_strKey
Key.
CString | m_strCustomShortcutText
Custom Shortcut Text.
CArray< CXTPControl *, CXTPControl * > | m_arrControls
Associated controls.
CXTPControlActions * | m_pActions
Parent actions object.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

CXTPControlAction is a CXTPCmdTarget derived class.

It represents the single action of controls.

Constructor & Destructor Documentation

◆ CXTPControlAction()

CXTPControlAction ( CXTPControlActions * pActions )
protected

Constructs a CXTPControlAction object.

Parameters
pActions Owner actions collection.

Member Function Documentation

◆ AddControl()

void AddControl ( CXTPControl * pControl )
protected

This method is called when a new control is attached to an action.

Parameters
pControl Control to be attached.
See also
RemoveControl

◆ DoPropExchange()

void DoPropExchange ( CXTPPropExchange * pPX )

Either reads this object from or writes this object to an archive.

Parameters
pPX A CXTPPropExchange object to serialize to or from.

◆ GetCaption()

AFX_INLINE CString GetCaption ( ) const

Call this member to get the action's caption.

Returns
The caption of the control.

◆ GetCategory()

AFX_INLINE CString GetCategory ( ) const

Call this method to retrieve the category of the action.

Returns
Category of the action.

◆ GetChecked()

AFX_INLINE BOOL GetChecked ( ) const

Call this member to get the checked state of an action.

Returns
TRUE if the action is checked; otherwise FALSE.

◆ GetCommandBars()

CXTPCommandBars * GetCommandBars ( ) const

Call this member to get a pointer to the owner CommandBars.

Returns
The pointer to the CXTPCommandBars object.

◆ GetControl()

CXTPControl * GetControl ( int nIndex ) const

Call this member to get a control associated with an action.

Parameters
nIndex Index of the control to retrieve.
Returns
Pointer to a CXTPControl object.

◆ GetCount()

int GetCount ( ) const

Call this member to get the number of controls associated with an action.

Returns
Total number of controls associated with an action.

◆ GetCustomShortcutText()

AFX_INLINE CString GetCustomShortcutText ( ) const

Call this member to get the action's custom shortcut text.

Returns
The shortcut of the control.

◆ GetDescription()

AFX_INLINE CString GetDescription ( ) const

Call this member to get the action's description.

Returns
The description of the control.

◆ GetEditHint()

AFX_INLINE CString GetEditHint ( ) const

Call this member to get the grayed-out text displayed in the edit and combo controls which provides a helpful description of what the control is used for.

Returns
Edit hint of the control.

◆ GetEnabled()

BOOL GetEnabled ( ) const

Call this member to get the state of the action.

Returns
TRUE if the action is enabled; otherwise FALSE.

◆ GetHelpId()

AFX_INLINE int GetHelpId ( ) const

Call this member to get the help identifier.

Returns
Help identifier of the action.

◆ GetIconId()

AFX_INLINE int GetIconId ( ) const

Call this member to get the icon's identifier.

Returns
An icon's identifier of the action.

◆ GetID()

AFX_INLINE int GetID ( ) const

Call this member to get the action's identifier.

Returns
The identifier of the control.

◆ GetKey()

AFX_INLINE CString GetKey ( ) const

Gets the "string" version of the ID given to a command in the CommandBars Designer (For use with CommandBars designed in the CommandBars Designer Studio).

The key is the "string" version of the ID given to a command in the CommandBars Designer. "String" version refers to the fact that a named constant is created in the designer, for example ID_FILE_NEW, can also be referenced buy the actual string "ID_FILE_NEW" which is stored in the key property. Use GetKey to retrieve this key.

This can be useful for developers who have older applications that referenced controls by name rather than by an ID.

Steps needed to use the key:

  1. In the Designer add all actions you need to the ActionLibrary pane (and Save them). Note: The Actions Pane is a way to save and "Re-use" commands. Always add controls to this library first so they can be re-used in other xcb or xml files.
  2. Now you need to drag the actions from the ActionLibrary pane to the Controls pane and then from the Controls pane to the Toolbars and Menus.
  3. In your code use GetKey property instead of the GetId.
Returns
The "string" version of the ID given to a command in the CommandBars Designer.
See also
SetKey

◆ GetKeyboardTip()

AFX_INLINE CString GetKeyboardTip ( ) const

Call this member to get the action's keyboard tip.

Returns
The keyboard tip of the control.

◆ GetShortcutText()

AFX_INLINE CString GetShortcutText ( ) const

Call this member to get the action's shortcut.

Returns
The shortcut of the control.

◆ GetTag()

AFX_INLINE DWORD_PTR GetTag ( ) const

This method retrieves the application-supplied, 32-bit value associated with the action.

Returns
The 32-bit value associated with the action.

◆ GetTooltip()

AFX_INLINE CString GetTooltip ( ) const

Call this member to get the action's tooltip.

Returns
Tooltip of the control.

◆ IsVisible()

AFX_INLINE BOOL IsVisible ( ) const

Call this member to get the visibility of an action.

Returns
TRUE if the action is visible, FALSE otherwise.

◆ OnChanged()

void OnChanged ( int nProperty )
protected

This method is called when the property of an action is changed.

Parameters
nProperty Property identifier.
See also
OnChanging

◆ OnChanging()

void OnChanging ( int nProperty )
protected

This method is called when the property of an action is about to be changed.

Parameters
nProperty Property identifier.
See also
OnChanged

◆ RemoveControl()

void RemoveControl ( CXTPControl * pControl )
protected

This method is called to remove a control from the actions list.

Parameters
pControl Control to be removed.
See also
AddControl

◆ SetCaption() [1/2]

void SetCaption ( LPCTSTR lpszCaption )

Call this member to set the caption of the action.

Parameters
lpszCaption Caption to be set.
See also
SetPrompt, SetDescription, SetTooltip

◆ SetCaption() [2/2]

void SetCaption ( UINT nIDCaption )

Call this member to set the caption of the action.

Parameters
nIDCaption Caption resource identifier.
See also
SetPrompt, SetDescription, SetTooltip

◆ SetCategory()

AFX_INLINE void SetCategory ( LPCTSTR lpszCategory )

Call this method to set the category of the action.

Parameters
lpszCategory Category of the action.

◆ SetChecked()

AFX_INLINE void SetChecked ( BOOL bChecked )

Call this member to set the checked state of an action.

Parameters
bChecked TRUE to set the action to checked.
See also
GetChecked, SetEnabled

◆ SetCustomShortcutText()

AFX_INLINE void SetCustomShortcutText ( LPCTSTR lpszCustomShortcutText )

Call this member to set the custom shortcut string to the action.

Parameters
lpszCustomShortcutText Shortcut to be set.

◆ SetDescription()

AFX_INLINE void SetDescription ( LPCTSTR lpszDescription )

Call this member to set the description of the action.

Parameters
lpszDescription Description to be set.
See also
SetCaption, SetPrompt, SetTooltip

◆ SetEditHint()

void SetEditHint ( LPCTSTR lpszEditHint )

Call this member to set the grayed-out text displayed in the edit and combo controls which provides a helpful description of what the control is used for.

Parameters
lpszEditHint Edit hint to be set.

◆ SetEnabled()

AFX_INLINE void SetEnabled ( BOOL bEnabled )

Call this member to enable or disable the action.

Parameters
bEnabled TRUE to enable the action, FALSE to disable the action.
See also
GetEnabled, SetChecked

◆ SetHelpId()

AFX_INLINE void SetHelpId ( int nId )

Call this member to set the action help identifier.

Parameters
nId Help identifier to be set.

◆ SetIconId()

AFX_INLINE void SetIconId ( int nId )

Call this member to set the action icon's identifier.

Parameters
nId Icon's identifier to be set.

◆ SetKey()

AFX_INLINE void SetKey ( LPCTSTR lpszKey )

"String" version of the ID given to a command in the CommandBars Designer (For use with CommandBars designed in the CommandBars Designer Studio).

Parameters
lpszKey "String" version of the ID to be given to a command in the CommandBars Designer.

The key is the "string" version of the ID given to a command in the CommandBars Designer. "String" version refers to the fact that a named constant is created in the designer, for example ID_FILE_NEW, can also be referenced buy the actual string "ID_FILE_NEW" which is stored in the key property. Use GetKey to retrieve this key.

This can be useful for developers who have older applications that referenced controls by name rather than by an ID.

Steps needed to use the key:

  1. In the Designer, add all actions you need to the ActionLibrary pane (and Save them). Note: The Actions Pane is a way to save and "Re-use" commands. Always add controls to this library first so they can be re-used in other xcb or xml files.
  2. Now you need to drag the actions from the ActionLibrary pane to the Controls pane and then from the Controls pane to the Toolbars and Menus.
  3. In your code use GetKey property instead of the GetId.
See also
GetKey, m_strKey

◆ SetKeyboardTip()

AFX_INLINE void SetKeyboardTip ( LPCTSTR lpszKeyboardTip )

Call this member to set the keyboard tip to the action.

Parameters
lpszKeyboardTip Keyboard tip to be set.

◆ SetPrompt()

void SetPrompt ( LPCTSTR lpszPrompt )

Call this member to load a string from a STRINGTABLE resource to set the tooltip and description of a action.

Parameters
lpszPrompt String from the resource file that contains the tooltip and description of the item. The Caption will be set to use the tooltip text. The tooltip and description must be separated by "\n" if both are included. You can omit the description and both the tooltip and description will be set to the same value.

Resource strings are in the format "Description\nToolTip". Note: The caption is set to the value of the tooltip when this member is called.

See also
SetCaption, SetDescription, SetTooltip

◆ SetShortcutText()

AFX_INLINE void SetShortcutText ( LPCTSTR lpszShortcutText )

Call this member to set the shortcut string to the action.

Parameters
lpszShortcutText Shortcut to be set.

◆ SetTag()

AFX_INLINE void SetTag ( DWORD_PTR dwTag )

This method sets the 32-bit value associated with the action.

Parameters
dwTag The new 32-bit value to associate with the action.

◆ SetTooltip()

AFX_INLINE void SetTooltip ( LPCTSTR lpszTooltip )

Call this member to set the tooltip of the action.

Parameters
lpszTooltip Tooltip to be set.
See also
SetCaption, SetDescription, SetPrompt

◆ SetVisible()

AFX_INLINE void SetVisible ( BOOL bVisible )

Call this member to set the visibility of an action.

Parameters
bVisible TRUE to set the action to visible.
The documentation for this class was generated from the following file:
  • XTPControl.h


Toolkit Pro: CXTPControlActions Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPControlActions Class Reference

CXTPControlActions is a CXTPCmdTarget derived class. More...

Inheritance diagram for CXTPControlActions:
[legend]

Public Member Functions

CXTPControlAction * | GetAt (int nIndex) const
Call this member to return the action at the specified index.
int | GetCount () const
Call this member to get the count of the actions.
CXTPControlAction * | FindAction (int nId) const
Call this member to find the specified action.
CXTPControlAction * | Add (int nId)
Call this member to add a new action.
CXTPControlAction * | Add (int nId, CXTPControlAction *pAction)
Call this member to add a new action.
void | DoPropExchange (CXTPPropExchange *pPX)
Either reads this object from or writes this object to an archive.
void | RemoveAll ()
Call this member to remove all actions.
void | Remove (int nId)
Removes the action of a control by using the ID of the control.
void | CreateFromMenu (CMenu *pMenu)
Call this method to create actions using menu commands.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

CXTPControlActions (CXTPCommandBars *pCommandBars)
Constructs a CXTPControlActions object.
~CXTPControlActions ()
Destroys a CXTPControlActions object, handles cleanup and deallocation.
void | Insert (CXTPControlAction *pAction)
Inserts an existing CXTPControlAction into the collection of actions.
void | SetActionId (CXTPControlAction *pAction, int nId)
Sets or updates the control ID associated with an action.

Protected Attributes

CArray< CXTPControlAction *, CXTPControlAction * > | m_arrActions
Actions array.
CXTPCommandBars * | m_pCommandBars
Parent CommandBars object.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

CXTPControlActions is a CXTPCmdTarget derived class.

It represents a collection of actions.

Constructor & Destructor Documentation

◆ CXTPControlActions()

CXTPControlActions ( CXTPCommandBars * pCommandBars )
protected

Constructs a CXTPControlActions object.

Parameters
pCommandBars Parent commandbars object.

Member Function Documentation

◆ Add() [1/2]

CXTPControlAction * Add ( int nId )

Call this member to add a new action.

Parameters
nId Identifier of the control to be added.
Returns
A pointer to the added action.

◆ Add() [2/2]

CXTPControlAction * Add | ( | int | nId,
 |  | CXTPControlAction * | pAction )

Call this member to add a new action.

Parameters
nId | Identifier of the control to be added.
pAction | Action to add.
Returns
A pointer to the added action.

◆ CreateFromMenu()

void CreateFromMenu ( CMenu * pMenu )

Call this method to create actions using menu commands.

Parameters
pMenu Menu pointer to convert from.

◆ DoPropExchange()

void DoPropExchange ( CXTPPropExchange * pPX )

Either reads this object from or writes this object to an archive.

Parameters
pPX A CXTPPropExchange object to serialize to or from.

◆ FindAction()

CXTPControlAction * FindAction ( int nId ) const

Call this member to find the specified action.

Parameters
nId The action's identifier.
Returns
Pointer to the CXTPControlAction object if successful; otherwise returns NULL.

◆ GetAt()

CXTPControlAction * GetAt ( int nIndex ) const

Call this member to return the action at the specified index.

Parameters
nIndex An integer index.
Returns
The CXTPControlAction pointer currently at this index.

◆ GetCount()

int GetCount ( ) const

Call this member to get the count of the actions.

Returns
The count of the actions.

◆ Insert()

void Insert ( CXTPControlAction * pAction )
protected

Inserts an existing CXTPControlAction into the collection of actions.

Parameters
pAction Reference to the action to add to the collection of actions.

◆ Remove()

void Remove ( int nId )

Removes the action of a control by using the ID of the control.

Parameters
nId Identifier of the control that has the action to be removed.

◆ SetActionId()

void SetActionId | ( | CXTPControlAction * | pAction,
 |  | int | nId )
 protected

Sets or updates the control ID associated with an action.

Parameters
pAction | Reference to an action to be assigned a new ID.
nId | The action's new identifier.
The documentation for this class was generated from the following file:
  • XTPControl.h


Toolkit Pro: CXTPControlBitmap Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPControlBitmap Class Reference

CXTPControlBitmap is a CXTPControlLabel derived class. More...

Inheritance diagram for CXTPControlBitmap:
[legend]

Public Member Functions

CXTPControlBitmap ()
Constructs a CXTPControlBitmap object.
- Public Member Functions inherited from CXTPControl
void | SetStyle (XTPButtonStyle buttonStyle)
Call this member to set the style of the control.
XTPButtonStyle | GetStyle () const
Call this member to get the control's style.
void | SetCaption (LPCTSTR lpszCaption)
Call this member to set the caption of the control.
void | SetCaption (UINT nIDCaption)
Call this member to set the caption of the control.
virtual CString | GetCaption () const
Call this member to get the control's caption.
void | SetShortcutText (LPCTSTR lpszShortcutText)
Call this member to set the shortcut string to the control.
CString | GetShortcutText () const
Call this member to get the control's shortcut.
void | SetDescription (LPCTSTR lpszDescription)
Call this member to set the description of the control.
virtual CString | GetDescription () const
Call this member to get the control's description.
void | SetTooltip (LPCTSTR lpszTooltip)
Call this member to set the tooltip of the control.
virtual CString | GetTooltip () const
Call this member to get the control's tooltip.
void | SetKeyboardTip (LPCTSTR lpszKeyboardTip)
Call this member to set the keyboard tip to the control.
CString | GetKeyboardTip () const
Call this member to get the keyboard tip.
void | SetCustomShortcutText (LPCTSTR lpszCustomShortcutText)
Call this member to set the text displayed for the shortcut in a pop-up menu.
CString | GetCustomShortcutText () const
Call this member to get the control's text displayed for the shortcut in a pop-up menu.
void | SetParameter (LPCTSTR lpszParameter)
Call this member to set the parameter of the control.
CString | GetParameter () const
Call this member to get the control's parameter.
void | SetID (int nId)
Call this member to set the identifier of the control.
int | GetID () const
Call this member to get the control's identifier.
long | GetIndex () const
Call this member to get the index of the control.
void | SetIconId (int nId)
Call this member to set the control icon's identifier.
int | GetIconId () const
Call this member to get the icon's identifier.
void | SetHelpId (int nId)
Call this member to set the control help identifier.
int | GetHelpId () const
Call this member to get the help identifier.
virtual void | SetBeginGroup (BOOL bBeginGroup)
Call this member to begin a new group using a separator.
BOOL | GetBeginGroup () const
Call this member to determine if the control has a separator.
virtual void | SetEnabled (BOOL bEnabled)
Call this member to enable/disable the control.
BOOL | GetEnabled () const
Call this member to check if the control is enabled.
virtual void | OnEnabledChanged ()
This method is called when a control's enabled state is changed.
virtual void | SetChecked (BOOL bChecked)
Call this member to set the checked state of the control.
BOOL | GetChecked () const
Call this member to get the checked state of the control.
void | SetOnQuickAccess (BOOL bOnQuicAccess=FALSE)
Call this member to set whether a control should be a part of the Quick Access panel.
BOOL | IsOnQuickAccess () const
Call this member to check if a control is a part of the Quick Access panel.
virtual void | SetFocused (BOOL bFocused)
Call this member to set the focused state of the control.
virtual BOOL | IsFocused () const
Call this member to check the focused state of the control.
void | SetPressed (BOOL bPressed)
Call this member to set the pressed state of the control.
virtual BOOL | GetPressed () const
Call this member to check the pressed state of the control.
virtual void | SetRect (CRect rcControl)
This member is called to set the bounding rectangle of the control.
CRect | GetRect () const
Call this member to get the bounding rectangle of the control.
CXTPCommandBar * | GetParent () const
Call this member to get the parent command bar.
virtual BOOL | IsVisible (DWORD dwSkipFlags=0) const
Call this member to determine if the control is visible.
virtual BOOL | IsCaptionVisible () const
Call this member to determine if the caption of the control is visible.
void | SetVisible (BOOL bVisible)
Call this member to set the visibility of the control.
CXTPControls * | GetControls () const
Call this member to get the parent controls collection.
XTPControlType | GetType () const
Call this member to get the control's type.
void | SetFlags (DWORD dwFlags)
Call this member to set the flags of the control.
DWORD | GetFlags () const
Call this member to retrieve control special flags.
void | SetTag (DWORD_PTR dwTag)
This method sets the 32-bit value associated with the control.
DWORD_PTR | GetTag () const
This method retrieves the application-supplied, 32-bit value associated with the control.
virtual BOOL | Compare (CXTPControl *pOther)
Call this member to compare controls.
virtual CXTPCommandBar * | GetCommandBar () const
Call this member to get the child command bar.
void | SetCloseSubMenuOnClick (BOOL bCloseOnClick)
Call this member function to enable/disable the closing of sub-menus when a control is clicked in the menu.
BOOL | GetCloseSubMenuOnClick () const
Call this member function to check if sub-menus will close as soon as a control is clicked.
void | SetExecuteOnPressInterval (int nExecuteOnPressInterval)
Call this method to set the delay (in milliseconds) between WM_COMMAND messages while a button is pressed by the user.
int | GetExecuteOnPressInterval () const
Call this method to get the delay (in milliseconds) between WM_COMMAND messages while a button is pressed by the user.
CXTPRibbonGroup * | GetRibbonGroup () const
Returns the ribbon group that the control belongs to.
virtual BOOL | IsTransparent () const
Determines if the control needs to draw its background.
void | SetHideWrap (BOOL bHide)
This method is called to hide the control.
virtual void | SetHideFlags (DWORD dwFlags)
This method is called to hide the control.
BOOL | SetHideFlag (XTPControlHideFlags dwFlag, BOOL bSet)
Call this member to set/remove hide flags.
DWORD | GetHideFlags () const
Call this method to retrieve hidden flags.
CRect | GetRowRect () const
Call this method to retrieve the position of the control's row.
BOOL | GetWrap () const
Call this method to check if the control is wrapped.
void | SetRowRect (CRect rcRow)
Call this method to set the row of the control.
void | SetWrap (BOOL bWrap)
Call this member to set the control to wrapped.
BOOL | GetExpanded () const
Call this member to check if the control is expanded.
BOOL | IsCursorOver () const
Call this member to determine if the mouse pointer is over the control.
virtual void | OnExecute ()
This method is called when the control is executed.
virtual void | OnCalcDynamicSize (DWORD dwMode)
This method is called before recalculating the parent command bar size to calculate the dimensions of the control.
void | DelayRedrawParent ()
Call this method to redraw the parent command bar.
void | DelayLayoutParent ()
Call this method to recalculate the parent command bar size.
void | SetCategory (LPCTSTR lpszCategory)
Call this method to set the category of the control.
CString | GetCategory () const
Call this method to retrieve the category of the control.
CXTPImageManager * | GetImageManager () const
Call this method to retrieve the image manager.
CXTPPaintManager * | GetPaintManager () const
Call this method to retrieve the paint manager.
virtual CXTPImageManagerIcon * | GetImage (int nWidth=16) const
Call this method to retrieve the image of the control.
void | AssignDocTemplate (UINT nIDResource)
Call this method to assign a document template to the control.
void | ExcludeDocTemplate (UINT nIDResource)
Call this method to exclude the document template from control.
BOOL | IsItemDefault () const
Call this method to check if a control is a default menu item.
void | SetItemDefault (BOOL bDefault)
Call this method to set a control to be a default menu item.
BOOL | IsTemporary () const
Call this method to determine if a control is temporary.
void | Reset ()
Call this member to reset the icon and caption of a control to its default settings before it was customized by the user.
void | SetPrompt (LPCTSTR lpszPrompt)
Call this member to load a string from a STRINGTABLE resource to set the tooltip and description of a control.
void | SetCustomIcon (HICON hIcon)
Call this member to set a custom icon to this control.
virtual void | DoPropExchange (CXTPPropExchange *pPX)
Either reads this object from or writes this object to an archive.
virtual void | OnUnderlineActivate ()
This method is called when the user activates the control using its underline.
virtual BOOL | GetPopuped () const
Call this member to get the control's pop-up state.
void | RedrawParent (BOOL bAnimate=TRUE)
This method is called to redraw the parent command bar.
LRESULT | NotifySite (UINT code)
This method is called to send message code to the parent site window.
LRESULT | NotifySite (UINT code, NMXTPCONTROL *pNM)
This method is called to send message code to the parent site window.
LRESULT | NotifySite (CWnd *pSite, UINT code, NMXTPCONTROL *pNM)
This method is called to send message code to the parent site window.
virtual void | SetAction (CXTPControlAction *pAction)
Call this method to manually assign an action for control.
CXTPControlAction * | GetAction () const
Call this method to retrieve an action associated with control.
virtual void | OnThemeChanged ()
This method is called when the paint manager theme is changed.
virtual void | SetWidth (int nWidth)
Call this member to set the width of the control.
virtual void | SetHeight (int nHeight)
Call this member to set the height of the control.
int | GetWidth () const
Call this member to get the width of the control.
int | GetHeight () const
Call this member to get the height of the control.
BOOL | HasDwmCompositedRect () const
This method is called to determine if control has a Vista DWM transparent area.
virtual CSize | GetButtonSize () const
Call this function to get the size of the command bar button.
virtual CSize | GetIconSize () const
Call this member function to get the size of a toolbar icon.
void | SetIconSize (CSize szIcon)
Call this member function to set the size of an icon for an individual control.
virtual void | Copy (CXTPControl *pControl, BOOL bRecursive=FALSE)
This method is called to copy the control.
virtual BOOL | IsCustomizeMovable () const
This method is called to determine if control can be repositioned in customize mode.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

virtual CSize | GetSize (CDC *pDC)
This method is called to determine the size of the control.
virtual void | Draw (CDC *pDC)
This method is called to draw the control.
- Protected Member Functions inherited from CXTPControl
CXTPControl ()
Constructs a CXTPControl object.
virtual | ~CXTPControl ()
Destroys a CXTPControl object, handles cleanup and deallocation.
virtual BOOL | IsFocusable () const
This method is called to check if the control can accept focus.
void | SetIndex (int nIndex)
This method is called to assign the order of the control in the controls list.
void | SetExpanded (BOOL bExpanded)
This method is called to set the control's expanded state.
virtual BOOL | OnHookKeyDown (UINT nChar, LPARAM lParam)
This method is called when a non-system key is pressed.
virtual BOOL | OnHookMouseWheel (UINT nFlags, short zDelta, CPoint point)
This method is called when the user rotates the mouse wheel.
virtual void | SetParent (CXTPCommandBar *pParent)
This method is called to assign a parent command bar object.
void | ScreenToClient (CPoint *point)
The ScreenToClient function converts the screen coordinates of a specified point on the screen.
void | ClickToolBarButton (CRect rcActiveRect=CRect(0, 0, 0, 0))
This helper method is called when the user clicks the toolbar's button.
virtual BOOL | OnSetPopup (BOOL bPopup)
This method is called to pop-up the control.
virtual void | OnLButtonUp (CPoint point)
This member is called when the user releases the left mouse button.
virtual void | OnLButtonDown (CPoint point)
This member is called when the user presses the left mouse button down.
virtual BOOL | OnRButtonDown (CPoint point)
This member is called when the user press the right mouse button.
virtual BOOL | OnRButtonUp (CPoint point)
This member is called when the user releases the right mouse button.
virtual BOOL | OnLButtonDblClk (CPoint point)
This member is called when the user double-clicks the left mouse button.
virtual void | OnMouseMove (CPoint point)
This member is called when the mouse cursor moves.
virtual void | OnMouseHover ()
Called after the mouse hovers over the control.
virtual BOOL | OnSetSelected (int bSelected)
This method is called when the control becomes selected.
BOOL | IsCustomizeMode () const
Call this method to determine if command bars is in customize mode.
virtual void | CustomizeStartDrag (CPoint point)
This member is called when the user starts to drag the control in customize mode.
virtual BOOL | CustomizeStartResize (CPoint point)
This method is called when user starts to resize control in customize mode.
virtual void | OnCustomizeDragOver (CXTPControl *pDataObject, CPoint point, DROPEFFECT &dropEffect)
This member is called when the user moves the mouse over the control.
virtual BOOL | DoCustomDragOver (CXTPCommandBar *pCommandBar, CPoint point, DROPEFFECT &dropEffect)
The implementation may implement a custom drag over handling logic in this method.
virtual BOOL | IsCustomizeResizeAllow () const
This member checks if the user can resize the control.
virtual int | GetCustomizeMinWidth () const
Retrieves the available minimum width of control.
virtual int | GetCustomizeMinHeight () const
Retrieves available minimum height of the control.
void | OnCustomizeMouseMove (CPoint point)
This member is called when the mouse cursor moves in customized mode.
virtual void | OnIdleUpdate ()
This virtual method is called in idle-time processing.
virtual void | OnRemoved ()
This method is called when a control is removed from the parent controls collection.
virtual INT_PTR | OnToolHitTest (CPoint point, TOOLINFO *pTI) const
The framework calls this member function to determine whether a point is in the bounding rectangle of the specified tool.
virtual void | RestoreCommandBarList (CXTPCommandBarList *pCommandBarList)
This method is called from LoadCommandBars to restore controls and its child command bars.
virtual void | GenerateCommandBarList (DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam)
This method is called from SaveCommandBars to save all child command bars.
virtual void | OnActionChanged (int nProperty)
This method is called when an action property is changed.
virtual void | OnActionChanging (int nProperty)
This method is called when an action property is about to be changed.
virtual void | OnCaptionChanged ()
This method is called when the control's caption is changed.
BOOL | IsLayoutRTL () const
Determines if right-to-left (RTL) mode is set.
BOOL | IsLayoutChanged ()
Call this member to determine if the layout has changed (RTL to LTR or LTR to RLT).

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControl
static CXTPControl *AFX_CDECL | FromUI (CCmdUI *pCmdUI)
Call this member to retrieve CXTPControl from a CCmdUI structure.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Attributes inherited from CXTPControl
DWORD_PTR | m_nTag
Control tag.
int | m_nIndex
Index of the control.
int | m_nId
Identifier of the control.
int | m_nIconId
Identifier of the control's image.
int | m_nHelpId
Help identifier.
int | m_nCustomIconId
Identifier of the control's custom image.
BOOL | m_bWrap
TRUE if the control is wrapped.
BOOL | m_bBeginGroup
TRUE if the control starts new group.
BOOL | m_bEnabled
TRUE if the control is enabled.
BOOL | m_bChecked
TRUE if the control is checked.
BOOL | m_bSelected
TRUE if the control is selected.
BOOL | m_bPressed
TRUE if the control is pushed.
BOOL | m_bTemporary
TRUE if the control is temporary.
BOOL | m_bOnQuickAccess
TRUE if the control is a part of Quick Access panel.
CRect | m_rcRow
Bounding rectangle of the control's row.
CRect | m_rcControl
Bounding rectangle of the control.
DWORD | m_dwHideFlags
Hidden flags.
DWORD | m_dwFlags
Flags of the control.
CString | m_strCaption
Caption of the control.
CString | m_strCustomCaption
User-defined caption.
CString | m_strShortcutText
Shortcut text.
CString | m_strShortcutTextAuto
Shortcut text.
CString | m_strTooltipText
Tooltip text.
CString | m_strDescriptionText
Description text.
CString | m_strParameter
Parameter text.
CString | m_strKeyboardTip
Keyboard tip.
CXTPControls * | m_pControls
Parent control collection.
XTPControlType | m_controlType
Type of the control.
CXTPCommandBar * | m_pParent
The Parent command bar.
BOOL | m_bExpanded
TRUE if the control is expanded.
CString | m_strCategory
Category of the control.
BOOL | m_bDefaultItem
TRUE if the item is default pop-up item.
CDocTemplateMap | m_mapDocTemplatesAssigned
Assigned templates.
CDocTemplateMap | m_mapDocTemplatesExcluded
Excluded templates.
XTPButtonStyle | m_buttonStyle
Button Style.
XTPButtonStyle | m_buttonCustomStyle
User-defined style of button.
XTPButtonStyle | m_buttonRibbonStyle
User-defined style of button.
BOOL | m_bCloseSubMenuOnClick
TRUE is sub-menus are closed as soon as a control is clicked.
CXTPRibbonGroup * | m_pRibbonGroup
Ribbon group of control.
CXTPControlAction * | m_pAction
Action of the control.
int | m_nWidth
Width of the control.
int | m_nHeight
Height of the control.
int | m_nExecuteOnPressInterval
Delay between each message when control is pressed.
CSize | m_szIcon
The size of the icon used for the control.
BOOL | m_bLayoutRTL
Indicate does last layout is RTL.

Detailed Description

CXTPControlBitmap is a CXTPControlLabel derived class.

It can be used to add a bitmap to a toolbar.

Member Function Documentation

◆ Draw()

virtual void Draw ( CDC * pDC )
protectedvirtual

This method is called to draw the control.

Parameters
pDC Pointer to a valid device context.

Reimplemented from CXTPControl.

◆ GetSize()

virtual CSize GetSize ( CDC * pDC )
protectedvirtual

This method is called to determine the size of the control.

Parameters
pDC Pointer to a valid device context.
Returns
A CSize object containing the size of the control.

Reimplemented from CXTPControl.

The documentation for this class was generated from the following file:
  • XTPControlExt.h


Toolkit Pro: CXTPControlButton Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPControlButton Class Reference

CXTPControlButton is a CXTPControl derived class. More...

Inheritance diagram for CXTPControlButton:
[legend]

Public Member Functions

CXTPControlButton ()
Constructs a CXTPControlButton object.
virtual | ~CXTPControlButton ()
Destroys a CXTPControlButton object, handles cleanup and deallocation.
void | SetStyleEx (XTPButtonStyle buttonStyle)
Call this member to set the style of the button containing vector icon.
XTPButtonStyle | GetStyleEx () const
Call this member to get the button's style containing vector icon.
void | DoPropExchange (CXTPPropExchange *pPX)
Either reads this object from or writes this object to an archive.
- Public Member Functions inherited from CXTPControl
void | SetStyle (XTPButtonStyle buttonStyle)
Call this member to set the style of the control.
XTPButtonStyle | GetStyle () const
Call this member to get the control's style.
void | SetCaption (LPCTSTR lpszCaption)
Call this member to set the caption of the control.
void | SetCaption (UINT nIDCaption)
Call this member to set the caption of the control.
virtual CString | GetCaption () const
Call this member to get the control's caption.
void | SetShortcutText (LPCTSTR lpszShortcutText)
Call this member to set the shortcut string to the control.
CString | GetShortcutText () const
Call this member to get the control's shortcut.
void | SetDescription (LPCTSTR lpszDescription)
Call this member to set the description of the control.
virtual CString | GetDescription () const
Call this member to get the control's description.
void | SetTooltip (LPCTSTR lpszTooltip)
Call this member to set the tooltip of the control.
virtual CString | GetTooltip () const
Call this member to get the control's tooltip.
void | SetKeyboardTip (LPCTSTR lpszKeyboardTip)
Call this member to set the keyboard tip to the control.
CString | GetKeyboardTip () const
Call this member to get the keyboard tip.
void | SetCustomShortcutText (LPCTSTR lpszCustomShortcutText)
Call this member to set the text displayed for the shortcut in a pop-up menu.
CString | GetCustomShortcutText () const
Call this member to get the control's text displayed for the shortcut in a pop-up menu.
void | SetParameter (LPCTSTR lpszParameter)
Call this member to set the parameter of the control.
CString | GetParameter () const
Call this member to get the control's parameter.
void | SetID (int nId)
Call this member to set the identifier of the control.
int | GetID () const
Call this member to get the control's identifier.
long | GetIndex () const
Call this member to get the index of the control.
void | SetIconId (int nId)
Call this member to set the control icon's identifier.
int | GetIconId () const
Call this member to get the icon's identifier.
void | SetHelpId (int nId)
Call this member to set the control help identifier.
int | GetHelpId () const
Call this member to get the help identifier.
virtual void | SetBeginGroup (BOOL bBeginGroup)
Call this member to begin a new group using a separator.
BOOL | GetBeginGroup () const
Call this member to determine if the control has a separator.
virtual void | SetEnabled (BOOL bEnabled)
Call this member to enable/disable the control.
BOOL | GetEnabled () const
Call this member to check if the control is enabled.
virtual void | OnEnabledChanged ()
This method is called when a control's enabled state is changed.
virtual void | SetChecked (BOOL bChecked)
Call this member to set the checked state of the control.
BOOL | GetChecked () const
Call this member to get the checked state of the control.
virtual int | GetSelected () const
Call this member to check if the control is selected.
void | SetOnQuickAccess (BOOL bOnQuicAccess=FALSE)
Call this member to set whether a control should be a part of the Quick Access panel.
BOOL | IsOnQuickAccess () const
Call this member to check if a control is a part of the Quick Access panel.
virtual void | SetFocused (BOOL bFocused)
Call this member to set the focused state of the control.
virtual BOOL | IsFocused () const
Call this member to check the focused state of the control.
void | SetPressed (BOOL bPressed)
Call this member to set the pressed state of the control.
virtual BOOL | GetPressed () const
Call this member to check the pressed state of the control.
virtual void | SetRect (CRect rcControl)
This member is called to set the bounding rectangle of the control.
CRect | GetRect () const
Call this member to get the bounding rectangle of the control.
CXTPCommandBar * | GetParent () const
Call this member to get the parent command bar.
virtual BOOL | IsVisible (DWORD dwSkipFlags=0) const
Call this member to determine if the control is visible.
virtual BOOL | IsCaptionVisible () const
Call this member to determine if the caption of the control is visible.
void | SetVisible (BOOL bVisible)
Call this member to set the visibility of the control.
CXTPControls * | GetControls () const
Call this member to get the parent controls collection.
XTPControlType | GetType () const
Call this member to get the control's type.
void | SetFlags (DWORD dwFlags)
Call this member to set the flags of the control.
DWORD | GetFlags () const
Call this member to retrieve control special flags.
void | SetTag (DWORD_PTR dwTag)
This method sets the 32-bit value associated with the control.
DWORD_PTR | GetTag () const
This method retrieves the application-supplied, 32-bit value associated with the control.
virtual BOOL | Compare (CXTPControl *pOther)
Call this member to compare controls.
virtual CXTPCommandBar * | GetCommandBar () const
Call this member to get the child command bar.
void | SetCloseSubMenuOnClick (BOOL bCloseOnClick)
Call this member function to enable/disable the closing of sub-menus when a control is clicked in the menu.
BOOL | GetCloseSubMenuOnClick () const
Call this member function to check if sub-menus will close as soon as a control is clicked.
void | SetExecuteOnPressInterval (int nExecuteOnPressInterval)
Call this method to set the delay (in milliseconds) between WM_COMMAND messages while a button is pressed by the user.
int | GetExecuteOnPressInterval () const
Call this method to get the delay (in milliseconds) between WM_COMMAND messages while a button is pressed by the user.
CXTPRibbonGroup * | GetRibbonGroup () const
Returns the ribbon group that the control belongs to.
virtual BOOL | IsTransparent () const
Determines if the control needs to draw its background.
void | SetHideWrap (BOOL bHide)
This method is called to hide the control.
virtual void | SetHideFlags (DWORD dwFlags)
This method is called to hide the control.
BOOL | SetHideFlag (XTPControlHideFlags dwFlag, BOOL bSet)
Call this member to set/remove hide flags.
DWORD | GetHideFlags () const
Call this method to retrieve hidden flags.
CRect | GetRowRect () const
Call this method to retrieve the position of the control's row.
BOOL | GetWrap () const
Call this method to check if the control is wrapped.
void | SetRowRect (CRect rcRow)
Call this method to set the row of the control.
void | SetWrap (BOOL bWrap)
Call this member to set the control to wrapped.
BOOL | GetExpanded () const
Call this member to check if the control is expanded.
BOOL | IsCursorOver () const
Call this member to determine if the mouse pointer is over the control.
virtual void | OnExecute ()
This method is called when the control is executed.
virtual CSize | GetSize (CDC *pDC)
This method is called to determine the size of the control.
virtual void | Draw (CDC *pDC)
This method is called to draw the control.
virtual void | OnCalcDynamicSize (DWORD dwMode)
This method is called before recalculating the parent command bar size to calculate the dimensions of the control.
void | DelayRedrawParent ()
Call this method to redraw the parent command bar.
void | DelayLayoutParent ()
Call this method to recalculate the parent command bar size.
void | SetCategory (LPCTSTR lpszCategory)
Call this method to set the category of the control.
CString | GetCategory () const
Call this method to retrieve the category of the control.
CXTPImageManager * | GetImageManager () const
Call this method to retrieve the image manager.
CXTPPaintManager * | GetPaintManager () const
Call this method to retrieve the paint manager.
virtual CXTPImageManagerIcon * | GetImage (int nWidth=16) const
Call this method to retrieve the image of the control.
void | AssignDocTemplate (UINT nIDResource)
Call this method to assign a document template to the control.
void | ExcludeDocTemplate (UINT nIDResource)
Call this method to exclude the document template from control.
BOOL | IsItemDefault () const
Call this method to check if a control is a default menu item.
void | SetItemDefault (BOOL bDefault)
Call this method to set a control to be a default menu item.
BOOL | IsTemporary () const
Call this method to determine if a control is temporary.
void | Reset ()
Call this member to reset the icon and caption of a control to its default settings before it was customized by the user.
void | SetPrompt (LPCTSTR lpszPrompt)
Call this member to load a string from a STRINGTABLE resource to set the tooltip and description of a control.
void | SetCustomIcon (HICON hIcon)
Call this member to set a custom icon to this control.
virtual void | OnUnderlineActivate ()
This method is called when the user activates the control using its underline.
virtual BOOL | GetPopuped () const
Call this member to get the control's pop-up state.
void | RedrawParent (BOOL bAnimate=TRUE)
This method is called to redraw the parent command bar.
LRESULT | NotifySite (UINT code)
This method is called to send message code to the parent site window.
LRESULT | NotifySite (UINT code, NMXTPCONTROL *pNM)
This method is called to send message code to the parent site window.
LRESULT | NotifySite (CWnd *pSite, UINT code, NMXTPCONTROL *pNM)
This method is called to send message code to the parent site window.
virtual void | SetAction (CXTPControlAction *pAction)
Call this method to manually assign an action for control.
CXTPControlAction * | GetAction () const
Call this method to retrieve an action associated with control.
virtual void | OnThemeChanged ()
This method is called when the paint manager theme is changed.
virtual void | SetWidth (int nWidth)
Call this member to set the width of the control.
virtual void | SetHeight (int nHeight)
Call this member to set the height of the control.
int | GetWidth () const
Call this member to get the width of the control.
int | GetHeight () const
Call this member to get the height of the control.
BOOL | HasDwmCompositedRect () const
This method is called to determine if control has a Vista DWM transparent area.
virtual CSize | GetButtonSize () const
Call this function to get the size of the command bar button.
virtual CSize | GetIconSize () const
Call this member function to get the size of a toolbar icon.
void | SetIconSize (CSize szIcon)
Call this member function to set the size of an icon for an individual control.
virtual BOOL | IsCustomizeMovable () const
This method is called to determine if control can be repositioned in customize mode.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

virtual void | OnClick (BOOL bKeyboard=FALSE, CPoint pt=CPoint(0, 0))
This method is called when the user clicks the control.
virtual void | OnLButtonUp (CPoint point)
This member is called when the user releases the left mouse button.
virtual void | Copy (CXTPControl *pControl, BOOL bRecursive=FALSE)
This method is called to copy the control.
- Protected Member Functions inherited from CXTPControl
CXTPControl ()
Constructs a CXTPControl object.
virtual | ~CXTPControl ()
Destroys a CXTPControl object, handles cleanup and deallocation.
virtual BOOL | IsFocusable () const
This method is called to check if the control can accept focus.
void | SetIndex (int nIndex)
This method is called to assign the order of the control in the controls list.
void | SetExpanded (BOOL bExpanded)
This method is called to set the control's expanded state.
virtual BOOL | OnHookKeyDown (UINT nChar, LPARAM lParam)
This method is called when a non-system key is pressed.
virtual BOOL | OnHookMouseWheel (UINT nFlags, short zDelta, CPoint point)
This method is called when the user rotates the mouse wheel.
virtual void | SetParent (CXTPCommandBar *pParent)
This method is called to assign a parent command bar object.
void | ScreenToClient (CPoint *point)
The ScreenToClient function converts the screen coordinates of a specified point on the screen.
void | ClickToolBarButton (CRect rcActiveRect=CRect(0, 0, 0, 0))
This helper method is called when the user clicks the toolbar's button.
virtual BOOL | OnSetPopup (BOOL bPopup)
This method is called to pop-up the control.
virtual void | OnLButtonDown (CPoint point)
This member is called when the user presses the left mouse button down.
virtual BOOL | OnRButtonDown (CPoint point)
This member is called when the user press the right mouse button.
virtual BOOL | OnRButtonUp (CPoint point)
This member is called when the user releases the right mouse button.
virtual BOOL | OnLButtonDblClk (CPoint point)
This member is called when the user double-clicks the left mouse button.
virtual void | OnMouseMove (CPoint point)
This member is called when the mouse cursor moves.
virtual void | OnMouseHover ()
Called after the mouse hovers over the control.
virtual BOOL | OnSetSelected (int bSelected)
This method is called when the control becomes selected.
BOOL | IsCustomizeMode () const
Call this method to determine if command bars is in customize mode.
virtual void | CustomizeStartDrag (CPoint point)
This member is called when the user starts to drag the control in customize mode.
virtual BOOL | CustomizeStartResize (CPoint point)
This method is called when user starts to resize control in customize mode.
virtual void | OnCustomizeDragOver (CXTPControl *pDataObject, CPoint point, DROPEFFECT &dropEffect)
This member is called when the user moves the mouse over the control.
virtual BOOL | DoCustomDragOver (CXTPCommandBar *pCommandBar, CPoint point, DROPEFFECT &dropEffect)
The implementation may implement a custom drag over handling logic in this method.
virtual BOOL | IsCustomizeResizeAllow () const
This member checks if the user can resize the control.
virtual int | GetCustomizeMinWidth () const
Retrieves the available minimum width of control.
virtual int | GetCustomizeMinHeight () const
Retrieves available minimum height of the control.
void | OnCustomizeMouseMove (CPoint point)
This member is called when the mouse cursor moves in customized mode.
virtual void | OnIdleUpdate ()
This virtual method is called in idle-time processing.
virtual void | OnRemoved ()
This method is called when a control is removed from the parent controls collection.
virtual INT_PTR | OnToolHitTest (CPoint point, TOOLINFO *pTI) const
The framework calls this member function to determine whether a point is in the bounding rectangle of the specified tool.
virtual void | RestoreCommandBarList (CXTPCommandBarList *pCommandBarList)
This method is called from LoadCommandBars to restore controls and its child command bars.
virtual void | GenerateCommandBarList (DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam)
This method is called from SaveCommandBars to save all child command bars.
virtual void | OnActionChanged (int nProperty)
This method is called when an action property is changed.
virtual void | OnActionChanging (int nProperty)
This method is called when an action property is about to be changed.
virtual void | OnCaptionChanged ()
This method is called when the control's caption is changed.
BOOL | IsLayoutRTL () const
Determines if right-to-left (RTL) mode is set.
BOOL | IsLayoutChanged ()
Call this member to determine if the layout has changed (RTL to LTR or LTR to RLT).

Protected Attributes

XTPButtonStyle | m_buttonStyleEx
User-defined style of button containing vector icon.
- Protected Attributes inherited from CXTPControl
DWORD_PTR | m_nTag
Control tag.
int | m_nIndex
Index of the control.
int | m_nId
Identifier of the control.
int | m_nIconId
Identifier of the control's image.
int | m_nHelpId
Help identifier.
int | m_nCustomIconId
Identifier of the control's custom image.
BOOL | m_bWrap
TRUE if the control is wrapped.
BOOL | m_bBeginGroup
TRUE if the control starts new group.
BOOL | m_bEnabled
TRUE if the control is enabled.
BOOL | m_bChecked
TRUE if the control is checked.
BOOL | m_bSelected
TRUE if the control is selected.
BOOL | m_bPressed
TRUE if the control is pushed.
BOOL | m_bTemporary
TRUE if the control is temporary.
BOOL | m_bOnQuickAccess
TRUE if the control is a part of Quick Access panel.
CRect | m_rcRow
Bounding rectangle of the control's row.
CRect | m_rcControl
Bounding rectangle of the control.
DWORD | m_dwHideFlags
Hidden flags.
DWORD | m_dwFlags
Flags of the control.
CString | m_strCaption
Caption of the control.
CString | m_strCustomCaption
User-defined caption.
CString | m_strShortcutText
Shortcut text.
CString | m_strShortcutTextAuto
Shortcut text.
CString | m_strTooltipText
Tooltip text.
CString | m_strDescriptionText
Description text.
CString | m_strParameter
Parameter text.
CString | m_strKeyboardTip
Keyboard tip.
CXTPControls * | m_pControls
Parent control collection.
XTPControlType | m_controlType
Type of the control.
CXTPCommandBar * | m_pParent
The Parent command bar.
BOOL | m_bExpanded
TRUE if the control is expanded.
CString | m_strCategory
Category of the control.
BOOL | m_bDefaultItem
TRUE if the item is default pop-up item.
CDocTemplateMap | m_mapDocTemplatesAssigned
Assigned templates.
CDocTemplateMap | m_mapDocTemplatesExcluded
Excluded templates.
XTPButtonStyle | m_buttonStyle
Button Style.
XTPButtonStyle | m_buttonCustomStyle
User-defined style of button.
XTPButtonStyle | m_buttonRibbonStyle
User-defined style of button.
BOOL | m_bCloseSubMenuOnClick
TRUE is sub-menus are closed as soon as a control is clicked.
CXTPRibbonGroup * | m_pRibbonGroup
Ribbon group of control.
CXTPControlAction * | m_pAction
Action of the control.
int | m_nWidth
Width of the control.
int | m_nHeight
Height of the control.
int | m_nExecuteOnPressInterval
Delay between each message when control is pressed.
CSize | m_szIcon
The size of the icon used for the control.
BOOL | m_bLayoutRTL
Indicate does last layout is RTL.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControl
static CXTPControl *AFX_CDECL | FromUI (CCmdUI *pCmdUI)
Call this member to retrieve CXTPControl from a CCmdUI structure.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

CXTPControlButton is a CXTPControl derived class.

It represents a button control.

Member Function Documentation

◆ Copy()

virtual void Copy | ( | CXTPControl * | pControl,
 |  | BOOL | bRecursive = FALSE )
 protectedvirtual

This method is called to copy the control.

Parameters
pControl | Points to a source CXTPControl object
bRecursive | TRUE to copy recursively.

Reimplemented from CXTPControl.

Reimplemented in CXTPControlButtonColor, CXTPControlComboBox, CXTPControlCustom, CXTPControlGallery, CXTPControlPopup, CXTPControlPopupColor, and CXTPRibbonControlTab.

◆ DoPropExchange()

void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Either reads this object from or writes this object to an archive.

Parameters
pPX A CXTPPropExchange object to serialize to or from.

Reimplemented from CXTPControl.

Reimplemented in CXTPControlButtonColor, CXTPControlComboBox, CXTPControlCustom, CXTPControlGallery, CXTPControlPopup, and CXTPRibbonControlTab.

◆ GetStyleEx()

XTPButtonStyle GetStyleEx ( ) const

Call this member to get the button's style containing vector icon.

Returns
The style of the button.

◆ OnClick()

virtual void OnClick | ( | BOOL | bKeyboard = FALSE,
 |  | CPoint | pt = CPoint(0, 0) )
 protectedvirtual

This method is called when the user clicks the control.

Parameters
bKeyboard | TRUE if the control is selected using the keyboard.
pt | Mouse cursor position.

Reimplemented from CXTPControl.

Reimplemented in CXTPControlComboBox, CXTPControlCustom, CXTPControlPopup, and CXTPControlTabWorkspace.

◆ OnLButtonUp()

virtual void OnLButtonUp ( CPoint point )
protectedvirtual

This member is called when the user releases the left mouse button.

Parameters
point Specifies the x- and y- coordinate of the cursor.

Reimplemented from CXTPControl.

Reimplemented in CXTPControlPopup, and CXTPRibbonControlSystemPopupBarPinableListItem.

◆ SetStyleEx()

void SetStyleEx ( XTPButtonStyle buttonStyle )

Call this member to set the style of the button containing vector icon.

Parameters
buttonStyle The style to be set. Can be any of the values listed in the Remarks section.

buttonStyle parameter can be one of the following: xtpButtonAutomatic: Indicates the default style. xtpButtonCaption: Indicates caption drawing only. xtpButtonIcon: Indicates icon drawing only. xtpButtonIconAndCaption: Indicates icon and caption drawing.

The documentation for this class was generated from the following file:
  • XTPControlButton.h


Toolkit Pro: CXTPControlButtonColor Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPControlButtonColor Class Reference

CXTPControlButtonColor is a CXTPControlButton derived class. More...

Inheritance diagram for CXTPControlButtonColor:
[legend]

Public Member Functions

CXTPControlButtonColor ()
Constructs a CXTPControlButtonColor object.
COLORREF | GetColor () const
Call this member to retrieve the color of the control.
void | SetColor (COLORREF clr)
Call this method to set the color of the control.
- Public Member Functions inherited from CXTPControlButton
CXTPControlButton ()
Constructs a CXTPControlButton object.
virtual | ~CXTPControlButton ()
Destroys a CXTPControlButton object, handles cleanup and deallocation.
void | SetStyleEx (XTPButtonStyle buttonStyle)
Call this member to set the style of the button containing vector icon.
XTPButtonStyle | GetStyleEx () const
Call this member to get the button's style containing vector icon.
- Public Member Functions inherited from CXTPControl
void | SetStyle (XTPButtonStyle buttonStyle)
Call this member to set the style of the control.
XTPButtonStyle | GetStyle () const
Call this member to get the control's style.
void | SetCaption (LPCTSTR lpszCaption)
Call this member to set the caption of the control.
void | SetCaption (UINT nIDCaption)
Call this member to set the caption of the control.
virtual CString | GetCaption () const
Call this member to get the control's caption.
void | SetShortcutText (LPCTSTR lpszShortcutText)
Call this member to set the shortcut string to the control.
CString | GetShortcutText () const
Call this member to get the control's shortcut.
void | SetDescription (LPCTSTR lpszDescription)
Call this member to set the description of the control.
virtual CString | GetDescription () const
Call this member to get the control's description.
void | SetTooltip (LPCTSTR lpszTooltip)
Call this member to set the tooltip of the control.
virtual CString | GetTooltip () const
Call this member to get the control's tooltip.
void | SetKeyboardTip (LPCTSTR lpszKeyboardTip)
Call this member to set the keyboard tip to the control.
CString | GetKeyboardTip () const
Call this member to get the keyboard tip.
void | SetCustomShortcutText (LPCTSTR lpszCustomShortcutText)
Call this member to set the text displayed for the shortcut in a pop-up menu.
CString | GetCustomShortcutText () const
Call this member to get the control's text displayed for the shortcut in a pop-up menu.
void | SetParameter (LPCTSTR lpszParameter)
Call this member to set the parameter of the control.
CString | GetParameter () const
Call this member to get the control's parameter.
void | SetID (int nId)
Call this member to set the identifier of the control.
int | GetID () const
Call this member to get the control's identifier.
long | GetIndex () const
Call this member to get the index of the control.
void | SetIconId (int nId)
Call this member to set the control icon's identifier.
int | GetIconId () const
Call this member to get the icon's identifier.
void | SetHelpId (int nId)
Call this member to set the control help identifier.
int | GetHelpId () const
Call this member to get the help identifier.
virtual void | SetBeginGroup (BOOL bBeginGroup)
Call this member to begin a new group using a separator.
BOOL | GetBeginGroup () const
Call this member to determine if the control has a separator.
virtual void | SetEnabled (BOOL bEnabled)
Call this member to enable/disable the control.
BOOL | GetEnabled () const
Call this member to check if the control is enabled.
virtual void | OnEnabledChanged ()
This method is called when a control's enabled state is changed.
virtual void | SetChecked (BOOL bChecked)
Call this member to set the checked state of the control.
BOOL | GetChecked () const
Call this member to get the checked state of the control.
virtual int | GetSelected () const
Call this member to check if the control is selected.
void | SetOnQuickAccess (BOOL bOnQuicAccess=FALSE)
Call this member to set whether a control should be a part of the Quick Access panel.
BOOL | IsOnQuickAccess () const
Call this member to check if a control is a part of the Quick Access panel.
virtual void | SetFocused (BOOL bFocused)
Call this member to set the focused state of the control.
virtual BOOL | IsFocused () const
Call this member to check the focused state of the control.
void | SetPressed (BOOL bPressed)
Call this member to set the pressed state of the control.
virtual BOOL | GetPressed () const
Call this member to check the pressed state of the control.
virtual void | SetRect (CRect rcControl)
This member is called to set the bounding rectangle of the control.
CRect | GetRect () const
Call this member to get the bounding rectangle of the control.
CXTPCommandBar * | GetParent () const
Call this member to get the parent command bar.
virtual BOOL | IsVisible (DWORD dwSkipFlags=0) const
Call this member to determine if the control is visible.
virtual BOOL | IsCaptionVisible () const
Call this member to determine if the caption of the control is visible.
void | SetVisible (BOOL bVisible)
Call this member to set the visibility of the control.
CXTPControls * | GetControls () const
Call this member to get the parent controls collection.
XTPControlType | GetType () const
Call this member to get the control's type.
void | SetFlags (DWORD dwFlags)
Call this member to set the flags of the control.
DWORD | GetFlags () const
Call this member to retrieve control special flags.
void | SetTag (DWORD_PTR dwTag)
This method sets the 32-bit value associated with the control.
DWORD_PTR | GetTag () const
This method retrieves the application-supplied, 32-bit value associated with the control.
virtual BOOL | Compare (CXTPControl *pOther)
Call this member to compare controls.
virtual CXTPCommandBar * | GetCommandBar () const
Call this member to get the child command bar.
void | SetCloseSubMenuOnClick (BOOL bCloseOnClick)
Call this member function to enable/disable the closing of sub-menus when a control is clicked in the menu.
BOOL | GetCloseSubMenuOnClick () const
Call this member function to check if sub-menus will close as soon as a control is clicked.
void | SetExecuteOnPressInterval (int nExecuteOnPressInterval)
Call this method to set the delay (in milliseconds) between WM_COMMAND messages while a button is pressed by the user.
int | GetExecuteOnPressInterval () const
Call this method to get the delay (in milliseconds) between WM_COMMAND messages while a button is pressed by the user.
CXTPRibbonGroup * | GetRibbonGroup () const
Returns the ribbon group that the control belongs to.
virtual BOOL | IsTransparent () const
Determines if the control needs to draw its background.
void | SetHideWrap (BOOL bHide)
This method is called to hide the control.
virtual void | SetHideFlags (DWORD dwFlags)
This method is called to hide the control.
BOOL | SetHideFlag (XTPControlHideFlags dwFlag, BOOL bSet)
Call this member to set/remove hide flags.
DWORD | GetHideFlags () const
Call this method to retrieve hidden flags.
CRect | GetRowRect () const
Call this method to retrieve the position of the control's row.
BOOL | GetWrap () const
Call this method to check if the control is wrapped.
void | SetRowRect (CRect rcRow)
Call this method to set the row of the control.
void | SetWrap (BOOL bWrap)
Call this member to set the control to wrapped.
BOOL | GetExpanded () const
Call this member to check if the control is expanded.
BOOL | IsCursorOver () const
Call this member to determine if the mouse pointer is over the control.
virtual void | OnExecute ()
This method is called when the control is executed.
virtual void | OnCalcDynamicSize (DWORD dwMode)
This method is called before recalculating the parent command bar size to calculate the dimensions of the control.
void | DelayRedrawParent ()
Call this method to redraw the parent command bar.
void | DelayLayoutParent ()
Call this method to recalculate the parent command bar size.
void | SetCategory (LPCTSTR lpszCategory)
Call this method to set the category of the control.
CString | GetCategory () const
Call this method to retrieve the category of the control.
CXTPImageManager * | GetImageManager () const
Call this method to retrieve the image manager.
CXTPPaintManager * | GetPaintManager () const
Call this method to retrieve the paint manager.
virtual CXTPImageManagerIcon * | GetImage (int nWidth=16) const
Call this method to retrieve the image of the control.
void | AssignDocTemplate (UINT nIDResource)
Call this method to assign a document template to the control.
void | ExcludeDocTemplate (UINT nIDResource)
Call this method to exclude the document template from control.
BOOL | IsItemDefault () const
Call this method to check if a control is a default menu item.
void | SetItemDefault (BOOL bDefault)
Call this method to set a control to be a default menu item.
BOOL | IsTemporary () const
Call this method to determine if a control is temporary.
void | Reset ()
Call this member to reset the icon and caption of a control to its default settings before it was customized by the user.
void | SetPrompt (LPCTSTR lpszPrompt)
Call this member to load a string from a STRINGTABLE resource to set the tooltip and description of a control.
void | SetCustomIcon (HICON hIcon)
Call this member to set a custom icon to this control.
virtual void | OnUnderlineActivate ()
This method is called when the user activates the control using its underline.
virtual BOOL | GetPopuped () const
Call this member to get the control's pop-up state.
void | RedrawParent (BOOL bAnimate=TRUE)
This method is called to redraw the parent command bar.
LRESULT | NotifySite (UINT code)
This method is called to send message code to the parent site window.
LRESULT | NotifySite (UINT code, NMXTPCONTROL *pNM)
This method is called to send message code to the parent site window.
LRESULT | NotifySite (CWnd *pSite, UINT code, NMXTPCONTROL *pNM)
This method is called to send message code to the parent site window.
virtual void | SetAction (CXTPControlAction *pAction)
Call this method to manually assign an action for control.
CXTPControlAction * | GetAction () const
Call this method to retrieve an action associated with control.
virtual void | OnThemeChanged ()
This method is called when the paint manager theme is changed.
virtual void | SetWidth (int nWidth)
Call this member to set the width of the control.
virtual void | SetHeight (int nHeight)
Call this member to set the height of the control.
int | GetWidth () const
Call this member to get the width of the control.
int | GetHeight () const
Call this member to get the height of the control.
BOOL | HasDwmCompositedRect () const
This method is called to determine if control has a Vista DWM transparent area.
virtual CSize | GetButtonSize () const
Call this function to get the size of the command bar button.
virtual CSize | GetIconSize () const
Call this member function to get the size of a toolbar icon.
void | SetIconSize (CSize szIcon)
Call this member function to set the size of an icon for an individual control.
virtual BOOL | IsCustomizeMovable () const
This method is called to determine if control can be repositioned in customize mode.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

void | Copy (CXTPControl *pControl, BOOL bRecursive=FALSE)
This method is called to copy the control.
void | DoPropExchange (CXTPPropExchange *pPX)
Either reads this object from or writes this object to an archive.
CSize | GetSize (CDC *pDC)
This method is called to determine the size of the control.
void | Draw (CDC *pDC)
This method is called to draw the control.
- Protected Member Functions inherited from CXTPControlButton
virtual void | OnClick (BOOL bKeyboard=FALSE, CPoint pt=CPoint(0, 0))
This method is called when the user clicks the control.
virtual void | OnLButtonUp (CPoint point)
This member is called when the user releases the left mouse button.
- Protected Member Functions inherited from CXTPControl
CXTPControl ()
Constructs a CXTPControl object.
virtual | ~CXTPControl ()
Destroys a CXTPControl object, handles cleanup and deallocation.
virtual BOOL | IsFocusable () const
This method is called to check if the control can accept focus.
void | SetIndex (int nIndex)
This method is called to assign the order of the control in the controls list.
void | SetExpanded (BOOL bExpanded)
This method is called to set the control's expanded state.
virtual BOOL | OnHookKeyDown (UINT nChar, LPARAM lParam)
This method is called when a non-system key is pressed.
virtual BOOL | OnHookMouseWheel (UINT nFlags, short zDelta, CPoint point)
This method is called when the user rotates the mouse wheel.
virtual void | SetParent (CXTPCommandBar *pParent)
This method is called to assign a parent command bar object.
void | ScreenToClient (CPoint *point)
The ScreenToClient function converts the screen coordinates of a specified point on the screen.
void | ClickToolBarButton (CRect rcActiveRect=CRect(0, 0, 0, 0))
This helper method is called when the user clicks the toolbar's button.
virtual BOOL | OnSetPopup (BOOL bPopup)
This method is called to pop-up the control.
virtual void | OnLButtonDown (CPoint point)
This member is called when the user presses the left mouse button down.
virtual BOOL | OnRButtonDown (CPoint point)
This member is called when the user press the right mouse button.
virtual BOOL | OnRButtonUp (CPoint point)
This member is called when the user releases the right mouse button.
virtual BOOL | OnLButtonDblClk (CPoint point)
This member is called when the user double-clicks the left mouse button.
virtual void | OnMouseMove (CPoint point)
This member is called when the mouse cursor moves.
virtual void | OnMouseHover ()
Called after the mouse hovers over the control.
virtual BOOL | OnSetSelected (int bSelected)
This method is called when the control becomes selected.
BOOL | IsCustomizeMode () const
Call this method to determine if command bars is in customize mode.
virtual void | CustomizeStartDrag (CPoint point)
This member is called when the user starts to drag the control in customize mode.
virtual BOOL | CustomizeStartResize (CPoint point)
This method is called when user starts to resize control in customize mode.
virtual void | OnCustomizeDragOver (CXTPControl *pDataObject, CPoint point, DROPEFFECT &dropEffect)
This member is called when the user moves the mouse over the control.
virtual BOOL | DoCustomDragOver (CXTPCommandBar *pCommandBar, CPoint point, DROPEFFECT &dropEffect)
The implementation may implement a custom drag over handling logic in this method.
virtual BOOL | IsCustomizeResizeAllow () const
This member checks if the user can resize the control.
virtual int | GetCustomizeMinWidth () const
Retrieves the available minimum width of control.
virtual int | GetCustomizeMinHeight () const
Retrieves available minimum height of the control.
void | OnCustomizeMouseMove (CPoint point)
This member is called when the mouse cursor moves in customized mode.
virtual void | OnIdleUpdate ()
This virtual method is called in idle-time processing.
virtual void | OnRemoved ()
This method is called when a control is removed from the parent controls collection.
virtual INT_PTR | OnToolHitTest (CPoint point, TOOLINFO *pTI) const
The framework calls this member function to determine whether a point is in the bounding rectangle of the specified tool.
virtual void | RestoreCommandBarList (CXTPCommandBarList *pCommandBarList)
This method is called from LoadCommandBars to restore controls and its child command bars.
virtual void | GenerateCommandBarList (DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam)
This method is called from SaveCommandBars to save all child command bars.
virtual void | OnActionChanged (int nProperty)
This method is called when an action property is changed.
virtual void | OnActionChanging (int nProperty)
This method is called when an action property is about to be changed.
virtual void | OnCaptionChanged ()
This method is called when the control's caption is changed.
BOOL | IsLayoutRTL () const
Determines if right-to-left (RTL) mode is set.
BOOL | IsLayoutChanged ()
Call this member to determine if the layout has changed (RTL to LTR or LTR to RLT).

Protected Attributes

COLORREF | m_clr
Color of the color bar displayed in the color button under the "pin" icon.
- Protected Attributes inherited from CXTPControlButton
XTPButtonStyle | m_buttonStyleEx
User-defined style of button containing vector icon.
- Protected Attributes inherited from CXTPControl
DWORD_PTR | m_nTag
Control tag.
int | m_nIndex
Index of the control.
int | m_nId
Identifier of the control.
int | m_nIconId
Identifier of the control's image.
int | m_nHelpId
Help identifier.
int | m_nCustomIconId
Identifier of the control's custom image.
BOOL | m_bWrap
TRUE if the control is wrapped.
BOOL | m_bBeginGroup
TRUE if the control starts new group.
BOOL | m_bEnabled
TRUE if the control is enabled.
BOOL | m_bChecked
TRUE if the control is checked.
BOOL | m_bSelected
TRUE if the control is selected.
BOOL | m_bPressed
TRUE if the control is pushed.
BOOL | m_bTemporary
TRUE if the control is temporary.
BOOL | m_bOnQuickAccess
TRUE if the control is a part of Quick Access panel.
CRect | m_rcRow
Bounding rectangle of the control's row.
CRect | m_rcControl
Bounding rectangle of the control.
DWORD | m_dwHideFlags
Hidden flags.
DWORD | m_dwFlags
Flags of the control.
CString | m_strCaption
Caption of the control.
CString | m_strCustomCaption
User-defined caption.
CString | m_strShortcutText
Shortcut text.
CString | m_strShortcutTextAuto
Shortcut text.
CString | m_strTooltipText
Tooltip text.
CString | m_strDescriptionText
Description text.
CString | m_strParameter
Parameter text.
CString | m_strKeyboardTip
Keyboard tip.
CXTPControls * | m_pControls
Parent control collection.
XTPControlType | m_controlType
Type of the control.
CXTPCommandBar * | m_pParent
The Parent command bar.
BOOL | m_bExpanded
TRUE if the control is expanded.
CString | m_strCategory
Category of the control.
BOOL | m_bDefaultItem
TRUE if the item is default pop-up item.
CDocTemplateMap | m_mapDocTemplatesAssigned
Assigned templates.
CDocTemplateMap | m_mapDocTemplatesExcluded
Excluded templates.
XTPButtonStyle | m_buttonStyle
Button Style.
XTPButtonStyle | m_buttonCustomStyle
User-defined style of button.
XTPButtonStyle | m_buttonRibbonStyle
User-defined style of button.
BOOL | m_bCloseSubMenuOnClick
TRUE is sub-menus are closed as soon as a control is clicked.
CXTPRibbonGroup * | m_pRibbonGroup
Ribbon group of control.
CXTPControlAction * | m_pAction
Action of the control.
int | m_nWidth
Width of the control.
int | m_nHeight
Height of the control.
int | m_nExecuteOnPressInterval
Delay between each message when control is pressed.
CSize | m_szIcon
The size of the icon used for the control.
BOOL | m_bLayoutRTL
Indicate does last layout is RTL.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControl
static CXTPControl *AFX_CDECL | FromUI (CCmdUI *pCmdUI)
Call this member to retrieve CXTPControl from a CCmdUI structure.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

CXTPControlButtonColor is a CXTPControlButton derived class.

It represents a text button in the color picker pop-up.

Member Function Documentation

◆ Copy()

void Copy | ( | CXTPControl * | pControl,
 |  | BOOL | bRecursive = FALSE )
 protectedvirtual

This method is called to copy the control.

Parameters
pControl | Pointer to a source CXTPControl object.
bRecursive | TRUE to copy recursively.

Reimplemented from CXTPControlButton.

◆ DoPropExchange()

void DoPropExchange ( CXTPPropExchange * pPX )
protectedvirtual

Either reads this object from or writes this object to an archive.

Parameters
pPX A CXTPPropExchange object to serialize to or from.

Reimplemented from CXTPControlButton.

◆ Draw()

void Draw ( CDC * pDC )
protectedvirtual

This method is called to draw the control.

Parameters
pDC Pointer to a valid device context.

Reimplemented from CXTPControl.

◆ GetColor()

COLORREF GetColor ( ) const

Call this member to retrieve the color of the control.

Returns
Color of the selector.

◆ GetSize()

CSize GetSize ( CDC * pDC )
protectedvirtual

This method is called to determine the size of the control.

Parameters
pDC Pointer to a valid device context.
Returns
A CSize object containing the size of the control.

Reimplemented from CXTPControl.

◆ SetColor()

void SetColor ( COLORREF clr )

Call this method to set the color of the control.

Parameters
clr Color to set.
The documentation for this class was generated from the following file:
  • XTPControlPopupColor.h


Toolkit Pro: CXTPControlCheckBox Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPControlCheckBox Class Reference

CXTPControlCheckBox is a CXTPControlButton derived class. More...

Inheritance diagram for CXTPControlCheckBox:
[legend]

Public Member Functions

CXTPControlCheckBox ()
Constructs a CXTPControlCheckBox object.
- Public Member Functions inherited from CXTPControlButton
CXTPControlButton ()
Constructs a CXTPControlButton object.
virtual | ~CXTPControlButton ()
Destroys a CXTPControlButton object, handles cleanup and deallocation.
void | SetStyleEx (XTPButtonStyle buttonStyle)
Call this member to set the style of the button containing vector icon.
XTPButtonStyle | GetStyleEx () const
Call this member to get the button's style containing vector icon.
void | DoPropExchange (CXTPPropExchange *pPX)
Either reads this object from or writes this object to an archive.
- Public Member Functions inherited from CXTPControl
void | SetStyle (XTPButtonStyle buttonStyle)
Call this member to set the style of the control.
XTPButtonStyle | GetStyle () const
Call this member to get the control's style.
void | SetCaption (LPCTSTR lpszCaption)
Call this member to set the caption of the control.
void | SetCaption (UINT nIDCaption)
Call this member to set the caption of the control.
virtual CString | GetCaption () const
Call this member to get the control's caption.
void | SetShortcutText (LPCTSTR lpszShortcutText)
Call this member to set the shortcut string to the control.
CString | GetShortcutText () const
Call this member to get the control's shortcut.
void | SetDescription (LPCTSTR lpszDescription)
Call this member to set the description of the control.
virtual CString | GetDescription () const
Call this member to get the control's description.
void | SetTooltip (LPCTSTR lpszTooltip)
Call this member to set the tooltip of the control.
virtual CString | GetTooltip () const
Call this member to get the control's tooltip.
void | SetKeyboardTip (LPCTSTR lpszKeyboardTip)
Call this member to set the keyboard tip to the control.
CString | GetKeyboardTip () const
Call this member to get the keyboard tip.
void | SetCustomShortcutText (LPCTSTR lpszCustomShortcutText)
Call this member to set the text displayed for the shortcut in a pop-up menu.
CString | GetCustomShortcutText () const
Call this member to get the control's text displayed for the shortcut in a pop-up menu.
void | SetParameter (LPCTSTR lpszParameter)
Call this member to set the parameter of the control.
CString | GetParameter () const
Call this member to get the control's parameter.
void | SetID (int nId)
Call this member to set the identifier of the control.
int | GetID () const
Call this member to get the control's identifier.
long | GetIndex () const
Call this member to get the index of the control.
void | SetIconId (int nId)
Call this member to set the control icon's identifier.
int | GetIconId () const
Call this member to get the icon's identifier.
void | SetHelpId (int nId)
Call this member to set the control help identifier.
int | GetHelpId () const
Call this member to get the help identifier.
virtual void | SetBeginGroup (BOOL bBeginGroup)
Call this member to begin a new group using a separator.
BOOL | GetBeginGroup () const
Call this member to determine if the control has a separator.
virtual void | SetEnabled (BOOL bEnabled)
Call this member to enable/disable the control.
BOOL | GetEnabled () const
Call this member to check if the control is enabled.
virtual void | OnEnabledChanged ()
This method is called when a control's enabled state is changed.
virtual void | SetChecked (BOOL bChecked)
Call this member to set the checked state of the control.
BOOL | GetChecked () const
Call this member to get the checked state of the control.
virtual int | GetSelected () const
Call this member to check if the control is selected.
void | SetOnQuickAccess (BOOL bOnQuicAccess=FALSE)
Call this member to set whether a control should be a part of the Quick Access panel.
BOOL | IsOnQuickAccess () const
Call this member to check if a control is a part of the Quick Access panel.
virtual void | SetFocused (BOOL bFocused)
Call this member to set the focused state of the control.
void | SetPressed (BOOL bPressed)
Call this member to set the pressed state of the control.
virtual BOOL | GetPressed () const
Call this member to check the pressed state of the control.
virtual void | SetRect (CRect rcControl)
This member is called to set the bounding rectangle of the control.
CRect | GetRect () const
Call this member to get the bounding rectangle of the control.
CXTPCommandBar * | GetParent () const
Call this member to get the parent command bar.
virtual BOOL | IsVisible (DWORD dwSkipFlags=0) const
Call this member to determine if the control is visible.
virtual BOOL | IsCaptionVisible () const
Call this member to determine if the caption of the control is visible.
void | SetVisible (BOOL bVisible)
Call this member to set the visibility of the control.
CXTPControls * | GetControls () const
Call this member to get the parent controls collection.
XTPControlType | GetType () const
Call this member to get the control's type.
void | SetFlags (DWORD dwFlags)
Call this member to set the flags of the control.
DWORD | GetFlags () const
Call this member to retrieve control special flags.
void | SetTag (DWORD_PTR dwTag)
This method sets the 32-bit value associated with the control.
DWORD_PTR | GetTag () const
This method retrieves the application-supplied, 32-bit value associated with the control.
virtual BOOL | Compare (CXTPControl *pOther)
Call this member to compare controls.
virtual CXTPCommandBar * | GetCommandBar () const
Call this member to get the child command bar.
void | SetCloseSubMenuOnClick (BOOL bCloseOnClick)
Call this member function to enable/disable the closing of sub-menus when a control is clicked in the menu.
BOOL | GetCloseSubMenuOnClick () const
Call this member function to check if sub-menus will close as soon as a control is clicked.
void | SetExecuteOnPressInterval (int nExecuteOnPressInterval)
Call this method to set the delay (in milliseconds) between WM_COMMAND messages while a button is pressed by the user.
int | GetExecuteOnPressInterval () const
Call this method to get the delay (in milliseconds) between WM_COMMAND messages while a button is pressed by the user.
CXTPRibbonGroup * | GetRibbonGroup () const
Returns the ribbon group that the control belongs to.
virtual BOOL | IsTransparent () const
Determines if the control needs to draw its background.
void | SetHideWrap (BOOL bHide)
This method is called to hide the control.
virtual void | SetHideFlags (DWORD dwFlags)
This method is called to hide the control.
BOOL | SetHideFlag (XTPControlHideFlags dwFlag, BOOL bSet)
Call this member to set/remove hide flags.
DWORD | GetHideFlags () const
Call this method to retrieve hidden flags.
CRect | GetRowRect () const
Call this method to retrieve the position of the control's row.
BOOL | GetWrap () const
Call this method to check if the control is wrapped.
void | SetRowRect (CRect rcRow)
Call this method to set the row of the control.
void | SetWrap (BOOL bWrap)
Call this member to set the control to wrapped.
BOOL | GetExpanded () const
Call this member to check if the control is expanded.
BOOL | IsCursorOver () const
Call this member to determine if the mouse pointer is over the control.
virtual void | OnExecute ()
This method is called when the control is executed.
virtual CSize | GetSize (CDC *pDC)
This method is called to determine the size of the control.
virtual void | Draw (CDC *pDC)
This method is called to draw the control.
virtual void | OnCalcDynamicSize (DWORD dwMode)
This method is called before recalculating the parent command bar size to calculate the dimensions of the control.
void | DelayRedrawParent ()
Call this method to redraw the parent command bar.
void | DelayLayoutParent ()
Call this method to recalculate the parent command bar size.
void | SetCategory (LPCTSTR lpszCategory)
Call this method to set the category of the control.
CString | GetCategory () const
Call this method to retrieve the category of the control.
CXTPImageManager * | GetImageManager () const
Call this method to retrieve the image manager.
CXTPPaintManager * | GetPaintManager () const
Call this method to retrieve the paint manager.
virtual CXTPImageManagerIcon * | GetImage (int nWidth=16) const
Call this method to retrieve the image of the control.
void | AssignDocTemplate (UINT nIDResource)
Call this method to assign a document template to the control.
void | ExcludeDocTemplate (UINT nIDResource)
Call this method to exclude the document template from control.
BOOL | IsItemDefault () const
Call this method to check if a control is a default menu item.
void | SetItemDefault (BOOL bDefault)
Call this method to set a control to be a default menu item.
BOOL | IsTemporary () const
Call this method to determine if a control is temporary.
void | Reset ()
Call this member to reset the icon and caption of a control to its default settings before it was customized by the user.
void | SetPrompt (LPCTSTR lpszPrompt)
Call this member to load a string from a STRINGTABLE resource to set the tooltip and description of a control.
void | SetCustomIcon (HICON hIcon)
Call this member to set a custom icon to this control.
virtual void | OnUnderlineActivate ()
This method is called when the user activates the control using its underline.
virtual BOOL | GetPopuped () const
Call this member to get the control's pop-up state.
void | RedrawParent (BOOL bAnimate=TRUE)
This method is called to redraw the parent command bar.
LRESULT | NotifySite (UINT code)
This method is called to send message code to the parent site window.
LRESULT | NotifySite (UINT code, NMXTPCONTROL *pNM)
This method is called to send message code to the parent site window.
LRESULT | NotifySite (CWnd *pSite, UINT code, NMXTPCONTROL *pNM)
This method is called to send message code to the parent site window.
virtual void | SetAction (CXTPControlAction *pAction)
Call this method to manually assign an action for control.
CXTPControlAction * | GetAction () const
Call this method to retrieve an action associated with control.
virtual void | OnThemeChanged ()
This method is called when the paint manager theme is changed.
virtual void | SetWidth (int nWidth)
Call this member to set the width of the control.
virtual void | SetHeight (int nHeight)
Call this member to set the height of the control.
int | GetWidth () const
Call this member to get the width of the control.
int | GetHeight () const
Call this member to get the height of the control.
BOOL | HasDwmCompositedRect () const
This method is called to determine if control has a Vista DWM transparent area.
virtual CSize | GetButtonSize () const
Call this function to get the size of the command bar button.
virtual CSize | GetIconSize () const
Call this member function to get the size of a toolbar icon.
void | SetIconSize (CSize szIcon)
Call this member function to set the size of an icon for an individual control.
virtual BOOL | IsCustomizeMovable () const
This method is called to determine if control can be repositioned in customize mode.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

BOOL | OnHookKeyDown (UINT nChar, LPARAM lParam)
The framework calls this member function when a non-system key is pressed.
BOOL | IsFocused () const
Call this member to get the focused state of the control.
- Protected Member Functions inherited from CXTPControlButton
virtual void | OnClick (BOOL bKeyboard=FALSE, CPoint pt=CPoint(0, 0))
This method is called when the user clicks the control.
virtual void | OnLButtonUp (CPoint point)
This member is called when the user releases the left mouse button.
virtual void | Copy (CXTPControl *pControl, BOOL bRecursive=FALSE)
This method is called to copy the control.
- Protected Member Functions inherited from CXTPControl
CXTPControl ()
Constructs a CXTPControl object.
virtual | ~CXTPControl ()
Destroys a CXTPControl object, handles cleanup and deallocation.
virtual BOOL | IsFocusable () const
This method is called to check if the control can accept focus.
void | SetIndex (int nIndex)
This method is called to assign the order of the control in the controls list.
void | SetExpanded (BOOL bExpanded)
This method is called to set the control's expanded state.
virtual BOOL | OnHookMouseWheel (UINT nFlags, short zDelta, CPoint point)
This method is called when the user rotates the mouse wheel.
virtual void | SetParent (CXTPCommandBar *pParent)
This method is called to assign a parent command bar object.
void | ScreenToClient (CPoint *point)
The ScreenToClient function converts the screen coordinates of a specified point on the screen.
void | ClickToolBarButton (CRect rcActiveRect=CRect(0, 0, 0, 0))
This helper method is called when the user clicks the toolbar's button.
virtual BOOL | OnSetPopup (BOOL bPopup)
This method is called to pop-up the control.
virtual void | OnLButtonDown (CPoint point)
This member is called when the user presses the left mouse button down.
virtual BOOL | OnRButtonDown (CPoint point)
This member is called when the user press the right mouse button.
virtual BOOL | OnRButtonUp (CPoint point)
This member is called when the user releases the right mouse button.
virtual BOOL | OnLButtonDblClk (CPoint point)
This member is called when the user double-clicks the left mouse button.
virtual void | OnMouseMove (CPoint point)
This member is called when the mouse cursor moves.
virtual void | OnMouseHover ()
Called after the mouse hovers over the control.
virtual BOOL | OnSetSelected (int bSelected)
This method is called when the control becomes selected.
BOOL | IsCustomizeMode () const
Call this method to determine if command bars is in customize mode.
virtual void | CustomizeStartDrag (CPoint point)
This member is called when the user starts to drag the control in customize mode.
virtual BOOL | CustomizeStartResize (CPoint point)
This method is called when user starts to resize control in customize mode.
virtual void | OnCustomizeDragOver (CXTPControl *pDataObject, CPoint point, DROPEFFECT &dropEffect)
This member is called when the user moves the mouse over the control.
virtual BOOL | DoCustomDragOver (CXTPCommandBar *pCommandBar, CPoint point, DROPEFFECT &dropEffect)
The implementation may implement a custom drag over handling logic in this method.
virtual BOOL | IsCustomizeResizeAllow () const
This member checks if the user can resize the control.
virtual int | GetCustomizeMinWidth () const
Retrieves the available minimum width of control.
virtual int | GetCustomizeMinHeight () const
Retrieves available minimum height of the control.
void | OnCustomizeMouseMove (CPoint point)
This member is called when the mouse cursor moves in customized mode.
virtual void | OnIdleUpdate ()
This virtual method is called in idle-time processing.
virtual void | OnRemoved ()
This method is called when a control is removed from the parent controls collection.
virtual INT_PTR | OnToolHitTest (CPoint point, TOOLINFO *pTI) const
The framework calls this member function to determine whether a point is in the bounding rectangle of the specified tool.
virtual void | RestoreCommandBarList (CXTPCommandBarList *pCommandBarList)
This method is called from LoadCommandBars to restore controls and its child command bars.
virtual void | GenerateCommandBarList (DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam)
This method is called from SaveCommandBars to save all child command bars.
virtual void | OnActionChanged (int nProperty)
This method is called when an action property is changed.
virtual void | OnActionChanging (int nProperty)
This method is called when an action property is about to be changed.
virtual void | OnCaptionChanged ()
This method is called when the control's caption is changed.
BOOL | IsLayoutRTL () const
Determines if right-to-left (RTL) mode is set.
BOOL | IsLayoutChanged ()
Call this member to determine if the layout has changed (RTL to LTR or LTR to RLT).

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControl
static CXTPControl *AFX_CDECL | FromUI (CCmdUI *pCmdUI)
Call this member to retrieve CXTPControl from a CCmdUI structure.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Attributes inherited from CXTPControlButton
XTPButtonStyle | m_buttonStyleEx
User-defined style of button containing vector icon.
- Protected Attributes inherited from CXTPControl
DWORD_PTR | m_nTag
Control tag.
int | m_nIndex
Index of the control.
int | m_nId
Identifier of the control.
int | m_nIconId
Identifier of the control's image.
int | m_nHelpId
Help identifier.
int | m_nCustomIconId
Identifier of the control's custom image.
BOOL | m_bWrap
TRUE if the control is wrapped.
BOOL | m_bBeginGroup
TRUE if the control starts new group.
BOOL | m_bEnabled
TRUE if the control is enabled.
BOOL | m_bChecked
TRUE if the control is checked.
BOOL | m_bSelected
TRUE if the control is selected.
BOOL | m_bPressed
TRUE if the control is pushed.
BOOL | m_bTemporary
TRUE if the control is temporary.
BOOL | m_bOnQuickAccess
TRUE if the control is a part of Quick Access panel.
CRect | m_rcRow
Bounding rectangle of the control's row.
CRect | m_rcControl
Bounding rectangle of the control.
DWORD | m_dwHideFlags
Hidden flags.
DWORD | m_dwFlags
Flags of the control.
CString | m_strCaption
Caption of the control.
CString | m_strCustomCaption
User-defined caption.
CString | m_strShortcutText
Shortcut text.
CString | m_strShortcutTextAuto
Shortcut text.
CString | m_strTooltipText
Tooltip text.
CString | m_strDescriptionText
Description text.
CString | m_strParameter
Parameter text.
CString | m_strKeyboardTip
Keyboard tip.
CXTPControls * | m_pControls
Parent control collection.
XTPControlType | m_controlType
Type of the control.
CXTPCommandBar * | m_pParent
The Parent command bar.
BOOL | m_bExpanded
TRUE if the control is expanded.
CString | m_strCategory
Category of the control.
BOOL | m_bDefaultItem
TRUE if the item is default pop-up item.
CDocTemplateMap | m_mapDocTemplatesAssigned
Assigned templates.
CDocTemplateMap | m_mapDocTemplatesExcluded
Excluded templates.
XTPButtonStyle | m_buttonStyle
Button Style.
XTPButtonStyle | m_buttonCustomStyle
User-defined style of button.
XTPButtonStyle | m_buttonRibbonStyle
User-defined style of button.
BOOL | m_bCloseSubMenuOnClick
TRUE is sub-menus are closed as soon as a control is clicked.
CXTPRibbonGroup * | m_pRibbonGroup
Ribbon group of control.
CXTPControlAction * | m_pAction
Action of the control.
int | m_nWidth
Width of the control.
int | m_nHeight
Height of the control.
int | m_nExecuteOnPressInterval
Delay between each message when control is pressed.
CSize | m_szIcon
The size of the icon used for the control.
BOOL | m_bLayoutRTL
Indicate does last layout is RTL.

Detailed Description

CXTPControlCheckBox is a CXTPControlButton derived class.

It represents a checkbox control.

Member Function Documentation

◆ IsFocused()

BOOL IsFocused ( ) const
protectedvirtual

Call this member to get the focused state of the control.

Returns
TRUE if the control has focus, otherwise FALSE.

Reimplemented from CXTPControl.

◆ OnHookKeyDown()

BOOL OnHookKeyDown | ( | UINT | nChar,
 |  | LPARAM | lParam )
 protectedvirtual

The framework calls this member function when a non-system key is pressed.

Parameters
nChar | Specifies the virtual key code of the given key.
lParam | Specifies additional message-dependent information.
Returns
TRUE if the key was handled, otherwise FALSE.

Reimplemented from CXTPControl.

The documentation for this class was generated from the following file:
  • XTPControlExt.h


Toolkit Pro: CXTPControlColorSelector Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPControlColorSelector Class Reference

CXTPControlColorSelector is a CXTPControl derived class. More...

Inheritance diagram for CXTPControlColorSelector:
[legend]

Public Member Functions

CXTPControlColorSelector ()
Constructs a CXTPControlColorSelector object.
COLORREF | GetColor () const
Call this member to retrieve the color of the selector control.
void | SetColor (COLORREF clr)
Call this method to set the color of the control.
- Public Member Functions inherited from CXTPControl
void | SetStyle (XTPButtonStyle buttonStyle)
Call this member to set the style of the control.
XTPButtonStyle | GetStyle () const
Call this member to get the control's style.
void | SetCaption (LPCTSTR lpszCaption)
Call this member to set the caption of the control.
void | SetCaption (UINT nIDCaption)
Call this member to set the caption of the control.
virtual CString | GetCaption () const
Call this member to get the control's caption.
void | SetShortcutText (LPCTSTR lpszShortcutText)
Call this member to set the shortcut string to the control.
CString | GetShortcutText () const
Call this member to get the control's shortcut.
void | SetDescription (LPCTSTR lpszDescription)
Call this member to set the description of the control.
virtual CString | GetDescription () const
Call this member to get the control's description.
void | SetTooltip (LPCTSTR lpszTooltip)
Call this member to set the tooltip of the control.
virtual CString | GetTooltip () const
Call this member to get the control's tooltip.
void | SetKeyboardTip (LPCTSTR lpszKeyboardTip)
Call this member to set the keyboard tip to the control.
CString | GetKeyboardTip () const
Call this member to get the keyboard tip.
void | SetCustomShortcutText (LPCTSTR lpszCustomShortcutText)
Call this member to set the text displayed for the shortcut in a pop-up menu.
CString | GetCustomShortcutText () const
Call this member to get the control's text displayed for the shortcut in a pop-up menu.
void | SetParameter (LPCTSTR lpszParameter)
Call this member to set the parameter of the control.
CString | GetParameter () const
Call this member to get the control's parameter.
void | SetID (int nId)
Call this member to set the identifier of the control.
int | GetID () const
Call this member to get the control's identifier.
long | GetIndex () const
Call this member to get the index of the control.
void | SetIconId (int nId)
Call this member to set the control icon's identifier.
int | GetIconId () const
Call this member to get the icon's identifier.
void | SetHelpId (int nId)
Call this member to set the control help identifier.
int | GetHelpId () const
Call this member to get the help identifier.
virtual void | SetBeginGroup (BOOL bBeginGroup)
Call this member to begin a new group using a separator.
BOOL | GetBeginGroup () const
Call this member to determine if the control has a separator.
virtual void | SetEnabled (BOOL bEnabled)
Call this member to enable/disable the control.
BOOL | GetEnabled () const
Call this member to check if the control is enabled.
virtual void | OnEnabledChanged ()
This method is called when a control's enabled state is changed.
virtual void | SetChecked (BOOL bChecked)
Call this member to set the checked state of the control.
BOOL | GetChecked () const
Call this member to get the checked state of the control.
virtual int | GetSelected () const
Call this member to check if the control is selected.
void | SetOnQuickAccess (BOOL bOnQuicAccess=FALSE)
Call this member to set whether a control should be a part of the Quick Access panel.
BOOL | IsOnQuickAccess () const
Call this member to check if a control is a part of the Quick Access panel.
virtual void | SetFocused (BOOL bFocused)
Call this member to set the focused state of the control.
void | SetPressed (BOOL bPressed)
Call this member to set the pressed state of the control.
virtual BOOL | GetPressed () const
Call this member to check the pressed state of the control.
virtual void | SetRect (CRect rcControl)
This member is called to set the bounding rectangle of the control.
CRect | GetRect () const
Call this member to get the bounding rectangle of the control.
CXTPCommandBar * | GetParent () const
Call this member to get the parent command bar.
virtual BOOL | IsVisible (DWORD dwSkipFlags=0) const
Call this member to determine if the control is visible.
virtual BOOL | IsCaptionVisible () const
Call this member to determine if the caption of the control is visible.
void | SetVisible (BOOL bVisible)
Call this member to set the visibility of the control.
CXTPControls * | GetControls () const
Call this member to get the parent controls collection.
XTPControlType | GetType () const
Call this member to get the control's type.
void | SetFlags (DWORD dwFlags)
Call this member to set the flags of the control.
DWORD | GetFlags () const
Call this member to retrieve control special flags.
void | SetTag (DWORD_PTR dwTag)
This method sets the 32-bit value associated with the control.
DWORD_PTR | GetTag () const
This method retrieves the application-supplied, 32-bit value associated with the control.
virtual BOOL | Compare (CXTPControl *pOther)
Call this member to compare controls.
virtual CXTPCommandBar * | GetCommandBar () const
Call this member to get the child command bar.
void | SetCloseSubMenuOnClick (BOOL bCloseOnClick)
Call this member function to enable/disable the closing of sub-menus when a control is clicked in the menu.
BOOL | GetCloseSubMenuOnClick () const
Call this member function to check if sub-menus will close as soon as a control is clicked.
void | SetExecuteOnPressInterval (int nExecuteOnPressInterval)
Call this method to set the delay (in milliseconds) between WM_COMMAND messages while a button is pressed by the user.
int | GetExecuteOnPressInterval () const
Call this method to get the delay (in milliseconds) between WM_COMMAND messages while a button is pressed by the user.
CXTPRibbonGroup * | GetRibbonGroup () const
Returns the ribbon group that the control belongs to.
virtual BOOL | IsTransparent () const
Determines if the control needs to draw its background.
void | SetHideWrap (BOOL bHide)
This method is called to hide the control.
virtual void | SetHideFlags (DWORD dwFlags)
This method is called to hide the control.
BOOL | SetHideFlag (XTPControlHideFlags dwFlag, BOOL bSet)
Call this member to set/remove hide flags.
DWORD | GetHideFlags () const
Call this method to retrieve hidden flags.
CRect | GetRowRect () const
Call this method to retrieve the position of the control's row.
BOOL | GetWrap () const
Call this method to check if the control is wrapped.
void | SetRowRect (CRect rcRow)
Call this method to set the row of the control.
void | SetWrap (BOOL bWrap)
Call this member to set the control to wrapped.
BOOL | GetExpanded () const
Call this member to check if the control is expanded.
BOOL | IsCursorOver () const
Call this member to determine if the mouse pointer is over the control.
virtual void | OnCalcDynamicSize (DWORD dwMode)
This method is called before recalculating the parent command bar size to calculate the dimensions of the control.
void | DelayRedrawParent ()
Call this method to redraw the parent command bar.
void | DelayLayoutParent ()
Call this method to recalculate the parent command bar size.
void | SetCategory (LPCTSTR lpszCategory)
Call this method to set the category of the control.
CString | GetCategory () const
Call this method to retrieve the category of the control.
CXTPImageManager * | GetImageManager () const
Call this method to retrieve the image manager.
CXTPPaintManager * | GetPaintManager () const
Call this method to retrieve the paint manager.
virtual CXTPImageManagerIcon * | GetImage (int nWidth=16) const
Call this method to retrieve the image of the control.
void | AssignDocTemplate (UINT nIDResource)
Call this method to assign a document template to the control.
void | ExcludeDocTemplate (UINT nIDResource)
Call this method to exclude the document template from control.
BOOL | IsItemDefault () const
Call this method to check if a control is a default menu item.
void | SetItemDefault (BOOL bDefault)
Call this method to set a control to be a default menu item.
BOOL | IsTemporary () const
Call this method to determine if a control is temporary.
void | Reset ()
Call this member to reset the icon and caption of a control to its default settings before it was customized by the user.
void | SetPrompt (LPCTSTR lpszPrompt)
Call this member to load a string from a STRINGTABLE resource to set the tooltip and description of a control.
void | SetCustomIcon (HICON hIcon)
Call this member to set a custom icon to this control.
virtual void | DoPropExchange (CXTPPropExchange *pPX)
Either reads this object from or writes this object to an archive.
virtual void | OnUnderlineActivate ()
This method is called when the user activates the control using its underline.
virtual BOOL | GetPopuped () const
Call this member to get the control's pop-up state.
void | RedrawParent (BOOL bAnimate=TRUE)
This method is called to redraw the parent command bar.
LRESULT | NotifySite (UINT code)
This method is called to send message code to the parent site window.
LRESULT | NotifySite (UINT code, NMXTPCONTROL *pNM)
This method is called to send message code to the parent site window.
LRESULT | NotifySite (CWnd *pSite, UINT code, NMXTPCONTROL *pNM)
This method is called to send message code to the parent site window.
virtual void | SetAction (CXTPControlAction *pAction)
Call this method to manually assign an action for control.
CXTPControlAction * | GetAction () const
Call this method to retrieve an action associated with control.
virtual void | OnThemeChanged ()
This method is called when the paint manager theme is changed.
virtual void | SetWidth (int nWidth)
Call this member to set the width of the control.
virtual void | SetHeight (int nHeight)
Call this member to set the height of the control.
int | GetWidth () const
Call this member to get the width of the control.
int | GetHeight () const
Call this member to get the height of the control.
BOOL | HasDwmCompositedRect () const
This method is called to determine if control has a Vista DWM transparent area.
virtual CSize | GetButtonSize () const
Call this function to get the size of the command bar button.
virtual CSize | GetIconSize () const
Call this member function to get the size of a toolbar icon.
void | SetIconSize (CSize szIcon)
Call this member function to set the size of an icon for an individual control.
virtual void | Copy (CXTPControl *pControl, BOOL bRecursive=FALSE)
This method is called to copy the control.
virtual BOOL | IsCustomizeMovable () const
This method is called to determine if control can be repositioned in customize mode.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

CSize | GetSize (CDC *pDC)
This method is called to determine the size of the control.
void | Draw (CDC *pDC)
This method is called to draw the control.
void | OnMouseMove (CPoint point)
This member is called when the mouse cursor moves.
BOOL | OnSetSelected (int bSelected)
This method is called when the control becomes selected.
void | OnClick (BOOL bKeyboard=FALSE, CPoint pt=CPoint(0, 0))
This method is called when the user clicks the control.
void | OnExecute ()
This method is called when the control is executed.
void | OnLButtonUp (CPoint point)
This member is called when the user releases the left mouse button.
virtual INT_PTR | OnToolHitTest (CPoint point, TOOLINFO *pTI) const
The framework calls this member function to determine whether a point is in the bounding rectangle of the specified tool.
- Protected Member Functions inherited from CXTPControl
CXTPControl ()
Constructs a CXTPControl object.
virtual | ~CXTPControl ()
Destroys a CXTPControl object, handles cleanup and deallocation.
virtual BOOL | IsFocusable () const
This method is called to check if the control can accept focus.
void | SetIndex (int nIndex)
This method is called to assign the order of the control in the controls list.
void | SetExpanded (BOOL bExpanded)
This method is called to set the control's expanded state.
virtual BOOL | OnHookMouseWheel (UINT nFlags, short zDelta, CPoint point)
This method is called when the user rotates the mouse wheel.
virtual void | SetParent (CXTPCommandBar *pParent)
This method is called to assign a parent command bar object.
void | ScreenToClient (CPoint *point)
The ScreenToClient function converts the screen coordinates of a specified point on the screen.
void | ClickToolBarButton (CRect rcActiveRect=CRect(0, 0, 0, 0))
This helper method is called when the user clicks the toolbar's button.
virtual BOOL | OnSetPopup (BOOL bPopup)
This method is called to pop-up the control.
virtual void | OnLButtonDown (CPoint point)
This member is called when the user presses the left mouse button down.
virtual BOOL | OnRButtonDown (CPoint point)
This member is called when the user press the right mouse button.
virtual BOOL | OnRButtonUp (CPoint point)
This member is called when the user releases the right mouse button.
virtual BOOL | OnLButtonDblClk (CPoint point)
This member is called when the user double-clicks the left mouse button.
virtual void | OnMouseHover ()
Called after the mouse hovers over the control.
BOOL | IsCustomizeMode () const
Call this method to determine if command bars is in customize mode.
virtual void | CustomizeStartDrag (CPoint point)
This member is called when the user starts to drag the control in customize mode.
virtual BOOL | CustomizeStartResize (CPoint point)
This method is called when user starts to resize control in customize mode.
virtual void | OnCustomizeDragOver (CXTPControl *pDataObject, CPoint point, DROPEFFECT &dropEffect)
This member is called when the user moves the mouse over the control.
virtual BOOL | DoCustomDragOver (CXTPCommandBar *pCommandBar, CPoint point, DROPEFFECT &dropEffect)
The implementation may implement a custom drag over handling logic in this method.
virtual BOOL | IsCustomizeResizeAllow () const
This member checks if the user can resize the control.
virtual int | GetCustomizeMinWidth () const
Retrieves the available minimum width of control.
virtual int | GetCustomizeMinHeight () const
Retrieves available minimum height of the control.
void | OnCustomizeMouseMove (CPoint point)
This member is called when the mouse cursor moves in customized mode.
virtual void | OnIdleUpdate ()
This virtual method is called in idle-time processing.
virtual void | OnRemoved ()
This method is called when a control is removed from the parent controls collection.
virtual void | RestoreCommandBarList (CXTPCommandBarList *pCommandBarList)
This method is called from LoadCommandBars to restore controls and its child command bars.
virtual void | GenerateCommandBarList (DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam)
This method is called from SaveCommandBars to save all child command bars.
virtual void | OnActionChanged (int nProperty)
This method is called when an action property is changed.
virtual void | OnActionChanging (int nProperty)
This method is called when an action property is about to be changed.
virtual void | OnCaptionChanged ()
This method is called when the control's caption is changed.
BOOL | IsLayoutRTL () const
Determines if right-to-left (RTL) mode is set.
BOOL | IsLayoutChanged ()
Call this member to determine if the layout has changed (RTL to LTR or LTR to RLT).

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControl
static CXTPControl *AFX_CDECL | FromUI (CCmdUI *pCmdUI)
Call this member to retrieve CXTPControl from a CCmdUI structure.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Attributes inherited from CXTPControl
DWORD_PTR | m_nTag
Control tag.
int | m_nIndex
Index of the control.
int | m_nId
Identifier of the control.
int | m_nIconId
Identifier of the control's image.
int | m_nHelpId
Help identifier.
int | m_nCustomIconId
Identifier of the control's custom image.
BOOL | m_bWrap
TRUE if the control is wrapped.
BOOL | m_bBeginGroup
TRUE if the control starts new group.
BOOL | m_bEnabled
TRUE if the control is enabled.
BOOL | m_bChecked
TRUE if the control is checked.
BOOL | m_bSelected
TRUE if the control is selected.
BOOL | m_bPressed
TRUE if the control is pushed.
BOOL | m_bTemporary
TRUE if the control is temporary.
BOOL | m_bOnQuickAccess
TRUE if the control is a part of Quick Access panel.
CRect | m_rcRow
Bounding rectangle of the control's row.
CRect | m_rcControl
Bounding rectangle of the control.
DWORD | m_dwHideFlags
Hidden flags.
DWORD | m_dwFlags
Flags of the control.
CString | m_strCaption
Caption of the control.
CString | m_strCustomCaption
User-defined caption.
CString | m_strShortcutText
Shortcut text.
CString | m_strShortcutTextAuto
Shortcut text.
CString | m_strTooltipText
Tooltip text.
CString | m_strDescriptionText
Description text.
CString | m_strParameter
Parameter text.
CString | m_strKeyboardTip
Keyboard tip.
CXTPControls * | m_pControls
Parent control collection.
XTPControlType | m_controlType
Type of the control.
CXTPCommandBar * | m_pParent
The Parent command bar.
BOOL | m_bExpanded
TRUE if the control is expanded.
CString | m_strCategory
Category of the control.
BOOL | m_bDefaultItem
TRUE if the item is default pop-up item.
CDocTemplateMap | m_mapDocTemplatesAssigned
Assigned templates.
CDocTemplateMap | m_mapDocTemplatesExcluded
Excluded templates.
XTPButtonStyle | m_buttonStyle
Button Style.
XTPButtonStyle | m_buttonCustomStyle
User-defined style of button.
XTPButtonStyle | m_buttonRibbonStyle
User-defined style of button.
BOOL | m_bCloseSubMenuOnClick
TRUE is sub-menus are closed as soon as a control is clicked.
CXTPRibbonGroup * | m_pRibbonGroup
Ribbon group of control.
CXTPControlAction * | m_pAction
Action of the control.
int | m_nWidth
Width of the control.
int | m_nHeight
Height of the control.
int | m_nExecuteOnPressInterval
Delay between each message when control is pressed.
CSize | m_szIcon
The size of the icon used for the control.
BOOL | m_bLayoutRTL
Indicate does last layout is RTL.

Detailed Description

CXTPControlColorSelector is a CXTPControl derived class.

It represents a color selector control.

Member Function Documentation

◆ Draw()

void Draw ( CDC * pDC )
protectedvirtual

This method is called to draw the control.

Parameters
pDC Pointer to a valid device context.

Reimplemented from CXTPControl.

◆ GetColor()

COLORREF GetColor ( ) const

Call this member to retrieve the color of the selector control.

Returns
Color of the selector.

◆ GetSize()

CSize GetSize ( CDC * pDC )
protectedvirtual

This method is called to determine the size of the control.

Parameters
pDC Pointer to a valid device context.
Returns
A CSize object containing the size of the control.

Reimplemented from CXTPControl.

◆ OnClick()

void OnClick | ( | BOOL | bKeyboard = FALSE,
 |  | CPoint | pt = CPoint(0, 0) )
 protectedvirtual

This method is called when the user clicks the control.

Parameters
bKeyboard | TRUE if the control is selected using the keyboard.
pt | Mouse cursor position.

Reimplemented from CXTPControl.

◆ OnLButtonUp()

void OnLButtonUp ( CPoint point )
protectedvirtual

This member is called when the user releases the left mouse button.

Parameters
point Specifies the x- and y- coordinates of the cursor.

Reimplemented from CXTPControl.

◆ OnMouseMove()

void OnMouseMove ( CPoint point )
protectedvirtual

This member is called when the mouse cursor moves.

Parameters
point Specifies the x- and y- coordinates of the cursor.

Reimplemented from CXTPControl.

◆ OnSetSelected()

BOOL OnSetSelected ( int bSelected )
protectedvirtual

This method is called when the control becomes selected.

Parameters
bSelected TRUE if the control becomes selected.
Returns
TRUE if successful, otherwise FALSE.

Reimplemented from CXTPControl.

◆ OnToolHitTest()

virtual INT_PTR OnToolHitTest | ( | CPoint | point,
 |  | TOOLINFO * | pTI ) const
 protectedvirtual

The framework calls this member function to determine whether a point is in the bounding rectangle of the specified tool.

Parameters
point | Specifies the x- and y- coordinates of the cursor. These coordinates are always relative to the upper-left corner of the window.
pTI | A pointer to a TOOLINFO structure.
Returns
If the tooltip control was found, then the window control ID is returned. If the tooltip control was not found, then a value of -1 is returned.

Reimplemented from CXTPControl.

◆ SetColor()

void SetColor ( COLORREF clr )

Call this method to set the color of the control.

Parameters
clr Color to set.
The documentation for this class was generated from the following file:
  • XTPControlPopupColor.h


Toolkit Pro: CXTPControlComboBox Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPControlComboBox Class Reference

CXTPControlComboBox is a CXTPControl derived class. More...

Inheritance diagram for CXTPControlComboBox:
[legend]

Public Member Functions

CXTPControlComboBox (CXTPCommandBars *pCommandBars=NULL)
Constructs a CXTPControlComboBox object.
virtual | ~CXTPControlComboBox ()
Destroys a CXTPControlComboBox object, handles cleanup and deallocation.
DWORD | GetEditStyle () const
Call this member to get the style of edit control.
void | SetEditStyle (DWORD dwStyle)
Call this member to set the style of edit control.
void | SetDropDownListStyle (BOOL bSet=TRUE)
Call this member to insert/delete an edit box in the combobox when the control has focus.
BOOL | GetDropDownListStyle () const
Call this member to determine if the combobox has an edit control.
void | SetDropDownWidth (int nWidth)
Call this member to set the width of the dropdown list.
void | SetDropDownItemCount (int nDropDownItemCount)
Call this member to set the count of items in the dropdown list.
int | GetDropDownWidth () const
Call this member to retrieve the dropdown list width.
int | AddString (LPCTSTR lpsz)
Call this member function to add a string to a list box.
int | GetCount () const
Call this member to retrieve the number of items in a list box.
void | GetLBText (int nIndex, CString &str) const
Call this member to retrieve a string from the list box of a combobox control.
void | ResetContent ()
Call this member to remove all items from the list box of a combobox control.
int | FindStringExact (int nIndexStart, LPCTSTR lpsz) const
Call this member to find the first list-box string (in a combobox) that matches the string specified in str.
int | InsertString (int nIndex, LPCTSTR lpsz)
Call this member to insert a string into the list box of a combobox control.
virtual CString | GetListBoxText () const
Call this member to get the currently selected item's text.
CXTPControlComboBoxEditCtrl * | GetEditCtrl () const
Call this member to get the edit control of the combobox control.
void | SetCurSel (int nIndex)
Call this member to select a string in the list box of a combobox.
int | GetCurSel () const
Call this member function to determine which item in the combobox is selected.
BOOL | GetDroppedState () const
Call the GetDroppedState member function to determine whether the list box of a drop-down combobox is visible (dropped down).
CString | GetEditText () const
Call this member to get the edit text.
void | ModifyListBoxStyle (DWORD dwRemove, DWORD dwAdd)
Call this member to modify the style of a list box.
void | SetEditText (const CString &lpszText)
Call this member to set the edit control text.
void | SetEditHint (LPCTSTR lpszEditHint)
Call this member to set the grayed-out text displayed in the edit control which provides a helpful description of what the control is used for.
CString | GetEditHint () const
Call this member to get the grayed-out text displayed in the edit control which provides a helpful description of what the control is used for.
virtual CHARFORMAT2 | GetDefaultCharFormat ()
This method is called to get the default char format of rich edit text.
void | EnableShellAutoComplete (DWORD dwFlags=SHACF_FILESYSTEM|SHACF_URLALL)
This member function enables or disables shell auto completion.
void | EnableAutoComplete (BOOL bAutoComplete=TRUE)
This member function enables or disables auto completion.
int | FindString (int nStartAfter, LPCTSTR lpszItem) const
This method finds the first string in a list box that contains the specified prefix, without changing the list-box selection.
DWORD_PTR | GetItemData (int nIndex) const
This method retrieves the application-supplied, 32-bit value associated with the specified combobox item.
int | SetItemData (int nIndex, DWORD_PTR dwItemData)
This method sets the 32-bit value associated with the specified item in a combobox.
void | DeleteItem (long nIndex)
Call this member function to delete a string.
void | OnEnabledChanged ()
This method is called when the control's enabled state is changed.
void | DoPropExchange (CXTPPropExchange *pPX)
Either reads this object from or writes this object to an archive.
virtual BOOL | Compare (CXTPControl *pOther)
Call this member to compare controls.
int | GetLabelWidth () const
Call this method to get the width of a label.
void | SetLabelWidth (int nLabelWidth)
Call this method to set the width of a label.
virtual BOOL | IsCaptionVisible () const
Call this member to determine if the caption of the control is visible.
BOOL | IsImageVisible () const
Call this member to determine if the icon is visible for a combobox control.
int | GetThumbWidth () const
Call this method to get the width of a thumb button.
void | SetThumbWidth (int nThumbWidth)
This method is called to set the width of a thumb button.
BOOL | HasFocus () const
Call this method to determine if control has focus.
virtual void | DrawEditText (CDC *pDC, CRect rcText)
This method draws the text of control if the style is CBS_DROPDOWNLIST.
CListBox * | GetListBoxCtrl () const
CXTPControlComboBoxPopupBar * | GetComboBoxPopupBar () const
void | SetEditIconId (int nId)
Call this member to set the edit icon's identifier.
int | GetEditIconId () const
Call this member to get the edit icon's identifier.
void | SetListIconId (int nId)
Call this member to set the combo list icon's identifier.
int | GetListIconId () const
Call this member to get the combo list icon's identifier.
virtual void | SetFocused (BOOL bFocused)
Call this member to set focus to the control.
virtual BOOL | IsFocused () const
Call this member to get the focused state of the control.
virtual void | OnEditChanged ()
This method is called when edit control's text is changed.
virtual void | OnSelChanged ()
This method is called when the selected string is changed.
virtual void | OnExecute ()
This method is called when the control is executed.
virtual void | SetHideFlags (DWORD dwFlags)
This method is called to hide the control.
virtual void | OnActionChanged (int nProperty)
This method is called when an action property is changed.
virtual void | OnActionChanging (int nProperty)
This method is called when an action property is about to be changed.
void | SetTextLimit (int nTextLimit)
This method sets the maximum text length that the user may enter into an edit control.
int | GetTextLimit () const
This method gets the maximum text length that the user may enter into an edit control.
- Public Member Functions inherited from CXTPControlPopup
CXTPControlPopup ()
Constructs a CXTPControlPopup object.
virtual | ~CXTPControlPopup ()
Destroys a CXTPControlPopup object, handles cleanup and deallocation.
void | SetCommandBar (CMenu *pMenu)
Call this member to set the child command bar.
void | SetCommandBar (CXTPCommandBar *pBar)
Call this member to set the child command bar.
CXTPCommandBar * | GetCommandBar () const
Call this member to get the child command bar.
BOOL | GetPopuped () const
Call this member to get the control's pop-up state.
virtual CString | GetCaption () const
Call this member to get the control's caption.
void | DoPropExchange (CXTPPropExchange *pPX)
Either reads this object from or writes this object to an archive.
virtual void | AdjustExcludeRect (CRect &rc, BOOL bVertical)
Updates rectangle to set the position where the child pop-up bar becomes visible.
void | Copy (CXTPControl *pControl, BOOL bRecursive=FALSE)
This method is called to copy the control.
- Public Member Functions inherited from CXTPControlButton
CXTPControlButton ()
Constructs a CXTPControlButton object.
virtual | ~CXTPControlButton ()
Destroys a CXTPControlButton object, handles cleanup and deallocation.
void | SetStyleEx (XTPButtonStyle buttonStyle)
Call this member to set the style of the button containing vector icon.
XTPButtonStyle | GetStyleEx () const
Call this member to get the button's style containing vector icon.
- Public Member Functions inherited from CXTPControl
void | SetStyle (XTPButtonStyle buttonStyle)
Call this member to set the style of the control.
XTPButtonStyle | GetStyle () const
Call this member to get the control's style.
void | SetCaption (LPCTSTR lpszCaption)
Call this member to set the caption of the control.
void | SetCaption (UINT nIDCaption)
Call this member to set the caption of the control.
void | SetShortcutText (LPCTSTR lpszShortcutText)
Call this member to set the shortcut string to the control.
CString | GetShortcutText () const
Call this member to get the control's shortcut.
void | SetDescription (LPCTSTR lpszDescription)
Call this member to set the description of the control.
virtual CString | GetDescription () const
Call this member to get the control's description.
void | SetTooltip (LPCTSTR lpszTooltip)
Call this member to set the tooltip of the control.
virtual CString | GetTooltip () const
Call this member to get the control's tooltip.
void | SetKeyboardTip (LPCTSTR lpszKeyboardTip)
Call this member to set the keyboard tip to the control.
CString | GetKeyboardTip () const
Call this member to get the keyboard tip.
void | SetCustomShortcutText (LPCTSTR lpszCustomShortcutText)
Call this member to set the text displayed for the shortcut in a pop-up menu.
CString | GetCustomShortcutText () const
Call this member to get the control's text displayed for the shortcut in a pop-up menu.
void | SetParameter (LPCTSTR lpszParameter)
Call this member to set the parameter of the control.
CString | GetParameter () const
Call this member to get the control's parameter.
void | SetID (int nId)
Call this member to set the identifier of the control.
int | GetID () const
Call this member to get the control's identifier.
long | GetIndex () const
Call this member to get the index of the control.
void | SetIconId (int nId)
Call this member to set the control icon's identifier.
int | GetIconId () const
Call this member to get the icon's identifier.
void | SetHelpId (int nId)
Call this member to set the control help identifier.
int | GetHelpId () const
Call this member to get the help identifier.
virtual void | SetBeginGroup (BOOL bBeginGroup)
Call this member to begin a new group using a separator.
BOOL | GetBeginGroup () const
Call this member to determine if the control has a separator.
virtual void | SetEnabled (BOOL bEnabled)
Call this member to enable/disable the control.
BOOL | GetEnabled () const
Call this member to check if the control is enabled.
virtual void | SetChecked (BOOL bChecked)
Call this member to set the checked state of the control.
BOOL | GetChecked () const
Call this member to get the checked state of the control.
virtual int | GetSelected () const
Call this member to check if the control is selected.
void | SetOnQuickAccess (BOOL bOnQuicAccess=FALSE)
Call this member to set whether a control should be a part of the Quick Access panel.
BOOL | IsOnQuickAccess () const
Call this member to check if a control is a part of the Quick Access panel.
void | SetPressed (BOOL bPressed)
Call this member to set the pressed state of the control.
virtual BOOL | GetPressed () const
Call this member to check the pressed state of the control.
CRect | GetRect () const
Call this member to get the bounding rectangle of the control.
CXTPCommandBar * | GetParent () const
Call this member to get the parent command bar.
virtual BOOL | IsVisible (DWORD dwSkipFlags=0) const
Call this member to determine if the control is visible.
void | SetVisible (BOOL bVisible)
Call this member to set the visibility of the control.
CXTPControls * | GetControls () const
Call this member to get the parent controls collection.
XTPControlType | GetType () const
Call this member to get the control's type.
void | SetFlags (DWORD dwFlags)
Call this member to set the flags of the control.
DWORD | GetFlags () const
Call this member to retrieve control special flags.
void | SetTag (DWORD_PTR dwTag)
This method sets the 32-bit value associated with the control.
DWORD_PTR | GetTag () const
This method retrieves the application-supplied, 32-bit value associated with the control.
void | SetCloseSubMenuOnClick (BOOL bCloseOnClick)
Call this member function to enable/disable the closing of sub-menus when a control is clicked in the menu.
BOOL | GetCloseSubMenuOnClick () const
Call this member function to check if sub-menus will close as soon as a control is clicked.
void | SetExecuteOnPressInterval (int nExecuteOnPressInterval)
Call this method to set the delay (in milliseconds) between WM_COMMAND messages while a button is pressed by the user.
int | GetExecuteOnPressInterval () const
Call this method to get the delay (in milliseconds) between WM_COMMAND messages while a button is pressed by the user.
CXTPRibbonGroup * | GetRibbonGroup () const
Returns the ribbon group that the control belongs to.
virtual BOOL | IsTransparent () const
Determines if the control needs to draw its background.
void | SetHideWrap (BOOL bHide)
This method is called to hide the control.
BOOL | SetHideFlag (XTPControlHideFlags dwFlag, BOOL bSet)
Call this member to set/remove hide flags.
DWORD | GetHideFlags () const
Call this method to retrieve hidden flags.
CRect | GetRowRect () const
Call this method to retrieve the position of the control's row.
BOOL | GetWrap () const
Call this method to check if the control is wrapped.
void | SetRowRect (CRect rcRow)
Call this method to set the row of the control.
void | SetWrap (BOOL bWrap)
Call this member to set the control to wrapped.
BOOL | GetExpanded () const
Call this member to check if the control is expanded.
BOOL | IsCursorOver () const
Call this member to determine if the mouse pointer is over the control.
virtual CSize | GetSize (CDC *pDC)
This method is called to determine the size of the control.
virtual void | Draw (CDC *pDC)
This method is called to draw the control.
void | DelayRedrawParent ()
Call this method to redraw the parent command bar.
void | DelayLayoutParent ()
Call this method to recalculate the parent command bar size.
void | SetCategory (LPCTSTR lpszCategory)
Call this method to set the category of the control.
CString | GetCategory () const
Call this method to retrieve the category of the control.
CXTPImageManager * | GetImageManager () const
Call this method to retrieve the image manager.
CXTPPaintManager * | GetPaintManager () const
Call this method to retrieve the paint manager.
virtual CXTPImageManagerIcon * | GetImage (int nWidth=16) const
Call this method to retrieve the image of the control.
void | AssignDocTemplate (UINT nIDResource)
Call this method to assign a document template to the control.
void | ExcludeDocTemplate (UINT nIDResource)
Call this method to exclude the document template from control.
BOOL | IsItemDefault () const
Call this method to check if a control is a default menu item.
void | SetItemDefault (BOOL bDefault)
Call this method to set a control to be a default menu item.
BOOL | IsTemporary () const
Call this method to determine if a control is temporary.
void | Reset ()
Call this member to reset the icon and caption of a control to its default settings before it was customized by the user.
void | SetPrompt (LPCTSTR lpszPrompt)
Call this member to load a string from a STRINGTABLE resource to set the tooltip and description of a control.
void | SetCustomIcon (HICON hIcon)
Call this member to set a custom icon to this control.
void | RedrawParent (BOOL bAnimate=TRUE)
This method is called to redraw the parent command bar.
LRESULT | NotifySite (UINT code)
This method is called to send message code to the parent site window.
LRESULT | NotifySite (UINT code, NMXTPCONTROL *pNM)
This method is called to send message code to the parent site window.
LRESULT | NotifySite (CWnd *pSite, UINT code, NMXTPCONTROL *pNM)
This method is called to send message code to the parent site window.
virtual void | SetAction (CXTPControlAction *pAction)
Call this method to manually assign an action for control.
CXTPControlAction * | GetAction () const
Call this method to retrieve an action associated with control.
virtual void | OnThemeChanged ()
This method is called when the paint manager theme is changed.
virtual void | SetWidth (int nWidth)
Call this member to set the width of the control.
virtual void | SetHeight (int nHeight)
Call this member to set the height of the control.
int | GetWidth () const
Call this member to get the width of the control.
int | GetHeight () const
Call this member to get the height of the control.
BOOL | HasDwmCompositedRect () const
This method is called to determine if control has a Vista DWM transparent area.
virtual CSize | GetButtonSize () const
Call this function to get the size of the command bar button.
virtual CSize | GetIconSize () const
Call this member function to get the size of a toolbar icon.
void | SetIconSize (CSize szIcon)
Call this member function to set the size of an icon for an individual control.
virtual BOOL | IsCustomizeMovable () const
This method is called to determine if control can be repositioned in customize mode.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

virtual BOOL | IsFocusable () const
This method is called to check if a control can accept focus.
virtual CXTPControlComboBoxEditCtrl * | CreateEditControl ()
This method creates an edit control.
void | OnMouseHover ()
Called after the mouse hovers over the control.
virtual void | OnSetFocus (CWnd *pOldWnd)
This method is called when the edit control gets focus.
virtual void | OnKillFocus ()
This method is called when the edit control loses focus.
virtual void | DeflateEditRect (CRect &rcControl)
This method is called to get the real rect of an edit control of a combobox.
BOOL | OnSetSelected (int bSelected)
This method is called when the control becomes selected.
void | SetRect (CRect rcControl)
Call this member to set the bounding rectangle of the control.
void | OnClick (BOOL bKeyboard=FALSE, CPoint pt=CPoint(0, 0))
This method is called when the user clicks the control.
virtual void | OnUnderlineActivate ()
This method is called when the user activates a control using its underline.
void | Copy (CXTPControl *pControl, BOOL bRecursive=FALSE)
This method is called to copy the control.
BOOL | OnHookKeyDown (UINT nChar, LPARAM lParam)
This method is called when a non-system key is pressed.
void | SetParent (CXTPCommandBar *pParent)
This method is called to assign a parent command bar object.
virtual void | OnCalcDynamicSize (DWORD dwMode)
This method is called before recalculating the parent command bar size to calculate the dimensions of the control.
virtual BOOL | OnSetPopup (BOOL bPopup)
This method is called to pop-up the control.
virtual BOOL | IsCustomizeResizeAllow () const
This member checks if the user can resize the control.
virtual int | GetCustomizeMinWidth () const
This member returns the minimum width that the combobox can be sized to by the user while in customization mode.
virtual void | OnRemoved ()
This method is called when a control is removed from the parent controls collection.
virtual void | OnMouseMove (CPoint point)
This member is called when the mouse cursor moves.
- Protected Member Functions inherited from CXTPControlPopup
BOOL | ContainsPopup (CXTPControlPopup *pControlPopup)
This method is called to check if pControlPopup contains in the control recursively.
void | ExpandCommandBar ()
Call this member to expand the parent pop-up bar.
BOOL | OnSetSelected (int bSelected)
This method is called when the control becomes selected.
void | OnClick (BOOL bKeyboard=FALSE, CPoint pt=CPoint(0, 0))
This method is called when the user clicks the control.
void | OnMouseHover ()
This method is called after the mouse hovers over the control.
virtual void | OnLButtonUp (CPoint point)
This member is called when the user releases the left mouse button.
virtual BOOL | OnLButtonDblClk (CPoint point)
This member is called when the user double-clicks the left mouse button.
void | OnCustomizeDragOver (CXTPControl *pDataObject, CPoint point, DROPEFFECT &dropEffect)
This method is called when the user moves the mouse over the control.
virtual BOOL | DoCustomDragOver (CXTPCommandBar *pCommandBar, CPoint point, DROPEFFECT &dropEffect)
The implementation may implement a custom drag over handling logic in this method.
virtual void | UpdateShadow ()
Call this member to update the shadow of the control.
virtual void | RestoreCommandBarList (CXTPCommandBarList *pCommandBarList)
This method is called from LoadCommandBars to restore controls and its child command bars.
- Protected Member Functions inherited from CXTPControlButton
- Protected Member Functions inherited from CXTPControl
CXTPControl ()
Constructs a CXTPControl object.
virtual | ~CXTPControl ()
Destroys a CXTPControl object, handles cleanup and deallocation.
void | SetIndex (int nIndex)
This method is called to assign the order of the control in the controls list.
void | SetExpanded (BOOL bExpanded)
This method is called to set the control's expanded state.
virtual BOOL | OnHookMouseWheel (UINT nFlags, short zDelta, CPoint point)
This method is called when the user rotates the mouse wheel.
void | ScreenToClient (CPoint *point)
The ScreenToClient function converts the screen coordinates of a specified point on the screen.
void | ClickToolBarButton (CRect rcActiveRect=CRect(0, 0, 0, 0))
This helper method is called when the user clicks the toolbar's button.
virtual void | OnLButtonDown (CPoint point)
This member is called when the user presses the left mouse button down.
virtual BOOL | OnRButtonDown (CPoint point)
This member is called when the user press the right mouse button.
virtual BOOL | OnRButtonUp (CPoint point)
This member is called when the user releases the right mouse button.
BOOL | IsCustomizeMode () const
Call this method to determine if command bars is in customize mode.
virtual void | CustomizeStartDrag (CPoint point)
This member is called when the user starts to drag the control in customize mode.
virtual BOOL | CustomizeStartResize (CPoint point)
This method is called when user starts to resize control in customize mode.
virtual int | GetCustomizeMinHeight () const
Retrieves available minimum height of the control.
void | OnCustomizeMouseMove (CPoint point)
This member is called when the mouse cursor moves in customized mode.
virtual void | OnIdleUpdate ()
This virtual method is called in idle-time processing.
virtual INT_PTR | OnToolHitTest (CPoint point, TOOLINFO *pTI) const
The framework calls this member function to determine whether a point is in the bounding rectangle of the specified tool.
virtual void | GenerateCommandBarList (DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam)
This method is called from SaveCommandBars to save all child command bars.
virtual void | OnCaptionChanged ()
This method is called when the control's caption is changed.
BOOL | IsLayoutRTL () const
Determines if right-to-left (RTL) mode is set.
BOOL | IsLayoutChanged ()
Call this member to determine if the layout has changed (RTL to LTR or LTR to RLT).

Protected Attributes

CXTPControlComboBoxEditCtrl * | m_pEdit
Child edit control.
BOOL | m_bDropDown
TRUE if the combo is dropdown.
XTPButtonStyle | m_comboStyle
Style of the combobox.
int | m_nLastSel
Last user selected index (used during display of list box).
CString | m_strLastText
Last Text before user select focus and change it.
BOOL | m_bDelayDestroy
TRUE if need to recreate control.
BOOL | m_bDelayReposition
Need to reposition control.
int | m_nLabelWidth
Width of the label.
int | m_nThumbWidth
Width of the thumb area.
CString | m_strEditHint
Grayed-out text displayed in the edit control that displayed a helpful description.
BOOL | m_bAutoComplete
TRUE if Auto Complete is enabled.
BOOL | m_bIgnoreAutoComplete
TRUE to disable auto complete till next key event.
DWORD | m_dwShellAutoCompleteFlags
Shell auto complete flags.
BOOL | m_bFocused
TRUE if control is focused.
int | m_nEditIconId
Edit Icon identifier.
BOOL | m_bSelEndOk
TRUE if user selects a list item.
int | m_nDropDownItemCount
Maximum drop down items.
CString | m_strEditText
Edit text.
BOOL | m_bEditChanged
TRUE if Edit Text is changed.
int | m_nTextLimit
The maximum number of characters that can be entered into an edit control.
CXTPControlComboBoxAutoCompleteWnd * | m_pAutoCompleteWnd
Auto Complete hook window.
DWORD | m_dwEditStyle
Edit style.
- Protected Attributes inherited from CXTPControlPopup
BOOL | m_bPopup
TRUE if pop-up'ed.
CXTPCommandBar * | m_pCommandBar
Child pop-up bar.
DWORD | m_dwCommandBarID
Child pop-up ID.
BOOL | m_bShowShadow
TRUE to show shadow.
- Protected Attributes inherited from CXTPControlButton
XTPButtonStyle | m_buttonStyleEx
User-defined style of button containing vector icon.
- Protected Attributes inherited from CXTPControl
DWORD_PTR | m_nTag
Control tag.
int | m_nIndex
Index of the control.
int | m_nId
Identifier of the control.
int | m_nIconId
Identifier of the control's image.
int | m_nHelpId
Help identifier.
int | m_nCustomIconId
Identifier of the control's custom image.
BOOL | m_bWrap
TRUE if the control is wrapped.
BOOL | m_bBeginGroup
TRUE if the control starts new group.
BOOL | m_bEnabled
TRUE if the control is enabled.
BOOL | m_bChecked
TRUE if the control is checked.
BOOL | m_bSelected
TRUE if the control is selected.
BOOL | m_bPressed
TRUE if the control is pushed.
BOOL | m_bTemporary
TRUE if the control is temporary.
BOOL | m_bOnQuickAccess
TRUE if the control is a part of Quick Access panel.
CRect | m_rcRow
Bounding rectangle of the control's row.
CRect | m_rcControl
Bounding rectangle of the control.
DWORD | m_dwHideFlags
Hidden flags.
DWORD | m_dwFlags
Flags of the control.
CString | m_strCaption
Caption of the control.
CString | m_strCustomCaption
User-defined caption.
CString | m_strShortcutText
Shortcut text.
CString | m_strShortcutTextAuto
Shortcut text.
CString | m_strTooltipText
Tooltip text.
CString | m_strDescriptionText
Description text.
CString | m_strParameter
Parameter text.
CString | m_strKeyboardTip
Keyboard tip.
CXTPControls * | m_pControls
Parent control collection.
XTPControlType | m_controlType
Type of the control.
CXTPCommandBar * | m_pParent
The Parent command bar.
BOOL | m_bExpanded
TRUE if the control is expanded.
CString | m_strCategory
Category of the control.
BOOL | m_bDefaultItem
TRUE if the item is default pop-up item.
CDocTemplateMap | m_mapDocTemplatesAssigned
Assigned templates.
CDocTemplateMap | m_mapDocTemplatesExcluded
Excluded templates.
XTPButtonStyle | m_buttonStyle
Button Style.
XTPButtonStyle | m_buttonCustomStyle
User-defined style of button.
XTPButtonStyle | m_buttonRibbonStyle
User-defined style of button.
BOOL | m_bCloseSubMenuOnClick
TRUE is sub-menus are closed as soon as a control is clicked.
CXTPRibbonGroup * | m_pRibbonGroup
Ribbon group of control.
CXTPControlAction * | m_pAction
Action of the control.
int | m_nWidth
Width of the control.
int | m_nHeight
Height of the control.
int | m_nExecuteOnPressInterval
Delay between each message when control is pressed.
CSize | m_szIcon
The size of the icon used for the control.
BOOL | m_bLayoutRTL
Indicate does last layout is RTL.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlPopup
static CXTPControlPopup *AFX_CDECL | CreateControlPopup (XTPControlType controlType)
Creates a CXTPControlPopup object with the specified type.
- Static Public Member Functions inherited from CXTPControl
static CXTPControl *AFX_CDECL | FromUI (CCmdUI *pCmdUI)
Call this member to retrieve CXTPControl from a CCmdUI structure.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

CXTPControlComboBox is a CXTPControl derived class.

It represents a combobox control.

Constructor & Destructor Documentation

◆ CXTPControlComboBox()

CXTPControlComboBox ( CXTPCommandBars * pCommandBars = NULL )

Constructs a CXTPControlComboBox object.

Parameters
pCommandBars Pointer to parent CommandBars class.

Member Function Documentation

◆ AddString()

AFX_INLINE int AddString ( LPCTSTR lpsz )

Call this member function to add a string to a list box.

Parameters
lpsz The string that is to be added.
Returns
The zero-based index of the string in the list box. The return value is LB_ERR if an error occurs.

◆ Compare()

virtual BOOL Compare ( CXTPControl * pOther )
virtual

Call this member to compare controls.

Parameters
pOther The control to compare with.
Returns
TRUE if the controls are identical, otherwise FALSE.

Reimplemented from CXTPControlPopup.

◆ Copy()

void Copy | ( | CXTPControl * | pControl,
 |  | BOOL | bRecursive = FALSE )
 protectedvirtual

This method is called to copy the control.

Parameters
pControl | Pointer to a source CXTPControl object.
bRecursive | TRUE to copy recursively.

Reimplemented from CXTPControlButton.

◆ CreateEditControl()

virtual CXTPControlComboBoxEditCtrl * CreateEditControl ( )
protectedvirtual

This method creates an edit control.

Override it to use inherited edit control.

Returns
Creates an edit control

◆ DeflateEditRect()

virtual void DeflateEditRect ( CRect & rcControl )
protectedvirtual

This method is called to get the real rect of an edit control of a combobox.

Parameters
rcControl Rectangle of combobox area.

◆ DeleteItem()

void DeleteItem ( long nIndex )

Call this member function to delete a string.

Parameters
nIndex Contains a zero-based index of the item to delete.

◆ DoPropExchange()

void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Either reads this object from or writes this object to an archive.

Parameters
pPX A CXTPPropExchange object to serialize to or from.

Reimplemented from CXTPControlButton.

◆ DrawEditText()

virtual void DrawEditText | ( | CDC * | pDC,
 |  | CRect | rcText )
 virtual

This method draws the text of control if the style is CBS_DROPDOWNLIST.

Parameters
pDC | Pointer to a valid device context.
rcText | Rectangle to draw.

◆ EnableAutoComplete()

void EnableAutoComplete ( BOOL bAutoComplete = TRUE )

This member function enables or disables auto completion.

Parameters
bAutoComplete TRUE to enable auto completion, otherwise FALSE.

◆ EnableShellAutoComplete()

void EnableShellAutoComplete ( DWORD dwFlags = SHACF_FILESYSTEM|SHACF_URLALL )

This member function enables or disables shell auto completion.

Parameters
dwFlags Flags that will be passed to SHAutoComplete function.

Flags can be combined by using the bitwise OR (|) operator. It can be one or more of the following: SHACF_FILESYSTEM: This includes the File System as well as the rest of the shell (Desktop/My Computer/Control Panel/). SHACF_URLALL: Include the URL's in the users History and Recently Used lists. Equivalent to SHACF_URLHISTORY | SHACF_URLMRU. HACF_URLHISTORY: URLs in the User's History. SHACF_URLMRU: URLs in the User's Recently Used list. SHACF_FILESYS_ONLY: Include only the file system. Do not include virtual folders such as Desktop or Control Panel.

◆ FindString()

AFX_INLINE int FindString | ( | int | nStartAfter,
 |  | LPCTSTR | lpszItem ) const

This method finds the first string in a list box that contains the specified prefix, without changing the list-box selection.

Parameters
nStartAfter | Contains the zero-based index of the item before the first item to be searched. When the search reaches the bottom of the list box, it continues from the top of the list box back to the item specified by nStartAfter. If nStartAfter is -1, the entire list box is searched from the beginning.
lpszItem | Points to the null-terminated string that contains the prefix to search for. The search is case independent, so this string may contain any combination of uppercase and lowercase letters.
Returns
The zero-based index of the matching item, or LB_ERR if the search was unsuccessful.
See also
FindStringExact

◆ FindStringExact()

AFX_INLINE int FindStringExact | ( | int | nIndexStart,
 |  | LPCTSTR | lpsz ) const

Call this member to find the first list-box string (in a combobox) that matches the string specified in str.

Parameters
nIndexStart | Specifies the zero-based index of the item before the first item to be searched.
lpsz | The string to search for.
Returns
The zero-based index of the matching item, or CB_ERR if the search was unsuccessful.
See also
FindString

◆ GetComboBoxPopupBar()

CXTPControlComboBoxPopupBar * GetComboBoxPopupBar ( ) const
Returns
Returns child pop-up bar.

◆ GetCount()

AFX_INLINE int GetCount ( ) const

Call this member to retrieve the number of items in a list box.

Returns
The number of items in the list box, or LB_ERR if an error occurs.

◆ GetCurSel()

int GetCurSel ( ) const

Call this member function to determine which item in the combobox is selected.

Returns
The zero-based index of the currently selected item in the list box of a combobox, or CB_ERR if no item is selected.

◆ GetCustomizeMinWidth()

virtual int GetCustomizeMinWidth ( ) const
protectedvirtual

This member returns the minimum width that the combobox can be sized to by the user while in customization mode.

Returns
Width of label + Width of Dropdown button + 5

Reimplemented from CXTPControl.

◆ GetDefaultCharFormat()

virtual CHARFORMAT2 GetDefaultCharFormat ( )
virtual

This method is called to get the default char format of rich edit text.

Returns
Returns default char format of rich edit text

◆ GetDropDownListStyle()

BOOL GetDropDownListStyle ( ) const

Call this member to determine if the combobox has an edit control.

Returns
TRUE if the combobox has an edit control, otherwise FALSE.
See also
SetDropDownListStyle

◆ GetDropDownWidth()

int GetDropDownWidth ( ) const

Call this member to retrieve the dropdown list width.

Returns
Width of the dropdown list.

◆ GetDroppedState()

BOOL GetDroppedState ( ) const

Call the GetDroppedState member function to determine whether the list box of a drop-down combobox is visible (dropped down).

Returns
Nonzero if the list box is visible; otherwise 0.

◆ GetEditCtrl()

AFX_INLINE CXTPControlComboBoxEditCtrl * GetEditCtrl ( ) const

Call this member to get the edit control of the combobox control.

Returns
A pointer to the CEdit control.

◆ GetEditHint()

CString GetEditHint ( ) const

Call this member to get the grayed-out text displayed in the edit control which provides a helpful description of what the control is used for.

Returns
Edit hint of the control
See also
SetEditHint

◆ GetEditIconId()

AFX_INLINE int GetEditIconId ( ) const

Call this member to get the edit icon's identifier.

Returns
Edit icon's identifier.

◆ GetEditStyle()

DWORD GetEditStyle ( ) const

Call this member to get the style of edit control.

Returns
The style of edit control.
See also
SetEditStyle

◆ GetEditText()

CString GetEditText ( ) const

Call this member to get the edit text.

Returns
The Edit control text.

◆ GetItemData()

AFX_INLINE DWORD_PTR GetItemData ( int nIndex ) const

This method retrieves the application-supplied, 32-bit value associated with the specified combobox item.

Parameters
nIndex Contains the zero-based index of an item in the combobox's list box.
Returns
The 32-bit value associated with the item, or CB_ERR if an error occurs.

◆ GetLabelWidth()

AFX_INLINE int GetLabelWidth ( ) const

Call this method to get the width of a label.

Returns
Width of the label.
See also
SetLabelWidth, SetStyle, GetStyle

◆ GetLBText()

AFX_INLINE void GetLBText | ( | int | nIndex,
 |  | CString & | str ) const

Call this member to retrieve a string from the list box of a combobox control.

Parameters
nIndex | Contains the zero-based index of the list-box string to be copied.
str | A reference to a CString.

◆ GetListBoxCtrl()

CListBox * GetListBoxCtrl ( ) const
Returns
Retrieves list box window.

◆ GetListBoxText()

virtual CString GetListBoxText ( ) const
virtual

Call this member to get the currently selected item's text.

Returns
The text that is currently selected.

◆ GetListIconId()

int GetListIconId ( ) const

Call this member to get the combo list icon's identifier.

Returns
Combo list icon's identifier.

◆ GetTextLimit()

int GetTextLimit ( ) const

This method gets the maximum text length that the user may enter into an edit control.

Returns
Maximum text length user may enter.
See also
SetTextLimit

◆ GetThumbWidth()

AFX_INLINE int GetThumbWidth ( ) const

Call this method to get the width of a thumb button.

Returns
Width of the thumb button.
See also
SetThumbWidth

◆ HasFocus()

BOOL HasFocus ( ) const

Call this method to determine if control has focus.

Returns
True if control has focus, false otherwise

◆ InsertString()

AFX_INLINE int InsertString | ( | int | nIndex,
 |  | LPCTSTR | lpsz )

Call this member to insert a string into the list box of a combobox control.

Parameters
nIndex | Contains the zero-based index to the position in the list box that will receive the string.
lpsz | The string that is to be inserted.
Returns
The zero-based index of a newly inserted item, or CB_ERR if insertion was unsuccessful.

◆ IsCaptionVisible()

virtual BOOL IsCaptionVisible ( ) const
virtual

Call this member to determine if the caption of the control is visible.

Returns
TRUE if the caption of the control is visible, otherwise FALSE.

Reimplemented from CXTPControl.

◆ IsCustomizeResizeAllow()

AFX_INLINE BOOL IsCustomizeResizeAllow ( ) const
protectedvirtual

This member checks if the user can resize the control.

Returns
TRUE if resize is available.

Reimplemented from CXTPControl.

◆ IsFocusable()

virtual BOOL IsFocusable ( ) const
protectedvirtual

This method is called to check if a control can accept focus.

Returns
True if control can accept focus, false if not
See also
SetFocused

Reimplemented from CXTPControl.

◆ IsFocused()

virtual BOOL IsFocused ( ) const
virtual

Call this member to get the focused state of the control.

Returns
TRUE if the control has focus, otherwise FALSE.

Reimplemented from CXTPControl.

◆ IsImageVisible()

BOOL IsImageVisible ( ) const

Call this member to determine if the icon is visible for a combobox control.

Returns
TRUE if the icon is visible, otherwise FALSE.

◆ ModifyListBoxStyle()

void ModifyListBoxStyle | ( | DWORD | dwRemove,
 |  | DWORD | dwAdd )

Call this member to modify the style of a list box.

Parameters
dwRemove | Styles to remove.
dwAdd | Styles to add.

◆ OnActionChanged()

virtual void OnActionChanged ( int nProperty )
virtual

This method is called when an action property is changed.

Parameters
nProperty Property of the action.
See also
OnActionChanging

Reimplemented from CXTPControl.

◆ OnActionChanging()

virtual void OnActionChanging ( int nProperty )
virtual

This method is called when an action property is about to be changed.

Parameters
nProperty Property of the action
See also
OnActionChanged

Reimplemented from CXTPControl.

◆ OnCalcDynamicSize()

virtual void OnCalcDynamicSize ( DWORD dwMode )
protectedvirtual

This method is called before recalculating the parent command bar size to calculate the dimensions of the control.

Parameters
dwMode Flags used to determine the height and width of the dynamic command bar. See Remarks section for a list of values.

The following predefined flags are used to determine the height and width of the dynamic command bar. Use the bitwise-OR (|) operator to combine the flags.

LM_STRETCH: Indicates whether the command bar should be stretched to the size of the frame. Set if the bar is not a docking bar (not available for docking). Not set when the bar is docked or floating (available for docking). If set, LM_STRETCH returns dimensions based on the LM_HORZ state. LM_STRETCH works similarly to the the bStretch parameter used in CalcFixedLayout; see that member function for more information about the relationship between stretching and orientation. LM_HORZ: Indicates that the bar is horizontally or vertically oriented. Set if the bar is horizontally oriented, and if it is vertically oriented, it is not set. LM_HORZ works similarly to the the bHorz parameter used in CalcFixedLayout; see that member function for more information about the relationship between stretching and orientation. LM_MRUWIDTH: Most Recently Used Dynamic Width. Uses the remembered most recently used width. LM_HORZDOCK: Horizontal Docked Dimensions. Returns the dynamic size with the largest width. LM_VERTDOCK: Vertical Docked Dimensions. Returns the dynamic size with the largest height. LM_COMMIT: Resets LM_MRUWIDTH to the current width of the floating command bar.

The framework calls this member function to calculate the dimensions of a dynamic command bar.

Override this member function to provide your own layout in classes you derive from CXTPControl. XTP classes derived from CXTPControl, such as CXTPControlComboBox, override this member function to provide their own implementation.

See also
CXTPControl, CXTPControlCustom, CXTPControlEdit, CXTPControlWindowList, CXTPControlWorkspaceActions, CXTPControlToolbars, CXTPControlOleItems, CXTPControlRecentFileList, CXTPControlSelector, CXTPControlListBox

Reimplemented from CXTPControl.

◆ OnClick()

void OnClick | ( | BOOL | bKeyboard = FALSE,
 |  | CPoint | pt = CPoint(0, 0) )
 protectedvirtual

This method is called when the user clicks the control.

Parameters
bKeyboard | TRUE if the control is selected using the keyboard.
pt | Mouse cursor position.

Reimplemented from CXTPControlButton.

◆ OnHookKeyDown()

BOOL OnHookKeyDown | ( | UINT | nChar,
 |  | LPARAM | lParam )
 protectedvirtual

This method is called when a non-system key is pressed.

Parameters
nChar | Specifies the virtual key code of the given key.
lParam | Specifies additional message-dependent information.
Returns
TRUE if the key was handled, otherwise FALSE.

Reimplemented from CXTPControl.

◆ OnMouseMove()

virtual void OnMouseMove ( CPoint point )
protectedvirtual

This member is called when the mouse cursor moves.

Parameters
point Specifies the x- and y- coordinates of the cursor.

Reimplemented from CXTPControlPopup.

◆ OnSetFocus()

virtual void OnSetFocus ( CWnd * pOldWnd )
protectedvirtual

This method is called when the edit control gets focus.

Parameters
pOldWnd Pointer to a CWnd object.

◆ OnSetPopup()

virtual BOOL OnSetPopup ( BOOL bPopup )
protectedvirtual

This method is called to pop-up the control.

Parameters
bPopup TRUE to set pop-up.
Returns
TRUE if successful, otherwise FALSE.

Reimplemented from CXTPControlPopup.

Reimplemented in CXTPControlSizeComboBox.

◆ OnSetSelected()

BOOL OnSetSelected ( int bSelected )
protectedvirtual

This method is called when the control becomes selected.

Parameters
bSelected TRUE if the control becomes selected.
Returns
TRUE if successful, otherwise FALSE.

Reimplemented from CXTPControl.

◆ SetCurSel()

void SetCurSel ( int nIndex )

Call this member to select a string in the list box of a combobox.

Parameters
nIndex Specifies the zero-based index of the string to select.

◆ SetDropDownItemCount()

AFX_INLINE void SetDropDownItemCount ( int nDropDownItemCount )

Call this member to set the count of items in the dropdown list.

Parameters
nDropDownItemCount The count of items in the dropdown list.

◆ SetDropDownListStyle()

void SetDropDownListStyle ( BOOL bSet = TRUE )

Call this member to insert/delete an edit box in the combobox when the control has focus.

Parameters
bSet TRUE to set the combobox to have an edit control.

If bSet is TRUE, an edit control will be used to display the text when the combobox control is clicked. This allows the user to edit or copy the text.

See also
GetDropDownListStyle

◆ SetDropDownWidth()

AFX_INLINE void SetDropDownWidth ( int nWidth )

Call this member to set the width of the dropdown list.

Parameters
nWidth The width of the dropdown list.

◆ SetEditHint()

void SetEditHint ( LPCTSTR lpszEditHint )

Call this member to set the grayed-out text displayed in the edit control which provides a helpful description of what the control is used for.

Parameters
lpszEditHint Edit hint to be set.

Example:

pCombo->SetEditHint(_T("Click to find a contact");
See also
GetEditHint

◆ SetEditIconId()

void SetEditIconId ( int nId )

Call this member to set the edit icon's identifier.

Parameters
nId Icon's identifier to be set.

◆ SetEditStyle()

void SetEditStyle ( DWORD dwStyle )

Call this member to set the style of edit control.

Parameters
dwStyle The style to be set.
See also
GetEditStyle

◆ SetEditText()

void SetEditText ( const CString & lpszText )

Call this member to set the edit control text.

Parameters
lpszText New text of the edit control.
See also
FindStringExact, FindString

◆ SetFocused()

virtual void SetFocused ( BOOL bFocused )
virtual

Call this member to set focus to the control.

Parameters
bFocused TRUE to set focus to the control.

Reimplemented from CXTPControl.

◆ SetHideFlags()

virtual void SetHideFlags ( DWORD dwFlags )
virtual

This method is called to hide the control.

Parameters
dwFlags Reasons to hide.
See also
XTPControlHideFlags

Reimplemented from CXTPControl.

◆ SetItemData()

AFX_INLINE int SetItemData | ( | int | nIndex,
 |  | DWORD_PTR | dwItemData )

This method sets the 32-bit value associated with the specified item in a combobox.

Parameters
nIndex | Contains a zero-based index of the item to set.
dwItemData | Contains the new value to associate with the item.
Returns
CB_ERR if an error occurs.

◆ SetLabelWidth()

void SetLabelWidth ( int nLabelWidth )

Call this method to set the width of a label.

Parameters
nLabelWidth Width of the label to be set.
See also
GetLabelWidth, SetStyle, GetStyle

◆ SetListIconId()

void SetListIconId ( int nId )

Call this member to set the combo list icon's identifier.

Parameters
nId Icon's identifier to be set.

◆ SetParent()

void SetParent ( CXTPCommandBar * pParent )
protectedvirtual

This method is called to assign a parent command bar object.

Parameters
pParent Pointer to a CXTPCommandBar object.

Reimplemented from CXTPControl.

◆ SetRect()

void SetRect ( CRect rcControl )
protectedvirtual

Call this member to set the bounding rectangle of the control.

Parameters
rcControl Bounding rectangle of the control.

Reimplemented from CXTPControl.

◆ SetTextLimit()

void SetTextLimit ( int nTextLimit )

This method sets the maximum text length that the user may enter into an edit control.

Parameters
nTextLimit Maximum text length user may enter.
See also
GetTextLimit

◆ SetThumbWidth()

void SetThumbWidth ( int nThumbWidth )

This method is called to set the width of a thumb button.

Parameters
nThumbWidth Width of the thumb button to be set.
See also
GetThumbWidth
The documentation for this class was generated from the following file:
  • XTPControlComboBox.h


Toolkit Pro: CXTPControlComboBoxEditCtrl Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPControlComboBoxEditCtrl Class Reference

Inplace Edit control of the combo. More...

Inheritance diagram for CXTPControlComboBoxEditCtrl:
[legend]

Public Member Functions

CXTPControlComboBox * | GetControlComboBox () const
Retrieves parent CXTPControlComboBox object.
- Public Member Functions inherited from CXTPCommandBarEditCtrl
CXTPCommandBarEditCtrl ()
Constructs a CXTPCommandBarEditCtrl object.
virtual BOOL | OnCmdMsg (UINT nID, int nCode, void *pExtra, AFX_CMDHANDLERINFO *pHandlerInfo)
Called by the framework to route and dispatch command messages and to handle the update of command user-interface objects.
virtual BOOL | OnCommand (WPARAM wParam, LPARAM lParam)
The framework calls this member function when the user selects an item from a menu, when a child control sends a notification message, or when an accelerator keystroke is translated.
virtual BOOL | ShowContextMenu (CXTPControl *pControl, CPoint point)
This member function displays a pop-up context menu.
virtual BOOL | CreateEdit (DWORD dwStyle, CWnd *pParentWnd)
This member function displays a pop-up context menu.
BOOL | IsDialogCode (UINT nChar, LPARAM lParam)
This method determines whether the specified character is intended for an edit.
void | GetWindowTextEx (CString &rString)
Returns window text of edit.
void | SetWindowTextEx (LPCTSTR lpszString)
Sets the window text of edit.
BOOL | IsImeMode () const
Determines if the Input Method Editor(IME) is being used.

Protected Member Functions

void | UpdateCharFormat ()
This method is called to refresh the char format of edit control.
- Protected Member Functions inherited from CXTPCommandBarEditCtrl
CRichEditContext & | GetRichEditContext ()
Call this method to get rich edit version information.
BOOL | IsCommandEnabled (UINT nID)
Determines if edit command is enabled.

Protected Attributes

CXTPControlComboBox * | m_pControl
Parent Combobox.
- Protected Attributes inherited from CXTPCommandBarEditCtrl
BOOL | m_bImeMode
TRUE if IME editor is currently enabled.
BOOL | m_bComposited
TRUE if control is AERO composited.
BOOL | m_bIgonoreEditChanged
Don't send OnEditChanged.

Detailed Description

Inplace Edit control of the combo.

Member Function Documentation

◆ GetControlComboBox()

AFX_INLINE CXTPControlComboBox * GetControlComboBox ( ) const

Retrieves parent CXTPControlComboBox object.

Returns
Pointer to parent CXTPControlComboBox.
The documentation for this class was generated from the following file:
  • XTPControlComboBox.h


Toolkit Pro: CXTPControlComboBoxGalleryPopupBar Class Reference

Static Public Member Functions | Protected Member Functions | List of all members
CXTPControlComboBoxGalleryPopupBar Class Reference

CXTPControlComboBoxPopupBar object. More...

Inheritance diagram for CXTPControlComboBoxGalleryPopupBar:
[legend]

Static Public Member Functions

static CXTPControlComboBoxGalleryPopupBar *AFX_CDECL | CreateComboBoxGalleryPopupBar (CXTPCommandBars *pCommandBars)
Creates a pop-up bar object.
- Static Public Member Functions inherited from CXTPPopupBar
static CXTPPopupBar *AFX_CDECL | CreatePopupBar (CXTPCommandBars *pCommandBars)
Creates a pop-up bar object.

Protected Member Functions

CXTPControlComboBoxGalleryPopupBar ()
Constructs a CXTPControlComboBoxGalleryPopupBar object.
- Protected Member Functions inherited from CXTPPopupBar
CXTPPopupBar ()
Constructs a CXTPPopupBar object.
virtual | ~CXTPPopupBar ()
Destroys a CXTPPopupBar object, handles cleanup and deallocation.
virtual void | DelayRedraw ()
Redraw the pop-up bar.
virtual BOOL | SetSelected (int nSelected, BOOL bKeyboard=FALSE)
Call this member to select the specified control.
void | UpdateLocation (CSize sz)
This method sets the pop-up bar's position.
virtual void | UpdateFlags ()
Update flags.
void | UpdateExpandingState ()
Update expanding state.
virtual void | DrawCommandBar (CDC *pDC, CRect rcClipBox)
This method is called to draw the command bar in the given context.
virtual void | OnControlsChanged ()
This method is called when the controls array is changed.
virtual void | OnRecalcLayout ()
This method is called to recalculate the command bar layout.
CXTPCommandBar * | GetParentCommandBar () const
Call this member to retrieve the parent command bar.
virtual void | DoPropExchange (CXTPPropExchange *pPX)
Either reads this object from or writes this object to an archive.
virtual void | Copy (CXTPCommandBar *pCommandBar, BOOL bRecursive=FALSE)
Call this method make a copy of the command bar.
virtual BOOL | OnHookKeyDown (UINT nChar, LPARAM lParam)
The framework calls this member function when a non-system key is pressed.
virtual void | AdjustExcludeRect (CRect &rc, BOOL bVertical)
Updates rectangle to set the position where the child pop-up bar becomes visible.
virtual void | Animate ()
Animates pop-up window.
- Protected Member Functions inherited from CXTPCommandBar
CXTPCommandBar ()
Constructs a CXTPCommandBar object.
virtual | ~CXTPCommandBar ()
Destroys a CXTPCommandBar object, handles cleanup and deallocation.
virtual BOOL | ProcessSpecialKey (XTPSpecialKey key)
This method is called to process special keys.
virtual int | OnMouseHitTest (CPoint pt)
This method is called to determine mouse hit code.
virtual void | UpdateShortcuts ()
Updates the control's shortcuts.
UINT | GetActiveDocTemplate () const
Retrieves the active MDI document template.
virtual void | GenerateCommandBarList (DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam)
This method is called to assign self identifiers for the serialization process.
virtual void | RestoreCommandBarList (CXTPCommandBarList *pCommandBarList)
This method is called in the serialization process to restore pop-ups from a list of command bars.
BOOL | IsHelpMode () const
Determines if the parent frame is in help mode.
virtual void | OnRemoved ()
This method is called when a toolbar is removed from the command bars collection.

Additional Inherited Members

- Public Member Functions inherited from CXTPControlComboBoxPopupBar
CXTPControlComboBoxPopupBar ()
Constructs a CXTPControlComboBoxPopupBar object.
- Public Member Functions inherited from CXTPPopupBar
void | SetTearOffPopup (LPCTSTR lpszCaption, UINT nID, int nWidth=400)
This method adds the tear-off state to the pop-up bar.
BOOL | IsTearOffPopup (CString &strCaption, UINT &nID, int &nWidth)
Determines if the pop-up bar has the tear-off state.
virtual BOOL | IsVisible () const
Call this member to determine if the pop-up menu is visible/displayed.
BOOL | Popup (int xPos, int yPos, LPCRECT rcExclude)
This method opens the pop-up bar.
BOOL | Popup (CXTPControlPopup *pControlPopup, BOOL bSelectFirst=FALSE)
This method opens the pop-up bar.
CXTPControlPopup * | GetControlPopup () const
Call this member to retrieve the control's pop-up.
void | ExpandBar ()
This method expands the bar.
BOOL | DestroyWindow ()
Call this member to destroy the window.
void | SetPopupToolBar (BOOL bToolBarType)
Call this method to make the pop-up bar look like a pop-up toolbar.
void | SetDefaultItem (UINT uItem, BOOL fByPos=FALSE)
Sets the default menu item for the specified pop-up bar.
UINT | GetDefaultItem (UINT gmdiFlags, BOOL fByPos=FALSE)
Determines the default menu item on the specified pop-up bar.
BOOL | IsDoubleGripper () const
Call this method to determine if the pop-up bar has a double gripper.
void | SetDoubleGripper (BOOL bDoubleGripper=TRUE)
Call this member to set a double gripper for the pop-up bar.
virtual BOOL | IsPopupBar () const
Call this member function to determine if the command bar is a CXTPPopupBar.
BOOL | IsContextMenu () const
Determines if the pop-up bar is a context menu.
void | PumpMessage ()
Translates all messages in the message queue.
virtual CSize | CalcDynamicLayout (int nLength, DWORD dwMode)
This method is called to get the size of the command bar.
virtual BOOL | Create ()
Creates the pop-up bar.
virtual CRect | CalculatePopupRect (CPoint ptPopup, CSize sz)
This method is called to calculate the destination rectangle of the pop-up bar.
void | SetPopupFlags (DWORD dwPopupFlags)
Call this method to set the pop-up direction.
virtual BOOL | SetTrackingMode (int bMode, BOOL bSelectFirst=TRUE, BOOL bKeyboard=FALSE)
Call this member to change the tracking state.
void | SetBorders (CRect rcBorders)
Sets the toolbar's borders.
void | DisableShadow ()
Disables shadow use.
BOOL | IsResizable () const
Determines if the control can be resized by the user.
virtual CRect | GetBorders ()
Call this method to get the border margins of the command bar.
- Public Member Functions inherited from CXTPCommandBar
int | IsTrackingMode () const
Call this member to get the tracking state.
CXTPControls * | GetControls () const
Call this member to get the controls collection.
void | SetControls (CXTPControls *pControls)
Call this member to set the controls collection of the command bar.
XTPBarType | GetType () const
Call this member to get the type of the command bar.
void | SetTextOrientation (XTPBarTextOrientation nTextOrientation)
Call this member to change text orientation.
XTPBarTextOrientation | GetTextOrientation () const
Call this member to get the text orientation.
XTPBarPosition | GetPosition () const
Call this member to get the position of the command bar.
void | DelayLayout ()
Call this member to recalculate the layout.
virtual BOOL | LoadMenu (CMenu *pMenu, BOOL bRemoveControls=TRUE)
Call this member to convert menu items to command bar controls.
CXTPControl * | GetControl (int nIndex) const
Call this member to return the control at the specified index.
int | GetControlCount () const
Call this member to get the count of the controls.
CXTPControl * | GetSelected () const
Call this member to get the currently selected control.
BOOL | SetPopuped (int nPopuped, BOOL bKeyboard=FALSE)
Call this member to pop-up the specified control.
void | SetTitle (LPCTSTR lpszTitle)
Call this member to set a title for this command bar.
CString | GetTitle () const
Call this member to get a title for this command bar.
CXTPCommandBars * | GetCommandBars () const
Call this member to get the command bar's object.
void | SetCommandBars (CXTPCommandBars *pCommandBars)
Call this member to set the command bar's object.
CWnd * | GetSite () const
Call this member to get the command bar's site.
CFrameWnd * | GetFrameSite () const
Call this member to get the command bar's site as CFrameWnd.
void | SetFlags (DWORD dwFlagsAdd, DWORD dwFlagsRemove=0)
Call this member to set the command bar's flags.
BOOL | SetButtons (UINT *pButtons, int nCount)
Call this member to set the controls from the button array.
virtual BOOL | LoadToolBar (UINT nIDResource, BOOL bLoadIcons=TRUE)
Call this member function to load the toolbar specified by nIDResource.
void | SetIconSize (CSize size)
Call this function to set the size of the actual bitmapped images to be added to a toolbar.
virtual CSize | GetIconSize () const
Call this member function to get the size of the toolbar icon.
CSize | GetLargeIconSize (BOOL bAutoSize) const
Call this method to get the large icon size of the toolbar.
void | SetButtonSize (CSize size)
Sets the size of the buttons in the command bar.
virtual CSize | GetButtonSize () const
Call this function to get the size of the command bar button.
void | ShowTextBelowIcons (BOOL bTextBelow=TRUE)
Call this member to show the caption below control's icon.
BOOL | IsTextBelowIcons () const
Checks whether the caption is below the control's icon.
HWND | GetTrackFocus () const
Call this method to retrieve the current focused control.
void | SetTrackFocus (HWND hwnd)
Call this method to set focus to the window.
virtual void | SetVisible (BOOL bVisible)
Call this method to set the visibility state of the control.
virtual BOOL | SetPosition (XTPBarPosition barPosition)
Call this member function to set the position of the command bar.
int | FindAccel (TCHAR chAccel) const
Call this method to get the index of the control with the specified accelerator character.
int | FindAccelEx (UINT chAccel, BOOL &bSelectOnly) const
Call this method to get the index of the control with the specified accelerator character.
BOOL | IsCustomizeMode () const
Call this method to check if the command bars are in customize mode.
virtual DROPEFFECT | OnCustomizeDragEnter (CXTPControl *pDataObject, CPoint point)
This member is called when a control is entered into the command bar.
virtual void | OnCustomizeDragLeave ()
This method is called when a control leaves the command bar.
virtual DROPEFFECT | OnCustomizeDragOver (CXTPControl *pDataObject, CPoint point)
This member is called when control is over the command bar.
virtual void | OnCustomizeDrop (CXTPControl *pDataObject, DROPEFFECT &dropEffect, CPoint ptDrop, CPoint ptDrag)
This method is called when a control is dropped to the command bar.
virtual BOOL | IsCustomizable () const
Call this method to check if the command bar is customizable.
BOOL | IsCustomizeDialogPresent () const
Call this method to check if the command bar is present in Customize dialog.
void | EnableCustomization (BOOL bEnable=TRUE)
Call this method to enable/disable customization of the command bar.
virtual void | OnTrackLost ()
Call this method to remove the tracking state of the command bar.
virtual void | OnTrackEnter ()
Call this method to track the command bar.
CWnd * | GetOwnerSite () const
Call this method to retrieve the owner window of the command bar.
void | InvalidateParents ()
Call this method to redraw all parent command bars.
DWORD | GetFlags () const
Call this method to retrieve the current behavior modification flags of the command bar.
UINT | GetBarID () const
Call this method to retrieve the identifier of the command bar.
void | SetBarID (UINT nID)
Call this method to set the identifier of the command bar.
virtual void | OnControlSelected (BOOL bSelected, CXTPControl *pControl)
This method is called when a child control becomes selected.
BOOL | SetStatusText (const CString &strDescription)
This method is called to set the description context.
void | SetCommandBarData (DWORD_PTR dwData)
This method sets the 32-bit value associated with the command bar.
DWORD_PTR | GetCommandBarData () const
This method retrieves the application-supplied, 32-bit value associated with the command bar.
CXTPCommandBar * | GetRootParent () const
Call this method to retrieve the top-level parent command bar.
CXTPPaintManager * | GetPaintManager () const
Call this method to retrieve the paint manager.
CXTPImageManager * | GetImageManager () const
Call this method to retrieve the image manager.
void | SetWidth (int nWidth)
Call this member to set the width of the floated or pop-up toolbar.
int | GetWidth () const
Call this member to get the width of the floated or pop-up toolbar.
void | SetPaintManager (CXTPPaintManager *pPaintManager)
Call this member to set the specified paint manager.
void | SetImageManager (CXTPImageManager *pImageManager)
Call this member to set the specified image manager.
BOOL | IsLayoutRTL () const
Call this member function to determine if the command bar layout is Right-to-Left (RTL).
virtual BOOL | IsDialogBar () const
Call this member function to determine if the command bar is a CXTPDialogBar.
virtual BOOL | IsRibbonBar () const
Call this member function to determine if the command bar is a CXTPRibbonBar.
virtual BOOL | IsMenuTitleBar () const
Call this member function to determine if the command bar is a CXTPMenuTitleBar.
virtual BOOL | IsKeyboardCuesVisible () const
Determines if underlines are visible in the command bar control.
void | SetGrabFocus (BOOL bGrabFocus)
This method is called internally to prevent the command bar from grabbing edit focus.
virtual void | Redraw (LPCRECT lpRect=0, BOOL bAnimate=TRUE)
The framework calls this member function to redraw the command bar.
void | EnableAnimation (BOOL bEnable=TRUE)
Call this method to enable animation for the command bar.
void | EnableDoubleBuffer (BOOL bEnable=TRUE)
Call this method to enable double buffer for toolbar drawing.
BOOL | IsAnimationEnabled () const
Determines if animation is enabled for the specified command bar.
virtual int | OnHookMessage (HWND hWnd, UINT nMessage, WPARAM &wParam, LPARAM &lParam, LRESULT &lResult)
This member function is called by WindowProc, or is called during message reflection.
virtual void | EnsureVisible (CXTPControl *pControl)
Call this method to ensure that a specified control is visible on the toolbar.
XTPButtonStyle | GetDefaultButtonStyle () const
Call this method to retrieve the default button style of the command bar.
void | SetDefaultButtonStyle (XTPButtonStyle buttonStyle)
Call this method to set the default button style of the command bar.
void | LockRedraw ()
Call this method to freeze redrawing until UnlockRedraw is called.
void | UnlockRedraw ()
Call this method to unfreeze redrawing.
void | SetShowGripper (BOOL bShow)
Call this method to set the visibility of the command bar's gripper.
BOOL | GetShowGripper () const
Call this method to check if the command bar's gripper is visible.
virtual void | FillCommandBarEntry (CDC *pDC)
This method is called to draw the background of the command bar.
BOOL | IsKeyboardTipsVisible () const
Call this method to check if keyboard tips are visible for the command bar.
virtual void | CreateKeyboardTips ()
This method is called to create a keyboard tips collection for the command bar.
void | OnKeyboardTipChar (UINT chAccel)
This method is called when the user presses a key while keyboard tips are visible.
virtual void | OnKeyboardTip (CXTPCommandBarKeyboardTip *pTip)
This method is called when a keyboard tip is found for the command bar.
void | HideKeyboardTips ()
Call this method to hide keyboard tips.
void | LockMouseMove (CXTPControl *pControl)
Locks the mouse cursor for a specified control.
void | UnlockMouseMove ()
Unlocks the mouse cursor.
- Public Member Functions inherited from CXTPHookManagerHookAble
CXTPHookManagerHookAble ()
Constructs a CXTPHookManagerHookAble object.
virtual | ~CXTPHookManagerHookAble ()
Destroys a CXTPHookManagerHookAble object, handles cleanup and deallocation.
virtual int | OnPostHookMessage (HWND hWnd, UINT nMessage, WPARAM &wParam, LPARAM &lParam, LRESULT &lResult)
This member function is called after a message has been processed by default window procedure.
virtual void | OnHookAttached (HWND hWnd)
This member function is called right after a hook is attached to the window.
virtual void | OnHookDetached ()
This member function is called right before a hook is to be detached from the window.
- Public Attributes inherited from CXTPCommandBar
int | m_nStateFlags
State of the command bars.
BOOL | m_bComboBar
TRUE if it is combobox list.
BOOL | m_bTrackOnHover
TRUE to select item if mouse stay over control.
- Public Attributes inherited from CXTPHookManagerHookAble
BOOL | m_bAutoDestroy
TRUE to automatically delete hook.
- Static Public Attributes inherited from CXTPPopupBar
static double | m_dMaxWidthDivisor
Maximum available width of pop-up.
- Static Public Attributes inherited from CXTPCommandBar
static int | s_nHoverDelay
Hover delay time.
static int | s_nExpandDelay
Expand delay time.
static int | s_nExpandHoverDelay
Expand hover delay.
- Protected Attributes inherited from CXTPPopupBar
CXTPControlPopup * | m_pControlPopup
Control that pop-up'ed the bar.
CPoint | m_ptPopup
Position of the bar.
CRect | m_rcExclude
Excluded area.
DWORD | m_popupFlags
Flags of the bar.
BOOL | m_bDynamicLayout
TRUE if DynamicLayout routine executed.
BOOL | m_bCollapsed
TRUE if pop-up bar is collapsed.
BOOL | m_bExpanded
TRUE if pop-up bar is expanded.
BOOL | m_bExpanding
TRUE if pop-up bar is expanding.
BOOL | m_bTearOffPopup
TRUE if pop-up bar has tear-off option.
CRect | m_rcTearOffGripper
Tear-off gripper position.
CRect | m_rcResizeGripper
Resizable gripper position.
BOOL | m_bResizable
TRUE to allow resize.
BOOL | m_bTearOffSelected
TRUE if gripper selected.
UINT_PTR | m_nTearOffTimer
Tear-off timer.
BOOL | m_bTearOffTracking
Tear-off tracking mode.
CSize | m_szTearOffBar
Size of the bar.
CXTPToolBar * | m_pTearOffBar
Tear-off toolbar pointer.
CString | m_strTearOffCaption
Caption of the Tear-off toolbar.
UINT | m_nTearOffID
ID of the Tear-off toolbar.
int | m_nTearOffWidth
Width of the Tear-off toolbar.
BOOL | m_bShowShadow
TRUE to show the shadow.
CRect | m_rcBorders
Borders of the bar.
BOOL | m_bDoubleGripper
TRUE if pop-up is state pop-up type.
BOOL | m_bContextMenu
TRUE if pop-up bar is context menu.
int | m_nMaxHeight
Maximum height the pop-up bar can become.
- Protected Attributes inherited from CXTPCommandBar
BOOL | m_bGrabFocus
TRUE to grab current focus.
int | m_nMRUWidth
Recent width.
int | m_nSelected
Selected control index.
int | m_nPopuped
Pop-up'ed control index.
HWND | m_hwndFocus
The handle of the window that currently has focus.
UINT | m_nBarID
Command bar's identifier.
BOOL | m_bTracking
TRUE if the command bar is in tracking mode.
CWnd * | m_pSite
Command bar's site.
DWORD | m_nIdleFlags
Idle flags.
DWORD | m_dwFlags
Command bar's flags.
DWORD | m_dwStyle
Command bar's styles.
CString | m_strTitle
Command bar's caption.
XTPBarType | m_barType
Type of the command bar.
CXTPControls * | m_pControls
A pointer to controls collection.
XTPBarPosition | m_barPosition
Position of the command bar.
CXTPCommandBars * | m_pCommandBars
parent command bars class.
CWnd * | m_pOwner
Owner window.
CSize | m_szIcons
Size of the command bar's icons.
CSize | m_szButtons
Size of the command bar's buttons.
BOOL | m_bTextBelow
TRUE if text is shown below the CommandBar buttons.
BOOL | m_bExecOnRButton
TRUE if the control button is executed on a right-click.
BOOL | m_bIgnoreUpdateHandler
TRUE to skip update handler for all child controls.
BOOL | m_bRecursePopup
TRUE if pop-up bar was opened recursively.
BOOL | m_bKeyboardSelect
TRUE if last item was selected by keyboard.
BOOL | m_bCloseable
TRUE if the CommandBar can be closed and-or Hidden.
BOOL | m_bCustomizable
TRUE if command bar is customizable.
CRect | m_rcMarker
Marker position.
BOOL | m_bVerticalMarker
TRUE to draw marker vertically.
DWORD_PTR | m_dwData
The 32-bit value associated with the command bar.
UINT * | m_pReturnCmd
Return command holder.
BOOL | m_bCustomizeDialogPresent
TRUE if the command bar is present in Customize dialog.
BOOL | m_bAnimatePopup
TRUE to animate pop-up bar.
BOOL | m_nLockRedraw
TRUE if all drawing routines skipped.
CXTPPaintManager * | m_pPaintManager
Selected paint manager for command bar.
CXTPImageManager * | m_pImageManager
Selected image manager for command bar.
BOOL | m_bMultiLine
True if multi line commandbar.
XTPButtonStyle | m_buttonStyle
Default button Style.
XTPBarTextOrientation | m_nTextOrientation
Commandbar text orientation.
CXTPToolTipContext * | m_pToolTipContext
Tool tip Context.
CXTPCommandBarAnimation * | m_pAnimation
Animation context.
CSize | m_szButtonSpacing
Spacing used between toolbar buttons.

Detailed Description

CXTPControlComboBoxPopupBar object.

Member Function Documentation

◆ CreateComboBoxGalleryPopupBar()

static CXTPControlComboBoxGalleryPopupBar *AFX_CDECL CreateComboBoxGalleryPopupBar ( CXTPCommandBars * pCommandBars )
static

Creates a pop-up bar object.

Parameters
pCommandBars Points to a CXTPCommandBars object.
Returns
A pointer to a CXTPControlComboBoxGalleryPopupBar object.
The documentation for this class was generated from the following file:
  • XTPControlComboBoxGalleryPopupBar.h


Toolkit Pro: CXTPControlComboBoxList Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPControlComboBoxList Class Reference

CXTPControlComboBoxList is a CXTPControlComboBoxPopupBar derived class. More...

Inheritance diagram for CXTPControlComboBoxList:
[legend]

Public Member Functions

CXTPControlComboBoxList ()
Constructs a CXTPControlButton object.
virtual void | CreateListBox ()
Creates list box.
CListBox * | GetListBoxCtrl () const
- Public Member Functions inherited from CXTPControlComboBoxPopupBar
CXTPControlComboBoxPopupBar ()
Constructs a CXTPControlComboBoxPopupBar object.
- Public Member Functions inherited from CXTPPopupBar
void | SetTearOffPopup (LPCTSTR lpszCaption, UINT nID, int nWidth=400)
This method adds the tear-off state to the pop-up bar.
BOOL | IsTearOffPopup (CString &strCaption, UINT &nID, int &nWidth)
Determines if the pop-up bar has the tear-off state.
virtual BOOL | IsVisible () const
Call this member to determine if the pop-up menu is visible/displayed.
BOOL | Popup (int xPos, int yPos, LPCRECT rcExclude)
This method opens the pop-up bar.
BOOL | Popup (CXTPControlPopup *pControlPopup, BOOL bSelectFirst=FALSE)
This method opens the pop-up bar.
CXTPControlPopup * | GetControlPopup () const
Call this member to retrieve the control's pop-up.
void | ExpandBar ()
This method expands the bar.
BOOL | DestroyWindow ()
Call this member to destroy the window.
void | SetPopupToolBar (BOOL bToolBarType)
Call this method to make the pop-up bar look like a pop-up toolbar.
void | SetDefaultItem (UINT uItem, BOOL fByPos=FALSE)
Sets the default menu item for the specified pop-up bar.
UINT | GetDefaultItem (UINT gmdiFlags, BOOL fByPos=FALSE)
Determines the default menu item on the specified pop-up bar.
BOOL | IsDoubleGripper () const
Call this method to determine if the pop-up bar has a double gripper.
void | SetDoubleGripper (BOOL bDoubleGripper=TRUE)
Call this member to set a double gripper for the pop-up bar.
virtual BOOL | IsPopupBar () const
Call this member function to determine if the command bar is a CXTPPopupBar.
BOOL | IsContextMenu () const
Determines if the pop-up bar is a context menu.
void | PumpMessage ()
Translates all messages in the message queue.
virtual CSize | CalcDynamicLayout (int nLength, DWORD dwMode)
This method is called to get the size of the command bar.
virtual BOOL | Create ()
Creates the pop-up bar.
virtual CRect | CalculatePopupRect (CPoint ptPopup, CSize sz)
This method is called to calculate the destination rectangle of the pop-up bar.
void | SetPopupFlags (DWORD dwPopupFlags)
Call this method to set the pop-up direction.
void | SetBorders (CRect rcBorders)
Sets the toolbar's borders.
void | DisableShadow ()
Disables shadow use.
BOOL | IsResizable () const
Determines if the control can be resized by the user.
virtual CRect | GetBorders ()
Call this method to get the border margins of the command bar.
- Public Member Functions inherited from CXTPCommandBar
int | IsTrackingMode () const
Call this member to get the tracking state.
CXTPControls * | GetControls () const
Call this member to get the controls collection.
void | SetControls (CXTPControls *pControls)
Call this member to set the controls collection of the command bar.
XTPBarType | GetType () const
Call this member to get the type of the command bar.
void | SetTextOrientation (XTPBarTextOrientation nTextOrientation)
Call this member to change text orientation.
XTPBarTextOrientation | GetTextOrientation () const
Call this member to get the text orientation.
XTPBarPosition | GetPosition () const
Call this member to get the position of the command bar.
void | DelayLayout ()
Call this member to recalculate the layout.
virtual BOOL | LoadMenu (CMenu *pMenu, BOOL bRemoveControls=TRUE)
Call this member to convert menu items to command bar controls.
CXTPControl * | GetControl (int nIndex) const
Call this member to return the control at the specified index.
int | GetControlCount () const
Call this member to get the count of the controls.
CXTPControl * | GetSelected () const
Call this member to get the currently selected control.
BOOL | SetPopuped (int nPopuped, BOOL bKeyboard=FALSE)
Call this member to pop-up the specified control.
void | SetTitle (LPCTSTR lpszTitle)
Call this member to set a title for this command bar.
CString | GetTitle () const
Call this member to get a title for this command bar.
CXTPCommandBars * | GetCommandBars () const
Call this member to get the command bar's object.
void | SetCommandBars (CXTPCommandBars *pCommandBars)
Call this member to set the command bar's object.
CWnd * | GetSite () const
Call this member to get the command bar's site.
CFrameWnd * | GetFrameSite () const
Call this member to get the command bar's site as CFrameWnd.
void | SetFlags (DWORD dwFlagsAdd, DWORD dwFlagsRemove=0)
Call this member to set the command bar's flags.
BOOL | SetButtons (UINT *pButtons, int nCount)
Call this member to set the controls from the button array.
virtual BOOL | LoadToolBar (UINT nIDResource, BOOL bLoadIcons=TRUE)
Call this member function to load the toolbar specified by nIDResource.
void | SetIconSize (CSize size)
Call this function to set the size of the actual bitmapped images to be added to a toolbar.
virtual CSize | GetIconSize () const
Call this member function to get the size of the toolbar icon.
CSize | GetLargeIconSize (BOOL bAutoSize) const
Call this method to get the large icon size of the toolbar.
void | SetButtonSize (CSize size)
Sets the size of the buttons in the command bar.
virtual CSize | GetButtonSize () const
Call this function to get the size of the command bar button.
void | ShowTextBelowIcons (BOOL bTextBelow=TRUE)
Call this member to show the caption below control's icon.
BOOL | IsTextBelowIcons () const
Checks whether the caption is below the control's icon.
HWND | GetTrackFocus () const
Call this method to retrieve the current focused control.
void | SetTrackFocus (HWND hwnd)
Call this method to set focus to the window.
virtual void | SetVisible (BOOL bVisible)
Call this method to set the visibility state of the control.
virtual BOOL | SetPosition (XTPBarPosition barPosition)
Call this member function to set the position of the command bar.
int | FindAccel (TCHAR chAccel) const
Call this method to get the index of the control with the specified accelerator character.
int | FindAccelEx (UINT chAccel, BOOL &bSelectOnly) const
Call this method to get the index of the control with the specified accelerator character.
BOOL | IsCustomizeMode () const
Call this method to check if the command bars are in customize mode.
virtual DROPEFFECT | OnCustomizeDragEnter (CXTPControl *pDataObject, CPoint point)
This member is called when a control is entered into the command bar.
virtual void | OnCustomizeDragLeave ()
This method is called when a control leaves the command bar.
virtual DROPEFFECT | OnCustomizeDragOver (CXTPControl *pDataObject, CPoint point)
This member is called when control is over the command bar.
virtual void | OnCustomizeDrop (CXTPControl *pDataObject, DROPEFFECT &dropEffect, CPoint ptDrop, CPoint ptDrag)
This method is called when a control is dropped to the command bar.
BOOL | IsCustomizeDialogPresent () const
Call this method to check if the command bar is present in Customize dialog.
void | EnableCustomization (BOOL bEnable=TRUE)
Call this method to enable/disable customization of the command bar.
virtual void | OnTrackLost ()
Call this method to remove the tracking state of the command bar.
virtual void | OnTrackEnter ()
Call this method to track the command bar.
CWnd * | GetOwnerSite () const
Call this method to retrieve the owner window of the command bar.
void | InvalidateParents ()
Call this method to redraw all parent command bars.
DWORD | GetFlags () const
Call this method to retrieve the current behavior modification flags of the command bar.
UINT | GetBarID () const
Call this method to retrieve the identifier of the command bar.
void | SetBarID (UINT nID)
Call this method to set the identifier of the command bar.
virtual void | OnControlSelected (BOOL bSelected, CXTPControl *pControl)
This method is called when a child control becomes selected.
BOOL | SetStatusText (const CString &strDescription)
This method is called to set the description context.
void | SetCommandBarData (DWORD_PTR dwData)
This method sets the 32-bit value associated with the command bar.
DWORD_PTR | GetCommandBarData () const
This method retrieves the application-supplied, 32-bit value associated with the command bar.
CXTPCommandBar * | GetRootParent () const
Call this method to retrieve the top-level parent command bar.
CXTPPaintManager * | GetPaintManager () const
Call this method to retrieve the paint manager.
CXTPImageManager * | GetImageManager () const
Call this method to retrieve the image manager.
void | SetWidth (int nWidth)
Call this member to set the width of the floated or pop-up toolbar.
int | GetWidth () const
Call this member to get the width of the floated or pop-up toolbar.
void | SetPaintManager (CXTPPaintManager *pPaintManager)
Call this member to set the specified paint manager.
void | SetImageManager (CXTPImageManager *pImageManager)
Call this member to set the specified image manager.
BOOL | IsLayoutRTL () const
Call this member function to determine if the command bar layout is Right-to-Left (RTL).
virtual BOOL | IsDialogBar () const
Call this member function to determine if the command bar is a CXTPDialogBar.
virtual BOOL | IsRibbonBar () const
Call this member function to determine if the command bar is a CXTPRibbonBar.
virtual BOOL | IsMenuTitleBar () const
Call this member function to determine if the command bar is a CXTPMenuTitleBar.
virtual BOOL | IsKeyboardCuesVisible () const
Determines if underlines are visible in the command bar control.
void | SetGrabFocus (BOOL bGrabFocus)
This method is called internally to prevent the command bar from grabbing edit focus.
virtual void | Redraw (LPCRECT lpRect=0, BOOL bAnimate=TRUE)
The framework calls this member function to redraw the command bar.
void | EnableAnimation (BOOL bEnable=TRUE)
Call this method to enable animation for the command bar.
void | EnableDoubleBuffer (BOOL bEnable=TRUE)
Call this method to enable double buffer for toolbar drawing.
BOOL | IsAnimationEnabled () const
Determines if animation is enabled for the specified command bar.
virtual void | EnsureVisible (CXTPControl *pControl)
Call this method to ensure that a specified control is visible on the toolbar.
XTPButtonStyle | GetDefaultButtonStyle () const
Call this method to retrieve the default button style of the command bar.
void | SetDefaultButtonStyle (XTPButtonStyle buttonStyle)
Call this method to set the default button style of the command bar.
void | LockRedraw ()
Call this method to freeze redrawing until UnlockRedraw is called.
void | UnlockRedraw ()
Call this method to unfreeze redrawing.
void | SetShowGripper (BOOL bShow)
Call this method to set the visibility of the command bar's gripper.
BOOL | GetShowGripper () const
Call this method to check if the command bar's gripper is visible.
virtual void | FillCommandBarEntry (CDC *pDC)
This method is called to draw the background of the command bar.
BOOL | IsKeyboardTipsVisible () const
Call this method to check if keyboard tips are visible for the command bar.
virtual void | CreateKeyboardTips ()
This method is called to create a keyboard tips collection for the command bar.
void | OnKeyboardTipChar (UINT chAccel)
This method is called when the user presses a key while keyboard tips are visible.
virtual void | OnKeyboardTip (CXTPCommandBarKeyboardTip *pTip)
This method is called when a keyboard tip is found for the command bar.
void | HideKeyboardTips ()
Call this method to hide keyboard tips.
void | LockMouseMove (CXTPControl *pControl)
Locks the mouse cursor for a specified control.
void | UnlockMouseMove ()
Unlocks the mouse cursor.
- Public Member Functions inherited from CXTPHookManagerHookAble
CXTPHookManagerHookAble ()
Constructs a CXTPHookManagerHookAble object.
virtual | ~CXTPHookManagerHookAble ()
Destroys a CXTPHookManagerHookAble object, handles cleanup and deallocation.
virtual int | OnPostHookMessage (HWND hWnd, UINT nMessage, WPARAM &wParam, LPARAM &lParam, LRESULT &lResult)
This member function is called after a message has been processed by default window procedure.
virtual void | OnHookAttached (HWND hWnd)
This member function is called right after a hook is attached to the window.
virtual void | OnHookDetached ()
This member function is called right before a hook is to be detached from the window.

Protected Member Functions

int | OnHookMessage (HWND hWnd, UINT nMessage, WPARAM &wParam, LPARAM &lParam, LRESULT &lResult)
This member function is called by WindowProc, or is called during message reflection.
virtual BOOL | Popup (CXTPControlPopup *pControlPopup, BOOL bSelectFirst=FALSE)
This method is called, then the pop-up bar becomes visible.
virtual BOOL | SetTrackingMode (int bMode, BOOL bSelectFirst, BOOL bKeyboard=FALSE)
Call this member to change the tracking state.
virtual void | DrawCommandBar (CDC *pDC, CRect rcClipBox)
This method is called to draw the command bar in the given context.
virtual BOOL | OnHookKeyDown (UINT nChar, LPARAM lParam)
The framework calls this member function when a non-system key is pressed.
virtual BOOL | IsCustomizable () const
Call this member to retrieve the customize mode of the command bars.
virtual void | DoPropExchange (CXTPPropExchange *pPX)
Either reads this object from or writes this object to an archive.
virtual void | Copy (CXTPCommandBar *pCommandBar, BOOL bRecursive=FALSE)
This method makes a copy of the command bar.
BOOL | ProcessHookKeyDown (CXTPControlComboBox *pComboBox, UINT nChar, LPARAM lParam)
This method is called to process key down events.
virtual void | DrawItem (LPDRAWITEMSTRUCT lpDrawItemStruct)
This member function is called to draw the combobox.
virtual void | MeasureItem (LPMEASUREITEMSTRUCT lpMeasureItemStruct)
Override this method and fill in the MEASUREITEMSTRUCT structure to inform Windows of the list-box dimensions.
- Protected Member Functions inherited from CXTPPopupBar
CXTPPopupBar ()
Constructs a CXTPPopupBar object.
virtual | ~CXTPPopupBar ()
Destroys a CXTPPopupBar object, handles cleanup and deallocation.
virtual void | DelayRedraw ()
Redraw the pop-up bar.
virtual BOOL | SetSelected (int nSelected, BOOL bKeyboard=FALSE)
Call this member to select the specified control.
void | UpdateLocation (CSize sz)
This method sets the pop-up bar's position.
virtual void | UpdateFlags ()
Update flags.
void | UpdateExpandingState ()
Update expanding state.
virtual void | OnControlsChanged ()
This method is called when the controls array is changed.
virtual void | OnRecalcLayout ()
This method is called to recalculate the command bar layout.
CXTPCommandBar * | GetParentCommandBar () const
Call this member to retrieve the parent command bar.
virtual void | AdjustExcludeRect (CRect &rc, BOOL bVertical)
Updates rectangle to set the position where the child pop-up bar becomes visible.
virtual void | Animate ()
Animates pop-up window.
- Protected Member Functions inherited from CXTPCommandBar
CXTPCommandBar ()
Constructs a CXTPCommandBar object.
virtual | ~CXTPCommandBar ()
Destroys a CXTPCommandBar object, handles cleanup and deallocation.
virtual BOOL | ProcessSpecialKey (XTPSpecialKey key)
This method is called to process special keys.
virtual int | OnMouseHitTest (CPoint pt)
This method is called to determine mouse hit code.
virtual void | UpdateShortcuts ()
Updates the control's shortcuts.
UINT | GetActiveDocTemplate () const
Retrieves the active MDI document template.
virtual void | GenerateCommandBarList (DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam)
This method is called to assign self identifiers for the serialization process.
virtual void | RestoreCommandBarList (CXTPCommandBarList *pCommandBarList)
This method is called in the serialization process to restore pop-ups from a list of command bars.
BOOL | IsHelpMode () const
Determines if the parent frame is in help mode.
virtual void | OnRemoved ()
This method is called when a toolbar is removed from the command bars collection.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPPopupBar
static CXTPPopupBar *AFX_CDECL | CreatePopupBar (CXTPCommandBars *pCommandBars)
Creates a pop-up bar object.
- Public Attributes inherited from CXTPCommandBar
int | m_nStateFlags
State of the command bars.
BOOL | m_bComboBar
TRUE if it is combobox list.
BOOL | m_bTrackOnHover
TRUE to select item if mouse stay over control.
- Public Attributes inherited from CXTPHookManagerHookAble
BOOL | m_bAutoDestroy
TRUE to automatically delete hook.
- Static Public Attributes inherited from CXTPPopupBar
static double | m_dMaxWidthDivisor
Maximum available width of pop-up.
- Static Public Attributes inherited from CXTPCommandBar
static int | s_nHoverDelay
Hover delay time.
static int | s_nExpandDelay
Expand delay time.
static int | s_nExpandHoverDelay
Expand hover delay.
- Protected Attributes inherited from CXTPPopupBar
CXTPControlPopup * | m_pControlPopup
Control that pop-up'ed the bar.
CPoint | m_ptPopup
Position of the bar.
CRect | m_rcExclude
Excluded area.
DWORD | m_popupFlags
Flags of the bar.
BOOL | m_bDynamicLayout
TRUE if DynamicLayout routine executed.
BOOL | m_bCollapsed
TRUE if pop-up bar is collapsed.
BOOL | m_bExpanded
TRUE if pop-up bar is expanded.
BOOL | m_bExpanding
TRUE if pop-up bar is expanding.
BOOL | m_bTearOffPopup
TRUE if pop-up bar has tear-off option.
CRect | m_rcTearOffGripper
Tear-off gripper position.
CRect | m_rcResizeGripper
Resizable gripper position.
BOOL | m_bResizable
TRUE to allow resize.
BOOL | m_bTearOffSelected
TRUE if gripper selected.
UINT_PTR | m_nTearOffTimer
Tear-off timer.
BOOL | m_bTearOffTracking
Tear-off tracking mode.
CSize | m_szTearOffBar
Size of the bar.
CXTPToolBar * | m_pTearOffBar
Tear-off toolbar pointer.
CString | m_strTearOffCaption
Caption of the Tear-off toolbar.
UINT | m_nTearOffID
ID of the Tear-off toolbar.
int | m_nTearOffWidth
Width of the Tear-off toolbar.
BOOL | m_bShowShadow
TRUE to show the shadow.
CRect | m_rcBorders
Borders of the bar.
BOOL | m_bDoubleGripper
TRUE if pop-up is state pop-up type.
BOOL | m_bContextMenu
TRUE if pop-up bar is context menu.
int | m_nMaxHeight
Maximum height the pop-up bar can become.
- Protected Attributes inherited from CXTPCommandBar
BOOL | m_bGrabFocus
TRUE to grab current focus.
int | m_nMRUWidth
Recent width.
int | m_nSelected
Selected control index.
int | m_nPopuped
Pop-up'ed control index.
HWND | m_hwndFocus
The handle of the window that currently has focus.
UINT | m_nBarID
Command bar's identifier.
BOOL | m_bTracking
TRUE if the command bar is in tracking mode.
CWnd * | m_pSite
Command bar's site.
DWORD | m_nIdleFlags
Idle flags.
DWORD | m_dwFlags
Command bar's flags.
DWORD | m_dwStyle
Command bar's styles.
CString | m_strTitle
Command bar's caption.
XTPBarType | m_barType
Type of the command bar.
CXTPControls * | m_pControls
A pointer to controls collection.
XTPBarPosition | m_barPosition
Position of the command bar.
CXTPCommandBars * | m_pCommandBars
parent command bars class.
CWnd * | m_pOwner
Owner window.
CSize | m_szIcons
Size of the command bar's icons.
CSize | m_szButtons
Size of the command bar's buttons.
BOOL | m_bTextBelow
TRUE if text is shown below the CommandBar buttons.
BOOL | m_bExecOnRButton
TRUE if the control button is executed on a right-click.
BOOL | m_bIgnoreUpdateHandler
TRUE to skip update handler for all child controls.
BOOL | m_bRecursePopup
TRUE if pop-up bar was opened recursively.
BOOL | m_bKeyboardSelect
TRUE if last item was selected by keyboard.
BOOL | m_bCloseable
TRUE if the CommandBar can be closed and-or Hidden.
BOOL | m_bCustomizable
TRUE if command bar is customizable.
CRect | m_rcMarker
Marker position.
BOOL | m_bVerticalMarker
TRUE to draw marker vertically.
DWORD_PTR | m_dwData
The 32-bit value associated with the command bar.
UINT * | m_pReturnCmd
Return command holder.
BOOL | m_bCustomizeDialogPresent
TRUE if the command bar is present in Customize dialog.
BOOL | m_bAnimatePopup
TRUE to animate pop-up bar.
BOOL | m_nLockRedraw
TRUE if all drawing routines skipped.
CXTPPaintManager * | m_pPaintManager
Selected paint manager for command bar.
CXTPImageManager * | m_pImageManager
Selected image manager for command bar.
BOOL | m_bMultiLine
True if multi line commandbar.
XTPButtonStyle | m_buttonStyle
Default button Style.
XTPBarTextOrientation | m_nTextOrientation
Commandbar text orientation.
CXTPToolTipContext * | m_pToolTipContext
Tool tip Context.
CXTPCommandBarAnimation * | m_pAnimation
Animation context.
CSize | m_szButtonSpacing
Spacing used between toolbar buttons.

Detailed Description

CXTPControlComboBoxList is a CXTPControlComboBoxPopupBar derived class.

It represents a list box of CXTPControlComboBox control.

Member Function Documentation

◆ Copy()

virtual void Copy | ( | CXTPCommandBar * | pCommandBar,
 |  | BOOL | bRecursive = FALSE )
 protectedvirtual

This method makes a copy of the command bar.

Parameters
pCommandBar | Command bar to be copied.
bRecursive | TRUE to copy recursively.

Reimplemented from CXTPPopupBar.

Reimplemented in CXTPControlFontComboBoxList.

◆ DoPropExchange()

virtual void DoPropExchange ( CXTPPropExchange * pPX )
protectedvirtual

Either reads this object from or writes this object to an archive.

Parameters
pPX A CXTPPropExchange object to serialize to or from.

Reimplemented from CXTPPopupBar.

Reimplemented in CXTPControlFontComboBoxList.

◆ DrawCommandBar()

virtual void DrawCommandBar | ( | CDC * | pDC,
 |  | CRect | rcClipBox )
 protectedvirtual

This method is called to draw the command bar in the given context.

Parameters
pDC | Pointer to a valid device context.
rcClipBox | The rectangular area of the control that is invalid.

Reimplemented from CXTPPopupBar.

◆ DrawItem()

virtual void DrawItem ( LPDRAWITEMSTRUCT lpDrawItemStruct )
protectedvirtual

This member function is called to draw the combobox.

Parameters
lpDrawItemStruct A long pointer to a DRAWITEMSTRUCT structure. The structure contains information about the item to be drawn and the type of drawing required.

◆ GetListBoxCtrl()

CListBox * GetListBoxCtrl ( ) const
Returns
Retrieves list box window.

◆ IsCustomizable()

virtual BOOL IsCustomizable ( ) const
inlineprotectedvirtual

Call this member to retrieve the customize mode of the command bars.

Returns
TRUE if command bars are in customized mode, otherwise FALSE.

Reimplemented from CXTPCommandBar.

◆ MeasureItem()

virtual void MeasureItem ( LPMEASUREITEMSTRUCT lpMeasureItemStruct )
protectedvirtual

Override this method and fill in the MEASUREITEMSTRUCT structure to inform Windows of the list-box dimensions.

Parameters
lpMeasureItemStruct Specifies a long pointer to a MEASUREITEMSTRUCT structure.

◆ OnHookKeyDown()

virtual BOOL OnHookKeyDown | ( | UINT | nChar,
 |  | LPARAM | lParam )
 protectedvirtual

The framework calls this member function when a non-system key is pressed.

Parameters
nChar | Specifies the virtual key code of the given key.
lParam | Specifies additional message-dependent information.
Returns
TRUE if key handled, otherwise FALSE

Reimplemented from CXTPPopupBar.

◆ OnHookMessage()

int OnHookMessage | ( | HWND | hWnd,
 |  | UINT | nMessage,
 |  | WPARAM & | wParam,
 |  | LPARAM & | lParam,
 |  | LRESULT & | lResult )
 protectedvirtual

This member function is called by WindowProc, or is called during message reflection.

Parameters
hWnd | Window handle that the message belongs to.
nMessage | Specifies the message to be sent.
wParam | Specifies additional message-dependent information.
lParam | Specifies additional message-dependent information.
lResult | The return value of WindowProc. Depends on the message; may be NULL.
Returns
A non-zero value if a hooked message is processed, 0 otherwise.

Reimplemented from CXTPCommandBar.

◆ Popup()

virtual BOOL Popup | ( | CXTPControlPopup * | pControlPopup,
 |  | BOOL | bSelectFirst = FALSE )
 protectedvirtual

This method is called, then the pop-up bar becomes visible.

Parameters
pControlPopup | Pointer to a CXTPControlPopup object.
bSelectFirst | TRUE to select the first item.
Returns
TRUE if successful; otherwise FALSE.

Reimplemented from CXTPCommandBar.

◆ ProcessHookKeyDown()

BOOL ProcessHookKeyDown | ( | CXTPControlComboBox * | pComboBox,
 |  | UINT | nChar,
 |  | LPARAM | lParam )
 protected

This method is called to process key down events.

Parameters
pComboBox | Owner combobox pointer.
nChar | Specifies the virtual key code of the given key.
lParam | Keystroke-message information.
Returns
TRUE if the message was processed, otherwise FALSE.

◆ SetTrackingMode()

virtual BOOL SetTrackingMode | ( | int | bMode,
 |  | BOOL | bSelectFirst,
 |  | BOOL | bKeyboard = FALSE )
 protectedvirtual

Call this member to change the tracking state.

Parameters
bMode | TRUE to set the tracking mode, otherwise FALSE.
bSelectFirst | TRUE to select the first item.
bKeyboard | TRUE if the item is pop-up'ed by the keyboard.
See also
IsTrackingMode.
Returns
TRUE if the method was successful, otherwise FALSE.

Reimplemented from CXTPPopupBar.

The documentation for this class was generated from the following file:
  • XTPControlComboBox.h


Toolkit Pro: CXTPControlComboBoxPopupBar Class Reference

Public Member Functions | List of all members
CXTPControlComboBoxPopupBar Class Reference

CXTPControlComboBoxPopupBar is a CXTPPopupBar derived class. More...

Inheritance diagram for CXTPControlComboBoxPopupBar:
[legend]

Public Member Functions

CXTPControlComboBoxPopupBar ()
Constructs a CXTPControlComboBoxPopupBar object.
- Public Member Functions inherited from CXTPPopupBar
void | SetTearOffPopup (LPCTSTR lpszCaption, UINT nID, int nWidth=400)
This method adds the tear-off state to the pop-up bar.
BOOL | IsTearOffPopup (CString &strCaption, UINT &nID, int &nWidth)
Determines if the pop-up bar has the tear-off state.
virtual BOOL | IsVisible () const
Call this member to determine if the pop-up menu is visible/displayed.
BOOL | Popup (int xPos, int yPos, LPCRECT rcExclude)
This method opens the pop-up bar.
BOOL | Popup (CXTPControlPopup *pControlPopup, BOOL bSelectFirst=FALSE)
This method opens the pop-up bar.
CXTPControlPopup * | GetControlPopup () const
Call this member to retrieve the control's pop-up.
void | ExpandBar ()
This method expands the bar.
BOOL | DestroyWindow ()
Call this member to destroy the window.
void | SetPopupToolBar (BOOL bToolBarType)
Call this method to make the pop-up bar look like a pop-up toolbar.
void | SetDefaultItem (UINT uItem, BOOL fByPos=FALSE)
Sets the default menu item for the specified pop-up bar.
UINT | GetDefaultItem (UINT gmdiFlags, BOOL fByPos=FALSE)
Determines the default menu item on the specified pop-up bar.
BOOL | IsDoubleGripper () const
Call this method to determine if the pop-up bar has a double gripper.
void | SetDoubleGripper (BOOL bDoubleGripper=TRUE)
Call this member to set a double gripper for the pop-up bar.
virtual BOOL | IsPopupBar () const
Call this member function to determine if the command bar is a CXTPPopupBar.
BOOL | IsContextMenu () const
Determines if the pop-up bar is a context menu.
void | PumpMessage ()
Translates all messages in the message queue.
virtual CSize | CalcDynamicLayout (int nLength, DWORD dwMode)
This method is called to get the size of the command bar.
virtual BOOL | Create ()
Creates the pop-up bar.
virtual CRect | CalculatePopupRect (CPoint ptPopup, CSize sz)
This method is called to calculate the destination rectangle of the pop-up bar.
void | SetPopupFlags (DWORD dwPopupFlags)
Call this method to set the pop-up direction.
virtual BOOL | SetTrackingMode (int bMode, BOOL bSelectFirst=TRUE, BOOL bKeyboard=FALSE)
Call this member to change the tracking state.
void | SetBorders (CRect rcBorders)
Sets the toolbar's borders.
void | DisableShadow ()
Disables shadow use.
BOOL | IsResizable () const
Determines if the control can be resized by the user.
virtual CRect | GetBorders ()
Call this method to get the border margins of the command bar.
- Public Member Functions inherited from CXTPCommandBar
int | IsTrackingMode () const
Call this member to get the tracking state.
CXTPControls * | GetControls () const
Call this member to get the controls collection.
void | SetControls (CXTPControls *pControls)
Call this member to set the controls collection of the command bar.
XTPBarType | GetType () const
Call this member to get the type of the command bar.
void | SetTextOrientation (XTPBarTextOrientation nTextOrientation)
Call this member to change text orientation.
XTPBarTextOrientation | GetTextOrientation () const
Call this member to get the text orientation.
XTPBarPosition | GetPosition () const
Call this member to get the position of the command bar.
void | DelayLayout ()
Call this member to recalculate the layout.
virtual BOOL | LoadMenu (CMenu *pMenu, BOOL bRemoveControls=TRUE)
Call this member to convert menu items to command bar controls.
CXTPControl * | GetControl (int nIndex) const
Call this member to return the control at the specified index.
int | GetControlCount () const
Call this member to get the count of the controls.
CXTPControl * | GetSelected () const
Call this member to get the currently selected control.
BOOL | SetPopuped (int nPopuped, BOOL bKeyboard=FALSE)
Call this member to pop-up the specified control.
void | SetTitle (LPCTSTR lpszTitle)
Call this member to set a title for this command bar.
CString | GetTitle () const
Call this member to get a title for this command bar.
CXTPCommandBars * | GetCommandBars () const
Call this member to get the command bar's object.
void | SetCommandBars (CXTPCommandBars *pCommandBars)
Call this member to set the command bar's object.
CWnd * | GetSite () const
Call this member to get the command bar's site.
CFrameWnd * | GetFrameSite () const
Call this member to get the command bar's site as CFrameWnd.
void | SetFlags (DWORD dwFlagsAdd, DWORD dwFlagsRemove=0)
Call this member to set the command bar's flags.
BOOL | SetButtons (UINT *pButtons, int nCount)
Call this member to set the controls from the button array.
virtual BOOL | LoadToolBar (UINT nIDResource, BOOL bLoadIcons=TRUE)
Call this member function to load the toolbar specified by nIDResource.
void | SetIconSize (CSize size)
Call this function to set the size of the actual bitmapped images to be added to a toolbar.
virtual CSize | GetIconSize () const
Call this member function to get the size of the toolbar icon.
CSize | GetLargeIconSize (BOOL bAutoSize) const
Call this method to get the large icon size of the toolbar.
void | SetButtonSize (CSize size)
Sets the size of the buttons in the command bar.
virtual CSize | GetButtonSize () const
Call this function to get the size of the command bar button.
void | ShowTextBelowIcons (BOOL bTextBelow=TRUE)
Call this member to show the caption below control's icon.
BOOL | IsTextBelowIcons () const
Checks whether the caption is below the control's icon.
HWND | GetTrackFocus () const
Call this method to retrieve the current focused control.
void | SetTrackFocus (HWND hwnd)
Call this method to set focus to the window.
virtual void | SetVisible (BOOL bVisible)
Call this method to set the visibility state of the control.
virtual BOOL | SetPosition (XTPBarPosition barPosition)
Call this member function to set the position of the command bar.
int | FindAccel (TCHAR chAccel) const
Call this method to get the index of the control with the specified accelerator character.
int | FindAccelEx (UINT chAccel, BOOL &bSelectOnly) const
Call this method to get the index of the control with the specified accelerator character.
BOOL | IsCustomizeMode () const
Call this method to check if the command bars are in customize mode.
virtual DROPEFFECT | OnCustomizeDragEnter (CXTPControl *pDataObject, CPoint point)
This member is called when a control is entered into the command bar.
virtual void | OnCustomizeDragLeave ()
This method is called when a control leaves the command bar.
virtual DROPEFFECT | OnCustomizeDragOver (CXTPControl *pDataObject, CPoint point)
This member is called when control is over the command bar.
virtual void | OnCustomizeDrop (CXTPControl *pDataObject, DROPEFFECT &dropEffect, CPoint ptDrop, CPoint ptDrag)
This method is called when a control is dropped to the command bar.
virtual BOOL | IsCustomizable () const
Call this method to check if the command bar is customizable.
BOOL | IsCustomizeDialogPresent () const
Call this method to check if the command bar is present in Customize dialog.
void | EnableCustomization (BOOL bEnable=TRUE)
Call this method to enable/disable customization of the command bar.
virtual void | OnTrackLost ()
Call this method to remove the tracking state of the command bar.
virtual void | OnTrackEnter ()
Call this method to track the command bar.
CWnd * | GetOwnerSite () const
Call this method to retrieve the owner window of the command bar.
void | InvalidateParents ()
Call this method to redraw all parent command bars.
DWORD | GetFlags () const
Call this method to retrieve the current behavior modification flags of the command bar.
UINT | GetBarID () const
Call this method to retrieve the identifier of the command bar.
void | SetBarID (UINT nID)
Call this method to set the identifier of the command bar.
virtual void | OnControlSelected (BOOL bSelected, CXTPControl *pControl)
This method is called when a child control becomes selected.
BOOL | SetStatusText (const CString &strDescription)
This method is called to set the description context.
void | SetCommandBarData (DWORD_PTR dwData)
This method sets the 32-bit value associated with the command bar.
DWORD_PTR | GetCommandBarData () const
This method retrieves the application-supplied, 32-bit value associated with the command bar.
CXTPCommandBar * | GetRootParent () const
Call this method to retrieve the top-level parent command bar.
CXTPPaintManager * | GetPaintManager () const
Call this method to retrieve the paint manager.
CXTPImageManager * | GetImageManager () const
Call this method to retrieve the image manager.
void | SetWidth (int nWidth)
Call this member to set the width of the floated or pop-up toolbar.
int | GetWidth () const
Call this member to get the width of the floated or pop-up toolbar.
void | SetPaintManager (CXTPPaintManager *pPaintManager)
Call this member to set the specified paint manager.
void | SetImageManager (CXTPImageManager *pImageManager)
Call this member to set the specified image manager.
BOOL | IsLayoutRTL () const
Call this member function to determine if the command bar layout is Right-to-Left (RTL).
virtual BOOL | IsDialogBar () const
Call this member function to determine if the command bar is a CXTPDialogBar.
virtual BOOL | IsRibbonBar () const
Call this member function to determine if the command bar is a CXTPRibbonBar.
virtual BOOL | IsMenuTitleBar () const
Call this member function to determine if the command bar is a CXTPMenuTitleBar.
virtual BOOL | IsKeyboardCuesVisible () const
Determines if underlines are visible in the command bar control.
void | SetGrabFocus (BOOL bGrabFocus)
This method is called internally to prevent the command bar from grabbing edit focus.
virtual void | Redraw (LPCRECT lpRect=0, BOOL bAnimate=TRUE)
The framework calls this member function to redraw the command bar.
void | EnableAnimation (BOOL bEnable=TRUE)
Call this method to enable animation for the command bar.
void | EnableDoubleBuffer (BOOL bEnable=TRUE)
Call this method to enable double buffer for toolbar drawing.
BOOL | IsAnimationEnabled () const
Determines if animation is enabled for the specified command bar.
virtual int | OnHookMessage (HWND hWnd, UINT nMessage, WPARAM &wParam, LPARAM &lParam, LRESULT &lResult)
This member function is called by WindowProc, or is called during message reflection.
virtual void | EnsureVisible (CXTPControl *pControl)
Call this method to ensure that a specified control is visible on the toolbar.
XTPButtonStyle | GetDefaultButtonStyle () const
Call this method to retrieve the default button style of the command bar.
void | SetDefaultButtonStyle (XTPButtonStyle buttonStyle)
Call this method to set the default button style of the command bar.
void | LockRedraw ()
Call this method to freeze redrawing until UnlockRedraw is called.
void | UnlockRedraw ()
Call this method to unfreeze redrawing.
void | SetShowGripper (BOOL bShow)
Call this method to set the visibility of the command bar's gripper.
BOOL | GetShowGripper () const
Call this method to check if the command bar's gripper is visible.
virtual void | FillCommandBarEntry (CDC *pDC)
This method is called to draw the background of the command bar.
BOOL | IsKeyboardTipsVisible () const
Call this method to check if keyboard tips are visible for the command bar.
virtual void | CreateKeyboardTips ()
This method is called to create a keyboard tips collection for the command bar.
void | OnKeyboardTipChar (UINT chAccel)
This method is called when the user presses a key while keyboard tips are visible.
virtual void | OnKeyboardTip (CXTPCommandBarKeyboardTip *pTip)
This method is called when a keyboard tip is found for the command bar.
void | HideKeyboardTips ()
Call this method to hide keyboard tips.
void | LockMouseMove (CXTPControl *pControl)
Locks the mouse cursor for a specified control.
void | UnlockMouseMove ()
Unlocks the mouse cursor.
- Public Member Functions inherited from CXTPHookManagerHookAble
CXTPHookManagerHookAble ()
Constructs a CXTPHookManagerHookAble object.
virtual | ~CXTPHookManagerHookAble ()
Destroys a CXTPHookManagerHookAble object, handles cleanup and deallocation.
virtual int | OnPostHookMessage (HWND hWnd, UINT nMessage, WPARAM &wParam, LPARAM &lParam, LRESULT &lResult)
This member function is called after a message has been processed by default window procedure.
virtual void | OnHookAttached (HWND hWnd)
This member function is called right after a hook is attached to the window.
virtual void | OnHookDetached ()
This member function is called right before a hook is to be detached from the window.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPPopupBar
static CXTPPopupBar *AFX_CDECL | CreatePopupBar (CXTPCommandBars *pCommandBars)
Creates a pop-up bar object.
- Public Attributes inherited from CXTPCommandBar
int | m_nStateFlags
State of the command bars.
BOOL | m_bComboBar
TRUE if it is combobox list.
BOOL | m_bTrackOnHover
TRUE to select item if mouse stay over control.
- Public Attributes inherited from CXTPHookManagerHookAble
BOOL | m_bAutoDestroy
TRUE to automatically delete hook.
- Static Public Attributes inherited from CXTPPopupBar
static double | m_dMaxWidthDivisor
Maximum available width of pop-up.
- Static Public Attributes inherited from CXTPCommandBar
static int | s_nHoverDelay
Hover delay time.
static int | s_nExpandDelay
Expand delay time.
static int | s_nExpandHoverDelay
Expand hover delay.
- Protected Member Functions inherited from CXTPPopupBar
CXTPPopupBar ()
Constructs a CXTPPopupBar object.
virtual | ~CXTPPopupBar ()
Destroys a CXTPPopupBar object, handles cleanup and deallocation.
virtual void | DelayRedraw ()
Redraw the pop-up bar.
virtual BOOL | SetSelected (int nSelected, BOOL bKeyboard=FALSE)
Call this member to select the specified control.
void | UpdateLocation (CSize sz)
This method sets the pop-up bar's position.
virtual void | UpdateFlags ()
Update flags.
void | UpdateExpandingState ()
Update expanding state.
virtual void | DrawCommandBar (CDC *pDC, CRect rcClipBox)
This method is called to draw the command bar in the given context.
virtual void | OnControlsChanged ()
This method is called when the controls array is changed.
virtual void | OnRecalcLayout ()
This method is called to recalculate the command bar layout.
CXTPCommandBar * | GetParentCommandBar () const
Call this member to retrieve the parent command bar.
virtual void | DoPropExchange (CXTPPropExchange *pPX)
Either reads this object from or writes this object to an archive.
virtual void | Copy (CXTPCommandBar *pCommandBar, BOOL bRecursive=FALSE)
Call this method make a copy of the command bar.
virtual BOOL | OnHookKeyDown (UINT nChar, LPARAM lParam)
The framework calls this member function when a non-system key is pressed.
virtual void | AdjustExcludeRect (CRect &rc, BOOL bVertical)
Updates rectangle to set the position where the child pop-up bar becomes visible.
virtual void | Animate ()
Animates pop-up window.
- Protected Member Functions inherited from CXTPCommandBar
CXTPCommandBar ()
Constructs a CXTPCommandBar object.
virtual | ~CXTPCommandBar ()
Destroys a CXTPCommandBar object, handles cleanup and deallocation.
virtual BOOL | ProcessSpecialKey (XTPSpecialKey key)
This method is called to process special keys.
virtual int | OnMouseHitTest (CPoint pt)
This method is called to determine mouse hit code.
virtual void | UpdateShortcuts ()
Updates the control's shortcuts.
UINT | GetActiveDocTemplate () const
Retrieves the active MDI document template.
virtual void | GenerateCommandBarList (DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam)
This method is called to assign self identifiers for the serialization process.
virtual void | RestoreCommandBarList (CXTPCommandBarList *pCommandBarList)
This method is called in the serialization process to restore pop-ups from a list of command bars.
BOOL | IsHelpMode () const
Determines if the parent frame is in help mode.
virtual void | OnRemoved ()
This method is called when a toolbar is removed from the command bars collection.
- Protected Attributes inherited from CXTPPopupBar
CXTPControlPopup * | m_pControlPopup
Control that pop-up'ed the bar.
CPoint | m_ptPopup
Position of the bar.
CRect | m_rcExclude
Excluded area.
DWORD | m_popupFlags
Flags of the bar.
BOOL | m_bDynamicLayout
TRUE if DynamicLayout routine executed.
BOOL | m_bCollapsed
TRUE if pop-up bar is collapsed.
BOOL | m_bExpanded
TRUE if pop-up bar is expanded.
BOOL | m_bExpanding
TRUE if pop-up bar is expanding.
BOOL | m_bTearOffPopup
TRUE if pop-up bar has tear-off option.
CRect | m_rcTearOffGripper
Tear-off gripper position.
CRect | m_rcResizeGripper
Resizable gripper position.
BOOL | m_bResizable
TRUE to allow resize.
BOOL | m_bTearOffSelected
TRUE if gripper selected.
UINT_PTR | m_nTearOffTimer
Tear-off timer.
BOOL | m_bTearOffTracking
Tear-off tracking mode.
CSize | m_szTearOffBar
Size of the bar.
CXTPToolBar * | m_pTearOffBar
Tear-off toolbar pointer.
CString | m_strTearOffCaption
Caption of the Tear-off toolbar.
UINT | m_nTearOffID
ID of the Tear-off toolbar.
int | m_nTearOffWidth
Width of the Tear-off toolbar.
BOOL | m_bShowShadow
TRUE to show the shadow.
CRect | m_rcBorders
Borders of the bar.
BOOL | m_bDoubleGripper
TRUE if pop-up is state pop-up type.
BOOL | m_bContextMenu
TRUE if pop-up bar is context menu.
int | m_nMaxHeight
Maximum height the pop-up bar can become.
- Protected Attributes inherited from CXTPCommandBar
BOOL | m_bGrabFocus
TRUE to grab current focus.
int | m_nMRUWidth
Recent width.
int | m_nSelected
Selected control index.
int | m_nPopuped
Pop-up'ed control index.
HWND | m_hwndFocus
The handle of the window that currently has focus.
UINT | m_nBarID
Command bar's identifier.
BOOL | m_bTracking
TRUE if the command bar is in tracking mode.
CWnd * | m_pSite
Command bar's site.
DWORD | m_nIdleFlags
Idle flags.
DWORD | m_dwFlags
Command bar's flags.
DWORD | m_dwStyle
Command bar's styles.
CString | m_strTitle
Command bar's caption.
XTPBarType | m_barType
Type of the command bar.
CXTPControls * | m_pControls
A pointer to controls collection.
XTPBarPosition | m_barPosition
Position of the command bar.
CXTPCommandBars * | m_pCommandBars
parent command bars class.
CWnd * | m_pOwner
Owner window.
CSize | m_szIcons
Size of the command bar's icons.
CSize | m_szButtons
Size of the command bar's buttons.
BOOL | m_bTextBelow
TRUE if text is shown below the CommandBar buttons.
BOOL | m_bExecOnRButton
TRUE if the control button is executed on a right-click.
BOOL | m_bIgnoreUpdateHandler
TRUE to skip update handler for all child controls.
BOOL | m_bRecursePopup
TRUE if pop-up bar was opened recursively.
BOOL | m_bKeyboardSelect
TRUE if last item was selected by keyboard.
BOOL | m_bCloseable
TRUE if the CommandBar can be closed and-or Hidden.
BOOL | m_bCustomizable
TRUE if command bar is customizable.
CRect | m_rcMarker
Marker position.
BOOL | m_bVerticalMarker
TRUE to draw marker vertically.
DWORD_PTR | m_dwData
The 32-bit value associated with the command bar.
UINT * | m_pReturnCmd
Return command holder.
BOOL | m_bCustomizeDialogPresent
TRUE if the command bar is present in Customize dialog.
BOOL | m_bAnimatePopup
TRUE to animate pop-up bar.
BOOL | m_nLockRedraw
TRUE if all drawing routines skipped.
CXTPPaintManager * | m_pPaintManager
Selected paint manager for command bar.
CXTPImageManager * | m_pImageManager
Selected image manager for command bar.
BOOL | m_bMultiLine
True if multi line commandbar.
XTPButtonStyle | m_buttonStyle
Default button Style.
XTPBarTextOrientation | m_nTextOrientation
Commandbar text orientation.
CXTPToolTipContext * | m_pToolTipContext
Tool tip Context.
CXTPCommandBarAnimation * | m_pAnimation
Animation context.
CSize | m_szButtonSpacing
Spacing used between toolbar buttons.

Detailed Description

CXTPControlComboBoxPopupBar is a CXTPPopupBar derived class.

It represents the base class for combo pop-ups.

The documentation for this class was generated from the following file:
  • XTPControlComboBox.h


Toolkit Pro: CXTPControlCustom Class Reference

Public Member Functions | Static Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPControlCustom Class Reference

CXTPControlCustom is a CXTPControlButton derived class. More...

Inheritance diagram for CXTPControlCustom:
[legend]

Public Member Functions

CXTPControlCustom ()
Constructs a CXTPControlCustom object.
~CXTPControlCustom ()
Destroys a CXTPControlCustom object, handles cleanup and deallocation.
void | SetControl (CWnd *pWnd)
Call this method to attach the window to the control.
CWnd * | GetControl ()
Call this method to retrieve the child window of the control.
void | SetSize (CSize szControl)
This method sets the child window size.
void | SetBorders (int cxRight, int cxTop, int cxLeft, int cxBottom)
This method sets the margins of the child window.
void | SetVerticalPositionOption (XTPControlCustomVerticalOptions options)
Call this method to set vertical options to the control.
virtual void | OnEnabledChanged ()
This method is called when the control's enabled state is changed.
- Public Member Functions inherited from CXTPControlButton
CXTPControlButton ()
Constructs a CXTPControlButton object.
virtual | ~CXTPControlButton ()
Destroys a CXTPControlButton object, handles cleanup and deallocation.
void | SetStyleEx (XTPButtonStyle buttonStyle)
Call this member to set the style of the button containing vector icon.
XTPButtonStyle | GetStyleEx () const
Call this member to get the button's style containing vector icon.
- Public Member Functions inherited from CXTPControl
void | SetStyle (XTPButtonStyle buttonStyle)
Call this member to set the style of the control.
XTPButtonStyle | GetStyle () const
Call this member to get the control's style.
void | SetCaption (LPCTSTR lpszCaption)
Call this member to set the caption of the control.
void | SetCaption (UINT nIDCaption)
Call this member to set the caption of the control.
virtual CString | GetCaption () const
Call this member to get the control's caption.
void | SetShortcutText (LPCTSTR lpszShortcutText)
Call this member to set the shortcut string to the control.
CString | GetShortcutText () const
Call this member to get the control's shortcut.
void | SetDescription (LPCTSTR lpszDescription)
Call this member to set the description of the control.
virtual CString | GetDescription () const
Call this member to get the control's description.
void | SetTooltip (LPCTSTR lpszTooltip)
Call this member to set the tooltip of the control.
virtual CString | GetTooltip () const
Call this member to get the control's tooltip.
void | SetKeyboardTip (LPCTSTR lpszKeyboardTip)
Call this member to set the keyboard tip to the control.
CString | GetKeyboardTip () const
Call this member to get the keyboard tip.
void | SetCustomShortcutText (LPCTSTR lpszCustomShortcutText)
Call this member to set the text displayed for the shortcut in a pop-up menu.
CString | GetCustomShortcutText () const
Call this member to get the control's text displayed for the shortcut in a pop-up menu.
void | SetParameter (LPCTSTR lpszParameter)
Call this member to set the parameter of the control.
CString | GetParameter () const
Call this member to get the control's parameter.
void | SetID (int nId)
Call this member to set the identifier of the control.
int | GetID () const
Call this member to get the control's identifier.
long | GetIndex () const
Call this member to get the index of the control.
void | SetIconId (int nId)
Call this member to set the control icon's identifier.
int | GetIconId () const
Call this member to get the icon's identifier.
void | SetHelpId (int nId)
Call this member to set the control help identifier.
int | GetHelpId () const
Call this member to get the help identifier.
virtual void | SetBeginGroup (BOOL bBeginGroup)
Call this member to begin a new group using a separator.
BOOL | GetBeginGroup () const
Call this member to determine if the control has a separator.
virtual void | SetEnabled (BOOL bEnabled)
Call this member to enable/disable the control.
BOOL | GetEnabled () const
Call this member to check if the control is enabled.
virtual void | SetChecked (BOOL bChecked)
Call this member to set the checked state of the control.
BOOL | GetChecked () const
Call this member to get the checked state of the control.
virtual int | GetSelected () const
Call this member to check if the control is selected.
void | SetOnQuickAccess (BOOL bOnQuicAccess=FALSE)
Call this member to set whether a control should be a part of the Quick Access panel.
BOOL | IsOnQuickAccess () const
Call this member to check if a control is a part of the Quick Access panel.
virtual void | SetFocused (BOOL bFocused)
Call this member to set the focused state of the control.
virtual BOOL | IsFocused () const
Call this member to check the focused state of the control.
void | SetPressed (BOOL bPressed)
Call this member to set the pressed state of the control.
virtual BOOL | GetPressed () const
Call this member to check the pressed state of the control.
CRect | GetRect () const
Call this member to get the bounding rectangle of the control.
CXTPCommandBar * | GetParent () const
Call this member to get the parent command bar.
virtual BOOL | IsVisible (DWORD dwSkipFlags=0) const
Call this member to determine if the control is visible.
virtual BOOL | IsCaptionVisible () const
Call this member to determine if the caption of the control is visible.
void | SetVisible (BOOL bVisible)
Call this member to set the visibility of the control.
CXTPControls * | GetControls () const
Call this member to get the parent controls collection.
XTPControlType | GetType () const
Call this member to get the control's type.
void | SetFlags (DWORD dwFlags)
Call this member to set the flags of the control.
DWORD | GetFlags () const
Call this member to retrieve control special flags.
void | SetTag (DWORD_PTR dwTag)
This method sets the 32-bit value associated with the control.
DWORD_PTR | GetTag () const
This method retrieves the application-supplied, 32-bit value associated with the control.
virtual BOOL | Compare (CXTPControl *pOther)
Call this member to compare controls.
virtual CXTPCommandBar * | GetCommandBar () const
Call this member to get the child command bar.
void | SetCloseSubMenuOnClick (BOOL bCloseOnClick)
Call this member function to enable/disable the closing of sub-menus when a control is clicked in the menu.
BOOL | GetCloseSubMenuOnClick () const
Call this member function to check if sub-menus will close as soon as a control is clicked.
void | SetExecuteOnPressInterval (int nExecuteOnPressInterval)
Call this method to set the delay (in milliseconds) between WM_COMMAND messages while a button is pressed by the user.
int | GetExecuteOnPressInterval () const
Call this method to get the delay (in milliseconds) between WM_COMMAND messages while a button is pressed by the user.
CXTPRibbonGroup * | GetRibbonGroup () const
Returns the ribbon group that the control belongs to.
virtual BOOL | IsTransparent () const
Determines if the control needs to draw its background.
void | SetHideWrap (BOOL bHide)
This method is called to hide the control.
BOOL | SetHideFlag (XTPControlHideFlags dwFlag, BOOL bSet)
Call this member to set/remove hide flags.
DWORD | GetHideFlags () const
Call this method to retrieve hidden flags.
CRect | GetRowRect () const
Call this method to retrieve the position of the control's row.
BOOL | GetWrap () const
Call this method to check if the control is wrapped.
void | SetRowRect (CRect rcRow)
Call this method to set the row of the control.
void | SetWrap (BOOL bWrap)
Call this member to set the control to wrapped.
BOOL | GetExpanded () const
Call this member to check if the control is expanded.
BOOL | IsCursorOver () const
Call this member to determine if the mouse pointer is over the control.
virtual void | OnExecute ()
This method is called when the control is executed.
void | DelayRedrawParent ()
Call this method to redraw the parent command bar.
void | DelayLayoutParent ()
Call this method to recalculate the parent command bar size.
void | SetCategory (LPCTSTR lpszCategory)
Call this method to set the category of the control.
CString | GetCategory () const
Call this method to retrieve the category of the control.
CXTPImageManager * | GetImageManager () const
Call this method to retrieve the image manager.
CXTPPaintManager * | GetPaintManager () const
Call this method to retrieve the paint manager.
virtual CXTPImageManagerIcon * | GetImage (int nWidth=16) const
Call this method to retrieve the image of the control.
void | AssignDocTemplate (UINT nIDResource)
Call this method to assign a document template to the control.
void | ExcludeDocTemplate (UINT nIDResource)
Call this method to exclude the document template from control.
BOOL | IsItemDefault () const
Call this method to check if a control is a default menu item.
void | SetItemDefault (BOOL bDefault)
Call this method to set a control to be a default menu item.
BOOL | IsTemporary () const
Call this method to determine if a control is temporary.
void | Reset ()
Call this member to reset the icon and caption of a control to its default settings before it was customized by the user.
void | SetPrompt (LPCTSTR lpszPrompt)
Call this member to load a string from a STRINGTABLE resource to set the tooltip and description of a control.
void | SetCustomIcon (HICON hIcon)
Call this member to set a custom icon to this control.
virtual void | OnUnderlineActivate ()
This method is called when the user activates the control using its underline.
virtual BOOL | GetPopuped () const
Call this member to get the control's pop-up state.
void | RedrawParent (BOOL bAnimate=TRUE)
This method is called to redraw the parent command bar.
LRESULT | NotifySite (UINT code)
This method is called to send message code to the parent site window.
LRESULT | NotifySite (UINT code, NMXTPCONTROL *pNM)
This method is called to send message code to the parent site window.
LRESULT | NotifySite (CWnd *pSite, UINT code, NMXTPCONTROL *pNM)
This method is called to send message code to the parent site window.
virtual void | SetAction (CXTPControlAction *pAction)
Call this method to manually assign an action for control.
CXTPControlAction * | GetAction () const
Call this method to retrieve an action associated with control.
virtual void | OnThemeChanged ()
This method is called when the paint manager theme is changed.
virtual void | SetWidth (int nWidth)
Call this member to set the width of the control.
virtual void | SetHeight (int nHeight)
Call this member to set the height of the control.
int | GetWidth () const
Call this member to get the width of the control.
int | GetHeight () const
Call this member to get the height of the control.
BOOL | HasDwmCompositedRect () const
This method is called to determine if control has a Vista DWM transparent area.
virtual CSize | GetButtonSize () const
Call this function to get the size of the command bar button.
virtual CSize | GetIconSize () const
Call this member function to get the size of a toolbar icon.
void | SetIconSize (CSize szIcon)
Call this member function to set the size of an icon for an individual control.
virtual BOOL | IsCustomizeMovable () const
This method is called to determine if control can be repositioned in customize mode.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.
- Public Member Functions inherited from CXTPHookManagerHookAble
CXTPHookManagerHookAble ()
Constructs a CXTPHookManagerHookAble object.
virtual | ~CXTPHookManagerHookAble ()
Destroys a CXTPHookManagerHookAble object, handles cleanup and deallocation.
virtual int | OnPostHookMessage (HWND hWnd, UINT nMessage, WPARAM &wParam, LPARAM &lParam, LRESULT &lResult)
This member function is called after a message has been processed by default window procedure.
virtual void | OnHookAttached (HWND hWnd)
This member function is called right after a hook is attached to the window.
virtual void | OnHookDetached ()
This member function is called right before a hook is to be detached from the window.

Static Public Member Functions

static CXTPControlCustom *AFX_CDECL | CreateControlCustom (CWnd *pWndChild)
Call this method to create a new CXTPControlCustom object with pWndChild as a child window.
- Static Public Member Functions inherited from CXTPControl
static CXTPControl *AFX_CDECL | FromUI (CCmdUI *pCmdUI)
Call this member to retrieve CXTPControl from a CCmdUI structure.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Protected Member Functions

virtual void | SetRect (CRect rcControl)
Call this member to set the bounding rectangle of the control.
virtual CSize | GetSize (CDC *pDC)
This method is called to determine the size of the control.
virtual void | Draw (CDC *pDC)
This method is called to draw the control.
virtual void | SetHideFlags (DWORD dwFlags)
This method is called to hide the control.
virtual void | OnActionChanged (int nProperty)
This method is called when the action property is changed.
virtual void | OnCalcDynamicSize (DWORD dwMode)
This method is called before recalculating the parent command bar size to calculate the dimensions of the control.
virtual void | DoPropExchange (CXTPPropExchange *pPX)
Either eads this object from or writes this object to an archive.
virtual void | Copy (CXTPControl *pControl, BOOL bRecursive=FALSE)
This method is called to copy the control.
virtual void | OnClick (BOOL bKeyboard=FALSE, CPoint pt=CPoint(0, 0))
This method is called when the user clicks the control.
virtual BOOL | DoCustomDragOver (CXTPCommandBar *pCommandBar, CPoint point, DROPEFFECT &dropEffect)
The implementation may implement a custom drag over handling logic in this method.
int | OnHookMessage (HWND hWnd, UINT nMessage, WPARAM &wParam, LPARAM &lParam, LRESULT &lResult)
This member function is called by WindowProc, or is called during message reflection.
virtual void | OnRemoved ()
This method is called when a control is removed from the parent controls collection.
- Protected Member Functions inherited from CXTPControlButton
virtual void | OnLButtonUp (CPoint point)
This member is called when the user releases the left mouse button.
- Protected Member Functions inherited from CXTPControl
CXTPControl ()
Constructs a CXTPControl object.
virtual | ~CXTPControl ()
Destroys a CXTPControl object, handles cleanup and deallocation.
virtual BOOL | IsFocusable () const
This method is called to check if the control can accept focus.
void | SetIndex (int nIndex)
This method is called to assign the order of the control in the controls list.
void | SetExpanded (BOOL bExpanded)
This method is called to set the control's expanded state.
virtual BOOL | OnHookKeyDown (UINT nChar, LPARAM lParam)
This method is called when a non-system key is pressed.
virtual BOOL | OnHookMouseWheel (UINT nFlags, short zDelta, CPoint point)
This method is called when the user rotates the mouse wheel.
virtual void | SetParent (CXTPCommandBar *pParent)
This method is called to assign a parent command bar object.
void | ScreenToClient (CPoint *point)
The ScreenToClient function converts the screen coordinates of a specified point on the screen.
void | ClickToolBarButton (CRect rcActiveRect=CRect(0, 0, 0, 0))
This helper method is called when the user clicks the toolbar's button.
virtual BOOL | OnSetPopup (BOOL bPopup)
This method is called to pop-up the control.
virtual void | OnLButtonDown (CPoint point)
This member is called when the user presses the left mouse button down.
virtual BOOL | OnRButtonDown (CPoint point)
This member is called when the user press the right mouse button.
virtual BOOL | OnRButtonUp (CPoint point)
This member is called when the user releases the right mouse button.
virtual BOOL | OnLButtonDblClk (CPoint point)
This member is called when the user double-clicks the left mouse button.
virtual void | OnMouseMove (CPoint point)
This member is called when the mouse cursor moves.
virtual void | OnMouseHover ()
Called after the mouse hovers over the control.
virtual BOOL | OnSetSelected (int bSelected)
This method is called when the control becomes selected.
BOOL | IsCustomizeMode () const
Call this method to determine if command bars is in customize mode.
virtual void | CustomizeStartDrag (CPoint point)
This member is called when the user starts to drag the control in customize mode.
virtual BOOL | CustomizeStartResize (CPoint point)
This method is called when user starts to resize control in customize mode.
virtual void | OnCustomizeDragOver (CXTPControl *pDataObject, CPoint point, DROPEFFECT &dropEffect)
This member is called when the user moves the mouse over the control.
virtual BOOL | IsCustomizeResizeAllow () const
This member checks if the user can resize the control.
virtual int | GetCustomizeMinWidth () const
Retrieves the available minimum width of control.
virtual int | GetCustomizeMinHeight () const
Retrieves available minimum height of the control.
void | OnCustomizeMouseMove (CPoint point)
This member is called when the mouse cursor moves in customized mode.
virtual void | OnIdleUpdate ()
This virtual method is called in idle-time processing.
virtual INT_PTR | OnToolHitTest (CPoint point, TOOLINFO *pTI) const
The framework calls this member function to determine whether a point is in the bounding rectangle of the specified tool.
virtual void | RestoreCommandBarList (CXTPCommandBarList *pCommandBarList)
This method is called from LoadCommandBars to restore controls and its child command bars.
virtual void | GenerateCommandBarList (DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam)
This method is called from SaveCommandBars to save all child command bars.
virtual void | OnActionChanging (int nProperty)
This method is called when an action property is about to be changed.
virtual void | OnCaptionChanged ()
This method is called when the control's caption is changed.
BOOL | IsLayoutRTL () const
Determines if right-to-left (RTL) mode is set.
BOOL | IsLayoutChanged ()
Call this member to determine if the layout has changed (RTL to LTR or LTR to RLT).

Protected Attributes

HWND | m_hwndControl
The child window.
CRect | m_rcBorders
Borders.
BOOL | m_bControlVisible
TRUE if child window is visible.
CSize | m_szControl
Size of the control.
XTPControlCustomVerticalOptions | m_verticalOptions
Vertical options.
int | m_nControlID
ID of the custom control.
- Protected Attributes inherited from CXTPControlButton
XTPButtonStyle | m_buttonStyleEx
User-defined style of button containing vector icon.
- Protected Attributes inherited from CXTPControl
DWORD_PTR | m_nTag
Control tag.
int | m_nIndex
Index of the control.
int | m_nId
Identifier of the control.
int | m_nIconId
Identifier of the control's image.
int | m_nHelpId
Help identifier.
int | m_nCustomIconId
Identifier of the control's custom image.
BOOL | m_bWrap
TRUE if the control is wrapped.
BOOL | m_bBeginGroup
TRUE if the control starts new group.
BOOL | m_bEnabled
TRUE if the control is enabled.
BOOL | m_bChecked
TRUE if the control is checked.
BOOL | m_bSelected
TRUE if the control is selected.
BOOL | m_bPressed
TRUE if the control is pushed.
BOOL | m_bTemporary
TRUE if the control is temporary.
BOOL | m_bOnQuickAccess
TRUE if the control is a part of Quick Access panel.
CRect | m_rcRow
Bounding rectangle of the control's row.
CRect | m_rcControl
Bounding rectangle of the control.
DWORD | m_dwHideFlags
Hidden flags.
DWORD | m_dwFlags
Flags of the control.
CString | m_strCaption
Caption of the control.
CString | m_strCustomCaption
User-defined caption.
CString | m_strShortcutText
Shortcut text.
CString | m_strShortcutTextAuto
Shortcut text.
CString | m_strTooltipText
Tooltip text.
CString | m_strDescriptionText
Description text.
CString | m_strParameter
Parameter text.
CString | m_strKeyboardTip
Keyboard tip.
CXTPControls * | m_pControls
Parent control collection.
XTPControlType | m_controlType
Type of the control.
CXTPCommandBar * | m_pParent
The Parent command bar.
BOOL | m_bExpanded
TRUE if the control is expanded.
CString | m_strCategory
Category of the control.
BOOL | m_bDefaultItem
TRUE if the item is default pop-up item.
CDocTemplateMap | m_mapDocTemplatesAssigned
Assigned templates.
CDocTemplateMap | m_mapDocTemplatesExcluded
Excluded templates.
XTPButtonStyle | m_buttonStyle
Button Style.
XTPButtonStyle | m_buttonCustomStyle
User-defined style of button.
XTPButtonStyle | m_buttonRibbonStyle
User-defined style of button.
BOOL | m_bCloseSubMenuOnClick
TRUE is sub-menus are closed as soon as a control is clicked.
CXTPRibbonGroup * | m_pRibbonGroup
Ribbon group of control.
CXTPControlAction * | m_pAction
Action of the control.
int | m_nWidth
Width of the control.
int | m_nHeight
Height of the control.
int | m_nExecuteOnPressInterval
Delay between each message when control is pressed.
CSize | m_szIcon
The size of the icon used for the control.
BOOL | m_bLayoutRTL
Indicate does last layout is RTL.

Additional Inherited Members

- Public Attributes inherited from CXTPHookManagerHookAble
BOOL m_bAutoDestroy
TRUE to automatically delete hook.

Detailed Description

CXTPControlCustom is a CXTPControlButton derived class.

It represents the control with some child window.

Member Function Documentation

◆ Copy()

virtual void Copy | ( | CXTPControl * | pControl,
 |  | BOOL | bRecursive = FALSE )
 protectedvirtual

This method is called to copy the control.

Parameters
pControl | Pointer to a source CXTPControl object
bRecursive | TRUE to copy recursively.

Reimplemented from CXTPControlButton.

◆ CreateControlCustom()

static CXTPControlCustom *AFX_CDECL CreateControlCustom ( CWnd * pWndChild )
static

Call this method to create a new CXTPControlCustom object with pWndChild as a child window.

Parameters
pWndChild Pointer to the child window.
Returns
Pointer to new CXTPControlCustom object.

◆ DoCustomDragOver()

virtual BOOL DoCustomDragOver | ( | CXTPCommandBar * | pCommandBar,
 |  | CPoint | point,
 |  | DROPEFFECT & | dropEffect )
 protectedvirtual

The implementation may implement a custom drag over handling logic in this method.

Parameters
pCommandBar | Pointer to a CXTPCommandBar object.
point | Mouse position.
dropEffect | DROPEFFECT enumerator.
Returns
TRUE if custom implementation handles drag over, otherwise FALSE.

Reimplemented from CXTPControl.

◆ DoPropExchange()

virtual void DoPropExchange ( CXTPPropExchange * pPX )
protectedvirtual

Either eads this object from or writes this object to an archive.

Parameters
pPX A CXTPPropExchange object to serialize to or from.

Reimplemented from CXTPControlButton.

◆ Draw()

virtual void Draw ( CDC * pDC )
protectedvirtual

This method is called to draw the control.

Parameters
pDC Pointer to a valid device context.

Reimplemented from CXTPControl.

◆ GetControl()

CWnd * GetControl ( )

Call this method to retrieve the child window of the control.

Returns
A pointer to a CWnd object.

◆ GetSize()

virtual CSize GetSize ( CDC * pDC )
protectedvirtual

This method is called to determine the size of the control.

Parameters
pDC Pointer to a valid device context
Returns
A CSize object containing the size of the control.

Reimplemented from CXTPControl.

◆ OnActionChanged()

virtual void OnActionChanged ( int nProperty )
protectedvirtual

This method is called when the action property is changed.

Parameters
nProperty Property of the action.
See also
OnActionChanging

Reimplemented from CXTPControl.

◆ OnCalcDynamicSize()

virtual void OnCalcDynamicSize ( DWORD dwMode )
protectedvirtual

This method is called before recalculating the parent command bar size to calculate the dimensions of the control.

Parameters
dwMode Flags used to determine the height and width of the dynamic command bar. See Remarks section for a list of values.

The following predefined flags are used to determine the height and width of the dynamic command bar. Use the bitwise-OR (|) operator to combine the flags.

LM_STRETCH: Indicates whether the command bar should be stretched to the size of the frame. Set if the bar is not a docking bar (not available for docking). Not set when the bar is docked or floating (available for docking). If set, LM_STRETCH returns dimensions based on the LM_HORZ state. LM_STRETCH works similarly to the the bStretch parameter used in CalcFixedLayout; see that member function for more information about the relationship between stretching and orientation. LM_HORZ: Indicates that the bar is horizontally or vertically oriented. Set if the bar is horizontally oriented, and if it is vertically oriented, it is not set. LM_HORZ works similarly to the the bHorz parameter used in CalcFixedLayout; see that member function for more information about the relationship between stretching and orientation. LM_MRUWIDTH: Most Recently Used Dynamic Width. Uses the remembered most recently used width. LM_HORZDOCK: Horizontal Docked Dimensions. Returns the dynamic size with the largest width. LM_VERTDOCK: Vertical Docked Dimensions. Returns the dynamic size with the largest height. LM_COMMIT: Resets LM_MRUWIDTH to current width of floating command bar.

The framework calls this member function to calculate the dimensions of a dynamic command bar.

Override this member function to provide your own layout in classes you derive from CXTPControl. XTP classes derived from CXTPControl, such as CXTPControlComboBox, override this member function to provide their own implementation.

See also
CXTPControlComboBox, CXTPControl, CXTPControlEdit, CXTPControlWindowList, CXTPControlWorkspaceActions, CXTPControlToolbars, CXTPControlOleItems, CXTPControlRecentFileList, CXTPControlSelector, CXTPControlListBox

Reimplemented from CXTPControl.

◆ OnClick()

virtual void OnClick | ( | BOOL | bKeyboard = FALSE,
 |  | CPoint | pt = CPoint(0, 0) )
 protectedvirtual

This method is called when the user clicks the control.

Parameters
bKeyboard | TRUE if the control is selected using the keyboard.
pt | Mouse cursor position.

Reimplemented from CXTPControlButton.

◆ OnHookMessage()

int OnHookMessage | ( | HWND | hWnd,
 |  | UINT | nMessage,
 |  | WPARAM & | wParam,
 |  | LPARAM & | lParam,
 |  | LRESULT & | lResult )
 protectedvirtual

This member function is called by WindowProc, or is called during message reflection.

Parameters
hWnd | Window handle that the message belongs to.
nMessage | Specifies the message to be sent.
wParam | Specifies additional message-dependent information.
lParam | Specifies additional message-dependent information.
lResult | The return value of WindowProc. Depends on the message; may be NULL.
Returns
A non-zero value if a hooked message is processed, 0 otherwise.

Reimplemented from CXTPHookManagerHookAble.

◆ SetBorders()

void SetBorders | ( | int | cxRight,
 |  | int | cxTop,
 |  | int | cxLeft,
 |  | int | cxBottom )

This method sets the margins of the child window.

Parameters
cxRight | Right border gap.
cxTop | Top border gap.
cxLeft | Left border gap.
cxBottom | Bottom border gap.

◆ SetControl()

void SetControl ( CWnd * pWnd )

Call this method to attach the window to the control.

Parameters
pWnd Pointer to a child CWnd object.

◆ SetHideFlags()

virtual void SetHideFlags ( DWORD dwFlags )
protectedvirtual

This method is called to hide the control.

Parameters
dwFlags Reasons to hide.
See also
XTPControlHideFlags

Reimplemented from CXTPControl.

◆ SetRect()

virtual void SetRect ( CRect rcControl )
protectedvirtual

Call this member to set the bounding rectangle of the control.

Parameters
rcControl Bounding rectangle of the control.

Reimplemented from CXTPControl.

◆ SetSize()

void SetSize ( CSize szControl )

This method sets the child window size.

Parameters
szControl Size of the child window.

◆ SetVerticalPositionOption()

void SetVerticalPositionOption ( XTPControlCustomVerticalOptions options )

Call this method to set vertical options to the control.

Parameters
options XTPControlCustomVerticalOptions type to be set. Can be any of the values listed in the Remarks section.

Vertical options refer to how the control will be displayed when the toolbar it docked vertically. It can be one of the following: xtpVerticalHide: To hide control. xtpVerticalShow: To show control. xtpVerticalButton: To show control as button.

See also
XTPControlCustomVerticalOptions
The documentation for this class was generated from the following file:
  • XTPControlCustom.h


Toolkit Pro: CXTPControlEdit Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPControlEdit Class Reference

CXTPControlEdit is a CXTPControl derived class. More...

Inheritance diagram for CXTPControlEdit:
[legend]

Public Member Functions

CXTPControlEdit ()
Constructs a CXTPControlEdit object.
virtual | ~CXTPControlEdit ()
Destroys a CXTPControlEdit object, handles cleanup and deallocation.
virtual CXTPControlEditCtrl * | CreateEditControl ()
This method creates an edit control.
CEdit * | GetEditCtrl () const
Call this member to get the edit control.
CString | GetEditText () const
Call this member to get the edit control text.
void | SetEditText (const CString &strText)
Call this member to set the edit control text.
void | SetEditHint (LPCTSTR lpszEditHint)
Call this member to set the grayed-out text displayed in the edit control which provides a helpful description of what the control is used for.
CString | GetEditHint () const
Call this member to get the grayed-out text displayed in the edit control which provides a helpful description of what the control is used for.
void | EnableShellAutoComplete (DWORD dwFlags=SHACF_FILESYSTEM|SHACF_URLALL)
This member function enables or disables shell auto completion.
void | ShowLabel (BOOL bShow)
Call this member to show the label of the control.
virtual BOOL | IsCaptionVisible () const
Call this member to determine if the caption of the control is visible.
BOOL | IsImageVisible () const
Determines if the icon is visible for edit control.
BOOL | IsLabeled () const
Call this member to determine if the control has a visible label.
void | ShowSpinButtons (BOOL bShow=TRUE)
Call this method to show spin buttons for edit control.
BOOL | IsSpinButtonsVisible () const
Determines if edit control has spin buttons.
void | ShowBuddyButton (int nButtonId)
Call this method to show the command (buddy) button for edit control.
BOOL | IsBuddyButtonVisible () const
Call this method to check if the buddy button is visible.
void | DoPropExchange (CXTPPropExchange *pPX)
Either reads this object from or writes this object to an archive.
virtual void | OnEnabledChanged ()
This method is called when control's enabled state is changed.
DWORD | GetEditStyle () const
Call this member to get the style of an edit control.
void | SetEditStyle (DWORD dwStyle)
Call this member to set the style of an edit control.
void | SetReadOnly (BOOL bReadOnly=TRUE)
Calls this function to set the read-only state of an edit control.
BOOL | GetReadOnly () const
Call this function to check if an edit control is read-only.
virtual BOOL | Compare (CXTPControl *pOther)
Call this member to compare controls.
int | GetLabelWidth () const
Call this method to get the width of the label.
void | SetLabelWidth (int nLabelWidth)
Call this method to set the width of the label.
BOOL | HasFocus () const
Call this method to determine if edit control has focus.
virtual void | SetFocused (BOOL bFocused)
Call this member to set the focused state of the control.
virtual BOOL | IsFocused () const
Call this member to get the focused state of the control.
CRect | GetSpinButtonsRect () const
Returns spin buttons' bounding rectangle.
virtual void | SetHideFlags (DWORD dwFlags)
This method is called to hide the control.
virtual void | OnActionChanged (int nProperty)
This method is called when an action property is changed.
virtual void | OnActionChanging (int nProperty)
This method is called when an action property is about to be changed.
virtual void | DrawEditText (CDC *pDC, CRect rcText)
This method draws the text of a control.
void | SetTextLimit (int nTextLimit)
This method sets the maximum text length that the user may enter into an edit control.
int | GetTextLimit () const
This method gets the maximum text length that the user may enter into an edit control.
void | SetEditIconId (int nId)
Call this member to set the edit icon's identifier.
int | GetEditIconId () const
Call this member to get the edit icon's identifier.
BOOL | SetNumericOnly (BOOL bNumericOnly=TRUE)
Call this member to allow only digits to be entered into the edit control.
BOOL | IsNumericOnly () const
Call this member to check if only digits can be entered into the edit control.
- Public Member Functions inherited from CXTPControl
void | SetStyle (XTPButtonStyle buttonStyle)
Call this member to set the style of the control.
XTPButtonStyle | GetStyle () const
Call this member to get the control's style.
void | SetCaption (LPCTSTR lpszCaption)
Call this member to set the caption of the control.
void | SetCaption (UINT nIDCaption)
Call this member to set the caption of the control.
virtual CString | GetCaption () const
Call this member to get the control's caption.
void | SetShortcutText (LPCTSTR lpszShortcutText)
Call this member to set the shortcut string to the control.
CString | GetShortcutText () const
Call this member to get the control's shortcut.
void | SetDescription (LPCTSTR lpszDescription)
Call this member to set the description of the control.
virtual CString | GetDescription () const
Call this member to get the control's description.
void | SetTooltip (LPCTSTR lpszTooltip)
Call this member to set the tooltip of the control.
virtual CString | GetTooltip () const
Call this member to get the control's tooltip.
void | SetKeyboardTip (LPCTSTR lpszKeyboardTip)
Call this member to set the keyboard tip to the control.
CString | GetKeyboardTip () const
Call this member to get the keyboard tip.
void | SetCustomShortcutText (LPCTSTR lpszCustomShortcutText)
Call this member to set the text displayed for the shortcut in a pop-up menu.
CString | GetCustomShortcutText () const
Call this member to get the control's text displayed for the shortcut in a pop-up menu.
void | SetParameter (LPCTSTR lpszParameter)
Call this member to set the parameter of the control.
CString | GetParameter () const
Call this member to get the control's parameter.
void | SetID (int nId)
Call this member to set the identifier of the control.
int | GetID () const
Call this member to get the control's identifier.
long | GetIndex () const
Call this member to get the index of the control.
void | SetIconId (int nId)
Call this member to set the control icon's identifier.
int | GetIconId () const
Call this member to get the icon's identifier.
void | SetHelpId (int nId)
Call this member to set the control help identifier.
int | GetHelpId () const
Call this member to get the help identifier.
virtual void | SetBeginGroup (BOOL bBeginGroup)
Call this member to begin a new group using a separator.
BOOL | GetBeginGroup () const
Call this member to determine if the control has a separator.
virtual void | SetEnabled (BOOL bEnabled)
Call this member to enable/disable the control.
BOOL | GetEnabled () const
Call this member to check if the control is enabled.
virtual void | SetChecked (BOOL bChecked)
Call this member to set the checked state of the control.
BOOL | GetChecked () const
Call this member to get the checked state of the control.
virtual int | GetSelected () const
Call this member to check if the control is selected.
void | SetOnQuickAccess (BOOL bOnQuicAccess=FALSE)
Call this member to set whether a control should be a part of the Quick Access panel.
BOOL | IsOnQuickAccess () const
Call this member to check if a control is a part of the Quick Access panel.
void | SetPressed (BOOL bPressed)
Call this member to set the pressed state of the control.
virtual BOOL | GetPressed () const
Call this member to check the pressed state of the control.
CRect | GetRect () const
Call this member to get the bounding rectangle of the control.
CXTPCommandBar * | GetParent () const
Call this member to get the parent command bar.
virtual BOOL | IsVisible (DWORD dwSkipFlags=0) const
Call this member to determine if the control is visible.
void | SetVisible (BOOL bVisible)
Call this member to set the visibility of the control.
CXTPControls * | GetControls () const
Call this member to get the parent controls collection.
XTPControlType | GetType () const
Call this member to get the control's type.
void | SetFlags (DWORD dwFlags)
Call this member to set the flags of the control.
DWORD | GetFlags () const
Call this member to retrieve control special flags.
void | SetTag (DWORD_PTR dwTag)
This method sets the 32-bit value associated with the control.
DWORD_PTR | GetTag () const
This method retrieves the application-supplied, 32-bit value associated with the control.
virtual CXTPCommandBar * | GetCommandBar () const
Call this member to get the child command bar.
void | SetCloseSubMenuOnClick (BOOL bCloseOnClick)
Call this member function to enable/disable the closing of sub-menus when a control is clicked in the menu.
BOOL | GetCloseSubMenuOnClick () const
Call this member function to check if sub-menus will close as soon as a control is clicked.
void | SetExecuteOnPressInterval (int nExecuteOnPressInterval)
Call this method to set the delay (in milliseconds) between WM_COMMAND messages while a button is pressed by the user.
int | GetExecuteOnPressInterval () const
Call this method to get the delay (in milliseconds) between WM_COMMAND messages while a button is pressed by the user.
CXTPRibbonGroup * | GetRibbonGroup () const
Returns the ribbon group that the control belongs to.
virtual BOOL | IsTransparent () const
Determines if the control needs to draw its background.
void | SetHideWrap (BOOL bHide)
This method is called to hide the control.
BOOL | SetHideFlag (XTPControlHideFlags dwFlag, BOOL bSet)
Call this member to set/remove hide flags.
DWORD | GetHideFlags () const
Call this method to retrieve hidden flags.
CRect | GetRowRect () const
Call this method to retrieve the position of the control's row.
BOOL | GetWrap () const
Call this method to check if the control is wrapped.
void | SetRowRect (CRect rcRow)
Call this method to set the row of the control.
void | SetWrap (BOOL bWrap)
Call this member to set the control to wrapped.
BOOL | GetExpanded () const
Call this member to check if the control is expanded.
BOOL | IsCursorOver () const
Call this member to determine if the mouse pointer is over the control.
virtual void | OnExecute ()
This method is called when the control is executed.
virtual CSize | GetSize (CDC *pDC)
This method is called to determine the size of the control.
virtual void | Draw (CDC *pDC)
This method is called to draw the control.
void | DelayRedrawParent ()
Call this method to redraw the parent command bar.
void | DelayLayoutParent ()
Call this method to recalculate the parent command bar size.
void | SetCategory (LPCTSTR lpszCategory)
Call this method to set the category of the control.
CString | GetCategory () const
Call this method to retrieve the category of the control.
CXTPImageManager * | GetImageManager () const
Call this method to retrieve the image manager.
CXTPPaintManager * | GetPaintManager () const
Call this method to retrieve the paint manager.
virtual CXTPImageManagerIcon * | GetImage (int nWidth=16) const
Call this method to retrieve the image of the control.
void | AssignDocTemplate (UINT nIDResource)
Call this method to assign a document template to the control.
void | ExcludeDocTemplate (UINT nIDResource)
Call this method to exclude the document template from control.
BOOL | IsItemDefault () const
Call this method to check if a control is a default menu item.
void | SetItemDefault (BOOL bDefault)
Call this method to set a control to be a default menu item.
BOOL | IsTemporary () const
Call this method to determine if a control is temporary.
void | Reset ()
Call this member to reset the icon and caption of a control to its default settings before it was customized by the user.
void | SetPrompt (LPCTSTR lpszPrompt)
Call this member to load a string from a STRINGTABLE resource to set the tooltip and description of a control.
void | SetCustomIcon (HICON hIcon)
Call this member to set a custom icon to this control.
virtual BOOL | GetPopuped () const
Call this member to get the control's pop-up state.
void | RedrawParent (BOOL bAnimate=TRUE)
This method is called to redraw the parent command bar.
LRESULT | NotifySite (UINT code)
This method is called to send message code to the parent site window.
LRESULT | NotifySite (UINT code, NMXTPCONTROL *pNM)
This method is called to send message code to the parent site window.
LRESULT | NotifySite (CWnd *pSite, UINT code, NMXTPCONTROL *pNM)
This method is called to send message code to the parent site window.
virtual void | SetAction (CXTPControlAction *pAction)
Call this method to manually assign an action for control.
CXTPControlAction * | GetAction () const
Call this method to retrieve an action associated with control.
virtual void | OnThemeChanged ()
This method is called when the paint manager theme is changed.
virtual void | SetWidth (int nWidth)
Call this member to set the width of the control.
virtual void | SetHeight (int nHeight)
Call this member to set the height of the control.
int | GetWidth () const
Call this member to get the width of the control.
int | GetHeight () const
Call this member to get the height of the control.
BOOL | HasDwmCompositedRect () const
This method is called to determine if control has a Vista DWM transparent area.
virtual CSize | GetButtonSize () const
Call this function to get the size of the command bar button.
virtual CSize | GetIconSize () const
Call this member function to get the size of a toolbar icon.
void | SetIconSize (CSize szIcon)
Call this member function to set the size of an icon for an individual control.
virtual BOOL | IsCustomizeMovable () const
This method is called to determine if control can be repositioned in customize mode.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

virtual BOOL | IsFocusable () const
This method is called to check if a control can accept focus.
virtual void | OnMouseHover ()
Called after the mouse hovers over the control.
virtual void | OnMouseMove (CPoint point)
This member is called when the mouse cursor moves.
virtual void | OnSetFocus (CWnd *pOldWnd)
This method is called when the edit control gets focus.
virtual void | OnKillFocus ()
This method is called when the edit control loses focus.
virtual void | DeflateEditRect (CRect &rcControl)
This method is called to get the real rect of the edit control of CEdit.
BOOL | OnSetSelected (int bSelected)
This method is called when the control becomes selected.
void | SetRect (CRect rcControl)
Call this member to set the bounding rectangle of the control.
virtual void | OnEditChanged ()
This method is called when edit control's text is changed.
virtual CHARFORMAT2 | GetDefaultCharFormat ()
This method is called to get the default char format of rich edit text.
void | OnClick (BOOL bKeyboard=FALSE, CPoint pt=CPoint(0, 0))
This method is called when the user clicks the control.
virtual void | OnUnderlineActivate ()
This method is called when the user activates a control using its underline.
void | Copy (CXTPControl *pControl, BOOL bRecursive=FALSE)
This method is called to copy the control.
BOOL | OnHookKeyDown (UINT nChar, LPARAM lParam)
This method is called when a non-system key is pressed.
virtual void | OnCalcDynamicSize (DWORD dwMode)
This method is called before recalculating the parent command bar size to calculate the dimensions of the control.
void | SetParent (CXTPCommandBar *pParent)
This method is called to assign a parent command bar object.
virtual BOOL | IsCustomizeResizeAllow () const
This member checks if the user can resize the control.
virtual int | GetCustomizeMinWidth () const
This member returns the minimum width that the edit control can be sized to by the user while in customization mode.
virtual void | OnRemoved ()
This method is called when a control is removed from the parent controls collection.
- Protected Member Functions inherited from CXTPControl
CXTPControl ()
Constructs a CXTPControl object.
virtual | ~CXTPControl ()
Destroys a CXTPControl object, handles cleanup and deallocation.
void | SetIndex (int nIndex)
This method is called to assign the order of the control in the controls list.
void | SetExpanded (BOOL bExpanded)
This method is called to set the control's expanded state.
virtual BOOL | OnHookMouseWheel (UINT nFlags, short zDelta, CPoint point)
This method is called when the user rotates the mouse wheel.
void | ScreenToClient (CPoint *point)
The ScreenToClient function converts the screen coordinates of a specified point on the screen.
void | ClickToolBarButton (CRect rcActiveRect=CRect(0, 0, 0, 0))
This helper method is called when the user clicks the toolbar's button.
virtual BOOL | OnSetPopup (BOOL bPopup)
This method is called to pop-up the control.
virtual void | OnLButtonUp (CPoint point)
This member is called when the user releases the left mouse button.
virtual void | OnLButtonDown (CPoint point)
This member is called when the user presses the left mouse button down.
virtual BOOL | OnRButtonDown (CPoint point)
This member is called when the user press the right mouse button.
virtual BOOL | OnRButtonUp (CPoint point)
This member is called when the user releases the right mouse button.
virtual BOOL | OnLButtonDblClk (CPoint point)
This member is called when the user double-clicks the left mouse button.
BOOL | IsCustomizeMode () const
Call this method to determine if command bars is in customize mode.
virtual void | CustomizeStartDrag (CPoint point)
This member is called when the user starts to drag the control in customize mode.
virtual BOOL | CustomizeStartResize (CPoint point)
This method is called when user starts to resize control in customize mode.
virtual void | OnCustomizeDragOver (CXTPControl *pDataObject, CPoint point, DROPEFFECT &dropEffect)
This member is called when the user moves the mouse over the control.
virtual BOOL | DoCustomDragOver (CXTPCommandBar *pCommandBar, CPoint point, DROPEFFECT &dropEffect)
The implementation may implement a custom drag over handling logic in this method.
virtual int | GetCustomizeMinHeight () const
Retrieves available minimum height of the control.
void | OnCustomizeMouseMove (CPoint point)
This member is called when the mouse cursor moves in customized mode.
virtual void | OnIdleUpdate ()
This virtual method is called in idle-time processing.
virtual INT_PTR | OnToolHitTest (CPoint point, TOOLINFO *pTI) const
The framework calls this member function to determine whether a point is in the bounding rectangle of the specified tool.
virtual void | RestoreCommandBarList (CXTPCommandBarList *pCommandBarList)
This method is called from LoadCommandBars to restore controls and its child command bars.
virtual void | GenerateCommandBarList (DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam)
This method is called from SaveCommandBars to save all child command bars.
virtual void | OnCaptionChanged ()
This method is called when the control's caption is changed.
BOOL | IsLayoutRTL () const
Determines if right-to-left (RTL) mode is set.
BOOL | IsLayoutChanged ()
Call this member to determine if the layout has changed (RTL to LTR or LTR to RLT).

Protected Attributes

CXTPControlEditCtrl * | m_pEdit
Inplace edit control.
BOOL | m_bLabel
TRUE if label is visible.
BOOL | m_bReadOnly
TRUE if edit is read-only.
int | m_nLabelWidth
Width of the label.
BOOL | m_bDelayReposition
Need to reposition control.
BOOL | m_bDelayDestroy
Need to reposition control.
CString | m_strEditHint
Edit hint of the controls.
BOOL | m_bFocused
TRUE if edit has focus.
CString | m_strLastText
Last entered text.
CString | m_strEditText
Edit text.
BOOL | m_bEditChanged
TRUE if Edit Text was changed.
CXTPControlComboBoxAutoCompleteWnd * | m_pAutoCompleteWnd
Auto complete window hook.
DWORD | m_dwShellAutoCompleteFlags
Shell auto complete flags.
DWORD | m_dwEditStyle
Edit style.
BOOL | m_bShowSpinButtons
TRUE to show spin buttons.
int | m_nEditIconId
Edit Icon identifier.
int | m_nTextLimit
The maximum number of characters that can be entered into an edit control.
BOOL | m_bNumericOnly
Allows only digits to be entered into the edit control.
- Protected Attributes inherited from CXTPControl
DWORD_PTR | m_nTag
Control tag.
int | m_nIndex
Index of the control.
int | m_nId
Identifier of the control.
int | m_nIconId
Identifier of the control's image.
int | m_nHelpId
Help identifier.
int | m_nCustomIconId
Identifier of the control's custom image.
BOOL | m_bWrap
TRUE if the control is wrapped.
BOOL | m_bBeginGroup
TRUE if the control starts new group.
BOOL | m_bEnabled
TRUE if the control is enabled.
BOOL | m_bChecked
TRUE if the control is checked.
BOOL | m_bSelected
TRUE if the control is selected.
BOOL | m_bPressed
TRUE if the control is pushed.
BOOL | m_bTemporary
TRUE if the control is temporary.
BOOL | m_bOnQuickAccess
TRUE if the control is a part of Quick Access panel.
CRect | m_rcRow
Bounding rectangle of the control's row.
CRect | m_rcControl
Bounding rectangle of the control.
DWORD | m_dwHideFlags
Hidden flags.
DWORD | m_dwFlags
Flags of the control.
CString | m_strCaption
Caption of the control.
CString | m_strCustomCaption
User-defined caption.
CString | m_strShortcutText
Shortcut text.
CString | m_strShortcutTextAuto
Shortcut text.
CString | m_strTooltipText
Tooltip text.
CString | m_strDescriptionText
Description text.
CString | m_strParameter
Parameter text.
CString | m_strKeyboardTip
Keyboard tip.
CXTPControls * | m_pControls
Parent control collection.
XTPControlType | m_controlType
Type of the control.
CXTPCommandBar * | m_pParent
The Parent command bar.
BOOL | m_bExpanded
TRUE if the control is expanded.
CString | m_strCategory
Category of the control.
BOOL | m_bDefaultItem
TRUE if the item is default pop-up item.
CDocTemplateMap | m_mapDocTemplatesAssigned
Assigned templates.
CDocTemplateMap | m_mapDocTemplatesExcluded
Excluded templates.
XTPButtonStyle | m_buttonStyle
Button Style.
XTPButtonStyle | m_buttonCustomStyle
User-defined style of button.
XTPButtonStyle | m_buttonRibbonStyle
User-defined style of button.
BOOL | m_bCloseSubMenuOnClick
TRUE is sub-menus are closed as soon as a control is clicked.
CXTPRibbonGroup * | m_pRibbonGroup
Ribbon group of control.
CXTPControlAction * | m_pAction
Action of the control.
int | m_nWidth
Width of the control.
int | m_nHeight
Height of the control.
int | m_nExecuteOnPressInterval
Delay between each message when control is pressed.
CSize | m_szIcon
The size of the icon used for the control.
BOOL | m_bLayoutRTL
Indicate does last layout is RTL.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControl
static CXTPControl *AFX_CDECL | FromUI (CCmdUI *pCmdUI)
Call this member to retrieve CXTPControl from a CCmdUI structure.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

CXTPControlEdit is a CXTPControl derived class.

It represents an edit control.

Member Function Documentation

◆ Compare()

virtual BOOL Compare ( CXTPControl * pOther )
virtual

Call this member to compare controls.

Parameters
pOther The control to compare with.
Returns
TRUE if the controls are identical, otherwise FALSE.

Reimplemented from CXTPControl.

◆ Copy()

void Copy | ( | CXTPControl * | pControl,
 |  | BOOL | bRecursive = FALSE )
 protectedvirtual

This method is called to copy the control.

Parameters
pControl | Pointer to a source CXTPControl object.
bRecursive | TRUE to copy recursively.

Reimplemented from CXTPControl.

◆ CreateEditControl()

virtual CXTPControlEditCtrl * CreateEditControl ( )
virtual

This method creates an edit control.

Override it to use inherited edit control.

Returns
A pointer to the newly created CXTPControlEditCtrl object.

◆ DeflateEditRect()

virtual void DeflateEditRect ( CRect & rcControl )
protectedvirtual

This method is called to get the real rect of the edit control of CEdit.

Parameters
rcControl Rectangle of Edit area.

◆ DoPropExchange()

void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Either reads this object from or writes this object to an archive.

Parameters
pPX A CXTPPropExchange object to serialize to or from.

Reimplemented from CXTPControl.

◆ DrawEditText()

virtual void DrawEditText | ( | CDC * | pDC,
 |  | CRect | rcText )
 virtual

This method draws the text of a control.

Parameters
pDC | Pointer to a valid device context.
rcText | Rectangle to draw.

◆ EnableShellAutoComplete()

void EnableShellAutoComplete ( DWORD dwFlags = SHACF_FILESYSTEM|SHACF_URLALL )

This member function enables or disables shell auto completion.

Parameters
dwFlags Flags that will be passed to SHAutoComplete function.

Flags can be combined by using the bitwise OR (|) operator. It can be one or more of the following: SHACF_FILESYSTEM: This includes the File System as well as the rest of the shell (Desktop/My Computer/Control Panel/). SHACF_URLALL: Include the URL's in the user's History and Recently Used lists. Equivalent to SHACF_URLHISTORY | SHACF_URLMRU. HACF_URLHISTORY: URLs in the User's History. SHACF_URLMRU: URLs in the user's Recently Used list. SHACF_FILESYS_ONLY: Include only the file system. Do not include virtual folders such as Desktop or Control Panel.

◆ GetCustomizeMinWidth()

AFX_INLINE int GetCustomizeMinWidth ( ) const
protectedvirtual

This member returns the minimum width that the edit control can be sized to by the user while in customization mode.

Returns
Width of label + 10 if the edit control's label is visible, if label is hidden, then it returns 10.

Reimplemented from CXTPControl.

◆ GetDefaultCharFormat()

virtual CHARFORMAT2 GetDefaultCharFormat ( )
protectedvirtual

This method is called to get the default char format of rich edit text.

Returns
Returns default char format of rich edit text

◆ GetEditCtrl()

AFX_INLINE CEdit * GetEditCtrl ( ) const

Call this member to get the edit control.

Returns
A pointer to the CEdit control.

◆ GetEditHint()

CString GetEditHint ( ) const

Call this member to get the grayed-out text displayed in the edit control which provides a helpful description of what the control is used for.

Returns
Edit hint of the control.
See also
SetEditHint

◆ GetEditIconId()

AFX_INLINE int GetEditIconId ( ) const

Call this member to get the edit icon's identifier.

Returns
Edit icon's identifier.

◆ GetEditStyle()

DWORD GetEditStyle ( ) const

Call this member to get the style of an edit control.

Returns
The style of the edit control.
See also
SetEditStyle

◆ GetEditText()

CString GetEditText ( ) const

Call this member to get the edit control text.

Returns
The Edit control text.

◆ GetLabelWidth()

AFX_INLINE int GetLabelWidth ( ) const

Call this method to get the width of the label.

Returns
Width of the label.
See also
SetLabelWidth, ShowLabel, IsLabeled

◆ GetReadOnly()

BOOL GetReadOnly ( ) const

Call this function to check if an edit control is read-only.

Returns
TRUE if the control is read-only, otherwise FALSE.
See also
SetReadOnly

◆ GetSpinButtonsRect()

CRect GetSpinButtonsRect ( ) const

Returns spin buttons' bounding rectangle.

Returns
Spin buttons' bounding rectangle.

◆ GetTextLimit()

int GetTextLimit ( ) const

This method gets the maximum text length that the user may enter into an edit control.

Returns
Maximum text length user can enter.
See also
SetTextLimit

◆ HasFocus()

BOOL HasFocus ( ) const

Call this method to determine if edit control has focus.

Returns
True if edit control has focus, false if not

◆ IsBuddyButtonVisible()

AFX_INLINE BOOL IsBuddyButtonVisible ( ) const

Call this method to check if the buddy button is visible.

Returns
TRUE if the buddy button is visible.
See also
ShowBuddyButton

◆ IsCaptionVisible()

virtual BOOL IsCaptionVisible ( ) const
virtual

Call this member to determine if the caption of the control is visible.

Returns
TRUE if the caption is visible.

Reimplemented from CXTPControl.

◆ IsCustomizeResizeAllow()

AFX_INLINE BOOL IsCustomizeResizeAllow ( ) const
protectedvirtual

This member checks if the user can resize the control.

Returns
TRUE if resize is available, otherwise FALSE.

Reimplemented from CXTPControl.

◆ IsFocusable()

virtual BOOL IsFocusable ( ) const
protectedvirtual

This method is called to check if a control can accept focus.

Returns
True if control can accept focus, false if not
See also
SetFocused

Reimplemented from CXTPControl.

◆ IsFocused()

virtual BOOL IsFocused ( ) const
virtual

Call this member to get the focused state of the control.

Returns
TRUE if the control has focus, otherwise FALSE.

Reimplemented from CXTPControl.

◆ IsImageVisible()

BOOL IsImageVisible ( ) const

Determines if the icon is visible for edit control.

Returns
TRUE if the icon is visible, otherwise FALSE.

◆ IsLabeled()

AFX_INLINE BOOL IsLabeled ( ) const

Call this member to determine if the control has a visible label.

Returns
TRUE if the control has a visible label, otherwise FALSE.

◆ IsNumericOnly()

AFX_INLINE BOOL IsNumericOnly ( ) const

Call this member to check if only digits can be entered into the edit control.

Returns
TRUE if only digits can be entered into the edit control, otherwise FALSE.

◆ IsSpinButtonsVisible()

AFX_INLINE BOOL IsSpinButtonsVisible ( ) const

Determines if edit control has spin buttons.

Returns
TRUE if edit control has spin buttons.
See also
ShowSpinButtons

◆ OnActionChanged()

virtual void OnActionChanged ( int nProperty )
virtual

This method is called when an action property is changed.

Parameters
nProperty Property of the action.
See also
OnActionChanging

Reimplemented from CXTPControl.

◆ OnActionChanging()

virtual void OnActionChanging ( int nProperty )
virtual

This method is called when an action property is about to be changed.

Parameters
nProperty Property of the action.
See also
OnActionChanged

Reimplemented from CXTPControl.

◆ OnCalcDynamicSize()

virtual void OnCalcDynamicSize ( DWORD dwMode )
protectedvirtual

This method is called before recalculating the parent command bar size to calculate the dimensions of the control.

Parameters
dwMode Flags used to determine the height and width of the dynamic command bar. See Remarks section for a list of values.

The following predefined flags are used to determine the height and width of the dynamic command bar. Use the bitwise-OR (|) operator to combine the flags.

LM_STRETCH: Indicates whether the command bar should be stretched to the size of the frame. Set if the bar is not a docking bar (not available for docking). Not set when the bar is docked or floating (available for docking). If set, LM_STRETCH returns dimensions based on the LM_HORZ state. LM_STRETCH works similarly to the the bStretch parameter used in CalcFixedLayout; see that member function for more information about the relationship between stretching and orientation. LM_HORZ: Indicates that the bar is horizontally or vertically oriented. Set if the bar is horizontally oriented, and if it is vertically oriented, it is not set. LM_HORZ works similarly to the the bHorz parameter used in CalcFixedLayout; see that member function for more information about the relationship between stretching and orientation. LM_MRUWIDTH: Most Recently Used Dynamic Width. Uses the remembered most recently used width. LM_HORZDOCK: Horizontal Docked Dimensions. Returns the dynamic size with the largest width. LM_VERTDOCK: Vertical Docked Dimensions. Returns the dynamic size with the largest height. LM_COMMIT: Resets LM_MRUWIDTH to current the width of the floating command bar.

The framework calls this member function to calculate the dimensions of a dynamic command bar.

Override this member function to provide your own layout in classes you derive from CXTPControl. XTP classes derived from CXTPControl, such as CXTPControlComboBox, override this member function to provide their own implementation.

See also
CXTPControlComboBox, CXTPControlCustom, CXTPControl, CXTPControlWindowList, CXTPControlWorkspaceActions, CXTPControlToolbars, CXTPControlOleItems, CXTPControlRecentFileList, CXTPControlSelector, CXTPControlListBox

Reimplemented from CXTPControl.

◆ OnClick()

void OnClick | ( | BOOL | bKeyboard = FALSE,
 |  | CPoint | pt = CPoint(0, 0) )
 protectedvirtual

This method is called when the user clicks the control.

Parameters
bKeyboard | TRUE if the control is selected using the keyboard.
pt | Mouse cursor position.

Reimplemented from CXTPControl.

◆ OnHookKeyDown()

BOOL OnHookKeyDown | ( | UINT | nChar,
 |  | LPARAM | lParam )
 protectedvirtual

This method is called when a non-system key is pressed.

Parameters
nChar | Specifies the virtual key code of the given key.
lParam | Specifies additional message-dependent information.
Returns
TRUE if the key was handled, otherwise FALSE.

Reimplemented from CXTPControl.

◆ OnMouseMove()

virtual void OnMouseMove ( CPoint point )
protectedvirtual

This member is called when the mouse cursor moves.

Parameters
point Specifies the x- and y- coordinates of the cursor.

Reimplemented from CXTPControl.

◆ OnSetFocus()

virtual void OnSetFocus ( CWnd * pOldWnd )
protectedvirtual

This method is called when the edit control gets focus.

Parameters
pOldWnd Pointer to a CWnd object.

◆ OnSetSelected()

BOOL OnSetSelected ( int bSelected )
protectedvirtual

This method is called when the control becomes selected.

Parameters
bSelected TRUE if the control becomes selected.
Returns
TRUE if successful, otherwise FALSE.

Reimplemented from CXTPControl.

◆ SetEditHint()

void SetEditHint ( LPCTSTR lpszEditHint )

Call this member to set the grayed-out text displayed in the edit control which provides a helpful description of what the control is used for.

Parameters
lpszEditHint Edit hint to be set.

Example:

pEdit->SetEditHint(_T("Click to find a contact");
See also
GetEditHint

◆ SetEditIconId()

AFX_INLINE void SetEditIconId ( int nId )

Call this member to set the edit icon's identifier.

Parameters
nId Icon's identifier to be set.

◆ SetEditStyle()

void SetEditStyle ( DWORD dwStyle )

Call this member to set the style of an edit control.

Parameters
dwStyle The style to be set.
See also
GetEditStyle

◆ SetEditText()

void SetEditText ( const CString & strText )

Call this member to set the edit control text.

Parameters
strText New text of the edit control.

◆ SetFocused()

virtual void SetFocused ( BOOL bFocused )
virtual

Call this member to set the focused state of the control.

Parameters
bFocused TRUE to set focus to the control.

Reimplemented from CXTPControl.

◆ SetHideFlags()

virtual void SetHideFlags ( DWORD dwFlags )
virtual

This method is called to hide the control.

Parameters
dwFlags Reasons to hide.
See also
XTPControlHideFlags

Reimplemented from CXTPControl.

◆ SetLabelWidth()

AFX_INLINE void SetLabelWidth ( int nLabelWidth )

Call this method to set the width of the label.

Parameters
nLabelWidth Width of the label to be set.
See also
GetLabelWidth, ShowLabel, IsLabeled

◆ SetNumericOnly()

BOOL SetNumericOnly ( BOOL bNumericOnly = TRUE )

Call this member to allow only digits to be entered into the edit control.

Parameters
bNumericOnly TRUE to enable numeric only mode, FALSE otherwise.
Returns
TRUE if successful, otherwise FALSE.

◆ SetParent()

void SetParent ( CXTPCommandBar * pParent )
protectedvirtual

This method is called to assign a parent command bar object.

Parameters
pParent Pointer to a CXTPCommandBar object.

Reimplemented from CXTPControl.

◆ SetReadOnly()

void SetReadOnly ( BOOL bReadOnly = TRUE )

Calls this function to set the read-only state of an edit control.

Parameters
bReadOnly Specifies whether to set or remove the read-only state of the edit control. A value of TRUE sets the state to read-only; a value of FALSE sets the state to read/write.
See also
GetReadOnly, SetEnabled

◆ SetRect()

void SetRect ( CRect rcControl )
protectedvirtual

Call this member to set the bounding rectangle of the control.

Parameters
rcControl Bounding rectangle of the control.

Reimplemented from CXTPControl.

◆ SetTextLimit()

void SetTextLimit ( int nTextLimit )

This method sets the maximum text length that the user may enter into an edit control.

Parameters
nTextLimit Maximum text length user can enter.
See also
GetTextLimit

◆ ShowBuddyButton()

AFX_INLINE void ShowBuddyButton ( int nButtonId )

Call this method to show the command (buddy) button for edit control.

Parameters
nButtonId Buddy button ID.
See also
IsBuddyButtonVisible

◆ ShowLabel()

AFX_INLINE void ShowLabel ( BOOL bShow )

Call this member to show the label of the control.

Parameters
bShow TRUE to show the label.

◆ ShowSpinButtons()

AFX_INLINE void ShowSpinButtons ( BOOL bShow = TRUE )

Call this method to show spin buttons for edit control.

Parameters
bShow TRUE to show spin buttons.
See also
IsSpinButtonsVisible
The documentation for this class was generated from the following file:
  • XTPControlEdit.h


Toolkit Pro: CXTPControlEditCtrl Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPControlEditCtrl Class Reference

Inplace Edit control of CXTPControlEdit. More...

Inheritance diagram for CXTPControlEditCtrl:
[legend]

Public Member Functions

CXTPControlEdit * | GetControlEdit () const
Retrieves the parent CXTPControlEdit object.
- Public Member Functions inherited from CXTPCommandBarEditCtrl
CXTPCommandBarEditCtrl ()
Constructs a CXTPCommandBarEditCtrl object.
virtual BOOL | OnCmdMsg (UINT nID, int nCode, void *pExtra, AFX_CMDHANDLERINFO *pHandlerInfo)
Called by the framework to route and dispatch command messages and to handle the update of command user-interface objects.
virtual BOOL | OnCommand (WPARAM wParam, LPARAM lParam)
The framework calls this member function when the user selects an item from a menu, when a child control sends a notification message, or when an accelerator keystroke is translated.
virtual BOOL | ShowContextMenu (CXTPControl *pControl, CPoint point)
This member function displays a pop-up context menu.
virtual BOOL | CreateEdit (DWORD dwStyle, CWnd *pParentWnd)
This member function displays a pop-up context menu.
BOOL | IsDialogCode (UINT nChar, LPARAM lParam)
This method determines whether the specified character is intended for an edit.
void | GetWindowTextEx (CString &rString)
Returns window text of edit.
void | SetWindowTextEx (LPCTSTR lpszString)
Sets the window text of edit.
BOOL | IsImeMode () const
Determines if the Input Method Editor(IME) is being used.

Protected Member Functions

void | UpdateCharFormat ()
This method is called to refresh the char format of edit control.
- Protected Member Functions inherited from CXTPCommandBarEditCtrl
CRichEditContext & | GetRichEditContext ()
Call this method to get rich edit version information.
BOOL | IsCommandEnabled (UINT nID)
Determines if edit command is enabled.

Protected Attributes

CXTPControlEdit * | m_pControl
Parent edit control.
- Protected Attributes inherited from CXTPCommandBarEditCtrl
BOOL | m_bImeMode
TRUE if IME editor is currently enabled.
BOOL | m_bComposited
TRUE if control is AERO composited.
BOOL | m_bIgonoreEditChanged
Don't send OnEditChanged.

Detailed Description

Inplace Edit control of CXTPControlEdit.

Member Function Documentation

◆ GetControlEdit()

AFX_INLINE CXTPControlEdit * GetControlEdit ( ) const

Retrieves the parent CXTPControlEdit object.

Returns
Pointer to parent CXTPControlEdit.
The documentation for this class was generated from the following file:
  • XTPControlEdit.h


Toolkit Pro: CXTPControlFontComboBox Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPControlFontComboBox Class Reference

CXTPControlFontComboBox is a CXTPControlComboBox derived class. More...

Inheritance diagram for CXTPControlFontComboBox:
[legend]

Public Member Functions

CXTPControlFontComboBox (DWORD dwStyleListBox=1)
Constructs a CXTPControlFontComboBox object.
virtual | ~CXTPControlFontComboBox ()
Destroys a CXTPControl object, handles cleanup and deallocation.
void | SetCharFormat (CHARFORMAT &cf)
Call this method to set the current font of the picker.
- Public Member Functions inherited from CXTPControlComboBox
CXTPControlComboBox (CXTPCommandBars *pCommandBars=NULL)
Constructs a CXTPControlComboBox object.
virtual | ~CXTPControlComboBox ()
Destroys a CXTPControlComboBox object, handles cleanup and deallocation.
DWORD | GetEditStyle () const
Call this member to get the style of edit control.
void | SetEditStyle (DWORD dwStyle)
Call this member to set the style of edit control.
void | SetDropDownListStyle (BOOL bSet=TRUE)
Call this member to insert/delete an edit box in the combobox when the control has focus.
BOOL | GetDropDownListStyle () const
Call this member to determine if the combobox has an edit control.
void | SetDropDownWidth (int nWidth)
Call this member to set the width of the dropdown list.
void | SetDropDownItemCount (int nDropDownItemCount)
Call this member to set the count of items in the dropdown list.
int | GetDropDownWidth () const
Call this member to retrieve the dropdown list width.
int | AddString (LPCTSTR lpsz)
Call this member function to add a string to a list box.
int | GetCount () const
Call this member to retrieve the number of items in a list box.
void | GetLBText (int nIndex, CString &str) const
Call this member to retrieve a string from the list box of a combobox control.
void | ResetContent ()
Call this member to remove all items from the list box of a combobox control.
int | FindStringExact (int nIndexStart, LPCTSTR lpsz) const
Call this member to find the first list-box string (in a combobox) that matches the string specified in str.
int | InsertString (int nIndex, LPCTSTR lpsz)
Call this member to insert a string into the list box of a combobox control.
virtual CString | GetListBoxText () const
Call this member to get the currently selected item's text.
CXTPControlComboBoxEditCtrl * | GetEditCtrl () const
Call this member to get the edit control of the combobox control.
void | SetCurSel (int nIndex)
Call this member to select a string in the list box of a combobox.
int | GetCurSel () const
Call this member function to determine which item in the combobox is selected.
BOOL | GetDroppedState () const
Call the GetDroppedState member function to determine whether the list box of a drop-down combobox is visible (dropped down).
CString | GetEditText () const
Call this member to get the edit text.
void | ModifyListBoxStyle (DWORD dwRemove, DWORD dwAdd)
Call this member to modify the style of a list box.
void | SetEditText (const CString &lpszText)
Call this member to set the edit control text.
void | SetEditHint (LPCTSTR lpszEditHint)
Call this member to set the grayed-out text displayed in the edit control which provides a helpful description of what the control is used for.
CString | GetEditHint () const
Call this member to get the grayed-out text displayed in the edit control which provides a helpful description of what the control is used for.
virtual CHARFORMAT2 | GetDefaultCharFormat ()
This method is called to get the default char format of rich edit text.
void | EnableShellAutoComplete (DWORD dwFlags=SHACF_FILESYSTEM|SHACF_URLALL)
This member function enables or disables shell auto completion.
void | EnableAutoComplete (BOOL bAutoComplete=TRUE)
This member function enables or disables auto completion.
int | FindString (int nStartAfter, LPCTSTR lpszItem) const
This method finds the first string in a list box that contains the specified prefix, without changing the list-box selection.
DWORD_PTR | GetItemData (int nIndex) const
This method retrieves the application-supplied, 32-bit value associated with the specified combobox item.
int | SetItemData (int nIndex, DWORD_PTR dwItemData)
This method sets the 32-bit value associated with the specified item in a combobox.
void | DeleteItem (long nIndex)
Call this member function to delete a string.
void | OnEnabledChanged ()
This method is called when the control's enabled state is changed.
void | DoPropExchange (CXTPPropExchange *pPX)
Either reads this object from or writes this object to an archive.
virtual BOOL | Compare (CXTPControl *pOther)
Call this member to compare controls.
int | GetLabelWidth () const
Call this method to get the width of a label.
void | SetLabelWidth (int nLabelWidth)
Call this method to set the width of a label.
virtual BOOL | IsCaptionVisible () const
Call this member to determine if the caption of the control is visible.
BOOL | IsImageVisible () const
Call this member to determine if the icon is visible for a combobox control.
int | GetThumbWidth () const
Call this method to get the width of a thumb button.
void | SetThumbWidth (int nThumbWidth)
This method is called to set the width of a thumb button.
BOOL | HasFocus () const
Call this method to determine if control has focus.
virtual void | DrawEditText (CDC *pDC, CRect rcText)
This method draws the text of control if the style is CBS_DROPDOWNLIST.
CListBox * | GetListBoxCtrl () const
CXTPControlComboBoxPopupBar * | GetComboBoxPopupBar () const
void | SetEditIconId (int nId)
Call this member to set the edit icon's identifier.
int | GetEditIconId () const
Call this member to get the edit icon's identifier.
void | SetListIconId (int nId)
Call this member to set the combo list icon's identifier.
int | GetListIconId () const
Call this member to get the combo list icon's identifier.
virtual void | SetFocused (BOOL bFocused)
Call this member to set focus to the control.
virtual BOOL | IsFocused () const
Call this member to get the focused state of the control.
virtual void | OnEditChanged ()
This method is called when edit control's text is changed.
virtual void | OnSelChanged ()
This method is called when the selected string is changed.
virtual void | SetHideFlags (DWORD dwFlags)
This method is called to hide the control.
virtual void | OnActionChanged (int nProperty)
This method is called when an action property is changed.
virtual void | OnActionChanging (int nProperty)
This method is called when an action property is about to be changed.
void | SetTextLimit (int nTextLimit)
This method sets the maximum text length that the user may enter into an edit control.
int | GetTextLimit () const
This method gets the maximum text length that the user may enter into an edit control.
- Public Member Functions inherited from CXTPControlPopup
CXTPControlPopup ()
Constructs a CXTPControlPopup object.
virtual | ~CXTPControlPopup ()
Destroys a CXTPControlPopup object, handles cleanup and deallocation.
void | SetCommandBar (CMenu *pMenu)
Call this member to set the child command bar.
void | SetCommandBar (CXTPCommandBar *pBar)
Call this member to set the child command bar.
CXTPCommandBar * | GetCommandBar () const
Call this member to get the child command bar.
BOOL | GetPopuped () const
Call this member to get the control's pop-up state.
virtual CString | GetCaption () const
Call this member to get the control's caption.
void | DoPropExchange (CXTPPropExchange *pPX)
Either reads this object from or writes this object to an archive.
virtual void | AdjustExcludeRect (CRect &rc, BOOL bVertical)
Updates rectangle to set the position where the child pop-up bar becomes visible.
void | Copy (CXTPControl *pControl, BOOL bRecursive=FALSE)
This method is called to copy the control.
- Public Member Functions inherited from CXTPControlButton
CXTPControlButton ()
Constructs a CXTPControlButton object.
virtual | ~CXTPControlButton ()
Destroys a CXTPControlButton object, handles cleanup and deallocation.
void | SetStyleEx (XTPButtonStyle buttonStyle)
Call this member to set the style of the button containing vector icon.
XTPButtonStyle | GetStyleEx () const
Call this member to get the button's style containing vector icon.
- Public Member Functions inherited from CXTPControl
void | SetStyle (XTPButtonStyle buttonStyle)
Call this member to set the style of the control.
XTPButtonStyle | GetStyle () const
Call this member to get the control's style.
void | SetCaption (LPCTSTR lpszCaption)
Call this member to set the caption of the control.
void | SetCaption (UINT nIDCaption)
Call this member to set the caption of the control.
void | SetShortcutText (LPCTSTR lpszShortcutText)
Call this member to set the shortcut string to the control.
CString | GetShortcutText () const
Call this member to get the control's shortcut.
void | SetDescription (LPCTSTR lpszDescription)
Call this member to set the description of the control.
virtual CString | GetDescription () const
Call this member to get the control's description.
void | SetTooltip (LPCTSTR lpszTooltip)
Call this member to set the tooltip of the control.
virtual CString | GetTooltip () const
Call this member to get the control's tooltip.
void | SetKeyboardTip (LPCTSTR lpszKeyboardTip)
Call this member to set the keyboard tip to the control.
CString | GetKeyboardTip () const
Call this member to get the keyboard tip.
void | SetCustomShortcutText (LPCTSTR lpszCustomShortcutText)
Call this member to set the text displayed for the shortcut in a pop-up menu.
CString | GetCustomShortcutText () const
Call this member to get the control's text displayed for the shortcut in a pop-up menu.
void | SetParameter (LPCTSTR lpszParameter)
Call this member to set the parameter of the control.
CString | GetParameter () const
Call this member to get the control's parameter.
void | SetID (int nId)
Call this member to set the identifier of the control.
int | GetID () const
Call this member to get the control's identifier.
long | GetIndex () const
Call this member to get the index of the control.
void | SetIconId (int nId)
Call this member to set the control icon's identifier.
int | GetIconId () const
Call this member to get the icon's identifier.
void | SetHelpId (int nId)
Call this member to set the control help identifier.
int | GetHelpId () const
Call this member to get the help identifier.
virtual void | SetBeginGroup (BOOL bBeginGroup)
Call this member to begin a new group using a separator.
BOOL | GetBeginGroup () const
Call this member to determine if the control has a separator.
virtual void | SetEnabled (BOOL bEnabled)
Call this member to enable/disable the control.
BOOL | GetEnabled () const
Call this member to check if the control is enabled.
virtual void | SetChecked (BOOL bChecked)
Call this member to set the checked state of the control.
BOOL | GetChecked () const
Call this member to get the checked state of the control.
virtual int | GetSelected () const
Call this member to check if the control is selected.
void | SetOnQuickAccess (BOOL bOnQuicAccess=FALSE)
Call this member to set whether a control should be a part of the Quick Access panel.
BOOL | IsOnQuickAccess () const
Call this member to check if a control is a part of the Quick Access panel.
void | SetPressed (BOOL bPressed)
Call this member to set the pressed state of the control.
virtual BOOL | GetPressed () const
Call this member to check the pressed state of the control.
CRect | GetRect () const
Call this member to get the bounding rectangle of the control.
CXTPCommandBar * | GetParent () const
Call this member to get the parent command bar.
virtual BOOL | IsVisible (DWORD dwSkipFlags=0) const
Call this member to determine if the control is visible.
void | SetVisible (BOOL bVisible)
Call this member to set the visibility of the control.
CXTPControls * | GetControls () const
Call this member to get the parent controls collection.
XTPControlType | GetType () const
Call this member to get the control's type.
void | SetFlags (DWORD dwFlags)
Call this member to set the flags of the control.
DWORD | GetFlags () const
Call this member to retrieve control special flags.
void | SetTag (DWORD_PTR dwTag)
This method sets the 32-bit value associated with the control.
DWORD_PTR | GetTag () const
This method retrieves the application-supplied, 32-bit value associated with the control.
void | SetCloseSubMenuOnClick (BOOL bCloseOnClick)
Call this member function to enable/disable the closing of sub-menus when a control is clicked in the menu.
BOOL | GetCloseSubMenuOnClick () const
Call this member function to check if sub-menus will close as soon as a control is clicked.
void | SetExecuteOnPressInterval (int nExecuteOnPressInterval)
Call this method to set the delay (in milliseconds) between WM_COMMAND messages while a button is pressed by the user.
int | GetExecuteOnPressInterval () const
Call this method to get the delay (in milliseconds) between WM_COMMAND messages while a button is pressed by the user.
CXTPRibbonGroup * | GetRibbonGroup () const
Returns the ribbon group that the control belongs to.
virtual BOOL | IsTransparent () const
Determines if the control needs to draw its background.
void | SetHideWrap (BOOL bHide)
This method is called to hide the control.
BOOL | SetHideFlag (XTPControlHideFlags dwFlag, BOOL bSet)
Call this member to set/remove hide flags.
DWORD | GetHideFlags () const
Call this method to retrieve hidden flags.
CRect | GetRowRect () const
Call this method to retrieve the position of the control's row.
BOOL | GetWrap () const
Call this method to check if the control is wrapped.
void | SetRowRect (CRect rcRow)
Call this method to set the row of the control.
void | SetWrap (BOOL bWrap)
Call this member to set the control to wrapped.
BOOL | GetExpanded () const
Call this member to check if the control is expanded.
BOOL | IsCursorOver () const
Call this member to determine if the mouse pointer is over the control.
virtual CSize | GetSize (CDC *pDC)
This method is called to determine the size of the control.
virtual void | Draw (CDC *pDC)
This method is called to draw the control.
void | DelayRedrawParent ()
Call this method to redraw the parent command bar.
void | DelayLayoutParent ()
Call this method to recalculate the parent command bar size.
void | SetCategory (LPCTSTR lpszCategory)
Call this method to set the category of the control.
CString | GetCategory () const
Call this method to retrieve the category of the control.
CXTPImageManager * | GetImageManager () const
Call this method to retrieve the image manager.
CXTPPaintManager * | GetPaintManager () const
Call this method to retrieve the paint manager.
virtual CXTPImageManagerIcon * | GetImage (int nWidth=16) const
Call this method to retrieve the image of the control.
void | AssignDocTemplate (UINT nIDResource)
Call this method to assign a document template to the control.
void | ExcludeDocTemplate (UINT nIDResource)
Call this method to exclude the document template from control.
BOOL | IsItemDefault () const
Call this method to check if a control is a default menu item.
void | SetItemDefault (BOOL bDefault)
Call this method to set a control to be a default menu item.
BOOL | IsTemporary () const
Call this method to determine if a control is temporary.
void | Reset ()
Call this member to reset the icon and caption of a control to its default settings before it was customized by the user.
void | SetPrompt (LPCTSTR lpszPrompt)
Call this member to load a string from a STRINGTABLE resource to set the tooltip and description of a control.
void | SetCustomIcon (HICON hIcon)
Call this member to set a custom icon to this control.
void | RedrawParent (BOOL bAnimate=TRUE)
This method is called to redraw the parent command bar.
LRESULT | NotifySite (UINT code)
This method is called to send message code to the parent site window.
LRESULT | NotifySite (UINT code, NMXTPCONTROL *pNM)
This method is called to send message code to the parent site window.
LRESULT | NotifySite (CWnd *pSite, UINT code, NMXTPCONTROL *pNM)
This method is called to send message code to the parent site window.
virtual void | SetAction (CXTPControlAction *pAction)
Call this method to manually assign an action for control.
CXTPControlAction * | GetAction () const
Call this method to retrieve an action associated with control.
virtual void | OnThemeChanged ()
This method is called when the paint manager theme is changed.
virtual void | SetWidth (int nWidth)
Call this member to set the width of the control.
virtual void | SetHeight (int nHeight)
Call this member to set the height of the control.
int | GetWidth () const
Call this member to get the width of the control.
int | GetHeight () const
Call this member to get the height of the control.
BOOL | HasDwmCompositedRect () const
This method is called to determine if control has a Vista DWM transparent area.
virtual CSize | GetButtonSize () const
Call this function to get the size of the command bar button.
virtual CSize | GetIconSize () const
Call this member function to get the size of a toolbar icon.
void | SetIconSize (CSize szIcon)
Call this member function to set the size of an icon for an individual control.
virtual BOOL | IsCustomizeMovable () const
This method is called to determine if control can be repositioned in customize mode.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

virtual void | OnExecute ()
This method is called when the control is executed.
- Protected Member Functions inherited from CXTPControlComboBox
virtual BOOL | IsFocusable () const
This method is called to check if a control can accept focus.
virtual CXTPControlComboBoxEditCtrl * | CreateEditControl ()
This method creates an edit control.
void | OnMouseHover ()
Called after the mouse hovers over the control.
virtual void | OnSetFocus (CWnd *pOldWnd)
This method is called when the edit control gets focus.
virtual void | OnKillFocus ()
This method is called when the edit control loses focus.
virtual void | DeflateEditRect (CRect &rcControl)
This method is called to get the real rect of an edit control of a combobox.
BOOL | OnSetSelected (int bSelected)
This method is called when the control becomes selected.
void | SetRect (CRect rcControl)
Call this member to set the bounding rectangle of the control.
void | OnClick (BOOL bKeyboard=FALSE, CPoint pt=CPoint(0, 0))
This method is called when the user clicks the control.
virtual void | OnUnderlineActivate ()
This method is called when the user activates a control using its underline.
void | Copy (CXTPControl *pControl, BOOL bRecursive=FALSE)
This method is called to copy the control.
BOOL | OnHookKeyDown (UINT nChar, LPARAM lParam)
This method is called when a non-system key is pressed.
void | SetParent (CXTPCommandBar *pParent)
This method is called to assign a parent command bar object.
virtual void | OnCalcDynamicSize (DWORD dwMode)
This method is called before recalculating the parent command bar size to calculate the dimensions of the control.
virtual BOOL | OnSetPopup (BOOL bPopup)
This method is called to pop-up the control.
virtual BOOL | IsCustomizeResizeAllow () const
This member checks if the user can resize the control.
virtual int | GetCustomizeMinWidth () const
This member returns the minimum width that the combobox can be sized to by the user while in customization mode.
virtual void | OnRemoved ()
This method is called when a control is removed from the parent controls collection.
virtual void | OnMouseMove (CPoint point)
This member is called when the mouse cursor moves.
- Protected Member Functions inherited from CXTPControlPopup
BOOL | ContainsPopup (CXTPControlPopup *pControlPopup)
This method is called to check if pControlPopup contains in the control recursively.
void | ExpandCommandBar ()
Call this member to expand the parent pop-up bar.
BOOL | OnSetSelected (int bSelected)
This method is called when the control becomes selected.
void | OnClick (BOOL bKeyboard=FALSE, CPoint pt=CPoint(0, 0))
This method is called when the user clicks the control.
void | OnMouseHover ()
This method is called after the mouse hovers over the control.
virtual void | OnLButtonUp (CPoint point)
This member is called when the user releases the left mouse button.
virtual BOOL | OnLButtonDblClk (CPoint point)
This member is called when the user double-clicks the left mouse button.
void | OnCustomizeDragOver (CXTPControl *pDataObject, CPoint point, DROPEFFECT &dropEffect)
This method is called when the user moves the mouse over the control.
virtual BOOL | DoCustomDragOver (CXTPCommandBar *pCommandBar, CPoint point, DROPEFFECT &dropEffect)
The implementation may implement a custom drag over handling logic in this method.
virtual void | UpdateShadow ()
Call this member to update the shadow of the control.
virtual void | RestoreCommandBarList (CXTPCommandBarList *pCommandBarList)
This method is called from LoadCommandBars to restore controls and its child command bars.
- Protected Member Functions inherited from CXTPControlButton
- Protected Member Functions inherited from CXTPControl
CXTPControl ()
Constructs a CXTPControl object.
virtual | ~CXTPControl ()
Destroys a CXTPControl object, handles cleanup and deallocation.
void | SetIndex (int nIndex)
This method is called to assign the order of the control in the controls list.
void | SetExpanded (BOOL bExpanded)
This method is called to set the control's expanded state.
virtual BOOL | OnHookMouseWheel (UINT nFlags, short zDelta, CPoint point)
This method is called when the user rotates the mouse wheel.
void | ScreenToClient (CPoint *point)
The ScreenToClient function converts the screen coordinates of a specified point on the screen.
void | ClickToolBarButton (CRect rcActiveRect=CRect(0, 0, 0, 0))
This helper method is called when the user clicks the toolbar's button.
virtual void | OnLButtonDown (CPoint point)
This member is called when the user presses the left mouse button down.
virtual BOOL | OnRButtonDown (CPoint point)
This member is called when the user press the right mouse button.
virtual BOOL | OnRButtonUp (CPoint point)
This member is called when the user releases the right mouse button.
BOOL | IsCustomizeMode () const
Call this method to determine if command bars is in customize mode.
virtual void | CustomizeStartDrag (CPoint point)
This member is called when the user starts to drag the control in customize mode.
virtual BOOL | CustomizeStartResize (CPoint point)
This method is called when user starts to resize control in customize mode.
virtual int | GetCustomizeMinHeight () const
Retrieves available minimum height of the control.
void | OnCustomizeMouseMove (CPoint point)
This member is called when the mouse cursor moves in customized mode.
virtual void | OnIdleUpdate ()
This virtual method is called in idle-time processing.
virtual INT_PTR | OnToolHitTest (CPoint point, TOOLINFO *pTI) const
The framework calls this member function to determine whether a point is in the bounding rectangle of the specified tool.
virtual void | GenerateCommandBarList (DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam)
This method is called from SaveCommandBars to save all child command bars.
virtual void | OnCaptionChanged ()
This method is called when the control's caption is changed.
BOOL | IsLayoutRTL () const
Determines if right-to-left (RTL) mode is set.
BOOL | IsLayoutChanged ()
Call this member to determine if the layout has changed (RTL to LTR or LTR to RLT).

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlPopup
static CXTPControlPopup *AFX_CDECL | CreateControlPopup (XTPControlType controlType)
Creates a CXTPControlPopup object with the specified type.
- Static Public Member Functions inherited from CXTPControl
static CXTPControl *AFX_CDECL | FromUI (CCmdUI *pCmdUI)
Call this member to retrieve CXTPControl from a CCmdUI structure.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Attributes inherited from CXTPControlComboBox
CXTPControlComboBoxEditCtrl * | m_pEdit
Child edit control.
BOOL | m_bDropDown
TRUE if the combo is dropdown.
XTPButtonStyle | m_comboStyle
Style of the combobox.
int | m_nLastSel
Last user selected index (used during display of list box).
CString | m_strLastText
Last Text before user select focus and change it.
BOOL | m_bDelayDestroy
TRUE if need to recreate control.
BOOL | m_bDelayReposition
Need to reposition control.
int | m_nLabelWidth
Width of the label.
int | m_nThumbWidth
Width of the thumb area.
CString | m_strEditHint
Grayed-out text displayed in the edit control that displayed a helpful description.
BOOL | m_bAutoComplete
TRUE if Auto Complete is enabled.
BOOL | m_bIgnoreAutoComplete
TRUE to disable auto complete till next key event.
DWORD | m_dwShellAutoCompleteFlags
Shell auto complete flags.
BOOL | m_bFocused
TRUE if control is focused.
int | m_nEditIconId
Edit Icon identifier.
BOOL | m_bSelEndOk
TRUE if user selects a list item.
int | m_nDropDownItemCount
Maximum drop down items.
CString | m_strEditText
Edit text.
BOOL | m_bEditChanged
TRUE if Edit Text is changed.
int | m_nTextLimit
The maximum number of characters that can be entered into an edit control.
CXTPControlComboBoxAutoCompleteWnd * | m_pAutoCompleteWnd
Auto Complete hook window.
DWORD | m_dwEditStyle
Edit style.
- Protected Attributes inherited from CXTPControlPopup
BOOL | m_bPopup
TRUE if pop-up'ed.
CXTPCommandBar * | m_pCommandBar
Child pop-up bar.
DWORD | m_dwCommandBarID
Child pop-up ID.
BOOL | m_bShowShadow
TRUE to show shadow.
- Protected Attributes inherited from CXTPControlButton
XTPButtonStyle | m_buttonStyleEx
User-defined style of button containing vector icon.
- Protected Attributes inherited from CXTPControl
DWORD_PTR | m_nTag
Control tag.
int | m_nIndex
Index of the control.
int | m_nId
Identifier of the control.
int | m_nIconId
Identifier of the control's image.
int | m_nHelpId
Help identifier.
int | m_nCustomIconId
Identifier of the control's custom image.
BOOL | m_bWrap
TRUE if the control is wrapped.
BOOL | m_bBeginGroup
TRUE if the control starts new group.
BOOL | m_bEnabled
TRUE if the control is enabled.
BOOL | m_bChecked
TRUE if the control is checked.
BOOL | m_bSelected
TRUE if the control is selected.
BOOL | m_bPressed
TRUE if the control is pushed.
BOOL | m_bTemporary
TRUE if the control is temporary.
BOOL | m_bOnQuickAccess
TRUE if the control is a part of Quick Access panel.
CRect | m_rcRow
Bounding rectangle of the control's row.
CRect | m_rcControl
Bounding rectangle of the control.
DWORD | m_dwHideFlags
Hidden flags.
DWORD | m_dwFlags
Flags of the control.
CString | m_strCaption
Caption of the control.
CString | m_strCustomCaption
User-defined caption.
CString | m_strShortcutText
Shortcut text.
CString | m_strShortcutTextAuto
Shortcut text.
CString | m_strTooltipText
Tooltip text.
CString | m_strDescriptionText
Description text.
CString | m_strParameter
Parameter text.
CString | m_strKeyboardTip
Keyboard tip.
CXTPControls * | m_pControls
Parent control collection.
XTPControlType | m_controlType
Type of the control.
CXTPCommandBar * | m_pParent
The Parent command bar.
BOOL | m_bExpanded
TRUE if the control is expanded.
CString | m_strCategory
Category of the control.
BOOL | m_bDefaultItem
TRUE if the item is default pop-up item.
CDocTemplateMap | m_mapDocTemplatesAssigned
Assigned templates.
CDocTemplateMap | m_mapDocTemplatesExcluded
Excluded templates.
XTPButtonStyle | m_buttonStyle
Button Style.
XTPButtonStyle | m_buttonCustomStyle
User-defined style of button.
XTPButtonStyle | m_buttonRibbonStyle
User-defined style of button.
BOOL | m_bCloseSubMenuOnClick
TRUE is sub-menus are closed as soon as a control is clicked.
CXTPRibbonGroup * | m_pRibbonGroup
Ribbon group of control.
CXTPControlAction * | m_pAction
Action of the control.
int | m_nWidth
Width of the control.
int | m_nHeight
Height of the control.
int | m_nExecuteOnPressInterval
Delay between each message when control is pressed.
CSize | m_szIcon
The size of the icon used for the control.
BOOL | m_bLayoutRTL
Indicate does last layout is RTL.

Detailed Description

CXTPControlFontComboBox is a CXTPControlComboBox derived class.

It represents the font picker control.

Constructor & Destructor Documentation

◆ CXTPControlFontComboBox()

CXTPControlFontComboBox ( DWORD dwStyleListBox = 1 )

Constructs a CXTPControlFontComboBox object.

Parameters
dwStyleListBox Flags to be used in list box. Currently not supported, must be default.

Member Function Documentation

◆ SetCharFormat()

void SetCharFormat ( CHARFORMAT & cf )

Call this method to set the current font of the picker.

Parameters
cf CHARFORMAT structure contains information about character formatting in a rich edit control.
The documentation for this class was generated from the following file:
  • XTPControlComboBoxExt.h


Toolkit Pro: CXTPControlFontComboBoxList Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPControlFontComboBoxList Class Reference

CXTPControlFontComboBoxList is a CXTPControlComboBoxList derived class. More...

Inheritance diagram for CXTPControlFontComboBoxList:
[legend]

Public Member Functions

void | EnumFontFamiliesEx (BOOL dwStyleListBox=1)
This method is called to add all fonts to the list.
- Public Member Functions inherited from CXTPControlComboBoxList
CXTPControlComboBoxList ()
Constructs a CXTPControlButton object.
CListBox * | GetListBoxCtrl () const
- Public Member Functions inherited from CXTPControlComboBoxPopupBar
CXTPControlComboBoxPopupBar ()
Constructs a CXTPControlComboBoxPopupBar object.
- Public Member Functions inherited from CXTPPopupBar
void | SetTearOffPopup (LPCTSTR lpszCaption, UINT nID, int nWidth=400)
This method adds the tear-off state to the pop-up bar.
BOOL | IsTearOffPopup (CString &strCaption, UINT &nID, int &nWidth)
Determines if the pop-up bar has the tear-off state.
virtual BOOL | IsVisible () const
Call this member to determine if the pop-up menu is visible/displayed.
BOOL | Popup (int xPos, int yPos, LPCRECT rcExclude)
This method opens the pop-up bar.
BOOL | Popup (CXTPControlPopup *pControlPopup, BOOL bSelectFirst=FALSE)
This method opens the pop-up bar.
CXTPControlPopup * | GetControlPopup () const
Call this member to retrieve the control's pop-up.
void | ExpandBar ()
This method expands the bar.
BOOL | DestroyWindow ()
Call this member to destroy the window.
void | SetPopupToolBar (BOOL bToolBarType)
Call this method to make the pop-up bar look like a pop-up toolbar.
void | SetDefaultItem (UINT uItem, BOOL fByPos=FALSE)
Sets the default menu item for the specified pop-up bar.
UINT | GetDefaultItem (UINT gmdiFlags, BOOL fByPos=FALSE)
Determines the default menu item on the specified pop-up bar.
BOOL | IsDoubleGripper () const
Call this method to determine if the pop-up bar has a double gripper.
void | SetDoubleGripper (BOOL bDoubleGripper=TRUE)
Call this member to set a double gripper for the pop-up bar.
virtual BOOL | IsPopupBar () const
Call this member function to determine if the command bar is a CXTPPopupBar.
BOOL | IsContextMenu () const
Determines if the pop-up bar is a context menu.
void | PumpMessage ()
Translates all messages in the message queue.
virtual CSize | CalcDynamicLayout (int nLength, DWORD dwMode)
This method is called to get the size of the command bar.
virtual BOOL | Create ()
Creates the pop-up bar.
virtual CRect | CalculatePopupRect (CPoint ptPopup, CSize sz)
This method is called to calculate the destination rectangle of the pop-up bar.
void | SetPopupFlags (DWORD dwPopupFlags)
Call this method to set the pop-up direction.
void | SetBorders (CRect rcBorders)
Sets the toolbar's borders.
void | DisableShadow ()
Disables shadow use.
BOOL | IsResizable () const
Determines if the control can be resized by the user.
virtual CRect | GetBorders ()
Call this method to get the border margins of the command bar.
- Public Member Functions inherited from CXTPCommandBar
int | IsTrackingMode () const
Call this member to get the tracking state.
CXTPControls * | GetControls () const
Call this member to get the controls collection.
void | SetControls (CXTPControls *pControls)
Call this member to set the controls collection of the command bar.
XTPBarType | GetType () const
Call this member to get the type of the command bar.
void | SetTextOrientation (XTPBarTextOrientation nTextOrientation)
Call this member to change text orientation.
XTPBarTextOrientation | GetTextOrientation () const
Call this member to get the text orientation.
XTPBarPosition | GetPosition () const
Call this member to get the position of the command bar.
void | DelayLayout ()
Call this member to recalculate the layout.
virtual BOOL | LoadMenu (CMenu *pMenu, BOOL bRemoveControls=TRUE)
Call this member to convert menu items to command bar controls.
CXTPControl * | GetControl (int nIndex) const
Call this member to return the control at the specified index.
int | GetControlCount () const
Call this member to get the count of the controls.
CXTPControl * | GetSelected () const
Call this member to get the currently selected control.
BOOL | SetPopuped (int nPopuped, BOOL bKeyboard=FALSE)
Call this member to pop-up the specified control.
void | SetTitle (LPCTSTR lpszTitle)
Call this member to set a title for this command bar.
CString | GetTitle () const
Call this member to get a title for this command bar.
CXTPCommandBars * | GetCommandBars () const
Call this member to get the command bar's object.
void | SetCommandBars (CXTPCommandBars *pCommandBars)
Call this member to set the command bar's object.
CWnd * | GetSite () const
Call this member to get the command bar's site.
CFrameWnd * | GetFrameSite () const
Call this member to get the command bar's site as CFrameWnd.
void | SetFlags (DWORD dwFlagsAdd, DWORD dwFlagsRemove=0)
Call this member to set the command bar's flags.
BOOL | SetButtons (UINT *pButtons, int nCount)
Call this member to set the controls from the button array.
virtual BOOL | LoadToolBar (UINT nIDResource, BOOL bLoadIcons=TRUE)
Call this member function to load the toolbar specified by nIDResource.
void | SetIconSize (CSize size)
Call this function to set the size of the actual bitmapped images to be added to a toolbar.
virtual CSize | GetIconSize () const
Call this member function to get the size of the toolbar icon.
CSize | GetLargeIconSize (BOOL bAutoSize) const
Call this method to get the large icon size of the toolbar.
void | SetButtonSize (CSize size)
Sets the size of the buttons in the command bar.
virtual CSize | GetButtonSize () const
Call this function to get the size of the command bar button.
void | ShowTextBelowIcons (BOOL bTextBelow=TRUE)
Call this member to show the caption below control's icon.
BOOL | IsTextBelowIcons () const
Checks whether the caption is below the control's icon.
HWND | GetTrackFocus () const
Call this method to retrieve the current focused control.
void | SetTrackFocus (HWND hwnd)
Call this method to set focus to the window.
virtual void | SetVisible (BOOL bVisible)
Call this method to set the visibility state of the control.
virtual BOOL | SetPosition (XTPBarPosition barPosition)
Call this member function to set the position of the command bar.
int | FindAccel (TCHAR chAccel) const
Call this method to get the index of the control with the specified accelerator character.
int | FindAccelEx (UINT chAccel, BOOL &bSelectOnly) const
Call this method to get the index of the control with the specified accelerator character.
BOOL | IsCustomizeMode () const
Call this method to check if the command bars are in customize mode.
virtual DROPEFFECT | OnCustomizeDragEnter (CXTPControl *pDataObject, CPoint point)
This member is called when a control is entered into the command bar.
virtual void | OnCustomizeDragLeave ()
This method is called when a control leaves the command bar.
virtual DROPEFFECT | OnCustomizeDragOver (CXTPControl *pDataObject, CPoint point)
This member is called when control is over the command bar.
virtual void | OnCustomizeDrop (CXTPControl *pDataObject, DROPEFFECT &dropEffect, CPoint ptDrop, CPoint ptDrag)
This method is called when a control is dropped to the command bar.
BOOL | IsCustomizeDialogPresent () const
Call this method to check if the command bar is present in Customize dialog.
void | EnableCustomization (BOOL bEnable=TRUE)
Call this method to enable/disable customization of the command bar.
virtual void | OnTrackLost ()
Call this method to remove the tracking state of the command bar.
virtual void | OnTrackEnter ()
Call this method to track the command bar.
CWnd * | GetOwnerSite () const
Call this method to retrieve the owner window of the command bar.
void | InvalidateParents ()
Call this method to redraw all parent command bars.
DWORD | GetFlags () const
Call this method to retrieve the current behavior modification flags of the command bar.
UINT | GetBarID () const
Call this method to retrieve the identifier of the command bar.
void | SetBarID (UINT nID)
Call this method to set the identifier of the command bar.
virtual void | OnControlSelected (BOOL bSelected, CXTPControl *pControl)
This method is called when a child control becomes selected.
BOOL | SetStatusText (const CString &strDescription)
This method is called to set the description context.
void | SetCommandBarData (DWORD_PTR dwData)
This method sets the 32-bit value associated with the command bar.
DWORD_PTR | GetCommandBarData () const
This method retrieves the application-supplied, 32-bit value associated with the command bar.
CXTPCommandBar * | GetRootParent () const
Call this method to retrieve the top-level parent command bar.
CXTPPaintManager * | GetPaintManager () const
Call this method to retrieve the paint manager.
CXTPImageManager * | GetImageManager () const
Call this method to retrieve the image manager.
void | SetWidth (int nWidth)
Call this member to set the width of the floated or pop-up toolbar.
int | GetWidth () const
Call this member to get the width of the floated or pop-up toolbar.
void | SetPaintManager (CXTPPaintManager *pPaintManager)
Call this member to set the specified paint manager.
void | SetImageManager (CXTPImageManager *pImageManager)
Call this member to set the specified image manager.
BOOL | IsLayoutRTL () const
Call this member function to determine if the command bar layout is Right-to-Left (RTL).
virtual BOOL | IsDialogBar () const
Call this member function to determine if the command bar is a CXTPDialogBar.
virtual BOOL | IsRibbonBar () const
Call this member function to determine if the command bar is a CXTPRibbonBar.
virtual BOOL | IsMenuTitleBar () const
Call this member function to determine if the command bar is a CXTPMenuTitleBar.
virtual BOOL | IsKeyboardCuesVisible () const
Determines if underlines are visible in the command bar control.
void | SetGrabFocus (BOOL bGrabFocus)
This method is called internally to prevent the command bar from grabbing edit focus.
virtual void | Redraw (LPCRECT lpRect=0, BOOL bAnimate=TRUE)
The framework calls this member function to redraw the command bar.
void | EnableAnimation (BOOL bEnable=TRUE)
Call this method to enable animation for the command bar.
void | EnableDoubleBuffer (BOOL bEnable=TRUE)
Call this method to enable double buffer for toolbar drawing.
BOOL | IsAnimationEnabled () const
Determines if animation is enabled for the specified command bar.
virtual void | EnsureVisible (CXTPControl *pControl)
Call this method to ensure that a specified control is visible on the toolbar.
XTPButtonStyle | GetDefaultButtonStyle () const
Call this method to retrieve the default button style of the command bar.
void | SetDefaultButtonStyle (XTPButtonStyle buttonStyle)
Call this method to set the default button style of the command bar.
void | LockRedraw ()
Call this method to freeze redrawing until UnlockRedraw is called.
void | UnlockRedraw ()
Call this method to unfreeze redrawing.
void | SetShowGripper (BOOL bShow)
Call this method to set the visibility of the command bar's gripper.
BOOL | GetShowGripper () const
Call this method to check if the command bar's gripper is visible.
virtual void | FillCommandBarEntry (CDC *pDC)
This method is called to draw the background of the command bar.
BOOL | IsKeyboardTipsVisible () const
Call this method to check if keyboard tips are visible for the command bar.
virtual void | CreateKeyboardTips ()
This method is called to create a keyboard tips collection for the command bar.
void | OnKeyboardTipChar (UINT chAccel)
This method is called when the user presses a key while keyboard tips are visible.
virtual void | OnKeyboardTip (CXTPCommandBarKeyboardTip *pTip)
This method is called when a keyboard tip is found for the command bar.
void | HideKeyboardTips ()
Call this method to hide keyboard tips.
void | LockMouseMove (CXTPControl *pControl)
Locks the mouse cursor for a specified control.
void | UnlockMouseMove ()
Unlocks the mouse cursor.
- Public Member Functions inherited from CXTPHookManagerHookAble
CXTPHookManagerHookAble ()
Constructs a CXTPHookManagerHookAble object.
virtual | ~CXTPHookManagerHookAble ()
Destroys a CXTPHookManagerHookAble object, handles cleanup and deallocation.
virtual int | OnPostHookMessage (HWND hWnd, UINT nMessage, WPARAM &wParam, LPARAM &lParam, LRESULT &lResult)
This member function is called after a message has been processed by default window procedure.
virtual void | OnHookAttached (HWND hWnd)
This member function is called right after a hook is attached to the window.
virtual void | OnHookDetached ()
This member function is called right before a hook is to be detached from the window.

Protected Member Functions

virtual void | DoPropExchange (CXTPPropExchange *pPX)
Either reads this object from or writes this object to an archive.
void | Copy (CXTPCommandBar *pCommandBar, BOOL bRecursive=FALSE)
Call this method to make a copy of the command bar.
void | CreateListBox ()
Creates a list box.
- Protected Member Functions inherited from CXTPControlComboBoxList
int | OnHookMessage (HWND hWnd, UINT nMessage, WPARAM &wParam, LPARAM &lParam, LRESULT &lResult)
This member function is called by WindowProc, or is called during message reflection.
virtual BOOL | Popup (CXTPControlPopup *pControlPopup, BOOL bSelectFirst=FALSE)
This method is called, then the pop-up bar becomes visible.
virtual BOOL | SetTrackingMode (int bMode, BOOL bSelectFirst, BOOL bKeyboard=FALSE)
Call this member to change the tracking state.
virtual void | DrawCommandBar (CDC *pDC, CRect rcClipBox)
This method is called to draw the command bar in the given context.
virtual BOOL | OnHookKeyDown (UINT nChar, LPARAM lParam)
The framework calls this member function when a non-system key is pressed.
virtual BOOL | IsCustomizable () const
Call this member to retrieve the customize mode of the command bars.
BOOL | ProcessHookKeyDown (CXTPControlComboBox *pComboBox, UINT nChar, LPARAM lParam)
This method is called to process key down events.
virtual void | DrawItem (LPDRAWITEMSTRUCT lpDrawItemStruct)
This member function is called to draw the combobox.
virtual void | MeasureItem (LPMEASUREITEMSTRUCT lpMeasureItemStruct)
Override this method and fill in the MEASUREITEMSTRUCT structure to inform Windows of the list-box dimensions.
- Protected Member Functions inherited from CXTPPopupBar
CXTPPopupBar ()
Constructs a CXTPPopupBar object.
virtual | ~CXTPPopupBar ()
Destroys a CXTPPopupBar object, handles cleanup and deallocation.
virtual void | DelayRedraw ()
Redraw the pop-up bar.
virtual BOOL | SetSelected (int nSelected, BOOL bKeyboard=FALSE)
Call this member to select the specified control.
void | UpdateLocation (CSize sz)
This method sets the pop-up bar's position.
virtual void | UpdateFlags ()
Update flags.
void | UpdateExpandingState ()
Update expanding state.
virtual void | OnControlsChanged ()
This method is called when the controls array is changed.
virtual void | OnRecalcLayout ()
This method is called to recalculate the command bar layout.
CXTPCommandBar * | GetParentCommandBar () const
Call this member to retrieve the parent command bar.
virtual void | AdjustExcludeRect (CRect &rc, BOOL bVertical)
Updates rectangle to set the position where the child pop-up bar becomes visible.
virtual void | Animate ()
Animates pop-up window.
- Protected Member Functions inherited from CXTPCommandBar
CXTPCommandBar ()
Constructs a CXTPCommandBar object.
virtual | ~CXTPCommandBar ()
Destroys a CXTPCommandBar object, handles cleanup and deallocation.
virtual BOOL | ProcessSpecialKey (XTPSpecialKey key)
This method is called to process special keys.
virtual int | OnMouseHitTest (CPoint pt)
This method is called to determine mouse hit code.
virtual void | UpdateShortcuts ()
Updates the control's shortcuts.
UINT | GetActiveDocTemplate () const
Retrieves the active MDI document template.
virtual void | GenerateCommandBarList (DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam)
This method is called to assign self identifiers for the serialization process.
virtual void | RestoreCommandBarList (CXTPCommandBarList *pCommandBarList)
This method is called in the serialization process to restore pop-ups from a list of command bars.
BOOL | IsHelpMode () const
Determines if the parent frame is in help mode.
virtual void | OnRemoved ()
This method is called when a toolbar is removed from the command bars collection.

Protected Attributes

DWORD | m_dwStyleListBox
Style of the control.
- Protected Attributes inherited from CXTPPopupBar
CXTPControlPopup * | m_pControlPopup
Control that pop-up'ed the bar.
CPoint | m_ptPopup
Position of the bar.
CRect | m_rcExclude
Excluded area.
DWORD | m_popupFlags
Flags of the bar.
BOOL | m_bDynamicLayout
TRUE if DynamicLayout routine executed.
BOOL | m_bCollapsed
TRUE if pop-up bar is collapsed.
BOOL | m_bExpanded
TRUE if pop-up bar is expanded.
BOOL | m_bExpanding
TRUE if pop-up bar is expanding.
BOOL | m_bTearOffPopup
TRUE if pop-up bar has tear-off option.
CRect | m_rcTearOffGripper
Tear-off gripper position.
CRect | m_rcResizeGripper
Resizable gripper position.
BOOL | m_bResizable
TRUE to allow resize.
BOOL | m_bTearOffSelected
TRUE if gripper selected.
UINT_PTR | m_nTearOffTimer
Tear-off timer.
BOOL | m_bTearOffTracking
Tear-off tracking mode.
CSize | m_szTearOffBar
Size of the bar.
CXTPToolBar * | m_pTearOffBar
Tear-off toolbar pointer.
CString | m_strTearOffCaption
Caption of the Tear-off toolbar.
UINT | m_nTearOffID
ID of the Tear-off toolbar.
int | m_nTearOffWidth
Width of the Tear-off toolbar.
BOOL | m_bShowShadow
TRUE to show the shadow.
CRect | m_rcBorders
Borders of the bar.
BOOL | m_bDoubleGripper
TRUE if pop-up is state pop-up type.
BOOL | m_bContextMenu
TRUE if pop-up bar is context menu.
int | m_nMaxHeight
Maximum height the pop-up bar can become.
- Protected Attributes inherited from CXTPCommandBar
BOOL | m_bGrabFocus
TRUE to grab current focus.
int | m_nMRUWidth
Recent width.
int | m_nSelected
Selected control index.
int | m_nPopuped
Pop-up'ed control index.
HWND | m_hwndFocus
The handle of the window that currently has focus.
UINT | m_nBarID
Command bar's identifier.
BOOL | m_bTracking
TRUE if the command bar is in tracking mode.
CWnd * | m_pSite
Command bar's site.
DWORD | m_nIdleFlags
Idle flags.
DWORD | m_dwFlags
Command bar's flags.
DWORD | m_dwStyle
Command bar's styles.
CString | m_strTitle
Command bar's caption.
XTPBarType | m_barType
Type of the command bar.
CXTPControls * | m_pControls
A pointer to controls collection.
XTPBarPosition | m_barPosition
Position of the command bar.
CXTPCommandBars * | m_pCommandBars
parent command bars class.
CWnd * | m_pOwner
Owner window.
CSize | m_szIcons
Size of the command bar's icons.
CSize | m_szButtons
Size of the command bar's buttons.
BOOL | m_bTextBelow
TRUE if text is shown below the CommandBar buttons.
BOOL | m_bExecOnRButton
TRUE if the control button is executed on a right-click.
BOOL | m_bIgnoreUpdateHandler
TRUE to skip update handler for all child controls.
BOOL | m_bRecursePopup
TRUE if pop-up bar was opened recursively.
BOOL | m_bKeyboardSelect
TRUE if last item was selected by keyboard.
BOOL | m_bCloseable
TRUE if the CommandBar can be closed and-or Hidden.
BOOL | m_bCustomizable
TRUE if command bar is customizable.
CRect | m_rcMarker
Marker position.
BOOL | m_bVerticalMarker
TRUE to draw marker vertically.
DWORD_PTR | m_dwData
The 32-bit value associated with the command bar.
UINT * | m_pReturnCmd
Return command holder.
BOOL | m_bCustomizeDialogPresent
TRUE if the command bar is present in Customize dialog.
BOOL | m_bAnimatePopup
TRUE to animate pop-up bar.
BOOL | m_nLockRedraw
TRUE if all drawing routines skipped.
CXTPPaintManager * | m_pPaintManager
Selected paint manager for command bar.
CXTPImageManager * | m_pImageManager
Selected image manager for command bar.
BOOL | m_bMultiLine
True if multi line commandbar.
XTPButtonStyle | m_buttonStyle
Default button Style.
XTPBarTextOrientation | m_nTextOrientation
Commandbar text orientation.
CXTPToolTipContext * | m_pToolTipContext
Tool tip Context.
CXTPCommandBarAnimation * | m_pAnimation
Animation context.
CSize | m_szButtonSpacing
Spacing used between toolbar buttons.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPPopupBar
static CXTPPopupBar *AFX_CDECL | CreatePopupBar (CXTPCommandBars *pCommandBars)
Creates a pop-up bar object.
- Public Attributes inherited from CXTPCommandBar
int | m_nStateFlags
State of the command bars.
BOOL | m_bComboBar
TRUE if it is combobox list.
BOOL | m_bTrackOnHover
TRUE to select item if mouse stay over control.
- Public Attributes inherited from CXTPHookManagerHookAble
BOOL | m_bAutoDestroy
TRUE to automatically delete hook.
- Static Public Attributes inherited from CXTPPopupBar
static double | m_dMaxWidthDivisor
Maximum available width of pop-up.
- Static Public Attributes inherited from CXTPCommandBar
static int | s_nHoverDelay
Hover delay time.
static int | s_nExpandDelay
Expand delay time.
static int | s_nExpandHoverDelay
Expand hover delay.

Detailed Description

CXTPControlFontComboBoxList is a CXTPControlComboBoxList derived class.

It represents the font picker pop-up.

Member Function Documentation

◆ Copy()

void Copy | ( | CXTPCommandBar * | pCommandBar,
 |  | BOOL | bRecursive = FALSE )
 protectedvirtual

Call this method to make a copy of the command bar.

Parameters
pCommandBar | Command bar to be copied.
bRecursive | TRUE to copy recursively.

Reimplemented from CXTPControlComboBoxList.

◆ DoPropExchange()

virtual void DoPropExchange ( CXTPPropExchange * pPX )
protectedvirtual

Either reads this object from or writes this object to an archive.

Parameters
pPX A CXTPPropExchange object to serialize to or from.

Reimplemented from CXTPControlComboBoxList.

◆ EnumFontFamiliesEx()

void EnumFontFamiliesEx ( BOOL dwStyleListBox = 1 )

This method is called to add all fonts to the list.

Parameters
dwStyleListBox Flags to be used in EnumFontFamiliesEx. Currently not supported.
The documentation for this class was generated from the following file:
  • XTPControlComboBoxExt.h


Toolkit Pro: CXTPControlGallery Class Reference

Classes | Public Member Functions | Static Public Attributes | Protected Member Functions | Protected Attributes | List of all members
CXTPControlGallery Class Reference

CXTPControlGallery is a CXTPControlPopup derived class. More...

Inheritance diagram for CXTPControlGallery:
[legend]

Classes

struct GALLERYITEM_POSITION
Structure contains item position description. More...

Public Member Functions

CXTPControlGallery ()
Constructs a CXTPControlGallery object.
~CXTPControlGallery ()
Destroys a CXTPControlGallery object, handles cleanup and deallocation.
void | SetItems (CXTPControlGalleryItems *pItems)
Call this method to set items for the gallery.
void | SetItemsMargin (int nLeft, int nTop, int nRight, int nBottom)
Call this method to set margins around items.
void | SetControlSize (CSize szControl)
Call this method to set the size of the control.
void | SetControlSize (int nColumns, int nRows, CSize szItem)
Call this method to the set size of the control depending on the number of rows, columns, current item size and current DPI.
int | GetItemCount () const
Call this method to get the count of items in the gallery.
CXTPControlGalleryItem * | GetItem (int nIndex) const
Call this method to retrieve an item by its index.
virtual CXTPControlGalleryItems * | GetItems () const
Call this method to get items associated with the gallery.
void | SetSelectedItem (int nSelected)
Call this method to set the selected item in the gallery.
int | GetSelectedItem () const
Call this method to get the selected item in the gallery.
void | SetCheckedItem (int nId)
Call this method to set the checked item identifier for the gallery.
virtual BOOL | IsItemChecked (CXTPControlGalleryItem *pItem) const
Call this method to determine if an item is checked.
int | GetCheckedItem () const
Call this method to get the checked item identifier for the gallery.
BOOL | IsItemSelected () const
Determines if any item in the gallery is selected.
void | ShowBorders (BOOL bShowBorders)
Call this method to show/hide borders around the gallery.
BOOL | IsShowBorders () const
Call this method to determine if borders are visible around the gallery.
void | ShowLabels (BOOL bShowLabels)
Call this method to show/hide labels for the gallery.
void | ShowScrollBar (BOOL bShowScrollBar)
Call this method to show/hide the scrollbar for the gallery.
BOOL | IsScrollBarVisible () const
Call this method to check if the scrollbar for the gallery is visible.
void | SetScrollBarAuto (BOOL bScrollBarAuto)
Call this method to automatically show/hide the scrollbar for the gallery.
BOOL | IsScrollBarAuto () const
Determines if the scrollbar for the gallery is automatically shown/hidden.
virtual CRect | GetBorders () const
Call this method to get the border margins for the gallery.
CRect | GetItemDrawRect (int nIndex)
Determines the bounding rectangle of the item.
int | HitTestItem (CPoint point, LPRECT lpRect=NULL) const
This method determines where a point lies in a specified item.
CRect | GetItemsRect () const
Determines the bounding rectangle of the items.
void | InvalidateItems (LPCRECT lpRect=NULL, BOOL bAnimate=TRUE)
Call this method to redraw items.
CXTPControlGalleryPaintManager * | GetGalleryPaintManager () const
Retrieves CXTPControlGalleryPaintManager pointer to draw gallery.
CXTPScrollBarPaintManager * | GetScrollBarPaintManager () const
Retrieves CXTPScrollBarPaintManager pointer to draw ScrollBar.
void | EnsureVisible (int nIndex)
Call this member to ensure that a specified item is visible in the gallery.
void | SetScrollPos (int nScrollPos)
Call this method to set the scrollbar position for the gallery.
int | GetScrollPos () const
Call this method to get the scrollbar position for the gallery.
int | SetTopIndex (int nIndex)
Call this method to scroll gallery to the specified top item.
void | SetResizable (BOOL bResizeWidth=TRUE, BOOL bResizeHeight=TRUE)
Call this method to allow the user to resize the gallery.
BOOL | IsResizable () const
Call this method to check if the gallery can be resized by the user.
virtual void | OnSelectedItemChanged ()
This method is called when the selection is changed by the user.
BOOL | HasBottomSeparator () const
Call this function to check if the gallery has a bottom separator.
long | GetNext (long nIndex, int nDirection) const
Call this method to get the index of the next focusable item.
long | GetNextInRow (long nIndex, int nDirection) const
Call this method to get the index of the next focusable item in the same row.
long | GetNextInColumn (long nIndex, int nDirection) const
Call this method to get the index of the next focusable item in the same column.
long | GetNextInPage (long nIndex, int nDirection) const
Call this method to get the index of the next focusable item in the same page.
int | FindItem (int nStartAfter, LPCTSTR lpszItem, BOOL bExact) const
Call this method to search for an item.
CString | GetItemCaption (int nIndex)
Call this method to get the caption of an item.
BOOL | IsScrollButtonEnabled (int ht)
Determines if the scrollbar button is enabled.
BOOL | IsScrollBarEnabled () const
Call this member to check if the scrollbar is enabled.
BOOL | IsShownAsButton () const
Determines if the gallery is shown as a button.
void | HideSelection ()
Call this method to hide the selection.
BOOL | IsTransparent () const
Determines if the control needs to draw its background.
- Public Member Functions inherited from CXTPControlPopup
CXTPControlPopup ()
Constructs a CXTPControlPopup object.
virtual | ~CXTPControlPopup ()
Destroys a CXTPControlPopup object, handles cleanup and deallocation.
void | SetCommandBar (CMenu *pMenu)
Call this member to set the child command bar.
void | SetCommandBar (CXTPCommandBar *pBar)
Call this member to set the child command bar.
CXTPCommandBar * | GetCommandBar () const
Call this member to get the child command bar.
BOOL | GetPopuped () const
Call this member to get the control's pop-up state.
virtual CString | GetCaption () const
Call this member to get the control's caption.
void | DoPropExchange (CXTPPropExchange *pPX)
Either reads this object from or writes this object to an archive.
virtual void | AdjustExcludeRect (CRect &rc, BOOL bVertical)
Updates rectangle to set the position where the child pop-up bar becomes visible.
void | Copy (CXTPControl *pControl, BOOL bRecursive=FALSE)
This method is called to copy the control.
virtual void | OnUnderlineActivate ()
This method is called when the user activates a control using its underline.
- Public Member Functions inherited from CXTPControlButton
CXTPControlButton ()
Constructs a CXTPControlButton object.
virtual | ~CXTPControlButton ()
Destroys a CXTPControlButton object, handles cleanup and deallocation.
void | SetStyleEx (XTPButtonStyle buttonStyle)
Call this member to set the style of the button containing vector icon.
XTPButtonStyle | GetStyleEx () const
Call this member to get the button's style containing vector icon.
- Public Member Functions inherited from CXTPControl
void | SetStyle (XTPButtonStyle buttonStyle)
Call this member to set the style of the control.
XTPButtonStyle | GetStyle () const
Call this member to get the control's style.
void | SetCaption (LPCTSTR lpszCaption)
Call this member to set the caption of the control.
void | SetCaption (UINT nIDCaption)
Call this member to set the caption of the control.
void | SetShortcutText (LPCTSTR lpszShortcutText)
Call this member to set the shortcut string to the control.
CString | GetShortcutText () const
Call this member to get the control's shortcut.
void | SetDescription (LPCTSTR lpszDescription)
Call this member to set the description of the control.
virtual CString | GetDescription () const
Call this member to get the control's description.
void | SetTooltip (LPCTSTR lpszTooltip)
Call this member to set the tooltip of the control.
virtual CString | GetTooltip () const
Call this member to get the control's tooltip.
void | SetKeyboardTip (LPCTSTR lpszKeyboardTip)
Call this member to set the keyboard tip to the control.
CString | GetKeyboardTip () const
Call this member to get the keyboard tip.
void | SetCustomShortcutText (LPCTSTR lpszCustomShortcutText)
Call this member to set the text displayed for the shortcut in a pop-up menu.
CString | GetCustomShortcutText () const
Call this member to get the control's text displayed for the shortcut in a pop-up menu.
void | SetParameter (LPCTSTR lpszParameter)
Call this member to set the parameter of the control.
CString | GetParameter () const
Call this member to get the control's parameter.
void | SetID (int nId)
Call this member to set the identifier of the control.
int | GetID () const
Call this member to get the control's identifier.
long | GetIndex () const
Call this member to get the index of the control.
void | SetIconId (int nId)
Call this member to set the control icon's identifier.
int | GetIconId () const
Call this member to get the icon's identifier.
void | SetHelpId (int nId)
Call this member to set the control help identifier.
int | GetHelpId () const
Call this member to get the help identifier.
virtual void | SetBeginGroup (BOOL bBeginGroup)
Call this member to begin a new group using a separator.
BOOL | GetBeginGroup () const
Call this member to determine if the control has a separator.
virtual void | SetEnabled (BOOL bEnabled)
Call this member to enable/disable the control.
BOOL | GetEnabled () const
Call this member to check if the control is enabled.
virtual void | OnEnabledChanged ()
This method is called when a control's enabled state is changed.
virtual void | SetChecked (BOOL bChecked)
Call this member to set the checked state of the control.
BOOL | GetChecked () const
Call this member to get the checked state of the control.
virtual int | GetSelected () const
Call this member to check if the control is selected.
void | SetOnQuickAccess (BOOL bOnQuicAccess=FALSE)
Call this member to set whether a control should be a part of the Quick Access panel.
BOOL | IsOnQuickAccess () const
Call this member to check if a control is a part of the Quick Access panel.
virtual void | SetFocused (BOOL bFocused)
Call this member to set the focused state of the control.
virtual BOOL | IsFocused () const
Call this member to check the focused state of the control.
void | SetPressed (BOOL bPressed)
Call this member to set the pressed state of the control.
virtual BOOL | GetPressed () const
Call this member to check the pressed state of the control.
virtual void | SetRect (CRect rcControl)
This member is called to set the bounding rectangle of the control.
CRect | GetRect () const
Call this member to get the bounding rectangle of the control.
CXTPCommandBar * | GetParent () const
Call this member to get the parent command bar.
virtual BOOL | IsVisible (DWORD dwSkipFlags=0) const
Call this member to determine if the control is visible.
virtual BOOL | IsCaptionVisible () const
Call this member to determine if the caption of the control is visible.
void | SetVisible (BOOL bVisible)
Call this member to set the visibility of the control.
CXTPControls * | GetControls () const
Call this member to get the parent controls collection.
XTPControlType | GetType () const
Call this member to get the control's type.
void | SetFlags (DWORD dwFlags)
Call this member to set the flags of the control.
DWORD | GetFlags () const
Call this member to retrieve control special flags.
void | SetTag (DWORD_PTR dwTag)
This method sets the 32-bit value associated with the control.
DWORD_PTR | GetTag () const
This method retrieves the application-supplied, 32-bit value associated with the control.
void | SetCloseSubMenuOnClick (BOOL bCloseOnClick)
Call this member function to enable/disable the closing of sub-menus when a control is clicked in the menu.
BOOL | GetCloseSubMenuOnClick () const
Call this member function to check if sub-menus will close as soon as a control is clicked.
void | SetExecuteOnPressInterval (int nExecuteOnPressInterval)
Call this method to set the delay (in milliseconds) between WM_COMMAND messages while a button is pressed by the user.
int | GetExecuteOnPressInterval () const
Call this method to get the delay (in milliseconds) between WM_COMMAND messages while a button is pressed by the user.
CXTPRibbonGroup * | GetRibbonGroup () const
Returns the ribbon group that the control belongs to.
void | SetHideWrap (BOOL bHide)
This method is called to hide the control.
virtual void | SetHideFlags (DWORD dwFlags)
This method is called to hide the control.
BOOL | SetHideFlag (XTPControlHideFlags dwFlag, BOOL bSet)
Call this member to set/remove hide flags.
DWORD | GetHideFlags () const
Call this method to retrieve hidden flags.
CRect | GetRowRect () const
Call this method to retrieve the position of the control's row.
BOOL | GetWrap () const
Call this method to check if the control is wrapped.
void | SetRowRect (CRect rcRow)
Call this method to set the row of the control.
void | SetWrap (BOOL bWrap)
Call this member to set the control to wrapped.
BOOL | GetExpanded () const
Call this member to check if the control is expanded.
BOOL | IsCursorOver () const
Call this member to determine if the mouse pointer is over the control.
virtual void | OnExecute ()
This method is called when the control is executed.
virtual CSize | GetSize (CDC *pDC)
This method is called to determine the size of the control.
virtual void | Draw (CDC *pDC)
This method is called to draw the control.
void | DelayRedrawParent ()
Call this method to redraw the parent command bar.
void | DelayLayoutParent ()
Call this method to recalculate the parent command bar size.
void | SetCategory (LPCTSTR lpszCategory)
Call this method to set the category of the control.
CString | GetCategory () const
Call this method to retrieve the category of the control.
CXTPImageManager * | GetImageManager () const
Call this method to retrieve the image manager.
CXTPPaintManager * | GetPaintManager () const
Call this method to retrieve the paint manager.
virtual CXTPImageManagerIcon * | GetImage (int nWidth=16) const
Call this method to retrieve the image of the control.
void | AssignDocTemplate (UINT nIDResource)
Call this method to assign a document template to the control.
void | ExcludeDocTemplate (UINT nIDResource)
Call this method to exclude the document template from control.
BOOL | IsItemDefault () const
Call this method to check if a control is a default menu item.
void | SetItemDefault (BOOL bDefault)
Call this method to set a control to be a default menu item.
BOOL | IsTemporary () const
Call this method to determine if a control is temporary.
void | Reset ()
Call this member to reset the icon and caption of a control to its default settings before it was customized by the user.
void | SetPrompt (LPCTSTR lpszPrompt)
Call this member to load a string from a STRINGTABLE resource to set the tooltip and description of a control.
void | SetCustomIcon (HICON hIcon)
Call this member to set a custom icon to this control.
void | RedrawParent (BOOL bAnimate=TRUE)
This method is called to redraw the parent command bar.
LRESULT | NotifySite (UINT code)
This method is called to send message code to the parent site window.
LRESULT | NotifySite (UINT code, NMXTPCONTROL *pNM)
This method is called to send message code to the parent site window.
LRESULT | NotifySite (CWnd *pSite, UINT code, NMXTPCONTROL *pNM)
This method is called to send message code to the parent site window.
virtual void | SetAction (CXTPControlAction *pAction)
Call this method to manually assign an action for control.
CXTPControlAction * | GetAction () const
Call this method to retrieve an action associated with control.
virtual void | OnThemeChanged ()
This method is called when the paint manager theme is changed.
virtual void | SetWidth (int nWidth)
Call this member to set the width of the control.
virtual void | SetHeight (int nHeight)
Call this member to set the height of the control.
int | GetWidth () const
Call this member to get the width of the control.
int | GetHeight () const
Call this member to get the height of the control.
BOOL | HasDwmCompositedRect () const
This method is called to determine if control has a Vista DWM transparent area.
virtual CSize | GetButtonSize () const
Call this function to get the size of the command bar button.
virtual CSize | GetIconSize () const
Call this member function to get the size of a toolbar icon.
void | SetIconSize (CSize szIcon)
Call this member function to set the size of an icon for an individual control.
virtual BOOL | IsCustomizeMovable () const
This method is called to determine if control can be repositioned in customize mode.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.
- Public Member Functions inherited from CXTPScrollBase
CXTPScrollBase ()
Constructs a CXTPScrollBase object.
virtual | ~CXTPScrollBase ()
Destroys a CXTPScrollBase object, handles cleanup and deallocation.
void | SetScrollBarStyle (XTPScrollBarStyle scrollStyle)
Call this method to set the style of the scrollbar.
XTPScrollBarStyle | GetScrollBarStyle () const
Call this method to get the style of the scrollbar.
XTP_SCROLLBAR_TRACKINFO * | GetScrollBarTrackInfo () const
Call this method to get XTP_SCROLLBAR_TRACKINFO information.
XTP_SCROLLBAR_POSINFO * GetScrollBarPosInfo ()
Call this method to get XTP_SCROLLBAR_POSINFO information.
virtual CWnd * | GetParentWindow () const =0
Retrieves parent window of scrollbar.
int | HitTestScrollBar (POINT pt) const
Call this method to check ScrollBar part under pointer.
CRect | GetScrollBarPartRect (int nPart) const
Gets the bounding rectangle of a specified part of the scrollbar.
void | PerformTrackInit (HWND hWnd, CPoint point, XTP_SCROLLBAR_POSINFO *pSBInfo, BOOL bDirect)
Call this method to start scrollbar tracking.
XTP_SLIDERTICKS * | GetTicks () const
Gets the ticks in the slider.
void | SetTicks (double *pTicks, int nCount)
Call this method to set ticks for the slider.
HBRUSH | GetCltColor (CDC *pDC) const
Call this method to get the scroll bar control color.
BOOL | IsSlider () const
Call this member function to determine if the scrollbar is a slider control.
virtual CRect | GetScrollBarRect ()=0
Obtains the rectangle occupied by the scrollbar in client coordinates.
virtual void | GetScrollInfo (SCROLLINFO *psi)=0
The GetScrollInfo function retrieves the parameters of a scroll bar, including the minimum and maximum scrolling positions, the page size, and the position of the scroll box(thumb)
virtual void | RedrawScrollBar ()=0
Forces the scrollbar to redraw itself.

Static Public Attributes

static BOOL m_bAutoScaleDpi
TRUE by default.

Protected Member Functions

void | Reposition ()
This method is called to set the position of all items.
void | DrawItems (CDC *pDC)
This method is called to draw all items.
void | Copy (CXTPControl *pControl, BOOL bRecursive=FALSE)
This method is called to copy the control.
void | DoPropExchange (CXTPPropExchange *pPX)
Either reads this object from or writes this object to an archive.
void | OnCalcDynamicSize (DWORD dwMode)
This method is called before recalculating the parent command bar size to calculate the dimensions of the control.
- Protected Member Functions inherited from CXTPControlPopup
BOOL | ContainsPopup (CXTPControlPopup *pControlPopup)
This method is called to check if pControlPopup contains in the control recursively.
void | ExpandCommandBar ()
Call this member to expand the parent pop-up bar.
BOOL | OnSetSelected (int bSelected)
This method is called when the control becomes selected.
void | OnClick (BOOL bKeyboard=FALSE, CPoint pt=CPoint(0, 0))
This method is called when the user clicks the control.
void | OnMouseHover ()
This method is called after the mouse hovers over the control.
virtual void | OnMouseMove (CPoint point)
This member is called when the mouse cursor moves.
virtual BOOL | OnSetPopup (BOOL bPopup)
This method is called to pop-up the control.
virtual void | OnLButtonUp (CPoint point)
This member is called when the user releases the left mouse button.
virtual BOOL | OnLButtonDblClk (CPoint point)
This member is called when the user double-clicks the left mouse button.
void | OnCustomizeDragOver (CXTPControl *pDataObject, CPoint point, DROPEFFECT &dropEffect)
This method is called when the user moves the mouse over the control.
virtual BOOL | DoCustomDragOver (CXTPCommandBar *pCommandBar, CPoint point, DROPEFFECT &dropEffect)
The implementation may implement a custom drag over handling logic in this method.
virtual BOOL | Compare (CXTPControl *pOther)
Call this member to compare controls.
virtual void | UpdateShadow ()
Call this member to update the shadow of the control.
virtual void | RestoreCommandBarList (CXTPCommandBarList *pCommandBarList)
This method is called from LoadCommandBars to restore controls and its child command bars.
- Protected Member Functions inherited from CXTPControlButton
- Protected Member Functions inherited from CXTPControl
CXTPControl ()
Constructs a CXTPControl object.
virtual | ~CXTPControl ()
Destroys a CXTPControl object, handles cleanup and deallocation.
virtual BOOL | IsFocusable () const
This method is called to check if the control can accept focus.
void | SetIndex (int nIndex)
This method is called to assign the order of the control in the controls list.
void | SetExpanded (BOOL bExpanded)
This method is called to set the control's expanded state.
virtual BOOL | OnHookKeyDown (UINT nChar, LPARAM lParam)
This method is called when a non-system key is pressed.
virtual BOOL | OnHookMouseWheel (UINT nFlags, short zDelta, CPoint point)
This method is called when the user rotates the mouse wheel.
virtual void | SetParent (CXTPCommandBar *pParent)
This method is called to assign a parent command bar object.
void | ScreenToClient (CPoint *point)
The ScreenToClient function converts the screen coordinates of a specified point on the screen.
void | ClickToolBarButton (CRect rcActiveRect=CRect(0, 0, 0, 0))
This helper method is called when the user clicks the toolbar's button.
virtual void | OnLButtonDown (CPoint point)
This member is called when the user presses the left mouse button down.
virtual BOOL | OnRButtonDown (CPoint point)
This member is called when the user press the right mouse button.
virtual BOOL | OnRButtonUp (CPoint point)
This member is called when the user releases the right mouse button.
BOOL | IsCustomizeMode () const
Call this method to determine if command bars is in customize mode.
virtual void | CustomizeStartDrag (CPoint point)
This member is called when the user starts to drag the control in customize mode.
virtual BOOL | CustomizeStartResize (CPoint point)
This method is called when user starts to resize control in customize mode.
virtual BOOL | IsCustomizeResizeAllow () const
This member checks if the user can resize the control.
virtual int | GetCustomizeMinWidth () const
Retrieves the available minimum width of control.
virtual int | GetCustomizeMinHeight () const
Retrieves available minimum height of the control.
void | OnCustomizeMouseMove (CPoint point)
This member is called when the mouse cursor moves in customized mode.
virtual void | OnIdleUpdate ()
This virtual method is called in idle-time processing.
virtual void | OnRemoved ()
This method is called when a control is removed from the parent controls collection.
virtual INT_PTR | OnToolHitTest (CPoint point, TOOLINFO *pTI) const
The framework calls this member function to determine whether a point is in the bounding rectangle of the specified tool.
virtual void | GenerateCommandBarList (DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam)
This method is called from SaveCommandBars to save all child command bars.
virtual void | OnActionChanged (int nProperty)
This method is called when an action property is changed.
virtual void | OnActionChanging (int nProperty)
This method is called when an action property is about to be changed.
virtual void | OnCaptionChanged ()
This method is called when the control's caption is changed.
BOOL | IsLayoutRTL () const
Determines if right-to-left (RTL) mode is set.
BOOL | IsLayoutChanged ()
Call this member to determine if the layout has changed (RTL to LTR or LTR to RLT).

Protected Attributes

int | m_nChecked
Checked ID.
int | m_nSelected
Index of selected item.
BOOL | m_bHideSelection
TRUE to hide selection.
BOOL | m_bPressed
TRUE if item is pressed.
CPoint | m_ptPressed
Position of pressed item.
int | m_nScrollPos
Scroll position.
int | m_nScrollPosTarget
Scroll position.
double | m_dAnimationStep
Number of steps to complete animation.
BOOL | m_bKeyboardSelected
TRUE if item was selected using keyboard.
int | m_nTotalHeight
Total height of items.
BOOL | m_bShowLabels
TRUE to show labels.
BOOL | m_bShowScrollBar
TRUE to show scrollbars.
BOOL | m_bShowBorders
TRUE to show borders.
CRect | m_rcMargin
Margins of gallery items.
BOOL | m_bPreview
TRUE if control is in preview mode.
int | m_nResizable
TRUE if the pop-up galley is resizable, see XTPGalleryResizable.
CArray< GALLERYITEM_POSITION, GALLERYITEM_POSITION & > | m_arrRects
bounding rectangles
- Protected Attributes inherited from CXTPControlPopup
BOOL | m_bPopup
TRUE if pop-up'ed.
CXTPCommandBar * | m_pCommandBar
Child pop-up bar.
DWORD | m_dwCommandBarID
Child pop-up ID.
BOOL | m_bShowShadow
TRUE to show shadow.
- Protected Attributes inherited from CXTPControlButton
XTPButtonStyle | m_buttonStyleEx
User-defined style of button containing vector icon.
- Protected Attributes inherited from CXTPControl
DWORD_PTR | m_nTag
Control tag.
int | m_nIndex
Index of the control.
int | m_nId
Identifier of the control.
int | m_nIconId
Identifier of the control's image.
int | m_nHelpId
Help identifier.
int | m_nCustomIconId
Identifier of the control's custom image.
BOOL | m_bWrap
TRUE if the control is wrapped.
BOOL | m_bBeginGroup
TRUE if the control starts new group.
BOOL | m_bEnabled
TRUE if the control is enabled.
BOOL | m_bChecked
TRUE if the control is checked.
BOOL | m_bSelected
TRUE if the control is selected.
BOOL | m_bPressed
TRUE if the control is pushed.
BOOL | m_bTemporary
TRUE if the control is temporary.
BOOL | m_bOnQuickAccess
TRUE if the control is a part of Quick Access panel.
CRect | m_rcRow
Bounding rectangle of the control's row.
CRect | m_rcControl
Bounding rectangle of the control.
DWORD | m_dwHideFlags
Hidden flags.
DWORD | m_dwFlags
Flags of the control.
CString | m_strCaption
Caption of the control.
CString | m_strCustomCaption
User-defined caption.
CString | m_strShortcutText
Shortcut text.
CString | m_strShortcutTextAuto
Shortcut text.
CString | m_strTooltipText
Tooltip text.
CString | m_strDescriptionText
Description text.
CString | m_strParameter
Parameter text.
CString | m_strKeyboardTip
Keyboard tip.
CXTPControls * | m_pControls
Parent control collection.
XTPControlType | m_controlType
Type of the control.
CXTPCommandBar * | m_pParent
The Parent command bar.
BOOL | m_bExpanded
TRUE if the control is expanded.
CString | m_strCategory
Category of the control.
BOOL | m_bDefaultItem
TRUE if the item is default pop-up item.
CDocTemplateMap | m_mapDocTemplatesAssigned
Assigned templates.
CDocTemplateMap | m_mapDocTemplatesExcluded
Excluded templates.
XTPButtonStyle | m_buttonStyle
Button Style.
XTPButtonStyle | m_buttonCustomStyle
User-defined style of button.
XTPButtonStyle | m_buttonRibbonStyle
User-defined style of button.
BOOL | m_bCloseSubMenuOnClick
TRUE is sub-menus are closed as soon as a control is clicked.
CXTPRibbonGroup * | m_pRibbonGroup
Ribbon group of control.
CXTPControlAction * | m_pAction
Action of the control.
int | m_nWidth
Width of the control.
int | m_nHeight
Height of the control.
int | m_nExecuteOnPressInterval
Delay between each message when control is pressed.
CSize | m_szIcon
The size of the icon used for the control.
BOOL | m_bLayoutRTL
Indicate does last layout is RTL.
- Protected Attributes inherited from CXTPScrollBase
XTP_SCROLLBAR_POSINFO | m_spi
ScrollBar position.
XTP_SCROLLBAR_TRACKINFO * | m_pSBTrack
ScrollBar tracking.
XTP_SLIDERTICKS * | m_pTicks
Slider Ticks.
XTPScrollBarStyle | m_scrollBarStyle
ScrollBar style.
BOOL | m_bAnimation
TRUE if animation enabled.
int | m_nTimerElapse
Scroll delay.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlPopup
static CXTPControlPopup *AFX_CDECL | CreateControlPopup (XTPControlType controlType)
Creates a CXTPControlPopup object with the specified type.
- Static Public Member Functions inherited from CXTPControl
static CXTPControl *AFX_CDECL | FromUI (CCmdUI *pCmdUI)
Call this member to retrieve CXTPControl from a CCmdUI structure.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

CXTPControlGallery is a CXTPControlPopup derived class.

It represents a gallery control toolbar.

Member Function Documentation

◆ Copy()

void Copy | ( | CXTPControl * | pControl,
 |  | BOOL | bRecursive = FALSE )
 protectedvirtual

This method is called to copy the control.

Parameters
pControl | Pointer to a source CXTPControl object.
bRecursive | TRUE to copy recursively.

Reimplemented from CXTPControlButton.

◆ DoPropExchange()

void DoPropExchange ( CXTPPropExchange * pPX )
protectedvirtual

Either reads this object from or writes this object to an archive.

Parameters
pPX A CXTPPropExchange object to serialize to or from.

Reimplemented from CXTPControlButton.

◆ DrawItems()

void DrawItems ( CDC * pDC )
protected

This method is called to draw all items.

Parameters
pDC Pointer to a device context to draw.

◆ EnsureVisible()

void EnsureVisible ( int nIndex )

Call this member to ensure that a specified item is visible in the gallery.

This will scroll the gallery until the specified item is visible.

Parameters
nIndex Index of the item whose visibility must be ensured.

◆ FindItem()

int FindItem | ( | int | nStartAfter,
 |  | LPCTSTR | lpszItem,
 |  | BOOL | bExact ) const

Call this method to search for an item.

Parameters
nStartAfter | Index to begin search.
lpszItem | Item caption to find.
bExact | TRUE to find whole caption or only part.
Returns
If successful, the index of the search item will be returned. If unsuccessful, a value of -1 will be returned.

◆ GetBorders()

virtual CRect GetBorders ( ) const
virtual

Call this method to get the border margins for the gallery.

Returns
A CRect object containing the border margins for the gallery.

◆ GetCheckedItem()

int GetCheckedItem ( ) const

Call this method to get the checked item identifier for the gallery.

Returns
Checked item's identifier.
See also
SetCheckedItem

◆ GetGalleryPaintManager()

CXTPControlGalleryPaintManager * GetGalleryPaintManager ( ) const

Retrieves CXTPControlGalleryPaintManager pointer to draw gallery.

Returns
Pointer to a CXTPControlGalleryPaintManager object.

◆ GetItem()

CXTPControlGalleryItem * GetItem ( int nIndex ) const

Call this method to retrieve an item by its index.

Parameters
nIndex Index of the item to be retrieved.
Returns
If successful, item at the specified index. Otherwise, NULL.
See also
SetItems, GetItemCount

◆ GetItemCaption()

CString GetItemCaption ( int nIndex )

Call this method to get the caption of an item.

Parameters
nIndex Index of the item.
Returns
Caption of the item.

◆ GetItemCount()

int GetItemCount ( ) const

Call this method to get the count of items in the gallery.

Returns
Count of items in the gallery.
See also
SetItems, GetItem

◆ GetItemDrawRect()

CRect GetItemDrawRect ( int nIndex )

Determines the bounding rectangle of the item.

Parameters
nIndex Item index.
Returns
Bounding rectangle of the item.

◆ GetItems()

virtual CXTPControlGalleryItems * GetItems ( ) const
virtual

Call this method to get items associated with the gallery.

Returns
Returns items associated with the gallery
See also
SetItems

◆ GetItemsRect()

CRect GetItemsRect ( ) const

Determines the bounding rectangle of the items.

Returns
Bounding rectangle of the items.

◆ GetNext()

long GetNext | ( | long | nIndex,
 |  | int | nDirection ) const

Call this method to get the index of the next focusable item.

Parameters
nIndex | Index to start.
nDirection | Direction to find (+1 or -1).
Returns
Index of the next focusable item.

◆ GetNextInColumn()

long GetNextInColumn | ( | long | nIndex,
 |  | int | nDirection ) const

Call this method to get the index of the next focusable item in the same column.

Parameters
nIndex | Index to start.
nDirection | Direction to find (+1 or -1).
Returns
Index of the next focusable item in the same column.

◆ GetNextInPage()

long GetNextInPage | ( | long | nIndex,
 |  | int | nDirection ) const

Call this method to get the index of the next focusable item in the same page.

Parameters
nIndex | Index to start.
nDirection | Direction to find (+1 or -1).
Returns
Index of the next focusable item in the same page.

◆ GetNextInRow()

long GetNextInRow | ( | long | nIndex,
 |  | int | nDirection ) const

Call this method to get the index of the next focusable item in the same row.

Parameters
nIndex | Index to start.
nDirection | Direction to find (+1 or -1).
Returns
Index of the next focusable item in the same row.

◆ GetScrollBarPaintManager()

CXTPScrollBarPaintManager * GetScrollBarPaintManager ( ) const
virtual

Retrieves CXTPScrollBarPaintManager pointer to draw ScrollBar.

Returns
Pointer to a CXTPScrollBarPaintManager object.

Implements CXTPScrollBase.

◆ GetScrollPos()

int GetScrollPos ( ) const

Call this method to get the scrollbar position for the gallery.

Returns
The scrollbar position.
See also
SetScrollPos

◆ GetSelectedItem()

int GetSelectedItem ( ) const

Call this method to get the selected item in the gallery.

Returns
The selected item in the gallery.
See also
SetSelectedItem

◆ HasBottomSeparator()

BOOL HasBottomSeparator ( ) const

Call this function to check if the gallery has a bottom separator.

Returns
TRUE if the gallery has a bottom separator, otherwise FALSE.

◆ HitTestItem()

int HitTestItem | ( | CPoint | point,
 |  | LPRECT | lpRect = NULL ) const

This method determines where a point lies in a specified item.

Parameters
point | Specifies the point to be tested.
lpRect | Retrieves rectangle where item is located. Can be NULL.
Returns
An index of CXTPControlGalleryItem that occupies the specified point or NULL if no control occupies the point.

◆ InvalidateItems()

void InvalidateItems | ( | LPCRECT | lpRect = NULL,
 |  | BOOL | bAnimate = TRUE )

Call this method to redraw items.

Parameters
lpRect | Rectangle to redraw.
bAnimate | TRUE to animate changes.

◆ IsItemChecked()

virtual BOOL IsItemChecked ( CXTPControlGalleryItem * pItem ) const
virtual

Call this method to determine if an item is checked.

Parameters
pItem Item to test.
Returns
TRUE if the specified item is checked, otherwise FALSE.
See also
SetCheckedItem

◆ IsItemSelected()

AFX_INLINE BOOL IsItemSelected ( ) const

Determines if any item in the gallery is selected.

Returns
TRUE if any item is selected, otherwise FALSE.
See also
GetSelectedItem

◆ IsResizable()

AFX_INLINE BOOL IsResizable ( ) const

Call this method to check if the gallery can be resized by the user.

Returns
TRUE if the gallery can be resized by the user, otherwise FALSE.
See also
SetResizable

◆ IsScrollBarAuto()

AFX_INLINE BOOL IsScrollBarAuto ( ) const

Determines if the scrollbar for the gallery is automatically shown/hidden.

Returns
TRUE if the scrollbar is automatically shown.

◆ IsScrollBarEnabled()

BOOL IsScrollBarEnabled ( ) const
virtual

Call this member to check if the scrollbar is enabled.

Returns
TRUE if the scrollbar is enabled, otherwise FALSE.

Implements CXTPScrollBase.

◆ IsScrollBarVisible()

AFX_INLINE BOOL IsScrollBarVisible ( ) const

Call this method to check if the scrollbar for the gallery is visible.

Returns
TRUE if the scrollbar is visible, otherwise FALSE.
See also
ShowScrollBar

◆ IsScrollButtonEnabled()

BOOL IsScrollButtonEnabled ( int ht )

Determines if the scrollbar button is enabled.

Parameters
ht HitTest of scrollbar button.
Returns
TRUE if the scrollbar button is enabled.

◆ IsShowBorders()

AFX_INLINE BOOL IsShowBorders ( ) const

Call this method to determine if borders are visible around the gallery.

Returns
TRUE if borders are visible, otherwise FALSE.
See also
ShowBorders

◆ IsShownAsButton()

BOOL IsShownAsButton ( ) const

Determines if the gallery is shown as a button.

Returns
TRUE if the gallery is shown as a button.

◆ IsTransparent()

AFX_INLINE BOOL IsTransparent ( ) const
virtual

Determines if the control needs to draw its background.

Returns
TRUE if the paint manager must skip filling the background of the control.

Reimplemented from CXTPControl.

◆ OnCalcDynamicSize()

void OnCalcDynamicSize ( DWORD dwMode )
protectedvirtual

This method is called before recalculating the parent command bar size to calculate the dimensions of the control.

Parameters
dwMode Flags used to determine the height and width of the dynamic command bar.

Reimplemented from CXTPControl.

◆ SetCheckedItem()

void SetCheckedItem ( int nId )

Call this method to set the checked item identifier for the gallery.

Parameters
nId Item ID.
See also
GetCheckedItem

◆ SetControlSize() [1/2]

void SetControlSize ( CSize szControl )

Call this method to set the size of the control.

Parameters
szControl New control size to be set.

◆ SetControlSize() [2/2]

void SetControlSize | ( | int | nColumns,
 |  | int | nRows,
 |  | CSize | szItem )

Call this method to the set size of the control depending on the number of rows, columns, current item size and current DPI.

Parameters
nColumns | Number of columns.
nRows | Number of rows.
szItem | Default item size.

◆ SetItems()

void SetItems ( CXTPControlGalleryItems * pItems )

Call this method to set items for the gallery.

Parameters
pItems Pointer to items to be set.

◆ SetItemsMargin()

void SetItemsMargin | ( | int | nLeft,
 |  | int | nTop,
 |  | int | nRight,
 |  | int | nBottom )

Call this method to set margins around items.

Parameters
nLeft | Left margin to be set.
nTop | Top margin to be set.
nRight | nRight margin to be set.
nBottom | Bottom margin to be set.

◆ SetResizable()

void SetResizable | ( | BOOL | bResizeWidth = TRUE,
 |  | BOOL | bResizeHeight = TRUE )

Call this method to allow the user to resize the gallery.

Parameters
bResizeWidth | Allow change width.
bResizeHeight | Allow change height.
See also
IsResizable

◆ SetScrollBarAuto()

AFX_INLINE void SetScrollBarAuto ( BOOL bScrollBarAuto )

Call this method to automatically show/hide the scrollbar for the gallery.

Parameters
bScrollBarAuto TRUE to show the scrollbar automatically.

◆ SetScrollPos()

void SetScrollPos ( int nScrollPos )

Call this method to set the scrollbar position for the gallery.

Parameters
nScrollPos New scrollbar position to be set.
See also
GetScrollPos

◆ SetSelectedItem()

void SetSelectedItem ( int nSelected )

Call this method to set the selected item in the gallery.

Parameters
nSelected Item to set as selected.
See also
GetSelectedItem

◆ SetTopIndex()

int SetTopIndex ( int nIndex )

Call this method to scroll gallery to the specified top item.

Parameters
nIndex Item to be scrolled to.
Returns
If successful, a value of 0 will be returned. If an error occurs, a value of -1 will be returned.
See also
SetScrollPos

◆ ShowBorders()

AFX_INLINE void ShowBorders ( BOOL bShowBorders )

Call this method to show/hide borders around the gallery.

Parameters
bShowBorders TRUE to show borders around the gallery.
See also
IsShowBorders

◆ ShowLabels()

AFX_INLINE void ShowLabels ( BOOL bShowLabels )

Call this method to show/hide labels for the gallery.

Parameters
bShowLabels TRUE to show labels for the gallery.

◆ ShowScrollBar()

AFX_INLINE void ShowScrollBar ( BOOL bShowScrollBar )

Call this method to show/hide the scrollbar for the gallery.

Parameters
bShowScrollBar TRUE to show the scrollbar for the gallery.
See also
IsScrollBarVisible

Member Data Documentation

◆ m_bAutoScaleDpi

BOOL m_bAutoScaleDpi
static

TRUE by default.

Enables scaling of ribbon gallery items (both inline and displayed in pop-up).

The documentation for this class was generated from the following file:
  • XTPControlGallery.h


Toolkit Pro: CXTPControlGallery::GALLERYITEM_POSITION Struct Reference

  • CXTPControlGallery
  • GALLERYITEM_POSITION
Public Attributes | List of all members
CXTPControlGallery::GALLERYITEM_POSITION Struct Reference

Structure contains item position description. More...

Public Attributes

RECT | rcItem
Bounding rectangle of the item.
CXTPControlGalleryItem * | pItem
Item pointer.
BOOL | bBeginRow
TRUE if the item starts a new row.

Detailed Description

Structure contains item position description.

The documentation for this struct was generated from the following file:
  • XTPControlGallery.h


Toolkit Pro: CXTPControlGalleryItem Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPControlGalleryItem Class Reference

CXTPControlGalleryItem is a CXTPCmdTarget derived class. More...

Inheritance diagram for CXTPControlGalleryItem:
[legend]

Public Member Functions

CXTPControlGalleryItem ()
Constructs a CXTPControlGalleryItem object.
~CXTPControlGalleryItem ()
Destroys a CXTPControlGalleryItem object, handles cleanup and deallocation.
virtual CSize | GetSize ()
This method is called to get the size of the item.
void | SetSize (CSize szItem)
Call this method to set the size of the individual item.
virtual void | Draw (CDC *pDC, CXTPControlGallery *pGallery, CRect rcItem, BOOL bEnabled, BOOL bSelected, BOOL bPressed, BOOL bChecked)
This method is called to draw the item.
CXTPImageManagerIcon * GetImage ()
Retrieves the image of the item.
BOOL | IsLabel () const
Call this method to determine if the item is a label.
void | SetCaption (LPCTSTR lpszCaption)
Call this method to set the caption of the item.
void | SetToolTip (LPCTSTR lpszToolTip)
Call this method to set the tooltip of the item.
CString | GetToolTip () const
Retrieves the tooltip of the item.
CString | GetCaption () const
Retrieves the caption of the item.
void | SetEnabled (BOOL bEnabled)
Call this member to enable or disable the item.
BOOL | GetEnabled () const
Call this member to get the state of the item.
int | GetIndex () const
Retrieves the index of the item.
void | SetID (int nId)
Call this member to set the identifier of the item.
int | GetID () const
Call this member to get the item's identifier.
void | SetData (DWORD_PTR dwData)
Sets the 32-bit value associated with the item.
DWORD_PTR | GetData () const
Retrieves the application-supplied, 32-bit value associated with the item.
void | SetDescription (LPCTSTR lpszDescription)
Call this member to set the description of the item.
CString | GetDescription () const
Call this member to get the item's description.
void | SetImageWidth (int nImageWidth)
Set the preferred image width.
int | GetImageWidth () const
Get the preferred image width.
CXTPMarkupUIElement * | GetMarkupUIElement () const
This member functions are used to get stored CXTPMarkupUIElement object.
virtual int | GetImageIndex ()
Gets the index of the used image.
virtual void | SetImageIndex (int nImageIndex)
Sets the preferred image index.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Attributes

int | m_nId
Identifier.
int | m_nIndex
Index of the item.
int | m_nImage
Image index.
CString | m_strCaption
Caption of the item.
CString | m_strToolTip
Tooltip of the item.
CString | m_strDescriptionText
Description of the item.
CXTPControlGalleryItems * | m_pItems
Parent items collection.
DWORD_PTR | m_dwData
32-bit data
CSize | m_szItem
Size of the item; CSize(0, 0) - to use default value.
BOOL | m_bLabel
TRUE if item is label.
BOOL | m_bEnabled
TRUE to enable, FALSE to disable.
int | m_nImageWidth
preferred image width (0) - to use default value

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

CXTPControlGalleryItem is a CXTPCmdTarget derived class.

It represents a single item of a gallery object.

Member Function Documentation

◆ Draw()

virtual void Draw | ( | CDC * | pDC,
 |  | CXTPControlGallery * | pGallery,
 |  | CRect | rcItem,
 |  | BOOL | bEnabled,
 |  | BOOL | bSelected,
 |  | BOOL | bPressed,
 |  | BOOL | bChecked )
 virtual

This method is called to draw the item.

Parameters
pDC | Pointer to a valid device context.
pGallery | Pointer to the parent gallery of the item.
rcItem | Bounding rectangle of the item.
bEnabled | TRUE to draw the item enabled, FALSE to draw the item disabled.
bSelected | TRUE to draw the item selected.
bPressed | TRUE to draw the item pressed.
bChecked | TRUE to draw the item checked.

◆ GetCaption()

AFX_INLINE CString GetCaption ( ) const

Retrieves the caption of the item.

Returns
The caption of the item.
See also
SetCaption, SetToolTip, GetToolTip

◆ GetData()

AFX_INLINE DWORD_PTR GetData ( ) const

Retrieves the application-supplied, 32-bit value associated with the item.

Returns
The 32-bit value associated with the item.

◆ GetDescription()

AFX_INLINE CString GetDescription ( ) const

Call this member to get the item's description.

Returns
The description of the control.

◆ GetEnabled()

BOOL GetEnabled ( ) const

Call this member to get the state of the item.

Returns
TRUE if the item is enabled, otherwise FALSE.

◆ GetID()

AFX_INLINE int GetID ( ) const

Call this member to get the item's identifier.

Returns
The identifier of the item.

◆ GetImage()

CXTPImageManagerIcon * GetImage ( )

Retrieves the image of the item.

Returns
A pointer to the image of the item.

◆ GetImageIndex()

virtual int GetImageIndex ( )
virtual

Gets the index of the used image.

Returns
The index of the image.

◆ GetImageWidth()

AFX_INLINE int GetImageWidth ( ) const

Get the preferred image width.

Returns
Preferred image width.

◆ GetIndex()

int GetIndex ( ) const

Retrieves the index of the item.

Returns
The index of the item.

◆ GetMarkupUIElement()

AFX_INLINE CXTPMarkupUIElement * GetMarkupUIElement ( ) const

This member functions are used to get stored CXTPMarkupUIElement object.

Returns
A pointer to a CXTPMarkupUIElement object.

◆ GetSize()

virtual CSize GetSize ( )
virtual

This method is called to get the size of the item.

Returns
A CSize object containing the size of the item.
See also
SetSize, CXTPControlGalleryItems::SetItemSize

◆ GetToolTip()

AFX_INLINE CString GetToolTip ( ) const

Retrieves the tooltip of the item.

Returns
The tooltip of the item.
See also
SetToolTip, SetCaption, GetCaption

◆ IsLabel()

AFX_INLINE BOOL IsLabel ( ) const

Call this method to determine if the item is a label.

Returns
TRUE if the item is a label, otherwise FALSE.

◆ SetCaption()

void SetCaption ( LPCTSTR lpszCaption )

Call this method to set the caption of the item.

Parameters
lpszCaption Caption of the item to be set.
See also
GetCaption, SetToolTip, GetToolTip

◆ SetData()

AFX_INLINE void SetData ( DWORD_PTR dwData )

Sets the 32-bit value associated with the item.

Parameters
dwData New value to be set.

◆ SetDescription()

AFX_INLINE void SetDescription ( LPCTSTR lpszDescription )

Call this member to set the description of the item.

Parameters
lpszDescription Description to be set.
See also
SetCaption, SetTooltip

◆ SetEnabled()

void SetEnabled ( BOOL bEnabled )

Call this member to enable or disable the item.

Parameters
bEnabled TRUE to enable the item, FALSE to disable the item.
See also
GetEnabled

◆ SetID()

AFX_INLINE void SetID ( int nId )

Call this member to set the identifier of the item.

Parameters
nId Identifier to be set.

◆ SetImageIndex()

virtual void SetImageIndex ( int nImageIndex )
virtual

Sets the preferred image index.

Parameters
nImageIndex New image index.

◆ SetImageWidth()

AFX_INLINE void SetImageWidth ( int nImageWidth )

Set the preferred image width.

Parameters
nImageWidth preferred image width.

◆ SetSize()

void SetSize ( CSize szItem )

Call this method to set the size of the individual item.

You can call CXTPControlGalleryItems::SetItemSize to set the default size for items.

Parameters
szItem Size of the item to be set.

◆ SetToolTip()

AFX_INLINE void SetToolTip ( LPCTSTR lpszToolTip )

Call this method to set the tooltip of the item.

Parameters
lpszToolTip Tooltip of the item to be set.
See also
GetToolTip, SetCaption, GetCaption
The documentation for this class was generated from the following file:
  • XTPControlGalleryItem.h


Toolkit Pro: CXTPControlGalleryItems Class Reference

Public Member Functions | Static Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPControlGalleryItems Class Reference

CXTPControlGalleryItems is a CXTPCmdTarget derived class. More...

Inheritance diagram for CXTPControlGalleryItems:
[legend]

Public Member Functions

void | RemoveAll ()
Call this method to remove all items in the collection.
void | Remove (int nIndex)
Call this member to remove an item.
CXTPControlGalleryItem * | AddItem (int nId, int nImage)
Call this member to add a new item.
CXTPControlGalleryItem * | AddItem (LPCTSTR lpszCaption, int nId, int nImage)
Call this member to add a new item.
CXTPControlGalleryItem * | AddItem (CXTPControlGalleryItem *pItem, int nId=-1, int nImage=-1)
Call this member to add a new item.
CXTPControlGalleryItem * | AddItem (LPCTSTR lpszCaption, int nImage=-1)
Call this member to add a new item.
CXTPControlGalleryItem * | InsertItem (int nIndex, CXTPControlGalleryItem *pItem, int nId=-1, int nImage=-1)
Call this member to insert a new item.
CXTPControlGalleryItem * | AddLabel (int nId)
Call this member to add a new label item.
CXTPControlGalleryItem * | AddLabel (LPCTSTR lpszCaption)
Call this member to add a new label item.
void | SetImageManager (CXTPImageManager *pImageManager)
Call this method to set the image manager for the items.
CXTPImageManager * | GetImageManager () const
Retrieves the image manager for the items.
CSize | GetItemSize () const
Determines the default size of the items.
void | SetItemSize (CSize szItem)
Call this method to set the size of the items.
int | GetItemCount () const
Call this member to get the count of the items.
CXTPControlGalleryItem * | GetItem (int nIndex) const
Call this member to return the item at the specified index.
void | ClipItems (BOOL bClipItems)
Call this member to enable/disable clipping items if selection was changed.
virtual void | OnItemsChanged ()
This method is called if items are added to or removed from the collection.
virtual BOOL | PreDrawItem (CDC *pDC, CXTPControlGallery *pGallery, CXTPControlGalleryItem *pItem, CRect rcItem, BOOL bEnabled, BOOL bSelected, BOOL bPressed, BOOL bChecked)
This method is called to draw the item.
CXTPControlAction * | GetAction () const
Call this method to get the actions list for command bars.
void | EnableMarkup (BOOL bEnableMarkup=TRUE)
Allows the use of a XAML snippet to be used for the text of items.
CXTPMarkupContext * | GetMarkupContext () const
Retrieves a pointer to the markup context.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Static Public Member Functions

static CXTPControlGalleryItems *AFX_CDECL | CreateItems (CXTPCommandBars *pCommandBars, int nId)
Creates new items collection for gallery control.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Protected Member Functions

CXTPControlGalleryItems (CXTPControlAction *pAction, CXTPCommandBars *pCommandBars)
Constructs a CXTPControlGalleryItems object.
~CXTPControlGalleryItems ()
Destroys a CXTPControlGalleryItems object, handles cleanup and deallocation.

Protected Attributes

CSize | m_szItem
Size of the items.
CXTPImageManager * | m_pImageManager
Image manager of items.
BOOL | m_bClipItems
TRUE to clip items.
CXTPControlAction * | m_pAction
Action of the items.
CArray< CXTPControlGalleryItem *, CXTPControlGalleryItem * > | m_arrItems
Array of items.

Detailed Description

CXTPControlGalleryItems is a CXTPCmdTarget derived class.

It represents a collection of items for gallery control.

Constructor & Destructor Documentation

◆ CXTPControlGalleryItems()

CXTPControlGalleryItems | ( | CXTPControlAction * | pAction,
 |  | CXTPCommandBars * | pCommandBars )
 protected

Constructs a CXTPControlGalleryItems object.

Parameters
pAction | Action for gallery control to link with.
pCommandBars | Commandbars object.

Protected constructor, use CreateItems to create items for gallery.

Member Function Documentation

◆ AddItem() [1/4]

CXTPControlGalleryItem * AddItem | ( | CXTPControlGalleryItem * | pItem,
 |  | int | nId = -1,
 |  | int | nImage = -1 )

Call this member to add a new item.

Parameters
pItem | Item to be added.
nId | Identifier of the item.
nImage | Image of the item.
Returns
A pointer to the added item.

◆ AddItem() [2/4]

CXTPControlGalleryItem * AddItem | ( | int | nId,
 |  | int | nImage )

Call this member to add a new item.

Parameters
nId | Identifier of the item.
nImage | Image of the item.
Returns
A pointer to the added item.

◆ AddItem() [3/4]

CXTPControlGalleryItem * AddItem | ( | LPCTSTR | lpszCaption,
 |  | int | nId,
 |  | int | nImage )

Call this member to add a new item.

Parameters
nId | Identifier of the item.
nImage | Image of the item.
lpszCaption | Caption of the item to be added.
Returns
A pointer to the added item.

◆ AddItem() [4/4]

CXTPControlGalleryItem * AddItem | ( | LPCTSTR | lpszCaption,
 |  | int | nImage = -1 )

Call this member to add a new item.

Parameters
nImage | Image of the item.
lpszCaption | Caption of the item to be added.
Returns
A pointer to the added item.

◆ AddLabel() [1/2]

CXTPControlGalleryItem * AddLabel ( int nId )

Call this member to add a new label item.

Parameters
nId Identifier of the item.
Returns
A pointer to the added item.

◆ AddLabel() [2/2]

CXTPControlGalleryItem * AddLabel ( LPCTSTR lpszCaption )

Call this member to add a new label item.

Parameters
lpszCaption Caption of the item to be added.
Returns
A pointer to the added item.

◆ ClipItems()

AFX_INLINE void ClipItems ( BOOL bClipItems )

Call this member to enable/disable clipping items if selection was changed.

Parameters
bClipItems TRUE to enable clipping, FALSE to disable clipping.

By default clipping is enabled.

◆ CreateItems()

static CXTPControlGalleryItems *AFX_CDECL CreateItems | ( | CXTPCommandBars * | pCommandBars,
 |  | int | nId )
 static

Creates new items collection for gallery control.

Parameters
pCommandBars | Parent Commandbars.
nId | Identifier of the items
Returns
A newly created gallery item collection object pointer.

◆ EnableMarkup()

void EnableMarkup ( BOOL bEnableMarkup = TRUE )

Allows the use of a XAML snippet to be used for the text of items.

Parameters
bEnableMarkup TRUE to enable markup, FALSE to disable markup.

◆ GetAction()

AFX_INLINE CXTPControlAction * GetAction ( ) const

Call this method to get the actions list for command bars.

Returns
A pointer to the actions list for command bars.

◆ GetImageManager()

AFX_INLINE CXTPImageManager * GetImageManager ( ) const

Retrieves the image manager for the items.

Returns
The image manager for the items.

◆ GetItem()

CXTPControlGalleryItem * GetItem ( int nIndex ) const

Call this member to return the item at the specified index.

Parameters
nIndex An integer index.
Returns
The CXTPControlGalleryItem pointer currently at this index.

◆ GetItemCount()

int GetItemCount ( ) const

Call this member to get the count of the items.

Returns
The count of the items in the collection.

◆ GetItemSize()

AFX_INLINE CSize GetItemSize ( ) const

Determines the default size of the items.

Returns
The default size of the items.
See also
SetItemSize

◆ GetMarkupContext()

AFX_INLINE CXTPMarkupContext * GetMarkupContext ( ) const

Retrieves a pointer to the markup context.

Returns
A pointer to a CXTPMarkupContext object.

◆ InsertItem()

CXTPControlGalleryItem * InsertItem | ( | int | nIndex,
 |  | CXTPControlGalleryItem * | pItem,
 |  | int | nId = -1,
 |  | int | nImage = -1 )

Call this member to insert a new item.

Parameters
nIndex | Index to insert new item.
pItem | Item to be added.
nId | Identifier of the item.
nImage | Image of the item.
Returns
A pointer to the added item.

◆ PreDrawItem()

virtual BOOL PreDrawItem | ( | CDC * | pDC,
 |  | CXTPControlGallery * | pGallery,
 |  | CXTPControlGalleryItem * | pItem,
 |  | CRect | rcItem,
 |  | BOOL | bEnabled,
 |  | BOOL | bSelected,
 |  | BOOL | bPressed,
 |  | BOOL | bChecked )
 virtual

This method is called to draw the item.

Parameters
pDC | Pointer to a valid device context.
pGallery | Pointer to the parent gallery of the item.
pItem | Pointer to the item to be drawn.
rcItem | Bounding rectangle of the item.
bEnabled | TRUE to draw the item enabled, FALSE to draw the item disabled.
bSelected | TRUE to draw the item selected.
bPressed | TRUE to draw the item pressed.
bChecked | TRUE to draw the item checked.
Returns
Draws the item

◆ Remove()

void Remove ( int nIndex )

Call this member to remove an item.

Parameters
nIndex Index of the item to be removed.

◆ SetImageManager()

void SetImageManager ( CXTPImageManager * pImageManager )

Call this method to set the image manager for the items.

Parameters
pImageManager New image manager to be set.

◆ SetItemSize()

void SetItemSize ( CSize szItem )

Call this method to set the size of the items.

Parameters
szItem New size to be set.
See also
GetItemSize
The documentation for this class was generated from the following file:
  • XTPControlGalleryItems.h


Toolkit Pro: CXTPControlGalleryNativeWindows10Theme Class Reference

Public Member Functions | List of all members
CXTPControlGalleryNativeWindows10Theme Class Reference

The CXTPControlGalleryResourceTheme class is used to enable a Gallery Native Windows 10 style theme for Command Bars. More...

Inheritance diagram for CXTPControlGalleryNativeWindows10Theme:
[legend]

Public Member Functions

CXTPControlGalleryNativeWindows10Theme (CXTPPaintManager *pPaintManager)
Constructs a CXTPControlGalleryNativeWindows10Theme object.
- Public Member Functions inherited from CXTPControlGalleryOffice2013Theme
CXTPControlGalleryOffice2013Theme (CXTPPaintManager *pPaintManager)
Constructs a CXTPControlGalleryOffice2013Theme object.
virtual void | RefreshMetrics ()
This method is called to refresh the visual metrics of the manager.
virtual void | DrawPopupScrollBar (CDC *pDC, CXTPControlGallery *pGallery)
This method is called to draw the scrollbar of the inplace gallery.
- Public Member Functions inherited from CXTPControlGalleryPaintManager
CXTPControlGalleryPaintManager (CXTPPaintManager *pPaintManager)
Constructs a CXTPControlGalleryPaintManager object.
virtual void | DrawLabel (CDC *pDC, CXTPControlGalleryItem *pLabel, CRect rc)
This method is called to draw a label control.

Additional Inherited Members

- Public Attributes inherited from CXTPControlGalleryPaintManager
int | m_cyPopupUp
Height of up arrow of in-place scrollbar.
int | m_cyPopupDown
Height of down arrow of in-place scrollbar.
int | m_cxPopup
Width of arrows of in-place scrollbar.
- Protected Member Functions inherited from CXTPControlGalleryOffice2013Theme
virtual void | FillControl (CDC *pDC, CXTPControlGallery *pGallery, CRect rc)
This method is called to draw the background of the gallery.
- Protected Attributes inherited from CXTPControlGalleryOffice2013Theme

Detailed Description

The CXTPControlGalleryResourceTheme class is used to enable a Gallery Native Windows 10 style theme for Command Bars.

See also
CXTPPaintManager::SetTheme

Constructor & Destructor Documentation

◆ CXTPControlGalleryNativeWindows10Theme()

CXTPControlGalleryNativeWindows10Theme ( CXTPPaintManager * pPaintManager )

Constructs a CXTPControlGalleryNativeWindows10Theme object.

Parameters
pPaintManager Reference to a CXTPPaintManager object.
The documentation for this class was generated from the following file:
  • XTPControlGalleryNativeWindows10Theme.h


Toolkit Pro: CXTPControlGalleryNativeWindows11Theme Class Reference

Public Member Functions | List of all members
CXTPControlGalleryNativeWindows11Theme Class Reference

The CXTPControlGalleryResourceTheme class is used to enable a Gallery Native Windows 10 style theme for Command Bars. More...

Inheritance diagram for CXTPControlGalleryNativeWindows11Theme:
[legend]

Public Member Functions

CXTPControlGalleryNativeWindows11Theme (CXTPPaintManager *pPaintManager)
Constructs a CXTPControlGalleryNativeWindows11Theme object.
- Public Member Functions inherited from CXTPControlGalleryOffice2013Theme
CXTPControlGalleryOffice2013Theme (CXTPPaintManager *pPaintManager)
Constructs a CXTPControlGalleryOffice2013Theme object.
virtual void | RefreshMetrics ()
This method is called to refresh the visual metrics of the manager.
virtual void | DrawPopupScrollBar (CDC *pDC, CXTPControlGallery *pGallery)
This method is called to draw the scrollbar of the inplace gallery.
- Public Member Functions inherited from CXTPControlGalleryPaintManager
CXTPControlGalleryPaintManager (CXTPPaintManager *pPaintManager)
Constructs a CXTPControlGalleryPaintManager object.
virtual void | DrawLabel (CDC *pDC, CXTPControlGalleryItem *pLabel, CRect rc)
This method is called to draw a label control.

Additional Inherited Members

- Public Attributes inherited from CXTPControlGalleryPaintManager
int | m_cyPopupUp
Height of up arrow of in-place scrollbar.
int | m_cyPopupDown
Height of down arrow of in-place scrollbar.
int | m_cxPopup
Width of arrows of in-place scrollbar.
- Protected Member Functions inherited from CXTPControlGalleryOffice2013Theme
virtual void | FillControl (CDC *pDC, CXTPControlGallery *pGallery, CRect rc)
This method is called to draw the background of the gallery.
- Protected Attributes inherited from CXTPControlGalleryOffice2013Theme

Detailed Description

The CXTPControlGalleryResourceTheme class is used to enable a Gallery Native Windows 10 style theme for Command Bars.

See also
CXTPPaintManager::SetTheme

Constructor & Destructor Documentation

◆ CXTPControlGalleryNativeWindows11Theme()

CXTPControlGalleryNativeWindows11Theme ( CXTPPaintManager * pPaintManager )

Constructs a CXTPControlGalleryNativeWindows11Theme object.

Parameters
pPaintManager Reference to a CXTPPaintManager object.
The documentation for this class was generated from the following file:
  • XTPControlGalleryNativeWindows11Theme.h


Toolkit Pro: CXTPControlGalleryOffice2013Theme Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPControlGalleryOffice2013Theme Class Reference

The CXTPControlGalleryResourceTheme class is used to enable a Gallery Office 2013 style theme for Command Bars. More...

Inheritance diagram for CXTPControlGalleryOffice2013Theme:
[legend]

Public Member Functions

CXTPControlGalleryOffice2013Theme (CXTPPaintManager *pPaintManager)
Constructs a CXTPControlGalleryOffice2013Theme object.
virtual void | RefreshMetrics ()
This method is called to refresh the visual metrics of the manager.
virtual void | DrawPopupScrollBar (CDC *pDC, CXTPControlGallery *pGallery)
This method is called to draw the scrollbar of the inplace gallery.
- Public Member Functions inherited from CXTPControlGalleryPaintManager
CXTPControlGalleryPaintManager (CXTPPaintManager *pPaintManager)
Constructs a CXTPControlGalleryPaintManager object.
virtual void | DrawLabel (CDC *pDC, CXTPControlGalleryItem *pLabel, CRect rc)
This method is called to draw a label control.

Protected Member Functions

virtual void FillControl (CDC *pDC, CXTPControlGallery *pGallery, CRect rc)
This method is called to draw the background of the gallery.

Additional Inherited Members

- Public Attributes inherited from CXTPControlGalleryPaintManager
int | m_cyPopupUp
Height of up arrow of in-place scrollbar.
int | m_cyPopupDown
Height of down arrow of in-place scrollbar.
int | m_cxPopup
Width of arrows of in-place scrollbar.

Detailed Description

The CXTPControlGalleryResourceTheme class is used to enable a Gallery Office 2013 style theme for Command Bars.

See also
CXTPPaintManager::SetTheme

Constructor & Destructor Documentation

◆ CXTPControlGalleryOffice2013Theme()

CXTPControlGalleryOffice2013Theme ( CXTPPaintManager * pPaintManager )

Constructs a CXTPControlGalleryOffice2013Theme object.

Parameters
pPaintManager Reference to a CXTPPaintManager object.

Member Function Documentation

◆ DrawPopupScrollBar()

virtual void DrawPopupScrollBar | ( | CDC * | pDC,
 |  | CXTPControlGallery * | pGallery )
 virtual

This method is called to draw the scrollbar of the inplace gallery.

Parameters
pDC | Pointer to device context.
pGallery | CXTPControlGallery object to draw.
See also
DrawScrollBar

Reimplemented from CXTPControlGalleryPaintManager.

◆ FillControl()

virtual void FillControl | ( | CDC * | pDC,
 |  | CXTPControlGallery * | pGallery,
 |  | CRect | rc )
 protectedvirtual

This method is called to draw the background of the gallery.

Parameters
pDC | Pointer to device context.
pGallery | CXTPControlGallery object to draw.
rc | Bounding rectangle of gallery object.

Reimplemented from CXTPControlGalleryPaintManager.

The documentation for this class was generated from the following file:
  • XTPControlGalleryOffice2013Theme.h


Toolkit Pro: CXTPControlGalleryPaintManager Class Reference

Public Member Functions | Public Attributes | List of all members
CXTPControlGalleryPaintManager Class Reference

CXTPControlGalleryPaintManager is a standalone class used to draw a CXTPControlGallery object. More...

Inheritance diagram for CXTPControlGalleryPaintManager:
[legend]

Public Member Functions

CXTPControlGalleryPaintManager (CXTPPaintManager *pPaintManager)
Constructs a CXTPControlGalleryPaintManager object.
virtual void | DrawLabel (CDC *pDC, CXTPControlGalleryItem *pLabel, CRect rc)
This method is called to draw a label control.
virtual void | FillControl (CDC *pDC, CXTPControlGallery *pGallery, CRect rc)
This method is called to draw the background of the gallery.
virtual void | DrawPopupScrollBar (CDC *pDC, CXTPControlGallery *pGallery)
This method is called to draw the scrollbar for an in-place gallery.
virtual void | RefreshMetrics ()
Recalculates gallery metrics.

Public Attributes

int | m_cyPopupUp
Height of up arrow of in-place scrollbar.
int | m_cyPopupDown
Height of down arrow of in-place scrollbar.
int | m_cxPopup
Width of arrows of in-place scrollbar.

Detailed Description

CXTPControlGalleryPaintManager is a standalone class used to draw a CXTPControlGallery object.

Constructor & Destructor Documentation

◆ CXTPControlGalleryPaintManager()

CXTPControlGalleryPaintManager ( CXTPPaintManager * pPaintManager )

Constructs a CXTPControlGalleryPaintManager object.

Parameters
pPaintManager PaintManager of command bars.

Member Function Documentation

◆ DrawLabel()

virtual void DrawLabel | ( | CDC * | pDC,
 |  | CXTPControlGalleryItem * | pLabel,
 |  | CRect | rc )
 virtual

This method is called to draw a label control.

Parameters
pDC | Pointer to a device context.
pLabel | Label item.
rc | Bounding rectangle of the label.

Reimplemented in CXTPControlGalleryResourceTheme.

◆ DrawPopupScrollBar()

virtual void DrawPopupScrollBar | ( | CDC * | pDC,
 |  | CXTPControlGallery * | pGallery )
 virtual

This method is called to draw the scrollbar for an in-place gallery.

Parameters
pDC | Pointer to device context.
pGallery | CXTPControlGallery object to draw.
See also
DrawScrollBar

Reimplemented in CXTPControlGalleryOffice2013Theme, and CXTPControlGalleryResourceTheme.

◆ FillControl()

virtual void FillControl | ( | CDC * | pDC,
 |  | CXTPControlGallery * | pGallery,
 |  | CRect | rc )
 virtual

This method is called to draw the background of the gallery.

Parameters
pDC | Pointer to a device context.
rc | Bounding rectangle of gallery object.
pGallery | CXTPControlGallery object to draw.

Reimplemented in CXTPControlGalleryOffice2013Theme, and CXTPControlGalleryResourceTheme.

The documentation for this class was generated from the following file:
  • XTPControlGallery.h


Toolkit Pro: CXTPControlGalleryResourceTheme Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPControlGalleryResourceTheme Class Reference

The CXTPControlGalleryResourceTheme class is used to enable a Gallery Resource style theme for Command Bars. More...

Inheritance diagram for CXTPControlGalleryResourceTheme:
[legend]

Public Member Functions

CXTPControlGalleryResourceTheme (CXTPPaintManager *pPaintManager)
Constructs a CXTPControlGalleryResourceTheme object.
virtual void | FillControl (CDC *pDC, CXTPControlGallery *pGallery, CRect rc)
This method is called to draw the background of the gallery.
virtual void | DrawPopupScrollBar (CDC *pDC, CXTPControlGallery *pGallery)
This method is called to draw the scrollbar of the inplace gallery.
virtual void | DrawLabel (CDC *pDC, CXTPControlGalleryItem *pLabel, CRect rc)
This method is called to draw the label control.
virtual void | RefreshMetrics ()
This method is called to refresh the visual metrics of the manager.
- Public Member Functions inherited from CXTPControlGalleryPaintManager
CXTPControlGalleryPaintManager (CXTPPaintManager *pPaintManager)
Constructs a CXTPControlGalleryPaintManager object.

Protected Attributes

COLORREF | m_clrControlGallerySelected
Selected item color.
COLORREF | m_clrControlGalleryNormal
Normal item color.
COLORREF | m_clrControlGalleryBorder
Border color.

Additional Inherited Members

- Public Attributes inherited from CXTPControlGalleryPaintManager
int | m_cyPopupUp
Height of up arrow of in-place scrollbar.
int | m_cyPopupDown
Height of down arrow of in-place scrollbar.
int | m_cxPopup
Width of arrows of in-place scrollbar.

Detailed Description

The CXTPControlGalleryResourceTheme class is used to enable a Gallery Resource style theme for Command Bars.

See also
CXTPPaintManager::SetTheme

Constructor & Destructor Documentation

◆ CXTPControlGalleryResourceTheme()

CXTPControlGalleryResourceTheme ( CXTPPaintManager * pPaintManager )

Constructs a CXTPControlGalleryResourceTheme object.

Parameters
pPaintManager Reference to a CXTPPaintManager object.

Member Function Documentation

◆ DrawLabel()

virtual void DrawLabel | ( | CDC * | pDC,
 |  | CXTPControlGalleryItem * | pLabel,
 |  | CRect | rc )
 virtual

This method is called to draw the label control.

Parameters
pDC | Pointer to device context.
pLabel | Label item.
rc | Bounding rectangle of the label.

Reimplemented from CXTPControlGalleryPaintManager.

◆ DrawPopupScrollBar()

virtual void DrawPopupScrollBar | ( | CDC * | pDC,
 |  | CXTPControlGallery * | pGallery )
 virtual

This method is called to draw the scrollbar of the inplace gallery.

Parameters
pDC | Pointer to device context.
pGallery | CXTPControlGallery object to draw.
See also
DrawScrollBar

Reimplemented from CXTPControlGalleryPaintManager.

◆ FillControl()

virtual void FillControl | ( | CDC * | pDC,
 |  | CXTPControlGallery * | pGallery,
 |  | CRect | rc )
 virtual

This method is called to draw the background of the gallery.

Parameters
pDC | Pointer to device context.
pGallery | CXTPControlGallery object to draw.
rc | Bounding rectangle of gallery object.

Reimplemented from CXTPControlGalleryPaintManager.

The documentation for this class was generated from the following file:
  • XTPControlGalleryResourceTheme.h


Toolkit Pro: CXTPControlGalleryVisualStudio2015Theme Class Reference

Public Member Functions | List of all members
CXTPControlGalleryVisualStudio2015Theme Class Reference

The CXTPControlGalleryResourceTheme class is used to enable a Gallery Visual Studio 2015 style theme for Command Bars. More...

Inheritance diagram for CXTPControlGalleryVisualStudio2015Theme:
[legend]

Public Member Functions

CXTPControlGalleryVisualStudio2015Theme (CXTPPaintManager *pPaintManager)
Constructs a CXTPControlGalleryVisualStudio2015Theme object.
- Public Member Functions inherited from CXTPControlGalleryOffice2013Theme
CXTPControlGalleryOffice2013Theme (CXTPPaintManager *pPaintManager)
Constructs a CXTPControlGalleryOffice2013Theme object.
virtual void | RefreshMetrics ()
This method is called to refresh the visual metrics of the manager.
virtual void | DrawPopupScrollBar (CDC *pDC, CXTPControlGallery *pGallery)
This method is called to draw the scrollbar of the inplace gallery.
- Public Member Functions inherited from CXTPControlGalleryPaintManager
CXTPControlGalleryPaintManager (CXTPPaintManager *pPaintManager)
Constructs a CXTPControlGalleryPaintManager object.
virtual void | DrawLabel (CDC *pDC, CXTPControlGalleryItem *pLabel, CRect rc)
This method is called to draw a label control.

Additional Inherited Members

- Public Attributes inherited from CXTPControlGalleryPaintManager
int | m_cyPopupUp
Height of up arrow of in-place scrollbar.
int | m_cyPopupDown
Height of down arrow of in-place scrollbar.
int | m_cxPopup
Width of arrows of in-place scrollbar.
- Protected Member Functions inherited from CXTPControlGalleryOffice2013Theme
virtual void | FillControl (CDC *pDC, CXTPControlGallery *pGallery, CRect rc)
This method is called to draw the background of the gallery.
- Protected Attributes inherited from CXTPControlGalleryOffice2013Theme

Detailed Description

The CXTPControlGalleryResourceTheme class is used to enable a Gallery Visual Studio 2015 style theme for Command Bars.

See also
CXTPPaintManager::SetTheme

Constructor & Destructor Documentation

◆ CXTPControlGalleryVisualStudio2015Theme()

CXTPControlGalleryVisualStudio2015Theme ( CXTPPaintManager * pPaintManager )

Constructs a CXTPControlGalleryVisualStudio2015Theme object.

Parameters
pPaintManager Reference to a CXTPPaintManager object.
The documentation for this class was generated from the following file:
  • XTPControlGalleryVisualStudio2015Theme.h


Toolkit Pro: CXTPControlGalleryVisualStudio2017Theme Class Reference

Public Member Functions | List of all members
CXTPControlGalleryVisualStudio2017Theme Class Reference

The CXTPControlGalleryResourceTheme class is used to enable a Gallery Visual Studio 2017 style theme for Command Bars. More...

Inheritance diagram for CXTPControlGalleryVisualStudio2017Theme:
[legend]

Public Member Functions

CXTPControlGalleryVisualStudio2017Theme (CXTPPaintManager *pPaintManager)
Constructs a CXTPControlGalleryVisualStudio2017Theme object.
- Public Member Functions inherited from CXTPControlGalleryOffice2013Theme
CXTPControlGalleryOffice2013Theme (CXTPPaintManager *pPaintManager)
Constructs a CXTPControlGalleryOffice2013Theme object.
virtual void | RefreshMetrics ()
This method is called to refresh the visual metrics of the manager.
virtual void | DrawPopupScrollBar (CDC *pDC, CXTPControlGallery *pGallery)
This method is called to draw the scrollbar of the inplace gallery.
- Public Member Functions inherited from CXTPControlGalleryPaintManager
CXTPControlGalleryPaintManager (CXTPPaintManager *pPaintManager)
Constructs a CXTPControlGalleryPaintManager object.
virtual void | DrawLabel (CDC *pDC, CXTPControlGalleryItem *pLabel, CRect rc)
This method is called to draw a label control.

Additional Inherited Members

- Public Attributes inherited from CXTPControlGalleryPaintManager
int | m_cyPopupUp
Height of up arrow of in-place scrollbar.
int | m_cyPopupDown
Height of down arrow of in-place scrollbar.
int | m_cxPopup
Width of arrows of in-place scrollbar.
- Protected Member Functions inherited from CXTPControlGalleryOffice2013Theme
virtual void | FillControl (CDC *pDC, CXTPControlGallery *pGallery, CRect rc)
This method is called to draw the background of the gallery.
- Protected Attributes inherited from CXTPControlGalleryOffice2013Theme

Detailed Description

The CXTPControlGalleryResourceTheme class is used to enable a Gallery Visual Studio 2017 style theme for Command Bars.

See also
CXTPPaintManager::SetTheme

Constructor & Destructor Documentation

◆ CXTPControlGalleryVisualStudio2017Theme()

CXTPControlGalleryVisualStudio2017Theme ( CXTPPaintManager * pPaintManager )

Constructs a CXTPControlGalleryVisualStudio2017Theme object.

Parameters
pPaintManager Reference to a CXTPPaintManager object.
The documentation for this class was generated from the following file:
  • XTPControlGalleryVisualStudio2017Theme.h


Toolkit Pro: CXTPControlGalleryVisualStudio2019Theme Class Reference

Public Member Functions | List of all members
CXTPControlGalleryVisualStudio2019Theme Class Reference

The CXTPControlGalleryResourceTheme class is used to enable a Gallery Visual Studio 2019 style theme for Command Bars. More...

Inheritance diagram for CXTPControlGalleryVisualStudio2019Theme:
[legend]

Public Member Functions

CXTPControlGalleryVisualStudio2019Theme (CXTPPaintManager *pPaintManager)
Constructs a CXTPControlGalleryVisualStudio2019Theme object.
- Public Member Functions inherited from CXTPControlGalleryOffice2013Theme
CXTPControlGalleryOffice2013Theme (CXTPPaintManager *pPaintManager)
Constructs a CXTPControlGalleryOffice2013Theme object.
virtual void | RefreshMetrics ()
This method is called to refresh the visual metrics of the manager.
virtual void | DrawPopupScrollBar (CDC *pDC, CXTPControlGallery *pGallery)
This method is called to draw the scrollbar of the inplace gallery.
- Public Member Functions inherited from CXTPControlGalleryPaintManager
CXTPControlGalleryPaintManager (CXTPPaintManager *pPaintManager)
Constructs a CXTPControlGalleryPaintManager object.
virtual void | DrawLabel (CDC *pDC, CXTPControlGalleryItem *pLabel, CRect rc)
This method is called to draw a label control.

Additional Inherited Members

- Public Attributes inherited from CXTPControlGalleryPaintManager
int | m_cyPopupUp
Height of up arrow of in-place scrollbar.
int | m_cyPopupDown
Height of down arrow of in-place scrollbar.
int | m_cxPopup
Width of arrows of in-place scrollbar.
- Protected Member Functions inherited from CXTPControlGalleryOffice2013Theme
virtual void | FillControl (CDC *pDC, CXTPControlGallery *pGallery, CRect rc)
This method is called to draw the background of the gallery.
- Protected Attributes inherited from CXTPControlGalleryOffice2013Theme

Detailed Description

The CXTPControlGalleryResourceTheme class is used to enable a Gallery Visual Studio 2019 style theme for Command Bars.

See also
CXTPPaintManager::SetTheme

Constructor & Destructor Documentation

◆ CXTPControlGalleryVisualStudio2019Theme()

CXTPControlGalleryVisualStudio2019Theme ( CXTPPaintManager * pPaintManager )

Constructs a CXTPControlGalleryVisualStudio2019Theme object.

Parameters
pPaintManager Reference to a CXTPPaintManager object.
The documentation for this class was generated from the following file:
  • XTPControlGalleryVisualStudio2019Theme.h


Toolkit Pro: CXTPControlGalleryVisualStudio2022Theme Class Reference

Public Member Functions | List of all members
CXTPControlGalleryVisualStudio2022Theme Class Reference

The CXTPControlGalleryResourceTheme class is used to enable a Gallery Visual Studio 2022 style theme for Command Bars. More...

Inheritance diagram for CXTPControlGalleryVisualStudio2022Theme:
[legend]

Public Member Functions

CXTPControlGalleryVisualStudio2022Theme (CXTPPaintManager *pPaintManager)
Constructs a CXTPControlGalleryVisualStudio2022Theme object.
- Public Member Functions inherited from CXTPControlGalleryOffice2013Theme
CXTPControlGalleryOffice2013Theme (CXTPPaintManager *pPaintManager)
Constructs a CXTPControlGalleryOffice2013Theme object.
virtual void | RefreshMetrics ()
This method is called to refresh the visual metrics of the manager.
virtual void | DrawPopupScrollBar (CDC *pDC, CXTPControlGallery *pGallery)
This method is called to draw the scrollbar of the inplace gallery.
- Public Member Functions inherited from CXTPControlGalleryPaintManager
CXTPControlGalleryPaintManager (CXTPPaintManager *pPaintManager)
Constructs a CXTPControlGalleryPaintManager object.
virtual void | DrawLabel (CDC *pDC, CXTPControlGalleryItem *pLabel, CRect rc)
This method is called to draw a label control.

Additional Inherited Members

- Public Attributes inherited from CXTPControlGalleryPaintManager
int | m_cyPopupUp
Height of up arrow of in-place scrollbar.
int | m_cyPopupDown
Height of down arrow of in-place scrollbar.
int | m_cxPopup
Width of arrows of in-place scrollbar.
- Protected Member Functions inherited from CXTPControlGalleryOffice2013Theme
virtual void | FillControl (CDC *pDC, CXTPControlGallery *pGallery, CRect rc)
This method is called to draw the background of the gallery.
- Protected Attributes inherited from CXTPControlGalleryOffice2013Theme

Detailed Description

The CXTPControlGalleryResourceTheme class is used to enable a Gallery Visual Studio 2022 style theme for Command Bars.

See also
CXTPPaintManager::SetTheme

Constructor & Destructor Documentation

◆ CXTPControlGalleryVisualStudio2022Theme()

CXTPControlGalleryVisualStudio2022Theme ( CXTPPaintManager * pPaintManager )

Constructs a CXTPControlGalleryVisualStudio2022Theme object.

Parameters
pPaintManager Reference to a CXTPPaintManager object.
The documentation for this class was generated from the following file:
  • XTPControlGalleryVisualStudio2022Theme.h


Toolkit Pro: CXTPControlHyperlink Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPControlHyperlink Class Reference

CXTPControlHyperlink is a CXTPControl derived class. More...

Inheritance diagram for CXTPControlHyperlink:
[legend]

Public Member Functions

CXTPControlHyperlink ()
Constructs a CXTPControlHyperlink object.
- Public Member Functions inherited from CXTPControl
void | SetStyle (XTPButtonStyle buttonStyle)
Call this member to set the style of the control.
XTPButtonStyle | GetStyle () const
Call this member to get the control's style.
void | SetCaption (LPCTSTR lpszCaption)
Call this member to set the caption of the control.
void | SetCaption (UINT nIDCaption)
Call this member to set the caption of the control.
virtual CString | GetCaption () const
Call this member to get the control's caption.
void | SetShortcutText (LPCTSTR lpszShortcutText)
Call this member to set the shortcut string to the control.
CString | GetShortcutText () const
Call this member to get the control's shortcut.
void | SetDescription (LPCTSTR lpszDescription)
Call this member to set the description of the control.
virtual CString | GetDescription () const
Call this member to get the control's description.
void | SetTooltip (LPCTSTR lpszTooltip)
Call this member to set the tooltip of the control.
virtual CString | GetTooltip () const
Call this member to get the control's tooltip.
void | SetKeyboardTip (LPCTSTR lpszKeyboardTip)
Call this member to set the keyboard tip to the control.
CString | GetKeyboardTip () const
Call this member to get the keyboard tip.
void | SetCustomShortcutText (LPCTSTR lpszCustomShortcutText)
Call this member to set the text displayed for the shortcut in a pop-up menu.
CString | GetCustomShortcutText () const
Call this member to get the control's text displayed for the shortcut in a pop-up menu.
void | SetParameter (LPCTSTR lpszParameter)
Call this member to set the parameter of the control.
CString | GetParameter () const
Call this member to get the control's parameter.
void | SetID (int nId)
Call this member to set the identifier of the control.
int | GetID () const
Call this member to get the control's identifier.
long | GetIndex () const
Call this member to get the index of the control.
void | SetIconId (int nId)
Call this member to set the control icon's identifier.
int | GetIconId () const
Call this member to get the icon's identifier.
void | SetHelpId (int nId)
Call this member to set the control help identifier.
int | GetHelpId () const
Call this member to get the help identifier.
virtual void | SetBeginGroup (BOOL bBeginGroup)
Call this member to begin a new group using a separator.
BOOL | GetBeginGroup () const
Call this member to determine if the control has a separator.
virtual void | SetEnabled (BOOL bEnabled)
Call this member to enable/disable the control.
BOOL | GetEnabled () const
Call this member to check if the control is enabled.
virtual void | OnEnabledChanged ()
This method is called when a control's enabled state is changed.
virtual void | SetChecked (BOOL bChecked)
Call this member to set the checked state of the control.
BOOL | GetChecked () const
Call this member to get the checked state of the control.
virtual int | GetSelected () const
Call this member to check if the control is selected.
void | SetOnQuickAccess (BOOL bOnQuicAccess=FALSE)
Call this member to set whether a control should be a part of the Quick Access panel.
BOOL | IsOnQuickAccess () const
Call this member to check if a control is a part of the Quick Access panel.
virtual void | SetFocused (BOOL bFocused)
Call this member to set the focused state of the control.
virtual BOOL | IsFocused () const
Call this member to check the focused state of the control.
void | SetPressed (BOOL bPressed)
Call this member to set the pressed state of the control.
virtual BOOL | GetPressed () const
Call this member to check the pressed state of the control.
virtual void | SetRect (CRect rcControl)
This member is called to set the bounding rectangle of the control.
CRect | GetRect () const
Call this member to get the bounding rectangle of the control.
CXTPCommandBar * | GetParent () const
Call this member to get the parent command bar.
virtual BOOL | IsVisible (DWORD dwSkipFlags=0) const
Call this member to determine if the control is visible.
virtual BOOL | IsCaptionVisible () const
Call this member to determine if the caption of the control is visible.
void | SetVisible (BOOL bVisible)
Call this member to set the visibility of the control.
CXTPControls * | GetControls () const
Call this member to get the parent controls collection.
XTPControlType | GetType () const
Call this member to get the control's type.
void | SetFlags (DWORD dwFlags)
Call this member to set the flags of the control.
DWORD | GetFlags () const
Call this member to retrieve control special flags.
void | SetTag (DWORD_PTR dwTag)
This method sets the 32-bit value associated with the control.
DWORD_PTR | GetTag () const
This method retrieves the application-supplied, 32-bit value associated with the control.
virtual BOOL | Compare (CXTPControl *pOther)
Call this member to compare controls.
virtual CXTPCommandBar * | GetCommandBar () const
Call this member to get the child command bar.
void | SetCloseSubMenuOnClick (BOOL bCloseOnClick)
Call this member function to enable/disable the closing of sub-menus when a control is clicked in the menu.
BOOL | GetCloseSubMenuOnClick () const
Call this member function to check if sub-menus will close as soon as a control is clicked.
void | SetExecuteOnPressInterval (int nExecuteOnPressInterval)
Call this method to set the delay (in milliseconds) between WM_COMMAND messages while a button is pressed by the user.
int | GetExecuteOnPressInterval () const
Call this method to get the delay (in milliseconds) between WM_COMMAND messages while a button is pressed by the user.
CXTPRibbonGroup * | GetRibbonGroup () const
Returns the ribbon group that the control belongs to.
virtual BOOL | IsTransparent () const
Determines if the control needs to draw its background.
void | SetHideWrap (BOOL bHide)
This method is called to hide the control.
virtual void | SetHideFlags (DWORD dwFlags)
This method is called to hide the control.
BOOL | SetHideFlag (XTPControlHideFlags dwFlag, BOOL bSet)
Call this member to set/remove hide flags.
DWORD | GetHideFlags () const
Call this method to retrieve hidden flags.
CRect | GetRowRect () const
Call this method to retrieve the position of the control's row.
BOOL | GetWrap () const
Call this method to check if the control is wrapped.
void | SetRowRect (CRect rcRow)
Call this method to set the row of the control.
void | SetWrap (BOOL bWrap)
Call this member to set the control to wrapped.
BOOL | GetExpanded () const
Call this member to check if the control is expanded.
BOOL | IsCursorOver () const
Call this member to determine if the mouse pointer is over the control.
virtual void | OnCalcDynamicSize (DWORD dwMode)
This method is called before recalculating the parent command bar size to calculate the dimensions of the control.
void | DelayRedrawParent ()
Call this method to redraw the parent command bar.
void | DelayLayoutParent ()
Call this method to recalculate the parent command bar size.
void | SetCategory (LPCTSTR lpszCategory)
Call this method to set the category of the control.
CString | GetCategory () const
Call this method to retrieve the category of the control.
CXTPImageManager * | GetImageManager () const
Call this method to retrieve the image manager.
CXTPPaintManager * | GetPaintManager () const
Call this method to retrieve the paint manager.
virtual CXTPImageManagerIcon * | GetImage (int nWidth=16) const
Call this method to retrieve the image of the control.
void | AssignDocTemplate (UINT nIDResource)
Call this method to assign a document template to the control.
void | ExcludeDocTemplate (UINT nIDResource)
Call this method to exclude the document template from control.
BOOL | IsItemDefault () const
Call this method to check if a control is a default menu item.
void | SetItemDefault (BOOL bDefault)
Call this method to set a control to be a default menu item.
BOOL | IsTemporary () const
Call this method to determine if a control is temporary.
void | Reset ()
Call this member to reset the icon and caption of a control to its default settings before it was customized by the user.
void | SetPrompt (LPCTSTR lpszPrompt)
Call this member to load a string from a STRINGTABLE resource to set the tooltip and description of a control.
void | SetCustomIcon (HICON hIcon)
Call this member to set a custom icon to this control.
virtual void | DoPropExchange (CXTPPropExchange *pPX)
Either reads this object from or writes this object to an archive.
virtual void | OnUnderlineActivate ()
This method is called when the user activates the control using its underline.
virtual BOOL | GetPopuped () const
Call this member to get the control's pop-up state.
void | RedrawParent (BOOL bAnimate=TRUE)
This method is called to redraw the parent command bar.
LRESULT | NotifySite (UINT code)
This method is called to send message code to the parent site window.
LRESULT | NotifySite (UINT code, NMXTPCONTROL *pNM)
This method is called to send message code to the parent site window.
LRESULT | NotifySite (CWnd *pSite, UINT code, NMXTPCONTROL *pNM)
This method is called to send message code to the parent site window.
virtual void | SetAction (CXTPControlAction *pAction)
Call this method to manually assign an action for control.
CXTPControlAction * | GetAction () const
Call this method to retrieve an action associated with control.
virtual void | OnThemeChanged ()
This method is called when the paint manager theme is changed.
virtual void | SetWidth (int nWidth)
Call this member to set the width of the control.
virtual void | SetHeight (int nHeight)
Call this member to set the height of the control.
int | GetWidth () const
Call this member to get the width of the control.
int | GetHeight () const
Call this member to get the height of the control.
BOOL | HasDwmCompositedRect () const
This method is called to determine if control has a Vista DWM transparent area.
virtual CSize | GetButtonSize () const
Call this function to get the size of the command bar button.
virtual CSize | GetIconSize () const
Call this member function to get the size of a toolbar icon.
void | SetIconSize (CSize szIcon)
Call this member function to set the size of an icon for an individual control.
virtual void | Copy (CXTPControl *pControl, BOOL bRecursive=FALSE)
This method is called to copy the control.
virtual BOOL | IsCustomizeMovable () const
This method is called to determine if control can be repositioned in customize mode.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

virtual CSize | GetSize (CDC *pDC)
This method is called to determine the size of the control.
virtual void | Draw (CDC *pDC)
This method is called to draw the control.
virtual void | OnClick (BOOL bKeyboard=FALSE, CPoint pt=CPoint(0, 0))
This method is called when the user clicks the control.
void | OnExecute ()
This method is called when the control is executed.
void | OnMouseMove (CPoint point)
This member is called when the mouse cursor moves.
- Protected Member Functions inherited from CXTPControl
CXTPControl ()
Constructs a CXTPControl object.
virtual | ~CXTPControl ()
Destroys a CXTPControl object, handles cleanup and deallocation.
virtual BOOL | IsFocusable () const
This method is called to check if the control can accept focus.
void | SetIndex (int nIndex)
This method is called to assign the order of the control in the controls list.
void | SetExpanded (BOOL bExpanded)
This method is called to set the control's expanded state.
virtual BOOL | OnHookKeyDown (UINT nChar, LPARAM lParam)
This method is called when a non-system key is pressed.
virtual BOOL | OnHookMouseWheel (UINT nFlags, short zDelta, CPoint point)
This method is called when the user rotates the mouse wheel.
virtual void | SetParent (CXTPCommandBar *pParent)
This method is called to assign a parent command bar object.
void | ScreenToClient (CPoint *point)
The ScreenToClient function converts the screen coordinates of a specified point on the screen.
void | ClickToolBarButton (CRect rcActiveRect=CRect(0, 0, 0, 0))
This helper method is called when the user clicks the toolbar's button.
virtual BOOL | OnSetPopup (BOOL bPopup)
This method is called to pop-up the control.
virtual void | OnLButtonUp (CPoint point)
This member is called when the user releases the left mouse button.
virtual void | OnLButtonDown (CPoint point)
This member is called when the user presses the left mouse button down.
virtual BOOL | OnRButtonDown (CPoint point)
This member is called when the user press the right mouse button.
virtual BOOL | OnRButtonUp (CPoint point)
This member is called when the user releases the right mouse button.
virtual BOOL | OnLButtonDblClk (CPoint point)
This member is called when the user double-clicks the left mouse button.
virtual void | OnMouseHover ()
Called after the mouse hovers over the control.
virtual BOOL | OnSetSelected (int bSelected)
This method is called when the control becomes selected.
BOOL | IsCustomizeMode () const
Call this method to determine if command bars is in customize mode.
virtual void | CustomizeStartDrag (CPoint point)
This member is called when the user starts to drag the control in customize mode.
virtual BOOL | CustomizeStartResize (CPoint point)
This method is called when user starts to resize control in customize mode.
virtual void | OnCustomizeDragOver (CXTPControl *pDataObject, CPoint point, DROPEFFECT &dropEffect)
This member is called when the user moves the mouse over the control.
virtual BOOL | DoCustomDragOver (CXTPCommandBar *pCommandBar, CPoint point, DROPEFFECT &dropEffect)
The implementation may implement a custom drag over handling logic in this method.
virtual BOOL | IsCustomizeResizeAllow () const
This member checks if the user can resize the control.
virtual int | GetCustomizeMinWidth () const
Retrieves the available minimum width of control.
virtual int | GetCustomizeMinHeight () const
Retrieves available minimum height of the control.
void | OnCustomizeMouseMove (CPoint point)
This member is called when the mouse cursor moves in customized mode.
virtual void | OnIdleUpdate ()
This virtual method is called in idle-time processing.
virtual void | OnRemoved ()
This method is called when a control is removed from the parent controls collection.
virtual INT_PTR | OnToolHitTest (CPoint point, TOOLINFO *pTI) const
The framework calls this member function to determine whether a point is in the bounding rectangle of the specified tool.
virtual void | RestoreCommandBarList (CXTPCommandBarList *pCommandBarList)
This method is called from LoadCommandBars to restore controls and its child command bars.
virtual void | GenerateCommandBarList (DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam)
This method is called from SaveCommandBars to save all child command bars.
virtual void | OnActionChanged (int nProperty)
This method is called when an action property is changed.
virtual void | OnActionChanging (int nProperty)
This method is called when an action property is about to be changed.
virtual void | OnCaptionChanged ()
This method is called when the control's caption is changed.
BOOL | IsLayoutRTL () const
Determines if right-to-left (RTL) mode is set.
BOOL | IsLayoutChanged ()
Call this member to determine if the layout has changed (RTL to LTR or LTR to RLT).

Protected Attributes

HCURSOR | m_hCursor
Cursor display when item is hovered.
- Protected Attributes inherited from CXTPControl
DWORD_PTR | m_nTag
Control tag.
int | m_nIndex
Index of the control.
int | m_nId
Identifier of the control.
int | m_nIconId
Identifier of the control's image.
int | m_nHelpId
Help identifier.
int | m_nCustomIconId
Identifier of the control's custom image.
BOOL | m_bWrap
TRUE if the control is wrapped.
BOOL | m_bBeginGroup
TRUE if the control starts new group.
BOOL | m_bEnabled
TRUE if the control is enabled.
BOOL | m_bChecked
TRUE if the control is checked.
BOOL | m_bSelected
TRUE if the control is selected.
BOOL | m_bPressed
TRUE if the control is pushed.
BOOL | m_bTemporary
TRUE if the control is temporary.
BOOL | m_bOnQuickAccess
TRUE if the control is a part of Quick Access panel.
CRect | m_rcRow
Bounding rectangle of the control's row.
CRect | m_rcControl
Bounding rectangle of the control.
DWORD | m_dwHideFlags
Hidden flags.
DWORD | m_dwFlags
Flags of the control.
CString | m_strCaption
Caption of the control.
CString | m_strCustomCaption
User-defined caption.
CString | m_strShortcutText
Shortcut text.
CString | m_strShortcutTextAuto
Shortcut text.
CString | m_strTooltipText
Tooltip text.
CString | m_strDescriptionText
Description text.
CString | m_strParameter
Parameter text.
CString | m_strKeyboardTip
Keyboard tip.
CXTPControls * | m_pControls
Parent control collection.
XTPControlType | m_controlType
Type of the control.
CXTPCommandBar * | m_pParent
The Parent command bar.
BOOL | m_bExpanded
TRUE if the control is expanded.
CString | m_strCategory
Category of the control.
BOOL | m_bDefaultItem
TRUE if the item is default pop-up item.
CDocTemplateMap | m_mapDocTemplatesAssigned
Assigned templates.
CDocTemplateMap | m_mapDocTemplatesExcluded
Excluded templates.
XTPButtonStyle | m_buttonStyle
Button Style.
XTPButtonStyle | m_buttonCustomStyle
User-defined style of button.
XTPButtonStyle | m_buttonRibbonStyle
User-defined style of button.
BOOL | m_bCloseSubMenuOnClick
TRUE is sub-menus are closed as soon as a control is clicked.
CXTPRibbonGroup * | m_pRibbonGroup
Ribbon group of control.
CXTPControlAction * | m_pAction
Action of the control.
int | m_nWidth
Width of the control.
int | m_nHeight
Height of the control.
int | m_nExecuteOnPressInterval
Delay between each message when control is pressed.
CSize | m_szIcon
The size of the icon used for the control.
BOOL | m_bLayoutRTL
Indicate does last layout is RTL.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControl
static CXTPControl *AFX_CDECL | FromUI (CCmdUI *pCmdUI)
Call this member to retrieve CXTPControl from a CCmdUI structure.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

CXTPControlHyperlink is a CXTPControl derived class.

It can be used to add hyperlink text.

Member Function Documentation

◆ Draw()

virtual void Draw ( CDC * pDC )
protectedvirtual

This method is called to draw the control.

Parameters
pDC Pointer to a valid device context.

Reimplemented from CXTPControl.

◆ GetSize()

virtual CSize GetSize ( CDC * pDC )
protectedvirtual

This method is called to determine the size of the control.

Parameters
pDC Pointer to a valid device context.
Returns
A CSize object containing the size of the control.

Reimplemented from CXTPControl.

◆ OnClick()

virtual void OnClick | ( | BOOL | bKeyboard = FALSE,
 |  | CPoint | pt = CPoint(0, 0) )
 protectedvirtual

This method is called when the user clicks the control.

Parameters
bKeyboard | TRUE if the control is selected using the keyboard.
pt | Mouse cursor position.

Reimplemented from CXTPControl.

◆ OnMouseMove()

void OnMouseMove ( CPoint point )
protectedvirtual

This member is called when the mouse cursor moves.

Parameters
point Specifies the x- and y- coordinates of the cursor.

Reimplemented from CXTPControl.

The documentation for this class was generated from the following file:
  • XTPControlExt.h


Toolkit Pro: CXTPControlLabel Class Reference

List of all members
CXTPControlLabel Class Reference

CXTPControlLabel is a CXTPControl derived class. More...

Inheritance diagram for CXTPControlLabel:
[legend]

Additional Inherited Members

- Public Member Functions inherited from CXTPControl
void | SetStyle (XTPButtonStyle buttonStyle)
Call this member to set the style of the control.
XTPButtonStyle | GetStyle () const
Call this member to get the control's style.
void | SetCaption (LPCTSTR lpszCaption)
Call this member to set the caption of the control.
void | SetCaption (UINT nIDCaption)
Call this member to set the caption of the control.
virtual CString | GetCaption () const
Call this member to get the control's caption.
void | SetShortcutText (LPCTSTR lpszShortcutText)
Call this member to set the shortcut string to the control.
CString | GetShortcutText () const
Call this member to get the control's shortcut.
void | SetDescription (LPCTSTR lpszDescription)
Call this member to set the description of the control.
virtual CString | GetDescription () const
Call this member to get the control's description.
void | SetTooltip (LPCTSTR lpszTooltip)
Call this member to set the tooltip of the control.
virtual CString | GetTooltip () const
Call this member to get the control's tooltip.
void | SetKeyboardTip (LPCTSTR lpszKeyboardTip)
Call this member to set the keyboard tip to the control.
CString | GetKeyboardTip () const
Call this member to get the keyboard tip.
void | SetCustomShortcutText (LPCTSTR lpszCustomShortcutText)
Call this member to set the text displayed for the shortcut in a pop-up menu.
CString | GetCustomShortcutText () const
Call this member to get the control's text displayed for the shortcut in a pop-up menu.
void | SetParameter (LPCTSTR lpszParameter)
Call this member to set the parameter of the control.
CString | GetParameter () const
Call this member to get the control's parameter.
void | SetID (int nId)
Call this member to set the identifier of the control.
int | GetID () const
Call this member to get the control's identifier.
long | GetIndex () const
Call this member to get the index of the control.
void | SetIconId (int nId)
Call this member to set the control icon's identifier.
int | GetIconId () const
Call this member to get the icon's identifier.
void | SetHelpId (int nId)
Call this member to set the control help identifier.
int | GetHelpId () const
Call this member to get the help identifier.
virtual void | SetBeginGroup (BOOL bBeginGroup)
Call this member to begin a new group using a separator.
BOOL | GetBeginGroup () const
Call this member to determine if the control has a separator.
virtual void | SetEnabled (BOOL bEnabled)
Call this member to enable/disable the control.
BOOL | GetEnabled () const
Call this member to check if the control is enabled.
virtual void | OnEnabledChanged ()
This method is called when a control's enabled state is changed.
virtual void | SetChecked (BOOL bChecked)
Call this member to set the checked state of the control.
BOOL | GetChecked () const
Call this member to get the checked state of the control.
void | SetOnQuickAccess (BOOL bOnQuicAccess=FALSE)
Call this member to set whether a control should be a part of the Quick Access panel.
BOOL | IsOnQuickAccess () const
Call this member to check if a control is a part of the Quick Access panel.
virtual void | SetFocused (BOOL bFocused)
Call this member to set the focused state of the control.
virtual BOOL | IsFocused () const
Call this member to check the focused state of the control.
void | SetPressed (BOOL bPressed)
Call this member to set the pressed state of the control.
virtual BOOL | GetPressed () const
Call this member to check the pressed state of the control.
virtual void | SetRect (CRect rcControl)
This member is called to set the bounding rectangle of the control.
CRect | GetRect () const
Call this member to get the bounding rectangle of the control.
CXTPCommandBar * | GetParent () const
Call this member to get the parent command bar.
virtual BOOL | IsVisible (DWORD dwSkipFlags=0) const
Call this member to determine if the control is visible.
virtual BOOL | IsCaptionVisible () const
Call this member to determine if the caption of the control is visible.
void | SetVisible (BOOL bVisible)
Call this member to set the visibility of the control.
CXTPControls * | GetControls () const
Call this member to get the parent controls collection.
XTPControlType | GetType () const
Call this member to get the control's type.
void | SetFlags (DWORD dwFlags)
Call this member to set the flags of the control.
DWORD | GetFlags () const
Call this member to retrieve control special flags.
void | SetTag (DWORD_PTR dwTag)
This method sets the 32-bit value associated with the control.
DWORD_PTR | GetTag () const
This method retrieves the application-supplied, 32-bit value associated with the control.
virtual BOOL | Compare (CXTPControl *pOther)
Call this member to compare controls.
virtual CXTPCommandBar * | GetCommandBar () const
Call this member to get the child command bar.
void | SetCloseSubMenuOnClick (BOOL bCloseOnClick)
Call this member function to enable/disable the closing of sub-menus when a control is clicked in the menu.
BOOL | GetCloseSubMenuOnClick () const
Call this member function to check if sub-menus will close as soon as a control is clicked.
void | SetExecuteOnPressInterval (int nExecuteOnPressInterval)
Call this method to set the delay (in milliseconds) between WM_COMMAND messages while a button is pressed by the user.
int | GetExecuteOnPressInterval () const
Call this method to get the delay (in milliseconds) between WM_COMMAND messages while a button is pressed by the user.
CXTPRibbonGroup * | GetRibbonGroup () const
Returns the ribbon group that the control belongs to.
virtual BOOL | IsTransparent () const
Determines if the control needs to draw its background.
void | SetHideWrap (BOOL bHide)
This method is called to hide the control.
virtual void | SetHideFlags (DWORD dwFlags)
This method is called to hide the control.
BOOL | SetHideFlag (XTPControlHideFlags dwFlag, BOOL bSet)
Call this member to set/remove hide flags.
DWORD | GetHideFlags () const
Call this method to retrieve hidden flags.
CRect | GetRowRect () const
Call this method to retrieve the position of the control's row.
BOOL | GetWrap () const
Call this method to check if the control is wrapped.
void | SetRowRect (CRect rcRow)
Call this method to set the row of the control.
void | SetWrap (BOOL bWrap)
Call this member to set the control to wrapped.
BOOL | GetExpanded () const
Call this member to check if the control is expanded.
BOOL | IsCursorOver () const
Call this member to determine if the mouse pointer is over the control.
virtual void | OnExecute ()
This method is called when the control is executed.
virtual CSize | GetSize (CDC *pDC)
This method is called to determine the size of the control.
virtual void | Draw (CDC *pDC)
This method is called to draw the control.
virtual void | OnCalcDynamicSize (DWORD dwMode)
This method is called before recalculating the parent command bar size to calculate the dimensions of the control.
void | DelayRedrawParent ()
Call this method to redraw the parent command bar.
void | DelayLayoutParent ()
Call this method to recalculate the parent command bar size.
void | SetCategory (LPCTSTR lpszCategory)
Call this method to set the category of the control.
CString | GetCategory () const
Call this method to retrieve the category of the control.
CXTPImageManager * | GetImageManager () const
Call this method to retrieve the image manager.
CXTPPaintManager * | GetPaintManager () const
Call this method to retrieve the paint manager.
virtual CXTPImageManagerIcon * | GetImage (int nWidth=16) const
Call this method to retrieve the image of the control.
void | AssignDocTemplate (UINT nIDResource)
Call this method to assign a document template to the control.
void | ExcludeDocTemplate (UINT nIDResource)
Call this method to exclude the document template from control.
BOOL | IsItemDefault () const
Call this method to check if a control is a default menu item.
void | SetItemDefault (BOOL bDefault)
Call this method to set a control to be a default menu item.
BOOL | IsTemporary () const
Call this method to determine if a control is temporary.
void | Reset ()
Call this member to reset the icon and caption of a control to its default settings before it was customized by the user.
void | SetPrompt (LPCTSTR lpszPrompt)
Call this member to load a string from a STRINGTABLE resource to set the tooltip and description of a control.
void | SetCustomIcon (HICON hIcon)
Call this member to set a custom icon to this control.
virtual void | DoPropExchange (CXTPPropExchange *pPX)
Either reads this object from or writes this object to an archive.
virtual void | OnUnderlineActivate ()
This method is called when the user activates the control using its underline.
virtual BOOL | GetPopuped () const
Call this member to get the control's pop-up state.
void | RedrawParent (BOOL bAnimate=TRUE)
This method is called to redraw the parent command bar.
LRESULT | NotifySite (UINT code)
This method is called to send message code to the parent site window.
LRESULT | NotifySite (UINT code, NMXTPCONTROL *pNM)
This method is called to send message code to the parent site window.
LRESULT | NotifySite (CWnd *pSite, UINT code, NMXTPCONTROL *pNM)
This method is called to send message code to the parent site window.
virtual void | SetAction (CXTPControlAction *pAction)
Call this method to manually assign an action for control.
CXTPControlAction * | GetAction () const
Call this method to retrieve an action associated with control.
virtual void | OnThemeChanged ()
This method is called when the paint manager theme is changed.
virtual void | SetWidth (int nWidth)
Call this member to set the width of the control.
virtual void | SetHeight (int nHeight)
Call this member to set the height of the control.
int | GetWidth () const
Call this member to get the width of the control.
int | GetHeight () const
Call this member to get the height of the control.
BOOL | HasDwmCompositedRect () const
This method is called to determine if control has a Vista DWM transparent area.
virtual CSize | GetButtonSize () const
Call this function to get the size of the command bar button.
virtual CSize | GetIconSize () const
Call this member function to get the size of a toolbar icon.
void | SetIconSize (CSize szIcon)
Call this member function to set the size of an icon for an individual control.
virtual void | Copy (CXTPControl *pControl, BOOL bRecursive=FALSE)
This method is called to copy the control.
virtual BOOL | IsCustomizeMovable () const
This method is called to determine if control can be repositioned in customize mode.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.
- Static Public Member Functions inherited from CXTPControl
static CXTPControl *AFX_CDECL | FromUI (CCmdUI *pCmdUI)
Call this member to retrieve CXTPControl from a CCmdUI structure.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Member Functions inherited from CXTPControl
CXTPControl ()
Constructs a CXTPControl object.
virtual | ~CXTPControl ()
Destroys a CXTPControl object, handles cleanup and deallocation.
virtual BOOL | IsFocusable () const
This method is called to check if the control can accept focus.
void | SetIndex (int nIndex)
This method is called to assign the order of the control in the controls list.
void | SetExpanded (BOOL bExpanded)
This method is called to set the control's expanded state.
virtual BOOL | OnHookKeyDown (UINT nChar, LPARAM lParam)
This method is called when a non-system key is pressed.
virtual BOOL | OnHookMouseWheel (UINT nFlags, short zDelta, CPoint point)
This method is called when the user rotates the mouse wheel.
virtual void | SetParent (CXTPCommandBar *pParent)
This method is called to assign a parent command bar object.
void | ScreenToClient (CPoint *point)
The ScreenToClient function converts the screen coordinates of a specified point on the screen.
void | ClickToolBarButton (CRect rcActiveRect=CRect(0, 0, 0, 0))
This helper method is called when the user clicks the toolbar's button.
virtual BOOL | OnSetPopup (BOOL bPopup)
This method is called to pop-up the control.
virtual void | OnLButtonUp (CPoint point)
This member is called when the user releases the left mouse button.
virtual void | OnLButtonDown (CPoint point)
This member is called when the user presses the left mouse button down.
virtual BOOL | OnRButtonDown (CPoint point)
This member is called when the user press the right mouse button.
virtual BOOL | OnRButtonUp (CPoint point)
This member is called when the user releases the right mouse button.
virtual BOOL | OnLButtonDblClk (CPoint point)
This member is called when the user double-clicks the left mouse button.
virtual void | OnMouseMove (CPoint point)
This member is called when the mouse cursor moves.
virtual void | OnMouseHover ()
Called after the mouse hovers over the control.
virtual BOOL | OnSetSelected (int bSelected)
This method is called when the control becomes selected.
BOOL | IsCustomizeMode () const
Call this method to determine if command bars is in customize mode.
virtual void | CustomizeStartDrag (CPoint point)
This member is called when the user starts to drag the control in customize mode.
virtual BOOL | CustomizeStartResize (CPoint point)
This method is called when user starts to resize control in customize mode.
virtual void | OnCustomizeDragOver (CXTPControl *pDataObject, CPoint point, DROPEFFECT &dropEffect)
This member is called when the user moves the mouse over the control.
virtual BOOL | DoCustomDragOver (CXTPCommandBar *pCommandBar, CPoint point, DROPEFFECT &dropEffect)
The implementation may implement a custom drag over handling logic in this method.
virtual BOOL | IsCustomizeResizeAllow () const
This member checks if the user can resize the control.
virtual int | GetCustomizeMinWidth () const
Retrieves the available minimum width of control.
virtual int | GetCustomizeMinHeight () const
Retrieves available minimum height of the control.
void | OnCustomizeMouseMove (CPoint point)
This member is called when the mouse cursor moves in customized mode.
virtual void | OnIdleUpdate ()
This virtual method is called in idle-time processing.
virtual void | OnRemoved ()
This method is called when a control is removed from the parent controls collection.
virtual INT_PTR | OnToolHitTest (CPoint point, TOOLINFO *pTI) const
The framework calls this member function to determine whether a point is in the bounding rectangle of the specified tool.
virtual void | RestoreCommandBarList (CXTPCommandBarList *pCommandBarList)
This method is called from LoadCommandBars to restore controls and its child command bars.
virtual void | GenerateCommandBarList (DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam)
This method is called from SaveCommandBars to save all child command bars.
virtual void | OnActionChanged (int nProperty)
This method is called when an action property is changed.
virtual void | OnActionChanging (int nProperty)
This method is called when an action property is about to be changed.
virtual void | OnCaptionChanged ()
This method is called when the control's caption is changed.
BOOL | IsLayoutRTL () const
Determines if right-to-left (RTL) mode is set.
BOOL | IsLayoutChanged ()
Call this member to determine if the layout has changed (RTL to LTR or LTR to RLT).
- Protected Attributes inherited from CXTPControl
DWORD_PTR | m_nTag
Control tag.
int | m_nIndex
Index of the control.
int | m_nId
Identifier of the control.
int | m_nIconId
Identifier of the control's image.
int | m_nHelpId
Help identifier.
int | m_nCustomIconId
Identifier of the control's custom image.
BOOL | m_bWrap
TRUE if the control is wrapped.
BOOL | m_bBeginGroup
TRUE if the control starts new group.
BOOL | m_bEnabled
TRUE if the control is enabled.
BOOL | m_bChecked
TRUE if the control is checked.
BOOL | m_bSelected
TRUE if the control is selected.
BOOL | m_bPressed
TRUE if the control is pushed.
BOOL | m_bTemporary
TRUE if the control is temporary.
BOOL | m_bOnQuickAccess
TRUE if the control is a part of Quick Access panel.
CRect | m_rcRow
Bounding rectangle of the control's row.
CRect | m_rcControl
Bounding rectangle of the control.
DWORD | m_dwHideFlags
Hidden flags.
DWORD | m_dwFlags
Flags of the control.
CString | m_strCaption
Caption of the control.
CString | m_strCustomCaption
User-defined caption.
CString | m_strShortcutText
Shortcut text.
CString | m_strShortcutTextAuto
Shortcut text.
CString | m_strTooltipText
Tooltip text.
CString | m_strDescriptionText
Description text.
CString | m_strParameter
Parameter text.
CString | m_strKeyboardTip
Keyboard tip.
CXTPControls * | m_pControls
Parent control collection.
XTPControlType | m_controlType
Type of the control.
CXTPCommandBar * | m_pParent
The Parent command bar.
BOOL | m_bExpanded
TRUE if the control is expanded.
CString | m_strCategory
Category of the control.
BOOL | m_bDefaultItem
TRUE if the item is default pop-up item.
CDocTemplateMap | m_mapDocTemplatesAssigned
Assigned templates.
CDocTemplateMap | m_mapDocTemplatesExcluded
Excluded templates.
XTPButtonStyle | m_buttonStyle
Button Style.
XTPButtonStyle | m_buttonCustomStyle
User-defined style of button.
XTPButtonStyle | m_buttonRibbonStyle
User-defined style of button.
BOOL | m_bCloseSubMenuOnClick
TRUE is sub-menus are closed as soon as a control is clicked.
CXTPRibbonGroup * | m_pRibbonGroup
Ribbon group of control.
CXTPControlAction * | m_pAction
Action of the control.
int | m_nWidth
Width of the control.
int | m_nHeight
Height of the control.
int | m_nExecuteOnPressInterval
Delay between each message when control is pressed.
CSize | m_szIcon
The size of the icon used for the control.
BOOL | m_bLayoutRTL
Indicate does last layout is RTL.

Detailed Description

CXTPControlLabel is a CXTPControl derived class.

It represents a label control.

The documentation for this class was generated from the following file:
  • XTPControlExt.h


Toolkit Pro: CXTPControlListBox Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPControlListBox Class Reference

CXTPControlComboBox is a CXTPControl derived class. More...

Inheritance diagram for CXTPControlListBox:
[legend]

Public Member Functions

CXTPControlListBox ()
Constructs a CXTPControlListBox object.
virtual | ~CXTPControlListBox ()
Destroys a CXTPControlListBox object, handles cleanup and deallocation.
void | SetWidth (int nWidth)
Call this member to set the width of the control.
void | SetLinesMinMax (int nMin, int nMax)
Call this member to set the total minimum and maximum lines.
CListBox * | GetListCtrl () const
Call this member to retrieve a pointer to the list control.
void | SetMultiplSel (BOOL bMultiplSel)
Call this member to set the multiple selection style of the control.
void | OnEnabledChanged ()
This method is called when the control's enabled state is changed.
- Public Member Functions inherited from CXTPControl
void | SetStyle (XTPButtonStyle buttonStyle)
Call this member to set the style of the control.
XTPButtonStyle | GetStyle () const
Call this member to get the control's style.
void | SetCaption (LPCTSTR lpszCaption)
Call this member to set the caption of the control.
void | SetCaption (UINT nIDCaption)
Call this member to set the caption of the control.
virtual CString | GetCaption () const
Call this member to get the control's caption.
void | SetShortcutText (LPCTSTR lpszShortcutText)
Call this member to set the shortcut string to the control.
CString | GetShortcutText () const
Call this member to get the control's shortcut.
void | SetDescription (LPCTSTR lpszDescription)
Call this member to set the description of the control.
virtual CString | GetDescription () const
Call this member to get the control's description.
void | SetTooltip (LPCTSTR lpszTooltip)
Call this member to set the tooltip of the control.
virtual CString | GetTooltip () const
Call this member to get the control's tooltip.
void | SetKeyboardTip (LPCTSTR lpszKeyboardTip)
Call this member to set the keyboard tip to the control.
CString | GetKeyboardTip () const
Call this member to get the keyboard tip.
void | SetCustomShortcutText (LPCTSTR lpszCustomShortcutText)
Call this member to set the text displayed for the shortcut in a pop-up menu.
CString | GetCustomShortcutText () const
Call this member to get the control's text displayed for the shortcut in a pop-up menu.
void | SetParameter (LPCTSTR lpszParameter)
Call this member to set the parameter of the control.
CString | GetParameter () const
Call this member to get the control's parameter.
void | SetID (int nId)
Call this member to set the identifier of the control.
int | GetID () const
Call this member to get the control's identifier.
long | GetIndex () const
Call this member to get the index of the control.
void | SetIconId (int nId)
Call this member to set the control icon's identifier.
int | GetIconId () const
Call this member to get the icon's identifier.
void | SetHelpId (int nId)
Call this member to set the control help identifier.
int | GetHelpId () const
Call this member to get the help identifier.
virtual void | SetBeginGroup (BOOL bBeginGroup)
Call this member to begin a new group using a separator.
BOOL | GetBeginGroup () const
Call this member to determine if the control has a separator.
virtual void | SetEnabled (BOOL bEnabled)
Call this member to enable/disable the control.
BOOL | GetEnabled () const
Call this member to check if the control is enabled.
virtual void | SetChecked (BOOL bChecked)
Call this member to set the checked state of the control.
BOOL | GetChecked () const
Call this member to get the checked state of the control.
virtual int | GetSelected () const
Call this member to check if the control is selected.
void | SetOnQuickAccess (BOOL bOnQuicAccess=FALSE)
Call this member to set whether a control should be a part of the Quick Access panel.
BOOL | IsOnQuickAccess () const
Call this member to check if a control is a part of the Quick Access panel.
virtual void | SetFocused (BOOL bFocused)
Call this member to set the focused state of the control.
void | SetPressed (BOOL bPressed)
Call this member to set the pressed state of the control.
virtual BOOL | GetPressed () const
Call this member to check the pressed state of the control.
CRect | GetRect () const
Call this member to get the bounding rectangle of the control.
CXTPCommandBar * | GetParent () const
Call this member to get the parent command bar.
virtual BOOL | IsVisible (DWORD dwSkipFlags=0) const
Call this member to determine if the control is visible.
virtual BOOL | IsCaptionVisible () const
Call this member to determine if the caption of the control is visible.
void | SetVisible (BOOL bVisible)
Call this member to set the visibility of the control.
CXTPControls * | GetControls () const
Call this member to get the parent controls collection.
XTPControlType | GetType () const
Call this member to get the control's type.
void | SetFlags (DWORD dwFlags)
Call this member to set the flags of the control.
DWORD | GetFlags () const
Call this member to retrieve control special flags.
void | SetTag (DWORD_PTR dwTag)
This method sets the 32-bit value associated with the control.
DWORD_PTR | GetTag () const
This method retrieves the application-supplied, 32-bit value associated with the control.
virtual BOOL | Compare (CXTPControl *pOther)
Call this member to compare controls.
virtual CXTPCommandBar * | GetCommandBar () const
Call this member to get the child command bar.
void | SetCloseSubMenuOnClick (BOOL bCloseOnClick)
Call this member function to enable/disable the closing of sub-menus when a control is clicked in the menu.
BOOL | GetCloseSubMenuOnClick () const
Call this member function to check if sub-menus will close as soon as a control is clicked.
void | SetExecuteOnPressInterval (int nExecuteOnPressInterval)
Call this method to set the delay (in milliseconds) between WM_COMMAND messages while a button is pressed by the user.
int | GetExecuteOnPressInterval () const
Call this method to get the delay (in milliseconds) between WM_COMMAND messages while a button is pressed by the user.
CXTPRibbonGroup * | GetRibbonGroup () const
Returns the ribbon group that the control belongs to.
virtual BOOL | IsTransparent () const
Determines if the control needs to draw its background.
void | SetHideWrap (BOOL bHide)
This method is called to hide the control.
virtual void | SetHideFlags (DWORD dwFlags)
This method is called to hide the control.
BOOL | SetHideFlag (XTPControlHideFlags dwFlag, BOOL bSet)
Call this member to set/remove hide flags.
DWORD | GetHideFlags () const
Call this method to retrieve hidden flags.
CRect | GetRowRect () const
Call this method to retrieve the position of the control's row.
BOOL | GetWrap () const
Call this method to check if the control is wrapped.
void | SetRowRect (CRect rcRow)
Call this method to set the row of the control.
void | SetWrap (BOOL bWrap)
Call this member to set the control to wrapped.
BOOL | GetExpanded () const
Call this member to check if the control is expanded.
BOOL | IsCursorOver () const
Call this member to determine if the mouse pointer is over the control.
virtual void | OnExecute ()
This method is called when the control is executed.
void | DelayRedrawParent ()
Call this method to redraw the parent command bar.
void | DelayLayoutParent ()
Call this method to recalculate the parent command bar size.
void | SetCategory (LPCTSTR lpszCategory)
Call this method to set the category of the control.
CString | GetCategory () const
Call this method to retrieve the category of the control.
CXTPImageManager * | GetImageManager () const
Call this method to retrieve the image manager.
CXTPPaintManager * | GetPaintManager () const
Call this method to retrieve the paint manager.
virtual CXTPImageManagerIcon * | GetImage (int nWidth=16) const
Call this method to retrieve the image of the control.
void | AssignDocTemplate (UINT nIDResource)
Call this method to assign a document template to the control.
void | ExcludeDocTemplate (UINT nIDResource)
Call this method to exclude the document template from control.
BOOL | IsItemDefault () const
Call this method to check if a control is a default menu item.
void | SetItemDefault (BOOL bDefault)
Call this method to set a control to be a default menu item.
BOOL | IsTemporary () const
Call this method to determine if a control is temporary.
void | Reset ()
Call this member to reset the icon and caption of a control to its default settings before it was customized by the user.
void | SetPrompt (LPCTSTR lpszPrompt)
Call this member to load a string from a STRINGTABLE resource to set the tooltip and description of a control.
void | SetCustomIcon (HICON hIcon)
Call this member to set a custom icon to this control.
virtual void | OnUnderlineActivate ()
This method is called when the user activates the control using its underline.
virtual BOOL | GetPopuped () const
Call this member to get the control's pop-up state.
void | RedrawParent (BOOL bAnimate=TRUE)
This method is called to redraw the parent command bar.
LRESULT | NotifySite (UINT code)
This method is called to send message code to the parent site window.
LRESULT | NotifySite (UINT code, NMXTPCONTROL *pNM)
This method is called to send message code to the parent site window.
LRESULT | NotifySite (CWnd *pSite, UINT code, NMXTPCONTROL *pNM)
This method is called to send message code to the parent site window.
virtual void | SetAction (CXTPControlAction *pAction)
Call this method to manually assign an action for control.
CXTPControlAction * | GetAction () const
Call this method to retrieve an action associated with control.
virtual void | OnThemeChanged ()
This method is called when the paint manager theme is changed.
virtual void | SetHeight (int nHeight)
Call this member to set the height of the control.
int | GetWidth () const
Call this member to get the width of the control.
int | GetHeight () const
Call this member to get the height of the control.
BOOL | HasDwmCompositedRect () const
This method is called to determine if control has a Vista DWM transparent area.
virtual CSize | GetButtonSize () const
Call this function to get the size of the command bar button.
virtual CSize | GetIconSize () const
Call this member function to get the size of a toolbar icon.
void | SetIconSize (CSize szIcon)
Call this member function to set the size of an icon for an individual control.
virtual BOOL | IsCustomizeMovable () const
This method is called to determine if control can be repositioned in customize mode.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

virtual void | SetRect (CRect rcControl)
Call this member to set the bounding rectangle of the control.
virtual CSize | GetSize (CDC *pDC)
This method is called to determine the size of the control.
virtual void | SetParent (CXTPCommandBar *pParent)
This method is called to assign a parent command bar object.
virtual void | Draw (CDC *pDC)
This method is called to draw the control.
virtual BOOL | IsFocused () const
Call this member to get the focused state of the control.
virtual BOOL | OnHookKeyDown (UINT nChar, LPARAM lParam)
The framework calls this member function when a non-system key is pressed.
virtual BOOL | OnSetSelected (int bSelected)
This method is called when the control becomes selected.
virtual void | OnClick (BOOL bKeyboard=FALSE, CPoint pt=CPoint(0, 0))
This method is called when the user clicks the control.
virtual void | OnCalcDynamicSize (DWORD dwMode)
This method is called before recalculating the parent command bar size to calculate the dimensions of the control.
virtual void | Copy (CXTPControl *pControl, BOOL bRecursive=FALSE)
This method is called to copy the control.
virtual void | DoPropExchange (CXTPPropExchange *pPX)
Either reads ths object from or writes this object to an archive.
- Protected Member Functions inherited from CXTPControl
CXTPControl ()
Constructs a CXTPControl object.
virtual | ~CXTPControl ()
Destroys a CXTPControl object, handles cleanup and deallocation.
virtual BOOL | IsFocusable () const
This method is called to check if the control can accept focus.
void | SetIndex (int nIndex)
This method is called to assign the order of the control in the controls list.
void | SetExpanded (BOOL bExpanded)
This method is called to set the control's expanded state.
virtual BOOL | OnHookMouseWheel (UINT nFlags, short zDelta, CPoint point)
This method is called when the user rotates the mouse wheel.
void | ScreenToClient (CPoint *point)
The ScreenToClient function converts the screen coordinates of a specified point on the screen.
void | ClickToolBarButton (CRect rcActiveRect=CRect(0, 0, 0, 0))
This helper method is called when the user clicks the toolbar's button.
virtual BOOL | OnSetPopup (BOOL bPopup)
This method is called to pop-up the control.
virtual void | OnLButtonUp (CPoint point)
This member is called when the user releases the left mouse button.
virtual void | OnLButtonDown (CPoint point)
This member is called when the user presses the left mouse button down.
virtual BOOL | OnRButtonDown (CPoint point)
This member is called when the user press the right mouse button.
virtual BOOL | OnRButtonUp (CPoint point)
This member is called when the user releases the right mouse button.
virtual BOOL | OnLButtonDblClk (CPoint point)
This member is called when the user double-clicks the left mouse button.
virtual void | OnMouseMove (CPoint point)
This member is called when the mouse cursor moves.
virtual void | OnMouseHover ()
Called after the mouse hovers over the control.
BOOL | IsCustomizeMode () const
Call this method to determine if command bars is in customize mode.
virtual void | CustomizeStartDrag (CPoint point)
This member is called when the user starts to drag the control in customize mode.
virtual BOOL | CustomizeStartResize (CPoint point)
This method is called when user starts to resize control in customize mode.
virtual void | OnCustomizeDragOver (CXTPControl *pDataObject, CPoint point, DROPEFFECT &dropEffect)
This member is called when the user moves the mouse over the control.
virtual BOOL | DoCustomDragOver (CXTPCommandBar *pCommandBar, CPoint point, DROPEFFECT &dropEffect)
The implementation may implement a custom drag over handling logic in this method.
virtual BOOL | IsCustomizeResizeAllow () const
This member checks if the user can resize the control.
virtual int | GetCustomizeMinWidth () const
Retrieves the available minimum width of control.
virtual int | GetCustomizeMinHeight () const
Retrieves available minimum height of the control.
void | OnCustomizeMouseMove (CPoint point)
This member is called when the mouse cursor moves in customized mode.
virtual void | OnIdleUpdate ()
This virtual method is called in idle-time processing.
virtual void | OnRemoved ()
This method is called when a control is removed from the parent controls collection.
virtual INT_PTR | OnToolHitTest (CPoint point, TOOLINFO *pTI) const
The framework calls this member function to determine whether a point is in the bounding rectangle of the specified tool.
virtual void | RestoreCommandBarList (CXTPCommandBarList *pCommandBarList)
This method is called from LoadCommandBars to restore controls and its child command bars.
virtual void | GenerateCommandBarList (DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam)
This method is called from SaveCommandBars to save all child command bars.
virtual void | OnActionChanged (int nProperty)
This method is called when an action property is changed.
virtual void | OnActionChanging (int nProperty)
This method is called when an action property is about to be changed.
virtual void | OnCaptionChanged ()
This method is called when the control's caption is changed.
BOOL | IsLayoutRTL () const
Determines if right-to-left (RTL) mode is set.
BOOL | IsLayoutChanged ()
Call this member to determine if the layout has changed (RTL to LTR or LTR to RLT).

Protected Attributes

CXTPControlListBoxCtrl * | m_pListBox
List box control.
int | m_nListBoxLinesMin
Minimum lines.
int | m_nListBoxLinesMax
Maximum lines.
BOOL | m_bMultiplSel
Multiple selection style.
BOOL | m_bMouseLocked
TRUE to lock mouse events.
- Protected Attributes inherited from CXTPControl
DWORD_PTR | m_nTag
Control tag.
int | m_nIndex
Index of the control.
int | m_nId
Identifier of the control.
int | m_nIconId
Identifier of the control's image.
int | m_nHelpId
Help identifier.
int | m_nCustomIconId
Identifier of the control's custom image.
BOOL | m_bWrap
TRUE if the control is wrapped.
BOOL | m_bBeginGroup
TRUE if the control starts new group.
BOOL | m_bEnabled
TRUE if the control is enabled.
BOOL | m_bChecked
TRUE if the control is checked.
BOOL | m_bSelected
TRUE if the control is selected.
BOOL | m_bPressed
TRUE if the control is pushed.
BOOL | m_bTemporary
TRUE if the control is temporary.
BOOL | m_bOnQuickAccess
TRUE if the control is a part of Quick Access panel.
CRect | m_rcRow
Bounding rectangle of the control's row.
CRect | m_rcControl
Bounding rectangle of the control.
DWORD | m_dwHideFlags
Hidden flags.
DWORD | m_dwFlags
Flags of the control.
CString | m_strCaption
Caption of the control.
CString | m_strCustomCaption
User-defined caption.
CString | m_strShortcutText
Shortcut text.
CString | m_strShortcutTextAuto
Shortcut text.
CString | m_strTooltipText
Tooltip text.
CString | m_strDescriptionText
Description text.
CString | m_strParameter
Parameter text.
CString | m_strKeyboardTip
Keyboard tip.
CXTPControls * | m_pControls
Parent control collection.
XTPControlType | m_controlType
Type of the control.
CXTPCommandBar * | m_pParent
The Parent command bar.
BOOL | m_bExpanded
TRUE if the control is expanded.
CString | m_strCategory
Category of the control.
BOOL | m_bDefaultItem
TRUE if the item is default pop-up item.
CDocTemplateMap | m_mapDocTemplatesAssigned
Assigned templates.
CDocTemplateMap | m_mapDocTemplatesExcluded
Excluded templates.
XTPButtonStyle | m_buttonStyle
Button Style.
XTPButtonStyle | m_buttonCustomStyle
User-defined style of button.
XTPButtonStyle | m_buttonRibbonStyle
User-defined style of button.
BOOL | m_bCloseSubMenuOnClick
TRUE is sub-menus are closed as soon as a control is clicked.
CXTPRibbonGroup * | m_pRibbonGroup
Ribbon group of control.
CXTPControlAction * | m_pAction
Action of the control.
int | m_nWidth
Width of the control.
int | m_nHeight
Height of the control.
int | m_nExecuteOnPressInterval
Delay between each message when control is pressed.
CSize | m_szIcon
The size of the icon used for the control.
BOOL | m_bLayoutRTL
Indicate does last layout is RTL.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControl
static CXTPControl *AFX_CDECL | FromUI (CCmdUI *pCmdUI)
Call this member to retrieve CXTPControl from a CCmdUI structure.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

CXTPControlComboBox is a CXTPControl derived class.

It represents a list box control.

Member Function Documentation

◆ Copy()

virtual void Copy | ( | CXTPControl * | pControl,
 |  | BOOL | bRecursive = FALSE )
 protectedvirtual

This method is called to copy the control.

Parameters
pControl | Pointer to a source CXTPControl object.
bRecursive | TRUE to copy recursively.

Reimplemented from CXTPControl.

◆ DoPropExchange()

virtual void DoPropExchange ( CXTPPropExchange * pPX )
protectedvirtual

Either reads ths object from or writes this object to an archive.

Parameters
pPX A CXTPPropExchange object to serialize to or from.

Reimplemented from CXTPControl.

◆ Draw()

virtual void Draw ( CDC * pDC )
protectedvirtual

This method is called to draw the control.

Parameters
pDC Pointer to a valid device context.

Reimplemented from CXTPControl.

◆ GetListCtrl()

CListBox * GetListCtrl ( ) const

Call this member to retrieve a pointer to the list control.

Returns
Retrieves list control.

◆ GetSize()

virtual CSize GetSize ( CDC * pDC )
protectedvirtual

This method is called to determine the size of the control.

Parameters
pDC Pointer to a valid device context.
Returns
A CSize object containing the size of the control.

Reimplemented from CXTPControl.

◆ IsFocused()

virtual BOOL IsFocused ( ) const
protectedvirtual

Call this member to get the focused state of the control.

Returns
TRUE if the control has focus; otherwise FALSE.

Reimplemented from CXTPControl.

◆ OnCalcDynamicSize()

virtual void OnCalcDynamicSize ( DWORD dwMode )
protectedvirtual

This method is called before recalculating the parent command bar size to calculate the dimensions of the control.

Parameters
dwMode Flags used to determine the height and width of the dynamic command bar. See Remarks section for a list of values.

The following predefined flags are used to determine the height and width of the dynamic command bar. Use the bitwise-OR (|) operator to combine the flags.

LM_STRETCH: Indicates whether the command bar should be stretched to the size of the frame. Set if the bar is not a docking bar (not available for docking). Not set when the bar is docked or floating (available for docking). If set, LM_STRETCH returns dimensions based on the LM_HORZ state. LM_STRETCH works similarly to the the bStretch parameter used in CalcFixedLayout; see that member function for more information about the relationship between stretching and orientation. LM_HORZ: Indicates that the bar is horizontally or vertically oriented. Set if the bar is horizontally oriented, and if it is vertically oriented, it is not set. LM_HORZ works similarly to the the bHorz parameter used in CalcFixedLayout; see that member function for more information about the relationship between stretching and orientation. LM_MRUWIDTH: Most Recently Used Dynamic Width. Uses the remembered most recently used width. LM_HORZDOCK: Horizontal Docked Dimensions. Returns the dynamic size with the largest width. LM_VERTDOCK: Vertical Docked Dimensions. Returns the dynamic size with the largest height. LM_COMMIT: Resets LM_MRUWIDTH to the current width of the floating command bar.

The framework calls this member function to calculate the dimensions of a dynamic command bar.

Override this member function to provide your own layout in classes you derive from CXTPControl. XTP classes derived from CXTPControl, such as CXTPControlComboBox, override this member function to provide their own implementation.

See also
CXTPControlComboBox, CXTPControlCustom, CXTPControlEdit, CXTPControlWindowList, CXTPControlWorkspaceActions, CXTPControlToolbars, CXTPControlOleItems, CXTPControlRecentFileList, CXTPControlSelector, CXTPControl

Reimplemented from CXTPControl.

◆ OnClick()

virtual void OnClick | ( | BOOL | bKeyboard = FALSE,
 |  | CPoint | pt = CPoint(0, 0) )
 protectedvirtual

This method is called when the user clicks the control.

Parameters
bKeyboard | TRUE if the control is selected using the keyboard.
pt | Mouse cursor position.

Reimplemented from CXTPControl.

◆ OnHookKeyDown()

virtual BOOL OnHookKeyDown | ( | UINT | nChar,
 |  | LPARAM | lParam )
 protectedvirtual

The framework calls this member function when a non-system key is pressed.

Parameters
nChar | Specifies the virtual key code of the given key.
lParam | Specifies additional message-dependent information.
Returns
TRUE if the key was handled, otherwise FALSE.

Reimplemented from CXTPControl.

◆ OnSetSelected()

virtual BOOL OnSetSelected ( int bSelected )
protectedvirtual

This method is called when the control becomes selected.

Parameters
bSelected TRUE if the control becomes selected.
Returns
TRUE if successful; otherwise FALSE.

Reimplemented from CXTPControl.

◆ SetLinesMinMax()

void SetLinesMinMax | ( | int | nMin,
 |  | int | nMax )

Call this member to set the total minimum and maximum lines.

Parameters
nMin | Minimum lines to be used.
nMax | Maximum lines to be used.

◆ SetMultiplSel()

void SetMultiplSel ( BOOL bMultiplSel )

Call this member to set the multiple selection style of the control.

Parameters
bMultiplSel TRUE to set the multiple selection style.

◆ SetParent()

virtual void SetParent ( CXTPCommandBar * pParent )
protectedvirtual

This method is called to assign a parent command bar object.

Parameters
pParent Pointer to a CXTPCommandBar object.

Reimplemented from CXTPControl.

◆ SetRect()

virtual void SetRect ( CRect rcControl )
protectedvirtual

Call this member to set the bounding rectangle of the control.

Parameters
rcControl Bounding rectangle of the control.

Reimplemented from CXTPControl.

◆ SetWidth()

void SetWidth ( int nWidth )
virtual

Call this member to set the width of the control.

Parameters
nWidth The width of the control.

Reimplemented from CXTPControl.

The documentation for this class was generated from the following file:
  • XTPControlListBox.h


Toolkit Pro: CXTPControlMarkupLabel Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPControlMarkupLabel Class Reference

CXTPControlMarkupLabel is a CXTPControlLabel derived class. More...

Inheritance diagram for CXTPControlMarkupLabel:
[legend]

Public Member Functions

CXTPControlMarkupLabel ()
Constructs a CXTPControlMarkupLabel object.
~CXTPControlMarkupLabel ()
Destroys a CXTPControlMarkupLabel object, handles cleanup and deallocation.
- Public Member Functions inherited from CXTPControl
void | SetStyle (XTPButtonStyle buttonStyle)
Call this member to set the style of the control.
XTPButtonStyle | GetStyle () const
Call this member to get the control's style.
void | SetCaption (LPCTSTR lpszCaption)
Call this member to set the caption of the control.
void | SetCaption (UINT nIDCaption)
Call this member to set the caption of the control.
virtual CString | GetCaption () const
Call this member to get the control's caption.
void | SetShortcutText (LPCTSTR lpszShortcutText)
Call this member to set the shortcut string to the control.
CString | GetShortcutText () const
Call this member to get the control's shortcut.
void | SetDescription (LPCTSTR lpszDescription)
Call this member to set the description of the control.
virtual CString | GetDescription () const
Call this member to get the control's description.
void | SetTooltip (LPCTSTR lpszTooltip)
Call this member to set the tooltip of the control.
virtual CString | GetTooltip () const
Call this member to get the control's tooltip.
void | SetKeyboardTip (LPCTSTR lpszKeyboardTip)
Call this member to set the keyboard tip to the control.
CString | GetKeyboardTip () const
Call this member to get the keyboard tip.
void | SetCustomShortcutText (LPCTSTR lpszCustomShortcutText)
Call this member to set the text displayed for the shortcut in a pop-up menu.
CString | GetCustomShortcutText () const
Call this member to get the control's text displayed for the shortcut in a pop-up menu.
void | SetParameter (LPCTSTR lpszParameter)
Call this member to set the parameter of the control.
CString | GetParameter () const
Call this member to get the control's parameter.
void | SetID (int nId)
Call this member to set the identifier of the control.
int | GetID () const
Call this member to get the control's identifier.
long | GetIndex () const
Call this member to get the index of the control.
void | SetIconId (int nId)
Call this member to set the control icon's identifier.
int | GetIconId () const
Call this member to get the icon's identifier.
void | SetHelpId (int nId)
Call this member to set the control help identifier.
int | GetHelpId () const
Call this member to get the help identifier.
virtual void | SetBeginGroup (BOOL bBeginGroup)
Call this member to begin a new group using a separator.
BOOL | GetBeginGroup () const
Call this member to determine if the control has a separator.
virtual void | SetEnabled (BOOL bEnabled)
Call this member to enable/disable the control.
BOOL | GetEnabled () const
Call this member to check if the control is enabled.
virtual void | OnEnabledChanged ()
This method is called when a control's enabled state is changed.
virtual void | SetChecked (BOOL bChecked)
Call this member to set the checked state of the control.
BOOL | GetChecked () const
Call this member to get the checked state of the control.
void | SetOnQuickAccess (BOOL bOnQuicAccess=FALSE)
Call this member to set whether a control should be a part of the Quick Access panel.
BOOL | IsOnQuickAccess () const
Call this member to check if a control is a part of the Quick Access panel.
virtual void | SetFocused (BOOL bFocused)
Call this member to set the focused state of the control.
virtual BOOL | IsFocused () const
Call this member to check the focused state of the control.
void | SetPressed (BOOL bPressed)
Call this member to set the pressed state of the control.
virtual BOOL | GetPressed () const
Call this member to check the pressed state of the control.
virtual void | SetRect (CRect rcControl)
This member is called to set the bounding rectangle of the control.
CRect | GetRect () const
Call this member to get the bounding rectangle of the control.
CXTPCommandBar * | GetParent () const
Call this member to get the parent command bar.
virtual BOOL | IsVisible (DWORD dwSkipFlags=0) const
Call this member to determine if the control is visible.
virtual BOOL | IsCaptionVisible () const
Call this member to determine if the caption of the control is visible.
void | SetVisible (BOOL bVisible)
Call this member to set the visibility of the control.
CXTPControls * | GetControls () const
Call this member to get the parent controls collection.
XTPControlType | GetType () const
Call this member to get the control's type.
void | SetFlags (DWORD dwFlags)
Call this member to set the flags of the control.
DWORD | GetFlags () const
Call this member to retrieve control special flags.
void | SetTag (DWORD_PTR dwTag)
This method sets the 32-bit value associated with the control.
DWORD_PTR | GetTag () const
This method retrieves the application-supplied, 32-bit value associated with the control.
virtual BOOL | Compare (CXTPControl *pOther)
Call this member to compare controls.
virtual CXTPCommandBar * | GetCommandBar () const
Call this member to get the child command bar.
void | SetCloseSubMenuOnClick (BOOL bCloseOnClick)
Call this member function to enable/disable the closing of sub-menus when a control is clicked in the menu.
BOOL | GetCloseSubMenuOnClick () const
Call this member function to check if sub-menus will close as soon as a control is clicked.
void | SetExecuteOnPressInterval (int nExecuteOnPressInterval)
Call this method to set the delay (in milliseconds) between WM_COMMAND messages while a button is pressed by the user.
int | GetExecuteOnPressInterval () const
Call this method to get the delay (in milliseconds) between WM_COMMAND messages while a button is pressed by the user.
CXTPRibbonGroup * | GetRibbonGroup () const
Returns the ribbon group that the control belongs to.
virtual BOOL | IsTransparent () const
Determines if the control needs to draw its background.
void | SetHideWrap (BOOL bHide)
This method is called to hide the control.
virtual void | SetHideFlags (DWORD dwFlags)
This method is called to hide the control.
BOOL | SetHideFlag (XTPControlHideFlags dwFlag, BOOL bSet)
Call this member to set/remove hide flags.
DWORD | GetHideFlags () const
Call this method to retrieve hidden flags.
CRect | GetRowRect () const
Call this method to retrieve the position of the control's row.
BOOL | GetWrap () const
Call this method to check if the control is wrapped.
void | SetRowRect (CRect rcRow)
Call this method to set the row of the control.
void | SetWrap (BOOL bWrap)
Call this member to set the control to wrapped.
BOOL | GetExpanded () const
Call this member to check if the control is expanded.
BOOL | IsCursorOver () const
Call this member to determine if the mouse pointer is over the control.
virtual void | OnExecute ()
This method is called when the control is executed.
virtual void | OnCalcDynamicSize (DWORD dwMode)
This method is called before recalculating the parent command bar size to calculate the dimensions of the control.
void | DelayRedrawParent ()
Call this method to redraw the parent command bar.
void | DelayLayoutParent ()
Call this method to recalculate the parent command bar size.
void | SetCategory (LPCTSTR lpszCategory)
Call this method to set the category of the control.
CString | GetCategory () const
Call this method to retrieve the category of the control.
CXTPImageManager * | GetImageManager () const
Call this method to retrieve the image manager.
CXTPPaintManager * | GetPaintManager () const
Call this method to retrieve the paint manager.
virtual CXTPImageManagerIcon * | GetImage (int nWidth=16) const
Call this method to retrieve the image of the control.
void | AssignDocTemplate (UINT nIDResource)
Call this method to assign a document template to the control.
void | ExcludeDocTemplate (UINT nIDResource)
Call this method to exclude the document template from control.
BOOL | IsItemDefault () const
Call this method to check if a control is a default menu item.
void | SetItemDefault (BOOL bDefault)
Call this method to set a control to be a default menu item.
BOOL | IsTemporary () const
Call this method to determine if a control is temporary.
void | Reset ()
Call this member to reset the icon and caption of a control to its default settings before it was customized by the user.
void | SetPrompt (LPCTSTR lpszPrompt)
Call this member to load a string from a STRINGTABLE resource to set the tooltip and description of a control.
void | SetCustomIcon (HICON hIcon)
Call this member to set a custom icon to this control.
virtual void | DoPropExchange (CXTPPropExchange *pPX)
Either reads this object from or writes this object to an archive.
virtual void | OnUnderlineActivate ()
This method is called when the user activates the control using its underline.
virtual BOOL | GetPopuped () const
Call this member to get the control's pop-up state.
void | RedrawParent (BOOL bAnimate=TRUE)
This method is called to redraw the parent command bar.
LRESULT | NotifySite (UINT code)
This method is called to send message code to the parent site window.
LRESULT | NotifySite (UINT code, NMXTPCONTROL *pNM)
This method is called to send message code to the parent site window.
LRESULT | NotifySite (CWnd *pSite, UINT code, NMXTPCONTROL *pNM)
This method is called to send message code to the parent site window.
virtual void | SetAction (CXTPControlAction *pAction)
Call this method to manually assign an action for control.
CXTPControlAction * | GetAction () const
Call this method to retrieve an action associated with control.
virtual void | SetWidth (int nWidth)
Call this member to set the width of the control.
virtual void | SetHeight (int nHeight)
Call this member to set the height of the control.
int | GetWidth () const
Call this member to get the width of the control.
int | GetHeight () const
Call this member to get the height of the control.
BOOL | HasDwmCompositedRect () const
This method is called to determine if control has a Vista DWM transparent area.
virtual CSize | GetButtonSize () const
Call this function to get the size of the command bar button.
virtual CSize | GetIconSize () const
Call this member function to get the size of a toolbar icon.
void | SetIconSize (CSize szIcon)
Call this member function to set the size of an icon for an individual control.
virtual void | Copy (CXTPControl *pControl, BOOL bRecursive=FALSE)
This method is called to copy the control.
virtual BOOL | IsCustomizeMovable () const
This method is called to determine if control can be repositioned in customize mode.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

void | OnCaptionChanged ()
This method is called when the control's caption is changed.
virtual void | OnThemeChanged ()
This method is called when the paint manager theme is changed.
virtual CSize | GetSize (CDC *pDC)
This method is called to determine the size of the control.
virtual void | Draw (CDC *pDC)
This method is called to draw the control.
- Protected Member Functions inherited from CXTPControl
CXTPControl ()
Constructs a CXTPControl object.
virtual | ~CXTPControl ()
Destroys a CXTPControl object, handles cleanup and deallocation.
virtual BOOL | IsFocusable () const
This method is called to check if the control can accept focus.
void | SetIndex (int nIndex)
This method is called to assign the order of the control in the controls list.
void | SetExpanded (BOOL bExpanded)
This method is called to set the control's expanded state.
virtual BOOL | OnHookKeyDown (UINT nChar, LPARAM lParam)
This method is called when a non-system key is pressed.
virtual BOOL | OnHookMouseWheel (UINT nFlags, short zDelta, CPoint point)
This method is called when the user rotates the mouse wheel.
virtual void | SetParent (CXTPCommandBar *pParent)
This method is called to assign a parent command bar object.
void | ScreenToClient (CPoint *point)
The ScreenToClient function converts the screen coordinates of a specified point on the screen.
void | ClickToolBarButton (CRect rcActiveRect=CRect(0, 0, 0, 0))
This helper method is called when the user clicks the toolbar's button.
virtual BOOL | OnSetPopup (BOOL bPopup)
This method is called to pop-up the control.
virtual void | OnLButtonUp (CPoint point)
This member is called when the user releases the left mouse button.
virtual void | OnLButtonDown (CPoint point)
This member is called when the user presses the left mouse button down.
virtual BOOL | OnRButtonDown (CPoint point)
This member is called when the user press the right mouse button.
virtual BOOL | OnRButtonUp (CPoint point)
This member is called when the user releases the right mouse button.
virtual BOOL | OnLButtonDblClk (CPoint point)
This member is called when the user double-clicks the left mouse button.
virtual void | OnMouseMove (CPoint point)
This member is called when the mouse cursor moves.
virtual void | OnMouseHover ()
Called after the mouse hovers over the control.
virtual BOOL | OnSetSelected (int bSelected)
This method is called when the control becomes selected.
BOOL | IsCustomizeMode () const
Call this method to determine if command bars is in customize mode.
virtual void | CustomizeStartDrag (CPoint point)
This member is called when the user starts to drag the control in customize mode.
virtual BOOL | CustomizeStartResize (CPoint point)
This method is called when user starts to resize control in customize mode.
virtual void | OnCustomizeDragOver (CXTPControl *pDataObject, CPoint point, DROPEFFECT &dropEffect)
This member is called when the user moves the mouse over the control.
virtual BOOL | DoCustomDragOver (CXTPCommandBar *pCommandBar, CPoint point, DROPEFFECT &dropEffect)
The implementation may implement a custom drag over handling logic in this method.
virtual BOOL | IsCustomizeResizeAllow () const
This member checks if the user can resize the control.
virtual int | GetCustomizeMinWidth () const
Retrieves the available minimum width of control.
virtual int | GetCustomizeMinHeight () const
Retrieves available minimum height of the control.
void | OnCustomizeMouseMove (CPoint point)
This member is called when the mouse cursor moves in customized mode.
virtual void | OnIdleUpdate ()
This virtual method is called in idle-time processing.
virtual void | OnRemoved ()
This method is called when a control is removed from the parent controls collection.
virtual INT_PTR | OnToolHitTest (CPoint point, TOOLINFO *pTI) const
The framework calls this member function to determine whether a point is in the bounding rectangle of the specified tool.
virtual void | RestoreCommandBarList (CXTPCommandBarList *pCommandBarList)
This method is called from LoadCommandBars to restore controls and its child command bars.
virtual void | GenerateCommandBarList (DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam)
This method is called from SaveCommandBars to save all child command bars.
virtual void | OnActionChanged (int nProperty)
This method is called when an action property is changed.
virtual void | OnActionChanging (int nProperty)
This method is called when an action property is about to be changed.
BOOL | IsLayoutRTL () const
Determines if right-to-left (RTL) mode is set.
BOOL | IsLayoutChanged ()
Call this member to determine if the layout has changed (RTL to LTR or LTR to RLT).

Protected Attributes

CXTPMarkupUIElement * | m_pMarkupUIElement
Markup element.
- Protected Attributes inherited from CXTPControl
DWORD_PTR | m_nTag
Control tag.
int | m_nIndex
Index of the control.
int | m_nId
Identifier of the control.
int | m_nIconId
Identifier of the control's image.
int | m_nHelpId
Help identifier.
int | m_nCustomIconId
Identifier of the control's custom image.
BOOL | m_bWrap
TRUE if the control is wrapped.
BOOL | m_bBeginGroup
TRUE if the control starts new group.
BOOL | m_bEnabled
TRUE if the control is enabled.
BOOL | m_bChecked
TRUE if the control is checked.
BOOL | m_bSelected
TRUE if the control is selected.
BOOL | m_bPressed
TRUE if the control is pushed.
BOOL | m_bTemporary
TRUE if the control is temporary.
BOOL | m_bOnQuickAccess
TRUE if the control is a part of Quick Access panel.
CRect | m_rcRow
Bounding rectangle of the control's row.
CRect | m_rcControl
Bounding rectangle of the control.
DWORD | m_dwHideFlags
Hidden flags.
DWORD | m_dwFlags
Flags of the control.
CString | m_strCaption
Caption of the control.
CString | m_strCustomCaption
User-defined caption.
CString | m_strShortcutText
Shortcut text.
CString | m_strShortcutTextAuto
Shortcut text.
CString | m_strTooltipText
Tooltip text.
CString | m_strDescriptionText
Description text.
CString | m_strParameter
Parameter text.
CString | m_strKeyboardTip
Keyboard tip.
CXTPControls * | m_pControls
Parent control collection.
XTPControlType | m_controlType
Type of the control.
CXTPCommandBar * | m_pParent
The Parent command bar.
BOOL | m_bExpanded
TRUE if the control is expanded.
CString | m_strCategory
Category of the control.
BOOL | m_bDefaultItem
TRUE if the item is default pop-up item.
CDocTemplateMap | m_mapDocTemplatesAssigned
Assigned templates.
CDocTemplateMap | m_mapDocTemplatesExcluded
Excluded templates.
XTPButtonStyle | m_buttonStyle
Button Style.
XTPButtonStyle | m_buttonCustomStyle
User-defined style of button.
XTPButtonStyle | m_buttonRibbonStyle
User-defined style of button.
BOOL | m_bCloseSubMenuOnClick
TRUE is sub-menus are closed as soon as a control is clicked.
CXTPRibbonGroup * | m_pRibbonGroup
Ribbon group of control.
CXTPControlAction * | m_pAction
Action of the control.
int | m_nWidth
Width of the control.
int | m_nHeight
Height of the control.
int | m_nExecuteOnPressInterval
Delay between each message when control is pressed.
CSize | m_szIcon
The size of the icon used for the control.
BOOL | m_bLayoutRTL
Indicate does last layout is RTL.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControl
static CXTPControl *AFX_CDECL | FromUI (CCmdUI *pCmdUI)
Call this member to retrieve CXTPControl from a CCmdUI structure.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

CXTPControlMarkupLabel is a CXTPControlLabel derived class.

It can be used to draw markup text

Member Function Documentation

◆ Draw()

virtual void Draw ( CDC * pDC )
protectedvirtual

This method is called to draw the control.

Parameters
pDC Pointer to a valid device context.

Reimplemented from CXTPControl.

◆ GetSize()

virtual CSize GetSize ( CDC * pDC )
protectedvirtual

This method is called to determine the size of the control.

Parameters
pDC Pointer to a valid device context.
Returns
A CSize object containing the size of the control.

Reimplemented from CXTPControl.

The documentation for this class was generated from the following file:
  • XTPControlExt.h


Toolkit Pro: CXTPControlOleItems Class Reference

Protected Member Functions | List of all members
CXTPControlOleItems Class Reference

CXTPControlOleItems is a CXTPControlButton derived class. More...

Inheritance diagram for CXTPControlOleItems:
[legend]

Protected Member Functions

virtual void | OnCalcDynamicSize (DWORD dwMode)
This method is called before recalculating the parent command bar size to calculate the dimensions of the control.
virtual BOOL | DoCustomDragOver (CXTPCommandBar *pCommandBar, CPoint point, DROPEFFECT &dropEffect)
The implementation may implement a custom drag over handling logic in this method.
- Protected Member Functions inherited from CXTPControlButton
virtual void | OnClick (BOOL bKeyboard=FALSE, CPoint pt=CPoint(0, 0))
This method is called when the user clicks the control.
virtual void | OnLButtonUp (CPoint point)
This member is called when the user releases the left mouse button.
virtual void | Copy (CXTPControl *pControl, BOOL bRecursive=FALSE)
This method is called to copy the control.
- Protected Member Functions inherited from CXTPControl
CXTPControl ()
Constructs a CXTPControl object.
virtual | ~CXTPControl ()
Destroys a CXTPControl object, handles cleanup and deallocation.
virtual BOOL | IsFocusable () const
This method is called to check if the control can accept focus.
void | SetIndex (int nIndex)
This method is called to assign the order of the control in the controls list.
void | SetExpanded (BOOL bExpanded)
This method is called to set the control's expanded state.
virtual BOOL | OnHookKeyDown (UINT nChar, LPARAM lParam)
This method is called when a non-system key is pressed.
virtual BOOL | OnHookMouseWheel (UINT nFlags, short zDelta, CPoint point)
This method is called when the user rotates the mouse wheel.
virtual void | SetParent (CXTPCommandBar *pParent)
This method is called to assign a parent command bar object.
void | ScreenToClient (CPoint *point)
The ScreenToClient function converts the screen coordinates of a specified point on the screen.
void | ClickToolBarButton (CRect rcActiveRect=CRect(0, 0, 0, 0))
This helper method is called when the user clicks the toolbar's button.
virtual BOOL | OnSetPopup (BOOL bPopup)
This method is called to pop-up the control.
virtual void | OnLButtonDown (CPoint point)
This member is called when the user presses the left mouse button down.
virtual BOOL | OnRButtonDown (CPoint point)
This member is called when the user press the right mouse button.
virtual BOOL | OnRButtonUp (CPoint point)
This member is called when the user releases the right mouse button.
virtual BOOL | OnLButtonDblClk (CPoint point)
This member is called when the user double-clicks the left mouse button.
virtual void | OnMouseMove (CPoint point)
This member is called when the mouse cursor moves.
virtual void | OnMouseHover ()
Called after the mouse hovers over the control.
virtual BOOL | OnSetSelected (int bSelected)
This method is called when the control becomes selected.
BOOL | IsCustomizeMode () const
Call this method to determine if command bars is in customize mode.
virtual void | CustomizeStartDrag (CPoint point)
This member is called when the user starts to drag the control in customize mode.
virtual BOOL | CustomizeStartResize (CPoint point)
This method is called when user starts to resize control in customize mode.
virtual void | OnCustomizeDragOver (CXTPControl *pDataObject, CPoint point, DROPEFFECT &dropEffect)
This member is called when the user moves the mouse over the control.
virtual BOOL | IsCustomizeResizeAllow () const
This member checks if the user can resize the control.
virtual int | GetCustomizeMinWidth () const
Retrieves the available minimum width of control.
virtual int | GetCustomizeMinHeight () const
Retrieves available minimum height of the control.
void | OnCustomizeMouseMove (CPoint point)
This member is called when the mouse cursor moves in customized mode.
virtual void | OnIdleUpdate ()
This virtual method is called in idle-time processing.
virtual void | OnRemoved ()
This method is called when a control is removed from the parent controls collection.
virtual INT_PTR | OnToolHitTest (CPoint point, TOOLINFO *pTI) const
The framework calls this member function to determine whether a point is in the bounding rectangle of the specified tool.
virtual void | RestoreCommandBarList (CXTPCommandBarList *pCommandBarList)
This method is called from LoadCommandBars to restore controls and its child command bars.
virtual void | GenerateCommandBarList (DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam)
This method is called from SaveCommandBars to save all child command bars.
virtual void | OnActionChanged (int nProperty)
This method is called when an action property is changed.
virtual void | OnActionChanging (int nProperty)
This method is called when an action property is about to be changed.
virtual void | OnCaptionChanged ()
This method is called when the control's caption is changed.
BOOL | IsLayoutRTL () const
Determines if right-to-left (RTL) mode is set.
BOOL | IsLayoutChanged ()
Call this member to determine if the layout has changed (RTL to LTR or LTR to RLT).

Additional Inherited Members

- Public Member Functions inherited from CXTPControlButton
CXTPControlButton ()
Constructs a CXTPControlButton object.
virtual | ~CXTPControlButton ()
Destroys a CXTPControlButton object, handles cleanup and deallocation.
void | SetStyleEx (XTPButtonStyle buttonStyle)
Call this member to set the style of the button containing vector icon.
XTPButtonStyle | GetStyleEx () const
Call this member to get the button's style containing vector icon.
void | DoPropExchange (CXTPPropExchange *pPX)
Either reads this object from or writes this object to an archive.
- Public Member Functions inherited from CXTPControl
void | SetStyle (XTPButtonStyle buttonStyle)
Call this member to set the style of the control.
XTPButtonStyle | GetStyle () const
Call this member to get the control's style.
void | SetCaption (LPCTSTR lpszCaption)
Call this member to set the caption of the control.
void | SetCaption (UINT nIDCaption)
Call this member to set the caption of the control.
virtual CString | GetCaption () const
Call this member to get the control's caption.
void | SetShortcutText (LPCTSTR lpszShortcutText)
Call this member to set the shortcut string to the control.
CString | GetShortcutText () const
Call this member to get the control's shortcut.
void | SetDescription (LPCTSTR lpszDescription)
Call this member to set the description of the control.
virtual CString | GetDescription () const
Call this member to get the control's description.
void | SetTooltip (LPCTSTR lpszTooltip)
Call this member to set the tooltip of the control.
virtual CString | GetTooltip () const
Call this member to get the control's tooltip.
void | SetKeyboardTip (LPCTSTR lpszKeyboardTip)
Call this member to set the keyboard tip to the control.
CString | GetKeyboardTip () const
Call this member to get the keyboard tip.
void | SetCustomShortcutText (LPCTSTR lpszCustomShortcutText)
Call this member to set the text displayed for the shortcut in a pop-up menu.
CString | GetCustomShortcutText () const
Call this member to get the control's text displayed for the shortcut in a pop-up menu.
void | SetParameter (LPCTSTR lpszParameter)
Call this member to set the parameter of the control.
CString | GetParameter () const
Call this member to get the control's parameter.
void | SetID (int nId)
Call this member to set the identifier of the control.
int | GetID () const
Call this member to get the control's identifier.
long | GetIndex () const
Call this member to get the index of the control.
void | SetIconId (int nId)
Call this member to set the control icon's identifier.
int | GetIconId () const
Call this member to get the icon's identifier.
void | SetHelpId (int nId)
Call this member to set the control help identifier.
int | GetHelpId () const
Call this member to get the help identifier.
virtual void | SetBeginGroup (BOOL bBeginGroup)
Call this member to begin a new group using a separator.
BOOL | GetBeginGroup () const
Call this member to determine if the control has a separator.
virtual void | SetEnabled (BOOL bEnabled)
Call this member to enable/disable the control.
BOOL | GetEnabled () const
Call this member to check if the control is enabled.
virtual void | OnEnabledChanged ()
This method is called when a control's enabled state is changed.
virtual void | SetChecked (BOOL bChecked)
Call this member to set the checked state of the control.
BOOL | GetChecked () const
Call this member to get the checked state of the control.
virtual int | GetSelected () const
Call this member to check if the control is selected.
void | SetOnQuickAccess (BOOL bOnQuicAccess=FALSE)
Call this member to set whether a control should be a part of the Quick Access panel.
BOOL | IsOnQuickAccess () const
Call this member to check if a control is a part of the Quick Access panel.
virtual void | SetFocused (BOOL bFocused)
Call this member to set the focused state of the control.
virtual BOOL | IsFocused () const
Call this member to check the focused state of the control.
void | SetPressed (BOOL bPressed)
Call this member to set the pressed state of the control.
virtual BOOL | GetPressed () const
Call this member to check the pressed state of the control.
virtual void | SetRect (CRect rcControl)
This member is called to set the bounding rectangle of the control.
CRect | GetRect () const
Call this member to get the bounding rectangle of the control.
CXTPCommandBar * | GetParent () const
Call this member to get the parent command bar.
virtual BOOL | IsVisible (DWORD dwSkipFlags=0) const
Call this member to determine if the control is visible.
virtual BOOL | IsCaptionVisible () const
Call this member to determine if the caption of the control is visible.
void | SetVisible (BOOL bVisible)
Call this member to set the visibility of the control.
CXTPControls * | GetControls () const
Call this member to get the parent controls collection.
XTPControlType | GetType () const
Call this member to get the control's type.
void | SetFlags (DWORD dwFlags)
Call this member to set the flags of the control.
DWORD | GetFlags () const
Call this member to retrieve control special flags.
void | SetTag (DWORD_PTR dwTag)
This method sets the 32-bit value associated with the control.
DWORD_PTR | GetTag () const
This method retrieves the application-supplied, 32-bit value associated with the control.
virtual BOOL | Compare (CXTPControl *pOther)
Call this member to compare controls.
virtual CXTPCommandBar * | GetCommandBar () const
Call this member to get the child command bar.
void | SetCloseSubMenuOnClick (BOOL bCloseOnClick)
Call this member function to enable/disable the closing of sub-menus when a control is clicked in the menu.
BOOL | GetCloseSubMenuOnClick () const
Call this member function to check if sub-menus will close as soon as a control is clicked.
void | SetExecuteOnPressInterval (int nExecuteOnPressInterval)
Call this method to set the delay (in milliseconds) between WM_COMMAND messages while a button is pressed by the user.
int | GetExecuteOnPressInterval () const
Call this method to get the delay (in milliseconds) between WM_COMMAND messages while a button is pressed by the user.
CXTPRibbonGroup * | GetRibbonGroup () const
Returns the ribbon group that the control belongs to.
virtual BOOL | IsTransparent () const
Determines if the control needs to draw its background.
void | SetHideWrap (BOOL bHide)
This method is called to hide the control.
virtual void | SetHideFlags (DWORD dwFlags)
This method is called to hide the control.
BOOL | SetHideFlag (XTPControlHideFlags dwFlag, BOOL bSet)
Call this member to set/remove hide flags.
DWORD | GetHideFlags () const
Call this method to retrieve hidden flags.
CRect | GetRowRect () const
Call this method to retrieve the position of the control's row.
BOOL | GetWrap () const
Call this method to check if the control is wrapped.
void | SetRowRect (CRect rcRow)
Call this method to set the row of the control.
void | SetWrap (BOOL bWrap)
Call this member to set the control to wrapped.
BOOL | GetExpanded () const
Call this member to check if the control is expanded.
BOOL | IsCursorOver () const
Call this member to determine if the mouse pointer is over the control.
virtual void | OnExecute ()
This method is called when the control is executed.
virtual CSize | GetSize (CDC *pDC)
This method is called to determine the size of the control.
virtual void | Draw (CDC *pDC)
This method is called to draw the control.
void | DelayRedrawParent ()
Call this method to redraw the parent command bar.
void | DelayLayoutParent ()
Call this method to recalculate the parent command bar size.
void | SetCategory (LPCTSTR lpszCategory)
Call this method to set the category of the control.
CString | GetCategory () const
Call this method to retrieve the category of the control.
CXTPImageManager * | GetImageManager () const
Call this method to retrieve the image manager.
CXTPPaintManager * | GetPaintManager () const
Call this method to retrieve the paint manager.
virtual CXTPImageManagerIcon * | GetImage (int nWidth=16) const
Call this method to retrieve the image of the control.
void | AssignDocTemplate (UINT nIDResource)
Call this method to assign a document template to the control.
void | ExcludeDocTemplate (UINT nIDResource)
Call this method to exclude the document template from control.
BOOL | IsItemDefault () const
Call this method to check if a control is a default menu item.
void | SetItemDefault (BOOL bDefault)
Call this method to set a control to be a default menu item.
BOOL | IsTemporary () const
Call this method to determine if a control is temporary.
void | Reset ()
Call this member to reset the icon and caption of a control to its default settings before it was customized by the user.
void | SetPrompt (LPCTSTR lpszPrompt)
Call this member to load a string from a STRINGTABLE resource to set the tooltip and description of a control.
void | SetCustomIcon (HICON hIcon)
Call this member to set a custom icon to this control.
virtual void | OnUnderlineActivate ()
This method is called when the user activates the control using its underline.
virtual BOOL | GetPopuped () const
Call this member to get the control's pop-up state.
void | RedrawParent (BOOL bAnimate=TRUE)
This method is called to redraw the parent command bar.
LRESULT | NotifySite (UINT code)
This method is called to send message code to the parent site window.
LRESULT | NotifySite (UINT code, NMXTPCONTROL *pNM)
This method is called to send message code to the parent site window.
LRESULT | NotifySite (CWnd *pSite, UINT code, NMXTPCONTROL *pNM)
This method is called to send message code to the parent site window.
virtual void | SetAction (CXTPControlAction *pAction)
Call this method to manually assign an action for control.
CXTPControlAction * | GetAction () const
Call this method to retrieve an action associated with control.
virtual void | OnThemeChanged ()
This method is called when the paint manager theme is changed.
virtual void | SetWidth (int nWidth)
Call this member to set the width of the control.
virtual void | SetHeight (int nHeight)
Call this member to set the height of the control.
int | GetWidth () const
Call this member to get the width of the control.
int | GetHeight () const
Call this member to get the height of the control.
BOOL | HasDwmCompositedRect () const
This method is called to determine if control has a Vista DWM transparent area.
virtual CSize | GetButtonSize () const
Call this function to get the size of the command bar button.
virtual CSize | GetIconSize () const
Call this member function to get the size of a toolbar icon.
void | SetIconSize (CSize szIcon)
Call this member function to set the size of an icon for an individual control.
virtual BOOL | IsCustomizeMovable () const
This method is called to determine if control can be repositioned in customize mode.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.
- Static Public Member Functions inherited from CXTPControl
static CXTPControl *AFX_CDECL | FromUI (CCmdUI *pCmdUI)
Call this member to retrieve CXTPControl from a CCmdUI structure.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Attributes inherited from CXTPControlButton
XTPButtonStyle | m_buttonStyleEx
User-defined style of button containing vector icon.
- Protected Attributes inherited from CXTPControl
DWORD_PTR | m_nTag
Control tag.
int | m_nIndex
Index of the control.
int | m_nId
Identifier of the control.
int | m_nIconId
Identifier of the control's image.
int | m_nHelpId
Help identifier.
int | m_nCustomIconId
Identifier of the control's custom image.
BOOL | m_bWrap
TRUE if the control is wrapped.
BOOL | m_bBeginGroup
TRUE if the control starts new group.
BOOL | m_bEnabled
TRUE if the control is enabled.
BOOL | m_bChecked
TRUE if the control is checked.
BOOL | m_bSelected
TRUE if the control is selected.
BOOL | m_bPressed
TRUE if the control is pushed.
BOOL | m_bTemporary
TRUE if the control is temporary.
BOOL | m_bOnQuickAccess
TRUE if the control is a part of Quick Access panel.
CRect | m_rcRow
Bounding rectangle of the control's row.
CRect | m_rcControl
Bounding rectangle of the control.
DWORD | m_dwHideFlags
Hidden flags.
DWORD | m_dwFlags
Flags of the control.
CString | m_strCaption
Caption of the control.
CString | m_strCustomCaption
User-defined caption.
CString | m_strShortcutText
Shortcut text.
CString | m_strShortcutTextAuto
Shortcut text.
CString | m_strTooltipText
Tooltip text.
CString | m_strDescriptionText
Description text.
CString | m_strParameter
Parameter text.
CString | m_strKeyboardTip
Keyboard tip.
CXTPControls * | m_pControls
Parent control collection.
XTPControlType | m_controlType
Type of the control.
CXTPCommandBar * | m_pParent
The Parent command bar.
BOOL | m_bExpanded
TRUE if the control is expanded.
CString | m_strCategory
Category of the control.
BOOL | m_bDefaultItem
TRUE if the item is default pop-up item.
CDocTemplateMap | m_mapDocTemplatesAssigned
Assigned templates.
CDocTemplateMap | m_mapDocTemplatesExcluded
Excluded templates.
XTPButtonStyle | m_buttonStyle
Button Style.
XTPButtonStyle | m_buttonCustomStyle
User-defined style of button.
XTPButtonStyle | m_buttonRibbonStyle
User-defined style of button.
BOOL | m_bCloseSubMenuOnClick
TRUE is sub-menus are closed as soon as a control is clicked.
CXTPRibbonGroup * | m_pRibbonGroup
Ribbon group of control.
CXTPControlAction * | m_pAction
Action of the control.
int | m_nWidth
Width of the control.
int | m_nHeight
Height of the control.
int | m_nExecuteOnPressInterval
Delay between each message when control is pressed.
CSize | m_szIcon
The size of the icon used for the control.
BOOL | m_bLayoutRTL
Indicate does last layout is RTL.

Detailed Description

CXTPControlOleItems is a CXTPControlButton derived class.

It is used internally to create ole items.

Member Function Documentation

◆ DoCustomDragOver()

virtual BOOL DoCustomDragOver | ( | CXTPCommandBar * | pCommandBar,
 |  | CPoint | point,
 |  | DROPEFFECT & | dropEffect )
 protectedvirtual

The implementation may implement a custom drag over handling logic in this method.

Parameters
pCommandBar | Pointer to a CXTPCommandBar object.
point | Mouse position.
dropEffect | DROPEFFECT enumerator.
Returns
TRUE if custom implementation handles drag over, otherwise FALSE.

Reimplemented from CXTPControl.

◆ OnCalcDynamicSize()

virtual void OnCalcDynamicSize ( DWORD dwMode )
protectedvirtual

This method is called before recalculating the parent command bar size to calculate the dimensions of the control.

Parameters
dwMode Flags used to determine the height and width of the dynamic command bar. See Remarks section for a list of values.

The following predefined flags are used to determine the height and width of the dynamic command bar. Use the bitwise-OR (|) operator to combine the flags.

LM_STRETCH: Indicates whether the command bar should be stretched to the size of the frame. Set if the bar is not a docking bar (not available for docking). Not set when the bar is docked or floating (available for docking). If set, LM_STRETCH returns dimensions based on the LM_HORZ state. LM_STRETCH works similarly to the the bStretch parameter used in CalcFixedLayout; see that member function for more information about the relationship between stretching and orientation. LM_HORZ: Indicates that the bar is horizontally or vertically oriented. Set if the bar is horizontally oriented, and if it is vertically oriented, it is not set. LM_HORZ works similarly to the the bHorz parameter used in CalcFixedLayout; see that member function for more information about the relationship between stretching and orientation. LM_MRUWIDTH: Most Recently Used Dynamic Width. Uses the remembered most recently used width. LM_HORZDOCK: Horizontal Docked Dimensions. Returns the dynamic size with the largest width. LM_VERTDOCK: Vertical Docked Dimensions. Returns the dynamic size with the largest height. LM_COMMIT: Resets LM_MRUWIDTH to the current width of the floating command bar.

The framework calls this member function to calculate the dimensions of a dynamic command bar.

Override this member function to provide your own layout in classes you derive from CXTPControl. XTP classes derived from CXTPControl, such as CXTPControlComboBox, override this member function to provide their own implementation.

See also
CXTPControlComboBox, CXTPControlCustom, CXTPControlEdit, CXTPControlWindowList, CXTPControlWorkspaceActions, CXTPControlToolbars, CXTPControl, CXTPControlRecentFileList, CXTPControlSelector, CXTPControlListBox

Reimplemented from CXTPControl.

The documentation for this class was generated from the following file:
  • XTPControlExt.h


Toolkit Pro: CXTPControlPopup Class Reference

Public Member Functions | Static Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPControlPopup Class Reference

CXTPControlPopup is a CXTPControl derived class. More...

Inheritance diagram for CXTPControlPopup:
[legend]

Public Member Functions

CXTPControlPopup ()
Constructs a CXTPControlPopup object.
virtual | ~CXTPControlPopup ()
Destroys a CXTPControlPopup object, handles cleanup and deallocation.
void | SetCommandBar (CMenu *pMenu)
Call this member to set the child command bar.
void | SetCommandBar (CXTPCommandBar *pBar)
Call this member to set the child command bar.
CXTPCommandBar * | GetCommandBar () const
Call this member to get the child command bar.
BOOL | GetPopuped () const
Call this member to get the control's pop-up state.
virtual CString | GetCaption () const
Call this member to get the control's caption.
void | DoPropExchange (CXTPPropExchange *pPX)
Either reads this object from or writes this object to an archive.
virtual void | AdjustExcludeRect (CRect &rc, BOOL bVertical)
Updates rectangle to set the position where the child pop-up bar becomes visible.
void | Copy (CXTPControl *pControl, BOOL bRecursive=FALSE)
This method is called to copy the control.
virtual void | OnUnderlineActivate ()
This method is called when the user activates a control using its underline.
- Public Member Functions inherited from CXTPControlButton
CXTPControlButton ()
Constructs a CXTPControlButton object.
virtual | ~CXTPControlButton ()
Destroys a CXTPControlButton object, handles cleanup and deallocation.
void | SetStyleEx (XTPButtonStyle buttonStyle)
Call this member to set the style of the button containing vector icon.
XTPButtonStyle | GetStyleEx () const
Call this member to get the button's style containing vector icon.
- Public Member Functions inherited from CXTPControl
void | SetStyle (XTPButtonStyle buttonStyle)
Call this member to set the style of the control.
XTPButtonStyle | GetStyle () const
Call this member to get the control's style.
void | SetCaption (LPCTSTR lpszCaption)
Call this member to set the caption of the control.
void | SetCaption (UINT nIDCaption)
Call this member to set the caption of the control.
void | SetShortcutText (LPCTSTR lpszShortcutText)
Call this member to set the shortcut string to the control.
CString | GetShortcutText () const
Call this member to get the control's shortcut.
void | SetDescription (LPCTSTR lpszDescription)
Call this member to set the description of the control.
virtual CString | GetDescription () const
Call this member to get the control's description.
void | SetTooltip (LPCTSTR lpszTooltip)
Call this member to set the tooltip of the control.
virtual CString | GetTooltip () const
Call this member to get the control's tooltip.
void | SetKeyboardTip (LPCTSTR lpszKeyboardTip)
Call this member to set the keyboard tip to the control.
CString | GetKeyboardTip () const
Call this member to get the keyboard tip.
void | SetCustomShortcutText (LPCTSTR lpszCustomShortcutText)
Call this member to set the text displayed for the shortcut in a pop-up menu.
CString | GetCustomShortcutText () const
Call this member to get the control's text displayed for the shortcut in a pop-up menu.
void | SetParameter (LPCTSTR lpszParameter)
Call this member to set the parameter of the control.
CString | GetParameter () const
Call this member to get the control's parameter.
void | SetID (int nId)
Call this member to set the identifier of the control.
int | GetID () const
Call this member to get the control's identifier.
long | GetIndex () const
Call this member to get the index of the control.
void | SetIconId (int nId)
Call this member to set the control icon's identifier.
int | GetIconId () const
Call this member to get the icon's identifier.
void | SetHelpId (int nId)
Call this member to set the control help identifier.
int | GetHelpId () const
Call this member to get the help identifier.
virtual void | SetBeginGroup (BOOL bBeginGroup)
Call this member to begin a new group using a separator.
BOOL | GetBeginGroup () const
Call this member to determine if the control has a separator.
virtual void | SetEnabled (BOOL bEnabled)
Call this member to enable/disable the control.
BOOL | GetEnabled () const
Call this member to check if the control is enabled.
virtual void | OnEnabledChanged ()
This method is called when a control's enabled state is changed.
virtual void | SetChecked (BOOL bChecked)
Call this member to set the checked state of the control.
BOOL | GetChecked () const
Call this member to get the checked state of the control.
virtual int | GetSelected () const
Call this member to check if the control is selected.
void | SetOnQuickAccess (BOOL bOnQuicAccess=FALSE)
Call this member to set whether a control should be a part of the Quick Access panel.
BOOL | IsOnQuickAccess () const
Call this member to check if a control is a part of the Quick Access panel.
virtual void | SetFocused (BOOL bFocused)
Call this member to set the focused state of the control.
virtual BOOL | IsFocused () const
Call this member to check the focused state of the control.
void | SetPressed (BOOL bPressed)
Call this member to set the pressed state of the control.
virtual BOOL | GetPressed () const
Call this member to check the pressed state of the control.
virtual void | SetRect (CRect rcControl)
This member is called to set the bounding rectangle of the control.
CRect | GetRect () const
Call this member to get the bounding rectangle of the control.
CXTPCommandBar * | GetParent () const
Call this member to get the parent command bar.
virtual BOOL | IsVisible (DWORD dwSkipFlags=0) const
Call this member to determine if the control is visible.
virtual BOOL | IsCaptionVisible () const
Call this member to determine if the caption of the control is visible.
void | SetVisible (BOOL bVisible)
Call this member to set the visibility of the control.
CXTPControls * | GetControls () const
Call this member to get the parent controls collection.
XTPControlType | GetType () const
Call this member to get the control's type.
void | SetFlags (DWORD dwFlags)
Call this member to set the flags of the control.
DWORD | GetFlags () const
Call this member to retrieve control special flags.
void | SetTag (DWORD_PTR dwTag)
This method sets the 32-bit value associated with the control.
DWORD_PTR | GetTag () const
This method retrieves the application-supplied, 32-bit value associated with the control.
void | SetCloseSubMenuOnClick (BOOL bCloseOnClick)
Call this member function to enable/disable the closing of sub-menus when a control is clicked in the menu.
BOOL | GetCloseSubMenuOnClick () const
Call this member function to check if sub-menus will close as soon as a control is clicked.
void | SetExecuteOnPressInterval (int nExecuteOnPressInterval)
Call this method to set the delay (in milliseconds) between WM_COMMAND messages while a button is pressed by the user.
int | GetExecuteOnPressInterval () const
Call this method to get the delay (in milliseconds) between WM_COMMAND messages while a button is pressed by the user.
CXTPRibbonGroup * | GetRibbonGroup () const
Returns the ribbon group that the control belongs to.
virtual BOOL | IsTransparent () const
Determines if the control needs to draw its background.
void | SetHideWrap (BOOL bHide)
This method is called to hide the control.
virtual void | SetHideFlags (DWORD dwFlags)
This method is called to hide the control.
BOOL | SetHideFlag (XTPControlHideFlags dwFlag, BOOL bSet)
Call this member to set/remove hide flags.
DWORD | GetHideFlags () const
Call this method to retrieve hidden flags.
CRect | GetRowRect () const
Call this method to retrieve the position of the control's row.
BOOL | GetWrap () const
Call this method to check if the control is wrapped.
void | SetRowRect (CRect rcRow)
Call this method to set the row of the control.
void | SetWrap (BOOL bWrap)
Call this member to set the control to wrapped.
BOOL | GetExpanded () const
Call this member to check if the control is expanded.
BOOL | IsCursorOver () const
Call this member to determine if the mouse pointer is over the control.
virtual void | OnExecute ()
This method is called when the control is executed.
virtual CSize | GetSize (CDC *pDC)
This method is called to determine the size of the control.
virtual void | Draw (CDC *pDC)
This method is called to draw the control.
virtual void | OnCalcDynamicSize (DWORD dwMode)
This method is called before recalculating the parent command bar size to calculate the dimensions of the control.
void | DelayRedrawParent ()
Call this method to redraw the parent command bar.
void | DelayLayoutParent ()
Call this method to recalculate the parent command bar size.
void | SetCategory (LPCTSTR lpszCategory)
Call this method to set the category of the control.
CString | GetCategory () const
Call this method to retrieve the category of the control.
CXTPImageManager * | GetImageManager () const
Call this method to retrieve the image manager.
CXTPPaintManager * | GetPaintManager () const
Call this method to retrieve the paint manager.
virtual CXTPImageManagerIcon * | GetImage (int nWidth=16) const
Call this method to retrieve the image of the control.
void | AssignDocTemplate (UINT nIDResource)
Call this method to assign a document template to the control.
void | ExcludeDocTemplate (UINT nIDResource)
Call this method to exclude the document template from control.
BOOL | IsItemDefault () const
Call this method to check if a control is a default menu item.
void | SetItemDefault (BOOL bDefault)
Call this method to set a control to be a default menu item.
BOOL | IsTemporary () const
Call this method to determine if a control is temporary.
void | Reset ()
Call this member to reset the icon and caption of a control to its default settings before it was customized by the user.
void | SetPrompt (LPCTSTR lpszPrompt)
Call this member to load a string from a STRINGTABLE resource to set the tooltip and description of a control.
void | SetCustomIcon (HICON hIcon)
Call this member to set a custom icon to this control.
void | RedrawParent (BOOL bAnimate=TRUE)
This method is called to redraw the parent command bar.
LRESULT | NotifySite (UINT code)
This method is called to send message code to the parent site window.
LRESULT | NotifySite (UINT code, NMXTPCONTROL *pNM)
This method is called to send message code to the parent site window.
LRESULT | NotifySite (CWnd *pSite, UINT code, NMXTPCONTROL *pNM)
This method is called to send message code to the parent site window.
virtual void | SetAction (CXTPControlAction *pAction)
Call this method to manually assign an action for control.
CXTPControlAction * | GetAction () const
Call this method to retrieve an action associated with control.
virtual void | OnThemeChanged ()
This method is called when the paint manager theme is changed.
virtual void | SetWidth (int nWidth)
Call this member to set the width of the control.
virtual void | SetHeight (int nHeight)
Call this member to set the height of the control.
int | GetWidth () const
Call this member to get the width of the control.
int | GetHeight () const
Call this member to get the height of the control.
BOOL | HasDwmCompositedRect () const
This method is called to determine if control has a Vista DWM transparent area.
virtual CSize | GetButtonSize () const
Call this function to get the size of the command bar button.
virtual CSize | GetIconSize () const
Call this member function to get the size of a toolbar icon.
void | SetIconSize (CSize szIcon)
Call this member function to set the size of an icon for an individual control.
virtual BOOL | IsCustomizeMovable () const
This method is called to determine if control can be repositioned in customize mode.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Static Public Member Functions

static CXTPControlPopup *AFX_CDECL | CreateControlPopup (XTPControlType controlType)
Creates a CXTPControlPopup object with the specified type.
- Static Public Member Functions inherited from CXTPControl
static CXTPControl *AFX_CDECL | FromUI (CCmdUI *pCmdUI)
Call this member to retrieve CXTPControl from a CCmdUI structure.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Protected Member Functions

BOOL | ContainsPopup (CXTPControlPopup *pControlPopup)
This method is called to check if pControlPopup contains in the control recursively.
void | ExpandCommandBar ()
Call this member to expand the parent pop-up bar.
BOOL | OnSetSelected (int bSelected)
This method is called when the control becomes selected.
void | OnClick (BOOL bKeyboard=FALSE, CPoint pt=CPoint(0, 0))
This method is called when the user clicks the control.
void | OnMouseHover ()
This method is called after the mouse hovers over the control.
virtual void | OnMouseMove (CPoint point)
This member is called when the mouse cursor moves.
virtual BOOL | OnSetPopup (BOOL bPopup)
This method is called to pop-up the control.
virtual void | OnLButtonUp (CPoint point)
This member is called when the user releases the left mouse button.
virtual BOOL | OnLButtonDblClk (CPoint point)
This member is called when the user double-clicks the left mouse button.
void | OnCustomizeDragOver (CXTPControl *pDataObject, CPoint point, DROPEFFECT &dropEffect)
This method is called when the user moves the mouse over the control.
virtual BOOL | DoCustomDragOver (CXTPCommandBar *pCommandBar, CPoint point, DROPEFFECT &dropEffect)
The implementation may implement a custom drag over handling logic in this method.
virtual BOOL | Compare (CXTPControl *pOther)
Call this member to compare controls.
virtual void | UpdateShadow ()
Call this member to update the shadow of the control.
virtual void | RestoreCommandBarList (CXTPCommandBarList *pCommandBarList)
This method is called from LoadCommandBars to restore controls and its child command bars.
- Protected Member Functions inherited from CXTPControlButton
- Protected Member Functions inherited from CXTPControl
CXTPControl ()
Constructs a CXTPControl object.
virtual | ~CXTPControl ()
Destroys a CXTPControl object, handles cleanup and deallocation.
virtual BOOL | IsFocusable () const
This method is called to check if the control can accept focus.
void | SetIndex (int nIndex)
This method is called to assign the order of the control in the controls list.
void | SetExpanded (BOOL bExpanded)
This method is called to set the control's expanded state.
virtual BOOL | OnHookKeyDown (UINT nChar, LPARAM lParam)
This method is called when a non-system key is pressed.
virtual BOOL | OnHookMouseWheel (UINT nFlags, short zDelta, CPoint point)
This method is called when the user rotates the mouse wheel.
virtual void | SetParent (CXTPCommandBar *pParent)
This method is called to assign a parent command bar object.
void | ScreenToClient (CPoint *point)
The ScreenToClient function converts the screen coordinates of a specified point on the screen.
void | ClickToolBarButton (CRect rcActiveRect=CRect(0, 0, 0, 0))
This helper method is called when the user clicks the toolbar's button.
virtual void | OnLButtonDown (CPoint point)
This member is called when the user presses the left mouse button down.
virtual BOOL | OnRButtonDown (CPoint point)
This member is called when the user press the right mouse button.
virtual BOOL | OnRButtonUp (CPoint point)
This member is called when the user releases the right mouse button.
BOOL | IsCustomizeMode () const
Call this method to determine if command bars is in customize mode.
virtual void | CustomizeStartDrag (CPoint point)
This member is called when the user starts to drag the control in customize mode.
virtual BOOL | CustomizeStartResize (CPoint point)
This method is called when user starts to resize control in customize mode.
virtual BOOL | IsCustomizeResizeAllow () const
This member checks if the user can resize the control.
virtual int | GetCustomizeMinWidth () const
Retrieves the available minimum width of control.
virtual int | GetCustomizeMinHeight () const
Retrieves available minimum height of the control.
void | OnCustomizeMouseMove (CPoint point)
This member is called when the mouse cursor moves in customized mode.
virtual void | OnIdleUpdate ()
This virtual method is called in idle-time processing.
virtual void | OnRemoved ()
This method is called when a control is removed from the parent controls collection.
virtual INT_PTR | OnToolHitTest (CPoint point, TOOLINFO *pTI) const
The framework calls this member function to determine whether a point is in the bounding rectangle of the specified tool.
virtual void | GenerateCommandBarList (DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam)
This method is called from SaveCommandBars to save all child command bars.
virtual void | OnActionChanged (int nProperty)
This method is called when an action property is changed.
virtual void | OnActionChanging (int nProperty)
This method is called when an action property is about to be changed.
virtual void | OnCaptionChanged ()
This method is called when the control's caption is changed.
BOOL | IsLayoutRTL () const
Determines if right-to-left (RTL) mode is set.
BOOL | IsLayoutChanged ()
Call this member to determine if the layout has changed (RTL to LTR or LTR to RLT).

Protected Attributes

BOOL | m_bPopup
TRUE if pop-up'ed.
CXTPCommandBar * | m_pCommandBar
Child pop-up bar.
DWORD | m_dwCommandBarID
Child pop-up ID.
BOOL | m_bShowShadow
TRUE to show shadow.
- Protected Attributes inherited from CXTPControlButton
XTPButtonStyle | m_buttonStyleEx
User-defined style of button containing vector icon.
- Protected Attributes inherited from CXTPControl
DWORD_PTR | m_nTag
Control tag.
int | m_nIndex
Index of the control.
int | m_nId
Identifier of the control.
int | m_nIconId
Identifier of the control's image.
int | m_nHelpId
Help identifier.
int | m_nCustomIconId
Identifier of the control's custom image.
BOOL | m_bWrap
TRUE if the control is wrapped.
BOOL | m_bBeginGroup
TRUE if the control starts new group.
BOOL | m_bEnabled
TRUE if the control is enabled.
BOOL | m_bChecked
TRUE if the control is checked.
BOOL | m_bSelected
TRUE if the control is selected.
BOOL | m_bPressed
TRUE if the control is pushed.
BOOL | m_bTemporary
TRUE if the control is temporary.
BOOL | m_bOnQuickAccess
TRUE if the control is a part of Quick Access panel.
CRect | m_rcRow
Bounding rectangle of the control's row.
CRect | m_rcControl
Bounding rectangle of the control.
DWORD | m_dwHideFlags
Hidden flags.
DWORD | m_dwFlags
Flags of the control.
CString | m_strCaption
Caption of the control.
CString | m_strCustomCaption
User-defined caption.
CString | m_strShortcutText
Shortcut text.
CString | m_strShortcutTextAuto
Shortcut text.
CString | m_strTooltipText
Tooltip text.
CString | m_strDescriptionText
Description text.
CString | m_strParameter
Parameter text.
CString | m_strKeyboardTip
Keyboard tip.
CXTPControls * | m_pControls
Parent control collection.
XTPControlType | m_controlType
Type of the control.
CXTPCommandBar * | m_pParent
The Parent command bar.
BOOL | m_bExpanded
TRUE if the control is expanded.
CString | m_strCategory
Category of the control.
BOOL | m_bDefaultItem
TRUE if the item is default pop-up item.
CDocTemplateMap | m_mapDocTemplatesAssigned
Assigned templates.
CDocTemplateMap | m_mapDocTemplatesExcluded
Excluded templates.
XTPButtonStyle | m_buttonStyle
Button Style.
XTPButtonStyle | m_buttonCustomStyle
User-defined style of button.
XTPButtonStyle | m_buttonRibbonStyle
User-defined style of button.
BOOL | m_bCloseSubMenuOnClick
TRUE is sub-menus are closed as soon as a control is clicked.
CXTPRibbonGroup * | m_pRibbonGroup
Ribbon group of control.
CXTPControlAction * | m_pAction
Action of the control.
int | m_nWidth
Width of the control.
int | m_nHeight
Height of the control.
int | m_nExecuteOnPressInterval
Delay between each message when control is pressed.
CSize | m_szIcon
The size of the icon used for the control.
BOOL | m_bLayoutRTL
Indicate does last layout is RTL.

Detailed Description

CXTPControlPopup is a CXTPControl derived class.

It represents a pop-upable control.

Member Function Documentation

◆ AdjustExcludeRect()

virtual void AdjustExcludeRect | ( | CRect & | rc,
 |  | BOOL | bVertical )
 virtual

Updates rectangle to set the position where the child pop-up bar becomes visible.

Parameters
rc | CRect object specifying the size of the area.
bVertical | TRUE if the control is located vertically in its parent.

Reimplemented in CXTPRibbonControlSystemButton.

◆ Compare()

virtual BOOL Compare ( CXTPControl * pOther )
protectedvirtual

Call this member to compare controls.

Parameters
pOther The control to compare with.
Returns
TRUE if the controls are identical, otherwise FALSE.

Reimplemented from CXTPControl.

Reimplemented in CXTPControlComboBox.

◆ ContainsPopup()

BOOL ContainsPopup ( CXTPControlPopup * pControlPopup )
protected

This method is called to check if pControlPopup contains in the control recursively.

Parameters
pControlPopup Pointer to a CXTPControlPopup object to check.
Returns
TRUE if contains; otherwise returns FALSE

◆ Copy()

void Copy | ( | CXTPControl * | pControl,
 |  | BOOL | bRecursive = FALSE )
 virtual

This method is called to copy the control.

Parameters
pControl | Pointer to a source CXTPControl object.
bRecursive | TRUE to copy recursively.

Reimplemented from CXTPControlButton.

Reimplemented in CXTPControlPopupColor, and CXTPRibbonControlTab.

◆ CreateControlPopup()

static CXTPControlPopup *AFX_CDECL CreateControlPopup ( XTPControlType controlType )
static

Creates a CXTPControlPopup object with the specified type.

Parameters
controlType XTPControlType type of pop-up control. Can be any of the values listed in the Remarks section.

Pop-up type can be one of the following: xtpControlPopup: Pop-up type. xtpControlButtonPopup: Button pop-up. xtpControlSplitButtonPopup: Split button pop-up.

Returns
A pointer to a CXTPControlPopup object.

◆ DoCustomDragOver()

virtual BOOL DoCustomDragOver | ( | CXTPCommandBar * | pCommandBar,
 |  | CPoint | point,
 |  | DROPEFFECT & | dropEffect )
 protectedvirtual

The implementation may implement a custom drag over handling logic in this method.

Parameters
pCommandBar | Pointer to a CXTPCommandBar object.
point | Mouse position.
dropEffect | DROPEFFECT enumerator.
Returns
TRUE if custom implementation handles drag over, otherwise FALSE.

Reimplemented from CXTPControl.

◆ DoPropExchange()

void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Either reads this object from or writes this object to an archive.

Parameters
pPX A CXTPPropExchange object to serialize to or from.

Reimplemented from CXTPControlButton.

Reimplemented in CXTPRibbonControlTab.

◆ GetCaption()

virtual CString GetCaption ( ) const
virtual

Call this member to get the control's caption.

Returns
The caption of the control.

Reimplemented from CXTPControl.

Reimplemented in CXTPRibbonControlSystemButton.

◆ GetCommandBar()

AFX_INLINE CXTPCommandBar * GetCommandBar ( ) const
virtual

Call this member to get the child command bar.

Returns
A pointer to the child command bar.

Reimplemented from CXTPControl.

◆ GetPopuped()

AFX_INLINE BOOL GetPopuped ( ) const
virtual

Call this member to get the control's pop-up state.

Returns
TRUE if the control is a pop-up, otherwise FALSE.

Reimplemented from CXTPControl.

◆ OnClick()

void OnClick | ( | BOOL | bKeyboard = FALSE,
 |  | CPoint | pt = CPoint(0, 0) )
 protectedvirtual

This method is called when the user clicks the control.

Parameters
bKeyboard | TRUE if the control is selected using the keyboard.
pt | Mouse cursor position.

Reimplemented from CXTPControlButton.

◆ OnCustomizeDragOver()

void OnCustomizeDragOver | ( | CXTPControl * | pDataObject,
 |  | CPoint | point,
 |  | DROPEFFECT & | dropEffect )
 protectedvirtual

This method is called when the user moves the mouse over the control.

Parameters
pDataObject | Pointer to a CXTPControl object.
point | Mouse position.
dropEffect | DROPEFFECT enumerator.

Reimplemented from CXTPControl.

◆ OnLButtonDblClk()

virtual BOOL OnLButtonDblClk ( CPoint point )
protectedvirtual

This member is called when the user double-clicks the left mouse button.

Parameters
point Specifies the x- and y- coordinates of the cursor.
Returns
TRUE if successful, otherwise FALSE.

Reimplemented from CXTPControl.

Reimplemented in CXTPRibbonControlSystemButton.

◆ OnLButtonUp()

virtual void OnLButtonUp ( CPoint point )
protectedvirtual

This member is called when the user releases the left mouse button.

Parameters
point Specifies the x- and y- coordinates of the cursor.

Reimplemented from CXTPControlButton.

◆ OnMouseMove()

virtual void OnMouseMove ( CPoint point )
protectedvirtual

This member is called when the mouse cursor moves.

Parameters
point Specifies the x- and y- coordinates of the cursor.

Reimplemented from CXTPControl.

Reimplemented in CXTPControlComboBox.

◆ OnSetPopup()

virtual BOOL OnSetPopup ( BOOL bPopup )
protectedvirtual

This method is called to pop-up the control.

Parameters
bPopup TRUE to set pop-up.
Returns
TRUE if successful, otherwise FALSE.

Reimplemented from CXTPControl.

Reimplemented in CXTPControlComboBox, and CXTPControlSizeComboBox.

◆ OnSetSelected()

BOOL OnSetSelected ( int bSelected )
protectedvirtual

This method is called when the control becomes selected.

Parameters
bSelected TRUE if the control becomes selected.
Returns
TRUE if successful, otherwise FALSE.

Reimplemented from CXTPControl.

Reimplemented in CXTPRibbonControlTab.

◆ RestoreCommandBarList()

virtual void RestoreCommandBarList ( CXTPCommandBarList * pCommandBarList )
protectedvirtual

This method is called from LoadCommandBars to restore controls and its child command bars.

Parameters
pCommandBarList Command bars collection that contains all the command bars to be restored.

Reimplemented from CXTPControl.

◆ SetCommandBar() [1/2]

void SetCommandBar ( CMenu * pMenu )

Call this member to set the child command bar.

Parameters
pMenu The menu to be loaded as a child.

◆ SetCommandBar() [2/2]

void SetCommandBar ( CXTPCommandBar * pBar )

Call this member to set the child command bar.

Parameters
pBar The child command bar.
The documentation for this class was generated from the following file:
  • XTPControlPopup.h


Toolkit Pro: CXTPControlPopupColor Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPControlPopupColor Class Reference

CXTPControlPopupColor is a CXTPControlPopup derived class. More...

Inheritance diagram for CXTPControlPopupColor:
[legend]

Public Member Functions

CXTPControlPopupColor ()
Constructs a CXTPControlPopupColor object.
~CXTPControlPopupColor ()
Destroys a CXTPControlPopupColor object, handles cleanup and deallocation.
void | SetColor (COLORREF clr)
Call this member to set the picker color.
COLORREF | GetColor () const
Call this member to retrieve the control color.
- Public Member Functions inherited from CXTPControlPopup
CXTPControlPopup ()
Constructs a CXTPControlPopup object.
virtual | ~CXTPControlPopup ()
Destroys a CXTPControlPopup object, handles cleanup and deallocation.
void | SetCommandBar (CMenu *pMenu)
Call this member to set the child command bar.
void | SetCommandBar (CXTPCommandBar *pBar)
Call this member to set the child command bar.
CXTPCommandBar * | GetCommandBar () const
Call this member to get the child command bar.
BOOL | GetPopuped () const
Call this member to get the control's pop-up state.
virtual CString | GetCaption () const
Call this member to get the control's caption.
void | DoPropExchange (CXTPPropExchange *pPX)
Either reads this object from or writes this object to an archive.
virtual void | AdjustExcludeRect (CRect &rc, BOOL bVertical)
Updates rectangle to set the position where the child pop-up bar becomes visible.
virtual void | OnUnderlineActivate ()
This method is called when the user activates a control using its underline.
- Public Member Functions inherited from CXTPControlButton
CXTPControlButton ()
Constructs a CXTPControlButton object.
virtual | ~CXTPControlButton ()
Destroys a CXTPControlButton object, handles cleanup and deallocation.
void | SetStyleEx (XTPButtonStyle buttonStyle)
Call this member to set the style of the button containing vector icon.
XTPButtonStyle | GetStyleEx () const
Call this member to get the button's style containing vector icon.
- Public Member Functions inherited from CXTPControl
void | SetStyle (XTPButtonStyle buttonStyle)
Call this member to set the style of the control.
XTPButtonStyle | GetStyle () const
Call this member to get the control's style.
void | SetCaption (LPCTSTR lpszCaption)
Call this member to set the caption of the control.
void | SetCaption (UINT nIDCaption)
Call this member to set the caption of the control.
void | SetShortcutText (LPCTSTR lpszShortcutText)
Call this member to set the shortcut string to the control.
CString | GetShortcutText () const
Call this member to get the control's shortcut.
void | SetDescription (LPCTSTR lpszDescription)
Call this member to set the description of the control.
virtual CString | GetDescription () const
Call this member to get the control's description.
void | SetTooltip (LPCTSTR lpszTooltip)
Call this member to set the tooltip of the control.
virtual CString | GetTooltip () const
Call this member to get the control's tooltip.
void | SetKeyboardTip (LPCTSTR lpszKeyboardTip)
Call this member to set the keyboard tip to the control.
CString | GetKeyboardTip () const
Call this member to get the keyboard tip.
void | SetCustomShortcutText (LPCTSTR lpszCustomShortcutText)
Call this member to set the text displayed for the shortcut in a pop-up menu.
CString | GetCustomShortcutText () const
Call this member to get the control's text displayed for the shortcut in a pop-up menu.
void | SetParameter (LPCTSTR lpszParameter)
Call this member to set the parameter of the control.
CString | GetParameter () const
Call this member to get the control's parameter.
void | SetID (int nId)
Call this member to set the identifier of the control.
int | GetID () const
Call this member to get the control's identifier.
long | GetIndex () const
Call this member to get the index of the control.
void | SetIconId (int nId)
Call this member to set the control icon's identifier.
int | GetIconId () const
Call this member to get the icon's identifier.
void | SetHelpId (int nId)
Call this member to set the control help identifier.
int | GetHelpId () const
Call this member to get the help identifier.
virtual void | SetBeginGroup (BOOL bBeginGroup)
Call this member to begin a new group using a separator.
BOOL | GetBeginGroup () const
Call this member to determine if the control has a separator.
virtual void | SetEnabled (BOOL bEnabled)
Call this member to enable/disable the control.
BOOL | GetEnabled () const
Call this member to check if the control is enabled.
virtual void | OnEnabledChanged ()
This method is called when a control's enabled state is changed.
virtual void | SetChecked (BOOL bChecked)
Call this member to set the checked state of the control.
BOOL | GetChecked () const
Call this member to get the checked state of the control.
virtual int | GetSelected () const
Call this member to check if the control is selected.
void | SetOnQuickAccess (BOOL bOnQuicAccess=FALSE)
Call this member to set whether a control should be a part of the Quick Access panel.
BOOL | IsOnQuickAccess () const
Call this member to check if a control is a part of the Quick Access panel.
virtual void | SetFocused (BOOL bFocused)
Call this member to set the focused state of the control.
virtual BOOL | IsFocused () const
Call this member to check the focused state of the control.
void | SetPressed (BOOL bPressed)
Call this member to set the pressed state of the control.
virtual BOOL | GetPressed () const
Call this member to check the pressed state of the control.
virtual void | SetRect (CRect rcControl)
This member is called to set the bounding rectangle of the control.
CRect | GetRect () const
Call this member to get the bounding rectangle of the control.
CXTPCommandBar * | GetParent () const
Call this member to get the parent command bar.
virtual BOOL | IsVisible (DWORD dwSkipFlags=0) const
Call this member to determine if the control is visible.
virtual BOOL | IsCaptionVisible () const
Call this member to determine if the caption of the control is visible.
void | SetVisible (BOOL bVisible)
Call this member to set the visibility of the control.
CXTPControls * | GetControls () const
Call this member to get the parent controls collection.
XTPControlType | GetType () const
Call this member to get the control's type.
void | SetFlags (DWORD dwFlags)
Call this member to set the flags of the control.
DWORD | GetFlags () const
Call this member to retrieve control special flags.
void | SetTag (DWORD_PTR dwTag)
This method sets the 32-bit value associated with the control.
DWORD_PTR | GetTag () const
This method retrieves the application-supplied, 32-bit value associated with the control.
void | SetCloseSubMenuOnClick (BOOL bCloseOnClick)
Call this member function to enable/disable the closing of sub-menus when a control is clicked in the menu.
BOOL | GetCloseSubMenuOnClick () const
Call this member function to check if sub-menus will close as soon as a control is clicked.
void | SetExecuteOnPressInterval (int nExecuteOnPressInterval)
Call this method to set the delay (in milliseconds) between WM_COMMAND messages while a button is pressed by the user.
int | GetExecuteOnPressInterval () const
Call this method to get the delay (in milliseconds) between WM_COMMAND messages while a button is pressed by the user.
CXTPRibbonGroup * | GetRibbonGroup () const
Returns the ribbon group that the control belongs to.
virtual BOOL | IsTransparent () const
Determines if the control needs to draw its background.
void | SetHideWrap (BOOL bHide)
This method is called to hide the control.
virtual void | SetHideFlags (DWORD dwFlags)
This method is called to hide the control.
BOOL | SetHideFlag (XTPControlHideFlags dwFlag, BOOL bSet)
Call this member to set/remove hide flags.
DWORD | GetHideFlags () const
Call this method to retrieve hidden flags.
CRect | GetRowRect () const
Call this method to retrieve the position of the control's row.
BOOL | GetWrap () const
Call this method to check if the control is wrapped.
void | SetRowRect (CRect rcRow)
Call this method to set the row of the control.
void | SetWrap (BOOL bWrap)
Call this member to set the control to wrapped.
BOOL | GetExpanded () const
Call this member to check if the control is expanded.
BOOL | IsCursorOver () const
Call this member to determine if the mouse pointer is over the control.
virtual void | OnExecute ()
This method is called when the control is executed.
virtual CSize | GetSize (CDC *pDC)
This method is called to determine the size of the control.
virtual void | Draw (CDC *pDC)
This method is called to draw the control.
virtual void | OnCalcDynamicSize (DWORD dwMode)
This method is called before recalculating the parent command bar size to calculate the dimensions of the control.
void | DelayRedrawParent ()
Call this method to redraw the parent command bar.
void | DelayLayoutParent ()
Call this method to recalculate the parent command bar size.
void | SetCategory (LPCTSTR lpszCategory)
Call this method to set the category of the control.
CString | GetCategory () const
Call this method to retrieve the category of the control.
CXTPImageManager * | GetImageManager () const
Call this method to retrieve the image manager.
CXTPPaintManager * | GetPaintManager () const
Call this method to retrieve the paint manager.
virtual CXTPImageManagerIcon * | GetImage (int nWidth=16) const
Call this method to retrieve the image of the control.
void | AssignDocTemplate (UINT nIDResource)
Call this method to assign a document template to the control.
void | ExcludeDocTemplate (UINT nIDResource)
Call this method to exclude the document template from control.
BOOL | IsItemDefault () const
Call this method to check if a control is a default menu item.
void | SetItemDefault (BOOL bDefault)
Call this method to set a control to be a default menu item.
BOOL | IsTemporary () const
Call this method to determine if a control is temporary.
void | Reset ()
Call this member to reset the icon and caption of a control to its default settings before it was customized by the user.
void | SetPrompt (LPCTSTR lpszPrompt)
Call this member to load a string from a STRINGTABLE resource to set the tooltip and description of a control.
void | SetCustomIcon (HICON hIcon)
Call this member to set a custom icon to this control.
void | RedrawParent (BOOL bAnimate=TRUE)
This method is called to redraw the parent command bar.
LRESULT | NotifySite (UINT code)
This method is called to send message code to the parent site window.
LRESULT | NotifySite (UINT code, NMXTPCONTROL *pNM)
This method is called to send message code to the parent site window.
LRESULT | NotifySite (CWnd *pSite, UINT code, NMXTPCONTROL *pNM)
This method is called to send message code to the parent site window.
virtual void | SetAction (CXTPControlAction *pAction)
Call this method to manually assign an action for control.
CXTPControlAction * | GetAction () const
Call this method to retrieve an action associated with control.
virtual void | OnThemeChanged ()
This method is called when the paint manager theme is changed.
virtual void | SetWidth (int nWidth)
Call this member to set the width of the control.
virtual void | SetHeight (int nHeight)
Call this member to set the height of the control.
int | GetWidth () const
Call this member to get the width of the control.
int | GetHeight () const
Call this member to get the height of the control.
BOOL | HasDwmCompositedRect () const
This method is called to determine if control has a Vista DWM transparent area.
virtual CSize | GetButtonSize () const
Call this function to get the size of the command bar button.
virtual CSize | GetIconSize () const
Call this member function to get the size of a toolbar icon.
void | SetIconSize (CSize szIcon)
Call this member function to set the size of an icon for an individual control.
virtual BOOL | IsCustomizeMovable () const
This method is called to determine if control can be repositioned in customize mode.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

void | Copy (CXTPControl *pControl, BOOL bRecursive=FALSE)
This method is called to copy the control.
- Protected Member Functions inherited from CXTPControlPopup
BOOL | ContainsPopup (CXTPControlPopup *pControlPopup)
This method is called to check if pControlPopup contains in the control recursively.
void | ExpandCommandBar ()
Call this member to expand the parent pop-up bar.
BOOL | OnSetSelected (int bSelected)
This method is called when the control becomes selected.
void | OnClick (BOOL bKeyboard=FALSE, CPoint pt=CPoint(0, 0))
This method is called when the user clicks the control.
void | OnMouseHover ()
This method is called after the mouse hovers over the control.
virtual void | OnMouseMove (CPoint point)
This member is called when the mouse cursor moves.
virtual BOOL | OnSetPopup (BOOL bPopup)
This method is called to pop-up the control.
virtual void | OnLButtonUp (CPoint point)
This member is called when the user releases the left mouse button.
virtual BOOL | OnLButtonDblClk (CPoint point)
This member is called when the user double-clicks the left mouse button.
void | OnCustomizeDragOver (CXTPControl *pDataObject, CPoint point, DROPEFFECT &dropEffect)
This method is called when the user moves the mouse over the control.
virtual BOOL | DoCustomDragOver (CXTPCommandBar *pCommandBar, CPoint point, DROPEFFECT &dropEffect)
The implementation may implement a custom drag over handling logic in this method.
virtual BOOL | Compare (CXTPControl *pOther)
Call this member to compare controls.
virtual void | UpdateShadow ()
Call this member to update the shadow of the control.
virtual void | RestoreCommandBarList (CXTPCommandBarList *pCommandBarList)
This method is called from LoadCommandBars to restore controls and its child command bars.
- Protected Member Functions inherited from CXTPControlButton
- Protected Member Functions inherited from CXTPControl
CXTPControl ()
Constructs a CXTPControl object.
virtual | ~CXTPControl ()
Destroys a CXTPControl object, handles cleanup and deallocation.
virtual BOOL | IsFocusable () const
This method is called to check if the control can accept focus.
void | SetIndex (int nIndex)
This method is called to assign the order of the control in the controls list.
void | SetExpanded (BOOL bExpanded)
This method is called to set the control's expanded state.
virtual BOOL | OnHookKeyDown (UINT nChar, LPARAM lParam)
This method is called when a non-system key is pressed.
virtual BOOL | OnHookMouseWheel (UINT nFlags, short zDelta, CPoint point)
This method is called when the user rotates the mouse wheel.
virtual void | SetParent (CXTPCommandBar *pParent)
This method is called to assign a parent command bar object.
void | ScreenToClient (CPoint *point)
The ScreenToClient function converts the screen coordinates of a specified point on the screen.
void | ClickToolBarButton (CRect rcActiveRect=CRect(0, 0, 0, 0))
This helper method is called when the user clicks the toolbar's button.
virtual void | OnLButtonDown (CPoint point)
This member is called when the user presses the left mouse button down.
virtual BOOL | OnRButtonDown (CPoint point)
This member is called when the user press the right mouse button.
virtual BOOL | OnRButtonUp (CPoint point)
This member is called when the user releases the right mouse button.
BOOL | IsCustomizeMode () const
Call this method to determine if command bars is in customize mode.
virtual void | CustomizeStartDrag (CPoint point)
This member is called when the user starts to drag the control in customize mode.
virtual BOOL | CustomizeStartResize (CPoint point)
This method is called when user starts to resize control in customize mode.
virtual BOOL | IsCustomizeResizeAllow () const
This member checks if the user can resize the control.
virtual int | GetCustomizeMinWidth () const
Retrieves the available minimum width of control.
virtual int | GetCustomizeMinHeight () const
Retrieves available minimum height of the control.
void | OnCustomizeMouseMove (CPoint point)
This member is called when the mouse cursor moves in customized mode.
virtual void | OnIdleUpdate ()
This virtual method is called in idle-time processing.
virtual void | OnRemoved ()
This method is called when a control is removed from the parent controls collection.
virtual INT_PTR | OnToolHitTest (CPoint point, TOOLINFO *pTI) const
The framework calls this member function to determine whether a point is in the bounding rectangle of the specified tool.
virtual void | GenerateCommandBarList (DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam)
This method is called from SaveCommandBars to save all child command bars.
virtual void | OnActionChanged (int nProperty)
This method is called when an action property is changed.
virtual void | OnActionChanging (int nProperty)
This method is called when an action property is about to be changed.
virtual void | OnCaptionChanged ()
This method is called when the control's caption is changed.
BOOL | IsLayoutRTL () const
Determines if right-to-left (RTL) mode is set.
BOOL | IsLayoutChanged ()
Call this member to determine if the layout has changed (RTL to LTR or LTR to RLT).

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlPopup
static CXTPControlPopup *AFX_CDECL | CreateControlPopup (XTPControlType controlType)
Creates a CXTPControlPopup object with the specified type.
- Static Public Member Functions inherited from CXTPControl
static CXTPControl *AFX_CDECL | FromUI (CCmdUI *pCmdUI)
Call this member to retrieve CXTPControl from a CCmdUI structure.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Attributes inherited from CXTPControlPopup
BOOL | m_bPopup
TRUE if pop-up'ed.
CXTPCommandBar * | m_pCommandBar
Child pop-up bar.
DWORD | m_dwCommandBarID
Child pop-up ID.
BOOL | m_bShowShadow
TRUE to show shadow.
- Protected Attributes inherited from CXTPControlButton
XTPButtonStyle | m_buttonStyleEx
User-defined style of button containing vector icon.
- Protected Attributes inherited from CXTPControl
DWORD_PTR | m_nTag
Control tag.
int | m_nIndex
Index of the control.
int | m_nId
Identifier of the control.
int | m_nIconId
Identifier of the control's image.
int | m_nHelpId
Help identifier.
int | m_nCustomIconId
Identifier of the control's custom image.
BOOL | m_bWrap
TRUE if the control is wrapped.
BOOL | m_bBeginGroup
TRUE if the control starts new group.
BOOL | m_bEnabled
TRUE if the control is enabled.
BOOL | m_bChecked
TRUE if the control is checked.
BOOL | m_bSelected
TRUE if the control is selected.
BOOL | m_bPressed
TRUE if the control is pushed.
BOOL | m_bTemporary
TRUE if the control is temporary.
BOOL | m_bOnQuickAccess
TRUE if the control is a part of Quick Access panel.
CRect | m_rcRow
Bounding rectangle of the control's row.
CRect | m_rcControl
Bounding rectangle of the control.
DWORD | m_dwHideFlags
Hidden flags.
DWORD | m_dwFlags
Flags of the control.
CString | m_strCaption
Caption of the control.
CString | m_strCustomCaption
User-defined caption.
CString | m_strShortcutText
Shortcut text.
CString | m_strShortcutTextAuto
Shortcut text.
CString | m_strTooltipText
Tooltip text.
CString | m_strDescriptionText
Description text.
CString | m_strParameter
Parameter text.
CString | m_strKeyboardTip
Keyboard tip.
CXTPControls * | m_pControls
Parent control collection.
XTPControlType | m_controlType
Type of the control.
CXTPCommandBar * | m_pParent
The Parent command bar.
BOOL | m_bExpanded
TRUE if the control is expanded.
CString | m_strCategory
Category of the control.
BOOL | m_bDefaultItem
TRUE if the item is default pop-up item.
CDocTemplateMap | m_mapDocTemplatesAssigned
Assigned templates.
CDocTemplateMap | m_mapDocTemplatesExcluded
Excluded templates.
XTPButtonStyle | m_buttonStyle
Button Style.
XTPButtonStyle | m_buttonCustomStyle
User-defined style of button.
XTPButtonStyle | m_buttonRibbonStyle
User-defined style of button.
BOOL | m_bCloseSubMenuOnClick
TRUE is sub-menus are closed as soon as a control is clicked.
CXTPRibbonGroup * | m_pRibbonGroup
Ribbon group of control.
CXTPControlAction * | m_pAction
Action of the control.
int | m_nWidth
Width of the control.
int | m_nHeight
Height of the control.
int | m_nExecuteOnPressInterval
Delay between each message when control is pressed.
CSize | m_szIcon
The size of the icon used for the control.
BOOL | m_bLayoutRTL
Indicate does last layout is RTL.

Detailed Description

CXTPControlPopupColor is a CXTPControlPopup derived class.

It represents a color picker control.

Member Function Documentation

◆ Copy()

void Copy | ( | CXTPControl * | pControl,
 |  | BOOL | bRecursive = FALSE )
 protectedvirtual

This method is called to copy the control.

Parameters
pControl | Pointer to a source CXTPControl object.
bRecursive | TRUE to copy recursively.

Reimplemented from CXTPControlPopup.

◆ GetColor()

COLORREF GetColor ( ) const

Call this member to retrieve the control color.

Returns
Color of the color picker.

◆ SetColor()

void SetColor ( COLORREF clr )

Call this member to set the picker color.

Parameters
clr Color to set.
The documentation for this class was generated from the following file:
  • XTPControlPopupColor.h


Toolkit Pro: CXTPControlProgress Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPControlProgress Class Reference

CXTPControlProgress is a CXTPControl derived class. More...

Inheritance diagram for CXTPControlProgress:
[legend]

Public Member Functions

CXTPControlProgress ()
Constructs a CXTPControlProgress object.
- Public Member Functions inherited from CXTPControl
void | SetStyle (XTPButtonStyle buttonStyle)
Call this member to set the style of the control.
XTPButtonStyle | GetStyle () const
Call this member to get the control's style.
void | SetCaption (LPCTSTR lpszCaption)
Call this member to set the caption of the control.
void | SetCaption (UINT nIDCaption)
Call this member to set the caption of the control.
virtual CString | GetCaption () const
Call this member to get the control's caption.
void | SetShortcutText (LPCTSTR lpszShortcutText)
Call this member to set the shortcut string to the control.
CString | GetShortcutText () const
Call this member to get the control's shortcut.
void | SetDescription (LPCTSTR lpszDescription)
Call this member to set the description of the control.
virtual CString | GetDescription () const
Call this member to get the control's description.
void | SetTooltip (LPCTSTR lpszTooltip)
Call this member to set the tooltip of the control.
virtual CString | GetTooltip () const
Call this member to get the control's tooltip.
void | SetKeyboardTip (LPCTSTR lpszKeyboardTip)
Call this member to set the keyboard tip to the control.
CString | GetKeyboardTip () const
Call this member to get the keyboard tip.
void | SetCustomShortcutText (LPCTSTR lpszCustomShortcutText)
Call this member to set the text displayed for the shortcut in a pop-up menu.
CString | GetCustomShortcutText () const
Call this member to get the control's text displayed for the shortcut in a pop-up menu.
void | SetParameter (LPCTSTR lpszParameter)
Call this member to set the parameter of the control.
CString | GetParameter () const
Call this member to get the control's parameter.
void | SetID (int nId)
Call this member to set the identifier of the control.
int | GetID () const
Call this member to get the control's identifier.
long | GetIndex () const
Call this member to get the index of the control.
void | SetIconId (int nId)
Call this member to set the control icon's identifier.
int | GetIconId () const
Call this member to get the icon's identifier.
void | SetHelpId (int nId)
Call this member to set the control help identifier.
int | GetHelpId () const
Call this member to get the help identifier.
virtual void | SetBeginGroup (BOOL bBeginGroup)
Call this member to begin a new group using a separator.
BOOL | GetBeginGroup () const
Call this member to determine if the control has a separator.
virtual void | SetEnabled (BOOL bEnabled)
Call this member to enable/disable the control.
BOOL | GetEnabled () const
Call this member to check if the control is enabled.
virtual void | OnEnabledChanged ()
This method is called when a control's enabled state is changed.
virtual void | SetChecked (BOOL bChecked)
Call this member to set the checked state of the control.
BOOL | GetChecked () const
Call this member to get the checked state of the control.
virtual int | GetSelected () const
Call this member to check if the control is selected.
void | SetOnQuickAccess (BOOL bOnQuicAccess=FALSE)
Call this member to set whether a control should be a part of the Quick Access panel.
BOOL | IsOnQuickAccess () const
Call this member to check if a control is a part of the Quick Access panel.
virtual void | SetFocused (BOOL bFocused)
Call this member to set the focused state of the control.
virtual BOOL | IsFocused () const
Call this member to check the focused state of the control.
void | SetPressed (BOOL bPressed)
Call this member to set the pressed state of the control.
virtual BOOL | GetPressed () const
Call this member to check the pressed state of the control.
virtual void | SetRect (CRect rcControl)
This member is called to set the bounding rectangle of the control.
CRect | GetRect () const
Call this member to get the bounding rectangle of the control.
CXTPCommandBar * | GetParent () const
Call this member to get the parent command bar.
virtual BOOL | IsVisible (DWORD dwSkipFlags=0) const
Call this member to determine if the control is visible.
virtual BOOL | IsCaptionVisible () const
Call this member to determine if the caption of the control is visible.
void | SetVisible (BOOL bVisible)
Call this member to set the visibility of the control.
CXTPControls * | GetControls () const
Call this member to get the parent controls collection.
XTPControlType | GetType () const
Call this member to get the control's type.
void | SetFlags (DWORD dwFlags)
Call this member to set the flags of the control.
DWORD | GetFlags () const
Call this member to retrieve control special flags.
void | SetTag (DWORD_PTR dwTag)
This method sets the 32-bit value associated with the control.
DWORD_PTR | GetTag () const
This method retrieves the application-supplied, 32-bit value associated with the control.
virtual BOOL | Compare (CXTPControl *pOther)
Call this member to compare controls.
virtual CXTPCommandBar * | GetCommandBar () const
Call this member to get the child command bar.
void | SetCloseSubMenuOnClick (BOOL bCloseOnClick)
Call this member function to enable/disable the closing of sub-menus when a control is clicked in the menu.
BOOL | GetCloseSubMenuOnClick () const
Call this member function to check if sub-menus will close as soon as a control is clicked.
void | SetExecuteOnPressInterval (int nExecuteOnPressInterval)
Call this method to set the delay (in milliseconds) between WM_COMMAND messages while a button is pressed by the user.
int | GetExecuteOnPressInterval () const
Call this method to get the delay (in milliseconds) between WM_COMMAND messages while a button is pressed by the user.
CXTPRibbonGroup * | GetRibbonGroup () const
Returns the ribbon group that the control belongs to.
virtual BOOL | IsTransparent () const
Determines if the control needs to draw its background.
void | SetHideWrap (BOOL bHide)
This method is called to hide the control.
virtual void | SetHideFlags (DWORD dwFlags)
This method is called to hide the control.
BOOL | SetHideFlag (XTPControlHideFlags dwFlag, BOOL bSet)
Call this member to set/remove hide flags.
DWORD | GetHideFlags () const
Call this method to retrieve hidden flags.
CRect | GetRowRect () const
Call this method to retrieve the position of the control's row.
BOOL | GetWrap () const
Call this method to check if the control is wrapped.
void | SetRowRect (CRect rcRow)
Call this method to set the row of the control.
void | SetWrap (BOOL bWrap)
Call this member to set the control to wrapped.
BOOL | GetExpanded () const
Call this member to check if the control is expanded.
BOOL | IsCursorOver () const
Call this member to determine if the mouse pointer is over the control.
virtual void | OnExecute ()
This method is called when the control is executed.
virtual void | OnCalcDynamicSize (DWORD dwMode)
This method is called before recalculating the parent command bar size to calculate the dimensions of the control.
void | DelayRedrawParent ()
Call this method to redraw the parent command bar.
void | DelayLayoutParent ()
Call this method to recalculate the parent command bar size.
void | SetCategory (LPCTSTR lpszCategory)
Call this method to set the category of the control.
CString | GetCategory () const
Call this method to retrieve the category of the control.
CXTPImageManager * | GetImageManager () const
Call this method to retrieve the image manager.
CXTPPaintManager * | GetPaintManager () const
Call this method to retrieve the paint manager.
virtual CXTPImageManagerIcon * | GetImage (int nWidth=16) const
Call this method to retrieve the image of the control.
void | AssignDocTemplate (UINT nIDResource)
Call this method to assign a document template to the control.
void | ExcludeDocTemplate (UINT nIDResource)
Call this method to exclude the document template from control.
BOOL | IsItemDefault () const
Call this method to check if a control is a default menu item.
void | SetItemDefault (BOOL bDefault)
Call this method to set a control to be a default menu item.
BOOL | IsTemporary () const
Call this method to determine if a control is temporary.
void | Reset ()
Call this member to reset the icon and caption of a control to its default settings before it was customized by the user.
void | SetPrompt (LPCTSTR lpszPrompt)
Call this member to load a string from a STRINGTABLE resource to set the tooltip and description of a control.
void | SetCustomIcon (HICON hIcon)
Call this member to set a custom icon to this control.
virtual void | OnUnderlineActivate ()
This method is called when the user activates the control using its underline.
virtual BOOL | GetPopuped () const
Call this member to get the control's pop-up state.
void | RedrawParent (BOOL bAnimate=TRUE)
This method is called to redraw the parent command bar.
LRESULT | NotifySite (UINT code)
This method is called to send message code to the parent site window.
LRESULT | NotifySite (UINT code, NMXTPCONTROL *pNM)
This method is called to send message code to the parent site window.
LRESULT | NotifySite (CWnd *pSite, UINT code, NMXTPCONTROL *pNM)
This method is called to send message code to the parent site window.
virtual void | SetAction (CXTPControlAction *pAction)
Call this method to manually assign an action for control.
CXTPControlAction * | GetAction () const
Call this method to retrieve an action associated with control.
virtual void | OnThemeChanged ()
This method is called when the paint manager theme is changed.
virtual void | SetWidth (int nWidth)
Call this member to set the width of the control.
virtual void | SetHeight (int nHeight)
Call this member to set the height of the control.
int | GetWidth () const
Call this member to get the width of the control.
int | GetHeight () const
Call this member to get the height of the control.
BOOL | HasDwmCompositedRect () const
This method is called to determine if control has a Vista DWM transparent area.
virtual CSize | GetButtonSize () const
Call this function to get the size of the command bar button.
virtual CSize | GetIconSize () const
Call this member function to get the size of a toolbar icon.
void | SetIconSize (CSize szIcon)
Call this member function to set the size of an icon for an individual control.
virtual BOOL | IsCustomizeMovable () const
This method is called to determine if control can be repositioned in customize mode.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.
- Public Member Functions inherited from CXTPProgressBase
CXTPProgressBase ()
Constructs a CXTPProgressBase object.
virtual | ~CXTPProgressBase ()
Destroys a CXTPProgressBase object, handles cleanup and deallocation.
void | SetRange (int nLower, int nUpper)
Sets the upper and lower limits of the progress bar control's range.
void | GetRange (int &nLower, int &nUpper) const
Gets the upper and lower limits of the progress bar control's range.
int | GetPos () const
Gets the current position of the progress bar, whose return value is always between the values for the Max and Min properties, inclusive.
void | SetPos (int nPos)
Sets the current position of the progress bar, whose return value is always between the values for the Max and Min properties, inclusive.

Protected Member Functions

virtual CSize | GetSize (CDC *pDC)
This method is called to determine the size of the control.
virtual void | Draw (CDC *pDC)
This method is called to draw the control.
virtual void | RedrawProgress ()
Call this member to redraw the progress bar.
virtual CXTPProgressPaintManager * | GetProgressPaintManager () const
Call this member to retrieve the paint manager of the progress bar.
virtual CRect | GetProgressRect ()
Call this member to get the bounding rectangle of the control.
virtual void | OnClick (BOOL bKeyboard=FALSE, CPoint pt=CPoint(0, 0))
This method is called when the user clicks the control.
void | Copy (CXTPControl *pControl, BOOL bRecursive=FALSE)
This method makes a copy of the progress bar.
void | DoPropExchange (CXTPPropExchange *pPX)
Either reads this object from or writes this object to an archive.
- Protected Member Functions inherited from CXTPControl
CXTPControl ()
Constructs a CXTPControl object.
virtual | ~CXTPControl ()
Destroys a CXTPControl object, handles cleanup and deallocation.
virtual BOOL | IsFocusable () const
This method is called to check if the control can accept focus.
void | SetIndex (int nIndex)
This method is called to assign the order of the control in the controls list.
void | SetExpanded (BOOL bExpanded)
This method is called to set the control's expanded state.
virtual BOOL | OnHookKeyDown (UINT nChar, LPARAM lParam)
This method is called when a non-system key is pressed.
virtual BOOL | OnHookMouseWheel (UINT nFlags, short zDelta, CPoint point)
This method is called when the user rotates the mouse wheel.
virtual void | SetParent (CXTPCommandBar *pParent)
This method is called to assign a parent command bar object.
void | ScreenToClient (CPoint *point)
The ScreenToClient function converts the screen coordinates of a specified point on the screen.
void | ClickToolBarButton (CRect rcActiveRect=CRect(0, 0, 0, 0))
This helper method is called when the user clicks the toolbar's button.
virtual BOOL | OnSetPopup (BOOL bPopup)
This method is called to pop-up the control.
virtual void | OnLButtonUp (CPoint point)
This member is called when the user releases the left mouse button.
virtual void | OnLButtonDown (CPoint point)
This member is called when the user presses the left mouse button down.
virtual BOOL | OnRButtonDown (CPoint point)
This member is called when the user press the right mouse button.
virtual BOOL | OnRButtonUp (CPoint point)
This member is called when the user releases the right mouse button.
virtual BOOL | OnLButtonDblClk (CPoint point)
This member is called when the user double-clicks the left mouse button.
virtual void | OnMouseMove (CPoint point)
This member is called when the mouse cursor moves.
virtual void | OnMouseHover ()
Called after the mouse hovers over the control.
virtual BOOL | OnSetSelected (int bSelected)
This method is called when the control becomes selected.
BOOL | IsCustomizeMode () const
Call this method to determine if command bars is in customize mode.
virtual void | CustomizeStartDrag (CPoint point)
This member is called when the user starts to drag the control in customize mode.
virtual BOOL | CustomizeStartResize (CPoint point)
This method is called when user starts to resize control in customize mode.
virtual void | OnCustomizeDragOver (CXTPControl *pDataObject, CPoint point, DROPEFFECT &dropEffect)
This member is called when the user moves the mouse over the control.
virtual BOOL | DoCustomDragOver (CXTPCommandBar *pCommandBar, CPoint point, DROPEFFECT &dropEffect)
The implementation may implement a custom drag over handling logic in this method.
virtual BOOL | IsCustomizeResizeAllow () const
This member checks if the user can resize the control.
virtual int | GetCustomizeMinWidth () const
Retrieves the available minimum width of control.
virtual int | GetCustomizeMinHeight () const
Retrieves available minimum height of the control.
void | OnCustomizeMouseMove (CPoint point)
This member is called when the mouse cursor moves in customized mode.
virtual void | OnIdleUpdate ()
This virtual method is called in idle-time processing.
virtual void | OnRemoved ()
This method is called when a control is removed from the parent controls collection.
virtual INT_PTR | OnToolHitTest (CPoint point, TOOLINFO *pTI) const
The framework calls this member function to determine whether a point is in the bounding rectangle of the specified tool.
virtual void | RestoreCommandBarList (CXTPCommandBarList *pCommandBarList)
This method is called from LoadCommandBars to restore controls and its child command bars.
virtual void | GenerateCommandBarList (DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam)
This method is called from SaveCommandBars to save all child command bars.
virtual void | OnActionChanged (int nProperty)
This method is called when an action property is changed.
virtual void | OnActionChanging (int nProperty)
This method is called when an action property is about to be changed.
virtual void | OnCaptionChanged ()
This method is called when the control's caption is changed.
BOOL | IsLayoutRTL () const
Determines if right-to-left (RTL) mode is set.
BOOL | IsLayoutChanged ()
Call this member to determine if the layout has changed (RTL to LTR or LTR to RLT).
- Protected Member Functions inherited from CXTPProgressBase

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControl
static CXTPControl *AFX_CDECL | FromUI (CCmdUI *pCmdUI)
Call this member to retrieve CXTPControl from a CCmdUI structure.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Attributes inherited from CXTPControl
DWORD_PTR | m_nTag
Control tag.
int | m_nIndex
Index of the control.
int | m_nId
Identifier of the control.
int | m_nIconId
Identifier of the control's image.
int | m_nHelpId
Help identifier.
int | m_nCustomIconId
Identifier of the control's custom image.
BOOL | m_bWrap
TRUE if the control is wrapped.
BOOL | m_bBeginGroup
TRUE if the control starts new group.
BOOL | m_bEnabled
TRUE if the control is enabled.
BOOL | m_bChecked
TRUE if the control is checked.
BOOL | m_bSelected
TRUE if the control is selected.
BOOL | m_bPressed
TRUE if the control is pushed.
BOOL | m_bTemporary
TRUE if the control is temporary.
BOOL | m_bOnQuickAccess
TRUE if the control is a part of Quick Access panel.
CRect | m_rcRow
Bounding rectangle of the control's row.
CRect | m_rcControl
Bounding rectangle of the control.
DWORD | m_dwHideFlags
Hidden flags.
DWORD | m_dwFlags
Flags of the control.
CString | m_strCaption
Caption of the control.
CString | m_strCustomCaption
User-defined caption.
CString | m_strShortcutText
Shortcut text.
CString | m_strShortcutTextAuto
Shortcut text.
CString | m_strTooltipText
Tooltip text.
CString | m_strDescriptionText
Description text.
CString | m_strParameter
Parameter text.
CString | m_strKeyboardTip
Keyboard tip.
CXTPControls * | m_pControls
Parent control collection.
XTPControlType | m_controlType
Type of the control.
CXTPCommandBar * | m_pParent
The Parent command bar.
BOOL | m_bExpanded
TRUE if the control is expanded.
CString | m_strCategory
Category of the control.
BOOL | m_bDefaultItem
TRUE if the item is default pop-up item.
CDocTemplateMap | m_mapDocTemplatesAssigned
Assigned templates.
CDocTemplateMap | m_mapDocTemplatesExcluded
Excluded templates.
XTPButtonStyle | m_buttonStyle
Button Style.
XTPButtonStyle | m_buttonCustomStyle
User-defined style of button.
XTPButtonStyle | m_buttonRibbonStyle
User-defined style of button.
BOOL | m_bCloseSubMenuOnClick
TRUE is sub-menus are closed as soon as a control is clicked.
CXTPRibbonGroup * | m_pRibbonGroup
Ribbon group of control.
CXTPControlAction * | m_pAction
Action of the control.
int | m_nWidth
Width of the control.
int | m_nHeight
Height of the control.
int | m_nExecuteOnPressInterval
Delay between each message when control is pressed.
CSize | m_szIcon
The size of the icon used for the control.
BOOL | m_bLayoutRTL
Indicate does last layout is RTL.
- Protected Attributes inherited from CXTPProgressBase
int | m_nMin
Minimum.
int | m_nMax
Maximum.
int | m_nPos
Current position.

Detailed Description

CXTPControlProgress is a CXTPControl derived class.

It represents a progress control.

Member Function Documentation

◆ Copy()

void Copy | ( | CXTPControl * | pControl,
 |  | BOOL | bRecursive = FALSE )
 protectedvirtual

This method makes a copy of the progress bar.

Parameters
pControl | Control to be copied.
bRecursive | TRUE to copy recursively.

Reimplemented from CXTPControl.

◆ DoPropExchange()

void DoPropExchange ( CXTPPropExchange * pPX )
protectedvirtual

Either reads this object from or writes this object to an archive.

Parameters
pPX A CXTPPropExchange object to serialize to or from.

Reimplemented from CXTPControl.

◆ Draw()

virtual void Draw ( CDC * pDC )
protectedvirtual

This method is called to draw the control.

Parameters
pDC Pointer to a valid device context.

Reimplemented from CXTPControl.

◆ GetProgressPaintManager()

virtual CXTPProgressPaintManager * GetProgressPaintManager ( ) const
protectedvirtual

Call this member to retrieve the paint manager of the progress bar.

Returns
A pointer to a CXTPProgressPaintManager object.

Implements CXTPProgressBase.

◆ GetProgressRect()

virtual CRect GetProgressRect ( )
protectedvirtual

Call this member to get the bounding rectangle of the control.

Returns
The bounding rectangle of the control.

Implements CXTPProgressBase.

◆ GetSize()

virtual CSize GetSize ( CDC * pDC )
protectedvirtual

This method is called to determine the size of the control.

Parameters
pDC Pointer to a valid device context.
Returns
A CSize object containing the size of the control.

Reimplemented from CXTPControl.

◆ OnClick()

virtual void OnClick | ( | BOOL | bKeyboard = FALSE,
 |  | CPoint | pt = CPoint(0, 0) )
 protectedvirtual

This method is called when the user clicks the control.

Parameters
bKeyboard | TRUE if the control is selected using the keyboard.
pt | Mouse cursor position.

Reimplemented from CXTPControl.

The documentation for this class was generated from the following file:
  • XTPControlProgress.h


Toolkit Pro: CXTPControlRadioButton Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPControlRadioButton Class Reference

CXTPControlRadioButton is a CXTPControlButton derived class. More...

Inheritance diagram for CXTPControlRadioButton:
[legend]

Public Member Functions

CXTPControlRadioButton ()
Constructs a CXTPControlRadioButton object.
- Public Member Functions inherited from CXTPControlButton
CXTPControlButton ()
Constructs a CXTPControlButton object.
virtual | ~CXTPControlButton ()
Destroys a CXTPControlButton object, handles cleanup and deallocation.
void | SetStyleEx (XTPButtonStyle buttonStyle)
Call this member to set the style of the button containing vector icon.
XTPButtonStyle | GetStyleEx () const
Call this member to get the button's style containing vector icon.
void | DoPropExchange (CXTPPropExchange *pPX)
Either reads this object from or writes this object to an archive.
- Public Member Functions inherited from CXTPControl
void | SetStyle (XTPButtonStyle buttonStyle)
Call this member to set the style of the control.
XTPButtonStyle | GetStyle () const
Call this member to get the control's style.
void | SetCaption (LPCTSTR lpszCaption)
Call this member to set the caption of the control.
void | SetCaption (UINT nIDCaption)
Call this member to set the caption of the control.
virtual CString | GetCaption () const
Call this member to get the control's caption.
void | SetShortcutText (LPCTSTR lpszShortcutText)
Call this member to set the shortcut string to the control.
CString | GetShortcutText () const
Call this member to get the control's shortcut.
void | SetDescription (LPCTSTR lpszDescription)
Call this member to set the description of the control.
virtual CString | GetDescription () const
Call this member to get the control's description.
void | SetTooltip (LPCTSTR lpszTooltip)
Call this member to set the tooltip of the control.
virtual CString | GetTooltip () const
Call this member to get the control's tooltip.
void | SetKeyboardTip (LPCTSTR lpszKeyboardTip)
Call this member to set the keyboard tip to the control.
CString | GetKeyboardTip () const
Call this member to get the keyboard tip.
void | SetCustomShortcutText (LPCTSTR lpszCustomShortcutText)
Call this member to set the text displayed for the shortcut in a pop-up menu.
CString | GetCustomShortcutText () const
Call this member to get the control's text displayed for the shortcut in a pop-up menu.
void | SetParameter (LPCTSTR lpszParameter)
Call this member to set the parameter of the control.
CString | GetParameter () const
Call this member to get the control's parameter.
void | SetID (int nId)
Call this member to set the identifier of the control.
int | GetID () const
Call this member to get the control's identifier.
long | GetIndex () const
Call this member to get the index of the control.
void | SetIconId (int nId)
Call this member to set the control icon's identifier.
int | GetIconId () const
Call this member to get the icon's identifier.
void | SetHelpId (int nId)
Call this member to set the control help identifier.
int | GetHelpId () const
Call this member to get the help identifier.
virtual void | SetBeginGroup (BOOL bBeginGroup)
Call this member to begin a new group using a separator.
BOOL | GetBeginGroup () const
Call this member to determine if the control has a separator.
virtual void | SetEnabled (BOOL bEnabled)
Call this member to enable/disable the control.
BOOL | GetEnabled () const
Call this member to check if the control is enabled.
virtual void | OnEnabledChanged ()
This method is called when a control's enabled state is changed.
virtual void | SetChecked (BOOL bChecked)
Call this member to set the checked state of the control.
BOOL | GetChecked () const
Call this member to get the checked state of the control.
virtual int | GetSelected () const
Call this member to check if the control is selected.
void | SetOnQuickAccess (BOOL bOnQuicAccess=FALSE)
Call this member to set whether a control should be a part of the Quick Access panel.
BOOL | IsOnQuickAccess () const
Call this member to check if a control is a part of the Quick Access panel.
virtual void | SetFocused (BOOL bFocused)
Call this member to set the focused state of the control.
void | SetPressed (BOOL bPressed)
Call this member to set the pressed state of the control.
virtual BOOL | GetPressed () const
Call this member to check the pressed state of the control.
virtual void | SetRect (CRect rcControl)
This member is called to set the bounding rectangle of the control.
CRect | GetRect () const
Call this member to get the bounding rectangle of the control.
CXTPCommandBar * | GetParent () const
Call this member to get the parent command bar.
virtual BOOL | IsVisible (DWORD dwSkipFlags=0) const
Call this member to determine if the control is visible.
virtual BOOL | IsCaptionVisible () const
Call this member to determine if the caption of the control is visible.
void | SetVisible (BOOL bVisible)
Call this member to set the visibility of the control.
CXTPControls * | GetControls () const
Call this member to get the parent controls collection.
XTPControlType | GetType () const
Call this member to get the control's type.
void | SetFlags (DWORD dwFlags)
Call this member to set the flags of the control.
DWORD | GetFlags () const
Call this member to retrieve control special flags.
void | SetTag (DWORD_PTR dwTag)
This method sets the 32-bit value associated with the control.
DWORD_PTR | GetTag () const
This method retrieves the application-supplied, 32-bit value associated with the control.
virtual BOOL | Compare (CXTPControl *pOther)
Call this member to compare controls.
virtual CXTPCommandBar * | GetCommandBar () const
Call this member to get the child command bar.
void | SetCloseSubMenuOnClick (BOOL bCloseOnClick)
Call this member function to enable/disable the closing of sub-menus when a control is clicked in the menu.
BOOL | GetCloseSubMenuOnClick () const
Call this member function to check if sub-menus will close as soon as a control is clicked.
void | SetExecuteOnPressInterval (int nExecuteOnPressInterval)
Call this method to set the delay (in milliseconds) between WM_COMMAND messages while a button is pressed by the user.
int | GetExecuteOnPressInterval () const
Call this method to get the delay (in milliseconds) between WM_COMMAND messages while a button is pressed by the user.
CXTPRibbonGroup * | GetRibbonGroup () const
Returns the ribbon group that the control belongs to.
virtual BOOL | IsTransparent () const
Determines if the control needs to draw its background.
void | SetHideWrap (BOOL bHide)
This method is called to hide the control.
virtual void | SetHideFlags (DWORD dwFlags)
This method is called to hide the control.
BOOL | SetHideFlag (XTPControlHideFlags dwFlag, BOOL bSet)
Call this member to set/remove hide flags.
DWORD | GetHideFlags () const
Call this method to retrieve hidden flags.
CRect | GetRowRect () const
Call this method to retrieve the position of the control's row.
BOOL | GetWrap () const
Call this method to check if the control is wrapped.
void | SetRowRect (CRect rcRow)
Call this method to set the row of the control.
void | SetWrap (BOOL bWrap)
Call this member to set the control to wrapped.
BOOL | GetExpanded () const
Call this member to check if the control is expanded.
BOOL | IsCursorOver () const
Call this member to determine if the mouse pointer is over the control.
virtual void | OnExecute ()
This method is called when the control is executed.
virtual CSize | GetSize (CDC *pDC)
This method is called to determine the size of the control.
virtual void | Draw (CDC *pDC)
This method is called to draw the control.
virtual void | OnCalcDynamicSize (DWORD dwMode)
This method is called before recalculating the parent command bar size to calculate the dimensions of the control.
void | DelayRedrawParent ()
Call this method to redraw the parent command bar.
void | DelayLayoutParent ()
Call this method to recalculate the parent command bar size.
void | SetCategory (LPCTSTR lpszCategory)
Call this method to set the category of the control.
CString | GetCategory () const
Call this method to retrieve the category of the control.
CXTPImageManager * | GetImageManager () const
Call this method to retrieve the image manager.
CXTPPaintManager * | GetPaintManager () const
Call this method to retrieve the paint manager.
virtual CXTPImageManagerIcon * | GetImage (int nWidth=16) const
Call this method to retrieve the image of the control.
void | AssignDocTemplate (UINT nIDResource)
Call this method to assign a document template to the control.
void | ExcludeDocTemplate (UINT nIDResource)
Call this method to exclude the document template from control.
BOOL | IsItemDefault () const
Call this method to check if a control is a default menu item.
void | SetItemDefault (BOOL bDefault)
Call this method to set a control to be a default menu item.
BOOL | IsTemporary () const
Call this method to determine if a control is temporary.
void | Reset ()
Call this member to reset the icon and caption of a control to its default settings before it was customized by the user.
void | SetPrompt (LPCTSTR lpszPrompt)
Call this member to load a string from a STRINGTABLE resource to set the tooltip and description of a control.
void | SetCustomIcon (HICON hIcon)
Call this member to set a custom icon to this control.
virtual void | OnUnderlineActivate ()
This method is called when the user activates the control using its underline.
virtual BOOL | GetPopuped () const
Call this member to get the control's pop-up state.
void | RedrawParent (BOOL bAnimate=TRUE)
This method is called to redraw the parent command bar.
LRESULT | NotifySite (UINT code)
This method is called to send message code to the parent site window.
LRESULT | NotifySite (UINT code, NMXTPCONTROL *pNM)
This method is called to send message code to the parent site window.
LRESULT | NotifySite (CWnd *pSite, UINT code, NMXTPCONTROL *pNM)
This method is called to send message code to the parent site window.
virtual void | SetAction (CXTPControlAction *pAction)
Call this method to manually assign an action for control.
CXTPControlAction * | GetAction () const
Call this method to retrieve an action associated with control.
virtual void | OnThemeChanged ()
This method is called when the paint manager theme is changed.
virtual void | SetWidth (int nWidth)
Call this member to set the width of the control.
virtual void | SetHeight (int nHeight)
Call this member to set the height of the control.
int | GetWidth () const
Call this member to get the width of the control.
int | GetHeight () const
Call this member to get the height of the control.
BOOL | HasDwmCompositedRect () const
This method is called to determine if control has a Vista DWM transparent area.
virtual CSize | GetButtonSize () const
Call this function to get the size of the command bar button.
virtual CSize | GetIconSize () const
Call this member function to get the size of a toolbar icon.
void | SetIconSize (CSize szIcon)
Call this member function to set the size of an icon for an individual control.
virtual BOOL | IsCustomizeMovable () const
This method is called to determine if control can be repositioned in customize mode.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

BOOL | OnHookKeyDown (UINT nChar, LPARAM lParam)
The framework calls this member function when a non-system key is pressed.
BOOL | IsFocused () const
Call this member to get the focused state of the control.
- Protected Member Functions inherited from CXTPControlButton
virtual void | OnClick (BOOL bKeyboard=FALSE, CPoint pt=CPoint(0, 0))
This method is called when the user clicks the control.
virtual void | OnLButtonUp (CPoint point)
This member is called when the user releases the left mouse button.
virtual void | Copy (CXTPControl *pControl, BOOL bRecursive=FALSE)
This method is called to copy the control.
- Protected Member Functions inherited from CXTPControl
CXTPControl ()
Constructs a CXTPControl object.
virtual | ~CXTPControl ()
Destroys a CXTPControl object, handles cleanup and deallocation.
virtual BOOL | IsFocusable () const
This method is called to check if the control can accept focus.
void | SetIndex (int nIndex)
This method is called to assign the order of the control in the controls list.
void | SetExpanded (BOOL bExpanded)
This method is called to set the control's expanded state.
virtual BOOL | OnHookMouseWheel (UINT nFlags, short zDelta, CPoint point)
This method is called when the user rotates the mouse wheel.
virtual void | SetParent (CXTPCommandBar *pParent)
This method is called to assign a parent command bar object.
void | ScreenToClient (CPoint *point)
The ScreenToClient function converts the screen coordinates of a specified point on the screen.
void | ClickToolBarButton (CRect rcActiveRect=CRect(0, 0, 0, 0))
This helper method is called when the user clicks the toolbar's button.
virtual BOOL | OnSetPopup (BOOL bPopup)
This method is called to pop-up the control.
virtual void | OnLButtonDown (CPoint point)
This member is called when the user presses the left mouse button down.
virtual BOOL | OnRButtonDown (CPoint point)
This member is called when the user press the right mouse button.
virtual BOOL | OnRButtonUp (CPoint point)
This member is called when the user releases the right mouse button.
virtual BOOL | OnLButtonDblClk (CPoint point)
This member is called when the user double-clicks the left mouse button.
virtual void | OnMouseMove (CPoint point)
This member is called when the mouse cursor moves.
virtual void | OnMouseHover ()
Called after the mouse hovers over the control.
virtual BOOL | OnSetSelected (int bSelected)
This method is called when the control becomes selected.
BOOL | IsCustomizeMode () const
Call this method to determine if command bars is in customize mode.
virtual void | CustomizeStartDrag (CPoint point)
This member is called when the user starts to drag the control in customize mode.
virtual BOOL | CustomizeStartResize (CPoint point)
This method is called when user starts to resize control in customize mode.
virtual void | OnCustomizeDragOver (CXTPControl *pDataObject, CPoint point, DROPEFFECT &dropEffect)
This member is called when the user moves the mouse over the control.
virtual BOOL | DoCustomDragOver (CXTPCommandBar *pCommandBar, CPoint point, DROPEFFECT &dropEffect)
The implementation may implement a custom drag over handling logic in this method.
virtual BOOL | IsCustomizeResizeAllow () const
This member checks if the user can resize the control.
virtual int | GetCustomizeMinWidth () const
Retrieves the available minimum width of control.
virtual int | GetCustomizeMinHeight () const
Retrieves available minimum height of the control.
void | OnCustomizeMouseMove (CPoint point)
This member is called when the mouse cursor moves in customized mode.
virtual void | OnIdleUpdate ()
This virtual method is called in idle-time processing.
virtual void | OnRemoved ()
This method is called when a control is removed from the parent controls collection.
virtual INT_PTR | OnToolHitTest (CPoint point, TOOLINFO *pTI) const
The framework calls this member function to determine whether a point is in the bounding rectangle of the specified tool.
virtual void | RestoreCommandBarList (CXTPCommandBarList *pCommandBarList)
This method is called from LoadCommandBars to restore controls and its child command bars.
virtual void | GenerateCommandBarList (DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam)
This method is called from SaveCommandBars to save all child command bars.
virtual void | OnActionChanged (int nProperty)
This method is called when an action property is changed.
virtual void | OnActionChanging (int nProperty)
This method is called when an action property is about to be changed.
virtual void | OnCaptionChanged ()
This method is called when the control's caption is changed.
BOOL | IsLayoutRTL () const
Determines if right-to-left (RTL) mode is set.
BOOL | IsLayoutChanged ()
Call this member to determine if the layout has changed (RTL to LTR or LTR to RLT).

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControl
static CXTPControl *AFX_CDECL | FromUI (CCmdUI *pCmdUI)
Call this member to retrieve CXTPControl from a CCmdUI structure.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Attributes inherited from CXTPControlButton
XTPButtonStyle | m_buttonStyleEx
User-defined style of button containing vector icon.
- Protected Attributes inherited from CXTPControl
DWORD_PTR | m_nTag
Control tag.
int | m_nIndex
Index of the control.
int | m_nId
Identifier of the control.
int | m_nIconId
Identifier of the control's image.
int | m_nHelpId
Help identifier.
int | m_nCustomIconId
Identifier of the control's custom image.
BOOL | m_bWrap
TRUE if the control is wrapped.
BOOL | m_bBeginGroup
TRUE if the control starts new group.
BOOL | m_bEnabled
TRUE if the control is enabled.
BOOL | m_bChecked
TRUE if the control is checked.
BOOL | m_bSelected
TRUE if the control is selected.
BOOL | m_bPressed
TRUE if the control is pushed.
BOOL | m_bTemporary
TRUE if the control is temporary.
BOOL | m_bOnQuickAccess
TRUE if the control is a part of Quick Access panel.
CRect | m_rcRow
Bounding rectangle of the control's row.
CRect | m_rcControl
Bounding rectangle of the control.
DWORD | m_dwHideFlags
Hidden flags.
DWORD | m_dwFlags
Flags of the control.
CString | m_strCaption
Caption of the control.
CString | m_strCustomCaption
User-defined caption.
CString | m_strShortcutText
Shortcut text.
CString | m_strShortcutTextAuto
Shortcut text.
CString | m_strTooltipText
Tooltip text.
CString | m_strDescriptionText
Description text.
CString | m_strParameter
Parameter text.
CString | m_strKeyboardTip
Keyboard tip.
CXTPControls * | m_pControls
Parent control collection.
XTPControlType | m_controlType
Type of the control.
CXTPCommandBar * | m_pParent
The Parent command bar.
BOOL | m_bExpanded
TRUE if the control is expanded.
CString | m_strCategory
Category of the control.
BOOL | m_bDefaultItem
TRUE if the item is default pop-up item.
CDocTemplateMap | m_mapDocTemplatesAssigned
Assigned templates.
CDocTemplateMap | m_mapDocTemplatesExcluded
Excluded templates.
XTPButtonStyle | m_buttonStyle
Button Style.
XTPButtonStyle | m_buttonCustomStyle
User-defined style of button.
XTPButtonStyle | m_buttonRibbonStyle
User-defined style of button.
BOOL | m_bCloseSubMenuOnClick
TRUE is sub-menus are closed as soon as a control is clicked.
CXTPRibbonGroup * | m_pRibbonGroup
Ribbon group of control.
CXTPControlAction * | m_pAction
Action of the control.
int | m_nWidth
Width of the control.
int | m_nHeight
Height of the control.
int | m_nExecuteOnPressInterval
Delay between each message when control is pressed.
CSize | m_szIcon
The size of the icon used for the control.
BOOL | m_bLayoutRTL
Indicate does last layout is RTL.

Detailed Description

CXTPControlRadioButton is a CXTPControlButton derived class.

It represents a radio button control.

Member Function Documentation

◆ IsFocused()

BOOL IsFocused ( ) const
protectedvirtual

Call this member to get the focused state of the control.

Returns
TRUE if the control has focus, otherwise FALSE.

Reimplemented from CXTPControl.

◆ OnHookKeyDown()

BOOL OnHookKeyDown | ( | UINT | nChar,
 |  | LPARAM | lParam )
 protectedvirtual

The framework calls this member function when a non-system key is pressed.

Parameters
nChar | Specifies the virtual key code of the given key.
lParam | Specifies additional message-dependent information.
Returns
TRUE if the key was handled, otherwise FALSE.

Reimplemented from CXTPControl.

The documentation for this class was generated from the following file:
  • XTPControlExt.h


Toolkit Pro: CXTPControlRecentFileList Class Reference

Protected Member Functions | List of all members
CXTPControlRecentFileList Class Reference

CXTPControlRecentFileList is a CXTPControlButton derived class. More...

Inheritance diagram for CXTPControlRecentFileList:
[legend]

Protected Member Functions

virtual void | OnCalcDynamicSize (DWORD dwMode)
This method is called before recalculating the parent command bar size to calculate the dimensions of the control.
virtual BOOL | DoCustomDragOver (CXTPCommandBar *pCommandBar, CPoint point, DROPEFFECT &dropEffect)
The implementation may implement a custom drag over handling logic in this method.
virtual CRecentFileList * | GetRecentFileList ()
Call this member to get a pointer to the recent file list collection.
virtual int | GetFirstMruID ()
Call this member to get ID_FILE_MRU_FILE1.
- Protected Member Functions inherited from CXTPControlButton
virtual void | OnClick (BOOL bKeyboard=FALSE, CPoint pt=CPoint(0, 0))
This method is called when the user clicks the control.
virtual void | OnLButtonUp (CPoint point)
This member is called when the user releases the left mouse button.
virtual void | Copy (CXTPControl *pControl, BOOL bRecursive=FALSE)
This method is called to copy the control.
- Protected Member Functions inherited from CXTPControl
CXTPControl ()
Constructs a CXTPControl object.
virtual | ~CXTPControl ()
Destroys a CXTPControl object, handles cleanup and deallocation.
virtual BOOL | IsFocusable () const
This method is called to check if the control can accept focus.
void | SetIndex (int nIndex)
This method is called to assign the order of the control in the controls list.
void | SetExpanded (BOOL bExpanded)
This method is called to set the control's expanded state.
virtual BOOL | OnHookKeyDown (UINT nChar, LPARAM lParam)
This method is called when a non-system key is pressed.
virtual BOOL | OnHookMouseWheel (UINT nFlags, short zDelta, CPoint point)
This method is called when the user rotates the mouse wheel.
virtual void | SetParent (CXTPCommandBar *pParent)
This method is called to assign a parent command bar object.
void | ScreenToClient (CPoint *point)
The ScreenToClient function converts the screen coordinates of a specified point on the screen.
void | ClickToolBarButton (CRect rcActiveRect=CRect(0, 0, 0, 0))
This helper method is called when the user clicks the toolbar's button.
virtual BOOL | OnSetPopup (BOOL bPopup)
This method is called to pop-up the control.
virtual void | OnLButtonDown (CPoint point)
This member is called when the user presses the left mouse button down.
virtual BOOL | OnRButtonDown (CPoint point)
This member is called when the user press the right mouse button.
virtual BOOL | OnRButtonUp (CPoint point)
This member is called when the user releases the right mouse button.
virtual BOOL | OnLButtonDblClk (CPoint point)
This member is called when the user double-clicks the left mouse button.
virtual void | OnMouseMove (CPoint point)
This member is called when the mouse cursor moves.
virtual void | OnMouseHover ()
Called after the mouse hovers over the control.
virtual BOOL | OnSetSelected (int bSelected)
This method is called when the control becomes selected.
BOOL | IsCustomizeMode () const
Call this method to determine if command bars is in customize mode.
virtual void | CustomizeStartDrag (CPoint point)
This member is called when the user starts to drag the control in customize mode.
virtual BOOL | CustomizeStartResize (CPoint point)
This method is called when user starts to resize control in customize mode.
virtual void | OnCustomizeDragOver (CXTPControl *pDataObject, CPoint point, DROPEFFECT &dropEffect)
This member is called when the user moves the mouse over the control.
virtual BOOL | IsCustomizeResizeAllow () const
This member checks if the user can resize the control.
virtual int | GetCustomizeMinWidth () const
Retrieves the available minimum width of control.
virtual int | GetCustomizeMinHeight () const
Retrieves available minimum height of the control.
void | OnCustomizeMouseMove (CPoint point)
This member is called when the mouse cursor moves in customized mode.
virtual void | OnIdleUpdate ()
This virtual method is called in idle-time processing.
virtual void | OnRemoved ()
This method is called when a control is removed from the parent controls collection.
virtual INT_PTR | OnToolHitTest (CPoint point, TOOLINFO *pTI) const
The framework calls this member function to determine whether a point is in the bounding rectangle of the specified tool.
virtual void | RestoreCommandBarList (CXTPCommandBarList *pCommandBarList)
This method is called from LoadCommandBars to restore controls and its child command bars.
virtual void | GenerateCommandBarList (DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam)
This method is called from SaveCommandBars to save all child command bars.
virtual void | OnActionChanged (int nProperty)
This method is called when an action property is changed.
virtual void | OnActionChanging (int nProperty)
This method is called when an action property is about to be changed.
virtual void | OnCaptionChanged ()
This method is called when the control's caption is changed.
BOOL | IsLayoutRTL () const
Determines if right-to-left (RTL) mode is set.
BOOL | IsLayoutChanged ()
Call this member to determine if the layout has changed (RTL to LTR or LTR to RLT).

Additional Inherited Members

- Public Member Functions inherited from CXTPControlButton
CXTPControlButton ()
Constructs a CXTPControlButton object.
virtual | ~CXTPControlButton ()
Destroys a CXTPControlButton object, handles cleanup and deallocation.
void | SetStyleEx (XTPButtonStyle buttonStyle)
Call this member to set the style of the button containing vector icon.
XTPButtonStyle | GetStyleEx () const
Call this member to get the button's style containing vector icon.
void | DoPropExchange (CXTPPropExchange *pPX)
Either reads this object from or writes this object to an archive.
- Public Member Functions inherited from CXTPControl
void | SetStyle (XTPButtonStyle buttonStyle)
Call this member to set the style of the control.
XTPButtonStyle | GetStyle () const
Call this member to get the control's style.
void | SetCaption (LPCTSTR lpszCaption)
Call this member to set the caption of the control.
void | SetCaption (UINT nIDCaption)
Call this member to set the caption of the control.
virtual CString | GetCaption () const
Call this member to get the control's caption.
void | SetShortcutText (LPCTSTR lpszShortcutText)
Call this member to set the shortcut string to the control.
CString | GetShortcutText () const
Call this member to get the control's shortcut.
void | SetDescription (LPCTSTR lpszDescription)
Call this member to set the description of the control.
virtual CString | GetDescription () const
Call this member to get the control's description.
void | SetTooltip (LPCTSTR lpszTooltip)
Call this member to set the tooltip of the control.
virtual CString | GetTooltip () const
Call this member to get the control's tooltip.
void | SetKeyboardTip (LPCTSTR lpszKeyboardTip)
Call this member to set the keyboard tip to the control.
CString | GetKeyboardTip () const
Call this member to get the keyboard tip.
void | SetCustomShortcutText (LPCTSTR lpszCustomShortcutText)
Call this member to set the text displayed for the shortcut in a pop-up menu.
CString | GetCustomShortcutText () const
Call this member to get the control's text displayed for the shortcut in a pop-up menu.
void | SetParameter (LPCTSTR lpszParameter)
Call this member to set the parameter of the control.
CString | GetParameter () const
Call this member to get the control's parameter.
void | SetID (int nId)
Call this member to set the identifier of the control.
int | GetID () const
Call this member to get the control's identifier.
long | GetIndex () const
Call this member to get the index of the control.
void | SetIconId (int nId)
Call this member to set the control icon's identifier.
int | GetIconId () const
Call this member to get the icon's identifier.
void | SetHelpId (int nId)
Call this member to set the control help identifier.
int | GetHelpId () const
Call this member to get the help identifier.
virtual void | SetBeginGroup (BOOL bBeginGroup)
Call this member to begin a new group using a separator.
BOOL | GetBeginGroup () const
Call this member to determine if the control has a separator.
virtual void | SetEnabled (BOOL bEnabled)
Call this member to enable/disable the control.
BOOL | GetEnabled () const
Call this member to check if the control is enabled.
virtual void | OnEnabledChanged ()
This method is called when a control's enabled state is changed.
virtual void | SetChecked (BOOL bChecked)
Call this member to set the checked state of the control.
BOOL | GetChecked () const
Call this member to get the checked state of the control.
virtual int | GetSelected () const
Call this member to check if the control is selected.
void | SetOnQuickAccess (BOOL bOnQuicAccess=FALSE)
Call this member to set whether a control should be a part of the Quick Access panel.
BOOL | IsOnQuickAccess () const
Call this member to check if a control is a part of the Quick Access panel.
virtual void | SetFocused (BOOL bFocused)
Call this member to set the focused state of the control.
virtual BOOL | IsFocused () const
Call this member to check the focused state of the control.
void | SetPressed (BOOL bPressed)
Call this member to set the pressed state of the control.
virtual BOOL | GetPressed () const
Call this member to check the pressed state of the control.
virtual void | SetRect (CRect rcControl)
This member is called to set the bounding rectangle of the control.
CRect | GetRect () const
Call this member to get the bounding rectangle of the control.
CXTPCommandBar * | GetParent () const
Call this member to get the parent command bar.
virtual BOOL | IsVisible (DWORD dwSkipFlags=0) const
Call this member to determine if the control is visible.
virtual BOOL | IsCaptionVisible () const
Call this member to determine if the caption of the control is visible.
void | SetVisible (BOOL bVisible)
Call this member to set the visibility of the control.
CXTPControls * | GetControls () const
Call this member to get the parent controls collection.
XTPControlType | GetType () const
Call this member to get the control's type.
void | SetFlags (DWORD dwFlags)
Call this member to set the flags of the control.
DWORD | GetFlags () const
Call this member to retrieve control special flags.
void | SetTag (DWORD_PTR dwTag)
This method sets the 32-bit value associated with the control.
DWORD_PTR | GetTag () const
This method retrieves the application-supplied, 32-bit value associated with the control.
virtual BOOL | Compare (CXTPControl *pOther)
Call this member to compare controls.
virtual CXTPCommandBar * | GetCommandBar () const
Call this member to get the child command bar.
void | SetCloseSubMenuOnClick (BOOL bCloseOnClick)
Call this member function to enable/disable the closing of sub-menus when a control is clicked in the menu.
BOOL | GetCloseSubMenuOnClick () const
Call this member function to check if sub-menus will close as soon as a control is clicked.
void | SetExecuteOnPressInterval (int nExecuteOnPressInterval)
Call this method to set the delay (in milliseconds) between WM_COMMAND messages while a button is pressed by the user.
int | GetExecuteOnPressInterval () const
Call this method to get the delay (in milliseconds) between WM_COMMAND messages while a button is pressed by the user.
CXTPRibbonGroup * | GetRibbonGroup () const
Returns the ribbon group that the control belongs to.
virtual BOOL | IsTransparent () const
Determines if the control needs to draw its background.
void | SetHideWrap (BOOL bHide)
This method is called to hide the control.
virtual void | SetHideFlags (DWORD dwFlags)
This method is called to hide the control.
BOOL | SetHideFlag (XTPControlHideFlags dwFlag, BOOL bSet)
Call this member to set/remove hide flags.
DWORD | GetHideFlags () const
Call this method to retrieve hidden flags.
CRect | GetRowRect () const
Call this method to retrieve the position of the control's row.
BOOL | GetWrap () const
Call this method to check if the control is wrapped.
void | SetRowRect (CRect rcRow)
Call this method to set the row of the control.
void | SetWrap (BOOL bWrap)
Call this member to set the control to wrapped.
BOOL | GetExpanded () const
Call this member to check if the control is expanded.
BOOL | IsCursorOver () const
Call this member to determine if the mouse pointer is over the control.
virtual void | OnExecute ()
This method is called when the control is executed.
virtual CSize | GetSize (CDC *pDC)
This method is called to determine the size of the control.
virtual void | Draw (CDC *pDC)
This method is called to draw the control.
void | DelayRedrawParent ()
Call this method to redraw the parent command bar.
void | DelayLayoutParent ()
Call this method to recalculate the parent command bar size.
void | SetCategory (LPCTSTR lpszCategory)
Call this method to set the category of the control.
CString | GetCategory () const
Call this method to retrieve the category of the control.
CXTPImageManager * | GetImageManager () const
Call this method to retrieve the image manager.
CXTPPaintManager * | GetPaintManager () const
Call this method to retrieve the paint manager.
virtual CXTPImageManagerIcon * | GetImage (int nWidth=16) const
Call this method to retrieve the image of the control.
void | AssignDocTemplate (UINT nIDResource)
Call this method to assign a document template to the control.
void | ExcludeDocTemplate (UINT nIDResource)
Call this method to exclude the document template from control.
BOOL | IsItemDefault () const
Call this method to check if a control is a default menu item.
void | SetItemDefault (BOOL bDefault)
Call this method to set a control to be a default menu item.
BOOL | IsTemporary () const
Call this method to determine if a control is temporary.
void | Reset ()
Call this member to reset the icon and caption of a control to its default settings before it was customized by the user.
void | SetPrompt (LPCTSTR lpszPrompt)
Call this member to load a string from a STRINGTABLE resource to set the tooltip and description of a control.
void | SetCustomIcon (HICON hIcon)
Call this member to set a custom icon to this control.
virtual void | OnUnderlineActivate ()
This method is called when the user activates the control using its underline.
virtual BOOL | GetPopuped () const
Call this member to get the control's pop-up state.
void | RedrawParent (BOOL bAnimate=TRUE)
This method is called to redraw the parent command bar.
LRESULT | NotifySite (UINT code)
This method is called to send message code to the parent site window.
LRESULT | NotifySite (UINT code, NMXTPCONTROL *pNM)
This method is called to send message code to the parent site window.
LRESULT | NotifySite (CWnd *pSite, UINT code, NMXTPCONTROL *pNM)
This method is called to send message code to the parent site window.
virtual void | SetAction (CXTPControlAction *pAction)
Call this method to manually assign an action for control.
CXTPControlAction * | GetAction () const
Call this method to retrieve an action associated with control.
virtual void | OnThemeChanged ()
This method is called when the paint manager theme is changed.
virtual void | SetWidth (int nWidth)
Call this member to set the width of the control.
virtual void | SetHeight (int nHeight)
Call this member to set the height of the control.
int | GetWidth () const
Call this member to get the width of the control.
int | GetHeight () const
Call this member to get the height of the control.
BOOL | HasDwmCompositedRect () const
This method is called to determine if control has a Vista DWM transparent area.
virtual CSize | GetButtonSize () const
Call this function to get the size of the command bar button.
virtual CSize | GetIconSize () const
Call this member function to get the size of a toolbar icon.
void | SetIconSize (CSize szIcon)
Call this member function to set the size of an icon for an individual control.
virtual BOOL | IsCustomizeMovable () const
This method is called to determine if control can be repositioned in customize mode.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.
- Static Public Member Functions inherited from CXTPControl
static CXTPControl *AFX_CDECL | FromUI (CCmdUI *pCmdUI)
Call this member to retrieve CXTPControl from a CCmdUI structure.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Attributes inherited from CXTPControlButton
XTPButtonStyle | m_buttonStyleEx
User-defined style of button containing vector icon.
- Protected Attributes inherited from CXTPControl
DWORD_PTR | m_nTag
Control tag.
int | m_nIndex
Index of the control.
int | m_nId
Identifier of the control.
int | m_nIconId
Identifier of the control's image.
int | m_nHelpId
Help identifier.
int | m_nCustomIconId
Identifier of the control's custom image.
BOOL | m_bWrap
TRUE if the control is wrapped.
BOOL | m_bBeginGroup
TRUE if the control starts new group.
BOOL | m_bEnabled
TRUE if the control is enabled.
BOOL | m_bChecked
TRUE if the control is checked.
BOOL | m_bSelected
TRUE if the control is selected.
BOOL | m_bPressed
TRUE if the control is pushed.
BOOL | m_bTemporary
TRUE if the control is temporary.
BOOL | m_bOnQuickAccess
TRUE if the control is a part of Quick Access panel.
CRect | m_rcRow
Bounding rectangle of the control's row.
CRect | m_rcControl
Bounding rectangle of the control.
DWORD | m_dwHideFlags
Hidden flags.
DWORD | m_dwFlags
Flags of the control.
CString | m_strCaption
Caption of the control.
CString | m_strCustomCaption
User-defined caption.
CString | m_strShortcutText
Shortcut text.
CString | m_strShortcutTextAuto
Shortcut text.
CString | m_strTooltipText
Tooltip text.
CString | m_strDescriptionText
Description text.
CString | m_strParameter
Parameter text.
CString | m_strKeyboardTip
Keyboard tip.
CXTPControls * | m_pControls
Parent control collection.
XTPControlType | m_controlType
Type of the control.
CXTPCommandBar * | m_pParent
The Parent command bar.
BOOL | m_bExpanded
TRUE if the control is expanded.
CString | m_strCategory
Category of the control.
BOOL | m_bDefaultItem
TRUE if the item is default pop-up item.
CDocTemplateMap | m_mapDocTemplatesAssigned
Assigned templates.
CDocTemplateMap | m_mapDocTemplatesExcluded
Excluded templates.
XTPButtonStyle | m_buttonStyle
Button Style.
XTPButtonStyle | m_buttonCustomStyle
User-defined style of button.
XTPButtonStyle | m_buttonRibbonStyle
User-defined style of button.
BOOL | m_bCloseSubMenuOnClick
TRUE is sub-menus are closed as soon as a control is clicked.
CXTPRibbonGroup * | m_pRibbonGroup
Ribbon group of control.
CXTPControlAction * | m_pAction
Action of the control.
int | m_nWidth
Width of the control.
int | m_nHeight
Height of the control.
int | m_nExecuteOnPressInterval
Delay between each message when control is pressed.
CSize | m_szIcon
The size of the icon used for the control.
BOOL | m_bLayoutRTL
Indicate does last layout is RTL.

Detailed Description

CXTPControlRecentFileList is a CXTPControlButton derived class.

It is used internally to create recent items list.

Member Function Documentation

◆ DoCustomDragOver()

virtual BOOL DoCustomDragOver | ( | CXTPCommandBar * | pCommandBar,
 |  | CPoint | point,
 |  | DROPEFFECT & | dropEffect )
 protectedvirtual

The implementation may implement a custom drag over handling logic in this method.

Parameters
pCommandBar | Pointer to a CXTPCommandBar object.
point | Mouse position.
dropEffect | DROPEFFECT enumerator.
Returns
TRUE if custom implementation handles drag over, otherwise FALSE.

Reimplemented from CXTPControl.

◆ GetFirstMruID()

virtual int GetFirstMruID ( )
protectedvirtual

Call this member to get ID_FILE_MRU_FILE1.

Returns
ID_FILE_MRU_FILE1.

◆ GetRecentFileList()

virtual CRecentFileList * GetRecentFileList ( )
protectedvirtual

Call this member to get a pointer to the recent file list collection.

Returns
Pointer to the recent file list collection.

◆ OnCalcDynamicSize()

virtual void OnCalcDynamicSize ( DWORD dwMode )
protectedvirtual

This method is called before recalculating the parent command bar size to calculate the dimensions of the control.

Parameters
dwMode Flags used to determine the height and width of the dynamic command bar. See Remarks section for a list of values.

The following predefined flags are used to determine the height and width of the dynamic command bar. Use the bitwise-OR (|) operator to combine the flags.

LM_STRETCH: Indicates whether the command bar should be stretched to the size of the frame. Set if the bar is not a docking bar (not available for docking). Not set when the bar is docked or floating (available for docking). If set, LM_STRETCH returns dimensions based on the LM_HORZ state. LM_STRETCH works similarly to the the bStretch parameter used in CalcFixedLayout; see that member function for more information about the relationship between stretching and orientation. LM_HORZ: Indicates that the bar is horizontally or vertically oriented. Set if the bar is horizontally oriented, and if it is vertically oriented, it is not set. LM_HORZ works similarly to the the bHorz parameter used in CalcFixedLayout; see that member function for more information about the relationship between stretching and orientation. LM_MRUWIDTH: Most Recently Used Dynamic Width. Uses the remembered most recently used width. LM_HORZDOCK: Horizontal Docked Dimensions. Returns the dynamic size with the largest width. LM_VERTDOCK: Vertical Docked Dimensions. Returns the dynamic size with the largest height. LM_COMMIT: Resets LM_MRUWIDTH to the current width of the floating command bar.

The framework calls this member function to calculate the dimensions of a dynamic command bar.

Override this member function to provide your own layout in classes you derive from CXTPControl. XTP classes derived from CXTPControl, such as CXTPControlComboBox, override this member function to provide their own implementation.

See also
CXTPControlComboBox, CXTPControlCustom, CXTPControlEdit, CXTPControlWindowList, CXTPControlWorkspaceActions, CXTPControlToolbars, CXTPControlOleItems, CXTPControl, CXTPControlSelector, CXTPControlListBox

Reimplemented from CXTPControl.

The documentation for this class was generated from the following file:
  • XTPControlExt.h


Toolkit Pro: CXTPControls Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPControls Class Reference

CXTPControls is a CXTPCmdTarget derived class. More...

Inheritance diagram for CXTPControls:
[legend]

Public Member Functions

CXTPControls ()
Internal helper structure.
virtual | ~CXTPControls ()
Destroys a CXTPControls object, handles cleanup and deallocation.
CXTPControl * | GetAt (int nIndex) const
Call this member to return the control at the specified index.
int | CommandToIndex (int nIDFind) const
This member function returns the index of the first control, starting at position 0, whose command ID matches nIDFind.
CXTPControl * | Add (CXTPControl *pControl, int nId, LPCTSTR lpszParameter=NULL, int nBefore=-1, BOOL bTemporary=FALSE)
Call this member to add a new control.
CXTPControl * | Add (XTPControlType controlType, int nId, LPCTSTR lpszParameter=NULL, int nBefore=-1, BOOL bTemporary=FALSE)
Call this member to add a new control.
CXTPControl * | Add (CXTPControl *pControl)
Call this member to add a new control.
CXTPControl * | InsertAt (CXTPControl *pControl, int nBefore)
Call this member to insert a new control.
CXTPControl * | AddMenuItem (CMenu *pMenu, int nIndex)
Call this member to add a new control.
virtual void | Remove (CXTPControl *pControl)
Call this member to remove a control.
void | Remove (int nIndex)
Call this member to remove a control.
void | RemoveAll ()
Call this member to remove all controls.
int | GetCount () const
Call this member to get the count of the controls.
CXTPControl * | FindControl (int nId) const
Call this member to find the specified control.
CXTPControl * | FindControl (XTPControlType type, int nId, BOOL bVisible, BOOL bRecursive) const
Call this member to find the specified control.
BOOL | LoadMenu (CMenu *pMenu)
Call this member to convert menu items to command bar controls.
CXTPControl * | GetFirst () const
Call this member to retrieve the first control.
void | GetNext (CXTPControl *&pControl) const
Finds the next control in the given direction.
long | GetNext (long nIndex, int nDirection=+1, BOOL bKeyboard=TRUE, BOOL bSkipTemporary=FALSE, BOOL bSkipCollapsed=TRUE) const
Finds the next control in the given direction.
CXTPControl * | HitTest (CPoint point) const
This member function determines which control, if any, is at a specified point.
CXTPControl * | SetControlType (CXTPControl *pControl, XTPControlType type)
Call this member to change the type of the control.
CXTPControl * | SetControlType (int nIndex, XTPControlType type)
Call this member to change the type of the control.
CXTPControl * | AddClone (CXTPControl *pClone, int nBefore=-1, BOOL bRecursive=FALSE)
Call this member to add a copy of a control.
CSize | CalcDynamicSize (CDC *pDC, int nLength, DWORD dwMode, const CRect &rcBorder, int nWidth=0)
This method is called internally to reposition controls and determine their size.
CSize | CalcPopupSize (CDC *pDC, int nLength, int nWidth, const CRect &rcBorder)
This method is called internally to reposition controls and determine their size for a pop-up bar.
int | GetVisibleCount (BOOL bIgnoreWrap=FALSE) const
Call this member to get the number of visible controls.
CXTPControl * | GetVisibleAt (int nIndex, BOOL bIgnoreWraps=FALSE) const
Finds a specified control by its ID.
void | SetCommandBars (CXTPCommandBars *pCommandBars)
Call this member to attach the specified command bars object.
CXTPControls * | Duplicate (BOOL bRecursive=FALSE)
Makes a copy of all controls.
virtual void | Copy (CXTPControls *pControls, BOOL bRecursive=FALSE)
This method is called to copy the control.
CXTPCommandBars * | GetCommandBars () const
Retrieves the parent command bars object.
void | MoveBefore (CXTPControl *pControl, int nBefore)
Moves the control to a specified position.
void | SetParent (CXTPCommandBar *pParent)
Attaches the parent command bar.
void | CreateOriginalControls ()
Creates the original controls set.
void | ClearOriginalControls ()
Removes the original controls set.
CXTPOriginalControls * | GetOriginalControls () const
Retrieves the original controls set.
void | SetOriginalControls (CXTPOriginalControls *pControls)
Call this method to assign original controls.
BOOL | Compare (const CXTPControls *pControls)
Call this member to compare the controls.
BOOL | IsChanged () const
Returns the changed status flag of the control.
virtual void | DoPropExchange (CXTPPropExchange *pPX)
Either reads this object from or writes this object to an archive.
virtual BOOL | ShouldSerializeControl (CXTPControl *pControl)
Call this method to check if the control has been changed and must be saved.
CXTPCommandBar * | GetParent () const
Call this member to get the parent command bar.
BOOL | IsOriginalControls () const
Determines if all controls in the collection are original (i.e.
void | Sort ()
Sorts the commands list.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

virtual void | OnControlAdded (CXTPControl *pControl)
This method is called when a control is added to the collection.
virtual void | OnControlRemoved (CXTPControl *pControl)
This method is called when a control is removed from the collection.
virtual BOOL | OnControlRemoving (CXTPControl *pControl)
This method is called when a control is about to be removed from the collection.

Protected Attributes

CXTPCommandBar * | m_pParent
Parent Command Bar.
CArray< CXTPControl *, CXTPControl * > | m_arrControls
Collection of controls.
CXTPCommandBars * | m_pCommandBars
Parent Command Bars.
CXTPOriginalControls * | m_pOriginalControls
Original controls collection.
BOOL | m_bOriginalControls
TRUE if all controls are original and unmodified.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

CXTPControls is a CXTPCmdTarget derived class.

It represents a collection of controls.

Constructor & Destructor Documentation

◆ CXTPControls()

CXTPControls ( )

Internal helper structure.

Protected constructor used by dynamic creation.

Member Function Documentation

◆ Add() [1/3]

CXTPControl * Add ( CXTPControl * pControl )

Call this member to add a new control.

Parameters
pControl A pointer to the control to be added.
Returns
A pointer to the added control.

◆ Add() [2/3]

CXTPControl * Add | ( | CXTPControl * | pControl,
 |  | int | nId,
 |  | LPCTSTR | lpszParameter = NULL,
 |  | int | nBefore = -1,
 |  | BOOL | bTemporary = FALSE )

Call this member to add a new control.

Parameters
nId | Identifier of the control to be added.
lpszParameter | Parameter of the control to be added.
nBefore | Index of the control to be inserted.
bTemporary | TRUE if this control is temporary.
pControl | A pointer to the control
Returns
A pointer to the added control.

◆ Add() [3/3]

CXTPControl * Add | ( | XTPControlType | controlType,
 |  | int | nId,
 |  | LPCTSTR | lpszParameter = NULL,
 |  | int | nBefore = -1,
 |  | BOOL | bTemporary = FALSE )

Call this member to add a new control.

Parameters
controlType | The type of the control to be added.
nId | Identifier of the control to be added.
lpszParameter | Parameter of the control to be added.
nBefore | Index of the control to be inserted.
bTemporary | TRUE if this control is temporary.
Returns
A pointer to the added control.

◆ AddClone()

CXTPControl * AddClone | ( | CXTPControl * | pClone,
 |  | int | nBefore = -1,
 |  | BOOL | bRecursive = FALSE )

Call this member to add a copy of a control.

Parameters
pClone | Pointer to the CXTPControl object to copy.
nBefore | Index of the control to be inserted.
bRecursive | TRUE to copy recursively.
Returns
A pointer to the added CXTPControl object.

◆ AddMenuItem()

CXTPControl * AddMenuItem | ( | CMenu * | pMenu,
 |  | int | nIndex )

Call this member to add a new control.

Parameters
pMenu | Menu that contains the control.
nIndex | Index of the control to be added.
Returns
Pointer to the added control.

◆ CalcDynamicSize()

CSize CalcDynamicSize | ( | CDC * | pDC,
 |  | int | nLength,
 |  | DWORD | dwMode,
 |  | const CRect & | rcBorder,
 |  | int | nWidth = 0 )

This method is called internally to reposition controls and determine their size.

Parameters
pDC | Pointer to a valid device context.
nLength | Length of the parent bar.
dwMode | Mode of the parent bar.
rcBorder | Borders of commandbar.
nWidth | Width of the parent bar.
Returns
Total size of the controls.

◆ CalcPopupSize()

CSize CalcPopupSize | ( | CDC * | pDC,
 |  | int | nLength,
 |  | int | nWidth,
 |  | const CRect & | rcBorder )

This method is called internally to reposition controls and determine their size for a pop-up bar.

Parameters
pDC | Pointer to a valid device context.
nLength | Length of the parent bar.
nWidth | Width of the parent bar.
rcBorder | Borders of pop-up bar.
Returns
Total size of the controls.
See also
CalcDynamicSize

◆ CommandToIndex()

int CommandToIndex ( int nIDFind ) const

This member function returns the index of the first control, starting at position 0, whose command ID matches nIDFind.

Parameters
nIDFind Command ID of the control to find.
Returns
The index of the control, or -1 if no control has the given command ID.

◆ Compare()

BOOL Compare ( const CXTPControls * pControls )

Call this member to compare the controls.

Parameters
pControls Pointer to a CXTPControls object.
Returns
TRUE if the controls are identical, otherwise FALSE.

◆ Copy()

virtual void Copy | ( | CXTPControls * | pControls,
 |  | BOOL | bRecursive = FALSE )
 virtual

This method is called to copy the control.

Parameters
pControls | Controls to be copied.
bRecursive | TRUE to copy recursively.

Reimplemented in CXTPRibbonControls.

◆ DoPropExchange()

virtual void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Either reads this object from or writes this object to an archive.

Parameters
pPX A CXTPPropExchange object to serialize to or from.

◆ Duplicate()

CXTPControls * Duplicate ( BOOL bRecursive = FALSE )

Makes a copy of all controls.

Parameters
bRecursive TRUE to copy recursively.
Returns
A pointer to a CXTPControls object.

◆ FindControl() [1/2]

CXTPControl * FindControl ( int nId ) const

Call this member to find the specified control.

Parameters
nId The control's identifier.
Returns
Pointer to the CXTPControl object if successful, otherwise NULL.

◆ FindControl() [2/2]

CXTPControl * FindControl | ( | XTPControlType | type,
 |  | int | nId,
 |  | BOOL | bVisible,
 |  | BOOL | bRecursive ) const

Call this member to find the specified control.

Parameters
type | The type of the control to find.
nId | The control's identifier.
bVisible | TRUE if the control is visible.
bRecursive | TRUE to find in the nested command bars.
Returns
Pointer to the CXTPControl object if successful, otherwise NULL.

◆ GetAt()

AFX_INLINE CXTPControl * GetAt ( int nIndex ) const

Call this member to return the control at the specified index.

Parameters
nIndex An integer index.
Returns
The CXTPControl pointer currently at this index.

◆ GetCommandBars()

CXTPCommandBars * GetCommandBars ( ) const

Retrieves the parent command bars object.

Returns
A pointer to a CXTPCommandBars object.

◆ GetCount()

AFX_INLINE int GetCount ( ) const

Call this member to get the count of the controls.

Returns
The count of the controls.

◆ GetFirst()

CXTPControl * GetFirst ( ) const

Call this member to retrieve the first control.

Returns
A pointer to a CXTPControl object.

◆ GetNext() [1/2]

void GetNext ( CXTPControl *& pControl ) const

Finds the next control in the given direction.

Parameters
pControl Receives a pointer to the next control.

◆ GetNext() [2/2]

long GetNext | ( | long | nIndex,
 |  | int | nDirection = +1,
 |  | BOOL | bKeyboard = TRUE,
 |  | BOOL | bSkipTemporary = FALSE,
 |  | BOOL | bSkipCollapsed = TRUE ) const

Finds the next control in the given direction.

Parameters
nIndex | Current control index.
nDirection | Direction to find.
bKeyboard | TRUE to skip controls with xtpFlagSkipFocus flag.
bSkipTemporary | TRUE to skip all controls with Temporary flag
bSkipCollapsed | TRUE to skip all controls with xtpHideExpand hide flag.
Returns
Index of the next control.

◆ GetOriginalControls()

AFX_INLINE CXTPOriginalControls * GetOriginalControls ( ) const

Retrieves the original controls set.

Returns
A pointer to a CXTPControls object.

◆ GetParent()

AFX_INLINE CXTPCommandBar * GetParent ( ) const

Call this member to get the parent command bar.

Returns
The parent command bar object.

◆ GetVisibleAt()

CXTPControl * GetVisibleAt | ( | int | nIndex,
 |  | BOOL | bIgnoreWraps = FALSE ) const

Finds a specified control by its ID.

Parameters
nIndex | Control's identifier
bIgnoreWraps | TRUE to ignore controls that are wrapped
Returns
Pointer to the CXTPControl object if successful, otherwise NULL.

◆ GetVisibleCount()

int GetVisibleCount ( BOOL bIgnoreWrap = FALSE ) const

Call this member to get the number of visible controls.

Parameters
bIgnoreWrap TRUE to ignore controls that are wrapped.
Returns
Number of visible controls.

◆ HitTest()

CXTPControl * HitTest ( CPoint point ) const

This member function determines which control, if any, is at a specified point.

Parameters
point Point to be tested.
Returns
A pointer to the control at the position specified by 'point', otherwise NULL.

◆ InsertAt()

CXTPControl * InsertAt | ( | CXTPControl * | pControl,
 |  | int | nBefore )

Call this member to insert a new control.

Parameters
pControl | A pointer to the control to be added.
nBefore | Index of the control to be inserted.
Returns
A pointer to the added control.
See also
Add

◆ IsChanged()

BOOL IsChanged ( ) const

Returns the changed status flag of the control.

Returns
TRUE if the internal control state was changed since the last drawing, otherwise FALSE.

◆ IsOriginalControls()

AFX_INLINE BOOL IsOriginalControls ( ) const

Determines if all controls in the collection are original (i.e.

not added or modified by the user).

Returns
TRUE if all controls in the collection were added at the time of creation or from the last time CreateOriginalControls was called.

◆ LoadMenu()

BOOL LoadMenu ( CMenu * pMenu )

Call this member to convert menu items to command bar controls.

Parameters
pMenu Menu to be converted.
Returns
TRUE if the method was successful, otherwise FALSE.

◆ MoveBefore()

void MoveBefore | ( | CXTPControl * | pControl,
 |  | int | nBefore )

Moves the control to a specified position.

Parameters
pControl | Pointer to a CXTPControl object.
nBefore | Index to be moved.

◆ OnControlAdded()

virtual void OnControlAdded ( CXTPControl * pControl )
protectedvirtual

This method is called when a control is added to the collection.

Parameters
pControl Control that was added to the collection.

Reimplemented in CXTPRibbonQuickAccessControls.

◆ OnControlRemoved()

virtual void OnControlRemoved ( CXTPControl * pControl )
protectedvirtual

This method is called when a control is removed from the collection.

Parameters
pControl Control that was removed from the collection.

Reimplemented in CXTPRibbonControls, and CXTPRibbonQuickAccessControls.

◆ OnControlRemoving()

virtual BOOL OnControlRemoving ( CXTPControl * pControl )
protectedvirtual

This method is called when a control is about to be removed from the collection.

Parameters
pControl Control to be removed from the collection.
Returns
TRUE to cancel removing the control.

Reimplemented in CXTPRibbonControls.

◆ Remove() [1/2]

virtual void Remove ( CXTPControl * pControl )
virtual

Call this member to remove a control.

Parameters
pControl Control to be removed.

Reimplemented in CXTPRibbonQuickAccessControls.

◆ Remove() [2/2]

void Remove ( int nIndex )

Call this member to remove a control.

Parameters
nIndex Index of the control to be removed.

◆ SetCommandBars()

void SetCommandBars ( CXTPCommandBars * pCommandBars )

Call this member to attach the specified command bars object.

Parameters
pCommandBars Command bars object to attach.

You can call this member if you create a plain toolbar and want to set CommandBars for it.

◆ SetControlType() [1/2]

CXTPControl * SetControlType | ( | CXTPControl * | pControl,
 |  | XTPControlType | type )

Call this member to change the type of the control.

Parameters
pControl | Pointer to a CXTPControl object
type | Type to be changed to.
Returns
A pointer to a CXTPControl object.

◆ SetControlType() [2/2]

CXTPControl * SetControlType | ( | int | nIndex,
 |  | XTPControlType | type )

Call this member to change the type of the control.

Parameters
nIndex | Index of the control.
type | Type to be changed to.
Returns
A pointer to a CXTPControl object.

◆ SetOriginalControls()

void SetOriginalControls ( CXTPOriginalControls * pControls )

Call this method to assign original controls.

Parameters
pControls A pointer to a CXTPControls object to assign.

◆ SetParent()

void SetParent ( CXTPCommandBar * pParent )

Attaches the parent command bar.

Parameters
pParent Pointer to a CXTPCommandBar object.

◆ ShouldSerializeControl()

virtual BOOL ShouldSerializeControl ( CXTPControl * pControl )
virtual

Call this method to check if the control has been changed and must be saved.

Parameters
pControl Control to be checked if it has been changed and must be saved.
Returns
TRUE if the control must be saved, otherwise FALSE.

Reimplemented in CXTPRibbonControls.

The documentation for this class was generated from the following file:
  • XTPControls.h


Toolkit Pro: CXTPControlScrollBar Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPControlScrollBar Class Reference

CXTPControlScrollBar is a CXTPControl derived class. More...

Inheritance diagram for CXTPControlScrollBar:
[legend]

Public Member Functions

CXTPControlScrollBar ()
Constructs a CXTPControlScrollBar object.
virtual | ~CXTPControlScrollBar ()
Destroys a CXTPControlScrollBar object, handles cleanup and deallocation.
void | SetPos (int nPos)
Call this member function to set the current position of the scrollbar.
int | GetPos () const
Call this member function to get the current position of the scrollbar.
void | SetRange (int nMin, int nMax)
Sets the upper and lower limits of the scrollbar control's range.
- Public Member Functions inherited from CXTPControl
void | SetStyle (XTPButtonStyle buttonStyle)
Call this member to set the style of the control.
XTPButtonStyle | GetStyle () const
Call this member to get the control's style.
void | SetCaption (LPCTSTR lpszCaption)
Call this member to set the caption of the control.
void | SetCaption (UINT nIDCaption)
Call this member to set the caption of the control.
virtual CString | GetCaption () const
Call this member to get the control's caption.
void | SetShortcutText (LPCTSTR lpszShortcutText)
Call this member to set the shortcut string to the control.
CString | GetShortcutText () const
Call this member to get the control's shortcut.
void | SetDescription (LPCTSTR lpszDescription)
Call this member to set the description of the control.
virtual CString | GetDescription () const
Call this member to get the control's description.
void | SetTooltip (LPCTSTR lpszTooltip)
Call this member to set the tooltip of the control.
virtual CString | GetTooltip () const
Call this member to get the control's tooltip.
void | SetKeyboardTip (LPCTSTR lpszKeyboardTip)
Call this member to set the keyboard tip to the control.
CString | GetKeyboardTip () const
Call this member to get the keyboard tip.
void | SetCustomShortcutText (LPCTSTR lpszCustomShortcutText)
Call this member to set the text displayed for the shortcut in a pop-up menu.
CString | GetCustomShortcutText () const
Call this member to get the control's text displayed for the shortcut in a pop-up menu.
void | SetParameter (LPCTSTR lpszParameter)
Call this member to set the parameter of the control.
CString | GetParameter () const
Call this member to get the control's parameter.
void | SetID (int nId)
Call this member to set the identifier of the control.
int | GetID () const
Call this member to get the control's identifier.
long | GetIndex () const
Call this member to get the index of the control.
void | SetIconId (int nId)
Call this member to set the control icon's identifier.
int | GetIconId () const
Call this member to get the icon's identifier.
void | SetHelpId (int nId)
Call this member to set the control help identifier.
int | GetHelpId () const
Call this member to get the help identifier.
virtual void | SetBeginGroup (BOOL bBeginGroup)
Call this member to begin a new group using a separator.
BOOL | GetBeginGroup () const
Call this member to determine if the control has a separator.
virtual void | SetEnabled (BOOL bEnabled)
Call this member to enable/disable the control.
BOOL | GetEnabled () const
Call this member to check if the control is enabled.
virtual void | OnEnabledChanged ()
This method is called when a control's enabled state is changed.
virtual void | SetChecked (BOOL bChecked)
Call this member to set the checked state of the control.
BOOL | GetChecked () const
Call this member to get the checked state of the control.
virtual int | GetSelected () const
Call this member to check if the control is selected.
void | SetOnQuickAccess (BOOL bOnQuicAccess=FALSE)
Call this member to set whether a control should be a part of the Quick Access panel.
BOOL | IsOnQuickAccess () const
Call this member to check if a control is a part of the Quick Access panel.
virtual void | SetFocused (BOOL bFocused)
Call this member to set the focused state of the control.
virtual BOOL | IsFocused () const
Call this member to check the focused state of the control.
void | SetPressed (BOOL bPressed)
Call this member to set the pressed state of the control.
virtual BOOL | GetPressed () const
Call this member to check the pressed state of the control.
virtual void | SetRect (CRect rcControl)
This member is called to set the bounding rectangle of the control.
CRect | GetRect () const
Call this member to get the bounding rectangle of the control.
CXTPCommandBar * | GetParent () const
Call this member to get the parent command bar.
virtual BOOL | IsVisible (DWORD dwSkipFlags=0) const
Call this member to determine if the control is visible.
virtual BOOL | IsCaptionVisible () const
Call this member to determine if the caption of the control is visible.
void | SetVisible (BOOL bVisible)
Call this member to set the visibility of the control.
CXTPControls * | GetControls () const
Call this member to get the parent controls collection.
XTPControlType | GetType () const
Call this member to get the control's type.
void | SetFlags (DWORD dwFlags)
Call this member to set the flags of the control.
DWORD | GetFlags () const
Call this member to retrieve control special flags.
void | SetTag (DWORD_PTR dwTag)
This method sets the 32-bit value associated with the control.
DWORD_PTR | GetTag () const
This method retrieves the application-supplied, 32-bit value associated with the control.
virtual BOOL | Compare (CXTPControl *pOther)
Call this member to compare controls.
virtual CXTPCommandBar * | GetCommandBar () const
Call this member to get the child command bar.
void | SetCloseSubMenuOnClick (BOOL bCloseOnClick)
Call this member function to enable/disable the closing of sub-menus when a control is clicked in the menu.
BOOL | GetCloseSubMenuOnClick () const
Call this member function to check if sub-menus will close as soon as a control is clicked.
void | SetExecuteOnPressInterval (int nExecuteOnPressInterval)
Call this method to set the delay (in milliseconds) between WM_COMMAND messages while a button is pressed by the user.
int | GetExecuteOnPressInterval () const
Call this method to get the delay (in milliseconds) between WM_COMMAND messages while a button is pressed by the user.
CXTPRibbonGroup * | GetRibbonGroup () const
Returns the ribbon group that the control belongs to.
virtual BOOL | IsTransparent () const
Determines if the control needs to draw its background.
void | SetHideWrap (BOOL bHide)
This method is called to hide the control.
virtual void | SetHideFlags (DWORD dwFlags)
This method is called to hide the control.
BOOL | SetHideFlag (XTPControlHideFlags dwFlag, BOOL bSet)
Call this member to set/remove hide flags.
DWORD | GetHideFlags () const
Call this method to retrieve hidden flags.
CRect | GetRowRect () const
Call this method to retrieve the position of the control's row.
BOOL | GetWrap () const
Call this method to check if the control is wrapped.
void | SetRowRect (CRect rcRow)
Call this method to set the row of the control.
void | SetWrap (BOOL bWrap)
Call this member to set the control to wrapped.
BOOL | GetExpanded () const
Call this member to check if the control is expanded.
BOOL | IsCursorOver () const
Call this member to determine if the mouse pointer is over the control.
virtual void | OnExecute ()
This method is called when the control is executed.
virtual CSize | GetSize (CDC *pDC)
This method is called to determine the size of the control.
virtual void | Draw (CDC *pDC)
This method is called to draw the control.
virtual void | OnCalcDynamicSize (DWORD dwMode)
This method is called before recalculating the parent command bar size to calculate the dimensions of the control.
void | DelayRedrawParent ()
Call this method to redraw the parent command bar.
void | DelayLayoutParent ()
Call this method to recalculate the parent command bar size.
void | SetCategory (LPCTSTR lpszCategory)
Call this method to set the category of the control.
CString | GetCategory () const
Call this method to retrieve the category of the control.
CXTPImageManager * | GetImageManager () const
Call this method to retrieve the image manager.
CXTPPaintManager * | GetPaintManager () const
Call this method to retrieve the paint manager.
virtual CXTPImageManagerIcon * | GetImage (int nWidth=16) const
Call this method to retrieve the image of the control.
void | AssignDocTemplate (UINT nIDResource)
Call this method to assign a document template to the control.
void | ExcludeDocTemplate (UINT nIDResource)
Call this method to exclude the document template from control.
BOOL | IsItemDefault () const
Call this method to check if a control is a default menu item.
void | SetItemDefault (BOOL bDefault)
Call this method to set a control to be a default menu item.
BOOL | IsTemporary () const
Call this method to determine if a control is temporary.
void | Reset ()
Call this member to reset the icon and caption of a control to its default settings before it was customized by the user.
void | SetPrompt (LPCTSTR lpszPrompt)
Call this member to load a string from a STRINGTABLE resource to set the tooltip and description of a control.
void | SetCustomIcon (HICON hIcon)
Call this member to set a custom icon to this control.
virtual void | DoPropExchange (CXTPPropExchange *pPX)
Either reads this object from or writes this object to an archive.
virtual void | OnUnderlineActivate ()
This method is called when the user activates the control using its underline.
virtual BOOL | GetPopuped () const
Call this member to get the control's pop-up state.
void | RedrawParent (BOOL bAnimate=TRUE)
This method is called to redraw the parent command bar.
LRESULT | NotifySite (UINT code)
This method is called to send message code to the parent site window.
LRESULT | NotifySite (UINT code, NMXTPCONTROL *pNM)
This method is called to send message code to the parent site window.
LRESULT | NotifySite (CWnd *pSite, UINT code, NMXTPCONTROL *pNM)
This method is called to send message code to the parent site window.
virtual void | SetAction (CXTPControlAction *pAction)
Call this method to manually assign an action for control.
CXTPControlAction * | GetAction () const
Call this method to retrieve an action associated with control.
virtual void | OnThemeChanged ()
This method is called when the paint manager theme is changed.
virtual void | SetWidth (int nWidth)
Call this member to set the width of the control.
virtual void | SetHeight (int nHeight)
Call this member to set the height of the control.
int | GetWidth () const
Call this member to get the width of the control.
int | GetHeight () const
Call this member to get the height of the control.
BOOL | HasDwmCompositedRect () const
This method is called to determine if control has a Vista DWM transparent area.
virtual CSize | GetButtonSize () const
Call this function to get the size of the command bar button.
virtual CSize | GetIconSize () const
Call this member function to get the size of a toolbar icon.
void | SetIconSize (CSize szIcon)
Call this member function to set the size of an icon for an individual control.
virtual void | Copy (CXTPControl *pControl, BOOL bRecursive=FALSE)
This method is called to copy the control.
virtual void | OnClick (BOOL bKeyboard=FALSE, CPoint pt=CPoint(0, 0))
This method is called when the user clicks the control.
virtual BOOL | IsCustomizeMovable () const
This method is called to determine if control can be repositioned in customize mode.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.
- Public Member Functions inherited from CXTPScrollBase
CXTPScrollBase ()
Constructs a CXTPScrollBase object.
virtual | ~CXTPScrollBase ()
Destroys a CXTPScrollBase object, handles cleanup and deallocation.
void | SetScrollBarStyle (XTPScrollBarStyle scrollStyle)
Call this method to set the style of the scrollbar.
XTPScrollBarStyle | GetScrollBarStyle () const
Call this method to get the style of the scrollbar.
XTP_SCROLLBAR_TRACKINFO * | GetScrollBarTrackInfo () const
Call this method to get XTP_SCROLLBAR_TRACKINFO information.
XTP_SCROLLBAR_POSINFO * GetScrollBarPosInfo ()
Call this method to get XTP_SCROLLBAR_POSINFO information.
virtual CWnd * | GetParentWindow () const =0
Retrieves parent window of scrollbar.
int | HitTestScrollBar (POINT pt) const
Call this method to check ScrollBar part under pointer.
CRect | GetScrollBarPartRect (int nPart) const
Gets the bounding rectangle of a specified part of the scrollbar.
void | PerformTrackInit (HWND hWnd, CPoint point, XTP_SCROLLBAR_POSINFO *pSBInfo, BOOL bDirect)
Call this method to start scrollbar tracking.
XTP_SLIDERTICKS * | GetTicks () const
Gets the ticks in the slider.
void | SetTicks (double *pTicks, int nCount)
Call this method to set ticks for the slider.
HBRUSH | GetCltColor (CDC *pDC) const
Call this method to get the scroll bar control color.
BOOL | IsSlider () const
Call this member function to determine if the scrollbar is a slider control.
virtual BOOL | IsScrollBarEnabled () const =0
Determines if the scrollbar is enabled.
virtual CXTPScrollBarPaintManager * | GetScrollBarPaintManager () const =0
Obtains a pointer to the associated scrollbar paint manager.
virtual CRect | GetScrollBarRect ()=0
Obtains the rectangle occupied by the scrollbar in client coordinates.
virtual void | GetScrollInfo (SCROLLINFO *psi)=0
The GetScrollInfo function retrieves the parameters of a scroll bar, including the minimum and maximum scrolling positions, the page size, and the position of the scroll box(thumb)
virtual void | RedrawScrollBar ()=0
Forces the scrollbar to redraw itself.

Protected Member Functions

virtual void | OnScroll (UINT nSBCode, UINT nPos)
This method is called when the position of the scrollbar is changed.
- Protected Member Functions inherited from CXTPControl
CXTPControl ()
Constructs a CXTPControl object.
virtual | ~CXTPControl ()
Destroys a CXTPControl object, handles cleanup and deallocation.
virtual BOOL | IsFocusable () const
This method is called to check if the control can accept focus.
void | SetIndex (int nIndex)
This method is called to assign the order of the control in the controls list.
void | SetExpanded (BOOL bExpanded)
This method is called to set the control's expanded state.
virtual BOOL | OnHookKeyDown (UINT nChar, LPARAM lParam)
This method is called when a non-system key is pressed.
virtual BOOL | OnHookMouseWheel (UINT nFlags, short zDelta, CPoint point)
This method is called when the user rotates the mouse wheel.
virtual void | SetParent (CXTPCommandBar *pParent)
This method is called to assign a parent command bar object.
void | ScreenToClient (CPoint *point)
The ScreenToClient function converts the screen coordinates of a specified point on the screen.
void | ClickToolBarButton (CRect rcActiveRect=CRect(0, 0, 0, 0))
This helper method is called when the user clicks the toolbar's button.
virtual BOOL | OnSetPopup (BOOL bPopup)
This method is called to pop-up the control.
virtual void | OnLButtonUp (CPoint point)
This member is called when the user releases the left mouse button.
virtual void | OnLButtonDown (CPoint point)
This member is called when the user presses the left mouse button down.
virtual BOOL | OnRButtonDown (CPoint point)
This member is called when the user press the right mouse button.
virtual BOOL | OnRButtonUp (CPoint point)
This member is called when the user releases the right mouse button.
virtual BOOL | OnLButtonDblClk (CPoint point)
This member is called when the user double-clicks the left mouse button.
virtual void | OnMouseMove (CPoint point)
This member is called when the mouse cursor moves.
virtual void | OnMouseHover ()
Called after the mouse hovers over the control.
virtual BOOL | OnSetSelected (int bSelected)
This method is called when the control becomes selected.
BOOL | IsCustomizeMode () const
Call this method to determine if command bars is in customize mode.
virtual void | CustomizeStartDrag (CPoint point)
This member is called when the user starts to drag the control in customize mode.
virtual BOOL | CustomizeStartResize (CPoint point)
This method is called when user starts to resize control in customize mode.
virtual void | OnCustomizeDragOver (CXTPControl *pDataObject, CPoint point, DROPEFFECT &dropEffect)
This member is called when the user moves the mouse over the control.
virtual BOOL | DoCustomDragOver (CXTPCommandBar *pCommandBar, CPoint point, DROPEFFECT &dropEffect)
The implementation may implement a custom drag over handling logic in this method.
virtual BOOL | IsCustomizeResizeAllow () const
This member checks if the user can resize the control.
virtual int | GetCustomizeMinWidth () const
Retrieves the available minimum width of control.
virtual int | GetCustomizeMinHeight () const
Retrieves available minimum height of the control.
void | OnCustomizeMouseMove (CPoint point)
This member is called when the mouse cursor moves in customized mode.
virtual void | OnIdleUpdate ()
This virtual method is called in idle-time processing.
virtual void | OnRemoved ()
This method is called when a control is removed from the parent controls collection.
virtual INT_PTR | OnToolHitTest (CPoint point, TOOLINFO *pTI) const
The framework calls this member function to determine whether a point is in the bounding rectangle of the specified tool.
virtual void | RestoreCommandBarList (CXTPCommandBarList *pCommandBarList)
This method is called from LoadCommandBars to restore controls and its child command bars.
virtual void | GenerateCommandBarList (DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam)
This method is called from SaveCommandBars to save all child command bars.
virtual void | OnActionChanged (int nProperty)
This method is called when an action property is changed.
virtual void | OnActionChanging (int nProperty)
This method is called when an action property is about to be changed.
virtual void | OnCaptionChanged ()
This method is called when the control's caption is changed.
BOOL | IsLayoutRTL () const
Determines if right-to-left (RTL) mode is set.
BOOL | IsLayoutChanged ()
Call this member to determine if the layout has changed (RTL to LTR or LTR to RLT).

Protected Attributes

int | m_nMin
Lower range.
int | m_nMax
Upper range.
int | m_nPos
Current position of scrollbar.
int | m_nPage
Current page of the scrollbar.
- Protected Attributes inherited from CXTPControl
DWORD_PTR | m_nTag
Control tag.
int | m_nIndex
Index of the control.
int | m_nId
Identifier of the control.
int | m_nIconId
Identifier of the control's image.
int | m_nHelpId
Help identifier.
int | m_nCustomIconId
Identifier of the control's custom image.
BOOL | m_bWrap
TRUE if the control is wrapped.
BOOL | m_bBeginGroup
TRUE if the control starts new group.
BOOL | m_bEnabled
TRUE if the control is enabled.
BOOL | m_bChecked
TRUE if the control is checked.
BOOL | m_bSelected
TRUE if the control is selected.
BOOL | m_bPressed
TRUE if the control is pushed.
BOOL | m_bTemporary
TRUE if the control is temporary.
BOOL | m_bOnQuickAccess
TRUE if the control is a part of Quick Access panel.
CRect | m_rcRow
Bounding rectangle of the control's row.
CRect | m_rcControl
Bounding rectangle of the control.
DWORD | m_dwHideFlags
Hidden flags.
DWORD | m_dwFlags
Flags of the control.
CString | m_strCaption
Caption of the control.
CString | m_strCustomCaption
User-defined caption.
CString | m_strShortcutText
Shortcut text.
CString | m_strShortcutTextAuto
Shortcut text.
CString | m_strTooltipText
Tooltip text.
CString | m_strDescriptionText
Description text.
CString | m_strParameter
Parameter text.
CString | m_strKeyboardTip
Keyboard tip.
CXTPControls * | m_pControls
Parent control collection.
XTPControlType | m_controlType
Type of the control.
CXTPCommandBar * | m_pParent
The Parent command bar.
BOOL | m_bExpanded
TRUE if the control is expanded.
CString | m_strCategory
Category of the control.
BOOL | m_bDefaultItem
TRUE if the item is default pop-up item.
CDocTemplateMap | m_mapDocTemplatesAssigned
Assigned templates.
CDocTemplateMap | m_mapDocTemplatesExcluded
Excluded templates.
XTPButtonStyle | m_buttonStyle
Button Style.
XTPButtonStyle | m_buttonCustomStyle
User-defined style of button.
XTPButtonStyle | m_buttonRibbonStyle
User-defined style of button.
BOOL | m_bCloseSubMenuOnClick
TRUE is sub-menus are closed as soon as a control is clicked.
CXTPRibbonGroup * | m_pRibbonGroup
Ribbon group of control.
CXTPControlAction * | m_pAction
Action of the control.
int | m_nWidth
Width of the control.
int | m_nHeight
Height of the control.
int | m_nExecuteOnPressInterval
Delay between each message when control is pressed.
CSize | m_szIcon
The size of the icon used for the control.
BOOL | m_bLayoutRTL
Indicate does last layout is RTL.
- Protected Attributes inherited from CXTPScrollBase
XTP_SCROLLBAR_POSINFO | m_spi
ScrollBar position.
XTP_SCROLLBAR_TRACKINFO * | m_pSBTrack
ScrollBar tracking.
XTP_SLIDERTICKS * | m_pTicks
Slider Ticks.
XTPScrollBarStyle | m_scrollBarStyle
ScrollBar style.
BOOL | m_bAnimation
TRUE if animation enabled.
int | m_nTimerElapse
Scroll delay.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControl
static CXTPControl *AFX_CDECL | FromUI (CCmdUI *pCmdUI)
Call this member to retrieve CXTPControl from a CCmdUI structure.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

CXTPControlScrollBar is a CXTPControl derived class.

It represents a scrollbar control.

Member Function Documentation

◆ GetPos()

int GetPos ( ) const

Call this member function to get the current position of the scrollbar.

Returns
The position of the scrollbar control.
See also
SetPos

◆ OnScroll()

virtual void OnScroll | ( | UINT | nSBCode,
 |  | UINT | nPos )
 protectedvirtual

This method is called when the position of the scrollbar is changed.

Parameters
nSBCode | Specifies a scrollbar code that indicates the user's scrolling request.
nPos | Contains the current scroll-box position.

◆ SetPos()

void SetPos ( int nPos )

Call this member function to set the current position of the scrollbar.

Parameters
nPos New position of the scrollbar control.
See also
GetPos, SetRange

◆ SetRange()

void SetRange | ( | int | nMin,
 |  | int | nMax )

Sets the upper and lower limits of the scrollbar control's range.

Parameters
nMin | Specifies the lower limit of the range.
nMax | Specifies the upper limit of the range.
See also
SetPos
The documentation for this class was generated from the following file:
  • XTPControlScrollBar.h


Toolkit Pro: CXTPControlSelector Class Reference

Public Member Functions | Public Attributes | Protected Member Functions | List of all members
CXTPControlSelector Class Reference

CXTPControlSelector is a CXTPControl derived class that represents a control selector. More...

Inheritance diagram for CXTPControlSelector:
[legend]

Public Member Functions

CXTPControlSelector ()
Constructs a CXTPControlSelector object.
- Public Member Functions inherited from CXTPControl
void | SetStyle (XTPButtonStyle buttonStyle)
Call this member to set the style of the control.
XTPButtonStyle | GetStyle () const
Call this member to get the control's style.
void | SetCaption (LPCTSTR lpszCaption)
Call this member to set the caption of the control.
void | SetCaption (UINT nIDCaption)
Call this member to set the caption of the control.
virtual CString | GetCaption () const
Call this member to get the control's caption.
void | SetShortcutText (LPCTSTR lpszShortcutText)
Call this member to set the shortcut string to the control.
CString | GetShortcutText () const
Call this member to get the control's shortcut.
void | SetDescription (LPCTSTR lpszDescription)
Call this member to set the description of the control.
virtual CString | GetDescription () const
Call this member to get the control's description.
void | SetTooltip (LPCTSTR lpszTooltip)
Call this member to set the tooltip of the control.
virtual CString | GetTooltip () const
Call this member to get the control's tooltip.
void | SetKeyboardTip (LPCTSTR lpszKeyboardTip)
Call this member to set the keyboard tip to the control.
CString | GetKeyboardTip () const
Call this member to get the keyboard tip.
void | SetCustomShortcutText (LPCTSTR lpszCustomShortcutText)
Call this member to set the text displayed for the shortcut in a pop-up menu.
CString | GetCustomShortcutText () const
Call this member to get the control's text displayed for the shortcut in a pop-up menu.
void | SetParameter (LPCTSTR lpszParameter)
Call this member to set the parameter of the control.
CString | GetParameter () const
Call this member to get the control's parameter.
void | SetID (int nId)
Call this member to set the identifier of the control.
int | GetID () const
Call this member to get the control's identifier.
long | GetIndex () const
Call this member to get the index of the control.
void | SetIconId (int nId)
Call this member to set the control icon's identifier.
int | GetIconId () const
Call this member to get the icon's identifier.
void | SetHelpId (int nId)
Call this member to set the control help identifier.
int | GetHelpId () const
Call this member to get the help identifier.
virtual void | SetBeginGroup (BOOL bBeginGroup)
Call this member to begin a new group using a separator.
BOOL | GetBeginGroup () const
Call this member to determine if the control has a separator.
virtual void | SetEnabled (BOOL bEnabled)
Call this member to enable/disable the control.
BOOL | GetEnabled () const
Call this member to check if the control is enabled.
virtual void | OnEnabledChanged ()
This method is called when a control's enabled state is changed.
virtual void | SetChecked (BOOL bChecked)
Call this member to set the checked state of the control.
BOOL | GetChecked () const
Call this member to get the checked state of the control.
virtual int | GetSelected () const
Call this member to check if the control is selected.
void | SetOnQuickAccess (BOOL bOnQuicAccess=FALSE)
Call this member to set whether a control should be a part of the Quick Access panel.
BOOL | IsOnQuickAccess () const
Call this member to check if a control is a part of the Quick Access panel.
virtual void | SetFocused (BOOL bFocused)
Call this member to set the focused state of the control.
virtual BOOL | IsFocused () const
Call this member to check the focused state of the control.
void | SetPressed (BOOL bPressed)
Call this member to set the pressed state of the control.
virtual BOOL | GetPressed () const
Call this member to check the pressed state of the control.
virtual void | SetRect (CRect rcControl)
This member is called to set the bounding rectangle of the control.
CRect | GetRect () const
Call this member to get the bounding rectangle of the control.
CXTPCommandBar * | GetParent () const
Call this member to get the parent command bar.
virtual BOOL | IsVisible (DWORD dwSkipFlags=0) const
Call this member to determine if the control is visible.
virtual BOOL | IsCaptionVisible () const
Call this member to determine if the caption of the control is visible.
void | SetVisible (BOOL bVisible)
Call this member to set the visibility of the control.
CXTPControls * | GetControls () const
Call this member to get the parent controls collection.
XTPControlType | GetType () const
Call this member to get the control's type.
void | SetFlags (DWORD dwFlags)
Call this member to set the flags of the control.
DWORD | GetFlags () const
Call this member to retrieve control special flags.
void | SetTag (DWORD_PTR dwTag)
This method sets the 32-bit value associated with the control.
DWORD_PTR | GetTag () const
This method retrieves the application-supplied, 32-bit value associated with the control.
virtual BOOL | Compare (CXTPControl *pOther)
Call this member to compare controls.
virtual CXTPCommandBar * | GetCommandBar () const
Call this member to get the child command bar.
void | SetCloseSubMenuOnClick (BOOL bCloseOnClick)
Call this member function to enable/disable the closing of sub-menus when a control is clicked in the menu.
BOOL | GetCloseSubMenuOnClick () const
Call this member function to check if sub-menus will close as soon as a control is clicked.
void | SetExecuteOnPressInterval (int nExecuteOnPressInterval)
Call this method to set the delay (in milliseconds) between WM_COMMAND messages while a button is pressed by the user.
int | GetExecuteOnPressInterval () const
Call this method to get the delay (in milliseconds) between WM_COMMAND messages while a button is pressed by the user.
CXTPRibbonGroup * | GetRibbonGroup () const
Returns the ribbon group that the control belongs to.
virtual BOOL | IsTransparent () const
Determines if the control needs to draw its background.
void | SetHideWrap (BOOL bHide)
This method is called to hide the control.
virtual void | SetHideFlags (DWORD dwFlags)
This method is called to hide the control.
BOOL | SetHideFlag (XTPControlHideFlags dwFlag, BOOL bSet)
Call this member to set/remove hide flags.
DWORD | GetHideFlags () const
Call this method to retrieve hidden flags.
CRect | GetRowRect () const
Call this method to retrieve the position of the control's row.
BOOL | GetWrap () const
Call this method to check if the control is wrapped.
void | SetRowRect (CRect rcRow)
Call this method to set the row of the control.
void | SetWrap (BOOL bWrap)
Call this member to set the control to wrapped.
BOOL | GetExpanded () const
Call this member to check if the control is expanded.
BOOL | IsCursorOver () const
Call this member to determine if the mouse pointer is over the control.
virtual void | OnExecute ()
This method is called when the control is executed.
void | DelayRedrawParent ()
Call this method to redraw the parent command bar.
void | DelayLayoutParent ()
Call this method to recalculate the parent command bar size.
void | SetCategory (LPCTSTR lpszCategory)
Call this method to set the category of the control.
CString | GetCategory () const
Call this method to retrieve the category of the control.
CXTPImageManager * | GetImageManager () const
Call this method to retrieve the image manager.
CXTPPaintManager * | GetPaintManager () const
Call this method to retrieve the paint manager.
virtual CXTPImageManagerIcon * | GetImage (int nWidth=16) const
Call this method to retrieve the image of the control.
void | AssignDocTemplate (UINT nIDResource)
Call this method to assign a document template to the control.
void | ExcludeDocTemplate (UINT nIDResource)
Call this method to exclude the document template from control.
BOOL | IsItemDefault () const
Call this method to check if a control is a default menu item.
void | SetItemDefault (BOOL bDefault)
Call this method to set a control to be a default menu item.
BOOL | IsTemporary () const
Call this method to determine if a control is temporary.
void | Reset ()
Call this member to reset the icon and caption of a control to its default settings before it was customized by the user.
void | SetPrompt (LPCTSTR lpszPrompt)
Call this member to load a string from a STRINGTABLE resource to set the tooltip and description of a control.
void | SetCustomIcon (HICON hIcon)
Call this member to set a custom icon to this control.
virtual void | OnUnderlineActivate ()
This method is called when the user activates the control using its underline.
virtual BOOL | GetPopuped () const
Call this member to get the control's pop-up state.
void | RedrawParent (BOOL bAnimate=TRUE)
This method is called to redraw the parent command bar.
LRESULT | NotifySite (UINT code)
This method is called to send message code to the parent site window.
LRESULT | NotifySite (UINT code, NMXTPCONTROL *pNM)
This method is called to send message code to the parent site window.
LRESULT | NotifySite (CWnd *pSite, UINT code, NMXTPCONTROL *pNM)
This method is called to send message code to the parent site window.
virtual void | SetAction (CXTPControlAction *pAction)
Call this method to manually assign an action for control.
CXTPControlAction * | GetAction () const
Call this method to retrieve an action associated with control.
virtual void | OnThemeChanged ()
This method is called when the paint manager theme is changed.
virtual void | SetWidth (int nWidth)
Call this member to set the width of the control.
virtual void | SetHeight (int nHeight)
Call this member to set the height of the control.
int | GetWidth () const
Call this member to get the width of the control.
int | GetHeight () const
Call this member to get the height of the control.
BOOL | HasDwmCompositedRect () const
This method is called to determine if control has a Vista DWM transparent area.
virtual CSize | GetButtonSize () const
Call this function to get the size of the command bar button.
virtual CSize | GetIconSize () const
Call this member function to get the size of a toolbar icon.
void | SetIconSize (CSize szIcon)
Call this member function to set the size of an icon for an individual control.
virtual void | OnClick (BOOL bKeyboard=FALSE, CPoint pt=CPoint(0, 0))
This method is called when the user clicks the control.
virtual BOOL | IsCustomizeMovable () const
This method is called to determine if control can be repositioned in customize mode.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Public Attributes

CSize | m_szItemsCount
Number of items to draw in the control selector's view.
CSize | m_szItemsMax
Maximum number of items to draw in the control selector.
CSize | m_szItemsActive
Number of items currently "active".
CSize | m_szItem
Size of the items.
CSize | m_szResult
Number of items that were selected from the control selector.
CSize | m_szItemsVisible
Number of items currently visible.

Protected Member Functions

CSize | GetSize (CDC *pDC)
This method is called to determine the size of the control.
void | Draw (CDC *pDC)
This method is called to draw the control.
void | OnMouseMove (CPoint point)
This member is called when the mouse cursor moves.
BOOL | OnSetSelected (int bSelected)
This method is called when the control becomes selected.
void | OnLButtonUp (CPoint point)
This member is called when the user releases the left mouse button.
virtual void | OnCalcDynamicSize (DWORD dwMode)
This method is called before recalculating the parent command bar size to calculate the dimensions of the control.
void | Copy (CXTPControl *pControl, BOOL bRecursive=FALSE)
This method is called to copy the control.
void | DoPropExchange (CXTPPropExchange *pPX)
Either reads this object from or writes this object to an archive.
void | SetItemsActive (CSize szActive, BOOL bNotify=FALSE)
This member is called to set the number of active items.
virtual void | OnDrawItem (CDC *pDC, CRect rcItem, COLORREF clrText)
This member is called when a control item in the control selector is drawn.
- Protected Member Functions inherited from CXTPControl
CXTPControl ()
Constructs a CXTPControl object.
virtual | ~CXTPControl ()
Destroys a CXTPControl object, handles cleanup and deallocation.
virtual BOOL | IsFocusable () const
This method is called to check if the control can accept focus.
void | SetIndex (int nIndex)
This method is called to assign the order of the control in the controls list.
void | SetExpanded (BOOL bExpanded)
This method is called to set the control's expanded state.
virtual BOOL | OnHookKeyDown (UINT nChar, LPARAM lParam)
This method is called when a non-system key is pressed.
virtual BOOL | OnHookMouseWheel (UINT nFlags, short zDelta, CPoint point)
This method is called when the user rotates the mouse wheel.
virtual void | SetParent (CXTPCommandBar *pParent)
This method is called to assign a parent command bar object.
void | ScreenToClient (CPoint *point)
The ScreenToClient function converts the screen coordinates of a specified point on the screen.
void | ClickToolBarButton (CRect rcActiveRect=CRect(0, 0, 0, 0))
This helper method is called when the user clicks the toolbar's button.
virtual BOOL | OnSetPopup (BOOL bPopup)
This method is called to pop-up the control.
virtual void | OnLButtonDown (CPoint point)
This member is called when the user presses the left mouse button down.
virtual BOOL | OnRButtonDown (CPoint point)
This member is called when the user press the right mouse button.
virtual BOOL | OnRButtonUp (CPoint point)
This member is called when the user releases the right mouse button.
virtual BOOL | OnLButtonDblClk (CPoint point)
This member is called when the user double-clicks the left mouse button.
virtual void | OnMouseHover ()
Called after the mouse hovers over the control.
BOOL | IsCustomizeMode () const
Call this method to determine if command bars is in customize mode.
virtual void | CustomizeStartDrag (CPoint point)
This member is called when the user starts to drag the control in customize mode.
virtual BOOL | CustomizeStartResize (CPoint point)
This method is called when user starts to resize control in customize mode.
virtual void | OnCustomizeDragOver (CXTPControl *pDataObject, CPoint point, DROPEFFECT &dropEffect)
This member is called when the user moves the mouse over the control.
virtual BOOL | DoCustomDragOver (CXTPCommandBar *pCommandBar, CPoint point, DROPEFFECT &dropEffect)
The implementation may implement a custom drag over handling logic in this method.
virtual BOOL | IsCustomizeResizeAllow () const
This member checks if the user can resize the control.
virtual int | GetCustomizeMinWidth () const
Retrieves the available minimum width of control.
virtual int | GetCustomizeMinHeight () const
Retrieves available minimum height of the control.
void | OnCustomizeMouseMove (CPoint point)
This member is called when the mouse cursor moves in customized mode.
virtual void | OnIdleUpdate ()
This virtual method is called in idle-time processing.
virtual void | OnRemoved ()
This method is called when a control is removed from the parent controls collection.
virtual INT_PTR | OnToolHitTest (CPoint point, TOOLINFO *pTI) const
The framework calls this member function to determine whether a point is in the bounding rectangle of the specified tool.
virtual void | RestoreCommandBarList (CXTPCommandBarList *pCommandBarList)
This method is called from LoadCommandBars to restore controls and its child command bars.
virtual void | GenerateCommandBarList (DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam)
This method is called from SaveCommandBars to save all child command bars.
virtual void | OnActionChanged (int nProperty)
This method is called when an action property is changed.
virtual void | OnActionChanging (int nProperty)
This method is called when an action property is about to be changed.
virtual void | OnCaptionChanged ()
This method is called when the control's caption is changed.
BOOL | IsLayoutRTL () const
Determines if right-to-left (RTL) mode is set.
BOOL | IsLayoutChanged ()
Call this member to determine if the layout has changed (RTL to LTR or LTR to RLT).

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControl
static CXTPControl *AFX_CDECL | FromUI (CCmdUI *pCmdUI)
Call this member to retrieve CXTPControl from a CCmdUI structure.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Attributes inherited from CXTPControl
DWORD_PTR | m_nTag
Control tag.
int | m_nIndex
Index of the control.
int | m_nId
Identifier of the control.
int | m_nIconId
Identifier of the control's image.
int | m_nHelpId
Help identifier.
int | m_nCustomIconId
Identifier of the control's custom image.
BOOL | m_bWrap
TRUE if the control is wrapped.
BOOL | m_bBeginGroup
TRUE if the control starts new group.
BOOL | m_bEnabled
TRUE if the control is enabled.
BOOL | m_bChecked
TRUE if the control is checked.
BOOL | m_bSelected
TRUE if the control is selected.
BOOL | m_bPressed
TRUE if the control is pushed.
BOOL | m_bTemporary
TRUE if the control is temporary.
BOOL | m_bOnQuickAccess
TRUE if the control is a part of Quick Access panel.
CRect | m_rcRow
Bounding rectangle of the control's row.
CRect | m_rcControl
Bounding rectangle of the control.
DWORD | m_dwHideFlags
Hidden flags.
DWORD | m_dwFlags
Flags of the control.
CString | m_strCaption
Caption of the control.
CString | m_strCustomCaption
User-defined caption.
CString | m_strShortcutText
Shortcut text.
CString | m_strShortcutTextAuto
Shortcut text.
CString | m_strTooltipText
Tooltip text.
CString | m_strDescriptionText
Description text.
CString | m_strParameter
Parameter text.
CString | m_strKeyboardTip
Keyboard tip.
CXTPControls * | m_pControls
Parent control collection.
XTPControlType | m_controlType
Type of the control.
CXTPCommandBar * | m_pParent
The Parent command bar.
BOOL | m_bExpanded
TRUE if the control is expanded.
CString | m_strCategory
Category of the control.
BOOL | m_bDefaultItem
TRUE if the item is default pop-up item.
CDocTemplateMap | m_mapDocTemplatesAssigned
Assigned templates.
CDocTemplateMap | m_mapDocTemplatesExcluded
Excluded templates.
XTPButtonStyle | m_buttonStyle
Button Style.
XTPButtonStyle | m_buttonCustomStyle
User-defined style of button.
XTPButtonStyle | m_buttonRibbonStyle
User-defined style of button.
BOOL | m_bCloseSubMenuOnClick
TRUE is sub-menus are closed as soon as a control is clicked.
CXTPRibbonGroup * | m_pRibbonGroup
Ribbon group of control.
CXTPControlAction * | m_pAction
Action of the control.
int | m_nWidth
Width of the control.
int | m_nHeight
Height of the control.
int | m_nExecuteOnPressInterval
Delay between each message when control is pressed.
CSize | m_szIcon
The size of the icon used for the control.
BOOL | m_bLayoutRTL
Indicate does last layout is RTL.

Detailed Description

CXTPControlSelector is a CXTPControl derived class that represents a control selector.

A control selector is an x by y grid of controls of which can be selected by the user. This control is like the "Insert Table" and "Insert Column" controls seen in Microsoft Word.

When the control selector is created, m_szItemsCount holds the number items that will initially be shown. By clicking and dragging inside the control selector, up to m_szItemsMax items can be shown. For example, if m_szItemsCount = CSize(5, 4) and m_szItemsMax = CSize(12, 12), then the control selector will always display a 5x4 grid of items unless the mouse is clicked and dragged to expand the grid up to 12x12.

The size of the items is set by m_szItem, all items in the grid will be sized according to m_szItem.

The current number of active items (highlighted items) is stored in m_szItemsActive. OnLButtonUp will store the number of selected items in m_szResult.

When the number of selected (active/highlighted) items changes, XTP_SLN_SELCHANGE is sent in a message to the parent command bar. The message is sent while in the SetItemsActive function.

The Office 2003 GUI sample illustrates how to use this class.

Member Function Documentation

◆ Copy()

void Copy | ( | CXTPControl * | pControl,
 |  | BOOL | bRecursive = FALSE )
 protectedvirtual

This method is called to copy the control.

Parameters
pControl | Pointer to a source CXTPControl object.
bRecursive | TRUE to copy recursively.

Reimplemented from CXTPControl.

◆ DoPropExchange()

void DoPropExchange ( CXTPPropExchange * pPX )
protectedvirtual

Either reads this object from or writes this object to an archive.

Parameters
pPX A CXTPPropExchange object to serialize to or from.

Reimplemented from CXTPControl.

◆ Draw()

void Draw ( CDC * pDC )
protectedvirtual

This method is called to draw the control.

Parameters
pDC Pointer to a valid device context.

Reimplemented from CXTPControl.

◆ GetSize()

CSize GetSize ( CDC * pDC )
protectedvirtual

This method is called to determine the size of the control.

Parameters
pDC Pointer to a valid device context.
Returns
A CSize object containing the size of the control.

Reimplemented from CXTPControl.

◆ OnCalcDynamicSize()

virtual void OnCalcDynamicSize ( DWORD dwMode )
protectedvirtual

This method is called before recalculating the parent command bar size to calculate the dimensions of the control.

Parameters
dwMode Flags used to determine the height and width of the dynamic command bar. See Remarks section for a list of values.

The following predefined flags are used to determine the height and width of the dynamic command bar. Use the bitwise-OR (|) operator to combine the flags.

LM_STRETCH: Indicates whether the command bar should be stretched to the size of the frame. Set if the bar is not a docking bar (not available for docking). Not set when the bar is docked or floating (available for docking). If set, LM_STRETCH returns dimensions based on the LM_HORZ state. LM_STRETCH works similarly to the the bStretch parameter used in CalcFixedLayout; see that member function for more information about the relationship between stretching and orientation. LM_HORZ: Indicates that the bar is horizontally or vertically oriented. Set if the bar is horizontally oriented, and if it is vertically oriented, it is not set. LM_HORZ works similarly to the the bHorz parameter used in CalcFixedLayout; see that member function for more information about the relationship between stretching and orientation. LM_MRUWIDTH: Most Recently Used Dynamic Width. Uses the remembered most recently used width. LM_HORZDOCK: Horizontal Docked Dimensions. Returns the dynamic size with the largest width. LM_VERTDOCK: Vertical Docked Dimensions. Returns the dynamic size with the largest height. LM_COMMIT: Resets LM_MRUWIDTH to the current width of the floating command bar.

The framework calls this member function to calculate the dimensions of a dynamic command bar.

Override this member function to provide your own layout in classes you derive from CXTPControl. XTP classes derived from CXTPControl, such as CXTPControlComboBox, override this member function to provide their own implementation.

See also
CXTPControlComboBox, CXTPControlCustom, CXTPControlEdit, CXTPControlWindowList, CXTPControlWorkspaceActions, CXTPControlToolbars, CXTPControlOleItems, CXTPControlRecentFileList, CXTPControl, CXTPControlListBox

Reimplemented from CXTPControl.

◆ OnDrawItem()

virtual void OnDrawItem | ( | CDC * | pDC,
 |  | CRect | rcItem,
 |  | COLORREF | clrText )
 protectedvirtual

This member is called when a control item in the control selector is drawn.

Parameters
pDC | Pointer to a valid device context.
rcItem | Bounding rectangle of item being drawn.
clrText | Color to use when drawing.

Override this member to draw your own custom control. In the Office 2003 GUI sample, this is used to draw the column lines in the column selector control.

◆ OnLButtonUp()

void OnLButtonUp ( CPoint point )
protectedvirtual

This member is called when the user releases the left mouse button.

Parameters
point Specifies the x- and y- coordinates of the cursor.

Reimplemented from CXTPControl.

◆ OnMouseMove()

void OnMouseMove ( CPoint point )
protectedvirtual

This member is called when the mouse cursor moves.

Parameters
point Specifies the x- and y- coordinates of the cursor.

Reimplemented from CXTPControl.

◆ OnSetSelected()

BOOL OnSetSelected ( int bSelected )
protectedvirtual

This method is called when the control becomes selected.

Parameters
bSelected TRUE if the control becomes selected.
Returns
TRUE if successful, otherwise FALSE.

Reimplemented from CXTPControl.

◆ SetItemsActive()

void SetItemsActive | ( | CSize | szActive,
 |  | BOOL | bNotify = FALSE )
 protected

This member is called to set the number of active items.

Parameters
szActive | Number of active items (on screen). If m_szItemsActive is not equal to szActive, then SetItemsActive will set m_szItemsActive = szActive.
bNotify | TRUE to send XTP_SLN_SELCHANGE message to parent commandbar even if m_szItemsActive = szActive. This is necessary when the number of items has changed and m_szItemsActive = szActive, which occurs when the mouse is clicked and dragged to select items more items than are currently visible.

Active items are the items that are currently highlighted in the control selector.

See also
XTP_SLN_SELCHANGE

Member Data Documentation

◆ m_szItemsActive

CSize m_szItemsActive

Number of items currently "active".

This is current number of items that are highlighted as the mouse moves across the control selector.

◆ m_szItemsCount

CSize m_szItemsCount

Number of items to draw in the control selector's view.

By clicking and dragging the mouse, the number of items drawn can be up to m_szItemsMax.

◆ m_szItemsVisible

CSize m_szItemsVisible

Number of items currently visible.

Item range is from m_szItemsCount to m_szItemsMax.

The documentation for this class was generated from the following file:
  • XTPControlExt.h


Toolkit Pro: CXTPControlSizeComboBox Class Reference

Public Member Functions | Static Public Member Functions | Protected Member Functions | List of all members
CXTPControlSizeComboBox Class Reference

CXTPControlSizeComboBox is a CXTPControlComboBox derived class. More...

Inheritance diagram for CXTPControlSizeComboBox:
[legend]

Public Member Functions

CXTPControlSizeComboBox ()
Constructs a CXTPControlSizeComboBox object.
virtual | ~CXTPControlSizeComboBox ()
Destroys a CXTPControlSizeComboBox object, handles cleanup and deallocation.
void | SetTwipSize (int nTwips)
Call this method to set the current size.
- Public Member Functions inherited from CXTPControlComboBox
CXTPControlComboBox (CXTPCommandBars *pCommandBars=NULL)
Constructs a CXTPControlComboBox object.
virtual | ~CXTPControlComboBox ()
Destroys a CXTPControlComboBox object, handles cleanup and deallocation.
DWORD | GetEditStyle () const
Call this member to get the style of edit control.
void | SetEditStyle (DWORD dwStyle)
Call this member to set the style of edit control.
void | SetDropDownListStyle (BOOL bSet=TRUE)
Call this member to insert/delete an edit box in the combobox when the control has focus.
BOOL | GetDropDownListStyle () const
Call this member to determine if the combobox has an edit control.
void | SetDropDownWidth (int nWidth)
Call this member to set the width of the dropdown list.
void | SetDropDownItemCount (int nDropDownItemCount)
Call this member to set the count of items in the dropdown list.
int | GetDropDownWidth () const
Call this member to retrieve the dropdown list width.
int | AddString (LPCTSTR lpsz)
Call this member function to add a string to a list box.
int | GetCount () const
Call this member to retrieve the number of items in a list box.
void | GetLBText (int nIndex, CString &str) const
Call this member to retrieve a string from the list box of a combobox control.
void | ResetContent ()
Call this member to remove all items from the list box of a combobox control.
int | FindStringExact (int nIndexStart, LPCTSTR lpsz) const
Call this member to find the first list-box string (in a combobox) that matches the string specified in str.
int | InsertString (int nIndex, LPCTSTR lpsz)
Call this member to insert a string into the list box of a combobox control.
virtual CString | GetListBoxText () const
Call this member to get the currently selected item's text.
CXTPControlComboBoxEditCtrl * | GetEditCtrl () const
Call this member to get the edit control of the combobox control.
void | SetCurSel (int nIndex)
Call this member to select a string in the list box of a combobox.
int | GetCurSel () const
Call this member function to determine which item in the combobox is selected.
BOOL | GetDroppedState () const
Call the GetDroppedState member function to determine whether the list box of a drop-down combobox is visible (dropped down).
CString | GetEditText () const
Call this member to get the edit text.
void | ModifyListBoxStyle (DWORD dwRemove, DWORD dwAdd)
Call this member to modify the style of a list box.
void | SetEditText (const CString &lpszText)
Call this member to set the edit control text.
void | SetEditHint (LPCTSTR lpszEditHint)
Call this member to set the grayed-out text displayed in the edit control which provides a helpful description of what the control is used for.
CString | GetEditHint () const
Call this member to get the grayed-out text displayed in the edit control which provides a helpful description of what the control is used for.
virtual CHARFORMAT2 | GetDefaultCharFormat ()
This method is called to get the default char format of rich edit text.
void | EnableShellAutoComplete (DWORD dwFlags=SHACF_FILESYSTEM|SHACF_URLALL)
This member function enables or disables shell auto completion.
void | EnableAutoComplete (BOOL bAutoComplete=TRUE)
This member function enables or disables auto completion.
int | FindString (int nStartAfter, LPCTSTR lpszItem) const
This method finds the first string in a list box that contains the specified prefix, without changing the list-box selection.
DWORD_PTR | GetItemData (int nIndex) const
This method retrieves the application-supplied, 32-bit value associated with the specified combobox item.
int | SetItemData (int nIndex, DWORD_PTR dwItemData)
This method sets the 32-bit value associated with the specified item in a combobox.
void | DeleteItem (long nIndex)
Call this member function to delete a string.
void | OnEnabledChanged ()
This method is called when the control's enabled state is changed.
void | DoPropExchange (CXTPPropExchange *pPX)
Either reads this object from or writes this object to an archive.
virtual BOOL | Compare (CXTPControl *pOther)
Call this member to compare controls.
int | GetLabelWidth () const
Call this method to get the width of a label.
void | SetLabelWidth (int nLabelWidth)
Call this method to set the width of a label.
virtual BOOL | IsCaptionVisible () const
Call this member to determine if the caption of the control is visible.
BOOL | IsImageVisible () const
Call this member to determine if the icon is visible for a combobox control.
int | GetThumbWidth () const
Call this method to get the width of a thumb button.
void | SetThumbWidth (int nThumbWidth)
This method is called to set the width of a thumb button.
BOOL | HasFocus () const
Call this method to determine if control has focus.
virtual void | DrawEditText (CDC *pDC, CRect rcText)
This method draws the text of control if the style is CBS_DROPDOWNLIST.
CListBox * | GetListBoxCtrl () const
CXTPControlComboBoxPopupBar * | GetComboBoxPopupBar () const
void | SetEditIconId (int nId)
Call this member to set the edit icon's identifier.
int | GetEditIconId () const
Call this member to get the edit icon's identifier.
void | SetListIconId (int nId)
Call this member to set the combo list icon's identifier.
int | GetListIconId () const
Call this member to get the combo list icon's identifier.
virtual void | SetFocused (BOOL bFocused)
Call this member to set focus to the control.
virtual BOOL | IsFocused () const
Call this member to get the focused state of the control.
virtual void | OnEditChanged ()
This method is called when edit control's text is changed.
virtual void | OnSelChanged ()
This method is called when the selected string is changed.
virtual void | SetHideFlags (DWORD dwFlags)
This method is called to hide the control.
virtual void | OnActionChanged (int nProperty)
This method is called when an action property is changed.
virtual void | OnActionChanging (int nProperty)
This method is called when an action property is about to be changed.
void | SetTextLimit (int nTextLimit)
This method sets the maximum text length that the user may enter into an edit control.
int | GetTextLimit () const
This method gets the maximum text length that the user may enter into an edit control.
- Public Member Functions inherited from CXTPControlPopup
CXTPControlPopup ()
Constructs a CXTPControlPopup object.
virtual | ~CXTPControlPopup ()
Destroys a CXTPControlPopup object, handles cleanup and deallocation.
void | SetCommandBar (CMenu *pMenu)
Call this member to set the child command bar.
void | SetCommandBar (CXTPCommandBar *pBar)
Call this member to set the child command bar.
CXTPCommandBar * | GetCommandBar () const
Call this member to get the child command bar.
BOOL | GetPopuped () const
Call this member to get the control's pop-up state.
virtual CString | GetCaption () const
Call this member to get the control's caption.
void | DoPropExchange (CXTPPropExchange *pPX)
Either reads this object from or writes this object to an archive.
virtual void | AdjustExcludeRect (CRect &rc, BOOL bVertical)
Updates rectangle to set the position where the child pop-up bar becomes visible.
void | Copy (CXTPControl *pControl, BOOL bRecursive=FALSE)
This method is called to copy the control.
- Public Member Functions inherited from CXTPControlButton
CXTPControlButton ()
Constructs a CXTPControlButton object.
virtual | ~CXTPControlButton ()
Destroys a CXTPControlButton object, handles cleanup and deallocation.
void | SetStyleEx (XTPButtonStyle buttonStyle)
Call this member to set the style of the button containing vector icon.
XTPButtonStyle | GetStyleEx () const
Call this member to get the button's style containing vector icon.
- Public Member Functions inherited from CXTPControl
void | SetStyle (XTPButtonStyle buttonStyle)
Call this member to set the style of the control.
XTPButtonStyle | GetStyle () const
Call this member to get the control's style.
void | SetCaption (LPCTSTR lpszCaption)
Call this member to set the caption of the control.
void | SetCaption (UINT nIDCaption)
Call this member to set the caption of the control.
void | SetShortcutText (LPCTSTR lpszShortcutText)
Call this member to set the shortcut string to the control.
CString | GetShortcutText () const
Call this member to get the control's shortcut.
void | SetDescription (LPCTSTR lpszDescription)
Call this member to set the description of the control.
virtual CString | GetDescription () const
Call this member to get the control's description.
void | SetTooltip (LPCTSTR lpszTooltip)
Call this member to set the tooltip of the control.
virtual CString | GetTooltip () const
Call this member to get the control's tooltip.
void | SetKeyboardTip (LPCTSTR lpszKeyboardTip)
Call this member to set the keyboard tip to the control.
CString | GetKeyboardTip () const
Call this member to get the keyboard tip.
void | SetCustomShortcutText (LPCTSTR lpszCustomShortcutText)
Call this member to set the text displayed for the shortcut in a pop-up menu.
CString | GetCustomShortcutText () const
Call this member to get the control's text displayed for the shortcut in a pop-up menu.
void | SetParameter (LPCTSTR lpszParameter)
Call this member to set the parameter of the control.
CString | GetParameter () const
Call this member to get the control's parameter.
void | SetID (int nId)
Call this member to set the identifier of the control.
int | GetID () const
Call this member to get the control's identifier.
long | GetIndex () const
Call this member to get the index of the control.
void | SetIconId (int nId)
Call this member to set the control icon's identifier.
int | GetIconId () const
Call this member to get the icon's identifier.
void | SetHelpId (int nId)
Call this member to set the control help identifier.
int | GetHelpId () const
Call this member to get the help identifier.
virtual void | SetBeginGroup (BOOL bBeginGroup)
Call this member to begin a new group using a separator.
BOOL | GetBeginGroup () const
Call this member to determine if the control has a separator.
virtual void | SetEnabled (BOOL bEnabled)
Call this member to enable/disable the control.
BOOL | GetEnabled () const
Call this member to check if the control is enabled.
virtual void | SetChecked (BOOL bChecked)
Call this member to set the checked state of the control.
BOOL | GetChecked () const
Call this member to get the checked state of the control.
virtual int | GetSelected () const
Call this member to check if the control is selected.
void | SetOnQuickAccess (BOOL bOnQuicAccess=FALSE)
Call this member to set whether a control should be a part of the Quick Access panel.
BOOL | IsOnQuickAccess () const
Call this member to check if a control is a part of the Quick Access panel.
void | SetPressed (BOOL bPressed)
Call this member to set the pressed state of the control.
virtual BOOL | GetPressed () const
Call this member to check the pressed state of the control.
CRect | GetRect () const
Call this member to get the bounding rectangle of the control.
CXTPCommandBar * | GetParent () const
Call this member to get the parent command bar.
virtual BOOL | IsVisible (DWORD dwSkipFlags=0) const
Call this member to determine if the control is visible.
void | SetVisible (BOOL bVisible)
Call this member to set the visibility of the control.
CXTPControls * | GetControls () const
Call this member to get the parent controls collection.
XTPControlType | GetType () const
Call this member to get the control's type.
void | SetFlags (DWORD dwFlags)
Call this member to set the flags of the control.
DWORD | GetFlags () const
Call this member to retrieve control special flags.
void | SetTag (DWORD_PTR dwTag)
This method sets the 32-bit value associated with the control.
DWORD_PTR | GetTag () const
This method retrieves the application-supplied, 32-bit value associated with the control.
void | SetCloseSubMenuOnClick (BOOL bCloseOnClick)
Call this member function to enable/disable the closing of sub-menus when a control is clicked in the menu.
BOOL | GetCloseSubMenuOnClick () const
Call this member function to check if sub-menus will close as soon as a control is clicked.
void | SetExecuteOnPressInterval (int nExecuteOnPressInterval)
Call this method to set the delay (in milliseconds) between WM_COMMAND messages while a button is pressed by the user.
int | GetExecuteOnPressInterval () const
Call this method to get the delay (in milliseconds) between WM_COMMAND messages while a button is pressed by the user.
CXTPRibbonGroup * | GetRibbonGroup () const
Returns the ribbon group that the control belongs to.
virtual BOOL | IsTransparent () const
Determines if the control needs to draw its background.
void | SetHideWrap (BOOL bHide)
This method is called to hide the control.
BOOL | SetHideFlag (XTPControlHideFlags dwFlag, BOOL bSet)
Call this member to set/remove hide flags.
DWORD | GetHideFlags () const
Call this method to retrieve hidden flags.
CRect | GetRowRect () const
Call this method to retrieve the position of the control's row.
BOOL | GetWrap () const
Call this method to check if the control is wrapped.
void | SetRowRect (CRect rcRow)
Call this method to set the row of the control.
void | SetWrap (BOOL bWrap)
Call this member to set the control to wrapped.
BOOL | GetExpanded () const
Call this member to check if the control is expanded.
BOOL | IsCursorOver () const
Call this member to determine if the mouse pointer is over the control.
virtual CSize | GetSize (CDC *pDC)
This method is called to determine the size of the control.
virtual void | Draw (CDC *pDC)
This method is called to draw the control.
void | DelayRedrawParent ()
Call this method to redraw the parent command bar.
void | DelayLayoutParent ()
Call this method to recalculate the parent command bar size.
void | SetCategory (LPCTSTR lpszCategory)
Call this method to set the category of the control.
CString | GetCategory () const
Call this method to retrieve the category of the control.
CXTPImageManager * | GetImageManager () const
Call this method to retrieve the image manager.
CXTPPaintManager * | GetPaintManager () const
Call this method to retrieve the paint manager.
virtual CXTPImageManagerIcon * | GetImage (int nWidth=16) const
Call this method to retrieve the image of the control.
void | AssignDocTemplate (UINT nIDResource)
Call this method to assign a document template to the control.
void | ExcludeDocTemplate (UINT nIDResource)
Call this method to exclude the document template from control.
BOOL | IsItemDefault () const
Call this method to check if a control is a default menu item.
void | SetItemDefault (BOOL bDefault)
Call this method to set a control to be a default menu item.
BOOL | IsTemporary () const
Call this method to determine if a control is temporary.
void | Reset ()
Call this member to reset the icon and caption of a control to its default settings before it was customized by the user.
void | SetPrompt (LPCTSTR lpszPrompt)
Call this member to load a string from a STRINGTABLE resource to set the tooltip and description of a control.
void | SetCustomIcon (HICON hIcon)
Call this member to set a custom icon to this control.
void | RedrawParent (BOOL bAnimate=TRUE)
This method is called to redraw the parent command bar.
LRESULT | NotifySite (UINT code)
This method is called to send message code to the parent site window.
LRESULT | NotifySite (UINT code, NMXTPCONTROL *pNM)
This method is called to send message code to the parent site window.
LRESULT | NotifySite (CWnd *pSite, UINT code, NMXTPCONTROL *pNM)
This method is called to send message code to the parent site window.
virtual void | SetAction (CXTPControlAction *pAction)
Call this method to manually assign an action for control.
CXTPControlAction * | GetAction () const
Call this method to retrieve an action associated with control.
virtual void | OnThemeChanged ()
This method is called when the paint manager theme is changed.
virtual void | SetWidth (int nWidth)
Call this member to set the width of the control.
virtual void | SetHeight (int nHeight)
Call this member to set the height of the control.
int | GetWidth () const
Call this member to get the width of the control.
int | GetHeight () const
Call this member to get the height of the control.
BOOL | HasDwmCompositedRect () const
This method is called to determine if control has a Vista DWM transparent area.
virtual CSize | GetButtonSize () const
Call this function to get the size of the command bar button.
virtual CSize | GetIconSize () const
Call this member function to get the size of a toolbar icon.
void | SetIconSize (CSize szIcon)
Call this member function to set the size of an icon for an individual control.
virtual BOOL | IsCustomizeMovable () const
This method is called to determine if control can be repositioned in customize mode.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Static Public Member Functions

static int AFX_CDECL | GetTwipSize (LPCTSTR lpszText)
This method is called to convert string to twip size.
static CString AFX_CDECL | TwipsToPointString (int nTwips)
This method is called to convert twips to string.
- Static Public Member Functions inherited from CXTPControlPopup
static CXTPControlPopup *AFX_CDECL | CreateControlPopup (XTPControlType controlType)
Creates a CXTPControlPopup object with the specified type.
- Static Public Member Functions inherited from CXTPControl
static CXTPControl *AFX_CDECL | FromUI (CCmdUI *pCmdUI)
Call this member to retrieve CXTPControl from a CCmdUI structure.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Protected Member Functions

virtual BOOL | OnSetPopup (BOOL bPopup)
This method is called to pop-up the control.
int | GetTwipSize () const
Call this method to retrieve the current user selected size.
virtual void | OnExecute ()
This method is called when the control is executed.
- Protected Member Functions inherited from CXTPControlComboBox
virtual BOOL | IsFocusable () const
This method is called to check if a control can accept focus.
virtual CXTPControlComboBoxEditCtrl * | CreateEditControl ()
This method creates an edit control.
void | OnMouseHover ()
Called after the mouse hovers over the control.
virtual void | OnSetFocus (CWnd *pOldWnd)
This method is called when the edit control gets focus.
virtual void | OnKillFocus ()
This method is called when the edit control loses focus.
virtual void | DeflateEditRect (CRect &rcControl)
This method is called to get the real rect of an edit control of a combobox.
BOOL | OnSetSelected (int bSelected)
This method is called when the control becomes selected.
void | SetRect (CRect rcControl)
Call this member to set the bounding rectangle of the control.
void | OnClick (BOOL bKeyboard=FALSE, CPoint pt=CPoint(0, 0))
This method is called when the user clicks the control.
virtual void | OnUnderlineActivate ()
This method is called when the user activates a control using its underline.
void | Copy (CXTPControl *pControl, BOOL bRecursive=FALSE)
This method is called to copy the control.
BOOL | OnHookKeyDown (UINT nChar, LPARAM lParam)
This method is called when a non-system key is pressed.
void | SetParent (CXTPCommandBar *pParent)
This method is called to assign a parent command bar object.
virtual void | OnCalcDynamicSize (DWORD dwMode)
This method is called before recalculating the parent command bar size to calculate the dimensions of the control.
virtual BOOL | IsCustomizeResizeAllow () const
This member checks if the user can resize the control.
virtual int | GetCustomizeMinWidth () const
This member returns the minimum width that the combobox can be sized to by the user while in customization mode.
virtual void | OnRemoved ()
This method is called when a control is removed from the parent controls collection.
virtual void | OnMouseMove (CPoint point)
This member is called when the mouse cursor moves.
- Protected Member Functions inherited from CXTPControlPopup
BOOL | ContainsPopup (CXTPControlPopup *pControlPopup)
This method is called to check if pControlPopup contains in the control recursively.
void | ExpandCommandBar ()
Call this member to expand the parent pop-up bar.
BOOL | OnSetSelected (int bSelected)
This method is called when the control becomes selected.
void | OnClick (BOOL bKeyboard=FALSE, CPoint pt=CPoint(0, 0))
This method is called when the user clicks the control.
void | OnMouseHover ()
This method is called after the mouse hovers over the control.
virtual void | OnLButtonUp (CPoint point)
This member is called when the user releases the left mouse button.
virtual BOOL | OnLButtonDblClk (CPoint point)
This member is called when the user double-clicks the left mouse button.
void | OnCustomizeDragOver (CXTPControl *pDataObject, CPoint point, DROPEFFECT &dropEffect)
This method is called when the user moves the mouse over the control.
virtual BOOL | DoCustomDragOver (CXTPCommandBar *pCommandBar, CPoint point, DROPEFFECT &dropEffect)
The implementation may implement a custom drag over handling logic in this method.
virtual void | UpdateShadow ()
Call this member to update the shadow of the control.
virtual void | RestoreCommandBarList (CXTPCommandBarList *pCommandBarList)
This method is called from LoadCommandBars to restore controls and its child command bars.
- Protected Member Functions inherited from CXTPControlButton
- Protected Member Functions inherited from CXTPControl
CXTPControl ()
Constructs a CXTPControl object.
virtual | ~CXTPControl ()
Destroys a CXTPControl object, handles cleanup and deallocation.
void | SetIndex (int nIndex)
This method is called to assign the order of the control in the controls list.
void | SetExpanded (BOOL bExpanded)
This method is called to set the control's expanded state.
virtual BOOL | OnHookMouseWheel (UINT nFlags, short zDelta, CPoint point)
This method is called when the user rotates the mouse wheel.
void | ScreenToClient (CPoint *point)
The ScreenToClient function converts the screen coordinates of a specified point on the screen.
void | ClickToolBarButton (CRect rcActiveRect=CRect(0, 0, 0, 0))
This helper method is called when the user clicks the toolbar's button.
virtual void | OnLButtonDown (CPoint point)
This member is called when the user presses the left mouse button down.
virtual BOOL | OnRButtonDown (CPoint point)
This member is called when the user press the right mouse button.
virtual BOOL | OnRButtonUp (CPoint point)
This member is called when the user releases the right mouse button.
BOOL | IsCustomizeMode () const
Call this method to determine if command bars is in customize mode.
virtual void | CustomizeStartDrag (CPoint point)
This member is called when the user starts to drag the control in customize mode.
virtual BOOL | CustomizeStartResize (CPoint point)
This method is called when user starts to resize control in customize mode.
virtual int | GetCustomizeMinHeight () const
Retrieves available minimum height of the control.
void | OnCustomizeMouseMove (CPoint point)
This member is called when the mouse cursor moves in customized mode.
virtual void | OnIdleUpdate ()
This virtual method is called in idle-time processing.
virtual INT_PTR | OnToolHitTest (CPoint point, TOOLINFO *pTI) const
The framework calls this member function to determine whether a point is in the bounding rectangle of the specified tool.
virtual void | GenerateCommandBarList (DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam)
This method is called from SaveCommandBars to save all child command bars.
virtual void | OnCaptionChanged ()
This method is called when the control's caption is changed.
BOOL | IsLayoutRTL () const
Determines if right-to-left (RTL) mode is set.
BOOL | IsLayoutChanged ()
Call this member to determine if the layout has changed (RTL to LTR or LTR to RLT).

Additional Inherited Members

- Protected Attributes inherited from CXTPControlComboBox
CXTPControlComboBoxEditCtrl * | m_pEdit
Child edit control.
BOOL | m_bDropDown
TRUE if the combo is dropdown.
XTPButtonStyle | m_comboStyle
Style of the combobox.
int | m_nLastSel
Last user selected index (used during display of list box).
CString | m_strLastText
Last Text before user select focus and change it.
BOOL | m_bDelayDestroy
TRUE if need to recreate control.
BOOL | m_bDelayReposition
Need to reposition control.
int | m_nLabelWidth
Width of the label.
int | m_nThumbWidth
Width of the thumb area.
CString | m_strEditHint
Grayed-out text displayed in the edit control that displayed a helpful description.
BOOL | m_bAutoComplete
TRUE if Auto Complete is enabled.
BOOL | m_bIgnoreAutoComplete
TRUE to disable auto complete till next key event.
DWORD | m_dwShellAutoCompleteFlags
Shell auto complete flags.
BOOL | m_bFocused
TRUE if control is focused.
int | m_nEditIconId
Edit Icon identifier.
BOOL | m_bSelEndOk
TRUE if user selects a list item.
int | m_nDropDownItemCount
Maximum drop down items.
CString | m_strEditText
Edit text.
BOOL | m_bEditChanged
TRUE if Edit Text is changed.
int | m_nTextLimit
The maximum number of characters that can be entered into an edit control.
CXTPControlComboBoxAutoCompleteWnd * | m_pAutoCompleteWnd
Auto Complete hook window.
DWORD | m_dwEditStyle
Edit style.
- Protected Attributes inherited from CXTPControlPopup
BOOL | m_bPopup
TRUE if pop-up'ed.
CXTPCommandBar * | m_pCommandBar
Child pop-up bar.
DWORD | m_dwCommandBarID
Child pop-up ID.
BOOL | m_bShowShadow
TRUE to show shadow.
- Protected Attributes inherited from CXTPControlButton
XTPButtonStyle | m_buttonStyleEx
User-defined style of button containing vector icon.
- Protected Attributes inherited from CXTPControl
DWORD_PTR | m_nTag
Control tag.
int | m_nIndex
Index of the control.
int | m_nId
Identifier of the control.
int | m_nIconId
Identifier of the control's image.
int | m_nHelpId
Help identifier.
int | m_nCustomIconId
Identifier of the control's custom image.
BOOL | m_bWrap
TRUE if the control is wrapped.
BOOL | m_bBeginGroup
TRUE if the control starts new group.
BOOL | m_bEnabled
TRUE if the control is enabled.
BOOL | m_bChecked
TRUE if the control is checked.
BOOL | m_bSelected
TRUE if the control is selected.
BOOL | m_bPressed
TRUE if the control is pushed.
BOOL | m_bTemporary
TRUE if the control is temporary.
BOOL | m_bOnQuickAccess
TRUE if the control is a part of Quick Access panel.
CRect | m_rcRow
Bounding rectangle of the control's row.
CRect | m_rcControl
Bounding rectangle of the control.
DWORD | m_dwHideFlags
Hidden flags.
DWORD | m_dwFlags
Flags of the control.
CString | m_strCaption
Caption of the control.
CString | m_strCustomCaption
User-defined caption.
CString | m_strShortcutText
Shortcut text.
CString | m_strShortcutTextAuto
Shortcut text.
CString | m_strTooltipText
Tooltip text.
CString | m_strDescriptionText
Description text.
CString | m_strParameter
Parameter text.
CString | m_strKeyboardTip
Keyboard tip.
CXTPControls * | m_pControls
Parent control collection.
XTPControlType | m_controlType
Type of the control.
CXTPCommandBar * | m_pParent
The Parent command bar.
BOOL | m_bExpanded
TRUE if the control is expanded.
CString | m_strCategory
Category of the control.
BOOL | m_bDefaultItem
TRUE if the item is default pop-up item.
CDocTemplateMap | m_mapDocTemplatesAssigned
Assigned templates.
CDocTemplateMap | m_mapDocTemplatesExcluded
Excluded templates.
XTPButtonStyle | m_buttonStyle
Button Style.
XTPButtonStyle | m_buttonCustomStyle
User-defined style of button.
XTPButtonStyle | m_buttonRibbonStyle
User-defined style of button.
BOOL | m_bCloseSubMenuOnClick
TRUE is sub-menus are closed as soon as a control is clicked.
CXTPRibbonGroup * | m_pRibbonGroup
Ribbon group of control.
CXTPControlAction * | m_pAction
Action of the control.
int | m_nWidth
Width of the control.
int | m_nHeight
Height of the control.
int | m_nExecuteOnPressInterval
Delay between each message when control is pressed.
CSize | m_szIcon
The size of the icon used for the control.
BOOL | m_bLayoutRTL
Indicate does last layout is RTL.

Detailed Description

CXTPControlSizeComboBox is a CXTPControlComboBox derived class.

It represents the size picker.

Member Function Documentation

◆ GetTwipSize() [1/2]

int GetTwipSize ( ) const
protected

Call this method to retrieve the current user selected size.

Returns
The current size.

◆ GetTwipSize() [2/2]

static int AFX_CDECL GetTwipSize ( LPCTSTR lpszText )
static

This method is called to convert string to twip size.

Parameters
lpszText String contains twips number.
Returns
Converts string to twip size

◆ OnSetPopup()

virtual BOOL OnSetPopup ( BOOL bPopup )
protectedvirtual

This method is called to pop-up the control.

Parameters
bPopup TRUE to set pop-up.
Returns
TRUE if successful; otherwise FALSE.

Reimplemented from CXTPControlComboBox.

◆ SetTwipSize()

void SetTwipSize ( int nTwips )

Call this method to set the current size.

Parameters
nTwips Size, in twips, to be set

◆ TwipsToPointString()

static CString AFX_CDECL TwipsToPointString ( int nTwips )
static

This method is called to convert twips to string.

Parameters
nTwips twips number to convert.
Returns
Returns converted twips to string
The documentation for this class was generated from the following file:
  • XTPControlComboBoxExt.h


Toolkit Pro: CXTPControlSlider Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPControlSlider Class Reference

CXTPControlSlider is a CXTPControl derived class. More...

Inheritance diagram for CXTPControlSlider:
[legend]

Public Member Functions

CXTPControlSlider ()
Constructs a CXTPControlSlider object.
virtual | ~CXTPControlSlider ()
Destroys a CXTPControlSlider object, handles cleanup and deallocation.
void | SetPos (int nPos)
Call this member to set the current position of the slider.
int | GetPos ()
Call this member to get the current position of the slider.
void | SetRange (int nMin, int nMax)
Sets the upper and lower limits of the slider control's range.
virtual void | OnEnabledChanged ()
This method is called when a control's enabled state is changed.
CSliderCtrl * | GetSliderCtrl () const
Call this member to get a pointer to the in-place slider control.
DWORD | GetSliderStyle () const
Call this member to get the style of the slider control.
void | SetSliderStyle (DWORD dwStyle)
Call this member to set the style of the slider control.
- Public Member Functions inherited from CXTPControl
void | SetStyle (XTPButtonStyle buttonStyle)
Call this member to set the style of the control.
XTPButtonStyle | GetStyle () const
Call this member to get the control's style.
void | SetCaption (LPCTSTR lpszCaption)
Call this member to set the caption of the control.
void | SetCaption (UINT nIDCaption)
Call this member to set the caption of the control.
virtual CString | GetCaption () const
Call this member to get the control's caption.
void | SetShortcutText (LPCTSTR lpszShortcutText)
Call this member to set the shortcut string to the control.
CString | GetShortcutText () const
Call this member to get the control's shortcut.
void | SetDescription (LPCTSTR lpszDescription)
Call this member to set the description of the control.
virtual CString | GetDescription () const
Call this member to get the control's description.
void | SetTooltip (LPCTSTR lpszTooltip)
Call this member to set the tooltip of the control.
virtual CString | GetTooltip () const
Call this member to get the control's tooltip.
void | SetKeyboardTip (LPCTSTR lpszKeyboardTip)
Call this member to set the keyboard tip to the control.
CString | GetKeyboardTip () const
Call this member to get the keyboard tip.
void | SetCustomShortcutText (LPCTSTR lpszCustomShortcutText)
Call this member to set the text displayed for the shortcut in a pop-up menu.
CString | GetCustomShortcutText () const
Call this member to get the control's text displayed for the shortcut in a pop-up menu.
void | SetParameter (LPCTSTR lpszParameter)
Call this member to set the parameter of the control.
CString | GetParameter () const
Call this member to get the control's parameter.
void | SetID (int nId)
Call this member to set the identifier of the control.
int | GetID () const
Call this member to get the control's identifier.
long | GetIndex () const
Call this member to get the index of the control.
void | SetIconId (int nId)
Call this member to set the control icon's identifier.
int | GetIconId () const
Call this member to get the icon's identifier.
void | SetHelpId (int nId)
Call this member to set the control help identifier.
int | GetHelpId () const
Call this member to get the help identifier.
virtual void | SetBeginGroup (BOOL bBeginGroup)
Call this member to begin a new group using a separator.
BOOL | GetBeginGroup () const
Call this member to determine if the control has a separator.
virtual void | SetEnabled (BOOL bEnabled)
Call this member to enable/disable the control.
BOOL | GetEnabled () const
Call this member to check if the control is enabled.
virtual void | SetChecked (BOOL bChecked)
Call this member to set the checked state of the control.
BOOL | GetChecked () const
Call this member to get the checked state of the control.
virtual int | GetSelected () const
Call this member to check if the control is selected.
void | SetOnQuickAccess (BOOL bOnQuicAccess=FALSE)
Call this member to set whether a control should be a part of the Quick Access panel.
BOOL | IsOnQuickAccess () const
Call this member to check if a control is a part of the Quick Access panel.
virtual void | SetFocused (BOOL bFocused)
Call this member to set the focused state of the control.
virtual BOOL | IsFocused () const
Call this member to check the focused state of the control.
void | SetPressed (BOOL bPressed)
Call this member to set the pressed state of the control.
virtual BOOL | GetPressed () const
Call this member to check the pressed state of the control.
virtual void | SetRect (CRect rcControl)
This member is called to set the bounding rectangle of the control.
CRect | GetRect () const
Call this member to get the bounding rectangle of the control.
CXTPCommandBar * | GetParent () const
Call this member to get the parent command bar.
virtual BOOL | IsVisible (DWORD dwSkipFlags=0) const
Call this member to determine if the control is visible.
virtual BOOL | IsCaptionVisible () const
Call this member to determine if the caption of the control is visible.
void | SetVisible (BOOL bVisible)
Call this member to set the visibility of the control.
CXTPControls * | GetControls () const
Call this member to get the parent controls collection.
XTPControlType | GetType () const
Call this member to get the control's type.
void | SetFlags (DWORD dwFlags)
Call this member to set the flags of the control.
DWORD | GetFlags () const
Call this member to retrieve control special flags.
void | SetTag (DWORD_PTR dwTag)
This method sets the 32-bit value associated with the control.
DWORD_PTR | GetTag () const
This method retrieves the application-supplied, 32-bit value associated with the control.
virtual BOOL | Compare (CXTPControl *pOther)
Call this member to compare controls.
virtual CXTPCommandBar * | GetCommandBar () const
Call this member to get the child command bar.
void | SetCloseSubMenuOnClick (BOOL bCloseOnClick)
Call this member function to enable/disable the closing of sub-menus when a control is clicked in the menu.
BOOL | GetCloseSubMenuOnClick () const
Call this member function to check if sub-menus will close as soon as a control is clicked.
void | SetExecuteOnPressInterval (int nExecuteOnPressInterval)
Call this method to set the delay (in milliseconds) between WM_COMMAND messages while a button is pressed by the user.
int | GetExecuteOnPressInterval () const
Call this method to get the delay (in milliseconds) between WM_COMMAND messages while a button is pressed by the user.
CXTPRibbonGroup * | GetRibbonGroup () const
Returns the ribbon group that the control belongs to.
virtual BOOL | IsTransparent () const
Determines if the control needs to draw its background.
void | SetHideWrap (BOOL bHide)
This method is called to hide the control.
virtual void | SetHideFlags (DWORD dwFlags)
This method is called to hide the control.
BOOL | SetHideFlag (XTPControlHideFlags dwFlag, BOOL bSet)
Call this member to set/remove hide flags.
DWORD | GetHideFlags () const
Call this method to retrieve hidden flags.
CRect | GetRowRect () const
Call this method to retrieve the position of the control's row.
BOOL | GetWrap () const
Call this method to check if the control is wrapped.
void | SetRowRect (CRect rcRow)
Call this method to set the row of the control.
void | SetWrap (BOOL bWrap)
Call this member to set the control to wrapped.
BOOL | GetExpanded () const
Call this member to check if the control is expanded.
BOOL | IsCursorOver () const
Call this member to determine if the mouse pointer is over the control.
virtual void | OnExecute ()
This method is called when the control is executed.
virtual CSize | GetSize (CDC *pDC)
This method is called to determine the size of the control.
virtual void | Draw (CDC *pDC)
This method is called to draw the control.
virtual void | OnCalcDynamicSize (DWORD dwMode)
This method is called before recalculating the parent command bar size to calculate the dimensions of the control.
void | DelayRedrawParent ()
Call this method to redraw the parent command bar.
void | DelayLayoutParent ()
Call this method to recalculate the parent command bar size.
void | SetCategory (LPCTSTR lpszCategory)
Call this method to set the category of the control.
CString | GetCategory () const
Call this method to retrieve the category of the control.
CXTPImageManager * | GetImageManager () const
Call this method to retrieve the image manager.
CXTPPaintManager * | GetPaintManager () const
Call this method to retrieve the paint manager.
virtual CXTPImageManagerIcon * | GetImage (int nWidth=16) const
Call this method to retrieve the image of the control.
void | AssignDocTemplate (UINT nIDResource)
Call this method to assign a document template to the control.
void | ExcludeDocTemplate (UINT nIDResource)
Call this method to exclude the document template from control.
BOOL | IsItemDefault () const
Call this method to check if a control is a default menu item.
void | SetItemDefault (BOOL bDefault)
Call this method to set a control to be a default menu item.
BOOL | IsTemporary () const
Call this method to determine if a control is temporary.
void | Reset ()
Call this member to reset the icon and caption of a control to its default settings before it was customized by the user.
void | SetPrompt (LPCTSTR lpszPrompt)
Call this member to load a string from a STRINGTABLE resource to set the tooltip and description of a control.
void | SetCustomIcon (HICON hIcon)
Call this member to set a custom icon to this control.
virtual void | DoPropExchange (CXTPPropExchange *pPX)
Either reads this object from or writes this object to an archive.
virtual void | OnUnderlineActivate ()
This method is called when the user activates the control using its underline.
virtual BOOL | GetPopuped () const
Call this member to get the control's pop-up state.
void | RedrawParent (BOOL bAnimate=TRUE)
This method is called to redraw the parent command bar.
LRESULT | NotifySite (UINT code)
This method is called to send message code to the parent site window.
LRESULT | NotifySite (UINT code, NMXTPCONTROL *pNM)
This method is called to send message code to the parent site window.
LRESULT | NotifySite (CWnd *pSite, UINT code, NMXTPCONTROL *pNM)
This method is called to send message code to the parent site window.
virtual void | SetAction (CXTPControlAction *pAction)
Call this method to manually assign an action for control.
CXTPControlAction * | GetAction () const
Call this method to retrieve an action associated with control.
virtual void | OnThemeChanged ()
This method is called when the paint manager theme is changed.
virtual void | SetWidth (int nWidth)
Call this member to set the width of the control.
virtual void | SetHeight (int nHeight)
Call this member to set the height of the control.
int | GetWidth () const
Call this member to get the width of the control.
int | GetHeight () const
Call this member to get the height of the control.
BOOL | HasDwmCompositedRect () const
This method is called to determine if control has a Vista DWM transparent area.
virtual CSize | GetButtonSize () const
Call this function to get the size of the command bar button.
virtual CSize | GetIconSize () const
Call this member function to get the size of a toolbar icon.
void | SetIconSize (CSize szIcon)
Call this member function to set the size of an icon for an individual control.
virtual void | Copy (CXTPControl *pControl, BOOL bRecursive=FALSE)
This method is called to copy the control.
virtual void | OnClick (BOOL bKeyboard=FALSE, CPoint pt=CPoint(0, 0))
This method is called when the user clicks the control.
virtual BOOL | IsCustomizeMovable () const
This method is called to determine if control can be repositioned in customize mode.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

virtual void | OnScroll (UINT nSBCode, UINT nPos)
This method is called when the position of the scrollbar is changed.
- Protected Member Functions inherited from CXTPControl
CXTPControl ()
Constructs a CXTPControl object.
virtual | ~CXTPControl ()
Destroys a CXTPControl object, handles cleanup and deallocation.
virtual BOOL | IsFocusable () const
This method is called to check if the control can accept focus.
void | SetIndex (int nIndex)
This method is called to assign the order of the control in the controls list.
void | SetExpanded (BOOL bExpanded)
This method is called to set the control's expanded state.
virtual BOOL | OnHookKeyDown (UINT nChar, LPARAM lParam)
This method is called when a non-system key is pressed.
virtual BOOL | OnHookMouseWheel (UINT nFlags, short zDelta, CPoint point)
This method is called when the user rotates the mouse wheel.
virtual void | SetParent (CXTPCommandBar *pParent)
This method is called to assign a parent command bar object.
void | ScreenToClient (CPoint *point)
The ScreenToClient function converts the screen coordinates of a specified point on the screen.
void | ClickToolBarButton (CRect rcActiveRect=CRect(0, 0, 0, 0))
This helper method is called when the user clicks the toolbar's button.
virtual BOOL | OnSetPopup (BOOL bPopup)
This method is called to pop-up the control.
virtual void | OnLButtonUp (CPoint point)
This member is called when the user releases the left mouse button.
virtual void | OnLButtonDown (CPoint point)
This member is called when the user presses the left mouse button down.
virtual BOOL | OnRButtonDown (CPoint point)
This member is called when the user press the right mouse button.
virtual BOOL | OnRButtonUp (CPoint point)
This member is called when the user releases the right mouse button.
virtual BOOL | OnLButtonDblClk (CPoint point)
This member is called when the user double-clicks the left mouse button.
virtual void | OnMouseMove (CPoint point)
This member is called when the mouse cursor moves.
virtual void | OnMouseHover ()
Called after the mouse hovers over the control.
virtual BOOL | OnSetSelected (int bSelected)
This method is called when the control becomes selected.
BOOL | IsCustomizeMode () const
Call this method to determine if command bars is in customize mode.
virtual void | CustomizeStartDrag (CPoint point)
This member is called when the user starts to drag the control in customize mode.
virtual BOOL | CustomizeStartResize (CPoint point)
This method is called when user starts to resize control in customize mode.
virtual void | OnCustomizeDragOver (CXTPControl *pDataObject, CPoint point, DROPEFFECT &dropEffect)
This member is called when the user moves the mouse over the control.
virtual BOOL | DoCustomDragOver (CXTPCommandBar *pCommandBar, CPoint point, DROPEFFECT &dropEffect)
The implementation may implement a custom drag over handling logic in this method.
virtual BOOL | IsCustomizeResizeAllow () const
This member checks if the user can resize the control.
virtual int | GetCustomizeMinWidth () const
Retrieves the available minimum width of control.
virtual int | GetCustomizeMinHeight () const
Retrieves available minimum height of the control.
void | OnCustomizeMouseMove (CPoint point)
This member is called when the mouse cursor moves in customized mode.
virtual void | OnIdleUpdate ()
This virtual method is called in idle-time processing.
virtual void | OnRemoved ()
This method is called when a control is removed from the parent controls collection.
virtual INT_PTR | OnToolHitTest (CPoint point, TOOLINFO *pTI) const
The framework calls this member function to determine whether a point is in the bounding rectangle of the specified tool.
virtual void | RestoreCommandBarList (CXTPCommandBarList *pCommandBarList)
This method is called from LoadCommandBars to restore controls and its child command bars.
virtual void | GenerateCommandBarList (DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam)
This method is called from SaveCommandBars to save all child command bars.
virtual void | OnActionChanged (int nProperty)
This method is called when an action property is changed.
virtual void | OnActionChanging (int nProperty)
This method is called when an action property is about to be changed.
virtual void | OnCaptionChanged ()
This method is called when the control's caption is changed.
BOOL | IsLayoutRTL () const
Determines if right-to-left (RTL) mode is set.
BOOL | IsLayoutChanged ()
Call this member to determine if the layout has changed (RTL to LTR or LTR to RLT).

Protected Attributes

CXTPControlSliderCtrl * | m_pSliderCtrl
Pointer to slider control.
int | m_nMin
Lower range.
int | m_nMax
Upper range.
int | m_nPos
Current position of slider.
DWORD | m_dwSliderStyle
Slider style.
CRect | m_rcPadding
Padding around slider.
- Protected Attributes inherited from CXTPControl
DWORD_PTR | m_nTag
Control tag.
int | m_nIndex
Index of the control.
int | m_nId
Identifier of the control.
int | m_nIconId
Identifier of the control's image.
int | m_nHelpId
Help identifier.
int | m_nCustomIconId
Identifier of the control's custom image.
BOOL | m_bWrap
TRUE if the control is wrapped.
BOOL | m_bBeginGroup
TRUE if the control starts new group.
BOOL | m_bEnabled
TRUE if the control is enabled.
BOOL | m_bChecked
TRUE if the control is checked.
BOOL | m_bSelected
TRUE if the control is selected.
BOOL | m_bPressed
TRUE if the control is pushed.
BOOL | m_bTemporary
TRUE if the control is temporary.
BOOL | m_bOnQuickAccess
TRUE if the control is a part of Quick Access panel.
CRect | m_rcRow
Bounding rectangle of the control's row.
CRect | m_rcControl
Bounding rectangle of the control.
DWORD | m_dwHideFlags
Hidden flags.
DWORD | m_dwFlags
Flags of the control.
CString | m_strCaption
Caption of the control.
CString | m_strCustomCaption
User-defined caption.
CString | m_strShortcutText
Shortcut text.
CString | m_strShortcutTextAuto
Shortcut text.
CString | m_strTooltipText
Tooltip text.
CString | m_strDescriptionText
Description text.
CString | m_strParameter
Parameter text.
CString | m_strKeyboardTip
Keyboard tip.
CXTPControls * | m_pControls
Parent control collection.
XTPControlType | m_controlType
Type of the control.
CXTPCommandBar * | m_pParent
The Parent command bar.
BOOL | m_bExpanded
TRUE if the control is expanded.
CString | m_strCategory
Category of the control.
BOOL | m_bDefaultItem
TRUE if the item is default pop-up item.
CDocTemplateMap | m_mapDocTemplatesAssigned
Assigned templates.
CDocTemplateMap | m_mapDocTemplatesExcluded
Excluded templates.
XTPButtonStyle | m_buttonStyle
Button Style.
XTPButtonStyle | m_buttonCustomStyle
User-defined style of button.
XTPButtonStyle | m_buttonRibbonStyle
User-defined style of button.
BOOL | m_bCloseSubMenuOnClick
TRUE is sub-menus are closed as soon as a control is clicked.
CXTPRibbonGroup * | m_pRibbonGroup
Ribbon group of control.
CXTPControlAction * | m_pAction
Action of the control.
int | m_nWidth
Width of the control.
int | m_nHeight
Height of the control.
int | m_nExecuteOnPressInterval
Delay between each message when control is pressed.
CSize | m_szIcon
The size of the icon used for the control.
BOOL | m_bLayoutRTL
Indicate does last layout is RTL.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControl
static CXTPControl *AFX_CDECL | FromUI (CCmdUI *pCmdUI)
Call this member to retrieve CXTPControl from a CCmdUI structure.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

CXTPControlSlider is a CXTPControl derived class.

It represents a slider control.

Member Function Documentation

◆ GetPos()

int GetPos ( )

Call this member to get the current position of the slider.

Returns
The position of the slider control.
See also
SetPos

◆ GetSliderCtrl()

AFX_INLINE CSliderCtrl * GetSliderCtrl ( ) const

Call this member to get a pointer to the in-place slider control.

Returns
A pointer to the in-place slider control.

◆ GetSliderStyle()

DWORD GetSliderStyle ( ) const

Call this member to get the style of the slider control.

Returns
The style of the slider control.
See also
SetSliderStyle

◆ OnScroll()

virtual void OnScroll | ( | UINT | nSBCode,
 |  | UINT | nPos )
 protectedvirtual

This method is called when the position of the scrollbar is changed.

Parameters
nSBCode | Specifies a scrollbar code that indicates the user's scrolling request.
nPos | Contains the current scroll-box position.

◆ SetPos()

void SetPos ( int nPos )

Call this member to set the current position of the slider.

Parameters
nPos New position of the slider control.
See also
GetPos, SetRange

◆ SetRange()

void SetRange | ( | int | nMin,
 |  | int | nMax )

Sets the upper and lower limits of the slider control's range.

Parameters
nMin | Specifies the lower limit of the range.
nMax | Specifies the upper limit of the range.
See also
SetPos

◆ SetSliderStyle()

void SetSliderStyle ( DWORD dwStyle )

Call this member to set the style of the slider control.

Parameters
dwStyle The style to be set.
See also
GetSliderStyle
The documentation for this class was generated from the following file:
  • XTPControlSlider.h


Toolkit Pro: CXTPControlSliderCtrl Class Reference

Protected Attributes | List of all members
CXTPControlSliderCtrl Class Reference

Inplace slider control of CXTPControlSlider. More...

Protected Attributes

CXTPControlSlider * m_pControl
Parent CXTPControlSlider control.

Detailed Description

Inplace slider control of CXTPControlSlider.

The documentation for this class was generated from the following file:
  • XTPControlSlider.h


Toolkit Pro: CXTPControlStatic Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPControlStatic Class Reference

CXTPControlStatic is a CXTPControl derived class. More...

Inheritance diagram for CXTPControlStatic:
[legend]

Public Member Functions

CXTPControlStatic ()
Constructs a CXTPControlStatic object.
void | SetWidth (int nWidth)
Call this member to set the width of the control.
- Public Member Functions inherited from CXTPControl
void | SetStyle (XTPButtonStyle buttonStyle)
Call this member to set the style of the control.
XTPButtonStyle | GetStyle () const
Call this member to get the control's style.
void | SetCaption (LPCTSTR lpszCaption)
Call this member to set the caption of the control.
void | SetCaption (UINT nIDCaption)
Call this member to set the caption of the control.
virtual CString | GetCaption () const
Call this member to get the control's caption.
void | SetShortcutText (LPCTSTR lpszShortcutText)
Call this member to set the shortcut string to the control.
CString | GetShortcutText () const
Call this member to get the control's shortcut.
void | SetDescription (LPCTSTR lpszDescription)
Call this member to set the description of the control.
virtual CString | GetDescription () const
Call this member to get the control's description.
void | SetTooltip (LPCTSTR lpszTooltip)
Call this member to set the tooltip of the control.
virtual CString | GetTooltip () const
Call this member to get the control's tooltip.
void | SetKeyboardTip (LPCTSTR lpszKeyboardTip)
Call this member to set the keyboard tip to the control.
CString | GetKeyboardTip () const
Call this member to get the keyboard tip.
void | SetCustomShortcutText (LPCTSTR lpszCustomShortcutText)
Call this member to set the text displayed for the shortcut in a pop-up menu.
CString | GetCustomShortcutText () const
Call this member to get the control's text displayed for the shortcut in a pop-up menu.
void | SetParameter (LPCTSTR lpszParameter)
Call this member to set the parameter of the control.
CString | GetParameter () const
Call this member to get the control's parameter.
void | SetID (int nId)
Call this member to set the identifier of the control.
int | GetID () const
Call this member to get the control's identifier.
long | GetIndex () const
Call this member to get the index of the control.
void | SetIconId (int nId)
Call this member to set the control icon's identifier.
int | GetIconId () const
Call this member to get the icon's identifier.
void | SetHelpId (int nId)
Call this member to set the control help identifier.
int | GetHelpId () const
Call this member to get the help identifier.
virtual void | SetBeginGroup (BOOL bBeginGroup)
Call this member to begin a new group using a separator.
BOOL | GetBeginGroup () const
Call this member to determine if the control has a separator.
virtual void | SetEnabled (BOOL bEnabled)
Call this member to enable/disable the control.
BOOL | GetEnabled () const
Call this member to check if the control is enabled.
virtual void | OnEnabledChanged ()
This method is called when a control's enabled state is changed.
virtual void | SetChecked (BOOL bChecked)
Call this member to set the checked state of the control.
BOOL | GetChecked () const
Call this member to get the checked state of the control.
virtual int | GetSelected () const
Call this member to check if the control is selected.
void | SetOnQuickAccess (BOOL bOnQuicAccess=FALSE)
Call this member to set whether a control should be a part of the Quick Access panel.
BOOL | IsOnQuickAccess () const
Call this member to check if a control is a part of the Quick Access panel.
virtual void | SetFocused (BOOL bFocused)
Call this member to set the focused state of the control.
virtual BOOL | IsFocused () const
Call this member to check the focused state of the control.
void | SetPressed (BOOL bPressed)
Call this member to set the pressed state of the control.
virtual BOOL | GetPressed () const
Call this member to check the pressed state of the control.
virtual void | SetRect (CRect rcControl)
This member is called to set the bounding rectangle of the control.
CRect | GetRect () const
Call this member to get the bounding rectangle of the control.
CXTPCommandBar * | GetParent () const
Call this member to get the parent command bar.
virtual BOOL | IsVisible (DWORD dwSkipFlags=0) const
Call this member to determine if the control is visible.
virtual BOOL | IsCaptionVisible () const
Call this member to determine if the caption of the control is visible.
void | SetVisible (BOOL bVisible)
Call this member to set the visibility of the control.
CXTPControls * | GetControls () const
Call this member to get the parent controls collection.
XTPControlType | GetType () const
Call this member to get the control's type.
void | SetFlags (DWORD dwFlags)
Call this member to set the flags of the control.
DWORD | GetFlags () const
Call this member to retrieve control special flags.
void | SetTag (DWORD_PTR dwTag)
This method sets the 32-bit value associated with the control.
DWORD_PTR | GetTag () const
This method retrieves the application-supplied, 32-bit value associated with the control.
virtual BOOL | Compare (CXTPControl *pOther)
Call this member to compare controls.
virtual CXTPCommandBar * | GetCommandBar () const
Call this member to get the child command bar.
void | SetCloseSubMenuOnClick (BOOL bCloseOnClick)
Call this member function to enable/disable the closing of sub-menus when a control is clicked in the menu.
BOOL | GetCloseSubMenuOnClick () const
Call this member function to check if sub-menus will close as soon as a control is clicked.
void | SetExecuteOnPressInterval (int nExecuteOnPressInterval)
Call this method to set the delay (in milliseconds) between WM_COMMAND messages while a button is pressed by the user.
int | GetExecuteOnPressInterval () const
Call this method to get the delay (in milliseconds) between WM_COMMAND messages while a button is pressed by the user.
CXTPRibbonGroup * | GetRibbonGroup () const
Returns the ribbon group that the control belongs to.
virtual BOOL | IsTransparent () const
Determines if the control needs to draw its background.
void | SetHideWrap (BOOL bHide)
This method is called to hide the control.
virtual void | SetHideFlags (DWORD dwFlags)
This method is called to hide the control.
BOOL | SetHideFlag (XTPControlHideFlags dwFlag, BOOL bSet)
Call this member to set/remove hide flags.
DWORD | GetHideFlags () const
Call this method to retrieve hidden flags.
CRect | GetRowRect () const
Call this method to retrieve the position of the control's row.
BOOL | GetWrap () const
Call this method to check if the control is wrapped.
void | SetRowRect (CRect rcRow)
Call this method to set the row of the control.
void | SetWrap (BOOL bWrap)
Call this member to set the control to wrapped.
BOOL | GetExpanded () const
Call this member to check if the control is expanded.
BOOL | IsCursorOver () const
Call this member to determine if the mouse pointer is over the control.
virtual void | OnExecute ()
This method is called when the control is executed.
virtual void | OnCalcDynamicSize (DWORD dwMode)
This method is called before recalculating the parent command bar size to calculate the dimensions of the control.
void | DelayRedrawParent ()
Call this method to redraw the parent command bar.
void | DelayLayoutParent ()
Call this method to recalculate the parent command bar size.
void | SetCategory (LPCTSTR lpszCategory)
Call this method to set the category of the control.
CString | GetCategory () const
Call this method to retrieve the category of the control.
CXTPImageManager * | GetImageManager () const
Call this method to retrieve the image manager.
CXTPPaintManager * | GetPaintManager () const
Call this method to retrieve the paint manager.
virtual CXTPImageManagerIcon * | GetImage (int nWidth=16) const
Call this method to retrieve the image of the control.
void | AssignDocTemplate (UINT nIDResource)
Call this method to assign a document template to the control.
void | ExcludeDocTemplate (UINT nIDResource)
Call this method to exclude the document template from control.
BOOL | IsItemDefault () const
Call this method to check if a control is a default menu item.
void | SetItemDefault (BOOL bDefault)
Call this method to set a control to be a default menu item.
BOOL | IsTemporary () const
Call this method to determine if a control is temporary.
void | Reset ()
Call this member to reset the icon and caption of a control to its default settings before it was customized by the user.
void | SetPrompt (LPCTSTR lpszPrompt)
Call this member to load a string from a STRINGTABLE resource to set the tooltip and description of a control.
void | SetCustomIcon (HICON hIcon)
Call this member to set a custom icon to this control.
virtual void | OnUnderlineActivate ()
This method is called when the user activates the control using its underline.
virtual BOOL | GetPopuped () const
Call this member to get the control's pop-up state.
void | RedrawParent (BOOL bAnimate=TRUE)
This method is called to redraw the parent command bar.
LRESULT | NotifySite (UINT code)
This method is called to send message code to the parent site window.
LRESULT | NotifySite (UINT code, NMXTPCONTROL *pNM)
This method is called to send message code to the parent site window.
LRESULT | NotifySite (CWnd *pSite, UINT code, NMXTPCONTROL *pNM)
This method is called to send message code to the parent site window.
virtual void | SetAction (CXTPControlAction *pAction)
Call this method to manually assign an action for control.
CXTPControlAction * | GetAction () const
Call this method to retrieve an action associated with control.
virtual void | OnThemeChanged ()
This method is called when the paint manager theme is changed.
virtual void | SetHeight (int nHeight)
Call this member to set the height of the control.
int | GetWidth () const
Call this member to get the width of the control.
int | GetHeight () const
Call this member to get the height of the control.
BOOL | HasDwmCompositedRect () const
This method is called to determine if control has a Vista DWM transparent area.
virtual CSize | GetButtonSize () const
Call this function to get the size of the command bar button.
virtual CSize | GetIconSize () const
Call this member function to get the size of a toolbar icon.
void | SetIconSize (CSize szIcon)
Call this member function to set the size of an icon for an individual control.
virtual void | OnClick (BOOL bKeyboard=FALSE, CPoint pt=CPoint(0, 0))
This method is called when the user clicks the control.
virtual BOOL | IsCustomizeMovable () const
This method is called to determine if control can be repositioned in customize mode.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

virtual CSize | GetSize (CDC *pDC)
This method is called to determine the size of the control.
virtual void | Draw (CDC *pDC)
This method is called to draw the control.
virtual void | Copy (CXTPControl *pControl, BOOL bRecursive=FALSE)
This method is called to copy the control.
virtual void | DoPropExchange (CXTPPropExchange *pPX)
Either reads this object from or writes this object to an archive.
- Protected Member Functions inherited from CXTPControl
CXTPControl ()
Constructs a CXTPControl object.
virtual | ~CXTPControl ()
Destroys a CXTPControl object, handles cleanup and deallocation.
virtual BOOL | IsFocusable () const
This method is called to check if the control can accept focus.
void | SetIndex (int nIndex)
This method is called to assign the order of the control in the controls list.
void | SetExpanded (BOOL bExpanded)
This method is called to set the control's expanded state.
virtual BOOL | OnHookKeyDown (UINT nChar, LPARAM lParam)
This method is called when a non-system key is pressed.
virtual BOOL | OnHookMouseWheel (UINT nFlags, short zDelta, CPoint point)
This method is called when the user rotates the mouse wheel.
virtual void | SetParent (CXTPCommandBar *pParent)
This method is called to assign a parent command bar object.
void | ScreenToClient (CPoint *point)
The ScreenToClient function converts the screen coordinates of a specified point on the screen.
void | ClickToolBarButton (CRect rcActiveRect=CRect(0, 0, 0, 0))
This helper method is called when the user clicks the toolbar's button.
virtual BOOL | OnSetPopup (BOOL bPopup)
This method is called to pop-up the control.
virtual void | OnLButtonUp (CPoint point)
This member is called when the user releases the left mouse button.
virtual void | OnLButtonDown (CPoint point)
This member is called when the user presses the left mouse button down.
virtual BOOL | OnRButtonDown (CPoint point)
This member is called when the user press the right mouse button.
virtual BOOL | OnRButtonUp (CPoint point)
This member is called when the user releases the right mouse button.
virtual BOOL | OnLButtonDblClk (CPoint point)
This member is called when the user double-clicks the left mouse button.
virtual void | OnMouseMove (CPoint point)
This member is called when the mouse cursor moves.
virtual void | OnMouseHover ()
Called after the mouse hovers over the control.
virtual BOOL | OnSetSelected (int bSelected)
This method is called when the control becomes selected.
BOOL | IsCustomizeMode () const
Call this method to determine if command bars is in customize mode.
virtual void | CustomizeStartDrag (CPoint point)
This member is called when the user starts to drag the control in customize mode.
virtual BOOL | CustomizeStartResize (CPoint point)
This method is called when user starts to resize control in customize mode.
virtual void | OnCustomizeDragOver (CXTPControl *pDataObject, CPoint point, DROPEFFECT &dropEffect)
This member is called when the user moves the mouse over the control.
virtual BOOL | DoCustomDragOver (CXTPCommandBar *pCommandBar, CPoint point, DROPEFFECT &dropEffect)
The implementation may implement a custom drag over handling logic in this method.
virtual BOOL | IsCustomizeResizeAllow () const
This member checks if the user can resize the control.
virtual int | GetCustomizeMinWidth () const
Retrieves the available minimum width of control.
virtual int | GetCustomizeMinHeight () const
Retrieves available minimum height of the control.
void | OnCustomizeMouseMove (CPoint point)
This member is called when the mouse cursor moves in customized mode.
virtual void | OnIdleUpdate ()
This virtual method is called in idle-time processing.
virtual void | OnRemoved ()
This method is called when a control is removed from the parent controls collection.
virtual INT_PTR | OnToolHitTest (CPoint point, TOOLINFO *pTI) const
The framework calls this member function to determine whether a point is in the bounding rectangle of the specified tool.
virtual void | RestoreCommandBarList (CXTPCommandBarList *pCommandBarList)
This method is called from LoadCommandBars to restore controls and its child command bars.
virtual void | GenerateCommandBarList (DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam)
This method is called from SaveCommandBars to save all child command bars.
virtual void | OnActionChanged (int nProperty)
This method is called when an action property is changed.
virtual void | OnActionChanging (int nProperty)
This method is called when an action property is about to be changed.
virtual void | OnCaptionChanged ()
This method is called when the control's caption is changed.
BOOL | IsLayoutRTL () const
Determines if right-to-left (RTL) mode is set.
BOOL | IsLayoutChanged ()
Call this member to determine if the layout has changed (RTL to LTR or LTR to RLT).

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControl
static CXTPControl *AFX_CDECL | FromUI (CCmdUI *pCmdUI)
Call this member to retrieve CXTPControl from a CCmdUI structure.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Attributes inherited from CXTPControl
DWORD_PTR | m_nTag
Control tag.
int | m_nIndex
Index of the control.
int | m_nId
Identifier of the control.
int | m_nIconId
Identifier of the control's image.
int | m_nHelpId
Help identifier.
int | m_nCustomIconId
Identifier of the control's custom image.
BOOL | m_bWrap
TRUE if the control is wrapped.
BOOL | m_bBeginGroup
TRUE if the control starts new group.
BOOL | m_bEnabled
TRUE if the control is enabled.
BOOL | m_bChecked
TRUE if the control is checked.
BOOL | m_bSelected
TRUE if the control is selected.
BOOL | m_bPressed
TRUE if the control is pushed.
BOOL | m_bTemporary
TRUE if the control is temporary.
BOOL | m_bOnQuickAccess
TRUE if the control is a part of Quick Access panel.
CRect | m_rcRow
Bounding rectangle of the control's row.
CRect | m_rcControl
Bounding rectangle of the control.
DWORD | m_dwHideFlags
Hidden flags.
DWORD | m_dwFlags
Flags of the control.
CString | m_strCaption
Caption of the control.
CString | m_strCustomCaption
User-defined caption.
CString | m_strShortcutText
Shortcut text.
CString | m_strShortcutTextAuto
Shortcut text.
CString | m_strTooltipText
Tooltip text.
CString | m_strDescriptionText
Description text.
CString | m_strParameter
Parameter text.
CString | m_strKeyboardTip
Keyboard tip.
CXTPControls * | m_pControls
Parent control collection.
XTPControlType | m_controlType
Type of the control.
CXTPCommandBar * | m_pParent
The Parent command bar.
BOOL | m_bExpanded
TRUE if the control is expanded.
CString | m_strCategory
Category of the control.
BOOL | m_bDefaultItem
TRUE if the item is default pop-up item.
CDocTemplateMap | m_mapDocTemplatesAssigned
Assigned templates.
CDocTemplateMap | m_mapDocTemplatesExcluded
Excluded templates.
XTPButtonStyle | m_buttonStyle
Button Style.
XTPButtonStyle | m_buttonCustomStyle
User-defined style of button.
XTPButtonStyle | m_buttonRibbonStyle
User-defined style of button.
BOOL | m_bCloseSubMenuOnClick
TRUE is sub-menus are closed as soon as a control is clicked.
CXTPRibbonGroup * | m_pRibbonGroup
Ribbon group of control.
CXTPControlAction * | m_pAction
Action of the control.
int | m_nWidth
Width of the control.
int | m_nHeight
Height of the control.
int | m_nExecuteOnPressInterval
Delay between each message when control is pressed.
CSize | m_szIcon
The size of the icon used for the control.
BOOL | m_bLayoutRTL
Indicate does last layout is RTL.

Detailed Description

CXTPControlStatic is a CXTPControl derived class.

It represents a static text control.

Member Function Documentation

◆ Copy()

virtual void Copy | ( | CXTPControl * | pControl,
 |  | BOOL | bRecursive = FALSE )
 protectedvirtual

This method is called to copy the control.

Parameters
pControl | Pointer to a source CXTPControl object.
bRecursive | TRUE to copy recursively.

Reimplemented from CXTPControl.

◆ DoPropExchange()

virtual void DoPropExchange ( CXTPPropExchange * pPX )
protectedvirtual

Either reads this object from or writes this object to an archive.

Parameters
pPX A CXTPPropExchange object to serialize to or from.

Reimplemented from CXTPControl.

◆ Draw()

virtual void Draw ( CDC * pDC )
protectedvirtual

This method is called to draw the control.

Parameters
pDC Pointer to a valid device context.

Reimplemented from CXTPControl.

◆ GetSize()

virtual CSize GetSize ( CDC * pDC )
protectedvirtual

This method is called to determine the size of the control.

Parameters
pDC Pointer to a valid device context.
Returns
A CSize object containing the size of the control.

Reimplemented from CXTPControl.

◆ SetWidth()

void SetWidth ( int nWidth )
virtual

Call this member to set the width of the control.

Parameters
nWidth The width of the control.

Reimplemented from CXTPControl.

The documentation for this class was generated from the following file:
  • XTPControlListBox.h


Toolkit Pro: CXTPControlTabWorkspace Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPControlTabWorkspace Class Reference

TabWorkspace control. More...

Inheritance diagram for CXTPControlTabWorkspace:
[legend]

Public Member Functions

CXTPControlTabWorkspace ()
Constructs a CXTPControlTabWorkspace object.
~CXTPControlTabWorkspace ()
Destroys a CXTPControlTabWorkspace object, handles cleanup and deallocation.
virtual void | RedrawControl (LPCRECT lpRect, BOOL bAnimate)
This member is called when the visual properties of the tabs are changed.
virtual CWnd * | GetWindow () const
This method is called to get the window handle of the workspace.
CXTPTabPaintManager * | GetPaintManager () const
Retrieves the paint manager.
virtual void | OnRecalcLayout ()
This method is called to recalculate the layout of the tab client.
XTPTabPosition | GetPosition () const
Call this member to get the current position of the tabs.
virtual void | OnRemoved ()
This method is called when an item is removed from the TabManager collection.
- Public Member Functions inherited from CXTPControlButton
CXTPControlButton ()
Constructs a CXTPControlButton object.
virtual | ~CXTPControlButton ()
Destroys a CXTPControlButton object, handles cleanup and deallocation.
void | SetStyleEx (XTPButtonStyle buttonStyle)
Call this member to set the style of the button containing vector icon.
XTPButtonStyle | GetStyleEx () const
Call this member to get the button's style containing vector icon.
void | DoPropExchange (CXTPPropExchange *pPX)
Either reads this object from or writes this object to an archive.
- Public Member Functions inherited from CXTPControl
void | SetStyle (XTPButtonStyle buttonStyle)
Call this member to set the style of the control.
XTPButtonStyle | GetStyle () const
Call this member to get the control's style.
void | SetCaption (LPCTSTR lpszCaption)
Call this member to set the caption of the control.
void | SetCaption (UINT nIDCaption)
Call this member to set the caption of the control.
virtual CString | GetCaption () const
Call this member to get the control's caption.
void | SetShortcutText (LPCTSTR lpszShortcutText)
Call this member to set the shortcut string to the control.
CString | GetShortcutText () const
Call this member to get the control's shortcut.
void | SetDescription (LPCTSTR lpszDescription)
Call this member to set the description of the control.
virtual CString | GetDescription () const
Call this member to get the control's description.
void | SetTooltip (LPCTSTR lpszTooltip)
Call this member to set the tooltip of the control.
virtual CString | GetTooltip () const
Call this member to get the control's tooltip.
void | SetKeyboardTip (LPCTSTR lpszKeyboardTip)
Call this member to set the keyboard tip to the control.
CString | GetKeyboardTip () const
Call this member to get the keyboard tip.
void | SetCustomShortcutText (LPCTSTR lpszCustomShortcutText)
Call this member to set the text displayed for the shortcut in a pop-up menu.
CString | GetCustomShortcutText () const
Call this member to get the control's text displayed for the shortcut in a pop-up menu.
void | SetParameter (LPCTSTR lpszParameter)
Call this member to set the parameter of the control.
CString | GetParameter () const
Call this member to get the control's parameter.
void | SetID (int nId)
Call this member to set the identifier of the control.
int | GetID () const
Call this member to get the control's identifier.
long | GetIndex () const
Call this member to get the index of the control.
void | SetIconId (int nId)
Call this member to set the control icon's identifier.
int | GetIconId () const
Call this member to get the icon's identifier.
void | SetHelpId (int nId)
Call this member to set the control help identifier.
int | GetHelpId () const
Call this member to get the help identifier.
virtual void | SetBeginGroup (BOOL bBeginGroup)
Call this member to begin a new group using a separator.
BOOL | GetBeginGroup () const
Call this member to determine if the control has a separator.
virtual void | SetEnabled (BOOL bEnabled)
Call this member to enable/disable the control.
BOOL | GetEnabled () const
Call this member to check if the control is enabled.
virtual void | OnEnabledChanged ()
This method is called when a control's enabled state is changed.
virtual void | SetChecked (BOOL bChecked)
Call this member to set the checked state of the control.
BOOL | GetChecked () const
Call this member to get the checked state of the control.
virtual int | GetSelected () const
Call this member to check if the control is selected.
void | SetOnQuickAccess (BOOL bOnQuicAccess=FALSE)
Call this member to set whether a control should be a part of the Quick Access panel.
BOOL | IsOnQuickAccess () const
Call this member to check if a control is a part of the Quick Access panel.
virtual void | SetFocused (BOOL bFocused)
Call this member to set the focused state of the control.
virtual BOOL | IsFocused () const
Call this member to check the focused state of the control.
void | SetPressed (BOOL bPressed)
Call this member to set the pressed state of the control.
virtual BOOL | GetPressed () const
Call this member to check the pressed state of the control.
CRect | GetRect () const
Call this member to get the bounding rectangle of the control.
CXTPCommandBar * | GetParent () const
Call this member to get the parent command bar.
virtual BOOL | IsVisible (DWORD dwSkipFlags=0) const
Call this member to determine if the control is visible.
virtual BOOL | IsCaptionVisible () const
Call this member to determine if the caption of the control is visible.
void | SetVisible (BOOL bVisible)
Call this member to set the visibility of the control.
CXTPControls * | GetControls () const
Call this member to get the parent controls collection.
XTPControlType | GetType () const
Call this member to get the control's type.
void | SetFlags (DWORD dwFlags)
Call this member to set the flags of the control.
DWORD | GetFlags () const
Call this member to retrieve control special flags.
void | SetTag (DWORD_PTR dwTag)
This method sets the 32-bit value associated with the control.
DWORD_PTR | GetTag () const
This method retrieves the application-supplied, 32-bit value associated with the control.
virtual BOOL | Compare (CXTPControl *pOther)
Call this member to compare controls.
virtual CXTPCommandBar * | GetCommandBar () const
Call this member to get the child command bar.
void | SetCloseSubMenuOnClick (BOOL bCloseOnClick)
Call this member function to enable/disable the closing of sub-menus when a control is clicked in the menu.
BOOL | GetCloseSubMenuOnClick () const
Call this member function to check if sub-menus will close as soon as a control is clicked.
void | SetExecuteOnPressInterval (int nExecuteOnPressInterval)
Call this method to set the delay (in milliseconds) between WM_COMMAND messages while a button is pressed by the user.
int | GetExecuteOnPressInterval () const
Call this method to get the delay (in milliseconds) between WM_COMMAND messages while a button is pressed by the user.
CXTPRibbonGroup * | GetRibbonGroup () const
Returns the ribbon group that the control belongs to.
virtual BOOL | IsTransparent () const
Determines if the control needs to draw its background.
void | SetHideWrap (BOOL bHide)
This method is called to hide the control.
virtual void | SetHideFlags (DWORD dwFlags)
This method is called to hide the control.
BOOL | SetHideFlag (XTPControlHideFlags dwFlag, BOOL bSet)
Call this member to set/remove hide flags.
DWORD | GetHideFlags () const
Call this method to retrieve hidden flags.
CRect | GetRowRect () const
Call this method to retrieve the position of the control's row.
BOOL | GetWrap () const
Call this method to check if the control is wrapped.
void | SetRowRect (CRect rcRow)
Call this method to set the row of the control.
void | SetWrap (BOOL bWrap)
Call this member to set the control to wrapped.
BOOL | GetExpanded () const
Call this member to check if the control is expanded.
BOOL | IsCursorOver () const
Call this member to determine if the mouse pointer is over the control.
virtual void | OnExecute ()
This method is called when the control is executed.
virtual void | OnCalcDynamicSize (DWORD dwMode)
This method is called before recalculating the parent command bar size to calculate the dimensions of the control.
void | DelayRedrawParent ()
Call this method to redraw the parent command bar.
void | DelayLayoutParent ()
Call this method to recalculate the parent command bar size.
void | SetCategory (LPCTSTR lpszCategory)
Call this method to set the category of the control.
CString | GetCategory () const
Call this method to retrieve the category of the control.
CXTPImageManager * | GetImageManager () const
Call this method to retrieve the image manager.
CXTPPaintManager * | GetPaintManager () const
Call this method to retrieve the paint manager.
virtual CXTPImageManagerIcon * | GetImage (int nWidth=16) const
Call this method to retrieve the image of the control.
void | AssignDocTemplate (UINT nIDResource)
Call this method to assign a document template to the control.
void | ExcludeDocTemplate (UINT nIDResource)
Call this method to exclude the document template from control.
BOOL | IsItemDefault () const
Call this method to check if a control is a default menu item.
void | SetItemDefault (BOOL bDefault)
Call this method to set a control to be a default menu item.
BOOL | IsTemporary () const
Call this method to determine if a control is temporary.
void | Reset ()
Call this member to reset the icon and caption of a control to its default settings before it was customized by the user.
void | SetPrompt (LPCTSTR lpszPrompt)
Call this member to load a string from a STRINGTABLE resource to set the tooltip and description of a control.
void | SetCustomIcon (HICON hIcon)
Call this member to set a custom icon to this control.
virtual void | OnUnderlineActivate ()
This method is called when the user activates the control using its underline.
virtual BOOL | GetPopuped () const
Call this member to get the control's pop-up state.
void | RedrawParent (BOOL bAnimate=TRUE)
This method is called to redraw the parent command bar.
LRESULT | NotifySite (UINT code)
This method is called to send message code to the parent site window.
LRESULT | NotifySite (UINT code, NMXTPCONTROL *pNM)
This method is called to send message code to the parent site window.
LRESULT | NotifySite (CWnd *pSite, UINT code, NMXTPCONTROL *pNM)
This method is called to send message code to the parent site window.
virtual void | SetAction (CXTPControlAction *pAction)
Call this method to manually assign an action for control.
CXTPControlAction * | GetAction () const
Call this method to retrieve an action associated with control.
virtual void | OnThemeChanged ()
This method is called when the paint manager theme is changed.
virtual void | SetWidth (int nWidth)
Call this member to set the width of the control.
virtual void | SetHeight (int nHeight)
Call this member to set the height of the control.
int | GetWidth () const
Call this member to get the width of the control.
int | GetHeight () const
Call this member to get the height of the control.
BOOL | HasDwmCompositedRect () const
This method is called to determine if control has a Vista DWM transparent area.
virtual CSize | GetButtonSize () const
Call this function to get the size of the command bar button.
virtual CSize | GetIconSize () const
Call this member function to get the size of a toolbar icon.
void | SetIconSize (CSize szIcon)
Call this member function to set the size of an icon for an individual control.
virtual BOOL | IsCustomizeMovable () const
This method is called to determine if control can be repositioned in customize mode.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

virtual void | SetRect (CRect rcControl)
This member is called to set the bounding rectangle of the tab control.
virtual void | Draw (CDC *pDC)
Call this member to draw the tab workspace.
virtual CSize | GetSize (CDC *pDC)
Call this member to retrieve the size of the tab workspace.
virtual INT_PTR | OnToolHitTest (CPoint point, TOOLINFO *pTI) const
The framework calls this member function to determine whether a point is in the bounding rectangle of the specified tool.
virtual void | OnClick (BOOL bKeyboard=FALSE, CPoint pt=CPoint(0, 0))
This method is called when the user clicks the control.
void | OnMouseMove (CPoint point)
This member is called when the mouse cursor moves.
- Protected Member Functions inherited from CXTPControlButton
virtual void | OnLButtonUp (CPoint point)
This member is called when the user releases the left mouse button.
virtual void | Copy (CXTPControl *pControl, BOOL bRecursive=FALSE)
This method is called to copy the control.
- Protected Member Functions inherited from CXTPControl
CXTPControl ()
Constructs a CXTPControl object.
virtual | ~CXTPControl ()
Destroys a CXTPControl object, handles cleanup and deallocation.
virtual BOOL | IsFocusable () const
This method is called to check if the control can accept focus.
void | SetIndex (int nIndex)
This method is called to assign the order of the control in the controls list.
void | SetExpanded (BOOL bExpanded)
This method is called to set the control's expanded state.
virtual BOOL | OnHookKeyDown (UINT nChar, LPARAM lParam)
This method is called when a non-system key is pressed.
virtual BOOL | OnHookMouseWheel (UINT nFlags, short zDelta, CPoint point)
This method is called when the user rotates the mouse wheel.
virtual void | SetParent (CXTPCommandBar *pParent)
This method is called to assign a parent command bar object.
void | ScreenToClient (CPoint *point)
The ScreenToClient function converts the screen coordinates of a specified point on the screen.
void | ClickToolBarButton (CRect rcActiveRect=CRect(0, 0, 0, 0))
This helper method is called when the user clicks the toolbar's button.
virtual BOOL | OnSetPopup (BOOL bPopup)
This method is called to pop-up the control.
virtual void | OnLButtonDown (CPoint point)
This member is called when the user presses the left mouse button down.
virtual BOOL | OnRButtonDown (CPoint point)
This member is called when the user press the right mouse button.
virtual BOOL | OnRButtonUp (CPoint point)
This member is called when the user releases the right mouse button.
virtual BOOL | OnLButtonDblClk (CPoint point)
This member is called when the user double-clicks the left mouse button.
virtual void | OnMouseHover ()
Called after the mouse hovers over the control.
virtual BOOL | OnSetSelected (int bSelected)
This method is called when the control becomes selected.
BOOL | IsCustomizeMode () const
Call this method to determine if command bars is in customize mode.
virtual void | CustomizeStartDrag (CPoint point)
This member is called when the user starts to drag the control in customize mode.
virtual BOOL | CustomizeStartResize (CPoint point)
This method is called when user starts to resize control in customize mode.
virtual void | OnCustomizeDragOver (CXTPControl *pDataObject, CPoint point, DROPEFFECT &dropEffect)
This member is called when the user moves the mouse over the control.
virtual BOOL | DoCustomDragOver (CXTPCommandBar *pCommandBar, CPoint point, DROPEFFECT &dropEffect)
The implementation may implement a custom drag over handling logic in this method.
virtual BOOL | IsCustomizeResizeAllow () const
This member checks if the user can resize the control.
virtual int | GetCustomizeMinWidth () const
Retrieves the available minimum width of control.
virtual int | GetCustomizeMinHeight () const
Retrieves available minimum height of the control.
void | OnCustomizeMouseMove (CPoint point)
This member is called when the mouse cursor moves in customized mode.
virtual void | OnIdleUpdate ()
This virtual method is called in idle-time processing.
virtual void | RestoreCommandBarList (CXTPCommandBarList *pCommandBarList)
This method is called from LoadCommandBars to restore controls and its child command bars.
virtual void | GenerateCommandBarList (DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam)
This method is called from SaveCommandBars to save all child command bars.
virtual void | OnActionChanged (int nProperty)
This method is called when an action property is changed.
virtual void | OnActionChanging (int nProperty)
This method is called when an action property is about to be changed.
virtual void | OnCaptionChanged ()
This method is called when the control's caption is changed.
BOOL | IsLayoutRTL () const
Determines if right-to-left (RTL) mode is set.
BOOL | IsLayoutChanged ()
Call this member to determine if the layout has changed (RTL to LTR or LTR to RLT).

Protected Attributes

BOOL | m_bForceRecalc
TRUE to force the tab control to recalculate it's layout.
- Protected Attributes inherited from CXTPControlButton
XTPButtonStyle | m_buttonStyleEx
User-defined style of button containing vector icon.
- Protected Attributes inherited from CXTPControl
DWORD_PTR | m_nTag
Control tag.
int | m_nIndex
Index of the control.
int | m_nId
Identifier of the control.
int | m_nIconId
Identifier of the control's image.
int | m_nHelpId
Help identifier.
int | m_nCustomIconId
Identifier of the control's custom image.
BOOL | m_bWrap
TRUE if the control is wrapped.
BOOL | m_bBeginGroup
TRUE if the control starts new group.
BOOL | m_bEnabled
TRUE if the control is enabled.
BOOL | m_bChecked
TRUE if the control is checked.
BOOL | m_bSelected
TRUE if the control is selected.
BOOL | m_bPressed
TRUE if the control is pushed.
BOOL | m_bTemporary
TRUE if the control is temporary.
BOOL | m_bOnQuickAccess
TRUE if the control is a part of Quick Access panel.
CRect | m_rcRow
Bounding rectangle of the control's row.
CRect | m_rcControl
Bounding rectangle of the control.
DWORD | m_dwHideFlags
Hidden flags.
DWORD | m_dwFlags
Flags of the control.
CString | m_strCaption
Caption of the control.
CString | m_strCustomCaption
User-defined caption.
CString | m_strShortcutText
Shortcut text.
CString | m_strShortcutTextAuto
Shortcut text.
CString | m_strTooltipText
Tooltip text.
CString | m_strDescriptionText
Description text.
CString | m_strParameter
Parameter text.
CString | m_strKeyboardTip
Keyboard tip.
CXTPControls * | m_pControls
Parent control collection.
XTPControlType | m_controlType
Type of the control.
CXTPCommandBar * | m_pParent
The Parent command bar.
BOOL | m_bExpanded
TRUE if the control is expanded.
CString | m_strCategory
Category of the control.
BOOL | m_bDefaultItem
TRUE if the item is default pop-up item.
CDocTemplateMap | m_mapDocTemplatesAssigned
Assigned templates.
CDocTemplateMap | m_mapDocTemplatesExcluded
Excluded templates.
XTPButtonStyle | m_buttonStyle
Button Style.
XTPButtonStyle | m_buttonCustomStyle
User-defined style of button.
XTPButtonStyle | m_buttonRibbonStyle
User-defined style of button.
BOOL | m_bCloseSubMenuOnClick
TRUE is sub-menus are closed as soon as a control is clicked.
CXTPRibbonGroup * | m_pRibbonGroup
Ribbon group of control.
CXTPControlAction * | m_pAction
Action of the control.
int | m_nWidth
Width of the control.
int | m_nHeight
Height of the control.
int | m_nExecuteOnPressInterval
Delay between each message when control is pressed.
CSize | m_szIcon
The size of the icon used for the control.
BOOL | m_bLayoutRTL
Indicate does last layout is RTL.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControl
static CXTPControl *AFX_CDECL | FromUI (CCmdUI *pCmdUI)
Call this member to retrieve CXTPControl from a CCmdUI structure.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

TabWorkspace control.

Member Function Documentation

◆ Draw()

virtual void Draw ( CDC * pDC )
protectedvirtual

Call this member to draw the tab workspace.

Parameters
pDC Pointer to a valid device context.

Reimplemented from CXTPControl.

◆ GetPaintManager()

CXTPTabPaintManager * GetPaintManager ( ) const

Retrieves the paint manager.

Returns
A pointer to a CXTPTabPaintManager object.

◆ GetPosition()

XTPTabPosition GetPosition ( ) const

Call this member to get the current position of the tabs.

Returns
Current XTPTabPosition of the tabs.

The position refers to where the tabs are located in relation to the TabClient. The tabs can be positioned on the top, bottom, left, or right side of the TabClient.

◆ GetSize()

virtual CSize GetSize ( CDC * pDC )
protectedvirtual

Call this member to retrieve the size of the tab workspace.

Parameters
pDC Pointer to a valid device context.
Returns
A CSize object containing the size of the tab workspace.

Reimplemented from CXTPControl.

◆ GetWindow()

virtual CWnd * GetWindow ( ) const
virtual

This method is called to get the window handle of the workspace.

Returns
The window handle of the workspace.

◆ OnClick()

virtual void OnClick | ( | BOOL | bKeyboard = FALSE,
 |  | CPoint | pt = CPoint(0, 0) )
 protectedvirtual

This method is called when the user clicks the control.

Parameters
bKeyboard | TRUE if the control is selected using the keyboard.
pt | Mouse cursor position.

Reimplemented from CXTPControlButton.

◆ OnMouseMove()

void OnMouseMove ( CPoint point )
protectedvirtual

This member is called when the mouse cursor moves.

Parameters
point Specifies the x- and y- coordinates of the cursor.

Reimplemented from CXTPControl.

◆ OnToolHitTest()

virtual INT_PTR OnToolHitTest | ( | CPoint | point,
 |  | TOOLINFO * | pTI ) const
 protectedvirtual

The framework calls this member function to determine whether a point is in the bounding rectangle of the specified tool.

Parameters
point | Specifies the x- and y- coordinates of the cursor. These coordinates are always relative to the upper-left corner of the window.
pTI | A pointer to a TOOLINFO structure.
Returns
If the tooltip control was found, then the window control ID is returned. If the tooltip control was not found, then a value of -1 is returned.

Reimplemented from CXTPControl.

◆ RedrawControl()

virtual void RedrawControl | ( | LPCRECT | lpRect,
 |  | BOOL | bAnimate )
 virtual

This member is called when the visual properties of the tabs are changed.

For example, color, mouse-over, and on-click. This member must be overridden in derived classes.

Parameters
lpRect | The rectangular area of the window that is invalid.
bAnimate | TRUE to animate changes in the bounding rectangle.

◆ SetRect()

virtual void SetRect ( CRect rcControl )
protectedvirtual

This member is called to set the bounding rectangle of the tab control.

Parameters
rcControl Bounding rectangle of the tab control.

Reimplemented from CXTPControl.

The documentation for this class was generated from the following file:
  • XTPControlTabWorkspace.h


Toolkit Pro: CXTPControlTheme Class Reference

Public Member Functions | Static Public Member Functions | Protected Attributes | List of all members
CXTPControlTheme Class Reference

CXTPControlTheme can be used as a base class for user defined themes. More...

Inheritance diagram for CXTPControlTheme:
[legend]

Public Member Functions

CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Static Public Member Functions

static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Protected Attributes

XTPControlTheme m_nTheme
Currently selected theme style index.

Detailed Description

CXTPControlTheme can be used as a base class for user defined themes.

Member Function Documentation

◆ GetThemeStyle()

XTPControlTheme GetThemeStyle ( ) const

Call this member function to get the style for the theme.

Returns
An XTPControlTheme enumerator index value representing the theme style.

◆ SetTheme()

static void AFX_CDECL SetTheme | ( | HWND | hWnd,
 |  | XTPControlTheme | nTheme )
 static

Static member posts the specified message to all immediate children of the specified HWND object.

If bDeep is TRUE, then the message is additionally sent to all other descendant windows.

Parameters
hWnd | HWND to the top level window, usually CMainFrame or CDialog.
nTheme | New visual theme. Can be any of the values listed in the Remarks section.

nTheme can be one of the following values: xtpControlThemeDefault: Default theme (either Windows classic or Windows Visual Style). xtpControlThemeFlat: Flat appearance style. xtpControlThemeUltraFlat: Ultra flat appearance style. xtpControlThemeOffice2000: Office 2000 style theme. xtpControlThemeOfficeXP: Office XP style theme. xtpControlThemeOffice2003: Office 2003 style theme. xtpControlThemeVisualStudio2005: Visual Studio 2005 style theme. xtpControlThemeVisualStudio2008: Visual Studio 2008 style theme. xtpControlThemeVisualStudio2010: Visual Studio 2010 style theme. xtpControlThemeResource: Office 2007 / Office 2010 / Windows 7 external resource .DLL.

Returns
The documentation for this class was generated from the following file:
  • XTPControlTheme.h


Toolkit Pro: CXTPControlToolbars Class Reference

Classes | Public Member Functions | Static Public Member Functions | Protected Member Functions | List of all members
CXTPControlToolbars Class Reference

CXTPControlToolbars is a CXTPControlButton derived class. More...

Inheritance diagram for CXTPControlToolbars:
[legend]

Classes

class CXTPControlToolbar
Represents a single toolbar item. More...

Public Member Functions

CXTPControlToolbars ()
Constructs a CXTPControlToolbars object.
- Public Member Functions inherited from CXTPControlButton
CXTPControlButton ()
Constructs a CXTPControlButton object.
virtual | ~CXTPControlButton ()
Destroys a CXTPControlButton object, handles cleanup and deallocation.
void | SetStyleEx (XTPButtonStyle buttonStyle)
Call this member to set the style of the button containing vector icon.
XTPButtonStyle | GetStyleEx () const
Call this member to get the button's style containing vector icon.
void | DoPropExchange (CXTPPropExchange *pPX)
Either reads this object from or writes this object to an archive.
- Public Member Functions inherited from CXTPControl
void | SetStyle (XTPButtonStyle buttonStyle)
Call this member to set the style of the control.
XTPButtonStyle | GetStyle () const
Call this member to get the control's style.
void | SetCaption (LPCTSTR lpszCaption)
Call this member to set the caption of the control.
void | SetCaption (UINT nIDCaption)
Call this member to set the caption of the control.
virtual CString | GetCaption () const
Call this member to get the control's caption.
void | SetShortcutText (LPCTSTR lpszShortcutText)
Call this member to set the shortcut string to the control.
CString | GetShortcutText () const
Call this member to get the control's shortcut.
void | SetDescription (LPCTSTR lpszDescription)
Call this member to set the description of the control.
virtual CString | GetDescription () const
Call this member to get the control's description.
void | SetTooltip (LPCTSTR lpszTooltip)
Call this member to set the tooltip of the control.
virtual CString | GetTooltip () const
Call this member to get the control's tooltip.
void | SetKeyboardTip (LPCTSTR lpszKeyboardTip)
Call this member to set the keyboard tip to the control.
CString | GetKeyboardTip () const
Call this member to get the keyboard tip.
void | SetCustomShortcutText (LPCTSTR lpszCustomShortcutText)
Call this member to set the text displayed for the shortcut in a pop-up menu.
CString | GetCustomShortcutText () const
Call this member to get the control's text displayed for the shortcut in a pop-up menu.
void | SetParameter (LPCTSTR lpszParameter)
Call this member to set the parameter of the control.
CString | GetParameter () const
Call this member to get the control's parameter.
void | SetID (int nId)
Call this member to set the identifier of the control.
int | GetID () const
Call this member to get the control's identifier.
long | GetIndex () const
Call this member to get the index of the control.
void | SetIconId (int nId)
Call this member to set the control icon's identifier.
int | GetIconId () const
Call this member to get the icon's identifier.
void | SetHelpId (int nId)
Call this member to set the control help identifier.
int | GetHelpId () const
Call this member to get the help identifier.
virtual void | SetBeginGroup (BOOL bBeginGroup)
Call this member to begin a new group using a separator.
BOOL | GetBeginGroup () const
Call this member to determine if the control has a separator.
virtual void | SetEnabled (BOOL bEnabled)
Call this member to enable/disable the control.
BOOL | GetEnabled () const
Call this member to check if the control is enabled.
virtual void | OnEnabledChanged ()
This method is called when a control's enabled state is changed.
virtual void | SetChecked (BOOL bChecked)
Call this member to set the checked state of the control.
BOOL | GetChecked () const
Call this member to get the checked state of the control.
virtual int | GetSelected () const
Call this member to check if the control is selected.
void | SetOnQuickAccess (BOOL bOnQuicAccess=FALSE)
Call this member to set whether a control should be a part of the Quick Access panel.
BOOL | IsOnQuickAccess () const
Call this member to check if a control is a part of the Quick Access panel.
virtual void | SetFocused (BOOL bFocused)
Call this member to set the focused state of the control.
virtual BOOL | IsFocused () const
Call this member to check the focused state of the control.
void | SetPressed (BOOL bPressed)
Call this member to set the pressed state of the control.
virtual BOOL | GetPressed () const
Call this member to check the pressed state of the control.
virtual void | SetRect (CRect rcControl)
This member is called to set the bounding rectangle of the control.
CRect | GetRect () const
Call this member to get the bounding rectangle of the control.
CXTPCommandBar * | GetParent () const
Call this member to get the parent command bar.
virtual BOOL | IsVisible (DWORD dwSkipFlags=0) const
Call this member to determine if the control is visible.
virtual BOOL | IsCaptionVisible () const
Call this member to determine if the caption of the control is visible.
void | SetVisible (BOOL bVisible)
Call this member to set the visibility of the control.
CXTPControls * | GetControls () const
Call this member to get the parent controls collection.
XTPControlType | GetType () const
Call this member to get the control's type.
void | SetFlags (DWORD dwFlags)
Call this member to set the flags of the control.
DWORD | GetFlags () const
Call this member to retrieve control special flags.
void | SetTag (DWORD_PTR dwTag)
This method sets the 32-bit value associated with the control.
DWORD_PTR | GetTag () const
This method retrieves the application-supplied, 32-bit value associated with the control.
virtual BOOL | Compare (CXTPControl *pOther)
Call this member to compare controls.
virtual CXTPCommandBar * | GetCommandBar () const
Call this member to get the child command bar.
void | SetCloseSubMenuOnClick (BOOL bCloseOnClick)
Call this member function to enable/disable the closing of sub-menus when a control is clicked in the menu.
BOOL | GetCloseSubMenuOnClick () const
Call this member function to check if sub-menus will close as soon as a control is clicked.
void | SetExecuteOnPressInterval (int nExecuteOnPressInterval)
Call this method to set the delay (in milliseconds) between WM_COMMAND messages while a button is pressed by the user.
int | GetExecuteOnPressInterval () const
Call this method to get the delay (in milliseconds) between WM_COMMAND messages while a button is pressed by the user.
CXTPRibbonGroup * | GetRibbonGroup () const
Returns the ribbon group that the control belongs to.
virtual BOOL | IsTransparent () const
Determines if the control needs to draw its background.
void | SetHideWrap (BOOL bHide)
This method is called to hide the control.
virtual void | SetHideFlags (DWORD dwFlags)
This method is called to hide the control.
BOOL | SetHideFlag (XTPControlHideFlags dwFlag, BOOL bSet)
Call this member to set/remove hide flags.
DWORD | GetHideFlags () const
Call this method to retrieve hidden flags.
CRect | GetRowRect () const
Call this method to retrieve the position of the control's row.
BOOL | GetWrap () const
Call this method to check if the control is wrapped.
void | SetRowRect (CRect rcRow)
Call this method to set the row of the control.
void | SetWrap (BOOL bWrap)
Call this member to set the control to wrapped.
BOOL | GetExpanded () const
Call this member to check if the control is expanded.
BOOL | IsCursorOver () const
Call this member to determine if the mouse pointer is over the control.
virtual void | OnExecute ()
This method is called when the control is executed.
virtual CSize | GetSize (CDC *pDC)
This method is called to determine the size of the control.
virtual void | Draw (CDC *pDC)
This method is called to draw the control.
void | DelayRedrawParent ()
Call this method to redraw the parent command bar.
void | DelayLayoutParent ()
Call this method to recalculate the parent command bar size.
void | SetCategory (LPCTSTR lpszCategory)
Call this method to set the category of the control.
CString | GetCategory () const
Call this method to retrieve the category of the control.
CXTPImageManager * | GetImageManager () const
Call this method to retrieve the image manager.
CXTPPaintManager * | GetPaintManager () const
Call this method to retrieve the paint manager.
virtual CXTPImageManagerIcon * | GetImage (int nWidth=16) const
Call this method to retrieve the image of the control.
void | AssignDocTemplate (UINT nIDResource)
Call this method to assign a document template to the control.
void | ExcludeDocTemplate (UINT nIDResource)
Call this method to exclude the document template from control.
BOOL | IsItemDefault () const
Call this method to check if a control is a default menu item.
void | SetItemDefault (BOOL bDefault)
Call this method to set a control to be a default menu item.
BOOL | IsTemporary () const
Call this method to determine if a control is temporary.
void | Reset ()
Call this member to reset the icon and caption of a control to its default settings before it was customized by the user.
void | SetPrompt (LPCTSTR lpszPrompt)
Call this member to load a string from a STRINGTABLE resource to set the tooltip and description of a control.
void | SetCustomIcon (HICON hIcon)
Call this member to set a custom icon to this control.
virtual void | OnUnderlineActivate ()
This method is called when the user activates the control using its underline.
virtual BOOL | GetPopuped () const
Call this member to get the control's pop-up state.
void | RedrawParent (BOOL bAnimate=TRUE)
This method is called to redraw the parent command bar.
LRESULT | NotifySite (UINT code)
This method is called to send message code to the parent site window.
LRESULT | NotifySite (UINT code, NMXTPCONTROL *pNM)
This method is called to send message code to the parent site window.
LRESULT | NotifySite (CWnd *pSite, UINT code, NMXTPCONTROL *pNM)
This method is called to send message code to the parent site window.
virtual void | SetAction (CXTPControlAction *pAction)
Call this method to manually assign an action for control.
CXTPControlAction * | GetAction () const
Call this method to retrieve an action associated with control.
virtual void | OnThemeChanged ()
This method is called when the paint manager theme is changed.
virtual void | SetWidth (int nWidth)
Call this member to set the width of the control.
virtual void | SetHeight (int nHeight)
Call this member to set the height of the control.
int | GetWidth () const
Call this member to get the width of the control.
int | GetHeight () const
Call this member to get the height of the control.
BOOL | HasDwmCompositedRect () const
This method is called to determine if control has a Vista DWM transparent area.
virtual CSize | GetButtonSize () const
Call this function to get the size of the command bar button.
virtual CSize | GetIconSize () const
Call this member function to get the size of a toolbar icon.
void | SetIconSize (CSize szIcon)
Call this member function to set the size of an icon for an individual control.
virtual BOOL | IsCustomizeMovable () const
This method is called to determine if control can be repositioned in customize mode.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Static Public Member Functions

static void AFX_CDECL | CreateToolbarMenu (CXTPCommandBar *pPopupBar, int nInsert, int nID, BOOL bAddCustomize, BOOL bBeginGroup=FALSE)
Creates a list of toolbars for the CommandBars Context Menu.
- Static Public Member Functions inherited from CXTPControl
static CXTPControl *AFX_CDECL | FromUI (CCmdUI *pCmdUI)
Call this member to retrieve CXTPControl from a CCmdUI structure.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Protected Member Functions

virtual void | OnCalcDynamicSize (DWORD dwMode)
This method is called before recalculating the parent command bar size to calculate the dimensions of the control.
virtual BOOL | DoCustomDragOver (CXTPCommandBar *pCommandBar, CPoint point, DROPEFFECT &dropEffect)
The implementation may implement a custom drag over handling logic in this method.
- Protected Member Functions inherited from CXTPControlButton
virtual void | OnClick (BOOL bKeyboard=FALSE, CPoint pt=CPoint(0, 0))
This method is called when the user clicks the control.
virtual void | OnLButtonUp (CPoint point)
This member is called when the user releases the left mouse button.
virtual void | Copy (CXTPControl *pControl, BOOL bRecursive=FALSE)
This method is called to copy the control.
- Protected Member Functions inherited from CXTPControl
CXTPControl ()
Constructs a CXTPControl object.
virtual | ~CXTPControl ()
Destroys a CXTPControl object, handles cleanup and deallocation.
virtual BOOL | IsFocusable () const
This method is called to check if the control can accept focus.
void | SetIndex (int nIndex)
This method is called to assign the order of the control in the controls list.
void | SetExpanded (BOOL bExpanded)
This method is called to set the control's expanded state.
virtual BOOL | OnHookKeyDown (UINT nChar, LPARAM lParam)
This method is called when a non-system key is pressed.
virtual BOOL | OnHookMouseWheel (UINT nFlags, short zDelta, CPoint point)
This method is called when the user rotates the mouse wheel.
virtual void | SetParent (CXTPCommandBar *pParent)
This method is called to assign a parent command bar object.
void | ScreenToClient (CPoint *point)
The ScreenToClient function converts the screen coordinates of a specified point on the screen.
void | ClickToolBarButton (CRect rcActiveRect=CRect(0, 0, 0, 0))
This helper method is called when the user clicks the toolbar's button.
virtual BOOL | OnSetPopup (BOOL bPopup)
This method is called to pop-up the control.
virtual void | OnLButtonDown (CPoint point)
This member is called when the user presses the left mouse button down.
virtual BOOL | OnRButtonDown (CPoint point)
This member is called when the user press the right mouse button.
virtual BOOL | OnRButtonUp (CPoint point)
This member is called when the user releases the right mouse button.
virtual BOOL | OnLButtonDblClk (CPoint point)
This member is called when the user double-clicks the left mouse button.
virtual void | OnMouseMove (CPoint point)
This member is called when the mouse cursor moves.
virtual void | OnMouseHover ()
Called after the mouse hovers over the control.
virtual BOOL | OnSetSelected (int bSelected)
This method is called when the control becomes selected.
BOOL | IsCustomizeMode () const
Call this method to determine if command bars is in customize mode.
virtual void | CustomizeStartDrag (CPoint point)
This member is called when the user starts to drag the control in customize mode.
virtual BOOL | CustomizeStartResize (CPoint point)
This method is called when user starts to resize control in customize mode.
virtual void | OnCustomizeDragOver (CXTPControl *pDataObject, CPoint point, DROPEFFECT &dropEffect)
This member is called when the user moves the mouse over the control.
virtual BOOL | IsCustomizeResizeAllow () const
This member checks if the user can resize the control.
virtual int | GetCustomizeMinWidth () const
Retrieves the available minimum width of control.
virtual int | GetCustomizeMinHeight () const
Retrieves available minimum height of the control.
void | OnCustomizeMouseMove (CPoint point)
This member is called when the mouse cursor moves in customized mode.
virtual void | OnIdleUpdate ()
This virtual method is called in idle-time processing.
virtual void | OnRemoved ()
This method is called when a control is removed from the parent controls collection.
virtual INT_PTR | OnToolHitTest (CPoint point, TOOLINFO *pTI) const
The framework calls this member function to determine whether a point is in the bounding rectangle of the specified tool.
virtual void | RestoreCommandBarList (CXTPCommandBarList *pCommandBarList)
This method is called from LoadCommandBars to restore controls and its child command bars.
virtual void | GenerateCommandBarList (DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam)
This method is called from SaveCommandBars to save all child command bars.
virtual void | OnActionChanged (int nProperty)
This method is called when an action property is changed.
virtual void | OnActionChanging (int nProperty)
This method is called when an action property is about to be changed.
virtual void | OnCaptionChanged ()
This method is called when the control's caption is changed.
BOOL | IsLayoutRTL () const
Determines if right-to-left (RTL) mode is set.
BOOL | IsLayoutChanged ()
Call this member to determine if the layout has changed (RTL to LTR or LTR to RLT).

Additional Inherited Members

- Protected Attributes inherited from CXTPControlButton
XTPButtonStyle | m_buttonStyleEx
User-defined style of button containing vector icon.
- Protected Attributes inherited from CXTPControl
DWORD_PTR | m_nTag
Control tag.
int | m_nIndex
Index of the control.
int | m_nId
Identifier of the control.
int | m_nIconId
Identifier of the control's image.
int | m_nHelpId
Help identifier.
int | m_nCustomIconId
Identifier of the control's custom image.
BOOL | m_bWrap
TRUE if the control is wrapped.
BOOL | m_bBeginGroup
TRUE if the control starts new group.
BOOL | m_bEnabled
TRUE if the control is enabled.
BOOL | m_bChecked
TRUE if the control is checked.
BOOL | m_bSelected
TRUE if the control is selected.
BOOL | m_bPressed
TRUE if the control is pushed.
BOOL | m_bTemporary
TRUE if the control is temporary.
BOOL | m_bOnQuickAccess
TRUE if the control is a part of Quick Access panel.
CRect | m_rcRow
Bounding rectangle of the control's row.
CRect | m_rcControl
Bounding rectangle of the control.
DWORD | m_dwHideFlags
Hidden flags.
DWORD | m_dwFlags
Flags of the control.
CString | m_strCaption
Caption of the control.
CString | m_strCustomCaption
User-defined caption.
CString | m_strShortcutText
Shortcut text.
CString | m_strShortcutTextAuto
Shortcut text.
CString | m_strTooltipText
Tooltip text.
CString | m_strDescriptionText
Description text.
CString | m_strParameter
Parameter text.
CString | m_strKeyboardTip
Keyboard tip.
CXTPControls * | m_pControls
Parent control collection.
XTPControlType | m_controlType
Type of the control.
CXTPCommandBar * | m_pParent
The Parent command bar.
BOOL | m_bExpanded
TRUE if the control is expanded.
CString | m_strCategory
Category of the control.
BOOL | m_bDefaultItem
TRUE if the item is default pop-up item.
CDocTemplateMap | m_mapDocTemplatesAssigned
Assigned templates.
CDocTemplateMap | m_mapDocTemplatesExcluded
Excluded templates.
XTPButtonStyle | m_buttonStyle
Button Style.
XTPButtonStyle | m_buttonCustomStyle
User-defined style of button.
XTPButtonStyle | m_buttonRibbonStyle
User-defined style of button.
BOOL | m_bCloseSubMenuOnClick
TRUE is sub-menus are closed as soon as a control is clicked.
CXTPRibbonGroup * | m_pRibbonGroup
Ribbon group of control.
CXTPControlAction * | m_pAction
Action of the control.
int | m_nWidth
Width of the control.
int | m_nHeight
Height of the control.
int | m_nExecuteOnPressInterval
Delay between each message when control is pressed.
CSize | m_szIcon
The size of the icon used for the control.
BOOL | m_bLayoutRTL
Indicate does last layout is RTL.

Detailed Description

CXTPControlToolbars is a CXTPControlButton derived class.

It is used internally to create toolbars list items.

Member Function Documentation

◆ CreateToolbarMenu()

static void AFX_CDECL CreateToolbarMenu | ( | CXTPCommandBar * | pPopupBar,
 |  | int | nInsert,
 |  | int | nID,
 |  | BOOL | bAddCustomize,
 |  | BOOL | bBeginGroup = FALSE )
 static

Creates a list of toolbars for the CommandBars Context Menu.

Parameters
pPopupBar | Pointer to a CXTPCommandBar object.
nInsert | Position to start inserting items in the context menu.
nID | ID to assign the menu items in the context menu.
bAddCustomize | TRUE to add the "Customize..." option at the bottom of the menu that allows the Toolbar Customization dialog to be opened.
bBeginGroup | TRUE to start a new group.
Returns

This is the context menu that appears when a toolbar is right-clicked. It lists all the toolbars and allows them to be hidden/displayed.

◆ DoCustomDragOver()

virtual BOOL DoCustomDragOver | ( | CXTPCommandBar * | pCommandBar,
 |  | CPoint | point,
 |  | DROPEFFECT & | dropEffect )
 protectedvirtual

The implementation may implement a custom drag over handling logic in this method.

Parameters
pCommandBar | Pointer to a CXTPCommandBar object.
point | Mouse position.
dropEffect | DROPEFFECT enumerator.
Returns
TRUE if custom implementation handles drag over, otherwise FALSE.

Reimplemented from CXTPControl.

◆ OnCalcDynamicSize()

virtual void OnCalcDynamicSize ( DWORD dwMode )
protectedvirtual

This method is called before recalculating the parent command bar size to calculate the dimensions of the control.

Parameters
dwMode Flags used to determine the height and width of the dynamic command bar. See Remarks section for a list of values.

The following predefined flags are used to determine the height and width of the dynamic command bar. Use the bitwise-OR (|) operator to combine the flags.

LM_STRETCH: Indicates whether the command bar should be stretched to the size of the frame. Set if the bar is not a docking bar (not available for docking). Not set when the bar is docked or floating (available for docking). If set, LM_STRETCH returns dimensions based on the LM_HORZ state. LM_STRETCH works similarly to the the bStretch parameter used in CalcFixedLayout; see that member function for more information about the relationship between stretching and orientation. LM_HORZ: Indicates that the bar is horizontally or vertically oriented. Set if the bar is horizontally oriented, and if it is vertically oriented, it is not set. LM_HORZ works similarly to the the bHorz parameter used in CalcFixedLayout; see that member function for more information about the relationship between stretching and orientation. LM_MRUWIDTH: Most Recently Used Dynamic Width. Uses the remembered most recently used width. LM_HORZDOCK: Horizontal Docked Dimensions. Returns the dynamic size with the largest width. LM_VERTDOCK: Vertical Docked Dimensions. Returns the dynamic size with the largest height. LM_COMMIT: Resets LM_MRUWIDTH to the current width of the floating command bar.

The framework calls this member function to calculate the dimensions of a dynamic command bar.

Override this member function to provide your own layout in classes you derive from CXTPControl. XTP classes derived from CXTPControl, such as CXTPControlComboBox, override this member function to provide their own implementation.

See also
CXTPControlComboBox, CXTPControlCustom, CXTPControlEdit, CXTPControlWindowList, CXTPControlWorkspaceActions, CXTPControl, CXTPControlOleItems, CXTPControlRecentFileList, CXTPControlSelector, CXTPControlListBox

Reimplemented from CXTPControl.

The documentation for this class was generated from the following file:
  • XTPControlExt.h


Toolkit Pro: CXTPControlToolbars::CXTPControlToolbar Class Reference

  • CXTPControlToolbars
  • CXTPControlToolbar
List of all members
CXTPControlToolbars::CXTPControlToolbar Class Reference

Represents a single toolbar item. More...

Inheritance diagram for CXTPControlToolbars::CXTPControlToolbar:
[legend]

Additional Inherited Members

- Public Member Functions inherited from CXTPControlButton
CXTPControlButton ()
Constructs a CXTPControlButton object.
virtual | ~CXTPControlButton ()
Destroys a CXTPControlButton object, handles cleanup and deallocation.
void | SetStyleEx (XTPButtonStyle buttonStyle)
Call this member to set the style of the button containing vector icon.
XTPButtonStyle | GetStyleEx () const
Call this member to get the button's style containing vector icon.
void | DoPropExchange (CXTPPropExchange *pPX)
Either reads this object from or writes this object to an archive.
- Public Member Functions inherited from CXTPControl
void | SetStyle (XTPButtonStyle buttonStyle)
Call this member to set the style of the control.
XTPButtonStyle | GetStyle () const
Call this member to get the control's style.
void | SetCaption (LPCTSTR lpszCaption)
Call this member to set the caption of the control.
void | SetCaption (UINT nIDCaption)
Call this member to set the caption of the control.
virtual CString | GetCaption () const
Call this member to get the control's caption.
void | SetShortcutText (LPCTSTR lpszShortcutText)
Call this member to set the shortcut string to the control.
CString | GetShortcutText () const
Call this member to get the control's shortcut.
void | SetDescription (LPCTSTR lpszDescription)
Call this member to set the description of the control.
virtual CString | GetDescription () const
Call this member to get the control's description.
void | SetTooltip (LPCTSTR lpszTooltip)
Call this member to set the tooltip of the control.
virtual CString | GetTooltip () const
Call this member to get the control's tooltip.
void | SetKeyboardTip (LPCTSTR lpszKeyboardTip)
Call this member to set the keyboard tip to the control.
CString | GetKeyboardTip () const
Call this member to get the keyboard tip.
void | SetCustomShortcutText (LPCTSTR lpszCustomShortcutText)
Call this member to set the text displayed for the shortcut in a pop-up menu.
CString | GetCustomShortcutText () const
Call this member to get the control's text displayed for the shortcut in a pop-up menu.
void | SetParameter (LPCTSTR lpszParameter)
Call this member to set the parameter of the control.
CString | GetParameter () const
Call this member to get the control's parameter.
void | SetID (int nId)
Call this member to set the identifier of the control.
int | GetID () const
Call this member to get the control's identifier.
long | GetIndex () const
Call this member to get the index of the control.
void | SetIconId (int nId)
Call this member to set the control icon's identifier.
int | GetIconId () const
Call this member to get the icon's identifier.
void | SetHelpId (int nId)
Call this member to set the control help identifier.
int | GetHelpId () const
Call this member to get the help identifier.
virtual void | SetBeginGroup (BOOL bBeginGroup)
Call this member to begin a new group using a separator.
BOOL | GetBeginGroup () const
Call this member to determine if the control has a separator.
virtual void | SetEnabled (BOOL bEnabled)
Call this member to enable/disable the control.
BOOL | GetEnabled () const
Call this member to check if the control is enabled.
virtual void | OnEnabledChanged ()
This method is called when a control's enabled state is changed.
virtual void | SetChecked (BOOL bChecked)
Call this member to set the checked state of the control.
BOOL | GetChecked () const
Call this member to get the checked state of the control.
virtual int | GetSelected () const
Call this member to check if the control is selected.
void | SetOnQuickAccess (BOOL bOnQuicAccess=FALSE)
Call this member to set whether a control should be a part of the Quick Access panel.
BOOL | IsOnQuickAccess () const
Call this member to check if a control is a part of the Quick Access panel.
virtual void | SetFocused (BOOL bFocused)
Call this member to set the focused state of the control.
virtual BOOL | IsFocused () const
Call this member to check the focused state of the control.
void | SetPressed (BOOL bPressed)
Call this member to set the pressed state of the control.
virtual BOOL | GetPressed () const
Call this member to check the pressed state of the control.
virtual void | SetRect (CRect rcControl)
This member is called to set the bounding rectangle of the control.
CRect | GetRect () const
Call this member to get the bounding rectangle of the control.
CXTPCommandBar * | GetParent () const
Call this member to get the parent command bar.
virtual BOOL | IsVisible (DWORD dwSkipFlags=0) const
Call this member to determine if the control is visible.
virtual BOOL | IsCaptionVisible () const
Call this member to determine if the caption of the control is visible.
void | SetVisible (BOOL bVisible)
Call this member to set the visibility of the control.
CXTPControls * | GetControls () const
Call this member to get the parent controls collection.
XTPControlType | GetType () const
Call this member to get the control's type.
void | SetFlags (DWORD dwFlags)
Call this member to set the flags of the control.
DWORD | GetFlags () const
Call this member to retrieve control special flags.
void | SetTag (DWORD_PTR dwTag)
This method sets the 32-bit value associated with the control.
DWORD_PTR | GetTag () const
This method retrieves the application-supplied, 32-bit value associated with the control.
virtual BOOL | Compare (CXTPControl *pOther)
Call this member to compare controls.
virtual CXTPCommandBar * | GetCommandBar () const
Call this member to get the child command bar.
void | SetCloseSubMenuOnClick (BOOL bCloseOnClick)
Call this member function to enable/disable the closing of sub-menus when a control is clicked in the menu.
BOOL | GetCloseSubMenuOnClick () const
Call this member function to check if sub-menus will close as soon as a control is clicked.
void | SetExecuteOnPressInterval (int nExecuteOnPressInterval)
Call this method to set the delay (in milliseconds) between WM_COMMAND messages while a button is pressed by the user.
int | GetExecuteOnPressInterval () const
Call this method to get the delay (in milliseconds) between WM_COMMAND messages while a button is pressed by the user.
CXTPRibbonGroup * | GetRibbonGroup () const
Returns the ribbon group that the control belongs to.
virtual BOOL | IsTransparent () const
Determines if the control needs to draw its background.
void | SetHideWrap (BOOL bHide)
This method is called to hide the control.
virtual void | SetHideFlags (DWORD dwFlags)
This method is called to hide the control.
BOOL | SetHideFlag (XTPControlHideFlags dwFlag, BOOL bSet)
Call this member to set/remove hide flags.
DWORD | GetHideFlags () const
Call this method to retrieve hidden flags.
CRect | GetRowRect () const
Call this method to retrieve the position of the control's row.
BOOL | GetWrap () const
Call this method to check if the control is wrapped.
void | SetRowRect (CRect rcRow)
Call this method to set the row of the control.
void | SetWrap (BOOL bWrap)
Call this member to set the control to wrapped.
BOOL | GetExpanded () const
Call this member to check if the control is expanded.
BOOL | IsCursorOver () const
Call this member to determine if the mouse pointer is over the control.
virtual CSize | GetSize (CDC *pDC)
This method is called to determine the size of the control.
virtual void | Draw (CDC *pDC)
This method is called to draw the control.
virtual void | OnCalcDynamicSize (DWORD dwMode)
This method is called before recalculating the parent command bar size to calculate the dimensions of the control.
void | DelayRedrawParent ()
Call this method to redraw the parent command bar.
void | DelayLayoutParent ()
Call this method to recalculate the parent command bar size.
void | SetCategory (LPCTSTR lpszCategory)
Call this method to set the category of the control.
CString | GetCategory () const
Call this method to retrieve the category of the control.
CXTPImageManager * | GetImageManager () const
Call this method to retrieve the image manager.
CXTPPaintManager * | GetPaintManager () const
Call this method to retrieve the paint manager.
virtual CXTPImageManagerIcon * | GetImage (int nWidth=16) const
Call this method to retrieve the image of the control.
void | AssignDocTemplate (UINT nIDResource)
Call this method to assign a document template to the control.
void | ExcludeDocTemplate (UINT nIDResource)
Call this method to exclude the document template from control.
BOOL | IsItemDefault () const
Call this method to check if a control is a default menu item.
void | SetItemDefault (BOOL bDefault)
Call this method to set a control to be a default menu item.
BOOL | IsTemporary () const
Call this method to determine if a control is temporary.
void | Reset ()
Call this member to reset the icon and caption of a control to its default settings before it was customized by the user.
void | SetPrompt (LPCTSTR lpszPrompt)
Call this member to load a string from a STRINGTABLE resource to set the tooltip and description of a control.
void | SetCustomIcon (HICON hIcon)
Call this member to set a custom icon to this control.
virtual void | OnUnderlineActivate ()
This method is called when the user activates the control using its underline.
virtual BOOL | GetPopuped () const
Call this member to get the control's pop-up state.
void | RedrawParent (BOOL bAnimate=TRUE)
This method is called to redraw the parent command bar.
LRESULT | NotifySite (UINT code)
This method is called to send message code to the parent site window.
LRESULT | NotifySite (UINT code, NMXTPCONTROL *pNM)
This method is called to send message code to the parent site window.
LRESULT | NotifySite (CWnd *pSite, UINT code, NMXTPCONTROL *pNM)
This method is called to send message code to the parent site window.
virtual void | SetAction (CXTPControlAction *pAction)
Call this method to manually assign an action for control.
CXTPControlAction * | GetAction () const
Call this method to retrieve an action associated with control.
virtual void | OnThemeChanged ()
This method is called when the paint manager theme is changed.
virtual void | SetWidth (int nWidth)
Call this member to set the width of the control.
virtual void | SetHeight (int nHeight)
Call this member to set the height of the control.
int | GetWidth () const
Call this member to get the width of the control.
int | GetHeight () const
Call this member to get the height of the control.
BOOL | HasDwmCompositedRect () const
This method is called to determine if control has a Vista DWM transparent area.
virtual CSize | GetButtonSize () const
Call this function to get the size of the command bar button.
virtual CSize | GetIconSize () const
Call this member function to get the size of a toolbar icon.
void | SetIconSize (CSize szIcon)
Call this member function to set the size of an icon for an individual control.
virtual BOOL | IsCustomizeMovable () const
This method is called to determine if control can be repositioned in customize mode.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.
- Static Public Member Functions inherited from CXTPControl
static CXTPControl *AFX_CDECL | FromUI (CCmdUI *pCmdUI)
Call this member to retrieve CXTPControl from a CCmdUI structure.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Member Functions inherited from CXTPControlButton
virtual void | OnClick (BOOL bKeyboard=FALSE, CPoint pt=CPoint(0, 0))
This method is called when the user clicks the control.
virtual void | OnLButtonUp (CPoint point)
This member is called when the user releases the left mouse button.
virtual void | Copy (CXTPControl *pControl, BOOL bRecursive=FALSE)
This method is called to copy the control.
- Protected Member Functions inherited from CXTPControl
CXTPControl ()
Constructs a CXTPControl object.
virtual | ~CXTPControl ()
Destroys a CXTPControl object, handles cleanup and deallocation.
virtual BOOL | IsFocusable () const
This method is called to check if the control can accept focus.
void | SetIndex (int nIndex)
This method is called to assign the order of the control in the controls list.
void | SetExpanded (BOOL bExpanded)
This method is called to set the control's expanded state.
virtual BOOL | OnHookKeyDown (UINT nChar, LPARAM lParam)
This method is called when a non-system key is pressed.
virtual BOOL | OnHookMouseWheel (UINT nFlags, short zDelta, CPoint point)
This method is called when the user rotates the mouse wheel.
virtual void | SetParent (CXTPCommandBar *pParent)
This method is called to assign a parent command bar object.
void | ScreenToClient (CPoint *point)
The ScreenToClient function converts the screen coordinates of a specified point on the screen.
void | ClickToolBarButton (CRect rcActiveRect=CRect(0, 0, 0, 0))
This helper method is called when the user clicks the toolbar's button.
virtual BOOL | OnSetPopup (BOOL bPopup)
This method is called to pop-up the control.
virtual void | OnLButtonDown (CPoint point)
This member is called when the user presses the left mouse button down.
virtual BOOL | OnRButtonDown (CPoint point)
This member is called when the user press the right mouse button.
virtual BOOL | OnRButtonUp (CPoint point)
This member is called when the user releases the right mouse button.
virtual BOOL | OnLButtonDblClk (CPoint point)
This member is called when the user double-clicks the left mouse button.
virtual void | OnMouseMove (CPoint point)
This member is called when the mouse cursor moves.
virtual void | OnMouseHover ()
Called after the mouse hovers over the control.
virtual BOOL | OnSetSelected (int bSelected)
This method is called when the control becomes selected.
BOOL | IsCustomizeMode () const
Call this method to determine if command bars is in customize mode.
virtual void | CustomizeStartDrag (CPoint point)
This member is called when the user starts to drag the control in customize mode.
virtual BOOL | CustomizeStartResize (CPoint point)
This method is called when user starts to resize control in customize mode.
virtual void | OnCustomizeDragOver (CXTPControl *pDataObject, CPoint point, DROPEFFECT &dropEffect)
This member is called when the user moves the mouse over the control.
virtual BOOL | DoCustomDragOver (CXTPCommandBar *pCommandBar, CPoint point, DROPEFFECT &dropEffect)
The implementation may implement a custom drag over handling logic in this method.
virtual BOOL | IsCustomizeResizeAllow () const
This member checks if the user can resize the control.
virtual int | GetCustomizeMinWidth () const
Retrieves the available minimum width of control.
virtual int | GetCustomizeMinHeight () const
Retrieves available minimum height of the control.
void | OnCustomizeMouseMove (CPoint point)
This member is called when the mouse cursor moves in customized mode.
virtual void | OnIdleUpdate ()
This virtual method is called in idle-time processing.
virtual void | OnRemoved ()
This method is called when a control is removed from the parent controls collection.
virtual INT_PTR | OnToolHitTest (CPoint point, TOOLINFO *pTI) const
The framework calls this member function to determine whether a point is in the bounding rectangle of the specified tool.
virtual void | RestoreCommandBarList (CXTPCommandBarList *pCommandBarList)
This method is called from LoadCommandBars to restore controls and its child command bars.
virtual void | GenerateCommandBarList (DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam)
This method is called from SaveCommandBars to save all child command bars.
virtual void | OnActionChanged (int nProperty)
This method is called when an action property is changed.
virtual void | OnActionChanging (int nProperty)
This method is called when an action property is about to be changed.
virtual void | OnCaptionChanged ()
This method is called when the control's caption is changed.
BOOL | IsLayoutRTL () const
Determines if right-to-left (RTL) mode is set.
BOOL | IsLayoutChanged ()
Call this member to determine if the layout has changed (RTL to LTR or LTR to RLT).
- Protected Attributes inherited from CXTPControlButton
XTPButtonStyle | m_buttonStyleEx
User-defined style of button containing vector icon.
- Protected Attributes inherited from CXTPControl
DWORD_PTR | m_nTag
Control tag.
int | m_nIndex
Index of the control.
int | m_nId
Identifier of the control.
int | m_nIconId
Identifier of the control's image.
int | m_nHelpId
Help identifier.
int | m_nCustomIconId
Identifier of the control's custom image.
BOOL | m_bWrap
TRUE if the control is wrapped.
BOOL | m_bBeginGroup
TRUE if the control starts new group.
BOOL | m_bEnabled
TRUE if the control is enabled.
BOOL | m_bChecked
TRUE if the control is checked.
BOOL | m_bSelected
TRUE if the control is selected.
BOOL | m_bPressed
TRUE if the control is pushed.
BOOL | m_bTemporary
TRUE if the control is temporary.
BOOL | m_bOnQuickAccess
TRUE if the control is a part of Quick Access panel.
CRect | m_rcRow
Bounding rectangle of the control's row.
CRect | m_rcControl
Bounding rectangle of the control.
DWORD | m_dwHideFlags
Hidden flags.
DWORD | m_dwFlags
Flags of the control.
CString | m_strCaption
Caption of the control.
CString | m_strCustomCaption
User-defined caption.
CString | m_strShortcutText
Shortcut text.
CString | m_strShortcutTextAuto
Shortcut text.
CString | m_strTooltipText
Tooltip text.
CString | m_strDescriptionText
Description text.
CString | m_strParameter
Parameter text.
CString | m_strKeyboardTip
Keyboard tip.
CXTPControls * | m_pControls
Parent control collection.
XTPControlType | m_controlType
Type of the control.
CXTPCommandBar * | m_pParent
The Parent command bar.
BOOL | m_bExpanded
TRUE if the control is expanded.
CString | m_strCategory
Category of the control.
BOOL | m_bDefaultItem
TRUE if the item is default pop-up item.
CDocTemplateMap | m_mapDocTemplatesAssigned
Assigned templates.
CDocTemplateMap | m_mapDocTemplatesExcluded
Excluded templates.
XTPButtonStyle | m_buttonStyle
Button Style.
XTPButtonStyle | m_buttonCustomStyle
User-defined style of button.
XTPButtonStyle | m_buttonRibbonStyle
User-defined style of button.
BOOL | m_bCloseSubMenuOnClick
TRUE is sub-menus are closed as soon as a control is clicked.
CXTPRibbonGroup * | m_pRibbonGroup
Ribbon group of control.
CXTPControlAction * | m_pAction
Action of the control.
int | m_nWidth
Width of the control.
int | m_nHeight
Height of the control.
int | m_nExecuteOnPressInterval
Delay between each message when control is pressed.
CSize | m_szIcon
The size of the icon used for the control.
BOOL | m_bLayoutRTL
Indicate does last layout is RTL.

Detailed Description

Represents a single toolbar item.

The documentation for this class was generated from the following file:
  • XTPControlExt.h


Toolkit Pro: CXTPControlWindowList Class Reference

Static Public Member Functions | Static Public Attributes | Protected Member Functions | List of all members
CXTPControlWindowList Class Reference

CXTPControlWindowList is a CXTPControlButton derived class. More...

Inheritance diagram for CXTPControlWindowList:
[legend]

Static Public Member Functions

static CString AFX_CDECL | ConstructCaption (const CString &lpszTitle, int nIndex)
Adds the number and an ampersand "&" before the caption of an item that appears in the Windows List.
- Static Public Member Functions inherited from CXTPControl
static CXTPControl *AFX_CDECL | FromUI (CCmdUI *pCmdUI)
Call this member to retrieve CXTPControl from a CCmdUI structure.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Static Public Attributes

static UINT | m_nFistMDIChild
First MDI child ID.
static UINT | m_nItemCount
Maximum allowed items.
static BOOL | m_bShowRadioButtons
TRUE to show Radio buttons.

Protected Member Functions

virtual void | OnCalcDynamicSize (DWORD dwMode)
This method is called before recalculating the parent command bar size to calculate the dimensions of the control.
virtual BOOL | DoCustomDragOver (CXTPCommandBar *pCommandBar, CPoint point, DROPEFFECT &dropEffect)
The implementation may implement a custom drag over handling logic in this method.
- Protected Member Functions inherited from CXTPControlButton
virtual void | OnClick (BOOL bKeyboard=FALSE, CPoint pt=CPoint(0, 0))
This method is called when the user clicks the control.
virtual void | OnLButtonUp (CPoint point)
This member is called when the user releases the left mouse button.
virtual void | Copy (CXTPControl *pControl, BOOL bRecursive=FALSE)
This method is called to copy the control.
- Protected Member Functions inherited from CXTPControl
CXTPControl ()
Constructs a CXTPControl object.
virtual | ~CXTPControl ()
Destroys a CXTPControl object, handles cleanup and deallocation.
virtual BOOL | IsFocusable () const
This method is called to check if the control can accept focus.
void | SetIndex (int nIndex)
This method is called to assign the order of the control in the controls list.
void | SetExpanded (BOOL bExpanded)
This method is called to set the control's expanded state.
virtual BOOL | OnHookKeyDown (UINT nChar, LPARAM lParam)
This method is called when a non-system key is pressed.
virtual BOOL | OnHookMouseWheel (UINT nFlags, short zDelta, CPoint point)
This method is called when the user rotates the mouse wheel.
virtual void | SetParent (CXTPCommandBar *pParent)
This method is called to assign a parent command bar object.
void | ScreenToClient (CPoint *point)
The ScreenToClient function converts the screen coordinates of a specified point on the screen.
void | ClickToolBarButton (CRect rcActiveRect=CRect(0, 0, 0, 0))
This helper method is called when the user clicks the toolbar's button.
virtual BOOL | OnSetPopup (BOOL bPopup)
This method is called to pop-up the control.
virtual void | OnLButtonDown (CPoint point)
This member is called when the user presses the left mouse button down.
virtual BOOL | OnRButtonDown (CPoint point)
This member is called when the user press the right mouse button.
virtual BOOL | OnRButtonUp (CPoint point)
This member is called when the user releases the right mouse button.
virtual BOOL | OnLButtonDblClk (CPoint point)
This member is called when the user double-clicks the left mouse button.
virtual void | OnMouseMove (CPoint point)
This member is called when the mouse cursor moves.
virtual void | OnMouseHover ()
Called after the mouse hovers over the control.
virtual BOOL | OnSetSelected (int bSelected)
This method is called when the control becomes selected.
BOOL | IsCustomizeMode () const
Call this method to determine if command bars is in customize mode.
virtual void | CustomizeStartDrag (CPoint point)
This member is called when the user starts to drag the control in customize mode.
virtual BOOL | CustomizeStartResize (CPoint point)
This method is called when user starts to resize control in customize mode.
virtual void | OnCustomizeDragOver (CXTPControl *pDataObject, CPoint point, DROPEFFECT &dropEffect)
This member is called when the user moves the mouse over the control.
virtual BOOL | IsCustomizeResizeAllow () const
This member checks if the user can resize the control.
virtual int | GetCustomizeMinWidth () const
Retrieves the available minimum width of control.
virtual int | GetCustomizeMinHeight () const
Retrieves available minimum height of the control.
void | OnCustomizeMouseMove (CPoint point)
This member is called when the mouse cursor moves in customized mode.
virtual void | OnIdleUpdate ()
This virtual method is called in idle-time processing.
virtual void | OnRemoved ()
This method is called when a control is removed from the parent controls collection.
virtual INT_PTR | OnToolHitTest (CPoint point, TOOLINFO *pTI) const
The framework calls this member function to determine whether a point is in the bounding rectangle of the specified tool.
virtual void | RestoreCommandBarList (CXTPCommandBarList *pCommandBarList)
This method is called from LoadCommandBars to restore controls and its child command bars.
virtual void | GenerateCommandBarList (DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam)
This method is called from SaveCommandBars to save all child command bars.
virtual void | OnActionChanged (int nProperty)
This method is called when an action property is changed.
virtual void | OnActionChanging (int nProperty)
This method is called when an action property is about to be changed.
virtual void | OnCaptionChanged ()
This method is called when the control's caption is changed.
BOOL | IsLayoutRTL () const
Determines if right-to-left (RTL) mode is set.
BOOL | IsLayoutChanged ()
Call this member to determine if the layout has changed (RTL to LTR or LTR to RLT).

Additional Inherited Members

- Public Member Functions inherited from CXTPControlButton
CXTPControlButton ()
Constructs a CXTPControlButton object.
virtual | ~CXTPControlButton ()
Destroys a CXTPControlButton object, handles cleanup and deallocation.
void | SetStyleEx (XTPButtonStyle buttonStyle)
Call this member to set the style of the button containing vector icon.
XTPButtonStyle | GetStyleEx () const
Call this member to get the button's style containing vector icon.
void | DoPropExchange (CXTPPropExchange *pPX)
Either reads this object from or writes this object to an archive.
- Public Member Functions inherited from CXTPControl
void | SetStyle (XTPButtonStyle buttonStyle)
Call this member to set the style of the control.
XTPButtonStyle | GetStyle () const
Call this member to get the control's style.
void | SetCaption (LPCTSTR lpszCaption)
Call this member to set the caption of the control.
void | SetCaption (UINT nIDCaption)
Call this member to set the caption of the control.
virtual CString | GetCaption () const
Call this member to get the control's caption.
void | SetShortcutText (LPCTSTR lpszShortcutText)
Call this member to set the shortcut string to the control.
CString | GetShortcutText () const
Call this member to get the control's shortcut.
void | SetDescription (LPCTSTR lpszDescription)
Call this member to set the description of the control.
virtual CString | GetDescription () const
Call this member to get the control's description.
void | SetTooltip (LPCTSTR lpszTooltip)
Call this member to set the tooltip of the control.
virtual CString | GetTooltip () const
Call this member to get the control's tooltip.
void | SetKeyboardTip (LPCTSTR lpszKeyboardTip)
Call this member to set the keyboard tip to the control.
CString | GetKeyboardTip () const
Call this member to get the keyboard tip.
void | SetCustomShortcutText (LPCTSTR lpszCustomShortcutText)
Call this member to set the text displayed for the shortcut in a pop-up menu.
CString | GetCustomShortcutText () const
Call this member to get the control's text displayed for the shortcut in a pop-up menu.
void | SetParameter (LPCTSTR lpszParameter)
Call this member to set the parameter of the control.
CString | GetParameter () const
Call this member to get the control's parameter.
void | SetID (int nId)
Call this member to set the identifier of the control.
int | GetID () const
Call this member to get the control's identifier.
long | GetIndex () const
Call this member to get the index of the control.
void | SetIconId (int nId)
Call this member to set the control icon's identifier.
int | GetIconId () const
Call this member to get the icon's identifier.
void | SetHelpId (int nId)
Call this member to set the control help identifier.
int | GetHelpId () const
Call this member to get the help identifier.
virtual void | SetBeginGroup (BOOL bBeginGroup)
Call this member to begin a new group using a separator.
BOOL | GetBeginGroup () const
Call this member to determine if the control has a separator.
virtual void | SetEnabled (BOOL bEnabled)
Call this member to enable/disable the control.
BOOL | GetEnabled () const
Call this member to check if the control is enabled.
virtual void | OnEnabledChanged ()
This method is called when a control's enabled state is changed.
virtual void | SetChecked (BOOL bChecked)
Call this member to set the checked state of the control.
BOOL | GetChecked () const
Call this member to get the checked state of the control.
virtual int | GetSelected () const
Call this member to check if the control is selected.
void | SetOnQuickAccess (BOOL bOnQuicAccess=FALSE)
Call this member to set whether a control should be a part of the Quick Access panel.
BOOL | IsOnQuickAccess () const
Call this member to check if a control is a part of the Quick Access panel.
virtual void | SetFocused (BOOL bFocused)
Call this member to set the focused state of the control.
virtual BOOL | IsFocused () const
Call this member to check the focused state of the control.
void | SetPressed (BOOL bPressed)
Call this member to set the pressed state of the control.
virtual BOOL | GetPressed () const
Call this member to check the pressed state of the control.
virtual void | SetRect (CRect rcControl)
This member is called to set the bounding rectangle of the control.
CRect | GetRect () const
Call this member to get the bounding rectangle of the control.
CXTPCommandBar * | GetParent () const
Call this member to get the parent command bar.
virtual BOOL | IsVisible (DWORD dwSkipFlags=0) const
Call this member to determine if the control is visible.
virtual BOOL | IsCaptionVisible () const
Call this member to determine if the caption of the control is visible.
void | SetVisible (BOOL bVisible)
Call this member to set the visibility of the control.
CXTPControls * | GetControls () const
Call this member to get the parent controls collection.
XTPControlType | GetType () const
Call this member to get the control's type.
void | SetFlags (DWORD dwFlags)
Call this member to set the flags of the control.
DWORD | GetFlags () const
Call this member to retrieve control special flags.
void | SetTag (DWORD_PTR dwTag)
This method sets the 32-bit value associated with the control.
DWORD_PTR | GetTag () const
This method retrieves the application-supplied, 32-bit value associated with the control.
virtual BOOL | Compare (CXTPControl *pOther)
Call this member to compare controls.
virtual CXTPCommandBar * | GetCommandBar () const
Call this member to get the child command bar.
void | SetCloseSubMenuOnClick (BOOL bCloseOnClick)
Call this member function to enable/disable the closing of sub-menus when a control is clicked in the menu.
BOOL | GetCloseSubMenuOnClick () const
Call this member function to check if sub-menus will close as soon as a control is clicked.
void | SetExecuteOnPressInterval (int nExecuteOnPressInterval)
Call this method to set the delay (in milliseconds) between WM_COMMAND messages while a button is pressed by the user.
int | GetExecuteOnPressInterval () const
Call this method to get the delay (in milliseconds) between WM_COMMAND messages while a button is pressed by the user.
CXTPRibbonGroup * | GetRibbonGroup () const
Returns the ribbon group that the control belongs to.
virtual BOOL | IsTransparent () const
Determines if the control needs to draw its background.
void | SetHideWrap (BOOL bHide)
This method is called to hide the control.
virtual void | SetHideFlags (DWORD dwFlags)
This method is called to hide the control.
BOOL | SetHideFlag (XTPControlHideFlags dwFlag, BOOL bSet)
Call this member to set/remove hide flags.
DWORD | GetHideFlags () const
Call this method to retrieve hidden flags.
CRect | GetRowRect () const
Call this method to retrieve the position of the control's row.
BOOL | GetWrap () const
Call this method to check if the control is wrapped.
void | SetRowRect (CRect rcRow)
Call this method to set the row of the control.
void | SetWrap (BOOL bWrap)
Call this member to set the control to wrapped.
BOOL | GetExpanded () const
Call this member to check if the control is expanded.
BOOL | IsCursorOver () const
Call this member to determine if the mouse pointer is over the control.
virtual void | OnExecute ()
This method is called when the control is executed.
virtual CSize | GetSize (CDC *pDC)
This method is called to determine the size of the control.
virtual void | Draw (CDC *pDC)
This method is called to draw the control.
void | DelayRedrawParent ()
Call this method to redraw the parent command bar.
void | DelayLayoutParent ()
Call this method to recalculate the parent command bar size.
void | SetCategory (LPCTSTR lpszCategory)
Call this method to set the category of the control.
CString | GetCategory () const
Call this method to retrieve the category of the control.
CXTPImageManager * | GetImageManager () const
Call this method to retrieve the image manager.
CXTPPaintManager * | GetPaintManager () const
Call this method to retrieve the paint manager.
virtual CXTPImageManagerIcon * | GetImage (int nWidth=16) const
Call this method to retrieve the image of the control.
void | AssignDocTemplate (UINT nIDResource)
Call this method to assign a document template to the control.
void | ExcludeDocTemplate (UINT nIDResource)
Call this method to exclude the document template from control.
BOOL | IsItemDefault () const
Call this method to check if a control is a default menu item.
void | SetItemDefault (BOOL bDefault)
Call this method to set a control to be a default menu item.
BOOL | IsTemporary () const
Call this method to determine if a control is temporary.
void | Reset ()
Call this member to reset the icon and caption of a control to its default settings before it was customized by the user.
void | SetPrompt (LPCTSTR lpszPrompt)
Call this member to load a string from a STRINGTABLE resource to set the tooltip and description of a control.
void | SetCustomIcon (HICON hIcon)
Call this member to set a custom icon to this control.
virtual void | OnUnderlineActivate ()
This method is called when the user activates the control using its underline.
virtual BOOL | GetPopuped () const
Call this member to get the control's pop-up state.
void | RedrawParent (BOOL bAnimate=TRUE)
This method is called to redraw the parent command bar.
LRESULT | NotifySite (UINT code)
This method is called to send message code to the parent site window.
LRESULT | NotifySite (UINT code, NMXTPCONTROL *pNM)
This method is called to send message code to the parent site window.
LRESULT | NotifySite (CWnd *pSite, UINT code, NMXTPCONTROL *pNM)
This method is called to send message code to the parent site window.
virtual void | SetAction (CXTPControlAction *pAction)
Call this method to manually assign an action for control.
CXTPControlAction * | GetAction () const
Call this method to retrieve an action associated with control.
virtual void | OnThemeChanged ()
This method is called when the paint manager theme is changed.
virtual void | SetWidth (int nWidth)
Call this member to set the width of the control.
virtual void | SetHeight (int nHeight)
Call this member to set the height of the control.
int | GetWidth () const
Call this member to get the width of the control.
int | GetHeight () const
Call this member to get the height of the control.
BOOL | HasDwmCompositedRect () const
This method is called to determine if control has a Vista DWM transparent area.
virtual CSize | GetButtonSize () const
Call this function to get the size of the command bar button.
virtual CSize | GetIconSize () const
Call this member function to get the size of a toolbar icon.
void | SetIconSize (CSize szIcon)
Call this member function to set the size of an icon for an individual control.
virtual BOOL | IsCustomizeMovable () const
This method is called to determine if control can be repositioned in customize mode.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.
- Protected Attributes inherited from CXTPControlButton
XTPButtonStyle | m_buttonStyleEx
User-defined style of button containing vector icon.
- Protected Attributes inherited from CXTPControl
DWORD_PTR | m_nTag
Control tag.
int | m_nIndex
Index of the control.
int | m_nId
Identifier of the control.
int | m_nIconId
Identifier of the control's image.
int | m_nHelpId
Help identifier.
int | m_nCustomIconId
Identifier of the control's custom image.
BOOL | m_bWrap
TRUE if the control is wrapped.
BOOL | m_bBeginGroup
TRUE if the control starts new group.
BOOL | m_bEnabled
TRUE if the control is enabled.
BOOL | m_bChecked
TRUE if the control is checked.
BOOL | m_bSelected
TRUE if the control is selected.
BOOL | m_bPressed
TRUE if the control is pushed.
BOOL | m_bTemporary
TRUE if the control is temporary.
BOOL | m_bOnQuickAccess
TRUE if the control is a part of Quick Access panel.
CRect | m_rcRow
Bounding rectangle of the control's row.
CRect | m_rcControl
Bounding rectangle of the control.
DWORD | m_dwHideFlags
Hidden flags.
DWORD | m_dwFlags
Flags of the control.
CString | m_strCaption
Caption of the control.
CString | m_strCustomCaption
User-defined caption.
CString | m_strShortcutText
Shortcut text.
CString | m_strShortcutTextAuto
Shortcut text.
CString | m_strTooltipText
Tooltip text.
CString | m_strDescriptionText
Description text.
CString | m_strParameter
Parameter text.
CString | m_strKeyboardTip
Keyboard tip.
CXTPControls * | m_pControls
Parent control collection.
XTPControlType | m_controlType
Type of the control.
CXTPCommandBar * | m_pParent
The Parent command bar.
BOOL | m_bExpanded
TRUE if the control is expanded.
CString | m_strCategory
Category of the control.
BOOL | m_bDefaultItem
TRUE if the item is default pop-up item.
CDocTemplateMap | m_mapDocTemplatesAssigned
Assigned templates.
CDocTemplateMap | m_mapDocTemplatesExcluded
Excluded templates.
XTPButtonStyle | m_buttonStyle
Button Style.
XTPButtonStyle | m_buttonCustomStyle
User-defined style of button.
XTPButtonStyle | m_buttonRibbonStyle
User-defined style of button.
BOOL | m_bCloseSubMenuOnClick
TRUE is sub-menus are closed as soon as a control is clicked.
CXTPRibbonGroup * | m_pRibbonGroup
Ribbon group of control.
CXTPControlAction * | m_pAction
Action of the control.
int | m_nWidth
Width of the control.
int | m_nHeight
Height of the control.
int | m_nExecuteOnPressInterval
Delay between each message when control is pressed.
CSize | m_szIcon
The size of the icon used for the control.
BOOL | m_bLayoutRTL
Indicate does last layout is RTL.

Detailed Description

CXTPControlWindowList is a CXTPControlButton derived class.

It is used internally to create window list items.

Member Function Documentation

◆ ConstructCaption()

static CString AFX_CDECL ConstructCaption | ( | const CString & | lpszTitle,
 |  | int | nIndex )
 static

Adds the number and an ampersand "&" before the caption of an item that appears in the Windows List.

Parameters
lpszTitle | Text string to display in Windows List. This text will be appended after the number.
nIndex | Position within the Windows list that the item should appear.
Returns
Returns the text string containing the entire string that will appear in the Windows List.

◆ DoCustomDragOver()

virtual BOOL DoCustomDragOver | ( | CXTPCommandBar * | pCommandBar,
 |  | CPoint | point,
 |  | DROPEFFECT & | dropEffect )
 protectedvirtual

The implementation may implement a custom drag over handling logic in this method.

Parameters
pCommandBar | Pointer to a CXTPCommandBar object.
point | Mouse position.
dropEffect | DROPEFFECT enumerator.
Returns
TRUE if custom implementation handles drag over, otherwise FALSE.

Reimplemented from CXTPControl.

◆ OnCalcDynamicSize()

virtual void OnCalcDynamicSize ( DWORD dwMode )
protectedvirtual

This method is called before recalculating the parent command bar size to calculate the dimensions of the control.

Parameters
dwMode Flags used to determine the height and width of the dynamic command bar. See Remarks section for a list of values.

The following predefined flags are used to determine the height and width of the dynamic command bar. Use the bitwise-OR (|) operator to combine the flags.

LM_STRETCH: Indicates whether the command bar should be stretched to the size of the frame. Set if the bar is not a docking bar (not available for docking). Not set when the bar is docked or floating (available for docking). If set, LM_STRETCH returns dimensions based on the LM_HORZ state. LM_STRETCH works similarly to the the bStretch parameter used in CalcFixedLayout; see that member function for more information about the relationship between stretching and orientation. LM_HORZ: Indicates that the bar is horizontally or vertically oriented. Set if the bar is horizontally oriented, and if it is vertically oriented, it is not set. LM_HORZ works similarly to the the bHorz parameter used in CalcFixedLayout; see that member function for more information about the relationship between stretching and orientation. LM_MRUWIDTH: Most Recently Used Dynamic Width. Uses the remembered most recently used width. LM_HORZDOCK: Horizontal Docked Dimensions. Returns the dynamic size with the largest width. LM_VERTDOCK: Vertical Docked Dimensions. Returns the dynamic size with the largest height. LM_COMMIT: Resets LM_MRUWIDTH to the current width of the floating command bar.

The framework calls this member function to calculate the dimensions of a dynamic command bar.

Override this member function to provide your own layout in classes you derive from CXTPControl. XTP classes derived from CXTPControl, such as CXTPControlComboBox, override this member function to provide their own implementation.

See also
CXTPControlComboBox, CXTPControlCustom, CXTPControlEdit, CXTPControl, CXTPControlWorkspaceActions, CXTPControlToolbars, CXTPControlOleItems, CXTPControlRecentFileList, CXTPControlSelector, CXTPControlListBox

Reimplemented from CXTPControl.

The documentation for this class was generated from the following file:
  • XTPControlExt.h


Toolkit Pro: CXTPControlWorkspaceActions Class Reference

Protected Member Functions | List of all members
CXTPControlWorkspaceActions Class Reference

CXTPControlWorkspaceActions is a CXTPControlButton derived class. More...

Inheritance diagram for CXTPControlWorkspaceActions:
[legend]

Protected Member Functions

virtual void | OnCalcDynamicSize (DWORD dwMode)
This method is called before recalculating the parent command bar size to calculate the dimensions of the control.
void | AddCommand (CXTPTabClientWnd *pClient, UINT nID, int &nIndex)
Adds an action command to parent controls.
- Protected Member Functions inherited from CXTPControlButton
virtual void | OnClick (BOOL bKeyboard=FALSE, CPoint pt=CPoint(0, 0))
This method is called when the user clicks the control.
virtual void | OnLButtonUp (CPoint point)
This member is called when the user releases the left mouse button.
virtual void | Copy (CXTPControl *pControl, BOOL bRecursive=FALSE)
This method is called to copy the control.
- Protected Member Functions inherited from CXTPControl
CXTPControl ()
Constructs a CXTPControl object.
virtual | ~CXTPControl ()
Destroys a CXTPControl object, handles cleanup and deallocation.
virtual BOOL | IsFocusable () const
This method is called to check if the control can accept focus.
void | SetIndex (int nIndex)
This method is called to assign the order of the control in the controls list.
void | SetExpanded (BOOL bExpanded)
This method is called to set the control's expanded state.
virtual BOOL | OnHookKeyDown (UINT nChar, LPARAM lParam)
This method is called when a non-system key is pressed.
virtual BOOL | OnHookMouseWheel (UINT nFlags, short zDelta, CPoint point)
This method is called when the user rotates the mouse wheel.
virtual void | SetParent (CXTPCommandBar *pParent)
This method is called to assign a parent command bar object.
void | ScreenToClient (CPoint *point)
The ScreenToClient function converts the screen coordinates of a specified point on the screen.
void | ClickToolBarButton (CRect rcActiveRect=CRect(0, 0, 0, 0))
This helper method is called when the user clicks the toolbar's button.
virtual BOOL | OnSetPopup (BOOL bPopup)
This method is called to pop-up the control.
virtual void | OnLButtonDown (CPoint point)
This member is called when the user presses the left mouse button down.
virtual BOOL | OnRButtonDown (CPoint point)
This member is called when the user press the right mouse button.
virtual BOOL | OnRButtonUp (CPoint point)
This member is called when the user releases the right mouse button.
virtual BOOL | OnLButtonDblClk (CPoint point)
This member is called when the user double-clicks the left mouse button.
virtual void | OnMouseMove (CPoint point)
This member is called when the mouse cursor moves.
virtual void | OnMouseHover ()
Called after the mouse hovers over the control.
virtual BOOL | OnSetSelected (int bSelected)
This method is called when the control becomes selected.
BOOL | IsCustomizeMode () const
Call this method to determine if command bars is in customize mode.
virtual void | CustomizeStartDrag (CPoint point)
This member is called when the user starts to drag the control in customize mode.
virtual BOOL | CustomizeStartResize (CPoint point)
This method is called when user starts to resize control in customize mode.
virtual void | OnCustomizeDragOver (CXTPControl *pDataObject, CPoint point, DROPEFFECT &dropEffect)
This member is called when the user moves the mouse over the control.
virtual BOOL | DoCustomDragOver (CXTPCommandBar *pCommandBar, CPoint point, DROPEFFECT &dropEffect)
The implementation may implement a custom drag over handling logic in this method.
virtual BOOL | IsCustomizeResizeAllow () const
This member checks if the user can resize the control.
virtual int | GetCustomizeMinWidth () const
Retrieves the available minimum width of control.
virtual int | GetCustomizeMinHeight () const
Retrieves available minimum height of the control.
void | OnCustomizeMouseMove (CPoint point)
This member is called when the mouse cursor moves in customized mode.
virtual void | OnIdleUpdate ()
This virtual method is called in idle-time processing.
virtual void | OnRemoved ()
This method is called when a control is removed from the parent controls collection.
virtual INT_PTR | OnToolHitTest (CPoint point, TOOLINFO *pTI) const
The framework calls this member function to determine whether a point is in the bounding rectangle of the specified tool.
virtual void | RestoreCommandBarList (CXTPCommandBarList *pCommandBarList)
This method is called from LoadCommandBars to restore controls and its child command bars.
virtual void | GenerateCommandBarList (DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam)
This method is called from SaveCommandBars to save all child command bars.
virtual void | OnActionChanged (int nProperty)
This method is called when an action property is changed.
virtual void | OnActionChanging (int nProperty)
This method is called when an action property is about to be changed.
virtual void | OnCaptionChanged ()
This method is called when the control's caption is changed.
BOOL | IsLayoutRTL () const
Determines if right-to-left (RTL) mode is set.
BOOL | IsLayoutChanged ()
Call this member to determine if the layout has changed (RTL to LTR or LTR to RLT).

Additional Inherited Members

- Public Member Functions inherited from CXTPControlButton
CXTPControlButton ()
Constructs a CXTPControlButton object.
virtual | ~CXTPControlButton ()
Destroys a CXTPControlButton object, handles cleanup and deallocation.
void | SetStyleEx (XTPButtonStyle buttonStyle)
Call this member to set the style of the button containing vector icon.
XTPButtonStyle | GetStyleEx () const
Call this member to get the button's style containing vector icon.
void | DoPropExchange (CXTPPropExchange *pPX)
Either reads this object from or writes this object to an archive.
- Public Member Functions inherited from CXTPControl
void | SetStyle (XTPButtonStyle buttonStyle)
Call this member to set the style of the control.
XTPButtonStyle | GetStyle () const
Call this member to get the control's style.
void | SetCaption (LPCTSTR lpszCaption)
Call this member to set the caption of the control.
void | SetCaption (UINT nIDCaption)
Call this member to set the caption of the control.
virtual CString | GetCaption () const
Call this member to get the control's caption.
void | SetShortcutText (LPCTSTR lpszShortcutText)
Call this member to set the shortcut string to the control.
CString | GetShortcutText () const
Call this member to get the control's shortcut.
void | SetDescription (LPCTSTR lpszDescription)
Call this member to set the description of the control.
virtual CString | GetDescription () const
Call this member to get the control's description.
void | SetTooltip (LPCTSTR lpszTooltip)
Call this member to set the tooltip of the control.
virtual CString | GetTooltip () const
Call this member to get the control's tooltip.
void | SetKeyboardTip (LPCTSTR lpszKeyboardTip)
Call this member to set the keyboard tip to the control.
CString | GetKeyboardTip () const
Call this member to get the keyboard tip.
void | SetCustomShortcutText (LPCTSTR lpszCustomShortcutText)
Call this member to set the text displayed for the shortcut in a pop-up menu.
CString | GetCustomShortcutText () const
Call this member to get the control's text displayed for the shortcut in a pop-up menu.
void | SetParameter (LPCTSTR lpszParameter)
Call this member to set the parameter of the control.
CString | GetParameter () const
Call this member to get the control's parameter.
void | SetID (int nId)
Call this member to set the identifier of the control.
int | GetID () const
Call this member to get the control's identifier.
long | GetIndex () const
Call this member to get the index of the control.
void | SetIconId (int nId)
Call this member to set the control icon's identifier.
int | GetIconId () const
Call this member to get the icon's identifier.
void | SetHelpId (int nId)
Call this member to set the control help identifier.
int | GetHelpId () const
Call this member to get the help identifier.
virtual void | SetBeginGroup (BOOL bBeginGroup)
Call this member to begin a new group using a separator.
BOOL | GetBeginGroup () const
Call this member to determine if the control has a separator.
virtual void | SetEnabled (BOOL bEnabled)
Call this member to enable/disable the control.
BOOL | GetEnabled () const
Call this member to check if the control is enabled.
virtual void | OnEnabledChanged ()
This method is called when a control's enabled state is changed.
virtual void | SetChecked (BOOL bChecked)
Call this member to set the checked state of the control.
BOOL | GetChecked () const
Call this member to get the checked state of the control.
virtual int | GetSelected () const
Call this member to check if the control is selected.
void | SetOnQuickAccess (BOOL bOnQuicAccess=FALSE)
Call this member to set whether a control should be a part of the Quick Access panel.
BOOL | IsOnQuickAccess () const
Call this member to check if a control is a part of the Quick Access panel.
virtual void | SetFocused (BOOL bFocused)
Call this member to set the focused state of the control.
virtual BOOL | IsFocused () const
Call this member to check the focused state of the control.
void | SetPressed (BOOL bPressed)
Call this member to set the pressed state of the control.
virtual BOOL | GetPressed () const
Call this member to check the pressed state of the control.
virtual void | SetRect (CRect rcControl)
This member is called to set the bounding rectangle of the control.
CRect | GetRect () const
Call this member to get the bounding rectangle of the control.
CXTPCommandBar * | GetParent () const
Call this member to get the parent command bar.
virtual BOOL | IsVisible (DWORD dwSkipFlags=0) const
Call this member to determine if the control is visible.
virtual BOOL | IsCaptionVisible () const
Call this member to determine if the caption of the control is visible.
void | SetVisible (BOOL bVisible)
Call this member to set the visibility of the control.
CXTPControls * | GetControls () const
Call this member to get the parent controls collection.
XTPControlType | GetType () const
Call this member to get the control's type.
void | SetFlags (DWORD dwFlags)
Call this member to set the flags of the control.
DWORD | GetFlags () const
Call this member to retrieve control special flags.
void | SetTag (DWORD_PTR dwTag)
This method sets the 32-bit value associated with the control.
DWORD_PTR | GetTag () const
This method retrieves the application-supplied, 32-bit value associated with the control.
virtual BOOL | Compare (CXTPControl *pOther)
Call this member to compare controls.
virtual CXTPCommandBar * | GetCommandBar () const
Call this member to get the child command bar.
void | SetCloseSubMenuOnClick (BOOL bCloseOnClick)
Call this member function to enable/disable the closing of sub-menus when a control is clicked in the menu.
BOOL | GetCloseSubMenuOnClick () const
Call this member function to check if sub-menus will close as soon as a control is clicked.
void | SetExecuteOnPressInterval (int nExecuteOnPressInterval)
Call this method to set the delay (in milliseconds) between WM_COMMAND messages while a button is pressed by the user.
int | GetExecuteOnPressInterval () const
Call this method to get the delay (in milliseconds) between WM_COMMAND messages while a button is pressed by the user.
CXTPRibbonGroup * | GetRibbonGroup () const
Returns the ribbon group that the control belongs to.
virtual BOOL | IsTransparent () const
Determines if the control needs to draw its background.
void | SetHideWrap (BOOL bHide)
This method is called to hide the control.
virtual void | SetHideFlags (DWORD dwFlags)
This method is called to hide the control.
BOOL | SetHideFlag (XTPControlHideFlags dwFlag, BOOL bSet)
Call this member to set/remove hide flags.
DWORD | GetHideFlags () const
Call this method to retrieve hidden flags.
CRect | GetRowRect () const
Call this method to retrieve the position of the control's row.
BOOL | GetWrap () const
Call this method to check if the control is wrapped.
void | SetRowRect (CRect rcRow)
Call this method to set the row of the control.
void | SetWrap (BOOL bWrap)
Call this member to set the control to wrapped.
BOOL | GetExpanded () const
Call this member to check if the control is expanded.
BOOL | IsCursorOver () const
Call this member to determine if the mouse pointer is over the control.
virtual void | OnExecute ()
This method is called when the control is executed.
virtual CSize | GetSize (CDC *pDC)
This method is called to determine the size of the control.
virtual void | Draw (CDC *pDC)
This method is called to draw the control.
void | DelayRedrawParent ()
Call this method to redraw the parent command bar.
void | DelayLayoutParent ()
Call this method to recalculate the parent command bar size.
void | SetCategory (LPCTSTR lpszCategory)
Call this method to set the category of the control.
CString | GetCategory () const
Call this method to retrieve the category of the control.
CXTPImageManager * | GetImageManager () const
Call this method to retrieve the image manager.
CXTPPaintManager * | GetPaintManager () const
Call this method to retrieve the paint manager.
virtual CXTPImageManagerIcon * | GetImage (int nWidth=16) const
Call this method to retrieve the image of the control.
void | AssignDocTemplate (UINT nIDResource)
Call this method to assign a document template to the control.
void | ExcludeDocTemplate (UINT nIDResource)
Call this method to exclude the document template from control.
BOOL | IsItemDefault () const
Call this method to check if a control is a default menu item.
void | SetItemDefault (BOOL bDefault)
Call this method to set a control to be a default menu item.
BOOL | IsTemporary () const
Call this method to determine if a control is temporary.
void | Reset ()
Call this member to reset the icon and caption of a control to its default settings before it was customized by the user.
void | SetPrompt (LPCTSTR lpszPrompt)
Call this member to load a string from a STRINGTABLE resource to set the tooltip and description of a control.
void | SetCustomIcon (HICON hIcon)
Call this member to set a custom icon to this control.
virtual void | OnUnderlineActivate ()
This method is called when the user activates the control using its underline.
virtual BOOL | GetPopuped () const
Call this member to get the control's pop-up state.
void | RedrawParent (BOOL bAnimate=TRUE)
This method is called to redraw the parent command bar.
LRESULT | NotifySite (UINT code)
This method is called to send message code to the parent site window.
LRESULT | NotifySite (UINT code, NMXTPCONTROL *pNM)
This method is called to send message code to the parent site window.
LRESULT | NotifySite (CWnd *pSite, UINT code, NMXTPCONTROL *pNM)
This method is called to send message code to the parent site window.
virtual void | SetAction (CXTPControlAction *pAction)
Call this method to manually assign an action for control.
CXTPControlAction * | GetAction () const
Call this method to retrieve an action associated with control.
virtual void | OnThemeChanged ()
This method is called when the paint manager theme is changed.
virtual void | SetWidth (int nWidth)
Call this member to set the width of the control.
virtual void | SetHeight (int nHeight)
Call this member to set the height of the control.
int | GetWidth () const
Call this member to get the width of the control.
int | GetHeight () const
Call this member to get the height of the control.
BOOL | HasDwmCompositedRect () const
This method is called to determine if control has a Vista DWM transparent area.
virtual CSize | GetButtonSize () const
Call this function to get the size of the command bar button.
virtual CSize | GetIconSize () const
Call this member function to get the size of a toolbar icon.
void | SetIconSize (CSize szIcon)
Call this member function to set the size of an icon for an individual control.
virtual BOOL | IsCustomizeMovable () const
This method is called to determine if control can be repositioned in customize mode.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.
- Static Public Member Functions inherited from CXTPControl
static CXTPControl *AFX_CDECL | FromUI (CCmdUI *pCmdUI)
Call this member to retrieve CXTPControl from a CCmdUI structure.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Attributes inherited from CXTPControlButton
XTPButtonStyle | m_buttonStyleEx
User-defined style of button containing vector icon.
- Protected Attributes inherited from CXTPControl
DWORD_PTR | m_nTag
Control tag.
int | m_nIndex
Index of the control.
int | m_nId
Identifier of the control.
int | m_nIconId
Identifier of the control's image.
int | m_nHelpId
Help identifier.
int | m_nCustomIconId
Identifier of the control's custom image.
BOOL | m_bWrap
TRUE if the control is wrapped.
BOOL | m_bBeginGroup
TRUE if the control starts new group.
BOOL | m_bEnabled
TRUE if the control is enabled.
BOOL | m_bChecked
TRUE if the control is checked.
BOOL | m_bSelected
TRUE if the control is selected.
BOOL | m_bPressed
TRUE if the control is pushed.
BOOL | m_bTemporary
TRUE if the control is temporary.
BOOL | m_bOnQuickAccess
TRUE if the control is a part of Quick Access panel.
CRect | m_rcRow
Bounding rectangle of the control's row.
CRect | m_rcControl
Bounding rectangle of the control.
DWORD | m_dwHideFlags
Hidden flags.
DWORD | m_dwFlags
Flags of the control.
CString | m_strCaption
Caption of the control.
CString | m_strCustomCaption
User-defined caption.
CString | m_strShortcutText
Shortcut text.
CString | m_strShortcutTextAuto
Shortcut text.
CString | m_strTooltipText
Tooltip text.
CString | m_strDescriptionText
Description text.
CString | m_strParameter
Parameter text.
CString | m_strKeyboardTip
Keyboard tip.
CXTPControls * | m_pControls
Parent control collection.
XTPControlType | m_controlType
Type of the control.
CXTPCommandBar * | m_pParent
The Parent command bar.
BOOL | m_bExpanded
TRUE if the control is expanded.
CString | m_strCategory
Category of the control.
BOOL | m_bDefaultItem
TRUE if the item is default pop-up item.
CDocTemplateMap | m_mapDocTemplatesAssigned
Assigned templates.
CDocTemplateMap | m_mapDocTemplatesExcluded
Excluded templates.
XTPButtonStyle | m_buttonStyle
Button Style.
XTPButtonStyle | m_buttonCustomStyle
User-defined style of button.
XTPButtonStyle | m_buttonRibbonStyle
User-defined style of button.
BOOL | m_bCloseSubMenuOnClick
TRUE is sub-menus are closed as soon as a control is clicked.
CXTPRibbonGroup * | m_pRibbonGroup
Ribbon group of control.
CXTPControlAction * | m_pAction
Action of the control.
int | m_nWidth
Width of the control.
int | m_nHeight
Height of the control.
int | m_nExecuteOnPressInterval
Delay between each message when control is pressed.
CSize | m_szIcon
The size of the icon used for the control.
BOOL | m_bLayoutRTL
Indicate does last layout is RTL.

Detailed Description

CXTPControlWorkspaceActions is a CXTPControlButton derived class.

It used internally to add workspace actions to a window menu.

Member Function Documentation

◆ AddCommand()

void AddCommand | ( | CXTPTabClientWnd * | pClient,
 |  | UINT | nID,
 |  | int & | nIndex )
 protected

Adds an action command to parent controls.

Parameters
pClient | Pointer to MDI tabbed client
nID | Specifies the object's child-window ID.
nIndex | Index to add.

◆ OnCalcDynamicSize()

virtual void OnCalcDynamicSize ( DWORD dwMode )
protectedvirtual

This method is called before recalculating the parent command bar size to calculate the dimensions of the control.

Parameters
dwMode Flags used to determine the height and width of the dynamic command bar. See Remarks section for a list of values.

The following predefined flags are used to determine the height and width of the dynamic command bar. Use the bitwise-OR (|) operator to combine the flags.

LM_STRETCH: Indicates whether the command bar should be stretched to the size of the frame. Set if the bar is not a docking bar (not available for docking). Not set when the bar is docked or floating (available for docking). If set, LM_STRETCH returns dimensions based on the LM_HORZ state. LM_STRETCH works similarly to the the bStretch parameter used in CalcFixedLayout; see that member function for more information about the relationship between stretching and orientation. LM_HORZ: Indicates that the bar is horizontally or vertically oriented. Set if the bar is horizontally oriented, and if it is vertically oriented, it is not set. LM_HORZ works similarly to the the bHorz parameter used in CalcFixedLayout; see that member function for more information about the relationship between stretching and orientation. LM_MRUWIDTH: Most Recently Used Dynamic Width. Uses the remembered most recently used width. LM_HORZDOCK: Horizontal Docked Dimensions. Returns the dynamic size with the largest width. LM_VERTDOCK: Vertical Docked Dimensions. Returns the dynamic size with the largest height. LM_COMMIT: Resets LM_MRUWIDTH to the current width of the floating command bar.

The framework calls this member function to calculate the dimensions of a dynamic command bar.

Override this member function to provide your own layout in classes you derive from CXTPControl. XTP classes derived from CXTPControl, such as CXTPControlComboBox, override this member function to provide their own implementation.

See also
CXTPControlComboBox, CXTPControlCustom, CXTPControlEdit, CXTPControlWindowList, CXTPControl, CXTPControlToolbars, CXTPControlOleItems, CXTPControlRecentFileList, CXTPControlSelector, CXTPControlListBox

Reimplemented from CXTPControl.

The documentation for this class was generated from the following file:
  • XTPControlExt.h


Toolkit Pro: CXTPCriticalSection Class Reference

Public Member Functions | List of all members
CXTPCriticalSection Class Reference

Critical Section Wrapper. More...

Public Member Functions

CXTPCriticalSection ()
Constructs a CXTPCriticalSection object.
~CXTPCriticalSection ()
Destroys a CXTPCriticalSection object, handles cleanup and deallocation.
void | EnterCritical ()
The EnterCriticalSection function waits for ownership of the specified critical section object.
void | LeaveCritical ()
The LeaveCriticalSection function releases ownership of the specified critical section object.
operator CRITICAL_SECTION & ()
Returns CRITICAL_SECTION reference.

Detailed Description

Critical Section Wrapper.

The documentation for this class was generated from the following file:
  • XTPSystemHelpers.h


Toolkit Pro: CXTPCustomizeCommandsListBox Class Reference

Public Member Functions | Public Attributes | List of all members
CXTPCustomizeCommandsListBox Class Reference

List of the commands. More...

Public Member Functions

CXTPCustomizeCommandsListBox ()
Constructs a CXTPCustomizeCommandsListBox object.

Public Attributes

CXTPCommandBars * | m_pCommandBars
Parent CommandBars object.
BOOL | m_bDragable
TRUE if user can drag controls from list.

Detailed Description

List of the commands.

The documentation for this class was generated from the following file:
  • XTPCustomizePageCommands.h


Toolkit Pro: CXTPCustomizeCommandsPage Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPCustomizeCommandsPage Class Reference

CXTPCustomizeCommandsPage is a CPropertyPage derived class. More...

Inheritance diagram for CXTPCustomizeCommandsPage:
[legend]

Public Member Functions

CXTPCustomizeCommandsPage (CXTPCustomizeSheet *pSheet=NULL)
Constructs a CXTPCustomizeCommandsPage object.
~CXTPCustomizeCommandsPage ()
Destroys a CXTPCustomizeCommandsPage object, handles cleanup and deallocation.
BOOL | AddCategories (UINT nIDResource, BOOL bListSubItems=FALSE)
Adds categories branch from menu resource.
BOOL | AddCategories (CXTPControls *pControls)
Adds categories branch from Controls.
BOOL | AddCategory (LPCTSTR strCategory, CMenu *pMenu, BOOL bListSubItems=FALSE)
Adds a new category from a CMenu object.
BOOL | AddToolbarCategory (LPCTSTR strCategory, UINT nIDResource)
Adds a new category from a toolbar resource.
CXTPControls * | InsertCategory (LPCTSTR strCategory, int nIndex=-1)
This method adds a new empty category in the given index.
void | InsertNewMenuCategory (UINT nIDResource=XTP_IDS_NEWMENU, int nIndex=-1)
Adds single "New menu" category.
void | InsertAllCommandsCategory (UINT nIDResource=XTP_IDS_ALLCOMMANDS, int nIndex=-1, BOOL bSortCommands=TRUE)
Adds "All Commands" category and adds all controls already created in other categories here.
BOOL | InsertBuiltInMenus (UINT nIDResourceMenu, UINT nIDResourceCategory=XTP_IDS_BUILTINMENUS, int nIndex=-1)
Adds built-in menus category.
CXTPControls * | GetControls (LPCTSTR strCategory)
Retrieves the control list of the given category.
XTP_COMMANDBARS_CATEGORYINFO * | FindCategory (LPCTSTR strCategory) const
Finds the category.
XTP_COMMANDBARS_CATEGORYINFO * | GetCategoryInfo (int nIndex) const
Gets the category by its index.
- Public Member Functions inherited from CXTPPropertyPage
CXTPPropertyPage ()
Constructs a CXTPPropertyPage object.
CXTPPropertyPage (UINT nIDTemplate, UINT nIDCaption=0)
Constructs a CXTPPropertyPage object.
CXTPPropertyPage (LPCTSTR lpszTemplateName, UINT nIDCaption=0)
Constructs a CXTPPropertyPage object.
~CXTPPropertyPage ()
Destroys a CXTPPropertyPage object, handles cleanup and deallocation.
CString | GetCaption () const
Retrieves the caption text used for property sheet tabs.
void | SetCaption (LPCTSTR lpszCaption)
Sets the caption text used to draw property sheet tabs.
virtual void | UpdatePage (void)
Forces a page to update its internal data as this data is supposed to be changed from outside the page.
- Public Member Functions inherited from CXTPResize
CXTPResize (CWnd *pWnd, const UINT nFlags=0)
Constructs a CXTPResize object.
virtual | ~CXTPResize ()
Destroys a CXTPResize object, handles cleanup and deallocation.
void | SetResize (UINT nID, XTP_RESIZE left, XTP_RESIZE top, XTP_RESIZE right, XTP_RESIZE bottom)
The SetResize function specifies how much each side of a control will move when the dialog is resized.
void | SetResize (UINT nID, const XTP_RESIZERECT &rrcSizing)
The SetResize function specifies how much each side of a control will move when the dialog is resized.
void | SetResize (UINT nID, HWND hWnd, const XTP_RESIZERECT &rrcSizing)
The SetResize function specifies how much each side of a control will move when the dialog is resized.
void | SetResize (UINT nID, HWND hWnd, const XTP_RESIZEPOINT &rpTopLeft, const XTP_RESIZEPOINT &rpBottomRight)
The SetResize function specifies how much each side of a control will move when the dialog is resized.
void | SetResize (UINT nID, const XTP_RESIZEPOINT &rpTopLeft, const XTP_RESIZEPOINT &rpBottomRight)
The SetResize function specifies how much each side of a control will move when the dialog is resized.
void | SetMinSize (CSize &sz)
This member function sets the minimum size explicitly.
void | SetMaxSize (CSize &sz)
This member function sets the maximum size.
BOOL | SavePlacement (LPCTSTR pszSection)
This member function saves the window placement to the registry.
BOOL | LoadPlacement (LPCTSTR pszSection)
This member function loads saved window placement information from the registry.
BOOL | AutoLoadPlacement (LPCTSTR pszSection)
This member function loads saved window placement information from the registry.

Protected Attributes

CXTPCustomizeCommandsListBox | m_lstCommands
List box of commands.
CListBox | m_lstCategories
List box of categories.
CXTPCustomizeSheet * | m_pSheet
Parent Customize dialog.
CXTPCommandBarsCategoryArray | m_arrCategories
Array of categories.
- Protected Attributes inherited from CXTPPropertyPage
CXTPPropertySheet * | m_pSheet
Parent CXTPPropertySheet object.
BOOL | m_bModified
TRUE to indicate that the property page settings have been modified.
- Protected Attributes inherited from CXTPResize
UINT | m_nFlagsXX
Flags passed from the constructor.
CWnd * | m_pWnd
The associative relation to the window to be resized.
CSize | m_szWindow
Last dialog size.
CSize | m_szInitWindow
Initial dialog size.
CSize | m_szMin
Smallest size allowed.
CSize | m_szMax
Largest size allowed.
CString | m_strSection
Section in registry where window placement information is saved.
CXTPSizeIcon | m_scSizeIcon
Size icon window.
CResizeItemArray | m_arrItems
Array of controls.

Additional Inherited Members

- Public Attributes inherited from CXTPPropertyPage
DWORD_PTR | m_dwData
Page specific 32-bit value.
- Protected Types inherited from CXTPResize
typedef CArray< CXTPResizeItem *, CXTPResizeItem *& > | CResizeItemArray
Used by CXTPResize to maintain a list of children that are sizable.
- Protected Member Functions inherited from CXTPResize
void | SetResize (CWnd *pWnd, const CXTPResizeRect &rrcSizing, CRect rcWindow)
The SetResize function specifies how much each side of a control will move when the dialog is resized.
BOOL | RemoveResize (UINT nID)
This member function is called to remove the specified dialog item from the list of items to be resized.
void | RemoveAllControls ()
This member function is called to purge the list that contains the dialog items to be sized.
virtual void | Init ()
This member function is called from OnInitDialog or OnInitialUpdate to initialize the resize manager.
virtual void | Size ()
This member function is called from OnSize to move and resize the dialog items that are managed.
void | Reset ()
This member function is called when a property sheet in wizard mode has changed pages to alert the resize manager that the property sheet (common control) has moved the page back to its original size/position on the sheet.
void | Offset (CPoint ptOffset)
Called to offset dialog items by the amount specified by ptOffset.
void | UpdateControlRect (CWnd *pWnd)
Call this method to reset m_rrcWindow for an item.
void | GetMinMaxInfo (MINMAXINFO *pMMI)
This member function is called from OnGetMinMaxInfo to get the maximized position or dimensions or the minimum or maximum tracking size.
virtual void | AdjustResizeRect (CSize &rcWindow)
This method is called in the Size method to adjust a window rectangle to fit real client size.
BOOL | HasFlag (XTPResize eFlag)
This member function is called to determine if the specified flag has been set for the resize manager.
void | SetFlag (XTPResize eFlag)
This member function is called to set a specific flag for the resize manager.
virtual BOOL | Defer (HDWP &hdwp, CXTPResizeItem *pItem, int dx, int dy)
Called by CXTPResize to resize a child window.

Detailed Description

CXTPCustomizeCommandsPage is a CPropertyPage derived class.

It represents the Commands page of the Customize dialog.

Constructor & Destructor Documentation

◆ CXTPCustomizeCommandsPage()

CXTPCustomizeCommandsPage ( CXTPCustomizeSheet * pSheet = NULL )

Constructs a CXTPCustomizeCommandsPage object.

Parameters
pSheet Points to a CXTPCustomizeSheet object

Member Function Documentation

◆ AddCategories() [1/2]

BOOL AddCategories ( CXTPControls * pControls )

Adds categories branch from Controls.

Parameters
pControls Points to a CXTPControls object
Returns
TRUE if successful; otherwise returns FALSE

◆ AddCategories() [2/2]

BOOL AddCategories | ( | UINT | nIDResource,
 |  | BOOL | bListSubItems = FALSE )

Adds categories branch from menu resource.

Parameters
nIDResource | Menu resource from where categories will be built.
bListSubItems | TRUE to add sub menus to categories.
Returns
TRUE if successful; otherwise returns FALSE

◆ AddCategory()

BOOL AddCategory | ( | LPCTSTR | strCategory,
 |  | CMenu * | pMenu,
 |  | BOOL | bListSubItems = FALSE )

Adds a new category from a CMenu object.

Parameters
strCategory | Category to be added.
pMenu | Points to a CMenu object
bListSubItems | TRUE to add sub menus to the category.
Returns
TRUE if successful; otherwise returns FALSE

◆ AddToolbarCategory()

BOOL AddToolbarCategory | ( | LPCTSTR | strCategory,
 |  | UINT | nIDResource )

Adds a new category from a toolbar resource.

Parameters
strCategory | Category to be added.
nIDResource | Toolbar resource identifier.
Returns
TRUE if successful; otherwise returns FALSE

◆ FindCategory()

XTP_COMMANDBARS_CATEGORYINFO * FindCategory ( LPCTSTR strCategory ) const

Finds the category.

Parameters
strCategory Category needed to find.
Returns
Returns category

◆ GetCategoryInfo()

XTP_COMMANDBARS_CATEGORYINFO * GetCategoryInfo ( int nIndex ) const

Gets the category by its index.

Parameters
nIndex Index of category
Returns
Returns category index

◆ GetControls()

CXTPControls * GetControls ( LPCTSTR strCategory )

Retrieves the control list of the given category.

Parameters
strCategory Category to retrieve.
Returns
A pointer to a CXTPControls object.

◆ InsertAllCommandsCategory()

void InsertAllCommandsCategory | ( | UINT | nIDResource = XTP_IDS_ALLCOMMANDS,
 |  | int | nIndex = -1,
 |  | BOOL | bSortCommands = TRUE )

Adds "All Commands" category and adds all controls already created in other categories here.

Parameters
nIDResource | "All commands" category string resource.
nIndex | Index to insert.
bSortCommands | TRUE to sort the commands list.

◆ InsertBuiltInMenus()

BOOL InsertBuiltInMenus | ( | UINT | nIDResourceMenu,
 |  | UINT | nIDResourceCategory = XTP_IDS_BUILTINMENUS,
 |  | int | nIndex = -1 )

Adds built-in menus category.

Parameters
nIDResourceMenu | Menu resource identifier.
nIDResourceCategory | "Built-in" string identifier.
nIndex | Index to insert.
Returns
TRUE if successful; otherwise returns FALSE.

◆ InsertCategory()

CXTPControls * InsertCategory | ( | LPCTSTR | strCategory,
 |  | int | nIndex = -1 )

This method adds a new empty category in the given index.

Parameters
strCategory | Category to be added.
nIndex | Index to insert.
Returns
A pointer to a CXTPControls object

◆ InsertNewMenuCategory()

void InsertNewMenuCategory | ( | UINT | nIDResource = XTP_IDS_NEWMENU,
 |  | int | nIndex = -1 )

Adds single "New menu" category.

Parameters
nIDResource | "New Menu" category string resource.
nIndex | Index to insert
The documentation for this class was generated from the following file:
  • XTPCustomizePageCommands.h


Toolkit Pro: CXTPCustomizeKeyboardPage Class Reference

Public Types | Public Member Functions | Public Attributes | Protected Attributes | List of all members
CXTPCustomizeKeyboardPage Class Reference

CXTPCustomizeKeyboardPage is a CPropertyPage derived class. More...

Inheritance diagram for CXTPCustomizeKeyboardPage:
[legend]

Public Types

enum { IDD = XTP_IDD_PAGE_KEYBOARD }

Public Member Functions

CXTPCustomizeKeyboardPage (CXTPCustomizeSheet *pSheet)
Constructs a CXTPCustomizeKeyboardPage object.
~CXTPCustomizeKeyboardPage ()
Destroys a CXTPCustomizeKeyboardPage object, handles cleanup and deallocation.
XTP_COMMANDBARS_CATEGORYINFO * | FindCategory (LPCTSTR strCategory) const
Finds the category.
XTP_COMMANDBARS_CATEGORYINFO * | GetCategoryInfo (int nIndex) const
Gets the category by its index.
CXTPControls * | InsertCategory (LPCTSTR strCategory, int nIndex=-1)
This method adds a new empty category in the given index.
BOOL | AddCategory (LPCTSTR strCategory, CMenu *pMenu, BOOL bListSubItems=FALSE)
Adds a new category from a CMenu object.
BOOL | AddCategories (CXTPControls *pControls)
Adds categories branch from Control or resource ID.
BOOL | AddCategories (UINT nIDResource, BOOL bListSubItems=FALSE)
Adds categories branch from Control or resource ID.
void | ReloadList ()
This member function is called by the page to reload the list items.
void | EnableControls ()
This member function is called by the page to enable the assignment buttons.
CXTPShortcutManagerAccelTable * | GetFrameAccelerator () const
void | UpdateAcellTable (LPACCEL lpAccel, int nSize)
Updates frame accelerators.
- Public Member Functions inherited from CXTPPropertyPage
CXTPPropertyPage ()
Constructs a CXTPPropertyPage object.
CXTPPropertyPage (UINT nIDTemplate, UINT nIDCaption=0)
Constructs a CXTPPropertyPage object.
CXTPPropertyPage (LPCTSTR lpszTemplateName, UINT nIDCaption=0)
Constructs a CXTPPropertyPage object.
~CXTPPropertyPage ()
Destroys a CXTPPropertyPage object, handles cleanup and deallocation.
CString | GetCaption () const
Retrieves the caption text used for property sheet tabs.
void | SetCaption (LPCTSTR lpszCaption)
Sets the caption text used to draw property sheet tabs.
virtual void | UpdatePage (void)
Forces a page to update its internal data as this data is supposed to be changed from outside the page.
- Public Member Functions inherited from CXTPResize
CXTPResize (CWnd *pWnd, const UINT nFlags=0)
Constructs a CXTPResize object.
virtual | ~CXTPResize ()
Destroys a CXTPResize object, handles cleanup and deallocation.
void | SetResize (UINT nID, XTP_RESIZE left, XTP_RESIZE top, XTP_RESIZE right, XTP_RESIZE bottom)
The SetResize function specifies how much each side of a control will move when the dialog is resized.
void | SetResize (UINT nID, const XTP_RESIZERECT &rrcSizing)
The SetResize function specifies how much each side of a control will move when the dialog is resized.
void | SetResize (UINT nID, HWND hWnd, const XTP_RESIZERECT &rrcSizing)
The SetResize function specifies how much each side of a control will move when the dialog is resized.
void | SetResize (UINT nID, HWND hWnd, const XTP_RESIZEPOINT &rpTopLeft, const XTP_RESIZEPOINT &rpBottomRight)
The SetResize function specifies how much each side of a control will move when the dialog is resized.
void | SetResize (UINT nID, const XTP_RESIZEPOINT &rpTopLeft, const XTP_RESIZEPOINT &rpBottomRight)
The SetResize function specifies how much each side of a control will move when the dialog is resized.
void | SetMinSize (CSize &sz)
This member function sets the minimum size explicitly.
void | SetMaxSize (CSize &sz)
This member function sets the maximum size.
BOOL | SavePlacement (LPCTSTR pszSection)
This member function saves the window placement to the registry.
BOOL | LoadPlacement (LPCTSTR pszSection)
This member function loads saved window placement information from the registry.
BOOL | AutoLoadPlacement (LPCTSTR pszSection)
This member function loads saved window placement information from the registry.

Public Attributes

CListBox | m_lboxKeys
Keys list box.
CListBox | m_lboxCommands
Commands list box.
CComboBox | m_comboCategory
Categories combobox.
CString | m_strDesc
Description of selected control.
int | m_iCategory
Selected category.
CXTPShortcutManager::CKeyAssign | m_editShortcutKey
Shortcut edit control.
- Public Attributes inherited from CXTPPropertyPage
DWORD_PTR | m_dwData
Page specific 32-bit value.

Protected Attributes

CXTPCommandBarsCategoryArray | m_arrCategories
Array of categories.
CXTPCustomizeSheet * | m_pSheet
Parent Customize dialog.
- Protected Attributes inherited from CXTPPropertyPage
CXTPPropertySheet * | m_pSheet
Parent CXTPPropertySheet object.
BOOL | m_bModified
TRUE to indicate that the property page settings have been modified.
- Protected Attributes inherited from CXTPResize
UINT | m_nFlagsXX
Flags passed from the constructor.
CWnd * | m_pWnd
The associative relation to the window to be resized.
CSize | m_szWindow
Last dialog size.
CSize | m_szInitWindow
Initial dialog size.
CSize | m_szMin
Smallest size allowed.
CSize | m_szMax
Largest size allowed.
CString | m_strSection
Section in registry where window placement information is saved.
CXTPSizeIcon | m_scSizeIcon
Size icon window.
CResizeItemArray | m_arrItems
Array of controls.

Additional Inherited Members

- Protected Types inherited from CXTPResize
typedef CArray< CXTPResizeItem *, CXTPResizeItem *& > | CResizeItemArray
Used by CXTPResize to maintain a list of children that are sizable.
- Protected Member Functions inherited from CXTPResize
void | SetResize (CWnd *pWnd, const CXTPResizeRect &rrcSizing, CRect rcWindow)
The SetResize function specifies how much each side of a control will move when the dialog is resized.
BOOL | RemoveResize (UINT nID)
This member function is called to remove the specified dialog item from the list of items to be resized.
void | RemoveAllControls ()
This member function is called to purge the list that contains the dialog items to be sized.
virtual void | Init ()
This member function is called from OnInitDialog or OnInitialUpdate to initialize the resize manager.
virtual void | Size ()
This member function is called from OnSize to move and resize the dialog items that are managed.
void | Reset ()
This member function is called when a property sheet in wizard mode has changed pages to alert the resize manager that the property sheet (common control) has moved the page back to its original size/position on the sheet.
void | Offset (CPoint ptOffset)
Called to offset dialog items by the amount specified by ptOffset.
void | UpdateControlRect (CWnd *pWnd)
Call this method to reset m_rrcWindow for an item.
void | GetMinMaxInfo (MINMAXINFO *pMMI)
This member function is called from OnGetMinMaxInfo to get the maximized position or dimensions or the minimum or maximum tracking size.
virtual void | AdjustResizeRect (CSize &rcWindow)
This method is called in the Size method to adjust a window rectangle to fit real client size.
BOOL | HasFlag (XTPResize eFlag)
This member function is called to determine if the specified flag has been set for the resize manager.
void | SetFlag (XTPResize eFlag)
This member function is called to set a specific flag for the resize manager.
virtual BOOL | Defer (HDWP &hdwp, CXTPResizeItem *pItem, int dx, int dy)
Called by CXTPResize to resize a child window.

Detailed Description

CXTPCustomizeKeyboardPage is a CPropertyPage derived class.

It represents the Keyboard page of the Customize dialog.

Member Enumeration Documentation

◆ anonymous enum

anonymous enum
Enumerator
IDD

Property page identifier.

Constructor & Destructor Documentation

◆ CXTPCustomizeKeyboardPage()

CXTPCustomizeKeyboardPage ( CXTPCustomizeSheet * pSheet )

Constructs a CXTPCustomizeKeyboardPage object.

Parameters
pSheet Points to a CXTPCustomizeSheet object that this page belongs to.

Member Function Documentation

◆ AddCategories() [1/2]

BOOL AddCategories ( CXTPControls * pControls )

Adds categories branch from Control or resource ID.

Parameters
pControls Points to a CXTPControls object
Returns
TRUE if successful; otherwise returns FALSE

◆ AddCategories() [2/2]

BOOL AddCategories | ( | UINT | nIDResource,
 |  | BOOL | bListSubItems = FALSE )

Adds categories branch from Control or resource ID.

Parameters
nIDResource | Menu resource from where categories will be built.
bListSubItems | TRUE to add sub menus to categories.
Returns
TRUE if successful; otherwise returns FALSE

◆ AddCategory()

BOOL AddCategory | ( | LPCTSTR | strCategory,
 |  | CMenu * | pMenu,
 |  | BOOL | bListSubItems = FALSE )

Adds a new category from a CMenu object.

Parameters
strCategory | Category to be added.
pMenu | Points to a CMenu object
bListSubItems | TRUE to add sub menus to categories.
Returns
TRUE if successful; otherwise returns FALSE

◆ FindCategory()

XTP_COMMANDBARS_CATEGORYINFO * FindCategory ( LPCTSTR strCategory ) const

Finds the category.

Parameters
strCategory Category needed to find.
Returns
Returns category

◆ GetCategoryInfo()

XTP_COMMANDBARS_CATEGORYINFO * GetCategoryInfo ( int nIndex ) const

Gets the category by its index.

Parameters
nIndex Index of category
Returns
Returns category index

◆ GetFrameAccelerator()

CXTPShortcutManagerAccelTable * GetFrameAccelerator ( ) const
Returns
Retrieves frame accelerators.

◆ InsertCategory()

CXTPControls * InsertCategory | ( | LPCTSTR | strCategory,
 |  | int | nIndex = -1 )

This method adds a new empty category in the given index.

Parameters
strCategory | Category to be added.
nIndex | Index to insert.
Returns
A pointer to a CXTPControls object

◆ UpdateAcellTable()

void UpdateAcellTable | ( | LPACCEL | lpAccel,
 |  | int | nSize )

Updates frame accelerators.

Parameters
lpAccel | Accelerator table to set.
nSize | Number of items.
The documentation for this class was generated from the following file:
  • XTPCustomizePageKeyboard.h


Toolkit Pro: CXTPCustomizeMenusPage Class Reference

Public Member Functions | Public Attributes | Protected Member Functions | Protected Attributes | List of all members
CXTPCustomizeMenusPage Class Reference

CXTPCustomizeMenusPage is a CPropertyPage derived class. More...

Inheritance diagram for CXTPCustomizeMenusPage:
[legend]

Public Member Functions

CXTPCustomizeMenusPage (CXTPCustomizeSheet *pSheet)
Construction.
~CXTPCustomizeMenusPage ()
Destroys a CXTPCustomizeMenusPage object, handles cleanup and deallocation.
- Public Member Functions inherited from CXTPPropertyPage
CXTPPropertyPage ()
Constructs a CXTPPropertyPage object.
CXTPPropertyPage (UINT nIDTemplate, UINT nIDCaption=0)
Constructs a CXTPPropertyPage object.
CXTPPropertyPage (LPCTSTR lpszTemplateName, UINT nIDCaption=0)
Constructs a CXTPPropertyPage object.
~CXTPPropertyPage ()
Destroys a CXTPPropertyPage object, handles cleanup and deallocation.
CString | GetCaption () const
Retrieves the caption text used for property sheet tabs.
void | SetCaption (LPCTSTR lpszCaption)
Sets the caption text used to draw property sheet tabs.
virtual void | UpdatePage (void)
Forces a page to update its internal data as this data is supposed to be changed from outside the page.
- Public Member Functions inherited from CXTPResize
CXTPResize (CWnd *pWnd, const UINT nFlags=0)
Constructs a CXTPResize object.
virtual | ~CXTPResize ()
Destroys a CXTPResize object, handles cleanup and deallocation.
void | SetResize (UINT nID, XTP_RESIZE left, XTP_RESIZE top, XTP_RESIZE right, XTP_RESIZE bottom)
The SetResize function specifies how much each side of a control will move when the dialog is resized.
void | SetResize (UINT nID, const XTP_RESIZERECT &rrcSizing)
The SetResize function specifies how much each side of a control will move when the dialog is resized.
void | SetResize (UINT nID, HWND hWnd, const XTP_RESIZERECT &rrcSizing)
The SetResize function specifies how much each side of a control will move when the dialog is resized.
void | SetResize (UINT nID, HWND hWnd, const XTP_RESIZEPOINT &rpTopLeft, const XTP_RESIZEPOINT &rpBottomRight)
The SetResize function specifies how much each side of a control will move when the dialog is resized.
void | SetResize (UINT nID, const XTP_RESIZEPOINT &rpTopLeft, const XTP_RESIZEPOINT &rpBottomRight)
The SetResize function specifies how much each side of a control will move when the dialog is resized.
void | SetMinSize (CSize &sz)
This member function sets the minimum size explicitly.
void | SetMaxSize (CSize &sz)
This member function sets the maximum size.
BOOL | SavePlacement (LPCTSTR pszSection)
This member function saves the window placement to the registry.
BOOL | LoadPlacement (LPCTSTR pszSection)
This member function loads saved window placement information from the registry.
BOOL | AutoLoadPlacement (LPCTSTR pszSection)
This member function loads saved window placement information from the registry.

Public Attributes

CStatic | m_wndIcon
Implementation.
- Public Attributes inherited from CXTPPropertyPage
DWORD_PTR | m_dwData
Page specific 32-bit value.

Protected Member Functions

void | CommitContextMenu ()
This method is called to save user changes.
- Protected Member Functions inherited from CXTPResize
void | SetResize (CWnd *pWnd, const CXTPResizeRect &rrcSizing, CRect rcWindow)
The SetResize function specifies how much each side of a control will move when the dialog is resized.
BOOL | RemoveResize (UINT nID)
This member function is called to remove the specified dialog item from the list of items to be resized.
void | RemoveAllControls ()
This member function is called to purge the list that contains the dialog items to be sized.
virtual void | Init ()
This member function is called from OnInitDialog or OnInitialUpdate to initialize the resize manager.
virtual void | Size ()
This member function is called from OnSize to move and resize the dialog items that are managed.
void | Reset ()
This member function is called when a property sheet in wizard mode has changed pages to alert the resize manager that the property sheet (common control) has moved the page back to its original size/position on the sheet.
void | Offset (CPoint ptOffset)
Called to offset dialog items by the amount specified by ptOffset.
void | UpdateControlRect (CWnd *pWnd)
Call this method to reset m_rrcWindow for an item.
void | GetMinMaxInfo (MINMAXINFO *pMMI)
This member function is called from OnGetMinMaxInfo to get the maximized position or dimensions or the minimum or maximum tracking size.
virtual void | AdjustResizeRect (CSize &rcWindow)
This method is called in the Size method to adjust a window rectangle to fit real client size.
BOOL | HasFlag (XTPResize eFlag)
This member function is called to determine if the specified flag has been set for the resize manager.
void | SetFlag (XTPResize eFlag)
This member function is called to set a specific flag for the resize manager.
virtual BOOL | Defer (HDWP &hdwp, CXTPResizeItem *pItem, int dx, int dy)
Called by CXTPResize to resize a child window.

Protected Attributes

CXTPToolBar * | m_pContextMenu
Active context menu.
CXTPCustomizeSheet * | m_pSheet
Parent sheet.
CPoint | m_ptContextMenu
Last position of context menu.
CString | m_strDefaultMenu
Default menu caption.
CString | m_strDefaultMenuDesc
Default menu description.
- Protected Attributes inherited from CXTPPropertyPage
CXTPPropertySheet * | m_pSheet
Parent CXTPPropertySheet object.
BOOL | m_bModified
TRUE to indicate that the property page settings have been modified.
- Protected Attributes inherited from CXTPResize
UINT | m_nFlagsXX
Flags passed from the constructor.
CWnd * | m_pWnd
The associative relation to the window to be resized.
CSize | m_szWindow
Last dialog size.
CSize | m_szInitWindow
Initial dialog size.
CSize | m_szMin
Smallest size allowed.
CSize | m_szMax
Largest size allowed.
CString | m_strSection
Section in registry where window placement information is saved.
CXTPSizeIcon | m_scSizeIcon
Size icon window.
CResizeItemArray | m_arrItems
Array of controls.

Additional Inherited Members

- Protected Types inherited from CXTPResize
typedef CArray< CXTPResizeItem *, CXTPResizeItem *& > CResizeItemArray
Used by CXTPResize to maintain a list of children that are sizable.

Detailed Description

CXTPCustomizeMenusPage is a CPropertyPage derived class.

It represents the Menus page of the Customize dialog.

Constructor & Destructor Documentation

◆ CXTPCustomizeMenusPage()

CXTPCustomizeMenusPage ( CXTPCustomizeSheet * pSheet )

Construction.

Constructs a CXTPCustomizeMenusPage object

Parameters
pSheet Points to a CXTPCustomizeSheet object that this page belongs to.
The documentation for this class was generated from the following file:
  • XTPCustomizePageMenus.h


Toolkit Pro: CXTPCustomizeOptionsPage Class Reference

Public Types | Public Member Functions | Public Attributes | Protected Member Functions | Protected Attributes | List of all members
CXTPCustomizeOptionsPage Class Reference

CXTPCustomizeOptionsPage is a CPropertyPage derived class. More...

Inheritance diagram for CXTPCustomizeOptionsPage:
[legend]

Public Types

enum { IDD = XTP_IDD_PAGE_OPTIONS }

Public Member Functions

CXTPCustomizeOptionsPage (CXTPCustomizeSheet *pSheet)
Constructs a CXTPCustomizeOptionsPage object.
~CXTPCustomizeOptionsPage ()
Destroys a CXTPCustomizeOptionsPage object, handles cleanup and deallocation.
CXTPCommandBars * | GetCommandBars () const
Retrieves parent command bars.
- Public Member Functions inherited from CXTPPropertyPage
CXTPPropertyPage ()
Constructs a CXTPPropertyPage object.
CXTPPropertyPage (UINT nIDTemplate, UINT nIDCaption=0)
Constructs a CXTPPropertyPage object.
CXTPPropertyPage (LPCTSTR lpszTemplateName, UINT nIDCaption=0)
Constructs a CXTPPropertyPage object.
~CXTPPropertyPage ()
Destroys a CXTPPropertyPage object, handles cleanup and deallocation.
CString | GetCaption () const
Retrieves the caption text used for property sheet tabs.
void | SetCaption (LPCTSTR lpszCaption)
Sets the caption text used to draw property sheet tabs.
virtual void | UpdatePage (void)
Forces a page to update its internal data as this data is supposed to be changed from outside the page.
- Public Member Functions inherited from CXTPResize
CXTPResize (CWnd *pWnd, const UINT nFlags=0)
Constructs a CXTPResize object.
virtual | ~CXTPResize ()
Destroys a CXTPResize object, handles cleanup and deallocation.
void | SetResize (UINT nID, XTP_RESIZE left, XTP_RESIZE top, XTP_RESIZE right, XTP_RESIZE bottom)
The SetResize function specifies how much each side of a control will move when the dialog is resized.
void | SetResize (UINT nID, const XTP_RESIZERECT &rrcSizing)
The SetResize function specifies how much each side of a control will move when the dialog is resized.
void | SetResize (UINT nID, HWND hWnd, const XTP_RESIZERECT &rrcSizing)
The SetResize function specifies how much each side of a control will move when the dialog is resized.
void | SetResize (UINT nID, HWND hWnd, const XTP_RESIZEPOINT &rpTopLeft, const XTP_RESIZEPOINT &rpBottomRight)
The SetResize function specifies how much each side of a control will move when the dialog is resized.
void | SetResize (UINT nID, const XTP_RESIZEPOINT &rpTopLeft, const XTP_RESIZEPOINT &rpBottomRight)
The SetResize function specifies how much each side of a control will move when the dialog is resized.
void | SetMinSize (CSize &sz)
This member function sets the minimum size explicitly.
void | SetMaxSize (CSize &sz)
This member function sets the maximum size.
BOOL | SavePlacement (LPCTSTR pszSection)
This member function saves the window placement to the registry.
BOOL | LoadPlacement (LPCTSTR pszSection)
This member function loads saved window placement information from the registry.
BOOL | AutoLoadPlacement (LPCTSTR pszSection)
This member function loads saved window placement information from the registry.

Public Attributes

CButton | m_btnResetData
Reset data.
CButton | m_btnAlwaysShowFullMenus
Show full menus always.
CButton | m_btnShowFullAfterDelay
Show menus after delay.
CButton | m_btnLargeIcons
Show large icons.
CButton | m_btnToolBarScreenTips
Show tool tips.
CButton | m_btnToolBarAccelTips
Show accelerators with tool tips.
CComboBox | m_comboAnimationType
Animation combobox.
int | m_nAnimationType
Selected animation type.
CXTPGroupLine | m_wndPersonalizedGroup
Personalized group line.
CXTPGroupLine | m_wndOtherGroup
Other group line.
- Public Attributes inherited from CXTPPropertyPage
DWORD_PTR | m_dwData
Page specific 32-bit value.

Protected Member Functions

void | AddComboString (UINT nIDResource)
Adds animation string from resource.
- Protected Member Functions inherited from CXTPResize
void | SetResize (CWnd *pWnd, const CXTPResizeRect &rrcSizing, CRect rcWindow)
The SetResize function specifies how much each side of a control will move when the dialog is resized.
BOOL | RemoveResize (UINT nID)
This member function is called to remove the specified dialog item from the list of items to be resized.
void | RemoveAllControls ()
This member function is called to purge the list that contains the dialog items to be sized.
virtual void | Init ()
This member function is called from OnInitDialog or OnInitialUpdate to initialize the resize manager.
virtual void | Size ()
This member function is called from OnSize to move and resize the dialog items that are managed.
void | Reset ()
This member function is called when a property sheet in wizard mode has changed pages to alert the resize manager that the property sheet (common control) has moved the page back to its original size/position on the sheet.
void | Offset (CPoint ptOffset)
Called to offset dialog items by the amount specified by ptOffset.
void | UpdateControlRect (CWnd *pWnd)
Call this method to reset m_rrcWindow for an item.
void | GetMinMaxInfo (MINMAXINFO *pMMI)
This member function is called from OnGetMinMaxInfo to get the maximized position or dimensions or the minimum or maximum tracking size.
virtual void | AdjustResizeRect (CSize &rcWindow)
This method is called in the Size method to adjust a window rectangle to fit real client size.
BOOL | HasFlag (XTPResize eFlag)
This member function is called to determine if the specified flag has been set for the resize manager.
void | SetFlag (XTPResize eFlag)
This member function is called to set a specific flag for the resize manager.
virtual BOOL | Defer (HDWP &hdwp, CXTPResizeItem *pItem, int dx, int dy)
Called by CXTPResize to resize a child window.

Protected Attributes

CXTPCustomizeSheet * | m_pSheet
Parent sheet.
- Protected Attributes inherited from CXTPPropertyPage
CXTPPropertySheet * | m_pSheet
Parent CXTPPropertySheet object.
BOOL | m_bModified
TRUE to indicate that the property page settings have been modified.
- Protected Attributes inherited from CXTPResize
UINT | m_nFlagsXX
Flags passed from the constructor.
CWnd * | m_pWnd
The associative relation to the window to be resized.
CSize | m_szWindow
Last dialog size.
CSize | m_szInitWindow
Initial dialog size.
CSize | m_szMin
Smallest size allowed.
CSize | m_szMax
Largest size allowed.
CString | m_strSection
Section in registry where window placement information is saved.
CXTPSizeIcon | m_scSizeIcon
Size icon window.
CResizeItemArray | m_arrItems
Array of controls.

Additional Inherited Members

- Protected Types inherited from CXTPResize
typedef CArray< CXTPResizeItem *, CXTPResizeItem *& > CResizeItemArray
Used by CXTPResize to maintain a list of children that are sizable.

Detailed Description

CXTPCustomizeOptionsPage is a CPropertyPage derived class.

It represents the Options page of the Customize dialog.

Member Enumeration Documentation

◆ anonymous enum

anonymous enum
Enumerator
IDD

Property page identifier.

Constructor & Destructor Documentation

◆ CXTPCustomizeOptionsPage()

CXTPCustomizeOptionsPage ( CXTPCustomizeSheet * pSheet )

Constructs a CXTPCustomizeOptionsPage object.

Parameters
pSheet Points to a CXTPCustomizeSheet object that this page belongs to.

Member Function Documentation

◆ AddComboString()

void AddComboString ( UINT nIDResource )
protected

Adds animation string from resource.

Parameters
nIDResource Specifies the string resource ID to add.

◆ GetCommandBars()

CXTPCommandBars * GetCommandBars ( ) const

Retrieves parent command bars.

Returns
A pointer to a CXTPCommandBars object
The documentation for this class was generated from the following file:
  • XTPCustomizePageOptions.h


Toolkit Pro: CXTPCustomizeSheet Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPCustomizeSheet Class Reference

CXTPCustomizeSheet is a CPropertySheet derived class. More...

Inheritance diagram for CXTPCustomizeSheet:
[legend]

Public Member Functions

CXTPCustomizeSheet (CXTPCommandBars *pCommandBars, UINT iSelectPage=0)
Constructs a CXTPCustomizeSheet object.
virtual | ~CXTPCustomizeSheet ()
Destroys a CXTPCustomizeSheet object, handles cleanup and deallocation.
CXTPPopupBar * | GetContextMenu () const
Call this member to get a pointer to the context menu that is displayed in customization mode when a user right-clicks on a control.
CXTPImageManager * | GetCustomIcons () const
Retrieves collection of custom icons that can be selected for a control during customization mode.
int | MessageBox (LPCTSTR lpszText, UINT nType=MB_OK)
Displays a message box.
CXTPControl * | GetDragControl () const
Call this member to retrieve the current customized control.
CXTPCustomizeCommandsPage * | GetCommandsPage () const
Returns the Commands PropertyPage.
CXTPCustomizeToolbarsPage * | GetToolbarsPage () const
Returns the Toolbars PropertyPage.
CXTPCommandBars * | GetCommandBars () const
Returns the parent Command Bars class.
INT_PTR | DoModal ()
Call this method to show customize dialog.
void | ContextMenu (CPoint point)
This method shows the context menu for toolbars.
void | AddPage (CXTPPropertyPage *pPage, int nIndex=-1)
Adds the supplied page with the rightmost tab in the property sheet.
- Public Member Functions inherited from CXTPPropertySheet
CXTPPropertySheet ()
Constructs a CXTPPropertySheet object.
CXTPPropertySheet (UINT nIDCaption, CWnd *pParentWnd=NULL, UINT iSelectPage=0)
Constructs a CXTPPropertySheet object.
CXTPPropertySheet (LPCTSTR pszCaption, CWnd *pParentWnd=NULL, UINT iSelectPage=0)
Constructs a CXTPPropertySheet object.
~CXTPPropertySheet ()
Destroys a CXTPPropertySheet object, handles cleanup and deallocation.
BOOL | Create (CWnd *pParentWnd=NULL, DWORD dwStyle=(DWORD) -1, DWORD dwExStyle=0)
Displays a modeless property sheet.
INT_PTR | DoModal ()
Call this member function to display a modal property sheet.
void | AddPage (CXTPPropertyPage *pPage)
Adds a page to the property sheet.
void | InsertPage (int nIndex, CXTPPropertyPage *pPage)
Adds a page to the property sheet.
void | RemovePage (int nPage)
This member function removes a page from the property sheet and destroys the associated window.
void | RemovePage (CXTPPropertyPage *pPage)
This member function removes a page from the property sheet and destroys the associated window.
int | GetPageCount () const
Call this member function to determine the number of pages currently in the property sheet.
CXTPPropertyPage * | GetPage (int nPage) const
Call this member function to retrieve a pointer to a specified page in the property sheet.
int | GetPageIndex (CXTPPropertyPage *pPage) const
Call this member function to retrieve the index number of a specified page in the property sheet.
CXTPPropertyPage * | GetActivePage () const
Call this member function to retrieve a pointer to the property sheet window's active page.
int | GetActiveIndex () const
Call this member function to retrieve the index number of the property sheet window's active page.
virtual BOOL | SetActivePage (int nPage)
Call this member function to set the active page.
virtual BOOL | SetActivePage (CXTPPropertyPage *pPage)
Call this member function to set the active page.
void | SetTitle (LPCTSTR lpszText)
Call this member function to set the property sheet's caption (the text displayed in the title bar of a frame window).
CRect | GetPageRect () const
Retrieves the CRect bounding rectangle for all property pages.
CXTPPropertyPageNavigator * | GetNavigator () const
Retrieves the currently used navigator object.
void | SetNavigator (CXTPPropertyPageNavigator *pNavigator)
Sets the navigator object that will be used to switch property pages.
virtual BOOL | AddButton (UINT nIDCaption, UINT nID)
Adds a new button to the property sheet window.
void | RemoveButtons ()
Deletes all buttons from the property sheet.
void | SetPageBorderStyle (XTPPropertyPageBorder nBorder)
Sets a border style around a client page rectangle.
XTPPropertyPageBorder | GetPageBorderStyle () const
Retrieves the border style around a client page rectangle.
void | SetResizable (BOOL bResizable=TRUE)
Call this member to allow the user to resize the property sheet.
void | SetPageSize (CSize szPage)
Call this member to set a custom size for property pages.
void | SetPageSizeMin (CSize szPage)
Call this member to set a minimun size for property pages.
void | SetPageSizeMax (CSize szPage)
Call this member to set a maximum size for property pages.
BOOL | SavePlacement (LPCTSTR pszSection)
This member function saves the window placement to the registry.
BOOL | LoadPlacement (LPCTSTR pszSection)
This member function loads saved window placement information from the registry.
BOOL | AutoLoadPlacement (LPCTSTR pszSection)
This member function loads saved window placement information from the registry.
void | UpdatePages ()
Forces all pages to update themselves as the data that they rely on is supposed to be changed from outside.
void | SetTheme (XTPControlTheme theme)
Call this member to switch the visual theme of the control.
XTPControlTheme GetTheme ()
This method is called to retrieve the current theme ID.
- Public Member Functions inherited from CXTPDialogEx
CXTPDialogEx ()
Constructs a CXTPDialogEx object.
CXTPDialogEx (UINT nIDTemplate, CWnd *pParentWnd=NULL)
Constructs a CXTPDialogEx object.
CXTPDialogEx (LPCTSTR lpszTemplateName, CWnd *pParentWnd=NULL)
Constructs a CXTPDialogEx object.
- Public Member Functions inherited from CXTPDialogBase< CDialog >
CXTPDialogBase ()
Constructs a CXTPDialog object.
CXTPDialogBase (UINT nIDTemplate, CWnd *pParentWnd=NULL)
Constructs a CXTPDialog object.
CXTPDialogBase (LPCTSTR lpszTemplateName, CWnd *pParentWnd=NULL)
Constructs a CXTPDialog object.

Protected Attributes

CXTPCustomizeToolbarsPage * | m_pPageToolBars
Toolbar page.
CXTPCustomizeCommandsPage * | m_pPageCommands
Commands page.
CWnd * | m_pWndParent
Parent window.
CXTPCommandBars * | m_pCommandBars
Customized comamndBars.
CXTPPopupBar * | m_pContextMenu
Context menu that is displayed in customization mode when a user right-clicks on a control.
CXTPImageManager * | m_pCustomIcons
Icons displayed in the "Change Button Image" pop-up of the context menu that is displayed when a user right-clicks on a control.
- Protected Attributes inherited from CXTPPropertySheet
CString | m_strCaption
Caption of the dialog.
LPDLGTEMPLATE | m_lpDlgTemplate
Dialog template.
CArray< CButton *, CButton * > | m_arrButtons
Array of buttons of property sheet.
CXTPPropertyPageNavigator * | m_pNavigator
Currently used navigator.
CXTPFont | m_xtpFontNormal
Font used to draw buttons and navigator.
CArray< CXTPPropertyPage *, CXTPPropertyPage * > | m_arrPages
Array of propety pages.
CXTPPropertyPage * | m_pActivePage
Pointer to active property page.
CRect | m_rcPage
Bounding rectangle of active page.
CRect | m_rcMinPage
Minimum bounding rectangle of active page.
CRect | m_rcMaxPage
Maximum bounding rectangle of active page.
BOOL | m_bAllowApply
TRUE to allow enable apply button.
BOOL | m_bModeless
TRUE if property sheet was created as modeless window.
BOOL | m_bResizable
TRUE if dialog can be resized.
CSize | m_szWindow
Last window size of property sheet.
CSize | m_szButton
Button size.
CXTPScrollBar | m_scSizeIcon
Resize glyph.
XTPPropertyPageBorder | m_nPageBorderStyle
Client border style.

Additional Inherited Members

- Public Attributes inherited from CXTPPropertySheet
PROPSHEETHEADER | m_psh
The Windows PROPSHEETHEADER structure.
- Protected Member Functions inherited from CXTPPropertySheet
virtual BOOL | CreateButtons ()
This method is called to create all property sheet buttons.
virtual BOOL | CreatePage (CXTPPropertyPage *pPage)
This method is called to create a property page window.

Detailed Description

CXTPCustomizeSheet is a CPropertySheet derived class.

It represents the Customize dialog.

Constructor & Destructor Documentation

◆ CXTPCustomizeSheet()

CXTPCustomizeSheet | ( | CXTPCommandBars * | pCommandBars,
 |  | UINT | iSelectPage = 0 )

Constructs a CXTPCustomizeSheet object.

Parameters
pCommandBars | Points to a CXTPCommandBars object
iSelectPage | Page initially selected.

Member Function Documentation

◆ AddPage()

void AddPage | ( | CXTPPropertyPage * | pPage,
 |  | int | nIndex = -1 )

Adds the supplied page with the rightmost tab in the property sheet.

Parameters
nIndex | Point index.
pPage | Points to the page to be added to the property sheet. Cannot be NULL.

◆ ContextMenu()

void ContextMenu ( CPoint point )

This method shows the context menu for toolbars.

Parameters
point Position of the menu to show

◆ DoModal()

INT_PTR DoModal ( )

Call this method to show customize dialog.

Returns
Returns customize dialog

◆ GetCommandBars()

AFX_INLINE CXTPCommandBars * GetCommandBars ( ) const

Returns the parent Command Bars class.

Returns
A pointer to a CXTPCommandBars object

◆ GetCommandsPage()

AFX_INLINE CXTPCustomizeCommandsPage * GetCommandsPage ( ) const

Returns the Commands PropertyPage.

Returns
A pointer to a CXTPCustomizeCommandsPage object

◆ GetContextMenu()

AFX_INLINE CXTPPopupBar * GetContextMenu ( ) const

Call this member to get a pointer to the context menu that is displayed in customization mode when a user right-clicks on a control.

Returns
Retrieves the context menu.

◆ GetCustomIcons()

AFX_INLINE CXTPImageManager * GetCustomIcons ( ) const

Retrieves collection of custom icons that can be selected for a control during customization mode.

Custom icons are displayed in the "Change Button Image" pop-up of the context menu that is displayed when a user right-clicks on a control.

Returns
Returns collection of custom icons

Icons must be numbered from 1. When adding icons, the numbering must start with 1 and increment by 1 for each icon added. So the numbering would look like this: 1, 2, 3, 4, ...N.

 The toolkit provide 42 "built-in" icons that you can choose from
 and they are automatically displayed in the "Change Button Icon"
 pop-up menu if you do not remove them.  If you do not remove the
 "built-in" icons that are provided with the toolkit then you should
 start your numbering at 43.  If you start at 1 and you did not
 remove the "bulilt-in" icons, then you will overwrite some of
 the "built-in" icons.  So you would number your icons
 43, 44, 45, ...N.  So you could even keep some of the "built-in"
 icons and overwrite the ones you don't need with your own
 custom icons.

◆ GetDragControl()

CXTPControl * GetDragControl ( ) const

Call this member to retrieve the current customized control.

Returns
A pointer to a CXTPControl object.

◆ GetToolbarsPage()

AFX_INLINE CXTPCustomizeToolbarsPage * GetToolbarsPage ( ) const

Returns the Toolbars PropertyPage.

Returns
A pointer to a CXTPCustomizeCommandsPage object

◆ MessageBox()

int MessageBox | ( | LPCTSTR | lpszText,
 |  | UINT | nType = MB_OK )

Displays a message box.

Parameters
lpszText | Text in message box.
nType | Specifies the contents and behavior of the dialog box.
Returns
If the function succeeds, the return value specified the button that was selected.
The documentation for this class was generated from the following file:
  • XTPCustomizeSheet.h


Toolkit Pro: CXTPCustomizeToolbarsPage Class Reference

Public Types | Public Member Functions | Public Attributes | Protected Attributes | List of all members
CXTPCustomizeToolbarsPage Class Reference

CXTPCustomizeToolbarsPage is a CPropertyPage derived class. More...

Inheritance diagram for CXTPCustomizeToolbarsPage:
[legend]

Public Types

enum { IDD = XTP_IDD_PAGE_TOOLBARS }

Public Member Functions

CXTPCustomizeToolbarsPage (CXTPCustomizeSheet *pSheet=NULL)
Constructs a CXTPCustomizeToolbarsPage object.
~CXTPCustomizeToolbarsPage ()
Destroys a CXTPCustomizeToolbarsPage object, handles cleanup and deallocation.
void | AllowNewToolbars (BOOL bEnable)
Displays or hides the new toolbar button.
- Public Member Functions inherited from CXTPPropertyPage
CXTPPropertyPage ()
Constructs a CXTPPropertyPage object.
CXTPPropertyPage (UINT nIDTemplate, UINT nIDCaption=0)
Constructs a CXTPPropertyPage object.
CXTPPropertyPage (LPCTSTR lpszTemplateName, UINT nIDCaption=0)
Constructs a CXTPPropertyPage object.
~CXTPPropertyPage ()
Destroys a CXTPPropertyPage object, handles cleanup and deallocation.
CString | GetCaption () const
Retrieves the caption text used for property sheet tabs.
void | SetCaption (LPCTSTR lpszCaption)
Sets the caption text used to draw property sheet tabs.
virtual void | UpdatePage (void)
Forces a page to update its internal data as this data is supposed to be changed from outside the page.
- Public Member Functions inherited from CXTPResize
CXTPResize (CWnd *pWnd, const UINT nFlags=0)
Constructs a CXTPResize object.
virtual | ~CXTPResize ()
Destroys a CXTPResize object, handles cleanup and deallocation.
void | SetResize (UINT nID, XTP_RESIZE left, XTP_RESIZE top, XTP_RESIZE right, XTP_RESIZE bottom)
The SetResize function specifies how much each side of a control will move when the dialog is resized.
void | SetResize (UINT nID, const XTP_RESIZERECT &rrcSizing)
The SetResize function specifies how much each side of a control will move when the dialog is resized.
void | SetResize (UINT nID, HWND hWnd, const XTP_RESIZERECT &rrcSizing)
The SetResize function specifies how much each side of a control will move when the dialog is resized.
void | SetResize (UINT nID, HWND hWnd, const XTP_RESIZEPOINT &rpTopLeft, const XTP_RESIZEPOINT &rpBottomRight)
The SetResize function specifies how much each side of a control will move when the dialog is resized.
void | SetResize (UINT nID, const XTP_RESIZEPOINT &rpTopLeft, const XTP_RESIZEPOINT &rpBottomRight)
The SetResize function specifies how much each side of a control will move when the dialog is resized.
void | SetMinSize (CSize &sz)
This member function sets the minimum size explicitly.
void | SetMaxSize (CSize &sz)
This member function sets the maximum size.
BOOL | SavePlacement (LPCTSTR pszSection)
This member function saves the window placement to the registry.
BOOL | LoadPlacement (LPCTSTR pszSection)
This member function loads saved window placement information from the registry.
BOOL | AutoLoadPlacement (LPCTSTR pszSection)
This member function loads saved window placement information from the registry.

Public Attributes

CXTPCustomizeSheet * | m_pSheet
Parent property sheet.
CButton | m_btnReset
Reset button.
CButton | m_btnRename
Rename button.
CButton | m_btnDelete
Delete button.
CButton | m_btnNew
New button.
CXTPCustomizeToolbarsPageCheckListBox | m_checkList
Toolbars list box.
- Public Attributes inherited from CXTPPropertyPage
DWORD_PTR | m_dwData
Page specific 32-bit value.

Protected Attributes

BOOL | m_bAllowNewToolbars
TRUE to allow display the add new toolbar button, FALSE to hide it.
- Protected Attributes inherited from CXTPPropertyPage
CXTPPropertySheet * | m_pSheet
Parent CXTPPropertySheet object.
BOOL | m_bModified
TRUE to indicate that the property page settings have been modified.
- Protected Attributes inherited from CXTPResize
UINT | m_nFlagsXX
Flags passed from the constructor.
CWnd * | m_pWnd
The associative relation to the window to be resized.
CSize | m_szWindow
Last dialog size.
CSize | m_szInitWindow
Initial dialog size.
CSize | m_szMin
Smallest size allowed.
CSize | m_szMax
Largest size allowed.
CString | m_strSection
Section in registry where window placement information is saved.
CXTPSizeIcon | m_scSizeIcon
Size icon window.
CResizeItemArray | m_arrItems
Array of controls.

Additional Inherited Members

- Protected Types inherited from CXTPResize
typedef CArray< CXTPResizeItem *, CXTPResizeItem *& > | CResizeItemArray
Used by CXTPResize to maintain a list of children that are sizable.
- Protected Member Functions inherited from CXTPResize
void | SetResize (CWnd *pWnd, const CXTPResizeRect &rrcSizing, CRect rcWindow)
The SetResize function specifies how much each side of a control will move when the dialog is resized.
BOOL | RemoveResize (UINT nID)
This member function is called to remove the specified dialog item from the list of items to be resized.
void | RemoveAllControls ()
This member function is called to purge the list that contains the dialog items to be sized.
virtual void | Init ()
This member function is called from OnInitDialog or OnInitialUpdate to initialize the resize manager.
virtual void | Size ()
This member function is called from OnSize to move and resize the dialog items that are managed.
void | Reset ()
This member function is called when a property sheet in wizard mode has changed pages to alert the resize manager that the property sheet (common control) has moved the page back to its original size/position on the sheet.
void | Offset (CPoint ptOffset)
Called to offset dialog items by the amount specified by ptOffset.
void | UpdateControlRect (CWnd *pWnd)
Call this method to reset m_rrcWindow for an item.
void | GetMinMaxInfo (MINMAXINFO *pMMI)
This member function is called from OnGetMinMaxInfo to get the maximized position or dimensions or the minimum or maximum tracking size.
virtual void | AdjustResizeRect (CSize &rcWindow)
This method is called in the Size method to adjust a window rectangle to fit real client size.
BOOL | HasFlag (XTPResize eFlag)
This member function is called to determine if the specified flag has been set for the resize manager.
void | SetFlag (XTPResize eFlag)
This member function is called to set a specific flag for the resize manager.
virtual BOOL | Defer (HDWP &hdwp, CXTPResizeItem *pItem, int dx, int dy)
Called by CXTPResize to resize a child window.

Detailed Description

CXTPCustomizeToolbarsPage is a CPropertyPage derived class.

It represents the Toolbars page of the Customize dialog.

Member Enumeration Documentation

◆ anonymous enum

anonymous enum
Enumerator
IDD

Property page identifier.

Constructor & Destructor Documentation

◆ CXTPCustomizeToolbarsPage()

CXTPCustomizeToolbarsPage ( CXTPCustomizeSheet * pSheet = NULL )

Constructs a CXTPCustomizeToolbarsPage object.

Parameters
pSheet Points to a CXTPCustomizeSheet object that this page belongs to.

Member Function Documentation

◆ AllowNewToolbars()

AFX_INLINE void AllowNewToolbars ( BOOL bEnable )

Displays or hides the new toolbar button.

Parameters
bEnable TRUE to allow display the add new toolbar button, FALSE to hide it.
The documentation for this class was generated from the following file:
  • XTPCustomizePageToolbars.h


Toolkit Pro: CXTPDateEdit Class Reference

Public Member Functions | List of all members
CXTPDateEdit Class Reference

CXTPDateEdit is a CXTPMaskEdit derived class. More...

Inheritance diagram for CXTPDateEdit:
[legend]

Public Member Functions

CXTPDateEdit ()
Constructs a CXTPDateEdit object.
virtual void | SetDateTime (COleDateTime &dt)
This member function will set the time based on the text string passed in as 'strDate'.
virtual void | SetDateTime (LPCTSTR strDate)
This member function will set the time based on the text string passed in as 'strDate'.
virtual COleDateTime | GetDateTime ()
This member function will retrieve a COleDateTime object that represents the currently displayed date.
virtual CString | GetWindowDateTime ()
This member function will retrieve a CString object that represents the currently displayed date.
virtual COleDateTime | ReadOleDateTime (LPCTSTR lpszData)
This member function will read the date string passed in as 'lpszData', convert it to a COleDateTime object, and return this COleDateTime object.
virtual BOOL | ProcessMask (TCHAR &nChar, int nEndPos)
This member function is used internally to process the character passed in by 'nChar' whose index is specified by 'nEndPos'.
virtual void | FormatOleDateTime (CString &strData, COleDateTime dt)
This member function will read the date passed in as 'dt', and format the 'strData' string as DD/MM/YY.
- Public Member Functions inherited from CXTPMaskEdit
CXTPMaskEdit ()
Constructs a CXTPMaskEdit object.
virtual bool | Initialize (CWnd *pParentWnd)
Initializes the CXTPMaskEdit control.
- Public Member Functions inherited from CXTPEdit
CXTPEdit ()
Constructs a CXTPEdit object.
virtual | ~CXTPEdit ()
Destroys a CXTPEdit object, handles cleanup and deallocation.
BOOL | SetEditMask (LPCTSTR lpszMask, LPCTSTR lpszLiteral, LPCTSTR lpszDefault=NULL)
This member function will set the mask for the edit control.
void | SetPattern (LPCTSTR lpszPattern)
Call this member function to set the pattern for the edit mask.
virtual BOOL | CanPaste ()
Call this member function to determine if the Clipboard contains information that can be pasted into this edit view.
BOOL | HasSelection () const
Call this member function to determine if a selection has been made.
void | AdjustBuddyRect (CWnd *pBuddy, CRect &rcUpDown, int nAlignment)
Called by the framework to adjust the size of the area to draw the buddy control borders on.
void | DrawBuddyBorders (CWnd *pBuddy, CDC *pDC, CRect rc, int nAlignment)
Called by the framework to draw the borders for the associated buddy window.
virtual void | RefreshMetrics ()
This member is called to update the color, text and other visual elements of the control.
virtual void | SetTheme (XTPControlTheme nTheme)
Call this member to switch the visual theme of the control.
XTPControlTheme GetThemeID ()
Call this member function to get the style for the theme.
CXTPEditTheme * GetTheme ()
Call this member to retrieve a pointer to the current theme.
BOOL | GetFlatStyle () const
Gets the flat style appearance of the button control.
void | SetFlatStyle (BOOL bFlatStyle=TRUE)
Sets the flat style appearance of the button control.
BOOL | GetUseVisualStyle () const
Determines if the control is drawn using visual styles/SkinFramework, if supported.
void | SetUseVisualStyle (BOOL bUseVisualStyle=TRUE)
Enables Windows XP visual styles for the control.
BOOL | IsPatternValid ()
Called by the framework to determine if the pattern set using SetPattern() is valid.
void | ShowThemedBorder (BOOL bShowThemedBorder)
Call this member function to enable/disable theme border display.
BOOL | IsHighlighted () const
Call this member function to determine if the edit state is highlighted, meaning that the mouse cursor is currently hovering over the control.
BOOL | IsFocused () const
Call this member function to determine if the edit-box has input focus.
BOOL | IsFlatStyle () const
Gets the flat style appearance of the edit control.
BOOL | ShowBorder () const
Call this member to determine if non-client borders are displayed.
- Public Member Functions inherited from CXTPMaskEditT< CEdit >
CXTPMaskEditT ()
Constructs a CXTPMaskEditT object.
void | SetUseMask (BOOL bUseMask)
Call this member function to enable or disable the mask for the mask edit control.
BOOL | CanUseMask () const
This member function is called to determine if the mask for the edit control can be used.
void | SetOverType (BOOL bOverType)
This member function is called to enable or disable type over, also known as insert mode.
BOOL | CanOverType () const
This member function is called to determine if type over has been enabled.
BOOL | PosInRange (int iPos) const
This member function is called to determine if the index specified by 'iPos' is a valid index for the currently displayed edit text.
TCHAR | GetPromptChar () const
This member function retrieves the character that is currently used as the mask prompt.
CString | GetPromptString (int nLength) const
This helper member function retrieves the string contains nLength prompt characters.
void | SetPromptChar (TCHAR ch, BOOL bAutoReplace=TRUE)
This member function is called to set the prompt character that is displayed to the user that indicates the field can be edited.
afx_msg BOOL | MaskCut ()
This member function is called to perform a cut operation using the currently selected text.
afx_msg BOOL | MaskCopy ()
This member function is called to perform a copy operation using the currently selected text.
void | MaskReplaceSel (LPCTSTR lpszNewText)
This member function is called to perform a replace operation using the currently selected text.
afx_msg BOOL | MaskPaste ()
This member function is called to perform a paste operation using the current clipboard text.
void | MaskDeleteSel ()
This member function is called to delete the selection.
afx_msg BOOL | MaskClear ()
This member function is called to clear the current text selection.
afx_msg BOOL | MaskUndo ()
This member function is called to undo the previous action.
afx_msg void | MaskSelectAll ()
This member function is called to select all text in the mask edit control.
BOOL | IsModified () const
This member function is called to determine if the text has been modified.
void | SetMaskedText (LPCTSTR lpszMaskedText, int iPos=0, BOOL bUpdateWindow=TRUE)
This method called to set masked text for the edit control.
TCHAR | ConvertUnicodeAlpha (TCHAR nChar, BOOL bUpperCase) const
Converts character to Upper/Lower case.
virtual BOOL | CheckChar (TCHAR &nChar, int nPos)
This member function is used internally to validate the character indicated by 'nChar'.
virtual BOOL | PreTranslateMessage (MSG *pMsg)
Used by class CWinApp to translate window messages before they are dispatched to theTranslateMessage andDispatchMessage Windows functions.
void | DeleteCharAt (int iPos)
Deletes character in specified position.
void | InsertCharAt (int iPos, TCHAR nChar)
Inserts character to specified position.
BOOL | CopyToClipboard (const CString &strText)
Copies text to system clipboard.
CString | GetMaskedText (int nStartPos=0, int nEndPos=-1) const
Retrieves masked text of the control.

Additional Inherited Members

- Protected Member Functions inherited from CXTPEdit
HBRUSH | GetClientBrush (CDC *pDC)
Retrieves a handle to the client background brush.
void | RedrawEdit ()
Called by the framework to redraw the edit control.
void | RedrawFocusedFrame ()
Called by the framework to redraw the focus rectangle for the edit control.
- Protected Member Functions inherited from CXTPMaskEditT< CEdit >
virtual BOOL | OnCommand (WPARAM wParam, LPARAM lParam)
The framework calls this member function when the user selects an item from a menu.
- Protected Attributes inherited from CXTPEdit
CXTPEditTheme * | m_pTheme
Pointer to the current edit theme.
BOOL | m_bPreSubclassInit
TRUE if the control has been subclassed.
BOOL | m_bShowBorder
TRUE if non-client borders are displayed.
BOOL | m_bHighlighted
TRUE when the mouse is hovering over the control.
BOOL | m_bFocused
TRUE when the control has input focus.
CXTPRegExp * | m_pRegExp
Pointer to the CXTPRegExp object for this control.
- Protected Attributes inherited from CXTPMaskEditT< CEdit >
int | m_nStartChar
Current position of the first character in the current selection.
int | m_nEndChar
Current position of the first non-selected character past the end of the current selection.
BOOL | m_bUseMask
TRUE to use the edit mask.
BOOL | m_bOverType
TRUE to over type the text, set with VK_INSERT key press.
BOOL | m_bRedo
TRUE to redo, or FALSE to undo.
BOOL | m_bModified
TRUE if mask edit has been modified.
TCHAR | m_chPrompt
Prompt character used to identify the text entry.
CString | m_strMask
Buffer that holds the actual edit mask value.
CString | m_strDefault
Contains the edit controls default display text.
CString | m_strUndoBuffer
Holds the contents of the undo buffer.
CString | m_strRedoBuffer
Holds the contents of the redo buffer.
CString | m_strWindowText
Buffer that holds the actual edit text.
CString | m_strLiteral
Literal format that restricts where the user can enter text.
BOOL | m_bUpdateUndo
TRUE to update undo.

Detailed Description

CXTPDateEdit is a CXTPMaskEdit derived class.

It is specifically geared toward editing date fields.

Member Function Documentation

◆ FormatOleDateTime()

virtual void FormatOleDateTime | ( | CString & | strData,
 |  | COleDateTime | dt )
 virtual

This member function will read the date passed in as 'dt', and format the 'strData' string as DD/MM/YY.

Parameters
strData | String reference that is filled with the date.
dt | COleDateTime object that represents the date to format.

Reimplemented in CXTPTimeEdit.

◆ GetDateTime()

virtual COleDateTime GetDateTime ( )
virtual

This member function will retrieve a COleDateTime object that represents the currently displayed date.

Returns
A COleDateTime object representing the currently displayed date.

◆ GetWindowDateTime()

virtual CString GetWindowDateTime ( )
virtual

This member function will retrieve a CString object that represents the currently displayed date.

Returns
A CString object representing the currently displayed date.

◆ ProcessMask()

virtual BOOL ProcessMask | ( | TCHAR & | nChar,
 |  | int | nEndPos )
 virtual

This member function is used internally to process the character passed in by 'nChar' whose index is specified by 'nEndPos'.

Parameters
nChar | Contains the character code value of the key.
nEndPos | Index of the character in the display string.
Returns
true if successful, otherwise false.

Reimplemented from CXTPMaskEditT< CEdit >.

Reimplemented in CXTPTimeEdit.

◆ ReadOleDateTime()

virtual COleDateTime ReadOleDateTime ( LPCTSTR lpszData )
virtual

This member function will read the date string passed in as 'lpszData', convert it to a COleDateTime object, and return this COleDateTime object.

Parameters
lpszData A NULL-terminated string that represents the date to convert.
Returns
A COleDateTime object that represents the converted date string.

◆ SetDateTime() [1/2]

virtual void SetDateTime ( COleDateTime & dt )
virtual

This member function will set the time based on the text string passed in as 'strDate'.

Parameters
dt A reference to a COleDateTime object that represents the date to display.

◆ SetDateTime() [2/2]

virtual void SetDateTime ( LPCTSTR strDate )
virtual

This member function will set the time based on the text string passed in as 'strDate'.

Parameters
strDate A NULL-terminated string that represents the date to display.
The documentation for this class was generated from the following file:
  • XTPMaskEdit.h


Toolkit Pro: CXTPDateLabelPart Class Reference

Public Member Functions | Public Attributes | List of all members
CXTPDateLabelPart Class Reference

This class implements Date Label part of the ScrollDateBar. More...

Inheritance diagram for CXTPDateLabelPart:
[legend]

Public Member Functions

virtual void | RefreshMetrics ()
Performs refreshing of graphical related parameters from system settings.
virtual void | Draw (CDC *pDC)
This member function is used to draw the part content utilizing the specified device context.
- Public Member Functions inherited from CXTPCalendarCaptionBarThemePart
CXTPCalendarCaptionBarThemePart (CXTPCalendarCaptionBarTheme *pTheme, int nPartID)
Default object constructor.
virtual | ~CXTPCalendarCaptionBarThemePart ()
Default object destructor.
virtual void | AdjustLayout (CDC *pDC, const CRect &rcRect)
This member function is used to adjust the object's layout depending on the provided bounding rectangle.
virtual void | Redraw (BOOL bUpdateNow=FALSE)
This member function initiates the CalendarCaptionBar control's redrawing.
virtual BOOL | HitTest (const CPoint &pt) const
This member function is used to determine is the specified point over visible object rectangle.
virtual CXTPCalendarCaptionBarTheme * | GetTheme () const
This member function is used to obtain pointer to parent CXTPCalendarCaptionBarTheme object.
virtual XTPCalendarTheme | GetPaintTheme () const
This member function is used to obtain current paint theme.
virtual int | GetPartID () const
This member function is used to obtain an object identifier.
virtual CRect | GetRect () const
This member function is used to obtain an object rectangle.
virtual CString | GetText () const
This member function is used to obtain an object text.
virtual void | SetText (LPCTSTR pcszText)
This member function is used to set object text.
virtual BOOL | IsVisible () const
This member function is used to get is part object visible.
virtual void | SetVisible (BOOL bVisible)
This member function is used to set visible object's state.
virtual int | GetCheck () const
This member function is used to get checked state.
virtual void | SetCheck (int nCheck)
This member function is used to set checked state.
int | GetState () const
This member function is used to get object state (flags from CXTPCalendarCaptionBarThemePart::EStates enum).
virtual void | SetState (int nState)
This member function is used to set object state as set of flags from CXTPCalendarCaptionBarThemePart::EStates enum.
virtual COLORREF | GetTextColor ()
This member function is used to get object text color.
CXTPCalendarCaptionBarPaintManager * | GetPaintManager () const
Gets the paint manager.
virtual void | OnMouseMove (UINT nFlags, CPoint point)
This member function is used to processes mouse movement events.
virtual BOOL | OnLButtonDown (UINT nFlags, CPoint point)
This member function is used to process left mouse button down events.
virtual BOOL | OnLButtonUp (UINT nFlags, CPoint point)
This member function is used to process left mouse button up events.
- Public Member Functions inherited from CXTPCalendarWMHandler
CXTPCalendarWMHandler ()
Default object constructor.
virtual int | GetChildHandlersCount () const
This member function is used to obtain the number of CXTPCalendarWMHandler elements in the descendant handlers collection.
virtual CXTPCalendarWMHandler * | GetChildHandlerAt (int nIndex) const
Call this method to get a handler object at the specified numeric index.
virtual BOOL | OnLButtonDblClk (UINT nFlags, CPoint point)
This member function is used to process left mouse button double click events.
virtual void | OnChar (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process keyboard events.
virtual void | OnKeyDown (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process key-down keyboard events.
virtual void | OnKeyUp (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process key-up keyboard events.
virtual BOOL | OnSysKeyDown (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process key-up keyboard events.
virtual BOOL | OnTimer (UINT_PTR uTimerID)
The framework calls this member function after each interval specified in the SetTimer member function.
virtual BOOL | OnWndMsg (UINT message, WPARAM wParam, LPARAM lParam, LRESULT *pResult)
This method is called by framework after default message processing.
virtual void | OnPostAdjustLayout ()
This member function is used to perform additional adjustments in some kinds of views.
virtual void | OnBeforeDestroy ()
This member function is called by the framework before destroying the view.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Public Attributes

CXTPCalendarThemeFontValue | m_fntTextFont
Store the text font.
- Public Attributes inherited from CXTPCalendarCaptionBarThemePart
CXTPPaintManagerColor | m_clrTextColor
Store the object's text color.
CRect | m_rcRect
Store a Part rectangle.
int | m_nState
Store a Part state.
CString | m_strText
Store a Part text.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Attributes inherited from CXTPCalendarCaptionBarThemePart
CXTPCalendarCaptionBarTheme * | m_pTheme
Store pointer to a parent theme object.
int | m_nPartID
Store a Part ID.
BOOL | m_bVisible
Store a Part visible state.

Detailed Description

This class implements Date Label part of the ScrollDateBar.

See also
CXTPCalendarCaptionBarThemePart

Member Function Documentation

◆ Draw()

virtual void Draw ( CDC * pDC )
virtual

This member function is used to draw the part content utilizing the specified device context.

Parameters
pDC Pointer to a valid device context.

Reimplemented from CXTPCalendarCaptionBarThemePart.

◆ RefreshMetrics()

virtual void RefreshMetrics ( )
virtual

Performs refreshing of graphical related parameters from system settings.

Base implementation do nothing.

Reimplemented from CXTPCalendarCaptionBarThemePart.

The documentation for this class was generated from the following file:
  • XTPCalendarCaptionBarThemePart.h


Toolkit Pro: CXTPDatePickerButton Class Reference

Public Member Functions | Public Attributes | Protected Attributes | List of all members
CXTPDatePickerButton Class Reference

This class represents a DatePicker button. More...

Public Member Functions

CXTPDatePickerButton ()
Default button constructor.
virtual | ~CXTPDatePickerButton ()
Destroys a CXTPDatePickerButton object, handles cleanup and deallocation.
virtual CString | GetCaption () const
Get a button caption.
virtual void | SetCaption (LPCTSTR pcszCaption)
Set a button caption.

Public Attributes

int | m_nID
This member variable is used to specify the identifier of the button.
CRect | m_rcButton
This member variable is used to specify the bounding rectangle coordinates of a button.
BOOL | m_bVisible
This member variable is used to indicate if a button is visible.
BOOL | m_bPressed
This member variable is used to indicate if a button is pressed.
BOOL | m_bHighlight
This member variable is used to indicate if a button is highlighted.

Protected Attributes

CString m_strCaption
This member variable is used to specify the caption of the button.

Detailed Description

This class represents a DatePicker button.

Returns
CXTPDatePickerButton provides storage for all parameters needed to display and handle a button.

Constructor & Destructor Documentation

◆ CXTPDatePickerButton()

CXTPDatePickerButton ( )

Default button constructor.

Default button constructor handles all necessary initialization.

Member Function Documentation

◆ GetCaption()

virtual CString GetCaption ( ) const
virtual

Get a button caption.

Load from resources string using ID stored in m_nID member or value which was set by SetCaption() call.

Returns
Returns a button caption.
See also
m_nID
SetCaption

◆ SetCaption()

virtual void SetCaption ( LPCTSTR pcszCaption )
virtual

Set a button caption.

Parameters
pcszCaption A caption string.

If pcszCaption is empty string - GetCaption will the m_nID to load caption string from resources.

See also
GetCaption
m_nID

Member Data Documentation

◆ m_nID

int m_nID

This member variable is used to specify the identifier of the button.

Also it used as resource ID for a caption string.

The documentation for this class was generated from the following file:
  • XTPDatePickerControl.h


Toolkit Pro: CXTPDatePickerButtons Class Reference

Public Member Functions | List of all members
CXTPDatePickerButtons Class Reference

Class CXTPDatePickerButtons represents a collection of buttons. More...

Public Member Functions

int | GetVisibleButtonCount () const
Call this member function to retrieve the current count of visible buttons.
CXTPDatePickerButton * | Find (int nID) const
This member function finds buttons by their ID property.
CXTPDatePickerButton * | HitTest (CPoint point) const
This member function determines which button is affected by the mouse pointer.

Detailed Description

Class CXTPDatePickerButtons represents a collection of buttons.

CXTPDatePickerButtons inherits most of the behavior of the standard MFC CArray. The DatePicker control can display and handle any number of buttons. CXTPDatePickerButtons provides the basic functionality to handle the collection.

Create a CXTPDatePickerButtons object by calling the default constructor without parameters. Furthermore, add buttons to collection using standard CArray member functions.

See also
CArray

Member Function Documentation

◆ Find()

CXTPDatePickerButton * Find ( int nID ) const

This member function finds buttons by their ID property.

Parameters
nID An int that contains the ID to search for.

Walks through the collection and looks for the button with the provided ID.

Returns
A pointer to the CXTPDatePickerButton structure. NULL if no matching button ID is found.

◆ GetVisibleButtonCount()

int GetVisibleButtonCount ( ) const

Call this member function to retrieve the current count of visible buttons.

Returns
Integer value that contains the current number of visible buttons that are in the collection.

◆ HitTest()

CXTPDatePickerButton * HitTest ( CPoint point ) const

This member function determines which button is affected by the mouse pointer.

Parameters
point Point to test.

Call this member function to test a mouse event occurring on one of the buttons rectangle areas. If no buttons are found then NULL is returned.

Returns
The DatePicker button at the specified position, if any, otherwise NULL.
The documentation for this class was generated from the following file:
  • XTPDatePickerControl.h


Toolkit Pro: CXTPDatePickerControl Class Reference

Public Types | Public Member Functions | Public Attributes | Protected Member Functions | Static Protected Member Functions | Protected Attributes | List of all members
CXTPDatePickerControl Class Reference

Class CXTPDatePickerControl encapsulates the functionality of a date and time picker control. More...

Public Types

enum DatePickerMouseMode {
mouseNothing , mouseScrollingLeft , mouseScrollingRight , mouseSelecting ,
mouseDeselecting , mouseTrackingHeaderList
}
Enumeration of operational mouse modes. More...

Public Member Functions

CXTPDatePickerControl ()
Default constructor is used to construct a CXTPDatePickerControl object.
virtual | ~CXTPDatePickerControl ()
Destroys a CXTPDatePickerControl object, handles cleanup and deallocation.
virtual BOOL | Create (DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID, CCreateContext *pContext=NULL)
This member function is used to create the Date Picker Control Window.
virtual BOOL | GoModal (const RECT &rect, CWnd *pParentWnd=NULL)
This member function implements pop-up window behavior for the Date Picker control.
BOOL | IsModal () const
Is the control runs in modal mode.
CXTPDatePickerPaintManager * | GetPaintManager () const
This member function returns a pointer to the associated paint manager.
virtual void | RedrawControl ()
This member function redraws the control windows.
void | SetTheme (CXTPDatePickerPaintManager *pPaintManager=NULL)
This member function sets the new control drawing theme.
BOOL | IsAutoSize () const
This function is called to determine if AutoSize mode is set.
void | SetAutoSize (BOOL bAuto=TRUE)
This function sets the AutoSize mode.
virtual void | SetCallbackDayMetrics (PFNITEMMETRICS pFunc, void *pParam=NULL)
This member function sets the user-defined day metrics callback function.
PFNITEMMETRICS | GetCallbackDayMetrics () const
This member function returns the day metrics callback function.
virtual void | GetDayMetrics (COleDateTime &dtDay, XTP_DAYITEM_METRICS *pDayMetics)
This member function returns the day item drawing metrics.
void | SetFirstDayOfWeek (int nDay)
This member function sets the day of the week that is displayed in the leftmost column of the calendar.
int | GetFirstDayOfWeek () const
This member function obtains the first day of the week that is displayed in the leftmost column of the calendar.
void | SetFirstWeekOfYearDays (int nDays)
This member function sets the required number of this year days in the first week of the year.
int | GetFirstWeekOfYearDays () const
This member function obtains the current required number of year days in the first week of the year.
virtual void | SetButtonsVisible (BOOL bShowToday, BOOL bShowNone)
This function sets visibility for the "Today" and "None" buttons.
virtual BOOL | IsTodayButtonVisible ()
This member function is used to obtain the value of the visibility flag for the "Today" button.
virtual BOOL | IsNoneButtonVisible ()
This function returns the boolean visibility flag of the "None" button.
void | SetHighlightToday (BOOL bValue)
Call this member function to enable or disable highlighting of the "Today" cell.
BOOL | GetHighlightToday () const
Call this member function to determine whether the "Today" cell highlighting is enabled or disabled.
virtual void | SetLayoutRTL (BOOL bRightToLeft)
Call this member to set right-to-left mode.
virtual void | SetShowWeekNumbers (BOOL bValue)
Call this member function to show or hide the week numbers.
BOOL | GetShowWeekNumbers () const
Call this member function to determine if the week numbers are visible.
void | SetShowNonMonthDays (BOOL bShow)
Call this member function to show or hide non-month days.
BOOL | GetShowNonMonthDays () const
Call this member function to determine if the non-month days are visible.
void | SetBorderStyle (XTPDatePickerBorderStyle borderStyle)
Call this member function to set borders style around the control.
XTPDatePickerBorderStyle | GetBorderStyle () const
Call this member function to determine if the border is visible.
virtual void | SetGridSize (int nRows, int nCols, BOOL bRestrictMode=FALSE)
Call this member function to set the number of months in the control's grid.
int | GetRows () const
Call this member function to obtain the number of rows in the months grid.
int | GetCols () const
Call this member function to obtain the number of columns in the months grid.
virtual CXTPDatePickerItemMonth * | HitTest (CPoint ptMouse) const
This member function finds the month item at the provided point.
virtual DWORD | HitTest (PMCHITTESTINFO pMCHitTest) const
This member function finds the month item at the provided point.
virtual void | ScrollLeft (int nMonthCount=1)
This member function scrolls the control's months grid to the left by the specified number of months.
virtual void | ScrollRight (int nMonthCount=1)
This member function scrolls the control's months grid to the right by the specified amount of months.
virtual LRESULT | SendMessageToParent (int nMessage, NMHDR *pNMHDR=NULL)
Call this member function to send notifications to the parent window.
virtual BOOL | IsSelected (const COleDateTime &dtDay) const
This function checks a specific date to determine if it is contained in the control's selection.
virtual BOOL | IsFocused (const COleDateTime &dtDay) const
This function checks a specific date to determine if it is focused.
virtual void | ClearFocus ()
This function clear focused attribute if it is set.
virtual void | Select (const COleDateTime &dtDay)
Call this member function to select a specific day.
virtual void | Deselect (const COleDateTime &dtDay)
Call this member function to de-select the specified day.
virtual void | EnsureVisible (const COleDateTime &dtDate)
Call this member function to ensure that a specified COleDateTime item is visible.
virtual void | EnsureVisibleSelection ()
Call this member function to ensure that the selection range is visible.
virtual void | EnsureVisibleFocus ()
Call this member function to ensure that the focused item is visible.
void | SetMonthName (int nMonth, LPCTSTR strMonthName)
This member function sets the user-defined month name.
CString | GetMonthName (int nMonth) const
This member function returns the month name of the given integer value.
void | EnableSysYearMonthFormat (BOOL nEnable)
This member function sets the system-defined format of year_month string.
void | SetDayOfWeekName (int nDayOfWeek, LPCTSTR strDayOfWeekName)
This member function sets the user-defined DayOfWeek name.
CString | GetDayOfWeekName (int nDayOfWeek) const
This member function returns the DayOfWeek name associated with the integer value of nDayOfWeek.
virtual BOOL | GetSelRange (COleDateTime &refMinRange, COleDateTime &refMaxRange) const
This member function retrieves date information representing the upper and lower limits of the date range currently selected by the user.
virtual BOOL | SetSelRange (const COleDateTime &refMinRange, const COleDateTime &refMaxRange)
This member function sets the selection for a date picker control to a given date range.
virtual BOOL | GetMinReqRect (RECT *pRect) const
This member function retrieves the minimum size required to show a full month in the date picker control or a specified number of full month items in a date picker control.
virtual BOOL | GetMinReqRect (RECT *pRect, int nRows, int nCols) const
This member function retrieves the minimum size required to show a full month in the date picker control or a specified number of full month items in a date picker control.
virtual BOOL | SizeMinReq (BOOL bRepaint=TRUE)
This member function adjusts the date picker control to the minimum size required to display one month.
int | GetMonthDelta () const
This member function retrieves the scroll rate for the date picker control.
void | SetMonthDelta (int iDelta)
This member function sets the scroll rate for the date picker control.
virtual BOOL | GetCurSel (COleDateTime &refDateTime) const
This member function retrieves the system time as indicated by the currently-selected date.
virtual BOOL | SetCurSel (const COleDateTime &refDateTime)
This member function sets the currently selected date for the date picker control.
int | GetMaxSelCount () const
This member function retrieves the current maximum number of days that can be selected in a date picker control.
void | SetMaxSelCount (int nMax=XTP_SELECTION_INFINITE)
This member function sets the maximum number of days that can be selected in a date picker control.
void | AllowNoncontinuousSelection (BOOL bAllow=TRUE)
This member function sets the flag which shows whether control allows non-continuous days selection or not.
BOOL | IsAllowNoncontinuousSelection () const
This member function returns the flag which shows whether control allows non-continuous days selection or not.
BOOL | IsMultiSelectionMode () const
Determines if the multiple selection mode is enabled.
void | SetMultiSelectionMode (BOOL bMultiSelectionMode)
Enables/disables the multiple selection mode for the control.
virtual BOOL | GetToday (COleDateTime &refDateTime) const
This member function retrieves the date information for the date specified as "Today" for the date picker control.
virtual void | SetToday (const COleDateTime &refDateTime)
This member function sets the calendar control to the current day.
virtual DWORD | GetRange (COleDateTime *pMinRange, COleDateTime *pMaxRange) const
This member function retrieves the current minimum and maximum dates set in a date picker control.
virtual BOOL | SetRange (const COleDateTime *pMinRange, const COleDateTime *pMaxRange)
This member function sets the minimum and maximum allowable dates for a date picker control.
virtual int | GetMonthRange (COleDateTime &refMinRange, COleDateTime &refMaxRange, DWORD dwFlags) const
This member function retrieves date information representing the high and low limits of a date picker control's display.
virtual BOOL | GetVisibleRange (COleDateTime &refFirstVisibleDay, COleDateTime &refLastVisibleDay) const
This member function retrieves the first and last displayed days dates.
virtual void | SetDesiredVisibleAndFullRange (COleDateTime FirstVisibleDay, COleDateTime LastVisibleDay, COleDateTime FirstDay, COleDateTime LastDay)
This member function allows scrolling between FirstDay and LastDay and tries to show the initial visible range between FirstVisibleDay and LastVisibleDay.
int | GetButtonCount () const
This member function returns the number of CXTPDatePickerButton items shown on the control.
CXTPDatePickerButton * | GetButton (int nIndex) const
This member function returns a pointer to the CXTPDatePickerButton object using its numeric index.
virtual void | AddButton (UINT nID)
This member function adds one more buttons to the control.
CXTPNotifyConnection * | GetConnection () const
This member function obtains a notification connection object pointer.
CXTPDatePickerDaysCollection * | GetSelectedDays () const
Returns a collection of the days selected in the date picker.
virtual void | AdjustLayout ()
This member function adjusts the layout of all sub-items depending on the current window client size.
XTPCalendarTheme | GetPaintTheme () const
This member function is used to obtain current paint theme.
void | SetPaintTheme (XTPCalendarTheme ePaintTheme)
This member function is used to set current paint theme.
BOOL | RegisterWindowClass (HINSTANCE hInstance=NULL)
This member function registers the window class if it has not already been registered.

Public Attributes

BOOL | m_bDeleteOnFinalRelease
Delete self OnFinalRelease() call.
BOOL | m_bYearsTriangle
Use extra button for 1 year jump.
BOOL | m_bRestrictMode
Flag to keep desired month's numbers without scaling.
CString | m_strYearMonthFormat
The year month format.

Protected Member Functions

virtual void | SendNotification (XTP_NOTIFY_CODE EventCode, WPARAM wParam=0, LPARAM lParam=0)
This member function sends a notification to all control's event subscribers.
virtual void | InitNames ()
This member function initializes the month and day names depending on localization.
virtual void | Populate ()
This member function performs control population, creating the view from the data.
virtual void | _RedrawControl (BOOL bUpdateNow)
This member function redraws the control windows.
virtual void | ClearMonths ()
This member function is used to cleanup the months array.
virtual void | OnDraw (CDC *pDC)
This member function is used to perform all drawing logic.
virtual void | DrawButtons (CDC *pDC)
Call this member function to draw the calendar's buttons.
virtual void | AdjustLayout (CRect rcClient)
This member function adjusts the layout of all sub-items depending on the current window client size.
virtual CSize | CalcButtonSize () const
This member function calculates the size of the button.
virtual void | SetButtonRect ()
Call this member function to calculate and set the button's bounding rectangle.
virtual void | CalcButtonBandRect ()
Call this member function to calculate and set the button's band rectangle.
virtual void | ProcessButtons (CPoint point)
This member function is used to implement button behavior.
virtual void | ShowListHeader (CRect rcHeader, COleDateTime dtMonth)
This member function shows a CXTPDatePickerList control at the coordinates specified by rcHeader.
virtual CSize | SetGridDimentions (CRect rcGrid)
This member function sets new dimensions for the month grid.
virtual void | CreateMonthArray ()
This member function creates the internal month array.
virtual void | PreSubclassWindow ()
This member function is called by the framework to allow other necessary sub-classing to occur before the window is sub-classed.
virtual void | OnButtonClick (UINT nID)
This member function is used to process the control's button clicks.

Static Protected Member Functions

static BOOL AFX_CDECL ShiftDate (COleDateTime &refDate, int nMonthCount)
This function shifts the specified date for the specified number of months.

Protected Attributes

DatePickerMouseMode | m_mouseMode
This member variable is used to specify the current Mouse operating mode.
int | m_nLockUpdateCount
This member variable is used as a counter that is used to count the update locks.
int | m_nTimerID
This member variable is used to specify the control timer ID.
CRect | m_rcControl
This data member is used to store the control drawing coordinates.
CXTPDatePickerPaintManager * | m_pPaintManager
This member variable is a pointer to the paint manager.
BOOL | m_bAutoSize
This member variable is used as the AutoSize flag.
BOOL | m_bIsModal
This member variable is used to specify if the control is used as a pop-up window.
BOOL | m_bChanged
This member variable is used to determine if the control requires redrawing.
CBitmap | m_bmpCache
This member variable is a cached window bitmap.
int | m_nRows
This member variable is used to specify the number of rows in the column month's grid.
int | m_nColumns
This member variable is used to specify the number of columns in the column month's grid.
int | m_nDesiredRows
The desired rows.
int | m_nDesiredColumns
The desired columns.
CXTPNotifyConnection * | m_pConnection
This member variable is a connection object that is used to send notifications.
COleDateTime | m_dtMinRange
This member variable specifies the minimum allowable date for a date picker control.
COleDateTime | m_dtMaxRange
This member variable specifies the maximum allowable date for a date picker control.
COleDateTime | m_dtToday
This member variable is used to specify the "Today" date for a date picker control.
COleDateTime | m_dtFirstMonth
This member variable is used to specify the first month in the grid.
int | m_nFirstDayOfWeek
This member variable is used to specify the first day of the week to display (1-Sunday, 2-Monday ... etc).
int | m_nFirstWeekOfYearDays
This member variable is used to specify the number of days of the new year in the first week of this year.
PFNITEMMETRICS | m_pfnCallback
This member variable is a pointer to the user's IsSpecialDay function.
void * | m_pCallbackParam
This member variable is a pointer to the user's additional parameter for the callback function.
CArray< CXTPDatePickerItemMonth *, CXTPDatePickerItemMonth * > | m_arrMonths
This member variable is an internal storage for the month items.
CXTPDatePickerDaysCollection * | m_pSelectedDays
This member variable is a collection of selected days.
BOOL | m_bHighlightToday
This member variable is used as a flag to determine if the "Today" date is highlighted.
BOOL | m_bShowWeekNumbers
This member variable is a flag that determines if the "week numbers" are displayed.
BOOL | m_bShowNonMonthDays
This member variable is a flag that determines if the "non-month days" are displayed.
XTPDatePickerBorderStyle | m_borderStyle
This member variable is a flag that determines if the control displays a 3D border.
int | m_nMaxSelectionDays
This member variable is used to specify the maximum number of selected days.
int | m_nMonthDelta
This member variable is used to specify the number of months set as the control's scroll rate.
BOOL | m_bLimitMonthDaysSelection
This member variable is a flag that determines to select if the "non-month days".
COleDateTime | m_dtFirstClicked
This member variable is used to specify the day that was clicked before starting the mouse selection.
COleDateTime | m_dtLastClicked
This member variable is used to specify the day that was clicked last in the mouse selection.
BOOL | m_bSelectWeek
TRUE when user is started selecting the whole week.
COleDateTime | m_dtFocused
This member variable is used to specify the focused day.
COleDateTime | m_dtFSelBase
This member variable is used to specify start day of the continuous selection.
CXTPDatePickerList * | m_pListControl
This member variable is used to specify the "header month list" pop-up control.
CString * | m_arMonthNames
This member variable contains the localized month names values.
CString * | m_arDayOfWeekNames
This member variable contains the day abbreviation for drawing.
CRect | m_rcGrid
Months grid rect.
CXTPDatePickerButtons | m_arrButtons
This member variable is an array of control buttons.
BOOL | m_bAllowNoncontinuousSelection
TRUE to allow Noncontinuous selection.
BOOL | m_bMultiSelectionMode
TRUE if multiselection mode enabled (i.e.
CXTPDatePickerButton * | m_pButtonCaptured
Pointer to a date picker button.
BOOL | m_bRightToLeft
TRUE to display calendar components in Right-To-Left (RTL) format.

Detailed Description

Class CXTPDatePickerControl encapsulates the functionality of a date and time picker control.

A CXTPDatePickerControl object implements a calendar-like user interface. This provides the user with a very intuitive and recognizable method of entering or selecting a date. The control also provides the application with the means to obtain and set the date information in the control using existing data types. By default, the date picker control displays the current day and month. However, the user is able to scroll to the previous and next months and select a specific month and/or year. The user can select a date or a range of dates. Also, the user can change the display by:

  • Scrolling backward and forward, from month to month.
  • Clicking the Today text to select the current day.
  • Clicking the None text to remove the selection.
  • Picking a month or a year from a pop-up menu.

The date picker control is customize by applying a variety of additional settings. Look at the control's class members list to see available customization options.

The date picker control can display more than one month, and it can indicate special days (such as holidays) by modifying the date's style. Furthermore, CXTPDatePickerControl contains methods similar to the MFC CMonthCalCtrl. Use the methods in the same way as the MFC CMonthCalCtrl.

See also
CMonthCalCtrl

Member Enumeration Documentation

◆ DatePickerMouseMode

enum DatePickerMouseMode

Enumeration of operational mouse modes.

Returns
DatePickerControl handles several Mouse states. This enumeration helps to clearly identify each of these states.
Enumerator
mouseNothing | No mouse activity by the user.
mouseScrollingLeft | User pressed left scroll triangle and is holding the button.
mouseScrollingRight | User pressed right scroll triangle and is holding the button.
mouseSelecting | User pressed left mouse down on unselected day item and is now selecting a range of day items.
mouseDeselecting | User pressed left mouse down on selected day item and is now de-selecting a range of day items.
mouseTrackingHeaderList | User is tracking pop-up month list window.

Constructor & Destructor Documentation

◆ CXTPDatePickerControl()

CXTPDatePickerControl ( )

Default constructor is used to construct a CXTPDatePickerControl object.

Construct a CXTPDatePickerControl object in two steps. First, call the constructor CXTPDatePickerControl and then call the Create method, which initializes the window.

Example:

// Declare a local CXTPDatePickerControl object.
CXTPDatePickerControl myDatePicker;

// Declare a dynamic CXTPDatePickerControl object.
CXTPDatePickerControl* pMyDatePicker = new CXTPDatePickerControl();

// Create a window
if (!myDatePicker.Create(WS_CHILD | WS_TABSTOP | WS_VISIBLE, CRect(0, 0, 200, 200), this,
ID_DATEPICKER_CONTROL))
{
   TRACE(_T("Failed to create the date picker window\\n"));
}
See also
Create

Member Function Documentation

◆ _RedrawControl()

virtual void _RedrawControl ( BOOL bUpdateNow )
protectedvirtual

This member function redraws the control windows.

Parameters
bUpdateNow If TRUE then CWnd::UpdateWindow() will be called, otherwise only CWnd::Invalidate() will be called.

Call this member function to redraw all control windows according to the stored parameter values.

See also
RedrawControl

◆ AddButton()

virtual void AddButton ( UINT nID )
virtual

This member function adds one more buttons to the control.

Parameters
nID ID of the string resource item. This is the caption of the new button.

Call this member function to add one more CXTPDatePickerButton objects to the control's collection.

See also
GetButton
GetButtonCount

◆ AdjustLayout() [1/2]

AFX_INLINE void AdjustLayout ( )
virtual

This member function adjusts the layout of all sub-items depending on the current window client size.

AdjustLayout depends on the AutoSize flag (changing control size or item fonts correspondingly).

See also
AdjustLayout
IsAutoSize

◆ AdjustLayout() [2/2]

virtual void AdjustLayout ( CRect rcClient )
protectedvirtual

This member function adjusts the layout of all sub-items depending on the current window client size.

AdjustLayout depends on the AutoSize flag (changing control size or item fonts correspondingly).

Parameters
rcClient A CRect that contains the control's client area rectangle cordinates

◆ AllowNoncontinuousSelection()

void AllowNoncontinuousSelection ( BOOL bAllow = TRUE )

This member function sets the flag which shows whether control allows non-continuous days selection or not.

Parameters
bAllow TRUE to allow non-continuous days selection (default value), FALSE to disallow.

Allowing continuous days selection means that user will be able to select only a single days interval between 2 dates, where all dates will be selected inside. Non-continuous days selection means that user will be able to select any specific dates totally up to MaxSelCount count.

See also
IsAllowNoncontinuousSelection
SetMaxSelCount
GetMaxSelCount

◆ CalcButtonBandRect()

virtual void CalcButtonBandRect ( )
protectedvirtual

Call this member function to calculate and set the button's band rectangle.

The band rectangle is a box that is drawn around the button to highlight the button.

See also
SetButtonRect
CalcButtonSize

◆ CalcButtonSize()

virtual CSize CalcButtonSize ( ) const
protectedvirtual

This member function calculates the size of the button.

Returns
CSize object with button size.
See also
SetButtonRect
CalcButtonBandRect

◆ ClearFocus()

virtual void ClearFocus ( )
virtual

This function clear focused attribute if it is set.

Focused item is used only for the keyboard navigation and selecting. It is initialized by keyboard using first day of the current selection or if selection is empty the first day of the first visible month is used. Focused item is cleared by mouse or by set selection externally.

See also
IsFocused

◆ ClearMonths()

virtual void ClearMonths ( )
protectedvirtual

This member function is used to cleanup the months array.

See also
Populate

◆ Create()

virtual BOOL Create | ( | DWORD | dwStyle,
 |  | const RECT & | rect,
 |  | CWnd * | pParentWnd,
 |  | UINT | nID,
 |  | CCreateContext * | pContext = NULL )
 virtual

This member function is used to create the Date Picker Control Window.

Parameters
dwStyle | Specifies the window style attributes.
rect | A RECT object that contains the coordinates of the window, in the client coordinates of pParentWnd.
pParentWnd | A CWnd pointer to the parent window.
nID | A UINT that contains the ID of the child window.
pContext | A CCreateContext pointer that contains the create context of the window.
Returns
Nonzero if successful. Otherwise 0.

◆ CreateMonthArray()

virtual void CreateMonthArray ( )
protectedvirtual

This member function creates the internal month array.

Fills the internal month array with the new DatPickerItemMonth objects, using the values of the initialized data members.

See also
Populate

◆ Deselect()

virtual void Deselect ( const COleDateTime & dtDay )
virtual

Call this member function to de-select the specified day.

Parameters
dtDay Date to be deselected.

This member function removes the provided day from the control's selected days collection.

See also
Select
IsSelected

◆ DrawButtons()

virtual void DrawButtons ( CDC * pDC )
protectedvirtual

Call this member function to draw the calendar's buttons.

Parameters
pDC Pointer to a valid device context.
See also
OnDraw

◆ EnableSysYearMonthFormat()

void EnableSysYearMonthFormat ( BOOL nEnable )

This member function sets the system-defined format of year_month string.

Parameters
nEnable Boolean value determines if the system-defined format of year_month string are shown.

String m_strYearMonthFormat can be defined proper only if operating system is Windows 2000 or a later version.

See also
SetMonthName
GetMonthName
m_strYearMonthFormat

◆ EnsureVisible()

virtual void EnsureVisible ( const COleDateTime & dtDate )
virtual

Call this member function to ensure that a specified COleDateTime item is visible.

Parameters
dtDate Reference to the COleDateTime item whose visibility must be ensured.

If necessary, the function scrolls the month grid on the control to make the day visible.

See also
EnsureVisibleSelection

◆ EnsureVisibleFocus()

virtual void EnsureVisibleFocus ( )
virtual

Call this member function to ensure that the focused item is visible.

Focused item is used only for the keyboard navigation and selecting. It is initialized by keyboard using first day of the current selection or if selection is empty the first day of the first visible month is used. Focused item is cleared by mouse or by set selection externally.

See also
EnsureVisible
EnsureVisibleSelection

◆ EnsureVisibleSelection()

virtual void EnsureVisibleSelection ( )
virtual

Call this member function to ensure that the selection range is visible.

If necessary, the function scrolls the month grid on the control to make all selected days visible.

See also
EnsureVisible
EnsureVisibleFocus

◆ GetBorderStyle()

AFX_INLINE XTPDatePickerBorderStyle GetBorderStyle ( ) const

Call this member function to determine if the border is visible.

Returns
XTPDatePickerBorderStyle value that specifies the border style.
See also
SetBorderStyle
CXTPDatePickerPaintManager::DrawBorder
XTPDatePickerBorderStyle

◆ GetButton()

AFX_INLINE CXTPDatePickerButton * GetButton ( int nIndex ) const

This member function returns a pointer to the CXTPDatePickerButton object using its numeric index.

Parameters
nIndex The index of the CXTPDatePickerButton to retrieve.

Call this member function to retrieve a pointer to the button object using its numeric index.

Returns
A pointer to the CXTPDatePickerButton object.
See also
GetButtonCount
AddButton

◆ GetButtonCount()

AFX_INLINE int GetButtonCount ( ) const

This member function returns the number of CXTPDatePickerButton items shown on the control.

Call this member function to determine the number of buttons currently used on the control.

Returns
A number of CXTPDatePickerButton items shown on the control.
See also
GetButton
AddButton

◆ GetCallbackDayMetrics()

AFX_INLINE PFNITEMMETRICS GetCallbackDayMetrics ( ) const

This member function returns the day metrics callback function.

Call this member function to obtain a pointer to the user-defined day metrics callback function.

Returns
Pointer to the callback function.
See also
PFNITEMMETRICS
SetCallbackDayMetrics
GetDayMetrics

◆ GetCols()

AFX_INLINE int GetCols ( ) const

Call this member function to obtain the number of columns in the months grid.

Returns
An int that contains the number of columns in the control's months grid.
See also
GetRows
SetGridSize

◆ GetConnection()

AFX_INLINE CXTPNotifyConnection * GetConnection ( ) const

This member function obtains a notification connection object pointer.

Used to subscribe (Advice) for notifications events from the control.

Returns
A CXTPNotifyConnection pointer to the connection object.
See also
CXTPNotifyConnection overview
IXTPNotificationSink overview

◆ GetCurSel()

virtual BOOL GetCurSel ( COleDateTime & refDateTime ) const
virtual

This member function retrieves the system time as indicated by the currently-selected date.

Parameters
refDateTime A reference to a COleDateTime object. Receives the currently selected time.

This member function fails if more than 1 date is selected.

Returns
A BOOL that indicates the success of the function. TRUE if the function is successfully able to retrieve the system time. FALSE if more than one date is selected.
See also
SetCurSel
CMonthCalCtrl::GetCurSel

◆ GetDayMetrics()

virtual void GetDayMetrics | ( | COleDateTime & | dtDay,
 |  | XTP_DAYITEM_METRICS * | pDayMetics )
 virtual

This member function returns the day item drawing metrics.

Parameters
dtDay | Reference to the DateTime value to check.
pDayMetics | Pointer to the day metrics structure.

Determines whether or not a given date is special. This function calls a callback function to make this determination.

See also
GetCallbackDayMetrics
SetCallbackDayMetrics

◆ GetDayOfWeekName()

AFX_INLINE CString GetDayOfWeekName ( int nDayOfWeek ) const

This member function returns the DayOfWeek name associated with the integer value of nDayOfWeek.

Parameters
nDayOfWeek DayOfWeek number.
Returns
Valid day-of-week range is between 1 and 7, where 1 = Sunday, 2 = Monday, and so on.

If nDayOfWeek is a valid integer value, then the function returns the name of the week associated with the integer value of nDayOfWeek. If nDayOfWeek is not a valid integer value, then the function returns an empty string.

See also
SetDayOfWeekName
SetMonthName
GetMonthName

◆ GetFirstDayOfWeek()

AFX_INLINE int GetFirstDayOfWeek ( ) const

This member function obtains the first day of the week that is displayed in the leftmost column of the calendar.

An integer value that represents the first day of the week. The days of the week are represented as integers, as follows.

  • 1: Sunday
  • 2: Monday
  • 3: Tuesday
  • 4: Wednesday
  • 5: Thursday
  • 6: Friday
  • 7: Saturday
    Returns
    Gets the first day of the week
    See also
    SetFirstDayOfWeek

◆ GetFirstWeekOfYearDays()

AFX_INLINE int GetFirstWeekOfYearDays ( ) const

This member function obtains the current required number of year days in the first week of the year.

Returns
An integer value that represents the required number of days of the new year in the first week of this year. The value should be between 1 (by default) and 7 (full week).
See also
SetFirstWeekOfYearDays

◆ GetHighlightToday()

AFX_INLINE BOOL GetHighlightToday ( ) const

Call this member function to determine whether the "Today" cell highlighting is enabled or disabled.

This member function returns a boolean flag that specifies the "Today" button highlighting mode.

Returns
A BOOL that indicates if the "Today" cell is highlighted.

TRUE if the "Today" cell is highlighted. Otherwise FALSE.

See also
GetHighlightToday
SetToday
GetToday
CXTPDatePickerPaintManager::GetHighlightTodayColor

◆ GetMaxSelCount()

AFX_INLINE int GetMaxSelCount ( ) const

This member function retrieves the current maximum number of days that can be selected in a date picker control.

This member function implements the behavior of the CMonthCalCtrl::GetMaxSelCount function.

Returns
An integer value that represents the total number of days that can be selected for the control. XTP_SELECTION_INFINITE if selection is not bounded.
See also
SetMaxSelCount
CMonthCalCtrl::GetMaxSelCount
AllowNoncontinuousSelection

◆ GetMinReqRect() [1/2]

virtual BOOL GetMinReqRect ( RECT * pRect ) const
virtual

This member function retrieves the minimum size required to show a full month in the date picker control or a specified number of full month items in a date picker control.

Parameters
pRect A pointer to a RECT structure that receives the bounding rectangle information. This parameter must be a valid address and cannot be NULL.

This member function implements the behavior of the CMonthCalCtrl::GetMinReqRect function.

GetMinReqRect(RECT* pRect, int nRows, int nCols) retrieves the minimum size required to show a specified number of full month items in a date picker control. The functionality implemented by this function is similar to the CMonthCalCtrl::GetMinReqRect, but instead of calculating a rectangle size for 1 month only, it can also calculate a rectangle size for any specified number of month items.

Returns
If successful, this member function returns nonzero and pRect receives the applicable bounding rectangle information. If unsuccessful, the member function returns 0.
See also
CMonthCalCtrl::GetMinReqRect

◆ GetMinReqRect() [2/2]

virtual BOOL GetMinReqRect | ( | RECT * | pRect,
 |  | int | nRows,
 |  | int | nCols ) const
 virtual

This member function retrieves the minimum size required to show a full month in the date picker control or a specified number of full month items in a date picker control.

Parameters
pRect | A pointer to a RECT structure that receives the bounding rectangle information. This parameter must be a valid address and cannot be NULL.
nRows | A number of months in a row inside the calculated rectangle.
nCols | A number of months in a column inside the calculated rectangle.

This member function implements the behavior of the CMonthCalCtrl::GetMinReqRect function.

GetMinReqRect(RECT* pRect, int nRows, int nCols) retrieves the minimum size required to show a specified number of full month items in a date picker control. The functionality implemented by this function is similar to the CMonthCalCtrl::GetMinReqRect, but instead of calculating a rectangle size for 1 month only, it can also calculate a rectangle size for any specified number of month items.

Returns
If successful, this member function returns nonzero and pRect receives the applicable bounding rectangle information. If unsuccessful, the member function returns 0.
See also
CMonthCalCtrl::GetMinReqRect

◆ GetMonthDelta()

AFX_INLINE int GetMonthDelta ( ) const

This member function retrieves the scroll rate for the date picker control.

This member function implements the behavior of the CMonthCalCtrl::GetMonthDelta function. The scroll rate is the number of months that the control moves its display when the user clicks a scroll button once.

Returns
The scroll rate for the date picker control.
See also
SetMonthDelta
CMonthCalCtrl::GetMonthDelta

◆ GetMonthName()

AFX_INLINE CString GetMonthName ( int nMonth ) const

This member function returns the month name of the given integer value.

Parameters
nMonth - Month number. The valid range is 1 <= nMonth >= 12.

Call this member function to retrieve the name of the month which was previously set by SetMonthName function. If month name was not set by SetMonthName function, it will return the default value, which is the default localized month name.

Returns
If nMonth is a valid integer value, then the function returns the name of the month. If nMonth is not valid, then the function
an empty string.
See also
SetMonthName
SetDayOfWeekName
GetDayOfWeekName

◆ GetMonthRange()

virtual int GetMonthRange | ( | COleDateTime & | refMinRange,
 |  | COleDateTime & | refMaxRange,
 |  | DWORD | dwFlags ) const
 virtual

This member function retrieves date information representing the high and low limits of a date picker control's display.

Parameters
refMinRange | A reference to a COleDateTime object containing the minimum date allowed.
refMaxRange | A reference to a COleDateTime object containing the maximum date allowed.
dwFlags | Value specifying the scope of the range limits to be retrieved. This value must be one of the following:
  • GMR_DAYSTATE: Include preceding and trailing months of visible range that are only partially displayed.
  • GMR_VISIBLE: Include only those months that are entirely displayed.

This member function implements the behavior of the CMonthCalCtrl::GetMonthRange function.

Returns
An integer that represents the range, in months, spanned by the two limits indicated by refMinRange and refMaxRange.
See also
CMonthCalCtrl::GetMonthRange

◆ GetPaintManager()

AFX_INLINE CXTPDatePickerPaintManager * GetPaintManager ( ) const

This member function returns a pointer to the associated paint manager.

Call this member function to obtain a pointer to the paint manager -object. The paint manager object is used for drawing the date picker window.

Returns
Pointer to the paint manager object.
See also
SetTheme
CXTPCalendarControl::SetPaintManager

◆ GetPaintTheme()

XTPCalendarTheme GetPaintTheme ( ) const

This member function is used to obtain current paint theme.

Returns
A paint theme ID from enum XTPCalendarTheme.

◆ GetRange()

virtual DWORD GetRange | ( | COleDateTime * | pMinRange,
 |  | COleDateTime * | pMaxRange ) const
 virtual

This member function retrieves the current minimum and maximum dates set in a date picker control.

Parameters
pMinRange | A pointer to a COleDateTime object containing the date at the lowest end of the range.
pMaxRange | A pointer to a COleDateTime object containing the date at the highest end of the range.

This member function implements the behavior of the CMonthCalCtrl::GetRange function.

Returns
A DWORD that can be zero (no limits are set) or a combination of the following values that specify limit information:
  • GDTR_MAX: A maximum limit is set for the control. pMaxRange is valid and contains the applicable date information.
  • GDTR_MIN: A minimum limit is set for the control. pMinRange is valid and contains the applicable date information.

Example: See CMonthCalCtrl::GetRange documentation for the example.

See also
SetRange
CMonthCalCtrl::GetRange

◆ GetRows()

AFX_INLINE int GetRows ( ) const

Call this member function to obtain the number of rows in the months grid.

Returns
The number of rows in the control's months grid.
See also
GetCols
SetGridSize

◆ GetSelectedDays()

AFX_INLINE CXTPDatePickerDaysCollection * GetSelectedDays ( ) const

Returns a collection of the days selected in the date picker.

Call this member function to return a CXTPDatePickerDaysCollection collection of the days selected in the date picker control.

Returns
Pointer to the collection of the selected days. If you want to use pointer to this collection lately in your code, you should increment and decrement references to the object manually.
See also
m_pSelectedDays

◆ GetSelRange()

virtual BOOL GetSelRange | ( | COleDateTime & | refMinRange,
 |  | COleDateTime & | refMaxRange ) const
 virtual

This member function retrieves date information representing the upper and lower limits of the date range currently selected by the user.

Parameters
refMinRange | A reference to a COleDateTime object containing the minimum date allowed.
refMaxRange | A reference to a COleDateTime object containing the maximum date allowed.

This member function implements the behavior of the CMonthCalCtrl::GetSelRange function.

Returns
Nonzero if successful. Otherwise 0.
See also
SetSelRange
CMonthCalCtrl::GetSelRange

◆ GetShowNonMonthDays()

AFX_INLINE BOOL GetShowNonMonthDays ( ) const

Call this member function to determine if the non-month days are visible.

Non-month days are shown in a special color or font just before and after regular days of a specific month. Note: For a control showing more than 1 month, non-month days are shown before the first month, and after the last month.

Returns
A boolean value that specifies if the "non-month days" are visible.

TRUE if non-month days are visible.

FALSE otherwise.

See also
SetShowNonMonthDays
CXTPDatePickerPaintManager::GetNonMonthDayBackColor
CXTPDatePickerPaintManager::GetNonMonthDayTextColor
CXTPDatePickerPaintManager::GetNonMonthDayTextFont

◆ GetShowWeekNumbers()

AFX_INLINE BOOL GetShowWeekNumbers ( ) const

Call this member function to determine if the week numbers are visible.

The week numbers are shown for each week in each month as the very left column of the month, separated by the vertical line from the -other week days. This member function determines if the week numbers are shown.

Returns
Boolean value that determines if the week numbers are set to be shown.

TRUE - If the week numbers are visible.

FALSE - If the week numbers are not visible.

See also
SetShowWeekNumbers
CXTPDatePickerPaintManager::GetWeekNumbersBackColor
CXTPDatePickerPaintManager::GetWeekNumbersTextColor
CXTPDatePickerPaintManager::GetWeekNumbersTextFont

◆ GetToday()

AFX_INLINE BOOL GetToday ( COleDateTime & refDateTime ) const
virtual

This member function retrieves the date information for the date specified as "Today" for the date picker control.

Parameters
refDateTime A reference to a COleDateTime object indicating the current day.

This member function implements the behavior of the CMonthCalCtrl::GetToday function.

Returns
Nonzero if successful. Otherwise 0.
See also
GetHighlightToday
SetHighlightToday
SetToday
CMonthCalCtrl::GetToday

◆ GetVisibleRange()

virtual BOOL GetVisibleRange | ( | COleDateTime & | refFirstVisibleDay,
 |  | COleDateTime & | refLastVisibleDay ) const
 virtual

This member function retrieves the first and last displayed days dates.

Parameters
refFirstVisibleDay | A first displayed day date.
refLastVisibleDay | A last displayed day date.
Returns
TRUE if successful, otherwise FALSE.
See also
GetMonthRange

◆ GoModal()

virtual BOOL GoModal | ( | const RECT & | rect,
 |  | CWnd * | pParentWnd = NULL )
 virtual

This member function implements pop-up window behavior for the Date Picker control.

Parameters
rect | Rectangle that contains the size and position of the window, in client coordinates of pParentWnd.
pParentWnd | Pointer to the parent window.
Returns
TRUE if successful, FALSE otherwise.
See also
IsModal

◆ HitTest() [1/2]

virtual CXTPDatePickerItemMonth * HitTest ( CPoint ptMouse ) const
virtual

This member function finds the month item at the provided point.

Parameters
ptMouse The mouse coordinates to test.

Call this function to retrieve a pointer to the month item at the specified position.

This HitTest(PMCHITTESTINFO pMCHitTest) function determines which date portion of the picker control, if any, is at a specified position. It implements the behavior of the CMonthCalCtrl::HitTest function.

Returns
A pointer to the month item where the mouse was clicked. Returns NULL if the mouse was clicked outside the months grid area.

HitTest(PMCHITTESTINFO pMCHitTest) returns a DWORD value. Equal to the uHit member of the MCHITTESTINFO structure.

See also
HitTest
CMonthCalCtrl::HitTest
MCHITTESTINFO

◆ HitTest() [2/2]

virtual DWORD HitTest ( PMCHITTESTINFO pMCHitTest ) const
virtual

This member function finds the month item at the provided point.

Parameters
pMCHitTest A pointer to a MCHITTESTINFO structure containing hit testing points for the date picker control.

Call this function to retrieve a pointer to the month item at the specified position.

This HitTest(PMCHITTESTINFO pMCHitTest) function determines which date portion of the picker control, if any, is at a specified position. It implements the behavior of the CMonthCalCtrl::HitTest function.

Returns
A pointer to the month item where the mouse was clicked. Returns NULL if the mouse was clicked outside the months grid area.

HitTest(PMCHITTESTINFO pMCHitTest) returns a DWORD value. Equal to the uHit member of the MCHITTESTINFO structure.

See also
HitTest
CMonthCalCtrl::HitTest
MCHITTESTINFO

◆ InitNames()

virtual void InitNames ( )
protectedvirtual

This member function initializes the month and day names depending on localization.

This is an internal initialization function that reads the system user locale defaults and fills the month and day of the week arrays with the locale defaults.

See also
GetMonthName
SetMonthName
GetDayOfWeekName
SetDayOfWeekName

◆ IsAllowNoncontinuousSelection()

AFX_INLINE BOOL IsAllowNoncontinuousSelection ( ) const

This member function returns the flag which shows whether control allows non-continuous days selection or not.

Allowing continuous days selection means that user will be able to select only a single days interval between 2 dates, where all dates will be selected inside. Non-continuous days selection means that user will be able to select any specific dates totally up to MaxSelCount count.

Returns
TRUE when non-continuous days selection is allowed, FALSE otherwise.
See also
AllowNoncontinuousSelection
SetMaxSelCount
GetMaxSelCount

◆ IsAutoSize()

AFX_INLINE BOOL IsAutoSize ( ) const

This function is called to determine if AutoSize mode is set.

Call this member function to determine whether the control's auto size mode is enabled.

Returns
A boolean value that specifies is AutoSize is enabled.

TRUE if AutoSize is enabled.

Otherwise return FALSE.

See also
SetAutoSize

◆ IsFocused()

virtual BOOL IsFocused ( const COleDateTime & dtDay ) const
virtual

This function checks a specific date to determine if it is focused.

Parameters
dtDay A date to check.

Focused item is used only for the keyboard navigation and selecting. It is initialized by keyboard using first day of the current selection or if selection is empty the first day of the first visible month is used. Focused item is cleared by mouse or by set selection externally.

Returns
TRUE when the day is focused, FALSE otherwise.
See also
ClearFocus

◆ IsModal()

AFX_INLINE BOOL IsModal ( ) const

Is the control runs in modal mode.

Returns
TRUE when the control is used as a pop-up window, FALSE otherwise.
See also
GoModal

◆ IsMultiSelectionMode()

AFX_INLINE BOOL IsMultiSelectionMode ( ) const

Determines if the multiple selection mode is enabled.

Returns
TRUE if the multiple selection mode is enabled.
See also
SetMultiSelectionMode

◆ IsNoneButtonVisible()

virtual BOOL IsNoneButtonVisible ( )
virtual

This function returns the boolean visibility flag of the "None" button.

Call this member function to determine the visibility of the "None" service button.

Returns
A boolean value that specifies if the "None" button is visible.

TRUE when the "None" button is visible.

Otherwise FALSE.

See also
IsTodayButtonVisible
SetButtonsVisible

◆ IsSelected()

virtual BOOL IsSelected ( const COleDateTime & dtDay ) const
virtual

This function checks a specific date to determine if it is contained in the control's selection.

Parameters
dtDay - A date to check.

Call this member function to determine whether dtDay is selected.

Returns
A boolean value that specifies if the date is contained in the current selection.

TRUE when the day is selected.

Otherwise FALSE.

See also
Select
Deselect

◆ IsTodayButtonVisible()

virtual BOOL IsTodayButtonVisible ( )
virtual

This member function is used to obtain the value of the visibility flag for the "Today" button.

Call this member function to determine the visibility of the "Today" service button.

Returns
A boolean value that specifies if the "Today" button is visible.

TRUE if the "Today" button is visible.

Otherwise FALSE.

See also
IsNoneButtonVisible
SetButtonsVisible

◆ OnButtonClick()

virtual void OnButtonClick ( UINT nID )
protectedvirtual

This member function is used to process the control's button clicks.

Parameters
nID Date picker button ID (could be XTP_IDS_DATEPICKER_TODAY or XTP_IDS_DATEPICKER_NONE)

This member function performs internal button click processing and sends a XTP_NC_DATEPICKER_BUTTON_CLICK notification to the parent window.

See also
SendMessageToParent

◆ OnDraw()

virtual void OnDraw ( CDC * pDC )
protectedvirtual

This member function is used to perform all drawing logic.

Parameters
pDC Pointer to a valid device context.
See also
DrawButtons

◆ Populate()

virtual void Populate ( )
protectedvirtual

This member function performs control population, creating the view from the data.

Creates a new month collection for the control, populating it with the new objects created according to the stored properties and settings. Call this member function if the number of months to show needs adjusting.

See also
ClearMonths

◆ PreSubclassWindow()

virtual void PreSubclassWindow ( )
protectedvirtual

This member function is called by the framework to allow other necessary sub-classing to occur before the window is sub-classed.

This member function is used to call some internal initialization functions like AdjustLayout() immediately after instantiating the DatePickerControl object.

See also
Create
CXTPDatePickerControl::CXTPDatePickerControl

◆ ProcessButtons()

virtual void ProcessButtons ( CPoint point )
protectedvirtual

This member function is used to implement button behavior.

Parameters
point Current mouse position.

This member function is called from the following member functions: OnLButtonDown, OnLButtonDblClk, OnLButtonUp, OnMouseLeave, and OnMouseMove.

◆ RedrawControl()

virtual void RedrawControl ( )
virtual

This member function redraws the control windows.

Call this member function to redraw all control windows according to the stored parameter values. The window will be updated immediately: CWnd::UpdateWindow() will be called.

See also
_RedrawControl

◆ RegisterWindowClass()

BOOL RegisterWindowClass ( HINSTANCE hInstance = NULL )

This member function registers the window class if it has not already been registered.

Parameters
hInstance Instance of the resource where the control is located.
Returns
TRUE if the window class was successfully registered, otherwise FALSE.

◆ ScrollLeft()

virtual void ScrollLeft ( int nMonthCount = 1 )
virtual

This member function scrolls the control's months grid to the left by the specified number of months.

Parameters
nMonthCount Integer value that specifies how many months to scroll. The default value is 1.

Call this member function to scroll the months grid to the left by nMonthCount positions.

See also
ScrollRight

◆ ScrollRight()

virtual void ScrollRight ( int nMonthCount = 1 )
virtual

This member function scrolls the control's months grid to the right by the specified amount of months.

Parameters
nMonthCount Integer value that specifies how many months to scroll. The default value is 1.

Call this member function to scroll the months grid to the right by nMonthCount positions.

See also
ScrollLeft

◆ Select()

virtual void Select ( const COleDateTime & dtDay )
virtual

Call this member function to select a specific day.

Parameters
dtDay Date to be selected.

This function determines if one more item can be added to the collection of selected days. If yes, then the selected day is added to the list of selected items.

See also
Deselect
IsSelected

◆ SendMessageToParent()

virtual LRESULT SendMessageToParent | ( | int | nMessage,
 |  | NMHDR * | pNMHDR = NULL )
 virtual

Call this member function to send notifications to the parent window.

Parameters
nMessage | An int that contains the identifier of the message. See remarks section for a list of valid values.
pNMHDR | Pointer to the XTP_NC_DATEPICKER_BUTTON notification structure.

The following values are valid for nMessage:

  • XTP_NC_DATEPICKER_BUTTON_CLICK - Notifies that one of date picker buttons was clicked.
  • XTP_NC_DATEPICKER_SELECTION_CHANGED - Notifies that the date picker selection has changed. This function notifies the parent window that something happened. For the example of how to catch these messages see below.

Example:

// First, add the message handler to your message map.
ON_NOTIFY(XTP_NC_DATEPICKER_BUTTON_CLICK, 1000, OnButtonPressed)

// Then implement the message handler like the example below
void YourDlg::OnButtonPressed(NMHDR* pNotifyStruct, LRESULT*)
{
   XTP_NC_DATEPICKER_BUTTON* pNMButton = (XTP_NC_DATEPICKER_BUTTON*)pNotifyStruct;

   switch (pNMButton->nID)
{
   case XTP_IDS_DATEPICKER_TODAY:
        TRACE(_T("TODAY BUTTON PRESSEDn"));
        break;
   case XTP_IDS_DATEPICKER_NONE:
        TRACE(_T("NONE BUTTON PRESSEDn"));
        break;
}
}
Returns
An LRESULT that is used to indicate the success of the function. Nonzero if the message is sent successfully, zero otherwise.

◆ SendNotification()

virtual void SendNotification | ( | XTP_NOTIFY_CODE | EventCode,
 |  | WPARAM | wParam = 0,
 |  | LPARAM | lParam = 0 )
 protectedvirtual

This member function sends a notification to all control's event subscribers.

Parameters
EventCode | The specific code of the event.
wParam | First custom parameter. Depends on the event type. See specific event description for details.
lParam | Second custom parameter. Depends on the event type. See specific event description for details.

This member function is called internally from inside the control when a notification is sent to all notification listeners.

See also
XTP_NOTIFICATIONCODE
GetConnection

◆ SetAutoSize()

void SetAutoSize ( BOOL bAuto = TRUE )

This function sets the AutoSize mode.

Parameters
bAuto Boolean value. If bAuto is TRUE, then AutoSize is enabled. If this parameter is FALSE, then AutoSize is disabled.

Set AutoSize mode to TRUE if you want the control to automatically calculate the number of month items according to control's size. When this mode is enabled and there is enough space on control's client area, the control adds a row or a column of month items and centers them both horizontally and vertically.

See also
IsAutoSize

◆ SetBorderStyle()

void SetBorderStyle ( XTPDatePickerBorderStyle borderStyle )

Call this member function to set borders style around the control.

Parameters
borderStyle New border style value determined by XTPDatePickerBorderStyle enumeration.
See also
GetBorderStyle
CXTPDatePickerPaintManager::DrawBorder
XTPDatePickerBorderStyle

◆ SetButtonRect()

virtual void SetButtonRect ( )
protectedvirtual

Call this member function to calculate and set the button's bounding rectangle.

See also
CalcButtonSize
CalcButtonBandRect

◆ SetButtonsVisible()

virtual void SetButtonsVisible | ( | BOOL | bShowToday,
 |  | BOOL | bShowNone )
 virtual

This function sets visibility for the "Today" and "None" buttons.

Parameters
bShowToday | Provide TRUE to show the "Today" button, or FALSE to hide it.
bShowNone | Provide TRUE to show the "None" button, or FALSE to hide it.

Call this member function to hide or show any of the control's service buttons.

See also
IsTodayButtonVisible
IsNoneButtonVisible

◆ SetCallbackDayMetrics()

AFX_INLINE void SetCallbackDayMetrics | ( | PFNITEMMETRICS | pFunc,
 |  | void * | pParam = NULL )
 virtual

This member function sets the user-defined day metrics callback function.

Parameters
pFunc | Pointer to the callback function.
pParam | Pointer to any user-defined parameter provided to the callback function.

Call this member function to set up the user-defined callback function to manipulate the 'special day's attributes'.

See also
PFNITEMMETRICS
GetCallbackDayMetrics
GetDayMetrics

◆ SetCurSel()

virtual BOOL SetCurSel ( const COleDateTime & refDateTime )
virtual

This member function sets the currently selected date for the date picker control.

Parameters
refDateTime A reference to a COleDateTime object, which contains a date to select.

This member function clears the selection of a date picker control and selects a specified date.

Returns
Nonzero if successful. Otherwise 0.
See also
GetCurSel
CMonthCalCtrl::GetCurSel

◆ SetDayOfWeekName()

AFX_INLINE void SetDayOfWeekName | ( | int | nDayOfWeek,
 |  | LPCTSTR | strDayOfWeekName )

This member function sets the user-defined DayOfWeek name.

Parameters
nDayOfWeek | DayOfWeek number to set new name for.
strDayOfWeekName | New DayOfWeek name.

Valid day-of-week range is between 1 and 7, where 1 = Sunday, 2 = Monday, and so on.

See also
GetDayOfWeekName
SetMonthName
GetMonthName

◆ SetDesiredVisibleAndFullRange()

virtual void SetDesiredVisibleAndFullRange | ( | COleDateTime | FirstVisibleDay,
 |  | COleDateTime | LastVisibleDay,
 |  | COleDateTime | FirstDay,
 |  | COleDateTime | LastDay )
 virtual

This member function allows scrolling between FirstDay and LastDay and tries to show the initial visible range between FirstVisibleDay and LastVisibleDay.

Parameters
FirstVisibleDay | A first displayed day date.
LastVisibleDay | A last displayed day date.
FirstDay | A first allowed day date.
LastDay | A last allowed day date.

◆ SetFirstDayOfWeek()

AFX_INLINE void SetFirstDayOfWeek ( int nDay )

This member function sets the day of the week that is displayed in the leftmost column of the calendar.

Parameters
nDay An integer value representing which day is set as the first day of the week. This value must be one of the day numbers. See GetFirstDayOfWeek for a description of the day numbers.
See also
GetFirstDayOfWeek

◆ SetFirstWeekOfYearDays()

AFX_INLINE void SetFirstWeekOfYearDays ( int nDays )

This member function sets the required number of this year days in the first week of the year.

Parameters
nDays An integer value representing the required number of days of the new year in the first week of the year. The value should be between 1 (default) and 7 (full week).
See also
GetFirstWeekOfYearDay

Example:

// Setup German style of week numbers calculation.
pMyDatePicker->SetFirstWeekOfYearDays(4);

◆ SetGridDimentions()

virtual CSize SetGridDimentions ( CRect rcGrid )
protectedvirtual

This member function sets new dimensions for the month grid.

Parameters
rcGrid New rectangle coordinates of the Grid area.
Returns
Calculates and sets Grid dimensions (rows and columns count) for the grid size.
See also
AdjustLayout

◆ SetGridSize()

virtual void SetGridSize | ( | int | nRows,
 |  | int | nCols,
 |  | BOOL | bRestrictMode = FALSE )
 virtual

Call this member function to set the number of months in the control's grid.

Parameters
nRows | int that contains the new rows count value.
nCols | int that contains the new columns count value.
bRestrictMode | BOOL flag used for resizing.

This member function is called in the AutoSize mode. It sets the new number of columns and rows in the control's months grid. Also, the function redraws each month within the existing control's coordinates, reducing or enlarging the size of each month item as necessary. Note: This function does nothing when AutoSize mode is enabled.

See also
GetRows
GetCols

◆ SetHighlightToday()

void SetHighlightToday ( BOOL bValue )

Call this member function to enable or disable highlighting of the "Today" cell.

Parameters
bValue Boolean value determines if the "Today" cell is highlighted.

The "Today" cell is determined and changed using the SetToday and GetToday member functions. When highlighting is enabled, the cell is surrounded by a rectangle frame of the specific color.

See also
GetHighlightToday
SetToday
GetToday
CXTPDatePickerPaintManager::GetHighlightTodayColor

◆ SetLayoutRTL()

virtual void SetLayoutRTL ( BOOL bRightToLeft )
virtual

Call this member to set right-to-left mode.

Parameters
bRightToLeft TRUE to set right-to-left reading-order properties.

◆ SetMaxSelCount()

void SetMaxSelCount ( int nMax = XTP_SELECTION_INFINITE )

This member function sets the maximum number of days that can be selected in a date picker control.

Parameters
nMax The value that is set to represent the maximum number of selectable days. XTP_SELECTION_INFINITE if selection is not bounded.

This member function implements the behavior of the CMonthCalCtrl::SetMaxSelCount function.

See also
GetMaxSelCount
AllowNoncontinuousSelection
CMonthCalCtrl::SetMaxSelCount

◆ SetMonthDelta()

AFX_INLINE void SetMonthDelta ( int iDelta )

This member function sets the scroll rate for the date picker control.

Parameters
iDelta The number of months set as the control's scroll rate. If this value is zero, the month delta is reset to the default, which is the number of months displayed in the control.

This member function implements the behavior of the CMonthCalCtrl::SetMonthDelta function.

See also
GetMonthDelta
CMonthCalCtrl::SetMonthDelta

◆ SetMonthName()

AFX_INLINE void SetMonthName | ( | int | nMonth,
 |  | LPCTSTR | strMonthName )

This member function sets the user-defined month name.

Parameters
nMonth | An int that contains the Month number corresponding to the month name. i.e. 1 = January, 2 = February, 3 = March, ... Valid values are from 1 to 12.
strMonthName | A CString that contains the New month name.

Use this function to change the shown month name to any preferred -or localized values.

See also
GetMonthName
SetDayOfWeekName
GetDayOfWeekName

◆ SetMultiSelectionMode()

AFX_INLINE void SetMultiSelectionMode ( BOOL bMultiSelectionMode )

Enables/disables the multiple selection mode for the control.

Parameters
bMultiSelectionMode TRUE for enabling, FALSE for disabling.

Sets the flag that determines whether the report is in multiple selection mode.

See also
IsMultiSelectionMode

◆ SetPaintTheme()

void SetPaintTheme ( XTPCalendarTheme ePaintTheme )

This member function is used to set current paint theme.

Parameters
ePaintTheme A paint theme ID from enum XTPCalendarTheme.

◆ SetRange()

virtual BOOL SetRange | ( | const COleDateTime * | pMinRange,
 |  | const COleDateTime * | pMaxRange )
 virtual

This member function sets the minimum and maximum allowable dates for a date picker control.

Parameters
pMinRange | A pointer to a COleDateTime object containing the date at the lowest end of the range.
pMaxRange | A pointer to a COleDateTime object containing the date at the highest end of the range.

This member function implements the behavior of the CMonthCalCtrl::GetRange function.

Returns
Nonzero if successful. Otherwise 0.
See also
GetRange
CMonthCalCtrl::SetRange

◆ SetSelRange()

virtual BOOL SetSelRange | ( | const COleDateTime & | refMinRange,
 |  | const COleDateTime & | refMaxRange )
 virtual

This member function sets the selection for a date picker control to a given date range.

Parameters
refMinRange | A reference to a COleDateTime object containing the date at the lowest end of the range.
refMaxRange | A reference to a COleDateTime object containing the date at the highest end of the range.

This member function implements the behavior of the CMonthCalCtrl::SetSelRange function.

Please note that this method doesn't refresh the control, and in order to update control's picture you'll have to call RedrawControl method after changing a selection.

Returns
Nonzero if successful. Otherwise 0.
See also
GetSelRange
CMonthCalCtrl::SetSelRange

◆ SetShowNonMonthDays()

void SetShowNonMonthDays ( BOOL bShow )

Call this member function to show or hide non-month days.

Parameters
bShow Boolean value determines if the non-month days are shown. TRUE If the non-month days are visible. FALSE If the non-month days are not visible.

Non-month days are shown in a special color or font. Non-month days are shown just before and after regular days of a specific month. Note: For a control showing more than 1 month, non-month days will be shown before the first month, and after the last one.

See also
GetShowNonMonthDays
CXTPDatePickerPaintManager::GetNonMonthDayBackColor
CXTPDatePickerPaintManager::GetNonMonthDayTextColor
CXTPDatePickerPaintManager::GetNonMonthDayTextFont

◆ SetShowWeekNumbers()

virtual void SetShowWeekNumbers ( BOOL bValue )
virtual

Call this member function to show or hide the week numbers.

Parameters
bValue Boolean value determines whether week numbers are visible.

Week numbers are shown for each week in each month at the very left column of the month, separated by the vertical line from the -other week days. This member function controls the visibility mode of the week numbers.

See also
GetShowWeekNumbers
CXTPDatePickerPaintManager::GetWeekNumbersBackColor
CXTPDatePickerPaintManager::GetWeekNumbersTextColor
CXTPDatePickerPaintManager::GetWeekNumbersTextFont

◆ SetTheme()

void SetTheme ( CXTPDatePickerPaintManager * pPaintManager = NULL )

This member function sets the new control drawing theme.

Parameters
pPaintManager Pointer of the new paint manager object or derived class like CXTPDatePickerThemeOffice2007. If NULL, then the default paint manager object is set.

Call this member function to set the paint manager object that is used for drawing a date picker window.

See also
GetPaintManager

◆ SetToday()

virtual void SetToday ( const COleDateTime & refDateTime )
virtual

This member function sets the calendar control to the current day.

Parameters
refDateTime A reference to a COleDateTime object that contains the current date.

This member function implements the behavior of the CMonthCalCtrl::SetToday function.

See also
GetHighlightToday
SetHighlightToday
SetToday
GetToday
CMonthCalCtrl::SetToday

◆ ShiftDate()

static BOOL AFX_CDECL ShiftDate | ( | COleDateTime & | refDate,
 |  | int | nMonthCount )
 staticprotected

This function shifts the specified date for the specified number of months.

Parameters
refDate | Reference to the COleDateTime object to shift the date on.
nMonthCount | Number of months used for shifting. Can be both positive and negative numbers.

This is a utility function that is used to shift the specified date for a specific number of months.

Returns
A BOOL value that specifies if the function is successful. Return zero if the value of this COleDateTime object is set successfully. Otherwise return 1.
See also
COleDateTime overview

◆ ShowListHeader()

virtual void ShowListHeader | ( | CRect | rcHeader,
 |  | COleDateTime | dtMonth )
 protectedvirtual

This member function shows a CXTPDatePickerList control at the coordinates specified by rcHeader.

Parameters
rcHeader | The coordinates of the list window.
dtMonth | The month date to start from.

Call this member function to force showing of the months pop-up list control.

See also
CXTPDatePickerList overview

◆ SizeMinReq()

virtual BOOL SizeMinReq ( BOOL bRepaint = TRUE )
virtual

This member function adjusts the date picker control to the minimum size required to display one month.

Parameters
bRepaint A BOOL that specifies whether the control is to be repainted. By default, TRUE. If FALSE, no repainting occurs.

Calling SizeMinReq successfully displays the entire date picker control for one month's calendar.

Returns
Nonzero if the date picker control is sized to its minimum. Otherwise 0.
See also
GetMinReqRect
CMonthCalCtrl::SizeMinReq

Member Data Documentation

◆ m_arDayOfWeekNames

CString* m_arDayOfWeekNames
protected

This member variable contains the day abbreviation for drawing.

in the month header.

◆ m_bDeleteOnFinalRelease

BOOL m_bDeleteOnFinalRelease

Delete self OnFinalRelease() call.

◆ m_bIsModal

BOOL m_bIsModal
protected

This member variable is used to specify if the control is used as a pop-up window.

TRUE when the control is used as a pop-up. FALSE -otherwise.

◆ m_bMultiSelectionMode

BOOL m_bMultiSelectionMode
protected

TRUE if multiselection mode enabled (i.e.

VK_CTRL is always on).

◆ m_bRestrictMode

BOOL m_bRestrictMode

Flag to keep desired month's numbers without scaling.

◆ m_bYearsTriangle

BOOL m_bYearsTriangle

Use extra button for 1 year jump.

◆ m_dtFocused

COleDateTime m_dtFocused
protected

This member variable is used to specify the focused day.

Used only for keyboard navigation and selecting.

◆ m_dtFSelBase

COleDateTime m_dtFSelBase
protected

This member variable is used to specify start day of the continuous selection.

Used only for keyboard navigation and selecting.

◆ m_nColumns

int m_nColumns
protected

This member variable is used to specify the number of columns in the column month's grid.

MODIFICATION - DESIRED MATRIX

◆ m_nLockUpdateCount

int m_nLockUpdateCount
protected

This member variable is used as a counter that is used to count the update locks.

An image will be redrawn only when the lock counter is equal to zero.

◆ m_nMonthDelta

int m_nMonthDelta
protected

This member variable is used to specify the number of months set as the control's scroll rate.

If this value is zero, then the month delta is reset to the default rate, which is the number of months displayed in the control.

◆ m_strYearMonthFormat

CString m_strYearMonthFormat

The year month format.

The documentation for this class was generated from the following file:
  • XTPDatePickerControl.h


Toolkit Pro: CXTPDatePickerDaysCollection Class Reference

Classes | Public Member Functions | Protected Attributes | List of all members
CXTPDatePickerDaysCollection Class Reference
Inheritance diagram for CXTPDatePickerDaysCollection:
[legend]

Classes

struct SELECTED_BLOCK
Selected block structure. More...

Public Member Functions

CXTPDatePickerDaysCollection (CXTPDatePickerControl *pControl)
Default collection constructor.
virtual | ~CXTPDatePickerDaysCollection ()
Default collection destructor.
void | Clear ()
Call this member function to clear the day collection.
void | Add (const COleDateTime &dtDay)
Call this member function to add a day to the collection.
void | Select (const COleDateTime &dtDay)
Call this member function to select a day.
void | SelectRange (const COleDateTime &dtDayBegin, const COleDateTime &dtDayEnd)
Call this member function to select days.
void | Remove (const COleDateTime &dtDay)
Call this member function to remove a day from the collection.
BOOL | Contains (const COleDateTime &dtDay) const
Call this member function to determine if a day is contained in the collection.
int | GetSelectedDaysCount () const
Call this member function to count the number of days in the collection.
int | GetSelectedBlocksCount () const
Call this member function to count the number of selected blocks.
SELECTED_BLOCK | GetSelectedBlock (int nIndex) const
Call this member function to get the selected block by its index.
BOOL | GetMinMaxRange (COleDateTime &refMinRange, COleDateTime &refMaxRange) const
Call this member function to determine the minimum and the maximum day in the collection.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Attributes

CXTPDatePickerControl * | m_pControl
This member variable is a pointer to the parent control.
CArray< SELECTED_BLOCK, SELECTED_BLOCK & > | m_arrSelectedBlocks
Contains an array of the selected dates blocks.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

Class CXTPDatePickerDaysCollection provides facilities to build various collection of days, for using in groups. For example, the selected days collection. To create an object of this class, simply call the constructor and provide a pointer to the DatePicker controller.

Constructor & Destructor Documentation

◆ CXTPDatePickerDaysCollection()

CXTPDatePickerDaysCollection ( CXTPDatePickerControl * pControl )

Default collection constructor.

Parameters
pControl Pointer to the DatePicker control object.

Handles initial initialization.h

◆ ~CXTPDatePickerDaysCollection()

virtual ~CXTPDatePickerDaysCollection ( )
virtual

Default collection destructor.

Handles member item deallocation.

See also
Clear()

Member Function Documentation

◆ Add()

void Add ( const COleDateTime & dtDay )

Call this member function to add a day to the collection.

Parameters
dtDay Date of a day, the key of the new element.

The primary means to insert an element into a map. First, search for the key. If the key is found, then the corresponding value is changed. Otherwise, a new key-value pair is created an added to the map.

See also
Remove

◆ Contains()

BOOL Contains ( const COleDateTime & dtDay ) const

Call this member function to determine if a day is contained in the collection.

Parameters
dtDay Date of a day. The key that identifies the element to search for.

This function uses a hash algorithm to quickly find the map element using a key that exactly matches the given key.

Returns
Nonzero if the element was found. Otherwise 0.

◆ GetMinMaxRange()

BOOL GetMinMaxRange | ( | COleDateTime & | refMinRange,
 |  | COleDateTime & | refMaxRange ) const

Call this member function to determine the minimum and the maximum day in the collection.

Parameters
refMinRange | A COleDateTime reference to the minimum date storage variable.
refMaxRange | A COleDateTime reference to maximum date storage variable.
Returns
A boolean value. TRUE if successful. Otherwise FALSE.

◆ GetSelectedBlock()

AFX_INLINE CXTPDatePickerDaysCollection::SELECTED_BLOCK GetSelectedBlock ( int nIndex ) const

Call this member function to get the selected block by its index.

Parameters
nIndex Selected block to retrieve.
Returns
An enumerated value specifying the selected block.

◆ GetSelectedBlocksCount()

AFX_INLINE int GetSelectedBlocksCount ( ) const

Call this member function to count the number of selected blocks.

Returns
An integer value representing the number of selected blocks.

◆ GetSelectedDaysCount()

int GetSelectedDaysCount ( ) const

Call this member function to count the number of days in the collection.

Returns
An integer value representing the number of day items in the collection.

◆ Remove()

void Remove ( const COleDateTime & dtDay )

Call this member function to remove a day from the collection.

Parameters
dtDay A COleDateTime reference that contains the date of a day. The key for the element to be removed.

Searches the map for the entry corresponding to the supplied key. If the key is found, then the entry is removed.

See also
Add

◆ Select()

void Select ( const COleDateTime & dtDay )

Call this member function to select a day.

Parameters
dtDay Date of a day, the key of the new element.
See also
Add
SelectRange

◆ SelectRange()

void SelectRange | ( | const COleDateTime & | dtDayBegin,
 |  | const COleDateTime & | dtDayEnd )

Call this member function to select days.

Parameters
dtDayBegin | First Date of a day.
dtDayEnd | Last Date of a day.
See also
Select
The documentation for this class was generated from the following file:
  • XTPDatePickerDaysCollection.h


Toolkit Pro: CXTPDatePickerDaysCollection::SELECTED_BLOCK Struct Reference

  • CXTPDatePickerDaysCollection
  • SELECTED_BLOCK
Public Attributes | List of all members
CXTPDatePickerDaysCollection::SELECTED_BLOCK Struct Reference

Selected block structure. More...

Public Attributes

long | nDateBegin
Begin date.
long | nDateEnd
End date.

Detailed Description

Selected block structure.

Each member is represented by an integer part of a corresponding COleDateTime value.

Example: You can create COleDateTime in a following manner:

COleDateTime dtValue;
dtValue = (DATE)(double)block.nDateBegin;
The documentation for this struct was generated from the following file:
  • XTPDatePickerDaysCollection.h


Toolkit Pro: CXTPDatePickerItemDay Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPDatePickerItemDay Class Reference

Class CXTPDatePickerItemDay represents one displayed day item in the calendar. More...

Inheritance diagram for CXTPDatePickerItemDay:
[legend]

Public Member Functions

CXTPDatePickerItemDay (CXTPDatePickerControl *pControl, CXTPDatePickerItemMonth *pMonth, COleDateTime dtDay)
Default collection constructor.
virtual | ~CXTPDatePickerItemDay ()
Default collection destructor.
virtual void | Draw (CDC *pDC)
Call this member function to draw a day item.
void | SetRect (const CRect &rcDay)
Call this member function to set the day's rectangle area.
CRect | GetRect () const
Call this member function to obtain the day's rectangle area.
COleDateTime | GetDate () const
Call this member function to get the date of the day.
BOOL | IsVisible () const
Call this member function to determine if the day is visible.
BOOL | IsToday (COleDateTime &dt) const
This member function is used to determine if the day is the "Today" date.
CXTPDatePickerItemMonth * | GetMonth () const
This member function is used to get a parent month object.
CXTPDatePickerControl * | GetDatePickerControl () const
This member function is used to get a parent date picker object.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Attributes

CXTPDatePickerControl * | m_pControl
This member variable is a pointer to the parent date picker control.
CXTPDatePickerItemMonth * | m_pMonth
This member variable is a pointer to the parent month item.
COleDateTime | m_dtDay
This member variable is used to specify the visible day date, represented by this Day item.
CRect | m_rcDay
This member variable is used to specify the coordinates of the day spot.
BOOL | m_bVisible
This member variable is used as a flag to specify if the day item is visible.The flag values are TRUE if the day item is drawn, otherwise FALSE.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

Class CXTPDatePickerItemDay represents one displayed day item in the calendar.

To create the object, call the constructor and provide pointers to the parent CXTPDatePickerControl and CXTPDatePickerItemMonth objects and a date value corresponding to its displayed day.

See also
CXTPDatePickerControl
CXTPDatePickerItemMonth

Constructor & Destructor Documentation

◆ CXTPDatePickerItemDay()

CXTPDatePickerItemDay | ( | CXTPDatePickerControl * | pControl,
 |  | CXTPDatePickerItemMonth * | pMonth,
 |  | COleDateTime | dtDay )

Default collection constructor.

Parameters
pControl | Pointer to the DatePicker control.
pMonth | Pointer to the corresponding Month item.
dtDay | Date value.

Handles initial initialization.

◆ ~CXTPDatePickerItemDay()

virtual ~CXTPDatePickerItemDay ( )
virtual

Default collection destructor.

Handles member item deallocation.

Member Function Documentation

◆ Draw()

virtual void Draw ( CDC * pDC )
virtual

Call this member function to draw a day item.

Parameters
pDC Pointer to a valid device context.

◆ GetDate()

AFX_INLINE COleDateTime GetDate ( ) const

Call this member function to get the date of the day.

Returns
The date of the day shown.
See also
CXTPDatePickerItemDay::CXTPDatePickerItemDay

◆ GetDatePickerControl()

AFX_INLINE CXTPDatePickerControl * GetDatePickerControl ( ) const

This member function is used to get a parent date picker object.

Returns
A pointer to a CXTPDatePickerControl parent object.

◆ GetMonth()

AFX_INLINE CXTPDatePickerItemMonth * GetMonth ( ) const

This member function is used to get a parent month object.

Returns
A pointer to a CXTPDatePickerItemMonth object which is an owner of this day object.

◆ GetRect()

AFX_INLINE CRect GetRect ( ) const

Call this member function to obtain the day's rectangle area.

Returns
A CRect that contains the rectangle coordinates of the day item in client coordinates of the parent's CXTPDatePickerControl object.
See also
SetRect(const CRect& rcDay)

◆ IsToday()

BOOL IsToday ( COleDateTime & dt ) const

This member function is used to determine if the day is the "Today" date.

Parameters
dt Reference to the COleDateTime object representing the date to check.
Returns
A BOOL that indicates if the day is the "Today" date. TRUE if the day is the "Today" date. Otherwise FALSE.

◆ IsVisible()

AFX_INLINE BOOL IsVisible ( ) const

Call this member function to determine if the day is visible.

Returns
Boolean value that determines if the day item is visible. TRUE if the day is visible. FALSE otherwise.

◆ SetRect()

AFX_INLINE void SetRect ( const CRect & rcDay )

Call this member function to set the day's rectangle area.

Parameters
rcDay Day rectangle in client CXTPDatePickerControl coordinates.
See also
GetRect()

Member Data Documentation

◆ m_dtDay

COleDateTime m_dtDay
protected

This member variable is used to specify the visible day date, represented by this Day item.

The documentation for this class was generated from the following file:
  • XTPDatePickerItemDay.h


Toolkit Pro: CXTPDatePickerItemMonth Class Reference

Public Member Functions | Public Attributes | Protected Member Functions | Protected Attributes | List of all members
CXTPDatePickerItemMonth Class Reference

Class CXTPDatePickerItemMonth represents one month inside the date picker month grid. More...

Inheritance diagram for CXTPDatePickerItemMonth:
[legend]

Public Member Functions

CXTPDatePickerItemMonth (CXTPDatePickerControl *pControl, COleDateTime dtMonth, int nRow, int nCol)
Default CXTPDatePickerItemMonth object constructor.
virtual | ~CXTPDatePickerItemMonth ()
Default collection destructor.
void | AdjustLayout (CRect rcClient, BOOL bIsAuto=FALSE)
Call this member function to adjust the layout of all sub-items.
virtual void | Draw (CDC *pDC)
Call this member function to perform drawing logic.
COleDateTime | GetMonth () const
Call this member function to obtain the month date.
BOOL | GetShowDaysBefore () const
Call this member function to determine if the days before a given month are displayed.
BOOL | GetShowDaysAfter () const
Call this member function to determine whether to show the days after this month.
void | SetShowDaysBefore (BOOL bShow)
Call this member function to set whether days before this month are shown.
void | SetShowDaysAfter (BOOL bShow)
Call this member function to set whether days after this month are shown.
BOOL | GetShowLeftScroll () const
Call this member function to determine if the left scroll triangle is visible.
BOOL | GetShowRightScroll () const
Call this member function to determine if the right scroll triangle is visible.
void | SetShowScrolling (BOOL bLeftScroll, BOOL bRightScroll)
Call this member function to add the left and the right scrolling triangles.
CXTPDatePickerItemDay * | GetDay (int nIndex) const
Call this member function to obtain the day item by its index in the day collection of the month.
int | GetDayCount () const
Call this member function to obtain the number of day items in the month collection.
CXTPDatePickerItemDay * | HitTest (CPoint point, BOOL bCheckVisible=TRUE) const
Call this function to return the day where the mouse cursor was located when the left mouse button was clicked.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Public Attributes

CXTPDatePickerControl * | m_pControl
This member variable is a CXTPDatePickerControl object pointer to the parent control.
int | m_nRow
This member variable is an int that is used for the row month index.
int | m_nColumn
This member variable is an int that is used for the column month index.
COleDateTime | m_dtMonth
This member variable is COleDateTime object that is used as the date with the month definition for the month item.
BOOL | m_bShowDaysBefore
This member variable is a BOOL that is used to determine if the "days before this month" are visible.
BOOL | m_bShowDaysAfter
This member variable is a BOOL that is used to indicate if the "days after this month" are visible.
BOOL | m_bShowLeftScroll
This member variable is a BOOL that is used to determine if the "left scroll triangle" is visible.
BOOL | m_bShowRightScroll
This member variable is a BOOL that is used to determine if the "right scroll triangle" is visible.
CRect | m_rcMonth
This member variable is a CRect object that contains the coordinates of the total month's area.
CRect | m_rcHeader
This member variable is a CRect object that contains the coordinates of the month's header area.
CRect | m_rcDaysOfWeek
This member variable is a CRect object that contains the coordinates of the month's "week days" area.
CRect | m_rcWeekNumbers
This member variable is a CRect object that contains the coordinates of the month's week numbers area.
CRect | m_rcDaysArea
This member variable is a CRect object that contains the coordinates of the month's "all days" area.
CRect | m_rcLeftScroll
This member variable is a CRect object that contains the coordinates of the left scroll triangle area.
CRect | m_rcRightScroll
This member variable is a CRect object that contains the coordinates of the right scroll triangle area.

Protected Member Functions

void | ClearDays ()
Call this member function to cleanup the days array.
void | PopulateDays ()
Call this member function to populate the day objects.
void | OnLButtonDown (UINT nFlags, CPoint point)
This member function is called to process left button down mouse messages.
void | OnLButtonUp (UINT nFlags, CPoint point)
This member function is called to process left button up mouse messages.
void | OnMouseMove (UINT nFlags, CPoint point)
This function is called to process mouse move messages.
BOOL | OnSetCursor (CPoint point)
This member function is called to process changing cursor message.
void | ByFontAdjustLayout (CRect rcClient)
Call this member function to calculate sizes and counts by font metrics.
void | AutoAdjustLayout (CRect rcClient)
This member function is used to calculate the size of the header, days of week, week numbers, and the scrolling triangles bounding rectangles.

Protected Attributes

CArray< CXTPDatePickerItemDay *, CXTPDatePickerItemDay * > m_arrDays
This member variable is a CArray<CXTPDatePickerItemDay*, CXTPDatePickerItemDay*> object that is used as an internal storage area for the day items.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

Class CXTPDatePickerItemMonth represents one month inside the date picker month grid.

Call the constructor to create the object and provide a pointer to the DatePicker control. The date value corresponds to the first day of the month and the grid coordinates. It is not necessary to add day items to the month item after creation. The month item constructor calls the day item constructor and fills the day items.

See also
CXTPDatePickerItemDay

Constructor & Destructor Documentation

◆ CXTPDatePickerItemMonth()

CXTPDatePickerItemMonth | ( | CXTPDatePickerControl * | pControl,
 |  | COleDateTime | dtMonth,
 |  | int | nRow,
 |  | int | nCol )

Default CXTPDatePickerItemMonth object constructor.

Parameters
pControl | A CXTPDatePickerControl pointer to the parent DatePicker control.
dtMonth | A COleDateTime object date of the first day of the month.
nRow | An int that contains the vertical coordinate of the month in the control's months grid.
nCol | An int that contains the horizontal coordinate of the month in the control's months grid.

Handles initial initialization, populates the month item with the corresponding day items.

See also
PopulateDays()
CXTPDatePickerItemDay

◆ ~CXTPDatePickerItemMonth()

virtual ~CXTPDatePickerItemMonth ( )
virtual

Default collection destructor.

Handles member items deallocation.

See also
ClearDays()

Member Function Documentation

◆ AdjustLayout()

void AdjustLayout | ( | CRect | rcClient,
 |  | BOOL | bIsAuto = FALSE )

Call this member function to adjust the layout of all sub-items.

Parameters
rcClient | A CRect object that contains the coordinates of the control.
bIsAuto | A BOOL that determines the method that is used to adjust the layout: If TRUE - The layout is adjusted depending on the given control client area rectangle. If FALSE - The layout calculations depend on the current display settings of all included items (day items, header items) and the current device context.

Adjusts the layout of all sub-items in two different ways depending on the bIsAuto parameter. If bIsAuto = TRUE, then the layout is adjusted depending on the given control's client area rectangle. In this case the given count of month items is adjusted to fit the client area. If bIsAuto = FALSE, then the layout calculation depends on the current display settings of all included items (day items, header items) and the current device context. In this case the size of one month item is calculated first, this then determines the count of the month items that fit into the control's client rectangle. Note: The second method is the default mode.

◆ AutoAdjustLayout()

void AutoAdjustLayout ( CRect rcClient )
protected

This member function is used to calculate the size of the header, days of week, week numbers, and the scrolling triangles bounding rectangles.

Parameters
rcClient A CRect object that contains the coordinates that specifies where the control is drawn.

This member function implements one of the branches of AdjustLayout(). If TRUE, then the layout is adjusted depending on the given control client area rectangle. In this case, the given count of month items is adjusted to fit the client area.

See also
AdjustLayout()

◆ ByFontAdjustLayout()

void ByFontAdjustLayout ( CRect rcClient )
protected

Call this member function to calculate sizes and counts by font metrics.

Parameters
rcClient A CRect object that contains the coordinates of the control and the location where the control is drawn.

This member function implements one of the branches of AdjustLayout(). If FALSE - The calculated layout depends on correct display settings of all included items (day items, header items) and current device context. In this case, the size of one month item is calculated first, then it determines the count of month items that fit into the control client rectangle.

See also
AdjustLayout()

◆ ClearDays()

void ClearDays ( )
protected

Call this member function to cleanup the days array.

Handles cleanup of days collection, including each day item.

◆ Draw()

virtual void Draw ( CDC * pDC )
virtual

Call this member function to perform drawing logic.

Parameters
pDC Pointer to a valid device context.

This function performs all drawing logic. This member function is used to display the month item. It does not perform any adjustments or size corrections. You must call AdjustLayout(CRect rcClient, BOOL bIsAuto = FALSE) first to handle all adjustments.

See also
AdjustLayout(CRect rcClient, BOOL bIsAuto = FALSE)

◆ GetDay()

CXTPDatePickerItemDay * GetDay ( int nIndex ) const

Call this member function to obtain the day item by its index in the day collection of the month.

Parameters
nIndex An int that contains the zero-based index value.
Returns
If the index value is less than 0 and greater then the value returned by GetDayCount() the function returns NULL.

Example:

// Enumerate the month array.
CPoint point (100, 100);
int nDayCount = GetDayCount();
for (int nDay = 0; nDay < nDayCount; nDay++)
{
   CXTPDatePickerItemDay* pDay = GetDay(nDay);
   if (pDay && pDay->GetRect().PtInRect(point) && pDay->IsVisible())
      return pDay;
}
Returns
A pointer to a CXTPDatePickerItemDay object or NULL if the index is invalid.
See also
GetDayCount()

◆ GetDayCount()

int GetDayCount ( ) const

Call this member function to obtain the number of day items in the month collection.

Returns
An int that contains the number of items stored in the collection.
See also
GetDay(int nIndex)

◆ GetMonth()

AFX_INLINE COleDateTime GetMonth ( ) const

Call this member function to obtain the month date.

Use this member function to identify the month by date. Use the date that corresponds to the first day of the month.

Returns
A ColeDateTime object that contains the month date for which this item represents.

◆ GetShowDaysAfter()

AFX_INLINE BOOL GetShowDaysAfter ( ) const

Call this member function to determine whether to show the days after this month.

This option allows changing the behavior of the control in the following way: If the last day of the month is Wednesday you may wish to leave places for the remaining day items empty or display the beginning days from the next month item.

Returns
Boolean value determines whether to show the days after this month. TRUE - If the days after this month are visible. FALSE - If the days after this month are not visible.
See also
GetShowDaysBefore()

◆ GetShowDaysBefore()

AFX_INLINE BOOL GetShowDaysBefore ( ) const

Call this member function to determine if the days before a given month are displayed.

This option allows changing the behavior of the control in the following way: If the first day of the month is Wednesday you may wish to leave places for Monday and Tuesday items empty to display the last days from previous month item.

Returns
Boolean value that determines if the days before this month are visible. TRUE if the days before this month are visible. Otherwise FALSE.
See also
SetShowDaysBefore(BOOL bShow)
SetShowDaysAfter(BOOL bShow)
GetShowDaysAfter()

◆ GetShowLeftScroll()

AFX_INLINE BOOL GetShowLeftScroll ( ) const

Call this member function to determine if the left scroll triangle is visible.

This option allows using scrolling facilities to find and work with month items that currently are not shown in the control. ScrollV to desired month item using the scroll triangle icon.

Returns
Boolean value determines if the left scroll triangle is visible. TRUE - If the left scroll triangle is visible. FALSE - If the left scroll triangle is not visible.
See also
GetShowRightScroll
SetShowScrolling

◆ GetShowRightScroll()

AFX_INLINE BOOL GetShowRightScroll ( ) const

Call this member function to determine if the right scroll triangle is visible.

This option allows scrolling facilities to find and work with month items that currently are not shown in the control. ScrollV to desired month item using the scroll triangle icon.

Returns
Boolean value that determines if the right scroll triangle is visible. TRUE - If the right scroll triangle is visible. FALSE - If the right scroll triangle is not visible.
See also
GetShowLeftScroll
SetShowScrolling

◆ HitTest()

CXTPDatePickerItemDay * HitTest | ( | CPoint | point,
 |  | BOOL | bCheckVisible = TRUE ) const

Call this function to return the day where the mouse cursor was located when the left mouse button was clicked.

Parameters
point | A CPoint object that specifies the x- and y- coordinates of the cursor.
bCheckVisible | TRUE when check visibility flag of the day item. If this parameter is FALSE, the method would return pointer to the corresponding day item even if this day is hidden (for example days from previous month). It is TRUE by default.

This member function is heavily used by all event handlers to determine the item that was disturbed by the mouse pointer. If item was found, then the function returns a pointer to item, otherwise NULL is returned.

Returns
Returns a pointer to the affected day item. Returns NULL if the left mouse button was clicked outside any day area.

◆ OnLButtonDown()

void OnLButtonDown | ( | UINT | nFlags,
 |  | CPoint | point )
 protected

This member function is called to process left button down mouse messages.

Parameters
nFlags | A UINT that is used to indicate whether various virtual keys are down.
point | A CPoint object that specifies the x- and y- coordinates of the cursor.

This function is called from control event handlers.

◆ OnLButtonUp()

void OnLButtonUp | ( | UINT | nFlags,
 |  | CPoint | point )
 protected

This member function is called to process left button up mouse messages.

Parameters
nFlags | A UINT that indicates whether various virtual keys are down.
point | A CPoint object that specifies the x- and y- coordinates of the cursor.

This function is called from control event handlers.

◆ OnMouseMove()

void OnMouseMove | ( | UINT | nFlags,
 |  | CPoint | point )
 protected

This function is called to process mouse move messages.

Parameters
nFlags | A UINT that indicates whether various virtual keys are down.
point | A CPoint object that specifies the x- and y- coordinates of the cursor.

This function is called from control event handlers.

◆ OnSetCursor()

BOOL OnSetCursor ( CPoint point )
protected

This member function is called to process changing cursor message.

Parameters
point A CPoint object that specifies the x- and y- coordinates of the cursor.

This function is called from control event handlers.

Returns
Nonzero to halt further processing, or 0 to continue.

◆ PopulateDays()

void PopulateDays ( )
protected

Call this member function to populate the day objects.

Creates days objects based on the current settings.

◆ SetShowDaysAfter()

AFX_INLINE void SetShowDaysAfter ( BOOL bShow )

Call this member function to set whether days after this month are shown.

Parameters
bShow Boolean value that determines if the days after this month are displayed. TRUE if the days after this month are visible. FALSE if the days after this month are not visible.

This option allows changing the behavior of the control in the following way: If the last day of month is Wednesday you may wish to leave places for remaining day items empty or display the beginning days from next month item.

See also
GetShowDaysAfter()

◆ SetShowDaysBefore()

AFX_INLINE void SetShowDaysBefore ( BOOL bShow )

Call this member function to set whether days before this month are shown.

Parameters
bShow Boolean value that determines if the days before this month are displayed. TRUE if the days before this month are shown. FALSE if the days before this month are not shown.

This option allows changing the behavior of the control in the following way: If the first day of the month is Wednesday you may leave places for Monday and Tuesday items empty or display the last days from the previous month item.

See also
GetShowDaysBefore()

◆ SetShowScrolling()

AFX_INLINE void SetShowScrolling | ( | BOOL | bLeftScroll,
 |  | BOOL | bRightScroll )

Call this member function to add the left and the right scrolling triangles.

Parameters
bLeftScroll | Boolean value determines if the left scroll triangle is visible. TRUE Left scrolling triangle is visible. Right scrolling triangle is visible. FALSE Left scrolling triangle is not visible. Right scrolling triangle is not visible.
bRightScroll | Boolean value determines if the right scroll triangle is visible.

This option allows scrolling facilities to find and work with month items that currently aren't shown in the control. ScrollV to the desired month item using the scroll triangle icon. In some cases scrolling is not needed, and you can hide one or both scrolling triangles.

See also
GetShowLeftScroll
GetShowRightScroll

Member Data Documentation

◆ m_bShowDaysAfter

BOOL m_bShowDaysAfter

This member variable is a BOOL that is used to indicate if the "days after this month" are visible.

The valid values are TRUE if the "days after this month" are visible, otherwise FALSE.

◆ m_bShowDaysBefore

BOOL m_bShowDaysBefore

This member variable is a BOOL that is used to determine if the "days before this month" are visible.

The valid values are TRUE if the "days before this month" are visible, otherwise false.

◆ m_bShowLeftScroll

BOOL m_bShowLeftScroll

This member variable is a BOOL that is used to determine if the "left scroll triangle" is visible.

The valid values are TRUE if the "left scroll triangle" is visible, otherwise false.

◆ m_bShowRightScroll

BOOL m_bShowRightScroll

This member variable is a BOOL that is used to determine if the "right scroll triangle" is visible.

The valid values are TRUE if the "right scroll triangle" is visible, otherwise false.

The documentation for this class was generated from the following file:
  • XTPDatePickerItemMonth.h


Toolkit Pro: CXTPDatePickerList Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPDatePickerList Class Reference

This class provides the functionality of a list control which displays month names. More...

Public Member Functions

CXTPDatePickerList (CXTPDatePickerControl *pControl, COleDateTime dtStartMonth)
Constructs a CXTPDatePickerList object.
virtual | ~CXTPDatePickerList ()
Destroys a CXTPDatePickerList object, handles cleanup and deallocation.
BOOL | Create (CRect rcList)
Creates the List Window with position and sizes.
int | GetMonthInterval () const
Returns an interval between start month and selected month.
void | ScrollDown (int nCount=1)
Implements scroll down functionality.
void | ScrollUp (int nCount=1)
Implements scroll up functionality.

Protected Member Functions

CSize | GetListSize () const
Calculates size of list by font and control sizes.
BOOL | IsSelected (int nX, CRect rcItem) const
Determines whether an item is selected.

Protected Attributes

CXTPDatePickerControl * | m_pControl
Pointer to the parent control.
COleDateTime | m_dtStartMonth
The month to start selection from (will be placed in the middle of the list for the beginning).
COleDateTime | m_dtMiddleMonth
The month currently in center.
COleDateTime | m_dtSelMonth
Currently selected month in the list.
int | m_nItemsAbove
How many items are from the top of the middle item on the list.
int | m_nItemsBelow
How many items are from the bottom of the middle item on the list.
CRect | m_rcListControl
Coordinates of list control in screen coordinates.

Detailed Description

This class provides the functionality of a list control which displays month names.

The CXTPDatePickerList provides a functionality of a list control which displays a collection of month names in a pop-up list window, allowing the user to scroll up and down and to choose any specific month for further selecting in the date picker control.

See also
CMonthCalCtrl

Constructor & Destructor Documentation

◆ CXTPDatePickerList()

CXTPDatePickerList | ( | CXTPDatePickerControl * | pControl,
 |  | COleDateTime | dtStartMonth )

Constructs a CXTPDatePickerList object.

Parameters
pControl | Pointer to the parent CXTPDatePickerControl object.
dtStartMonth | A date containing the month which will be created as the central item in the list.

Construct a CXTPDatePickerList object in two steps. First, call the constructor CXTPDatePickerList and then call Create method, which initializes the window.

Example:

// Declare a dynamic CXTPDatePickerList object.
pListControl = new CXTPDatePickerList(pDatePickerWnd, dtMonthToShow);

// create control
pListControl->Create(rcHeader);
See also
Create

Member Function Documentation

◆ Create()

BOOL Create ( CRect rcList )

Creates the List Window with position and sizes.

Parameters
rcList Rectangle determining list window position and size.

Construct a CXTPDatePickerList object in two steps. First, call the constructor CXTPDatePickerList and then call Create method, which initializes the window. Example: For the example, see CXTPDatePickerList::CXTPDatePickerList.

Returns
Nonzero if successful; otherwise 0.
See also
CXTPDatePickerList::CXTPDatePickerList

◆ GetListSize()

CSize GetListSize ( ) const
protected

Calculates size of list by font and control sizes.

Returns
A size of the list to create.

◆ GetMonthInterval()

int GetMonthInterval ( ) const

Returns an interval between start month and selected month.

Call this member function at any time to determine which month is currently selected in the list.

Returns
A number of months between start month and selected one.

◆ IsSelected()

BOOL IsSelected | ( | int | nX,
 |  | CRect | rcItem ) const
 protected

Determines whether an item is selected.

Parameters
nX | Item zero-based numeric index from the beginning of the list.
rcItem | Coordinates of the item to check.
Returns
TRUE if item is selected, FALSE otherwise.

◆ ScrollDown()

void ScrollDown ( int nCount = 1 )

Implements scroll down functionality.

Parameters
nCount determines how many positions will be scrolled.

Call this member function to scroll the list with months down by a specified amount of items.

See also
ScrollUp

◆ ScrollUp()

void ScrollUp ( int nCount = 1 )

Implements scroll up functionality.

Parameters
nCount Determines how many positions will be scrolled.

Call this member function to scroll the list with months up by a specified amount of items.

See also
ScrollDown
The documentation for this class was generated from the following file:
  • XTPDatePickerList.h


Toolkit Pro: CXTPDatePickerPaintManager Class Reference

Public Member Functions | Public Attributes | Protected Member Functions | Protected Attributes | List of all members
CXTPDatePickerPaintManager Class Reference

Class CXTPDatePickerPaintManager handles most of the drawing activities for the DatePicker control. More...

Inheritance diagram for CXTPDatePickerPaintManager:
[legend]

Public Member Functions

CXTPDatePickerPaintManager ()
Default paint manager constructor.
virtual | ~CXTPDatePickerPaintManager ()
Default paint manager destructor.
virtual void | RefreshMetrics ()
This member function performs initialization for the Paint Manager.
virtual void | DrawBackground (CDC *pDC, CRect rcClient)
This member function is called to fill the control's background.
virtual void | DrawBorder (CDC *pDC, const CXTPDatePickerControl *pControl, CRect &rcClient, BOOL bDraw)
This member function draws a border around the control.
virtual void | DrawScrollTriangle (CDC *pDC, CRect rcSpot, BOOL bLeftDirection, COLORREF clrColor=0, BOOL bYears=FALSE)
This member function draws scrolling triangles on the highest bounded month headers.
virtual COLORREF | GetControlBackColor ()
This member function is used to obtain the control's background color.
virtual COLORREF | GetDayBackColor ()
This member function is used to obtain the background color of the standard day item.
virtual COLORREF | GetDayTextColor ()
This member function is used to obtain the color of the standard day item.
virtual CFont * | GetDayTextFont ()
This member function is used to obtain a pointer to the font for the standard day item.
virtual CFont * | GetDayTextFontBold ()
This member function is used to obtain a pointer to the font for the bolded day item.
virtual COLORREF | GetNonMonthDayBackColor ()
This member function is used to obtain the background color of the non-month day item.
virtual COLORREF | GetNonMonthDayTextColor ()
This member function is used to obtain the color of the non-month day item.
CFont * | GetNonMonthDayTextFont ()
This member function is used to obtain the font of the non-month day item.
virtual COLORREF | GetSelectedDayBackColor ()
This member function is used to obtain the background color of the selected day item.
virtual COLORREF | GetSelectedDayTextColor ()
This member function obtains the color of the selected day item.
virtual COLORREF | GetMonthHeaderBackColor ()
This member function obtains the background color of the month header area.
virtual COLORREF | GetMonthHeaderTextColor ()
This member function obtains the text color of the month header area.
CFont * | GetHeaderTextFont ()
This member function obtains the font of the month header area text.
virtual COLORREF | GetDaysOfWeekBackColor ()
This member function returns the background color of the days of weeks area.
virtual COLORREF | GetDaysOfWeekTextColor ()
This member function obtains the text color of the days of weeks area.
CFont * | GetDaysOfWeekTextFont ()
This member function obtains the font of the days of weeks area text.
virtual COLORREF | GetWeekNumbersBackColor ()
This member function obtains the background color of the week numbers area.
virtual COLORREF | GetWeekNumbersTextColor ()
This member function obtains the text color of the week numbers items.
CFont * | GetWeekNumbersTextFont ()
This member function obtains the font of the week numbers items.
virtual COLORREF | GetListControlBackColor ()
This member function obtains the background color of the pop-up month list control.
virtual COLORREF | GetListControlTextColor ()
This member function obtains the text color of the pop-up month list control.
CFont * | GetListControlTextFont ()
This member function obtains the font of the pop-up month list control.
virtual COLORREF | GetHighlightTodayColor ()
This member function obtains the highlighting color of the "Today" item.
void | SetButtonFont (CFont *fontButton)
This member function sets the button's font.
void | SetButtonFontIndirect (LOGFONT *lFont)
This member function sets the button's font using a LOGFONT structure.
CFont * | GetButtonFont ()
This member function is used to obtain the button's font object.
void | SetFontIndirect (LOGFONT *lFont)
This member function is used to set the control's default font using a LOGFONT structure.
virtual void | DrawButton (CDC *pDC, const CRect &rcButton, const CString &strButton, BOOL bIsDown, BOOL bIsHighLight)
This member function is used to draw the control's buttons.
virtual BOOL | DrawDay (CDC *pDC, CXTPDatePickerItemDay *pDay)
Call this member function to draw a single month day in the month area.
virtual void | DrawMonthHeader (CDC *pDC, CXTPDatePickerItemMonth *pMonth)
Call this member function to draw the month header in the month area.
virtual void | DrawWeekNumbers (CDC *pDC, CXTPDatePickerItemMonth *pMonth)
Call this member function to draw the week numbers in the month area.
virtual void | DrawDaysOfWeek (CDC *pDC, CXTPDatePickerItemMonth *pMonth)
Call this member function to draw the days of the week in the month header.
virtual CSize | CalcDayRect (CDC *pDC)
This member function is used to calculate the day's bounding rectangle coordinates.
virtual CSize | CalcMonthHeaderRect (CDC *pDC)
This member function calculates the month's header bounding rectangle coordinates.
virtual CSize | CalcDayOfWeekRect (CDC *pDC)
This member function calculates the "day of week names" bounding rectangle coordinates.
virtual CSize | CalcWeekNumbersRect (CDC *pDC)
This member function calculates the "week numbers" bounding rectangle coordinates.
virtual CSize | CalcMonthRect (CDC *pDC)
This member function calculates the month's bounding rectangle coordinates.
virtual void | EnableTheme (BOOL bEnableTheme)
This member function is used to switch "Themes".
virtual HCURSOR | GetCursorBack ()
This member function is used to obtain the back cursor used for weeks selection.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Public Attributes

CSize | m_szDayMargin
This member function is used to set current paint theme.
CXTPPaintManagerColor | m_clrControlBack
This member variable is a COLORREF object that is used as the background color of the control.
CXTPPaintManagerColor | m_clrHighlightToday
This member variable is a COLORREF object that is used as the color for highlighting the "Today" item.
CXTPPaintManagerColor | m_clrSelectedDayBack
This member variable is a COLORREF object that is used as the background color of the selected day item.
CXTPPaintManagerColor | m_clrMonthHeaderBack
This member variable is a COLORREF object that is used as the background color of the month header area.
CXTPPaintManagerColor | m_clrMonthHeaderText
This member variable is a COLORREF object that is used as the text color of the month header area.
CXTPPaintManagerColor | m_clrSelectedDayText
This member variable is a COLORREF object that is used as the color of the selected day item.
CXTPPaintManagerColor | m_clrMonthBorder
This member variable is a COLORREF object that is used as the color of the border between day of month and week numbers or days of week.
CXTPPaintManagerColor | m_clrMonthHeaderButton
This member variable is a COLORREF object that is used as the color for the scroll's triangle button.
CXTPPaintManagerColor | m_clrDayBack
This member variable is a COLORREF object that is used as the background color of the normal day item.
CXTPPaintManagerColor | m_clrDayText
This member variable is a COLORREF object that is used as the color of the usual day item.
CXTPPaintManagerColor | m_clrNonMonthDayBack
This member variable is a COLORREF object that is used as the background color of the non-month day item.
CXTPPaintManagerColor | m_clrNonMonthDayText
This member variable is a COLORREF object that is used as the color of the non-month day item.
CXTPPaintManagerColor | m_clrDaysOfWeekBack
This member variable is a COLORREF object that is used for the background color of the days of weeks area.
CXTPPaintManagerColor | m_clrDaysOfWeekText
This member variable is a COLORFEF object that is used as the text color of the days of weeks area.
CXTPPaintManagerColor | m_clrWeekNumbersBack
This member variable is a COLORREF object that is used as the background color of the week numbers area.
CXTPPaintManagerColor | m_clrWeekNumbersText
This member variable is a COLORREF object that is used as the text color of the week numbers items.
CXTPPaintManagerColor | m_clrButtonText
This member variable is a COLORREF object that is used as the color for the button text.
CXTPPaintManagerColor | m_clrButtonFace
This member variable is a COLORREF object that is used as the basic color for buttons.
CXTPPaintManagerColor | m_clrListControlBack
This member variable is a COLORREF object that is used as the background color of the pop-up month list control.
CXTPPaintManagerColor | m_clrListControlText
This member variable is a COLORREF object that is used as the text color of the pop-up month list control.

Protected Member Functions

virtual void | Triangle (CDC *pDC, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clrColor=0)
This member function is used to draw a black triangle.
XTPCalendarTheme | GetPaintTheme () const
This member function is used to obtain current paint theme.

Protected Attributes

COLORREF | m_clrStaticBorder
Static border color.
COLORREF | m_clr3DShadow
This member variable is a COLORREF object that is used to specify the color for shadow areas.
COLORREF | m_clr3DLight
This member variable is a COLORREF object that is used to specify the color for light areas.
COLORREF | m_clr3DFace
This member variable is a COL ORREF object that is used as the color for the button text.
COLORREF | m_clr3DText
This member variable is a COLORREF object that is used as the basic color for buttons.
CXTPFont | m_xtpFontDay
This member variable is a CXTPFont object that is used for the font -of the usual day item.
CXTPFont | m_xtpFontDayBold
This member variable is a CXTPFont object that is used for the font -of the bold day item.
CXTPFont | m_xtpFontNonMonthDay
This member variable is a CXTPFont object that is used as the font for the non-month day item.
CXTPFont | m_xtpFontHeader
This member variable is a CXTPFont object that is used as the font for the header text.
CXTPFont | m_xtpFontDaysOfWeek
This member variable is a CXTPFont object that is used as the font for the days of weeks text.
CXTPFont | m_xtpFontWeekNumbers
This member variable is a CXTPFont object that is used as the font for the week number items text.
CXTPFont | m_xtpFontListControl
This member variable is a CXTPFont object that is used as the font for the pop-up month list control.
CXTPFont | m_xtpFontButton
This member variable is a CXTPFont object that is used as the font for the button text.
BOOL | m_bEnableTheme
This member variable is a BOOL that is used to indicate if Luna colors are enabled.
CXTPWinThemeWrapper * | m_themeButton
This member variable is a CXTPWinThemeWrapper object that is used as the theme wrapper for the Paint Manager.
HCURSOR | m_hCursorBack
Back cursor for week selection.
XTPCalendarTheme | m_nPaintTheme
Store the Paint Theme;.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

Class CXTPDatePickerPaintManager handles most of the drawing activities for the DatePicker control.

Utility class, handles most of the drawing activities. It stores all settings needed by the control to perform drawing operations: fonts, colors, styles for all others classes of control. It also implements all functions for drawing typical graphical primitives, functions that directly work with the device context. Can be -overridden to provide another look and feel for the control. Thus, you have an easy way to change the "skin" of your control. Provide your own implementation of CXTPDatePickerPaintManager and do not change the functionality all other classes of the control.

Create a DatePickerPaintManager by calling its constructor. Furthermore, call the "get" and "set" functions to change the settings as needed.

Constructor & Destructor Documentation

◆ CXTPDatePickerPaintManager()

CXTPDatePickerPaintManager ( )

Default paint manager constructor.

Handles initial initialization.

See also
RefreshMetrics()

◆ ~CXTPDatePickerPaintManager()

virtual ~CXTPDatePickerPaintManager ( )
virtual

Default paint manager destructor.

Handles member item deallocation.

Member Function Documentation

◆ CalcDayOfWeekRect()

virtual CSize CalcDayOfWeekRect ( CDC * pDC )
virtual

This member function calculates the "day of week names" bounding rectangle coordinates.

Parameters
pDC Pointer to a valid device context.

Calculates the "day of week names" bounding rectangle coordinates for the given device context's current header font.

Returns
A CSize object that contains the "day of week names" rectangle coordinates.

◆ CalcDayRect()

virtual CSize CalcDayRect ( CDC * pDC )
virtual

This member function is used to calculate the day's bounding rectangle coordinates.

Parameters
pDC Pointer to a valid device context.

This member function calculates the day's bounding rectangle coordinates for the given device context current day's font.

Returns
A CSize object containing the day's bounding rectangle coordinates.

◆ CalcMonthHeaderRect()

virtual CSize CalcMonthHeaderRect ( CDC * pDC )
virtual

This member function calculates the month's header bounding rectangle coordinates.

Parameters
pDC Pointer to a valid device context.

This member function calculates the month's header bounding rectangle coordinates for the given device context's current header font.

Returns
A CSize object containing the month's header bounding rectangle coordinates.

◆ CalcMonthRect()

virtual CSize CalcMonthRect ( CDC * pDC )
virtual

This member function calculates the month's bounding rectangle coordinates.

Parameters
pDC Pointer to a valid device context.

Calculates the Month's bounding rectangle coordinates for the given device context's current header font.

Returns
A CSize object that contains the month's bounding rectangle coordinates.

◆ CalcWeekNumbersRect()

virtual CSize CalcWeekNumbersRect ( CDC * pDC )
virtual

This member function calculates the "week numbers" bounding rectangle coordinates.

Parameters
pDC Pointer to a valid device context.

Calculates the "week numbers" bounding rectangle coordinates for the given device context's current header font.

Returns
A CSize object that contains the "week numbers" bounding rectangle coordinates.

◆ DrawBackground()

virtual void DrawBackground | ( | CDC * | pDC,
 |  | CRect | rcClient )
 virtual

This member function is called to fill the control's background.

Parameters
pDC | Pointer to a valid device context.
rcClient | A CRect that contains the control's client area rectangle coordinates.

Reimplemented in CXTPDatePickerThemeOffice2013.

◆ DrawBorder()

virtual void DrawBorder | ( | CDC * | pDC,
 |  | const CXTPDatePickerControl * | pControl,
 |  | CRect & | rcClient,
 |  | BOOL | bDraw )
 virtual

This member function draws a border around the control.

Parameters
pDC | Pointer to a valid device context.
pControl | Pointer to a CXTPDatePickerControl object.
rcClient | A CRect that contains the control's client area rectangle coordinates.
bDraw | TRUE to draw else Adjust client rectangle.

Reimplemented in CXTPDatePickerThemeOffice2013.

◆ DrawButton()

virtual void DrawButton | ( | CDC * | pDC,
 |  | const CRect & | rcButton,
 |  | const CString & | strButton,
 |  | BOOL | bIsDown,
 |  | BOOL | bIsHighLight )
 virtual

This member function is used to draw the control's buttons.

Parameters
pDC | Pointer to a valid device context.
rcButton | A CRect that contains the button area bounding rectangle coordinates.
strButton | A CString that contains the string of the button's text.
bIsDown | A BOOL that determines if the button is down or up.
bIsHighLight | A BOOL that determines if the button is highlighted.

Use this member function to draw buttons in the appropriate state. The state depends on the bIsDown parameter, the button may be drawn pressed or released. Furthermore, depending on the bIsHighLight, the button may be drawn with highlighted borders.

Example:

for (int i = 0; i < GetButtonCount(); i++)
{
   CXTPDatePickerButton* pButton = GetButton(i);
   if (pButton->m_bVisible)
      DrawButton(pDC, pButton->m_rcButton, pButton->m_strCaption,
      pButton->m_bPressed, pButton->m_bHighlight);
}

Reimplemented in CXTPDatePickerThemeOffice2003, CXTPDatePickerThemeOffice2013, and CXTPDatePickerThemeResource.

◆ DrawDay()

virtual BOOL DrawDay | ( | CDC * | pDC,
 |  | CXTPDatePickerItemDay * | pDay )
 virtual

Call this member function to draw a single month day in the month area.

Parameters
pDC | Pointer to a valid device context.
pDay | Pointer to day object.
Returns
TRUE if the drawing is successful, FALSE else.

It is called from the CXTPDatePickerItemDay implementation. You can override it to customize drawing.

Reimplemented in CXTPDatePickerThemeOffice2013.

◆ DrawDaysOfWeek()

virtual void DrawDaysOfWeek | ( | CDC * | pDC,
 |  | CXTPDatePickerItemMonth * | pMonth )
 virtual

Call this member function to draw the days of the week in the month header.

Parameters
pDC | Pointer to a valid device context.
pMonth | Pointer to month object.

It is called from the CXTPDatePickerItemMonth implementation. You can override it to customize drawing.

Reimplemented in CXTPDatePickerThemeOffice2013.

◆ DrawMonthHeader()

virtual void DrawMonthHeader | ( | CDC * | pDC,
 |  | CXTPDatePickerItemMonth * | pMonth )
 virtual

Call this member function to draw the month header in the month area.

Parameters
pDC | Pointer to a valid device context.
pMonth | Pointer to month object.

It is called from the CXTPDatePickerItemMonth implementation. You can override it to customize drawing.

Reimplemented in CXTPDatePickerThemeOffice2000.

◆ DrawScrollTriangle()

virtual void DrawScrollTriangle | ( | CDC * | pDC,
 |  | CRect | rcSpot,
 |  | BOOL | bLeftDirection,
 |  | COLORREF | clrColor = 0,
 |  | BOOL | bYears = FALSE )
 virtual

This member function draws scrolling triangles on the highest bounded month headers.

Parameters
pDC | Pointer to a valid device context.
rcSpot | A CRect object that contains the coordinates of the triangle spot area.
bLeftDirection | A BOOL that is used to determine the triangle direction. TRUE the left scrolling triangle is drawn.FALSE the right scrolling triangle is drawn.
clrColor | The triangle color
bYears | BOOL flag to show or hide arrow to scroll by years

◆ DrawWeekNumbers()

virtual void DrawWeekNumbers | ( | CDC * | pDC,
 |  | CXTPDatePickerItemMonth * | pMonth )
 virtual

Call this member function to draw the week numbers in the month area.

Parameters
pDC | Pointer to a valid device context.
pMonth | Pointer to month object.

It is called from the CXTPDatePickerItemMonth implementation. You can override it to customize drawing.

Reimplemented in CXTPDatePickerThemeOffice2013.

◆ EnableTheme()

AFX_INLINE void EnableTheme ( BOOL bEnableTheme )
virtual

This member function is used to switch "Themes".

Parameters
bEnableTheme A BOOL that is used as a flag to indicate if themes are enabled. Set to TRUE if themes are enabled, FALSE if themes are not enabled.

◆ GetButtonFont()

AFX_INLINE CFont * GetButtonFont ( )

This member function is used to obtain the button's font object.

Returns
A pointer to the button's CFont object.
See also
SetButtonFontIndirect(LOGFONT* lFont)
SetButtonFont(CFont* fontButton)

◆ GetControlBackColor()

AFX_INLINE COLORREF GetControlBackColor ( )
virtual

This member function is used to obtain the control's background color.

Returns
The color used to fill the control's client rectangle.

◆ GetCursorBack()

AFX_INLINE HCURSOR GetCursorBack ( )
virtual

This member function is used to obtain the back cursor used for weeks selection.

Returns
A handle of the loaded cursor.

◆ GetDayBackColor()

AFX_INLINE COLORREF GetDayBackColor ( )
virtual

This member function is used to obtain the background color of the standard day item.

Returns
A COLORREF object that contains the background color of the standard day item.

◆ GetDaysOfWeekBackColor()

AFX_INLINE COLORREF GetDaysOfWeekBackColor ( )
virtual

This member function returns the background color of the days of weeks area.

Returns
A COLORREF object containing the background color of the days of weeks area.

◆ GetDaysOfWeekTextColor()

AFX_INLINE COLORREF GetDaysOfWeekTextColor ( )
virtual

This member function obtains the text color of the days of weeks area.

Returns
A COLORREF object containing the text color of the days of weeks area.

◆ GetDaysOfWeekTextFont()

AFX_INLINE CFont * GetDaysOfWeekTextFont ( )

This member function obtains the font of the days of weeks area text.

Returns
A pointer to a CFont object that contains the font of the days of weeks area text.

◆ GetDayTextColor()

AFX_INLINE COLORREF GetDayTextColor ( )
virtual

This member function is used to obtain the color of the standard day item.

Returns
A COLORREF object that contains the color of the standard day item.

◆ GetDayTextFont()

AFX_INLINE CFont * GetDayTextFont ( )
virtual

This member function is used to obtain a pointer to the font for the standard day item.

Example:

// Get the font and extract a LOGGFONT structure.
LOGFONT lf;
GetDayTextFont()->GetLogFont(&lf);
// Create new italic font.
lf.lfItalic = 1;
CFont fontItalic;
Italic.CreateFontIndirect(&lf);
Returns
A pointer to a CFont object that contains the standard day item font.

◆ GetDayTextFontBold()

AFX_INLINE CFont * GetDayTextFontBold ( )
virtual

This member function is used to obtain a pointer to the font for the bolded day item.

Returns
A pointer to a CFont object that contains the bold day item font.

◆ GetHeaderTextFont()

AFX_INLINE CFont * GetHeaderTextFont ( )

This member function obtains the font of the month header area text.

Returns
A CFont object that contains the font of the month header area text.

◆ GetHighlightTodayColor()

AFX_INLINE COLORREF GetHighlightTodayColor ( )
virtual

This member function obtains the highlighting color of the "Today" item.

Returns
A COLORREF object that contains the highlighting color of the "Today" item.

◆ GetListControlBackColor()

AFX_INLINE COLORREF GetListControlBackColor ( )
virtual

This member function obtains the background color of the pop-up month list control.

Returns
A COLORREF object that contains the background color of the pop-up month list control.

◆ GetListControlTextColor()

AFX_INLINE COLORREF GetListControlTextColor ( )
virtual

This member function obtains the text color of the pop-up month list control.

Returns
A COLORREF object that contains the text color of the pop-up month list control.

◆ GetListControlTextFont()

AFX_INLINE CFont * GetListControlTextFont ( )

This member function obtains the font of the pop-up month list control.

Returns
A pointer to a CFont object that contains the font of the pop-up month list control.

◆ GetMonthHeaderBackColor()

AFX_INLINE COLORREF GetMonthHeaderBackColor ( )
virtual

This member function obtains the background color of the month header area.

Returns
A COLORREF object containing the background color of the month header area.

◆ GetMonthHeaderTextColor()

AFX_INLINE COLORREF GetMonthHeaderTextColor ( )
virtual

This member function obtains the text color of the month header area.

Returns
A COLORREF object containing the text color of the month header area.

◆ GetNonMonthDayBackColor()

AFX_INLINE COLORREF GetNonMonthDayBackColor ( )
virtual

This member function is used to obtain the background color of the non-month day item.

Returns
A COLORREF object that contains the background color of the non month day item.

◆ GetNonMonthDayTextColor()

AFX_INLINE COLORREF GetNonMonthDayTextColor ( )
virtual

This member function is used to obtain the color of the non-month day item.

Returns
A COLORREF object that contains the color of the non-month day item.

◆ GetNonMonthDayTextFont()

AFX_INLINE CFont * GetNonMonthDayTextFont ( )

This member function is used to obtain the font of the non-month day item.

Example:

// Get the font and extract a LOGGFONT structure.
LOGFONT lf;
GetNonMonthDayTextFont->GetLogFont(&lf);
// Create new old font
lf.lfWeight = FW_BOLD;
CFont fontBold;
fntBold.CreateFontIndirect(&lf);
Returns
Pointer to a CFont object that contains the font of the non-month day item.

◆ GetPaintTheme()

AFX_INLINE XTPCalendarTheme GetPaintTheme ( ) const
protected

This member function is used to obtain current paint theme.

Returns
A paint theme ID from enum XTPCalendarTheme.

◆ GetSelectedDayBackColor()

AFX_INLINE COLORREF GetSelectedDayBackColor ( )
virtual

This member function is used to obtain the background color of the selected day item.

Returns
A COLORREF object that contains the background color of the selected day item.

◆ GetSelectedDayTextColor()

AFX_INLINE COLORREF GetSelectedDayTextColor ( )
virtual

This member function obtains the color of the selected day item.

Returns
A COLORREF object that contains the color of the selected day item.

◆ GetWeekNumbersBackColor()

AFX_INLINE COLORREF GetWeekNumbersBackColor ( )
virtual

This member function obtains the background color of the week numbers area.

Returns
A COLORREF object that contains the background color of the week numbers area.

◆ GetWeekNumbersTextColor()

AFX_INLINE COLORREF GetWeekNumbersTextColor ( )
virtual

This member function obtains the text color of the week numbers items.

Returns
A COLORREF object that contains the text color of the week numbers items.

◆ GetWeekNumbersTextFont()

AFX_INLINE CFont * GetWeekNumbersTextFont ( )

This member function obtains the font of the week numbers items.

Returns
A pointer to a CFont object that contains the font of the week numbers items.

◆ RefreshMetrics()

virtual void RefreshMetrics ( )
virtual

This member function performs initialization for the Paint Manager.

Initializes all drawing defaults (fonts, colors, etc.). Most of defaults are system defaults.

Reimplemented in CXTPDatePickerThemeOffice2003, CXTPDatePickerThemeOffice2013, and CXTPDatePickerThemeResource.

◆ SetButtonFont()

void SetButtonFont ( CFont * fontButton )

This member function sets the button's font.

Parameters
fontButton A CFont pointer to the button's font object.

Call this function to set the new button's font from the provided CFont object.

See also
SetButtonFontIndirect(LOGFONT*)
GetButtonFont()

◆ SetButtonFontIndirect()

void SetButtonFontIndirect ( LOGFONT * lFont )

This member function sets the button's font using a LOGFONT structure.

Parameters
lFont Pointer to the LOGFONT structure.

This member function creates and sets the new button's font from the given LOGFONT structure.

See also
SetButtonFont(CFont*)
GetButtonFont()

◆ SetFontIndirect()

void SetFontIndirect ( LOGFONT * lFont )

This member function is used to set the control's default font using a LOGFONT structure.

Parameters
lFont Pointer to the LOGFONT structure.

This member function creates and sets the control's new default font from the given LOGFONT structure.

◆ Triangle()

virtual void Triangle | ( | CDC * | pDC,
 |  | CPoint | pt0,
 |  | CPoint | pt1,
 |  | CPoint | pt2,
 |  | COLORREF | clrColor = 0 )
 protectedvirtual

This member function is used to draw a black triangle.

Parameters
pDC | Pointer to a valid device context.
pt0 | Apex coordinate.
pt1 | Apex coordinate.
pt2 | Apex coordinate.
clrColor | The triangle color.

Member Data Documentation

◆ m_bEnableTheme

BOOL m_bEnableTheme
protected

This member variable is a BOOL that is used to indicate if Luna colors are enabled.

The valid values are TRUE to enable Luna colors, otherwise FALSE.

◆ m_szDayMargin

CSize m_szDayMargin

This member function is used to set current paint theme.

Parameters
ePaintTheme A paint theme ID from enum XTPCalendarTheme.
The documentation for this class was generated from the following file:
  • XTPDatePickerPaintManager.h


Toolkit Pro: CXTPDatePickerThemeNativeWindows10 Class Reference

Public Member Functions | List of all members
CXTPDatePickerThemeNativeWindows10 Class Reference

Class CXTPDatePickerThemeNativeWindows10 is derived from CXTPDatePickerThemeOffice2013 for rendering an Native Windows 10 style for DatePicker control. More...

Inheritance diagram for CXTPDatePickerThemeNativeWindows10:
[legend]

Public Member Functions

CXTPDatePickerThemeNativeWindows10 ()
Default paint manager constructor.
virtual | ~CXTPDatePickerThemeNativeWindows10 ()
Default paint manager destructor.
- Public Member Functions inherited from CXTPDatePickerThemeOffice2013
CXTPDatePickerThemeOffice2013 ()
Default paint manager constructor.
virtual | ~CXTPDatePickerThemeOffice2013 ()
Default paint manager destructor.
virtual void | RefreshMetrics ()
This member function performs initialization for the Paint Manager.
virtual void | DrawBackground (CDC *pDC, CRect rcClient)
This member function is called to fill the control's background.
virtual void | DrawWeekNumbers (CDC *pDC, CXTPDatePickerItemMonth *pMonth)
Call this member function to draw the week numbers in the month area.
virtual void | DrawDaysOfWeek (CDC *pDC, CXTPDatePickerItemMonth *pMonth)
Call this member function to draw the days of the week in the month header.
virtual void | DrawBorder (CDC *pDC, const CXTPDatePickerControl *pControl, CRect &rcClient, BOOL bDraw)
This member function draws a border around the control.
virtual BOOL | DrawDay (CDC *pDC, CXTPDatePickerItemDay *pDay)
Call this member function to draw a single month day in the month area.
virtual void | DrawButton (CDC *pDC, const CRect &rcButton, const CString &strButton, BOOL bIsDown, BOOL bIsHighLight)
This member function is used to draw the control's buttons.
virtual COLORREF | GetHighlightTodayBackColor ()
Call this member function to retrieve the background color for the highlight today item.
virtual COLORREF | GetHighlightTodayTextColor ()
Call this member function to retrieve the foreground (text) color for the highlight today item.
virtual COLORREF | GetHighlightTodayBorderColor ()
Call this member function to retrieve the Border color for the highlight today item.
- Public Member Functions inherited from CXTPDatePickerPaintManager
CXTPDatePickerPaintManager ()
Default paint manager constructor.
virtual | ~CXTPDatePickerPaintManager ()
Default paint manager destructor.
virtual void | DrawScrollTriangle (CDC *pDC, CRect rcSpot, BOOL bLeftDirection, COLORREF clrColor=0, BOOL bYears=FALSE)
This member function draws scrolling triangles on the highest bounded month headers.
virtual COLORREF | GetControlBackColor ()
This member function is used to obtain the control's background color.
virtual COLORREF | GetDayBackColor ()
This member function is used to obtain the background color of the standard day item.
virtual COLORREF | GetDayTextColor ()
This member function is used to obtain the color of the standard day item.
virtual CFont * | GetDayTextFont ()
This member function is used to obtain a pointer to the font for the standard day item.
virtual CFont * | GetDayTextFontBold ()
This member function is used to obtain a pointer to the font for the bolded day item.
virtual COLORREF | GetNonMonthDayBackColor ()
This member function is used to obtain the background color of the non-month day item.
virtual COLORREF | GetNonMonthDayTextColor ()
This member function is used to obtain the color of the non-month day item.
CFont * | GetNonMonthDayTextFont ()
This member function is used to obtain the font of the non-month day item.
virtual COLORREF | GetSelectedDayBackColor ()
This member function is used to obtain the background color of the selected day item.
virtual COLORREF | GetSelectedDayTextColor ()
This member function obtains the color of the selected day item.
virtual COLORREF | GetMonthHeaderBackColor ()
This member function obtains the background color of the month header area.
virtual COLORREF | GetMonthHeaderTextColor ()
This member function obtains the text color of the month header area.
CFont * | GetHeaderTextFont ()
This member function obtains the font of the month header area text.
virtual COLORREF | GetDaysOfWeekBackColor ()
This member function returns the background color of the days of weeks area.
virtual COLORREF | GetDaysOfWeekTextColor ()
This member function obtains the text color of the days of weeks area.
CFont * | GetDaysOfWeekTextFont ()
This member function obtains the font of the days of weeks area text.
virtual COLORREF | GetWeekNumbersBackColor ()
This member function obtains the background color of the week numbers area.
virtual COLORREF | GetWeekNumbersTextColor ()
This member function obtains the text color of the week numbers items.
CFont * | GetWeekNumbersTextFont ()
This member function obtains the font of the week numbers items.
virtual COLORREF | GetListControlBackColor ()
This member function obtains the background color of the pop-up month list control.
virtual COLORREF | GetListControlTextColor ()
This member function obtains the text color of the pop-up month list control.
CFont * | GetListControlTextFont ()
This member function obtains the font of the pop-up month list control.
virtual COLORREF | GetHighlightTodayColor ()
This member function obtains the highlighting color of the "Today" item.
void | SetButtonFont (CFont *fontButton)
This member function sets the button's font.
void | SetButtonFontIndirect (LOGFONT *lFont)
This member function sets the button's font using a LOGFONT structure.
CFont * | GetButtonFont ()
This member function is used to obtain the button's font object.
void | SetFontIndirect (LOGFONT *lFont)
This member function is used to set the control's default font using a LOGFONT structure.
virtual void | DrawMonthHeader (CDC *pDC, CXTPDatePickerItemMonth *pMonth)
Call this member function to draw the month header in the month area.
virtual CSize | CalcDayRect (CDC *pDC)
This member function is used to calculate the day's bounding rectangle coordinates.
virtual CSize | CalcMonthHeaderRect (CDC *pDC)
This member function calculates the month's header bounding rectangle coordinates.
virtual CSize | CalcDayOfWeekRect (CDC *pDC)
This member function calculates the "day of week names" bounding rectangle coordinates.
virtual CSize | CalcWeekNumbersRect (CDC *pDC)
This member function calculates the "week numbers" bounding rectangle coordinates.
virtual CSize | CalcMonthRect (CDC *pDC)
This member function calculates the month's bounding rectangle coordinates.
virtual void | EnableTheme (BOOL bEnableTheme)
This member function is used to switch "Themes".
virtual HCURSOR | GetCursorBack ()
This member function is used to obtain the back cursor used for weeks selection.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPDatePickerPaintManager
CSize | m_szDayMargin
This member function is used to set current paint theme.
CXTPPaintManagerColor | m_clrControlBack
This member variable is a COLORREF object that is used as the background color of the control.
CXTPPaintManagerColor | m_clrHighlightToday
This member variable is a COLORREF object that is used as the color for highlighting the "Today" item.
CXTPPaintManagerColor | m_clrSelectedDayBack
This member variable is a COLORREF object that is used as the background color of the selected day item.
CXTPPaintManagerColor | m_clrMonthHeaderBack
This member variable is a COLORREF object that is used as the background color of the month header area.
CXTPPaintManagerColor | m_clrMonthHeaderText
This member variable is a COLORREF object that is used as the text color of the month header area.
CXTPPaintManagerColor | m_clrSelectedDayText
This member variable is a COLORREF object that is used as the color of the selected day item.
CXTPPaintManagerColor | m_clrMonthBorder
This member variable is a COLORREF object that is used as the color of the border between day of month and week numbers or days of week.
CXTPPaintManagerColor | m_clrMonthHeaderButton
This member variable is a COLORREF object that is used as the color for the scroll's triangle button.
CXTPPaintManagerColor | m_clrDayBack
This member variable is a COLORREF object that is used as the background color of the normal day item.
CXTPPaintManagerColor | m_clrDayText
This member variable is a COLORREF object that is used as the color of the usual day item.
CXTPPaintManagerColor | m_clrNonMonthDayBack
This member variable is a COLORREF object that is used as the background color of the non-month day item.
CXTPPaintManagerColor | m_clrNonMonthDayText
This member variable is a COLORREF object that is used as the color of the non-month day item.
CXTPPaintManagerColor | m_clrDaysOfWeekBack
This member variable is a COLORREF object that is used for the background color of the days of weeks area.
CXTPPaintManagerColor | m_clrDaysOfWeekText
This member variable is a COLORFEF object that is used as the text color of the days of weeks area.
CXTPPaintManagerColor | m_clrWeekNumbersBack
This member variable is a COLORREF object that is used as the background color of the week numbers area.
CXTPPaintManagerColor | m_clrWeekNumbersText
This member variable is a COLORREF object that is used as the text color of the week numbers items.
CXTPPaintManagerColor | m_clrButtonText
This member variable is a COLORREF object that is used as the color for the button text.
CXTPPaintManagerColor | m_clrButtonFace
This member variable is a COLORREF object that is used as the basic color for buttons.
CXTPPaintManagerColor | m_clrListControlBack
This member variable is a COLORREF object that is used as the background color of the pop-up month list control.
CXTPPaintManagerColor | m_clrListControlText
This member variable is a COLORREF object that is used as the text color of the pop-up month list control.
- Protected Member Functions inherited from CXTPDatePickerPaintManager
virtual void | Triangle (CDC *pDC, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clrColor=0)
This member function is used to draw a black triangle.
XTPCalendarTheme | GetPaintTheme () const
This member function is used to obtain current paint theme.
- Protected Attributes inherited from CXTPDatePickerThemeOffice2013
CXTPPaintManagerColorGradient | m_clrBackground
This member variable represents two COLORREF objects that is used as the dark and light background gradient color of the control.
- Protected Attributes inherited from CXTPDatePickerPaintManager
COLORREF | m_clrStaticBorder
Static border color.
COLORREF | m_clr3DShadow
This member variable is a COLORREF object that is used to specify the color for shadow areas.
COLORREF | m_clr3DLight
This member variable is a COLORREF object that is used to specify the color for light areas.
COLORREF | m_clr3DFace
This member variable is a COL ORREF object that is used as the color for the button text.
COLORREF | m_clr3DText
This member variable is a COLORREF object that is used as the basic color for buttons.
CXTPFont | m_xtpFontDay
This member variable is a CXTPFont object that is used for the font -of the usual day item.
CXTPFont | m_xtpFontDayBold
This member variable is a CXTPFont object that is used for the font -of the bold day item.
CXTPFont | m_xtpFontNonMonthDay
This member variable is a CXTPFont object that is used as the font for the non-month day item.
CXTPFont | m_xtpFontHeader
This member variable is a CXTPFont object that is used as the font for the header text.
CXTPFont | m_xtpFontDaysOfWeek
This member variable is a CXTPFont object that is used as the font for the days of weeks text.
CXTPFont | m_xtpFontWeekNumbers
This member variable is a CXTPFont object that is used as the font for the week number items text.
CXTPFont | m_xtpFontListControl
This member variable is a CXTPFont object that is used as the font for the pop-up month list control.
CXTPFont | m_xtpFontButton
This member variable is a CXTPFont object that is used as the font for the button text.
BOOL | m_bEnableTheme
This member variable is a BOOL that is used to indicate if Luna colors are enabled.
CXTPWinThemeWrapper * | m_themeButton
This member variable is a CXTPWinThemeWrapper object that is used as the theme wrapper for the Paint Manager.
HCURSOR | m_hCursorBack
Back cursor for week selection.
XTPCalendarTheme | m_nPaintTheme
Store the Paint Theme;.

Detailed Description

Class CXTPDatePickerThemeNativeWindows10 is derived from CXTPDatePickerThemeOffice2013 for rendering an Native Windows 10 style for DatePicker control.

Example:

 if (m_bThemeNativeWindows10)
 {
    CXTPDatePickerThemeNativeWindows10* pTheme = new CXTPDatePickerThemeNativeWindows10;
    m_wndDatePicker.SetTheme(pTheme);
 }
 else
 {
    m_wndDatePicker.SetTheme(NULL);
 }
See also
CXTPDatePickerThemeNativeWindows10

Constructor & Destructor Documentation

◆ CXTPDatePickerThemeNativeWindows10()

CXTPDatePickerThemeNativeWindows10 ( )

Default paint manager constructor.

Handles initial initialization.

See also
RefreshMetrics()

◆ ~CXTPDatePickerThemeNativeWindows10()

virtual ~CXTPDatePickerThemeNativeWindows10 ( )
virtual

Default paint manager destructor.

Handles member item deallocation.

The documentation for this class was generated from the following file:
  • XTPDatePickerNativeWindows10Theme.h


Toolkit Pro: CXTPDatePickerThemeNativeWindows11 Class Reference

Public Member Functions | List of all members
CXTPDatePickerThemeNativeWindows11 Class Reference

Class CXTPDatePickerThemeNativeWindows11 is derived from CXTPDatePickerThemeOffice2013 for rendering an Native Windows 11 style for DatePicker control. More...

Inheritance diagram for CXTPDatePickerThemeNativeWindows11:
[legend]

Public Member Functions

CXTPDatePickerThemeNativeWindows11 ()
Default paint manager constructor.
virtual | ~CXTPDatePickerThemeNativeWindows11 ()
Default paint manager destructor.
- Public Member Functions inherited from CXTPDatePickerThemeOffice2013
CXTPDatePickerThemeOffice2013 ()
Default paint manager constructor.
virtual | ~CXTPDatePickerThemeOffice2013 ()
Default paint manager destructor.
virtual void | RefreshMetrics ()
This member function performs initialization for the Paint Manager.
virtual void | DrawBackground (CDC *pDC, CRect rcClient)
This member function is called to fill the control's background.
virtual void | DrawWeekNumbers (CDC *pDC, CXTPDatePickerItemMonth *pMonth)
Call this member function to draw the week numbers in the month area.
virtual void | DrawDaysOfWeek (CDC *pDC, CXTPDatePickerItemMonth *pMonth)
Call this member function to draw the days of the week in the month header.
virtual void | DrawBorder (CDC *pDC, const CXTPDatePickerControl *pControl, CRect &rcClient, BOOL bDraw)
This member function draws a border around the control.
virtual BOOL | DrawDay (CDC *pDC, CXTPDatePickerItemDay *pDay)
Call this member function to draw a single month day in the month area.
virtual void | DrawButton (CDC *pDC, const CRect &rcButton, const CString &strButton, BOOL bIsDown, BOOL bIsHighLight)
This member function is used to draw the control's buttons.
virtual COLORREF | GetHighlightTodayBackColor ()
Call this member function to retrieve the background color for the highlight today item.
virtual COLORREF | GetHighlightTodayTextColor ()
Call this member function to retrieve the foreground (text) color for the highlight today item.
virtual COLORREF | GetHighlightTodayBorderColor ()
Call this member function to retrieve the Border color for the highlight today item.
- Public Member Functions inherited from CXTPDatePickerPaintManager
CXTPDatePickerPaintManager ()
Default paint manager constructor.
virtual | ~CXTPDatePickerPaintManager ()
Default paint manager destructor.
virtual void | DrawScrollTriangle (CDC *pDC, CRect rcSpot, BOOL bLeftDirection, COLORREF clrColor=0, BOOL bYears=FALSE)
This member function draws scrolling triangles on the highest bounded month headers.
virtual COLORREF | GetControlBackColor ()
This member function is used to obtain the control's background color.
virtual COLORREF | GetDayBackColor ()
This member function is used to obtain the background color of the standard day item.
virtual COLORREF | GetDayTextColor ()
This member function is used to obtain the color of the standard day item.
virtual CFont * | GetDayTextFont ()
This member function is used to obtain a pointer to the font for the standard day item.
virtual CFont * | GetDayTextFontBold ()
This member function is used to obtain a pointer to the font for the bolded day item.
virtual COLORREF | GetNonMonthDayBackColor ()
This member function is used to obtain the background color of the non-month day item.
virtual COLORREF | GetNonMonthDayTextColor ()
This member function is used to obtain the color of the non-month day item.
CFont * | GetNonMonthDayTextFont ()
This member function is used to obtain the font of the non-month day item.
virtual COLORREF | GetSelectedDayBackColor ()
This member function is used to obtain the background color of the selected day item.
virtual COLORREF | GetSelectedDayTextColor ()
This member function obtains the color of the selected day item.
virtual COLORREF | GetMonthHeaderBackColor ()
This member function obtains the background color of the month header area.
virtual COLORREF | GetMonthHeaderTextColor ()
This member function obtains the text color of the month header area.
CFont * | GetHeaderTextFont ()
This member function obtains the font of the month header area text.
virtual COLORREF | GetDaysOfWeekBackColor ()
This member function returns the background color of the days of weeks area.
virtual COLORREF | GetDaysOfWeekTextColor ()
This member function obtains the text color of the days of weeks area.
CFont * | GetDaysOfWeekTextFont ()
This member function obtains the font of the days of weeks area text.
virtual COLORREF | GetWeekNumbersBackColor ()
This member function obtains the background color of the week numbers area.
virtual COLORREF | GetWeekNumbersTextColor ()
This member function obtains the text color of the week numbers items.
CFont * | GetWeekNumbersTextFont ()
This member function obtains the font of the week numbers items.
virtual COLORREF | GetListControlBackColor ()
This member function obtains the background color of the pop-up month list control.
virtual COLORREF | GetListControlTextColor ()
This member function obtains the text color of the pop-up month list control.
CFont * | GetListControlTextFont ()
This member function obtains the font of the pop-up month list control.
virtual COLORREF | GetHighlightTodayColor ()
This member function obtains the highlighting color of the "Today" item.
void | SetButtonFont (CFont *fontButton)
This member function sets the button's font.
void | SetButtonFontIndirect (LOGFONT *lFont)
This member function sets the button's font using a LOGFONT structure.
CFont * | GetButtonFont ()
This member function is used to obtain the button's font object.
void | SetFontIndirect (LOGFONT *lFont)
This member function is used to set the control's default font using a LOGFONT structure.
virtual void | DrawMonthHeader (CDC *pDC, CXTPDatePickerItemMonth *pMonth)
Call this member function to draw the month header in the month area.
virtual CSize | CalcDayRect (CDC *pDC)
This member function is used to calculate the day's bounding rectangle coordinates.
virtual CSize | CalcMonthHeaderRect (CDC *pDC)
This member function calculates the month's header bounding rectangle coordinates.
virtual CSize | CalcDayOfWeekRect (CDC *pDC)
This member function calculates the "day of week names" bounding rectangle coordinates.
virtual CSize | CalcWeekNumbersRect (CDC *pDC)
This member function calculates the "week numbers" bounding rectangle coordinates.
virtual CSize | CalcMonthRect (CDC *pDC)
This member function calculates the month's bounding rectangle coordinates.
virtual void | EnableTheme (BOOL bEnableTheme)
This member function is used to switch "Themes".
virtual HCURSOR | GetCursorBack ()
This member function is used to obtain the back cursor used for weeks selection.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPDatePickerPaintManager
CSize | m_szDayMargin
This member function is used to set current paint theme.
CXTPPaintManagerColor | m_clrControlBack
This member variable is a COLORREF object that is used as the background color of the control.
CXTPPaintManagerColor | m_clrHighlightToday
This member variable is a COLORREF object that is used as the color for highlighting the "Today" item.
CXTPPaintManagerColor | m_clrSelectedDayBack
This member variable is a COLORREF object that is used as the background color of the selected day item.
CXTPPaintManagerColor | m_clrMonthHeaderBack
This member variable is a COLORREF object that is used as the background color of the month header area.
CXTPPaintManagerColor | m_clrMonthHeaderText
This member variable is a COLORREF object that is used as the text color of the month header area.
CXTPPaintManagerColor | m_clrSelectedDayText
This member variable is a COLORREF object that is used as the color of the selected day item.
CXTPPaintManagerColor | m_clrMonthBorder
This member variable is a COLORREF object that is used as the color of the border between day of month and week numbers or days of week.
CXTPPaintManagerColor | m_clrMonthHeaderButton
This member variable is a COLORREF object that is used as the color for the scroll's triangle button.
CXTPPaintManagerColor | m_clrDayBack
This member variable is a COLORREF object that is used as the background color of the normal day item.
CXTPPaintManagerColor | m_clrDayText
This member variable is a COLORREF object that is used as the color of the usual day item.
CXTPPaintManagerColor | m_clrNonMonthDayBack
This member variable is a COLORREF object that is used as the background color of the non-month day item.
CXTPPaintManagerColor | m_clrNonMonthDayText
This member variable is a COLORREF object that is used as the color of the non-month day item.
CXTPPaintManagerColor | m_clrDaysOfWeekBack
This member variable is a COLORREF object that is used for the background color of the days of weeks area.
CXTPPaintManagerColor | m_clrDaysOfWeekText
This member variable is a COLORFEF object that is used as the text color of the days of weeks area.
CXTPPaintManagerColor | m_clrWeekNumbersBack
This member variable is a COLORREF object that is used as the background color of the week numbers area.
CXTPPaintManagerColor | m_clrWeekNumbersText
This member variable is a COLORREF object that is used as the text color of the week numbers items.
CXTPPaintManagerColor | m_clrButtonText
This member variable is a COLORREF object that is used as the color for the button text.
CXTPPaintManagerColor | m_clrButtonFace
This member variable is a COLORREF object that is used as the basic color for buttons.
CXTPPaintManagerColor | m_clrListControlBack
This member variable is a COLORREF object that is used as the background color of the pop-up month list control.
CXTPPaintManagerColor | m_clrListControlText
This member variable is a COLORREF object that is used as the text color of the pop-up month list control.
- Protected Member Functions inherited from CXTPDatePickerPaintManager
virtual void | Triangle (CDC *pDC, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clrColor=0)
This member function is used to draw a black triangle.
XTPCalendarTheme | GetPaintTheme () const
This member function is used to obtain current paint theme.
- Protected Attributes inherited from CXTPDatePickerThemeOffice2013
CXTPPaintManagerColorGradient | m_clrBackground
This member variable represents two COLORREF objects that is used as the dark and light background gradient color of the control.
- Protected Attributes inherited from CXTPDatePickerPaintManager
COLORREF | m_clrStaticBorder
Static border color.
COLORREF | m_clr3DShadow
This member variable is a COLORREF object that is used to specify the color for shadow areas.
COLORREF | m_clr3DLight
This member variable is a COLORREF object that is used to specify the color for light areas.
COLORREF | m_clr3DFace
This member variable is a COL ORREF object that is used as the color for the button text.
COLORREF | m_clr3DText
This member variable is a COLORREF object that is used as the basic color for buttons.
CXTPFont | m_xtpFontDay
This member variable is a CXTPFont object that is used for the font -of the usual day item.
CXTPFont | m_xtpFontDayBold
This member variable is a CXTPFont object that is used for the font -of the bold day item.
CXTPFont | m_xtpFontNonMonthDay
This member variable is a CXTPFont object that is used as the font for the non-month day item.
CXTPFont | m_xtpFontHeader
This member variable is a CXTPFont object that is used as the font for the header text.
CXTPFont | m_xtpFontDaysOfWeek
This member variable is a CXTPFont object that is used as the font for the days of weeks text.
CXTPFont | m_xtpFontWeekNumbers
This member variable is a CXTPFont object that is used as the font for the week number items text.
CXTPFont | m_xtpFontListControl
This member variable is a CXTPFont object that is used as the font for the pop-up month list control.
CXTPFont | m_xtpFontButton
This member variable is a CXTPFont object that is used as the font for the button text.
BOOL | m_bEnableTheme
This member variable is a BOOL that is used to indicate if Luna colors are enabled.
CXTPWinThemeWrapper * | m_themeButton
This member variable is a CXTPWinThemeWrapper object that is used as the theme wrapper for the Paint Manager.
HCURSOR | m_hCursorBack
Back cursor for week selection.
XTPCalendarTheme | m_nPaintTheme
Store the Paint Theme;.

Detailed Description

Class CXTPDatePickerThemeNativeWindows11 is derived from CXTPDatePickerThemeOffice2013 for rendering an Native Windows 11 style for DatePicker control.

Example:

 if (m_bThemeNativeWindows11)
 {
    CXTPDatePickerThemeNativeWindows11* pTheme = new CXTPDatePickerThemeNativeWindows11;
    m_wndDatePicker.SetTheme(pTheme);
 }
 else
 {
    m_wndDatePicker.SetTheme(NULL);
 }
See also
CXTPDatePickerThemeNativeWindows11

Constructor & Destructor Documentation

◆ CXTPDatePickerThemeNativeWindows11()

CXTPDatePickerThemeNativeWindows11 ( )

Default paint manager constructor.

Handles initial initialization.

See also
RefreshMetrics()

◆ ~CXTPDatePickerThemeNativeWindows11()

virtual ~CXTPDatePickerThemeNativeWindows11 ( )
virtual

Default paint manager destructor.

Handles member item deallocation.

The documentation for this class was generated from the following file:
  • XTPDatePickerNativeWindows11Theme.h


Toolkit Pro: CXTPDatePickerThemeOffice2000 Class Reference

Public Member Functions | List of all members
CXTPDatePickerThemeOffice2000 Class Reference

Class CXTPDatePickerThemeOffice2000 is derived from CXTPDatePickerPaintManager for rendering an Office 2000 style for DatePicker control. More...

Inheritance diagram for CXTPDatePickerThemeOffice2000:
[legend]

Public Member Functions

CXTPDatePickerThemeOffice2000 ()
Default paint manager constructor.
virtual | ~CXTPDatePickerThemeOffice2000 ()
Default paint manager destructor.
virtual void | DrawMonthHeader (CDC *pDC, CXTPDatePickerItemMonth *pMonth)
Call this member function to draw the month header in the month area.
- Public Member Functions inherited from CXTPDatePickerPaintManager
CXTPDatePickerPaintManager ()
Default paint manager constructor.
virtual | ~CXTPDatePickerPaintManager ()
Default paint manager destructor.
virtual void | RefreshMetrics ()
This member function performs initialization for the Paint Manager.
virtual void | DrawBackground (CDC *pDC, CRect rcClient)
This member function is called to fill the control's background.
virtual void | DrawBorder (CDC *pDC, const CXTPDatePickerControl *pControl, CRect &rcClient, BOOL bDraw)
This member function draws a border around the control.
virtual void | DrawScrollTriangle (CDC *pDC, CRect rcSpot, BOOL bLeftDirection, COLORREF clrColor=0, BOOL bYears=FALSE)
This member function draws scrolling triangles on the highest bounded month headers.
virtual COLORREF | GetControlBackColor ()
This member function is used to obtain the control's background color.
virtual COLORREF | GetDayBackColor ()
This member function is used to obtain the background color of the standard day item.
virtual COLORREF | GetDayTextColor ()
This member function is used to obtain the color of the standard day item.
virtual CFont * | GetDayTextFont ()
This member function is used to obtain a pointer to the font for the standard day item.
virtual CFont * | GetDayTextFontBold ()
This member function is used to obtain a pointer to the font for the bolded day item.
virtual COLORREF | GetNonMonthDayBackColor ()
This member function is used to obtain the background color of the non-month day item.
virtual COLORREF | GetNonMonthDayTextColor ()
This member function is used to obtain the color of the non-month day item.
CFont * | GetNonMonthDayTextFont ()
This member function is used to obtain the font of the non-month day item.
virtual COLORREF | GetSelectedDayBackColor ()
This member function is used to obtain the background color of the selected day item.
virtual COLORREF | GetSelectedDayTextColor ()
This member function obtains the color of the selected day item.
virtual COLORREF | GetMonthHeaderBackColor ()
This member function obtains the background color of the month header area.
virtual COLORREF | GetMonthHeaderTextColor ()
This member function obtains the text color of the month header area.
CFont * | GetHeaderTextFont ()
This member function obtains the font of the month header area text.
virtual COLORREF | GetDaysOfWeekBackColor ()
This member function returns the background color of the days of weeks area.
virtual COLORREF | GetDaysOfWeekTextColor ()
This member function obtains the text color of the days of weeks area.
CFont * | GetDaysOfWeekTextFont ()
This member function obtains the font of the days of weeks area text.
virtual COLORREF | GetWeekNumbersBackColor ()
This member function obtains the background color of the week numbers area.
virtual COLORREF | GetWeekNumbersTextColor ()
This member function obtains the text color of the week numbers items.
CFont * | GetWeekNumbersTextFont ()
This member function obtains the font of the week numbers items.
virtual COLORREF | GetListControlBackColor ()
This member function obtains the background color of the pop-up month list control.
virtual COLORREF | GetListControlTextColor ()
This member function obtains the text color of the pop-up month list control.
CFont * | GetListControlTextFont ()
This member function obtains the font of the pop-up month list control.
virtual COLORREF | GetHighlightTodayColor ()
This member function obtains the highlighting color of the "Today" item.
void | SetButtonFont (CFont *fontButton)
This member function sets the button's font.
void | SetButtonFontIndirect (LOGFONT *lFont)
This member function sets the button's font using a LOGFONT structure.
CFont * | GetButtonFont ()
This member function is used to obtain the button's font object.
void | SetFontIndirect (LOGFONT *lFont)
This member function is used to set the control's default font using a LOGFONT structure.
virtual void | DrawButton (CDC *pDC, const CRect &rcButton, const CString &strButton, BOOL bIsDown, BOOL bIsHighLight)
This member function is used to draw the control's buttons.
virtual BOOL | DrawDay (CDC *pDC, CXTPDatePickerItemDay *pDay)
Call this member function to draw a single month day in the month area.
virtual void | DrawWeekNumbers (CDC *pDC, CXTPDatePickerItemMonth *pMonth)
Call this member function to draw the week numbers in the month area.
virtual void | DrawDaysOfWeek (CDC *pDC, CXTPDatePickerItemMonth *pMonth)
Call this member function to draw the days of the week in the month header.
virtual CSize | CalcDayRect (CDC *pDC)
This member function is used to calculate the day's bounding rectangle coordinates.
virtual CSize | CalcMonthHeaderRect (CDC *pDC)
This member function calculates the month's header bounding rectangle coordinates.
virtual CSize | CalcDayOfWeekRect (CDC *pDC)
This member function calculates the "day of week names" bounding rectangle coordinates.
virtual CSize | CalcWeekNumbersRect (CDC *pDC)
This member function calculates the "week numbers" bounding rectangle coordinates.
virtual CSize | CalcMonthRect (CDC *pDC)
This member function calculates the month's bounding rectangle coordinates.
virtual void | EnableTheme (BOOL bEnableTheme)
This member function is used to switch "Themes".
virtual HCURSOR | GetCursorBack ()
This member function is used to obtain the back cursor used for weeks selection.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPDatePickerPaintManager
CSize | m_szDayMargin
This member function is used to set current paint theme.
CXTPPaintManagerColor | m_clrControlBack
This member variable is a COLORREF object that is used as the background color of the control.
CXTPPaintManagerColor | m_clrHighlightToday
This member variable is a COLORREF object that is used as the color for highlighting the "Today" item.
CXTPPaintManagerColor | m_clrSelectedDayBack
This member variable is a COLORREF object that is used as the background color of the selected day item.
CXTPPaintManagerColor | m_clrMonthHeaderBack
This member variable is a COLORREF object that is used as the background color of the month header area.
CXTPPaintManagerColor | m_clrMonthHeaderText
This member variable is a COLORREF object that is used as the text color of the month header area.
CXTPPaintManagerColor | m_clrSelectedDayText
This member variable is a COLORREF object that is used as the color of the selected day item.
CXTPPaintManagerColor | m_clrMonthBorder
This member variable is a COLORREF object that is used as the color of the border between day of month and week numbers or days of week.
CXTPPaintManagerColor | m_clrMonthHeaderButton
This member variable is a COLORREF object that is used as the color for the scroll's triangle button.
CXTPPaintManagerColor | m_clrDayBack
This member variable is a COLORREF object that is used as the background color of the normal day item.
CXTPPaintManagerColor | m_clrDayText
This member variable is a COLORREF object that is used as the color of the usual day item.
CXTPPaintManagerColor | m_clrNonMonthDayBack
This member variable is a COLORREF object that is used as the background color of the non-month day item.
CXTPPaintManagerColor | m_clrNonMonthDayText
This member variable is a COLORREF object that is used as the color of the non-month day item.
CXTPPaintManagerColor | m_clrDaysOfWeekBack
This member variable is a COLORREF object that is used for the background color of the days of weeks area.
CXTPPaintManagerColor | m_clrDaysOfWeekText
This member variable is a COLORFEF object that is used as the text color of the days of weeks area.
CXTPPaintManagerColor | m_clrWeekNumbersBack
This member variable is a COLORREF object that is used as the background color of the week numbers area.
CXTPPaintManagerColor | m_clrWeekNumbersText
This member variable is a COLORREF object that is used as the text color of the week numbers items.
CXTPPaintManagerColor | m_clrButtonText
This member variable is a COLORREF object that is used as the color for the button text.
CXTPPaintManagerColor | m_clrButtonFace
This member variable is a COLORREF object that is used as the basic color for buttons.
CXTPPaintManagerColor | m_clrListControlBack
This member variable is a COLORREF object that is used as the background color of the pop-up month list control.
CXTPPaintManagerColor | m_clrListControlText
This member variable is a COLORREF object that is used as the text color of the pop-up month list control.
- Protected Member Functions inherited from CXTPDatePickerPaintManager
virtual void | Triangle (CDC *pDC, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clrColor=0)
This member function is used to draw a black triangle.
XTPCalendarTheme | GetPaintTheme () const
This member function is used to obtain current paint theme.
- Protected Attributes inherited from CXTPDatePickerPaintManager
COLORREF | m_clrStaticBorder
Static border color.
COLORREF | m_clr3DShadow
This member variable is a COLORREF object that is used to specify the color for shadow areas.
COLORREF | m_clr3DLight
This member variable is a COLORREF object that is used to specify the color for light areas.
COLORREF | m_clr3DFace
This member variable is a COL ORREF object that is used as the color for the button text.
COLORREF | m_clr3DText
This member variable is a COLORREF object that is used as the basic color for buttons.
CXTPFont | m_xtpFontDay
This member variable is a CXTPFont object that is used for the font -of the usual day item.
CXTPFont | m_xtpFontDayBold
This member variable is a CXTPFont object that is used for the font -of the bold day item.
CXTPFont | m_xtpFontNonMonthDay
This member variable is a CXTPFont object that is used as the font for the non-month day item.
CXTPFont | m_xtpFontHeader
This member variable is a CXTPFont object that is used as the font for the header text.
CXTPFont | m_xtpFontDaysOfWeek
This member variable is a CXTPFont object that is used as the font for the days of weeks text.
CXTPFont | m_xtpFontWeekNumbers
This member variable is a CXTPFont object that is used as the font for the week number items text.
CXTPFont | m_xtpFontListControl
This member variable is a CXTPFont object that is used as the font for the pop-up month list control.
CXTPFont | m_xtpFontButton
This member variable is a CXTPFont object that is used as the font for the button text.
BOOL | m_bEnableTheme
This member variable is a BOOL that is used to indicate if Luna colors are enabled.
CXTPWinThemeWrapper * | m_themeButton
This member variable is a CXTPWinThemeWrapper object that is used as the theme wrapper for the Paint Manager.
HCURSOR | m_hCursorBack
Back cursor for week selection.
XTPCalendarTheme | m_nPaintTheme
Store the Paint Theme;.

Detailed Description

Class CXTPDatePickerThemeOffice2000 is derived from CXTPDatePickerPaintManager for rendering an Office 2000 style for DatePicker control.

Example:

 if (m_bThemeOffice2000)
 {
    CXTPDatePickerThemeOffice2000* pTheme2000 = new CXTPDatePickerThemeOffice2000;
    m_wndDatePicker.SetTheme(pTheme2000);
 }
 else
 {
    m_wndDatePicker.SetTheme(NULL);
 }
See also
CXTPDatePickerThemeOffice2000

Constructor & Destructor Documentation

◆ CXTPDatePickerThemeOffice2000()

CXTPDatePickerThemeOffice2000 ( )

Default paint manager constructor.

Handles initial initialization.

See also
RefreshMetrics()

◆ ~CXTPDatePickerThemeOffice2000()

virtual ~CXTPDatePickerThemeOffice2000 ( )
virtual

Default paint manager destructor.

Handles member item deallocation.

Member Function Documentation

◆ DrawMonthHeader()

virtual void DrawMonthHeader | ( | CDC * | pDC,
 |  | CXTPDatePickerItemMonth * | pMonth )
 virtual

Call this member function to draw the month header in the month area.

Parameters
pDC | Pointer to a valid device context.
pMonth | Pointer to month object.

It is called from CXTPDatePickerItemMonth implementation. You can override it to customize drawing.

Reimplemented from CXTPDatePickerPaintManager.

The documentation for this class was generated from the following file:
  • XTPDatePickerOffice2000Theme.h


Toolkit Pro: CXTPDatePickerThemeOffice2003 Class Reference

Public Member Functions | List of all members
CXTPDatePickerThemeOffice2003 Class Reference

Class CXTPDatePickerThemeOffice2003 is derived from CXTPDatePickerPaintManager for rendering an Office 2003 style for DatePicker control. More...

Inheritance diagram for CXTPDatePickerThemeOffice2003:
[legend]

Public Member Functions

CXTPDatePickerThemeOffice2003 ()
Default paint manager constructor.
virtual | ~CXTPDatePickerThemeOffice2003 ()
Default paint manager destructor.
virtual void | RefreshMetrics ()
This member function performs initialization for the Paint Manager.
virtual void | DrawButton (CDC *pDC, const CRect &rcButton, const CString &strButton, BOOL bIsDown, BOOL bIsHighLight)
This member function is used to draw the control's buttons.
- Public Member Functions inherited from CXTPDatePickerPaintManager
CXTPDatePickerPaintManager ()
Default paint manager constructor.
virtual | ~CXTPDatePickerPaintManager ()
Default paint manager destructor.
virtual void | DrawBackground (CDC *pDC, CRect rcClient)
This member function is called to fill the control's background.
virtual void | DrawBorder (CDC *pDC, const CXTPDatePickerControl *pControl, CRect &rcClient, BOOL bDraw)
This member function draws a border around the control.
virtual void | DrawScrollTriangle (CDC *pDC, CRect rcSpot, BOOL bLeftDirection, COLORREF clrColor=0, BOOL bYears=FALSE)
This member function draws scrolling triangles on the highest bounded month headers.
virtual COLORREF | GetControlBackColor ()
This member function is used to obtain the control's background color.
virtual COLORREF | GetDayBackColor ()
This member function is used to obtain the background color of the standard day item.
virtual COLORREF | GetDayTextColor ()
This member function is used to obtain the color of the standard day item.
virtual CFont * | GetDayTextFont ()
This member function is used to obtain a pointer to the font for the standard day item.
virtual CFont * | GetDayTextFontBold ()
This member function is used to obtain a pointer to the font for the bolded day item.
virtual COLORREF | GetNonMonthDayBackColor ()
This member function is used to obtain the background color of the non-month day item.
virtual COLORREF | GetNonMonthDayTextColor ()
This member function is used to obtain the color of the non-month day item.
CFont * | GetNonMonthDayTextFont ()
This member function is used to obtain the font of the non-month day item.
virtual COLORREF | GetSelectedDayBackColor ()
This member function is used to obtain the background color of the selected day item.
virtual COLORREF | GetSelectedDayTextColor ()
This member function obtains the color of the selected day item.
virtual COLORREF | GetMonthHeaderBackColor ()
This member function obtains the background color of the month header area.
virtual COLORREF | GetMonthHeaderTextColor ()
This member function obtains the text color of the month header area.
CFont * | GetHeaderTextFont ()
This member function obtains the font of the month header area text.
virtual COLORREF | GetDaysOfWeekBackColor ()
This member function returns the background color of the days of weeks area.
virtual COLORREF | GetDaysOfWeekTextColor ()
This member function obtains the text color of the days of weeks area.
CFont * | GetDaysOfWeekTextFont ()
This member function obtains the font of the days of weeks area text.
virtual COLORREF | GetWeekNumbersBackColor ()
This member function obtains the background color of the week numbers area.
virtual COLORREF | GetWeekNumbersTextColor ()
This member function obtains the text color of the week numbers items.
CFont * | GetWeekNumbersTextFont ()
This member function obtains the font of the week numbers items.
virtual COLORREF | GetListControlBackColor ()
This member function obtains the background color of the pop-up month list control.
virtual COLORREF | GetListControlTextColor ()
This member function obtains the text color of the pop-up month list control.
CFont * | GetListControlTextFont ()
This member function obtains the font of the pop-up month list control.
virtual COLORREF | GetHighlightTodayColor ()
This member function obtains the highlighting color of the "Today" item.
void | SetButtonFont (CFont *fontButton)
This member function sets the button's font.
void | SetButtonFontIndirect (LOGFONT *lFont)
This member function sets the button's font using a LOGFONT structure.
CFont * | GetButtonFont ()
This member function is used to obtain the button's font object.
void | SetFontIndirect (LOGFONT *lFont)
This member function is used to set the control's default font using a LOGFONT structure.
virtual BOOL | DrawDay (CDC *pDC, CXTPDatePickerItemDay *pDay)
Call this member function to draw a single month day in the month area.
virtual void | DrawMonthHeader (CDC *pDC, CXTPDatePickerItemMonth *pMonth)
Call this member function to draw the month header in the month area.
virtual void | DrawWeekNumbers (CDC *pDC, CXTPDatePickerItemMonth *pMonth)
Call this member function to draw the week numbers in the month area.
virtual void | DrawDaysOfWeek (CDC *pDC, CXTPDatePickerItemMonth *pMonth)
Call this member function to draw the days of the week in the month header.
virtual CSize | CalcDayRect (CDC *pDC)
This member function is used to calculate the day's bounding rectangle coordinates.
virtual CSize | CalcMonthHeaderRect (CDC *pDC)
This member function calculates the month's header bounding rectangle coordinates.
virtual CSize | CalcDayOfWeekRect (CDC *pDC)
This member function calculates the "day of week names" bounding rectangle coordinates.
virtual CSize | CalcWeekNumbersRect (CDC *pDC)
This member function calculates the "week numbers" bounding rectangle coordinates.
virtual CSize | CalcMonthRect (CDC *pDC)
This member function calculates the month's bounding rectangle coordinates.
virtual void | EnableTheme (BOOL bEnableTheme)
This member function is used to switch "Themes".
virtual HCURSOR | GetCursorBack ()
This member function is used to obtain the back cursor used for weeks selection.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPDatePickerPaintManager
CSize | m_szDayMargin
This member function is used to set current paint theme.
CXTPPaintManagerColor | m_clrControlBack
This member variable is a COLORREF object that is used as the background color of the control.
CXTPPaintManagerColor | m_clrHighlightToday
This member variable is a COLORREF object that is used as the color for highlighting the "Today" item.
CXTPPaintManagerColor | m_clrSelectedDayBack
This member variable is a COLORREF object that is used as the background color of the selected day item.
CXTPPaintManagerColor | m_clrMonthHeaderBack
This member variable is a COLORREF object that is used as the background color of the month header area.
CXTPPaintManagerColor | m_clrMonthHeaderText
This member variable is a COLORREF object that is used as the text color of the month header area.
CXTPPaintManagerColor | m_clrSelectedDayText
This member variable is a COLORREF object that is used as the color of the selected day item.
CXTPPaintManagerColor | m_clrMonthBorder
This member variable is a COLORREF object that is used as the color of the border between day of month and week numbers or days of week.
CXTPPaintManagerColor | m_clrMonthHeaderButton
This member variable is a COLORREF object that is used as the color for the scroll's triangle button.
CXTPPaintManagerColor | m_clrDayBack
This member variable is a COLORREF object that is used as the background color of the normal day item.
CXTPPaintManagerColor | m_clrDayText
This member variable is a COLORREF object that is used as the color of the usual day item.
CXTPPaintManagerColor | m_clrNonMonthDayBack
This member variable is a COLORREF object that is used as the background color of the non-month day item.
CXTPPaintManagerColor | m_clrNonMonthDayText
This member variable is a COLORREF object that is used as the color of the non-month day item.
CXTPPaintManagerColor | m_clrDaysOfWeekBack
This member variable is a COLORREF object that is used for the background color of the days of weeks area.
CXTPPaintManagerColor | m_clrDaysOfWeekText
This member variable is a COLORFEF object that is used as the text color of the days of weeks area.
CXTPPaintManagerColor | m_clrWeekNumbersBack
This member variable is a COLORREF object that is used as the background color of the week numbers area.
CXTPPaintManagerColor | m_clrWeekNumbersText
This member variable is a COLORREF object that is used as the text color of the week numbers items.
CXTPPaintManagerColor | m_clrButtonText
This member variable is a COLORREF object that is used as the color for the button text.
CXTPPaintManagerColor | m_clrButtonFace
This member variable is a COLORREF object that is used as the basic color for buttons.
CXTPPaintManagerColor | m_clrListControlBack
This member variable is a COLORREF object that is used as the background color of the pop-up month list control.
CXTPPaintManagerColor | m_clrListControlText
This member variable is a COLORREF object that is used as the text color of the pop-up month list control.
- Protected Member Functions inherited from CXTPDatePickerPaintManager
virtual void | Triangle (CDC *pDC, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clrColor=0)
This member function is used to draw a black triangle.
XTPCalendarTheme | GetPaintTheme () const
This member function is used to obtain current paint theme.
- Protected Attributes inherited from CXTPDatePickerPaintManager
COLORREF | m_clrStaticBorder
Static border color.
COLORREF | m_clr3DShadow
This member variable is a COLORREF object that is used to specify the color for shadow areas.
COLORREF | m_clr3DLight
This member variable is a COLORREF object that is used to specify the color for light areas.
COLORREF | m_clr3DFace
This member variable is a COL ORREF object that is used as the color for the button text.
COLORREF | m_clr3DText
This member variable is a COLORREF object that is used as the basic color for buttons.
CXTPFont | m_xtpFontDay
This member variable is a CXTPFont object that is used for the font -of the usual day item.
CXTPFont | m_xtpFontDayBold
This member variable is a CXTPFont object that is used for the font -of the bold day item.
CXTPFont | m_xtpFontNonMonthDay
This member variable is a CXTPFont object that is used as the font for the non-month day item.
CXTPFont | m_xtpFontHeader
This member variable is a CXTPFont object that is used as the font for the header text.
CXTPFont | m_xtpFontDaysOfWeek
This member variable is a CXTPFont object that is used as the font for the days of weeks text.
CXTPFont | m_xtpFontWeekNumbers
This member variable is a CXTPFont object that is used as the font for the week number items text.
CXTPFont | m_xtpFontListControl
This member variable is a CXTPFont object that is used as the font for the pop-up month list control.
CXTPFont | m_xtpFontButton
This member variable is a CXTPFont object that is used as the font for the button text.
BOOL | m_bEnableTheme
This member variable is a BOOL that is used to indicate if Luna colors are enabled.
CXTPWinThemeWrapper * | m_themeButton
This member variable is a CXTPWinThemeWrapper object that is used as the theme wrapper for the Paint Manager.
HCURSOR | m_hCursorBack
Back cursor for week selection.
XTPCalendarTheme | m_nPaintTheme
Store the Paint Theme;.

Detailed Description

Class CXTPDatePickerThemeOffice2003 is derived from CXTPDatePickerPaintManager for rendering an Office 2003 style for DatePicker control.

Example:

 if (m_bThemeOffice2003)
 {
    CXTPDatePickerThemeOffice2003* pTheme2003 = new CXTPDatePickerThemeOffice2003;
    m_wndDatePicker.SetTheme(pTheme2003);
 }
 else
 {
    m_wndDatePicker.SetTheme(NULL);
 }
See also
CXTPDatePickerThemeOffice2003

Constructor & Destructor Documentation

◆ CXTPDatePickerThemeOffice2003()

CXTPDatePickerThemeOffice2003 ( )

Default paint manager constructor.

Handles initial initialization.

See also
RefreshMetrics()

◆ ~CXTPDatePickerThemeOffice2003()

virtual ~CXTPDatePickerThemeOffice2003 ( )
virtual

Default paint manager destructor.

Handles member item deallocation.

Member Function Documentation

◆ DrawButton()

virtual void DrawButton | ( | CDC * | pDC,
 |  | const CRect & | rcButton,
 |  | const CString & | strButton,
 |  | BOOL | bIsDown,
 |  | BOOL | bIsHighLight )
 virtual

This member function is used to draw the control's buttons.

Parameters
pDC | Pointer to a valid device context.
rcButton | A CRect that contains the button area bounding rectangle coordinates.
strButton | A CString that contains the string of the button's text.
bIsDown | A BOOL that determines if the button is down or up.
bIsHighLight | A BOOL that determines if the button is highlighted.

Use this member function to draw buttons in the appropriate state. The state depends on the bIsDown parameter, the button may be drawn pressed or released. Furthermore, depending on the bIsHighLight, the button may be drawn with highlighted borders.

Example:

for (int i = 0; i < GetButtonCount(); i++)
{
CXTPDatePickerButton* pButton = GetButton(i);
if (pButton->m_bVisible)
   DrawButton(pDC, pButton->m_rcButton, pButton->m_strCaption,
   pButton->m_bPressed, pButton->m_bHighlight);
}

Reimplemented from CXTPDatePickerPaintManager.

◆ RefreshMetrics()

virtual void RefreshMetrics ( )
virtual

This member function performs initialization for the Paint Manager.

Initializes all drawing defaults (fonts, colors, etc.). Most of defaults are system defaults.

Reimplemented from CXTPDatePickerPaintManager.

The documentation for this class was generated from the following file:
  • XTPDatePickerOffice2003Theme.h


Toolkit Pro: CXTPDatePickerThemeOffice2013 Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPDatePickerThemeOffice2013 Class Reference

Class CXTPDatePickerThemeOffice2013 is derived from CXTPDatePickerPaintManager for rendering an Office 2013 style for DatePicker control. More...

Inheritance diagram for CXTPDatePickerThemeOffice2013:
[legend]

Public Member Functions

CXTPDatePickerThemeOffice2013 ()
Default paint manager constructor.
virtual | ~CXTPDatePickerThemeOffice2013 ()
Default paint manager destructor.
virtual void | RefreshMetrics ()
This member function performs initialization for the Paint Manager.
virtual void | DrawBackground (CDC *pDC, CRect rcClient)
This member function is called to fill the control's background.
virtual void | DrawWeekNumbers (CDC *pDC, CXTPDatePickerItemMonth *pMonth)
Call this member function to draw the week numbers in the month area.
virtual void | DrawDaysOfWeek (CDC *pDC, CXTPDatePickerItemMonth *pMonth)
Call this member function to draw the days of the week in the month header.
virtual void | DrawBorder (CDC *pDC, const CXTPDatePickerControl *pControl, CRect &rcClient, BOOL bDraw)
This member function draws a border around the control.
virtual BOOL | DrawDay (CDC *pDC, CXTPDatePickerItemDay *pDay)
Call this member function to draw a single month day in the month area.
virtual void | DrawButton (CDC *pDC, const CRect &rcButton, const CString &strButton, BOOL bIsDown, BOOL bIsHighLight)
This member function is used to draw the control's buttons.
virtual COLORREF | GetHighlightTodayBackColor ()
Call this member function to retrieve the background color for the highlight today item.
virtual COLORREF | GetHighlightTodayTextColor ()
Call this member function to retrieve the foreground (text) color for the highlight today item.
virtual COLORREF | GetHighlightTodayBorderColor ()
Call this member function to retrieve the Border color for the highlight today item.
- Public Member Functions inherited from CXTPDatePickerPaintManager
CXTPDatePickerPaintManager ()
Default paint manager constructor.
virtual | ~CXTPDatePickerPaintManager ()
Default paint manager destructor.
virtual void | DrawScrollTriangle (CDC *pDC, CRect rcSpot, BOOL bLeftDirection, COLORREF clrColor=0, BOOL bYears=FALSE)
This member function draws scrolling triangles on the highest bounded month headers.
virtual COLORREF | GetControlBackColor ()
This member function is used to obtain the control's background color.
virtual COLORREF | GetDayBackColor ()
This member function is used to obtain the background color of the standard day item.
virtual COLORREF | GetDayTextColor ()
This member function is used to obtain the color of the standard day item.
virtual CFont * | GetDayTextFont ()
This member function is used to obtain a pointer to the font for the standard day item.
virtual CFont * | GetDayTextFontBold ()
This member function is used to obtain a pointer to the font for the bolded day item.
virtual COLORREF | GetNonMonthDayBackColor ()
This member function is used to obtain the background color of the non-month day item.
virtual COLORREF | GetNonMonthDayTextColor ()
This member function is used to obtain the color of the non-month day item.
CFont * | GetNonMonthDayTextFont ()
This member function is used to obtain the font of the non-month day item.
virtual COLORREF | GetSelectedDayBackColor ()
This member function is used to obtain the background color of the selected day item.
virtual COLORREF | GetSelectedDayTextColor ()
This member function obtains the color of the selected day item.
virtual COLORREF | GetMonthHeaderBackColor ()
This member function obtains the background color of the month header area.
virtual COLORREF | GetMonthHeaderTextColor ()
This member function obtains the text color of the month header area.
CFont * | GetHeaderTextFont ()
This member function obtains the font of the month header area text.
virtual COLORREF | GetDaysOfWeekBackColor ()
This member function returns the background color of the days of weeks area.
virtual COLORREF | GetDaysOfWeekTextColor ()
This member function obtains the text color of the days of weeks area.
CFont * | GetDaysOfWeekTextFont ()
This member function obtains the font of the days of weeks area text.
virtual COLORREF | GetWeekNumbersBackColor ()
This member function obtains the background color of the week numbers area.
virtual COLORREF | GetWeekNumbersTextColor ()
This member function obtains the text color of the week numbers items.
CFont * | GetWeekNumbersTextFont ()
This member function obtains the font of the week numbers items.
virtual COLORREF | GetListControlBackColor ()
This member function obtains the background color of the pop-up month list control.
virtual COLORREF | GetListControlTextColor ()
This member function obtains the text color of the pop-up month list control.
CFont * | GetListControlTextFont ()
This member function obtains the font of the pop-up month list control.
virtual COLORREF | GetHighlightTodayColor ()
This member function obtains the highlighting color of the "Today" item.
void | SetButtonFont (CFont *fontButton)
This member function sets the button's font.
void | SetButtonFontIndirect (LOGFONT *lFont)
This member function sets the button's font using a LOGFONT structure.
CFont * | GetButtonFont ()
This member function is used to obtain the button's font object.
void | SetFontIndirect (LOGFONT *lFont)
This member function is used to set the control's default font using a LOGFONT structure.
virtual void | DrawMonthHeader (CDC *pDC, CXTPDatePickerItemMonth *pMonth)
Call this member function to draw the month header in the month area.
virtual CSize | CalcDayRect (CDC *pDC)
This member function is used to calculate the day's bounding rectangle coordinates.
virtual CSize | CalcMonthHeaderRect (CDC *pDC)
This member function calculates the month's header bounding rectangle coordinates.
virtual CSize | CalcDayOfWeekRect (CDC *pDC)
This member function calculates the "day of week names" bounding rectangle coordinates.
virtual CSize | CalcWeekNumbersRect (CDC *pDC)
This member function calculates the "week numbers" bounding rectangle coordinates.
virtual CSize | CalcMonthRect (CDC *pDC)
This member function calculates the month's bounding rectangle coordinates.
virtual void | EnableTheme (BOOL bEnableTheme)
This member function is used to switch "Themes".
virtual HCURSOR | GetCursorBack ()
This member function is used to obtain the back cursor used for weeks selection.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Attributes

CXTPPaintManagerColorGradient | m_clrBackground
This member variable represents two COLORREF objects that is used as the dark and light background gradient color of the control.
- Protected Attributes inherited from CXTPDatePickerPaintManager
COLORREF | m_clrStaticBorder
Static border color.
COLORREF | m_clr3DShadow
This member variable is a COLORREF object that is used to specify the color for shadow areas.
COLORREF | m_clr3DLight
This member variable is a COLORREF object that is used to specify the color for light areas.
COLORREF | m_clr3DFace
This member variable is a COL ORREF object that is used as the color for the button text.
COLORREF | m_clr3DText
This member variable is a COLORREF object that is used as the basic color for buttons.
CXTPFont | m_xtpFontDay
This member variable is a CXTPFont object that is used for the font -of the usual day item.
CXTPFont | m_xtpFontDayBold
This member variable is a CXTPFont object that is used for the font -of the bold day item.
CXTPFont | m_xtpFontNonMonthDay
This member variable is a CXTPFont object that is used as the font for the non-month day item.
CXTPFont | m_xtpFontHeader
This member variable is a CXTPFont object that is used as the font for the header text.
CXTPFont | m_xtpFontDaysOfWeek
This member variable is a CXTPFont object that is used as the font for the days of weeks text.
CXTPFont | m_xtpFontWeekNumbers
This member variable is a CXTPFont object that is used as the font for the week number items text.
CXTPFont | m_xtpFontListControl
This member variable is a CXTPFont object that is used as the font for the pop-up month list control.
CXTPFont | m_xtpFontButton
This member variable is a CXTPFont object that is used as the font for the button text.
BOOL | m_bEnableTheme
This member variable is a BOOL that is used to indicate if Luna colors are enabled.
CXTPWinThemeWrapper * | m_themeButton
This member variable is a CXTPWinThemeWrapper object that is used as the theme wrapper for the Paint Manager.
HCURSOR | m_hCursorBack
Back cursor for week selection.
XTPCalendarTheme | m_nPaintTheme
Store the Paint Theme;.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPDatePickerPaintManager
CSize | m_szDayMargin
This member function is used to set current paint theme.
CXTPPaintManagerColor | m_clrControlBack
This member variable is a COLORREF object that is used as the background color of the control.
CXTPPaintManagerColor | m_clrHighlightToday
This member variable is a COLORREF object that is used as the color for highlighting the "Today" item.
CXTPPaintManagerColor | m_clrSelectedDayBack
This member variable is a COLORREF object that is used as the background color of the selected day item.
CXTPPaintManagerColor | m_clrMonthHeaderBack
This member variable is a COLORREF object that is used as the background color of the month header area.
CXTPPaintManagerColor | m_clrMonthHeaderText
This member variable is a COLORREF object that is used as the text color of the month header area.
CXTPPaintManagerColor | m_clrSelectedDayText
This member variable is a COLORREF object that is used as the color of the selected day item.
CXTPPaintManagerColor | m_clrMonthBorder
This member variable is a COLORREF object that is used as the color of the border between day of month and week numbers or days of week.
CXTPPaintManagerColor | m_clrMonthHeaderButton
This member variable is a COLORREF object that is used as the color for the scroll's triangle button.
CXTPPaintManagerColor | m_clrDayBack
This member variable is a COLORREF object that is used as the background color of the normal day item.
CXTPPaintManagerColor | m_clrDayText
This member variable is a COLORREF object that is used as the color of the usual day item.
CXTPPaintManagerColor | m_clrNonMonthDayBack
This member variable is a COLORREF object that is used as the background color of the non-month day item.
CXTPPaintManagerColor | m_clrNonMonthDayText
This member variable is a COLORREF object that is used as the color of the non-month day item.
CXTPPaintManagerColor | m_clrDaysOfWeekBack
This member variable is a COLORREF object that is used for the background color of the days of weeks area.
CXTPPaintManagerColor | m_clrDaysOfWeekText
This member variable is a COLORFEF object that is used as the text color of the days of weeks area.
CXTPPaintManagerColor | m_clrWeekNumbersBack
This member variable is a COLORREF object that is used as the background color of the week numbers area.
CXTPPaintManagerColor | m_clrWeekNumbersText
This member variable is a COLORREF object that is used as the text color of the week numbers items.
CXTPPaintManagerColor | m_clrButtonText
This member variable is a COLORREF object that is used as the color for the button text.
CXTPPaintManagerColor | m_clrButtonFace
This member variable is a COLORREF object that is used as the basic color for buttons.
CXTPPaintManagerColor | m_clrListControlBack
This member variable is a COLORREF object that is used as the background color of the pop-up month list control.
CXTPPaintManagerColor | m_clrListControlText
This member variable is a COLORREF object that is used as the text color of the pop-up month list control.
- Protected Member Functions inherited from CXTPDatePickerPaintManager
virtual void | Triangle (CDC *pDC, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clrColor=0)
This member function is used to draw a black triangle.
XTPCalendarTheme | GetPaintTheme () const
This member function is used to obtain current paint theme.

Detailed Description

Class CXTPDatePickerThemeOffice2013 is derived from CXTPDatePickerPaintManager for rendering an Office 2013 style for DatePicker control.

Example:

 if (m_bThemeOffice2013)
 {
    CXTPDatePickerThemeOffice2013* pTheme2013 = new CXTPDatePickerThemeOffice2013;
    m_wndDatePicker.SetTheme(pTheme2013);
 }
 else
 {
    m_wndDatePicker.SetTheme(NULL);
 }
See also
CXTPDatePickerThemeOffice2013

Constructor & Destructor Documentation

◆ CXTPDatePickerThemeOffice2013()

CXTPDatePickerThemeOffice2013 ( )

Default paint manager constructor.

Handles initial initialization.

See also
RefreshMetrics()

◆ ~CXTPDatePickerThemeOffice2013()

virtual ~CXTPDatePickerThemeOffice2013 ( )
virtual

Default paint manager destructor.

Handles member item deallocation.

Member Function Documentation

◆ DrawBackground()

virtual void DrawBackground | ( | CDC * | pDC,
 |  | CRect | rcClient )
 virtual

This member function is called to fill the control's background.

Parameters
pDC | Pointer to a valid device context.
rcClient | A CRect that contains the control's client area rectangle coordinates.

Reimplemented from CXTPDatePickerPaintManager.

◆ DrawBorder()

virtual void DrawBorder | ( | CDC * | pDC,
 |  | const CXTPDatePickerControl * | pControl,
 |  | CRect & | rcClient,
 |  | BOOL | bDraw )
 virtual

This member function draws a border around the control.

Parameters
pDC | Pointer to a valid device context.
pControl | Pointer to a CXTPDatePickerControl object.
rcClient | A CRect that contains the control's client area rectangle coordinates.
bDraw | TRUE to draw else Adjust client rectangle.

Reimplemented from CXTPDatePickerPaintManager.

◆ DrawButton()

virtual void DrawButton | ( | CDC * | pDC,
 |  | const CRect & | rcButton,
 |  | const CString & | strButton,
 |  | BOOL | bIsDown,
 |  | BOOL | bIsHighLight )
 virtual

This member function is used to draw the control's buttons.

Parameters
pDC | Pointer to a valid device context.
rcButton | A CRect that contains the button area bounding rectangle coordinates.
strButton | A CString that contains the string of the button's text.
bIsDown | A BOOL that determines if the button is down or up.
bIsHighLight | A BOOL that determines if the button is highlighted.

Use this member function to draw buttons in the appropriate state. The state depends on the bIsDown parameter, the button may be drawn pressed or released. Furthermore, depending on the bIsHighLight, the button may be drawn with highlighted borders.

Example:

for (int i = 0; i < GetButtonCount(); i++)
{
CXTPDatePickerButton* pButton = GetButton(i);
if (pButton->m_bVisible)
   DrawButton(pDC, pButton->m_rcButton, pButton->m_strCaption,
   pButton->m_bPressed, pButton->m_bHighlight);
}

Reimplemented from CXTPDatePickerPaintManager.

◆ DrawDay()

virtual BOOL DrawDay | ( | CDC * | pDC,
 |  | CXTPDatePickerItemDay * | pDay )
 virtual

Call this member function to draw a single month day in the month area.

Parameters
pDC | Pointer to a valid device context.
pDay | Pointer to day object.
Returns
TRUE if the drawing is successful, FALSE else.

It is called from CXTPDatePickerItemDay implementation. You can override it to customize drawing.

Reimplemented from CXTPDatePickerPaintManager.

◆ DrawDaysOfWeek()

virtual void DrawDaysOfWeek | ( | CDC * | pDC,
 |  | CXTPDatePickerItemMonth * | pMonth )
 virtual

Call this member function to draw the days of the week in the month header.

Parameters
pDC | Pointer to a valid device context.
pMonth | Pointer to month object.

It is called from CXTPDatePickerItemMonth implementation. You can override it to customize drawing.

Reimplemented from CXTPDatePickerPaintManager.

◆ DrawWeekNumbers()

virtual void DrawWeekNumbers | ( | CDC * | pDC,
 |  | CXTPDatePickerItemMonth * | pMonth )
 virtual

Call this member function to draw the week numbers in the month area.

Parameters
pDC | Pointer to a valid device context.
pMonth | Pointer to month object.

It is called from CXTPDatePickerItemMonth implementation. You can override it to customize drawing.

Reimplemented from CXTPDatePickerPaintManager.

◆ GetHighlightTodayBackColor()

AFX_INLINE COLORREF GetHighlightTodayBackColor ( )
virtual

Call this member function to retrieve the background color for the highlight today item.

Returns
A COLORREF object that contains the background color of the "Today" item.

◆ GetHighlightTodayBorderColor()

AFX_INLINE COLORREF GetHighlightTodayBorderColor ( )
virtual

Call this member function to retrieve the Border color for the highlight today item.

Returns
A COLORREF object that contains the Border color of the "Today" item.

◆ GetHighlightTodayTextColor()

AFX_INLINE COLORREF GetHighlightTodayTextColor ( )
virtual

Call this member function to retrieve the foreground (text) color for the highlight today item.

Returns
A COLORREF object that contains the foreground (text) color of the "Today" item.

◆ RefreshMetrics()

virtual void RefreshMetrics ( )
virtual

This member function performs initialization for the Paint Manager.

Initializes all drawing defaults (fonts, colors, etc.). Most of defaults are system defaults.

Reimplemented from CXTPDatePickerPaintManager.

The documentation for this class was generated from the following file:
  • XTPDatePickerOffice2013Theme.h


Toolkit Pro: CXTPDatePickerThemeOfficeXP Class Reference

Public Member Functions | List of all members
CXTPDatePickerThemeOfficeXP Class Reference

Class CXTPDatePickerThemeOfficeXP is derived from CXTPDatePickerPaintManager for rendering an Office XP style for DatePicker control. More...

Inheritance diagram for CXTPDatePickerThemeOfficeXP:
[legend]

Public Member Functions

CXTPDatePickerThemeOfficeXP ()
Default paint manager constructor.
virtual | ~CXTPDatePickerThemeOfficeXP ()
Default paint manager destructor.
- Public Member Functions inherited from CXTPDatePickerPaintManager
CXTPDatePickerPaintManager ()
Default paint manager constructor.
virtual | ~CXTPDatePickerPaintManager ()
Default paint manager destructor.
virtual void | RefreshMetrics ()
This member function performs initialization for the Paint Manager.
virtual void | DrawBackground (CDC *pDC, CRect rcClient)
This member function is called to fill the control's background.
virtual void | DrawBorder (CDC *pDC, const CXTPDatePickerControl *pControl, CRect &rcClient, BOOL bDraw)
This member function draws a border around the control.
virtual void | DrawScrollTriangle (CDC *pDC, CRect rcSpot, BOOL bLeftDirection, COLORREF clrColor=0, BOOL bYears=FALSE)
This member function draws scrolling triangles on the highest bounded month headers.
virtual COLORREF | GetControlBackColor ()
This member function is used to obtain the control's background color.
virtual COLORREF | GetDayBackColor ()
This member function is used to obtain the background color of the standard day item.
virtual COLORREF | GetDayTextColor ()
This member function is used to obtain the color of the standard day item.
virtual CFont * | GetDayTextFont ()
This member function is used to obtain a pointer to the font for the standard day item.
virtual CFont * | GetDayTextFontBold ()
This member function is used to obtain a pointer to the font for the bolded day item.
virtual COLORREF | GetNonMonthDayBackColor ()
This member function is used to obtain the background color of the non-month day item.
virtual COLORREF | GetNonMonthDayTextColor ()
This member function is used to obtain the color of the non-month day item.
CFont * | GetNonMonthDayTextFont ()
This member function is used to obtain the font of the non-month day item.
virtual COLORREF | GetSelectedDayBackColor ()
This member function is used to obtain the background color of the selected day item.
virtual COLORREF | GetSelectedDayTextColor ()
This member function obtains the color of the selected day item.
virtual COLORREF | GetMonthHeaderBackColor ()
This member function obtains the background color of the month header area.
virtual COLORREF | GetMonthHeaderTextColor ()
This member function obtains the text color of the month header area.
CFont * | GetHeaderTextFont ()
This member function obtains the font of the month header area text.
virtual COLORREF | GetDaysOfWeekBackColor ()
This member function returns the background color of the days of weeks area.
virtual COLORREF | GetDaysOfWeekTextColor ()
This member function obtains the text color of the days of weeks area.
CFont * | GetDaysOfWeekTextFont ()
This member function obtains the font of the days of weeks area text.
virtual COLORREF | GetWeekNumbersBackColor ()
This member function obtains the background color of the week numbers area.
virtual COLORREF | GetWeekNumbersTextColor ()
This member function obtains the text color of the week numbers items.
CFont * | GetWeekNumbersTextFont ()
This member function obtains the font of the week numbers items.
virtual COLORREF | GetListControlBackColor ()
This member function obtains the background color of the pop-up month list control.
virtual COLORREF | GetListControlTextColor ()
This member function obtains the text color of the pop-up month list control.
CFont * | GetListControlTextFont ()
This member function obtains the font of the pop-up month list control.
virtual COLORREF | GetHighlightTodayColor ()
This member function obtains the highlighting color of the "Today" item.
void | SetButtonFont (CFont *fontButton)
This member function sets the button's font.
void | SetButtonFontIndirect (LOGFONT *lFont)
This member function sets the button's font using a LOGFONT structure.
CFont * | GetButtonFont ()
This member function is used to obtain the button's font object.
void | SetFontIndirect (LOGFONT *lFont)
This member function is used to set the control's default font using a LOGFONT structure.
virtual void | DrawButton (CDC *pDC, const CRect &rcButton, const CString &strButton, BOOL bIsDown, BOOL bIsHighLight)
This member function is used to draw the control's buttons.
virtual BOOL | DrawDay (CDC *pDC, CXTPDatePickerItemDay *pDay)
Call this member function to draw a single month day in the month area.
virtual void | DrawMonthHeader (CDC *pDC, CXTPDatePickerItemMonth *pMonth)
Call this member function to draw the month header in the month area.
virtual void | DrawWeekNumbers (CDC *pDC, CXTPDatePickerItemMonth *pMonth)
Call this member function to draw the week numbers in the month area.
virtual void | DrawDaysOfWeek (CDC *pDC, CXTPDatePickerItemMonth *pMonth)
Call this member function to draw the days of the week in the month header.
virtual CSize | CalcDayRect (CDC *pDC)
This member function is used to calculate the day's bounding rectangle coordinates.
virtual CSize | CalcMonthHeaderRect (CDC *pDC)
This member function calculates the month's header bounding rectangle coordinates.
virtual CSize | CalcDayOfWeekRect (CDC *pDC)
This member function calculates the "day of week names" bounding rectangle coordinates.
virtual CSize | CalcWeekNumbersRect (CDC *pDC)
This member function calculates the "week numbers" bounding rectangle coordinates.
virtual CSize | CalcMonthRect (CDC *pDC)
This member function calculates the month's bounding rectangle coordinates.
virtual void | EnableTheme (BOOL bEnableTheme)
This member function is used to switch "Themes".
virtual HCURSOR | GetCursorBack ()
This member function is used to obtain the back cursor used for weeks selection.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPDatePickerPaintManager
CSize | m_szDayMargin
This member function is used to set current paint theme.
CXTPPaintManagerColor | m_clrControlBack
This member variable is a COLORREF object that is used as the background color of the control.
CXTPPaintManagerColor | m_clrHighlightToday
This member variable is a COLORREF object that is used as the color for highlighting the "Today" item.
CXTPPaintManagerColor | m_clrSelectedDayBack
This member variable is a COLORREF object that is used as the background color of the selected day item.
CXTPPaintManagerColor | m_clrMonthHeaderBack
This member variable is a COLORREF object that is used as the background color of the month header area.
CXTPPaintManagerColor | m_clrMonthHeaderText
This member variable is a COLORREF object that is used as the text color of the month header area.
CXTPPaintManagerColor | m_clrSelectedDayText
This member variable is a COLORREF object that is used as the color of the selected day item.
CXTPPaintManagerColor | m_clrMonthBorder
This member variable is a COLORREF object that is used as the color of the border between day of month and week numbers or days of week.
CXTPPaintManagerColor | m_clrMonthHeaderButton
This member variable is a COLORREF object that is used as the color for the scroll's triangle button.
CXTPPaintManagerColor | m_clrDayBack
This member variable is a COLORREF object that is used as the background color of the normal day item.
CXTPPaintManagerColor | m_clrDayText
This member variable is a COLORREF object that is used as the color of the usual day item.
CXTPPaintManagerColor | m_clrNonMonthDayBack
This member variable is a COLORREF object that is used as the background color of the non-month day item.
CXTPPaintManagerColor | m_clrNonMonthDayText
This member variable is a COLORREF object that is used as the color of the non-month day item.
CXTPPaintManagerColor | m_clrDaysOfWeekBack
This member variable is a COLORREF object that is used for the background color of the days of weeks area.
CXTPPaintManagerColor | m_clrDaysOfWeekText
This member variable is a COLORFEF object that is used as the text color of the days of weeks area.
CXTPPaintManagerColor | m_clrWeekNumbersBack
This member variable is a COLORREF object that is used as the background color of the week numbers area.
CXTPPaintManagerColor | m_clrWeekNumbersText
This member variable is a COLORREF object that is used as the text color of the week numbers items.
CXTPPaintManagerColor | m_clrButtonText
This member variable is a COLORREF object that is used as the color for the button text.
CXTPPaintManagerColor | m_clrButtonFace
This member variable is a COLORREF object that is used as the basic color for buttons.
CXTPPaintManagerColor | m_clrListControlBack
This member variable is a COLORREF object that is used as the background color of the pop-up month list control.
CXTPPaintManagerColor | m_clrListControlText
This member variable is a COLORREF object that is used as the text color of the pop-up month list control.
- Protected Member Functions inherited from CXTPDatePickerPaintManager
virtual void | Triangle (CDC *pDC, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clrColor=0)
This member function is used to draw a black triangle.
XTPCalendarTheme | GetPaintTheme () const
This member function is used to obtain current paint theme.
- Protected Attributes inherited from CXTPDatePickerPaintManager
COLORREF | m_clrStaticBorder
Static border color.
COLORREF | m_clr3DShadow
This member variable is a COLORREF object that is used to specify the color for shadow areas.
COLORREF | m_clr3DLight
This member variable is a COLORREF object that is used to specify the color for light areas.
COLORREF | m_clr3DFace
This member variable is a COL ORREF object that is used as the color for the button text.
COLORREF | m_clr3DText
This member variable is a COLORREF object that is used as the basic color for buttons.
CXTPFont | m_xtpFontDay
This member variable is a CXTPFont object that is used for the font -of the usual day item.
CXTPFont | m_xtpFontDayBold
This member variable is a CXTPFont object that is used for the font -of the bold day item.
CXTPFont | m_xtpFontNonMonthDay
This member variable is a CXTPFont object that is used as the font for the non-month day item.
CXTPFont | m_xtpFontHeader
This member variable is a CXTPFont object that is used as the font for the header text.
CXTPFont | m_xtpFontDaysOfWeek
This member variable is a CXTPFont object that is used as the font for the days of weeks text.
CXTPFont | m_xtpFontWeekNumbers
This member variable is a CXTPFont object that is used as the font for the week number items text.
CXTPFont | m_xtpFontListControl
This member variable is a CXTPFont object that is used as the font for the pop-up month list control.
CXTPFont | m_xtpFontButton
This member variable is a CXTPFont object that is used as the font for the button text.
BOOL | m_bEnableTheme
This member variable is a BOOL that is used to indicate if Luna colors are enabled.
CXTPWinThemeWrapper * | m_themeButton
This member variable is a CXTPWinThemeWrapper object that is used as the theme wrapper for the Paint Manager.
HCURSOR | m_hCursorBack
Back cursor for week selection.
XTPCalendarTheme | m_nPaintTheme
Store the Paint Theme;.

Detailed Description

Class CXTPDatePickerThemeOfficeXP is derived from CXTPDatePickerPaintManager for rendering an Office XP style for DatePicker control.

Example:

 if (m_bThemeOfficeXP)
 {
    CXTPDatePickerThemeOfficeXP* pThemeXP = new CXTPDatePickerThemeOfficeXP;
    m_wndDatePicker.SetTheme(pThemeXP);
 }
 else
 {
    m_wndDatePicker.SetTheme(NULL);
 }
See also
CXTPDatePickerThemeOfficeXP

Constructor & Destructor Documentation

◆ CXTPDatePickerThemeOfficeXP()

CXTPDatePickerThemeOfficeXP ( )

Default paint manager constructor.

Handles initial initialization.

See also
RefreshMetrics()

◆ ~CXTPDatePickerThemeOfficeXP()

virtual ~CXTPDatePickerThemeOfficeXP ( )
virtual

Default paint manager destructor.

Handles member item deallocation.

The documentation for this class was generated from the following file:
  • XTPDatePickerOfficeXPTheme.h


Toolkit Pro: CXTPDatePickerThemeResource Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPDatePickerThemeResource Class Reference

Class CXTPDatePickerThemeResource is derived from CXTPDatePickerPaintManager for rendering a Resource DLL style for DatePicker control. More...

Inheritance diagram for CXTPDatePickerThemeResource:
[legend]

Public Member Functions

CXTPDatePickerThemeResource ()
Default paint manager constructor.
virtual | ~CXTPDatePickerThemeResource ()
Default paint manager destructor.
virtual void | RefreshMetrics ()
This member function performs initialization for the Paint Manager.
virtual void | DrawButton (CDC *pDC, const CRect &rcButton, const CString &strButton, BOOL bIsDown, BOOL bIsHighLight)
This member function is used to draw the control's buttons.
- Public Member Functions inherited from CXTPDatePickerPaintManager
CXTPDatePickerPaintManager ()
Default paint manager constructor.
virtual | ~CXTPDatePickerPaintManager ()
Default paint manager destructor.
virtual void | DrawBackground (CDC *pDC, CRect rcClient)
This member function is called to fill the control's background.
virtual void | DrawBorder (CDC *pDC, const CXTPDatePickerControl *pControl, CRect &rcClient, BOOL bDraw)
This member function draws a border around the control.
virtual void | DrawScrollTriangle (CDC *pDC, CRect rcSpot, BOOL bLeftDirection, COLORREF clrColor=0, BOOL bYears=FALSE)
This member function draws scrolling triangles on the highest bounded month headers.
virtual COLORREF | GetControlBackColor ()
This member function is used to obtain the control's background color.
virtual COLORREF | GetDayBackColor ()
This member function is used to obtain the background color of the standard day item.
virtual COLORREF | GetDayTextColor ()
This member function is used to obtain the color of the standard day item.
virtual CFont * | GetDayTextFont ()
This member function is used to obtain a pointer to the font for the standard day item.
virtual CFont * | GetDayTextFontBold ()
This member function is used to obtain a pointer to the font for the bolded day item.
virtual COLORREF | GetNonMonthDayBackColor ()
This member function is used to obtain the background color of the non-month day item.
virtual COLORREF | GetNonMonthDayTextColor ()
This member function is used to obtain the color of the non-month day item.
CFont * | GetNonMonthDayTextFont ()
This member function is used to obtain the font of the non-month day item.
virtual COLORREF | GetSelectedDayBackColor ()
This member function is used to obtain the background color of the selected day item.
virtual COLORREF | GetSelectedDayTextColor ()
This member function obtains the color of the selected day item.
virtual COLORREF | GetMonthHeaderBackColor ()
This member function obtains the background color of the month header area.
virtual COLORREF | GetMonthHeaderTextColor ()
This member function obtains the text color of the month header area.
CFont * | GetHeaderTextFont ()
This member function obtains the font of the month header area text.
virtual COLORREF | GetDaysOfWeekBackColor ()
This member function returns the background color of the days of weeks area.
virtual COLORREF | GetDaysOfWeekTextColor ()
This member function obtains the text color of the days of weeks area.
CFont * | GetDaysOfWeekTextFont ()
This member function obtains the font of the days of weeks area text.
virtual COLORREF | GetWeekNumbersBackColor ()
This member function obtains the background color of the week numbers area.
virtual COLORREF | GetWeekNumbersTextColor ()
This member function obtains the text color of the week numbers items.
CFont * | GetWeekNumbersTextFont ()
This member function obtains the font of the week numbers items.
virtual COLORREF | GetListControlBackColor ()
This member function obtains the background color of the pop-up month list control.
virtual COLORREF | GetListControlTextColor ()
This member function obtains the text color of the pop-up month list control.
CFont * | GetListControlTextFont ()
This member function obtains the font of the pop-up month list control.
virtual COLORREF | GetHighlightTodayColor ()
This member function obtains the highlighting color of the "Today" item.
void | SetButtonFont (CFont *fontButton)
This member function sets the button's font.
void | SetButtonFontIndirect (LOGFONT *lFont)
This member function sets the button's font using a LOGFONT structure.
CFont * | GetButtonFont ()
This member function is used to obtain the button's font object.
void | SetFontIndirect (LOGFONT *lFont)
This member function is used to set the control's default font using a LOGFONT structure.
virtual BOOL | DrawDay (CDC *pDC, CXTPDatePickerItemDay *pDay)
Call this member function to draw a single month day in the month area.
virtual void | DrawMonthHeader (CDC *pDC, CXTPDatePickerItemMonth *pMonth)
Call this member function to draw the month header in the month area.
virtual void | DrawWeekNumbers (CDC *pDC, CXTPDatePickerItemMonth *pMonth)
Call this member function to draw the week numbers in the month area.
virtual void | DrawDaysOfWeek (CDC *pDC, CXTPDatePickerItemMonth *pMonth)
Call this member function to draw the days of the week in the month header.
virtual CSize | CalcDayRect (CDC *pDC)
This member function is used to calculate the day's bounding rectangle coordinates.
virtual CSize | CalcMonthHeaderRect (CDC *pDC)
This member function calculates the month's header bounding rectangle coordinates.
virtual CSize | CalcDayOfWeekRect (CDC *pDC)
This member function calculates the "day of week names" bounding rectangle coordinates.
virtual CSize | CalcWeekNumbersRect (CDC *pDC)
This member function calculates the "week numbers" bounding rectangle coordinates.
virtual CSize | CalcMonthRect (CDC *pDC)
This member function calculates the month's bounding rectangle coordinates.
virtual void | EnableTheme (BOOL bEnableTheme)
This member function is used to switch "Themes".
virtual HCURSOR | GetCursorBack ()
This member function is used to obtain the back cursor used for weeks selection.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

COLORREF | GetResourceColor (LPCTSTR pcszColorName, COLORREF clrDefault)
Call this member function to return the COLORREF value for the specified color name located in the Resource DLL INI file.
- Protected Member Functions inherited from CXTPDatePickerPaintManager
virtual void | Triangle (CDC *pDC, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clrColor=0)
This member function is used to draw a black triangle.
XTPCalendarTheme | GetPaintTheme () const
This member function is used to obtain current paint theme.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPDatePickerPaintManager
CSize | m_szDayMargin
This member function is used to set current paint theme.
CXTPPaintManagerColor | m_clrControlBack
This member variable is a COLORREF object that is used as the background color of the control.
CXTPPaintManagerColor | m_clrHighlightToday
This member variable is a COLORREF object that is used as the color for highlighting the "Today" item.
CXTPPaintManagerColor | m_clrSelectedDayBack
This member variable is a COLORREF object that is used as the background color of the selected day item.
CXTPPaintManagerColor | m_clrMonthHeaderBack
This member variable is a COLORREF object that is used as the background color of the month header area.
CXTPPaintManagerColor | m_clrMonthHeaderText
This member variable is a COLORREF object that is used as the text color of the month header area.
CXTPPaintManagerColor | m_clrSelectedDayText
This member variable is a COLORREF object that is used as the color of the selected day item.
CXTPPaintManagerColor | m_clrMonthBorder
This member variable is a COLORREF object that is used as the color of the border between day of month and week numbers or days of week.
CXTPPaintManagerColor | m_clrMonthHeaderButton
This member variable is a COLORREF object that is used as the color for the scroll's triangle button.
CXTPPaintManagerColor | m_clrDayBack
This member variable is a COLORREF object that is used as the background color of the normal day item.
CXTPPaintManagerColor | m_clrDayText
This member variable is a COLORREF object that is used as the color of the usual day item.
CXTPPaintManagerColor | m_clrNonMonthDayBack
This member variable is a COLORREF object that is used as the background color of the non-month day item.
CXTPPaintManagerColor | m_clrNonMonthDayText
This member variable is a COLORREF object that is used as the color of the non-month day item.
CXTPPaintManagerColor | m_clrDaysOfWeekBack
This member variable is a COLORREF object that is used for the background color of the days of weeks area.
CXTPPaintManagerColor | m_clrDaysOfWeekText
This member variable is a COLORFEF object that is used as the text color of the days of weeks area.
CXTPPaintManagerColor | m_clrWeekNumbersBack
This member variable is a COLORREF object that is used as the background color of the week numbers area.
CXTPPaintManagerColor | m_clrWeekNumbersText
This member variable is a COLORREF object that is used as the text color of the week numbers items.
CXTPPaintManagerColor | m_clrButtonText
This member variable is a COLORREF object that is used as the color for the button text.
CXTPPaintManagerColor | m_clrButtonFace
This member variable is a COLORREF object that is used as the basic color for buttons.
CXTPPaintManagerColor | m_clrListControlBack
This member variable is a COLORREF object that is used as the background color of the pop-up month list control.
CXTPPaintManagerColor | m_clrListControlText
This member variable is a COLORREF object that is used as the text color of the pop-up month list control.
- Protected Attributes inherited from CXTPDatePickerPaintManager
COLORREF | m_clrStaticBorder
Static border color.
COLORREF | m_clr3DShadow
This member variable is a COLORREF object that is used to specify the color for shadow areas.
COLORREF | m_clr3DLight
This member variable is a COLORREF object that is used to specify the color for light areas.
COLORREF | m_clr3DFace
This member variable is a COL ORREF object that is used as the color for the button text.
COLORREF | m_clr3DText
This member variable is a COLORREF object that is used as the basic color for buttons.
CXTPFont | m_xtpFontDay
This member variable is a CXTPFont object that is used for the font -of the usual day item.
CXTPFont | m_xtpFontDayBold
This member variable is a CXTPFont object that is used for the font -of the bold day item.
CXTPFont | m_xtpFontNonMonthDay
This member variable is a CXTPFont object that is used as the font for the non-month day item.
CXTPFont | m_xtpFontHeader
This member variable is a CXTPFont object that is used as the font for the header text.
CXTPFont | m_xtpFontDaysOfWeek
This member variable is a CXTPFont object that is used as the font for the days of weeks text.
CXTPFont | m_xtpFontWeekNumbers
This member variable is a CXTPFont object that is used as the font for the week number items text.
CXTPFont | m_xtpFontListControl
This member variable is a CXTPFont object that is used as the font for the pop-up month list control.
CXTPFont | m_xtpFontButton
This member variable is a CXTPFont object that is used as the font for the button text.
BOOL | m_bEnableTheme
This member variable is a BOOL that is used to indicate if Luna colors are enabled.
CXTPWinThemeWrapper * | m_themeButton
This member variable is a CXTPWinThemeWrapper object that is used as the theme wrapper for the Paint Manager.
HCURSOR | m_hCursorBack
Back cursor for week selection.
XTPCalendarTheme | m_nPaintTheme
Store the Paint Theme;.

Detailed Description

Class CXTPDatePickerThemeResource is derived from CXTPDatePickerPaintManager for rendering a Resource DLL style for DatePicker control.

Example:

 if (m_bThemeResource)
 {
    CXTPDatePickerThemeResource* pThemeResource = new CXTPDatePickerThemeResource;
    m_wndDatePicker.SetTheme(pThemeResource);
 }
 else
 {
    m_wndDatePicker.SetTheme(NULL);
 }
See also
CXTPDatePickerThemeResource

Constructor & Destructor Documentation

◆ CXTPDatePickerThemeResource()

CXTPDatePickerThemeResource ( )

Default paint manager constructor.

Handles initial initialization.

See also
RefreshMetrics()

◆ ~CXTPDatePickerThemeResource()

virtual ~CXTPDatePickerThemeResource ( )
virtual

Default paint manager destructor.

Handles member item deallocation.

Member Function Documentation

◆ DrawButton()

virtual void DrawButton | ( | CDC * | pDC,
 |  | const CRect & | rcButton,
 |  | const CString & | strButton,
 |  | BOOL | bIsDown,
 |  | BOOL | bIsHighLight )
 virtual

This member function is used to draw the control's buttons.

Parameters
pDC | Pointer to a valid device context.
rcButton | A CRect that contains the button area bounding rectangle coordinates.
strButton | A CString that contains the string of the button's text.
bIsDown | A BOOL that determines if the button is down or up.
bIsHighLight | A BOOL that determines if the button is highlighted.

Use this member function to draw buttons in the appropriate state. The state depends on the bIsDown parameter, the button may be drawn pressed or released. Furthermore, depending on the bIsHighLight, the button may be drawn with highlighted borders.

Example:

for (int i = 0; i < GetButtonCount(); i++)
{
CXTPDatePickerButton* pButton = GetButton(i);
if (pButton->m_bVisible)
   DrawButton(pDC, pButton->m_rcButton, pButton->m_strCaption,
   pButton->m_bPressed, pButton->m_bHighlight);
}

Reimplemented from CXTPDatePickerPaintManager.

◆ GetResourceColor()

COLORREF GetResourceColor | ( | LPCTSTR | pcszColorName,
 |  | COLORREF | clrDefault )
 protected

Call this member function to return the COLORREF value for the specified color name located in the Resource DLL INI file.

Parameters
pcszColorName | A text string representing the color name specified in the Resource DLL
clrDefault | Default RGB value to be returned if the color was not found in the Resource DLL.
Returns
An RGB COLORREF value representing the color name if located in the Resource DLL, otherwise returns the specified default color.

◆ RefreshMetrics()

virtual void RefreshMetrics ( )
virtual

This member function performs initialization for the Paint Manager.

Initializes all drawing defaults (fonts, colors, etc.). Most of defaults are system defaults.

Reimplemented from CXTPDatePickerPaintManager.

The documentation for this class was generated from the following file:
  • XTPDatePickerResourceTheme.h


Toolkit Pro: CXTPDatePickerThemeVisualStudio2015 Class Reference

Public Member Functions | List of all members
CXTPDatePickerThemeVisualStudio2015 Class Reference

Class CXTPDatePickerThemeVisualStudio2015 is derived from CXTPDatePickerThemeOffice2013 for rendering an Visual Studio 2015 style for DatePicker control. More...

Inheritance diagram for CXTPDatePickerThemeVisualStudio2015:
[legend]

Public Member Functions

CXTPDatePickerThemeVisualStudio2015 ()
Default paint manager constructor.
virtual | ~CXTPDatePickerThemeVisualStudio2015 ()
Default paint manager destructor.
- Public Member Functions inherited from CXTPDatePickerThemeOffice2013
CXTPDatePickerThemeOffice2013 ()
Default paint manager constructor.
virtual | ~CXTPDatePickerThemeOffice2013 ()
Default paint manager destructor.
virtual void | RefreshMetrics ()
This member function performs initialization for the Paint Manager.
virtual void | DrawBackground (CDC *pDC, CRect rcClient)
This member function is called to fill the control's background.
virtual void | DrawWeekNumbers (CDC *pDC, CXTPDatePickerItemMonth *pMonth)
Call this member function to draw the week numbers in the month area.
virtual void | DrawDaysOfWeek (CDC *pDC, CXTPDatePickerItemMonth *pMonth)
Call this member function to draw the days of the week in the month header.
virtual void | DrawBorder (CDC *pDC, const CXTPDatePickerControl *pControl, CRect &rcClient, BOOL bDraw)
This member function draws a border around the control.
virtual BOOL | DrawDay (CDC *pDC, CXTPDatePickerItemDay *pDay)
Call this member function to draw a single month day in the month area.
virtual void | DrawButton (CDC *pDC, const CRect &rcButton, const CString &strButton, BOOL bIsDown, BOOL bIsHighLight)
This member function is used to draw the control's buttons.
virtual COLORREF | GetHighlightTodayBackColor ()
Call this member function to retrieve the background color for the highlight today item.
virtual COLORREF | GetHighlightTodayTextColor ()
Call this member function to retrieve the foreground (text) color for the highlight today item.
virtual COLORREF | GetHighlightTodayBorderColor ()
Call this member function to retrieve the Border color for the highlight today item.
- Public Member Functions inherited from CXTPDatePickerPaintManager
CXTPDatePickerPaintManager ()
Default paint manager constructor.
virtual | ~CXTPDatePickerPaintManager ()
Default paint manager destructor.
virtual void | DrawScrollTriangle (CDC *pDC, CRect rcSpot, BOOL bLeftDirection, COLORREF clrColor=0, BOOL bYears=FALSE)
This member function draws scrolling triangles on the highest bounded month headers.
virtual COLORREF | GetControlBackColor ()
This member function is used to obtain the control's background color.
virtual COLORREF | GetDayBackColor ()
This member function is used to obtain the background color of the standard day item.
virtual COLORREF | GetDayTextColor ()
This member function is used to obtain the color of the standard day item.
virtual CFont * | GetDayTextFont ()
This member function is used to obtain a pointer to the font for the standard day item.
virtual CFont * | GetDayTextFontBold ()
This member function is used to obtain a pointer to the font for the bolded day item.
virtual COLORREF | GetNonMonthDayBackColor ()
This member function is used to obtain the background color of the non-month day item.
virtual COLORREF | GetNonMonthDayTextColor ()
This member function is used to obtain the color of the non-month day item.
CFont * | GetNonMonthDayTextFont ()
This member function is used to obtain the font of the non-month day item.
virtual COLORREF | GetSelectedDayBackColor ()
This member function is used to obtain the background color of the selected day item.
virtual COLORREF | GetSelectedDayTextColor ()
This member function obtains the color of the selected day item.
virtual COLORREF | GetMonthHeaderBackColor ()
This member function obtains the background color of the month header area.
virtual COLORREF | GetMonthHeaderTextColor ()
This member function obtains the text color of the month header area.
CFont * | GetHeaderTextFont ()
This member function obtains the font of the month header area text.
virtual COLORREF | GetDaysOfWeekBackColor ()
This member function returns the background color of the days of weeks area.
virtual COLORREF | GetDaysOfWeekTextColor ()
This member function obtains the text color of the days of weeks area.
CFont * | GetDaysOfWeekTextFont ()
This member function obtains the font of the days of weeks area text.
virtual COLORREF | GetWeekNumbersBackColor ()
This member function obtains the background color of the week numbers area.
virtual COLORREF | GetWeekNumbersTextColor ()
This member function obtains the text color of the week numbers items.
CFont * | GetWeekNumbersTextFont ()
This member function obtains the font of the week numbers items.
virtual COLORREF | GetListControlBackColor ()
This member function obtains the background color of the pop-up month list control.
virtual COLORREF | GetListControlTextColor ()
This member function obtains the text color of the pop-up month list control.
CFont * | GetListControlTextFont ()
This member function obtains the font of the pop-up month list control.
virtual COLORREF | GetHighlightTodayColor ()
This member function obtains the highlighting color of the "Today" item.
void | SetButtonFont (CFont *fontButton)
This member function sets the button's font.
void | SetButtonFontIndirect (LOGFONT *lFont)
This member function sets the button's font using a LOGFONT structure.
CFont * | GetButtonFont ()
This member function is used to obtain the button's font object.
void | SetFontIndirect (LOGFONT *lFont)
This member function is used to set the control's default font using a LOGFONT structure.
virtual void | DrawMonthHeader (CDC *pDC, CXTPDatePickerItemMonth *pMonth)
Call this member function to draw the month header in the month area.
virtual CSize | CalcDayRect (CDC *pDC)
This member function is used to calculate the day's bounding rectangle coordinates.
virtual CSize | CalcMonthHeaderRect (CDC *pDC)
This member function calculates the month's header bounding rectangle coordinates.
virtual CSize | CalcDayOfWeekRect (CDC *pDC)
This member function calculates the "day of week names" bounding rectangle coordinates.
virtual CSize | CalcWeekNumbersRect (CDC *pDC)
This member function calculates the "week numbers" bounding rectangle coordinates.
virtual CSize | CalcMonthRect (CDC *pDC)
This member function calculates the month's bounding rectangle coordinates.
virtual void | EnableTheme (BOOL bEnableTheme)
This member function is used to switch "Themes".
virtual HCURSOR | GetCursorBack ()
This member function is used to obtain the back cursor used for weeks selection.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPDatePickerPaintManager
CSize | m_szDayMargin
This member function is used to set current paint theme.
CXTPPaintManagerColor | m_clrControlBack
This member variable is a COLORREF object that is used as the background color of the control.
CXTPPaintManagerColor | m_clrHighlightToday
This member variable is a COLORREF object that is used as the color for highlighting the "Today" item.
CXTPPaintManagerColor | m_clrSelectedDayBack
This member variable is a COLORREF object that is used as the background color of the selected day item.
CXTPPaintManagerColor | m_clrMonthHeaderBack
This member variable is a COLORREF object that is used as the background color of the month header area.
CXTPPaintManagerColor | m_clrMonthHeaderText
This member variable is a COLORREF object that is used as the text color of the month header area.
CXTPPaintManagerColor | m_clrSelectedDayText
This member variable is a COLORREF object that is used as the color of the selected day item.
CXTPPaintManagerColor | m_clrMonthBorder
This member variable is a COLORREF object that is used as the color of the border between day of month and week numbers or days of week.
CXTPPaintManagerColor | m_clrMonthHeaderButton
This member variable is a COLORREF object that is used as the color for the scroll's triangle button.
CXTPPaintManagerColor | m_clrDayBack
This member variable is a COLORREF object that is used as the background color of the normal day item.
CXTPPaintManagerColor | m_clrDayText
This member variable is a COLORREF object that is used as the color of the usual day item.
CXTPPaintManagerColor | m_clrNonMonthDayBack
This member variable is a COLORREF object that is used as the background color of the non-month day item.
CXTPPaintManagerColor | m_clrNonMonthDayText
This member variable is a COLORREF object that is used as the color of the non-month day item.
CXTPPaintManagerColor | m_clrDaysOfWeekBack
This member variable is a COLORREF object that is used for the background color of the days of weeks area.
CXTPPaintManagerColor | m_clrDaysOfWeekText
This member variable is a COLORFEF object that is used as the text color of the days of weeks area.
CXTPPaintManagerColor | m_clrWeekNumbersBack
This member variable is a COLORREF object that is used as the background color of the week numbers area.
CXTPPaintManagerColor | m_clrWeekNumbersText
This member variable is a COLORREF object that is used as the text color of the week numbers items.
CXTPPaintManagerColor | m_clrButtonText
This member variable is a COLORREF object that is used as the color for the button text.
CXTPPaintManagerColor | m_clrButtonFace
This member variable is a COLORREF object that is used as the basic color for buttons.
CXTPPaintManagerColor | m_clrListControlBack
This member variable is a COLORREF object that is used as the background color of the pop-up month list control.
CXTPPaintManagerColor | m_clrListControlText
This member variable is a COLORREF object that is used as the text color of the pop-up month list control.
- Protected Member Functions inherited from CXTPDatePickerPaintManager
virtual void | Triangle (CDC *pDC, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clrColor=0)
This member function is used to draw a black triangle.
XTPCalendarTheme | GetPaintTheme () const
This member function is used to obtain current paint theme.
- Protected Attributes inherited from CXTPDatePickerThemeOffice2013
CXTPPaintManagerColorGradient | m_clrBackground
This member variable represents two COLORREF objects that is used as the dark and light background gradient color of the control.
- Protected Attributes inherited from CXTPDatePickerPaintManager
COLORREF | m_clrStaticBorder
Static border color.
COLORREF | m_clr3DShadow
This member variable is a COLORREF object that is used to specify the color for shadow areas.
COLORREF | m_clr3DLight
This member variable is a COLORREF object that is used to specify the color for light areas.
COLORREF | m_clr3DFace
This member variable is a COL ORREF object that is used as the color for the button text.
COLORREF | m_clr3DText
This member variable is a COLORREF object that is used as the basic color for buttons.
CXTPFont | m_xtpFontDay
This member variable is a CXTPFont object that is used for the font -of the usual day item.
CXTPFont | m_xtpFontDayBold
This member variable is a CXTPFont object that is used for the font -of the bold day item.
CXTPFont | m_xtpFontNonMonthDay
This member variable is a CXTPFont object that is used as the font for the non-month day item.
CXTPFont | m_xtpFontHeader
This member variable is a CXTPFont object that is used as the font for the header text.
CXTPFont | m_xtpFontDaysOfWeek
This member variable is a CXTPFont object that is used as the font for the days of weeks text.
CXTPFont | m_xtpFontWeekNumbers
This member variable is a CXTPFont object that is used as the font for the week number items text.
CXTPFont | m_xtpFontListControl
This member variable is a CXTPFont object that is used as the font for the pop-up month list control.
CXTPFont | m_xtpFontButton
This member variable is a CXTPFont object that is used as the font for the button text.
BOOL | m_bEnableTheme
This member variable is a BOOL that is used to indicate if Luna colors are enabled.
CXTPWinThemeWrapper * | m_themeButton
This member variable is a CXTPWinThemeWrapper object that is used as the theme wrapper for the Paint Manager.
HCURSOR | m_hCursorBack
Back cursor for week selection.
XTPCalendarTheme | m_nPaintTheme
Store the Paint Theme;.

Detailed Description

Class CXTPDatePickerThemeVisualStudio2015 is derived from CXTPDatePickerThemeOffice2013 for rendering an Visual Studio 2015 style for DatePicker control.

Example:

 if (m_bThemeVisualStudio2015)
 {
    CXTPDatePickerThemeVisualStudio2015* pTheme = new CXTPDatePickerThemeVisualStudio2015;
    m_wndDatePicker.SetTheme(pTheme);
 }
 else
 {
    m_wndDatePicker.SetTheme(NULL);
 }
See also
CXTPDatePickerThemeVisualStudio2015

Constructor & Destructor Documentation

◆ CXTPDatePickerThemeVisualStudio2015()

CXTPDatePickerThemeVisualStudio2015 ( )

Default paint manager constructor.

Handles initial initialization.

See also
RefreshMetrics()

◆ ~CXTPDatePickerThemeVisualStudio2015()

virtual ~CXTPDatePickerThemeVisualStudio2015 ( )
virtual

Default paint manager destructor.

Handles member item deallocation.

The documentation for this class was generated from the following file:
  • XTPDatePickerVisualStudio2015Theme.h


Toolkit Pro: CXTPDatePickerThemeVisualStudio2017 Class Reference

Public Member Functions | List of all members
CXTPDatePickerThemeVisualStudio2017 Class Reference

Class CXTPDatePickerThemeVisualStudio2017 is derived from CXTPDatePickerThemeOffice2013 for rendering an Visual Studio 2017 style for DatePicker control. More...

Inheritance diagram for CXTPDatePickerThemeVisualStudio2017:
[legend]

Public Member Functions

CXTPDatePickerThemeVisualStudio2017 ()
Default paint manager constructor.
virtual | ~CXTPDatePickerThemeVisualStudio2017 ()
Default paint manager destructor.
- Public Member Functions inherited from CXTPDatePickerThemeOffice2013
CXTPDatePickerThemeOffice2013 ()
Default paint manager constructor.
virtual | ~CXTPDatePickerThemeOffice2013 ()
Default paint manager destructor.
virtual void | RefreshMetrics ()
This member function performs initialization for the Paint Manager.
virtual void | DrawBackground (CDC *pDC, CRect rcClient)
This member function is called to fill the control's background.
virtual void | DrawWeekNumbers (CDC *pDC, CXTPDatePickerItemMonth *pMonth)
Call this member function to draw the week numbers in the month area.
virtual void | DrawDaysOfWeek (CDC *pDC, CXTPDatePickerItemMonth *pMonth)
Call this member function to draw the days of the week in the month header.
virtual void | DrawBorder (CDC *pDC, const CXTPDatePickerControl *pControl, CRect &rcClient, BOOL bDraw)
This member function draws a border around the control.
virtual BOOL | DrawDay (CDC *pDC, CXTPDatePickerItemDay *pDay)
Call this member function to draw a single month day in the month area.
virtual void | DrawButton (CDC *pDC, const CRect &rcButton, const CString &strButton, BOOL bIsDown, BOOL bIsHighLight)
This member function is used to draw the control's buttons.
virtual COLORREF | GetHighlightTodayBackColor ()
Call this member function to retrieve the background color for the highlight today item.
virtual COLORREF | GetHighlightTodayTextColor ()
Call this member function to retrieve the foreground (text) color for the highlight today item.
virtual COLORREF | GetHighlightTodayBorderColor ()
Call this member function to retrieve the Border color for the highlight today item.
- Public Member Functions inherited from CXTPDatePickerPaintManager
CXTPDatePickerPaintManager ()
Default paint manager constructor.
virtual | ~CXTPDatePickerPaintManager ()
Default paint manager destructor.
virtual void | DrawScrollTriangle (CDC *pDC, CRect rcSpot, BOOL bLeftDirection, COLORREF clrColor=0, BOOL bYears=FALSE)
This member function draws scrolling triangles on the highest bounded month headers.
virtual COLORREF | GetControlBackColor ()
This member function is used to obtain the control's background color.
virtual COLORREF | GetDayBackColor ()
This member function is used to obtain the background color of the standard day item.
virtual COLORREF | GetDayTextColor ()
This member function is used to obtain the color of the standard day item.
virtual CFont * | GetDayTextFont ()
This member function is used to obtain a pointer to the font for the standard day item.
virtual CFont * | GetDayTextFontBold ()
This member function is used to obtain a pointer to the font for the bolded day item.
virtual COLORREF | GetNonMonthDayBackColor ()
This member function is used to obtain the background color of the non-month day item.
virtual COLORREF | GetNonMonthDayTextColor ()
This member function is used to obtain the color of the non-month day item.
CFont * | GetNonMonthDayTextFont ()
This member function is used to obtain the font of the non-month day item.
virtual COLORREF | GetSelectedDayBackColor ()
This member function is used to obtain the background color of the selected day item.
virtual COLORREF | GetSelectedDayTextColor ()
This member function obtains the color of the selected day item.
virtual COLORREF | GetMonthHeaderBackColor ()
This member function obtains the background color of the month header area.
virtual COLORREF | GetMonthHeaderTextColor ()
This member function obtains the text color of the month header area.
CFont * | GetHeaderTextFont ()
This member function obtains the font of the month header area text.
virtual COLORREF | GetDaysOfWeekBackColor ()
This member function returns the background color of the days of weeks area.
virtual COLORREF | GetDaysOfWeekTextColor ()
This member function obtains the text color of the days of weeks area.
CFont * | GetDaysOfWeekTextFont ()
This member function obtains the font of the days of weeks area text.
virtual COLORREF | GetWeekNumbersBackColor ()
This member function obtains the background color of the week numbers area.
virtual COLORREF | GetWeekNumbersTextColor ()
This member function obtains the text color of the week numbers items.
CFont * | GetWeekNumbersTextFont ()
This member function obtains the font of the week numbers items.
virtual COLORREF | GetListControlBackColor ()
This member function obtains the background color of the pop-up month list control.
virtual COLORREF | GetListControlTextColor ()
This member function obtains the text color of the pop-up month list control.
CFont * | GetListControlTextFont ()
This member function obtains the font of the pop-up month list control.
virtual COLORREF | GetHighlightTodayColor ()
This member function obtains the highlighting color of the "Today" item.
void | SetButtonFont (CFont *fontButton)
This member function sets the button's font.
void | SetButtonFontIndirect (LOGFONT *lFont)
This member function sets the button's font using a LOGFONT structure.
CFont * | GetButtonFont ()
This member function is used to obtain the button's font object.
void | SetFontIndirect (LOGFONT *lFont)
This member function is used to set the control's default font using a LOGFONT structure.
virtual void | DrawMonthHeader (CDC *pDC, CXTPDatePickerItemMonth *pMonth)
Call this member function to draw the month header in the month area.
virtual CSize | CalcDayRect (CDC *pDC)
This member function is used to calculate the day's bounding rectangle coordinates.
virtual CSize | CalcMonthHeaderRect (CDC *pDC)
This member function calculates the month's header bounding rectangle coordinates.
virtual CSize | CalcDayOfWeekRect (CDC *pDC)
This member function calculates the "day of week names" bounding rectangle coordinates.
virtual CSize | CalcWeekNumbersRect (CDC *pDC)
This member function calculates the "week numbers" bounding rectangle coordinates.
virtual CSize | CalcMonthRect (CDC *pDC)
This member function calculates the month's bounding rectangle coordinates.
virtual void | EnableTheme (BOOL bEnableTheme)
This member function is used to switch "Themes".
virtual HCURSOR | GetCursorBack ()
This member function is used to obtain the back cursor used for weeks selection.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPDatePickerPaintManager
CSize | m_szDayMargin
This member function is used to set current paint theme.
CXTPPaintManagerColor | m_clrControlBack
This member variable is a COLORREF object that is used as the background color of the control.
CXTPPaintManagerColor | m_clrHighlightToday
This member variable is a COLORREF object that is used as the color for highlighting the "Today" item.
CXTPPaintManagerColor | m_clrSelectedDayBack
This member variable is a COLORREF object that is used as the background color of the selected day item.
CXTPPaintManagerColor | m_clrMonthHeaderBack
This member variable is a COLORREF object that is used as the background color of the month header area.
CXTPPaintManagerColor | m_clrMonthHeaderText
This member variable is a COLORREF object that is used as the text color of the month header area.
CXTPPaintManagerColor | m_clrSelectedDayText
This member variable is a COLORREF object that is used as the color of the selected day item.
CXTPPaintManagerColor | m_clrMonthBorder
This member variable is a COLORREF object that is used as the color of the border between day of month and week numbers or days of week.
CXTPPaintManagerColor | m_clrMonthHeaderButton
This member variable is a COLORREF object that is used as the color for the scroll's triangle button.
CXTPPaintManagerColor | m_clrDayBack
This member variable is a COLORREF object that is used as the background color of the normal day item.
CXTPPaintManagerColor | m_clrDayText
This member variable is a COLORREF object that is used as the color of the usual day item.
CXTPPaintManagerColor | m_clrNonMonthDayBack
This member variable is a COLORREF object that is used as the background color of the non-month day item.
CXTPPaintManagerColor | m_clrNonMonthDayText
This member variable is a COLORREF object that is used as the color of the non-month day item.
CXTPPaintManagerColor | m_clrDaysOfWeekBack
This member variable is a COLORREF object that is used for the background color of the days of weeks area.
CXTPPaintManagerColor | m_clrDaysOfWeekText
This member variable is a COLORFEF object that is used as the text color of the days of weeks area.
CXTPPaintManagerColor | m_clrWeekNumbersBack
This member variable is a COLORREF object that is used as the background color of the week numbers area.
CXTPPaintManagerColor | m_clrWeekNumbersText
This member variable is a COLORREF object that is used as the text color of the week numbers items.
CXTPPaintManagerColor | m_clrButtonText
This member variable is a COLORREF object that is used as the color for the button text.
CXTPPaintManagerColor | m_clrButtonFace
This member variable is a COLORREF object that is used as the basic color for buttons.
CXTPPaintManagerColor | m_clrListControlBack
This member variable is a COLORREF object that is used as the background color of the pop-up month list control.
CXTPPaintManagerColor | m_clrListControlText
This member variable is a COLORREF object that is used as the text color of the pop-up month list control.
- Protected Member Functions inherited from CXTPDatePickerPaintManager
virtual void | Triangle (CDC *pDC, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clrColor=0)
This member function is used to draw a black triangle.
XTPCalendarTheme | GetPaintTheme () const
This member function is used to obtain current paint theme.
- Protected Attributes inherited from CXTPDatePickerThemeOffice2013
CXTPPaintManagerColorGradient | m_clrBackground
This member variable represents two COLORREF objects that is used as the dark and light background gradient color of the control.
- Protected Attributes inherited from CXTPDatePickerPaintManager
COLORREF | m_clrStaticBorder
Static border color.
COLORREF | m_clr3DShadow
This member variable is a COLORREF object that is used to specify the color for shadow areas.
COLORREF | m_clr3DLight
This member variable is a COLORREF object that is used to specify the color for light areas.
COLORREF | m_clr3DFace
This member variable is a COL ORREF object that is used as the color for the button text.
COLORREF | m_clr3DText
This member variable is a COLORREF object that is used as the basic color for buttons.
CXTPFont | m_xtpFontDay
This member variable is a CXTPFont object that is used for the font -of the usual day item.
CXTPFont | m_xtpFontDayBold
This member variable is a CXTPFont object that is used for the font -of the bold day item.
CXTPFont | m_xtpFontNonMonthDay
This member variable is a CXTPFont object that is used as the font for the non-month day item.
CXTPFont | m_xtpFontHeader
This member variable is a CXTPFont object that is used as the font for the header text.
CXTPFont | m_xtpFontDaysOfWeek
This member variable is a CXTPFont object that is used as the font for the days of weeks text.
CXTPFont | m_xtpFontWeekNumbers
This member variable is a CXTPFont object that is used as the font for the week number items text.
CXTPFont | m_xtpFontListControl
This member variable is a CXTPFont object that is used as the font for the pop-up month list control.
CXTPFont | m_xtpFontButton
This member variable is a CXTPFont object that is used as the font for the button text.
BOOL | m_bEnableTheme
This member variable is a BOOL that is used to indicate if Luna colors are enabled.
CXTPWinThemeWrapper * | m_themeButton
This member variable is a CXTPWinThemeWrapper object that is used as the theme wrapper for the Paint Manager.
HCURSOR | m_hCursorBack
Back cursor for week selection.
XTPCalendarTheme | m_nPaintTheme
Store the Paint Theme;.

Detailed Description

Class CXTPDatePickerThemeVisualStudio2017 is derived from CXTPDatePickerThemeOffice2013 for rendering an Visual Studio 2017 style for DatePicker control.

Example:

 if (m_bThemeVisualStudio2017)
 {
    CXTPDatePickerThemeVisualStudio2017* pTheme = new CXTPDatePickerThemeVisualStudio2017;
    m_wndDatePicker.SetTheme(pTheme);
 }
 else
 {
    m_wndDatePicker.SetTheme(NULL);
 }
See also
CXTPDatePickerThemeVisualStudio2017

Constructor & Destructor Documentation

◆ CXTPDatePickerThemeVisualStudio2017()

CXTPDatePickerThemeVisualStudio2017 ( )

Default paint manager constructor.

Handles initial initialization.

See also
RefreshMetrics()

◆ ~CXTPDatePickerThemeVisualStudio2017()

virtual ~CXTPDatePickerThemeVisualStudio2017 ( )
virtual

Default paint manager destructor.

Handles member item deallocation.

The documentation for this class was generated from the following file:
  • XTPDatePickerVisualStudio2017Theme.h


Toolkit Pro: CXTPDatePickerThemeVisualStudio2019 Class Reference

Public Member Functions | List of all members
CXTPDatePickerThemeVisualStudio2019 Class Reference

Class CXTPDatePickerThemeVisualStudio2019 is derived from CXTPDatePickerThemeOffice2013 for rendering an Visual Studio 2019 style for DatePicker control. More...

Inheritance diagram for CXTPDatePickerThemeVisualStudio2019:
[legend]

Public Member Functions

CXTPDatePickerThemeVisualStudio2019 ()
Default paint manager constructor.
virtual | ~CXTPDatePickerThemeVisualStudio2019 ()
Default paint manager destructor.
- Public Member Functions inherited from CXTPDatePickerThemeOffice2013
CXTPDatePickerThemeOffice2013 ()
Default paint manager constructor.
virtual | ~CXTPDatePickerThemeOffice2013 ()
Default paint manager destructor.
virtual void | RefreshMetrics ()
This member function performs initialization for the Paint Manager.
virtual void | DrawBackground (CDC *pDC, CRect rcClient)
This member function is called to fill the control's background.
virtual void | DrawWeekNumbers (CDC *pDC, CXTPDatePickerItemMonth *pMonth)
Call this member function to draw the week numbers in the month area.
virtual void | DrawDaysOfWeek (CDC *pDC, CXTPDatePickerItemMonth *pMonth)
Call this member function to draw the days of the week in the month header.
virtual void | DrawBorder (CDC *pDC, const CXTPDatePickerControl *pControl, CRect &rcClient, BOOL bDraw)
This member function draws a border around the control.
virtual BOOL | DrawDay (CDC *pDC, CXTPDatePickerItemDay *pDay)
Call this member function to draw a single month day in the month area.
virtual void | DrawButton (CDC *pDC, const CRect &rcButton, const CString &strButton, BOOL bIsDown, BOOL bIsHighLight)
This member function is used to draw the control's buttons.
virtual COLORREF | GetHighlightTodayBackColor ()
Call this member function to retrieve the background color for the highlight today item.
virtual COLORREF | GetHighlightTodayTextColor ()
Call this member function to retrieve the foreground (text) color for the highlight today item.
virtual COLORREF | GetHighlightTodayBorderColor ()
Call this member function to retrieve the Border color for the highlight today item.
- Public Member Functions inherited from CXTPDatePickerPaintManager
CXTPDatePickerPaintManager ()
Default paint manager constructor.
virtual | ~CXTPDatePickerPaintManager ()
Default paint manager destructor.
virtual void | DrawScrollTriangle (CDC *pDC, CRect rcSpot, BOOL bLeftDirection, COLORREF clrColor=0, BOOL bYears=FALSE)
This member function draws scrolling triangles on the highest bounded month headers.
virtual COLORREF | GetControlBackColor ()
This member function is used to obtain the control's background color.
virtual COLORREF | GetDayBackColor ()
This member function is used to obtain the background color of the standard day item.
virtual COLORREF | GetDayTextColor ()
This member function is used to obtain the color of the standard day item.
virtual CFont * | GetDayTextFont ()
This member function is used to obtain a pointer to the font for the standard day item.
virtual CFont * | GetDayTextFontBold ()
This member function is used to obtain a pointer to the font for the bolded day item.
virtual COLORREF | GetNonMonthDayBackColor ()
This member function is used to obtain the background color of the non-month day item.
virtual COLORREF | GetNonMonthDayTextColor ()
This member function is used to obtain the color of the non-month day item.
CFont * | GetNonMonthDayTextFont ()
This member function is used to obtain the font of the non-month day item.
virtual COLORREF | GetSelectedDayBackColor ()
This member function is used to obtain the background color of the selected day item.
virtual COLORREF | GetSelectedDayTextColor ()
This member function obtains the color of the selected day item.
virtual COLORREF | GetMonthHeaderBackColor ()
This member function obtains the background color of the month header area.
virtual COLORREF | GetMonthHeaderTextColor ()
This member function obtains the text color of the month header area.
CFont * | GetHeaderTextFont ()
This member function obtains the font of the month header area text.
virtual COLORREF | GetDaysOfWeekBackColor ()
This member function returns the background color of the days of weeks area.
virtual COLORREF | GetDaysOfWeekTextColor ()
This member function obtains the text color of the days of weeks area.
CFont * | GetDaysOfWeekTextFont ()
This member function obtains the font of the days of weeks area text.
virtual COLORREF | GetWeekNumbersBackColor ()
This member function obtains the background color of the week numbers area.
virtual COLORREF | GetWeekNumbersTextColor ()
This member function obtains the text color of the week numbers items.
CFont * | GetWeekNumbersTextFont ()
This member function obtains the font of the week numbers items.
virtual COLORREF | GetListControlBackColor ()
This member function obtains the background color of the pop-up month list control.
virtual COLORREF | GetListControlTextColor ()
This member function obtains the text color of the pop-up month list control.
CFont * | GetListControlTextFont ()
This member function obtains the font of the pop-up month list control.
virtual COLORREF | GetHighlightTodayColor ()
This member function obtains the highlighting color of the "Today" item.
void | SetButtonFont (CFont *fontButton)
This member function sets the button's font.
void | SetButtonFontIndirect (LOGFONT *lFont)
This member function sets the button's font using a LOGFONT structure.
CFont * | GetButtonFont ()
This member function is used to obtain the button's font object.
void | SetFontIndirect (LOGFONT *lFont)
This member function is used to set the control's default font using a LOGFONT structure.
virtual void | DrawMonthHeader (CDC *pDC, CXTPDatePickerItemMonth *pMonth)
Call this member function to draw the month header in the month area.
virtual CSize | CalcDayRect (CDC *pDC)
This member function is used to calculate the day's bounding rectangle coordinates.
virtual CSize | CalcMonthHeaderRect (CDC *pDC)
This member function calculates the month's header bounding rectangle coordinates.
virtual CSize | CalcDayOfWeekRect (CDC *pDC)
This member function calculates the "day of week names" bounding rectangle coordinates.
virtual CSize | CalcWeekNumbersRect (CDC *pDC)
This member function calculates the "week numbers" bounding rectangle coordinates.
virtual CSize | CalcMonthRect (CDC *pDC)
This member function calculates the month's bounding rectangle coordinates.
virtual void | EnableTheme (BOOL bEnableTheme)
This member function is used to switch "Themes".
virtual HCURSOR | GetCursorBack ()
This member function is used to obtain the back cursor used for weeks selection.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPDatePickerPaintManager
CSize | m_szDayMargin
This member function is used to set current paint theme.
CXTPPaintManagerColor | m_clrControlBack
This member variable is a COLORREF object that is used as the background color of the control.
CXTPPaintManagerColor | m_clrHighlightToday
This member variable is a COLORREF object that is used as the color for highlighting the "Today" item.
CXTPPaintManagerColor | m_clrSelectedDayBack
This member variable is a COLORREF object that is used as the background color of the selected day item.
CXTPPaintManagerColor | m_clrMonthHeaderBack
This member variable is a COLORREF object that is used as the background color of the month header area.
CXTPPaintManagerColor | m_clrMonthHeaderText
This member variable is a COLORREF object that is used as the text color of the month header area.
CXTPPaintManagerColor | m_clrSelectedDayText
This member variable is a COLORREF object that is used as the color of the selected day item.
CXTPPaintManagerColor | m_clrMonthBorder
This member variable is a COLORREF object that is used as the color of the border between day of month and week numbers or days of week.
CXTPPaintManagerColor | m_clrMonthHeaderButton
This member variable is a COLORREF object that is used as the color for the scroll's triangle button.
CXTPPaintManagerColor | m_clrDayBack
This member variable is a COLORREF object that is used as the background color of the normal day item.
CXTPPaintManagerColor | m_clrDayText
This member variable is a COLORREF object that is used as the color of the usual day item.
CXTPPaintManagerColor | m_clrNonMonthDayBack
This member variable is a COLORREF object that is used as the background color of the non-month day item.
CXTPPaintManagerColor | m_clrNonMonthDayText
This member variable is a COLORREF object that is used as the color of the non-month day item.
CXTPPaintManagerColor | m_clrDaysOfWeekBack
This member variable is a COLORREF object that is used for the background color of the days of weeks area.
CXTPPaintManagerColor | m_clrDaysOfWeekText
This member variable is a COLORFEF object that is used as the text color of the days of weeks area.
CXTPPaintManagerColor | m_clrWeekNumbersBack
This member variable is a COLORREF object that is used as the background color of the week numbers area.
CXTPPaintManagerColor | m_clrWeekNumbersText
This member variable is a COLORREF object that is used as the text color of the week numbers items.
CXTPPaintManagerColor | m_clrButtonText
This member variable is a COLORREF object that is used as the color for the button text.
CXTPPaintManagerColor | m_clrButtonFace
This member variable is a COLORREF object that is used as the basic color for buttons.
CXTPPaintManagerColor | m_clrListControlBack
This member variable is a COLORREF object that is used as the background color of the pop-up month list control.
CXTPPaintManagerColor | m_clrListControlText
This member variable is a COLORREF object that is used as the text color of the pop-up month list control.
- Protected Member Functions inherited from CXTPDatePickerPaintManager
virtual void | Triangle (CDC *pDC, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clrColor=0)
This member function is used to draw a black triangle.
XTPCalendarTheme | GetPaintTheme () const
This member function is used to obtain current paint theme.
- Protected Attributes inherited from CXTPDatePickerThemeOffice2013
CXTPPaintManagerColorGradient | m_clrBackground
This member variable represents two COLORREF objects that is used as the dark and light background gradient color of the control.
- Protected Attributes inherited from CXTPDatePickerPaintManager
COLORREF | m_clrStaticBorder
Static border color.
COLORREF | m_clr3DShadow
This member variable is a COLORREF object that is used to specify the color for shadow areas.
COLORREF | m_clr3DLight
This member variable is a COLORREF object that is used to specify the color for light areas.
COLORREF | m_clr3DFace
This member variable is a COL ORREF object that is used as the color for the button text.
COLORREF | m_clr3DText
This member variable is a COLORREF object that is used as the basic color for buttons.
CXTPFont | m_xtpFontDay
This member variable is a CXTPFont object that is used for the font -of the usual day item.
CXTPFont | m_xtpFontDayBold
This member variable is a CXTPFont object that is used for the font -of the bold day item.
CXTPFont | m_xtpFontNonMonthDay
This member variable is a CXTPFont object that is used as the font for the non-month day item.
CXTPFont | m_xtpFontHeader
This member variable is a CXTPFont object that is used as the font for the header text.
CXTPFont | m_xtpFontDaysOfWeek
This member variable is a CXTPFont object that is used as the font for the days of weeks text.
CXTPFont | m_xtpFontWeekNumbers
This member variable is a CXTPFont object that is used as the font for the week number items text.
CXTPFont | m_xtpFontListControl
This member variable is a CXTPFont object that is used as the font for the pop-up month list control.
CXTPFont | m_xtpFontButton
This member variable is a CXTPFont object that is used as the font for the button text.
BOOL | m_bEnableTheme
This member variable is a BOOL that is used to indicate if Luna colors are enabled.
CXTPWinThemeWrapper * | m_themeButton
This member variable is a CXTPWinThemeWrapper object that is used as the theme wrapper for the Paint Manager.
HCURSOR | m_hCursorBack
Back cursor for week selection.
XTPCalendarTheme | m_nPaintTheme
Store the Paint Theme;.

Detailed Description

Class CXTPDatePickerThemeVisualStudio2019 is derived from CXTPDatePickerThemeOffice2013 for rendering an Visual Studio 2019 style for DatePicker control.

Example:

if (m_bThemeVisualStudio2019)
{
   CXTPDatePickerThemeVisualStudio2019* pTheme = new CXTPDatePickerThemeVisualStudio2019;
   m_wndDatePicker.SetTheme(pTheme);
}
else
{
   m_wndDatePicker.SetTheme(NULL);
}
See also
CXTPDatePickerThemeVisualStudio2019

Constructor & Destructor Documentation

◆ CXTPDatePickerThemeVisualStudio2019()

CXTPDatePickerThemeVisualStudio2019 ( )

Default paint manager constructor.

Handles initial initialization.

See also
RefreshMetrics()

◆ ~CXTPDatePickerThemeVisualStudio2019()

virtual ~CXTPDatePickerThemeVisualStudio2019 ( )
virtual

Default paint manager destructor.

Handles member item deallocation.

The documentation for this class was generated from the following file:
  • XTPDatePickerVisualStudio2019Theme.h


Toolkit Pro: CXTPDatePickerThemeVisualStudio2022 Class Reference

Public Member Functions | List of all members
CXTPDatePickerThemeVisualStudio2022 Class Reference

Class CXTPDatePickerThemeVisualStudio2022 is derived from CXTPDatePickerThemeOffice2013 for rendering an Visual Studio 2022 style for DatePicker control. More...

Inheritance diagram for CXTPDatePickerThemeVisualStudio2022:
[legend]

Public Member Functions

CXTPDatePickerThemeVisualStudio2022 ()
Default paint manager constructor.
virtual | ~CXTPDatePickerThemeVisualStudio2022 ()
Default paint manager destructor.
- Public Member Functions inherited from CXTPDatePickerThemeOffice2013
CXTPDatePickerThemeOffice2013 ()
Default paint manager constructor.
virtual | ~CXTPDatePickerThemeOffice2013 ()
Default paint manager destructor.
virtual void | RefreshMetrics ()
This member function performs initialization for the Paint Manager.
virtual void | DrawBackground (CDC *pDC, CRect rcClient)
This member function is called to fill the control's background.
virtual void | DrawWeekNumbers (CDC *pDC, CXTPDatePickerItemMonth *pMonth)
Call this member function to draw the week numbers in the month area.
virtual void | DrawDaysOfWeek (CDC *pDC, CXTPDatePickerItemMonth *pMonth)
Call this member function to draw the days of the week in the month header.
virtual void | DrawBorder (CDC *pDC, const CXTPDatePickerControl *pControl, CRect &rcClient, BOOL bDraw)
This member function draws a border around the control.
virtual BOOL | DrawDay (CDC *pDC, CXTPDatePickerItemDay *pDay)
Call this member function to draw a single month day in the month area.
virtual void | DrawButton (CDC *pDC, const CRect &rcButton, const CString &strButton, BOOL bIsDown, BOOL bIsHighLight)
This member function is used to draw the control's buttons.
virtual COLORREF | GetHighlightTodayBackColor ()
Call this member function to retrieve the background color for the highlight today item.
virtual COLORREF | GetHighlightTodayTextColor ()
Call this member function to retrieve the foreground (text) color for the highlight today item.
virtual COLORREF | GetHighlightTodayBorderColor ()
Call this member function to retrieve the Border color for the highlight today item.
- Public Member Functions inherited from CXTPDatePickerPaintManager
CXTPDatePickerPaintManager ()
Default paint manager constructor.
virtual | ~CXTPDatePickerPaintManager ()
Default paint manager destructor.
virtual void | DrawScrollTriangle (CDC *pDC, CRect rcSpot, BOOL bLeftDirection, COLORREF clrColor=0, BOOL bYears=FALSE)
This member function draws scrolling triangles on the highest bounded month headers.
virtual COLORREF | GetControlBackColor ()
This member function is used to obtain the control's background color.
virtual COLORREF | GetDayBackColor ()
This member function is used to obtain the background color of the standard day item.
virtual COLORREF | GetDayTextColor ()
This member function is used to obtain the color of the standard day item.
virtual CFont * | GetDayTextFont ()
This member function is used to obtain a pointer to the font for the standard day item.
virtual CFont * | GetDayTextFontBold ()
This member function is used to obtain a pointer to the font for the bolded day item.
virtual COLORREF | GetNonMonthDayBackColor ()
This member function is used to obtain the background color of the non-month day item.
virtual COLORREF | GetNonMonthDayTextColor ()
This member function is used to obtain the color of the non-month day item.
CFont * | GetNonMonthDayTextFont ()
This member function is used to obtain the font of the non-month day item.
virtual COLORREF | GetSelectedDayBackColor ()
This member function is used to obtain the background color of the selected day item.
virtual COLORREF | GetSelectedDayTextColor ()
This member function obtains the color of the selected day item.
virtual COLORREF | GetMonthHeaderBackColor ()
This member function obtains the background color of the month header area.
virtual COLORREF | GetMonthHeaderTextColor ()
This member function obtains the text color of the month header area.
CFont * | GetHeaderTextFont ()
This member function obtains the font of the month header area text.
virtual COLORREF | GetDaysOfWeekBackColor ()
This member function returns the background color of the days of weeks area.
virtual COLORREF | GetDaysOfWeekTextColor ()
This member function obtains the text color of the days of weeks area.
CFont * | GetDaysOfWeekTextFont ()
This member function obtains the font of the days of weeks area text.
virtual COLORREF | GetWeekNumbersBackColor ()
This member function obtains the background color of the week numbers area.
virtual COLORREF | GetWeekNumbersTextColor ()
This member function obtains the text color of the week numbers items.
CFont * | GetWeekNumbersTextFont ()
This member function obtains the font of the week numbers items.
virtual COLORREF | GetListControlBackColor ()
This member function obtains the background color of the pop-up month list control.
virtual COLORREF | GetListControlTextColor ()
This member function obtains the text color of the pop-up month list control.
CFont * | GetListControlTextFont ()
This member function obtains the font of the pop-up month list control.
virtual COLORREF | GetHighlightTodayColor ()
This member function obtains the highlighting color of the "Today" item.
void | SetButtonFont (CFont *fontButton)
This member function sets the button's font.
void | SetButtonFontIndirect (LOGFONT *lFont)
This member function sets the button's font using a LOGFONT structure.
CFont * | GetButtonFont ()
This member function is used to obtain the button's font object.
void | SetFontIndirect (LOGFONT *lFont)
This member function is used to set the control's default font using a LOGFONT structure.
virtual void | DrawMonthHeader (CDC *pDC, CXTPDatePickerItemMonth *pMonth)
Call this member function to draw the month header in the month area.
virtual CSize | CalcDayRect (CDC *pDC)
This member function is used to calculate the day's bounding rectangle coordinates.
virtual CSize | CalcMonthHeaderRect (CDC *pDC)
This member function calculates the month's header bounding rectangle coordinates.
virtual CSize | CalcDayOfWeekRect (CDC *pDC)
This member function calculates the "day of week names" bounding rectangle coordinates.
virtual CSize | CalcWeekNumbersRect (CDC *pDC)
This member function calculates the "week numbers" bounding rectangle coordinates.
virtual CSize | CalcMonthRect (CDC *pDC)
This member function calculates the month's bounding rectangle coordinates.
virtual void | EnableTheme (BOOL bEnableTheme)
This member function is used to switch "Themes".
virtual HCURSOR | GetCursorBack ()
This member function is used to obtain the back cursor used for weeks selection.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPDatePickerPaintManager
CSize | m_szDayMargin
This member function is used to set current paint theme.
CXTPPaintManagerColor | m_clrControlBack
This member variable is a COLORREF object that is used as the background color of the control.
CXTPPaintManagerColor | m_clrHighlightToday
This member variable is a COLORREF object that is used as the color for highlighting the "Today" item.
CXTPPaintManagerColor | m_clrSelectedDayBack
This member variable is a COLORREF object that is used as the background color of the selected day item.
CXTPPaintManagerColor | m_clrMonthHeaderBack
This member variable is a COLORREF object that is used as the background color of the month header area.
CXTPPaintManagerColor | m_clrMonthHeaderText
This member variable is a COLORREF object that is used as the text color of the month header area.
CXTPPaintManagerColor | m_clrSelectedDayText
This member variable is a COLORREF object that is used as the color of the selected day item.
CXTPPaintManagerColor | m_clrMonthBorder
This member variable is a COLORREF object that is used as the color of the border between day of month and week numbers or days of week.
CXTPPaintManagerColor | m_clrMonthHeaderButton
This member variable is a COLORREF object that is used as the color for the scroll's triangle button.
CXTPPaintManagerColor | m_clrDayBack
This member variable is a COLORREF object that is used as the background color of the normal day item.
CXTPPaintManagerColor | m_clrDayText
This member variable is a COLORREF object that is used as the color of the usual day item.
CXTPPaintManagerColor | m_clrNonMonthDayBack
This member variable is a COLORREF object that is used as the background color of the non-month day item.
CXTPPaintManagerColor | m_clrNonMonthDayText
This member variable is a COLORREF object that is used as the color of the non-month day item.
CXTPPaintManagerColor | m_clrDaysOfWeekBack
This member variable is a COLORREF object that is used for the background color of the days of weeks area.
CXTPPaintManagerColor | m_clrDaysOfWeekText
This member variable is a COLORFEF object that is used as the text color of the days of weeks area.
CXTPPaintManagerColor | m_clrWeekNumbersBack
This member variable is a COLORREF object that is used as the background color of the week numbers area.
CXTPPaintManagerColor | m_clrWeekNumbersText
This member variable is a COLORREF object that is used as the text color of the week numbers items.
CXTPPaintManagerColor | m_clrButtonText
This member variable is a COLORREF object that is used as the color for the button text.
CXTPPaintManagerColor | m_clrButtonFace
This member variable is a COLORREF object that is used as the basic color for buttons.
CXTPPaintManagerColor | m_clrListControlBack
This member variable is a COLORREF object that is used as the background color of the pop-up month list control.
CXTPPaintManagerColor | m_clrListControlText
This member variable is a COLORREF object that is used as the text color of the pop-up month list control.
- Protected Member Functions inherited from CXTPDatePickerPaintManager
virtual void | Triangle (CDC *pDC, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clrColor=0)
This member function is used to draw a black triangle.
XTPCalendarTheme | GetPaintTheme () const
This member function is used to obtain current paint theme.
- Protected Attributes inherited from CXTPDatePickerThemeOffice2013
CXTPPaintManagerColorGradient | m_clrBackground
This member variable represents two COLORREF objects that is used as the dark and light background gradient color of the control.
- Protected Attributes inherited from CXTPDatePickerPaintManager
COLORREF | m_clrStaticBorder
Static border color.
COLORREF | m_clr3DShadow
This member variable is a COLORREF object that is used to specify the color for shadow areas.
COLORREF | m_clr3DLight
This member variable is a COLORREF object that is used to specify the color for light areas.
COLORREF | m_clr3DFace
This member variable is a COL ORREF object that is used as the color for the button text.
COLORREF | m_clr3DText
This member variable is a COLORREF object that is used as the basic color for buttons.
CXTPFont | m_xtpFontDay
This member variable is a CXTPFont object that is used for the font -of the usual day item.
CXTPFont | m_xtpFontDayBold
This member variable is a CXTPFont object that is used for the font -of the bold day item.
CXTPFont | m_xtpFontNonMonthDay
This member variable is a CXTPFont object that is used as the font for the non-month day item.
CXTPFont | m_xtpFontHeader
This member variable is a CXTPFont object that is used as the font for the header text.
CXTPFont | m_xtpFontDaysOfWeek
This member variable is a CXTPFont object that is used as the font for the days of weeks text.
CXTPFont | m_xtpFontWeekNumbers
This member variable is a CXTPFont object that is used as the font for the week number items text.
CXTPFont | m_xtpFontListControl
This member variable is a CXTPFont object that is used as the font for the pop-up month list control.
CXTPFont | m_xtpFontButton
This member variable is a CXTPFont object that is used as the font for the button text.
BOOL | m_bEnableTheme
This member variable is a BOOL that is used to indicate if Luna colors are enabled.
CXTPWinThemeWrapper * | m_themeButton
This member variable is a CXTPWinThemeWrapper object that is used as the theme wrapper for the Paint Manager.
HCURSOR | m_hCursorBack
Back cursor for week selection.
XTPCalendarTheme | m_nPaintTheme
Store the Paint Theme;.

Detailed Description

Class CXTPDatePickerThemeVisualStudio2022 is derived from CXTPDatePickerThemeOffice2013 for rendering an Visual Studio 2022 style for DatePicker control.

Example:

 if (m_bThemeVisualStudio2022)
 {
    CXTPDatePickerThemeVisualStudio2022* pTheme = new CXTPDatePickerThemeVisualStudio2022;
    m_wndDatePicker.SetTheme(pTheme);
 }
 else
 {
    m_wndDatePicker.SetTheme(NULL);
 }
See also
CXTPDatePickerThemeVisualStudio2022

Constructor & Destructor Documentation

◆ CXTPDatePickerThemeVisualStudio2022()

CXTPDatePickerThemeVisualStudio2022 ( )

Default paint manager constructor.

Handles initial initialization.

See also
RefreshMetrics()

◆ ~CXTPDatePickerThemeVisualStudio2022()

virtual ~CXTPDatePickerThemeVisualStudio2022 ( )
virtual

Default paint manager destructor.

Handles member item deallocation.

The documentation for this class was generated from the following file:
  • XTPDatePickerVisualStudio2022Theme.h


Toolkit Pro: CXTPDeviceCaps Class Reference

Public Member Functions | Public Attributes | List of all members
CXTPDeviceCaps Class Reference

The CXTPDeviceCaps class is used to store and update sytem information. More...

Public Member Functions

CXTPDeviceCaps ()
Call this member to refresh the metrics for this class.
void RefreshMetrics ()
Call this member to refresh the metrics for this class.

Public Attributes

int | m_nLogPixelsX
X location, see LOGPIXELSX.
int | m_nLogPixelsY
Y location, see LOGPIXELSY.

Detailed Description

The CXTPDeviceCaps class is used to store and update sytem information.

The documentation for this class was generated from the following file:
  • XTPSystemMetrics.h


Toolkit Pro: CXTPDialogBar Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPDialogBar Class Reference

CXTPDialogBar is a CXTPToolBar derived class. More...

Inheritance diagram for CXTPDialogBar:
[legend]

Public Member Functions

CXTPDialogBar ()
Constructs a CXTPDialogBar object.
virtual | ~CXTPDialogBar ()
Destroys a CXTPDialogBar object, handles cleanup and deallocation.
void | SetChild (CWnd *pChild)
Call this member to specify the child window displayed under the dialog bar.
void | SetCaption (LPCTSTR lpszCaption)
Call this member to set the text that will be displayed in the dialog bar's caption pop-up.
CString | GetCaption () const
Call this member to retrieve the text displayed in the caption pop-up.
void | SetCaptionVisible (BOOL bVisible)
Call this member to hide the caption pop-up control (and close button).
void | SetCaptionPopup (int nMenuResourceID)
Call this member to tell the caption pop-up which CMenu pop-up to display when the the caption pop-up is dropped down.
CXTPPopupBar * | GetCaptionPopup () const
Call this member to retrieve a pointer to the CXTPPopupBar that is displayed when the caption pop-up control is clicked/dropped down.
void | SetResizable (BOOL bResizable)
Call this member to specify whether the dialog bar will be re-sizable.
void | SetSize (CSize sz)
Call this member to set the width and height of the dialog bar child window.
BOOL | IsActive () const
Call this member function to get the child pane state.
- Public Member Functions inherited from CXTPToolBar
CXTPToolBar ()
Constructs a CXTPToolBar object.
~CXTPToolBar ()
Destroys a CXTPToolBar object, handles cleanup and deallocation.
virtual void | SetVisible (BOOL bVisible)
Call this member to set the visibility of the toolbar.
virtual BOOL | IsVisible () const
Call this member to check the visibility of the toolbar.
BOOL | SetPosition (XTPBarPosition barPosition)
Call this member to set the position of the toolbar.
BOOL | LoadToolBar (UINT nIDResource, BOOL bLoadIcons=TRUE)
Call this member function to load the toolbar specified by nIDResource.
BOOL | CreateToolBar (DWORD dwStyle, CWnd *pParentWnd, UINT nID=AFX_IDW_TOOLBAR)
This method creates the ToolBar control.
void | GetBarInfo (CToolBarInfo *pInfo)
Retrieves bar information for serialization routines.
void | SetBarInfo (CToolBarInfo *pInfo)
Sets bar information.
void | EnableDocking (DWORD dwFlags=xtpFlagAlignAny|xtpFlagFloating|xtpFlagHideWrap)
Call this method to set docking flags.
BOOL | IsBuiltIn () const
Determines if the toolbar is built-in.
CXTPDockBar * | GetDockBar () const
Retrieves the parent dock bar.
virtual void | Reset (BOOL bShowWarningMessage)
Resets the controls to their original state.
void | OnSetPreviewMode (BOOL bPreview)
Call this method to show/hide toolbars in preview mode.
BOOL | OnHookKeyDown (UINT nChar, LPARAM lParam)
The framework calls this member function when a non-system key is pressed.
void | SetContextMenuPresent (BOOL bPresent)
Call this method to show/hide the toolbar in a context menu.
BOOL | IsContextMenuPresent () const
Call this member to determine if this toolbar is included in the right-click context menu.
void | SetCustomizeDialogPresent (BOOL bPresent)
Call this method to show/hide the toolbar in a customize dialog.
BOOL | IsCustomizeDialogPresent () const
Call this member to determine if this toolbar is included in the customize dialog.
void | ModifyBarStyle (DWORD dwRemove, DWORD dwAdd)
Modifies the styles of the toolbar.
void | SetCloseable (BOOL bCloseable)
Call this method to enable/disable the closeable property of the command bar.
BOOL | IsCloseable () const
Call this method to retrieve the closeable property of the command bar.
BOOL | IsTemporary () const
Call this method to determine if the control is temporary.
void | SetTemporary (BOOL bTemporary)
Call this method to set the control to temporary.
void | ShowExpandButton (BOOL bShowExpandButton)
Call this method to show/hide the expand button of the toolbar.
void | OnRecalcLayout ()
This method recalculates the position of the toolbar.
BOOL | IsWindowVisible () const
Determines if the toolbar is visible on the screen.
- Public Member Functions inherited from CXTPCommandBar
int | IsTrackingMode () const
Call this member to get the tracking state.
CXTPControls * | GetControls () const
Call this member to get the controls collection.
void | SetControls (CXTPControls *pControls)
Call this member to set the controls collection of the command bar.
XTPBarType | GetType () const
Call this member to get the type of the command bar.
void | SetTextOrientation (XTPBarTextOrientation nTextOrientation)
Call this member to change text orientation.
XTPBarTextOrientation | GetTextOrientation () const
Call this member to get the text orientation.
XTPBarPosition | GetPosition () const
Call this member to get the position of the command bar.
void | DelayLayout ()
Call this member to recalculate the layout.
virtual void | DelayRedraw ()
Call this member to redraw the command bar.
virtual BOOL | SetTrackingMode (int bMode, BOOL bSelectFirst=TRUE, BOOL bKeyboard=FALSE)
Call this member to change the tracking state.
virtual BOOL | LoadMenu (CMenu *pMenu, BOOL bRemoveControls=TRUE)
Call this member to convert menu items to command bar controls.
CXTPControl * | GetControl (int nIndex) const
Call this member to return the control at the specified index.
int | GetControlCount () const
Call this member to get the count of the controls.
virtual BOOL | SetSelected (int nSelected, BOOL bKeyboard=FALSE)
Call this member to select the specified control.
CXTPControl * | GetSelected () const
Call this member to get the currently selected control.
BOOL | SetPopuped (int nPopuped, BOOL bKeyboard=FALSE)
Call this member to pop-up the specified control.
void | SetTitle (LPCTSTR lpszTitle)
Call this member to set a title for this command bar.
CString | GetTitle () const
Call this member to get a title for this command bar.
CXTPCommandBars * | GetCommandBars () const
Call this member to get the command bar's object.
void | SetCommandBars (CXTPCommandBars *pCommandBars)
Call this member to set the command bar's object.
CWnd * | GetSite () const
Call this member to get the command bar's site.
CFrameWnd * | GetFrameSite () const
Call this member to get the command bar's site as CFrameWnd.
void | SetFlags (DWORD dwFlagsAdd, DWORD dwFlagsRemove=0)
Call this member to set the command bar's flags.
BOOL | SetButtons (UINT *pButtons, int nCount)
Call this member to set the controls from the button array.
void | SetIconSize (CSize size)
Call this function to set the size of the actual bitmapped images to be added to a toolbar.
virtual CSize | GetIconSize () const
Call this member function to get the size of the toolbar icon.
CSize | GetLargeIconSize (BOOL bAutoSize) const
Call this method to get the large icon size of the toolbar.
void | SetButtonSize (CSize size)
Sets the size of the buttons in the command bar.
virtual CSize | GetButtonSize () const
Call this function to get the size of the command bar button.
void | ShowTextBelowIcons (BOOL bTextBelow=TRUE)
Call this member to show the caption below control's icon.
BOOL | IsTextBelowIcons () const
Checks whether the caption is below the control's icon.
virtual BOOL | Popup (CXTPControlPopup *pControlPopup, BOOL bSelectFirst=FALSE)
This method is called to pop-up the command bar.
HWND | GetTrackFocus () const
Call this method to retrieve the current focused control.
void | SetTrackFocus (HWND hwnd)
Call this method to set focus to the window.
int | FindAccel (TCHAR chAccel) const
Call this method to get the index of the control with the specified accelerator character.
int | FindAccelEx (UINT chAccel, BOOL &bSelectOnly) const
Call this method to get the index of the control with the specified accelerator character.
BOOL | IsCustomizeMode () const
Call this method to check if the command bars are in customize mode.
virtual DROPEFFECT | OnCustomizeDragEnter (CXTPControl *pDataObject, CPoint point)
This member is called when a control is entered into the command bar.
virtual void | OnCustomizeDragLeave ()
This method is called when a control leaves the command bar.
virtual DROPEFFECT | OnCustomizeDragOver (CXTPControl *pDataObject, CPoint point)
This member is called when control is over the command bar.
virtual void | OnCustomizeDrop (CXTPControl *pDataObject, DROPEFFECT &dropEffect, CPoint ptDrop, CPoint ptDrag)
This method is called when a control is dropped to the command bar.
virtual BOOL | IsCustomizable () const
Call this method to check if the command bar is customizable.
BOOL | IsCustomizeDialogPresent () const
Call this method to check if the command bar is present in Customize dialog.
void | EnableCustomization (BOOL bEnable=TRUE)
Call this method to enable/disable customization of the command bar.
virtual void | OnTrackLost ()
Call this method to remove the tracking state of the command bar.
virtual void | OnTrackEnter ()
Call this method to track the command bar.
CWnd * | GetOwnerSite () const
Call this method to retrieve the owner window of the command bar.
void | InvalidateParents ()
Call this method to redraw all parent command bars.
DWORD | GetFlags () const
Call this method to retrieve the current behavior modification flags of the command bar.
UINT | GetBarID () const
Call this method to retrieve the identifier of the command bar.
void | SetBarID (UINT nID)
Call this method to set the identifier of the command bar.
virtual void | OnControlSelected (BOOL bSelected, CXTPControl *pControl)
This method is called when a child control becomes selected.
BOOL | SetStatusText (const CString &strDescription)
This method is called to set the description context.
void | SetCommandBarData (DWORD_PTR dwData)
This method sets the 32-bit value associated with the command bar.
DWORD_PTR | GetCommandBarData () const
This method retrieves the application-supplied, 32-bit value associated with the command bar.
virtual CXTPCommandBar * | GetParentCommandBar () const
This method retrieves the parent command bar.
CXTPCommandBar * | GetRootParent () const
Call this method to retrieve the top-level parent command bar.
CXTPPaintManager * | GetPaintManager () const
Call this method to retrieve the paint manager.
CXTPImageManager * | GetImageManager () const
Call this method to retrieve the image manager.
void | SetWidth (int nWidth)
Call this member to set the width of the floated or pop-up toolbar.
int | GetWidth () const
Call this member to get the width of the floated or pop-up toolbar.
void | SetPaintManager (CXTPPaintManager *pPaintManager)
Call this member to set the specified paint manager.
void | SetImageManager (CXTPImageManager *pImageManager)
Call this member to set the specified image manager.
BOOL | IsLayoutRTL () const
Call this member function to determine if the command bar layout is Right-to-Left (RTL).
virtual BOOL | IsRibbonBar () const
Call this member function to determine if the command bar is a CXTPRibbonBar.
virtual BOOL | IsMenuTitleBar () const
Call this member function to determine if the command bar is a CXTPMenuTitleBar.
virtual BOOL | IsPopupBar () const
Call this member function to determine if the command bar is a CXTPPopupBar.
virtual BOOL | IsKeyboardCuesVisible () const
Determines if underlines are visible in the command bar control.
void | SetGrabFocus (BOOL bGrabFocus)
This method is called internally to prevent the command bar from grabbing edit focus.
virtual void | Redraw (LPCRECT lpRect=0, BOOL bAnimate=TRUE)
The framework calls this member function to redraw the command bar.
virtual void | DrawCommandBar (CDC *pDC, CRect rcClipBox)
This method is called to draw the command bar in the given context.
void | EnableAnimation (BOOL bEnable=TRUE)
Call this method to enable animation for the command bar.
void | EnableDoubleBuffer (BOOL bEnable=TRUE)
Call this method to enable double buffer for toolbar drawing.
BOOL | IsAnimationEnabled () const
Determines if animation is enabled for the specified command bar.
virtual int | OnHookMessage (HWND hWnd, UINT nMessage, WPARAM &wParam, LPARAM &lParam, LRESULT &lResult)
This member function is called by WindowProc, or is called during message reflection.
virtual void | EnsureVisible (CXTPControl *pControl)
Call this method to ensure that a specified control is visible on the toolbar.
XTPButtonStyle | GetDefaultButtonStyle () const
Call this method to retrieve the default button style of the command bar.
void | SetDefaultButtonStyle (XTPButtonStyle buttonStyle)
Call this method to set the default button style of the command bar.
void | LockRedraw ()
Call this method to freeze redrawing until UnlockRedraw is called.
void | UnlockRedraw ()
Call this method to unfreeze redrawing.
void | SetShowGripper (BOOL bShow)
Call this method to set the visibility of the command bar's gripper.
BOOL | GetShowGripper () const
Call this method to check if the command bar's gripper is visible.
virtual void | FillCommandBarEntry (CDC *pDC)
This method is called to draw the background of the command bar.
virtual BOOL | IsResizable () const
Specifies whether the pop-up gallery can be resized by the user.
BOOL | IsKeyboardTipsVisible () const
Call this method to check if keyboard tips are visible for the command bar.
virtual void | CreateKeyboardTips ()
This method is called to create a keyboard tips collection for the command bar.
void | OnKeyboardTipChar (UINT chAccel)
This method is called when the user presses a key while keyboard tips are visible.
virtual void | OnKeyboardTip (CXTPCommandBarKeyboardTip *pTip)
This method is called when a keyboard tip is found for the command bar.
void | HideKeyboardTips ()
Call this method to hide keyboard tips.
void | LockMouseMove (CXTPControl *pControl)
Locks the mouse cursor for a specified control.
void | UnlockMouseMove ()
Unlocks the mouse cursor.
- Public Member Functions inherited from CXTPHookManagerHookAble
CXTPHookManagerHookAble ()
Constructs a CXTPHookManagerHookAble object.
virtual | ~CXTPHookManagerHookAble ()
Destroys a CXTPHookManagerHookAble object, handles cleanup and deallocation.
virtual int | OnPostHookMessage (HWND hWnd, UINT nMessage, WPARAM &wParam, LPARAM &lParam, LRESULT &lResult)
This member function is called after a message has been processed by default window procedure.
virtual void | OnHookAttached (HWND hWnd)
This member function is called right after a hook is attached to the window.
virtual void | OnHookDetached ()
This member function is called right before a hook is to be detached from the window.

Protected Member Functions

CSize | CalcDockingLayout (int nLength, DWORD dwMode, int nWidth)
This method calculates the dimensions of a toolbar.
CSize | CalcDynamicLayout (int nLength, DWORD dwMode)
This method calculates the dimensions of a toolbar.
BOOL | IsDialogBar () const
Call this member function to determine if the CommandBar is a CXTPDialogBar.
void | OnResize (CRect rcWindow, int nHitTest)
This method is called when the user resizes the dialog bar.
CSize | CalcSize (int nLength, DWORD dwMode, CSize szClient)
This method calculates the dimensions of a dialog bar.
int | OnMouseHitTest (CPoint pt)
This method is called to determine mouse hit code.
CRect | GetMargins ()
Retrieves the client margins of the dialog bar.
void | MoveChildWindow (CRect rc)
This method is called to reposition the child window in the dialog bar.
- Protected Member Functions inherited from CXTPToolBar
virtual BOOL | Create (CWnd *pParentWnd, BOOL bFloat)
Creates a toolbar.
virtual void | DoPropExchange (CXTPPropExchange *pPX)
Either reads this object from or writes this object to an archive.
virtual void | Copy (CXTPCommandBar *pCommandBar, BOOL bRecursive=FALSE)
This method makes a copy of the command bar.
virtual CRect | GetBorders ()
This method retrieves the borders of the toolbar.
virtual void | OnPaintManagerChanged ()
This method is called when the paint manager is changed.
virtual BOOL | ShouldSerializeBar ()
Call this method to check if the toolbar has changed and must be saved.
virtual void | MergeToolBar (CXTPCommandBar *pCommandBar, BOOL bSilent)
This method is called to restore a toolbar to a previous state.
virtual void | MergeToolBar (CXTPCommandBar *pCommandBar, BOOL bSilent, int nDefaultConfirmationChoice)
This method is called to restore a toolbar to a previous state.
- Protected Member Functions inherited from CXTPCommandBar
CXTPCommandBar ()
Constructs a CXTPCommandBar object.
virtual | ~CXTPCommandBar ()
Destroys a CXTPCommandBar object, handles cleanup and deallocation.
virtual BOOL | ProcessSpecialKey (XTPSpecialKey key)
This method is called to process special keys.
virtual void | OnControlsChanged ()
This method is called when the controls array is changed.
virtual void | UpdateShortcuts ()
Updates the control's shortcuts.
UINT | GetActiveDocTemplate () const
Retrieves the active MDI document template.
virtual void | GenerateCommandBarList (DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam)
This method is called to assign self identifiers for the serialization process.
virtual void | RestoreCommandBarList (CXTPCommandBarList *pCommandBarList)
This method is called in the serialization process to restore pop-ups from a list of command bars.
BOOL | IsHelpMode () const
Determines if the parent frame is in help mode.
virtual void | OnRemoved ()
This method is called when a toolbar is removed from the command bars collection.

Protected Attributes

CRect | m_rcBorders
Borders size.
BOOL | m_bResizable
TRUE if the child window and dialog bar are re-sizable.
CSize | m_szMinTrackRect
Minimum tracking rectangle.
BOOL | m_bCaptionVisible
TRUE if the caption pop-up control is visible.
BOOL | m_bCaptionPopup
TRUE to use the caption as a pop-up control.
int | m_nCaptionHeight
Caption height.
CSize | m_szDockingClient
Docking client rectangle.
CSize | m_szFloatingClient
Floating client rectangle.
HWND | m_hwndChild
Child window handle.
CString | m_strCaption
Text that is displayed in the caption pop-up control.
CXTPPopupBar * | m_pPopupBar
Pointer to caption pop-up bar.
BOOL | m_bActive
TRUE if the dialog bar has an active caption.
- Protected Attributes inherited from CXTPToolBar
CXTPDockBar * | m_pDockBar
Parent dock bar.
CXTPDockContext * | m_pDockContext
Docking context.
BOOL | m_bBuiltIn
TRUE if toolbar is built-in.
BOOL | m_bTearOff
TRUE if toolbar is tear-offed.
BOOL | m_bPreviewVisible
TRUE if Toolbar was visible in preview mode.
BOOL | m_bPreviewMode
TRUE if Toolbar was visible in preview mode.
BOOL | m_bTemporary
TRUE if Toolbar is temporary (If it will be saved when the CommandBar layout is saved.)
BOOL | m_bShowExpandButton
TRUE to show expand button of toolbar.
BOOL | m_bContextMenuPresent
TRUE if the command bar is present in context menu.
BOOL | m_bInRecalcLayout
TRUE if RecalcLayout method is called.
BOOL | m_bVisible
TRUE if the command bar is visible.
- Protected Attributes inherited from CXTPCommandBar
BOOL | m_bGrabFocus
TRUE to grab current focus.
int | m_nMRUWidth
Recent width.
int | m_nSelected
Selected control index.
int | m_nPopuped
Pop-up'ed control index.
HWND | m_hwndFocus
The handle of the window that currently has focus.
UINT | m_nBarID
Command bar's identifier.
BOOL | m_bTracking
TRUE if the command bar is in tracking mode.
CWnd * | m_pSite
Command bar's site.
DWORD | m_nIdleFlags
Idle flags.
DWORD | m_dwFlags
Command bar's flags.
DWORD | m_dwStyle
Command bar's styles.
CString | m_strTitle
Command bar's caption.
XTPBarType | m_barType
Type of the command bar.
CXTPControls * | m_pControls
A pointer to controls collection.
XTPBarPosition | m_barPosition
Position of the command bar.
CXTPCommandBars * | m_pCommandBars
parent command bars class.
CWnd * | m_pOwner
Owner window.
CSize | m_szIcons
Size of the command bar's icons.
CSize | m_szButtons
Size of the command bar's buttons.
BOOL | m_bTextBelow
TRUE if text is shown below the CommandBar buttons.
BOOL | m_bExecOnRButton
TRUE if the control button is executed on a right-click.
BOOL | m_bIgnoreUpdateHandler
TRUE to skip update handler for all child controls.
BOOL | m_bRecursePopup
TRUE if pop-up bar was opened recursively.
BOOL | m_bKeyboardSelect
TRUE if last item was selected by keyboard.
BOOL | m_bCloseable
TRUE if the CommandBar can be closed and-or Hidden.
BOOL | m_bCustomizable
TRUE if command bar is customizable.
CRect | m_rcMarker
Marker position.
BOOL | m_bVerticalMarker
TRUE to draw marker vertically.
DWORD_PTR | m_dwData
The 32-bit value associated with the command bar.
UINT * | m_pReturnCmd
Return command holder.
BOOL | m_bCustomizeDialogPresent
TRUE if the command bar is present in Customize dialog.
BOOL | m_bAnimatePopup
TRUE to animate pop-up bar.
BOOL | m_nLockRedraw
TRUE if all drawing routines skipped.
CXTPPaintManager * | m_pPaintManager
Selected paint manager for command bar.
CXTPImageManager * | m_pImageManager
Selected image manager for command bar.
BOOL | m_bMultiLine
True if multi line commandbar.
XTPButtonStyle | m_buttonStyle
Default button Style.
XTPBarTextOrientation | m_nTextOrientation
Commandbar text orientation.
CXTPToolTipContext * | m_pToolTipContext
Tool tip Context.
CXTPCommandBarAnimation * | m_pAnimation
Animation context.
CSize | m_szButtonSpacing
Spacing used between toolbar buttons.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPToolBar
static BOOL AFX_CDECL | DoUpdateCustomizeMenuControl (CXTPControl *pControl, CCmdTarget *pTarget)
Tries to update a Customize menu control.
- Public Attributes inherited from CXTPCommandBar
int | m_nStateFlags
State of the command bars.
BOOL | m_bComboBar
TRUE if it is combobox list.
BOOL | m_bTrackOnHover
TRUE to select item if mouse stay over control.
- Public Attributes inherited from CXTPHookManagerHookAble
BOOL | m_bAutoDestroy
TRUE to automatically delete hook.
- Static Public Attributes inherited from CXTPCommandBar
static int | s_nHoverDelay
Hover delay time.
static int | s_nExpandDelay
Expand delay time.
static int | s_nExpandHoverDelay
Expand hover delay.

Detailed Description

CXTPDialogBar is a CXTPToolBar derived class.

It represents a dockable container for a child window.

Member Function Documentation

◆ CalcDockingLayout()

CSize CalcDockingLayout | ( | int | nLength,
 |  | DWORD | dwMode,
 |  | int | nWidth )
 protectedvirtual

This method calculates the dimensions of a toolbar.

Parameters
nLength | Length of the bar.
dwMode | Mode to dock.
nWidth | Width of the bar.
Returns
Size of the docked toolbar.

Reimplemented from CXTPToolBar.

◆ CalcDynamicLayout()

CSize CalcDynamicLayout | ( | int | nLength,
 |  | DWORD | dwMode )
 protectedvirtual

This method calculates the dimensions of a toolbar.

Parameters
nLength | The requested dimension of the control bar, either horizontal or vertical, depending on dwMode.
dwMode | See CControlBar::CalcDynamicLayout for a list of supported flags.
Returns
Size of the docked toolbar.

Reimplemented from CXTPToolBar.

◆ CalcSize()

CSize CalcSize | ( | int | nLength,
 |  | DWORD | dwMode,
 |  | CSize | szClient )
 protected

This method calculates the dimensions of a dialog bar.

Parameters
nLength | Length of the bar.
dwMode | Mode to dock.
szClient | Client size of dialog bar.
Returns
Size of the dialog bar.

◆ GetCaption()

CString GetCaption ( ) const

Call this member to retrieve the text displayed in the caption pop-up.

Returns
The text displayed in the caption pop-up.

◆ GetCaptionPopup()

AFX_INLINE CXTPPopupBar * GetCaptionPopup ( ) const

Call this member to retrieve a pointer to the CXTPPopupBar that is displayed when the caption pop-up control is clicked/dropped down.

Returns
Pointer to the CXTPPopupBar that is displayed when the caption pop-up control is clicked/dropped down.

◆ GetMargins()

CRect GetMargins ( )
protected

Retrieves the client margins of the dialog bar.

Returns
Rectangle containing the top, left, right, and bottom margins of the dialog bar.

◆ IsActive()

AFX_INLINE BOOL IsActive ( ) const

Call this member function to get the child pane state.

Returns
TRUE if a child pane is active, otherwise FALSE.

◆ IsDialogBar()

AFX_INLINE BOOL IsDialogBar ( ) const
protectedvirtual

Call this member function to determine if the CommandBar is a CXTPDialogBar.

This will always return TRUE.

Returns
Returns TRUE if the CommandBar is a CXTPDialogBar, otherwise FALSE.

Reimplemented from CXTPCommandBar.

◆ MoveChildWindow()

void MoveChildWindow ( CRect rc )
protected

This method is called to reposition the child window in the dialog bar.

Parameters
rc CRect object specifying size of the area.

◆ OnMouseHitTest()

int OnMouseHitTest ( CPoint pt )
protectedvirtual

This method is called to determine mouse hit code.

Parameters
pt Position to test.
Returns
HTCLIENT if pointer belongs client area, otherwise HTNOWHERE.

Reimplemented from CXTPCommandBar.

◆ OnResize()

void OnResize | ( | CRect | rcWindow,
 |  | int | nHitTest )
 protected

This method is called when the user resizes the dialog bar.

Parameters
rcWindow | CRect object specifying the size of the window.
nHitTest | Specifies the hit-test area code.

◆ SetCaption()

void SetCaption ( LPCTSTR lpszCaption )

Call this member to set the text that will be displayed in the dialog bar's caption pop-up.

Parameters
lpszCaption Text that is displayed in the dialog bar's caption pop-up.

This is the text displayed in the dialog bar's caption pop-up. The caption pop-up can be used to indicate what is being displayed in the child window.

◆ SetCaptionPopup()

void SetCaptionPopup ( int nMenuResourceID )

Call this member to tell the caption pop-up which CMenu pop-up to display when the the caption pop-up is dropped down.

Parameters
nMenuResourceID ID of the CMenu resource that contains the pop-up menu that should be displayed when the caption pop-up is clicked/displayed.

If there is more than one pop-up on the CMenu resource, then only the first pop-up on the CMenu will be used.

◆ SetCaptionVisible()

void SetCaptionVisible ( BOOL bVisible )

Call this member to hide the caption pop-up control (and close button).

Parameters
bVisible TRUE to hide the caption pop-up control, FALSE to show it.

If bVisible is TRUE, only the commandbar is displayed (the caption pop-up and close button are hidden).

◆ SetChild()

void SetChild ( CWnd * pChild )

Call this member to specify the child window displayed under the dialog bar.

Parameters
pChild Pointer to a CWnd object that is displayed under the dialog bar.

◆ SetResizable()

AFX_INLINE void SetResizable ( BOOL bResizable )

Call this member to specify whether the dialog bar will be re-sizable.

Parameters
bResizable TRUE if the dialog bar can be resized, FALSE to lock the dialog bar.

By default, bResizable is TRUE. If FALSE, no splitter is displayed when the mouse pointer is positioned over the dialog bar borders. You can use the SetSize member function to change the size of the dialog bar programmatically.

◆ SetSize()

void SetSize ( CSize sz )

Call this member to set the width and height of the dialog bar child window.

Parameters
sz The width and height of the dialog bar's child window.

The size is only used to size the child window when the dialog bar is floating, then both the specified width and height are used. If the bar is docked on the left or right, only the width is used, the height will depend on how much of the client area the dialog bar can occupy. If the bar is docked on the top or bottom, then only the height is used to size the child window.

The documentation for this class was generated from the following file:
  • XTPDialogBar.h


Toolkit Pro: CXTPDialogBase< TBase > Class Template Reference

Public Member Functions | List of all members
CXTPDialogBase< TBase > Class Template Reference

CXTPDialogBase is a TBase derived class. More...

Inheritance diagram for CXTPDialogBase< TBase >:
[legend]

Public Member Functions

CXTPDialogBase ()
Constructs a CXTPDialog object.
CXTPDialogBase (UINT nIDTemplate, CWnd *pParentWnd=NULL)
Constructs a CXTPDialog object.
CXTPDialogBase (LPCTSTR lpszTemplateName, CWnd *pParentWnd=NULL)
Constructs a CXTPDialog object.

Detailed Description

template<class TBase>
class CXTPDialogBase< TBase >

CXTPDialogBase is a TBase derived class.

It represents the parent class for a CXTPDialog class.

Constructor & Destructor Documentation

◆ CXTPDialogBase() [1/2]

template<class TBase >
CXTPDialogBase | ( | UINT | nIDTemplate,
 |  | CWnd * | pParentWnd = NULL )
 inline

Constructs a CXTPDialog object.

Parameters
nIDTemplate | Contains the ID number of a dialog-template resource.
pParentWnd | Pointer to the parent of the DialogBase control.

◆ CXTPDialogBase() [2/2]

template<class TBase >
CXTPDialogBase | ( | LPCTSTR | lpszTemplateName,
 |  | CWnd * | pParentWnd = NULL )
 inline

Constructs a CXTPDialog object.

Parameters
lpszTemplateName | Contains a NULL-terminated string that is the name of a dialog-template resource.
pParentWnd | Pointer to the parent of the DialogBase control.
The documentation for this class was generated from the following file:
  • Controls/Dialog/XTPDialogBase.h


Toolkit Pro: CXTPDialogEx Class Reference

Public Member Functions | List of all members
CXTPDialogEx Class Reference

CXTPDialogEx is a CXTPDialogBase derived class. More...

Inheritance diagram for CXTPDialogEx:
[legend]

Public Member Functions

CXTPDialogEx ()
Constructs a CXTPDialogEx object.
CXTPDialogEx (UINT nIDTemplate, CWnd *pParentWnd=NULL)
Constructs a CXTPDialogEx object.
CXTPDialogEx (LPCTSTR lpszTemplateName, CWnd *pParentWnd=NULL)
Constructs a CXTPDialogEx object.
- Public Member Functions inherited from CXTPDialogBase< CDialog >
CXTPDialogBase ()
Constructs a CXTPDialog object.
CXTPDialogBase (UINT nIDTemplate, CWnd *pParentWnd=NULL)
Constructs a CXTPDialog object.
CXTPDialogBase (LPCTSTR lpszTemplateName, CWnd *pParentWnd=NULL)
Constructs a CXTPDialog object.

Detailed Description

CXTPDialogEx is a CXTPDialogBase derived class.

Use this class in your dialog base application.

Constructor & Destructor Documentation

◆ CXTPDialogEx() [1/2]

CXTPDialogEx | ( | UINT | nIDTemplate,
 |  | CWnd * | pParentWnd = NULL )
 inline

Constructs a CXTPDialogEx object.

Parameters
nIDTemplate | Contains the ID number of a dialog-template resource.
pParentWnd | Pointer to the parent of the Dialog control.

◆ CXTPDialogEx() [2/2]

CXTPDialogEx | ( | LPCTSTR | lpszTemplateName,
 |  | CWnd * | pParentWnd = NULL )
 inline

Constructs a CXTPDialogEx object.

Parameters
lpszTemplateName | Contains a NULL-terminated string that is the name of a dialog-template resource.
pParentWnd | Pointer to the parent of the Dialog control.
The documentation for this class was generated from the following file:
  • Controls/Dialog/XTPDialogBase.h


Toolkit Pro: CXTPDialogScrollBarContainer< Parent > Class Template Reference

Protected Member Functions | List of all members
CXTPDialogScrollBarContainer< Parent > Class Template Reference

CXTPDialogScrollBarContainer class adds XTP scroll bars to a class derived from CDialog. More...

Inheritance diagram for CXTPDialogScrollBarContainer< Parent >:
[legend]

Protected Member Functions

CXTPDialogScrollBarContainer ()
Constructs a CXTPDialogScrollBarContainer object.
CXTPDialogScrollBarContainer (LPCTSTR lpszTemplateName, CWnd *pParentWnd=NULL)
Constructs a CXTPDialogScrollBarContainer object.
CXTPDialogScrollBarContainer (UINT nIDTemplate, CWnd *pParentWnd=NULL)
Constructs a CXTPDialogScrollBarContainer object.
- Protected Member Functions inherited from CXTPScrollBarContainer< Parent >
CXTPScrollBarContainer ()
Constructs a CXTPScrollBarContainer object.

Additional Inherited Members

- Public Member Functions inherited from CXTPScrollBarContainer< Parent >
void | SetScrollBarTheme (XTPScrollBarTheme theme)
Sets scroll bar theme.
BOOL | CreateScrollBarCtrl (DWORD dwStyle, UINT nID)
Creates a scroll bar control with ID and style specied.
virtual CScrollBar * | GetScrollBarCtrl (int nBar) const
Call this member function to obtain a pointer to the specified sibling scroll bar or splitter window.
void | ShowScrollBar (UINT nBar, BOOL bShow=TRUE)
Shows or hides a scroll bar.
BOOL | EnableScrollBar (int nSBFlags, UINT nArrowFlags=ESB_ENABLE_BOTH)
Enables or disables one or both arrows of a scroll bar.
void | RefreshScrollBarMetrics ()
Triggers update of color and size information for themed scroll bars.
void | OptimizeChildrenClipping ()
Applies WS_CLIPCHILDREN and WS_CLIPSIBLINGS styles the the container owner and all its immediate children windows in order prevent possible overlapping of children controls with scroll bars.
void | SetScrollBarClass (CRuntimeClass *pClass=NULL)
Sets a scroll bar class to be used for creating scroll bars.

Detailed Description

template<class Parent>
class CXTPDialogScrollBarContainer< Parent >

CXTPDialogScrollBarContainer class adds XTP scroll bars to a class derived from CDialog.

The parent class must have CDialog constructors.

Constructor & Destructor Documentation

◆ CXTPDialogScrollBarContainer() [1/2]

template<class Parent >
CXTPDialogScrollBarContainer | ( | LPCTSTR | lpszTemplateName,
 |  | CWnd * | pParentWnd = NULL )
 inlineexplicitprotected

Constructs a CXTPDialogScrollBarContainer object.

Parameters
lpszTemplateName | Contains a null-terminated string that is the name of a dialog-box template resource.
pParentWnd | Contains the ID number of a dialog-box template resource.

◆ CXTPDialogScrollBarContainer() [2/2]

template<class Parent >
CXTPDialogScrollBarContainer | ( | UINT | nIDTemplate,
 |  | CWnd * | pParentWnd = NULL )
 inlineexplicitprotected

Constructs a CXTPDialogScrollBarContainer object.

Parameters
nIDTemplate | Resource ID for the string that is the name of a dialog-box template resource.
pParentWnd | Points to the parent or owner window object (of type CWnd) to which the dialog object belongs. If it is NULL, the dialog object's parent window is set to the main application window.
The documentation for this class was generated from the following file:
  • XTPScrollBarContainer.h


Toolkit Pro: CXTPDirWatcher Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPDirWatcher Class Reference

The CXTPDirWatcher is a thread class that will monitor a specified path for file and directory changes to occur. More...

Inheritance diagram for CXTPDirWatcher:
[legend]

Public Member Functions

CXTPDirWatcher ()
Constructs a CXTPDirWatcher object.
BOOL | SetFolderPath (CWnd *pMainWnd, LPCTSTR lpszFolderPath, BOOL bWatchSubtree=FALSE)
Call this member function to monitor the directory specified by strPath.
CString | GetFolderPath () const
Call this member function to retrieve the full path to the currently monitored directory.
BOOL | SetFolderData (CWnd *pMainWnd, XTP_TVITEMDATA *lpTVID)
Call this member function to monitor the directory using a pointer to an XTP_TVITEMDATA pointer.
XTP_TVITEMDATA * GetFolderData ()
This member function is called to return a pointer to the XTP_TVITEMDATA structure for the directory that is currently monitored.
BOOL | GetFolderData (LPCTSTR lpszFolderPath, XTP_TVITEMDATA &lpTVID)
This function constructs an XTP_TVITEMDATA structure from the specified path.
BOOL | IsPathValid (LPCTSTR lpszFolderPath)
Call this member function to determine if the specified path is a valid directory name.
void | StopNotifications ()
Finishes Notification loop.
- Public Member Functions inherited from CXTPWinThread
CXTPWinThread (int xtpComInit=xtpComInitAppDefault)
Default constructor.
virtual | ~CXTPWinThread ()
Default destructor, handles cleanup / deallocation.

Protected Member Functions

virtual | ~CXTPDirWatcher ()
Destroys a CXTPDirWatcher object, handles cleanup and deallocation.
virtual void | RefreshFolder ()
This member function is called by the thread whenever the monitored directory list needs to be refreshed.
virtual void | RefreshTree ()
This member function is called by the thread whenever the monitored directory tree needs to be refreshed.
BOOL | MonitorNotifications ()
Worker method with main notification loop.
BOOL | WaitPathChangedEvent ()
Waits for the developer to set a new path to monitor.

Protected Attributes

HANDLE | m_dwMonitorEvents [4]
Change event handles.
CString | m_strFolderPath
Path that is monitored.
XTP_TVITEMDATA | m_tvid
Tree view item data.
BOOL | m_bWatchSubtree
Monitors the directory tree.

Detailed Description

The CXTPDirWatcher is a thread class that will monitor a specified path for file and directory changes to occur.

Whenever an item is created, deleted or renamed, the thread will send a notification to its owner in the form of a WM_XTP_SHELL_NOTIFY message. The WPARAM value for the notification will be set to SHN_XTP_TREESELCHANGE if the folder list contents require updating or SHN_XTP_CONTENTSCHANGED if the tree contents require updating. The LPARAM value is set to the address of an XTP_TVITEMDATA structure that contains information that the path monitored. Example: To use CXTPDirWatcher, add a CXTPDirWatcher* m_pDirThread member to your class and instantiate a new thread using AfxBeginThread:

// Start the directory monitoring thread.
m_pDirThread = (CXTPDirWatcher*)AfxBeginThread(RUNTIME_CLASS(CXTPDirWatcher),
THREAD_PRIORITY_NORMAL, 0, CREATE_SUSPENDED, NULL);

You can then specify what directory you wish to monitor by calling SetFolderData or SetFolderPath:

// Specify the folder to monitor.
m_pDirThread->SetFolderData(this, lpTVID);
m_pDirThread->ResumeThread();

You can add a message handler to the window receiving messages and handle your change event notifications. The thread will send two notifications. The wParam value indicates what event has occurred. If wParam equals HN_XT_REFRESHFOLDER, then this indicates that the folder list has changed and needs to be updated. If wParam equals SHN_XTP_REFRESHTREE, then this indicates the folder tree has changed and needs to be updated. The lParam value represents a pointer to an XTP_TVITEMDATA structure for the folder:

BEGIN_MESSAGE_MAP(CNotifyWnd, CWnd)
   //{{AFX_MSG_MAP(CNotifyWnd)
   ON_MESSAGE(WM_XTP_SHELL_NOTIFY, OnUpdateShell)
   //}}AFX_MSG_MAP
END_MESSAGE_MAP()

LRESULT CNotifyWnd::OnUpdateShell(WPARAM wParam, LPARAM lParam)
{
   switch (wParam)
   {
      case SHN_XTP_REFRESHFOLDER:
      case SHN_XTP_REFRESHTREE:
      {
         // Directory monitory thread has issued an update notification,
         // refresh the list control.
         XTP_TVITEMDATA*  lpTVID = (XTP_TVITEMDATA*)lParam;
         _ASSERTE(lpTVID);

         PopulateListView(lpTVID, lpTVID->lpsfParent);
         break;
      }

      default:
         break;
   }

   return 0;
}

When you are finished using the CXTPDirWatcher thread, you will need to free the memory associated with the object. To do so, you can use the SAFE_DELETE macro like so:

SAFE_DELETE(m_pDirThread);

The CXTPDirWatcher class is used internally by the CXTPShellListCtrl and CXTPShellListView classes to handle refreshing the list when a file or directory change occurs.

Member Function Documentation

◆ GetFolderData() [1/2]

XTP_TVITEMDATA * GetFolderData ( )

This member function is called to return a pointer to the XTP_TVITEMDATA structure for the directory that is currently monitored.

In the second version, this function constructs an XTP_TVITEMDATA structure from the specified path.

Returns
A pointer to an XTP_TVITEMDATA structure.

◆ GetFolderData() [2/2]

BOOL GetFolderData | ( | LPCTSTR | lpszFolderPath,
 |  | XTP_TVITEMDATA & | lpTVID )

This function constructs an XTP_TVITEMDATA structure from the specified path.

Parameters
lpszFolderPath | Full path to directory.
lpTVID | Reference to tree view item data.
Returns
TRUE if successful, otherwise FALSE.

◆ GetFolderPath()

CString GetFolderPath ( ) const

Call this member function to retrieve the full path to the currently monitored directory.

Returns
A CString object representing the full path to the currently monitored directory.

◆ IsPathValid()

BOOL IsPathValid ( LPCTSTR lpszFolderPath )

Call this member function to determine if the specified path is a valid directory name.

Parameters
lpszFolderPath Full path to directory.
Returns
TRUE if the path is valid, otherwise FALSE.

◆ MonitorNotifications()

BOOL MonitorNotifications ( )
protected

Worker method with main notification loop.

Returns
TRUE if succcessful, otherwise FALSE.

◆ SetFolderData()

BOOL SetFolderData | ( | CWnd * | pMainWnd,
 |  | XTP_TVITEMDATA * | lpTVID )

Call this member function to monitor the directory using a pointer to an XTP_TVITEMDATA pointer.

Parameters
pMainWnd | Pointer to the window to receive update notifications.
lpTVID | Pointer to the tree view item data.
Returns
TRUE if successful, otherwise FALSE.

◆ SetFolderPath()

BOOL SetFolderPath | ( | CWnd * | pMainWnd,
 |  | LPCTSTR | lpszFolderPath,
 |  | BOOL | bWatchSubtree = FALSE )

Call this member function to monitor the directory specified by strPath.

Parameters
pMainWnd | Pointer to the window to receive change notifications.
lpszFolderPath | Full path of the directory to monitor.
bWatchSubtree | Monitors the directory tree rooted at the specified directory.
Returns
TRUE if successful, otherwise FALSE.

◆ WaitPathChangedEvent()

BOOL WaitPathChangedEvent ( )
protected

Waits for the developer to set a new path to monitor.

Returns
TRUE if succcessful, otherwise FALSE.
The documentation for this class was generated from the following file:
  • XTPDirWatcher.h


Toolkit Pro: CXTPDockBar Class Reference

Public Types | Public Member Functions | Protected Attributes | List of all members
CXTPDockBar Class Reference

CXTPDockBar is a CWnd derived class. More...

Public Types

typedef CArray< CXTPToolBar *, CXTPToolBar * > CToolBarArray
Array of CXTPToolBar objects.

Public Member Functions

CXTPDockBar ()
Constructs a CXTPDockBar object.
virtual | ~CXTPDockBar ()
Destroys a CXTPDockBar object, handles cleanup and deallocation.
XTPBarPosition | GetPosition () const
Retrieves the dockbar position.
BOOL | IsVerticalPosition () const
Checks if dockbar is vertical.

Protected Attributes

DWORD | m_dwStyle
Style of the control.
CToolBarArray | m_arrBars
Toolbar list.
CXTPCommandBars * | m_pCommandBars
Parent CommandBars object.

Detailed Description

CXTPDockBar is a CWnd derived class.

It is used internally by CXTPCommandBars.

Member Function Documentation

◆ GetPosition()

XTPBarPosition GetPosition ( ) const

Retrieves the dockbar position.

Returns
Position of the dock bar.

◆ IsVerticalPosition()

BOOL IsVerticalPosition ( ) const

Checks if dockbar is vertical.

Returns
TRUE if docked vertically, otherwise FALSE.
The documentation for this class was generated from the following file:
  • XTPDockBar.h


Toolkit Pro: CXTPDockContext Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPDockContext Class Reference

CXTPDockContext is a standalone class. More...

Public Member Functions

CXTPDockContext (CXTPToolBar *pBar)
Constructs a CXTPDockContext object.
virtual | ~CXTPDockContext ()
Destroys a CXTPDockContext object, handles cleanup and deallocation.
virtual void | StartDrag (CPoint pt)
This method is called when the user starts to move the toolbar.
virtual void | StartResize (int nHitTest, CPoint pt)
This method is called when the user starts to resize the toolbar.
virtual BOOL | ToggleDocking ()
This method is called to switch the docking position of the toolbar.

Protected Member Functions

virtual void | Track ()
This method is called to start the tracking loop.
void | Stretch (CPoint pt)
This method is called to stretch the child toolbar.
void | Move (CPoint pt)
This method is called to move the child toolbar to the specified position.
void | Resize (CPoint pt)
This method is called to move the child toolbar to resize the child dialog bar.

Protected Attributes

CXTPToolBar * | m_pBar
Child toolbar.
int | m_nHitTest
Hit Test code.
CPoint | m_ptLast
Last mouse position.
XTPBarPosition | m_uMRUDockPosition
Last docking position.
CRect | m_rectMRUDockPos
Last docking rectangle.
CPoint | m_ptMRUFloatPos
Last floating rectangle.
CRect | m_rectDragDock
Current docking rectangle.
CRect | m_rectDragFrame
Current floating rectangle.

Detailed Description

CXTPDockContext is a standalone class.

It is used internally by CXTPToolBar.

Constructor & Destructor Documentation

◆ CXTPDockContext()

CXTPDockContext ( CXTPToolBar * pBar )

Constructs a CXTPDockContext object.

Parameters
pBar Pointer to a CXTPToolBar object.

Member Function Documentation

◆ Move()

void Move ( CPoint pt )
protected

This method is called to move the child toolbar to the specified position.

Parameters
pt CPoint object that specifies xy coordinates.

◆ Resize()

void Resize ( CPoint pt )
protected

This method is called to move the child toolbar to resize the child dialog bar.

Parameters
pt CPoint object that specifies xy coordinates.

◆ StartDrag()

virtual void StartDrag ( CPoint pt )
virtual

This method is called when the user starts to move the toolbar.

Parameters
pt Initial cursor position.

◆ StartResize()

virtual void StartResize | ( | int | nHitTest,
 |  | CPoint | pt )
 virtual

This method is called when the user starts to resize the toolbar.

Parameters
nHitTest | Specifies the hit-test area code.
pt | Initial cursor position.

◆ Stretch()

void Stretch ( CPoint pt )
protected

This method is called to stretch the child toolbar.

Parameters
pt CPoint object that specifies xy coordinates.

◆ ToggleDocking()

virtual BOOL ToggleDocking ( )
virtual

This method is called to switch the docking position of the toolbar.

Returns
TRUE if successful, otherwise FALSE.
The documentation for this class was generated from the following file:
  • XTPDockContext.h


Toolkit Pro: CXTPDockingPane Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPDockingPane Class Reference

CXTPDockingPane is a CXTPDockingPaneBase derived class. More...

Inheritance diagram for CXTPDockingPane:
[legend]

Public Member Functions

void | SetTitle (LPCTSTR lpszTitle)
Call this member to set a title for this object.
virtual void | SetFocus ()
Call this member to set the focus of the pane.
int | GetID () const
Call this member to get the pane's identifier.
virtual CString | GetTitle () const
Call this member to get the title of the pane.
virtual CString | GetTabCaption () const
Call this member to get the tab caption of the pane.
void | SetTabCaption (LPCTSTR lpszTabCaption)
Call this member to set the tab caption of the pane.
virtual CString | GetTitleToolTip () const
Call this member to get the title tooltip text of the pane.
void | SetTitleToolTip (LPCTSTR lpszTitleToolTip)
Call this member to set the title tooltip text for the pane.
void | Close ()
Call this member to close the pane.
void | Hide ()
Call this member to hide the pane.
BOOL | IsValid () const
Call this member to check if the pane is associated with a user window.
BOOL | IsClosed () const
Call this member to check if the pane is closed.
BOOL | IsHidden () const
Call this member to check if the pane is hidden.
BOOL | IsSelected () const
Call this member to check if the pane is selected.
BOOL | IsFloating () const
Call this member to check if the pane is floating.
BOOL | IsSidePanel () const
Call this member to check if the pane is a side panel.
BOOL | IsTabsVisible () const
Call this member to check if the tab bar is visible.
void | Attach (CWnd *pWnd)
Call this member to associate the pane with a user window.
CWnd * | AttachView (CWnd *pParentWnd, CRuntimeClass *pViewClass, CDocument *pDocument=NULL, CCreateContext *pContext=NULL)
This member function dynamically creates a view based on a CRuntimeClass object and attaches it to the pane.
void | Detach ()
Call this member to disassociate the pane from a user window.
void | Select ()
Call this member to select the pane.
int | GetIconID () const
Retrieves the identifier of the icon.
virtual CXTPImageManagerIcon * | GetIcon (int nWidth=16) const
Retrieves the icon associated with the pane.
void | SetIconID (UINT nID)
Call this member to set the identifier of the icon.
CWnd * | GetChild () const
Call this member to get the associated user window.
void | SetOptions (DWORD dwOptions)
Call this member to set options for the pane.
DWORD | GetOptions () const
Call this member to get the options of the pane.
void | SetPaneData (DWORD_PTR dwData)
Call this method to set the 32-bit value associated with the pane.
DWORD_PTR | GetPaneData () const
This method retrieves the application-supplied, 32-bit value associated with the tab item.
virtual COLORREF | GetItemColor () const
This member function retrieves the RGB value for the referenced item tab color, or (COLORREF)-1 if the color was not set.
void | SetItemColor (COLORREF clr)
Call this member to set the RGB value for the item tab.
virtual void | GetMinMaxInfo (LPMINMAXINFO pMinMaxInfo) const
Call this member to fill the pMinMaxInfo structure with the minimum and maximum width and height of the container.
BOOL | IsFocus () const
Retrieves the state of the child window.
CSize | SetMinTrackSize (CSize sz)
Call this method to set the minimum size for the pane.
CSize | SetMaxTrackSize (CSize sz)
Call this method to set the maximum size for the pane.
void | SetHelpID (int nIDR)
Sets a context-sensitive help ID for the child pane.
CFrameWnd * | GetParentFrame () const
Call this member function to retrieve the parent frame window.
CWnd * | GetDockingSite () const
Call this member function to retrieve the parent window for the pane.
XTPDockingPaneEnableOptions | GetEnabled () const
Determines the pane's enabled state.
void | SetEnabled (XTPDockingPaneEnableOptions nState)
Call this method to set the pane's enabled state.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.
- Public Member Functions inherited from CXTPDockingPaneBase
virtual BOOL | IsActive () const
Determines if the frame is active.
virtual BOOL | IsCaptionVertical () const
Determines if the caption is drawn vertically.
XTPDockingPaneType | GetType () const
Call this member to determine the type of the pane.
CRect | GetPaneWindowRect () const
The GetPaneWindowRect function retrieves the dimensions of the bounding rectangle of the pane.
CXTPDockingPaneBase * | GetContainer () const
Call this member function to retrieve the parent container of the pane.
CXTPDockingPaneManager * | GetDockingPaneManager () const
Call this member function to retrieve the pane manager.
CXTPDockingPanePaintManager * | GetPaintManager () const
Call this member function to retrieve the paint manager.
CXTPDockingPaneCaptionButton * | FindCaptionButton (int nID) const
Call this member to find the specified caption button.
CXTPDockingPaneCaptionButtons * | GetCaptionButtons () const
Call this member to get a reference to the caption's close/pop-up button.
virtual void | RedrawPane ()
Call this member to redraw the pane.
virtual POSITION | ContainPane (CXTPDockingPaneBase *pPane) const
Call this member to determine if one pane is contained in the collection of another.
virtual void | FindPane (XTPDockingPaneType type, CXTPDockingPaneBaseList *pList) const
Call this member to retrieve a collection of the panes with a specified type.
virtual BOOL | IsEmpty () const
Call this member to determine if there are no children panes.
virtual HWND | GetPaneHwnd () const
Retrieves the window handle for a window.
virtual void | InvalidatePane (BOOL bSelectionChanged)
This member is called when a pane must be redrawn.

Protected Member Functions

CXTPDockingPane (CXTPDockingPaneLayout *pLayout)
Constructs a CXTPDockingPane object.
virtual | ~CXTPDockingPane ()
Destroys a CXTPDockingPane object, handles cleanup and deallocation.
virtual void | Copy (CXTPDockingPane *pPane)
Copies self data from another pane.
virtual void | OnSizeParent (CWnd *pParent, CRect rect, LPVOID lParam)
This method is called to set the position of the pane.
virtual void | SetParentContainer (CXTPDockingPaneBase *pContainer)
Call this method to set the parent container of the pane.
virtual BOOL | DoPropExchange (CXTPPropExchange *pPX)
Call this member function to save/restore the settings of the pane.
void | ShowWindow (BOOL bShow)
Sets the visibility state of the window.
void | SetID (int nID)
Call this member to set the identifier of the item.
void | SetWindowRect (CRect rc)
Call this member to set the bounding rectangle.
virtual void | DeletePane ()
This method is called to the destroy the pane.
- Protected Member Functions inherited from CXTPDockingPaneBase
CXTPDockingPaneBase (XTPDockingPaneType type, CXTPDockingPaneLayout *pLayout)
Protected constructor.
virtual | ~CXTPDockingPaneBase ()
Destroys a CXTPDockingPaneBase object, handles cleanup and deallocation.
virtual void | OnFocusChanged ()
This method is called to update the state of the pane.
virtual void | SetDockingSite (CWnd *pFrame)
Call this member to set the parent frame of the pane.
virtual void | OnChildContainerChanged (CXTPDockingPaneBase *pContainer)
This member is called when a child pane collection is changed.
virtual void | OnParentContainerChanged (CXTPDockingPaneBase *pContainer)
This member is called when the parent pane collection is changed.
virtual CXTPDockingPaneBase * | Clone (CXTPDockingPaneLayout *pLayout, CXTPPaneToPaneMap *pMap, DWORD dwIgnoredOptions=0)
This member is called to clone the pane.
virtual void | RemovePane (CXTPDockingPaneBase *pPane)
Call this member to remove a pane from the collection.
virtual void | OnCaptionButtonRectChanged (CXTPDockingPaneCaptionButton *pButton)
This member is called when the dimensions of the caption button are changed.
virtual BOOL | IsCaptionButtonVisible (CXTPDockingPaneCaptionButton *pButton)
Call this member to determine if a caption button is visible.
virtual void | CreateContainer ()
This member is called to create a pane.

Protected Attributes

HWND | m_hwndChild
Child window handle.
int | m_nID
Pane identifier.
int | m_nIconID
Icon identifier.
CString | m_strTitle
Caption of the pane.
CString | m_strTabCaption
Tab caption, text inside tab button.
CString | m_strTitleToolTip
Tooltip text for the tab button.
DWORD | m_dwOptions
Options of the pane.
DWORD_PTR | m_dwData
User item data.
CPoint | m_ptMinTrackSize
Minimum pane size.
CPoint | m_ptMaxTrackSize
Maximum pane size.
COLORREF | m_clrItemTab
Color used to fill the docking pane tab buttons.
int | m_nIDHelp
Context-sensitive help ID for a child pane.
XTPDockingPaneEnableOptions | m_bEnabled
Pane enabled options.
- Protected Attributes inherited from CXTPDockingPaneBase
CSize | m_szDocking
Size of the pane.
CXTPDockingPaneLayout * | m_pLayout
Parent layout.
CXTPDockingPaneBase * | m_pParentContainer
Parent container.
CWnd * | m_pDockingSite
Parent frame.
XTPDockingPaneType | m_type
Type of the pane.
CRect | m_rcWindow
Position of the pane.
CXTPDockingPaneCaptionButtons * | m_pCaptionButtons
Collection of caption buttons.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

CXTPDockingPane is a CXTPDockingPaneBase derived class.

It is used as a container for a user window.

Constructor & Destructor Documentation

◆ CXTPDockingPane()

CXTPDockingPane ( CXTPDockingPaneLayout * pLayout )
protected

Constructs a CXTPDockingPane object.

Protected constructor. Use CXTPDockingPaneManager::CreatePane() to create it.

Parameters
pLayout Pointer to a CXTPDockingPaneLayout object.

Member Function Documentation

◆ Attach()

void Attach ( CWnd * pWnd )

Call this member to associate the pane with a user window.

Parameters
pWnd Pointer to a user window.

The best place to create a user window and associate it with a pane is after the pane becomes visible. To catch this event, use the XTPWM_DOCKINGPANE_NOTIFY Handler.

◆ AttachView()

CWnd * AttachView | ( | CWnd * | pParentWnd,
 |  | CRuntimeClass * | pViewClass,
 |  | CDocument * | pDocument = NULL,
 |  | CCreateContext * | pContext = NULL )

This member function dynamically creates a view based on a CRuntimeClass object and attaches it to the pane.

Parameters
pParentWnd | Pointer to the parent of the view to be created. The parent must be valid.
pViewClass | CView runtime class.
pDocument | CDocument associated with the view. It can be NULL.
pContext | Create context for the view. It can be NULL.

The best place to create a user window and associate it with a pane is after the pane becomes visible. To catch this event, use the XTPWM_DOCKINGPANE_NOTIFY Handler.

Returns
A CWnd* pointer to the newly created view if successful, otherwise NULL.

◆ Copy()

virtual void Copy ( CXTPDockingPane * pPane )
protectedvirtual

Copies self data from another pane.

Parameters
pPane Pane which members need to copy.
See also
Clone

◆ DoPropExchange()

virtual BOOL DoPropExchange ( CXTPPropExchange * pPX )
protectedvirtual

Call this member function to save/restore the settings of the pane.

Parameters
pPX Pointer to a CXTPPropExchange object.
Returns
TRUE if successful, otherwise returns FALSE.

Reimplemented from CXTPDockingPaneBase.

◆ GetChild()

CWnd * GetChild ( ) const

Call this member to get the associated user window.

Returns
Pointer to the associated user child window.

◆ GetDockingSite()

CWnd * GetDockingSite ( ) const
virtual

Call this member function to retrieve the parent window for the pane.

Returns
A pointer to a parent window if successful, otherwise NULL.

Reimplemented from CXTPDockingPaneBase.

◆ GetEnabled()

XTPDockingPaneEnableOptions GetEnabled ( ) const

Determines the pane's enabled state.

Returns
Pane's enabled state value.
See also
XTPDockingPaneEnableOptions

◆ GetIcon()

virtual CXTPImageManagerIcon * GetIcon ( int nWidth = 16 ) const
virtual

Retrieves the icon associated with the pane.

Parameters
nWidth Width of the icon to retrieve.
Returns
Handle of the icon.

◆ GetIconID()

int GetIconID ( ) const

Retrieves the identifier of the icon.

Returns
The identifier of the icon if set. Otherwise, returns the identifier of the pane.

◆ GetID()

AFX_INLINE int GetID ( ) const

Call this member to get the pane's identifier.

Returns
The identifier of the pane.

◆ GetItemColor()

virtual COLORREF GetItemColor ( ) const
virtual

This member function retrieves the RGB value for the referenced item tab color, or (COLORREF)-1 if the color was not set.

Returns
The RGB value for the referenced item tab color, or (COLORREF)-1 if the color was not set.

◆ GetMinMaxInfo()

virtual void GetMinMaxInfo ( LPMINMAXINFO pMinMaxInfo ) const
virtual

Call this member to fill the pMinMaxInfo structure with the minimum and maximum width and height of the container.

This will look at the MinMaxInfo for each pane in the container and set the appropriate minimum and maximum width and height for the container.

Parameters
pMinMaxInfo Pointer to a MINMAXINFO structure.

Reimplemented from CXTPDockingPaneBase.

◆ GetOptions()

DWORD GetOptions ( ) const

Call this member to get the options of the pane.

Returns
The options of the pane.
See also
XTPDockingPaneOptions

◆ GetPaneData()

AFX_INLINE DWORD_PTR GetPaneData ( ) const

This method retrieves the application-supplied, 32-bit value associated with the tab item.

Returns
The 32-bit value associated with the pane.
See also
SetPaneData

◆ GetParentFrame()

CFrameWnd * GetParentFrame ( ) const

Call this member function to retrieve the parent frame window.

The member function searches up the parent chain until a CFrameWnd (or derived class) object is found.

Returns
A pointer to a frame window if successful, otherwise NULL

◆ GetTabCaption()

virtual CString GetTabCaption ( ) const
virtual

Call this member to get the tab caption of the pane.

Returns
The tab caption of the pane.

◆ GetTitle()

virtual CString GetTitle ( ) const
virtual

Call this member to get the title of the pane.

Returns
The title of the pane.

Reimplemented from CXTPDockingPaneBase.

◆ GetTitleToolTip()

virtual CString GetTitleToolTip ( ) const
virtual

Call this member to get the title tooltip text of the pane.

Returns
The title tooltip text of the pane.

◆ IsClosed()

BOOL IsClosed ( ) const

Call this member to check if the pane is closed.

Returns
TRUE if the pane is closed.

◆ IsFloating()

BOOL IsFloating ( ) const

Call this member to check if the pane is floating.

Returns
TRUE if the pane is floating.

◆ IsFocus()

BOOL IsFocus ( ) const

Retrieves the state of the child window.

Returns
TRUE if child window is focused.

◆ IsHidden()

BOOL IsHidden ( ) const
virtual

Call this member to check if the pane is hidden.

Returns
TRUE if the pane is hidden.

Reimplemented from CXTPDockingPaneBase.

◆ IsSelected()

BOOL IsSelected ( ) const

Call this member to check if the pane is selected.

Returns
TRUE if the pane is selected.

◆ IsSidePanel()

BOOL IsSidePanel ( ) const

Call this member to check if the pane is a side panel.

Returns
TRUE if the pane is a side panel.

◆ IsTabsVisible()

BOOL IsTabsVisible ( ) const

Call this member to check if the tab bar is visible.

Returns
TRUE if the tab bar is visible.

◆ IsValid()

BOOL IsValid ( ) const

Call this member to check if the pane is associated with a user window.

Returns
TRUE if the pane is associated with a user window.

◆ OnSizeParent()

virtual void OnSizeParent | ( | CWnd * | pParent,
 |  | CRect | rect,
 |  | LPVOID | lParam )
 protectedvirtual

This method is called to set the position of the pane.

Parameters
pParent | Pointer to a CWnd object.
rect | Rectangle of the pane to be set.
lParam | Pointer to an AFX_SIZEPARENTPARAMS structure.

Reimplemented from CXTPDockingPaneBase.

◆ SetEnabled()

void SetEnabled ( XTPDockingPaneEnableOptions nState )

Call this method to set the pane's enabled state.

Parameters
nState New pane enabled state value.
See also
XTPDockingPaneEnableOptions

◆ SetHelpID()

AFX_INLINE void SetHelpID ( int nIDR )

Sets a context-sensitive help ID for the child pane.

Parameters
nIDR Specifies the context-sensitive help ID.

◆ SetIconID()

void SetIconID ( UINT nID )

Call this member to set the identifier of the icon.

Parameters
nID Identifier of the icon

◆ SetID()

void SetID ( int nID )
protected

Call this member to set the identifier of the item.

Parameters
nID Identifier of the item.

◆ SetItemColor()

void SetItemColor ( COLORREF clr )

Call this member to set the RGB value for the item tab.

Parameters
clr Color of the item tab.

◆ SetMaxTrackSize()

CSize SetMaxTrackSize ( CSize sz )

Call this method to set the maximum size for the pane.

Parameters
sz Maximum size to be set for the pane.
Returns
The applied maximum track size.

◆ SetMinTrackSize()

CSize SetMinTrackSize ( CSize sz )

Call this method to set the minimum size for the pane.

Parameters
sz Minimum size to be set for the pane.
Returns
The applied minimum track size.

◆ SetOptions()

AFX_INLINE void SetOptions ( DWORD dwOptions )

Call this member to set options for the pane.

Parameters
dwOptions Options to be set. Can be any of the values listed in the Remarks section.

dwOptions parameter can be one or more of the following: xtpPaneNoCloseable: Indicates the pane can't be closed. xtpPaneNoHideable: Indicates the pane can't be hidden. xtpPaneNoFloatable: Indicates the pane can't be floated. xtpPaneNoCaption: Indicates the pane has no caption. xtpPaneHasMenuButton: Indicates the pane has menu button. xtpPaneNoDockable: Indicates the pane can't be docked.

See also
XTPDockingPaneOptions

◆ SetPaneData()

AFX_INLINE void SetPaneData ( DWORD_PTR dwData )

Call this method to set the 32-bit value associated with the pane.

Parameters
dwData Contains the new value to associate with the pane.
See also
GetPaneData

◆ SetParentContainer()

virtual void SetParentContainer ( CXTPDockingPaneBase * pContainer )
protectedvirtual

Call this method to set the parent container of the pane.

Parameters
pContainer Pointer to a CXTPDockingPaneBase object.

Reimplemented from CXTPDockingPaneBase.

◆ SetTabCaption()

void SetTabCaption ( LPCTSTR lpszTabCaption )

Call this member to set the tab caption of the pane.

Parameters
lpszTabCaption The tab caption of the pane to be set.

◆ SetTitle()

void SetTitle ( LPCTSTR lpszTitle )

Call this member to set a title for this object.

Parameters
lpszTitle Title to be set.

◆ SetTitleToolTip()

void SetTitleToolTip ( LPCTSTR lpszTitleToolTip )

Call this member to set the title tooltip text for the pane.

Parameters
lpszTitleToolTip The title tooltip text to be set for the pane.

◆ SetWindowRect()

void SetWindowRect ( CRect rc )
protected

Call this member to set the bounding rectangle.

Parameters
rc Bounding rectangle to draw.

◆ ShowWindow()

void ShowWindow ( BOOL bShow )
protected

Sets the visibility state of the window.

Parameters
bShow TRUE to show the window, or FALSE to hide it.

Member Data Documentation

◆ m_dwOptions

DWORD m_dwOptions
protected

Options of the pane.

See XTPDockingPaneOptions.

The documentation for this class was generated from the following file:
  • XTPDockingPane.h


Toolkit Pro: CXTPDockingPaneAutoHidePanel Class Reference

Public Member Functions | Static Public Attributes | Protected Member Functions | Protected Attributes | List of all members
CXTPDockingPaneAutoHidePanel Class Reference

CXTPDockingPaneAutoHidePanel is a multiple inheritance class derived from CWnd and CXTPDockingPaneBase. More...

Inheritance diagram for CXTPDockingPaneAutoHidePanel:
[legend]

Public Member Functions

XTPDockingPaneDirection | GetDirection () const
Call this member function to determine the position of the auto-hide panel.
virtual HWND | GetPaneHwnd () const
Retrieves the window handle for a window.
CXTPDockingPane * | HitTest (CPoint point) const
This member function determines which header item, if any, is at a specified cursor position.
CXTPTabManagerItem * | GetPaneTab (CXTPDockingPane *pPane) const
Call this member to get the tab for a corresponding pane.
virtual CXTPTabPaintManager * | GetPaintManager () const
This member is called to access the visual elements of the docking pane tabs (i.e.
virtual BOOL | DrawIcon (CDC *pDC, CPoint pt, CXTPTabManagerItem *pItem, BOOL bDraw, CSize &szIcon) const
This member is called when the icon of the tab in the tabbed container needs to be drawn (i.e.
XTPTabPosition | GetPosition () const
Call this member to get the position of the pane's tab in the auto-hide panel.
virtual int | GetItemsLength () const
Call this member to get the length of the items in the auto-hide panel.
- Public Member Functions inherited from CXTPDockingPaneBaseContainer
virtual POSITION | ContainPane (CXTPDockingPaneBase *pPane) const
Call this member to determine if one pane is contained in the collection of another.
virtual void | FindPane (XTPDockingPaneType type, CXTPDockingPaneBaseList *pList) const
Call this member to find all panes of a specific XTPDockingPaneType within the container.
POSITION | GetHeadPosition () const
This method retrieves the position of the first pane of this container.
CXTPDockingPaneBase * | GetNext (POSITION &pos) const
Gets the pane element identified by rPosition, then sets rPosition to the POSITION value of the next entry in the container.
CXTPDockingPaneBase * | GetFirstPane () const
This method retrieves the first pane in the container.
CXTPDockingPaneBase * | GetLastPane () const
This method retrieves the last pane in the container.
CXTPDockingPaneBaseList & GetPanes ()
Call this member to retrieve the collection of child panes.
BOOL | OnAction (XTPDockingPaneAction action)
This method is called if some action occurs.
- Public Member Functions inherited from CXTPDockingPaneBase
virtual BOOL | IsActive () const
Determines if the frame is active.
virtual BOOL | IsCaptionVertical () const
Determines if the caption is drawn vertically.
virtual CString | GetTitle () const
Call this member to get the text in the caption for the tabbed container (group of panes).
XTPDockingPaneType | GetType () const
Call this member to determine the type of the pane.
CRect | GetPaneWindowRect () const
The GetPaneWindowRect function retrieves the dimensions of the bounding rectangle of the pane.
CXTPDockingPaneBase * | GetContainer () const
Call this member function to retrieve the parent container of the pane.
CXTPDockingPaneManager * | GetDockingPaneManager () const
Call this member function to retrieve the pane manager.
CXTPDockingPanePaintManager * | GetPaintManager () const
Call this member function to retrieve the paint manager.
CXTPDockingPaneCaptionButton * | FindCaptionButton (int nID) const
Call this member to find the specified caption button.
CXTPDockingPaneCaptionButtons * | GetCaptionButtons () const
Call this member to get a reference to the caption's close/pop-up button.
virtual void | RedrawPane ()
Call this member to redraw the pane.
virtual void | GetMinMaxInfo (LPMINMAXINFO pMinMaxInfo) const
Call this member to fill the pMinMaxInfo structure with the minimum and maximum width and height of the container.
virtual CWnd * | GetDockingSite () const
Call this member function to retrieve the parent window for the pane.
virtual BOOL | IsHidden () const
Call this member to check if the pane is hidden.
- Public Member Functions inherited from CXTPTabManager
CXTPTabManager ()
Constructs a CXTPTabManager object.
virtual | ~CXTPTabManager ()
Destroys a CXTPTabManager object, handles cleanup and deallocation.
CXTPTabManagerItem * | GetItem (int nIndex) const
Retrieves a tab item by its index.
BOOL | DeleteItem (int nItem)
Deletes a tab item by its index.
void | DeleteAllItems ()
Deletes all tab items from the tab manager.
int | GetItemCount () const
Gets the number of tab items in the tab manager.
virtual CString | GetItemCaption (const CXTPTabManagerItem *pItem) const
Retrieves the caption text of a specified tab item.
virtual HICON | GetItemIcon (const CXTPTabManagerItem *pItem) const
Retrieves the icon of a specified tab item.
virtual COLORREF | GetItemColor (const CXTPTabManagerItem *pItem) const
Retrieves the tab button color of a specified tab item.
virtual CString | GetItemTooltip (const CXTPTabManagerItem *pItem) const
Retrieves the tooltip of a specified tab item.
virtual void | OnItemsChanged ()
This method is called when tab items are changed (i.e.
void | SetCurSel (int nIndex)
Sets the index for the currently selected tab item within the collection of tab items.
int | GetCurSel () const
Gets the index of the currently selected tab item within the collection of tab items.
virtual void | SetSelectedItem (CXTPTabManagerItem *pItem)
Sets the currently selected tab item.
virtual void | SetFocusedItem (CXTPTabManagerItem *pItem)
Sets the focused tab item.
CXTPTabManagerItem * | GetSelectedItem () const
Gets the currently selected tab item.
CXTPTabManagerItem * | HitTest (CPoint point) const
Determines which tab is at a specified point, if any.
CXTPTabManagerNavigateButton * | HitTestNavigateButton (CPoint point, BOOL bHeaderOnly, int *pnIndex=NULL) const
Determines which navigation button is at a specified point, if any.
virtual void | GetItemMetrics (CSize *szNormal, CSize *szMin=NULL, CSize *szMax=NULL) const
Gets the minimum, maximum, and normal lengths of tab buttons.
void | SetItemMetrics (CSize szNormal, CSize szMin=CSize(0, 0), CSize szMax=CSize(0, 0))
Sets the minimum, maximum, and normal lengths for tab buttons.
void | MoveItem (CXTPTabManagerItem *pItem, int nIndex)
Sets the position of a specified tab item.
void | ShowCloseItemButton (XTPTabNavigateButtonFlags bCloseItemButton=xtpTabNavigateButtonAlways)
Call this member to show close button for each tab.
int | GetRectLength (CRect rc) const
Gets the length of the bounding rectangle of the tab client header area.
CXTPTabManagerNavigateButton * | FindNavigateButton (UINT nID) const
Retrieves a specified tab navigation button (i.e.
BOOL | IsHorizontalPosition () const
Determines if the tabs are positioned horizontally.
int | GetHeaderOffset () const
Gets the scroll offset of the tabs in the tab header.
void | SetHeaderOffset (int nOffset)
Sets the scroll offset for the tabs in the tab header.
void | EnsureVisible (CXTPTabManagerItem *pItem)
Ensures that a specified tab is visible.
virtual void | SetPaintManager (CXTPTabPaintManager *pPaintManager)
Sets the tab paint manager.
virtual void | RedrawControl (LPCRECT lpRect, BOOL bAnimate)=0
This method is called when the visual properties of the tabs are changed (e.g.
virtual BOOL | IsAllowReorder () const
Determines if tabs are allowed to be reordered.
virtual void | SetAllowReorder (BOOL bAllowReorder)
Specifies if tabs should be allowed to be reordered.
virtual BOOL | IsDrawStaticFrame () const
Determines if a static frame is used.
void | EnableTabThemeTexture (HWND hWnd, BOOL bEnable=TRUE)
Enables/disables Windows XP themed back color.
CXTPTabPaintManagerColorSet * | SetColor (XTPTabColorStyle tabColor)
Applies one of the "built-in" color sets for the tabs.
CXTPTabPaintManagerColorSet * | SetColorSet (CXTPTabPaintManagerColorSet *pColorSet)
Applies a custom color set for the tabs.
CXTPTabPaintManagerTheme * | SetAppearance (XTPTabAppearanceStyle tabAppearance)
Applies one of the "built-in" appearance sets for the tabs.
CXTPTabPaintManagerTheme * | SetAppearanceSet (CXTPTabPaintManagerTheme *pAppearanceSet)
Applies a custom appearance set for the tabs.
CXTPTabPaintManagerTheme * | GetAppearanceSet () const
Gets the currently applied custom appearance set.
CXTPTabPaintManagerColorSet * | GetColorSet () const
Gets the currently applied custom color set.
XTPTabAppearanceStyle | GetAppearance () const
Gets the currently applied "built-in appearance set.
XTPTabColorStyle | GetColor () const
Gets the currently applied "built-in" color set.
void | SetPosition (XTPTabPosition tabPosition)
Sets the tab position.
void | SetLayoutStyle (XTPTabLayoutStyle tabLayout)
Sets the tab layout style.
XTPTabLayoutStyle | GetLayout () const
Gets the tab layout style.
void | ShowIcons (BOOL bShowIcons)
Shows/hides tab icons.
void | SetActive (BOOL bActive)
Specifies if this tab group should be active/inactive.
BOOL | IsActive () const
Determines if this tab group is active/inactive.
CRect | GetControlRect () const
Gets the bounding rectangle of the tab manager control area.
CRect | GetClientRect () const
Gets the bounding rectangle of the tab client area.
CRect | GetHeaderRect () const
Gets the bounding rectangle of the tab client header area.
int | GetRowCount () const
Gets the number of rows of tabs in the tab control.
virtual void | OnScrollHeader (BOOL bRight)
This method is called when the user presses either the left or right navigation buttons.
CXTPTabManagerNavigateButtons * GetNavigateButtons ()
Gets the collection of navigation buttons.
CXTPTabManagerItem * | FindNextFocusable (int nIndex, int nDirection) const
Retrieves the next/previous focusable tab item from a specified index.
void | PerformMouseMove (HWND hWnd, CPoint pt)
This method is called when the mouse cursor moves.
BOOL | PerformClick (HWND hWnd, CPoint pt, BOOL bNoItemClick=FALSE)
This method is called when the user presses the left mouse button.
virtual INT_PTR | PerformToolHitTest (HWND hWnd, CPoint point, TOOLINFO *pTI) const
Determines which tab is beneath the mouse cursor, if any, and stores the tooltip information of the tab within a TOOLINFO structure.
virtual BOOL | PerformKeyDown (HWND hWnd, UINT nChar)
This method is called to process a WM_KEYDOWN event for the tab manager.
virtual BOOL | DrawParentBackground (CDC *pDC, CRect rc)
Draws the parent background under the tab control.
int | GetNavigateButtonCount () const
Gets the total number of tab navigation buttons within the collection of tab navigation buttons.
CXTPTabManagerNavigateButton * | GetNavigateButton (int nIndex) const
Retrieves the tab navigation button at a specified index within the collection of tab navigation buttons.
void | EnableMarkup (BOOL bEnable=TRUE)
Enables/disables markup for the tab captions.
virtual CXTPMarkupContext * | GetMarkupContext () const
Gets the markup context.
- Public Member Functions inherited from CXTPTabManagerAtom
virtual void | OnPropertyChanged ()
This method is called when a property of the tab paint manager is changed.
virtual void | Reposition ()=0
Recalculates the layout of the tab manager and then repositions itself.

Static Public Attributes

static BOOL m_bCloseActiveWindow
TRUE to allow the auto-hide window to be closed.

Protected Member Functions

CXTPDockingPaneAutoHidePanel (CXTPDockingPaneLayout *pLayout)
Constructs a CXTPDockingPaneAutoHidePanel object.
~CXTPDockingPaneAutoHidePanel ()
Destroys a CXTPDockingPaneAutoHidePanel object, handles cleanup and deallocation.
virtual void | OnSizeParentEx (CWnd *pParent, CRect &rect, LPVOID lParam)
This method is called to set the position of the pane.
virtual void | RemovePane (CXTPDockingPaneBase *pPane)
Call this member to remove a pane from the collection.
virtual void | OnChildContainerChanged (CXTPDockingPaneBase *pContainer)
This member is called when a child pane collection is changed.
virtual void | _InsertPane (CXTPDockingPaneBase *pPane)
Call this member to insert a pane into a collection.
virtual BOOL | DoPropExchange (CXTPPropExchange *pPX)
Call this member function to save/restore the settings of the pane.
void | CloseActiveWindow (BOOL bDelayed=FALSE)
Call this member to close the active window from a panel.
void | CloseActiveWindows ()
Call this member to close active windows from all panels.
void | ShowPane (CXTPDockingPane *pPane, BOOL bSetFocus=TRUE)
Call this member to show (activate) a pane by its identifier.
void | RefreshManagersArray (CDC *pDC, CRect rcClient)
Call this member to refresh the manager array.
int | GetPanelHeight () const
Retrieves the height of the panel.
virtual void | Create (CWnd *pParent)
Creates an auto-hide panel.
virtual void | InvalidatePane (BOOL bSelectionChanged)
This member is called when a pane must be redrawn.
- Protected Member Functions inherited from CXTPDockingPaneBaseContainer
CXTPDockingPaneBaseContainer (XTPDockingPaneType type, CXTPDockingPaneLayout *pLayout)
Protected constructor.
virtual | ~CXTPDockingPaneBaseContainer ()
Destroys a CXTPDockingPaneBase object, handles cleanup and deallocation.
virtual BOOL | IsEmpty () const
Call this member to determine if there are no children panes.
- Protected Member Functions inherited from CXTPDockingPaneBase
CXTPDockingPaneBase (XTPDockingPaneType type, CXTPDockingPaneLayout *pLayout)
Protected constructor.
virtual | ~CXTPDockingPaneBase ()
Destroys a CXTPDockingPaneBase object, handles cleanup and deallocation.
virtual void | OnSizeParent (CWnd *pParent, CRect rect, LPVOID lParam)
This method is called to set the position of the pane.
virtual void | OnFocusChanged ()
This method is called to update the state of the pane.
virtual void | SetDockingSite (CWnd *pFrame)
Call this member to set the parent frame of the pane.
virtual void | SetParentContainer (CXTPDockingPaneBase *pContainer)
Call this method to set the parent container of the pane.
virtual void | OnParentContainerChanged (CXTPDockingPaneBase *pContainer)
This member is called when the parent pane collection is changed.
virtual CXTPDockingPaneBase * | Clone (CXTPDockingPaneLayout *pLayout, CXTPPaneToPaneMap *pMap, DWORD dwIgnoredOptions=0)
This member is called to clone the pane.
virtual void | OnCaptionButtonRectChanged (CXTPDockingPaneCaptionButton *pButton)
This member is called when the dimensions of the caption button are changed.
virtual BOOL | IsCaptionButtonVisible (CXTPDockingPaneCaptionButton *pButton)
Call this member to determine if a caption button is visible.
virtual void | DeletePane ()=0
This method is called to destroy a pane.
virtual void | CreateContainer ()
This member is called to create a pane.
- Protected Member Functions inherited from CXTPTabManager
virtual BOOL | IsNavigateButtonAutomaticVisible (CXTPTabManagerNavigateButton *pButton)
Determines if a specified tab navigation button is automatically displayed.
virtual BOOL | IsNavigateButtonVisible (CXTPTabManagerNavigateButton *pButton)
Determines if a specified tab navigation button is visible.
virtual void | OnItemClick (CXTPTabManagerItem *pItem)
This method is called when a tab button is clicked to select the tab item that was clicked.
virtual BOOL | OnBeforeItemClick (CXTPTabManagerItem *pItem)
This method is called before a tab item is clicked.
virtual void | ReOrder (HWND hWnd, CPoint pt, CXTPTabManagerItem *pItem)
This method is called when a tab item is clicked and dragged within the tab header.
virtual void | OnSwitchItem (CXTPTabManagerItem *pItem1, CXTPTabManagerItem *pItem2)
This method is called by ReOrder when two tab items are switched.
virtual void | OnItemOrderChanged (CXTPTabManagerItem *pItem, int nOldIndex, int nNewIndex)
This method is called by ReOrder when a tab item's position is changed.
virtual void | OnNavigateButtonClick (CXTPTabManagerNavigateButton *pButton)
This method is called when a tab navigation button is clicked.
virtual void | OnNavigateButtonClick (UINT nID)
This method is called when a tab navigation button is clicked.
virtual BOOL | IsMouseLocked () const
Determines if the MouseMove event has been disabled.
CXTPTabManagerItem * | AddItem (int nItem, CXTPTabManagerItem *pItem=NULL)
Adds a specified tab item to the collection of tab items.
virtual BOOL | HeaderHasFocus () const
The implementation should return TRUE if the header has focus or FALSE otherwise.
void | TrackClick (HWND hWnd, CPoint pt, CXTPTabManagerItem *pItem)
Activates and tracks a specified tab item on mouse click.
virtual void | OnItemHandleChanged (CXTPTabManagerItem *pItem, HWND hwndOld, HWND hwndNew)
This method is called when the handle of a tab item is changed.
- Protected Member Functions inherited from CXTPTabManagerAtom
virtual | ~CXTPTabManagerAtom ()
Destroys a CXTPTabManagerAtom object, handles cleanup and deallocation.

Protected Attributes

CXTPDockingPaneAutoHideWnd * | m_pActiveWnd
Active window.
XTPDockingPaneDirection | m_direction
Location of hidden panel.
- Protected Attributes inherited from CXTPDockingPaneBaseContainer
CXTPDockingPaneBaseList | m_lstPanes
Child panes collection.
- Protected Attributes inherited from CXTPDockingPaneBase
CSize | m_szDocking
Size of the pane.
CXTPDockingPaneLayout * | m_pLayout
Parent layout.
CXTPDockingPaneBase * | m_pParentContainer
Parent container.
CWnd * | m_pDockingSite
Parent frame.
XTPDockingPaneType | m_type
Type of the pane.
CRect | m_rcWindow
Position of the pane.
CXTPDockingPaneCaptionButtons * | m_pCaptionButtons
Collection of caption buttons.
- Protected Attributes inherited from CXTPTabManager
CXTPTabManagerItem * m_pSelected
Tab currently selected (i.e.
CXTPTabManagerItem * m_pHighlighted
Tab currently highlighted (i.e.
CXTPTabManagerItem * | m_pPressed
Pointer to the currently pressed tab.
CXTPTabManagerNavigateButton * | m_pHighlightedNavigateButton
Pointer to highlighted navigate button.
int | m_nHeaderOffset
Scroll offset, this is how much the tabs in the tab header have been scrolled using the left and right tab navigation buttons.
BOOL | m_bAllowReorder
TRUE to allow tabs to be reordered.
BOOL | m_bActive
TRUE if the MDITabClient tab group is active.
XTPTabNavigateButtonFlags | m_bCloseItemButton
TRUE to show the close button for tabs.
CRect | m_rcHeaderRect
Bounding rectangle of the tab header area.
CRect | m_rcControl
Bounding rectangle of the tab manager control.
CArray< CXTPTabManagerItem *, CXTPTabManagerItem * > | m_arrItems
Bounding rectangle of the tab client area.
CXTPTabManagerNavigateButtons | m_arrNavigateButtons
Collection of tab navigation buttons for this tab manager.
CRowIndexer * | m_pRowIndexer
Row indexer.
int | m_nScrollDelta
Scroll header delta.
CXTPMarkupContext * | m_pMarkupContext
Markup context of the tab manager.

Detailed Description

CXTPDockingPaneAutoHidePanel is a multiple inheritance class derived from CWnd and CXTPDockingPaneBase.

It is used internally as an auto-hide container for CXTPDockingPaneBase derived classes.

Constructor & Destructor Documentation

◆ CXTPDockingPaneAutoHidePanel()

CXTPDockingPaneAutoHidePanel ( CXTPDockingPaneLayout * pLayout )
protected

Constructs a CXTPDockingPaneAutoHidePanel object.

Protected constructor. Internally constructed only.

Parameters
pLayout Pointer to a CXTPDockingPaneLayout object.

Member Function Documentation

◆ _InsertPane()

virtual void _InsertPane ( CXTPDockingPaneBase * pPane )
protectedvirtual

Call this member to insert a pane into a collection.

Parameters
pPane Pointer to a CXTPDockingPaneBase object.

◆ CloseActiveWindow()

void CloseActiveWindow ( BOOL bDelayed = FALSE )
protected

Call this member to close the active window from a panel.

Parameters
bDelayed FALSE to delay the closing.
See also
CloseActiveWindows

◆ CloseActiveWindows()

void CloseActiveWindows ( )
protected

Call this member to close active windows from all panels.

See also
CloseActiveWindow

◆ Create()

virtual void Create ( CWnd * pParent )
protectedvirtual

Creates an auto-hide panel.

Parameters
pParent Parent frame site.

◆ DoPropExchange()

virtual BOOL DoPropExchange ( CXTPPropExchange * pPX )
protectedvirtual

Call this member function to save/restore the settings of the pane.

Parameters
pPX Pointer to a CXTPPropExchange object.
Returns
TRUE if successful, otherwise FALSE.

Reimplemented from CXTPDockingPaneBase.

◆ DrawIcon()

virtual BOOL DrawIcon | ( | CDC * | pDC,
 |  | CPoint | pt,
 |  | CXTPTabManagerItem * | pItem,
 |  | BOOL | bDraw,
 |  | CSize & | szIcon ) const
 virtual

This member is called when the icon of the tab in the tabbed container needs to be drawn (i.e.

on mouse over).

Parameters
pDC | Pointer to the destination device context.
pt | Specifies the location of the image.
pItem | CXTPTabManagerItem object to draw icon on.
bDraw | TRUE if the icon needs to be drawn (i.e. the icon size changed), FALSE if the icon does not need to be drawn or redrawn.
szIcon | Size of the tab icon.
Returns
TRUE if the icon was drawn successfully, FALSE if the icon was not drawn.

Implements CXTPTabManager.

◆ GetDirection()

AFX_INLINE XTPDockingPaneDirection GetDirection ( ) const

Call this member function to determine the position of the auto-hide panel.

Returns
The panel's direction.

◆ GetItemsLength()

virtual int GetItemsLength ( ) const
virtual

Call this member to get the length of the items in the auto-hide panel.

Returns
Length of the items in the auto hide panel.

Reimplemented from CXTPTabManager.

◆ GetPaintManager()

virtual CXTPTabPaintManager * GetPaintManager ( ) const
virtual

This member is called to access the visual elements of the docking pane tabs (i.e.

tab colors, styles, etc.).

Returns
Pointer to the CXTPTabPaintManager that contains the visual elements of the docking pane tabs.

Implements CXTPTabManager.

◆ GetPaneHwnd()

AFX_INLINE HWND GetPaneHwnd ( ) const
virtual

Retrieves the window handle for a window.

Returns
The window handle for a window if successful. NULL if the HWND is not attached to a window or if it is used with a NULL HWND pointer.

Reimplemented from CXTPDockingPaneBase.

◆ GetPanelHeight()

int GetPanelHeight ( ) const
protected

Retrieves the height of the panel.

Returns
The height of the panel.

◆ GetPaneTab()

CXTPTabManagerItem * GetPaneTab ( CXTPDockingPane * pPane ) const

Call this member to get the tab for a corresponding pane.

Parameters
pPane Pane to get the tab for.
Returns
Pointer to the CXTPTabManagerItem object corresponding with pPane.

◆ GetPosition()

XTPTabPosition GetPosition ( ) const
virtual

Call this member to get the position of the pane's tab in the auto-hide panel.

Returns
Flag from the XTPTabPosition enumeration that specifies the position.

Reimplemented from CXTPTabManager.

◆ HitTest()

CXTPDockingPane * HitTest ( CPoint point ) const

This member function determines which header item, if any, is at a specified cursor position.

Parameters
point Point to be tested.
Returns
The index of the item at the position specified by 'point', otherwise NULL.

◆ InvalidatePane()

virtual void InvalidatePane ( BOOL bSelectionChanged )
protectedvirtual

This member is called when a pane must be redrawn.

Parameters
bSelectionChanged TRUE if the selected pane was changed.

Reimplemented from CXTPDockingPaneBase.

◆ OnChildContainerChanged()

virtual void OnChildContainerChanged ( CXTPDockingPaneBase * pContainer )
protectedvirtual

This member is called when a child pane collection is changed.

Parameters
pContainer Pointer to the CXTPDockingPaneBase object that was changed.

Reimplemented from CXTPDockingPaneBase.

◆ OnSizeParentEx()

virtual void OnSizeParentEx | ( | CWnd * | pParent,
 |  | CRect & | rect,
 |  | LPVOID | lParam )
 protectedvirtual

This method is called to set the position of the pane.

Parameters
pParent | Pointer to a CWnd object.
rect | Rectangle of the pane to be set.
lParam | Pointer to an AFX_SIZEPARENTPARAMS structure.

◆ RefreshManagersArray()

void RefreshManagersArray | ( | CDC * | pDC,
 |  | CRect | rcClient )
 protected

Call this member to refresh the manager array.

Parameters
pDC | Pointer to a CDC object.
rcClient | Size of the client area.

◆ RemovePane()

virtual void RemovePane ( CXTPDockingPaneBase * pPane )
protectedvirtual

Call this member to remove a pane from the collection.

Parameters
pPane Pointer to a CXTPDockingPaneBase object.

Reimplemented from CXTPDockingPaneBase.

◆ ShowPane()

void ShowPane | ( | CXTPDockingPane * | pPane,
 |  | BOOL | bSetFocus = TRUE )
 protected

Call this member to show (activate) a pane by its identifier.

Parameters
pPane | Pointer to a CXTPDockingPane object.
bSetFocus | TRUE to set focus to the child docking pane.
The documentation for this class was generated from the following file:
  • XTPDockingPaneAutoHidePanel.h


Toolkit Pro: CXTPDockingPaneAutoHideWnd Class Reference

Public Member Functions | Static Public Attributes | List of all members
CXTPDockingPaneAutoHideWnd Class Reference

CXTPDockingPaneAutoHideWnd is a CMiniFrameWnd derived class. More...

Public Member Functions

CXTPDockingPaneTabbedContainer * GetPane () const

Static Public Attributes

static double | m_dAnimationDelay
Animation delay.
static int | m_nAnimationInterval
Delay in ms between animation steps.
static int | m_nAnimationDuration
Duration of sliding animation in ms.
static DWORD | m_nMouseHoverDelay
Duration of mouse hover before expanding.
static UINT | m_nInactiveCollapseDelay
Delay before collapsing inactive.

Detailed Description

CXTPDockingPaneAutoHideWnd is a CMiniFrameWnd derived class.

It is used internally by CXTPDockingPaneAutoHidePanel as a sliding auto-hide window for the hidden pane.

Member Function Documentation

◆ GetPane()

AFX_INLINE CXTPDockingPaneTabbedContainer * GetPane ( ) const
Returns
Retrieves the child container of a sliding auto-hide window.
The documentation for this class was generated from the following file:
  • XTPDockingPaneAutoHidePanel.h


Toolkit Pro: CXTPDockingPaneBase Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPDockingPaneBase Class Referenceabstract

CXTPDockingPaneBase is a standalone class. More...

Inheritance diagram for CXTPDockingPaneBase:
[legend]

Public Member Functions

virtual BOOL | IsActive () const
Determines if the frame is active.
virtual BOOL | IsCaptionVertical () const
Determines if the caption is drawn vertically.
virtual CString | GetTitle () const
Call this member to get the text in the caption for the tabbed container (group of panes).
XTPDockingPaneType | GetType () const
Call this member to determine the type of the pane.
CRect | GetPaneWindowRect () const
The GetPaneWindowRect function retrieves the dimensions of the bounding rectangle of the pane.
CXTPDockingPaneBase * | GetContainer () const
Call this member function to retrieve the parent container of the pane.
CXTPDockingPaneManager * | GetDockingPaneManager () const
Call this member function to retrieve the pane manager.
CXTPDockingPanePaintManager * | GetPaintManager () const
Call this member function to retrieve the paint manager.
CXTPDockingPaneCaptionButton * | FindCaptionButton (int nID) const
Call this member to find the specified caption button.
CXTPDockingPaneCaptionButtons * | GetCaptionButtons () const
Call this member to get a reference to the caption's close/pop-up button.
virtual void | RedrawPane ()
Call this member to redraw the pane.
virtual POSITION | ContainPane (CXTPDockingPaneBase *pPane) const
Call this member to determine if one pane is contained in the collection of another.
virtual void | FindPane (XTPDockingPaneType type, CXTPDockingPaneBaseList *pList) const
Call this member to retrieve a collection of the panes with a specified type.
virtual void | GetMinMaxInfo (LPMINMAXINFO pMinMaxInfo) const
Call this member to fill the pMinMaxInfo structure with the minimum and maximum width and height of the container.
virtual BOOL | IsEmpty () const
Call this member to determine if there are no children panes.
virtual CWnd * | GetDockingSite () const
Call this member function to retrieve the parent window for the pane.
virtual BOOL | IsHidden () const
Call this member to check if the pane is hidden.
virtual HWND | GetPaneHwnd () const
Retrieves the window handle for a window.
virtual void | InvalidatePane (BOOL bSelectionChanged)
This member is called when a pane must be redrawn.

Protected Member Functions

CXTPDockingPaneBase (XTPDockingPaneType type, CXTPDockingPaneLayout *pLayout)
Protected constructor.
virtual | ~CXTPDockingPaneBase ()
Destroys a CXTPDockingPaneBase object, handles cleanup and deallocation.
virtual void | OnSizeParent (CWnd *pParent, CRect rect, LPVOID lParam)
This method is called to set the position of the pane.
virtual void | OnFocusChanged ()
This method is called to update the state of the pane.
virtual void | SetDockingSite (CWnd *pFrame)
Call this member to set the parent frame of the pane.
virtual void | SetParentContainer (CXTPDockingPaneBase *pContainer)
Call this method to set the parent container of the pane.
virtual void | OnChildContainerChanged (CXTPDockingPaneBase *pContainer)
This member is called when a child pane collection is changed.
virtual void | OnParentContainerChanged (CXTPDockingPaneBase *pContainer)
This member is called when the parent pane collection is changed.
virtual BOOL | DoPropExchange (CXTPPropExchange *pPX)
Call this member function to save/restore the settings of the pane.
virtual CXTPDockingPaneBase * | Clone (CXTPDockingPaneLayout *pLayout, CXTPPaneToPaneMap *pMap, DWORD dwIgnoredOptions=0)
This member is called to clone the pane.
virtual void | Copy (CXTPDockingPaneBase *pClone, CXTPPaneToPaneMap *pMap, DWORD dwIgnoredOptions)
This member is called to copy a pane.
virtual void | RemovePane (CXTPDockingPaneBase *pPane)
Call this member to remove a pane from the collection.
virtual void | OnCaptionButtonRectChanged (CXTPDockingPaneCaptionButton *pButton)
This member is called when the dimensions of the caption button are changed.
virtual BOOL | IsCaptionButtonVisible (CXTPDockingPaneCaptionButton *pButton)
Call this member to determine if a caption button is visible.
virtual void | DeletePane ()=0
This method is called to destroy a pane.
virtual void | CreateContainer ()
This member is called to create a pane.

Protected Attributes

CSize | m_szDocking
Size of the pane.
CXTPDockingPaneLayout * | m_pLayout
Parent layout.
CXTPDockingPaneBase * | m_pParentContainer
Parent container.
CWnd * | m_pDockingSite
Parent frame.
XTPDockingPaneType | m_type
Type of the pane.
CRect | m_rcWindow
Position of the pane.
CXTPDockingPaneCaptionButtons * | m_pCaptionButtons
Collection of caption buttons.

Detailed Description

CXTPDockingPaneBase is a standalone class.

It represents the parent class for a docking pane and its containers.

Constructor & Destructor Documentation

◆ CXTPDockingPaneBase()

CXTPDockingPaneBase | ( | XTPDockingPaneType | type,
 |  | CXTPDockingPaneLayout * | pLayout )
 protected

Protected constructor.

You cannot create this class.

Parameters
type | Docking Pane type. Can be any of the values listed in the Remarks section.
pLayout | Pointer to a CXTPDockingPaneLayout object.

Docking Pane type can be one of the following: xtpPaneTypeDockingPane: Indicates the pane's style is a docking pane. xtpPaneTypeTabbedContainer: Indicates the pane's style is a tabbed container for a pane. xtpPaneTypeSplitterContainer: Indicates the pane's style is a splitter container. xtpPaneTypeMiniWnd: Indicates the pane's style is a floating window container. xtpPaneTypeClient: Indicates the pane's style is a container for client area. xtpPaneTypeAutoHidePanel: Indicates the pane's style is an auto-hide panel container.

Member Function Documentation

◆ Clone()

virtual CXTPDockingPaneBase * Clone | ( | CXTPDockingPaneLayout * | pLayout,
 |  | CXTPPaneToPaneMap * | pMap,
 |  | DWORD | dwIgnoredOptions = 0 )
 protectedvirtual

This member is called to clone the pane.

Parameters
pLayout | Pointer to a CXTPDockingPaneLayout object.
pMap | Pointer to a CXTPPaneToPaneMap object.
dwIgnoredOptions | Options that must be skipped.
Returns
A pointer to a CXTPDockingPaneBase object.
See also
CXTPPaneToPaneMap

◆ ContainPane()

virtual POSITION ContainPane ( CXTPDockingPaneBase * pPane ) const
virtual

Call this member to determine if one pane is contained in the collection of another.

Parameters
pPane Pointer to a CXTPDockingPaneBase object.
Returns
POSITION of the pane in the collection if successful, otherwise NULL.

Reimplemented in CXTPDockingPaneBaseContainer.

◆ Copy()

virtual void Copy | ( | CXTPDockingPaneBase * | pClone,
 |  | CXTPPaneToPaneMap * | pMap,
 |  | DWORD | dwIgnoredOptions )
 protectedvirtual

This member is called to copy a pane.

Parameters
pClone | Pointer to a CXTPDockingPaneBase object.
pMap | Pointer to a CXTPPaneToPaneMap object.
dwIgnoredOptions | Options that must be skipped.
See also
CXTPPaneToPaneMap

Reimplemented in CXTPDockingPaneMiniWnd, CXTPDockingPaneSidePanel, CXTPDockingPaneSplitterContainer, and CXTPDockingPaneTabbedContainer.

◆ DoPropExchange()

virtual BOOL DoPropExchange ( CXTPPropExchange * pPX )
protectedvirtual

Call this member function to save/restore the settings of the pane.

Parameters
pPX Pointer to a CXTPPropExchange object.
Returns
TRUE if successful, otherwise returns FALSE.

Reimplemented in CXTPDockingPane, CXTPDockingPaneAutoHidePanel, CXTPDockingPaneMiniWnd, CXTPDockingPaneSidePanel, CXTPDockingPaneSplitterContainer, and CXTPDockingPaneTabbedContainer.

◆ FindCaptionButton()

CXTPDockingPaneCaptionButton * FindCaptionButton ( int nID ) const

Call this member to find the specified caption button.

Parameters
nID Identifier of the button.
Returns
The CXTPDockingPaneCaptionButton object if successful, otherwise NULL.

◆ FindPane()

virtual void FindPane | ( | XTPDockingPaneType | type,
 |  | CXTPDockingPaneBaseList * | pList ) const
 virtual

Call this member to retrieve a collection of the panes with a specified type.

Parameters
type | Type of the panes to find.
pList | Pointer to a CXTPDockingPaneBaseList object that will contain found panes.
See also
CXTPDockingPaneBaseList

Reimplemented in CXTPDockingPaneBaseContainer, and CXTPDockingPaneMiniWnd.

◆ GetCaptionButtons()

AFX_INLINE CXTPDockingPaneCaptionButtons * GetCaptionButtons ( ) const

Call this member to get a reference to the caption's close/pop-up button.

Returns
A reference to a CXTPDockingPaneCaptionButtons object.

◆ GetContainer()

AFX_INLINE CXTPDockingPaneBase * GetContainer ( ) const

Call this member function to retrieve the parent container of the pane.

Returns
The parent container of the pane.

◆ GetDockingPaneManager()

CXTPDockingPaneManager * GetDockingPaneManager ( ) const

Call this member function to retrieve the pane manager.

Returns
A pointer to a CXTPDockingPaneManager object.

◆ GetDockingSite()

AFX_INLINE CWnd * GetDockingSite ( ) const
virtual

Call this member function to retrieve the parent window for the pane.

Returns
A pointer to a parent window if successful, otherwise NULL.

Reimplemented in CXTPDockingPane.

◆ GetMinMaxInfo()

virtual void GetMinMaxInfo ( LPMINMAXINFO pMinMaxInfo ) const
virtual

Call this member to fill the pMinMaxInfo structure with the minimum and maximum width and height of the container.

This will look at the MinMaxInfo for each pane in the container and set the appropriate minimum and maximum width and height for the container.

Parameters
pMinMaxInfo Pointer to a MINMAXINFO structure.

Reimplemented in CXTPDockingPane, CXTPDockingPaneMiniWnd, CXTPDockingPaneSidePanel, CXTPDockingPaneSplitterContainer, and CXTPDockingPaneTabbedContainer.

◆ GetPaintManager()

CXTPDockingPanePaintManager * GetPaintManager ( ) const

Call this member function to retrieve the paint manager.

Returns
A pointer to a CXTPDockingPanePaintManager object.

◆ GetPaneHwnd()

AFX_INLINE HWND GetPaneHwnd ( ) const
virtual

Retrieves the window handle for a window.

Returns
The window handle for a window if successful. NULL if the HWND is not attached to a window or if it is used with a NULL HWND pointer.

Reimplemented in CXTPDockingPaneAutoHidePanel, CXTPDockingPaneMiniWnd, CXTPDockingPaneSidePanel, and CXTPDockingPaneTabbedContainer.

◆ GetPaneWindowRect()

CRect GetPaneWindowRect ( ) const

The GetPaneWindowRect function retrieves the dimensions of the bounding rectangle of the pane.

Returns
The visible rectangle of the pane.

◆ GetTitle()

AFX_INLINE CString GetTitle ( ) const
virtual

Call this member to get the text in the caption for the tabbed container (group of panes).

Returns
The text in the caption for the tabbed container (group of panes).

Reimplemented in CXTPDockingPane, CXTPDockingPaneMiniWnd, CXTPDockingPaneSidePanel, and CXTPDockingPaneTabbedContainer.

◆ GetType()

AFX_INLINE XTPDockingPaneType GetType ( ) const

Call this member to determine the type of the pane.

Returns
The type of the pane. It can be one of the following: xtpPaneTypeDockingPane: Indicates the pane's style is a docking pane. xtpPaneTypeTabbedContainer: Indicates the pane's style is a tabbed container for a pane. xtpPaneTypeSplitterContainer: Indicates the pane's style is a splitter container. xtpPaneTypeMiniWnd: Indicates the pane's style is a floating window container. xtpPaneTypeClient: Indicates the pane's style is a container for client area. xtpPaneTypeAutoHidePanel: Indicates the pane's style is an auto-hide panel container.

◆ InvalidatePane()

virtual void InvalidatePane ( BOOL bSelectionChanged )
virtual

This member is called when a pane must be redrawn.

Parameters
bSelectionChanged TRUE if the selected pane was changed.

Reimplemented in CXTPDockingPaneAutoHidePanel, CXTPDockingPaneMiniWnd, and CXTPDockingPaneSidePanel.

◆ IsActive()

AFX_INLINE BOOL IsActive ( ) const
virtual

Determines if the frame is active.

Returns
TRUE if the frame is active.

Reimplemented in CXTPDockingPaneMiniWnd, CXTPDockingPaneSidePanel, and CXTPDockingPaneTabbedContainer.

◆ IsCaptionButtonVisible()

AFX_INLINE BOOL IsCaptionButtonVisible ( CXTPDockingPaneCaptionButton * pButton )
protectedvirtual

Call this member to determine if a caption button is visible.

Parameters
pButton Caption button pointer.
Returns
TRUE if the caption button is visible, otherwise FALSE.

Reimplemented in CXTPDockingPaneMiniWnd, and CXTPDockingPaneTabbedContainer.

◆ IsCaptionVertical()

AFX_INLINE BOOL IsCaptionVertical ( ) const
virtual

Determines if the caption is drawn vertically.

Returns
TRUE if the caption is drawn vertically.

Reimplemented in CXTPDockingPaneMiniWnd, CXTPDockingPaneSidePanel, and CXTPDockingPaneTabbedContainer.

◆ IsEmpty()

virtual BOOL IsEmpty ( ) const
virtual

Call this member to determine if there are no children panes.

Returns
TRUE if there are no children panes, otherwise FALSE.

Reimplemented in CXTPDockingPaneBaseContainer.

◆ IsHidden()

virtual BOOL IsHidden ( ) const
virtual

Call this member to check if the pane is hidden.

Returns
TRUE if the pane is hidden.

Reimplemented in CXTPDockingPane, and CXTPDockingPaneTabbedContainer.

◆ OnCaptionButtonRectChanged()

AFX_INLINE void OnCaptionButtonRectChanged ( CXTPDockingPaneCaptionButton * pButton )
protectedvirtual

This member is called when the dimensions of the caption button are changed.

Parameters
pButton Caption button pointer.

◆ OnChildContainerChanged()

virtual void OnChildContainerChanged ( CXTPDockingPaneBase * pContainer )
protectedvirtual

This member is called when a child pane collection is changed.

Parameters
pContainer Pointer to the CXTPDockingPaneBase object that was changed.

Reimplemented in CXTPDockingPaneAutoHidePanel, CXTPDockingPaneMiniWnd, and CXTPDockingPaneSplitterContainer.

◆ OnParentContainerChanged()

virtual void OnParentContainerChanged ( CXTPDockingPaneBase * pContainer )
protectedvirtual

This member is called when the parent pane collection is changed.

Parameters
pContainer Pointer to the CXTPDockingPaneBase object that was changed.

Reimplemented in CXTPDockingPaneSplitterContainer.

◆ OnSizeParent()

virtual void OnSizeParent | ( | CWnd * | pParent,
 |  | CRect | rect,
 |  | LPVOID | lParam )
 protectedvirtual

This method is called to set the position of the pane.

Parameters
pParent | Pointer to a CWnd object.
rect | Rectangle of the pane to be set.
lParam | Pointer to an AFX_SIZEPARENTPARAMS structure.

Reimplemented in CXTPDockingPane, and CXTPDockingPaneSplitterContainer.

◆ RemovePane()

virtual void RemovePane ( CXTPDockingPaneBase * pPane )
protectedvirtual

Call this member to remove a pane from the collection.

Parameters
pPane Pointer to a CXTPDockingPaneBase object.

Reimplemented in CXTPDockingPaneAutoHidePanel, CXTPDockingPaneMiniWnd, and CXTPDockingPaneSplitterContainer.

◆ SetDockingSite()

AFX_INLINE void SetDockingSite ( CWnd * pFrame )
protectedvirtual

Call this member to set the parent frame of the pane.

Parameters
pFrame Pointer to a CWnd object.

◆ SetParentContainer()

AFX_INLINE void SetParentContainer ( CXTPDockingPaneBase * pContainer )
protectedvirtual

Call this method to set the parent container of the pane.

Parameters
pContainer Pointer to a CXTPDockingPaneBase object.

Reimplemented in CXTPDockingPane.

The documentation for this class was generated from the following file:
  • XTPDockingPaneBase.h


Toolkit Pro: CXTPDockingPaneBaseContainer Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPDockingPaneBaseContainer Class Reference

CXTPDockingPaneBaseContainer is a CXTPDockingPaneBase derived class. More...

Inheritance diagram for CXTPDockingPaneBaseContainer:
[legend]

Public Member Functions

virtual POSITION | ContainPane (CXTPDockingPaneBase *pPane) const
Call this member to determine if one pane is contained in the collection of another.
virtual void | FindPane (XTPDockingPaneType type, CXTPDockingPaneBaseList *pList) const
Call this member to find all panes of a specific XTPDockingPaneType within the container.
POSITION | GetHeadPosition () const
This method retrieves the position of the first pane of this container.
CXTPDockingPaneBase * | GetNext (POSITION &pos) const
Gets the pane element identified by rPosition, then sets rPosition to the POSITION value of the next entry in the container.
CXTPDockingPaneBase * | GetFirstPane () const
This method retrieves the first pane in the container.
CXTPDockingPaneBase * | GetLastPane () const
This method retrieves the last pane in the container.
CXTPDockingPaneBaseList & GetPanes ()
Call this member to retrieve the collection of child panes.
BOOL | OnAction (XTPDockingPaneAction action)
This method is called if some action occurs.
- Public Member Functions inherited from CXTPDockingPaneBase
virtual BOOL | IsActive () const
Determines if the frame is active.
virtual BOOL | IsCaptionVertical () const
Determines if the caption is drawn vertically.
virtual CString | GetTitle () const
Call this member to get the text in the caption for the tabbed container (group of panes).
XTPDockingPaneType | GetType () const
Call this member to determine the type of the pane.
CRect | GetPaneWindowRect () const
The GetPaneWindowRect function retrieves the dimensions of the bounding rectangle of the pane.
CXTPDockingPaneBase * | GetContainer () const
Call this member function to retrieve the parent container of the pane.
CXTPDockingPaneManager * | GetDockingPaneManager () const
Call this member function to retrieve the pane manager.
CXTPDockingPanePaintManager * | GetPaintManager () const
Call this member function to retrieve the paint manager.
CXTPDockingPaneCaptionButton * | FindCaptionButton (int nID) const
Call this member to find the specified caption button.
CXTPDockingPaneCaptionButtons * | GetCaptionButtons () const
Call this member to get a reference to the caption's close/pop-up button.
virtual void | RedrawPane ()
Call this member to redraw the pane.
virtual void | GetMinMaxInfo (LPMINMAXINFO pMinMaxInfo) const
Call this member to fill the pMinMaxInfo structure with the minimum and maximum width and height of the container.
virtual CWnd * | GetDockingSite () const
Call this member function to retrieve the parent window for the pane.
virtual BOOL | IsHidden () const
Call this member to check if the pane is hidden.
virtual HWND | GetPaneHwnd () const
Retrieves the window handle for a window.
virtual void | InvalidatePane (BOOL bSelectionChanged)
This member is called when a pane must be redrawn.

Protected Member Functions

CXTPDockingPaneBaseContainer (XTPDockingPaneType type, CXTPDockingPaneLayout *pLayout)
Protected constructor.
virtual | ~CXTPDockingPaneBaseContainer ()
Destroys a CXTPDockingPaneBase object, handles cleanup and deallocation.
virtual BOOL | IsEmpty () const
Call this member to determine if there are no children panes.
- Protected Member Functions inherited from CXTPDockingPaneBase
CXTPDockingPaneBase (XTPDockingPaneType type, CXTPDockingPaneLayout *pLayout)
Protected constructor.
virtual | ~CXTPDockingPaneBase ()
Destroys a CXTPDockingPaneBase object, handles cleanup and deallocation.
virtual void | OnSizeParent (CWnd *pParent, CRect rect, LPVOID lParam)
This method is called to set the position of the pane.
virtual void | OnFocusChanged ()
This method is called to update the state of the pane.
virtual void | SetDockingSite (CWnd *pFrame)
Call this member to set the parent frame of the pane.
virtual void | SetParentContainer (CXTPDockingPaneBase *pContainer)
Call this method to set the parent container of the pane.
virtual void | OnChildContainerChanged (CXTPDockingPaneBase *pContainer)
This member is called when a child pane collection is changed.
virtual void | OnParentContainerChanged (CXTPDockingPaneBase *pContainer)
This member is called when the parent pane collection is changed.
virtual BOOL | DoPropExchange (CXTPPropExchange *pPX)
Call this member function to save/restore the settings of the pane.
virtual CXTPDockingPaneBase * | Clone (CXTPDockingPaneLayout *pLayout, CXTPPaneToPaneMap *pMap, DWORD dwIgnoredOptions=0)
This member is called to clone the pane.
virtual void | Copy (CXTPDockingPaneBase *pClone, CXTPPaneToPaneMap *pMap, DWORD dwIgnoredOptions)
This member is called to copy a pane.
virtual void | RemovePane (CXTPDockingPaneBase *pPane)
Call this member to remove a pane from the collection.
virtual void | OnCaptionButtonRectChanged (CXTPDockingPaneCaptionButton *pButton)
This member is called when the dimensions of the caption button are changed.
virtual BOOL | IsCaptionButtonVisible (CXTPDockingPaneCaptionButton *pButton)
Call this member to determine if a caption button is visible.
virtual void | DeletePane ()=0
This method is called to destroy a pane.
virtual void | CreateContainer ()
This member is called to create a pane.

Protected Attributes

CXTPDockingPaneBaseList | m_lstPanes
Child panes collection.
- Protected Attributes inherited from CXTPDockingPaneBase
CSize | m_szDocking
Size of the pane.
CXTPDockingPaneLayout * | m_pLayout
Parent layout.
CXTPDockingPaneBase * | m_pParentContainer
Parent container.
CWnd * | m_pDockingSite
Parent frame.
XTPDockingPaneType | m_type
Type of the pane.
CRect | m_rcWindow
Position of the pane.
CXTPDockingPaneCaptionButtons * | m_pCaptionButtons
Collection of caption buttons.

Detailed Description

CXTPDockingPaneBaseContainer is a CXTPDockingPaneBase derived class.

It represents the parent class for all virtual containers.

Constructor & Destructor Documentation

◆ CXTPDockingPaneBaseContainer()

CXTPDockingPaneBaseContainer | ( | XTPDockingPaneType | type,
 |  | CXTPDockingPaneLayout * | pLayout )
 protected

Protected constructor.

You cannot create this class.

Parameters
type | Docking Pane type. Can be any of the values listed in the Remarks section.
pLayout | Pointer to a CXTPDockingPaneLayout object.

Docking Pane type can be one of the following: xtpPaneTypeDockingPane: Indicates the pane's style is a docking pane. xtpPaneTypeTabbedContainer: Indicates the pane's style is a tabbed container for a pane. xtpPaneTypeSplitterContainer: Indicates the pane's style is a splitter container. xtpPaneTypeMiniWnd: Indicates the pane's style is a floating window container. xtpPaneTypeClient: Indicates the pane's style is a container for client area. xtpPaneTypeAutoHidePanel: Indicates the pane's style is an auto-hide panel container.

Member Function Documentation

◆ ContainPane()

virtual POSITION ContainPane ( CXTPDockingPaneBase * pPane ) const
virtual

Call this member to determine if one pane is contained in the collection of another.

Parameters
pPane Pointer to a CXTPDockingPaneBase object
Returns
POSITION of the pane in the collection if successful, otherwise NULL.

Reimplemented from CXTPDockingPaneBase.

◆ FindPane()

virtual void FindPane | ( | XTPDockingPaneType | type,
 |  | CXTPDockingPaneBaseList * | pList ) const
 virtual

Call this member to find all panes of a specific XTPDockingPaneType within the container.

Parameters
type | Type of docking pane to search for within the container.
pList | An array of type CXTPDockingPaneBaseList that will contain a list of all panes of the specified type that are in the tabbed container. This points to a CXTPDockingPaneBaseList object that will contain the found panes.

pList is an external list that you must create and pass in as a parameter. See example below:

Example: This will get the count of panes inside container:

CXTPDockingPaneBaseList lst;

m_pTopContainer->FindPane(xtpPaneTypeTabbedContainer, &lst);
int nCount = (int)lst.GetCount();

Reimplemented from CXTPDockingPaneBase.

◆ GetFirstPane()

CXTPDockingPaneBase * GetFirstPane ( ) const

This method retrieves the first pane in the container.

Returns
First pane in the container.
See also
GetLastPane, GetHeadPosition

◆ GetHeadPosition()

POSITION GetHeadPosition ( ) const

This method retrieves the position of the first pane of this container.

Returns
A POSITION value that can be used for iteration or object pointer retrieval; it is NULL if the list is empty.
See also
GetNext

◆ GetLastPane()

CXTPDockingPaneBase * GetLastPane ( ) const

This method retrieves the last pane in the container.

Returns
Last pane in the container.
See also
GetFirstPane, GetHeadPosition

◆ GetNext()

CXTPDockingPaneBase * GetNext ( POSITION & pos ) const

Gets the pane element identified by rPosition, then sets rPosition to the POSITION value of the next entry in the container.

You can use GetNext in a forward iteration loop if you establish the initial position with a call to GetHeadPosition.

Parameters
pos Specifies a reference to a POSITION value returned by a previous GetNext, GetHeadPosition, or other method call.
Returns
Pane identified by rPosition.
See also
GetHeadPosition

◆ GetPanes()

AFX_INLINE CXTPDockingPaneBaseList & GetPanes ( )

Call this member to retrieve the collection of child panes.

Returns
A reference to the child panes collection.

◆ IsEmpty()

virtual BOOL IsEmpty ( ) const
protectedvirtual

Call this member to determine if there are no children panes.

Returns
TRUE if there are no children panes, otherwise FALSE.

Reimplemented from CXTPDockingPaneBase.

◆ OnAction()

BOOL OnAction ( XTPDockingPaneAction action )

This method is called if some action occurs.

Parameters
action Docking pane action.
Returns
TRUE if the action was canceled.
The documentation for this class was generated from the following file:
  • XTPDockingPaneBaseContainer.h


Toolkit Pro: CXTPDockingPaneCaptionButton Class Reference

Public Member Functions | Static Public Member Functions | Protected Attributes | List of all members
CXTPDockingPaneCaptionButton Class Reference

CXTPDockingPaneCaptionButton is a standalone internal class. More...

Public Member Functions

CXTPDockingPaneCaptionButton (int nID, CXTPDockingPaneBase *pPane)
Constructs a CXTPDockingPaneCaptionButton object.
void | SetRect (CRect rc)
Call this member to set the button's rectangle.
DWORD | Click (CWnd *pWnd, CPoint pt, BOOL bClient=TRUE)
Call this method to click a button.
CRect | GetRect () const
Call this member to get the bounding rectangle.
DWORD | GetState () const
Call this member to determine the state of the pin caption button.
void | SetState (DWORD dwState)
Call this member to set the state for the pin caption button.
int | GetID () const
Call this member to retrieve the button identifier.
CXTPDockingPaneBase * | GetPane () const
Call this member to retrieve the pane that the pin caption button controls.
BOOL | PtInRect (POINT pt) const
Call this member to determine if a specified point belongs to the button.
BOOL | CheckForMouseOver (CPoint pt)
Call this member to refresh the styles of the button.
void | InvalidateRect ()
Call this member to redraw the button.
BOOL | IsPressed () const
Call this member to determine if the pin caption button is pressed.
BOOL | IsSelected () const
Call this member to determine if the mouse is hovering over the pin caption button.
BOOL | IsVisible () const
Call this member to determine if the pin caption button is visible.
BOOL | IsEnabled () const
Call this member to determine if the pin caption button is enabled.

Static Public Member Functions

static void AFX_CDECL | DrawPinButton (CDC *pDC, CPoint pt, BOOL bPinned, COLORREF clr=COLORREF_NULL)
Call this member to draw the pin button.
static void AFX_CDECL | DrawPinButton (CDC *pDC, CRect rc, BOOL bPinned, COLORREF clr=COLORREF_NULL)
Call this member to draw the pin button.
static void AFX_CDECL | DrawMaximizeRestoreButton (CDC *pDC, CPoint pt, BOOL bMaximize, COLORREF clr=COLORREF_NULL)
Call this member to draw the Maximize/Restore button.
static void AFX_CDECL | DrawMaximizeRestoreButton (CDC *pDC, CRect rc, BOOL bMaximize, COLORREF clr=COLORREF_NULL)
Call this member to draw the Maximize/Restore button.
static void AFX_CDECL | DrawCloseButton (CDC *pDC, CRect rc, COLORREF clr=COLORREF_NULL)
Call this member to draw the Close button.
static void AFX_CDECL | DrawMenuButton (CDC *pDC, CRect rc, COLORREF clr=COLORREF_NULL)
Call this member to draw the Menu button.

Protected Attributes

CRect | m_rcButton
Bounding rectangle of the button.
CXTPDockingPaneBase * | m_pPane
Parent pane.
int | m_nID
Identifier of the button.
BOOL | m_bPressed
TRUE if the button is pressed.
BOOL | m_bSelected
TRUE if the mouse is hovering over the button.
DWORD | m_dwState
XTPDockingPanePinState of the pin caption button.

Detailed Description

CXTPDockingPaneCaptionButton is a standalone internal class.

Constructor & Destructor Documentation

◆ CXTPDockingPaneCaptionButton()

CXTPDockingPaneCaptionButton | ( | int | nID,
 |  | CXTPDockingPaneBase * | pPane )

Constructs a CXTPDockingPaneCaptionButton object.

Parameters
nID | ID of the caption button.
pPane | Pane that the caption button controls.

Member Function Documentation

◆ CheckForMouseOver()

BOOL CheckForMouseOver ( CPoint pt )

Call this member to refresh the styles of the button.

Parameters
pt Pointer to the mouse cursor.
Returns
True if mouse over, false otherwise

◆ Click()

DWORD Click | ( | CWnd * | pWnd,
 |  | CPoint | pt,
 |  | BOOL | bClient = TRUE )

Call this method to click a button.

Parameters
pWnd | Parent window of the button.
pt | Initial mouse position.
bClient | TRUE if pt belongs in the client area of the window.
Returns
Draws the click button

◆ DrawCloseButton()

static void AFX_CDECL DrawCloseButton | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | COLORREF | clr = COLORREF_NULL )
 static

Call this member to draw the Close button.

Parameters
pDC | Pointer to the device context in which to draw.
rc | Button rectangle.
clr | Button color. COLORREF_NULL by default. In this case, current text color is used.
Returns
Draws the Close button

◆ DrawMaximizeRestoreButton() [1/2]

static void AFX_CDECL DrawMaximizeRestoreButton | ( | CDC * | pDC,
 |  | CPoint | pt,
 |  | BOOL | bMaximize,
 |  | COLORREF | clr = COLORREF_NULL )
 static

Call this member to draw the Maximize/Restore button.

Parameters
pDC | Pointer to the device context in which to draw.
pt | Center point.
bMaximize | TRUE to draw the Maximize button, FALSE to draw the Restore button.
clr | Button color. COLORREF_NULL by default. In this case, current text color is used.
Returns
Draws the Maximize/Restore button

◆ DrawMaximizeRestoreButton() [2/2]

static void AFX_CDECL DrawMaximizeRestoreButton | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | BOOL | bMaximize,
 |  | COLORREF | clr = COLORREF_NULL )
 static

Call this member to draw the Maximize/Restore button.

Parameters
pDC | Pointer to the device context in which to draw.
rc | Button rectangle.
bMaximize | TRUE to draw the Maximize button, FALSE to draw the Restore button.
clr | Button color. COLORREF_NULL by default. In this case, current text color is used.
Returns
Draws the Maximize/Restore button

◆ DrawMenuButton()

static void AFX_CDECL DrawMenuButton | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | COLORREF | clr = COLORREF_NULL )
 static

Call this member to draw the Menu button.

Parameters
pDC | Pointer to the device context in which to draw.
rc | Button rectangle.
clr | Button color. COLORREF_NULL by default. In this case, current text color is used.
Returns
Draws the menu button

◆ DrawPinButton() [1/2]

static void AFX_CDECL DrawPinButton | ( | CDC * | pDC,
 |  | CPoint | pt,
 |  | BOOL | bPinned,
 |  | COLORREF | clr = COLORREF_NULL )
 static

Call this member to draw the pin button.

Parameters
pDC | Pointer to the device context in which to draw.
pt | Center point.
bPinned | TRUE if the button is pinned.
clr | Button color. COLORREF_NULL by default. In this case, current text color is used.
Returns
Draws pin button

◆ DrawPinButton() [2/2]

static void AFX_CDECL DrawPinButton | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | BOOL | bPinned,
 |  | COLORREF | clr = COLORREF_NULL )
 static

Call this member to draw the pin button.

Parameters
pDC | Pointer to the device context in which to draw.
rc | Button rectangle.
bPinned | TRUE if the button is pinned.
clr | Button color. COLORREF_NULL by default. In this case, current text color is used.
Returns
Draws pin button

◆ GetID()

AFX_INLINE int GetID ( ) const

Call this member to retrieve the button identifier.

Returns
Button identifier. Standard values are: XTP_IDS_DOCKINGPANE_CLOSE: Close button. XTP_IDS_DOCKINGPANE_AUTOHIDE: Auto-hide button.

◆ GetPane()

AFX_INLINE CXTPDockingPaneBase * GetPane ( ) const

Call this member to retrieve the pane that the pin caption button controls.

Returns
Pane that the pin caption button controls.

◆ GetRect()

AFX_INLINE CRect GetRect ( ) const

Call this member to get the bounding rectangle.

Returns
A CRect object.

◆ GetState()

AFX_INLINE DWORD GetState ( ) const

Call this member to determine the state of the pin caption button.

This will tell you if the pin caption button is visible or if it is pushed.

Returns
1 if the the button is visible, 2 if it is pushed, or 3 if it is both visible and pushed.
See also
XTPDockingPanePinState

◆ IsEnabled()

BOOL IsEnabled ( ) const

Call this member to determine if the pin caption button is enabled.

Returns
TRUE if the pin caption button is enabled, otherwise FALSE.

◆ IsPressed()

AFX_INLINE BOOL IsPressed ( ) const

Call this member to determine if the pin caption button is pressed.

Returns
TRUE if the pin caption button is pressed, otherwise FALSE.

◆ IsSelected()

AFX_INLINE BOOL IsSelected ( ) const

Call this member to determine if the mouse is hovering over the pin caption button.

Returns
TRUE if the mouse is hovering over the pin caption button, otherwise FALSE.

◆ IsVisible()

BOOL IsVisible ( ) const

Call this member to determine if the pin caption button is visible.

Returns
TRUE if the pin caption button is visible, otherwise FALSE.

◆ PtInRect()

AFX_INLINE BOOL PtInRect ( POINT pt ) const

Call this member to determine if a specified point belongs to the button.

Parameters
pt Point to test.
Returns
TRUE if the point belongs to the button, otherwise FALSE.

◆ SetRect()

void SetRect ( CRect rc )

Call this member to set the button's rectangle.

Parameters
rc Button's rectangle.

◆ SetState()

AFX_INLINE void SetState ( DWORD dwState )

Call this member to set the state for the pin caption button.

Parameters
dwState XTPDockingPanePinState for the pin caption button.
See also
XTPDockingPanePinState
The documentation for this class was generated from the following file:
  • XTPDockingPaneCaptionButton.h


Toolkit Pro: CXTPDockingPaneCaptionButtons Class Reference

Public Member Functions | List of all members
CXTPDockingPaneCaptionButtons Class Reference

CXTPDockingPaneCaptionButtons is a CArray derived class used to manipulate Caption Buttons. More...

Public Member Functions

BOOL CheckForMouseOver (CPoint pt)
Call this member to determine if the mouse pointer is positioned over one of the buttons in the pane caption.

Detailed Description

CXTPDockingPaneCaptionButtons is a CArray derived class used to manipulate Caption Buttons.

Member Function Documentation

◆ CheckForMouseOver()

BOOL CheckForMouseOver ( CPoint pt )

Call this member to determine if the mouse pointer is positioned over one of the buttons in the pane caption.

Parameters
pt A CPoint object containing the coordinates of the mouse pointer.
Returns
TRUE if the mouse pointer is positioned over a caption button, otherwise FALSE.
The documentation for this class was generated from the following file:
  • XTPDockingPaneBase.h


Toolkit Pro: CXTPDockingPaneColorSet Class Reference

Public Member Functions | Public Attributes | Protected Attributes | List of all members
CXTPDockingPaneColorSet Class Referenceabstract

Helper class used to initialize default colors for a theme from an .INI resource. More...

Inheritance diagram for CXTPDockingPaneColorSet:
[legend]

Public Member Functions

virtual | ~CXTPDockingPaneColorSet ()
Handles object destruction.
virtual void | RefreshMetrics (CString strSection)=0
This member function is used to initialize default colors for a theme from an .INI resource.
virtual CXTPColorSetCaptionButton & | GetButtonColorSet (CXTPDockingPaneCaptionButton *pButton)
Call this member function to retrieve the state color set for the caption button specified by pButton.

Public Attributes

CXTPPaintManagerColor | m_clrBorder
Border color.
CXTPPaintManagerColor | m_clrBackground
Background color.
CXTPPaintManagerColor | m_clrCaption
Caption color.
CXTPPaintManagerColor | m_clrText
Text color.
CXTPPaintManagerColor | m_clrGripper
Gripper color.
CXTPPaintManagerColor | m_clrSplitter
Splitter color.

Protected Attributes

CXTPColorSetCaptionButton | m_csCaptionButtonHot
Selected state caption button colors.
CXTPColorSetCaptionButton | m_csCaptionButtonNormal
Normal state caption button colors.
CXTPColorSetCaptionButton | m_csCaptionButtonPressed
Pressed state caption button colors.

Detailed Description

Helper class used to initialize default colors for a theme from an .INI resource.

Member Function Documentation

◆ GetButtonColorSet()

virtual CXTPColorSetCaptionButton & GetButtonColorSet ( CXTPDockingPaneCaptionButton * pButton )
virtual

Call this member function to retrieve the state color set for the caption button specified by pButton.

Parameters
pButton Pointer to a CXTPDockingPaneCaptionButton object used to determine the correct color set to return.
Returns
A reference to a CXTPColorSetCaptionButton object representing the caption button state colors.

◆ RefreshMetrics()

virtual void RefreshMetrics ( CString strSection )
pure virtual

This member function is used to initialize default colors for a theme from an .INI resource.

Parameters
strSection Location of color settings in theme .INI file.

Implemented in CXTPDockingPaneColorSet2012, CXTPDockingPaneColorSet2013, CXTPDockingPaneColorSet2015, CXTPDockingPaneColorSet2017, CXTPDockingPaneColorSet2019, CXTPDockingPaneColorSet2022, CXTPDockingPaneColorSetNativeWindows10, and CXTPDockingPaneColorSetNativeWindows11.

The documentation for this class was generated from the following file:
  • XTPDockingPaneColorSet.h


Toolkit Pro: CXTPDockingPaneColorSet2012 Class Reference

Public Member Functions | List of all members
CXTPDockingPaneColorSet2012 Class Reference

Helper class used to initialize default colors for a theme from an .INI resource. More...

Inheritance diagram for CXTPDockingPaneColorSet2012:
[legend]

Public Member Functions

virtual void | RefreshMetrics (CString strSection)
This member function is used to initialize default colors for a theme from an .INI resource.
- Public Member Functions inherited from CXTPDockingPaneColorSet
virtual | ~CXTPDockingPaneColorSet ()
Handles object destruction.
virtual CXTPColorSetCaptionButton & | GetButtonColorSet (CXTPDockingPaneCaptionButton *pButton)
Call this member function to retrieve the state color set for the caption button specified by pButton.

Additional Inherited Members

- Public Attributes inherited from CXTPDockingPaneColorSet
CXTPPaintManagerColor | m_clrBorder
Border color.
CXTPPaintManagerColor | m_clrBackground
Background color.
CXTPPaintManagerColor | m_clrCaption
Caption color.
CXTPPaintManagerColor | m_clrText
Text color.
CXTPPaintManagerColor | m_clrGripper
Gripper color.
CXTPPaintManagerColor | m_clrSplitter
Splitter color.
- Protected Attributes inherited from CXTPDockingPaneColorSet
CXTPColorSetCaptionButton | m_csCaptionButtonHot
Selected state caption button colors.
CXTPColorSetCaptionButton | m_csCaptionButtonNormal
Normal state caption button colors.
CXTPColorSetCaptionButton | m_csCaptionButtonPressed
Pressed state caption button colors.

Detailed Description

Helper class used to initialize default colors for a theme from an .INI resource.

Member Function Documentation

◆ RefreshMetrics()

virtual void RefreshMetrics ( CString strSection )
virtual

This member function is used to initialize default colors for a theme from an .INI resource.

Parameters
strSection Location of color settings in theme .INI file.

Implements CXTPDockingPaneColorSet.

The documentation for this class was generated from the following file:
  • XTPDockingPaneColorSet2012.h


Toolkit Pro: CXTPDockingPaneColorSet2013 Class Reference

Public Member Functions | List of all members
CXTPDockingPaneColorSet2013 Class Reference

Helper class used to initialize default colors for a theme from an .INI resource. More...

Inheritance diagram for CXTPDockingPaneColorSet2013:
[legend]

Public Member Functions

virtual void | RefreshMetrics (CString strSection)
This member function is used to initialize default colors for a theme from an .INI resource.
- Public Member Functions inherited from CXTPDockingPaneColorSet
virtual | ~CXTPDockingPaneColorSet ()
Handles object destruction.
virtual CXTPColorSetCaptionButton & | GetButtonColorSet (CXTPDockingPaneCaptionButton *pButton)
Call this member function to retrieve the state color set for the caption button specified by pButton.

Additional Inherited Members

- Public Attributes inherited from CXTPDockingPaneColorSet
CXTPPaintManagerColor | m_clrBorder
Border color.
CXTPPaintManagerColor | m_clrBackground
Background color.
CXTPPaintManagerColor | m_clrCaption
Caption color.
CXTPPaintManagerColor | m_clrText
Text color.
CXTPPaintManagerColor | m_clrGripper
Gripper color.
CXTPPaintManagerColor | m_clrSplitter
Splitter color.
- Protected Attributes inherited from CXTPDockingPaneColorSet
CXTPColorSetCaptionButton | m_csCaptionButtonHot
Selected state caption button colors.
CXTPColorSetCaptionButton | m_csCaptionButtonNormal
Normal state caption button colors.
CXTPColorSetCaptionButton | m_csCaptionButtonPressed
Pressed state caption button colors.

Detailed Description

Helper class used to initialize default colors for a theme from an .INI resource.

Member Function Documentation

◆ RefreshMetrics()

virtual void RefreshMetrics ( CString strSection )
virtual

This member function is used to initialize default colors for a theme from an .INI resource.

Parameters
strSection Location of color settings in theme .INI file.

Implements CXTPDockingPaneColorSet.

The documentation for this class was generated from the following file:
  • XTPDockingPaneColorSet2013.h


Toolkit Pro: CXTPDockingPaneColorSet2015 Class Reference

Public Member Functions | List of all members
CXTPDockingPaneColorSet2015 Class Reference

Helper class used to initialize default colors for a theme from an .INI resource. More...

Inheritance diagram for CXTPDockingPaneColorSet2015:
[legend]

Public Member Functions

virtual void | RefreshMetrics (CString strSection)
This member function is used to initialize default colors for a theme from an .INI resource.
- Public Member Functions inherited from CXTPDockingPaneColorSet
virtual | ~CXTPDockingPaneColorSet ()
Handles object destruction.
virtual CXTPColorSetCaptionButton & | GetButtonColorSet (CXTPDockingPaneCaptionButton *pButton)
Call this member function to retrieve the state color set for the caption button specified by pButton.

Additional Inherited Members

- Public Attributes inherited from CXTPDockingPaneColorSet
CXTPPaintManagerColor | m_clrBorder
Border color.
CXTPPaintManagerColor | m_clrBackground
Background color.
CXTPPaintManagerColor | m_clrCaption
Caption color.
CXTPPaintManagerColor | m_clrText
Text color.
CXTPPaintManagerColor | m_clrGripper
Gripper color.
CXTPPaintManagerColor | m_clrSplitter
Splitter color.
- Protected Attributes inherited from CXTPDockingPaneColorSet
CXTPColorSetCaptionButton | m_csCaptionButtonHot
Selected state caption button colors.
CXTPColorSetCaptionButton | m_csCaptionButtonNormal
Normal state caption button colors.
CXTPColorSetCaptionButton | m_csCaptionButtonPressed
Pressed state caption button colors.

Detailed Description

Helper class used to initialize default colors for a theme from an .INI resource.

Member Function Documentation

◆ RefreshMetrics()

virtual void RefreshMetrics ( CString strSection )
virtual

This member function is used to initialize default colors for a theme from an .INI resource.

Parameters
strSection Location of color settings in theme .INI file.

Implements CXTPDockingPaneColorSet.

The documentation for this class was generated from the following file:
  • XTPDockingPaneColorSet2015.h


Toolkit Pro: CXTPDockingPaneColorSet2017 Class Reference

Public Member Functions | List of all members
CXTPDockingPaneColorSet2017 Class Reference

Helper class used to initialize default colors for a theme from an .INI resource. More...

Inheritance diagram for CXTPDockingPaneColorSet2017:
[legend]

Public Member Functions

virtual void | RefreshMetrics (CString strSection)
This member function is used to initialize default colors for a theme from an .INI resource.
- Public Member Functions inherited from CXTPDockingPaneColorSet
virtual | ~CXTPDockingPaneColorSet ()
Handles object destruction.
virtual CXTPColorSetCaptionButton & | GetButtonColorSet (CXTPDockingPaneCaptionButton *pButton)
Call this member function to retrieve the state color set for the caption button specified by pButton.

Additional Inherited Members

- Public Attributes inherited from CXTPDockingPaneColorSet
CXTPPaintManagerColor | m_clrBorder
Border color.
CXTPPaintManagerColor | m_clrBackground
Background color.
CXTPPaintManagerColor | m_clrCaption
Caption color.
CXTPPaintManagerColor | m_clrText
Text color.
CXTPPaintManagerColor | m_clrGripper
Gripper color.
CXTPPaintManagerColor | m_clrSplitter
Splitter color.
- Protected Attributes inherited from CXTPDockingPaneColorSet
CXTPColorSetCaptionButton | m_csCaptionButtonHot
Selected state caption button colors.
CXTPColorSetCaptionButton | m_csCaptionButtonNormal
Normal state caption button colors.
CXTPColorSetCaptionButton | m_csCaptionButtonPressed
Pressed state caption button colors.

Detailed Description

Helper class used to initialize default colors for a theme from an .INI resource.

Member Function Documentation

◆ RefreshMetrics()

virtual void RefreshMetrics ( CString strSection )
virtual

This member function is used to initialize default colors for a theme from an .INI resource.

Parameters
strSection Location of color settings in theme .INI file.

Implements CXTPDockingPaneColorSet.

The documentation for this class was generated from the following file:
  • XTPDockingPaneColorSet2017.h


Toolkit Pro: CXTPDockingPaneColorSet2019 Class Reference

Public Member Functions | List of all members
CXTPDockingPaneColorSet2019 Class Reference

Helper class used to initialize default colors for a theme from an .INI resource. More...

Inheritance diagram for CXTPDockingPaneColorSet2019:
[legend]

Public Member Functions

virtual void | RefreshMetrics (CString strSection)
This member function is used to initialize default colors for a theme from an .INI resource.
- Public Member Functions inherited from CXTPDockingPaneColorSet
virtual | ~CXTPDockingPaneColorSet ()
Handles object destruction.
virtual CXTPColorSetCaptionButton & | GetButtonColorSet (CXTPDockingPaneCaptionButton *pButton)
Call this member function to retrieve the state color set for the caption button specified by pButton.

Additional Inherited Members

- Public Attributes inherited from CXTPDockingPaneColorSet
CXTPPaintManagerColor | m_clrBorder
Border color.
CXTPPaintManagerColor | m_clrBackground
Background color.
CXTPPaintManagerColor | m_clrCaption
Caption color.
CXTPPaintManagerColor | m_clrText
Text color.
CXTPPaintManagerColor | m_clrGripper
Gripper color.
CXTPPaintManagerColor | m_clrSplitter
Splitter color.
- Protected Attributes inherited from CXTPDockingPaneColorSet
CXTPColorSetCaptionButton | m_csCaptionButtonHot
Selected state caption button colors.
CXTPColorSetCaptionButton | m_csCaptionButtonNormal
Normal state caption button colors.
CXTPColorSetCaptionButton | m_csCaptionButtonPressed
Pressed state caption button colors.

Detailed Description

Helper class used to initialize default colors for a theme from an .INI resource.

Member Function Documentation

◆ RefreshMetrics()

virtual void RefreshMetrics ( CString strSection )
virtual

This member function is used to initialize default colors for a theme from an .INI resource.

Parameters
strSection Location of color settings in theme .INI file.

Implements CXTPDockingPaneColorSet.

The documentation for this class was generated from the following file:
  • XTPDockingPaneColorSet2019.h


Toolkit Pro: CXTPDockingPaneColorSet2022 Class Reference

Public Member Functions | List of all members
CXTPDockingPaneColorSet2022 Class Reference

Helper class used to initialize default colors for a theme from an .INI resource. More...

Inheritance diagram for CXTPDockingPaneColorSet2022:
[legend]

Public Member Functions

virtual void | RefreshMetrics (CString strSection)
This member function is used to initialize default colors for a theme from an .INI resource.
- Public Member Functions inherited from CXTPDockingPaneColorSet
virtual | ~CXTPDockingPaneColorSet ()
Handles object destruction.
virtual CXTPColorSetCaptionButton & | GetButtonColorSet (CXTPDockingPaneCaptionButton *pButton)
Call this member function to retrieve the state color set for the caption button specified by pButton.

Additional Inherited Members

- Public Attributes inherited from CXTPDockingPaneColorSet
CXTPPaintManagerColor | m_clrBorder
Border color.
CXTPPaintManagerColor | m_clrBackground
Background color.
CXTPPaintManagerColor | m_clrCaption
Caption color.
CXTPPaintManagerColor | m_clrText
Text color.
CXTPPaintManagerColor | m_clrGripper
Gripper color.
CXTPPaintManagerColor | m_clrSplitter
Splitter color.
- Protected Attributes inherited from CXTPDockingPaneColorSet
CXTPColorSetCaptionButton | m_csCaptionButtonHot
Selected state caption button colors.
CXTPColorSetCaptionButton | m_csCaptionButtonNormal
Normal state caption button colors.
CXTPColorSetCaptionButton | m_csCaptionButtonPressed
Pressed state caption button colors.

Detailed Description

Helper class used to initialize default colors for a theme from an .INI resource.

Member Function Documentation

◆ RefreshMetrics()

virtual void RefreshMetrics ( CString strSection )
virtual

This member function is used to initialize default colors for a theme from an .INI resource.

Parameters
strSection Location of color settings in theme .INI file.

Implements CXTPDockingPaneColorSet.

The documentation for this class was generated from the following file:
  • XTPDockingPaneColorSet2022.h


Toolkit Pro: CXTPDockingPaneColorSetNativeWindows10 Class Reference

Public Member Functions | List of all members
CXTPDockingPaneColorSetNativeWindows10 Class Reference

Helper class used to initialize default colors for a theme from an .INI resource. More...

Inheritance diagram for CXTPDockingPaneColorSetNativeWindows10:
[legend]

Public Member Functions

virtual void | RefreshMetrics (CString strSection)
This member function is used to initialize default colors for a theme from an .INI resource.
- Public Member Functions inherited from CXTPDockingPaneColorSet
virtual | ~CXTPDockingPaneColorSet ()
Handles object destruction.
virtual CXTPColorSetCaptionButton & | GetButtonColorSet (CXTPDockingPaneCaptionButton *pButton)
Call this member function to retrieve the state color set for the caption button specified by pButton.

Additional Inherited Members

- Public Attributes inherited from CXTPDockingPaneColorSet
CXTPPaintManagerColor | m_clrBorder
Border color.
CXTPPaintManagerColor | m_clrBackground
Background color.
CXTPPaintManagerColor | m_clrCaption
Caption color.
CXTPPaintManagerColor | m_clrText
Text color.
CXTPPaintManagerColor | m_clrGripper
Gripper color.
CXTPPaintManagerColor | m_clrSplitter
Splitter color.
- Protected Attributes inherited from CXTPDockingPaneColorSet
CXTPColorSetCaptionButton | m_csCaptionButtonHot
Selected state caption button colors.
CXTPColorSetCaptionButton | m_csCaptionButtonNormal
Normal state caption button colors.
CXTPColorSetCaptionButton | m_csCaptionButtonPressed
Pressed state caption button colors.

Detailed Description

Helper class used to initialize default colors for a theme from an .INI resource.

Member Function Documentation

◆ RefreshMetrics()

virtual void RefreshMetrics ( CString strSection )
virtual

This member function is used to initialize default colors for a theme from an .INI resource.

Parameters
strSection Location of color settings in theme .INI file.

Implements CXTPDockingPaneColorSet.

The documentation for this class was generated from the following file:
  • XTPDockingPaneColorSetNativeWindows10.h


Toolkit Pro: CXTPDockingPaneColorSetNativeWindows11 Class Reference

Public Member Functions | List of all members
CXTPDockingPaneColorSetNativeWindows11 Class Reference

Helper class used to initialize default colors for a theme from an .INI resource. More...

Inheritance diagram for CXTPDockingPaneColorSetNativeWindows11:
[legend]

Public Member Functions

virtual void | RefreshMetrics (CString strSection)
This member function is used to initialize default colors for a theme from an .INI resource.
- Public Member Functions inherited from CXTPDockingPaneColorSet
virtual | ~CXTPDockingPaneColorSet ()
Handles object destruction.
virtual CXTPColorSetCaptionButton & | GetButtonColorSet (CXTPDockingPaneCaptionButton *pButton)
Call this member function to retrieve the state color set for the caption button specified by pButton.

Additional Inherited Members

- Public Attributes inherited from CXTPDockingPaneColorSet
CXTPPaintManagerColor | m_clrBorder
Border color.
CXTPPaintManagerColor | m_clrBackground
Background color.
CXTPPaintManagerColor | m_clrCaption
Caption color.
CXTPPaintManagerColor | m_clrText
Text color.
CXTPPaintManagerColor | m_clrGripper
Gripper color.
CXTPPaintManagerColor | m_clrSplitter
Splitter color.
- Protected Attributes inherited from CXTPDockingPaneColorSet
CXTPColorSetCaptionButton | m_csCaptionButtonHot
Selected state caption button colors.
CXTPColorSetCaptionButton | m_csCaptionButtonNormal
Normal state caption button colors.
CXTPColorSetCaptionButton | m_csCaptionButtonPressed
Pressed state caption button colors.

Detailed Description

Helper class used to initialize default colors for a theme from an .INI resource.

Member Function Documentation

◆ RefreshMetrics()

virtual void RefreshMetrics ( CString strSection )
virtual

This member function is used to initialize default colors for a theme from an .INI resource.

Parameters
strSection Location of color settings in theme .INI file.

Implements CXTPDockingPaneColorSet.

The documentation for this class was generated from the following file:
  • XTPDockingPaneColorSetNativeWindows11.h


Toolkit Pro: CXTPDockingPaneContext Class Reference

Public Member Functions | Protected Member Functions | Static Protected Member Functions | Protected Attributes | List of all members
CXTPDockingPaneContext Class Reference

CXTPDockingPaneContext is a standalone class. More...

Public Member Functions

CXTPDockingPaneContext ()
Constructs a CXTPDockingPaneContext object.
virtual | ~CXTPDockingPaneContext ()
Destroys a CXTPDockingPaneContext object, handles cleanup and deallocation.
virtual void | Drag (CXTPDockingPaneBase *pPane, CPoint point)
Call this member to drag a pane.
void | Drag (CXTPDockingPaneBase *pPane, CPoint point, CRect rcPane)
Call this member to drag a pane.
virtual void | OnSizingFloatingFrame (CXTPDockingPaneMiniWnd *pWnd, UINT nSide, LPRECT lpRect)
This method is called inside the WM_SIZING handler of a mini-frame to update the sticky position of the frame.

Protected Member Functions

virtual void | Track ()
This method is called to track the size of the pane.
virtual void | Move (CPoint pt)
This method is called when the user moves the mouse cursor in track mode.
virtual void | InitLoop ()
Call this member function to initialize a loop.
virtual void | CancelLoop ()
This member function is called when a loop is canceled.
virtual void | DrawFocusRect (BOOL bRemoveRect=FALSE)
This member function is called to draw the focus rectangle.
void | CreateContextWindow (CXTPDockingPaneContextAlphaWnd *pWnd)
Call this member function to create a context menu.
void | UpdateDockingStickers ()
Call this member function to refresh the docking stickers.
void | DestroyDockingStickers ()
Call this member to remove the docking stickers.
CXTPDockingPaneContextStickerWnd * | CreateNewSticker (CRect rc, XTPDockingPaneStickerType typeSticker)
Creates a new sticker window.

Static Protected Member Functions

static void AFX_CDECL | AdjustRectangle (CRect &rect, CPoint pt)
Call this member to adjust the rectangle.
static void AFX_CDECL | AdjustCursor (CPoint &pt)
Moves the cursor to the available work area.

Protected Attributes

CXTPDockingPaneContextAlphaWnd | m_wndContext
Alpha context control.
CXTPDockingPaneContextAlphaWnd | m_wndAttachedTab
Attached tab control.
PVOID | m_pfnSetLayeredWindowAttributes
Pointer to SetLayeredWindowAttributes method.
BOOL | m_bUseDockingStickers
TRUE to use docking stickers.
BOOL | m_bUseAlphaContext
TRUE to use alpha context.
CRect | m_rectStickerPane
Area occupied by the sticker pane.
CXTPDockingPaneBase * | m_pStickerPane
Sticker Pane.
CXTPDockingPaneBase * | m_pLastStickerPane
Last Sticker Pane.
CList< CXTPDockingPaneContextStickerWnd *, CXTPDockingPaneContextStickerWnd * > | m_lstStickers
List of the stickers.
CPoint | m_ptLast
Holds the last selection point.
CPoint | m_ptSticky
Position of the sticky control.
CRect | m_rectDragFrame
Area occupied by the drag frame.
CRect | m_rectDragFrameScreen
Screen drag frame.
CXTPDockingPaneManager * | m_pManager
Parent pane manager.
CXTPDockingPaneBase * | m_pPane
Pointer to the associated pane.
BOOL | m_bDragKeyboard
TRUE if the keyboard was used to drag the pane.

Detailed Description

CXTPDockingPaneContext is a standalone class.

It is used internally for docking and sizing panes.

Member Function Documentation

◆ AdjustCursor()

static void AFX_CDECL AdjustCursor ( CPoint & pt )
staticprotected

Moves the cursor to the available work area.

Parameters
pt Pointer to the mouse cursor.
Returns

◆ AdjustRectangle()

static void AFX_CDECL AdjustRectangle | ( | CRect & | rect,
 |  | CPoint | pt )
 staticprotected

Call this member to adjust the rectangle.

Parameters
rect | Rectangle to be changed.
pt | Position of the rectangle to be changed.
Returns

◆ CreateContextWindow()

void CreateContextWindow ( CXTPDockingPaneContextAlphaWnd * pWnd )
protected

Call this member function to create a context menu.

Parameters
pWnd A pointer to a CXTPDockingPaneContextAlphaWnd object.

◆ CreateNewSticker()

CXTPDockingPaneContextStickerWnd * CreateNewSticker | ( | CRect | rc,
 |  | XTPDockingPaneStickerType | typeSticker )
 protected

Creates a new sticker window.

Parameters
rc | Boundary rectangle of the sticker.
typeSticker | Type of sticker to create.
Returns
New Sticker window.

◆ Drag() [1/2]

virtual void Drag | ( | CXTPDockingPaneBase * | pPane,
 |  | CPoint | point )
 virtual

Call this member to drag a pane.

Parameters
pPane | Pointer to a CXTPDockingPaneBase object.
point | Initial mouse position.

◆ Drag() [2/2]

void Drag | ( | CXTPDockingPaneBase * | pPane,
 |  | CPoint | point,
 |  | CRect | rcPane )

Call this member to drag a pane.

Parameters
pPane | Pointer to a CXTPDockingPaneBase object.
point | Initial mouse position.
rcPane | Size of the pane.

◆ DrawFocusRect()

virtual void DrawFocusRect ( BOOL bRemoveRect = FALSE )
protectedvirtual

This member function is called to draw the focus rectangle.

Parameters
bRemoveRect TRUE to delete the focus rectangle.

◆ Move()

virtual void Move ( CPoint pt )
protectedvirtual

This method is called when the user moves the mouse cursor in track mode.

Parameters
pt New mouse cursor position.

◆ OnSizingFloatingFrame()

virtual void OnSizingFloatingFrame | ( | CXTPDockingPaneMiniWnd * | pWnd,
 |  | UINT | nSide,
 |  | LPRECT | lpRect )
 virtual

This method is called inside the WM_SIZING handler of a mini-frame to update the sticky position of the frame.

Parameters
pWnd | Mini-frame pointer.
nSide | Side that was dragged by the user.
lpRect | Rectangle of the frame.
The documentation for this class was generated from the following file:
  • XTPDockingPaneContext.h


Toolkit Pro: CXTPDockingPaneContextAlphaWnd Class Reference

Public Member Functions | List of all members
CXTPDockingPaneContextAlphaWnd Class Reference

CXTPDockingPaneContextAlphaWnd is a CWnd derived class that represents an alpha context helper window. More...

Public Member Functions

CXTPDockingPaneContextAlphaWnd ()
Constructs a CXTPDockingPaneContextAlphaWnd object.
virtual ~CXTPDockingPaneContextAlphaWnd ()
Destroys a CXTPDockingPaneContextAlphaWnd object, handles cleanup and deallocation.

Detailed Description

CXTPDockingPaneContextAlphaWnd is a CWnd derived class that represents an alpha context helper window.

The documentation for this class was generated from the following file:
  • XTPDockingPaneContext.h


Toolkit Pro: CXTPDockingPaneContextStickerWnd Class Reference

Public Member Functions | Public Attributes | List of all members
CXTPDockingPaneContextStickerWnd Class Reference

CXTPDockingPaneContextStickerWnd is a CWnd derived class that represents a sticker window. More...

Public Member Functions

CXTPDockingPaneContextStickerWnd (CXTPDockingPaneContext *pContext)
Constructs a CXTPDockingPaneContextStickerWnd object.
virtual | ~CXTPDockingPaneContextStickerWnd ()
Destroys a CXTPDockingPaneContextStickerWnd object, handles cleanup and deallocation.
void | OnDraw (CDC *pDC)
This method is called to draw the sticker.

Public Attributes

XTPDockingPaneStickerType | m_typeSticker
Type of the sticker.
XTPDockingPaneStickerType | m_selectedSticker
Selected sticker part.
CXTPDockingPaneContext * | m_pContext
Pointer to a docking pane context.

Detailed Description

CXTPDockingPaneContextStickerWnd is a CWnd derived class that represents a sticker window.

Constructor & Destructor Documentation

◆ CXTPDockingPaneContextStickerWnd()

CXTPDockingPaneContextStickerWnd ( CXTPDockingPaneContext * pContext )

Constructs a CXTPDockingPaneContextStickerWnd object.

Parameters
pContext Parent context object.

Member Function Documentation

◆ OnDraw()

void OnDraw ( CDC * pDC )

This method is called to draw the sticker.

Parameters
pDC Device context pointer.
The documentation for this class was generated from the following file:
  • XTPDockingPaneContext.h


Toolkit Pro: CXTPDockingPaneDefaultTheme Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPDockingPaneDefaultTheme Class Reference

CXTPDockingPaneDefaultTheme is a CXTPDockingPanePaintManager derived class that represents a classic theme for docking panes. More...

Inheritance diagram for CXTPDockingPaneDefaultTheme:
[legend]

Public Member Functions

CXTPDockingPaneDefaultTheme ()
Constructs a CXTPDockingPaneDefaultTheme object.
void | DrawFloatingFrame (CDC *pDC, CXTPDockingPaneMiniWnd *pPane, CRect rc)
Call this method to draw the frame of a floating window.
virtual void | DrawCaption (CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc)
Override this member function to draw a caption.
virtual void | DrawSidePanel (CDC *pDC, CXTPDockingPaneSidePanel *pPane, CRect rc)
Override this member function to draw the side panel.
virtual void | RefreshMetrics ()
This method is called to refresh the visual metrics of the pane.
- Public Member Functions inherited from CXTPDockingPanePaintManager
virtual void | DrawPane (CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc)
Override this member function to draw a tabbed container.
virtual CRect | GetPaneCaptionRect (const CXTPDockingPaneSidePanel *pPane)
Call this method to get the pane's caption rectangle.
virtual void | DrawSplitter (CDC *pDC, CXTPDockingPaneSplitterWnd *pSplitter)
Override this method to draw a splitter.
virtual void | DrawCaptionButtons (CDC *pDC, CXTPDockingPaneCaptionButtons *pButtons, CRect &rcCaption, COLORREF clr, int nButtonSize, int nButtonGap, BOOL bVertical=FALSE)
Override this member function to draw buttons for a tabbed caption.
virtual void | DrawCaptionButton (CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton)
Override this member function to draw a button for a tabbed caption.
virtual void | AdjustClientRect (CXTPDockingPaneSidePanel *pPane, CRect &rect)
Override this member to change the client rectangle of the child docking pane.
virtual void | AdjustClientRect (CXTPDockingPaneTabbedContainer *pPane, CRect &rect, BOOL bApply)
Override this member to change the client rectangle of the child docking pane.
virtual void | AdjustCaptionRect (const CXTPDockingPaneSidePanel *pPane, CRect &rc)
Override this member to change the caption rectangle of the child docking pane.
virtual void | AdjustCaptionRect (const CXTPDockingPaneTabbedContainer *pPane, CRect &rc)
Override this member to change the caption rectangle of the child docking pane.
virtual void | GetCaptionRect (const CXTPDockingPaneTabbedContainer *pPane, CRect &rc)
Call this method to get a caption rectangle.
virtual CRect | GetCaptionGripperRect (const CXTPDockingPaneTabbedContainer *pPane)
Call this method to get a caption gripper for a tabbed container.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1, int nPen)
Draws a line.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1)
Draws a line.
int | DrawCaptionText (CDC *pDC, const CString &strTitle, CRect rc, BOOL bVertical, BOOL bCalcWidth=FALSE)
Draws the text of a pane caption.
void | Pixel (CDC *pDC, int xPos, int yPos, int nPen)
Sets the pixel at the point.
void | Rectangle (CDC *pDC, CRect rc, int nPenEntry, int nPenBorder)
Draws a rectangle.
void | UseOfficeFont (BOOL bUseOfficeFont)
Call this member to use Office (Tahoma) font.
void | SetCaptionFontIndirect (LOGFONT *pLogFont, BOOL bUseStandardFont=FALSE)
Call this method to set the caption's font.
CXTPTabPaintManager * | SetTabPaintManager (CXTPTabPaintManager *pManager)
Call this method to set the paint manager used to draw tabs of a tabbed container.
CXTPTabPaintManager * | SetPanelPaintManager (CXTPTabPaintManager *pManager)
Call this method to set the paint manager used to draw tabs of an auto-hide panel.
CXTPTabPaintManager * | GetTabPaintManager () const
Retrieves the paint manager used to draw tabs of a tabbed container.
CXTPTabPaintManager * | GetPanelPaintManager () const
Retrieves the paint manager used to draw tabs of an auto-hide panel.
COLORREF | GetXtremeColor (UINT nIndex)
Retrieves the current color of the specified XP display element.
void | SetColors (int cElements, CONST INT *lpaElements, CONST COLORREF *lpaRgbValues)
Call this member to set the colors for each element in an array to the colors in a specified color array.
int | GetCaptionHeight () const
Call this member to get the caption height of the tabbed container.
int | GetTabsHeight () const
Call this member to get tabs height of the tabbed container.
void | SetSplitterStyle (DWORD dwStyle)
Call this member to set the splitter style.
DWORD | GetSplitterStyle () const
Call this method to get the splitter style.
void | SetCaptionButtonStyle (XTPDockingPaneCaptionButtonStyle nStyle)
Call this member to set the caption button style.
XTPDockingPaneCaptionButtonStyle | GetCaptionButtonStyle () const
Call this method to get the caption button style.
XTPCurrentSystemTheme | GetCurrentSystemTheme () const
Call this member function to determine the current Windows XP theme in use.
void | SetLunaTheme (XTPCurrentSystemTheme systemTheme)
Call this method to force system theme.
virtual void | DrawAutoHidePanel (CDC *pDC, CRect rc, XTPDockingPaneDirection direction)
This mmethod is called by the framework to draw the docking pane auto-hide panel background and splitter.
void | SetCustomTitleBrushes (HBRUSH hbrActiveTitleHorz, HBRUSH hbrInactiveTitleHorz=NULL, HBRUSH hbrActiveTitleVert=NULL, HBRUSH hbrInactiveTitleVert=NULL, BOOL bDestroyOnCleanup=FALSE)
Sets custom title brushes.
HBRUSH | GetCustomTitleBrush (BOOL bActive, BOOL bVertical) const
Obtains the custom title brush.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

virtual void | DrawCaptionPart (CDC *pDC, CXTPDockingPaneBase *pPane, CRect rcCaption, const CString &strTitle, BOOL bActive, BOOL bVertical)
Draws the common part of a tabbed and floating caption.
- Protected Member Functions inherited from CXTPDockingPanePaintManager
CXTPDockingPanePaintManager ()
Constructs a CXTPDockingPanePaintManager object.
virtual | ~CXTPDockingPanePaintManager ()
Destroys a CXTPDockingPanePaintManager object, handles cleanup and deallocation.
virtual void | DrawCaptionButtonEntry (CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton, CSize szOffset)
Draws only the glyph of a button.
virtual void | DrawCaptionButtonEntry (CDC *pDC, CXTPDockingPaneCaptionButton *pButton, CPoint pt, COLORREF clrButton)
Draws only the glyph of a button.
void | ClipAndAddEllipsisIfNeeded (CDC *pDC, CString &strTitle, int nCaptionWidth) const
Clip string and add ellipsis if its width less than nCaptionWidth.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPDockingPanePaintManager
BOOL | m_bUseBoldCaptionFont
TRUE to use bold font for caption.
BOOL | m_bHighlightActiveCaption
TRUE to highlight active caption.
int | m_nSplitterSize
Splitter size.
BOOL | m_bShowCaption
TRUE to draw captions of tabbed containers.
BOOL | m_bDrawSingleTab
TRUE to draw single tab.
BOOL | m_bDrawCaptionIcon
TRUE to draw caption icon.
int | m_nSplitterIndent
Size of splitter indent.
CXTPPaintManagerColor | m_clrBackground
Background color.
CXTPPaintManagerColor | m_clrSplitterGripper
Splitter gripper color.
CXTPPaintManagerColor | m_clrSplitter
Splitter color.
CXTPPaintManagerColorGradient | m_clrSplitterGradient
Splitter gradient color.
CXTPPaintManagerColorGradient | m_clrNormalCaption
Color of pane caption when inactive.
CXTPPaintManagerColorGradient | m_clrActiveCaption
Color of pane caption when active.
CXTPPaintManagerColor | m_clrNormalCaptionText
Color of pane caption text when the caption is inactive.
CXTPPaintManagerColor | m_clrActiveCaptionText
Active caption text.
CXTPPaintManagerColor | m_clrDisabledCaptionText
Disabled caption text.
- Protected Attributes inherited from CXTPDockingPanePaintManager
XTPDockingPaneCaptionButtonStyle | m_nCaptionButtonStyle
Caption button style.
DWORD | m_dwSplitterStyle
Splitter style.
int | m_nTitleHeight
Title's height.
int | m_nCaptionFontGap
Additional gap of font.
int | m_nTabsHeight
Tab bar's height.
CXTPFont | m_xtpFontTitle
Title font.
CXTPFont | m_xtpFontTitleVertical
Title vertical font.
BOOL | m_bUseOfficeFont
TRUE to use Tahoma font.
BOOL | m_bUseStandardFont
TRUE to use system icon font.
BOOL | m_bDestroyCustomTitleBrushes
If TRUE, custom title bushes will be destroyed on cleanup.
HBRUSH | m_hbrActiveTitleHorz
Optional user specified active horizontal title brush.
HBRUSH | m_hbrInactiveTitleHorz
Optional user specified inactive horizontal title brush.
HBRUSH | m_hbrActiveTitleVert
Optional user specified active vertical title brush.
HBRUSH | m_hbrInactiveTitleVert
Optional user specified inactive vertical title brush.
CXTPTabPaintManager * | m_pTabPaintManager
Paint Manager used to draw tabs for a tabbed container.
CXTPTabPaintManager * | m_pPanelPaintManager
Paint Manager used to draw tabs for an auto-hide panel.
COLORREF | m_arrColor [XPCOLOR_LAST+1]
Self colors array.
XTPDockingPanePaintTheme | m_themeCurrent
Current theme.
CString | m_strOfficeFont
Office font name.
CRect | m_rcCaptionMargin
Margins of caption.
XTPCurrentSystemTheme | m_systemTheme
Current system theme.
CXTPWinThemeWrapper * | m_themeToolbar
Toolbar theme helper.
CXTPWinThemeWrapper * | m_themeExplorer
WinXP Explorer theme helper.
CXTPWinThemeWrapper * | m_themeButton
WinXP Button theme helper.
CXTPWinThemeWrapper * | m_themeWindow
WinXP Window Theme helper.
CXTPWinThemeWrapper * | m_themeRebar
Rebar theme helper.
BOOL | m_bLunaTheme
TRUE if luna colors are used.

Detailed Description

CXTPDockingPaneDefaultTheme is a CXTPDockingPanePaintManager derived class that represents a classic theme for docking panes.

Call CXTPDockingPaneManager::SetTheme(xtpPaneThemeDefault); to set this theme.

Member Function Documentation

◆ DrawCaption()

virtual void DrawCaption | ( | CDC * | pDC,
 |  | CXTPDockingPaneTabbedContainer * | pPane,
 |  | CRect | rc )
 virtual

Override this member function to draw a caption.

Parameters
pDC | Reference to the device context in which to draw.
pPane | Pointer to the tabbed container.
rc | Client rectangle of the tabbed container.

Implements CXTPDockingPanePaintManager.

Reimplemented in CXTPDockingPaneGripperedTheme, CXTPDockingPaneOffice2002VisioTheme, CXTPDockingPaneOffice2003Theme, CXTPDockingPaneOffice2007OutlookTheme, CXTPDockingPaneOffice2007Theme, CXTPDockingPaneOffice2007WordTheme, CXTPDockingPaneOffice2013Theme, CXTPDockingPaneVisualStudio2012Theme, and CXTPDockingPaneWinNativeTheme.

◆ DrawCaptionPart()

virtual void DrawCaptionPart | ( | CDC * | pDC,
 |  | CXTPDockingPaneBase * | pPane,
 |  | CRect | rcCaption,
 |  | const CString & | strTitle,
 |  | BOOL | bActive,
 |  | BOOL | bVertical )
 protectedvirtual

Draws the common part of a tabbed and floating caption.

Parameters
pDC | Reference to the device context in which to draw.
pPane | Container which the caption needs to draw.
rcCaption | Caption bounding rectangle.
strTitle | Caption text.
bActive | TRUE if the caption is active.
bVertical | TRUE to draw the caption vertically.

Reimplemented in CXTPDockingPaneGripperedTheme, CXTPDockingPaneOffice2003Theme, CXTPDockingPaneOffice2007WordTheme, CXTPDockingPaneVisualStudio2003Theme, CXTPDockingPaneVisualStudio6Theme, CXTPDockingPaneWinExplorerTheme, and CXTPDockingPaneWinNativeTheme.

◆ DrawFloatingFrame()

void DrawFloatingFrame | ( | CDC * | pDC,
 |  | CXTPDockingPaneMiniWnd * | pPane,
 |  | CRect | rc )
 virtual

Call this method to draw the frame of a floating window.

Parameters
pDC | Pointer to a valid device context.
pPane | Floating window pointer.
rc | Client rectangle of the floating frame.

Reimplemented from CXTPDockingPanePaintManager.

Reimplemented in CXTPDockingPaneGripperedTheme, CXTPDockingPaneOffice2002VisioTheme, CXTPDockingPaneOffice2003Theme, CXTPDockingPaneOffice2013Theme, CXTPDockingPaneVisualStudio2010Theme, CXTPDockingPaneVisualStudio2012Theme, and CXTPDockingPaneWinNativeTheme.

◆ DrawSidePanel()

virtual void DrawSidePanel | ( | CDC * | pDC,
 |  | CXTPDockingPaneSidePanel * | pPane,
 |  | CRect | rc )
 virtual

Override this member function to draw the side panel.

Parameters
pDC | Reference to the device context in which to draw.
pPane | Pointer to the side panel.
rc | Client rectangle of the side panel.

Reimplemented from CXTPDockingPanePaintManager.

Reimplemented in CXTPDockingPaneOffice2003Theme, CXTPDockingPaneOffice2013Theme, CXTPDockingPaneVisualStudio2012Theme, and CXTPDockingPaneWinNativeTheme.

The documentation for this class was generated from the following file:
  • XTPDockingPaneThemeDefault.h


Toolkit Pro: CXTPDockingPaneGripperedTheme Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPDockingPaneGripperedTheme Class Reference

CXTPDockingPaneGripperedTheme is a CXTPDockingPaneDefaultTheme derived class that represents a gripper theme for docking panes. More...

Inheritance diagram for CXTPDockingPaneGripperedTheme:
[legend]

Public Member Functions

CXTPDockingPaneGripperedTheme ()
Constructs a CXTPDockingPaneGripperedTheme object.
void | DrawFloatingFrame (CDC *pDC, CXTPDockingPaneMiniWnd *pPane, CRect rc)
Call this method to draw the frame of a floating window.
virtual void | DrawCaption (CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc)
Override this member function to draw a caption.
virtual void | RefreshMetrics ()
This method is called to refresh the visual metrics of the pane.
- Public Member Functions inherited from CXTPDockingPaneDefaultTheme
CXTPDockingPaneDefaultTheme ()
Constructs a CXTPDockingPaneDefaultTheme object.
virtual void | DrawSidePanel (CDC *pDC, CXTPDockingPaneSidePanel *pPane, CRect rc)
Override this member function to draw the side panel.
- Public Member Functions inherited from CXTPDockingPanePaintManager
virtual void | DrawPane (CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc)
Override this member function to draw a tabbed container.
virtual CRect | GetPaneCaptionRect (const CXTPDockingPaneSidePanel *pPane)
Call this method to get the pane's caption rectangle.
virtual void | DrawSplitter (CDC *pDC, CXTPDockingPaneSplitterWnd *pSplitter)
Override this method to draw a splitter.
virtual void | DrawCaptionButtons (CDC *pDC, CXTPDockingPaneCaptionButtons *pButtons, CRect &rcCaption, COLORREF clr, int nButtonSize, int nButtonGap, BOOL bVertical=FALSE)
Override this member function to draw buttons for a tabbed caption.
virtual void | DrawCaptionButton (CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton)
Override this member function to draw a button for a tabbed caption.
virtual void | AdjustClientRect (CXTPDockingPaneSidePanel *pPane, CRect &rect)
Override this member to change the client rectangle of the child docking pane.
virtual void | AdjustClientRect (CXTPDockingPaneTabbedContainer *pPane, CRect &rect, BOOL bApply)
Override this member to change the client rectangle of the child docking pane.
virtual void | AdjustCaptionRect (const CXTPDockingPaneSidePanel *pPane, CRect &rc)
Override this member to change the caption rectangle of the child docking pane.
virtual void | AdjustCaptionRect (const CXTPDockingPaneTabbedContainer *pPane, CRect &rc)
Override this member to change the caption rectangle of the child docking pane.
virtual void | GetCaptionRect (const CXTPDockingPaneTabbedContainer *pPane, CRect &rc)
Call this method to get a caption rectangle.
virtual CRect | GetCaptionGripperRect (const CXTPDockingPaneTabbedContainer *pPane)
Call this method to get a caption gripper for a tabbed container.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1, int nPen)
Draws a line.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1)
Draws a line.
int | DrawCaptionText (CDC *pDC, const CString &strTitle, CRect rc, BOOL bVertical, BOOL bCalcWidth=FALSE)
Draws the text of a pane caption.
void | Pixel (CDC *pDC, int xPos, int yPos, int nPen)
Sets the pixel at the point.
void | Rectangle (CDC *pDC, CRect rc, int nPenEntry, int nPenBorder)
Draws a rectangle.
void | UseOfficeFont (BOOL bUseOfficeFont)
Call this member to use Office (Tahoma) font.
void | SetCaptionFontIndirect (LOGFONT *pLogFont, BOOL bUseStandardFont=FALSE)
Call this method to set the caption's font.
CXTPTabPaintManager * | SetTabPaintManager (CXTPTabPaintManager *pManager)
Call this method to set the paint manager used to draw tabs of a tabbed container.
CXTPTabPaintManager * | SetPanelPaintManager (CXTPTabPaintManager *pManager)
Call this method to set the paint manager used to draw tabs of an auto-hide panel.
CXTPTabPaintManager * | GetTabPaintManager () const
Retrieves the paint manager used to draw tabs of a tabbed container.
CXTPTabPaintManager * | GetPanelPaintManager () const
Retrieves the paint manager used to draw tabs of an auto-hide panel.
COLORREF | GetXtremeColor (UINT nIndex)
Retrieves the current color of the specified XP display element.
void | SetColors (int cElements, CONST INT *lpaElements, CONST COLORREF *lpaRgbValues)
Call this member to set the colors for each element in an array to the colors in a specified color array.
int | GetCaptionHeight () const
Call this member to get the caption height of the tabbed container.
int | GetTabsHeight () const
Call this member to get tabs height of the tabbed container.
void | SetSplitterStyle (DWORD dwStyle)
Call this member to set the splitter style.
DWORD | GetSplitterStyle () const
Call this method to get the splitter style.
void | SetCaptionButtonStyle (XTPDockingPaneCaptionButtonStyle nStyle)
Call this member to set the caption button style.
XTPDockingPaneCaptionButtonStyle | GetCaptionButtonStyle () const
Call this method to get the caption button style.
XTPCurrentSystemTheme | GetCurrentSystemTheme () const
Call this member function to determine the current Windows XP theme in use.
void | SetLunaTheme (XTPCurrentSystemTheme systemTheme)
Call this method to force system theme.
virtual void | DrawAutoHidePanel (CDC *pDC, CRect rc, XTPDockingPaneDirection direction)
This mmethod is called by the framework to draw the docking pane auto-hide panel background and splitter.
void | SetCustomTitleBrushes (HBRUSH hbrActiveTitleHorz, HBRUSH hbrInactiveTitleHorz=NULL, HBRUSH hbrActiveTitleVert=NULL, HBRUSH hbrInactiveTitleVert=NULL, BOOL bDestroyOnCleanup=FALSE)
Sets custom title brushes.
HBRUSH | GetCustomTitleBrush (BOOL bActive, BOOL bVertical) const
Obtains the custom title brush.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

virtual void | DrawCaptionPart (CDC *pDC, CXTPDockingPaneBase *pPane, CRect rcCaption, const CString &strTitle, BOOL bActive, BOOL bVertical)
Draws the common part of a tabbed and floating caption.
- Protected Member Functions inherited from CXTPDockingPaneDefaultTheme
- Protected Member Functions inherited from CXTPDockingPanePaintManager
CXTPDockingPanePaintManager ()
Constructs a CXTPDockingPanePaintManager object.
virtual | ~CXTPDockingPanePaintManager ()
Destroys a CXTPDockingPanePaintManager object, handles cleanup and deallocation.
virtual void | DrawCaptionButtonEntry (CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton, CSize szOffset)
Draws only the glyph of a button.
virtual void | DrawCaptionButtonEntry (CDC *pDC, CXTPDockingPaneCaptionButton *pButton, CPoint pt, COLORREF clrButton)
Draws only the glyph of a button.
void | ClipAndAddEllipsisIfNeeded (CDC *pDC, CString &strTitle, int nCaptionWidth) const
Clip string and add ellipsis if its width less than nCaptionWidth.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPDockingPanePaintManager
BOOL | m_bUseBoldCaptionFont
TRUE to use bold font for caption.
BOOL | m_bHighlightActiveCaption
TRUE to highlight active caption.
int | m_nSplitterSize
Splitter size.
BOOL | m_bShowCaption
TRUE to draw captions of tabbed containers.
BOOL | m_bDrawSingleTab
TRUE to draw single tab.
BOOL | m_bDrawCaptionIcon
TRUE to draw caption icon.
int | m_nSplitterIndent
Size of splitter indent.
CXTPPaintManagerColor | m_clrBackground
Background color.
CXTPPaintManagerColor | m_clrSplitterGripper
Splitter gripper color.
CXTPPaintManagerColor | m_clrSplitter
Splitter color.
CXTPPaintManagerColorGradient | m_clrSplitterGradient
Splitter gradient color.
CXTPPaintManagerColorGradient | m_clrNormalCaption
Color of pane caption when inactive.
CXTPPaintManagerColorGradient | m_clrActiveCaption
Color of pane caption when active.
CXTPPaintManagerColor | m_clrNormalCaptionText
Color of pane caption text when the caption is inactive.
CXTPPaintManagerColor | m_clrActiveCaptionText
Active caption text.
CXTPPaintManagerColor | m_clrDisabledCaptionText
Disabled caption text.
- Protected Attributes inherited from CXTPDockingPanePaintManager
XTPDockingPaneCaptionButtonStyle | m_nCaptionButtonStyle
Caption button style.
DWORD | m_dwSplitterStyle
Splitter style.
int | m_nTitleHeight
Title's height.
int | m_nCaptionFontGap
Additional gap of font.
int | m_nTabsHeight
Tab bar's height.
CXTPFont | m_xtpFontTitle
Title font.
CXTPFont | m_xtpFontTitleVertical
Title vertical font.
BOOL | m_bUseOfficeFont
TRUE to use Tahoma font.
BOOL | m_bUseStandardFont
TRUE to use system icon font.
BOOL | m_bDestroyCustomTitleBrushes
If TRUE, custom title bushes will be destroyed on cleanup.
HBRUSH | m_hbrActiveTitleHorz
Optional user specified active horizontal title brush.
HBRUSH | m_hbrInactiveTitleHorz
Optional user specified inactive horizontal title brush.
HBRUSH | m_hbrActiveTitleVert
Optional user specified active vertical title brush.
HBRUSH | m_hbrInactiveTitleVert
Optional user specified inactive vertical title brush.
CXTPTabPaintManager * | m_pTabPaintManager
Paint Manager used to draw tabs for a tabbed container.
CXTPTabPaintManager * | m_pPanelPaintManager
Paint Manager used to draw tabs for an auto-hide panel.
COLORREF | m_arrColor [XPCOLOR_LAST+1]
Self colors array.
XTPDockingPanePaintTheme | m_themeCurrent
Current theme.
CString | m_strOfficeFont
Office font name.
CRect | m_rcCaptionMargin
Margins of caption.
XTPCurrentSystemTheme | m_systemTheme
Current system theme.
CXTPWinThemeWrapper * | m_themeToolbar
Toolbar theme helper.
CXTPWinThemeWrapper * | m_themeExplorer
WinXP Explorer theme helper.
CXTPWinThemeWrapper * | m_themeButton
WinXP Button theme helper.
CXTPWinThemeWrapper * | m_themeWindow
WinXP Window Theme helper.
CXTPWinThemeWrapper * | m_themeRebar
Rebar theme helper.
BOOL | m_bLunaTheme
TRUE if luna colors are used.

Detailed Description

CXTPDockingPaneGripperedTheme is a CXTPDockingPaneDefaultTheme derived class that represents a gripper theme for docking panes.

Call CXTPDockingPaneManager::SetTheme(xtpPaneThemeGrippered); to set this theme.

Member Function Documentation

◆ DrawCaption()

virtual void DrawCaption | ( | CDC * | pDC,
 |  | CXTPDockingPaneTabbedContainer * | pPane,
 |  | CRect | rc )
 virtual

Override this member function to draw a caption.

Parameters
pDC | Reference to the device context in which to draw.
pPane | Pointer to the tabbed container.
rc | Client rectangle of the tabbed container.

Reimplemented from CXTPDockingPaneDefaultTheme.

Reimplemented in CXTPDockingPaneOffice2002VisioTheme, CXTPDockingPaneOffice2003Theme, CXTPDockingPaneOffice2007OutlookTheme, CXTPDockingPaneOffice2007Theme, CXTPDockingPaneOffice2007WordTheme, and CXTPDockingPaneWinNativeTheme.

◆ DrawCaptionPart()

virtual void DrawCaptionPart | ( | CDC * | pDC,
 |  | CXTPDockingPaneBase * | pPane,
 |  | CRect | rcCaption,
 |  | const CString & | strTitle,
 |  | BOOL | bActive,
 |  | BOOL | bVertical )
 protectedvirtual

Draws the common part of a tabbed and floating caption.

Parameters
pDC | Reference to the device context in which to draw.
pPane | Container which the caption needs to draw.
rcCaption | Caption bounding rectangle.
strTitle | Caption text.
bActive | TRUE if the caption is active.
bVertical | TRUE to draw the caption vertically.

Reimplemented from CXTPDockingPaneDefaultTheme.

Reimplemented in CXTPDockingPaneOffice2003Theme, CXTPDockingPaneOffice2007WordTheme, CXTPDockingPaneVisualStudio2003Theme, CXTPDockingPaneVisualStudio6Theme, CXTPDockingPaneWinExplorerTheme, and CXTPDockingPaneWinNativeTheme.

◆ DrawFloatingFrame()

void DrawFloatingFrame | ( | CDC * | pDC,
 |  | CXTPDockingPaneMiniWnd * | pPane,
 |  | CRect | rc )
 virtual

Call this method to draw the frame of a floating window.

Parameters
pDC | Pointer to a valid device context.
pPane | Floating window pointer.
rc | Client rectangle of floating frame.

Reimplemented from CXTPDockingPaneDefaultTheme.

Reimplemented in CXTPDockingPaneOffice2002VisioTheme, CXTPDockingPaneOffice2003Theme, CXTPDockingPaneVisualStudio2010Theme, and CXTPDockingPaneWinNativeTheme.

The documentation for this class was generated from the following file:
  • XTPDockingPaneThemeGrippered.h


Toolkit Pro: CXTPDockingPaneLayout Class Reference

Public Member Functions | List of all members
CXTPDockingPaneLayout Class Reference

CXTPDockingPaneLayout is a standalone class. More...

Inheritance diagram for CXTPDockingPaneLayout:
[legend]

Public Member Functions

CXTPDockingPaneLayout (CXTPDockingPaneManager *pManager)
Constructs a CXTPDockingPaneLayout object.
virtual | ~CXTPDockingPaneLayout ()
Destroys a CXTPDockingPaneLayout object, handles cleanup and deallocation.
void | Copy (const CXTPDockingPaneLayout *pLayout)
Call this member function to copy one layout to another.
void | Save (LPCTSTR lpszSection)
Call this member function to save the layout to the registry.
BOOL | Load (LPCTSTR lpszSection)
Call this member function to load the layout from the registry.
CXTPDockingPaneInfoList & | GetPaneList () const
Retrieves a list of layout's panes.
void | Serialize (CArchive &ar)
Either reads this object from or writes this object to an archive.
void | SaveToFile (LPCTSTR lpszFileName, LPCTSTR lpszSection)
Call this member function to save the layout to the file.
BOOL | LoadFromFile (LPCTSTR lpszFileName, LPCTSTR lpszSection)
Call this member function to load the layout from the file.
void | SaveToNode (XTPXML::IXMLDOMNode *pNode, LPCTSTR lpszSection)
Call this member function to save the layout to the XML node.
BOOL | LoadFromNode (XTPXML::IXMLDOMNode *pNode, LPCTSTR lpszSection)
Call this member function to load the layout from the XML node.
BOOL | IsUserLayout () const
Call this member to determine if the layout is a user created layout.
BOOL | IsValid () const
Determines if the layout is valid.
BOOL | DoPropExchange (CXTPPropExchange *pPX)
Call this member function to save/restore the settings of the pane.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

CXTPDockingPaneLayout is a standalone class.

It is used to manipulate a pane's layouts.

Constructor & Destructor Documentation

◆ CXTPDockingPaneLayout()

CXTPDockingPaneLayout ( CXTPDockingPaneManager * pManager )

Constructs a CXTPDockingPaneLayout object.

Parameters
pManager Pointer to a CXTPDockingPaneManager object.

Member Function Documentation

◆ Copy()

void Copy ( const CXTPDockingPaneLayout * pLayout )

Call this member function to copy one layout to another.

Parameters
pLayout Source Layout.

◆ DoPropExchange()

BOOL DoPropExchange ( CXTPPropExchange * pPX )

Call this member function to save/restore the settings of the pane.

Parameters
pPX Pointer to a CXTPPropExchange object.
Returns
TRUE if successful, otherwise FALSE.

◆ GetPaneList()

AFX_INLINE CXTPDockingPaneInfoList & GetPaneList ( ) const

Retrieves a list of layout's panes.

Returns
A list of the layout's panes.
See also
CXTPDockingPaneInfoList

◆ IsUserLayout()

AFX_INLINE BOOL IsUserLayout ( ) const

Call this member to determine if the layout is a user created layout.

Returns
TRUE if the layout is a user created layout.

◆ IsValid()

BOOL IsValid ( ) const

Determines if the layout is valid.

Returns
TRUE if the layout is valid.

◆ Load()

BOOL Load ( LPCTSTR lpszSection )

Call this member function to load the layout from the registry.

Parameters
lpszSection Registry section.
Returns
TRUE if successful, otherwise FALSE.

◆ LoadFromFile()

BOOL LoadFromFile | ( | LPCTSTR | lpszFileName,
 |  | LPCTSTR | lpszSection )

Call this member function to load the layout from the file.

Parameters
lpszFileName | The full path and file name.
lpszSection | Registry section.
Returns
TRUE if successful, otherwise FALSE.

◆ LoadFromNode()

BOOL LoadFromNode | ( | XTPXML::IXMLDOMNode * | pNode,
 |  | LPCTSTR | lpszSection )

Call this member function to load the layout from the XML node.

Parameters
pNode | Points to the node object.
lpszSection | Registry section.
Returns
TRUE if successful, otherwise FALSE.

◆ Save()

void Save ( LPCTSTR lpszSection )

Call this member function to save the layout to the registry.

Parameters
lpszSection Registry section.

◆ SaveToFile()

void SaveToFile | ( | LPCTSTR | lpszFileName,
 |  | LPCTSTR | lpszSection )

Call this member function to save the layout to the file.

Parameters
lpszFileName | The full path and file name.
lpszSection | Registry section.

◆ SaveToNode()

void SaveToNode | ( | XTPXML::IXMLDOMNode * | pNode,
 |  | LPCTSTR | lpszSection )

Call this member function to save the layout to the XML node.

Parameters
pNode | Points to the node object.
lpszSection | Registry section.

◆ Serialize()

void Serialize ( CArchive & ar )

Either reads this object from or writes this object to an archive.

Parameters
ar A CArchive object to serialize to or from.
The documentation for this class was generated from the following file:
  • XTPDockingPaneLayout.h


Toolkit Pro: CXTPDockingPaneManager Class Reference

Public Member Functions | Public Attributes | Protected Attributes | List of all members
CXTPDockingPaneManager Class Reference

CXTPDockingPaneManager is a CWnd derived class. More...

Public Member Functions

CXTPDockingPaneManager ()
Constructs a CXTPDockingPaneManager object.
~CXTPDockingPaneManager ()
Destroys a CXTPDockingPaneManager object, handles cleanup and deallocation.
virtual bool | InstallDockingPanes (CWnd *pParent, bool bClipChildren=true)
Call this member function to install docking panes.
virtual CXTPDockingPane * | CreatePane (UINT nID, CRect rc, XTPDockingPaneDirection direction, CXTPDockingPaneBase *pNeighbour=NULL)
Call this member function to create a docking pane.
virtual void | DockPane (CXTPDockingPaneBase *pPane, XTPDockingPaneDirection direction, CXTPDockingPaneBase *pNeighbour=NULL)
Call this member to dock an existing pane.
virtual CXTPDockingPaneSidePanel * | DockSidePane (CXTPDockingPaneBase *pPane, XTPDockingPaneDirection direction, CRect rc)
Call this member to dock an existing pane to a dock panel.
virtual CXTPDockingPaneMiniWnd * | FloatPane (CXTPDockingPaneBase *pPane, CRect rc)
Call this member to float an existing pane.
virtual void | AttachPane (CXTPDockingPaneBase *pPane, CXTPDockingPaneBase *pNeighbour)
Call this member to attach a pane to another one.
virtual void | ToggleDocking (CXTPDockingPaneBase *pPane)
Call this member to switch the pane's position (docking/floating).
virtual void | ToggleAutoHide (CXTPDockingPaneBase *pPane)
Call this member to switch the pane's auto-hide (docking/auto-hide).
virtual void | ShowPane (int nID, BOOL bSetFocus=TRUE)
Call this member to show (activate) a pane.
virtual void | ShowPane (CXTPDockingPane *pPane, BOOL bSetFocus=TRUE)
Call this member to show (activate) a pane.
virtual void | ClosePane (int nID)
Call this member to close a pane.
virtual void | ClosePane (CXTPDockingPane *pPane)
Call this member to close a pane.
virtual void | DestroyPane (int nID)
Call this member to destroy a pane.
virtual void | DestroyPane (CXTPDockingPane *pPane)
Call this member to destroy a pane.
virtual void | HidePane (int nID)
Call this member to hide a pane.
virtual void | HidePane (CXTPDockingPaneBase *pPane)
Call this member to hide a pane.
CXTPDockingPane * | FindPane (int nID) const
Call this member to find a pane by its identifier.
BOOL | IsPaneClosed (int nID) const
Call this member to check if a pane is closed.
BOOL | IsPaneClosed (CXTPDockingPane *pPane) const
Call this member to check if a pane is closed.
BOOL | IsPaneHidden (int nID) const
Call this member to check if a pane is hidden.
BOOL | IsPaneHidden (CXTPDockingPane *pPane) const
Call this member to check if a pane is hidden.
BOOL | IsPaneSelected (int nID) const
Call this member to check if a pane is selected.
BOOL | IsPaneSelected (CXTPDockingPane *pPane) const
Call this member to check if a pane is selected.
BOOL | SetIcons (UINT nIDResource, const int *nIDs, int nCount, COLORREF clrMask=0xC0C0C0)
Call this member to set icons to panes.
void | SetIcon (UINT nID, const CXTPImageManagerIconHandle &hIcon)
Call this member to set an icon to the pane.
CXTPImageManagerIcon * | GetIcon (UINT nID, int nWidth=16) const
Call this member to get an icon of the pane.
void | ClearIconMap ()
Call this member to remove all icons.
void | SetAnimationDelay (double dAnimationDelay=-1, int nAnimationDuration=128, int nAnimationInterval=16)
Call this member to set the animation speed.
double | GetAnimationDelay (int *pAnimationDuration=NULL, int *pAnimationInterval=NULL) const
Call this member to get the animation speed.
void | EnableKeyboardNavigate (DWORD options=xtpPaneKeyboardUseAll)
Call this member to allow the user to switch and move panes using the keyboard.
BOOL | IsKeyboardNavigateEnabled () const
Determines if keyboard navigate options are enabled.
void | SetKeyboardWindowSelectClass (CRuntimeClass *pWindowSelectClass)
Call this method to set a custom CXTPDockingPaneWindowSelect window that will be used to show active panes and files.
CRuntimeClass * | GetKeyboardWindowSelectClass () const
Determines the runtime class for a CXTPDockingPaneWindowSelect window that shows active panes and files.
BOOL | ActivateNextPane (CXTPDockingPane *pPane, BOOL bForward)
Call this method to activate a pane in cycle order.
CXTPDockingPaneInfoList & | GetPaneList () const
Call this member to get the list of created panes.
CXTPDockingPaneBaseList & | GetPaneStack () const
Call this member to get the list of created panes, including its virtual containers.
CWnd * | GetSite () const
Call this member to retrieve the docking site of the manager.
void | SetTheme (XTPDockingPanePaintTheme theme)
Call this member to switch the visual theme of the panes.
void | SetCustomTheme (CXTPDockingPanePaintManager *pTheme)
Call this member to set a custom theme.
XTPDockingPanePaintTheme | GetCurrentTheme () const
Call this member to get the current visual theme.
CXTPDockingPanePaintManager * | GetPaintManager () const
Retrieves the paint manager of docking panes.
virtual CXTPDockingPaneLayout * | CreateLayout ()
Call this member to create a new layout.
void | GetLayout (CXTPDockingPaneLayout *pLayout) const
Call this member to get the current layout.
void | SetLayout (const CXTPDockingPaneLayout *pLayout)
Call this member to set the current layout.
void | RedrawPanes ()
Call this member to redraw all panes.
CXTPDockingPaneBase * | GetClientPane () const
Call this member to retrieve the client pane.
void | DestroyAll ()
Call this member to destroy all panes.
void | CloseAll ()
Call this member to close all panes.
CXTPImageManager * | GetImageManager () const
Call this member to retrieve the image manager of docking panes.
void | SetImageManager (CXTPImageManager *pImageManager)
Call this member to set the image manager for docking panes.
void | HideClient (BOOL bHide)
Call this member to hide the client area.
BOOL | IsClientHidden () const
Checks if the client area is hidden.
void | SetClientMargin (int nMargin)
Sets the width for the client margin.
int | GetClientMargin () const
Retrieves the width of the client margin.
void | SetClientMargins (CRect rcClientMargins)
Sets the width for each side of the client margin (left, top, right, and bottom) individually using a CRect object.
CRect | GetClientMargins () const
Retrieves the width for each side of the client margin (left, top, right, and bottom).
void | SetSideDockingMargin (CRect rcMargin)
Sets the margin between the client area's edge and a docking pane docked to the edge of the client area when side docking is enabled.
CRect | GetSideDockingMargin () const
Gets the margin between the client area's edge and a docking pane docked to the edge of the client area when side docking is enabled.
void | UseSplitterTracker (BOOL bSplitterTracker)
Call this member to use the splitter tracker.
BOOL | IsSplitterTrackerUsed () const
Call this member to determine if the splitter tracker is used.
void | SetCaptionDirection (XTPDockingPaneCaptionDirection captionDirection)
Call this member to set the direction of captions.
XTPDockingPaneCaptionDirection | GetCaptionDirection () const
Call this member to get the direction of captions.
void | LockSplitters (BOOL bLock=TRUE)
Call this method to lock the splitters.
BOOL | IsSplittersLocked () const
Call this member to determine if the splitters are locked.
void | SetFloatingFrameCaption (LPCTSTR lpszCaption)
Call this method to set the common caption for floating frames.
void | EnableFloatingFrameTheme (BOOL bThemedFloatingFrames)
Call this method to use themes for floating frames.
BOOL | IsFloatingFrameThemeEnabled () const
Determines if themes are used for floating frames.
void | SetStickyFloatingFrames (BOOL bSticky)
Call this method to enable sticky floating frames.
BOOL | IsStickyFloatingFrames () const
Determines if sticky floating frames are enabled.
void | SetFloatingFramesOpacity (int nOpacity)
Call this method to set the opacity for inactive floating frames.
int | GetFloatingFramesOpacity () const
Determines the opacity for inactive floating frames.
void | SyncActiveFloatingFrames (BOOL bSyncActiveFloatingFrames)
Call this member to keep the activation of floating frames windows in sync with the activation of the top-level frame window.
BOOL | IsLayoutRTL () const
Call this member to determine if the current layout is Right-to-Left (RTL).
XTPDockingPaneDirection | GetRTLDirection (XTPDockingPaneDirection direction) const
Call this member to retrieve the Right-to-Left (RTL) docking direction equivalent to the docking direction passed in to this member.
XTPDockingPaneDirection | GetPaneDirection (const CXTPDockingPaneBase *pPane) const
Call this member to determine the XTPDockingPaneDirection of pPane.
CXTPDockingPaneBase * | GetTopPane () const
Retrieves the top-level virtual container for the site window.
void | SetDockingContext (CXTPDockingPaneContext *pDockingContext)
Call this method to use a custom docking context.
CXTPDockingPaneContext * | GetDockingContext () const
Retrieves a pointer to the current docking context.
BOOL | IsAlphaDockingContext () const
Call this member to determine if alpha docking context is used when panes are being dragged and dropped.
void | SetAlphaDockingContext (BOOL bAlphaDockingContext)
Call this member to specify whether an alpha docking context is used to indicate where a pane can be docked while dragging the pane.
BOOL | IsShowDockingContextStickers () const
Call this member to determine whether docking context stickers are used.
void | SetShowDockingContextStickers (BOOL bShowDockingContextStickers)
Call this member to specify whether Visual Studio 2005 style docking context stickers should be used while dragging a docking pane.
void | SetDockingContextStickerStyle (XTPDockingContextStickerStyle style)
Call this member to set the style for docking context stickers.
XTPDockingContextStickerStyle | GetDockingContextStickerStyle () const
Call this member to get the style of docking context stickers.
void | SetShowContentsWhileDragging (BOOL bShow=TRUE)
Call this member to set the "Show window contents while dragging" option.
BOOL | GetShowContentsWhileDragging () const
Determines if the "Show window contents while dragging" option is enabled.
void | ShowCaptionMaximizeButton (BOOL bShowMaximizeButton)
Call this method to show Maximize/Restore buttons for non-floating docking panes.
void | ShowFloatingCaptionMaximizeButton (BOOL bShowMaximizeButton)
Call this method to show Maximize/Restore buttons for floating docking panes.
BOOL | IsCaptionMaximizeButtonsVisible () const
Determines if Maximize/Restore buttons for non-floating docking panes are visible.
BOOL | IsFloatingCaptionMaximizeButtonsVisible () const
Determines if Maximize/Restore buttons for floating docking panes are visible.
void | NormalizeSplitters ()
Call this method to save the current splitter positions for all splitter containers.
void | RecalcFramesLayout ()
Call this method to recalculate the layout for all parent frames of panes.
void | SyncPanesState ()
This method updates the XTP_DOCKINGPANE_INFO structure for each pane filling its members.
void | SetDefaultPaneOptions (DWORD dwOptions)
Call this method to set the default options used for each pane.
DWORD | GetDefaultPaneOptions () const
Call this method to retrieve the default options used for each pane.
void | OnSetPreviewMode (BOOL bPreview)
Call this member function to set the application's panes into and out of print-preview mode.
CXTPDockingPane * | GetActivePane () const
Call this member function to get the currently active (focused) pane.
CXTPToolTipContext * | GetToolTipContext () const
Call this method to get a pointer to the tooltip context.
BOOL | DoPropExchange (CXTPPropExchange *pPX)
Call this member function to save/restore the settings of the pane.
void | RecalcFrameLayout (CXTPDockingPaneBase *pPane, BOOL bDelay=FALSE)
This method is called to recalculate a pane's site layout.
virtual void | UpdatePanes ()
This method is called to update panes state.
virtual LRESULT | NotifyOwner (UINT nCode, LPARAM lParam)
This member is called to notify the parent window that an event has occurred in the docking pane.
void | EnsureVisible (CXTPDockingPaneBase *pPane)
Call this method to ensure that a specified pane is visible.
void | EnableSideDocking (BOOL bEnable=TRUE)
Enables/disables side docking.
BOOL | IsSideDockingEnabled () const
Determines if side docking is enabled.
virtual CXTPDockingPaneBase * | OnCreatePane (XTPDockingPaneType type, CXTPDockingPaneLayout *pLayout)
This method is called when a pane is created.
virtual void | OnActivatePane (BOOL bActive, CXTPDockingPane *pPane)
This method is called when a pane is activated/deactivated.
BOOL | NotifyAction (XTPDockingPaneAction action, CXTPDockingPane *pPane, CXTPDockingPaneBase *pDockContainer=NULL, XTPDockingPaneDirection dockDirection=xtpPaneDockLeft)
The framework calls this method when a docking pane is performing an action.

Public Attributes

int | m_nSplitterGap
Minimum available width of panes.
BOOL | m_bCloseGroupOnButtonClick
If TRUE, when the close button on a group of panes is clicked, then the entire group of panes is closed.
BOOL | m_bHideGroupOnButtonClick
If TRUE, when the hide button on a group of panes is clicked, then the entire group of panes is hidden.
BOOL | m_bShowSizeCursorWhileDragging
TRUE to show the size cursor while panes are dragged.
CPoint | m_ptMinClientSize
Minimum client size.
int | m_nStickyGap
Sticky gap.
BOOL | m_bShowPanelScrollButtons
TRUE to show scroll buttons for auto-hide panels.
BOOL | m_bAutoInitialUpdate
TRUE to send WM_INITIIALUPDATE to Pane Children.
XTPTabNavigateButtonFlags | m_bShowCloseTabButton
Close Tab Button Flag.

Protected Attributes

CWnd * | m_pSite
Parent window of the docking manager.
CXTPDockingPaneLayout * | m_pLayout
Selected layout.
CXTPDockingPanePaintManager * | m_pPaintManager
Current paint manager.
CXTPDockingPane * | m_pActivePane
Current active pane.
CRect | m_rcClientMargins
Specifies each client margin individually.
CRect | m_rcSideDockingMargin
Side docking margin.
BOOL | m_bStickyFloatingFrames
TRUE to enable sticky option for floating panes.
CXTPImageManager * | m_pImageManager
Image manager of docking panes.
BOOL | m_bSideDocking
TRUE if side docking is enabled, FALSE if disabled.
BOOL | m_bHideClient
If TRUE, then the client area is hidden so that only the docking panes are visible and occupy the entire area.
BOOL | m_bUseSplitterTracker
If TRUE, then splitter trackers are used.
BOOL | m_bShowMaximizeButton
Allow non-floating panes to be maximized.
BOOL | m_bShowFloatingMaximizeButton
Allow floating panes to be maximized.
BOOL | m_bLockSplitters
If TRUE, then you can not resize the panes when they are docked.
BOOL | m_bAlphaDockingContext
If TRUE, then alpha docking context is used when dragging a pane.
BOOL | m_bShowDockingContextStickers
If TRUE, then docking context stickers are drawn when the pane is being dragged and dropped.
BOOL | m_bShowContentsWhileDragging
If TRUE, then window contents are visible while dragging.
BOOL | m_bThemedFloatingFrames
If TRUE, then floating docking panes will use the currently set theme.
BOOL | m_bSyncActiveFloatingFrames
Synchronizes the activation of the mini-frame window to the activation of its parent window.
BOOL | m_nFloatingFramesOpacity
Opacity of floating frames.
DWORD | m_bKeyboardEnabled
XTPDockingPaneKeyboardNavigate options.
DWORD | m_dwDefaultPaneOptions
Default Panes options.
XTPDockingPaneCaptionDirection | m_captionDirection
Caption Direction.
CString | m_strFloatingFrameCaption
The caption that is displayed in the title bar of a floating frame that has panes docked.
XTPDockingContextStickerStyle | m_nDockingContextStickerStyle
Sticker style.
CXTPDockingPaneContext * | m_pDockingContext
Docking context helper.
CXTPDockingPaneLayout * | m_pPreviewLayout
Preview mode layout.
CXTPToolTipContext * | m_pToolTipContext
Tooltip Context.
PFNSETLAYEREDWINDOWATTRIBUTES | m_pfnSetLayeredWindowAttributes
Pointer to SetLayeredWindowAttributes API function.
CRuntimeClass * | m_pWindowSelectClass
Runtime class of WindowSelect.

Detailed Description

CXTPDockingPaneManager is a CWnd derived class.

It is used to manipulate docking panes.

Member Function Documentation

◆ ActivateNextPane()

BOOL ActivateNextPane | ( | CXTPDockingPane * | pPane,
 |  | BOOL | bForward )

Call this method to activate a pane in cycle order.

Parameters
pPane | Pane to start. NULL to select the first pane.
bForward | TRUE to select the next pane, FALSE to select the previous pane.
Returns
TRUE if the pane was successfully activated.

◆ AttachPane()

virtual void AttachPane | ( | CXTPDockingPaneBase * | pPane,
 |  | CXTPDockingPaneBase * | pNeighbour )
 virtual

Call this member to attach a pane to another one.

Parameters
pPane | Pane to be attached.
pNeighbour | Pane's Neighbor.

◆ ClosePane() [1/2]

virtual void ClosePane ( CXTPDockingPane * pPane )
virtual

Call this member to close a pane.

Parameters
pPane Pane to close.

◆ ClosePane() [2/2]

AFX_INLINE void ClosePane ( int nID )
virtual

Call this member to close a pane.

Parameters
nID Pane's identifier.

◆ CreateLayout()

virtual CXTPDockingPaneLayout * CreateLayout ( )
virtual

Call this member to create a new layout.

You must delete a layout when it no longer used.

Returns
A pointer to a CXTPDockingPaneLayout object.

◆ CreatePane()

virtual CXTPDockingPane * CreatePane | ( | UINT | nID,
 |  | CRect | rc,
 |  | XTPDockingPaneDirection | direction,
 |  | CXTPDockingPaneBase * | pNeighbour = NULL )
 virtual

Call this member function to create a docking pane.

Parameters
nID | Unique identifier of the pane.
rc | Initial size of the pane.
direction | Docking direction. Can be any of the values listed in the Remarks section.
pNeighbour | Pane's Neighbor. It can be NULL to use the frame as a neighbor.

direction parameter can be one of the following: xtpPaneDockTop: Docks the pane to the top of the neighbor. xtpPaneDockLeft: Docks the pane to the left of the neighbor. xtpPaneDockRight: Docks the pane to the right of the neighbor. xtpPaneDockBottom: Docks the pane to the bottom of the neighbor.

Returns
The pointer to the created pane.

◆ DestroyPane() [1/2]

virtual void DestroyPane ( CXTPDockingPane * pPane )
virtual

Call this member to destroy a pane.

Parameters
pPane Pane to destroy.
See also
ClosePane

◆ DestroyPane() [2/2]

AFX_INLINE void DestroyPane ( int nID )
virtual

Call this member to destroy a pane.

Parameters
nID Pane's identifier.
See also
ClosePane

◆ DockPane()

virtual void DockPane | ( | CXTPDockingPaneBase * | pPane,
 |  | XTPDockingPaneDirection | direction,
 |  | CXTPDockingPaneBase * | pNeighbour = NULL )
 virtual

Call this member to dock an existing pane.

Parameters
pPane | Pane to be docked.
direction | Docking direction. Can be any of the values listed in the Remarks section.
pNeighbour | Pane's Neighbor.

direction parameter can be one of the following: xtpPaneDockTop: Docks the pane to the top of the neighbor. xtpPaneDockLeft: Docks the pane to the left of the neighbor. xtpPaneDockRight: Docks the pane to the right of the neighbor. xtpPaneDockBottom: Docks the pane to the bottom of the neighbor.

◆ DockSidePane()

virtual CXTPDockingPaneSidePanel * DockSidePane | ( | CXTPDockingPaneBase * | pPane,
 |  | XTPDockingPaneDirection | direction,
 |  | CRect | rc )
 virtual

Call this member to dock an existing pane to a dock panel.

Parameters
pPane | Pane to be docked.
direction | Docking direction. Can be any of the values listed in the Remarks section.
rc | Number of pixels to offset the pane from the inside top edge of the client area. This only has an effect when using the DockLeftOf and DockRightOf direction.

DockSidePane will dock a pane to the inside edge of the client using code. SideDocking must be enabled for DockSidePane to have any effect.

SideDocking enables or disables "Visio" style client edge docking. Side docking can only occur to the inside edges of the client area. When SideDocking is enabled, any pane that is dragged to an inside edge of the client area will attempt to "snap" to that inside edge of the client. The pane will "snap" to the inside edge of the client and will leave a margin equal to that specified by SetSideDockingMargin.

SideDocking does not affect normal docking of panes. You will need to drag the pane past the side docking margin for normal docking algorithms to be used.

Returns
Reference to the side panel that the pane is docked to.

◆ DoPropExchange()

BOOL DoPropExchange ( CXTPPropExchange * pPX )

Call this member function to save/restore the settings of the pane.

Parameters
pPX Pointer to a CXTPPropExchange object.
Returns
TRUE if successful, otherwise FALSE.

◆ EnableFloatingFrameTheme()

void EnableFloatingFrameTheme ( BOOL bThemedFloatingFrames )

Call this method to use themes for floating frames.

Parameters
bThemedFloatingFrames TRUE to use themes for floating panes, FALSE otherwise.

◆ EnableKeyboardNavigate()

void EnableKeyboardNavigate ( DWORD options = xtpPaneKeyboardUseAll )

Call this member to allow the user to switch and move panes using the keyboard.

Parameters
options Available keyboard keys that can be used to navigate items.

options can be combination of the following: xtpPaneKeyboardUseAltMinus: To use Alt+'-' to show the context menu. xtpPaneKeyboardUseAltF6: To use Alt+F6 to select the next pane. xtpPaneKeyboardUseAltF7: To use Alt+F7 to show the window select dialog. xtpPaneKeyboardUseCtrlTab: To use Ctrl+Tab to show the window select dialog. xtpPaneKeyboardUseAll: To use all keys.

You can call SetKeyboardWindowSelectClass to set a custom window for Ctrl-Tab and Alt_F7 operations.

See also
XTPDockingPaneKeyboardNavigate

◆ EnableSideDocking()

AFX_INLINE void EnableSideDocking ( BOOL bEnable = TRUE )

Enables/disables side docking.

Parameters
bEnable TRUE to enable side docking, FALSE to disable side docking.
See also
SideDocking, SetSideDockingMargin

◆ EnsureVisible()

void EnsureVisible ( CXTPDockingPaneBase * pPane )

Call this method to ensure that a specified pane is visible.

Parameters
pPane Pointer to the CXTPDockingPaneBase object whose visibility must be ensured.
See also
ShowPane

◆ FindPane()

CXTPDockingPane * FindPane ( int nID ) const

Call this member to find a pane by its identifier.

Parameters
nID Pane's identifier.
Returns
A pointer to a CXTPDockingPane object.

◆ FloatPane()

virtual CXTPDockingPaneMiniWnd * FloatPane | ( | CXTPDockingPaneBase * | pPane,
 |  | CRect | rc )
 virtual

Call this member to float an existing pane.

Parameters
pPane | Pane to be floated.
rc | Floating rectangle.
Returns
A floating pane window object or NULL.

◆ GetActivePane()

AFX_INLINE CXTPDockingPane * GetActivePane ( ) const

Call this member function to get the currently active (focused) pane.

Returns
A pointer to the currently active (focused) pane.

◆ GetAnimationDelay()

double GetAnimationDelay | ( | int * | pAnimationDuration = NULL,
 |  | int * | pAnimationInterval = NULL ) const

Call this member to get the animation speed.

Parameters
pAnimationDuration | Pointer to an int that will receive the total time of the animation, in milliseconds.
pAnimationInterval | Pointer to an int that will receive the amount of time to rest, in milliseconds, between each animation step.
Returns
The animation delay.
See also
SetAnimationDelay

◆ GetCaptionDirection()

AFX_INLINE XTPDockingPaneCaptionDirection GetCaptionDirection ( ) const

Call this member to get the direction of captions.

Can return one of the following direction: xtpPaneCaptionHorizontal xtpPaneCaptionVertical xtpPaneCaptionAutoByPosition xtpPaneCaptionAutoBySize

Returns
An XTPDockingPaneCaptionDirection flag indicating which direction the pane captions are displayed.
See also
SetCaptionDirection

◆ GetClientMargin()

AFX_INLINE int GetClientMargin ( ) const

Retrieves the width of the client margin.

Returns
The width, in pixels, of the client margin.

◆ GetClientMargins()

AFX_INLINE CRect GetClientMargins ( ) const

Retrieves the width for each side of the client margin (left, top, right, and bottom).

Returns
A CRect object representing the width, in pixels, for each side of the client margin. The left, top, right, and bottom members specify the width for each side of the client margin.

◆ GetClientPane()

CXTPDockingPaneBase * GetClientPane ( ) const

Call this member to retrieve the client pane.

Returns
A pointer to a CXTPDockingPaneBase object.

◆ GetCurrentTheme()

XTPDockingPanePaintTheme GetCurrentTheme ( ) const

Call this member to get the current visual theme.

Returns
The current theme.

◆ GetDefaultPaneOptions()

AFX_INLINE DWORD GetDefaultPaneOptions ( ) const

Call this method to retrieve the default options used for each pane.

Returns
The default options used for each pane.
See also
SetDefaultPaneOptions, XTPDockingPaneOptions

◆ GetDockingContext()

AFX_INLINE CXTPDockingPaneContext * GetDockingContext ( ) const

Retrieves a pointer to the current docking context.

Returns
A pointer to the current docking context.

◆ GetDockingContextStickerStyle()

AFX_INLINE XTPDockingContextStickerStyle GetDockingContextStickerStyle ( ) const

Call this member to get the style of docking context stickers.

Returns
Style of docking context stickers.

Call SetShowDockingContextStickers to enable docking context stickers.

See also
SetShowDockingContextStickers, SetDockingContextStickerStyle

◆ GetFloatingFramesOpacity()

AFX_INLINE int GetFloatingFramesOpacity ( ) const

Determines the opacity for inactive floating frames.

Returns
The opacity for inactive floating frames.

◆ GetIcon()

CXTPImageManagerIcon * GetIcon | ( | UINT | nID,
 |  | int | nWidth = 16 ) const

Call this member to get an icon of the pane.

Parameters
nID | Docking pane's identifier.
nWidth | Width of the icon to retrieve.
Returns
The docking pane's icon.

◆ GetImageManager()

AFX_INLINE CXTPImageManager * GetImageManager ( ) const

Call this member to retrieve the image manager of docking panes.

Returns
The image manager of docking panes.

◆ GetKeyboardWindowSelectClass()

AFX_INLINE CRuntimeClass * GetKeyboardWindowSelectClass ( ) const

Determines the runtime class for a CXTPDockingPaneWindowSelect window that shows active panes and files.

Returns
A CRuntimeClass pointer to a CXTPDockingPaneWindowSelect window.
See also
SetKeyboardWindowSelectClass, EnableKeyboardNavigate, XTPDockingPaneKeyboardNavigate

◆ GetLayout()

void GetLayout ( CXTPDockingPaneLayout * pLayout ) const

Call this member to get the current layout.

Parameters
pLayout Pointer to a CXTPDockingPaneLayout object to receive the current layout.

◆ GetPaintManager()

AFX_INLINE CXTPDockingPanePaintManager * GetPaintManager ( ) const

Retrieves the paint manager of docking panes.

Returns
The paint manager of docking panes.

◆ GetPaneDirection()

XTPDockingPaneDirection GetPaneDirection ( const CXTPDockingPaneBase * pPane ) const

Call this member to determine the XTPDockingPaneDirection of pPane.

Parameters
pPane Pointer to a CXTPDockingPaneBase object.
Returns
The current XTPDockingPaneDirection of pPane.

◆ GetPaneList()

CXTPDockingPaneInfoList & GetPaneList ( ) const

Call this member to get the list of created panes.

Returns
The list of created panes.
See also
GetPaneStack, CXTPDockingPaneInfoList

◆ GetPaneStack()

CXTPDockingPaneBaseList & GetPaneStack ( ) const

Call this member to get the list of created panes, including its virtual containers.

Returns
The list of created panes, including its virtual containers.
See also
GetPaneList

◆ GetRTLDirection()

XTPDockingPaneDirection GetRTLDirection ( XTPDockingPaneDirection direction ) const

Call this member to retrieve the Right-to-Left (RTL) docking direction equivalent to the docking direction passed in to this member.

The return value for this member is dependent on the return value of IsLayoutRTL.

Parameters
direction Docking direction.
Returns
If IsLayoutRTL returns TRUE, then this member returns the Right-to-Left (RTL) docking direction of the supplied direction. If IsLayoutRTL returns FALSE, then the direction passed in to this member remains the same.

◆ GetShowContentsWhileDragging()

AFX_INLINE BOOL GetShowContentsWhileDragging ( ) const

Determines if the "Show window contents while dragging" option is enabled.

Returns
TRUE if the "Show window contents while dragging" option is enabled.

◆ GetSideDockingMargin()

AFX_INLINE CRect GetSideDockingMargin ( ) const

Gets the margin between the client area's edge and a docking pane docked to the edge of the client area when side docking is enabled.

SetSideDockingMargin sets the margins between the client areas's edge and a docking pane docked to the edge of the client area when side docking is enabled.

Returns
Side docking margins (margin between the right/top/left/bottom edge of the client area and any docking panes that are docked to the left/top/right/bottom edge of the client area.)
See also
SideDocking, SetSideDockingMargin

◆ GetSite()

AFX_INLINE CWnd * GetSite ( ) const

Call this member to retrieve the docking site of the manager.

Returns
The docking site.

◆ GetToolTipContext()

AFX_INLINE CXTPToolTipContext * GetToolTipContext ( ) const

Call this method to get a pointer to the tooltip context.

Returns
A pointer to the tooltip context.

◆ GetTopPane()

CXTPDockingPaneBase * GetTopPane ( ) const

Retrieves the top-level virtual container for the site window.

The top-level container is always the splitter container (xtpPaneTypeSplitterContainer).

Returns
The top-level virtual container for the site window.

◆ HideClient()

void HideClient ( BOOL bHide )

Call this member to hide the client area.

Parameters
bHide TRUE to hide the client area.

◆ HidePane() [1/2]

virtual void HidePane ( CXTPDockingPaneBase * pPane )
virtual

Call this member to hide a pane.

Parameters
pPane Pane to hide.

◆ HidePane() [2/2]

virtual void HidePane ( int nID )
virtual

Call this member to hide a pane.

Parameters
nID Pane's identifier.

◆ InstallDockingPanes()

virtual bool InstallDockingPanes | ( | CWnd * | pParent,
 |  | bool | bClipChildren = true )
 virtual

Call this member function to install docking panes.

Parameters
pParent | Parent frame of the panes.
bClipChildren | 'true' to add WS_CLIPCHILDREN and WS_CLIPSIBLING styles to frame windows so panes are displayed correctly from a hidden state.
Returns
'true' if the Docking Pane manager was correctly initialized, otherwise 'false'.

You must call this member function first to initialize the Docking Pane manager. This must be called first before any other member functions are called.

◆ IsAlphaDockingContext()

AFX_INLINE BOOL IsAlphaDockingContext ( ) const

Call this member to determine if alpha docking context is used when panes are being dragged and dropped.

Returns
TRUE if AlphaDockingContext is enabled, FALSE if it is disabled.

AlphaDockingContext must be TRUE if docking context stickers will be used.

See also
SetAlphaDockingContext, IsShowDockingContextStickers, SetShowDockingContextStickers

◆ IsCaptionMaximizeButtonsVisible()

AFX_INLINE BOOL IsCaptionMaximizeButtonsVisible ( ) const

Determines if Maximize/Restore buttons for non-floating docking panes are visible.

Returns
TRUE if Maximize/Restore buttons for non-floating docking panes are visible.
See also
ShowCaptionMaximizeButton, ShowFloatingCaptionMaximizeButton, IsFloatingCaptionMaximizeButtonsVisible

◆ IsClientHidden()

AFX_INLINE BOOL IsClientHidden ( ) const

Checks if the client area is hidden.

Returns
TRUE if the client area is hidden, otherwise FALSE.

◆ IsFloatingCaptionMaximizeButtonsVisible()

AFX_INLINE BOOL IsFloatingCaptionMaximizeButtonsVisible ( ) const

Determines if Maximize/Restore buttons for floating docking panes are visible.

Returns
TRUE if Maximize/Restore buttons for floating docking panes are visible.
See also
ShowCaptionMaximizeButton, ShowFloatingCaptionMaximizeButton, IsCaptionMaximizeButtonsVisible

◆ IsFloatingFrameThemeEnabled()

AFX_INLINE BOOL IsFloatingFrameThemeEnabled ( ) const

Determines if themes are used for floating frames.

Returns
TRUE if themes are used for floating frames, otherwise FALSE.

◆ IsKeyboardNavigateEnabled()

AFX_INLINE BOOL IsKeyboardNavigateEnabled ( ) const

Determines if keyboard navigate options are enabled.

Returns
A combination of XTPDockingPaneKeyboardNavigate flags indicating which keys can be used to navigate panes.
See also
EnableKeyboardNavigate, XTPDockingPaneKeyboardNavigate

◆ IsLayoutRTL()

BOOL IsLayoutRTL ( ) const

Call this member to determine if the current layout is Right-to-Left (RTL).

Returns
TRUE if the current layout is Right-to-Left (RTL), FALSE if the current layout is Left-to-Right.

◆ IsPaneClosed() [1/2]

BOOL IsPaneClosed ( CXTPDockingPane * pPane ) const

Call this member to check if a pane is closed.

Parameters
pPane Pointer to a CXTPDockingPane object.
Returns
TRUE if the pane is closed.

◆ IsPaneClosed() [2/2]

AFX_INLINE BOOL IsPaneClosed ( int nID ) const

Call this member to check if a pane is closed.

Parameters
nID Pane's identifier.
Returns
TRUE if the pane is closed.

◆ IsPaneHidden() [1/2]

BOOL IsPaneHidden ( CXTPDockingPane * pPane ) const

Call this member to check if a pane is hidden.

Parameters
pPane Pointer to a CXTPDockingPane object.
Returns
TRUE if the pane is hidden.

◆ IsPaneHidden() [2/2]

AFX_INLINE BOOL IsPaneHidden ( int nID ) const

Call this member to check if a pane is hidden.

Parameters
nID Pane's identifier.
Returns
TRUE if the pane is hidden.

◆ IsPaneSelected() [1/2]

BOOL IsPaneSelected ( CXTPDockingPane * pPane ) const

Call this member to check if a pane is selected.

Parameters
pPane Pointer to a CXTPDockingPane object.
Returns
TRUE if the pane is selected.

◆ IsPaneSelected() [2/2]

AFX_INLINE BOOL IsPaneSelected ( int nID ) const

Call this member to check if a pane is selected.

Parameters
nID Pane's identifier.
Returns
TRUE if the pane is selected.

◆ IsShowDockingContextStickers()

AFX_INLINE BOOL IsShowDockingContextStickers ( ) const

Call this member to determine whether docking context stickers are used.

Returns
TRUE if docking context stickers are used, FALSE if they are not used.
See also
SetAlphaDockingContext, IsAlphaDockingContext, SetShowDockingContextStickers

◆ IsSideDockingEnabled()

AFX_INLINE BOOL IsSideDockingEnabled ( ) const

Determines if side docking is enabled.

Returns
TRUE if side docking is enabled, FALSE if side docking is disabled.
See also
SideDocking, SetSideDockingMargin, EnableSideDocking

◆ IsSplittersLocked()

AFX_INLINE BOOL IsSplittersLocked ( ) const

Call this member to determine if the splitters are locked.

Returns
TRUE if the splitters are locked, otherwise FALSE.

◆ IsSplitterTrackerUsed()

AFX_INLINE BOOL IsSplitterTrackerUsed ( ) const

Call this member to determine if the splitter tracker is used.

Returns
TRUE if the splitter tracker is used, otherwise FALSE.
See also
UseSplitterTracker

◆ IsStickyFloatingFrames()

AFX_INLINE BOOL IsStickyFloatingFrames ( ) const

Determines if sticky floating frames are enabled.

Returns
TRUE if sticky floating frames are enabled, otherwise FALSE.

◆ LockSplitters()

void LockSplitters ( BOOL bLock = TRUE )

Call this method to lock the splitters.

Parameters
bLock TRUE to prevent splitter window panes from being resized.

◆ NormalizeSplitters()

void NormalizeSplitters ( )

Call this method to save the current splitter positions for all splitter containers.

See also
CXTPDockingPaneSplitterContainer

◆ NotifyAction()

BOOL NotifyAction | ( | XTPDockingPaneAction | action,
 |  | CXTPDockingPane * | pPane,
 |  | CXTPDockingPaneBase * | pDockContainer = NULL,
 |  | XTPDockingPaneDirection | dockDirection = xtpPaneDockLeft )

The framework calls this method when a docking pane is performing an action.

Parameters
action | The action that the docking pane is performing.
pPane | The pane performing the action.
pDockContainer | Object used to provide additional information about where a pane will be/has been docked.
dockDirection | Specifies the direction where a pane is docking.
Returns
TRUE if the action was successful, FALSE if the action was cancelled or failed.

◆ NotifyOwner()

virtual LRESULT NotifyOwner | ( | UINT | nCode,
 |  | LPARAM | lParam )
 virtual

This member is called to notify the parent window that an event has occurred in the docking pane.

Parameters
nCode | Specifies the event that has occurred.
lParam | Additional message-specific information.
Returns
Window message processing result.

◆ OnActivatePane()

virtual void OnActivatePane | ( | BOOL | bActive,
 |  | CXTPDockingPane * | pPane )
 virtual

This method is called when a pane is activated/deactivated.

Parameters
bActive | TRUE if the pane was activated, FALSE if the pane was deactivated.
pPane | The pane that was activated/deactivated.

◆ OnCreatePane()

virtual CXTPDockingPaneBase * OnCreatePane | ( | XTPDockingPaneType | type,
 |  | CXTPDockingPaneLayout * | pLayout )
 virtual

This method is called when a pane is created.

Parameters
type | Type of pane that was created.
pLayout | Pointer to a CXTPDockingPaneLayout object.
Returns
A pointer to the newly created pane.

◆ OnSetPreviewMode()

void OnSetPreviewMode ( BOOL bPreview )

Call this member function to set the application's panes into and out of print-preview mode.

Parameters
bPreview Specifies whether or not to place the application in print-preview mode. TRUE to place in print preview, FALSE to cancel print preview mode.

◆ RecalcFrameLayout()

void RecalcFrameLayout | ( | CXTPDockingPaneBase * | pPane,
 |  | BOOL | bDelay = FALSE )

This method is called to recalculate a pane's site layout.

Parameters
pPane | Pane whose site layout must be recalculated.
bDelay | TRUE to recalculate after a small delay.

◆ SetAlphaDockingContext()

AFX_INLINE void SetAlphaDockingContext ( BOOL bAlphaDockingContext )

Call this member to specify whether an alpha docking context is used to indicate where a pane can be docked while dragging the pane.

Parameters
bAlphaDockingContext TRUE to enable alpha colorization while docking.

Specifies whether the area that a docking pane can occupy is shaded in gray as the pane is dragged to its new location. The shaded area indicates the area on the application the docking pane will occupy if docked in that location. AlphaDockingContext must be TRUE if docking context stickers will be used.

See also
IsAlphaDockingContext, IsShowDockingContextStickers, SetShowDockingContextStickers

◆ SetAnimationDelay()

void SetAnimationDelay | ( | double | dAnimationDelay = -1,
 |  | int | nAnimationDuration = 128,
 |  | int | nAnimationInterval = 16 )

Call this member to set the animation speed.

Parameters
dAnimationDelay | Must be -1 to use nAnimationDuration and nAnimationInterval.
nAnimationDuration | Total time of the animation, in milliseconds.
nAnimationInterval | Amount of time to rest, in milliseconds, between each animation step.

To disable the animation, set nAnimationDuration = 0.

See also
GetAnimationDelay

◆ SetCaptionDirection()

AFX_INLINE void SetCaptionDirection ( XTPDockingPaneCaptionDirection captionDirection )

Call this member to set the direction of captions.

Parameters
captionDirection An XTPDockingPaneCaptionDirection flag indicating which direction the pane captions are to be displayed.

captionDirection parameter can be one of the following: xtpPaneCaptionHorizontal xtpPaneCaptionVertical xtpPaneCaptionAutoByPosition xtpPaneCaptionAutoBySize

Example: m_paneManager.GetPaintManager()->SetCaptionDirection(xtpPaneCaptionAutoSize);

◆ SetClientMargin()

AFX_INLINE void SetClientMargin ( int nMargin )

Sets the width for the client margin.

Parameters
nMargin Width, in pixels, for the client margin.

◆ SetClientMargins()

AFX_INLINE void SetClientMargins ( CRect rcClientMargins )

Sets the width for each side of the client margin (left, top, right, and bottom) individually using a CRect object.

Parameters
rcClientMargins A CRect object representing the width, in pixels, for each side of the client margin. Use the left, top, right, and bottom members to specify the width for each side of the client margin.

◆ SetCustomTheme()

void SetCustomTheme ( CXTPDockingPanePaintManager * pTheme )

Call this member to set a custom theme.

See the DockingPane sample as a sample of creating a new theme.

Parameters
pTheme New Theme.

◆ SetDefaultPaneOptions()

AFX_INLINE void SetDefaultPaneOptions ( DWORD dwOptions )

Call this method to set the default options used for each pane.

Parameters
dwOptions Options applied for each pane. Can be any of the values listed in the Remarks section.

dwOptions parameter can be one or more of the following: xtpPaneNoCloseable: Indicates that the pane cannot be closed. xtpPaneNoHideable: Indicates that the pane cannot be hidden. xtpPaneNoFloatable: Indicates that the pane cannot be floated. xtpPaneNoCaption: Indicates that the pane has no caption.

See also
GetDefaultPaneOptions, CXTPDockingPane::SetOptions, XTPDockingPaneOptions

◆ SetDockingContext()

void SetDockingContext ( CXTPDockingPaneContext * pDockingContext )

Call this method to use a custom docking context.

Parameters
pDockingContext Pointer to a CXTPDockingPaneContext object.

◆ SetDockingContextStickerStyle()

AFX_INLINE void SetDockingContextStickerStyle ( XTPDockingContextStickerStyle style )

Call this member to set the style for docking context stickers.

Parameters
style Style for docking context stickers.

Call SetShowDockingContextStickers to enable Stickers. Style parameter can be one of the following: xtpPaneStickerStyleVisualStudio2005Beta: Visual Studio 2005 Beta stickers. xtpPaneStickerStyleVisualStudio2005: Visual Studio 2005 stickers.

See also
SetShowDockingContextStickers, GetDockingContextStickerStyle

◆ SetFloatingFrameCaption()

AFX_INLINE void SetFloatingFrameCaption ( LPCTSTR lpszCaption )

Call this method to set the common caption for floating frames.

Parameters
lpszCaption Caption to be set.

◆ SetFloatingFramesOpacity()

void SetFloatingFramesOpacity ( int nOpacity )

Call this method to set the opacity for inactive floating frames.

Parameters
nOpacity Alpha value. When nOpacity is 0, the window is completely transparent. When nOpacity is 255, the window is opaque.

◆ SetIcon()

void SetIcon | ( | UINT | nID,
 |  | const CXTPImageManagerIconHandle & | hIcon )

Call this member to set an icon to the pane.

Parameters
nID | Docking pane's identifier.
hIcon | Icon handle.

◆ SetIcons()

BOOL SetIcons | ( | UINT | nIDResource,
 |  | const int * | nIDs,
 |  | int | nCount,
 |  | COLORREF | clrMask = 0xC0C0C0 )

Call this member to set icons to panes.

Parameters
nIDResource | Resource identifier.
nIDs | Pointer to an array of pane IDs.
nCount | Number of elements in the array pointed to by nIDs.
clrMask | An RGB value of a transparent color.
Returns
TRUE if successful, otherwise FALSE.

◆ SetImageManager()

void SetImageManager ( CXTPImageManager * pImageManager )

Call this member to set the image manager for docking panes.

Parameters
pImageManager Pointer to a CXTPImageManager object.

◆ SetKeyboardWindowSelectClass()

AFX_INLINE void SetKeyboardWindowSelectClass ( CRuntimeClass * pWindowSelectClass )

Call this method to set a custom CXTPDockingPaneWindowSelect window that will be used to show active panes and files.

Parameters
pWindowSelectClass A CRuntimeClass pointer to a custom CXTPDockingPaneWindowSelect window.
See also
EnableKeyboardNavigate, XTPDockingPaneKeyboardNavigate

◆ SetLayout()

void SetLayout ( const CXTPDockingPaneLayout * pLayout )

Call this member to set the current layout.

Parameters
pLayout Pointer to a CXTPDockingPaneLayout object.

◆ SetShowContentsWhileDragging()

AFX_INLINE void SetShowContentsWhileDragging ( BOOL bShow = TRUE )

Call this member to set the "Show window contents while dragging" option.

Parameters
bShow TRUE to enable the "Show window contents while dragging" option.

◆ SetShowDockingContextStickers()

AFX_INLINE void SetShowDockingContextStickers ( BOOL bShowDockingContextStickers )

Call this member to specify whether Visual Studio 2005 style docking context stickers should be used while dragging a docking pane.

Parameters
bShowDockingContextStickers If TRUE, then docking stickers are drawn on the screen indicating all the possible locations that the docking pane can be docked while the pane is dragged over the application. AlphaDockingContext must also be TRUE to display the stickers.

AlphaDockingContext must be TRUE if docking context stickers will be used.

See also
SetAlphaDockingContext, IsAlphaDockingContext, IsShowDockingContextStickers, SetDockingContextStickerStyle

◆ SetSideDockingMargin()

AFX_INLINE void SetSideDockingMargin ( CRect rcMargin )

Sets the margin between the client area's edge and a docking pane docked to the edge of the client area when side docking is enabled.

Parameters
rcMargin Side docking margins (margin between the right/top/left/bottom edge of the client area and any docking panes that are docked to the left/top/right/bottom edge of the client area.)

SetSideDockingMargin sets the margins between the client areas's edge and a docking pane docked to the edge of the client area when side docking is enabled.

See also
SideDocking

◆ SetStickyFloatingFrames()

AFX_INLINE void SetStickyFloatingFrames ( BOOL bSticky )

Call this method to enable sticky floating frames.

Parameters
bSticky TRUE to enable sticky floating frames, FALSE otherwise.

◆ SetTheme()

void SetTheme ( XTPDockingPanePaintTheme theme )

Call this member to switch the visual theme of the panes.

Parameters
theme New visual theme. Can be any of the values listed in the Remarks section.

theme can be one of the following: xtpPaneThemeDefault: Enables the default theme. xtpPaneThemeVisualStudio2003: Enables Visual Studio .NET style theme. xtpPaneThemeGrippered: Enables Visual Studio 6 style theme. xtpPaneThemeOffice2002Visio: Enables Visio style theme. xtpPaneThemeOffice2003: Enables Office 2003 style theme. xtpPaneThemeWinNative: Enables XP Theme. xtpPaneThemeVisualStudio2005Beta1: Enables Visual Studio 2005 Beta 1 theme.

◆ ShowCaptionMaximizeButton()

AFX_INLINE void ShowCaptionMaximizeButton ( BOOL bShowMaximizeButton )

Call this method to show Maximize/Restore buttons for non-floating docking panes.

Parameters
bShowMaximizeButton TRUE to show Maximize/Restore buttons for non-floating docking panes.
See also
ShowFloatingCaptionMaximizeButton, IsCaptionMaximizeButtonsVisible, IsFloatingCaptionMaximizeButtonsVisible

◆ ShowFloatingCaptionMaximizeButton()

AFX_INLINE void ShowFloatingCaptionMaximizeButton ( BOOL bShowMaximizeButton )

Call this method to show Maximize/Restore buttons for floating docking panes.

Parameters
bShowMaximizeButton TRUE to show Maximize/Restore buttons for floating docking panes.
See also
ShowCaptionMaximizeButton, IsFloatingCaptionMaximizeButtonsVisible, IsCaptionMaximizeButtonsVisible

◆ ShowPane() [1/2]

virtual void ShowPane | ( | CXTPDockingPane * | pPane,
 |  | BOOL | bSetFocus = TRUE )
 virtual

Call this member to show (activate) a pane.

Parameters
pPane | Pane to show.
bSetFocus | TRUE to set focus to the selected pane.

◆ ShowPane() [2/2]

AFX_INLINE void ShowPane | ( | int | nID,
 |  | BOOL | bSetFocus = TRUE )
 virtual

Call this member to show (activate) a pane.

Parameters
nID | Pane's identifier.
bSetFocus | TRUE to set focus to the selected pane.

◆ SyncActiveFloatingFrames()

void SyncActiveFloatingFrames ( BOOL bSyncActiveFloatingFrames )

Call this member to keep the activation of floating frames windows in sync with the activation of the top-level frame window.

Parameters
bSyncActiveFloatingFrames TRUE to synchronizes the activation of the mini-frame window to the activation of its parent window.

◆ ToggleAutoHide()

virtual void ToggleAutoHide ( CXTPDockingPaneBase * pPane )
virtual

Call this member to switch the pane's auto-hide (docking/auto-hide).

Parameters
pPane Docking Pane.

◆ ToggleDocking()

virtual void ToggleDocking ( CXTPDockingPaneBase * pPane )
virtual

Call this member to switch the pane's position (docking/floating).

Parameters
pPane Docking Pane.

◆ UseSplitterTracker()

AFX_INLINE void UseSplitterTracker ( BOOL bSplitterTracker )

Call this member to use the splitter tracker.

Parameters
bSplitterTracker TRUE to use the splitter tracker.

If bSplitterTracker is set to FALSE, then this member function will display the contents of a child pane while the splitter is resized.

See also
IsSplitterTrackerUsed

Member Data Documentation

◆ m_bAlphaDockingContext

BOOL m_bAlphaDockingContext
protected

If TRUE, then alpha docking context is used when dragging a pane.

The shaded area indicates the panes new location if dropped.

◆ m_bCloseGroupOnButtonClick

BOOL m_bCloseGroupOnButtonClick

If TRUE, when the close button on a group of panes is clicked, then the entire group of panes is closed.

If FALSE, then only the currently visible pane in the group will be closed.

◆ m_bHideGroupOnButtonClick

BOOL m_bHideGroupOnButtonClick

If TRUE, when the hide button on a group of panes is clicked, then the entire group of panes is hidden.

If FALSE, then only the currently visible pane in the group will be hidden.

◆ m_bLockSplitters

BOOL m_bLockSplitters
protected

If TRUE, then you can not resize the panes when they are docked.

However, panes can be resized via code and when they are floated.

◆ m_bShowDockingContextStickers

BOOL m_bShowDockingContextStickers
protected

If TRUE, then docking context stickers are drawn when the pane is being dragged and dropped.

m_bAlphaDockingContext must be TRUE.

◆ m_bUseSplitterTracker

BOOL m_bUseSplitterTracker
protected

If TRUE, then splitter trackers are used.

When resizing a docking pane, an outline of the pane is drawn as the splitter is dragged. If FALSE, then the docking pane will be resized in "real-time."

◆ m_rcSideDockingMargin

CRect m_rcSideDockingMargin
protected

Side docking margin.

This is the margin between the client area's edge and a docking pane docked to the edge of the client area when side docking is enabled.

◆ m_strFloatingFrameCaption

CString m_strFloatingFrameCaption
protected

The caption that is displayed in the title bar of a floating frame that has panes docked.

This is the floating frame that contains other docking panes.

The documentation for this class was generated from the following file:
  • XTPDockingPaneManager.h


Toolkit Pro: CXTPDockingPaneMiniWnd Class Reference

Public Member Functions | Static Public Attributes | Protected Member Functions | Protected Attributes | List of all members
CXTPDockingPaneMiniWnd Class Reference

CXTPDockingPaneMiniWnd is a multiple inheritance class derived from CMiniFrameWnd and CXTPDockingPaneBase. More...

Inheritance diagram for CXTPDockingPaneMiniWnd:
[legend]

Public Member Functions

BOOL | IsActive () const
Determines if the frame is active.
virtual BOOL | IsCaptionVertical () const
Determines if the caption is drawn vertically.
void | Expand ()
Call this method to expand a collapsed frame.
CXTPDockingPaneSplitterContainer * | GetTopPane () const
Retrieves the top-level container of a floating frame.
BOOL | IsCollapsed () const
Determines if the frame is collapsed.
void | Collapse (BOOL bDelay=FALSE)
This method is called to collapse the frame.
CString | GetTitle () const
Call this member to get the text in the caption for the tabbed container (group of panes).
- Public Member Functions inherited from CXTPDockingPaneBase
XTPDockingPaneType | GetType () const
Call this member to determine the type of the pane.
CRect | GetPaneWindowRect () const
The GetPaneWindowRect function retrieves the dimensions of the bounding rectangle of the pane.
CXTPDockingPaneBase * | GetContainer () const
Call this member function to retrieve the parent container of the pane.
CXTPDockingPaneManager * | GetDockingPaneManager () const
Call this member function to retrieve the pane manager.
CXTPDockingPanePaintManager * | GetPaintManager () const
Call this member function to retrieve the paint manager.
CXTPDockingPaneCaptionButton * | FindCaptionButton (int nID) const
Call this member to find the specified caption button.
CXTPDockingPaneCaptionButtons * | GetCaptionButtons () const
Call this member to get a reference to the caption's close/pop-up button.
virtual POSITION | ContainPane (CXTPDockingPaneBase *pPane) const
Call this member to determine if one pane is contained in the collection of another.
virtual BOOL | IsEmpty () const
Call this member to determine if there are no children panes.
virtual CWnd * | GetDockingSite () const
Call this member function to retrieve the parent window for the pane.
virtual BOOL | IsHidden () const
Call this member to check if the pane is hidden.

Static Public Attributes

static BOOL m_bShowPinButton
TRUE to show pin button of the frame.

Protected Member Functions

CXTPDockingPaneMiniWnd (CXTPDockingPaneLayout *pLayout)
Constructs a CXTPDockingPaneMiniWnd object.
~CXTPDockingPaneMiniWnd ()
Destroys a CXTPDockingPaneMiniWnd object, handles cleanup and deallocation.
virtual void | Copy (CXTPDockingPaneBase *pClone, CXTPPaneToPaneMap *pMap, DWORD dwIgnoredOptions)
Copies self data from another pane.
virtual void | Init (CXTPDockingPaneBase *pPane, CRect rc)
Initializes the frame window.
virtual void | RemovePane (CXTPDockingPaneBase *pPane)
Call this member to remove a pane from the collection.
virtual void | OnChildContainerChanged (CXTPDockingPaneBase *pContainer)
This member is called when a child pane collection is changed.
virtual BOOL | DoPropExchange (CXTPPropExchange *pPX)
Call this member function to save/restore the settings of the pane.
virtual BOOL | Create (CRect rc)
Creates a frame window.
virtual void | OnCaptionButtonClick (CXTPDockingPaneCaptionButton *pButton)
This member is called by the framework when a caption button is clicked.
virtual BOOL | OnCaptionButtonDown (CXTPDockingPaneCaptionButton *pButton)
This member is called by the framework when the mouse button is pressed on a caption button.
CXTPDockingPane * | GetSelectedPane () const
Call this member to determine the currently selected pane.
virtual BOOL | IsCaptionButtonVisible (CXTPDockingPaneCaptionButton *pButton)
Call this member to determine if a caption button is visible.
BOOL | IsThemed () const
Call this member to determine if themed floating panes are used.
void | OnThemedChanged ()
This member is called when the theme is changed.
void | RedrawPane ()
Call this member to redraw the pane.
virtual HWND | GetPaneHwnd () const
Retrieves the window handle for a window.
void | GetMinMaxInfo (LPMINMAXINFO pMinMaxInfo) const
Call this member to get the min/max information for the pane window.
void | DoSlideStep (BOOL bActivate=FALSE)
This method is called to animate a collapsed frame.
void | OnPinButtonClick ()
This member is called when the "pin" caption button is clicked.
virtual void | InvalidatePane (BOOL bSelectionChanged)
This member is called when a pane must be redrawn.
virtual void | UpdateWindowOpacity ()
This member is called to update the opacity of a floating frame.
void | OnFocusChanged ()
This method is called when focus is changed inside the application.
virtual void | FindPane (XTPDockingPaneType type, CXTPDockingPaneBaseList *pList) const
Call this member to retrieve a collection of the panes with a specified type.
BOOL | OnAction (XTPDockingPaneAction action)
This method is called if some action occurs.
void | CreateContainer ()
Creates a docking container.
- Protected Member Functions inherited from CXTPDockingPaneBase
CXTPDockingPaneBase (XTPDockingPaneType type, CXTPDockingPaneLayout *pLayout)
Protected constructor.
virtual | ~CXTPDockingPaneBase ()
Destroys a CXTPDockingPaneBase object, handles cleanup and deallocation.
virtual void | OnSizeParent (CWnd *pParent, CRect rect, LPVOID lParam)
This method is called to set the position of the pane.
virtual void | SetDockingSite (CWnd *pFrame)
Call this member to set the parent frame of the pane.
virtual void | SetParentContainer (CXTPDockingPaneBase *pContainer)
Call this method to set the parent container of the pane.
virtual void | OnParentContainerChanged (CXTPDockingPaneBase *pContainer)
This member is called when the parent pane collection is changed.
virtual CXTPDockingPaneBase * | Clone (CXTPDockingPaneLayout *pLayout, CXTPPaneToPaneMap *pMap, DWORD dwIgnoredOptions=0)
This member is called to clone the pane.
virtual void | OnCaptionButtonRectChanged (CXTPDockingPaneCaptionButton *pButton)
This member is called when the dimensions of the caption button are changed.
virtual void | DeletePane ()=0
This method is called to destroy a pane.

Protected Attributes

CXTPDockingPaneSplitterContainer * | m_pTopContainer
Top-level container.
BOOL | m_bCloseEnabled
Close button of frame is enabled.
int | m_nExpandedHeight
Expanded height of the frame.
int | m_nStepsCount
Total steps of animation process.
int | m_nSlideStep
Current step of the animation process.
int | m_nDeactivationCount
Deactivation counter.
BOOL | m_bCollapsed
Pane is collapsed.
BOOL | m_bExpanded
Pane is expanded.
BOOL | m_bSlideOut
Pane is currently expanding.
BOOL | m_bDelayInvalidate
TRUE to redraw the frame after a small delay.
- Protected Attributes inherited from CXTPDockingPaneBase
CSize | m_szDocking
Size of the pane.
CXTPDockingPaneLayout * | m_pLayout
Parent layout.
CXTPDockingPaneBase * | m_pParentContainer
Parent container.
CWnd * | m_pDockingSite
Parent frame.
XTPDockingPaneType | m_type
Type of the pane.
CRect | m_rcWindow
Position of the pane.
CXTPDockingPaneCaptionButtons * | m_pCaptionButtons
Collection of caption buttons.

Detailed Description

CXTPDockingPaneMiniWnd is a multiple inheritance class derived from CMiniFrameWnd and CXTPDockingPaneBase.

It is used internally as a MiniWnd container for CXTPDockingPaneBase derived classes.

Constructor & Destructor Documentation

◆ CXTPDockingPaneMiniWnd()

CXTPDockingPaneMiniWnd ( CXTPDockingPaneLayout * pLayout )
protected

Constructs a CXTPDockingPaneMiniWnd object.

Parameters
pLayout Parent layout pointer.

Member Function Documentation

◆ Collapse()

void Collapse ( BOOL bDelay = FALSE )

This method is called to collapse the frame.

Parameters
bDelay TRUE to collapse the frame after a small delay with an animation.

◆ Copy()

virtual void Copy | ( | CXTPDockingPaneBase * | pClone,
 |  | CXTPPaneToPaneMap * | pMap,
 |  | DWORD | dwIgnoredOptions )
 protectedvirtual

Copies self data from another pane.

Parameters
pMap | Internal parameter to map a pane to the copied pane.
dwIgnoredOptions | Options that must be skipped.
pClone | Pointer to a CXTPDockingPaneSidePanel object.
See also
CXTPPaneToPaneMap

Reimplemented from CXTPDockingPaneBase.

◆ Create()

virtual BOOL Create ( CRect rc )
protectedvirtual

Creates a frame window.

Parameters
rc Specifies the size and position of the window.
Returns
Nonzero if initialization was successful, otherwise 0.

◆ DoPropExchange()

virtual BOOL DoPropExchange ( CXTPPropExchange * pPX )
protectedvirtual

Call this member function to save/restore the settings of the pane.

Parameters
pPX Pointer to a CXTPPropExchange object.
Returns
TRUE if successful, otherwise FALSE.

Reimplemented from CXTPDockingPaneBase.

◆ DoSlideStep()

void DoSlideStep ( BOOL bActivate = FALSE )
protected

This method is called to animate a collapsed frame.

Parameters
bActivate TRUE to activate the frame.

◆ FindPane()

virtual void FindPane | ( | XTPDockingPaneType | type,
 |  | CXTPDockingPaneBaseList * | pList ) const
 protectedvirtual

Call this member to retrieve a collection of the panes with a specified type.

Parameters
type | Type of the panes to find.
pList | Pointer to a CXTPDockingPaneBaseList object that will contain found panes.
See also
CXTPDockingPaneBaseList

Reimplemented from CXTPDockingPaneBase.

◆ GetMinMaxInfo()

void GetMinMaxInfo ( LPMINMAXINFO pMinMaxInfo ) const
protectedvirtual

Call this member to get the min/max information for the pane window.

Parameters
pMinMaxInfo LPMINMAXINFO to fill with the min/max information.

Reimplemented from CXTPDockingPaneBase.

◆ GetPaneHwnd()

AFX_INLINE HWND GetPaneHwnd ( ) const
protectedvirtual

Retrieves the window handle for a window.

Returns
The window handle for a window if successful. NULL if the HWND is not attached to a window or if it is used with a NULL HWND pointer.

Reimplemented from CXTPDockingPaneBase.

◆ GetSelectedPane()

CXTPDockingPane * GetSelectedPane ( ) const
protected

Call this member to determine the currently selected pane.

Returns
A pointer to the currently selected pane.

◆ GetTitle()

AFX_INLINE CString GetTitle ( ) const
virtual

Call this member to get the text in the caption for the tabbed container (group of panes).

Returns
The text in the caption for the tabbed container (group of panes).

Reimplemented from CXTPDockingPaneBase.

◆ GetTopPane()

AFX_INLINE CXTPDockingPaneSplitterContainer * GetTopPane ( ) const

Retrieves the top-level container of a floating frame.

Returns
A pointer to the top-level container of a floating frame.

◆ Init()

virtual void Init | ( | CXTPDockingPaneBase * | pPane,
 |  | CRect | rc )
 protectedvirtual

Initializes the frame window.

Parameters
pPane | Child pane that will be placed to the frame.
rc | Rectangle of the floating frame.

◆ InvalidatePane()

virtual void InvalidatePane ( BOOL bSelectionChanged )
protectedvirtual

This member is called when a pane must be redrawn.

Parameters
bSelectionChanged TRUE if the selected pane was changed.

Reimplemented from CXTPDockingPaneBase.

◆ IsActive()

AFX_INLINE BOOL IsActive ( ) const
virtual

Determines if the frame is active.

Returns
TRUE if the frame is active.

Reimplemented from CXTPDockingPaneBase.

◆ IsCaptionButtonVisible()

virtual BOOL IsCaptionButtonVisible ( CXTPDockingPaneCaptionButton * pButton )
protectedvirtual

Call this member to determine if a caption button is visible.

Parameters
pButton Caption button pointer.
Returns
TRUE if the caption button is visible, otherwise FALSE.

Reimplemented from CXTPDockingPaneBase.

◆ IsCaptionVertical()

AFX_INLINE BOOL IsCaptionVertical ( ) const
virtual

Determines if the caption is drawn vertically.

Returns
TRUE if the caption is drawn vertically.

Reimplemented from CXTPDockingPaneBase.

◆ IsCollapsed()

AFX_INLINE BOOL IsCollapsed ( ) const

Determines if the frame is collapsed.

Returns
True if collapse, false otherwise

◆ IsThemed()

BOOL IsThemed ( ) const
protected

Call this member to determine if themed floating panes are used.

Returns
TRUE is themed floating panes are used, otherwise FALSE.

◆ OnAction()

BOOL OnAction ( XTPDockingPaneAction action )
protected

This method is called if some action occurs.

Parameters
action Docking pane action.
Returns
TRUE if the action was canceled.

◆ OnCaptionButtonClick()

virtual void OnCaptionButtonClick ( CXTPDockingPaneCaptionButton * pButton )
protectedvirtual

This member is called by the framework when a caption button is clicked.

Parameters
pButton Caption button that was clicked.

◆ OnCaptionButtonDown()

virtual BOOL OnCaptionButtonDown ( CXTPDockingPaneCaptionButton * pButton )
protectedvirtual

This member is called by the framework when the mouse button is pressed on a caption button.

Parameters
pButton Caption button that is being clicked.
Returns
True when caption button is pressed, false otherwise

◆ OnChildContainerChanged()

virtual void OnChildContainerChanged ( CXTPDockingPaneBase * pContainer )
protectedvirtual

This member is called when a child pane collection is changed.

Parameters
pContainer Pointer to the CXTPDockingPaneBase object that was changed.

Reimplemented from CXTPDockingPaneBase.

◆ RemovePane()

virtual void RemovePane ( CXTPDockingPaneBase * pPane )
protectedvirtual

Call this member to remove a pane from the collection.

Parameters
pPane Pointer to a CXTPDockingPaneBase object to remove.

Reimplemented from CXTPDockingPaneBase.

◆ UpdateWindowOpacity()

virtual void UpdateWindowOpacity ( )
protectedvirtual

This member is called to update the opacity of a floating frame.

See also
CXTPDockingPaneManager::SetFloatingFramesOpacity
The documentation for this class was generated from the following file:
  • XTPDockingPaneMiniWnd.h


Toolkit Pro: CXTPDockingPaneNativeWindows10Theme Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPDockingPaneNativeWindows10Theme Class Reference

CXTPDockingPaneNativeWindows10Theme is used to define drawing routines specific to a Native Windows 10 docking pane theme. More...

Inheritance diagram for CXTPDockingPaneNativeWindows10Theme:
[legend]

Public Member Functions

CXTPDockingPaneNativeWindows10Theme ()
Constructs a CXTPDockingPaneNativeWindows10Theme object.
virtual | ~CXTPDockingPaneNativeWindows10Theme ()
Destroys a CXTPDockingPaneNativeWindows10Theme object, handles cleanup and deallocation.
virtual void | RefreshMetrics ()
This member function is used to initialize default colors for a theme from an .INI resource.
virtual void | DrawSplitter (CDC *pDC, CXTPDockingPaneSplitterWnd *pSplitter)
Override this method to draw a splitter.
virtual void | DrawAutoHidePanel (CDC *pDC, CRect rc, XTPDockingPaneDirection direction)
This method is called by the framework to draw the docking pane auto-hide panel background and splitter.
- Public Member Functions inherited from CXTPDockingPaneVisualStudio2012Theme
CXTPDockingPaneVisualStudio2012Theme ()
Constructs a CXTPDockingPaneVisualStudio2012Theme object.
virtual | ~CXTPDockingPaneVisualStudio2012Theme ()
Destroys a CXTPDockingPaneVisualStudio2012Theme object, handles cleanup and deallocation.
virtual CRect | GetPaneCaptionRect (const CXTPDockingPaneSidePanel *pPane)
Call this method to get the pane's caption rectangle.
virtual void | AdjustClientRect (CXTPDockingPaneTabbedContainer *pPane, CRect &rc, BOOL bApply)
Override this member to change the client rectangle of the child docking pane.
virtual void | AdjustCaptionRect (const CXTPDockingPaneTabbedContainer *pPane, CRect &rc)
Override this member to change the caption rectangle of the child docking pane.
virtual void | DrawCaption (CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc)
Override this member function to draw a caption.
virtual void | DrawFloatingFrame (CDC *pDC, CXTPDockingPaneMiniWnd *pPane, CRect rc)
Call this method to draw the frame of a floating window.
virtual void | DrawPane (CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc)
Override this member function to draw a tabbed container.
virtual void | DrawSidePanel (CDC *pDC, CXTPDockingPaneSidePanel *pPane, CRect rc)
Override this member function to draw the side panel.
virtual void | DrawCaptionButton (CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton)
Override this member function to draw a button for a tabbed caption.
- Public Member Functions inherited from CXTPDockingPaneDefaultTheme
CXTPDockingPaneDefaultTheme ()
Constructs a CXTPDockingPaneDefaultTheme object.
- Public Member Functions inherited from CXTPDockingPanePaintManager
virtual void | DrawCaptionButtons (CDC *pDC, CXTPDockingPaneCaptionButtons *pButtons, CRect &rcCaption, COLORREF clr, int nButtonSize, int nButtonGap, BOOL bVertical=FALSE)
Override this member function to draw buttons for a tabbed caption.
virtual void | AdjustClientRect (CXTPDockingPaneSidePanel *pPane, CRect &rect)
Override this member to change the client rectangle of the child docking pane.
virtual void | AdjustCaptionRect (const CXTPDockingPaneSidePanel *pPane, CRect &rc)
Override this member to change the caption rectangle of the child docking pane.
virtual void | GetCaptionRect (const CXTPDockingPaneTabbedContainer *pPane, CRect &rc)
Call this method to get a caption rectangle.
virtual CRect | GetCaptionGripperRect (const CXTPDockingPaneTabbedContainer *pPane)
Call this method to get a caption gripper for a tabbed container.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1, int nPen)
Draws a line.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1)
Draws a line.
int | DrawCaptionText (CDC *pDC, const CString &strTitle, CRect rc, BOOL bVertical, BOOL bCalcWidth=FALSE)
Draws the text of a pane caption.
void | Pixel (CDC *pDC, int xPos, int yPos, int nPen)
Sets the pixel at the point.
void | Rectangle (CDC *pDC, CRect rc, int nPenEntry, int nPenBorder)
Draws a rectangle.
void | UseOfficeFont (BOOL bUseOfficeFont)
Call this member to use Office (Tahoma) font.
void | SetCaptionFontIndirect (LOGFONT *pLogFont, BOOL bUseStandardFont=FALSE)
Call this method to set the caption's font.
CXTPTabPaintManager * | SetTabPaintManager (CXTPTabPaintManager *pManager)
Call this method to set the paint manager used to draw tabs of a tabbed container.
CXTPTabPaintManager * | SetPanelPaintManager (CXTPTabPaintManager *pManager)
Call this method to set the paint manager used to draw tabs of an auto-hide panel.
CXTPTabPaintManager * | GetTabPaintManager () const
Retrieves the paint manager used to draw tabs of a tabbed container.
CXTPTabPaintManager * | GetPanelPaintManager () const
Retrieves the paint manager used to draw tabs of an auto-hide panel.
COLORREF | GetXtremeColor (UINT nIndex)
Retrieves the current color of the specified XP display element.
void | SetColors (int cElements, CONST INT *lpaElements, CONST COLORREF *lpaRgbValues)
Call this member to set the colors for each element in an array to the colors in a specified color array.
int | GetCaptionHeight () const
Call this member to get the caption height of the tabbed container.
int | GetTabsHeight () const
Call this member to get tabs height of the tabbed container.
void | SetSplitterStyle (DWORD dwStyle)
Call this member to set the splitter style.
DWORD | GetSplitterStyle () const
Call this method to get the splitter style.
void | SetCaptionButtonStyle (XTPDockingPaneCaptionButtonStyle nStyle)
Call this member to set the caption button style.
XTPDockingPaneCaptionButtonStyle | GetCaptionButtonStyle () const
Call this method to get the caption button style.
XTPCurrentSystemTheme | GetCurrentSystemTheme () const
Call this member function to determine the current Windows XP theme in use.
void | SetLunaTheme (XTPCurrentSystemTheme systemTheme)
Call this method to force system theme.
void | SetCustomTitleBrushes (HBRUSH hbrActiveTitleHorz, HBRUSH hbrInactiveTitleHorz=NULL, HBRUSH hbrActiveTitleVert=NULL, HBRUSH hbrInactiveTitleVert=NULL, BOOL bDestroyOnCleanup=FALSE)
Sets custom title brushes.
HBRUSH | GetCustomTitleBrush (BOOL bActive, BOOL bVertical) const
Obtains the custom title brush.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

virtual void | DrawTitleBar (CDC *pDC, CXTPDockingPaneBase *pPane, CRect rc, BOOL bVertical)
This member function is called to draw a title bar for the docking pane.
- Protected Member Functions inherited from CXTPDockingPaneVisualStudio2012Theme
void | DrawGripper (CDC *pDC, CRect rcGripper, COLORREF clr, BOOL bVertical)
This member function is called to draw a gripper for the docking pane.
void | DrawDottedLine (CDC *pDC, int x, int y, int nSize, COLORREF clr, BOOL bVertical)
This member function is called to draw a dotted line.
virtual CXTPDockingPaneColorSet * | GetColorSet (BOOL bActive)
Call this member function to retrieve the active or inactive color set for the Docking Pane using the state specified by bActive.
void | SetPaneColorSets (CXTPDockingPaneColorSet *pcsActive, CXTPDockingPaneColorSet *pcsInactive)
Called to initialize the active and inactive colors sets for the docking pane theme.
void | DeletePaneColorSets ()
Called to free the memory allocated for the docking pane active and inactive color sets.
- Protected Member Functions inherited from CXTPDockingPaneDefaultTheme
virtual void | DrawCaptionPart (CDC *pDC, CXTPDockingPaneBase *pPane, CRect rcCaption, const CString &strTitle, BOOL bActive, BOOL bVertical)
Draws the common part of a tabbed and floating caption.
- Protected Member Functions inherited from CXTPDockingPanePaintManager
CXTPDockingPanePaintManager ()
Constructs a CXTPDockingPanePaintManager object.
virtual | ~CXTPDockingPanePaintManager ()
Destroys a CXTPDockingPanePaintManager object, handles cleanup and deallocation.
virtual void | DrawCaptionButtonEntry (CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton, CSize szOffset)
Draws only the glyph of a button.
virtual void | DrawCaptionButtonEntry (CDC *pDC, CXTPDockingPaneCaptionButton *pButton, CPoint pt, COLORREF clrButton)
Draws only the glyph of a button.
void | ClipAndAddEllipsisIfNeeded (CDC *pDC, CString &strTitle, int nCaptionWidth) const
Clip string and add ellipsis if its width less than nCaptionWidth.

Protected Attributes

COLORREF | m_clrCaptionBorder
Caption border color.
- Protected Attributes inherited from CXTPDockingPaneVisualStudio2012Theme
CXTPDockingPaneColorSet * | m_pcsActive
Active state docking pane colors.
CXTPDockingPaneColorSet * | m_pcsInactive
Inactive state docking pane colors.
CString | m_strFontFace
Font face name.
int | m_nFontSize
Font size in points.
- Protected Attributes inherited from CXTPDockingPanePaintManager
XTPDockingPaneCaptionButtonStyle | m_nCaptionButtonStyle
Caption button style.
DWORD | m_dwSplitterStyle
Splitter style.
int | m_nTitleHeight
Title's height.
int | m_nCaptionFontGap
Additional gap of font.
int | m_nTabsHeight
Tab bar's height.
CXTPFont | m_xtpFontTitle
Title font.
CXTPFont | m_xtpFontTitleVertical
Title vertical font.
BOOL | m_bUseOfficeFont
TRUE to use Tahoma font.
BOOL | m_bUseStandardFont
TRUE to use system icon font.
BOOL | m_bDestroyCustomTitleBrushes
If TRUE, custom title bushes will be destroyed on cleanup.
HBRUSH | m_hbrActiveTitleHorz
Optional user specified active horizontal title brush.
HBRUSH | m_hbrInactiveTitleHorz
Optional user specified inactive horizontal title brush.
HBRUSH | m_hbrActiveTitleVert
Optional user specified active vertical title brush.
HBRUSH | m_hbrInactiveTitleVert
Optional user specified inactive vertical title brush.
CXTPTabPaintManager * | m_pTabPaintManager
Paint Manager used to draw tabs for a tabbed container.
CXTPTabPaintManager * | m_pPanelPaintManager
Paint Manager used to draw tabs for an auto-hide panel.
COLORREF | m_arrColor [XPCOLOR_LAST+1]
Self colors array.
XTPDockingPanePaintTheme | m_themeCurrent
Current theme.
CString | m_strOfficeFont
Office font name.
CRect | m_rcCaptionMargin
Margins of caption.
XTPCurrentSystemTheme | m_systemTheme
Current system theme.
CXTPWinThemeWrapper * | m_themeToolbar
Toolbar theme helper.
CXTPWinThemeWrapper * | m_themeExplorer
WinXP Explorer theme helper.
CXTPWinThemeWrapper * | m_themeButton
WinXP Button theme helper.
CXTPWinThemeWrapper * | m_themeWindow
WinXP Window Theme helper.
CXTPWinThemeWrapper * | m_themeRebar
Rebar theme helper.
BOOL | m_bLunaTheme
TRUE if luna colors are used.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPDockingPanePaintManager
BOOL | m_bUseBoldCaptionFont
TRUE to use bold font for caption.
BOOL | m_bHighlightActiveCaption
TRUE to highlight active caption.
int | m_nSplitterSize
Splitter size.
BOOL | m_bShowCaption
TRUE to draw captions of tabbed containers.
BOOL | m_bDrawSingleTab
TRUE to draw single tab.
BOOL | m_bDrawCaptionIcon
TRUE to draw caption icon.
int | m_nSplitterIndent
Size of splitter indent.
CXTPPaintManagerColor | m_clrBackground
Background color.
CXTPPaintManagerColor | m_clrSplitterGripper
Splitter gripper color.
CXTPPaintManagerColor | m_clrSplitter
Splitter color.
CXTPPaintManagerColorGradient | m_clrSplitterGradient
Splitter gradient color.
CXTPPaintManagerColorGradient | m_clrNormalCaption
Color of pane caption when inactive.
CXTPPaintManagerColorGradient | m_clrActiveCaption
Color of pane caption when active.
CXTPPaintManagerColor | m_clrNormalCaptionText
Color of pane caption text when the caption is inactive.
CXTPPaintManagerColor | m_clrActiveCaptionText
Active caption text.
CXTPPaintManagerColor | m_clrDisabledCaptionText
Disabled caption text.

Detailed Description

CXTPDockingPaneNativeWindows10Theme is used to define drawing routines specific to a Native Windows 10 docking pane theme.

Member Function Documentation

◆ DrawAutoHidePanel()

virtual void DrawAutoHidePanel | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | XTPDockingPaneDirection | direction )
 virtual

This method is called by the framework to draw the docking pane auto-hide panel background and splitter.

Parameters
pDC | Pointer to the auto-hide panes device context.
rc | Size of the area to draw.
direction | Docking direction (either xtpPaneDockLeft, xtpPaneDockRight, xtpPaneDockTop or xtpPaneDockBottom).

Reimplemented from CXTPDockingPaneVisualStudio2012Theme.

◆ DrawSplitter()

virtual void DrawSplitter | ( | CDC * | pDC,
 |  | CXTPDockingPaneSplitterWnd * | pSplitter )
 virtual

Override this method to draw a splitter.

Parameters
pDC | Pointer to a valid device context.
pSplitter | Pointer to a splitter window.

Reimplemented from CXTPDockingPaneVisualStudio2012Theme.

◆ DrawTitleBar()

virtual void DrawTitleBar | ( | CDC * | pDC,
 |  | CXTPDockingPaneBase * | pPane,
 |  | CRect | rc,
 |  | BOOL | bVertical )
 protectedvirtual

This member function is called to draw a title bar for the docking pane.

Parameters
pDC | Pointer to a valid device context.
pPane | Pointer to a valid CXTPDockingPaneBase object.
rc | Size of the title bar to draw.
bVertical | TRUE if the title bar should be drawn vertically.

Reimplemented from CXTPDockingPaneVisualStudio2012Theme.

The documentation for this class was generated from the following file:
  • XTPDockingPaneThemeNativeWindows10.h


Toolkit Pro: CXTPDockingPaneNativeWindows11Theme Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPDockingPaneNativeWindows11Theme Class Reference

CXTPDockingPaneNativeWindows11Theme is used to define drawing routines specific to a Native Windows 10 docking pane theme. More...

Inheritance diagram for CXTPDockingPaneNativeWindows11Theme:
[legend]

Public Member Functions

CXTPDockingPaneNativeWindows11Theme ()
Constructs a CXTPDockingPaneNativeWindows11Theme object.
virtual | ~CXTPDockingPaneNativeWindows11Theme ()
Destroys a CXTPDockingPaneNativeWindows11Theme object, handles cleanup and deallocation.
virtual void | RefreshMetrics ()
This member function is used to initialize default colors for a theme from an .INI resource.
virtual void | DrawSplitter (CDC *pDC, CXTPDockingPaneSplitterWnd *pSplitter)
Override this method to draw a splitter.
virtual void | DrawAutoHidePanel (CDC *pDC, CRect rc, XTPDockingPaneDirection direction)
This method is called by the framework to draw the docking pane auto-hide panel background and splitter.
- Public Member Functions inherited from CXTPDockingPaneVisualStudio2012Theme
CXTPDockingPaneVisualStudio2012Theme ()
Constructs a CXTPDockingPaneVisualStudio2012Theme object.
virtual | ~CXTPDockingPaneVisualStudio2012Theme ()
Destroys a CXTPDockingPaneVisualStudio2012Theme object, handles cleanup and deallocation.
virtual CRect | GetPaneCaptionRect (const CXTPDockingPaneSidePanel *pPane)
Call this method to get the pane's caption rectangle.
virtual void | AdjustClientRect (CXTPDockingPaneTabbedContainer *pPane, CRect &rc, BOOL bApply)
Override this member to change the client rectangle of the child docking pane.
virtual void | AdjustCaptionRect (const CXTPDockingPaneTabbedContainer *pPane, CRect &rc)
Override this member to change the caption rectangle of the child docking pane.
virtual void | DrawCaption (CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc)
Override this member function to draw a caption.
virtual void | DrawFloatingFrame (CDC *pDC, CXTPDockingPaneMiniWnd *pPane, CRect rc)
Call this method to draw the frame of a floating window.
virtual void | DrawPane (CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc)
Override this member function to draw a tabbed container.
virtual void | DrawSidePanel (CDC *pDC, CXTPDockingPaneSidePanel *pPane, CRect rc)
Override this member function to draw the side panel.
virtual void | DrawCaptionButton (CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton)
Override this member function to draw a button for a tabbed caption.
- Public Member Functions inherited from CXTPDockingPaneDefaultTheme
CXTPDockingPaneDefaultTheme ()
Constructs a CXTPDockingPaneDefaultTheme object.
- Public Member Functions inherited from CXTPDockingPanePaintManager
virtual void | DrawCaptionButtons (CDC *pDC, CXTPDockingPaneCaptionButtons *pButtons, CRect &rcCaption, COLORREF clr, int nButtonSize, int nButtonGap, BOOL bVertical=FALSE)
Override this member function to draw buttons for a tabbed caption.
virtual void | AdjustClientRect (CXTPDockingPaneSidePanel *pPane, CRect &rect)
Override this member to change the client rectangle of the child docking pane.
virtual void | AdjustCaptionRect (const CXTPDockingPaneSidePanel *pPane, CRect &rc)
Override this member to change the caption rectangle of the child docking pane.
virtual void | GetCaptionRect (const CXTPDockingPaneTabbedContainer *pPane, CRect &rc)
Call this method to get a caption rectangle.
virtual CRect | GetCaptionGripperRect (const CXTPDockingPaneTabbedContainer *pPane)
Call this method to get a caption gripper for a tabbed container.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1, int nPen)
Draws a line.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1)
Draws a line.
int | DrawCaptionText (CDC *pDC, const CString &strTitle, CRect rc, BOOL bVertical, BOOL bCalcWidth=FALSE)
Draws the text of a pane caption.
void | Pixel (CDC *pDC, int xPos, int yPos, int nPen)
Sets the pixel at the point.
void | Rectangle (CDC *pDC, CRect rc, int nPenEntry, int nPenBorder)
Draws a rectangle.
void | UseOfficeFont (BOOL bUseOfficeFont)
Call this member to use Office (Tahoma) font.
void | SetCaptionFontIndirect (LOGFONT *pLogFont, BOOL bUseStandardFont=FALSE)
Call this method to set the caption's font.
CXTPTabPaintManager * | SetTabPaintManager (CXTPTabPaintManager *pManager)
Call this method to set the paint manager used to draw tabs of a tabbed container.
CXTPTabPaintManager * | SetPanelPaintManager (CXTPTabPaintManager *pManager)
Call this method to set the paint manager used to draw tabs of an auto-hide panel.
CXTPTabPaintManager * | GetTabPaintManager () const
Retrieves the paint manager used to draw tabs of a tabbed container.
CXTPTabPaintManager * | GetPanelPaintManager () const
Retrieves the paint manager used to draw tabs of an auto-hide panel.
COLORREF | GetXtremeColor (UINT nIndex)
Retrieves the current color of the specified XP display element.
void | SetColors (int cElements, CONST INT *lpaElements, CONST COLORREF *lpaRgbValues)
Call this member to set the colors for each element in an array to the colors in a specified color array.
int | GetCaptionHeight () const
Call this member to get the caption height of the tabbed container.
int | GetTabsHeight () const
Call this member to get tabs height of the tabbed container.
void | SetSplitterStyle (DWORD dwStyle)
Call this member to set the splitter style.
DWORD | GetSplitterStyle () const
Call this method to get the splitter style.
void | SetCaptionButtonStyle (XTPDockingPaneCaptionButtonStyle nStyle)
Call this member to set the caption button style.
XTPDockingPaneCaptionButtonStyle | GetCaptionButtonStyle () const
Call this method to get the caption button style.
XTPCurrentSystemTheme | GetCurrentSystemTheme () const
Call this member function to determine the current Windows XP theme in use.
void | SetLunaTheme (XTPCurrentSystemTheme systemTheme)
Call this method to force system theme.
void | SetCustomTitleBrushes (HBRUSH hbrActiveTitleHorz, HBRUSH hbrInactiveTitleHorz=NULL, HBRUSH hbrActiveTitleVert=NULL, HBRUSH hbrInactiveTitleVert=NULL, BOOL bDestroyOnCleanup=FALSE)
Sets custom title brushes.
HBRUSH | GetCustomTitleBrush (BOOL bActive, BOOL bVertical) const
Obtains the custom title brush.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

virtual void | DrawTitleBar (CDC *pDC, CXTPDockingPaneBase *pPane, CRect rc, BOOL bVertical)
This member function is called to draw a title bar for the docking pane.
- Protected Member Functions inherited from CXTPDockingPaneVisualStudio2012Theme
void | DrawGripper (CDC *pDC, CRect rcGripper, COLORREF clr, BOOL bVertical)
This member function is called to draw a gripper for the docking pane.
void | DrawDottedLine (CDC *pDC, int x, int y, int nSize, COLORREF clr, BOOL bVertical)
This member function is called to draw a dotted line.
virtual CXTPDockingPaneColorSet * | GetColorSet (BOOL bActive)
Call this member function to retrieve the active or inactive color set for the Docking Pane using the state specified by bActive.
void | SetPaneColorSets (CXTPDockingPaneColorSet *pcsActive, CXTPDockingPaneColorSet *pcsInactive)
Called to initialize the active and inactive colors sets for the docking pane theme.
void | DeletePaneColorSets ()
Called to free the memory allocated for the docking pane active and inactive color sets.
- Protected Member Functions inherited from CXTPDockingPaneDefaultTheme
virtual void | DrawCaptionPart (CDC *pDC, CXTPDockingPaneBase *pPane, CRect rcCaption, const CString &strTitle, BOOL bActive, BOOL bVertical)
Draws the common part of a tabbed and floating caption.
- Protected Member Functions inherited from CXTPDockingPanePaintManager
CXTPDockingPanePaintManager ()
Constructs a CXTPDockingPanePaintManager object.
virtual | ~CXTPDockingPanePaintManager ()
Destroys a CXTPDockingPanePaintManager object, handles cleanup and deallocation.
virtual void | DrawCaptionButtonEntry (CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton, CSize szOffset)
Draws only the glyph of a button.
virtual void | DrawCaptionButtonEntry (CDC *pDC, CXTPDockingPaneCaptionButton *pButton, CPoint pt, COLORREF clrButton)
Draws only the glyph of a button.
void | ClipAndAddEllipsisIfNeeded (CDC *pDC, CString &strTitle, int nCaptionWidth) const
Clip string and add ellipsis if its width less than nCaptionWidth.

Protected Attributes

COLORREF | m_clrCaptionBorder
Caption border color.
- Protected Attributes inherited from CXTPDockingPaneVisualStudio2012Theme
CXTPDockingPaneColorSet * | m_pcsActive
Active state docking pane colors.
CXTPDockingPaneColorSet * | m_pcsInactive
Inactive state docking pane colors.
CString | m_strFontFace
Font face name.
int | m_nFontSize
Font size in points.
- Protected Attributes inherited from CXTPDockingPanePaintManager
XTPDockingPaneCaptionButtonStyle | m_nCaptionButtonStyle
Caption button style.
DWORD | m_dwSplitterStyle
Splitter style.
int | m_nTitleHeight
Title's height.
int | m_nCaptionFontGap
Additional gap of font.
int | m_nTabsHeight
Tab bar's height.
CXTPFont | m_xtpFontTitle
Title font.
CXTPFont | m_xtpFontTitleVertical
Title vertical font.
BOOL | m_bUseOfficeFont
TRUE to use Tahoma font.
BOOL | m_bUseStandardFont
TRUE to use system icon font.
BOOL | m_bDestroyCustomTitleBrushes
If TRUE, custom title bushes will be destroyed on cleanup.
HBRUSH | m_hbrActiveTitleHorz
Optional user specified active horizontal title brush.
HBRUSH | m_hbrInactiveTitleHorz
Optional user specified inactive horizontal title brush.
HBRUSH | m_hbrActiveTitleVert
Optional user specified active vertical title brush.
HBRUSH | m_hbrInactiveTitleVert
Optional user specified inactive vertical title brush.
CXTPTabPaintManager * | m_pTabPaintManager
Paint Manager used to draw tabs for a tabbed container.
CXTPTabPaintManager * | m_pPanelPaintManager
Paint Manager used to draw tabs for an auto-hide panel.
COLORREF | m_arrColor [XPCOLOR_LAST+1]
Self colors array.
XTPDockingPanePaintTheme | m_themeCurrent
Current theme.
CString | m_strOfficeFont
Office font name.
CRect | m_rcCaptionMargin
Margins of caption.
XTPCurrentSystemTheme | m_systemTheme
Current system theme.
CXTPWinThemeWrapper * | m_themeToolbar
Toolbar theme helper.
CXTPWinThemeWrapper * | m_themeExplorer
WinXP Explorer theme helper.
CXTPWinThemeWrapper * | m_themeButton
WinXP Button theme helper.
CXTPWinThemeWrapper * | m_themeWindow
WinXP Window Theme helper.
CXTPWinThemeWrapper * | m_themeRebar
Rebar theme helper.
BOOL | m_bLunaTheme
TRUE if luna colors are used.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPDockingPanePaintManager
BOOL | m_bUseBoldCaptionFont
TRUE to use bold font for caption.
BOOL | m_bHighlightActiveCaption
TRUE to highlight active caption.
int | m_nSplitterSize
Splitter size.
BOOL | m_bShowCaption
TRUE to draw captions of tabbed containers.
BOOL | m_bDrawSingleTab
TRUE to draw single tab.
BOOL | m_bDrawCaptionIcon
TRUE to draw caption icon.
int | m_nSplitterIndent
Size of splitter indent.
CXTPPaintManagerColor | m_clrBackground
Background color.
CXTPPaintManagerColor | m_clrSplitterGripper
Splitter gripper color.
CXTPPaintManagerColor | m_clrSplitter
Splitter color.
CXTPPaintManagerColorGradient | m_clrSplitterGradient
Splitter gradient color.
CXTPPaintManagerColorGradient | m_clrNormalCaption
Color of pane caption when inactive.
CXTPPaintManagerColorGradient | m_clrActiveCaption
Color of pane caption when active.
CXTPPaintManagerColor | m_clrNormalCaptionText
Color of pane caption text when the caption is inactive.
CXTPPaintManagerColor | m_clrActiveCaptionText
Active caption text.
CXTPPaintManagerColor | m_clrDisabledCaptionText
Disabled caption text.

Detailed Description

CXTPDockingPaneNativeWindows11Theme is used to define drawing routines specific to a Native Windows 10 docking pane theme.

Member Function Documentation

◆ DrawAutoHidePanel()

virtual void DrawAutoHidePanel | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | XTPDockingPaneDirection | direction )
 virtual

This method is called by the framework to draw the docking pane auto-hide panel background and splitter.

Parameters
pDC | Pointer to the auto-hide panes device context.
rc | Size of the area to draw.
direction | Docking direction (either xtpPaneDockLeft, xtpPaneDockRight, xtpPaneDockTop or xtpPaneDockBottom).

Reimplemented from CXTPDockingPaneVisualStudio2012Theme.

◆ DrawSplitter()

virtual void DrawSplitter | ( | CDC * | pDC,
 |  | CXTPDockingPaneSplitterWnd * | pSplitter )
 virtual

Override this method to draw a splitter.

Parameters
pDC | Pointer to a valid device context.
pSplitter | Pointer to a splitter window.

Reimplemented from CXTPDockingPaneVisualStudio2012Theme.

◆ DrawTitleBar()

virtual void DrawTitleBar | ( | CDC * | pDC,
 |  | CXTPDockingPaneBase * | pPane,
 |  | CRect | rc,
 |  | BOOL | bVertical )
 protectedvirtual

This member function is called to draw a title bar for the docking pane.

Parameters
pDC | Pointer to a valid device context.
pPane | Pointer to a valid CXTPDockingPaneBase object.
rc | Size of the title bar to draw.
bVertical | TRUE if the title bar should be drawn vertically.

Reimplemented from CXTPDockingPaneVisualStudio2012Theme.

The documentation for this class was generated from the following file:
  • XTPDockingPaneThemeNativeWindows11.h


Toolkit Pro: CXTPDockingPaneOffice2002VisioTheme Class Reference

Public Member Functions | List of all members
CXTPDockingPaneOffice2002VisioTheme Class Reference

CXTPDockingPaneOffice2002VisioTheme is a CXTPDockingPaneVisualStudio2003Theme derived class that represents a Visio theme for docking panes. More...

Inheritance diagram for CXTPDockingPaneOffice2002VisioTheme:
[legend]

Public Member Functions

CXTPDockingPaneOffice2002VisioTheme ()
Constructs a CXTPDockingPaneOffice2002VisioTheme object.
void | RefreshMetrics ()
This method is called to refresh the visual metrics of the pane.
void | DrawCaption (CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc)
Override this member function to draw a caption.
void | DrawPane (CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc)
Override this member function to draw a tabbed container.
void | AdjustCaptionRect (const CXTPDockingPaneTabbedContainer *pPane, CRect &rc)
Override this member to change the caption rectangle of the child docking pane.
void | DrawFloatingFrame (CDC *pDC, CXTPDockingPaneMiniWnd *pPane, CRect rc)
Call this method to draw the frame of a floating window.
- Public Member Functions inherited from CXTPDockingPaneVisualStudio2003Theme
CXTPDockingPaneVisualStudio2003Theme ()
Constructs a CXTPDockingPaneVisualStudio2003Theme object.
- Public Member Functions inherited from CXTPDockingPaneGripperedTheme
CXTPDockingPaneGripperedTheme ()
Constructs a CXTPDockingPaneGripperedTheme object.
- Public Member Functions inherited from CXTPDockingPaneDefaultTheme
CXTPDockingPaneDefaultTheme ()
Constructs a CXTPDockingPaneDefaultTheme object.
virtual void | DrawSidePanel (CDC *pDC, CXTPDockingPaneSidePanel *pPane, CRect rc)
Override this member function to draw the side panel.
- Public Member Functions inherited from CXTPDockingPanePaintManager
virtual CRect | GetPaneCaptionRect (const CXTPDockingPaneSidePanel *pPane)
Call this method to get the pane's caption rectangle.
virtual void | DrawSplitter (CDC *pDC, CXTPDockingPaneSplitterWnd *pSplitter)
Override this method to draw a splitter.
virtual void | DrawCaptionButtons (CDC *pDC, CXTPDockingPaneCaptionButtons *pButtons, CRect &rcCaption, COLORREF clr, int nButtonSize, int nButtonGap, BOOL bVertical=FALSE)
Override this member function to draw buttons for a tabbed caption.
virtual void | DrawCaptionButton (CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton)
Override this member function to draw a button for a tabbed caption.
virtual void | AdjustClientRect (CXTPDockingPaneSidePanel *pPane, CRect &rect)
Override this member to change the client rectangle of the child docking pane.
virtual void | AdjustClientRect (CXTPDockingPaneTabbedContainer *pPane, CRect &rect, BOOL bApply)
Override this member to change the client rectangle of the child docking pane.
virtual void | AdjustCaptionRect (const CXTPDockingPaneSidePanel *pPane, CRect &rc)
Override this member to change the caption rectangle of the child docking pane.
virtual void | GetCaptionRect (const CXTPDockingPaneTabbedContainer *pPane, CRect &rc)
Call this method to get a caption rectangle.
virtual CRect | GetCaptionGripperRect (const CXTPDockingPaneTabbedContainer *pPane)
Call this method to get a caption gripper for a tabbed container.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1, int nPen)
Draws a line.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1)
Draws a line.
int | DrawCaptionText (CDC *pDC, const CString &strTitle, CRect rc, BOOL bVertical, BOOL bCalcWidth=FALSE)
Draws the text of a pane caption.
void | Pixel (CDC *pDC, int xPos, int yPos, int nPen)
Sets the pixel at the point.
void | Rectangle (CDC *pDC, CRect rc, int nPenEntry, int nPenBorder)
Draws a rectangle.
void | UseOfficeFont (BOOL bUseOfficeFont)
Call this member to use Office (Tahoma) font.
void | SetCaptionFontIndirect (LOGFONT *pLogFont, BOOL bUseStandardFont=FALSE)
Call this method to set the caption's font.
CXTPTabPaintManager * | SetTabPaintManager (CXTPTabPaintManager *pManager)
Call this method to set the paint manager used to draw tabs of a tabbed container.
CXTPTabPaintManager * | SetPanelPaintManager (CXTPTabPaintManager *pManager)
Call this method to set the paint manager used to draw tabs of an auto-hide panel.
CXTPTabPaintManager * | GetTabPaintManager () const
Retrieves the paint manager used to draw tabs of a tabbed container.
CXTPTabPaintManager * | GetPanelPaintManager () const
Retrieves the paint manager used to draw tabs of an auto-hide panel.
COLORREF | GetXtremeColor (UINT nIndex)
Retrieves the current color of the specified XP display element.
void | SetColors (int cElements, CONST INT *lpaElements, CONST COLORREF *lpaRgbValues)
Call this member to set the colors for each element in an array to the colors in a specified color array.
int | GetCaptionHeight () const
Call this member to get the caption height of the tabbed container.
int | GetTabsHeight () const
Call this member to get tabs height of the tabbed container.
void | SetSplitterStyle (DWORD dwStyle)
Call this member to set the splitter style.
DWORD | GetSplitterStyle () const
Call this method to get the splitter style.
void | SetCaptionButtonStyle (XTPDockingPaneCaptionButtonStyle nStyle)
Call this member to set the caption button style.
XTPDockingPaneCaptionButtonStyle | GetCaptionButtonStyle () const
Call this method to get the caption button style.
XTPCurrentSystemTheme | GetCurrentSystemTheme () const
Call this member function to determine the current Windows XP theme in use.
void | SetLunaTheme (XTPCurrentSystemTheme systemTheme)
Call this method to force system theme.
virtual void | DrawAutoHidePanel (CDC *pDC, CRect rc, XTPDockingPaneDirection direction)
This mmethod is called by the framework to draw the docking pane auto-hide panel background and splitter.
void | SetCustomTitleBrushes (HBRUSH hbrActiveTitleHorz, HBRUSH hbrInactiveTitleHorz=NULL, HBRUSH hbrActiveTitleVert=NULL, HBRUSH hbrInactiveTitleVert=NULL, BOOL bDestroyOnCleanup=FALSE)
Sets custom title brushes.
HBRUSH | GetCustomTitleBrush (BOOL bActive, BOOL bVertical) const
Obtains the custom title brush.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPDockingPanePaintManager
BOOL | m_bUseBoldCaptionFont
TRUE to use bold font for caption.
BOOL | m_bHighlightActiveCaption
TRUE to highlight active caption.
int | m_nSplitterSize
Splitter size.
BOOL | m_bShowCaption
TRUE to draw captions of tabbed containers.
BOOL | m_bDrawSingleTab
TRUE to draw single tab.
BOOL | m_bDrawCaptionIcon
TRUE to draw caption icon.
int | m_nSplitterIndent
Size of splitter indent.
CXTPPaintManagerColor | m_clrBackground
Background color.
CXTPPaintManagerColor | m_clrSplitterGripper
Splitter gripper color.
CXTPPaintManagerColor | m_clrSplitter
Splitter color.
CXTPPaintManagerColorGradient | m_clrSplitterGradient
Splitter gradient color.
CXTPPaintManagerColorGradient | m_clrNormalCaption
Color of pane caption when inactive.
CXTPPaintManagerColorGradient | m_clrActiveCaption
Color of pane caption when active.
CXTPPaintManagerColor | m_clrNormalCaptionText
Color of pane caption text when the caption is inactive.
CXTPPaintManagerColor | m_clrActiveCaptionText
Active caption text.
CXTPPaintManagerColor | m_clrDisabledCaptionText
Disabled caption text.
- Protected Member Functions inherited from CXTPDockingPaneVisualStudio2003Theme
virtual void | DrawCaptionPart (CDC *pDC, CXTPDockingPaneBase *pPane, CRect rcCaption, const CString &strTitle, BOOL bActive, BOOL bVertical)
Draws the common part of a tabbed and floating caption.
virtual COLORREF | FillCaptionPart (CDC *pDC, CXTPDockingPaneBase *pPane, CRect rcCaption, BOOL bActive, BOOL bVertical)
Draws the background of the pane caption.
- Protected Member Functions inherited from CXTPDockingPaneGripperedTheme
- Protected Member Functions inherited from CXTPDockingPaneDefaultTheme
- Protected Member Functions inherited from CXTPDockingPanePaintManager
CXTPDockingPanePaintManager ()
Constructs a CXTPDockingPanePaintManager object.
virtual | ~CXTPDockingPanePaintManager ()
Destroys a CXTPDockingPanePaintManager object, handles cleanup and deallocation.
virtual void | DrawCaptionButtonEntry (CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton, CSize szOffset)
Draws only the glyph of a button.
virtual void | DrawCaptionButtonEntry (CDC *pDC, CXTPDockingPaneCaptionButton *pButton, CPoint pt, COLORREF clrButton)
Draws only the glyph of a button.
void | ClipAndAddEllipsisIfNeeded (CDC *pDC, CString &strTitle, int nCaptionWidth) const
Clip string and add ellipsis if its width less than nCaptionWidth.
- Protected Attributes inherited from CXTPDockingPaneVisualStudio2003Theme
BOOL | m_bGradientCaption
TRUE to draw gradient caption.
- Protected Attributes inherited from CXTPDockingPanePaintManager
XTPDockingPaneCaptionButtonStyle | m_nCaptionButtonStyle
Caption button style.
DWORD | m_dwSplitterStyle
Splitter style.
int | m_nTitleHeight
Title's height.
int | m_nCaptionFontGap
Additional gap of font.
int | m_nTabsHeight
Tab bar's height.
CXTPFont | m_xtpFontTitle
Title font.
CXTPFont | m_xtpFontTitleVertical
Title vertical font.
BOOL | m_bUseOfficeFont
TRUE to use Tahoma font.
BOOL | m_bUseStandardFont
TRUE to use system icon font.
BOOL | m_bDestroyCustomTitleBrushes
If TRUE, custom title bushes will be destroyed on cleanup.
HBRUSH | m_hbrActiveTitleHorz
Optional user specified active horizontal title brush.
HBRUSH | m_hbrInactiveTitleHorz
Optional user specified inactive horizontal title brush.
HBRUSH | m_hbrActiveTitleVert
Optional user specified active vertical title brush.
HBRUSH | m_hbrInactiveTitleVert
Optional user specified inactive vertical title brush.
CXTPTabPaintManager * | m_pTabPaintManager
Paint Manager used to draw tabs for a tabbed container.
CXTPTabPaintManager * | m_pPanelPaintManager
Paint Manager used to draw tabs for an auto-hide panel.
COLORREF | m_arrColor [XPCOLOR_LAST+1]
Self colors array.
XTPDockingPanePaintTheme | m_themeCurrent
Current theme.
CString | m_strOfficeFont
Office font name.
CRect | m_rcCaptionMargin
Margins of caption.
XTPCurrentSystemTheme | m_systemTheme
Current system theme.
CXTPWinThemeWrapper * | m_themeToolbar
Toolbar theme helper.
CXTPWinThemeWrapper * | m_themeExplorer
WinXP Explorer theme helper.
CXTPWinThemeWrapper * | m_themeButton
WinXP Button theme helper.
CXTPWinThemeWrapper * | m_themeWindow
WinXP Window Theme helper.
CXTPWinThemeWrapper * | m_themeRebar
Rebar theme helper.
BOOL | m_bLunaTheme
TRUE if luna colors are used.

Detailed Description

CXTPDockingPaneOffice2002VisioTheme is a CXTPDockingPaneVisualStudio2003Theme derived class that represents a Visio theme for docking panes.

Call CXTPDockingPaneManager::SetTheme(xtpPaneThemeOffice2002Visio); to set this theme.

Member Function Documentation

◆ AdjustCaptionRect()

void AdjustCaptionRect | ( | const CXTPDockingPaneTabbedContainer * | pPane,
 |  | CRect & | rc )
 virtual

Override this member to change the caption rectangle of the child docking pane.

Parameters
pPane | Pointer to a CXTPDockingPaneTabbedContainer object.
rc | Caption rectangle to be changed.

Reimplemented from CXTPDockingPanePaintManager.

◆ DrawCaption()

void DrawCaption | ( | CDC * | pDC,
 |  | CXTPDockingPaneTabbedContainer * | pPane,
 |  | CRect | rc )
 virtual

Override this member function to draw a caption.

Parameters
pDC | Reference to the device context in which to draw.
pPane | Pointer to the tabbed container.
rc | Client rectangle of the tabbed container.

Reimplemented from CXTPDockingPaneGripperedTheme.

◆ DrawFloatingFrame()

void DrawFloatingFrame | ( | CDC * | pDC,
 |  | CXTPDockingPaneMiniWnd * | pPane,
 |  | CRect | rc )
 virtual

Call this method to draw the frame of a floating window.

Parameters
pDC | Pointer to a valid device context.
pPane | Floating window pointer.
rc | Client rectangle of the floating frame.

Reimplemented from CXTPDockingPaneGripperedTheme.

◆ DrawPane()

void DrawPane | ( | CDC * | pDC,
 |  | CXTPDockingPaneTabbedContainer * | pPane,
 |  | CRect | rc )
 virtual

Override this member function to draw a tabbed container.

Parameters
pDC | Reference to the device context in which to draw.
pPane | Pointer to the tabbed container.
rc | Client rectangle of the tabbed container.

Reimplemented from CXTPDockingPanePaintManager.

The documentation for this class was generated from the following file:
  • XTPDockingPaneThemeOffice2002Visio.h


Toolkit Pro: CXTPDockingPaneOffice2003OutlookTheme Class Reference

Public Member Functions | List of all members
CXTPDockingPaneOffice2003OutlookTheme Class Reference

CXTPDockingPaneOffice2003OutlookTheme is a CXTPDockingPaneOffice2003Theme derived class that represents an Office 2003 theme for docking panes. More...

Inheritance diagram for CXTPDockingPaneOffice2003OutlookTheme:
[legend]

Public Member Functions

CXTPDockingPaneOffice2003OutlookTheme ()
Constructs a CXTPDockingPaneOffice2003OutlookTheme object.
virtual | ~CXTPDockingPaneOffice2003OutlookTheme ()
Destroys a CXTPDockingPaneOffice2003OutlookTheme object, handles cleanup and deallocation.
virtual void | RefreshMetrics ()
This method is called to refresh the visual metrics of the pane.
virtual CRect | GetCaptionGripperRect (const CXTPDockingPaneTabbedContainer *pPane)
Call this method to get the caption gripper for a tabbed container.
- Public Member Functions inherited from CXTPDockingPaneOffice2003Theme
CXTPDockingPaneOffice2003Theme ()
Constructs a CXTPDockingPaneOffice2003Theme object.
virtual | ~CXTPDockingPaneOffice2003Theme ()
Destroys a CXTPDockingPaneOffice2003Theme object, handles cleanup and deallocation.
virtual void | DrawCaption (CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc)
Override this member function to draw a caption.
virtual void | DrawFloatingFrame (CDC *pDC, CXTPDockingPaneMiniWnd *pPane, CRect rc)
Call this method to draw the frame of a floating window.
virtual void | DrawSidePanel (CDC *pDC, CXTPDockingPaneSidePanel *pPane, CRect rc)
Override this member function to draw the side panel.
virtual CRect | GetPaneCaptionRect (const CXTPDockingPaneSidePanel *pPane)
Call this method to get the pane's caption rectangle.
- Public Member Functions inherited from CXTPDockingPaneVisualStudio2003Theme
CXTPDockingPaneVisualStudio2003Theme ()
Constructs a CXTPDockingPaneVisualStudio2003Theme object.
- Public Member Functions inherited from CXTPDockingPaneGripperedTheme
CXTPDockingPaneGripperedTheme ()
Constructs a CXTPDockingPaneGripperedTheme object.
- Public Member Functions inherited from CXTPDockingPaneDefaultTheme
CXTPDockingPaneDefaultTheme ()
Constructs a CXTPDockingPaneDefaultTheme object.
- Public Member Functions inherited from CXTPDockingPanePaintManager
virtual void | DrawPane (CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc)
Override this member function to draw a tabbed container.
virtual void | DrawSplitter (CDC *pDC, CXTPDockingPaneSplitterWnd *pSplitter)
Override this method to draw a splitter.
virtual void | DrawCaptionButtons (CDC *pDC, CXTPDockingPaneCaptionButtons *pButtons, CRect &rcCaption, COLORREF clr, int nButtonSize, int nButtonGap, BOOL bVertical=FALSE)
Override this member function to draw buttons for a tabbed caption.
virtual void | DrawCaptionButton (CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton)
Override this member function to draw a button for a tabbed caption.
virtual void | AdjustClientRect (CXTPDockingPaneSidePanel *pPane, CRect &rect)
Override this member to change the client rectangle of the child docking pane.
virtual void | AdjustClientRect (CXTPDockingPaneTabbedContainer *pPane, CRect &rect, BOOL bApply)
Override this member to change the client rectangle of the child docking pane.
virtual void | AdjustCaptionRect (const CXTPDockingPaneSidePanel *pPane, CRect &rc)
Override this member to change the caption rectangle of the child docking pane.
virtual void | AdjustCaptionRect (const CXTPDockingPaneTabbedContainer *pPane, CRect &rc)
Override this member to change the caption rectangle of the child docking pane.
virtual void | GetCaptionRect (const CXTPDockingPaneTabbedContainer *pPane, CRect &rc)
Call this method to get a caption rectangle.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1, int nPen)
Draws a line.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1)
Draws a line.
int | DrawCaptionText (CDC *pDC, const CString &strTitle, CRect rc, BOOL bVertical, BOOL bCalcWidth=FALSE)
Draws the text of a pane caption.
void | Pixel (CDC *pDC, int xPos, int yPos, int nPen)
Sets the pixel at the point.
void | Rectangle (CDC *pDC, CRect rc, int nPenEntry, int nPenBorder)
Draws a rectangle.
void | UseOfficeFont (BOOL bUseOfficeFont)
Call this member to use Office (Tahoma) font.
void | SetCaptionFontIndirect (LOGFONT *pLogFont, BOOL bUseStandardFont=FALSE)
Call this method to set the caption's font.
CXTPTabPaintManager * | SetTabPaintManager (CXTPTabPaintManager *pManager)
Call this method to set the paint manager used to draw tabs of a tabbed container.
CXTPTabPaintManager * | SetPanelPaintManager (CXTPTabPaintManager *pManager)
Call this method to set the paint manager used to draw tabs of an auto-hide panel.
CXTPTabPaintManager * | GetTabPaintManager () const
Retrieves the paint manager used to draw tabs of a tabbed container.
CXTPTabPaintManager * | GetPanelPaintManager () const
Retrieves the paint manager used to draw tabs of an auto-hide panel.
COLORREF | GetXtremeColor (UINT nIndex)
Retrieves the current color of the specified XP display element.
void | SetColors (int cElements, CONST INT *lpaElements, CONST COLORREF *lpaRgbValues)
Call this member to set the colors for each element in an array to the colors in a specified color array.
int | GetCaptionHeight () const
Call this member to get the caption height of the tabbed container.
int | GetTabsHeight () const
Call this member to get tabs height of the tabbed container.
void | SetSplitterStyle (DWORD dwStyle)
Call this member to set the splitter style.
DWORD | GetSplitterStyle () const
Call this method to get the splitter style.
void | SetCaptionButtonStyle (XTPDockingPaneCaptionButtonStyle nStyle)
Call this member to set the caption button style.
XTPDockingPaneCaptionButtonStyle | GetCaptionButtonStyle () const
Call this method to get the caption button style.
XTPCurrentSystemTheme | GetCurrentSystemTheme () const
Call this member function to determine the current Windows XP theme in use.
void | SetLunaTheme (XTPCurrentSystemTheme systemTheme)
Call this method to force system theme.
virtual void | DrawAutoHidePanel (CDC *pDC, CRect rc, XTPDockingPaneDirection direction)
This mmethod is called by the framework to draw the docking pane auto-hide panel background and splitter.
void | SetCustomTitleBrushes (HBRUSH hbrActiveTitleHorz, HBRUSH hbrInactiveTitleHorz=NULL, HBRUSH hbrActiveTitleVert=NULL, HBRUSH hbrInactiveTitleVert=NULL, BOOL bDestroyOnCleanup=FALSE)
Sets custom title brushes.
HBRUSH | GetCustomTitleBrush (BOOL bActive, BOOL bVertical) const
Obtains the custom title brush.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPDockingPaneOffice2003Theme
BOOL | m_bDrawGripper
TRUE to draw gripper.
- Public Attributes inherited from CXTPDockingPanePaintManager
BOOL | m_bUseBoldCaptionFont
TRUE to use bold font for caption.
BOOL | m_bHighlightActiveCaption
TRUE to highlight active caption.
int | m_nSplitterSize
Splitter size.
BOOL | m_bShowCaption
TRUE to draw captions of tabbed containers.
BOOL | m_bDrawSingleTab
TRUE to draw single tab.
BOOL | m_bDrawCaptionIcon
TRUE to draw caption icon.
int | m_nSplitterIndent
Size of splitter indent.
CXTPPaintManagerColor | m_clrBackground
Background color.
CXTPPaintManagerColor | m_clrSplitterGripper
Splitter gripper color.
CXTPPaintManagerColor | m_clrSplitter
Splitter color.
CXTPPaintManagerColorGradient | m_clrSplitterGradient
Splitter gradient color.
CXTPPaintManagerColorGradient | m_clrNormalCaption
Color of pane caption when inactive.
CXTPPaintManagerColorGradient | m_clrActiveCaption
Color of pane caption when active.
CXTPPaintManagerColor | m_clrNormalCaptionText
Color of pane caption text when the caption is inactive.
CXTPPaintManagerColor | m_clrActiveCaptionText
Active caption text.
CXTPPaintManagerColor | m_clrDisabledCaptionText
Disabled caption text.
- Protected Member Functions inherited from CXTPDockingPaneOffice2003Theme
virtual void | DrawCaptionPart (CDC *pDC, CXTPDockingPaneBase *pPane, CRect rcCaption, const CString &strTitle, BOOL bActive, BOOL bVertical)
Draws the common part of a tabbed and floating caption.
- Protected Member Functions inherited from CXTPDockingPaneVisualStudio2003Theme
virtual COLORREF | FillCaptionPart (CDC *pDC, CXTPDockingPaneBase *pPane, CRect rcCaption, BOOL bActive, BOOL bVertical)
Draws the background of the pane caption.
- Protected Member Functions inherited from CXTPDockingPaneGripperedTheme
- Protected Member Functions inherited from CXTPDockingPaneDefaultTheme
- Protected Member Functions inherited from CXTPDockingPanePaintManager
CXTPDockingPanePaintManager ()
Constructs a CXTPDockingPanePaintManager object.
virtual | ~CXTPDockingPanePaintManager ()
Destroys a CXTPDockingPanePaintManager object, handles cleanup and deallocation.
virtual void | DrawCaptionButtonEntry (CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton, CSize szOffset)
Draws only the glyph of a button.
virtual void | DrawCaptionButtonEntry (CDC *pDC, CXTPDockingPaneCaptionButton *pButton, CPoint pt, COLORREF clrButton)
Draws only the glyph of a button.
void | ClipAndAddEllipsisIfNeeded (CDC *pDC, CString &strTitle, int nCaptionWidth) const
Clip string and add ellipsis if its width less than nCaptionWidth.
- Protected Attributes inherited from CXTPDockingPaneOffice2003Theme
BOOL | m_bRoundedCaption
TRUE to draw rounded caption.
- Protected Attributes inherited from CXTPDockingPaneVisualStudio2003Theme
BOOL | m_bGradientCaption
TRUE to draw gradient caption.
- Protected Attributes inherited from CXTPDockingPanePaintManager
XTPDockingPaneCaptionButtonStyle | m_nCaptionButtonStyle
Caption button style.
DWORD | m_dwSplitterStyle
Splitter style.
int | m_nTitleHeight
Title's height.
int | m_nCaptionFontGap
Additional gap of font.
int | m_nTabsHeight
Tab bar's height.
CXTPFont | m_xtpFontTitle
Title font.
CXTPFont | m_xtpFontTitleVertical
Title vertical font.
BOOL | m_bUseOfficeFont
TRUE to use Tahoma font.
BOOL | m_bUseStandardFont
TRUE to use system icon font.
BOOL | m_bDestroyCustomTitleBrushes
If TRUE, custom title bushes will be destroyed on cleanup.
HBRUSH | m_hbrActiveTitleHorz
Optional user specified active horizontal title brush.
HBRUSH | m_hbrInactiveTitleHorz
Optional user specified inactive horizontal title brush.
HBRUSH | m_hbrActiveTitleVert
Optional user specified active vertical title brush.
HBRUSH | m_hbrInactiveTitleVert
Optional user specified inactive vertical title brush.
CXTPTabPaintManager * | m_pTabPaintManager
Paint Manager used to draw tabs for a tabbed container.
CXTPTabPaintManager * | m_pPanelPaintManager
Paint Manager used to draw tabs for an auto-hide panel.
COLORREF | m_arrColor [XPCOLOR_LAST+1]
Self colors array.
XTPDockingPanePaintTheme | m_themeCurrent
Current theme.
CString | m_strOfficeFont
Office font name.
CRect | m_rcCaptionMargin
Margins of caption.
XTPCurrentSystemTheme | m_systemTheme
Current system theme.
CXTPWinThemeWrapper * | m_themeToolbar
Toolbar theme helper.
CXTPWinThemeWrapper * | m_themeExplorer
WinXP Explorer theme helper.
CXTPWinThemeWrapper * | m_themeButton
WinXP Button theme helper.
CXTPWinThemeWrapper * | m_themeWindow
WinXP Window Theme helper.
CXTPWinThemeWrapper * | m_themeRebar
Rebar theme helper.
BOOL | m_bLunaTheme
TRUE if luna colors are used.

Detailed Description

CXTPDockingPaneOffice2003OutlookTheme is a CXTPDockingPaneOffice2003Theme derived class that represents an Office 2003 theme for docking panes.

Call CXTPDockingPaneManager::SetTheme(xtpPaneThemeOffice2003Outlook); to set this theme.

Member Function Documentation

◆ GetCaptionGripperRect()

virtual CRect GetCaptionGripperRect ( const CXTPDockingPaneTabbedContainer * pPane )
virtual

Call this method to get the caption gripper for a tabbed container.

Parameters
pPane Tabbed container to test.
Returns
Bounding rectangle of the gripper to set size cursor.

Reimplemented from CXTPDockingPaneOffice2003Theme.

The documentation for this class was generated from the following file:
  • XTPDockingPaneThemeOffice2003Outlook.h


Toolkit Pro: CXTPDockingPaneOffice2003Theme Class Reference

Public Member Functions | Public Attributes | Protected Member Functions | Protected Attributes | List of all members
CXTPDockingPaneOffice2003Theme Class Reference

CXTPDockingPaneOffice2003Theme is a CXTPDockingPaneVisualStudio2003Theme derived class that represents an Office 2003 theme for docking panes. More...

Inheritance diagram for CXTPDockingPaneOffice2003Theme:
[legend]

Public Member Functions

CXTPDockingPaneOffice2003Theme ()
Constructs a CXTPDockingPaneOffice2003Theme object.
virtual | ~CXTPDockingPaneOffice2003Theme ()
Destroys a CXTPDockingPaneOffice2003Theme object, handles cleanup and deallocation.
virtual void | RefreshMetrics ()
This method is called to refresh the visual metrics of the pane.
virtual void | DrawCaption (CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc)
Override this member function to draw a caption.
virtual void | DrawFloatingFrame (CDC *pDC, CXTPDockingPaneMiniWnd *pPane, CRect rc)
Call this method to draw the frame of a floating window.
virtual void | DrawSidePanel (CDC *pDC, CXTPDockingPaneSidePanel *pPane, CRect rc)
Override this member function to draw the side panel.
virtual CRect | GetPaneCaptionRect (const CXTPDockingPaneSidePanel *pPane)
Call this method to get the pane's caption rectangle.
virtual CRect | GetCaptionGripperRect (const CXTPDockingPaneTabbedContainer *pPane)
Call this method to get the caption gripper for a tabbed container.
- Public Member Functions inherited from CXTPDockingPaneVisualStudio2003Theme
CXTPDockingPaneVisualStudio2003Theme ()
Constructs a CXTPDockingPaneVisualStudio2003Theme object.
- Public Member Functions inherited from CXTPDockingPaneGripperedTheme
CXTPDockingPaneGripperedTheme ()
Constructs a CXTPDockingPaneGripperedTheme object.
- Public Member Functions inherited from CXTPDockingPaneDefaultTheme
CXTPDockingPaneDefaultTheme ()
Constructs a CXTPDockingPaneDefaultTheme object.
- Public Member Functions inherited from CXTPDockingPanePaintManager
virtual void | DrawPane (CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc)
Override this member function to draw a tabbed container.
virtual void | DrawSplitter (CDC *pDC, CXTPDockingPaneSplitterWnd *pSplitter)
Override this method to draw a splitter.
virtual void | DrawCaptionButtons (CDC *pDC, CXTPDockingPaneCaptionButtons *pButtons, CRect &rcCaption, COLORREF clr, int nButtonSize, int nButtonGap, BOOL bVertical=FALSE)
Override this member function to draw buttons for a tabbed caption.
virtual void | DrawCaptionButton (CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton)
Override this member function to draw a button for a tabbed caption.
virtual void | AdjustClientRect (CXTPDockingPaneSidePanel *pPane, CRect &rect)
Override this member to change the client rectangle of the child docking pane.
virtual void | AdjustClientRect (CXTPDockingPaneTabbedContainer *pPane, CRect &rect, BOOL bApply)
Override this member to change the client rectangle of the child docking pane.
virtual void | AdjustCaptionRect (const CXTPDockingPaneSidePanel *pPane, CRect &rc)
Override this member to change the caption rectangle of the child docking pane.
virtual void | AdjustCaptionRect (const CXTPDockingPaneTabbedContainer *pPane, CRect &rc)
Override this member to change the caption rectangle of the child docking pane.
virtual void | GetCaptionRect (const CXTPDockingPaneTabbedContainer *pPane, CRect &rc)
Call this method to get a caption rectangle.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1, int nPen)
Draws a line.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1)
Draws a line.
int | DrawCaptionText (CDC *pDC, const CString &strTitle, CRect rc, BOOL bVertical, BOOL bCalcWidth=FALSE)
Draws the text of a pane caption.
void | Pixel (CDC *pDC, int xPos, int yPos, int nPen)
Sets the pixel at the point.
void | Rectangle (CDC *pDC, CRect rc, int nPenEntry, int nPenBorder)
Draws a rectangle.
void | UseOfficeFont (BOOL bUseOfficeFont)
Call this member to use Office (Tahoma) font.
void | SetCaptionFontIndirect (LOGFONT *pLogFont, BOOL bUseStandardFont=FALSE)
Call this method to set the caption's font.
CXTPTabPaintManager * | SetTabPaintManager (CXTPTabPaintManager *pManager)
Call this method to set the paint manager used to draw tabs of a tabbed container.
CXTPTabPaintManager * | SetPanelPaintManager (CXTPTabPaintManager *pManager)
Call this method to set the paint manager used to draw tabs of an auto-hide panel.
CXTPTabPaintManager * | GetTabPaintManager () const
Retrieves the paint manager used to draw tabs of a tabbed container.
CXTPTabPaintManager * | GetPanelPaintManager () const
Retrieves the paint manager used to draw tabs of an auto-hide panel.
COLORREF | GetXtremeColor (UINT nIndex)
Retrieves the current color of the specified XP display element.
void | SetColors (int cElements, CONST INT *lpaElements, CONST COLORREF *lpaRgbValues)
Call this member to set the colors for each element in an array to the colors in a specified color array.
int | GetCaptionHeight () const
Call this member to get the caption height of the tabbed container.
int | GetTabsHeight () const
Call this member to get tabs height of the tabbed container.
void | SetSplitterStyle (DWORD dwStyle)
Call this member to set the splitter style.
DWORD | GetSplitterStyle () const
Call this method to get the splitter style.
void | SetCaptionButtonStyle (XTPDockingPaneCaptionButtonStyle nStyle)
Call this member to set the caption button style.
XTPDockingPaneCaptionButtonStyle | GetCaptionButtonStyle () const
Call this method to get the caption button style.
XTPCurrentSystemTheme | GetCurrentSystemTheme () const
Call this member function to determine the current Windows XP theme in use.
void | SetLunaTheme (XTPCurrentSystemTheme systemTheme)
Call this method to force system theme.
virtual void | DrawAutoHidePanel (CDC *pDC, CRect rc, XTPDockingPaneDirection direction)
This mmethod is called by the framework to draw the docking pane auto-hide panel background and splitter.
void | SetCustomTitleBrushes (HBRUSH hbrActiveTitleHorz, HBRUSH hbrInactiveTitleHorz=NULL, HBRUSH hbrActiveTitleVert=NULL, HBRUSH hbrInactiveTitleVert=NULL, BOOL bDestroyOnCleanup=FALSE)
Sets custom title brushes.
HBRUSH | GetCustomTitleBrush (BOOL bActive, BOOL bVertical) const
Obtains the custom title brush.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Public Attributes

BOOL | m_bDrawGripper
TRUE to draw gripper.
- Public Attributes inherited from CXTPDockingPanePaintManager
BOOL | m_bUseBoldCaptionFont
TRUE to use bold font for caption.
BOOL | m_bHighlightActiveCaption
TRUE to highlight active caption.
int | m_nSplitterSize
Splitter size.
BOOL | m_bShowCaption
TRUE to draw captions of tabbed containers.
BOOL | m_bDrawSingleTab
TRUE to draw single tab.
BOOL | m_bDrawCaptionIcon
TRUE to draw caption icon.
int | m_nSplitterIndent
Size of splitter indent.
CXTPPaintManagerColor | m_clrBackground
Background color.
CXTPPaintManagerColor | m_clrSplitterGripper
Splitter gripper color.
CXTPPaintManagerColor | m_clrSplitter
Splitter color.
CXTPPaintManagerColorGradient | m_clrSplitterGradient
Splitter gradient color.
CXTPPaintManagerColorGradient | m_clrNormalCaption
Color of pane caption when inactive.
CXTPPaintManagerColorGradient | m_clrActiveCaption
Color of pane caption when active.
CXTPPaintManagerColor | m_clrNormalCaptionText
Color of pane caption text when the caption is inactive.
CXTPPaintManagerColor | m_clrActiveCaptionText
Active caption text.
CXTPPaintManagerColor | m_clrDisabledCaptionText
Disabled caption text.

Protected Member Functions

virtual void | DrawCaptionPart (CDC *pDC, CXTPDockingPaneBase *pPane, CRect rcCaption, const CString &strTitle, BOOL bActive, BOOL bVertical)
Draws the common part of a tabbed and floating caption.
- Protected Member Functions inherited from CXTPDockingPaneVisualStudio2003Theme
virtual COLORREF | FillCaptionPart (CDC *pDC, CXTPDockingPaneBase *pPane, CRect rcCaption, BOOL bActive, BOOL bVertical)
Draws the background of the pane caption.
- Protected Member Functions inherited from CXTPDockingPaneGripperedTheme
- Protected Member Functions inherited from CXTPDockingPaneDefaultTheme
- Protected Member Functions inherited from CXTPDockingPanePaintManager
CXTPDockingPanePaintManager ()
Constructs a CXTPDockingPanePaintManager object.
virtual | ~CXTPDockingPanePaintManager ()
Destroys a CXTPDockingPanePaintManager object, handles cleanup and deallocation.
virtual void | DrawCaptionButtonEntry (CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton, CSize szOffset)
Draws only the glyph of a button.
virtual void | DrawCaptionButtonEntry (CDC *pDC, CXTPDockingPaneCaptionButton *pButton, CPoint pt, COLORREF clrButton)
Draws only the glyph of a button.
void | ClipAndAddEllipsisIfNeeded (CDC *pDC, CString &strTitle, int nCaptionWidth) const
Clip string and add ellipsis if its width less than nCaptionWidth.

Protected Attributes

BOOL | m_bRoundedCaption
TRUE to draw rounded caption.
- Protected Attributes inherited from CXTPDockingPaneVisualStudio2003Theme
BOOL | m_bGradientCaption
TRUE to draw gradient caption.
- Protected Attributes inherited from CXTPDockingPanePaintManager
XTPDockingPaneCaptionButtonStyle | m_nCaptionButtonStyle
Caption button style.
DWORD | m_dwSplitterStyle
Splitter style.
int | m_nTitleHeight
Title's height.
int | m_nCaptionFontGap
Additional gap of font.
int | m_nTabsHeight
Tab bar's height.
CXTPFont | m_xtpFontTitle
Title font.
CXTPFont | m_xtpFontTitleVertical
Title vertical font.
BOOL | m_bUseOfficeFont
TRUE to use Tahoma font.
BOOL | m_bUseStandardFont
TRUE to use system icon font.
BOOL | m_bDestroyCustomTitleBrushes
If TRUE, custom title bushes will be destroyed on cleanup.
HBRUSH | m_hbrActiveTitleHorz
Optional user specified active horizontal title brush.
HBRUSH | m_hbrInactiveTitleHorz
Optional user specified inactive horizontal title brush.
HBRUSH | m_hbrActiveTitleVert
Optional user specified active vertical title brush.
HBRUSH | m_hbrInactiveTitleVert
Optional user specified inactive vertical title brush.
CXTPTabPaintManager * | m_pTabPaintManager
Paint Manager used to draw tabs for a tabbed container.
CXTPTabPaintManager * | m_pPanelPaintManager
Paint Manager used to draw tabs for an auto-hide panel.
COLORREF | m_arrColor [XPCOLOR_LAST+1]
Self colors array.
XTPDockingPanePaintTheme | m_themeCurrent
Current theme.
CString | m_strOfficeFont
Office font name.
CRect | m_rcCaptionMargin
Margins of caption.
XTPCurrentSystemTheme | m_systemTheme
Current system theme.
CXTPWinThemeWrapper * | m_themeToolbar
Toolbar theme helper.
CXTPWinThemeWrapper * | m_themeExplorer
WinXP Explorer theme helper.
CXTPWinThemeWrapper * | m_themeButton
WinXP Button theme helper.
CXTPWinThemeWrapper * | m_themeWindow
WinXP Window Theme helper.
CXTPWinThemeWrapper * | m_themeRebar
Rebar theme helper.
BOOL | m_bLunaTheme
TRUE if luna colors are used.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

CXTPDockingPaneOffice2003Theme is a CXTPDockingPaneVisualStudio2003Theme derived class that represents an Office 2003 theme for docking panes.

Call CXTPDockingPaneManager::SetTheme(xtpPaneThemeOffice2003); to set this theme.

Member Function Documentation

◆ DrawCaption()

virtual void DrawCaption | ( | CDC * | pDC,
 |  | CXTPDockingPaneTabbedContainer * | pPane,
 |  | CRect | rc )
 virtual

Override this member function to draw a caption.

Parameters
pDC | Reference to the device context in which to draw.
pPane | Pointer to the tabbed container.
rc | Client rectangle of the tabbed container.

Reimplemented from CXTPDockingPaneGripperedTheme.

Reimplemented in CXTPDockingPaneOffice2007OutlookTheme, CXTPDockingPaneOffice2007Theme, and CXTPDockingPaneOffice2007WordTheme.

◆ DrawCaptionPart()

virtual void DrawCaptionPart | ( | CDC * | pDC,
 |  | CXTPDockingPaneBase * | pPane,
 |  | CRect | rcCaption,
 |  | const CString & | strTitle,
 |  | BOOL | bActive,
 |  | BOOL | bVertical )
 protectedvirtual

Draws the common part of a tabbed and floating caption.

Parameters
pDC | Reference to the device context in which to draw.
pPane | Container which the caption needs to draw.
rcCaption | Caption bounding rectangle.
strTitle | Caption text.
bActive | TRUE if the caption is active.
bVertical | TRUE to draw the caption vertically.

Reimplemented from CXTPDockingPaneVisualStudio2003Theme.

Reimplemented in CXTPDockingPaneOffice2007WordTheme.

◆ DrawFloatingFrame()

virtual void DrawFloatingFrame | ( | CDC * | pDC,
 |  | CXTPDockingPaneMiniWnd * | pPane,
 |  | CRect | rc )
 virtual

Call this method to draw the frame of a floating window.

Parameters
pDC | Pointer to a valid device context.
pPane | Floating window pointer.
rc | Client rectangle of the floating frame.

Reimplemented from CXTPDockingPaneGripperedTheme.

◆ DrawSidePanel()

virtual void DrawSidePanel | ( | CDC * | pDC,
 |  | CXTPDockingPaneSidePanel * | pPane,
 |  | CRect | rc )
 virtual

Override this member function to draw the side panel.

Parameters
pDC | Reference to the device context in which to draw.
pPane | Pointer to the side panel.
rc | Client rectangle of the side panel.

Reimplemented from CXTPDockingPaneDefaultTheme.

◆ GetCaptionGripperRect()

virtual CRect GetCaptionGripperRect ( const CXTPDockingPaneTabbedContainer * pPane )
virtual

Call this method to get the caption gripper for a tabbed container.

Parameters
pPane Tabbed container to test.
Returns
Bounding rectangle of the gripper to set size cursor.

Reimplemented from CXTPDockingPanePaintManager.

Reimplemented in CXTPDockingPaneOffice2003OutlookTheme.

◆ GetPaneCaptionRect()

virtual CRect GetPaneCaptionRect ( const CXTPDockingPaneSidePanel * pPane )
virtual

Call this method to get the pane's caption rectangle.

Parameters
pPane Side panel container to get caption CRect.
Returns
Bounding rectangle of the side panel's caption.

Reimplemented from CXTPDockingPanePaintManager.

The documentation for this class was generated from the following file:
  • XTPDockingPaneThemeOffice2003.h


Toolkit Pro: CXTPDockingPaneOffice2003VisioTheme Class Reference

Public Member Functions | List of all members
CXTPDockingPaneOffice2003VisioTheme Class Reference

CXTPDockingPaneOffice2003VisioTheme is a CXTPDockingPaneOffice2002VisioTheme derived class that represents an Office 2003 Visio theme for docking panes. More...

Inheritance diagram for CXTPDockingPaneOffice2003VisioTheme:
[legend]

Public Member Functions

CXTPDockingPaneOffice2003VisioTheme ()
Constructs a CXTPDockingPaneOffice2003VisioTheme object.
- Public Member Functions inherited from CXTPDockingPaneOffice2002VisioTheme
CXTPDockingPaneOffice2002VisioTheme ()
Constructs a CXTPDockingPaneOffice2002VisioTheme object.
void | RefreshMetrics ()
This method is called to refresh the visual metrics of the pane.
void | DrawCaption (CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc)
Override this member function to draw a caption.
void | DrawPane (CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc)
Override this member function to draw a tabbed container.
void | AdjustCaptionRect (const CXTPDockingPaneTabbedContainer *pPane, CRect &rc)
Override this member to change the caption rectangle of the child docking pane.
void | DrawFloatingFrame (CDC *pDC, CXTPDockingPaneMiniWnd *pPane, CRect rc)
Call this method to draw the frame of a floating window.
- Public Member Functions inherited from CXTPDockingPaneVisualStudio2003Theme
CXTPDockingPaneVisualStudio2003Theme ()
Constructs a CXTPDockingPaneVisualStudio2003Theme object.
- Public Member Functions inherited from CXTPDockingPaneGripperedTheme
CXTPDockingPaneGripperedTheme ()
Constructs a CXTPDockingPaneGripperedTheme object.
- Public Member Functions inherited from CXTPDockingPaneDefaultTheme
CXTPDockingPaneDefaultTheme ()
Constructs a CXTPDockingPaneDefaultTheme object.
virtual void | DrawSidePanel (CDC *pDC, CXTPDockingPaneSidePanel *pPane, CRect rc)
Override this member function to draw the side panel.
- Public Member Functions inherited from CXTPDockingPanePaintManager
virtual CRect | GetPaneCaptionRect (const CXTPDockingPaneSidePanel *pPane)
Call this method to get the pane's caption rectangle.
virtual void | DrawSplitter (CDC *pDC, CXTPDockingPaneSplitterWnd *pSplitter)
Override this method to draw a splitter.
virtual void | DrawCaptionButtons (CDC *pDC, CXTPDockingPaneCaptionButtons *pButtons, CRect &rcCaption, COLORREF clr, int nButtonSize, int nButtonGap, BOOL bVertical=FALSE)
Override this member function to draw buttons for a tabbed caption.
virtual void | DrawCaptionButton (CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton)
Override this member function to draw a button for a tabbed caption.
virtual void | AdjustClientRect (CXTPDockingPaneSidePanel *pPane, CRect &rect)
Override this member to change the client rectangle of the child docking pane.
virtual void | AdjustClientRect (CXTPDockingPaneTabbedContainer *pPane, CRect &rect, BOOL bApply)
Override this member to change the client rectangle of the child docking pane.
virtual void | AdjustCaptionRect (const CXTPDockingPaneSidePanel *pPane, CRect &rc)
Override this member to change the caption rectangle of the child docking pane.
virtual void | GetCaptionRect (const CXTPDockingPaneTabbedContainer *pPane, CRect &rc)
Call this method to get a caption rectangle.
virtual CRect | GetCaptionGripperRect (const CXTPDockingPaneTabbedContainer *pPane)
Call this method to get a caption gripper for a tabbed container.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1, int nPen)
Draws a line.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1)
Draws a line.
int | DrawCaptionText (CDC *pDC, const CString &strTitle, CRect rc, BOOL bVertical, BOOL bCalcWidth=FALSE)
Draws the text of a pane caption.
void | Pixel (CDC *pDC, int xPos, int yPos, int nPen)
Sets the pixel at the point.
void | Rectangle (CDC *pDC, CRect rc, int nPenEntry, int nPenBorder)
Draws a rectangle.
void | UseOfficeFont (BOOL bUseOfficeFont)
Call this member to use Office (Tahoma) font.
void | SetCaptionFontIndirect (LOGFONT *pLogFont, BOOL bUseStandardFont=FALSE)
Call this method to set the caption's font.
CXTPTabPaintManager * | SetTabPaintManager (CXTPTabPaintManager *pManager)
Call this method to set the paint manager used to draw tabs of a tabbed container.
CXTPTabPaintManager * | SetPanelPaintManager (CXTPTabPaintManager *pManager)
Call this method to set the paint manager used to draw tabs of an auto-hide panel.
CXTPTabPaintManager * | GetTabPaintManager () const
Retrieves the paint manager used to draw tabs of a tabbed container.
CXTPTabPaintManager * | GetPanelPaintManager () const
Retrieves the paint manager used to draw tabs of an auto-hide panel.
COLORREF | GetXtremeColor (UINT nIndex)
Retrieves the current color of the specified XP display element.
void | SetColors (int cElements, CONST INT *lpaElements, CONST COLORREF *lpaRgbValues)
Call this member to set the colors for each element in an array to the colors in a specified color array.
int | GetCaptionHeight () const
Call this member to get the caption height of the tabbed container.
int | GetTabsHeight () const
Call this member to get tabs height of the tabbed container.
void | SetSplitterStyle (DWORD dwStyle)
Call this member to set the splitter style.
DWORD | GetSplitterStyle () const
Call this method to get the splitter style.
void | SetCaptionButtonStyle (XTPDockingPaneCaptionButtonStyle nStyle)
Call this member to set the caption button style.
XTPDockingPaneCaptionButtonStyle | GetCaptionButtonStyle () const
Call this method to get the caption button style.
XTPCurrentSystemTheme | GetCurrentSystemTheme () const
Call this member function to determine the current Windows XP theme in use.
void | SetLunaTheme (XTPCurrentSystemTheme systemTheme)
Call this method to force system theme.
virtual void | DrawAutoHidePanel (CDC *pDC, CRect rc, XTPDockingPaneDirection direction)
This mmethod is called by the framework to draw the docking pane auto-hide panel background and splitter.
void | SetCustomTitleBrushes (HBRUSH hbrActiveTitleHorz, HBRUSH hbrInactiveTitleHorz=NULL, HBRUSH hbrActiveTitleVert=NULL, HBRUSH hbrInactiveTitleVert=NULL, BOOL bDestroyOnCleanup=FALSE)
Sets custom title brushes.
HBRUSH | GetCustomTitleBrush (BOOL bActive, BOOL bVertical) const
Obtains the custom title brush.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPDockingPanePaintManager
BOOL | m_bUseBoldCaptionFont
TRUE to use bold font for caption.
BOOL | m_bHighlightActiveCaption
TRUE to highlight active caption.
int | m_nSplitterSize
Splitter size.
BOOL | m_bShowCaption
TRUE to draw captions of tabbed containers.
BOOL | m_bDrawSingleTab
TRUE to draw single tab.
BOOL | m_bDrawCaptionIcon
TRUE to draw caption icon.
int | m_nSplitterIndent
Size of splitter indent.
CXTPPaintManagerColor | m_clrBackground
Background color.
CXTPPaintManagerColor | m_clrSplitterGripper
Splitter gripper color.
CXTPPaintManagerColor | m_clrSplitter
Splitter color.
CXTPPaintManagerColorGradient | m_clrSplitterGradient
Splitter gradient color.
CXTPPaintManagerColorGradient | m_clrNormalCaption
Color of pane caption when inactive.
CXTPPaintManagerColorGradient | m_clrActiveCaption
Color of pane caption when active.
CXTPPaintManagerColor | m_clrNormalCaptionText
Color of pane caption text when the caption is inactive.
CXTPPaintManagerColor | m_clrActiveCaptionText
Active caption text.
CXTPPaintManagerColor | m_clrDisabledCaptionText
Disabled caption text.
- Protected Member Functions inherited from CXTPDockingPaneVisualStudio2003Theme
virtual void | DrawCaptionPart (CDC *pDC, CXTPDockingPaneBase *pPane, CRect rcCaption, const CString &strTitle, BOOL bActive, BOOL bVertical)
Draws the common part of a tabbed and floating caption.
virtual COLORREF | FillCaptionPart (CDC *pDC, CXTPDockingPaneBase *pPane, CRect rcCaption, BOOL bActive, BOOL bVertical)
Draws the background of the pane caption.
- Protected Member Functions inherited from CXTPDockingPaneGripperedTheme
- Protected Member Functions inherited from CXTPDockingPaneDefaultTheme
- Protected Member Functions inherited from CXTPDockingPanePaintManager
CXTPDockingPanePaintManager ()
Constructs a CXTPDockingPanePaintManager object.
virtual | ~CXTPDockingPanePaintManager ()
Destroys a CXTPDockingPanePaintManager object, handles cleanup and deallocation.
virtual void | DrawCaptionButtonEntry (CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton, CSize szOffset)
Draws only the glyph of a button.
virtual void | DrawCaptionButtonEntry (CDC *pDC, CXTPDockingPaneCaptionButton *pButton, CPoint pt, COLORREF clrButton)
Draws only the glyph of a button.
void | ClipAndAddEllipsisIfNeeded (CDC *pDC, CString &strTitle, int nCaptionWidth) const
Clip string and add ellipsis if its width less than nCaptionWidth.
- Protected Attributes inherited from CXTPDockingPaneVisualStudio2003Theme
BOOL | m_bGradientCaption
TRUE to draw gradient caption.
- Protected Attributes inherited from CXTPDockingPanePaintManager
XTPDockingPaneCaptionButtonStyle | m_nCaptionButtonStyle
Caption button style.
DWORD | m_dwSplitterStyle
Splitter style.
int | m_nTitleHeight
Title's height.
int | m_nCaptionFontGap
Additional gap of font.
int | m_nTabsHeight
Tab bar's height.
CXTPFont | m_xtpFontTitle
Title font.
CXTPFont | m_xtpFontTitleVertical
Title vertical font.
BOOL | m_bUseOfficeFont
TRUE to use Tahoma font.
BOOL | m_bUseStandardFont
TRUE to use system icon font.
BOOL | m_bDestroyCustomTitleBrushes
If TRUE, custom title bushes will be destroyed on cleanup.
HBRUSH | m_hbrActiveTitleHorz
Optional user specified active horizontal title brush.
HBRUSH | m_hbrInactiveTitleHorz
Optional user specified inactive horizontal title brush.
HBRUSH | m_hbrActiveTitleVert
Optional user specified active vertical title brush.
HBRUSH | m_hbrInactiveTitleVert
Optional user specified inactive vertical title brush.
CXTPTabPaintManager * | m_pTabPaintManager
Paint Manager used to draw tabs for a tabbed container.
CXTPTabPaintManager * | m_pPanelPaintManager
Paint Manager used to draw tabs for an auto-hide panel.
COLORREF | m_arrColor [XPCOLOR_LAST+1]
Self colors array.
XTPDockingPanePaintTheme | m_themeCurrent
Current theme.
CString | m_strOfficeFont
Office font name.
CRect | m_rcCaptionMargin
Margins of caption.
XTPCurrentSystemTheme | m_systemTheme
Current system theme.
CXTPWinThemeWrapper * | m_themeToolbar
Toolbar theme helper.
CXTPWinThemeWrapper * | m_themeExplorer
WinXP Explorer theme helper.
CXTPWinThemeWrapper * | m_themeButton
WinXP Button theme helper.
CXTPWinThemeWrapper * | m_themeWindow
WinXP Window Theme helper.
CXTPWinThemeWrapper * | m_themeRebar
Rebar theme helper.
BOOL | m_bLunaTheme
TRUE if luna colors are used.

Detailed Description

CXTPDockingPaneOffice2003VisioTheme is a CXTPDockingPaneOffice2002VisioTheme derived class that represents an Office 2003 Visio theme for docking panes.

Call CXTPDockingPaneManager::SetTheme(xtpPaneThemeOffice2003Visio); to set this theme.

The documentation for this class was generated from the following file:
  • XTPDockingPaneThemeOffice2003Visio.h


Toolkit Pro: CXTPDockingPaneOffice2007OutlookTheme Class Reference

Public Member Functions | List of all members
CXTPDockingPaneOffice2007OutlookTheme Class Reference

CXTPDockingPaneOffice2007OutlookTheme is CXTPDockingPaneOffice2007Theme derived class that represents an Outlook 2007 theme for docking panes. More...

Inheritance diagram for CXTPDockingPaneOffice2007OutlookTheme:
[legend]

Public Member Functions

CXTPDockingPaneOffice2007OutlookTheme ()
Constructs a CXTPDockingPaneOffice2007OutlookTheme object.
void | RefreshMetrics ()
This method is called to refresh the visual metrics of the pane.
void | DrawCaption (CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc)
Override this member function to draw a caption.
- Public Member Functions inherited from CXTPDockingPaneOffice2007Theme
CXTPDockingPaneOffice2007Theme ()
Constructs a CXTPDockingPaneOffice2007Theme object.
void | RefreshMetrics ()
This method is called to refresh the visual metrics of the pane.
void | DrawCaption (CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc)
Override this member function to draw a caption.
- Public Member Functions inherited from CXTPDockingPaneOffice2003Theme
CXTPDockingPaneOffice2003Theme ()
Constructs a CXTPDockingPaneOffice2003Theme object.
virtual | ~CXTPDockingPaneOffice2003Theme ()
Destroys a CXTPDockingPaneOffice2003Theme object, handles cleanup and deallocation.
virtual void | DrawFloatingFrame (CDC *pDC, CXTPDockingPaneMiniWnd *pPane, CRect rc)
Call this method to draw the frame of a floating window.
virtual void | DrawSidePanel (CDC *pDC, CXTPDockingPaneSidePanel *pPane, CRect rc)
Override this member function to draw the side panel.
virtual CRect | GetPaneCaptionRect (const CXTPDockingPaneSidePanel *pPane)
Call this method to get the pane's caption rectangle.
virtual CRect | GetCaptionGripperRect (const CXTPDockingPaneTabbedContainer *pPane)
Call this method to get the caption gripper for a tabbed container.
- Public Member Functions inherited from CXTPDockingPaneVisualStudio2003Theme
CXTPDockingPaneVisualStudio2003Theme ()
Constructs a CXTPDockingPaneVisualStudio2003Theme object.
- Public Member Functions inherited from CXTPDockingPaneGripperedTheme
CXTPDockingPaneGripperedTheme ()
Constructs a CXTPDockingPaneGripperedTheme object.
- Public Member Functions inherited from CXTPDockingPaneDefaultTheme
CXTPDockingPaneDefaultTheme ()
Constructs a CXTPDockingPaneDefaultTheme object.
- Public Member Functions inherited from CXTPDockingPanePaintManager
virtual void | DrawPane (CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc)
Override this member function to draw a tabbed container.
virtual void | DrawSplitter (CDC *pDC, CXTPDockingPaneSplitterWnd *pSplitter)
Override this method to draw a splitter.
virtual void | DrawCaptionButtons (CDC *pDC, CXTPDockingPaneCaptionButtons *pButtons, CRect &rcCaption, COLORREF clr, int nButtonSize, int nButtonGap, BOOL bVertical=FALSE)
Override this member function to draw buttons for a tabbed caption.
virtual void | DrawCaptionButton (CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton)
Override this member function to draw a button for a tabbed caption.
virtual void | AdjustClientRect (CXTPDockingPaneSidePanel *pPane, CRect &rect)
Override this member to change the client rectangle of the child docking pane.
virtual void | AdjustClientRect (CXTPDockingPaneTabbedContainer *pPane, CRect &rect, BOOL bApply)
Override this member to change the client rectangle of the child docking pane.
virtual void | AdjustCaptionRect (const CXTPDockingPaneSidePanel *pPane, CRect &rc)
Override this member to change the caption rectangle of the child docking pane.
virtual void | AdjustCaptionRect (const CXTPDockingPaneTabbedContainer *pPane, CRect &rc)
Override this member to change the caption rectangle of the child docking pane.
virtual void | GetCaptionRect (const CXTPDockingPaneTabbedContainer *pPane, CRect &rc)
Call this method to get a caption rectangle.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1, int nPen)
Draws a line.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1)
Draws a line.
int | DrawCaptionText (CDC *pDC, const CString &strTitle, CRect rc, BOOL bVertical, BOOL bCalcWidth=FALSE)
Draws the text of a pane caption.
void | Pixel (CDC *pDC, int xPos, int yPos, int nPen)
Sets the pixel at the point.
void | Rectangle (CDC *pDC, CRect rc, int nPenEntry, int nPenBorder)
Draws a rectangle.
void | UseOfficeFont (BOOL bUseOfficeFont)
Call this member to use Office (Tahoma) font.
void | SetCaptionFontIndirect (LOGFONT *pLogFont, BOOL bUseStandardFont=FALSE)
Call this method to set the caption's font.
CXTPTabPaintManager * | SetTabPaintManager (CXTPTabPaintManager *pManager)
Call this method to set the paint manager used to draw tabs of a tabbed container.
CXTPTabPaintManager * | SetPanelPaintManager (CXTPTabPaintManager *pManager)
Call this method to set the paint manager used to draw tabs of an auto-hide panel.
CXTPTabPaintManager * | GetTabPaintManager () const
Retrieves the paint manager used to draw tabs of a tabbed container.
CXTPTabPaintManager * | GetPanelPaintManager () const
Retrieves the paint manager used to draw tabs of an auto-hide panel.
COLORREF | GetXtremeColor (UINT nIndex)
Retrieves the current color of the specified XP display element.
void | SetColors (int cElements, CONST INT *lpaElements, CONST COLORREF *lpaRgbValues)
Call this member to set the colors for each element in an array to the colors in a specified color array.
int | GetCaptionHeight () const
Call this member to get the caption height of the tabbed container.
int | GetTabsHeight () const
Call this member to get tabs height of the tabbed container.
void | SetSplitterStyle (DWORD dwStyle)
Call this member to set the splitter style.
DWORD | GetSplitterStyle () const
Call this method to get the splitter style.
void | SetCaptionButtonStyle (XTPDockingPaneCaptionButtonStyle nStyle)
Call this member to set the caption button style.
XTPDockingPaneCaptionButtonStyle | GetCaptionButtonStyle () const
Call this method to get the caption button style.
XTPCurrentSystemTheme | GetCurrentSystemTheme () const
Call this member function to determine the current Windows XP theme in use.
void | SetLunaTheme (XTPCurrentSystemTheme systemTheme)
Call this method to force system theme.
virtual void | DrawAutoHidePanel (CDC *pDC, CRect rc, XTPDockingPaneDirection direction)
This mmethod is called by the framework to draw the docking pane auto-hide panel background and splitter.
void | SetCustomTitleBrushes (HBRUSH hbrActiveTitleHorz, HBRUSH hbrInactiveTitleHorz=NULL, HBRUSH hbrActiveTitleVert=NULL, HBRUSH hbrInactiveTitleVert=NULL, BOOL bDestroyOnCleanup=FALSE)
Sets custom title brushes.
HBRUSH | GetCustomTitleBrush (BOOL bActive, BOOL bVertical) const
Obtains the custom title brush.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPDockingPaneOffice2003Theme
BOOL | m_bDrawGripper
TRUE to draw gripper.
- Public Attributes inherited from CXTPDockingPanePaintManager
BOOL | m_bUseBoldCaptionFont
TRUE to use bold font for caption.
BOOL | m_bHighlightActiveCaption
TRUE to highlight active caption.
int | m_nSplitterSize
Splitter size.
BOOL | m_bShowCaption
TRUE to draw captions of tabbed containers.
BOOL | m_bDrawSingleTab
TRUE to draw single tab.
BOOL | m_bDrawCaptionIcon
TRUE to draw caption icon.
int | m_nSplitterIndent
Size of splitter indent.
CXTPPaintManagerColor | m_clrBackground
Background color.
CXTPPaintManagerColor | m_clrSplitterGripper
Splitter gripper color.
CXTPPaintManagerColor | m_clrSplitter
Splitter color.
CXTPPaintManagerColorGradient | m_clrSplitterGradient
Splitter gradient color.
CXTPPaintManagerColorGradient | m_clrNormalCaption
Color of pane caption when inactive.
CXTPPaintManagerColorGradient | m_clrActiveCaption
Color of pane caption when active.
CXTPPaintManagerColor | m_clrNormalCaptionText
Color of pane caption text when the caption is inactive.
CXTPPaintManagerColor | m_clrActiveCaptionText
Active caption text.
CXTPPaintManagerColor | m_clrDisabledCaptionText
Disabled caption text.
- Protected Member Functions inherited from CXTPDockingPaneOffice2003Theme
virtual void | DrawCaptionPart (CDC *pDC, CXTPDockingPaneBase *pPane, CRect rcCaption, const CString &strTitle, BOOL bActive, BOOL bVertical)
Draws the common part of a tabbed and floating caption.
- Protected Member Functions inherited from CXTPDockingPaneVisualStudio2003Theme
virtual COLORREF | FillCaptionPart (CDC *pDC, CXTPDockingPaneBase *pPane, CRect rcCaption, BOOL bActive, BOOL bVertical)
Draws the background of the pane caption.
- Protected Member Functions inherited from CXTPDockingPaneGripperedTheme
- Protected Member Functions inherited from CXTPDockingPaneDefaultTheme
- Protected Member Functions inherited from CXTPDockingPanePaintManager
CXTPDockingPanePaintManager ()
Constructs a CXTPDockingPanePaintManager object.
virtual | ~CXTPDockingPanePaintManager ()
Destroys a CXTPDockingPanePaintManager object, handles cleanup and deallocation.
virtual void | DrawCaptionButtonEntry (CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton, CSize szOffset)
Draws only the glyph of a button.
virtual void | DrawCaptionButtonEntry (CDC *pDC, CXTPDockingPaneCaptionButton *pButton, CPoint pt, COLORREF clrButton)
Draws only the glyph of a button.
void | ClipAndAddEllipsisIfNeeded (CDC *pDC, CString &strTitle, int nCaptionWidth) const
Clip string and add ellipsis if its width less than nCaptionWidth.
- Protected Attributes inherited from CXTPDockingPaneOffice2003Theme
BOOL | m_bRoundedCaption
TRUE to draw rounded caption.
- Protected Attributes inherited from CXTPDockingPaneVisualStudio2003Theme
BOOL | m_bGradientCaption
TRUE to draw gradient caption.
- Protected Attributes inherited from CXTPDockingPanePaintManager
XTPDockingPaneCaptionButtonStyle | m_nCaptionButtonStyle
Caption button style.
DWORD | m_dwSplitterStyle
Splitter style.
int | m_nTitleHeight
Title's height.
int | m_nCaptionFontGap
Additional gap of font.
int | m_nTabsHeight
Tab bar's height.
CXTPFont | m_xtpFontTitle
Title font.
CXTPFont | m_xtpFontTitleVertical
Title vertical font.
BOOL | m_bUseOfficeFont
TRUE to use Tahoma font.
BOOL | m_bUseStandardFont
TRUE to use system icon font.
BOOL | m_bDestroyCustomTitleBrushes
If TRUE, custom title bushes will be destroyed on cleanup.
HBRUSH | m_hbrActiveTitleHorz
Optional user specified active horizontal title brush.
HBRUSH | m_hbrInactiveTitleHorz
Optional user specified inactive horizontal title brush.
HBRUSH | m_hbrActiveTitleVert
Optional user specified active vertical title brush.
HBRUSH | m_hbrInactiveTitleVert
Optional user specified inactive vertical title brush.
CXTPTabPaintManager * | m_pTabPaintManager
Paint Manager used to draw tabs for a tabbed container.
CXTPTabPaintManager * | m_pPanelPaintManager
Paint Manager used to draw tabs for an auto-hide panel.
COLORREF | m_arrColor [XPCOLOR_LAST+1]
Self colors array.
XTPDockingPanePaintTheme | m_themeCurrent
Current theme.
CString | m_strOfficeFont
Office font name.
CRect | m_rcCaptionMargin
Margins of caption.
XTPCurrentSystemTheme | m_systemTheme
Current system theme.
CXTPWinThemeWrapper * | m_themeToolbar
Toolbar theme helper.
CXTPWinThemeWrapper * | m_themeExplorer
WinXP Explorer theme helper.
CXTPWinThemeWrapper * | m_themeButton
WinXP Button theme helper.
CXTPWinThemeWrapper * | m_themeWindow
WinXP Window Theme helper.
CXTPWinThemeWrapper * | m_themeRebar
Rebar theme helper.
BOOL | m_bLunaTheme
TRUE if luna colors are used.

Detailed Description

CXTPDockingPaneOffice2007OutlookTheme is CXTPDockingPaneOffice2007Theme derived class that represents an Outlook 2007 theme for docking panes.

Call CXTPDockingPaneManager::SetTheme(xtpPaneThemeOffice2007Outlook); to set this theme.

Member Function Documentation

◆ DrawCaption()

void DrawCaption | ( | CDC * | pDC,
 |  | CXTPDockingPaneTabbedContainer * | pPane,
 |  | CRect | rc )
 virtual

Override this member function to draw a caption.

Parameters
pDC | Reference to the device context in which to draw.
pPane | Pointer to the tabbed container.
rc | Client rectangle of the tabbed container.

Reimplemented from CXTPDockingPaneOffice2003Theme.

The documentation for this class was generated from the following file:
  • XTPDockingPaneThemeOffice2007Outlook.h


Toolkit Pro: CXTPDockingPaneOffice2007Theme Class Reference

Public Member Functions | List of all members
CXTPDockingPaneOffice2007Theme Class Reference

CXTPDockingPaneOffice2007Theme is a CXTPDockingPaneOffice2003Theme derived class that represents an Office 2007 theme for docking panes. More...

Inheritance diagram for CXTPDockingPaneOffice2007Theme:
[legend]

Public Member Functions

CXTPDockingPaneOffice2007Theme ()
Constructs a CXTPDockingPaneOffice2007Theme object.
void | RefreshMetrics ()
This method is called to refresh the visual metrics of the pane.
void | DrawCaption (CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc)
Override this member function to draw a caption.
- Public Member Functions inherited from CXTPDockingPaneOffice2003Theme
CXTPDockingPaneOffice2003Theme ()
Constructs a CXTPDockingPaneOffice2003Theme object.
virtual | ~CXTPDockingPaneOffice2003Theme ()
Destroys a CXTPDockingPaneOffice2003Theme object, handles cleanup and deallocation.
virtual void | DrawFloatingFrame (CDC *pDC, CXTPDockingPaneMiniWnd *pPane, CRect rc)
Call this method to draw the frame of a floating window.
virtual void | DrawSidePanel (CDC *pDC, CXTPDockingPaneSidePanel *pPane, CRect rc)
Override this member function to draw the side panel.
virtual CRect | GetPaneCaptionRect (const CXTPDockingPaneSidePanel *pPane)
Call this method to get the pane's caption rectangle.
virtual CRect | GetCaptionGripperRect (const CXTPDockingPaneTabbedContainer *pPane)
Call this method to get the caption gripper for a tabbed container.
- Public Member Functions inherited from CXTPDockingPaneVisualStudio2003Theme
CXTPDockingPaneVisualStudio2003Theme ()
Constructs a CXTPDockingPaneVisualStudio2003Theme object.
- Public Member Functions inherited from CXTPDockingPaneGripperedTheme
CXTPDockingPaneGripperedTheme ()
Constructs a CXTPDockingPaneGripperedTheme object.
- Public Member Functions inherited from CXTPDockingPaneDefaultTheme
CXTPDockingPaneDefaultTheme ()
Constructs a CXTPDockingPaneDefaultTheme object.
- Public Member Functions inherited from CXTPDockingPanePaintManager
virtual void | DrawPane (CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc)
Override this member function to draw a tabbed container.
virtual void | DrawSplitter (CDC *pDC, CXTPDockingPaneSplitterWnd *pSplitter)
Override this method to draw a splitter.
virtual void | DrawCaptionButtons (CDC *pDC, CXTPDockingPaneCaptionButtons *pButtons, CRect &rcCaption, COLORREF clr, int nButtonSize, int nButtonGap, BOOL bVertical=FALSE)
Override this member function to draw buttons for a tabbed caption.
virtual void | DrawCaptionButton (CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton)
Override this member function to draw a button for a tabbed caption.
virtual void | AdjustClientRect (CXTPDockingPaneSidePanel *pPane, CRect &rect)
Override this member to change the client rectangle of the child docking pane.
virtual void | AdjustClientRect (CXTPDockingPaneTabbedContainer *pPane, CRect &rect, BOOL bApply)
Override this member to change the client rectangle of the child docking pane.
virtual void | AdjustCaptionRect (const CXTPDockingPaneSidePanel *pPane, CRect &rc)
Override this member to change the caption rectangle of the child docking pane.
virtual void | AdjustCaptionRect (const CXTPDockingPaneTabbedContainer *pPane, CRect &rc)
Override this member to change the caption rectangle of the child docking pane.
virtual void | GetCaptionRect (const CXTPDockingPaneTabbedContainer *pPane, CRect &rc)
Call this method to get a caption rectangle.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1, int nPen)
Draws a line.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1)
Draws a line.
int | DrawCaptionText (CDC *pDC, const CString &strTitle, CRect rc, BOOL bVertical, BOOL bCalcWidth=FALSE)
Draws the text of a pane caption.
void | Pixel (CDC *pDC, int xPos, int yPos, int nPen)
Sets the pixel at the point.
void | Rectangle (CDC *pDC, CRect rc, int nPenEntry, int nPenBorder)
Draws a rectangle.
void | UseOfficeFont (BOOL bUseOfficeFont)
Call this member to use Office (Tahoma) font.
void | SetCaptionFontIndirect (LOGFONT *pLogFont, BOOL bUseStandardFont=FALSE)
Call this method to set the caption's font.
CXTPTabPaintManager * | SetTabPaintManager (CXTPTabPaintManager *pManager)
Call this method to set the paint manager used to draw tabs of a tabbed container.
CXTPTabPaintManager * | SetPanelPaintManager (CXTPTabPaintManager *pManager)
Call this method to set the paint manager used to draw tabs of an auto-hide panel.
CXTPTabPaintManager * | GetTabPaintManager () const
Retrieves the paint manager used to draw tabs of a tabbed container.
CXTPTabPaintManager * | GetPanelPaintManager () const
Retrieves the paint manager used to draw tabs of an auto-hide panel.
COLORREF | GetXtremeColor (UINT nIndex)
Retrieves the current color of the specified XP display element.
void | SetColors (int cElements, CONST INT *lpaElements, CONST COLORREF *lpaRgbValues)
Call this member to set the colors for each element in an array to the colors in a specified color array.
int | GetCaptionHeight () const
Call this member to get the caption height of the tabbed container.
int | GetTabsHeight () const
Call this member to get tabs height of the tabbed container.
void | SetSplitterStyle (DWORD dwStyle)
Call this member to set the splitter style.
DWORD | GetSplitterStyle () const
Call this method to get the splitter style.
void | SetCaptionButtonStyle (XTPDockingPaneCaptionButtonStyle nStyle)
Call this member to set the caption button style.
XTPDockingPaneCaptionButtonStyle | GetCaptionButtonStyle () const
Call this method to get the caption button style.
XTPCurrentSystemTheme | GetCurrentSystemTheme () const
Call this member function to determine the current Windows XP theme in use.
void | SetLunaTheme (XTPCurrentSystemTheme systemTheme)
Call this method to force system theme.
virtual void | DrawAutoHidePanel (CDC *pDC, CRect rc, XTPDockingPaneDirection direction)
This mmethod is called by the framework to draw the docking pane auto-hide panel background and splitter.
void | SetCustomTitleBrushes (HBRUSH hbrActiveTitleHorz, HBRUSH hbrInactiveTitleHorz=NULL, HBRUSH hbrActiveTitleVert=NULL, HBRUSH hbrInactiveTitleVert=NULL, BOOL bDestroyOnCleanup=FALSE)
Sets custom title brushes.
HBRUSH | GetCustomTitleBrush (BOOL bActive, BOOL bVertical) const
Obtains the custom title brush.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPDockingPaneOffice2003Theme
BOOL | m_bDrawGripper
TRUE to draw gripper.
- Public Attributes inherited from CXTPDockingPanePaintManager
BOOL | m_bUseBoldCaptionFont
TRUE to use bold font for caption.
BOOL | m_bHighlightActiveCaption
TRUE to highlight active caption.
int | m_nSplitterSize
Splitter size.
BOOL | m_bShowCaption
TRUE to draw captions of tabbed containers.
BOOL | m_bDrawSingleTab
TRUE to draw single tab.
BOOL | m_bDrawCaptionIcon
TRUE to draw caption icon.
int | m_nSplitterIndent
Size of splitter indent.
CXTPPaintManagerColor | m_clrBackground
Background color.
CXTPPaintManagerColor | m_clrSplitterGripper
Splitter gripper color.
CXTPPaintManagerColor | m_clrSplitter
Splitter color.
CXTPPaintManagerColorGradient | m_clrSplitterGradient
Splitter gradient color.
CXTPPaintManagerColorGradient | m_clrNormalCaption
Color of pane caption when inactive.
CXTPPaintManagerColorGradient | m_clrActiveCaption
Color of pane caption when active.
CXTPPaintManagerColor | m_clrNormalCaptionText
Color of pane caption text when the caption is inactive.
CXTPPaintManagerColor | m_clrActiveCaptionText
Active caption text.
CXTPPaintManagerColor | m_clrDisabledCaptionText
Disabled caption text.
- Protected Member Functions inherited from CXTPDockingPaneOffice2003Theme
virtual void | DrawCaptionPart (CDC *pDC, CXTPDockingPaneBase *pPane, CRect rcCaption, const CString &strTitle, BOOL bActive, BOOL bVertical)
Draws the common part of a tabbed and floating caption.
- Protected Member Functions inherited from CXTPDockingPaneVisualStudio2003Theme
virtual COLORREF | FillCaptionPart (CDC *pDC, CXTPDockingPaneBase *pPane, CRect rcCaption, BOOL bActive, BOOL bVertical)
Draws the background of the pane caption.
- Protected Member Functions inherited from CXTPDockingPaneGripperedTheme
- Protected Member Functions inherited from CXTPDockingPaneDefaultTheme
- Protected Member Functions inherited from CXTPDockingPanePaintManager
CXTPDockingPanePaintManager ()
Constructs a CXTPDockingPanePaintManager object.
virtual | ~CXTPDockingPanePaintManager ()
Destroys a CXTPDockingPanePaintManager object, handles cleanup and deallocation.
virtual void | DrawCaptionButtonEntry (CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton, CSize szOffset)
Draws only the glyph of a button.
virtual void | DrawCaptionButtonEntry (CDC *pDC, CXTPDockingPaneCaptionButton *pButton, CPoint pt, COLORREF clrButton)
Draws only the glyph of a button.
void | ClipAndAddEllipsisIfNeeded (CDC *pDC, CString &strTitle, int nCaptionWidth) const
Clip string and add ellipsis if its width less than nCaptionWidth.
- Protected Attributes inherited from CXTPDockingPaneOffice2003Theme
BOOL | m_bRoundedCaption
TRUE to draw rounded caption.
- Protected Attributes inherited from CXTPDockingPaneVisualStudio2003Theme
BOOL | m_bGradientCaption
TRUE to draw gradient caption.
- Protected Attributes inherited from CXTPDockingPanePaintManager
XTPDockingPaneCaptionButtonStyle | m_nCaptionButtonStyle
Caption button style.
DWORD | m_dwSplitterStyle
Splitter style.
int | m_nTitleHeight
Title's height.
int | m_nCaptionFontGap
Additional gap of font.
int | m_nTabsHeight
Tab bar's height.
CXTPFont | m_xtpFontTitle
Title font.
CXTPFont | m_xtpFontTitleVertical
Title vertical font.
BOOL | m_bUseOfficeFont
TRUE to use Tahoma font.
BOOL | m_bUseStandardFont
TRUE to use system icon font.
BOOL | m_bDestroyCustomTitleBrushes
If TRUE, custom title bushes will be destroyed on cleanup.
HBRUSH | m_hbrActiveTitleHorz
Optional user specified active horizontal title brush.
HBRUSH | m_hbrInactiveTitleHorz
Optional user specified inactive horizontal title brush.
HBRUSH | m_hbrActiveTitleVert
Optional user specified active vertical title brush.
HBRUSH | m_hbrInactiveTitleVert
Optional user specified inactive vertical title brush.
CXTPTabPaintManager * | m_pTabPaintManager
Paint Manager used to draw tabs for a tabbed container.
CXTPTabPaintManager * | m_pPanelPaintManager
Paint Manager used to draw tabs for an auto-hide panel.
COLORREF | m_arrColor [XPCOLOR_LAST+1]
Self colors array.
XTPDockingPanePaintTheme | m_themeCurrent
Current theme.
CString | m_strOfficeFont
Office font name.
CRect | m_rcCaptionMargin
Margins of caption.
XTPCurrentSystemTheme | m_systemTheme
Current system theme.
CXTPWinThemeWrapper * | m_themeToolbar
Toolbar theme helper.
CXTPWinThemeWrapper * | m_themeExplorer
WinXP Explorer theme helper.
CXTPWinThemeWrapper * | m_themeButton
WinXP Button theme helper.
CXTPWinThemeWrapper * | m_themeWindow
WinXP Window Theme helper.
CXTPWinThemeWrapper * | m_themeRebar
Rebar theme helper.
BOOL | m_bLunaTheme
TRUE if luna colors are used.

Detailed Description

CXTPDockingPaneOffice2007Theme is a CXTPDockingPaneOffice2003Theme derived class that represents an Office 2007 theme for docking panes.

Call CXTPDockingPaneManager::SetTheme(xtpPaneThemeResource); to set this theme.

Member Function Documentation

◆ DrawCaption()

void DrawCaption | ( | CDC * | pDC,
 |  | CXTPDockingPaneTabbedContainer * | pPane,
 |  | CRect | rc )
 virtual

Override this member function to draw a caption.

Parameters
pDC | Reference to the device context in which to draw.
pPane | Pointer to the tabbed container.
rc | Client rectangle of the tabbed container.

Reimplemented from CXTPDockingPaneOffice2003Theme.

The documentation for this class was generated from the following file:
  • XTPDockingPaneThemeOffice2007.h


Toolkit Pro: CXTPDockingPaneOffice2007VisioTheme Class Reference

Public Member Functions | List of all members
CXTPDockingPaneOffice2007VisioTheme Class Reference

CXTPDockingPaneOffice2007VisioTheme is a CXTPDockingPaneOffice2003VisioTheme derived class that represents an Office 2007 Visio theme for docking panes. More...

Inheritance diagram for CXTPDockingPaneOffice2007VisioTheme:
[legend]

Public Member Functions

CXTPDockingPaneOffice2007VisioTheme ()
Constructs a CXTPDockingPaneOffice2007VisioTheme object.
- Public Member Functions inherited from CXTPDockingPaneOffice2003VisioTheme
CXTPDockingPaneOffice2003VisioTheme ()
Constructs a CXTPDockingPaneOffice2003VisioTheme object.
- Public Member Functions inherited from CXTPDockingPaneOffice2002VisioTheme
CXTPDockingPaneOffice2002VisioTheme ()
Constructs a CXTPDockingPaneOffice2002VisioTheme object.
void | RefreshMetrics ()
This method is called to refresh the visual metrics of the pane.
void | DrawCaption (CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc)
Override this member function to draw a caption.
void | DrawPane (CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc)
Override this member function to draw a tabbed container.
void | AdjustCaptionRect (const CXTPDockingPaneTabbedContainer *pPane, CRect &rc)
Override this member to change the caption rectangle of the child docking pane.
void | DrawFloatingFrame (CDC *pDC, CXTPDockingPaneMiniWnd *pPane, CRect rc)
Call this method to draw the frame of a floating window.
- Public Member Functions inherited from CXTPDockingPaneVisualStudio2003Theme
CXTPDockingPaneVisualStudio2003Theme ()
Constructs a CXTPDockingPaneVisualStudio2003Theme object.
- Public Member Functions inherited from CXTPDockingPaneGripperedTheme
CXTPDockingPaneGripperedTheme ()
Constructs a CXTPDockingPaneGripperedTheme object.
- Public Member Functions inherited from CXTPDockingPaneDefaultTheme
CXTPDockingPaneDefaultTheme ()
Constructs a CXTPDockingPaneDefaultTheme object.
virtual void | DrawSidePanel (CDC *pDC, CXTPDockingPaneSidePanel *pPane, CRect rc)
Override this member function to draw the side panel.
- Public Member Functions inherited from CXTPDockingPanePaintManager
virtual CRect | GetPaneCaptionRect (const CXTPDockingPaneSidePanel *pPane)
Call this method to get the pane's caption rectangle.
virtual void | DrawSplitter (CDC *pDC, CXTPDockingPaneSplitterWnd *pSplitter)
Override this method to draw a splitter.
virtual void | DrawCaptionButtons (CDC *pDC, CXTPDockingPaneCaptionButtons *pButtons, CRect &rcCaption, COLORREF clr, int nButtonSize, int nButtonGap, BOOL bVertical=FALSE)
Override this member function to draw buttons for a tabbed caption.
virtual void | DrawCaptionButton (CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton)
Override this member function to draw a button for a tabbed caption.
virtual void | AdjustClientRect (CXTPDockingPaneSidePanel *pPane, CRect &rect)
Override this member to change the client rectangle of the child docking pane.
virtual void | AdjustClientRect (CXTPDockingPaneTabbedContainer *pPane, CRect &rect, BOOL bApply)
Override this member to change the client rectangle of the child docking pane.
virtual void | AdjustCaptionRect (const CXTPDockingPaneSidePanel *pPane, CRect &rc)
Override this member to change the caption rectangle of the child docking pane.
virtual void | GetCaptionRect (const CXTPDockingPaneTabbedContainer *pPane, CRect &rc)
Call this method to get a caption rectangle.
virtual CRect | GetCaptionGripperRect (const CXTPDockingPaneTabbedContainer *pPane)
Call this method to get a caption gripper for a tabbed container.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1, int nPen)
Draws a line.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1)
Draws a line.
int | DrawCaptionText (CDC *pDC, const CString &strTitle, CRect rc, BOOL bVertical, BOOL bCalcWidth=FALSE)
Draws the text of a pane caption.
void | Pixel (CDC *pDC, int xPos, int yPos, int nPen)
Sets the pixel at the point.
void | Rectangle (CDC *pDC, CRect rc, int nPenEntry, int nPenBorder)
Draws a rectangle.
void | UseOfficeFont (BOOL bUseOfficeFont)
Call this member to use Office (Tahoma) font.
void | SetCaptionFontIndirect (LOGFONT *pLogFont, BOOL bUseStandardFont=FALSE)
Call this method to set the caption's font.
CXTPTabPaintManager * | SetTabPaintManager (CXTPTabPaintManager *pManager)
Call this method to set the paint manager used to draw tabs of a tabbed container.
CXTPTabPaintManager * | SetPanelPaintManager (CXTPTabPaintManager *pManager)
Call this method to set the paint manager used to draw tabs of an auto-hide panel.
CXTPTabPaintManager * | GetTabPaintManager () const
Retrieves the paint manager used to draw tabs of a tabbed container.
CXTPTabPaintManager * | GetPanelPaintManager () const
Retrieves the paint manager used to draw tabs of an auto-hide panel.
COLORREF | GetXtremeColor (UINT nIndex)
Retrieves the current color of the specified XP display element.
void | SetColors (int cElements, CONST INT *lpaElements, CONST COLORREF *lpaRgbValues)
Call this member to set the colors for each element in an array to the colors in a specified color array.
int | GetCaptionHeight () const
Call this member to get the caption height of the tabbed container.
int | GetTabsHeight () const
Call this member to get tabs height of the tabbed container.
void | SetSplitterStyle (DWORD dwStyle)
Call this member to set the splitter style.
DWORD | GetSplitterStyle () const
Call this method to get the splitter style.
void | SetCaptionButtonStyle (XTPDockingPaneCaptionButtonStyle nStyle)
Call this member to set the caption button style.
XTPDockingPaneCaptionButtonStyle | GetCaptionButtonStyle () const
Call this method to get the caption button style.
XTPCurrentSystemTheme | GetCurrentSystemTheme () const
Call this member function to determine the current Windows XP theme in use.
void | SetLunaTheme (XTPCurrentSystemTheme systemTheme)
Call this method to force system theme.
virtual void | DrawAutoHidePanel (CDC *pDC, CRect rc, XTPDockingPaneDirection direction)
This mmethod is called by the framework to draw the docking pane auto-hide panel background and splitter.
void | SetCustomTitleBrushes (HBRUSH hbrActiveTitleHorz, HBRUSH hbrInactiveTitleHorz=NULL, HBRUSH hbrActiveTitleVert=NULL, HBRUSH hbrInactiveTitleVert=NULL, BOOL bDestroyOnCleanup=FALSE)
Sets custom title brushes.
HBRUSH | GetCustomTitleBrush (BOOL bActive, BOOL bVertical) const
Obtains the custom title brush.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPDockingPanePaintManager
BOOL | m_bUseBoldCaptionFont
TRUE to use bold font for caption.
BOOL | m_bHighlightActiveCaption
TRUE to highlight active caption.
int | m_nSplitterSize
Splitter size.
BOOL | m_bShowCaption
TRUE to draw captions of tabbed containers.
BOOL | m_bDrawSingleTab
TRUE to draw single tab.
BOOL | m_bDrawCaptionIcon
TRUE to draw caption icon.
int | m_nSplitterIndent
Size of splitter indent.
CXTPPaintManagerColor | m_clrBackground
Background color.
CXTPPaintManagerColor | m_clrSplitterGripper
Splitter gripper color.
CXTPPaintManagerColor | m_clrSplitter
Splitter color.
CXTPPaintManagerColorGradient | m_clrSplitterGradient
Splitter gradient color.
CXTPPaintManagerColorGradient | m_clrNormalCaption
Color of pane caption when inactive.
CXTPPaintManagerColorGradient | m_clrActiveCaption
Color of pane caption when active.
CXTPPaintManagerColor | m_clrNormalCaptionText
Color of pane caption text when the caption is inactive.
CXTPPaintManagerColor | m_clrActiveCaptionText
Active caption text.
CXTPPaintManagerColor | m_clrDisabledCaptionText
Disabled caption text.
- Protected Member Functions inherited from CXTPDockingPaneVisualStudio2003Theme
virtual void | DrawCaptionPart (CDC *pDC, CXTPDockingPaneBase *pPane, CRect rcCaption, const CString &strTitle, BOOL bActive, BOOL bVertical)
Draws the common part of a tabbed and floating caption.
virtual COLORREF | FillCaptionPart (CDC *pDC, CXTPDockingPaneBase *pPane, CRect rcCaption, BOOL bActive, BOOL bVertical)
Draws the background of the pane caption.
- Protected Member Functions inherited from CXTPDockingPaneGripperedTheme
- Protected Member Functions inherited from CXTPDockingPaneDefaultTheme
- Protected Member Functions inherited from CXTPDockingPanePaintManager
CXTPDockingPanePaintManager ()
Constructs a CXTPDockingPanePaintManager object.
virtual | ~CXTPDockingPanePaintManager ()
Destroys a CXTPDockingPanePaintManager object, handles cleanup and deallocation.
virtual void | DrawCaptionButtonEntry (CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton, CSize szOffset)
Draws only the glyph of a button.
virtual void | DrawCaptionButtonEntry (CDC *pDC, CXTPDockingPaneCaptionButton *pButton, CPoint pt, COLORREF clrButton)
Draws only the glyph of a button.
void | ClipAndAddEllipsisIfNeeded (CDC *pDC, CString &strTitle, int nCaptionWidth) const
Clip string and add ellipsis if its width less than nCaptionWidth.
- Protected Attributes inherited from CXTPDockingPaneVisualStudio2003Theme
BOOL | m_bGradientCaption
TRUE to draw gradient caption.
- Protected Attributes inherited from CXTPDockingPanePaintManager
XTPDockingPaneCaptionButtonStyle | m_nCaptionButtonStyle
Caption button style.
DWORD | m_dwSplitterStyle
Splitter style.
int | m_nTitleHeight
Title's height.
int | m_nCaptionFontGap
Additional gap of font.
int | m_nTabsHeight
Tab bar's height.
CXTPFont | m_xtpFontTitle
Title font.
CXTPFont | m_xtpFontTitleVertical
Title vertical font.
BOOL | m_bUseOfficeFont
TRUE to use Tahoma font.
BOOL | m_bUseStandardFont
TRUE to use system icon font.
BOOL | m_bDestroyCustomTitleBrushes
If TRUE, custom title bushes will be destroyed on cleanup.
HBRUSH | m_hbrActiveTitleHorz
Optional user specified active horizontal title brush.
HBRUSH | m_hbrInactiveTitleHorz
Optional user specified inactive horizontal title brush.
HBRUSH | m_hbrActiveTitleVert
Optional user specified active vertical title brush.
HBRUSH | m_hbrInactiveTitleVert
Optional user specified inactive vertical title brush.
CXTPTabPaintManager * | m_pTabPaintManager
Paint Manager used to draw tabs for a tabbed container.
CXTPTabPaintManager * | m_pPanelPaintManager
Paint Manager used to draw tabs for an auto-hide panel.
COLORREF | m_arrColor [XPCOLOR_LAST+1]
Self colors array.
XTPDockingPanePaintTheme | m_themeCurrent
Current theme.
CString | m_strOfficeFont
Office font name.
CRect | m_rcCaptionMargin
Margins of caption.
XTPCurrentSystemTheme | m_systemTheme
Current system theme.
CXTPWinThemeWrapper * | m_themeToolbar
Toolbar theme helper.
CXTPWinThemeWrapper * | m_themeExplorer
WinXP Explorer theme helper.
CXTPWinThemeWrapper * | m_themeButton
WinXP Button theme helper.
CXTPWinThemeWrapper * | m_themeWindow
WinXP Window Theme helper.
CXTPWinThemeWrapper * | m_themeRebar
Rebar theme helper.
BOOL | m_bLunaTheme
TRUE if luna colors are used.

Detailed Description

CXTPDockingPaneOffice2007VisioTheme is a CXTPDockingPaneOffice2003VisioTheme derived class that represents an Office 2007 Visio theme for docking panes.

Call CXTPDockingPaneManager::SetTheme(xtpPaneThemeOffice2007Visio); to set this theme.

The documentation for this class was generated from the following file:
  • XTPDockingPaneThemeOffice2007Visio.h


Toolkit Pro: CXTPDockingPaneOffice2007WordTheme Class Reference

Public Member Functions | List of all members
CXTPDockingPaneOffice2007WordTheme Class Reference

CXTPDockingPaneOffice2007WordTheme is a CXTPDockingPaneOffice2003Theme derived class that represents an Office Word 2007 theme for docking panes. More...

Inheritance diagram for CXTPDockingPaneOffice2007WordTheme:
[legend]

Public Member Functions

CXTPDockingPaneOffice2007WordTheme ()
Constructs a CXTPDockingPaneOffice2007WordTheme object.
void | RefreshMetrics ()
This method is called to refresh the visual metrics of the pane.
void | DrawCaption (CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc)
Override this member function to draw a caption.
void | DrawCaptionPart (CDC *pDC, CXTPDockingPaneBase *pPane, CRect rcCaption, const CString &strTitle, BOOL bActive, BOOL bVertical)
Draws the common part of a tabbed and floating caption.
void | AdjustClientRect (CXTPDockingPaneTabbedContainer *pPane, CRect &rect, BOOL bApply)
Override this member to change the client rectangle of the child docking pane.
void | DrawPane (CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc)
Override this member function to draw a tabbed container.
BOOL | PaneHasBorders (CXTPDockingPaneTabbedContainer *pPane) const
Determines if a pane has borders (if title is visible).
- Public Member Functions inherited from CXTPDockingPaneOffice2003Theme
CXTPDockingPaneOffice2003Theme ()
Constructs a CXTPDockingPaneOffice2003Theme object.
virtual | ~CXTPDockingPaneOffice2003Theme ()
Destroys a CXTPDockingPaneOffice2003Theme object, handles cleanup and deallocation.
virtual void | DrawFloatingFrame (CDC *pDC, CXTPDockingPaneMiniWnd *pPane, CRect rc)
Call this method to draw the frame of a floating window.
virtual void | DrawSidePanel (CDC *pDC, CXTPDockingPaneSidePanel *pPane, CRect rc)
Override this member function to draw the side panel.
virtual CRect | GetPaneCaptionRect (const CXTPDockingPaneSidePanel *pPane)
Call this method to get the pane's caption rectangle.
virtual CRect | GetCaptionGripperRect (const CXTPDockingPaneTabbedContainer *pPane)
Call this method to get the caption gripper for a tabbed container.
- Public Member Functions inherited from CXTPDockingPaneVisualStudio2003Theme
CXTPDockingPaneVisualStudio2003Theme ()
Constructs a CXTPDockingPaneVisualStudio2003Theme object.
- Public Member Functions inherited from CXTPDockingPaneGripperedTheme
CXTPDockingPaneGripperedTheme ()
Constructs a CXTPDockingPaneGripperedTheme object.
- Public Member Functions inherited from CXTPDockingPaneDefaultTheme
CXTPDockingPaneDefaultTheme ()
Constructs a CXTPDockingPaneDefaultTheme object.
- Public Member Functions inherited from CXTPDockingPanePaintManager
virtual void | DrawSplitter (CDC *pDC, CXTPDockingPaneSplitterWnd *pSplitter)
Override this method to draw a splitter.
virtual void | DrawCaptionButtons (CDC *pDC, CXTPDockingPaneCaptionButtons *pButtons, CRect &rcCaption, COLORREF clr, int nButtonSize, int nButtonGap, BOOL bVertical=FALSE)
Override this member function to draw buttons for a tabbed caption.
virtual void | DrawCaptionButton (CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton)
Override this member function to draw a button for a tabbed caption.
virtual void | AdjustClientRect (CXTPDockingPaneSidePanel *pPane, CRect &rect)
Override this member to change the client rectangle of the child docking pane.
virtual void | AdjustCaptionRect (const CXTPDockingPaneSidePanel *pPane, CRect &rc)
Override this member to change the caption rectangle of the child docking pane.
virtual void | AdjustCaptionRect (const CXTPDockingPaneTabbedContainer *pPane, CRect &rc)
Override this member to change the caption rectangle of the child docking pane.
virtual void | GetCaptionRect (const CXTPDockingPaneTabbedContainer *pPane, CRect &rc)
Call this method to get a caption rectangle.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1, int nPen)
Draws a line.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1)
Draws a line.
int | DrawCaptionText (CDC *pDC, const CString &strTitle, CRect rc, BOOL bVertical, BOOL bCalcWidth=FALSE)
Draws the text of a pane caption.
void | Pixel (CDC *pDC, int xPos, int yPos, int nPen)
Sets the pixel at the point.
void | Rectangle (CDC *pDC, CRect rc, int nPenEntry, int nPenBorder)
Draws a rectangle.
void | UseOfficeFont (BOOL bUseOfficeFont)
Call this member to use Office (Tahoma) font.
void | SetCaptionFontIndirect (LOGFONT *pLogFont, BOOL bUseStandardFont=FALSE)
Call this method to set the caption's font.
CXTPTabPaintManager * | SetTabPaintManager (CXTPTabPaintManager *pManager)
Call this method to set the paint manager used to draw tabs of a tabbed container.
CXTPTabPaintManager * | SetPanelPaintManager (CXTPTabPaintManager *pManager)
Call this method to set the paint manager used to draw tabs of an auto-hide panel.
CXTPTabPaintManager * | GetTabPaintManager () const
Retrieves the paint manager used to draw tabs of a tabbed container.
CXTPTabPaintManager * | GetPanelPaintManager () const
Retrieves the paint manager used to draw tabs of an auto-hide panel.
COLORREF | GetXtremeColor (UINT nIndex)
Retrieves the current color of the specified XP display element.
void | SetColors (int cElements, CONST INT *lpaElements, CONST COLORREF *lpaRgbValues)
Call this member to set the colors for each element in an array to the colors in a specified color array.
int | GetCaptionHeight () const
Call this member to get the caption height of the tabbed container.
int | GetTabsHeight () const
Call this member to get tabs height of the tabbed container.
void | SetSplitterStyle (DWORD dwStyle)
Call this member to set the splitter style.
DWORD | GetSplitterStyle () const
Call this method to get the splitter style.
void | SetCaptionButtonStyle (XTPDockingPaneCaptionButtonStyle nStyle)
Call this member to set the caption button style.
XTPDockingPaneCaptionButtonStyle | GetCaptionButtonStyle () const
Call this method to get the caption button style.
XTPCurrentSystemTheme | GetCurrentSystemTheme () const
Call this member function to determine the current Windows XP theme in use.
void | SetLunaTheme (XTPCurrentSystemTheme systemTheme)
Call this method to force system theme.
virtual void | DrawAutoHidePanel (CDC *pDC, CRect rc, XTPDockingPaneDirection direction)
This mmethod is called by the framework to draw the docking pane auto-hide panel background and splitter.
void | SetCustomTitleBrushes (HBRUSH hbrActiveTitleHorz, HBRUSH hbrInactiveTitleHorz=NULL, HBRUSH hbrActiveTitleVert=NULL, HBRUSH hbrInactiveTitleVert=NULL, BOOL bDestroyOnCleanup=FALSE)
Sets custom title brushes.
HBRUSH | GetCustomTitleBrush (BOOL bActive, BOOL bVertical) const
Obtains the custom title brush.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPDockingPaneOffice2003Theme
BOOL | m_bDrawGripper
TRUE to draw gripper.
- Public Attributes inherited from CXTPDockingPanePaintManager
BOOL | m_bUseBoldCaptionFont
TRUE to use bold font for caption.
BOOL | m_bHighlightActiveCaption
TRUE to highlight active caption.
int | m_nSplitterSize
Splitter size.
BOOL | m_bShowCaption
TRUE to draw captions of tabbed containers.
BOOL | m_bDrawSingleTab
TRUE to draw single tab.
BOOL | m_bDrawCaptionIcon
TRUE to draw caption icon.
int | m_nSplitterIndent
Size of splitter indent.
CXTPPaintManagerColor | m_clrBackground
Background color.
CXTPPaintManagerColor | m_clrSplitterGripper
Splitter gripper color.
CXTPPaintManagerColor | m_clrSplitter
Splitter color.
CXTPPaintManagerColorGradient | m_clrSplitterGradient
Splitter gradient color.
CXTPPaintManagerColorGradient | m_clrNormalCaption
Color of pane caption when inactive.
CXTPPaintManagerColorGradient | m_clrActiveCaption
Color of pane caption when active.
CXTPPaintManagerColor | m_clrNormalCaptionText
Color of pane caption text when the caption is inactive.
CXTPPaintManagerColor | m_clrActiveCaptionText
Active caption text.
CXTPPaintManagerColor | m_clrDisabledCaptionText
Disabled caption text.
- Protected Member Functions inherited from CXTPDockingPaneOffice2003Theme
- Protected Member Functions inherited from CXTPDockingPaneVisualStudio2003Theme
virtual COLORREF | FillCaptionPart (CDC *pDC, CXTPDockingPaneBase *pPane, CRect rcCaption, BOOL bActive, BOOL bVertical)
Draws the background of the pane caption.
- Protected Member Functions inherited from CXTPDockingPaneGripperedTheme
- Protected Member Functions inherited from CXTPDockingPaneDefaultTheme
- Protected Member Functions inherited from CXTPDockingPanePaintManager
CXTPDockingPanePaintManager ()
Constructs a CXTPDockingPanePaintManager object.
virtual | ~CXTPDockingPanePaintManager ()
Destroys a CXTPDockingPanePaintManager object, handles cleanup and deallocation.
virtual void | DrawCaptionButtonEntry (CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton, CSize szOffset)
Draws only the glyph of a button.
virtual void | DrawCaptionButtonEntry (CDC *pDC, CXTPDockingPaneCaptionButton *pButton, CPoint pt, COLORREF clrButton)
Draws only the glyph of a button.
void | ClipAndAddEllipsisIfNeeded (CDC *pDC, CString &strTitle, int nCaptionWidth) const
Clip string and add ellipsis if its width less than nCaptionWidth.
- Protected Attributes inherited from CXTPDockingPaneOffice2003Theme
BOOL | m_bRoundedCaption
TRUE to draw rounded caption.
- Protected Attributes inherited from CXTPDockingPaneVisualStudio2003Theme
BOOL | m_bGradientCaption
TRUE to draw gradient caption.
- Protected Attributes inherited from CXTPDockingPanePaintManager
XTPDockingPaneCaptionButtonStyle | m_nCaptionButtonStyle
Caption button style.
DWORD | m_dwSplitterStyle
Splitter style.
int | m_nTitleHeight
Title's height.
int | m_nCaptionFontGap
Additional gap of font.
int | m_nTabsHeight
Tab bar's height.
CXTPFont | m_xtpFontTitle
Title font.
CXTPFont | m_xtpFontTitleVertical
Title vertical font.
BOOL | m_bUseOfficeFont
TRUE to use Tahoma font.
BOOL | m_bUseStandardFont
TRUE to use system icon font.
BOOL | m_bDestroyCustomTitleBrushes
If TRUE, custom title bushes will be destroyed on cleanup.
HBRUSH | m_hbrActiveTitleHorz
Optional user specified active horizontal title brush.
HBRUSH | m_hbrInactiveTitleHorz
Optional user specified inactive horizontal title brush.
HBRUSH | m_hbrActiveTitleVert
Optional user specified active vertical title brush.
HBRUSH | m_hbrInactiveTitleVert
Optional user specified inactive vertical title brush.
CXTPTabPaintManager * | m_pTabPaintManager
Paint Manager used to draw tabs for a tabbed container.
CXTPTabPaintManager * | m_pPanelPaintManager
Paint Manager used to draw tabs for an auto-hide panel.
COLORREF | m_arrColor [XPCOLOR_LAST+1]
Self colors array.
XTPDockingPanePaintTheme | m_themeCurrent
Current theme.
CString | m_strOfficeFont
Office font name.
CRect | m_rcCaptionMargin
Margins of caption.
XTPCurrentSystemTheme | m_systemTheme
Current system theme.
CXTPWinThemeWrapper * | m_themeToolbar
Toolbar theme helper.
CXTPWinThemeWrapper * | m_themeExplorer
WinXP Explorer theme helper.
CXTPWinThemeWrapper * | m_themeButton
WinXP Button theme helper.
CXTPWinThemeWrapper * | m_themeWindow
WinXP Window Theme helper.
CXTPWinThemeWrapper * | m_themeRebar
Rebar theme helper.
BOOL | m_bLunaTheme
TRUE if luna colors are used.

Detailed Description

CXTPDockingPaneOffice2007WordTheme is a CXTPDockingPaneOffice2003Theme derived class that represents an Office Word 2007 theme for docking panes.

Call CXTPDockingPaneManager::SetTheme(xtpPaneThemeOffice2007Word); to set this theme.

Member Function Documentation

◆ AdjustClientRect()

void AdjustClientRect | ( | CXTPDockingPaneTabbedContainer * | pPane,
 |  | CRect & | rect,
 |  | BOOL | bApply )
 virtual

Override this member to change the client rectangle of the child docking pane.

Parameters
pPane | Pointer to the tabbed container.
rect | Client rectangle to be changed.
bApply | TRUE to update tabs inside the client area.

Reimplemented from CXTPDockingPanePaintManager.

◆ DrawCaption()

void DrawCaption | ( | CDC * | pDC,
 |  | CXTPDockingPaneTabbedContainer * | pPane,
 |  | CRect | rc )
 virtual

Override this member function to draw a caption.

Parameters
pDC | Reference to the device context in which to draw.
pPane | Pointer to the tabbed container.
rc | Client rectangle of the tabbed container.

Reimplemented from CXTPDockingPaneOffice2003Theme.

◆ DrawCaptionPart()

void DrawCaptionPart | ( | CDC * | pDC,
 |  | CXTPDockingPaneBase * | pPane,
 |  | CRect | rcCaption,
 |  | const CString & | strTitle,
 |  | BOOL | bActive,
 |  | BOOL | bVertical )
 virtual

Draws the common part of a tabbed and floating caption.

Parameters
pDC | Reference to the device context in which to draw.
pPane | Container which the caption needs to draw.
rcCaption | Caption bounding rectangle.
strTitle | Caption text.
bActive | TRUE if the caption is active.
bVertical | TRUE to draw the caption vertically.

Reimplemented from CXTPDockingPaneOffice2003Theme.

◆ DrawPane()

void DrawPane | ( | CDC * | pDC,
 |  | CXTPDockingPaneTabbedContainer * | pPane,
 |  | CRect | rc )
 virtual

Override this member function to draw a tabbed container.

Parameters
pDC | Reference to the device context in which to draw.
pPane | Pointer to the tabbed container.
rc | Client rectangle of the tabbed container.

Reimplemented from CXTPDockingPanePaintManager.

◆ PaneHasBorders()

BOOL PaneHasBorders ( CXTPDockingPaneTabbedContainer * pPane ) const

Determines if a pane has borders (if title is visible).

Parameters
pPane Pointer to the tabbed container.
Returns
TRUE if the pane has borders (title visible), otherwise FALSE.
The documentation for this class was generated from the following file:
  • XTPDockingPaneThemeOffice2007Word.h


Toolkit Pro: CXTPDockingPaneOffice2013Theme Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPDockingPaneOffice2013Theme Class Reference

CXTPDockingPaneOffice2013Theme is used to define drawing routines specific to an Office 2013 docking pane theme. More...

Inheritance diagram for CXTPDockingPaneOffice2013Theme:
[legend]

Public Member Functions

CXTPDockingPaneOffice2013Theme ()
Constructs a CXTPDockingPaneOffice2013Theme object.
virtual | ~CXTPDockingPaneOffice2013Theme ()
Destroys a CXTPDockingPaneOffice2013Theme object, handles cleanup and deallocation.
virtual void | RefreshMetrics ()
This member function is used to initialize default colors for a theme from an .INI resource.
virtual void | DrawSplitter (CDC *pDC, CXTPDockingPaneSplitterWnd *pSplitter)
Override this method to draw a splitter.
virtual void | DrawCaption (CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc)
Override this member function to draw a caption.
virtual void | DrawFloatingFrame (CDC *pDC, CXTPDockingPaneMiniWnd *pPane, CRect rc)
Call this method to draw the frame of a floating window.
virtual void | DrawPane (CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc)
Override this member function to draw a tabbed container.
virtual void | DrawSidePanel (CDC *pDC, CXTPDockingPaneSidePanel *pPane, CRect rc)
Override this member function to draw the side panel.
virtual void | DrawCaptionButton (CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton)
Override this member function to draw a button for a tabbed caption.
virtual void | DrawAutoHidePanel (CDC *pDC, CRect rc, XTPDockingPaneDirection direction)
This method is called by the framework to draw the docking pane auto-hide panel background and splitter.
- Public Member Functions inherited from CXTPDockingPaneVisualStudio2012Theme
CXTPDockingPaneVisualStudio2012Theme ()
Constructs a CXTPDockingPaneVisualStudio2012Theme object.
virtual | ~CXTPDockingPaneVisualStudio2012Theme ()
Destroys a CXTPDockingPaneVisualStudio2012Theme object, handles cleanup and deallocation.
virtual CRect | GetPaneCaptionRect (const CXTPDockingPaneSidePanel *pPane)
Call this method to get the pane's caption rectangle.
virtual void | AdjustClientRect (CXTPDockingPaneTabbedContainer *pPane, CRect &rc, BOOL bApply)
Override this member to change the client rectangle of the child docking pane.
virtual void | AdjustCaptionRect (const CXTPDockingPaneTabbedContainer *pPane, CRect &rc)
Override this member to change the caption rectangle of the child docking pane.
- Public Member Functions inherited from CXTPDockingPaneDefaultTheme
CXTPDockingPaneDefaultTheme ()
Constructs a CXTPDockingPaneDefaultTheme object.
- Public Member Functions inherited from CXTPDockingPanePaintManager
virtual void | DrawCaptionButtons (CDC *pDC, CXTPDockingPaneCaptionButtons *pButtons, CRect &rcCaption, COLORREF clr, int nButtonSize, int nButtonGap, BOOL bVertical=FALSE)
Override this member function to draw buttons for a tabbed caption.
virtual void | AdjustClientRect (CXTPDockingPaneSidePanel *pPane, CRect &rect)
Override this member to change the client rectangle of the child docking pane.
virtual void | AdjustCaptionRect (const CXTPDockingPaneSidePanel *pPane, CRect &rc)
Override this member to change the caption rectangle of the child docking pane.
virtual void | GetCaptionRect (const CXTPDockingPaneTabbedContainer *pPane, CRect &rc)
Call this method to get a caption rectangle.
virtual CRect | GetCaptionGripperRect (const CXTPDockingPaneTabbedContainer *pPane)
Call this method to get a caption gripper for a tabbed container.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1, int nPen)
Draws a line.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1)
Draws a line.
int | DrawCaptionText (CDC *pDC, const CString &strTitle, CRect rc, BOOL bVertical, BOOL bCalcWidth=FALSE)
Draws the text of a pane caption.
void | Pixel (CDC *pDC, int xPos, int yPos, int nPen)
Sets the pixel at the point.
void | Rectangle (CDC *pDC, CRect rc, int nPenEntry, int nPenBorder)
Draws a rectangle.
void | UseOfficeFont (BOOL bUseOfficeFont)
Call this member to use Office (Tahoma) font.
void | SetCaptionFontIndirect (LOGFONT *pLogFont, BOOL bUseStandardFont=FALSE)
Call this method to set the caption's font.
CXTPTabPaintManager * | SetTabPaintManager (CXTPTabPaintManager *pManager)
Call this method to set the paint manager used to draw tabs of a tabbed container.
CXTPTabPaintManager * | SetPanelPaintManager (CXTPTabPaintManager *pManager)
Call this method to set the paint manager used to draw tabs of an auto-hide panel.
CXTPTabPaintManager * | GetTabPaintManager () const
Retrieves the paint manager used to draw tabs of a tabbed container.
CXTPTabPaintManager * | GetPanelPaintManager () const
Retrieves the paint manager used to draw tabs of an auto-hide panel.
COLORREF | GetXtremeColor (UINT nIndex)
Retrieves the current color of the specified XP display element.
void | SetColors (int cElements, CONST INT *lpaElements, CONST COLORREF *lpaRgbValues)
Call this member to set the colors for each element in an array to the colors in a specified color array.
int | GetCaptionHeight () const
Call this member to get the caption height of the tabbed container.
int | GetTabsHeight () const
Call this member to get tabs height of the tabbed container.
void | SetSplitterStyle (DWORD dwStyle)
Call this member to set the splitter style.
DWORD | GetSplitterStyle () const
Call this method to get the splitter style.
void | SetCaptionButtonStyle (XTPDockingPaneCaptionButtonStyle nStyle)
Call this member to set the caption button style.
XTPDockingPaneCaptionButtonStyle | GetCaptionButtonStyle () const
Call this method to get the caption button style.
XTPCurrentSystemTheme | GetCurrentSystemTheme () const
Call this member function to determine the current Windows XP theme in use.
void | SetLunaTheme (XTPCurrentSystemTheme systemTheme)
Call this method to force system theme.
void | SetCustomTitleBrushes (HBRUSH hbrActiveTitleHorz, HBRUSH hbrInactiveTitleHorz=NULL, HBRUSH hbrActiveTitleVert=NULL, HBRUSH hbrInactiveTitleVert=NULL, BOOL bDestroyOnCleanup=FALSE)
Sets custom title brushes.
HBRUSH | GetCustomTitleBrush (BOOL bActive, BOOL bVertical) const
Obtains the custom title brush.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

virtual void | DrawTitleBar (CDC *pDC, CXTPDockingPaneBase *pPane, CRect rc, BOOL bVertical)
This member function is called to draw a title bar for the docking pane.
- Protected Member Functions inherited from CXTPDockingPaneVisualStudio2012Theme
void | DrawGripper (CDC *pDC, CRect rcGripper, COLORREF clr, BOOL bVertical)
This member function is called to draw a gripper for the docking pane.
void | DrawDottedLine (CDC *pDC, int x, int y, int nSize, COLORREF clr, BOOL bVertical)
This member function is called to draw a dotted line.
virtual CXTPDockingPaneColorSet * | GetColorSet (BOOL bActive)
Call this member function to retrieve the active or inactive color set for the Docking Pane using the state specified by bActive.
void | SetPaneColorSets (CXTPDockingPaneColorSet *pcsActive, CXTPDockingPaneColorSet *pcsInactive)
Called to initialize the active and inactive colors sets for the docking pane theme.
void | DeletePaneColorSets ()
Called to free the memory allocated for the docking pane active and inactive color sets.
- Protected Member Functions inherited from CXTPDockingPaneDefaultTheme
virtual void | DrawCaptionPart (CDC *pDC, CXTPDockingPaneBase *pPane, CRect rcCaption, const CString &strTitle, BOOL bActive, BOOL bVertical)
Draws the common part of a tabbed and floating caption.
- Protected Member Functions inherited from CXTPDockingPanePaintManager
CXTPDockingPanePaintManager ()
Constructs a CXTPDockingPanePaintManager object.
virtual | ~CXTPDockingPanePaintManager ()
Destroys a CXTPDockingPanePaintManager object, handles cleanup and deallocation.
virtual void | DrawCaptionButtonEntry (CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton, CSize szOffset)
Draws only the glyph of a button.
virtual void | DrawCaptionButtonEntry (CDC *pDC, CXTPDockingPaneCaptionButton *pButton, CPoint pt, COLORREF clrButton)
Draws only the glyph of a button.
void | ClipAndAddEllipsisIfNeeded (CDC *pDC, CString &strTitle, int nCaptionWidth) const
Clip string and add ellipsis if its width less than nCaptionWidth.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPDockingPanePaintManager
BOOL | m_bUseBoldCaptionFont
TRUE to use bold font for caption.
BOOL | m_bHighlightActiveCaption
TRUE to highlight active caption.
int | m_nSplitterSize
Splitter size.
BOOL | m_bShowCaption
TRUE to draw captions of tabbed containers.
BOOL | m_bDrawSingleTab
TRUE to draw single tab.
BOOL | m_bDrawCaptionIcon
TRUE to draw caption icon.
int | m_nSplitterIndent
Size of splitter indent.
CXTPPaintManagerColor | m_clrBackground
Background color.
CXTPPaintManagerColor | m_clrSplitterGripper
Splitter gripper color.
CXTPPaintManagerColor | m_clrSplitter
Splitter color.
CXTPPaintManagerColorGradient | m_clrSplitterGradient
Splitter gradient color.
CXTPPaintManagerColorGradient | m_clrNormalCaption
Color of pane caption when inactive.
CXTPPaintManagerColorGradient | m_clrActiveCaption
Color of pane caption when active.
CXTPPaintManagerColor | m_clrNormalCaptionText
Color of pane caption text when the caption is inactive.
CXTPPaintManagerColor | m_clrActiveCaptionText
Active caption text.
CXTPPaintManagerColor | m_clrDisabledCaptionText
Disabled caption text.
- Protected Attributes inherited from CXTPDockingPaneVisualStudio2012Theme
CXTPDockingPaneColorSet * | m_pcsActive
Active state docking pane colors.
CXTPDockingPaneColorSet * | m_pcsInactive
Inactive state docking pane colors.
CString | m_strFontFace
Font face name.
int | m_nFontSize
Font size in points.
- Protected Attributes inherited from CXTPDockingPanePaintManager
XTPDockingPaneCaptionButtonStyle | m_nCaptionButtonStyle
Caption button style.
DWORD | m_dwSplitterStyle
Splitter style.
int | m_nTitleHeight
Title's height.
int | m_nCaptionFontGap
Additional gap of font.
int | m_nTabsHeight
Tab bar's height.
CXTPFont | m_xtpFontTitle
Title font.
CXTPFont | m_xtpFontTitleVertical
Title vertical font.
BOOL | m_bUseOfficeFont
TRUE to use Tahoma font.
BOOL | m_bUseStandardFont
TRUE to use system icon font.
BOOL | m_bDestroyCustomTitleBrushes
If TRUE, custom title bushes will be destroyed on cleanup.
HBRUSH | m_hbrActiveTitleHorz
Optional user specified active horizontal title brush.
HBRUSH | m_hbrInactiveTitleHorz
Optional user specified inactive horizontal title brush.
HBRUSH | m_hbrActiveTitleVert
Optional user specified active vertical title brush.
HBRUSH | m_hbrInactiveTitleVert
Optional user specified inactive vertical title brush.
CXTPTabPaintManager * | m_pTabPaintManager
Paint Manager used to draw tabs for a tabbed container.
CXTPTabPaintManager * | m_pPanelPaintManager
Paint Manager used to draw tabs for an auto-hide panel.
COLORREF | m_arrColor [XPCOLOR_LAST+1]
Self colors array.
XTPDockingPanePaintTheme | m_themeCurrent
Current theme.
CString | m_strOfficeFont
Office font name.
CRect | m_rcCaptionMargin
Margins of caption.
XTPCurrentSystemTheme | m_systemTheme
Current system theme.
CXTPWinThemeWrapper * | m_themeToolbar
Toolbar theme helper.
CXTPWinThemeWrapper * | m_themeExplorer
WinXP Explorer theme helper.
CXTPWinThemeWrapper * | m_themeButton
WinXP Button theme helper.
CXTPWinThemeWrapper * | m_themeWindow
WinXP Window Theme helper.
CXTPWinThemeWrapper * | m_themeRebar
Rebar theme helper.
BOOL | m_bLunaTheme
TRUE if luna colors are used.

Detailed Description

CXTPDockingPaneOffice2013Theme is used to define drawing routines specific to an Office 2013 docking pane theme.

Member Function Documentation

◆ DrawAutoHidePanel()

virtual void DrawAutoHidePanel | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | XTPDockingPaneDirection | direction )
 virtual

This method is called by the framework to draw the docking pane auto-hide panel background and splitter.

Parameters
pDC | Pointer to the auto-hide panes device context.
rc | Size of the area to draw.
direction | Docking direction (either xtpPaneDockLeft, xtpPaneDockRight, xtpPaneDockTop or xtpPaneDockBottom).

Reimplemented from CXTPDockingPaneVisualStudio2012Theme.

◆ DrawCaption()

virtual void DrawCaption | ( | CDC * | pDC,
 |  | CXTPDockingPaneTabbedContainer * | pPane,
 |  | CRect | rc )
 virtual

Override this member function to draw a caption.

Parameters
pDC | Reference to the device context in which to draw.
pPane | Pointer to the tabbed container.
rc | Client rectangle of the tabbed container.

Reimplemented from CXTPDockingPaneVisualStudio2012Theme.

◆ DrawCaptionButton()

virtual void DrawCaptionButton | ( | CDC * | pDC,
 |  | CXTPDockingPaneCaptionButton * | pButton,
 |  | COLORREF | clrButton )
 virtual

Override this member function to draw a button for a tabbed caption.

Parameters
pDC | Pointer to a valid device context.
pButton | Pointer to the button to draw.
clrButton | Color of the button's text.

Reimplemented from CXTPDockingPaneVisualStudio2012Theme.

◆ DrawFloatingFrame()

virtual void DrawFloatingFrame | ( | CDC * | pDC,
 |  | CXTPDockingPaneMiniWnd * | pPane,
 |  | CRect | rc )
 virtual

Call this method to draw the frame of a floating window.

Parameters
pDC | Pointer to a valid device context.
pPane | Floating window pointer.
rc | Client rectangle of the floating frame.

Reimplemented from CXTPDockingPaneVisualStudio2012Theme.

◆ DrawPane()

virtual void DrawPane | ( | CDC * | pDC,
 |  | CXTPDockingPaneTabbedContainer * | pPane,
 |  | CRect | rc )
 virtual

Override this member function to draw a tabbed container.

Parameters
pDC | Reference to the device context in which to draw.
pPane | Pointer to the tabbed container.
rc | Client rectangle of the tabbed container.

Reimplemented from CXTPDockingPaneVisualStudio2012Theme.

◆ DrawSidePanel()

virtual void DrawSidePanel | ( | CDC * | pDC,
 |  | CXTPDockingPaneSidePanel * | pPane,
 |  | CRect | rc )
 virtual

Override this member function to draw the side panel.

Parameters
pDC | Reference to the device context in which to draw.
pPane | Pointer to the side panel.
rc | Client rectangle of the side panel.

Reimplemented from CXTPDockingPaneVisualStudio2012Theme.

◆ DrawSplitter()

virtual void DrawSplitter | ( | CDC * | pDC,
 |  | CXTPDockingPaneSplitterWnd * | pSplitter )
 virtual

Override this method to draw a splitter.

Parameters
pDC | Pointer to a valid device context.
pSplitter | Pointer to a splitter window.

Reimplemented from CXTPDockingPaneVisualStudio2012Theme.

◆ DrawTitleBar()

virtual void DrawTitleBar | ( | CDC * | pDC,
 |  | CXTPDockingPaneBase * | pPane,
 |  | CRect | rc,
 |  | BOOL | bVertical )
 protectedvirtual

This member function is called to draw a title bar for the docking pane.

Parameters
pDC | Pointer to a valid device context.
pPane | Pointer to a valid CXTPDockingPaneBase object.
rc | Size of the title bar to draw.
bVertical | TRUE if the title bar should be drawn vertically.

Reimplemented from CXTPDockingPaneVisualStudio2012Theme.

The documentation for this class was generated from the following file:
  • XTPDockingPaneThemeOffice2013.h


Toolkit Pro: CXTPDockingPanePaintManager Class Reference

Public Member Functions | Public Attributes | Protected Member Functions | Protected Attributes | List of all members
CXTPDockingPanePaintManager Class Referenceabstract

CXTPDockingPanePaintManager is a standalone class. More...

Inheritance diagram for CXTPDockingPanePaintManager:
[legend]

Public Member Functions

virtual void | DrawPane (CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc)
Override this member function to draw a tabbed container.
virtual void | DrawSidePanel (CDC *pDC, CXTPDockingPaneSidePanel *pPane, CRect rc)
Override this member function to draw the side panel.
virtual CRect | GetPaneCaptionRect (const CXTPDockingPaneSidePanel *pPane)
Call this method to get the pane's caption rectangle.
virtual void | DrawFloatingFrame (CDC *pDC, CXTPDockingPaneMiniWnd *pPane, CRect rc)
Call this method to draw the frame of a floating window.
virtual void | DrawSplitter (CDC *pDC, CXTPDockingPaneSplitterWnd *pSplitter)
Override this method to draw a splitter.
virtual void | DrawCaption (CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc)=0
Override this member function to draw a caption.
virtual void | DrawCaptionButtons (CDC *pDC, CXTPDockingPaneCaptionButtons *pButtons, CRect &rcCaption, COLORREF clr, int nButtonSize, int nButtonGap, BOOL bVertical=FALSE)
Override this member function to draw buttons for a tabbed caption.
virtual void | DrawCaptionButton (CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton)
Override this member function to draw a button for a tabbed caption.
virtual void | RefreshMetrics ()
This method is called to refresh the visual metrics of the manager.
virtual void | AdjustClientRect (CXTPDockingPaneSidePanel *pPane, CRect &rect)
Override this member to change the client rectangle of the child docking pane.
virtual void | AdjustClientRect (CXTPDockingPaneTabbedContainer *pPane, CRect &rect, BOOL bApply)
Override this member to change the client rectangle of the child docking pane.
virtual void | AdjustCaptionRect (const CXTPDockingPaneSidePanel *pPane, CRect &rc)
Override this member to change the caption rectangle of the child docking pane.
virtual void | AdjustCaptionRect (const CXTPDockingPaneTabbedContainer *pPane, CRect &rc)
Override this member to change the caption rectangle of the child docking pane.
virtual void | GetCaptionRect (const CXTPDockingPaneTabbedContainer *pPane, CRect &rc)
Call this method to get a caption rectangle.
virtual CRect | GetCaptionGripperRect (const CXTPDockingPaneTabbedContainer *pPane)
Call this method to get a caption gripper for a tabbed container.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1, int nPen)
Draws a line.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1)
Draws a line.
int | DrawCaptionText (CDC *pDC, const CString &strTitle, CRect rc, BOOL bVertical, BOOL bCalcWidth=FALSE)
Draws the text of a pane caption.
void | Pixel (CDC *pDC, int xPos, int yPos, int nPen)
Sets the pixel at the point.
void | Rectangle (CDC *pDC, CRect rc, int nPenEntry, int nPenBorder)
Draws a rectangle.
void | UseOfficeFont (BOOL bUseOfficeFont)
Call this member to use Office (Tahoma) font.
void | SetCaptionFontIndirect (LOGFONT *pLogFont, BOOL bUseStandardFont=FALSE)
Call this method to set the caption's font.
CXTPTabPaintManager * | SetTabPaintManager (CXTPTabPaintManager *pManager)
Call this method to set the paint manager used to draw tabs of a tabbed container.
CXTPTabPaintManager * | SetPanelPaintManager (CXTPTabPaintManager *pManager)
Call this method to set the paint manager used to draw tabs of an auto-hide panel.
CXTPTabPaintManager * | GetTabPaintManager () const
Retrieves the paint manager used to draw tabs of a tabbed container.
CXTPTabPaintManager * | GetPanelPaintManager () const
Retrieves the paint manager used to draw tabs of an auto-hide panel.
COLORREF | GetXtremeColor (UINT nIndex)
Retrieves the current color of the specified XP display element.
void | SetColors (int cElements, CONST INT *lpaElements, CONST COLORREF *lpaRgbValues)
Call this member to set the colors for each element in an array to the colors in a specified color array.
int | GetCaptionHeight () const
Call this member to get the caption height of the tabbed container.
int | GetTabsHeight () const
Call this member to get tabs height of the tabbed container.
void | SetSplitterStyle (DWORD dwStyle)
Call this member to set the splitter style.
DWORD | GetSplitterStyle () const
Call this method to get the splitter style.
void | SetCaptionButtonStyle (XTPDockingPaneCaptionButtonStyle nStyle)
Call this member to set the caption button style.
XTPDockingPaneCaptionButtonStyle | GetCaptionButtonStyle () const
Call this method to get the caption button style.
XTPCurrentSystemTheme | GetCurrentSystemTheme () const
Call this member function to determine the current Windows XP theme in use.
void | SetLunaTheme (XTPCurrentSystemTheme systemTheme)
Call this method to force system theme.
virtual void | DrawAutoHidePanel (CDC *pDC, CRect rc, XTPDockingPaneDirection direction)
This mmethod is called by the framework to draw the docking pane auto-hide panel background and splitter.
void | SetCustomTitleBrushes (HBRUSH hbrActiveTitleHorz, HBRUSH hbrInactiveTitleHorz=NULL, HBRUSH hbrActiveTitleVert=NULL, HBRUSH hbrInactiveTitleVert=NULL, BOOL bDestroyOnCleanup=FALSE)
Sets custom title brushes.
HBRUSH | GetCustomTitleBrush (BOOL bActive, BOOL bVertical) const
Obtains the custom title brush.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Public Attributes

BOOL | m_bUseBoldCaptionFont
TRUE to use bold font for caption.
BOOL | m_bHighlightActiveCaption
TRUE to highlight active caption.
int | m_nSplitterSize
Splitter size.
BOOL | m_bShowCaption
TRUE to draw captions of tabbed containers.
BOOL | m_bDrawSingleTab
TRUE to draw single tab.
BOOL | m_bDrawCaptionIcon
TRUE to draw caption icon.
int | m_nSplitterIndent
Size of splitter indent.
CXTPPaintManagerColor | m_clrBackground
Background color.
CXTPPaintManagerColor | m_clrSplitterGripper
Splitter gripper color.
CXTPPaintManagerColor | m_clrSplitter
Splitter color.
CXTPPaintManagerColorGradient | m_clrSplitterGradient
Splitter gradient color.
CXTPPaintManagerColorGradient | m_clrNormalCaption
Color of pane caption when inactive.
CXTPPaintManagerColorGradient | m_clrActiveCaption
Color of pane caption when active.
CXTPPaintManagerColor | m_clrNormalCaptionText
Color of pane caption text when the caption is inactive.
CXTPPaintManagerColor | m_clrActiveCaptionText
Active caption text.
CXTPPaintManagerColor | m_clrDisabledCaptionText
Disabled caption text.

Protected Member Functions

CXTPDockingPanePaintManager ()
Constructs a CXTPDockingPanePaintManager object.
virtual | ~CXTPDockingPanePaintManager ()
Destroys a CXTPDockingPanePaintManager object, handles cleanup and deallocation.
virtual void | DrawCaptionButtonEntry (CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton, CSize szOffset)
Draws only the glyph of a button.
virtual void | DrawCaptionButtonEntry (CDC *pDC, CXTPDockingPaneCaptionButton *pButton, CPoint pt, COLORREF clrButton)
Draws only the glyph of a button.
void | ClipAndAddEllipsisIfNeeded (CDC *pDC, CString &strTitle, int nCaptionWidth) const
Clip string and add ellipsis if its width less than nCaptionWidth.

Protected Attributes

XTPDockingPaneCaptionButtonStyle | m_nCaptionButtonStyle
Caption button style.
DWORD | m_dwSplitterStyle
Splitter style.
int | m_nTitleHeight
Title's height.
int | m_nCaptionFontGap
Additional gap of font.
int | m_nTabsHeight
Tab bar's height.
CXTPFont | m_xtpFontTitle
Title font.
CXTPFont | m_xtpFontTitleVertical
Title vertical font.
BOOL | m_bUseOfficeFont
TRUE to use Tahoma font.
BOOL | m_bUseStandardFont
TRUE to use system icon font.
BOOL | m_bDestroyCustomTitleBrushes
If TRUE, custom title bushes will be destroyed on cleanup.
HBRUSH | m_hbrActiveTitleHorz
Optional user specified active horizontal title brush.
HBRUSH | m_hbrInactiveTitleHorz
Optional user specified inactive horizontal title brush.
HBRUSH | m_hbrActiveTitleVert
Optional user specified active vertical title brush.
HBRUSH | m_hbrInactiveTitleVert
Optional user specified inactive vertical title brush.
CXTPTabPaintManager * | m_pTabPaintManager
Paint Manager used to draw tabs for a tabbed container.
CXTPTabPaintManager * | m_pPanelPaintManager
Paint Manager used to draw tabs for an auto-hide panel.
COLORREF | m_arrColor [XPCOLOR_LAST+1]
Self colors array.
XTPDockingPanePaintTheme | m_themeCurrent
Current theme.
CString | m_strOfficeFont
Office font name.
CRect | m_rcCaptionMargin
Margins of caption.
XTPCurrentSystemTheme | m_systemTheme
Current system theme.
CXTPWinThemeWrapper * | m_themeToolbar
Toolbar theme helper.
CXTPWinThemeWrapper * | m_themeExplorer
WinXP Explorer theme helper.
CXTPWinThemeWrapper * | m_themeButton
WinXP Button theme helper.
CXTPWinThemeWrapper * | m_themeWindow
WinXP Window Theme helper.
CXTPWinThemeWrapper * | m_themeRebar
Rebar theme helper.
BOOL | m_bLunaTheme
TRUE if luna colors are used.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

CXTPDockingPanePaintManager is a standalone class.

Override some virtual functions to get a new visual theme.

Member Function Documentation

◆ AdjustCaptionRect() [1/2]

virtual void AdjustCaptionRect | ( | const CXTPDockingPaneSidePanel * | pPane,
 |  | CRect & | rc )
 virtual

Override this member to change the caption rectangle of the child docking pane.

Parameters
pPane | Pointer to a CXTPDockingPaneTabbedContainer object or CXTPDockingPaneSidePanel object.
rc | Caption rectangle to be changed.

◆ AdjustCaptionRect() [2/2]

virtual void AdjustCaptionRect | ( | const CXTPDockingPaneTabbedContainer * | pPane,
 |  | CRect & | rc )
 virtual

Override this member to change the caption rectangle of the child docking pane.

Parameters
pPane | Pointer to a CXTPDockingPaneTabbedContainer object or CXTPDockingPaneSidePanel object.
rc | Caption rectangle to be changed.

Reimplemented in CXTPDockingPaneOffice2002VisioTheme, and CXTPDockingPaneVisualStudio2012Theme.

◆ AdjustClientRect() [1/2]

virtual void AdjustClientRect | ( | CXTPDockingPaneSidePanel * | pPane,
 |  | CRect & | rect )
 virtual

Override this member to change the client rectangle of the child docking pane.

Parameters
pPane | Pointer to the tabbed container or side panel.
rect | Client rectangle to be changed.

◆ AdjustClientRect() [2/2]

virtual void AdjustClientRect | ( | CXTPDockingPaneTabbedContainer * | pPane,
 |  | CRect & | rect,
 |  | BOOL | bApply )
 virtual

Override this member to change the client rectangle of the child docking pane.

Parameters
pPane | Pointer to the tabbed container or side panel.
rect | Client rectangle to be changed.
bApply | TRUE to update tabs inside the client area.

Reimplemented in CXTPDockingPaneOffice2007WordTheme, and CXTPDockingPaneVisualStudio2012Theme.

◆ ClipAndAddEllipsisIfNeeded()

void ClipAndAddEllipsisIfNeeded | ( | CDC * | pDC,
 |  | CString & | strTitle,
 |  | int | nCaptionWidth ) const
 protected

Clip string and add ellipsis if its width less than nCaptionWidth.

Parameters
pDC | Pointer to the device context in which to draw.
strTitle | Text to process.
nCaptionWidth | Caption width.

DT_END_ELLIPSIS doesn't work with rotated text.

See also
DrawCaptionText

◆ DrawAutoHidePanel()

virtual void DrawAutoHidePanel | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | XTPDockingPaneDirection | direction )
 virtual

This mmethod is called by the framework to draw the docking pane auto-hide panel background and splitter.

Parameters
pDC | Pointer to the auto-hide pane's device context.
rc | Size of the area to draw.
direction | Docking direction (either xtpPaneDockLeft, xtpPaneDockRight, xtpPaneDockTop, or xtpPaneDockBottom).

Reimplemented in CXTPDockingPaneNativeWindows10Theme, CXTPDockingPaneNativeWindows11Theme, CXTPDockingPaneOffice2013Theme, CXTPDockingPaneVisualStudio2012Theme, CXTPDockingPaneVisualStudio2015Theme, CXTPDockingPaneVisualStudio2017Theme, CXTPDockingPaneVisualStudio2019Theme, and CXTPDockingPaneVisualStudio2022Theme.

◆ DrawCaption()

virtual void DrawCaption | ( | CDC * | pDC,
 |  | CXTPDockingPaneTabbedContainer * | pPane,
 |  | CRect | rc )
 pure virtual

Override this member function to draw a caption.

Parameters
pDC | Reference to the device context in which to draw.
pPane | Pointer to the tabbed container.
rc | Client rectangle of the tabbed container.

Implemented in CXTPDockingPaneDefaultTheme, CXTPDockingPaneGripperedTheme, CXTPDockingPaneOffice2002VisioTheme, CXTPDockingPaneOffice2003Theme, CXTPDockingPaneOffice2007OutlookTheme, CXTPDockingPaneOffice2007Theme, CXTPDockingPaneOffice2007WordTheme, CXTPDockingPaneOffice2013Theme, CXTPDockingPaneVisualStudio2012Theme, and CXTPDockingPaneWinNativeTheme.

◆ DrawCaptionButton()

virtual void DrawCaptionButton | ( | CDC * | pDC,
 |  | CXTPDockingPaneCaptionButton * | pButton,
 |  | COLORREF | clrButton )
 virtual

Override this member function to draw a button for a tabbed caption.

Parameters
pDC | Pointer to a valid device context.
pButton | Pointer to the button to draw.
clrButton | Color of the button's text.

Reimplemented in CXTPDockingPaneOffice2013Theme, and CXTPDockingPaneVisualStudio2012Theme.

◆ DrawCaptionButtonEntry() [1/2]

virtual void DrawCaptionButtonEntry | ( | CDC * | pDC,
 |  | CXTPDockingPaneCaptionButton * | pButton,
 |  | COLORREF | clrButton,
 |  | CSize | szOffset )
 protectedvirtual

Draws only the glyph of a button.

For example, the cross of a Close Button.

Parameters
pDC | Pointer to the device context in which to draw.
pButton | Pointer to the button to draw.
clrButton | Color of glyph.
szOffset | Glyph offset.

◆ DrawCaptionButtonEntry() [2/2]

virtual void DrawCaptionButtonEntry | ( | CDC * | pDC,
 |  | CXTPDockingPaneCaptionButton * | pButton,
 |  | CPoint | pt,
 |  | COLORREF | clrButton )
 protectedvirtual

Draws only the glyph of a button.

For example, the cross of a Close Button.

Parameters
pDC | Pointer to the device context in which to draw.
pButton | Pointer to the button to draw.
pt | Glyph center point.
clrButton | Color of glyph.

◆ DrawCaptionButtons()

virtual void DrawCaptionButtons | ( | CDC * | pDC,
 |  | CXTPDockingPaneCaptionButtons * | pButtons,
 |  | CRect & | rcCaption,
 |  | COLORREF | clr,
 |  | int | nButtonSize,
 |  | int | nButtonGap,
 |  | BOOL | bVertical = FALSE )
 virtual

Override this member function to draw buttons for a tabbed caption.

Parameters
pDC | Pointer to a valid device context.
pButtons | Pointer to a collection of buttons to draw.
rcCaption | Caption rectangle.
clr | Color of the buttons' text.
nButtonSize | Size of the buttons.
nButtonGap | Distance between buttons.
bVertical | TRUE if the caption is drawn vertically.

◆ DrawCaptionText()

int DrawCaptionText | ( | CDC * | pDC,
 |  | const CString & | strTitle,
 |  | CRect | rc,
 |  | BOOL | bVertical,
 |  | BOOL | bCalcWidth = FALSE )

Draws the text of a pane caption.

Parameters
pDC | Reference to a valid device context.
strTitle | Text to draw in the caption.
rc | Client rectangle of the tabbed container.
bVertical | TRUE to draw the caption vertically.
bCalcWidth | TRUE to calculate width.
Returns
The width of the text that was drawn in the pane caption bar.

◆ DrawFloatingFrame()

AFX_INLINE void DrawFloatingFrame | ( | CDC * | pDC,
 |  | CXTPDockingPaneMiniWnd * | pPane,
 |  | CRect | rc )
 virtual

Call this method to draw the frame of a floating window.

Parameters
pDC | Pointer to a valid device context.
pPane | Floating window pointer.
rc | Client rectangle of the floating frame.

Reimplemented in CXTPDockingPaneDefaultTheme, CXTPDockingPaneGripperedTheme, CXTPDockingPaneOffice2002VisioTheme, CXTPDockingPaneOffice2003Theme, CXTPDockingPaneOffice2013Theme, CXTPDockingPaneVisualStudio2010Theme, CXTPDockingPaneVisualStudio2012Theme, and CXTPDockingPaneWinNativeTheme.

◆ DrawPane()

virtual void DrawPane | ( | CDC * | pDC,
 |  | CXTPDockingPaneTabbedContainer * | pPane,
 |  | CRect | rc )
 virtual

Override this member function to draw a tabbed container.

Parameters
pDC | Reference to the device context in which to draw.
pPane | Pointer to the tabbed container.
rc | Client rectangle of the tabbed container.

Reimplemented in CXTPDockingPaneOffice2002VisioTheme, CXTPDockingPaneOffice2007WordTheme, CXTPDockingPaneOffice2013Theme, and CXTPDockingPaneVisualStudio2012Theme.

◆ DrawSidePanel()

AFX_INLINE void DrawSidePanel | ( | CDC * | pDC,
 |  | CXTPDockingPaneSidePanel * | pPane,
 |  | CRect | rc )
 virtual

Override this member function to draw the side panel.

Parameters
pDC | Reference to the device context in which to draw.
pPane | Pointer to the side panel.
rc | Client rectangle of the side panel.

Reimplemented in CXTPDockingPaneDefaultTheme, CXTPDockingPaneOffice2003Theme, CXTPDockingPaneOffice2013Theme, CXTPDockingPaneVisualStudio2012Theme, and CXTPDockingPaneWinNativeTheme.

◆ DrawSplitter()

virtual void DrawSplitter | ( | CDC * | pDC,
 |  | CXTPDockingPaneSplitterWnd * | pSplitter )
 virtual

Override this method to draw a splitter.

Parameters
pDC | Pointer to a valid device context.
pSplitter | Pointer to a splitter window.

Reimplemented in CXTPDockingPaneNativeWindows10Theme, CXTPDockingPaneNativeWindows11Theme, CXTPDockingPaneOffice2013Theme, CXTPDockingPaneVisualStudio2012Theme, CXTPDockingPaneVisualStudio2015Theme, CXTPDockingPaneVisualStudio2017Theme, CXTPDockingPaneVisualStudio2019Theme, and CXTPDockingPaneVisualStudio2022Theme.

◆ GetCaptionButtonStyle()

AFX_INLINE XTPDockingPaneCaptionButtonStyle GetCaptionButtonStyle ( ) const

Call this method to get the caption button style.

Returns
The style used for caption buttons.
See also
XTPDockingPaneCaptionButtonStyle, SetCaptionButtonStyle

◆ GetCaptionGripperRect()

virtual CRect GetCaptionGripperRect ( const CXTPDockingPaneTabbedContainer * pPane )
virtual

Call this method to get a caption gripper for a tabbed container.

Parameters
pPane Tabbed container to test.
Returns
Bounding rectangle of the gripper to set the size cursor.

Reimplemented in CXTPDockingPaneOffice2003OutlookTheme, and CXTPDockingPaneOffice2003Theme.

◆ GetCaptionHeight()

AFX_INLINE int GetCaptionHeight ( ) const

Call this member to get the caption height of the tabbed container.

Returns
The caption height of the tabbed container.
See also
GetTabsHeight

◆ GetCaptionRect()

virtual void GetCaptionRect | ( | const CXTPDockingPaneTabbedContainer * | pPane,
 |  | CRect & | rc )
 virtual

Call this method to get a caption rectangle.

Parameters
pPane | Tabbed container to get caption CRect.
rc | Caption rectangle to store caption CRect.

◆ GetCurrentSystemTheme()

XTPCurrentSystemTheme GetCurrentSystemTheme ( ) const

Call this member function to determine the current Windows XP theme in use.

Returns
A XTPCurrentSystemTheme enumeration that represents the current Windows XP theme in use; can be one of the following values: xtpSystemThemeUnknown: Indicates no known theme in use. xtpSystemThemeBlue: Indicates blue theme in use. xtpSystemThemeOlive: Indicates olive theme in use. xtpSystemThemeSilver: Indicates silver theme in use.
See also
SetLunaTheme, RefreshLunaColors

◆ GetCustomTitleBrush()

HBRUSH GetCustomTitleBrush | ( | BOOL | bActive,
 |  | BOOL | bVertical ) const

Obtains the custom title brush.

Parameters
bActive | Determines whether to obtain the active or inactive title brush.
bVertical | Determines whether to obtain the vertical or horizontal title brush.
Returns
The custom title brush.

◆ GetPaneCaptionRect()

virtual CRect GetPaneCaptionRect ( const CXTPDockingPaneSidePanel * pPane )
virtual

Call this method to get the pane's caption rectangle.

Parameters
pPane Side panel container to get caption CRect.
Returns
Bounding rectangle of the side panel's caption.

Reimplemented in CXTPDockingPaneOffice2003Theme, and CXTPDockingPaneVisualStudio2012Theme.

◆ GetPanelPaintManager()

AFX_INLINE CXTPTabPaintManager * GetPanelPaintManager ( ) const

Retrieves the paint manager used to draw tabs of an auto-hide panel.

Returns
A pointer to the CXTPTabPaintManager used to draw tabs of an auto-hide panel.
See also
SetPanelPaintManager, GetTabPaintManager

◆ GetSplitterStyle()

DWORD GetSplitterStyle ( ) const

Call this method to get the splitter style.

Returns
The style used for splitters.
See also
XTPDockingPaneSplitterStyle, SetSplitterStyle

◆ GetTabPaintManager()

AFX_INLINE CXTPTabPaintManager * GetTabPaintManager ( ) const

Retrieves the paint manager used to draw tabs of a tabbed container.

Returns
A pointer to the CXTPTabPaintManager used to draw tabs of a tabbed container.
See also
SetTabPaintManager, GetPanelPaintManager

◆ GetTabsHeight()

AFX_INLINE int GetTabsHeight ( ) const

Call this member to get tabs height of the tabbed container.

Returns
The tabs height of the tabbed container.
See also
GetCaptionHeight

◆ GetXtremeColor()

COLORREF GetXtremeColor ( UINT nIndex )

Retrieves the current color of the specified XP display element.

Parameters
nIndex Specifies the display element whose color is to be retrieved. This parameter can be one of the following values displayed in the table below:

Display elements are the parts of a window and the display that appear on the system display screen. The function returns the red, green, blue (RGB) color value of the given element. To provide a consistent look to all Windows applications, the operating system provides and maintains global settings that define the colors of various aspects of the display. These settings as a group are sometimes referred to as a "color scheme." To view the current color settings, click Control Panel, double-click the Display icon, and then click the "Appearance" tab.

  Constant                      Value           Description
  COLOR_SCROLLBAR                     0             Scroll bar
  COLOR_BACKGROUND                  1             Desktop color
  COLOR_ACTIVECAPTION                 2             Color of the title bar for the active
*window, Specifies the left side color in the color gradient of an active window's title bar if
*the gradient effect is enabled. COLOR_INACTIVECAPTION             3             Color of the
*title bar for the inactive window, Specifies the left side color in the color gradient of an
*inactive window's title bar if the gradient effect is enabled. COLOR_MENU 4
*Menu background color COLOR_WINDOW                      5             Window background color
  COLOR_WINDOWFRAME                 6             Window frame color
  COLOR_MENUTEXT                    7             Color of text on menus
  COLOR_WINDOWTEXT                  8             Color of text in windows
  COLOR_CAPTIONTEXT                 9             Color of text in caption, size box, and
*scroll arrow COLOR_ACTIVEBORDER                10            Border color of active window
  COLOR_INACTIVEBORDER              11            Border color of inactive window
  COLOR_APPWORKSPACE                12            Background color of multiple-document
*interface (MDI) applications COLOR_HIGHLIGHT                   13            Background color
*of items selected in a control COLOR_HIGHLIGHTTEXT               14            Text color of
*items selected in a control COLOR_BTNFACE                     15            Face color for
*three-dimensional display elements and for dialog box backgrounds. COLOR_BTNSHADOW 16 Color of
*shading on the edge of command buttons COLOR_GRAYTEXT                    17            Grayed
*(disabled) text COLOR_BTNTEXT                     18            Text color on push buttons
  COLOR_INACTIVECAPTIONTEXT         19            Color of text in an inactive caption
  COLOR_BTNHIGHLIGHT                20            Highlight color for 3-D display elements
  COLOR_3DDKSHADOW                  21            Darkest shadow color for 3-D display elements
  COLOR_3DLIGHT                     22            Second lightest 3-D color after 3DHighlight,
*Light color for three-dimensional display elements (for edges facing the light source.)
  COLOR_INFOTEXT                    23            Color of text in ToolTips
  COLOR_INFOBK                      24            Background color of ToolTips
  COLOR_HOTLIGHT                    25            Color for a hot-tracked item. Single clicking
*a hot-tracked item executes the item. COLOR_GRADIENTACTIVECAPTION       26         Right
*side color in the color gradient of an active window's title bar. COLOR_ACTIVECAPTION
*27         specifies the left side color. COLOR_GRADIENTINACTIVECAPTION     28 Right side
*color in the color gradient of an inactive window's title bar. COLOR_INACTIVECAPTION 29
*specifies the left side color. XPCOLOR_TOOLBAR_FACE              30            Toolbar
*background color. XPCOLOR_HIGHLIGHT                 31            Menu item selected color.
  XPCOLOR_HIGHLIGHT_BORDER          32            Menu item selected border color.
  XPCOLOR_HIGHLIGHT_PUSHED          33            Menu item pushed color.
  XPCOLOR_ICONSHADDOW               34            Menu item icon shadow.
  XPCOLOR_MENUBAR_GRAYTEXT          35            Menu bar gray text
  XPCOLOR_GRAYTEXT                  35            Menu item disabled text color.
  XPCOLOR_HIGHLIGHT_CHECKED         36            Menu item checked color.
  XPCOLOR_HIGHLIGHT_CHECKED_BORDER  37            An RGB value that represents the menu item
*checked border color. XPCOLOR_TOOLBAR_GRIPPER           38            Toolbar gripper color.
  XPCOLOR_SEPARATOR                 39            Toolbar separator color.
  XPCOLOR_DISABLED                  40            Menu icon disabled color.
  XPCOLOR_MENUBAR_FACE              41            Menu item text background color.
  XPCOLOR_MENUBAR_EXPANDED          42            Hidden menu commands background color.
  XPCOLOR_MENUBAR_BORDER            43            Menu border color.
  XPCOLOR_MENUBAR_TEXT              44            Menu item text color.
  XPCOLOR_HIGHLIGHT_TEXT            45            Menu item selected text color.
  XPCOLOR_CHECKED_TEXT              45          Color for text displayed in a checked button.
  XPCOLOR_TOOLBAR_TEXT              46            Toolbar text color.
  XPCOLOR_PUSHED_TEXT               47            Toolbar pushed text color.
  XPCOLOR_TAB_INACTIVE_BACK         48            Inactive tab background color.
  XPCOLOR_TAB_INACTIVE_TEXT         49            Inactive tab text color.
  XPCOLOR_HIGHLIGHT_PUSHED_BORDER   50            An RGB value that represents the border color
*for pushed in 3D elements. XPCOLOR_3DFACE                    51            Face color for
*three- dimensional display elements and for dialog box backgrounds. XPCOLOR_3DSHADOW 52 Shadow
*color for three-dimensional display elements (for edges facing away from the light source).
  XPCOLOR_EDITCTRLBORDER              53            Color for the border color of edit controls.
  XPCOLOR_FRAME                     54          Office 2003 frame color.
  XPCOLOR_SPLITTER_FACE             55            Splitter face color.
  XPCOLOR_LABEL                     56            Color for label control (xtpControlLabel)
  XPCOLOR_STATICFRAME               57            Static frame color
  XPCOLOR_HIGHLIGHT_DISABLED_BORDER 58            Highlighted disabled border color
  XPCOLOR_SHADOW_FACTOR             59            Shadow factor color
  XPCOLOR_TOOLBAR_GRAYTEXT          60            Toolbar gray text color
  XPCOLOR_FLOATBAR_BORDER           61            Floatbar border color
  XPCOLOR_LAST                      62            The last color value
Returns
The red, green, blue (RGB) color value of the given element.

◆ Line() [1/2]

void Line | ( | CDC * | pDC,
 |  | int | x0,
 |  | int | y0,
 |  | int | x1,
 |  | int | y1 )

Draws a line.

Parameters
pDC | Pointer to a valid device context.
x0 | Specifies the logical x-coordinate of the start position.
y0 | Specifies the logical y-coordinate of the start position.
x1 | Specifies the logical x-coordinate of the endpoint for the line.
y1 | Specifies the logical y-coordinate of the endpoint for the line.

◆ Line() [2/2]

void Line | ( | CDC * | pDC,
 |  | int | x0,
 |  | int | y0,
 |  | int | x1,
 |  | int | y1,
 |  | int | nPen )

Draws a line.

Parameters
pDC | Pointer to a valid device context.
x0 | Specifies the logical x-coordinate of the start position.
y0 | Specifies the logical y-coordinate of the start position.
x1 | Specifies the logical x-coordinate of the endpoint for the line.
y1 | Specifies the logical y-coordinate of the endpoint for the line.
nPen | Specifies the color used to paint the line.

◆ Pixel()

void Pixel | ( | CDC * | pDC,
 |  | int | xPos,
 |  | int | yPos,
 |  | int | nPen )

Sets the pixel at the point.

Parameters
pDC | Pointer to a valid device context.
xPos | Specifies the logical x-coordinate of the point to be set.
yPos | Specifies the logical y-coordinate of the point to be set.
nPen | Specifies the color used to paint the point.

◆ Rectangle()

void Rectangle | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | int | nPenEntry,
 |  | int | nPenBorder )

Draws a rectangle.

Parameters
pDC | Pointer to a valid device context.
rc | Specifies the rectangle in logical units.
nPenEntry | Specifies the color used to paint the rectangle.
nPenBorder | Specifies the color used to fill the rectangle.

◆ SetCaptionButtonStyle()

AFX_INLINE void SetCaptionButtonStyle ( XTPDockingPaneCaptionButtonStyle nStyle )

Call this member to set the caption button style.

Parameters
nStyle New style to be used for caption buttons.

dwStyle parameter can be one or more of the following: xtpPaneCaptionButtonDefault xtpPaneCaptionButtonOffice xtpPaneCaptionButtonOffice2003 xtpPaneCaptionButtonThemeExplorerBar xtpPaneCaptionButtonThemeButton xtpPaneCaptionButtonThemeToolBar

Example: m_paneManager.GetPaintManager()->SetCaptionButtonStyle(xtpPaneCaptionButtonOffice2003);

See also
XTPDockingPaneCaptionButtonStyle, GetCaptionButtonStyle

◆ SetCaptionFontIndirect()

void SetCaptionFontIndirect | ( | LOGFONT * | pLogFont,
 |  | BOOL | bUseStandardFont = FALSE )

Call this method to set the caption's font.

Parameters
pLogFont | LOGFONT to be set for the caption.
bUseStandardFont | Must be FALSE.

◆ SetColors()

void SetColors | ( | int | cElements,
 |  | CONST INT * | lpaElements,
 |  | CONST COLORREF * | lpaRgbValues )

Call this member to set the colors for each element in an array to the colors in a specified color array.

Parameters
cElements | Number of elements in the array.
lpaElements | Array of elements.
lpaRgbValues | Array of RGB values.
See also
SetColor

◆ SetCustomTitleBrushes()

void SetCustomTitleBrushes | ( | HBRUSH | hbrActiveTitleHorz,
 |  | HBRUSH | hbrInactiveTitleHorz = NULL,
 |  | HBRUSH | hbrActiveTitleVert = NULL,
 |  | HBRUSH | hbrInactiveTitleVert = NULL,
 |  | BOOL | bDestroyOnCleanup = FALSE )

Sets custom title brushes.

Parameters
hbrActiveTitleHorz | Active horizontal title brush handle. NULL to use default title background drawing.
hbrInactiveTitleHorz | Inactive horizontal title brush handle. NULL to use hbrActiveTitleHorz value.
hbrActiveTitleVert | Active horizontal title brush handle. NULL to use hbrActiveTitleHorz value.
hbrInactiveTitleVert | Inactive horizontal title brush handle. NULL to use hbrInactiveTitleHorz value.
bDestroyOnCleanup | If TRUE, then brushes will be destroyed on cleanup.

◆ SetLunaTheme()

void SetLunaTheme ( XTPCurrentSystemTheme systemTheme )

Call this method to force system theme.

Parameters
systemTheme Theme to use. Can be any of the values listed in the Remarks section.

Theme can be one of the following: xtpSystemThemeUnknown Disables luna theme support. xtpSystemThemeBlue Enables blue theme. xtpSystemThemeOlive Enables olive theme. xtpSystemThemeSilver Enables silver theme.

◆ SetPanelPaintManager()

CXTPTabPaintManager * SetPanelPaintManager ( CXTPTabPaintManager * pManager )

Call this method to set the paint manager used to draw tabs of an auto-hide panel.

Parameters
pManager New CXTPTabPaintManager pointer.
Returns
A pointer to the CXTPTabPaintManager that will be used.
See also
GetPanelPaintManager, SetTabPaintManager

◆ SetSplitterStyle()

void SetSplitterStyle ( DWORD dwStyle )

Call this member to set the splitter style.

Parameters
dwStyle New style to be used for splitters.

dwStyle parameter can be one or more of the following: xtpPaneSplitterFlat xtpPaneSplitter3D xtpPaneSplitterSoft3D xtpPaneSplitterGripperOfficeXP xtpPaneSplitterGripperOffice2003

Example: m_paneManager.GetPaintManager()->SetSplitterStyle(xtpPaneSplitterSoft3D + xtpPaneSplitterGripperOffice2003);

◆ SetTabPaintManager()

CXTPTabPaintManager * SetTabPaintManager ( CXTPTabPaintManager * pManager )

Call this method to set the paint manager used to draw tabs of a tabbed container.

Parameters
pManager New CXTPTabPaintManager pointer.
Returns
A pointer to the CXTPTabPaintManager that will be used.
See also
GetTabPaintManager, SetPanelPaintManager

◆ UseOfficeFont()

void UseOfficeFont ( BOOL bUseOfficeFont )

Call this member to use Office (Tahoma) font.

Parameters
bUseOfficeFont TRUE to use Office font.
The documentation for this class was generated from the following file:
  • XTPDockingPanePaintManager.h


Toolkit Pro: CXTPDockingPanePanelColorSet2012 Class Reference

Public Member Functions | List of all members
CXTPDockingPanePanelColorSet2012 Class Reference

Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines. More...

Inheritance diagram for CXTPDockingPanePanelColorSet2012:
[legend]

Public Member Functions

CXTPDockingPanePanelColorSet2012 ()
Default class constructor.
virtual void | RefreshMetrics ()
This member function is used to initialize default colors for a theme from an .INI resource.
virtual COLORREF | GetItemColor (CXTPTabManagerItem *pItem)
Call this member function to retrieve the color for the tab specified by pItem.
virtual void | FillNavigateButton (CDC *pDC, CXTPTabManagerNavigateButton *pButton, CRect &rc)
This member is called to fill the tab navigation buttons.
- Public Member Functions inherited from CXTPTabPaintManagerColorSet
CXTPTabPaintManagerColorSet ()
Constructs a CXTPTabPaintManagerColorSet object.
virtual | ~CXTPTabPaintManagerColorSet ()
Destroys a CXTPTabPaintManagerColorSet object, handles cleanup and deallocation.
virtual void | SetTextColor (CDC *pDC, CXTPTabManagerItem *pItem)
Sets the text color for the tab.
virtual void | FillHeader (CDC *pDC, CRect rc, CXTPTabManager *pTabManager)
Fills the header of the tab client of a specified tab manager.
virtual COLORREF | FillClient (CDC *pDC, CRect rc, CXTPTabManager *pTabManager)
Fills the tab client area of a specified tab manager.
virtual COLORREF | GetClientColor (CXTPTabManager *pTabManager)
Obtains client background color.
virtual void | FillStateButton (CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem)
Fills a specified tab button when XTPTabAppearanceStyle is xtpTabAppearanceStateButtons.
virtual COLORREF | FillPropertyButton (CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem)
Fills a specified tab button.
virtual void | SelectClipRgn (CDC *pDC, CRect rcClient, CXTPTabManager *pTabManager)
Sets a clipping region for the specified tab client area.
void | GradientFill (CDC *pDC, CRect rc, COLORREF clrLight, COLORREF clrDark, XTPTabPosition position)
Performs a gradient fill of a rectangle with a color that smoothly fades from top to bottom.
virtual BOOL | IsAppThemed () const
Determines if Windows XP themes are enabled and if a Windows XP theme is currently used.

Additional Inherited Members

- Public Attributes inherited from CXTPTabPaintManagerColorSet
CXTPPaintManagerColorGradient | m_clrHeaderFace
Color set of the tab header background.
CXTPPaintManagerColorGradient m_clrAutoHideFace
Color set of the auto-hide panel background.
CXTPPaintManagerColor | m_clrFrameBorder
Color of the border placed around the tab buttons and the tab client.
CXTPPaintManagerColor m_clrControlFace
Color of the control foreground.
CXTPPaintManagerColor | m_clrPaneFace
Color of the control pane foreground.
CXTPPaintManagerColor | m_clrBorderHighlight
Color of the highlight border.
CXTPPaintManagerColor | m_clrTabClientBack
Background color for the tab client area.
CXTPPaintManagerColor | m_clrTabClientBorder
Border color for the tab client area.
CXTPPaintManagerColor m_clrButtonNormal
Color of normal tabs.
CXTPPaintManagerColor | m_clrButtonPressed
Tab pressed button color.
CXTPPaintManagerColor | m_clrButtonHighlighted
Tab button color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonHighlightedClose
Tab close button color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonBorderHighlighted
Tab button border color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonBorderTabContext1
Tab button border color with tab context.
CXTPPaintManagerColor | m_clrButtonBorderTabContext2
Tab button border color with tab context.
CXTPPaintManagerColor | m_clrButtonBorderKeyTips
Tab button border color when ALT button is pressed.
CXTPPaintManagerColor | m_clrButtonSelected
Color of the currently selected tab.
CXTPPaintManagerColor | m_clrButtonSelectedPressed
Color of the currently selected tab when pressed.
CXTPPaintManagerColor | m_clrButtonSelectedHighlighted
Color of the currently selected tab when highlighted.
CXTPPaintManagerColor | m_clrButtonBorder
Tab button border (edge) color.
CXTPPaintManagerColor | m_clrButtonBorderHot
Tab button highlight or pressed border (edge) color.
CXTPPaintManagerColor m_clrTextNormal
Color of text in a normal tab.
CXTPPaintManagerColor m_clrTextPressed
Color of text in a "pressed" tab button.
CXTPPaintManagerColor | m_clrTextHighlight
Color of text on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrTextHighlightClose
Color of close button text on mouse over when hot tracking is enabled.
CXTPPaintManagerColor m_clrTextSelected
Color of text in a "selected" tab button.
CXTPPaintManagerColor m_clrTextSelectedPressed
Color of text in a "pressed" tab button.
CXTPPaintManagerColor | m_clrTextSelectedHighlighted
Color of text for tabs in all non-active groups of tabs in MDITabClient.
CXTPPaintManagerColor m_clrTextDisabled
Color of text when a tab is disabled.
CXTPPaintManagerColor | m_clrActiveFilesGlyph
Color of navigation button.
CXTPPaintManagerColor | m_clrActiveFilesGlyphHighlighted
Color of highlighted navigation button.
CXTPPaintManagerColor | m_clrActiveFilesGlyphPressed
Color of selected navigation button.
CXTPPaintManagerColor | m_clrActiveFilesBack
Color of highlighted navigation button background.
CXTPPaintManagerColor | m_clrActiveFilesBackHighlighted
Color of navigation button background.
CXTPPaintManagerColor | m_clrActiveFilesBackPressed
Color of selected navigation button background.
COLORSET_TAB_STATEBUTTON | m_csStateButton
Color set of state button style tabs.
COLORSET_TAB_PROPERTYPAGE | m_csPropertyPage
Color set of visual studio style tabs.
COLORSET_TAB_PROPERTYPAGE2003 | m_csPropertyPage2003
Color set of Office 2003 style tabs.
COLORSET_TAB_EXCEL | m_csExcelSelected
Color set of selected (focused) Excel style tabs.
COLORSET_TAB_EXCEL | m_csExcelNormal
Color set of normal Excel style tabs.
- Protected Attributes inherited from CXTPTabPaintManagerColorSet
CXTPTabPaintManager * | m_pPaintManager
Self paint manager pointer.

Detailed Description

Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines.

Member Function Documentation

◆ FillNavigateButton()

virtual void FillNavigateButton | ( | CDC * | pDC,
 |  | CXTPTabManagerNavigateButton * | pButton,
 |  | CRect & | rc )
 virtual

This member is called to fill the tab navigation buttons.

Parameters
pDC | Pointer to a valid device context.
pButton | Tab navigation button to fill.
rc | Bounding rectangle of the tab navigation button.

This member must be overridden and takes care of filling the tab navigation buttons that are in the header of the TabClient. The XTPTabColorStyle CXTPTabPaintManagerColorSet classes override this to perform actions such as painting the highlighting, pressed, and normal versions of the tab navigation buttons.

See also
CXTPTabManager::GetNavigateButton, CXTPTabManagerNavigateButton

Implements CXTPTabPaintManagerColorSet.

◆ GetItemColor()

virtual COLORREF GetItemColor ( CXTPTabManagerItem * pItem )
virtual

Call this member function to retrieve the color for the tab specified by pItem.

Parameters
pItem Pointer to a valid CXTPTabManagerItem object.
Returns
An RGB color value representing the specified tab color.

Reimplemented from CXTPTabPaintManagerColorSet.

The documentation for this class was generated from the following file:
  • XTPDockingPanePanelColorSet2012.h


Toolkit Pro: CXTPDockingPanePanelColorSet2013 Class Reference

Public Member Functions | List of all members
CXTPDockingPanePanelColorSet2013 Class Reference

Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines. More...

Inheritance diagram for CXTPDockingPanePanelColorSet2013:
[legend]

Public Member Functions

CXTPDockingPanePanelColorSet2013 ()
Default class constructor.
virtual void | RefreshMetrics ()
This member function is used to initialize default colors for a theme from an .INI resource.
- Public Member Functions inherited from CXTPDockingPanePanelColorSet2012
CXTPDockingPanePanelColorSet2012 ()
Default class constructor.
virtual COLORREF | GetItemColor (CXTPTabManagerItem *pItem)
Call this member function to retrieve the color for the tab specified by pItem.
virtual void | FillNavigateButton (CDC *pDC, CXTPTabManagerNavigateButton *pButton, CRect &rc)
This member is called to fill the tab navigation buttons.
- Public Member Functions inherited from CXTPTabPaintManagerColorSet
CXTPTabPaintManagerColorSet ()
Constructs a CXTPTabPaintManagerColorSet object.
virtual | ~CXTPTabPaintManagerColorSet ()
Destroys a CXTPTabPaintManagerColorSet object, handles cleanup and deallocation.
virtual void | SetTextColor (CDC *pDC, CXTPTabManagerItem *pItem)
Sets the text color for the tab.
virtual void | FillHeader (CDC *pDC, CRect rc, CXTPTabManager *pTabManager)
Fills the header of the tab client of a specified tab manager.
virtual COLORREF | FillClient (CDC *pDC, CRect rc, CXTPTabManager *pTabManager)
Fills the tab client area of a specified tab manager.
virtual COLORREF | GetClientColor (CXTPTabManager *pTabManager)
Obtains client background color.
virtual void | FillStateButton (CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem)
Fills a specified tab button when XTPTabAppearanceStyle is xtpTabAppearanceStateButtons.
virtual COLORREF | FillPropertyButton (CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem)
Fills a specified tab button.
virtual void | SelectClipRgn (CDC *pDC, CRect rcClient, CXTPTabManager *pTabManager)
Sets a clipping region for the specified tab client area.
void | GradientFill (CDC *pDC, CRect rc, COLORREF clrLight, COLORREF clrDark, XTPTabPosition position)
Performs a gradient fill of a rectangle with a color that smoothly fades from top to bottom.
virtual BOOL | IsAppThemed () const
Determines if Windows XP themes are enabled and if a Windows XP theme is currently used.

Additional Inherited Members

- Public Attributes inherited from CXTPTabPaintManagerColorSet
CXTPPaintManagerColorGradient | m_clrHeaderFace
Color set of the tab header background.
CXTPPaintManagerColorGradient m_clrAutoHideFace
Color set of the auto-hide panel background.
CXTPPaintManagerColor | m_clrFrameBorder
Color of the border placed around the tab buttons and the tab client.
CXTPPaintManagerColor m_clrControlFace
Color of the control foreground.
CXTPPaintManagerColor | m_clrPaneFace
Color of the control pane foreground.
CXTPPaintManagerColor | m_clrBorderHighlight
Color of the highlight border.
CXTPPaintManagerColor | m_clrTabClientBack
Background color for the tab client area.
CXTPPaintManagerColor | m_clrTabClientBorder
Border color for the tab client area.
CXTPPaintManagerColor m_clrButtonNormal
Color of normal tabs.
CXTPPaintManagerColor | m_clrButtonPressed
Tab pressed button color.
CXTPPaintManagerColor | m_clrButtonHighlighted
Tab button color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonHighlightedClose
Tab close button color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonBorderHighlighted
Tab button border color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonBorderTabContext1
Tab button border color with tab context.
CXTPPaintManagerColor | m_clrButtonBorderTabContext2
Tab button border color with tab context.
CXTPPaintManagerColor | m_clrButtonBorderKeyTips
Tab button border color when ALT button is pressed.
CXTPPaintManagerColor | m_clrButtonSelected
Color of the currently selected tab.
CXTPPaintManagerColor | m_clrButtonSelectedPressed
Color of the currently selected tab when pressed.
CXTPPaintManagerColor | m_clrButtonSelectedHighlighted
Color of the currently selected tab when highlighted.
CXTPPaintManagerColor | m_clrButtonBorder
Tab button border (edge) color.
CXTPPaintManagerColor | m_clrButtonBorderHot
Tab button highlight or pressed border (edge) color.
CXTPPaintManagerColor m_clrTextNormal
Color of text in a normal tab.
CXTPPaintManagerColor m_clrTextPressed
Color of text in a "pressed" tab button.
CXTPPaintManagerColor | m_clrTextHighlight
Color of text on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrTextHighlightClose
Color of close button text on mouse over when hot tracking is enabled.
CXTPPaintManagerColor m_clrTextSelected
Color of text in a "selected" tab button.
CXTPPaintManagerColor m_clrTextSelectedPressed
Color of text in a "pressed" tab button.
CXTPPaintManagerColor | m_clrTextSelectedHighlighted
Color of text for tabs in all non-active groups of tabs in MDITabClient.
CXTPPaintManagerColor m_clrTextDisabled
Color of text when a tab is disabled.
CXTPPaintManagerColor | m_clrActiveFilesGlyph
Color of navigation button.
CXTPPaintManagerColor | m_clrActiveFilesGlyphHighlighted
Color of highlighted navigation button.
CXTPPaintManagerColor | m_clrActiveFilesGlyphPressed
Color of selected navigation button.
CXTPPaintManagerColor | m_clrActiveFilesBack
Color of highlighted navigation button background.
CXTPPaintManagerColor | m_clrActiveFilesBackHighlighted
Color of navigation button background.
CXTPPaintManagerColor | m_clrActiveFilesBackPressed
Color of selected navigation button background.
COLORSET_TAB_STATEBUTTON | m_csStateButton
Color set of state button style tabs.
COLORSET_TAB_PROPERTYPAGE | m_csPropertyPage
Color set of visual studio style tabs.
COLORSET_TAB_PROPERTYPAGE2003 | m_csPropertyPage2003
Color set of Office 2003 style tabs.
COLORSET_TAB_EXCEL | m_csExcelSelected
Color set of selected (focused) Excel style tabs.
COLORSET_TAB_EXCEL | m_csExcelNormal
Color set of normal Excel style tabs.
- Protected Attributes inherited from CXTPTabPaintManagerColorSet
CXTPTabPaintManager * | m_pPaintManager
Self paint manager pointer.

Detailed Description

Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines.

The documentation for this class was generated from the following file:
  • XTPDockingPanePanelColorSet2013.h


Toolkit Pro: CXTPDockingPanePanelColorSet2015 Class Reference

Public Member Functions | List of all members
CXTPDockingPanePanelColorSet2015 Class Reference

Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines. More...

Inheritance diagram for CXTPDockingPanePanelColorSet2015:
[legend]

Public Member Functions

CXTPDockingPanePanelColorSet2015 ()
Default class constructor.
virtual void | RefreshMetrics ()
This member function is used to initialize default colors for a theme from an .INI resource.
- Public Member Functions inherited from CXTPDockingPanePanelColorSet2012
CXTPDockingPanePanelColorSet2012 ()
Default class constructor.
virtual COLORREF | GetItemColor (CXTPTabManagerItem *pItem)
Call this member function to retrieve the color for the tab specified by pItem.
virtual void | FillNavigateButton (CDC *pDC, CXTPTabManagerNavigateButton *pButton, CRect &rc)
This member is called to fill the tab navigation buttons.
- Public Member Functions inherited from CXTPTabPaintManagerColorSet
CXTPTabPaintManagerColorSet ()
Constructs a CXTPTabPaintManagerColorSet object.
virtual | ~CXTPTabPaintManagerColorSet ()
Destroys a CXTPTabPaintManagerColorSet object, handles cleanup and deallocation.
virtual void | SetTextColor (CDC *pDC, CXTPTabManagerItem *pItem)
Sets the text color for the tab.
virtual void | FillHeader (CDC *pDC, CRect rc, CXTPTabManager *pTabManager)
Fills the header of the tab client of a specified tab manager.
virtual COLORREF | FillClient (CDC *pDC, CRect rc, CXTPTabManager *pTabManager)
Fills the tab client area of a specified tab manager.
virtual COLORREF | GetClientColor (CXTPTabManager *pTabManager)
Obtains client background color.
virtual void | FillStateButton (CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem)
Fills a specified tab button when XTPTabAppearanceStyle is xtpTabAppearanceStateButtons.
virtual COLORREF | FillPropertyButton (CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem)
Fills a specified tab button.
virtual void | SelectClipRgn (CDC *pDC, CRect rcClient, CXTPTabManager *pTabManager)
Sets a clipping region for the specified tab client area.
void | GradientFill (CDC *pDC, CRect rc, COLORREF clrLight, COLORREF clrDark, XTPTabPosition position)
Performs a gradient fill of a rectangle with a color that smoothly fades from top to bottom.
virtual BOOL | IsAppThemed () const
Determines if Windows XP themes are enabled and if a Windows XP theme is currently used.

Additional Inherited Members

- Public Attributes inherited from CXTPTabPaintManagerColorSet
CXTPPaintManagerColorGradient | m_clrHeaderFace
Color set of the tab header background.
CXTPPaintManagerColorGradient m_clrAutoHideFace
Color set of the auto-hide panel background.
CXTPPaintManagerColor | m_clrFrameBorder
Color of the border placed around the tab buttons and the tab client.
CXTPPaintManagerColor m_clrControlFace
Color of the control foreground.
CXTPPaintManagerColor | m_clrPaneFace
Color of the control pane foreground.
CXTPPaintManagerColor | m_clrBorderHighlight
Color of the highlight border.
CXTPPaintManagerColor | m_clrTabClientBack
Background color for the tab client area.
CXTPPaintManagerColor | m_clrTabClientBorder
Border color for the tab client area.
CXTPPaintManagerColor m_clrButtonNormal
Color of normal tabs.
CXTPPaintManagerColor | m_clrButtonPressed
Tab pressed button color.
CXTPPaintManagerColor | m_clrButtonHighlighted
Tab button color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonHighlightedClose
Tab close button color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonBorderHighlighted
Tab button border color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonBorderTabContext1
Tab button border color with tab context.
CXTPPaintManagerColor | m_clrButtonBorderTabContext2
Tab button border color with tab context.
CXTPPaintManagerColor | m_clrButtonBorderKeyTips
Tab button border color when ALT button is pressed.
CXTPPaintManagerColor | m_clrButtonSelected
Color of the currently selected tab.
CXTPPaintManagerColor | m_clrButtonSelectedPressed
Color of the currently selected tab when pressed.
CXTPPaintManagerColor | m_clrButtonSelectedHighlighted
Color of the currently selected tab when highlighted.
CXTPPaintManagerColor | m_clrButtonBorder
Tab button border (edge) color.
CXTPPaintManagerColor | m_clrButtonBorderHot
Tab button highlight or pressed border (edge) color.
CXTPPaintManagerColor m_clrTextNormal
Color of text in a normal tab.
CXTPPaintManagerColor m_clrTextPressed
Color of text in a "pressed" tab button.
CXTPPaintManagerColor | m_clrTextHighlight
Color of text on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrTextHighlightClose
Color of close button text on mouse over when hot tracking is enabled.
CXTPPaintManagerColor m_clrTextSelected
Color of text in a "selected" tab button.
CXTPPaintManagerColor m_clrTextSelectedPressed
Color of text in a "pressed" tab button.
CXTPPaintManagerColor | m_clrTextSelectedHighlighted
Color of text for tabs in all non-active groups of tabs in MDITabClient.
CXTPPaintManagerColor m_clrTextDisabled
Color of text when a tab is disabled.
CXTPPaintManagerColor | m_clrActiveFilesGlyph
Color of navigation button.
CXTPPaintManagerColor | m_clrActiveFilesGlyphHighlighted
Color of highlighted navigation button.
CXTPPaintManagerColor | m_clrActiveFilesGlyphPressed
Color of selected navigation button.
CXTPPaintManagerColor | m_clrActiveFilesBack
Color of highlighted navigation button background.
CXTPPaintManagerColor | m_clrActiveFilesBackHighlighted
Color of navigation button background.
CXTPPaintManagerColor | m_clrActiveFilesBackPressed
Color of selected navigation button background.
COLORSET_TAB_STATEBUTTON | m_csStateButton
Color set of state button style tabs.
COLORSET_TAB_PROPERTYPAGE | m_csPropertyPage
Color set of visual studio style tabs.
COLORSET_TAB_PROPERTYPAGE2003 | m_csPropertyPage2003
Color set of Office 2003 style tabs.
COLORSET_TAB_EXCEL | m_csExcelSelected
Color set of selected (focused) Excel style tabs.
COLORSET_TAB_EXCEL | m_csExcelNormal
Color set of normal Excel style tabs.
- Protected Attributes inherited from CXTPTabPaintManagerColorSet
CXTPTabPaintManager * | m_pPaintManager
Self paint manager pointer.

Detailed Description

Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines.

The documentation for this class was generated from the following file:
  • XTPDockingPanePanelColorSet2015.h


Toolkit Pro: CXTPDockingPanePanelColorSet2017 Class Reference

Public Member Functions | List of all members
CXTPDockingPanePanelColorSet2017 Class Reference

Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines. More...

Inheritance diagram for CXTPDockingPanePanelColorSet2017:
[legend]

Public Member Functions

CXTPDockingPanePanelColorSet2017 ()
Default class constructor.
virtual void | RefreshMetrics ()
This member function is used to initialize default colors for a theme from an .INI resource.
- Public Member Functions inherited from CXTPDockingPanePanelColorSet2012
CXTPDockingPanePanelColorSet2012 ()
Default class constructor.
virtual COLORREF | GetItemColor (CXTPTabManagerItem *pItem)
Call this member function to retrieve the color for the tab specified by pItem.
virtual void | FillNavigateButton (CDC *pDC, CXTPTabManagerNavigateButton *pButton, CRect &rc)
This member is called to fill the tab navigation buttons.
- Public Member Functions inherited from CXTPTabPaintManagerColorSet
CXTPTabPaintManagerColorSet ()
Constructs a CXTPTabPaintManagerColorSet object.
virtual | ~CXTPTabPaintManagerColorSet ()
Destroys a CXTPTabPaintManagerColorSet object, handles cleanup and deallocation.
virtual void | SetTextColor (CDC *pDC, CXTPTabManagerItem *pItem)
Sets the text color for the tab.
virtual void | FillHeader (CDC *pDC, CRect rc, CXTPTabManager *pTabManager)
Fills the header of the tab client of a specified tab manager.
virtual COLORREF | FillClient (CDC *pDC, CRect rc, CXTPTabManager *pTabManager)
Fills the tab client area of a specified tab manager.
virtual COLORREF | GetClientColor (CXTPTabManager *pTabManager)
Obtains client background color.
virtual void | FillStateButton (CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem)
Fills a specified tab button when XTPTabAppearanceStyle is xtpTabAppearanceStateButtons.
virtual COLORREF | FillPropertyButton (CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem)
Fills a specified tab button.
virtual void | SelectClipRgn (CDC *pDC, CRect rcClient, CXTPTabManager *pTabManager)
Sets a clipping region for the specified tab client area.
void | GradientFill (CDC *pDC, CRect rc, COLORREF clrLight, COLORREF clrDark, XTPTabPosition position)
Performs a gradient fill of a rectangle with a color that smoothly fades from top to bottom.
virtual BOOL | IsAppThemed () const
Determines if Windows XP themes are enabled and if a Windows XP theme is currently used.

Additional Inherited Members

- Public Attributes inherited from CXTPTabPaintManagerColorSet
CXTPPaintManagerColorGradient | m_clrHeaderFace
Color set of the tab header background.
CXTPPaintManagerColorGradient m_clrAutoHideFace
Color set of the auto-hide panel background.
CXTPPaintManagerColor | m_clrFrameBorder
Color of the border placed around the tab buttons and the tab client.
CXTPPaintManagerColor m_clrControlFace
Color of the control foreground.
CXTPPaintManagerColor | m_clrPaneFace
Color of the control pane foreground.
CXTPPaintManagerColor | m_clrBorderHighlight
Color of the highlight border.
CXTPPaintManagerColor | m_clrTabClientBack
Background color for the tab client area.
CXTPPaintManagerColor | m_clrTabClientBorder
Border color for the tab client area.
CXTPPaintManagerColor m_clrButtonNormal
Color of normal tabs.
CXTPPaintManagerColor | m_clrButtonPressed
Tab pressed button color.
CXTPPaintManagerColor | m_clrButtonHighlighted
Tab button color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonHighlightedClose
Tab close button color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonBorderHighlighted
Tab button border color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonBorderTabContext1
Tab button border color with tab context.
CXTPPaintManagerColor | m_clrButtonBorderTabContext2
Tab button border color with tab context.
CXTPPaintManagerColor | m_clrButtonBorderKeyTips
Tab button border color when ALT button is pressed.
CXTPPaintManagerColor | m_clrButtonSelected
Color of the currently selected tab.
CXTPPaintManagerColor | m_clrButtonSelectedPressed
Color of the currently selected tab when pressed.
CXTPPaintManagerColor | m_clrButtonSelectedHighlighted
Color of the currently selected tab when highlighted.
CXTPPaintManagerColor | m_clrButtonBorder
Tab button border (edge) color.
CXTPPaintManagerColor | m_clrButtonBorderHot
Tab button highlight or pressed border (edge) color.
CXTPPaintManagerColor m_clrTextNormal
Color of text in a normal tab.
CXTPPaintManagerColor m_clrTextPressed
Color of text in a "pressed" tab button.
CXTPPaintManagerColor | m_clrTextHighlight
Color of text on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrTextHighlightClose
Color of close button text on mouse over when hot tracking is enabled.
CXTPPaintManagerColor m_clrTextSelected
Color of text in a "selected" tab button.
CXTPPaintManagerColor m_clrTextSelectedPressed
Color of text in a "pressed" tab button.
CXTPPaintManagerColor | m_clrTextSelectedHighlighted
Color of text for tabs in all non-active groups of tabs in MDITabClient.
CXTPPaintManagerColor m_clrTextDisabled
Color of text when a tab is disabled.
CXTPPaintManagerColor | m_clrActiveFilesGlyph
Color of navigation button.
CXTPPaintManagerColor | m_clrActiveFilesGlyphHighlighted
Color of highlighted navigation button.
CXTPPaintManagerColor | m_clrActiveFilesGlyphPressed
Color of selected navigation button.
CXTPPaintManagerColor | m_clrActiveFilesBack
Color of highlighted navigation button background.
CXTPPaintManagerColor | m_clrActiveFilesBackHighlighted
Color of navigation button background.
CXTPPaintManagerColor | m_clrActiveFilesBackPressed
Color of selected navigation button background.
COLORSET_TAB_STATEBUTTON | m_csStateButton
Color set of state button style tabs.
COLORSET_TAB_PROPERTYPAGE | m_csPropertyPage
Color set of visual studio style tabs.
COLORSET_TAB_PROPERTYPAGE2003 | m_csPropertyPage2003
Color set of Office 2003 style tabs.
COLORSET_TAB_EXCEL | m_csExcelSelected
Color set of selected (focused) Excel style tabs.
COLORSET_TAB_EXCEL | m_csExcelNormal
Color set of normal Excel style tabs.
- Protected Attributes inherited from CXTPTabPaintManagerColorSet
CXTPTabPaintManager * | m_pPaintManager
Self paint manager pointer.

Detailed Description

Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines.

The documentation for this class was generated from the following file:
  • XTPDockingPanePanelColorSet2017.h


Toolkit Pro: CXTPDockingPanePanelColorSet2019 Class Reference

Public Member Functions | List of all members
CXTPDockingPanePanelColorSet2019 Class Reference

Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines. More...

Inheritance diagram for CXTPDockingPanePanelColorSet2019:
[legend]

Public Member Functions

CXTPDockingPanePanelColorSet2019 ()
Default class constructor.
virtual void | RefreshMetrics ()
This member function is used to initialize default colors for a theme from an .INI resource.
- Public Member Functions inherited from CXTPDockingPanePanelColorSet2012
CXTPDockingPanePanelColorSet2012 ()
Default class constructor.
virtual COLORREF | GetItemColor (CXTPTabManagerItem *pItem)
Call this member function to retrieve the color for the tab specified by pItem.
virtual void | FillNavigateButton (CDC *pDC, CXTPTabManagerNavigateButton *pButton, CRect &rc)
This member is called to fill the tab navigation buttons.
- Public Member Functions inherited from CXTPTabPaintManagerColorSet
CXTPTabPaintManagerColorSet ()
Constructs a CXTPTabPaintManagerColorSet object.
virtual | ~CXTPTabPaintManagerColorSet ()
Destroys a CXTPTabPaintManagerColorSet object, handles cleanup and deallocation.
virtual void | SetTextColor (CDC *pDC, CXTPTabManagerItem *pItem)
Sets the text color for the tab.
virtual void | FillHeader (CDC *pDC, CRect rc, CXTPTabManager *pTabManager)
Fills the header of the tab client of a specified tab manager.
virtual COLORREF | FillClient (CDC *pDC, CRect rc, CXTPTabManager *pTabManager)
Fills the tab client area of a specified tab manager.
virtual COLORREF | GetClientColor (CXTPTabManager *pTabManager)
Obtains client background color.
virtual void | FillStateButton (CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem)
Fills a specified tab button when XTPTabAppearanceStyle is xtpTabAppearanceStateButtons.
virtual COLORREF | FillPropertyButton (CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem)
Fills a specified tab button.
virtual void | SelectClipRgn (CDC *pDC, CRect rcClient, CXTPTabManager *pTabManager)
Sets a clipping region for the specified tab client area.
void | GradientFill (CDC *pDC, CRect rc, COLORREF clrLight, COLORREF clrDark, XTPTabPosition position)
Performs a gradient fill of a rectangle with a color that smoothly fades from top to bottom.
virtual BOOL | IsAppThemed () const
Determines if Windows XP themes are enabled and if a Windows XP theme is currently used.

Additional Inherited Members

- Public Attributes inherited from CXTPTabPaintManagerColorSet
CXTPPaintManagerColorGradient | m_clrHeaderFace
Color set of the tab header background.
CXTPPaintManagerColorGradient m_clrAutoHideFace
Color set of the auto-hide panel background.
CXTPPaintManagerColor | m_clrFrameBorder
Color of the border placed around the tab buttons and the tab client.
CXTPPaintManagerColor m_clrControlFace
Color of the control foreground.
CXTPPaintManagerColor | m_clrPaneFace
Color of the control pane foreground.
CXTPPaintManagerColor | m_clrBorderHighlight
Color of the highlight border.
CXTPPaintManagerColor | m_clrTabClientBack
Background color for the tab client area.
CXTPPaintManagerColor | m_clrTabClientBorder
Border color for the tab client area.
CXTPPaintManagerColor m_clrButtonNormal
Color of normal tabs.
CXTPPaintManagerColor | m_clrButtonPressed
Tab pressed button color.
CXTPPaintManagerColor | m_clrButtonHighlighted
Tab button color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonHighlightedClose
Tab close button color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonBorderHighlighted
Tab button border color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonBorderTabContext1
Tab button border color with tab context.
CXTPPaintManagerColor | m_clrButtonBorderTabContext2
Tab button border color with tab context.
CXTPPaintManagerColor | m_clrButtonBorderKeyTips
Tab button border color when ALT button is pressed.
CXTPPaintManagerColor | m_clrButtonSelected
Color of the currently selected tab.
CXTPPaintManagerColor | m_clrButtonSelectedPressed
Color of the currently selected tab when pressed.
CXTPPaintManagerColor | m_clrButtonSelectedHighlighted
Color of the currently selected tab when highlighted.
CXTPPaintManagerColor | m_clrButtonBorder
Tab button border (edge) color.
CXTPPaintManagerColor | m_clrButtonBorderHot
Tab button highlight or pressed border (edge) color.
CXTPPaintManagerColor m_clrTextNormal
Color of text in a normal tab.
CXTPPaintManagerColor m_clrTextPressed
Color of text in a "pressed" tab button.
CXTPPaintManagerColor | m_clrTextHighlight
Color of text on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrTextHighlightClose
Color of close button text on mouse over when hot tracking is enabled.
CXTPPaintManagerColor m_clrTextSelected
Color of text in a "selected" tab button.
CXTPPaintManagerColor m_clrTextSelectedPressed
Color of text in a "pressed" tab button.
CXTPPaintManagerColor | m_clrTextSelectedHighlighted
Color of text for tabs in all non-active groups of tabs in MDITabClient.
CXTPPaintManagerColor m_clrTextDisabled
Color of text when a tab is disabled.
CXTPPaintManagerColor | m_clrActiveFilesGlyph
Color of navigation button.
CXTPPaintManagerColor | m_clrActiveFilesGlyphHighlighted
Color of highlighted navigation button.
CXTPPaintManagerColor | m_clrActiveFilesGlyphPressed
Color of selected navigation button.
CXTPPaintManagerColor | m_clrActiveFilesBack
Color of highlighted navigation button background.
CXTPPaintManagerColor | m_clrActiveFilesBackHighlighted
Color of navigation button background.
CXTPPaintManagerColor | m_clrActiveFilesBackPressed
Color of selected navigation button background.
COLORSET_TAB_STATEBUTTON | m_csStateButton
Color set of state button style tabs.
COLORSET_TAB_PROPERTYPAGE | m_csPropertyPage
Color set of visual studio style tabs.
COLORSET_TAB_PROPERTYPAGE2003 | m_csPropertyPage2003
Color set of Office 2003 style tabs.
COLORSET_TAB_EXCEL | m_csExcelSelected
Color set of selected (focused) Excel style tabs.
COLORSET_TAB_EXCEL | m_csExcelNormal
Color set of normal Excel style tabs.
- Protected Attributes inherited from CXTPTabPaintManagerColorSet
CXTPTabPaintManager * | m_pPaintManager
Self paint manager pointer.

Detailed Description

Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines.

The documentation for this class was generated from the following file:
  • XTPDockingPanePanelColorSet2019.h


Toolkit Pro: CXTPDockingPanePanelColorSet2022 Class Reference

Public Member Functions | List of all members
CXTPDockingPanePanelColorSet2022 Class Reference

Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines. More...

Inheritance diagram for CXTPDockingPanePanelColorSet2022:
[legend]

Public Member Functions

CXTPDockingPanePanelColorSet2022 ()
Default class constructor.
virtual void | RefreshMetrics ()
This member function is used to initialize default colors for a theme from an .INI resource.
- Public Member Functions inherited from CXTPDockingPanePanelColorSet2012
CXTPDockingPanePanelColorSet2012 ()
Default class constructor.
virtual COLORREF | GetItemColor (CXTPTabManagerItem *pItem)
Call this member function to retrieve the color for the tab specified by pItem.
virtual void | FillNavigateButton (CDC *pDC, CXTPTabManagerNavigateButton *pButton, CRect &rc)
This member is called to fill the tab navigation buttons.
- Public Member Functions inherited from CXTPTabPaintManagerColorSet
CXTPTabPaintManagerColorSet ()
Constructs a CXTPTabPaintManagerColorSet object.
virtual | ~CXTPTabPaintManagerColorSet ()
Destroys a CXTPTabPaintManagerColorSet object, handles cleanup and deallocation.
virtual void | SetTextColor (CDC *pDC, CXTPTabManagerItem *pItem)
Sets the text color for the tab.
virtual void | FillHeader (CDC *pDC, CRect rc, CXTPTabManager *pTabManager)
Fills the header of the tab client of a specified tab manager.
virtual COLORREF | FillClient (CDC *pDC, CRect rc, CXTPTabManager *pTabManager)
Fills the tab client area of a specified tab manager.
virtual COLORREF | GetClientColor (CXTPTabManager *pTabManager)
Obtains client background color.
virtual void | FillStateButton (CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem)
Fills a specified tab button when XTPTabAppearanceStyle is xtpTabAppearanceStateButtons.
virtual COLORREF | FillPropertyButton (CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem)
Fills a specified tab button.
virtual void | SelectClipRgn (CDC *pDC, CRect rcClient, CXTPTabManager *pTabManager)
Sets a clipping region for the specified tab client area.
void | GradientFill (CDC *pDC, CRect rc, COLORREF clrLight, COLORREF clrDark, XTPTabPosition position)
Performs a gradient fill of a rectangle with a color that smoothly fades from top to bottom.
virtual BOOL | IsAppThemed () const
Determines if Windows XP themes are enabled and if a Windows XP theme is currently used.

Additional Inherited Members

- Public Attributes inherited from CXTPTabPaintManagerColorSet
CXTPPaintManagerColorGradient | m_clrHeaderFace
Color set of the tab header background.
CXTPPaintManagerColorGradient m_clrAutoHideFace
Color set of the auto-hide panel background.
CXTPPaintManagerColor | m_clrFrameBorder
Color of the border placed around the tab buttons and the tab client.
CXTPPaintManagerColor m_clrControlFace
Color of the control foreground.
CXTPPaintManagerColor | m_clrPaneFace
Color of the control pane foreground.
CXTPPaintManagerColor | m_clrBorderHighlight
Color of the highlight border.
CXTPPaintManagerColor | m_clrTabClientBack
Background color for the tab client area.
CXTPPaintManagerColor | m_clrTabClientBorder
Border color for the tab client area.
CXTPPaintManagerColor m_clrButtonNormal
Color of normal tabs.
CXTPPaintManagerColor | m_clrButtonPressed
Tab pressed button color.
CXTPPaintManagerColor | m_clrButtonHighlighted
Tab button color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonHighlightedClose
Tab close button color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonBorderHighlighted
Tab button border color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonBorderTabContext1
Tab button border color with tab context.
CXTPPaintManagerColor | m_clrButtonBorderTabContext2
Tab button border color with tab context.
CXTPPaintManagerColor | m_clrButtonBorderKeyTips
Tab button border color when ALT button is pressed.
CXTPPaintManagerColor | m_clrButtonSelected
Color of the currently selected tab.
CXTPPaintManagerColor | m_clrButtonSelectedPressed
Color of the currently selected tab when pressed.
CXTPPaintManagerColor | m_clrButtonSelectedHighlighted
Color of the currently selected tab when highlighted.
CXTPPaintManagerColor | m_clrButtonBorder
Tab button border (edge) color.
CXTPPaintManagerColor | m_clrButtonBorderHot
Tab button highlight or pressed border (edge) color.
CXTPPaintManagerColor m_clrTextNormal
Color of text in a normal tab.
CXTPPaintManagerColor m_clrTextPressed
Color of text in a "pressed" tab button.
CXTPPaintManagerColor | m_clrTextHighlight
Color of text on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrTextHighlightClose
Color of close button text on mouse over when hot tracking is enabled.
CXTPPaintManagerColor m_clrTextSelected
Color of text in a "selected" tab button.
CXTPPaintManagerColor m_clrTextSelectedPressed
Color of text in a "pressed" tab button.
CXTPPaintManagerColor | m_clrTextSelectedHighlighted
Color of text for tabs in all non-active groups of tabs in MDITabClient.
CXTPPaintManagerColor m_clrTextDisabled
Color of text when a tab is disabled.
CXTPPaintManagerColor | m_clrActiveFilesGlyph
Color of navigation button.
CXTPPaintManagerColor | m_clrActiveFilesGlyphHighlighted
Color of highlighted navigation button.
CXTPPaintManagerColor | m_clrActiveFilesGlyphPressed
Color of selected navigation button.
CXTPPaintManagerColor | m_clrActiveFilesBack
Color of highlighted navigation button background.
CXTPPaintManagerColor | m_clrActiveFilesBackHighlighted
Color of navigation button background.
CXTPPaintManagerColor | m_clrActiveFilesBackPressed
Color of selected navigation button background.
COLORSET_TAB_STATEBUTTON | m_csStateButton
Color set of state button style tabs.
COLORSET_TAB_PROPERTYPAGE | m_csPropertyPage
Color set of visual studio style tabs.
COLORSET_TAB_PROPERTYPAGE2003 | m_csPropertyPage2003
Color set of Office 2003 style tabs.
COLORSET_TAB_EXCEL | m_csExcelSelected
Color set of selected (focused) Excel style tabs.
COLORSET_TAB_EXCEL | m_csExcelNormal
Color set of normal Excel style tabs.
- Protected Attributes inherited from CXTPTabPaintManagerColorSet
CXTPTabPaintManager * | m_pPaintManager
Self paint manager pointer.

Detailed Description

Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines.

The documentation for this class was generated from the following file:
  • XTPDockingPanePanelColorSet2022.h


Toolkit Pro: CXTPDockingPanePanelColorSetNativeWindows10 Class Reference

Public Member Functions | List of all members
CXTPDockingPanePanelColorSetNativeWindows10 Class Reference

Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines. More...

Inheritance diagram for CXTPDockingPanePanelColorSetNativeWindows10:
[legend]

Public Member Functions

CXTPDockingPanePanelColorSetNativeWindows10 ()
Default class constructor.
virtual void | RefreshMetrics ()
This member function is used to initialize default colors for a theme from an .INI resource.
- Public Member Functions inherited from CXTPDockingPanePanelColorSet2012
CXTPDockingPanePanelColorSet2012 ()
Default class constructor.
virtual COLORREF | GetItemColor (CXTPTabManagerItem *pItem)
Call this member function to retrieve the color for the tab specified by pItem.
virtual void | FillNavigateButton (CDC *pDC, CXTPTabManagerNavigateButton *pButton, CRect &rc)
This member is called to fill the tab navigation buttons.
- Public Member Functions inherited from CXTPTabPaintManagerColorSet
CXTPTabPaintManagerColorSet ()
Constructs a CXTPTabPaintManagerColorSet object.
virtual | ~CXTPTabPaintManagerColorSet ()
Destroys a CXTPTabPaintManagerColorSet object, handles cleanup and deallocation.
virtual void | SetTextColor (CDC *pDC, CXTPTabManagerItem *pItem)
Sets the text color for the tab.
virtual void | FillHeader (CDC *pDC, CRect rc, CXTPTabManager *pTabManager)
Fills the header of the tab client of a specified tab manager.
virtual COLORREF | FillClient (CDC *pDC, CRect rc, CXTPTabManager *pTabManager)
Fills the tab client area of a specified tab manager.
virtual COLORREF | GetClientColor (CXTPTabManager *pTabManager)
Obtains client background color.
virtual void | FillStateButton (CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem)
Fills a specified tab button when XTPTabAppearanceStyle is xtpTabAppearanceStateButtons.
virtual COLORREF | FillPropertyButton (CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem)
Fills a specified tab button.
virtual void | SelectClipRgn (CDC *pDC, CRect rcClient, CXTPTabManager *pTabManager)
Sets a clipping region for the specified tab client area.
void | GradientFill (CDC *pDC, CRect rc, COLORREF clrLight, COLORREF clrDark, XTPTabPosition position)
Performs a gradient fill of a rectangle with a color that smoothly fades from top to bottom.
virtual BOOL | IsAppThemed () const
Determines if Windows XP themes are enabled and if a Windows XP theme is currently used.

Additional Inherited Members

- Public Attributes inherited from CXTPTabPaintManagerColorSet
CXTPPaintManagerColorGradient | m_clrHeaderFace
Color set of the tab header background.
CXTPPaintManagerColorGradient m_clrAutoHideFace
Color set of the auto-hide panel background.
CXTPPaintManagerColor | m_clrFrameBorder
Color of the border placed around the tab buttons and the tab client.
CXTPPaintManagerColor m_clrControlFace
Color of the control foreground.
CXTPPaintManagerColor | m_clrPaneFace
Color of the control pane foreground.
CXTPPaintManagerColor | m_clrBorderHighlight
Color of the highlight border.
CXTPPaintManagerColor | m_clrTabClientBack
Background color for the tab client area.
CXTPPaintManagerColor | m_clrTabClientBorder
Border color for the tab client area.
CXTPPaintManagerColor m_clrButtonNormal
Color of normal tabs.
CXTPPaintManagerColor | m_clrButtonPressed
Tab pressed button color.
CXTPPaintManagerColor | m_clrButtonHighlighted
Tab button color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonHighlightedClose
Tab close button color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonBorderHighlighted
Tab button border color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonBorderTabContext1
Tab button border color with tab context.
CXTPPaintManagerColor | m_clrButtonBorderTabContext2
Tab button border color with tab context.
CXTPPaintManagerColor | m_clrButtonBorderKeyTips
Tab button border color when ALT button is pressed.
CXTPPaintManagerColor | m_clrButtonSelected
Color of the currently selected tab.
CXTPPaintManagerColor | m_clrButtonSelectedPressed
Color of the currently selected tab when pressed.
CXTPPaintManagerColor | m_clrButtonSelectedHighlighted
Color of the currently selected tab when highlighted.
CXTPPaintManagerColor | m_clrButtonBorder
Tab button border (edge) color.
CXTPPaintManagerColor | m_clrButtonBorderHot
Tab button highlight or pressed border (edge) color.
CXTPPaintManagerColor m_clrTextNormal
Color of text in a normal tab.
CXTPPaintManagerColor m_clrTextPressed
Color of text in a "pressed" tab button.
CXTPPaintManagerColor | m_clrTextHighlight
Color of text on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrTextHighlightClose
Color of close button text on mouse over when hot tracking is enabled.
CXTPPaintManagerColor m_clrTextSelected
Color of text in a "selected" tab button.
CXTPPaintManagerColor m_clrTextSelectedPressed
Color of text in a "pressed" tab button.
CXTPPaintManagerColor | m_clrTextSelectedHighlighted
Color of text for tabs in all non-active groups of tabs in MDITabClient.
CXTPPaintManagerColor m_clrTextDisabled
Color of text when a tab is disabled.
CXTPPaintManagerColor | m_clrActiveFilesGlyph
Color of navigation button.
CXTPPaintManagerColor | m_clrActiveFilesGlyphHighlighted
Color of highlighted navigation button.
CXTPPaintManagerColor | m_clrActiveFilesGlyphPressed
Color of selected navigation button.
CXTPPaintManagerColor | m_clrActiveFilesBack
Color of highlighted navigation button background.
CXTPPaintManagerColor | m_clrActiveFilesBackHighlighted
Color of navigation button background.
CXTPPaintManagerColor | m_clrActiveFilesBackPressed
Color of selected navigation button background.
COLORSET_TAB_STATEBUTTON | m_csStateButton
Color set of state button style tabs.
COLORSET_TAB_PROPERTYPAGE | m_csPropertyPage
Color set of visual studio style tabs.
COLORSET_TAB_PROPERTYPAGE2003 | m_csPropertyPage2003
Color set of Office 2003 style tabs.
COLORSET_TAB_EXCEL | m_csExcelSelected
Color set of selected (focused) Excel style tabs.
COLORSET_TAB_EXCEL | m_csExcelNormal
Color set of normal Excel style tabs.
- Protected Attributes inherited from CXTPTabPaintManagerColorSet
CXTPTabPaintManager * | m_pPaintManager
Self paint manager pointer.

Detailed Description

Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines.

The documentation for this class was generated from the following file:
  • XTPDockingPanePanelColorSetNativeWindows10.h


Toolkit Pro: CXTPDockingPanePanelColorSetNativeWindows11 Class Reference

Public Member Functions | List of all members
CXTPDockingPanePanelColorSetNativeWindows11 Class Reference

Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines. More...

Inheritance diagram for CXTPDockingPanePanelColorSetNativeWindows11:
[legend]

Public Member Functions

CXTPDockingPanePanelColorSetNativeWindows11 ()
Default class constructor.
virtual void | RefreshMetrics ()
This member function is used to initialize default colors for a theme from an .INI resource.
- Public Member Functions inherited from CXTPDockingPanePanelColorSet2012
CXTPDockingPanePanelColorSet2012 ()
Default class constructor.
virtual COLORREF | GetItemColor (CXTPTabManagerItem *pItem)
Call this member function to retrieve the color for the tab specified by pItem.
virtual void | FillNavigateButton (CDC *pDC, CXTPTabManagerNavigateButton *pButton, CRect &rc)
This member is called to fill the tab navigation buttons.
- Public Member Functions inherited from CXTPTabPaintManagerColorSet
CXTPTabPaintManagerColorSet ()
Constructs a CXTPTabPaintManagerColorSet object.
virtual | ~CXTPTabPaintManagerColorSet ()
Destroys a CXTPTabPaintManagerColorSet object, handles cleanup and deallocation.
virtual void | SetTextColor (CDC *pDC, CXTPTabManagerItem *pItem)
Sets the text color for the tab.
virtual void | FillHeader (CDC *pDC, CRect rc, CXTPTabManager *pTabManager)
Fills the header of the tab client of a specified tab manager.
virtual COLORREF | FillClient (CDC *pDC, CRect rc, CXTPTabManager *pTabManager)
Fills the tab client area of a specified tab manager.
virtual COLORREF | GetClientColor (CXTPTabManager *pTabManager)
Obtains client background color.
virtual void | FillStateButton (CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem)
Fills a specified tab button when XTPTabAppearanceStyle is xtpTabAppearanceStateButtons.
virtual COLORREF | FillPropertyButton (CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem)
Fills a specified tab button.
virtual void | SelectClipRgn (CDC *pDC, CRect rcClient, CXTPTabManager *pTabManager)
Sets a clipping region for the specified tab client area.
void | GradientFill (CDC *pDC, CRect rc, COLORREF clrLight, COLORREF clrDark, XTPTabPosition position)
Performs a gradient fill of a rectangle with a color that smoothly fades from top to bottom.
virtual BOOL | IsAppThemed () const
Determines if Windows XP themes are enabled and if a Windows XP theme is currently used.

Additional Inherited Members

- Public Attributes inherited from CXTPTabPaintManagerColorSet
CXTPPaintManagerColorGradient | m_clrHeaderFace
Color set of the tab header background.
CXTPPaintManagerColorGradient m_clrAutoHideFace
Color set of the auto-hide panel background.
CXTPPaintManagerColor | m_clrFrameBorder
Color of the border placed around the tab buttons and the tab client.
CXTPPaintManagerColor m_clrControlFace
Color of the control foreground.
CXTPPaintManagerColor | m_clrPaneFace
Color of the control pane foreground.
CXTPPaintManagerColor | m_clrBorderHighlight
Color of the highlight border.
CXTPPaintManagerColor | m_clrTabClientBack
Background color for the tab client area.
CXTPPaintManagerColor | m_clrTabClientBorder
Border color for the tab client area.
CXTPPaintManagerColor m_clrButtonNormal
Color of normal tabs.
CXTPPaintManagerColor | m_clrButtonPressed
Tab pressed button color.
CXTPPaintManagerColor | m_clrButtonHighlighted
Tab button color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonHighlightedClose
Tab close button color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonBorderHighlighted
Tab button border color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonBorderTabContext1
Tab button border color with tab context.
CXTPPaintManagerColor | m_clrButtonBorderTabContext2
Tab button border color with tab context.
CXTPPaintManagerColor | m_clrButtonBorderKeyTips
Tab button border color when ALT button is pressed.
CXTPPaintManagerColor | m_clrButtonSelected
Color of the currently selected tab.
CXTPPaintManagerColor | m_clrButtonSelectedPressed
Color of the currently selected tab when pressed.
CXTPPaintManagerColor | m_clrButtonSelectedHighlighted
Color of the currently selected tab when highlighted.
CXTPPaintManagerColor | m_clrButtonBorder
Tab button border (edge) color.
CXTPPaintManagerColor | m_clrButtonBorderHot
Tab button highlight or pressed border (edge) color.
CXTPPaintManagerColor m_clrTextNormal
Color of text in a normal tab.
CXTPPaintManagerColor m_clrTextPressed
Color of text in a "pressed" tab button.
CXTPPaintManagerColor | m_clrTextHighlight
Color of text on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrTextHighlightClose
Color of close button text on mouse over when hot tracking is enabled.
CXTPPaintManagerColor m_clrTextSelected
Color of text in a "selected" tab button.
CXTPPaintManagerColor m_clrTextSelectedPressed
Color of text in a "pressed" tab button.
CXTPPaintManagerColor | m_clrTextSelectedHighlighted
Color of text for tabs in all non-active groups of tabs in MDITabClient.
CXTPPaintManagerColor m_clrTextDisabled
Color of text when a tab is disabled.
CXTPPaintManagerColor | m_clrActiveFilesGlyph
Color of navigation button.
CXTPPaintManagerColor | m_clrActiveFilesGlyphHighlighted
Color of highlighted navigation button.
CXTPPaintManagerColor | m_clrActiveFilesGlyphPressed
Color of selected navigation button.
CXTPPaintManagerColor | m_clrActiveFilesBack
Color of highlighted navigation button background.
CXTPPaintManagerColor | m_clrActiveFilesBackHighlighted
Color of navigation button background.
CXTPPaintManagerColor | m_clrActiveFilesBackPressed
Color of selected navigation button background.
COLORSET_TAB_STATEBUTTON | m_csStateButton
Color set of state button style tabs.
COLORSET_TAB_PROPERTYPAGE | m_csPropertyPage
Color set of visual studio style tabs.
COLORSET_TAB_PROPERTYPAGE2003 | m_csPropertyPage2003
Color set of Office 2003 style tabs.
COLORSET_TAB_EXCEL | m_csExcelSelected
Color set of selected (focused) Excel style tabs.
COLORSET_TAB_EXCEL | m_csExcelNormal
Color set of normal Excel style tabs.
- Protected Attributes inherited from CXTPTabPaintManagerColorSet
CXTPTabPaintManager * | m_pPaintManager
Self paint manager pointer.

Detailed Description

Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines.

The documentation for this class was generated from the following file:
  • XTPDockingPanePanelColorSetNativeWindows11.h


Toolkit Pro: CXTPDockingPanePanelPaintManager Class Reference

Public Member Functions | List of all members
CXTPDockingPanePanelPaintManager Class Reference

CXTPDockingPanePanelPaintManager is a CXTPTabPaintManager derived class that is used to store the color and appearance information of the tabs in the tab manager. More...

Inheritance diagram for CXTPDockingPanePanelPaintManager:
[legend]

Public Member Functions

virtual CXTPTabPaintManagerColorSet * | SetColor (XTPTabColorStyle tabColor)
Call this member to apply one of the "built-in" color sets to the tabs.
virtual CXTPTabPaintManagerTheme * | SetAppearance (XTPTabAppearanceStyle tabAppearance)
Call this member to apply one of the "built-in" appearances to the tabs.
- Public Member Functions inherited from CXTPTabPaintManager
CXTPTabPaintManager (BOOL bPanelManager=FALSE)
Constructs a CXTPTabPaintManager object.
virtual | ~CXTPTabPaintManager ()
Destroys a CXTPTabPaintManager object, handles cleanup and deallocation.
virtual CXTPTabPaintManagerColorSet * | SetColorSet (CXTPTabPaintManagerColorSet *pColorSet)
Applies a custom color set for the tabs.
virtual CXTPTabPaintManagerTheme * | SetAppearanceSet (CXTPTabPaintManagerTheme *pAppearanceSet)
Applies a custom appearance set for the tabs.
CXTPTabPaintManagerTheme * | GetAppearanceSet () const
Gets the currently applied custom appearance set.
CXTPTabPaintManagerColorSet * | GetColorSet () const
Gets the currently applied custom color set.
XTPTabAppearanceStyle | GetAppearance () const
Gets the currently applied "built-in appearance set.
XTPTabColorStyle | GetColor () const
Gets the currently applied "built-in" color set.
BOOL | IsLunaColorsDisabled () const
Determines if luna colors are disabled/enabled.
void | DisableLunaColors (BOOL bDisableLunaColors)
Disables/enables luna colors.
void | SetOneNoteColors (BOOL bOneNoteColors)
Enables/disables OneNote colorization for the tabs.
void | SetPosition (XTPTabPosition tabPosition)
Sets the tab position.
void | SetLayout (XTPTabLayoutStyle tabLayout)
Sets the tab layout style.
XTPTabPosition | GetPosition () const
Gets the tab position.
XTPTabLayoutStyle | GetLayout () const
Gets the tab layout style.
void | SetFontIndirect (LOGFONT *pLogFont, BOOL bUseStandardFont=FALSE)
Sets the font for the tabs.
virtual void | DrawTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl)
Draws the tab control.
virtual void | AdjustClientRect (CXTPTabManager *pTabManager, CRect &rcClient)
Adjusts the tab client rectangle.
virtual void | RepositionTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl)
Moves the tab buttons of the tab control to their correct positions.
CRect | RepositionNavigateButtons (CXTPTabManager *pTabManager, CRect rcClient)
Repositions the tab navigation buttons.
void | FillNavigateButton (CDC *pDC, CXTPTabManagerNavigateButton *pButton, CRect &rc)
Fills a specified tab navigation button.
virtual void | DrawNavigateButton (CDC *pDC, CXTPTabManagerNavigateButton *pButton, CRect &rc)
Draws a specified tab navigation button.
virtual int | DrawSingleButtonIconAndText (CDC *pDC, CXTPTabManagerItem *pItem, CRect rcItem, BOOL bDraw)
Draws the text and icon of a specified tab button.
void | EnsureVisible (CXTPTabManager *pTabManager, CXTPTabManagerItem *pItem)
Ensures that a specified tab is visible.
virtual void | RefreshMetrics ()
Refreshes the visual metrics of the main tab manager.
void | AddObserver (CXTPTabManagerAtom *pObserver)
Adds a control to the list of controls that receives a notification when a property of the paint manager is changed.
void | EnableToolTips (XTPTabToolTipBehaviour behaviour=xtpTabToolTipAlways)
Sets the behaviour for tooltips.
CFont * | GetFont (BOOL bVertical=FALSE)
Gets the font used to display caption text in the tab buttons.
CFont * | GetBoldFont (BOOL bVertical=FALSE)
Gets the font used to display bold caption text in the tab buttons.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPTabPaintManager
static COLORREF AFX_CDECL | GetOneNoteColor (XTPTabOneNoteColor tabColor)
Retrieves the RGB value of a specified OneNote color.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPTabPaintManager
BOOL | m_bHotTracking
If TRUE, then tab hot tracking will be enabled.
BOOL | m_bShowIcons
If TRUE, then tab icons will be drawn if icons were added.
BOOL | m_bBoldSelected
If TRUE, then the text of selected tabs will be displayed in bold font.
BOOL | m_bBoldNormal
If TRUE, then bold font will be used for all tabs regardless of whether they are selected or non-selected.
BOOL | m_bOneNoteColors
If FALSE, then tabs will not use luna colors * the current theme uses luna colors.
XTPTabClientFrame m_clientFrame
If TRUE, then tabs will use OneNote colorization.
BOOL | m_bStaticFrame
If TRUE, then a static frame will be drawn around the entire tab area.
CRect | m_rcClientMargin
Margin around the tab client area.
CRect | m_rcControlMargin
Margin around the entire tab control (i.e.
CRect | m_rcButtonMargin
Margin around the text in tab button.
CRect | m_rcButtonTextPadding
Margin around the text in tab button.
BOOL | m_bInvertGradient
If TRUE, then the colors passed into CXTPTabPaintManagerColorSet::GradientFill will be swapped before the rectangle is filled with the gradient.
BOOL | m_bFillBackground
If TRUE, then the tab client space is filled using CXTPTabPaintManager.CXTPTabPaintManagerColorSet.m_clrControlFace color.
CSize | m_szIcon
Size of the icon displayed in the tab button.
BOOL | m_bDrawTextPathEllipsis
If TRUE, when the size of a tab button is too small to display the caption, the middle of the caption will be replaced with an ellipse "...".
BOOL | m_bDrawTextEndEllipsis
If TRUE, when the size of a tab button is too small to display the caption, the end of the caption will be replaced with an ellipse "...".
BOOL | m_bDrawTextNoPrefix
If FALSE, then an ampersand '&' in the tab button caption will be ignored and a double ampersand '&&' will display a single ampersand '&'.
UINT | m_nDrawTextFormat
Text format for tabs (default - DT_LEFT | DT_VCENTER).
BOOL | m_bDrawTextHidePrefix
If FALSE, then an ampersand '&' in the tab button caption will be ignored and a double ampersand '&&' will display a single ampersand '&'.
BOOL | m_bMultiRowFixedSelection
FALSE to move row with selected item close to client pane.
BOOL | m_bMultiRowJustified
TRUE to stretch each row of tabs to fill the entire width of the control.
BOOL | m_bDrawFocusRect
TRUE to draw focus rect for focused item.
int | m_bSelectOnDragOver
1 - to activate tab when user drag files/text under it.
int | m_nButtonExtraLength
Additional padding of tabs.
BOOL | m_bSelectOnButtonDown
If TRUE, then tab selected on mouse button down.
BOOL | m_bClearTypeTextQuality
TRUE to enable ClearType text for the font.
BOOL | m_bRotateImageOnVerticalDraw
TRUE to rotate image when tab located left or right.
BOOL | m_bClipHeader
TRUE to select clip rectangle before draw tabs.
CSize | m_szNavigateButton
Navigate buttons size.
CSize | m_szTabCloseButton
Tab close button size.
BOOL | m_bShowTabs
TRUE to show tabs.
BOOL | m_bMultiRowTabsOptimization
TRUE if the tab manager will arrange tabs according to their widths.
int | m_nMinTabWidth
Minimum tabs width.
int | m_nMaxTabWidth
Maximum tabs width.
int | m_nFixedTabWidth
Tabs width for fixed layout.
XTPTabToolTipBehaviour | m_toolBehaviour
Tootips behaviour.
BOOL | m_bVerticalTextTopToBottom
Draw vertical text Top-to-Bottom or Bottom-to-Top.
BOOL | m_bPanelManager
TRUE indicates that this is a panel manager, FALSE for tab manager.
- Static Public Attributes inherited from CXTPTabPaintManager
static DWORD | m_nSelectOnDragOverDelay
Delay before Select-on-Drag-Over (300 by default).
- Protected Member Functions inherited from CXTPTabPaintManager
void | SizeToFit (CXTPTabManager *pTabManager, int nWidth)
Changes the tab button size when XTPTabLayoutStyle is set to xtpTabLayoutSizeToFit.
void | DrawTabControlEx (CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl)
Draws the tab control.
void | RepositionTabControlEx (CXTPTabManager *pTabManager, CDC *pDC, CRect rcClient)
Moves the tab buttons of the tab control to their correct positions.
void | RepositionTabControlMultiRow (CXTPTabManager *pTabManager, CDC *pDC, CRect rcClient)
Moves the tab buttons of the multi-row tab control to their correct positions.
virtual void | OnPropertyChanged ()
This method is called when a property of the tab paint manager is changed.
int | _GetButtonLength (int nValue, int nMin, int nMax)
Gets the total button length of a tab button including the left and right button margins.
void | DrawTextPathEllipsis (CDC *pDC, CXTPTabManager *pManager, const CString &strItem, CRect rcItem, UINT uFormat)
Draws an ellipse "..." in the middle of a specified string.
- Protected Attributes inherited from CXTPTabPaintManager
CXTPTabPaintManagerTheme * | m_pAppearanceSet
Currently set CXTPTabPaintManagerTheme.
CXTPTabPaintManagerColorSet * | m_pColorSet
Currently used CXTPTabPaintManagerColorSet.
CArray< CXTPTabManagerAtom *, CXTPTabManagerAtom * > | m_arrObservers
List of controls that receive a notification when a property of the paint manager has changed.
XTPTabAppearanceStyle | m_tabAppearance
Currently set appearance style.
XTPTabColorStyle | m_tabColor
Currently used color style.
XTPTabPosition m_tabPosition
Currently set tab button position.
XTPTabLayoutStyle m_tabLayout
Currently set tab button layout.
CXTPFont | m_xtpFontNormal
Font used to display text in tab buttons.
CXTPFont m_xtpFontBold
Font used to display bold text in the tab buttons (i.e.
CXTPFont | m_xtpFontVerticalNormal
Font used to display tab button caption when the tab position is vertical.
CXTPFont m_xtpFontVerticalBold
Font used to display bold text in the tab buttons when the tab position is vertical (i.e.
BOOL | m_bUseStandardFont
TRUE to use standard system "icon" font (i.e.

Detailed Description

CXTPDockingPanePanelPaintManager is a CXTPTabPaintManager derived class that is used to store the color and appearance information of the tabs in the tab manager.

Member Function Documentation

◆ SetAppearance()

virtual CXTPTabPaintManagerTheme * SetAppearance ( XTPTabAppearanceStyle tabAppearance )
virtual

Call this member to apply one of the "built-in" appearances to the tabs.

Parameters
tabAppearance An XTPTabAppearanceStyle to apply to the tabs.
Returns
A pointer to the CXTPTabPaintManagerTheme object applied.

Use SetAppearance to apply a "Built-In" theme. To apply a custom theme, use the SetAppearanceSet member.

See also
XTPTabAppearanceStyle, SetAppearanceSet, GetAppearance, GetAppearanceSet, SetColor, GetColor, GetColorSet, SetColorSet

Reimplemented from CXTPTabPaintManager.

◆ SetColor()

virtual CXTPTabPaintManagerColorSet * SetColor ( XTPTabColorStyle tabColor )
virtual

Call this member to apply one of the "built-in" color sets to the tabs.

Parameters
tabColor An XTPTabColorStyle to apply to the tabs.
Returns
A pointer to the CXTPTabPaintManagerColorSet object applied.
See also
XTPTabColorStyle, SetColorSet, GetColor, GetColorSet, XTPTabAppearanceStyle, SetAppearanceSet, SetAppearance, GetAppearance, GetAppearanceSet

Reimplemented from CXTPTabPaintManager.

The documentation for this class was generated from the following file:
  • XTPDockingPanePaintManager.h


Toolkit Pro: CXTPDockingPanePanelTheme2012 Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPDockingPanePanelTheme2012 Class Reference

Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines. More...

Inheritance diagram for CXTPDockingPanePanelTheme2012:
[legend]

Public Member Functions

CXTPDockingPanePanelTheme2012 ()
Default class constructor.
virtual void | RefreshMetrics ()
This member function is used to initialize default colors for a theme from an .INI resource.
virtual void | DrawSingleButton (CDC *pDC, CXTPTabManagerItem *pItem)
This method is called to draw a single tab button in the tab client header area.
- Public Member Functions inherited from CXTPTabThemeFlat
CXTPTabThemeFlat ()
Constructs a CXTPTabThemeFlat object.
virtual CRect | FillTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl)
Fills both the tab header and the tab client area and then draws the tab client frame.
virtual XTPTabColorStyle | GetDefaultColorSet ()
Gets the default value of the color set for this theme.
- Public Member Functions inherited from CXTPTabPaintManagerTheme
CXTPTabPaintManagerTheme ()
Constructs a CXTPTabPaintManagerTheme object.
virtual | ~CXTPTabPaintManagerTheme ()
Destroys a CXTPTabPaintManagerTheme object, handles cleanup and deallocation.
CXTPTabPaintManagerColorSet * | GetColorSet () const
Gets the color set.
virtual CRect | GetHeaderRect (CRect rcControl, CXTPTabManager *pTabManager)
Gets the bounding rectangle of the tab header area.
virtual CRect | GetHeaderClipBox (CDC *pDC, CXTPTabManager *pTabManager)
Gets the clip box of the tab header area.
int | GetHeaderHeight (CXTPTabManager *pTabManager)
Gets the height of the tab header area.
virtual CRect | GetClientRect (CRect rcControl, CXTPTabManager *pTabManager)
Gets the bounding rectangle of the tab client area.
virtual CRect | GetHeaderMargin ()
Gets the top, left, right, and bottom margins of the tab header.
virtual CRect | GetClientMargin ()
Gets the top, left, right, and bottom margins of the tab client area.
virtual int | GetButtonLength (CDC *pDC, CXTPTabManagerItem *pItem)
Retrieves the total length of a specified tab button including the left and right button margins.
virtual int | GetButtonHeight (const CXTPTabManager *pTabManager)
Retrieves the total height of the tab buttons within a specified tab manager including the top and bottom margins and the icon.
virtual CRect | GetButtonDrawRect (const CXTPTabManagerItem *pItem)
Retrieves the bounding rectangle of a specified drawing item.
virtual void | DrawTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl)
Draws the tab control.
virtual void | RepositionTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcClient)
Moves the tab buttons of the tab control to their correct positions.
virtual void | AdjustClientRect (CXTPTabManager *pTabManager, CRect &rcClient)
Adjusts the tab client rectangle.
virtual void | DrawWorkspacePart (CDC *pDC, LPRECT lpRect, XTPTabWorkspacePart workspacePart)
Draws a specified TabMDIClient TabWorkspace part.
virtual int | GetSupportedColorSets ()
Gets the supported color sets for this theme.
COLORREF | FillButton (CDC *pDC, CXTPTabManagerItem *pItem, LPPOINT pts, int nCount, XTPTabPosition tabPosition, BOOL bAbsolute=FALSE)
Draws a tab button within a specified polygon.
virtual void | DrawText (CDC *pDC, CXTPTabManager *pManager, const CString &str, LPRECT lpRect, UINT nFormat)
Draws the text of a specified item.

Protected Attributes

int | m_nGripperWidth
Size of the docking pane gripper.
- Protected Attributes inherited from CXTPTabPaintManagerTheme
int | m_nButtonHeight
Current tab button height (without margins).
CXTPTabPaintManager * | m_pPaintManager
Self paint manager pointer.
BOOL | m_bButtonsReverseZOrder
Draw buttons in right to left order.

Additional Inherited Members

- Public Attributes inherited from CXTPTabPaintManagerTheme
CRect | m_rcHeaderMargin
CRect struct containing the left, top, right, and bottom.
int | m_nRowMargin
margins of the tab header.

Detailed Description

Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines.

Member Function Documentation

◆ DrawSingleButton()

virtual void DrawSingleButton | ( | CDC * | pDC,
 |  | CXTPTabManagerItem * | pItem )
 virtual

This method is called to draw a single tab button in the tab client header area.

Parameters
pDC | Pointer to a valid device context.
pItem | Tab button to draw.

This method will draw a single tab button. This method only draws the button, no text or icon is added.

DrawSingleButton calls CXTPTabPaintManager::DrawSingleButtonIconAndText after the button is drawn. This is called to draw the button's icon and text.

See also
CXTPTabPaintManager::DrawTabControlEx, CXTPTabPaintManager::DrawSingleButtonIconAndText

Reimplemented from CXTPTabThemeFlat.

The documentation for this class was generated from the following file:
  • XTPDockingPanePanelTheme2012.h


Toolkit Pro: CXTPDockingPanePanelTheme2013 Class Reference

Public Member Functions | List of all members
CXTPDockingPanePanelTheme2013 Class Reference

Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines. More...

Inheritance diagram for CXTPDockingPanePanelTheme2013:
[legend]

Public Member Functions

CXTPDockingPanePanelTheme2013 ()
Default class constructor.
- Public Member Functions inherited from CXTPDockingPanePanelTheme2012
CXTPDockingPanePanelTheme2012 ()
Default class constructor.
virtual void | RefreshMetrics ()
This member function is used to initialize default colors for a theme from an .INI resource.
virtual void | DrawSingleButton (CDC *pDC, CXTPTabManagerItem *pItem)
This method is called to draw a single tab button in the tab client header area.
- Public Member Functions inherited from CXTPTabThemeFlat
CXTPTabThemeFlat ()
Constructs a CXTPTabThemeFlat object.
virtual CRect | FillTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl)
Fills both the tab header and the tab client area and then draws the tab client frame.
virtual XTPTabColorStyle | GetDefaultColorSet ()
Gets the default value of the color set for this theme.
- Public Member Functions inherited from CXTPTabPaintManagerTheme
CXTPTabPaintManagerTheme ()
Constructs a CXTPTabPaintManagerTheme object.
virtual | ~CXTPTabPaintManagerTheme ()
Destroys a CXTPTabPaintManagerTheme object, handles cleanup and deallocation.
CXTPTabPaintManagerColorSet * | GetColorSet () const
Gets the color set.
virtual CRect | GetHeaderRect (CRect rcControl, CXTPTabManager *pTabManager)
Gets the bounding rectangle of the tab header area.
virtual CRect | GetHeaderClipBox (CDC *pDC, CXTPTabManager *pTabManager)
Gets the clip box of the tab header area.
int | GetHeaderHeight (CXTPTabManager *pTabManager)
Gets the height of the tab header area.
virtual CRect | GetClientRect (CRect rcControl, CXTPTabManager *pTabManager)
Gets the bounding rectangle of the tab client area.
virtual CRect | GetHeaderMargin ()
Gets the top, left, right, and bottom margins of the tab header.
virtual CRect | GetClientMargin ()
Gets the top, left, right, and bottom margins of the tab client area.
virtual int | GetButtonLength (CDC *pDC, CXTPTabManagerItem *pItem)
Retrieves the total length of a specified tab button including the left and right button margins.
virtual int | GetButtonHeight (const CXTPTabManager *pTabManager)
Retrieves the total height of the tab buttons within a specified tab manager including the top and bottom margins and the icon.
virtual CRect | GetButtonDrawRect (const CXTPTabManagerItem *pItem)
Retrieves the bounding rectangle of a specified drawing item.
virtual void | DrawTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl)
Draws the tab control.
virtual void | RepositionTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcClient)
Moves the tab buttons of the tab control to their correct positions.
virtual void | AdjustClientRect (CXTPTabManager *pTabManager, CRect &rcClient)
Adjusts the tab client rectangle.
virtual void | DrawWorkspacePart (CDC *pDC, LPRECT lpRect, XTPTabWorkspacePart workspacePart)
Draws a specified TabMDIClient TabWorkspace part.
virtual int | GetSupportedColorSets ()
Gets the supported color sets for this theme.
COLORREF | FillButton (CDC *pDC, CXTPTabManagerItem *pItem, LPPOINT pts, int nCount, XTPTabPosition tabPosition, BOOL bAbsolute=FALSE)
Draws a tab button within a specified polygon.
virtual void | DrawText (CDC *pDC, CXTPTabManager *pManager, const CString &str, LPRECT lpRect, UINT nFormat)
Draws the text of a specified item.

Additional Inherited Members

- Public Attributes inherited from CXTPTabPaintManagerTheme
CRect | m_rcHeaderMargin
CRect struct containing the left, top, right, and bottom.
int | m_nRowMargin
margins of the tab header.
- Protected Attributes inherited from CXTPDockingPanePanelTheme2012
int | m_nGripperWidth
Size of the docking pane gripper.
- Protected Attributes inherited from CXTPTabPaintManagerTheme
int | m_nButtonHeight
Current tab button height (without margins).
CXTPTabPaintManager * | m_pPaintManager
Self paint manager pointer.
BOOL | m_bButtonsReverseZOrder
Draw buttons in right to left order.

Detailed Description

Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines.

The documentation for this class was generated from the following file:
  • XTPDockingPanePanelTheme2013.h


Toolkit Pro: CXTPDockingPanePanelTheme2015 Class Reference

Public Member Functions | List of all members
CXTPDockingPanePanelTheme2015 Class Reference

Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines. More...

Inheritance diagram for CXTPDockingPanePanelTheme2015:
[legend]

Public Member Functions

CXTPDockingPanePanelTheme2015 ()
Default class constructor.
- Public Member Functions inherited from CXTPDockingPanePanelTheme2012
CXTPDockingPanePanelTheme2012 ()
Default class constructor.
virtual void | RefreshMetrics ()
This member function is used to initialize default colors for a theme from an .INI resource.
virtual void | DrawSingleButton (CDC *pDC, CXTPTabManagerItem *pItem)
This method is called to draw a single tab button in the tab client header area.
- Public Member Functions inherited from CXTPTabThemeFlat
CXTPTabThemeFlat ()
Constructs a CXTPTabThemeFlat object.
virtual CRect | FillTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl)
Fills both the tab header and the tab client area and then draws the tab client frame.
virtual XTPTabColorStyle | GetDefaultColorSet ()
Gets the default value of the color set for this theme.
- Public Member Functions inherited from CXTPTabPaintManagerTheme
CXTPTabPaintManagerTheme ()
Constructs a CXTPTabPaintManagerTheme object.
virtual | ~CXTPTabPaintManagerTheme ()
Destroys a CXTPTabPaintManagerTheme object, handles cleanup and deallocation.
CXTPTabPaintManagerColorSet * | GetColorSet () const
Gets the color set.
virtual CRect | GetHeaderRect (CRect rcControl, CXTPTabManager *pTabManager)
Gets the bounding rectangle of the tab header area.
virtual CRect | GetHeaderClipBox (CDC *pDC, CXTPTabManager *pTabManager)
Gets the clip box of the tab header area.
int | GetHeaderHeight (CXTPTabManager *pTabManager)
Gets the height of the tab header area.
virtual CRect | GetClientRect (CRect rcControl, CXTPTabManager *pTabManager)
Gets the bounding rectangle of the tab client area.
virtual CRect | GetHeaderMargin ()
Gets the top, left, right, and bottom margins of the tab header.
virtual CRect | GetClientMargin ()
Gets the top, left, right, and bottom margins of the tab client area.
virtual int | GetButtonLength (CDC *pDC, CXTPTabManagerItem *pItem)
Retrieves the total length of a specified tab button including the left and right button margins.
virtual int | GetButtonHeight (const CXTPTabManager *pTabManager)
Retrieves the total height of the tab buttons within a specified tab manager including the top and bottom margins and the icon.
virtual CRect | GetButtonDrawRect (const CXTPTabManagerItem *pItem)
Retrieves the bounding rectangle of a specified drawing item.
virtual void | DrawTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl)
Draws the tab control.
virtual void | RepositionTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcClient)
Moves the tab buttons of the tab control to their correct positions.
virtual void | AdjustClientRect (CXTPTabManager *pTabManager, CRect &rcClient)
Adjusts the tab client rectangle.
virtual void | DrawWorkspacePart (CDC *pDC, LPRECT lpRect, XTPTabWorkspacePart workspacePart)
Draws a specified TabMDIClient TabWorkspace part.
virtual int | GetSupportedColorSets ()
Gets the supported color sets for this theme.
COLORREF | FillButton (CDC *pDC, CXTPTabManagerItem *pItem, LPPOINT pts, int nCount, XTPTabPosition tabPosition, BOOL bAbsolute=FALSE)
Draws a tab button within a specified polygon.
virtual void | DrawText (CDC *pDC, CXTPTabManager *pManager, const CString &str, LPRECT lpRect, UINT nFormat)
Draws the text of a specified item.

Additional Inherited Members

- Public Attributes inherited from CXTPTabPaintManagerTheme
CRect | m_rcHeaderMargin
CRect struct containing the left, top, right, and bottom.
int | m_nRowMargin
margins of the tab header.
- Protected Attributes inherited from CXTPDockingPanePanelTheme2012
int | m_nGripperWidth
Size of the docking pane gripper.
- Protected Attributes inherited from CXTPTabPaintManagerTheme
int | m_nButtonHeight
Current tab button height (without margins).
CXTPTabPaintManager * | m_pPaintManager
Self paint manager pointer.
BOOL | m_bButtonsReverseZOrder
Draw buttons in right to left order.

Detailed Description

Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines.

The documentation for this class was generated from the following file:
  • XTPDockingPanePanelTheme2015.h


Toolkit Pro: CXTPDockingPanePanelTheme2017 Class Reference

Public Member Functions | List of all members
CXTPDockingPanePanelTheme2017 Class Reference

Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines. More...

Inheritance diagram for CXTPDockingPanePanelTheme2017:
[legend]

Public Member Functions

CXTPDockingPanePanelTheme2017 ()
Default class constructor.
- Public Member Functions inherited from CXTPDockingPanePanelTheme2012
CXTPDockingPanePanelTheme2012 ()
Default class constructor.
virtual void | RefreshMetrics ()
This member function is used to initialize default colors for a theme from an .INI resource.
virtual void | DrawSingleButton (CDC *pDC, CXTPTabManagerItem *pItem)
This method is called to draw a single tab button in the tab client header area.
- Public Member Functions inherited from CXTPTabThemeFlat
CXTPTabThemeFlat ()
Constructs a CXTPTabThemeFlat object.
virtual CRect | FillTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl)
Fills both the tab header and the tab client area and then draws the tab client frame.
virtual XTPTabColorStyle | GetDefaultColorSet ()
Gets the default value of the color set for this theme.
- Public Member Functions inherited from CXTPTabPaintManagerTheme
CXTPTabPaintManagerTheme ()
Constructs a CXTPTabPaintManagerTheme object.
virtual | ~CXTPTabPaintManagerTheme ()
Destroys a CXTPTabPaintManagerTheme object, handles cleanup and deallocation.
CXTPTabPaintManagerColorSet * | GetColorSet () const
Gets the color set.
virtual CRect | GetHeaderRect (CRect rcControl, CXTPTabManager *pTabManager)
Gets the bounding rectangle of the tab header area.
virtual CRect | GetHeaderClipBox (CDC *pDC, CXTPTabManager *pTabManager)
Gets the clip box of the tab header area.
int | GetHeaderHeight (CXTPTabManager *pTabManager)
Gets the height of the tab header area.
virtual CRect | GetClientRect (CRect rcControl, CXTPTabManager *pTabManager)
Gets the bounding rectangle of the tab client area.
virtual CRect | GetHeaderMargin ()
Gets the top, left, right, and bottom margins of the tab header.
virtual CRect | GetClientMargin ()
Gets the top, left, right, and bottom margins of the tab client area.
virtual int | GetButtonLength (CDC *pDC, CXTPTabManagerItem *pItem)
Retrieves the total length of a specified tab button including the left and right button margins.
virtual int | GetButtonHeight (const CXTPTabManager *pTabManager)
Retrieves the total height of the tab buttons within a specified tab manager including the top and bottom margins and the icon.
virtual CRect | GetButtonDrawRect (const CXTPTabManagerItem *pItem)
Retrieves the bounding rectangle of a specified drawing item.
virtual void | DrawTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl)
Draws the tab control.
virtual void | RepositionTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcClient)
Moves the tab buttons of the tab control to their correct positions.
virtual void | AdjustClientRect (CXTPTabManager *pTabManager, CRect &rcClient)
Adjusts the tab client rectangle.
virtual void | DrawWorkspacePart (CDC *pDC, LPRECT lpRect, XTPTabWorkspacePart workspacePart)
Draws a specified TabMDIClient TabWorkspace part.
virtual int | GetSupportedColorSets ()
Gets the supported color sets for this theme.
COLORREF | FillButton (CDC *pDC, CXTPTabManagerItem *pItem, LPPOINT pts, int nCount, XTPTabPosition tabPosition, BOOL bAbsolute=FALSE)
Draws a tab button within a specified polygon.
virtual void | DrawText (CDC *pDC, CXTPTabManager *pManager, const CString &str, LPRECT lpRect, UINT nFormat)
Draws the text of a specified item.

Additional Inherited Members

- Public Attributes inherited from CXTPTabPaintManagerTheme
CRect | m_rcHeaderMargin
CRect struct containing the left, top, right, and bottom.
int | m_nRowMargin
margins of the tab header.
- Protected Attributes inherited from CXTPDockingPanePanelTheme2012
int | m_nGripperWidth
Size of the docking pane gripper.
- Protected Attributes inherited from CXTPTabPaintManagerTheme
int | m_nButtonHeight
Current tab button height (without margins).
CXTPTabPaintManager * | m_pPaintManager
Self paint manager pointer.
BOOL | m_bButtonsReverseZOrder
Draw buttons in right to left order.

Detailed Description

Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines.

The documentation for this class was generated from the following file:
  • XTPDockingPanePanelTheme2017.h


Toolkit Pro: CXTPDockingPanePanelTheme2019 Class Reference

Public Member Functions | List of all members
CXTPDockingPanePanelTheme2019 Class Reference

Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines. More...

Inheritance diagram for CXTPDockingPanePanelTheme2019:
[legend]

Public Member Functions

CXTPDockingPanePanelTheme2019 ()
Default class constructor.
- Public Member Functions inherited from CXTPDockingPanePanelTheme2012
CXTPDockingPanePanelTheme2012 ()
Default class constructor.
virtual void | RefreshMetrics ()
This member function is used to initialize default colors for a theme from an .INI resource.
virtual void | DrawSingleButton (CDC *pDC, CXTPTabManagerItem *pItem)
This method is called to draw a single tab button in the tab client header area.
- Public Member Functions inherited from CXTPTabThemeFlat
CXTPTabThemeFlat ()
Constructs a CXTPTabThemeFlat object.
virtual CRect | FillTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl)
Fills both the tab header and the tab client area and then draws the tab client frame.
virtual XTPTabColorStyle | GetDefaultColorSet ()
Gets the default value of the color set for this theme.
- Public Member Functions inherited from CXTPTabPaintManagerTheme
CXTPTabPaintManagerTheme ()
Constructs a CXTPTabPaintManagerTheme object.
virtual | ~CXTPTabPaintManagerTheme ()
Destroys a CXTPTabPaintManagerTheme object, handles cleanup and deallocation.
CXTPTabPaintManagerColorSet * | GetColorSet () const
Gets the color set.
virtual CRect | GetHeaderRect (CRect rcControl, CXTPTabManager *pTabManager)
Gets the bounding rectangle of the tab header area.
virtual CRect | GetHeaderClipBox (CDC *pDC, CXTPTabManager *pTabManager)
Gets the clip box of the tab header area.
int | GetHeaderHeight (CXTPTabManager *pTabManager)
Gets the height of the tab header area.
virtual CRect | GetClientRect (CRect rcControl, CXTPTabManager *pTabManager)
Gets the bounding rectangle of the tab client area.
virtual CRect | GetHeaderMargin ()
Gets the top, left, right, and bottom margins of the tab header.
virtual CRect | GetClientMargin ()
Gets the top, left, right, and bottom margins of the tab client area.
virtual int | GetButtonLength (CDC *pDC, CXTPTabManagerItem *pItem)
Retrieves the total length of a specified tab button including the left and right button margins.
virtual int | GetButtonHeight (const CXTPTabManager *pTabManager)
Retrieves the total height of the tab buttons within a specified tab manager including the top and bottom margins and the icon.
virtual CRect | GetButtonDrawRect (const CXTPTabManagerItem *pItem)
Retrieves the bounding rectangle of a specified drawing item.
virtual void | DrawTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl)
Draws the tab control.
virtual void | RepositionTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcClient)
Moves the tab buttons of the tab control to their correct positions.
virtual void | AdjustClientRect (CXTPTabManager *pTabManager, CRect &rcClient)
Adjusts the tab client rectangle.
virtual void | DrawWorkspacePart (CDC *pDC, LPRECT lpRect, XTPTabWorkspacePart workspacePart)
Draws a specified TabMDIClient TabWorkspace part.
virtual int | GetSupportedColorSets ()
Gets the supported color sets for this theme.
COLORREF | FillButton (CDC *pDC, CXTPTabManagerItem *pItem, LPPOINT pts, int nCount, XTPTabPosition tabPosition, BOOL bAbsolute=FALSE)
Draws a tab button within a specified polygon.
virtual void | DrawText (CDC *pDC, CXTPTabManager *pManager, const CString &str, LPRECT lpRect, UINT nFormat)
Draws the text of a specified item.

Additional Inherited Members

- Public Attributes inherited from CXTPTabPaintManagerTheme
CRect | m_rcHeaderMargin
CRect struct containing the left, top, right, and bottom.
int | m_nRowMargin
margins of the tab header.
- Protected Attributes inherited from CXTPDockingPanePanelTheme2012
int | m_nGripperWidth
Size of the docking pane gripper.
- Protected Attributes inherited from CXTPTabPaintManagerTheme
int | m_nButtonHeight
Current tab button height (without margins).
CXTPTabPaintManager * | m_pPaintManager
Self paint manager pointer.
BOOL | m_bButtonsReverseZOrder
Draw buttons in right to left order.

Detailed Description

Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines.

The documentation for this class was generated from the following file:
  • XTPDockingPanePanelTheme2019.h


Toolkit Pro: CXTPDockingPanePanelTheme2022 Class Reference

Public Member Functions | List of all members
CXTPDockingPanePanelTheme2022 Class Reference

Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines. More...

Inheritance diagram for CXTPDockingPanePanelTheme2022:
[legend]

Public Member Functions

CXTPDockingPanePanelTheme2022 ()
Default class constructor.
- Public Member Functions inherited from CXTPDockingPanePanelTheme2012
CXTPDockingPanePanelTheme2012 ()
Default class constructor.
virtual void | RefreshMetrics ()
This member function is used to initialize default colors for a theme from an .INI resource.
virtual void | DrawSingleButton (CDC *pDC, CXTPTabManagerItem *pItem)
This method is called to draw a single tab button in the tab client header area.
- Public Member Functions inherited from CXTPTabThemeFlat
CXTPTabThemeFlat ()
Constructs a CXTPTabThemeFlat object.
virtual CRect | FillTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl)
Fills both the tab header and the tab client area and then draws the tab client frame.
virtual XTPTabColorStyle | GetDefaultColorSet ()
Gets the default value of the color set for this theme.
- Public Member Functions inherited from CXTPTabPaintManagerTheme
CXTPTabPaintManagerTheme ()
Constructs a CXTPTabPaintManagerTheme object.
virtual | ~CXTPTabPaintManagerTheme ()
Destroys a CXTPTabPaintManagerTheme object, handles cleanup and deallocation.
CXTPTabPaintManagerColorSet * | GetColorSet () const
Gets the color set.
virtual CRect | GetHeaderRect (CRect rcControl, CXTPTabManager *pTabManager)
Gets the bounding rectangle of the tab header area.
virtual CRect | GetHeaderClipBox (CDC *pDC, CXTPTabManager *pTabManager)
Gets the clip box of the tab header area.
int | GetHeaderHeight (CXTPTabManager *pTabManager)
Gets the height of the tab header area.
virtual CRect | GetClientRect (CRect rcControl, CXTPTabManager *pTabManager)
Gets the bounding rectangle of the tab client area.
virtual CRect | GetHeaderMargin ()
Gets the top, left, right, and bottom margins of the tab header.
virtual CRect | GetClientMargin ()
Gets the top, left, right, and bottom margins of the tab client area.
virtual int | GetButtonLength (CDC *pDC, CXTPTabManagerItem *pItem)
Retrieves the total length of a specified tab button including the left and right button margins.
virtual int | GetButtonHeight (const CXTPTabManager *pTabManager)
Retrieves the total height of the tab buttons within a specified tab manager including the top and bottom margins and the icon.
virtual CRect | GetButtonDrawRect (const CXTPTabManagerItem *pItem)
Retrieves the bounding rectangle of a specified drawing item.
virtual void | DrawTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl)
Draws the tab control.
virtual void | RepositionTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcClient)
Moves the tab buttons of the tab control to their correct positions.
virtual void | AdjustClientRect (CXTPTabManager *pTabManager, CRect &rcClient)
Adjusts the tab client rectangle.
virtual void | DrawWorkspacePart (CDC *pDC, LPRECT lpRect, XTPTabWorkspacePart workspacePart)
Draws a specified TabMDIClient TabWorkspace part.
virtual int | GetSupportedColorSets ()
Gets the supported color sets for this theme.
COLORREF | FillButton (CDC *pDC, CXTPTabManagerItem *pItem, LPPOINT pts, int nCount, XTPTabPosition tabPosition, BOOL bAbsolute=FALSE)
Draws a tab button within a specified polygon.
virtual void | DrawText (CDC *pDC, CXTPTabManager *pManager, const CString &str, LPRECT lpRect, UINT nFormat)
Draws the text of a specified item.

Additional Inherited Members

- Public Attributes inherited from CXTPTabPaintManagerTheme
CRect | m_rcHeaderMargin
CRect struct containing the left, top, right, and bottom.
int | m_nRowMargin
margins of the tab header.
- Protected Attributes inherited from CXTPDockingPanePanelTheme2012
int | m_nGripperWidth
Size of the docking pane gripper.
- Protected Attributes inherited from CXTPTabPaintManagerTheme
int | m_nButtonHeight
Current tab button height (without margins).
CXTPTabPaintManager * | m_pPaintManager
Self paint manager pointer.
BOOL | m_bButtonsReverseZOrder
Draw buttons in right to left order.

Detailed Description

Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines.

The documentation for this class was generated from the following file:
  • XTPDockingPanePanelTheme2022.h


Toolkit Pro: CXTPDockingPanePanelThemeNativeWindows10 Class Reference

Public Member Functions | List of all members
CXTPDockingPanePanelThemeNativeWindows10 Class Reference

Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines. More...

Inheritance diagram for CXTPDockingPanePanelThemeNativeWindows10:
[legend]

Public Member Functions

CXTPDockingPanePanelThemeNativeWindows10 ()
Default class constructor.
- Public Member Functions inherited from CXTPDockingPanePanelTheme2012
CXTPDockingPanePanelTheme2012 ()
Default class constructor.
virtual void | RefreshMetrics ()
This member function is used to initialize default colors for a theme from an .INI resource.
virtual void | DrawSingleButton (CDC *pDC, CXTPTabManagerItem *pItem)
This method is called to draw a single tab button in the tab client header area.
- Public Member Functions inherited from CXTPTabThemeFlat
CXTPTabThemeFlat ()
Constructs a CXTPTabThemeFlat object.
virtual CRect | FillTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl)
Fills both the tab header and the tab client area and then draws the tab client frame.
virtual XTPTabColorStyle | GetDefaultColorSet ()
Gets the default value of the color set for this theme.
- Public Member Functions inherited from CXTPTabPaintManagerTheme
CXTPTabPaintManagerTheme ()
Constructs a CXTPTabPaintManagerTheme object.
virtual | ~CXTPTabPaintManagerTheme ()
Destroys a CXTPTabPaintManagerTheme object, handles cleanup and deallocation.
CXTPTabPaintManagerColorSet * | GetColorSet () const
Gets the color set.
virtual CRect | GetHeaderRect (CRect rcControl, CXTPTabManager *pTabManager)
Gets the bounding rectangle of the tab header area.
virtual CRect | GetHeaderClipBox (CDC *pDC, CXTPTabManager *pTabManager)
Gets the clip box of the tab header area.
int | GetHeaderHeight (CXTPTabManager *pTabManager)
Gets the height of the tab header area.
virtual CRect | GetClientRect (CRect rcControl, CXTPTabManager *pTabManager)
Gets the bounding rectangle of the tab client area.
virtual CRect | GetHeaderMargin ()
Gets the top, left, right, and bottom margins of the tab header.
virtual CRect | GetClientMargin ()
Gets the top, left, right, and bottom margins of the tab client area.
virtual int | GetButtonLength (CDC *pDC, CXTPTabManagerItem *pItem)
Retrieves the total length of a specified tab button including the left and right button margins.
virtual int | GetButtonHeight (const CXTPTabManager *pTabManager)
Retrieves the total height of the tab buttons within a specified tab manager including the top and bottom margins and the icon.
virtual CRect | GetButtonDrawRect (const CXTPTabManagerItem *pItem)
Retrieves the bounding rectangle of a specified drawing item.
virtual void | DrawTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl)
Draws the tab control.
virtual void | RepositionTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcClient)
Moves the tab buttons of the tab control to their correct positions.
virtual void | AdjustClientRect (CXTPTabManager *pTabManager, CRect &rcClient)
Adjusts the tab client rectangle.
virtual void | DrawWorkspacePart (CDC *pDC, LPRECT lpRect, XTPTabWorkspacePart workspacePart)
Draws a specified TabMDIClient TabWorkspace part.
virtual int | GetSupportedColorSets ()
Gets the supported color sets for this theme.
COLORREF | FillButton (CDC *pDC, CXTPTabManagerItem *pItem, LPPOINT pts, int nCount, XTPTabPosition tabPosition, BOOL bAbsolute=FALSE)
Draws a tab button within a specified polygon.
virtual void | DrawText (CDC *pDC, CXTPTabManager *pManager, const CString &str, LPRECT lpRect, UINT nFormat)
Draws the text of a specified item.

Additional Inherited Members

- Public Attributes inherited from CXTPTabPaintManagerTheme
CRect | m_rcHeaderMargin
CRect struct containing the left, top, right, and bottom.
int | m_nRowMargin
margins of the tab header.
- Protected Attributes inherited from CXTPDockingPanePanelTheme2012
int | m_nGripperWidth
Size of the docking pane gripper.
- Protected Attributes inherited from CXTPTabPaintManagerTheme
int | m_nButtonHeight
Current tab button height (without margins).
CXTPTabPaintManager * | m_pPaintManager
Self paint manager pointer.
BOOL | m_bButtonsReverseZOrder
Draw buttons in right to left order.

Detailed Description

Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines.

The documentation for this class was generated from the following file:
  • XTPDockingPanePanelThemeNativeWindows10.h


Toolkit Pro: CXTPDockingPanePanelThemeNativeWindows11 Class Reference

Public Member Functions | List of all members
CXTPDockingPanePanelThemeNativeWindows11 Class Reference

Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines. More...

Inheritance diagram for CXTPDockingPanePanelThemeNativeWindows11:
[legend]

Public Member Functions

CXTPDockingPanePanelThemeNativeWindows11 ()
Default class constructor.
- Public Member Functions inherited from CXTPDockingPanePanelTheme2012
CXTPDockingPanePanelTheme2012 ()
Default class constructor.
virtual void | RefreshMetrics ()
This member function is used to initialize default colors for a theme from an .INI resource.
virtual void | DrawSingleButton (CDC *pDC, CXTPTabManagerItem *pItem)
This method is called to draw a single tab button in the tab client header area.
- Public Member Functions inherited from CXTPTabThemeFlat
CXTPTabThemeFlat ()
Constructs a CXTPTabThemeFlat object.
virtual CRect | FillTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl)
Fills both the tab header and the tab client area and then draws the tab client frame.
virtual XTPTabColorStyle | GetDefaultColorSet ()
Gets the default value of the color set for this theme.
- Public Member Functions inherited from CXTPTabPaintManagerTheme
CXTPTabPaintManagerTheme ()
Constructs a CXTPTabPaintManagerTheme object.
virtual | ~CXTPTabPaintManagerTheme ()
Destroys a CXTPTabPaintManagerTheme object, handles cleanup and deallocation.
CXTPTabPaintManagerColorSet * | GetColorSet () const
Gets the color set.
virtual CRect | GetHeaderRect (CRect rcControl, CXTPTabManager *pTabManager)
Gets the bounding rectangle of the tab header area.
virtual CRect | GetHeaderClipBox (CDC *pDC, CXTPTabManager *pTabManager)
Gets the clip box of the tab header area.
int | GetHeaderHeight (CXTPTabManager *pTabManager)
Gets the height of the tab header area.
virtual CRect | GetClientRect (CRect rcControl, CXTPTabManager *pTabManager)
Gets the bounding rectangle of the tab client area.
virtual CRect | GetHeaderMargin ()
Gets the top, left, right, and bottom margins of the tab header.
virtual CRect | GetClientMargin ()
Gets the top, left, right, and bottom margins of the tab client area.
virtual int | GetButtonLength (CDC *pDC, CXTPTabManagerItem *pItem)
Retrieves the total length of a specified tab button including the left and right button margins.
virtual int | GetButtonHeight (const CXTPTabManager *pTabManager)
Retrieves the total height of the tab buttons within a specified tab manager including the top and bottom margins and the icon.
virtual CRect | GetButtonDrawRect (const CXTPTabManagerItem *pItem)
Retrieves the bounding rectangle of a specified drawing item.
virtual void | DrawTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl)
Draws the tab control.
virtual void | RepositionTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcClient)
Moves the tab buttons of the tab control to their correct positions.
virtual void | AdjustClientRect (CXTPTabManager *pTabManager, CRect &rcClient)
Adjusts the tab client rectangle.
virtual void | DrawWorkspacePart (CDC *pDC, LPRECT lpRect, XTPTabWorkspacePart workspacePart)
Draws a specified TabMDIClient TabWorkspace part.
virtual int | GetSupportedColorSets ()
Gets the supported color sets for this theme.
COLORREF | FillButton (CDC *pDC, CXTPTabManagerItem *pItem, LPPOINT pts, int nCount, XTPTabPosition tabPosition, BOOL bAbsolute=FALSE)
Draws a tab button within a specified polygon.
virtual void | DrawText (CDC *pDC, CXTPTabManager *pManager, const CString &str, LPRECT lpRect, UINT nFormat)
Draws the text of a specified item.

Additional Inherited Members

- Public Attributes inherited from CXTPTabPaintManagerTheme
CRect | m_rcHeaderMargin
CRect struct containing the left, top, right, and bottom.
int | m_nRowMargin
margins of the tab header.
- Protected Attributes inherited from CXTPDockingPanePanelTheme2012
int | m_nGripperWidth
Size of the docking pane gripper.
- Protected Attributes inherited from CXTPTabPaintManagerTheme
int | m_nButtonHeight
Current tab button height (without margins).
CXTPTabPaintManager * | m_pPaintManager
Self paint manager pointer.
BOOL | m_bButtonsReverseZOrder
Draw buttons in right to left order.

Detailed Description

Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines.

The documentation for this class was generated from the following file:
  • XTPDockingPanePanelThemeNativeWindows11.h


Toolkit Pro: CXTPDockingPaneSidePanel Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPDockingPaneSidePanel Class Reference

CXTPDockingPaneSidePanel is a multiple inheritance class derived from CWnd and CXTPDockingPaneBase. More...

Inheritance diagram for CXTPDockingPaneSidePanel:
[legend]

Public Member Functions

CXTPDockingPaneTabbedContainer * | GetTopContainer () const
Retrieves a CXTPDockingPaneTabbedContainer object that points to the parent container for this container.
XTPDockingPaneDirection | GetDirection () const
Call this member function to determine the direction of the auto-hide panel.
BOOL | IsActive () const
Call this member function to determine if a child pane is active.
CString | GetTitle () const
Call this member to get the title of the pane.
CXTPDockingPane * | GetSelectedPane () const
Call this member to determine the currently selected pane in the side panel.
void | Collapse (BOOL bDelay=FALSE)
This method is called to collapse the frame.
BOOL | IsCollapsed () const
Determines if the frame is collapsed.
void | Expand ()
Call this method to expand a collapsed frame.
void | MovePanel (XTPDockingPaneDirection direction, CRect rect)
Moves the side panel to the desired location.
virtual BOOL | IsCaptionVertical () const
Determines if the caption is drawn vertically.
- Public Member Functions inherited from CXTPDockingPaneBaseContainer
virtual POSITION | ContainPane (CXTPDockingPaneBase *pPane) const
Call this member to determine if one pane is contained in the collection of another.
virtual void | FindPane (XTPDockingPaneType type, CXTPDockingPaneBaseList *pList) const
Call this member to find all panes of a specific XTPDockingPaneType within the container.
POSITION | GetHeadPosition () const
This method retrieves the position of the first pane of this container.
CXTPDockingPaneBase * | GetNext (POSITION &pos) const
Gets the pane element identified by rPosition, then sets rPosition to the POSITION value of the next entry in the container.
CXTPDockingPaneBase * | GetFirstPane () const
This method retrieves the first pane in the container.
CXTPDockingPaneBase * | GetLastPane () const
This method retrieves the last pane in the container.
CXTPDockingPaneBaseList & GetPanes ()
Call this member to retrieve the collection of child panes.
BOOL | OnAction (XTPDockingPaneAction action)
This method is called if some action occurs.
- Public Member Functions inherited from CXTPDockingPaneBase
XTPDockingPaneType | GetType () const
Call this member to determine the type of the pane.
CRect | GetPaneWindowRect () const
The GetPaneWindowRect function retrieves the dimensions of the bounding rectangle of the pane.
CXTPDockingPaneBase * | GetContainer () const
Call this member function to retrieve the parent container of the pane.
CXTPDockingPaneManager * | GetDockingPaneManager () const
Call this member function to retrieve the pane manager.
CXTPDockingPanePaintManager * | GetPaintManager () const
Call this member function to retrieve the paint manager.
CXTPDockingPaneCaptionButton * | FindCaptionButton (int nID) const
Call this member to find the specified caption button.
CXTPDockingPaneCaptionButtons * | GetCaptionButtons () const
Call this member to get a reference to the caption's close/pop-up button.
virtual void | RedrawPane ()
Call this member to redraw the pane.
virtual CWnd * | GetDockingSite () const
Call this member function to retrieve the parent window for the pane.
virtual BOOL | IsHidden () const
Call this member to check if the pane is hidden.

Protected Member Functions

CXTPDockingPaneSidePanel (CXTPDockingPaneLayout *pLayout)
Constructs a CXTPDockingPaneAutoHidePanel object.
~CXTPDockingPaneSidePanel ()
Destroys a CXTPDockingPaneAutoHidePanel object, handles cleanup and deallocation.
BOOL | Init (CXTPDockingPaneBase *pPane, XTPDockingPaneDirection direction, CRect rc)
Constructs a CXTPDockingPaneSidePanel object.
BOOL | Create (CRect rc)
Creates a frame window.
void | Copy (CXTPDockingPaneBase *pClone, CXTPPaneToPaneMap *pMap, DWORD dwIgnoredOptions)
Copies a CXTPDockingPaneSidePanel object.
void | _InsertPane (CXTPDockingPaneBase *pPane)
Call this member to insert a pane into the collection.
void | GetMinMaxInfo (LPMINMAXINFO pMinMaxInfo) const
Call this member to fill the pMinMaxInfo structure with the minimum and maximum width and height of the splitter container.
BOOL | IsHorizontal () const
Call this member to determine if the side panel orientation is horizontal.
INT_PTR | OnToolHitTest (CPoint point, TOOLINFO *pTI) const
The framework calls this member function to determine whether a point is in the bounding rectangle of the specified tool.
virtual BOOL | DoPropExchange (CXTPPropExchange *pPX)
This member is called to save/restore the settings of the pane.
virtual void | InvalidatePane (BOOL bSelectionChanged)
This member is called when a pane must be redrawn.
HWND | GetPaneHwnd () const
Retrieves the window handle for a window.
void | DoSlideStep (BOOL bActivate=FALSE)
This method is called to animate a collapsed frame.
void | OnPinButtonClick ()
This member is called when the "pin" caption button is clicked.
- Protected Member Functions inherited from CXTPDockingPaneBaseContainer
CXTPDockingPaneBaseContainer (XTPDockingPaneType type, CXTPDockingPaneLayout *pLayout)
Protected constructor.
virtual | ~CXTPDockingPaneBaseContainer ()
Destroys a CXTPDockingPaneBase object, handles cleanup and deallocation.
virtual BOOL | IsEmpty () const
Call this member to determine if there are no children panes.
- Protected Member Functions inherited from CXTPDockingPaneBase
CXTPDockingPaneBase (XTPDockingPaneType type, CXTPDockingPaneLayout *pLayout)
Protected constructor.
virtual | ~CXTPDockingPaneBase ()
Destroys a CXTPDockingPaneBase object, handles cleanup and deallocation.
virtual void | OnSizeParent (CWnd *pParent, CRect rect, LPVOID lParam)
This method is called to set the position of the pane.
virtual void | OnFocusChanged ()
This method is called to update the state of the pane.
virtual void | SetDockingSite (CWnd *pFrame)
Call this member to set the parent frame of the pane.
virtual void | SetParentContainer (CXTPDockingPaneBase *pContainer)
Call this method to set the parent container of the pane.
virtual void | OnChildContainerChanged (CXTPDockingPaneBase *pContainer)
This member is called when a child pane collection is changed.
virtual void | OnParentContainerChanged (CXTPDockingPaneBase *pContainer)
This member is called when the parent pane collection is changed.
virtual CXTPDockingPaneBase * | Clone (CXTPDockingPaneLayout *pLayout, CXTPPaneToPaneMap *pMap, DWORD dwIgnoredOptions=0)
This member is called to clone the pane.
virtual void | RemovePane (CXTPDockingPaneBase *pPane)
Call this member to remove a pane from the collection.
virtual void | OnCaptionButtonRectChanged (CXTPDockingPaneCaptionButton *pButton)
This member is called when the dimensions of the caption button are changed.
virtual void | DeletePane ()=0
This method is called to destroy a pane.
virtual void | CreateContainer ()
This member is called to create a pane.

Protected Attributes

XTPDockingPaneDirection | m_direction
Location of side panel.
int | m_nStepsCount
Total steps of animation process.
int | m_nSlideStep
Current step of animation process.
int | m_nDeactivationCount
Deactivation counter.
BOOL | m_bCollapsed
Pane is collapsed.
BOOL | m_bExpanded
Pane is expanded.
BOOL | m_bSlideOut
Pane is currently expanding.
- Protected Attributes inherited from CXTPDockingPaneBaseContainer
CXTPDockingPaneBaseList | m_lstPanes
Child panes collection.
- Protected Attributes inherited from CXTPDockingPaneBase
CSize | m_szDocking
Size of the pane.
CXTPDockingPaneLayout * | m_pLayout
Parent layout.
CXTPDockingPaneBase * | m_pParentContainer
Parent container.
CWnd * | m_pDockingSite
Parent frame.
XTPDockingPaneType | m_type
Type of the pane.
CRect | m_rcWindow
Position of the pane.
CXTPDockingPaneCaptionButtons * | m_pCaptionButtons
Collection of caption buttons.

Detailed Description

CXTPDockingPaneSidePanel is a multiple inheritance class derived from CWnd and CXTPDockingPaneBase.

It is used internally as an auto-hide container for CXTPDockingPaneBase derived classes.

Constructor & Destructor Documentation

◆ CXTPDockingPaneSidePanel()

CXTPDockingPaneSidePanel ( CXTPDockingPaneLayout * pLayout )
protected

Constructs a CXTPDockingPaneAutoHidePanel object.

Protected constructor. Internally constructed only.

Parameters
pLayout Pointer to a CXTPDockingPaneLayout object.

Member Function Documentation

◆ _InsertPane()

void _InsertPane ( CXTPDockingPaneBase * pPane )
protected

Call this member to insert a pane into the collection.

Parameters
pPane Pointer to a CXTPDockingPaneBase object.

◆ Collapse()

void Collapse ( BOOL bDelay = FALSE )

This method is called to collapse the frame.

Parameters
bDelay TRUE to collapse the frame after a small delay with an animation.

◆ Copy()

void Copy | ( | CXTPDockingPaneBase * | pClone,
 |  | CXTPPaneToPaneMap * | pMap,
 |  | DWORD | dwIgnoredOptions )
 protectedvirtual

Copies a CXTPDockingPaneSidePanel object.

Parameters
pClone | Pointer to a CXTPDockingPaneSidePanel object.
pMap | Pointer to a CXTPPaneToPaneMap object.
dwIgnoredOptions | Options that must be skipped.
See also
CXTPPaneToPaneMap

Reimplemented from CXTPDockingPaneBase.

◆ Create()

BOOL Create ( CRect rc )
protected

Creates a frame window.

Parameters
rc Specifies the size and position of the window.
Returns
Nonzero if initialization was successful, otherwise 0.

◆ DoPropExchange()

virtual BOOL DoPropExchange ( CXTPPropExchange * pPX )
protectedvirtual

This member is called to save/restore the settings of the pane.

Parameters
pPX Pointer to a CXTPPropExchange object.
Returns
TRUE if successful, otherwise FALSE.

Reimplemented from CXTPDockingPaneBase.

◆ DoSlideStep()

void DoSlideStep ( BOOL bActivate = FALSE )
protected

This method is called to animate a collapsed frame.

Parameters
bActivate TRUE to activate the frame.

◆ GetDirection()

AFX_INLINE XTPDockingPaneDirection GetDirection ( ) const

Call this member function to determine the direction of the auto-hide panel.

Returns
The auto-hide panel's direction.

◆ GetMinMaxInfo()

void GetMinMaxInfo ( LPMINMAXINFO pMinMaxInfo ) const
protectedvirtual

Call this member to fill the pMinMaxInfo structure with the minimum and maximum width and height of the splitter container.

This will look at the MinMaxInfo for each pane in the splitter container and set the appropriate minimum and maximum width and height for the splitter container.

Parameters
pMinMaxInfo Pointer to a MINMAXINFO structure.

Reimplemented from CXTPDockingPaneBase.

◆ GetPaneHwnd()

AFX_INLINE HWND GetPaneHwnd ( ) const
protectedvirtual

Retrieves the window handle for a window.

Returns
The window handle for a window if successful. NULL if the HWND is not attached to a window or if it is used with a NULL HWND pointer.

Reimplemented from CXTPDockingPaneBase.

◆ GetSelectedPane()

CXTPDockingPane * GetSelectedPane ( ) const

Call this member to determine the currently selected pane in the side panel.

Returns
A pointer to the currently selected pane in the side panel.

◆ GetTitle()

CString GetTitle ( ) const
virtual

Call this member to get the title of the pane.

Returns
The title of the pane.

Reimplemented from CXTPDockingPaneBase.

◆ GetTopContainer()

CXTPDockingPaneTabbedContainer * GetTopContainer ( ) const

Retrieves a CXTPDockingPaneTabbedContainer object that points to the parent container for this container.

Returns
A CXTPDockingPaneTabbedContainer object that points to the parent container for this container.

◆ Init()

BOOL Init | ( | CXTPDockingPaneBase * | pPane,
 |  | XTPDockingPaneDirection | direction,
 |  | CRect | rc )
 protected

Constructs a CXTPDockingPaneSidePanel object.

Protected constructor. Internally constructed only.

Parameters
pPane | Child pane.
direction | Direction to dock.
rc | Position of the side panel.
Returns
TRUE if successful, otherwise FALSE.

◆ InvalidatePane()

virtual void InvalidatePane ( BOOL bSelectionChanged )
protectedvirtual

This member is called when a pane must be redrawn.

Parameters
bSelectionChanged TRUE if the selected pane was changed.

Reimplemented from CXTPDockingPaneBase.

◆ IsActive()

AFX_INLINE BOOL IsActive ( ) const
virtual

Call this member function to determine if a child pane is active.

Returns
TRUE if a child pane is active.

Reimplemented from CXTPDockingPaneBase.

◆ IsCaptionVertical()

virtual BOOL IsCaptionVertical ( ) const
virtual

Determines if the caption is drawn vertically.

Returns
TRUE if the caption is drawn vertically.

Reimplemented from CXTPDockingPaneBase.

◆ IsCollapsed()

BOOL IsCollapsed ( ) const

Determines if the frame is collapsed.

Returns
TRUE if the frame is collapsed, FALSE if the frame is visible.

◆ IsHorizontal()

BOOL IsHorizontal ( ) const
protected

Call this member to determine if the side panel orientation is horizontal.

Returns
TRUE if the side panel orientation is horizontal, otherwise FALSE.

◆ MovePanel()

void MovePanel | ( | XTPDockingPaneDirection | direction,
 |  | CRect | rect )

Moves the side panel to the desired location.

Parameters
direction | The panel's direction.
rect | Position of the side panel.

◆ OnToolHitTest()

INT_PTR OnToolHitTest | ( | CPoint | point,
 |  | TOOLINFO * | pTI ) const
 protected

The framework calls this member function to determine whether a point is in the bounding rectangle of the specified tool.

Parameters
point | Specifies the x- and y- coordinates of the cursor. These coordinates are always relative to the upper-left corner of the window.
pTI | A pointer to a TOOLINFO structure.
Returns
If the tooltip control was found, then the window control ID is returned. If the tooltip control was not found, then a value of -1 is returned.
The documentation for this class was generated from the following file:
  • XTPDockingPaneSidePanel.h


Toolkit Pro: CXTPDockingPaneSplitterContainer Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPDockingPaneSplitterContainer Class Reference

CXTPDockingPaneSplitterContainer is a CXTPDockingPaneBase derived class. More...

Inheritance diagram for CXTPDockingPaneSplitterContainer:
[legend]

Public Member Functions

virtual void | OnSizeParent (CWnd *pParent, CRect rect, LPVOID lParam)
This method is called to set the position of the pane.
void | FindChildPane (XTPDockingPaneType type, CXTPDockingPaneBaseList *pList) const
Call this member to retrieve a collection of the panes with a specified type within the splitter container's child panes.
BOOL | IsHoriz () const
Call this member to determine if the splitter orientation is horizontal.
void | GetMinMaxInfo (LPMINMAXINFO pMinMaxInfo) const
Call this member to fill the pMinMaxInfo structure with the minimum and maximum width and height of the splitter container.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.
- Public Member Functions inherited from CXTPDockingPaneBaseContainer
virtual POSITION | ContainPane (CXTPDockingPaneBase *pPane) const
Call this member to determine if one pane is contained in the collection of another.
virtual void | FindPane (XTPDockingPaneType type, CXTPDockingPaneBaseList *pList) const
Call this member to find all panes of a specific XTPDockingPaneType within the container.
POSITION | GetHeadPosition () const
This method retrieves the position of the first pane of this container.
CXTPDockingPaneBase * | GetNext (POSITION &pos) const
Gets the pane element identified by rPosition, then sets rPosition to the POSITION value of the next entry in the container.
CXTPDockingPaneBase * | GetFirstPane () const
This method retrieves the first pane in the container.
CXTPDockingPaneBase * | GetLastPane () const
This method retrieves the last pane in the container.
CXTPDockingPaneBaseList & GetPanes ()
Call this member to retrieve the collection of child panes.
BOOL | OnAction (XTPDockingPaneAction action)
This method is called if some action occurs.
- Public Member Functions inherited from CXTPDockingPaneBase
virtual BOOL | IsActive () const
Determines if the frame is active.
virtual BOOL | IsCaptionVertical () const
Determines if the caption is drawn vertically.
virtual CString | GetTitle () const
Call this member to get the text in the caption for the tabbed container (group of panes).
XTPDockingPaneType | GetType () const
Call this member to determine the type of the pane.
CRect | GetPaneWindowRect () const
The GetPaneWindowRect function retrieves the dimensions of the bounding rectangle of the pane.
CXTPDockingPaneBase * | GetContainer () const
Call this member function to retrieve the parent container of the pane.
CXTPDockingPaneManager * | GetDockingPaneManager () const
Call this member function to retrieve the pane manager.
CXTPDockingPanePaintManager * | GetPaintManager () const
Call this member function to retrieve the paint manager.
CXTPDockingPaneCaptionButton * | FindCaptionButton (int nID) const
Call this member to find the specified caption button.
CXTPDockingPaneCaptionButtons * | GetCaptionButtons () const
Call this member to get a reference to the caption's close/pop-up button.
virtual void | RedrawPane ()
Call this member to redraw the pane.
virtual CWnd * | GetDockingSite () const
Call this member function to retrieve the parent window for the pane.
virtual BOOL | IsHidden () const
Call this member to check if the pane is hidden.
virtual HWND | GetPaneHwnd () const
Retrieves the window handle for a window.
virtual void | InvalidatePane (BOOL bSelectionChanged)
This member is called when a pane must be redrawn.

Protected Member Functions

CXTPDockingPaneSplitterContainer (CXTPDockingPaneLayout *pLayout)
Constructs a CXTPDockingPaneSplitterContainer object.
virtual | ~CXTPDockingPaneSplitterContainer ()
Destroys a CXTPDockingPaneSplitterContainer object, handles cleanup and deallocation.
void | Init (CXTPDockingPaneBase *pPane, BOOL bHoriz, CWnd *pFrame)
Constructs a CXTPDockingPaneSplitterContainer object Protected constructor.
void | Copy (CXTPDockingPaneBase *pClone, CXTPPaneToPaneMap *pMap, DWORD dwIgnoredOptions)
Copies a CXTPDockingPaneSplitterContainer object.
virtual CXTPDockingPaneSplitterWnd * | OnCreateSplitter ()
This member is called by the framework when a splitter container is created.
virtual void | RemovePane (CXTPDockingPaneBase *pPane)
This member is called to remove a pane from the collection.
virtual void | OnChildContainerChanged (CXTPDockingPaneBase *pContainer)
This member is called when a child pane collection is changed.
virtual void | OnParentContainerChanged (CXTPDockingPaneBase *pContainer)
This member is called when the parent pane collection is changed.
virtual BOOL | DoPropExchange (CXTPPropExchange *pPX)
This member is called to save/restore the settings of the pane.
void | NormalizeDockingSize ()
This member is called to normalize the size of docking panes in the splitter container.
void | DeletePane ()
This method is called to the destroy the pane.
- Protected Member Functions inherited from CXTPDockingPaneBaseContainer
CXTPDockingPaneBaseContainer (XTPDockingPaneType type, CXTPDockingPaneLayout *pLayout)
Protected constructor.
virtual | ~CXTPDockingPaneBaseContainer ()
Destroys a CXTPDockingPaneBase object, handles cleanup and deallocation.
virtual BOOL | IsEmpty () const
Call this member to determine if there are no children panes.
- Protected Member Functions inherited from CXTPDockingPaneBase
CXTPDockingPaneBase (XTPDockingPaneType type, CXTPDockingPaneLayout *pLayout)
Protected constructor.
virtual | ~CXTPDockingPaneBase ()
Destroys a CXTPDockingPaneBase object, handles cleanup and deallocation.
virtual void | OnFocusChanged ()
This method is called to update the state of the pane.
virtual void | SetDockingSite (CWnd *pFrame)
Call this member to set the parent frame of the pane.
virtual void | SetParentContainer (CXTPDockingPaneBase *pContainer)
Call this method to set the parent container of the pane.
virtual CXTPDockingPaneBase * | Clone (CXTPDockingPaneLayout *pLayout, CXTPPaneToPaneMap *pMap, DWORD dwIgnoredOptions=0)
This member is called to clone the pane.
virtual void | OnCaptionButtonRectChanged (CXTPDockingPaneCaptionButton *pButton)
This member is called when the dimensions of the caption button are changed.
virtual BOOL | IsCaptionButtonVisible (CXTPDockingPaneCaptionButton *pButton)
Call this member to determine if a caption button is visible.
virtual void | CreateContainer ()
This member is called to create a pane.

Protected Attributes

CList< CXTPDockingPaneSplitterWnd *, CXTPDockingPaneSplitterWnd * > | m_lstSpliters
List of splitter windows.
BOOL | m_bHoriz
TRUE if the splitter orientation is horizontal.
BOOL | m_bRecalcLayout
TRUE if RecalcLayout method currently executed.
- Protected Attributes inherited from CXTPDockingPaneBaseContainer
CXTPDockingPaneBaseList | m_lstPanes
Child panes collection.
- Protected Attributes inherited from CXTPDockingPaneBase
CSize | m_szDocking
Size of the pane.
CXTPDockingPaneLayout * | m_pLayout
Parent layout.
CXTPDockingPaneBase * | m_pParentContainer
Parent container.
CWnd * | m_pDockingSite
Parent frame.
XTPDockingPaneType | m_type
Type of the pane.
CRect | m_rcWindow
Position of the pane.
CXTPDockingPaneCaptionButtons * | m_pCaptionButtons
Collection of caption buttons.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

CXTPDockingPaneSplitterContainer is a CXTPDockingPaneBase derived class.

It is used internally as a splitter container for CXTPDockingPaneBase derived classes.

Constructor & Destructor Documentation

◆ CXTPDockingPaneSplitterContainer()

CXTPDockingPaneSplitterContainer ( CXTPDockingPaneLayout * pLayout )
protected

Constructs a CXTPDockingPaneSplitterContainer object.

Parameters
pLayout Pointer to a CXTPDockingPaneLayout object.

Member Function Documentation

◆ Copy()

void Copy | ( | CXTPDockingPaneBase * | pClone,
 |  | CXTPPaneToPaneMap * | pMap,
 |  | DWORD | dwIgnoredOptions )
 protectedvirtual

Copies a CXTPDockingPaneSplitterContainer object.

Parameters
pClone | Pointer to a CXTPDockingPaneSplitterContainer object.
pMap | Pointer to a CXTPPaneToPaneMap object.
dwIgnoredOptions | Options that must be skipped.
See also
CXTPPaneToPaneMap

Reimplemented from CXTPDockingPaneBase.

◆ DoPropExchange()

virtual BOOL DoPropExchange ( CXTPPropExchange * pPX )
protectedvirtual

This member is called to save/restore the settings of the pane.

Parameters
pPX Pointer to a CXTPPropExchange object.
Returns
TRUE if successful, otherwise FALSE.

Reimplemented from CXTPDockingPaneBase.

◆ FindChildPane()

void FindChildPane | ( | XTPDockingPaneType | type,
 |  | CXTPDockingPaneBaseList * | pList ) const

Call this member to retrieve a collection of the panes with a specified type within the splitter container's child panes.

Parameters
type | Type of panes to find.
pList | Pointer to a CXTPDockingPaneBaseList object that will contain found panes.

◆ GetMinMaxInfo()

void GetMinMaxInfo ( LPMINMAXINFO pMinMaxInfo ) const
virtual

Call this member to fill the pMinMaxInfo structure with the minimum and maximum width and height of the splitter container.

This will look at the MinMaxInfo for each pane in the splitter container and set the appropriate minimum and maximum width and height for the splitter container.

Parameters
pMinMaxInfo Pointer to a MINMAXINFO structure.

Reimplemented from CXTPDockingPaneBase.

◆ Init()

void Init | ( | CXTPDockingPaneBase * | pPane,
 |  | BOOL | bHoriz,
 |  | CWnd * | pFrame )
 protected

Constructs a CXTPDockingPaneSplitterContainer object Protected constructor.

Internally constructed only.

Parameters
pPane | Child pane.
bHoriz | TRUE if the splitter orientation should be horizontal.
pFrame | Parent Frame.

◆ IsHoriz()

BOOL IsHoriz ( ) const
inline

Call this member to determine if the splitter orientation is horizontal.

Returns
TRUE if the splitter orientation is horizontal, otherwise FALSE.

◆ NormalizeDockingSize()

void NormalizeDockingSize ( )
protected

This member is called to normalize the size of docking panes in the splitter container.

Normalizing the size of the panes means that the value of the left coordinate is less than the right and the top is less than the bottom.

◆ OnChildContainerChanged()

virtual void OnChildContainerChanged ( CXTPDockingPaneBase * pContainer )
protectedvirtual

This member is called when a child pane collection is changed.

Parameters
pContainer Pointer to a CXTPDockingPaneBase object.

Reimplemented from CXTPDockingPaneBase.

◆ OnCreateSplitter()

virtual CXTPDockingPaneSplitterWnd * OnCreateSplitter ( )
protectedvirtual

This member is called by the framework when a splitter container is created.

Returns
A pointer to the newly created CXTPDockingPaneSplitterWnd object.

◆ OnParentContainerChanged()

virtual void OnParentContainerChanged ( CXTPDockingPaneBase * pContainer )
protectedvirtual

This member is called when the parent pane collection is changed.

Parameters
pContainer Pointer to a CXTPDockingPaneBase object.

Reimplemented from CXTPDockingPaneBase.

◆ OnSizeParent()

virtual void OnSizeParent | ( | CWnd * | pParent,
 |  | CRect | rect,
 |  | LPVOID | lParam )
 virtual

This method is called to set the position of the pane.

Parameters
pParent | Pointer to a CWnd object.
rect | Rectangle of the pane to be set.
lParam | Pointer to an AFX_SIZEPARENTPARAMS structure.

Reimplemented from CXTPDockingPaneBase.

◆ RemovePane()

virtual void RemovePane ( CXTPDockingPaneBase * pPane )
protectedvirtual

This member is called to remove a pane from the collection.

Parameters
pPane Pointer to a CXTPDockingPaneBase object.

Reimplemented from CXTPDockingPaneBase.

The documentation for this class was generated from the following file:
  • XTPDockingPaneSplitterContainer.h


Toolkit Pro: CXTPDockingPaneSplitterWnd Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPDockingPaneSplitterWnd Class Reference

CXTPDockingPaneSplitterWnd is a CWnd derived class. More...

Public Member Functions

BOOL | IsHorizontal () const
Determines if the splitter orientation is horizontal.
void | Create (CXTPDockingPaneSplitterContainer *pContainer, CXTPDockingPaneBase *pFirst, CXTPDockingPaneBase *pSecond)
Creates a CXTPDockingPaneSplitterWnd window.
void | Create (CXTPDockingPaneManager *pManager, BOOL bHoriz)
Creates a CXTPDockingPaneSplitterWnd window.
CXTPDockingPaneSplitterContainer * | GetContainer () const
Retrieves the associated splitter container of a splitter window.
CXTPDockingPaneManager * | GetDockingPaneManager () const
Retrieves a pointer to the docking pane manager.
CXTPDockingPaneBase * | GetPaneBase (BOOL bFirst=TRUE)
Call this member function to retrieve a pointer to the docking splitter base pane.
XTPDockingPaneDirection | GetPaneDirection () const
Call this member to determine the XTPDockingPaneDirection of the splitter.

Protected Member Functions

CXTPDockingPaneSplitterWnd ()
Constructs a CXTPDockingPaneSplitterWnd object.
~CXTPDockingPaneSplitterWnd ()
Destroys a CXTPDockingPaneSplitterWnd object, handles cleanup and deallocation.

Detailed Description

CXTPDockingPaneSplitterWnd is a CWnd derived class.

It is used internally for splitting Panes.

Member Function Documentation

◆ Create() [1/2]

void Create | ( | CXTPDockingPaneManager * | pManager,
 |  | BOOL | bHoriz )

Creates a CXTPDockingPaneSplitterWnd window.

Parameters
pManager | Pointer to a parent CXTPDockingPaneManager object.
bHoriz | TRUE if the splitter orientation should be horizontal.

◆ Create() [2/2]

void Create | ( | CXTPDockingPaneSplitterContainer * | pContainer,
 |  | CXTPDockingPaneBase * | pFirst,
 |  | CXTPDockingPaneBase * | pSecond )

Creates a CXTPDockingPaneSplitterWnd window.

Parameters
pContainer | Pointer to a parent CXTPDockingPaneSplitterContainer object.
pFirst | Pointer to a first splitting CXTPDockingPaneBase object.
pSecond | Pointer to a second splitting CXTPDockingPaneBase object.

◆ GetContainer()

AFX_INLINE CXTPDockingPaneSplitterContainer * GetContainer ( ) const

Retrieves the associated splitter container of a splitter window.

Returns
A pointer to the associated splitter container of a splitter window.

◆ GetDockingPaneManager()

CXTPDockingPaneManager * GetDockingPaneManager ( ) const

Retrieves a pointer to the docking pane manager.

Returns
A pointer to the docking pane manager.

◆ GetPaneBase()

CXTPDockingPaneBase * GetPaneBase ( BOOL bFirst = TRUE )

Call this member function to retrieve a pointer to the docking splitter base pane.

Parameters
bFirst TRUE to retrieve a pointer to the first base pane in the group, otherwise retrieves a pointer to the second pane.
Returns
A CXTPDockingPaneBase object.

◆ GetPaneDirection()

XTPDockingPaneDirection GetPaneDirection ( ) const
inline

Call this member to determine the XTPDockingPaneDirection of the splitter.

Returns
The current XTPDockingPaneDirection of the splitter.

◆ IsHorizontal()

BOOL IsHorizontal ( ) const

Determines if the splitter orientation is horizontal.

Returns
TRUE if the splitter orientation is horizontal.
The documentation for this class was generated from the following file:
  • XTPDockingPaneSplitterContainer.h


Toolkit Pro: CXTPDockingPaneTabbedContainer Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPDockingPaneTabbedContainer Class Reference

CXTPDockingPaneTabbedContainer is a multiple inheritance class derived from CWnd and CXTPDockingPaneBase. More...

Inheritance diagram for CXTPDockingPaneTabbedContainer:
[legend]

Public Member Functions

virtual void | SelectPane (CXTPDockingPane *pPane, BOOL bSetFocus=TRUE, BOOL bDelayRedraw=TRUE)
Call this member to activate a child docking pane.
BOOL | IsActive () const
Call this member function to determine if a child pane is active.
CXTPDockingPane * | GetSelected () const
Call this member function to get the selected child pane.
CXTPDockingPaneCaptionButton * | GetCloseButton () const
Call this member to retrieve the title's close button.
CXTPDockingPaneCaptionButton * | GetPinButton () const
Call this member to retrieve the title's pin button.
BOOL | IsTitleVisible () const
Call this member to determine if the title is visible.
virtual BOOL | IsCaptionVertical () const
Call this member to determine if the caption is drawn vertically.
virtual BOOL | IsTabsVisible () const
Call this member to determine if the tab bar is visible.
virtual HWND | GetPaneHwnd () const
Retrieves the window handle for a window.
BOOL | IsHidden () const
Call this member to determine if the tabbed container is auto-hidden.
virtual void | OnCaptionLButtonDown (CPoint point)
This member is called by the framework when the left mouse button is clicked while the mouse pointer is positioned over a pane caption.
virtual BOOL | CanAttach (CRect &rcClient, CPoint pt) const
This method called to check if a docking pane can be attached to a tabbed container.
void | GetMinMaxInfo (LPMINMAXINFO pMinMaxInfo) const
Call this member to fill the pMinMaxInfo structure with the minimum and maximum width and height of the container.
CXTPDockingPane * | GetItemPane (int nIndex) const
Call this member to get a pane by its index.
CXTPTabManagerItem * | GetPaneTab (CXTPDockingPane *pPane) const
Call this member to get the tab for a corresponding pane.
CString | GetTitle () const
Call this member to get the text in the caption for the tabbed container (group of panes).
- Public Member Functions inherited from CXTPDockingPaneBaseContainer
virtual POSITION | ContainPane (CXTPDockingPaneBase *pPane) const
Call this member to determine if one pane is contained in the collection of another.
virtual void | FindPane (XTPDockingPaneType type, CXTPDockingPaneBaseList *pList) const
Call this member to find all panes of a specific XTPDockingPaneType within the container.
POSITION | GetHeadPosition () const
This method retrieves the position of the first pane of this container.
CXTPDockingPaneBase * | GetNext (POSITION &pos) const
Gets the pane element identified by rPosition, then sets rPosition to the POSITION value of the next entry in the container.
CXTPDockingPaneBase * | GetFirstPane () const
This method retrieves the first pane in the container.
CXTPDockingPaneBase * | GetLastPane () const
This method retrieves the last pane in the container.
CXTPDockingPaneBaseList & GetPanes ()
Call this member to retrieve the collection of child panes.
BOOL | OnAction (XTPDockingPaneAction action)
This method is called if some action occurs.
- Public Member Functions inherited from CXTPDockingPaneBase
XTPDockingPaneType | GetType () const
Call this member to determine the type of the pane.
CRect | GetPaneWindowRect () const
The GetPaneWindowRect function retrieves the dimensions of the bounding rectangle of the pane.
CXTPDockingPaneBase * | GetContainer () const
Call this member function to retrieve the parent container of the pane.
CXTPDockingPaneManager * | GetDockingPaneManager () const
Call this member function to retrieve the pane manager.
CXTPDockingPanePaintManager * | GetPaintManager () const
Call this member function to retrieve the paint manager.
CXTPDockingPaneCaptionButton * | FindCaptionButton (int nID) const
Call this member to find the specified caption button.
CXTPDockingPaneCaptionButtons * | GetCaptionButtons () const
Call this member to get a reference to the caption's close/pop-up button.
virtual void | RedrawPane ()
Call this member to redraw the pane.
virtual CWnd * | GetDockingSite () const
Call this member function to retrieve the parent window for the pane.
virtual void | InvalidatePane (BOOL bSelectionChanged)
This member is called when a pane must be redrawn.
- Public Member Functions inherited from CXTPTabManager
CXTPTabManager ()
Constructs a CXTPTabManager object.
virtual | ~CXTPTabManager ()
Destroys a CXTPTabManager object, handles cleanup and deallocation.
CXTPTabManagerItem * | GetItem (int nIndex) const
Retrieves a tab item by its index.
BOOL | DeleteItem (int nItem)
Deletes a tab item by its index.
void | DeleteAllItems ()
Deletes all tab items from the tab manager.
int | GetItemCount () const
Gets the number of tab items in the tab manager.
virtual CString | GetItemCaption (const CXTPTabManagerItem *pItem) const
Retrieves the caption text of a specified tab item.
virtual HICON | GetItemIcon (const CXTPTabManagerItem *pItem) const
Retrieves the icon of a specified tab item.
virtual COLORREF | GetItemColor (const CXTPTabManagerItem *pItem) const
Retrieves the tab button color of a specified tab item.
virtual CString | GetItemTooltip (const CXTPTabManagerItem *pItem) const
Retrieves the tooltip of a specified tab item.
virtual void | OnItemsChanged ()
This method is called when tab items are changed (i.e.
void | SetCurSel (int nIndex)
Sets the index for the currently selected tab item within the collection of tab items.
int | GetCurSel () const
Gets the index of the currently selected tab item within the collection of tab items.
virtual void | SetSelectedItem (CXTPTabManagerItem *pItem)
Sets the currently selected tab item.
virtual void | SetFocusedItem (CXTPTabManagerItem *pItem)
Sets the focused tab item.
CXTPTabManagerItem * | GetSelectedItem () const
Gets the currently selected tab item.
CXTPTabManagerItem * | HitTest (CPoint point) const
Determines which tab is at a specified point, if any.
CXTPTabManagerNavigateButton * | HitTestNavigateButton (CPoint point, BOOL bHeaderOnly, int *pnIndex=NULL) const
Determines which navigation button is at a specified point, if any.
virtual void | GetItemMetrics (CSize *szNormal, CSize *szMin=NULL, CSize *szMax=NULL) const
Gets the minimum, maximum, and normal lengths of tab buttons.
void | SetItemMetrics (CSize szNormal, CSize szMin=CSize(0, 0), CSize szMax=CSize(0, 0))
Sets the minimum, maximum, and normal lengths for tab buttons.
void | MoveItem (CXTPTabManagerItem *pItem, int nIndex)
Sets the position of a specified tab item.
void | ShowCloseItemButton (XTPTabNavigateButtonFlags bCloseItemButton=xtpTabNavigateButtonAlways)
Call this member to show close button for each tab.
virtual int | GetItemsLength () const
Gets the total width of all of the tab buttons.
int | GetRectLength (CRect rc) const
Gets the length of the bounding rectangle of the tab client header area.
CXTPTabManagerNavigateButton * | FindNavigateButton (UINT nID) const
Retrieves a specified tab navigation button (i.e.
BOOL | IsHorizontalPosition () const
Determines if the tabs are positioned horizontally.
int | GetHeaderOffset () const
Gets the scroll offset of the tabs in the tab header.
void | SetHeaderOffset (int nOffset)
Sets the scroll offset for the tabs in the tab header.
void | EnsureVisible (CXTPTabManagerItem *pItem)
Ensures that a specified tab is visible.
virtual BOOL | IsAllowReorder () const
Determines if tabs are allowed to be reordered.
virtual void | SetAllowReorder (BOOL bAllowReorder)
Specifies if tabs should be allowed to be reordered.
virtual BOOL | IsDrawStaticFrame () const
Determines if a static frame is used.
void | EnableTabThemeTexture (HWND hWnd, BOOL bEnable=TRUE)
Enables/disables Windows XP themed back color.
CXTPTabPaintManagerColorSet * | SetColor (XTPTabColorStyle tabColor)
Applies one of the "built-in" color sets for the tabs.
CXTPTabPaintManagerColorSet * | SetColorSet (CXTPTabPaintManagerColorSet *pColorSet)
Applies a custom color set for the tabs.
CXTPTabPaintManagerTheme * | SetAppearance (XTPTabAppearanceStyle tabAppearance)
Applies one of the "built-in" appearance sets for the tabs.
CXTPTabPaintManagerTheme * | SetAppearanceSet (CXTPTabPaintManagerTheme *pAppearanceSet)
Applies a custom appearance set for the tabs.
CXTPTabPaintManagerTheme * | GetAppearanceSet () const
Gets the currently applied custom appearance set.
CXTPTabPaintManagerColorSet * | GetColorSet () const
Gets the currently applied custom color set.
XTPTabAppearanceStyle | GetAppearance () const
Gets the currently applied "built-in appearance set.
XTPTabColorStyle | GetColor () const
Gets the currently applied "built-in" color set.
void | SetPosition (XTPTabPosition tabPosition)
Sets the tab position.
void | SetLayoutStyle (XTPTabLayoutStyle tabLayout)
Sets the tab layout style.
virtual XTPTabPosition | GetPosition () const
Gets the tab position.
XTPTabLayoutStyle | GetLayout () const
Gets the tab layout style.
void | ShowIcons (BOOL bShowIcons)
Shows/hides tab icons.
void | SetActive (BOOL bActive)
Specifies if this tab group should be active/inactive.
BOOL | IsActive () const
Determines if this tab group is active/inactive.
CRect | GetControlRect () const
Gets the bounding rectangle of the tab manager control area.
CRect | GetClientRect () const
Gets the bounding rectangle of the tab client area.
CRect | GetHeaderRect () const
Gets the bounding rectangle of the tab client header area.
int | GetRowCount () const
Gets the number of rows of tabs in the tab control.
virtual void | OnScrollHeader (BOOL bRight)
This method is called when the user presses either the left or right navigation buttons.
CXTPTabManagerNavigateButtons * GetNavigateButtons ()
Gets the collection of navigation buttons.
CXTPTabManagerItem * | FindNextFocusable (int nIndex, int nDirection) const
Retrieves the next/previous focusable tab item from a specified index.
void | PerformMouseMove (HWND hWnd, CPoint pt)
This method is called when the mouse cursor moves.
BOOL | PerformClick (HWND hWnd, CPoint pt, BOOL bNoItemClick=FALSE)
This method is called when the user presses the left mouse button.
virtual INT_PTR | PerformToolHitTest (HWND hWnd, CPoint point, TOOLINFO *pTI) const
Determines which tab is beneath the mouse cursor, if any, and stores the tooltip information of the tab within a TOOLINFO structure.
virtual BOOL | PerformKeyDown (HWND hWnd, UINT nChar)
This method is called to process a WM_KEYDOWN event for the tab manager.
virtual BOOL | DrawParentBackground (CDC *pDC, CRect rc)
Draws the parent background under the tab control.
int | GetNavigateButtonCount () const
Gets the total number of tab navigation buttons within the collection of tab navigation buttons.
CXTPTabManagerNavigateButton * | GetNavigateButton (int nIndex) const
Retrieves the tab navigation button at a specified index within the collection of tab navigation buttons.
void | EnableMarkup (BOOL bEnable=TRUE)
Enables/disables markup for the tab captions.
virtual CXTPMarkupContext * | GetMarkupContext () const
Gets the markup context.
- Public Member Functions inherited from CXTPTabManagerAtom
virtual void | OnPropertyChanged ()
This method is called when a property of the tab paint manager is changed.

Protected Member Functions

CXTPDockingPaneTabbedContainer (CXTPDockingPaneLayout *pLayout)
Constructs a CXTPDockingPaneTabbedContainer object Protected constructor.
virtual | ~CXTPDockingPaneTabbedContainer ()
Destroys a CXTPDockingPaneTabbedContainer object, handles cleanup and deallocation.
virtual BOOL | IsCaptionButtonVisible (CXTPDockingPaneCaptionButton *pButton)
Call this member to determine if the caption button is visible.
virtual void | OnCaptionButtonClick (CXTPDockingPaneCaptionButton *pButton)
This member is called by the framework when a caption button is clicked.
virtual void | OnNavigateButtonClick (CXTPTabManagerNavigateButton *pButton)
This member is called by the framework when a navigate button is clicked.
void | Init (CXTPDockingPane *pPane, CWnd *pFrame)
Constructs a CXTPDockingPaneTabbedContainer object Protected constructor.
virtual void | Copy (CXTPDockingPaneBase *pClone, CXTPPaneToPaneMap *pMap, DWORD dwIgnoredOptions)
Copies a CXTPDockingPaneTabbedContainer object.
virtual void | Reposition ()
This member is called to recalculate the positions of tab groups/items.
virtual void | RedrawControl (LPCRECT lpRect, BOOL bAnimate)
This member is called to redraw the tabbed control (i.e.
virtual CXTPTabPaintManager * | GetPaintManager () const
This member is called to access the visual elements of the docking pane tabs (i.e.
virtual void | SetPaintManager (CXTPTabPaintManager *pPaintManager)
This member function is called in a derived class to set the tab paint manager.
virtual BOOL | DrawIcon (CDC *pDC, CPoint pt, CXTPTabManagerItem *pItem, BOOL bDraw, CSize &szIcon) const
This member is called when the icon of the tab in the tabbed container needs to be drawn (i.e.
virtual BOOL | DoPropExchange (CXTPPropExchange *pPX)
This member is called to save/restore the settings of the pane.
virtual void | OnTabsChanged ()
This member is called when tabs are changed.
virtual void | CreateContainer ()
This member is called to create a pane.
- Protected Member Functions inherited from CXTPDockingPaneBaseContainer
CXTPDockingPaneBaseContainer (XTPDockingPaneType type, CXTPDockingPaneLayout *pLayout)
Protected constructor.
virtual | ~CXTPDockingPaneBaseContainer ()
Destroys a CXTPDockingPaneBase object, handles cleanup and deallocation.
virtual BOOL | IsEmpty () const
Call this member to determine if there are no children panes.
- Protected Member Functions inherited from CXTPDockingPaneBase
CXTPDockingPaneBase (XTPDockingPaneType type, CXTPDockingPaneLayout *pLayout)
Protected constructor.
virtual | ~CXTPDockingPaneBase ()
Destroys a CXTPDockingPaneBase object, handles cleanup and deallocation.
virtual void | OnSizeParent (CWnd *pParent, CRect rect, LPVOID lParam)
This method is called to set the position of the pane.
virtual void | OnFocusChanged ()
This method is called to update the state of the pane.
virtual void | SetDockingSite (CWnd *pFrame)
Call this member to set the parent frame of the pane.
virtual void | SetParentContainer (CXTPDockingPaneBase *pContainer)
Call this method to set the parent container of the pane.
virtual void | OnChildContainerChanged (CXTPDockingPaneBase *pContainer)
This member is called when a child pane collection is changed.
virtual void | OnParentContainerChanged (CXTPDockingPaneBase *pContainer)
This member is called when the parent pane collection is changed.
virtual CXTPDockingPaneBase * | Clone (CXTPDockingPaneLayout *pLayout, CXTPPaneToPaneMap *pMap, DWORD dwIgnoredOptions=0)
This member is called to clone the pane.
virtual void | RemovePane (CXTPDockingPaneBase *pPane)
Call this member to remove a pane from the collection.
virtual void | OnCaptionButtonRectChanged (CXTPDockingPaneCaptionButton *pButton)
This member is called when the dimensions of the caption button are changed.
virtual void | DeletePane ()=0
This method is called to destroy a pane.
- Protected Member Functions inherited from CXTPTabManager
virtual BOOL | IsNavigateButtonAutomaticVisible (CXTPTabManagerNavigateButton *pButton)
Determines if a specified tab navigation button is automatically displayed.
virtual BOOL | IsNavigateButtonVisible (CXTPTabManagerNavigateButton *pButton)
Determines if a specified tab navigation button is visible.
virtual void | OnItemClick (CXTPTabManagerItem *pItem)
This method is called when a tab button is clicked to select the tab item that was clicked.
virtual BOOL | OnBeforeItemClick (CXTPTabManagerItem *pItem)
This method is called before a tab item is clicked.
virtual void | ReOrder (HWND hWnd, CPoint pt, CXTPTabManagerItem *pItem)
This method is called when a tab item is clicked and dragged within the tab header.
virtual void | OnSwitchItem (CXTPTabManagerItem *pItem1, CXTPTabManagerItem *pItem2)
This method is called by ReOrder when two tab items are switched.
virtual void | OnItemOrderChanged (CXTPTabManagerItem *pItem, int nOldIndex, int nNewIndex)
This method is called by ReOrder when a tab item's position is changed.
virtual BOOL | IsMouseLocked () const
Determines if the MouseMove event has been disabled.
CXTPTabManagerItem * | AddItem (int nItem, CXTPTabManagerItem *pItem=NULL)
Adds a specified tab item to the collection of tab items.
virtual BOOL | HeaderHasFocus () const
The implementation should return TRUE if the header has focus or FALSE otherwise.
void | TrackClick (HWND hWnd, CPoint pt, CXTPTabManagerItem *pItem)
Activates and tracks a specified tab item on mouse click.
virtual void | OnItemHandleChanged (CXTPTabManagerItem *pItem, HWND hwndOld, HWND hwndNew)
This method is called when the handle of a tab item is changed.
- Protected Member Functions inherited from CXTPTabManagerAtom
virtual | ~CXTPTabManagerAtom ()
Destroys a CXTPTabManagerAtom object, handles cleanup and deallocation.

Protected Attributes

BOOL | m_bActive
TRUE if the tabbed container has an active caption.
BOOL | m_bTitleVisible
TRUE if the title is visible.
int | m_nLockReposition
InvalidatePane method currently executed.
BOOL | m_bDelayRedraw
TRUE to redraw the pane after a small delay.
CXTPDockingPane * | m_pSelectedPane
Pointer to the selected pane.
CXTPDockingPane * | m_pTrackingPane
Pointer to the dragging pane.
CArray< CRect, CRect & > | m_lstRects
Array of previous tabs positions.
COleDropTarget * | m_pDropTarget
Pointer to Ole Drop Target.
BOOL | m_bMaximized
TRUE if the pane is currently maximized.
BOOL | m_bEnsureSelectedTab
TRUE to check if the selected tab is visible after a delay.
- Protected Attributes inherited from CXTPDockingPaneBaseContainer
CXTPDockingPaneBaseList | m_lstPanes
Child panes collection.
- Protected Attributes inherited from CXTPDockingPaneBase
CSize | m_szDocking
Size of the pane.
CXTPDockingPaneLayout * | m_pLayout
Parent layout.
CXTPDockingPaneBase * | m_pParentContainer
Parent container.
CWnd * | m_pDockingSite
Parent frame.
XTPDockingPaneType | m_type
Type of the pane.
CRect | m_rcWindow
Position of the pane.
CXTPDockingPaneCaptionButtons * | m_pCaptionButtons
Collection of caption buttons.
- Protected Attributes inherited from CXTPTabManager
CXTPTabManagerItem * m_pSelected
Tab currently selected (i.e.
CXTPTabManagerItem * m_pHighlighted
Tab currently highlighted (i.e.
CXTPTabManagerItem * | m_pPressed
Pointer to the currently pressed tab.
CXTPTabManagerNavigateButton * | m_pHighlightedNavigateButton
Pointer to highlighted navigate button.
int | m_nHeaderOffset
Scroll offset, this is how much the tabs in the tab header have been scrolled using the left and right tab navigation buttons.
BOOL | m_bAllowReorder
TRUE to allow tabs to be reordered.
BOOL | m_bActive
TRUE if the MDITabClient tab group is active.
XTPTabNavigateButtonFlags | m_bCloseItemButton
TRUE to show the close button for tabs.
CRect | m_rcHeaderRect
Bounding rectangle of the tab header area.
CRect | m_rcControl
Bounding rectangle of the tab manager control.
CArray< CXTPTabManagerItem *, CXTPTabManagerItem * > | m_arrItems
Bounding rectangle of the tab client area.
CXTPTabManagerNavigateButtons | m_arrNavigateButtons
Collection of tab navigation buttons for this tab manager.
CRowIndexer * | m_pRowIndexer
Row indexer.
int | m_nScrollDelta
Scroll header delta.
CXTPMarkupContext * | m_pMarkupContext
Markup context of the tab manager.

Detailed Description

CXTPDockingPaneTabbedContainer is a multiple inheritance class derived from CWnd and CXTPDockingPaneBase.

It represents a tabbed container for Docking Panes.

Constructor & Destructor Documentation

◆ CXTPDockingPaneTabbedContainer()

CXTPDockingPaneTabbedContainer ( CXTPDockingPaneLayout * pLayout )
protected

Constructs a CXTPDockingPaneTabbedContainer object Protected constructor.

Internally constructed only.

Parameters
pLayout Pointer to a CXTPDockingPaneLayout object.

Member Function Documentation

◆ CanAttach()

virtual BOOL CanAttach | ( | CRect & | rcClient,
 |  | CPoint | pt ) const
 virtual

This method called to check if a docking pane can be attached to a tabbed container.

Parameters
rcClient | Client rectangle of the container.
pt | Point to attach.
Returns
TRUE if the pane can be attached as a new tab to the tabbed container.

◆ Copy()

virtual void Copy | ( | CXTPDockingPaneBase * | pClone,
 |  | CXTPPaneToPaneMap * | pMap,
 |  | DWORD | dwIgnoredOptions )
 protectedvirtual

Copies a CXTPDockingPaneTabbedContainer object.

Parameters
pClone | Pointer to a CXTPDockingPaneTabbedContainer object.
pMap | Pointer to a CXTPPaneToPaneMap object.
dwIgnoredOptions | Options that must be skipped.
See also
CXTPPaneToPaneMap

Reimplemented from CXTPDockingPaneBase.

◆ DoPropExchange()

virtual BOOL DoPropExchange ( CXTPPropExchange * pPX )
protectedvirtual

This member is called to save/restore the settings of the pane.

Parameters
pPX Pointer to a CXTPPropExchange object.
Returns
TRUE if successful, otherwise FALSE.

Reimplemented from CXTPDockingPaneBase.

◆ DrawIcon()

virtual BOOL DrawIcon | ( | CDC * | pDC,
 |  | CPoint | pt,
 |  | CXTPTabManagerItem * | pItem,
 |  | BOOL | bDraw,
 |  | CSize & | szIcon ) const
 protectedvirtual

This member is called when the icon of the tab in the tabbed container needs to be drawn (i.e.

on mouse over).

Parameters
pDC | Pointer to the destination device context.
pt | Specifies the location of the image.
pItem | CXTPTabManagerItem object to draw icon on.
bDraw | TRUE if the icon needs to be drawn (i.e. the icon size changed), FALSE if the icon does not need to be drawn or redrawn.
szIcon | Size of the tab icon.
Returns
TRUE if the icon was drawn successfully, FALSE if the icon was not drawn.

Implements CXTPTabManager.

◆ GetCloseButton()

CXTPDockingPaneCaptionButton * GetCloseButton ( ) const

Call this member to retrieve the title's close button.

Returns
A reference to the title's close button.

◆ GetItemPane()

CXTPDockingPane * GetItemPane ( int nIndex ) const

Call this member to get a pane by its index.

Parameters
nIndex Index of the pane to retrieve.
Returns
A pointer to a CXTPDockingPane object.

◆ GetMinMaxInfo()

void GetMinMaxInfo ( LPMINMAXINFO pMinMaxInfo ) const
virtual

Call this member to fill the pMinMaxInfo structure with the minimum and maximum width and height of the container.

This will look at the MinMaxInfo for each pane in the container and set the appropriate minimum and maximum width and height for the container.

Parameters
pMinMaxInfo Pointer to a MINMAXINFO structure.

Reimplemented from CXTPDockingPaneBase.

◆ GetPaintManager()

virtual CXTPTabPaintManager * GetPaintManager ( ) const
protectedvirtual

This member is called to access the visual elements of the docking pane tabs (i.e.

tab colors, styles, etc.).

Returns
Pointer to the CXTPTabPaintManager that contains the visual elements of the docking pane tabs.

Implements CXTPTabManager.

◆ GetPaneHwnd()

AFX_INLINE HWND GetPaneHwnd ( ) const
virtual

Retrieves the window handle for a window.

Returns
The window handle for a window if successful. NULL if the HWND is not attached to a window or if it is used with a NULL HWND pointer.

Reimplemented from CXTPDockingPaneBase.

◆ GetPaneTab()

CXTPTabManagerItem * GetPaneTab ( CXTPDockingPane * pPane ) const

Call this member to get the tab for a corresponding pane.

Parameters
pPane Pane to get the tab for.
Returns
Pointer to the CXTPTabManagerItem object corresponding with pPane.

◆ GetPinButton()

CXTPDockingPaneCaptionButton * GetPinButton ( ) const

Call this member to retrieve the title's pin button.

Returns
A reference to the title's pin button.

◆ GetSelected()

AFX_INLINE CXTPDockingPane * GetSelected ( ) const

Call this member function to get the selected child pane.

Returns
The selected child pane.

◆ GetTitle()

CString GetTitle ( ) const
virtual

Call this member to get the text in the caption for the tabbed container (group of panes).

Returns
The text in the caption for the tabbed container (group of panes).

Reimplemented from CXTPDockingPaneBase.

◆ Init()

void Init | ( | CXTPDockingPane * | pPane,
 |  | CWnd * | pFrame )
 protected

Constructs a CXTPDockingPaneTabbedContainer object Protected constructor.

Internally constructed only.

Parameters
pPane | Child pane.
pFrame | Parent Frame.

◆ IsActive()

AFX_INLINE BOOL IsActive ( ) const
virtual

Call this member function to determine if a child pane is active.

Returns
TRUE if a child pane is active.

Reimplemented from CXTPDockingPaneBase.

◆ IsCaptionButtonVisible()

virtual BOOL IsCaptionButtonVisible ( CXTPDockingPaneCaptionButton * pButton )
protectedvirtual

Call this member to determine if the caption button is visible.

Parameters
pButton Caption button pointer.
Returns
TRUE if the caption button is visible, otherwise FALSE.

Reimplemented from CXTPDockingPaneBase.

◆ IsCaptionVertical()

virtual BOOL IsCaptionVertical ( ) const
virtual

Call this member to determine if the caption is drawn vertically.

Returns
TRUE if the caption is drawn vertically.

Reimplemented from CXTPDockingPaneBase.

◆ IsHidden()

BOOL IsHidden ( ) const
virtual

Call this member to determine if the tabbed container is auto-hidden.

If one pane in a group of panes is auto-hidden, then the entire group will be auto-hidden.

Returns
TRUE if the tabbed container is auto-hidden, FALSE if the tab group is visible.

Reimplemented from CXTPDockingPaneBase.

◆ IsTabsVisible()

virtual BOOL IsTabsVisible ( ) const
virtual

Call this member to determine if the tab bar is visible.

Returns
TRUE if the tab bar is visible.

◆ IsTitleVisible()

BOOL IsTitleVisible ( ) const

Call this member to determine if the title is visible.

Returns
TRUE if the title is visible.

◆ OnCaptionButtonClick()

virtual void OnCaptionButtonClick ( CXTPDockingPaneCaptionButton * pButton )
protectedvirtual

This member is called by the framework when a caption button is clicked.

Parameters
pButton Caption button that was clicked.

◆ OnCaptionLButtonDown()

virtual void OnCaptionLButtonDown ( CPoint point )
virtual

This member is called by the framework when the left mouse button is clicked while the mouse pointer is positioned over a pane caption.

This will give the pane focus and begin the pane dragging process (if the left button is held down).

Parameters
point Cursor location of the pane's caption that was clicked.

◆ OnNavigateButtonClick()

virtual void OnNavigateButtonClick ( CXTPTabManagerNavigateButton * pButton )
protectedvirtual

This member is called by the framework when a navigate button is clicked.

Parameters
pButton Navigate button that was clicked.

Reimplemented from CXTPTabManager.

◆ RedrawControl()

virtual void RedrawControl | ( | LPCRECT | lpRect,
 |  | BOOL | bAnimate )
 protectedvirtual

This member is called to redraw the tabbed control (i.e.

when an icon has changed).

Parameters
lpRect | The rectangular area of the window that is invalid.
bAnimate | TRUE to animate changes in the bounding rectangle.

Implements CXTPTabManager.

◆ SelectPane()

virtual void SelectPane | ( | CXTPDockingPane * | pPane,
 |  | BOOL | bSetFocus = TRUE,
 |  | BOOL | bDelayRedraw = TRUE )
 virtual

Call this member to activate a child docking pane.

Parameters
pPane | Pane to be activated.
bSetFocus | TRUE to set focus to the child docking pane.
bDelayRedraw | TRUE to redraw the pane after a small delay.

◆ SetPaintManager()

virtual void SetPaintManager ( CXTPTabPaintManager * pPaintManager )
protectedvirtual

This member function is called in a derived class to set the tab paint manager.

Parameters
pPaintManager Pointer to a CXTPTabPaintManager object.

Reimplemented from CXTPTabManager.

The documentation for this class was generated from the following file:
  • XTPDockingPaneTabbedContainer.h


Toolkit Pro: CXTPDockingPaneTabColorSet2012 Class Reference

Public Member Functions | List of all members
CXTPDockingPaneTabColorSet2012 Class Reference

Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines. More...

Inheritance diagram for CXTPDockingPaneTabColorSet2012:
[legend]

Public Member Functions

CXTPDockingPaneTabColorSet2012 ()
Default class constructor.
virtual void | RefreshMetrics ()
This member function is used to initialize default colors for a theme from an .INI resource.
virtual COLORREF | GetItemColor (CXTPTabManagerItem *pItem)
Call this member function to retrieve the color for the tab specified by pItem.
virtual void | FillNavigateButton (CDC *pDC, CXTPTabManagerNavigateButton *pButton, CRect &rc)
This member is called to fill the tab navigation buttons.
virtual void | FillHeader (CDC *pDC, CRect rc, CXTPTabManager *pTabManager)
This member is called to fill the header of the TabClient of the tab manager.
- Public Member Functions inherited from CXTPTabPaintManagerColorSet
CXTPTabPaintManagerColorSet ()
Constructs a CXTPTabPaintManagerColorSet object.
virtual | ~CXTPTabPaintManagerColorSet ()
Destroys a CXTPTabPaintManagerColorSet object, handles cleanup and deallocation.
virtual void | SetTextColor (CDC *pDC, CXTPTabManagerItem *pItem)
Sets the text color for the tab.
virtual COLORREF | FillClient (CDC *pDC, CRect rc, CXTPTabManager *pTabManager)
Fills the tab client area of a specified tab manager.
virtual COLORREF | GetClientColor (CXTPTabManager *pTabManager)
Obtains client background color.
virtual void | FillStateButton (CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem)
Fills a specified tab button when XTPTabAppearanceStyle is xtpTabAppearanceStateButtons.
virtual COLORREF | FillPropertyButton (CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem)
Fills a specified tab button.
virtual void | SelectClipRgn (CDC *pDC, CRect rcClient, CXTPTabManager *pTabManager)
Sets a clipping region for the specified tab client area.
void | GradientFill (CDC *pDC, CRect rc, COLORREF clrLight, COLORREF clrDark, XTPTabPosition position)
Performs a gradient fill of a rectangle with a color that smoothly fades from top to bottom.
virtual BOOL | IsAppThemed () const
Determines if Windows XP themes are enabled and if a Windows XP theme is currently used.

Additional Inherited Members

- Public Attributes inherited from CXTPTabPaintManagerColorSet
CXTPPaintManagerColorGradient | m_clrHeaderFace
Color set of the tab header background.
CXTPPaintManagerColorGradient m_clrAutoHideFace
Color set of the auto-hide panel background.
CXTPPaintManagerColor | m_clrFrameBorder
Color of the border placed around the tab buttons and the tab client.
CXTPPaintManagerColor m_clrControlFace
Color of the control foreground.
CXTPPaintManagerColor | m_clrPaneFace
Color of the control pane foreground.
CXTPPaintManagerColor | m_clrBorderHighlight
Color of the highlight border.
CXTPPaintManagerColor | m_clrTabClientBack
Background color for the tab client area.
CXTPPaintManagerColor | m_clrTabClientBorder
Border color for the tab client area.
CXTPPaintManagerColor m_clrButtonNormal
Color of normal tabs.
CXTPPaintManagerColor | m_clrButtonPressed
Tab pressed button color.
CXTPPaintManagerColor | m_clrButtonHighlighted
Tab button color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonHighlightedClose
Tab close button color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonBorderHighlighted
Tab button border color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonBorderTabContext1
Tab button border color with tab context.
CXTPPaintManagerColor | m_clrButtonBorderTabContext2
Tab button border color with tab context.
CXTPPaintManagerColor | m_clrButtonBorderKeyTips
Tab button border color when ALT button is pressed.
CXTPPaintManagerColor | m_clrButtonSelected
Color of the currently selected tab.
CXTPPaintManagerColor | m_clrButtonSelectedPressed
Color of the currently selected tab when pressed.
CXTPPaintManagerColor | m_clrButtonSelectedHighlighted
Color of the currently selected tab when highlighted.
CXTPPaintManagerColor | m_clrButtonBorder
Tab button border (edge) color.
CXTPPaintManagerColor | m_clrButtonBorderHot
Tab button highlight or pressed border (edge) color.
CXTPPaintManagerColor m_clrTextNormal
Color of text in a normal tab.
CXTPPaintManagerColor m_clrTextPressed
Color of text in a "pressed" tab button.
CXTPPaintManagerColor | m_clrTextHighlight
Color of text on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrTextHighlightClose
Color of close button text on mouse over when hot tracking is enabled.
CXTPPaintManagerColor m_clrTextSelected
Color of text in a "selected" tab button.
CXTPPaintManagerColor m_clrTextSelectedPressed
Color of text in a "pressed" tab button.
CXTPPaintManagerColor | m_clrTextSelectedHighlighted
Color of text for tabs in all non-active groups of tabs in MDITabClient.
CXTPPaintManagerColor m_clrTextDisabled
Color of text when a tab is disabled.
CXTPPaintManagerColor | m_clrActiveFilesGlyph
Color of navigation button.
CXTPPaintManagerColor | m_clrActiveFilesGlyphHighlighted
Color of highlighted navigation button.
CXTPPaintManagerColor | m_clrActiveFilesGlyphPressed
Color of selected navigation button.
CXTPPaintManagerColor | m_clrActiveFilesBack
Color of highlighted navigation button background.
CXTPPaintManagerColor | m_clrActiveFilesBackHighlighted
Color of navigation button background.
CXTPPaintManagerColor | m_clrActiveFilesBackPressed
Color of selected navigation button background.
COLORSET_TAB_STATEBUTTON | m_csStateButton
Color set of state button style tabs.
COLORSET_TAB_PROPERTYPAGE | m_csPropertyPage
Color set of visual studio style tabs.
COLORSET_TAB_PROPERTYPAGE2003 | m_csPropertyPage2003
Color set of Office 2003 style tabs.
COLORSET_TAB_EXCEL | m_csExcelSelected
Color set of selected (focused) Excel style tabs.
COLORSET_TAB_EXCEL | m_csExcelNormal
Color set of normal Excel style tabs.
- Protected Attributes inherited from CXTPTabPaintManagerColorSet
CXTPTabPaintManager * | m_pPaintManager
Self paint manager pointer.

Detailed Description

Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines.

Member Function Documentation

◆ FillHeader()

virtual void FillHeader | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | CXTPTabManager * | pTabManager )
 virtual

This member is called to fill the header of the TabClient of the tab manager.

Parameters
pDC | Pointer to a valid device context.
rc | Bounding rectangle of the tab header.
pTabManager | Fill the header of this CXTPTabManager object.

The TabClient header is the bounding rectangle with tab buttons. The bounding rectangle can be retrieved with the CXTPTabPaintManagerTheme::GetHeaderRect, and CXTPTabManager::GetHeaderRect members.

See also
CXTPTabPaintManagerTheme::GetHeaderRect, CXTPTabManager::GetHeaderRect

Reimplemented from CXTPTabPaintManagerColorSet.

Reimplemented in CXTPDockingPaneTabColorSet2015, CXTPDockingPaneTabColorSet2017, CXTPDockingPaneTabColorSet2019, CXTPDockingPaneTabColorSet2022, CXTPDockingPaneTabColorSetNativeWindows10, and CXTPDockingPaneTabColorSetNativeWindows11.

◆ FillNavigateButton()

virtual void FillNavigateButton | ( | CDC * | pDC,
 |  | CXTPTabManagerNavigateButton * | pButton,
 |  | CRect & | rc )
 virtual

This member is called to fill the tab navigation buttons.

Parameters
pDC | Pointer to a valid device context.
pButton | Tab navigation button to fill.
rc | Bounding rectangle of the tab navigation button.

This member must be overridden and takes care of filling the tab navigation buttons that are in the header of the TabClient. The XTPTabColorStyle CXTPTabPaintManagerColorSet classes override this to perform actions such as painting the highlighting, pressed, and normal versions of the tab navigation buttons.

See also
CXTPTabManager::GetNavigateButton, CXTPTabManagerNavigateButton

Implements CXTPTabPaintManagerColorSet.

◆ GetItemColor()

virtual COLORREF GetItemColor ( CXTPTabManagerItem * pItem )
virtual

Call this member function to retrieve the color for the tab specified by pItem.

Parameters
pItem Pointer to a valid CXTPTabManagerItem object.
Returns
An RGB color value representing the specified tab color.

Reimplemented from CXTPTabPaintManagerColorSet.

The documentation for this class was generated from the following file:
  • XTPDockingPaneTabColorSet2012.h


Toolkit Pro: CXTPDockingPaneTabColorSet2013 Class Reference

Public Member Functions | List of all members
CXTPDockingPaneTabColorSet2013 Class Reference

Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines. More...

Inheritance diagram for CXTPDockingPaneTabColorSet2013:
[legend]

Public Member Functions

CXTPDockingPaneTabColorSet2013 ()
Default class constructor.
virtual void | RefreshMetrics ()
This member function is used to initialize default colors for a theme from an .INI resource.
virtual COLORREF | GetItemColor (CXTPTabManagerItem *pItem)
Call this member function to retrieve the color for the tab specified by pItem.
virtual void | FillNavigateButton (CDC *pDC, CXTPTabManagerNavigateButton *pButton, CRect &rc)
This member is called to fill the tab navigation buttons.
virtual void | FillHeader (CDC *pDC, CRect rc, CXTPTabManager *pTabManager)
This member is called to fill the header of the TabClient of the tab manager.
- Public Member Functions inherited from CXTPTabPaintManagerColorSet
CXTPTabPaintManagerColorSet ()
Constructs a CXTPTabPaintManagerColorSet object.
virtual | ~CXTPTabPaintManagerColorSet ()
Destroys a CXTPTabPaintManagerColorSet object, handles cleanup and deallocation.
virtual void | SetTextColor (CDC *pDC, CXTPTabManagerItem *pItem)
Sets the text color for the tab.
virtual COLORREF | FillClient (CDC *pDC, CRect rc, CXTPTabManager *pTabManager)
Fills the tab client area of a specified tab manager.
virtual COLORREF | GetClientColor (CXTPTabManager *pTabManager)
Obtains client background color.
virtual void | FillStateButton (CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem)
Fills a specified tab button when XTPTabAppearanceStyle is xtpTabAppearanceStateButtons.
virtual COLORREF | FillPropertyButton (CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem)
Fills a specified tab button.
virtual void | SelectClipRgn (CDC *pDC, CRect rcClient, CXTPTabManager *pTabManager)
Sets a clipping region for the specified tab client area.
void | GradientFill (CDC *pDC, CRect rc, COLORREF clrLight, COLORREF clrDark, XTPTabPosition position)
Performs a gradient fill of a rectangle with a color that smoothly fades from top to bottom.
virtual BOOL | IsAppThemed () const
Determines if Windows XP themes are enabled and if a Windows XP theme is currently used.

Additional Inherited Members

- Public Attributes inherited from CXTPTabPaintManagerColorSet
CXTPPaintManagerColorGradient | m_clrHeaderFace
Color set of the tab header background.
CXTPPaintManagerColorGradient m_clrAutoHideFace
Color set of the auto-hide panel background.
CXTPPaintManagerColor | m_clrFrameBorder
Color of the border placed around the tab buttons and the tab client.
CXTPPaintManagerColor m_clrControlFace
Color of the control foreground.
CXTPPaintManagerColor | m_clrPaneFace
Color of the control pane foreground.
CXTPPaintManagerColor | m_clrBorderHighlight
Color of the highlight border.
CXTPPaintManagerColor | m_clrTabClientBack
Background color for the tab client area.
CXTPPaintManagerColor | m_clrTabClientBorder
Border color for the tab client area.
CXTPPaintManagerColor m_clrButtonNormal
Color of normal tabs.
CXTPPaintManagerColor | m_clrButtonPressed
Tab pressed button color.
CXTPPaintManagerColor | m_clrButtonHighlighted
Tab button color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonHighlightedClose
Tab close button color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonBorderHighlighted
Tab button border color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonBorderTabContext1
Tab button border color with tab context.
CXTPPaintManagerColor | m_clrButtonBorderTabContext2
Tab button border color with tab context.
CXTPPaintManagerColor | m_clrButtonBorderKeyTips
Tab button border color when ALT button is pressed.
CXTPPaintManagerColor | m_clrButtonSelected
Color of the currently selected tab.
CXTPPaintManagerColor | m_clrButtonSelectedPressed
Color of the currently selected tab when pressed.
CXTPPaintManagerColor | m_clrButtonSelectedHighlighted
Color of the currently selected tab when highlighted.
CXTPPaintManagerColor | m_clrButtonBorder
Tab button border (edge) color.
CXTPPaintManagerColor | m_clrButtonBorderHot
Tab button highlight or pressed border (edge) color.
CXTPPaintManagerColor m_clrTextNormal
Color of text in a normal tab.
CXTPPaintManagerColor m_clrTextPressed
Color of text in a "pressed" tab button.
CXTPPaintManagerColor | m_clrTextHighlight
Color of text on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrTextHighlightClose
Color of close button text on mouse over when hot tracking is enabled.
CXTPPaintManagerColor m_clrTextSelected
Color of text in a "selected" tab button.
CXTPPaintManagerColor m_clrTextSelectedPressed
Color of text in a "pressed" tab button.
CXTPPaintManagerColor | m_clrTextSelectedHighlighted
Color of text for tabs in all non-active groups of tabs in MDITabClient.
CXTPPaintManagerColor m_clrTextDisabled
Color of text when a tab is disabled.
CXTPPaintManagerColor | m_clrActiveFilesGlyph
Color of navigation button.
CXTPPaintManagerColor | m_clrActiveFilesGlyphHighlighted
Color of highlighted navigation button.
CXTPPaintManagerColor | m_clrActiveFilesGlyphPressed
Color of selected navigation button.
CXTPPaintManagerColor | m_clrActiveFilesBack
Color of highlighted navigation button background.
CXTPPaintManagerColor | m_clrActiveFilesBackHighlighted
Color of navigation button background.
CXTPPaintManagerColor | m_clrActiveFilesBackPressed
Color of selected navigation button background.
COLORSET_TAB_STATEBUTTON | m_csStateButton
Color set of state button style tabs.
COLORSET_TAB_PROPERTYPAGE | m_csPropertyPage
Color set of visual studio style tabs.
COLORSET_TAB_PROPERTYPAGE2003 | m_csPropertyPage2003
Color set of Office 2003 style tabs.
COLORSET_TAB_EXCEL | m_csExcelSelected
Color set of selected (focused) Excel style tabs.
COLORSET_TAB_EXCEL | m_csExcelNormal
Color set of normal Excel style tabs.
- Protected Attributes inherited from CXTPTabPaintManagerColorSet
CXTPTabPaintManager * | m_pPaintManager
Self paint manager pointer.

Detailed Description

Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines.

Member Function Documentation

◆ FillHeader()

virtual void FillHeader | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | CXTPTabManager * | pTabManager )
 virtual

This member is called to fill the header of the TabClient of the tab manager.

Parameters
pDC | Pointer to a valid device context.
rc | Bounding rectangle of the tab header.
pTabManager | Fill the header of this CXTPTabManager object.

The TabClient header is the bounding rectangle with tab buttons. The bounding rectangle can be retrieved with the CXTPTabPaintManagerTheme::GetHeaderRect, and CXTPTabManager::GetHeaderRect members.

See also
CXTPTabPaintManagerTheme::GetHeaderRect, CXTPTabManager::GetHeaderRect

Reimplemented from CXTPTabPaintManagerColorSet.

◆ FillNavigateButton()

virtual void FillNavigateButton | ( | CDC * | pDC,
 |  | CXTPTabManagerNavigateButton * | pButton,
 |  | CRect & | rc )
 virtual

This member is called to fill the tab navigation buttons.

Parameters
pDC | Pointer to a valid device context.
pButton | Tab navigation button to fill.
rc | Bounding rectangle of the tab navigation button.

This member must be overridden and takes care of filling the tab navigation buttons that are in the header of the TabClient. The XTPTabColorStyle CXTPTabPaintManagerColorSet classes override this to perform actions such as painting the highlighting, pressed, and normal versions of the tab navigation buttons.

See also
CXTPTabManager::GetNavigateButton, CXTPTabManagerNavigateButton

Implements CXTPTabPaintManagerColorSet.

◆ GetItemColor()

virtual COLORREF GetItemColor ( CXTPTabManagerItem * pItem )
virtual

Call this member function to retrieve the color for the tab specified by pItem.

Parameters
pItem Pointer to a valid CXTPTabManagerItem object.
Returns
An RGB color value representing the specified tab color.

Reimplemented from CXTPTabPaintManagerColorSet.

The documentation for this class was generated from the following file:
  • XTPDockingPaneTabColorSet2013.h


Toolkit Pro: CXTPDockingPaneTabColorSet2015 Class Reference

Public Member Functions | List of all members
CXTPDockingPaneTabColorSet2015 Class Reference

Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines. More...

Inheritance diagram for CXTPDockingPaneTabColorSet2015:
[legend]

Public Member Functions

CXTPDockingPaneTabColorSet2015 ()
Default class constructor.
virtual void | FillHeader (CDC *pDC, CRect rc, CXTPTabManager *pTabManager)
This member is called to fill the header of the TabClient of the tab manager.
- Public Member Functions inherited from CXTPDockingPaneTabColorSet2012
CXTPDockingPaneTabColorSet2012 ()
Default class constructor.
virtual void | RefreshMetrics ()
This member function is used to initialize default colors for a theme from an .INI resource.
virtual COLORREF | GetItemColor (CXTPTabManagerItem *pItem)
Call this member function to retrieve the color for the tab specified by pItem.
virtual void | FillNavigateButton (CDC *pDC, CXTPTabManagerNavigateButton *pButton, CRect &rc)
This member is called to fill the tab navigation buttons.
- Public Member Functions inherited from CXTPTabPaintManagerColorSet
CXTPTabPaintManagerColorSet ()
Constructs a CXTPTabPaintManagerColorSet object.
virtual | ~CXTPTabPaintManagerColorSet ()
Destroys a CXTPTabPaintManagerColorSet object, handles cleanup and deallocation.
virtual void | SetTextColor (CDC *pDC, CXTPTabManagerItem *pItem)
Sets the text color for the tab.
virtual COLORREF | FillClient (CDC *pDC, CRect rc, CXTPTabManager *pTabManager)
Fills the tab client area of a specified tab manager.
virtual COLORREF | GetClientColor (CXTPTabManager *pTabManager)
Obtains client background color.
virtual void | FillStateButton (CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem)
Fills a specified tab button when XTPTabAppearanceStyle is xtpTabAppearanceStateButtons.
virtual COLORREF | FillPropertyButton (CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem)
Fills a specified tab button.
virtual void | SelectClipRgn (CDC *pDC, CRect rcClient, CXTPTabManager *pTabManager)
Sets a clipping region for the specified tab client area.
void | GradientFill (CDC *pDC, CRect rc, COLORREF clrLight, COLORREF clrDark, XTPTabPosition position)
Performs a gradient fill of a rectangle with a color that smoothly fades from top to bottom.
virtual BOOL | IsAppThemed () const
Determines if Windows XP themes are enabled and if a Windows XP theme is currently used.

Additional Inherited Members

- Public Attributes inherited from CXTPTabPaintManagerColorSet
CXTPPaintManagerColorGradient | m_clrHeaderFace
Color set of the tab header background.
CXTPPaintManagerColorGradient m_clrAutoHideFace
Color set of the auto-hide panel background.
CXTPPaintManagerColor | m_clrFrameBorder
Color of the border placed around the tab buttons and the tab client.
CXTPPaintManagerColor m_clrControlFace
Color of the control foreground.
CXTPPaintManagerColor | m_clrPaneFace
Color of the control pane foreground.
CXTPPaintManagerColor | m_clrBorderHighlight
Color of the highlight border.
CXTPPaintManagerColor | m_clrTabClientBack
Background color for the tab client area.
CXTPPaintManagerColor | m_clrTabClientBorder
Border color for the tab client area.
CXTPPaintManagerColor m_clrButtonNormal
Color of normal tabs.
CXTPPaintManagerColor | m_clrButtonPressed
Tab pressed button color.
CXTPPaintManagerColor | m_clrButtonHighlighted
Tab button color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonHighlightedClose
Tab close button color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonBorderHighlighted
Tab button border color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonBorderTabContext1
Tab button border color with tab context.
CXTPPaintManagerColor | m_clrButtonBorderTabContext2
Tab button border color with tab context.
CXTPPaintManagerColor | m_clrButtonBorderKeyTips
Tab button border color when ALT button is pressed.
CXTPPaintManagerColor | m_clrButtonSelected
Color of the currently selected tab.
CXTPPaintManagerColor | m_clrButtonSelectedPressed
Color of the currently selected tab when pressed.
CXTPPaintManagerColor | m_clrButtonSelectedHighlighted
Color of the currently selected tab when highlighted.
CXTPPaintManagerColor | m_clrButtonBorder
Tab button border (edge) color.
CXTPPaintManagerColor | m_clrButtonBorderHot
Tab button highlight or pressed border (edge) color.
CXTPPaintManagerColor m_clrTextNormal
Color of text in a normal tab.
CXTPPaintManagerColor m_clrTextPressed
Color of text in a "pressed" tab button.
CXTPPaintManagerColor | m_clrTextHighlight
Color of text on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrTextHighlightClose
Color of close button text on mouse over when hot tracking is enabled.
CXTPPaintManagerColor m_clrTextSelected
Color of text in a "selected" tab button.
CXTPPaintManagerColor m_clrTextSelectedPressed
Color of text in a "pressed" tab button.
CXTPPaintManagerColor | m_clrTextSelectedHighlighted
Color of text for tabs in all non-active groups of tabs in MDITabClient.
CXTPPaintManagerColor m_clrTextDisabled
Color of text when a tab is disabled.
CXTPPaintManagerColor | m_clrActiveFilesGlyph
Color of navigation button.
CXTPPaintManagerColor | m_clrActiveFilesGlyphHighlighted
Color of highlighted navigation button.
CXTPPaintManagerColor | m_clrActiveFilesGlyphPressed
Color of selected navigation button.
CXTPPaintManagerColor | m_clrActiveFilesBack
Color of highlighted navigation button background.
CXTPPaintManagerColor | m_clrActiveFilesBackHighlighted
Color of navigation button background.
CXTPPaintManagerColor | m_clrActiveFilesBackPressed
Color of selected navigation button background.
COLORSET_TAB_STATEBUTTON | m_csStateButton
Color set of state button style tabs.
COLORSET_TAB_PROPERTYPAGE | m_csPropertyPage
Color set of visual studio style tabs.
COLORSET_TAB_PROPERTYPAGE2003 | m_csPropertyPage2003
Color set of Office 2003 style tabs.
COLORSET_TAB_EXCEL | m_csExcelSelected
Color set of selected (focused) Excel style tabs.
COLORSET_TAB_EXCEL | m_csExcelNormal
Color set of normal Excel style tabs.
- Protected Attributes inherited from CXTPTabPaintManagerColorSet
CXTPTabPaintManager * | m_pPaintManager
Self paint manager pointer.

Detailed Description

Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines.

Member Function Documentation

◆ FillHeader()

virtual void FillHeader | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | CXTPTabManager * | pTabManager )
 virtual

This member is called to fill the header of the TabClient of the tab manager.

Parameters
pDC | Pointer to a valid device context.
rc | Bounding rectangle of the tab header.
pTabManager | Fill the header of this CXTPTabManager object.

The TabClient header is the bounding rectangle with tab buttons. The bounding rectangle can be retrieved with the CXTPTabPaintManagerTheme::GetHeaderRect, and CXTPTabManager::GetHeaderRect members.

See also
CXTPTabPaintManagerTheme::GetHeaderRect, CXTPTabManager::GetHeaderRect

Reimplemented from CXTPDockingPaneTabColorSet2012.

The documentation for this class was generated from the following file:
  • XTPDockingPaneTabColorSet2015.h


Toolkit Pro: CXTPDockingPaneTabColorSet2017 Class Reference

Public Member Functions | List of all members
CXTPDockingPaneTabColorSet2017 Class Reference

Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines. More...

Inheritance diagram for CXTPDockingPaneTabColorSet2017:
[legend]

Public Member Functions

CXTPDockingPaneTabColorSet2017 ()
Default class constructor.
virtual void | FillHeader (CDC *pDC, CRect rc, CXTPTabManager *pTabManager)
This member is called to fill the header of the TabClient of the tab manager.
- Public Member Functions inherited from CXTPDockingPaneTabColorSet2012
CXTPDockingPaneTabColorSet2012 ()
Default class constructor.
virtual void | RefreshMetrics ()
This member function is used to initialize default colors for a theme from an .INI resource.
virtual COLORREF | GetItemColor (CXTPTabManagerItem *pItem)
Call this member function to retrieve the color for the tab specified by pItem.
virtual void | FillNavigateButton (CDC *pDC, CXTPTabManagerNavigateButton *pButton, CRect &rc)
This member is called to fill the tab navigation buttons.
- Public Member Functions inherited from CXTPTabPaintManagerColorSet
CXTPTabPaintManagerColorSet ()
Constructs a CXTPTabPaintManagerColorSet object.
virtual | ~CXTPTabPaintManagerColorSet ()
Destroys a CXTPTabPaintManagerColorSet object, handles cleanup and deallocation.
virtual void | SetTextColor (CDC *pDC, CXTPTabManagerItem *pItem)
Sets the text color for the tab.
virtual COLORREF | FillClient (CDC *pDC, CRect rc, CXTPTabManager *pTabManager)
Fills the tab client area of a specified tab manager.
virtual COLORREF | GetClientColor (CXTPTabManager *pTabManager)
Obtains client background color.
virtual void | FillStateButton (CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem)
Fills a specified tab button when XTPTabAppearanceStyle is xtpTabAppearanceStateButtons.
virtual COLORREF | FillPropertyButton (CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem)
Fills a specified tab button.
virtual void | SelectClipRgn (CDC *pDC, CRect rcClient, CXTPTabManager *pTabManager)
Sets a clipping region for the specified tab client area.
void | GradientFill (CDC *pDC, CRect rc, COLORREF clrLight, COLORREF clrDark, XTPTabPosition position)
Performs a gradient fill of a rectangle with a color that smoothly fades from top to bottom.
virtual BOOL | IsAppThemed () const
Determines if Windows XP themes are enabled and if a Windows XP theme is currently used.

Additional Inherited Members

- Public Attributes inherited from CXTPTabPaintManagerColorSet
CXTPPaintManagerColorGradient | m_clrHeaderFace
Color set of the tab header background.
CXTPPaintManagerColorGradient m_clrAutoHideFace
Color set of the auto-hide panel background.
CXTPPaintManagerColor | m_clrFrameBorder
Color of the border placed around the tab buttons and the tab client.
CXTPPaintManagerColor m_clrControlFace
Color of the control foreground.
CXTPPaintManagerColor | m_clrPaneFace
Color of the control pane foreground.
CXTPPaintManagerColor | m_clrBorderHighlight
Color of the highlight border.
CXTPPaintManagerColor | m_clrTabClientBack
Background color for the tab client area.
CXTPPaintManagerColor | m_clrTabClientBorder
Border color for the tab client area.
CXTPPaintManagerColor m_clrButtonNormal
Color of normal tabs.
CXTPPaintManagerColor | m_clrButtonPressed
Tab pressed button color.
CXTPPaintManagerColor | m_clrButtonHighlighted
Tab button color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonHighlightedClose
Tab close button color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonBorderHighlighted
Tab button border color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonBorderTabContext1
Tab button border color with tab context.
CXTPPaintManagerColor | m_clrButtonBorderTabContext2
Tab button border color with tab context.
CXTPPaintManagerColor | m_clrButtonBorderKeyTips
Tab button border color when ALT button is pressed.
CXTPPaintManagerColor | m_clrButtonSelected
Color of the currently selected tab.
CXTPPaintManagerColor | m_clrButtonSelectedPressed
Color of the currently selected tab when pressed.
CXTPPaintManagerColor | m_clrButtonSelectedHighlighted
Color of the currently selected tab when highlighted.
CXTPPaintManagerColor | m_clrButtonBorder
Tab button border (edge) color.
CXTPPaintManagerColor | m_clrButtonBorderHot
Tab button highlight or pressed border (edge) color.
CXTPPaintManagerColor m_clrTextNormal
Color of text in a normal tab.
CXTPPaintManagerColor m_clrTextPressed
Color of text in a "pressed" tab button.
CXTPPaintManagerColor | m_clrTextHighlight
Color of text on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrTextHighlightClose
Color of close button text on mouse over when hot tracking is enabled.
CXTPPaintManagerColor m_clrTextSelected
Color of text in a "selected" tab button.
CXTPPaintManagerColor m_clrTextSelectedPressed
Color of text in a "pressed" tab button.
CXTPPaintManagerColor | m_clrTextSelectedHighlighted
Color of text for tabs in all non-active groups of tabs in MDITabClient.
CXTPPaintManagerColor m_clrTextDisabled
Color of text when a tab is disabled.
CXTPPaintManagerColor | m_clrActiveFilesGlyph
Color of navigation button.
CXTPPaintManagerColor | m_clrActiveFilesGlyphHighlighted
Color of highlighted navigation button.
CXTPPaintManagerColor | m_clrActiveFilesGlyphPressed
Color of selected navigation button.
CXTPPaintManagerColor | m_clrActiveFilesBack
Color of highlighted navigation button background.
CXTPPaintManagerColor | m_clrActiveFilesBackHighlighted
Color of navigation button background.
CXTPPaintManagerColor | m_clrActiveFilesBackPressed
Color of selected navigation button background.
COLORSET_TAB_STATEBUTTON | m_csStateButton
Color set of state button style tabs.
COLORSET_TAB_PROPERTYPAGE | m_csPropertyPage
Color set of visual studio style tabs.
COLORSET_TAB_PROPERTYPAGE2003 | m_csPropertyPage2003
Color set of Office 2003 style tabs.
COLORSET_TAB_EXCEL | m_csExcelSelected
Color set of selected (focused) Excel style tabs.
COLORSET_TAB_EXCEL | m_csExcelNormal
Color set of normal Excel style tabs.
- Protected Attributes inherited from CXTPTabPaintManagerColorSet
CXTPTabPaintManager * | m_pPaintManager
Self paint manager pointer.

Detailed Description

Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines.

Member Function Documentation

◆ FillHeader()

virtual void FillHeader | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | CXTPTabManager * | pTabManager )
 virtual

This member is called to fill the header of the TabClient of the tab manager.

Parameters
pDC | Pointer to a valid device context.
rc | Bounding rectangle of the tab header.
pTabManager | Fill the header of this CXTPTabManager object.

The TabClient header is the bounding rectangle with tab buttons. The bounding rectangle can be retrieved with the CXTPTabPaintManagerTheme::GetHeaderRect, and CXTPTabManager::GetHeaderRect members.

See also
CXTPTabPaintManagerTheme::GetHeaderRect, CXTPTabManager::GetHeaderRect

Reimplemented from CXTPDockingPaneTabColorSet2012.

The documentation for this class was generated from the following file:
  • XTPDockingPaneTabColorSet2017.h


Toolkit Pro: CXTPDockingPaneTabColorSet2019 Class Reference

Public Member Functions | List of all members
CXTPDockingPaneTabColorSet2019 Class Reference

Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines. More...

Inheritance diagram for CXTPDockingPaneTabColorSet2019:
[legend]

Public Member Functions

CXTPDockingPaneTabColorSet2019 ()
Default class constructor.
virtual void | FillHeader (CDC *pDC, CRect rc, CXTPTabManager *pTabManager)
This member is called to fill the header of the TabClient of the tab manager.
- Public Member Functions inherited from CXTPDockingPaneTabColorSet2012
CXTPDockingPaneTabColorSet2012 ()
Default class constructor.
virtual void | RefreshMetrics ()
This member function is used to initialize default colors for a theme from an .INI resource.
virtual COLORREF | GetItemColor (CXTPTabManagerItem *pItem)
Call this member function to retrieve the color for the tab specified by pItem.
virtual void | FillNavigateButton (CDC *pDC, CXTPTabManagerNavigateButton *pButton, CRect &rc)
This member is called to fill the tab navigation buttons.
- Public Member Functions inherited from CXTPTabPaintManagerColorSet
CXTPTabPaintManagerColorSet ()
Constructs a CXTPTabPaintManagerColorSet object.
virtual | ~CXTPTabPaintManagerColorSet ()
Destroys a CXTPTabPaintManagerColorSet object, handles cleanup and deallocation.
virtual void | SetTextColor (CDC *pDC, CXTPTabManagerItem *pItem)
Sets the text color for the tab.
virtual COLORREF | FillClient (CDC *pDC, CRect rc, CXTPTabManager *pTabManager)
Fills the tab client area of a specified tab manager.
virtual COLORREF | GetClientColor (CXTPTabManager *pTabManager)
Obtains client background color.
virtual void | FillStateButton (CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem)
Fills a specified tab button when XTPTabAppearanceStyle is xtpTabAppearanceStateButtons.
virtual COLORREF | FillPropertyButton (CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem)
Fills a specified tab button.
virtual void | SelectClipRgn (CDC *pDC, CRect rcClient, CXTPTabManager *pTabManager)
Sets a clipping region for the specified tab client area.
void | GradientFill (CDC *pDC, CRect rc, COLORREF clrLight, COLORREF clrDark, XTPTabPosition position)
Performs a gradient fill of a rectangle with a color that smoothly fades from top to bottom.
virtual BOOL | IsAppThemed () const
Determines if Windows XP themes are enabled and if a Windows XP theme is currently used.

Additional Inherited Members

- Public Attributes inherited from CXTPTabPaintManagerColorSet
CXTPPaintManagerColorGradient | m_clrHeaderFace
Color set of the tab header background.
CXTPPaintManagerColorGradient m_clrAutoHideFace
Color set of the auto-hide panel background.
CXTPPaintManagerColor | m_clrFrameBorder
Color of the border placed around the tab buttons and the tab client.
CXTPPaintManagerColor m_clrControlFace
Color of the control foreground.
CXTPPaintManagerColor | m_clrPaneFace
Color of the control pane foreground.
CXTPPaintManagerColor | m_clrBorderHighlight
Color of the highlight border.
CXTPPaintManagerColor | m_clrTabClientBack
Background color for the tab client area.
CXTPPaintManagerColor | m_clrTabClientBorder
Border color for the tab client area.
CXTPPaintManagerColor m_clrButtonNormal
Color of normal tabs.
CXTPPaintManagerColor | m_clrButtonPressed
Tab pressed button color.
CXTPPaintManagerColor | m_clrButtonHighlighted
Tab button color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonHighlightedClose
Tab close button color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonBorderHighlighted
Tab button border color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonBorderTabContext1
Tab button border color with tab context.
CXTPPaintManagerColor | m_clrButtonBorderTabContext2
Tab button border color with tab context.
CXTPPaintManagerColor | m_clrButtonBorderKeyTips
Tab button border color when ALT button is pressed.
CXTPPaintManagerColor | m_clrButtonSelected
Color of the currently selected tab.
CXTPPaintManagerColor | m_clrButtonSelectedPressed
Color of the currently selected tab when pressed.
CXTPPaintManagerColor | m_clrButtonSelectedHighlighted
Color of the currently selected tab when highlighted.
CXTPPaintManagerColor | m_clrButtonBorder
Tab button border (edge) color.
CXTPPaintManagerColor | m_clrButtonBorderHot
Tab button highlight or pressed border (edge) color.
CXTPPaintManagerColor m_clrTextNormal
Color of text in a normal tab.
CXTPPaintManagerColor m_clrTextPressed
Color of text in a "pressed" tab button.
CXTPPaintManagerColor | m_clrTextHighlight
Color of text on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrTextHighlightClose
Color of close button text on mouse over when hot tracking is enabled.
CXTPPaintManagerColor m_clrTextSelected
Color of text in a "selected" tab button.
CXTPPaintManagerColor m_clrTextSelectedPressed
Color of text in a "pressed" tab button.
CXTPPaintManagerColor | m_clrTextSelectedHighlighted
Color of text for tabs in all non-active groups of tabs in MDITabClient.
CXTPPaintManagerColor m_clrTextDisabled
Color of text when a tab is disabled.
CXTPPaintManagerColor | m_clrActiveFilesGlyph
Color of navigation button.
CXTPPaintManagerColor | m_clrActiveFilesGlyphHighlighted
Color of highlighted navigation button.
CXTPPaintManagerColor | m_clrActiveFilesGlyphPressed
Color of selected navigation button.
CXTPPaintManagerColor | m_clrActiveFilesBack
Color of highlighted navigation button background.
CXTPPaintManagerColor | m_clrActiveFilesBackHighlighted
Color of navigation button background.
CXTPPaintManagerColor | m_clrActiveFilesBackPressed
Color of selected navigation button background.
COLORSET_TAB_STATEBUTTON | m_csStateButton
Color set of state button style tabs.
COLORSET_TAB_PROPERTYPAGE | m_csPropertyPage
Color set of visual studio style tabs.
COLORSET_TAB_PROPERTYPAGE2003 | m_csPropertyPage2003
Color set of Office 2003 style tabs.
COLORSET_TAB_EXCEL | m_csExcelSelected
Color set of selected (focused) Excel style tabs.
COLORSET_TAB_EXCEL | m_csExcelNormal
Color set of normal Excel style tabs.
- Protected Attributes inherited from CXTPTabPaintManagerColorSet
CXTPTabPaintManager * | m_pPaintManager
Self paint manager pointer.

Detailed Description

Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines.

Member Function Documentation

◆ FillHeader()

virtual void FillHeader | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | CXTPTabManager * | pTabManager )
 virtual

This member is called to fill the header of the TabClient of the tab manager.

Parameters
pDC | Pointer to a valid device context.
rc | Bounding rectangle of the tab header.
pTabManager | Fill the header of this CXTPTabManager object.

The TabClient header is the bounding rectangle with tab buttons. The bounding rectangle can be retrieved with the CXTPTabPaintManagerTheme::GetHeaderRect, and CXTPTabManager::GetHeaderRect members.

See also
CXTPTabPaintManagerTheme::GetHeaderRect, CXTPTabManager::GetHeaderRect

Reimplemented from CXTPDockingPaneTabColorSet2012.

The documentation for this class was generated from the following file:
  • XTPDockingPaneTabColorSet2019.h


Toolkit Pro: CXTPDockingPaneTabColorSet2022 Class Reference

Public Member Functions | List of all members
CXTPDockingPaneTabColorSet2022 Class Reference

Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines. More...

Inheritance diagram for CXTPDockingPaneTabColorSet2022:
[legend]

Public Member Functions

CXTPDockingPaneTabColorSet2022 ()
Default class constructor.
virtual void | FillHeader (CDC *pDC, CRect rc, CXTPTabManager *pTabManager)
This member is called to fill the header of the TabClient of the tab manager.
- Public Member Functions inherited from CXTPDockingPaneTabColorSet2012
CXTPDockingPaneTabColorSet2012 ()
Default class constructor.
virtual void | RefreshMetrics ()
This member function is used to initialize default colors for a theme from an .INI resource.
virtual COLORREF | GetItemColor (CXTPTabManagerItem *pItem)
Call this member function to retrieve the color for the tab specified by pItem.
virtual void | FillNavigateButton (CDC *pDC, CXTPTabManagerNavigateButton *pButton, CRect &rc)
This member is called to fill the tab navigation buttons.
- Public Member Functions inherited from CXTPTabPaintManagerColorSet
CXTPTabPaintManagerColorSet ()
Constructs a CXTPTabPaintManagerColorSet object.
virtual | ~CXTPTabPaintManagerColorSet ()
Destroys a CXTPTabPaintManagerColorSet object, handles cleanup and deallocation.
virtual void | SetTextColor (CDC *pDC, CXTPTabManagerItem *pItem)
Sets the text color for the tab.
virtual COLORREF | FillClient (CDC *pDC, CRect rc, CXTPTabManager *pTabManager)
Fills the tab client area of a specified tab manager.
virtual COLORREF | GetClientColor (CXTPTabManager *pTabManager)
Obtains client background color.
virtual void | FillStateButton (CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem)
Fills a specified tab button when XTPTabAppearanceStyle is xtpTabAppearanceStateButtons.
virtual COLORREF | FillPropertyButton (CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem)
Fills a specified tab button.
virtual void | SelectClipRgn (CDC *pDC, CRect rcClient, CXTPTabManager *pTabManager)
Sets a clipping region for the specified tab client area.
void | GradientFill (CDC *pDC, CRect rc, COLORREF clrLight, COLORREF clrDark, XTPTabPosition position)
Performs a gradient fill of a rectangle with a color that smoothly fades from top to bottom.
virtual BOOL | IsAppThemed () const
Determines if Windows XP themes are enabled and if a Windows XP theme is currently used.

Additional Inherited Members

- Public Attributes inherited from CXTPTabPaintManagerColorSet
CXTPPaintManagerColorGradient | m_clrHeaderFace
Color set of the tab header background.
CXTPPaintManagerColorGradient m_clrAutoHideFace
Color set of the auto-hide panel background.
CXTPPaintManagerColor | m_clrFrameBorder
Color of the border placed around the tab buttons and the tab client.
CXTPPaintManagerColor m_clrControlFace
Color of the control foreground.
CXTPPaintManagerColor | m_clrPaneFace
Color of the control pane foreground.
CXTPPaintManagerColor | m_clrBorderHighlight
Color of the highlight border.
CXTPPaintManagerColor | m_clrTabClientBack
Background color for the tab client area.
CXTPPaintManagerColor | m_clrTabClientBorder
Border color for the tab client area.
CXTPPaintManagerColor m_clrButtonNormal
Color of normal tabs.
CXTPPaintManagerColor | m_clrButtonPressed
Tab pressed button color.
CXTPPaintManagerColor | m_clrButtonHighlighted
Tab button color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonHighlightedClose
Tab close button color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonBorderHighlighted
Tab button border color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonBorderTabContext1
Tab button border color with tab context.
CXTPPaintManagerColor | m_clrButtonBorderTabContext2
Tab button border color with tab context.
CXTPPaintManagerColor | m_clrButtonBorderKeyTips
Tab button border color when ALT button is pressed.
CXTPPaintManagerColor | m_clrButtonSelected
Color of the currently selected tab.
CXTPPaintManagerColor | m_clrButtonSelectedPressed
Color of the currently selected tab when pressed.
CXTPPaintManagerColor | m_clrButtonSelectedHighlighted
Color of the currently selected tab when highlighted.
CXTPPaintManagerColor | m_clrButtonBorder
Tab button border (edge) color.
CXTPPaintManagerColor | m_clrButtonBorderHot
Tab button highlight or pressed border (edge) color.
CXTPPaintManagerColor m_clrTextNormal
Color of text in a normal tab.
CXTPPaintManagerColor m_clrTextPressed
Color of text in a "pressed" tab button.
CXTPPaintManagerColor | m_clrTextHighlight
Color of text on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrTextHighlightClose
Color of close button text on mouse over when hot tracking is enabled.
CXTPPaintManagerColor m_clrTextSelected
Color of text in a "selected" tab button.
CXTPPaintManagerColor m_clrTextSelectedPressed
Color of text in a "pressed" tab button.
CXTPPaintManagerColor | m_clrTextSelectedHighlighted
Color of text for tabs in all non-active groups of tabs in MDITabClient.
CXTPPaintManagerColor m_clrTextDisabled
Color of text when a tab is disabled.
CXTPPaintManagerColor | m_clrActiveFilesGlyph
Color of navigation button.
CXTPPaintManagerColor | m_clrActiveFilesGlyphHighlighted
Color of highlighted navigation button.
CXTPPaintManagerColor | m_clrActiveFilesGlyphPressed
Color of selected navigation button.
CXTPPaintManagerColor | m_clrActiveFilesBack
Color of highlighted navigation button background.
CXTPPaintManagerColor | m_clrActiveFilesBackHighlighted
Color of navigation button background.
CXTPPaintManagerColor | m_clrActiveFilesBackPressed
Color of selected navigation button background.
COLORSET_TAB_STATEBUTTON | m_csStateButton
Color set of state button style tabs.
COLORSET_TAB_PROPERTYPAGE | m_csPropertyPage
Color set of visual studio style tabs.
COLORSET_TAB_PROPERTYPAGE2003 | m_csPropertyPage2003
Color set of Office 2003 style tabs.
COLORSET_TAB_EXCEL | m_csExcelSelected
Color set of selected (focused) Excel style tabs.
COLORSET_TAB_EXCEL | m_csExcelNormal
Color set of normal Excel style tabs.
- Protected Attributes inherited from CXTPTabPaintManagerColorSet
CXTPTabPaintManager * | m_pPaintManager
Self paint manager pointer.

Detailed Description

Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines.

Member Function Documentation

◆ FillHeader()

virtual void FillHeader | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | CXTPTabManager * | pTabManager )
 virtual

This member is called to fill the header of the TabClient of the tab manager.

Parameters
pDC | Pointer to a valid device context.
rc | Bounding rectangle of the tab header.
pTabManager | Fill the header of this CXTPTabManager object.

The TabClient header is the bounding rectangle with tab buttons. The bounding rectangle can be retrieved with the CXTPTabPaintManagerTheme::GetHeaderRect, and CXTPTabManager::GetHeaderRect members.

See also
CXTPTabPaintManagerTheme::GetHeaderRect, CXTPTabManager::GetHeaderRect

Reimplemented from CXTPDockingPaneTabColorSet2012.

The documentation for this class was generated from the following file:
  • XTPDockingPaneTabColorSet2022.h


Toolkit Pro: CXTPDockingPaneTabColorSetNativeWindows10 Class Reference

Public Member Functions | List of all members
CXTPDockingPaneTabColorSetNativeWindows10 Class Reference

Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines. More...

Inheritance diagram for CXTPDockingPaneTabColorSetNativeWindows10:
[legend]

Public Member Functions

CXTPDockingPaneTabColorSetNativeWindows10 ()
Default class constructor.
virtual void | FillHeader (CDC *pDC, CRect rc, CXTPTabManager *pTabManager)
This member is called to fill the header of the TabClient of the tab manager.
- Public Member Functions inherited from CXTPDockingPaneTabColorSet2012
CXTPDockingPaneTabColorSet2012 ()
Default class constructor.
virtual void | RefreshMetrics ()
This member function is used to initialize default colors for a theme from an .INI resource.
virtual COLORREF | GetItemColor (CXTPTabManagerItem *pItem)
Call this member function to retrieve the color for the tab specified by pItem.
virtual void | FillNavigateButton (CDC *pDC, CXTPTabManagerNavigateButton *pButton, CRect &rc)
This member is called to fill the tab navigation buttons.
- Public Member Functions inherited from CXTPTabPaintManagerColorSet
CXTPTabPaintManagerColorSet ()
Constructs a CXTPTabPaintManagerColorSet object.
virtual | ~CXTPTabPaintManagerColorSet ()
Destroys a CXTPTabPaintManagerColorSet object, handles cleanup and deallocation.
virtual void | SetTextColor (CDC *pDC, CXTPTabManagerItem *pItem)
Sets the text color for the tab.
virtual COLORREF | FillClient (CDC *pDC, CRect rc, CXTPTabManager *pTabManager)
Fills the tab client area of a specified tab manager.
virtual COLORREF | GetClientColor (CXTPTabManager *pTabManager)
Obtains client background color.
virtual void | FillStateButton (CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem)
Fills a specified tab button when XTPTabAppearanceStyle is xtpTabAppearanceStateButtons.
virtual COLORREF | FillPropertyButton (CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem)
Fills a specified tab button.
virtual void | SelectClipRgn (CDC *pDC, CRect rcClient, CXTPTabManager *pTabManager)
Sets a clipping region for the specified tab client area.
void | GradientFill (CDC *pDC, CRect rc, COLORREF clrLight, COLORREF clrDark, XTPTabPosition position)
Performs a gradient fill of a rectangle with a color that smoothly fades from top to bottom.
virtual BOOL | IsAppThemed () const
Determines if Windows XP themes are enabled and if a Windows XP theme is currently used.

Additional Inherited Members

- Public Attributes inherited from CXTPTabPaintManagerColorSet
CXTPPaintManagerColorGradient | m_clrHeaderFace
Color set of the tab header background.
CXTPPaintManagerColorGradient m_clrAutoHideFace
Color set of the auto-hide panel background.
CXTPPaintManagerColor | m_clrFrameBorder
Color of the border placed around the tab buttons and the tab client.
CXTPPaintManagerColor m_clrControlFace
Color of the control foreground.
CXTPPaintManagerColor | m_clrPaneFace
Color of the control pane foreground.
CXTPPaintManagerColor | m_clrBorderHighlight
Color of the highlight border.
CXTPPaintManagerColor | m_clrTabClientBack
Background color for the tab client area.
CXTPPaintManagerColor | m_clrTabClientBorder
Border color for the tab client area.
CXTPPaintManagerColor m_clrButtonNormal
Color of normal tabs.
CXTPPaintManagerColor | m_clrButtonPressed
Tab pressed button color.
CXTPPaintManagerColor | m_clrButtonHighlighted
Tab button color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonHighlightedClose
Tab close button color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonBorderHighlighted
Tab button border color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonBorderTabContext1
Tab button border color with tab context.
CXTPPaintManagerColor | m_clrButtonBorderTabContext2
Tab button border color with tab context.
CXTPPaintManagerColor | m_clrButtonBorderKeyTips
Tab button border color when ALT button is pressed.
CXTPPaintManagerColor | m_clrButtonSelected
Color of the currently selected tab.
CXTPPaintManagerColor | m_clrButtonSelectedPressed
Color of the currently selected tab when pressed.
CXTPPaintManagerColor | m_clrButtonSelectedHighlighted
Color of the currently selected tab when highlighted.
CXTPPaintManagerColor | m_clrButtonBorder
Tab button border (edge) color.
CXTPPaintManagerColor | m_clrButtonBorderHot
Tab button highlight or pressed border (edge) color.
CXTPPaintManagerColor m_clrTextNormal
Color of text in a normal tab.
CXTPPaintManagerColor m_clrTextPressed
Color of text in a "pressed" tab button.
CXTPPaintManagerColor | m_clrTextHighlight
Color of text on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrTextHighlightClose
Color of close button text on mouse over when hot tracking is enabled.
CXTPPaintManagerColor m_clrTextSelected
Color of text in a "selected" tab button.
CXTPPaintManagerColor m_clrTextSelectedPressed
Color of text in a "pressed" tab button.
CXTPPaintManagerColor | m_clrTextSelectedHighlighted
Color of text for tabs in all non-active groups of tabs in MDITabClient.
CXTPPaintManagerColor m_clrTextDisabled
Color of text when a tab is disabled.
CXTPPaintManagerColor | m_clrActiveFilesGlyph
Color of navigation button.
CXTPPaintManagerColor | m_clrActiveFilesGlyphHighlighted
Color of highlighted navigation button.
CXTPPaintManagerColor | m_clrActiveFilesGlyphPressed
Color of selected navigation button.
CXTPPaintManagerColor | m_clrActiveFilesBack
Color of highlighted navigation button background.
CXTPPaintManagerColor | m_clrActiveFilesBackHighlighted
Color of navigation button background.
CXTPPaintManagerColor | m_clrActiveFilesBackPressed
Color of selected navigation button background.
COLORSET_TAB_STATEBUTTON | m_csStateButton
Color set of state button style tabs.
COLORSET_TAB_PROPERTYPAGE | m_csPropertyPage
Color set of visual studio style tabs.
COLORSET_TAB_PROPERTYPAGE2003 | m_csPropertyPage2003
Color set of Office 2003 style tabs.
COLORSET_TAB_EXCEL | m_csExcelSelected
Color set of selected (focused) Excel style tabs.
COLORSET_TAB_EXCEL | m_csExcelNormal
Color set of normal Excel style tabs.
- Protected Attributes inherited from CXTPTabPaintManagerColorSet
CXTPTabPaintManager * | m_pPaintManager
Self paint manager pointer.

Detailed Description

Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines.

Member Function Documentation

◆ FillHeader()

virtual void FillHeader | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | CXTPTabManager * | pTabManager )
 virtual

This member is called to fill the header of the TabClient of the tab manager.

Parameters
pDC | Pointer to a valid device context.
rc | Bounding rectangle of the tab header.
pTabManager | Fill the header of this CXTPTabManager object.

The TabClient header is the bounding rectangle with tab buttons. The bounding rectangle can be retrieved with the CXTPTabPaintManagerTheme::GetHeaderRect, and CXTPTabManager::GetHeaderRect members.

See also
CXTPTabPaintManagerTheme::GetHeaderRect, CXTPTabManager::GetHeaderRect

Reimplemented from CXTPDockingPaneTabColorSet2012.

The documentation for this class was generated from the following file:
  • XTPDockingPaneTabColorSetNativeWindows10.h


Toolkit Pro: CXTPDockingPaneTabColorSetNativeWindows11 Class Reference

Public Member Functions | List of all members
CXTPDockingPaneTabColorSetNativeWindows11 Class Reference

Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines. More...

Inheritance diagram for CXTPDockingPaneTabColorSetNativeWindows11:
[legend]

Public Member Functions

CXTPDockingPaneTabColorSetNativeWindows11 ()
Default class constructor.
virtual void | FillHeader (CDC *pDC, CRect rc, CXTPTabManager *pTabManager)
This member is called to fill the header of the TabClient of the tab manager.
- Public Member Functions inherited from CXTPDockingPaneTabColorSet2012
CXTPDockingPaneTabColorSet2012 ()
Default class constructor.
virtual void | RefreshMetrics ()
This member function is used to initialize default colors for a theme from an .INI resource.
virtual COLORREF | GetItemColor (CXTPTabManagerItem *pItem)
Call this member function to retrieve the color for the tab specified by pItem.
virtual void | FillNavigateButton (CDC *pDC, CXTPTabManagerNavigateButton *pButton, CRect &rc)
This member is called to fill the tab navigation buttons.
- Public Member Functions inherited from CXTPTabPaintManagerColorSet
CXTPTabPaintManagerColorSet ()
Constructs a CXTPTabPaintManagerColorSet object.
virtual | ~CXTPTabPaintManagerColorSet ()
Destroys a CXTPTabPaintManagerColorSet object, handles cleanup and deallocation.
virtual void | SetTextColor (CDC *pDC, CXTPTabManagerItem *pItem)
Sets the text color for the tab.
virtual COLORREF | FillClient (CDC *pDC, CRect rc, CXTPTabManager *pTabManager)
Fills the tab client area of a specified tab manager.
virtual COLORREF | GetClientColor (CXTPTabManager *pTabManager)
Obtains client background color.
virtual void | FillStateButton (CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem)
Fills a specified tab button when XTPTabAppearanceStyle is xtpTabAppearanceStateButtons.
virtual COLORREF | FillPropertyButton (CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem)
Fills a specified tab button.
virtual void | SelectClipRgn (CDC *pDC, CRect rcClient, CXTPTabManager *pTabManager)
Sets a clipping region for the specified tab client area.
void | GradientFill (CDC *pDC, CRect rc, COLORREF clrLight, COLORREF clrDark, XTPTabPosition position)
Performs a gradient fill of a rectangle with a color that smoothly fades from top to bottom.
virtual BOOL | IsAppThemed () const
Determines if Windows XP themes are enabled and if a Windows XP theme is currently used.

Additional Inherited Members

- Public Attributes inherited from CXTPTabPaintManagerColorSet
CXTPPaintManagerColorGradient | m_clrHeaderFace
Color set of the tab header background.
CXTPPaintManagerColorGradient m_clrAutoHideFace
Color set of the auto-hide panel background.
CXTPPaintManagerColor | m_clrFrameBorder
Color of the border placed around the tab buttons and the tab client.
CXTPPaintManagerColor m_clrControlFace
Color of the control foreground.
CXTPPaintManagerColor | m_clrPaneFace
Color of the control pane foreground.
CXTPPaintManagerColor | m_clrBorderHighlight
Color of the highlight border.
CXTPPaintManagerColor | m_clrTabClientBack
Background color for the tab client area.
CXTPPaintManagerColor | m_clrTabClientBorder
Border color for the tab client area.
CXTPPaintManagerColor m_clrButtonNormal
Color of normal tabs.
CXTPPaintManagerColor | m_clrButtonPressed
Tab pressed button color.
CXTPPaintManagerColor | m_clrButtonHighlighted
Tab button color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonHighlightedClose
Tab close button color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonBorderHighlighted
Tab button border color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonBorderTabContext1
Tab button border color with tab context.
CXTPPaintManagerColor | m_clrButtonBorderTabContext2
Tab button border color with tab context.
CXTPPaintManagerColor | m_clrButtonBorderKeyTips
Tab button border color when ALT button is pressed.
CXTPPaintManagerColor | m_clrButtonSelected
Color of the currently selected tab.
CXTPPaintManagerColor | m_clrButtonSelectedPressed
Color of the currently selected tab when pressed.
CXTPPaintManagerColor | m_clrButtonSelectedHighlighted
Color of the currently selected tab when highlighted.
CXTPPaintManagerColor | m_clrButtonBorder
Tab button border (edge) color.
CXTPPaintManagerColor | m_clrButtonBorderHot
Tab button highlight or pressed border (edge) color.
CXTPPaintManagerColor m_clrTextNormal
Color of text in a normal tab.
CXTPPaintManagerColor m_clrTextPressed
Color of text in a "pressed" tab button.
CXTPPaintManagerColor | m_clrTextHighlight
Color of text on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrTextHighlightClose
Color of close button text on mouse over when hot tracking is enabled.
CXTPPaintManagerColor m_clrTextSelected
Color of text in a "selected" tab button.
CXTPPaintManagerColor m_clrTextSelectedPressed
Color of text in a "pressed" tab button.
CXTPPaintManagerColor | m_clrTextSelectedHighlighted
Color of text for tabs in all non-active groups of tabs in MDITabClient.
CXTPPaintManagerColor m_clrTextDisabled
Color of text when a tab is disabled.
CXTPPaintManagerColor | m_clrActiveFilesGlyph
Color of navigation button.
CXTPPaintManagerColor | m_clrActiveFilesGlyphHighlighted
Color of highlighted navigation button.
CXTPPaintManagerColor | m_clrActiveFilesGlyphPressed
Color of selected navigation button.
CXTPPaintManagerColor | m_clrActiveFilesBack
Color of highlighted navigation button background.
CXTPPaintManagerColor | m_clrActiveFilesBackHighlighted
Color of navigation button background.
CXTPPaintManagerColor | m_clrActiveFilesBackPressed
Color of selected navigation button background.
COLORSET_TAB_STATEBUTTON | m_csStateButton
Color set of state button style tabs.
COLORSET_TAB_PROPERTYPAGE | m_csPropertyPage
Color set of visual studio style tabs.
COLORSET_TAB_PROPERTYPAGE2003 | m_csPropertyPage2003
Color set of Office 2003 style tabs.
COLORSET_TAB_EXCEL | m_csExcelSelected
Color set of selected (focused) Excel style tabs.
COLORSET_TAB_EXCEL | m_csExcelNormal
Color set of normal Excel style tabs.
- Protected Attributes inherited from CXTPTabPaintManagerColorSet
CXTPTabPaintManager * | m_pPaintManager
Self paint manager pointer.

Detailed Description

Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines.

Member Function Documentation

◆ FillHeader()

virtual void FillHeader | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | CXTPTabManager * | pTabManager )
 virtual

This member is called to fill the header of the TabClient of the tab manager.

Parameters
pDC | Pointer to a valid device context.
rc | Bounding rectangle of the tab header.
pTabManager | Fill the header of this CXTPTabManager object.

The TabClient header is the bounding rectangle with tab buttons. The bounding rectangle can be retrieved with the CXTPTabPaintManagerTheme::GetHeaderRect, and CXTPTabManager::GetHeaderRect members.

See also
CXTPTabPaintManagerTheme::GetHeaderRect, CXTPTabManager::GetHeaderRect

Reimplemented from CXTPDockingPaneTabColorSet2012.

The documentation for this class was generated from the following file:
  • XTPDockingPaneTabColorSetNativeWindows11.h


Toolkit Pro: CXTPDockingPaneTabColorSetOfficePanel Class Reference

Public Member Functions | List of all members
CXTPDockingPaneTabColorSetOfficePanel Class Reference

Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines. More...

Inheritance diagram for CXTPDockingPaneTabColorSetOfficePanel:
[legend]

Public Member Functions

CXTPDockingPaneTabColorSetOfficePanel ()
Default class constructor.
virtual void | RefreshMetrics ()
This member function is used to initialize default colors for a theme from an .INI resource.
- Public Member Functions inherited from CXTPDockingPaneTabColorSetVisualStudio2003
CXTPDockingPaneTabColorSetVisualStudio2003 (BOOL bHighlightSelected)
Default class constructor.
void | RefreshMetrics ()
This member function is used to initialize default colors for a theme from an .INI resource.
void | FillFramePartRect (CDC *pDC, CRect rc, CWnd *pWnd, CWnd *pSite)
This member is used to paint the specified frame portion for a docking pane tab.
void | FillHeader (CDC *pDC, CRect rc, CXTPTabManager *pTabManager)
This member is used to paint the specified header portion for a docking pane tab.
virtual COLORREF | FillPropertyButton (CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem)
This member is called to fill a tab button.
- Public Member Functions inherited from CXTPTabColorSetOffice2003
virtual void | FillNavigateButton (CDC *pDC, CXTPTabManagerNavigateButton *pButton, CRect &rc)
Fills a specified tab navigation button.
void | Rectangle (CDC *pDC, CRect rc, int nPen, int nBrush)
Draws a rectangle with a border.
- Public Member Functions inherited from CXTPTabColorSetDefault
- Public Member Functions inherited from CXTPTabPaintManagerColorSet
CXTPTabPaintManagerColorSet ()
Constructs a CXTPTabPaintManagerColorSet object.
virtual | ~CXTPTabPaintManagerColorSet ()
Destroys a CXTPTabPaintManagerColorSet object, handles cleanup and deallocation.
virtual void | SetTextColor (CDC *pDC, CXTPTabManagerItem *pItem)
Sets the text color for the tab.
virtual COLORREF | FillClient (CDC *pDC, CRect rc, CXTPTabManager *pTabManager)
Fills the tab client area of a specified tab manager.
virtual COLORREF | GetClientColor (CXTPTabManager *pTabManager)
Obtains client background color.
virtual void | FillStateButton (CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem)
Fills a specified tab button when XTPTabAppearanceStyle is xtpTabAppearanceStateButtons.
virtual void | SelectClipRgn (CDC *pDC, CRect rcClient, CXTPTabManager *pTabManager)
Sets a clipping region for the specified tab client area.
virtual COLORREF | GetItemColor (CXTPTabManagerItem *pItem)
Retrieves the color of a specified tab.
void | GradientFill (CDC *pDC, CRect rc, COLORREF clrLight, COLORREF clrDark, XTPTabPosition position)
Performs a gradient fill of a rectangle with a color that smoothly fades from top to bottom.
virtual BOOL | IsAppThemed () const
Determines if Windows XP themes are enabled and if a Windows XP theme is currently used.

Additional Inherited Members

- Public Attributes inherited from CXTPTabPaintManagerColorSet
CXTPPaintManagerColorGradient | m_clrHeaderFace
Color set of the tab header background.
CXTPPaintManagerColorGradient m_clrAutoHideFace
Color set of the auto-hide panel background.
CXTPPaintManagerColor | m_clrFrameBorder
Color of the border placed around the tab buttons and the tab client.
CXTPPaintManagerColor m_clrControlFace
Color of the control foreground.
CXTPPaintManagerColor | m_clrPaneFace
Color of the control pane foreground.
CXTPPaintManagerColor | m_clrBorderHighlight
Color of the highlight border.
CXTPPaintManagerColor | m_clrTabClientBack
Background color for the tab client area.
CXTPPaintManagerColor | m_clrTabClientBorder
Border color for the tab client area.
CXTPPaintManagerColor m_clrButtonNormal
Color of normal tabs.
CXTPPaintManagerColor | m_clrButtonPressed
Tab pressed button color.
CXTPPaintManagerColor | m_clrButtonHighlighted
Tab button color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonHighlightedClose
Tab close button color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonBorderHighlighted
Tab button border color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonBorderTabContext1
Tab button border color with tab context.
CXTPPaintManagerColor | m_clrButtonBorderTabContext2
Tab button border color with tab context.
CXTPPaintManagerColor | m_clrButtonBorderKeyTips
Tab button border color when ALT button is pressed.
CXTPPaintManagerColor | m_clrButtonSelected
Color of the currently selected tab.
CXTPPaintManagerColor | m_clrButtonSelectedPressed
Color of the currently selected tab when pressed.
CXTPPaintManagerColor | m_clrButtonSelectedHighlighted
Color of the currently selected tab when highlighted.
CXTPPaintManagerColor | m_clrButtonBorder
Tab button border (edge) color.
CXTPPaintManagerColor | m_clrButtonBorderHot
Tab button highlight or pressed border (edge) color.
CXTPPaintManagerColor m_clrTextNormal
Color of text in a normal tab.
CXTPPaintManagerColor m_clrTextPressed
Color of text in a "pressed" tab button.
CXTPPaintManagerColor | m_clrTextHighlight
Color of text on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrTextHighlightClose
Color of close button text on mouse over when hot tracking is enabled.
CXTPPaintManagerColor m_clrTextSelected
Color of text in a "selected" tab button.
CXTPPaintManagerColor m_clrTextSelectedPressed
Color of text in a "pressed" tab button.
CXTPPaintManagerColor | m_clrTextSelectedHighlighted
Color of text for tabs in all non-active groups of tabs in MDITabClient.
CXTPPaintManagerColor m_clrTextDisabled
Color of text when a tab is disabled.
CXTPPaintManagerColor | m_clrActiveFilesGlyph
Color of navigation button.
CXTPPaintManagerColor | m_clrActiveFilesGlyphHighlighted
Color of highlighted navigation button.
CXTPPaintManagerColor | m_clrActiveFilesGlyphPressed
Color of selected navigation button.
CXTPPaintManagerColor | m_clrActiveFilesBack
Color of highlighted navigation button background.
CXTPPaintManagerColor | m_clrActiveFilesBackHighlighted
Color of navigation button background.
CXTPPaintManagerColor | m_clrActiveFilesBackPressed
Color of selected navigation button background.
COLORSET_TAB_STATEBUTTON | m_csStateButton
Color set of state button style tabs.
COLORSET_TAB_PROPERTYPAGE | m_csPropertyPage
Color set of visual studio style tabs.
COLORSET_TAB_PROPERTYPAGE2003 | m_csPropertyPage2003
Color set of Office 2003 style tabs.
COLORSET_TAB_EXCEL | m_csExcelSelected
Color set of selected (focused) Excel style tabs.
COLORSET_TAB_EXCEL | m_csExcelNormal
Color set of normal Excel style tabs.
- Protected Attributes inherited from CXTPDockingPaneTabColorSetVisualStudio2003
- Protected Attributes inherited from CXTPTabColorSetOffice2003
CXTPPaintManagerColor | m_clrNavigateButtonBorder
Border color of tab navigation buttons on mouse over.
BOOL | m_bLunaTheme
TRUE if the current system theme is xtpSystemThemeSilver, xtpSystemThemeOlive or xtpSystemThemeOlive, otherwise FALSE.
- Protected Attributes inherited from CXTPTabPaintManagerColorSet
CXTPTabPaintManager * | m_pPaintManager
Self paint manager pointer.

Detailed Description

Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines.

The documentation for this class was generated from the following file:
  • XTPDockingPaneTabColorSetOfficePanel.h


Toolkit Pro: CXTPDockingPaneTabColorSetVisualStudio2003 Class Reference

Public Member Functions | List of all members
CXTPDockingPaneTabColorSetVisualStudio2003 Class Reference

Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines. More...

Inheritance diagram for CXTPDockingPaneTabColorSetVisualStudio2003:
[legend]

Public Member Functions

CXTPDockingPaneTabColorSetVisualStudio2003 (BOOL bHighlightSelected)
Default class constructor.
void | RefreshMetrics ()
This member function is used to initialize default colors for a theme from an .INI resource.
void | FillFramePartRect (CDC *pDC, CRect rc, CWnd *pWnd, CWnd *pSite)
This member is used to paint the specified frame portion for a docking pane tab.
void | FillHeader (CDC *pDC, CRect rc, CXTPTabManager *pTabManager)
This member is used to paint the specified header portion for a docking pane tab.
virtual COLORREF | FillPropertyButton (CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem)
This member is called to fill a tab button.
- Public Member Functions inherited from CXTPTabColorSetOffice2003
virtual void | FillNavigateButton (CDC *pDC, CXTPTabManagerNavigateButton *pButton, CRect &rc)
Fills a specified tab navigation button.
void | Rectangle (CDC *pDC, CRect rc, int nPen, int nBrush)
Draws a rectangle with a border.
- Public Member Functions inherited from CXTPTabColorSetDefault
- Public Member Functions inherited from CXTPTabPaintManagerColorSet
CXTPTabPaintManagerColorSet ()
Constructs a CXTPTabPaintManagerColorSet object.
virtual | ~CXTPTabPaintManagerColorSet ()
Destroys a CXTPTabPaintManagerColorSet object, handles cleanup and deallocation.
virtual void | SetTextColor (CDC *pDC, CXTPTabManagerItem *pItem)
Sets the text color for the tab.
virtual COLORREF | FillClient (CDC *pDC, CRect rc, CXTPTabManager *pTabManager)
Fills the tab client area of a specified tab manager.
virtual COLORREF | GetClientColor (CXTPTabManager *pTabManager)
Obtains client background color.
virtual void | FillStateButton (CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem)
Fills a specified tab button when XTPTabAppearanceStyle is xtpTabAppearanceStateButtons.
virtual void | SelectClipRgn (CDC *pDC, CRect rcClient, CXTPTabManager *pTabManager)
Sets a clipping region for the specified tab client area.
virtual COLORREF | GetItemColor (CXTPTabManagerItem *pItem)
Retrieves the color of a specified tab.
void | GradientFill (CDC *pDC, CRect rc, COLORREF clrLight, COLORREF clrDark, XTPTabPosition position)
Performs a gradient fill of a rectangle with a color that smoothly fades from top to bottom.
virtual BOOL | IsAppThemed () const
Determines if Windows XP themes are enabled and if a Windows XP theme is currently used.

Additional Inherited Members

- Public Attributes inherited from CXTPTabPaintManagerColorSet
CXTPPaintManagerColorGradient | m_clrHeaderFace
Color set of the tab header background.
CXTPPaintManagerColorGradient m_clrAutoHideFace
Color set of the auto-hide panel background.
CXTPPaintManagerColor | m_clrFrameBorder
Color of the border placed around the tab buttons and the tab client.
CXTPPaintManagerColor m_clrControlFace
Color of the control foreground.
CXTPPaintManagerColor | m_clrPaneFace
Color of the control pane foreground.
CXTPPaintManagerColor | m_clrBorderHighlight
Color of the highlight border.
CXTPPaintManagerColor | m_clrTabClientBack
Background color for the tab client area.
CXTPPaintManagerColor | m_clrTabClientBorder
Border color for the tab client area.
CXTPPaintManagerColor m_clrButtonNormal
Color of normal tabs.
CXTPPaintManagerColor | m_clrButtonPressed
Tab pressed button color.
CXTPPaintManagerColor | m_clrButtonHighlighted
Tab button color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonHighlightedClose
Tab close button color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonBorderHighlighted
Tab button border color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonBorderTabContext1
Tab button border color with tab context.
CXTPPaintManagerColor | m_clrButtonBorderTabContext2
Tab button border color with tab context.
CXTPPaintManagerColor | m_clrButtonBorderKeyTips
Tab button border color when ALT button is pressed.
CXTPPaintManagerColor | m_clrButtonSelected
Color of the currently selected tab.
CXTPPaintManagerColor | m_clrButtonSelectedPressed
Color of the currently selected tab when pressed.
CXTPPaintManagerColor | m_clrButtonSelectedHighlighted
Color of the currently selected tab when highlighted.
CXTPPaintManagerColor | m_clrButtonBorder
Tab button border (edge) color.
CXTPPaintManagerColor | m_clrButtonBorderHot
Tab button highlight or pressed border (edge) color.
CXTPPaintManagerColor m_clrTextNormal
Color of text in a normal tab.
CXTPPaintManagerColor m_clrTextPressed
Color of text in a "pressed" tab button.
CXTPPaintManagerColor | m_clrTextHighlight
Color of text on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrTextHighlightClose
Color of close button text on mouse over when hot tracking is enabled.
CXTPPaintManagerColor m_clrTextSelected
Color of text in a "selected" tab button.
CXTPPaintManagerColor m_clrTextSelectedPressed
Color of text in a "pressed" tab button.
CXTPPaintManagerColor | m_clrTextSelectedHighlighted
Color of text for tabs in all non-active groups of tabs in MDITabClient.
CXTPPaintManagerColor m_clrTextDisabled
Color of text when a tab is disabled.
CXTPPaintManagerColor | m_clrActiveFilesGlyph
Color of navigation button.
CXTPPaintManagerColor | m_clrActiveFilesGlyphHighlighted
Color of highlighted navigation button.
CXTPPaintManagerColor | m_clrActiveFilesGlyphPressed
Color of selected navigation button.
CXTPPaintManagerColor | m_clrActiveFilesBack
Color of highlighted navigation button background.
CXTPPaintManagerColor | m_clrActiveFilesBackHighlighted
Color of navigation button background.
CXTPPaintManagerColor | m_clrActiveFilesBackPressed
Color of selected navigation button background.
COLORSET_TAB_STATEBUTTON | m_csStateButton
Color set of state button style tabs.
COLORSET_TAB_PROPERTYPAGE | m_csPropertyPage
Color set of visual studio style tabs.
COLORSET_TAB_PROPERTYPAGE2003 | m_csPropertyPage2003
Color set of Office 2003 style tabs.
COLORSET_TAB_EXCEL | m_csExcelSelected
Color set of selected (focused) Excel style tabs.
COLORSET_TAB_EXCEL | m_csExcelNormal
Color set of normal Excel style tabs.
- Protected Attributes inherited from CXTPTabColorSetOffice2003
CXTPPaintManagerColor | m_clrNavigateButtonBorder
Border color of tab navigation buttons on mouse over.
BOOL | m_bLunaTheme
TRUE if the current system theme is xtpSystemThemeSilver, xtpSystemThemeOlive or xtpSystemThemeOlive, otherwise FALSE.
- Protected Attributes inherited from CXTPTabPaintManagerColorSet
CXTPTabPaintManager * | m_pPaintManager
Self paint manager pointer.

Detailed Description

Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines.

Constructor & Destructor Documentation

◆ CXTPDockingPaneTabColorSetVisualStudio2003()

CXTPDockingPaneTabColorSetVisualStudio2003 ( BOOL bHighlightSelected )

Default class constructor.

Parameters
bHighlightSelected TRUE if the tab is selected.

Member Function Documentation

◆ FillFramePartRect()

void FillFramePartRect | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | CWnd * | pWnd,
 |  | CWnd * | pSite )

This member is used to paint the specified frame portion for a docking pane tab.

Parameters
pDC | Pointer to a valid device context.
rc | Size of the area to draw.
pWnd | Pointer to a valid CWnd object.
pSite | Pointer to a valid CWnd object.

◆ FillHeader()

void FillHeader | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | CXTPTabManager * | pTabManager )
 virtual

This member is used to paint the specified header portion for a docking pane tab.

Parameters
pDC | Pointer to a valid device context.
rc | Size of the area to draw.
pTabManager | Pointer to a valid CXTPTabManager object.

Reimplemented from CXTPTabPaintManagerColorSet.

◆ FillPropertyButton()

virtual COLORREF FillPropertyButton | ( | CDC * | pDC,
 |  | CRect | rcItem,
 |  | CXTPTabManagerItem * | pItem )
 virtual

This member is called to fill a tab button.

Parameters
pDC | Pointer to a valid device context.
rcItem | Bounding rectangle of the tab button to fill.
pItem | Tab button to draw.
Returns
COLORREF returned from CXTPTabManager::GetItemColor(pItem).

This member is used to fill all tab buttons except when the XTPTabAppearanceStyle is xtpTabAppearanceStateButtons. xtpTabAppearanceStateButtons require the FillStateButton member.

Tab buttons will use CXTPTabPaintManagerColorSet::GradientFill to fill the buttons. The gradient will use the color of the tab item blended with RGB(255, 255, 255) to produce a "light color". The gradient will start with the "light color" and fill to the normal color of the tab item.

See also
FillStateButton

Reimplemented from CXTPTabColorSetOffice2003.

The documentation for this class was generated from the following file:
  • XTPDockingPaneTabColorSetVisualStudio2003.h


Toolkit Pro: CXTPDockingPaneTabColorSetVisualStudio2005 Class Reference

Public Member Functions | List of all members
CXTPDockingPaneTabColorSetVisualStudio2005 Class Reference

Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines. More...

Inheritance diagram for CXTPDockingPaneTabColorSetVisualStudio2005:
[legend]

Public Member Functions

CXTPDockingPaneTabColorSetVisualStudio2005 (BOOL bHighlightSelected)
Default class constructor.
void | RefreshMetrics ()
This member function is used to initialize default colors for a theme from an .INI resource.
- Public Member Functions inherited from CXTPDockingPaneTabColorSetVisualStudio2003
CXTPDockingPaneTabColorSetVisualStudio2003 (BOOL bHighlightSelected)
Default class constructor.
void | FillFramePartRect (CDC *pDC, CRect rc, CWnd *pWnd, CWnd *pSite)
This member is used to paint the specified frame portion for a docking pane tab.
void | FillHeader (CDC *pDC, CRect rc, CXTPTabManager *pTabManager)
This member is used to paint the specified header portion for a docking pane tab.
virtual COLORREF | FillPropertyButton (CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem)
This member is called to fill a tab button.
- Public Member Functions inherited from CXTPTabColorSetOffice2003
virtual void | FillNavigateButton (CDC *pDC, CXTPTabManagerNavigateButton *pButton, CRect &rc)
Fills a specified tab navigation button.
void | Rectangle (CDC *pDC, CRect rc, int nPen, int nBrush)
Draws a rectangle with a border.
- Public Member Functions inherited from CXTPTabColorSetDefault
- Public Member Functions inherited from CXTPTabPaintManagerColorSet
CXTPTabPaintManagerColorSet ()
Constructs a CXTPTabPaintManagerColorSet object.
virtual | ~CXTPTabPaintManagerColorSet ()
Destroys a CXTPTabPaintManagerColorSet object, handles cleanup and deallocation.
virtual void | SetTextColor (CDC *pDC, CXTPTabManagerItem *pItem)
Sets the text color for the tab.
virtual COLORREF | FillClient (CDC *pDC, CRect rc, CXTPTabManager *pTabManager)
Fills the tab client area of a specified tab manager.
virtual COLORREF | GetClientColor (CXTPTabManager *pTabManager)
Obtains client background color.
virtual void | FillStateButton (CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem)
Fills a specified tab button when XTPTabAppearanceStyle is xtpTabAppearanceStateButtons.
virtual void | SelectClipRgn (CDC *pDC, CRect rcClient, CXTPTabManager *pTabManager)
Sets a clipping region for the specified tab client area.
virtual COLORREF | GetItemColor (CXTPTabManagerItem *pItem)
Retrieves the color of a specified tab.
void | GradientFill (CDC *pDC, CRect rc, COLORREF clrLight, COLORREF clrDark, XTPTabPosition position)
Performs a gradient fill of a rectangle with a color that smoothly fades from top to bottom.
virtual BOOL | IsAppThemed () const
Determines if Windows XP themes are enabled and if a Windows XP theme is currently used.

Additional Inherited Members

- Public Attributes inherited from CXTPTabPaintManagerColorSet
CXTPPaintManagerColorGradient | m_clrHeaderFace
Color set of the tab header background.
CXTPPaintManagerColorGradient m_clrAutoHideFace
Color set of the auto-hide panel background.
CXTPPaintManagerColor | m_clrFrameBorder
Color of the border placed around the tab buttons and the tab client.
CXTPPaintManagerColor m_clrControlFace
Color of the control foreground.
CXTPPaintManagerColor | m_clrPaneFace
Color of the control pane foreground.
CXTPPaintManagerColor | m_clrBorderHighlight
Color of the highlight border.
CXTPPaintManagerColor | m_clrTabClientBack
Background color for the tab client area.
CXTPPaintManagerColor | m_clrTabClientBorder
Border color for the tab client area.
CXTPPaintManagerColor m_clrButtonNormal
Color of normal tabs.
CXTPPaintManagerColor | m_clrButtonPressed
Tab pressed button color.
CXTPPaintManagerColor | m_clrButtonHighlighted
Tab button color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonHighlightedClose
Tab close button color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonBorderHighlighted
Tab button border color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonBorderTabContext1
Tab button border color with tab context.
CXTPPaintManagerColor | m_clrButtonBorderTabContext2
Tab button border color with tab context.
CXTPPaintManagerColor | m_clrButtonBorderKeyTips
Tab button border color when ALT button is pressed.
CXTPPaintManagerColor | m_clrButtonSelected
Color of the currently selected tab.
CXTPPaintManagerColor | m_clrButtonSelectedPressed
Color of the currently selected tab when pressed.
CXTPPaintManagerColor | m_clrButtonSelectedHighlighted
Color of the currently selected tab when highlighted.
CXTPPaintManagerColor | m_clrButtonBorder
Tab button border (edge) color.
CXTPPaintManagerColor | m_clrButtonBorderHot
Tab button highlight or pressed border (edge) color.
CXTPPaintManagerColor m_clrTextNormal
Color of text in a normal tab.
CXTPPaintManagerColor m_clrTextPressed
Color of text in a "pressed" tab button.
CXTPPaintManagerColor | m_clrTextHighlight
Color of text on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrTextHighlightClose
Color of close button text on mouse over when hot tracking is enabled.
CXTPPaintManagerColor m_clrTextSelected
Color of text in a "selected" tab button.
CXTPPaintManagerColor m_clrTextSelectedPressed
Color of text in a "pressed" tab button.
CXTPPaintManagerColor | m_clrTextSelectedHighlighted
Color of text for tabs in all non-active groups of tabs in MDITabClient.
CXTPPaintManagerColor m_clrTextDisabled
Color of text when a tab is disabled.
CXTPPaintManagerColor | m_clrActiveFilesGlyph
Color of navigation button.
CXTPPaintManagerColor | m_clrActiveFilesGlyphHighlighted
Color of highlighted navigation button.
CXTPPaintManagerColor | m_clrActiveFilesGlyphPressed
Color of selected navigation button.
CXTPPaintManagerColor | m_clrActiveFilesBack
Color of highlighted navigation button background.
CXTPPaintManagerColor | m_clrActiveFilesBackHighlighted
Color of navigation button background.
CXTPPaintManagerColor | m_clrActiveFilesBackPressed
Color of selected navigation button background.
COLORSET_TAB_STATEBUTTON | m_csStateButton
Color set of state button style tabs.
COLORSET_TAB_PROPERTYPAGE | m_csPropertyPage
Color set of visual studio style tabs.
COLORSET_TAB_PROPERTYPAGE2003 | m_csPropertyPage2003
Color set of Office 2003 style tabs.
COLORSET_TAB_EXCEL | m_csExcelSelected
Color set of selected (focused) Excel style tabs.
COLORSET_TAB_EXCEL | m_csExcelNormal
Color set of normal Excel style tabs.
- Protected Attributes inherited from CXTPDockingPaneTabColorSetVisualStudio2003
- Protected Attributes inherited from CXTPTabColorSetOffice2003
CXTPPaintManagerColor | m_clrNavigateButtonBorder
Border color of tab navigation buttons on mouse over.
BOOL | m_bLunaTheme
TRUE if the current system theme is xtpSystemThemeSilver, xtpSystemThemeOlive or xtpSystemThemeOlive, otherwise FALSE.
- Protected Attributes inherited from CXTPTabPaintManagerColorSet
CXTPTabPaintManager * | m_pPaintManager
Self paint manager pointer.

Detailed Description

Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines.

Constructor & Destructor Documentation

◆ CXTPDockingPaneTabColorSetVisualStudio2005()

CXTPDockingPaneTabColorSetVisualStudio2005 ( BOOL bHighlightSelected )

Default class constructor.

Parameters
bHighlightSelected TRUE if the tab is selected.
The documentation for this class was generated from the following file:
  • XTPDockingPaneTabColorSetVisualStudio2005.h


Toolkit Pro: CXTPDockingPaneTabPaintManager Class Reference

Public Member Functions | List of all members
CXTPDockingPaneTabPaintManager Class Reference

CXTPDockingPaneTabPaintManager is a CXTPTabPaintManager derived class that is used to store the color and appearance information of the tabs in the tab manager. More...

Inheritance diagram for CXTPDockingPaneTabPaintManager:
[legend]

Public Member Functions

virtual CXTPTabPaintManagerColorSet * | SetColor (XTPTabColorStyle tabColor)
Call this member to apply one of the "built-in" color sets to the tabs.
virtual CXTPTabPaintManagerTheme * | SetAppearance (XTPTabAppearanceStyle tabAppearance)
Call this member to apply one of the "built-in" appearances to the tabs.
- Public Member Functions inherited from CXTPTabPaintManager
CXTPTabPaintManager (BOOL bPanelManager=FALSE)
Constructs a CXTPTabPaintManager object.
virtual | ~CXTPTabPaintManager ()
Destroys a CXTPTabPaintManager object, handles cleanup and deallocation.
virtual CXTPTabPaintManagerColorSet * | SetColorSet (CXTPTabPaintManagerColorSet *pColorSet)
Applies a custom color set for the tabs.
virtual CXTPTabPaintManagerTheme * | SetAppearanceSet (CXTPTabPaintManagerTheme *pAppearanceSet)
Applies a custom appearance set for the tabs.
CXTPTabPaintManagerTheme * | GetAppearanceSet () const
Gets the currently applied custom appearance set.
CXTPTabPaintManagerColorSet * | GetColorSet () const
Gets the currently applied custom color set.
XTPTabAppearanceStyle | GetAppearance () const
Gets the currently applied "built-in appearance set.
XTPTabColorStyle | GetColor () const
Gets the currently applied "built-in" color set.
BOOL | IsLunaColorsDisabled () const
Determines if luna colors are disabled/enabled.
void | DisableLunaColors (BOOL bDisableLunaColors)
Disables/enables luna colors.
void | SetOneNoteColors (BOOL bOneNoteColors)
Enables/disables OneNote colorization for the tabs.
void | SetPosition (XTPTabPosition tabPosition)
Sets the tab position.
void | SetLayout (XTPTabLayoutStyle tabLayout)
Sets the tab layout style.
XTPTabPosition | GetPosition () const
Gets the tab position.
XTPTabLayoutStyle | GetLayout () const
Gets the tab layout style.
void | SetFontIndirect (LOGFONT *pLogFont, BOOL bUseStandardFont=FALSE)
Sets the font for the tabs.
virtual void | DrawTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl)
Draws the tab control.
virtual void | AdjustClientRect (CXTPTabManager *pTabManager, CRect &rcClient)
Adjusts the tab client rectangle.
virtual void | RepositionTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl)
Moves the tab buttons of the tab control to their correct positions.
CRect | RepositionNavigateButtons (CXTPTabManager *pTabManager, CRect rcClient)
Repositions the tab navigation buttons.
void | FillNavigateButton (CDC *pDC, CXTPTabManagerNavigateButton *pButton, CRect &rc)
Fills a specified tab navigation button.
virtual void | DrawNavigateButton (CDC *pDC, CXTPTabManagerNavigateButton *pButton, CRect &rc)
Draws a specified tab navigation button.
virtual int | DrawSingleButtonIconAndText (CDC *pDC, CXTPTabManagerItem *pItem, CRect rcItem, BOOL bDraw)
Draws the text and icon of a specified tab button.
void | EnsureVisible (CXTPTabManager *pTabManager, CXTPTabManagerItem *pItem)
Ensures that a specified tab is visible.
virtual void | RefreshMetrics ()
Refreshes the visual metrics of the main tab manager.
void | AddObserver (CXTPTabManagerAtom *pObserver)
Adds a control to the list of controls that receives a notification when a property of the paint manager is changed.
void | EnableToolTips (XTPTabToolTipBehaviour behaviour=xtpTabToolTipAlways)
Sets the behaviour for tooltips.
CFont * | GetFont (BOOL bVertical=FALSE)
Gets the font used to display caption text in the tab buttons.
CFont * | GetBoldFont (BOOL bVertical=FALSE)
Gets the font used to display bold caption text in the tab buttons.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPTabPaintManager
static COLORREF AFX_CDECL | GetOneNoteColor (XTPTabOneNoteColor tabColor)
Retrieves the RGB value of a specified OneNote color.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPTabPaintManager
BOOL | m_bHotTracking
If TRUE, then tab hot tracking will be enabled.
BOOL | m_bShowIcons
If TRUE, then tab icons will be drawn if icons were added.
BOOL | m_bBoldSelected
If TRUE, then the text of selected tabs will be displayed in bold font.
BOOL | m_bBoldNormal
If TRUE, then bold font will be used for all tabs regardless of whether they are selected or non-selected.
BOOL | m_bOneNoteColors
If FALSE, then tabs will not use luna colors * the current theme uses luna colors.
XTPTabClientFrame m_clientFrame
If TRUE, then tabs will use OneNote colorization.
BOOL | m_bStaticFrame
If TRUE, then a static frame will be drawn around the entire tab area.
CRect | m_rcClientMargin
Margin around the tab client area.
CRect | m_rcControlMargin
Margin around the entire tab control (i.e.
CRect | m_rcButtonMargin
Margin around the text in tab button.
CRect | m_rcButtonTextPadding
Margin around the text in tab button.
BOOL | m_bInvertGradient
If TRUE, then the colors passed into CXTPTabPaintManagerColorSet::GradientFill will be swapped before the rectangle is filled with the gradient.
BOOL | m_bFillBackground
If TRUE, then the tab client space is filled using CXTPTabPaintManager.CXTPTabPaintManagerColorSet.m_clrControlFace color.
CSize | m_szIcon
Size of the icon displayed in the tab button.
BOOL | m_bDrawTextPathEllipsis
If TRUE, when the size of a tab button is too small to display the caption, the middle of the caption will be replaced with an ellipse "...".
BOOL | m_bDrawTextEndEllipsis
If TRUE, when the size of a tab button is too small to display the caption, the end of the caption will be replaced with an ellipse "...".
BOOL | m_bDrawTextNoPrefix
If FALSE, then an ampersand '&' in the tab button caption will be ignored and a double ampersand '&&' will display a single ampersand '&'.
UINT | m_nDrawTextFormat
Text format for tabs (default - DT_LEFT | DT_VCENTER).
BOOL | m_bDrawTextHidePrefix
If FALSE, then an ampersand '&' in the tab button caption will be ignored and a double ampersand '&&' will display a single ampersand '&'.
BOOL | m_bMultiRowFixedSelection
FALSE to move row with selected item close to client pane.
BOOL | m_bMultiRowJustified
TRUE to stretch each row of tabs to fill the entire width of the control.
BOOL | m_bDrawFocusRect
TRUE to draw focus rect for focused item.
int | m_bSelectOnDragOver
1 - to activate tab when user drag files/text under it.
int | m_nButtonExtraLength
Additional padding of tabs.
BOOL | m_bSelectOnButtonDown
If TRUE, then tab selected on mouse button down.
BOOL | m_bClearTypeTextQuality
TRUE to enable ClearType text for the font.
BOOL | m_bRotateImageOnVerticalDraw
TRUE to rotate image when tab located left or right.
BOOL | m_bClipHeader
TRUE to select clip rectangle before draw tabs.
CSize | m_szNavigateButton
Navigate buttons size.
CSize | m_szTabCloseButton
Tab close button size.
BOOL | m_bShowTabs
TRUE to show tabs.
BOOL | m_bMultiRowTabsOptimization
TRUE if the tab manager will arrange tabs according to their widths.
int | m_nMinTabWidth
Minimum tabs width.
int | m_nMaxTabWidth
Maximum tabs width.
int | m_nFixedTabWidth
Tabs width for fixed layout.
XTPTabToolTipBehaviour | m_toolBehaviour
Tootips behaviour.
BOOL | m_bVerticalTextTopToBottom
Draw vertical text Top-to-Bottom or Bottom-to-Top.
BOOL | m_bPanelManager
TRUE indicates that this is a panel manager, FALSE for tab manager.
- Static Public Attributes inherited from CXTPTabPaintManager
static DWORD | m_nSelectOnDragOverDelay
Delay before Select-on-Drag-Over (300 by default).
- Protected Member Functions inherited from CXTPTabPaintManager
void | SizeToFit (CXTPTabManager *pTabManager, int nWidth)
Changes the tab button size when XTPTabLayoutStyle is set to xtpTabLayoutSizeToFit.
void | DrawTabControlEx (CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl)
Draws the tab control.
void | RepositionTabControlEx (CXTPTabManager *pTabManager, CDC *pDC, CRect rcClient)
Moves the tab buttons of the tab control to their correct positions.
void | RepositionTabControlMultiRow (CXTPTabManager *pTabManager, CDC *pDC, CRect rcClient)
Moves the tab buttons of the multi-row tab control to their correct positions.
virtual void | OnPropertyChanged ()
This method is called when a property of the tab paint manager is changed.
int | _GetButtonLength (int nValue, int nMin, int nMax)
Gets the total button length of a tab button including the left and right button margins.
void | DrawTextPathEllipsis (CDC *pDC, CXTPTabManager *pManager, const CString &strItem, CRect rcItem, UINT uFormat)
Draws an ellipse "..." in the middle of a specified string.
- Protected Attributes inherited from CXTPTabPaintManager
CXTPTabPaintManagerTheme * | m_pAppearanceSet
Currently set CXTPTabPaintManagerTheme.
CXTPTabPaintManagerColorSet * | m_pColorSet
Currently used CXTPTabPaintManagerColorSet.
CArray< CXTPTabManagerAtom *, CXTPTabManagerAtom * > | m_arrObservers
List of controls that receive a notification when a property of the paint manager has changed.
XTPTabAppearanceStyle | m_tabAppearance
Currently set appearance style.
XTPTabColorStyle | m_tabColor
Currently used color style.
XTPTabPosition m_tabPosition
Currently set tab button position.
XTPTabLayoutStyle m_tabLayout
Currently set tab button layout.
CXTPFont | m_xtpFontNormal
Font used to display text in tab buttons.
CXTPFont m_xtpFontBold
Font used to display bold text in the tab buttons (i.e.
CXTPFont | m_xtpFontVerticalNormal
Font used to display tab button caption when the tab position is vertical.
CXTPFont m_xtpFontVerticalBold
Font used to display bold text in the tab buttons when the tab position is vertical (i.e.
BOOL | m_bUseStandardFont
TRUE to use standard system "icon" font (i.e.

Detailed Description

CXTPDockingPaneTabPaintManager is a CXTPTabPaintManager derived class that is used to store the color and appearance information of the tabs in the tab manager.

Member Function Documentation

◆ SetAppearance()

virtual CXTPTabPaintManagerTheme * SetAppearance ( XTPTabAppearanceStyle tabAppearance )
virtual

Call this member to apply one of the "built-in" appearances to the tabs.

Parameters
tabAppearance An XTPTabAppearanceStyle to apply to the tabs.
Returns
A pointer to the CXTPTabPaintManagerTheme object applied.

Use SetAppearance to apply a "Built-In" theme. To apply a custom theme, use the SetAppearanceSet member.

See also
XTPTabAppearanceStyle, SetAppearanceSet, GetAppearance, GetAppearanceSet, SetColor, GetColor, GetColorSet, SetColorSet

Reimplemented from CXTPTabPaintManager.

◆ SetColor()

virtual CXTPTabPaintManagerColorSet * SetColor ( XTPTabColorStyle tabColor )
virtual

Call this member to apply one of the "built-in" color sets to the tabs.

Parameters
tabColor An XTPTabColorStyle to apply to the tabs.
Returns
A pointer to the CXTPTabPaintManagerColorSet object applied.
See also
XTPTabColorStyle, SetColorSet, GetColor, GetColorSet, XTPTabAppearanceStyle, SetAppearanceSet, SetAppearance, GetAppearance, GetAppearanceSet

Reimplemented from CXTPTabPaintManager.

The documentation for this class was generated from the following file:
  • XTPDockingPanePaintManager.h


Toolkit Pro: CXTPDockingPaneTabTheme2012 Class Reference

Public Member Functions | List of all members
CXTPDockingPaneTabTheme2012 Class Reference

Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines. More...

Inheritance diagram for CXTPDockingPaneTabTheme2012:
[legend]

Public Member Functions

CXTPDockingPaneTabTheme2012 ()
Default class constructor.
virtual void | RefreshMetrics ()
This member function is used to initialize default colors for a theme from an .INI resource.
virtual void | DrawText (CDC *pDC, CXTPTabManager *pManager, const CString &str, LPRECT lpRect, UINT nFormat)
This method is called to draw text for the specified item.
virtual void | DrawSingleButton (CDC *pDC, CXTPTabManagerItem *pItem)
This method is called to draw a single tab button in the tab client header area.
- Public Member Functions inherited from CXTPTabThemeFlat
CXTPTabThemeFlat ()
Constructs a CXTPTabThemeFlat object.
virtual CRect | FillTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl)
Fills both the tab header and the tab client area and then draws the tab client frame.
virtual XTPTabColorStyle | GetDefaultColorSet ()
Gets the default value of the color set for this theme.
- Public Member Functions inherited from CXTPTabPaintManagerTheme
CXTPTabPaintManagerTheme ()
Constructs a CXTPTabPaintManagerTheme object.
virtual | ~CXTPTabPaintManagerTheme ()
Destroys a CXTPTabPaintManagerTheme object, handles cleanup and deallocation.
CXTPTabPaintManagerColorSet * | GetColorSet () const
Gets the color set.
virtual CRect | GetHeaderRect (CRect rcControl, CXTPTabManager *pTabManager)
Gets the bounding rectangle of the tab header area.
virtual CRect | GetHeaderClipBox (CDC *pDC, CXTPTabManager *pTabManager)
Gets the clip box of the tab header area.
int | GetHeaderHeight (CXTPTabManager *pTabManager)
Gets the height of the tab header area.
virtual CRect | GetClientRect (CRect rcControl, CXTPTabManager *pTabManager)
Gets the bounding rectangle of the tab client area.
virtual CRect | GetHeaderMargin ()
Gets the top, left, right, and bottom margins of the tab header.
virtual CRect | GetClientMargin ()
Gets the top, left, right, and bottom margins of the tab client area.
virtual int | GetButtonLength (CDC *pDC, CXTPTabManagerItem *pItem)
Retrieves the total length of a specified tab button including the left and right button margins.
virtual int | GetButtonHeight (const CXTPTabManager *pTabManager)
Retrieves the total height of the tab buttons within a specified tab manager including the top and bottom margins and the icon.
virtual CRect | GetButtonDrawRect (const CXTPTabManagerItem *pItem)
Retrieves the bounding rectangle of a specified drawing item.
virtual void | DrawTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl)
Draws the tab control.
virtual void | RepositionTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcClient)
Moves the tab buttons of the tab control to their correct positions.
virtual void | AdjustClientRect (CXTPTabManager *pTabManager, CRect &rcClient)
Adjusts the tab client rectangle.
virtual void | DrawWorkspacePart (CDC *pDC, LPRECT lpRect, XTPTabWorkspacePart workspacePart)
Draws a specified TabMDIClient TabWorkspace part.
virtual int | GetSupportedColorSets ()
Gets the supported color sets for this theme.
COLORREF | FillButton (CDC *pDC, CXTPTabManagerItem *pItem, LPPOINT pts, int nCount, XTPTabPosition tabPosition, BOOL bAbsolute=FALSE)
Draws a tab button within a specified polygon.

Additional Inherited Members

- Public Attributes inherited from CXTPTabPaintManagerTheme
CRect | m_rcHeaderMargin
CRect struct containing the left, top, right, and bottom.
int | m_nRowMargin
margins of the tab header.
- Protected Attributes inherited from CXTPTabPaintManagerTheme
int | m_nButtonHeight
Current tab button height (without margins).
CXTPTabPaintManager * | m_pPaintManager
Self paint manager pointer.
BOOL | m_bButtonsReverseZOrder
Draw buttons in right to left order.

Detailed Description

Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines.

Member Function Documentation

◆ DrawSingleButton()

virtual void DrawSingleButton | ( | CDC * | pDC,
 |  | CXTPTabManagerItem * | pItem )
 virtual

This method is called to draw a single tab button in the tab client header area.

Parameters
pDC | Pointer to a valid device context.
pItem | Tab button to draw.

This method will draw a single tab button. This method only draws the button, no text or icon is added.

DrawSingleButton calls CXTPTabPaintManager::DrawSingleButtonIconAndText after the button is drawn. This is called to draw the button's icon and text.

See also
CXTPTabPaintManager::DrawTabControlEx, CXTPTabPaintManager::DrawSingleButtonIconAndText

Reimplemented from CXTPTabThemeFlat.

Reimplemented in CXTPDockingPaneTabTheme2015, CXTPDockingPaneTabTheme2017, CXTPDockingPaneTabTheme2019, CXTPDockingPaneTabTheme2022, CXTPDockingPaneTabThemeNativeWindows10, and CXTPDockingPaneTabThemeNativeWindows11.

◆ DrawText()

virtual void DrawText | ( | CDC * | pDC,
 |  | CXTPTabManager * | pManager,
 |  | const CString & | str,
 |  | LPRECT | lpRect,
 |  | UINT | nFormat )
 virtual

This method is called to draw text for the specified item.

Parameters
pDC | Pointer to a valid device context.
pManager | Pointer to a valid CXTPTabManager object.
str | Text to render.
lpRect | Size of the text to render.
nFormat | Drawing format flags.

Reimplemented from CXTPTabPaintManagerTheme.

The documentation for this class was generated from the following file:
  • XTPDockingPaneTabTheme2012.h


Toolkit Pro: CXTPDockingPaneTabTheme2013 Class Reference

Public Member Functions | List of all members
CXTPDockingPaneTabTheme2013 Class Reference

Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines. More...

Inheritance diagram for CXTPDockingPaneTabTheme2013:
[legend]

Public Member Functions

CXTPDockingPaneTabTheme2013 ()
Default class constructor.
virtual void | RefreshMetrics ()
This member function is used to initialize default colors for a theme from an .INI resource.
virtual void | DrawSingleButton (CDC *pDC, CXTPTabManagerItem *pItem)
This method is called to draw a single tab button in the tab client header area.
- Public Member Functions inherited from CXTPTabThemeFlat
CXTPTabThemeFlat ()
Constructs a CXTPTabThemeFlat object.
virtual CRect | FillTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl)
Fills both the tab header and the tab client area and then draws the tab client frame.
virtual XTPTabColorStyle | GetDefaultColorSet ()
Gets the default value of the color set for this theme.
- Public Member Functions inherited from CXTPTabPaintManagerTheme
CXTPTabPaintManagerTheme ()
Constructs a CXTPTabPaintManagerTheme object.
virtual | ~CXTPTabPaintManagerTheme ()
Destroys a CXTPTabPaintManagerTheme object, handles cleanup and deallocation.
CXTPTabPaintManagerColorSet * | GetColorSet () const
Gets the color set.
virtual CRect | GetHeaderRect (CRect rcControl, CXTPTabManager *pTabManager)
Gets the bounding rectangle of the tab header area.
virtual CRect | GetHeaderClipBox (CDC *pDC, CXTPTabManager *pTabManager)
Gets the clip box of the tab header area.
int | GetHeaderHeight (CXTPTabManager *pTabManager)
Gets the height of the tab header area.
virtual CRect | GetClientRect (CRect rcControl, CXTPTabManager *pTabManager)
Gets the bounding rectangle of the tab client area.
virtual CRect | GetHeaderMargin ()
Gets the top, left, right, and bottom margins of the tab header.
virtual CRect | GetClientMargin ()
Gets the top, left, right, and bottom margins of the tab client area.
virtual int | GetButtonLength (CDC *pDC, CXTPTabManagerItem *pItem)
Retrieves the total length of a specified tab button including the left and right button margins.
virtual int | GetButtonHeight (const CXTPTabManager *pTabManager)
Retrieves the total height of the tab buttons within a specified tab manager including the top and bottom margins and the icon.
virtual CRect | GetButtonDrawRect (const CXTPTabManagerItem *pItem)
Retrieves the bounding rectangle of a specified drawing item.
virtual void | DrawTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl)
Draws the tab control.
virtual void | RepositionTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcClient)
Moves the tab buttons of the tab control to their correct positions.
virtual void | AdjustClientRect (CXTPTabManager *pTabManager, CRect &rcClient)
Adjusts the tab client rectangle.
virtual void | DrawWorkspacePart (CDC *pDC, LPRECT lpRect, XTPTabWorkspacePart workspacePart)
Draws a specified TabMDIClient TabWorkspace part.
virtual int | GetSupportedColorSets ()
Gets the supported color sets for this theme.
COLORREF | FillButton (CDC *pDC, CXTPTabManagerItem *pItem, LPPOINT pts, int nCount, XTPTabPosition tabPosition, BOOL bAbsolute=FALSE)
Draws a tab button within a specified polygon.
virtual void | DrawText (CDC *pDC, CXTPTabManager *pManager, const CString &str, LPRECT lpRect, UINT nFormat)
Draws the text of a specified item.

Additional Inherited Members

- Public Attributes inherited from CXTPTabPaintManagerTheme
CRect | m_rcHeaderMargin
CRect struct containing the left, top, right, and bottom.
int | m_nRowMargin
margins of the tab header.
- Protected Attributes inherited from CXTPTabPaintManagerTheme
int | m_nButtonHeight
Current tab button height (without margins).
CXTPTabPaintManager * | m_pPaintManager
Self paint manager pointer.
BOOL | m_bButtonsReverseZOrder
Draw buttons in right to left order.

Detailed Description

Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines.

Member Function Documentation

◆ DrawSingleButton()

virtual void DrawSingleButton | ( | CDC * | pDC,
 |  | CXTPTabManagerItem * | pItem )
 virtual

This method is called to draw a single tab button in the tab client header area.

Parameters
pDC | Pointer to a valid device context.
pItem | Tab button to draw.

This method will draw a single tab button. This method only draws the button, no text or icon is added.

DrawSingleButton calls CXTPTabPaintManager::DrawSingleButtonIconAndText after the button is drawn. This is called to draw the button's icon and text.

See also
CXTPTabPaintManager::DrawTabControlEx, CXTPTabPaintManager::DrawSingleButtonIconAndText

Reimplemented from CXTPTabThemeFlat.

The documentation for this class was generated from the following file:
  • XTPDockingPaneTabTheme2013.h


Toolkit Pro: CXTPDockingPaneTabTheme2015 Class Reference

Public Member Functions | List of all members
CXTPDockingPaneTabTheme2015 Class Reference

Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines. More...

Inheritance diagram for CXTPDockingPaneTabTheme2015:
[legend]

Public Member Functions

CXTPDockingPaneTabTheme2015 ()
Default class constructor.
virtual void | DrawSingleButton (CDC *pDC, CXTPTabManagerItem *pItem)
This method is called to draw a single tab button in the tab client header area.
- Public Member Functions inherited from CXTPDockingPaneTabTheme2012
CXTPDockingPaneTabTheme2012 ()
Default class constructor.
virtual void | RefreshMetrics ()
This member function is used to initialize default colors for a theme from an .INI resource.
virtual void | DrawText (CDC *pDC, CXTPTabManager *pManager, const CString &str, LPRECT lpRect, UINT nFormat)
This method is called to draw text for the specified item.
- Public Member Functions inherited from CXTPTabThemeFlat
CXTPTabThemeFlat ()
Constructs a CXTPTabThemeFlat object.
virtual CRect | FillTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl)
Fills both the tab header and the tab client area and then draws the tab client frame.
virtual XTPTabColorStyle | GetDefaultColorSet ()
Gets the default value of the color set for this theme.
- Public Member Functions inherited from CXTPTabPaintManagerTheme
CXTPTabPaintManagerTheme ()
Constructs a CXTPTabPaintManagerTheme object.
virtual | ~CXTPTabPaintManagerTheme ()
Destroys a CXTPTabPaintManagerTheme object, handles cleanup and deallocation.
CXTPTabPaintManagerColorSet * | GetColorSet () const
Gets the color set.
virtual CRect | GetHeaderRect (CRect rcControl, CXTPTabManager *pTabManager)
Gets the bounding rectangle of the tab header area.
virtual CRect | GetHeaderClipBox (CDC *pDC, CXTPTabManager *pTabManager)
Gets the clip box of the tab header area.
int | GetHeaderHeight (CXTPTabManager *pTabManager)
Gets the height of the tab header area.
virtual CRect | GetClientRect (CRect rcControl, CXTPTabManager *pTabManager)
Gets the bounding rectangle of the tab client area.
virtual CRect | GetHeaderMargin ()
Gets the top, left, right, and bottom margins of the tab header.
virtual CRect | GetClientMargin ()
Gets the top, left, right, and bottom margins of the tab client area.
virtual int | GetButtonLength (CDC *pDC, CXTPTabManagerItem *pItem)
Retrieves the total length of a specified tab button including the left and right button margins.
virtual int | GetButtonHeight (const CXTPTabManager *pTabManager)
Retrieves the total height of the tab buttons within a specified tab manager including the top and bottom margins and the icon.
virtual CRect | GetButtonDrawRect (const CXTPTabManagerItem *pItem)
Retrieves the bounding rectangle of a specified drawing item.
virtual void | DrawTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl)
Draws the tab control.
virtual void | RepositionTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcClient)
Moves the tab buttons of the tab control to their correct positions.
virtual void | AdjustClientRect (CXTPTabManager *pTabManager, CRect &rcClient)
Adjusts the tab client rectangle.
virtual void | DrawWorkspacePart (CDC *pDC, LPRECT lpRect, XTPTabWorkspacePart workspacePart)
Draws a specified TabMDIClient TabWorkspace part.
virtual int | GetSupportedColorSets ()
Gets the supported color sets for this theme.
COLORREF | FillButton (CDC *pDC, CXTPTabManagerItem *pItem, LPPOINT pts, int nCount, XTPTabPosition tabPosition, BOOL bAbsolute=FALSE)
Draws a tab button within a specified polygon.

Additional Inherited Members

- Public Attributes inherited from CXTPTabPaintManagerTheme
CRect | m_rcHeaderMargin
CRect struct containing the left, top, right, and bottom.
int | m_nRowMargin
margins of the tab header.
- Protected Attributes inherited from CXTPTabPaintManagerTheme
int | m_nButtonHeight
Current tab button height (without margins).
CXTPTabPaintManager * | m_pPaintManager
Self paint manager pointer.
BOOL | m_bButtonsReverseZOrder
Draw buttons in right to left order.

Detailed Description

Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines.

Member Function Documentation

◆ DrawSingleButton()

virtual void DrawSingleButton | ( | CDC * | pDC,
 |  | CXTPTabManagerItem * | pItem )
 virtual

This method is called to draw a single tab button in the tab client header area.

Parameters
pDC | Pointer to a valid device context.
pItem | Tab button to draw.

This method will draw a single tab button. This method only draws the button, no text or icon is added.

DrawSingleButton calls CXTPTabPaintManager::DrawSingleButtonIconAndText after the button is drawn. This is called to draw the button's icon and text.

See also
CXTPTabPaintManager::DrawTabControlEx, CXTPTabPaintManager::DrawSingleButtonIconAndText

Reimplemented from CXTPDockingPaneTabTheme2012.

The documentation for this class was generated from the following file:
  • XTPDockingPaneTabTheme2015.h


Toolkit Pro: CXTPDockingPaneTabTheme2017 Class Reference

Public Member Functions | List of all members
CXTPDockingPaneTabTheme2017 Class Reference

Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines. More...

Inheritance diagram for CXTPDockingPaneTabTheme2017:
[legend]

Public Member Functions

CXTPDockingPaneTabTheme2017 ()
Default class constructor.
virtual void | DrawSingleButton (CDC *pDC, CXTPTabManagerItem *pItem)
This method is called to draw a single tab button in the tab client header area.
- Public Member Functions inherited from CXTPDockingPaneTabTheme2012
CXTPDockingPaneTabTheme2012 ()
Default class constructor.
virtual void | RefreshMetrics ()
This member function is used to initialize default colors for a theme from an .INI resource.
virtual void | DrawText (CDC *pDC, CXTPTabManager *pManager, const CString &str, LPRECT lpRect, UINT nFormat)
This method is called to draw text for the specified item.
- Public Member Functions inherited from CXTPTabThemeFlat
CXTPTabThemeFlat ()
Constructs a CXTPTabThemeFlat object.
virtual CRect | FillTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl)
Fills both the tab header and the tab client area and then draws the tab client frame.
virtual XTPTabColorStyle | GetDefaultColorSet ()
Gets the default value of the color set for this theme.
- Public Member Functions inherited from CXTPTabPaintManagerTheme
CXTPTabPaintManagerTheme ()
Constructs a CXTPTabPaintManagerTheme object.
virtual | ~CXTPTabPaintManagerTheme ()
Destroys a CXTPTabPaintManagerTheme object, handles cleanup and deallocation.
CXTPTabPaintManagerColorSet * | GetColorSet () const
Gets the color set.
virtual CRect | GetHeaderRect (CRect rcControl, CXTPTabManager *pTabManager)
Gets the bounding rectangle of the tab header area.
virtual CRect | GetHeaderClipBox (CDC *pDC, CXTPTabManager *pTabManager)
Gets the clip box of the tab header area.
int | GetHeaderHeight (CXTPTabManager *pTabManager)
Gets the height of the tab header area.
virtual CRect | GetClientRect (CRect rcControl, CXTPTabManager *pTabManager)
Gets the bounding rectangle of the tab client area.
virtual CRect | GetHeaderMargin ()
Gets the top, left, right, and bottom margins of the tab header.
virtual CRect | GetClientMargin ()
Gets the top, left, right, and bottom margins of the tab client area.
virtual int | GetButtonLength (CDC *pDC, CXTPTabManagerItem *pItem)
Retrieves the total length of a specified tab button including the left and right button margins.
virtual int | GetButtonHeight (const CXTPTabManager *pTabManager)
Retrieves the total height of the tab buttons within a specified tab manager including the top and bottom margins and the icon.
virtual CRect | GetButtonDrawRect (const CXTPTabManagerItem *pItem)
Retrieves the bounding rectangle of a specified drawing item.
virtual void | DrawTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl)
Draws the tab control.
virtual void | RepositionTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcClient)
Moves the tab buttons of the tab control to their correct positions.
virtual void | AdjustClientRect (CXTPTabManager *pTabManager, CRect &rcClient)
Adjusts the tab client rectangle.
virtual void | DrawWorkspacePart (CDC *pDC, LPRECT lpRect, XTPTabWorkspacePart workspacePart)
Draws a specified TabMDIClient TabWorkspace part.
virtual int | GetSupportedColorSets ()
Gets the supported color sets for this theme.
COLORREF | FillButton (CDC *pDC, CXTPTabManagerItem *pItem, LPPOINT pts, int nCount, XTPTabPosition tabPosition, BOOL bAbsolute=FALSE)
Draws a tab button within a specified polygon.

Additional Inherited Members

- Public Attributes inherited from CXTPTabPaintManagerTheme
CRect | m_rcHeaderMargin
CRect struct containing the left, top, right, and bottom.
int | m_nRowMargin
margins of the tab header.
- Protected Attributes inherited from CXTPTabPaintManagerTheme
int | m_nButtonHeight
Current tab button height (without margins).
CXTPTabPaintManager * | m_pPaintManager
Self paint manager pointer.
BOOL | m_bButtonsReverseZOrder
Draw buttons in right to left order.

Detailed Description

Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines.

Member Function Documentation

◆ DrawSingleButton()

virtual void DrawSingleButton | ( | CDC * | pDC,
 |  | CXTPTabManagerItem * | pItem )
 virtual

This method is called to draw a single tab button in the tab client header area.

Parameters
pDC | Pointer to a valid device context.
pItem | Tab button to draw.

This method will draw a single tab button. This method only draws the button, no text or icon is added.

DrawSingleButton calls CXTPTabPaintManager::DrawSingleButtonIconAndText after the button is drawn. This is called to draw the button's icon and text.

See also
CXTPTabPaintManager::DrawTabControlEx, CXTPTabPaintManager::DrawSingleButtonIconAndText

Reimplemented from CXTPDockingPaneTabTheme2012.

The documentation for this class was generated from the following file:
  • XTPDockingPaneTabTheme2017.h


Toolkit Pro: CXTPDockingPaneTabTheme2019 Class Reference

Public Member Functions | List of all members
CXTPDockingPaneTabTheme2019 Class Reference

Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines. More...

Inheritance diagram for CXTPDockingPaneTabTheme2019:
[legend]

Public Member Functions

CXTPDockingPaneTabTheme2019 ()
Default class constructor.
virtual void | DrawSingleButton (CDC *pDC, CXTPTabManagerItem *pItem)
This method is called to draw a single tab button in the tab client header area.
- Public Member Functions inherited from CXTPDockingPaneTabTheme2012
CXTPDockingPaneTabTheme2012 ()
Default class constructor.
virtual void | RefreshMetrics ()
This member function is used to initialize default colors for a theme from an .INI resource.
virtual void | DrawText (CDC *pDC, CXTPTabManager *pManager, const CString &str, LPRECT lpRect, UINT nFormat)
This method is called to draw text for the specified item.
- Public Member Functions inherited from CXTPTabThemeFlat
CXTPTabThemeFlat ()
Constructs a CXTPTabThemeFlat object.
virtual CRect | FillTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl)
Fills both the tab header and the tab client area and then draws the tab client frame.
virtual XTPTabColorStyle | GetDefaultColorSet ()
Gets the default value of the color set for this theme.
- Public Member Functions inherited from CXTPTabPaintManagerTheme
CXTPTabPaintManagerTheme ()
Constructs a CXTPTabPaintManagerTheme object.
virtual | ~CXTPTabPaintManagerTheme ()
Destroys a CXTPTabPaintManagerTheme object, handles cleanup and deallocation.
CXTPTabPaintManagerColorSet * | GetColorSet () const
Gets the color set.
virtual CRect | GetHeaderRect (CRect rcControl, CXTPTabManager *pTabManager)
Gets the bounding rectangle of the tab header area.
virtual CRect | GetHeaderClipBox (CDC *pDC, CXTPTabManager *pTabManager)
Gets the clip box of the tab header area.
int | GetHeaderHeight (CXTPTabManager *pTabManager)
Gets the height of the tab header area.
virtual CRect | GetClientRect (CRect rcControl, CXTPTabManager *pTabManager)
Gets the bounding rectangle of the tab client area.
virtual CRect | GetHeaderMargin ()
Gets the top, left, right, and bottom margins of the tab header.
virtual CRect | GetClientMargin ()
Gets the top, left, right, and bottom margins of the tab client area.
virtual int | GetButtonLength (CDC *pDC, CXTPTabManagerItem *pItem)
Retrieves the total length of a specified tab button including the left and right button margins.
virtual int | GetButtonHeight (const CXTPTabManager *pTabManager)
Retrieves the total height of the tab buttons within a specified tab manager including the top and bottom margins and the icon.
virtual CRect | GetButtonDrawRect (const CXTPTabManagerItem *pItem)
Retrieves the bounding rectangle of a specified drawing item.
virtual void | DrawTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl)
Draws the tab control.
virtual void | RepositionTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcClient)
Moves the tab buttons of the tab control to their correct positions.
virtual void | AdjustClientRect (CXTPTabManager *pTabManager, CRect &rcClient)
Adjusts the tab client rectangle.
virtual void | DrawWorkspacePart (CDC *pDC, LPRECT lpRect, XTPTabWorkspacePart workspacePart)
Draws a specified TabMDIClient TabWorkspace part.
virtual int | GetSupportedColorSets ()
Gets the supported color sets for this theme.
COLORREF | FillButton (CDC *pDC, CXTPTabManagerItem *pItem, LPPOINT pts, int nCount, XTPTabPosition tabPosition, BOOL bAbsolute=FALSE)
Draws a tab button within a specified polygon.

Additional Inherited Members

- Public Attributes inherited from CXTPTabPaintManagerTheme
CRect | m_rcHeaderMargin
CRect struct containing the left, top, right, and bottom.
int | m_nRowMargin
margins of the tab header.
- Protected Attributes inherited from CXTPTabPaintManagerTheme
int | m_nButtonHeight
Current tab button height (without margins).
CXTPTabPaintManager * | m_pPaintManager
Self paint manager pointer.
BOOL | m_bButtonsReverseZOrder
Draw buttons in right to left order.

Detailed Description

Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines.

Member Function Documentation

◆ DrawSingleButton()

virtual void DrawSingleButton | ( | CDC * | pDC,
 |  | CXTPTabManagerItem * | pItem )
 virtual

This method is called to draw a single tab button in the tab client header area.

Parameters
pDC | Pointer to a valid device context.
pItem | Tab button to draw.

This method will draw a single tab button. This method only draws the button, no text or icon is added.

DrawSingleButton calls CXTPTabPaintManager::DrawSingleButtonIconAndText after the button is drawn. This is called to draw the button's icon and text.

See also
CXTPTabPaintManager::DrawTabControlEx, CXTPTabPaintManager::DrawSingleButtonIconAndText

Reimplemented from CXTPDockingPaneTabTheme2012.

The documentation for this class was generated from the following file:
  • XTPDockingPaneTabTheme2019.h


Toolkit Pro: CXTPDockingPaneTabTheme2022 Class Reference

Public Member Functions | List of all members
CXTPDockingPaneTabTheme2022 Class Reference

Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines. More...

Inheritance diagram for CXTPDockingPaneTabTheme2022:
[legend]

Public Member Functions

CXTPDockingPaneTabTheme2022 ()
Default class constructor.
virtual void | DrawSingleButton (CDC *pDC, CXTPTabManagerItem *pItem)
This method is called to draw a single tab button in the tab client header area.
- Public Member Functions inherited from CXTPDockingPaneTabTheme2012
CXTPDockingPaneTabTheme2012 ()
Default class constructor.
virtual void | RefreshMetrics ()
This member function is used to initialize default colors for a theme from an .INI resource.
virtual void | DrawText (CDC *pDC, CXTPTabManager *pManager, const CString &str, LPRECT lpRect, UINT nFormat)
This method is called to draw text for the specified item.
- Public Member Functions inherited from CXTPTabThemeFlat
CXTPTabThemeFlat ()
Constructs a CXTPTabThemeFlat object.
virtual CRect | FillTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl)
Fills both the tab header and the tab client area and then draws the tab client frame.
virtual XTPTabColorStyle | GetDefaultColorSet ()
Gets the default value of the color set for this theme.
- Public Member Functions inherited from CXTPTabPaintManagerTheme
CXTPTabPaintManagerTheme ()
Constructs a CXTPTabPaintManagerTheme object.
virtual | ~CXTPTabPaintManagerTheme ()
Destroys a CXTPTabPaintManagerTheme object, handles cleanup and deallocation.
CXTPTabPaintManagerColorSet * | GetColorSet () const
Gets the color set.
virtual CRect | GetHeaderRect (CRect rcControl, CXTPTabManager *pTabManager)
Gets the bounding rectangle of the tab header area.
virtual CRect | GetHeaderClipBox (CDC *pDC, CXTPTabManager *pTabManager)
Gets the clip box of the tab header area.
int | GetHeaderHeight (CXTPTabManager *pTabManager)
Gets the height of the tab header area.
virtual CRect | GetClientRect (CRect rcControl, CXTPTabManager *pTabManager)
Gets the bounding rectangle of the tab client area.
virtual CRect | GetHeaderMargin ()
Gets the top, left, right, and bottom margins of the tab header.
virtual CRect | GetClientMargin ()
Gets the top, left, right, and bottom margins of the tab client area.
virtual int | GetButtonLength (CDC *pDC, CXTPTabManagerItem *pItem)
Retrieves the total length of a specified tab button including the left and right button margins.
virtual int | GetButtonHeight (const CXTPTabManager *pTabManager)
Retrieves the total height of the tab buttons within a specified tab manager including the top and bottom margins and the icon.
virtual CRect | GetButtonDrawRect (const CXTPTabManagerItem *pItem)
Retrieves the bounding rectangle of a specified drawing item.
virtual void | DrawTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl)
Draws the tab control.
virtual void | RepositionTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcClient)
Moves the tab buttons of the tab control to their correct positions.
virtual void | AdjustClientRect (CXTPTabManager *pTabManager, CRect &rcClient)
Adjusts the tab client rectangle.
virtual void | DrawWorkspacePart (CDC *pDC, LPRECT lpRect, XTPTabWorkspacePart workspacePart)
Draws a specified TabMDIClient TabWorkspace part.
virtual int | GetSupportedColorSets ()
Gets the supported color sets for this theme.
COLORREF | FillButton (CDC *pDC, CXTPTabManagerItem *pItem, LPPOINT pts, int nCount, XTPTabPosition tabPosition, BOOL bAbsolute=FALSE)
Draws a tab button within a specified polygon.

Additional Inherited Members

- Public Attributes inherited from CXTPTabPaintManagerTheme
CRect | m_rcHeaderMargin
CRect struct containing the left, top, right, and bottom.
int | m_nRowMargin
margins of the tab header.
- Protected Attributes inherited from CXTPTabPaintManagerTheme
int | m_nButtonHeight
Current tab button height (without margins).
CXTPTabPaintManager * | m_pPaintManager
Self paint manager pointer.
BOOL | m_bButtonsReverseZOrder
Draw buttons in right to left order.

Detailed Description

Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines.

Member Function Documentation

◆ DrawSingleButton()

virtual void DrawSingleButton | ( | CDC * | pDC,
 |  | CXTPTabManagerItem * | pItem )
 virtual

This method is called to draw a single tab button in the tab client header area.

Parameters
pDC | Pointer to a valid device context.
pItem | Tab button to draw.

This method will draw a single tab button. This method only draws the button, no text or icon is added.

DrawSingleButton calls CXTPTabPaintManager::DrawSingleButtonIconAndText after the button is drawn. This is called to draw the button's icon and text.

See also
CXTPTabPaintManager::DrawTabControlEx, CXTPTabPaintManager::DrawSingleButtonIconAndText

Reimplemented from CXTPDockingPaneTabTheme2012.

The documentation for this class was generated from the following file:
  • XTPDockingPaneTabTheme2022.h


Toolkit Pro: CXTPDockingPaneTabThemeNativeWindows10 Class Reference

Public Member Functions | List of all members
CXTPDockingPaneTabThemeNativeWindows10 Class Reference

Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines. More...

Inheritance diagram for CXTPDockingPaneTabThemeNativeWindows10:
[legend]

Public Member Functions

CXTPDockingPaneTabThemeNativeWindows10 ()
Default class constructor.
virtual void | DrawSingleButton (CDC *pDC, CXTPTabManagerItem *pItem)
This method is called to draw a single tab button in the tab client header area.
- Public Member Functions inherited from CXTPDockingPaneTabTheme2012
CXTPDockingPaneTabTheme2012 ()
Default class constructor.
virtual void | RefreshMetrics ()
This member function is used to initialize default colors for a theme from an .INI resource.
virtual void | DrawText (CDC *pDC, CXTPTabManager *pManager, const CString &str, LPRECT lpRect, UINT nFormat)
This method is called to draw text for the specified item.
- Public Member Functions inherited from CXTPTabThemeFlat
CXTPTabThemeFlat ()
Constructs a CXTPTabThemeFlat object.
virtual CRect | FillTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl)
Fills both the tab header and the tab client area and then draws the tab client frame.
virtual XTPTabColorStyle | GetDefaultColorSet ()
Gets the default value of the color set for this theme.
- Public Member Functions inherited from CXTPTabPaintManagerTheme
CXTPTabPaintManagerTheme ()
Constructs a CXTPTabPaintManagerTheme object.
virtual | ~CXTPTabPaintManagerTheme ()
Destroys a CXTPTabPaintManagerTheme object, handles cleanup and deallocation.
CXTPTabPaintManagerColorSet * | GetColorSet () const
Gets the color set.
virtual CRect | GetHeaderRect (CRect rcControl, CXTPTabManager *pTabManager)
Gets the bounding rectangle of the tab header area.
virtual CRect | GetHeaderClipBox (CDC *pDC, CXTPTabManager *pTabManager)
Gets the clip box of the tab header area.
int | GetHeaderHeight (CXTPTabManager *pTabManager)
Gets the height of the tab header area.
virtual CRect | GetClientRect (CRect rcControl, CXTPTabManager *pTabManager)
Gets the bounding rectangle of the tab client area.
virtual CRect | GetHeaderMargin ()
Gets the top, left, right, and bottom margins of the tab header.
virtual CRect | GetClientMargin ()
Gets the top, left, right, and bottom margins of the tab client area.
virtual int | GetButtonLength (CDC *pDC, CXTPTabManagerItem *pItem)
Retrieves the total length of a specified tab button including the left and right button margins.
virtual int | GetButtonHeight (const CXTPTabManager *pTabManager)
Retrieves the total height of the tab buttons within a specified tab manager including the top and bottom margins and the icon.
virtual CRect | GetButtonDrawRect (const CXTPTabManagerItem *pItem)
Retrieves the bounding rectangle of a specified drawing item.
virtual void | DrawTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl)
Draws the tab control.
virtual void | RepositionTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcClient)
Moves the tab buttons of the tab control to their correct positions.
virtual void | AdjustClientRect (CXTPTabManager *pTabManager, CRect &rcClient)
Adjusts the tab client rectangle.
virtual void | DrawWorkspacePart (CDC *pDC, LPRECT lpRect, XTPTabWorkspacePart workspacePart)
Draws a specified TabMDIClient TabWorkspace part.
virtual int | GetSupportedColorSets ()
Gets the supported color sets for this theme.
COLORREF | FillButton (CDC *pDC, CXTPTabManagerItem *pItem, LPPOINT pts, int nCount, XTPTabPosition tabPosition, BOOL bAbsolute=FALSE)
Draws a tab button within a specified polygon.

Additional Inherited Members

- Public Attributes inherited from CXTPTabPaintManagerTheme
CRect | m_rcHeaderMargin
CRect struct containing the left, top, right, and bottom.
int | m_nRowMargin
margins of the tab header.
- Protected Attributes inherited from CXTPTabPaintManagerTheme
int | m_nButtonHeight
Current tab button height (without margins).
CXTPTabPaintManager * | m_pPaintManager
Self paint manager pointer.
BOOL | m_bButtonsReverseZOrder
Draw buttons in right to left order.

Detailed Description

Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines.

Member Function Documentation

◆ DrawSingleButton()

virtual void DrawSingleButton | ( | CDC * | pDC,
 |  | CXTPTabManagerItem * | pItem )
 virtual

This method is called to draw a single tab button in the tab client header area.

Parameters
pDC | Pointer to a valid device context.
pItem | Tab button to draw.

This method will draw a single tab button. This method only draws the button, no text or icon is added.

DrawSingleButton calls CXTPTabPaintManager::DrawSingleButtonIconAndText after the button is drawn. This is called to draw the button's icon and text.

See also
CXTPTabPaintManager::DrawTabControlEx, CXTPTabPaintManager::DrawSingleButtonIconAndText

Reimplemented from CXTPDockingPaneTabTheme2012.

The documentation for this class was generated from the following file:
  • XTPDockingPaneTabThemeNativeWindows10.h


Toolkit Pro: CXTPDockingPaneTabThemeNativeWindows11 Class Reference

Public Member Functions | List of all members
CXTPDockingPaneTabThemeNativeWindows11 Class Reference

Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines. More...

Inheritance diagram for CXTPDockingPaneTabThemeNativeWindows11:
[legend]

Public Member Functions

CXTPDockingPaneTabThemeNativeWindows11 ()
Default class constructor.
virtual void | DrawSingleButton (CDC *pDC, CXTPTabManagerItem *pItem)
This method is called to draw a single tab button in the tab client header area.
- Public Member Functions inherited from CXTPDockingPaneTabTheme2012
CXTPDockingPaneTabTheme2012 ()
Default class constructor.
virtual void | RefreshMetrics ()
This member function is used to initialize default colors for a theme from an .INI resource.
virtual void | DrawText (CDC *pDC, CXTPTabManager *pManager, const CString &str, LPRECT lpRect, UINT nFormat)
This method is called to draw text for the specified item.
- Public Member Functions inherited from CXTPTabThemeFlat
CXTPTabThemeFlat ()
Constructs a CXTPTabThemeFlat object.
virtual CRect | FillTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl)
Fills both the tab header and the tab client area and then draws the tab client frame.
virtual XTPTabColorStyle | GetDefaultColorSet ()
Gets the default value of the color set for this theme.
- Public Member Functions inherited from CXTPTabPaintManagerTheme
CXTPTabPaintManagerTheme ()
Constructs a CXTPTabPaintManagerTheme object.
virtual | ~CXTPTabPaintManagerTheme ()
Destroys a CXTPTabPaintManagerTheme object, handles cleanup and deallocation.
CXTPTabPaintManagerColorSet * | GetColorSet () const
Gets the color set.
virtual CRect | GetHeaderRect (CRect rcControl, CXTPTabManager *pTabManager)
Gets the bounding rectangle of the tab header area.
virtual CRect | GetHeaderClipBox (CDC *pDC, CXTPTabManager *pTabManager)
Gets the clip box of the tab header area.
int | GetHeaderHeight (CXTPTabManager *pTabManager)
Gets the height of the tab header area.
virtual CRect | GetClientRect (CRect rcControl, CXTPTabManager *pTabManager)
Gets the bounding rectangle of the tab client area.
virtual CRect | GetHeaderMargin ()
Gets the top, left, right, and bottom margins of the tab header.
virtual CRect | GetClientMargin ()
Gets the top, left, right, and bottom margins of the tab client area.
virtual int | GetButtonLength (CDC *pDC, CXTPTabManagerItem *pItem)
Retrieves the total length of a specified tab button including the left and right button margins.
virtual int | GetButtonHeight (const CXTPTabManager *pTabManager)
Retrieves the total height of the tab buttons within a specified tab manager including the top and bottom margins and the icon.
virtual CRect | GetButtonDrawRect (const CXTPTabManagerItem *pItem)
Retrieves the bounding rectangle of a specified drawing item.
virtual void | DrawTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl)
Draws the tab control.
virtual void | RepositionTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcClient)
Moves the tab buttons of the tab control to their correct positions.
virtual void | AdjustClientRect (CXTPTabManager *pTabManager, CRect &rcClient)
Adjusts the tab client rectangle.
virtual void | DrawWorkspacePart (CDC *pDC, LPRECT lpRect, XTPTabWorkspacePart workspacePart)
Draws a specified TabMDIClient TabWorkspace part.
virtual int | GetSupportedColorSets ()
Gets the supported color sets for this theme.
COLORREF | FillButton (CDC *pDC, CXTPTabManagerItem *pItem, LPPOINT pts, int nCount, XTPTabPosition tabPosition, BOOL bAbsolute=FALSE)
Draws a tab button within a specified polygon.

Additional Inherited Members

- Public Attributes inherited from CXTPTabPaintManagerTheme
CRect | m_rcHeaderMargin
CRect struct containing the left, top, right, and bottom.
int | m_nRowMargin
margins of the tab header.
- Protected Attributes inherited from CXTPTabPaintManagerTheme
int | m_nButtonHeight
Current tab button height (without margins).
CXTPTabPaintManager * | m_pPaintManager
Self paint manager pointer.
BOOL | m_bButtonsReverseZOrder
Draw buttons in right to left order.

Detailed Description

Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines.

Member Function Documentation

◆ DrawSingleButton()

virtual void DrawSingleButton | ( | CDC * | pDC,
 |  | CXTPTabManagerItem * | pItem )
 virtual

This method is called to draw a single tab button in the tab client header area.

Parameters
pDC | Pointer to a valid device context.
pItem | Tab button to draw.

This method will draw a single tab button. This method only draws the button, no text or icon is added.

DrawSingleButton calls CXTPTabPaintManager::DrawSingleButtonIconAndText after the button is drawn. This is called to draw the button's icon and text.

See also
CXTPTabPaintManager::DrawTabControlEx, CXTPTabPaintManager::DrawSingleButtonIconAndText

Reimplemented from CXTPDockingPaneTabTheme2012.

The documentation for this class was generated from the following file:
  • XTPDockingPaneTabThemeNativeWindows11.h


Toolkit Pro: CXTPDockingPaneVisualStudio2003Theme Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPDockingPaneVisualStudio2003Theme Class Reference

CXTPDockingPaneVisualStudio2003Theme is a CXTPDockingPaneGripperedTheme derived class that represents a Visual Studio 2003 theme for docking panes. More...

Inheritance diagram for CXTPDockingPaneVisualStudio2003Theme:
[legend]

Public Member Functions

CXTPDockingPaneVisualStudio2003Theme ()
Constructs a CXTPDockingPaneVisualStudio2003Theme object.
virtual void | RefreshMetrics ()
This method is called to refresh the visual metrics of the pane.
- Public Member Functions inherited from CXTPDockingPaneGripperedTheme
CXTPDockingPaneGripperedTheme ()
Constructs a CXTPDockingPaneGripperedTheme object.
void | DrawFloatingFrame (CDC *pDC, CXTPDockingPaneMiniWnd *pPane, CRect rc)
Call this method to draw the frame of a floating window.
virtual void | DrawCaption (CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc)
Override this member function to draw a caption.
- Public Member Functions inherited from CXTPDockingPaneDefaultTheme
CXTPDockingPaneDefaultTheme ()
Constructs a CXTPDockingPaneDefaultTheme object.
virtual void | DrawSidePanel (CDC *pDC, CXTPDockingPaneSidePanel *pPane, CRect rc)
Override this member function to draw the side panel.
- Public Member Functions inherited from CXTPDockingPanePaintManager
virtual void | DrawPane (CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc)
Override this member function to draw a tabbed container.
virtual CRect | GetPaneCaptionRect (const CXTPDockingPaneSidePanel *pPane)
Call this method to get the pane's caption rectangle.
virtual void | DrawSplitter (CDC *pDC, CXTPDockingPaneSplitterWnd *pSplitter)
Override this method to draw a splitter.
virtual void | DrawCaptionButtons (CDC *pDC, CXTPDockingPaneCaptionButtons *pButtons, CRect &rcCaption, COLORREF clr, int nButtonSize, int nButtonGap, BOOL bVertical=FALSE)
Override this member function to draw buttons for a tabbed caption.
virtual void | DrawCaptionButton (CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton)
Override this member function to draw a button for a tabbed caption.
virtual void | AdjustClientRect (CXTPDockingPaneSidePanel *pPane, CRect &rect)
Override this member to change the client rectangle of the child docking pane.
virtual void | AdjustClientRect (CXTPDockingPaneTabbedContainer *pPane, CRect &rect, BOOL bApply)
Override this member to change the client rectangle of the child docking pane.
virtual void | AdjustCaptionRect (const CXTPDockingPaneSidePanel *pPane, CRect &rc)
Override this member to change the caption rectangle of the child docking pane.
virtual void | AdjustCaptionRect (const CXTPDockingPaneTabbedContainer *pPane, CRect &rc)
Override this member to change the caption rectangle of the child docking pane.
virtual void | GetCaptionRect (const CXTPDockingPaneTabbedContainer *pPane, CRect &rc)
Call this method to get a caption rectangle.
virtual CRect | GetCaptionGripperRect (const CXTPDockingPaneTabbedContainer *pPane)
Call this method to get a caption gripper for a tabbed container.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1, int nPen)
Draws a line.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1)
Draws a line.
int | DrawCaptionText (CDC *pDC, const CString &strTitle, CRect rc, BOOL bVertical, BOOL bCalcWidth=FALSE)
Draws the text of a pane caption.
void | Pixel (CDC *pDC, int xPos, int yPos, int nPen)
Sets the pixel at the point.
void | Rectangle (CDC *pDC, CRect rc, int nPenEntry, int nPenBorder)
Draws a rectangle.
void | UseOfficeFont (BOOL bUseOfficeFont)
Call this member to use Office (Tahoma) font.
void | SetCaptionFontIndirect (LOGFONT *pLogFont, BOOL bUseStandardFont=FALSE)
Call this method to set the caption's font.
CXTPTabPaintManager * | SetTabPaintManager (CXTPTabPaintManager *pManager)
Call this method to set the paint manager used to draw tabs of a tabbed container.
CXTPTabPaintManager * | SetPanelPaintManager (CXTPTabPaintManager *pManager)
Call this method to set the paint manager used to draw tabs of an auto-hide panel.
CXTPTabPaintManager * | GetTabPaintManager () const
Retrieves the paint manager used to draw tabs of a tabbed container.
CXTPTabPaintManager * | GetPanelPaintManager () const
Retrieves the paint manager used to draw tabs of an auto-hide panel.
COLORREF | GetXtremeColor (UINT nIndex)
Retrieves the current color of the specified XP display element.
void | SetColors (int cElements, CONST INT *lpaElements, CONST COLORREF *lpaRgbValues)
Call this member to set the colors for each element in an array to the colors in a specified color array.
int | GetCaptionHeight () const
Call this member to get the caption height of the tabbed container.
int | GetTabsHeight () const
Call this member to get tabs height of the tabbed container.
void | SetSplitterStyle (DWORD dwStyle)
Call this member to set the splitter style.
DWORD | GetSplitterStyle () const
Call this method to get the splitter style.
void | SetCaptionButtonStyle (XTPDockingPaneCaptionButtonStyle nStyle)
Call this member to set the caption button style.
XTPDockingPaneCaptionButtonStyle | GetCaptionButtonStyle () const
Call this method to get the caption button style.
XTPCurrentSystemTheme | GetCurrentSystemTheme () const
Call this member function to determine the current Windows XP theme in use.
void | SetLunaTheme (XTPCurrentSystemTheme systemTheme)
Call this method to force system theme.
virtual void | DrawAutoHidePanel (CDC *pDC, CRect rc, XTPDockingPaneDirection direction)
This mmethod is called by the framework to draw the docking pane auto-hide panel background and splitter.
void | SetCustomTitleBrushes (HBRUSH hbrActiveTitleHorz, HBRUSH hbrInactiveTitleHorz=NULL, HBRUSH hbrActiveTitleVert=NULL, HBRUSH hbrInactiveTitleVert=NULL, BOOL bDestroyOnCleanup=FALSE)
Sets custom title brushes.
HBRUSH | GetCustomTitleBrush (BOOL bActive, BOOL bVertical) const
Obtains the custom title brush.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

virtual void | DrawCaptionPart (CDC *pDC, CXTPDockingPaneBase *pPane, CRect rcCaption, const CString &strTitle, BOOL bActive, BOOL bVertical)
Draws the common part of a tabbed and floating caption.
virtual COLORREF | FillCaptionPart (CDC *pDC, CXTPDockingPaneBase *pPane, CRect rcCaption, BOOL bActive, BOOL bVertical)
Draws the background of the pane caption.
- Protected Member Functions inherited from CXTPDockingPaneGripperedTheme
- Protected Member Functions inherited from CXTPDockingPaneDefaultTheme
- Protected Member Functions inherited from CXTPDockingPanePaintManager
CXTPDockingPanePaintManager ()
Constructs a CXTPDockingPanePaintManager object.
virtual | ~CXTPDockingPanePaintManager ()
Destroys a CXTPDockingPanePaintManager object, handles cleanup and deallocation.
virtual void | DrawCaptionButtonEntry (CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton, CSize szOffset)
Draws only the glyph of a button.
virtual void | DrawCaptionButtonEntry (CDC *pDC, CXTPDockingPaneCaptionButton *pButton, CPoint pt, COLORREF clrButton)
Draws only the glyph of a button.
void | ClipAndAddEllipsisIfNeeded (CDC *pDC, CString &strTitle, int nCaptionWidth) const
Clip string and add ellipsis if its width less than nCaptionWidth.

Protected Attributes

BOOL | m_bGradientCaption
TRUE to draw gradient caption.
- Protected Attributes inherited from CXTPDockingPanePaintManager
XTPDockingPaneCaptionButtonStyle | m_nCaptionButtonStyle
Caption button style.
DWORD | m_dwSplitterStyle
Splitter style.
int | m_nTitleHeight
Title's height.
int | m_nCaptionFontGap
Additional gap of font.
int | m_nTabsHeight
Tab bar's height.
CXTPFont | m_xtpFontTitle
Title font.
CXTPFont | m_xtpFontTitleVertical
Title vertical font.
BOOL | m_bUseOfficeFont
TRUE to use Tahoma font.
BOOL | m_bUseStandardFont
TRUE to use system icon font.
BOOL | m_bDestroyCustomTitleBrushes
If TRUE, custom title bushes will be destroyed on cleanup.
HBRUSH | m_hbrActiveTitleHorz
Optional user specified active horizontal title brush.
HBRUSH | m_hbrInactiveTitleHorz
Optional user specified inactive horizontal title brush.
HBRUSH | m_hbrActiveTitleVert
Optional user specified active vertical title brush.
HBRUSH | m_hbrInactiveTitleVert
Optional user specified inactive vertical title brush.
CXTPTabPaintManager * | m_pTabPaintManager
Paint Manager used to draw tabs for a tabbed container.
CXTPTabPaintManager * | m_pPanelPaintManager
Paint Manager used to draw tabs for an auto-hide panel.
COLORREF | m_arrColor [XPCOLOR_LAST+1]
Self colors array.
XTPDockingPanePaintTheme | m_themeCurrent
Current theme.
CString | m_strOfficeFont
Office font name.
CRect | m_rcCaptionMargin
Margins of caption.
XTPCurrentSystemTheme | m_systemTheme
Current system theme.
CXTPWinThemeWrapper * | m_themeToolbar
Toolbar theme helper.
CXTPWinThemeWrapper * | m_themeExplorer
WinXP Explorer theme helper.
CXTPWinThemeWrapper * | m_themeButton
WinXP Button theme helper.
CXTPWinThemeWrapper * | m_themeWindow
WinXP Window Theme helper.
CXTPWinThemeWrapper * | m_themeRebar
Rebar theme helper.
BOOL | m_bLunaTheme
TRUE if luna colors are used.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPDockingPanePaintManager
BOOL | m_bUseBoldCaptionFont
TRUE to use bold font for caption.
BOOL | m_bHighlightActiveCaption
TRUE to highlight active caption.
int | m_nSplitterSize
Splitter size.
BOOL | m_bShowCaption
TRUE to draw captions of tabbed containers.
BOOL | m_bDrawSingleTab
TRUE to draw single tab.
BOOL | m_bDrawCaptionIcon
TRUE to draw caption icon.
int | m_nSplitterIndent
Size of splitter indent.
CXTPPaintManagerColor | m_clrBackground
Background color.
CXTPPaintManagerColor | m_clrSplitterGripper
Splitter gripper color.
CXTPPaintManagerColor | m_clrSplitter
Splitter color.
CXTPPaintManagerColorGradient | m_clrSplitterGradient
Splitter gradient color.
CXTPPaintManagerColorGradient | m_clrNormalCaption
Color of pane caption when inactive.
CXTPPaintManagerColorGradient | m_clrActiveCaption
Color of pane caption when active.
CXTPPaintManagerColor | m_clrNormalCaptionText
Color of pane caption text when the caption is inactive.
CXTPPaintManagerColor | m_clrActiveCaptionText
Active caption text.
CXTPPaintManagerColor | m_clrDisabledCaptionText
Disabled caption text.

Detailed Description

CXTPDockingPaneVisualStudio2003Theme is a CXTPDockingPaneGripperedTheme derived class that represents a Visual Studio 2003 theme for docking panes.

Call CXTPDockingPaneManager::SetTheme(xtpPaneThemeVisualStudio2003); to set this theme.

Member Function Documentation

◆ DrawCaptionPart()

virtual void DrawCaptionPart | ( | CDC * | pDC,
 |  | CXTPDockingPaneBase * | pPane,
 |  | CRect | rcCaption,
 |  | const CString & | strTitle,
 |  | BOOL | bActive,
 |  | BOOL | bVertical )
 protectedvirtual

Draws the common part of a tabbed and floating caption.

Parameters
pDC | Reference to the device context in which to draw.
pPane | Container which the caption needs to draw.
rcCaption | Caption bounding rectangle.
strTitle | Caption text.
bActive | TRUE if the caption is active.
bVertical | TRUE to draw the caption vertically.

Reimplemented from CXTPDockingPaneGripperedTheme.

Reimplemented in CXTPDockingPaneOffice2003Theme, CXTPDockingPaneOffice2007WordTheme, and CXTPDockingPaneWinNativeTheme.

◆ FillCaptionPart()

virtual COLORREF FillCaptionPart | ( | CDC * | pDC,
 |  | CXTPDockingPaneBase * | pPane,
 |  | CRect | rcCaption,
 |  | BOOL | bActive,
 |  | BOOL | bVertical )
 protectedvirtual

Draws the background of the pane caption.

Parameters
pDC | Reference to the device context in which to draw.
pPane | Container which the caption needs to draw the background.
rcCaption | Caption bounding rectangle.
bActive | TRUE if the caption is active.
bVertical | TRUE to draw the caption vertically.
Returns
Caption text color value.

Reimplemented in CXTPDockingPaneVisualStudio2005Beta2Theme, and CXTPDockingPaneVisualStudio2010Theme.

The documentation for this class was generated from the following file:
  • XTPDockingPaneThemeVisualStudio2003.h


Toolkit Pro: CXTPDockingPaneVisualStudio2005Beta1Theme Class Reference

Public Member Functions | List of all members
CXTPDockingPaneVisualStudio2005Beta1Theme Class Reference

CXTPDockingPaneVisualStudio2005Beta1Theme is CXTPDockingPaneVisualStudio2003Theme derived class that represents a Visual Studio 2005 Beta 1 theme for docking panes. More...

Inheritance diagram for CXTPDockingPaneVisualStudio2005Beta1Theme:
[legend]

Public Member Functions

CXTPDockingPaneVisualStudio2005Beta1Theme ()
Constructs a CXTPDockingPaneVisualStudio2005Beta1Theme object.
void | RefreshMetrics ()
This method is called to refresh the visual metrics of the pane.
- Public Member Functions inherited from CXTPDockingPaneVisualStudio2003Theme
CXTPDockingPaneVisualStudio2003Theme ()
Constructs a CXTPDockingPaneVisualStudio2003Theme object.
- Public Member Functions inherited from CXTPDockingPaneGripperedTheme
CXTPDockingPaneGripperedTheme ()
Constructs a CXTPDockingPaneGripperedTheme object.
void | DrawFloatingFrame (CDC *pDC, CXTPDockingPaneMiniWnd *pPane, CRect rc)
Call this method to draw the frame of a floating window.
virtual void | DrawCaption (CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc)
Override this member function to draw a caption.
- Public Member Functions inherited from CXTPDockingPaneDefaultTheme
CXTPDockingPaneDefaultTheme ()
Constructs a CXTPDockingPaneDefaultTheme object.
virtual void | DrawSidePanel (CDC *pDC, CXTPDockingPaneSidePanel *pPane, CRect rc)
Override this member function to draw the side panel.
- Public Member Functions inherited from CXTPDockingPanePaintManager
virtual void | DrawPane (CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc)
Override this member function to draw a tabbed container.
virtual CRect | GetPaneCaptionRect (const CXTPDockingPaneSidePanel *pPane)
Call this method to get the pane's caption rectangle.
virtual void | DrawSplitter (CDC *pDC, CXTPDockingPaneSplitterWnd *pSplitter)
Override this method to draw a splitter.
virtual void | DrawCaptionButtons (CDC *pDC, CXTPDockingPaneCaptionButtons *pButtons, CRect &rcCaption, COLORREF clr, int nButtonSize, int nButtonGap, BOOL bVertical=FALSE)
Override this member function to draw buttons for a tabbed caption.
virtual void | DrawCaptionButton (CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton)
Override this member function to draw a button for a tabbed caption.
virtual void | AdjustClientRect (CXTPDockingPaneSidePanel *pPane, CRect &rect)
Override this member to change the client rectangle of the child docking pane.
virtual void | AdjustClientRect (CXTPDockingPaneTabbedContainer *pPane, CRect &rect, BOOL bApply)
Override this member to change the client rectangle of the child docking pane.
virtual void | AdjustCaptionRect (const CXTPDockingPaneSidePanel *pPane, CRect &rc)
Override this member to change the caption rectangle of the child docking pane.
virtual void | AdjustCaptionRect (const CXTPDockingPaneTabbedContainer *pPane, CRect &rc)
Override this member to change the caption rectangle of the child docking pane.
virtual void | GetCaptionRect (const CXTPDockingPaneTabbedContainer *pPane, CRect &rc)
Call this method to get a caption rectangle.
virtual CRect | GetCaptionGripperRect (const CXTPDockingPaneTabbedContainer *pPane)
Call this method to get a caption gripper for a tabbed container.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1, int nPen)
Draws a line.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1)
Draws a line.
int | DrawCaptionText (CDC *pDC, const CString &strTitle, CRect rc, BOOL bVertical, BOOL bCalcWidth=FALSE)
Draws the text of a pane caption.
void | Pixel (CDC *pDC, int xPos, int yPos, int nPen)
Sets the pixel at the point.
void | Rectangle (CDC *pDC, CRect rc, int nPenEntry, int nPenBorder)
Draws a rectangle.
void | UseOfficeFont (BOOL bUseOfficeFont)
Call this member to use Office (Tahoma) font.
void | SetCaptionFontIndirect (LOGFONT *pLogFont, BOOL bUseStandardFont=FALSE)
Call this method to set the caption's font.
CXTPTabPaintManager * | SetTabPaintManager (CXTPTabPaintManager *pManager)
Call this method to set the paint manager used to draw tabs of a tabbed container.
CXTPTabPaintManager * | SetPanelPaintManager (CXTPTabPaintManager *pManager)
Call this method to set the paint manager used to draw tabs of an auto-hide panel.
CXTPTabPaintManager * | GetTabPaintManager () const
Retrieves the paint manager used to draw tabs of a tabbed container.
CXTPTabPaintManager * | GetPanelPaintManager () const
Retrieves the paint manager used to draw tabs of an auto-hide panel.
COLORREF | GetXtremeColor (UINT nIndex)
Retrieves the current color of the specified XP display element.
void | SetColors (int cElements, CONST INT *lpaElements, CONST COLORREF *lpaRgbValues)
Call this member to set the colors for each element in an array to the colors in a specified color array.
int | GetCaptionHeight () const
Call this member to get the caption height of the tabbed container.
int | GetTabsHeight () const
Call this member to get tabs height of the tabbed container.
void | SetSplitterStyle (DWORD dwStyle)
Call this member to set the splitter style.
DWORD | GetSplitterStyle () const
Call this method to get the splitter style.
void | SetCaptionButtonStyle (XTPDockingPaneCaptionButtonStyle nStyle)
Call this member to set the caption button style.
XTPDockingPaneCaptionButtonStyle | GetCaptionButtonStyle () const
Call this method to get the caption button style.
XTPCurrentSystemTheme | GetCurrentSystemTheme () const
Call this member function to determine the current Windows XP theme in use.
void | SetLunaTheme (XTPCurrentSystemTheme systemTheme)
Call this method to force system theme.
virtual void | DrawAutoHidePanel (CDC *pDC, CRect rc, XTPDockingPaneDirection direction)
This mmethod is called by the framework to draw the docking pane auto-hide panel background and splitter.
void | SetCustomTitleBrushes (HBRUSH hbrActiveTitleHorz, HBRUSH hbrInactiveTitleHorz=NULL, HBRUSH hbrActiveTitleVert=NULL, HBRUSH hbrInactiveTitleVert=NULL, BOOL bDestroyOnCleanup=FALSE)
Sets custom title brushes.
HBRUSH | GetCustomTitleBrush (BOOL bActive, BOOL bVertical) const
Obtains the custom title brush.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPDockingPanePaintManager
BOOL | m_bUseBoldCaptionFont
TRUE to use bold font for caption.
BOOL | m_bHighlightActiveCaption
TRUE to highlight active caption.
int | m_nSplitterSize
Splitter size.
BOOL | m_bShowCaption
TRUE to draw captions of tabbed containers.
BOOL | m_bDrawSingleTab
TRUE to draw single tab.
BOOL | m_bDrawCaptionIcon
TRUE to draw caption icon.
int | m_nSplitterIndent
Size of splitter indent.
CXTPPaintManagerColor | m_clrBackground
Background color.
CXTPPaintManagerColor | m_clrSplitterGripper
Splitter gripper color.
CXTPPaintManagerColor | m_clrSplitter
Splitter color.
CXTPPaintManagerColorGradient | m_clrSplitterGradient
Splitter gradient color.
CXTPPaintManagerColorGradient | m_clrNormalCaption
Color of pane caption when inactive.
CXTPPaintManagerColorGradient | m_clrActiveCaption
Color of pane caption when active.
CXTPPaintManagerColor | m_clrNormalCaptionText
Color of pane caption text when the caption is inactive.
CXTPPaintManagerColor | m_clrActiveCaptionText
Active caption text.
CXTPPaintManagerColor | m_clrDisabledCaptionText
Disabled caption text.
- Protected Member Functions inherited from CXTPDockingPaneVisualStudio2003Theme
virtual void | DrawCaptionPart (CDC *pDC, CXTPDockingPaneBase *pPane, CRect rcCaption, const CString &strTitle, BOOL bActive, BOOL bVertical)
Draws the common part of a tabbed and floating caption.
virtual COLORREF | FillCaptionPart (CDC *pDC, CXTPDockingPaneBase *pPane, CRect rcCaption, BOOL bActive, BOOL bVertical)
Draws the background of the pane caption.
- Protected Member Functions inherited from CXTPDockingPaneGripperedTheme
- Protected Member Functions inherited from CXTPDockingPaneDefaultTheme
- Protected Member Functions inherited from CXTPDockingPanePaintManager
CXTPDockingPanePaintManager ()
Constructs a CXTPDockingPanePaintManager object.
virtual | ~CXTPDockingPanePaintManager ()
Destroys a CXTPDockingPanePaintManager object, handles cleanup and deallocation.
virtual void | DrawCaptionButtonEntry (CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton, CSize szOffset)
Draws only the glyph of a button.
virtual void | DrawCaptionButtonEntry (CDC *pDC, CXTPDockingPaneCaptionButton *pButton, CPoint pt, COLORREF clrButton)
Draws only the glyph of a button.
void | ClipAndAddEllipsisIfNeeded (CDC *pDC, CString &strTitle, int nCaptionWidth) const
Clip string and add ellipsis if its width less than nCaptionWidth.
- Protected Attributes inherited from CXTPDockingPaneVisualStudio2003Theme
BOOL | m_bGradientCaption
TRUE to draw gradient caption.
- Protected Attributes inherited from CXTPDockingPanePaintManager
XTPDockingPaneCaptionButtonStyle | m_nCaptionButtonStyle
Caption button style.
DWORD | m_dwSplitterStyle
Splitter style.
int | m_nTitleHeight
Title's height.
int | m_nCaptionFontGap
Additional gap of font.
int | m_nTabsHeight
Tab bar's height.
CXTPFont | m_xtpFontTitle
Title font.
CXTPFont | m_xtpFontTitleVertical
Title vertical font.
BOOL | m_bUseOfficeFont
TRUE to use Tahoma font.
BOOL | m_bUseStandardFont
TRUE to use system icon font.
BOOL | m_bDestroyCustomTitleBrushes
If TRUE, custom title bushes will be destroyed on cleanup.
HBRUSH | m_hbrActiveTitleHorz
Optional user specified active horizontal title brush.
HBRUSH | m_hbrInactiveTitleHorz
Optional user specified inactive horizontal title brush.
HBRUSH | m_hbrActiveTitleVert
Optional user specified active vertical title brush.
HBRUSH | m_hbrInactiveTitleVert
Optional user specified inactive vertical title brush.
CXTPTabPaintManager * | m_pTabPaintManager
Paint Manager used to draw tabs for a tabbed container.
CXTPTabPaintManager * | m_pPanelPaintManager
Paint Manager used to draw tabs for an auto-hide panel.
COLORREF | m_arrColor [XPCOLOR_LAST+1]
Self colors array.
XTPDockingPanePaintTheme | m_themeCurrent
Current theme.
CString | m_strOfficeFont
Office font name.
CRect | m_rcCaptionMargin
Margins of caption.
XTPCurrentSystemTheme | m_systemTheme
Current system theme.
CXTPWinThemeWrapper * | m_themeToolbar
Toolbar theme helper.
CXTPWinThemeWrapper * | m_themeExplorer
WinXP Explorer theme helper.
CXTPWinThemeWrapper * | m_themeButton
WinXP Button theme helper.
CXTPWinThemeWrapper * | m_themeWindow
WinXP Window Theme helper.
CXTPWinThemeWrapper * | m_themeRebar
Rebar theme helper.
BOOL | m_bLunaTheme
TRUE if luna colors are used.

Detailed Description

CXTPDockingPaneVisualStudio2005Beta1Theme is CXTPDockingPaneVisualStudio2003Theme derived class that represents a Visual Studio 2005 Beta 1 theme for docking panes.

Call CXTPDockingPaneManager::SetTheme(xtpPaneThemeVisualStudio2005Beta1); to set this theme.

The documentation for this class was generated from the following file:
  • XTPDockingPaneThemeVisualStudio2005Beta1.h


Toolkit Pro: CXTPDockingPaneVisualStudio2005Beta2Theme Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPDockingPaneVisualStudio2005Beta2Theme Class Reference

CXTPDockingPaneVisualStudio2005Beta2Theme is CXTPDockingPaneVisualStudio2005Beta1Theme derived class that represents a Visual Studio 2005 Beta 2 theme for docking panes. More...

Inheritance diagram for CXTPDockingPaneVisualStudio2005Beta2Theme:
[legend]

Public Member Functions

CXTPDockingPaneVisualStudio2005Beta2Theme ()
Constructs a CXTPDockingPaneVisualStudio2005Beta2Theme object.
void | RefreshMetrics ()
This method is called to refresh the visual metrics of the pane.
virtual COLORREF | FillCaptionPart (CDC *pDC, CXTPDockingPaneBase *pPane, CRect rcCaption, BOOL bActive, BOOL bVertical)
Draws the background of the pane caption.
- Public Member Functions inherited from CXTPDockingPaneVisualStudio2005Beta1Theme
CXTPDockingPaneVisualStudio2005Beta1Theme ()
Constructs a CXTPDockingPaneVisualStudio2005Beta1Theme object.
- Public Member Functions inherited from CXTPDockingPaneVisualStudio2003Theme
CXTPDockingPaneVisualStudio2003Theme ()
Constructs a CXTPDockingPaneVisualStudio2003Theme object.
- Public Member Functions inherited from CXTPDockingPaneGripperedTheme
CXTPDockingPaneGripperedTheme ()
Constructs a CXTPDockingPaneGripperedTheme object.
void | DrawFloatingFrame (CDC *pDC, CXTPDockingPaneMiniWnd *pPane, CRect rc)
Call this method to draw the frame of a floating window.
virtual void | DrawCaption (CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc)
Override this member function to draw a caption.
- Public Member Functions inherited from CXTPDockingPaneDefaultTheme
CXTPDockingPaneDefaultTheme ()
Constructs a CXTPDockingPaneDefaultTheme object.
virtual void | DrawSidePanel (CDC *pDC, CXTPDockingPaneSidePanel *pPane, CRect rc)
Override this member function to draw the side panel.
- Public Member Functions inherited from CXTPDockingPanePaintManager
virtual void | DrawPane (CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc)
Override this member function to draw a tabbed container.
virtual CRect | GetPaneCaptionRect (const CXTPDockingPaneSidePanel *pPane)
Call this method to get the pane's caption rectangle.
virtual void | DrawSplitter (CDC *pDC, CXTPDockingPaneSplitterWnd *pSplitter)
Override this method to draw a splitter.
virtual void | DrawCaptionButtons (CDC *pDC, CXTPDockingPaneCaptionButtons *pButtons, CRect &rcCaption, COLORREF clr, int nButtonSize, int nButtonGap, BOOL bVertical=FALSE)
Override this member function to draw buttons for a tabbed caption.
virtual void | DrawCaptionButton (CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton)
Override this member function to draw a button for a tabbed caption.
virtual void | AdjustClientRect (CXTPDockingPaneSidePanel *pPane, CRect &rect)
Override this member to change the client rectangle of the child docking pane.
virtual void | AdjustClientRect (CXTPDockingPaneTabbedContainer *pPane, CRect &rect, BOOL bApply)
Override this member to change the client rectangle of the child docking pane.
virtual void | AdjustCaptionRect (const CXTPDockingPaneSidePanel *pPane, CRect &rc)
Override this member to change the caption rectangle of the child docking pane.
virtual void | AdjustCaptionRect (const CXTPDockingPaneTabbedContainer *pPane, CRect &rc)
Override this member to change the caption rectangle of the child docking pane.
virtual void | GetCaptionRect (const CXTPDockingPaneTabbedContainer *pPane, CRect &rc)
Call this method to get a caption rectangle.
virtual CRect | GetCaptionGripperRect (const CXTPDockingPaneTabbedContainer *pPane)
Call this method to get a caption gripper for a tabbed container.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1, int nPen)
Draws a line.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1)
Draws a line.
int | DrawCaptionText (CDC *pDC, const CString &strTitle, CRect rc, BOOL bVertical, BOOL bCalcWidth=FALSE)
Draws the text of a pane caption.
void | Pixel (CDC *pDC, int xPos, int yPos, int nPen)
Sets the pixel at the point.
void | Rectangle (CDC *pDC, CRect rc, int nPenEntry, int nPenBorder)
Draws a rectangle.
void | UseOfficeFont (BOOL bUseOfficeFont)
Call this member to use Office (Tahoma) font.
void | SetCaptionFontIndirect (LOGFONT *pLogFont, BOOL bUseStandardFont=FALSE)
Call this method to set the caption's font.
CXTPTabPaintManager * | SetTabPaintManager (CXTPTabPaintManager *pManager)
Call this method to set the paint manager used to draw tabs of a tabbed container.
CXTPTabPaintManager * | SetPanelPaintManager (CXTPTabPaintManager *pManager)
Call this method to set the paint manager used to draw tabs of an auto-hide panel.
CXTPTabPaintManager * | GetTabPaintManager () const
Retrieves the paint manager used to draw tabs of a tabbed container.
CXTPTabPaintManager * | GetPanelPaintManager () const
Retrieves the paint manager used to draw tabs of an auto-hide panel.
COLORREF | GetXtremeColor (UINT nIndex)
Retrieves the current color of the specified XP display element.
void | SetColors (int cElements, CONST INT *lpaElements, CONST COLORREF *lpaRgbValues)
Call this member to set the colors for each element in an array to the colors in a specified color array.
int | GetCaptionHeight () const
Call this member to get the caption height of the tabbed container.
int | GetTabsHeight () const
Call this member to get tabs height of the tabbed container.
void | SetSplitterStyle (DWORD dwStyle)
Call this member to set the splitter style.
DWORD | GetSplitterStyle () const
Call this method to get the splitter style.
void | SetCaptionButtonStyle (XTPDockingPaneCaptionButtonStyle nStyle)
Call this member to set the caption button style.
XTPDockingPaneCaptionButtonStyle | GetCaptionButtonStyle () const
Call this method to get the caption button style.
XTPCurrentSystemTheme | GetCurrentSystemTheme () const
Call this member function to determine the current Windows XP theme in use.
void | SetLunaTheme (XTPCurrentSystemTheme systemTheme)
Call this method to force system theme.
virtual void | DrawAutoHidePanel (CDC *pDC, CRect rc, XTPDockingPaneDirection direction)
This mmethod is called by the framework to draw the docking pane auto-hide panel background and splitter.
void | SetCustomTitleBrushes (HBRUSH hbrActiveTitleHorz, HBRUSH hbrInactiveTitleHorz=NULL, HBRUSH hbrActiveTitleVert=NULL, HBRUSH hbrInactiveTitleVert=NULL, BOOL bDestroyOnCleanup=FALSE)
Sets custom title brushes.
HBRUSH | GetCustomTitleBrush (BOOL bActive, BOOL bVertical) const
Obtains the custom title brush.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Attributes

COLORREF | m_clrCaptionBorder
Color used to draw the border of the pane caption.
- Protected Attributes inherited from CXTPDockingPaneVisualStudio2003Theme
BOOL | m_bGradientCaption
TRUE to draw gradient caption.
- Protected Attributes inherited from CXTPDockingPanePaintManager
XTPDockingPaneCaptionButtonStyle | m_nCaptionButtonStyle
Caption button style.
DWORD | m_dwSplitterStyle
Splitter style.
int | m_nTitleHeight
Title's height.
int | m_nCaptionFontGap
Additional gap of font.
int | m_nTabsHeight
Tab bar's height.
CXTPFont | m_xtpFontTitle
Title font.
CXTPFont | m_xtpFontTitleVertical
Title vertical font.
BOOL | m_bUseOfficeFont
TRUE to use Tahoma font.
BOOL | m_bUseStandardFont
TRUE to use system icon font.
BOOL | m_bDestroyCustomTitleBrushes
If TRUE, custom title bushes will be destroyed on cleanup.
HBRUSH | m_hbrActiveTitleHorz
Optional user specified active horizontal title brush.
HBRUSH | m_hbrInactiveTitleHorz
Optional user specified inactive horizontal title brush.
HBRUSH | m_hbrActiveTitleVert
Optional user specified active vertical title brush.
HBRUSH | m_hbrInactiveTitleVert
Optional user specified inactive vertical title brush.
CXTPTabPaintManager * | m_pTabPaintManager
Paint Manager used to draw tabs for a tabbed container.
CXTPTabPaintManager * | m_pPanelPaintManager
Paint Manager used to draw tabs for an auto-hide panel.
COLORREF | m_arrColor [XPCOLOR_LAST+1]
Self colors array.
XTPDockingPanePaintTheme | m_themeCurrent
Current theme.
CString | m_strOfficeFont
Office font name.
CRect | m_rcCaptionMargin
Margins of caption.
XTPCurrentSystemTheme | m_systemTheme
Current system theme.
CXTPWinThemeWrapper * | m_themeToolbar
Toolbar theme helper.
CXTPWinThemeWrapper * | m_themeExplorer
WinXP Explorer theme helper.
CXTPWinThemeWrapper * | m_themeButton
WinXP Button theme helper.
CXTPWinThemeWrapper * | m_themeWindow
WinXP Window Theme helper.
CXTPWinThemeWrapper * | m_themeRebar
Rebar theme helper.
BOOL | m_bLunaTheme
TRUE if luna colors are used.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPDockingPanePaintManager
BOOL | m_bUseBoldCaptionFont
TRUE to use bold font for caption.
BOOL | m_bHighlightActiveCaption
TRUE to highlight active caption.
int | m_nSplitterSize
Splitter size.
BOOL | m_bShowCaption
TRUE to draw captions of tabbed containers.
BOOL | m_bDrawSingleTab
TRUE to draw single tab.
BOOL | m_bDrawCaptionIcon
TRUE to draw caption icon.
int | m_nSplitterIndent
Size of splitter indent.
CXTPPaintManagerColor | m_clrBackground
Background color.
CXTPPaintManagerColor | m_clrSplitterGripper
Splitter gripper color.
CXTPPaintManagerColor | m_clrSplitter
Splitter color.
CXTPPaintManagerColorGradient | m_clrSplitterGradient
Splitter gradient color.
CXTPPaintManagerColorGradient | m_clrNormalCaption
Color of pane caption when inactive.
CXTPPaintManagerColorGradient | m_clrActiveCaption
Color of pane caption when active.
CXTPPaintManagerColor | m_clrNormalCaptionText
Color of pane caption text when the caption is inactive.
CXTPPaintManagerColor | m_clrActiveCaptionText
Active caption text.
CXTPPaintManagerColor | m_clrDisabledCaptionText
Disabled caption text.
- Protected Member Functions inherited from CXTPDockingPaneVisualStudio2003Theme
virtual void | DrawCaptionPart (CDC *pDC, CXTPDockingPaneBase *pPane, CRect rcCaption, const CString &strTitle, BOOL bActive, BOOL bVertical)
Draws the common part of a tabbed and floating caption.
- Protected Member Functions inherited from CXTPDockingPaneGripperedTheme
- Protected Member Functions inherited from CXTPDockingPaneDefaultTheme
- Protected Member Functions inherited from CXTPDockingPanePaintManager
CXTPDockingPanePaintManager ()
Constructs a CXTPDockingPanePaintManager object.
virtual | ~CXTPDockingPanePaintManager ()
Destroys a CXTPDockingPanePaintManager object, handles cleanup and deallocation.
virtual void | DrawCaptionButtonEntry (CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton, CSize szOffset)
Draws only the glyph of a button.
virtual void | DrawCaptionButtonEntry (CDC *pDC, CXTPDockingPaneCaptionButton *pButton, CPoint pt, COLORREF clrButton)
Draws only the glyph of a button.
void | ClipAndAddEllipsisIfNeeded (CDC *pDC, CString &strTitle, int nCaptionWidth) const
Clip string and add ellipsis if its width less than nCaptionWidth.

Detailed Description

CXTPDockingPaneVisualStudio2005Beta2Theme is CXTPDockingPaneVisualStudio2005Beta1Theme derived class that represents a Visual Studio 2005 Beta 2 theme for docking panes.

Call CXTPDockingPaneManager::SetTheme(xtpPaneThemeVisualStudio2005Beta2); to set this theme.

Member Function Documentation

◆ FillCaptionPart()

virtual COLORREF FillCaptionPart | ( | CDC * | pDC,
 |  | CXTPDockingPaneBase * | pPane,
 |  | CRect | rcCaption,
 |  | BOOL | bActive,
 |  | BOOL | bVertical )
 virtual

Draws the background of the pane caption.

Parameters
pDC | Reference to the device context in which to draw.
pPane | Container which the caption needs to draw the background.
rcCaption | Caption bounding rectangle.
bActive | TRUE if the caption is active.
bVertical | TRUE to draw the caption vertically.
Returns

Reimplemented from CXTPDockingPaneVisualStudio2003Theme.

Reimplemented in CXTPDockingPaneVisualStudio2010Theme.

The documentation for this class was generated from the following file:
  • XTPDockingPaneThemeVisualStudio2005Beta2.h


Toolkit Pro: CXTPDockingPaneVisualStudio2005Theme Class Reference

Public Member Functions | List of all members
CXTPDockingPaneVisualStudio2005Theme Class Reference

CXTPDockingPaneVisualStudio2005Theme is a CXTPDockingPaneVisualStudio2005Beta2Theme derived class that represents a Visual Studio 2005 theme for docking panes. More...

Inheritance diagram for CXTPDockingPaneVisualStudio2005Theme:
[legend]

Public Member Functions

CXTPDockingPaneVisualStudio2005Theme ()
Constructs a CXTPDockingPaneVisualStudio2005Theme object.
- Public Member Functions inherited from CXTPDockingPaneVisualStudio2005Beta2Theme
CXTPDockingPaneVisualStudio2005Beta2Theme ()
Constructs a CXTPDockingPaneVisualStudio2005Beta2Theme object.
void | RefreshMetrics ()
This method is called to refresh the visual metrics of the pane.
virtual COLORREF | FillCaptionPart (CDC *pDC, CXTPDockingPaneBase *pPane, CRect rcCaption, BOOL bActive, BOOL bVertical)
Draws the background of the pane caption.
- Public Member Functions inherited from CXTPDockingPaneVisualStudio2005Beta1Theme
CXTPDockingPaneVisualStudio2005Beta1Theme ()
Constructs a CXTPDockingPaneVisualStudio2005Beta1Theme object.
- Public Member Functions inherited from CXTPDockingPaneVisualStudio2003Theme
CXTPDockingPaneVisualStudio2003Theme ()
Constructs a CXTPDockingPaneVisualStudio2003Theme object.
- Public Member Functions inherited from CXTPDockingPaneGripperedTheme
CXTPDockingPaneGripperedTheme ()
Constructs a CXTPDockingPaneGripperedTheme object.
void | DrawFloatingFrame (CDC *pDC, CXTPDockingPaneMiniWnd *pPane, CRect rc)
Call this method to draw the frame of a floating window.
virtual void | DrawCaption (CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc)
Override this member function to draw a caption.
- Public Member Functions inherited from CXTPDockingPaneDefaultTheme
CXTPDockingPaneDefaultTheme ()
Constructs a CXTPDockingPaneDefaultTheme object.
virtual void | DrawSidePanel (CDC *pDC, CXTPDockingPaneSidePanel *pPane, CRect rc)
Override this member function to draw the side panel.
- Public Member Functions inherited from CXTPDockingPanePaintManager
virtual void | DrawPane (CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc)
Override this member function to draw a tabbed container.
virtual CRect | GetPaneCaptionRect (const CXTPDockingPaneSidePanel *pPane)
Call this method to get the pane's caption rectangle.
virtual void | DrawSplitter (CDC *pDC, CXTPDockingPaneSplitterWnd *pSplitter)
Override this method to draw a splitter.
virtual void | DrawCaptionButtons (CDC *pDC, CXTPDockingPaneCaptionButtons *pButtons, CRect &rcCaption, COLORREF clr, int nButtonSize, int nButtonGap, BOOL bVertical=FALSE)
Override this member function to draw buttons for a tabbed caption.
virtual void | DrawCaptionButton (CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton)
Override this member function to draw a button for a tabbed caption.
virtual void | AdjustClientRect (CXTPDockingPaneSidePanel *pPane, CRect &rect)
Override this member to change the client rectangle of the child docking pane.
virtual void | AdjustClientRect (CXTPDockingPaneTabbedContainer *pPane, CRect &rect, BOOL bApply)
Override this member to change the client rectangle of the child docking pane.
virtual void | AdjustCaptionRect (const CXTPDockingPaneSidePanel *pPane, CRect &rc)
Override this member to change the caption rectangle of the child docking pane.
virtual void | AdjustCaptionRect (const CXTPDockingPaneTabbedContainer *pPane, CRect &rc)
Override this member to change the caption rectangle of the child docking pane.
virtual void | GetCaptionRect (const CXTPDockingPaneTabbedContainer *pPane, CRect &rc)
Call this method to get a caption rectangle.
virtual CRect | GetCaptionGripperRect (const CXTPDockingPaneTabbedContainer *pPane)
Call this method to get a caption gripper for a tabbed container.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1, int nPen)
Draws a line.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1)
Draws a line.
int | DrawCaptionText (CDC *pDC, const CString &strTitle, CRect rc, BOOL bVertical, BOOL bCalcWidth=FALSE)
Draws the text of a pane caption.
void | Pixel (CDC *pDC, int xPos, int yPos, int nPen)
Sets the pixel at the point.
void | Rectangle (CDC *pDC, CRect rc, int nPenEntry, int nPenBorder)
Draws a rectangle.
void | UseOfficeFont (BOOL bUseOfficeFont)
Call this member to use Office (Tahoma) font.
void | SetCaptionFontIndirect (LOGFONT *pLogFont, BOOL bUseStandardFont=FALSE)
Call this method to set the caption's font.
CXTPTabPaintManager * | SetTabPaintManager (CXTPTabPaintManager *pManager)
Call this method to set the paint manager used to draw tabs of a tabbed container.
CXTPTabPaintManager * | SetPanelPaintManager (CXTPTabPaintManager *pManager)
Call this method to set the paint manager used to draw tabs of an auto-hide panel.
CXTPTabPaintManager * | GetTabPaintManager () const
Retrieves the paint manager used to draw tabs of a tabbed container.
CXTPTabPaintManager * | GetPanelPaintManager () const
Retrieves the paint manager used to draw tabs of an auto-hide panel.
COLORREF | GetXtremeColor (UINT nIndex)
Retrieves the current color of the specified XP display element.
void | SetColors (int cElements, CONST INT *lpaElements, CONST COLORREF *lpaRgbValues)
Call this member to set the colors for each element in an array to the colors in a specified color array.
int | GetCaptionHeight () const
Call this member to get the caption height of the tabbed container.
int | GetTabsHeight () const
Call this member to get tabs height of the tabbed container.
void | SetSplitterStyle (DWORD dwStyle)
Call this member to set the splitter style.
DWORD | GetSplitterStyle () const
Call this method to get the splitter style.
void | SetCaptionButtonStyle (XTPDockingPaneCaptionButtonStyle nStyle)
Call this member to set the caption button style.
XTPDockingPaneCaptionButtonStyle | GetCaptionButtonStyle () const
Call this method to get the caption button style.
XTPCurrentSystemTheme | GetCurrentSystemTheme () const
Call this member function to determine the current Windows XP theme in use.
void | SetLunaTheme (XTPCurrentSystemTheme systemTheme)
Call this method to force system theme.
virtual void | DrawAutoHidePanel (CDC *pDC, CRect rc, XTPDockingPaneDirection direction)
This mmethod is called by the framework to draw the docking pane auto-hide panel background and splitter.
void | SetCustomTitleBrushes (HBRUSH hbrActiveTitleHorz, HBRUSH hbrInactiveTitleHorz=NULL, HBRUSH hbrActiveTitleVert=NULL, HBRUSH hbrInactiveTitleVert=NULL, BOOL bDestroyOnCleanup=FALSE)
Sets custom title brushes.
HBRUSH | GetCustomTitleBrush (BOOL bActive, BOOL bVertical) const
Obtains the custom title brush.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPDockingPanePaintManager
BOOL | m_bUseBoldCaptionFont
TRUE to use bold font for caption.
BOOL | m_bHighlightActiveCaption
TRUE to highlight active caption.
int | m_nSplitterSize
Splitter size.
BOOL | m_bShowCaption
TRUE to draw captions of tabbed containers.
BOOL | m_bDrawSingleTab
TRUE to draw single tab.
BOOL | m_bDrawCaptionIcon
TRUE to draw caption icon.
int | m_nSplitterIndent
Size of splitter indent.
CXTPPaintManagerColor | m_clrBackground
Background color.
CXTPPaintManagerColor | m_clrSplitterGripper
Splitter gripper color.
CXTPPaintManagerColor | m_clrSplitter
Splitter color.
CXTPPaintManagerColorGradient | m_clrSplitterGradient
Splitter gradient color.
CXTPPaintManagerColorGradient | m_clrNormalCaption
Color of pane caption when inactive.
CXTPPaintManagerColorGradient | m_clrActiveCaption
Color of pane caption when active.
CXTPPaintManagerColor | m_clrNormalCaptionText
Color of pane caption text when the caption is inactive.
CXTPPaintManagerColor | m_clrActiveCaptionText
Active caption text.
CXTPPaintManagerColor | m_clrDisabledCaptionText
Disabled caption text.
- Protected Member Functions inherited from CXTPDockingPaneVisualStudio2003Theme
virtual void | DrawCaptionPart (CDC *pDC, CXTPDockingPaneBase *pPane, CRect rcCaption, const CString &strTitle, BOOL bActive, BOOL bVertical)
Draws the common part of a tabbed and floating caption.
- Protected Member Functions inherited from CXTPDockingPaneGripperedTheme
- Protected Member Functions inherited from CXTPDockingPaneDefaultTheme
- Protected Member Functions inherited from CXTPDockingPanePaintManager
CXTPDockingPanePaintManager ()
Constructs a CXTPDockingPanePaintManager object.
virtual | ~CXTPDockingPanePaintManager ()
Destroys a CXTPDockingPanePaintManager object, handles cleanup and deallocation.
virtual void | DrawCaptionButtonEntry (CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton, CSize szOffset)
Draws only the glyph of a button.
virtual void | DrawCaptionButtonEntry (CDC *pDC, CXTPDockingPaneCaptionButton *pButton, CPoint pt, COLORREF clrButton)
Draws only the glyph of a button.
void | ClipAndAddEllipsisIfNeeded (CDC *pDC, CString &strTitle, int nCaptionWidth) const
Clip string and add ellipsis if its width less than nCaptionWidth.
- Protected Attributes inherited from CXTPDockingPaneVisualStudio2005Beta2Theme
COLORREF | m_clrCaptionBorder
Color used to draw the border of the pane caption.
- Protected Attributes inherited from CXTPDockingPaneVisualStudio2003Theme
BOOL | m_bGradientCaption
TRUE to draw gradient caption.
- Protected Attributes inherited from CXTPDockingPanePaintManager
XTPDockingPaneCaptionButtonStyle | m_nCaptionButtonStyle
Caption button style.
DWORD | m_dwSplitterStyle
Splitter style.
int | m_nTitleHeight
Title's height.
int | m_nCaptionFontGap
Additional gap of font.
int | m_nTabsHeight
Tab bar's height.
CXTPFont | m_xtpFontTitle
Title font.
CXTPFont | m_xtpFontTitleVertical
Title vertical font.
BOOL | m_bUseOfficeFont
TRUE to use Tahoma font.
BOOL | m_bUseStandardFont
TRUE to use system icon font.
BOOL | m_bDestroyCustomTitleBrushes
If TRUE, custom title bushes will be destroyed on cleanup.
HBRUSH | m_hbrActiveTitleHorz
Optional user specified active horizontal title brush.
HBRUSH | m_hbrInactiveTitleHorz
Optional user specified inactive horizontal title brush.
HBRUSH | m_hbrActiveTitleVert
Optional user specified active vertical title brush.
HBRUSH | m_hbrInactiveTitleVert
Optional user specified inactive vertical title brush.
CXTPTabPaintManager * | m_pTabPaintManager
Paint Manager used to draw tabs for a tabbed container.
CXTPTabPaintManager * | m_pPanelPaintManager
Paint Manager used to draw tabs for an auto-hide panel.
COLORREF | m_arrColor [XPCOLOR_LAST+1]
Self colors array.
XTPDockingPanePaintTheme | m_themeCurrent
Current theme.
CString | m_strOfficeFont
Office font name.
CRect | m_rcCaptionMargin
Margins of caption.
XTPCurrentSystemTheme | m_systemTheme
Current system theme.
CXTPWinThemeWrapper * | m_themeToolbar
Toolbar theme helper.
CXTPWinThemeWrapper * | m_themeExplorer
WinXP Explorer theme helper.
CXTPWinThemeWrapper * | m_themeButton
WinXP Button theme helper.
CXTPWinThemeWrapper * | m_themeWindow
WinXP Window Theme helper.
CXTPWinThemeWrapper * | m_themeRebar
Rebar theme helper.
BOOL | m_bLunaTheme
TRUE if luna colors are used.

Detailed Description

CXTPDockingPaneVisualStudio2005Theme is a CXTPDockingPaneVisualStudio2005Beta2Theme derived class that represents a Visual Studio 2005 theme for docking panes.

Call CXTPDockingPaneManager::SetTheme(xtpPaneThemeVisualStudio2005); to set this theme.

The documentation for this class was generated from the following file:
  • XTPDockingPaneThemeVisualStudio2005.h


Toolkit Pro: CXTPDockingPaneVisualStudio2008Theme Class Reference

Public Member Functions | List of all members
CXTPDockingPaneVisualStudio2008Theme Class Reference

CXTPDockingPaneVisualStudio2008Theme is a CXTPDockingPaneVisualStudio2005Theme derived class that represents a Visual Studio 2008 theme for docking panes. More...

Inheritance diagram for CXTPDockingPaneVisualStudio2008Theme:
[legend]

Public Member Functions

CXTPDockingPaneVisualStudio2008Theme ()
Constructs a CXTPDockingPaneVisualStudio2008Theme object.
virtual void | RefreshMetrics ()
This method is called to refresh the visual metrics of manager.
- Public Member Functions inherited from CXTPDockingPaneVisualStudio2005Theme
CXTPDockingPaneVisualStudio2005Theme ()
Constructs a CXTPDockingPaneVisualStudio2005Theme object.
- Public Member Functions inherited from CXTPDockingPaneVisualStudio2005Beta2Theme
CXTPDockingPaneVisualStudio2005Beta2Theme ()
Constructs a CXTPDockingPaneVisualStudio2005Beta2Theme object.
virtual COLORREF | FillCaptionPart (CDC *pDC, CXTPDockingPaneBase *pPane, CRect rcCaption, BOOL bActive, BOOL bVertical)
Draws the background of the pane caption.
- Public Member Functions inherited from CXTPDockingPaneVisualStudio2005Beta1Theme
CXTPDockingPaneVisualStudio2005Beta1Theme ()
Constructs a CXTPDockingPaneVisualStudio2005Beta1Theme object.
- Public Member Functions inherited from CXTPDockingPaneVisualStudio2003Theme
CXTPDockingPaneVisualStudio2003Theme ()
Constructs a CXTPDockingPaneVisualStudio2003Theme object.
- Public Member Functions inherited from CXTPDockingPaneGripperedTheme
CXTPDockingPaneGripperedTheme ()
Constructs a CXTPDockingPaneGripperedTheme object.
void | DrawFloatingFrame (CDC *pDC, CXTPDockingPaneMiniWnd *pPane, CRect rc)
Call this method to draw the frame of a floating window.
virtual void | DrawCaption (CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc)
Override this member function to draw a caption.
- Public Member Functions inherited from CXTPDockingPaneDefaultTheme
CXTPDockingPaneDefaultTheme ()
Constructs a CXTPDockingPaneDefaultTheme object.
virtual void | DrawSidePanel (CDC *pDC, CXTPDockingPaneSidePanel *pPane, CRect rc)
Override this member function to draw the side panel.
- Public Member Functions inherited from CXTPDockingPanePaintManager
virtual void | DrawPane (CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc)
Override this member function to draw a tabbed container.
virtual CRect | GetPaneCaptionRect (const CXTPDockingPaneSidePanel *pPane)
Call this method to get the pane's caption rectangle.
virtual void | DrawSplitter (CDC *pDC, CXTPDockingPaneSplitterWnd *pSplitter)
Override this method to draw a splitter.
virtual void | DrawCaptionButtons (CDC *pDC, CXTPDockingPaneCaptionButtons *pButtons, CRect &rcCaption, COLORREF clr, int nButtonSize, int nButtonGap, BOOL bVertical=FALSE)
Override this member function to draw buttons for a tabbed caption.
virtual void | DrawCaptionButton (CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton)
Override this member function to draw a button for a tabbed caption.
virtual void | AdjustClientRect (CXTPDockingPaneSidePanel *pPane, CRect &rect)
Override this member to change the client rectangle of the child docking pane.
virtual void | AdjustClientRect (CXTPDockingPaneTabbedContainer *pPane, CRect &rect, BOOL bApply)
Override this member to change the client rectangle of the child docking pane.
virtual void | AdjustCaptionRect (const CXTPDockingPaneSidePanel *pPane, CRect &rc)
Override this member to change the caption rectangle of the child docking pane.
virtual void | AdjustCaptionRect (const CXTPDockingPaneTabbedContainer *pPane, CRect &rc)
Override this member to change the caption rectangle of the child docking pane.
virtual void | GetCaptionRect (const CXTPDockingPaneTabbedContainer *pPane, CRect &rc)
Call this method to get a caption rectangle.
virtual CRect | GetCaptionGripperRect (const CXTPDockingPaneTabbedContainer *pPane)
Call this method to get a caption gripper for a tabbed container.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1, int nPen)
Draws a line.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1)
Draws a line.
int | DrawCaptionText (CDC *pDC, const CString &strTitle, CRect rc, BOOL bVertical, BOOL bCalcWidth=FALSE)
Draws the text of a pane caption.
void | Pixel (CDC *pDC, int xPos, int yPos, int nPen)
Sets the pixel at the point.
void | Rectangle (CDC *pDC, CRect rc, int nPenEntry, int nPenBorder)
Draws a rectangle.
void | UseOfficeFont (BOOL bUseOfficeFont)
Call this member to use Office (Tahoma) font.
void | SetCaptionFontIndirect (LOGFONT *pLogFont, BOOL bUseStandardFont=FALSE)
Call this method to set the caption's font.
CXTPTabPaintManager * | SetTabPaintManager (CXTPTabPaintManager *pManager)
Call this method to set the paint manager used to draw tabs of a tabbed container.
CXTPTabPaintManager * | SetPanelPaintManager (CXTPTabPaintManager *pManager)
Call this method to set the paint manager used to draw tabs of an auto-hide panel.
CXTPTabPaintManager * | GetTabPaintManager () const
Retrieves the paint manager used to draw tabs of a tabbed container.
CXTPTabPaintManager * | GetPanelPaintManager () const
Retrieves the paint manager used to draw tabs of an auto-hide panel.
COLORREF | GetXtremeColor (UINT nIndex)
Retrieves the current color of the specified XP display element.
void | SetColors (int cElements, CONST INT *lpaElements, CONST COLORREF *lpaRgbValues)
Call this member to set the colors for each element in an array to the colors in a specified color array.
int | GetCaptionHeight () const
Call this member to get the caption height of the tabbed container.
int | GetTabsHeight () const
Call this member to get tabs height of the tabbed container.
void | SetSplitterStyle (DWORD dwStyle)
Call this member to set the splitter style.
DWORD | GetSplitterStyle () const
Call this method to get the splitter style.
void | SetCaptionButtonStyle (XTPDockingPaneCaptionButtonStyle nStyle)
Call this member to set the caption button style.
XTPDockingPaneCaptionButtonStyle | GetCaptionButtonStyle () const
Call this method to get the caption button style.
XTPCurrentSystemTheme | GetCurrentSystemTheme () const
Call this member function to determine the current Windows XP theme in use.
void | SetLunaTheme (XTPCurrentSystemTheme systemTheme)
Call this method to force system theme.
virtual void | DrawAutoHidePanel (CDC *pDC, CRect rc, XTPDockingPaneDirection direction)
This mmethod is called by the framework to draw the docking pane auto-hide panel background and splitter.
void | SetCustomTitleBrushes (HBRUSH hbrActiveTitleHorz, HBRUSH hbrInactiveTitleHorz=NULL, HBRUSH hbrActiveTitleVert=NULL, HBRUSH hbrInactiveTitleVert=NULL, BOOL bDestroyOnCleanup=FALSE)
Sets custom title brushes.
HBRUSH | GetCustomTitleBrush (BOOL bActive, BOOL bVertical) const
Obtains the custom title brush.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPDockingPanePaintManager
BOOL | m_bUseBoldCaptionFont
TRUE to use bold font for caption.
BOOL | m_bHighlightActiveCaption
TRUE to highlight active caption.
int | m_nSplitterSize
Splitter size.
BOOL | m_bShowCaption
TRUE to draw captions of tabbed containers.
BOOL | m_bDrawSingleTab
TRUE to draw single tab.
BOOL | m_bDrawCaptionIcon
TRUE to draw caption icon.
int | m_nSplitterIndent
Size of splitter indent.
CXTPPaintManagerColor | m_clrBackground
Background color.
CXTPPaintManagerColor | m_clrSplitterGripper
Splitter gripper color.
CXTPPaintManagerColor | m_clrSplitter
Splitter color.
CXTPPaintManagerColorGradient | m_clrSplitterGradient
Splitter gradient color.
CXTPPaintManagerColorGradient | m_clrNormalCaption
Color of pane caption when inactive.
CXTPPaintManagerColorGradient | m_clrActiveCaption
Color of pane caption when active.
CXTPPaintManagerColor | m_clrNormalCaptionText
Color of pane caption text when the caption is inactive.
CXTPPaintManagerColor | m_clrActiveCaptionText
Active caption text.
CXTPPaintManagerColor | m_clrDisabledCaptionText
Disabled caption text.
- Protected Member Functions inherited from CXTPDockingPaneVisualStudio2003Theme
virtual void | DrawCaptionPart (CDC *pDC, CXTPDockingPaneBase *pPane, CRect rcCaption, const CString &strTitle, BOOL bActive, BOOL bVertical)
Draws the common part of a tabbed and floating caption.
- Protected Member Functions inherited from CXTPDockingPaneGripperedTheme
- Protected Member Functions inherited from CXTPDockingPaneDefaultTheme
- Protected Member Functions inherited from CXTPDockingPanePaintManager
CXTPDockingPanePaintManager ()
Constructs a CXTPDockingPanePaintManager object.
virtual | ~CXTPDockingPanePaintManager ()
Destroys a CXTPDockingPanePaintManager object, handles cleanup and deallocation.
virtual void | DrawCaptionButtonEntry (CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton, CSize szOffset)
Draws only the glyph of a button.
virtual void | DrawCaptionButtonEntry (CDC *pDC, CXTPDockingPaneCaptionButton *pButton, CPoint pt, COLORREF clrButton)
Draws only the glyph of a button.
void | ClipAndAddEllipsisIfNeeded (CDC *pDC, CString &strTitle, int nCaptionWidth) const
Clip string and add ellipsis if its width less than nCaptionWidth.
- Protected Attributes inherited from CXTPDockingPaneVisualStudio2005Beta2Theme
COLORREF | m_clrCaptionBorder
Color used to draw the border of the pane caption.
- Protected Attributes inherited from CXTPDockingPaneVisualStudio2003Theme
BOOL | m_bGradientCaption
TRUE to draw gradient caption.
- Protected Attributes inherited from CXTPDockingPanePaintManager
XTPDockingPaneCaptionButtonStyle | m_nCaptionButtonStyle
Caption button style.
DWORD | m_dwSplitterStyle
Splitter style.
int | m_nTitleHeight
Title's height.
int | m_nCaptionFontGap
Additional gap of font.
int | m_nTabsHeight
Tab bar's height.
CXTPFont | m_xtpFontTitle
Title font.
CXTPFont | m_xtpFontTitleVertical
Title vertical font.
BOOL | m_bUseOfficeFont
TRUE to use Tahoma font.
BOOL | m_bUseStandardFont
TRUE to use system icon font.
BOOL | m_bDestroyCustomTitleBrushes
If TRUE, custom title bushes will be destroyed on cleanup.
HBRUSH | m_hbrActiveTitleHorz
Optional user specified active horizontal title brush.
HBRUSH | m_hbrInactiveTitleHorz
Optional user specified inactive horizontal title brush.
HBRUSH | m_hbrActiveTitleVert
Optional user specified active vertical title brush.
HBRUSH | m_hbrInactiveTitleVert
Optional user specified inactive vertical title brush.
CXTPTabPaintManager * | m_pTabPaintManager
Paint Manager used to draw tabs for a tabbed container.
CXTPTabPaintManager * | m_pPanelPaintManager
Paint Manager used to draw tabs for an auto-hide panel.
COLORREF | m_arrColor [XPCOLOR_LAST+1]
Self colors array.
XTPDockingPanePaintTheme | m_themeCurrent
Current theme.
CString | m_strOfficeFont
Office font name.
CRect | m_rcCaptionMargin
Margins of caption.
XTPCurrentSystemTheme | m_systemTheme
Current system theme.
CXTPWinThemeWrapper * | m_themeToolbar
Toolbar theme helper.
CXTPWinThemeWrapper * | m_themeExplorer
WinXP Explorer theme helper.
CXTPWinThemeWrapper * | m_themeButton
WinXP Button theme helper.
CXTPWinThemeWrapper * | m_themeWindow
WinXP Window Theme helper.
CXTPWinThemeWrapper * | m_themeRebar
Rebar theme helper.
BOOL | m_bLunaTheme
TRUE if luna colors are used.

Detailed Description

CXTPDockingPaneVisualStudio2008Theme is a CXTPDockingPaneVisualStudio2005Theme derived class that represents a Visual Studio 2008 theme for docking panes.

Call CXTPDockingPaneManager::SetTheme(xtpPaneThemeVisualStudio2008); to set this theme.

The documentation for this class was generated from the following file:
  • XTPDockingPaneThemeVisualStudio2008.h


Toolkit Pro: CXTPDockingPaneVisualStudio2010Theme Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPDockingPaneVisualStudio2010Theme Class Reference

CXTPDockingPaneVisualStudio2010Theme is a CXTPDockingPaneVisualStudio2008Theme derived class that represents a Visual Studio 2010 theme for docking panes. More...

Inheritance diagram for CXTPDockingPaneVisualStudio2010Theme:
[legend]

Public Member Functions

CXTPDockingPaneVisualStudio2010Theme ()
Constructs a CXTPDockingPaneVisualStudio2010Theme object.
virtual void | RefreshMetrics ()
This method is called to refresh the visual metrics of manager.
- Public Member Functions inherited from CXTPDockingPaneVisualStudio2008Theme
CXTPDockingPaneVisualStudio2008Theme ()
Constructs a CXTPDockingPaneVisualStudio2008Theme object.
- Public Member Functions inherited from CXTPDockingPaneVisualStudio2005Theme
CXTPDockingPaneVisualStudio2005Theme ()
Constructs a CXTPDockingPaneVisualStudio2005Theme object.
- Public Member Functions inherited from CXTPDockingPaneVisualStudio2005Beta2Theme
CXTPDockingPaneVisualStudio2005Beta2Theme ()
Constructs a CXTPDockingPaneVisualStudio2005Beta2Theme object.
- Public Member Functions inherited from CXTPDockingPaneVisualStudio2005Beta1Theme
CXTPDockingPaneVisualStudio2005Beta1Theme ()
Constructs a CXTPDockingPaneVisualStudio2005Beta1Theme object.
- Public Member Functions inherited from CXTPDockingPaneVisualStudio2003Theme
CXTPDockingPaneVisualStudio2003Theme ()
Constructs a CXTPDockingPaneVisualStudio2003Theme object.
- Public Member Functions inherited from CXTPDockingPaneGripperedTheme
CXTPDockingPaneGripperedTheme ()
Constructs a CXTPDockingPaneGripperedTheme object.
virtual void | DrawCaption (CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc)
Override this member function to draw a caption.
- Public Member Functions inherited from CXTPDockingPaneDefaultTheme
CXTPDockingPaneDefaultTheme ()
Constructs a CXTPDockingPaneDefaultTheme object.
virtual void | DrawSidePanel (CDC *pDC, CXTPDockingPaneSidePanel *pPane, CRect rc)
Override this member function to draw the side panel.
- Public Member Functions inherited from CXTPDockingPanePaintManager
virtual void | DrawPane (CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc)
Override this member function to draw a tabbed container.
virtual CRect | GetPaneCaptionRect (const CXTPDockingPaneSidePanel *pPane)
Call this method to get the pane's caption rectangle.
virtual void | DrawSplitter (CDC *pDC, CXTPDockingPaneSplitterWnd *pSplitter)
Override this method to draw a splitter.
virtual void | DrawCaptionButtons (CDC *pDC, CXTPDockingPaneCaptionButtons *pButtons, CRect &rcCaption, COLORREF clr, int nButtonSize, int nButtonGap, BOOL bVertical=FALSE)
Override this member function to draw buttons for a tabbed caption.
virtual void | DrawCaptionButton (CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton)
Override this member function to draw a button for a tabbed caption.
virtual void | AdjustClientRect (CXTPDockingPaneSidePanel *pPane, CRect &rect)
Override this member to change the client rectangle of the child docking pane.
virtual void | AdjustClientRect (CXTPDockingPaneTabbedContainer *pPane, CRect &rect, BOOL bApply)
Override this member to change the client rectangle of the child docking pane.
virtual void | AdjustCaptionRect (const CXTPDockingPaneSidePanel *pPane, CRect &rc)
Override this member to change the caption rectangle of the child docking pane.
virtual void | AdjustCaptionRect (const CXTPDockingPaneTabbedContainer *pPane, CRect &rc)
Override this member to change the caption rectangle of the child docking pane.
virtual void | GetCaptionRect (const CXTPDockingPaneTabbedContainer *pPane, CRect &rc)
Call this method to get a caption rectangle.
virtual CRect | GetCaptionGripperRect (const CXTPDockingPaneTabbedContainer *pPane)
Call this method to get a caption gripper for a tabbed container.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1, int nPen)
Draws a line.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1)
Draws a line.
int | DrawCaptionText (CDC *pDC, const CString &strTitle, CRect rc, BOOL bVertical, BOOL bCalcWidth=FALSE)
Draws the text of a pane caption.
void | Pixel (CDC *pDC, int xPos, int yPos, int nPen)
Sets the pixel at the point.
void | Rectangle (CDC *pDC, CRect rc, int nPenEntry, int nPenBorder)
Draws a rectangle.
void | UseOfficeFont (BOOL bUseOfficeFont)
Call this member to use Office (Tahoma) font.
void | SetCaptionFontIndirect (LOGFONT *pLogFont, BOOL bUseStandardFont=FALSE)
Call this method to set the caption's font.
CXTPTabPaintManager * | SetTabPaintManager (CXTPTabPaintManager *pManager)
Call this method to set the paint manager used to draw tabs of a tabbed container.
CXTPTabPaintManager * | SetPanelPaintManager (CXTPTabPaintManager *pManager)
Call this method to set the paint manager used to draw tabs of an auto-hide panel.
CXTPTabPaintManager * | GetTabPaintManager () const
Retrieves the paint manager used to draw tabs of a tabbed container.
CXTPTabPaintManager * | GetPanelPaintManager () const
Retrieves the paint manager used to draw tabs of an auto-hide panel.
COLORREF | GetXtremeColor (UINT nIndex)
Retrieves the current color of the specified XP display element.
void | SetColors (int cElements, CONST INT *lpaElements, CONST COLORREF *lpaRgbValues)
Call this member to set the colors for each element in an array to the colors in a specified color array.
int | GetCaptionHeight () const
Call this member to get the caption height of the tabbed container.
int | GetTabsHeight () const
Call this member to get tabs height of the tabbed container.
void | SetSplitterStyle (DWORD dwStyle)
Call this member to set the splitter style.
DWORD | GetSplitterStyle () const
Call this method to get the splitter style.
void | SetCaptionButtonStyle (XTPDockingPaneCaptionButtonStyle nStyle)
Call this member to set the caption button style.
XTPDockingPaneCaptionButtonStyle | GetCaptionButtonStyle () const
Call this method to get the caption button style.
XTPCurrentSystemTheme | GetCurrentSystemTheme () const
Call this member function to determine the current Windows XP theme in use.
void | SetLunaTheme (XTPCurrentSystemTheme systemTheme)
Call this method to force system theme.
virtual void | DrawAutoHidePanel (CDC *pDC, CRect rc, XTPDockingPaneDirection direction)
This mmethod is called by the framework to draw the docking pane auto-hide panel background and splitter.
void | SetCustomTitleBrushes (HBRUSH hbrActiveTitleHorz, HBRUSH hbrInactiveTitleHorz=NULL, HBRUSH hbrActiveTitleVert=NULL, HBRUSH hbrInactiveTitleVert=NULL, BOOL bDestroyOnCleanup=FALSE)
Sets custom title brushes.
HBRUSH | GetCustomTitleBrush (BOOL bActive, BOOL bVertical) const
Obtains the custom title brush.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

virtual COLORREF | FillCaptionPart (CDC *pDC, CXTPDockingPaneBase *pPane, CRect rcCaption, BOOL bActive, BOOL bVertical)
Draws the background of the pane caption.
void | DrawFloatingFrame (CDC *pDC, CXTPDockingPaneMiniWnd *pPane, CRect rc)
Call this method to draw the frame of a floating window.
- Protected Member Functions inherited from CXTPDockingPaneVisualStudio2003Theme
virtual void | DrawCaptionPart (CDC *pDC, CXTPDockingPaneBase *pPane, CRect rcCaption, const CString &strTitle, BOOL bActive, BOOL bVertical)
Draws the common part of a tabbed and floating caption.
- Protected Member Functions inherited from CXTPDockingPaneGripperedTheme
- Protected Member Functions inherited from CXTPDockingPaneDefaultTheme
- Protected Member Functions inherited from CXTPDockingPanePaintManager
CXTPDockingPanePaintManager ()
Constructs a CXTPDockingPanePaintManager object.
virtual | ~CXTPDockingPanePaintManager ()
Destroys a CXTPDockingPanePaintManager object, handles cleanup and deallocation.
virtual void | DrawCaptionButtonEntry (CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton, CSize szOffset)
Draws only the glyph of a button.
virtual void | DrawCaptionButtonEntry (CDC *pDC, CXTPDockingPaneCaptionButton *pButton, CPoint pt, COLORREF clrButton)
Draws only the glyph of a button.
void | ClipAndAddEllipsisIfNeeded (CDC *pDC, CString &strTitle, int nCaptionWidth) const
Clip string and add ellipsis if its width less than nCaptionWidth.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPDockingPanePaintManager
BOOL | m_bUseBoldCaptionFont
TRUE to use bold font for caption.
BOOL | m_bHighlightActiveCaption
TRUE to highlight active caption.
int | m_nSplitterSize
Splitter size.
BOOL | m_bShowCaption
TRUE to draw captions of tabbed containers.
BOOL | m_bDrawSingleTab
TRUE to draw single tab.
BOOL | m_bDrawCaptionIcon
TRUE to draw caption icon.
int | m_nSplitterIndent
Size of splitter indent.
CXTPPaintManagerColor | m_clrBackground
Background color.
CXTPPaintManagerColor | m_clrSplitterGripper
Splitter gripper color.
CXTPPaintManagerColor | m_clrSplitter
Splitter color.
CXTPPaintManagerColorGradient | m_clrSplitterGradient
Splitter gradient color.
CXTPPaintManagerColorGradient | m_clrNormalCaption
Color of pane caption when inactive.
CXTPPaintManagerColorGradient | m_clrActiveCaption
Color of pane caption when active.
CXTPPaintManagerColor | m_clrNormalCaptionText
Color of pane caption text when the caption is inactive.
CXTPPaintManagerColor | m_clrActiveCaptionText
Active caption text.
CXTPPaintManagerColor | m_clrDisabledCaptionText
Disabled caption text.
- Protected Attributes inherited from CXTPDockingPaneVisualStudio2005Beta2Theme
COLORREF | m_clrCaptionBorder
Color used to draw the border of the pane caption.
- Protected Attributes inherited from CXTPDockingPaneVisualStudio2003Theme
BOOL | m_bGradientCaption
TRUE to draw gradient caption.
- Protected Attributes inherited from CXTPDockingPanePaintManager
XTPDockingPaneCaptionButtonStyle | m_nCaptionButtonStyle
Caption button style.
DWORD | m_dwSplitterStyle
Splitter style.
int | m_nTitleHeight
Title's height.
int | m_nCaptionFontGap
Additional gap of font.
int | m_nTabsHeight
Tab bar's height.
CXTPFont | m_xtpFontTitle
Title font.
CXTPFont | m_xtpFontTitleVertical
Title vertical font.
BOOL | m_bUseOfficeFont
TRUE to use Tahoma font.
BOOL | m_bUseStandardFont
TRUE to use system icon font.
BOOL | m_bDestroyCustomTitleBrushes
If TRUE, custom title bushes will be destroyed on cleanup.
HBRUSH | m_hbrActiveTitleHorz
Optional user specified active horizontal title brush.
HBRUSH | m_hbrInactiveTitleHorz
Optional user specified inactive horizontal title brush.
HBRUSH | m_hbrActiveTitleVert
Optional user specified active vertical title brush.
HBRUSH | m_hbrInactiveTitleVert
Optional user specified inactive vertical title brush.
CXTPTabPaintManager * | m_pTabPaintManager
Paint Manager used to draw tabs for a tabbed container.
CXTPTabPaintManager * | m_pPanelPaintManager
Paint Manager used to draw tabs for an auto-hide panel.
COLORREF | m_arrColor [XPCOLOR_LAST+1]
Self colors array.
XTPDockingPanePaintTheme | m_themeCurrent
Current theme.
CString | m_strOfficeFont
Office font name.
CRect | m_rcCaptionMargin
Margins of caption.
XTPCurrentSystemTheme | m_systemTheme
Current system theme.
CXTPWinThemeWrapper * | m_themeToolbar
Toolbar theme helper.
CXTPWinThemeWrapper * | m_themeExplorer
WinXP Explorer theme helper.
CXTPWinThemeWrapper * | m_themeButton
WinXP Button theme helper.
CXTPWinThemeWrapper * | m_themeWindow
WinXP Window Theme helper.
CXTPWinThemeWrapper * | m_themeRebar
Rebar theme helper.
BOOL | m_bLunaTheme
TRUE if luna colors are used.

Detailed Description

CXTPDockingPaneVisualStudio2010Theme is a CXTPDockingPaneVisualStudio2008Theme derived class that represents a Visual Studio 2010 theme for docking panes.

Call CXTPDockingPaneManager::SetTheme(xtpPaneThemeVisualStudio2010); to set this theme.

Member Function Documentation

◆ DrawFloatingFrame()

void DrawFloatingFrame | ( | CDC * | pDC,
 |  | CXTPDockingPaneMiniWnd * | pPane,
 |  | CRect | rc )
 protectedvirtual

Call this method to draw the frame of a floating window.

Parameters
pDC | Pointer to a valid device context.
pPane | Floating window pointer.
rc | Client rectangle of floating frame.

Reimplemented from CXTPDockingPaneGripperedTheme.

◆ FillCaptionPart()

virtual COLORREF FillCaptionPart | ( | CDC * | pDC,
 |  | CXTPDockingPaneBase * | pPane,
 |  | CRect | rcCaption,
 |  | BOOL | bActive,
 |  | BOOL | bVertical )
 protectedvirtual

Draws the background of the pane caption.

Parameters
pDC | Reference to the device context in which to draw.
pPane | Container which the caption needs to draw the background.
rcCaption | Caption bounding rectangle.
bActive | TRUE if the caption is active.
bVertical | TRUE to draw the caption vertically.
Returns
Caption text color value.

Reimplemented from CXTPDockingPaneVisualStudio2005Beta2Theme.

The documentation for this class was generated from the following file:
  • XTPDockingPaneThemeVisualStudio2010.h


Toolkit Pro: CXTPDockingPaneVisualStudio2012Theme Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPDockingPaneVisualStudio2012Theme Class Reference

CXTPDockingPaneVisualStudio2012Theme is used to define drawing routines specific to a Visual Studio 2012 docking pane theme. More...

Inheritance diagram for CXTPDockingPaneVisualStudio2012Theme:
[legend]

Public Member Functions

CXTPDockingPaneVisualStudio2012Theme ()
Constructs a CXTPDockingPaneVisualStudio2012Theme object.
virtual | ~CXTPDockingPaneVisualStudio2012Theme ()
Destroys a CXTPDockingPaneVisualStudio2012Theme object, handles cleanup and deallocation.
virtual void | RefreshMetrics ()
This member function is used to initialize default colors for a theme from an .INI resource.
virtual CRect | GetPaneCaptionRect (const CXTPDockingPaneSidePanel *pPane)
Call this method to get the pane's caption rectangle.
virtual void | AdjustClientRect (CXTPDockingPaneTabbedContainer *pPane, CRect &rc, BOOL bApply)
Override this member to change the client rectangle of the child docking pane.
virtual void | AdjustCaptionRect (const CXTPDockingPaneTabbedContainer *pPane, CRect &rc)
Override this member to change the caption rectangle of the child docking pane.
virtual void | DrawSplitter (CDC *pDC, CXTPDockingPaneSplitterWnd *pSplitter)
Override this method to draw a splitter.
virtual void | DrawCaption (CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc)
Override this member function to draw a caption.
virtual void | DrawFloatingFrame (CDC *pDC, CXTPDockingPaneMiniWnd *pPane, CRect rc)
Call this method to draw the frame of a floating window.
virtual void | DrawPane (CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc)
Override this member function to draw a tabbed container.
virtual void | DrawSidePanel (CDC *pDC, CXTPDockingPaneSidePanel *pPane, CRect rc)
Override this member function to draw the side panel.
virtual void | DrawCaptionButton (CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton)
Override this member function to draw a button for a tabbed caption.
virtual void | DrawAutoHidePanel (CDC *pDC, CRect rc, XTPDockingPaneDirection direction)
This method is called by the framework to draw the docking pane auto-hide panel background and splitter.
- Public Member Functions inherited from CXTPDockingPaneDefaultTheme
CXTPDockingPaneDefaultTheme ()
Constructs a CXTPDockingPaneDefaultTheme object.
- Public Member Functions inherited from CXTPDockingPanePaintManager
virtual void | DrawCaptionButtons (CDC *pDC, CXTPDockingPaneCaptionButtons *pButtons, CRect &rcCaption, COLORREF clr, int nButtonSize, int nButtonGap, BOOL bVertical=FALSE)
Override this member function to draw buttons for a tabbed caption.
virtual void | AdjustClientRect (CXTPDockingPaneSidePanel *pPane, CRect &rect)
Override this member to change the client rectangle of the child docking pane.
virtual void | AdjustCaptionRect (const CXTPDockingPaneSidePanel *pPane, CRect &rc)
Override this member to change the caption rectangle of the child docking pane.
virtual void | GetCaptionRect (const CXTPDockingPaneTabbedContainer *pPane, CRect &rc)
Call this method to get a caption rectangle.
virtual CRect | GetCaptionGripperRect (const CXTPDockingPaneTabbedContainer *pPane)
Call this method to get a caption gripper for a tabbed container.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1, int nPen)
Draws a line.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1)
Draws a line.
int | DrawCaptionText (CDC *pDC, const CString &strTitle, CRect rc, BOOL bVertical, BOOL bCalcWidth=FALSE)
Draws the text of a pane caption.
void | Pixel (CDC *pDC, int xPos, int yPos, int nPen)
Sets the pixel at the point.
void | Rectangle (CDC *pDC, CRect rc, int nPenEntry, int nPenBorder)
Draws a rectangle.
void | UseOfficeFont (BOOL bUseOfficeFont)
Call this member to use Office (Tahoma) font.
void | SetCaptionFontIndirect (LOGFONT *pLogFont, BOOL bUseStandardFont=FALSE)
Call this method to set the caption's font.
CXTPTabPaintManager * | SetTabPaintManager (CXTPTabPaintManager *pManager)
Call this method to set the paint manager used to draw tabs of a tabbed container.
CXTPTabPaintManager * | SetPanelPaintManager (CXTPTabPaintManager *pManager)
Call this method to set the paint manager used to draw tabs of an auto-hide panel.
CXTPTabPaintManager * | GetTabPaintManager () const
Retrieves the paint manager used to draw tabs of a tabbed container.
CXTPTabPaintManager * | GetPanelPaintManager () const
Retrieves the paint manager used to draw tabs of an auto-hide panel.
COLORREF | GetXtremeColor (UINT nIndex)
Retrieves the current color of the specified XP display element.
void | SetColors (int cElements, CONST INT *lpaElements, CONST COLORREF *lpaRgbValues)
Call this member to set the colors for each element in an array to the colors in a specified color array.
int | GetCaptionHeight () const
Call this member to get the caption height of the tabbed container.
int | GetTabsHeight () const
Call this member to get tabs height of the tabbed container.
void | SetSplitterStyle (DWORD dwStyle)
Call this member to set the splitter style.
DWORD | GetSplitterStyle () const
Call this method to get the splitter style.
void | SetCaptionButtonStyle (XTPDockingPaneCaptionButtonStyle nStyle)
Call this member to set the caption button style.
XTPDockingPaneCaptionButtonStyle | GetCaptionButtonStyle () const
Call this method to get the caption button style.
XTPCurrentSystemTheme | GetCurrentSystemTheme () const
Call this member function to determine the current Windows XP theme in use.
void | SetLunaTheme (XTPCurrentSystemTheme systemTheme)
Call this method to force system theme.
void | SetCustomTitleBrushes (HBRUSH hbrActiveTitleHorz, HBRUSH hbrInactiveTitleHorz=NULL, HBRUSH hbrActiveTitleVert=NULL, HBRUSH hbrInactiveTitleVert=NULL, BOOL bDestroyOnCleanup=FALSE)
Sets custom title brushes.
HBRUSH | GetCustomTitleBrush (BOOL bActive, BOOL bVertical) const
Obtains the custom title brush.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

virtual void | DrawTitleBar (CDC *pDC, CXTPDockingPaneBase *pPane, CRect rc, BOOL bVertical)
This member function is called to draw a title bar for the docking pane.
void | DrawGripper (CDC *pDC, CRect rcGripper, COLORREF clr, BOOL bVertical)
This member function is called to draw a gripper for the docking pane.
void | DrawDottedLine (CDC *pDC, int x, int y, int nSize, COLORREF clr, BOOL bVertical)
This member function is called to draw a dotted line.
virtual CXTPDockingPaneColorSet * | GetColorSet (BOOL bActive)
Call this member function to retrieve the active or inactive color set for the Docking Pane using the state specified by bActive.
void | SetPaneColorSets (CXTPDockingPaneColorSet *pcsActive, CXTPDockingPaneColorSet *pcsInactive)
Called to initialize the active and inactive colors sets for the docking pane theme.
void | DeletePaneColorSets ()
Called to free the memory allocated for the docking pane active and inactive color sets.
- Protected Member Functions inherited from CXTPDockingPaneDefaultTheme
virtual void | DrawCaptionPart (CDC *pDC, CXTPDockingPaneBase *pPane, CRect rcCaption, const CString &strTitle, BOOL bActive, BOOL bVertical)
Draws the common part of a tabbed and floating caption.
- Protected Member Functions inherited from CXTPDockingPanePaintManager
CXTPDockingPanePaintManager ()
Constructs a CXTPDockingPanePaintManager object.
virtual | ~CXTPDockingPanePaintManager ()
Destroys a CXTPDockingPanePaintManager object, handles cleanup and deallocation.
virtual void | DrawCaptionButtonEntry (CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton, CSize szOffset)
Draws only the glyph of a button.
virtual void | DrawCaptionButtonEntry (CDC *pDC, CXTPDockingPaneCaptionButton *pButton, CPoint pt, COLORREF clrButton)
Draws only the glyph of a button.
void | ClipAndAddEllipsisIfNeeded (CDC *pDC, CString &strTitle, int nCaptionWidth) const
Clip string and add ellipsis if its width less than nCaptionWidth.

Protected Attributes

CXTPDockingPaneColorSet * | m_pcsActive
Active state docking pane colors.
CXTPDockingPaneColorSet * | m_pcsInactive
Inactive state docking pane colors.
CString | m_strFontFace
Font face name.
int | m_nFontSize
Font size in points.
- Protected Attributes inherited from CXTPDockingPanePaintManager
XTPDockingPaneCaptionButtonStyle | m_nCaptionButtonStyle
Caption button style.
DWORD | m_dwSplitterStyle
Splitter style.
int | m_nTitleHeight
Title's height.
int | m_nCaptionFontGap
Additional gap of font.
int | m_nTabsHeight
Tab bar's height.
CXTPFont | m_xtpFontTitle
Title font.
CXTPFont | m_xtpFontTitleVertical
Title vertical font.
BOOL | m_bUseOfficeFont
TRUE to use Tahoma font.
BOOL | m_bUseStandardFont
TRUE to use system icon font.
BOOL | m_bDestroyCustomTitleBrushes
If TRUE, custom title bushes will be destroyed on cleanup.
HBRUSH | m_hbrActiveTitleHorz
Optional user specified active horizontal title brush.
HBRUSH | m_hbrInactiveTitleHorz
Optional user specified inactive horizontal title brush.
HBRUSH | m_hbrActiveTitleVert
Optional user specified active vertical title brush.
HBRUSH | m_hbrInactiveTitleVert
Optional user specified inactive vertical title brush.
CXTPTabPaintManager * | m_pTabPaintManager
Paint Manager used to draw tabs for a tabbed container.
CXTPTabPaintManager * | m_pPanelPaintManager
Paint Manager used to draw tabs for an auto-hide panel.
COLORREF | m_arrColor [XPCOLOR_LAST+1]
Self colors array.
XTPDockingPanePaintTheme | m_themeCurrent
Current theme.
CString | m_strOfficeFont
Office font name.
CRect | m_rcCaptionMargin
Margins of caption.
XTPCurrentSystemTheme | m_systemTheme
Current system theme.
CXTPWinThemeWrapper * | m_themeToolbar
Toolbar theme helper.
CXTPWinThemeWrapper * | m_themeExplorer
WinXP Explorer theme helper.
CXTPWinThemeWrapper * | m_themeButton
WinXP Button theme helper.
CXTPWinThemeWrapper * | m_themeWindow
WinXP Window Theme helper.
CXTPWinThemeWrapper * | m_themeRebar
Rebar theme helper.
BOOL | m_bLunaTheme
TRUE if luna colors are used.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPDockingPanePaintManager
BOOL | m_bUseBoldCaptionFont
TRUE to use bold font for caption.
BOOL | m_bHighlightActiveCaption
TRUE to highlight active caption.
int | m_nSplitterSize
Splitter size.
BOOL | m_bShowCaption
TRUE to draw captions of tabbed containers.
BOOL | m_bDrawSingleTab
TRUE to draw single tab.
BOOL | m_bDrawCaptionIcon
TRUE to draw caption icon.
int | m_nSplitterIndent
Size of splitter indent.
CXTPPaintManagerColor | m_clrBackground
Background color.
CXTPPaintManagerColor | m_clrSplitterGripper
Splitter gripper color.
CXTPPaintManagerColor | m_clrSplitter
Splitter color.
CXTPPaintManagerColorGradient | m_clrSplitterGradient
Splitter gradient color.
CXTPPaintManagerColorGradient | m_clrNormalCaption
Color of pane caption when inactive.
CXTPPaintManagerColorGradient | m_clrActiveCaption
Color of pane caption when active.
CXTPPaintManagerColor | m_clrNormalCaptionText
Color of pane caption text when the caption is inactive.
CXTPPaintManagerColor | m_clrActiveCaptionText
Active caption text.
CXTPPaintManagerColor | m_clrDisabledCaptionText
Disabled caption text.

Detailed Description

CXTPDockingPaneVisualStudio2012Theme is used to define drawing routines specific to a Visual Studio 2012 docking pane theme.

Member Function Documentation

◆ AdjustCaptionRect()

virtual void AdjustCaptionRect | ( | const CXTPDockingPaneTabbedContainer * | pPane,
 |  | CRect & | rc )
 virtual

Override this member to change the caption rectangle of the child docking pane.

Parameters
pPane | Pointer to a CXTPDockingPaneTabbedContainer object or CXTPDockingPaneSidePanel object.
rc | Caption rectangle to be changed.

Reimplemented from CXTPDockingPanePaintManager.

◆ AdjustClientRect()

virtual void AdjustClientRect | ( | CXTPDockingPaneTabbedContainer * | pPane,
 |  | CRect & | rc,
 |  | BOOL | bApply )
 virtual

Override this member to change the client rectangle of the child docking pane.

Parameters
pPane | Pointer to the tabbed container or side panel.
rc | Client rectangle to be changed.
bApply | TRUE to update tabs inside the client area.

Reimplemented from CXTPDockingPanePaintManager.

◆ DrawAutoHidePanel()

virtual void DrawAutoHidePanel | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | XTPDockingPaneDirection | direction )
 virtual

This method is called by the framework to draw the docking pane auto-hide panel background and splitter.

Parameters
pDC | Pointer to the auto-hide panes device context.
rc | Size of the area to draw.
direction | Docking direction (either xtpPaneDockLeft, xtpPaneDockRight, xtpPaneDockTop or xtpPaneDockBottom).

Reimplemented from CXTPDockingPanePaintManager.

Reimplemented in CXTPDockingPaneNativeWindows10Theme, CXTPDockingPaneNativeWindows11Theme, CXTPDockingPaneOffice2013Theme, CXTPDockingPaneVisualStudio2015Theme, CXTPDockingPaneVisualStudio2017Theme, CXTPDockingPaneVisualStudio2019Theme, and CXTPDockingPaneVisualStudio2022Theme.

◆ DrawCaption()

virtual void DrawCaption | ( | CDC * | pDC,
 |  | CXTPDockingPaneTabbedContainer * | pPane,
 |  | CRect | rc )
 virtual

Override this member function to draw a caption.

Parameters
pDC | Reference to the device context in which to draw.
pPane | Pointer to the tabbed container.
rc | Client rectangle of the tabbed container.

Reimplemented from CXTPDockingPaneDefaultTheme.

Reimplemented in CXTPDockingPaneOffice2013Theme.

◆ DrawCaptionButton()

virtual void DrawCaptionButton | ( | CDC * | pDC,
 |  | CXTPDockingPaneCaptionButton * | pButton,
 |  | COLORREF | clrButton )
 virtual

Override this member function to draw a button for a tabbed caption.

Parameters
pDC | Pointer to a valid device context.
pButton | Pointer to the button to draw.
clrButton | Color of the button's text.

Reimplemented from CXTPDockingPanePaintManager.

Reimplemented in CXTPDockingPaneOffice2013Theme.

◆ DrawDottedLine()

void DrawDottedLine | ( | CDC * | pDC,
 |  | int | x,
 |  | int | y,
 |  | int | nSize,
 |  | COLORREF | clr,
 |  | BOOL | bVertical )
 protected

This member function is called to draw a dotted line.

Parameters
pDC | Pointer to a valid device context.
x | Specifies the left position of the dotted line.
y | Specifies the top position of the dotted line.
nSize | Specifies the length of the dotted line.
clr | Specifies the color of the dotted line.
bVertical | TRUE if the line should be drawn vertically.

◆ DrawFloatingFrame()

virtual void DrawFloatingFrame | ( | CDC * | pDC,
 |  | CXTPDockingPaneMiniWnd * | pPane,
 |  | CRect | rc )
 virtual

Call this method to draw the frame of a floating window.

Parameters
pDC | Pointer to a valid device context.
pPane | Floating window pointer.
rc | Client rectangle of the floating frame.

Reimplemented from CXTPDockingPaneDefaultTheme.

Reimplemented in CXTPDockingPaneOffice2013Theme.

◆ DrawGripper()

void DrawGripper | ( | CDC * | pDC,
 |  | CRect | rcGripper,
 |  | COLORREF | clr,
 |  | BOOL | bVertical )
 protected

This member function is called to draw a gripper for the docking pane.

Parameters
pDC | Pointer to a valid device context.
rcGripper | Size of the gripper to draw.
clr | Specifies the color of the gripper.
bVertical | TRUE it the gripper should be drawn vertically.

◆ DrawPane()

virtual void DrawPane | ( | CDC * | pDC,
 |  | CXTPDockingPaneTabbedContainer * | pPane,
 |  | CRect | rc )
 virtual

Override this member function to draw a tabbed container.

Parameters
pDC | Reference to the device context in which to draw.
pPane | Pointer to the tabbed container.
rc | Client rectangle of the tabbed container.

Reimplemented from CXTPDockingPanePaintManager.

Reimplemented in CXTPDockingPaneOffice2013Theme.

◆ DrawSidePanel()

virtual void DrawSidePanel | ( | CDC * | pDC,
 |  | CXTPDockingPaneSidePanel * | pPane,
 |  | CRect | rc )
 virtual

Override this member function to draw the side panel.

Parameters
pDC | Reference to the device context in which to draw.
pPane | Pointer to the side panel.
rc | Client rectangle of the side panel.

Reimplemented from CXTPDockingPaneDefaultTheme.

Reimplemented in CXTPDockingPaneOffice2013Theme.

◆ DrawSplitter()

virtual void DrawSplitter | ( | CDC * | pDC,
 |  | CXTPDockingPaneSplitterWnd * | pSplitter )
 virtual

Override this method to draw a splitter.

Parameters
pDC | Pointer to a valid device context.
pSplitter | Pointer to a splitter window.

Reimplemented from CXTPDockingPanePaintManager.

Reimplemented in CXTPDockingPaneNativeWindows10Theme, CXTPDockingPaneNativeWindows11Theme, CXTPDockingPaneOffice2013Theme, CXTPDockingPaneVisualStudio2015Theme, CXTPDockingPaneVisualStudio2017Theme, CXTPDockingPaneVisualStudio2019Theme, and CXTPDockingPaneVisualStudio2022Theme.

◆ DrawTitleBar()

virtual void DrawTitleBar | ( | CDC * | pDC,
 |  | CXTPDockingPaneBase * | pPane,
 |  | CRect | rc,
 |  | BOOL | bVertical )
 protectedvirtual

This member function is called to draw a title bar for the docking pane.

Parameters
pDC | Pointer to a valid device context.
pPane | Pointer to a valid CXTPDockingPaneBase object.
rc | Size of the title bar to draw.
bVertical | TRUE if the title bar should be drawn vertically.

Reimplemented in CXTPDockingPaneNativeWindows10Theme, CXTPDockingPaneNativeWindows11Theme, CXTPDockingPaneOffice2013Theme, CXTPDockingPaneVisualStudio2015Theme, CXTPDockingPaneVisualStudio2017Theme, CXTPDockingPaneVisualStudio2019Theme, and CXTPDockingPaneVisualStudio2022Theme.

◆ GetColorSet()

AFX_INLINE CXTPDockingPaneColorSet * GetColorSet ( BOOL bActive )
protectedvirtual

Call this member function to retrieve the active or inactive color set for the Docking Pane using the state specified by bActive.

Parameters
bActive TRUE to retrieve the active color set, FALSE to retrieve the inactive color set.
Returns
A reference to a CXTPDockingPaneColorSet object representing the docking pane state specified by bActive.

◆ GetPaneCaptionRect()

virtual CRect GetPaneCaptionRect ( const CXTPDockingPaneSidePanel * pPane )
virtual

Call this method to get the pane's caption rectangle.

Parameters
pPane Side panel container to get caption CRect.
Returns
Bounding rectangle of the side panel's caption.

Reimplemented from CXTPDockingPanePaintManager.

◆ SetPaneColorSets()

void SetPaneColorSets | ( | CXTPDockingPaneColorSet * | pcsActive,
 |  | CXTPDockingPaneColorSet * | pcsInactive )
 protected

Called to initialize the active and inactive colors sets for the docking pane theme.

Parameters
pcsActive | Pointer to a CXTPDockingPaneColorSet representing the active pane color set.
pcsInactive | Pointer to a CXTPDockingPaneColorSet representing the inactive pane color set.
The documentation for this class was generated from the following file:
  • XTPDockingPaneThemeVisualStudio2012.h


Toolkit Pro: CXTPDockingPaneVisualStudio2015Theme Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPDockingPaneVisualStudio2015Theme Class Reference

CXTPDockingPaneVisualStudio2015Theme is used to define drawing routines specific to a Visual Studio 2015 docking pane theme. More...

Inheritance diagram for CXTPDockingPaneVisualStudio2015Theme:
[legend]

Public Member Functions

CXTPDockingPaneVisualStudio2015Theme ()
Constructs a CXTPDockingPaneVisualStudio2015Theme object.
virtual | ~CXTPDockingPaneVisualStudio2015Theme ()
Destroys a CXTPDockingPaneVisualStudio2015Theme object, handles cleanup and deallocation.
virtual void | RefreshMetrics ()
This member function is used to initialize default colors for a theme from an .INI resource.
virtual void | DrawSplitter (CDC *pDC, CXTPDockingPaneSplitterWnd *pSplitter)
Override this method to draw a splitter.
virtual void | DrawAutoHidePanel (CDC *pDC, CRect rc, XTPDockingPaneDirection direction)
This method is called by the framework to draw the docking pane auto-hide panel background and splitter.
- Public Member Functions inherited from CXTPDockingPaneVisualStudio2012Theme
CXTPDockingPaneVisualStudio2012Theme ()
Constructs a CXTPDockingPaneVisualStudio2012Theme object.
virtual | ~CXTPDockingPaneVisualStudio2012Theme ()
Destroys a CXTPDockingPaneVisualStudio2012Theme object, handles cleanup and deallocation.
virtual CRect | GetPaneCaptionRect (const CXTPDockingPaneSidePanel *pPane)
Call this method to get the pane's caption rectangle.
virtual void | AdjustClientRect (CXTPDockingPaneTabbedContainer *pPane, CRect &rc, BOOL bApply)
Override this member to change the client rectangle of the child docking pane.
virtual void | AdjustCaptionRect (const CXTPDockingPaneTabbedContainer *pPane, CRect &rc)
Override this member to change the caption rectangle of the child docking pane.
virtual void | DrawCaption (CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc)
Override this member function to draw a caption.
virtual void | DrawFloatingFrame (CDC *pDC, CXTPDockingPaneMiniWnd *pPane, CRect rc)
Call this method to draw the frame of a floating window.
virtual void | DrawPane (CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc)
Override this member function to draw a tabbed container.
virtual void | DrawSidePanel (CDC *pDC, CXTPDockingPaneSidePanel *pPane, CRect rc)
Override this member function to draw the side panel.
virtual void | DrawCaptionButton (CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton)
Override this member function to draw a button for a tabbed caption.
- Public Member Functions inherited from CXTPDockingPaneDefaultTheme
CXTPDockingPaneDefaultTheme ()
Constructs a CXTPDockingPaneDefaultTheme object.
- Public Member Functions inherited from CXTPDockingPanePaintManager
virtual void | DrawCaptionButtons (CDC *pDC, CXTPDockingPaneCaptionButtons *pButtons, CRect &rcCaption, COLORREF clr, int nButtonSize, int nButtonGap, BOOL bVertical=FALSE)
Override this member function to draw buttons for a tabbed caption.
virtual void | AdjustClientRect (CXTPDockingPaneSidePanel *pPane, CRect &rect)
Override this member to change the client rectangle of the child docking pane.
virtual void | AdjustCaptionRect (const CXTPDockingPaneSidePanel *pPane, CRect &rc)
Override this member to change the caption rectangle of the child docking pane.
virtual void | GetCaptionRect (const CXTPDockingPaneTabbedContainer *pPane, CRect &rc)
Call this method to get a caption rectangle.
virtual CRect | GetCaptionGripperRect (const CXTPDockingPaneTabbedContainer *pPane)
Call this method to get a caption gripper for a tabbed container.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1, int nPen)
Draws a line.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1)
Draws a line.
int | DrawCaptionText (CDC *pDC, const CString &strTitle, CRect rc, BOOL bVertical, BOOL bCalcWidth=FALSE)
Draws the text of a pane caption.
void | Pixel (CDC *pDC, int xPos, int yPos, int nPen)
Sets the pixel at the point.
void | Rectangle (CDC *pDC, CRect rc, int nPenEntry, int nPenBorder)
Draws a rectangle.
void | UseOfficeFont (BOOL bUseOfficeFont)
Call this member to use Office (Tahoma) font.
void | SetCaptionFontIndirect (LOGFONT *pLogFont, BOOL bUseStandardFont=FALSE)
Call this method to set the caption's font.
CXTPTabPaintManager * | SetTabPaintManager (CXTPTabPaintManager *pManager)
Call this method to set the paint manager used to draw tabs of a tabbed container.
CXTPTabPaintManager * | SetPanelPaintManager (CXTPTabPaintManager *pManager)
Call this method to set the paint manager used to draw tabs of an auto-hide panel.
CXTPTabPaintManager * | GetTabPaintManager () const
Retrieves the paint manager used to draw tabs of a tabbed container.
CXTPTabPaintManager * | GetPanelPaintManager () const
Retrieves the paint manager used to draw tabs of an auto-hide panel.
COLORREF | GetXtremeColor (UINT nIndex)
Retrieves the current color of the specified XP display element.
void | SetColors (int cElements, CONST INT *lpaElements, CONST COLORREF *lpaRgbValues)
Call this member to set the colors for each element in an array to the colors in a specified color array.
int | GetCaptionHeight () const
Call this member to get the caption height of the tabbed container.
int | GetTabsHeight () const
Call this member to get tabs height of the tabbed container.
void | SetSplitterStyle (DWORD dwStyle)
Call this member to set the splitter style.
DWORD | GetSplitterStyle () const
Call this method to get the splitter style.
void | SetCaptionButtonStyle (XTPDockingPaneCaptionButtonStyle nStyle)
Call this member to set the caption button style.
XTPDockingPaneCaptionButtonStyle | GetCaptionButtonStyle () const
Call this method to get the caption button style.
XTPCurrentSystemTheme | GetCurrentSystemTheme () const
Call this member function to determine the current Windows XP theme in use.
void | SetLunaTheme (XTPCurrentSystemTheme systemTheme)
Call this method to force system theme.
void | SetCustomTitleBrushes (HBRUSH hbrActiveTitleHorz, HBRUSH hbrInactiveTitleHorz=NULL, HBRUSH hbrActiveTitleVert=NULL, HBRUSH hbrInactiveTitleVert=NULL, BOOL bDestroyOnCleanup=FALSE)
Sets custom title brushes.
HBRUSH | GetCustomTitleBrush (BOOL bActive, BOOL bVertical) const
Obtains the custom title brush.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

virtual void | DrawTitleBar (CDC *pDC, CXTPDockingPaneBase *pPane, CRect rc, BOOL bVertical)
This member function is called to draw a title bar for the docking pane.
- Protected Member Functions inherited from CXTPDockingPaneVisualStudio2012Theme
void | DrawGripper (CDC *pDC, CRect rcGripper, COLORREF clr, BOOL bVertical)
This member function is called to draw a gripper for the docking pane.
void | DrawDottedLine (CDC *pDC, int x, int y, int nSize, COLORREF clr, BOOL bVertical)
This member function is called to draw a dotted line.
virtual CXTPDockingPaneColorSet * | GetColorSet (BOOL bActive)
Call this member function to retrieve the active or inactive color set for the Docking Pane using the state specified by bActive.
void | SetPaneColorSets (CXTPDockingPaneColorSet *pcsActive, CXTPDockingPaneColorSet *pcsInactive)
Called to initialize the active and inactive colors sets for the docking pane theme.
void | DeletePaneColorSets ()
Called to free the memory allocated for the docking pane active and inactive color sets.
- Protected Member Functions inherited from CXTPDockingPaneDefaultTheme
virtual void | DrawCaptionPart (CDC *pDC, CXTPDockingPaneBase *pPane, CRect rcCaption, const CString &strTitle, BOOL bActive, BOOL bVertical)
Draws the common part of a tabbed and floating caption.
- Protected Member Functions inherited from CXTPDockingPanePaintManager
CXTPDockingPanePaintManager ()
Constructs a CXTPDockingPanePaintManager object.
virtual | ~CXTPDockingPanePaintManager ()
Destroys a CXTPDockingPanePaintManager object, handles cleanup and deallocation.
virtual void | DrawCaptionButtonEntry (CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton, CSize szOffset)
Draws only the glyph of a button.
virtual void | DrawCaptionButtonEntry (CDC *pDC, CXTPDockingPaneCaptionButton *pButton, CPoint pt, COLORREF clrButton)
Draws only the glyph of a button.
void | ClipAndAddEllipsisIfNeeded (CDC *pDC, CString &strTitle, int nCaptionWidth) const
Clip string and add ellipsis if its width less than nCaptionWidth.

Protected Attributes

COLORREF | m_clrCaptionBorder
Caption border color.
- Protected Attributes inherited from CXTPDockingPaneVisualStudio2012Theme
CXTPDockingPaneColorSet * | m_pcsActive
Active state docking pane colors.
CXTPDockingPaneColorSet * | m_pcsInactive
Inactive state docking pane colors.
CString | m_strFontFace
Font face name.
int | m_nFontSize
Font size in points.
- Protected Attributes inherited from CXTPDockingPanePaintManager
XTPDockingPaneCaptionButtonStyle | m_nCaptionButtonStyle
Caption button style.
DWORD | m_dwSplitterStyle
Splitter style.
int | m_nTitleHeight
Title's height.
int | m_nCaptionFontGap
Additional gap of font.
int | m_nTabsHeight
Tab bar's height.
CXTPFont | m_xtpFontTitle
Title font.
CXTPFont | m_xtpFontTitleVertical
Title vertical font.
BOOL | m_bUseOfficeFont
TRUE to use Tahoma font.
BOOL | m_bUseStandardFont
TRUE to use system icon font.
BOOL | m_bDestroyCustomTitleBrushes
If TRUE, custom title bushes will be destroyed on cleanup.
HBRUSH | m_hbrActiveTitleHorz
Optional user specified active horizontal title brush.
HBRUSH | m_hbrInactiveTitleHorz
Optional user specified inactive horizontal title brush.
HBRUSH | m_hbrActiveTitleVert
Optional user specified active vertical title brush.
HBRUSH | m_hbrInactiveTitleVert
Optional user specified inactive vertical title brush.
CXTPTabPaintManager * | m_pTabPaintManager
Paint Manager used to draw tabs for a tabbed container.
CXTPTabPaintManager * | m_pPanelPaintManager
Paint Manager used to draw tabs for an auto-hide panel.
COLORREF | m_arrColor [XPCOLOR_LAST+1]
Self colors array.
XTPDockingPanePaintTheme | m_themeCurrent
Current theme.
CString | m_strOfficeFont
Office font name.
CRect | m_rcCaptionMargin
Margins of caption.
XTPCurrentSystemTheme | m_systemTheme
Current system theme.
CXTPWinThemeWrapper * | m_themeToolbar
Toolbar theme helper.
CXTPWinThemeWrapper * | m_themeExplorer
WinXP Explorer theme helper.
CXTPWinThemeWrapper * | m_themeButton
WinXP Button theme helper.
CXTPWinThemeWrapper * | m_themeWindow
WinXP Window Theme helper.
CXTPWinThemeWrapper * | m_themeRebar
Rebar theme helper.
BOOL | m_bLunaTheme
TRUE if luna colors are used.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPDockingPanePaintManager
BOOL | m_bUseBoldCaptionFont
TRUE to use bold font for caption.
BOOL | m_bHighlightActiveCaption
TRUE to highlight active caption.
int | m_nSplitterSize
Splitter size.
BOOL | m_bShowCaption
TRUE to draw captions of tabbed containers.
BOOL | m_bDrawSingleTab
TRUE to draw single tab.
BOOL | m_bDrawCaptionIcon
TRUE to draw caption icon.
int | m_nSplitterIndent
Size of splitter indent.
CXTPPaintManagerColor | m_clrBackground
Background color.
CXTPPaintManagerColor | m_clrSplitterGripper
Splitter gripper color.
CXTPPaintManagerColor | m_clrSplitter
Splitter color.
CXTPPaintManagerColorGradient | m_clrSplitterGradient
Splitter gradient color.
CXTPPaintManagerColorGradient | m_clrNormalCaption
Color of pane caption when inactive.
CXTPPaintManagerColorGradient | m_clrActiveCaption
Color of pane caption when active.
CXTPPaintManagerColor | m_clrNormalCaptionText
Color of pane caption text when the caption is inactive.
CXTPPaintManagerColor | m_clrActiveCaptionText
Active caption text.
CXTPPaintManagerColor | m_clrDisabledCaptionText
Disabled caption text.

Detailed Description

CXTPDockingPaneVisualStudio2015Theme is used to define drawing routines specific to a Visual Studio 2015 docking pane theme.

Member Function Documentation

◆ DrawAutoHidePanel()

virtual void DrawAutoHidePanel | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | XTPDockingPaneDirection | direction )
 virtual

This method is called by the framework to draw the docking pane auto-hide panel background and splitter.

Parameters
pDC | Pointer to the auto-hide panes device context.
rc | Size of the area to draw.
direction | Docking direction (either xtpPaneDockLeft, xtpPaneDockRight, xtpPaneDockTop or xtpPaneDockBottom).

Reimplemented from CXTPDockingPaneVisualStudio2012Theme.

◆ DrawSplitter()

virtual void DrawSplitter | ( | CDC * | pDC,
 |  | CXTPDockingPaneSplitterWnd * | pSplitter )
 virtual

Override this method to draw a splitter.

Parameters
pDC | Pointer to a valid device context.
pSplitter | Pointer to a splitter window.

Reimplemented from CXTPDockingPaneVisualStudio2012Theme.

◆ DrawTitleBar()

virtual void DrawTitleBar | ( | CDC * | pDC,
 |  | CXTPDockingPaneBase * | pPane,
 |  | CRect | rc,
 |  | BOOL | bVertical )
 protectedvirtual

This member function is called to draw a title bar for the docking pane.

Parameters
pDC | Pointer to a valid device context.
pPane | Pointer to a valid CXTPDockingPaneBase object.
rc | Size of the title bar to draw.
bVertical | TRUE if the title bar should be drawn vertically.

Reimplemented from CXTPDockingPaneVisualStudio2012Theme.

The documentation for this class was generated from the following file:
  • XTPDockingPaneThemeVisualStudio2015.h


Toolkit Pro: CXTPDockingPaneVisualStudio2017Theme Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPDockingPaneVisualStudio2017Theme Class Reference

CXTPDockingPaneVisualStudio2017Theme is used to define drawing routines specific to a Visual Studio 2017 docking pane theme. More...

Inheritance diagram for CXTPDockingPaneVisualStudio2017Theme:
[legend]

Public Member Functions

CXTPDockingPaneVisualStudio2017Theme ()
Constructs a CXTPDockingPaneVisualStudio2017Theme object.
virtual | ~CXTPDockingPaneVisualStudio2017Theme ()
Destroys a CXTPDockingPaneVisualStudio2017Theme object, handles cleanup and deallocation.
virtual void | RefreshMetrics ()
This member function is used to initialize default colors for a theme from an .INI resource.
virtual void | DrawSplitter (CDC *pDC, CXTPDockingPaneSplitterWnd *pSplitter)
Override this method to draw a splitter.
virtual void | DrawAutoHidePanel (CDC *pDC, CRect rc, XTPDockingPaneDirection direction)
This method is called by the framework to draw the docking pane auto-hide panel background and splitter.
- Public Member Functions inherited from CXTPDockingPaneVisualStudio2012Theme
CXTPDockingPaneVisualStudio2012Theme ()
Constructs a CXTPDockingPaneVisualStudio2012Theme object.
virtual | ~CXTPDockingPaneVisualStudio2012Theme ()
Destroys a CXTPDockingPaneVisualStudio2012Theme object, handles cleanup and deallocation.
virtual CRect | GetPaneCaptionRect (const CXTPDockingPaneSidePanel *pPane)
Call this method to get the pane's caption rectangle.
virtual void | AdjustClientRect (CXTPDockingPaneTabbedContainer *pPane, CRect &rc, BOOL bApply)
Override this member to change the client rectangle of the child docking pane.
virtual void | AdjustCaptionRect (const CXTPDockingPaneTabbedContainer *pPane, CRect &rc)
Override this member to change the caption rectangle of the child docking pane.
virtual void | DrawCaption (CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc)
Override this member function to draw a caption.
virtual void | DrawFloatingFrame (CDC *pDC, CXTPDockingPaneMiniWnd *pPane, CRect rc)
Call this method to draw the frame of a floating window.
virtual void | DrawPane (CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc)
Override this member function to draw a tabbed container.
virtual void | DrawSidePanel (CDC *pDC, CXTPDockingPaneSidePanel *pPane, CRect rc)
Override this member function to draw the side panel.
virtual void | DrawCaptionButton (CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton)
Override this member function to draw a button for a tabbed caption.
- Public Member Functions inherited from CXTPDockingPaneDefaultTheme
CXTPDockingPaneDefaultTheme ()
Constructs a CXTPDockingPaneDefaultTheme object.
- Public Member Functions inherited from CXTPDockingPanePaintManager
virtual void | DrawCaptionButtons (CDC *pDC, CXTPDockingPaneCaptionButtons *pButtons, CRect &rcCaption, COLORREF clr, int nButtonSize, int nButtonGap, BOOL bVertical=FALSE)
Override this member function to draw buttons for a tabbed caption.
virtual void | AdjustClientRect (CXTPDockingPaneSidePanel *pPane, CRect &rect)
Override this member to change the client rectangle of the child docking pane.
virtual void | AdjustCaptionRect (const CXTPDockingPaneSidePanel *pPane, CRect &rc)
Override this member to change the caption rectangle of the child docking pane.
virtual void | GetCaptionRect (const CXTPDockingPaneTabbedContainer *pPane, CRect &rc)
Call this method to get a caption rectangle.
virtual CRect | GetCaptionGripperRect (const CXTPDockingPaneTabbedContainer *pPane)
Call this method to get a caption gripper for a tabbed container.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1, int nPen)
Draws a line.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1)
Draws a line.
int | DrawCaptionText (CDC *pDC, const CString &strTitle, CRect rc, BOOL bVertical, BOOL bCalcWidth=FALSE)
Draws the text of a pane caption.
void | Pixel (CDC *pDC, int xPos, int yPos, int nPen)
Sets the pixel at the point.
void | Rectangle (CDC *pDC, CRect rc, int nPenEntry, int nPenBorder)
Draws a rectangle.
void | UseOfficeFont (BOOL bUseOfficeFont)
Call this member to use Office (Tahoma) font.
void | SetCaptionFontIndirect (LOGFONT *pLogFont, BOOL bUseStandardFont=FALSE)
Call this method to set the caption's font.
CXTPTabPaintManager * | SetTabPaintManager (CXTPTabPaintManager *pManager)
Call this method to set the paint manager used to draw tabs of a tabbed container.
CXTPTabPaintManager * | SetPanelPaintManager (CXTPTabPaintManager *pManager)
Call this method to set the paint manager used to draw tabs of an auto-hide panel.
CXTPTabPaintManager * | GetTabPaintManager () const
Retrieves the paint manager used to draw tabs of a tabbed container.
CXTPTabPaintManager * | GetPanelPaintManager () const
Retrieves the paint manager used to draw tabs of an auto-hide panel.
COLORREF | GetXtremeColor (UINT nIndex)
Retrieves the current color of the specified XP display element.
void | SetColors (int cElements, CONST INT *lpaElements, CONST COLORREF *lpaRgbValues)
Call this member to set the colors for each element in an array to the colors in a specified color array.
int | GetCaptionHeight () const
Call this member to get the caption height of the tabbed container.
int | GetTabsHeight () const
Call this member to get tabs height of the tabbed container.
void | SetSplitterStyle (DWORD dwStyle)
Call this member to set the splitter style.
DWORD | GetSplitterStyle () const
Call this method to get the splitter style.
void | SetCaptionButtonStyle (XTPDockingPaneCaptionButtonStyle nStyle)
Call this member to set the caption button style.
XTPDockingPaneCaptionButtonStyle | GetCaptionButtonStyle () const
Call this method to get the caption button style.
XTPCurrentSystemTheme | GetCurrentSystemTheme () const
Call this member function to determine the current Windows XP theme in use.
void | SetLunaTheme (XTPCurrentSystemTheme systemTheme)
Call this method to force system theme.
void | SetCustomTitleBrushes (HBRUSH hbrActiveTitleHorz, HBRUSH hbrInactiveTitleHorz=NULL, HBRUSH hbrActiveTitleVert=NULL, HBRUSH hbrInactiveTitleVert=NULL, BOOL bDestroyOnCleanup=FALSE)
Sets custom title brushes.
HBRUSH | GetCustomTitleBrush (BOOL bActive, BOOL bVertical) const
Obtains the custom title brush.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

virtual void | DrawTitleBar (CDC *pDC, CXTPDockingPaneBase *pPane, CRect rc, BOOL bVertical)
This member function is called to draw a title bar for the docking pane.
- Protected Member Functions inherited from CXTPDockingPaneVisualStudio2012Theme
void | DrawGripper (CDC *pDC, CRect rcGripper, COLORREF clr, BOOL bVertical)
This member function is called to draw a gripper for the docking pane.
void | DrawDottedLine (CDC *pDC, int x, int y, int nSize, COLORREF clr, BOOL bVertical)
This member function is called to draw a dotted line.
virtual CXTPDockingPaneColorSet * | GetColorSet (BOOL bActive)
Call this member function to retrieve the active or inactive color set for the Docking Pane using the state specified by bActive.
void | SetPaneColorSets (CXTPDockingPaneColorSet *pcsActive, CXTPDockingPaneColorSet *pcsInactive)
Called to initialize the active and inactive colors sets for the docking pane theme.
void | DeletePaneColorSets ()
Called to free the memory allocated for the docking pane active and inactive color sets.
- Protected Member Functions inherited from CXTPDockingPaneDefaultTheme
virtual void | DrawCaptionPart (CDC *pDC, CXTPDockingPaneBase *pPane, CRect rcCaption, const CString &strTitle, BOOL bActive, BOOL bVertical)
Draws the common part of a tabbed and floating caption.
- Protected Member Functions inherited from CXTPDockingPanePaintManager
CXTPDockingPanePaintManager ()
Constructs a CXTPDockingPanePaintManager object.
virtual | ~CXTPDockingPanePaintManager ()
Destroys a CXTPDockingPanePaintManager object, handles cleanup and deallocation.
virtual void | DrawCaptionButtonEntry (CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton, CSize szOffset)
Draws only the glyph of a button.
virtual void | DrawCaptionButtonEntry (CDC *pDC, CXTPDockingPaneCaptionButton *pButton, CPoint pt, COLORREF clrButton)
Draws only the glyph of a button.
void | ClipAndAddEllipsisIfNeeded (CDC *pDC, CString &strTitle, int nCaptionWidth) const
Clip string and add ellipsis if its width less than nCaptionWidth.

Protected Attributes

COLORREF | m_clrCaptionBorder
Caption border color.
- Protected Attributes inherited from CXTPDockingPaneVisualStudio2012Theme
CXTPDockingPaneColorSet * | m_pcsActive
Active state docking pane colors.
CXTPDockingPaneColorSet * | m_pcsInactive
Inactive state docking pane colors.
CString | m_strFontFace
Font face name.
int | m_nFontSize
Font size in points.
- Protected Attributes inherited from CXTPDockingPanePaintManager
XTPDockingPaneCaptionButtonStyle | m_nCaptionButtonStyle
Caption button style.
DWORD | m_dwSplitterStyle
Splitter style.
int | m_nTitleHeight
Title's height.
int | m_nCaptionFontGap
Additional gap of font.
int | m_nTabsHeight
Tab bar's height.
CXTPFont | m_xtpFontTitle
Title font.
CXTPFont | m_xtpFontTitleVertical
Title vertical font.
BOOL | m_bUseOfficeFont
TRUE to use Tahoma font.
BOOL | m_bUseStandardFont
TRUE to use system icon font.
BOOL | m_bDestroyCustomTitleBrushes
If TRUE, custom title bushes will be destroyed on cleanup.
HBRUSH | m_hbrActiveTitleHorz
Optional user specified active horizontal title brush.
HBRUSH | m_hbrInactiveTitleHorz
Optional user specified inactive horizontal title brush.
HBRUSH | m_hbrActiveTitleVert
Optional user specified active vertical title brush.
HBRUSH | m_hbrInactiveTitleVert
Optional user specified inactive vertical title brush.
CXTPTabPaintManager * | m_pTabPaintManager
Paint Manager used to draw tabs for a tabbed container.
CXTPTabPaintManager * | m_pPanelPaintManager
Paint Manager used to draw tabs for an auto-hide panel.
COLORREF | m_arrColor [XPCOLOR_LAST+1]
Self colors array.
XTPDockingPanePaintTheme | m_themeCurrent
Current theme.
CString | m_strOfficeFont
Office font name.
CRect | m_rcCaptionMargin
Margins of caption.
XTPCurrentSystemTheme | m_systemTheme
Current system theme.
CXTPWinThemeWrapper * | m_themeToolbar
Toolbar theme helper.
CXTPWinThemeWrapper * | m_themeExplorer
WinXP Explorer theme helper.
CXTPWinThemeWrapper * | m_themeButton
WinXP Button theme helper.
CXTPWinThemeWrapper * | m_themeWindow
WinXP Window Theme helper.
CXTPWinThemeWrapper * | m_themeRebar
Rebar theme helper.
BOOL | m_bLunaTheme
TRUE if luna colors are used.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPDockingPanePaintManager
BOOL | m_bUseBoldCaptionFont
TRUE to use bold font for caption.
BOOL | m_bHighlightActiveCaption
TRUE to highlight active caption.
int | m_nSplitterSize
Splitter size.
BOOL | m_bShowCaption
TRUE to draw captions of tabbed containers.
BOOL | m_bDrawSingleTab
TRUE to draw single tab.
BOOL | m_bDrawCaptionIcon
TRUE to draw caption icon.
int | m_nSplitterIndent
Size of splitter indent.
CXTPPaintManagerColor | m_clrBackground
Background color.
CXTPPaintManagerColor | m_clrSplitterGripper
Splitter gripper color.
CXTPPaintManagerColor | m_clrSplitter
Splitter color.
CXTPPaintManagerColorGradient | m_clrSplitterGradient
Splitter gradient color.
CXTPPaintManagerColorGradient | m_clrNormalCaption
Color of pane caption when inactive.
CXTPPaintManagerColorGradient | m_clrActiveCaption
Color of pane caption when active.
CXTPPaintManagerColor | m_clrNormalCaptionText
Color of pane caption text when the caption is inactive.
CXTPPaintManagerColor | m_clrActiveCaptionText
Active caption text.
CXTPPaintManagerColor | m_clrDisabledCaptionText
Disabled caption text.

Detailed Description

CXTPDockingPaneVisualStudio2017Theme is used to define drawing routines specific to a Visual Studio 2017 docking pane theme.

Member Function Documentation

◆ DrawAutoHidePanel()

virtual void DrawAutoHidePanel | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | XTPDockingPaneDirection | direction )
 virtual

This method is called by the framework to draw the docking pane auto-hide panel background and splitter.

Parameters
pDC | Pointer to the auto-hide panes device context.
rc | Size of the area to draw.
direction | Docking direction (either xtpPaneDockLeft, xtpPaneDockRight, xtpPaneDockTop or xtpPaneDockBottom).

Reimplemented from CXTPDockingPaneVisualStudio2012Theme.

◆ DrawSplitter()

virtual void DrawSplitter | ( | CDC * | pDC,
 |  | CXTPDockingPaneSplitterWnd * | pSplitter )
 virtual

Override this method to draw a splitter.

Parameters
pDC | Pointer to a valid device context.
pSplitter | Pointer to a splitter window.

Reimplemented from CXTPDockingPaneVisualStudio2012Theme.

◆ DrawTitleBar()

virtual void DrawTitleBar | ( | CDC * | pDC,
 |  | CXTPDockingPaneBase * | pPane,
 |  | CRect | rc,
 |  | BOOL | bVertical )
 protectedvirtual

This member function is called to draw a title bar for the docking pane.

Parameters
pDC | Pointer to a valid device context.
pPane | Pointer to a valid CXTPDockingPaneBase object.
rc | Size of the title bar to draw.
bVertical | TRUE if the title bar should be drawn vertically.

Reimplemented from CXTPDockingPaneVisualStudio2012Theme.

The documentation for this class was generated from the following file:
  • XTPDockingPaneThemeVisualStudio2017.h


Toolkit Pro: CXTPDockingPaneVisualStudio2019Theme Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPDockingPaneVisualStudio2019Theme Class Reference

CXTPDockingPaneVisualStudio2019Theme is used to define drawing routines specific to a Visual Studio 2019 docking pane theme. More...

Inheritance diagram for CXTPDockingPaneVisualStudio2019Theme:
[legend]

Public Member Functions

CXTPDockingPaneVisualStudio2019Theme ()
Constructs a CXTPDockingPaneVisualStudio2019Theme object.
virtual | ~CXTPDockingPaneVisualStudio2019Theme ()
Destroys a CXTPDockingPaneVisualStudio2019Theme object, handles cleanup and deallocation.
virtual void | RefreshMetrics ()
This member function is used to initialize default colors for a theme from an .INI resource.
virtual void | DrawSplitter (CDC *pDC, CXTPDockingPaneSplitterWnd *pSplitter)
Override this method to draw a splitter.
virtual void | DrawAutoHidePanel (CDC *pDC, CRect rc, XTPDockingPaneDirection direction)
This method is called by the framework to draw the docking pane auto-hide panel background and splitter.
- Public Member Functions inherited from CXTPDockingPaneVisualStudio2012Theme
CXTPDockingPaneVisualStudio2012Theme ()
Constructs a CXTPDockingPaneVisualStudio2012Theme object.
virtual | ~CXTPDockingPaneVisualStudio2012Theme ()
Destroys a CXTPDockingPaneVisualStudio2012Theme object, handles cleanup and deallocation.
virtual CRect | GetPaneCaptionRect (const CXTPDockingPaneSidePanel *pPane)
Call this method to get the pane's caption rectangle.
virtual void | AdjustClientRect (CXTPDockingPaneTabbedContainer *pPane, CRect &rc, BOOL bApply)
Override this member to change the client rectangle of the child docking pane.
virtual void | AdjustCaptionRect (const CXTPDockingPaneTabbedContainer *pPane, CRect &rc)
Override this member to change the caption rectangle of the child docking pane.
virtual void | DrawCaption (CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc)
Override this member function to draw a caption.
virtual void | DrawFloatingFrame (CDC *pDC, CXTPDockingPaneMiniWnd *pPane, CRect rc)
Call this method to draw the frame of a floating window.
virtual void | DrawPane (CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc)
Override this member function to draw a tabbed container.
virtual void | DrawSidePanel (CDC *pDC, CXTPDockingPaneSidePanel *pPane, CRect rc)
Override this member function to draw the side panel.
virtual void | DrawCaptionButton (CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton)
Override this member function to draw a button for a tabbed caption.
- Public Member Functions inherited from CXTPDockingPaneDefaultTheme
CXTPDockingPaneDefaultTheme ()
Constructs a CXTPDockingPaneDefaultTheme object.
- Public Member Functions inherited from CXTPDockingPanePaintManager
virtual void | DrawCaptionButtons (CDC *pDC, CXTPDockingPaneCaptionButtons *pButtons, CRect &rcCaption, COLORREF clr, int nButtonSize, int nButtonGap, BOOL bVertical=FALSE)
Override this member function to draw buttons for a tabbed caption.
virtual void | AdjustClientRect (CXTPDockingPaneSidePanel *pPane, CRect &rect)
Override this member to change the client rectangle of the child docking pane.
virtual void | AdjustCaptionRect (const CXTPDockingPaneSidePanel *pPane, CRect &rc)
Override this member to change the caption rectangle of the child docking pane.
virtual void | GetCaptionRect (const CXTPDockingPaneTabbedContainer *pPane, CRect &rc)
Call this method to get a caption rectangle.
virtual CRect | GetCaptionGripperRect (const CXTPDockingPaneTabbedContainer *pPane)
Call this method to get a caption gripper for a tabbed container.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1, int nPen)
Draws a line.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1)
Draws a line.
int | DrawCaptionText (CDC *pDC, const CString &strTitle, CRect rc, BOOL bVertical, BOOL bCalcWidth=FALSE)
Draws the text of a pane caption.
void | Pixel (CDC *pDC, int xPos, int yPos, int nPen)
Sets the pixel at the point.
void | Rectangle (CDC *pDC, CRect rc, int nPenEntry, int nPenBorder)
Draws a rectangle.
void | UseOfficeFont (BOOL bUseOfficeFont)
Call this member to use Office (Tahoma) font.
void | SetCaptionFontIndirect (LOGFONT *pLogFont, BOOL bUseStandardFont=FALSE)
Call this method to set the caption's font.
CXTPTabPaintManager * | SetTabPaintManager (CXTPTabPaintManager *pManager)
Call this method to set the paint manager used to draw tabs of a tabbed container.
CXTPTabPaintManager * | SetPanelPaintManager (CXTPTabPaintManager *pManager)
Call this method to set the paint manager used to draw tabs of an auto-hide panel.
CXTPTabPaintManager * | GetTabPaintManager () const
Retrieves the paint manager used to draw tabs of a tabbed container.
CXTPTabPaintManager * | GetPanelPaintManager () const
Retrieves the paint manager used to draw tabs of an auto-hide panel.
COLORREF | GetXtremeColor (UINT nIndex)
Retrieves the current color of the specified XP display element.
void | SetColors (int cElements, CONST INT *lpaElements, CONST COLORREF *lpaRgbValues)
Call this member to set the colors for each element in an array to the colors in a specified color array.
int | GetCaptionHeight () const
Call this member to get the caption height of the tabbed container.
int | GetTabsHeight () const
Call this member to get tabs height of the tabbed container.
void | SetSplitterStyle (DWORD dwStyle)
Call this member to set the splitter style.
DWORD | GetSplitterStyle () const
Call this method to get the splitter style.
void | SetCaptionButtonStyle (XTPDockingPaneCaptionButtonStyle nStyle)
Call this member to set the caption button style.
XTPDockingPaneCaptionButtonStyle | GetCaptionButtonStyle () const
Call this method to get the caption button style.
XTPCurrentSystemTheme | GetCurrentSystemTheme () const
Call this member function to determine the current Windows XP theme in use.
void | SetLunaTheme (XTPCurrentSystemTheme systemTheme)
Call this method to force system theme.
void | SetCustomTitleBrushes (HBRUSH hbrActiveTitleHorz, HBRUSH hbrInactiveTitleHorz=NULL, HBRUSH hbrActiveTitleVert=NULL, HBRUSH hbrInactiveTitleVert=NULL, BOOL bDestroyOnCleanup=FALSE)
Sets custom title brushes.
HBRUSH | GetCustomTitleBrush (BOOL bActive, BOOL bVertical) const
Obtains the custom title brush.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

virtual void | DrawTitleBar (CDC *pDC, CXTPDockingPaneBase *pPane, CRect rc, BOOL bVertical)
This member function is called to draw a title bar for the docking pane.
- Protected Member Functions inherited from CXTPDockingPaneVisualStudio2012Theme
void | DrawGripper (CDC *pDC, CRect rcGripper, COLORREF clr, BOOL bVertical)
This member function is called to draw a gripper for the docking pane.
void | DrawDottedLine (CDC *pDC, int x, int y, int nSize, COLORREF clr, BOOL bVertical)
This member function is called to draw a dotted line.
virtual CXTPDockingPaneColorSet * | GetColorSet (BOOL bActive)
Call this member function to retrieve the active or inactive color set for the Docking Pane using the state specified by bActive.
void | SetPaneColorSets (CXTPDockingPaneColorSet *pcsActive, CXTPDockingPaneColorSet *pcsInactive)
Called to initialize the active and inactive colors sets for the docking pane theme.
void | DeletePaneColorSets ()
Called to free the memory allocated for the docking pane active and inactive color sets.
- Protected Member Functions inherited from CXTPDockingPaneDefaultTheme
virtual void | DrawCaptionPart (CDC *pDC, CXTPDockingPaneBase *pPane, CRect rcCaption, const CString &strTitle, BOOL bActive, BOOL bVertical)
Draws the common part of a tabbed and floating caption.
- Protected Member Functions inherited from CXTPDockingPanePaintManager
CXTPDockingPanePaintManager ()
Constructs a CXTPDockingPanePaintManager object.
virtual | ~CXTPDockingPanePaintManager ()
Destroys a CXTPDockingPanePaintManager object, handles cleanup and deallocation.
virtual void | DrawCaptionButtonEntry (CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton, CSize szOffset)
Draws only the glyph of a button.
virtual void | DrawCaptionButtonEntry (CDC *pDC, CXTPDockingPaneCaptionButton *pButton, CPoint pt, COLORREF clrButton)
Draws only the glyph of a button.
void | ClipAndAddEllipsisIfNeeded (CDC *pDC, CString &strTitle, int nCaptionWidth) const
Clip string and add ellipsis if its width less than nCaptionWidth.

Protected Attributes

COLORREF | m_clrCaptionBorder
Caption border color.
- Protected Attributes inherited from CXTPDockingPaneVisualStudio2012Theme
CXTPDockingPaneColorSet * | m_pcsActive
Active state docking pane colors.
CXTPDockingPaneColorSet * | m_pcsInactive
Inactive state docking pane colors.
CString | m_strFontFace
Font face name.
int | m_nFontSize
Font size in points.
- Protected Attributes inherited from CXTPDockingPanePaintManager
XTPDockingPaneCaptionButtonStyle | m_nCaptionButtonStyle
Caption button style.
DWORD | m_dwSplitterStyle
Splitter style.
int | m_nTitleHeight
Title's height.
int | m_nCaptionFontGap
Additional gap of font.
int | m_nTabsHeight
Tab bar's height.
CXTPFont | m_xtpFontTitle
Title font.
CXTPFont | m_xtpFontTitleVertical
Title vertical font.
BOOL | m_bUseOfficeFont
TRUE to use Tahoma font.
BOOL | m_bUseStandardFont
TRUE to use system icon font.
BOOL | m_bDestroyCustomTitleBrushes
If TRUE, custom title bushes will be destroyed on cleanup.
HBRUSH | m_hbrActiveTitleHorz
Optional user specified active horizontal title brush.
HBRUSH | m_hbrInactiveTitleHorz
Optional user specified inactive horizontal title brush.
HBRUSH | m_hbrActiveTitleVert
Optional user specified active vertical title brush.
HBRUSH | m_hbrInactiveTitleVert
Optional user specified inactive vertical title brush.
CXTPTabPaintManager * | m_pTabPaintManager
Paint Manager used to draw tabs for a tabbed container.
CXTPTabPaintManager * | m_pPanelPaintManager
Paint Manager used to draw tabs for an auto-hide panel.
COLORREF | m_arrColor [XPCOLOR_LAST+1]
Self colors array.
XTPDockingPanePaintTheme | m_themeCurrent
Current theme.
CString | m_strOfficeFont
Office font name.
CRect | m_rcCaptionMargin
Margins of caption.
XTPCurrentSystemTheme | m_systemTheme
Current system theme.
CXTPWinThemeWrapper * | m_themeToolbar
Toolbar theme helper.
CXTPWinThemeWrapper * | m_themeExplorer
WinXP Explorer theme helper.
CXTPWinThemeWrapper * | m_themeButton
WinXP Button theme helper.
CXTPWinThemeWrapper * | m_themeWindow
WinXP Window Theme helper.
CXTPWinThemeWrapper * | m_themeRebar
Rebar theme helper.
BOOL | m_bLunaTheme
TRUE if luna colors are used.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPDockingPanePaintManager
BOOL | m_bUseBoldCaptionFont
TRUE to use bold font for caption.
BOOL | m_bHighlightActiveCaption
TRUE to highlight active caption.
int | m_nSplitterSize
Splitter size.
BOOL | m_bShowCaption
TRUE to draw captions of tabbed containers.
BOOL | m_bDrawSingleTab
TRUE to draw single tab.
BOOL | m_bDrawCaptionIcon
TRUE to draw caption icon.
int | m_nSplitterIndent
Size of splitter indent.
CXTPPaintManagerColor | m_clrBackground
Background color.
CXTPPaintManagerColor | m_clrSplitterGripper
Splitter gripper color.
CXTPPaintManagerColor | m_clrSplitter
Splitter color.
CXTPPaintManagerColorGradient | m_clrSplitterGradient
Splitter gradient color.
CXTPPaintManagerColorGradient | m_clrNormalCaption
Color of pane caption when inactive.
CXTPPaintManagerColorGradient | m_clrActiveCaption
Color of pane caption when active.
CXTPPaintManagerColor | m_clrNormalCaptionText
Color of pane caption text when the caption is inactive.
CXTPPaintManagerColor | m_clrActiveCaptionText
Active caption text.
CXTPPaintManagerColor | m_clrDisabledCaptionText
Disabled caption text.

Detailed Description

CXTPDockingPaneVisualStudio2019Theme is used to define drawing routines specific to a Visual Studio 2019 docking pane theme.

Member Function Documentation

◆ DrawAutoHidePanel()

virtual void DrawAutoHidePanel | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | XTPDockingPaneDirection | direction )
 virtual

This method is called by the framework to draw the docking pane auto-hide panel background and splitter.

Parameters
pDC | Pointer to the auto-hide panes device context.
rc | Size of the area to draw.
direction | Docking direction (either xtpPaneDockLeft, xtpPaneDockRight, xtpPaneDockTop or xtpPaneDockBottom).

Reimplemented from CXTPDockingPaneVisualStudio2012Theme.

◆ DrawSplitter()

virtual void DrawSplitter | ( | CDC * | pDC,
 |  | CXTPDockingPaneSplitterWnd * | pSplitter )
 virtual

Override this method to draw a splitter.

Parameters
pDC | Pointer to a valid device context.
pSplitter | Pointer to a splitter window.

Reimplemented from CXTPDockingPaneVisualStudio2012Theme.

◆ DrawTitleBar()

virtual void DrawTitleBar | ( | CDC * | pDC,
 |  | CXTPDockingPaneBase * | pPane,
 |  | CRect | rc,
 |  | BOOL | bVertical )
 protectedvirtual

This member function is called to draw a title bar for the docking pane.

Parameters
pDC | Pointer to a valid device context.
pPane | Pointer to a valid CXTPDockingPaneBase object.
rc | Size of the title bar to draw.
bVertical | TRUE if the title bar should be drawn vertically.

Reimplemented from CXTPDockingPaneVisualStudio2012Theme.

The documentation for this class was generated from the following file:
  • XTPDockingPaneThemeVisualStudio2019.h


Toolkit Pro: CXTPDockingPaneVisualStudio2022Theme Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPDockingPaneVisualStudio2022Theme Class Reference

CXTPDockingPaneVisualStudio2022Theme is used to define drawing routines specific to a Visual Studio 2022 docking pane theme. More...

Inheritance diagram for CXTPDockingPaneVisualStudio2022Theme:
[legend]

Public Member Functions

CXTPDockingPaneVisualStudio2022Theme ()
Constructs a CXTPDockingPaneVisualStudio2022Theme object.
virtual | ~CXTPDockingPaneVisualStudio2022Theme ()
Destroys a CXTPDockingPaneVisualStudio2022Theme object, handles cleanup and deallocation.
virtual void | RefreshMetrics ()
This member function is used to initialize default colors for a theme from an .INI resource.
virtual void | DrawSplitter (CDC *pDC, CXTPDockingPaneSplitterWnd *pSplitter)
Override this method to draw a splitter.
virtual void | DrawAutoHidePanel (CDC *pDC, CRect rc, XTPDockingPaneDirection direction)
This method is called by the framework to draw the docking pane auto-hide panel background and splitter.
- Public Member Functions inherited from CXTPDockingPaneVisualStudio2012Theme
CXTPDockingPaneVisualStudio2012Theme ()
Constructs a CXTPDockingPaneVisualStudio2012Theme object.
virtual | ~CXTPDockingPaneVisualStudio2012Theme ()
Destroys a CXTPDockingPaneVisualStudio2012Theme object, handles cleanup and deallocation.
virtual CRect | GetPaneCaptionRect (const CXTPDockingPaneSidePanel *pPane)
Call this method to get the pane's caption rectangle.
virtual void | AdjustClientRect (CXTPDockingPaneTabbedContainer *pPane, CRect &rc, BOOL bApply)
Override this member to change the client rectangle of the child docking pane.
virtual void | AdjustCaptionRect (const CXTPDockingPaneTabbedContainer *pPane, CRect &rc)
Override this member to change the caption rectangle of the child docking pane.
virtual void | DrawCaption (CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc)
Override this member function to draw a caption.
virtual void | DrawFloatingFrame (CDC *pDC, CXTPDockingPaneMiniWnd *pPane, CRect rc)
Call this method to draw the frame of a floating window.
virtual void | DrawPane (CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc)
Override this member function to draw a tabbed container.
virtual void | DrawSidePanel (CDC *pDC, CXTPDockingPaneSidePanel *pPane, CRect rc)
Override this member function to draw the side panel.
virtual void | DrawCaptionButton (CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton)
Override this member function to draw a button for a tabbed caption.
- Public Member Functions inherited from CXTPDockingPaneDefaultTheme
CXTPDockingPaneDefaultTheme ()
Constructs a CXTPDockingPaneDefaultTheme object.
- Public Member Functions inherited from CXTPDockingPanePaintManager
virtual void | DrawCaptionButtons (CDC *pDC, CXTPDockingPaneCaptionButtons *pButtons, CRect &rcCaption, COLORREF clr, int nButtonSize, int nButtonGap, BOOL bVertical=FALSE)
Override this member function to draw buttons for a tabbed caption.
virtual void | AdjustClientRect (CXTPDockingPaneSidePanel *pPane, CRect &rect)
Override this member to change the client rectangle of the child docking pane.
virtual void | AdjustCaptionRect (const CXTPDockingPaneSidePanel *pPane, CRect &rc)
Override this member to change the caption rectangle of the child docking pane.
virtual void | GetCaptionRect (const CXTPDockingPaneTabbedContainer *pPane, CRect &rc)
Call this method to get a caption rectangle.
virtual CRect | GetCaptionGripperRect (const CXTPDockingPaneTabbedContainer *pPane)
Call this method to get a caption gripper for a tabbed container.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1, int nPen)
Draws a line.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1)
Draws a line.
int | DrawCaptionText (CDC *pDC, const CString &strTitle, CRect rc, BOOL bVertical, BOOL bCalcWidth=FALSE)
Draws the text of a pane caption.
void | Pixel (CDC *pDC, int xPos, int yPos, int nPen)
Sets the pixel at the point.
void | Rectangle (CDC *pDC, CRect rc, int nPenEntry, int nPenBorder)
Draws a rectangle.
void | UseOfficeFont (BOOL bUseOfficeFont)
Call this member to use Office (Tahoma) font.
void | SetCaptionFontIndirect (LOGFONT *pLogFont, BOOL bUseStandardFont=FALSE)
Call this method to set the caption's font.
CXTPTabPaintManager * | SetTabPaintManager (CXTPTabPaintManager *pManager)
Call this method to set the paint manager used to draw tabs of a tabbed container.
CXTPTabPaintManager * | SetPanelPaintManager (CXTPTabPaintManager *pManager)
Call this method to set the paint manager used to draw tabs of an auto-hide panel.
CXTPTabPaintManager * | GetTabPaintManager () const
Retrieves the paint manager used to draw tabs of a tabbed container.
CXTPTabPaintManager * | GetPanelPaintManager () const
Retrieves the paint manager used to draw tabs of an auto-hide panel.
COLORREF | GetXtremeColor (UINT nIndex)
Retrieves the current color of the specified XP display element.
void | SetColors (int cElements, CONST INT *lpaElements, CONST COLORREF *lpaRgbValues)
Call this member to set the colors for each element in an array to the colors in a specified color array.
int | GetCaptionHeight () const
Call this member to get the caption height of the tabbed container.
int | GetTabsHeight () const
Call this member to get tabs height of the tabbed container.
void | SetSplitterStyle (DWORD dwStyle)
Call this member to set the splitter style.
DWORD | GetSplitterStyle () const
Call this method to get the splitter style.
void | SetCaptionButtonStyle (XTPDockingPaneCaptionButtonStyle nStyle)
Call this member to set the caption button style.
XTPDockingPaneCaptionButtonStyle | GetCaptionButtonStyle () const
Call this method to get the caption button style.
XTPCurrentSystemTheme | GetCurrentSystemTheme () const
Call this member function to determine the current Windows XP theme in use.
void | SetLunaTheme (XTPCurrentSystemTheme systemTheme)
Call this method to force system theme.
void | SetCustomTitleBrushes (HBRUSH hbrActiveTitleHorz, HBRUSH hbrInactiveTitleHorz=NULL, HBRUSH hbrActiveTitleVert=NULL, HBRUSH hbrInactiveTitleVert=NULL, BOOL bDestroyOnCleanup=FALSE)
Sets custom title brushes.
HBRUSH | GetCustomTitleBrush (BOOL bActive, BOOL bVertical) const
Obtains the custom title brush.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

virtual void | DrawTitleBar (CDC *pDC, CXTPDockingPaneBase *pPane, CRect rc, BOOL bVertical)
This member function is called to draw a title bar for the docking pane.
- Protected Member Functions inherited from CXTPDockingPaneVisualStudio2012Theme
void | DrawGripper (CDC *pDC, CRect rcGripper, COLORREF clr, BOOL bVertical)
This member function is called to draw a gripper for the docking pane.
void | DrawDottedLine (CDC *pDC, int x, int y, int nSize, COLORREF clr, BOOL bVertical)
This member function is called to draw a dotted line.
virtual CXTPDockingPaneColorSet * | GetColorSet (BOOL bActive)
Call this member function to retrieve the active or inactive color set for the Docking Pane using the state specified by bActive.
void | SetPaneColorSets (CXTPDockingPaneColorSet *pcsActive, CXTPDockingPaneColorSet *pcsInactive)
Called to initialize the active and inactive colors sets for the docking pane theme.
void | DeletePaneColorSets ()
Called to free the memory allocated for the docking pane active and inactive color sets.
- Protected Member Functions inherited from CXTPDockingPaneDefaultTheme
virtual void | DrawCaptionPart (CDC *pDC, CXTPDockingPaneBase *pPane, CRect rcCaption, const CString &strTitle, BOOL bActive, BOOL bVertical)
Draws the common part of a tabbed and floating caption.
- Protected Member Functions inherited from CXTPDockingPanePaintManager
CXTPDockingPanePaintManager ()
Constructs a CXTPDockingPanePaintManager object.
virtual | ~CXTPDockingPanePaintManager ()
Destroys a CXTPDockingPanePaintManager object, handles cleanup and deallocation.
virtual void | DrawCaptionButtonEntry (CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton, CSize szOffset)
Draws only the glyph of a button.
virtual void | DrawCaptionButtonEntry (CDC *pDC, CXTPDockingPaneCaptionButton *pButton, CPoint pt, COLORREF clrButton)
Draws only the glyph of a button.
void | ClipAndAddEllipsisIfNeeded (CDC *pDC, CString &strTitle, int nCaptionWidth) const
Clip string and add ellipsis if its width less than nCaptionWidth.

Protected Attributes

COLORREF | m_clrCaptionBorder
Caption border color.
- Protected Attributes inherited from CXTPDockingPaneVisualStudio2012Theme
CXTPDockingPaneColorSet * | m_pcsActive
Active state docking pane colors.
CXTPDockingPaneColorSet * | m_pcsInactive
Inactive state docking pane colors.
CString | m_strFontFace
Font face name.
int | m_nFontSize
Font size in points.
- Protected Attributes inherited from CXTPDockingPanePaintManager
XTPDockingPaneCaptionButtonStyle | m_nCaptionButtonStyle
Caption button style.
DWORD | m_dwSplitterStyle
Splitter style.
int | m_nTitleHeight
Title's height.
int | m_nCaptionFontGap
Additional gap of font.
int | m_nTabsHeight
Tab bar's height.
CXTPFont | m_xtpFontTitle
Title font.
CXTPFont | m_xtpFontTitleVertical
Title vertical font.
BOOL | m_bUseOfficeFont
TRUE to use Tahoma font.
BOOL | m_bUseStandardFont
TRUE to use system icon font.
BOOL | m_bDestroyCustomTitleBrushes
If TRUE, custom title bushes will be destroyed on cleanup.
HBRUSH | m_hbrActiveTitleHorz
Optional user specified active horizontal title brush.
HBRUSH | m_hbrInactiveTitleHorz
Optional user specified inactive horizontal title brush.
HBRUSH | m_hbrActiveTitleVert
Optional user specified active vertical title brush.
HBRUSH | m_hbrInactiveTitleVert
Optional user specified inactive vertical title brush.
CXTPTabPaintManager * | m_pTabPaintManager
Paint Manager used to draw tabs for a tabbed container.
CXTPTabPaintManager * | m_pPanelPaintManager
Paint Manager used to draw tabs for an auto-hide panel.
COLORREF | m_arrColor [XPCOLOR_LAST+1]
Self colors array.
XTPDockingPanePaintTheme | m_themeCurrent
Current theme.
CString | m_strOfficeFont
Office font name.
CRect | m_rcCaptionMargin
Margins of caption.
XTPCurrentSystemTheme | m_systemTheme
Current system theme.
CXTPWinThemeWrapper * | m_themeToolbar
Toolbar theme helper.
CXTPWinThemeWrapper * | m_themeExplorer
WinXP Explorer theme helper.
CXTPWinThemeWrapper * | m_themeButton
WinXP Button theme helper.
CXTPWinThemeWrapper * | m_themeWindow
WinXP Window Theme helper.
CXTPWinThemeWrapper * | m_themeRebar
Rebar theme helper.
BOOL | m_bLunaTheme
TRUE if luna colors are used.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPDockingPanePaintManager
BOOL | m_bUseBoldCaptionFont
TRUE to use bold font for caption.
BOOL | m_bHighlightActiveCaption
TRUE to highlight active caption.
int | m_nSplitterSize
Splitter size.
BOOL | m_bShowCaption
TRUE to draw captions of tabbed containers.
BOOL | m_bDrawSingleTab
TRUE to draw single tab.
BOOL | m_bDrawCaptionIcon
TRUE to draw caption icon.
int | m_nSplitterIndent
Size of splitter indent.
CXTPPaintManagerColor | m_clrBackground
Background color.
CXTPPaintManagerColor | m_clrSplitterGripper
Splitter gripper color.
CXTPPaintManagerColor | m_clrSplitter
Splitter color.
CXTPPaintManagerColorGradient | m_clrSplitterGradient
Splitter gradient color.
CXTPPaintManagerColorGradient | m_clrNormalCaption
Color of pane caption when inactive.
CXTPPaintManagerColorGradient | m_clrActiveCaption
Color of pane caption when active.
CXTPPaintManagerColor | m_clrNormalCaptionText
Color of pane caption text when the caption is inactive.
CXTPPaintManagerColor | m_clrActiveCaptionText
Active caption text.
CXTPPaintManagerColor | m_clrDisabledCaptionText
Disabled caption text.

Detailed Description

CXTPDockingPaneVisualStudio2022Theme is used to define drawing routines specific to a Visual Studio 2022 docking pane theme.

Member Function Documentation

◆ DrawAutoHidePanel()

virtual void DrawAutoHidePanel | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | XTPDockingPaneDirection | direction )
 virtual

This method is called by the framework to draw the docking pane auto-hide panel background and splitter.

Parameters
pDC | Pointer to the auto-hide panes device context.
rc | Size of the area to draw.
direction | Docking direction (either xtpPaneDockLeft, xtpPaneDockRight, xtpPaneDockTop or xtpPaneDockBottom).

Reimplemented from CXTPDockingPaneVisualStudio2012Theme.

◆ DrawSplitter()

virtual void DrawSplitter | ( | CDC * | pDC,
 |  | CXTPDockingPaneSplitterWnd * | pSplitter )
 virtual

Override this method to draw a splitter.

Parameters
pDC | Pointer to a valid device context.
pSplitter | Pointer to a splitter window.

Reimplemented from CXTPDockingPaneVisualStudio2012Theme.

◆ DrawTitleBar()

virtual void DrawTitleBar | ( | CDC * | pDC,
 |  | CXTPDockingPaneBase * | pPane,
 |  | CRect | rc,
 |  | BOOL | bVertical )
 protectedvirtual

This member function is called to draw a title bar for the docking pane.

Parameters
pDC | Pointer to a valid device context.
pPane | Pointer to a valid CXTPDockingPaneBase object.
rc | Size of the title bar to draw.
bVertical | TRUE if the title bar should be drawn vertically.

Reimplemented from CXTPDockingPaneVisualStudio2012Theme.

The documentation for this class was generated from the following file:
  • XTPDockingPaneThemeVisualStudio2022.h


Toolkit Pro: CXTPDockingPaneVisualStudio6Theme Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPDockingPaneVisualStudio6Theme Class Reference

CXTPDockingPaneVisualStudio6Theme is a CXTPDockingPaneGripperedTheme derived class that represents a Visual Studio 6 theme for docking panes. More...

Inheritance diagram for CXTPDockingPaneVisualStudio6Theme:
[legend]

Public Member Functions

CXTPDockingPaneVisualStudio6Theme ()
Constructs a CXTPDockingPaneVisualStudio6Theme object.
- Public Member Functions inherited from CXTPDockingPaneGripperedTheme
CXTPDockingPaneGripperedTheme ()
Constructs a CXTPDockingPaneGripperedTheme object.
void | DrawFloatingFrame (CDC *pDC, CXTPDockingPaneMiniWnd *pPane, CRect rc)
Call this method to draw the frame of a floating window.
virtual void | DrawCaption (CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc)
Override this member function to draw a caption.
virtual void | RefreshMetrics ()
This method is called to refresh the visual metrics of the pane.
- Public Member Functions inherited from CXTPDockingPaneDefaultTheme
CXTPDockingPaneDefaultTheme ()
Constructs a CXTPDockingPaneDefaultTheme object.
virtual void | DrawSidePanel (CDC *pDC, CXTPDockingPaneSidePanel *pPane, CRect rc)
Override this member function to draw the side panel.
- Public Member Functions inherited from CXTPDockingPanePaintManager
virtual void | DrawPane (CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc)
Override this member function to draw a tabbed container.
virtual CRect | GetPaneCaptionRect (const CXTPDockingPaneSidePanel *pPane)
Call this method to get the pane's caption rectangle.
virtual void | DrawSplitter (CDC *pDC, CXTPDockingPaneSplitterWnd *pSplitter)
Override this method to draw a splitter.
virtual void | DrawCaptionButtons (CDC *pDC, CXTPDockingPaneCaptionButtons *pButtons, CRect &rcCaption, COLORREF clr, int nButtonSize, int nButtonGap, BOOL bVertical=FALSE)
Override this member function to draw buttons for a tabbed caption.
virtual void | DrawCaptionButton (CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton)
Override this member function to draw a button for a tabbed caption.
virtual void | AdjustClientRect (CXTPDockingPaneSidePanel *pPane, CRect &rect)
Override this member to change the client rectangle of the child docking pane.
virtual void | AdjustClientRect (CXTPDockingPaneTabbedContainer *pPane, CRect &rect, BOOL bApply)
Override this member to change the client rectangle of the child docking pane.
virtual void | AdjustCaptionRect (const CXTPDockingPaneSidePanel *pPane, CRect &rc)
Override this member to change the caption rectangle of the child docking pane.
virtual void | AdjustCaptionRect (const CXTPDockingPaneTabbedContainer *pPane, CRect &rc)
Override this member to change the caption rectangle of the child docking pane.
virtual void | GetCaptionRect (const CXTPDockingPaneTabbedContainer *pPane, CRect &rc)
Call this method to get a caption rectangle.
virtual CRect | GetCaptionGripperRect (const CXTPDockingPaneTabbedContainer *pPane)
Call this method to get a caption gripper for a tabbed container.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1, int nPen)
Draws a line.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1)
Draws a line.
int | DrawCaptionText (CDC *pDC, const CString &strTitle, CRect rc, BOOL bVertical, BOOL bCalcWidth=FALSE)
Draws the text of a pane caption.
void | Pixel (CDC *pDC, int xPos, int yPos, int nPen)
Sets the pixel at the point.
void | Rectangle (CDC *pDC, CRect rc, int nPenEntry, int nPenBorder)
Draws a rectangle.
void | UseOfficeFont (BOOL bUseOfficeFont)
Call this member to use Office (Tahoma) font.
void | SetCaptionFontIndirect (LOGFONT *pLogFont, BOOL bUseStandardFont=FALSE)
Call this method to set the caption's font.
CXTPTabPaintManager * | SetTabPaintManager (CXTPTabPaintManager *pManager)
Call this method to set the paint manager used to draw tabs of a tabbed container.
CXTPTabPaintManager * | SetPanelPaintManager (CXTPTabPaintManager *pManager)
Call this method to set the paint manager used to draw tabs of an auto-hide panel.
CXTPTabPaintManager * | GetTabPaintManager () const
Retrieves the paint manager used to draw tabs of a tabbed container.
CXTPTabPaintManager * | GetPanelPaintManager () const
Retrieves the paint manager used to draw tabs of an auto-hide panel.
COLORREF | GetXtremeColor (UINT nIndex)
Retrieves the current color of the specified XP display element.
void | SetColors (int cElements, CONST INT *lpaElements, CONST COLORREF *lpaRgbValues)
Call this member to set the colors for each element in an array to the colors in a specified color array.
int | GetCaptionHeight () const
Call this member to get the caption height of the tabbed container.
int | GetTabsHeight () const
Call this member to get tabs height of the tabbed container.
void | SetSplitterStyle (DWORD dwStyle)
Call this member to set the splitter style.
DWORD | GetSplitterStyle () const
Call this method to get the splitter style.
void | SetCaptionButtonStyle (XTPDockingPaneCaptionButtonStyle nStyle)
Call this member to set the caption button style.
XTPDockingPaneCaptionButtonStyle | GetCaptionButtonStyle () const
Call this method to get the caption button style.
XTPCurrentSystemTheme | GetCurrentSystemTheme () const
Call this member function to determine the current Windows XP theme in use.
void | SetLunaTheme (XTPCurrentSystemTheme systemTheme)
Call this method to force system theme.
virtual void | DrawAutoHidePanel (CDC *pDC, CRect rc, XTPDockingPaneDirection direction)
This mmethod is called by the framework to draw the docking pane auto-hide panel background and splitter.
void | SetCustomTitleBrushes (HBRUSH hbrActiveTitleHorz, HBRUSH hbrInactiveTitleHorz=NULL, HBRUSH hbrActiveTitleVert=NULL, HBRUSH hbrInactiveTitleVert=NULL, BOOL bDestroyOnCleanup=FALSE)
Sets custom title brushes.
HBRUSH | GetCustomTitleBrush (BOOL bActive, BOOL bVertical) const
Obtains the custom title brush.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

virtual void | DrawCaptionPart (CDC *pDC, CXTPDockingPaneBase *pPane, CRect rcCaption, const CString &strTitle, BOOL bActive, BOOL bVertical)
Draws the common part of a tabbed and floating caption.
- Protected Member Functions inherited from CXTPDockingPaneGripperedTheme
- Protected Member Functions inherited from CXTPDockingPaneDefaultTheme
- Protected Member Functions inherited from CXTPDockingPanePaintManager
CXTPDockingPanePaintManager ()
Constructs a CXTPDockingPanePaintManager object.
virtual | ~CXTPDockingPanePaintManager ()
Destroys a CXTPDockingPanePaintManager object, handles cleanup and deallocation.
virtual void | DrawCaptionButtonEntry (CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton, CSize szOffset)
Draws only the glyph of a button.
virtual void | DrawCaptionButtonEntry (CDC *pDC, CXTPDockingPaneCaptionButton *pButton, CPoint pt, COLORREF clrButton)
Draws only the glyph of a button.
void | ClipAndAddEllipsisIfNeeded (CDC *pDC, CString &strTitle, int nCaptionWidth) const
Clip string and add ellipsis if its width less than nCaptionWidth.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPDockingPanePaintManager
BOOL | m_bUseBoldCaptionFont
TRUE to use bold font for caption.
BOOL | m_bHighlightActiveCaption
TRUE to highlight active caption.
int | m_nSplitterSize
Splitter size.
BOOL | m_bShowCaption
TRUE to draw captions of tabbed containers.
BOOL | m_bDrawSingleTab
TRUE to draw single tab.
BOOL | m_bDrawCaptionIcon
TRUE to draw caption icon.
int | m_nSplitterIndent
Size of splitter indent.
CXTPPaintManagerColor | m_clrBackground
Background color.
CXTPPaintManagerColor | m_clrSplitterGripper
Splitter gripper color.
CXTPPaintManagerColor | m_clrSplitter
Splitter color.
CXTPPaintManagerColorGradient | m_clrSplitterGradient
Splitter gradient color.
CXTPPaintManagerColorGradient | m_clrNormalCaption
Color of pane caption when inactive.
CXTPPaintManagerColorGradient | m_clrActiveCaption
Color of pane caption when active.
CXTPPaintManagerColor | m_clrNormalCaptionText
Color of pane caption text when the caption is inactive.
CXTPPaintManagerColor | m_clrActiveCaptionText
Active caption text.
CXTPPaintManagerColor | m_clrDisabledCaptionText
Disabled caption text.
- Protected Attributes inherited from CXTPDockingPanePaintManager
XTPDockingPaneCaptionButtonStyle | m_nCaptionButtonStyle
Caption button style.
DWORD | m_dwSplitterStyle
Splitter style.
int | m_nTitleHeight
Title's height.
int | m_nCaptionFontGap
Additional gap of font.
int | m_nTabsHeight
Tab bar's height.
CXTPFont | m_xtpFontTitle
Title font.
CXTPFont | m_xtpFontTitleVertical
Title vertical font.
BOOL | m_bUseOfficeFont
TRUE to use Tahoma font.
BOOL | m_bUseStandardFont
TRUE to use system icon font.
BOOL | m_bDestroyCustomTitleBrushes
If TRUE, custom title bushes will be destroyed on cleanup.
HBRUSH | m_hbrActiveTitleHorz
Optional user specified active horizontal title brush.
HBRUSH | m_hbrInactiveTitleHorz
Optional user specified inactive horizontal title brush.
HBRUSH | m_hbrActiveTitleVert
Optional user specified active vertical title brush.
HBRUSH | m_hbrInactiveTitleVert
Optional user specified inactive vertical title brush.
CXTPTabPaintManager * | m_pTabPaintManager
Paint Manager used to draw tabs for a tabbed container.
CXTPTabPaintManager * | m_pPanelPaintManager
Paint Manager used to draw tabs for an auto-hide panel.
COLORREF | m_arrColor [XPCOLOR_LAST+1]
Self colors array.
XTPDockingPanePaintTheme | m_themeCurrent
Current theme.
CString | m_strOfficeFont
Office font name.
CRect | m_rcCaptionMargin
Margins of caption.
XTPCurrentSystemTheme | m_systemTheme
Current system theme.
CXTPWinThemeWrapper * | m_themeToolbar
Toolbar theme helper.
CXTPWinThemeWrapper * | m_themeExplorer
WinXP Explorer theme helper.
CXTPWinThemeWrapper * | m_themeButton
WinXP Button theme helper.
CXTPWinThemeWrapper * | m_themeWindow
WinXP Window Theme helper.
CXTPWinThemeWrapper * | m_themeRebar
Rebar theme helper.
BOOL | m_bLunaTheme
TRUE if luna colors are used.

Detailed Description

CXTPDockingPaneVisualStudio6Theme is a CXTPDockingPaneGripperedTheme derived class that represents a Visual Studio 6 theme for docking panes.

Call CXTPDockingPaneManager::SetTheme(xtpPaneThemeVisualStudio6); to set this theme.

Member Function Documentation

◆ DrawCaptionPart()

virtual void DrawCaptionPart | ( | CDC * | pDC,
 |  | CXTPDockingPaneBase * | pPane,
 |  | CRect | rcCaption,
 |  | const CString & | strTitle,
 |  | BOOL | bActive,
 |  | BOOL | bVertical )
 protectedvirtual

Draws the common part of a tabbed and floating caption.

Parameters
pDC | Reference to the device context in which to draw.
pPane | Container which the caption needs to draw.
rcCaption | Caption bounding rectangle.
strTitle | Caption text.
bActive | TRUE if the caption is active.
bVertical | TRUE to draw the caption vertically.

Reimplemented from CXTPDockingPaneGripperedTheme.

The documentation for this class was generated from the following file:
  • XTPDockingPaneThemeVisualStudio6.h


Toolkit Pro: CXTPDockingPaneWindowSelect Class Reference

Classes | Public Types | Public Member Functions | Protected Member Functions | List of all members
CXTPDockingPaneWindowSelect Class Reference

CXTPDockingPaneWindowSelect is a CMiniFrameWnd derived class used to show a window selector for Ctrl+F9 and Alt+F7 handlers. More...

Classes

struct | CColumn
Column description. More...
struct | CItem
Item description. More...

Public Types

enum ItemType { itemPane , itemMDIFrame , itemSDIFrame }
Item type enumeration. More...

Public Member Functions

virtual | ~CXTPDockingPaneWindowSelect ()
Destroys a CXTPDockingPaneMiniWnd object, handles cleanup and deallocation.
CItem * | HitTest (CPoint pt) const
Call this method to determine which item, if any, is at the specified position.
void | Select (CItem *pItem)
Call this method to select a specified item.
void | Select (int nItem)
Call this method to select an item by its index.
virtual CString | GetItemCaption (CItem *pItem) const
This method is called to retrieve an item's caption.
virtual CString | GetItemDescription (CItem *pItem) const
This method is called to retrieve an item's description.
virtual CString | GetItemPath (CItem *pItem) const
This method is called to retrieve an item's path string.
virtual BOOL | Reposition ()
This method is called to update the position of all items inside the dialog.

Protected Member Functions

CXTPDockingPaneWindowSelect ()
Constructs a CXTPDockingPaneWindowSelect object.

Detailed Description

CXTPDockingPaneWindowSelect is a CMiniFrameWnd derived class used to show a window selector for Ctrl+F9 and Alt+F7 handlers.

Member Enumeration Documentation

◆ ItemType

enum ItemType

Item type enumeration.

Enumerator
itemPane | Item is a docking pane.
itemMDIFrame | Item is a handle of a MDI child.
itemSDIFrame | Item is a handle of a SDI frame.

Member Function Documentation

◆ GetItemCaption()

virtual CString GetItemCaption ( CItem * pItem ) const
virtual

This method is called to retrieve an item's caption.

Parameters
pItem Pointer to the item with the caption to retrieve.
Returns
The item's caption.

◆ GetItemDescription()

virtual CString GetItemDescription ( CItem * pItem ) const
virtual

This method is called to retrieve an item's description.

Parameters
pItem Pointer to the item with the description to retrieve.
Returns
The item's description.

◆ GetItemPath()

virtual CString GetItemPath ( CItem * pItem ) const
virtual

This method is called to retrieve an item's path string.

Parameters
pItem Pointer to the item with the path string to retrieve.
Returns
The item's path string.

◆ HitTest()

CItem * HitTest ( CPoint pt ) const

Call this method to determine which item, if any, is at the specified position.

Parameters
pt Client coordinates to test.
Returns
A pointer to a CItem object if successful, or 0 if no item is at the specified position.

◆ Reposition()

virtual BOOL Reposition ( )
virtual

This method is called to update the position of all items inside the dialog.

Returns
TRUE is successful.

◆ Select() [1/2]

void Select ( CItem * pItem )

Call this method to select a specified item.

Parameters
pItem Item to select.

◆ Select() [2/2]

void Select ( int nItem )

Call this method to select an item by its index.

Parameters
nItem Index of the item to select.
The documentation for this class was generated from the following file:
  • XTPDockingPaneKeyboardHook.h


Toolkit Pro: CXTPDockingPaneWindowSelect::CColumn Struct Reference

  • CXTPDockingPaneWindowSelect
  • CColumn
List of all members
CXTPDockingPaneWindowSelect::CColumn Struct Reference

Column description. More...

Detailed Description

Column description.

The documentation for this struct was generated from the following file:
  • XTPDockingPaneKeyboardHook.h


Toolkit Pro: CXTPDockingPaneWindowSelect::CItem Struct Reference

  • CXTPDockingPaneWindowSelect
  • CItem
Public Attributes | List of all members
CXTPDockingPaneWindowSelect::CItem Struct Reference

Item description. More...

Public Attributes

CRect | rc
Item bounding rectangle.
int | nIndex
Index of the item.
int | nColumn
Column of the index.
int | nRow
Row of the item.
ItemType | type
Item type.

Detailed Description

Item description.

The documentation for this struct was generated from the following file:
  • XTPDockingPaneKeyboardHook.h


Toolkit Pro: CXTPDockingPaneWinExplorerTheme Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPDockingPaneWinExplorerTheme Class Reference

CXTPDockingPaneWinExplorerTheme is a CXTPDockingPaneDefaultTheme derived class that represents an Explorer theme for docking panes. More...

Inheritance diagram for CXTPDockingPaneWinExplorerTheme:
[legend]

Public Member Functions

CXTPDockingPaneWinExplorerTheme ()
Constructs a CXTPDockingPaneWinExplorerTheme object.
void | RefreshMetrics ()
This method is called to refresh the visual metrics of the pane.
- Public Member Functions inherited from CXTPDockingPaneGripperedTheme
CXTPDockingPaneGripperedTheme ()
Constructs a CXTPDockingPaneGripperedTheme object.
void | DrawFloatingFrame (CDC *pDC, CXTPDockingPaneMiniWnd *pPane, CRect rc)
Call this method to draw the frame of a floating window.
virtual void | DrawCaption (CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc)
Override this member function to draw a caption.
- Public Member Functions inherited from CXTPDockingPaneDefaultTheme
CXTPDockingPaneDefaultTheme ()
Constructs a CXTPDockingPaneDefaultTheme object.
virtual void | DrawSidePanel (CDC *pDC, CXTPDockingPaneSidePanel *pPane, CRect rc)
Override this member function to draw the side panel.
- Public Member Functions inherited from CXTPDockingPanePaintManager
virtual void | DrawPane (CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc)
Override this member function to draw a tabbed container.
virtual CRect | GetPaneCaptionRect (const CXTPDockingPaneSidePanel *pPane)
Call this method to get the pane's caption rectangle.
virtual void | DrawSplitter (CDC *pDC, CXTPDockingPaneSplitterWnd *pSplitter)
Override this method to draw a splitter.
virtual void | DrawCaptionButtons (CDC *pDC, CXTPDockingPaneCaptionButtons *pButtons, CRect &rcCaption, COLORREF clr, int nButtonSize, int nButtonGap, BOOL bVertical=FALSE)
Override this member function to draw buttons for a tabbed caption.
virtual void | DrawCaptionButton (CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton)
Override this member function to draw a button for a tabbed caption.
virtual void | AdjustClientRect (CXTPDockingPaneSidePanel *pPane, CRect &rect)
Override this member to change the client rectangle of the child docking pane.
virtual void | AdjustClientRect (CXTPDockingPaneTabbedContainer *pPane, CRect &rect, BOOL bApply)
Override this member to change the client rectangle of the child docking pane.
virtual void | AdjustCaptionRect (const CXTPDockingPaneSidePanel *pPane, CRect &rc)
Override this member to change the caption rectangle of the child docking pane.
virtual void | AdjustCaptionRect (const CXTPDockingPaneTabbedContainer *pPane, CRect &rc)
Override this member to change the caption rectangle of the child docking pane.
virtual void | GetCaptionRect (const CXTPDockingPaneTabbedContainer *pPane, CRect &rc)
Call this method to get a caption rectangle.
virtual CRect | GetCaptionGripperRect (const CXTPDockingPaneTabbedContainer *pPane)
Call this method to get a caption gripper for a tabbed container.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1, int nPen)
Draws a line.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1)
Draws a line.
int | DrawCaptionText (CDC *pDC, const CString &strTitle, CRect rc, BOOL bVertical, BOOL bCalcWidth=FALSE)
Draws the text of a pane caption.
void | Pixel (CDC *pDC, int xPos, int yPos, int nPen)
Sets the pixel at the point.
void | Rectangle (CDC *pDC, CRect rc, int nPenEntry, int nPenBorder)
Draws a rectangle.
void | UseOfficeFont (BOOL bUseOfficeFont)
Call this member to use Office (Tahoma) font.
void | SetCaptionFontIndirect (LOGFONT *pLogFont, BOOL bUseStandardFont=FALSE)
Call this method to set the caption's font.
CXTPTabPaintManager * | SetTabPaintManager (CXTPTabPaintManager *pManager)
Call this method to set the paint manager used to draw tabs of a tabbed container.
CXTPTabPaintManager * | SetPanelPaintManager (CXTPTabPaintManager *pManager)
Call this method to set the paint manager used to draw tabs of an auto-hide panel.
CXTPTabPaintManager * | GetTabPaintManager () const
Retrieves the paint manager used to draw tabs of a tabbed container.
CXTPTabPaintManager * | GetPanelPaintManager () const
Retrieves the paint manager used to draw tabs of an auto-hide panel.
COLORREF | GetXtremeColor (UINT nIndex)
Retrieves the current color of the specified XP display element.
void | SetColors (int cElements, CONST INT *lpaElements, CONST COLORREF *lpaRgbValues)
Call this member to set the colors for each element in an array to the colors in a specified color array.
int | GetCaptionHeight () const
Call this member to get the caption height of the tabbed container.
int | GetTabsHeight () const
Call this member to get tabs height of the tabbed container.
void | SetSplitterStyle (DWORD dwStyle)
Call this member to set the splitter style.
DWORD | GetSplitterStyle () const
Call this method to get the splitter style.
void | SetCaptionButtonStyle (XTPDockingPaneCaptionButtonStyle nStyle)
Call this member to set the caption button style.
XTPDockingPaneCaptionButtonStyle | GetCaptionButtonStyle () const
Call this method to get the caption button style.
XTPCurrentSystemTheme | GetCurrentSystemTheme () const
Call this member function to determine the current Windows XP theme in use.
void | SetLunaTheme (XTPCurrentSystemTheme systemTheme)
Call this method to force system theme.
virtual void | DrawAutoHidePanel (CDC *pDC, CRect rc, XTPDockingPaneDirection direction)
This mmethod is called by the framework to draw the docking pane auto-hide panel background and splitter.
void | SetCustomTitleBrushes (HBRUSH hbrActiveTitleHorz, HBRUSH hbrInactiveTitleHorz=NULL, HBRUSH hbrActiveTitleVert=NULL, HBRUSH hbrInactiveTitleVert=NULL, BOOL bDestroyOnCleanup=FALSE)
Sets custom title brushes.
HBRUSH | GetCustomTitleBrush (BOOL bActive, BOOL bVertical) const
Obtains the custom title brush.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

virtual void | DrawCaptionPart (CDC *pDC, CXTPDockingPaneBase *pPane, CRect rcCaption, const CString &strTitle, BOOL bActive, BOOL bVertical)
Draws the common part of a tabbed and floating caption.
- Protected Member Functions inherited from CXTPDockingPaneGripperedTheme
- Protected Member Functions inherited from CXTPDockingPaneDefaultTheme
- Protected Member Functions inherited from CXTPDockingPanePaintManager
CXTPDockingPanePaintManager ()
Constructs a CXTPDockingPanePaintManager object.
virtual | ~CXTPDockingPanePaintManager ()
Destroys a CXTPDockingPanePaintManager object, handles cleanup and deallocation.
virtual void | DrawCaptionButtonEntry (CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton, CSize szOffset)
Draws only the glyph of a button.
virtual void | DrawCaptionButtonEntry (CDC *pDC, CXTPDockingPaneCaptionButton *pButton, CPoint pt, COLORREF clrButton)
Draws only the glyph of a button.
void | ClipAndAddEllipsisIfNeeded (CDC *pDC, CString &strTitle, int nCaptionWidth) const
Clip string and add ellipsis if its width less than nCaptionWidth.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPDockingPanePaintManager
BOOL | m_bUseBoldCaptionFont
TRUE to use bold font for caption.
BOOL | m_bHighlightActiveCaption
TRUE to highlight active caption.
int | m_nSplitterSize
Splitter size.
BOOL | m_bShowCaption
TRUE to draw captions of tabbed containers.
BOOL | m_bDrawSingleTab
TRUE to draw single tab.
BOOL | m_bDrawCaptionIcon
TRUE to draw caption icon.
int | m_nSplitterIndent
Size of splitter indent.
CXTPPaintManagerColor | m_clrBackground
Background color.
CXTPPaintManagerColor | m_clrSplitterGripper
Splitter gripper color.
CXTPPaintManagerColor | m_clrSplitter
Splitter color.
CXTPPaintManagerColorGradient | m_clrSplitterGradient
Splitter gradient color.
CXTPPaintManagerColorGradient | m_clrNormalCaption
Color of pane caption when inactive.
CXTPPaintManagerColorGradient | m_clrActiveCaption
Color of pane caption when active.
CXTPPaintManagerColor | m_clrNormalCaptionText
Color of pane caption text when the caption is inactive.
CXTPPaintManagerColor | m_clrActiveCaptionText
Active caption text.
CXTPPaintManagerColor | m_clrDisabledCaptionText
Disabled caption text.
- Protected Attributes inherited from CXTPDockingPanePaintManager
XTPDockingPaneCaptionButtonStyle | m_nCaptionButtonStyle
Caption button style.
DWORD | m_dwSplitterStyle
Splitter style.
int | m_nTitleHeight
Title's height.
int | m_nCaptionFontGap
Additional gap of font.
int | m_nTabsHeight
Tab bar's height.
CXTPFont | m_xtpFontTitle
Title font.
CXTPFont | m_xtpFontTitleVertical
Title vertical font.
BOOL | m_bUseOfficeFont
TRUE to use Tahoma font.
BOOL | m_bUseStandardFont
TRUE to use system icon font.
BOOL | m_bDestroyCustomTitleBrushes
If TRUE, custom title bushes will be destroyed on cleanup.
HBRUSH | m_hbrActiveTitleHorz
Optional user specified active horizontal title brush.
HBRUSH | m_hbrInactiveTitleHorz
Optional user specified inactive horizontal title brush.
HBRUSH | m_hbrActiveTitleVert
Optional user specified active vertical title brush.
HBRUSH | m_hbrInactiveTitleVert
Optional user specified inactive vertical title brush.
CXTPTabPaintManager * | m_pTabPaintManager
Paint Manager used to draw tabs for a tabbed container.
CXTPTabPaintManager * | m_pPanelPaintManager
Paint Manager used to draw tabs for an auto-hide panel.
COLORREF | m_arrColor [XPCOLOR_LAST+1]
Self colors array.
XTPDockingPanePaintTheme | m_themeCurrent
Current theme.
CString | m_strOfficeFont
Office font name.
CRect | m_rcCaptionMargin
Margins of caption.
XTPCurrentSystemTheme | m_systemTheme
Current system theme.
CXTPWinThemeWrapper * | m_themeToolbar
Toolbar theme helper.
CXTPWinThemeWrapper * | m_themeExplorer
WinXP Explorer theme helper.
CXTPWinThemeWrapper * | m_themeButton
WinXP Button theme helper.
CXTPWinThemeWrapper * | m_themeWindow
WinXP Window Theme helper.
CXTPWinThemeWrapper * | m_themeRebar
Rebar theme helper.
BOOL | m_bLunaTheme
TRUE if luna colors are used.

Detailed Description

CXTPDockingPaneWinExplorerTheme is a CXTPDockingPaneDefaultTheme derived class that represents an Explorer theme for docking panes.

Call CXTPDockingPaneManager::SetTheme(xtpPaneThemeWinExplorer); to set this theme.

Member Function Documentation

◆ DrawCaptionPart()

virtual void DrawCaptionPart | ( | CDC * | pDC,
 |  | CXTPDockingPaneBase * | pPane,
 |  | CRect | rcCaption,
 |  | const CString & | strTitle,
 |  | BOOL | bActive,
 |  | BOOL | bVertical )
 protectedvirtual

Draws the common part of a tabbed and floating caption.

Parameters
pDC | Reference to the device context in which to draw.
pPane | Container which the caption needs to draw.
rcCaption | Caption bounding rectangle.
strTitle | Caption text.
bActive | TRUE if the caption is active.
bVertical | TRUE to draw the caption vertically.

Reimplemented from CXTPDockingPaneGripperedTheme.

The documentation for this class was generated from the following file:
  • XTPDockingPaneThemeWinExplorer.h


Toolkit Pro: CXTPDockingPaneWinNativeTheme Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPDockingPaneWinNativeTheme Class Reference

CXTPDockingPaneWinNativeTheme is a CXTPDockingPaneVisualStudio2003Theme derived class that represents a Win Native theme for docking panes. More...

Inheritance diagram for CXTPDockingPaneWinNativeTheme:
[legend]

Public Member Functions

CXTPDockingPaneWinNativeTheme ()
Constructs a CXTPDockingPaneWinNativeTheme object.
virtual void | RefreshMetrics ()
This method is called to refresh the visual metrics of the pane.
virtual void | DrawCaption (CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc)
Override this member function to draw a caption.
void | DrawFloatingFrame (CDC *pDC, CXTPDockingPaneMiniWnd *pPane, CRect rc)
Call this method to draw the frame of a floating window.
void | DrawSidePanel (CDC *pDC, CXTPDockingPaneSidePanel *pPane, CRect rc)
Override this member function to draw the side panel.
- Public Member Functions inherited from CXTPDockingPaneVisualStudio2003Theme
CXTPDockingPaneVisualStudio2003Theme ()
Constructs a CXTPDockingPaneVisualStudio2003Theme object.
- Public Member Functions inherited from CXTPDockingPaneGripperedTheme
CXTPDockingPaneGripperedTheme ()
Constructs a CXTPDockingPaneGripperedTheme object.
- Public Member Functions inherited from CXTPDockingPaneDefaultTheme
CXTPDockingPaneDefaultTheme ()
Constructs a CXTPDockingPaneDefaultTheme object.
- Public Member Functions inherited from CXTPDockingPanePaintManager
virtual void | DrawPane (CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc)
Override this member function to draw a tabbed container.
virtual CRect | GetPaneCaptionRect (const CXTPDockingPaneSidePanel *pPane)
Call this method to get the pane's caption rectangle.
virtual void | DrawSplitter (CDC *pDC, CXTPDockingPaneSplitterWnd *pSplitter)
Override this method to draw a splitter.
virtual void | DrawCaptionButtons (CDC *pDC, CXTPDockingPaneCaptionButtons *pButtons, CRect &rcCaption, COLORREF clr, int nButtonSize, int nButtonGap, BOOL bVertical=FALSE)
Override this member function to draw buttons for a tabbed caption.
virtual void | DrawCaptionButton (CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton)
Override this member function to draw a button for a tabbed caption.
virtual void | AdjustClientRect (CXTPDockingPaneSidePanel *pPane, CRect &rect)
Override this member to change the client rectangle of the child docking pane.
virtual void | AdjustClientRect (CXTPDockingPaneTabbedContainer *pPane, CRect &rect, BOOL bApply)
Override this member to change the client rectangle of the child docking pane.
virtual void | AdjustCaptionRect (const CXTPDockingPaneSidePanel *pPane, CRect &rc)
Override this member to change the caption rectangle of the child docking pane.
virtual void | AdjustCaptionRect (const CXTPDockingPaneTabbedContainer *pPane, CRect &rc)
Override this member to change the caption rectangle of the child docking pane.
virtual void | GetCaptionRect (const CXTPDockingPaneTabbedContainer *pPane, CRect &rc)
Call this method to get a caption rectangle.
virtual CRect | GetCaptionGripperRect (const CXTPDockingPaneTabbedContainer *pPane)
Call this method to get a caption gripper for a tabbed container.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1, int nPen)
Draws a line.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1)
Draws a line.
int | DrawCaptionText (CDC *pDC, const CString &strTitle, CRect rc, BOOL bVertical, BOOL bCalcWidth=FALSE)
Draws the text of a pane caption.
void | Pixel (CDC *pDC, int xPos, int yPos, int nPen)
Sets the pixel at the point.
void | Rectangle (CDC *pDC, CRect rc, int nPenEntry, int nPenBorder)
Draws a rectangle.
void | UseOfficeFont (BOOL bUseOfficeFont)
Call this member to use Office (Tahoma) font.
void | SetCaptionFontIndirect (LOGFONT *pLogFont, BOOL bUseStandardFont=FALSE)
Call this method to set the caption's font.
CXTPTabPaintManager * | SetTabPaintManager (CXTPTabPaintManager *pManager)
Call this method to set the paint manager used to draw tabs of a tabbed container.
CXTPTabPaintManager * | SetPanelPaintManager (CXTPTabPaintManager *pManager)
Call this method to set the paint manager used to draw tabs of an auto-hide panel.
CXTPTabPaintManager * | GetTabPaintManager () const
Retrieves the paint manager used to draw tabs of a tabbed container.
CXTPTabPaintManager * | GetPanelPaintManager () const
Retrieves the paint manager used to draw tabs of an auto-hide panel.
COLORREF | GetXtremeColor (UINT nIndex)
Retrieves the current color of the specified XP display element.
void | SetColors (int cElements, CONST INT *lpaElements, CONST COLORREF *lpaRgbValues)
Call this member to set the colors for each element in an array to the colors in a specified color array.
int | GetCaptionHeight () const
Call this member to get the caption height of the tabbed container.
int | GetTabsHeight () const
Call this member to get tabs height of the tabbed container.
void | SetSplitterStyle (DWORD dwStyle)
Call this member to set the splitter style.
DWORD | GetSplitterStyle () const
Call this method to get the splitter style.
void | SetCaptionButtonStyle (XTPDockingPaneCaptionButtonStyle nStyle)
Call this member to set the caption button style.
XTPDockingPaneCaptionButtonStyle | GetCaptionButtonStyle () const
Call this method to get the caption button style.
XTPCurrentSystemTheme | GetCurrentSystemTheme () const
Call this member function to determine the current Windows XP theme in use.
void | SetLunaTheme (XTPCurrentSystemTheme systemTheme)
Call this method to force system theme.
virtual void | DrawAutoHidePanel (CDC *pDC, CRect rc, XTPDockingPaneDirection direction)
This mmethod is called by the framework to draw the docking pane auto-hide panel background and splitter.
void | SetCustomTitleBrushes (HBRUSH hbrActiveTitleHorz, HBRUSH hbrInactiveTitleHorz=NULL, HBRUSH hbrActiveTitleVert=NULL, HBRUSH hbrInactiveTitleVert=NULL, BOOL bDestroyOnCleanup=FALSE)
Sets custom title brushes.
HBRUSH | GetCustomTitleBrush (BOOL bActive, BOOL bVertical) const
Obtains the custom title brush.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

virtual void | DrawCaptionPart (CDC *pDC, CXTPDockingPaneBase *pPane, CRect rcCaption, const CString &strTitle, BOOL bActive, BOOL bVertical)
Draws the common part of a tabbed and floating caption.
- Protected Member Functions inherited from CXTPDockingPaneVisualStudio2003Theme
virtual COLORREF | FillCaptionPart (CDC *pDC, CXTPDockingPaneBase *pPane, CRect rcCaption, BOOL bActive, BOOL bVertical)
Draws the background of the pane caption.
- Protected Member Functions inherited from CXTPDockingPaneGripperedTheme
- Protected Member Functions inherited from CXTPDockingPaneDefaultTheme
- Protected Member Functions inherited from CXTPDockingPanePaintManager
CXTPDockingPanePaintManager ()
Constructs a CXTPDockingPanePaintManager object.
virtual | ~CXTPDockingPanePaintManager ()
Destroys a CXTPDockingPanePaintManager object, handles cleanup and deallocation.
virtual void | DrawCaptionButtonEntry (CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton, CSize szOffset)
Draws only the glyph of a button.
virtual void | DrawCaptionButtonEntry (CDC *pDC, CXTPDockingPaneCaptionButton *pButton, CPoint pt, COLORREF clrButton)
Draws only the glyph of a button.
void | ClipAndAddEllipsisIfNeeded (CDC *pDC, CString &strTitle, int nCaptionWidth) const
Clip string and add ellipsis if its width less than nCaptionWidth.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPDockingPanePaintManager
BOOL | m_bUseBoldCaptionFont
TRUE to use bold font for caption.
BOOL | m_bHighlightActiveCaption
TRUE to highlight active caption.
int | m_nSplitterSize
Splitter size.
BOOL | m_bShowCaption
TRUE to draw captions of tabbed containers.
BOOL | m_bDrawSingleTab
TRUE to draw single tab.
BOOL | m_bDrawCaptionIcon
TRUE to draw caption icon.
int | m_nSplitterIndent
Size of splitter indent.
CXTPPaintManagerColor | m_clrBackground
Background color.
CXTPPaintManagerColor | m_clrSplitterGripper
Splitter gripper color.
CXTPPaintManagerColor | m_clrSplitter
Splitter color.
CXTPPaintManagerColorGradient | m_clrSplitterGradient
Splitter gradient color.
CXTPPaintManagerColorGradient | m_clrNormalCaption
Color of pane caption when inactive.
CXTPPaintManagerColorGradient | m_clrActiveCaption
Color of pane caption when active.
CXTPPaintManagerColor | m_clrNormalCaptionText
Color of pane caption text when the caption is inactive.
CXTPPaintManagerColor | m_clrActiveCaptionText
Active caption text.
CXTPPaintManagerColor | m_clrDisabledCaptionText
Disabled caption text.
- Protected Attributes inherited from CXTPDockingPaneVisualStudio2003Theme
BOOL | m_bGradientCaption
TRUE to draw gradient caption.
- Protected Attributes inherited from CXTPDockingPanePaintManager
XTPDockingPaneCaptionButtonStyle | m_nCaptionButtonStyle
Caption button style.
DWORD | m_dwSplitterStyle
Splitter style.
int | m_nTitleHeight
Title's height.
int | m_nCaptionFontGap
Additional gap of font.
int | m_nTabsHeight
Tab bar's height.
CXTPFont | m_xtpFontTitle
Title font.
CXTPFont | m_xtpFontTitleVertical
Title vertical font.
BOOL | m_bUseOfficeFont
TRUE to use Tahoma font.
BOOL | m_bUseStandardFont
TRUE to use system icon font.
BOOL | m_bDestroyCustomTitleBrushes
If TRUE, custom title bushes will be destroyed on cleanup.
HBRUSH | m_hbrActiveTitleHorz
Optional user specified active horizontal title brush.
HBRUSH | m_hbrInactiveTitleHorz
Optional user specified inactive horizontal title brush.
HBRUSH | m_hbrActiveTitleVert
Optional user specified active vertical title brush.
HBRUSH | m_hbrInactiveTitleVert
Optional user specified inactive vertical title brush.
CXTPTabPaintManager * | m_pTabPaintManager
Paint Manager used to draw tabs for a tabbed container.
CXTPTabPaintManager * | m_pPanelPaintManager
Paint Manager used to draw tabs for an auto-hide panel.
COLORREF | m_arrColor [XPCOLOR_LAST+1]
Self colors array.
XTPDockingPanePaintTheme | m_themeCurrent
Current theme.
CString | m_strOfficeFont
Office font name.
CRect | m_rcCaptionMargin
Margins of caption.
XTPCurrentSystemTheme | m_systemTheme
Current system theme.
CXTPWinThemeWrapper * | m_themeToolbar
Toolbar theme helper.
CXTPWinThemeWrapper * | m_themeExplorer
WinXP Explorer theme helper.
CXTPWinThemeWrapper * | m_themeButton
WinXP Button theme helper.
CXTPWinThemeWrapper * | m_themeWindow
WinXP Window Theme helper.
CXTPWinThemeWrapper * | m_themeRebar
Rebar theme helper.
BOOL | m_bLunaTheme
TRUE if luna colors are used.

Detailed Description

CXTPDockingPaneWinNativeTheme is a CXTPDockingPaneVisualStudio2003Theme derived class that represents a Win Native theme for docking panes.

Call CXTPDockingPaneManager::SetTheme(xtpPaneThemeWinNative); to set this theme.

Member Function Documentation

◆ DrawCaption()

virtual void DrawCaption | ( | CDC * | pDC,
 |  | CXTPDockingPaneTabbedContainer * | pPane,
 |  | CRect | rc )
 virtual

Override this member function to draw a caption.

Parameters
pDC | Reference to the device context in which to draw.
pPane | Pointer to the tabbed container.
rc | Client rectangle of the tabbed container.

Reimplemented from CXTPDockingPaneGripperedTheme.

◆ DrawCaptionPart()

virtual void DrawCaptionPart | ( | CDC * | pDC,
 |  | CXTPDockingPaneBase * | pPane,
 |  | CRect | rcCaption,
 |  | const CString & | strTitle,
 |  | BOOL | bActive,
 |  | BOOL | bVertical )
 protectedvirtual

Draws the common part of a tabbed and floating caption.

Parameters
pDC | Reference to the device context in which to draw.
pPane | Container which the caption needs to draw.
rcCaption | Caption bounding rectangle.
strTitle | Caption text.
bActive | TRUE if the caption is active.
bVertical | TRUE to draw the caption vertically.

Reimplemented from CXTPDockingPaneVisualStudio2003Theme.

◆ DrawFloatingFrame()

void DrawFloatingFrame | ( | CDC * | pDC,
 |  | CXTPDockingPaneMiniWnd * | pPane,
 |  | CRect | rc )
 virtual

Call this method to draw the frame of a floating window.

Parameters
pDC | Pointer to a valid device context.
pPane | Floating window pointer.
rc | Client rectangle of the floating frame.

Reimplemented from CXTPDockingPaneGripperedTheme.

◆ DrawSidePanel()

void DrawSidePanel | ( | CDC * | pDC,
 |  | CXTPDockingPaneSidePanel * | pPane,
 |  | CRect | rc )
 virtual

Override this member function to draw the side panel.

Parameters
pDC | Reference to the device context in which to draw.
pPane | Pointer to the side panel.
rc | Client rectangle of the side panel.

Reimplemented from CXTPDockingPaneDefaultTheme.

The documentation for this class was generated from the following file:
  • XTPDockingPaneThemeWinNative.h


Toolkit Pro: CXTPDockState Class Reference

Public Member Functions | List of all members
CXTPDockState Class Reference

CXTPDockState is a standalone class. More...

Public Member Functions

void | ScalePoint (CPoint &pt)
Maps the point from the stored coordinates to the device.
void | ScaleRectPos (CRect &rect)
Maps the point from the stored coordinates to the device.
DWORD | GetVersion () const
Call this function to retrieve the version number of the stored bar state.
CXTPDockState ()
Constructs a CXTPDockState object.
~CXTPDockState ()
Destroys a CXTPDockState object, handles cleanup and deallocation.
void | SaveState (LPCTSTR lpszProfileName)
Saves state information to the registry or .INI file.
void | LoadState (LPCTSTR lpszProfileName)
Retrieves state information from the registry or .INI file.
void | DoPropExchange (CXTPPropExchange *pPX)
Either reads this object from or writes this object to an archive.

Detailed Description

CXTPDockState is a standalone class.

It is used internally by CXTPToolBar.

Member Function Documentation

◆ DoPropExchange()

void DoPropExchange ( CXTPPropExchange * pPX )

Either reads this object from or writes this object to an archive.

Parameters
pPX A CXTPPropExchange object to serialize to or from.
See also
CXTPCommandBars::DoPropExchange

◆ GetVersion()

AFX_INLINE DWORD GetVersion ( ) const

Call this function to retrieve the version number of the stored bar state.

Returns
Retrieves version number of stored bar state

◆ LoadState()

void LoadState ( LPCTSTR lpszProfileName )

Retrieves state information from the registry or .INI file.

Parameters
lpszProfileName Pointer to a NULL-terminated string that specifies the name of a section in the initialization file or a key in the Windows registry where state information is stored.

◆ SaveState()

void SaveState ( LPCTSTR lpszProfileName )

Saves state information to the registry or .INI file.

Parameters
lpszProfileName Pointer to a NULL-terminated string that specifies the name of a section in the initialization file or a key in the Windows registry where state information is stored.

◆ ScalePoint()

void ScalePoint ( CPoint & pt )

Maps the point from the stored coordinates to the device.

Parameters
pt Specifies the point to be tested.

◆ ScaleRectPos()

void ScaleRectPos ( CRect & rect )

Maps the point from the stored coordinates to the device.

Parameters
rect A reference to a CRect object.
The documentation for this class was generated from the following file:
  • XTPDockState.h


Toolkit Pro: CXTPDropSource Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPDropSource Class Reference

The CXTPDropSource class is derived from IDropSource. More...

Public Member Functions

CXTPDropSource ()
Constructs a CXTPDropSource object.
virtual | ~CXTPDropSource ()
Destroys a CXTPDropSource object, handles cleanup and deallocation.
STDMETHODIMP | QueryInterface (REFIID riid, LPVOID *ppReturn)
Provides client access to other interfaces.
STDMETHODIMP | QueryContinueDrag (BOOL bEsc, DWORD dwKeyState)
Determines if drag-and-drop should continue, stop or signal complete.
STDMETHODIMP | GiveFeedback (DWORD dwEffect)
Provides visual feedback during drag-and-drop operations.

Protected Attributes

UINT m_uiRefCount
Indicates the current reference count.

Detailed Description

The CXTPDropSource class is derived from IDropSource.

It is used by the shell list control to provide drag-and-drop operations in your application.

CXTPDropSource contains methods used in any application used as a data source in a drag-and-drop operation. The data source application in a drag-and-drop operation is responsible for:

Determining the data being dragged based on the user's selection. Initiating the drag-and-drop operation based on the user's mouse actions. Generating some of the visual feedback during the drag-and-drop operation, such as setting the cursor and highlighting the data selected for the drag-and-drop operation. Canceling or completing the drag-and-drop operation based on the user's mouse actions. Performing any action on the original data caused by the drop operation, such as deleting the data on a drag move.

CXTPDropSource contains the methods for generating visual feedback to the end user and for canceling or completing the drag-and-drop operation. You also need to call the DoDragDrop, RegisterDragDrop, and RevokeDragDrop functions in drag-and-drop operations.

Member Function Documentation

◆ GiveFeedback()

STDMETHODIMP GiveFeedback ( DWORD dwEffect )

Provides visual feedback during drag-and-drop operations.

Parameters
dwEffect Effect of a drop operation.

This method enables a source application to give visual feedback to the end user during a drag-and-drop operation by providing the DoDragDrop function with an enumeration value specifying the visual effect. This method supports the standard return values E_INVALIDARG, E_UNEXPECTED, and E_OUTOFMEMORY, as well as the following:

S_OK: Method completed its task successfully, using the cursor set by the source application. DRAGDROP_S_USEDEFAULTCURSORS: Successful completion of the method, and requests OLE to update the cursor using the OLE-provided default cursors.

Returns
An HRESULT value.

◆ QueryContinueDrag()

STDMETHODIMP QueryContinueDrag | ( | BOOL | bEsc,
 |  | DWORD | dwKeyState )

Determines if drag-and-drop should continue, stop or signal complete.

Parameters
bEsc | Specifies whether the ESC key has been pressed since the previous call to QueryContinueDrag, or to DoDragDrop if this is the first call to QueryContinueDrag. A TRUE value indicates that the end user has pressed the escape key. A FALSE value indicates it has not been pressed.
dwKeyState | Current state of the keyboard modifier keys on the keyboard. Valid values can be a combination of any of the flags MK_CONTROL, MK_SHIFT, MK_ALT, MK_BUTTON, MK_LBUTTON, MK_MBUTTON, and MK_RBUTTON.

This method determines whether a drag-and-drop operation should be continued, canceled, or completed. You do not call this method directly. The OLE DoDragDrop function calls this method during a drag-and-drop operation. This method supports the standard return values E_UNEXPECTED and E_OUTOFMEMORY, as well as the following:

S_OK: Drag operation should continue. This result occurs if no errors are detected, the mouse button starting the drag-and-drop operation has not been released, and the ESC key has not been detected. DRAGDROP_S_DROP: Drop operation should occur completing the drag operation. This result occurs if DWORD indicates that the key that started the drag-and-drop operation has been released. DRAGDROP_S_CANCEL: Drag operation should be canceled with no drop operation occurring. This result occurs if BOOL is TRUE, indicating that the ESC key has been pressed.

Returns
An HRESULT value.

◆ QueryInterface()

STDMETHODIMP QueryInterface | ( | REFIID | riid,
 |  | LPVOID * | ppReturn )

Provides client access to other interfaces.

The QueryInterface method gives a client access to other interfaces on an object. For any one object, a specific query for the IUnknown interface on any of the object's interfaces must always return the same pointer value. This allows a client to determine whether two pointers point to the same component by calling QueryInterface on both and comparing the results. It is specifically not the case that queries for interfaces (even the same interface through the same pointer) must return the same pointer value.

Parameters
riid | Identifier of the interface being requested.
ppReturn | Address of the pointer variable that receives the interface pointer requested in 'riid'. Upon successful return, 'ppReturn' contains the requested interface pointer to the object. If the object does not support the interface specified in 'riid', then 'ppReturn' is set to NULL.
Returns
A pointer to an interface if successful, otherwise NULL.
The documentation for this class was generated from the following file:
  • XTPDropSource.h


Toolkit Pro: CXTPEdit Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPEdit Class Reference

CXTPEdit is a CEdit derived class. More...

Inheritance diagram for CXTPEdit:
[legend]

Public Member Functions

CXTPEdit ()
Constructs a CXTPEdit object.
virtual | ~CXTPEdit ()
Destroys a CXTPEdit object, handles cleanup and deallocation.
BOOL | SetEditMask (LPCTSTR lpszMask, LPCTSTR lpszLiteral, LPCTSTR lpszDefault=NULL)
This member function will set the mask for the edit control.
void | SetPattern (LPCTSTR lpszPattern)
Call this member function to set the pattern for the edit mask.
virtual BOOL | CanPaste ()
Call this member function to determine if the Clipboard contains information that can be pasted into this edit view.
BOOL | HasSelection () const
Call this member function to determine if a selection has been made.
void | AdjustBuddyRect (CWnd *pBuddy, CRect &rcUpDown, int nAlignment)
Called by the framework to adjust the size of the area to draw the buddy control borders on.
void | DrawBuddyBorders (CWnd *pBuddy, CDC *pDC, CRect rc, int nAlignment)
Called by the framework to draw the borders for the associated buddy window.
virtual void | RefreshMetrics ()
This member is called to update the color, text and other visual elements of the control.
virtual void | SetTheme (XTPControlTheme nTheme)
Call this member to switch the visual theme of the control.
XTPControlTheme GetThemeID ()
Call this member function to get the style for the theme.
CXTPEditTheme * GetTheme ()
Call this member to retrieve a pointer to the current theme.
BOOL | GetFlatStyle () const
Gets the flat style appearance of the button control.
void | SetFlatStyle (BOOL bFlatStyle=TRUE)
Sets the flat style appearance of the button control.
BOOL | GetUseVisualStyle () const
Determines if the control is drawn using visual styles/SkinFramework, if supported.
void | SetUseVisualStyle (BOOL bUseVisualStyle=TRUE)
Enables Windows XP visual styles for the control.
BOOL | IsPatternValid ()
Called by the framework to determine if the pattern set using SetPattern() is valid.
void | ShowThemedBorder (BOOL bShowThemedBorder)
Call this member function to enable/disable theme border display.
BOOL | IsHighlighted () const
Call this member function to determine if the edit state is highlighted, meaning that the mouse cursor is currently hovering over the control.
BOOL | IsFocused () const
Call this member function to determine if the edit-box has input focus.
BOOL | IsFlatStyle () const
Gets the flat style appearance of the edit control.
BOOL | ShowBorder () const
Call this member to determine if non-client borders are displayed.
- Public Member Functions inherited from CXTPMaskEditT< CEdit >
CXTPMaskEditT ()
Constructs a CXTPMaskEditT object.
void | SetUseMask (BOOL bUseMask)
Call this member function to enable or disable the mask for the mask edit control.
BOOL | CanUseMask () const
This member function is called to determine if the mask for the edit control can be used.
void | SetOverType (BOOL bOverType)
This member function is called to enable or disable type over, also known as insert mode.
BOOL | CanOverType () const
This member function is called to determine if type over has been enabled.
BOOL | PosInRange (int iPos) const
This member function is called to determine if the index specified by 'iPos' is a valid index for the currently displayed edit text.
TCHAR | GetPromptChar () const
This member function retrieves the character that is currently used as the mask prompt.
CString | GetPromptString (int nLength) const
This helper member function retrieves the string contains nLength prompt characters.
void | SetPromptChar (TCHAR ch, BOOL bAutoReplace=TRUE)
This member function is called to set the prompt character that is displayed to the user that indicates the field can be edited.
afx_msg BOOL | MaskCut ()
This member function is called to perform a cut operation using the currently selected text.
afx_msg BOOL | MaskCopy ()
This member function is called to perform a copy operation using the currently selected text.
void | MaskReplaceSel (LPCTSTR lpszNewText)
This member function is called to perform a replace operation using the currently selected text.
afx_msg BOOL | MaskPaste ()
This member function is called to perform a paste operation using the current clipboard text.
void | MaskDeleteSel ()
This member function is called to delete the selection.
afx_msg BOOL | MaskClear ()
This member function is called to clear the current text selection.
afx_msg BOOL | MaskUndo ()
This member function is called to undo the previous action.
afx_msg void | MaskSelectAll ()
This member function is called to select all text in the mask edit control.
BOOL | IsModified () const
This member function is called to determine if the text has been modified.
void | SetMaskedText (LPCTSTR lpszMaskedText, int iPos=0, BOOL bUpdateWindow=TRUE)
This method called to set masked text for the edit control.
TCHAR | ConvertUnicodeAlpha (TCHAR nChar, BOOL bUpperCase) const
Converts character to Upper/Lower case.
virtual BOOL | CheckChar (TCHAR &nChar, int nPos)
This member function is used internally to validate the character indicated by 'nChar'.
virtual BOOL | ProcessMask (TCHAR &nChar, int nEndPos)
This member function is used internally to process the character passed in by 'nChar' whose index is specified by 'nEndPos'.
virtual BOOL | PreTranslateMessage (MSG *pMsg)
Used by class CWinApp to translate window messages before they are dispatched to theTranslateMessage andDispatchMessage Windows functions.
void | DeleteCharAt (int iPos)
Deletes character in specified position.
void | InsertCharAt (int iPos, TCHAR nChar)
Inserts character to specified position.
BOOL | CopyToClipboard (const CString &strText)
Copies text to system clipboard.
CString | GetMaskedText (int nStartPos=0, int nEndPos=-1) const
Retrieves masked text of the control.

Protected Member Functions

HBRUSH | GetClientBrush (CDC *pDC)
Retrieves a handle to the client background brush.
void | RedrawEdit ()
Called by the framework to redraw the edit control.
void | RedrawFocusedFrame ()
Called by the framework to redraw the focus rectangle for the edit control.
- Protected Member Functions inherited from CXTPMaskEditT< CEdit >
virtual BOOL | OnCommand (WPARAM wParam, LPARAM lParam)
The framework calls this member function when the user selects an item from a menu.

Protected Attributes

CXTPEditTheme * | m_pTheme
Pointer to the current edit theme.
BOOL | m_bPreSubclassInit
TRUE if the control has been subclassed.
BOOL | m_bShowBorder
TRUE if non-client borders are displayed.
BOOL | m_bHighlighted
TRUE when the mouse is hovering over the control.
BOOL | m_bFocused
TRUE when the control has input focus.
CXTPRegExp * | m_pRegExp
Pointer to the CXTPRegExp object for this control.
- Protected Attributes inherited from CXTPMaskEditT< CEdit >
int | m_nStartChar
Current position of the first character in the current selection.
int | m_nEndChar
Current position of the first non-selected character past the end of the current selection.
BOOL | m_bUseMask
TRUE to use the edit mask.
BOOL | m_bOverType
TRUE to over type the text, set with VK_INSERT key press.
BOOL | m_bRedo
TRUE to redo, or FALSE to undo.
BOOL | m_bModified
TRUE if mask edit has been modified.
TCHAR | m_chPrompt
Prompt character used to identify the text entry.
CString | m_strMask
Buffer that holds the actual edit mask value.
CString | m_strDefault
Contains the edit controls default display text.
CString | m_strUndoBuffer
Holds the contents of the undo buffer.
CString | m_strRedoBuffer
Holds the contents of the redo buffer.
CString | m_strWindowText
Buffer that holds the actual edit text.
CString | m_strLiteral
Literal format that restricts where the user can enter text.
BOOL | m_bUpdateUndo
TRUE to update undo.

Detailed Description

CXTPEdit is a CEdit derived class.

The CXTPEdit class provides the functionality of a Windows edit control. An edit control is a rectangular child window in which the user can enter text.

You can create an edit control either from a dialog template or directly in your code. In both cases, first call the constructor CXTPEdit to construct the CXTPEdit object, then call the Create member function to create the Windows edit control and attach it to the CXTPEdit object.

Construction can be a one-step process in a class derived from CXTPEdit. Write a constructor for the derived class and call Create from within the constructor.

CXTPEdit inherits significant functionality from CWnd. To set and retrieve text from a CXTPEdit object, use the CWnd member functions SetWindowText and GetWindowText, which either set or get the entire contents of an edit control even if it is a multi-line control. Also, if an edit control is multi-line, get and set part of the control's text by calling the CXTPEdit member functions GetLine, SetSel, GetSel, and ReplaceSel.

If you want to handle Windows notification messages sent by an edit control to its parent (usually a class derived from CDialog), add a message-map entry and message-handler member function to the parent class for each message.

Each message-map entry takes the following form:

ON_Notification(id, memberFxn)

Where 'id' specifies the child window ID of the edit control sending the notification, and 'memberFxn' is the name of the parent member function you have written to handle the notification.

The parent's function prototype is as follows:

afx_msg void memberFxn();

Following is a list of potential message-map entries and a description of the cases in which they would be sent to the parent:

ON_EN_CHANGE: The user has taken an action that may have altered text in an edit control. Unlike the EN_UPDATE notification message, this notification message is sent after Windows updates the display. ON_EN_ERRSPACE: The edit control cannot allocate enough memory to meet a specific request. ON_EN_HSCROLL: The user clicks an edit control's horizontal scrollbar. The parent window is notified before the screen is updated. ON_EN_KILLFOCUS: The edit control loses the input focus. ON_EN_MAXTEXT: The current insertion has exceeded the specified number of characters for the edit control and has been truncated. Also sent when an edit control does not have the ES_AUTOHSCROLL style and the number of characters to be inserted would exceed the width of the edit control. Also sent when an edit control does not have the ES_AUTOVSCROLL style and the total number of lines resulting from a text insertion would exceed the height of the edit control. ON_EN_SETFOCUS: Sent when an edit control receives the input focus. ON_EN_UPDATE: The edit control is about to display altered text. Sent after the control has formatted the text but before it screens the text so that the window size can be altered, if necessary. ON_EN_VSCROLL: The user clicks an edit control's vertical scrollbar. The parent window is notified before the screen is updated.

If you create a CXTPEdit object within a dialog box, then the CXTPEdit object is automatically destroyed when the user closes the dialog box.

If you create a CXTPEdit object from a dialog resource using the dialog editor, then the CXTPEdit object is automatically destroyed when the user closes the dialog box.

If you create a CXTPEdit object within a window, you may also need to destroy it. If you create the CXTPEdit object on the stack, it is destroyed automatically. If you create the CXTPEdit object on the heap by using the new function, you must call delete on the object to destroy it when the user terminates the Windows edit control. If you allocate any memory in the CXTPEdit object, override the CXTPEdit destructor to dispose of the allocations.

Member Function Documentation

◆ AdjustBuddyRect()

void AdjustBuddyRect | ( | CWnd * | pBuddy,
 |  | CRect & | rcUpDown,
 |  | int | nAlignment )

Called by the framework to adjust the size of the area to draw the buddy control borders on.

Parameters
pBuddy | Pointer to the buddy control associated with the edit.
rcUpDown | Size of the buddy border area to be drawn.
nAlignment | Side of the edit box that the buddy is attached to (either UDS_ALIGNRIGHT or UDS_ALIGNLEFT).

◆ CanPaste()

virtual BOOL CanPaste ( )
virtual

Call this member function to determine if the Clipboard contains information that can be pasted into this edit view.

Returns
TRUE if the Clipboard contains data in a format which this edit view can accept, otherwise FALSE.

◆ DrawBuddyBorders()

void DrawBuddyBorders | ( | CWnd * | pBuddy,
 |  | CDC * | pDC,
 |  | CRect | rc,
 |  | int | nAlignment )

Called by the framework to draw the borders for the associated buddy window.

Parameters
pBuddy | Pointer to the buddy control associated with the edit.
pDC | Pointer to a valid device context.
rc | Size of the buddy border area to be drawn.
nAlignment | Side of the edit box that thee buddy is attached to (either UDS_ALIGNRIGHT or UDS_ALIGNLEFT).

◆ GetClientBrush()

HBRUSH GetClientBrush ( CDC * pDC )
protected

Retrieves a handle to the client background brush.

Parameters
pDC Pointer to a valid device context.
Returns
A HBRUSH handle representing the client background brush.

◆ GetFlatStyle()

BOOL GetFlatStyle ( ) const

Gets the flat style appearance of the button control.

The control will appear flat until the mouse pointer moves over it, at which point it appears three-dimensional.

Returns
TRUE if the flat style is used, otherwise FALSE.

◆ GetTheme()

CXTPEditTheme * GetTheme ( )

Call this member to retrieve a pointer to the current theme.

Returns
A CXTPEditTheme object that represents the current theme.

◆ GetThemeID()

XTPControlTheme GetThemeID ( )

Call this member function to get the style for the theme.

Returns
An XTPControlTheme enumerator index value representing the theme style.

◆ GetUseVisualStyle()

BOOL GetUseVisualStyle ( ) const

Determines if the control is drawn using visual styles/SkinFramework, if supported.

This method enables Windows XP visual styles for the control. This Control will draw using visual styles if both the control and the operating system support it. Visual styles and SkinFramework skins are specifications for the appearance of controls. GetUseVisualStyle determines whether to use the currently set Windows XP visual style. If using SkinFramework, then it determines whether to use the currently set style of the SkinFramework.

Returns
TRUE if the currently set Windows XP visual style will be used to theme the control. If using SkinFramework, then the currently set style of the SkinFramework will be used to skin the control. FALSE if the currently set appearance/style in the OS will be used.

◆ HasSelection()

BOOL HasSelection ( ) const

Call this member function to determine if a selection has been made.

Returns
TRUE if a selection has been made, otherwise FALSE.

◆ IsFlatStyle()

BOOL IsFlatStyle ( ) const

Gets the flat style appearance of the edit control.

The control will appear flat until the mouse pointer moves over it, at which point it appears three-dimensional.

Returns
TRUE if the flat style is used, otherwise FALSE.

◆ IsFocused()

BOOL IsFocused ( ) const

Call this member function to determine if the edit-box has input focus.

Returns
TRUE if the edit-box has input focus, otherwise FALSE.

◆ IsHighlighted()

BOOL IsHighlighted ( ) const

Call this member function to determine if the edit state is highlighted, meaning that the mouse cursor is currently hovering over the control.

Returns
TRUE if the edit state is highlighted, otherwise FALSE.

◆ IsPatternValid()

BOOL IsPatternValid ( )

Called by the framework to determine if the pattern set using SetPattern() is valid.

Returns
TRUE if the previously set pattern is valid.

◆ SetEditMask()

BOOL SetEditMask | ( | LPCTSTR | lpszMask,
 |  | LPCTSTR | lpszLiteral,
 |  | LPCTSTR | lpszDefault = NULL )
 virtual

This member function will set the mask for the edit control.

Parameters
lpszMask | The format for the mask field. For example, if you wanted to set the mask for a phone number, and you only wanted digits to be entered, your mask might look like this; _T("(000) 000-0000").
lpszLiteral | The literal format is entered here. Wherever you place an underscore ('_') is where the user will be allowed to enter data only. Using the phone number example; _T("(___) ___-____").
lpszDefault | Text that is to be displayed when the control is initialized. For example; _T("(800) 555-1212"). If NULL, then 'lpszLiteral' is used to initialize the edit text.

The values that can be set are:

Mask Character  Description
---------------------  ------------------------
0                      Numeric (0-9)
9                      Numeric (0-9) or space (' ')
#                      Numeric (0-9) or space (' ') or ('+') or ('-')
L                      Alpha (a-Z)
?                      Alpha (a-Z) or space (' ')
A                      Alpha numeric (0-9 and a-Z)
a                      Alpha numeric (0-9 and a-Z) or space (' ')
&                      All print character only
H                      Uppercase hex digit (0-9 and A-F)
h                      Lowercase hex digit (0-9 and a-f)
X                      Uppercase hex digit (0-9 and A-F) and space (' ')
x                      Lowercase hex digit (0-9 and a-f) and space (' ')
>                      Forces characters to upper case (A-Z) or any Unicode character
<                      Forces characters to lower case (a-z) or any Unicode character
C                      Uppercase ASCII character
c                      Lowercase ASCII character
Returns
TRUE if successful; otherwise FALSE.

Reimplemented from CXTPMaskEditT< CEdit >.

◆ SetFlatStyle()

void SetFlatStyle ( BOOL bFlatStyle = TRUE )

Sets the flat style appearance of the button control.

Parameters
bFlatStyle TRUE to use the flat style, FALSE otherwise.

The control will appear flat until the mouse pointer moves over it, at which point it appears three-dimensional.

◆ SetPattern()

void SetPattern ( LPCTSTR lpszPattern )

Call this member function to set the pattern for the edit mask.

Parameters
lpszPattern Text pattern to set.

◆ SetTheme()

virtual void SetTheme ( XTPControlTheme nTheme )
virtual

Call this member to switch the visual theme of the control.

Parameters
nTheme New visual theme. Can be any of the values listed in the Remarks section.

nTheme can be one of the following: xtpControlThemeDefault: Standard appearance style. xtpControlThemeFlat: Flat appearance style. xtpControlThemeUltraFlat: Ultra flat appearance style. xtpControlThemeOffice2000: Office 2000 appearance style. xtpControlThemeOfficeXP: Office XP appearance style. xtpControlThemeOffice2003: Office 2003 appearance style. xtpControlThemeResource: Office 2007 appearance style. xtpControlThemeVisualStudio2012Light: VS 2012 Light style theme. xtpControlThemeVisualStudio2012Dark: VS 2012 Dark style theme.

◆ SetUseVisualStyle()

void SetUseVisualStyle ( BOOL bUseVisualStyle = TRUE )

Enables Windows XP visual styles for the control.

This method enables Windows XP visual styles for the control. This Control will draw using visual styles if both the control and the operating system support it. Visual styles and SkinFramework skins are specifications for the appearance of controls. GetUseVisualStyle determines whether to use the currently set Windows XP visual style. If using SkinFramework, then it determines whether to use the currently set style of the SkinFramework.

Parameters
bUseVisualStyle TRUE if the currently set Windows XP visual style will be used to theme the control. If using SkinFramework, then the currently set style of the SkinFramework will be used to skin the control. FALSE if the currently set appearance/style in the OS will be used.

◆ ShowBorder()

BOOL ShowBorder ( ) const

Call this member to determine if non-client borders are displayed.

Returns
TRUE if non-client borders are displayed.

◆ ShowThemedBorder()

void ShowThemedBorder ( BOOL bShowThemedBorder )

Call this member function to enable/disable theme border display.

Parameters
bShowThemedBorder TRUE to enable themed borders, FALSE to disable themed borders.
The documentation for this class was generated from the following file:
  • XTPEdit.h


Toolkit Pro: CXTPEditListBox Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPEditListBox Class Reference

CXTPEditListBox is a CXTPListBox derived class. More...

Inheritance diagram for CXTPEditListBox:
[legend]

Public Member Functions

CXTPEditListBox ()
Constructs a CXTPEditListBox object.
virtual | ~CXTPEditListBox ()
Destroys a CXTPEditListBox object, handles cleanup and deallocation.
void | SetListEditStyle (UINT nTitle, DWORD dwLStyle=LBS_XTP_DEFAULT)
Sets the edit style for the edit list box.
void | SetListEditStyle (LPCTSTR lpszTitle, DWORD dwLStyle=LBS_XTP_DEFAULT)
Sets the edit style for the edit list box.
int | GetCurrentIndex ()
Retrieves the current item index.
void | EditItem (int iItem)
This member function will enable editing for the list box item.
virtual void | GetEditItemText ()
Retrieves the edited item's text label.
void | SetEditText (LPCTSTR pcszText)
This method is called to set in-place edit text.
CXTPEditListBoxToolBar & GetEditGroup ()
Retrieves a pointer to the CXTPEditListBoxToolBar toolbar.
void | SetDlgFilter (LPCTSTR lpszFilter=NULL)
Call this member function to set the default filter for the file dialog.
void | SetDlgInitialDir (LPCTSTR lpszInitialDir)
This member function sets the initial directory for the file dialog.
bool | HasToolbar ()
Call this member function to determine if the edit list has a toolbar.
void | EnableEdit (bool bEnable)
This member function will enable/disable editing.
virtual void | Initialize (bool bAutoFont=true)
Initializes the CXTPEditListBox control.
virtual void | RecalcLayout ()
Recalculates the toolbar layout for the CXTPEditListBox.
virtual void | RefreshMetrics ()
Call this member function to refresh theme colors and redraw the control.
void | SetNewItemDefaultText (LPCTSTR lpszItemDefaultText)
Sets the default text for new items.
virtual void | MoveItemUp (int nIndex)
Moves an item up.
virtual void | MoveItemDown (int nIndex)
Moves an item down.
- Public Member Functions inherited from CXTPListBox
CXTPListBox ()
Constructs a CXTPListBox object.
virtual | ~CXTPListBox ()
Destroys a CXTPListBox object, handles cleanup and deallocation.
virtual COLORREF | GetBackColor ()
Called to retrieve the background color for the list box.
void | SetListStyle (XTPListBoxStyle style)
Call this method to set the style of the list box.
XTPListBoxStyle | GetListStyle () const
Call this method to retrieve the style of the list box.
void | SetTheme (XTPControlTheme nTheme)
This member function sets the drawing theme for the control.
BOOL | HasFocus () const
Call this member function to determine if the list box control has input focus.

Protected Member Functions

virtual BOOL | CreateEditGroup (bool bAutoFont=true)
This member function will create the edit group control.
virtual void | EditListItem (BOOL bNewItem)
Enables editing for the currently selected item.
virtual void | DeleteItem ()
Deletes the currently selected item.
virtual CXTPItemEdit * | CreateEditControl (CRect rcItem)
This method is called to create an in-place edit control.
- Protected Member Functions inherited from CXTPListBox
BOOL | TryItemFromPoint (CPoint pt, BOOL &bOutside, int &nIndex) const
This method determines the list box item nearest to the point specified in pt when there is at least one item in the list box.

Protected Attributes

CWnd * | m_pParentWnd
Pointer to the parent window.
CString | m_strItemDefaultText
Default text used when new items are created.
int | m_nIndex
Current index when edit functions are performed.
BOOL | m_bNewItem
TRUE if a new item is being entered into the list box.
bool | m_bEnableEdit
true if editing is enabled.
DWORD | m_dwLStyle
List edit styles.
CString | m_strTitle
Caption area title.
CString | m_strFilter
Default file filter.
CString | m_strInitialDir
Initial Dir.
CString | m_strItemText
Current text of a selected item during edit.
CXTPItemEdit * | m_pItemEdit
Pointer to the in-place edit item.
CXTPEditListBoxToolBar | m_editGroup
The edit group (toolbar) that appears above the list box.

Additional Inherited Members

- Public Attributes inherited from CXTPListBox
CXTPListBoxTheme * | m_pTheme
Pointer to the currently active theme.
XTPControlTheme | m_theme
List box theme.
int | m_nItemHeight
Height of the items.
int | m_nTextPadding
Text padding.
int | m_nHotItem
Hot item index.

Detailed Description

CXTPEditListBox is a CXTPListBox derived class.

It is used to create an editable list box. This list box can be configured to display a toolbar for editing. You can define browse styles to search for files or folders. Each entry is made editable with a double mouse click.

Member Function Documentation

◆ CreateEditControl()

virtual CXTPItemEdit * CreateEditControl ( CRect rcItem )
protectedvirtual

This method is called to create an in-place edit control.

Parameters
rcItem Bounding rectangle of edit control.
Returns
A newly created edit control object pointer.

◆ CreateEditGroup()

virtual BOOL CreateEditGroup ( bool bAutoFont = true )
protectedvirtual

This member function will create the edit group control.

Parameters
bAutoFont true to enable automatic font initialization.
Returns
TRUE if successful, otherwise FALSE.

◆ EditItem()

void EditItem ( int iItem )

This member function will enable editing for the list box item.

Parameters
iItem Index of the item to edit.

◆ EditListItem()

virtual void EditListItem ( BOOL bNewItem )
protectedvirtual

Enables editing for the currently selected item.

Parameters
bNewItem TRUE to add a new item.

This member function will enable editing for the currently selected list box item. If 'bNewItem' is TRUE, then a new item is added to the end of the list box.

◆ EnableEdit()

void EnableEdit ( bool bEnable )

This member function will enable/disable editing.

Parameters
bEnable true to enable editing, false to disable editing.

◆ GetCurrentIndex()

int GetCurrentIndex ( )

Retrieves the current item index.

Returns
An integer value that represents the edit control index.

Call this member function to get the current index for the edit control. Similar to GetCurSel; however, the current index is the index of the last item to be modified or added to the edit list box and not necessarily the selected item.

◆ GetEditGroup()

CXTPEditListBoxToolBar & GetEditGroup ( )

Retrieves a pointer to the CXTPEditListBoxToolBar toolbar.

Returns
A reference to a CXTPEditListBoxToolBar object.

Call this member function to return a reference to the CXTPEditListBoxToolBar control associated with the edit list box.

◆ GetEditItemText()

virtual void GetEditItemText ( )
virtual

Retrieves the edited item's text label.

This member function is called to retrieve the text for the item that is being edited in the list box and save the value to m_strItemText.

◆ HasToolbar()

bool HasToolbar ( )

Call this member function to determine if the edit list has a toolbar.

Returns
true if the toolbar is turned on, otherwise false.

◆ Initialize()

virtual void Initialize ( bool bAutoFont = true )
virtual

Initializes the CXTPEditListBox control.

Parameters
bAutoFont true to enable automatic font initialization.

Call this member function to initialize the list box. This method should be called directly after creating or sub-classing the control.

Reimplemented from CXTPListBox.

◆ MoveItemDown()

virtual void MoveItemDown ( int nIndex )
virtual

Moves an item down.

Parameters
nIndex Item index to move.

◆ MoveItemUp()

virtual void MoveItemUp ( int nIndex )
virtual

Moves an item up.

Parameters
nIndex Item index to move.

◆ RecalcLayout()

virtual void RecalcLayout ( )
virtual

Recalculates the toolbar layout for the CXTPEditListBox.

Call this member function to correctly reposition the edit list box toolbar. This will readjust the layout correctly and position the toolbar in relation to the list.

◆ SetDlgFilter()

void SetDlgFilter ( LPCTSTR lpszFilter = NULL )

Call this member function to set the default filter for the file dialog.

Parameters
lpszFilter Pointwe to a NULL-terminated string that represents the file filter used by the file open dialog.

◆ SetDlgInitialDir()

void SetDlgInitialDir ( LPCTSTR lpszInitialDir )

This member function sets the initial directory for the file dialog.

Parameters
lpszInitialDir [in] Pointer to a NULL-terminated string that represents the initial directory of the file open dialog.

◆ SetEditText()

void SetEditText ( LPCTSTR pcszText )

This method is called to set in-place edit text.

Parameters
pcszText Next text to set.

◆ SetListEditStyle() [1/2]

void SetListEditStyle | ( | LPCTSTR | lpszTitle,
 |  | DWORD | dwLStyle = LBS_XTP_DEFAULT )

Sets the edit style for the edit list box.

Parameters
lpszTitle | NULL-terminated string that represents the caption title.
dwLStyle | Style for the list edit control. Pass in LBS_XTP_NOTOOLBAR if you do not wish for the caption edit navigation control bar to be displayed.

Call this member function to set the style and title for the edit list box. The style of the edit list box can be set to one or more of the following values:

LBS_XTP_DEFAULT: Standard edit field. LBS_XTP_CHOOSEDIR: Choose directory browse edit field. LBS_XTP_CHOOSEFILE: Choose file browse edit field. LBS_XTP_NOTOOLBAR: Do not display edit toolbar.

◆ SetListEditStyle() [2/2]

void SetListEditStyle | ( | UINT | nTitle,
 |  | DWORD | dwLStyle = LBS_XTP_DEFAULT )

Sets the edit style for the edit list box.

Parameters
nTitle | Resource ID of the string to load for the caption title.
dwLStyle | Style for the list edit control. Pass in LBS_XTP_NOTOOLBAR if you do not wish for the caption edit navigation control bar to be displayed.

Call this member function to set the style and title for the edit list box. The style of the edit list box can be set to one or more of the following values:

LBS_XTP_DEFAULT: Standard edit field. LBS_XTP_CHOOSEDIR: Choose directory browse edit field. LBS_XTP_CHOOSEFILE: Choose file browse edit field. LBS_XTP_NOTOOLBAR: Do not display edit toolbar.

◆ SetNewItemDefaultText()

void SetNewItemDefaultText ( LPCTSTR lpszItemDefaultText )

Sets the default text for new items.

Parameters
lpszItemDefaultText A NULL-terminated string.

Call this member function to set the default text that is displayed when a new item is added to the edit list box.

The documentation for this class was generated from the following file:
  • XTPEditListBox.h


Toolkit Pro: CXTPEditListBoxToolBar Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPEditListBoxToolBar Class Reference

CXTPEditListBoxToolBar is a CStatic derived class. More...

Public Member Functions

CXTPEditListBoxToolBar ()
Constructs a CXTPEditListBoxToolBar object.
virtual | ~CXTPEditListBoxToolBar ()
Destroys a CXTPEditListBoxToolBar object, handles cleanup and deallocation.
virtual void | Initialize (bool bAutoFont=true)
Initializes the CXTPEditListBoxToolBar control.
CXTPButton & GetNewButton ()
This member function returns a reference to the new button of the edit group.
CXTPButton & GetDeleteButton ()
This member function returns a reference to the delete button of the edit group.
CXTPButton & GetUpButton ()
This member function returns a reference to the up button of the edit group.
CXTPButton & GetDownButton ()
This member function returns a reference to the down button of the edit group.
void | EnableEdit (bool bEnable)
This member function will enable/disable editing.
void | SetButtonTheme (XTPControlTheme eTheme)
Call this member to switch the visual theme of the control.
virtual void | DrawText (CDC *pDC, CRect &rcClient)
This member function is called by the CXTPEditListBoxToolBar object to render a text display for the control.
virtual void | MoveButtons ()
Recalculates the button layout within the CXTPEditListBoxToolBar window.
virtual void | SendCommand (UINT nCmdID)
Sends a notification to the owner window.
CToolTipCtrl & | GetTooltipControl ()
This member function returns a reference to the tooltip control.
void | SetTheme (XTPControlTheme nTheme)
This member function sets the drawing theme for the control.

Protected Attributes

bool | m_bShowUpDownButtons
Controls whether or not the up/down buttons are shown.
bool | m_bShowNewDeleteButtons
Controls whether or not the new/delete buttons are shown.
bool | m_bEnableEdit
true if editing is enabled.
CRect | m_arClipRect [4]
Array of toolbar button sizes.
CXTPButton | m_arButton [4]
Array of toolbar buttons.
CToolTipCtrl | m_tooltip
Tooltip control for edit buttons.
XTPControlTheme | m_theme
List box toolbar theme.

Detailed Description

CXTPEditListBoxToolBar is a CStatic derived class.

It used by the CXTPEditListBox class to create a toolbar above the edit list box to display icons for editing.

CXTPEditListBoxToolBar can be used for other classes by setting the notify window in Initialize. This window will receive notification messages whenever the new, delete, up, and down buttons are pressed. You can handle these messages by adding an ON_BN_CLICKED handler for each of the buttons XTP_IDC_BTN_NEW, XTP_IDC_BTN_DELETE, XTP_IDC_BTN_UP and XTP_IDC_BTN_DOWN.

Member Function Documentation

◆ DrawText()

virtual void DrawText | ( | CDC * | pDC,
 |  | CRect & | rcClient )
 virtual

This member function is called by the CXTPEditListBoxToolBar object to render a text display for the control.

Parameters
pDC | Pointer to a valid device context.
rcClient | Area to draw text on.

◆ EnableEdit()

void EnableEdit ( bool bEnable )

This member function will enable/disable editing.

Parameters
bEnable true to enable editing, false to disable editing.

◆ GetDeleteButton()

CXTPButton & GetDeleteButton ( )

This member function returns a reference to the delete button of the edit group.

Returns
A reference to a CXTPButton object.

◆ GetDownButton()

CXTPButton & GetDownButton ( )

This member function returns a reference to the down button of the edit group.

Returns
A reference to a CXTPButton object.

◆ GetNewButton()

CXTPButton & GetNewButton ( )

This member function returns a reference to the new button of the edit group.

Returns
A reference to a CXTPButton object.

◆ GetTooltipControl()

CToolTipCtrl & GetTooltipControl ( )

This member function returns a reference to the tooltip control.

Returns
A reference to a CToolTipCtrl object.

◆ GetUpButton()

CXTPButton & GetUpButton ( )

This member function returns a reference to the up button of the edit group.

Returns
A reference to a CXTPButton object.

◆ Initialize()

virtual void Initialize ( bool bAutoFont = true )
virtual

Initializes the CXTPEditListBoxToolBar control.

Parameters
bAutoFont true to enable automatic font initialization.

Call this member function to initialize the edit group control. This method should be called directly after creating or sub-classing the control.

◆ MoveButtons()

virtual void MoveButtons ( )
virtual

Recalculates the button layout within the CXTPEditListBoxToolBar window.

This member function is called by the CXTPEditListBoxToolBar object to position the group bar buttons when the window is sized.

◆ SendCommand()

virtual void SendCommand ( UINT nCmdID )
virtual

Sends a notification to the owner window.

Parameters
nCmdID Command ID to send.

This member function sends the command specified by nCmdID to the owner of the CXTPEditListBoxToolBar object. The command is sent whenever a button is pressed on the group bar.

◆ SetButtonTheme()

void SetButtonTheme ( XTPControlTheme eTheme )

Call this member to switch the visual theme of the control.

Parameters
eTheme New visual theme. Can be any of the values listed in the Remarks section.

nStyle can be one of the following: xtpControlThemeDefault: Use default theme. xtpControlThemeFlat: Flat appearance style. xtpControlThemeUltraFlat: Ultra flat appearance style. xtpControlThemeOffice2000: Office 2000 appearance style. xtpControlThemeOfficeXP: Office XP appearance style. xtpControlThemeOffice2003: Office 2003 appearance style. xtpControlThemeResource: Office 2007 appearance style.

◆ SetTheme()

void SetTheme ( XTPControlTheme nTheme )

This member function sets the drawing theme for the control.

Parameters
nTheme A XTPControlTheme constant used to specify which theme is to be used for the control.
See also
XTPControlTheme
The documentation for this class was generated from the following file:
  • XTPEditListBox.h


Toolkit Pro: CXTPEditTheme Class Reference

Public Member Functions | Public Attributes | Protected Attributes | List of all members
CXTPEditTheme Class Referenceabstract

CXTPEditTheme is the base class for all edit themes used to perform drawing tasks. More...

Inheritance diagram for CXTPEditTheme:
[legend]

Public Member Functions

CXTPEditTheme ()
Constructs a CXTPEditThemeDefault object.
virtual | ~CXTPEditTheme ()
Destructor, handles cleanup and deallocation.
virtual void | RefreshMetrics (CXTPEdit *pEdit)=0
This member function is called by the theme manager to refresh the visual styles used by each component's theme.
virtual void | DrawNcBorders (CDC *pDC, CRect rcWnd, CXTPEdit *pEdit)=0
This member function is called by the theme manager to draw non-client borders for the edit control.
virtual void | DrawNcScrollBack (CDC *pDC, CRect rcWnd, CXTPEdit *pEdit)=0
Called by the framework to draw the non-client background for the combobox scrollbar area.
virtual void | FillRect (CDC *pDC, int x, int y, int cx, int cy, CBrush *pBrush)
Called by the edit control to fill a rectangle using the brush specifed by pBrush.
virtual void | DrawFrame (CDC *pDC, CRect rc, int nSize, CBrush *pBrush)
Called by the edit control to draw a frame rectangle using the brush specified by pBrush.
virtual CBrush * | GetClientBrush (CDC *pDC, CXTPEdit *pEdit)
Call this member function to retrieve a pointer to the client background brush.
virtual CBrush * | CtlColor (CDC *pDC, UINT nCtlColor, CXTPEdit *pEdit)=0
Called by the framework to handle setting the text and background colors for the edit control.
virtual BOOL | AdjustBuddyRect (CWnd *pBuddy, CRect &rcUpDown, int nAlignment)
Called by the framework to adjust the size of the area to draw the buddy control borders on.
virtual void | DrawBuddyBorders (CWnd *pBuddy, CDC *pDC, CRect rc, int nAlignment, CXTPEdit *pEdit)=0
Called by the framework to draw the borders for the associated buddy window.
virtual BOOL | RedrawFocusedFrame () const
Called by the framework to redraw the focus rectangle for the edit control.
BOOL | IsFlatStyle () const
Call this member function to determine if the m_bFlatStyle flag has be set.
void | SetFlatStyle (BOOL bFlatStyle)
Call this member function to set a value for m_bFlatStyle.
XTPControlTheme | GetThemeID () const
Call this member function to get the style for the theme.
void | UseWinTheme (BOOL bUseWinTheme)
Call this member function to enable Windows themes for the edit control.
- Public Member Functions inherited from CXTPControlTheme
CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme | GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Public Attributes

CXTPBrush | m_xtpBrushBack
Background brush color.
CXTPPaintManagerColor | m_clrBack
Background color.
CXTPPaintManagerColor | m_clrText
Text color.
CXTPPaintManagerColor | m_clrTextReadOnly
Read-only text color.
CXTPPaintManagerColor | m_clrBackNonClient
Non-client area background color.
CXTPPaintManagerColorGradient | m_clrBorder
Dark and light border colors.

Protected Attributes

BOOL | m_bFlatStyle
TRUE when drawing flat borders.
BOOL | m_bUseWinTheme
TRUE to use windows themes.
XTPControlTheme | m_nTheme
Specifies the Theme ID used by the paint manager.
CXTPWinThemeWrapper | m_winTheme
Windows theme wrapper.
- Protected Attributes inherited from CXTPControlTheme
XTPControlTheme | m_nTheme
Currently selected theme style index.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlTheme
static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

CXTPEditTheme is the base class for all edit themes used to perform drawing tasks.

Member Function Documentation

◆ AdjustBuddyRect()

virtual BOOL AdjustBuddyRect | ( | CWnd * | pBuddy,
 |  | CRect & | rcUpDown,
 |  | int | nAlignment )
 virtual

Called by the framework to adjust the size of the area to draw the buddy control borders on.

Parameters
pBuddy | Pointer to the buddy control associated with the edit.
rcUpDown | Size of the buddy border area to be drawn.
nAlignment | Side of the edit box that the buddy is attached to (either UDS_ALIGNRIGHT or UDS_ALIGNLEFT).
Returns
TRUE if successful, otherwise FALSE.

Reimplemented in CXTPEditThemeDefault, CXTPEditThemeOfficeXP, and CXTPEditThemeResource.

◆ CtlColor()

virtual CBrush * CtlColor | ( | CDC * | pDC,
 |  | UINT | nCtlColor,
 |  | CXTPEdit * | pEdit )
 pure virtual

Called by the framework to handle setting the text and background colors for the edit control.

Parameters
pDC | Pointer to a valid device context.
nCtlColor | Specifies type of control (either CTLCOLOR_STATIC or CTLCOLOR_EDIT).
pEdit | Pointer to the edit control to to be drawn.
Returns
A brush object pointer to use or NULL.

Implemented in CXTPEditThemeDefault.

◆ DrawBuddyBorders()

virtual void DrawBuddyBorders | ( | CWnd * | pBuddy,
 |  | CDC * | pDC,
 |  | CRect | rc,
 |  | int | nAlignment,
 |  | CXTPEdit * | pEdit )
 pure virtual

Called by the framework to draw the borders for the associated buddy window.

Parameters
pBuddy | Pointer to the buddy control associated with the edit.
pDC | Pointer to a valid device context.
rc | Size of the buddy border area to be drawn.
nAlignment | Side of the edit box that the buddy is attached to (either UDS_ALIGNRIGHT or UDS_ALIGNLEFT).
pEdit | Pointer to the edit control for the buddy window.

Implemented in CXTPEditThemeDefault, CXTPEditThemeOffice2000, CXTPEditThemeOfficeXP, and CXTPEditThemeResource.

◆ DrawFrame()

virtual void DrawFrame | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | int | nSize,
 |  | CBrush * | pBrush )
 virtual

Called by the edit control to draw a frame rectangle using the brush specified by pBrush.

Parameters
pDC | Pointer to a valid device context.
rc | CRect object representing the size of rectangle to draw.
nSize | Width in pixels of the rectangle borders.
pBrush | Pointer to a CBrush object representing the border fill color.

◆ DrawNcBorders()

virtual void DrawNcBorders | ( | CDC * | pDC,
 |  | CRect | rcWnd,
 |  | CXTPEdit * | pEdit )
 pure virtual

This member function is called by the theme manager to draw non-client borders for the edit control.

Parameters
pDC | Pointer to a valid device context for the control.
rcWnd | Size of the area to draw borders on.
pEdit | Pointer to a CXTPEdit object.

Implemented in CXTPEditThemeDefault, CXTPEditThemeOffice2000, and CXTPEditThemeOfficeXP.

◆ DrawNcScrollBack()

virtual void DrawNcScrollBack | ( | CDC * | pDC,
 |  | CRect | rcWnd,
 |  | CXTPEdit * | pEdit )
 pure virtual

Called by the framework to draw the non-client background for the combobox scrollbar area.

Parameters
pDC | Pointer to a valid device context.
rcWnd | Size in window coordinates for the combobox.
pEdit | Pointer to the edit control to be drawn.

Implemented in CXTPEditThemeDefault.

◆ FillRect()

virtual void FillRect | ( | CDC * | pDC,
 |  | int | x,
 |  | int | y,
 |  | int | cx,
 |  | int | cy,
 |  | CBrush * | pBrush )
 virtual

Called by the edit control to fill a rectangle using the brush specifed by pBrush.

Parameters
pDC | Pointer to a valid device context.
x | Left side of the rectangle to draw.
y | Top side of the rectangle to draw.
cx | Width of the rectangle to draw.
cy | Height of the rectangle to draw.
pBrush | Pointer to a CBrush object representing the background fill color.

◆ GetClientBrush()

virtual CBrush * GetClientBrush | ( | CDC * | pDC,
 |  | CXTPEdit * | pEdit )
 virtual

Call this member function to retrieve a pointer to the client background brush.

Parameters
pDC | Pointer to a valid device context.
pEdit | Pointer to the edit control.
Returns
A CBrush pointer representing the client background brush.

◆ GetThemeID()

XTPControlTheme GetThemeID ( ) const

Call this member function to get the style for the theme.

Returns
A XTPControlTheme enumerator index value representing the theme style.

◆ IsFlatStyle()

BOOL IsFlatStyle ( ) const

Call this member function to determine if the m_bFlatStyle flag has be set.

Returns
TRUE if the flag has been set, otherwise FALSE.

◆ RedrawFocusedFrame()

virtual BOOL RedrawFocusedFrame ( ) const
virtual

Called by the framework to redraw the focus rectangle for the edit control.

Returns
The implementation must return TRUE to indicate that the focused frame has to be redrawn, or FALSE otherwise.

Reimplemented in CXTPEditThemeOffice2000, and CXTPEditThemeOfficeXP.

◆ RefreshMetrics()

virtual void RefreshMetrics ( CXTPEdit * pEdit )
pure virtual

This member function is called by the theme manager to refresh the visual styles used by each component's theme.

Parameters
pEdit Pointer to a CXTPEdit object.

Implemented in CXTPEditThemeDefault, CXTPEditThemeFlat, CXTPEditThemeOffice2000, CXTPEditThemeOffice2003, CXTPEditThemeOffice2013, CXTPEditThemeOfficeXP, CXTPEditThemeResource, CXTPEditThemeUltraFlat, CXTPEditThemeVisualStudio2010, and CXTPEditThemeVisualStudio2012.

◆ SetFlatStyle()

void SetFlatStyle ( BOOL bFlatStyle )

Call this member function to set a value for m_bFlatStyle.

Parameters
bFlatStyle TRUE to set the flat style flag.

◆ UseWinTheme()

void UseWinTheme ( BOOL bUseWinTheme )

Call this member function to enable Windows themes for the edit control.

Parameters
bUseWinTheme TRUE to use Windows themes.
The documentation for this class was generated from the following file:
  • XTPEditTheme.h


Toolkit Pro: CXTPEditThemeDefault Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPEditThemeDefault Class Reference

CXTPEditThemeDefault is a class used to perform theme drawing tasks. More...

Inheritance diagram for CXTPEditThemeDefault:
[legend]

Public Member Functions

CXTPEditThemeDefault ()
Constructs a CXTPEditThemeDefault object.
virtual | ~CXTPEditThemeDefault ()
Destructor, handles cleanup and deallocation.
virtual void | RefreshMetrics (CXTPEdit *pEdit)
This member function is called by the theme manager to refresh the visual styles used by each component's theme.
virtual void | DrawNcBorders (CDC *pDC, CRect rcWnd, CXTPEdit *pEdit)
This member function is called by the theme manager to draw non-client borders for the edit control.
virtual void | DrawNcScrollBack (CDC *pDC, CRect rcWnd, CXTPEdit *pEdit)
Called by the framework to draw the non-client background for the combobox scrollbar area.
virtual CBrush * | CtlColor (CDC *pDC, UINT nCtlColor, CXTPEdit *pEdit)
Called by the framework to handle setting the text and background colors for the edit control.
virtual BOOL | AdjustBuddyRect (CWnd *pBuddy, CRect &rcUpDown, int nAlignment)
Called by the framework to adjust the size of the area to draw the buddy control borders on.
virtual void | DrawBuddyBorders (CWnd *pBuddy, CDC *pDC, CRect rc, int nAlignment, CXTPEdit *pEdit)
Called by the framework to draw the borders for the associated buddy window.
- Public Member Functions inherited from CXTPEditTheme
CXTPEditTheme ()
Constructs a CXTPEditThemeDefault object.
virtual | ~CXTPEditTheme ()
Destructor, handles cleanup and deallocation.
virtual void | FillRect (CDC *pDC, int x, int y, int cx, int cy, CBrush *pBrush)
Called by the edit control to fill a rectangle using the brush specifed by pBrush.
virtual void | DrawFrame (CDC *pDC, CRect rc, int nSize, CBrush *pBrush)
Called by the edit control to draw a frame rectangle using the brush specified by pBrush.
virtual CBrush * | GetClientBrush (CDC *pDC, CXTPEdit *pEdit)
Call this member function to retrieve a pointer to the client background brush.
virtual BOOL | RedrawFocusedFrame () const
Called by the framework to redraw the focus rectangle for the edit control.
BOOL | IsFlatStyle () const
Call this member function to determine if the m_bFlatStyle flag has be set.
void | SetFlatStyle (BOOL bFlatStyle)
Call this member function to set a value for m_bFlatStyle.
XTPControlTheme | GetThemeID () const
Call this member function to get the style for the theme.
void | UseWinTheme (BOOL bUseWinTheme)
Call this member function to enable Windows themes for the edit control.
- Public Member Functions inherited from CXTPControlTheme
CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme | GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

virtual BOOL | DrawBuddyBorders (CDC *pDC, CRect rc, int nAlignment, CXTPEdit *pEdit)
Called by the paint-manager to draw the borders for the associated buddy window.
virtual BOOL | DrawNcBordersDefault (CDC *pDC, CRect rcWnd, CXTPEdit *pEdit)
Called by the paint-manager to perform Windows default border drawing for the non-client area of the combobox.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlTheme
static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPEditTheme
CXTPBrush | m_xtpBrushBack
Background brush color.
CXTPPaintManagerColor | m_clrBack
Background color.
CXTPPaintManagerColor | m_clrText
Text color.
CXTPPaintManagerColor | m_clrTextReadOnly
Read-only text color.
CXTPPaintManagerColor | m_clrBackNonClient
Non-client area background color.
CXTPPaintManagerColorGradient | m_clrBorder
Dark and light border colors.
- Protected Attributes inherited from CXTPEditTheme
BOOL | m_bFlatStyle
TRUE when drawing flat borders.
BOOL | m_bUseWinTheme
TRUE to use windows themes.
XTPControlTheme | m_nTheme
Specifies the Theme ID used by the paint manager.
CXTPWinThemeWrapper | m_winTheme
Windows theme wrapper.
- Protected Attributes inherited from CXTPControlTheme
XTPControlTheme | m_nTheme
Currently selected theme style index.

Detailed Description

CXTPEditThemeDefault is a class used to perform theme drawing tasks.

Member Function Documentation

◆ AdjustBuddyRect()

virtual BOOL AdjustBuddyRect | ( | CWnd * | pBuddy,
 |  | CRect & | rcUpDown,
 |  | int | nAlignment )
 virtual

Called by the framework to adjust the size of the area to draw the buddy control borders on.

Parameters
pBuddy | Pointer to the buddy control associated with the edit.
rcUpDown | Size of the buddy border area to be drawn.
nAlignment | Side of the edit box that the buddy is attached to (either UDS_ALIGNRIGHT or UDS_ALIGNLEFT).
Returns
TRUE if successful, otherwise FALSE.

Reimplemented from CXTPEditTheme.

Reimplemented in CXTPEditThemeOfficeXP, and CXTPEditThemeResource.

◆ CtlColor()

virtual CBrush * CtlColor | ( | CDC * | pDC,
 |  | UINT | nCtlColor,
 |  | CXTPEdit * | pEdit )
 virtual

Called by the framework to handle setting the text and background colors for the edit control.

Parameters
pDC | Pointer to a valid device context.
nCtlColor | Specifies type of control (either CTLCOLOR_STATIC or CTLCOLOR_EDIT).
pEdit | Pointer to the edit control to to be drawn.
Returns
A pointer to the brush used for painting the control background.

Implements CXTPEditTheme.

◆ DrawBuddyBorders() [1/2]

virtual BOOL DrawBuddyBorders | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | int | nAlignment,
 |  | CXTPEdit * | pEdit )
 protectedvirtual

Called by the paint-manager to draw the borders for the associated buddy window.

Parameters
pDC | Pointer to a valid device context.
rc | Size of the buddy border area to be drawn.
nAlignment | Side of the edit box that the buddy is attached to (either UDS_ALIGNRIGHT or UDS_ALIGNLEFT).
pEdit | Pointer to the edit control for the buddy window.
Returns
TRUE if the borders were successfully drawn.

Reimplemented in CXTPEditThemeOffice2000.

◆ DrawBuddyBorders() [2/2]

virtual void DrawBuddyBorders | ( | CWnd * | pBuddy,
 |  | CDC * | pDC,
 |  | CRect | rc,
 |  | int | nAlignment,
 |  | CXTPEdit * | pEdit )
 virtual

Called by the framework to draw the borders for the associated buddy window.

Parameters
pBuddy | Pointer to the buddy control associated with the edit.
pDC | Pointer to a valid device context.
rc | Size of the buddy border area to be drawn.
nAlignment | Side of the edit box that the buddy is attached to (either UDS_ALIGNRIGHT or UDS_ALIGNLEFT).
pEdit | Pointer to the edit control for the buddy window.

Implements CXTPEditTheme.

Reimplemented in CXTPEditThemeOffice2000, CXTPEditThemeOfficeXP, and CXTPEditThemeResource.

◆ DrawNcBorders()

virtual void DrawNcBorders | ( | CDC * | pDC,
 |  | CRect | rcWnd,
 |  | CXTPEdit * | pEdit )
 virtual

This member function is called by the theme manager to draw non-client borders for the edit control.

Parameters
pDC | Pointer to a valid device context for the control.
rcWnd | Size of the area to draw borders on.
pEdit | Pointer to a CXTPEdit object.

Implements CXTPEditTheme.

Reimplemented in CXTPEditThemeOffice2000, and CXTPEditThemeOfficeXP.

◆ DrawNcBordersDefault()

virtual BOOL DrawNcBordersDefault | ( | CDC * | pDC,
 |  | CRect | rcWnd,
 |  | CXTPEdit * | pEdit )
 protectedvirtual

Called by the paint-manager to perform Windows default border drawing for the non-client area of the combobox.

Parameters
pDC | Pointer to a valid device context.
rcWnd | Size of the border area to be drawn.
pEdit | Pointer to the edit control.
Returns
TRUE if the default borders were drawn, otherwise FALSE.

◆ DrawNcScrollBack()

virtual void DrawNcScrollBack | ( | CDC * | pDC,
 |  | CRect | rcWnd,
 |  | CXTPEdit * | pEdit )
 virtual

Called by the framework to draw the non-client background for the combobox scrollbar area.

Parameters
pDC | Pointer to a valid device context.
rcWnd | Size in window coordinates for the combobox.
pEdit | Pointer to the edit control to to be drawn.

Implements CXTPEditTheme.

◆ RefreshMetrics()

virtual void RefreshMetrics ( CXTPEdit * pEdit )
virtual

This member function is called by the theme manager to refresh the visual styles used by each component's theme.

Parameters
pEdit Pointer to a CXTPEdit object.

Implements CXTPEditTheme.

Reimplemented in CXTPEditThemeFlat, CXTPEditThemeOffice2000, CXTPEditThemeOffice2003, CXTPEditThemeOffice2013, CXTPEditThemeOfficeXP, CXTPEditThemeResource, CXTPEditThemeUltraFlat, CXTPEditThemeVisualStudio2010, and CXTPEditThemeVisualStudio2012.

The documentation for this class was generated from the following file:
  • XTPEditThemeDefault.h


Toolkit Pro: CXTPEditThemeFlat Class Reference

Public Member Functions | List of all members
CXTPEditThemeFlat Class Reference

CXTPEditThemeFlat is a class used to perform theme drawing tasks. More...

Inheritance diagram for CXTPEditThemeFlat:
[legend]

Public Member Functions

CXTPEditThemeFlat ()
Constructs a CXTPEditThemeFlat object.
virtual | ~CXTPEditThemeFlat ()
Destructor, handles cleanup and deallocation.
virtual void | RefreshMetrics (CXTPEdit *pEdit)
This member function is called by the theme manager to refresh the visual styles used by each component's theme.
- Public Member Functions inherited from CXTPEditThemeOfficeXP
CXTPEditThemeOfficeXP ()
Constructs a CXTPEditThemeOfficeXP object.
virtual | ~CXTPEditThemeOfficeXP ()
Destructor, handles cleanup and deallocation.
virtual void | DrawNcBorders (CDC *pDC, CRect rcWnd, CXTPEdit *pEdit)
This member function is called by the theme manager to draw non-client borders for the edit control.
virtual BOOL | AdjustBuddyRect (CWnd *pBuddy, CRect &rcUpDown, int nAlignment)
Called by the framework to adjust the size of the area to draw the buddy control borders on.
virtual void | DrawBuddyBorders (CWnd *pBuddy, CDC *pDC, CRect rc, int nAlignment, CXTPEdit *pEdit)
Called by the framework to draw the borders for the associated buddy window.
virtual BOOL | RedrawFocusedFrame () const
Called by the framework to redraw the focus rectangle for the edit control.
- Public Member Functions inherited from CXTPEditThemeOffice2000
CXTPEditThemeOffice2000 ()
Constructs a CXTPEditThemeOffice2000 object.
virtual | ~CXTPEditThemeOffice2000 ()
Destructor, handles cleanup and deallocation.
virtual BOOL | DrawBuddyBorders (CDC *pDC, CRect rc, int nAlignment, CXTPEdit *pEdit)
Called by the paint-manager to draw the borders for the associated buddy window.
- Public Member Functions inherited from CXTPEditThemeDefault
CXTPEditThemeDefault ()
Constructs a CXTPEditThemeDefault object.
virtual | ~CXTPEditThemeDefault ()
Destructor, handles cleanup and deallocation.
virtual void | DrawNcScrollBack (CDC *pDC, CRect rcWnd, CXTPEdit *pEdit)
Called by the framework to draw the non-client background for the combobox scrollbar area.
virtual CBrush * | CtlColor (CDC *pDC, UINT nCtlColor, CXTPEdit *pEdit)
Called by the framework to handle setting the text and background colors for the edit control.
- Public Member Functions inherited from CXTPEditTheme
CXTPEditTheme ()
Constructs a CXTPEditThemeDefault object.
virtual | ~CXTPEditTheme ()
Destructor, handles cleanup and deallocation.
virtual void | FillRect (CDC *pDC, int x, int y, int cx, int cy, CBrush *pBrush)
Called by the edit control to fill a rectangle using the brush specifed by pBrush.
virtual void | DrawFrame (CDC *pDC, CRect rc, int nSize, CBrush *pBrush)
Called by the edit control to draw a frame rectangle using the brush specified by pBrush.
virtual CBrush * | GetClientBrush (CDC *pDC, CXTPEdit *pEdit)
Call this member function to retrieve a pointer to the client background brush.
BOOL | IsFlatStyle () const
Call this member function to determine if the m_bFlatStyle flag has be set.
void | SetFlatStyle (BOOL bFlatStyle)
Call this member function to set a value for m_bFlatStyle.
XTPControlTheme | GetThemeID () const
Call this member function to get the style for the theme.
void | UseWinTheme (BOOL bUseWinTheme)
Call this member function to enable Windows themes for the edit control.
- Public Member Functions inherited from CXTPControlTheme
CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme | GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlTheme
static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPEditTheme
CXTPBrush | m_xtpBrushBack
Background brush color.
CXTPPaintManagerColor | m_clrBack
Background color.
CXTPPaintManagerColor | m_clrText
Text color.
CXTPPaintManagerColor | m_clrTextReadOnly
Read-only text color.
CXTPPaintManagerColor | m_clrBackNonClient
Non-client area background color.
CXTPPaintManagerColorGradient | m_clrBorder
Dark and light border colors.
- Protected Member Functions inherited from CXTPEditThemeDefault
virtual BOOL | DrawNcBordersDefault (CDC *pDC, CRect rcWnd, CXTPEdit *pEdit)
Called by the paint-manager to perform Windows default border drawing for the non-client area of the combobox.
- Protected Attributes inherited from CXTPEditThemeOfficeXP
CXTPPaintManagerColor | m_clrBorderHilite
Highlighted border color.
CXTPPaintManagerColor | m_clrBorderDisabled
Disabled border color.
- Protected Attributes inherited from CXTPEditTheme
BOOL | m_bFlatStyle
TRUE when drawing flat borders.
BOOL | m_bUseWinTheme
TRUE to use windows themes.
XTPControlTheme | m_nTheme
Specifies the Theme ID used by the paint manager.
CXTPWinThemeWrapper | m_winTheme
Windows theme wrapper.
- Protected Attributes inherited from CXTPControlTheme
XTPControlTheme | m_nTheme
Currently selected theme style index.

Detailed Description

CXTPEditThemeFlat is a class used to perform theme drawing tasks.

Member Function Documentation

◆ RefreshMetrics()

virtual void RefreshMetrics ( CXTPEdit * pEdit )
virtual

This member function is called by the theme manager to refresh the visual styles used by each component's theme.

Parameters
pEdit Pointer to a CXTPEdit object.

Reimplemented from CXTPEditThemeOfficeXP.

The documentation for this class was generated from the following file:
  • XTPEditThemeFlat.h


Toolkit Pro: CXTPEditThemeNativeWindows10 Class Reference

Public Member Functions | List of all members
CXTPEditThemeNativeWindows10 Class Reference

CXTPEditThemeNativeWindows10 is a class used to perform theme drawing tasks. More...

Inheritance diagram for CXTPEditThemeNativeWindows10:
[legend]

Public Member Functions

CXTPEditThemeNativeWindows10 ()
Constructs a CXTPEditThemeNativeWindows10 object.
virtual | ~CXTPEditThemeNativeWindows10 ()
Destructor, handles cleanup and deallocation.
- Public Member Functions inherited from CXTPEditThemeOffice2013
CXTPEditThemeOffice2013 ()
Constructs a CXTPEditThemeOffice2013 object.
virtual | ~CXTPEditThemeOffice2013 ()
Destructor, handles cleanup and deallocation.
virtual void | RefreshMetrics (CXTPEdit *pEdit)
This member function is called by the theme manager to refresh the visual styles used by each component's theme.
- Public Member Functions inherited from CXTPEditThemeOfficeXP
CXTPEditThemeOfficeXP ()
Constructs a CXTPEditThemeOfficeXP object.
virtual | ~CXTPEditThemeOfficeXP ()
Destructor, handles cleanup and deallocation.
virtual void | DrawNcBorders (CDC *pDC, CRect rcWnd, CXTPEdit *pEdit)
This member function is called by the theme manager to draw non-client borders for the edit control.
virtual BOOL | AdjustBuddyRect (CWnd *pBuddy, CRect &rcUpDown, int nAlignment)
Called by the framework to adjust the size of the area to draw the buddy control borders on.
virtual void | DrawBuddyBorders (CWnd *pBuddy, CDC *pDC, CRect rc, int nAlignment, CXTPEdit *pEdit)
Called by the framework to draw the borders for the associated buddy window.
virtual BOOL | RedrawFocusedFrame () const
Called by the framework to redraw the focus rectangle for the edit control.
- Public Member Functions inherited from CXTPEditThemeOffice2000
CXTPEditThemeOffice2000 ()
Constructs a CXTPEditThemeOffice2000 object.
virtual | ~CXTPEditThemeOffice2000 ()
Destructor, handles cleanup and deallocation.
virtual BOOL | DrawBuddyBorders (CDC *pDC, CRect rc, int nAlignment, CXTPEdit *pEdit)
Called by the paint-manager to draw the borders for the associated buddy window.
- Public Member Functions inherited from CXTPEditThemeDefault
CXTPEditThemeDefault ()
Constructs a CXTPEditThemeDefault object.
virtual | ~CXTPEditThemeDefault ()
Destructor, handles cleanup and deallocation.
virtual void | DrawNcScrollBack (CDC *pDC, CRect rcWnd, CXTPEdit *pEdit)
Called by the framework to draw the non-client background for the combobox scrollbar area.
virtual CBrush * | CtlColor (CDC *pDC, UINT nCtlColor, CXTPEdit *pEdit)
Called by the framework to handle setting the text and background colors for the edit control.
- Public Member Functions inherited from CXTPEditTheme
CXTPEditTheme ()
Constructs a CXTPEditThemeDefault object.
virtual | ~CXTPEditTheme ()
Destructor, handles cleanup and deallocation.
virtual void | FillRect (CDC *pDC, int x, int y, int cx, int cy, CBrush *pBrush)
Called by the edit control to fill a rectangle using the brush specifed by pBrush.
virtual void | DrawFrame (CDC *pDC, CRect rc, int nSize, CBrush *pBrush)
Called by the edit control to draw a frame rectangle using the brush specified by pBrush.
virtual CBrush * | GetClientBrush (CDC *pDC, CXTPEdit *pEdit)
Call this member function to retrieve a pointer to the client background brush.
BOOL | IsFlatStyle () const
Call this member function to determine if the m_bFlatStyle flag has be set.
void | SetFlatStyle (BOOL bFlatStyle)
Call this member function to set a value for m_bFlatStyle.
XTPControlTheme | GetThemeID () const
Call this member function to get the style for the theme.
void | UseWinTheme (BOOL bUseWinTheme)
Call this member function to enable Windows themes for the edit control.
- Public Member Functions inherited from CXTPControlTheme
CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme | GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlTheme
static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPEditTheme
CXTPBrush | m_xtpBrushBack
Background brush color.
CXTPPaintManagerColor | m_clrBack
Background color.
CXTPPaintManagerColor | m_clrText
Text color.
CXTPPaintManagerColor | m_clrTextReadOnly
Read-only text color.
CXTPPaintManagerColor | m_clrBackNonClient
Non-client area background color.
CXTPPaintManagerColorGradient | m_clrBorder
Dark and light border colors.
- Protected Member Functions inherited from CXTPEditThemeDefault
virtual BOOL | DrawNcBordersDefault (CDC *pDC, CRect rcWnd, CXTPEdit *pEdit)
Called by the paint-manager to perform Windows default border drawing for the non-client area of the combobox.
- Protected Attributes inherited from CXTPEditThemeOfficeXP
CXTPPaintManagerColor | m_clrBorderHilite
Highlighted border color.
CXTPPaintManagerColor | m_clrBorderDisabled
Disabled border color.
- Protected Attributes inherited from CXTPEditTheme
BOOL | m_bFlatStyle
TRUE when drawing flat borders.
BOOL | m_bUseWinTheme
TRUE to use windows themes.
XTPControlTheme | m_nTheme
Specifies the Theme ID used by the paint manager.
CXTPWinThemeWrapper | m_winTheme
Windows theme wrapper.
- Protected Attributes inherited from CXTPControlTheme
XTPControlTheme | m_nTheme
Currently selected theme style index.

Detailed Description

CXTPEditThemeNativeWindows10 is a class used to perform theme drawing tasks.

The documentation for this class was generated from the following file:
  • XTPEditThemeNativeWindows10.h


Toolkit Pro: CXTPEditThemeNativeWindows11 Class Reference

Public Member Functions | List of all members
CXTPEditThemeNativeWindows11 Class Reference

CXTPEditThemeNativeWindows11 is a class used to perform theme drawing tasks. More...

Inheritance diagram for CXTPEditThemeNativeWindows11:
[legend]

Public Member Functions

CXTPEditThemeNativeWindows11 ()
Constructs a CXTPEditThemeNativeWindows11 object.
virtual | ~CXTPEditThemeNativeWindows11 ()
Destructor, handles cleanup and deallocation.
- Public Member Functions inherited from CXTPEditThemeOffice2013
CXTPEditThemeOffice2013 ()
Constructs a CXTPEditThemeOffice2013 object.
virtual | ~CXTPEditThemeOffice2013 ()
Destructor, handles cleanup and deallocation.
virtual void | RefreshMetrics (CXTPEdit *pEdit)
This member function is called by the theme manager to refresh the visual styles used by each component's theme.
- Public Member Functions inherited from CXTPEditThemeOfficeXP
CXTPEditThemeOfficeXP ()
Constructs a CXTPEditThemeOfficeXP object.
virtual | ~CXTPEditThemeOfficeXP ()
Destructor, handles cleanup and deallocation.
virtual void | DrawNcBorders (CDC *pDC, CRect rcWnd, CXTPEdit *pEdit)
This member function is called by the theme manager to draw non-client borders for the edit control.
virtual BOOL | AdjustBuddyRect (CWnd *pBuddy, CRect &rcUpDown, int nAlignment)
Called by the framework to adjust the size of the area to draw the buddy control borders on.
virtual void | DrawBuddyBorders (CWnd *pBuddy, CDC *pDC, CRect rc, int nAlignment, CXTPEdit *pEdit)
Called by the framework to draw the borders for the associated buddy window.
virtual BOOL | RedrawFocusedFrame () const
Called by the framework to redraw the focus rectangle for the edit control.
- Public Member Functions inherited from CXTPEditThemeOffice2000
CXTPEditThemeOffice2000 ()
Constructs a CXTPEditThemeOffice2000 object.
virtual | ~CXTPEditThemeOffice2000 ()
Destructor, handles cleanup and deallocation.
virtual BOOL | DrawBuddyBorders (CDC *pDC, CRect rc, int nAlignment, CXTPEdit *pEdit)
Called by the paint-manager to draw the borders for the associated buddy window.
- Public Member Functions inherited from CXTPEditThemeDefault
CXTPEditThemeDefault ()
Constructs a CXTPEditThemeDefault object.
virtual | ~CXTPEditThemeDefault ()
Destructor, handles cleanup and deallocation.
virtual void | DrawNcScrollBack (CDC *pDC, CRect rcWnd, CXTPEdit *pEdit)
Called by the framework to draw the non-client background for the combobox scrollbar area.
virtual CBrush * | CtlColor (CDC *pDC, UINT nCtlColor, CXTPEdit *pEdit)
Called by the framework to handle setting the text and background colors for the edit control.
- Public Member Functions inherited from CXTPEditTheme
CXTPEditTheme ()
Constructs a CXTPEditThemeDefault object.
virtual | ~CXTPEditTheme ()
Destructor, handles cleanup and deallocation.
virtual void | FillRect (CDC *pDC, int x, int y, int cx, int cy, CBrush *pBrush)
Called by the edit control to fill a rectangle using the brush specifed by pBrush.
virtual void | DrawFrame (CDC *pDC, CRect rc, int nSize, CBrush *pBrush)
Called by the edit control to draw a frame rectangle using the brush specified by pBrush.
virtual CBrush * | GetClientBrush (CDC *pDC, CXTPEdit *pEdit)
Call this member function to retrieve a pointer to the client background brush.
BOOL | IsFlatStyle () const
Call this member function to determine if the m_bFlatStyle flag has be set.
void | SetFlatStyle (BOOL bFlatStyle)
Call this member function to set a value for m_bFlatStyle.
XTPControlTheme | GetThemeID () const
Call this member function to get the style for the theme.
void | UseWinTheme (BOOL bUseWinTheme)
Call this member function to enable Windows themes for the edit control.
- Public Member Functions inherited from CXTPControlTheme
CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme | GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlTheme
static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPEditTheme
CXTPBrush | m_xtpBrushBack
Background brush color.
CXTPPaintManagerColor | m_clrBack
Background color.
CXTPPaintManagerColor | m_clrText
Text color.
CXTPPaintManagerColor | m_clrTextReadOnly
Read-only text color.
CXTPPaintManagerColor | m_clrBackNonClient
Non-client area background color.
CXTPPaintManagerColorGradient | m_clrBorder
Dark and light border colors.
- Protected Member Functions inherited from CXTPEditThemeDefault
virtual BOOL | DrawNcBordersDefault (CDC *pDC, CRect rcWnd, CXTPEdit *pEdit)
Called by the paint-manager to perform Windows default border drawing for the non-client area of the combobox.
- Protected Attributes inherited from CXTPEditThemeOfficeXP
CXTPPaintManagerColor | m_clrBorderHilite
Highlighted border color.
CXTPPaintManagerColor | m_clrBorderDisabled
Disabled border color.
- Protected Attributes inherited from CXTPEditTheme
BOOL | m_bFlatStyle
TRUE when drawing flat borders.
BOOL | m_bUseWinTheme
TRUE to use windows themes.
XTPControlTheme | m_nTheme
Specifies the Theme ID used by the paint manager.
CXTPWinThemeWrapper | m_winTheme
Windows theme wrapper.
- Protected Attributes inherited from CXTPControlTheme
XTPControlTheme | m_nTheme
Currently selected theme style index.

Detailed Description

CXTPEditThemeNativeWindows11 is a class used to perform theme drawing tasks.

The documentation for this class was generated from the following file:
  • XTPEditThemeNativeWindows11.h


Toolkit Pro: CXTPEditThemeOffice2000 Class Reference

Public Member Functions | List of all members
CXTPEditThemeOffice2000 Class Reference

CXTPEditThemeOffice2000 is a class used to perform theme drawing tasks. More...

Inheritance diagram for CXTPEditThemeOffice2000:
[legend]

Public Member Functions

CXTPEditThemeOffice2000 ()
Constructs a CXTPEditThemeOffice2000 object.
virtual | ~CXTPEditThemeOffice2000 ()
Destructor, handles cleanup and deallocation.
virtual void | RefreshMetrics (CXTPEdit *pEdit)
This member function is called by the theme manager to refresh the visual styles used by each component's theme.
virtual void | DrawNcBorders (CDC *pDC, CRect rcWnd, CXTPEdit *pEdit)
This member function is called by the theme manager to draw non-client borders for the edit control.
virtual void | DrawBuddyBorders (CWnd *pBuddy, CDC *pDC, CRect rc, int nAlignment, CXTPEdit *pEdit)
Called by the framework to draw the borders for the associated buddy window.
virtual BOOL | RedrawFocusedFrame () const
Called by the framework to redraw the focus rectangle for the edit control.
virtual BOOL | DrawBuddyBorders (CDC *pDC, CRect rc, int nAlignment, CXTPEdit *pEdit)
Called by the paint-manager to draw the borders for the associated buddy window.
- Public Member Functions inherited from CXTPEditThemeDefault
CXTPEditThemeDefault ()
Constructs a CXTPEditThemeDefault object.
virtual | ~CXTPEditThemeDefault ()
Destructor, handles cleanup and deallocation.
virtual void | DrawNcScrollBack (CDC *pDC, CRect rcWnd, CXTPEdit *pEdit)
Called by the framework to draw the non-client background for the combobox scrollbar area.
virtual CBrush * | CtlColor (CDC *pDC, UINT nCtlColor, CXTPEdit *pEdit)
Called by the framework to handle setting the text and background colors for the edit control.
virtual BOOL | AdjustBuddyRect (CWnd *pBuddy, CRect &rcUpDown, int nAlignment)
Called by the framework to adjust the size of the area to draw the buddy control borders on.
- Public Member Functions inherited from CXTPEditTheme
CXTPEditTheme ()
Constructs a CXTPEditThemeDefault object.
virtual | ~CXTPEditTheme ()
Destructor, handles cleanup and deallocation.
virtual void | FillRect (CDC *pDC, int x, int y, int cx, int cy, CBrush *pBrush)
Called by the edit control to fill a rectangle using the brush specifed by pBrush.
virtual void | DrawFrame (CDC *pDC, CRect rc, int nSize, CBrush *pBrush)
Called by the edit control to draw a frame rectangle using the brush specified by pBrush.
virtual CBrush * | GetClientBrush (CDC *pDC, CXTPEdit *pEdit)
Call this member function to retrieve a pointer to the client background brush.
BOOL | IsFlatStyle () const
Call this member function to determine if the m_bFlatStyle flag has be set.
void | SetFlatStyle (BOOL bFlatStyle)
Call this member function to set a value for m_bFlatStyle.
XTPControlTheme | GetThemeID () const
Call this member function to get the style for the theme.
void | UseWinTheme (BOOL bUseWinTheme)
Call this member function to enable Windows themes for the edit control.
- Public Member Functions inherited from CXTPControlTheme
CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme | GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlTheme
static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPEditTheme
CXTPBrush | m_xtpBrushBack
Background brush color.
CXTPPaintManagerColor | m_clrBack
Background color.
CXTPPaintManagerColor | m_clrText
Text color.
CXTPPaintManagerColor | m_clrTextReadOnly
Read-only text color.
CXTPPaintManagerColor | m_clrBackNonClient
Non-client area background color.
CXTPPaintManagerColorGradient | m_clrBorder
Dark and light border colors.
- Protected Member Functions inherited from CXTPEditThemeDefault
virtual BOOL | DrawNcBordersDefault (CDC *pDC, CRect rcWnd, CXTPEdit *pEdit)
Called by the paint-manager to perform Windows default border drawing for the non-client area of the combobox.
- Protected Attributes inherited from CXTPEditTheme
BOOL | m_bFlatStyle
TRUE when drawing flat borders.
BOOL | m_bUseWinTheme
TRUE to use windows themes.
XTPControlTheme | m_nTheme
Specifies the Theme ID used by the paint manager.
CXTPWinThemeWrapper | m_winTheme
Windows theme wrapper.
- Protected Attributes inherited from CXTPControlTheme
XTPControlTheme | m_nTheme
Currently selected theme style index.

Detailed Description

CXTPEditThemeOffice2000 is a class used to perform theme drawing tasks.

Member Function Documentation

◆ DrawBuddyBorders() [1/2]

virtual BOOL DrawBuddyBorders | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | int | nAlignment,
 |  | CXTPEdit * | pEdit )
 virtual

Called by the paint-manager to draw the borders for the associated buddy window.

Parameters
pDC | Pointer to a valid device context.
rc | Size of the buddy border area to be drawn.
nAlignment | Side of the edit box that the buddy is attached to (either UDS_ALIGNRIGHT or UDS_ALIGNLEFT).
pEdit | Pointer to the edit control for the buddy window.
Returns
TRUE if the borders were successfully drawn.

Reimplemented from CXTPEditThemeDefault.

◆ DrawBuddyBorders() [2/2]

virtual void DrawBuddyBorders | ( | CWnd * | pBuddy,
 |  | CDC * | pDC,
 |  | CRect | rc,
 |  | int | nAlignment,
 |  | CXTPEdit * | pEdit )
 virtual

Called by the framework to draw the borders for the associated buddy window.

Parameters
pBuddy | Pointer to the buddy control associated with the edit.
pDC | Pointer to a valid device context.
rc | Size of the buddy border area to be drawn.
nAlignment | Side of the edit box that the buddy is attached to (either UDS_ALIGNRIGHT or UDS_ALIGNLEFT).
pEdit | Pointer to the edit control for the buddy window.

Reimplemented from CXTPEditThemeDefault.

Reimplemented in CXTPEditThemeOfficeXP, and CXTPEditThemeResource.

◆ DrawNcBorders()

virtual void DrawNcBorders | ( | CDC * | pDC,
 |  | CRect | rcWnd,
 |  | CXTPEdit * | pEdit )
 virtual

This member function is called by the theme manager to draw non-client borders for the edit control.

Parameters
pDC | Pointer to a valid device context for the control.
rcWnd | Size of the area to draw borders on.
pEdit | Pointer to a CXTPEdit object.

Reimplemented from CXTPEditThemeDefault.

Reimplemented in CXTPEditThemeOfficeXP.

◆ RedrawFocusedFrame()

virtual BOOL RedrawFocusedFrame ( ) const
virtual

Called by the framework to redraw the focus rectangle for the edit control.

Returns
The implementation must return TRUE to indicate that the focused frame has to be redrawn, or FALSE otherwise.

Reimplemented from CXTPEditTheme.

Reimplemented in CXTPEditThemeOfficeXP.

◆ RefreshMetrics()

virtual void RefreshMetrics ( CXTPEdit * pEdit )
virtual

This member function is called by the theme manager to refresh the visual styles used by each component's theme.

Parameters
pEdit Pointer to a CXTPEdit object.

Reimplemented from CXTPEditThemeDefault.

Reimplemented in CXTPEditThemeFlat, CXTPEditThemeOffice2003, CXTPEditThemeOffice2013, CXTPEditThemeOfficeXP, CXTPEditThemeResource, CXTPEditThemeUltraFlat, CXTPEditThemeVisualStudio2010, and CXTPEditThemeVisualStudio2012.

The documentation for this class was generated from the following file:
  • XTPEditThemeOffice2000.h


Toolkit Pro: CXTPEditThemeOffice2003 Class Reference

Public Member Functions | List of all members
CXTPEditThemeOffice2003 Class Reference

CXTPEditThemeOffice2003 is a class used to perform theme drawing tasks. More...

Inheritance diagram for CXTPEditThemeOffice2003:
[legend]

Public Member Functions

CXTPEditThemeOffice2003 ()
Constructs a CXTPEditThemeOffice2003 object.
virtual | ~CXTPEditThemeOffice2003 ()
Destructor, handles cleanup and deallocation.
virtual void | RefreshMetrics (CXTPEdit *pEdit)
This member function is called by the theme manager to refresh the visual styles used by each component's theme.
- Public Member Functions inherited from CXTPEditThemeOfficeXP
CXTPEditThemeOfficeXP ()
Constructs a CXTPEditThemeOfficeXP object.
virtual | ~CXTPEditThemeOfficeXP ()
Destructor, handles cleanup and deallocation.
virtual void | DrawNcBorders (CDC *pDC, CRect rcWnd, CXTPEdit *pEdit)
This member function is called by the theme manager to draw non-client borders for the edit control.
virtual BOOL | AdjustBuddyRect (CWnd *pBuddy, CRect &rcUpDown, int nAlignment)
Called by the framework to adjust the size of the area to draw the buddy control borders on.
virtual void | DrawBuddyBorders (CWnd *pBuddy, CDC *pDC, CRect rc, int nAlignment, CXTPEdit *pEdit)
Called by the framework to draw the borders for the associated buddy window.
virtual BOOL | RedrawFocusedFrame () const
Called by the framework to redraw the focus rectangle for the edit control.
- Public Member Functions inherited from CXTPEditThemeOffice2000
CXTPEditThemeOffice2000 ()
Constructs a CXTPEditThemeOffice2000 object.
virtual | ~CXTPEditThemeOffice2000 ()
Destructor, handles cleanup and deallocation.
virtual BOOL | DrawBuddyBorders (CDC *pDC, CRect rc, int nAlignment, CXTPEdit *pEdit)
Called by the paint-manager to draw the borders for the associated buddy window.
- Public Member Functions inherited from CXTPEditThemeDefault
CXTPEditThemeDefault ()
Constructs a CXTPEditThemeDefault object.
virtual | ~CXTPEditThemeDefault ()
Destructor, handles cleanup and deallocation.
virtual void | DrawNcScrollBack (CDC *pDC, CRect rcWnd, CXTPEdit *pEdit)
Called by the framework to draw the non-client background for the combobox scrollbar area.
virtual CBrush * | CtlColor (CDC *pDC, UINT nCtlColor, CXTPEdit *pEdit)
Called by the framework to handle setting the text and background colors for the edit control.
- Public Member Functions inherited from CXTPEditTheme
CXTPEditTheme ()
Constructs a CXTPEditThemeDefault object.
virtual | ~CXTPEditTheme ()
Destructor, handles cleanup and deallocation.
virtual void | FillRect (CDC *pDC, int x, int y, int cx, int cy, CBrush *pBrush)
Called by the edit control to fill a rectangle using the brush specifed by pBrush.
virtual void | DrawFrame (CDC *pDC, CRect rc, int nSize, CBrush *pBrush)
Called by the edit control to draw a frame rectangle using the brush specified by pBrush.
virtual CBrush * | GetClientBrush (CDC *pDC, CXTPEdit *pEdit)
Call this member function to retrieve a pointer to the client background brush.
BOOL | IsFlatStyle () const
Call this member function to determine if the m_bFlatStyle flag has be set.
void | SetFlatStyle (BOOL bFlatStyle)
Call this member function to set a value for m_bFlatStyle.
XTPControlTheme | GetThemeID () const
Call this member function to get the style for the theme.
void | UseWinTheme (BOOL bUseWinTheme)
Call this member function to enable Windows themes for the edit control.
- Public Member Functions inherited from CXTPControlTheme
CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme | GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlTheme
static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPEditTheme
CXTPBrush | m_xtpBrushBack
Background brush color.
CXTPPaintManagerColor | m_clrBack
Background color.
CXTPPaintManagerColor | m_clrText
Text color.
CXTPPaintManagerColor | m_clrTextReadOnly
Read-only text color.
CXTPPaintManagerColor | m_clrBackNonClient
Non-client area background color.
CXTPPaintManagerColorGradient | m_clrBorder
Dark and light border colors.
- Protected Member Functions inherited from CXTPEditThemeDefault
virtual BOOL | DrawNcBordersDefault (CDC *pDC, CRect rcWnd, CXTPEdit *pEdit)
Called by the paint-manager to perform Windows default border drawing for the non-client area of the combobox.
- Protected Attributes inherited from CXTPEditThemeOfficeXP
CXTPPaintManagerColor | m_clrBorderHilite
Highlighted border color.
CXTPPaintManagerColor | m_clrBorderDisabled
Disabled border color.
- Protected Attributes inherited from CXTPEditTheme
BOOL | m_bFlatStyle
TRUE when drawing flat borders.
BOOL | m_bUseWinTheme
TRUE to use windows themes.
XTPControlTheme | m_nTheme
Specifies the Theme ID used by the paint manager.
CXTPWinThemeWrapper | m_winTheme
Windows theme wrapper.
- Protected Attributes inherited from CXTPControlTheme
XTPControlTheme | m_nTheme
Currently selected theme style index.

Detailed Description

CXTPEditThemeOffice2003 is a class used to perform theme drawing tasks.

Member Function Documentation

◆ RefreshMetrics()

virtual void RefreshMetrics ( CXTPEdit * pEdit )
virtual

This member function is called by the theme manager to refresh the visual styles used by each component's theme.

Parameters
pEdit Pointer to a CXTPEdit object.

Reimplemented from CXTPEditThemeOfficeXP.

The documentation for this class was generated from the following file:
  • XTPEditThemeOffice2003.h


Toolkit Pro: CXTPEditThemeOffice2013 Class Reference

Public Member Functions | List of all members
CXTPEditThemeOffice2013 Class Reference

CXTPEditThemeOffice2013 is a class used to perform theme drawing tasks. More...

Inheritance diagram for CXTPEditThemeOffice2013:
[legend]

Public Member Functions

CXTPEditThemeOffice2013 ()
Constructs a CXTPEditThemeOffice2013 object.
virtual | ~CXTPEditThemeOffice2013 ()
Destructor, handles cleanup and deallocation.
virtual void | RefreshMetrics (CXTPEdit *pEdit)
This member function is called by the theme manager to refresh the visual styles used by each component's theme.
- Public Member Functions inherited from CXTPEditThemeOfficeXP
CXTPEditThemeOfficeXP ()
Constructs a CXTPEditThemeOfficeXP object.
virtual | ~CXTPEditThemeOfficeXP ()
Destructor, handles cleanup and deallocation.
virtual void | DrawNcBorders (CDC *pDC, CRect rcWnd, CXTPEdit *pEdit)
This member function is called by the theme manager to draw non-client borders for the edit control.
virtual BOOL | AdjustBuddyRect (CWnd *pBuddy, CRect &rcUpDown, int nAlignment)
Called by the framework to adjust the size of the area to draw the buddy control borders on.
virtual void | DrawBuddyBorders (CWnd *pBuddy, CDC *pDC, CRect rc, int nAlignment, CXTPEdit *pEdit)
Called by the framework to draw the borders for the associated buddy window.
virtual BOOL | RedrawFocusedFrame () const
Called by the framework to redraw the focus rectangle for the edit control.
- Public Member Functions inherited from CXTPEditThemeOffice2000
CXTPEditThemeOffice2000 ()
Constructs a CXTPEditThemeOffice2000 object.
virtual | ~CXTPEditThemeOffice2000 ()
Destructor, handles cleanup and deallocation.
virtual BOOL | DrawBuddyBorders (CDC *pDC, CRect rc, int nAlignment, CXTPEdit *pEdit)
Called by the paint-manager to draw the borders for the associated buddy window.
- Public Member Functions inherited from CXTPEditThemeDefault
CXTPEditThemeDefault ()
Constructs a CXTPEditThemeDefault object.
virtual | ~CXTPEditThemeDefault ()
Destructor, handles cleanup and deallocation.
virtual void | DrawNcScrollBack (CDC *pDC, CRect rcWnd, CXTPEdit *pEdit)
Called by the framework to draw the non-client background for the combobox scrollbar area.
virtual CBrush * | CtlColor (CDC *pDC, UINT nCtlColor, CXTPEdit *pEdit)
Called by the framework to handle setting the text and background colors for the edit control.
- Public Member Functions inherited from CXTPEditTheme
CXTPEditTheme ()
Constructs a CXTPEditThemeDefault object.
virtual | ~CXTPEditTheme ()
Destructor, handles cleanup and deallocation.
virtual void | FillRect (CDC *pDC, int x, int y, int cx, int cy, CBrush *pBrush)
Called by the edit control to fill a rectangle using the brush specifed by pBrush.
virtual void | DrawFrame (CDC *pDC, CRect rc, int nSize, CBrush *pBrush)
Called by the edit control to draw a frame rectangle using the brush specified by pBrush.
virtual CBrush * | GetClientBrush (CDC *pDC, CXTPEdit *pEdit)
Call this member function to retrieve a pointer to the client background brush.
BOOL | IsFlatStyle () const
Call this member function to determine if the m_bFlatStyle flag has be set.
void | SetFlatStyle (BOOL bFlatStyle)
Call this member function to set a value for m_bFlatStyle.
XTPControlTheme | GetThemeID () const
Call this member function to get the style for the theme.
void | UseWinTheme (BOOL bUseWinTheme)
Call this member function to enable Windows themes for the edit control.
- Public Member Functions inherited from CXTPControlTheme
CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme | GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlTheme
static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPEditTheme
CXTPBrush | m_xtpBrushBack
Background brush color.
CXTPPaintManagerColor | m_clrBack
Background color.
CXTPPaintManagerColor | m_clrText
Text color.
CXTPPaintManagerColor | m_clrTextReadOnly
Read-only text color.
CXTPPaintManagerColor | m_clrBackNonClient
Non-client area background color.
CXTPPaintManagerColorGradient | m_clrBorder
Dark and light border colors.
- Protected Member Functions inherited from CXTPEditThemeDefault
virtual BOOL | DrawNcBordersDefault (CDC *pDC, CRect rcWnd, CXTPEdit *pEdit)
Called by the paint-manager to perform Windows default border drawing for the non-client area of the combobox.
- Protected Attributes inherited from CXTPEditThemeOfficeXP
CXTPPaintManagerColor | m_clrBorderHilite
Highlighted border color.
CXTPPaintManagerColor | m_clrBorderDisabled
Disabled border color.
- Protected Attributes inherited from CXTPEditTheme
BOOL | m_bFlatStyle
TRUE when drawing flat borders.
BOOL | m_bUseWinTheme
TRUE to use windows themes.
XTPControlTheme | m_nTheme
Specifies the Theme ID used by the paint manager.
CXTPWinThemeWrapper | m_winTheme
Windows theme wrapper.
- Protected Attributes inherited from CXTPControlTheme
XTPControlTheme | m_nTheme
Currently selected theme style index.

Detailed Description

CXTPEditThemeOffice2013 is a class used to perform theme drawing tasks.

Member Function Documentation

◆ RefreshMetrics()

virtual void RefreshMetrics ( CXTPEdit * pEdit )
virtual

This member function is called by the theme manager to refresh the visual styles used by each component's theme.

Parameters
pEdit Pointer to a CXTPEdit object.

Reimplemented from CXTPEditThemeOfficeXP.

The documentation for this class was generated from the following file:
  • XTPEditThemeOffice2013.h


Toolkit Pro: CXTPEditThemeOfficeXP Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPEditThemeOfficeXP Class Reference

CXTPEditThemeOfficeXP is a class used to perform theme drawing tasks. More...

Inheritance diagram for CXTPEditThemeOfficeXP:
[legend]

Public Member Functions

CXTPEditThemeOfficeXP ()
Constructs a CXTPEditThemeOfficeXP object.
virtual | ~CXTPEditThemeOfficeXP ()
Destructor, handles cleanup and deallocation.
virtual void | RefreshMetrics (CXTPEdit *pEdit)
This member function is called by the theme manager to refresh the visual styles used by each component's theme.
virtual void | DrawNcBorders (CDC *pDC, CRect rcWnd, CXTPEdit *pEdit)
This member function is called by the theme manager to draw non-client borders for the edit control.
virtual BOOL | AdjustBuddyRect (CWnd *pBuddy, CRect &rcUpDown, int nAlignment)
Called by the framework to adjust the size of the area to draw the buddy control borders on.
virtual void | DrawBuddyBorders (CWnd *pBuddy, CDC *pDC, CRect rc, int nAlignment, CXTPEdit *pEdit)
Called by the framework to draw the borders for the associated buddy window.
virtual BOOL | RedrawFocusedFrame () const
Called by the framework to redraw the focus rectangle for the edit control.
- Public Member Functions inherited from CXTPEditThemeOffice2000
CXTPEditThemeOffice2000 ()
Constructs a CXTPEditThemeOffice2000 object.
virtual | ~CXTPEditThemeOffice2000 ()
Destructor, handles cleanup and deallocation.
virtual BOOL | DrawBuddyBorders (CDC *pDC, CRect rc, int nAlignment, CXTPEdit *pEdit)
Called by the paint-manager to draw the borders for the associated buddy window.
- Public Member Functions inherited from CXTPEditThemeDefault
CXTPEditThemeDefault ()
Constructs a CXTPEditThemeDefault object.
virtual | ~CXTPEditThemeDefault ()
Destructor, handles cleanup and deallocation.
virtual void | DrawNcScrollBack (CDC *pDC, CRect rcWnd, CXTPEdit *pEdit)
Called by the framework to draw the non-client background for the combobox scrollbar area.
virtual CBrush * | CtlColor (CDC *pDC, UINT nCtlColor, CXTPEdit *pEdit)
Called by the framework to handle setting the text and background colors for the edit control.
- Public Member Functions inherited from CXTPEditTheme
CXTPEditTheme ()
Constructs a CXTPEditThemeDefault object.
virtual | ~CXTPEditTheme ()
Destructor, handles cleanup and deallocation.
virtual void | FillRect (CDC *pDC, int x, int y, int cx, int cy, CBrush *pBrush)
Called by the edit control to fill a rectangle using the brush specifed by pBrush.
virtual void | DrawFrame (CDC *pDC, CRect rc, int nSize, CBrush *pBrush)
Called by the edit control to draw a frame rectangle using the brush specified by pBrush.
virtual CBrush * | GetClientBrush (CDC *pDC, CXTPEdit *pEdit)
Call this member function to retrieve a pointer to the client background brush.
BOOL | IsFlatStyle () const
Call this member function to determine if the m_bFlatStyle flag has be set.
void | SetFlatStyle (BOOL bFlatStyle)
Call this member function to set a value for m_bFlatStyle.
XTPControlTheme | GetThemeID () const
Call this member function to get the style for the theme.
void | UseWinTheme (BOOL bUseWinTheme)
Call this member function to enable Windows themes for the edit control.
- Public Member Functions inherited from CXTPControlTheme
CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme | GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Attributes

CXTPPaintManagerColor | m_clrBorderHilite
Highlighted border color.
CXTPPaintManagerColor | m_clrBorderDisabled
Disabled border color.
- Protected Attributes inherited from CXTPEditTheme
BOOL | m_bFlatStyle
TRUE when drawing flat borders.
BOOL | m_bUseWinTheme
TRUE to use windows themes.
XTPControlTheme | m_nTheme
Specifies the Theme ID used by the paint manager.
CXTPWinThemeWrapper | m_winTheme
Windows theme wrapper.
- Protected Attributes inherited from CXTPControlTheme
XTPControlTheme | m_nTheme
Currently selected theme style index.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlTheme
static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPEditTheme
CXTPBrush | m_xtpBrushBack
Background brush color.
CXTPPaintManagerColor | m_clrBack
Background color.
CXTPPaintManagerColor | m_clrText
Text color.
CXTPPaintManagerColor | m_clrTextReadOnly
Read-only text color.
CXTPPaintManagerColor | m_clrBackNonClient
Non-client area background color.
CXTPPaintManagerColorGradient | m_clrBorder
Dark and light border colors.
- Protected Member Functions inherited from CXTPEditThemeDefault
virtual BOOL | DrawNcBordersDefault (CDC *pDC, CRect rcWnd, CXTPEdit *pEdit)
Called by the paint-manager to perform Windows default border drawing for the non-client area of the combobox.

Detailed Description

CXTPEditThemeOfficeXP is a class used to perform theme drawing tasks.

Member Function Documentation

◆ AdjustBuddyRect()

virtual BOOL AdjustBuddyRect | ( | CWnd * | pBuddy,
 |  | CRect & | rcUpDown,
 |  | int | nAlignment )
 virtual

Called by the framework to adjust the size of the area to draw the buddy control borders on.

Parameters
pBuddy | Pointer to the buddy control associated with the edit.
rcUpDown | Size of the buddy border area to be drawn.
nAlignment | Side of the edit box that the buddy is attached to (either UDS_ALIGNRIGHT or UDS_ALIGNLEFT).
Returns
TRUE if successful, otherwise FALSE.

Reimplemented from CXTPEditThemeDefault.

Reimplemented in CXTPEditThemeResource.

◆ DrawBuddyBorders()

virtual void DrawBuddyBorders | ( | CWnd * | pBuddy,
 |  | CDC * | pDC,
 |  | CRect | rc,
 |  | int | nAlignment,
 |  | CXTPEdit * | pEdit )
 virtual

Called by the framework to draw the borders for the associated buddy window.

Parameters
pBuddy | Pointer to the buddy control associated with the edit.
pDC | Pointer to a valid device context.
rc | Size of the buddy border area to be drawn.
nAlignment | Side of the edit box that the buddy is attached to (either UDS_ALIGNRIGHT or UDS_ALIGNLEFT).
pEdit | Pointer to the edit control for the buddy window.

Reimplemented from CXTPEditThemeOffice2000.

Reimplemented in CXTPEditThemeResource.

◆ DrawNcBorders()

virtual void DrawNcBorders | ( | CDC * | pDC,
 |  | CRect | rcWnd,
 |  | CXTPEdit * | pEdit )
 virtual

This member function is called by the theme manager to draw non-client borders for the edit control.

Parameters
pDC | Pointer to a valid device context for the control.
rcWnd | Size of the area to draw borders on.
pEdit | Pointer to a CXTPEdit object.

Reimplemented from CXTPEditThemeOffice2000.

◆ RedrawFocusedFrame()

virtual BOOL RedrawFocusedFrame ( ) const
virtual

Called by the framework to redraw the focus rectangle for the edit control.

Returns
The implementation must return TRUE to indicate that the focused frame has to be redrawn, or FALSE otherwise.

Reimplemented from CXTPEditThemeOffice2000.

◆ RefreshMetrics()

virtual void RefreshMetrics ( CXTPEdit * pEdit )
virtual

This member function is called by the theme manager to refresh the visual styles used by each component's theme.

Parameters
pEdit Pointer to a CXTPEdit object.

Reimplemented from CXTPEditThemeOffice2000.

Reimplemented in CXTPEditThemeFlat, CXTPEditThemeOffice2003, CXTPEditThemeOffice2013, CXTPEditThemeResource, CXTPEditThemeUltraFlat, CXTPEditThemeVisualStudio2010, and CXTPEditThemeVisualStudio2012.

The documentation for this class was generated from the following file:
  • XTPEditThemeOfficeXP.h


Toolkit Pro: CXTPEditThemeResource Class Reference

Public Member Functions | List of all members
CXTPEditThemeResource Class Reference

CXTPEditThemeResource is a class used to perform theme drawing tasks. More...

Inheritance diagram for CXTPEditThemeResource:
[legend]

Public Member Functions

CXTPEditThemeResource ()
Constructs a CXTPEditThemeResource object.
virtual | ~CXTPEditThemeResource ()
Destructor, handles cleanup and deallocation.
virtual void | RefreshMetrics (CXTPEdit *pEdit)
This member function is called by the theme manager to refresh the visual styles used by each component's theme.
virtual BOOL | AdjustBuddyRect (CWnd *pBuddy, CRect &rcUpDown, int nAlignment)
Called by the framework to adjust the size of the area to draw the buddy control borders on.
virtual void | DrawBuddyBorders (CWnd *pBuddy, CDC *pDC, CRect rc, int nAlignment, CXTPEdit *pEdit)
Called by the framework to draw the borders for the associated buddy window.
- Public Member Functions inherited from CXTPEditThemeOfficeXP
CXTPEditThemeOfficeXP ()
Constructs a CXTPEditThemeOfficeXP object.
virtual | ~CXTPEditThemeOfficeXP ()
Destructor, handles cleanup and deallocation.
virtual void | DrawNcBorders (CDC *pDC, CRect rcWnd, CXTPEdit *pEdit)
This member function is called by the theme manager to draw non-client borders for the edit control.
virtual BOOL | RedrawFocusedFrame () const
Called by the framework to redraw the focus rectangle for the edit control.
- Public Member Functions inherited from CXTPEditThemeOffice2000
CXTPEditThemeOffice2000 ()
Constructs a CXTPEditThemeOffice2000 object.
virtual | ~CXTPEditThemeOffice2000 ()
Destructor, handles cleanup and deallocation.
virtual BOOL | DrawBuddyBorders (CDC *pDC, CRect rc, int nAlignment, CXTPEdit *pEdit)
Called by the paint-manager to draw the borders for the associated buddy window.
- Public Member Functions inherited from CXTPEditThemeDefault
CXTPEditThemeDefault ()
Constructs a CXTPEditThemeDefault object.
virtual | ~CXTPEditThemeDefault ()
Destructor, handles cleanup and deallocation.
virtual void | DrawNcScrollBack (CDC *pDC, CRect rcWnd, CXTPEdit *pEdit)
Called by the framework to draw the non-client background for the combobox scrollbar area.
virtual CBrush * | CtlColor (CDC *pDC, UINT nCtlColor, CXTPEdit *pEdit)
Called by the framework to handle setting the text and background colors for the edit control.
- Public Member Functions inherited from CXTPEditTheme
CXTPEditTheme ()
Constructs a CXTPEditThemeDefault object.
virtual | ~CXTPEditTheme ()
Destructor, handles cleanup and deallocation.
virtual void | FillRect (CDC *pDC, int x, int y, int cx, int cy, CBrush *pBrush)
Called by the edit control to fill a rectangle using the brush specifed by pBrush.
virtual void | DrawFrame (CDC *pDC, CRect rc, int nSize, CBrush *pBrush)
Called by the edit control to draw a frame rectangle using the brush specified by pBrush.
virtual CBrush * | GetClientBrush (CDC *pDC, CXTPEdit *pEdit)
Call this member function to retrieve a pointer to the client background brush.
BOOL | IsFlatStyle () const
Call this member function to determine if the m_bFlatStyle flag has be set.
void | SetFlatStyle (BOOL bFlatStyle)
Call this member function to set a value for m_bFlatStyle.
XTPControlTheme | GetThemeID () const
Call this member function to get the style for the theme.
void | UseWinTheme (BOOL bUseWinTheme)
Call this member function to enable Windows themes for the edit control.
- Public Member Functions inherited from CXTPControlTheme
CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme | GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlTheme
static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPEditTheme
CXTPBrush | m_xtpBrushBack
Background brush color.
CXTPPaintManagerColor | m_clrBack
Background color.
CXTPPaintManagerColor | m_clrText
Text color.
CXTPPaintManagerColor | m_clrTextReadOnly
Read-only text color.
CXTPPaintManagerColor | m_clrBackNonClient
Non-client area background color.
CXTPPaintManagerColorGradient | m_clrBorder
Dark and light border colors.
- Protected Member Functions inherited from CXTPEditThemeDefault
virtual BOOL | DrawNcBordersDefault (CDC *pDC, CRect rcWnd, CXTPEdit *pEdit)
Called by the paint-manager to perform Windows default border drawing for the non-client area of the combobox.
- Protected Attributes inherited from CXTPEditThemeOfficeXP
CXTPPaintManagerColor | m_clrBorderHilite
Highlighted border color.
CXTPPaintManagerColor | m_clrBorderDisabled
Disabled border color.
- Protected Attributes inherited from CXTPEditTheme
BOOL | m_bFlatStyle
TRUE when drawing flat borders.
BOOL | m_bUseWinTheme
TRUE to use windows themes.
XTPControlTheme | m_nTheme
Specifies the Theme ID used by the paint manager.
CXTPWinThemeWrapper | m_winTheme
Windows theme wrapper.
- Protected Attributes inherited from CXTPControlTheme
XTPControlTheme | m_nTheme
Currently selected theme style index.

Detailed Description

CXTPEditThemeResource is a class used to perform theme drawing tasks.

Member Function Documentation

◆ AdjustBuddyRect()

virtual BOOL AdjustBuddyRect | ( | CWnd * | pBuddy,
 |  | CRect & | rcUpDown,
 |  | int | nAlignment )
 virtual

Called by the framework to adjust the size of the area to draw the buddy control borders on.

Parameters
pBuddy | Pointer to the buddy control associated with the edit.
rcUpDown | Size of the buddy border area to be drawn.
nAlignment | Side of the edit box that the buddy is attached to (either UDS_ALIGNRIGHT or UDS_ALIGNLEFT).
Returns
TRUE if successful, otherwise FALSE.

Reimplemented from CXTPEditThemeOfficeXP.

◆ DrawBuddyBorders()

virtual void DrawBuddyBorders | ( | CWnd * | pBuddy,
 |  | CDC * | pDC,
 |  | CRect | rc,
 |  | int | nAlignment,
 |  | CXTPEdit * | pEdit )
 virtual

Called by the framework to draw the borders for the associated buddy window.

Parameters
pBuddy | Pointer to the buddy control associated with the edit.
pDC | Pointer to a valid device context.
rc | Size of the buddy border area to be drawn.
nAlignment | Side of the edit box that the buddy is attached to (either UDS_ALIGNRIGHT or UDS_ALIGNLEFT).
pEdit | Pointer to the edit control for the buddy window.

Reimplemented from CXTPEditThemeOfficeXP.

◆ RefreshMetrics()

virtual void RefreshMetrics ( CXTPEdit * pEdit )
virtual

This member function is called by the theme manager to refresh the visual styles used by each component's theme.

Parameters
pEdit Pointer to a CXTPEdit object.

Reimplemented from CXTPEditThemeOfficeXP.

The documentation for this class was generated from the following file:
  • XTPEditThemeResource.h


Toolkit Pro: CXTPEditThemeUltraFlat Class Reference

Public Member Functions | List of all members
CXTPEditThemeUltraFlat Class Reference

CXTPEditThemeUltraFlat is a class used to perform theme drawing tasks. More...

Inheritance diagram for CXTPEditThemeUltraFlat:
[legend]

Public Member Functions

CXTPEditThemeUltraFlat ()
Constructs a CXTPEditThemeUltraFlat object.
virtual | ~CXTPEditThemeUltraFlat ()
Destructor, handles cleanup and deallocation.
virtual void | RefreshMetrics (CXTPEdit *pEdit)
This member function is called by the theme manager to refresh the visual styles used by each component's theme.
- Public Member Functions inherited from CXTPEditThemeOfficeXP
CXTPEditThemeOfficeXP ()
Constructs a CXTPEditThemeOfficeXP object.
virtual | ~CXTPEditThemeOfficeXP ()
Destructor, handles cleanup and deallocation.
virtual void | DrawNcBorders (CDC *pDC, CRect rcWnd, CXTPEdit *pEdit)
This member function is called by the theme manager to draw non-client borders for the edit control.
virtual BOOL | AdjustBuddyRect (CWnd *pBuddy, CRect &rcUpDown, int nAlignment)
Called by the framework to adjust the size of the area to draw the buddy control borders on.
virtual void | DrawBuddyBorders (CWnd *pBuddy, CDC *pDC, CRect rc, int nAlignment, CXTPEdit *pEdit)
Called by the framework to draw the borders for the associated buddy window.
virtual BOOL | RedrawFocusedFrame () const
Called by the framework to redraw the focus rectangle for the edit control.
- Public Member Functions inherited from CXTPEditThemeOffice2000
CXTPEditThemeOffice2000 ()
Constructs a CXTPEditThemeOffice2000 object.
virtual | ~CXTPEditThemeOffice2000 ()
Destructor, handles cleanup and deallocation.
virtual BOOL | DrawBuddyBorders (CDC *pDC, CRect rc, int nAlignment, CXTPEdit *pEdit)
Called by the paint-manager to draw the borders for the associated buddy window.
- Public Member Functions inherited from CXTPEditThemeDefault
CXTPEditThemeDefault ()
Constructs a CXTPEditThemeDefault object.
virtual | ~CXTPEditThemeDefault ()
Destructor, handles cleanup and deallocation.
virtual void | DrawNcScrollBack (CDC *pDC, CRect rcWnd, CXTPEdit *pEdit)
Called by the framework to draw the non-client background for the combobox scrollbar area.
virtual CBrush * | CtlColor (CDC *pDC, UINT nCtlColor, CXTPEdit *pEdit)
Called by the framework to handle setting the text and background colors for the edit control.
- Public Member Functions inherited from CXTPEditTheme
CXTPEditTheme ()
Constructs a CXTPEditThemeDefault object.
virtual | ~CXTPEditTheme ()
Destructor, handles cleanup and deallocation.
virtual void | FillRect (CDC *pDC, int x, int y, int cx, int cy, CBrush *pBrush)
Called by the edit control to fill a rectangle using the brush specifed by pBrush.
virtual void | DrawFrame (CDC *pDC, CRect rc, int nSize, CBrush *pBrush)
Called by the edit control to draw a frame rectangle using the brush specified by pBrush.
virtual CBrush * | GetClientBrush (CDC *pDC, CXTPEdit *pEdit)
Call this member function to retrieve a pointer to the client background brush.
BOOL | IsFlatStyle () const
Call this member function to determine if the m_bFlatStyle flag has be set.
void | SetFlatStyle (BOOL bFlatStyle)
Call this member function to set a value for m_bFlatStyle.
XTPControlTheme | GetThemeID () const
Call this member function to get the style for the theme.
void | UseWinTheme (BOOL bUseWinTheme)
Call this member function to enable Windows themes for the edit control.
- Public Member Functions inherited from CXTPControlTheme
CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme | GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlTheme
static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPEditTheme
CXTPBrush | m_xtpBrushBack
Background brush color.
CXTPPaintManagerColor | m_clrBack
Background color.
CXTPPaintManagerColor | m_clrText
Text color.
CXTPPaintManagerColor | m_clrTextReadOnly
Read-only text color.
CXTPPaintManagerColor | m_clrBackNonClient
Non-client area background color.
CXTPPaintManagerColorGradient | m_clrBorder
Dark and light border colors.
- Protected Member Functions inherited from CXTPEditThemeDefault
virtual BOOL | DrawNcBordersDefault (CDC *pDC, CRect rcWnd, CXTPEdit *pEdit)
Called by the paint-manager to perform Windows default border drawing for the non-client area of the combobox.
- Protected Attributes inherited from CXTPEditThemeOfficeXP
CXTPPaintManagerColor | m_clrBorderHilite
Highlighted border color.
CXTPPaintManagerColor | m_clrBorderDisabled
Disabled border color.
- Protected Attributes inherited from CXTPEditTheme
BOOL | m_bFlatStyle
TRUE when drawing flat borders.
BOOL | m_bUseWinTheme
TRUE to use windows themes.
XTPControlTheme | m_nTheme
Specifies the Theme ID used by the paint manager.
CXTPWinThemeWrapper | m_winTheme
Windows theme wrapper.
- Protected Attributes inherited from CXTPControlTheme
XTPControlTheme | m_nTheme
Currently selected theme style index.

Detailed Description

CXTPEditThemeUltraFlat is a class used to perform theme drawing tasks.

Member Function Documentation

◆ RefreshMetrics()

virtual void RefreshMetrics ( CXTPEdit * pEdit )
virtual

This member function is called by the theme manager to refresh the visual styles used by each component's theme.

Parameters
pEdit Pointer to a CXTPEdit object.

Reimplemented from CXTPEditThemeOfficeXP.

The documentation for this class was generated from the following file:
  • XTPEditThemeUltraFlat.h


Toolkit Pro: CXTPEditThemeVisualStudio2010 Class Reference

Public Member Functions | List of all members
CXTPEditThemeVisualStudio2010 Class Reference

CXTPEditThemeVisualStudio2010 is a class used to perform theme drawing tasks. More...

Inheritance diagram for CXTPEditThemeVisualStudio2010:
[legend]

Public Member Functions

CXTPEditThemeVisualStudio2010 ()
Constructs a CXTPEditThemeVisualStudio2010 object.
virtual | ~CXTPEditThemeVisualStudio2010 ()
Destructor, handles cleanup and deallocation.
virtual void | RefreshMetrics (CXTPEdit *pEdit)
This member function is called by the theme manager to refresh the visual styles used by each component's theme.
- Public Member Functions inherited from CXTPEditThemeOfficeXP
CXTPEditThemeOfficeXP ()
Constructs a CXTPEditThemeOfficeXP object.
virtual | ~CXTPEditThemeOfficeXP ()
Destructor, handles cleanup and deallocation.
virtual void | DrawNcBorders (CDC *pDC, CRect rcWnd, CXTPEdit *pEdit)
This member function is called by the theme manager to draw non-client borders for the edit control.
virtual BOOL | AdjustBuddyRect (CWnd *pBuddy, CRect &rcUpDown, int nAlignment)
Called by the framework to adjust the size of the area to draw the buddy control borders on.
virtual void | DrawBuddyBorders (CWnd *pBuddy, CDC *pDC, CRect rc, int nAlignment, CXTPEdit *pEdit)
Called by the framework to draw the borders for the associated buddy window.
virtual BOOL | RedrawFocusedFrame () const
Called by the framework to redraw the focus rectangle for the edit control.
- Public Member Functions inherited from CXTPEditThemeOffice2000
CXTPEditThemeOffice2000 ()
Constructs a CXTPEditThemeOffice2000 object.
virtual | ~CXTPEditThemeOffice2000 ()
Destructor, handles cleanup and deallocation.
virtual BOOL | DrawBuddyBorders (CDC *pDC, CRect rc, int nAlignment, CXTPEdit *pEdit)
Called by the paint-manager to draw the borders for the associated buddy window.
- Public Member Functions inherited from CXTPEditThemeDefault
CXTPEditThemeDefault ()
Constructs a CXTPEditThemeDefault object.
virtual | ~CXTPEditThemeDefault ()
Destructor, handles cleanup and deallocation.
virtual void | DrawNcScrollBack (CDC *pDC, CRect rcWnd, CXTPEdit *pEdit)
Called by the framework to draw the non-client background for the combobox scrollbar area.
virtual CBrush * | CtlColor (CDC *pDC, UINT nCtlColor, CXTPEdit *pEdit)
Called by the framework to handle setting the text and background colors for the edit control.
- Public Member Functions inherited from CXTPEditTheme
CXTPEditTheme ()
Constructs a CXTPEditThemeDefault object.
virtual | ~CXTPEditTheme ()
Destructor, handles cleanup and deallocation.
virtual void | FillRect (CDC *pDC, int x, int y, int cx, int cy, CBrush *pBrush)
Called by the edit control to fill a rectangle using the brush specifed by pBrush.
virtual void | DrawFrame (CDC *pDC, CRect rc, int nSize, CBrush *pBrush)
Called by the edit control to draw a frame rectangle using the brush specified by pBrush.
virtual CBrush * | GetClientBrush (CDC *pDC, CXTPEdit *pEdit)
Call this member function to retrieve a pointer to the client background brush.
BOOL | IsFlatStyle () const
Call this member function to determine if the m_bFlatStyle flag has be set.
void | SetFlatStyle (BOOL bFlatStyle)
Call this member function to set a value for m_bFlatStyle.
XTPControlTheme | GetThemeID () const
Call this member function to get the style for the theme.
void | UseWinTheme (BOOL bUseWinTheme)
Call this member function to enable Windows themes for the edit control.
- Public Member Functions inherited from CXTPControlTheme
CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme | GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlTheme
static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPEditTheme
CXTPBrush | m_xtpBrushBack
Background brush color.
CXTPPaintManagerColor | m_clrBack
Background color.
CXTPPaintManagerColor | m_clrText
Text color.
CXTPPaintManagerColor | m_clrTextReadOnly
Read-only text color.
CXTPPaintManagerColor | m_clrBackNonClient
Non-client area background color.
CXTPPaintManagerColorGradient | m_clrBorder
Dark and light border colors.
- Protected Member Functions inherited from CXTPEditThemeDefault
virtual BOOL | DrawNcBordersDefault (CDC *pDC, CRect rcWnd, CXTPEdit *pEdit)
Called by the paint-manager to perform Windows default border drawing for the non-client area of the combobox.
- Protected Attributes inherited from CXTPEditThemeOfficeXP
CXTPPaintManagerColor | m_clrBorderHilite
Highlighted border color.
CXTPPaintManagerColor | m_clrBorderDisabled
Disabled border color.
- Protected Attributes inherited from CXTPEditTheme
BOOL | m_bFlatStyle
TRUE when drawing flat borders.
BOOL | m_bUseWinTheme
TRUE to use windows themes.
XTPControlTheme | m_nTheme
Specifies the Theme ID used by the paint manager.
CXTPWinThemeWrapper | m_winTheme
Windows theme wrapper.
- Protected Attributes inherited from CXTPControlTheme
XTPControlTheme | m_nTheme
Currently selected theme style index.

Detailed Description

CXTPEditThemeVisualStudio2010 is a class used to perform theme drawing tasks.

Member Function Documentation

◆ RefreshMetrics()

virtual void RefreshMetrics ( CXTPEdit * pEdit )
virtual

This member function is called by the theme manager to refresh the visual styles used by each component's theme.

Parameters
pEdit Pointer to a CXTPEdit object.

Reimplemented from CXTPEditThemeOfficeXP.

The documentation for this class was generated from the following file:
  • XTPEditThemeVisualStudio2010.h


Toolkit Pro: CXTPEditThemeVisualStudio2012 Class Reference

Public Member Functions | List of all members
CXTPEditThemeVisualStudio2012 Class Reference

CXTPEditThemeVisualStudio2012 is a class used to perform theme drawing tasks. More...

Inheritance diagram for CXTPEditThemeVisualStudio2012:
[legend]

Public Member Functions

CXTPEditThemeVisualStudio2012 (XTPControlTheme nTheme)
Constructs a CXTPEditThemeVisualStudio2012 object.
virtual | ~CXTPEditThemeVisualStudio2012 ()
Destructor, handles cleanup and deallocation.
virtual void | RefreshMetrics (CXTPEdit *pEdit)
This member function is called by the theme manager to refresh the visual styles used by each component's theme.
- Public Member Functions inherited from CXTPEditThemeOfficeXP
CXTPEditThemeOfficeXP ()
Constructs a CXTPEditThemeOfficeXP object.
virtual | ~CXTPEditThemeOfficeXP ()
Destructor, handles cleanup and deallocation.
virtual void | DrawNcBorders (CDC *pDC, CRect rcWnd, CXTPEdit *pEdit)
This member function is called by the theme manager to draw non-client borders for the edit control.
virtual BOOL | AdjustBuddyRect (CWnd *pBuddy, CRect &rcUpDown, int nAlignment)
Called by the framework to adjust the size of the area to draw the buddy control borders on.
virtual void | DrawBuddyBorders (CWnd *pBuddy, CDC *pDC, CRect rc, int nAlignment, CXTPEdit *pEdit)
Called by the framework to draw the borders for the associated buddy window.
virtual BOOL | RedrawFocusedFrame () const
Called by the framework to redraw the focus rectangle for the edit control.
- Public Member Functions inherited from CXTPEditThemeOffice2000
CXTPEditThemeOffice2000 ()
Constructs a CXTPEditThemeOffice2000 object.
virtual | ~CXTPEditThemeOffice2000 ()
Destructor, handles cleanup and deallocation.
virtual BOOL | DrawBuddyBorders (CDC *pDC, CRect rc, int nAlignment, CXTPEdit *pEdit)
Called by the paint-manager to draw the borders for the associated buddy window.
- Public Member Functions inherited from CXTPEditThemeDefault
CXTPEditThemeDefault ()
Constructs a CXTPEditThemeDefault object.
virtual | ~CXTPEditThemeDefault ()
Destructor, handles cleanup and deallocation.
virtual void | DrawNcScrollBack (CDC *pDC, CRect rcWnd, CXTPEdit *pEdit)
Called by the framework to draw the non-client background for the combobox scrollbar area.
virtual CBrush * | CtlColor (CDC *pDC, UINT nCtlColor, CXTPEdit *pEdit)
Called by the framework to handle setting the text and background colors for the edit control.
- Public Member Functions inherited from CXTPEditTheme
CXTPEditTheme ()
Constructs a CXTPEditThemeDefault object.
virtual | ~CXTPEditTheme ()
Destructor, handles cleanup and deallocation.
virtual void | FillRect (CDC *pDC, int x, int y, int cx, int cy, CBrush *pBrush)
Called by the edit control to fill a rectangle using the brush specifed by pBrush.
virtual void | DrawFrame (CDC *pDC, CRect rc, int nSize, CBrush *pBrush)
Called by the edit control to draw a frame rectangle using the brush specified by pBrush.
virtual CBrush * | GetClientBrush (CDC *pDC, CXTPEdit *pEdit)
Call this member function to retrieve a pointer to the client background brush.
BOOL | IsFlatStyle () const
Call this member function to determine if the m_bFlatStyle flag has be set.
void | SetFlatStyle (BOOL bFlatStyle)
Call this member function to set a value for m_bFlatStyle.
XTPControlTheme | GetThemeID () const
Call this member function to get the style for the theme.
void | UseWinTheme (BOOL bUseWinTheme)
Call this member function to enable Windows themes for the edit control.
- Public Member Functions inherited from CXTPControlTheme
CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme | GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlTheme
static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPEditTheme
CXTPBrush | m_xtpBrushBack
Background brush color.
CXTPPaintManagerColor | m_clrBack
Background color.
CXTPPaintManagerColor | m_clrText
Text color.
CXTPPaintManagerColor | m_clrTextReadOnly
Read-only text color.
CXTPPaintManagerColor | m_clrBackNonClient
Non-client area background color.
CXTPPaintManagerColorGradient | m_clrBorder
Dark and light border colors.
- Protected Member Functions inherited from CXTPEditThemeDefault
virtual BOOL | DrawNcBordersDefault (CDC *pDC, CRect rcWnd, CXTPEdit *pEdit)
Called by the paint-manager to perform Windows default border drawing for the non-client area of the combobox.
- Protected Attributes inherited from CXTPEditThemeOfficeXP
CXTPPaintManagerColor | m_clrBorderHilite
Highlighted border color.
CXTPPaintManagerColor | m_clrBorderDisabled
Disabled border color.
- Protected Attributes inherited from CXTPEditTheme
BOOL | m_bFlatStyle
TRUE when drawing flat borders.
BOOL | m_bUseWinTheme
TRUE to use windows themes.
XTPControlTheme | m_nTheme
Specifies the Theme ID used by the paint manager.
CXTPWinThemeWrapper | m_winTheme
Windows theme wrapper.
- Protected Attributes inherited from CXTPControlTheme
XTPControlTheme | m_nTheme
Currently selected theme style index.

Detailed Description

CXTPEditThemeVisualStudio2012 is a class used to perform theme drawing tasks.

Constructor & Destructor Documentation

◆ CXTPEditThemeVisualStudio2012()

CXTPEditThemeVisualStudio2012 ( XTPControlTheme nTheme )

Constructs a CXTPEditThemeVisualStudio2012 object.

Parameters
nTheme New visual theme. Can be any of the values listed

Member Function Documentation

◆ RefreshMetrics()

virtual void RefreshMetrics ( CXTPEdit * pEdit )
virtual

This member function is called by the theme manager to refresh the visual styles used by each component's theme.

Parameters
pEdit Pointer to a CXTPEdit object.

Reimplemented from CXTPEditThemeOfficeXP.

The documentation for this class was generated from the following file:
  • XTPEditThemeVisualStudio2012.h


Toolkit Pro: CXTPEditThemeVisualStudio2015 Class Reference

Public Member Functions | List of all members
CXTPEditThemeVisualStudio2015 Class Reference

CXTPEditThemeVisualStudio2015 is a class used to perform theme drawing tasks. More...

Inheritance diagram for CXTPEditThemeVisualStudio2015:
[legend]

Public Member Functions

CXTPEditThemeVisualStudio2015 ()
Constructs a CXTPEditThemeVisualStudio2015 object.
virtual | ~CXTPEditThemeVisualStudio2015 ()
Destructor, handles cleanup and deallocation.
- Public Member Functions inherited from CXTPEditThemeOffice2013
CXTPEditThemeOffice2013 ()
Constructs a CXTPEditThemeOffice2013 object.
virtual | ~CXTPEditThemeOffice2013 ()
Destructor, handles cleanup and deallocation.
virtual void | RefreshMetrics (CXTPEdit *pEdit)
This member function is called by the theme manager to refresh the visual styles used by each component's theme.
- Public Member Functions inherited from CXTPEditThemeOfficeXP
CXTPEditThemeOfficeXP ()
Constructs a CXTPEditThemeOfficeXP object.
virtual | ~CXTPEditThemeOfficeXP ()
Destructor, handles cleanup and deallocation.
virtual void | DrawNcBorders (CDC *pDC, CRect rcWnd, CXTPEdit *pEdit)
This member function is called by the theme manager to draw non-client borders for the edit control.
virtual BOOL | AdjustBuddyRect (CWnd *pBuddy, CRect &rcUpDown, int nAlignment)
Called by the framework to adjust the size of the area to draw the buddy control borders on.
virtual void | DrawBuddyBorders (CWnd *pBuddy, CDC *pDC, CRect rc, int nAlignment, CXTPEdit *pEdit)
Called by the framework to draw the borders for the associated buddy window.
virtual BOOL | RedrawFocusedFrame () const
Called by the framework to redraw the focus rectangle for the edit control.
- Public Member Functions inherited from CXTPEditThemeOffice2000
CXTPEditThemeOffice2000 ()
Constructs a CXTPEditThemeOffice2000 object.
virtual | ~CXTPEditThemeOffice2000 ()
Destructor, handles cleanup and deallocation.
virtual BOOL | DrawBuddyBorders (CDC *pDC, CRect rc, int nAlignment, CXTPEdit *pEdit)
Called by the paint-manager to draw the borders for the associated buddy window.
- Public Member Functions inherited from CXTPEditThemeDefault
CXTPEditThemeDefault ()
Constructs a CXTPEditThemeDefault object.
virtual | ~CXTPEditThemeDefault ()
Destructor, handles cleanup and deallocation.
virtual void | DrawNcScrollBack (CDC *pDC, CRect rcWnd, CXTPEdit *pEdit)
Called by the framework to draw the non-client background for the combobox scrollbar area.
virtual CBrush * | CtlColor (CDC *pDC, UINT nCtlColor, CXTPEdit *pEdit)
Called by the framework to handle setting the text and background colors for the edit control.
- Public Member Functions inherited from CXTPEditTheme
CXTPEditTheme ()
Constructs a CXTPEditThemeDefault object.
virtual | ~CXTPEditTheme ()
Destructor, handles cleanup and deallocation.
virtual void | FillRect (CDC *pDC, int x, int y, int cx, int cy, CBrush *pBrush)
Called by the edit control to fill a rectangle using the brush specifed by pBrush.
virtual void | DrawFrame (CDC *pDC, CRect rc, int nSize, CBrush *pBrush)
Called by the edit control to draw a frame rectangle using the brush specified by pBrush.
virtual CBrush * | GetClientBrush (CDC *pDC, CXTPEdit *pEdit)
Call this member function to retrieve a pointer to the client background brush.
BOOL | IsFlatStyle () const
Call this member function to determine if the m_bFlatStyle flag has be set.
void | SetFlatStyle (BOOL bFlatStyle)
Call this member function to set a value for m_bFlatStyle.
XTPControlTheme | GetThemeID () const
Call this member function to get the style for the theme.
void | UseWinTheme (BOOL bUseWinTheme)
Call this member function to enable Windows themes for the edit control.
- Public Member Functions inherited from CXTPControlTheme
CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme | GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlTheme
static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPEditTheme
CXTPBrush | m_xtpBrushBack
Background brush color.
CXTPPaintManagerColor | m_clrBack
Background color.
CXTPPaintManagerColor | m_clrText
Text color.
CXTPPaintManagerColor | m_clrTextReadOnly
Read-only text color.
CXTPPaintManagerColor | m_clrBackNonClient
Non-client area background color.
CXTPPaintManagerColorGradient | m_clrBorder
Dark and light border colors.
- Protected Member Functions inherited from CXTPEditThemeDefault
virtual BOOL | DrawNcBordersDefault (CDC *pDC, CRect rcWnd, CXTPEdit *pEdit)
Called by the paint-manager to perform Windows default border drawing for the non-client area of the combobox.
- Protected Attributes inherited from CXTPEditThemeOfficeXP
CXTPPaintManagerColor | m_clrBorderHilite
Highlighted border color.
CXTPPaintManagerColor | m_clrBorderDisabled
Disabled border color.
- Protected Attributes inherited from CXTPEditTheme
BOOL | m_bFlatStyle
TRUE when drawing flat borders.
BOOL | m_bUseWinTheme
TRUE to use windows themes.
XTPControlTheme | m_nTheme
Specifies the Theme ID used by the paint manager.
CXTPWinThemeWrapper | m_winTheme
Windows theme wrapper.
- Protected Attributes inherited from CXTPControlTheme
XTPControlTheme | m_nTheme
Currently selected theme style index.

Detailed Description

CXTPEditThemeVisualStudio2015 is a class used to perform theme drawing tasks.

The documentation for this class was generated from the following file:
  • XTPEditThemeVisualStudio2015.h


Toolkit Pro: CXTPEditThemeVisualStudio2017 Class Reference

Public Member Functions | List of all members
CXTPEditThemeVisualStudio2017 Class Reference

CXTPEditThemeVisualStudio2017 is a class used to perform theme drawing tasks. More...

Inheritance diagram for CXTPEditThemeVisualStudio2017:
[legend]

Public Member Functions

CXTPEditThemeVisualStudio2017 ()
Constructs a CXTPEditThemeVisualStudio2017 object.
virtual | ~CXTPEditThemeVisualStudio2017 ()
Destructor, handles cleanup and deallocation.
- Public Member Functions inherited from CXTPEditThemeOffice2013
CXTPEditThemeOffice2013 ()
Constructs a CXTPEditThemeOffice2013 object.
virtual | ~CXTPEditThemeOffice2013 ()
Destructor, handles cleanup and deallocation.
virtual void | RefreshMetrics (CXTPEdit *pEdit)
This member function is called by the theme manager to refresh the visual styles used by each component's theme.
- Public Member Functions inherited from CXTPEditThemeOfficeXP
CXTPEditThemeOfficeXP ()
Constructs a CXTPEditThemeOfficeXP object.
virtual | ~CXTPEditThemeOfficeXP ()
Destructor, handles cleanup and deallocation.
virtual void | DrawNcBorders (CDC *pDC, CRect rcWnd, CXTPEdit *pEdit)
This member function is called by the theme manager to draw non-client borders for the edit control.
virtual BOOL | AdjustBuddyRect (CWnd *pBuddy, CRect &rcUpDown, int nAlignment)
Called by the framework to adjust the size of the area to draw the buddy control borders on.
virtual void | DrawBuddyBorders (CWnd *pBuddy, CDC *pDC, CRect rc, int nAlignment, CXTPEdit *pEdit)
Called by the framework to draw the borders for the associated buddy window.
virtual BOOL | RedrawFocusedFrame () const
Called by the framework to redraw the focus rectangle for the edit control.
- Public Member Functions inherited from CXTPEditThemeOffice2000
CXTPEditThemeOffice2000 ()
Constructs a CXTPEditThemeOffice2000 object.
virtual | ~CXTPEditThemeOffice2000 ()
Destructor, handles cleanup and deallocation.
virtual BOOL | DrawBuddyBorders (CDC *pDC, CRect rc, int nAlignment, CXTPEdit *pEdit)
Called by the paint-manager to draw the borders for the associated buddy window.
- Public Member Functions inherited from CXTPEditThemeDefault
CXTPEditThemeDefault ()
Constructs a CXTPEditThemeDefault object.
virtual | ~CXTPEditThemeDefault ()
Destructor, handles cleanup and deallocation.
virtual void | DrawNcScrollBack (CDC *pDC, CRect rcWnd, CXTPEdit *pEdit)
Called by the framework to draw the non-client background for the combobox scrollbar area.
virtual CBrush * | CtlColor (CDC *pDC, UINT nCtlColor, CXTPEdit *pEdit)
Called by the framework to handle setting the text and background colors for the edit control.
- Public Member Functions inherited from CXTPEditTheme
CXTPEditTheme ()
Constructs a CXTPEditThemeDefault object.
virtual | ~CXTPEditTheme ()
Destructor, handles cleanup and deallocation.
virtual void | FillRect (CDC *pDC, int x, int y, int cx, int cy, CBrush *pBrush)
Called by the edit control to fill a rectangle using the brush specifed by pBrush.
virtual void | DrawFrame (CDC *pDC, CRect rc, int nSize, CBrush *pBrush)
Called by the edit control to draw a frame rectangle using the brush specified by pBrush.
virtual CBrush * | GetClientBrush (CDC *pDC, CXTPEdit *pEdit)
Call this member function to retrieve a pointer to the client background brush.
BOOL | IsFlatStyle () const
Call this member function to determine if the m_bFlatStyle flag has be set.
void | SetFlatStyle (BOOL bFlatStyle)
Call this member function to set a value for m_bFlatStyle.
XTPControlTheme | GetThemeID () const
Call this member function to get the style for the theme.
void | UseWinTheme (BOOL bUseWinTheme)
Call this member function to enable Windows themes for the edit control.
- Public Member Functions inherited from CXTPControlTheme
CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme | GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlTheme
static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPEditTheme
CXTPBrush | m_xtpBrushBack
Background brush color.
CXTPPaintManagerColor | m_clrBack
Background color.
CXTPPaintManagerColor | m_clrText
Text color.
CXTPPaintManagerColor | m_clrTextReadOnly
Read-only text color.
CXTPPaintManagerColor | m_clrBackNonClient
Non-client area background color.
CXTPPaintManagerColorGradient | m_clrBorder
Dark and light border colors.
- Protected Member Functions inherited from CXTPEditThemeDefault
virtual BOOL | DrawNcBordersDefault (CDC *pDC, CRect rcWnd, CXTPEdit *pEdit)
Called by the paint-manager to perform Windows default border drawing for the non-client area of the combobox.
- Protected Attributes inherited from CXTPEditThemeOfficeXP
CXTPPaintManagerColor | m_clrBorderHilite
Highlighted border color.
CXTPPaintManagerColor | m_clrBorderDisabled
Disabled border color.
- Protected Attributes inherited from CXTPEditTheme
BOOL | m_bFlatStyle
TRUE when drawing flat borders.
BOOL | m_bUseWinTheme
TRUE to use windows themes.
XTPControlTheme | m_nTheme
Specifies the Theme ID used by the paint manager.
CXTPWinThemeWrapper | m_winTheme
Windows theme wrapper.
- Protected Attributes inherited from CXTPControlTheme
XTPControlTheme | m_nTheme
Currently selected theme style index.

Detailed Description

CXTPEditThemeVisualStudio2017 is a class used to perform theme drawing tasks.

The documentation for this class was generated from the following file:
  • XTPEditThemeVisualStudio2017.h


Toolkit Pro: CXTPEditThemeVisualStudio2019 Class Reference

Public Member Functions | List of all members
CXTPEditThemeVisualStudio2019 Class Reference

CXTPEditThemeVisualStudio2019 is a class used to perform theme drawing tasks. More...

Inheritance diagram for CXTPEditThemeVisualStudio2019:
[legend]

Public Member Functions

CXTPEditThemeVisualStudio2019 ()
Constructs a CXTPEditThemeVisualStudio2019 object.
virtual | ~CXTPEditThemeVisualStudio2019 ()
Destructor, handles cleanup and deallocation.
- Public Member Functions inherited from CXTPEditThemeOffice2013
CXTPEditThemeOffice2013 ()
Constructs a CXTPEditThemeOffice2013 object.
virtual | ~CXTPEditThemeOffice2013 ()
Destructor, handles cleanup and deallocation.
virtual void | RefreshMetrics (CXTPEdit *pEdit)
This member function is called by the theme manager to refresh the visual styles used by each component's theme.
- Public Member Functions inherited from CXTPEditThemeOfficeXP
CXTPEditThemeOfficeXP ()
Constructs a CXTPEditThemeOfficeXP object.
virtual | ~CXTPEditThemeOfficeXP ()
Destructor, handles cleanup and deallocation.
virtual void | DrawNcBorders (CDC *pDC, CRect rcWnd, CXTPEdit *pEdit)
This member function is called by the theme manager to draw non-client borders for the edit control.
virtual BOOL | AdjustBuddyRect (CWnd *pBuddy, CRect &rcUpDown, int nAlignment)
Called by the framework to adjust the size of the area to draw the buddy control borders on.
virtual void | DrawBuddyBorders (CWnd *pBuddy, CDC *pDC, CRect rc, int nAlignment, CXTPEdit *pEdit)
Called by the framework to draw the borders for the associated buddy window.
virtual BOOL | RedrawFocusedFrame () const
Called by the framework to redraw the focus rectangle for the edit control.
- Public Member Functions inherited from CXTPEditThemeOffice2000
CXTPEditThemeOffice2000 ()
Constructs a CXTPEditThemeOffice2000 object.
virtual | ~CXTPEditThemeOffice2000 ()
Destructor, handles cleanup and deallocation.
virtual BOOL | DrawBuddyBorders (CDC *pDC, CRect rc, int nAlignment, CXTPEdit *pEdit)
Called by the paint-manager to draw the borders for the associated buddy window.
- Public Member Functions inherited from CXTPEditThemeDefault
CXTPEditThemeDefault ()
Constructs a CXTPEditThemeDefault object.
virtual | ~CXTPEditThemeDefault ()
Destructor, handles cleanup and deallocation.
virtual void | DrawNcScrollBack (CDC *pDC, CRect rcWnd, CXTPEdit *pEdit)
Called by the framework to draw the non-client background for the combobox scrollbar area.
virtual CBrush * | CtlColor (CDC *pDC, UINT nCtlColor, CXTPEdit *pEdit)
Called by the framework to handle setting the text and background colors for the edit control.
- Public Member Functions inherited from CXTPEditTheme
CXTPEditTheme ()
Constructs a CXTPEditThemeDefault object.
virtual | ~CXTPEditTheme ()
Destructor, handles cleanup and deallocation.
virtual void | FillRect (CDC *pDC, int x, int y, int cx, int cy, CBrush *pBrush)
Called by the edit control to fill a rectangle using the brush specifed by pBrush.
virtual void | DrawFrame (CDC *pDC, CRect rc, int nSize, CBrush *pBrush)
Called by the edit control to draw a frame rectangle using the brush specified by pBrush.
virtual CBrush * | GetClientBrush (CDC *pDC, CXTPEdit *pEdit)
Call this member function to retrieve a pointer to the client background brush.
BOOL | IsFlatStyle () const
Call this member function to determine if the m_bFlatStyle flag has be set.
void | SetFlatStyle (BOOL bFlatStyle)
Call this member function to set a value for m_bFlatStyle.
XTPControlTheme | GetThemeID () const
Call this member function to get the style for the theme.
void | UseWinTheme (BOOL bUseWinTheme)
Call this member function to enable Windows themes for the edit control.
- Public Member Functions inherited from CXTPControlTheme
CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme | GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlTheme
static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPEditTheme
CXTPBrush | m_xtpBrushBack
Background brush color.
CXTPPaintManagerColor | m_clrBack
Background color.
CXTPPaintManagerColor | m_clrText
Text color.
CXTPPaintManagerColor | m_clrTextReadOnly
Read-only text color.
CXTPPaintManagerColor | m_clrBackNonClient
Non-client area background color.
CXTPPaintManagerColorGradient | m_clrBorder
Dark and light border colors.
- Protected Member Functions inherited from CXTPEditThemeDefault
virtual BOOL | DrawNcBordersDefault (CDC *pDC, CRect rcWnd, CXTPEdit *pEdit)
Called by the paint-manager to perform Windows default border drawing for the non-client area of the combobox.
- Protected Attributes inherited from CXTPEditThemeOfficeXP
CXTPPaintManagerColor | m_clrBorderHilite
Highlighted border color.
CXTPPaintManagerColor | m_clrBorderDisabled
Disabled border color.
- Protected Attributes inherited from CXTPEditTheme
BOOL | m_bFlatStyle
TRUE when drawing flat borders.
BOOL | m_bUseWinTheme
TRUE to use windows themes.
XTPControlTheme | m_nTheme
Specifies the Theme ID used by the paint manager.
CXTPWinThemeWrapper | m_winTheme
Windows theme wrapper.
- Protected Attributes inherited from CXTPControlTheme
XTPControlTheme | m_nTheme
Currently selected theme style index.

Detailed Description

CXTPEditThemeVisualStudio2019 is a class used to perform theme drawing tasks.

The documentation for this class was generated from the following file:
  • XTPEditThemeVisualStudio2019.h


Toolkit Pro: CXTPEditThemeVisualStudio2022 Class Reference

Public Member Functions | List of all members
CXTPEditThemeVisualStudio2022 Class Reference

CXTPEditThemeVisualStudio2022 is a class used to perform theme drawing tasks. More...

Inheritance diagram for CXTPEditThemeVisualStudio2022:
[legend]

Public Member Functions

CXTPEditThemeVisualStudio2022 ()
Constructs a CXTPEditThemeVisualStudio2022 object.
virtual | ~CXTPEditThemeVisualStudio2022 ()
Destructor, handles cleanup and deallocation.
- Public Member Functions inherited from CXTPEditThemeOffice2013
CXTPEditThemeOffice2013 ()
Constructs a CXTPEditThemeOffice2013 object.
virtual | ~CXTPEditThemeOffice2013 ()
Destructor, handles cleanup and deallocation.
virtual void | RefreshMetrics (CXTPEdit *pEdit)
This member function is called by the theme manager to refresh the visual styles used by each component's theme.
- Public Member Functions inherited from CXTPEditThemeOfficeXP
CXTPEditThemeOfficeXP ()
Constructs a CXTPEditThemeOfficeXP object.
virtual | ~CXTPEditThemeOfficeXP ()
Destructor, handles cleanup and deallocation.
virtual void | DrawNcBorders (CDC *pDC, CRect rcWnd, CXTPEdit *pEdit)
This member function is called by the theme manager to draw non-client borders for the edit control.
virtual BOOL | AdjustBuddyRect (CWnd *pBuddy, CRect &rcUpDown, int nAlignment)
Called by the framework to adjust the size of the area to draw the buddy control borders on.
virtual void | DrawBuddyBorders (CWnd *pBuddy, CDC *pDC, CRect rc, int nAlignment, CXTPEdit *pEdit)
Called by the framework to draw the borders for the associated buddy window.
virtual BOOL | RedrawFocusedFrame () const
Called by the framework to redraw the focus rectangle for the edit control.
- Public Member Functions inherited from CXTPEditThemeOffice2000
CXTPEditThemeOffice2000 ()
Constructs a CXTPEditThemeOffice2000 object.
virtual | ~CXTPEditThemeOffice2000 ()
Destructor, handles cleanup and deallocation.
virtual BOOL | DrawBuddyBorders (CDC *pDC, CRect rc, int nAlignment, CXTPEdit *pEdit)
Called by the paint-manager to draw the borders for the associated buddy window.
- Public Member Functions inherited from CXTPEditThemeDefault
CXTPEditThemeDefault ()
Constructs a CXTPEditThemeDefault object.
virtual | ~CXTPEditThemeDefault ()
Destructor, handles cleanup and deallocation.
virtual void | DrawNcScrollBack (CDC *pDC, CRect rcWnd, CXTPEdit *pEdit)
Called by the framework to draw the non-client background for the combobox scrollbar area.
virtual CBrush * | CtlColor (CDC *pDC, UINT nCtlColor, CXTPEdit *pEdit)
Called by the framework to handle setting the text and background colors for the edit control.
- Public Member Functions inherited from CXTPEditTheme
CXTPEditTheme ()
Constructs a CXTPEditThemeDefault object.
virtual | ~CXTPEditTheme ()
Destructor, handles cleanup and deallocation.
virtual void | FillRect (CDC *pDC, int x, int y, int cx, int cy, CBrush *pBrush)
Called by the edit control to fill a rectangle using the brush specifed by pBrush.
virtual void | DrawFrame (CDC *pDC, CRect rc, int nSize, CBrush *pBrush)
Called by the edit control to draw a frame rectangle using the brush specified by pBrush.
virtual CBrush * | GetClientBrush (CDC *pDC, CXTPEdit *pEdit)
Call this member function to retrieve a pointer to the client background brush.
BOOL | IsFlatStyle () const
Call this member function to determine if the m_bFlatStyle flag has be set.
void | SetFlatStyle (BOOL bFlatStyle)
Call this member function to set a value for m_bFlatStyle.
XTPControlTheme | GetThemeID () const
Call this member function to get the style for the theme.
void | UseWinTheme (BOOL bUseWinTheme)
Call this member function to enable Windows themes for the edit control.
- Public Member Functions inherited from CXTPControlTheme
CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme | GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlTheme
static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPEditTheme
CXTPBrush | m_xtpBrushBack
Background brush color.
CXTPPaintManagerColor | m_clrBack
Background color.
CXTPPaintManagerColor | m_clrText
Text color.
CXTPPaintManagerColor | m_clrTextReadOnly
Read-only text color.
CXTPPaintManagerColor | m_clrBackNonClient
Non-client area background color.
CXTPPaintManagerColorGradient | m_clrBorder
Dark and light border colors.
- Protected Member Functions inherited from CXTPEditThemeDefault
virtual BOOL | DrawNcBordersDefault (CDC *pDC, CRect rcWnd, CXTPEdit *pEdit)
Called by the paint-manager to perform Windows default border drawing for the non-client area of the combobox.
- Protected Attributes inherited from CXTPEditThemeOfficeXP
CXTPPaintManagerColor | m_clrBorderHilite
Highlighted border color.
CXTPPaintManagerColor | m_clrBorderDisabled
Disabled border color.
- Protected Attributes inherited from CXTPEditTheme
BOOL | m_bFlatStyle
TRUE when drawing flat borders.
BOOL | m_bUseWinTheme
TRUE to use windows themes.
XTPControlTheme | m_nTheme
Specifies the Theme ID used by the paint manager.
CXTPWinThemeWrapper | m_winTheme
Windows theme wrapper.
- Protected Attributes inherited from CXTPControlTheme
XTPControlTheme | m_nTheme
Currently selected theme style index.

Detailed Description

CXTPEditThemeVisualStudio2022 is a class used to perform theme drawing tasks.

The documentation for this class was generated from the following file:
  • XTPEditThemeVisualStudio2022.h


Toolkit Pro: CXTPEmptyRect Class Reference

Public Member Functions | List of all members
CXTPEmptyRect Class Reference

CXTPEmptyRect is a helper class used to instantiate an empty CRect object. More...

Public Member Functions

CXTPEmptyRect ()
Constructs a CXTPEmptyRect object used to instantiate an empty CRect object.

Detailed Description

CXTPEmptyRect is a helper class used to instantiate an empty CRect object.

The documentation for this class was generated from the following file:
  • XTPDrawHelpers.h


Toolkit Pro: CXTPEmptySize Class Reference

Public Member Functions | List of all members
CXTPEmptySize Class Reference

CXTPEmptySize is a helper class used to instantiate an empty CSize object. More...

Public Member Functions

CXTPEmptySize ()
Constructs a CXTPEmptySize object used to instantiate an empty CSize object.
void | SetSizeEmpty ()
Makes CXTPEmptySize a null size by setting all coordinates to zero.
const SIZE & | operator= (const SIZE &srcSize)
Assigns srcSize to CSize.

Detailed Description

CXTPEmptySize is a helper class used to instantiate an empty CSize object.

Member Function Documentation

◆ operator=()

const SIZE & operator= ( const SIZE & srcSize )

Assigns srcSize to CSize.

Parameters
srcSize Refers to a source size. Can be a SIZE or CSize.
Returns
Self reference.
The documentation for this class was generated from the following file:
  • XTPDrawHelpers.h


Toolkit Pro: CXTPExcelTabCtrl Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPExcelTabCtrl Class Reference

CXTPExcelTabCtrl is a CWnd derived class. More...

Public Member Functions

CXTPExcelTabCtrl ()
Constructs a CXTPExcelTabCtrl object.
virtual | ~CXTPExcelTabCtrl ()
Destroys a CXTPExcelTabCtrl object, handles cleanup and deallocation.
BOOL | SetTheme (XTPControlTheme eTheme)
Call this member to switch the visual theme of the control.
CXTPExcelTabCtrlTheme * GetTheme ()
Call this member function to get a pointer to the currently selected theme.
CTabItemArray & | GetTabItemArray ()
Call this member function to retrieve a reference to the tab item array.
LPCTSTR | GetItemText (int nIndex) const
This member function gets the text of a specific tab.
bool | SetItemText (int nIndex, LPCTSTR pszText)
This member function will set the text for a particular tab.
CWnd * | GetItemWindow (int nIndex) const
This member function gets a CWnd pointer to the window that is associated with a specific tab.
virtual void | SetTabFonts (CFont *pNormFont, CFont *pBoldFont)
This member function will set the fonts to be used by the tab control.
virtual int | InsertItem (int nItem, UINT nTextID, CWnd *pWndControl=NULL)
This member function will insert a tab into the flat tab control.
virtual int | InsertItem (int nItem, LPCTSTR lpszItem, CWnd *pWndControl=NULL)
This member function will insert a tab into the flat tab control.
virtual BOOL | DeleteItem (int nItem)
This member function will delete the tab specified by 'nItem' from the tab control.
virtual BOOL | DeleteAllItems ()
This member function will remove all tabs from the tab control.
virtual BOOL | GetItemRect (int nItem, LPRECT lpRect)
This member function will retrieve the size of the tab specified by 'nItem'.
virtual int | HitTest (TCHITTESTINFO *pHitTestInfo) const
Call this function to determine which tab, if any, is at the specified screen position.
virtual int | GetCurSel () const
Call this function to retrieve the currently selected tab in a flat tab control.
virtual int | SetCurSel (int nItem)
This member function selects a tab in a flat tab control.
virtual int | GetItemCount () const
Call this function to retrieve the number of tabs in the tab control.
virtual void | SetTipText (int nItem, LPCTSTR lpszTabTip)
This member function will set the tooltip for the tab specified by 'nItem'.
virtual CString | GetTipText (int nItem)
This member function will get the tooltip text associated with the tab specified by 'nItem'.
virtual void | Home ()
This member function will cause the tab control to reposition the tabs to the home position.
void | SetGripperPosition (int nPos, bool bPercent)
This member function changes the location of the sizing gripper.
int | GetGripperPosition () const
This member function gets the location of the sizing gripper in pixels relative to the left-hand side of the control.
void | SyncScrollBar ()
Synchronizes the scrollbar with the horizontal scroll position.
void | SetTabShadowColor (COLORREF crShadow)
This member function is called to set the shadow color for all tabs.
COLORREF | GetTabShadowColor () const
This member function gets an RGB value that represents the shadow color of the tab.
void | SetTabHighlightColor (COLORREF crHighlight)
This member function is called to set the highlight color for all tabs.
COLORREF | GetTabHighlightColor () const
This member function gets an RGB value that represents the highlight color of the tab.
void | SetTabBackColor (COLORREF crBack)
This member function is called to set the default background color for all tabs.
void | SetTabBackColor (int nIndex, COLORREF crBack)
This member function is called to set the default background color for the specified tab located at 'nIndex'.
COLORREF | GetTabBackColor () const
This member function gets an RGB value that represents the background color of the tab.
COLORREF | GetTabBackColor (int nIndex) const
This member function gets an RGB value that represents the background color of the tab.
void | SetTabTextColor (COLORREF crText)
This member function is called to set the default text color for all tabs.
void | SetTabTextColor (int nIndex, COLORREF crText)
This member function is called to set the default text color for all tabs.
COLORREF | GetTabTextColor () const
This member function gets an RGB value that represents the text color of the tab.
COLORREF | GetTabTextColor (int nIndex) const
This member function gets an RGB value that represents the text color of the tab.
void | SetSelTabBackColor (COLORREF crBack)
This member function is called to set the selected background color for all tabs.
void | SetSelTabBackColor (int nIndex, COLORREF crBack)
This member function is called to set the selected background color for all tabs.
COLORREF | GetSelTabBackColor () const
This member function gets an RGB value that represents the background color for selected tabs.
COLORREF | GetSelTabBackColor (int nIndex) const
This member function gets an RGB value that represents the background color for selected tabs.
void | SetSelTabTextColor (COLORREF crText)
This member function is called to set the selected text color for all tabs.
void | SetSelTabTextColor (int nIndex, COLORREF crText)
This member function is called to set the selected text color for all tabs.
COLORREF | GetSelTabTextColor () const
This member function gets an RGB value that represents the text color for selected tabs.
COLORREF | GetSelTabTextColor (int nIndex) const
This member function gets an RGB value that represents the text color for selected tabs.
void | UpdateDefaultColors ()
Call this member function to reset the tab control to use default system colors.
virtual CScrollBar * | GetScrollBarCtrl (int nBar) const
This method obtains a pointer to the specified sibling scrollbar for the flat tab control.
CRect | GetTabsRect ()
Retrieves the area occupied by the tabs.
CFont * | GetTabFont (BOOL bBold)
Retrieves the tab font.
DWORD | GetTabStyle ()
Retrieves the FTS_XTP_ styles that are currently in use for the flat tab control.
void | SetTabStyle (DWORD dwStyle)
Sets the FTS_XTP_ styles for a flat tab control.
virtual BOOL | Create (DWORD dwStyle, const CRect &rect, CWnd *pParentWnd, UINT nID)
Creates a flat tab control and attaches it to an instance of a CXTPExcelTabCtrl object.
void | SetTabHeight (int iTabHeight)
Call this member function to set the height for the tab control.
int | GetTabHeight () const
Call this member function to retrieve the current height in pixels for the tab control.

Protected Member Functions

virtual int | ButtonHitTest (CPoint &pt)
Call this function to determine which button, if any, is at the specified screen position.
int | GetTabWidth (int nItem) const
This member function will get the width in pixels of the tab specified by 'nItem'.
int | GetTotalTabWidth () const
This member function will calculate the total width of all the tabs in the flat tab control.
int | GetTotalArrowWidth () const
This member function will calculate the total width of all the arrow buttons that are visible in the flat tab control.
int | GetTotalTabAreaWidth () const
This member function will calculate the total area width of all the tabs in the flat tab control.
void | InvalidateTabs ()
This member function will force all of the tabs to be repainted.
void | EnableButtons ()
This member function will enable/disable the arrow buttons depending on the current tab display state.
void | FreeButtonIcons ()
This member function will free the resources allocated for the icons used by the arrow buttons.
void | CreateButtonIcons ()
This member function will create the icon resources that are used by the arrow buttons.
void | DrawGripper (CDC *pDC, CRect rect) const
This member function will draw the horizontal sizing gripper at a specified location.
void | SetTracking (bool bTracking)
The member function is used internally to toggle the state of the sizing-grip tracking mode.
void | ClearAllItems ()
This member function frees all memory occupied by the tab items.
virtual void | RecalcLayout ()
This member function is called when the tab control is resized.
virtual BOOL | _DeleteItem (int nItem)
This internal function deletes an item from the tab item list.
virtual int | GetOverlap () const
This internal function calculates the overlap between two tabs.
void | ResetMouseOver ()
Call this member function to remove the highlight from all of the buttons.
CRect | GetTotalButtonRect () const
Call this member function to get the dimensions of the rectangle that encompasses all of the buttons.
virtual BOOL | Init ()
This member function is called by the CXTPExcelTabCtrl class to perform initialization when the window is created or sub-classed.
virtual void | RefreshMetrics ()
Call this member function to refresh theme colors and redraw the control.

Protected Attributes

int | m_cx
Width for each arrow button.
int | m_cy
Height for each arrow button.
int | m_nCurSel
Index of the currently selected tab.
int | m_nClientWidth
Width in pixels of the tab control client area.
int | m_nClientHeight
Height in pixels of the tab control client area.
int | m_nOffset
Amount in pixels of the displayed tab offset.
int | m_xGripperPos
The current gripper position in pixels from the left.
int | m_iGripperPosPerCent
The current gripper position in percent of the control width.
int | m_xTrackingDelta
Tracking delta.
int | m_iBtnLeft
Index of "left" button in button array.
int | m_iBtnRight
Index of "right" button in button array.
int | m_iBtnHome
Index of "home" button in button array.
int | m_iBtnEnd
Index of "end" button in button array.
int | m_iBtnHilight
Index of the button that has the mouse hovering over it.
int | m_iTabHeight
Max height in pixels for the tab control.
bool | m_bTracking
Tracking state.
bool | m_bManagingViews
true if the control is managing views.
bool | m_bUserColors
true if user defined colors are used.
bool | m_bPainted
Set to TRUE to indicate that a button has been painted.
DWORD | m_dwStyle
Tab control style.
CWnd * | m_pWndLastFocus
Last focused window.
CRect | m_rectTabs
Area occupied by tabs.
CRect | m_rectViews
Area occupied by managed views.
CRect | m_rectSB_H
Area occupied by the horizontal scrollbar.
CRect | m_rectGripper
Area occupied by the sizing gripper.
CFont * | m_pNormFont
Font that is used for non-selected tabs.
CFont * | m_pBoldFont
Font that is used for selected tabs.
CXTPScrollBar | m_wndHScrollBar
The horizontal scrollbar (used with FTS_XTP_HSCROLL).
CToolTipCtrl | m_ToolTip
Tooltip for the flat tab control.
CXTPExcelTabCtrlButtonState | m_buttons [4]
Array of button information.
CTabItemArray | m_tcbItems
Template list containing tab information.
CXTPExcelTabCtrlTheme * | m_pTheme
Pointer to the current theme object.
BOOL | m_bSubclassed
TRUE if the window was sub-classed.

Detailed Description

CXTPExcelTabCtrl is a CWnd derived class.

It is used to create an Excel style sheet control. This control allows you to define if you want the control to have home, end, back, and next buttons.

Member Function Documentation

◆ _DeleteItem()

virtual BOOL _DeleteItem ( int nItem )
protectedvirtual

This internal function deletes an item from the tab item list.

Parameters
nItem Index of the tab to delete.
Returns
TRUE if successful, otherwise FALSE.

◆ ButtonHitTest()

virtual int ButtonHitTest ( CPoint & pt )
protectedvirtual

Call this function to determine which button, if any, is at the specified screen position.

Parameters
pt A CPoint reference representing the specified screen position.
Returns
The zero-based index of the button within the button's array, or -1 if no button is at the specified position.

◆ Create()

virtual BOOL Create | ( | DWORD | dwStyle,
 |  | const CRect & | rect,
 |  | CWnd * | pParentWnd,
 |  | UINT | nID )
 virtual

Creates a flat tab control and attaches it to an instance of a CXTPExcelTabCtrl object.

Parameters
dwStyle | Specifies the tab control's style. Apply any combination of tab control styles mentioned below in the Remarks section.
rect | Specifies the tab control's size and position. It can be either a CRect object or a RECT structure.
pParentWnd | Specifies the tab control's parent window, usually a CDialog. It must not be NULL.
nID | Specifies the tab control's ID.
Returns
TRUE if initialization of the object was successful, otherwise FALSE.

You construct a CXTPExcelTabCtrl object in two steps. First, call the constructor, and then call Create, which creates the tab control and attaches it to the CXTPExcelTabCtrl object. You can use the following tab control styles when creating the object:

FTS_XTP_BOTTOM: Show tabs on bottom. FTS_XTP_HASARROWS: Show back and next arrows. FTS_XTP_HASHOMEEND: Show home and end arrows. Used with FTS_XTP_HASARROWS. FTS_XTP_TOOLTIPS: Show tab tooltips. FTS_XTP_DEFAULT: Same as (FTS_XTP_BOTTOM | FTS_XTP_HASARROWS | FTS_XTP_HASHOMEEND | FTS_XTP_TOOLTIPS). FTS_XTP_HSCROLL: Show a horizontal scrollbar. FTS_XTP_SQUARETABS: Shows square tabs instead of angled tabs. FTS_XTP_MASK: Combines all FTS_ styles.

In addition to tab control styles, you can apply the following window styles to a tab control:

WS_CHILD: Creates a child window that represents the tab control. Cannot be used with the WS_POPUP style. WS_VISIBLE: Creates a tab control that is initially visible. WS_DISABLED: Creates a window that is initially disabled. WS_GROUP: Specifies the first control of a group of controls in which the user can move from one control to the next with the arrow keys. All controls defined with the WS_GROUP style after the first control belong to the same group. The next control with the WS_GROUP style ends the style group and starts the next group (that is, one group ends where the next begins). WS_TABSTOP: Specifies one of any number of controls through which the user can move by using the TAB key. The TAB key moves the user to the next control specified by the WS_TABSTOP style. Example: The following code sample demonstrates the usage of Create.

// Create  the flat tab control.
if (!m_wndFlatTabCtrl.Create(WS_CHILD | WS_VISIBLE | FTS_XTP_DEFAULT,
   m_rcTabs, this, IDC_FLAT_TABCTRL))
{
   TRACE0("Failed to create flattab control\n");
   return;
}

CreateViews();

// Insert tabs into the flat tab control.
m_wndFlatTabCtrl.InsertItem(0, _T("Build"),           &m_sheet1);
m_wndFlatTabCtrl.InsertItem(1, _T("Debug"),           &m_sheet2);
m_wndFlatTabCtrl.InsertItem(2, _T("Find in Files 1"), &m_sheet3);
m_wndFlatTabCtrl.InsertItem(3, _T("Find in Files 2"), &m_sheet4);
m_wndFlatTabCtrl.InsertItem(4, _T("Results"),         &m_sheet5);
m_wndFlatTabCtrl.InsertItem(5, _T("SQL Debugging"),   &m_sheet6);
m_wndFlatTabCtrl.InsertItem(6, _T("Form View"),       m_pSheet7);
See also
GetTabStyle, SetTabStyle

◆ DeleteAllItems()

virtual BOOL DeleteAllItems ( )
virtual

This member function will remove all tabs from the tab control.

Returns
TRUE if successful, otherwise FALSE.

◆ DeleteItem()

virtual BOOL DeleteItem ( int nItem )
virtual

This member function will delete the tab specified by 'nItem' from the tab control.

Parameters
nItem Index of the tab to delete.
Returns
TRUE if successful, otherwise FALSE.

◆ DrawGripper()

void DrawGripper | ( | CDC * | pDC,
 |  | CRect | rect ) const
 protected

This member function will draw the horizontal sizing gripper at a specified location.

Parameters
pDC | Pointer to the device context to draw the gripper to.
rect | Location of the gripper.

◆ GetCurSel()

virtual int GetCurSel ( ) const
virtual

Call this function to retrieve the currently selected tab in a flat tab control.

Returns
The zero-based index of the selected tab if successful, or -1 if no tab is selected.

◆ GetGripperPosition()

int GetGripperPosition ( ) const

This member function gets the location of the sizing gripper in pixels relative to the left-hand side of the control.

Returns
An integer value representing the location of the sizing gripper in pixels relative to the left hand side of the control.

◆ GetItemCount()

virtual int GetItemCount ( ) const
virtual

Call this function to retrieve the number of tabs in the tab control.

Returns
The number of tabs in the tab control.

◆ GetItemRect()

virtual BOOL GetItemRect | ( | int | nItem,
 |  | LPRECT | lpRect )
 virtual

This member function will retrieve the size of the tab specified by 'nItem'.

Parameters
nItem | Index of the tab to retrieve the size of.
lpRect | Pointer to a RECT structure to receive the size of the tab.
Returns
TRUE if successful, otherwise FALSE.

◆ GetItemText()

LPCTSTR GetItemText ( int nIndex ) const

This member function gets the text of a specific tab.

Parameters
nIndex The index of the tab whose text is to be retrieved.
Returns
The text of a particular tab, or NULL if an error occurs.

◆ GetItemWindow()

CWnd * GetItemWindow ( int nIndex ) const

This member function gets a CWnd pointer to the window that is associated with a specific tab.

Parameters
nIndex The index of the tab whose managed window is to be retrieved.
Returns
A pointer to the window that is associated with a tab, or NULL if no window is associated with (managed by) the tab.

◆ GetOverlap()

virtual int GetOverlap ( ) const
protectedvirtual

This internal function calculates the overlap between two tabs.

Returns
An integer value that represents the overlap between the tabs.

◆ GetScrollBarCtrl()

virtual CScrollBar * GetScrollBarCtrl ( int nBar ) const
virtual

This method obtains a pointer to the specified sibling scrollbar for the flat tab control.

Parameters
nBar Specifies the type of scrollbar. The parameter can take one of the values specified in the Remarks section.

The scrollbar type can be one of the following values: SB_HORZ: Retrieves the position of the horizontal scrollbar. SB_VERT: Retrieves the position of the vertical scrollbar.

Returns
Returns a pointer to the specified sibling scrollbar

◆ GetSelTabBackColor() [1/2]

COLORREF GetSelTabBackColor ( ) const

This member function gets an RGB value that represents the background color for selected tabs.

Returns
An RGB value that represents the selected tabs background color if successful, otherwise COLORREF_NULL.

◆ GetSelTabBackColor() [2/2]

COLORREF GetSelTabBackColor ( int nIndex ) const

This member function gets an RGB value that represents the background color for selected tabs.

Parameters
nIndex The index of the tab to get the selected background color for.
Returns
An RGB value that represents the selected tabs background color if successful, otherwise COLORREF_NULL.

◆ GetSelTabTextColor() [1/2]

COLORREF GetSelTabTextColor ( ) const

This member function gets an RGB value that represents the text color for selected tabs.

Returns
An RGB value that represents the selected tab text color if successful, otherwise COLORREF_NULL.

◆ GetSelTabTextColor() [2/2]

COLORREF GetSelTabTextColor ( int nIndex ) const

This member function gets an RGB value that represents the text color for selected tabs.

Parameters
nIndex The index of the tab to get selected text color for.
Returns
An RGB value that represents the selected tab text color if successful, otherwise COLORREF_NULL.

◆ GetTabBackColor() [1/2]

COLORREF GetTabBackColor ( ) const

This member function gets an RGB value that represents the background color of the tab.

Returns
An RGB value that represents the tab background color if successful, otherwise COLORREF_NULL.

◆ GetTabBackColor() [2/2]

COLORREF GetTabBackColor ( int nIndex ) const

This member function gets an RGB value that represents the background color of the tab.

Parameters
nIndex The index of the tab to get the background color for.
Returns
An RGB value that represents the tab background color if successful, otherwise COLORREF_NULL.

◆ GetTabFont()

CFont * GetTabFont ( BOOL bBold )

Retrieves the tab font.

Parameters
bBold TRUE to retrieve the bold font.

Call this member function to return a pointer to the font used to display the tab item label for the tab control.

Returns
A pointer to a CFont object.

◆ GetTabHeight()

int GetTabHeight ( ) const

Call this member function to retrieve the current height in pixels for the tab control.

Returns
The height in pixels for the tab control.

◆ GetTabHighlightColor()

COLORREF GetTabHighlightColor ( ) const

This member function gets an RGB value that represents the highlight color of the tab.

Returns
An RGB value that represents the tab highlight color.

◆ GetTabItemArray()

CTabItemArray & GetTabItemArray ( )
inline

Call this member function to retrieve a reference to the tab item array.

Returns
A reference to a CTabItemArray object used for maintaining the list of tabs for the tab control.

◆ GetTabShadowColor()

COLORREF GetTabShadowColor ( ) const

This member function gets an RGB value that represents the shadow color of the tab.

Returns
An RGB value that represents the tab shadow color.

◆ GetTabsRect()

CRect GetTabsRect ( )

Retrieves the area occupied by the tabs.

This member function is called to retrieve the size and location of the area that is occupied by the tab items.

Returns
A CRect object representing the tab item area.

◆ GetTabStyle()

DWORD GetTabStyle ( )

Retrieves the FTS_XTP_ styles that are currently in use for the flat tab control.

Returns
A DWORD value that represents the FTS_XTP_ styles currently in use for the flat tab control.

This value is a combination of tab control FTS_XTP_ styles. See the CXTPExcelTabCtrl::Create method for a list of available styles.

See also
Create, SetTabStyle

◆ GetTabTextColor() [1/2]

COLORREF GetTabTextColor ( ) const

This member function gets an RGB value that represents the text color of the tab.

Returns
An RGB value that represents the tab text color if successful, otherwise COLORREF_NULL.

◆ GetTabTextColor() [2/2]

COLORREF GetTabTextColor ( int nIndex ) const

This member function gets an RGB value that represents the text color of the tab.

Parameters
nIndex The index of the tab to get text color for.
Returns
An RGB value that represents the tab text color if successful, otherwise COLORREF_NULL.

◆ GetTabWidth()

int GetTabWidth ( int nItem ) const
protected

This member function will get the width in pixels of the tab specified by 'nItem'.

Parameters
nItem The zero-based index of the tab to retrieve the width for.
Returns
The width in pixels of the tab.

◆ GetTheme()

CXTPExcelTabCtrlTheme * GetTheme ( )

Call this member function to get a pointer to the currently selected theme.

Returns
A pointer to a CXTPExcelTabCtrlTheme object representing the currently selected theme.

◆ GetTipText()

virtual CString GetTipText ( int nItem )
virtual

This member function will get the tooltip text associated with the tab specified by 'nItem'.

Parameters
nItem The zero-based index of the tab to retrieve the tooltip text for.
Returns
A CString object containing the text to be used in the tooltip.

◆ GetTotalArrowWidth()

int GetTotalArrowWidth ( ) const
protected

This member function will calculate the total width of all the arrow buttons that are visible in the flat tab control.

Returns
The total width in pixels of all the visible arrow buttons.

◆ GetTotalButtonRect()

CRect GetTotalButtonRect ( ) const
protected

Call this member function to get the dimensions of the rectangle that encompasses all of the buttons.

Returns
Gets the dimensions of the rectangle that encompasses all of the buttons

◆ GetTotalTabAreaWidth()

int GetTotalTabAreaWidth ( ) const
protected

This member function will calculate the total area width of all the tabs in the flat tab control.

Returns
The total area width in pixels of all the tabs in the flat tab control.

◆ GetTotalTabWidth()

int GetTotalTabWidth ( ) const
protected

This member function will calculate the total width of all the tabs in the flat tab control.

Returns
The total combined width in pixels of all the tabs in the control.

◆ HitTest()

virtual int HitTest ( TCHITTESTINFO * pHitTestInfo ) const
virtual

Call this function to determine which tab, if any, is at the specified screen position.

Parameters
pHitTestInfo Pointer to a TCHITTESTINFO structure, as described in the Platform SDK, which specifies the screen position to test.
Returns
The zero-based index of the tab, or -1 if no tab is at the specified position.

◆ Init()

virtual BOOL Init ( )
protectedvirtual

This member function is called by the CXTPExcelTabCtrl class to perform initialization when the window is created or sub-classed.

Returns
TRUE if the window was successfully initialized, otherwise FALSE.

◆ InsertItem() [1/2]

virtual int InsertItem | ( | int | nItem,
 |  | LPCTSTR | lpszItem,
 |  | CWnd * | pWndControl = NULL )
 virtual

This member function will insert a tab into the flat tab control.

Parameters
nItem | Index of the tab to insert.
lpszItem | A NULL-terminated string that represents the tab label.
pWndControl | Optional pointer to the managed control.
Returns
The index of the tab that has been inserted if successful, otherwise -1.

◆ InsertItem() [2/2]

virtual int InsertItem | ( | int | nItem,
 |  | UINT | nTextID,
 |  | CWnd * | pWndControl = NULL )
 virtual

This member function will insert a tab into the flat tab control.

Parameters
nItem | Index of the tab to insert.
nTextID | String resource ID of the tab label.
pWndControl | Optional pointer to the managed control.
Returns
The index of the tab that has been inserted if successful, otherwise -1.

◆ RecalcLayout()

virtual void RecalcLayout ( )
protectedvirtual

This member function is called when the tab control is resized.

It is responsible for updating internal structures that are dependent on the control's size.

◆ SetCurSel()

virtual int SetCurSel ( int nItem )
virtual

This member function selects a tab in a flat tab control.

Parameters
nItem The zero-based index of the item to be selected.
Returns
The zero-based index of the previously selected tab if successful, otherwise -1.

◆ SetGripperPosition()

void SetGripperPosition | ( | int | nPos,
 |  | bool | bPercent )

This member function changes the location of the sizing gripper.

The function has no effect if FTS_XTP_HSCROLL is not used.

Parameters
nPos | The position for the gripper, relative to the left-hand side of the control.
bPercent | Indicates that the position is a percent of the control width, as opposed to an absolute location in pixels.

◆ SetItemText()

bool SetItemText | ( | int | nIndex,
 |  | LPCTSTR | pszText )

This member function will set the text for a particular tab.

Parameters
nIndex | The index of the tab whose text is to be changed.
pszText | The new title for the tab.
Returns
true if successful, otherwise false.

◆ SetSelTabBackColor() [1/2]

void SetSelTabBackColor ( COLORREF crBack )

This member function is called to set the selected background color for all tabs.

If nIndex is specified, then the color is only set for the tab located at 'nIndex'.

Parameters
crBack An RGB value that represents the selected tab background color.

◆ SetSelTabBackColor() [2/2]

void SetSelTabBackColor | ( | int | nIndex,
 |  | COLORREF | crBack )

This member function is called to set the selected background color for all tabs.

If nIndex is specified, then the color is only set for the tab located at 'nIndex'.

Parameters
nIndex | The index of the tab to set the selected background color for.
crBack | An RGB value that represents the selected tab background color.

◆ SetSelTabTextColor() [1/2]

void SetSelTabTextColor ( COLORREF crText )

This member function is called to set the selected text color for all tabs.

If nIndex is specified, then the color is only set for the tab located at 'nIndex'.

Parameters
crText An RGB value that represents the selected tab text color.

◆ SetSelTabTextColor() [2/2]

void SetSelTabTextColor | ( | int | nIndex,
 |  | COLORREF | crText )

This member function is called to set the selected text color for all tabs.

If nIndex is specified, then the color is only set for the tab located at 'nIndex'.

Parameters
nIndex | The index of the tab to set the selected text color for.
crText | An RGB value that represents the selected tab text color.

◆ SetTabBackColor() [1/2]

void SetTabBackColor ( COLORREF crBack )

This member function is called to set the default background color for all tabs.

Parameters
crBack An RGB value that represents the tab background color.

◆ SetTabBackColor() [2/2]

void SetTabBackColor | ( | int | nIndex,
 |  | COLORREF | crBack )

This member function is called to set the default background color for the specified tab located at 'nIndex'.

Parameters
nIndex | The index of the tab to set the background color for.
crBack | An RGB value that represents the tab background color.

◆ SetTabFonts()

virtual void SetTabFonts | ( | CFont * | pNormFont,
 |  | CFont * | pBoldFont )
 virtual

This member function will set the fonts to be used by the tab control.

Parameters
pNormFont | Represents the font used by non-selected tabs.
pBoldFont | Represents the font used by selected tabs.

◆ SetTabHeight()

void SetTabHeight ( int iTabHeight )

Call this member function to set the height for the tab control.

Parameters
iTabHeight Size in pixels for the tab control. Minimum height must be no smaller than the size returned from GetSystemMetrics(SM_CYHSCROLL).

◆ SetTabHighlightColor()

void SetTabHighlightColor ( COLORREF crHighlight )

This member function is called to set the highlight color for all tabs.

Parameters
crHighlight An RGB value that represents the tab highlight color.

◆ SetTabShadowColor()

void SetTabShadowColor ( COLORREF crShadow )

This member function is called to set the shadow color for all tabs.

Parameters
crShadow An RGB value that represents the tab shadow color.

◆ SetTabStyle()

void SetTabStyle ( DWORD dwStyle )

Sets the FTS_XTP_ styles for a flat tab control.

Parameters
dwStyle Value specifying a combination of flat tab control FTS_XTP_ styles.

The dwStyle parameter allows you to set one or more FTS_XTP_ styles. See the CXTPExcelTabCtrl::Create method for a list of available styles.

See also
Create, GetTabStyle

◆ SetTabTextColor() [1/2]

void SetTabTextColor ( COLORREF crText )

This member function is called to set the default text color for all tabs.

If nIndex is specified, then the color is only set for the tab located at 'nIndex'.

Parameters
crText An RGB value that represents the tab text color.

◆ SetTabTextColor() [2/2]

void SetTabTextColor | ( | int | nIndex,
 |  | COLORREF | crText )

This member function is called to set the default text color for all tabs.

If nIndex is specified, then the color is only set for the tab located at 'nIndex'.

Parameters
nIndex | The index of the tab to set the text color for.
crText | An RGB value that represents the tab text color.

◆ SetTheme()

BOOL SetTheme ( XTPControlTheme eTheme )

Call this member to switch the visual theme of the control.

Parameters
eTheme New visual theme. Can be any of the values listed in the Remarks section.

nStyle can be one of the following: xtpControlThemeDefault: Use default theme. xtpControlThemeOfficeXP: Use Office XP theme. xtpControlThemeOffice2003: Use Office 2003 theme.

Returns
TRUE if successful, otherwise FALSE.

◆ SetTipText()

virtual void SetTipText | ( | int | nItem,
 |  | LPCTSTR | lpszTabTip )
 virtual

This member function will set the tooltip for the tab specified by 'nItem'.

Parameters
nItem | The zero-based index of the tab to receive the tooltip text.
lpszTabTip | A pointer to a string containing the tooltip text.

◆ SetTracking()

void SetTracking ( bool bTracking )
protected

The member function is used internally to toggle the state of the sizing-grip tracking mode.

Parameters
bTracking true to enable tracking, false to disable.

◆ SyncScrollBar()

void SyncScrollBar ( )

Synchronizes the scrollbar with the horizontal scroll position.

Call this function to synchronize the tab control's horizontal scrollbar with the horizontal scrollbar of the current view.

This function should be called if anything happens in the view that affects the horizontal scroll bar (e.g., a user typing text into an edit control could make the text wider, thus requiring a call to this function).

Member Data Documentation

◆ m_bPainted

bool m_bPainted
protected

Set to TRUE to indicate that a button has been painted.

FALSE otherwise.

The documentation for this class was generated from the following file:
  • XTPExcelTabCtrl.h


Toolkit Pro: CXTPExcelTabCtrlButtonState Class Reference

Public Member Functions | Public Attributes | List of all members
CXTPExcelTabCtrlButtonState Class Reference

The CXTPExcelTabCtrlButtonState class is used by the CXTPExcelTabCtrl class to manage navigation button information. More...

Public Member Functions

CXTPExcelTabCtrlButtonState ()
Constructs a CXTPExcelTabCtrlButtonState object.
void SetInfo (CRect rect, int iCommand, XTPArrowIcon iconType)
This member function is called to initialize the information about the tab control navigation button.

Public Attributes

int | m_iCommand
Button command ID.
bool | m_bPressed
true if the button is pressed.
bool | m_bEnabled
true if the button is enabled.
bool | m_bHilight
true if the mouse if hovering.
CRect | m_rect
Size and location of the button.
XTPArrowIcon | m_IconType
Icon style of the button.

Detailed Description

The CXTPExcelTabCtrlButtonState class is used by the CXTPExcelTabCtrl class to manage navigation button information.

This class contains information about the state and command identifiers for the button.

Member Function Documentation

◆ SetInfo()

void SetInfo | ( | CRect | rect,
 |  | int | iCommand,
 |  | XTPArrowIcon | iconType )

This member function is called to initialize the information about the tab control navigation button.

Parameters
rect | Size and location of the button.
iCommand | Command ID for the button.
iconType | Icon style of the button.
The documentation for this class was generated from the following file:
  • XTPExcelTabCtrl.h


Toolkit Pro: CXTPExcelTabCtrlTheme Class Reference

Public Member Functions | Public Attributes | List of all members
CXTPExcelTabCtrlTheme Class Reference

CXTPExcelTabCtrlTheme is used to draw the CXTPExcelTabCtrl object. More...

Inheritance diagram for CXTPExcelTabCtrlTheme:
[legend]

Public Member Functions

CXTPExcelTabCtrlTheme ()
Constructs a CXTPExcelTabCtrlTheme object.
~CXTPExcelTabCtrlTheme ()
Destroys a CXTPExcelTabCtrlTheme object, handles cleanup and deallocation.
virtual void | RefreshMetrics (CXTPExcelTabCtrl *pTab)
Call this function to refresh the flat tab control colors, position any scroll bars to their default positions, and then reset the control to the system defaults.
virtual int | DrawTab (CDC *pDC, CXTPExcelTabCtrl *pTabCtrl, const CPoint &pt, bool bSelected, CXTPTcbItem *pTcbItem)
This member function will draw a tab to the device context specified by 'pDC'.
virtual void | DrawButton (CDC *pDC, CXTPExcelTabCtrl *pTabCtrl, const CXTPExcelTabCtrlButtonState &state)
This member function is used by the flat tab control to draw an arrow button to the device context specified by 'pDC'.
virtual void | DrawButtonBack (CDC *pDC, CRect &rect, const CXTPExcelTabCtrlButtonState &state)
Call this member function to draw the background of the button.
virtual void | FillBackground (CDC *pDC, CRect &rect, BOOL bBottom)
This member function is called to fill the background area for the tab control.
virtual void | FillTabsBackground (CDC *pDC, int cx, int cy)
This member function is called to fill the background area that is occupied by the tab strip.
virtual void | DrawGripper (CDC *pDC, CRect rect)
This member function will draw the horizontal sizing gripper at a specified location.
virtual COLORREF | GetTabBackColor (CXTPTcbItem *pTcbItem) const
This member function gets an RGB value that represents the background color of the tab.
virtual COLORREF | GetTabTextColor (CXTPTcbItem *pTcbItem) const
This member function gets an RGB value that represents the text color of the tab.
virtual COLORREF | GetSelTabBackColor (CXTPTcbItem *pTcbItem) const
This member function gets an RGB value that represents the background color for selected tabs.
virtual COLORREF | GetSelTabTextColor (CXTPTcbItem *pTcbItem) const
This member function gets an RGB value that represents the text color for selected tabs.
- Public Member Functions inherited from CXTPControlTheme
CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme | GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Public Attributes

CXTPPaintManagerColor | m_clr3DFace
An RGB value that represents the normal tab face color.
CXTPPaintManagerColor | m_clr3DFacePushed
An RGB value for pushed background color.
CXTPPaintManagerColor | m_clr3DFaceHilite
An RGB value for highlighted background color.
CXTPPaintManagerColor | m_clrBtnText
An RGB value that represents the tab outline color.
CXTPPaintManagerColor | m_clrBtnTextGray
An RGB value for disabled text color.
CXTPPaintManagerColor | m_clrBtnTextPushed
An RGB value for highlighted text color.
CXTPPaintManagerColor | m_clrBtnTextHilite
An RGB value for pushed text color.
CXTPPaintManagerColor | m_clrWindow
An RGB value that represents the selected tab face color.
CXTPPaintManagerColor | m_clrWindowText
An RGB value that represents the tab text color.
CXTPPaintManagerColor | m_clr3DHilight
An RGB value that represents the tab highlight color.
CXTPPaintManagerColor | m_clr3DShadow
An RGB value that represents the tab shadow color.
CXTPPaintManagerColor | m_clrBorder3DHilite
An RGB value for 3D border highlight color.
CXTPPaintManagerColor | m_clrBorder3DShadow
An RGB value for 3D border shadow color.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlTheme
static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Attributes inherited from CXTPControlTheme
XTPControlTheme | m_nTheme
Currently selected theme style index.

Detailed Description

CXTPExcelTabCtrlTheme is used to draw the CXTPExcelTabCtrl object.

All themes used for CXTPExcelTabCtrl should inherit from this base class.

Member Function Documentation

◆ DrawButton()

virtual void DrawButton | ( | CDC * | pDC,
 |  | CXTPExcelTabCtrl * | pTabCtrl,
 |  | const CXTPExcelTabCtrlButtonState & | state )
 virtual

This member function is used by the flat tab control to draw an arrow button to the device context specified by 'pDC'.

Parameters
pDC | A CDC pointer that represents the current device context.
pTabCtrl | A pointer to a CXTPExcelTabCtrl object.
state | The XY location of the top left corner of the tab to draw.

Reimplemented in CXTPExcelTabCtrlThemeOffice2013.

◆ DrawButtonBack()

virtual void DrawButtonBack | ( | CDC * | pDC,
 |  | CRect & | rect,
 |  | const CXTPExcelTabCtrlButtonState & | state )
 virtual

Call this member function to draw the background of the button.

Parameters
pDC | A pointer to a valid device context.
rect | A CRect object that contains the location and dimensions of the button.
state | A CXTPExcelTabCtrlButtonState that contains the current state of the button.

Reimplemented in CXTPExcelTabCtrlThemeOffice2003, CXTPExcelTabCtrlThemeOffice2013, and CXTPExcelTabCtrlThemeOfficeXP.

◆ DrawGripper()

virtual void DrawGripper | ( | CDC * | pDC,
 |  | CRect | rect )
 virtual

This member function will draw the horizontal sizing gripper at a specified location.

Parameters
pDC | Pointer to the device context to draw the gripper to.
rect | Location of the gripper.

Reimplemented in CXTPExcelTabCtrlThemeOffice2013.

◆ DrawTab()

virtual int DrawTab | ( | CDC * | pDC,
 |  | CXTPExcelTabCtrl * | pTabCtrl,
 |  | const CPoint & | pt,
 |  | bool | bSelected,
 |  | CXTPTcbItem * | pTcbItem )
 virtual

This member function will draw a tab to the device context specified by 'pDC'.

Parameters
pDC | A CDC pointer that represents the current device context.
pTabCtrl | A pointer to a CXTPExcelTabCtrl object.
pt | A CPoint object that specifies the position of the XY location of the top left corner of the tab to draw.
bSelected | true if the tab is currently selected.
pTcbItem | Tab pointer to render.
Returns
The x position of the next tab to be drawn if successful, otherwise -1.

Reimplemented in CXTPExcelTabCtrlThemeOffice2013.

◆ FillBackground()

virtual void FillBackground | ( | CDC * | pDC,
 |  | CRect & | rect,
 |  | BOOL | bBottom )
 virtual

This member function is called to fill the background area for the tab control.

Parameters
pDC | A CDC pointer that represents the current device context.
rect | A CRect object that contains the location and dimensions of the tab control.
bBottom | TRUE if the tab control is orientated at the bottom of the screen.

Reimplemented in CXTPExcelTabCtrlThemeOffice2013.

◆ FillTabsBackground()

virtual void FillTabsBackground | ( | CDC * | pDC,
 |  | int | cx,
 |  | int | cy )
 virtual

This member function is called to fill the background area that is occupied by the tab strip.

Parameters
pDC | A CDC pointer that represents the current device context.
cx | Width in pixels of the tab background to fill.
cy | Height in pixels of the tab background to fill.

Reimplemented in CXTPExcelTabCtrlThemeOffice2013.

◆ GetSelTabBackColor()

virtual COLORREF GetSelTabBackColor ( CXTPTcbItem * pTcbItem ) const
virtual

This member function gets an RGB value that represents the background color for selected tabs.

Parameters
pTcbItem The tab pointer to get the selected background color for.
Returns
An RGB value that represents the selected tabs background color if successful, otherwise COLORREF_NULL.

◆ GetSelTabTextColor()

virtual COLORREF GetSelTabTextColor ( CXTPTcbItem * pTcbItem ) const
virtual

This member function gets an RGB value that represents the text color for selected tabs.

Parameters
pTcbItem The tab pointer to get the selected text color for.
Returns
An RGB value that represents the selected tab text color if successful, otherwise COLORREF_NULL.

◆ GetTabBackColor()

virtual COLORREF GetTabBackColor ( CXTPTcbItem * pTcbItem ) const
virtual

This member function gets an RGB value that represents the background color of the tab.

Parameters
pTcbItem The tab pointer to get the background color for.
Returns
An RGB value that represents the tab background color if successful, otherwise COLORREF_NULL.

◆ GetTabTextColor()

virtual COLORREF GetTabTextColor ( CXTPTcbItem * pTcbItem ) const
virtual

This member function gets an RGB value that represents the text color of the tab.

Parameters
pTcbItem The tab pointer to get the text color for.
Returns
An RGB value that represents the tab text color if successful, otherwise COLORREF_NULL.

◆ RefreshMetrics()

virtual void RefreshMetrics ( CXTPExcelTabCtrl * pTab )
virtual

Call this function to refresh the flat tab control colors, position any scroll bars to their default positions, and then reset the control to the system defaults.

Parameters
pTab Pointer to the CXTPExcelTabCtrl object.

Reimplemented in CXTPExcelTabCtrlThemeOffice2003, CXTPExcelTabCtrlThemeOffice2013, and CXTPExcelTabCtrlThemeOfficeXP.

The documentation for this class was generated from the following file:
  • XTPExcelTabCtrlTheme.h


Toolkit Pro: CXTPExcelTabCtrlThemeNativeWindows10 Class Reference

Public Member Functions | List of all members
CXTPExcelTabCtrlThemeNativeWindows10 Class Reference

This class is used to draw a CXTPTabCtrl object using Excel Native Windows 10 theme. More...

Inheritance diagram for CXTPExcelTabCtrlThemeNativeWindows10:
[legend]

Public Member Functions

CXTPExcelTabCtrlThemeNativeWindows10 ()
Constructs a CXTPExcelTabCtrlThemeNativeWindows10 object.
- Public Member Functions inherited from CXTPExcelTabCtrlThemeOffice2013
CXTPExcelTabCtrlThemeOffice2013 ()
Constructs a CXTPExcelTabCtrlThemeOffice2013 object.
virtual void | RefreshMetrics (CXTPExcelTabCtrl *pTab)
This member function is called by the theme manager to refresh the visual styles used by each component's theme.
virtual int | DrawTab (CDC *pDC, CXTPExcelTabCtrl *pTabCtrl, const CPoint &pt, bool bSelected, CXTPTcbItem *pTcbItem)
This member function will draw a tab to the device context specified by 'pDC'.
virtual void | DrawButtonBack (CDC *pDC, CRect &rect, const CXTPExcelTabCtrlButtonState &state)
Call this member function to draw the background of the button.
virtual void | DrawButton (CDC *pDC, CXTPExcelTabCtrl *pTabCtrl, const CXTPExcelTabCtrlButtonState &state)
This member function is used by the flat tab control to draw an arrow button to the device context specified by 'pDC'.
virtual void | FillBackground (CDC *pDC, CRect &rect, BOOL bBottom)
This member function is called to fill the background area for the tab control.
virtual void | FillTabsBackground (CDC *pDC, int cx, int cy)
This member function is called to fill the background area that is occupied by the tab strip.
virtual void | DrawGripper (CDC *pDC, CRect rect)
This member function will draw the horizontal sizing gripper at a specified location.
- Public Member Functions inherited from CXTPExcelTabCtrlTheme
CXTPExcelTabCtrlTheme ()
Constructs a CXTPExcelTabCtrlTheme object.
~CXTPExcelTabCtrlTheme ()
Destroys a CXTPExcelTabCtrlTheme object, handles cleanup and deallocation.
virtual COLORREF | GetTabBackColor (CXTPTcbItem *pTcbItem) const
This member function gets an RGB value that represents the background color of the tab.
virtual COLORREF | GetTabTextColor (CXTPTcbItem *pTcbItem) const
This member function gets an RGB value that represents the text color of the tab.
virtual COLORREF | GetSelTabBackColor (CXTPTcbItem *pTcbItem) const
This member function gets an RGB value that represents the background color for selected tabs.
virtual COLORREF | GetSelTabTextColor (CXTPTcbItem *pTcbItem) const
This member function gets an RGB value that represents the text color for selected tabs.
- Public Member Functions inherited from CXTPControlTheme
CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme | GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlTheme
static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPExcelTabCtrlTheme
CXTPPaintManagerColor | m_clr3DFace
An RGB value that represents the normal tab face color.
CXTPPaintManagerColor | m_clr3DFacePushed
An RGB value for pushed background color.
CXTPPaintManagerColor | m_clr3DFaceHilite
An RGB value for highlighted background color.
CXTPPaintManagerColor | m_clrBtnText
An RGB value that represents the tab outline color.
CXTPPaintManagerColor | m_clrBtnTextGray
An RGB value for disabled text color.
CXTPPaintManagerColor | m_clrBtnTextPushed
An RGB value for highlighted text color.
CXTPPaintManagerColor | m_clrBtnTextHilite
An RGB value for pushed text color.
CXTPPaintManagerColor | m_clrWindow
An RGB value that represents the selected tab face color.
CXTPPaintManagerColor | m_clrWindowText
An RGB value that represents the tab text color.
CXTPPaintManagerColor | m_clr3DHilight
An RGB value that represents the tab highlight color.
CXTPPaintManagerColor | m_clr3DShadow
An RGB value that represents the tab shadow color.
CXTPPaintManagerColor | m_clrBorder3DHilite
An RGB value for 3D border highlight color.
CXTPPaintManagerColor | m_clrBorder3DShadow
An RGB value for 3D border shadow color.
- Protected Attributes inherited from CXTPControlTheme
XTPControlTheme | m_nTheme
Currently selected theme style index.

Detailed Description

This class is used to draw a CXTPTabCtrl object using Excel Native Windows 10 theme.

The documentation for this class was generated from the following file:
  • XTPExcelTabCtrlTheme.h


Toolkit Pro: CXTPExcelTabCtrlThemeNativeWindows11 Class Reference

Public Member Functions | List of all members
CXTPExcelTabCtrlThemeNativeWindows11 Class Reference

This class is used to draw a CXTPTabCtrl object using Excel Native Windows 11 theme. More...

Inheritance diagram for CXTPExcelTabCtrlThemeNativeWindows11:
[legend]

Public Member Functions

CXTPExcelTabCtrlThemeNativeWindows11 ()
Constructs a CXTPExcelTabCtrlThemeNativeWindows10 object.
- Public Member Functions inherited from CXTPExcelTabCtrlThemeOffice2013
CXTPExcelTabCtrlThemeOffice2013 ()
Constructs a CXTPExcelTabCtrlThemeOffice2013 object.
virtual void | RefreshMetrics (CXTPExcelTabCtrl *pTab)
This member function is called by the theme manager to refresh the visual styles used by each component's theme.
virtual int | DrawTab (CDC *pDC, CXTPExcelTabCtrl *pTabCtrl, const CPoint &pt, bool bSelected, CXTPTcbItem *pTcbItem)
This member function will draw a tab to the device context specified by 'pDC'.
virtual void | DrawButtonBack (CDC *pDC, CRect &rect, const CXTPExcelTabCtrlButtonState &state)
Call this member function to draw the background of the button.
virtual void | DrawButton (CDC *pDC, CXTPExcelTabCtrl *pTabCtrl, const CXTPExcelTabCtrlButtonState &state)
This member function is used by the flat tab control to draw an arrow button to the device context specified by 'pDC'.
virtual void | FillBackground (CDC *pDC, CRect &rect, BOOL bBottom)
This member function is called to fill the background area for the tab control.
virtual void | FillTabsBackground (CDC *pDC, int cx, int cy)
This member function is called to fill the background area that is occupied by the tab strip.
virtual void | DrawGripper (CDC *pDC, CRect rect)
This member function will draw the horizontal sizing gripper at a specified location.
- Public Member Functions inherited from CXTPExcelTabCtrlTheme
CXTPExcelTabCtrlTheme ()
Constructs a CXTPExcelTabCtrlTheme object.
~CXTPExcelTabCtrlTheme ()
Destroys a CXTPExcelTabCtrlTheme object, handles cleanup and deallocation.
virtual COLORREF | GetTabBackColor (CXTPTcbItem *pTcbItem) const
This member function gets an RGB value that represents the background color of the tab.
virtual COLORREF | GetTabTextColor (CXTPTcbItem *pTcbItem) const
This member function gets an RGB value that represents the text color of the tab.
virtual COLORREF | GetSelTabBackColor (CXTPTcbItem *pTcbItem) const
This member function gets an RGB value that represents the background color for selected tabs.
virtual COLORREF | GetSelTabTextColor (CXTPTcbItem *pTcbItem) const
This member function gets an RGB value that represents the text color for selected tabs.
- Public Member Functions inherited from CXTPControlTheme
CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme | GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlTheme
static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPExcelTabCtrlTheme
CXTPPaintManagerColor | m_clr3DFace
An RGB value that represents the normal tab face color.
CXTPPaintManagerColor | m_clr3DFacePushed
An RGB value for pushed background color.
CXTPPaintManagerColor | m_clr3DFaceHilite
An RGB value for highlighted background color.
CXTPPaintManagerColor | m_clrBtnText
An RGB value that represents the tab outline color.
CXTPPaintManagerColor | m_clrBtnTextGray
An RGB value for disabled text color.
CXTPPaintManagerColor | m_clrBtnTextPushed
An RGB value for highlighted text color.
CXTPPaintManagerColor | m_clrBtnTextHilite
An RGB value for pushed text color.
CXTPPaintManagerColor | m_clrWindow
An RGB value that represents the selected tab face color.
CXTPPaintManagerColor | m_clrWindowText
An RGB value that represents the tab text color.
CXTPPaintManagerColor | m_clr3DHilight
An RGB value that represents the tab highlight color.
CXTPPaintManagerColor | m_clr3DShadow
An RGB value that represents the tab shadow color.
CXTPPaintManagerColor | m_clrBorder3DHilite
An RGB value for 3D border highlight color.
CXTPPaintManagerColor | m_clrBorder3DShadow
An RGB value for 3D border shadow color.
- Protected Attributes inherited from CXTPControlTheme
XTPControlTheme | m_nTheme
Currently selected theme style index.

Detailed Description

This class is used to draw a CXTPTabCtrl object using Excel Native Windows 11 theme.

The documentation for this class was generated from the following file:
  • XTPExcelTabCtrlTheme.h


Toolkit Pro: CXTPExcelTabCtrlThemeOffice2003 Class Reference

Public Member Functions | List of all members
CXTPExcelTabCtrlThemeOffice2003 Class Reference

This class is used to draw a CXTPTabCtrl object using Excel Office 2003 theme. More...

Inheritance diagram for CXTPExcelTabCtrlThemeOffice2003:
[legend]

Public Member Functions

CXTPExcelTabCtrlThemeOffice2003 ()
Constructs a CXTPExcelTabCtrlThemeOffice2003 object.
virtual void | RefreshMetrics (CXTPExcelTabCtrl *pTab)
This member function is called by the theme manager to refresh the visual styles used by each component's theme.
virtual void | DrawButtonBack (CDC *pDC, CRect &rect, const CXTPExcelTabCtrlButtonState &state)
Call this member function to draw the background of the button.
- Public Member Functions inherited from CXTPExcelTabCtrlThemeOfficeXP
CXTPExcelTabCtrlThemeOfficeXP ()
Constructs a CXTPExcelTabCtrlThemeOfficeXP object.
- Public Member Functions inherited from CXTPExcelTabCtrlTheme
CXTPExcelTabCtrlTheme ()
Constructs a CXTPExcelTabCtrlTheme object.
~CXTPExcelTabCtrlTheme ()
Destroys a CXTPExcelTabCtrlTheme object, handles cleanup and deallocation.
virtual int | DrawTab (CDC *pDC, CXTPExcelTabCtrl *pTabCtrl, const CPoint &pt, bool bSelected, CXTPTcbItem *pTcbItem)
This member function will draw a tab to the device context specified by 'pDC'.
virtual void | DrawButton (CDC *pDC, CXTPExcelTabCtrl *pTabCtrl, const CXTPExcelTabCtrlButtonState &state)
This member function is used by the flat tab control to draw an arrow button to the device context specified by 'pDC'.
virtual void | FillBackground (CDC *pDC, CRect &rect, BOOL bBottom)
This member function is called to fill the background area for the tab control.
virtual void | FillTabsBackground (CDC *pDC, int cx, int cy)
This member function is called to fill the background area that is occupied by the tab strip.
virtual void | DrawGripper (CDC *pDC, CRect rect)
This member function will draw the horizontal sizing gripper at a specified location.
virtual COLORREF | GetTabBackColor (CXTPTcbItem *pTcbItem) const
This member function gets an RGB value that represents the background color of the tab.
virtual COLORREF | GetTabTextColor (CXTPTcbItem *pTcbItem) const
This member function gets an RGB value that represents the text color of the tab.
virtual COLORREF | GetSelTabBackColor (CXTPTcbItem *pTcbItem) const
This member function gets an RGB value that represents the background color for selected tabs.
virtual COLORREF | GetSelTabTextColor (CXTPTcbItem *pTcbItem) const
This member function gets an RGB value that represents the text color for selected tabs.
- Public Member Functions inherited from CXTPControlTheme
CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme | GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlTheme
static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPExcelTabCtrlTheme
CXTPPaintManagerColor | m_clr3DFace
An RGB value that represents the normal tab face color.
CXTPPaintManagerColor | m_clr3DFacePushed
An RGB value for pushed background color.
CXTPPaintManagerColor | m_clr3DFaceHilite
An RGB value for highlighted background color.
CXTPPaintManagerColor | m_clrBtnText
An RGB value that represents the tab outline color.
CXTPPaintManagerColor | m_clrBtnTextGray
An RGB value for disabled text color.
CXTPPaintManagerColor | m_clrBtnTextPushed
An RGB value for highlighted text color.
CXTPPaintManagerColor | m_clrBtnTextHilite
An RGB value for pushed text color.
CXTPPaintManagerColor | m_clrWindow
An RGB value that represents the selected tab face color.
CXTPPaintManagerColor | m_clrWindowText
An RGB value that represents the tab text color.
CXTPPaintManagerColor | m_clr3DHilight
An RGB value that represents the tab highlight color.
CXTPPaintManagerColor | m_clr3DShadow
An RGB value that represents the tab shadow color.
CXTPPaintManagerColor | m_clrBorder3DHilite
An RGB value for 3D border highlight color.
CXTPPaintManagerColor | m_clrBorder3DShadow
An RGB value for 3D border shadow color.
- Protected Attributes inherited from CXTPControlTheme
XTPControlTheme | m_nTheme
Currently selected theme style index.

Detailed Description

This class is used to draw a CXTPTabCtrl object using Excel Office 2003 theme.

Member Function Documentation

◆ DrawButtonBack()

virtual void DrawButtonBack | ( | CDC * | pDC,
 |  | CRect & | rect,
 |  | const CXTPExcelTabCtrlButtonState & | state )
 virtual

Call this member function to draw the background of the button.

Parameters
pDC | A pointer to a valid device context.
rect | A CRect object that contains the location and dimensions of the button.
state | A CXTPExcelTabCtrlButtonState that contains the current state of the button.

Reimplemented from CXTPExcelTabCtrlThemeOfficeXP.

◆ RefreshMetrics()

virtual void RefreshMetrics ( CXTPExcelTabCtrl * pTab )
virtual

This member function is called by the theme manager to refresh the visual styles used by each component's theme.

Parameters
pTab Pointer to the CXTPExcelTabCtrl object.

Reimplemented from CXTPExcelTabCtrlThemeOfficeXP.

The documentation for this class was generated from the following file:
  • XTPExcelTabCtrlTheme.h


Toolkit Pro: CXTPExcelTabCtrlThemeOffice2013 Class Reference

Public Member Functions | List of all members
CXTPExcelTabCtrlThemeOffice2013 Class Reference

This class is used to draw a CXTPTabCtrl object using Excel Office 2013 theme. More...

Inheritance diagram for CXTPExcelTabCtrlThemeOffice2013:
[legend]

Public Member Functions

CXTPExcelTabCtrlThemeOffice2013 ()
Constructs a CXTPExcelTabCtrlThemeOffice2013 object.
virtual void | RefreshMetrics (CXTPExcelTabCtrl *pTab)
This member function is called by the theme manager to refresh the visual styles used by each component's theme.
virtual int | DrawTab (CDC *pDC, CXTPExcelTabCtrl *pTabCtrl, const CPoint &pt, bool bSelected, CXTPTcbItem *pTcbItem)
This member function will draw a tab to the device context specified by 'pDC'.
virtual void | DrawButtonBack (CDC *pDC, CRect &rect, const CXTPExcelTabCtrlButtonState &state)
Call this member function to draw the background of the button.
virtual void | DrawButton (CDC *pDC, CXTPExcelTabCtrl *pTabCtrl, const CXTPExcelTabCtrlButtonState &state)
This member function is used by the flat tab control to draw an arrow button to the device context specified by 'pDC'.
virtual void | FillBackground (CDC *pDC, CRect &rect, BOOL bBottom)
This member function is called to fill the background area for the tab control.
virtual void | FillTabsBackground (CDC *pDC, int cx, int cy)
This member function is called to fill the background area that is occupied by the tab strip.
virtual void | DrawGripper (CDC *pDC, CRect rect)
This member function will draw the horizontal sizing gripper at a specified location.
- Public Member Functions inherited from CXTPExcelTabCtrlTheme
CXTPExcelTabCtrlTheme ()
Constructs a CXTPExcelTabCtrlTheme object.
~CXTPExcelTabCtrlTheme ()
Destroys a CXTPExcelTabCtrlTheme object, handles cleanup and deallocation.
virtual COLORREF | GetTabBackColor (CXTPTcbItem *pTcbItem) const
This member function gets an RGB value that represents the background color of the tab.
virtual COLORREF | GetTabTextColor (CXTPTcbItem *pTcbItem) const
This member function gets an RGB value that represents the text color of the tab.
virtual COLORREF | GetSelTabBackColor (CXTPTcbItem *pTcbItem) const
This member function gets an RGB value that represents the background color for selected tabs.
virtual COLORREF | GetSelTabTextColor (CXTPTcbItem *pTcbItem) const
This member function gets an RGB value that represents the text color for selected tabs.
- Public Member Functions inherited from CXTPControlTheme
CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme | GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlTheme
static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPExcelTabCtrlTheme
CXTPPaintManagerColor | m_clr3DFace
An RGB value that represents the normal tab face color.
CXTPPaintManagerColor | m_clr3DFacePushed
An RGB value for pushed background color.
CXTPPaintManagerColor | m_clr3DFaceHilite
An RGB value for highlighted background color.
CXTPPaintManagerColor | m_clrBtnText
An RGB value that represents the tab outline color.
CXTPPaintManagerColor | m_clrBtnTextGray
An RGB value for disabled text color.
CXTPPaintManagerColor | m_clrBtnTextPushed
An RGB value for highlighted text color.
CXTPPaintManagerColor | m_clrBtnTextHilite
An RGB value for pushed text color.
CXTPPaintManagerColor | m_clrWindow
An RGB value that represents the selected tab face color.
CXTPPaintManagerColor | m_clrWindowText
An RGB value that represents the tab text color.
CXTPPaintManagerColor | m_clr3DHilight
An RGB value that represents the tab highlight color.
CXTPPaintManagerColor | m_clr3DShadow
An RGB value that represents the tab shadow color.
CXTPPaintManagerColor | m_clrBorder3DHilite
An RGB value for 3D border highlight color.
CXTPPaintManagerColor | m_clrBorder3DShadow
An RGB value for 3D border shadow color.
- Protected Attributes inherited from CXTPControlTheme
XTPControlTheme | m_nTheme
Currently selected theme style index.

Detailed Description

This class is used to draw a CXTPTabCtrl object using Excel Office 2013 theme.

Member Function Documentation

◆ DrawButton()

virtual void DrawButton | ( | CDC * | pDC,
 |  | CXTPExcelTabCtrl * | pTabCtrl,
 |  | const CXTPExcelTabCtrlButtonState & | state )
 virtual

This member function is used by the flat tab control to draw an arrow button to the device context specified by 'pDC'.

Parameters
pDC | A CDC pointer that represents the current device context.
pTabCtrl | A pointer to a CXTPExcelTabCtrl object.
state | The XY location of the top left corner of the tab to draw.

Reimplemented from CXTPExcelTabCtrlTheme.

◆ DrawButtonBack()

virtual void DrawButtonBack | ( | CDC * | pDC,
 |  | CRect & | rect,
 |  | const CXTPExcelTabCtrlButtonState & | state )
 virtual

Call this member function to draw the background of the button.

Parameters
pDC | A pointer to a valid device context.
rect | A CRect object that contains the location and dimensions of the button.
state | A CXTPExcelTabCtrlButtonState that contains the current state of the button.

Reimplemented from CXTPExcelTabCtrlTheme.

◆ DrawGripper()

virtual void DrawGripper | ( | CDC * | pDC,
 |  | CRect | rect )
 virtual

This member function will draw the horizontal sizing gripper at a specified location.

Parameters
pDC | Pointer to the device context to draw the gripper to.
rect | Location of the gripper.

Reimplemented from CXTPExcelTabCtrlTheme.

◆ DrawTab()

virtual int DrawTab | ( | CDC * | pDC,
 |  | CXTPExcelTabCtrl * | pTabCtrl,
 |  | const CPoint & | pt,
 |  | bool | bSelected,
 |  | CXTPTcbItem * | pTcbItem )
 virtual

This member function will draw a tab to the device context specified by 'pDC'.

Parameters
pDC | A CDC pointer that represents the current device context.
pTabCtrl | A pointer to a CXTPExcelTabCtrl object.
pt | A CPoint object that specifies the position of the XY location of the top left corner of the tab to draw.
bSelected | true if the tab is currently selected.
pTcbItem | Tab pointer to render.
Returns
The x position of the next tab to be drawn if successful, otherwise -1.

Reimplemented from CXTPExcelTabCtrlTheme.

◆ FillBackground()

virtual void FillBackground | ( | CDC * | pDC,
 |  | CRect & | rect,
 |  | BOOL | bBottom )
 virtual

This member function is called to fill the background area for the tab control.

Parameters
pDC | A CDC pointer that represents the current device context.
rect | A CRect object that contains the location and dimensions of the tab control.
bBottom | TRUE if the tab control is orientated at the bottom of the screen.

Reimplemented from CXTPExcelTabCtrlTheme.

◆ FillTabsBackground()

virtual void FillTabsBackground | ( | CDC * | pDC,
 |  | int | cx,
 |  | int | cy )
 virtual

This member function is called to fill the background area that is occupied by the tab strip.

Parameters
pDC | A CDC pointer that represents the current device context.
cx | Width in pixels of the tab background to fill.
cy | Height in pixels of the tab background to fill.

Reimplemented from CXTPExcelTabCtrlTheme.

◆ RefreshMetrics()

virtual void RefreshMetrics ( CXTPExcelTabCtrl * pTab )
virtual

This member function is called by the theme manager to refresh the visual styles used by each component's theme.

Parameters
pTab Pointer to the CXTPExcelTabCtrl object.

Reimplemented from CXTPExcelTabCtrlTheme.

The documentation for this class was generated from the following file:
  • XTPExcelTabCtrlTheme.h


Toolkit Pro: CXTPExcelTabCtrlThemeOfficeXP Class Reference

Public Member Functions | List of all members
CXTPExcelTabCtrlThemeOfficeXP Class Reference

This class is used to draw a CXTPTabCtrl object using Excel Office XP theme. More...

Inheritance diagram for CXTPExcelTabCtrlThemeOfficeXP:
[legend]

Public Member Functions

CXTPExcelTabCtrlThemeOfficeXP ()
Constructs a CXTPExcelTabCtrlThemeOfficeXP object.
virtual void | RefreshMetrics (CXTPExcelTabCtrl *pTab)
This member function is called by the theme manager to refresh the visual styles used by each component's theme.
virtual void | DrawButtonBack (CDC *pDC, CRect &rect, const CXTPExcelTabCtrlButtonState &state)
Call this member function to draw the background of the button.
- Public Member Functions inherited from CXTPExcelTabCtrlTheme
CXTPExcelTabCtrlTheme ()
Constructs a CXTPExcelTabCtrlTheme object.
~CXTPExcelTabCtrlTheme ()
Destroys a CXTPExcelTabCtrlTheme object, handles cleanup and deallocation.
virtual int | DrawTab (CDC *pDC, CXTPExcelTabCtrl *pTabCtrl, const CPoint &pt, bool bSelected, CXTPTcbItem *pTcbItem)
This member function will draw a tab to the device context specified by 'pDC'.
virtual void | DrawButton (CDC *pDC, CXTPExcelTabCtrl *pTabCtrl, const CXTPExcelTabCtrlButtonState &state)
This member function is used by the flat tab control to draw an arrow button to the device context specified by 'pDC'.
virtual void | FillBackground (CDC *pDC, CRect &rect, BOOL bBottom)
This member function is called to fill the background area for the tab control.
virtual void | FillTabsBackground (CDC *pDC, int cx, int cy)
This member function is called to fill the background area that is occupied by the tab strip.
virtual void | DrawGripper (CDC *pDC, CRect rect)
This member function will draw the horizontal sizing gripper at a specified location.
virtual COLORREF | GetTabBackColor (CXTPTcbItem *pTcbItem) const
This member function gets an RGB value that represents the background color of the tab.
virtual COLORREF | GetTabTextColor (CXTPTcbItem *pTcbItem) const
This member function gets an RGB value that represents the text color of the tab.
virtual COLORREF | GetSelTabBackColor (CXTPTcbItem *pTcbItem) const
This member function gets an RGB value that represents the background color for selected tabs.
virtual COLORREF | GetSelTabTextColor (CXTPTcbItem *pTcbItem) const
This member function gets an RGB value that represents the text color for selected tabs.
- Public Member Functions inherited from CXTPControlTheme
CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme | GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlTheme
static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPExcelTabCtrlTheme
CXTPPaintManagerColor | m_clr3DFace
An RGB value that represents the normal tab face color.
CXTPPaintManagerColor | m_clr3DFacePushed
An RGB value for pushed background color.
CXTPPaintManagerColor | m_clr3DFaceHilite
An RGB value for highlighted background color.
CXTPPaintManagerColor | m_clrBtnText
An RGB value that represents the tab outline color.
CXTPPaintManagerColor | m_clrBtnTextGray
An RGB value for disabled text color.
CXTPPaintManagerColor | m_clrBtnTextPushed
An RGB value for highlighted text color.
CXTPPaintManagerColor | m_clrBtnTextHilite
An RGB value for pushed text color.
CXTPPaintManagerColor | m_clrWindow
An RGB value that represents the selected tab face color.
CXTPPaintManagerColor | m_clrWindowText
An RGB value that represents the tab text color.
CXTPPaintManagerColor | m_clr3DHilight
An RGB value that represents the tab highlight color.
CXTPPaintManagerColor | m_clr3DShadow
An RGB value that represents the tab shadow color.
CXTPPaintManagerColor | m_clrBorder3DHilite
An RGB value for 3D border highlight color.
CXTPPaintManagerColor | m_clrBorder3DShadow
An RGB value for 3D border shadow color.
- Protected Attributes inherited from CXTPControlTheme
XTPControlTheme | m_nTheme
Currently selected theme style index.

Detailed Description

This class is used to draw a CXTPTabCtrl object using Excel Office XP theme.

Member Function Documentation

◆ DrawButtonBack()

virtual void DrawButtonBack | ( | CDC * | pDC,
 |  | CRect & | rect,
 |  | const CXTPExcelTabCtrlButtonState & | state )
 virtual

Call this member function to draw the background of the button.

Parameters
pDC | A pointer to a valid device context.
rect | A CRect object that contains the location and dimensions of the button.
state | A CXTPExcelTabCtrlButtonState that contains the current state of the button.

Reimplemented from CXTPExcelTabCtrlTheme.

Reimplemented in CXTPExcelTabCtrlThemeOffice2003.

◆ RefreshMetrics()

virtual void RefreshMetrics ( CXTPExcelTabCtrl * pTab )
virtual

This member function is called by the theme manager to refresh the visual styles used by each component's theme.

Parameters
pTab Pointer to the CXTPExcelTabCtrl object.

Reimplemented from CXTPExcelTabCtrlTheme.

Reimplemented in CXTPExcelTabCtrlThemeOffice2003.

The documentation for this class was generated from the following file:
  • XTPExcelTabCtrlTheme.h


Toolkit Pro: CXTPExcelTabCtrlThemeVisualStudio2015 Class Reference

Public Member Functions | List of all members
CXTPExcelTabCtrlThemeVisualStudio2015 Class Reference

This class is used to draw a CXTPExcelTabCtrlThemeVisualStudio2015 object using Excel Visual Studio 2015 theme. More...

Inheritance diagram for CXTPExcelTabCtrlThemeVisualStudio2015:
[legend]

Public Member Functions

CXTPExcelTabCtrlThemeVisualStudio2015 ()
Constructs a CXTPExcelTabCtrlThemeVisualStudio2015 object.
- Public Member Functions inherited from CXTPExcelTabCtrlThemeOffice2013
CXTPExcelTabCtrlThemeOffice2013 ()
Constructs a CXTPExcelTabCtrlThemeOffice2013 object.
virtual void | RefreshMetrics (CXTPExcelTabCtrl *pTab)
This member function is called by the theme manager to refresh the visual styles used by each component's theme.
virtual int | DrawTab (CDC *pDC, CXTPExcelTabCtrl *pTabCtrl, const CPoint &pt, bool bSelected, CXTPTcbItem *pTcbItem)
This member function will draw a tab to the device context specified by 'pDC'.
virtual void | DrawButtonBack (CDC *pDC, CRect &rect, const CXTPExcelTabCtrlButtonState &state)
Call this member function to draw the background of the button.
virtual void | DrawButton (CDC *pDC, CXTPExcelTabCtrl *pTabCtrl, const CXTPExcelTabCtrlButtonState &state)
This member function is used by the flat tab control to draw an arrow button to the device context specified by 'pDC'.
virtual void | FillBackground (CDC *pDC, CRect &rect, BOOL bBottom)
This member function is called to fill the background area for the tab control.
virtual void | FillTabsBackground (CDC *pDC, int cx, int cy)
This member function is called to fill the background area that is occupied by the tab strip.
virtual void | DrawGripper (CDC *pDC, CRect rect)
This member function will draw the horizontal sizing gripper at a specified location.
- Public Member Functions inherited from CXTPExcelTabCtrlTheme
CXTPExcelTabCtrlTheme ()
Constructs a CXTPExcelTabCtrlTheme object.
~CXTPExcelTabCtrlTheme ()
Destroys a CXTPExcelTabCtrlTheme object, handles cleanup and deallocation.
virtual COLORREF | GetTabBackColor (CXTPTcbItem *pTcbItem) const
This member function gets an RGB value that represents the background color of the tab.
virtual COLORREF | GetTabTextColor (CXTPTcbItem *pTcbItem) const
This member function gets an RGB value that represents the text color of the tab.
virtual COLORREF | GetSelTabBackColor (CXTPTcbItem *pTcbItem) const
This member function gets an RGB value that represents the background color for selected tabs.
virtual COLORREF | GetSelTabTextColor (CXTPTcbItem *pTcbItem) const
This member function gets an RGB value that represents the text color for selected tabs.
- Public Member Functions inherited from CXTPControlTheme
CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme | GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlTheme
static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPExcelTabCtrlTheme
CXTPPaintManagerColor | m_clr3DFace
An RGB value that represents the normal tab face color.
CXTPPaintManagerColor | m_clr3DFacePushed
An RGB value for pushed background color.
CXTPPaintManagerColor | m_clr3DFaceHilite
An RGB value for highlighted background color.
CXTPPaintManagerColor | m_clrBtnText
An RGB value that represents the tab outline color.
CXTPPaintManagerColor | m_clrBtnTextGray
An RGB value for disabled text color.
CXTPPaintManagerColor | m_clrBtnTextPushed
An RGB value for highlighted text color.
CXTPPaintManagerColor | m_clrBtnTextHilite
An RGB value for pushed text color.
CXTPPaintManagerColor | m_clrWindow
An RGB value that represents the selected tab face color.
CXTPPaintManagerColor | m_clrWindowText
An RGB value that represents the tab text color.
CXTPPaintManagerColor | m_clr3DHilight
An RGB value that represents the tab highlight color.
CXTPPaintManagerColor | m_clr3DShadow
An RGB value that represents the tab shadow color.
CXTPPaintManagerColor | m_clrBorder3DHilite
An RGB value for 3D border highlight color.
CXTPPaintManagerColor | m_clrBorder3DShadow
An RGB value for 3D border shadow color.
- Protected Attributes inherited from CXTPControlTheme
XTPControlTheme | m_nTheme
Currently selected theme style index.

Detailed Description

This class is used to draw a CXTPExcelTabCtrlThemeVisualStudio2015 object using Excel Visual Studio 2015 theme.

The documentation for this class was generated from the following file:
  • XTPExcelTabCtrlTheme.h


Toolkit Pro: CXTPExcelTabCtrlThemeVisualStudio2017 Class Reference

Public Member Functions | List of all members
CXTPExcelTabCtrlThemeVisualStudio2017 Class Reference

This class is used to draw a CXTPExcelTabCtrlThemeVisualStudio2017 object using Excel Visual Studio 2017 theme. More...

Inheritance diagram for CXTPExcelTabCtrlThemeVisualStudio2017:
[legend]

Public Member Functions

CXTPExcelTabCtrlThemeVisualStudio2017 ()
Constructs a CXTPExcelTabCtrlThemeVisualStudio2017 object.
- Public Member Functions inherited from CXTPExcelTabCtrlThemeOffice2013
CXTPExcelTabCtrlThemeOffice2013 ()
Constructs a CXTPExcelTabCtrlThemeOffice2013 object.
virtual void | RefreshMetrics (CXTPExcelTabCtrl *pTab)
This member function is called by the theme manager to refresh the visual styles used by each component's theme.
virtual int | DrawTab (CDC *pDC, CXTPExcelTabCtrl *pTabCtrl, const CPoint &pt, bool bSelected, CXTPTcbItem *pTcbItem)
This member function will draw a tab to the device context specified by 'pDC'.
virtual void | DrawButtonBack (CDC *pDC, CRect &rect, const CXTPExcelTabCtrlButtonState &state)
Call this member function to draw the background of the button.
virtual void | DrawButton (CDC *pDC, CXTPExcelTabCtrl *pTabCtrl, const CXTPExcelTabCtrlButtonState &state)
This member function is used by the flat tab control to draw an arrow button to the device context specified by 'pDC'.
virtual void | FillBackground (CDC *pDC, CRect &rect, BOOL bBottom)
This member function is called to fill the background area for the tab control.
virtual void | FillTabsBackground (CDC *pDC, int cx, int cy)
This member function is called to fill the background area that is occupied by the tab strip.
virtual void | DrawGripper (CDC *pDC, CRect rect)
This member function will draw the horizontal sizing gripper at a specified location.
- Public Member Functions inherited from CXTPExcelTabCtrlTheme
CXTPExcelTabCtrlTheme ()
Constructs a CXTPExcelTabCtrlTheme object.
~CXTPExcelTabCtrlTheme ()
Destroys a CXTPExcelTabCtrlTheme object, handles cleanup and deallocation.
virtual COLORREF | GetTabBackColor (CXTPTcbItem *pTcbItem) const
This member function gets an RGB value that represents the background color of the tab.
virtual COLORREF | GetTabTextColor (CXTPTcbItem *pTcbItem) const
This member function gets an RGB value that represents the text color of the tab.
virtual COLORREF | GetSelTabBackColor (CXTPTcbItem *pTcbItem) const
This member function gets an RGB value that represents the background color for selected tabs.
virtual COLORREF | GetSelTabTextColor (CXTPTcbItem *pTcbItem) const
This member function gets an RGB value that represents the text color for selected tabs.
- Public Member Functions inherited from CXTPControlTheme
CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme | GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlTheme
static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPExcelTabCtrlTheme
CXTPPaintManagerColor | m_clr3DFace
An RGB value that represents the normal tab face color.
CXTPPaintManagerColor | m_clr3DFacePushed
An RGB value for pushed background color.
CXTPPaintManagerColor | m_clr3DFaceHilite
An RGB value for highlighted background color.
CXTPPaintManagerColor | m_clrBtnText
An RGB value that represents the tab outline color.
CXTPPaintManagerColor | m_clrBtnTextGray
An RGB value for disabled text color.
CXTPPaintManagerColor | m_clrBtnTextPushed
An RGB value for highlighted text color.
CXTPPaintManagerColor | m_clrBtnTextHilite
An RGB value for pushed text color.
CXTPPaintManagerColor | m_clrWindow
An RGB value that represents the selected tab face color.
CXTPPaintManagerColor | m_clrWindowText
An RGB value that represents the tab text color.
CXTPPaintManagerColor | m_clr3DHilight
An RGB value that represents the tab highlight color.
CXTPPaintManagerColor | m_clr3DShadow
An RGB value that represents the tab shadow color.
CXTPPaintManagerColor | m_clrBorder3DHilite
An RGB value for 3D border highlight color.
CXTPPaintManagerColor | m_clrBorder3DShadow
An RGB value for 3D border shadow color.
- Protected Attributes inherited from CXTPControlTheme
XTPControlTheme | m_nTheme
Currently selected theme style index.

Detailed Description

This class is used to draw a CXTPExcelTabCtrlThemeVisualStudio2017 object using Excel Visual Studio 2017 theme.

The documentation for this class was generated from the following file:
  • XTPExcelTabCtrlTheme.h


Toolkit Pro: CXTPExcelTabCtrlThemeVisualStudio2019 Class Reference

Public Member Functions | List of all members
CXTPExcelTabCtrlThemeVisualStudio2019 Class Reference

This class is used to draw a CXTPExcelTabCtrlThemeVisualStudio2019 object using Excel Visual Studio 2019 theme. More...

Inheritance diagram for CXTPExcelTabCtrlThemeVisualStudio2019:
[legend]

Public Member Functions

CXTPExcelTabCtrlThemeVisualStudio2019 ()
Constructs a CXTPExcelTabCtrlThemeVisualStudio2019 object.
- Public Member Functions inherited from CXTPExcelTabCtrlThemeOffice2013
CXTPExcelTabCtrlThemeOffice2013 ()
Constructs a CXTPExcelTabCtrlThemeOffice2013 object.
virtual void | RefreshMetrics (CXTPExcelTabCtrl *pTab)
This member function is called by the theme manager to refresh the visual styles used by each component's theme.
virtual int | DrawTab (CDC *pDC, CXTPExcelTabCtrl *pTabCtrl, const CPoint &pt, bool bSelected, CXTPTcbItem *pTcbItem)
This member function will draw a tab to the device context specified by 'pDC'.
virtual void | DrawButtonBack (CDC *pDC, CRect &rect, const CXTPExcelTabCtrlButtonState &state)
Call this member function to draw the background of the button.
virtual void | DrawButton (CDC *pDC, CXTPExcelTabCtrl *pTabCtrl, const CXTPExcelTabCtrlButtonState &state)
This member function is used by the flat tab control to draw an arrow button to the device context specified by 'pDC'.
virtual void | FillBackground (CDC *pDC, CRect &rect, BOOL bBottom)
This member function is called to fill the background area for the tab control.
virtual void | FillTabsBackground (CDC *pDC, int cx, int cy)
This member function is called to fill the background area that is occupied by the tab strip.
virtual void | DrawGripper (CDC *pDC, CRect rect)
This member function will draw the horizontal sizing gripper at a specified location.
- Public Member Functions inherited from CXTPExcelTabCtrlTheme
CXTPExcelTabCtrlTheme ()
Constructs a CXTPExcelTabCtrlTheme object.
~CXTPExcelTabCtrlTheme ()
Destroys a CXTPExcelTabCtrlTheme object, handles cleanup and deallocation.
virtual COLORREF | GetTabBackColor (CXTPTcbItem *pTcbItem) const
This member function gets an RGB value that represents the background color of the tab.
virtual COLORREF | GetTabTextColor (CXTPTcbItem *pTcbItem) const
This member function gets an RGB value that represents the text color of the tab.
virtual COLORREF | GetSelTabBackColor (CXTPTcbItem *pTcbItem) const
This member function gets an RGB value that represents the background color for selected tabs.
virtual COLORREF | GetSelTabTextColor (CXTPTcbItem *pTcbItem) const
This member function gets an RGB value that represents the text color for selected tabs.
- Public Member Functions inherited from CXTPControlTheme
CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme | GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlTheme
static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPExcelTabCtrlTheme
CXTPPaintManagerColor | m_clr3DFace
An RGB value that represents the normal tab face color.
CXTPPaintManagerColor | m_clr3DFacePushed
An RGB value for pushed background color.
CXTPPaintManagerColor | m_clr3DFaceHilite
An RGB value for highlighted background color.
CXTPPaintManagerColor | m_clrBtnText
An RGB value that represents the tab outline color.
CXTPPaintManagerColor | m_clrBtnTextGray
An RGB value for disabled text color.
CXTPPaintManagerColor | m_clrBtnTextPushed
An RGB value for highlighted text color.
CXTPPaintManagerColor | m_clrBtnTextHilite
An RGB value for pushed text color.
CXTPPaintManagerColor | m_clrWindow
An RGB value that represents the selected tab face color.
CXTPPaintManagerColor | m_clrWindowText
An RGB value that represents the tab text color.
CXTPPaintManagerColor | m_clr3DHilight
An RGB value that represents the tab highlight color.
CXTPPaintManagerColor | m_clr3DShadow
An RGB value that represents the tab shadow color.
CXTPPaintManagerColor | m_clrBorder3DHilite
An RGB value for 3D border highlight color.
CXTPPaintManagerColor | m_clrBorder3DShadow
An RGB value for 3D border shadow color.
- Protected Attributes inherited from CXTPControlTheme
XTPControlTheme | m_nTheme
Currently selected theme style index.

Detailed Description

This class is used to draw a CXTPExcelTabCtrlThemeVisualStudio2019 object using Excel Visual Studio 2019 theme.

The documentation for this class was generated from the following file:
  • XTPExcelTabCtrlTheme.h


Toolkit Pro: CXTPExcelTabCtrlThemeVisualStudio2022 Class Reference

Public Member Functions | List of all members
CXTPExcelTabCtrlThemeVisualStudio2022 Class Reference

This class is used to draw a CXTPExcelTabCtrlThemeVisualStudio2022 object using Excel Visual Studio 2022 theme. More...

Inheritance diagram for CXTPExcelTabCtrlThemeVisualStudio2022:
[legend]

Public Member Functions

CXTPExcelTabCtrlThemeVisualStudio2022 ()
Constructs a CXTPExcelTabCtrlThemeVisualStudio2022 object.
- Public Member Functions inherited from CXTPExcelTabCtrlThemeOffice2013
CXTPExcelTabCtrlThemeOffice2013 ()
Constructs a CXTPExcelTabCtrlThemeOffice2013 object.
virtual void | RefreshMetrics (CXTPExcelTabCtrl *pTab)
This member function is called by the theme manager to refresh the visual styles used by each component's theme.
virtual int | DrawTab (CDC *pDC, CXTPExcelTabCtrl *pTabCtrl, const CPoint &pt, bool bSelected, CXTPTcbItem *pTcbItem)
This member function will draw a tab to the device context specified by 'pDC'.
virtual void | DrawButtonBack (CDC *pDC, CRect &rect, const CXTPExcelTabCtrlButtonState &state)
Call this member function to draw the background of the button.
virtual void | DrawButton (CDC *pDC, CXTPExcelTabCtrl *pTabCtrl, const CXTPExcelTabCtrlButtonState &state)
This member function is used by the flat tab control to draw an arrow button to the device context specified by 'pDC'.
virtual void | FillBackground (CDC *pDC, CRect &rect, BOOL bBottom)
This member function is called to fill the background area for the tab control.
virtual void | FillTabsBackground (CDC *pDC, int cx, int cy)
This member function is called to fill the background area that is occupied by the tab strip.
virtual void | DrawGripper (CDC *pDC, CRect rect)
This member function will draw the horizontal sizing gripper at a specified location.
- Public Member Functions inherited from CXTPExcelTabCtrlTheme
CXTPExcelTabCtrlTheme ()
Constructs a CXTPExcelTabCtrlTheme object.
~CXTPExcelTabCtrlTheme ()
Destroys a CXTPExcelTabCtrlTheme object, handles cleanup and deallocation.
virtual COLORREF | GetTabBackColor (CXTPTcbItem *pTcbItem) const
This member function gets an RGB value that represents the background color of the tab.
virtual COLORREF | GetTabTextColor (CXTPTcbItem *pTcbItem) const
This member function gets an RGB value that represents the text color of the tab.
virtual COLORREF | GetSelTabBackColor (CXTPTcbItem *pTcbItem) const
This member function gets an RGB value that represents the background color for selected tabs.
virtual COLORREF | GetSelTabTextColor (CXTPTcbItem *pTcbItem) const
This member function gets an RGB value that represents the text color for selected tabs.
- Public Member Functions inherited from CXTPControlTheme
CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme | GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlTheme
static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPExcelTabCtrlTheme
CXTPPaintManagerColor | m_clr3DFace
An RGB value that represents the normal tab face color.
CXTPPaintManagerColor | m_clr3DFacePushed
An RGB value for pushed background color.
CXTPPaintManagerColor | m_clr3DFaceHilite
An RGB value for highlighted background color.
CXTPPaintManagerColor | m_clrBtnText
An RGB value that represents the tab outline color.
CXTPPaintManagerColor | m_clrBtnTextGray
An RGB value for disabled text color.
CXTPPaintManagerColor | m_clrBtnTextPushed
An RGB value for highlighted text color.
CXTPPaintManagerColor | m_clrBtnTextHilite
An RGB value for pushed text color.
CXTPPaintManagerColor | m_clrWindow
An RGB value that represents the selected tab face color.
CXTPPaintManagerColor | m_clrWindowText
An RGB value that represents the tab text color.
CXTPPaintManagerColor | m_clr3DHilight
An RGB value that represents the tab highlight color.
CXTPPaintManagerColor | m_clr3DShadow
An RGB value that represents the tab shadow color.
CXTPPaintManagerColor | m_clrBorder3DHilite
An RGB value for 3D border highlight color.
CXTPPaintManagerColor | m_clrBorder3DShadow
An RGB value for 3D border shadow color.
- Protected Attributes inherited from CXTPControlTheme
XTPControlTheme | m_nTheme
Currently selected theme style index.

Detailed Description

This class is used to draw a CXTPExcelTabCtrlThemeVisualStudio2022 object using Excel Visual Studio 2022 theme.

The documentation for this class was generated from the following file:
  • XTPExcelTabCtrlTheme.h


Toolkit Pro: CXTPExcludedMemberPadding< Type > Class Template Reference

List of all members
CXTPExcludedMemberPadding< Type > Class Template Reference

The CXTPExcludedMemberPadding type is used for declaring padding members for the members that were excluded by conditional compilation in order to preserve the layout of the compiled classes. More...

Inheritance diagram for CXTPExcludedMemberPadding< Type >:
[legend]

Detailed Description

template<class Type>
class CXTPExcludedMemberPadding< Type >

The CXTPExcludedMemberPadding type is used for declaring padding members for the members that were excluded by conditional compilation in order to preserve the layout of the compiled classes.

The documentation for this class was generated from the following file:
  • XTPSystemHelpers.h


Toolkit Pro: CXTPExpandButtonPart Class Reference

Public Member Functions | List of all members
CXTPExpandButtonPart Class Reference

This class implements Expand button part of the ScrollDateBar. More...

Inheritance diagram for CXTPExpandButtonPart:
[legend]

Public Member Functions

virtual void | Draw (CDC *pDC)
This member function is used to draw the part content utilizing the specified device context.
virtual void | AdjustLayout (CDC *pDC, const CRect &rcRect)
This member function is used to adjust the object's layout depending on the provided bounding rectangle.
- Public Member Functions inherited from CXTPCalendarCaptionBarThemePart
CXTPCalendarCaptionBarThemePart (CXTPCalendarCaptionBarTheme *pTheme, int nPartID)
Default object constructor.
virtual | ~CXTPCalendarCaptionBarThemePart ()
Default object destructor.
virtual void | RefreshMetrics ()
Performs refreshing of graphical related parameters from system settings.
virtual void | Redraw (BOOL bUpdateNow=FALSE)
This member function initiates the CalendarCaptionBar control's redrawing.
virtual BOOL | HitTest (const CPoint &pt) const
This member function is used to determine is the specified point over visible object rectangle.
virtual CXTPCalendarCaptionBarTheme * | GetTheme () const
This member function is used to obtain pointer to parent CXTPCalendarCaptionBarTheme object.
virtual XTPCalendarTheme | GetPaintTheme () const
This member function is used to obtain current paint theme.
virtual int | GetPartID () const
This member function is used to obtain an object identifier.
virtual CRect | GetRect () const
This member function is used to obtain an object rectangle.
virtual CString | GetText () const
This member function is used to obtain an object text.
virtual void | SetText (LPCTSTR pcszText)
This member function is used to set object text.
virtual BOOL | IsVisible () const
This member function is used to get is part object visible.
virtual void | SetVisible (BOOL bVisible)
This member function is used to set visible object's state.
virtual int | GetCheck () const
This member function is used to get checked state.
virtual void | SetCheck (int nCheck)
This member function is used to set checked state.
int | GetState () const
This member function is used to get object state (flags from CXTPCalendarCaptionBarThemePart::EStates enum).
virtual void | SetState (int nState)
This member function is used to set object state as set of flags from CXTPCalendarCaptionBarThemePart::EStates enum.
virtual COLORREF | GetTextColor ()
This member function is used to get object text color.
CXTPCalendarCaptionBarPaintManager * | GetPaintManager () const
Gets the paint manager.
virtual void | OnMouseMove (UINT nFlags, CPoint point)
This member function is used to processes mouse movement events.
virtual BOOL | OnLButtonDown (UINT nFlags, CPoint point)
This member function is used to process left mouse button down events.
virtual BOOL | OnLButtonUp (UINT nFlags, CPoint point)
This member function is used to process left mouse button up events.
- Public Member Functions inherited from CXTPCalendarWMHandler
CXTPCalendarWMHandler ()
Default object constructor.
virtual int | GetChildHandlersCount () const
This member function is used to obtain the number of CXTPCalendarWMHandler elements in the descendant handlers collection.
virtual CXTPCalendarWMHandler * | GetChildHandlerAt (int nIndex) const
Call this method to get a handler object at the specified numeric index.
virtual BOOL | OnLButtonDblClk (UINT nFlags, CPoint point)
This member function is used to process left mouse button double click events.
virtual void | OnChar (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process keyboard events.
virtual void | OnKeyDown (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process key-down keyboard events.
virtual void | OnKeyUp (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process key-up keyboard events.
virtual BOOL | OnSysKeyDown (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process key-up keyboard events.
virtual BOOL | OnTimer (UINT_PTR uTimerID)
The framework calls this member function after each interval specified in the SetTimer member function.
virtual BOOL | OnWndMsg (UINT message, WPARAM wParam, LPARAM lParam, LRESULT *pResult)
This method is called by framework after default message processing.
virtual void | OnPostAdjustLayout ()
This member function is used to perform additional adjustments in some kinds of views.
virtual void | OnBeforeDestroy ()
This member function is called by the framework before destroying the view.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPCalendarCaptionBarThemePart
CXTPPaintManagerColor | m_clrTextColor
Store the object's text color.
CRect | m_rcRect
Store a Part rectangle.
int | m_nState
Store a Part state.
CString | m_strText
Store a Part text.
- Protected Attributes inherited from CXTPCalendarCaptionBarThemePart
CXTPCalendarCaptionBarTheme * | m_pTheme
Store pointer to a parent theme object.
int | m_nPartID
Store a Part ID.
BOOL | m_bVisible
Store a Part visible state.

Detailed Description

This class implements Expand button part of the ScrollDateBar.

See also
CXTPCalendarCaptionBarThemePart

Member Function Documentation

◆ AdjustLayout()

virtual void AdjustLayout | ( | CDC * | pDC,
 |  | const CRect & | rcRect )
 virtual

This member function is used to adjust the object's layout depending on the provided bounding rectangle.

Parameters
pDC | Pointer to a valid device context (may be NULL).
rcRect | A CRect object containing the dimensions of the bounding rectangle for this part.

Reimplemented from CXTPCalendarCaptionBarThemePart.

◆ Draw()

virtual void Draw ( CDC * pDC )
virtual

This member function is used to draw the part content utilizing the specified device context.

Parameters
pDC Pointer to a valid device context.

Reimplemented from CXTPCalendarCaptionBarThemePart.

The documentation for this class was generated from the following file:
  • XTPCalendarCaptionBarThemePart.h


Toolkit Pro: CXTPEyeDropper Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPEyeDropper Class Reference

Creates an eye dropper control that can be used to select any color that is displayed anywhere on the screen. More...

Public Member Functions

CXTPEyeDropper ()
Constructs a CXTPEyeDropper object.
virtual | ~CXTPEyeDropper ()
Destroys a CXTPEyeDropper object, handles cleanup and deallocation.
virtual BOOL | Create (DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID)
Call this member function to create an eye dropper control.
void | SetClipboard (BOOL bSetClipboard)
Call this member function to enable/disable setting the RGB color value as text on the Windows clipboard.
void | ShowPreview (BOOL bShowPreview)
Call this member function to enable/disable the display for the color preview window.

Protected Member Functions

virtual BOOL | Init ()
This member function is called by the CXTPEyeDropper class to perform initialization when the window is created or sub-classed.
virtual void | DrawDropper (CDC *pDC)
Used by the eye dropper control to draw the eye dropper box.
virtual void | DrawColor (CDC *pDC)
Used by the eye dropper control to draw the color preview box.
BOOL | SetClipboardText (LPCTSTR lpszClipText)
Used by the eye dropper control to place RGB color values as text on the Windows clipboard.
CRect | GetColorRect ()
Used by the eye dropper control to determine the rectangle for drawing the color preview box.
CRect | GetDropperRect ()
Used by the eye dropper control to determine the rectangle for drawing the eye dropper box.

Protected Attributes

int | m_nPadding
Size of the gap between the eye dropper and preview display.
CSize | m_icoSize
Size of the preview icon.
BOOL | m_bPreInit
TRUE when initializing from PreSubclassWindow.
BOOL | m_bSetClipboard
TRUE to set the selected RGB color on the clipboard.
BOOL | m_bShowPreview
TRUE to show color preview.
HICON | m_hIcon
Handle to the eye dropper icon.
HCURSOR | m_hCurEyeDropper
Handle to the eye dropper cursor.
HCURSOR | m_hCurPrevious
Handle to the previous cursor.
COLORREF | m_color
Selected RGB color value.

Detailed Description

Creates an eye dropper control that can be used to select any color that is displayed anywhere on the screen.

To use the eye dropper control, click and hold the left mouse button and move it over the screen. The color that is currently under the cursor will be selected as the new color.

Member Function Documentation

◆ Create()

virtual BOOL Create | ( | DWORD | dwStyle,
 |  | const RECT & | rect,
 |  | CWnd * | pParentWnd,
 |  | UINT | nID )
 virtual

Call this member function to create an eye dropper control.

Parameters
dwStyle | Specifies the window style attributes.
rect | The size and position of the window, in client coordinates of pParentWnd.
pParentWnd | The parent window.
nID | The ID of the child window.
Returns
TRUE if successful, otherwise FALSE.

◆ DrawColor()

virtual void DrawColor ( CDC * pDC )
protectedvirtual

Used by the eye dropper control to draw the color preview box.

Parameters
pDC Pointer to a valid device context for the eye dropper window.

◆ DrawDropper()

virtual void DrawDropper ( CDC * pDC )
protectedvirtual

Used by the eye dropper control to draw the eye dropper box.

Parameters
pDC Pointer to a valid device context for the eye dropper window.

◆ GetColorRect()

CRect GetColorRect ( )
protected

Used by the eye dropper control to determine the rectangle for drawing the color preview box.

Returns
A CRect object indicating the size in client coordinates.

◆ GetDropperRect()

CRect GetDropperRect ( )
protected

Used by the eye dropper control to determine the rectangle for drawing the eye dropper box.

Returns
A CRect object indicating the size in client coordinates.

◆ Init()

virtual BOOL Init ( )
protectedvirtual

This member function is called by the CXTPEyeDropper class to perform initialization when the window is created or sub-classed.

Returns
TRUE if the window was successfully initialized, otherwise FALSE.

◆ SetClipboard()

void SetClipboard ( BOOL bSetClipboard )

Call this member function to enable/disable setting the RGB color value as text on the Windows clipboard.

Parameters
bSetClipboard TRUE to enable setting the RGB color value as text on the Windows clipboard.

◆ SetClipboardText()

BOOL SetClipboardText ( LPCTSTR lpszClipText )
protected

Used by the eye dropper control to place RGB color values as text on the Windows clipboard.

Parameters
lpszClipText A NULL-terminated string representing the current RGB color value.
Returns
TRUE if successful, otherwise FALSE.

◆ ShowPreview()

void ShowPreview ( BOOL bShowPreview )

Call this member function to enable/disable the display for the color preview window.

The color preview window is a rectangle that is displayed to the right of the eye dropper that displays the currently selected color.

Parameters
bShowPreview TRUE to enable the display for the color preview window.
The documentation for this class was generated from the following file:
  • XTPColorDialog.h


Toolkit Pro: CXTPFlowGraphConnection Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPFlowGraphConnection Class Reference

Represents a connection. More...

Inheritance diagram for CXTPFlowGraphConnection:
[legend]

Public Member Functions

CXTPFlowGraphConnection ()
Constructs a CXTPFlowGraphConnection object.
virtual | ~CXTPFlowGraphConnection ()
Destroys a CXTPFlowGraphConnection object, handles cleanup and deallocation.
virtual void | SetInputPoint (CXTPFlowGraphConnectionPoint *pPoint)
Sets the input connection point that this connection line is connected to.
CXTPFlowGraphConnectionPoint * | GetInputPoint () const
Gets the input connection point that this connection line is connected to.
virtual void | SetOutputPoint (CXTPFlowGraphConnectionPoint *pPoint)
Sets the output connection point that this connection line is connected to.
CXTPFlowGraphConnectionPoint * | GetOutputPoint () const
Gets the output connection point that this connection line is connected to.
void | SetControlPoint (CPoint pt)
Sets the middle point of the connection (this is also what happens when a connection is dragged by the mouse).
CPoint | GetControlPoint () const
Gets the middle point of the connection (this is also what happens when a connection is dragged by the mouse).
void | SetCaption (LPCTSTR lpszCaption)
Sets the caption for the connection.
CString | GetCaption () const
Gets the caption of the connection.
void | SetTooltip (LPCTSTR lpszTooltip)
Sets the tooltip for this connection.
CString | GetTooltip () const
Gets the tooltip of this connection.
void | SetColor (COLORREF clr)
Sets the color for the connection line.
COLORREF | GetColor () const
Gets the color of the connection line.
void | SetStyle (int nStyle)
Sets the style for the connector.
int | GetStyle () const
Gets the style of the connector.
void | SetWidth (int nWidth)
Sets the width for the connector line.
int | GetWidth () const
Gets the width of the connector line.
void | SetDashed (BOOL bDashed)
Enables/disables dashed style for the connector line.
BOOL | GetDashed () const
Determines if dashed style is enabled/disabled for the connector line.
CRect | GetBoundingRect ()
Gets the bounding rectangle for this element.
virtual BOOL | PtInRect (POINT pt)
Determines if the specified point is within the connection.
CXTPFlowGraphNode * | GetInputNode () const
Gets the input Node that this connection line is connected to.
CXTPFlowGraphNode * | GetOutputNode () const
Gets the output Node that this connection line is connected to.
CXTPFlowGraphControl * | GetControl () const
Gets a reference to the parent FlowGraph control.
CXTPFlowGraphPage * | GetPage () const
Gets a reference to the page that this connection belongs to.
virtual void | RecalcLayout (CXTPFlowGraphDrawContext *pDC)
Call this method to recalculate the size and layout of the connection.
void | Remove ()
Remove/delete this connection from its parent node.
virtual void | OnRemoved ()
This method is called when the connection is removed.
virtual void | DoPropExchange (CXTPPropExchange *pPX)
Call this member function to store/load a connection using the specified data object.
- Public Member Functions inherited from CXTPFlowGraphElement
CXTPFlowGraphElement ()
Constructs a CXTPFlowGraphElement object.
virtual | ~CXTPFlowGraphElement ()
Destroys a CXTPFlowGraphElement object, handles cleanup and deallocation.
BOOL | IsSelected () const
Determines if the element is currently selected.
void | OnGraphChanged ()
This method is called when the flow graph layout is changed.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

virtual void RestoreConnection ()
Used internally to restore the connection when loaded from a resource.

Protected Attributes

CXTPFlowGraphPage * | m_pPage
The page that this connection belongs to.
CXTPFlowGraphConnectionPoint * | m_pInputPoint
The input ConnectionPoint that this connection line is connected to.
CXTPFlowGraphConnectionPoint * | m_pOutputPoint
The output ConnectionPoint that this connection line is connected to.
CXTPFlowGraphConnection * | m_pNextVisibleConnection
Reference to the next visible connection.
CPoint | m_ptInputPoint
Stores the coordinates of the Input connection point (if any), also is used internally for drag/drop.
CPoint | m_ptOutputPoint
Stores the coordinates of the Output connection point (if any), also is used internally for drag/drop.
CPoint | m_ptControlPoint
Middle point for the connection.
CString | m_strCaption
The caption of the connection.
CString | m_strTooltip
Tooltip text for the item.
CString | m_strTag
A tag property to define a connection.
COLORREF | m_clrConnection
Color of the connection.
int | m_nStyle
Style of the connection.
int | m_nInputId
Used internally to store the ID of the Input connection point.
int | m_nOutputId
Used internally to store the ID of the Output connection point.
CRect | m_rcBoundingRect
The bounding rectangle for this element.
Gdiplus::GraphicsPath * | m_pPath
Path to the GDI Plus graphics used to draw the conneciton.
- Protected Attributes inherited from CXTPFlowGraphElement
BOOL | m_bSelected
Specifies whether the element is selected.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPFlowGraphElement
BOOL | m_bDirty
Internally used to tell the flow graph that the element has changed.

Detailed Description

Represents a connection.

Connections are the lines that connect two connection points.

Member Function Documentation

◆ DoPropExchange()

virtual void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Call this member function to store/load a connection using the specified data object.

Parameters
pPX Source/destination CXTPPropExchange data object reference.

This member function is used to store/load connection data to/from storage.

◆ GetBoundingRect()

CRect GetBoundingRect ( )

Gets the bounding rectangle for this element.

Returns
The bounding rectangle for this element.

◆ GetCaption()

AFX_INLINE CString GetCaption ( ) const
virtual

Gets the caption of the connection.

The connection's caption is not visible in the graph. It can be used like a tag property.

Returns
The caption of the connection.

Implements CXTPFlowGraphElement.

◆ GetColor()

AFX_INLINE COLORREF GetColor ( ) const

Gets the color of the connection line.

Returns
The color of the connection line.

◆ GetControl()

CXTPFlowGraphControl * GetControl ( ) const
virtual

Gets a reference to the parent FlowGraph control.

Returns
A reference to the parent FlowGraph control.

Implements CXTPFlowGraphElement.

◆ GetControlPoint()

AFX_INLINE CPoint GetControlPoint ( ) const

Gets the middle point of the connection (this is also what happens when a connection is dragged by the mouse).

This is the point where the little circle glyph is drawn along the spline/line (connection). When a connection is clicked and dragged with the mouse, a small circle "point" is drawn to indicate where the line was clicked and how much it has been dragged.

Returns
The middle point for the connection.

◆ GetDashed()

AFX_INLINE BOOL GetDashed ( ) const

Determines if dashed style is enabled/disabled for the connector line.

Returns
TRUE if dashed style is enabled for the connector line, FALSE if it is disabled.

◆ GetInputNode()

CXTPFlowGraphNode * GetInputNode ( ) const

Gets the input Node that this connection line is connected to.

Returns
Reference to the input Node that this connection line is connected to.

◆ GetInputPoint()

AFX_INLINE CXTPFlowGraphConnectionPoint * GetInputPoint ( ) const

Gets the input connection point that this connection line is connected to.

Returns
Reference to the input connection point that this connection line is connected to.

◆ GetOutputNode()

CXTPFlowGraphNode * GetOutputNode ( ) const

Gets the output Node that this connection line is connected to.

Returns
Reference to the output Node that this connection line is connected to.

◆ GetOutputPoint()

AFX_INLINE CXTPFlowGraphConnectionPoint * GetOutputPoint ( ) const

Gets the output connection point that this connection line is connected to.

Returns
Reference to the output connection point that this connection line is connected to.

◆ GetPage()

AFX_INLINE CXTPFlowGraphPage * GetPage ( ) const
virtual

Gets a reference to the page that this connection belongs to.

Returns
A reference to the page that this connection belongs to.

Implements CXTPFlowGraphElement.

◆ GetStyle()

AFX_INLINE int GetStyle ( ) const

Gets the style of the connector.

This will return a value from the XTPFlowGraphConnectorType enumeration.

Returns
The style of the connector.

◆ GetTooltip()

AFX_INLINE CString GetTooltip ( ) const

Gets the tooltip of this connection.

This is the text that is displayed when the mouse is hovered over the connection.

Returns
The tooltip of this connection.

◆ GetWidth()

AFX_INLINE int GetWidth ( ) const

Gets the width of the connector line.

Returns
The width of the connector line.

◆ PtInRect()

virtual BOOL PtInRect ( POINT pt )
virtual

Determines if the specified point is within the connection.

Parameters
pt Point to test.
Returns
TRUE if the point is located within the connection, otherwise FALSE.

◆ RecalcLayout()

virtual void RecalcLayout ( CXTPFlowGraphDrawContext * pDC )
virtual

Call this method to recalculate the size and layout of the connection.

Parameters
pDC Reference to a valid device context.

◆ RestoreConnection()

virtual void RestoreConnection ( )
protectedvirtual

Used internally to restore the connection when loaded from a resource.

This is used in DoPropExchange.

◆ SetCaption()

void SetCaption ( LPCTSTR lpszCaption )
virtual

Sets the caption for the connection.

Parameters
lpszCaption Caption for the connection.

Implements CXTPFlowGraphElement.

◆ SetColor()

AFX_INLINE void SetColor ( COLORREF clr )

Sets the color for the connection line.

Parameters
clr Color for the connection line.

◆ SetControlPoint()

void SetControlPoint ( CPoint pt )

Sets the middle point of the connection (this is also what happens when a connection is dragged by the mouse).

Parameters
pt Point to use as the middle point in the connection.

This sets the point where the little circle glyph is drawn along the spline/line (connection). When a connection is clicked and dragged with the mouse, a small circle "point" is drawn to indicate where the line was clicked and how much it has been dragged.

◆ SetDashed()

AFX_INLINE void SetDashed ( BOOL bDashed )

Enables/disables dashed style for the connector line.

Parameters
bDashed TRUE to enable dashed style, FALSE to disable.

◆ SetInputPoint()

virtual void SetInputPoint ( CXTPFlowGraphConnectionPoint * pPoint )
virtual

Sets the input connection point that this connection line is connected to.

Parameters
pPoint Reference to the connection point to connect to.

◆ SetOutputPoint()

virtual void SetOutputPoint ( CXTPFlowGraphConnectionPoint * pPoint )
virtual

Sets the output connection point that this connection line is connected to.

Parameters
pPoint Reference to the connection point to connect to.

◆ SetStyle()

AFX_INLINE void SetStyle ( int nStyle )

Sets the style for the connector.

Parameters
nStyle Style for the connector. This will be a value from the XTPFlowGraphConnectorType enumeration.

Use a value from the XTPFlowGraphConnectorType enumeration to set the style for the connector.

◆ SetTooltip()

AFX_INLINE void SetTooltip ( LPCTSTR lpszTooltip )

Sets the tooltip for this connection.

Parameters
lpszTooltip Tooltip for this connection.

This is the text that is displayed when the mouse is hovered over the connection.

◆ SetWidth()

AFX_INLINE void SetWidth ( int nWidth )

Sets the width for the connector line.

Parameters
nWidth Width for the connector line.

Member Data Documentation

◆ m_nStyle

int m_nStyle
protected

Style of the connection.

It uses a value from the XTPFlowGraphConnectorType enumeration.

◆ m_ptControlPoint

CPoint m_ptControlPoint
protected

Middle point for the connection.

This is the point that is set a connection is clicked and dragged by a mouse.

The documentation for this class was generated from the following file:
  • XTPFlowGraphConnection.h


Toolkit Pro: CXTPFlowGraphConnectionPoint Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPFlowGraphConnectionPoint Class Reference

Represents a connection point for a node. More...

Inheritance diagram for CXTPFlowGraphConnectionPoint:
[legend]

Public Member Functions

virtual | ~CXTPFlowGraphConnectionPoint ()
Destroys a CXTPFlowGraphConnectionPoint object, handles cleanup and deallocation.
void | SetCaption (LPCTSTR lpszCaption)
Sets the caption of the connection point.
CString | GetCaption () const
Gets the caption of the connection point.
void | SetName (LPCTSTR lpszName)
Sets the name of the connection point.
CString | GetName () const
Gets the name of the connection point.
void | SetTooltip (LPCTSTR lpszTooltip)
Sets the tooltip for this connection point.
CString | GetTooltip () const
Gets the tooltip for this connection point.
void | SetColor (COLORREF clr)
Sets the color for the connection point.
COLORREF | GetColor () const
Gets the color of the connection point.
void | SetStyle (int nStyle)
Reserved for future use.
int | GetStyle () const
Reserved for future use.
XTPFlowGraphConnectionPointType | GetType () const
Gets whether the flow graph connection will have any connection points (input/output).
void | SetType (XTPFlowGraphConnectionPointType type)
Specifies whether the flow graph connection will have any connection points (input/output).
CRect | GetRect () const
Gets the bounding rectangle for this element.
void | SetRect (const CRect &rect)
Sets the bounding rectangle for this element.
void | SetID (int nId)
Sets the ID used to identify this connection point.
int | GetID () const
Gets the ID used to identify this connection point.
BOOL | IsLocked () const
Gets whether the connection's points are locked.
void | SetLocked (BOOL bLocked=TRUE)
Specifies whether the connection's points should be locked.
int | GetMaxConnections () const
Gets the maximum number of connections (connection lines) that the connection point can accept.
void | SetMaxConnections (int nMaxConnections)
Specifies the maximum number of connections (connection lines) that the connection point can accept.
int | GetConnectionsCount () const
Gets the number of connection lines connected to this connection point.
int | GetInputConnectionsCount () const
Gets the number of input connection lines connected to this connection point.
CXTPFlowGraphConnection * | GetInputConnectionAt (int nIndex) const
Retrieves the input connection associated with a point by its index.
int | GetOutputConnectionsCount () const
Gets the number of output connection lines connected to this connection point.
CXTPFlowGraphConnection * | GetOutputConnectionAt (int nIndex) const
Retrieves the output connection associated with a point by its index.
void | SetImageIndex (int nImageIndex)
Sets the ID of the image to display to the left of the connection point's caption.
int | GetImageIndex () const
Gets the ID of the image to display to the left of the connection point's caption.
CXTPMarkupUIElement * | GetMarkupUIElement () const
Call this method to get the markup element that renders the caption of the control.
CXTPFlowGraphNode * | GetNode () const
Gets a reference to the Node that this connection point belongs to.
CXTPFlowGraphPage * | GetPage () const
Gets a reference to the page that this connection point belongs to.
CXTPFlowGraphControl * | GetControl () const
Gets a reference to the parent FlowGraph control.
CXTPFlowGraphImage * | GetImage () const
Gets the image to display to the left of the connection point's caption.
void | OnGraphChanged ()
This method is called when the flow graph's layout is changed.
virtual void | DoPropExchange (CXTPPropExchange *pPX)
Call this member function to store/load a connection point using the specified data object.
virtual BOOL | HitTestConnectionArea (CPoint point) const
Determines if the specified point is within the connection area.
- Public Member Functions inherited from CXTPFlowGraphElement
CXTPFlowGraphElement ()
Constructs a CXTPFlowGraphElement object.
virtual | ~CXTPFlowGraphElement ()
Destroys a CXTPFlowGraphElement object, handles cleanup and deallocation.
BOOL | IsSelected () const
Determines if the element is currently selected.
void | OnGraphChanged ()
This method is called when the flow graph layout is changed.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

CXTPFlowGraphConnectionPoint ()
Constructs a CXTPFlowGraphConnectionPoint object.
virtual void OnRemoved ()
This method is called when the point is removed.

Protected Attributes

CXTPFlowGraphNode * | m_pNode
Reference to the Node that this connection point belongs to.
CString | m_strCaption
Caption of the connection point.
CString | m_strName
Unique name of the connection point.
CString | m_strTooltip
Tooltip text for the item.
COLORREF | m_clrPoint
Color of the connection point.
XTPFlowGraphConnectionPointType | m_nType
Type of connection point; specifies whether the FlowGraphConnection will have any connection points (input/output).
int | m_nStyle
Reserved for future use.
int | m_nId
ID of the connection point.
BOOL | m_bLocked
Specifies if the connection point is locked.
BOOL | m_bMarkupPoint
Specifies if the connection point is actually an XML-markup point-row.
BOOL | m_bInputOutPair
for the undo manager.
int | m_nMaxConnections
The maximum number of connections (connection lines) that the connection point can accept.
int | m_nImageIndex
ID of the image to display to the left of the connection point's caption.
- Protected Attributes inherited from CXTPFlowGraphElement
BOOL | m_bSelected
Specifies whether the element is selected.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPFlowGraphElement
BOOL | m_bDirty
Internally used to tell the flow graph that the element has changed.

Detailed Description

Represents a connection point for a node.

Connection points are added to a Node and can have no input points, only input or output points, or both.

Member Function Documentation

◆ DoPropExchange()

virtual void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Call this member function to store/load a connection point using the specified data object.

Parameters
pPX Source/destination CXTPPropExchange data object reference.

This member function is used to store/load connection point data to/from storage.

◆ GetCaption()

AFX_INLINE CString GetCaption ( ) const
virtual

Gets the caption of the connection point.

Returns
The caption of the connection point.

Implements CXTPFlowGraphElement.

◆ GetColor()

AFX_INLINE COLORREF GetColor ( ) const

Gets the color of the connection point.

Returns
The color of the connection point.

◆ GetConnectionsCount()

AFX_INLINE int GetConnectionsCount ( ) const

Gets the number of connection lines connected to this connection point.

Returns
The number of connection lines connected to this connection point.

◆ GetControl()

CXTPFlowGraphControl * GetControl ( ) const
virtual

Gets a reference to the parent FlowGraph control.

Returns
A reference to the parent FlowGraph control.

Implements CXTPFlowGraphElement.

◆ GetID()

AFX_INLINE int GetID ( ) const

Gets the ID used to identify this connection point.

Returns
The ID used to identify this connection point.

◆ GetImage()

CXTPFlowGraphImage * GetImage ( ) const

Gets the image to display to the left of the connection point's caption.

Returns
The image to display to the left of the connection point's caption.

◆ GetImageIndex()

AFX_INLINE int GetImageIndex ( ) const

Gets the ID of the image to display to the left of the connection point's caption.

Returns
The ID of the image to display to the left of the connection point's caption.

◆ GetInputConnectionAt()

AFX_INLINE CXTPFlowGraphConnection * GetInputConnectionAt ( int nIndex ) const

Retrieves the input connection associated with a point by its index.

Parameters
nIndex Index of the point whose input connection must be retrieved.
Returns
A pointer to the input connection associated with the point.

◆ GetInputConnectionsCount()

AFX_INLINE int GetInputConnectionsCount ( ) const

Gets the number of input connection lines connected to this connection point.

Returns
The number of input connection lines connected to this connection point.

◆ GetMarkupUIElement()

CXTPMarkupUIElement * GetMarkupUIElement ( ) const

Call this method to get the markup element that renders the caption of the control.

Returns
A pointer to a CXTPMarkupUIElement object.

◆ GetMaxConnections()

AFX_INLINE int GetMaxConnections ( ) const

Gets the maximum number of connections (connection lines) that the connection point can accept.

Returns
The maximum number of connections (connection lines) that the connection point can accept.

◆ GetName()

AFX_INLINE CString GetName ( ) const

Gets the name of the connection point.

You can use FindConnectionPoint to search for a connection point by name.

Returns
The name of the connection point.

◆ GetNode()

AFX_INLINE CXTPFlowGraphNode * GetNode ( ) const

Gets a reference to the Node that this connection point belongs to.

Returns
A reference to the Node that this connection point belongs to.

◆ GetOutputConnectionAt()

AFX_INLINE CXTPFlowGraphConnection * GetOutputConnectionAt ( int nIndex ) const

Retrieves the output connection associated with a point by its index.

Parameters
nIndex Index of the point whose output connection must be retrieved.
Returns
A pointer to the output connection associated with the point.

◆ GetOutputConnectionsCount()

AFX_INLINE int GetOutputConnectionsCount ( ) const

Gets the number of output connection lines connected to this connection point.

Returns
The number of output connection lines connected to this connection point.

◆ GetPage()

CXTPFlowGraphPage * GetPage ( ) const
virtual

Gets a reference to the page that this connection point belongs to.

Returns
A reference to the page that this connection point belongs to.

Implements CXTPFlowGraphElement.

◆ GetRect()

AFX_INLINE CRect GetRect ( ) const

Gets the bounding rectangle for this element.

Returns
The bounding rectangle for this element.

◆ GetStyle()

AFX_INLINE int GetStyle ( ) const

Reserved for future use.

Currently can be used as a "tag" property if needed.

Returns
Current style value.

◆ GetTooltip()

AFX_INLINE CString GetTooltip ( ) const

Gets the tooltip for this connection point.

This is the text that is displayed when the mouse is hovered over the connection point.

Returns
The tooltip for this connection point.

◆ GetType()

AFX_INLINE XTPFlowGraphConnectionPointType GetType ( ) const

Gets whether the flow graph connection will have any connection points (input/output).

An option from FlowGraphConnectionPointType that specifies the included connection points, if any.

Returns
FlowGraphConnectionPointType is used to specify whether a flow graph connection will have any connection points. Connection points are used to make connections between a connection in different nodes.

◆ HitTestConnectionArea()

virtual BOOL HitTestConnectionArea ( CPoint point ) const
virtual

Determines if the specified point is within the connection area.

Parameters
point Point to test.
Returns
TRUE if the specified point is located within the connection area, otherwise FALSE.

◆ IsLocked()

AFX_INLINE BOOL IsLocked ( ) const

Gets whether the connection's points are locked.

Returns
TRUE if the connection's points are locked, FALSE if they can accept connections.

◆ OnGraphChanged()

void OnGraphChanged ( )

This method is called when the flow graph's layout is changed.

This method is called when the page zoom level, page scroll offset, window/Node size, window handle, Node style, Node color, or connection style is changed.

◆ SetCaption()

void SetCaption ( LPCTSTR lpszCaption )
virtual

Sets the caption of the connection point.

Parameters
lpszCaption String caption of the connection point.

Implements CXTPFlowGraphElement.

◆ SetColor()

void SetColor ( COLORREF clr )

Sets the color for the connection point.

Parameters
clr Color for the connection point.

◆ SetID()

AFX_INLINE void SetID ( int nId )

Sets the ID used to identify this connection point.

Parameters
nId New ID used to identify this connection point.

◆ SetImageIndex()

void SetImageIndex ( int nImageIndex )

Sets the ID of the image to display to the left of the connection point's caption.

Parameters
nImageIndex The ID of the image to display to the left of the connection point's caption.

Use the image index to specify the index of the previously loaded image to display next to the connection point's caption.

◆ SetLocked()

AFX_INLINE void SetLocked ( BOOL bLocked = TRUE )

Specifies whether the connection's points should be locked.

Parameters
bLocked TRUE if the connection's points should be locked, FALSE if they should accept connections.

If TRUE, then the connection's points cannot accept a connection line and any connection lines that were added cannot be removed.

◆ SetMaxConnections()

AFX_INLINE void SetMaxConnections ( int nMaxConnections )

Specifies the maximum number of connections (connection lines) that the connection point can accept.

Parameters
nMaxConnections The maximum number of connections (connection lines) that the connection point can accept.

◆ SetName()

void SetName ( LPCTSTR lpszName )

Sets the name of the connection point.

Parameters
lpszName String name of the connection point.

You can use FindConnectionPoint to search for a connection point by name.

◆ SetRect()

AFX_INLINE void SetRect ( const CRect & rect )

Sets the bounding rectangle for this element.

Parameters
rect Bounding rectangle to be set.

◆ SetStyle()

AFX_INLINE void SetStyle ( int nStyle )

Reserved for future use.

Currently can be used as a "tag" property if needed.

Parameters
nStyle Style value.

◆ SetTooltip()

AFX_INLINE void SetTooltip ( LPCTSTR lpszTooltip )

Sets the tooltip for this connection point.

Parameters
lpszTooltip Tooltip for this connection point.

This is the text that is displayed when the mouse is hovered over the connection point.

◆ SetType()

AFX_INLINE void SetType ( XTPFlowGraphConnectionPointType type )

Specifies whether the flow graph connection will have any connection points (input/output).

Parameters
type An option from FlowGraphConnectionPointType that specifies the included connection points.

FlowGraphConnectionPointType is used to specify whether a flow graph connection will have any connection points. Connection points are used to make connections between a connection in different nodes.

Member Data Documentation

◆ m_bLocked

BOOL m_bLocked
protected

Specifies if the connection point is locked.

TRUE if the connection point is locked, FALSE if it can accept connections.

◆ m_nStyle

int m_nStyle
protected

Reserved for future use.

Currently can be used as a "tag" property if needed.

The documentation for this class was generated from the following file:
  • XTPFlowGraphConnectionPoint.h


Toolkit Pro: CXTPFlowGraphConnectionPoints Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPFlowGraphConnectionPoints Class Reference

Represents a collection of connection points for a Node. More...

Inheritance diagram for CXTPFlowGraphConnectionPoints:
[legend]

Public Member Functions

CXTPFlowGraphConnectionPoint * | AddConnectionPoint (CXTPFlowGraphConnectionPoint *pConnectionPoint, int nIndex=-1)
Adds a connection point to the Node.
void | RemoveAll ()
Removes all connection points from the Node.
void | Remove (CXTPFlowGraphConnectionPoint *pConnectionPoint, BOOL bRemovePairs=TRUE)
Removes a specified connection point.
void | RemoveAt (int nIndex, BOOL bRemovePairs=TRUE, BOOL bSkipUndoTask=FALSE)
Removes a specified connection point from the Node's collection of connection points.
int | GetCount () const
Retrieves the total number of connections points for the Node.
CXTPFlowGraphConnectionPoint * | GetAt (int nIndex) const
Retrieves the connection point at the specified index.
CXTPFlowGraphConnectionPoint * | FindConnectionPoint (LPCTSTR lpszName, XTPFlowGraphConnectionPointType type=xtpFlowGraphPointNone) const
Finds and retrieves the specified connection point by searching for the connection point's name.
CXTPFlowGraphConnectionPoint * | FindConnectionPoint (int nId) const
Finds and retrieves the specified connection point.
CXTPFlowGraphConnectionPoint * | FindConnectionPointByCaption (LPCTSTR lpszCaption, XTPFlowGraphConnectionPointType type=xtpFlowGraphPointNone) const
Finds and retrieves the specified connection point by searching for the connection point's caption.
void | DoPropExchange (CXTPPropExchange *pPX)
Call this member function to store/load a collection of connection points using the specified data object.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

CXTPFlowGraphConnectionPoints (CXTPFlowGraphNode *pNode)
Constructs a CXTPFlowGraphConnectionPoints object.
virtual ~CXTPFlowGraphConnectionPoints ()
Destroys a CXTPFlowGraphConnectionPoints object, handles cleanup and deallocation.

Protected Attributes

CXTPFlowGraphNode * | m_pNode
Reference to the node that uses the connection points from this collection.
CArray< CXTPFlowGraphConnectionPoint *, CXTPFlowGraphConnectionPoint * > | m_arrConnectionPoints
Collection of connection points.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

Represents a collection of connection points for a Node.

Connection points are added to a Node and can have no input points, only input or output points, or both.

Constructor & Destructor Documentation

◆ CXTPFlowGraphConnectionPoints()

CXTPFlowGraphConnectionPoints ( CXTPFlowGraphNode * pNode )
protected

Constructs a CXTPFlowGraphConnectionPoints object.

Parameters
pNode Target grpah node object pointer.

Member Function Documentation

◆ AddConnectionPoint()

CXTPFlowGraphConnectionPoint * AddConnectionPoint | ( | CXTPFlowGraphConnectionPoint * | pConnectionPoint,
 |  | int | nIndex = -1 )

Adds a connection point to the Node.

Parameters
pConnectionPoint | Reference to the connection point to add.
nIndex | Point index.
Returns
A reference to the connection point that was just added.

◆ DoPropExchange()

void DoPropExchange ( CXTPPropExchange * pPX )

Call this member function to store/load a collection of connection points using the specified data object.

Parameters
pPX Source/destination CXTPPropExchange data object reference.

This member function is used to store/load a collection of connection points data to/from storage.

◆ FindConnectionPoint() [1/2]

CXTPFlowGraphConnectionPoint * FindConnectionPoint ( int nId ) const

Finds and retrieves the specified connection point.

Parameters
nId ID of the connection point to find.
Returns
A reference to the FlowGraphConnectionPoint if found, otherwise NULL.

◆ FindConnectionPoint() [2/2]

CXTPFlowGraphConnectionPoint * FindConnectionPoint | ( | LPCTSTR | lpszName,
 |  | XTPFlowGraphConnectionPointType | type = xtpFlowGraphPointNone ) const

Finds and retrieves the specified connection point by searching for the connection point's name.

There can be 2 connection points with the same name, but a different type (in & out), so sometimes you should provide a type.

Parameters
lpszName | Name of the connection point to find.
type | Type object pointer.
Returns
A reference to the FlowGraphConnectionPoint if found, otherwise NULL.

◆ FindConnectionPointByCaption()

CXTPFlowGraphConnectionPoint * FindConnectionPointByCaption | ( | LPCTSTR | lpszCaption,
 |  | XTPFlowGraphConnectionPointType | type = xtpFlowGraphPointNone ) const

Finds and retrieves the specified connection point by searching for the connection point's caption.

There can be 2 connection points with the same caption, but a different type (in & out), so sometimes you should provide a type.

Parameters
lpszCaption | Caption of the connection point to find.
type | Type object pointer.
Returns
A reference to the FlowGraphConnectionPoint if found, otherwise NULL.

◆ GetAt()

AFX_INLINE CXTPFlowGraphConnectionPoint * GetAt ( int nIndex ) const

Retrieves the connection point at the specified index.

Parameters
nIndex Index of the desired connection point to retrieve.
Returns
Reference to the connection point at the specified index.

◆ GetCount()

AFX_INLINE int GetCount ( ) const

Retrieves the total number of connections points for the Node.

Returns
The total number of connections points for the Node.

◆ Remove()

void Remove | ( | CXTPFlowGraphConnectionPoint * | pConnectionPoint,
 |  | BOOL | bRemovePairs = TRUE )

Removes a specified connection point.

Parameters
pConnectionPoint | Reference to the connection point to remove.
bRemovePairs | Indicates whether to remove the other connection point with the same name (but different type (in & out)).

◆ RemoveAt()

void RemoveAt | ( | int | nIndex,
 |  | BOOL | bRemovePairs = TRUE,
 |  | BOOL | bSkipUndoTask = FALSE )

Removes a specified connection point from the Node's collection of connection points.

Parameters
bRemovePairs | Indicates whether to remove the other connection
nIndex | Index of the connection point to remove.
bSkipUndoTask | TRUE to skip undo task.
The documentation for this class was generated from the following file:
  • XTPFlowGraphConnectionPoints.h


Toolkit Pro: CXTPFlowGraphConnections Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPFlowGraphConnections Class Reference

Represents a collection of connections for a Node. More...

Inheritance diagram for CXTPFlowGraphConnections:
[legend]

Public Member Functions

void | RemoveAll ()
Removes all connections from the Node.
CXTPFlowGraphConnection * | AddConnection (CXTPFlowGraphConnection *pConnection)
Adds a connection to the Node.
void | Remove (CXTPFlowGraphConnection *pConnection)
Removes the specified connection.
void | RemoveAt (int nIndex)
Removes the specified connection from the Node's collection of connections.
int | GetCount () const
Gets the total number of connections for the Node.
CXTPFlowGraphConnection * | GetAt (int nIndex) const
Retrieves the connection at the specified index.
void | DoPropExchange (CXTPPropExchange *pPX)
Call this member function to store/load a collection of connections using the specified data object.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

CXTPFlowGraphConnections (CXTPFlowGraphPage *pPage)
Constructs a CXTPFlowGraphConnections object.
virtual ~CXTPFlowGraphConnections ()
Destroys a CXTPFlowGraphConnections object, handles cleanup and deallocation.

Protected Attributes

CXTPFlowGraphPage * | m_pPage
Pointer to the page that displays these connections.
CArray< CXTPFlowGraphConnection *, CXTPFlowGraphConnection * > | m_arrConnections
Collection of connections.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

Represents a collection of connections for a Node.

Constructor & Destructor Documentation

◆ CXTPFlowGraphConnections()

CXTPFlowGraphConnections ( CXTPFlowGraphPage * pPage )
protected

Constructs a CXTPFlowGraphConnections object.

Parameters
pPage Target graph page object pointer.

Member Function Documentation

◆ AddConnection()

CXTPFlowGraphConnection * AddConnection ( CXTPFlowGraphConnection * pConnection )

Adds a connection to the Node.

Parameters
pConnection Reference to the connection to add.
Returns
A reference to the connection that was just added.

◆ DoPropExchange()

void DoPropExchange ( CXTPPropExchange * pPX )

Call this member function to store/load a collection of connections using the specified data object.

Parameters
pPX Source/destination CXTPPropExchange data object reference.

This member function is used to store/load a collection of connections data to/from storage.

◆ GetAt()

AFX_INLINE CXTPFlowGraphConnection * GetAt ( int nIndex ) const

Retrieves the connection at the specified index.

Parameters
nIndex Index of the desired connection to retrieve.
Returns
Reference to the connection at the specified index.

◆ GetCount()

AFX_INLINE int GetCount ( ) const

Gets the total number of connections for the Node.

Returns
The total number of connections for the Node.

◆ Remove()

void Remove ( CXTPFlowGraphConnection * pConnection )

Removes the specified connection.

Parameters
pConnection Reference to the connection to remove.

◆ RemoveAt()

void RemoveAt ( int nIndex )

Removes the specified connection from the Node's collection of connections.

Parameters
nIndex Index of the connection to remove.
The documentation for this class was generated from the following file:
  • XTPFlowGraphConnections.h


Toolkit Pro: CXTPFlowGraphControl Class Reference

Public Member Functions | Static Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPFlowGraphControl Class Reference

Flow Graph Control. More...

Public Member Functions

CXTPFlowGraphControl ()
Constructs a CXTPFlowGraphControl object.
virtual | ~CXTPFlowGraphControl ()
Destroys a CXTPFlowGraphControl object, handles cleanup and deallocation.
void | SetActivePage (CXTPFlowGraphPage *pPage)
Sets the active page.
CXTPFlowGraphPages * | GetPages () const
Collection of all pages in the flow graph.
virtual void | OnGraphChanged ()
This method is called whenever the flow graph or any of its elements have changed.
CXTPFlowGraphPaintManager * | GetPaintManager () const
Retrieves the FlowGraphPaintManager object used for drawing the flow graph.
void | SetPaintManager (CXTPFlowGraphPaintManager *pPaintManager)
Sets the FlowGraphPaintManager object used for drawing the flow graph.
CXTPFlowGraphImages * | GetImages () const
Retrieves a reference to all the images that the flow graph can use.
virtual void | DoPropExchange (CXTPPropExchange *pPX)
Exchanges layout and state information to/from a PropExchange object.
virtual void | OnDraw (CXTPFlowGraphDrawContext *pDC)
Called by the framework to draw the flow graph control.
virtual void | Reposition ()
Updates the position of elements in the graph.
virtual void | RedrawControl ()
Redraws the control.
CXTPFlowGraphPage * | GetActivePage () const
Retrieves a reference to the currently active page.
CXTPFlowGraphPageHistory * | GetHistory () const
Gets an object that keeps track of page history and allows for the history to be navigated.
CXTPFlowGraphUndoManager * | GetUndoManager () const
Gets the manager used to Undo and Redo edit operations in the flow graph.
BOOL | RegisterWindowClass (HINSTANCE hInstance=NULL)
Registers the window class if it has not already been registered.
BOOL | Create (DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID)
Call this method to create a flow graph control.
double | GetZoomLevel () const
Gets the current zoom level of the control.
void | SetZoomLevel (double dZoomLevel)
Sets the current zoom level for the control.
CPoint | GetScrollOffset () const
Gets the scroll offset (how much the page has been scrolled).
void | SetZoomRange (double dMinZoom, double dMaxZoom)
Call this method to set the minimum and maximum zoom percentages that are allowed when using the various zoom methods.
CPoint | TransformPoint (CPoint pt) const
This method uses the current zoom level and scroll offset to transform a point in logical coordinates to current drawing coordinates.
virtual void | ZoomToSelection ()
Zooms to the currently selected Nodes.
virtual void | ZoomFitToWindow ()
Fits all the Nodes in the active page to the window.
virtual void | ZoomToRect (LPCRECT lpRect, BOOL bAnimate=TRUE)
Zooms the view to a specific set of coordinates on the active page.
virtual void | AnimateTo (CPoint ptScrollOffset, double dZoomLevel)
Call this method to use animation to scroll to the specified offset in the control.
virtual void | AnimatePageTransition (CXTPFlowGraphNode *pNodeFrom, CXTPFlowGraphNode *pNodeTo)
This method will transition from a Node on the current page to a Node on a different page.
void | SetAnimationDelay (int nDelay)
Sets the delay to use between animation steps when animation is used (zooming/scrolling).
int | GetAnimationDelay () const
Gets the delay used between animation steps when animation is used (zooming/scrolling).
void | SetAllowMoveNodes (BOOL bAllow)
Specifies whether the user can drag/move Nodes.
BOOL | GetAllowMoveNodes () const
Gets whether the user can drag/move Nodes.
void | SetAllowResizeNodes (XTPFlowGraphResize nResizeMode)
Sets Node resizing options (drag/drop size of nodes).
XTPFlowGraphResize | GetAllowResizeNodes () const
Gets Node resizing options (drag/drop size of nodes).
void | SetAllowModifyConnections (BOOL bAllowModifyConnections)
Specifies whether the user is allowed to drag/move/add/delete connections.
BOOL | GetAllowModifyConnections () const
Checks whether the user is allowed to drag/move/add/delete connections.
void | SetSmoothingMode (XTPFlowGraphSmoothingMode nSmoothingMode)
Sets the draw quality options for the flow graph.
XTPFlowGraphSmoothingMode | GetSmoothingMode () const
Gets the draw quality options used for the flow graph.
virtual void | SelectAll ()
Selects all Nodes in the graph.
virtual void | Arrange ()
Auto-arranges the Nodes in the active page.
virtual void | RenameNode (CXTPFlowGraphNode *pNode)
Call this method to place a Node into edit mode so the user can edit the text.
virtual void | RenameConnectionPoint (CXTPFlowGraphConnectionPoint *pConnectionPoint)
Call this method to place a connection point into edit mode so the user can edit the text.
CXTPFlowGraphNodeCustom * | AddCustomNodeFromToolkitResource (UINT uResShapeID, CXTPFlowGraphPage *pPage=NULL)
Helper method to load a custom XAML shape from toolkit using its resource ID.
virtual CXTPFlowGraphNode * | HitTestNode (CPoint point) const
Call this method to determine if there is a CXTPFlowGraphNode at the specified point.
virtual CXTPFlowGraphConnection * | HitTestConnection (CPoint point) const
Call this method to determine if there is a CXTPFlowGraphConnection at the specified point.
virtual CXTPFlowGraphConnectionPoint * | HitTestConnectionArea (CPoint point) const
Call this method to determine if there is a CXTPFlowGraphConnectionPoint at the specified point.
virtual void | OnEndLabelEdit (CXTPFlowGraphElement *pItem, LPCTSTR str)
Called after a label has been edited.
void | CancelLabelEdit ()
Call this method to cancel a label edit.
CXTPToolTipContext * | GetToolTipContext () const
Call this method to get a pointer to the tooltip context.
BOOL | SaveToFile (LPCTSTR szFile)
Save the picture to a specified file.
void | EnableMarkup (BOOL bEnable=TRUE)
Enables/disables markup for the flow graph.
void | EnableScrollBarCtrl (int nBar, BOOL bEnable=TRUE)
Enables/disables the scrollbar.
int | GetScrollLimit (int nBar)
Call this member function to retrieve the maximum scrolling position of the scroll bar.
virtual CScrollBar * | GetScrollBarCtrl (int nBar) const
Call this member function to obtain a pointer to the specified sibling scroll bar.
CXTPMarkupContext * | GetMarkupContext () const
Retrieves a pointer to the markup context.
CXTPMarkupDependencyProperty * | GetCustomMarkupProperty (XTPFlowGraphCustomProperty property) const
Call this method to retrieve a custom markup property from the custom properties map.
CString | GetDefaultMarkupTemplate (XTPFlowGraphDefaultXAMLTemplate tmpl) const
Call this method to retrieve a default markup template.
void | RegisterCustomMarkupProperties ()
Attaches custom properties to a control.
void | SetupDefaultMarkupTemplates ()
Sets up default Node's markup templates for a Node and its rows (used to be names connection points).
virtual LRESULT | SendNotifyMessage (UINT nMessage, NMHDR *pNMHDR=NULL) const
Sends the specified message to the window.

Static Public Member Functions

static CString AFX_CDECL LoadXamlTemplate (LPCTSTR szTemplate)
Loads a markup XAML template from a resource.

Protected Member Functions

virtual void | AdjustScrollBars ()
Adjusts scrollbars depending on currently visible elements (nodes, connections, etc.).
virtual void | StartDragNodes ()
Internal method that is called when Nodes are starting to get dragged.
virtual void | StartResizeNode (CXTPFlowGraphNode *pNode, UINT hitTest)
Internal method that is called when a Node starts to get resized.
virtual void | StartDragScreen ()
Internal method that is called when the screen has begun to get dragged.
virtual void | StartDragSelection ()
Internal method that is called when the selection starts to get dragged.
virtual void | StartDragConnection (CXTPFlowGraphConnection *pConnection)
Internal method that is called when a connection starts to get dragged.
virtual void | StartDragConnectionPoint (CXTPFlowGraphConnectionPoint *pPoint)
Internal method that is called when a connection point starts to get dragged.
virtual void | OnMoveSelection (CPoint pt)
Called when the selection has changed.
virtual void | GetZoomParam (LPCRECT lpRect, CPoint &ptScrollOffset, double &dZoomLevel)
Calculates the correct ScrollOffset and ZoomLevel needed for a given rectangle.
virtual CXTPFlowGraphDrawContext * | CreateDrawContext (CDC &dc)
Creates a CXTPFlowGraphDrawContext object that will use the specified dc to draw.

Protected Attributes

CBitmap | m_bmpCache
Bitmap Cache.
BOOL | m_bReposition
Specifies whether the control should reposition itself.
CXTPFlowGraphPaintManager * | m_pPaintManager
Pointer to the paint manager used to draw the flow graph.
CXTPFlowGraphPage * | m_pActivePage
Pointer to the currently active page.
CXTPFlowGraphPages * | m_pPages
Pointer to the flow graph's collection of pages.
BOOL | m_bAdjustScrollBars
Specifies whether to adjust the scrollbars.
CPoint | m_ptStartDrag
Point to start dragging.
CPoint | m_ptMouse
Current point the mouse cursor is located.
CRect | m_rcSelectedArea
Bounding rectangle of the currently selected area.
CXTPFlowGraphUndoManager * | m_pUndoManager
The pointer to the undo manager object.
CXTPFlowGraphImages * | m_pImages
Image collection for the flow graph control.
double | m_dMinZoom
Minimum zoom level allowed for the flow graph control.
double | m_dMaxZoom
Maximum zoom level allowed for the flow graph control.
CXTPToolTipContext * | m_pToolTipContext
Tooltip Context.
int | m_nAnimationDelay
Delay between animation steps used when zooming or scrolling.
CXTPFlowGraphPageHistory * | m_pHistory
Object that keeps track of page history and allows the history to be navigated.
BOOL | m_bAllowMoveNodes
Specifies whether the user can drag/move Nodes.
BOOL | m_bAllowModifyConnections
Specifies whether the user can drag/move/add/delete connections.
BOOL | m_bInAction
Internally used to tell the flow graph it is in animation (scrolling, zooming) or dragging.
XTPFlowGraphSmoothingMode | m_nSmoothingMode
Draw quality options for the flow graph.
CXTPMarkupContext * | m_pMarkupContext
Markup context of flow graph.
BOOL | m_bCreateScrollbarOnParent
TRUE if parent window scrollbars are used, otherwise FALSE.

Detailed Description

Flow Graph Control.

Used to display relationship graphs.

The Flow Graph Control is used to display relationship graphs. This can be thought of as a relationship diagram commonly used to display the relationships for a relational database.

The control consists of "Nodes" that can be thought of as tables in a database. The Nodes contain "connections" (fields of a table). The connections can have many "connection points" that can be used to link the connections between different nodes (i.e. linking an invoice table to a customer table via a connection).

Nodes and connection lines can be dragged around the graph allowing the user to fully customize the look of their relationship diagram.

The control also supports undo/redo edit operations in the case you allow the nodes to be moved, renamed, connections added/removed, etc.

Several different zoom navigation functions allow the control to zoom to a specific Node, zoom to a range of Nodes, zoom to the selection and fit it to the window.

Page transitions can be used to transition from one database to another.

Member Function Documentation

◆ AddCustomNodeFromToolkitResource()

CXTPFlowGraphNodeCustom * AddCustomNodeFromToolkitResource | ( | UINT | uResShapeID,
 |  | CXTPFlowGraphPage * | pPage = NULL )

Helper method to load a custom XAML shape from toolkit using its resource ID.

Parameters
uResShapeID | Shape resource ID.
pPage | A pointer to a CXTPFlowGraphPage. If not defined, then the active page is used.
Returns
A custom graph node object pointer.

◆ AnimatePageTransition()

virtual void AnimatePageTransition | ( | CXTPFlowGraphNode * | pNodeFrom,
 |  | CXTPFlowGraphNode * | pNodeTo )
 virtual

This method will transition from a Node on the current page to a Node on a different page.

Parameters
pNodeFrom | Reference to a Node on the current page to transition from.
pNodeTo | Reference to a Node on a different page to transition to.

AnimatePageTransition will transition from a Node on the current page to a Node on a different page. This will cause the active page to change to the page that contains the Node that was transitioned to.

◆ AnimateTo()

virtual void AnimateTo | ( | CPoint | ptScrollOffset,
 |  | double | dZoomLevel )
 virtual

Call this method to use animation to scroll to the specified offset in the control.

Parameters
ptScrollOffset | A point that represents the offset to scroll to.
dZoomLevel | Level of zoom to use.

0.0 is 0 zoom and 1.0 is 100% zoom.

◆ Arrange()

virtual void Arrange ( )
virtual

Auto-arranges the Nodes in the active page.

This will left-align all Nodes in the active page. Nodes with connections will be placed to the right of the connected Node.

◆ CancelLabelEdit()

void CancelLabelEdit ( )

Call this method to cancel a label edit.

This method is used in the CXTPFlowGraphControl::Reposition method.

◆ Create()

BOOL Create | ( | DWORD | dwStyle,
 |  | const RECT & | rect,
 |  | CWnd * | pParentWnd,
 |  | UINT | nID )

Call this method to create a flow graph control.

Parameters
dwStyle | Styles to use.
rect | Specifies the size and position of the item.
pParentWnd | Pointer to the parent window.
nID | ID to use for this control.
Returns
TRUE if successful, FALSE otherwise.

◆ CreateDrawContext()

virtual CXTPFlowGraphDrawContext * CreateDrawContext ( CDC & dc )
protectedvirtual

Creates a CXTPFlowGraphDrawContext object that will use the specified dc to draw.

Parameters
dc Pointer to a valid device context.

This will retrieve CXTPFlowGraphDrawContext or CXTPFlowGraphDrawContextGdiPlus depending on the value of m_nSmoothingMode.

Returns
Pointer to the CXTPFlowGraphDrawContext object that will use the specified dc to draw.

◆ DoPropExchange()

virtual void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Exchanges layout and state information to/from a PropExchange object.

The PropExchange object provides a universal solution to save the layout and state of the flow graph to a single file or the system registry with support to write/load directly to/from a file or registry.

Parameters
pPX PropExhange object to exchange data with.

◆ EnableMarkup()

void EnableMarkup ( BOOL bEnable = TRUE )

Enables/disables markup for the flow graph.

Parameters
bEnable TRUE to enable markup for the flow graph, FALSE to disable markup for the flow graph.

◆ EnableScrollBarCtrl()

void EnableScrollBarCtrl | ( | int | nBar,
 |  | BOOL | bEnable = TRUE )

Enables/disables the scrollbar.

Parameters
nBar | [in] The scrollbar identifier.
bEnable | [in] TRUE to enable the scrollbar, FALSE to disable.

If the window has a sibling scrollbar control, then that scrollbar is used. Otherwise the window's own scrollbar is used.

See also
void ShowScrollBar(UINT nBar, BOOL bShow = TRUE);

◆ GetActivePage()

AFX_INLINE CXTPFlowGraphPage * GetActivePage ( ) const

Retrieves a reference to the currently active page.

The flow graph can contain many pages that each have their own set of Nodes/connections. GetActivePage will retrieve a reference to the page currently in view. Note that only one page can be viewed at a time.

Returns
A reference to the currently active page.

◆ GetAllowModifyConnections()

AFX_INLINE BOOL GetAllowModifyConnections ( ) const

Checks whether the user is allowed to drag/move/add/delete connections.

Returns
TRUE if the user is allowed to drag/move/add/delete connections, FALSE if they are locked.

◆ GetAllowMoveNodes()

AFX_INLINE BOOL GetAllowMoveNodes ( ) const

Gets whether the user can drag/move Nodes.

Returns
TRUE if nodes are allowed to be moved, FALSE if they are locked.

◆ GetAllowResizeNodes()

AFX_INLINE XTPFlowGraphResize GetAllowResizeNodes ( ) const

Gets Node resizing options (drag/drop size of nodes).

To resize a Node, you must click the border of the node and drag it to the desired width/height.

Returns
Current resizing options; returns one of the values defined by the XTPFlowGraphResize enumeration.

◆ GetAnimationDelay()

AFX_INLINE int GetAnimationDelay ( ) const

Gets the delay used between animation steps when animation is used (zooming/scrolling).

Returns
The animation delay.

◆ GetCustomMarkupProperty()

CXTPMarkupDependencyProperty * GetCustomMarkupProperty ( XTPFlowGraphCustomProperty property ) const

Call this method to retrieve a custom markup property from the custom properties map.

Parameters
property Identifies the property to retrieve.
Returns
A pointer to the custom markup property.

◆ GetDefaultMarkupTemplate()

CString GetDefaultMarkupTemplate ( XTPFlowGraphDefaultXAMLTemplate tmpl ) const

Call this method to retrieve a default markup template.

Parameters
tmpl Identifies the template to retrieve.
Returns
A string containing the default markup template.

◆ GetHistory()

AFX_INLINE CXTPFlowGraphPageHistory * GetHistory ( ) const

Gets an object that keeps track of page history and allows for the history to be navigated.

Returns
A FlowGraphPageHistory object used to navigate the history of the pages.

◆ GetImages()

AFX_INLINE CXTPFlowGraphImages * GetImages ( ) const

Retrieves a reference to all the images that the flow graph can use.

Use this method to manage all images for the flow graph.

Returns
A reference to all the images that the flow graph can use.

◆ GetMarkupContext()

AFX_INLINE CXTPMarkupContext * GetMarkupContext ( ) const

Retrieves a pointer to the markup context.

Returns
A pointer to a CXTPMarkupContext object.

◆ GetPages()

AFX_INLINE CXTPFlowGraphPages * GetPages ( ) const

Collection of all pages in the flow graph.

A page is what contains all the elements in the flow graph. The flow graph can contain many pages, each of which can contain Nodes, Node groups, and connections. A page is the first thing that you must add to the flow graph and then you can add elements to the pages.

Returns
Reference to the collection of all pages in the flow graph.

◆ GetPaintManager()

AFX_INLINE CXTPFlowGraphPaintManager * GetPaintManager ( ) const

Retrieves the FlowGraphPaintManager object used for drawing the flow graph.

The paint manager holds many properties to change the various colors and other visual properties used in the flow graph.

Returns
The FlowGraphPaintManager object used for drawing the flow graph.

◆ GetScrollBarCtrl()

virtual CScrollBar * GetScrollBarCtrl ( int nBar ) const
virtual

Call this member function to obtain a pointer to the specified sibling scroll bar.

Parameters
nBar [in] Specifies the type of scrollbar. The parameter can take one of the following values: SB_HORZ: Retrieves the position of the horizontal scroll bar. SB_VERT: Retrieves the position of the vertical scroll bar.

This member function does not operate on scrollbars created when the WS_HSCROLL or WS_VSCROLL bits are set during the creation of a window. The CWnd implementation of this function simply returns NULL. Derived classes, such as CView, implement the described functionality.

Returns
A pointer to the specified sibling scrollbar control if successful, or NULL if the specified sibling scrollbar does not exist.

◆ GetScrollLimit()

int GetScrollLimit ( int nBar )

Call this member function to retrieve the maximum scrolling position of the scroll bar.

Parameters
nBar [in] Specifies the type of scroll bar. The parameter can take one of the following values: SB_HORZ: Retrieves the scroll limit of the horizontal scrollbar. SB_VERT: Retrieves the scroll limit of the vertical scrollbar.
Returns
An int value which specified the maximum scrolling position of the scrollbar if successful, otherwise 0.

◆ GetScrollOffset()

CPoint GetScrollOffset ( ) const

Gets the scroll offset (how much the page has been scrolled).

This retrieves the X/Y coordinates excluding the left/right offset.

Returns
The scroll offset (how much the page has been scrolled). This retrieves a point that contains the X/Y coordinates excluding the left/right offset.

◆ GetSmoothingMode()

AFX_INLINE XTPFlowGraphSmoothingMode GetSmoothingMode ( ) const

Gets the draw quality options used for the flow graph.

These options greatly affect the performance of the control and will, in part, be effected by the graphics capability of the machine that uses the control. xtpFlowGraphSmoothingModeHighQuality is recommended when you don't intend for the Nodes to be dragged by the user. If dragging is enabled, then this setting is most affected by the system's graphic capabilities.

Returns
Currently set smoothing mode; returns an option from XTPFlowGraphSmoothingMode.

◆ GetToolTipContext()

AFX_INLINE CXTPToolTipContext * GetToolTipContext ( ) const

Call this method to get a pointer to the tooltip context.

Returns
A pointer to the tooltip context.

◆ GetUndoManager()

AFX_INLINE CXTPFlowGraphUndoManager * GetUndoManager ( ) const

Gets the manager used to Undo and Redo edit operations in the flow graph.

The FlowGraphUndoManager allows for certain edit operations to be undone and re-done in the Flow Graph. Supported operations are Add/Remove/Move/Resize Nodes/Move Connector Lines/Rename Nodes/Grouping. If any of these operations are performed, then they can easily be undone/re-done using the methods of the FlowGraphUndoManager.

StartGroup and EndGroup are used to "group" a set of "undoable" operations together. Grouping the operations together is useful since the grouped operations can be Undone or Re-done with a single call to Undo or Redo. If the operations are not grouped, then you would have to call Undo or Redo for each operation performed.

Any "undoable" operations performed between StartGroup and EndGroup will be undone/re-done with a single call to Undo or Redo.

Returns
Reference to the FlowGraphUndoManager.

◆ GetZoomLevel()

double GetZoomLevel ( ) const

Gets the current zoom level of the control.

0.0 is 0 zoom and 1.0 is 100% zoom.

Returns
The current zoom level of the control.

◆ GetZoomParam()

virtual void GetZoomParam | ( | LPCRECT | lpRect,
 |  | CPoint & | ptScrollOffset,
 |  | double & | dZoomLevel )
 protectedvirtual

Calculates the correct ScrollOffset and ZoomLevel needed for a given rectangle.

Parameters
lpRect | [in] Rectangle within the client rectangle to zoom to.
ptScrollOffset | [out] Will contain the needed scroll offset for the specified rectangle to zoom.
dZoomLevel | [out] Will contain the needed zoom level for the specified rectangle to zoom.

This is a helper method that calculates the correct ScrollOffset and ZoomLevel needed for a given rectangle. You supply the rectangle and then GetZoomParam will populate ptScrollOffset and dZoomLevel with the correct values.

◆ HitTestConnection()

virtual CXTPFlowGraphConnection * HitTestConnection ( CPoint point ) const
virtual

Call this method to determine if there is a CXTPFlowGraphConnection at the specified point.

Parameters
point Point to test.
Returns
A reference to the CXTPFlowGraphConnection found at the specified point, or NULL if no CXTPFlowGraphConnection is found.

◆ HitTestConnectionArea()

virtual CXTPFlowGraphConnectionPoint * HitTestConnectionArea ( CPoint point ) const
virtual

Call this method to determine if there is a CXTPFlowGraphConnectionPoint at the specified point.

Parameters
point Point to test.
Returns
A reference to the CXTPFlowGraphConnectionPoint found at the specified point, or NULL if no CXTPFlowGraphConnectionPoint is found.

◆ HitTestNode()

virtual CXTPFlowGraphNode * HitTestNode ( CPoint point ) const
virtual

Call this method to determine if there is a CXTPFlowGraphNode at the specified point.

Parameters
point Point to test.
Returns
A reference to the CXTPFlowGraphNode found at the specified point, or NULL if no CXTPFlowGraphNode is found.

◆ LoadXamlTemplate()

static CString AFX_CDECL LoadXamlTemplate ( LPCTSTR szTemplate )
static

Loads a markup XAML template from a resource.

Parameters
szTemplate A string defining a resource of type 'XML'.
Returns
A string containing a markup string (applies to default Nodes).

◆ OnDraw()

virtual void OnDraw ( CXTPFlowGraphDrawContext * pDC )
virtual

Called by the framework to draw the flow graph control.

Parameters
pDC Pointer to a valid device context.

This will redraw the control's background and call OnDraw for the active page.

◆ OnEndLabelEdit()

virtual void OnEndLabelEdit | ( | CXTPFlowGraphElement * | pItem,
 |  | LPCTSTR | str )
 virtual

Called after a label has been edited.

Parameters
pItem | Reference to the element that has finished editing.
str | New label for the element.

This will occur after the label is edited, but before it is changed.

◆ OnGraphChanged()

virtual void OnGraphChanged ( )
virtual

This method is called whenever the flow graph or any of its elements have changed.

For example, this method is called when the page zoom level, page scroll offset, window/Node size, window handle, node style, node color, or connection style is changed.

◆ OnMoveSelection()

virtual void OnMoveSelection ( CPoint pt )
protectedvirtual

Called when the selection has changed.

Parameters
pt Point where the selection changed.

◆ RedrawControl()

virtual void RedrawControl ( )
virtual

Redraws the control.

Call this method after applying changes in code that require a visual redraw (e.g. color).

◆ RegisterWindowClass()

BOOL RegisterWindowClass ( HINSTANCE hInstance = NULL )

Registers the window class if it has not already been registered.

Parameters
hInstance Instance of the resource where the control is located.
Returns
TRUE if the window class was successfully registered.

◆ RenameConnectionPoint()

virtual void RenameConnectionPoint ( CXTPFlowGraphConnectionPoint * pConnectionPoint )
virtual

Call this method to place a connection point into edit mode so the user can edit the text.

Parameters
pConnectionPoint Reference to the connection point to place into edit mode.

◆ RenameNode()

virtual void RenameNode ( CXTPFlowGraphNode * pNode )
virtual

Call this method to place a Node into edit mode so the user can edit the text.

Parameters
pNode Reference to the Node to place into edit mode.

◆ Reposition()

virtual void Reposition ( )
virtual

Updates the position of elements in the graph.

Call this method after applying changes in code that require a reposition of elements of the flow graph (e.g. adding nodes).

◆ SaveToFile()

BOOL SaveToFile ( LPCTSTR szFile )

Save the picture to a specified file.

Parameters
szFile File to save the picture to.
Returns
TRUE if successful.

◆ SelectAll()

virtual void SelectAll ( )
virtual

Selects all Nodes in the graph.

This will select all Nodes in the graph. Selected Nodes have a "bluish" color when selected. The current selection is stored in the active page's selection property.

◆ SendNotifyMessage()

virtual LRESULT SendNotifyMessage | ( | UINT | nMessage,
 |  | NMHDR * | pNMHDR = NULL ) const
 virtual

Sends the specified message to the window.

Parameters
nMessage | The message to be sent.
pNMHDR | Notify header.
Returns
Nonzero if successful, otherwise zero.

◆ SetActivePage()

void SetActivePage ( CXTPFlowGraphPage * pPage )

Sets the active page.

The flow graph can contain many pages that each have their own set of Nodes/connections. GetActivePage will retrieve a reference to the page currently in view. Note that only one page can be viewed at a time.

Parameters
pPage Reference to the page to make active.

◆ SetAllowModifyConnections()

AFX_INLINE void SetAllowModifyConnections ( BOOL bAllowModifyConnections )

Specifies whether the user is allowed to drag/move/add/delete connections.

Parameters
bAllowModifyConnections TRUE to allow the user to drag/move/add/delete connections, FALSE to lock them.

◆ SetAllowMoveNodes()

AFX_INLINE void SetAllowMoveNodes ( BOOL bAllow )

Specifies whether the user can drag/move Nodes.

Parameters
bAllow TRUE to allow Nodes to be moved, FALSE to lock them.

◆ SetAllowResizeNodes()

AFX_INLINE void SetAllowResizeNodes ( XTPFlowGraphResize nResizeMode )

Sets Node resizing options (drag/drop size of nodes).

To resize a Node, you must click the border of the node and drag it to the desired width/height.

Parameters
nResizeMode New resizing options; must be one of the values defined by the XTPFlowGraphResize enumeration.

◆ SetAnimationDelay()

AFX_INLINE void SetAnimationDelay ( int nDelay )

Sets the delay to use between animation steps when animation is used (zooming/scrolling).

Parameters
nDelay New animation delay.

◆ SetPaintManager()

void SetPaintManager ( CXTPFlowGraphPaintManager * pPaintManager )

Sets the FlowGraphPaintManager object used for drawing the flow graph.

The paint manager holds many properties to change the various colors and other visual properties used in the flow graph.

Parameters
pPaintManager Reference to the FlowGraphPaintManager object to use for drawing the flow graph.

◆ SetSmoothingMode()

void SetSmoothingMode ( XTPFlowGraphSmoothingMode nSmoothingMode )

Sets the draw quality options for the flow graph.

Parameters
nSmoothingMode Smoothing mode to use; must be an option from XTPFlowGraphSmoothingMode.

Set SmoothingMode to the setting that best matches your systems capabilities. Use one of the XTPFlowGraphSmoothingMode options for the smoothing mode that best suits your needs.

These options greatly affect the performance of the control and will, in part, be effected by the graphics capability of the machine that uses the control. xtpFlowGraphSmoothingModeHighQuality is recommended when you don't intend for the Nodes to be dragged by the user. If dragging is enabled, then this setting is most affected by the system's graphic capabilities.

◆ SetZoomLevel()

void SetZoomLevel ( double dZoomLevel )

Sets the current zoom level for the control.

Parameters
dZoomLevel New zoom level to use.

0.0 is 0 zoom and 1.0 is 100% zoom.

◆ SetZoomRange()

AFX_INLINE void SetZoomRange | ( | double | dMinZoom,
 |  | double | dMaxZoom )

Call this method to set the minimum and maximum zoom percentages that are allowed when using the various zoom methods.

By default, there is no zoom restriction. 0.0 is 0 and 1.0 is 100%.

Parameters
dMinZoom | Minimum zoom value (0.0 - 1.0).
dMaxZoom | Maximum zoom value (0.0 - 1.0).

◆ StartDragConnection()

virtual void StartDragConnection ( CXTPFlowGraphConnection * pConnection )
protectedvirtual

Internal method that is called when a connection starts to get dragged.

Parameters
pConnection Pointer to the connection that is starting to get dragged.

◆ StartDragConnectionPoint()

virtual void StartDragConnectionPoint ( CXTPFlowGraphConnectionPoint * pPoint )
protectedvirtual

Internal method that is called when a connection point starts to get dragged.

Parameters
pPoint Pointer to the connection point that is starting to get dragged.

◆ StartResizeNode()

virtual void StartResizeNode | ( | CXTPFlowGraphNode * | pNode,
 |  | UINT | hitTest )
 protectedvirtual

Internal method that is called when a Node starts to get resized.

Parameters
pNode | Pointer to the Node that is starting to get resized.
hitTest | Hit test information; must be one of the values defined by the SelectionRectHitTest enumeration.

◆ TransformPoint()

CPoint TransformPoint ( CPoint pt ) const

This method uses the current zoom level and scroll offset to transform a point in logical coordinates to current drawing coordinates.

Parameters
pt Point in logical coordinates.
Returns
The transformed current drawing coordinates.

◆ ZoomFitToWindow()

virtual void ZoomFitToWindow ( )
virtual

Fits all the Nodes in the active page to the window.

The contents of the active page will zoom in or out to fit all content to the full size of the page.

◆ ZoomToRect()

virtual void ZoomToRect | ( | LPCRECT | lpRect,
 |  | BOOL | bAnimate = TRUE )
 virtual

Zooms the view to a specific set of coordinates on the active page.

This will zoom the view to the specified coordinates.

Parameters
lpRect | Specifies the coordinates of the rectangle to zoom to.
bAnimate | TRUE to use animation wile zooming.

◆ ZoomToSelection()

virtual void ZoomToSelection ( )
virtual

Zooms to the currently selected Nodes.

This will fill the entire view with the currently selected Nodes.

Member Data Documentation

◆ m_bAllowModifyConnections

BOOL m_bAllowModifyConnections
protected

Specifies whether the user can drag/move/add/delete connections.

TRUE to allow the user to drag/move/add/delete connections, FALSE to lock them.

◆ m_bAllowMoveNodes

BOOL m_bAllowMoveNodes
protected

Specifies whether the user can drag/move Nodes.

TRUE to allow Nodes to be moved, FALSE to lock them.

The documentation for this class was generated from the following file:
  • XTPFlowGraphControl.h


Toolkit Pro: CXTPFlowGraphEditItem Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPFlowGraphEditItem Class Reference

Represents an edit control used to edit captions for elements in the flow graph. More...

Public Member Functions

CXTPFlowGraphEditItem ()
Constructs a CXTPFlowGraphEditItem object.
BOOL Create (CXTPFlowGraphElement *pElement)
This member function is called to create the edit control used to edit the caption of a connection.

Protected Attributes

BOOL | m_bEscapeKey
TRUE if the escape key was pressed, FALSE otherwise.
CXTPFlowGraphElement * | m_pElement
Parent element to create the edit control for.
CXTPFont | m_xtpFont
Font used in the edit control.

Detailed Description

Represents an edit control used to edit captions for elements in the flow graph.

Member Function Documentation

◆ Create()

BOOL Create ( CXTPFlowGraphElement * pElement )

This member function is called to create the edit control used to edit the caption of a connection.

Parameters
pElement [in] Parent element to create the edit control for.
Returns
TRUE if successful, otherwise FALSE.
The documentation for this class was generated from the following file:
  • XTPFlowGraphEditItem.h


Toolkit Pro: CXTPFlowGraphElement Class Reference

Public Member Functions | Public Attributes | Protected Attributes | List of all members
CXTPFlowGraphElement Class Referenceabstract

Base class for all elements in the flow graph. More...

Inheritance diagram for CXTPFlowGraphElement:
[legend]

Public Member Functions

CXTPFlowGraphElement ()
Constructs a CXTPFlowGraphElement object.
virtual | ~CXTPFlowGraphElement ()
Destroys a CXTPFlowGraphElement object, handles cleanup and deallocation.
virtual CXTPFlowGraphControl * | GetControl () const =0
Gets a reference to the parent FlowGraph control.
virtual CXTPFlowGraphPage * | GetPage () const =0
Retrieves a reference to the flow graph page that this element is displayed on.
BOOL | IsSelected () const
Determines if the element is currently selected.
void | OnGraphChanged ()
This method is called when the flow graph layout is changed.
virtual void | OnRemoved ()
This method is called when the element is removed.
virtual void | SetCaption (LPCTSTR lpszCaption)=0
Sets the caption to be displayed for this element.
virtual CString | GetCaption () const =0
Gets the caption displayed for this element.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Public Attributes

BOOL m_bDirty
Internally used to tell the flow graph that the element has changed.

Protected Attributes

BOOL m_bSelected
Specifies whether the element is selected.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

Base class for all elements in the flow graph.

Every object in the flow graph is derived from FlowGraphElement. It is commonly used when referencing an object that can be many different types. For example, when using HitTest, the returned object is a FlowGraphElement and then you can cast it to the appropriate type.

Member Function Documentation

◆ GetCaption()

virtual CString GetCaption ( ) const
pure virtual

Gets the caption displayed for this element.

Returns
The caption displayed for this element.

Implemented in CXTPFlowGraphConnection, CXTPFlowGraphConnectionPoint, CXTPFlowGraphNode, and CXTPFlowGraphNodeGroup.

◆ GetControl()

virtual CXTPFlowGraphControl * GetControl ( ) const
pure virtual

Gets a reference to the parent FlowGraph control.

Returns
A reference to the parent FlowGraph control.

Implemented in CXTPFlowGraphConnection, CXTPFlowGraphConnectionPoint, CXTPFlowGraphNode, and CXTPFlowGraphNodeGroup.

◆ GetPage()

virtual CXTPFlowGraphPage * GetPage ( ) const
pure virtual

Retrieves a reference to the flow graph page that this element is displayed on.

Returns
A reference to the flow graph page that this element is displayed on.

Implemented in CXTPFlowGraphConnection, CXTPFlowGraphConnectionPoint, CXTPFlowGraphNode, and CXTPFlowGraphNodeGroup.

◆ IsSelected()

BOOL IsSelected ( ) const

Determines if the element is currently selected.

Returns
TRUE if the element is currently selected, otherwise FALSE.

◆ OnGraphChanged()

void OnGraphChanged ( )

This method is called when the flow graph layout is changed.

This method is called when the page zoom level, page scroll offset, window/Node size, window handle, Node style, Node color, or connection style is changed.

◆ SetCaption()

virtual void SetCaption ( LPCTSTR lpszCaption )
pure virtual

Sets the caption to be displayed for this element.

Parameters
lpszCaption The caption to be displayed for this element.

Implemented in CXTPFlowGraphConnection, CXTPFlowGraphConnectionPoint, CXTPFlowGraphNode, and CXTPFlowGraphNodeGroup.

Member Data Documentation

◆ m_bDirty

BOOL m_bDirty

Internally used to tell the flow graph that the element has changed.

This will tell Reposition to handle the element.

◆ m_bSelected

BOOL m_bSelected
protected

Specifies whether the element is selected.

TRUE if selected, FALSE otherwise.

The documentation for this class was generated from the following file:
  • XTPFlowGraphElement.h


Toolkit Pro: CXTPFlowGraphImage Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPFlowGraphImage Class Reference

Object used to represent an image displayed in a Node or connection point. More...

Inheritance diagram for CXTPFlowGraphImage:
[legend]

Public Member Functions

CXTPFlowGraphImage ()
Constructs a CXTPFlowGraphImage object.
virtual | ~CXTPFlowGraphImage ()
Destroys a CXTPFlowGraphImage object, handles cleanup and deallocation.
void | LoadFromResource (HINSTANCE hInstance, UINT nResourceName)
Loads an image from a resource.
void | LoadFromResource (HINSTANCE hInstance, LPCTSTR lpszResourceName, LPCTSTR lpszResourceType)
Loads an image from a resource.
void | LoadFromFile (LPCTSTR lpszFileName)
Loads an image so that it can be used in the flow graph.
void | SetBitmap (HBITMAP hBitmap)
Call this method to assign a bitmap handle to the CXTPFlowGraphImage class.
void | SetIcon (HICON hIcon)
Call this method to assign an icon handle to the CXTPFlowGraphImage class.
CSize | GetSize () const
Gets the size of this image.
Gdiplus::Image * | GetImage () const
Gets a reference to a Gdiplus::Image for this flow graph image.
CXTPImageManagerIcon * | GetIcon () const
Gets a reference to a CXTPImageManagerIcon for this flow graph image.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

void | OnRemoved ()
This method is called when the image is removed from the flow graph's collection of images.
void | ImageChanged ()
This method is called whenever the image has been changed.

Protected Attributes

Gdiplus::Bitmap * | m_pImage
Reference to a Gdiplus::Image for this flow graph image.
CXTPImageManagerIcon * | m_pIcon
Reference to a CXTPImageManagerIcon for this flow graph image.
CSize | m_szImage
Size of the image.
CXTPFlowGraphImages * | m_pParent
Reference to the collection of images that this image belongs to.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

Object used to represent an image displayed in a Node or connection point.

Member Function Documentation

◆ GetIcon()

CXTPImageManagerIcon * GetIcon ( ) const

Gets a reference to a CXTPImageManagerIcon for this flow graph image.

Returns
A reference to a CXTPImageManagerIcon for this flow graph image.

◆ GetImage()

Gdiplus::Image * GetImage ( ) const

Gets a reference to a Gdiplus::Image for this flow graph image.

Returns
A reference to a Gdiplus::Image for this flow graph image.

◆ GetSize()

AFX_INLINE CSize GetSize ( ) const

Gets the size of this image.

Returns
A CSize object containing the size of this image.

◆ ImageChanged()

void ImageChanged ( )
protected

This method is called whenever the image has been changed.

This is called when a bitmap/icon is set or when an image is loaded from a resource or file.

◆ LoadFromFile()

void LoadFromFile ( LPCTSTR lpszFileName )

Loads an image so that it can be used in the flow graph.

Parameters
lpszFileName Filename and path to the file with the image to load.

◆ LoadFromResource() [1/2]

void LoadFromResource | ( | HINSTANCE | hInstance,
 |  | LPCTSTR | lpszResourceName,
 |  | LPCTSTR | lpszResourceType )

Loads an image from a resource.

Parameters
hInstance | Handle to an instance of the module that contains the image to be loaded.
lpszResourceName | Pointer to the string containing the name of the resource containing the image to load.
lpszResourceType | The type of the resource.

◆ LoadFromResource() [2/2]

void LoadFromResource | ( | HINSTANCE | hInstance,
 |  | UINT | nResourceName )

Loads an image from a resource.

Parameters
hInstance | Handle to an instance of the module that contains the image to be loaded.
nResourceName | The ID of the buffer containing the name of the resource to load.

◆ SetBitmap()

void SetBitmap ( HBITMAP hBitmap )

Call this method to assign a bitmap handle to the CXTPFlowGraphImage class.

Parameters
hBitmap Bitmap handle.

◆ SetIcon()

void SetIcon ( HICON hIcon )

Call this method to assign an icon handle to the CXTPFlowGraphImage class.

Parameters
hIcon Icon handle to assign.
The documentation for this class was generated from the following file:
  • XTPFlowGraphImage.h


Toolkit Pro: CXTPFlowGraphImages Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPFlowGraphImages Class Reference

Collection of images that can be used in the flow graph. More...

Inheritance diagram for CXTPFlowGraphImages:
[legend]

Public Member Functions

CXTPFlowGraphImage * | AddImage (CXTPFlowGraphImage *pPage)
Adds an image object that can then be used to load an image file.
void | RemoveAll ()
Removes all images from the flow graph.
int | GetCount () const
Retrieves the total number of images added to the flow graph.
CXTPFlowGraphImage * | GetAt (int nIndex) const
Retrieves the specified image from the collection of all images added to the flow graph.
void | Remove (CXTPFlowGraphImage *pPage)
Removes all images from the specified page.
void | RemoveAt (int nIndex)
Removes the specified images from the collection of images.
CXTPImageManager * | GetImageManager () const
Retrieves the image manager associated with the flow graph.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

CXTPFlowGraphImages (CXTPFlowGraphControl *pControl)
Constructs a CXTPFlowGraphImages object.
virtual ~CXTPFlowGraphImages ()
Destroys a CXTPFlowGraphImage object, handles cleanup and deallocation.

Protected Attributes

CArray< CXTPFlowGraphImage *, CXTPFlowGraphImage * > | m_arrImages
List of images for the flow graph.
CXTPImageManager * | m_pImageManager
Pointer to the image manager associated with the graph.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

Collection of images that can be used in the flow graph.

Images can be loaded and displayed next to the Node's caption or connection point captions.

Constructor & Destructor Documentation

◆ CXTPFlowGraphImages()

CXTPFlowGraphImages ( CXTPFlowGraphControl * pControl )
protected

Constructs a CXTPFlowGraphImages object.

Parameters
pControl Pointer to the flow graph control.

Member Function Documentation

◆ AddImage()

CXTPFlowGraphImage * AddImage ( CXTPFlowGraphImage * pPage )

Adds an image object that can then be used to load an image file.

AddImage must first be used to create a FlowGraphImage. You can use this object to load an image file.

Parameters
pPage Reference to the page to add this image to.
Returns
A reference to the FlowGraphImage that was just added.

◆ GetAt()

AFX_INLINE CXTPFlowGraphImage * GetAt ( int nIndex ) const

Retrieves the specified image from the collection of all images added to the flow graph.

Parameters
nIndex Index of the desired image to retrieve.
Returns
A reference to the specified image.

◆ GetCount()

AFX_INLINE int GetCount ( ) const

Retrieves the total number of images added to the flow graph.

Returns
The total number of images added to the flow graph.

◆ GetImageManager()

AFX_INLINE CXTPImageManager * GetImageManager ( ) const

Retrieves the image manager associated with the flow graph.

Returns
A pointer to the image manager object that stores the images in the flow graph.

◆ Remove()

void Remove ( CXTPFlowGraphImage * pPage )

Removes all images from the specified page.

Parameters
pPage Reference to the page to remove images from.

◆ RemoveAt()

void RemoveAt ( int nIndex )

Removes the specified images from the collection of images.

Parameters
nIndex Index of the image to remove.
The documentation for this class was generated from the following file:
  • XTPFlowGraphImage.h


Toolkit Pro: CXTPFlowGraphNode Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | Static Protected Attributes | List of all members
CXTPFlowGraphNode Class Reference

Represents a Node object. More...

Inheritance diagram for CXTPFlowGraphNode:
[legend]

Public Member Functions

CXTPFlowGraphNode ()
Constructs a CXTPFlowGraphNode object.
virtual | ~CXTPFlowGraphNode ()
Destroys a CXTPFlowGraphNode object, handles cleanup and deallocation.
void | SetCaption (LPCTSTR lpszCaption)
Sets the caption that is displayed for this Node.
CString | GetCaption () const
Gets the caption that is displayed for this Node.
void | SetTooltip (LPCTSTR lpszTooltip)
Sets the tooltip for this Node.
CString | GetTooltip () const
Gets the tooltip for this Node.
virtual void | SetColor (COLORREF clr, BYTE bAlpha=255)
Sets the color for the Node.
COLORREF | GetColor () const
Gets the color of the node.
void | SetStyle (int nStyle)
Reserved for future use.
int | GetStyle () const
Reserved for future use.
void | SetTag (DWORD_PTR dwTag)
This method sets the 32-bit value associated with the Node.
DWORD_PTR | GetTag () const
This method retrieves the application-supplied, 32-bit value associated with the Node.
void | SetID (int nId)
Sets the ID used to identify this Node.
int | GetID () const
Gets the ID used to identify this Node.
virtual void | SetWindowHandle (HWND hWnd)
Call this member to associate an object with the Node.
HWND | GetWindowHandle () const
Call this member to get the HWND of the object associated with the Node.
virtual void | SetWindowSize (CSize sz)
Sets the size of the window for the external control that is attached to the Node (if applicable).
CSize | GetWindowSize () const
Gets the size of the window for the external control that is attached to the Node (if applicable).
void | SetImageIndex (int nImageIndex)
Sets the ID of the image to display next to the caption text of the Node.
int | GetImageIndex () const
Gets the ID of the image to display next to the caption text of the Node.
void | SetLocked (BOOL bLocked=TRUE)
Sets the locked state of the Node.
BOOL | IsLocked () const
Gets the locked state of the Node.
void | SetVisible (BOOL bVisible=TRUE)
Sets the visibility of the Node and its connections.
BOOL | IsVisible () const
Gets the visibility of the Node and its connections.
void | SetLocation (CPoint ptLocation)
Sets the location of the Node.
CPoint | GetLocation () const
Gets the location of the Node.
virtual void | SetSize (CSize sz)
Sets the size for the Node (Node's Markup!).
void | SetSizeCore (CSize sz)
Sets the size for the Node.
CSize | GetSize () const
Gets the size of the Node.
CSize | GetUserSize () const
Gets the size of the Node (including user resizing).
BOOL | IsResizable () const
Checks if the Node is resizable.
CSize | GetMinSize () const
Gets the minimum size of the Node; calculated in the CalcMinSize method.
void | SetMinSize (CSize sz)
Sets the minimum size for the Node.
CRect | GetScreenRect (BOOL bIncludeConnectionPointsEllipses=TRUE) const
Gets the screen coordinates for the Node.
CXTPFlowGraphPage * | GetPage () const
Gets a reference to the page that this Node belongs to.
CXTPFlowGraphNodeGroup * | GetGroup () const
Retrieves the group that this Node is a part of (if any).
CXTPFlowGraphImage * | GetImage () const
Gets the image to display next to the caption text of the Node.
CXTPFlowGraphConnectionPoints * | GetConnectionPoints () const
Gets the connection points collection for this Node.
CXTPFlowGraphControl * | GetControl () const
Gets a reference to the parent FlowGraph control.
void | Remove ()
Removes this node from the flow graph.
virtual CXTPFlowGraphConnectionPoint * | HitTestConnectionPoint (CPoint point)
Determines which connection point, if any, is at a specified point.
virtual void | UpdateWindowPosition ()
Updates the window position of the attached external control.
virtual void | DrawWindowContent (CXTPFlowGraphDrawContext *pDC)
Draws the contents of the Node.
virtual void | Select (BOOL bSelect=TRUE)
Specifies the selected state of the Node.
virtual void | DoPropExchange (CXTPPropExchange *pPX)
Call this member function to store/load a Node using the specified data object.
void | DoCommonPropExchange (CXTPPropExchange *pPX)
Stores/loads Node common properties (for both default and derived Nodes).
virtual void | RecalLayout ()
virtual void | Draw (CXTPFlowGraphDrawContext *pDC)
This method is called to draw the Node.
CRect | GetSelectionRect () const
Retrieves the Node's selection rectangle (visible only when the Node is selected).
virtual void | DrawSelectionRect (CXTPFlowGraphDrawContext *pDC)
This virtual method is called to draw the Node's selection rectangle.
virtual void | DrawConnectionPoints (CXTPFlowGraphDrawContext *pDC)
A virtual method that draws the Node's connection points (circles) in their placeholders.
virtual void | CalcMinSize ()
A virtual method that calculates the minimum size of the Node (used in resizing mechanism).
virtual void | AddNamedConnectionPoints (LPCTSTR szName, XTPFlowGraphConnectionPointType type=xtpFlowGraphPointNone, LPCTSTR szCaption=NULL)
Adds a table row to the Node (of default type), with none, one, or two real connection points.
CRect | GetMarkupVisualElementRect (const CXTPMarkupVisual *pElementVisual) const
An important common method used to get a rectangle of any visual Markup element.
int | GetMarkupTableRowIndex (CXTPFlowGraphConnectionPoint *pPoint, CXTPMarkupUIElementCollection *pChildren)
Retrieves the index of a table row in the list (to insert a new one).
int | RemoveMarkupTableRow (CXTPFlowGraphConnectionPoint *pPoint)
Removes a table row (with its connection points) from a default Node.
CXTPMarkupTextBlock * | GetTableRowTextBlock (const CString &strConnectionPointName) const
Retrieves the XAML TextBlock element for a table row of a default Node.
CRect | GetTableRowCaptionRect (CXTPFlowGraphConnectionPoint *pPoint) const
Retrieves the rectangle of a XAML TextBlock element for a table row of a default Node.
virtual void | SetDefaultMarkup ()
Sets the default XAML Markup for a default Node with zero table rows.
void | UpdateMarkupPointCaption (CXTPFlowGraphConnectionPoint *pPoint)
Updates the Markup point caption (when changed or restored using DoPropExchange).
void | UpdateMarkupPointName (CXTPFlowGraphConnectionPoint *pPoint)
Updates the Markup point name (when changed or restored using DoPropExchange).
virtual void | UpdateMarkupPointColor (CXTPFlowGraphConnectionPoint *pPoint)
Updates the Markup point color (when changed or restored using DoPropExchange).
void | UpdateMarkupPointImage (CXTPFlowGraphConnectionPoint *pPoint)
Updates the markup point image (when changed or restored using DoPropExchange).
BOOL | SetMarkupText (LPCTSTR szMarkupText)
Sets Markup text for the Node (for a custom Node).
virtual BOOL | IsCustomMarkup () const
A virtual function that determines if the Node is a custom Node (a Node with custom XAML markup).
virtual void | UpdateConnectionPoints (CXTPMarkupObject *pRootElement)
A virtual method that finds and updates real connection points in the Markup.
virtual void | UpdateColorRecursive (CXTPMarkupObject *pRootElement, COLORREF clrColor)
A recursive method to update/set the color of a Node.
virtual void | UpdateCaptionColor ()
Updates the foreground color of the CXTPMarkupTextBlock element of the Node's caption.
virtual void | UpdateMarkupImage ()
Updates the Node's image.
virtual CXTPMarkupTextBlock * | UpdateMarkupCaption ()
Updates Node's caption <TextBlock> element with Node's caption text (m_strCaption).
CXTPMarkupTextBlock * | GetCaptionTextBlock () const
Get the Node's caption <TextBlock> element.
CRect | GetCaptionRect () const
Get the Node's caption <TextBlock> rectangle.
virtual void | UpdateMarkupFont ()
Updates the default font defined in the paint manager; used in Markup drawing.
- Public Member Functions inherited from CXTPFlowGraphElement
CXTPFlowGraphElement ()
Constructs a CXTPFlowGraphElement object.
virtual | ~CXTPFlowGraphElement ()
Destroys a CXTPFlowGraphElement object, handles cleanup and deallocation.
BOOL | IsSelected () const
Determines if the element is currently selected.
void | OnGraphChanged ()
This method is called when the flow graph layout is changed.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

virtual void OnRemoved ()
This method is called when the Node is removed.

Protected Attributes

CXTPFlowGraphPage * | m_pPage
Pointer to the page this Node is displayed on.
CXTPFlowGraphNode * | m_pNextVisibleNode
Pointer to the next visible node.
CString | m_strCaption
Caption displayed for this node.
CXTPMarkupUIElement * | m_pMarkup
Markup that is responsible for drawing this Node.
CPoint | m_ptLocation
Point that contains the coordinates of the Node.
CSize | m_szUserSize
Current size of the Node including user resizing.
CSize | m_szActualSize
Real size of the Node before the user might have resized it.
CSize | m_szUserMinSize
Manually set minimum size.
CString | m_strTooltip
Tooltip of the item.
COLORREF | m_clrNode
Color of the Node.
BYTE | m_bAlpha
Alpha channel 0-255.
int | m_nStyle
Reserved for future use.
DWORD_PTR | m_dwTag
The 32-bit value associated with the item.
int | m_nId
ID of the node.
HWND | m_hWnd
Handle of the window inside the Node.
WNDPROC | m_pOriginalWindowProc
Window procedure pointer.
CSize | m_szWindow
Size of the window of the attached control (if applicable).
int | m_nGroupId
ID of the group this Node belongs to (if any).
int | m_nImageIndex
Index of an image to display next to the caption text of the Node.
BOOL | m_bLocked
Specifies whether the Node is locked.
BOOL | m_bVisible
Specifies whether the Node is visible.
CXTPFlowGraphConnectionPoints * | m_pConnectionPoints
Collection of connection points that are displayed for this Node.
CXTPFlowGraphNodeGroup * | m_pGroup
Pointer to the group this Node belongs to (if any).
- Protected Attributes inherited from CXTPFlowGraphElement
BOOL | m_bSelected
Specifies whether the element is selected.

Static Protected Attributes

static CMap< HWND, HWND, CXTPFlowGraphNode *, CXTPFlowGraphNode * > m_WindowToNodeHash
Used in the custom window 'ControlWindowProc'.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPFlowGraphElement
BOOL | m_bDirty
Internally used to tell the flow graph that the element has changed.

Detailed Description

Represents a Node object.

Nodes are the main objects that are displayed in the flow graph. In terms of a database, they can be thought of as tables. Nodes contain many connection points, which are like the fields in a table. Finally, there are connections that are used to draw a relationship between the fields of two tables.

Member Function Documentation

◆ AddNamedConnectionPoints()

virtual void AddNamedConnectionPoints | ( | LPCTSTR | szName,
 |  | XTPFlowGraphConnectionPointType | type = xtpFlowGraphPointNone,
 |  | LPCTSTR | szCaption = NULL )
 virtual

Adds a table row to the Node (of default type), with none, one, or two real connection points.

Parameters
szName | Unique name.
szCaption | Caption of the table row. Uses szName if not specified.
type | Type.

Parameters : xtpFlowGraphPointNone No actual connection points. xtpFlowGraphPointInput One connection point (in the left of the row). xtpFlowGraphPointOutput One connection point (in the right of the row). xtpFlowGraphPointInputAndOutput Two connection points (in the left and right of the row).

Reimplemented in CXTPFlowGraphNodeCustom.

◆ DoCommonPropExchange()

void DoCommonPropExchange ( CXTPPropExchange * pPX )

Stores/loads Node common properties (for both default and derived Nodes).

Parameters
pPX Source/destination CXTPPropExchange data object reference.

This function is called automatically in both default and custom Nodes.

◆ DoPropExchange()

virtual void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Call this member function to store/load a Node using the specified data object.

Parameters
pPX Source/destination CXTPPropExchange data object reference.

This member function is used to store/load Node data to/from storage.

Reimplemented in CXTPFlowGraphNodeCustom.

◆ Draw()

virtual void Draw ( CXTPFlowGraphDrawContext * pDC )
virtual

This method is called to draw the Node.

Parameters
pDC Pointer to a valid device context.

◆ DrawConnectionPoints()

virtual void DrawConnectionPoints ( CXTPFlowGraphDrawContext * pDC )
virtual

A virtual method that draws the Node's connection points (circles) in their placeholders.

Parameters
pDC Pointer to a valid device context.

◆ DrawSelectionRect()

virtual void DrawSelectionRect ( CXTPFlowGraphDrawContext * pDC )
virtual

This virtual method is called to draw the Node's selection rectangle.

Parameters
pDC Pointer to a valid device context.

◆ DrawWindowContent()

virtual void DrawWindowContent ( CXTPFlowGraphDrawContext * pDC )
virtual

Draws the contents of the Node.

Parameters
pDC Pointer to a CXTPFlowGraphDrawContext object.

Reimplemented in CXTPFlowGraphNodeCustom.

◆ GetCaption()

AFX_INLINE CString GetCaption ( ) const
virtual

Gets the caption that is displayed for this Node.

The Node's caption will be displayed at the top of the Node and its background color is the same color as the Node, which is, by default, a different color than the connection points that get added to the node.

Returns
The caption that is displayed for this Node.

Implements CXTPFlowGraphElement.

◆ GetCaptionRect()

CRect GetCaptionRect ( ) const

Get the Node's caption <TextBlock> rectangle.

Returns
The Node's caption <TextBlock> rectangle. Coordinates are relative to the Node's location.

◆ GetCaptionTextBlock()

CXTPMarkupTextBlock * GetCaptionTextBlock ( ) const

Get the Node's caption <TextBlock> element.

Returns
A pointer to a CXTPMarkupTextBlock element.

◆ GetColor()

AFX_INLINE COLORREF GetColor ( ) const

Gets the color of the node.

Returns
The color of the node.

◆ GetConnectionPoints()

AFX_INLINE CXTPFlowGraphConnectionPoints * GetConnectionPoints ( ) const

Gets the connection points collection for this Node.

Returns
A pointer to the connection points collection for this Node.

◆ GetControl()

CXTPFlowGraphControl * GetControl ( ) const
virtual

Gets a reference to the parent FlowGraph control.

Returns
A reference to the parent FlowGraph control.

Implements CXTPFlowGraphElement.

◆ GetGroup()

AFX_INLINE CXTPFlowGraphNodeGroup * GetGroup ( ) const

Retrieves the group that this Node is a part of (if any).

A group is just a "box" that is used to visually group Nodes together. By default, the group will only be shown when a Node in the group is selected, but you can choose to always show the groups with ShowNodeGroupsAlways.

Returns
A reference to the group that this Node is a part of (if any), otherwise NULL.

◆ GetID()

AFX_INLINE int GetID ( ) const

Gets the ID used to identify this Node.

Returns
The ID used to identify this Node.

◆ GetImage()

CXTPFlowGraphImage * GetImage ( ) const

Gets the image to display next to the caption text of the Node.

Returns
A pointer to the image to display next to the caption text of the Node.

◆ GetImageIndex()

AFX_INLINE int GetImageIndex ( ) const

Gets the ID of the image to display next to the caption text of the Node.

Returns
The ID of the image to display next to the caption text of the Node.

◆ GetLocation()

AFX_INLINE CPoint GetLocation ( ) const

Gets the location of the Node.

Returns
A point containing the x- and y- coordinates of the location of the Node.

◆ GetMarkupTableRowIndex()

int GetMarkupTableRowIndex | ( | CXTPFlowGraphConnectionPoint * | pPoint,
 |  | CXTPMarkupUIElementCollection * | pChildren )

Retrieves the index of a table row in the list (to insert a new one).

Parameters
pPoint | Pointer to a connection point object located in this row.
pChildren | Pointer to a collection of markup elements from which the index of the element associated with the specified connection point object is to be returned.
Returns
The index of the collection element associated with the specified connection point object.

◆ GetMarkupVisualElementRect()

CRect GetMarkupVisualElementRect ( const CXTPMarkupVisual * pElementVisual ) const

An important common method used to get a rectangle of any visual Markup element.

Rectangle coordinates are relative to the Markup root element (<Border>\ for example).

Parameters
pElementVisual Pointer to a valid visual markup element.
Returns
The rectangle of the visual markup element.

◆ GetMinSize()

CSize GetMinSize ( ) const

Gets the minimum size of the Node; calculated in the CalcMinSize method.

Returns
The minimum size of the Node

◆ GetPage()

AFX_INLINE CXTPFlowGraphPage * GetPage ( ) const
virtual

Gets a reference to the page that this Node belongs to.

Returns
A reference to the page that this Node belongs to.

Implements CXTPFlowGraphElement.

◆ GetScreenRect()

CRect GetScreenRect ( BOOL bIncludeConnectionPointsEllipses = TRUE ) const

Gets the screen coordinates for the Node.

Parameters
bIncludeConnectionPointsEllipses TRUE to include connection points ellipses
Returns
The screen coordinates for the Node.

◆ GetSelectionRect()

CRect GetSelectionRect ( ) const

Retrieves the Node's selection rectangle (visible only when the Node is selected).

Returns
The Node's selection rectangle.

◆ GetSize()

CSize GetSize ( ) const

Gets the size of the Node.

Returns
A CSize object containing the size of the Node.

◆ GetStyle()

AFX_INLINE int GetStyle ( ) const

Reserved for future use.

Currently can be used as a "tag" property if needed.

Returns
Current style value.

◆ GetTableRowCaptionRect()

CRect GetTableRowCaptionRect ( CXTPFlowGraphConnectionPoint * pPoint ) const

Retrieves the rectangle of a XAML TextBlock element for a table row of a default Node.

Parameters
pPoint Pointer to a connection point that is located in the table row.
Returns
The rectangle of the XAML TextBlock element. Coordinates are relative to the Node's location.

◆ GetTableRowTextBlock()

CXTPMarkupTextBlock * GetTableRowTextBlock ( const CString & strConnectionPointName ) const

Retrieves the XAML TextBlock element for a table row of a default Node.

Parameters
strConnectionPointName The name of a connection point located within the table row with the XAML TextBlock element to be retrieved.
Returns
A pointer to a CXTPMarkupTextBlock element.

◆ GetTag()

AFX_INLINE DWORD_PTR GetTag ( ) const

This method retrieves the application-supplied, 32-bit value associated with the Node.

The tag is used to store any arbitrary value that must be associated with the Node.

Returns
The 32-bit value associated with the Node.

◆ GetTooltip()

AFX_INLINE CString GetTooltip ( ) const

Gets the tooltip for this Node.

This is the text that is displayed when the mouse is hovered over the Node.

Returns
The tooltip for this Node.

◆ GetUserSize()

CSize GetUserSize ( ) const

Gets the size of the Node (including user resizing).

Returns
The size of the Node.

◆ GetWindowHandle()

AFX_INLINE HWND GetWindowHandle ( ) const

Call this member to get the HWND of the object associated with the Node.

This is the HWND of the object that is displayed in the Node.

Returns
The HWND of the object associated with the Node.

◆ GetWindowSize()

AFX_INLINE CSize GetWindowSize ( ) const

Gets the size of the window for the external control that is attached to the Node (if applicable).

This will get the size for the attached external control (i.e. if a tree control is attached to the node). This is the size of the window of the control that was attached using the SetWindowHandle method.

Returns
The size of the window for the external control that is attached to the Node.

◆ HitTestConnectionPoint()

virtual CXTPFlowGraphConnectionPoint * HitTestConnectionPoint ( CPoint point )
virtual

Determines which connection point, if any, is at a specified point.

Parameters
point Point to be tested.
Returns
A pointer to the connection point found at the specified point, if any, or NULL if no connection point is found.

Reimplemented in CXTPFlowGraphNodeCustom.

◆ IsCustomMarkup()

virtual BOOL IsCustomMarkup ( ) const
inlinevirtual

A virtual function that determines if the Node is a custom Node (a Node with custom XAML markup).

Returns
TRUE if the Node is a custom Node, otherwise FALSE.

Reimplemented in CXTPFlowGraphNodeCustom.

◆ IsLocked()

AFX_INLINE BOOL IsLocked ( ) const

Gets the locked state of the Node.

If the Node is locked, then its connection points cannot accept connection lines and any connection lines that were added cannot be removed.

Returns
TRUE if the Node is locked, otherwise FALSE.

◆ IsResizable()

AFX_INLINE BOOL IsResizable ( ) const

Checks if the Node is resizable.

Returns
TRUE if the Node is resizable.

◆ IsVisible()

AFX_INLINE BOOL IsVisible ( ) const

Gets the visibility of the Node and its connections.

Returns
TRUE if the Node and its connections are visible, otherwise FALSE.

◆ RecalLayout()

virtual void RecalLayout ( )
virtual

Recalculates the layout of the Node.

Call this functions to correctly reposition the connections within the Node. This also will readjust the layout when the size or caption has changed.

◆ RemoveMarkupTableRow()

int RemoveMarkupTableRow ( CXTPFlowGraphConnectionPoint * pPoint )

Removes a table row (with its connection points) from a default Node.

Parameters
pPoint Pointer to a connection point that is located in the table row.
Returns
The index of the removed table row in the table rows list.

◆ Select()

virtual void Select ( BOOL bSelect = TRUE )
virtual

Specifies the selected state of the Node.

Parameters
bSelect TRUE to set the Node to selected, FALSE otherwise.

◆ SetCaption()

void SetCaption ( LPCTSTR lpszCaption )
virtual

Sets the caption that is displayed for this Node.

Parameters
lpszCaption Caption to displayed for this Node.

The Node's caption will be displayed at the top of the Node and its background color is the same color as the Node, which is, by default, a different color than the connection points that get added to the node.

Implements CXTPFlowGraphElement.

◆ SetColor()

virtual void SetColor | ( | COLORREF | clr,
 |  | BYTE | bAlpha = 255 )
 virtual

Sets the color for the Node.

Parameters
clr | New color for the Node.
bAlpha | Alpha value for Node.

Reimplemented in CXTPFlowGraphNodeCustom.

◆ SetID()

AFX_INLINE void SetID ( int nId )

Sets the ID used to identify this Node.

Parameters
nId New ID to be used to identify this Node.

◆ SetImageIndex()

void SetImageIndex ( int nImageIndex )

Sets the ID of the image to display next to the caption text of the Node.

Parameters
nImageIndex The ID of the image to display next to the caption text of the Node.

Use the image index to specify the index of the previously loaded image to display next to the caption text of the node.

◆ SetLocation()

void SetLocation ( CPoint ptLocation )

Sets the location of the Node.

Parameters
ptLocation Point containing the x- and y- coordinates for the location of the Node.

◆ SetLocked()

AFX_INLINE void SetLocked ( BOOL bLocked = TRUE )

Sets the locked state of the Node.

Parameters
bLocked TRUE to set the Node to locked, FALSE otherwise.

If the Node is locked, then its connection points cannot accept connection lines and any connection lines that were added cannot be removed.

◆ SetMarkupText()

BOOL SetMarkupText ( LPCTSTR szMarkupText )

Sets Markup text for the Node (for a custom Node).

Parameters
szMarkupText Markup text to set.
Returns
TRUE if successful, otherwise FALSE.

◆ SetMinSize()

void SetMinSize ( CSize sz )

Sets the minimum size for the Node.

Parameters
sz New minimum size for the Node.

◆ SetSize()

virtual void SetSize ( CSize sz )
virtual

Sets the size for the Node (Node's Markup!).

Parameters
sz New size for the Node.

Reimplemented in CXTPFlowGraphNodeCustom.

◆ SetSizeCore()

void SetSizeCore ( CSize sz )

Sets the size for the Node.

Parameters
sz New size for the Node.

◆ SetStyle()

AFX_INLINE void SetStyle ( int nStyle )

Reserved for future use.

Currently can be used as a "tag" property if needed.

Parameters
nStyle Style value.

◆ SetTag()

AFX_INLINE void SetTag ( DWORD_PTR dwTag )

This method sets the 32-bit value associated with the Node.

Parameters
dwTag New 32-bit value to associate with the Node.

The tag is used to store any arbitrary value that must be associated with the Node.

◆ SetTooltip()

AFX_INLINE void SetTooltip ( LPCTSTR lpszTooltip )

Sets the tooltip for this Node.

Parameters
lpszTooltip New tooltip for this Node.

This is the text that is displayed when the mouse is hovered over the Node.

◆ SetVisible()

void SetVisible ( BOOL bVisible = TRUE )

Sets the visibility of the Node and its connections.

Parameters
bVisible TRUE to set the Node and its connections to visible, FALSE to set the Node and its connections to invisible.

◆ SetWindowHandle()

virtual void SetWindowHandle ( HWND hWnd )
virtual

Call this member to associate an object with the Node.

This will tell the Node what to display (i.e. the HWND of a dialog).

Parameters
hWnd HWND of the object that should be displayed in the Node.

Reimplemented in CXTPFlowGraphNodeCustom.

◆ SetWindowSize()

virtual void SetWindowSize ( CSize sz )
virtual

Sets the size of the window for the external control that is attached to the Node (if applicable).

Parameters
sz New size of the window.

This will set the size for the attached external control (i.e. if a tree control is attached to the node). You would attach the external control using the SetWindowHandle method.

Reimplemented in CXTPFlowGraphNodeCustom.

◆ UpdateColorRecursive()

virtual void UpdateColorRecursive | ( | CXTPMarkupObject * | pRootElement,
 |  | COLORREF | clrColor )
 virtual

A recursive method to update/set the color of a Node.

Parameters
pRootElement | An XAML element used to search for XAML elements that can have a color property (see XAML_MARKUP_PROPERTY_CANSETCOLOR).
clrColor | Color to be set.

Reimplemented in CXTPFlowGraphNodeCustom.

◆ UpdateConnectionPoints()

virtual void UpdateConnectionPoints ( CXTPMarkupObject * pRootElement )
virtual

A virtual method that finds and updates real connection points in the Markup.

Parameters
pRootElement An XAML element used to search for connection points in its children.

Implementation of this method for default Nodes is recursive. A rectangle for a connection point is defined by the <Rectangle> element in XAML for default Nodes. Implementation of this method for custom Nodes uses an absolutely different approach (see CXTPFlowGraphNodeCustom::UpdateConnectionPoints).

Reimplemented in CXTPFlowGraphNodeCustom.

◆ UpdateMarkupCaption()

virtual CXTPMarkupTextBlock * UpdateMarkupCaption ( )
virtual

Updates Node's caption <TextBlock> element with Node's caption text (m_strCaption).

Returns
A pointer to a CXTPMarkupTextBlock element.

Reimplemented in CXTPFlowGraphNodeCustom.

◆ UpdateMarkupPointCaption()

void UpdateMarkupPointCaption ( CXTPFlowGraphConnectionPoint * pPoint )

Updates the Markup point caption (when changed or restored using DoPropExchange).

Parameters
pPoint Pointer to a CXTPFlowGraphConnectionPoint object.

◆ UpdateMarkupPointColor()

virtual void UpdateMarkupPointColor ( CXTPFlowGraphConnectionPoint * pPoint )
virtual

Updates the Markup point color (when changed or restored using DoPropExchange).

Parameters
pPoint Pointer to a CXTPFlowGraphConnectionPoint object.

Reimplemented in CXTPFlowGraphNodeCustom.

◆ UpdateMarkupPointImage()

void UpdateMarkupPointImage ( CXTPFlowGraphConnectionPoint * pPoint )

Updates the markup point image (when changed or restored using DoPropExchange).

Parameters
pPoint Pointer to a CXTPFlowGraphConnectionPoint object.

◆ UpdateMarkupPointName()

void UpdateMarkupPointName ( CXTPFlowGraphConnectionPoint * pPoint )

Updates the Markup point name (when changed or restored using DoPropExchange).

Parameters
pPoint Pointer to a CXTPFlowGraphConnectionPoint object.

◆ UpdateWindowPosition()

virtual void UpdateWindowPosition ( )
virtual

Updates the window position of the attached external control.

This method is also called internally when the Node is drawn.

Reimplemented in CXTPFlowGraphNodeCustom.

Member Data Documentation

◆ m_bLocked

BOOL m_bLocked
protected

Specifies whether the Node is locked.

TRUE if the node if locked, FALSE otherwise.

◆ m_bVisible

BOOL m_bVisible
protected

Specifies whether the Node is visible.

TRUE if the node if visible, FALSE otherwise.

◆ m_nStyle

int m_nStyle
protected

Reserved for future use.

Currently can be used as a "tag" property if needed.

◆ m_szWindow

CSize m_szWindow
protected

Size of the window of the attached control (if applicable).

For example, if a tree control was attached to the Node, this would be it's window size.

The documentation for this class was generated from the following file:
  • XTPFlowGraphNode.h


Toolkit Pro: CXTPFlowGraphNodeCustom Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPFlowGraphNodeCustom Class Reference

Represents a Node object defined by custom XAML markup. More...

Inheritance diagram for CXTPFlowGraphNodeCustom:
[legend]

Public Member Functions

CXTPFlowGraphNodeCustom ()
Constructs a CXTPFlowGraphNodeCustom object.
~CXTPFlowGraphNodeCustom ()
Destroys a CXTPFlowGraphNodeCustom object, handles cleanup and deallocation.
void | SetCaptionPosition (XTPFlowGraphCustomNodeCaptionPosition pos)
Sets the Node's caption position.
XTPFlowGraphCustomNodeCaptionPosition | GetCaptionPosition () const
Gets the Node's caption position.
CRect | GetSelectionRect ()
Retrieves the Node's selection rectangle (visible only when the Node is selected).
virtual void | SetWindowHandle (HWND)
Call this member to associate an object with the Node.
virtual void | SetWindowSize (CSize)
Sets the size of the window for the external control that is attached to the Node (if applicable).
virtual void | UpdateWindowPosition ()
Updates the window position of the attached external control.
virtual void | DrawWindowContent (CXTPFlowGraphDrawContext *)
Draws the contents of the Node.
virtual void | UpdateMarkupPointColor (CXTPFlowGraphConnectionPoint *)
Updates the Markup point color (when changed or restored using DoPropExchange).
virtual void | SetDefaultMarkup ()
Sets the default XAML Markup for a default Node with zero table rows.
virtual void | SetColor (COLORREF clr, BYTE bAlpha=255)
Sets the color for the Node.
virtual BOOL | IsCustomMarkup () const
A virtual function that determines if the Node is a custom Node (a Node with custom XAML markup).
virtual void | SetSize (CSize sz)
Sets the size for the Node (Node's Markup!).
virtual void | AddNamedConnectionPoints (LPCTSTR, XTPFlowGraphConnectionPointType, LPCTSTR)
Adds a table row to the Node (of default type), with none, one, or two real connection points.
virtual void | UpdateConnectionPoints (CXTPMarkupObject *pRootElement)
A virtual method that finds and updates real connection points in the Markup.
virtual void | UpdateColorRecursive (CXTPMarkupObject *pRootElement, COLORREF clrColor)
A recursive method to update/set the color of a Node.
virtual CXTPMarkupTextBlock * | UpdateMarkupCaption ()
Updates Node's caption <TextBlock> element with Node's caption text (m_strCaption).
virtual void | UpdateCaptionColor ()
Updates the foreground color of the CXTPMarkupTextBlock element of the Node's caption.
virtual void | CalcMinSize ()
A virtual method that calculates the minimum size of the Node (used in resizing mechanism).
virtual void | DoPropExchange (CXTPPropExchange *pPX)
Call this member function to store/load a Node using the specified data object.
virtual CXTPFlowGraphConnectionPoint * | HitTestConnectionPoint (CPoint point)
Determines which connection point, if any, is at a specified point.
- Public Member Functions inherited from CXTPFlowGraphNode
CXTPFlowGraphNode ()
Constructs a CXTPFlowGraphNode object.
virtual | ~CXTPFlowGraphNode ()
Destroys a CXTPFlowGraphNode object, handles cleanup and deallocation.
void | SetCaption (LPCTSTR lpszCaption)
Sets the caption that is displayed for this Node.
CString | GetCaption () const
Gets the caption that is displayed for this Node.
void | SetTooltip (LPCTSTR lpszTooltip)
Sets the tooltip for this Node.
CString | GetTooltip () const
Gets the tooltip for this Node.
COLORREF | GetColor () const
Gets the color of the node.
void | SetStyle (int nStyle)
Reserved for future use.
int | GetStyle () const
Reserved for future use.
void | SetTag (DWORD_PTR dwTag)
This method sets the 32-bit value associated with the Node.
DWORD_PTR | GetTag () const
This method retrieves the application-supplied, 32-bit value associated with the Node.
void | SetID (int nId)
Sets the ID used to identify this Node.
int | GetID () const
Gets the ID used to identify this Node.
HWND | GetWindowHandle () const
Call this member to get the HWND of the object associated with the Node.
CSize | GetWindowSize () const
Gets the size of the window for the external control that is attached to the Node (if applicable).
void | SetImageIndex (int nImageIndex)
Sets the ID of the image to display next to the caption text of the Node.
int | GetImageIndex () const
Gets the ID of the image to display next to the caption text of the Node.
void | SetLocked (BOOL bLocked=TRUE)
Sets the locked state of the Node.
BOOL | IsLocked () const
Gets the locked state of the Node.
void | SetVisible (BOOL bVisible=TRUE)
Sets the visibility of the Node and its connections.
BOOL | IsVisible () const
Gets the visibility of the Node and its connections.
void | SetLocation (CPoint ptLocation)
Sets the location of the Node.
CPoint | GetLocation () const
Gets the location of the Node.
void | SetSizeCore (CSize sz)
Sets the size for the Node.
CSize | GetSize () const
Gets the size of the Node.
CSize | GetUserSize () const
Gets the size of the Node (including user resizing).
BOOL | IsResizable () const
Checks if the Node is resizable.
CSize | GetMinSize () const
Gets the minimum size of the Node; calculated in the CalcMinSize method.
void | SetMinSize (CSize sz)
Sets the minimum size for the Node.
CRect | GetScreenRect (BOOL bIncludeConnectionPointsEllipses=TRUE) const
Gets the screen coordinates for the Node.
CXTPFlowGraphPage * | GetPage () const
Gets a reference to the page that this Node belongs to.
CXTPFlowGraphNodeGroup * | GetGroup () const
Retrieves the group that this Node is a part of (if any).
CXTPFlowGraphImage * | GetImage () const
Gets the image to display next to the caption text of the Node.
CXTPFlowGraphConnectionPoints * | GetConnectionPoints () const
Gets the connection points collection for this Node.
CXTPFlowGraphControl * | GetControl () const
Gets a reference to the parent FlowGraph control.
void | Remove ()
Removes this node from the flow graph.
virtual void | Select (BOOL bSelect=TRUE)
Specifies the selected state of the Node.
void | DoCommonPropExchange (CXTPPropExchange *pPX)
Stores/loads Node common properties (for both default and derived Nodes).
virtual void | RecalLayout ()
virtual void | Draw (CXTPFlowGraphDrawContext *pDC)
This method is called to draw the Node.
CRect | GetSelectionRect () const
Retrieves the Node's selection rectangle (visible only when the Node is selected).
virtual void | DrawSelectionRect (CXTPFlowGraphDrawContext *pDC)
This virtual method is called to draw the Node's selection rectangle.
virtual void | DrawConnectionPoints (CXTPFlowGraphDrawContext *pDC)
A virtual method that draws the Node's connection points (circles) in their placeholders.
CRect | GetMarkupVisualElementRect (const CXTPMarkupVisual *pElementVisual) const
An important common method used to get a rectangle of any visual Markup element.
int | GetMarkupTableRowIndex (CXTPFlowGraphConnectionPoint *pPoint, CXTPMarkupUIElementCollection *pChildren)
Retrieves the index of a table row in the list (to insert a new one).
int | RemoveMarkupTableRow (CXTPFlowGraphConnectionPoint *pPoint)
Removes a table row (with its connection points) from a default Node.
CXTPMarkupTextBlock * | GetTableRowTextBlock (const CString &strConnectionPointName) const
Retrieves the XAML TextBlock element for a table row of a default Node.
CRect | GetTableRowCaptionRect (CXTPFlowGraphConnectionPoint *pPoint) const
Retrieves the rectangle of a XAML TextBlock element for a table row of a default Node.
void | UpdateMarkupPointCaption (CXTPFlowGraphConnectionPoint *pPoint)
Updates the Markup point caption (when changed or restored using DoPropExchange).
void | UpdateMarkupPointName (CXTPFlowGraphConnectionPoint *pPoint)
Updates the Markup point name (when changed or restored using DoPropExchange).
void | UpdateMarkupPointImage (CXTPFlowGraphConnectionPoint *pPoint)
Updates the markup point image (when changed or restored using DoPropExchange).
BOOL | SetMarkupText (LPCTSTR szMarkupText)
Sets Markup text for the Node (for a custom Node).
virtual void | UpdateMarkupImage ()
Updates the Node's image.
CXTPMarkupTextBlock * | GetCaptionTextBlock () const
Get the Node's caption <TextBlock> element.
CRect | GetCaptionRect () const
Get the Node's caption <TextBlock> rectangle.
virtual void | UpdateMarkupFont ()
Updates the default font defined in the paint manager; used in Markup drawing.
- Public Member Functions inherited from CXTPFlowGraphElement
CXTPFlowGraphElement ()
Constructs a CXTPFlowGraphElement object.
virtual | ~CXTPFlowGraphElement ()
Destroys a CXTPFlowGraphElement object, handles cleanup and deallocation.
BOOL | IsSelected () const
Determines if the element is currently selected.
void | OnGraphChanged ()
This method is called when the flow graph layout is changed.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

CXTPMarkupPathData * | CreateStretchedPathData (const CXTPMarkupPath *pNodePath) const
Retrieves a stretched path from a specified path based on the render size the Node.
CRect | GetPointRect (CPoint point) const
Retrieves a rectangle with a specified point in the center of it.
- Protected Member Functions inherited from CXTPFlowGraphNode
virtual void | OnRemoved ()
This method is called when the Node is removed.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPFlowGraphElement
BOOL | m_bDirty
Internally used to tell the flow graph that the element has changed.
- Static Protected Member Functions inherited from CXTPFlowGraphNode
- Protected Attributes inherited from CXTPFlowGraphNode
CXTPFlowGraphPage * | m_pPage
Pointer to the page this Node is displayed on.
CXTPFlowGraphNode * | m_pNextVisibleNode
Pointer to the next visible node.
CString | m_strCaption
Caption displayed for this node.
CXTPMarkupUIElement * | m_pMarkup
Markup that is responsible for drawing this Node.
CPoint | m_ptLocation
Point that contains the coordinates of the Node.
CSize | m_szUserSize
Current size of the Node including user resizing.
CSize | m_szActualSize
Real size of the Node before the user might have resized it.
CSize | m_szUserMinSize
Manually set minimum size.
CString | m_strTooltip
Tooltip of the item.
COLORREF | m_clrNode
Color of the Node.
BYTE | m_bAlpha
Alpha channel 0-255.
int | m_nStyle
Reserved for future use.
DWORD_PTR | m_dwTag
The 32-bit value associated with the item.
int | m_nId
ID of the node.
HWND | m_hWnd
Handle of the window inside the Node.
WNDPROC | m_pOriginalWindowProc
Window procedure pointer.
CSize | m_szWindow
Size of the window of the attached control (if applicable).
int | m_nGroupId
ID of the group this Node belongs to (if any).
int | m_nImageIndex
Index of an image to display next to the caption text of the Node.
BOOL | m_bLocked
Specifies whether the Node is locked.
BOOL | m_bVisible
Specifies whether the Node is visible.
CXTPFlowGraphConnectionPoints * | m_pConnectionPoints
Collection of connection points that are displayed for this Node.
CXTPFlowGraphNodeGroup * | m_pGroup
Pointer to the group this Node belongs to (if any).
- Protected Attributes inherited from CXTPFlowGraphElement
BOOL | m_bSelected
Specifies whether the element is selected.
- Static Protected Attributes inherited from CXTPFlowGraphNode
static CMap< HWND, HWND, CXTPFlowGraphNode *, CXTPFlowGraphNode * > | m_WindowToNodeHash
Used in the custom window 'ControlWindowProc'.

Detailed Description

Represents a Node object defined by custom XAML markup.

XAML markup of a custom Node must have <Canvas x:Name='nodeCanvas'> as a root element. A child element of Canvas must be a shape (defined by Path, Image, etc.). A Path must have a Stretch='Fill' property for correct resizing of a Node. Path should have a certain name: <Path x:Name='nodePath' Stretch="Fill"/> If you want a Node to have a caption, you should specify <TextBlock x:Name='nodeCaption'/> as the second child element of Canvas. Connection points of a Node are supporting points of a shape if the shape is defined by a Path. Otherwise, when a custom Node is a shape with no Path (like ellipses or a custom image), connection points' disposition is defined by the ConnectionPointsIn property (see ellipse.xaml and image.xaml samples for details).

Member Function Documentation

◆ AddNamedConnectionPoints()

virtual void AddNamedConnectionPoints | ( | LPCTSTR | szName,
 |  | XTPFlowGraphConnectionPointType | type,
 |  | LPCTSTR | szCaption )
 inlinevirtual

Adds a table row to the Node (of default type), with none, one, or two real connection points.

Parameters
szName | Unique name.
szCaption | Caption of the table row. Uses szName if not specified.
type | Type.

Parameters : xtpFlowGraphPointNone No actual connection points. xtpFlowGraphPointInput One connection point (in the left of the row). xtpFlowGraphPointOutput One connection point (in the right of the row). xtpFlowGraphPointInputAndOutput Two connection points (in the left and right of the row).

Reimplemented from CXTPFlowGraphNode.

◆ CreateStretchedPathData()

CXTPMarkupPathData * CreateStretchedPathData ( const CXTPMarkupPath * pNodePath ) const
protected

Retrieves a stretched path from a specified path based on the render size the Node.

Parameters
pNodePath The specified path.
Returns
The new stretched path (that must be deleted with a delete operator).

◆ DoPropExchange()

virtual void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Call this member function to store/load a Node using the specified data object.

Parameters
pPX Source/destination CXTPPropExchange data object reference.

This member function is used to store/load Node data to/from storage.

Reimplemented from CXTPFlowGraphNode.

◆ DrawWindowContent()

virtual void DrawWindowContent ( CXTPFlowGraphDrawContext * pDC )
inlinevirtual

Draws the contents of the Node.

Parameters
pDC Pointer to a CXTPFlowGraphDrawContext object.

Reimplemented from CXTPFlowGraphNode.

◆ GetCaptionPosition()

XTPFlowGraphCustomNodeCaptionPosition GetCaptionPosition ( ) const

Gets the Node's caption position.

Returns
The Node's caption position.

◆ GetPointRect()

CRect GetPointRect ( CPoint point ) const
protected

Retrieves a rectangle with a specified point in the center of it.

Parameters
point The specified point.
Returns
The rectangle with the specified point in the center of it.

◆ GetSelectionRect()

CRect GetSelectionRect ( )

Retrieves the Node's selection rectangle (visible only when the Node is selected).

Returns
The Node's selection rectangle.

◆ HitTestConnectionPoint()

virtual CXTPFlowGraphConnectionPoint * HitTestConnectionPoint ( CPoint point )
virtual

Determines which connection point, if any, is at a specified point.

Parameters
point Point to be tested.
Returns
A pointer to the connection point found at the specified point, if any, or NULL if no connection point is found.

Reimplemented from CXTPFlowGraphNode.

◆ IsCustomMarkup()

virtual BOOL IsCustomMarkup ( ) const
inlinevirtual

A virtual function that determines if the Node is a custom Node (a Node with custom XAML markup).

Returns
TRUE if the Node is a custom Node, otherwise FALSE.

Reimplemented from CXTPFlowGraphNode.

◆ SetCaptionPosition()

void SetCaptionPosition ( XTPFlowGraphCustomNodeCaptionPosition pos )

Sets the Node's caption position.

Parameters
pos New caption position.

◆ SetColor()

virtual void SetColor | ( | COLORREF | clr,
 |  | BYTE | bAlpha = 255 )
 virtual

Sets the color for the Node.

Parameters
clr | New color for the Node.
bAlpha | Alpha value for Node.

Reimplemented from CXTPFlowGraphNode.

◆ SetSize()

virtual void SetSize ( CSize sz )
virtual

Sets the size for the Node (Node's Markup!).

Parameters
sz New size for the Node.

Reimplemented from CXTPFlowGraphNode.

◆ SetWindowHandle()

virtual void SetWindowHandle ( HWND hWnd )
inlinevirtual

Call this member to associate an object with the Node.

This will tell the Node what to display (i.e. the HWND of a dialog).

Parameters
hWnd HWND of the object that should be displayed in the Node.

Reimplemented from CXTPFlowGraphNode.

◆ SetWindowSize()

virtual void SetWindowSize ( CSize sz )
inlinevirtual

Sets the size of the window for the external control that is attached to the Node (if applicable).

Parameters
sz New size of the window.

This will set the size for the attached external control (i.e. if a tree control is attached to the node). You would attach the external control using the SetWindowHandle method.

Reimplemented from CXTPFlowGraphNode.

◆ UpdateColorRecursive()

virtual void UpdateColorRecursive | ( | CXTPMarkupObject * | pRootElement,
 |  | COLORREF | clrColor )
 virtual

A recursive method to update/set the color of a Node.

Parameters
pRootElement | An XAML element used to search for XAML elements that can have a color property (see XAML_MARKUP_PROPERTY_CANSETCOLOR).
clrColor | Color to be set.

Reimplemented from CXTPFlowGraphNode.

◆ UpdateConnectionPoints()

virtual void UpdateConnectionPoints ( CXTPMarkupObject * pRootElement )
virtual

A virtual method that finds and updates real connection points in the Markup.

Parameters
pRootElement An XAML element used to search for connection points in its children.

Implementation of this method for default Nodes is recursive. A rectangle for a connection point is defined by the <Rectangle> element in XAML for default Nodes. Implementation of this method for custom Nodes uses an absolutely different approach (see CXTPFlowGraphNodeCustom::UpdateConnectionPoints).

Reimplemented from CXTPFlowGraphNode.

◆ UpdateMarkupCaption()

virtual CXTPMarkupTextBlock * UpdateMarkupCaption ( )
virtual

Updates Node's caption <TextBlock> element with Node's caption text (m_strCaption).

Returns
A pointer to a CXTPMarkupTextBlock element.

Reimplemented from CXTPFlowGraphNode.

◆ UpdateMarkupPointColor()

virtual void UpdateMarkupPointColor ( CXTPFlowGraphConnectionPoint * pPoint )
inlinevirtual

Updates the Markup point color (when changed or restored using DoPropExchange).

Parameters
pPoint Pointer to a CXTPFlowGraphConnectionPoint object.

Reimplemented from CXTPFlowGraphNode.

◆ UpdateWindowPosition()

virtual void UpdateWindowPosition ( )
inlinevirtual

Updates the window position of the attached external control.

This method is also called internally when the Node is drawn.

Reimplemented from CXTPFlowGraphNode.

The documentation for this class was generated from the following file:
  • XTPFlowGraphNodeCustom.h


Toolkit Pro: CXTPFlowGraphNodeGroup Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPFlowGraphNodeGroup Class Reference

Represents a group of Nodes. More...

Inheritance diagram for CXTPFlowGraphNodeGroup:
[legend]

Public Member Functions

CXTPFlowGraphNodeGroup ()
Constructs a CXTPFlowGraphNodeGroup object.
virtual | ~CXTPFlowGraphNodeGroup ()
Destroys a CXTPFlowGraphNodeGroup object, handles cleanup and deallocation.
void | AddNode (CXTPFlowGraphNode *pNode)
Adds a Node to the Node group.
void | RemoveNode (CXTPFlowGraphNode *pNode)
Removes a Node from the Node group.
void | RemoveAll ()
Removes all nodes from this group.
void | Remove ()
Removes this group from the flow graph's collection of groups.
CXTPFlowGraphControl * | GetControl () const
Gets a reference to the parent FlowGraph control.
CXTPFlowGraphPage * | GetPage () const
Gets a reference to the page that this group belongs to.
int | GetCount () const
Get the total number of Nodes that are in the group.
CXTPFlowGraphNode * | GetAt (int nIndex) const
Retrieves the Node at the specified index from the group's collection of Nodes.
CRect | GetWorkRect () const
Gets the bounding rectangle for the group.
void | SetCaption (LPCTSTR lpszCaption)
Sets the common caption for each Node in the group.
CString | GetCaption () const
Gets the common caption for each Node in the group.
- Public Member Functions inherited from CXTPFlowGraphElement
CXTPFlowGraphElement ()
Constructs a CXTPFlowGraphElement object.
virtual | ~CXTPFlowGraphElement ()
Destroys a CXTPFlowGraphElement object, handles cleanup and deallocation.
BOOL | IsSelected () const
Determines if the element is currently selected.
void | OnGraphChanged ()
This method is called when the flow graph layout is changed.
virtual void | OnRemoved ()
This method is called when the element is removed.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Attributes

CArray< CXTPFlowGraphNode *, CXTPFlowGraphNode * > | m_arrNodes
Collection of nodes that are in this group.
CXTPFlowGraphNodeGroups * | m_pGroups
Pointer to the collection of groups that this belongs to.
CRect | m_rcWorkRect
Rectangle displayed for this group.
- Protected Attributes inherited from CXTPFlowGraphElement
BOOL | m_bSelected
Specifies whether the element is selected.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPFlowGraphElement
BOOL | m_bDirty
Internally used to tell the flow graph that the element has changed.

Detailed Description

Represents a group of Nodes.

A group is just a "box" that is used to visually group Nodes together. By default, the group will only be shown when a Node in the group is selected, but you can choose to always show the groups with ShowNodeGroupsAlways.

Member Function Documentation

◆ AddNode()

void AddNode ( CXTPFlowGraphNode * pNode )

Adds a Node to the Node group.

Parameters
pNode Reference to the Node to add to the group.

◆ GetAt()

AFX_INLINE CXTPFlowGraphNode * GetAt ( int nIndex ) const

Retrieves the Node at the specified index from the group's collection of Nodes.

Parameters
nIndex Index of the specified Node to retrieve.
Returns
A reference to the specified Node.

◆ GetCaption()

CString GetCaption ( ) const
virtual

Gets the common caption for each Node in the group.

If any Nodes in the group have a different caption, then the return value will be an empty string.

Returns
If all Nodes in the group share the same caption, then the common caption for each Node in the group will be returned. If any Nodes in the group have a different caption, then an empty string will be returned.

Implements CXTPFlowGraphElement.

◆ GetControl()

CXTPFlowGraphControl * GetControl ( ) const
virtual

Gets a reference to the parent FlowGraph control.

Returns
A reference to the parent FlowGraph control.

Implements CXTPFlowGraphElement.

◆ GetCount()

AFX_INLINE int GetCount ( ) const

Get the total number of Nodes that are in the group.

Returns
The total number of Nodes that are in the group.

◆ GetPage()

CXTPFlowGraphPage * GetPage ( ) const
virtual

Gets a reference to the page that this group belongs to.

Returns
A reference to the page that this group belongs to.

Implements CXTPFlowGraphElement.

◆ GetWorkRect()

AFX_INLINE CRect GetWorkRect ( ) const

Gets the bounding rectangle for the group.

Returns
The bounding rectangle for the group.

◆ RemoveNode()

void RemoveNode ( CXTPFlowGraphNode * pNode )

Removes a Node from the Node group.

Parameters
pNode Reference to the Node to remove from the group.

◆ SetCaption()

void SetCaption ( LPCTSTR lpszCaption )
virtual

Sets the common caption for each Node in the group.

Parameters
lpszCaption New common caption for each Node in the group.

Implements CXTPFlowGraphElement.

The documentation for this class was generated from the following file:
  • XTPFlowGraphNodeGroup.h


Toolkit Pro: CXTPFlowGraphNodeGroups Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPFlowGraphNodeGroups Class Reference

Represents a collection of groups in a page. More...

Inheritance diagram for CXTPFlowGraphNodeGroups:
[legend]

Public Member Functions

void | RemoveAll ()
Removes all groups from the collection.
CXTPFlowGraphNodeGroup * AddGroup ()
Adds a group to the page's collection of groups.
int | GetCount () const
Retrieves the total number of groups in the collection.
CXTPFlowGraphNodeGroup * | GetAt (int nIndex) const
Gets the group at a specified index in the collection.
void | Remove (CXTPFlowGraphNodeGroup *pGroup)
Removes a specific group from the collection.
CXTPFlowGraphPage * | GetPage () const
Retrieves a reference to the flow graph page that this collection of groups are displayed on.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

CXTPFlowGraphNodeGroups (CXTPFlowGraphPage *pPage)
Constructs a CXTPFlowGraphNodeGroups object.
virtual ~CXTPFlowGraphNodeGroups ()
Destroys a CXTPFlowGraphNodeGroups object, handles cleanup and deallocation.

Protected Attributes

CXTPFlowGraphPage * | m_pPage
Pointer to the page that this collection of groups is displayed on.
CArray< CXTPFlowGraphNodeGroup *, CXTPFlowGraphNodeGroup * > | m_arrGroups
Collection of groups.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

Represents a collection of groups in a page.

A group is just a "box" that is used to visually group Nodes together. By default, the group will only be shown when a Node in the group is selected, but you can choose to always show the groups with ShowNodeGroupsAlways.

Constructor & Destructor Documentation

◆ CXTPFlowGraphNodeGroups()

CXTPFlowGraphNodeGroups ( CXTPFlowGraphPage * pPage )
protected

Constructs a CXTPFlowGraphNodeGroups object.

Parameters
pPage An associated graph page object pointer.

Member Function Documentation

◆ AddGroup()

CXTPFlowGraphNodeGroup * AddGroup ( )

Adds a group to the page's collection of groups.

Returns
A reference to the group added.

◆ GetAt()

AFX_INLINE CXTPFlowGraphNodeGroup * GetAt ( int nIndex ) const

Gets the group at a specified index in the collection.

Parameters
nIndex Index of the group in the collection.
Returns
A reference to the group at the specified index in the collection.

◆ GetCount()

AFX_INLINE int GetCount ( ) const

Retrieves the total number of groups in the collection.

Returns
The total number of groups in the collection.

◆ GetPage()

AFX_INLINE CXTPFlowGraphPage * GetPage ( ) const

Retrieves a reference to the flow graph page that this collection of groups are displayed on.

Returns
A reference to the flow graph page that this collection of groups are displayed on.

◆ Remove()

void Remove ( CXTPFlowGraphNodeGroup * pGroup )

Removes a specific group from the collection.

Parameters
pGroup Reference to the group to remove.
The documentation for this class was generated from the following file:
  • XTPFlowGraphNodeGroups.h


Toolkit Pro: CXTPFlowGraphNodes Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPFlowGraphNodes Class Reference

Represents a collection of Nodes in a page or group. More...

Inheritance diagram for CXTPFlowGraphNodes:
[legend]

Public Member Functions

void | RemoveAll ()
Removes all Nodes from the page or group.
CXTPFlowGraphNode * | AddNode (CXTPFlowGraphNode *pNode)
Adds a node to a page or group.
CXTPFlowGraphNodeCustom * | AddCustomNode (CXTPFlowGraphNodeCustom *pNode=NULL)
Adds a custom node.
void | Remove (CXTPFlowGraphNode *pNode)
Removes the specified Node.
void | RemoveAt (int nIndex)
Removes the specified Node from the page or group.
CXTPFlowGraphNode * | FindNode (int nId) const
Finds and retrieves the specified Node.
int | GetCount () const
Retrieves the total number of Nodes in the page or group.
CXTPFlowGraphNode * | GetAt (int nIndex) const
Gets the Node at the specified index.
void | MoveToFront (CXTPFlowGraphNode *pNode)
Moves the specified Node to the front.
void | DoPropExchange (CXTPPropExchange *pPX)
Call this member function to store/load a collection of Nodes using the specified data object.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

CXTPFlowGraphNodes (CXTPFlowGraphPage *pPage)
Constructs a CXTPFlowGraphPage object.
virtual ~CXTPFlowGraphNodes ()
Destroys a CXTPFlowGraphNodes object, handles cleanup and deallocation.

Protected Attributes

CXTPFlowGraphPage * | m_pPage
Pointer to the page this collection of nodes is displayed on.
CArray< CXTPFlowGraphNode *, CXTPFlowGraphNode * > | m_arrNodes
Collection of nodes.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

Represents a collection of Nodes in a page or group.

Nodes are the main objects that are displayed in the flow graph. In terms of a database, they can be thought of as tables. Nodes contain many connection points, which are like the fields in a table. Finally, there are connections that are used to draw a relationship between the fields of two tables.

Constructor & Destructor Documentation

◆ CXTPFlowGraphNodes()

CXTPFlowGraphNodes ( CXTPFlowGraphPage * pPage )
protected

Constructs a CXTPFlowGraphPage object.

Parameters
pPage An associated graph page object pointer.

Member Function Documentation

◆ AddCustomNode()

CXTPFlowGraphNodeCustom * AddCustomNode ( CXTPFlowGraphNodeCustom * pNode = NULL )

Adds a custom node.

Parameters
pNode A new custom node to add.
Returns
A newly added custom node object pointer.

◆ AddNode()

CXTPFlowGraphNode * AddNode ( CXTPFlowGraphNode * pNode )

Adds a node to a page or group.

Parameters
pNode Reference to the Node to add.
Returns
A reference to the Node that was added.

◆ DoPropExchange()

void DoPropExchange ( CXTPPropExchange * pPX )

Call this member function to store/load a collection of Nodes using the specified data object.

Parameters
pPX Source/destination CXTPPropExchange data object reference.

This member function is used to store/load a collection of Nodes data to/from a storage.

◆ FindNode()

CXTPFlowGraphNode * FindNode ( int nId ) const

Finds and retrieves the specified Node.

Parameters
nId ID of the node to find and retrieve.
Returns
If found, then a reference to the Node with the specified ID will be returned. Otherwise, a NULL value will be returned.

◆ GetAt()

AFX_INLINE CXTPFlowGraphNode * GetAt ( int nIndex ) const

Gets the Node at the specified index.

Parameters
nIndex Index of the specified Node.
Returns
A reference to the specified Node.

◆ GetCount()

AFX_INLINE int GetCount ( ) const

Retrieves the total number of Nodes in the page or group.

Returns
The total number of Nodes in the page or group.

◆ MoveToFront()

void MoveToFront ( CXTPFlowGraphNode * pNode )

Moves the specified Node to the front.

Parameters
pNode Reference to the Node to move to the front.

◆ Remove()

void Remove ( CXTPFlowGraphNode * pNode )

Removes the specified Node.

Parameters
pNode Reference to the Node to remove.

◆ RemoveAt()

void RemoveAt ( int nIndex )

Removes the specified Node from the page or group.

Parameters
nIndex Index of the node to remove.
The documentation for this class was generated from the following file:
  • XTPFlowGraphNodes.h


Toolkit Pro: CXTPFlowGraphPage Class Reference

Public Member Functions | Static Public Attributes | Protected Member Functions | Protected Attributes | List of all members
CXTPFlowGraphPage Class Reference

Represents a page in the flow graph. More...

Inheritance diagram for CXTPFlowGraphPage:
[legend]

Public Member Functions

CXTPFlowGraphPage ()
Constructs a CXTPFlowGraphPage object.
CXTPFlowGraphNodes * | GetNodes () const
Gets a collection of all Nodes that have been added to this page.
CXTPFlowGraphNodeGroups * | GetGroups () const
Gets a collection of all groups that have been added to this page.
CXTPFlowGraphControl * | GetControl () const
Gets a reference to the parent FlowGraph control.
CXTPFlowGraphConnections * | GetConnections () const
Gets a collection of all connections that have been added to this page.
void | SetID (int nId)
Sets the ID for this page.
int | GetID () const
Gets the ID of this page.
void | SetCaption (LPCTSTR lpszCaption)
Sets the caption for this page.
CString | GetCaption () const
Gets the caption of this page.
virtual void | OnGraphChanged ()
This method is called when the flow graph layout is changed.
virtual void | Reposition (CXTPFlowGraphDrawContext *pDC, CRect rcPage)
This method is called to move the contents of the page to their correct positions.
virtual void | OnDraw (CXTPFlowGraphDrawContext *pDC)
This method is called when the page is drawn.
CRect | PageToScreen (LPCRECT lpRect) const
Converts the page coordinates of a given point or rectangle on the display to screen coordinates.
void | ScreenToPage (double &x, double &y) const
Converts the given x- and y- screen coordinates to page coordinates.
CPoint | ScreenToPage (CPoint point) const
Converts the screen coordinates of a given point or rectangle on the display to page coordinates.
CRect | ScreenToPage (LPCRECT lpRect) const
Converts the screen coordinates of a given point or rectangle on the display to page coordinates.
virtual void | Copy ()
Call this method to copy all the currently selected elements to the flow graph's clipboard.
virtual void | Paste ()
Call this method to paste the contents of the flow graph's clipboard to the currently active page.
virtual BOOL | CanPaste ()
Specifies whether the flow control can perform a paste operation.
virtual void | Cut ()
Call this method to copy all the currently selected elements to the flow graph's clipboard and then remove the selected contents from the active page.
void | Remove ()
Removes this page from the flow graph.
virtual void | Arrange ()
Auto-arranges the Nodes in this page.
CXTPFlowGraphSelectedElements * | GetSelection () const
Gets a reference to the collection of selected elements in the flow graph in this page.
CRect | GetPageRect () const
Gets the bounding rectangle for this page.
CPoint | GetScrollOffset () const
Retrieves the scroll offset (how much the page has been scrolled).
void | SetScrollOffset (CPoint ptScrollOffset)
Sets the scroll offset (how much the page has been scrolled).
double | GetZoomLevel () const
Gets the current zoom level of the page.
void | SetZoomLevel (double dZoomLevel)
Sets the current zoom level of the page.
virtual void | DoPropExchange (CXTPPropExchange *pPX)
Call this member function to store/load a page using the specified data object.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Static Public Attributes

static CLIPFORMAT m_cfNode
Clipboard format.

Protected Member Functions

virtual | ~CXTPFlowGraphPage ()
Destroys a CXTPFlowGraphPage object, handles cleanup and deallocation.
virtual void | OnRemoved ()
This method is called when the page is removed.
void | SetVisibleNodesWindowsRegions ()
Define visible regions of windows inside Nodes (if windows exist inside Nodes).

Protected Attributes

CXTPFlowGraphControl * | m_pControl
Pointer to the parent flow graph control.
CXTPFlowGraphNodes * | m_pNodes
Collection of Nodes that are displayed on this page.
CXTPFlowGraphNodeGroups * | m_pGroups
Collection of groups that are displayed on this page.
CXTPFlowGraphConnections * | m_pConnections
Collection of connections that are used in this page.
CXTPFlowGraphSelectedElements * | m_pSelectedElements
Collection of elements that are used this page.
CXTPFlowGraphNode * | m_pFirstVisibleNode
Pointer to the first visible Node in the page.
CXTPFlowGraphConnection * | m_pFirstVisibleConnection
Pointer to the first visible connection in the page.
CRect | m_rcPage
Bounding rectangle for this page.
CRect | m_rcWorkRect
Rectangle for the currently visible portion of the page (it might be zoomed or scrolled).
CPoint | m_ptScrollOffset
The scroll offset (how much the page has been scrolled).
double | m_dZoomLevel
Current zoom level of the page.
int | m_nId
ID of the page.
CString | m_strCaption
Caption of the page.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

Represents a page in the flow graph.

A page is what contains all the elements in the flow graph. The flow graph can contain many pages, each of which can contain Nodes, Node groups, and connections. A page is the first thing that you must add to the flow graph and then you can add elements to the pages.

Member Function Documentation

◆ Arrange()

virtual void Arrange ( )
virtual

Auto-arranges the Nodes in this page.

This will left-align all Nodes in this page. Nodes with connections will be placed to the right of the connected Node.

◆ CanPaste()

virtual BOOL CanPaste ( )
virtual

Specifies whether the flow control can perform a paste operation.

There must be something in the control's clipboard from a previous copy/cut before a paste operation can be performed.

Returns
TRUE if the flow control can perform a paste operation.

◆ DoPropExchange()

virtual void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Call this member function to store/load a page using the specified data object.

Parameters
pPX Source/destination CXTPPropExchange data object reference.

This member function is used to store/load page data to/from storage.

◆ GetCaption()

AFX_INLINE CString GetCaption ( ) const

Gets the caption of this page.

Returns
The caption of this page.

◆ GetConnections()

AFX_INLINE CXTPFlowGraphConnections * GetConnections ( ) const

Gets a collection of all connections that have been added to this page.

Returns
A collection of all connections that have been added to this page.

◆ GetControl()

AFX_INLINE CXTPFlowGraphControl * GetControl ( ) const

Gets a reference to the parent FlowGraph control.

Returns
A reference to the parent FlowGraph control.

◆ GetGroups()

AFX_INLINE CXTPFlowGraphNodeGroups * GetGroups ( ) const

Gets a collection of all groups that have been added to this page.

A group is just a "box" that is used to visually group Nodes together. By default, the group will only be shown when a Node in the group is selected, but you can choose to always show the groups with ShowNodeGroupsAlways.

Returns
A collection of all groups that have been added to this page.

◆ GetID()

AFX_INLINE int GetID ( ) const

Gets the ID of this page.

Returns
The ID of this page.

◆ GetNodes()

AFX_INLINE CXTPFlowGraphNodes * GetNodes ( ) const

Gets a collection of all Nodes that have been added to this page.

Nodes are the main objects that are displayed in the flow graph. In terms of a database, they can be thought of as tables. Nodes contain many connection points, which are like the fields in a table. Finally, there are connections that are used to draw a relationship between the fields of two tables.

Returns
A collection of all Nodes that have been added to this page.

◆ GetPageRect()

AFX_INLINE CRect GetPageRect ( ) const

Gets the bounding rectangle for this page.

Returns
The bounding rectangle for this page.

◆ GetScrollOffset()

AFX_INLINE CPoint GetScrollOffset ( ) const

Retrieves the scroll offset (how much the page has been scrolled).

This retrieves the X/Y coordinates excluding the left/right offset.

Returns
The scroll offset (how much the page has been scrolled); a point that contains the X/Y coordinates excluding the left/right offset.

◆ GetSelection()

AFX_INLINE CXTPFlowGraphSelectedElements * GetSelection ( ) const

Gets a reference to the collection of selected elements in the flow graph in this page.

Selected elements will include Nodes, connections, and connection points. This collection can be used to add/remove elements to/from the selection. Elements can be selected with the mouse or by using methods in code.

Returns
A reference to the collection of selected elements in the flow graph in this page.

◆ GetZoomLevel()

AFX_INLINE double GetZoomLevel ( ) const

Gets the current zoom level of the page.

0.0 is 0 zoom and 1.0 is 100% zoom.

Returns
The current zoom level of the page.

◆ OnDraw()

virtual void OnDraw ( CXTPFlowGraphDrawContext * pDC )
virtual

This method is called when the page is drawn.

Parameters
pDC Pointer to a valid device context.

◆ OnGraphChanged()

virtual void OnGraphChanged ( )
virtual

This method is called when the flow graph layout is changed.

This method is called when the page zoom level, page scroll offset, window/Node size, window handle, Node style, Node color, or connection style is changed.

◆ PageToScreen()

CRect PageToScreen ( LPCRECT lpRect ) const

Converts the page coordinates of a given point or rectangle on the display to screen coordinates.

Parameters
lpRect Pointer to a RECT structure or CRect object that contains the page coordinates to be converted.
Returns
A rectangle with page coordinates converted into screen coordinates.

◆ Reposition()

virtual void Reposition | ( | CXTPFlowGraphDrawContext * | pDC,
 |  | CRect | rcPage )
 virtual

This method is called to move the contents of the page to their correct positions.

Parameters
pDC | Pointer to a valid device context.
rcPage | Bounding rectangle of the page.

◆ ScreenToPage() [1/3]

CPoint ScreenToPage ( CPoint point ) const

Converts the screen coordinates of a given point or rectangle on the display to page coordinates.

Parameters
point Pointer to a CPoint object or POINT structure that contains the screen coordinates to be converted.

The ScreenToPage member function replaces the screen coordinates given in lpPoint or lpRect with page coordinates. The new coordinates are relative to the upper-left corner of the page area.

Returns
A point with screen coordinates converted into page coordinates.

◆ ScreenToPage() [2/3]

void ScreenToPage | ( | double & | x,
 |  | double & | y ) const

Converts the given x- and y- screen coordinates to page coordinates.

Parameters
x | Reference to the x- screen coordinate to be converted. This parameter will receive the converted x- page coordinate.
y | Reference to the y- screen coordinate to be converted. This parameter will receive the converted y- page coordinate.

The ScreenToPage member function replaces the given x- and y- screen coordinates with converted page coordinates. The new coordinates are relative to the upper-left corner of the page area.

◆ ScreenToPage() [3/3]

CRect ScreenToPage ( LPCRECT lpRect ) const

Converts the screen coordinates of a given point or rectangle on the display to page coordinates.

Parameters
lpRect Pointer to a CRect object or RECT structure that contains the screen coordinates to be converted.

The ScreenToPage member function replaces the screen coordinates given in lpPoint or lpRect with page coordinates. The new coordinates are relative to the upper-left corner of the page area.

Returns
A rectangle with screen coordinates converted into page coordinates.

◆ SetCaption()

AFX_INLINE void SetCaption ( LPCTSTR lpszCaption )

Sets the caption for this page.

Parameters
lpszCaption New caption for this page.

◆ SetID()

AFX_INLINE void SetID ( int nId )

Sets the ID for this page.

Parameters
nId New ID for this page.

◆ SetScrollOffset()

AFX_INLINE void SetScrollOffset ( CPoint ptScrollOffset )

Sets the scroll offset (how much the page has been scrolled).

This sets the X/Y coordinates excluding the left/right offset.

Parameters
ptScrollOffset New scroll offset (how much the page has been scrolled); a point that contains the X/Y coordinates excluding the left/right offset.

◆ SetZoomLevel()

AFX_INLINE void SetZoomLevel ( double dZoomLevel )

Sets the current zoom level of the page.

Parameters
dZoomLevel New zoom level to use.

0.0 is 0 zoom and 1.0 is 100% zoom.

Member Data Documentation

◆ m_ptScrollOffset

CPoint m_ptScrollOffset
protected

The scroll offset (how much the page has been scrolled).

This returns the X and Y coordinates - up/down offset.

The documentation for this class was generated from the following file:
  • XTPFlowGraphPage.h


Toolkit Pro: CXTPFlowGraphPageHistory Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPFlowGraphPageHistory Class Reference

Object that contains page transition history for the flow graph. More...

Inheritance diagram for CXTPFlowGraphPageHistory:
[legend]

Public Member Functions

CXTPFlowGraphPageHistory (CXTPFlowGraphControl *pControl)
Constructs a CXTPFlowGraphPageHistory object.
void | GoForward ()
Moves to the next page in the flow graph's history (if available).
void | GoBackward ()
Moves to the previous page in the flow graph's history (if available).
BOOL | CanGoForward () const
Checks if a GoForward operation can be performed.
BOOL | CanGoBackward () const
Checks if a GoBack operation can be performed.
void | Clear ()
Clears the history of the flow graph.
void | AnimatePageTransition (CXTPFlowGraphNode *pNodeFrom, CXTPFlowGraphNode *pNodeTo)
This method will transition from a Node on the current page to a Node on a different page.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

virtual ~CXTPFlowGraphPageHistory ()
Destroys a CXTPFlowGraphPageHistory object, handles cleanup and deallocation.

Protected Attributes

CXTPFlowGraphControl * | m_pControl
Pointer to the parent flow graph control.
CArray< CXTPFlowGraphPageHistoryItem, CXTPFlowGraphPageHistoryItem & > | m_arrPageUndo
Contains all the undo actions from the history.
CArray< CXTPFlowGraphPageHistoryItem, CXTPFlowGraphPageHistoryItem & > | m_arrPageRedo
Contains all the redo actions from the history.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

Object that contains page transition history for the flow graph.

Constructor & Destructor Documentation

◆ CXTPFlowGraphPageHistory()

CXTPFlowGraphPageHistory ( CXTPFlowGraphControl * pControl )

Constructs a CXTPFlowGraphPageHistory object.

Parameters
pControl Pointer to the flow graph control.

Member Function Documentation

◆ AnimatePageTransition()

void AnimatePageTransition | ( | CXTPFlowGraphNode * | pNodeFrom,
 |  | CXTPFlowGraphNode * | pNodeTo )

This method will transition from a Node on the current page to a Node on a different page.

Parameters
pNodeFrom | Reference to a Node on the current page to transition from.
pNodeTo | Reference to a Node on a different page to transition to.

AnimatePageTransition will transition from a Node on the current page to a Node on a different page. This will cause the active page to change to the page that contains the Node that was transitioned to.

◆ CanGoBackward()

BOOL CanGoBackward ( ) const

Checks if a GoBack operation can be performed.

A GoForward or page transition operation must be performed before a GoBack operation can be performed.

Returns
TRUE if a GoBack operation can be performed.

◆ CanGoForward()

BOOL CanGoForward ( ) const

Checks if a GoForward operation can be performed.

Returns
TRUE if a GoForward operation can be performed.
The documentation for this class was generated from the following file:
  • XTPFlowGraphPageHistory.h


Toolkit Pro: CXTPFlowGraphPageHistoryItem Struct Reference

Public Attributes | List of all members
CXTPFlowGraphPageHistoryItem Struct Reference

Used internally to store Node history for history operations. More...

Public Attributes

CXTPFlowGraphNode * | pFrom
Pointer to the previous Node.
CXTPFlowGraphNode * | pTo
Pointer to the destination Node.

Detailed Description

Used internally to store Node history for history operations.

The documentation for this struct was generated from the following file:
  • XTPFlowGraphPageHistory.h


Toolkit Pro: CXTPFlowGraphPages Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPFlowGraphPages Class Reference

Represents a collection of pages in the flow graph. More...

Inheritance diagram for CXTPFlowGraphPages:
[legend]

Public Member Functions

CXTPFlowGraphPage * | AddPage (CXTPFlowGraphPage *pPage)
Adds a page to the flow graph.
void | RemoveAll ()
Removes all pages from the flow graph.
int | GetCount () const
Retrieves the total number of pages in the flow graph.
CXTPFlowGraphPage * | GetAt (int nIndex) const
Gets a page at the specified index from the FlowGraph's collection of pages.
void | Remove (CXTPFlowGraphPage *pPage)
Removes a page from the FlowGraph.
void | RemoveAt (int nIndex)
Removes the specified page from the FlowGraph.
CXTPFlowGraphPage * | FindPage (int nId) const
Finds and retrieves the specified page.
void | DoPropExchange (CXTPPropExchange *pPX)
Call this member function to store/load a collection of pages using the specified data object.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

CXTPFlowGraphPages (CXTPFlowGraphControl *pControl)
Constructs a CXTPFlowGraphPages object.
virtual ~CXTPFlowGraphPages ()
Destroys a CXTPFlowGraphPages object, handles cleanup and deallocation.

Protected Attributes

CArray< CXTPFlowGraphPage *, CXTPFlowGraphPage * > | m_arrPages
Collection of pages in the flow graph control.
CXTPFlowGraphControl * | m_pControl
Pointer to the parent flow graph control.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

Represents a collection of pages in the flow graph.

A page is what contains all the elements in the flow graph. The flow graph can contain many pages, each of which can contain Nodes, Node groups, and connections. A page is the first thing that you must add to the flow graph and then you can add elements to the pages.

Constructor & Destructor Documentation

◆ CXTPFlowGraphPages()

CXTPFlowGraphPages ( CXTPFlowGraphControl * pControl )
protected

Constructs a CXTPFlowGraphPages object.

Parameters
pControl Pointer to the flow graph control.

Member Function Documentation

◆ AddPage()

CXTPFlowGraphPage * AddPage ( CXTPFlowGraphPage * pPage )

Adds a page to the flow graph.

Parameters
pPage Reference to the page to add.
Returns
A reference to the newly added FlowGraphPage.

◆ DoPropExchange()

void DoPropExchange ( CXTPPropExchange * pPX )

Call this member function to store/load a collection of pages using the specified data object.

Parameters
pPX Source/destination CXTPPropExchange data object reference.

This member function is used to store/load a collection of pages data to/from storage.

◆ FindPage()

CXTPFlowGraphPage * FindPage ( int nId ) const

Finds and retrieves the specified page.

Parameters
nId ID of the page to find and retrieve.
Returns
A reference to the page with the specified ID if found, otherwise NULL.

◆ GetAt()

AFX_INLINE CXTPFlowGraphPage * GetAt ( int nIndex ) const

Gets a page at the specified index from the FlowGraph's collection of pages.

Parameters
nIndex Index of the specified page.
Returns
A reference to the specified FlowGraphPage.

◆ GetCount()

AFX_INLINE int GetCount ( ) const

Retrieves the total number of pages in the flow graph.

Returns
The total number of pages in the flow graph.

◆ Remove()

void Remove ( CXTPFlowGraphPage * pPage )

Removes a page from the FlowGraph.

Parameters
pPage Reference to the page to remove.

◆ RemoveAt()

void RemoveAt ( int nIndex )

Removes the specified page from the FlowGraph.

Parameters
nIndex Index of the page to remove.
The documentation for this class was generated from the following file:
  • XTPFlowGraphPages.h


Toolkit Pro: CXTPFlowGraphPaintManager Class Reference

Public Member Functions | Static Public Member Functions | Public Attributes | List of all members
CXTPFlowGraphPaintManager Class Reference

Handles most of the drawing activities of the flow graph. More...

Inheritance diagram for CXTPFlowGraphPaintManager:
[legend]

Public Member Functions

CXTPFlowGraphPaintManager ()
Constructs a CXTPFlowGraphPaintManager object.
virtual | ~CXTPFlowGraphPaintManager ()
Destroys a CXTPFlowGraphPaintManager object, handles cleanup and deallocation.
virtual void | DrawControlBackground (CXTPFlowGraphDrawContext *pDC, CXTPFlowGraphControl *pControl, BOOL bPrintToFile=FALSE, const CRect &drawRect=CRect(0, 0, 0, 0))
Draws the background for the flow graph control.
virtual void | RefreshMetrics ()
This method is called to refresh the visual metrics of the flow graph.
virtual void | RecalcConnectionLayout (CXTPFlowGraphDrawContext *pDC, CXTPFlowGraphConnection *pConnection)
Recalculates the layout of the connection.
virtual void | DrawConnection (CXTPFlowGraphDrawContext *pDC, CXTPFlowGraphConnection *pConnection)
This method is called to draw a single connection in the flow graph control.
virtual CRect | GetNodeBoundingRectangle (CXTPFlowGraphNode *pNode)
Retrieves the bounding rectangle for the specified Node.
void | DrawTransparentRectangle (CXTPFlowGraphDrawContext *pDC, CRect rect, COLORREF clrColor)
This method is called to draw a transparent rectangle on the graph control.
virtual void | DrawNodeGroup (CXTPFlowGraphDrawContext *pDC, CXTPFlowGraphNodeGroup *pNodeGroup)
This method is called to draw a single Node group in the flow graph control.
virtual BOOL | HitTestConnectionArea (const CXTPFlowGraphConnectionPoint *pPoint, CPoint point)
Determines if the specified point is within the connection area.
virtual CRect | GetCaptionRect (CXTPFlowGraphElement *pNode)
Retrieves the bounding rectangle for the caption of the specified Node.
virtual void | Cleanup ()
Cleans up allocated resources used by the paint manager that have been allocated during draw routines.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Static Public Member Functions

static COLORREF AFX_CDECL | GetDarkColor (COLORREF clrBackground)
Creates and retrieves a darker color of a specified color.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Public Attributes

COLORREF | m_clrBackground
Specifies the background "canvas" color for the flow graph.
COLORREF | m_clrSelection
Specifies the color used for selected Node's connection points' rectangles.
COLORREF | m_clrSelectionInactive
Specifies the color used for selected Node's (inactive).
COLORREF | m_clrTextColor
Specifies the color used for text.
COLORREF | m_clrTextColorSelected
Specifies the color used for text when a Node is selected.
COLORREF | m_clrGridColor
Specifies the color used for grid lines.
COLORREF | m_clrNodeBackground
Gets/sets the background color used for Nodes.
LOGFONT | m_lfText
Gets/sets the font used for connection captions.
LOGFONT | m_lfCaption
Gets/sets the font used for Node captions.
int | m_nNodeFrameSize
Gets/sets the size of the border-frame of a Node.
int | m_nPointTextMargin
Specifies the margin to place between a connection's caption text and the connection's connection point (if a connection point is present).
COLORREF | m_clrConnection
Specifies the color of the connection lines that connect connection points.
int | m_nEllipseSize
Specifies the size of connection points.
BOOL | m_bShowGrid
Specifies whether to show the grid for the flow graph.
BOOL | m_bShowNodeGroupsAlways
Specifies whether to always show Node groups, even if a non-grouped Node is selected (or if no Nodes are selected).
BOOL | m_bAlwaysDrawConnectionPoints
Specifies whether to draw connection points always draw only on active Nodes.
BOOL | m_bRecalcConnectionLayoutWhenNeeded
Recalculates the end points of a connection its selected state changes.
BOOL | m_bChangeNodeColorWhenSelected
TRUE by default.
XTPFlowGraphConnectorType | m_nConnectorType
Node connector style.
double | m_dMinZoomLevelBackground
Specifies the minimum zoom level to stop drawing the background of the flow graph.
double | m_dMinZoomLevelConnectionPoints
Specifies the minimum zoom level to stop drawing connection points in the flow graph.
double | m_dMinZoomLevelConnections
Specifies the minimum zoom level to stop drawing connections in the flow graph.
double | m_dMinZoomLevelGDIQuality
Specifies the minimum zoom level to stop using GDI quality when drawing elements in the flow graph.

Detailed Description

Handles most of the drawing activities of the flow graph.

Member Function Documentation

◆ DrawConnection()

virtual void DrawConnection | ( | CXTPFlowGraphDrawContext * | pDC,
 |  | CXTPFlowGraphConnection * | pConnection )
 virtual

This method is called to draw a single connection in the flow graph control.

Parameters
pDC | Pointer to a valid device context.
pConnection | Pointer to a CXTPFlowGraphConnection object to draw.

◆ DrawControlBackground()

virtual void DrawControlBackground | ( | CXTPFlowGraphDrawContext * | pDC,
 |  | CXTPFlowGraphControl * | pControl,
 |  | BOOL | bPrintToFile = FALSE,
 |  | const CRect & | drawRect = CRect(0, 0, 0, 0) )
 virtual

Draws the background for the flow graph control.

Parameters
pDC | Pointer to a valid device context.
pControl | Pointer to the flow graph control.
bPrintToFile | TRUE to print to file.
drawRect | Size of the area to draw.

◆ DrawNodeGroup()

virtual void DrawNodeGroup | ( | CXTPFlowGraphDrawContext * | pDC,
 |  | CXTPFlowGraphNodeGroup * | pNodeGroup )
 virtual

This method is called to draw a single Node group in the flow graph control.

Parameters
pDC | Pointer to a valid device context.
pNodeGroup | Pointer to a CXTPFlowGraphNodeGroup object to draw.

◆ DrawTransparentRectangle()

void DrawTransparentRectangle | ( | CXTPFlowGraphDrawContext * | pDC,
 |  | CRect | rect,
 |  | COLORREF | clrColor )

This method is called to draw a transparent rectangle on the graph control.

Parameters
pDC | Pointer to a valid device context.
rect | Rectangle boundaries.
clrColor | Base color.

◆ GetCaptionRect()

virtual CRect GetCaptionRect ( CXTPFlowGraphElement * pNode )
virtual

Retrieves the bounding rectangle for the caption of the specified Node.

Parameters
pNode Reference to the element to retrieve the bounding rectangle for the caption.
Returns
The bounding rectangle for the caption of the specified Node.

◆ GetDarkColor()

static COLORREF AFX_CDECL GetDarkColor ( COLORREF clrBackground )
static

Creates and retrieves a darker color of a specified color.

Parameters
clrBackground Color to make darker.

This will take the specified color and make it darker. For example, it will take blue and make "dark blue". This is also used internally to make the Node and group frame colors.

Returns
A darker color of the specified color.

◆ GetNodeBoundingRectangle()

virtual CRect GetNodeBoundingRectangle ( CXTPFlowGraphNode * pNode )
virtual

Retrieves the bounding rectangle for the specified Node.

Parameters
pNode Reference to the Node whose bounding rectangle must be retrieved.
Returns
The bounding rectangle for the specified node.

◆ HitTestConnectionArea()

virtual BOOL HitTestConnectionArea | ( | const CXTPFlowGraphConnectionPoint * | pPoint,
 |  | CPoint | point )
 virtual

Determines if the specified point is within the connection area.

Parameters
pPoint | CXTPFlowGraphConnectionPoint to test.
point | Point in the flow graph to test.
Returns
TRUE if the point is located within the connection area, otherwise FALSE.

◆ RecalcConnectionLayout()

virtual void RecalcConnectionLayout | ( | CXTPFlowGraphDrawContext * | pDC,
 |  | CXTPFlowGraphConnection * | pConnection )
 virtual

Recalculates the layout of the connection.

Parameters
pDC | Drawing device context pointer.
pConnection | Connection object pointer.

Call this functions to correctly reposition the connection within the Node. This will also update any colors, etc. that have changed.

Member Data Documentation

◆ m_bChangeNodeColorWhenSelected

BOOL m_bChangeNodeColorWhenSelected

TRUE by default.

Otherwise selected Node's caption text color is changed (to white by default, m_clrTextColorSelected).

◆ m_dMinZoomLevelBackground

double m_dMinZoomLevelBackground

Specifies the minimum zoom level to stop drawing the background of the flow graph.

Default is 20%. Can be used to optimize drawing when a lot of objects are on screen.

◆ m_dMinZoomLevelConnectionPoints

double m_dMinZoomLevelConnectionPoints

Specifies the minimum zoom level to stop drawing connection points in the flow graph.

Default is 30%. Can be used to optimize drawing when a lot of objects are on screen.

◆ m_dMinZoomLevelConnections

double m_dMinZoomLevelConnections

Specifies the minimum zoom level to stop drawing connections in the flow graph.

Default is 5%. Can be used to optimize drawing when a lot of objects are on screen.

◆ m_dMinZoomLevelGDIQuality

double m_dMinZoomLevelGDIQuality

Specifies the minimum zoom level to stop using GDI quality when drawing elements in the flow graph.

Default is 40%. Can be used to optimize drawing when a lot of objects are on screen.

The documentation for this class was generated from the following file:
  • XTPFlowGraphPaintManager.h


Toolkit Pro: CXTPFlowGraphSelectedElements Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPFlowGraphSelectedElements Class Reference

Collection of selected elements in the flow graph. More...

Inheritance diagram for CXTPFlowGraphSelectedElements:
[legend]

Public Member Functions

CXTPFlowGraphSelectedElements (CXTPFlowGraphPage *pPage)
Constructs a CXTPFlowGraphSelectedElements object.
virtual | ~CXTPFlowGraphSelectedElements ()
Destroys a CXTPFlowGraphSelectedElements object, handles cleanup and deallocation.
void | Clear ()
Removes all elements from the current selection.
void | SetSelection (CXTPFlowGraphElement *pElement)
Sets the current selection to a specified element.
void | AddSelection (CXTPFlowGraphElement *pElement)
Adds an element to the current selection.
void | Remove (CXTPFlowGraphElement *pElement)
Removes an element from the current selection.
void | RemoveAt (int nIndex)
Removes the element at a specified index from the current selection.
int | GetCount () const
Retrieves the number of elements in the current selection.
CXTPFlowGraphElement * | GetAt (int nIndex) const
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Attributes

CArray< CXTPFlowGraphElement *, CXTPFlowGraphElement * > | m_arrSelectedElements
Collection of selected elements.
CXTPFlowGraphPage * | m_pPage
Pointer to the page that the selected elements are dispalyed on.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

Collection of selected elements in the flow graph.

Selected elements will include Nodes, connections, and connection points. This collection can be used to add/remove elements to/from the selection. Elements can be selected with the mouse or by using methods in code.

Constructor & Destructor Documentation

◆ CXTPFlowGraphSelectedElements()

CXTPFlowGraphSelectedElements ( CXTPFlowGraphPage * pPage )

Constructs a CXTPFlowGraphSelectedElements object.

Parameters
pPage Target flow graph page object pointer.

Member Function Documentation

◆ AddSelection()

void AddSelection ( CXTPFlowGraphElement * pElement )

Adds an element to the current selection.

Parameters
pElement The element to add to the current selection; can be any valid flow graph element (connection, node).

◆ GetAt()

AFX_INLINE CXTPFlowGraphElement * GetAt ( int nIndex ) const
Parameters
nIndex Index of the element to retrieve.

Elements are added using the SetSelection method and removed using the RemoveAt method.

Returns
Retrieves the element at a specified index from the current selection.

◆ GetCount()

AFX_INLINE int GetCount ( ) const

Retrieves the number of elements in the current selection.

Returns
The number of elements in the current selection.

◆ Remove()

void Remove ( CXTPFlowGraphElement * pElement )

Removes an element from the current selection.

Parameters
pElement The element to remove from the current selection; can be any valid flow graph element (connection, node).

◆ RemoveAt()

void RemoveAt ( int nIndex )

Removes the element at a specified index from the current selection.

Parameters
nIndex Index of the element to remove.

◆ SetSelection()

void SetSelection ( CXTPFlowGraphElement * pElement )

Sets the current selection to a specified element.

Parameters
pElement The element to set the current selection to; can be any valid flow graph element (connection, node).
The documentation for this class was generated from the following file:
  • XTPFlowGraphSelectedElements.h


Toolkit Pro: CXTPFlowGraphUndoAddConnectionCommand Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPFlowGraphUndoAddConnectionCommand Class Reference

This class abstracts the undo add connection command. More...

Inheritance diagram for CXTPFlowGraphUndoAddConnectionCommand:
[legend]

Public Member Functions

CXTPFlowGraphUndoAddConnectionCommand (CXTPFlowGraphConnection *pConnection)
Constructs a CXTPFlowGraphUndoAddConnectionCommand object.
virtual | ~CXTPFlowGraphUndoAddConnectionCommand ()
Destroys a CXTPFlowGraphUndoAddConnectionCommand object, handles cleanup and deallocation.
- Public Member Functions inherited from CXTPFlowGraphUndoCommand
int | GetID () const
Call this function to get the command ID associated with this object.

Protected Member Functions

virtual void | Undo ()
Call this function to do the undo operation.
- Protected Member Functions inherited from CXTPFlowGraphUndoCommand
CXTPFlowGraphUndoCommand (int nID)
Constructs a CXTPFlowGraphUndoCommand object.
virtual | ~CXTPFlowGraphUndoCommand ()
Destroys a CXTPFlowGraphUndoCommand object, handles cleanup and deallocation.

Protected Attributes

CXTPFlowGraphConnection * | m_pConnection
Pointer to the FlowGraph connection object.
- Protected Attributes inherited from CXTPFlowGraphUndoCommand
const int | m_nID
The command ID.

Detailed Description

This class abstracts the undo add connection command.

This is a kind of CXTPFlowGraphUndoCommand.

Constructor & Destructor Documentation

◆ CXTPFlowGraphUndoAddConnectionCommand()

CXTPFlowGraphUndoAddConnectionCommand ( CXTPFlowGraphConnection * pConnection )

Constructs a CXTPFlowGraphUndoAddConnectionCommand object.

Parameters
pConnection Pointer to a CXTPFlowGraphConnection object.

Member Function Documentation

◆ Undo()

virtual void Undo ( )
protectedvirtual

Call this function to do the undo operation.

This is a virtual function, so derived classes can provide their specific implementations.

Reimplemented from CXTPFlowGraphUndoCommand.

The documentation for this class was generated from the following file:
  • XTPFlowGraphUndoManager.h


Toolkit Pro: CXTPFlowGraphUndoAddConnectionPointCommand Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPFlowGraphUndoAddConnectionPointCommand Class Reference

This class abstracts the undo add connection point command. More...

Inheritance diagram for CXTPFlowGraphUndoAddConnectionPointCommand:
[legend]

Public Member Functions

CXTPFlowGraphUndoAddConnectionPointCommand (CXTPFlowGraphConnectionPoint *pConnectionPoint)
Constructs a CXTPFlowGraphUndoAddConnectionPointCommand object.
virtual | ~CXTPFlowGraphUndoAddConnectionPointCommand ()
Destroys a CXTPFlowGraphUndoAddConnectionPointCommand object, handles cleanup and deallocation.
- Public Member Functions inherited from CXTPFlowGraphUndoCommand
int | GetID () const
Call this function to get the command ID associated with this object.

Protected Member Functions

virtual void | Undo ()
Call this function to do the undo operation.
- Protected Member Functions inherited from CXTPFlowGraphUndoCommand
CXTPFlowGraphUndoCommand (int nID)
Constructs a CXTPFlowGraphUndoCommand object.
virtual | ~CXTPFlowGraphUndoCommand ()
Destroys a CXTPFlowGraphUndoCommand object, handles cleanup and deallocation.

Protected Attributes

CXTPFlowGraphConnectionPoint * | m_pConnectionPoint
Pointer to the FlowGraph point object.
- Protected Attributes inherited from CXTPFlowGraphUndoCommand
const int | m_nID
The command ID.

Detailed Description

This class abstracts the undo add connection point command.

This is a kind of CXTPFlowGraphUndoCommand.

Constructor & Destructor Documentation

◆ CXTPFlowGraphUndoAddConnectionPointCommand()

CXTPFlowGraphUndoAddConnectionPointCommand ( CXTPFlowGraphConnectionPoint * pConnectionPoint )

Constructs a CXTPFlowGraphUndoAddConnectionPointCommand object.

Parameters
pConnectionPoint Pointer to a CXTPFlowGraphConnectionPoint object.

Member Function Documentation

◆ Undo()

virtual void Undo ( )
protectedvirtual

Call this function to do the undo operation.

This is a virtual function, so derived classes can provide their specific implementations.

Reimplemented from CXTPFlowGraphUndoCommand.

The documentation for this class was generated from the following file:
  • XTPFlowGraphUndoManager.h


Toolkit Pro: CXTPFlowGraphUndoAddNodeCommand Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPFlowGraphUndoAddNodeCommand Class Reference

This class abstracts the undo add Node command. More...

Inheritance diagram for CXTPFlowGraphUndoAddNodeCommand:
[legend]

Public Member Functions

CXTPFlowGraphUndoAddNodeCommand (CXTPFlowGraphNode *pNode)
Constructs a CXTPFlowGraphUndoAddNodeCommand object.
virtual | ~CXTPFlowGraphUndoAddNodeCommand ()
Destroys a CXTPFlowGraphUndoAddNodeCommand object, handles cleanup and deallocation.
- Public Member Functions inherited from CXTPFlowGraphUndoCommand
int | GetID () const
Call this function to get the command ID associated with this object.

Protected Member Functions

virtual void | Undo ()
Call this function to do the undo operation.
- Protected Member Functions inherited from CXTPFlowGraphUndoCommand
CXTPFlowGraphUndoCommand (int nID)
Constructs a CXTPFlowGraphUndoCommand object.
virtual | ~CXTPFlowGraphUndoCommand ()
Destroys a CXTPFlowGraphUndoCommand object, handles cleanup and deallocation.

Protected Attributes

CXTPFlowGraphNode * | m_pNode
Pointer to the FlowGraph Node object.
- Protected Attributes inherited from CXTPFlowGraphUndoCommand
const int | m_nID
The command ID.

Detailed Description

This class abstracts the undo add Node command.

This is a kind of CXTPFlowGraphUndoCommand.

Constructor & Destructor Documentation

◆ CXTPFlowGraphUndoAddNodeCommand()

CXTPFlowGraphUndoAddNodeCommand ( CXTPFlowGraphNode * pNode )

Constructs a CXTPFlowGraphUndoAddNodeCommand object.

Parameters
pNode Pointer to a CXTPFlowGraphNode object.

Member Function Documentation

◆ Undo()

virtual void Undo ( )
protectedvirtual

Call this function to do the undo operation.

This is a virtual function, so derived classes can provide their specific implementations.

Reimplemented from CXTPFlowGraphUndoCommand.

The documentation for this class was generated from the following file:
  • XTPFlowGraphUndoManager.h


Toolkit Pro: CXTPFlowGraphUndoCommand Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPFlowGraphUndoCommand Class Reference

This class abstracts the undo command. More...

Inheritance diagram for CXTPFlowGraphUndoCommand:
[legend]

Public Member Functions

int GetID () const
Call this function to get the command ID associated with this object.

Protected Member Functions

CXTPFlowGraphUndoCommand (int nID)
Constructs a CXTPFlowGraphUndoCommand object.
virtual | ~CXTPFlowGraphUndoCommand ()
Destroys a CXTPFlowGraphUndoCommand object, handles cleanup and deallocation.
virtual void | Undo ()
Call this function to do the undo operation.

Protected Attributes

const int m_nID
The command ID.

Detailed Description

This class abstracts the undo command.

Constructor & Destructor Documentation

◆ CXTPFlowGraphUndoCommand()

CXTPFlowGraphUndoCommand ( int nID )
protected

Constructs a CXTPFlowGraphUndoCommand object.

Parameters
nID The command ID.

Member Function Documentation

◆ GetID()

AFX_INLINE int GetID ( ) const

Call this function to get the command ID associated with this object.

Returns
An int value denoting the command ID associated with this object.

◆ Undo()

virtual void Undo ( )
protectedvirtual

Call this function to do the undo operation.

This is a virtual function, so derived classes can provide their specific implementations.

Reimplemented in CXTPFlowGraphUndoAddConnectionCommand, CXTPFlowGraphUndoAddConnectionPointCommand, CXTPFlowGraphUndoAddNodeCommand, CXTPFlowGraphUndoDeleteConnectionCommand, CXTPFlowGraphUndoDeleteConnectionPointCommand, CXTPFlowGraphUndoDeleteNodeCommand, CXTPFlowGraphUndoGroupCommand, CXTPFlowGraphUndoSetConnectionPositionCommand, CXTPFlowGraphUndoSetNodeCaptionCommand, CXTPFlowGraphUndoSetNodePositionCommand, and CXTPFlowGraphUndoSetNodeSizeCommand.

The documentation for this class was generated from the following file:
  • XTPFlowGraphUndoManager.h


Toolkit Pro: CXTPFlowGraphUndoDeleteConnectionCommand Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPFlowGraphUndoDeleteConnectionCommand Class Reference

This class abstracts the undo delete connection command. More...

Inheritance diagram for CXTPFlowGraphUndoDeleteConnectionCommand:
[legend]

Public Member Functions

CXTPFlowGraphUndoDeleteConnectionCommand (CXTPFlowGraphConnection *pConnection)
Constructs a CXTPFlowGraphUndoDeleteConnectionCommand object.
virtual | ~CXTPFlowGraphUndoDeleteConnectionCommand ()
Destroys a CXTPFlowGraphUndoDeleteConnectionCommand object, handles cleanup and deallocation.
- Public Member Functions inherited from CXTPFlowGraphUndoCommand
int | GetID () const
Call this function to get the command ID associated with this object.

Protected Member Functions

virtual void | Undo ()
Call this function to do the undo operation.
- Protected Member Functions inherited from CXTPFlowGraphUndoCommand
CXTPFlowGraphUndoCommand (int nID)
Constructs a CXTPFlowGraphUndoCommand object.
virtual | ~CXTPFlowGraphUndoCommand ()
Destroys a CXTPFlowGraphUndoCommand object, handles cleanup and deallocation.

Protected Attributes

CXTPFlowGraphConnection * | m_pConnection
The FlowGraph connection object.
CXTPFlowGraphPage * | m_pPage
The FlowGraph page object.
- Protected Attributes inherited from CXTPFlowGraphUndoCommand
const int | m_nID
The command ID.

Detailed Description

This class abstracts the undo delete connection command.

This is a kind of CXTPFlowGraphUndoCommand.

Constructor & Destructor Documentation

◆ CXTPFlowGraphUndoDeleteConnectionCommand()

CXTPFlowGraphUndoDeleteConnectionCommand ( CXTPFlowGraphConnection * pConnection )

Constructs a CXTPFlowGraphUndoDeleteConnectionCommand object.

Parameters
pConnection Pointer to a CXTPFlowGraphConnection object.

Member Function Documentation

◆ Undo()

virtual void Undo ( )
protectedvirtual

Call this function to do the undo operation.

This is a virtual function, so derived classes can provide their specific implementations.

Reimplemented from CXTPFlowGraphUndoCommand.

The documentation for this class was generated from the following file:
  • XTPFlowGraphUndoManager.h


Toolkit Pro: CXTPFlowGraphUndoDeleteConnectionPointCommand Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPFlowGraphUndoDeleteConnectionPointCommand Class Reference

This class abstracts the undo delete connection point command. More...

Inheritance diagram for CXTPFlowGraphUndoDeleteConnectionPointCommand:
[legend]

Public Member Functions

CXTPFlowGraphUndoDeleteConnectionPointCommand (CXTPFlowGraphConnectionPoint *pConnectionPoint)
Constructs a CXTPFlowGraphUndoDeleteConnectionPointCommand object.
virtual | ~CXTPFlowGraphUndoDeleteConnectionPointCommand ()
Destroys a CXTPFlowGraphUndoDeleteConnectionPointCommand object, handles cleanup and deallocation.
- Public Member Functions inherited from CXTPFlowGraphUndoCommand
int | GetID () const
Call this function to get the command ID associated with this object.

Protected Member Functions

virtual void | Undo ()
Call this function to do the undo operation.
- Protected Member Functions inherited from CXTPFlowGraphUndoCommand
CXTPFlowGraphUndoCommand (int nID)
Constructs a CXTPFlowGraphUndoCommand object.
virtual | ~CXTPFlowGraphUndoCommand ()
Destroys a CXTPFlowGraphUndoCommand object, handles cleanup and deallocation.

Protected Attributes

CXTPFlowGraphNode * | m_pNode
The FlowGraph Node object.
CXTPFlowGraphConnectionPoint * | m_pConnectionPoint
The FlowGraph connection point object.
- Protected Attributes inherited from CXTPFlowGraphUndoCommand
const int | m_nID
The command ID.

Detailed Description

This class abstracts the undo delete connection point command.

This is a kind of CXTPFlowGraphUndoCommand.

Constructor & Destructor Documentation

◆ CXTPFlowGraphUndoDeleteConnectionPointCommand()

CXTPFlowGraphUndoDeleteConnectionPointCommand ( CXTPFlowGraphConnectionPoint * pConnectionPoint )

Constructs a CXTPFlowGraphUndoDeleteConnectionPointCommand object.

Parameters
pConnectionPoint Pointer to a CXTPFlowGraphConnectionPoint object.

Member Function Documentation

◆ Undo()

virtual void Undo ( )
protectedvirtual

Call this function to do the undo operation.

This is a virtual function, so derived classes can provide their specific implementations.

Reimplemented from CXTPFlowGraphUndoCommand.

The documentation for this class was generated from the following file:
  • XTPFlowGraphUndoManager.h


Toolkit Pro: CXTPFlowGraphUndoDeleteNodeCommand Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPFlowGraphUndoDeleteNodeCommand Class Reference

This class abstracts the undo delete Node command. More...

Inheritance diagram for CXTPFlowGraphUndoDeleteNodeCommand:
[legend]

Public Member Functions

CXTPFlowGraphUndoDeleteNodeCommand (CXTPFlowGraphNode *pNode)
Constructs a CXTPFlowGraphUndoDeleteNodeCommand object.
virtual | ~CXTPFlowGraphUndoDeleteNodeCommand ()
Destroys a CXTPFlowGraphUndoDeleteNodeCommand object, handles cleanup and deallocation.
- Public Member Functions inherited from CXTPFlowGraphUndoCommand
int | GetID () const
Call this function to get the command ID associated with this object.

Protected Member Functions

virtual void | Undo ()
Call this function to do the undo operation.
- Protected Member Functions inherited from CXTPFlowGraphUndoCommand
CXTPFlowGraphUndoCommand (int nID)
Constructs a CXTPFlowGraphUndoCommand object.
virtual | ~CXTPFlowGraphUndoCommand ()
Destroys a CXTPFlowGraphUndoCommand object, handles cleanup and deallocation.

Protected Attributes

CXTPFlowGraphNode * | m_pNode
The FlowGraph Node object.
CXTPFlowGraphPage * | m_pPage
The FlowGraph page object.
- Protected Attributes inherited from CXTPFlowGraphUndoCommand
const int | m_nID
The command ID.

Detailed Description

This class abstracts the undo delete Node command.

This is a kind of CXTPFlowGraphUndoCommand.

Constructor & Destructor Documentation

◆ CXTPFlowGraphUndoDeleteNodeCommand()

CXTPFlowGraphUndoDeleteNodeCommand ( CXTPFlowGraphNode * pNode )

Constructs a CXTPFlowGraphUndoDeleteNodeCommand object.

Parameters
pNode Pointer to a CXTPFlowGraphNode object.

Member Function Documentation

◆ Undo()

virtual void Undo ( )
protectedvirtual

Call this function to do the undo operation.

This is a virtual function, so derived classes can provide their specific implementations.

Reimplemented from CXTPFlowGraphUndoCommand.

The documentation for this class was generated from the following file:
  • XTPFlowGraphUndoManager.h


Toolkit Pro: CXTPFlowGraphUndoGroupCommand Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPFlowGraphUndoGroupCommand Class Reference

This class abstracts the undo commands in a group. More...

Inheritance diagram for CXTPFlowGraphUndoGroupCommand:
[legend]

Public Member Functions

virtual void | Undo ()
Call this function to do the undo operation.
int | GetCount () const
Call this function to get the number of command objects in this group.
void | Add (CXTPFlowGraphUndoCommand *pCommand)
Call this function to add a command to the command group.
- Public Member Functions inherited from CXTPFlowGraphUndoCommand
int | GetID () const
Call this function to get the command ID associated with this object.

Protected Member Functions

CXTPFlowGraphUndoGroupCommand (CXTPFlowGraphUndoManager *pManager)
Constructs a CXTPFlowGraphUndoGroupCommand object.
virtual | ~CXTPFlowGraphUndoGroupCommand ()
Destroys a CXTPFlowGraphUndoGroupCommand object, handles cleanup and deallocation.
- Protected Member Functions inherited from CXTPFlowGraphUndoCommand
CXTPFlowGraphUndoCommand (int nID)
Constructs a CXTPFlowGraphUndoCommand object.
virtual | ~CXTPFlowGraphUndoCommand ()
Destroys a CXTPFlowGraphUndoCommand object, handles cleanup and deallocation.

Protected Attributes

CArray< CXTPFlowGraphUndoCommand *, CXTPFlowGraphUndoCommand * > | m_arrUndoCommands
The command collection.
CXTPFlowGraphUndoManager * | m_pManager
The undo manager.
- Protected Attributes inherited from CXTPFlowGraphUndoCommand
const int | m_nID
The command ID.

Detailed Description

This class abstracts the undo commands in a group.

Constructor & Destructor Documentation

◆ CXTPFlowGraphUndoGroupCommand()

CXTPFlowGraphUndoGroupCommand ( CXTPFlowGraphUndoManager * pManager )
protected

Constructs a CXTPFlowGraphUndoGroupCommand object.

Parameters
pManager Pointer to a CXTPFlowGraphUndoManager object.

Member Function Documentation

◆ Add()

void Add ( CXTPFlowGraphUndoCommand * pCommand )

Call this function to add a command to the command group.

Parameters
pCommand Pointer to a CXTPFlowGraphUndoCommand object.

◆ GetCount()

int GetCount ( ) const

Call this function to get the number of command objects in this group.

Returns
An int value denoting the number of command objects in this group.

◆ Undo()

virtual void Undo ( )
virtual

Call this function to do the undo operation.

This is a virtual function, so derived classes can provide their specific implementations.

Reimplemented from CXTPFlowGraphUndoCommand.

The documentation for this class was generated from the following file:
  • XTPFlowGraphUndoManager.h


Toolkit Pro: CXTPFlowGraphUndoManager Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPFlowGraphUndoManager Class Reference

This class abstracts an undo manager. More...

Inheritance diagram for CXTPFlowGraphUndoManager:
[legend]

Public Member Functions

CXTPFlowGraphUndoManager ()
Constructs a CXTPFlowGraphUndoManager object.
virtual | ~CXTPFlowGraphUndoManager ()
Destroys a CXTPFlowGraphUndoManager object, handles cleanup and deallocation.
virtual void | Undo ()
Call this function to do the undo operation.
virtual void | Redo ()
Call this function to do the redo operation.
BOOL | CanUndo () const
Call this function to determine if the undo operation is possible in the current context.
BOOL | CanRedo () const
Call this function to determine if the redo operation is possible in the current context.
void | Clear ()
Call this function to clear the list of undo and redo operations.
void | AddUndoCommand (CXTPFlowGraphUndoCommand *pCommand)
Use this function to add an undo command to the collection of undo commands.
virtual void | StartGroup ()
Call this function to start an undo group command.
virtual void | EndGroup ()
Call this function to end an undo group command.
void | EnableUndoManager (BOOL bEnabled)
Use this function to enable/disable the undo manager.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Attributes

CArray< CXTPFlowGraphUndoCommand *, CXTPFlowGraphUndoCommand * > | m_arrUndoCommands
The undo commands array.
CArray< CXTPFlowGraphUndoCommand *, CXTPFlowGraphUndoCommand * > | m_arrRedoCommands
The redo command array.
CArray< CXTPFlowGraphUndoGroupCommand *, CXTPFlowGraphUndoGroupCommand * > | m_arrGroupStack
The groups stack.
int | m_nUndoContext
The undo context.
BOOL | m_bEnabled
Specifies whether the undo manager is enabled or disabled.
CXTPFlowGraphUndoGroupCommand * | m_pUndoGroup
The undo group command.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

This class abstracts an undo manager.

It manages all the undo operations of the FlowGraph control. This is a kind of CXTPCmdTarget.

The FlowGraphUndoManager allows for certain edit operations to be undone and re-done in the flow graph. Supported operations are Add/Remove/Move/Resize Nodes/Move Connector Lines/Rename Nodes/Grouping. If any of these operations are performed, then they can easily be undone or re-done using the methods of the FlowGraphUndoManager.

StartGroup and EndGroup are used to "group" a set of "undoable" operations together. Grouping the operations together is useful as grouped operations can be undone or re-done with a single call to Undo or Redo. If the operations are not grouped, then you would have to call Undo or Redo for each operation performed.

Any "undoable" operations performed between StartGroup and EndGroup will be undone or re-done with a single call to Undo or Redo.

Member Function Documentation

◆ AddUndoCommand()

void AddUndoCommand ( CXTPFlowGraphUndoCommand * pCommand )

Use this function to add an undo command to the collection of undo commands.

Parameters
pCommand Pointer to a CXTPFlowGraphUndoCommand object.

◆ CanRedo()

BOOL CanRedo ( ) const

Call this function to determine if the redo operation is possible in the current context.

Returns
TRUE if the redo operation is possible, otherwise FALSE.

◆ CanUndo()

BOOL CanUndo ( ) const

Call this function to determine if the undo operation is possible in the current context.

Returns
TRUE if the undo operation is possible, otherwise FALSE.

◆ EnableUndoManager()

AFX_INLINE void EnableUndoManager ( BOOL bEnabled )

Use this function to enable/disable the undo manager.

Parameters
bEnabled TRUE to enable, FALSE to disable.
The documentation for this class was generated from the following file:
  • XTPFlowGraphUndoManager.h


Toolkit Pro: CXTPFlowGraphUndoSetConnectionPositionCommand Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPFlowGraphUndoSetConnectionPositionCommand Class Reference

This class abstracts the undo set connection position command. More...

Inheritance diagram for CXTPFlowGraphUndoSetConnectionPositionCommand:
[legend]

Public Member Functions

CXTPFlowGraphUndoSetConnectionPositionCommand (CXTPFlowGraphConnection *pConnection, CPoint ptOldPosition)
Constructs a CXTPFlowGraphUndoSetConnectionPositionCommand object.
virtual | ~CXTPFlowGraphUndoSetConnectionPositionCommand ()
Destroys a CXTPFlowGraphUndoSetConnectionPositionCommand object, handles cleanup and deallocation.
- Public Member Functions inherited from CXTPFlowGraphUndoCommand
int | GetID () const
Call this function to get the command ID associated with this object.

Protected Member Functions

virtual void | Undo ()
Call this function to do the undo operation.
- Protected Member Functions inherited from CXTPFlowGraphUndoCommand
CXTPFlowGraphUndoCommand (int nID)
Constructs a CXTPFlowGraphUndoCommand object.
virtual | ~CXTPFlowGraphUndoCommand ()
Destroys a CXTPFlowGraphUndoCommand object, handles cleanup and deallocation.

Protected Attributes

CXTPFlowGraphConnection * | m_pConnection
Pointer to the FlowGraph connection object.
CPoint | m_ptOldPosition
Old position of the connection.
- Protected Attributes inherited from CXTPFlowGraphUndoCommand
const int | m_nID
The command ID.

Detailed Description

This class abstracts the undo set connection position command.

This is a kind of CXTPFlowGraphUndoCommand.

Constructor & Destructor Documentation

◆ CXTPFlowGraphUndoSetConnectionPositionCommand()

CXTPFlowGraphUndoSetConnectionPositionCommand | ( | CXTPFlowGraphConnection * | pConnection,
 |  | CPoint | ptOldPosition )

Constructs a CXTPFlowGraphUndoSetConnectionPositionCommand object.

Parameters
pConnection | Pointer to a CXTPFlowGraphConnection object.
ptOldPosition | The old position of the connection.

Member Function Documentation

◆ Undo()

virtual void Undo ( )
protectedvirtual

Call this function to do the undo operation.

This is a virtual function, so derived classes can provide their specific implementations.

Reimplemented from CXTPFlowGraphUndoCommand.

The documentation for this class was generated from the following file:
  • XTPFlowGraphUndoManager.h


Toolkit Pro: CXTPFlowGraphUndoSetNodeCaptionCommand Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPFlowGraphUndoSetNodeCaptionCommand Class Reference

This class abstracts the undo set Node caption command. More...

Inheritance diagram for CXTPFlowGraphUndoSetNodeCaptionCommand:
[legend]

Public Member Functions

CXTPFlowGraphUndoSetNodeCaptionCommand (CXTPFlowGraphElement *pNode, CString strOldCaption)
Constructs a CXTPFlowGraphUndoSetNodeCaptionCommand object.
virtual | ~CXTPFlowGraphUndoSetNodeCaptionCommand ()
Destroys a CXTPFlowGraphUndoSetNodeCaptionCommand object, handles cleanup and deallocation.
- Public Member Functions inherited from CXTPFlowGraphUndoCommand
int | GetID () const
Call this function to get the command ID associated with this object.

Protected Member Functions

virtual void | Undo ()
Call this function to do the undo operation.
- Protected Member Functions inherited from CXTPFlowGraphUndoCommand
CXTPFlowGraphUndoCommand (int nID)
Constructs a CXTPFlowGraphUndoCommand object.
virtual | ~CXTPFlowGraphUndoCommand ()
Destroys a CXTPFlowGraphUndoCommand object, handles cleanup and deallocation.

Protected Attributes

CXTPFlowGraphElement * | m_pNode
Pointer to the FlowGraph Node object.
CString | m_strOldCaption
Old caption of the Node.
- Protected Attributes inherited from CXTPFlowGraphUndoCommand
const int | m_nID
The command ID.

Detailed Description

This class abstracts the undo set Node caption command.

This is a kind of CXTPFlowGraphUndoCommand.

Constructor & Destructor Documentation

◆ CXTPFlowGraphUndoSetNodeCaptionCommand()

CXTPFlowGraphUndoSetNodeCaptionCommand | ( | CXTPFlowGraphElement * | pNode,
 |  | CString | strOldCaption )

Constructs a CXTPFlowGraphUndoSetNodeCaptionCommand object.

Parameters
pNode | Pointer to a CXTPFlowGraphNode object.
strOldCaption | The old caption of the Node.

Member Function Documentation

◆ Undo()

virtual void Undo ( )
protectedvirtual

Call this function to do the undo operation.

This is a virtual function, so derived classes can provide their specific implementations.

Reimplemented from CXTPFlowGraphUndoCommand.

The documentation for this class was generated from the following file:
  • XTPFlowGraphUndoManager.h


Toolkit Pro: CXTPFlowGraphUndoSetNodePositionCommand Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPFlowGraphUndoSetNodePositionCommand Class Reference

This class abstracts the undo set Node position command. More...

Inheritance diagram for CXTPFlowGraphUndoSetNodePositionCommand:
[legend]

Public Member Functions

CXTPFlowGraphUndoSetNodePositionCommand (CXTPFlowGraphNode *pNode, CPoint ptOldPosition)
Constructs a CXTPFlowGraphUndoSetNodePositionCommand object.
virtual | ~CXTPFlowGraphUndoSetNodePositionCommand ()
Destroys a CXTPFlowGraphUndoSetNodePositionCommand object, handles cleanup and deallocation.
- Public Member Functions inherited from CXTPFlowGraphUndoCommand
int | GetID () const
Call this function to get the command ID associated with this object.

Protected Member Functions

virtual void | Undo ()
Call this function to do the undo operation.
- Protected Member Functions inherited from CXTPFlowGraphUndoCommand
CXTPFlowGraphUndoCommand (int nID)
Constructs a CXTPFlowGraphUndoCommand object.
virtual | ~CXTPFlowGraphUndoCommand ()
Destroys a CXTPFlowGraphUndoCommand object, handles cleanup and deallocation.

Protected Attributes

CXTPFlowGraphNode * | m_pNode
Pointer to the FlowGraph Node object.
CPoint | m_ptOldPosition
Old position of the Node.
- Protected Attributes inherited from CXTPFlowGraphUndoCommand
const int | m_nID
The command ID.

Detailed Description

This class abstracts the undo set Node position command.

This is a kind of CXTPFlowGraphUndoCommand.

Constructor & Destructor Documentation

◆ CXTPFlowGraphUndoSetNodePositionCommand()

CXTPFlowGraphUndoSetNodePositionCommand | ( | CXTPFlowGraphNode * | pNode,
 |  | CPoint | ptOldPosition )

Constructs a CXTPFlowGraphUndoSetNodePositionCommand object.

Parameters
pNode | Pointer to a CXTPFlowGraphNode object.
ptOldPosition | The old position of the Node.

Member Function Documentation

◆ Undo()

virtual void Undo ( )
protectedvirtual

Call this function to do the undo operation.

This is a virtual function, so derived classes can provide their specific implementations.

Reimplemented from CXTPFlowGraphUndoCommand.

The documentation for this class was generated from the following file:
  • XTPFlowGraphUndoManager.h


Toolkit Pro: CXTPFlowGraphUndoSetNodeSizeCommand Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPFlowGraphUndoSetNodeSizeCommand Class Reference

This class abstracts the undo set Node size command. More...

Inheritance diagram for CXTPFlowGraphUndoSetNodeSizeCommand:
[legend]

Public Member Functions

CXTPFlowGraphUndoSetNodeSizeCommand (CXTPFlowGraphNode *pNode, CSize szOldSize)
Constructs a CXTPFlowGraphUndoSetNodeSizeCommand object.
virtual | ~CXTPFlowGraphUndoSetNodeSizeCommand ()
Destroys a CXTPFlowGraphUndoSetNodeSizeCommand object, handles cleanup and deallocation.
- Public Member Functions inherited from CXTPFlowGraphUndoCommand
int | GetID () const
Call this function to get the command ID associated with this object.

Protected Member Functions

virtual void | Undo ()
Call this function to do the undo operation.
- Protected Member Functions inherited from CXTPFlowGraphUndoCommand
CXTPFlowGraphUndoCommand (int nID)
Constructs a CXTPFlowGraphUndoCommand object.
virtual | ~CXTPFlowGraphUndoCommand ()
Destroys a CXTPFlowGraphUndoCommand object, handles cleanup and deallocation.

Protected Attributes

CXTPFlowGraphNode * | m_pNode
Pointer to the FlowGraph Node object.
CPoint | m_szOldSize
Old size of the Node.
- Protected Attributes inherited from CXTPFlowGraphUndoCommand
const int | m_nID
The command ID.

Detailed Description

This class abstracts the undo set Node size command.

This is a kind of CXTPFlowGraphUndoCommand.

Constructor & Destructor Documentation

◆ CXTPFlowGraphUndoSetNodeSizeCommand()

CXTPFlowGraphUndoSetNodeSizeCommand | ( | CXTPFlowGraphNode * | pNode,
 |  | CSize | szOldSize )

Constructs a CXTPFlowGraphUndoSetNodeSizeCommand object.

Parameters
pNode | Pointer to a CXTPFlowGraphNode object.
szOldSize | The old size of the Node.

Member Function Documentation

◆ Undo()

virtual void Undo ( )
protectedvirtual

Call this function to do the undo operation.

This is a virtual function, so derived classes can provide their specific implementations.

Reimplemented from CXTPFlowGraphUndoCommand.

The documentation for this class was generated from the following file:
  • XTPFlowGraphUndoManager.h


Toolkit Pro: CXTPFont Class Reference

Public Member Functions | List of all members
CXTPFont Class Reference

Provides a convenient object oriented interface for HFONT GDI object and uses GDI handle caching. More...

Inheritance diagram for CXTPFont:
[legend]

Public Member Functions

CXTPFont ()
Constructs empty CXTPFont object.
~CXTPFont ()
Handles CXTPFont object destruction.
BOOL | CreateFontIndirect (const LOGFONT *lpLogFont)
Initializes a CFont object with the characteristics given in a LOGFONTstructure.
BOOL | CreateFont (int nHeight, int nWidth, int nEscapement, int nOrientation, int nWeight, BYTE bItalic, BYTE bUnderline, BYTE cStrikeOut, BYTE nCharSet, BYTE nOutPrecision, BYTE nClipPrecision, BYTE nQuality, BYTE nPitchAndFamily, LPCTSTR lpszFacename)
Initializes a CFont object with the specified characteristics.
BOOL | CreatePointFont (int nPointSize, LPCTSTR lpszFaceName, CDC *pDC=NULL)
This function provides a simple way to create a font of a specified typeface and point size.
BOOL | CreatePointFontIndirect (const LOGFONT *lpLogFont, CDC *pDC=NULL)
This function is the same as CreateFontIndirect except that the lfHeight member of the LOGFONT is interpreted in tenths of a point rather than device units.
int | GetLogFont (LOGFONT *pLogFont)
Call this function to retrieve a copy of the LOGFONT structure that describes the encapsulated GDI object.
CFont * | GetNativeGdiObject ()
Obtains a pointer to the encapsulated GDI object as CFont type.
const CFont * | GetNativeGdiObject () const
Obtains a pointer to the encapsulated GDI object as CFont type.
operator HFONT () const
Casts an object to an encapsulated GDI handle.
operator CFont & ()
Converts an object to CFont reference making it possible to use CXTPFont with MFC classes and methods that use CFont or CGdiObject reference as an argument.
operator const CFont & () const
Converts an object to CFont reference making it possible to use CXTPFont with MFC classes and methods that use CFont or CGdiObject constant reference as an argument.
- Public Member Functions inherited from CXTPGdiObject
virtual | ~CXTPGdiObject ()=0
Handles CXTPGdiObject destruction.
operator HGDIOBJ () const
Casts an object to an encapsulated GDI handle.
HGDIOBJ | GetSafeHandle () const
Returns m_hObject unless this is NULL, in which case NULL is returned.
BOOL | DeleteObject ()
Decrements reference counter for a cached GDI object or delete the cached GDI object once the reference counter is equal to zero.
int | GetObject (int nCount, LPVOID lpObject) const
Fills a buffer with data that defines a specified object.
UINT | GetObjectType () const
Retrieves the type of the GDI object.
BOOL | CreateStockObject (int nIndex)
Retrieves a handle to one of the predefined stock Windows GDI pens, brushes, or fonts, and attaches the GDI object to the CGdiObject object.
BOOL | operator== (const CXTPGdiObject &obj) const
Determines if two GDI objects are logically equal.
BOOL | operator!= (const CXTPGdiObject &obj) const
Determines if two GDI objects are logically not equal.
operator CGdiObject & ()
Converts an object to CGdiObject reference making it possible to use CXTPGdiObject with MFC classes and methods that use CGdiObject reference as an argument.
operator const CGdiObject & () const
Converts an object to CGdiObject constance reference making it possible to use CXTPGdiObject with MFC classes and methods that use CGdiObject reference as an argument.
__declspec (property(get=GetSafeHandle)) HGDIOBJ m_hObject
A read-only encapsulated GDI handle value.
void | SetHandleOwnershipNotGuaranteed ()
Sets handle ownership guaranteed status.
BOOL | IsHandleOwnershipGuaranteed () const
Determines handle ownership guaranteed status.

Additional Inherited Members

- Protected Member Functions inherited from CXTPGdiObject
CXTPGdiObject ()
Performs internal CXTPGdiObject construction logic.

Detailed Description

Provides a convenient object oriented interface for HFONT GDI object and uses GDI handle caching.

Mimics CFont's interface from MFC however cannot be cast to CFont or CGdiObject types.

XTP GDI objects use cached GDI handles so one native GDI handle can be shared across several XTP GDI object instances. The lifetime of a handle is controlled by XTP GDI reference counter, meaning a handle is deleted only when the last XTP GDI object that references a particular handle is destroyed or DeleteObject is called. Note, because an encapsulated GDI handle is cached and shared, passing m_hObject to DeleteObject from Windows SDK or convering an XTP GDI object to CGdiObject& and making a call to CGdiObject::DeleteObject will delete a cached handle and leave all XTP GDI object that reference the delete handle in an undetermined state. This will also affect every place in a program where the cached handles are used. So use the encapsulated GDI handle or CGdiObject very carefully and for read-only purposes.

See also
CXTPGdiObject, CXTPBrush, CXTPPen

Member Function Documentation

◆ CreateFont()

BOOL CreateFont | ( | int | nHeight,
 |  | int | nWidth,
 |  | int | nEscapement,
 |  | int | nOrientation,
 |  | int | nWeight,
 |  | BYTE | bItalic,
 |  | BYTE | bUnderline,
 |  | BYTE | cStrikeOut,
 |  | BYTE | nCharSet,
 |  | BYTE | nOutPrecision,
 |  | BYTE | nClipPrecision,
 |  | BYTE | nQuality,
 |  | BYTE | nPitchAndFamily,
 |  | LPCTSTR | lpszFacename )

Initializes a CFont object with the specified characteristics.

Parameters
nHeight | Specifies the desired height(in logical units) of the font.
nWidth | Specifies the average width(in logical units) of characters in the font.
nEscapement | Specifies the angle(in 0.1 degree units) between the escapement vector and the x axis of the display surface.
nOrientation | Specifies the angle(in 0.1 degree units) between the baseline of a character and the x axis.
nWeight | Specifies the font weight(in inked pixels per 1000).
bItalic | Specifies whether the font is italic.
bUnderline | Specifies whether the font is underlined.
cStrikeOut | Specifies whether characters in the font are struck out.
nCharSet | Specifies the font's character set.
nOutPrecision | Specifies the desired output precision.
nClipPrecision | Specifies the desired clipping precision.
nQuality | Specifies the font's output quality.
nPitchAndFamily | Specifies the pitch and family of the font.
lpszFacename | A CString or pointer to a null terminated string that specifies the typeface name of the font.
Returns
Nonzero if successful; otherwise 0.

If the requested font has already been created from another CXTPFont instance and not yet deleted the same font will be re-used and its reference counter will be incremented.

◆ CreateFontIndirect()

BOOL CreateFontIndirect ( const LOGFONT * lpLogFont )

Initializes a CFont object with the characteristics given in a LOGFONTstructure.

Parameters
lpLogFont Points to a LOGFONT structure that defines the characteristics of the logical font.
Returns
Nonzero if successful; otherwise 0.

If the requested font has already been created from another CXTPFont instance and not yet deleted the same font will be re-used and its reference counter will be incremented.

◆ CreatePointFont()

BOOL CreatePointFont | ( | int | nPointSize,
 |  | LPCTSTR | lpszFaceName,
 |  | CDC * | pDC = NULL )

This function provides a simple way to create a font of a specified typeface and point size.

Parameters
nPointSize | Requested font height in tenths of a point.
lpszFaceName | A CString or pointer to a null terminated string that specifies the typeface name of the font.
pDC | Pointer to the CDC object to be used to convert the height in nPointSize to logical units.
Returns
Nonzero if successful, otherwise 0.

If the requested font has already been created from another CXTPFont instance and not yet deleted the same font will be re-used and its reference counter will be incremented.

◆ CreatePointFontIndirect()

BOOL CreatePointFontIndirect | ( | const LOGFONT * | lpLogFont,
 |  | CDC * | pDC = NULL )

This function is the same as CreateFontIndirect except that the lfHeight member of the LOGFONT is interpreted in tenths of a point rather than device units.

Parameters
lpLogFont | Points to a LOGFONT structure that defines the characteristics of the logical font.
pDC | Pointer to the CDC object to be used to convert the height in lfHeight to logical units.
Returns
Nonzero if successful, otherwise 0.

If the requested font has already been created from another CXTPFont instance and not yet deleted the same font will be re-used and its reference counter will be incremented.

◆ GetLogFont()

int GetLogFont ( LOGFONT * pLogFont )

Call this function to retrieve a copy of the LOGFONT structure that describes the encapsulated GDI object.

Parameters
pLogFont Pointer to the LOGFONT structure to receive the font information.
Returns
Nonzero if the function succeeds, otherwise 0.

◆ GetNativeGdiObject() [1/2]

CFont * GetNativeGdiObject ( )

Obtains a pointer to the encapsulated GDI object as CFont type.

The returned object must not be deleted or modified as it will affect every place in a program where the cached handle is used.

Returns
A pointer to the encapsulated GDI object as CFont type.

◆ GetNativeGdiObject() [2/2]

const CFont * GetNativeGdiObject ( ) const

Obtains a pointer to the encapsulated GDI object as CFont type.

The returned object must not be deleted or modified as it will affect every place in a program where the cached handle is used.

Returns
A pointer to the encapsulated GDI object as CFont type.

◆ operator CFont &()

operator CFont & ( )

Converts an object to CFont reference making it possible to use CXTPFont with MFC classes and methods that use CFont or CGdiObject reference as an argument.

Returns
An encapsulated CFont reference.

The returned object must not be deleted or modified as it will affect every place in a program where the cached handle is used.

◆ operator const CFont &()

operator const CFont & ( ) const

Converts an object to CFont reference making it possible to use CXTPFont with MFC classes and methods that use CFont or CGdiObject constant reference as an argument.

Returns
An encapsulated CFont constance reference.

◆ operator HFONT()

operator HFONT ( ) const

Casts an object to an encapsulated GDI handle.

The returned handle must not be passed to DeleteObject and should be used for read-only purposes, i.e. GDI object state should not be modified as it will affect every place in a program where the cached hande is used.

Returns
Encapsulated GDI handle or NULL.
The documentation for this class was generated from the following file:
  • XTPGdiObjects.h


Toolkit Pro: CXTPFontComboBox Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPFontComboBox Class Reference

CXTPFontComboBox is a CXTPComboBox derived class. More...

Inheritance diagram for CXTPFontComboBox:
[legend]

Public Member Functions

CXTPFontComboBox ()
Constructs a CXTPFontComboBox object.
virtual | ~CXTPFontComboBox ()
Destroys a CXTPFontComboBox object, handles cleanup and deallocation.
void | SetListStyle (DWORD dwStyle)
Sets the font style for the CXTPFontComboBox control.
virtual void | InitControl (LPCTSTR lpszFaceName=NULL, UINT nWidth=0, BOOL bEnable=TRUE)
Initializes the CXTPFontComboBox control.
- Public Member Functions inherited from CXTPComboBox
CXTPComboBox ()
Constructs a CXTPComboBox object.
virtual | ~CXTPComboBox ()
Destroys a CXTPComboBox object, handles cleanup and deallocation.
virtual void | Initialize (bool bAutoFont=true)
Call this member function to initialize the combobox.
BOOL | SetTheme (XTPControlTheme nTheme)
Call this member function to switch the visual theme of the control.
virtual void | SetTheme (CXTPComboBoxTheme *pTheme)
This member function is called to set the theme for the combobox control using the theme specified by pTheme.
CXTPComboBoxTheme * GetTheme ()
Call this member function to retrieve a pointer to the current theme used by the combobox.
const CXTPComboBoxTheme * | GetTheme () const
Call this member function to retrieve a pointer to the current theme used by the combobox.
void | RedrawComboBox (BOOL bUpdateWindow=FALSE)
Redraws the button.
BOOL | GetFlatStyle () const
Gets the flat style appearance of the combobox.
void | SetFlatStyle (BOOL bFlatStyle=TRUE)
Sets the flat style appearance of the button control.
BOOL | GetUseVisualStyle () const
Determines if the control is drawn using visual styles/SkinFramework, if supported.
void | SetUseVisualStyle (BOOL bUseVisualStyle=TRUE)
Enables Windows XP visual styles for the control.
void | EnableAutoCompletion (BOOL bEnable=TRUE)
This member function enables/disables auto-completion.
virtual void | SetBackColor (COLORREF crBack)
Call this member function to set the background color for the CXTPComboBox control.
COLORREF | GetBackColor () const
Call this member function to retrieve the background color of the CXTPComboBox control.
virtual void | SetTextColor (COLORREF crText)
Call this member function to set the text color for the CXTPComboBox control.
COLORREF | GetTextColor () const
Call this member function to retrieve the text color of the CXTPComboBox control.
void | RefreshMetrics ()
This member function is called to update the color, text, and other visual elements of the control.
BOOL | IsFocused () const
Call this member function to determine if the combobox has input focus.
BOOL | IsHighlighted () const
Call this member function to determine if the combobox state is highilghted, meaning that the mouse cursor is currently hovering over the control.
BOOL | IsDroppedDown () const
Call this member function to determine if the combobox is currently dropped down.
HBRUSH | GetClientBrush (CDC *pDC)
Call this member function to retrieve a handle to the client background brush.
CRect | GetComboBoxRect () const
Call this member function to retrieve the size of the combobox in client coordinates.
void | SetHighlighted (BOOL bHot)
This member fuction is called to set the highlighted state for the combobox.
void | EnableMarkup (BOOL bEnableMarkup=TRUE)
Allows the use of a XAML snippet to be used for the text of panes in the control.
- Public Member Functions inherited from CXTPFontCtrlBase
CXTPFontCtrlBase ()
Standard constructor.
virtual | ~CXTPFontCtrlBase ()
Handles object destruction.
virtual BOOL | GetSelFont (CXTPLogFont &lf)
Call this member function to get the font for the currently selected item.
virtual BOOL | GetSelFont (CString &strFaceName)
Call this member function to get the font for the currently selected item.
virtual BOOL | SetSelFont (CXTPLogFont &lf)
Call this member function to select the font for the list box.
virtual BOOL | SetSelFont (const CString &strFaceName)
Call this member function to select the font for the list box.

Protected Member Functions

virtual void | NotifyOwner (UINT nCode)
Called by the font combobox to send CBN notifications to the owner window to support keyboard navigation.
- Protected Member Functions inherited from CXTPComboBox
void | RedrawFocusedFrame ()
Called by the framework to redraw the focused frame for the combobox.
BOOL | NeedRedraw ()
Called by the framework to determine if the combobox needs to be redrawn.
- Protected Member Functions inherited from CXTPFontCtrlBase
virtual void | OnDrawItem (LPDRAWITEMSTRUCT lpDIS)
This method is called by the framework when a visual aspect of an owner-drawn combo or list box changes.
virtual void | OnMeasureItem (LPMEASUREITEMSTRUCT lpMIS)
This method is called by the framework when a combo or list box with an owner-drawn style is created.
virtual int | OnCompareItem (LPCOMPAREITEMSTRUCT lpCIS)
Called by the framework to determine the relative position of a new item in the list-box portion of a sorted owner-draw combobox.
virtual void | OnInit (CXTPFontListBox *pListBox)
Call this member function to set the listbox pointer for the base class.
virtual void | OnInit (CXTPFontComboBox *pComboBox)
Call this member function to set the combobox pointer for the base class.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPFontCtrlBase
static int AFX_CDECL | GetFontItemHeight ()
Call this member function to retrieve the default height for combo or list items.
static BOOL AFX_CDECL | CreateUIFont (CFont &font)
Call this member function to create a default font for a combo or list box.
- Protected Types inherited from CXTPFontCtrlBase
- Protected Attributes inherited from CXTPComboBox
BOOL | m_bPreSubclassInit
TRUE if the control has been subclassed.
BOOL | m_bUseVisualStyle
TRUE to use Windows themes.
BOOL | m_bFlatStyle
TRUE to draw the control using flat styles.
BOOL | m_bHighlighted
TRUE when the combobox is highlighted.
BOOL | m_bFocused
TRUE when the combobox has input focus.
BOOL | m_bAutoComp
TRUE when the combobox is using the auto-complete feature.
BOOL | m_bDisableAC
TRUE to disable auto-complete temporarily.
CXTPComboBoxTheme * | m_pTheme
Pointer to the current theme object.
CXTPComboBoxEditCtrl * | m_pWndEdit
Pointer to the edit-control for the combobox.
BOOL | m_bEnableMarkup
TRUE to enable markup.
CXTPMarkupContext * | m_pMarkupContext
Markup context.
- Protected Attributes inherited from CXTPFontCtrlBase
DWORD | m_dwStyle
Display style indicating how to render the font list.
CString | m_csSymbol
String displayed for the symbol characters.
CXTPFontListBox * | m_pListBox
Pointer to the owner list box.
CXTPFontComboBox * | m_pComboBox
Pointer to the owner combobox.

Detailed Description

CXTPFontComboBox is a CXTPComboBox derived class.

It is used to create a combobox that displays a drop list of available fonts for your system. The fonts are displayed in their various styles.

Member Function Documentation

◆ InitControl()

virtual void InitControl | ( | LPCTSTR | lpszFaceName = NULL,
 |  | UINT | nWidth = 0,
 |  | BOOL | bEnable = TRUE )
 virtual

Initializes the CXTPFontComboBox control.

Parameters
lpszFaceName | A NULL-terminated string that represents the logfont face name.
nWidth | The minimum allowable width of the list box portion of the combobox in pixels.
bEnable | TRUE to enable auto-completion, otherwise FALSE.

Call this member function to initialize the font list box and populate it with a list of available fonts.

◆ NotifyOwner()

virtual void NotifyOwner ( UINT nCode )
protectedvirtual

Called by the font combobox to send CBN notifications to the owner window to support keyboard navigation.

Parameters
nCode CBN notification message to send.

◆ SetListStyle()

void SetListStyle ( DWORD dwStyle )

Sets the font style for the CXTPFontComboBox control.

Parameters
dwStyle Specifies the style for the font list box. Styles can be any one of the values in the Remarks section.

Call this member function to set the font display style for the font list box. There are three styles to choose from that include displaying the font in the default GUI font, displaying the font in its own font style, or displaying both the font name in the default GUI font and a sample to the right.

The style can be any of the following values:

xtpFontGUI: Display font name with GUI font style. xtpFontSample: Display font name with its own font style. xtpFontBoth: Display font name with GUI font style, then a sample display to the right.

The documentation for this class was generated from the following file:
  • XTPFontComboBox.h


Toolkit Pro: CXTPFontCtrlBase Class Reference

Public Member Functions | Static Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPFontCtrlBase Class Reference

CXTPFontCtrlBase is a base class used by CXTPFontListBox and CXTPFontComboBox controls to perform common drawing routines. More...

Inheritance diagram for CXTPFontCtrlBase:
[legend]

Public Member Functions

CXTPFontCtrlBase ()
Standard constructor.
virtual | ~CXTPFontCtrlBase ()
Handles object destruction.
virtual BOOL | GetSelFont (CXTPLogFont &lf)
Call this member function to get the font for the currently selected item.
virtual BOOL | GetSelFont (CString &strFaceName)
Call this member function to get the font for the currently selected item.
virtual BOOL | SetSelFont (CXTPLogFont &lf)
Call this member function to select the font for the list box.
virtual BOOL | SetSelFont (const CString &strFaceName)
Call this member function to select the font for the list box.

Static Public Member Functions

static int AFX_CDECL | GetFontItemHeight ()
Call this member function to retrieve the default height for combo or list items.
static BOOL AFX_CDECL | CreateUIFont (CFont &font)
Call this member function to create a default font for a combo or list box.

Protected Member Functions

virtual void | OnDrawItem (LPDRAWITEMSTRUCT lpDIS)
This method is called by the framework when a visual aspect of an owner-drawn combo or list box changes.
virtual void | OnMeasureItem (LPMEASUREITEMSTRUCT lpMIS)
This method is called by the framework when a combo or list box with an owner-drawn style is created.
virtual int | OnCompareItem (LPCOMPAREITEMSTRUCT lpCIS)
Called by the framework to determine the relative position of a new item in the list-box portion of a sorted owner-draw combobox.
virtual void | OnInit (CXTPFontListBox *pListBox)
Call this member function to set the listbox pointer for the base class.
virtual void | OnInit (CXTPFontComboBox *pComboBox)
Call this member function to set the combobox pointer for the base class.

Protected Attributes

DWORD | m_dwStyle
Display style indicating how to render the font list.
CString | m_csSymbol
String displayed for the symbol characters.
CXTPFontListBox * | m_pListBox
Pointer to the owner list box.
CXTPFontComboBox * | m_pComboBox
Pointer to the owner combobox.

Detailed Description

CXTPFontCtrlBase is a base class used by CXTPFontListBox and CXTPFontComboBox controls to perform common drawing routines.

Member Function Documentation

◆ CreateUIFont()

static BOOL AFX_CDECL CreateUIFont ( CFont & font )
static

Call this member function to create a default font for a combo or list box.

Parameters
font Reference to a CFont object.
Returns
TRUE if successful, otherwise FALSE.

◆ GetFontItemHeight()

static int AFX_CDECL GetFontItemHeight ( )
static

Call this member function to retrieve the default height for combo or list items.

Returns
The default height, in pixels, for combo or list items.

◆ GetSelFont() [1/2]

virtual BOOL GetSelFont ( CString & strFaceName )
virtual

Call this member function to get the font for the currently selected item.

Parameters
strFaceName A reference to a valid CString object to receive the logfont face name.

The first version of GetSelFont will retrieve the selected font name. The second version will get the CXTPLogFont for the currently selected item.

Returns
TRUE if successful, otherwise FALSE.

◆ GetSelFont() [2/2]

virtual BOOL GetSelFont ( CXTPLogFont & lf )
virtual

Call this member function to get the font for the currently selected item.

Parameters
lf Reference to a CXTPLogFont structure.

The first version of GetSelFont will retrieve the selected font name. The second version will get the CXTPLogFont for the currently selected item.

Returns
TRUE if successful, otherwise FALSE.

◆ OnCompareItem()

virtual int OnCompareItem ( LPCOMPAREITEMSTRUCT lpCIS )
protectedvirtual

Called by the framework to determine the relative position of a new item in the list-box portion of a sorted owner-draw combobox.

By default, this member function does nothing.

Parameters
lpCIS A long pointer to a COMPAREITEMSTRUCT structure.
Returns
Indicates the relative position of the two items described in the COMPAREITEMSTRUCT structure. It can be any of the following values:

Value Meaning: -1: Item 1 sorts before item 2. 0: Item 1 and item 2 sort the same. 1: Item 1 sorts after item 2.

◆ OnDrawItem()

virtual void OnDrawItem ( LPDRAWITEMSTRUCT lpDIS )
protectedvirtual

This method is called by the framework when a visual aspect of an owner-drawn combo or list box changes.

Parameters
lpDIS A pointer to a DRAWITEMSTRUCT structure that contains information about the type of drawing required.

◆ OnInit() [1/2]

virtual void OnInit ( CXTPFontComboBox * pComboBox )
protectedvirtual

Call this member function to set the combobox pointer for the base class.

Parameters
pComboBox Pointer to a valid CXTPFontComboBox object.

◆ OnInit() [2/2]

virtual void OnInit ( CXTPFontListBox * pListBox )
protectedvirtual

Call this member function to set the listbox pointer for the base class.

Parameters
pListBox Pointer to a valid CXTPFontListBox object.

◆ OnMeasureItem()

virtual void OnMeasureItem ( LPMEASUREITEMSTRUCT lpMIS )
protectedvirtual

This method is called by the framework when a combo or list box with an owner-drawn style is created.

Parameters
lpMIS A long pointer to a MEASUREITEMSTRUCT structure.

◆ SetSelFont() [1/2]

virtual BOOL SetSelFont ( const CString & strFaceName )
virtual

Call this member function to select the font for the list box.

Parameters
strFaceName A reference to a valid CString object to receive the logfont face name.

The first version of SetSelFont will set the selected font by using its face name. The second version will set the selected font by using a CXTPLogFont object.

Returns
TRUE if successful, otherwise FALSE.

◆ SetSelFont() [2/2]

virtual BOOL SetSelFont ( CXTPLogFont & lf )
virtual

Call this member function to select the font for the list box.

Parameters
lf Reference to a CXTPLogFont structure.

The first version of SetSelFont will set the selected font by using its face name. The second version will set the selected font by using a CXTPLogFont object.

Returns
TRUE if successful, otherwise FALSE.
The documentation for this class was generated from the following file:
  • XTPFontComboBox.h


Toolkit Pro: CXTPFontEnum Class Reference

Public Member Functions | Static Public Member Functions | Protected Member Functions | Static Protected Member Functions | Protected Attributes | List of all members
CXTPFontEnum Class Reference

CXTPFontEnum is a standalone singleton font enumeration class. More...

Public Member Functions

virtual | ~CXTPFontEnum ()
Destroys a CXTPFontEnum object, handles cleanup and deallocation.
bool | DoesFontExist (CString &strFaceName)
This member function is used to determine the existence of the font specified by 'strFaceName'.
CXTPLogFont * | GetLogFont (const CString &strFaceName)
This member function is used to get a pointer to the font specified by 'strFaceName'.
int | GetMaxWidth ()
This member function is used by the callback function to retrieve the current width for the longest font name in the list.
int | GetMaxWidth (LPCTSTR lpString)
Retrieves the widest size of a string provided using available fonts.
CXTPFontList & GetFontList ()
This member function is used to get a reference to the font list.
void | Init (CDC *pDC=NULL, BYTE nCharSet=DEFAULT_CHARSET)
This member function is called by the CXTPFontEnum class to initialize the font list.

Static Public Member Functions

static CXTPFontEnum &AFX_CDECL Get ()
This static member function will return a reference to the one and only CXTPFontEnum object.

Protected Member Functions

CXTPFontEnum ()
Constructs a CXTPFontEnum object.
bool AddFont (const LOGFONT *pLF, DWORD dwType)
This member function is called by the font enumeration callback to add a font to the font list.

Static Protected Member Functions

static BOOL CALLBACK EnumFontFamExProc (ENUMLOGFONTEX *pelf, NEWTEXTMETRICEX *lpntm, DWORD dwFontType, LPARAM lParam)
The EnumFontFamExProc function is an application defined-callback function used with the EnumFontFamiliesEx function.

Protected Attributes

CXTPFontList m_listFonts
List of fonts found during enumeration.

Detailed Description

CXTPFontEnum is a standalone singleton font enumeration class.

It is used to enumerate a list of fonts found installed for the operating system.

CXTPFontEnum is a singleton class, which means that it can only be instantiated a single time. The constructor is private, so the only way to access members of this class is to use the object's Get() method. To retrieve a list of available fonts for your operating system, you would make the following call: Example: The following example demonstrates the use of the CXTPFontEnum class:

CXTPFontEnum::Get().GetFontList()

Constructor & Destructor Documentation

◆ CXTPFontEnum()

CXTPFontEnum ( )
protected

Constructs a CXTPFontEnum object.

CXTPFontEnum is a singleton class. To instantiate an object, use the static method Get().

Member Function Documentation

◆ AddFont()

bool AddFont | ( | const LOGFONT * | pLF,
 |  | DWORD | dwType )
 protected

This member function is called by the font enumeration callback to add a font to the font list.

Parameters
pLF | Pointer to a valid LOGFONT structure.
dwType | Specifies the type of the font. This parameter can be a combination of the values in the Remarks section.

Styles to be added or removed can be combined by using the bitwise OR (|) operator. It can be one or more of the following:

DEVICE_FONTTYPE: The font is a device font. RASTER_FONTTYPE: The font is a raster font. TRUETYPE_FONTTYPE: The font is a TrueType font.

Returns
true if successful, otherwise false.

◆ DoesFontExist()

bool DoesFontExist ( CString & strFaceName )

This member function is used to determine the existence of the font specified by 'strFaceName'.

Parameters
strFaceName Reference to a NULL-terminated string that represents the font name.
Returns
true if the font exists, otherwise false.

◆ EnumFontFamExProc()

static BOOL CALLBACK EnumFontFamExProc | ( | ENUMLOGFONTEX * | pelf,
 |  | NEWTEXTMETRICEX * | lpntm,
 |  | DWORD | dwFontType,
 |  | LPARAM | lParam )
 staticprotected

The EnumFontFamExProc function is an application defined-callback function used with the EnumFontFamiliesEx function.

It is used to process the fonts and is called once for each enumerated font. The FONTENUMPROC type defines a pointer to this callback function. EnumFontFamExProc is a placeholder for the application defined-function name.

Parameters
pelf | Pointer to an ENUMLOGFONTEX structure that contains information about the logical attributes of the font.
lpntm | Pointer to a structure that contains information about the physical attributes of a font. The function uses the NEWTEXTMETRICEX structure for TrueType fonts and the TEXTMETRIC structure for other fonts.
dwFontType | Specifies the type of the font. This parameter can be a combination of the values in the Remarks section.
lParam | Specifies the application-defined data passed by the EnumFontFamiliesEx function.

Styles to be added or removed can be combined by using the bitwise OR (|) operator. It can be one or more of the following:

DEVICE_FONTTYPE: The font is a device font. RASTER_FONTTYPE: The font is a raster font. TRUETYPE_FONTTYPE: The font is a TrueType font.

Returns
To continue enumeration, the return value must be a nonzero value. To stop enumeration, the return value must be zero.

◆ Get()

static CXTPFontEnum &AFX_CDECL Get ( )
static

This static member function will return a reference to the one and only CXTPFontEnum object.

You can use this function to access data members for the CXTPFontEnum class. Example: The following example demonstrates the use of Get():

CXTPFontEnum::Get().GetFontList()
Returns
A reference to a CXTPFontEnum object.

◆ GetFontList()

CXTPFontList & GetFontList ( )

This member function is used to get a reference to the font list.

Returns
A reference to the CXTPFontList used by this class.

◆ GetLogFont()

CXTPLogFont * GetLogFont ( const CString & strFaceName )

This member function is used to get a pointer to the font specified by 'strFaceName'.

Parameters
strFaceName A NULL-terminated string that represents the font name.
Returns
A pointer to the CXTPLogFont structure for the specified item, or NULL if no font was found.

◆ GetMaxWidth() [1/2]

int GetMaxWidth ( )

This member function is used by the callback function to retrieve the current width for the longest font name in the list.

Returns
An integer value that represents the width for the longest font name in the list.

◆ GetMaxWidth() [2/2]

int GetMaxWidth ( LPCTSTR lpString )

Retrieves the widest size of a string provided using available fonts.

Parameters
lpString
Returns
An integer value that represents the widest size of a string.

◆ Init()

void Init | ( | CDC * | pDC = NULL,
 |  | BYTE | nCharSet = DEFAULT_CHARSET )

This member function is called by the CXTPFontEnum class to initialize the font list.

You can also call this member function to reinitialize the font enumeration. For example, if you changed printers and you want to enumerate printer fonts, or you wanted to use a different character set.

Parameters
pDC | Pointer to a valid device context. If NULL, then the screen device context is used.
nCharSet | Represents the character set to enumerate.
The documentation for this class was generated from the following file:
  • XTPFontComboBox.h


Toolkit Pro: CXTPFontListBox Class Reference

Public Member Functions | List of all members
CXTPFontListBox Class Reference

CXTPFontListBox is a CXTPListBox derived class. More...

Inheritance diagram for CXTPFontListBox:
[legend]

Public Member Functions

CXTPFontListBox ()
Constructs a CXTPFontListBox object.
virtual | ~CXTPFontListBox ()
Destroys a CXTPFontListBox object, handles cleanup and deallocation.
void | SetListStyle (DWORD dwStyle)
Call this member function to set the font display style for the font list box.
virtual void | Initialize (bool bAutoFont=true)
Call this member function to initialize the font list box and populate it with a list of available fonts.
- Public Member Functions inherited from CXTPListBox
CXTPListBox ()
Constructs a CXTPListBox object.
virtual | ~CXTPListBox ()
Destroys a CXTPListBox object, handles cleanup and deallocation.
virtual COLORREF | GetBackColor ()
Called to retrieve the background color for the list box.
void | SetListStyle (XTPListBoxStyle style)
Call this method to set the style of the list box.
XTPListBoxStyle | GetListStyle () const
Call this method to retrieve the style of the list box.
void | SetTheme (XTPControlTheme nTheme)
This member function sets the drawing theme for the control.
virtual void | RefreshMetrics ()
Call this member function to refresh theme colors and redraw the control.
BOOL | HasFocus () const
Call this member function to determine if the list box control has input focus.
- Public Member Functions inherited from CXTPFontCtrlBase
CXTPFontCtrlBase ()
Standard constructor.
virtual | ~CXTPFontCtrlBase ()
Handles object destruction.
virtual BOOL | GetSelFont (CXTPLogFont &lf)
Call this member function to get the font for the currently selected item.
virtual BOOL | GetSelFont (CString &strFaceName)
Call this member function to get the font for the currently selected item.
virtual BOOL | SetSelFont (CXTPLogFont &lf)
Call this member function to select the font for the list box.
virtual BOOL | SetSelFont (const CString &strFaceName)
Call this member function to select the font for the list box.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPFontCtrlBase
static int AFX_CDECL | GetFontItemHeight ()
Call this member function to retrieve the default height for combo or list items.
static BOOL AFX_CDECL | CreateUIFont (CFont &font)
Call this member function to create a default font for a combo or list box.
- Public Attributes inherited from CXTPListBox
CXTPListBoxTheme * | m_pTheme
Pointer to the currently active theme.
XTPControlTheme | m_theme
List box theme.
int | m_nItemHeight
Height of the items.
int | m_nTextPadding
Text padding.
int | m_nHotItem
Hot item index.
- Protected Types inherited from CXTPFontCtrlBase
- Protected Member Functions inherited from CXTPListBox
BOOL | TryItemFromPoint (CPoint pt, BOOL &bOutside, int &nIndex) const
This method determines the list box item nearest to the point specified in pt when there is at least one item in the list box.
- Protected Member Functions inherited from CXTPFontCtrlBase
virtual void | OnDrawItem (LPDRAWITEMSTRUCT lpDIS)
This method is called by the framework when a visual aspect of an owner-drawn combo or list box changes.
virtual void | OnMeasureItem (LPMEASUREITEMSTRUCT lpMIS)
This method is called by the framework when a combo or list box with an owner-drawn style is created.
virtual int | OnCompareItem (LPCOMPAREITEMSTRUCT lpCIS)
Called by the framework to determine the relative position of a new item in the list-box portion of a sorted owner-draw combobox.
virtual void | OnInit (CXTPFontListBox *pListBox)
Call this member function to set the listbox pointer for the base class.
virtual void | OnInit (CXTPFontComboBox *pComboBox)
Call this member function to set the combobox pointer for the base class.
- Protected Attributes inherited from CXTPFontCtrlBase
DWORD | m_dwStyle
Display style indicating how to render the font list.
CString | m_csSymbol
String displayed for the symbol characters.
CXTPFontListBox * | m_pListBox
Pointer to the owner list box.
CXTPFontComboBox * | m_pComboBox
Pointer to the owner combobox.

Detailed Description

CXTPFontListBox is a CXTPListBox derived class.

It is used to create a font selection list box.

You can choose to display the font name with the GUI font style, display the font name with its own font style, or display the font name with the default GUI font style and a sample display to the right.

Member Function Documentation

◆ Initialize()

virtual void Initialize ( bool bAutoFont = true )
virtual

Call this member function to initialize the font list box and populate it with a list of available fonts.

This method should be called directly after creating or sub-classing the control.

Parameters
bAutoFont true to enable automatic font initialization.

Reimplemented from CXTPListBox.

◆ SetListStyle()

void SetListStyle ( DWORD dwStyle )

Call this member function to set the font display style for the font list box.

There are three styles to choose from that include displaying the font in the default GUI font, displaying the font in its own font style, or displaying both the font name in the default GUI font and a sample to the right.

Parameters
dwStyle Specifies the style for the font list box. See XTPFontStyle for a list of available styles.
See also
XTPFontStyle
The documentation for this class was generated from the following file:
  • XTPFontComboBox.h


Toolkit Pro: CXTPFontManager Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPFontManager Class Reference

Singleton class to manage fonts used by library windows and controls. More...

Public Member Functions

BOOL | FontExists (LPCTSTR lpszFaceName)
Call this member function to determine if the specified font exists.
void | CreateFonts (LOGFONT lf)
Call this member to create system fonts using the specified LOGFONT structure.
CFont & | GetFont ()
Retrieves a reference to the standard library font managed by CXTPFontManager.
CFont & | GetFontBold ()
Retrieves a reference to the bold library font managed by CXTPFontManager.
CFont & | GetFontItalic ()
Retrieves a reference to the italic library font managed by CXTPFontManager.
CFont & | GetFontItalicBold ()
Retrieves a reference to the italic standard library font managed by CXTPFontManager.
CFont & | GetFontVertical ()
Retrieves a reference to the vertical library font managed by CXTPFontManager.
CFont & | GetFontVerticalBold ()
Retrieves a reference to the vertical bold library font managed by CXTPFontManager.

Protected Attributes

CXTPFont | m_xtpFont
Default font.
CXTPFont | m_xtpFontBold
Default bold font.
CXTPFont | m_xtpFontItalic
Default italic font.
CXTPFont | m_xtpFontItalicBold
Default italic bold font.
CXTPFont | m_xtpFontVertical
Default vertical font.
CXTPFont | m_xtpFontVerticalBold
Default vertical bold font.

Detailed Description

Singleton class to manage fonts used by library windows and controls.

You can access members of this class by using the function XTPFontManager().

Member Function Documentation

◆ CreateFonts()

void CreateFonts ( LOGFONT lf )

Call this member to create system fonts using the specified LOGFONT structure.

Parameters
lf Font structure used to initialize all system fonts.

◆ FontExists()

BOOL FontExists ( LPCTSTR lpszFaceName )

Call this member function to determine if the specified font exists.

Parameters
lpszFaceName A NULL-terminated string that represents the font face name.
Returns
TRUE if the font was found, otherwise FALSE.

◆ GetFont()

AFX_INLINE CFont & GetFont ( )

Retrieves a reference to the standard library font managed by CXTPFontManager.

Returns
A reference to a CFont object representing the library standard font.

◆ GetFontBold()

AFX_INLINE CFont & GetFontBold ( )

Retrieves a reference to the bold library font managed by CXTPFontManager.

Returns
A reference to a CFont object representing the library bold font.

◆ GetFontItalic()

AFX_INLINE CFont & GetFontItalic ( )

Retrieves a reference to the italic library font managed by CXTPFontManager.

Returns
A reference to a CFont object representing the library italic font.

◆ GetFontItalicBold()

AFX_INLINE CFont & GetFontItalicBold ( )

Retrieves a reference to the italic standard library font managed by CXTPFontManager.

Returns
A reference to a CFont object representing the library italic standard font.

◆ GetFontVertical()

AFX_INLINE CFont & GetFontVertical ( )

Retrieves a reference to the vertical library font managed by CXTPFontManager.

Returns
A reference to a CFont object representing the library vertical font.

◆ GetFontVerticalBold()

AFX_INLINE CFont & GetFontVerticalBold ( )

Retrieves a reference to the vertical bold library font managed by CXTPFontManager.

Returns
A reference to a CFont object representing the library vertical bold font.
The documentation for this class was generated from the following file:
  • XTPFontManager.h


Toolkit Pro: CXTPFramePaintManager Class Reference

Public Member Functions | Public Attributes | Protected Attributes | List of all members
CXTPFramePaintManager Class Referenceabstract

Paint manager for the Office 2007 style window frame. More...

Inheritance diagram for CXTPFramePaintManager:
[legend]

Public Member Functions

CXTPFramePaintManager (CXTPPaintManager *pPaintManager)
Constructs a CXTPFramePaintManager object.
virtual | ~CXTPFramePaintManager ()
Destroys a CXTPFramePaintManager object, handles cleanup and deallocation.
void | SetIcon (HICON hIcon, CSize szIcon)
Sets the frame icon.
virtual CRect | CalcFrameCaption (const CXTPCommandBarsFrameHook *pFrameHook) const
Calculates the frame caption rect.
virtual CRect | CalcFrameBorder (const CXTPCommandBarsFrameHook *pFrameHook) const
Calculates the frame border sizes.
virtual HRGN | CalcFrameRegion (CXTPCommandBarsFrameHook *pFrameHook, CSize sz) const =0
This method is called to create the window region.
virtual void | DrawFrame (CDC *pDC, CXTPCommandBarsFrameHook *pFrameHook)=0
This method is called to draw the frame if Ribbon was found.
virtual void | DrawFrameCaptionButton (CDC *pDC, CRect rc, int nId, BOOL bSelected, BOOL bPressed, BOOL bActive)=0
This method is called to draw the caption button.
virtual void | DrawFrameCaptionButton (CDC *pDC, CRect rc, int nId, BOOL bSelected, BOOL bPressed, BOOL bActive, CXTPRibbonBar *pRibbonBar)=0
This method is called to draw the caption button.
virtual COLORREF | GetFrameCaptionAccentTextColor (BOOL bActive) const
Obtains frame caption accent color.
BOOL | IsUseSystemAccentColorEnabled () const
Determines whether xtpApplicationUseSystemAccentColor application ambient property is set.
virtual int | GetFrameCaptionHeight () const
Retrieves the frame caption's height.
virtual void | RefreshMetrics ()
This method is called to refresh the visual metrics of the manager.
CXTPResourceImages * | GetImages () const
This method is called to get a pointer to the CXTPResourceImages object.
virtual void | DrawCaptionText (CDC *pDC, CRect rcCaptionText, CWnd *pSite, BOOL bActive)
This method is called to draw the frame caption text.
virtual void | DrawCaptionText (CDC *pDC, CRect rcCaptionText, CWnd *pSite, BOOL bActive, CXTPRibbonBar *pRibbonBar)
This method is called to draw the frame caption text.
virtual void | DrawCaptionBar (CDC *pDC, CRect rcCaptionBar, CWnd *pSite, BOOL bActive)
This method is called to draw the frame caption bar.
CXTPResourceImage * | LoadImage (LPCTSTR lpszFileName)
Loads a bitmap image from the specified path.
HICON | GetFrameSmallIcon (CWnd *pFrame)
Retrieves frame small icon.
HICON | GetFrameLargeIcon (CWnd *pFrame)
Retrieves frame large icon.
virtual CXTPFrameShadow * | CreateShadow (CWnd *pFrame)
Creates frame shadow if supported by theme.
virtual void | OnShadowedFrameActiveStateChanged (BOOL bActive, CWnd *pFrame, CXTPFrameShadow *pShadow)
An implementation can override this method in order to change frame appearance when a window gets activated or deactivated.
const CXTPPaintManagerColor & | GetFrameCaptionActiveColor () const
Obtains theme specific active frame caption color value.

Public Attributes

BOOL | m_bFrameStatusBar
TRUE if status bar used to draw.
CXTPPaintManagerFont | m_fntFrameCaption
Font used to draw text in the frame caption.
int | m_nFrameCaptionHeight
Frame caption.
CXTPPaintManager * | m_pPaintManager
Parent Paint Manager.
BOOL | m_bFlatFrame
TRUE to use a flat frame, FALSE otherwise.
BOOL | m_bCaptionCenterAligned
If TRUE, caption title will be center aligned.

Protected Attributes

HICON | m_hIcon
Icon handle.
CSize | m_szIcon
Icon size.
CRect | m_rcIconMargin
Icon margin.
CXTPPaintManagerColor | m_clrFrameCaptionActive
Caption color (active)
CXTPPaintManagerColor | m_clrFrameCaptionInactive
Caption color (inactive)
CXTPPaintManagerColor | m_clrFrameCaptionTextActive
Caption text color.
CXTPPaintManagerColor | m_clrFrameCaptionTextInactive
Caption text color.
CXTPPaintManagerColor | m_clrFrameCaptionTextActiveTitle
Caption text color.
CXTPPaintManagerColor | m_clrFrameCaptionTextActiveBSMode
Caption text color.
CXTPPaintManagerColor | m_clrFrameCaptionTextInactiveBSMode
Caption text color.
CXTPPaintManagerColor | m_clrFrameCaptionTextActiveTitleBSMode
Caption text color.

Detailed Description

Paint manager for the Office 2007 style window frame.

Constructor & Destructor Documentation

◆ CXTPFramePaintManager()

CXTPFramePaintManager ( CXTPPaintManager * pPaintManager )

Constructs a CXTPFramePaintManager object.

Parameters
pPaintManager Reference to a CXTPPaintManager object.

Member Function Documentation

◆ CalcFrameBorder()

virtual CRect CalcFrameBorder ( const CXTPCommandBarsFrameHook * pFrameHook ) const
virtual

Calculates the frame border sizes.

Parameters
pFrameHook CXTPCommandBarsFrameHook hook object.
Returns
Returns Calculated frame border sizes

Reimplemented in CXTPFrameThemeOffice2007System.

◆ CalcFrameCaption()

virtual CRect CalcFrameCaption ( const CXTPCommandBarsFrameHook * pFrameHook ) const
virtual

Calculates the frame caption rect.

Parameters
pFrameHook CXTPCommandBarsFrameHook hook object.
Returns
Returns Calculated frame caption rect

◆ CalcFrameRegion()

virtual HRGN CalcFrameRegion | ( | CXTPCommandBarsFrameHook * | pFrameHook,
 |  | CSize | sz ) const
 pure virtual

This method is called to create the window region.

Parameters
pFrameHook | CXTPCommandBarsFrameHook hook object.
sz | Window size.
Returns
Region of the window to be set.

Implemented in CXTPFrameThemeOffice2007System.

◆ CreateShadow()

virtual CXTPFrameShadow * CreateShadow ( CWnd * pFrame )
virtual

Creates frame shadow if supported by theme.

Default implementation returns NULL.

Parameters
pFrame Window object pointer
Returns
Returns either a valid frame shadow pointer created by XTPFrameShadowManager()->EnableShadow or NULL if frame has no shadow.
See also
XTPFrameShadowManager

◆ DrawCaptionBar()

virtual void DrawCaptionBar | ( | CDC * | pDC,
 |  | CRect | rcCaptionBar,
 |  | CWnd * | pSite,
 |  | BOOL | bActive )
 virtual

This method is called to draw the frame caption bar.

Parameters
pDC | Pointer to device context.
rcCaptionBar | Caption bar rectangle.
pSite | Frame to draw.
bActive | TRUE if the frame is active.

Reimplemented in CXTPFrameThemeOffice2007System.

◆ DrawCaptionText() [1/2]

virtual void DrawCaptionText | ( | CDC * | pDC,
 |  | CRect | rcCaptionText,
 |  | CWnd * | pSite,
 |  | BOOL | bActive )
 virtual

This method is called to draw the frame caption text.

Parameters
pDC | Pointer to device context.
rcCaptionText | Bounding rectangle of window text.
pSite | Frame to draw.
bActive | TRUE if the frame is active.

◆ DrawCaptionText() [2/2]

virtual void DrawCaptionText | ( | CDC * | pDC,
 |  | CRect | rcCaptionText,
 |  | CWnd * | pSite,
 |  | BOOL | bActive,
 |  | CXTPRibbonBar * | pRibbonBar )
 virtual

This method is called to draw the frame caption text.

Parameters
pDC | Pointer to device context.
rcCaptionText | Bounding rectangle of window text.
pSite | Frame to draw.
bActive | TRUE if the frame is active.
pRibbonBar | Ribbon bar pointer.

◆ DrawFrame()

virtual void DrawFrame | ( | CDC * | pDC,
 |  | CXTPCommandBarsFrameHook * | pFrameHook )
 pure virtual

This method is called to draw the frame if Ribbon was found.

Parameters
pDC | Pointer to device context.
pFrameHook | CXTPCommandBarsFrameHook hook object.

Implemented in CXTPRibbonMarkupFrameTheme.

◆ DrawFrameCaptionButton() [1/2]

virtual void DrawFrameCaptionButton | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | int | nId,
 |  | BOOL | bSelected,
 |  | BOOL | bPressed,
 |  | BOOL | bActive )
 pure virtual

This method is called to draw the caption button.

Parameters
pDC | Pointer to device context.
rc | Bounding rectangle of the button.
nId | Identifier of the button.
bSelected | TRUE if the button is highlighted.
bPressed | TRUE if the button is pressed.
bActive | TRUE if the frame is active.

Implemented in CXTPFrameThemeOffice2007System.

◆ DrawFrameCaptionButton() [2/2]

virtual void DrawFrameCaptionButton | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | int | nId,
 |  | BOOL | bSelected,
 |  | BOOL | bPressed,
 |  | BOOL | bActive,
 |  | CXTPRibbonBar * | pRibbonBar )
 pure virtual

This method is called to draw the caption button.

Parameters
pDC | Pointer to device context.
rc | Bounding rectangle of the button.
nId | Identifier of the button.
bSelected | TRUE if the button is highlighted.
bPressed | TRUE if the button is pressed.
bActive | TRUE if the frame is active.
pRibbonBar | Ribbon bar pointer.

Implemented in CXTPFrameThemeOffice2007System.

◆ GetFrameCaptionAccentTextColor()

virtual COLORREF GetFrameCaptionAccentTextColor ( BOOL bActive ) const
virtual

Obtains frame caption accent color.

Parameters
bActive If TRUE then an active caption frame accent color to be obtained, FALSE otherwise.
Returns
Caption frame accent color value or COLORREF_NULL if no color is specified.

◆ GetFrameCaptionActiveColor()

AFX_INLINE const CXTPPaintManagerColor & GetFrameCaptionActiveColor ( ) const

Obtains theme specific active frame caption color value.

Returns
Theme specific active frame caption color value.

◆ GetFrameCaptionHeight()

AFX_INLINE int GetFrameCaptionHeight ( ) const
virtual

Retrieves the frame caption's height.

Returns
The frame Caption's height.

◆ GetFrameLargeIcon()

HICON GetFrameLargeIcon ( CWnd * pFrame )

Retrieves frame large icon.

Parameters
pFrame Window to retrieve icon.
Returns
Frame large icon.
See also
GetFrameLargeIcon

◆ GetFrameSmallIcon()

HICON GetFrameSmallIcon ( CWnd * pFrame )

Retrieves frame small icon.

Parameters
pFrame Window to retrieve icon.
Returns
Frame small icon.
See also
GetFrameLargeIcon

◆ GetImages()

CXTPResourceImages * GetImages ( ) const

This method is called to get a pointer to the CXTPResourceImages object.

Returns
A pointer to the CXTPResourceImages object.

◆ IsUseSystemAccentColorEnabled()

BOOL IsUseSystemAccentColorEnabled ( ) const

Determines whether xtpApplicationUseSystemAccentColor application ambient property is set.

Returns
TRUE if use of system accent color is required, FALSE otherwise.

◆ LoadImage()

CXTPResourceImage * LoadImage ( LPCTSTR lpszFileName )

Loads a bitmap image from the specified path.

Parameters
lpszFileName The name of the file that contains the bitmaps to load.

The images are the bitmaps that represent all the visual components of the Ribbon Bar. For example tab buttons, group buttons, menu buttons, toolbar buttons, option button, toolbar dropdown, etc. The images are loaded using LoadImage and are stored in the m_pImages image collection. Images for the Office 2007 theme can be found in the \Source\Ribbon\Res folder.

Returns
New CXTPResourceImage containing the loaded bitmap.
See also
SetImageHandle, m_pImages

◆ OnShadowedFrameActiveStateChanged()

virtual void OnShadowedFrameActiveStateChanged | ( | BOOL | bActive,
 |  | CWnd * | pFrame,
 |  | CXTPFrameShadow * | pShadow )
 virtual

An implementation can override this method in order to change frame appearance when a window gets activated or deactivated.

Parameters
bActive | TRUE is a window is activated, otherwise FALSE.
pFrame | Window object pointer.
pShadow | Shadow object pointer.
See also
CreateShadow, XTPFrameShadowManager

◆ SetIcon()

void SetIcon | ( | HICON | hIcon,
 |  | CSize | szIcon )

Sets the frame icon.

Parameters
szIcon | Size of the icon.
hIcon | Icon handle to set.
The documentation for this class was generated from the following file:
  • XTPFramePaintManager.h


Toolkit Pro: CXTPFrameShadow Class Reference

Public Member Functions | Static Public Member Functions | Protected Member Functions | List of all members
CXTPFrameShadow Class Reference

The class represents frame shadow object. More...

Inheritance diagram for CXTPFrameShadow:
[legend]

Public Member Functions

CXTPFrameShadow (HWND hOwner)
Constructs frame shadow object.
virtual | ~CXTPFrameShadow ()
Handles frame shadow deallocation.
BOOL | Create (COLORREF crColor, UINT nOuterSize, UINT nInnerSize=0, CPoint ptOffset=CPoint(0, 0), BYTE bTransparency=0x80)
Creates frame shadow and initializes it with initial parameters.
void | FreezeUpdates (BOOL bFreeze=TRUE)
Freezes/unfreezes updates on changing shadow settings, as a result shadow blinking is reduced.
BOOL | IsCreated () const
Determines if the shadows has been created.
HWND | GetOwner () const
Obtains an owning window pointer.
UINT | GetOuterSize () const
Obtains the value of the outer size.
void | SetOuterSize (UINT nSize)
Sets the value of the outer size.
UINT | GetInnerSize () const
Obtains the value of the inner size.
void | SetInnerSize (UINT nSize)
Sets the value of the inner size.
CPoint | GetOffset () const
Obtains offset value.
void | SetOffset (CPoint ptOffset)
Sets offset value.
COLORREF | GetColor () const
Obtains color value.
void | SetColor (COLORREF crColor)
Sets color value.
BYTE | GetTransparency () const
Obtains transparency value.
void | SetTransparency (BYTE bTransparency)
Sets transparency value.
UINT | GetBlendingOptions (OUT OPTIONAL float *pFactors, OUT OPTIONAL float *pPositions) const
Obtains shadow blending options.
void | SetBlendingOptions (UINT nCount, const float *pFactors, const float *pPositions)
Sets shadow blending options.
BOOL | GetClipOwner () const
Obtains owner clipping for the current shadow only.
void | SetClipOwner (BOOL bClipOwner)
Sets owner clipping for the current shadow only.
void | Show ()
Shows frame shadow if not visible.
void | Hide ()
Hides frame shadow if not visible.
void | UpdatePosition ()
Updates shadow position and redraws it if necessary.

Static Public Member Functions

static BOOL AFX_CDECL IsShadowSupported ()
Determines if frame shadows are supported by the platform.

Protected Member Functions

virtual void OnFlagsChanged (CXTPFrameShadowManager *pManager, int nOldEffectiveFlags, int nNewEffectiveFlags)
Invoked when flags are changed.

Detailed Description

The class represents frame shadow object.

Frame shadow is a rounded rectangle beyond a window to which it is assigned. The thickness of shadow area and the radius of the corners are controlled by outer and inner shadow size, that is a size between window border and the outermost shadow edge (outer size), and a size between window border and the innermost shadow edge (inner size).

Constructor & Destructor Documentation

◆ CXTPFrameShadow()

CXTPFrameShadow ( HWND hOwner )
explicit

Constructs frame shadow object.

Parameters
hOwner Owner window handle.

Member Function Documentation

◆ Create()

BOOL Create | ( | COLORREF | crColor,
 |  | UINT | nOuterSize,
 |  | UINT | nInnerSize = 0,
 |  | CPoint | ptOffset = CPoint(0, 0),
 |  | BYTE | bTransparency = 0x80 )

Creates frame shadow and initializes it with initial parameters.

Parameters
crColor | Shadow color.
nOuterSize | The outer size of a shadow, i.e. the size between window border and shadow edge outside the window.
nInnerSize | The inner size of a shadow, i.e. the size between window border and shadow edge under the window.
ptOffset | Shadow offset.
bTransparency | Shadow transparency, 0 means fully transparent, 255 means fully opaque.
Returns
TRUE if frame shadows are supported, otherwise FALSE.
See also
IsCreated

◆ FreezeUpdates()

void FreezeUpdates ( BOOL bFreeze = TRUE )

Freezes/unfreezes updates on changing shadow settings, as a result shadow blinking is reduced.

Parameters
bFreeze If TRUE the update freeze counter is incremented. Otherwise the update freeze counter is decremented.

◆ GetBlendingOptions()

UINT GetBlendingOptions | ( | OUT OPTIONAL float * | pFactors,
 |  | OUT OPTIONAL float * | pPositions ) const

Obtains shadow blending options.

The pFactors and pPositions arrays are of the same size where each factor is applied at the appropriate position specified. A factor value has to be in a range [0..1], where 0 means fully transparent shadow and 1 means fully opaque shadow at the specified position. The position array has to be either empty or has at least two values { 0, 1 }. The first position has always be equal to 0, and the last - to 1, positions in between have to be sorted in the ascending order left-to-right and should be in a range (0, 1).

Parameters
pFactors | Optional. If not NULL it should a pointer to an array of factors, large enough to hold the number of elements returned by the function.
pPositions | Optional. If not NULL it should a pointer to an array of positions, large enough to hold the number of elements returned by the function.
Returns
A number of blenging elements or 0 if no blending options applied.
See also
SetBlendingOptions

◆ GetClipOwner()

BOOL GetClipOwner ( ) const

Obtains owner clipping for the current shadow only.

By default owner clipping is enabled in order to reduce flickering and improve rendering speed in slow environments. Disabling owner clipping may be necessary for owner windows that non-rectangular shape as the clipping box is always rectangular.

Returns
TRUE if clipping is enabled.

◆ GetColor()

COLORREF GetColor ( ) const

Obtains color value.

Returns
Color value.
See also
SetColor

◆ GetInnerSize()

UINT GetInnerSize ( ) const

Obtains the value of the inner size.

Returns
The value of the inner size.
See also
SetInnerSize

◆ GetOffset()

CPoint GetOffset ( ) const

Obtains offset value.

Returns
Offset value.
See also
SetOffset

◆ GetOuterSize()

UINT GetOuterSize ( ) const

Obtains the value of the outer size.

Returns
The value of the outer size.
See also
SetOuterSize

◆ GetOwner()

HWND GetOwner ( ) const

Obtains an owning window pointer.

Returns
An owning window handle.

◆ GetTransparency()

BYTE GetTransparency ( ) const

Obtains transparency value.

0 means fully transparent, 255 means fully opaque.

Returns
Transparency value.
See also
SetTransparency

◆ Hide()

void Hide ( )

Hides frame shadow if not visible.

Note that showing and hiding a shadow is not the same as enabling and disabling the shadow when the it's actually created and destroyed. It's just about making an enabled shadow hidden.

See also
Show

◆ IsCreated()

BOOL IsCreated ( ) const

Determines if the shadows has been created.

Returns
TRUE if the shadow has been created.
See also
Create

◆ IsShadowSupported()

static BOOL AFX_CDECL IsShadowSupported ( )
static

Determines if frame shadows are supported by the platform.

Returns
TRUE if frame shadows are supported, otherwise FALSE.

◆ OnFlagsChanged()

virtual void OnFlagsChanged | ( | CXTPFrameShadowManager * | pManager,
 |  | int | nOldEffectiveFlags,
 |  | int | nNewEffectiveFlags )
 protectedvirtual

Invoked when flags are changed.

Parameters
pManager | Frame Shadow Manager pointer
nOldEffectiveFlags | A set of old effective flags.
nNewEffectiveFlags | A set of new effective flags.
See also
XTPFrameShadowManagerFlags

Reimplemented from IXTPFrameShadowManagerEvents.

◆ SetBlendingOptions()

void SetBlendingOptions | ( | UINT | nCount,
 |  | const float * | pFactors,
 |  | const float * | pPositions )

Sets shadow blending options.

The pFactors and pPositions arrays are of the same size where each factor is applied at the appropriate position specified. A factor value has to be in a range [0..1], where 0 means fully transparent shadow and 1 means fully opaque shadow at the specified position. The position array has to be either empty or has at least two values { 0, 1 }. The first position has always be equal to 0, and the last - to 1, positions in between have to be sorted in the ascending order left-to-right and should be in a range (0, 1).

Parameters
nCount | Number of elements in pFactors and pPositions arrays. If equals to 0 the pFactors and pPositions values are ignored and blending options are disabled.
pFactors | A pointer to an array of factors of nCount elements.
pPositions | A pointer to an array of positions of nCount elements.
See also
GetBlendingOptions

◆ SetClipOwner()

void SetClipOwner ( BOOL bClipOwner )

Sets owner clipping for the current shadow only.

Parameters
bClipOwner TRUE to enable clipping.

By default owner clipping is enabled in order to reduce flickering and improve rendering speed in slow environments. Disabling owner clipping may be necessary for owner windows that non-rectangular shape as the clipping box is always rectangular.

◆ SetColor()

void SetColor ( COLORREF crColor )

Sets color value.

Parameters
crColor Color value.
See also
GetColor

◆ SetInnerSize()

void SetInnerSize ( UINT nSize )

Sets the value of the inner size.

Parameters
nSize The value of the inner size.
See also
GetInnerSize

◆ SetOffset()

void SetOffset ( CPoint ptOffset )

Sets offset value.

Parameters
ptOffset Offset value.
See also
GetOffset

◆ SetOuterSize()

void SetOuterSize ( UINT nSize )

Sets the value of the outer size.

Parameters
nSize The value of the outer size.
See also
GetOuterSize

◆ SetTransparency()

void SetTransparency ( BYTE bTransparency )

Sets transparency value.

0 means fully transparent, 255 means fully opaque.

Parameters
bTransparency Transparency value.
See also
GetTransparency

◆ Show()

void Show ( )

Shows frame shadow if not visible.

Note that showing and hiding a shadow is not the same as enabling and disabling the shadow when the it's actually created and destroyed. It's just about making an enabled shadow visible.

See also
Hide
The documentation for this class was generated from the following file:
  • XTPFrameShadow.h


Toolkit Pro: CXTPFrameShadowManager Class Reference

Public Member Functions | List of all members
CXTPFrameShadowManager Class Reference

Provides frame shadow management functionality. More...

Inheritance diagram for CXTPFrameShadowManager:
[legend]

Public Member Functions

BOOL | IsShadowSupported () const
Determines if frame shadows are supported by the platform.
int | GetFlags () const
Obtains global frame shadow flags.
void | SetFlags (int nFlags)
Sets global frame shadow flags.
CXTPFrameShadow * | EnableShadow (CWnd *pWnd, COLORREF crColor=(COLORREF) -1, UINT nOuterSize=0, UINT nInnerSize=0, CPoint ptOffset=CPoint(0, 0), BYTE bTransparency=0)
Enables frame shadow for a window specified.
CXTPFrameShadow * | EnableShadow (HWND hWnd, COLORREF crColor=(COLORREF) -1, UINT nOuterSize=0, UINT nInnerSize=0, CPoint ptOffset=CPoint(0, 0), BYTE bTransparency=0)
Enables frame shadow for a window specified.
void | DisableShadow (HWND hWnd)
Disable a previsously enabled frame shadow for a window specified.
void | DisableShadow (CWnd *pWnd)
Disable a previsously enabled frame shadow for a window specified.
BOOL | IsShadowEnabled (CWnd *pWnd) const
Determines if a shadow is enabled for the window specified.
CXTPFrameShadow * | GetShadow (HWND hWnd) const
Obtains shadow object pointer for a window specified.
CXTPFrameShadow * | GetShadow (CWnd *pWnd) const
Obtains shadow object pointer for a window specified.
POSITION | GetFirstShadowPosition () const
Obtains the position of the first shadow in the list of all enabled shadows.
CXTPFrameShadow * | GetNextShadow (POSITION &pos) const
Obtains frame shadow pointer in the position specified and moves the position cursor to the next enabled shadow.
void | FreezeUpdates (BOOL bFreeze=TRUE)
Freezes/unfreezes updates on changing shadow settings, as a result shadow blinking is reduced.
UINT | GetDefaultOuterSize () const
Obtains a value of default outer size used for all shadows to be created if a default value is used in EnableShadow.
void | SetDefaultOuterSize (UINT nSize)
Sets a value of default outer size used for all shadows to be created if a default value is used in EnableShadow.
void | SetGlobalOuterSize (UINT nSize)
Sets a value of default outer size used for all shadows to be created if a default value is used in EnableShadow and applies the change for all enabled shadows.
UINT | GetDefaultInnerSize () const
Obtains a value of default inner size used for all shadows to be created if a default value is used in EnableShadow.
void | SetDefaultInnerSize (UINT nSize)
Sets a value of default inner size used for all shadows to be created if a default value is used in EnableShadow.
void | SetGlobalInnerSize (UINT nSize)
Sets a value of default inner size used for all shadows to be created if a default value is used in EnableShadow and applies the change for all enabled shadows.
CPoint | GetDefaultOffset () const
Obtains a value of default shadow offset used for all shadows to be created if a default value is used in EnableShadow.
void | SetDefaultOffset (CPoint ptOffset)
Sets a value of default shadow offset used for all shadows to be created if a default value is used in EnableShadow.
void | SetGlobalOffset (CPoint ptOffset)
Sets a value of default shadow offset used for all shadows to be created if a default value is used in EnableShadow and applies the change for all enabled shadows.
COLORREF | GetDefaultColor () const
Obtains a value of default color used for all shadows to be created if a default value is used in EnableShadow.
void | SetDefaultColor (COLORREF crColor)
Sets a value of default color used for all shadows to be created if a default value is used in EnableShadow.
void | SetGlobalColor (COLORREF crColor)
Sets a value of default color used for all shadows to be created if a default value is used in EnableShadow and applies the change for all enabled shadows.
BYTE | GetDefaultTransparency () const
Obtains a value of default transparency used for all shadows to be created if a default value is used in EnableShadow.
void | SetDefaultTransparency (BYTE bTransparency)
Sets a value of default transparency used for all shadows to be created if a default value is used in EnableShadow.
void | SetGlobalTransparency (BYTE bTransparency)
Sets a value of default trasparency used for all shadows to be created if a default value is used in EnableShadow and applies the change for all enabled shadows.
UINT | GetDefaultBlendingOptions (OUT OPTIONAL float *pFactors, OUT OPTIONAL float *pPositions) const
Obtains default blending options used for all shadows to be created if a default value is used in EnableShadow.
void | SetDefaultBlendingOptions (UINT nCount, const float *pFactors, const float *pPositions)
Sets default blending options used for all shadows to be created if a default value is used in EnableShadow.
void | SetGlobalBlendingOptions (UINT nCount, const float *pFactors, const float *pPositions)
Sets default blending options used for all shadows to be created if a default value is used in EnableShadow and applies the change for all enabled shadows.
BOOL | GetDefaultClipOwner () const
Obtains default owner clipping for new shadows.
void | SetDefaultClipOwner (BOOL bClipOwner)
Sets default owner clipping for new shadows.
void | SetGlobalClipOwner (BOOL bClipOwner)
Sets owner clipping for all shadows.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.
- Public Member Functions inherited from CXTPObservable< CXTPFrameShadowManager, IXTPFrameShadowManagerEvents >
void | Subscribe (IXTPFrameShadowManagerEvents *pObserver, CXTPSubscriptionList< CXTPFrameShadowManager, IXTPFrameShadowManagerEvents > *pSubcriptionList=NULL)
Subscribes a unique observer for events.
void | Unsubscribe (IXTPFrameShadowManagerEvents *pObserver)
Unsubscribes an observer from events.
void | Notify (void(IXTPFrameShadowManagerEvents::*method)(CXTPFrameShadowManager *))
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(IXTPFrameShadowManagerEvents::*method)(CXTPFrameShadowManager *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(IXTPFrameShadowManagerEvents::*method)(CXTPFrameShadowManager *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(IXTPFrameShadowManagerEvents::*method)(CXTPFrameShadowManager *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(IXTPFrameShadowManagerEvents::*method)(CXTPFrameShadowManager *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(IXTPFrameShadowManagerEvents::*method)(CXTPFrameShadowManager *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(IXTPFrameShadowManagerEvents::*method)(CXTPFrameShadowManager *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(IXTPFrameShadowManagerEvents::*method)(CXTPFrameShadowManager *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *))
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Member Functions inherited from CXTPObservable< CXTPFrameShadowManager, IXTPFrameShadowManagerEvents >
CXTPObservable ()
Constructs an observable object.
~CXTPObservable ()
Handles observable object destruction.

Detailed Description

Provides frame shadow management functionality.

Member Function Documentation

◆ DisableShadow() [1/2]

void DisableShadow ( CWnd * pWnd )

Disable a previsously enabled frame shadow for a window specified.

Parameters
pWnd A pointer to a non-child window for which frame shadow has to be disabled.
See also
EnableShadow, IsShadowEnabled, GetShadow

◆ DisableShadow() [2/2]

void DisableShadow ( HWND hWnd )

Disable a previsously enabled frame shadow for a window specified.

Parameters
hWnd A handle to a non-child window for which frame shadow has to be disabled.
See also
EnableShadow, IsShadowEnabled, GetShadow

◆ EnableShadow() [1/2]

CXTPFrameShadow * EnableShadow | ( | CWnd * | pWnd,
 |  | COLORREF | crColor = (COLORREF) -1,
 |  | UINT | nOuterSize = 0,
 |  | UINT | nInnerSize = 0,
 |  | CPoint | ptOffset = CPoint(0, 0),
 |  | BYTE | bTransparency = 0 )

Enables frame shadow for a window specified.

Parameters
pWnd | A pointer to a non-child window for which frame shadow has to be enabled.
crColor | Optional. Frame shadow color. If not specified, default value is used.
nOuterSize | Optional. Frame shadow outer size. If not specified, default value is used.
nInnerSize | Optional. Frame shadow inner size. If not specified, default value is used.
ptOffset | Optional. Frame shadow offset. If not specified, default value is used.
bTransparency | Optional. Frame shadow transparency (0 fully transparent, 255 fully opaque). If not specified, default value is used.
Returns
Shadow object pointer or NULL if failed.
See also
DisableShadow, IsShadowEnabled, GetShadow

◆ EnableShadow() [2/2]

CXTPFrameShadow * EnableShadow | ( | HWND | hWnd,
 |  | COLORREF | crColor = (COLORREF) -1,
 |  | UINT | nOuterSize = 0,
 |  | UINT | nInnerSize = 0,
 |  | CPoint | ptOffset = CPoint(0, 0),
 |  | BYTE | bTransparency = 0 )

Enables frame shadow for a window specified.

Parameters
hWnd | A non-child window handle for which frame shadow has to be enabled.
crColor | Optional. Frame shadow color. If not specified, default value is used.
nOuterSize | Optional. Frame shadow outer size. If not specified, default value is used.
nInnerSize | Optional. Frame shadow inner size. If not specified, default value is used.
ptOffset | Optional. Frame shadow offset. If not specified, default value is used.
bTransparency | Optional. Frame shadow transparency (0 fully transparent, 255 fully opaque). If not specified, default value is used.
Returns
Shadow object pointer or NULL if failed.
See also
DisableShadow, IsShadowEnabled, GetShadow

◆ FreezeUpdates()

void FreezeUpdates ( BOOL bFreeze = TRUE )

Freezes/unfreezes updates on changing shadow settings, as a result shadow blinking is reduced.

Parameters
bFreeze If TRUE the update freeze counter is incremented. Otherwise the update freeze counter is decremented.

◆ GetDefaultBlendingOptions()

UINT GetDefaultBlendingOptions | ( | OUT OPTIONAL float * | pFactors,
 |  | OUT OPTIONAL float * | pPositions ) const

Obtains default blending options used for all shadows to be created if a default value is used in EnableShadow.

Refer to CXTPFrameShadow documentation for further details.

Parameters
pFactors | Optionals. If not NULL, should be a pointer to an array of the number of elements equal to the returned value.
pPositions | Optionals. If not NULL, should be a pointer to an array of the number of elements equal to the returned value.
Returns
A number of factors and positions used for blending.
See also
SetDefaultBlendingOptions, SetGlobalBlendingOptions, CXTPFrameShadow

◆ GetDefaultClipOwner()

BOOL GetDefaultClipOwner ( ) const

Obtains default owner clipping for new shadows.

By default owner clipping is enabled in order to reduce flickering and improve rendering speed in slow environments. Disabling owner clipping may be necessary for owner windows that non-rectangular shape as the clipping box is always rectangular.

Returns
TRUE if clipping is enabled.
See also
SetGlobalClipOwner

◆ GetDefaultColor()

COLORREF GetDefaultColor ( ) const

Obtains a value of default color used for all shadows to be created if a default value is used in EnableShadow.

Returns
A default value.
See also
SetDefaultColor, SetGlobalColor

◆ GetDefaultInnerSize()

UINT GetDefaultInnerSize ( ) const

Obtains a value of default inner size used for all shadows to be created if a default value is used in EnableShadow.

Returns
A default value.
See also
SetDefaultInnerSize, SetGlobalInnerSize

◆ GetDefaultOffset()

CPoint GetDefaultOffset ( ) const

Obtains a value of default shadow offset used for all shadows to be created if a default value is used in EnableShadow.

Returns
A default value.
See also
SetDefaultOffset, SetGlobalOffset

◆ GetDefaultOuterSize()

UINT GetDefaultOuterSize ( ) const

Obtains a value of default outer size used for all shadows to be created if a default value is used in EnableShadow.

Returns
A default value.
See also
SetDefaultOuterSize, SetGlobalOuterSize

◆ GetDefaultTransparency()

BYTE GetDefaultTransparency ( ) const

Obtains a value of default transparency used for all shadows to be created if a default value is used in EnableShadow.

Returns
A default value. 0 means a fully transparent shadow, 255 means fully opaque.
See also
SetDefaultTransparency, SetGlobalTransparency

◆ GetFirstShadowPosition()

POSITION GetFirstShadowPosition ( ) const

Obtains the position of the first shadow in the list of all enabled shadows.

Returns
A position of the first enabled shadow in the internal list or NULL if not shadow is enabled.
See also
GetNextShadow

◆ GetFlags()

int GetFlags ( ) const

Obtains global frame shadow flags.

Returns
Global frame shadow flags combination.
See also
XTPFrameShadowManagerFlags

◆ GetNextShadow()

CXTPFrameShadow * GetNextShadow ( POSITION & pos ) const

Obtains frame shadow pointer in the position specified and moves the position cursor to the next enabled shadow.

Parameters
pos Position to show.
Returns
A pointer to the shadow at the position specified or NULL if the end of the list is reached.
See also
GetFirstShadowPosition

◆ GetShadow() [1/2]

CXTPFrameShadow * GetShadow ( CWnd * pWnd ) const

Obtains shadow object pointer for a window specified.

Parameters
pWnd A pointer to a window for which to obtain a shadow object pointer.
Returns
Window's frame shadow object pointer or NULL if the window has no shadow enabled.
See also
EnableShadow, DisableShadow, IsShadowEnabled

◆ GetShadow() [2/2]

CXTPFrameShadow * GetShadow ( HWND hWnd ) const

Obtains shadow object pointer for a window specified.

Parameters
hWnd A handle to a window for which to obtain a shadow object pointer.
Returns
Window's frame shadow object pointer or NULL if the window has no shadow enabled.
See also
EnableShadow, DisableShadow, IsShadowEnabled

◆ IsShadowEnabled()

BOOL IsShadowEnabled ( CWnd * pWnd ) const

Determines if a shadow is enabled for the window specified.

Parameters
pWnd A pointer to a window to check shadow for.
Returns
TRUE if shadow is enabled for the window specified.
See also
EnableShadow, DisableShadow, GetShadow

◆ IsShadowSupported()

BOOL IsShadowSupported ( ) const

Determines if frame shadows are supported by the platform.

Returns
TRUE if frame shadows are supported, otherwise FALSE.

◆ SetDefaultBlendingOptions()

void SetDefaultBlendingOptions | ( | UINT | nCount,
 |  | const float * | pFactors,
 |  | const float * | pPositions )

Sets default blending options used for all shadows to be created if a default value is used in EnableShadow.

Refer to CXTPFrameShadow documentation for further details.

Parameters
nCount | The number of blending factors and positions.
pFactors | A pointer to an array of nCount elements. Ignored if nCount = 0.
pPositions | A pointer to an array of nCount elements. Ignored if nCount = 0.
See also
GetDefaultBlendingOptions, SetGlobalBlendingOptions, CXTPFrameShadow

◆ SetDefaultClipOwner()

void SetDefaultClipOwner ( BOOL bClipOwner )

Sets default owner clipping for new shadows.

Parameters
bClipOwner TRUE to enable clipping.

By default owner clipping is enabled in order to reduce flickering and improve rendering speed in slow environments. Disabling owner clipping may be necessary for owner windows that non-rectangular shape as the clipping box is always rectangular.

See also
SetGlobalClipOwner

◆ SetDefaultColor()

void SetDefaultColor ( COLORREF crColor )

Sets a value of default color used for all shadows to be created if a default value is used in EnableShadow.

Parameters
crColor A new default value to be used.
See also
GetDefaultColor, SetGlobalColor

◆ SetDefaultInnerSize()

void SetDefaultInnerSize ( UINT nSize )

Sets a value of default inner size used for all shadows to be created if a default value is used in EnableShadow.

Parameters
nSize A new default value to be used.
See also
GetDefaultInnerSize, SetGlobalInnerSize

◆ SetDefaultOffset()

void SetDefaultOffset ( CPoint ptOffset )

Sets a value of default shadow offset used for all shadows to be created if a default value is used in EnableShadow.

Parameters
ptOffset A new default value to be used.
See also
GetDefaultOffset, SetGlobalOffset

◆ SetDefaultOuterSize()

void SetDefaultOuterSize ( UINT nSize )

Sets a value of default outer size used for all shadows to be created if a default value is used in EnableShadow.

Parameters
nSize A new default value to be used.
See also
GetDefaultOuterSize, SetGlobalOuterSize

◆ SetDefaultTransparency()

void SetDefaultTransparency ( BYTE bTransparency )

Sets a value of default transparency used for all shadows to be created if a default value is used in EnableShadow.

Parameters
bTransparency A new default value to be used. 0 means a fully transparent shadow, 255 means fully opaque.
See also
GetDefaultTransparency, SetGlobalTransparency

◆ SetFlags()

void SetFlags ( int nFlags )

Sets global frame shadow flags.

The previous value is overwritten.

Parameters
nFlags Global frame shadow flags combination.
See also
XTPFrameShadowManagerFlags

◆ SetGlobalBlendingOptions()

void SetGlobalBlendingOptions | ( | UINT | nCount,
 |  | const float * | pFactors,
 |  | const float * | pPositions )

Sets default blending options used for all shadows to be created if a default value is used in EnableShadow and applies the change for all enabled shadows.

Refer to CXTPFrameShadow documentation for further details.

Parameters
nCount | The number of blending factors and positions.
pFactors | A pointer to an array of nCount elements. Ignored if nCount = 0.
pPositions | A pointer to an array of nCount elements. Ignored if nCount = 0.
See also
GetDefaultBlendingOptions, SetDefaultBlendingOptions, CXTPFrameShadow

◆ SetGlobalClipOwner()

void SetGlobalClipOwner ( BOOL bClipOwner )

Sets owner clipping for all shadows.

Parameters
bClipOwner TRUE to enable clipping.

By default owner clipping is enabled in order to reduce flickering and improve rendering speed in slow environments. Disabling owner clipping may be necessary for owner windows that non-rectangular shape as the clipping box is always rectangular.

See also
GetDefaultClipOwner, SetDefaultClipOwner

◆ SetGlobalColor()

void SetGlobalColor ( COLORREF crColor )

Sets a value of default color used for all shadows to be created if a default value is used in EnableShadow and applies the change for all enabled shadows.

Parameters
crColor A new value to be applied and used by default.
See also
GetDefaultColor, SetDefaultColor

◆ SetGlobalInnerSize()

void SetGlobalInnerSize ( UINT nSize )

Sets a value of default inner size used for all shadows to be created if a default value is used in EnableShadow and applies the change for all enabled shadows.

Parameters
nSize A new value to be applied and used by default.
See also
GetDefaultInnerSize, SetDefaultInnerSize

◆ SetGlobalOffset()

void SetGlobalOffset ( CPoint ptOffset )

Sets a value of default shadow offset used for all shadows to be created if a default value is used in EnableShadow and applies the change for all enabled shadows.

Parameters
ptOffset A new value to be applied and used by default.
See also
GetDefaultOffset, SetDefaultOffset

◆ SetGlobalOuterSize()

void SetGlobalOuterSize ( UINT nSize )

Sets a value of default outer size used for all shadows to be created if a default value is used in EnableShadow and applies the change for all enabled shadows.

Parameters
nSize A new value to be applied and used by default.
See also
GetDefaultOuterSize, SetDefaultOuterSize

◆ SetGlobalTransparency()

void SetGlobalTransparency ( BYTE bTransparency )

Sets a value of default trasparency used for all shadows to be created if a default value is used in EnableShadow and applies the change for all enabled shadows.

Parameters
bTransparency A new default value to be used. 0 means a fully transparent shadow, 255 means fully opaque.
See also
GetDefaultTransparency, SetDefaultTransparency
The documentation for this class was generated from the following file:
  • XTPFrameShadowManager.h


Toolkit Pro: CXTPFrameThemeOffice2007System Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPFrameThemeOffice2007System Class Reference

The CXTPFrameThemeOffice2007System class is used to enable a system style theme for Command Bars. More...

Inheritance diagram for CXTPFrameThemeOffice2007System:
[legend]

Public Member Functions

CXTPFrameThemeOffice2007System (CXTPPaintManager *pPaintManager)
Construction / Destruction.
virtual | ~CXTPFrameThemeOffice2007System ()
Destroys a CXTPFrameThemeOffice2007System object, handles cleanup and deallocation.
virtual HRGN | CalcFrameRegion (CXTPCommandBarsFrameHook *pFrameHook, CSize sz) const
This method is called to create the window region.
virtual CRect | CalcFrameBorder (const CXTPCommandBarsFrameHook *pFrameHook) const
Calculates the frame border sizes.
virtual CXTPMarkupThemePart * | GetFrameBorder (int nId, BOOL bActive)
This method is called to get the frame border part.
virtual void | DrawCaptionBar (CDC *pDC, CRect rcCaptionBar, CWnd *pSite, BOOL bActive)
This method is called to draw the frame caption bar.
void | DrawFrameCaptionButton (CDC *pDC, CRect rc, int nId, BOOL bSelected, BOOL bPressed, BOOL bActive)
This method is called to draw caption button.
virtual void | DrawFrameCaptionButton (CDC *pDC, CRect rc, int nId, BOOL bSelected, BOOL bPressed, BOOL bActive, CXTPRibbonBar *pRibbonBar)
This method is called to draw caption button.
virtual void | RefreshMetrics ()
This method is called to refresh the visual metrics of the manager.
virtual void | LoadParts (HZIP hZip, CXTPMarkupContext *pMarkupContext)
Loads markup parts from the specified ZIP source.
virtual void | LoadParts (BOOL bReload=FALSE)
Loads markup parts.
- Public Member Functions inherited from CXTPRibbonMarkupFrameTheme
CXTPRibbonMarkupFrameTheme (CXTPPaintManager *pPaintManager)
Constructs a CXTPRibbonMarkupFrameTheme object.
virtual | ~CXTPRibbonMarkupFrameTheme ()
Destroys a CXTPRibbonMarkupFrameTheme object, handles cleanup and deallocation.
virtual void | DrawFrame (CDC *pDC, CXTPCommandBarsFrameHook *pFrameHook)
This method is called to draw the frame if the Ribbon was found.
virtual void | DrawFrameBorder (CDC *pDC, CXTPCommandBarsFrameHook *pFrameHook)
This method is called to draw the frame border.
void | ReloadMarkupParts (HZIP hZip, CXTPMarkupContext *pMarkupContext)
Re-loads markup parts from the specified ZIP source.
- Public Member Functions inherited from CXTPFramePaintManager
CXTPFramePaintManager (CXTPPaintManager *pPaintManager)
Constructs a CXTPFramePaintManager object.
virtual | ~CXTPFramePaintManager ()
Destroys a CXTPFramePaintManager object, handles cleanup and deallocation.
void | SetIcon (HICON hIcon, CSize szIcon)
Sets the frame icon.
virtual CRect | CalcFrameCaption (const CXTPCommandBarsFrameHook *pFrameHook) const
Calculates the frame caption rect.
virtual COLORREF | GetFrameCaptionAccentTextColor (BOOL bActive) const
Obtains frame caption accent color.
BOOL | IsUseSystemAccentColorEnabled () const
Determines whether xtpApplicationUseSystemAccentColor application ambient property is set.
virtual int | GetFrameCaptionHeight () const
Retrieves the frame caption's height.
CXTPResourceImages * | GetImages () const
This method is called to get a pointer to the CXTPResourceImages object.
virtual void | DrawCaptionText (CDC *pDC, CRect rcCaptionText, CWnd *pSite, BOOL bActive)
This method is called to draw the frame caption text.
virtual void | DrawCaptionText (CDC *pDC, CRect rcCaptionText, CWnd *pSite, BOOL bActive, CXTPRibbonBar *pRibbonBar)
This method is called to draw the frame caption text.
CXTPResourceImage * | LoadImage (LPCTSTR lpszFileName)
Loads a bitmap image from the specified path.
HICON | GetFrameSmallIcon (CWnd *pFrame)
Retrieves frame small icon.
HICON | GetFrameLargeIcon (CWnd *pFrame)
Retrieves frame large icon.
virtual CXTPFrameShadow * | CreateShadow (CWnd *pFrame)
Creates frame shadow if supported by theme.
virtual void | OnShadowedFrameActiveStateChanged (BOOL bActive, CWnd *pFrame, CXTPFrameShadow *pShadow)
An implementation can override this method in order to change frame appearance when a window gets activated or deactivated.
const CXTPPaintManagerColor & | GetFrameCaptionActiveColor () const
Obtains theme specific active frame caption color value.

Protected Attributes

CXTPMarkupContext * | m_pMarkupContext
Store pointer to CXTPMarkupContext object.
BOOL | m_bMarkupPartsLoaded
TRUE if markup parts have been loaded.
- Protected Attributes inherited from CXTPRibbonMarkupFrameTheme
BOOL | m_bMarkupPartsLoaded
TRUE if markup parts have been loaded.
- Protected Attributes inherited from CXTPFramePaintManager
HICON | m_hIcon
Icon handle.
CSize | m_szIcon
Icon size.
CRect | m_rcIconMargin
Icon margin.
CXTPPaintManagerColor | m_clrFrameCaptionActive
Caption color (active)
CXTPPaintManagerColor | m_clrFrameCaptionInactive
Caption color (inactive)
CXTPPaintManagerColor | m_clrFrameCaptionTextActive
Caption text color.
CXTPPaintManagerColor | m_clrFrameCaptionTextInactive
Caption text color.
CXTPPaintManagerColor | m_clrFrameCaptionTextActiveTitle
Caption text color.
CXTPPaintManagerColor | m_clrFrameCaptionTextActiveBSMode
Caption text color.
CXTPPaintManagerColor | m_clrFrameCaptionTextInactiveBSMode
Caption text color.
CXTPPaintManagerColor | m_clrFrameCaptionTextActiveTitleBSMode
Caption text color.

Additional Inherited Members

- Public Attributes inherited from CXTPFramePaintManager
BOOL | m_bFrameStatusBar
TRUE if status bar used to draw.
CXTPPaintManagerFont | m_fntFrameCaption
Font used to draw text in the frame caption.
int | m_nFrameCaptionHeight
Frame caption.
CXTPPaintManager * | m_pPaintManager
Parent Paint Manager.
BOOL | m_bFlatFrame
TRUE to use a flat frame, FALSE otherwise.
BOOL | m_bCaptionCenterAligned
If TRUE, caption title will be center aligned.
- Protected Types inherited from CXTPRibbonMarkupFrameTheme
enum XTPBorderPart {
xtpBorderPartTop , xtpBorderPartLeft , xtpBorderPartLeftCaption , xtpBorderPartRight ,
xtpBorderPartRightCaption , xtpBorderPartBottom , xtpBorderPartCount
}
Defines border parts. More...
- Protected Member Functions inherited from CXTPRibbonMarkupFrameTheme

Detailed Description

The CXTPFrameThemeOffice2007System class is used to enable a system style theme for Command Bars.

See also
CXTPPaintManager::SetTheme

Constructor & Destructor Documentation

◆ CXTPFrameThemeOffice2007System()

CXTPFrameThemeOffice2007System ( CXTPPaintManager * pPaintManager )

Construction / Destruction.

Constructs a CXTPFrameThemeOffice2007System object.

Parameters
pPaintManager Reference to a CXTPPaintManager object.

Member Function Documentation

◆ CalcFrameBorder()

virtual CRect CalcFrameBorder ( const CXTPCommandBarsFrameHook * pFrameHook ) const
virtual

Calculates the frame border sizes.

Parameters
pFrameHook CXTPCommandBarsFrameHook hook object.
Returns
Returns Calculated frame border sizes

Reimplemented from CXTPFramePaintManager.

◆ CalcFrameRegion()

virtual HRGN CalcFrameRegion | ( | CXTPCommandBarsFrameHook * | pFrameHook,
 |  | CSize | sz ) const
 virtual

This method is called to create the window region.

Parameters
pFrameHook | CXTPCommandBarsFrameHook hook object.
sz | Window size.
Returns
Region of the window to be set.

Implements CXTPFramePaintManager.

◆ DrawCaptionBar()

virtual void DrawCaptionBar | ( | CDC * | pDC,
 |  | CRect | rcCaptionBar,
 |  | CWnd * | pSite,
 |  | BOOL | bActive )
 virtual

This method is called to draw the frame caption bar.

Parameters
pDC | Pointer to device context.
rcCaptionBar | Caption bar rectangle.
pSite | Frame to draw.
bActive | TRUE if the frame is active.

Reimplemented from CXTPFramePaintManager.

◆ DrawFrameCaptionButton() [1/2]

void DrawFrameCaptionButton | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | int | nId,
 |  | BOOL | bSelected,
 |  | BOOL | bPressed,
 |  | BOOL | bActive )
 virtual

This method is called to draw caption button.

Parameters
pDC | Pointer to device context.
rc | Bounding rectangle of the button.
nId | Identifier of the button.
bSelected | TRUE if the button is highlighted.
bPressed | TRUE if the button is pressed.
bActive | TRUE if the frame is active.

Implements CXTPFramePaintManager.

◆ DrawFrameCaptionButton() [2/2]

virtual void DrawFrameCaptionButton | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | int | nId,
 |  | BOOL | bSelected,
 |  | BOOL | bPressed,
 |  | BOOL | bActive,
 |  | CXTPRibbonBar * | pRibbonBar )
 virtual

This method is called to draw caption button.

Parameters
pDC | Pointer to device context.
rc | Bounding rectangle of the button.
nId | Identifier of the button.
bSelected | TRUE if the button is highlighted.
bPressed | TRUE if the button is pressed.
bActive | TRUE if the frame is active.
pRibbonBar | Ribbon bar pointer.

Implements CXTPFramePaintManager.

◆ GetFrameBorder()

virtual CXTPMarkupThemePart * GetFrameBorder | ( | int | nId,
 |  | BOOL | bActive )
 virtual

This method is called to get the frame border part.

Parameters
nId | Identifier of the frame border; can be one of the values defined by the CXTPRibbonMarkupFrameTheme::XTPBorderPart enumeration.
bActive | TRUE if the frame border is active.
Returns
Gets the frame border part

Implements CXTPRibbonMarkupFrameTheme.

◆ LoadParts() [1/2]

virtual void LoadParts ( BOOL bReload = FALSE )
virtual

Loads markup parts.

Parameters
bReload Re-loads previously loaded parts if TRUE.

Implements CXTPRibbonMarkupFrameTheme.

◆ LoadParts() [2/2]

virtual void LoadParts | ( | HZIP | hZip,
 |  | CXTPMarkupContext * | pMarkupContext )
 virtual

Loads markup parts from the specified ZIP source.

Parameters
hZip | ZIP source to load markup parts from.
pMarkupContext | Associated markup context.

Implements CXTPRibbonMarkupFrameTheme.

The documentation for this class was generated from the following file:
  • XTPFrameThemeOffice2007System.h


Toolkit Pro: CXTPFrameWnd Class Reference

Public Member Functions | List of all members
CXTPFrameWnd Class Reference

CXTPFrameWnd is a CXTPFrameWndBase derived class. More...

Inheritance diagram for CXTPFrameWnd:
[legend]

Public Member Functions

DECLARE_DYNCREATE (CXTPFrameWnd) CXTPFrameWnd()
Constructs a CXTPFrameWnd object.
- Public Member Functions inherited from CXTPFrameWndBase< CFrameWnd >
CXTPFrameWndBase ()
Constructs a CXTPFrameWndBase object.
~CXTPFrameWndBase ()
Destroys a CXTPFrameWndBase object, handles cleanup and deallocation.
- Public Member Functions inherited from CXTPCommandBarsSiteBase< CFrameWnd >
CXTPCommandBarsSiteBase ()
Constructs a CXTPCommandBarsSiteBase object.
~CXTPCommandBarsSiteBase ()
Destroys a CXTPCommandBarsSiteBase object, handles cleanup and deallocation.
virtual BOOL | InitCommandBars (CRuntimeClass *pCommandBarsClass=RUNTIME_CLASS(CXTPCommandBars))
Creates command bars.
void | DockRightOf (CXTPToolBar *pBarToDock, CXTPToolBar *pBarOnLeft)
This member function will re-dock a toolbar specified by 'pBarToDock' to the right of a newly docked toolbar specified by 'pBarOnLeft'.
virtual void | SaveCommandBars (LPCTSTR lpszProfileName)
Call this function to save the state information to the registry or .INI file.
virtual void | LoadCommandBars (LPCTSTR lpszProfileName, BOOL bSilent=FALSE)
Call this function to retrieve state information from the registry or .INI file.
CXTPCommandBars * | GetCommandBars () const
Call this member to retrieve a pointer to the CommandBars object.

Detailed Description

CXTPFrameWnd is a CXTPFrameWndBase derived class.

The documentation for this class was generated from the following file:
  • XTPFrameWnd.h


Toolkit Pro: CXTPFrameWndBase< TBase > Class Template Reference

Public Member Functions | List of all members
CXTPFrameWndBase< TBase > Class Template Reference

CXTPFrameWndBase is a standalone class. More...

Inheritance diagram for CXTPFrameWndBase< TBase >:
[legend]

Public Member Functions

CXTPFrameWndBase ()
Constructs a CXTPFrameWndBase object.
~CXTPFrameWndBase ()
Destroys a CXTPFrameWndBase object, handles cleanup and deallocation.
- Public Member Functions inherited from CXTPCommandBarsSiteBase< TBase >
CXTPCommandBarsSiteBase ()
Constructs a CXTPCommandBarsSiteBase object.
~CXTPCommandBarsSiteBase ()
Destroys a CXTPCommandBarsSiteBase object, handles cleanup and deallocation.
virtual BOOL | InitCommandBars (CRuntimeClass *pCommandBarsClass=RUNTIME_CLASS(CXTPCommandBars))
Creates command bars.
void | DockRightOf (CXTPToolBar *pBarToDock, CXTPToolBar *pBarOnLeft)
This member function will re-dock a toolbar specified by 'pBarToDock' to the right of a newly docked toolbar specified by 'pBarOnLeft'.
virtual void | SaveCommandBars (LPCTSTR lpszProfileName)
Call this function to save the state information to the registry or .INI file.
virtual void | LoadCommandBars (LPCTSTR lpszProfileName, BOOL bSilent=FALSE)
Call this function to retrieve state information from the registry or .INI file.
CXTPCommandBars * | GetCommandBars () const
Call this member to retrieve a pointer to the CommandBars object.

Detailed Description

template<class TBase>
class CXTPFrameWndBase< TBase >

CXTPFrameWndBase is a standalone class.

It represents the parent class for the CXTPMDIFrameWnd and CXTPFrameWnd classes.

The documentation for this class was generated from the following file:
  • XTPFrameWnd.h


Toolkit Pro: CXTPGaugeBaseType Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPGaugeBaseType Class Referenceabstract

A base class for all gauge types. More...

Inheritance diagram for CXTPGaugeBaseType:
[legend]

Public Member Functions

~CXTPGaugeBaseType ()
Handles gauge type object destruction.
virtual LPCWSTR | GetTypeName () const =0
Obtains implementation specified type name.
BOOL | IsAutomaticUpdateEnabled () const
Gets automatic update flag value.
void | EnableAutomaticUpdate (BOOL bEnable=TRUE)
Sets automatic update flag value.
HRESULT | GetTrait (LPCTSTR pJPath, COleVariant &vtValue) const
Gets a trait value using the specified JPath expression.
HRESULT | SetTrait (LPCTSTR pJPath, const COleVariant &vtValue)
Sets a trait value using the specified JPath expression.
HRESULT | Update ()
Causes onUpdate JavaScript callback to be invoked to apply state and traits changes.
BOOL | DumpTraits (CString &strTraits) const
Obtains the current evaluated traits object in JSON format.
HRESULT | InvokeAction (LPCTSTR lpName, const COleVariant &vtArg=COleVariant(), COleVariant *pvtResult=NULL)
Invokes named gauge action.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

CXTPGaugeBaseType ()
Handles gauge type object construction.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

A base class for all gauge types.

Implements common gauge type specific actions.

See also
CXTPGaugeCtrl
CXTPGaugeTraits

Member Function Documentation

◆ DumpTraits()

BOOL DumpTraits ( CString & strTraits ) const

Obtains the current evaluated traits object in JSON format.

Parameters
strTraits String that receives JSON data
Returns
TRUE if succeeds and FALSE otherwise.

◆ EnableAutomaticUpdate()

AFX_INLINE void EnableAutomaticUpdate ( BOOL bEnable = TRUE )

Sets automatic update flag value.

If enabled, all gauge trait changes will immediately trigger the Update call to reflect the changes right away. By default automatic update is disabled as using it can result in performance loss when related traits change too frequently.

Parameters
bEnable TRUE to enable automatic update, FALSE to disable it.
See also
IsAutomaticUpdateEnabled

◆ GetTrait()

HRESULT GetTrait | ( | LPCTSTR | pJPath,
 |  | COleVariant & | vtValue ) const

Gets a trait value using the specified JPath expression.

Unlike CXTPGaugeTrait, these methods operate on the actual evaluated traits and can be called after a gauge type is load to modify its traits at run time.

A JavaScript path is an expression in JavaScript language that points to a nested object value. Root object values can be accessed by their names, nested object values require a period sign placed before the name, and array elements can be accessed by specifying a zero-base array element index in square brackets. For example, in order to access the bar value from the following object '{foo: [ {null}, {bar:"#"} ]}' the following JPath expression must be used: 'foo[1].bar'.

Parameters
pJPath | A JavaScript value path. See Remarks.
vtValue | Specifies or receives a trait value
Returns
S_OK if succeeds and an error code otherwise.

◆ GetTypeName()

virtual LPCWSTR GetTypeName ( ) const
pure virtual

Obtains implementation specified type name.

Returns
Type name string point.

Implemented in CXTPGaugeMeterType, and CXTPGaugeStateType.

◆ InvokeAction()

HRESULT InvokeAction | ( | LPCTSTR | lpName,
 |  | const COleVariant & | vtArg = COleVariant(),
 |  | COleVariant * | pvtResult = NULL )

Invokes named gauge action.

Parameters
lpName | Required action name.
vtArg | Optional action argument.
pvtResult | Optional pointer to a variable that receives result returned by the action function.
Returns
An error code or S_OK if no error occurs.

◆ IsAutomaticUpdateEnabled()

AFX_INLINE BOOL IsAutomaticUpdateEnabled ( ) const

Gets automatic update flag value.

If enabled, all gauge trait changes will immediately trigger the Update call to reflect the changes right away. By default automatic update is disabled as using it can result in performance loss when related traits change too frequently.

Returns
TRUE automatic update is enabled, otherwise FALSE.
See also
EnableAutomaticUpdate

◆ SetTrait()

HRESULT SetTrait | ( | LPCTSTR | pJPath,
 |  | const COleVariant & | vtValue )

Sets a trait value using the specified JPath expression.

Unlike CXTPGaugeTraits, these methods operate on the actual evaluated traits and can be called after a gauge type is load to modify its traits at run time.

A JavaScript path is an expression in JavaScript language that points to a nested object value. Root object values can be accessed by their names, nested object values require a period sign placed before the name, and array elements can be accessed by specifying a zero-base array element index in square brackets. For example, in order to access the bar value from the following object '{foo: [ {null}, {bar:"#"} ]}' the following JPath expression must be used: 'foo[1].bar'.

Parameters
pJPath | A JavaScript value path. See above remarks.
vtValue | Specifies or receives a trait value
Returns
S_OK if succeeds and an error code otherwise.

◆ Update()

HRESULT Update ( )

Causes onUpdate JavaScript callback to be invoked to apply state and traits changes.

Returns
S_OK if succeeds and an error code otherwise.
The documentation for this class was generated from the following file:
  • XTPGaugeBaseType.h


Toolkit Pro: CXTPGaugeCtrl Class Reference

Public Member Functions | List of all members
CXTPGaugeCtrl Class Reference

Gauge control hosts a JavaScript and Markup based gauge implementation of a certain type and provides a bidirectional data and event exchange between native and script implementation. More...

Public Member Functions

CXTPGaugeCtrl ()
Constructs gauge control object.
~CXTPGaugeCtrl ()
Handles gauge control object destruction.
BOOL | RegisterWindowClass (HINSTANCE hInstance=NULL)
Registers the window class if it has not already been registered.
virtual BOOL | Create (DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID, CCreateContext *pContext=NULL)
Creates a Gauge control window object.
virtual BOOL | CreateEx (DWORD dwExStyle, DWORD dwStyle, int x, int y, int nWidth, int nHeight, HWND hWndParent, HMENU nIDorHMenu, LPVOID lpParam=NULL)
Creates a Gauge control window object.
virtual BOOL | CreateEx (DWORD dwExStyle, DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID, LPVOID lpParam=NULL)
Creates a Gauge control window object.
IXTPGaugeClientSite * | GetCilentSite () const
Obtains an associated gauge client site interface.
void | SetCilentSite (IXTPGaugeClientSite *pSite)
Sets an associated gauge client site interface.
BOOL | IsLoaded () const
Determines if any gauge type is currently loaded.
CXTPGaugeBaseType * | Load (CRuntimeClass *pClass, IStream &source, const CXTPGaugeTraits &traits)
Loads a gauge using the specified gauge type from the data source provided using provided gauge traits.
CXTPGaugeBaseType * GetType ()
Obtains a generalized pointer of the currently loaded gauge type object.
const CXTPGaugeBaseType * | GetType () const
Obtains a generalized pointer of the currently loaded gauge type object.
BOOL | IsType (CRuntimeClass *pClass) const
Checks if the currently loaded gauge type is of the specified class.
CXTPGaugeMeterType * | LoadMeterType (IStream &source, const CXTPGaugeTraits &traits)
A helper method for loading CXTPGaugeMeterType gauge.
CXTPGaugeMeterType * GetMeterType ()
A helpers method for obtaining the currently loaded gauge type as CXTPGaugeMeterType.
const CXTPGaugeMeterType * | GetMeterType () const
A helpers method for obtaining the currently loaded gauge type as CXTPGaugeMeterType.
BOOL | IsMeterType () const
Determines if the currently loaded gauge type is CXTPGaugeMeterType.
CXTPGaugeStateType * | LoadStateType (IStream &source, const CXTPGaugeTraits &traits)
A helper method for loading CXTPGaugeStateType gauge.
CXTPGaugeStateType * GetStateType ()
A helpers method for obtaining the currently loaded gauge type as CXTPGaugeStateType.
const CXTPGaugeStateType * | GetStateType () const
A helpers method for obtaining the currently loaded gauge type as CXTPGaugeStateType.
BOOL | IsStateType () const
Determines if the currently loaded gauge type is CXTPGaugeStateType.
void | Unload ()
Unloads the currently loaded gauge type.

Detailed Description

Gauge control hosts a JavaScript and Markup based gauge implementation of a certain type and provides a bidirectional data and event exchange between native and script implementation.

A complete gauge consists of 4 major parts:

  • A gauge control: a window for Markup context
  • A gauge type object: defines a set of common type specific actions and properties
  • A gauge markup: defines a visual template of a gauge type and contains a type specific gauge execution script in JavaScript
  • A gauge traits object: a JavaScript object with a set of type and markup specific properties used by the Markup embedded script.

Main points to consider during custom gauge development are:

  • A gauge control is capable to load any gauge types
  • One gauge type object can work with any compatible gauge Markup ("type" value in the traits must match gauge type name)
  • One gauge Markup can accept any compatibe gauge traits object that will be used for gauge setup and customization according to the logic and rules defined in the Markup embedded script.
See also
CXTPGaugeTraits
CXTPGaugeBaseType

Member Function Documentation

◆ Create()

virtual BOOL Create | ( | DWORD | dwStyle,
 |  | const RECT & | rect,
 |  | CWnd * | pParentWnd,
 |  | UINT | nID,
 |  | CCreateContext * | pContext = NULL )
 virtual

Creates a Gauge control window object.

Parameters
dwStyle | Bitwise combination (OR) of window styles; otherwise NULL for the default window style.
rect | The size and location of the window relative to the screen or the parent window.
pParentWnd | For a child window, pointer to the parent window; otherwise, a pointer to the owner window if the window has an owner.
nID | For a child window, the window ID; otherwise, the ID of a menu for the window.
pContext | The create context of the window.
Returns
TRUE if the method was successful, otherwise FALSE.
See also
CreateEx(DWORD, DWORD, int, int, int, int, HWND, HMENU, LPVOID)
CreateEx(DWORD, DWORD, const RECT&, CWnd*, UINT, LPVOID)

◆ CreateEx() [1/2]

virtual BOOL CreateEx | ( | DWORD | dwExStyle,
 |  | DWORD | dwStyle,
 |  | const RECT & | rect,
 |  | CWnd * | pParentWnd,
 |  | UINT | nID,
 |  | LPVOID | lpParam = NULL )
 virtual

Creates a Gauge control window object.

Parameters
dwExStyle | Bitwise combination (OR) of extended window styles; otherwise NULL for the default extended window style.
dwStyle | Bitwise combination (OR) of window styles; otherwise NULL for the default window style.
lpParam | Pointer to user data that is passed to the CWnd::OnCreate method in the lpCreateParams field.
rect | The size and location of the window relative to the screen or the parent window.
pParentWnd | For a child window, pointer to the parent window; otherwise, a pointer to the owner window if the window has an owner.
nID | For a child window, the window ID; otherwise, the ID of a menu for the window.
Returns
TRUE if the method was successful, otherwise FALSE.
See also
Create(DWORD, const RECT&, CWnd*, UINT, CCreateContext*)
CreateEx(DWORD, DWORD, int, int, int, int, HWND, HMENU, LPVOID)

◆ CreateEx() [2/2]

virtual BOOL CreateEx | ( | DWORD | dwExStyle,
 |  | DWORD | dwStyle,
 |  | int | x,
 |  | int | y,
 |  | int | nWidth,
 |  | int | nHeight,
 |  | HWND | hWndParent,
 |  | HMENU | nIDorHMenu,
 |  | LPVOID | lpParam = NULL )
 virtual

Creates a Gauge control window object.

Parameters
dwExStyle | Bitwise combination (OR) of extended window styles; otherwise NULL for the default extended window style.
dwStyle | Bitwise combination (OR) of window styles; otherwise NULL for the default window style.
x | The initial horizontal distance of the window from the left side of the screen or the parent window.
y | The initial vertical distance of the window from the top of the screen or the parent window.
nWidth | The width, in pixels, of the window.
nHeight | The height, in pixels, of the window.
hWndParent | For a child window, the handle to the parent window; otherwise, the handle of the owner window if the window has an owner.
nIDorHMenu | For a child window, the window ID; otherwise, the ID of a menu for the window.
lpParam | Pointer to user data that is passed to the CWnd::OnCreate method in the lpCreateParams field.
Returns
TRUE if the method was successful, otherwise FALSE.
See also
Create(DWORD, const RECT&, CWnd*, UINT, CCreateContext*)
CreateEx(DWORD, DWORD, const RECT&, CWnd*, UINT, LPVOID)

◆ GetCilentSite()

AFX_INLINE IXTPGaugeClientSite * GetCilentSite ( ) const

Obtains an associated gauge client site interface.

Returns
The value of the associated client site interface.

◆ GetMeterType() [1/2]

CXTPGaugeMeterType * GetMeterType ( )

A helpers method for obtaining the currently loaded gauge type as CXTPGaugeMeterType.

Returns
Gauge type pointer or NULL if no gauge type is loaded or the loaded gauge has a different type.

◆ GetMeterType() [2/2]

AFX_INLINE const CXTPGaugeMeterType * GetMeterType ( ) const

A helpers method for obtaining the currently loaded gauge type as CXTPGaugeMeterType.

Returns
A const Gauge type pointer or NULL if no gauge type is loaded or the loaded gauge has a different type.

◆ GetStateType() [1/2]

CXTPGaugeStateType * GetStateType ( )

A helpers method for obtaining the currently loaded gauge type as CXTPGaugeStateType.

Returns
Gauge type pointer or NULL if no gauge type is loaded or the loaded gauge has a different type.

◆ GetStateType() [2/2]

AFX_INLINE const CXTPGaugeStateType * GetStateType ( ) const

A helpers method for obtaining the currently loaded gauge type as CXTPGaugeStateType.

Returns
Const Gauge type pointer or NULL if no gauge type is loaded or the loaded gauge has a different type.

◆ GetType() [1/2]

AFX_INLINE CXTPGaugeBaseType * GetType ( )

Obtains a generalized pointer of the currently loaded gauge type object.

Returns
Gauge type object pointer or NULL is no gauge type is loaded.

◆ GetType() [2/2]

AFX_INLINE const CXTPGaugeBaseType * GetType ( ) const

Obtains a generalized pointer of the currently loaded gauge type object.

Returns
A const Gauge type object pointer or NULL is no gauge type is loaded.

◆ IsLoaded()

AFX_INLINE BOOL IsLoaded ( ) const

Determines if any gauge type is currently loaded.

Returns
TRUE if loaded and FALSE otherwise.

◆ IsMeterType()

AFX_INLINE BOOL IsMeterType ( ) const

Determines if the currently loaded gauge type is CXTPGaugeMeterType.

Returns
TRUE if the currently loaded gauge type is CXTPGaugeMeterType, FALSE otherwise of if no gauge type is loaded.

◆ IsStateType()

AFX_INLINE BOOL IsStateType ( ) const

Determines if the currently loaded gauge type is CXTPGaugeStateType.

Returns
TRUE if the currently loaded gauge type is CXTPGaugeStateType, FALSE otherwise of if no gauge type is loaded.

◆ IsType()

BOOL IsType ( CRuntimeClass * pClass ) const

Checks if the currently loaded gauge type is of the specified class.

Parameters
pClass A gauge type class pointer
Returns
TRUE if the currently loaded gauge is of the the type specified, FALSE otherwise or if no gauge type is loaded.

◆ Load()

CXTPGaugeBaseType * Load | ( | CRuntimeClass * | pClass,
 |  | IStream & | source,
 |  | const CXTPGaugeTraits & | traits )

Loads a gauge using the specified gauge type from the data source provided using provided gauge traits.

Parameters
pClass | A gauge type class pointer. The type class must be derived from CXTPGaugeBaseType
source | A gauge Markup data stream object
traits | A gauge traits object
Returns
A generalized pointer to the loaded gauge type object or NULL if loading has failed.

◆ LoadMeterType()

CXTPGaugeMeterType * LoadMeterType | ( | IStream & | source,
 |  | const CXTPGaugeTraits & | traits )

A helper method for loading CXTPGaugeMeterType gauge.

Parameters
source | A gauge Markup data stream object
traits | A gauge traits object
Returns
A generalized pointer to the loaded gauge type object or NULL if loading has failed.

◆ LoadStateType()

CXTPGaugeStateType * LoadStateType | ( | IStream & | source,
 |  | const CXTPGaugeTraits & | traits )

A helper method for loading CXTPGaugeStateType gauge.

Parameters
source | A gauge Markup data stream object
traits | A gauge traits object
Returns
A generalized pointer to the loaded gauge type object or NULL if loading has failed.

◆ RegisterWindowClass()

BOOL RegisterWindowClass ( HINSTANCE hInstance = NULL )

Registers the window class if it has not already been registered.

Parameters
hInstance Instance of the resource where the control is located.
Returns
TRUE if the window class was successfully registered, otherwise FALSE.

◆ SetCilentSite()

AFX_INLINE void SetCilentSite ( IXTPGaugeClientSite * pSite )

Sets an associated gauge client site interface.

Parameters
pSite The new value of the associated client site interface.
The documentation for this class was generated from the following file:
  • XTPGaugeCtrl.h


Toolkit Pro: CXTPGaugeMeterType Class Reference

Public Member Functions | List of all members
CXTPGaugeMeterType Class Reference

Implements a Meter gauge type. More...

Inheritance diagram for CXTPGaugeMeterType:
[legend]

Public Member Functions

~CXTPGaugeMeterType ()
Handles meter gauge type destruction.
virtual LPCWSTR | GetTypeName () const
Obtains implementation specified type name.
double | GetMin () const
Gets the minimum acceptable value in the value range.
double | GetMin (UINT nDimension) const
Gets the minimum acceptable value in the value range.
BOOL | SetMin (double dValue)
Sets the minimum acceptable value in the value range.
BOOL | SetMin (UINT nDimension, double dValue)
Sets the minimum acceptable value in the value range.
BOOL | UnsetMin (UINT nDimension)
Clears the minimum acceptable value in the value range.
double | GetMax () const
Gets the maximum acceptable value in the value range.
double | GetMax (UINT nDimension) const
Gets the maximum acceptable value in the value range.
BOOL | SetMax (double dValue)
Sets the maximum acceptable value in the value range.
BOOL | SetMax (UINT nDimension, double dValue)
Sets the maximum acceptable value in the value range.
BOOL | UnsetMax (UINT nDimension)
Clears the maximum acceptable value in the value range.
double | GetCurrent () const
Gets the currently reflected value.
double | GetCurrent (UINT nDimension) const
Gets the currently reflected value.
BOOL | SetCurrent (double dValue)
Sets/clears the currently reflected value.
BOOL | SetCurrent (UINT nDimension, double dValue)
Sets/clears the currently reflected value.
BOOL | UnsetCurrent (UINT nDimension)
Clears the currently reflected value.
UINT | GetDimensionCount () const
Obtains the number of available dimensions.
- Public Member Functions inherited from CXTPGaugeBaseType
~CXTPGaugeBaseType ()
Handles gauge type object destruction.
BOOL | IsAutomaticUpdateEnabled () const
Gets automatic update flag value.
void | EnableAutomaticUpdate (BOOL bEnable=TRUE)
Sets automatic update flag value.
HRESULT | GetTrait (LPCTSTR pJPath, COleVariant &vtValue) const
Gets a trait value using the specified JPath expression.
HRESULT | SetTrait (LPCTSTR pJPath, const COleVariant &vtValue)
Sets a trait value using the specified JPath expression.
HRESULT | Update ()
Causes onUpdate JavaScript callback to be invoked to apply state and traits changes.
BOOL | DumpTraits (CString &strTraits) const
Obtains the current evaluated traits object in JSON format.
HRESULT | InvokeAction (LPCTSTR lpName, const COleVariant &vtArg=COleVariant(), COleVariant *pvtResult=NULL)
Invokes named gauge action.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Member Functions inherited from CXTPGaugeBaseType
CXTPGaugeBaseType ()
Handles gauge type object construction.

Detailed Description

Implements a Meter gauge type.

This kind of gauges is supposed to reflect a potentially unlimited number of numeric values in the specified value range. A clock or a numeric display are simple examples of the meter gauges. Gauges of this type must have an initial value set to a valid value within the given range. The currently reflected value can be updated from both a user code and by the gauge itself in reaction to a certain user input or time events.

See also
CXTPGaugeBaseType
CXTPGaugeStateType
CXTPGaugeCtrl

Member Function Documentation

◆ GetCurrent() [1/2]

AFX_INLINE double GetCurrent ( ) const

Gets the currently reflected value.

Returns
The currently reflected value in the value range. If a dimension specific value is unset then the respective global value is used for that dimension. This allows having all or selected dimensions to reflect a single global value in different ways. The global value cannot be unset.
See also
SetCurrent
UnsetCurrent

◆ GetCurrent() [2/2]

double GetCurrent ( UINT nDimension ) const

Gets the currently reflected value.

Parameters
nDimension Dimension index to get the value for. UINT_MAX is assumed by default and can be used to access global value.
Returns
The currently reflected value in the value range. If a dimension specific value is unset then the respective global value is used for that dimension. This allows having all or selected dimensions to reflect a single global value in different ways. The global value cannot be unset.
See also
SetCurrent
UnsetCurrent

◆ GetDimensionCount()

UINT GetDimensionCount ( ) const

Obtains the number of available dimensions.

Returns
The number of available dimensions.

◆ GetMax() [1/2]

AFX_INLINE double GetMax ( ) const

Gets the maximum acceptable value in the value range.

Returns
The current maximum value in the value range. If a dimension specific value is unset then the respective global value is used for that dimension. This allows having all or selected dimensions to reflect a single global value in different ways. The global value cannot be unset.
See also
SetMax
UnsetMax

◆ GetMax() [2/2]

double GetMax ( UINT nDimension ) const

Gets the maximum acceptable value in the value range.

Parameters
nDimension Dimension index to get the value for. UINT_MAX is assumed by default and can be used to access global value.
Returns
The current maximum value in the value range. If a dimension specific value is unset then the respective global value is used for that dimension. This allows having all or selected dimensions to reflect a single global value in different ways. The global value cannot be unset.
See also
SetMax
UnsetMax

◆ GetMin() [1/2]

AFX_INLINE double GetMin ( ) const

Gets the minimum acceptable value in the value range.

Returns
The current minimum value in the value range. If a dimension specific value is unset then the respective global value is used for that dimension. This allows having all or selected dimensions to reflect a single global value in different ways. The global value cannot be unset.
See also
SetMin
UnsetMin

◆ GetMin() [2/2]

double GetMin ( UINT nDimension ) const

Gets the minimum acceptable value in the value range.

Parameters
nDimension Dimension index to get the value for. UINT_MAX is assumed by default and can be used to access global value.
Returns
The current minimum value in the value range. If a dimension specific value is unset then the respective global value is used for that dimension. This allows having all or selected dimensions to reflect a single global value in different ways. The global value cannot be unset.
See also
SetMin
UnsetMin

◆ GetTypeName()

virtual LPCWSTR GetTypeName ( ) const
virtual

Obtains implementation specified type name.

Returns
Type name string point.

Implements CXTPGaugeBaseType.

◆ SetCurrent() [1/2]

AFX_INLINE BOOL SetCurrent ( double dValue )

Sets/clears the currently reflected value.

Parameters
dValue New currently reflected value in the value range. If the value provided does not fit the current value range then it will be automatically adjusted to the closest acceptable value.
Returns
The currently reflected value in the value range. If a dimension specific value is unset then the respective global value is used for that dimension. This allows having all or selected dimensions to reflect a single global value in different ways. The global value cannot be unset. Returns TRUE if the new value is different from the old one, thus the actual value change happened.
See also
GetCurrent
UnsetCurrent

◆ SetCurrent() [2/2]

BOOL SetCurrent | ( | UINT | nDimension,
 |  | double | dValue )

Sets/clears the currently reflected value.

Parameters
dValue | New currently reflected value in the value range. If the value provided does not fit the current value range then it will be automatically adjusted to the closest acceptable value.
nDimension | Dimension index to set the value for. UINT_MAX is assumed by default and can be used to access global value.
Returns
The currently reflected value in the value range. If a dimension specific value is unset then the respective global value is used for that dimension. This allows having all or selected dimensions to reflect a single global value in different ways. The global value cannot be unset. Returns TRUE if the new value is different from the old one, thus the actual value change happened.
See also
GetCurrent
UnsetCurrent

◆ SetMax() [1/2]

AFX_INLINE BOOL SetMax ( double dValue )

Sets the maximum acceptable value in the value range.

Parameters
dValue New maximum value in the value range.
Returns
The current maximum value in the value range. If a dimension specific value is unset then the respective global value is used for that dimension. This allows having all or selected dimensions to reflect a single global value in different ways. The global value cannot be unset. Return TRUE if the new value is different from the old one, thus the actual value change happened.
See also
GetMax
UnsetMax

◆ SetMax() [2/2]

BOOL SetMax | ( | UINT | nDimension,
 |  | double | dValue )

Sets the maximum acceptable value in the value range.

Parameters
dValue | New maximum value in the value range.
nDimension | Dimension index to set the value for. UINT_MAX is assumed by default and can be used to access global value.
Returns
The current maximum value in the value range. If a dimension specific value is unset then the respective global value is used for that dimension. This allows having all or selected dimensions to reflect a single global value in different ways. The global value cannot be unset. Return TRUE if the new value is different from the old one, thus the actual value change happened.
See also
GetMax
UnsetMax

◆ SetMin() [1/2]

AFX_INLINE BOOL SetMin ( double dValue )

Sets the minimum acceptable value in the value range.

Parameters
dValue New minimum value in the value range.
Returns
The current minimum value in the value range. If a dimension specific value is unset then the respective global value is used for that dimension. This allows having all or selected dimensions to reflect a single global value in different ways. The global value cannot be unset. Returns TRUE if the new value is different from the old one, thus the actual value change happened.
See also
GetMin
UnsetMin

◆ SetMin() [2/2]

BOOL SetMin | ( | UINT | nDimension,
 |  | double | dValue )

Sets the minimum acceptable value in the value range.

Parameters
dValue | New minimum value in the value range.
nDimension | Dimension index to set the value for. UINT_MAX is assumed by default and can be used to access global value.
Returns
The current minimum value in the value range. If a dimension specific value is unset then the respective global value is used for that dimension. This allows having all or selected dimensions to reflect a single global value in different ways. The global value cannot be unset. Returns TRUE if the new value is different from the old one, thus the actual value change happened.
See also
GetMin
UnsetMin

◆ UnsetCurrent()

AFX_INLINE BOOL UnsetCurrent ( UINT nDimension )

Clears the currently reflected value.

Parameters
nDimension Dimension index to set the value for. UINT_MAX is assumed by default and can be used to access global value.
Returns
The currently reflected value in the value range. If a dimension specific value is unset then the respective global value is used for that dimension. This allows having all or selected dimensions to reflect a single global value in different ways. The global value cannot be unset. Returns TRUE if the new value is different from the old one, thus the actual value change happened.
See also
GetCurrent
SetCurrent

◆ UnsetMax()

AFX_INLINE BOOL UnsetMax ( UINT nDimension )

Clears the maximum acceptable value in the value range.

Parameters
nDimension Dimension index to set the value for. UINT_MAX is assumed by default and can be used to access global value.
Returns
The current maximum value in the value range. If a dimension specific value is unset then the respective global value is used for that dimension. This allows having all or selected dimensions to reflect a single global value in different ways. The global value cannot be unset. Return TRUE if the new value is different from the old one, thus the actual value change happened.
See also
GetMax
SetMax

◆ UnsetMin()

AFX_INLINE BOOL UnsetMin ( UINT nDimension )

Clears the minimum acceptable value in the value range.

Parameters
nDimension Dimension index to set the value for. UINT_MAX is assumed by default and can be used to access global value.
Returns
The current minimum value in the value range. If a dimension specific value is unset then the respective global value is used for that dimension. This allows having all or selected dimensions to reflect a single global value in different ways. The global value cannot be unset. Returns TRUE if the new value is different from the old one, thus the actual value change happened.
See also
GetMin
SetMin
The documentation for this class was generated from the following file:
  • XTPGaugeMeterType.h


Toolkit Pro: CXTPGaugeStateType Class Reference

Public Member Functions | List of all members
CXTPGaugeStateType Class Reference

Implements a State gauge type. More...

Inheritance diagram for CXTPGaugeStateType:
[legend]

Public Member Functions

~CXTPGaugeStateType ()
Handles gauge type object destruction.
virtual LPCWSTR | GetTypeName () const
Obtains implementation specified type name.
UINT | GetState () const
Gets the current state value.
BOOL | SetState (UINT nState)
Sets the current state value.
UINT | GetStateCount () const
Obtains the supported number of states that is the number of elements of the 'states' array specified in traits.
- Public Member Functions inherited from CXTPGaugeBaseType
~CXTPGaugeBaseType ()
Handles gauge type object destruction.
BOOL | IsAutomaticUpdateEnabled () const
Gets automatic update flag value.
void | EnableAutomaticUpdate (BOOL bEnable=TRUE)
Sets automatic update flag value.
HRESULT | GetTrait (LPCTSTR pJPath, COleVariant &vtValue) const
Gets a trait value using the specified JPath expression.
HRESULT | SetTrait (LPCTSTR pJPath, const COleVariant &vtValue)
Sets a trait value using the specified JPath expression.
HRESULT | Update ()
Causes onUpdate JavaScript callback to be invoked to apply state and traits changes.
BOOL | DumpTraits (CString &strTraits) const
Obtains the current evaluated traits object in JSON format.
HRESULT | InvokeAction (LPCTSTR lpName, const COleVariant &vtArg=COleVariant(), COleVariant *pvtResult=NULL)
Invokes named gauge action.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Member Functions inherited from CXTPGaugeBaseType
CXTPGaugeBaseType ()
Handles gauge type object construction.

Detailed Description

Implements a State gauge type.

This kind of gauges is supposed to reflect a limited and strictly defined set of states. A simple example of it can be an ON/OFF light or a power switch. Gauges of this type must have an initial state value set to a valid value. State can be updated from both a user code and by the gauge itself in reaction to a certain user input or time events.

See also
CXTPGaugeBaseType
CXTPGaugeMeterType
CXTPGaugeCtrl

Member Function Documentation

◆ GetState()

UINT GetState ( ) const

Gets the current state value.

The meaning and the limits of state value are defined by the actual State gauge JavaScript implementation. It's the caller's responsibility to ensure that a new state value passed can be accepted and handled by the currently loaded gauge.

Returns
The current state value.

◆ GetStateCount()

UINT GetStateCount ( ) const

Obtains the supported number of states that is the number of elements of the 'states' array specified in traits.

Returns
The supported number of states.

◆ GetTypeName()

virtual LPCWSTR GetTypeName ( ) const
virtual

Obtains implementation specified type name.

Returns
Type name string point.

Implements CXTPGaugeBaseType.

◆ SetState()

BOOL SetState ( UINT nState )

Sets the current state value.

The meaning and the limits of state value are defined by the actual State gauge JavaScript implementation. It's the caller's responsibility to ensure that a new state value passed can be accepted and handled by the currently loaded gauge.

Parameters
nState A new state value to be set.
Returns
TRUE if the new state value is different from the previous one and the actual state change is taking place.
The documentation for this class was generated from the following file:
  • XTPGaugeStateType.h


Toolkit Pro: CXTPGaugeTraits Class Reference

Public Member Functions | List of all members
CXTPGaugeTraits Class Reference

Defines a set of loaded gauge traits. More...

Public Member Functions

CXTPGaugeTraits ()
Initializes an empty set of gauge traits.
CXTPGaugeTraits (IStream &stream, CString strTraitsArg=CString())
Loads a set of gauge traits from the specified source.
CXTPGaugeTraits (CString strTraits, CString strTraitsArg=CString())
Loads a set of gauge traits from the specified source.
~CXTPGaugeTraits ()
Handles traits set destruction.
const CString & | GetTraits () const
Gets gauge traits data.
void | SetTraits (CString strTraits)
Sets gauge traits data.
const CString & | GetTraitsArgument () const
Gets gauge traits data argument.
void | SetTraitsArgument (CString strTraitsArg)
Sets gauge traits data argument.
COleVariant * | GetCustomTrait (CString strJsonPath) const
Gets a custom value of a gauge trait.
void | SetCustomTrait (CString strJsonPath, COleVariant vtValue)
Sets a custom value of a gauge trait.
POSITION | EnumCustomTraits () const
Start custom traits enumeration.
BOOL | GetNextCustomTrait (POSITION &pos, CString &strJsonPath, COleVariant *&pValue) const
Enumerates specified custom trait paths and values.
const CString & | GetResourcePath () const
Gets the resource path to be used by the gauge implementation to load images and other assets from.
void | SetResourcePath (CString strPath)
Sets the resource path to be used by the gauge implementation to load images and other assets from.
HMODULE | GetResourceModule () const
Gets resource module handle to be used by the gauge implementation to load images and other assets from.
const CString & | GetResourceNamespace () const
Gets resource module handle to be used by the gauge implementation to load images and other assets from.
BOOL | SetResourceModule (HMODULE hResMod, LPCTSTR pNamespace=NULL)
Sets resource module handle to be used by the gauge implementation to load images and other assets from.

Detailed Description

Defines a set of loaded gauge traits.

Constructor & Destructor Documentation

◆ CXTPGaugeTraits() [1/2]

CXTPGaugeTraits | ( | IStream & | stream,
 |  | CString | strTraitsArg = CString() )

Loads a set of gauge traits from the specified source.

Gauge traits data is either a JSON content or a JavaScript code of form (function(args) { ... })(args). JSON traits get evaluated into a JavaScript object as is. If a JavaScript function is provided then it gets executed with one argument that is an evaluated JavaScript object from strTraitsArg JSON data, then the function must return a JavaScript object that containts the evaluated traits data.

Parameters
stream | A stream object to read traits data from.
strTraitsArg | Optional JSON traits to be passed to traits evaluation call if needed.

◆ CXTPGaugeTraits() [2/2]

AFX_INLINE CXTPGaugeTraits | ( | CString | strTraits,
 |  | CString | strTraitsArg = CString() )

Loads a set of gauge traits from the specified source.

Gauge traits data is either a JSON content or a JavaScript code of form (function(args) { ... })(args). JSON traits get evaluated into a JavaScript object as is. If a JavaScript function is provided then it gets executed with one argument that is an evaluated JavaScript object from strTraitsArg JSON data, then the function must return a JavaScript object that containts the evaluated traits data.

Parameters
strTraits | Traits data to load.
strTraitsArg | Optional JSON traits to be passed to traits evaluation call if needed.

Member Function Documentation

◆ EnumCustomTraits()

AFX_INLINE POSITION EnumCustomTraits ( ) const

Start custom traits enumeration.

Returns
The first custom trait position.
See also
GetNextCustomTrait
GetCustomTrait
SetCustomTrait

◆ GetCustomTrait()

COleVariant * GetCustomTrait ( CString strJsonPath ) const

Gets a custom value of a gauge trait.

Custom traits get evaluated only once upon gauge loading and provide a mechanism of customizing existing gauge traits without need to re-create the entire traits JSON file. So GetCustomTrait and SetCustomTrait do not access the actual traits JSON data. Instead they operate on a separate list of custom traits to be applied upon gauge loading. By default this list is empty. It is possible to get a custom trait value only if it has been previously set. JSON path syntax is as simple as JavaScript object access, for example this path:

state[1].image.src

points to this JSON element in a JSON traits object:

{
  states: [
    { ... },
    {
       image: {
         src: '[path_to_svg_file]'
       }
    }
  ]
}
Parameters
strJsonPath JSON path of an existing value to be accessed.
Returns
Current custom trait value pointer or NULL if no value is associated with the given path.
See also
SetCustomTrait

◆ GetNextCustomTrait()

BOOL GetNextCustomTrait | ( | POSITION & | pos,
 |  | CString & | strJsonPath,
 |  | COleVariant *& | pValue ) const

Enumerates specified custom trait paths and values.

Parameters
pos | On input it contains position of the current custom trait, on output it is updated with the next custom trait position value, NULL indicates end of enumeration
strJsonPath | Upon successful completion contains a JSON path value of a custom trait to be customized
pValue | Upon successful completion contains a pointer to the custom trait value
Returns
TRUE if enumeration can continue, FALSE if enumeration is completed.
See also
EnumCustomTraits
GetCustomTrait
SetCustomTrait

◆ GetResourceModule()

AFX_INLINE HMODULE GetResourceModule ( ) const

Gets resource module handle to be used by the gauge implementation to load images and other assets from.

Setting a new value will also invalidate the traits argument value.

Returns
Current resource handle module.
See also
GetResourceNamespace
SetResourceModule
GetResourcePath
SetResourcePath

◆ GetResourceNamespace()

AFX_INLINE const CString & GetResourceNamespace ( ) const

Gets resource module handle to be used by the gauge implementation to load images and other assets from.

Setting a new value will also invalidate the traits argument value.

Returns
Current resource handle module.
See also
GetResourceModule
SetResourceModule
GetResourcePath
SetResourcePath

◆ GetResourcePath()

AFX_INLINE const CString & GetResourcePath ( ) const

Gets the resource path to be used by the gauge implementation to load images and other assets from.

Setting a new value will also invalidate the traits argument value.

Returns
Current resource path value.
See also
GetResourceModule
SetResourceModule

◆ GetTraits()

AFX_INLINE const CString & GetTraits ( ) const

Gets gauge traits data.

Gauge traits data is either a JSON content or a JavaScript code of form (function(args) { ... })(args). JSON traits get evaluated into a JavaScript object as is. If a JavaScript function is provided then it gets executed with one argument that is an evaluated JavaScript object from strTraitsArg JSON data, then the function must return a JavaScript object that containts the evaluated traits data.

Returns
Current traits data.
See also
SetTraits

◆ GetTraitsArgument()

AFX_INLINE const CString & GetTraitsArgument ( ) const

Gets gauge traits data argument.

Gauge traits data is either a JSON content or a JavaScript code of form (function(args) { ... })(args). JSON traits get evaluated into a JavaScript object as is. If a JavaScript function is provided then it gets executed with one argument that is an evaluated JavaScript object from strTraitsArg JSON data, then the function must return a JavaScript object that containts the evaluated traits data.

Returns
Current traits data argument.
See also
SetTraitsArgument

◆ SetCustomTrait()

void SetCustomTrait | ( | CString | strJsonPath,
 |  | COleVariant | vtValue )

Sets a custom value of a gauge trait.

Custom traits get evaluated only once upon gauge loading and provide a mechanism of customizing existing gauge traits without need to re-create the entire traits JSON file. So GetCustomTrait and SetCustomTrait do not access the actual traits JSON data. Instead they operate on a separate list of custom traits to be applied upon gauge loading. By default this list is empty. It is possible to get a custom trait value only if it has been previously set. JSON path syntax is as simple as JavaScript object access, for example this path:

state[1].image.src

points to this JSON element in a JSON traits object:

{
  states: [
    { ... },
    {
       image: {
         src: '[path_to_svg_file]'
       }
    }
  ]
}
Parameters
strJsonPath | JSON path of an existing value to be accessed.
vtValue | A new value of an JSON element defined by the JSON path provided.
See also
GetCustomTrait

◆ SetResourceModule()

BOOL SetResourceModule | ( | HMODULE | hResMod,
 |  | LPCTSTR | pNamespace = NULL )

Sets resource module handle to be used by the gauge implementation to load images and other assets from.

Setting a new value will also invalidate the traits argument value.

Parameters
hResMod | Resource module handle. NULL handle value will make traits argument an empty string.
pNamespace | An optional string to be added as a resource name prefix for all requested gauge resources. The string must contain only alpha-numeric a hyphen and a underscore symbols.
See also
GetResourceModule
GetResourceNamespace
GetResourcePath
SetResourcePath

◆ SetResourcePath()

void SetResourcePath ( CString strPath )

Sets the resource path to be used by the gauge implementation to load images and other assets from.

Setting a new value will also invalidate the traits argument value.

Parameters
strPath Path value. Empty path value will make traits argument an empty string.
See also
GetResourceModule
SetResourceModule

◆ SetTraits()

AFX_INLINE void SetTraits ( CString strTraits )

Sets gauge traits data.

Gauge traits data is either a JSON content or a JavaScript code of form (function(args) { ... })(args). JSON traits get evaluated into a JavaScript object as is. If a JavaScript function is provided then it gets executed with one argument that is an evaluated JavaScript object from strTraitsArg JSON data, then the function must return a JavaScript object that containts the evaluated traits data.

Parameters
strTraits Traits data to load.
See also
GetTraits

◆ SetTraitsArgument()

AFX_INLINE void SetTraitsArgument ( CString strTraitsArg )

Sets gauge traits data argument.

Gauge traits data is either a JSON content or a JavaScript code of form (function(args) { ... })(args). JSON traits get evaluated into a JavaScript object as is. If a JavaScript function is provided then it gets executed with one argument that is an evaluated JavaScript object from strTraitsArg JSON data, then the function must return a JavaScript object that containts the evaluated traits data.

Parameters
strTraitsArg Traits data to load.
See also
GetTraitsArgument
The documentation for this class was generated from the following file:
  • XTPGaugeTraits.h


Toolkit Pro: CXTPGdiObject Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPGdiObject Class Referenceabstract

Implements common functionality for all XTP GDI object. More...

Inheritance diagram for CXTPGdiObject:
[legend]

Public Member Functions

virtual | ~CXTPGdiObject ()=0
Handles CXTPGdiObject destruction.
operator HGDIOBJ () const
Casts an object to an encapsulated GDI handle.
HGDIOBJ | GetSafeHandle () const
Returns m_hObject unless this is NULL, in which case NULL is returned.
BOOL | DeleteObject ()
Decrements reference counter for a cached GDI object or delete the cached GDI object once the reference counter is equal to zero.
int | GetObject (int nCount, LPVOID lpObject) const
Fills a buffer with data that defines a specified object.
UINT | GetObjectType () const
Retrieves the type of the GDI object.
BOOL | CreateStockObject (int nIndex)
Retrieves a handle to one of the predefined stock Windows GDI pens, brushes, or fonts, and attaches the GDI object to the CGdiObject object.
BOOL | operator== (const CXTPGdiObject &obj) const
Determines if two GDI objects are logically equal.
BOOL | operator!= (const CXTPGdiObject &obj) const
Determines if two GDI objects are logically not equal.
operator CGdiObject & ()
Converts an object to CGdiObject reference making it possible to use CXTPGdiObject with MFC classes and methods that use CGdiObject reference as an argument.
operator const CGdiObject & () const
Converts an object to CGdiObject constance reference making it possible to use CXTPGdiObject with MFC classes and methods that use CGdiObject reference as an argument.
__declspec (property(get=GetSafeHandle)) HGDIOBJ m_hObject
A read-only encapsulated GDI handle value.
void | SetHandleOwnershipNotGuaranteed ()
Sets handle ownership guaranteed status.
BOOL | IsHandleOwnershipGuaranteed () const
Determines handle ownership guaranteed status.

Protected Member Functions

CXTPGdiObject ()
Performs internal CXTPGdiObject construction logic.

Detailed Description

Implements common functionality for all XTP GDI object.

Mimics CGdiObject's interface from MFC however cannot be cast to CGdiObject type.

XTP GDI objects use cached GDI handles so one native GDI handle can be shared across several XTP GDI object instances. The lifetime of a handle is controlled by XTP GDI reference counter, meaning a handle is deleted only when the last XTP GDI object that references a particular handle is destroyed or DeleteObject is called. Note, because an encapsulated GDI handle is cached and shared, passing m_hObject to DeleteObject from Windows SDK or convering an XTP GDI object to CGdiObject& and making a call to CGdiObject::DeleteObject will delete a cached handle and leave all XTP GDI object that reference the delete handle in an undetermined state. This will also affect every place in a program where the cached handles are used. So use the encapsulated GDI handle or CGdiObject very carefully and for read-only purposes.

See also
CXTPFont, CXTPBrush, CXTPPen

Constructor & Destructor Documentation

◆ ~CXTPGdiObject()

virtual ~CXTPGdiObject ( )
pure virtual

Handles CXTPGdiObject destruction.

Makes a call to DeleteObject if it has not been done prior to object destruction.

Member Function Documentation

◆ __declspec()

__declspec ( property(get=GetSafeHandle) )

A read-only encapsulated GDI handle value.

The returned handle must not be passed to DeleteObject and should be used for read-only purposes, i.e. GDI object state should not be modified as it will affect every place in a program where the cached handle is used.

Returns
Encapsulated GDI handle or NULL.

◆ CreateStockObject()

BOOL CreateStockObject ( int nIndex )

Retrieves a handle to one of the predefined stock Windows GDI pens, brushes, or fonts, and attaches the GDI object to the CGdiObject object.

Parameters
nIndex A constant specifying the type of stock object desired. Refer to the Platform SDK documentation for the list of possible values.
Returns
Nonzero if the function is successful; otherwise 0.

Stock objects don't get cached and its handle becomes associated with one and only one instance of CXTPGdiObject or its derived class.

◆ DeleteObject()

BOOL DeleteObject ( )

Decrements reference counter for a cached GDI object or delete the cached GDI object once the reference counter is equal to zero.

Returns
TRUE if the reference counter is decremented without deleting a cached GDI object or the GDI object is deleted successfully.

◆ GetObject()

int GetObject | ( | int | nCount,
 |  | LPVOID | lpObject ) const

Fills a buffer with data that defines a specified object.

Parameters
nCount | Specifies the number of bytes to copy into the lpObject buffer.
lpObject | Points to a user supplied buffer that is to receive the information.
Returns
The number of bytes retrieved; otherwise 0 if an error occurs.

◆ GetObjectType()

UINT GetObjectType ( ) const

Retrieves the type of the GDI object.

Returns
The type of the object, if successful; otherwise 0. Refer to the Platform SDK documentation for the list of possible values returned.

◆ GetSafeHandle()

HGDIOBJ GetSafeHandle ( ) const

Returns m_hObject unless this is NULL, in which case NULL is returned.

The returned handle must not be passed to DeleteObject and should be used for read-only purposes, i.e. GDI object state should not be modified as it will affect every place in a program where the cached handle is used.

Returns
Encapsulated GDI handle or NULL.

◆ IsHandleOwnershipGuaranteed()

BOOL IsHandleOwnershipGuaranteed ( ) const

Determines handle ownership guaranteed status.

Guaranteed ownership implies full control over the cached encapsulated handle and thus guarantees that the handle is properly detached from a device context before being deleted. Non-guaranteed ownership can be set in scenarios when a handle is being passed to any API thay may or may not detach it from a device context. By default guaranteed ownership is implied. This status is used only as a diagnostic hint and does not provide any functional advantage. Changing this status affects all GDI object that use the same cached handle.

Returns
TRUE if handle ownership is guaranteed.

◆ operator CGdiObject &()

operator CGdiObject & ( )

Converts an object to CGdiObject reference making it possible to use CXTPGdiObject with MFC classes and methods that use CGdiObject reference as an argument.

Returns
An encapsulated CGdiObject reference.

The returned object must not be deleted or modified as it will affect every place in a program where the cached handle is used.

◆ operator const CGdiObject &()

operator const CGdiObject & ( ) const

Converts an object to CGdiObject constance reference making it possible to use CXTPGdiObject with MFC classes and methods that use CGdiObject reference as an argument.

Returns
An encapsulated CGdiObject constant reference.

◆ operator HGDIOBJ()

operator HGDIOBJ ( ) const

Casts an object to an encapsulated GDI handle.

The returned handle must not be passed to DeleteObject and should be used for read-only purposes, i.e. GDI object state should not be modified as it will affect every place in a program where the cached hande is used.

Returns
Encapsulated GDI handle or NULL.

◆ operator!=()

BOOL operator!= ( const CXTPGdiObject & obj ) const

Determines if two GDI objects are logically not equal.

Parameters
obj A reference to the other CXTPGdiObject instance to compare to.
Returns
TRUE if the encapsulated GDI objects are logically not equal (handles are not the same) or FALSE otherwise.

◆ operator==()

BOOL operator== ( const CXTPGdiObject & obj ) const

Determines if two GDI objects are logically equal.

Parameters
obj A reference to the other CXTPGdiObject instance to compare to.
Returns
TRUE if the encapsulated GDI objects are logically equal (handles are the same) or FALSE otherwise.

◆ SetHandleOwnershipNotGuaranteed()

void SetHandleOwnershipNotGuaranteed ( )

Sets handle ownership guaranteed status.

Guaranteed ownership implies full control over the cached encapsulated handle and thus guarantees that the handle is properly detached from a device context before being deleted. Non-guaranteed ownership can be set in scenarios when a handle is being passed to any API thay may or may not detach it from a device context. By default guaranteed ownership is implied. This status is used only as a diagnostic hint and does not provide any functional advantage. Changing this status affects all GDI object that use the same cached handle.

The documentation for this class was generated from the following file:
  • XTPGdiObjects.h


Toolkit Pro: CXTPGifPreviewProvider Class Reference

List of all members
CXTPGifPreviewProvider Class Reference

Provides a preview handler for static and animated GIF files. More...

Inheritance diagram for CXTPGifPreviewProvider:
[legend]

Additional Inherited Members

- Public Member Functions inherited from IXTPPreviewProvider
virtual | ~IXTPPreviewProvider ()
Handles object destruction.
- Protected Member Functions inherited from CXTPPreviewProviderBase
CXTPPreviewProviderBase ()
Handles object construction.
void | BindHost (IXTPPreviewHost &host)
The method is called by the host preview control when the provider is initially bound to the host.
IXTPPreviewHost & | GetHost () const
Obtains the preview host interface that the provider is bound to.

Detailed Description

Provides a preview handler for static and animated GIF files.

See also
CXTPSystemPreviewProvider, CXTPCommonPicturePreviewProvider, CXTPMsgPreviewProvider, CXTPTextPreviewProvider, CXTPXamlPreviewProvider
The documentation for this class was generated from the following file:
  • XTPGifPreviewProvider.h


Toolkit Pro: CXTPGlobalAtom Class Reference

Public Member Functions | List of all members
CXTPGlobalAtom Class Reference

A helper class for handling a global atom primitive. More...

Public Member Functions

CXTPGlobalAtom (LPCTSTR lpAtomName)
Creates a global atom object using the provided name.
~CXTPGlobalAtom ()
Handles global atom destruction.
ATOM | GetAtom () const
Obtains atom value.
LPCTSTR | GetAtomString () const
Obtains atom value as a string pointer.
const CString & | GetName () const
Obtains atom name.

Detailed Description

A helper class for handling a global atom primitive.

Constructor & Destructor Documentation

◆ CXTPGlobalAtom()

CXTPGlobalAtom ( LPCTSTR lpAtomName )
explicit

Creates a global atom object using the provided name.

If an atom with such a name already exists, then its reference counter will be incremented.

Parameters
lpAtomName An atom name string.

◆ ~CXTPGlobalAtom()

~CXTPGlobalAtom ( )

Handles global atom destruction.

Atom reference counter gets decremented and will be destroyed if it reaches zero.

Member Function Documentation

◆ GetAtom()

ATOM GetAtom ( ) const

Obtains atom value.

Returns
Atom value.

◆ GetAtomString()

LPCTSTR GetAtomString ( ) const

Obtains atom value as a string pointer.

Returns
Atom value as a string pointer. The value must not be used for string operations except where permitted by SDK documentation.

◆ GetName()

const CString & GetName ( ) const

Obtains atom name.

Returns
Atom name string.
The documentation for this class was generated from the following file:
  • XTPSystemHelpers.h


Toolkit Pro: CXTPGraphicBitmapPng Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPGraphicBitmapPng Class Reference

CXTPGraphicBitmapPng is a CBitmap derived class used to load .PNG files from files and resources. More...

Public Member Functions

CXTPGraphicBitmapPng ()
Default constructor.
BOOL | LoadFromFile (LPCTSTR lpszFileName)
Call this method to load a .PNG file.
BOOL | LoadFromResource (HMODULE hModule, HRSRC hRes)
Call this member function to load a .PNG file from a specified resource.
BOOL | LoadFromFile (CFile *pFile)
Call this method to load a .PNG file.
BOOL | IsAlpha () const
Determines if the loaded .PNG file has alpha layer.

Protected Attributes

BOOL m_bAlpha
TRUE if the .PNG file has alpha layer.

Detailed Description

CXTPGraphicBitmapPng is a CBitmap derived class used to load .PNG files from files and resources.

Member Function Documentation

◆ IsAlpha()

BOOL IsAlpha ( ) const

Determines if the loaded .PNG file has alpha layer.

Returns
TRUE if the .PNG file has alpha layer.

◆ LoadFromFile() [1/2]

BOOL LoadFromFile ( CFile * pFile )

Call this method to load a .PNG file.

Parameters
pFile Pointer to the CFile to be loaded.
Returns
TRUE if successful, otherwise 0.

◆ LoadFromFile() [2/2]

BOOL LoadFromFile ( LPCTSTR lpszFileName )

Call this method to load a .PNG file.

Parameters
lpszFileName A string value that contains the name of a file to be loaded.
Returns
TRUE if successful, otherwise 0.

◆ LoadFromResource()

BOOL LoadFromResource | ( | HMODULE | hModule,
 |  | HRSRC | hRes )

Call this member function to load a .PNG file from a specified resource.

Parameters
hModule | Module instance to load.
hRes | Resource handle.
Returns
TRUE if successful, otherwise 0.
The documentation for this class was generated from the following file:
  • XTPGraphicBitmapPng.h


Toolkit Pro: CXTPGridColumn Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPGridColumn Class Reference

Represents a grid column item with its properties and operations. More...

Inheritance diagram for CXTPGridColumn:
[legend]

Public Member Functions

CXTPGridColumn (int nItemIndex, LPCTSTR strName, int nWidth, BOOL bAutoSize=TRUE, int nIconID=XTP_GRID_NOICON, BOOL bSortable=TRUE, BOOL bVisible=TRUE)
Constructs a CXTPGridColumn object.
CXTPGridColumn (int nItemIndex, LPCTSTR strDisplayName, LPCTSTR strInternalName, int nWidth, BOOL bAutoSize=TRUE, int nIconID=XTP_GRID_NOICON, BOOL bSortable=TRUE, BOOL bVisible=TRUE)
Constructs a CXTPGridColumn object.
virtual | ~CXTPGridColumn ()
Destroys a CXTPGridColumn object, handles cleanup and deallocation.
BOOL | IsDragging () const
Determines if the column header is in dragging mode.
CRect | GetRect () const
Gets the client rectangle where the column was drawn last time.
int | GetWidth () const
Gets the column width.
int | GetCaptionWidth (CDC *pDC)
Calculates the caption width (i.e.
int | SetWidth (int nNewWidth)
Sets the column width.
int | GetIndent () const
Gets the column indentation.
int | GetItemIndex () const
Gets the index of the associated record item.
void | SetItemIndex (int nItemIndex)
Sets the index of the associated record item.
int | GetIndex () const
Gets the index of the column.
int | GetVisibleIndex () const
Gets the visible index of the column.
int | GetOldVisibleIndex () const
Gets the old visible index of the column.
int | GetIconID () const
Gets the ID of the associated column header icon.
void | SetIconID (int nIconId)
Sets the ID for the associated column header icon.
CString | GetCaption () const
Gets the text caption of the column header.
void | SetCaption (LPCTSTR strCaption)
Sets the text caption for the column header.
void | SetFooterText (LPCTSTR strFooter)
Sets the text caption for the column footer.
CString | GetFooterText () const
Gets the text caption of the column footer.
void | SetFooterFont (CFont *pFont)
Sets the font for the column footer.
CFont * | GetFooterFont ()
Gets the font of the column footer.
void | SetDrawFooterDivider (BOOL bSet)
Call this member to set/change is the right column footer divider visible.
BOOL | GetDrawFooterDivider () const
Returns is right column footer divider visible.
void | SetDrawHeaderDivider (BOOL bSet)
Call this member to set/change is the right column header divider visible.
BOOL | GetDrawHeaderDivider () const
Returns is right column header divider visible.
CString | GetTooltip () const
Gets the tooltip text of the column header.
void | SetTooltip (LPCTSTR lpszTooltip)
Sets the tooltop text for the column header.
BOOL | IsVisible () const
Determines the visible state of the column header.
void | SetVisible (BOOL bVisible=TRUE)
Sets the visible state for the column header.
BOOL | IsHotTracking () const
Determines the highlighted state of the group.
BOOL | SetFilterable (BOOL bFilterable=TRUE)
Sets the filterable state for the column header.
BOOL | IsFilterable () const
Determines the filterable state of the column header.
BOOL | IsResizable () const
Determines the resizable state of the column.
void | EnableResize (BOOL bIsResizable)
Sets the resizable state of the column.
int | SetMinWidth (int nMinWidth)
Sets the minimal width for the column.
int | GetMinWidth () const
Gets the minimal width of the column.
int | SetMaxWidth (int nMaxWidth)
Sets the maximal width for the column.
int | GetMaxWidth () const
Gets the maximal width of the column.
BOOL | IsSortable () const
Gets the sortable state of the column.
BOOL | IsGroupable () const
Gets the groupable state of the column.
BOOL | IsPlusMinus () const
Determines if the column's expand collapse right icon (+/-) is enabled/disabled.
BOOL | IsExpanded () const
Determines the expanded state of the column.
int | GetNextVisualBlock () const
Gets the index of the next visual column.
BOOL | IsAutoSortWhenGrouped () const
Determines if the column is sortable when grouped.
BOOL | IsAllowDragging () const
Determines if the column can be dragged.
BOOL | IsSortedIncreasing () const
Determines if the column is sorted in increasing order.
BOOL | IsSortedDecreasing () const
Determines if the column is sorted in decreasing order.
void | SetSortIncreasing (BOOL bSortIncreasing)
Specifies if the column should be sorted in increasing/decreasing order.
BOOL | IsSorted () const
Determines if the column is sorted.
void | SetTreeColumn (BOOL bIsTreeColumn)
Specifies if the column should contain a tree.
BOOL | IsTreeColumn () const
Determines if the column contains a tree.
virtual void | DoPropExchange (CXTPPropExchange *pPX)
Reads/writes column data to/from the provided archive stream.
int | SetAlignment (int nAlignment)
Sets the alignment value for the column.
int | GetAlignment () const
Gets the alignment value of the column.
void | SetHeaderAlignment (int nAlignment)
Sets the alignment value for the column header.
int | GetHeaderAlignment () const
Gets the alignment value of the column header.
void | SetFooterAlignment (int nAlignment)
Sets the alignment value for the column footer.
int | GetFooterAlignment () const
Gets the alignment value of the column footer.
BOOL | HasSortTriangle () const
Checks if the column header should have the sort triangle drawn.
BOOL | IsAutoSize () const
Gets if the column is automatically sized.
void | SetAutoSize (BOOL bSet)
Sets if the column is automatically sized.
void | SetSortable (BOOL bSortable)
Specifies if the column should be sorted when the user clicks on the column's header.
void | SetAutoSortWhenGrouped (BOOL bAutoSortWhenGrouped)
Specifies if the column should be sortable when grouped.
void | SetGroupable (BOOL bGroupable)
Sets the groupable state of the column.
void | SetPlusMinus (BOOL bPlusMinus)
Enables/disables the column's expand collapse right icon (+/-).
void | SetExpanded (BOOL bExpanded)
Sets the expanded state of the column.
void | SetNextVisualBlock (int nNextVisualBlock)
Sets the index of the next visual column.
void | SetAllowDrag (BOOL bAllowDrag)
Specifies if columns can be dragged with the mouse.
CXTPGridColumns * | GetColumns () const
Gets the array of column objects.
CXTPGridControl * | GetControl () const
Gets the parent Grid control.
BOOL | IsShowInFieldChooser () const
Determines if the column header will appear in the field chooser when the column is hidden or in the "Group By Box.".
void | SetShowInFieldChooser (BOOL bShow)
Specifies if the column header will appear in the field chooser when the column is hidden or in the "Group By Box.".
CXTPGridRecordItemEditOptions * | GetEditOptions () const
Gets the edit options of the column.
CXTPGridColumnDisplayOptions * | GetDisplayOptions () const
Gets the display options of the column.
BOOL | IsEditable () const
Determines the editable state of items in the column.
void | SetEditable (BOOL bEditable=TRUE)
Specifies the editable state of items in the column.
void | AllowRemove (BOOL bAllow)
Specifies if column removing is allowed.
BOOL | IsAllowRemove () const
Determines if column removing is allowed.
int | GetPrintWidth (int nTotalWidth) const
Gets the column print width.
CString | GetInternalName () const
Gets the internal column name used in serialization to uniquely identify a column rather than a column index.
void | SetInternalName (LPCTSTR pcszName)
Sets the internal column name used in serialization to uniquely identify a column rather than a column index.
BOOL | GetDrawHeaderRowsVGrid () const
Determines if the vertical grid will be shown for header rows.
BOOL | GetDrawFooterRowsVGrid () const
Determines if the vertical grid will be shown for footer rows.
void | SetDrawHeaderRowsVGrid (BOOL bDrawVGrid=TRUE)
Specifies if the vertical grid will be shown for header rows.
void | SetDrawFooterRowsVGrid (BOOL bDrawVGrid=TRUE)
Specifies if the vertical grid will be shown for footer rows.
virtual void | EnsureVisible ()
Ensures that this column is visible.
int | GetBestFitMode () const
Gets the column best fit mode.
void | SetBestFitMode (int nMode)
Sets the column best fit mode.
CXTPMarkupUIElement * | GetMarkupUIElement () const
Gets the Markup UI element object.
virtual void | ResetMarkupUIElement ()
Resets the Markup UI element object.
void | SetFixed (BOOL bFixed)
Sets the fixed state for the column.
BOOL | IsFixed () const
Determines the fixed state of the column.
BOOL | IsFrozen () const
Determines the frozen state of the column.
void | SetFrozen (BOOL bFrozen)
Sets the frozen state for the column.
void | SetMask (LPCTSTR strMask, LPCTSTR strLiteral, TCHAR chPrompt=_T('_'))
Applies a specified mask to a CXTPGridColumn data field to create a restrictive field for text entry.
CString | GetMask () const
Gets string to use as edit mask.
CString | GetLiteral () const
Gets string to use as literal.
TCHAR | GetPrompt () const
Gets character used as a space holder for a character.
BOOL | IsUseMask () const
Determines the specified mask to a data field.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Attributes

CString | m_strInternalName
Internal column name (to serialize column options).
CString | m_strName
Column name.
CString | m_strTooltip
Column tooltip.
int | m_nItemIndex
Index of the associated record item.
CString | m_strFooterText
Column Footer Text.
CXTPFont m_xtpFontFooter
Column Footer font.
BOOL | m_bDrawFooterDivider
If TRUE, then draw footer column right divider.
BOOL | m_bDrawHeaderDivider
If TRUE, then draw header column right divider.
BOOL | m_bAutoNumbering
Enables auto-numbering.
int | m_nAutoNumberingBase
Base index for auto-numbering.
BOOL | m_bSortIncreasing
Stores column sort direction (used when m_bSortable is TRUE).
BOOL | m_bSortable
TRUE if the column could be sortable by.
BOOL | m_bGroupable
TRUE if the column could be grouped by.
BOOL | m_bAutoSortWhenGrouped
Column will be sortable when grouped by, otherwise it will grouped without sorting by it (sort by other columns wiil be applied).
BOOL | m_bFixed
TRUE if the column is fixed.
BOOL | m_bFrozen
TRUE if the column is frozen (i.e.
BOOL | m_bFilterable
TRUE if filtering by this column is allowed.
BOOL | m_bPlusMinus
Determines if the column have Expand / Collapse right icon (+/-).
BOOL | m_bExpanded
State of PlusMinus column.
int | m_nNextVisualBlock
Number of next visual columns to show or hide see SetNextVisualBlock(...) and GetNextVisualBlock().
BOOL | m_bAllowDrag
Allow/disallow dragging of the column.
BOOL | m_bAllowRemove
TRUE to allow column remove.
CXTPGridColumns * | m_pColumns
Pointer to the parent columns collection.
int | m_nIconID
Associated icon ID.
BOOL | m_bVisible
Visible state.
int | m_nOldVisibleIndex
Visible index before Hide state.
BOOL | m_bIsResizable
Indicates if the column allows for width resizing.
CRect | m_rcColumn
Saves rectangle where column was drawn last time.
CRect | m_rcGroupBy
Saves rectangle where column was drawn in group box.
int | m_nMinWidth
Minimal column width.
int | m_nMaxWidth
Maximal column width (if set as positive).
int | m_nMaxItemWidth
Contains maximal width of the corresponding item drawn in the column.
int | m_nAlignment
Alignment mode for column: DT_LEFT || DT_RIGHT || DT_CENTER.
int | m_nHeaderAlignment
Alignment mode for column text: DT_LEFT || DT_RIGHT || DT_CENTER.
int | m_nFooterAlignment
Alignment mode for column footer text: DT_LEFT || DT_RIGHT || DT_CENTER.
int | m_nColumnAutoWidth
The column automatic width.
int | m_nColumnStaticWidth
The user defined width.
BOOL | m_bAutoSize
TRUE if column auto-sized.
BOOL | m_bShowInFieldChooser
Indicates if the column is shown in the field chooser when the column is hidden or in the GroupBy Box.
BOOL | m_bEditable
Indicates whether an edit box should be added to the items in the column.
BOOL | m_bDrawHeaderRowsVGrid
Indicates whether to draw vertical grid for headers rows.
BOOL | m_bDrawFooterRowsVGrid
Indicates whether to draw vertical grid for footers rows.
int | m_nBestFitMode
Best fit mode.
CXTPGridRecordItemEditOptions * | m_pEditOptions
Edit options of the column.
CXTPGridColumnDisplayOptions * | m_pDisplayOptions
Display options of the column.
CXTPMarkupUIElement * | m_pMarkupUIElement
Markup Object.
CString | m_strMask
String to use as edit mask.
CString | m_strLiteral
String to use as literal.
TCHAR | m_chPrompt
Character used as a space holder for a character.
BOOL | m_bUseMask
TRUE to use an edit mask to display item data.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

Represents a grid column item with its properties and operations.

You create a CXTPGridColumn object by calling a constructor and providing all necessary parameters. Many of these parameters have default values. Column has 3 properties that greatly influence its behavior:

bAutoSize: TRUE allows auto-resizing of the width of columns when GridControl's client area is resized by the user. If bAutoSize is set to FALSE, then the column keeps its initial size.

bSortable: TRUE allows a column to be sortable. If bSortable is set to FALSE, then you will not be able to sort records by their column.

bVisible: Determines if columns will draw by control or not. For example, if the column is dragged into FieldChooser, then the column still exists in the columns list, but it becomes invisible.

See also
CXTPGridControl, CXTPGridColumns

Constructor & Destructor Documentation

◆ CXTPGridColumn() [1/2]

CXTPGridColumn | ( | int | nItemIndex,
 |  | LPCTSTR | strName,
 |  | int | nWidth,
 |  | BOOL | bAutoSize = TRUE,
 |  | int | nIconID = XTP_GRID_NOICON,
 |  | BOOL | bSortable = TRUE,
 |  | BOOL | bVisible = TRUE )

Constructs a CXTPGridColumn object.

Parameters
strName | Column name.
nItemIndex | Index of the corresponding record item.
nWidth | Initial width of the created column.
nIconID | Number of the corresponding icon in the image list.
bAutoSize | Is column resizable flag.
bSortable | Is column sortable flag.
bVisible | Is column visible flag. There are 3 parameters that greatly influence a column's behavior: bAutoSize: TRUE allows auto-resizing of the width of columns when GridControl's client area is resized by the user. If bAutoSize is set to FALSE, then the column keeps its initial size. bSortable: TRUE allows a column to be sortable. If bSortable is set to FALSE, then you will not be able to sort records by their column. bVisible: Determines if columns will draw by control or not. For example, if the column is dragged into FieldChooser, then the column still exists in the columns list, but it becomes invisible.

Example:

CXTPGridControl wndGrid;
wndGrid.AddColumn(new CXTPGridColumn(COLUMN_ICON, _T("Message Class"), 18, FALSE,
COLUMN_MAIL_ICON));

◆ CXTPGridColumn() [2/2]

CXTPGridColumn | ( | int | nItemIndex,
 |  | LPCTSTR | strDisplayName,
 |  | LPCTSTR | strInternalName,
 |  | int | nWidth,
 |  | BOOL | bAutoSize = TRUE,
 |  | int | nIconID = XTP_GRID_NOICON,
 |  | BOOL | bSortable = TRUE,
 |  | BOOL | bVisible = TRUE )

Constructs a CXTPGridColumn object.

Parameters
nItemIndex | Index of the corresponding record item.
nWidth | Initial width of the created column.
nIconID | Number of the corresponding icon in the image list.
bAutoSize | Is column resizable flag.
bSortable | Is column sortable flag.
bVisible | Is column visible flag.
strInternalName | Internal column name (to serialize column options).
strDisplayName | The display name (caption) of the column.

There are 3 parameters that greatly influence a column's behavior: bAutoSize: TRUE allows auto-resizing of the width of columns when GridControl's client area is resized by the user. If bAutoSize is set to FALSE, then the column keeps its initial size. bSortable: TRUE allows a column to be sortable. If bSortable is set to FALSE, then you will not be able to sort records by their column. bVisible: Determines if columns will draw by control or not. For example, if the column is dragged into FieldChooser, then the column still exists in the columns list, but it becomes invisible.

Example:

CXTPGridControl wndGrid;
wndGrid.AddColumn(new CXTPGridColumn(COLUMN_ICON, _T("Message Class"), 18, FALSE,
COLUMN_MAIL_ICON));

Member Function Documentation

◆ AllowRemove()

AFX_INLINE void AllowRemove ( BOOL bAllow )

Specifies if column removing is allowed.

Parameters
bAllow TRUE to allow column removing, FALSE to disallow.

Usually the user is allowed to remove a column using mouse drag and drop. Using this member function, you can change the user's permissions to force either allowing or disallowing column removing.

See also
CXTPGridHeader::AllowColumnRemove

◆ DoPropExchange()

virtual void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Reads/writes column data to/from the provided archive stream.

Parameters
pPX Pointer to a CXTPPropExchange object to serialize to/from.

◆ EnableResize()

AFX_INLINE void EnableResize ( BOOL bIsResizable )

Sets the resizable state of the column.

Parameters
bIsResizable TRUE to set the column to resizable, FALSE otherwise.
See also
IsResizable

◆ EnsureVisible()

virtual void EnsureVisible ( )
virtual

Ensures that this column is visible.

This will cause the Grid control to scroll to this column.

◆ GetAlignment()

int GetAlignment ( ) const

Gets the alignment value of the column.

Returns
The alignment value of the column; the alignment value should be a combination of DT_* bits used by the DrawText and DrawTextEx functions from the Windows SDK.

◆ GetBestFitMode()

AFX_INLINE int GetBestFitMode ( ) const

Gets the column best fit mode.

Returns
The column best fit mode; one of the values defined by the XTPGridColumnBestFitMode enumeration.
See also
SetBestFitMode

◆ GetCaption()

AFX_INLINE CString GetCaption ( ) const

Gets the text caption of the column header.

You use GetCaption() to get the current column caption.

Returns
The text caption of the column header.

◆ GetCaptionWidth()

int GetCaptionWidth ( CDC * pDC )

Calculates the caption width (i.e.

the caption text length).

Parameters
pDC Pointer to the device context to calculate the width at.

This function calculates the caption width in logical units using the given device context, current caption font, and string of text.

Returns
The caption width, in pixels.

◆ GetColumns()

CXTPGridColumns * GetColumns ( ) const

Gets the array of column objects.

Returns
A pointer to the array of column objects.

◆ GetControl()

CXTPGridControl * GetControl ( ) const

Gets the parent Grid control.

Returns
A pointer to the parent Grid control.
See also
GetColumns

◆ GetDisplayOptions()

AFX_INLINE CXTPGridColumnDisplayOptions * GetDisplayOptions ( ) const

Gets the display options of the column.

Returns
A pointer to a CXTPGridColumnDisplayOptions object.

◆ GetDrawFooterDivider()

AFX_INLINE BOOL GetDrawFooterDivider ( ) const

Returns is right column footer divider visible.

By default divider is visible.

Returns
Is column footer divider visible.
See also
SetDrawFooterDivider

◆ GetDrawFooterRowsVGrid()

AFX_INLINE BOOL GetDrawFooterRowsVGrid ( ) const

Determines if the vertical grid will be shown for footer rows.

Returns
TRUE if the vertical grid will be shown for footer rows, FALSE otherwise.
See also
SetDrawFooterRowsVGrid

◆ GetDrawHeaderDivider()

AFX_INLINE BOOL GetDrawHeaderDivider ( ) const

Returns is right column header divider visible.

By default divider is visible.

Returns
Is column footer divider visible.
See also
SetDrawHeaderDivider

◆ GetDrawHeaderRowsVGrid()

AFX_INLINE BOOL GetDrawHeaderRowsVGrid ( ) const

Determines if the vertical grid will be shown for header rows.

Returns
TRUE if the vertical grid will be shown for header rows, FALSE otherwise.
See also
SetDrawHeaderRowsVGrid

◆ GetEditOptions()

AFX_INLINE CXTPGridRecordItemEditOptions * GetEditOptions ( ) const

Gets the edit options of the column.

Returns
A pointer to a CXTPGridRecordItemEditOptions object.

◆ GetFooterAlignment()

int GetFooterAlignment ( ) const

Gets the alignment value of the column footer.

Returns
The alignment value of the column footer; the alignment value should be a combination of DT_* bits used by the DrawText and DrawTextEx functions from the Windows SDK.

◆ GetFooterFont()

CFont * GetFooterFont ( )

Gets the font of the column footer.

CXTPGridPaintManager::m_fontCaption is used as the default footer font.

Returns
The font of the column footer.
See also
SetFooterFont

◆ GetFooterText()

AFX_INLINE CString GetFooterText ( ) const

Gets the text caption of the column footer.

Use SetFooterText() to set the text caption for the column footer.

Returns
The text caption of the column footer.

◆ GetHeaderAlignment()

int GetHeaderAlignment ( ) const

Gets the alignment value of the column header.

Returns
The alignment value of the column header; the alignment value should be a combination of DT_* bits used by the DrawText and DrawTextEx functions from the Windows SDK.

◆ GetIconID()

AFX_INLINE int GetIconID ( ) const

Gets the ID of the associated column header icon.

Columns can have an image that will be drawn on it. You use GetIconID() to get the current image ID which passes to the column ID of the column. The ID must match one of the IDs in the imagelist.

Returns
The ID of the associated column header icon.

◆ GetIndent()

int GetIndent ( ) const

Gets the column indentation.

Returns
The column indentation, in pixels.

◆ GetIndex()

int GetIndex ( ) const

Gets the index of the column.

Returns
The index of the column.

◆ GetInternalName()

AFX_INLINE CString GetInternalName ( ) const

Gets the internal column name used in serialization to uniquely identify a column rather than a column index.

Returns
The internal column name.

◆ GetItemIndex()

int GetItemIndex ( ) const

Gets the index of the associated record item.

Returns
The index of the associated record item.

◆ GetLiteral()

AFX_INLINE CString GetLiteral ( ) const

Gets string to use as literal.

Returns
String to use as literal.
See also
SetMask

◆ GetMarkupUIElement()

AFX_INLINE CXTPMarkupUIElement * GetMarkupUIElement ( ) const

Gets the Markup UI element object.

Returns
A pointer to the Markup UI element object.

◆ GetMask()

AFX_INLINE CString GetMask ( ) const

Gets string to use as edit mask.

Returns
String to use as edit mask.
See also
SetMask

◆ GetMaxWidth()

int GetMaxWidth ( ) const

Gets the maximal width of the column.

Returns
The maximal width of the column, in pixels.
See also
SetMaxWidth

◆ GetMinWidth()

int GetMinWidth ( ) const

Gets the minimal width of the column.

Returns
The minimal width of the column, in pixels.
See also
SetMinWidth

◆ GetNextVisualBlock()

AFX_INLINE int GetNextVisualBlock ( ) const

Gets the index of the next visual column.

Returns
The zero-based index of the next visual column.
See also
SetNextVisualBlock(...)

◆ GetOldVisibleIndex()

int GetOldVisibleIndex ( ) const

Gets the old visible index of the column.

Returns
The old visible index of the column.

◆ GetPrintWidth()

int GetPrintWidth ( int nTotalWidth ) const

Gets the column print width.

Parameters
nTotalWidth Total width, in pixels.

Returns the current column width in logical units for print mode.

Returns
The column print width.

◆ GetPrompt()

AFX_INLINE TCHAR GetPrompt ( ) const

Gets character used as a space holder for a character.

Returns
Character used as a space holder for a character.
See also
SetMask

◆ GetRect()

CRect GetRect ( ) const

Gets the client rectangle where the column was drawn last time.

Each time when the column is drawing, its rectangle is recalculated to fit in size after GridControl resizing, column resizing or moving, etc. You use GetWidth() to get the latest rectangle width.

Returns
The client rectangle where the column was drawn last time.

◆ GetTooltip()

AFX_INLINE CString GetTooltip ( ) const

Gets the tooltip text of the column header.

Returns
The tooltip text of the column header.

◆ GetVisibleIndex()

int GetVisibleIndex ( ) const

Gets the visible index of the column.

Returns
The visible index of the column.

◆ GetWidth()

int GetWidth ( ) const

Gets the column width.

Each time when the column is drawing, its rectangle is recalculated to fit in size after GridControl resizing, column resizing or moving, etc. You use GetWidth() to get the latest rectangle width.

Returns
The column width.

◆ HasSortTriangle()

BOOL HasSortTriangle ( ) const

Checks if the column header should have the sort triangle drawn.

Returns
TRUE if the sort triangle should be drawn for this column, FALSE otherwise.

◆ IsAllowDragging()

AFX_INLINE BOOL IsAllowDragging ( ) const

Determines if the column can be dragged.

Returns
TRUE if the column can be dragged, otherwise FALSE.
See also
IsDragging

◆ IsAllowRemove()

AFX_INLINE BOOL IsAllowRemove ( ) const

Determines if column removing is allowed.

Returns
TRUE if column removing is allowed, otherwise FALSE.
See also
AllowRemove

◆ IsAutoSize()

AFX_INLINE BOOL IsAutoSize ( ) const

Gets if the column is automatically sized.

Returns
TRUE if the column is automatically sized, otherwise FALSE.

◆ IsAutoSortWhenGrouped()

AFX_INLINE BOOL IsAutoSortWhenGrouped ( ) const

Determines if the column is sortable when grouped.

Returns
TRUE if the column is sortable when grouped, otherwise FALSE.

◆ IsDragging()

BOOL IsDragging ( ) const

Determines if the column header is in dragging mode.

Grid columns may be moved (change order of columns, delete columns from header, move column to FieldChooser) using drag and drop. When a column is moved, it is in dragging mode. You use IsDragging() to determine if the columns are in dragging mode.

Returns
TRUE if the column header is in dragging mode, otherwise FALSE.
See also
IsAllowDragging

◆ IsEditable()

AFX_INLINE BOOL IsEditable ( ) const

Determines the editable state of items in the column.

If the items in the column are editable, then an edit box will appear when an item is clicked/double-clicked that allows for that item to be edited. This can be overridden for individual items by calling the CXTPGridRecordItem::SetEditable method.

Returns
TRUE if the items in the column are editable, otherwise FALSE.
See also
SetEditable

◆ IsExpanded()

AFX_INLINE BOOL IsExpanded ( ) const

Determines the expanded state of the column.

Returns
TRUE if the column is expanded, otherwise FALSE.
See also
SetExpanded(...)

◆ IsFilterable()

AFX_INLINE BOOL IsFilterable ( ) const

Determines the filterable state of the column header.

Returns
TRUE if the column header is filterable, otherwise FALSE.
See also
SetFilterable

◆ IsFixed()

AFX_INLINE BOOL IsFixed ( ) const

Determines the fixed state of the column.

Returns
TRUE if the column is fixed, otherwise FALSE.

◆ IsFrozen()

AFX_INLINE BOOL IsFrozen ( ) const

Determines the frozen state of the column.

Returns
TRUE if the column is frozen, otherwise FALSE.

◆ IsGroupable()

AFX_INLINE BOOL IsGroupable ( ) const

Gets the groupable state of the column.

Not all columns allow grouping. This method can be used to determine if the column can be grouped (i.e. added to the "Group By" box).

Returns
TRUE if the column is groupable, otherwise FALSE.

◆ IsHotTracking()

BOOL IsHotTracking ( ) const

Determines the highlighted state of the group.

Returns
TRUE if the group is highlighted, otherwise FALSE.

◆ IsPlusMinus()

AFX_INLINE BOOL IsPlusMinus ( ) const

Determines if the column's expand collapse right icon (+/-) is enabled/disabled.

Returns
TRUE if the column's expand collapse right icon (+/-) is enabled, FALSE the column's expand collapse right icon (+/-) is disabled.
See also
SetPlusMinus(...)

◆ IsResizable()

AFX_INLINE BOOL IsResizable ( ) const

Determines the resizable state of the column.

Returns
TRUE if the column is resizable, otherwise FALSE.
See also
EnableResize

◆ IsShowInFieldChooser()

BOOL IsShowInFieldChooser ( ) const

Determines if the column header will appear in the field chooser when the column is hidden or in the "Group By Box.".

When a column is hidden or added to the "Group By Box", it will be automatically added to the FieldChooser unless the ShowInFieldChooser property is set to FALSE. If you would like to have a hidden column that the user cannot access and you enable the FieldChooser, then you will need to set the ShowInFieldChooser property to FALSE. By default, this property is TRUE.

Returns
TRUE if the column header will appear in the field chooser when the column is hidden or in the "Group By Box", otherwise FALSE.
See also
SetShowInFieldChooser

◆ IsSortable()

AFX_INLINE BOOL IsSortable ( ) const

Gets the sortable state of the column.

Returns
TRUE if the column is sortable, otherwise FALSE.
See also
IsSorted, IsSortedIncreasing, IsSortedDecreasing

◆ IsSorted()

BOOL IsSorted ( ) const

Determines if the column is sorted.

Returns
TRUE if the column is sorted, otherwise FALSE.
See also
IsSortable, IsSortedIncreasing, IsSortedDecreasing

◆ IsSortedDecreasing()

BOOL IsSortedDecreasing ( ) const

Determines if the column is sorted in decreasing order.

Returns
TRUE if the column is sorted in decreasing order, otherwise FALSE.
See also
IsSorted, IsSortable, IsSortedIncreasing

◆ IsSortedIncreasing()

BOOL IsSortedIncreasing ( ) const

Determines if the column is sorted in increasing order.

Returns
TRUE if the column is sorted in increasing order, otherwise FALSE.
See also
IsSorted, IsSortable, IsSortedDecreasing

◆ IsTreeColumn()

BOOL IsTreeColumn ( ) const

Determines if the column contains a tree.

Returns
TRUE if the column contains tree items, otherwise FALSE.
See also
SetTreeColumn

◆ IsUseMask()

AFX_INLINE BOOL IsUseMask ( ) const

Determines the specified mask to a data field.

Returns
TRUE if the mask is used, otherwise FALSE.
See also
SetMask

◆ IsVisible()

BOOL IsVisible ( ) const

Determines the visible state of the column header.

Returns
TRUE if the column header is visible, otherwise FALSE.
See also
SetVisible

◆ ResetMarkupUIElement()

virtual void ResetMarkupUIElement ( )
virtual

Resets the Markup UI element object.

See also
GetMarkupUIElement, CXTPGridControl::EnableMarkup

◆ SetAlignment()

int SetAlignment ( int nAlignment )

Sets the alignment value for the column.

Parameters
nAlignment Alignment value to be set; the alignment value should be a combination of DT_* bits used by the DrawText and DrawTextEx functions from the Windows SDK.
Returns
The previous alignment value of the column.

◆ SetAllowDrag()

void SetAllowDrag ( BOOL bAllowDrag )

Specifies if columns can be dragged with the mouse.

Parameters
bAllowDrag TRUE to allow columns to be dragged with the mouse, FALSE to disallow columns from being dragged with the mouse.
See also
SetSortable, SetGroupable

◆ SetAutoSize()

AFX_INLINE void SetAutoSize ( BOOL bSet )

Sets if the column is automatically sized.

Parameters
bSet TRUE to automatically size the column, FALSE otherwise.

Missing MFC function (presented in ActiveX version).

◆ SetAutoSortWhenGrouped()

AFX_INLINE void SetAutoSortWhenGrouped ( BOOL bAutoSortWhenGrouped )

Specifies if the column should be sortable when grouped.

Parameters
bAutoSortWhenGrouped TRUE to allow the column to be sorted when grouped, FALSE to disallow the column from being sorted when grouped.

TRUE by default. If FALSE, then records will be grouped without sorting by the column (sort by other columns will still be applied).

◆ SetBestFitMode()

AFX_INLINE void SetBestFitMode ( int nMode )

Sets the column best fit mode.

Parameters
nMode Column best fit mode to be set; must be one of the values defined by the XTPGridColumnBestFitMode enumeration.
See also
GetBestFitMode

◆ SetCaption()

void SetCaption ( LPCTSTR strCaption )

Sets the text caption for the column header.

Parameters
strCaption Text caption to be set.

◆ SetDrawFooterDivider()

void SetDrawFooterDivider ( BOOL bSet )

Call this member to set/change is the right column footer divider visible.

Parameters
bSet If TRUE divider is visible, FALSE invisible.

By default divider is visible.

See also
GetDrawFooterDivider

◆ SetDrawFooterRowsVGrid()

AFX_INLINE void SetDrawFooterRowsVGrid ( BOOL bDrawVGrid = TRUE )

Specifies if the vertical grid will be shown for footer rows.

Parameters
bDrawVGrid TRUE to show the vertical grid for footer rows.
See also
GetDrawFooterRowsVGrid

◆ SetDrawHeaderDivider()

void SetDrawHeaderDivider ( BOOL bSet )

Call this member to set/change is the right column header divider visible.

Parameters
bSet If TRUE divider is visible, FALSE invisible.

By default divider is visible.

See also
GetDrawHeaderDivider

◆ SetDrawHeaderRowsVGrid()

AFX_INLINE void SetDrawHeaderRowsVGrid ( BOOL bDrawVGrid = TRUE )

Specifies if the vertical grid will be shown for header rows.

Parameters
bDrawVGrid TRUE to show the vertical grid for header rows.
See also
GetDrawHeaderRowsVGrid

◆ SetEditable()

AFX_INLINE void SetEditable ( BOOL bEditable = TRUE )

Specifies the editable state of items in the column.

Parameters
bEditable TRUE to set the items in the column to editable, FALSE otherwise.

If the items in the column are editable, then an edit box will appear when an item is clicked/double-clicked that allows for that item to be edited. This can be overridden for individual items by calling the CXTPGridRecordItem::SetEditable method.

See also
IsEditable

◆ SetExpanded()

void SetExpanded ( BOOL bExpanded )

Sets the expanded state of the column.

Parameters
bExpanded TRUE to expand the column, FALSE otherwise.
See also
IsExpanded(...)

◆ SetFilterable()

BOOL SetFilterable ( BOOL bFilterable = TRUE )

Sets the filterable state for the column header.

Parameters
bFilterable TRUE to set the column header to filterable, FALSE to set the column header to not filterable.
Returns
The previous filterable state of the column header.
See also
IsFiltrable

◆ SetFixed()

AFX_INLINE void SetFixed ( BOOL bFixed )

Sets the fixed state for the column.

Parameters
bFixed TRUE to fix the column, FALSE to unfix it.

◆ SetFooterAlignment()

void SetFooterAlignment ( int nAlignment )

Sets the alignment value for the column footer.

Parameters
nAlignment Alignment value to be set; the alignment value should be a combination of DT_* bits used by the DrawText and DrawTextEx functions from the Windows SDK.

◆ SetFooterFont()

void SetFooterFont ( CFont * pFont )

Sets the font for the column footer.

Parameters
pFont Pointer to a CFont object; may be NULL.

CXTPGridPaintManager::m_fontCaption is used as the default footer font. If pFont is NULL, then the default font will be used.

See also
GetFooterFont

◆ SetFooterText()

void SetFooterText ( LPCTSTR strFooter )

Sets the text caption for the column footer.

Parameters
strFooter Text caption to be set. Remarks Call CXTPGridControl::ShowFooter to show the footer area.
See also
GetFooterText, CXTPGridControl::ShowFooter

◆ SetFrozen()

AFX_INLINE void SetFrozen ( BOOL bFrozen )

Sets the frozen state for the column.

Parameters
bFrozen TRUE to freeze the column, FALSE to unfreeze it.

◆ SetGroupable()

AFX_INLINE void SetGroupable ( BOOL bGroupable )

Sets the groupable state of the column.

Parameters
bGroupable TRUE to set the column to groupable, FALSE otherwise.

If a column is groupable, then it can be added to the "Group By" box. In the event that a column is added to the "Group By" box, the contents of the Grid control will be grouped by the column. If a column is not groupable, then it cannot be added to the "Group By" box.

See also
SetSortable

◆ SetHeaderAlignment()

AFX_INLINE void SetHeaderAlignment ( int nAlignment )

Sets the alignment value for the column header.

Parameters
nAlignment Alignment value to be set; the alignment value should be a combination of DT_* bits used by the DrawText and DrawTextEx functions from the Windows SDK.

◆ SetIconID()

AFX_INLINE void SetIconID ( int nIconId )

Sets the ID for the associated column header icon.

Parameters
nIconId ID to be set.

◆ SetInternalName()

AFX_INLINE void SetInternalName ( LPCTSTR pcszName )

Sets the internal column name used in serialization to uniquely identify a column rather than a column index.

Parameters
pcszName Internal column name to be set.

◆ SetItemIndex()

void SetItemIndex ( int nItemIndex )

Sets the index of the associated record item.

Parameters
nItemIndex New index to be set.

◆ SetMask()

void SetMask | ( | LPCTSTR | strMask,
 |  | LPCTSTR | strLiteral,
 |  | TCHAR | chPrompt = _T('_') )

Applies a specified mask to a CXTPGridColumn data field to create a restrictive field for text entry.

Parameters
strMask | Mask of the item.
strLiteral | Defines the prompt area of the mask where text entry is allowed. This value should match the areas that you have already defined as mask fields. By default, the prompt character is '_'.

Phone No: (___) ___-____

Parameters
chPrompt (Optional) This value is the prompt character used in strLiteral to indicate a place holder. By default, this parameter is the underscore '_' character.

You can use any of these characters for defining your edit mask:

Mask Character         Description
---------------------  ------------------------
0                      Numeric (0-9)
9                      Numeric (0-9) or space (' ')
#                      Numeric (0-9) or space (' ') or ('+') or ('-')
L                      Alpha (a-Z)
?                      Alpha (a-Z) or space (' ')
A                      Alpha numeric (0-9 and a-Z)
a                      Alpha numeric (0-9 and a-Z) or space (' ')
&                      All print character only
H                      Uppercase hex digit (0-9 and A-F)
h                      Lowercase hex digit (0-9 and a-f)
X                      Uppercase hex digit (0-9 and A-F) and space (' ')
x                      Lowercase hex digit (0-9 and a-f) and space (' ')
>                      Forces characters to upper case (A-Z) or any Unicode character
<                      Forces characters to lower case (a-z) or any Unicode character
C                      Uppercase ASCII character
c                      Lowercase ASCII character

Any of these characters can be combined with additional characters to create a restrictive field for text entry. For example, if you wanted to display a prompt for a telephone number and wanted to restrict only numeric values, but wanted to display the area code inside of parentheses '(' and ')' then you could define your mask as:

Phone No: (000) 000-0000

◆ SetMaxWidth()

int SetMaxWidth ( int nMaxWidth )

Sets the maximal width for the column.

Parameters
nMaxWidth Maximal width, in pixels, to be set.

After you set the maximal width for the column, the column cannot be resized to more than the maximal width.

Returns
The previous maximal width of the column, in pixels.
See also
GetMaxWidth

◆ SetMinWidth()

int SetMinWidth ( int nMinWidth )

Sets the minimal width for the column.

Parameters
nMinWidth Minimal width, in pixels, to be set.

After you set the minimal width for the column, the column cannot be resized to less than the minimal width.

Returns
The previous minimal width of the column, in pixels.
See also
GetMinWidth

◆ SetNextVisualBlock()

void SetNextVisualBlock ( int nNextVisualBlock )

Sets the index of the next visual column.

Parameters
nNextVisualBlock Zero-based index of the column.
See also
GetNextVisualBlock(...)

◆ SetPlusMinus()

void SetPlusMinus ( BOOL bPlusMinus )

Enables/disables the column's expand collapse right icon (+/-).

Parameters
bPlusMinus TRUE to enable, FALSE to disable.
See also
IsPlusMinus(...)

◆ SetShowInFieldChooser()

void SetShowInFieldChooser ( BOOL bShow )

Specifies if the column header will appear in the field chooser when the column is hidden or in the "Group By Box.".

Parameters
bShow TRUE to show the column header in the field chooser when the column is hidden or in the "Group By Box", FALSE otherwise.

When a column is hidden or added to the "Group By Box", it will be automatically added to the FieldChooser unless the ShowInFieldChooser property is set to FALSE. If you would like to have a hidden column that the user cannot access and you enable the FieldChooser, then you will need to set the ShowInFieldChooser property to FALSE. By default, this property is TRUE.

See also
IsShowInFieldChooser

◆ SetSortable()

AFX_INLINE void SetSortable ( BOOL bSortable )

Specifies if the column should be sorted when the user clicks on the column's header.

Parameters
bSortable TRUE to allow records to be sorted by the column by clicking on the column's header, FALSE to disallow records from being sorted by the column by clicking on the column's header.

If bSortable is TRUE, then the sort order will toggle between ascending and descending order each time the column header is clicked. If bSortable is FALSE, then the column may still be sorted, but not by clicking the column header. In order to sort the column when bSortable is FALSE, the column can be added to Grid control's sort order. This will keep the column sorted at all times.

See also
SetGroupable

◆ SetSortIncreasing()

AFX_INLINE void SetSortIncreasing ( BOOL bSortIncreasing )

Specifies if the column should be sorted in increasing/decreasing order.

Parameters
bSortIncreasing TRUE to sort the column in increasing order, FALSE to sort the column in decreasing order.
See also
IsSorted, IsSortable, IsSortedIncreasing, IsSortedDecreasing

◆ SetTooltip()

AFX_INLINE void SetTooltip ( LPCTSTR lpszTooltip )

Sets the tooltop text for the column header.

Parameters
lpszTooltip Tooltip text to be set.

◆ SetTreeColumn()

void SetTreeColumn ( BOOL bIsTreeColumn )

Specifies if the column should contain a tree.

Parameters
bIsTreeColumn TRUE to set the column to contain tree items, FALSE otherwise.
See also
IsTreeColumn

◆ SetVisible()

void SetVisible ( BOOL bVisible = TRUE )

Sets the visible state for the column header.

Parameters
bVisible TRUE to set the column header to visible, FALSE to set the column header to invisible.

A column header will become invisible if it is moved to FieldChooser. To change the visibility of a column header, use SetVisible(BOOL).

See also
IsVisible

◆ SetWidth()

int SetWidth ( int nNewWidth )

Sets the column width.

Parameters
nNewWidth New column width, in pixels.

This member function provides you with the ability to change column width manually. Used to set the initial width and/or width for columns in which AutoSize = FALSE.

Returns
The previous column width, in pixels.

Member Data Documentation

◆ m_bFrozen

BOOL m_bFrozen
protected

TRUE if the column is frozen (i.e.

not scrollable).

◆ m_bPlusMinus

BOOL m_bPlusMinus
protected

Determines if the column have Expand / Collapse right icon (+/-).

See IsPlusMinus() and SetPlusMinus().

◆ m_chPrompt

TCHAR m_chPrompt
protected

Character used as a space holder for a character.

This is used in m_strLiteral.

◆ m_nBestFitMode

int m_nBestFitMode
protected

Best fit mode.

See enum XTPGridColumnBestFitMode.

◆ m_nMaxWidth

int m_nMaxWidth
protected

Maximal column width (if set as positive).

It is not allowed to do it more then maximal.

◆ m_nMinWidth

int m_nMinWidth
protected

Minimal column width.

It is not allowed to do it less then minimal.

◆ m_nOldVisibleIndex

int m_nOldVisibleIndex
protected

Visible index before Hide state.

Release 13.1

◆ m_strLiteral

CString m_strLiteral
protected

String to use as literal.

This is the same as the edit mask, but all mask characters are replaced with m_chPrompt.

◆ m_xtpFontFooter

CXTPFont m_xtpFontFooter
protected

Column Footer font.

If Font handle is NULL, then the default font is used.

The documentation for this class was generated from the following file:
  • XTPGridColumn.h


Toolkit Pro: CXTPGridColumnOrder Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPGridColumnOrder Class Reference

Represents the column order, used for sorting and grouping. More...

Inheritance diagram for CXTPGridColumnOrder:
[legend]

Public Member Functions

CXTPGridColumnOrder (CXTPGridColumns *pColumns)
Constructs a CXTPGridColumnOrder object.
CXTPGridColumn * | GetAt (int nIndex)
Retrieves the column item at a specified index in the collection.
int | InsertAt (int nIndex, CXTPGridColumn *pColumn)
Inserts a specified column at a specified index.
void | RemoveAt (int nIndex)
Removes the column at a specified index from the collection.
void | Remove (CXTPGridColumn *pColumn)
Removes a specified column from the collection.
int | Add (CXTPGridColumn *pColumn)
Adds a specified column to the end of the collection.
int | Add (CXTPGridColumn *pColumn, BOOL bSortIncreasing)
Adds a specified column to the end of the collection.
int | IndexOf (const CXTPGridColumn *pColumn)
Retrieves the index of a column.
void | Clear ()
Clears all stored order information.
int | GetCount () const
Gets the number of columns in the collection.
virtual void | DoPropExchange (CXTPPropExchange *pPX)
Reads/writes column order settings to/from the provided archive stream.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Attributes

CXTPGridColumns * | m_pColumns
Parent columns array.
CArray< CXTPGridColumn *, CXTPGridColumn * > | m_arrColumns
Storage for column items with the corresponding order.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

Represents the column order, used for sorting and grouping.

This class is a collection of sorted columns objects, each of which can be referred to by its zero-based index. It provides the following main operations to manipulate a list of columns: adding/removing columns, get at a given position, clear collection, get the index of an object by it pointer. You create a CXTPGridColumnOrder object simply by calling its constructor with one parameter pointer to the columns collection.

Constructor & Destructor Documentation

◆ CXTPGridColumnOrder()

CXTPGridColumnOrder ( CXTPGridColumns * pColumns )

Constructs a CXTPGridColumnOrder object.

Parameters
pColumns Parent columns collection.

Member Function Documentation

◆ Add() [1/2]

int Add ( CXTPGridColumn * pColumn )

Adds a specified column to the end of the collection.

Parameters
pColumn Pointer to the column to be added.

Adds a new column to the end of a collection, increasing the collection by 1.

Returns
The index of the newly added column.

◆ Add() [2/2]

int Add | ( | CXTPGridColumn * | pColumn,
 |  | BOOL | bSortIncreasing )

Adds a specified column to the end of the collection.

Parameters
pColumn | Pointer to the column to be added.
bSortIncreasing | TRUE if the column should be sorted in increasing order, FALSE if the column should be sorted in decreasing order.

Adds a new column to the end of a collection, increasing the collection by 1.

Returns
The index of the newly added column.

◆ DoPropExchange()

virtual void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Reads/writes column order settings to/from the provided archive stream.

Parameters
pPX Pointer to a CXTPPropExchange object to serialize to/from.

◆ GetAt()

CXTPGridColumn * GetAt ( int nIndex )

Retrieves the column item at a specified index in the collection.

Parameters
nIndex Index of the column to retrieve; must be greater than or equal to zero and less than the value returned by GetCount().
Returns
A pointer to the column item at the specified index if successful, or a NULL value if the specified index is less than zero or greater than the value returned by GetCount().

◆ GetCount()

int GetCount ( ) const

Gets the number of columns in the collection.

Returns
The number of columns in the collection.

◆ IndexOf()

int IndexOf ( const CXTPGridColumn * pColumn )

Retrieves the index of a column.

Parameters
pColumn Pointer to the column whose index must be retrieved.

Searches for the first occurrence of the specified column, beginning with the first index in the collection.

Returns
The index of the first occurrence of the specified column if successful, otherwise a value of -1.

◆ InsertAt()

int InsertAt | ( | int | nIndex,
 |  | CXTPGridColumn * | pColumn )

Inserts a specified column at a specified index.

Parameters
nIndex | Index to insert the column at.
pColumn | Pointer to the column to be inserted.
Returns
The index of the inserted column if successful, otherwise a value of -1.

◆ Remove()

void Remove ( CXTPGridColumn * pColumn )

Removes a specified column from the collection.

Parameters
pColumn Pointer to the column to be removed.

◆ RemoveAt()

void RemoveAt ( int nIndex )

Removes the column at a specified index from the collection.

Parameters
nIndex Index of the column to be removed.
The documentation for this class was generated from the following file:
  • XTPGridColumns.h


Toolkit Pro: CXTPGridColumns Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPGridColumns Class Reference

This class is a collection of grid column objects. More...

Inheritance diagram for CXTPGridColumns:
[legend]

Public Member Functions

CXTPGridColumns (CXTPGridControl *pControl)
Constructs a CXTPGridColumns object.
virtual | ~CXTPGridColumns ()
Destroys a CXTPGridColumns object.
int | GetCount () const
Retrieves the total number of column items in the collection.
void | Clear ()
Clears all column collection items.
int | GetVisibleColumnsCount () const
Retrieves the number of visible columns in the collection.
void | GetVisibleColumns (CXTPGridColumns &arrColumns) const
Retrieves all visible columns in the collection and places them within a referenced CXTPGridColumns array object.
CXTPGridColumn * | GetAt (int nIndex) const
Retrieves the column item at a specified index in the collection.
CXTPGridColumn * | GetVisibleAt (int nIndex) const
Retrieves the closest visible column to a specified index in the collection that appears at or before the specified index.
int | GetAtOffset (int nOffset, BOOL bFrozen) const
Retrieves the index of the column at a specified left offset.
int | GetOffset (int nIndex) const
Retrieves the left offset, in pixels, of the column at a specified index.
CXTPGridColumn * | GetIndentColumn () const
Gets the indentation column of this collection.
CXTPGridColumn * | Find (int nItemIndex) const
Finds a specified column by its item index/internal name.
CXTPGridColumn * | Find (const CString &strInternalName) const
Finds a specified column by its item index/internal name.
void | Add (CXTPGridColumn *pColumn)
Adds a specified column to the end of the collection.
void | Remove (CXTPGridColumn *pColumn)
Removes a specified column from the collection.
void | ResetSortOrder ()
Clears the sort order for all columns.
CXTPGridHeader * | GetGridHeader () const
Gets the associated grid header object.
int | ChangeColumnOrder (int nNewIndex, int nOldIndex)
Repositions a specified column in the collection.
int | IndexOf (const CXTPGridColumn *pColumn) const
Retrieves the index of a column.
void | InsertSortColumn (CXTPGridColumn *pColumn)
Inserts a specified column to the sort columns array according to the columns order of the group columns array.
void | SetSortColumn (CXTPGridColumn *pColumn, BOOL bIncreasing)
Sets a specified column as the sorted column and resets the previous sort order.
CXTPGridColumnOrder * | GetGroupsOrder () const
Gets the columns groups order array.
CXTPGridColumnOrder * | GetSortOrder () const
Gets the columns sort order array.
virtual void | DoPropExchange (CXTPPropExchange *pPX)
Reads/writes configuration to/from the provided archive stream.
CXTPGridColumn * | GetFirstVisibleColumn () const
Gets the first visible column in the collection.
CXTPGridColumn * | GetLastVisibleColumn () const
Gets the last visible column in the collection.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Attributes

CXTPGridColumnOrder * | m_pGroupsOrder
Container for the columns order in auto-grouping mode.
CXTPGridColumnOrder * | m_pSortOrder
Container for the columns sort order.
CArray< CXTPGridColumn *, CXTPGridColumn * > | m_arrColumns
Storage for column items.
CXTPGridControl * | m_pControl
Pointer to the associated Grid control object.
CXTPGridColumn * | m_pTreeColumn
Column containing tree view images.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

This class is a collection of grid column objects.

Each grid column object can be referred to by its zero-based index.

This class provides main operations to manipulate a list of columns: Adding/removing columns Showing columns header Working with field chooser Working with "group by" field (Re)Storing column settings To create a CXTPGridColumns object simply call its constructor with one parameter - the pointer to the parent Grid control object.

Constructor & Destructor Documentation

◆ CXTPGridColumns()

CXTPGridColumns ( CXTPGridControl * pControl )

Constructs a CXTPGridColumns object.

Parameters
pControl Pointer to the parent Grid control object.

◆ ~CXTPGridColumns()

virtual ~CXTPGridColumns ( )
virtual

Destroys a CXTPGridColumns object.

Handles cleanup and deallocation, including all of the objects presented in the list by calling the Clear() member function.

Member Function Documentation

◆ Add()

void Add ( CXTPGridColumn * pColumn )

Adds a specified column to the end of the collection.

Parameters
pColumn Pointer to the column to be added.

Adds a new column to the end of a collection, increasing the collection by 1.

◆ ChangeColumnOrder()

int ChangeColumnOrder | ( | int | nNewIndex,
 |  | int | nOldIndex )

Repositions a specified column in the collection.

Parameters
nNewIndex | New index of the column.
nOldIndex | Old index of the column.
Returns
The new index of the column if successful, otherwise a value of -1.

◆ DoPropExchange()

virtual void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Reads/writes configuration to/from the provided archive stream.

Parameters
pPX Pointer to a CXTPPropExchange object to serialize to/from.

◆ Find() [1/2]

CXTPGridColumn * Find ( const CString & strInternalName ) const

Finds a specified column by its item index/internal name.

Parameters
strInternalName Internal name of the column to find.

Searches the collection sequentially to find the first column matching the specified column's item index/internal name.

Returns
A pointer to the found column if successful, otherwise NULL.

◆ Find() [2/2]

CXTPGridColumn * Find ( int nItemIndex ) const

Finds a specified column by its item index/internal name.

Parameters
nItemIndex Item index of the column to find.

Searches the collection sequentially to find the first column matching the specified column's item index/internal name.

Returns
A pointer to the found column if successful, otherwise NULL.

◆ GetAt()

AFX_INLINE CXTPGridColumn * GetAt ( int nIndex ) const

Retrieves the column item at a specified index in the collection.

Parameters
nIndex Index of the column to retrieve; must be greater than or equal to zero and less than the value returned by GetCount().
Returns
A pointer to the column item at the specified index if successful, or a NULL value if the specified index is less than zero or greater than the value returned by GetCount().

◆ GetAtOffset()

int GetAtOffset | ( | int | nOffset,
 |  | BOOL | bFrozen ) const

Retrieves the index of the column at a specified left offset.

Parameters
nOffset | Left offset, in pixels, of the column to retrieve the index of.
bFrozen | TRUE to count frozen columns, FALSE to not count frozen columns.
Returns
The index of the column at the specified left offset.

◆ GetCount()

AFX_INLINE int GetCount ( ) const

Retrieves the total number of column items in the collection.

Returns
The total number of column items in the collection.

◆ GetFirstVisibleColumn()

CXTPGridColumn * GetFirstVisibleColumn ( ) const

Gets the first visible column in the collection.

Returns
A pointer to the first visible column in the collection.
See also
GetLastVisibleColumn

◆ GetGridHeader()

CXTPGridHeader * GetGridHeader ( ) const

Gets the associated grid header object.

Returns
A pointer to the associated grid header object.

◆ GetGroupsOrder()

AFX_INLINE CXTPGridColumnOrder * GetGroupsOrder ( ) const

Gets the columns groups order array.

Returns
A pointer to the columns groups order array.

◆ GetIndentColumn()

AFX_INLINE CXTPGridColumn * GetIndentColumn ( ) const

Gets the indentation column of this collection.

Returns
A pointer to the indentation column of this collection.

Indentation columns are used to represent the ends of column collections. An indentation column is usually the first column in the list.

◆ GetLastVisibleColumn()

CXTPGridColumn * GetLastVisibleColumn ( ) const

Gets the last visible column in the collection.

Returns
A pointer to the last visible column in the collection.
See also
GetFirstVisibleColumn

◆ GetOffset()

int GetOffset ( int nIndex ) const

Retrieves the left offset, in pixels, of the column at a specified index.

Parameters
nIndex Index of the column to retrieve the left offset of (i.e. this value should include frozen and non-frozen columns).
Returns
The left offset, in pixels, of the column at the specified index.

◆ GetSortOrder()

AFX_INLINE CXTPGridColumnOrder * GetSortOrder ( ) const

Gets the columns sort order array.

Returns
A pointer to the columns sort order array.

◆ GetVisibleAt()

CXTPGridColumn * GetVisibleAt ( int nIndex ) const

Retrieves the closest visible column to a specified index in the collection that appears at or before the specified index.

Parameters
nIndex Index of a column in the collection; must be greater than or equal to zero and less than the value returned by GetCount().
Returns
A pointer to the closest visible column to the specified index in the collection that appears at or before the specified index, or a NULL value if either a visible column is not found or the specified index is less than zero or greater than the value returned by GetCount().

◆ GetVisibleColumns()

void GetVisibleColumns ( CXTPGridColumns & arrColumns ) const

Retrieves all visible columns in the collection and places them within a referenced CXTPGridColumns array object.

Parameters
arrColumns Reference to a CXTPGridColumns array object.

The referenced CXTPGridColumns array object will be filled with all visible columns in the collection.

◆ GetVisibleColumnsCount()

int GetVisibleColumnsCount ( ) const

Retrieves the number of visible columns in the collection.

Unlike the GetCount() member function, this function only returns the count of columns whose visibility property is set to TRUE.

Returns
The number of visible columns in the collection.

◆ IndexOf()

int IndexOf ( const CXTPGridColumn * pColumn ) const

Retrieves the index of a column.

Parameters
pColumn Pointer to the column whose index must be retrieved.

Searches for the first occurrence of the specified column, beginning with the first index in the collection.

Returns
The index of the first occurrence of the specified column if successful, otherwise a value of -1.

◆ InsertSortColumn()

void InsertSortColumn ( CXTPGridColumn * pColumn )

Inserts a specified column to the sort columns array according to the columns order of the group columns array.

Parameters
pColumn Pointer to the column to be inserted.

◆ Remove()

void Remove ( CXTPGridColumn * pColumn )

Removes a specified column from the collection.

Parameters
pColumn Pointer to the column to be removed.

◆ SetSortColumn()

void SetSortColumn | ( | CXTPGridColumn * | pColumn,
 |  | BOOL | bIncreasing )

Sets a specified column as the sorted column and resets the previous sort order.

Parameters
pColumn | Pointer to the column to be set.
bIncreasing | TRUE if the column should be sorted in increasing order, FALSE if the column should be sorted in decreasing order.
The documentation for this class was generated from the following file:
  • XTPGridColumns.h


Toolkit Pro: CXTPGridControl Class Reference

Classes | Public Member Functions | Static Public Member Functions | Public Attributes | Protected Member Functions | Static Protected Member Functions | Protected Attributes | List of all members
CXTPGridControl Class Reference

The CXTPGridControl class provides an implementation of the Grid control. More...

Inheritance diagram for CXTPGridControl:
[legend]

Classes

class CUpdateContext
Internal grid update helper. More...

Public Member Functions

CXTPGridControl ()
Constructs a CXTPGridControl object.
virtual | ~CXTPGridControl ()
Destroys a CXTPGridControl object, handles cleanup and deallocation.
BOOL | Create (DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID, CCreateContext *pContext=NULL)
This method is called to create a Grid control.
virtual void | SerializeState (CArchive &ar)
(Re)Stores control configuration to/from the provided archive stream.
virtual void | DoPropExchange (CXTPPropExchange *pPX)
Reads/writes configuration to/from the provided data source.
CXTPGridColumn * | AddColumn (CXTPGridColumn *pColumn)
Adds a specified column to the end of the columns array.
virtual CXTPGridRecord * | AddRecord (CXTPGridRecord *pRecord)
Adds a specified data record to the records collection.
virtual void | AddRecordEx (CXTPGridRecord *pRecord, CXTPGridRecord *pParentRecord=NULL, int nRowChildIndex=-1, int nRecordChildIndex=-1)
Adds a specified data record to the records collection and associates a row with it.
virtual BOOL | RemoveRecordEx (CXTPGridRecord *pRecord, BOOL bAdjustLayout=TRUE, BOOL bRemoveFromParent=TRUE)
Removes a specified record, the row associated with the specified record, and all child records and rows.
virtual BOOL | RemoveRowEx (CXTPGridRow *pRow, BOOL bAdjustLayout=TRUE)
Removes a specified row, the record associated with the specified row, and all child rows and records.
virtual void | UpdateRecord (CXTPGridRecord *pRecord, BOOL bUpdateChildren)
Updates a specified record.
void | BeginUpdate ()
Prevents the Grid control from being redrawn until the EndUpdate method is called.
void | ResetContent (BOOL bUpdateControl=TRUE)
Deletes all rows and records from the Grid control.
void | EndUpdate ()
Resumes drawing of the Grid control after drawing has been suspended by the BeginUpdate method.
int | GetLockUpdateCount () const
void | RedrawControl ()
Initiates Grid control redrawing.
CXTPToolTipContext * | GetToolTipContext () const
Gets the tooltip context.
CLIPFORMAT | EnableDragDrop (LPCTSTR lpszClipboardFormat, DWORD dwFlags, DWORD dwDropMarkerFlags=xtpGridDropBetween)
Call this method to enable built in drag and drop operations.
void | SetDropMarkerFlags (DWORD dwDropMarkerFlags)
Sets the drop marker flags.
DWORD | GetDropMarkerFlags () const
Gets the drop marker flags.
void | SetGridStyle (XTPGridOrientation orientation, XTPGridGridStyle gridStyle)
Sets the grid drawing style.
XTPGridGridStyle | GetGridStyle (XTPGridOrientation orientation) const
Gets the grid drawing style.
COLORREF | SetGridColor (COLORREF clrGridLine)
Sets the grid line color.
CXTPGridColumns * | GetColumns () const
Gets the collection of grid columns.
CXTPGridPaintManager * | GetPaintManager () const
Gets the paint manager object used to draw the Grid control window.
void | SetPaintManager (CXTPGridPaintManager *pPaintManager)
Sets the paint manager object used to draw the Grid control window.
CXTPGridNavigator * | GetNavigator () const
Gets the navigator object used for cell navigation by the Grid control.
virtual void | Populate ()
Performs control population, creating a view from the data.
virtual void | PopulateHeaderRows ()
Performs control's header rows population, creating a view from the data.
virtual void | PopulateFooterRows ()
Performs control's footer rows population, creating a view from the data.
void | EnsureVisible (CXTPGridRow *pRow)
Ensures that a Grid control row is at least partially visible.
void | EnsureVisible (CXTPGridColumn *pCheckColumn)
Ensures that a Grid control column is at least partially visible.
virtual BOOL | HitTest (CPoint pt, CXTPGridHitTestInfo *pInfo) const
Determines which grid part is at a specified point.
CXTPGridRow * | HitTest (CPoint pt) const
Determines which grid row is at a specified point, if any.
CXTPGridSelectedRows * | GetSelectedRows () const
Gets the collection of selected rows.
CXTPGridRow * | GetFocusedRow () const
Gets the currently focused row in the Grid control's view.
BOOL | SetFocusedRow (CXTPGridRow *pRow, BOOL bControlKey=FALSE)
Sets the currently focused row in the Grid control's view.
BOOL | SetFocusedRow (CXTPGridRow *pRow, BOOL bShiftKey, BOOL bControlKey)
Sets the currently focused row in the Grid control's view.
BOOL | SetFocusedRow (BOOL bEnsureVisible, CXTPGridRow *pRow, BOOL bShiftKey, BOOL bControlKey)
Sets the currently focused row in the Grid control's view.
int | GetGridAreaRows (int nStartRow, BOOL bMoveDown)
Calculates the number of visible rows between a specified row and the bottom/top of the current view.
void | SetTopRow (int nIndex)
Sets the top row of the Grid control view.
int | GetTopRowIndex () const
Gets the index of the top row of the Grid control view.
void | SetScrollOffsetH (int nOffset)
Sets the horizontal scroll position.
void | SetScrollOffsetV (int nOffset)
Sets the vertical scroll position.
void | SetLayoutRTL (BOOL bRightToLeft)
Sets right-to-left (RTL) mode.
BOOL | IsLayoutRTL ()
Determines if right-to-left (RTL) mode was set.
void | EnablePreviewMode (BOOL bIsPreviewMode)
Enables/disables preview mode for the control.
BOOL | IsPreviewMode () const
Determines if preview mode is enabled/disabled for the control.
void | ShowGroupBy (BOOL bEnable=TRUE)
Sets the visible state of the Group By area.
BOOL | IsGroupByVisible () const
Gets the visible state of the Group By area.
void | ShowHeader (BOOL bShow=TRUE)
Sets the visible state of column headers.
BOOL | IsHeaderVisible () const
Gets the visible state of column headers.
void | ShowFooter (BOOL bShow=TRUE)
Sets the visible state of column footers.
BOOL | IsFooterVisible () const
Gets the visible state of column footers.
void | ShadeGroupHeadings (BOOL bEnable=TRUE)
Enables/disables group items shading.
BOOL | IsShadeGroupHeadingsEnabled () const
Determines if group items shading is enabled/disabled.
void | SetGroupRowsBold (BOOL bBold=TRUE)
Sets the group rows text style: bold or normal.
BOOL | IsGroupRowsBold () const
Gets the group rows text style: bold or normal.
int | GetFreezeColumnsCount () const
Gets the number of frozen columns starting from the left hand side.
int | GetFreezeColumnsCount (int &nLastIndex) const
Gets the number of frozen columns starting from the left hand side.
int | GetFreezeColumnsIndex () const
Gets the index of the rightmost frozen column.
void | SetFreezeColumnsCount (int nCount, BOOL bReserved=FALSE)
Sets the number of frozen columns.
int | GetDisableReorderColumnsCount () const
Gets the number of columns at the left side where reordering is disabled.
void | SetDisableReorderColumnsCount (int nCount)
Sets the number of columns at the left side where reordering is disabled.
BOOL | IsFullColumnScrolling () const
Gets the horizontal scrolling mode.
void | SetFullColumnScrolling (BOOL bSet)
Sets the horizontal scrolling mode.
void | ReleaseItem (int nIndex)
Call this method to remove all items and column in specified position.
void | PinFooterRows (BOOL bPin=FALSE)
Specifies if footer records are pinned to the last body row.
BOOL | IsFooterRowsPinned () const
Determines if footer records are pinned to the last body row.
void | PinFooterRowsPrinted (BOOL bPin=FALSE)
Specifies if footer records are pinned to the last body row.
BOOL | IsFooterRowsPinnedPrinted () const
Determines if footer records are pinned to the last body row.
void | EnableMarkup (BOOL bEnable=TRUE)
Call this method to enable Markup for records.
CXTPMarkupContext * | GetMarkupContext () const
Gets the Markup context.
CXTPImageManager * | GetImageManager () const
Gets the image manager of the Grid control.
void | SetImageManager (CXTPImageManager *pImageManager)
Sets the image manager for the Grid control.
void | SetImageList (CImageList *pImageList)
Sets the image list for the paint manager.
CXTPGridHeader * | GetGridHeader () const
Gets the associated grid header object.
void | SetGridHeader (CXTPGridHeader *pGridHeader)
Sets the associated grid header object.
int | GetIndent (int nLevel) const
Calculates the indentation, in pixels, for a tree view row of a specified depth level.
LRESULT | SendMessageToParent (CXTPGridRow *pRow, CXTPGridRecordItem *pItem, CXTPGridColumn *pColumn, UINT nMessage, CPoint *pPoint, int nHyperlink=-1) const
Notifies the parent control about an event that occurred.
LRESULT | SendNotifyMessage (UINT nMessage, NMHDR *pNMHDR=NULL) const
Sends a specified message to the window.
void | CollapseAll ()
Collapses all rows.
void | ExpandAll (BOOL bRecursive=FALSE)
Expands all rows.
BOOL | IsMultipleSelection () const
Determines if multiple selections is enabled/disabled for the Grid control.
void | SetMultipleSelection (BOOL bMultipleSelection)
Enables/disables multiple selections for the Grid control.
BOOL | IsMultiSelectionMode () const
Determines if multi-selection mode is enabled/disabled for the Grid control.
void | SetMultiSelectionMode (BOOL bMultiSelectionMode)
Enables/disables multi-selection mode for the Grid control.
void | EnableToolTips (BOOL bEnable)
Enables/disables showing tooltips for the Grid control window.
void | SkipGroupsFocus (BOOL bSkipFocus)
Specifies if groups are skipped when navigating the Grid control by using the Up and Down keys.
BOOL | IsSkipGroupsFocusEnabled () const
Determines if groups are skipped when navigating the Grid control by using the Up and Down keys.
int | GetHeaderIndent () const
Gets the indentation of the header.
virtual void | AdjustScrollBars ()
Adjusts scrollbars depending on currently visible rows.
virtual void | AdjustLayout ()
Adjusts main control areas depending on current control size.
CXTPGridColumn * | GetFocusedColumn () const
Gets the selected column.
BOOL | SetFocusedColumn (CXTPGridColumn *pColumn)
Sets the selected column.
void | SetSelectionState (int index, int state)
Sets the selection state of a row.
void | EnsureFocusedRowVisible (BOOL bEnsureFocusedRowVisible)
Specifies if the visibility of focused rows should be ensured.
BOOL | IsEnsureFocusedRowVisible () const
Determines if the visibility of focused rows is ensured.
void | FocusSubItems (BOOL bFocusSubItems)
Specifies if each individual record item in a row should receive focus when an item in the row is clicked.
BOOL | IsFocusSubItems () const
Determines if each individual record item in a row receives focus when an item in the row is clicked.
void | EditOnClick (BOOL bEditOnClick)
Specifies if a CXTPGridRecordItem should become editable after being single-clicked.
BOOL | IsEditOnClick () const
Determines if a CXTPGridRecordItem becomes editable after being single-clicked.
void | EditOnDelayClick (BOOL bEditOnDelayClick)
Enables/disables the Delay Click Edit feature.
BOOL | IsEditOnDelayClick () const
Determines if the Delay Click Edit feature is enabled/disabled.
void | EditOnDoubleClick (BOOL bEditOnClick)
Specifies if a CXTPGridRecordItem should become editable after being double-clicked.
BOOL | IsEditOnDoubleClick () const
Determines if a CXTPGridRecordItem becomes editable after being double-clicked.
int | GetLastRqstEditRow () const
Gets the index of the most recent row that was requested for editing.
int | GetLastRqstEditCol () const
Gets the index of the most recent column that was requested for editing.
void | SetLastRqstEdit (int iRqstEditRow, int iRqstEditCol)
Sets an arbitrary index for both the most recent row and most recent column that was requested for editing.
void | EnsureStopLastRqstTimer ()
Stops the last request timer used for delay edit.
void | StartLastRqstTimer ()
Starts the last request timer used for delay edit.
UINT_PTR | GetDelayEditTimer () const
Gets the ID of the delay edit timer.
void | EnsureStopDelayEditTimer ()
Stops the delay edit timer.
void | StartDelayEditTimer ()
Starts the delay edit timer.
void | SetAutoCheckItems (BOOL bAutoCheck)
Enables/disables auto-check mode for checkbox items.
BOOL | IsAutoCheckItems () const
Determines if auto-check mode is enabled/disabled for checkbox items.
void | EditItem (XTP_GRIDRECORDITEM_ARGS *pItemArgs)
Edits a grid cell by focusing the specified cell and starting in-place editing for the control specified there.
CXTPGridInplaceEdit * | GetInplaceEdit () const
Gets the in-place edit control.
CXTPGridInplaceButtons * | GetInplaceButtons () const
Gets the collection of in-place buttons of the Grid control.
CXTPGridInplaceList * | GetInplaceList () const
Gets the in-place list of Grid controls.
BOOL | HasFocus () const
Determines if the Grid control has focus.
CXTPGridRecordItem * | GetActiveItem () const
Gets the active item (i.e.
CXTPGridRecordItem * | GetFocusedRecordItem () const
Gets the focused item.
void | SetTreeIndent (int nIndent)
Sets the indentation before the text of each child node in a hierarchical tree structure.
void | SetVirtualMode (CXTPGridRecord *pVirtualRecord, int nCount, int nFields=0)
Call this method to enable virtual mode of the control.
BOOL | IsVirtualMode () const
Determines if virtual mode is enabled/disabled.
virtual CString | GetFilterText ()
Gets the filter text of the control.
virtual void | SetFilterText (LPCTSTR strFilterText)
Sets the filter text for the control.
virtual BOOL | IsFilterHiddenColumns () const
Determines if search filter text is enabled/disabled in hidden columns.
virtual void | SetFilterHiddenColumns (BOOL bFilterHidden)
Enables/disables search filter text in hidden columns.
void | SetRecordsTreeFilterMode (int nMode)
Sets the filtering mode for the record tree.
int | GetRecordsTreeFilterMode () const
Gets the filtering mode of the record tree.
BOOL | RegisterWindowClass (HINSTANCE hInstance=NULL)
Registers the window class if it has not already been registered.
virtual BOOL | CanCut ()
Determines if the Cut operation is possible in the current context (i.e.
virtual BOOL | CanCopy ()
Determines if the Copy operation is posssible in the current context (i.e.
virtual BOOL | CanPaste ()
Determines if the Paste operation is possible in the current context (i.e.
virtual void | Cut ()
Copies the selected record data (in the binary and/or text data formats) to the clipboard and deletes the selected record data.
virtual void | Copy ()
Copies the selected record data (in the binary and/or text data formats) to the clipboard.
virtual void | Paste ()
Reads records from the clipboard and adds them to the records collection (the binary data format is used rather than the text data format).
virtual BOOL | IsEditMode ()
Determines if the in-place edit control is active (i.e.
virtual void | SetRowsCompareFunc (XTPGridRowsCompareFunc pCompareFunc)
Sets the compare function used to compare (and sort) rows.
BOOL | IsSortRecordChilds () const
Determines if the sort order is applied to record children.
void | SetSortRecordChilds (BOOL bSortRecordChildren)
Specifies if the sort order should be applied to record children.
int | GetHScrollStep () const
Gets the horizontal scrolling step.
void | SetHScrollStep (int nStep)
Sets the horizontal scrolling step.
UINT | GetAutoVScrollTimerResolution () const
Gets the vertical scrolling timer resolution.
void | SetAutoVScrollTimerResolution (UINT nNewTimerResolution)
Sets the vertical scrolling timer resolution.
BOOL | IsPreviewAllowEdit () const
Determines if preview editing is enabled/disabled.
void | PreviewAllowEdit (BOOL bAllowEdit)
Enables/disables preview editing.
BOOL | IsLockExpand () const
Determines if the user's ability to collapse/expand rows is locked.
void | LockExpand (BOOL bLockExpand)
Specifies if the user's ability to collapse/expand rows should be locked.
void | Recalc (BOOL bAll=FALSE)
Recalculates and redraws rows.
void | EnableDoubleBuffering (BOOL bEnable)
Enables/disables double-buffering.
BOOL | IsDoubleBuffering () const
Determines if double-buffering is enabled/disabled.
BOOL | IsInitialSelectionEnabled () const
Determines if initial selection is enabled/disabled.
void | InitialSelectionEnable (BOOL bEnable)
Enables/disables initial selection.
BOOL | IsRowFocusVisible () const
Determines if row focus is shown.
void | ShowRowFocus (BOOL bShow)
Specifies if row focus should be shown.
int | GetWatermarkAlignment () const
Gets the watermark alignment.
void | SetWatermarkAlignment (int nWatermarkAlignment)
Sets the watermark alignment.
void | DrawWatermark (CDC *pDC, CRect rcWatermark, CRect rcClient)
Draws a watermark.
CRect | GetElementRect (XTPGridElementRect nElement) const
Retrieves a specified grid element rectangle.
CXTPGridDataManager * GetDataManager ()
Gets the grid data manager.
void | SetMouseMode (XTPGridMouseMode nMode)
Sets the control mouse mode.
XTPGridMouseMode | GetMouseMode () const
Gets the control mouse mode.
virtual HBITMAP | GetWatermarkBitmap () const
Gets the watermark bitmap to be shown in the Grid control background.
virtual BOOL | SetWatermarkBitmap (HBITMAP hBitmap, BYTE Transparency)
Sets the watermark bitmap to be shown in the Grid control background.
virtual BOOL | SetWatermarkBitmap (LPCTSTR szPath, BYTE Transparency)
Sets the watermark bitmap to be shown in the Grid control background.
virtual CXTPGridColumn * | GetNextFocusableColumn (CXTPGridRow *pRow, int nColumnIndex, int nDirection)
Gets the next focusable column.
void | ShowIconWhenEditing (BOOL bShow)
Specifies if item icons should be shown while the item is being edited.
BOOL | IsShowIconWhenEditing ()
Determines if item icons are shown while the item is being edited.
void | SetFastDeselectMode (BOOL bFastDeselect=TRUE)
Enables/disables Fast Deselect mode (like in Windows Explorer).
void | SetIconColumn (CXTPGridColumn *pColumn)
Sets a column to be an icon view column.
void | CreateIconColumn (BOOL bUseColumnForNum=FALSE, int nWidth=40)
Creates a column as an icon view column and specifies if the column may be reused as a number column in the grid view.
void | AssignIconViewPropNumAndIconNum (int nCol=0, int nIcon=0, BOOL bUseColumnForNum=FALSE, int nWidth=20)
Creates a column as an icon view column and specifies if the column may be reused as a number column in the grid view.
void | SetIconView (BOOL bIconView=TRUE)
Toggles between Icon View mode and Grid View mode.
BOOL | IsIconView () const
Determines if Icon View mode is active.
int | GetRowsPerLine () const
Gets the number of rows per line.
int | GetNumRowsOnLine (int iTotalWidth) const
Gets the number of rows on a line of abitrary width.
void | SetNavigator (CXTPGridNavigator *pNavigator)
Sets the grid navigator.
void | ShowRowNumber (BOOL bSet)
Specifies if the row number should be shown.
BOOL | IsShowRowNumber ()
Determines if the row number is shown.
BOOL | SetCellText (int row, int col, CString sText)
Sets the text for a specified cell.
BOOL | SetCellFormula (int row, int col, CString sFormula)
Sets the formula for a specified cell.
void | UnselectGroupRows ()
Deselects all group rows.
void | ReleaseSorted ()
Releases all sorted items and clears memory.
int | GetLeftOffset () const
Gets the horizontal scroll position.
BOOL | IsDragMode () const
assessors for m_bDragMode
int | GetDragSensitivityX () const
Gets the horizontal sensitivity of Drag'n'Drop operations.
void | SetDragSensitivityX (int nDragSensitivityX)
Sets the horizontal sensitivity of Drag'n'Drop operations.
int | GetDragSensitivityY () const
Gets the vertical sensitivity of Drag'n'Drop operations.
void | SetDragSensitivityY (int nDragSensitivityY)
Sets the vertical sensitivity of Drag'n'Drop operation.
void | SetIconViewToDefaults ()
Resets the icon view column to its default values.
XTPGridScrollMode | GetScrollMode (XTPGridOrientation orientation) const
Gets the scroll mode.
void | SetScrollMode (XTPGridOrientation orientation, XTPGridScrollMode scrollMode)
Sets the scroll mode.
CXTPGridSections * | GetSections () const
Gets the sections collection.
virtual BOOL | IsCellMergingAllowed () const
Determines if cell merging is allowed.

Static Public Member Functions

static BOOL AFX_CDECL | UseGridCustomHeap ()
Call this function to use the custom heap feature.
static BOOL AFX_CDECL | UseRowBatchAllocation ()
Call this function to enable the batch allocation feature for grid rows.
static void AFX_CDECL | FreeRowBatchExtraData ()
This function is used when row batch allocation is enabled to both check all allocated blocks and deallocate any blocks which are completely free.

Public Attributes

BOOL | m_bThemeMetrics
TRUE to allow themes to override control metrics.
BOOL | m_bMovePivot
Tells whether the freeze column is displayed or not when columns are added to the group by box.
BOOL | m_bStrictFiltering
Tells whether strict filtering is enabled or not.
BOOL | m_bForcePagination
Specifies whether to force the grid to be split up into "pages" while in print preview mode.
BOOL | m_bSelectionExcludeGroupRows
TRUE if the selection excludes group rows.
XTPGridInputState | m_mouseDownState
MouseDown state.
CXTPGridRow * | m_pHotExpandButtonRow
Row with hot expand button.
CXTPGridHyperlink * | m_pHotHyperlink
Hot hyperlink.
int | m_iIconWidth
Icon geometry settings.
int | m_iIconHeight
Icon geometry settings.
int | m_iIconWidthSpacing
Icon geometry settings.
int | m_iIconHeightSpacing
Icon geometry settings.
int | m_iIconPropNum
Icon view setting.
int | m_iIconNum
Icon view setting.
BOOL | m_bMarkupEnabled
Flag to check markup settings.
int | m_iIconViewColumn
Icon view setting.
BOOL | m_bIconColumnIndexNotValid
Used to indicate icon column is created, but does not yet have a valid index.
BOOL | m_bStrictBestFit
TRUE to use BestFit only for non-autosize mode.
BOOL | m_bWasShiftKey
Flag set on MouseUp or KeyUp if Shift key was On.
BOOL | m_bSortedDragDrop
Flag to set Drag Drop mode like Vista Windows Explorer or XP Windows Explorer.
BOOL | m_bTrapTabKey
Flag to set Trap Tab key in m_bEditOnClick && m_bAllowEdit case.
BOOL | m_bDesktopTrackerMode
Flag to set Vista Tracker Mode On or Off.
BOOL | m_bUnrestrictedDragDrop
TRUE to allow a child to be dropped to any pos; default = FALSE.
BOOL | m_bFreeHeightMode
Flag to set RC Free Height Mode.
int | m_nDefaultRowFreeHeight
Row height for initialization.
CString | m_sCustomTitle
Used for a unique title (e.g.
BOOL | m_bRClickDrag
TRUE to allow drag on right click.
BOOL | m_bKeepSelectionAfterSort
TRUE to keep the selection after sorting items.
int | m_iColumnForNum
Index of the row number column used.

Protected Member Functions

virtual void | OnDraw (CDC *pDC)
Performs all drawing logic.
virtual int | DrawRows (CDC *pDC, CRect &rcClient, int y, CXTPGridRows *pRows, int nTopRow, int nColumnFrom, int nColumnTo, int *pnHeight=NULL)
Draws all rows in the provided device context.
virtual void | DrawNoItems (CDC *pDC, const CRect &rcClient)
Draws the 'NoItems' text in the provided device conext.
BOOL | IsChanged () const
Determines if the internal control state was changed since the last drawing.
void | SetChanged (BOOL bChanged=TRUE)
Specifies if the internal control state was changed since the last drawing.
virtual void | ReSortRows ()
Re-sorts the rows tree according to the sort order for columns.
void | UpdateSubList ()
Updates the field chooser control with its content.
virtual int | InsertRow (int nIndex, CXTPGridRow *pRow)
Inserts a specified row at a specified index in the rows array.
virtual BOOL | ApplyFilter (CXTPGridRecord *pRecord, CString strFilterText, BOOL bIncludePreview)
Checks a record for filter text.
virtual void | OnSelectionChanged ()
This member function is called after a user selects a row or a column.
virtual BOOL | OnFocusChanging (CXTPGridRow *pNewRow, CXTPGridColumn *pNewCol)
This member function is called before the focus changes.
virtual void | GetItemMetrics (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pItemMetrics)
Calculates metrics for a row.
virtual CXTPGridRow * | CreateRow ()
Creates a CXTPGridRow object.
virtual CXTPGridGroupRow * | CreateGroupRow ()
Creates a CXTPGridGroupRow object.
virtual CXTPGridRow * | CreateHeaderFooterRow ()
Creates a CXTPGridRow object for header/footer rows.
virtual void | OnBeginDrag (CPoint point)
This method is called when the user begins dragging a row.
virtual void | OnBeginDrag (CPoint point, UINT nFlags)
This method is called when the user begins dragging a row.
virtual BOOL | OnBeforeCopyToText (CXTPGridRecord *pRecord, CStringArray &rarStrings)
This method is called before a record is copied to the clipboard in text format.
virtual BOOL | OnBeforePasteFromText (CStringArray &arStrings, CXTPGridRecord **ppRecord)
This method is called before creating a new record using text data from the clipboard.
virtual BOOL | OnBeforePaste (CXTPGridRecord **ppRecord)
This method is called after creating a new record using binary data from the clipboard, but before adding it to records collection.
virtual BOOL | OnPreviewKeyDown (UINT &rnChar, UINT nRepCnt, UINT nFlags)
This method is called before processing the OnKeyDown event.
virtual int | OnGetColumnDataBestFitWidth (CXTPGridColumn *pColumn)
This method is used by the Grid control to calculate the best-fit column width.
virtual int | OnGetItemsCaptionMaxWidth (CDC *pDC, CXTPGridRows *pRows, CXTPGridColumn *pColumn, int nStartRow=0, int nRowsCount=-1)
This method is used by the Grid control to calculate the items captions maximum width.
virtual void | EnsureStartAutoVertScroll ()
This method is used to start monitoring mouse position for automatic vertical scrolling.
virtual void | EnsureStopAutoVertScroll ()
This method is used to stop monitoring mouse position for automatic vertical scrolling.
virtual void | DoAutoVertScrollIfNeed (CPoint ptClick, CPoint pt)
This method is used to monitor mouse position.
virtual int | GetRowsHeight (CXTPGridRows *pRows, int nTotalWidth, int nMaxHeight=-1)
Calculates the combined height of all rows within a specified rows collection.
virtual BOOL | OnConstraintSelecting (CXTPGridRow *pRow, CXTPGridRecordItem *pItem, CXTPGridColumn *pColumn, CXTPGridRecordItemConstraint *pConstraint)
This method is used to notify about changes to the constraint selection.
virtual const XTP_NM_GRIDTOOLTIPINFO & | OnGetToolTipInfo (CXTPGridRow *pRow, CXTPGridRecordItem *pItem, CString &rstrToolTipText)
This method is called to get the tooltip text for the current record item.
void | AdjustIndentation ()
Adjusts control indentation properties depending on the current tree depth.
virtual DROPEFFECT | OnDragOver (COleDataObject *pDataObject, DWORD dwKeyState, CPoint point, int nState)
This member is called when an item is dragged over the Grid control.
virtual BOOL | OnDrop (COleDataObject *pDataObject, DROPEFFECT dropEffect, CPoint point)
This member is called when an item has been dropped into the Grid control.
virtual void | RelayToolTipEvent (UINT message)
Relays a tooltip event.

Static Protected Member Functions

static UINT AFX_CDECL GetMouseScrollLines ()
Gets the number of rows per mouse scroll.

Protected Attributes

BOOL | m_bDoubleBuffering
Enables double-buffering.
BOOL | m_bChanged
Internal member for storing changed flag.
BOOL | m_bInternalMove
Internal member for storing DD run-time flag.
int | m_nLockUpdateCount
A counter of the update locks.
CRect | m_rcGroupByArea
The area occupied by Group By item.
CRect | m_rcHeaderArea
The area occupied by the header.
CRect | m_rcFooterArea
The area occupied by the footer.
CXTPGridColumns * | m_pColumns
List columns container.
CXTPGridRows * m_pRows
Virtual list rows container.
CXTPGridHeader * | m_pGridHeader
List header member.
CXTPMarkupContext * | m_pMarkupContext
Markup context.
CXTPGridPaintManager * | m_pPaintManager
Paint manager.
CXTPGridNavigator * | m_pNavigator
Navigator.
XTPGridScrollUpdateMode | m_scrollUpdateMode
Scroll update mode.
XTPGridScrollMode | m_scrollModeH
Horizontal scroll mode.
XTPGridScrollMode | m_scrollModeV
Vertical scroll mode.
int | m_nScrollOffsetH
Horizontal scroll position.
int | m_nScrollStepH
Horizontal scroll step (in pixels).
int | m_nScrollStepV
Vertical scroll step (in pixels).
int | m_nDisableReorderColumnsCount
Count of columns at the left side where reordering is disabled.
CXTPGridSelectedRows * | m_pSelectedRows
Container for the currently selected rows.
CXTPGridRow * | m_pHotRow
Hot row.
int | m_nRowsPerWheel
Amount of rows to scroll by mouse wheel.
CXTPGridTip * | m_pTip
Tip window.
CBitmap | m_bmpCache
Cached window bitmap.
BOOL | m_bGroupByEnabled
TRUE if Group By box is enabled.
BOOL | m_bSortRecordChilds
TRUE to apply sort order for record children.
XTPGridMouseMode | m_mouseMode
Current mouse operation mode.
BOOL | m_bBlockSelection
TRUE if multiple selection is enabled.
BOOL | m_bMultiSelectionMode
TRUE if multi-selection mode is enabled (i.e.
BOOL | m_bShowTooltips
TRUE if show tooltips is enabled.
BOOL | m_bAutoCheckItems
TRUE to enable auto-check mode, FALSE to disable auto-check mode.
CXTPImageManager * | m_pImageManager
Image list for the Grid control.
BOOL | m_bSkipGroupsFocus
TRUE if group rows are skipped when navigating rows with the Up and Down arrow keys.
BOOL | m_bLockExpand
TRUE if collapsing/expanding rows is locked.
BOOL | m_bEnsureFocusedRowVisible
TRUE if focused rows will be forced visible.
BOOL | m_bFocusSubItems
TRUE if sub-items can receive focus.
BOOL | m_bEditOnClick
TRUE if sub-items become editable on a single-click.
BOOL | m_bEditOnDelayClick
TRUE if sub-items become editable on a delay-click.
BOOL | m_bEditOnDoubleClick
TRUE if sub-items become editable on a double-click.
BOOL | m_bPreviewAllowEdit
TRUE if the preview of the row can be edited.
BOOL | m_bHeaderVisible
TRUE if column headers are visible.
BOOL | m_bFooterVisible
TRUE if column footers are visible.
BOOL | m_bPinFooterRows
TRUE if footer rows are drawn immediately after the body rows.
BOOL | m_bPinFooterRowsPrinted
TRUE if footer rows are printed immediately after the body rows.
BOOL | m_bInitialSelectionEnable
TRUE if Initial (in Populate() call) selection is enabled.
BOOL | m_bRowFocusVisible
TRUE if showing focused row rectangle is enabled.
CXTPGridColumn * | m_pFocusedColumn
Pointer to the currently focused CXTPGridColumn.
CXTPToolTipContext * | m_pToolTipContext
Tooltip context.
CXTPGridRecordItem * | m_pActiveItem
Pointer to the currently focused CXTPGridRecordItem.
CXTPGridInplaceEdit * | m_pInplaceEdit
In-place edit pointer.
CXTPGridInplaceButtons * | m_pInplaceButtons
In-place buttons pointer.
CXTPGridInplaceList * | m_pInplaceList
In-place list pointer.
BOOL | m_bVScrollBarVisible
TRUE if vertical scrollbar is visible.
BOOL | m_bHScrollBarVisible
TRUE if horizontal scrollbar is visible.
UINT | m_nAutoVScrollTimerResolution
Vertical scrolling timer resolution (in milliseconds).
CPoint | m_ptDrag
Drag position.
int | m_nDragSensitivityX
Horizontal sensitivity of Drag'n'Drop operation (in pixels).
int | m_nDragSensitivityY
Vertical sensitivity of Drag'n'Drop operation (in pixels).
BOOL | m_bPrepareDrag
TRUE if the user clicks the Grid control and does not release the button.
CString | m_strFilterText
Filter text.
BOOL | m_bFilterHiddenColumns
Search filter text in hidden columns too.
int | m_nRecordsTreeFilterMode
Tree Filter mode.
CLIPFORMAT | m_cfGrid
Grid clipboard format for drag/drop operations.
CGridDropTarget * | m_pDropTarget
Internal drag/drop helper.
BOOL | m_bDragMode
TRUE if records are currently being dragged.
BOOL | m_bInternalDrag
TRUE if records begin dragging from this control.
DWORD | m_dwDragDropFlags
Drag/drop flags.
DWORD | m_dwDropMarkerFlags
The drop marker flags.
CXTPGridSelectedRows * | m_pSelectedRowsBeforeDrag
The selected rows before a dragging action.
int | m_nDropPos
Position of records to be dropped.
CXTPGridRecords * | m_pDropRecords
Drop records.
BOOL | m_bAdjustLayoutRunning
TRUE if AdjustLayout handler is entered, FALSE otherwise.
UINT_PTR | m_uAutoScrollTimerID
Auto scroll timer ID or 0.
CXTPGridRow * | m_ptrVirtualEditingRow
Currently editing row in virtual mode.
XTPGridRowsCompareFunc | m_pRowsCompareFunc
Pointer to the rows compare function.
HBITMAP | m_hbmpWatermark
Watermark bitmap handle.
BYTE | m_WatermarkTransparency
Watermark bitmap transparency value.
BITMAP | m_bmWatermark
Watermark bitmap info.
XTPGridWatermarkAlignment | m_WatermarkAlignment
Watermark alignment flags.
int | m_nEnsureVisibleRowIdx
Ensure visible row index.
int | m_nEnsureVisibleColumnIdx
Ensure visible column index.
CXTPGridDataManager * | m_pDataManager
Data manager.
BOOL | m_bShowIconWhenEditing
TRUE to show item icons while the item is being edited.
BOOL | m_bCreated
TRUE if created using the Create() method.
BOOL | m_bIconView
TRUE if icon view, FALSE otherwise.
int | m_iIconViewRowsPerLine
The icon view rows per line.
CXTPGridColumnOrder * | m_pPrevVisible
The previous visible column order.
CXTPGridColumnOrder * m_pPrevGroupsOrder
The previous group column order.
BOOL | m_bPrevFocusSubItems
TRUE if there are previous focused sub-items, FALSE otherwise.
BOOL | m_bPrevHeaderAutoSize
TRUE if the previous header is auto-size, FALSE otherwise.
BOOL | m_bPrevHeaderRows
TRUE if there are previous header rows, FALSE otherwise.
BOOL | m_bPrevFooterRows
TRUE if there are previous footer rows, FALSE otherwise.
int | m_nPrevTreeIndent
Tree indentation.
BOOL | m_bPrevHeaderShow
Tells whether the previous header is visible or not.
BOOL | m_bPrevFooterShow
Tells whether the previous footer is visible or not.
BOOL | m_bPrevPreviewMode
Tells whether the preview mode is enabled or not previously.
BOOL | m_bNoNeedSortedDragDrop
Dynamic flag during Sorted DragDrop operation (set during OnDragOver state - used during OnDrop state)
UINT_PTR | m_uiDelayEditTimer
The delay edit timer.
UINT | m_uiDelayEditMaxTime
The delay edit time interval.
int | m_iLastRqstEditRow
The last row which requested a delay edit.
int | m_iLastRqstEditCol
The last column which requested a delay edit.
UINT_PTR | m_uRqstEditTimer
The edit timer ID.
BOOL | m_bFastDeselectMode
Tells whether the fast deselect mode is enabled or not.
XTPGridPaintTheme | m_themeCurrent
Currently set theme.
BOOL | m_bRelayWndMsg
Used for relaying window messages.

Detailed Description

The CXTPGridControl class provides an implementation of the Grid control.

A "Grid control" is a window that displays a hierarchical list of items, such as emails in the inbox. Each item is called a CXTPGridRow and consists of its properties and corresponding CXTPGridRecord, which contains all the corresponding data (mostly text). Each Row item (as well as Record) can have a list of sub-items associated with it. By clicking a Row item, the user can expand and collapse the associated list of sub-items.

The CXTPGridRecords collection holds all the CXTPGridRecord objects that are assigned to the Grid control. It could be accessible via the GetRecords() method. The records in this collection are referred to as the root records. Any record that is subsequently added to a root record is referred to as a child record. Because each CXTPGridRecord can contain a collection of other CXTPGridRecord objects, you might find it difficult to determine your location in the tree structure when you iterate through the collection.

Record nodes can be expanded to display the next level of child records. The user can expand the CXTPGridRecord by clicking the plus-sign (+) button, if one is displayed, or you can expand the CXTPGridRecord by calling the CXTPGridRecord::SetExpanded method. To expand all the child records, call the ExpandAll method. You can collapse the child CXTPGridRecord level by calling the CXTPGridRecord::SetExpanded(FALSE) method, or the user can press the minus-sign (-) button, if one is displayed. You can also call CollapseAll method to collapse all child records.

Each record contains an array of record items which are implemented with CXTPGridRecordItem and its descendants. You can create your own types of items simply by inheriting from the base record item class.

Each record item has an association with a corresponding CXTPGridColumn item. The item will be shown below the corresponding column header depending on its position in Grid control columns array. If a column does not have an associated item in the record, there will be an empty item shown in the corresponding cell.

Columns array is represented by the CXTPGridColumns collection and could be accessed via the GetColumns() method.

As a finalization of adding data to the Grid control, which means adding columns and records, the Populate() method should be called. It performs population of control rows with data - creates a rows tree if necessary, rebuilds groups if grouping if enabled, and sorts rows on a specified manner. See Also an example below.

Handling notification messages sent by the control to the parent window is allowed with the ON_NOTIFY handler. The control uses the SendMessageToParent function to send notifications. See below for the example of how messages could be handled in a parent window:

ON_NOTIFY(NM_CLICK, ID_GRID_CONTROL, OnGridItemClick)
ON_NOTIFY(NM_RCLICK, ID_GRID_CONTROL, OnGridItemRClick)
ON_NOTIFY(NM_DBLCLK, ID_GRID_CONTROL, OnGridItemDblClick)
ON_NOTIFY(XTP_NM_SHOWFIELDCHOOSER, ID_GRID_CONTROL, OnShowFieldChooser)
ON_NOTIFY(XTP_NM_HEADER_RCLICK, ID_GRID_CONTROL, OnGridColumnRClick)
ON_NOTIFY(NM_KEYDOWN, ID_GRID_CONTROL, OnGridKeyDown)

You can also change the appearance of the CXTPGridControl control by setting some of its display and style properties.

Also Grid control has an ability to store and restore its settings, which includes all columns with their settings, and some required control's settings. It is implemented via standard MFC and XTP serialization and is available with the member functions SerializeState(CArchive& ar), DoPropExchange(CXTPPropExchange* pPX);

Grid control supports Copy/Paste clipboard operations. See methods: CanCut(), CanCopy(), CanPaste(), Cut(), Copy(), Paste(). There are 2 clipboard formats that are supported: Binary - contains all record(s) data; Text - contains visible columns texts.

To support binary format the XTP serialization is used - DoPropExchange() methods are implemented for CXTPGridRecord, CXTPGridRecordItem and derived CXTPGridRecordItemXXX classes. Also some part of standard MFC serialization is used (see DECLARE_SERIAL macro) to automatically create classes when loading from the data source.

If you are creating custom records and records items classes, you have to use DECLARE_SERIAL macro and may need to override DoPropExchange() methods to serialize custom data as well as standard records data.

Storing records is simple: the CXTPGridRecord (or derived class) is stored first, then record items (CXTPGridRecordItemXXX classes) are stored one by one. The class information, which allows for creating object instances when loading, is stored for all classes. See CArchive::WriteClass(), CArchive::ReadClass() and other CArchive members for more details about this idea.

When Grid control loads records from the data source, the record class is created automatically (using stored class information). Then the items collection is cleared and record items are created automatically and added to the items collection. For example see GridSample project: CMessageRecord class.

We support text format with '\t' dividers for record items and "\\r\\n" dividers for records (simple tab-separated text). Such format is also supported by Excel and some other applications.

There are a few methods and corresponding notifications which allow for the customization of copy/paste operations: OnBeforeCopyToText(); OnBeforePasteFromText(); OnBeforePaste();

See also
CXTPGridView, CXTPGridHeader, CXTPGridRow, CXTPGridRecord, CXTPGridColumn, CXTPGridRecords, CXTPGridRows, CXTPGridColumns, CXTPGridSubListControl, CXTPGridFilterEditControl

Constructor & Destructor Documentation

◆ CXTPGridControl()

CXTPGridControl ( )

Constructs a CXTPGridControl object.

You construct a CXTPGridControl object in two steps. First, call the constructor CXTPGridControl and then call the Create method. This initializes the window.

Example:

// Declare a local CXTPGridControl object.
CXTPGridControl myGrid;

// Declare a dynamic CXTPGridControl object.
CXTPGridControl* pMyGrid = new CXTPGridControl();

if (!myGrid.Create(WS_CHILD | WS_TABSTOP | WS_VISIBLE | WM_VSCROLL, CRect(0, 0, 0, 0),
this, ID_GRID_CONTROL))
{
   TRACE(_T("Failed to create view window\n"));
}
See also
Create

Member Function Documentation

◆ AddColumn()

CXTPGridColumn * AddColumn ( CXTPGridColumn * pColumn )

Adds a specified column to the end of the columns array.

Parameters
pColumn Pointer to a CXTPGridColumn object to add.

Call this member function if you want to add a specified column to the Grid control. It will be added to the end of the columns array.

Returns
A pointer to the newly added column.

Example:

// this function adds a column with "Subject" caption and 250 pixels initial width
void AddSubjectColumn(CXTPGridControl* pGridCtrl)
{
   pGridCtrl->AddColumn(new CXTPGridColumn(1, _T("Subject"), 250));
}
See also
CXTPGridColumn overview

◆ AddRecord()

virtual CXTPGridRecord * AddRecord ( CXTPGridRecord * pRecord )
virtual

Adds a specified data record to the records collection.

Parameters
pRecord Pointer to a CXTPGridRecord object to add.

Call this member function if you want to add a specified data record to the Grid control's internal storage.

Returns
A pointer to the newly added data record.

Example:

// this function adds 2 empty records to a Grid control
void Add2Empties(CXTPGridControl* pGridCtrl)
{
   pGridCtrl->AddRecord(new CXTPGridRecord());
   pGridCtrl->AddRecord(new CXTPGridRecord());
}
Returns
Pointer to the recently added record object.
See also
CXTPGridRecord overview, GetRecords

◆ AddRecordEx()

virtual void AddRecordEx | ( | CXTPGridRecord * | pRecord,
 |  | CXTPGridRecord * | pParentRecord = NULL,
 |  | int | nRowChildIndex = -1,
 |  | int | nRecordChildIndex = -1 )
 virtual

Adds a specified data record to the records collection and associates a row with it.

Parameters
pRecord | Pointer to a CXTPGridRecord object to add.
pParentRecord | Pointer to a parent CXTPGridRecord object for pRecord to be added to.
nRowChildIndex | Child index for a row to be inserted at in case the index is not defined by other conditions (or -1).
nRecordChildIndex | Child index for a record to be inserted at (or -1).

Call this member function if you want to add a data record to the Grid control's internal storage and associate a row with it.

Example:

// this function adds 2 empty records to a Grid control
void Add2Empties(CXTPGridControl* pGridCtrl)
{
   pGridCtrl->AddRecordEx(new CXTPGridRecord());
   pGridCtrl->AddRecordEx(new CXTPGridRecord());
}
See also
CXTPGridRecord overview, GetRecords, RemoveRecordEx, RemoveRowEx, UpdateRecord

◆ AdjustIndentation()

void AdjustIndentation ( )
protected

Adjusts control indentation properties depending on the current tree depth.

See also
GetIndent

◆ ApplyFilter()

virtual BOOL ApplyFilter | ( | CXTPGridRecord * | pRecord,
 |  | CString | strFilterText,
 |  | BOOL | bIncludePreview )
 protectedvirtual

Checks a record for filter text.

Parameters
pRecord | A record to apply filter to.
strFilterText | Filter string text.
bIncludePreview | Include preview item in filtering or not.

This member function represents filter functionality. First, it parses the input text of a filter string by tokens; second it enumerates all visible columns to find text matching to the filter string. Returns TRUE if matching found, FALSE otherwise

Returns
TRUE if record is filtered with the specified filter, FALSE otherwise.

◆ AssignIconViewPropNumAndIconNum()

void AssignIconViewPropNumAndIconNum | ( | int | nCol = 0,
 |  | int | nIcon = 0,
 |  | BOOL | bUseColumnForNum = FALSE,
 |  | int | nWidth = 20 )

Creates a column as an icon view column and specifies if the column may be reused as a number column in the grid view.

Parameters
nCol | Column index to use as the icon column property.
nIcon | Icon index to use in icon view.
bUseColumnForNum | TRUE to reuse the column as a number column in the grid view.
nWidth | Width for the number column.

This can be used for non-virtual mode.

◆ BeginUpdate()

void BeginUpdate ( )

Prevents the Grid control from being redrawn until the EndUpdate method is called.

If you want to add items one at a time using the AddRecord method, or if you want to perform other operations in a single sequence, then you can use the BeginUpdate method to prevent the control from repainting the CXTPGridControl each time an item is added. Once you have completed the task of adding items to the control, call the EndUpdate method to enable the CXTPGridControl to repaint. This way of adding items can prevent flickered drawing of the CXTPGridControl when a large number of items are being added to the control.

Example:

// This function collapses all rows for the specified Grid control
void CollapseAll(CXTPGridControl* pGridCtrl)
{
   pGridCtrl->BeginUpdate();
   for (int i = pGridCtrl->GetRows()->GetCount() - 1; i >= 0; i --)
   pGridCtrl->GetRows()->GetAt(i)->SetExpanded(FALSE);

   pGridCtrl->EndUpdate();
}
See also
EndUpdate, RedrawControl, AddRecord

◆ CanCopy()

virtual BOOL CanCopy ( )
virtual

Determines if the Copy operation is posssible in the current context (i.e.

one or more records are selected).

Returns
TRUE if the Copy operation is possible in the current context, otherwise FALSE.
See also
CanPaste, Cut, Copy, Paste.

◆ CanCut()

virtual BOOL CanCut ( )
virtual

Determines if the Cut operation is possible in the current context (i.e.

one or more records are selected).

Returns
TRUE if the Cut operation is possible in the current context, otherwise FALSE.
See also
CanPaste, Cut, Copy, Paste.

◆ CanPaste()

virtual BOOL CanPaste ( )
virtual

Determines if the Paste operation is possible in the current context (i.e.

binary and/or text data exists in the clipboard).

Returns
TRUE if the Paste operation is possible in the current context, otherwise FALSE.
See also
CanCut, CanCopy, Cut, Copy, Paste.

◆ CollapseAll()

void CollapseAll ( )

Collapses all rows.

The CollapseAll method collapses all CXTPGridRow objects, including child rows, that are in the Grid control.

See also
ExpandAll, CXTPGridRow::SetExpanded

◆ Copy()

virtual void Copy ( )
virtual

Copies the selected record data (in the binary and/or text data formats) to the clipboard.

See also
CanCut, CanCopy, CanPaste, Cut, Paste, OnBeforeCopyToText, OnBeforePasteFromText, OnBeforePaste.

◆ Create()

BOOL Create | ( | DWORD | dwStyle,
 |  | const RECT & | rect,
 |  | CWnd * | pParentWnd,
 |  | UINT | nID,
 |  | CCreateContext * | pContext = NULL )

This method is called to create a Grid control.

Parameters
dwStyle | Specifies the window style attributes (this could be a combination of standard window styles).
rect | Size and position of the window, in client coordinates of pParentWnd.
pParentWnd | Specifies the Grid control parent window.
nID | Specifies the Grid control identifier.
pContext | The create context of the window.

You construct a CXTPGridControl object in two steps. First, call the constructor CXTPGridControl and then call the Create method. This initializes the window.

Example: See the example for CXTPGridControl::CXTPGridControl.

Returns
Nonzero if successful, otherwise 0.
See also
CXTPGridControl::CXTPGridControl

◆ CreateGroupRow()

virtual CXTPGridGroupRow * CreateGroupRow ( )
protectedvirtual

Creates a CXTPGridGroupRow object.

Overwrite it to use the derived CXTPGridGroupRow class.

Returns
A pointer to the newly created CXTPGridGroupRow object.

◆ CreateHeaderFooterRow()

virtual CXTPGridRow * CreateHeaderFooterRow ( )
protectedvirtual

Creates a CXTPGridRow object for header/footer rows.

Overwrite it to use the derived CXTPGridRow class.

Returns
A pointer to the newly created CXTPGridRow object.

◆ CreateIconColumn()

void CreateIconColumn | ( | BOOL | bUseColumnForNum = FALSE,
 |  | int | nWidth = 40 )

Creates a column as an icon view column and specifies if the column may be reused as a number column in the grid view.

Parameters
bUseColumnForNum | TRUE to reuse the column as a number column in the grid view.
nWidth | Width for the number column.

◆ CreateRow()

virtual CXTPGridRow * CreateRow ( )
protectedvirtual

Creates a CXTPGridRow object.

Overwrite it to use the derived CXTPGridRow class.

Returns
A pointer to the newly created CXTPGridRow object.

◆ Cut()

virtual void Cut ( )
virtual

Copies the selected record data (in the binary and/or text data formats) to the clipboard and deletes the selected record data.

See also
CanCut, CanCopy, CanPaste, Copy, Paste, OnBeforeCopyToText, OnBeforePasteFromText, OnBeforePaste.

◆ DoAutoVertScrollIfNeed()

virtual void DoAutoVertScrollIfNeed | ( | CPoint | ptClick,
 |  | CPoint | pt )
 protectedvirtual

This method is used to monitor mouse position.

If the mouse is moved to 20 pixels before either the top or bottom grid borders, then the control will be scrolled vertically.

Parameters
ptClick | Coordinates of the initial click (or mouse down).
pt | Current mouse position.

Used when dragging records.

See also
EnsureStartAutoVertScroll, EnsureStopAutoVertScroll

◆ DoPropExchange()

virtual void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Reads/writes configuration to/from the provided data source.

Parameters
pPX Pointer to a CXTPPropExchange object to serialize to/from.

Reimplemented in CXTPTrackControl.

◆ DrawNoItems()

virtual void DrawNoItems | ( | CDC * | pDC,
 |  | const CRect & | rcClient )
 protectedvirtual

Draws the 'NoItems' text in the provided device conext.

Parameters
pDC | Provided device context to draw text with.
rcClient | Rectangle to draw text into.

◆ DrawRows()

virtual int DrawRows | ( | CDC * | pDC,
 |  | CRect & | rcClient,
 |  | int | y,
 |  | CXTPGridRows * | pRows,
 |  | int | nTopRow,
 |  | int | nColumnFrom,
 |  | int | nColumnTo,
 |  | int * | pnHeight = NULL )
 protectedvirtual

Draws all rows in the provided device context.

Parameters
pDC | Provided device context to draw rows image with.
rcClient | Reference to a rectangle to draw rows image into.
pRows | Rows collection to draw.
nTopRow | Index of the topmost visible row of the rows collection.
nColumnFrom | Index of the first column to draw from.
nColumnTo | Index of the last column to draw to.
pnHeight | Pointer to an integer to receive the total height of the drawn rows; can be NULL.
y | Distance from the top.
Returns
The index of the last printed row.

Reimplemented in CXTPTrackControl.

◆ DrawWatermark()

void DrawWatermark | ( | CDC * | pDC,
 |  | CRect | rcWatermark,
 |  | CRect | rcClient )

Draws a watermark.

Parameters
pDC | Pointer to the device context.
rcWatermark | Rectangular bounds of the watermark.
rcClient | Rectangular bounds of the client area.

◆ EditItem()

void EditItem ( XTP_GRIDRECORDITEM_ARGS * pItemArgs )

Edits a grid cell by focusing the specified cell and starting in-place editing for the control specified there.

Parameters
pItemArgs Pointer to an XTP_GRIDRECORDITEM_ARGS structure containing item arguments of the item to be edited.

All editing options should be enabled in order for this method to be executed successfully. Call this method with NULL as its parameter to stop item edit.

See also
AllowEdit, CXTPGridColumn::SetEditable

◆ EditOnClick()

AFX_INLINE void EditOnClick ( BOOL bEditOnClick )

Specifies if a CXTPGridRecordItem should become editable after being single-clicked.

Parameters
bEditOnClick TRUE to allow a CXTPGridRecordItem to become editable after being single-clicked.

The entire Grid control and/or the specific CXTPGridRecordItem must also be set to editable in order for a CXTPGridRecordItem to become editable after being single-clicked.

See also
AllowEdit, IsAllowEdit, IsEditOnClick

◆ EditOnDelayClick()

AFX_INLINE void EditOnDelayClick ( BOOL bEditOnDelayClick )

Enables/disables the Delay Click Edit feature.

Parameters
bEditOnDelayClick TRUE to enable the Delay Click Edit feature, FALSE to disable the Delay Click Edit feature.

◆ EditOnDoubleClick()

AFX_INLINE void EditOnDoubleClick ( BOOL bEditOnClick )

Specifies if a CXTPGridRecordItem should become editable after being double-clicked.

Parameters
bEditOnClick TRUE to allow a CXTPGridRecordItem to become editable after being double-clicked.

The entire Grid control and/or the specific CXTPGridRecordItem must also be set to editable in order for a CXTPGridRecordItem to become editable after being double-clicked.

See also
AllowEdit, IsAllowEdit, IsEditOnDoubleClick

◆ EnableDoubleBuffering()

void EnableDoubleBuffering ( BOOL bEnable )

Enables/disables double-buffering.

Parameters
bEnable TRUE to enable double-buffering, FALSE to disable double-buffering.

◆ EnableDragDrop()

CLIPFORMAT EnableDragDrop | ( | LPCTSTR | lpszClipboardFormat,
 |  | DWORD | dwFlags,
 |  | DWORD | dwDropMarkerFlags = xtpGridDropBetween )

Call this method to enable built in drag and drop operations.

Parameters
lpszClipboardFormat | Name of the clipboard format to be used for the Grid control.
dwFlags | Combination of XTPGridDragDrop flags; can be one or more of following: xtpGridAllowDrop: Allow drop records to grid. xtpGridAllowDragCopy: Allow copy records from grid. xtpGridAllowDragMove: Allow move records from grid. xtpGridAllowDrag: Allow copy and move records from grid.
dwDropMarkerFlags | Combination of required bits specified by the XTPGridDropMarker enumeration.
Returns
Clipboard format that will be used with Grid Control
See also
XTPGridDragDrop

◆ EnableMarkup()

void EnableMarkup ( BOOL bEnable = TRUE )

Call this method to enable Markup for records.

Parameters
bEnable TRUE to enable Markup.

◆ EnablePreviewMode()

void EnablePreviewMode ( BOOL bIsPreviewMode )

Enables/disables preview mode for the control.

Parameters
bIsPreviewMode TRUE to enable preview mode, FALSE to disable preview mode.

Preview mode has two states: enabled and disabled. When preview mode is enabled, the control tries to show additional bands with preview text.

See also
IsPreviewMode

◆ EnableToolTips()

AFX_INLINE void EnableToolTips ( BOOL bEnable )

Enables/disables showing tooltips for the Grid control window.

Parameters
bEnable TRUE to enable showing tooltips, FALSE to disable showing tooltips.

◆ EndUpdate()

void EndUpdate ( )

Resumes drawing of the Grid control after drawing has been suspended by the BeginUpdate method.

If you want to add items one at a time using the AddRecord method, or if you want to perform other operations in a single sequence, then you can use the BeginUpdate method to prevent the control from repainting the CXTPGridControl each time an item is added. Once you have completed the task of adding items to the control, call the EndUpdate method to enable the CXTPGridControl to repaint. This way of adding items can prevent flickered drawing of the CXTPGridControl when a large number of items are being added to the control.

Example: See example for CXTPGridControl::BeginUpdate method.

See also
BeginUpdate, RedrawControl

◆ EnsureFocusedRowVisible()

AFX_INLINE void EnsureFocusedRowVisible ( BOOL bEnsureFocusedRowVisible )

Specifies if the visibility of focused rows should be ensured.

Parameters
bEnsureFocusedRowVisible TRUE to ensure the visibility of the entire row when a record item is focused.
See also
IsEnsureFocusedRowVisible

◆ EnsureStartAutoVertScroll()

virtual void EnsureStartAutoVertScroll ( )
protectedvirtual

This method is used to start monitoring mouse position for automatic vertical scrolling.

Used when dragging records.

See also
EnsureStopAutoVertScroll, DoAutoVertScrollIfNeed

◆ EnsureStopAutoVertScroll()

virtual void EnsureStopAutoVertScroll ( )
protectedvirtual

This method is used to stop monitoring mouse position for automatic vertical scrolling.

Used when dragging records.

See also
EnsureStartAutoVertScroll, DoAutoVertScrollIfNeed

◆ EnsureVisible() [1/2]

void EnsureVisible ( CXTPGridColumn * pCheckColumn )

Ensures that a Grid control column is at least partially visible.

Parameters
pCheckColumn Pointer to the CXTPGridColumn object whose visibility must be checked.

Ensures that a grid column item is at least partially visible. The list view control is scrolled if necessary.

See also
MoveRight, MoveLeft, MoveToColumn, MoveFirstColumn, MoveLastColumn

◆ EnsureVisible() [2/2]

void EnsureVisible ( CXTPGridRow * pRow )

Ensures that a Grid control row is at least partially visible.

Parameters
pRow Pointer to the CXTPGridRow object whose visibility must be checked.

Ensures that a grid row item is at least partially visible. The list view control is scrolled if necessary.

See also
MoveDown, MoveUp, MovePageDown, MovePageUp, MoveFirst, MoveLast

◆ ExpandAll()

void ExpandAll ( BOOL bRecursive = FALSE )

Expands all rows.

Parameters
bRecursive TRUE to recursively expand all levels of child rows, FALSE to only expand one level of child rows.

The ExpandAll method expands all CXTPGridRow objects, including child rows, that are in the Grid control.

See also
CollapseAll, CXTPGridRow::SetExpanded

◆ FocusSubItems()

AFX_INLINE void FocusSubItems ( BOOL bFocusSubItems )

Specifies if each individual record item in a row should receive focus when an item in the row is clicked.

Parameters
bFocusSubItems TRUE to highlight the entire row when a record item is clicked excluding the item that was clicked, FALSE to highlight the entire row when a record item is clicked including the item that was clicked.
See also
IsFocusSubItems

◆ FreeRowBatchExtraData()

static void AFX_CDECL FreeRowBatchExtraData ( )
static

This function is used when row batch allocation is enabled to both check all allocated blocks and deallocate any blocks which are completely free.

Returns
See also
UseRowBatchAllocation, CXTPBatchAllocObjT

◆ GetActiveItem()

AFX_INLINE CXTPGridRecordItem * GetActiveItem ( ) const

Gets the active item (i.e.

the item that has focus in edit mode).

Returns
A pointer to the active item if in edit mode, otherwise NULL.

◆ GetAutoVScrollTimerResolution()

AFX_INLINE UINT GetAutoVScrollTimerResolution ( ) const

Gets the vertical scrolling timer resolution.

Returns
The vertical scrolling timer resolution, in milliseconds.

◆ GetColumns()

AFX_INLINE CXTPGridColumns * GetColumns ( ) const

Gets the collection of grid columns.

Returns
A pointer to the collection of grid columns.

Example:

// this function adds a column with "Subject" caption and 250 pixels initial width
void AddSubjectColumn(CXTPGridControl* pGridCtrl)
{
   pGridCtrl->GetColumns()->Add(new CXTPGridColumn(1, _T("Subject"), 250));
}
See also
CXTPGridColumns overview

◆ GetDataManager()

CXTPGridDataManager * GetDataManager ( )

Gets the grid data manager.

Returns
A pointer to the grid data manager.

◆ GetDelayEditTimer()

AFX_INLINE UINT_PTR GetDelayEditTimer ( ) const

Gets the ID of the delay edit timer.

Returns
The ID of the delay edit timer.

◆ GetDisableReorderColumnsCount()

AFX_INLINE int GetDisableReorderColumnsCount ( ) const

Gets the number of columns at the left side where reordering is disabled.

Returns
The number of columns at the left side.

◆ GetDragSensitivityX()

AFX_INLINE int GetDragSensitivityX ( ) const

Gets the horizontal sensitivity of Drag'n'Drop operations.

Returns
The horizontal sensitivity of Drag'n'Drop operations, in pixels.
See also
SetDragSensitivityX, GetDragSensitivityY, SetDragSensitivityY

◆ GetDragSensitivityY()

AFX_INLINE int GetDragSensitivityY ( ) const

Gets the vertical sensitivity of Drag'n'Drop operations.

Returns
The vertical sensitivity of Drag'n'Drop operations, in pixels.
See also
GetDragSensitivityX, SetDragSensitivityX, SetDragSensitivityY

◆ GetDropMarkerFlags()

AFX_INLINE DWORD GetDropMarkerFlags ( ) const

Gets the drop marker flags.

Returns
The drop marker flags.

◆ GetElementRect()

CRect GetElementRect ( XTPGridElementRect nElement ) const

Retrieves a specified grid element rectangle.

Parameters
nElement Grid element rectangle to retrieve; must be one of the values defined by the XTPGridElementRect enumeration.
Returns
The specified grid element rectangle.
See also
XTPGridElementRect

◆ GetFilterText()

AFX_INLINE CString GetFilterText ( )
virtual

Gets the filter text of the control.

Returns
The filter text of the control.
See also
SetFilterText

◆ GetFocusedColumn()

AFX_INLINE CXTPGridColumn * GetFocusedColumn ( ) const

Gets the selected column.

Returns
A pointer to the selected column.

◆ GetFocusedRecordItem()

CXTPGridRecordItem * GetFocusedRecordItem ( ) const

Gets the focused item.

Returns
A pointer to the focused item.

◆ GetFocusedRow()

CXTPGridRow * GetFocusedRow ( ) const

Gets the currently focused row in the Grid control's view.

Returns
A pointer to the currently focused row if successful, otherwise NULL.

◆ GetFreezeColumnsCount() [1/2]

int GetFreezeColumnsCount ( ) const

Gets the number of frozen columns starting from the left hand side.

Returns
The number of the frozen columns.

◆ GetFreezeColumnsCount() [2/2]

int GetFreezeColumnsCount ( int & nLastIndex ) const

Gets the number of frozen columns starting from the left hand side.

Parameters
nLastIndex Reference to an int to receive the index of the rightmost frozen column.
Returns
The number of the frozen columns.

◆ GetFreezeColumnsIndex()

int GetFreezeColumnsIndex ( ) const

Gets the index of the rightmost frozen column.

Returns
The index of the rightmost frozen column.

◆ GetGridAreaRows()

int GetGridAreaRows | ( | int | nStartRow,
 |  | BOOL | bMoveDown )

Calculates the number of visible rows between a specified row and the bottom/top of the current view.

Parameters
nStartRow | Index of the row to begin calculating from.
bMoveDown | TRUE to down, FALSE to move up.
Returns
The number of visible rows between the specified row and the bottom/top of the current view.
See also
MovePageDown, MovePageUp

◆ GetGridHeader()

AFX_INLINE CXTPGridHeader * GetGridHeader ( ) const

Gets the associated grid header object.

Call this member function if you want to retrieve access to the grid header object properties and methods.

Returns
A pointer to the associated grid header object.
See also
CXTPGridHeader overview

◆ GetGridStyle()

XTPGridGridStyle GetGridStyle ( XTPGridOrientation orientation ) const

Gets the grid drawing style.

Parameters
orientation Determines the grid style to get; must be one of the values defined by the XTPGridOrientation enumeration; xtpGridOrientationVertical to get the vertical grid style, xtpGridOrientationHorizontal to get the horizontal grid style.

Call this member function if you want to get the grid line drawing style for the Grid control.

Returns
The grid drawing style; one of the values defined by the XTPGridGridStyle enumeration.
See also
XTPGridGridStyle overview, SetGridStyle, SetGridColor

◆ GetHeaderIndent()

int GetHeaderIndent ( ) const

Gets the indentation of the header.

Returns
The indentation of the header.

◆ GetHScrollStep()

AFX_INLINE int GetHScrollStep ( ) const

Gets the horizontal scrolling step.

Returns
The horizontal scrolling step, in pixels.

◆ GetImageManager()

AFX_INLINE CXTPImageManager * GetImageManager ( ) const

Gets the image manager of the Grid control.

Returns
A pointer to the image manager of the Grid control.
See also
SetImageManager

◆ GetIndent()

int GetIndent ( int nLevel ) const

Calculates the indentation, in pixels, for a tree view row of a specified depth level.

Parameters
nLevel Tree depth level.
Returns
The indentation, in pixels, for a tree view row of the specified depth level.
See also
Populate

◆ GetInplaceButtons()

AFX_INLINE CXTPGridInplaceButtons * GetInplaceButtons ( ) const

Gets the collection of in-place buttons of the Grid control.

Returns
A pointer to the collection of in-place buttons of the Grid control.

◆ GetInplaceEdit()

AFX_INLINE CXTPGridInplaceEdit * GetInplaceEdit ( ) const

Gets the in-place edit control.

Returns
A pointer to the in-place edit control.

◆ GetInplaceList()

AFX_INLINE CXTPGridInplaceList * GetInplaceList ( ) const

Gets the in-place list of Grid controls.

Returns
A pointer to the in-place list of Grid controls.

◆ GetItemMetrics()

virtual void GetItemMetrics | ( | XTP_GRIDRECORDITEM_DRAWARGS * | pDrawArgs,
 |  | XTP_GRIDRECORDITEM_METRICS * | pItemMetrics )
 protectedvirtual

Calculates metrics for a row.

Parameters
pDrawArgs | Pointer to an XTP_GRIDRECORDITEM_DRAWARGS structure used to calculate metrics.
pItemMetrics | Pointer to an XTP_GRIDRECORDITEM_METRICS structure to fill with values.

◆ GetLastRqstEditCol()

AFX_INLINE int GetLastRqstEditCol ( ) const

Gets the index of the most recent column that was requested for editing.

Returns
The index of the most recent column that was requested for editing.

◆ GetLastRqstEditRow()

AFX_INLINE int GetLastRqstEditRow ( ) const

Gets the index of the most recent row that was requested for editing.

Returns
The index of the most recent row that was requested for editing.

◆ GetLeftOffset()

AFX_INLINE int GetLeftOffset ( ) const

Gets the horizontal scroll position.

Returns
The horizontal scroll position.

◆ GetLockUpdateCount()

AFX_INLINE int GetLockUpdateCount ( ) const
Returns
Gets the number of update locks.

The number of update locks.

◆ GetMarkupContext()

CXTPMarkupContext * GetMarkupContext ( ) const

Gets the Markup context.

Returns
A pointer to the Markup context.

◆ GetMouseMode()

AFX_INLINE XTPGridMouseMode GetMouseMode ( ) const

Gets the control mouse mode.

Returns
The control mouse mode; one of the values defined by the XTPGridMouseMode enumeration.
See also
XTPGridMouseMode overview, SetMouseMode

◆ GetMouseScrollLines()

static UINT AFX_CDECL GetMouseScrollLines ( )
staticprotected

Gets the number of rows per mouse scroll.

Returns
The number of rows per mouse scroll.

◆ GetNavigator()

AFX_INLINE CXTPGridNavigator * GetNavigator ( ) const

Gets the navigator object used for cell navigation by the Grid control.

Returns
A pointer to the navigator object.
See also
CXTPGridNavigator overview

◆ GetNextFocusableColumn()

virtual CXTPGridColumn * GetNextFocusableColumn | ( | CXTPGridRow * | pRow,
 |  | int | nColumnIndex,
 |  | int | nDirection )
 virtual

Gets the next focusable column.

Parameters
pRow | Pointer to a CXTPGridRow object.
nColumnIndex | Column index.
nDirection | Positive integer to get the next focusable column to the right of nColumnIndex, Negative integer to get the next focusable column to the left of nColumnIndex.
Returns
A pointer to the next focusable column.

◆ GetNumRowsOnLine()

int GetNumRowsOnLine ( int iTotalWidth ) const

Gets the number of rows on a line of abitrary width.

Parameters
iTotalWidth Width of the line.
Returns
The number of rows on the line.

◆ GetPaintManager()

AFX_INLINE CXTPGridPaintManager * GetPaintManager ( ) const

Gets the paint manager object used to draw the Grid control window.

Returns
A pointer to the paint manager object.
See also
CXTPGridPaintManager overview

◆ GetRecordsTreeFilterMode()

AFX_INLINE int GetRecordsTreeFilterMode ( ) const

Gets the filtering mode of the record tree.

Returns
The filtering mode of the record tree; one of the values defined by the XTPGridFilterMode enumeration.
See also
SetRecordsTreeFilterMode, XTPGridFilterMode

◆ GetRowsHeight()

virtual int GetRowsHeight | ( | CXTPGridRows * | pRows,
 |  | int | nTotalWidth,
 |  | int | nMaxHeight = -1 )
 protectedvirtual

Calculates the combined height of all rows within a specified rows collection.

Parameters
pRows | Pointer to the rows collection to calculate the combined height of all rows within.
nTotalWidth | Width of the row.
nMaxHeight | Should the calculated height exceed the value of this parameter, then the calculation will end. Set this parameter to -1 to calculate the height of all rows.
Returns
The combined height of all rows within the specified rows collection.

◆ GetRowsPerLine()

AFX_INLINE int GetRowsPerLine ( ) const

Gets the number of rows per line.

Returns
The number of rows per line.

◆ GetScrollMode()

XTPGridScrollMode GetScrollMode ( XTPGridOrientation orientation ) const

Gets the scroll mode.

Parameters
orientation Orientation of the scroll mode to get; must be one of the values defined by the XTPGridOrientation enumeration.
Returns
The scroll mode; one of the values defined by the XTPGridScrollMode enumeration.

◆ GetSections()

CXTPGridSections * GetSections ( ) const

Gets the sections collection.

Returns
A pointer to the sections collection.

◆ GetSelectedRows()

AFX_INLINE CXTPGridSelectedRows * GetSelectedRows ( ) const

Gets the collection of selected rows.

Use this member function to retrieve access to the collection of currently selected grid rows.

Returns
A pointer to the collection of selected rows.
See also
CXTPGridSelectedRows overview.

◆ GetToolTipContext()

CXTPToolTipContext * GetToolTipContext ( ) const

Gets the tooltip context.

Returns
A pointer to the tooltip context.

◆ GetTopRowIndex()

int GetTopRowIndex ( ) const

Gets the index of the top row of the Grid control view.

Returns
The index of the top row of the Grid control view.
See also
SetTopRow

◆ GetWatermarkAlignment()

AFX_INLINE int GetWatermarkAlignment ( ) const

Gets the watermark alignment.

Returns
The watermark alignment; one of the values defined by the XTPGridWatermarkAlignment enumeration.
See also
XTPGridWatermarkAlignment, SetWatermarkAlignment.

◆ GetWatermarkBitmap()

virtual HBITMAP GetWatermarkBitmap ( ) const
virtual

Gets the watermark bitmap to be shown in the Grid control background.

Returns
The handle of the watermark bitmap.

◆ HasFocus()

BOOL HasFocus ( ) const

Determines if the Grid control has focus.

Returns
TRUE if the Grid control has focus, otherwise FALSE.

◆ HitTest() [1/2]

CXTPGridRow * HitTest ( CPoint pt ) const

Determines which grid row is at a specified point, if any.

Parameters
pt Point to be tested.
Returns
A pointer to the CXTPGridRow object at the specified point, if any, otherwise NULL.

◆ HitTest() [2/2]

virtual BOOL HitTest | ( | CPoint | pt,
 |  | CXTPGridHitTestInfo * | pInfo ) const
 virtual

Determines which grid part is at a specified point.

Parameters
pt | Point to be tested.
pInfo | Pointer to a CXTPGridHitTestInfo object that will receive the returned information.
Returns
TRUE if the method was successful, otherwise FALSE.

Reimplemented in CXTPTrackControl.

◆ InitialSelectionEnable()

void InitialSelectionEnable ( BOOL bEnable )

Enables/disables initial selection.

Parameters
bEnable TRUE to enable initial selection, FALSE to disable initial selection.

If initial selection is enabled, then the first row in the grid will become selected when the grid is populated.

See also
IsSelectionEnabled

◆ InsertRow()

virtual int InsertRow | ( | int | nIndex,
 |  | CXTPGridRow * | pRow )
 protectedvirtual

Inserts a specified row at a specified index in the rows array.

Parameters
nIndex | Integer index to insert the row at.
pRow | Row to be inserted.

This method inserts the specified row to the rows array at the specified index with all its children expanded. Use _DoExpand() to expand all child items.

Returns
The number of inserted rows.

◆ IsAutoCheckItems()

AFX_INLINE BOOL IsAutoCheckItems ( ) const

Determines if auto-check mode is enabled/disabled for checkbox items.

If auto-check mode is enabled, then the checkbox will become checked/unchecked automatically when the user clicks on the checkbox.

Returns
TRUE if auto-check mode is enabled, FALSE if auto-check mode is disabled.
See also
SetAutoCheckItems, CXTPGridRecordItem::OnClick, CXTPGridRecordItem::OnChar

◆ IsCellMergingAllowed()

virtual BOOL IsCellMergingAllowed ( ) const
virtual

Determines if cell merging is allowed.

Returns
TRUE if cell merging is allowed, otherwise FALSE.

◆ IsChanged()

AFX_INLINE BOOL IsChanged ( ) const
protected

Determines if the internal control state was changed since the last drawing.

This method is used for caching control image drawing.

Returns
TRUE if the internal control state was changed since last drawing, otherwise FALSE.

◆ IsDoubleBuffering()

AFX_INLINE BOOL IsDoubleBuffering ( ) const

Determines if double-buffering is enabled/disabled.

Returns
TRUE if double buffering is enabled, FALSE if double-buffering is disabled.
See also
EnableDoubleBuffering

◆ IsDragMode()

AFX_INLINE BOOL IsDragMode ( ) const

assessors for m_bDragMode

Determines if Grid control items are in drag mode.

Returns
TRUE if Grid control items are in drag mode, otherwise FALSE.

◆ IsEditMode()

virtual BOOL IsEditMode ( )
virtual

Determines if the in-place edit control is active (i.e.

visible and focused).

Returns
TRUE if the in-place edit control is active, otherwise FALSE.
See also
GetInplaceEdit.

◆ IsEditOnClick()

AFX_INLINE BOOL IsEditOnClick ( ) const

Determines if a CXTPGridRecordItem becomes editable after being single-clicked.

Returns
TRUE if a CXTPGridRecordItem becomes editable after being single-clicked.

The entire Grid control and/or the specific CXTPGridRecordItem must also be set to editable in order for a CXTPGridRecordItem to become editable after being single-clicked.

See also
AllowEdit, IsAllowEdit, EditOnClick

◆ IsEditOnDelayClick()

AFX_INLINE BOOL IsEditOnDelayClick ( ) const

Determines if the Delay Click Edit feature is enabled/disabled.

Returns
TRUE if the Delay Click Edit feature is enabled, FALSE if the Delay Click Edit feature is disabled.

◆ IsEditOnDoubleClick()

AFX_INLINE BOOL IsEditOnDoubleClick ( ) const

Determines if a CXTPGridRecordItem becomes editable after being double-clicked.

Returns
TRUE if a CXTPGridRecordItem becomes editable after being double-clicked.

The entire Grid control and/or the specific CXTPGridRecordItem must also be set to editable in order for a CXTPGridRecordItem to become editable after being double-clicked.

See also
AllowEdit, IsAllowEdit, EditOnDoubleClick

◆ IsEnsureFocusedRowVisible()

AFX_INLINE BOOL IsEnsureFocusedRowVisible ( ) const

Determines if the visibility of focused rows is ensured.

Returns
TRUE if the visibility of focused rows is ensured, otherwise FALSE.

◆ IsFilterHiddenColumns()

AFX_INLINE BOOL IsFilterHiddenColumns ( ) const
virtual

Determines if search filter text is enabled/disabled in hidden columns.

This option is disabled by default.

Returns
TRUE if search filter text is enabled in hidden columns, FALSE if search filter text is disabled in hidden columns.
See also
SetFilterHiddenColumns, GetFilterText, SetFilterText

◆ IsFocusSubItems()

AFX_INLINE BOOL IsFocusSubItems ( ) const

Determines if each individual record item in a row receives focus when an item in the row is clicked.

Returns
TRUE if the entire row is highlighted when a record item is clicked excluding the item that was clicked, FALSE if the entire row is highlighted when a record item is clicked including the item that was clicked.
See also
FocusSubItems

◆ IsFooterRowsPinned()

AFX_INLINE BOOL IsFooterRowsPinned ( ) const

Determines if footer records are pinned to the last body row.

Returns
TRUE if footer records are pinned to the last body row, FALSE if footer records are docked to the footer.
See also
PinFooterRows

◆ IsFooterRowsPinnedPrinted()

AFX_INLINE BOOL IsFooterRowsPinnedPrinted ( ) const

Determines if footer records are pinned to the last body row.

This method is used only in printing mode.

Returns
TRUE if footer records are pinned to the last body row, FALSE if footer records are docked to the footer.
See also
PinFooterRows

◆ IsFooterVisible()

AFX_INLINE BOOL IsFooterVisible ( ) const

Gets the visible state of column footers.

Returns
TRUE if column footers are shown, FALSE if column footers are hidden.
See also
ShowHeader

◆ IsFullColumnScrolling()

BOOL IsFullColumnScrolling ( ) const

Gets the horizontal scrolling mode.

Returns
TRUE if full columns scrolling mode is set, FALSE if horizontal scrolling by pixels mode is set.
See also
SetFullColumnScrolling

◆ IsGroupByVisible()

AFX_INLINE BOOL IsGroupByVisible ( ) const

Gets the visible state of the Group By area.

Call this member function if you want to determine if the Group By area in the grid header is shown or not.

Returns
TRUE if the Group By area is shown, FALSE if the Group By area is hidden.
See also
ShowGroupBy

◆ IsGroupRowsBold()

BOOL IsGroupRowsBold ( ) const

Gets the group rows text style: bold or normal.

Returns
TRUE if group rows text style is bold, FALSE if group rows text style is normal.
See also
SetGroupRowsBold, ShadeGroupHeadings, IsShadeGroupHeadingsEnabled, GetItemMetrics

◆ IsHeaderVisible()

AFX_INLINE BOOL IsHeaderVisible ( ) const

Gets the visible state of column headers.

Returns
TRUE if column headers are shown, FALSE if column headers are hidden.
See also
ShowHeader

◆ IsIconView()

AFX_INLINE BOOL IsIconView ( ) const

Determines if Icon View mode is active.

Returns
TRUE if Icon View mode is active.

◆ IsInitialSelectionEnabled()

AFX_INLINE BOOL IsInitialSelectionEnabled ( ) const

Determines if initial selection is enabled/disabled.

If initial selection is enabled, then the first row in the grid will become selected when the grid is populated.

Returns
TRUE if initial selection is enabled, FALSE if initial selection is disabled.
See also
SelectionEnable

◆ IsLayoutRTL()

BOOL IsLayoutRTL ( )

Determines if right-to-left (RTL) mode was set.

Returns
TRUE if the layout is right-to-left (RTL), otherwise FALSE.

◆ IsLockExpand()

AFX_INLINE BOOL IsLockExpand ( ) const

Determines if the user's ability to collapse/expand rows is locked.

Returns
TRUE if the user's ability to collapse/expand rows is locked.

◆ IsMultipleSelection()

AFX_INLINE BOOL IsMultipleSelection ( ) const

Determines if multiple selections is enabled/disabled for the Grid control.

Returns
TRUE if multiple selections is enabled for the Grid control, FALSE if multiple selections is disabled for the Grid control.
See also
SetMultipleSelection, GetSelectedRows

◆ IsMultiSelectionMode()

AFX_INLINE BOOL IsMultiSelectionMode ( ) const

Determines if multi-selection mode is enabled/disabled for the Grid control.

Returns
TRUE if multi-selection mode is enabled for the control, FALSE if multi-selection mode is disabled for the control.

If multi-selection mode is enabled, then VK_CTRL is always ON.

See also
SetMultiSelectionMode

◆ IsPreviewAllowEdit()

AFX_INLINE BOOL IsPreviewAllowEdit ( ) const

Determines if preview editing is enabled/disabled.

Returns
TRUE if preview editing is enabled, FALSE if preview editing is disabled.

◆ IsPreviewMode()

BOOL IsPreviewMode ( ) const

Determines if preview mode is enabled/disabled for the control.

Returns
TRUE if preview mode is enabled, FALSE if preview mode is disabled.
See also
EnablePreviewMode

◆ IsRowFocusVisible()

AFX_INLINE BOOL IsRowFocusVisible ( ) const

Determines if row focus is shown.

Returns
TRUE if row focus is shown, otherwise FALSE.
See also
ShowRowFocus

◆ IsShadeGroupHeadingsEnabled()

BOOL IsShadeGroupHeadingsEnabled ( ) const

Determines if group items shading is enabled/disabled.

Call this member function if you want to determine whether group rows' headings are enabled or not.

Returns
TRUE if group items shading is enabled, FALSE if group items shading is disabled.
See also
ShadeGroupHeadings, IsGroupRowsBold, SetGroupRowsBold, GetItemMetrics

◆ IsShowIconWhenEditing()

BOOL IsShowIconWhenEditing ( )

Determines if item icons are shown while the item is being edited.

Returns
TRUE if item icons are shown while the item is being edited, otherwise FALSE.

◆ IsShowRowNumber()

BOOL IsShowRowNumber ( )

Determines if the row number is shown.

Returns
TRUE if the row number is shown, otherwise FALSE.

◆ IsSkipGroupsFocusEnabled()

AFX_INLINE BOOL IsSkipGroupsFocusEnabled ( ) const

Determines if groups are skipped when navigating the Grid control by using the Up and Down keys.

Returns
TRUE if group headings are skipped and the next non-group heading row is selected when navigating the Grid control by using the Up and Down keys, FALSE if all rows are selected (including group headings) when navigating the Grid control by using the Up and Down keys.

◆ IsSortRecordChilds()

AFX_INLINE BOOL IsSortRecordChilds ( ) const

Determines if the sort order is applied to record children.

Returns
TRUE if the sort order is applied to record children, otherwise FALSE.

◆ IsVirtualMode()

BOOL IsVirtualMode ( ) const

Determines if virtual mode is enabled/disabled.

Returns
TRUE if virtual mode is enabled, FALSE if virtual mode is disabled.
See also
SetVirtualMode

◆ LockExpand()

AFX_INLINE void LockExpand ( BOOL bLockExpand )

Specifies if the user's ability to collapse/expand rows should be locked.

Parameters
bLockExpand TRUE to lock the user's ability to collapse/expand rows.

◆ OnBeforeCopyToText()

virtual BOOL OnBeforeCopyToText | ( | CXTPGridRecord * | pRecord,
 |  | CStringArray & | rarStrings )
 protectedvirtual

This method is called before a record is copied to the clipboard in text format.

Parameters
pRecord | [in] Pointer to the source record.
rarStrings | [in/out] Reference to an array of strings with record item values. By default, this array contains visible item captions.

If you would like to customize text data for the clipboard, then you can change rarStrings as needed.

Default implementation sends an XTP_NM_GRID_BEFORE_COPY_TOTEXT notification.

Returns
TRUE if the operation will be canceled, FALSE if the operation will continue.
See also
OnBeforePasteFromText, OnBeforePaste, Cut, Copy, Paste.

◆ OnBeforePaste()

virtual BOOL OnBeforePaste ( CXTPGridRecord ** ppRecord )
protectedvirtual

This method is called after creating a new record using binary data from the clipboard, but before adding it to records collection.

Parameters
ppRecord [in/out] Double pointer to the new record.

If you would like to customize the new record created from binary data, then you may either create a new record or change the provided record by using the ppRecord parameter.

Default implementation sends an XTP_NM_GRID_BEFORE_PASTE notification.

Returns
TRUE if the operation will be canceled, FALSE if the operation will continue.
See also
OnBeforeCopyToText, OnBeforePasteFromText, Cut, Copy, Paste.

◆ OnBeforePasteFromText()

virtual BOOL OnBeforePasteFromText | ( | CStringArray & | arStrings,
 |  | CXTPGridRecord ** | ppRecord )
 protectedvirtual

This method is called before creating a new record using text data from the clipboard.

Parameters
arStrings | [in] Array of strings with record items values.
ppRecord | [out] Double pointer to the new record.

If you would like to customize creating a new record from text data, then you must create a new record object with record items and fill them using the default values and strings provided by the arStrings parameter.

If the new record will not be set to the ppRecord parameter, then the control will create a CXTPGridRecord object with CXTPGridRecordItemVariant items and fill the visible items using the strings provided by the arStrings parameter.

Default implementation sends an XTP_NM_GRID_BEFORE_PASTE_FROMTEXT notification.

Returns
TRUE if the operation will be canceled, FALSE if the operation will continue.
See also
OnBeforeCopyToText, OnBeforePaste, Cut, Copy, Paste.

◆ OnBeginDrag() [1/2]

virtual void OnBeginDrag ( CPoint point )
protectedvirtual

This method is called when the user begins dragging a row.

Parameters
point Drag point.

You can override this method or catch a LVN_BEGINDRAG message to proceed with drag operations. OnBeginDrag will not know which mouse button is used for the drag unless you pass nFlags.

◆ OnBeginDrag() [2/2]

virtual void OnBeginDrag | ( | CPoint | point,
 |  | UINT | nFlags )
 protectedvirtual

This method is called when the user begins dragging a row.

Parameters
point | Drag point.
nFlags | Flags for various mouse button states.

You can override this method or catch a LVN_BEGINDRAG message to proceed with drag operations. OnBeginDrag will not know which mouse button is used for the drag unless you pass nFlags.

◆ OnConstraintSelecting()

virtual BOOL OnConstraintSelecting | ( | CXTPGridRow * | pRow,
 |  | CXTPGridRecordItem * | pItem,
 |  | CXTPGridColumn * | pColumn,
 |  | CXTPGridRecordItemConstraint * | pConstraint )
 protectedvirtual

This method is used to notify about changes to the constraint selection.

Parameters
pRow | Pointer to the current row object.
pItem | Pointer to the current record item object.
pColumn | Pointer to the current column object.
pConstraint | Pointer to the hot selected constraint.

Sent for every selection change before the new selection is applied or canceled.

Returns
TRUE if the notification was sent successfully, otherwise FALSE.

◆ OnDragOver()

virtual DROPEFFECT OnDragOver | ( | COleDataObject * | pDataObject,
 |  | DWORD | dwKeyState,
 |  | CPoint | point,
 |  | int | nState )
 protectedvirtual

This member is called when an item is dragged over the Grid control.

Parameters
pDataObject | Pointer to the COleDataObject being dragged over the drop target.
dwKeyState | State of keys on the keyboard (including modifier keys). This is a combination of any number of the following: MK_CONTROL, MK_SHIFT, MK_ALT, MK_LBUTTON, MK_MBUTTON, and MK_RBUTTON.
point | Current mouse position relative to the Grid control.
nState | Transition state (0 enter, 1 leave, 2 over).
Returns
A value from the DROPEFFECT enumerated type which indicates the type of drop that would occur if the user dropped the object at this position. The type of drop often depends on the current key state as indicated by dwKeyState. A standard mapping of key states to DROPEFFECT values is: DROPEFFECT_NONE: The data object cannot be dropped in this window. DROPEFFECT_COPY for MK_CONTROL: Creates a copy of the dropped object. DROPEFFECT_MOVE for MK_ALT: Creates a copy of the dropped object and deletes the original object. This is typically the default drop effect when the view can accept the data object.

◆ OnDraw()

virtual void OnDraw ( CDC * pDC )
protectedvirtual

Performs all drawing logic.

Parameters
pDC Provided device context to draw control image with.

◆ OnDrop()

virtual BOOL OnDrop | ( | COleDataObject * | pDataObject,
 |  | DROPEFFECT | dropEffect,
 |  | CPoint | point )
 protectedvirtual

This member is called when an item has been dropped into the Grid control.

Parameters
pDataObject | Pointer to the COleDataObject dropped into the drop target.
dropEffect | Drop effect requested by the user; can be any of the values listed in the Remarks section.
point | Current mouse position relative to the Grid control.

The dropEffect parameter can be one of the following values: DROPEFFECT_COPY: Creates a copy of the data object being dropped. DROPEFFECT_MOVE: Moves the data object to the current mouse location.

Returns
TRUE if the drop was successful, otherwise FALSE.

◆ OnFocusChanging()

virtual BOOL OnFocusChanging | ( | CXTPGridRow * | pNewRow,
 |  | CXTPGridColumn * | pNewCol )
 protectedvirtual

This member function is called before the focus changes.

Parameters
pNewRow | Pointer to the newly focused row object.
pNewCol | Pointer to the newly focused column object.

Before the user changes the focused row or column, the Grid control sends a notification to the parent window by calling OnFocusChanging().

Returns
TRUE if the operation will continue, FALSE if the operation will be canceled.
See also
XTP_NM_GRID_FOCUS_CHANGING, SendNotifyMessage(), OnFocusChanged

◆ OnGetColumnDataBestFitWidth()

virtual int OnGetColumnDataBestFitWidth ( CXTPGridColumn * pColumn )
protectedvirtual

This method is used by the Grid control to calculate the best-fit column width.

Parameters
pColumn Pointer to a column for width calculation.
Returns
The best-fit column width if successful, otherwise a value of 0.

◆ OnGetItemsCaptionMaxWidth()

virtual int OnGetItemsCaptionMaxWidth | ( | CDC * | pDC,
 |  | CXTPGridRows * | pRows,
 |  | CXTPGridColumn * | pColumn,
 |  | int | nStartRow = 0,
 |  | int | nRowsCount = -1 )
 protectedvirtual

This method is used by the Grid control to calculate the items captions maximum width.

Parameters
pDC | Pointer to a valid device context.
pRows | Pointer to a rows collection.
pColumn | Pointer to a column for width calculation.
nStartRow | Index of the row to begin calculating from.
nRowsCount | Number of rows to include within the calculation (i.e. the rows specified by this parameter includes both nStartRow and the rows that immediately follow nStartRow).
Returns
The items captions maximum width.

◆ OnGetToolTipInfo()

virtual const XTP_NM_GRIDTOOLTIPINFO & OnGetToolTipInfo | ( | CXTPGridRow * | pRow,
 |  | CXTPGridRecordItem * | pItem,
 |  | CString & | rstrToolTipText )
 protectedvirtual

This method is called to get the tooltip text for the current record item.

Parameters
pRow | Pointer to the current row object.
pItem | Pointer to the current record item object.
rstrToolTipText | Reference to a CString object to customize the tooltip text. It contains default tooltip text.

If rstrToolTipText is set to empty, then the default tooltip will be shown when there is not enough space to draw item text. If rstrToolTipText is set to a single space (" "), then no tooltip will be shown.

Returns
A reference to an XTP_NM_GRIDTOOLTIPINFO structure.

◆ OnPreviewKeyDown()

virtual BOOL OnPreviewKeyDown | ( | UINT & | rnChar,
 |  | UINT | nRepCnt,
 |  | UINT | nFlags )
 protectedvirtual

This method is called before processing the OnKeyDown event.

Parameters
rnChar | [in/out] Reference to a variable that specifies the virtual key code of the given key. For a list of standard virtual key codes, see Winuser.h.
nRepCnt | [in] Repeat count (the number of times that the keystroke is repeated as a result of the user holding down the key).
nFlags | [in] Specifies the scan code, key-transition code, previous key state, and context code.

If you would like to customize keyboard behavior, then you can either change the rnChar parameter value or perform your logic and then return FALSE to disable default processing.

Default implementation sends an XTP_NM_GRID_PREVIEWKEYDOWN notification.

Returns
TRUE if the operation will continue, FALSE if the operation will be canceled.
See also
OnKeyDown, CWnd::OnKeyDown, XTP_NM_GRID_PREVIEWKEYDOWN.

◆ OnSelectionChanged()

virtual void OnSelectionChanged ( )
protectedvirtual

This member function is called after a user selects a row or a column.

After the user selects a row or column, the Grid control sends a notification to the parent window by calling OnSelectionChanged().

See also
XTP_NM_GRID_SELCHANGED, SendNotifyMessage()

◆ Paste()

virtual void Paste ( )
virtual

Reads records from the clipboard and adds them to the records collection (the binary data format is used rather than the text data format).

See also
CanCut, CanCopy, CanPaste, Cut, Copy, OnBeforeCopyToText, OnBeforePasteFromText, OnBeforePaste.

◆ PinFooterRows()

void PinFooterRows ( BOOL bPin = FALSE )

Specifies if footer records are pinned to the last body row.

Parameters
bPin TRUE to pin footer records to the last body row, FALSE to dock footer records to the footer.

By default, footer records are docked to the footer.

See also
IsFooterRowsVisible, ShowFooterRows

◆ PinFooterRowsPrinted()

AFX_INLINE void PinFooterRowsPrinted ( BOOL bPin = FALSE )

Specifies if footer records are pinned to the last body row.

This method is used only in printing mode.

Parameters
bPin TRUE to pin footer records to the last body row, FALSE to dock footer records to the footer.

By default, footer records are docked to the footer.

See also
IsFooterRowsVisible, ShowFooterRows

◆ Populate()

virtual void Populate ( )
virtual

Performs control population, creating a view from the data.

Call this member function to populate control's rows collection with the data containing in the records collection. This method automatically creates Tree View references if necessary (e.g. in Grouping mode). This method is the main function which should be called for (re)populating all data changes made in the records collection.

See also
CXTPGridPaintManager overview

Reimplemented in CXTPTrackControl.

◆ PopulateFooterRows()

virtual void PopulateFooterRows ( )
virtual

Performs control's footer rows population, creating a view from the data.

Call this member function to populate control's footer rows collection with the data contained in the footer records collection. This method is useful when main rows are controlled through the use of the AddRecordEx/RemoveRecordEx/UpdateRecord methods.

See also
Populate, PopulateHeaderRows, AddRecordEx, RemoveRecordEx, UpdateRecord

◆ PopulateHeaderRows()

virtual void PopulateHeaderRows ( )
virtual

Performs control's header rows population, creating a view from the data.

Call this member function to populate control's header rows collection with the data contained in the header records collection. This method is useful when main rows are controlled through the use of the AddRecordEx/RemoveRecordEx/UpdateRecord methods.

See also
Populate, PopulateFooterRows, AddRecordEx, RemoveRecordEx, UpdateRecord

◆ PreviewAllowEdit()

AFX_INLINE void PreviewAllowEdit ( BOOL bAllowEdit )

Enables/disables preview editing.

Parameters
bAllowEdit TRUE to enable preview editing, FALSE to disable preview editing.

◆ Recalc()

void Recalc ( BOOL bAll = FALSE )

Recalculates and redraws rows.

Parameters
bAll TRUE to recalculate and redraw all rows, FALSE to recalculate and redraw only the focused row.

◆ RedrawControl()

void RedrawControl ( )

Initiates Grid control redrawing.

Call this member function if you want to initialize Grid control redrawing. The control will be redrawn taking into account its latest state.

See also
BeginUpdate, EndUpdate

◆ RegisterWindowClass()

BOOL RegisterWindowClass ( HINSTANCE hInstance = NULL )

Registers the window class if it has not already been registered.

Parameters
hInstance Instance of the resource where the control is located.
Returns
TRUE if the window class was successfully registered.

◆ RelayToolTipEvent()

virtual void RelayToolTipEvent ( UINT message )
protectedvirtual

Relays a tooltip event.

Parameters
message Windows message.

◆ ReleaseItem()

void ReleaseItem ( int nIndex )

Call this method to remove all items and column in specified position.

Parameters
nIndex Index of item to remove.

◆ RemoveRecordEx()

virtual BOOL RemoveRecordEx | ( | CXTPGridRecord * | pRecord,
 |  | BOOL | bAdjustLayout = TRUE,
 |  | BOOL | bRemoveFromParent = TRUE )
 virtual

Removes a specified record, the row associated with the specified record, and all child records and rows.

Parameters
pRecord | Pointer to a CXTPGridRecord object to remove.
bAdjustLayout | TRUE to call the AdjustLayout method.
bRemoveFromParent | TRUE to remove the record from its parent.

Call this member function if you want to remove a record and row on the fly without calling the Populate method.

Returns
TRUE if the operation was successful, otherwise FALSE.
See also
RemoveRowEx, AddRecordEx, CXTPGridRecords::RemoveRecord, UpdateRecord

◆ RemoveRowEx()

virtual BOOL RemoveRowEx | ( | CXTPGridRow * | pRow,
 |  | BOOL | bAdjustLayout = TRUE )
 virtual

Removes a specified row, the record associated with the specified row, and all child rows and records.

Parameters
pRow | Pointer to a CXTPGridRow object to remove.
bAdjustLayout | TRUE to call the AdjustLayout method.

Call this member function if you want to remove a row and record on the fly without calling the Populate method.

Returns
TRUE if the operation was successful, otherwise FALSE.
See also
RemoveRecordEx, AddRecordEx, CXTPGridRecords::RemoveRecord, UpdateRecord

◆ ResetContent()

void ResetContent ( BOOL bUpdateControl = TRUE )

Deletes all rows and records from the Grid control.

Parameters
bUpdateControl TRUE to redraw the control, FALSE otherwise.

◆ ReSortRows()

virtual void ReSortRows ( )
protectedvirtual

Re-sorts the rows tree according to the sort order for columns.

This method works faster than Populate.

◆ SendMessageToParent()

LRESULT SendMessageToParent | ( | CXTPGridRow * | pRow,
 |  | CXTPGridRecordItem * | pItem,
 |  | CXTPGridColumn * | pColumn,
 |  | UINT | nMessage,
 |  | CPoint * | pPoint,
 |  | int | nHyperlink = -1 ) const

Notifies the parent control about an event that occurred.

Parameters
pRow | Pointer to the row of the event if used.
pItem | Pointer to the item of the event if used.
pColumn | Pointer to the column of the event if used.
nMessage | Message to be sent to the parent window.
pPoint | Pointer to the point where the message was sent from in client coordinates.
nHyperlink | Hyperlink order number where the message was sent from (or -1 if the message was not send from a hyperlink).

Sends a message to the parent control in the form of a WM_NOTIFY message with a specific structure attached.

Returns
The result of the message processing; its value depends on the message that was sent (see CWnd::SendMessage).
See also
CXTPGridControl overview, SendNotifyMessage

◆ SendNotifyMessage()

LRESULT SendNotifyMessage | ( | UINT | nMessage,
 |  | NMHDR * | pNMHDR = NULL ) const

Sends a specified message to the window.

Parameters
nMessage | Message to be sent.
pNMHDR | Notify header.
Returns
Nonzero if successful, otherwise zero.

◆ SerializeState()

virtual void SerializeState ( CArchive & ar )
virtual

(Re)Stores control configuration to/from the provided archive stream.

Parameters
ar Archive stream for serializing.

◆ SetAutoCheckItems()

AFX_INLINE void SetAutoCheckItems ( BOOL bAutoCheck )

Enables/disables auto-check mode for checkbox items.

Parameters
bAutoCheck TRUE to enable auto-check mode, FALSE to disable auto-check mode.

If auto-check mode is enabled, then the checkbox will become checked/unchecked automatically when the user clicks on the checkbox.

See also
IsAutoCheckItems, CXTPGridRecordItem::OnClick, CXTPGridRecordItem::OnChar

◆ SetAutoVScrollTimerResolution()

void SetAutoVScrollTimerResolution ( UINT nNewTimerResolution )

Sets the vertical scrolling timer resolution.

Parameters
nNewTimerResolution Vertical scrolling timer resolution, in milliseconds.
See also
CWnd::SetTimer

◆ SetCellFormula()

BOOL SetCellFormula | ( | int | row,
 |  | int | col,
 |  | CString | sFormula )

Sets the formula for a specified cell.

Parameters
row | Row index.
col | Column index.
sFormula | Formula to be set.
Returns
TRUE if successful, otherwise FALSE.

◆ SetCellText()

BOOL SetCellText | ( | int | row,
 |  | int | col,
 |  | CString | sText )

Sets the text for a specified cell.

Parameters
row | Row index.
col | Column index.
sText | Text string to be set.
Returns
TRUE if successful, otherwise FALSE.

◆ SetChanged()

AFX_INLINE void SetChanged ( BOOL bChanged = TRUE )
protected

Specifies if the internal control state was changed since the last drawing.

Parameters
bChanged TRUE if the internal control state was changed since the last drawing and the control must be republished.

This method is used for caching control image drawing.

◆ SetDisableReorderColumnsCount()

void SetDisableReorderColumnsCount ( int nCount )

Sets the number of columns at the left side where reordering is disabled.

Parameters
nCount Number of columns to be set.

◆ SetDragSensitivityX()

void SetDragSensitivityX ( int nDragSensitivityX )

Sets the horizontal sensitivity of Drag'n'Drop operations.

Parameters
nDragSensitivityX Horizontal sensitivity for Drag'n'Drop operations, in pixels. The value must not be scaled to DPI and must be in the range of 1-10000.
See also
GetDragSensitivityX, GetDragSensitivityY, SetDragSensitivityY

◆ SetDragSensitivityY()

void SetDragSensitivityY ( int nDragSensitivityY )

Sets the vertical sensitivity of Drag'n'Drop operation.

Parameters
nDragSensitivityY Vertical sensitivity for Drag'n'Drop operations, in pixels. The value must not be scaled to DPI and must be in the range of 1-10000.
See also
GetDragSensitivityX, SetDragSensitivityX, GetDragSensitivityY

◆ SetDropMarkerFlags()

AFX_INLINE void SetDropMarkerFlags ( DWORD dwDropMarkerFlags )

Sets the drop marker flags.

Parameters
dwDropMarkerFlags Drop marker flags.

◆ SetFastDeselectMode()

AFX_INLINE void SetFastDeselectMode ( BOOL bFastDeselect = TRUE )

Enables/disables Fast Deselect mode (like in Windows Explorer).

Parameters
bFastDeselect TRUE to enable Fast Deselect mode, FALSE to disable Fast Deselect mode.

◆ SetFilterHiddenColumns()

AFX_INLINE void SetFilterHiddenColumns ( BOOL bFilterHidden )
virtual

Enables/disables search filter text in hidden columns.

Parameters
bFilterHidden TRUE to enable search filter text in hidden columns, FALSE to disable search filter text in hidden columns.

This option is disabled by default. You must call the Populate method to update rows.

See also
IsFilterHiddenColumns, GetFilterText, SetFilterText, Populate

◆ SetFilterText()

AFX_INLINE void SetFilterText ( LPCTSTR strFilterText )
virtual

Sets the filter text for the control.

Parameters
strFilterText Filter text to be set.

You must call the Populate method to update rows.

See also
GetFilterText, Populate

◆ SetFocusedColumn()

BOOL SetFocusedColumn ( CXTPGridColumn * pColumn )

Sets the selected column.

Parameters
pColumn Column to be selected.
Returns
TRUE if the specified column was selected, otherwise FALSE.

◆ SetFocusedRow() [1/3]

BOOL SetFocusedRow | ( | BOOL | bEnsureVisible,
 |  | CXTPGridRow * | pRow,
 |  | BOOL | bShiftKey,
 |  | BOOL | bControlKey )

Sets the currently focused row in the Grid control's view.

Parameters
bEnsureVisible | TRUE to ensure that the row will be visible.
pRow | Pointer to a CXTPGridRow object.
bControlKey | TRUE to select a new focused row.
bShiftKey | TRUE to select rows up to the new focused row.
Returns
TRUE if the specified row has been focused, otherwise FALSE.

◆ SetFocusedRow() [2/3]

BOOL SetFocusedRow | ( | CXTPGridRow * | pRow,
 |  | BOOL | bControlKey = FALSE )

Sets the currently focused row in the Grid control's view.

Parameters
pRow | Pointer to a CXTPGridRow object.
bControlKey | TRUE to select a new focused row.
Returns
TRUE if the specified row has been focused, otherwise FALSE.

◆ SetFocusedRow() [3/3]

BOOL SetFocusedRow | ( | CXTPGridRow * | pRow,
 |  | BOOL | bShiftKey,
 |  | BOOL | bControlKey )

Sets the currently focused row in the Grid control's view.

Parameters
pRow | Pointer to a CXTPGridRow object.
bControlKey | TRUE to select a new focused row.
bShiftKey | TRUE to select rows up to the new focused row.
Returns
TRUE if the specified row has been focused, otherwise FALSE.

◆ SetFreezeColumnsCount()

void SetFreezeColumnsCount | ( | int | nCount,
 |  | BOOL | bReserved = FALSE )

Sets the number of frozen columns.

Parameters
nCount | Number of frozen columns to be set (e.g. 1 would make only one leftmost column frozen).
bReserved | TRUE for reserved.

◆ SetFullColumnScrolling()

void SetFullColumnScrolling ( BOOL bSet )

Sets the horizontal scrolling mode.

Parameters
bSet TRUE to set full columns scrolling mode, FALSE to set horizontal scrolling by pixels mode.
See also
IsFullColumnScrolling

◆ SetGridColor()

COLORREF SetGridColor ( COLORREF clrGridLine )

Sets the grid line color.

Parameters
clrGridLine Grid line color to be set.

Call this member function if you want to change the color of Grid control grid lines.

Returns
The previous grid line color.
See also
SetGridStyle, GetGridStyle

◆ SetGridHeader()

void SetGridHeader ( CXTPGridHeader * pGridHeader )

Sets the associated grid header object.

Parameters
pGridHeader Pointer to the grid header to be set.

Example:

m_wndGrid.SetGridHeader(new CMyGridHeader());
See also
CXTPGridHeader overview

◆ SetGridStyle()

void SetGridStyle | ( | XTPGridOrientation | orientation,
 |  | XTPGridGridStyle | gridStyle )

Sets the grid drawing style.

Parameters
orientation | Determines the grid style to set; must be one of the values defined by the XTPGridOrientation enumeration; xtpGridOrientationVertical to set the vertical grid style, xtpGridOrientationHorizontal to set the horizontal grid style.
gridStyle | Grid style to be set; must be one of the values defined by the XTPGridGridStyle enumeration.

Call this member function if you want to set the grid line drawing style for the Grid control.

Possible grid line drawing styles are the following: xtpGridGridNoLines: Empty line. xtpGridGridSmallDots: Line drawn by small dots. xtpGridGridLargeDots: Line drawn by large dots. xtpGridGridDashes: Line drawn by dashes. xtpGridGridSolid: Draws solid line.

See also
XTPGridGridStyle overview, GetGridStyle, SetGridColor

◆ SetGroupRowsBold()

void SetGroupRowsBold ( BOOL bBold = TRUE )

Sets the group rows text style: bold or normal.

Parameters
bBold TRUE for bold text style, FALSE for normal text style.
See also
IsGroupRowsBold, ShadeGroupHeadings, IsShadeGroupHeadingsEnabled, GetItemMetrics

◆ SetHScrollStep()

AFX_INLINE void SetHScrollStep ( int nStep )

Sets the horizontal scrolling step.

Parameters
nStep Horizontal scrolling step to be set, in pixels.

◆ SetIconColumn()

void SetIconColumn ( CXTPGridColumn * pColumn )

Sets a column to be an icon view column.

Parameters
pColumn Pointer to a CXTPGridColumn object.

◆ SetIconView()

void SetIconView ( BOOL bIconView = TRUE )

Toggles between Icon View mode and Grid View mode.

Parameters
bIconView TRUE for Icon View mode, FALSE for Grid View mode.

◆ SetIconViewToDefaults()

void SetIconViewToDefaults ( )

Resets the icon view column to its default values.

This method should be called in the event that the icon view column is destroyed.

◆ SetImageList()

void SetImageList ( CImageList * pImageList )

Sets the image list for the paint manager.

Parameters
pImageList Pointer to a CImageList object.

Use this function to set up your own image list with set bitmaps that represent various states of rows and depict any other information. Note: Recommended to use the SetImageManager/GetImageManager methods instead.

Example:

CImageList listIcons;
listIcons.Create(16, 16, ILC_COLOR24 | ILC_MASK, 0, 1));
CBitmap bmp;
// load bitmap by id
bmp.LoadBitmap(IDB_BMGRID);
ilIcons.Add(&bmp, RGB(255, 0, 255));
m_wndGrid.SetImageList(&lIcons);
See also
GetImageManager

◆ SetImageManager()

void SetImageManager ( CXTPImageManager * pImageManager )

Sets the image manager for the Grid control.

Parameters
pImageManager Image manager to be set

Example:

CXTPImageManager* pImageManager = new CXTPImageManager();
pImageManager->SetIcons(IDR_MAINFRAME);
m_wndGrid.SetImageManager(pImageManager);
See also
GetImageManager

◆ SetLastRqstEdit()

AFX_INLINE void SetLastRqstEdit | ( | int | iRqstEditRow,
 |  | int | iRqstEditCol )

Sets an arbitrary index for both the most recent row and most recent column that was requested for editing.

Parameters
iRqstEditRow | Index to be set for the most recent row.
iRqstEditCol | Index to be set for the most recent column.

◆ SetLayoutRTL()

void SetLayoutRTL ( BOOL bRightToLeft )

Sets right-to-left (RTL) mode.

Parameters
bRightToLeft TRUE to set right-to-left (RTL) reading-order properties.

◆ SetMouseMode()

void SetMouseMode ( XTPGridMouseMode nMode )

Sets the control mouse mode.

Parameters
nMode Mouse mode to be set; must be one of the values defined by the XTPGridMouseMode enumeration.
See also
XTPGridMouseMode overview, GetMouseMode

◆ SetMultipleSelection()

AFX_INLINE void SetMultipleSelection ( BOOL bMultipleSelection )

Enables/disables multiple selections for the Grid control.

Parameters
bMultipleSelection TRUE to enable multiple selections, FALSE to disable multiple selections.
See also
IsMultipleSelection, GetSelectedRows

◆ SetMultiSelectionMode()

AFX_INLINE void SetMultiSelectionMode ( BOOL bMultiSelectionMode )

Enables/disables multi-selection mode for the Grid control.

Parameters
bMultiSelectionMode TRUE to enable multi-selection mode, FALSE to disable multi-selection mode.

If multi-selection mode is enabled, then VK_CTRL is always ON.

See also
IsMultiSelectionMode

◆ SetNavigator()

void SetNavigator ( CXTPGridNavigator * pNavigator )

Sets the grid navigator.

Parameters
pNavigator Pointer to the grid navigator to be set.

◆ SetPaintManager()

void SetPaintManager ( CXTPGridPaintManager * pPaintManager )

Sets the paint manager object used to draw the Grid control window.

Parameters
pPaintManager Pointer to a CXTPGridPaintManager object.

◆ SetRecordsTreeFilterMode()

AFX_INLINE void SetRecordsTreeFilterMode ( int nMode )

Sets the filtering mode for the record tree.

Parameters
nMode Filtering mode to be set; must be one of the values defined by the XTPGridFilterMode enumeration.
See also
GetRecordsTreeFilterMode, XTPGridFilterMode

◆ SetRowsCompareFunc()

AFX_INLINE void SetRowsCompareFunc ( XTPGridRowsCompareFunc pCompareFunc )
virtual

Sets the compare function used to compare (and sort) rows.

Parameters
pCompareFunc XTPGridRowsCompareFunc function pointer to be used to compare rows, or NULL to use the default function.

This method uses Visual C++ run-time library (MSVCRT) implementation of the quick-sort function, qsort, for sorting stored CXTPGridRow objects. If pCompareFunc = NULL, then the default compare function is used. Call the Populate() method to re-sort items.

See also
SortRows, CXTPGridRows::SortEx, CXTPGridRows::Sort, CXTPGridRows::XTPGridRowsCompareFunc

◆ SetScrollMode()

void SetScrollMode | ( | XTPGridOrientation | orientation,
 |  | XTPGridScrollMode | scrollMode )

Sets the scroll mode.

Parameters
orientation | Orientation of the scroll mode to set; must be one of the values defined by the XTPGridOrientation enumeration.
scrollMode | Scroll mode to be set; must be one of the values defined by the XTPGridScrollMode enumeration.

◆ SetScrollOffsetH()

void SetScrollOffsetH ( int nOffset )

Sets the horizontal scroll position.

Parameters
nOffset Horizontal scroll position to be set.

This method only takes effect when auto-column sizing is disabled.

See also
CXTPGridHeader::SetAutoColumnSizing

◆ SetScrollOffsetV()

void SetScrollOffsetV ( int nOffset )

Sets the vertical scroll position.

Parameters
nOffset Vertical scroll position to be set.

◆ SetSelectionState()

void SetSelectionState | ( | int | index,
 |  | int | state )

Sets the selection state of a row.

Parameters
index | Index of the row.
state | Integer value denoting the state of the checkbox; must be one of the values defined by the XTPGridCheckState enumeration.

◆ SetSortRecordChilds()

AFX_INLINE void SetSortRecordChilds ( BOOL bSortRecordChildren )

Specifies if the sort order should be applied to record children.

Parameters
bSortRecordChildren TRUE to apply the sort order to record children, FALSE otherwise.

◆ SetTopRow()

void SetTopRow ( int nIndex )

Sets the top row of the Grid control view.

Parameters
nIndex Index of the row to be set.

The system scrolls the Grid control view upward until either the row specified by nIndex is at the top of the view or the maximum scroll range is reached.

See also
GetGridAreaRows, EnsureVisible

◆ SetTreeIndent()

void SetTreeIndent ( int nIndent )

Sets the indentation before the text of each child node in a hierarchical tree structure.

Parameters
nIndent Indentation to be set.

◆ SetVirtualMode()

void SetVirtualMode | ( | CXTPGridRecord * | pVirtualRecord,
 |  | int | nCount,
 |  | int | nFields = 0 )

Call this method to enable virtual mode of the control.

Parameters
pVirtualRecord | record to be used as virtual for all rows.
nCount | Count of virtual records.
nFields | number of fields to assign);

Example:

class CVirtualRecord : public CXTPGridRecord
{
   public:
   CVirtualRecord()
   {
      AddItem(new CXTPGridRecordItem());
      AddItem(new CXTPGridRecordItem());
      AddItem(new CXTPGridRecordItem());
   }

   void GetItemMetrics (XTP_GRIDRECORDITEM_DRAWARGS* pDrawArgs,
   XTP_GRIDRECORDITEM_METRICS* pItemMetrics)
   {
      // Draw virtual record
   }
}
...
m_wndGrid.SetVirtualMode(new CVirtualRecord(), 540);
See also
IsVirtualMode

◆ SetWatermarkAlignment()

AFX_INLINE void SetWatermarkAlignment ( int nWatermarkAlignment )

Sets the watermark alignment.

Parameters
nWatermarkAlignment Watermark alignment to be set; must be one of the values defined by the XTPGridWatermarkAlignment enumeration.
See also
XTPGridWatermarkAlignment, GetWatermarkAlignment.

◆ SetWatermarkBitmap() [1/2]

virtual BOOL SetWatermarkBitmap | ( | HBITMAP | hBitmap,
 |  | BYTE | Transparency )
 virtual

Sets the watermark bitmap to be shown in the Grid control background.

Parameters
hBitmap | Handle of the watermark bitmap.
Transparency | Transparency value.
Returns
TRUE if successful, otherwise FALSE.

◆ SetWatermarkBitmap() [2/2]

virtual BOOL SetWatermarkBitmap | ( | LPCTSTR | szPath,
 |  | BYTE | Transparency )
 virtual

Sets the watermark bitmap to be shown in the Grid control background.

Parameters
szPath | Path to the bitmap file of the watermark bitmap.
Transparency | Transparency value.
Returns
TRUE if successful, otherwise FALSE.

◆ ShadeGroupHeadings()

void ShadeGroupHeadings ( BOOL bEnable = TRUE )

Enables/disables group items shading.

Parameters
bEnable TRUE to enable group items shading, FALSE to disable group items shading.

Call this member function if you want to show/hide group rows' headings.

See also
IsShadeGroupHeadingsEnabled, IsGroupRowsBold, SetGroupRowsBold, GetItemMetrics

◆ ShowFooter()

AFX_INLINE void ShowFooter ( BOOL bShow = TRUE )

Sets the visible state of column footers.

Parameters
bShow TRUE to show column footers, FALSE to hide column footers.
See also
IsFooterVisible, ShowHeader

◆ ShowGroupBy()

AFX_INLINE void ShowGroupBy ( BOOL bEnable = TRUE )

Sets the visible state of the Group By area.

Parameters
bEnable TRUE to show the Group By area FALSE to hide the Group By area.

Call this member function if you want to show/hide the Group By area in the grid header.

See also
IsGroupByVisible

◆ ShowHeader()

AFX_INLINE void ShowHeader ( BOOL bShow = TRUE )

Sets the visible state of column headers.

Parameters
bShow TRUE to show column headers, FALSE to hide column headers.
See also
IsHeaderVisible, ShowFooter

◆ ShowIconWhenEditing()

void ShowIconWhenEditing ( BOOL bShow )

Specifies if item icons should be shown while the item is being edited.

Parameters
bShow TRUE to show item icons, FALSE otherwise.

◆ ShowRowFocus()

AFX_INLINE void ShowRowFocus ( BOOL bShow )

Specifies if row focus should be shown.

Parameters
bShow TRUE to show row focus, FALSE otherwise.
See also
IsRowFocusVisible

◆ ShowRowNumber()

void ShowRowNumber ( BOOL bSet )

Specifies if the row number should be shown.

Parameters
bSet TRUE to show the row number, FALSE otherwise.

◆ SkipGroupsFocus()

AFX_INLINE void SkipGroupsFocus ( BOOL bSkipFocus )

Specifies if groups are skipped when navigating the Grid control by using the Up and Down keys.

Parameters
bSkipFocus TRUE to skip group headings and select the next non-group heading row when navigating the Grid control by using the Up and Down keys, FALSE to cause all rows to be selected (including group headings) when navigating the Grid control by using the Up and Down keys.

◆ UpdateRecord()

virtual void UpdateRecord | ( | CXTPGridRecord * | pRecord,
 |  | BOOL | bUpdateChildren )
 virtual

Updates a specified record.

Parameters
pRecord | Pointer to a CXTPGridRecord object to update.
bUpdateChildren | TRUE to update the children of pRecord.

Call this member function if you modified a record and want it to be updated according to the current grouping and sorting.

See also
CXTPGridRecord overview, GetRecords

◆ UseGridCustomHeap()

static BOOL AFX_CDECL UseGridCustomHeap ( )
static

Call this function to use the custom heap feature.

If it is enabled, grid data will be allocated in custom (separate) heap instead of standard application heap. This optimize memory using (fragmentation) for big amount of data. For custom heap used for classes derived from CXTPHeapObjectT template, like CXTPGridRecord, CXTPGridRecordItem, CXTPGridRow and so others. This template just overrides operators new and delete.

It must be called on initialization before any allocations of classes which use custom heap. OnInitInstance is a fine place for this.

Returns
TRUE if custom heap feature is enabled for all grid allocators, FALSE otherwise.

◆ UseRowBatchAllocation()

static BOOL AFX_CDECL UseRowBatchAllocation ( )
static

Call this function to enable the batch allocation feature for grid rows.

Batch allocation means that memory allocated not for one object only, but for many objects at one time (for 1024 objects by default). Next allocations take memory from this big block. New blocks allocated when necessary. This increase performance and reduce heap fragmentation. Batch allocation mechanism responsible for allocation/deallocation blocks of memory from heap and internally organize free/busy lists of memory pieces. When object deleted, its memory stored in free list and used for new objects. When all memory pieces from block free, it may be deallocated from heap automatically (this depends on options in _TBatchAllocData) or by FreeExtraData call,

It must be called on initialization before any allocations of classes which use batch allocation. OnInitInstance is a fine place for this.

Returns
TRUE if batch allocation feature is enabled for grid rows, FALSE otherwise.

Member Data Documentation

◆ m_bAdjustLayoutRunning

BOOL m_bAdjustLayoutRunning
protected

TRUE if AdjustLayout handler is entered, FALSE otherwise.

Used to prevent OnSize reenter and stack overflow in Win95/98/ME.

◆ m_bIconView

BOOL m_bIconView
protected

TRUE if icon view, FALSE otherwise.

Height of a grid cell for items in large icon view, in pixels. Each item fits into a rectangle of size SM_CXICONSPACING by SM_CYICONSPACING when arranged. This value is always greater than or equal to SM_CYICON.

◆ m_bMultiSelectionMode

BOOL m_bMultiSelectionMode
protected

TRUE if multi-selection mode is enabled (i.e.

VK_CTRL is always on).

◆ m_nDragSensitivityX

int m_nDragSensitivityX
protected

Horizontal sensitivity of Drag'n'Drop operation (in pixels).

Default value is 3. DPI aware.

◆ m_nDragSensitivityY

int m_nDragSensitivityY
protected

Vertical sensitivity of Drag'n'Drop operation (in pixels).

Default value is 3. DPI aware.

◆ m_nLockUpdateCount

int m_nLockUpdateCount
protected

A counter of the update locks.

An image will be redrawn only when the lock counter is equal to zero.

◆ m_pPrevGroupsOrder

CXTPGridColumnOrder* m_pPrevGroupsOrder
protected

The previous group column order.

Visible columns before setting icon view

◆ m_pRows

CXTPGridRows* m_pRows
protected

Virtual list rows container.

Used for changing order, etc.

◆ m_sCustomTitle

CString m_sCustomTitle

Used for a unique title (e.g.

for PrintJob name).

The documentation for this class was generated from the following file:
  • XTPGridControl.h


Toolkit Pro: CXTPGridControl::CUpdateContext Class Reference

  • CXTPGridControl
  • CUpdateContext
Public Member Functions | Protected Attributes | List of all members
CXTPGridControl::CUpdateContext Class Reference

Internal grid update helper. More...

Public Member Functions

CUpdateContext (CXTPGridControl *pControl)
Constructs a CUpdateContext object.
~CUpdateContext ()
Destroys a CUpdateContext object, handles cleanup and deallocation.

Protected Attributes

CXTPGridControl * m_pControl
Updated Grid control pointer.

Detailed Description

Internal grid update helper.

Constructor & Destructor Documentation

◆ CUpdateContext()

CUpdateContext ( CXTPGridControl * pControl )
inline

Constructs a CUpdateContext object.

Parameters
pControl Pointer to a Grid Control object.
The documentation for this class was generated from the following file:
  • XTPGridControl.h


Toolkit Pro: CXTPGridControlLocale Class Reference

Static Public Member Functions | List of all members
CXTPGridControlLocale Class Reference

Helper class with static member functions used to control active locale for Grid control and perform some locale dependent tasks. More...

Static Public Member Functions

static BOOL AFX_CDECL | IsUseResourceFileLocale ()
Determines which locale is to be used as an active locale: current user locale or resource file locale.
static void AFX_CDECL | SetUseResourceFileLocale (BOOL bUseResourceFileLocale)
Used to set which locale is to be used as an the active locale: current user locale or resource file locale.
static LCID AFX_CDECL | GetActiveLCID ()
Retrieves the active locale ID (resource file locale or current user locale).
static BOOL AFX_CDECL | VariantChangeTypeEx (VARIANT &rVarValue, VARTYPE vartype, BOOL bThrowError=TRUE)
Changes the type of a VARIANT value using the active locale ID.
static CString AFX_CDECL | FormatDateTime (const COleDateTime &dt, LPCTSTR lpcszFormatString)
Formats a string using strftime() function format specifiers.

Detailed Description

Helper class with static member functions used to control active locale for Grid control and perform some locale dependent tasks.

Member Function Documentation

◆ FormatDateTime()

static CString AFX_CDECL FormatDateTime | ( | const COleDateTime & | dt,
 |  | LPCTSTR | lpcszFormatString )
 static

Formats a string using strftime() function format specifiers.

The active locale ID is used.

Parameters
dt | [in] Reference to a COleDateTime object containing a date-time value to format.
lpcszFormatString | [in] Format-control string.
Returns
A string containing a date-time formatted using the active locale ID.
See also
GetActiveLCID, strftime

◆ GetActiveLCID()

static LCID AFX_CDECL GetActiveLCID ( )
static

Retrieves the active locale ID (resource file locale or current user locale).

Returns
If the used active locale is the resource file locale, then the resource file locale ID is returned. If the used active locale is the current user locale, then LOCALE_USER_DEFAULT is returned.
See also
CXTPResourceManager::GetResourcesLangID, LOCALE_USER_DEFAULT

◆ IsUseResourceFileLocale()

static BOOL AFX_CDECL IsUseResourceFileLocale ( )
static

Determines which locale is to be used as an active locale: current user locale or resource file locale.

Returns
TRUE if a resource file locale is used as an active locale, FALSE otherwise.
See also
SetUseResourceFileLocale, CXTPResourceManager::GetResourcesLangID, GetActiveLCID, LOCALE_USER_DEFAULT

◆ SetUseResourceFileLocale()

static void AFX_CDECL SetUseResourceFileLocale ( BOOL bUseResourceFileLocale )
static

Used to set which locale is to be used as an the active locale: current user locale or resource file locale.

Parameters
bUseResourceFileLocale If TRUE, the resource file locale will be used, if FALSE, the current user locale will be used.
Returns
If TRUE, the resource file locale will be used, if FALSE, the current user locale will be used
See also
IsUseResourceFileLocale, CXTPResourceManager::GetResourcesLangID, GetActiveLCID, LOCALE_USER_DEFAULT

◆ VariantChangeTypeEx()

static BOOL AFX_CDECL VariantChangeTypeEx | ( | VARIANT & | rVarValue,
 |  | VARTYPE | vartype,
 |  | BOOL | bThrowError = TRUE )
 static

Changes the type of a VARIANT value using the active locale ID.

Parameters
rVarValue | [in, out] Reference to a VARIANT value to change the type of.
vartype | [in] Type to change the VARIANT value to.
bThrowError | [in] TRUE to make the function throw an exception in the event that an error occurs, FALSE to make the function return TRUE or FALSE.
Returns
TRUE if successful, otherwise FALSE.
See also
GetActiveLCID, VariantChangeTypeEx API function.
The documentation for this class was generated from the following file:
  • XTPGridControl.h


Toolkit Pro: CXTPGridDataManager Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPGridDataManager Class Reference

Represents a grid data manager. More...

Inheritance diagram for CXTPGridDataManager:
[legend]

Public Member Functions

CXTPGridDataManager (CXTPGridControl *pGridControl)
Constructs a CXTPGridDataManager object.
virtual | ~CXTPGridDataManager ()
Destroys a CXTPGridDataManager object, handles cleanup and deallocation.
virtual void | SetDataSource (XTPGRIDADODB::_RecordsetPtr pDataSource)
Sets the data source.
virtual XTPGRIDADODB::_RecordsetPtr | GetDataSource () const
Gets the data source.
virtual BOOL | DataBind ()
Binds the data (i.e.
virtual HRESULT | CreateColumns ()
Creates the columns based on the fields.
virtual HRESULT | UpdateGridRecords (XTPGRIDADODB::_RecordsetPtr pRecordset)
Updates the grid records.
virtual HRESULT | AddGridRecords (XTPGRIDADODB::_RecordsetPtr pRecordset, BOOL bAddNow)
Adds a record to the Grid control.
virtual HRESULT | PrepareDeleteGridRecords (XTPGRIDADODB::_RecordsetPtr pRecordset)
Performs preperation for the deletion of grid records.
virtual void | ClearDeleteGridRecords ()
Clears deleted records.
virtual HRESULT | DeleteGridRecords ()
Deletes the grid records.
virtual HRESULT | DeleteGridRecords (XTPGRIDADODB::_RecordsetPtr pRecordset)
Deletes the grid records.
virtual HRESULT | UpdateField (CXTPGridRecordItemVariant *pItem)
Updates a field.
virtual HRESULT | UpdateRecord (CXTPGridRecord *pRecord, CXTPGridRecordItem *pItemChanged=NULL)
Updates a grid record.
virtual HRESULT | AddRecord (CXTPGridRecord *pRecord, BOOL bAddToGrid)
Adds a record.
virtual HRESULT | CreateEmptyRecord (CXTPGridRecord **ppRecord)
Creates an empty record.
virtual HRESULT | DeleteRecord (CXTPGridRecord *pRecord)
Deletes a record.
virtual XTP_GRIDDATAMANAGER_COM_ERROR | GetLastComError ()
Gets the last COM error.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

void | RemoveDataSource ()
Removes the data source.
void | ClearGridControl ()
Clears the Grid control.

Protected Attributes

CXTPGridControl * | m_pGridControl
Pointer to the Grid control.
XTPGRIDADODB::_ConnectionPtr | m_pConnection
The custom ADODB connection point.
XTPGRIDADODB::_RecordsetPtr | m_pDataSource
The data source.
CRstEvent * | m_pRstEvent
Pointer to the record set event object.
DWORD | m_dwRstEvent
The record set event.
CXTPGridRecords * | m_pDeleteRecords
The delete records.
BOOL | m_bLocalUpdate
Tells whether the update is local only.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

Represents a grid data manager.

Constructor & Destructor Documentation

◆ CXTPGridDataManager()

CXTPGridDataManager ( CXTPGridControl * pGridControl )

Constructs a CXTPGridDataManager object.

Parameters
pGridControl Pointer to a CXTPGridControl object.

Member Function Documentation

◆ AddGridRecords()

virtual HRESULT AddGridRecords | ( | XTPGRIDADODB::_RecordsetPtr | pRecordset,
 |  | BOOL | bAddNow )
 virtual

Adds a record to the Grid control.

Parameters
pRecordset | Pointer to a custom ADODB record set
bAddNow | Add now.
Returns
S_OK if the operation was successful, otherwise E_FAIL.

◆ AddRecord()

virtual HRESULT AddRecord | ( | CXTPGridRecord * | pRecord,
 |  | BOOL | bAddToGrid )
 virtual

Adds a record.

Parameters
pRecord | Pointer to a grid record object.
bAddToGrid | TRUE if the record should also be added to the Grid control, FALSE otherwise.
Returns
S_OK if the operation was successful, otherwise E_FAIL.

◆ CreateColumns()

virtual HRESULT CreateColumns ( )
virtual

Creates the columns based on the fields.

Returns
S_OK if the operation was successful, otherwise E_FAIL.

◆ CreateEmptyRecord()

virtual HRESULT CreateEmptyRecord ( CXTPGridRecord ** ppRecord )
virtual

Creates an empty record.

Parameters
ppRecord Pointer to a grid record pointer.
Returns
S_OK if the operation was successful, otherwise E_FAIL.

◆ DataBind()

virtual BOOL DataBind ( )
virtual

Binds the data (i.e.

brings the data to the control).

Returns
TRUE if the operation was successful, otherwise FALSE.

◆ DeleteGridRecords() [1/2]

virtual HRESULT DeleteGridRecords ( )
virtual

Deletes the grid records.

Returns
S_OK if the operation was successful, otherwise E_FAIL.

◆ DeleteGridRecords() [2/2]

virtual HRESULT DeleteGridRecords ( XTPGRIDADODB::_RecordsetPtr pRecordset )
virtual

Deletes the grid records.

Parameters
pRecordset - Pointer to a custom ADODB record set.
Returns
S_OK if the operation was successful, otherwise E_FAIL.

◆ DeleteRecord()

virtual HRESULT DeleteRecord ( CXTPGridRecord * pRecord )
virtual

Deletes a record.

Parameters
pRecord Pointer to a grid record object.
Returns
S_OK if the operation was successful, otherwise E_FAIL.

◆ GetDataSource()

AFX_INLINE XTPGRIDADODB::_RecordsetPtr GetDataSource ( ) const
virtual

Gets the data source.

Returns
A pointer to a custom ADODB object.

◆ GetLastComError()

virtual XTP_GRIDDATAMANAGER_COM_ERROR GetLastComError ( )
virtual

Gets the last COM error.

Returns
An XTP_GRIDDATAMANAGER_COM_ERROR value specifying the COM error.

◆ PrepareDeleteGridRecords()

virtual HRESULT PrepareDeleteGridRecords ( XTPGRIDADODB::_RecordsetPtr pRecordset )
virtual

Performs preperation for the deletion of grid records.

Parameters
pRecordset Pointer to a custom ADODB record set
Returns
S_OK if the operation was successful, otherwise E_FAIL.

◆ SetDataSource()

virtual void SetDataSource ( XTPGRIDADODB::_RecordsetPtr pDataSource )
virtual

Sets the data source.

Parameters
pDataSource Pointer to a custom ADODB object.

◆ UpdateField()

virtual HRESULT UpdateField ( CXTPGridRecordItemVariant * pItem )
virtual

Updates a field.

Parameters
pItem Pointer to a grid record item variant.
Returns
S_OK if the operation was successful, otherwise E_FAIL.

◆ UpdateGridRecords()

virtual HRESULT UpdateGridRecords ( XTPGRIDADODB::_RecordsetPtr pRecordset )
virtual

Updates the grid records.

Parameters
pRecordset Pointer to a custom ADODB record set.
Returns
S_OK if the operation was successful, otherwise E_FAIL.

◆ UpdateRecord()

virtual HRESULT UpdateRecord | ( | CXTPGridRecord * | pRecord,
 |  | CXTPGridRecordItem * | pItemChanged = NULL )
 virtual

Updates a grid record.

Parameters
pRecord | Pointer to a grid record object.
pItemChanged | Specifies an optional changed item pointer.
Returns
S_OK if the operation was successful, otherwise E_FAIL.
The documentation for this class was generated from the following file:
  • XTPGridDataManager.h


Toolkit Pro: CXTPGridFilterEditControl Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPGridFilterEditControl Class Reference

The CXTPGridFilterEditControl class provides the functionality of the filter string edit control associated to the main Grid control window. More...

Public Member Functions

CXTPGridFilterEditControl ()
Constructs a CXTPGridFilterEditControl object.
~CXTPGridFilterEditControl ()
Destroys a CXTPGridFilterEditControl object, handles cleanup and deallocation.
BOOL | SetGridCtrl (CXTPGridControl *pGridCtrl)
Sets the associated Grid control.
CXTPGridControl * GetGridCtrl ()
Gets the associated Grid control.
void | SetText (const CString &lpszText)
Sets the edit control text.
CString | GetText () const
Gets the edit control text.
void | SetHint (LPCTSTR lpszHint)
Sets the edit hint for the control (i.e.
CString | GetHint () const
Gets the edit hint of the control (i.e.

Protected Attributes

CXTPGridControl * | m_pGridCtrl
Pointer to the main Grid control.
CString | m_strHint
Grayed-out text displayed in the edit control to show a helpful description like "Enter filter text here".

Detailed Description

The CXTPGridFilterEditControl class provides the functionality of the filter string edit control associated to the main Grid control window.

It has all the functionality of the CEdit control, as well as some specific additions. This control should be instantiated in the user's application. To use a field chooser within an existing dialog box in your application, add a standard list box to your dialog template using the dialog editor and then initialize your CXTPGridSubListControl object inside the dialog OnInitialUpdate handler. See the example below:

Example:

// CXTPGridFilterEditControl wndFilter;
wndFilter.SubclassDlgItem(IDC_FILTEREDIT, &pFilterDialog);
// CXTPGridControl wndGrid;
wndGrid.GetColumns()->GetGridHeader()->SetFilterEditCtrl(&wndFilter);
See also
CEdit, CXTPGridHeader::SetFilterEditCtrl

Constructor & Destructor Documentation

◆ CXTPGridFilterEditControl()

CXTPGridFilterEditControl ( )

Constructs a CXTPGridFilterEditControl object.

You construct a CXTPGridFilterEditControl object in two steps. First, call the CXTPGridFilterEditControl constructor. Second, call Create. This initializes the Windows edit box and attaches it to the CXTPGridFilterEditControl.

Example:

// Declare a local CXTPGridFilterEditControl object.
CXTPGridFilterEditControl myFilterEdit;

// Declare a dynamic CXTPGridFilterEditControl object.
CXTPGridFilterEditControl* pMyFilterEdit = new CXTPGridFilterEditControl;
See also
CEdit, SetGridCtrl, CXTPGridHeader::SetFilterEditCtrl

Member Function Documentation

◆ GetGridCtrl()

CXTPGridControl * GetGridCtrl ( )

Gets the associated Grid control.

Returns
A pointer to the associated Grid control.
See also
CXTPGridHeader::SetFilterEditCtrl, SetGridCtrl

◆ GetHint()

CString GetHint ( ) const

Gets the edit hint of the control (i.e.

the grayed-out text displayed in the edit control that provides a helpful description of what the control is used for).

Returns
The edit hint of the control.
See also
SetHint

◆ GetText()

CString GetText ( ) const

Gets the edit control text.

Returns
The edit control text.

◆ SetGridCtrl()

BOOL SetGridCtrl ( CXTPGridControl * pGridCtrl )

Sets the associated Grid control.

Parameters
pGridCtrl Pointer to the associated Grid control to be set.

Usually this method should not be called by the user. Instead the user should call CXTPGridHeader::SetFilterEditCtrl.

Returns
TRUE if the associated Grid control was set successfully, otherwise FALSE.
See also
CXTPGridHeader::SetFilterEditCtrl, GetGridCtrl

◆ SetHint()

void SetHint ( LPCTSTR lpszHint )

Sets the edit hint for the control (i.e.

the grayed-out text displayed in the edit control that provides a helpful description of what the control is used for).

Parameters
lpszHint Edit hint to be set.

Example:

pEdit->SetHint(_T("Click to find a contact");
See also
GetHint

◆ SetText()

void SetText ( const CString & lpszText )

Sets the edit control text.

Parameters
lpszText New edit control text to be set.
The documentation for this class was generated from the following file:
  • XTPGridFilterEditControl.h


Toolkit Pro: CXTPGridGroupRow Class Reference

Public Member Functions | Public Attributes | Protected Member Functions | Protected Attributes | List of all members
CXTPGridGroupRow Class Reference

This class represents a 'group row' of the Grid control view. More...

Inheritance diagram for CXTPGridGroupRow:
[legend]

Public Member Functions

CXTPGridGroupRow ()
Constructs a CXTPGridGroupRow object.
virtual | ~CXTPGridGroupRow ()
Destroys a CXTPGridGroupRow object, handles cleanup and deallocation.
virtual CString | GetCaption () const
Gets the text caption.
virtual COleVariant | GetCaptionValue () const
Gets the optional native group caption value.
virtual CString | GetTooltip () const
Gets the tooltip text.
void | SetCaption (LPCTSTR lpszCaption)
Sets the text caption and, optionally, the group caption value.
void | SetCaption (LPCTSTR lpszCaption, COleVariant vtValue)
Sets the text caption and, optionally, the group caption value.
void | UpdateValue ()
Causes formula computed value to be updated.
virtual CString | GetFormula () const
Gets the group row formula.
virtual void | SetFormula (LPCTSTR sFormula)
Sets the group row formula.
virtual CString | GetFormatString () const
Gets the group row caption format string.
virtual void | SetFormatString (LPCTSTR strFormat)
Sets the group row caption format string.
virtual void | Draw (CDC *pDC, CRect rcRow, CRect rcClip, int nLeftOffset, CXTPGridRecordMergeItems &mergeItems, int nColumnFrom, int nColumnTo)
Draws the group row on the specified device context.
void | OnClick (CPoint ptClicked)
Processes single mouse clicks.
void | OnDblClick (CPoint ptClicked)
Processes double mouse clicks.
BOOL | IsGroupRow () const
Determines if this row is a group row.
virtual void | ResetMarkupUIElement ()
Resets the Markup element.
virtual void | SetControl (CXTPGridControl *pControl)
Sets a pointer to the parent Grid control.
void | SetCurrencyFormat (LPCURRENCYFMT fmt)
Sets a pointer to the LPCURRENCYFMT (i.e.
- Public Member Functions inherited from CXTPGridRow
CXTPGridRow ()
Constructs a CXTPGridRow object.
virtual | ~CXTPGridRow ()
Destroys a CXTPGridRow object, handles cleanup and deallocation.
virtual void | InitRow (CXTPGridRow *pRow)
Performs initial initialization for the current row.
virtual void | InitRow (CXTPGridControl *pControl, CXTPGridSection *pSection, CXTPGridRecord *pRecord)
Performs initial initialization for the current row.
virtual CXTPGridRecord * | GetRecord () const
Gets the record associated with the current row.
virtual int | GetHeight (CDC *pDC, int nWidth)
Calculates the height of the current row depending on the specified device context.
virtual int | GetIndex () const
Gets the current row index in the view.
virtual BOOL | IsFocused () const
Gets the focused state of the current row.
virtual BOOL | IsSelected () const
Gets the selected state of the current row.
virtual BOOL | IsExpanded () const
Gets the expanded state of the current row.
virtual void | SetExpanded (BOOL bExpanded, BOOL bRecursive=FALSE)
Sets the expanded state for the current row.
virtual void | _SetExpanded (BOOL bExpanded, BOOL bRecursive, BOOL bNotify)
Sets the expanded state for the current row.
void | SetFullExpanded (BOOL bExpanded)
Sets the expanded state for the current row and its children.
virtual BOOL | IsVisible () const
Determines the visible state of the current row.
virtual void | SetVisible (BOOL bVisible)
Sets the visible state for the current row.
virtual BOOL | IsLockExpand () const
Determines if the user's ability to collapse/expand rows is locked.
virtual void | LockExpand (BOOL bLockExpand)
Specifies if the user's ability to collapse/expand rows should be locked.
virtual void | SetSelected (BOOL bSelected)
Sets the selected state for the current row.
virtual void | SelectChilds ()
Selects all child items of the current row.
virtual CXTPGridRecordItem * | HitTest (CPoint ptPoint, CRect *pRectItem=NULL, CXTPGridColumn **ppColumn=NULL) const
Determines which grid item, if any, is at a specified point.
virtual BOOL | OnLButtonDown (XTP_GRIDRECORDITEM_CLICKARGS *pClickArgs)
Processes mouse left button down clicks.
virtual BOOL | OnLButtonUp (XTP_GRIDRECORDITEM_CLICKARGS *pClickArgs)
Processes mouse left button up clicks.
virtual void | OnMouseMove (UINT nFlags, CPoint point)
Processes the move mouse event.
virtual void | OnContextMenu (CPoint ptClick)
Processes context menu.
virtual void | ShowToolTip (CPoint ptTip, CXTPGridTip *pTipWnd)
Shows a specified tooltip window at a specified position.
virtual CXTPGridControl * | GetControl () const
Gets the parent Grid control.
virtual CXTPGridRow * | GetParentRow () const
Gets the parent row of the current row.
virtual CXTPGridRows * | GetParentRows () const
Gets the parent rows of the current row.
virtual int | GetTreeDepth () const
Gets the depth of the current row in tree view.
virtual BOOL | HasParent (CXTPGridRow *pRow)
Determines if a specified row has a parent row in tree view.
virtual CXTPGridRows * | GetChilds (BOOL bCreate=TRUE)
Gets the child collection of the current row.
virtual CXTPGridRow * | AddChild (CXTPGridRow *pRow)
Adds a child row to the current row.
virtual BOOL | HasChildren () const
Determines if the current row has child rows in tree view.
virtual CXTPGridRow * | GetNextSiblingRow () const
Gets the next sibling row of the current row.
virtual void | SetCollapseRect (CRect rcCollapse)
Sets the coordinates of the collapse/expand button for the current row.
virtual BOOL | IsPreviewVisible () const
Determines if the preview item is visible for the current row.
virtual BOOL | IsItemsVisible () const
Determines if items are visible.
virtual CRect | GetRect () const
Gets the coordinates of the row rectangle.
virtual void | GetItemMetrics (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pItemMetrics)
Gets the drawing metrics of the current row.
virtual int | GetGroupLevel () const
Gets the row depth level when the current row is a group row.
virtual CRect | GetItemRect (CXTPGridRecordItem *pItem)
Gets the rectangle of a specified item.
virtual BOOL | IsLastTreeRow () const
Determine if the current row is the last tree row or is not a part of a tree row.
virtual void | EnsureVisible ()
Ensures that the current row is visible.
virtual void | ShiftTreeIndent (CRect &rcItem, CXTPGridColumn *pColumn) const
Updates the rectangle of an item.
virtual void | FillMetrics (CXTPGridColumn *pColumn, CXTPGridRecordItem *pItem, XTP_GRIDRECORDITEM_METRICS *pMetrics)
Fills an XTP_GRIDRECORDITEM_METRICS structure with drawing metrics.
XTPGridRowType | GetType () const
Determine the type of the current row (i.e.
CXTPGridSection * | GetSection () const
Gets the section that the current row belongs to.
BOOL | HasMergedItems () const
Determines if the current row has merged items.
void | SetMergeHeight (int nMergeHeight)
Sets the height of the current row calculated during merge cell processing.
int | GetMergeHeight () const
Gets the height of the current row calculated during merge cell processing.
- Public Member Functions inherited from CXTPHeapObjectT< CXTPGridRowBase, CXTPGridRowAllocator >
void *PASCAL | operator new (size_t nSize)
Allocate memory block of nSize bytes.
void PASCAL | operator delete (void *p)
Free memory block previously allocated by operator new.

Public Attributes

CXTPMarkupUIElement * m_pMarkupUIElement
Store markup object.

Protected Member Functions

virtual INT_PTR | OnToolHitTest (CPoint point, TOOLINFO *pTI)
The framework calls this member function to determine whether a point is in the bounding rectangle of the specified tool.
CString | GetCurrencyString (double value)
Converts a value into a formatted currency string using m_lpCurrencyFmt.
- Protected Member Functions inherited from CXTPGridRow
CRect | GetItemRect (CXTPGridRecordItem *pItem, BOOL bAsMerged)
Gets the rectangle of a specified item.
virtual void | SetIndex (int nNewIndex)
Sets the index of the current row in the corresponding rows collection.
int | GetLastChildRow (CXTPGridRows *pChildren) const
Gets the index of the last child row in a specified child row collection.

Protected Attributes

CString | m_strGroupText
Group text label.
CString | m_strGroupLabel
Group text label - used as formula prefix.
CString | m_strFormula
The formula.
CString | m_strFormat
The format string.
COleVariant | m_vtCaptionValue
Native caption value.
LPCURRENCYFMT | m_lpCurrencyFmt
Contains information that defines the format of a currency.
- Protected Attributes inherited from CXTPGridRow
CXTPGridControl * | m_pControl
Pointer to the parent Grid control.
CXTPGridRecord * | m_pRecord
Pointer to the associated CXTPGridRecord object.
CXTPGridRow * | m_pParentRow
Pointer to the parent row in the tree.
CXTPGridRows * | m_pParentRows
Pointer to the parent rows in the tree.
CXTPGridRows * | m_pChilds
Pointer to collection of children.
CXTPGridSection * | m_pSection
Pointer to section the row belongs to.
CRect | m_rcRow
A rectangle where a row is to be drawn.
CRect | m_rcCollapse
A rectangle with coordinates of collapse/expand bitmap.
int | m_nIndex
Item index.
int | m_nGroupLevel
Contains row depth level when row is a group row.
int | m_nRowLevel
Row depth level in a tree.
BOOL | m_bVisible
TRUE if this row should be visible, FALSE if row is hidden.
BOOL | m_bExpanded
TRUE if row is expanded in a tree view, FALSE if row is collapsed.
BOOL | m_bLockExpand
TRUE if row cannot be expanded/collapsed by the user.
BOOL | m_bHasSelectedChilds
TRUE if the row has selected children (on any deep level).
int | m_nPreviewHeight
Height of the preview item of this row.
int | m_nFreeHeight
Height of row in FreeHeight RC mode.
int | m_nMergeHeight
Height of row which calculated on merge cells processing.
int | m_nChildIndex
Index of row inside parent rows.

Detailed Description

This class represents a 'group row' of the Grid control view.

A 'group row' is a row which has a special text caption instead of an associated record item.

CXTPGridGroupRow has a slightly different reaction on mouse events and another draw logic. All other behavior of the group row is similar to its parent.

See also
CXTPGridRow overview, CXTPGridControl overview

Member Function Documentation

◆ Draw()

virtual void Draw | ( | CDC * | pDC,
 |  | CRect | rcRow,
 |  | CRect | rcClip,
 |  | int | nLeftOffset,
 |  | CXTPGridRecordMergeItems & | mergeItems,
 |  | int | nColumnFrom,
 |  | int | nColumnTo )
 virtual

Draws the group row on the specified device context.

Parameters
pDC | Pointer to the device context in which the drawing occurs.
rcRow | Position of the row in client window coordinates.
rcClip | Position of the row in client window coordinates.
nLeftOffset | Left offset of the drawing, in pixels (horizontal scroll position).
mergeItems | Reference to the set of merged grid records.
nColumnFrom | Index of the column to begin drawing.
nColumnTo | Index of the column to end drawing.
See also
CXTPGridRow::Draw

Reimplemented from CXTPGridRow.

◆ GetCaption()

virtual CString GetCaption ( ) const
virtual

Gets the text caption.

Returns
The text caption.
See also
CXTPGridGroupRow::CXTPGridGroupRow

◆ GetCaptionValue()

virtual COleVariant GetCaptionValue ( ) const
virtual

Gets the optional native group caption value.

Returns
The optional native group caption value.
See also
CXTPGridGroupRow::CXTPGridGroupRow

◆ GetCurrencyString()

CString GetCurrencyString ( double value )
protected

Converts a value into a formatted currency string using m_lpCurrencyFmt.

Parameters
value Value to be converted.
Returns
The formatted currency string.

◆ GetFormatString()

AFX_INLINE CString GetFormatString ( ) const
virtual

Gets the group row caption format string.

Returns
The group row caption format string.

◆ GetFormula()

AFX_INLINE CString GetFormula ( ) const
virtual

Gets the group row formula.

Returns
The group row formula.

◆ GetTooltip()

AFX_INLINE CString GetTooltip ( ) const
virtual

Gets the tooltip text.

Returns
The tooltip text.

◆ IsGroupRow()

AFX_INLINE BOOL IsGroupRow ( ) const
virtual

Determines if this row is a group row.

Returns
TRUE since this row is a group row.
See also
CXTPGridRow::IsGroupRow

Reimplemented from CXTPGridRow.

◆ OnClick()

void OnClick ( CPoint ptClicked )
virtual

Processes single mouse clicks.

Parameters
ptClicked Point coordinates where the message was fired from.
See also
CXTPGridRow::OnClick

Reimplemented from CXTPGridRow.

◆ OnDblClick()

void OnDblClick ( CPoint ptClicked )
virtual

Processes double mouse clicks.

Parameters
ptClicked Point coordinates where the message was fired from.

The group row adds a collapse/expand function in the event that the double-click occurs on a row.

See also
CXTPGridRow::OnDblClick

Reimplemented from CXTPGridRow.

◆ OnToolHitTest()

virtual INT_PTR OnToolHitTest | ( | CPoint | point,
 |  | TOOLINFO * | pTI )
 protectedvirtual

The framework calls this member function to determine whether a point is in the bounding rectangle of the specified tool.

Parameters
point | Specifies the x- and y- coordinates of the cursor. These coordinates are always relative to the upper-left corner of the window.
pTI | Pointer to a TOOLINFO structure.
Returns
If the tooltip control was found, then the window control ID is returned. If the tooltip control was not found, then a value of -1 is returned.

Reimplemented from CXTPGridRow.

◆ ResetMarkupUIElement()

virtual void ResetMarkupUIElement ( )
virtual

Resets the Markup element.

See also
CXTPGridControl::EnableMarkup

◆ SetCaption() [1/2]

void SetCaption ( LPCTSTR lpszCaption )

Sets the text caption and, optionally, the group caption value.

Parameters
lpszCaption Caption to be set.

When a column that the GridRecordItem belongs to has been grouped, the caption of the column is displayed as the group caption. If you specify a caption with CXTPGridGroupRow::SetCaption for the GridRecordItem, then the m_strGroupText text will be displayed instead of the caption of the column. You can use CXTPGridGroupRow::SetCaption to "sub group" your GridRecordItems when the column that they belong to has been grouped. The GridRecordItems will be "sub grouped" by the value in m_strGroupText when the column that they belong to is grouped.

◆ SetCaption() [2/2]

void SetCaption | ( | LPCTSTR | lpszCaption,
 |  | COleVariant | vtValue )

Sets the text caption and, optionally, the group caption value.

Parameters
lpszCaption | Caption to be set.
vtValue | Optional group caption value.

When a column that the GridRecordItem belongs to has been grouped, the caption of the column is displayed as the group caption. If you specify a caption with CXTPGridGroupRow::SetCaption for the GridRecordItem, then the m_strGroupText text will be displayed instead of the caption of the column. You can use CXTPGridGroupRow::SetCaption to "sub group" your GridRecordItems when the column that they belong to has been grouped. The GridRecordItems will be "sub grouped" by the value in m_strGroupText when the column that they belong to is grouped.

◆ SetControl()

AFX_INLINE void SetControl ( CXTPGridControl * pControl )
virtual

Sets a pointer to the parent Grid control.

Parameters
pControl Pointer to the parent Grid control.
See also
CXTPGridControl overview

Reimplemented from CXTPGridRow.

◆ SetCurrencyFormat()

AFX_INLINE void SetCurrencyFormat ( LPCURRENCYFMT fmt )

Sets a pointer to the LPCURRENCYFMT (i.e.

the information that defines the format of a currency string).

Parameters
fmt Pointer to the LPCURRENCYFMT.

◆ SetFormatString()

AFX_INLINE void SetFormatString ( LPCTSTR strFormat )
virtual

Sets the group row caption format string.

Parameters
strFormat New group row caption format string to be set.

◆ SetFormula()

AFX_INLINE void SetFormula ( LPCTSTR sFormula )
virtual

Sets the group row formula.

Parameters
sFormula New group row formula to be set.
The documentation for this class was generated from the following file:
  • XTPGridGroupRow.h


Toolkit Pro: CXTPGridHeader Class Reference

Public Member Functions | Public Attributes | Static Public Attributes | Protected Types | Protected Member Functions | Protected Attributes | List of all members
CXTPGridHeader Class Reference

A grid header is a part of the grid window positioned above columns of text or numbers. More...

Inheritance diagram for CXTPGridHeader:
[legend]

Public Member Functions

CXTPGridHeader (CXTPGridControl *pControl, CXTPGridColumns *pColumns)
Constructs a CXTPGridHeader object.
virtual | ~CXTPGridHeader ()
Destroys CXTPGridHeader object, handles cleanup and deallocation.
BOOL | IsDragHeader () const
Determines if the header is being dragged.
void | AllowColumnRemove (BOOL bAllow)
Specifies if column removing is allowed.
BOOL | IsAllowColumnRemove () const
Determines if column removing is allowed.
void | AllowColumnReorder (BOOL bAllow)
Specifies if column reordering is allowed.
BOOL | IsAllowColumnReorder () const
Determines if column reordering is allowed.
void | AllowColumnResize (BOOL bAllow)
Specifies if column resizing is allowed.
BOOL | IsAllowColumnResize () const
Determines if column resizing is allowed.
void | ShowItemsInGroups (BOOL bShowInGroups)
Enables/disables show items in groups mode.
BOOL | IsShowItemsInGroups () const
Determines if show items in groups mode is enabled/disabled.
void | AllowColumnSort (BOOL bAllow)
Specifies if column sorting mode is allowed.
BOOL | IsAllowColumnSort () const
Determines if column sorting mode is allowed.
virtual CXTPGridColumn * | GetNextVisibleColumn (int nIndex, int nDirection)
Gets the next visible column in the array of columns.
virtual CXTPGridColumn * | HitTest (CPoint ptPoint) const
Determines which column, if any, is at a specified point.
virtual int | FindHeaderColumn (CPoint ptPoint) const
Calculates the header index of where to insert a column nearest to a specified point.
virtual int | FindGroupByColumn (CPoint ptPoint, BOOL bExactSearch=FALSE) const
Calculates index of where to insert a column nearest to the provided point.
virtual int | HitTestHeaderColumnIndex (CPoint ptPoint) const
private:
CXTPGridColumn * | MouseOverColumnResizeArea (CPoint ptPoint)
Determines if a specified point is over the column resize area.
int | GetFullColScrollInfo (CXTPGridColumn *&rpPrev, CXTPGridColumn *&rpCurr, CXTPGridColumn *&rpNext, int &rnScrollPos, int &rnScrollMax) const
Gets the current scroll information for full columns scroll mode and the helper information to scroll left or right.
void | AdjustColumnsWidth (int nTotalWidth, int nFirstIndex=0)
Adjusts the width of columns.
CXTPGridColumn * | GetDraggingColumn () const
Gets the dragging column if the control is in dragging mode.
CXTPGridColumn * | GetResizingColumn () const
Gets the resizing column if the control is in resizing mode.
BOOL | SetSubListCtrl (CXTPGridSubListControl *pSubList)
Sets the associated field chooser list control.
CXTPGridSubListControl * | GetSubListCtrl () const
Gets the associated field chooser list control.
BOOL | SetFilterEditCtrl (CXTPGridFilterEditControl *pFilterEdit)
Sets the associated filter edit control.
CXTPGridFilterEditControl * | GetFilterEditCtrl () const
Gets the associated filter edit control.
int | GetGroupByHeight () const
Gets the height of the Group By area, in pixels.
void | BestFit (CXTPGridColumn *pColumn)
Adjusts the width of a specified column to the width of the widest column item.
BOOL | IsLastVisibleColumn (CXTPGridColumn *pColumn) const
Determines if a specified column is the last visible column in the grid header.
BOOL | IsLastResizebleColumn (CXTPGridColumn *pColumn) const
Determines if a specified column in the last resizable column in the grid header.
int | GetIndentLevel () const
Gets the indent, in pixels, for a single level of tree depth for the Grid control in tree mode.
virtual void | OnColumnsChanged (int nReason, CXTPGridColumn *pColumn)
Updates header settings after any changes occur.
CXTPGridControl * | GetControl () const
Gets the parent Grid control.
void | SetAutoColumnSizing (BOOL bAutoColumnSizing)
Specifies if AutoColumnSizing should be used.
BOOL | IsAutoColumnSizing () const
Determines if AutoColumnSizing is used.
BOOL | ForceLayoutAdjustment () const
Call this member to determine m_bForceLayoutAdjustment flag.
int | GetWidth () const
Gets the total width of the header (i.e.
void | SetLastColumnExpand (BOOL bLastColumnExpand, BOOL bLastColumnExpandKeep)
Sets the expanded state of the last column.
int | GetMaxColumnWidth () const
Gets the maximum column width for all columns.
void | SetMaxColumnWidth (int nMaxColumnWidth)
Sets the maximum column width for all columns.
HCURSOR | GetResizeCursor () const
Gets the handler of the user's horizontal resizing cursor.
HCURSOR | GetResizeVCursor () const
Gets the handler of the user's vertical resizing cursor.
HCURSOR | GetDontDropCursor () const
Gets the handler of the user's Don't Drop cursor.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Public Attributes

BOOL m_bHideColumnAfterGroupBoxDrop
Tell whether to hide the column after group box drop.

Static Public Attributes

static int | s_nMinAutoScrollStep
Minimal horizontal auto-scrolling step, in pixels.
static BOOL | s_bShowItemsInGroupsPXDefault
Store default value of m_bShowItemsInGroups member for serialization (PropExchange).
static BOOL | s_bSendContextMenuForWholeHeaderArea
If TRUE, then the Grid control sends ContextMenu event for clicks on whole header area (not only for columns) rectangles.

Protected Types

enum GridDraggingMode {
dragNothing = 0 , dragOutTarget = 1 , dragInHeader = 2 , dragInGroupBox = 4 ,
dragInTarget = 6 , dragFieldChooser = 8
}
Specifies grid dragging mode. More...

Protected Member Functions

virtual void | Draw (CDC *pDC, CRect rcHeader, int nLeftOffset)
Draws columns header on a provided device context.
virtual void | DrawGroupByControl (CDC *pDC, CRect &rcGroupBy)
Draws Group By area on a provided device context.
virtual void | DrawFooter (CDC *pDC, CRect &rcFooter, int nLeftOffset)
Draws columns footer on a provided device context.
virtual void | OnLButtonDown (CPoint ptClick)
Processes mouse left button down clicks.
virtual void | OnLButtonDblClk (CPoint ptDblClick)
Processes mouse left button double clicks.
virtual void | OnLButtonUp (UINT nFlags, CPoint ptClick)
Processes mouse left button up clicks.
virtual void | OnContextMenu (CPoint ptClick)
Processes context menu.
CXTPGridPaintManager * | GetPaintManager () const
Gets the paint manager object used to draw the Grid control window.
virtual void | OnMouseMove (UINT nFlags, CPoint point)
Processes mouse movements.
virtual void | DoPropExchange (CXTPPropExchange *pPX)
Reads/writes configuration to/from the provided archive stream.
void | StartDragging (CXTPGridColumn *pColumn, BOOL bHeader=FALSE)
Starts column header dragging mode.
void | ResizeColumn (CXTPGridColumn *pColumn, int nWidth)
Resizes a specified column to a specified width and adjusts the width of other columns in correspondence with the specified column.
void | CancelMouseMode ()
Resets the mouse mode to xtpMouseNothing and performs all necessary cleanup operations.
int | GetMaxAvailWidth (CXTPGridColumn *pColumn)
Gets the maximum available width of a specified column, in pixels.
int | SetHotDivider (int nIndex, BOOL bHeader=TRUE)
Sets a hot divider between columns.
virtual INT_PTR | OnToolHitTest (CPoint point, TOOLINFO *pTI) const
The framework calls this member function to determine whether a point is in the bounding rectangle of the specified tool.

Protected Attributes

CXTPGridColumns * | m_pColumns
Pointer to the associated columns list.
CXTPGridControl * | m_pControl
Pointer to the parent Grid control.
int | m_nDropIndex
Item index of the column to drop to.
int | m_nVisIndex
Item visual index of the column to drag from.
CXTPGridHeaderDragWnd * | m_pDragWnd
Column drag window.
CXTPGridColumn * | m_pDragColumn
Dragging column.
CXTPGridColumn * | m_pResizeColumn
Resizing column.
CXTPGridColumn * | m_pHotTrackingColumn
Hot column.
BOOL | m_bDragHeader
Determines whether control is in header dragging mode or group by dragging mode.
BOOL | m_bDragGroupBox
Determines whether control is in group box dragging mode.
CXTPGridSubListControl * | m_pSubList
Field chooser list control.
CXTPGridFilterEditControl * | m_pFilterEdit
Filter edit control.
CRect | m_rcGroupBy
Group By area coordinates.
CRect | m_rcHeader
Header coordinates.
CPoint | m_ptMouse
Stores mouse coordinates for processing when required (resizing, etc.).
HCURSOR | m_hResizeCursor
Handler of the user's horizontal resizing cursor.
HCURSOR | m_hResizeVCursor
Handler of the user's vertical resizing cursor.
HCURSOR | m_hDontDropCursor
Handler of the user's Don't Drop cursor.
BOOL | m_bAllowColumnRemove
FALSE if columns removing is not allowed.
BOOL | m_bAllowColumnResize
FALSE if columns resizing is not allowed.
BOOL | m_bAllowColumnReorder
FALSE if columns reordering is not allowed.
BOOL | m_bAllowColumnSort
FALSE if columns sorting is not allowed.
BOOL | m_bAutoColumnSizing
TRUE if AutoColumnSizing should be used.
int | m_nResizeCaptureRange
Distance around column divider where column re-sizer is shown.
int | m_nIndentLevel
Width indent at the left of the column.
BOOL | m_bShowItemsInGroups
TRUE when showing items in groups, FALSE when grouping is not used.
int | m_nHeaderWidth
The combined width of all the visible column headers.
int | m_nForceLayoutAdjustment
Internal flag to Force Layout Adjustment (and also show scrollbar) if positive.
BOOL | m_bLastColumnExpand
Tells whether the last column is expanded or not.
BOOL | m_bLastColumnExpandKeep
Not used currently.
int | m_nMaxColumnWidth
Custom maximum column width.
enum CXTPGridHeader::GridDraggingMode | m_dragMode
Column dragging mode.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

A grid header is a part of the grid window positioned above columns of text or numbers.

It contains a title for each column, and it can be divided into parts. The user can drag the dividers that separate the parts to set the width of each column.

This class is responsible for header drawing on a grid window, processing user events, and changing header properties.

Functionality of the header includes the following: Header self-drawing. Header item custom ordering. Header item drag and drop, for the reordering of header items. Sorting grid rows with mouse clicks on a column header. Filtering grid row items using the associated CXTPGridFilterEditControl. Choosing header items using the associated field chooser control: CXTPGridSubListControl. Group By area support containing the order of grouped columns.

See also
CXTPGridControl, CXTPGridColumn, CXTPGridSubListControl

Member Enumeration Documentation

◆ GridDraggingMode

enum GridDraggingMode
protected

Specifies grid dragging mode.

Enumerator
dragNothing | User is dragging nothing.
dragOutTarget | User is dragging an item outside the drop target.
dragInHeader | User is dragging an item inside header
dragInGroupBox | User is dragging an item inside group box
dragInTarget | User is dragging an item inside the drop target.
dragFieldChooser | User is dragging an item inside field chooser.

Constructor & Destructor Documentation

◆ CXTPGridHeader()

CXTPGridHeader | ( | CXTPGridControl * | pControl,
 |  | CXTPGridColumns * | pColumns )

Constructs a CXTPGridHeader object.

Parameters
pColumns | Pointer to the associated columns array.
pControl | Pointer to the parent Grid control.

Example:

// Declare a local CXTPGridHeader object.
CXTPGridHeader  myHeader;

// Declare a dynamic CXTPGridHeader object.
CXTPGridHeader* pmyHeader = new CXTPGridHeader;

Member Function Documentation

◆ AdjustColumnsWidth()

void AdjustColumnsWidth | ( | int | nTotalWidth,
 |  | int | nFirstIndex = 0 )

Adjusts the width of columns.

Parameters
nTotalWidth | Total width of the header area, in pixels.
nFirstIndex | Index of the column to begin adjusting from.

Call this member function when you want to adjust the width of columns in reaction to any specific event. For example, this member function is called by the framework when changing the Grid control size (WM_SIZE) and when changing the size of any column by mouse dragging.

See also
ResizeColumn, GetMaxAvailWidth

◆ AllowColumnRemove()

AFX_INLINE void AllowColumnRemove ( BOOL bAllow )

Specifies if column removing is allowed.

Parameters
bAllow TRUE to allow column removing, FALSE to disallow.

Usually the user is allowed to remove a column using mouse drag and drop. Using this member function, you can change the user's permissions to force either allowing or disallowing column removing.

See also
IsAllowColumnRemove, CXTPGridColumn::AllowColumnRemove

◆ AllowColumnReorder()

AFX_INLINE void AllowColumnReorder ( BOOL bAllow )

Specifies if column reordering is allowed.

Parameters
bAllow TRUE to allow column reordering, FALSE to disallow.

Usually the user is allowed to reorder a column using mouse drag and drop. Using this member function, you can change the user's permissions to force either allowing or disallowing column reordering.

See also
IsAllowColumnReorder

◆ AllowColumnResize()

AFX_INLINE void AllowColumnResize ( BOOL bAllow )

Specifies if column resizing is allowed.

Parameters
bAllow TRUE to allow column resizing, FALSE to disallow.

Usually the user is allowed to resize a column using mouse drag and drop. Using this member function, you can change the user's permissions to force either allowing or disallowing column resizing.

See also
IsAllowColumnResize

◆ AllowColumnSort()

AFX_INLINE void AllowColumnSort ( BOOL bAllow )

Specifies if column sorting mode is allowed.

Parameters
bAllow TRUE to allow column sorting mode, FALSE to disallow.

Call this member function to specify whether the user is allowed to sort columns using the mouse.

See also
IsAllowColumnSort

◆ BestFit()

void BestFit ( CXTPGridColumn * pColumn )

Adjusts the width of a specified column to the width of the widest column item.

Parameters
pColumn Pointer to a CXTPGridColumn object.

◆ CancelMouseMode()

void CancelMouseMode ( )
protected

Resets the mouse mode to xtpMouseNothing and performs all necessary cleanup operations.

This member function is usually called when finishing dragging or resizing columns.

See also
StartDragging

◆ DoPropExchange()

virtual void DoPropExchange ( CXTPPropExchange * pPX )
protectedvirtual

Reads/writes configuration to/from the provided archive stream.

Parameters
pPX Pointer to a CXTPPropExchange object to serialize to/from.

◆ Draw()

virtual void Draw | ( | CDC * | pDC,
 |  | CRect | rcHeader,
 |  | int | nLeftOffset )
 protectedvirtual

Draws columns header on a provided device context.

Parameters
pDC | Pointer to the destination device context.
rcHeader | Reference to the rectangle in which the header is drawn.
nLeftOffset | Left offset in pixels (Horizontal scroll position).

Call this function to draw the header on the provided device context. Note that it does not contain the Group By area.

See also
DrawGroupByControl

Reimplemented in CXTPTrackHeader.

◆ DrawFooter()

virtual void DrawFooter | ( | CDC * | pDC,
 |  | CRect & | rcFooter,
 |  | int | nLeftOffset )
 protectedvirtual

Draws columns footer on a provided device context.

Parameters
pDC | Pointer to the destination device context.
rcFooter | Reference to the rectangle in which the footer is drawn.
nLeftOffset | Left offset in pixels (Horizontal scroll position).

Call this function to draw the footer on the provided device context.

See also
Draw

◆ DrawGroupByControl()

virtual void DrawGroupByControl | ( | CDC * | pDC,
 |  | CRect & | rcGroupBy )
 protectedvirtual

Draws Group By area on a provided device context.

Parameters
pDC | Pointer to the destination device context.
rcGroupBy | Reference to the rectangle of the Group By area.

Call this function to draw the Group By area on the provided device context.

See also
Draw

◆ FindGroupByColumn()

virtual int FindGroupByColumn | ( | CPoint | ptPoint,
 |  | BOOL | bExactSearch = FALSE ) const
 virtual

Calculates index of where to insert a column nearest to the provided point.

Parameters
ptPoint | Point coordinates to test.
bExactSearch | TRUE when search by exact position, FALSE when searching average value.
Returns
GroupBy column position.

◆ FindHeaderColumn()

virtual int FindHeaderColumn ( CPoint ptPoint ) const
virtual

Calculates the header index of where to insert a column nearest to a specified point.

Parameters
ptPoint Point coordinates.
Returns
The header index of where to insert a column nearest to the specified point.

◆ ForceLayoutAdjustment()

AFX_INLINE int ForceLayoutAdjustment ( ) const

Call this member to determine m_bForceLayoutAdjustment flag.

Returns
TRUE if the operation is successful, FALSE else.

◆ GetControl()

AFX_INLINE CXTPGridControl * GetControl ( ) const

Gets the parent Grid control.

Returns
A pointer to the parent Grid control.

◆ GetDontDropCursor()

AFX_INLINE HCURSOR GetDontDropCursor ( ) const

Gets the handler of the user's Don't Drop cursor.

Returns
The handler of the user's Don't Drop cursor.

◆ GetDraggingColumn()

CXTPGridColumn * GetDraggingColumn ( ) const

Gets the dragging column if the control is in dragging mode.

Returns
A pointer to the dragging column if the control is in dragging mode, or NULL otherwise.

Example:

CXTPGridColumn* pColumn = GetDraggingColumn();
See also
StartDragging, GetResizingColumn

◆ GetFilterEditCtrl()

AFX_INLINE CXTPGridFilterEditControl * GetFilterEditCtrl ( ) const

Gets the associated filter edit control.

Returns
A pointer to the associated filter edit control.
See also
CXTPGridFilterEditControl overview, SetFilterEditCtrl

◆ GetFullColScrollInfo()

int GetFullColScrollInfo | ( | CXTPGridColumn *& | rpPrev,
 |  | CXTPGridColumn *& | rpCurr,
 |  | CXTPGridColumn *& | rpNext,
 |  | int & | rnScrollPos,
 |  | int & | rnScrollMax ) const

Gets the current scroll information for full columns scroll mode and the helper information to scroll left or right.

Parameters
rpPrev | [out] Reference to a CXTPGridColumn pointer to receive the previous column (i.e. the next column when scrolling left). This parameter will be set to NULL if the current scrollbar position is on the leftmost column.
rpCurr | [out] Reference to a CXTPGridColumn pointer to receive the current column (i.e. the first visible column on the left).
rpNext | [out] Reference to a CXTPGridColumn pointer to receive the next column (i.e. the next column when scrolling right). This parameter will be set to NULL if the current scrollbar position is on the rightmost column.
rnScrollPos | [out] Reference to an integer value to receive the current scrollbar position.
rnScrollMax | [out] Reference to an integer value to receive the number of scrollbar positions.
Returns
The width of frozen columns, in pixels.

◆ GetGroupByHeight()

int GetGroupByHeight ( ) const

Gets the height of the Group By area, in pixels.

Calculates the height of the Group By area based on the number of items contained inside it.

Returns
The height of the Group By area, in pixels.

◆ GetIndentLevel()

AFX_INLINE int GetIndentLevel ( ) const

Gets the indent, in pixels, for a single level of tree depth for the Grid control in tree mode.

Returns
The indent, in pixels, for a single level of tree depth for the Grid control in tree mode.

◆ GetMaxAvailWidth()

int GetMaxAvailWidth ( CXTPGridColumn * pColumn )
protected

Gets the maximum available width of a specified column, in pixels.

Parameters
pColumn Pointer to a CXTPGridColumn object.

Calculates the maximum available width for a column depending on the width and modes of other columns.

Returns
The maximum available width of the specified column, in pixels.
See also
AdjustColumnsWidth, ResizeColumn

◆ GetMaxColumnWidth()

AFX_INLINE int GetMaxColumnWidth ( ) const

Gets the maximum column width for all columns.

Returns
The maximum column width for all columns.

◆ GetNextVisibleColumn()

virtual CXTPGridColumn * GetNextVisibleColumn | ( | int | nIndex,
 |  | int | nDirection )
 virtual

Gets the next visible column in the array of columns.

Parameters
nIndex | Position of a column in the array of columns to start from.
nDirection | Direction to move (left or right) in the array of columns starting from nIndex; must be one of the values defined by the xtpGridColumnDirectionRight enumeration
Returns
A pointer to the next visible column in the array of columns.

◆ GetPaintManager()

CXTPGridPaintManager * GetPaintManager ( ) const
protected

Gets the paint manager object used to draw the Grid control window.

Returns
A pointer to the paint manager object.
See also
CXTPGridPaintManager overview

◆ GetResizeCursor()

AFX_INLINE HCURSOR GetResizeCursor ( ) const

Gets the handler of the user's horizontal resizing cursor.

Returns
The handler of the user's horizontal resizing cursor.

◆ GetResizeVCursor()

AFX_INLINE HCURSOR GetResizeVCursor ( ) const

Gets the handler of the user's vertical resizing cursor.

Returns
The handler of the user's vertical resizing cursor.

◆ GetResizingColumn()

CXTPGridColumn * GetResizingColumn ( ) const

Gets the resizing column if the control is in resizing mode.

Returns
A pointer to the resizing column if the control is in resizing mode, or NULL otherwise.

Example:

CXTPGridColumn* pColumn = GetResizingColumn();
See also
StartDragging, GetDraggingColumn

◆ GetSubListCtrl()

AFX_INLINE CXTPGridSubListControl * GetSubListCtrl ( ) const

Gets the associated field chooser list control.

Returns
A pointer to the associated field chooser list control.
See also
SetSubListCtrl

◆ GetWidth()

AFX_INLINE int GetWidth ( ) const

Gets the total width of the header (i.e.

the total combined width of all columns).

Returns
The total width of the header (i.e. the total combined width of all columns).

◆ HitTest()

virtual CXTPGridColumn * HitTest ( CPoint ptPoint ) const
virtual

Determines which column, if any, is at a specified point.

Parameters
ptPoint Point to be tested in Grid control client coordinates.
Returns
A pointer to the CXTPGridColumn object at the specified point, if any, or NULL otherwise.
See also
CXTPGridControl::HitTest, CXTPGridRow::HitTest

◆ HitTestHeaderColumnIndex()

virtual int HitTestHeaderColumnIndex ( CPoint ptPoint ) const
virtual

private:

Gets the header column index at a specified point, if any.

Parameters
ptPoint Point to test in Grid control window client coordinates.
Returns
The header column index at the specified point, if any, otherwise a value of -1.

◆ IsAllowColumnRemove()

AFX_INLINE BOOL IsAllowColumnRemove ( ) const

Determines if column removing is allowed.

Call this member function to determine whether the user is allowed to remove the column using drag and drop or not.

Returns
TRUE if column removing is allowed, otherwise FALSE.
See also
AllowColumnRemove

◆ IsAllowColumnReorder()

AFX_INLINE BOOL IsAllowColumnReorder ( ) const

Determines if column reordering is allowed.

Call this member function to determine whether the user is allowed to reorder the column using drag and drop or not.

Returns
TRUE if column reordering is allowed, otherwise FALSE.
See also
AllowColumnReorder

◆ IsAllowColumnResize()

AFX_INLINE BOOL IsAllowColumnResize ( ) const

Determines if column resizing is allowed.

Call this member function to determine whether the user is allowed to resize a column using drag and drop or not.

Returns
TRUE if column resizing is allowed, FALSE to disallow.
See also
AllowColumnResize

◆ IsAllowColumnSort()

AFX_INLINE BOOL IsAllowColumnSort ( ) const

Determines if column sorting mode is allowed.

Call this member function to determine whether the user is allowed to sort columns using the mouse.

Returns
TRUE when column sorting is allowed, FALSE otherwise.
See also
AllowColumnSort

◆ IsAutoColumnSizing()

AFX_INLINE BOOL IsAutoColumnSizing ( ) const

Determines if AutoColumnSizing is used.

Returns
TRUE if AutoColumnSizing is used, otherwise FALSE.

◆ IsDragHeader()

AFX_INLINE BOOL IsDragHeader ( ) const

Determines if the header is being dragged.

When the user begins dragging a row, the grid header enters a dragging loop and processes each message in a specific way. This function is used to determine if the grid header is in the dragging loop or not.

Returns
TRUE if the header is being dragged, otherwise FALSE.

◆ IsLastResizebleColumn()

BOOL IsLastResizebleColumn ( CXTPGridColumn * pColumn ) const

Determines if a specified column in the last resizable column in the grid header.

Parameters
pColumn Pointer to a CXTPGridColumn object.
Returns
TRUE if the specified column is the last resizable column in the grid header, otherwise FALSE.

◆ IsLastVisibleColumn()

BOOL IsLastVisibleColumn ( CXTPGridColumn * pColumn ) const

Determines if a specified column is the last visible column in the grid header.

Parameters
pColumn Pointer to a CXTPGridColumn object.
Returns
TRUE if the specified column is the last visible column in the grid header, otherwise FALSE.

◆ IsShowItemsInGroups()

AFX_INLINE BOOL IsShowItemsInGroups ( ) const

Determines if show items in groups mode is enabled/disabled.

Returns
TRUE if show items in groups mode is enabled, FALSE if show items in groups mode is disabled.
See also
ShowItemsInGroups

◆ MouseOverColumnResizeArea()

CXTPGridColumn * MouseOverColumnResizeArea ( CPoint ptPoint )

Determines if a specified point is over the column resize area.

Parameters
ptPoint Point coordinates to test.
Returns
A pointer to the column for resize at the specified point, if any, or NULL if the specified point is not over any column resize area.

◆ OnColumnsChanged()

virtual void OnColumnsChanged | ( | int | nReason,
 |  | CXTPGridColumn * | pColumn )
 virtual

Updates header settings after any changes occur.

Parameters
nReason | Event reason.
pColumn | Affected column.

Call this member function if you want to automatically adjust column widths and redraw the Grid control depending on current columns settings.

See also
XTPGridColumnOrderChangedReason

◆ OnContextMenu()

virtual void OnContextMenu ( CPoint ptClick )
protectedvirtual

Processes context menu.

Called by the framework when the user has clicked the right mouse button (right clicked) in the window.

Parameters
ptClick Position of the cursor, in screen coordinates, at the time of the mouse click.

Call this member function if you want the grid header to process a mouse right button down (context menu call) message. You should provide the method with the coordinates of the mouse message to proceed.

See also
OnLButtonDown, OnLButtonUp, OnMouseMove

◆ OnLButtonDblClk()

virtual void OnLButtonDblClk ( CPoint ptDblClick )
protectedvirtual

Processes mouse left button double clicks.

Parameters
ptDblClick Point coordinates where the message was fired from.

◆ OnLButtonDown()

virtual void OnLButtonDown ( CPoint ptClick )
protectedvirtual

Processes mouse left button down clicks.

Parameters
ptClick Point coordinates where the message was fired from.

Call this member function if you want the grid header to process a mouse left button down message. You should provide the method with the coordinates of the mouse message to proceed.

See also
OnLButtonUp, OnContextMenu, OnMouseMove

Reimplemented in CXTPTrackHeader.

◆ OnLButtonUp()

virtual void OnLButtonUp | ( | UINT | nFlags,
 |  | CPoint | ptClick )
 protectedvirtual

Processes mouse left button up clicks.

Parameters
nFlags | Indicates whether various virtual keys are down.
ptClick | Point coordinates where the message was fired from.

Call this member function if you want the grid header to process a mouse left button up message. You should provide the method with the coordinates of the mouse message to proceed and a flag showing which virtual keys were down.

See also
OnLButtonDown, OnContextMenu, OnMouseMove

◆ OnMouseMove()

virtual void OnMouseMove | ( | UINT | nFlags,
 |  | CPoint | point )
 protectedvirtual

Processes mouse movements.

Parameters
nFlags | Indicates whether various virtual keys are down.
point | Point coordinates where the message was fired from.

Call this member function if you want the grid header to process a mouse move message. You should provide the method with the coordinates of the mouse message to proceed and a flag showing which virtual keys were down.

See also
OnLButtonDown, OnLButtonUp, OnContextMenu

Reimplemented in CXTPTrackHeader.

◆ OnToolHitTest()

virtual INT_PTR OnToolHitTest | ( | CPoint | point,
 |  | TOOLINFO * | pTI ) const
 protectedvirtual

The framework calls this member function to determine whether a point is in the bounding rectangle of the specified tool.

Parameters
point | Specifies the x- and y- coordinates of the cursor. These coordinates are always relative to the upper-left corner of the window.
pTI | Pointer to a TOOLINFO structure.
Returns
If the tooltip control was found, then the window control ID is returned. If the tooltip control was not found, then a value of -1 is returned.

◆ ResizeColumn()

void ResizeColumn | ( | CXTPGridColumn * | pColumn,
 |  | int | nWidth )
 protected

Resizes a specified column to a specified width and adjusts the width of other columns in correspondence with the specified column.

Parameters
pColumn | Pointer to the column to resize.
nWidth | New column width, in pixels.
See also
AdjustColumnsWidth, GetMaxAvailWidth

◆ SetAutoColumnSizing()

void SetAutoColumnSizing ( BOOL bAutoColumnSizing )

Specifies if AutoColumnSizing should be used.

Parameters
bAutoColumnSizing TRUE to use AutoColumnSizing, FALSE otherwise.

If AutoColumnSizing is used (bAutoColumnSizing = TRUE), then all columns are sized to fill the entire width of the Grid control. When the Grid control is resized, all columns will be resized to fit the new size of the Grid control. If AutoColumnSizing is not used (bAutoColumnSizing = FALSE), then columns will use either the width that they were assigned when they were created or the value stored in their column width property. The width of columns may occupy more or less than the total width of the Grid control. In the case that the total width of columns exceeds the width of the Grid control, then those columns will not be visible. If the Grid control is resized, then the size of columns will not be affected.

◆ SetFilterEditCtrl()

BOOL SetFilterEditCtrl ( CXTPGridFilterEditControl * pFilterEdit )

Sets the associated filter edit control.

Parameters
pFilterEdit Pointer to the filter edit control.

You should call this member function to assign the user's custom edit box control as a Grid control filter edit control. After assigning, the framework will automatically process all windows messages for the control.

Returns
TRUE if successful, otherwise FALSE.

Example:

CXTPGridControl wndGrid;
CXTPGridFilterEditControl wndFilterEdit;
wndGrid.GetGridHeader()->SetFilterEditCtrl(&wndFilterEdit);
See also
CXTPGridFilterEditControl overview, GetFilterEditCtrl, SetSubListCtrl

◆ SetHotDivider()

int SetHotDivider | ( | int | nIndex,
 |  | BOOL | bHeader = TRUE )
 protected

Sets a hot divider between columns.

Parameters
nIndex | Index of the column to set the hot divider before.
bHeader | TRUE if you want to set the hot divider in the columns header, FALSE if you want to set the hot divider between Group By area items.

When dragging a column, call this member function to show a hot divider (red arrows by default) between columns to be used as as a target for dropping the currently dragged column.

Returns
The index of the column that the hot divider was set before.

◆ SetLastColumnExpand()

void SetLastColumnExpand | ( | BOOL | bLastColumnExpand,
 |  | BOOL | bLastColumnExpandKeep )

Sets the expanded state of the last column.

Parameters
bLastColumnExpand | TRUE to expand the last column.
bLastColumnExpandKeep | Not used currently.

◆ SetMaxColumnWidth()

AFX_INLINE void SetMaxColumnWidth ( int nMaxColumnWidth )

Sets the maximum column width for all columns.

Parameters
nMaxColumnWidth Maximum column width to be set.

Call pColumn->SetMaxWidth to set the maximumn column width for an individual column.

◆ SetSubListCtrl()

BOOL SetSubListCtrl ( CXTPGridSubListControl * pSubList )

Sets the associated field chooser list control.

Parameters
pSubList Pointer to the field chooser list control.

You should call this member function to assign the user's custom list box control as a Grid control field chooser list control. After assigning, the framework will automatically process all windows messages for the control.

Returns
TRUE if successful, otherwise FALSE.

Example:

// CXTPGridControl wndGrid;
// CXTPGridSubListControl wndSubList;
wndGrid.GetColumns()->GetGridHeader()->SetSubListCtrl(&wndSubList);
See also
CXTPGridSubListControl overview, SetFilterEditCtrl

◆ ShowItemsInGroups()

void ShowItemsInGroups ( BOOL bShowInGroups )

Enables/disables show items in groups mode.

Parameters
bShowInGroups TRUE to enable show items in groups mode, FALSE to disable show items in groups mode.
See also
IsShowItemsInGroups

◆ StartDragging()

void StartDragging | ( | CXTPGridColumn * | pColumn,
 |  | BOOL | bHeader = FALSE )
 protected

Starts column header dragging mode.

Parameters
pColumn | Pointer to the column to be set as the dragging column.
bHeader | TRUE when starting dragging for column header items, FALSE when starting dragging for Group By column items.

Usually this method is called internally as a reaction to specific user actions (e.g. when the user begins dragging the header by mouse).

See also
GetDraggingColumn, CancelMouseMode
The documentation for this class was generated from the following file:
  • XTPGridHeader.h


Toolkit Pro: CXTPGridHeaderDragWnd Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPGridHeaderDragWnd Class Reference

CXTPGridHeaderDragWnd is a CWnd derived class. More...

Public Member Functions

CXTPGridHeaderDragWnd ()
Creates a CXTPGridHeaderDragWnd object.
virtual | ~CXTPGridHeaderDragWnd ()
Destroys a CXTPGridHeaderDragWnd object, handles cleanup and deallocation.
virtual BOOL | Create (CRect rect, CXTPGridHeader *pHeader, CXTPGridPaintManager *pPaintManager, CXTPGridColumn *pColumn)
Creates a dragging window with the specified parameters.

Protected Member Functions

virtual void OnDraw (CDC *pDC, CRect rcClient)
Called by the framework to draw the contents of the window using the specified device context.

Protected Attributes

CXTPGridHeader * | m_pHeader
Pointer to the associated grid header object.
CXTPGridPaintManager * | m_pPaintManager
Pointer to the associated paint manager object.
CXTPGridColumn * | m_pColumn
Pointer to the associated grid column object.

Detailed Description

CXTPGridHeaderDragWnd is a CWnd derived class.

It is used internally to represent a dragging column window.

Member Function Documentation

◆ Create()

virtual BOOL Create | ( | CRect | rect,
 |  | CXTPGridHeader * | pHeader,
 |  | CXTPGridPaintManager * | pPaintManager,
 |  | CXTPGridColumn * | pColumn )
 virtual

Creates a dragging window with the specified parameters.

Parameters
rect | Drawing rectangle position.
pHeader | Pointer to the parent grid header object.
pPaintManager | Paint manager for performing draw operations.
pColumn | Pointer to the associated column.
Returns
TRUE if the dragging window was created successfully, otherwise FALSE.

◆ OnDraw()

virtual void OnDraw | ( | CDC * | pDC,
 |  | CRect | rcClient )
 protectedvirtual

Called by the framework to draw the contents of the window using the specified device context.

Parameters
pDC | Pointer to the device context in which the drawing occurs.
rcClient | Coordinates of the client window position.
The documentation for this class was generated from the following file:
  • XTPGridDragDrop.h


Toolkit Pro: CXTPGridHeaderDropWnd Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPGridHeaderDropWnd Class Reference

CXTPGridHeaderDropWnd is a CWnd derived class. More...

Public Member Functions

CXTPGridHeaderDropWnd (COLORREF crColor)
Creates a CXTPGridHeaderDropWnd object.
virtual | ~CXTPGridHeaderDropWnd ()
Destroys a CXTPGridHeaderDropWnd object, handles cleanup and deallocation.
void | SetWindowPos (int xPos, int yPos)
Changes the window position.
virtual BOOL | Create (CWnd *pParentWnd, int nHeight)
Creates a drop window with a specified gap inside.

Protected Attributes

COLORREF | m_clr
Drawing brush.
CRgn | m_rgn
Arrows region.
int | m_nHeight
Height of the gap between two arrows.

Detailed Description

CXTPGridHeaderDropWnd is a CWnd derived class.

It is used internally to represent drop target arrows.

Constructor & Destructor Documentation

◆ CXTPGridHeaderDropWnd()

CXTPGridHeaderDropWnd ( COLORREF crColor )

Creates a CXTPGridHeaderDropWnd object.

Parameters
crColor Drop window color.

Member Function Documentation

◆ Create()

virtual BOOL Create | ( | CWnd * | pParentWnd,
 |  | int | nHeight )
 virtual

Creates a drop window with a specified gap inside.

Parameters
pParentWnd | Pointer to the parent window.
nHeight | Height of the gap between two arrows, in pixels.
Returns
TRUE if the drop window was created successfully, otherwise FALSE.

◆ SetWindowPos()

void SetWindowPos | ( | int | xPos,
 |  | int | yPos )

Changes the window position.

Parameters
xPos | New horizontal position.
yPos | New vertical position.
The documentation for this class was generated from the following file:
  • XTPGridDragDrop.h


Toolkit Pro: CXTPGridHyperlink Class Reference

Public Member Functions | Public Attributes | List of all members
CXTPGridHyperlink Class Reference

This class represents hyperlinks. More...

Inheritance diagram for CXTPGridHyperlink:
[legend]

Public Member Functions

CXTPGridHyperlink (int nHyperTextBegin=0, int nHyperTextLen=0)
Default CXTPGridHyperlink constructor.
virtual | ~CXTPGridHyperlink ()
Destroys a CXTPGridHyperlink object, handles cleanup and deallocation.
virtual void | DoPropExchange (CXTPPropExchange *pPX)
Call this member function to store/load a grid hyperlink using the specified data object.
- Public Member Functions inherited from CXTPHeapObjectT< CXTPCmdTarget, CXTPGridDataAllocator >
void *PASCAL | operator new (size_t nSize)
Allocate memory block of nSize bytes.
void PASCAL | operator delete (void *p)
Free memory block previously allocated by operator new.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Public Attributes

CRect | m_rcHyperSpot
Hyperlink draw place.
int | m_nHyperTextBegin
Start position of the hyperlink item text in the parent item caption.
int | m_nHyperTextLen
The length of the hyperlink item text.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

This class represents hyperlinks.

It stores the start position and length of a hyperlink item's text as well as the rectangle used for drawing the hyperlink and identifying clicks on the hyperlink. To create an instance of this class, you simply call its constructor with the start position and length of a hyperlink item's text.

Constructor & Destructor Documentation

◆ CXTPGridHyperlink()

CXTPGridHyperlink | ( | int | nHyperTextBegin = 0,
 |  | int | nHyperTextLen = 0 )

Default CXTPGridHyperlink constructor.

Parameters
nHyperTextBegin | Start position of the hyperlink item text in the parent item caption.
nHyperTextLen | Length of the hyperlink item text.

Member Function Documentation

◆ DoPropExchange()

virtual void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Call this member function to store/load a grid hyperlink using the specified data object.

Parameters
pPX Source/destination CXTPPropExchange data object reference.
The documentation for this class was generated from the following file:
  • XTPGridHyperlink.h


Toolkit Pro: CXTPGridHyperlinks Class Reference

Public Member Functions | List of all members
CXTPGridHyperlinks Class Reference

This class represents an array of pointers to CXTPGridHyperlink objects. More...

Inheritance diagram for CXTPGridHyperlinks:
[legend]

Public Member Functions

CXTPGridHyperlinks ()
Default CXTPGridHyperlink constructor.
virtual | ~CXTPGridHyperlinks ()
Destroys a CXTPGridHyperlinks object, handles cleanup and deallocation.
virtual void | DoPropExchange (CXTPPropExchange *pPX)
Call this member function to store/load a grid hyperlinks collection using the specified data object.
virtual void | RemoveAt (int nIndex)
Removes the hyperlink at a specified index from the collection.
virtual void | RemoveAt (int nIndex, int nCount)
Removes the hyperlink at a specified index from the collection.
virtual void | RemoveAll ()
Removes all hyperlinks from the collection.
virtual void | CopyFrom (CXTPGridHyperlinks *pSrc)
Copies all members from a specified CXTPGridHyperlinks object to this CXTPGridHyperlinks object.
- Public Member Functions inherited from CXTPHeapObjectT< CXTPGridHyperlinks_base, CXTPGridDataAllocator >
void *PASCAL | operator new (size_t nSize)
Allocate memory block of nSize bytes.
void PASCAL | operator delete (void *p)
Free memory block previously allocated by operator new.
- Public Member Functions inherited from CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE >
CXTPArrayT ()
Default object constructor.
virtual | ~CXTPArrayT ()
Default object destructor.
virtual int | GetSize () const
This member function is used to obtain the number of elements in the collection.
virtual void | SetSize (int nNewSize, int nGrowBy=-1)
This member function is used to change the array size.
virtual TYPE | GetAt (int nIndex) const
This member function returns an element at the specified numeric index.
virtual void | SetAt (int nIndex, ARG_TYPE newElement)
This member function is used to set a new element to the position specified in the nIndex parameter.
virtual TYPE & | ElementAt (int nIndex)
This member function returns a reference to element at the specified numeric index.
virtual const TYPE * | GetData () const
This member function is used to Direct Access to the element data.
virtual TYPE * | GetData ()
This member function is used to Direct Access to the element data.
virtual void | SetAtGrow (int nIndex, ARG_TYPE newElement)
This member function is used to set a new element to the position specified in the nIndex parameter.
virtual int | Add (ARG_TYPE newElement)
This member function adds a new element to the end of the array.
virtual int | Append (const CXTPArrayT &src)
This member function adds the elements from a specified array to the end of this array.
virtual void | Copy (const CXTPArrayT &src)
This member function overwrites the contents of this array with the contents of a specified array.
TYPE | operator[] (int nIndex) const
This operator returns the array element at a specified numeric index.
TYPE & | operator[] (int nIndex)
This operator returns a reference to the array element at a specified numeric index.
virtual void | InsertAt (int nIndex, ARG_TYPE newElement, int nCount=1)
This member function is used to insert a number of copies of an element, specified by the nCount parameter, to the array starting at the position specified by the nIndex parameter.
virtual void | InsertAt (int nStartIndex, CXTPArrayT *pNewArray)
This member function is used to insert an array of elements to the array starting at the position specified by the nStartIndex parameter.
virtual int | FindElement (ARG_TYPE nElement) const
Call this member function to find an element in the collection.
virtual void | AddIfNeed (ARG_TYPE newElement)
Call this member function to add a specified element to the collection if it is not present already.
virtual BOOL | RemoveElement (ARG_TYPE nElement)
Call this member function to remove all elements with a specified value from the collection.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Attributes inherited from CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE >
CArray< TYPE, ARG_TYPE > | m_arElements
Elements storage.

Detailed Description

This class represents an array of pointers to CXTPGridHyperlink objects.

InternalRelease is called for each item in the array destructor. Serialization for array items is provided (see the DoPropExchange method).

Member Function Documentation

◆ CopyFrom()

virtual void CopyFrom ( CXTPGridHyperlinks * pSrc )
virtual

Copies all members from a specified CXTPGridHyperlinks object to this CXTPGridHyperlinks object.

Parameters
pSrc Pointer to a CXTPGridHyperlinks object to copy from.

◆ DoPropExchange()

virtual void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Call this member function to store/load a grid hyperlinks collection using the specified data object.

Parameters
pPX Source/destination CXTPPropExchange data object reference.

◆ RemoveAll()

virtual void RemoveAll ( )
virtual

Removes all hyperlinks from the collection.

See also
RemoveAt, CXTPGridHyperlink, CXTPArrayT

Reimplemented from CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE >.

◆ RemoveAt() [1/2]

virtual void RemoveAt ( int nIndex )
virtual

Removes the hyperlink at a specified index from the collection.

Parameters
nIndex Zero-based index of the hyperlink to remove.
See also
CXTPGridHyperlink, CXTPArrayT

◆ RemoveAt() [2/2]

virtual void RemoveAt | ( | int | nIndex,
 |  | int | nCount )
 virtual

Removes the hyperlink at a specified index from the collection.

Parameters
nIndex | Zero-based index of the hyperlink to remove.
nCount | The number of elements to remove.
See also
CXTPGridHyperlink, CXTPArrayT

Reimplemented from CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE >.

The documentation for this class was generated from the following file:
  • XTPGridHyperlink.h


Toolkit Pro: CXTPGridHyperlinkStyle Class Reference

Public Member Functions | List of all members
CXTPGridHyperlinkStyle Class Reference

This class stores the anchor styles. More...

Inheritance diagram for CXTPGridHyperlinkStyle:
[legend]

Public Member Functions

CXTPGridHyperlinkStyle (COLORREF color, XTPGridTextDecoration textDecoration)
Constructs the object and initializes the color and text decoration.
COLORREF | GetColor () const
Gets the color of the anchor text.
void | SetColor (COLORREF color)
Sets the color for the anchor text.
XTPGridTextDecoration | GetTextDecoration () const
Gets the text decoration of the anchor text.
void | SetTextDecoration (XTPGridTextDecoration textDecoration)
Sets the text decoration for the anchor text.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

This class stores the anchor styles.

Constructor & Destructor Documentation

◆ CXTPGridHyperlinkStyle()

CXTPGridHyperlinkStyle | ( | COLORREF | color,
 |  | XTPGridTextDecoration | textDecoration )

Constructs the object and initializes the color and text decoration.

Parameters
color | Color.
textDecoration | Text decoration.

Member Function Documentation

◆ GetColor()

COLORREF GetColor ( ) const

Gets the color of the anchor text.

Returns
The color of the anchor text.

◆ GetTextDecoration()

XTPGridTextDecoration GetTextDecoration ( ) const

Gets the text decoration of the anchor text.

Returns
The text decoration of the anchor text.

◆ SetColor()

void SetColor ( COLORREF color )

Sets the color for the anchor text.

Parameters
color New color to be set.

◆ SetTextDecoration()

void SetTextDecoration ( XTPGridTextDecoration textDecoration )

Sets the text decoration for the anchor text.

Parameters
textDecoration New text decoration to be set.
The documentation for this class was generated from the following file:
  • XTPGridHyperlink.h


Toolkit Pro: CXTPGridIconNavigator Class Reference

Public Member Functions | List of all members
CXTPGridIconNavigator Class Reference

Utility class, handles Grid control icon navigation. More...

Inheritance diagram for CXTPGridIconNavigator:
[legend]

Public Member Functions

CXTPGridIconNavigator (CXTPGridControl *pGridControl)
Default navigator constructor, handles properties initialization.
virtual | ~CXTPGridIconNavigator ()
Default navigator destructor, handles member items deallocation.
virtual void | BeginEdit ()
Call this method to begin editing the currently focused item.
virtual void | MoveDown (BOOL bShiftKey=FALSE, BOOL bControlKey=FALSE)
Moves the focused row down by one.
virtual void | MoveUp (BOOL bShiftKey=FALSE, BOOL bControlKey=FALSE)
Moves the focused row up by one.
virtual void | MoveDownStep (BOOL bShiftKey=FALSE, BOOL bControlKey=FALSE)
Moves the focused row down by one.
virtual void | MoveUpStep (BOOL bShiftKey=FALSE, BOOL bControlKey=FALSE)
Moves the focused row up by one.
virtual void | MovePageDown (BOOL bShiftKey, BOOL bControlKey)
Moves the focused row down by one page.
virtual void | MovePageUp (BOOL bShiftKey, BOOL bControlKey)
Moves the focused row up by one page.
virtual void | MoveLeftRight (BOOL bBack, BOOL bShiftKey=FALSE, BOOL bControlKey=FALSE)
Moves the focused column left/right.
- Public Member Functions inherited from CXTPGridNavigator
CXTPGridNavigator (CXTPGridControl *pGridControl)
Default navigator constructor, handles properties initialization.
virtual | ~CXTPGridNavigator ()
Default navigator destructor, handles member items deallocation.
void | MoveFirstRow (BOOL bShiftKey=FALSE, BOOL bControlKey=FALSE)
Moves the focused row to the beginning of the grid view.
void | MoveLastRow (BOOL bShiftKey=FALSE, BOOL bControlKey=FALSE)
Moves the focused row to the end of the grid view.
void | MoveToRow (int nRowIndex, BOOL bShiftKey=FALSE, BOOL bControlKey=FALSE)
Moves the focused row to a specified row index.
void | MoveFirstColumn ()
Moves the focused column to the beginning of the currently selected row.
void | MoveLastColumn ()
Moves the focused column to the end of the currently selected row.
void | MoveLeft (BOOL bShiftKey=FALSE, BOOL bControlKey=FALSE)
Moves the focused column left by one.
void | MoveRight (BOOL bShiftKey=FALSE, BOOL bControlKey=FALSE)
Moves the focused column right by one.
void | MoveToColumn (int nColumnIndex, BOOL bClearIfNonFocusable=FALSE)
Moves the focused column to a specified column index.
void | SetCurrentFocusInHeadersRows (BOOL bCurrentFocusInHeadersRows)
Sets the current focus (selected row) to header rows.
void | SetCurrentFocusInFootersRows (BOOL bCurrentFocusInFootersRows)
Sets the current focus (selected row) to footer rows.
BOOL | GetCurrentFocusInHeadersRows ()
Determines if the current focus (selected row) belongs to header rows.
BOOL | GetCurrentFocusInFootersRows ()
Determines if the current focus (selected row) belongs to footer rows.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Member Functions inherited from CXTPGridNavigator
void | MoveFirstVisibleRow (XTPGridRowType RowType)
Moves the focused row to the first visible row of a target section: body, header, or footer.
void | MoveLastVisibleRow (XTPGridRowType RowType)
Moves the focused row to the last visible row of a target section: body, header, or footer.
int | CheckDeadEnd (BOOL bMoveDown)
Checks for a dead end row by moving down/up.
- Protected Attributes inherited from CXTPGridNavigator
CXTPGridControl * | m_pGridControl
Associated Grid control.

Detailed Description

Utility class, handles Grid control icon navigation.

See also
CXTPGridControl overview

Constructor & Destructor Documentation

◆ CXTPGridIconNavigator()

CXTPGridIconNavigator ( CXTPGridControl * pGridControl )

Default navigator constructor, handles properties initialization.

Parameters
pGridControl Pointer to a CXTPGridControl object.
See also
RefreshMetrics

Member Function Documentation

◆ MoveDown()

virtual void MoveDown | ( | BOOL | bShiftKey = FALSE,
 |  | BOOL | bControlKey = FALSE )
 virtual

Moves the focused row down by one.

Parameters
bShiftKey | TRUE to select a new focused row.
bControlKey | TRUE to ignore the current rows selection.

Moves the currently focused row down by one.

See also
MoveUp, MovePageDown, MovePageUp, MoveFirst, MoveLast

Reimplemented from CXTPGridNavigator.

◆ MoveDownStep()

virtual void MoveDownStep | ( | BOOL | bShiftKey = FALSE,
 |  | BOOL | bControlKey = FALSE )
 virtual

Moves the focused row down by one.

Parameters
bShiftKey | TRUE to select a new focused row.
bControlKey | TRUE to ignore the current rows selection.

Moves the currently focused row down by one.

See also
MoveUp, MovePageDown, MovePageUp, MoveFirst, MoveLast

Reimplemented from CXTPGridNavigator.

◆ MoveLeftRight()

virtual void MoveLeftRight | ( | BOOL | bBack,
 |  | BOOL | bShiftKey = FALSE,
 |  | BOOL | bControlKey = FALSE )
 virtual

Moves the focused column left/right.

Parameters
bBack | TRUE to move left, FALSE to move right.
bShiftKey | TRUE to select a new focused row.
bControlKey | TRUE to ignore the current rows selection.
See also
MoveDown, MovePageDown, MovePageUp, MoveFirst, MoveLast

Reimplemented from CXTPGridNavigator.

◆ MovePageDown()

virtual void MovePageDown | ( | BOOL | bShiftKey,
 |  | BOOL | bControlKey )
 virtual

Moves the focused row down by one page.

Parameters
bShiftKey | TRUE to select rows up to the new focused row.
bControlKey | TRUE to ignore the current rows selection.

Moves the currently focused row down by one page (and count the visible rows in a view).

See also
MoveDown, MoveUp, MovePageUp, MoveFirst, MoveLast

Reimplemented from CXTPGridNavigator.

◆ MovePageUp()

virtual void MovePageUp | ( | BOOL | bShiftKey,
 |  | BOOL | bControlKey )
 virtual

Moves the focused row up by one page.

Parameters
bShiftKey | TRUE to select rows up to the new focused row.
bControlKey | TRUE to ignore the current rows selection.

Moves the currently focused row up by one page (and count the visible rows in a view).

See also
MoveDown, MoveUp, MovePageDown, MoveFirst, MoveLast

Reimplemented from CXTPGridNavigator.

◆ MoveUp()

virtual void MoveUp | ( | BOOL | bShiftKey = FALSE,
 |  | BOOL | bControlKey = FALSE )
 virtual

Moves the focused row up by one.

Parameters
bShiftKey | TRUE to select a new focused row.
bControlKey | TRUE to ignore the current rows selection.

Moves the currently focused row up by one.

See also
MoveDown, MovePageDown, MovePageUp, MoveFirst, MoveLast

Reimplemented from CXTPGridNavigator.

◆ MoveUpStep()

virtual void MoveUpStep | ( | BOOL | bShiftKey = FALSE,
 |  | BOOL | bControlKey = FALSE )
 virtual

Moves the focused row up by one.

Parameters
bShiftKey | TRUE to select a new focused row.
bControlKey | TRUE to ignore the current rows selection.

Moves the currently focused row up by one.

See also
MoveDown, MovePageDown, MovePageUp, MoveFirst, MoveLast

Reimplemented from CXTPGridNavigator.

The documentation for this class was generated from the following file:
  • XTPGridNavigator.h


Toolkit Pro: CXTPGridInplaceButton Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPGridInplaceButton Class Reference

CXTPGridInplaceButton is a CXTPGridInplaceControl derived class that represents a combo button and expand button of a grid cell. More...

Inheritance diagram for CXTPGridInplaceButton:
[legend]

Public Member Functions

CXTPGridInplaceButton (UINT nID)
Constructs a CXTPGridInplaceButton object.
void | Create (XTP_GRIDRECORDITEM_ARGS *pItemArgs, CRect &rcButtons)
Creates an in-place button control.
int | GetID () const
Gets the identifier of the button.
BOOL | IsPressed () const
Determines if the user pressed the button.
int | GetState () const
Gets the state of the button.
CXTPGridRecordItem * | GetItem () const
Gets a child Grid control item.
int | GetWidth () const
Gets the width of the button.
BOOL | IsInsideCellButton () const
Determines if the button is placed inside or outside (near the right cell side) the cell rect.
void | SetInsideCellButton (BOOL bInsideCell)
Specifies if the button should be placed inside or outside (near the right cell side) the cell rect.
void | SetIconIndex (int nIconIndex)
Sets the icon index for the button.
int | GetIconIndex () const
Gets the icon index of the button.
int | GetSpinButtonMin () const
Gets spin button properties.
int | GetSpinButtonMax () const
Gets spin button properties.
int | GetSpinButtonStep () const
Gets spin button properties.
void | SetSpinButtonMin (int nValue)
Sets spin button properties.
void | SetSpinButtonMax (int nValue)
Sets spin button properties.
void | SetSpinButtonStep (int nValue)
Sets spin button properties.
void | Activate ()
Call this function to activate the button.
int | GetDropListItemNumber () const
Gets the number of items to show in the dropdown list.
void | SetDropListItemNumber (int nNumber)
Sets the number of items to show in the dropdown list.
- Public Member Functions inherited from CXTPGridInplaceControl
CXTPGridInplaceControl ()
Constructs a CXTPGridInplaceControl object.
virtual | ~CXTPGridInplaceControl ()
Destroys a CXTPGridInplaceControl object, handles cleanup and deallocation.

Protected Attributes

int | m_nID
Identifier of the button.
int | m_nWidth
Width of the button.
int | m_nFixedHeight
Height of the button.
BOOL | m_bInsideCell
Store button place: inside the cell rect, or outside.
int | m_nIconIndex
Icon index.
BOOL | m_bPressed
TRUE if the button is pressed.
BOOL | m_bOver
TRUE if the mouse cursor is over the button.
int | m_nState
Button state.
int | m_nSpinMin
Spin button only: minimum value.
int | m_nSpinMax
Spin button only: maximum value.
int | m_nSpinStep
Spin button only: step value.
UINT_PTR | m_unSpinTimerCnt
Spin button only: timer counter.
UINT_PTR | m_unSpinTimerId
Spin button only: timer identifier.
int | m_nSpinIncrement
Spin button only: increment value.

Additional Inherited Members

- Public Attributes inherited from XTP_GRIDRECORDITEM_ARGS
CXTPGridControl * | pControl
Pointer to the main Grid control.
CXTPGridRow * | pRow
Pointer to the associated row.
CXTPGridColumn * | pColumn
Grid column at click position, if any, NULL otherwise.
CXTPGridRecordItem * | pItem
Pointer to the associated item.
CRect | rcItem
Item position in control client coordinates.
- Protected Member Functions inherited from CXTPGridInplaceControl
virtual void | SetItemArgs (XTP_GRIDRECORDITEM_ARGS *pItemArgs)
This method is called internally to fill the item arguments of an in-place control.

Detailed Description

CXTPGridInplaceButton is a CXTPGridInplaceControl derived class that represents a combo button and expand button of a grid cell.

Constructor & Destructor Documentation

◆ CXTPGridInplaceButton()

CXTPGridInplaceButton ( UINT nID )

Constructs a CXTPGridInplaceButton object.

Parameters
nID Identifier of the in-place button. Can be any of the values listed in the Remarks section.

Default identifiers are: XTP_ID_GRID_EXPANDBUTTON: Indicates that the button acts like an expand button. XTP_ID_GRID_COMBOBUTTON: Indicates that the button acts like a combo button. XTP_ID_GRID_SPINBUTTON: Indicates that the button acts like a spin button.

Member Function Documentation

◆ Create()

void Create | ( | XTP_GRIDRECORDITEM_ARGS * | pItemArgs,
 |  | CRect & | rcButtons )

Creates an in-place button control.

Parameters
pItemArgs | Pointer to an XTP_GRIDRECORDITEM_ARGS structure containing item cell parameters.
rcButtons | Reference to the bounding rectangle of the button.

◆ GetDropListItemNumber()

AFX_INLINE int GetDropListItemNumber ( ) const

Gets the number of items to show in the dropdown list.

Returns
A number of items to show.

◆ GetIconIndex()

AFX_INLINE int GetIconIndex ( ) const

Gets the icon index of the button.

Returns
The icon index of the button.
See also
SetIconIndex

◆ GetID()

AFX_INLINE int GetID ( ) const

Gets the identifier of the button.

Returns
The identifier of the button.

◆ GetItem()

AFX_INLINE CXTPGridRecordItem * GetItem ( ) const

Gets a child Grid control item.

Returns
A pointer to a CXTPGridRecordItem object.

◆ GetSpinButtonMax()

AFX_INLINE int GetSpinButtonMax ( ) const

Gets spin button properties.

Returns
The requested spin button property value.
See also
SetSpinButtonMin, SetSpinButtonMax, SetSpinButtonStep

◆ GetSpinButtonMin()

AFX_INLINE int GetSpinButtonMin ( ) const

Gets spin button properties.

Returns
The requested spin button property value.
See also
SetSpinButtonMin, SetSpinButtonMax, SetSpinButtonStep

◆ GetSpinButtonStep()

AFX_INLINE int GetSpinButtonStep ( ) const

Gets spin button properties.

Returns
The requested spin button property value.
See also
SetSpinButtonMin, SetSpinButtonMax, SetSpinButtonStep

◆ GetState()

AFX_INLINE int GetState ( ) const

Gets the state of the button.

Returns
The state of the button.

◆ GetWidth()

AFX_INLINE int GetWidth ( ) const

Gets the width of the button.

Returns
The width of the button.

◆ IsInsideCellButton()

AFX_INLINE BOOL IsInsideCellButton ( ) const

Determines if the button is placed inside or outside (near the right cell side) the cell rect.

Returns
TRUE if the button is placed inside the cell rect, otherwise FALSE.

◆ IsPressed()

AFX_INLINE BOOL IsPressed ( ) const

Determines if the user pressed the button.

Returns
TRUE if the user pressed the button.

◆ SetDropListItemNumber()

AFX_INLINE void SetDropListItemNumber ( int nNumber )

Sets the number of items to show in the dropdown list.

Parameters
nNumber A number of items to show.

◆ SetIconIndex()

AFX_INLINE void SetIconIndex ( int nIconIndex )

Sets the icon index for the button.

Parameters
nIconIndex Icon index to be set.
See also
GetIconIndex

◆ SetInsideCellButton()

AFX_INLINE void SetInsideCellButton ( BOOL bInsideCell )

Specifies if the button should be placed inside or outside (near the right cell side) the cell rect.

Parameters
bInsideCell TRUE to place the button inside the cell rect, FALSE to place the button outside the cell rect.

◆ SetSpinButtonMax()

AFX_INLINE void SetSpinButtonMax ( int nValue )

Sets spin button properties.

Parameters
nValue Spin button property value to be set.
See also
GetSpinButtonMin, GetSpinButtonMax, GetSpinButtonStep

◆ SetSpinButtonMin()

AFX_INLINE void SetSpinButtonMin ( int nValue )

Sets spin button properties.

Parameters
nValue Spin button property value to be set.
See also
GetSpinButtonMin, GetSpinButtonMax, GetSpinButtonStep

◆ SetSpinButtonStep()

AFX_INLINE void SetSpinButtonStep ( int nValue )

Sets spin button properties.

Parameters
nValue Spin button property value to be set.
See also
GetSpinButtonMin, GetSpinButtonMax, GetSpinButtonStep
The documentation for this class was generated from the following file:
  • XTPGridInplaceControls.h


Toolkit Pro: CXTPGridInplaceButtons Class Reference

Public Member Functions | List of all members
CXTPGridInplaceButtons Class Reference

This class represents a collection of in-place buttons for a single item of the Grid control. More...

Public Member Functions

CXTPGridInplaceButtons ()
Constructs a CXTPGridInplaceButtons object.

Detailed Description

This class represents a collection of in-place buttons for a single item of the Grid control.

The documentation for this class was generated from the following file:
  • XTPGridRecordItem.h


Toolkit Pro: CXTPGridInplaceControl Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPGridInplaceControl Class Reference

CXTPGridInplaceControl is the base class for all in-place controls of the Grid control item. More...

Inheritance diagram for CXTPGridInplaceControl:
[legend]

Public Member Functions

CXTPGridInplaceControl ()
Constructs a CXTPGridInplaceControl object.
virtual ~CXTPGridInplaceControl ()
Destroys a CXTPGridInplaceControl object, handles cleanup and deallocation.

Protected Member Functions

virtual void SetItemArgs (XTP_GRIDRECORDITEM_ARGS *pItemArgs)
This method is called internally to fill the item arguments of an in-place control.

Additional Inherited Members

- Public Attributes inherited from XTP_GRIDRECORDITEM_ARGS
CXTPGridControl * | pControl
Pointer to the main Grid control.
CXTPGridRow * | pRow
Pointer to the associated row.
CXTPGridColumn * | pColumn
Grid column at click position, if any, NULL otherwise.
CXTPGridRecordItem * | pItem
Pointer to the associated item.
CRect | rcItem
Item position in control client coordinates.

Detailed Description

CXTPGridInplaceControl is the base class for all in-place controls of the Grid control item.

There are three built-in, in-place controls for the Grid control item: CXTPGridInplaceEdit: Represents the edit control to allow users to change a cell of the Grid control. CXTPGridInplaceButton: Represents a single button of the item. CXTPGridInplaceList: Represents the list box to allow users to select the constraints of the grid item.

See also
CXTPGridInplaceEdit, CXTPGridInplaceButton, CXTPGridInplaceList

Member Function Documentation

◆ SetItemArgs()

virtual void SetItemArgs ( XTP_GRIDRECORDITEM_ARGS * pItemArgs )
protectedvirtual

This method is called internally to fill the item arguments of an in-place control.

Parameters
pItemArgs Pointer to an XTP_GRIDRECORDITEM_ARGS structure containing item arguments.

Reimplemented in CXTPGridInplaceList.

The documentation for this class was generated from the following file:
  • XTPGridInplaceControls.h


Toolkit Pro: CXTPGridInplaceEdit Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPGridInplaceEdit Class Reference

CXTPGridInplaceEdit is a CXTPGridInplaceControl derived class that represents an edit control to allow users to change a cell of a Grid control. More...

Inheritance diagram for CXTPGridInplaceEdit:
[legend]

Public Member Functions

CXTPGridInplaceEdit ()
Constructs a CXTPGridInplaceEdit object.
virtual | ~CXTPGridInplaceEdit ()
Destroys a CXTPGridInplaceEdit object, handles cleanup and deallocation.
void | HideWindow ()
Hides the in-place edit control.
CXTPGridRecordItem * | GetItem () const
Gets a child Grid control item.
void | Create (XTP_GRIDRECORDITEM_ARGS *pItemArgs)
Creates an in-place edit control.
void | SetWindowText (LPCTSTR lpszString)
Sets edit text.
- Public Member Functions inherited from CXTPMaskEditT< CEdit >
CXTPMaskEditT ()
Constructs a CXTPMaskEditT object.
void | SetUseMask (BOOL bUseMask)
Call this member function to enable or disable the mask for the mask edit control.
BOOL | CanUseMask () const
This member function is called to determine if the mask for the edit control can be used.
void | SetOverType (BOOL bOverType)
This member function is called to enable or disable type over, also known as insert mode.
BOOL | CanOverType () const
This member function is called to determine if type over has been enabled.
BOOL | PosInRange (int iPos) const
This member function is called to determine if the index specified by 'iPos' is a valid index for the currently displayed edit text.
TCHAR | GetPromptChar () const
This member function retrieves the character that is currently used as the mask prompt.
CString | GetPromptString (int nLength) const
This helper member function retrieves the string contains nLength prompt characters.
void | SetPromptChar (TCHAR ch, BOOL bAutoReplace=TRUE)
This member function is called to set the prompt character that is displayed to the user that indicates the field can be edited.
afx_msg BOOL | MaskCut ()
This member function is called to perform a cut operation using the currently selected text.
afx_msg BOOL | MaskCopy ()
This member function is called to perform a copy operation using the currently selected text.
void | MaskReplaceSel (LPCTSTR lpszNewText)
This member function is called to perform a replace operation using the currently selected text.
afx_msg BOOL | MaskPaste ()
This member function is called to perform a paste operation using the current clipboard text.
void | MaskDeleteSel ()
This member function is called to delete the selection.
afx_msg BOOL | MaskClear ()
This member function is called to clear the current text selection.
afx_msg BOOL | MaskUndo ()
This member function is called to undo the previous action.
afx_msg void | MaskSelectAll ()
This member function is called to select all text in the mask edit control.
BOOL | IsModified () const
This member function is called to determine if the text has been modified.
void | SetMaskedText (LPCTSTR lpszMaskedText, int iPos=0, BOOL bUpdateWindow=TRUE)
This method called to set masked text for the edit control.
virtual BOOL | SetEditMask (LPCTSTR lpszMask, LPCTSTR lpszLiteral, LPCTSTR lpszDefault=NULL)
This member function will set the mask for the edit control.
TCHAR | ConvertUnicodeAlpha (TCHAR nChar, BOOL bUpperCase) const
Converts character to Upper/Lower case.
virtual BOOL | CheckChar (TCHAR &nChar, int nPos)
This member function is used internally to validate the character indicated by 'nChar'.
virtual BOOL | ProcessMask (TCHAR &nChar, int nEndPos)
This member function is used internally to process the character passed in by 'nChar' whose index is specified by 'nEndPos'.
virtual BOOL | PreTranslateMessage (MSG *pMsg)
Used by class CWinApp to translate window messages before they are dispatched to theTranslateMessage andDispatchMessage Windows functions.
void | DeleteCharAt (int iPos)
Deletes character in specified position.
void | InsertCharAt (int iPos, TCHAR nChar)
Inserts character to specified position.
BOOL | CopyToClipboard (const CString &strText)
Copies text to system clipboard.
CString | GetMaskedText (int nStartPos=0, int nEndPos=-1) const
Retrieves masked text of the control.
- Public Member Functions inherited from CXTPGridInplaceControl
CXTPGridInplaceControl ()
Constructs a CXTPGridInplaceControl object.
virtual | ~CXTPGridInplaceControl ()
Destroys a CXTPGridInplaceControl object, handles cleanup and deallocation.

Protected Member Functions

void | SetFont (CFont *pFont)
Sets the font of the in-place edit control.
- Protected Member Functions inherited from CXTPMaskEditT< CEdit >
virtual BOOL | OnCommand (WPARAM wParam, LPARAM lParam)
The framework calls this member function when the user selects an item from a menu.
- Protected Member Functions inherited from CXTPGridInplaceControl
virtual void | SetItemArgs (XTP_GRIDRECORDITEM_ARGS *pItemArgs)
This method is called internally to fill the item arguments of an in-place control.

Protected Attributes

CString | m_strValue
The value of item before user change it.
CString | m_strText_prev
The text value from previous change.
CXTPFont | m_xtpFontEdit
Font of in-place edit.
CXTPGridRecordItemConstraint * | m_pSelectedConstraint
Selected constraint.
COLORREF | m_clrText
Text color of in-place edit.
COLORREF | m_clrBack
Background color of in-place edit.
CXTPBrush | m_xtpBrushBack
Background brush of in-place edit.
BOOL | m_bSetWindowText
Indicates that text is being set with the SetWindowText function.
- Protected Attributes inherited from CXTPMaskEditT< CEdit >
int | m_nStartChar
Current position of the first character in the current selection.
int | m_nEndChar
Current position of the first non-selected character past the end of the current selection.
BOOL | m_bUseMask
TRUE to use the edit mask.
BOOL | m_bOverType
TRUE to over type the text, set with VK_INSERT key press.
BOOL | m_bRedo
TRUE to redo, or FALSE to undo.
BOOL | m_bModified
TRUE if mask edit has been modified.
TCHAR | m_chPrompt
Prompt character used to identify the text entry.
CString | m_strMask
Buffer that holds the actual edit mask value.
CString | m_strDefault
Contains the edit controls default display text.
CString | m_strUndoBuffer
Holds the contents of the undo buffer.
CString | m_strRedoBuffer
Holds the contents of the redo buffer.
CString | m_strWindowText
Buffer that holds the actual edit text.
CString | m_strLiteral
Literal format that restricts where the user can enter text.
BOOL | m_bUpdateUndo
TRUE to update undo.

Additional Inherited Members

- Public Attributes inherited from XTP_GRIDRECORDITEM_ARGS
CXTPGridControl * | pControl
Pointer to the main Grid control.
CXTPGridRow * | pRow
Pointer to the associated row.
CXTPGridColumn * | pColumn
Grid column at click position, if any, NULL otherwise.
CXTPGridRecordItem * | pItem
Pointer to the associated item.
CRect | rcItem
Item position in control client coordinates.

Detailed Description

CXTPGridInplaceEdit is a CXTPGridInplaceControl derived class that represents an edit control to allow users to change a cell of a Grid control.

Member Function Documentation

◆ Create()

void Create ( XTP_GRIDRECORDITEM_ARGS * pItemArgs )

Creates an in-place edit control.

Parameters
pItemArgs Pointer to an XTP_GRIDRECORDITEM_ARGS structure containing item cell parameters.

◆ GetItem()

AFX_INLINE CXTPGridRecordItem * GetItem ( ) const

Gets a child Grid control item.

Returns
A pointer to a CXTPGridRecordItem object.

◆ SetFont()

void SetFont ( CFont * pFont )
protected

Sets the font of the in-place edit control.

Parameters
pFont New font to be set.

◆ SetWindowText()

void SetWindowText ( LPCTSTR lpszString )

Sets edit text.

Parameters
lpszString Edit text to be set.
The documentation for this class was generated from the following file:
  • XTPGridInplaceControls.h


Toolkit Pro: CXTPGridInplaceList Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPGridInplaceList Class Reference

CXTPGridInplaceList is a CXTPGridInplaceControl derived class that represents a list box with item constraints. More...

Inheritance diagram for CXTPGridInplaceList:
[legend]

Public Member Functions

CXTPGridInplaceList ()
Constructs a CXTPGridInplaceList object.
void | Create (XTP_GRIDRECORDITEM_ARGS *pItemArgs, CXTPGridRecordItemConstraints *pConstraints)
Creates an in-place list control.
void | Cancel ()
Cancels the user selection.
void | Apply ()
Saves the selected value of the list box.
int | GetDropListItemNumber () const
Gets the number of items to show in the dropdown list.
void | SetDropListItemNumber (int nNumber)
Sets the number of items to show in the dropdown list.
- Public Member Functions inherited from CXTPGridInplaceControl
CXTPGridInplaceControl ()
Constructs a CXTPGridInplaceControl object.
virtual | ~CXTPGridInplaceControl ()
Destroys a CXTPGridInplaceControl object, handles cleanup and deallocation.

Protected Member Functions

virtual void | SetItemArgs (XTP_GRIDRECORDITEM_ARGS *pItemArgs)
This method is called internally to fill the item arguments of an in-place control.
virtual void | OnSelectionChanged (int nLBIndex)
This method is called internally when the selection is changed.
- Protected Member Functions inherited from CXTPGridInplaceControl

Additional Inherited Members

- Public Attributes inherited from XTP_GRIDRECORDITEM_ARGS
CXTPGridControl * | pControl
Pointer to the main Grid control.
CXTPGridRow * | pRow
Pointer to the associated row.
CXTPGridColumn * | pColumn
Grid column at click position, if any, NULL otherwise.
CXTPGridRecordItem * | pItem
Pointer to the associated item.
CRect | rcItem
Item position in control client coordinates.

Detailed Description

CXTPGridInplaceList is a CXTPGridInplaceControl derived class that represents a list box with item constraints.

See also
CXTPGridRecordItemConstraints

Member Function Documentation

◆ Create()

void Create | ( | XTP_GRIDRECORDITEM_ARGS * | pItemArgs,
 |  | CXTPGridRecordItemConstraints * | pConstraints )

Creates an in-place list control.

Parameters
pItemArgs | Pointer to an XTP_GRIDRECORDITEM_ARGS structure containing item cell parameters.
pConstraints | Pointer to a CXTPGridRecordItemConstraints object containing item constraints.

◆ GetDropListItemNumber()

AFX_INLINE int GetDropListItemNumber ( ) const

Gets the number of items to show in the dropdown list.

Returns
A number of items to show.

◆ OnSelectionChanged()

virtual void OnSelectionChanged ( int nLBIndex )
protectedvirtual

This method is called internally when the selection is changed.

Parameters
nLBIndex Index of the selected item in the list.

◆ SetDropListItemNumber()

AFX_INLINE void SetDropListItemNumber ( int nNumber )

Sets the number of items to show in the dropdown list.

Parameters
nNumber A number of items to show.

◆ SetItemArgs()

virtual void SetItemArgs ( XTP_GRIDRECORDITEM_ARGS * pItemArgs )
protectedvirtual

This method is called internally to fill the item arguments of an in-place control.

Parameters
pItemArgs Pointer to an XTP_GRIDRECORDITEM_ARGS structure containing item arguments.

Reimplemented from CXTPGridInplaceControl.

The documentation for this class was generated from the following file:
  • XTPGridInplaceControls.h


Toolkit Pro: CXTPGridNavigator Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPGridNavigator Class Reference

Utility class, handles Grid control item navigation. More...

Inheritance diagram for CXTPGridNavigator:
[legend]

Public Member Functions

CXTPGridNavigator (CXTPGridControl *pGridControl)
Default navigator constructor, handles properties initialization.
virtual | ~CXTPGridNavigator ()
Default navigator destructor, handles member items deallocation.
virtual void | BeginEdit ()
Call this method to begin editing the currently focused item.
virtual void | MoveDown (BOOL bShiftKey=FALSE, BOOL bControlKey=FALSE)
Moves the focused row down by one.
virtual void | MoveDownStep (BOOL bShiftKey=FALSE, BOOL bControlKey=FALSE)
Moves the focused row down by one.
virtual void | MoveUp (BOOL bShiftKey=FALSE, BOOL bControlKey=FALSE)
Moves the focused row up by one.
virtual void | MoveUpStep (BOOL bShiftKey=FALSE, BOOL bControlKey=FALSE)
Moves the focused row up by one.
virtual void | MovePageDown (BOOL bShiftKey=FALSE, BOOL bControlKey=FALSE)
Moves the focused row down by one page.
virtual void | MovePageUp (BOOL bShiftKey=FALSE, BOOL bControlKey=FALSE)
Moves the focused row up by one page.
void | MoveFirstRow (BOOL bShiftKey=FALSE, BOOL bControlKey=FALSE)
Moves the focused row to the beginning of the grid view.
void | MoveLastRow (BOOL bShiftKey=FALSE, BOOL bControlKey=FALSE)
Moves the focused row to the end of the grid view.
void | MoveToRow (int nRowIndex, BOOL bShiftKey=FALSE, BOOL bControlKey=FALSE)
Moves the focused row to a specified row index.
void | MoveFirstColumn ()
Moves the focused column to the beginning of the currently selected row.
void | MoveLastColumn ()
Moves the focused column to the end of the currently selected row.
void | MoveLeft (BOOL bShiftKey=FALSE, BOOL bControlKey=FALSE)
Moves the focused column left by one.
void | MoveRight (BOOL bShiftKey=FALSE, BOOL bControlKey=FALSE)
Moves the focused column right by one.
void | MoveToColumn (int nColumnIndex, BOOL bClearIfNonFocusable=FALSE)
Moves the focused column to a specified column index.
void | SetCurrentFocusInHeadersRows (BOOL bCurrentFocusInHeadersRows)
Sets the current focus (selected row) to header rows.
void | SetCurrentFocusInFootersRows (BOOL bCurrentFocusInFootersRows)
Sets the current focus (selected row) to footer rows.
BOOL | GetCurrentFocusInHeadersRows ()
Determines if the current focus (selected row) belongs to header rows.
BOOL | GetCurrentFocusInFootersRows ()
Determines if the current focus (selected row) belongs to footer rows.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

virtual void | MoveLeftRight (BOOL bBack, BOOL bShiftKey=FALSE, BOOL bControlKey=FALSE)
Moves the focused column left/right.
void | MoveFirstVisibleRow (XTPGridRowType RowType)
Moves the focused row to the first visible row of a target section: body, header, or footer.
void | MoveLastVisibleRow (XTPGridRowType RowType)
Moves the focused row to the last visible row of a target section: body, header, or footer.
int | CheckDeadEnd (BOOL bMoveDown)
Checks for a dead end row by moving down/up.

Protected Attributes

CXTPGridControl * m_pGridControl
Associated Grid control.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

Utility class, handles Grid control item navigation.

See also
CXTPGridControl overview

Constructor & Destructor Documentation

◆ CXTPGridNavigator()

CXTPGridNavigator ( CXTPGridControl * pGridControl )

Default navigator constructor, handles properties initialization.

Parameters
pGridControl Pointer to a CXTPGridControl object
See also
RefreshMetrics

Member Function Documentation

◆ CheckDeadEnd()

int CheckDeadEnd ( BOOL bMoveDown )
protected

Checks for a dead end row by moving down/up.

Parameters
bMoveDown TRUE to move down, FALSE to move up.
Returns
The index of the dead end row.
See also
SetCurrentFocusInHeadersRows, SetCurrentFocusInFootersRows

◆ GetCurrentFocusInFootersRows()

BOOL GetCurrentFocusInFootersRows ( )

Determines if the current focus (selected row) belongs to footer rows.

Returns
TRUE if the current focus (selected row) belongs to footer rows, otherwise FALSE.
See also
SetCurrentFocusInFootersRows

◆ GetCurrentFocusInHeadersRows()

BOOL GetCurrentFocusInHeadersRows ( )

Determines if the current focus (selected row) belongs to header rows.

Returns
TRUE if the current focus (selected row) belongs to header rows, otherwise FALSE.
See also
SetCurrentFocusInHeadersRows

◆ MoveDown()

virtual void MoveDown | ( | BOOL | bShiftKey = FALSE,
 |  | BOOL | bControlKey = FALSE )
 virtual

Moves the focused row down by one.

Parameters
bShiftKey | TRUE to select a new focused row.
bControlKey | TRUE to ignore the current rows selection.

Moves the currently focused row down by one.

See also
MoveUp, MovePageDown, MovePageUp, MoveFirst, MoveLast

Reimplemented in CXTPGridIconNavigator.

◆ MoveDownStep()

virtual void MoveDownStep | ( | BOOL | bShiftKey = FALSE,
 |  | BOOL | bControlKey = FALSE )
 virtual

Moves the focused row down by one.

Parameters
bShiftKey | TRUE to select a new focused row.
bControlKey | TRUE to ignore the current rows selection.

Moves the currently focused row down by one.

See also
MoveUp, MovePageDown, MovePageUp, MoveFirst, MoveLast

Reimplemented in CXTPGridIconNavigator.

◆ MoveFirstColumn()

void MoveFirstColumn ( )

Moves the focused column to the beginning of the currently selected row.

See also
MoveLastColumn

◆ MoveFirstRow()

void MoveFirstRow | ( | BOOL | bShiftKey = FALSE,
 |  | BOOL | bControlKey = FALSE )

Moves the focused row to the beginning of the grid view.

Parameters
bShiftKey | TRUE to select rows up to the new focused row.
bControlKey | TRUE to ignore the current rows selection.

Moves the currently focused row to the top of the rows list.

See also
MoveDown, MoveUp, MovePageDown, MovePageUp, MoveLast

◆ MoveFirstVisibleRow()

void MoveFirstVisibleRow ( XTPGridRowType RowType )
protected

Moves the focused row to the first visible row of a target section: body, header, or footer.

Parameters
RowType Target section for the focused row; must be one of the values defined by the XTPGridRowType enumeration.

Moves the focused row to the first visible target row.

See also
SetCurrentFocusInHeadersRows, SetCurrentFocusInFootersRows

◆ MoveLastColumn()

void MoveLastColumn ( )

Moves the focused column to the end of the currently selected row.

See also
MoveFirstColumn

◆ MoveLastRow()

void MoveLastRow | ( | BOOL | bShiftKey = FALSE,
 |  | BOOL | bControlKey = FALSE )

Moves the focused row to the end of the grid view.

Parameters
bShiftKey | TRUE to select rows up to the new focused row.
bControlKey | TRUE to ignore the current rows selection.

Moves the currently focused row to the bottom of the rows list.

See also
MoveDown, MoveUp, MovePageDown, MovePageUp, MoveFirst

◆ MoveLastVisibleRow()

void MoveLastVisibleRow ( XTPGridRowType RowType )
protected

Moves the focused row to the last visible row of a target section: body, header, or footer.

Parameters
RowType Target section for the focused row; must be one of the values defined by the XTPGridRowType enumeration.

Moves the focused row to the last visible target row.

See also
SetCurrentFocusInHeadersRows, SetCurrentFocusInFootersRows

◆ MoveLeft()

void MoveLeft | ( | BOOL | bShiftKey = FALSE,
 |  | BOOL | bControlKey = FALSE )

Moves the focused column left by one.

Parameters
bShiftKey | TRUE to select a new focused row.
bControlKey | TRUE to ignore the current rows selection.

Moves the currently focused column left by one.

See also
MoveUp, MovePageDown, MovePageUp, MoveFirst, MoveLast

◆ MoveLeftRight()

virtual void MoveLeftRight | ( | BOOL | bBack,
 |  | BOOL | bShiftKey = FALSE,
 |  | BOOL | bControlKey = FALSE )
 protectedvirtual

Moves the focused column left/right.

Parameters
bBack | TRUE to move left, FALSE to move right.
bShiftKey | TRUE to select a new focused row.
bControlKey | TRUE to ignore the current rows selection.
See also
MoveDown, MovePageDown, MovePageUp, MoveFirst, MoveLast

Reimplemented in CXTPGridIconNavigator.

◆ MovePageDown()

virtual void MovePageDown | ( | BOOL | bShiftKey = FALSE,
 |  | BOOL | bControlKey = FALSE )
 virtual

Moves the focused row down by one page.

Parameters
bShiftKey | TRUE to select rows up to the new focused row.
bControlKey | TRUE to ignore the current rows selection.

Moves the currently focused row down by one page (and count the visible rows in a view).

See also
MoveDown, MoveUp, MovePageUp, MoveFirst, MoveLast

Reimplemented in CXTPGridIconNavigator.

◆ MovePageUp()

virtual void MovePageUp | ( | BOOL | bShiftKey = FALSE,
 |  | BOOL | bControlKey = FALSE )
 virtual

Moves the focused row up by one page.

Parameters
bShiftKey | TRUE to select rows up to the new focused row.
bControlKey | TRUE to ignore the current rows selection.

Moves the currently focused row up by one page (and count the visible rows in a view).

See also
MoveDown, MoveUp, MovePageDown, MoveFirst, MoveLast

Reimplemented in CXTPGridIconNavigator.

◆ MoveRight()

void MoveRight | ( | BOOL | bShiftKey = FALSE,
 |  | BOOL | bControlKey = FALSE )

Moves the focused column right by one.

Parameters
bShiftKey | TRUE to select a new focused row.
bControlKey | TRUE to ignore the current rows selection.

Moves the currently focused column right by one.

See also
MoveDown, MovePageDown, MovePageUp, MoveFirst, MoveLast

◆ MoveToColumn()

void MoveToColumn | ( | int | nColumnIndex,
 |  | BOOL | bClearIfNonFocusable = FALSE )

Moves the focused column to a specified column index.

Parameters
nColumnIndex | Column index to move the focused column to.
bClearIfNonFocusable | Used in the event that the column specified by nColumnIndex is not focusable. TRUE to clear the column focus (resulting in no column having focus), FALSE to prevent the focused column from being changed.

Moves the currently focused column to the specified column index.

See also
MoveDown, MovePageDown, MovePageUp, MoveFirst, MoveLast

◆ MoveToRow()

void MoveToRow | ( | int | nRowIndex,
 |  | BOOL | bShiftKey = FALSE,
 |  | BOOL | bControlKey = FALSE )

Moves the focused row to a specified row index.

Parameters
nRowIndex | Row index to move the focused row to.
bShiftKey | TRUE to select rows up to the new focused row.
bControlKey | TRUE to ignore the current rows selection.

Moves the currently focused row to the specified row index.

See also
MoveDown, MoveUp, MovePageDown, MovePageUp, MoveFirst

◆ MoveUp()

virtual void MoveUp | ( | BOOL | bShiftKey = FALSE,
 |  | BOOL | bControlKey = FALSE )
 virtual

Moves the focused row up by one.

Parameters
bShiftKey | TRUE to select a new focused row.
bControlKey | TRUE to ignore the current rows selection.

Moves the currently focused row up by one.

See also
MoveDown, MovePageDown, MovePageUp, MoveFirst, MoveLast

Reimplemented in CXTPGridIconNavigator.

◆ MoveUpStep()

virtual void MoveUpStep | ( | BOOL | bShiftKey = FALSE,
 |  | BOOL | bControlKey = FALSE )
 virtual

Moves the focused row up by one.

Parameters
bShiftKey | TRUE to select a new focused row.
bControlKey | TRUE to ignore the current rows selection.

Moves the currently focused row up by one.

See also
MoveDown, MovePageDown, MovePageUp, MoveFirst, MoveLast

Reimplemented in CXTPGridIconNavigator.

◆ SetCurrentFocusInFootersRows()

void SetCurrentFocusInFootersRows ( BOOL bCurrentFocusInFootersRows )

Sets the current focus (selected row) to footer rows.

Parameters
bCurrentFocusInFootersRows TRUE to set the current focus to footer rows, FALSE otherwise.
See also
GetCurrentFocusInFootersRows

◆ SetCurrentFocusInHeadersRows()

void SetCurrentFocusInHeadersRows ( BOOL bCurrentFocusInHeadersRows )

Sets the current focus (selected row) to header rows.

Parameters
bCurrentFocusInHeadersRows TRUE to set the current focus to header rows, FALSE otherwise.
See also
GetCurrentFocusInHeadersRows
The documentation for this class was generated from the following file:
  • XTPGridNavigator.h


Toolkit Pro: CXTPGridPageSetupDialog Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPGridPageSetupDialog Class Reference

Customized Grid control page setup dialog. More...

Public Member Functions

CXTPGridPageSetupDialog (CXTPGridViewPrintOptions *pOptions, DWORD dwFlags=PSD_MARGINS|PSD_INWININIINTLMEASURE, CWnd *pParentWnd=NULL)
Class constructor.
virtual ~CXTPGridPageSetupDialog ()
Destroys a CXTPGridPageSetupDialog object, handles cleanup and deallocation.

Protected Member Functions

virtual BOOL | OnInitDialog ()
Dialog-box initialization.
virtual void | OnOK ()
Called when the user clicks the OK button (i.e.

Protected Attributes

CXTPGridViewPrintOptions * m_pOptions
Pointer to associated print options object.

Detailed Description

Customized Grid control page setup dialog.

Use this class when you want to allow users to customize printing options for the Grid control.

This class enhances the standard MFC page setup dialog, which encapsulates the services provided by the Windows common OLE Page Setup dialog box with additional support for setting and modifying print margins. This class is designed to take the place of the Print Setup dialog box.

See also
CXTPGridViewPrintOptions overview, CPageSetupDialog overview

Constructor & Destructor Documentation

◆ CXTPGridPageSetupDialog()

CXTPGridPageSetupDialog | ( | CXTPGridViewPrintOptions * | pOptions,
 |  | DWORD | dwFlags = PSD_MARGINS|PSD_INWININIINTLMEASURE,
 |  | CWnd * | pParentWnd = NULL )

Class constructor.

Parameters
pOptions | Pointer to an associated CXTPGridViewPrintOptions object for storing user's interaction results.
dwFlags | One or more flags you can use to customize the settings of the dialog box. The values can be combined using the bitwise-OR operator. For more details, see CPageSetupDialog::CPageSetupDialog.
pParentWnd | Pointer to the dialog box's parent or owner.

Use the DoModal function to display the dialog box.

See also
CPageSetupDialog::CPageSetupDialog()

Member Function Documentation

◆ OnInitDialog()

virtual BOOL OnInitDialog ( )
protectedvirtual

Dialog-box initialization.

Returns
FALSE because it must explicitly set the input focus to one of the controls in the dialog box.
See also
CPageSetupDialog::OnInitDialog().

◆ OnOK()

virtual void OnOK ( )
protectedvirtual

Called when the user clicks the OK button (i.e.

the button with an ID of IDOK).

Saves all values into the m_pOptions structure.

See also
CPageSetupDialog::OnOK().
The documentation for this class was generated from the following file:
  • XTPGridPageSetupDialog.h


Toolkit Pro: CXTPGridPaintManager Class Reference

Public Member Functions | Public Attributes | Protected Member Functions | Protected Attributes | List of all members
CXTPGridPaintManager Class Reference

Utility class that handles most drawing activities. More...

Inheritance diagram for CXTPGridPaintManager:
[legend]

Public Member Functions

CXTPGridPaintManager ()
Default CXTPGridPaintManager constructor, handles properties initialization.
virtual | ~CXTPGridPaintManager ()
Default CXTPGridPaintManager destructor, handles member items deallocation.
virtual void | SetGridControl (CXTPGridControl *pControl)
Sets the associated Grid control for the paint manager.
virtual void | LoadGlyphs ()
Loads the default images used by the Grid control.
virtual void | RefreshMetrics ()
Initializes all drawings defaults (fonts, colors, etc.).
virtual int | GetRowHeight (CDC *pDC, CXTPGridRow *pRow)
Retrieves the default row height for print mode (i.e.
virtual int | GetRowHeight (CDC *pDC, CXTPGridRow *pRow, int nTotalWidth)
Retrieves the default row height for print mode (i.e.
int | GetRowHeightEx (CDC *pDC, CXTPGridRow *pRow, int nTotalWidth, const BOOL firstLevel=TRUE)
Retrieves the default row height for print mode (i.e.
int | GetItemHeight (XTP_GRIDRECORDITEM_DRAWARGS &drawArgs, int nWidth)
Retrieves the height of a record item for a given width.
BOOL | FindRowAdjacentToMergedEx (const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, int &nAdjRowIndex, BOOL bUpward)
Searches the topmost or bottommost row depending on the height of the current row.
int | FindRowAdjacentToMerged (const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, BOOL bUpward)
Wrapper for the FindRowAdjacentToMergedEx method.
int | RecalcTotalHightOfMergedRows (CXTPGridColumns *pColumns, CDC *pDC, CXTPGridRow *pRow, int nRowHeight, int nTotalWidth)
Recalculates row height according to the height of merged items.
virtual int | GetPreviewItemHeight (CDC *pDC, CXTPGridRow *pRow, int nWidth, int nHeight)
Retrieves the height of a preview item for print mode.
virtual int | GetHeaderHeight ()
Gets the column header height.
virtual int | GetHeaderHeight (CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0)
Calculates the optimal header height.
virtual void | SetHeaderHeight (int nHeight)
Sets the column header height.
virtual int | GetFooterHeight (CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0)
Calculates the optimal footer height.
virtual COLORREF | GetControlBackColor (CXTPGridControl *pControl)
Retrieves the parent Grid control's background color.
virtual void | FillRow (CDC *pDC, CXTPGridRow *pRow, CRect rcRow)
Fills a specified row with its background color.
virtual void | DrawGrid (CDC *pDC, XTPGridOrientation orientation, CRect rcGrid)
Draws a grid for the control.
virtual void | DrawFreezeColsDivider (CDC *pDC, const CRect &rc, CXTPGridControl *pControl, CXTPGridRow *pRow=NULL)
Draws a freeze column divider.
virtual void | DrawVerticalTimeLineMarker (CDC *pDC, int xPos, CXTPGridControl *pControl, COLORREF color=RGB(0, 255, 0))
Draws a vertical timeline marker.
virtual void | DrawGroupRow (CDC *pDC, CXTPGridGroupRow *pRow, CRect rcRow, XTP_GRIDRECORDITEM_METRICS *pMetrics)
Draws a group row.
virtual void | FillGroupRowMetrics (CXTPGridGroupRow *pRow, XTP_GRIDRECORDITEM_METRICS *pMetrics, BOOL bPrinting)
Fills the font and color members of the metrics structure for a specified group row.
virtual void | FillIndent (CDC *pDC, CRect rcRow)
Fills an indent area by its background.
virtual void | FillItemShade (CDC *pDC, CRect rcItem)
Fills an item shade by its background if necessary.
virtual void | FillHeaderControl (CDC *pDC, CRect rcHeader)
Fills a column header control area by its background.
virtual void | FillFooter (CDC *pDC, CRect rcFooter)
Fills a column footer control area by its background.
virtual void | DrawColumnText (CDC *pDC, CRect rcText, CString strCaption, int nHeaderAlignment, BOOL bIsHeader, BOOL bColumnPressed)
Draws text for the column header.
virtual void | DrawColumn (CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn, BOOL bDrawExternal=FALSE, int nShadowWidth=0)
Draws a column header with all related attributes (sort order, icon, etc.).
virtual void | DrawColumnFooterDivider (CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn)
Draws the column footer divider.
virtual void | DrawColumnFooter (CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn)
Draws the column footer with all related attributes (e.g.
virtual BOOL | IsColumHotTrackingEnabled () const
Determines if hot tracking is enabled for the current column style.
virtual void | DrawFocusedRow (CDC *pDC, CRect rcRow)
Draws focused rows.
virtual void | FillGroupByControl (CDC *pDC, CRect &rcGroupBy)
Draws the Group By box.
CXTPImageManager * | GetGlyphs () const
Gets a pointer to the additional image list with glyphs.
void | DrawHorizontalLine (CDC *pDC, int xPos, int yPos, int cx, COLORREF clr)
Draws a horizontal line.
void | DrawVerticalLine (CDC *pDC, int xPos, int yPos, int cy, COLORREF clr)
Draws a vertical line.
virtual void | DrawTriangle (CDC *pDC, CRect rcTriangle, BOOL bToDown, BOOL bDraggingFromHeader, int nShadowWidth, BOOL bColumnPressed)
Draws a triangle that shows the sort order of the column.
void | DrawConnector (CDC *pDC, CPoint ptFrom, CPoint ptTo)
Draws a column connector for the Group By box.
virtual CSize | DrawCollapsedBitmap (CDC *pDC, const CXTPGridRow *pRow, CRect &rcBitmap)
Draws a collapsed bitmap.
virtual int | DrawBitmap (CDC *pDC, CXTPGridControl *pControl, CRect rcColumn, int iImage)
Draws a bitmap.
virtual int | DrawColumnIcon (CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, CRect rcIcon, int iIcon)
Draws an icon for a column.
virtual CSize | DrawGlyph (CDC *pDC, CRect rcColumn, int iImage)
Draws the standard glyphs of the Grid control.
virtual CSize | DrawShellIcon (CDC *pDC, CRect rcColumn, int iImage)
Draws the shell icon.
void | EnablePreviewMode (BOOL bIsPreviewMode)
Enables/disables preview mode for the control.
BOOL | IsPreviewMode () const
Determines if preview mode is enabled/disabled for the control.
CFont * | GetTextFont ()
Gets the default text font used for control items.
int | SetMaxPreviewLines (int nMaxLines)
Sets the maximum number of lines of text for a preview item.
int | GetMaxPreviewLines ()
Gets the maximum number of lines of text for a preview item.
int | GetPreviewLinesCount (CDC *pDC, CRect &rcText, const CString &strText)
Calculates the number of lines required to draw a specified preview text string, taking into account the maximum number of lines of text for a preview item.
BOOL | IsGridVisible (BOOL bVertical) const
Determines the visibility of specified grid lines.
BOOL | IsGridVisible (XTPGridOrientation orientation) const
Determines the visibility of specified grid lines.
void | SetColumnStyle (XTPGridColumnStyle columnStyle)
Sets the header style.
XTPGridColumnStyle | GetColumnStyle () const
Gets the header style.
void | SetColumnOffice2007CustomThemeBaseColor (COLORREF clrBaseColor)
Sets the header's custom theme base color for Office2007 column style.
COLORREF | GetColumnOffice2007CustomThemeBaseColor () const
Gets the header's custom theme base color for Office2007 column style.
void | SetTextFont (LOGFONT &lf)
Creates and sets the default text font.
void | SetCaptionFont (LOGFONT &lf)
Creates and sets the default caption font.
void | SetPreviewIndent (int nLeft, int nTop, int nRight, int nBottom)
Sets the preview item indent.
virtual void | DrawInplaceButton (CDC *pDC, CXTPGridInplaceButton *pButton)
Draws the in-place button of the Grid control.
virtual BOOL | DrawInplaceComboButton (CDC *pDC, CRect *pRc)
Draws the combo button of the Grid control.
virtual BOOL | DrawInplaceExpandButton (CDC *pDC, CRect *pRc)
Draws the expand button of the Grid control.
virtual BOOL | DrawInplaceSpinButton (CDC *pDC, CRect *pRc)
Draws the spin button of the Grid control.
virtual void | DrawTreeStructure (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CRect rcItem, CSize sizeGlyph)
Draws tree elements of the Grid control.
virtual void | DrawItemBitmap (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CRect &rcItem, int nImage)
Draws an item bitmap.
virtual void | DrawItemCaption (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics)
Draws an item caption.
virtual void | DrawRowNumber (CDC *pDC, CRect rcNumber, CXTPGridRow *pRow)
Draws a row number.
virtual void | DrawItemControl (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CXTPGridRecordItemControl *pControl, CRect &rcItem)
Draws an item control.
BOOL | IsFixedRowHeight () const
Determines if the paint manager supports fixed or variable row height.
void | SetFixedRowHeight (BOOL bFixedRowHeight)
Sets if the paint manager supports fixed or variable row height.
BOOL | IsColumnWidthWYSIWYG () const
Determines if the paint manager supports column width WYSIWYG mode.
BOOL | IsLastColumnWidthWYSIWYG () const
Determines if the paint manager supports last column width WYSIWYG mode.
BOOL | IsShowWYSIWYGMarkers () const
Determines if the paint manager shows WYSIWYG page-end markers.
void | ShowWYSIWYGMarkers (BOOL bSet)
Sets if the paint manager shows WYSIWYG page-end markers.
void | SetColumnWidthWYSIWYG (BOOL bColumnWidthWYSIWYG)
Sets if the paint manager supports column width WYSIWYG mode.
void | SetLastColumnWidthWYSIWYG (BOOL bColumnWidthWYSIWYG)
Sets if the paint manager supports last column width WYSIWYG mode.
BOOL | IsFixedInplaceButtonHeight () const
Determines if the paint manager supports fixed or variable in-place button height.
void | SetInplaceButtonHeight (BOOL bFixedInplaceButtonHeight)
Sets if the paint manager supports fixed or variable in-place button height.
int | GetFreezeColsDividerStyle () const
Gets the style of the freeze columns divider line.
void | SetFreezeColsDividerStyle (int nStyle)
Sets the style for the freeze columns divider line.
virtual BOOL | OnDrawAction (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs)
Override this method to perform custom activities for the item before processing it.
virtual void | DrawNoGroupByText (CDC *pDC, CRect rcItem)
Draws the "No items" text message in the Group By area when there are no items inside it.
BOOL | IsDrawGridForEmptySpace () const
Determines if the grid fills empty space after body rows.
void | SetDrawGridForEmptySpace (BOOL bDrawGrid)
Sets if the grid fills empty space after body rows.
BOOL | IsPrintGroupRowIcon () const
Determines if the group row collapse-expand icon is drawn in print mode.
void | SetPrintGroupRowIcon (BOOL bDraw)
Sets if the group row collapse-expand icon is drawn in print mode.
BOOL | IsColumnPlusMinusSign () const
Determines if columns use expand/collapse icons (+/-) or directional arrows.
void | SetColumnPlusMinusSign (BOOL bDraw)
Specifies if columns use expand/collapse icons (+/-) or directional arrows.
virtual int | CalculateRowHeight (CDC *pDC, const CString &strText, int nMaxWidth, BOOL bWordBreak=TRUE)
Calculates the height required for a rectangle bounding multi-line text to draw the multi-line text when the width of the rectangle is fixed.
void | DrawSectionDivider (CDC *pDC, const CRect &rc, XTPGridSectionDividerPosition dividerPosition, XTPGridSectionDividerStyle dividerStyle, CXTPPaintManagerColor dividerColor)
Draws the divider between grid sections (e.g.
int | GetSectionDividerHeight (XTPGridFixedRowsDividerStyle dividerStyle)
Gets the height of the section divider.
BOOL | IsUseDropMarker () const
Determines if a drop marker will be used when dragging and dropping.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Public Attributes

CXTPFont | m_xtpFontText
Grid items default text.
CXTPFont | m_xtpFontBoldText
Grid items default bold text.
CXTPFont | m_xtpFontCaption
Column header caption font.
CXTPFont | m_xtpFontPreview
Column header caption font.
CXTPGridHyperlinkStyle * | m_pHyperlinkStyle
Style for links.
CXTPGridHyperlinkStyle * | m_pHyperlinkHoverStyle
Style for hovered links.
CXTPPaintManagerColor | m_clrHighlight
Background color of the highlighted row.
CXTPPaintManagerColor | m_clrBoldText
Grid items bold text color.
CXTPPaintManagerColor | m_clrBoldTextHighlight
Grid items bold text highlight color.
CXTPPaintManagerColor | m_clrWindowText
Grid items default text color.
CXTPPaintManagerColor | m_clrHighlightText
Text color of the highlighted text.
CXTPPaintManagerColor | m_clrHeaderControl
Background color of the grid header.
CXTPPaintManagerColor | m_clrCaptionText
Column header text color.
CXTPPaintManagerColor | m_clrCaptionTextPressed
Column header text color when pressed.
CXTPPaintManagerColor | m_clrControlBack
Background color of the control grid area.
CXTPPaintManagerColor | m_clrGroupRowText
Row text color.
CXTPPaintManagerColor | m_clrGroupShadeBack
Group row background color when indentation shade is enabled.
CXTPPaintManagerColor | m_clrGroupShadeText
Group row foreground color when indentation shade is enabled.
CXTPPaintManagerColor | m_clrGroupShadeBorder
Color for group border's shade.
CXTPPaintManagerColor | m_clrGroupBoxBack
Color of group box.
CXTPPaintManagerColor | m_clrControlDark
Dark background color of the Grid control (used on Group By area).
CXTPPaintManagerColor | m_clrControlLightLight
Light background color used for drawing shades (used on column header area).
CXTPPaintManagerColor | m_clrHotDivider
Color of the column hot divider window (two arrows).
CXTPPaintManagerColor | m_clrIndentControl
Color of the tree indentation area.
CXTPPaintManagerColor | m_clrItemShade
Color of the shade on sorted by column items.
CXTPPaintManagerColor | m_clrBtnFace
Standard button face color.
CXTPPaintManagerColor | m_clrBtnText
Standard button text color.
CXTPPaintManagerColor | m_clrPreviewText
Preview text color.
CXTPPaintManagerColor | m_clrSelectedRow
Selected row background color.
CXTPPaintManagerColor | m_clrSelectedRowText
Selected row text color.
CXTPPaintManagerColor | m_clrBtnFacePressed
Standard button face color when pressed.
CXTPPaintManagerColor | m_clrConnector
Header column connector line color.
CXTPPaintManagerColor | m_clrDisableBitmapLightest
The lightest color of bitmap which covers disabled grid.
CXTPPaintManagerColor | m_clrDisableBitmapDarkest
The darkest color of bitmap which covers disabled grid.
CXTPPaintManagerColorGradient | m_grcGradientColumn
Color of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColorGradient | m_grcGradientColumnHot
HotTracking Color of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColorGradient | m_grcGradientColumnPushed
Pushed Color of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColor | m_clrGradientColumnShadow
Bottom shadow of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColor | m_clrGradientColumnSeparator
Separator of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColor | m_crlNoGroupByText
A color for "No items" text in GroupBy area (see m_strNoGroupBy member).
CXTPPaintManagerColor | m_clrFreezeColsDivider
Freeze Columns Divider color.
COLORREF | m_clrColumnOffice2007CustomTheme
Base color for Office2007 custom theme.
COLORREF | m_clrFormulaSum
Color for Formula Sum fields.
COLORREF | m_clrFormulaSubSum
Color for Formula SubSum fields.
COLORREF | m_clrAlternativeBackground
Color for Alternative Row Background.
BOOL | m_bUseAlternativeBackground
TRUE to use Alternative Row Background, FALSE otherwise.
BOOL | m_bAllowMergeCells
TRUE to Allow Merge Cells, FALSE otherwise.
int | m_nTextIndentForGroupRowsWithNoIcon
Specifies Text indent if a group row icon is not used.
int | m_nTreeIndent
Tree indentation.
int | m_nTreeStructureStyle
Tree structure style.
int | m_nTreeTextIndentRowParent
Text indent, in pixels, for rows with children.
int | m_nTreeTextIndentRowChildren
Text indent, in pixels, for rows without children.
int | m_nTreeTextIndent
Text indent, in pixels, for rows that are neither parent nor children.
int | m_nTreeTextIndentGroupRow
Text indent, in pixels, for group rows.
BOOL | m_bGroupRowTextBold
TRUE to draw group rows with bold text.
BOOL | m_bShadeGroupHeadings
TRUE to show the indentation shade, FALSE otherwise.
BOOL | m_bShadeSortColumn
TRUE to show the items shade in the sorted by column, FALSE otherwise.
BOOL | m_bHotTracking
TRUE to allow column hot tracking.
BOOL | m_bInvertColumnOnClick
TRUE to invert column on click.
CString | m_strNoItems
A string which contains customized "No Items" text for displaying in view when there are no visible rows.
CString | m_strSortBy
A string which contains customized "Sort By" text for displaying in tooltip.
CString | m_strIncreasing
A string which contains customized "Increasing" text for displaying in tooltip.
CString | m_strDecreasing
A string which contains customized "Decreasing" text for displaying in tooltip.
CString | m_strNoGroupBy
A string which contains customized "No items" text message for displaying in Group By area when there are no items inside it.
CString | m_strNoFieldsAvailable
A string which contains customized "No Fields Available" text message for displaying in Field Chooser.
CString | m_strExpand
A string which contains customized "Expand" text for displaying in tooltip.
CString | m_strCollapse
A string which contains customized "Collapse" text for displaying in tooltip.
BOOL | m_bHideSelection
TRUE when hiding Grid control's selection by drawing selected items as others, FALSE otherwise.
BOOL | m_bPrintSortTriangle
TRUE to show the sort triangle in printout.
BOOL | m_bRevertAlignment
TRUE to revert column alignments.
BOOL | m_bUseEditTextAlignment
TRUE to automatically apply edit alignment using column alignment.
BOOL | m_bShowLockIcon
TRUE to show the lock icon, FALSE to hide.
BOOL | m_bUseShellIcon
TRUE to use the shell icon, FALSE otherwise.
int | m_iRecOrRowStart
Start position in numbering (0 or 1 or something user want).
BOOL | m_bRecOrRowNum
TRUE to display record number if support mode is used, FALSE to display row number.
BOOL | m_bMakeUpper
TRUE to display column header and group row text in all caps.
XTPGridTreeStructureStyle | m_treeStructureStyle
Tree structure style.
CRect | m_rcPreviewIndent
Preview indentation.
int | m_nFixedColumnsIndent
Fixed Column total width.
BOOL | m_bMoveScrollbarOnFixedColumnsIndent
Move Scrollbar right follow FixedColumnsIndent.
BOOL | m_bThemedInplaceButtons
Draw in-place buttons using current theme settings.
BOOL | m_bBaseTreeIndent
TRUE to add Extra Tree indentation to cover initial TreeColumn.
CUIntArray | m_arStartCol
Start column in each virtual page.
int | m_PrintPageWidth
Width of print page (run-time)
BOOL | m_bPrintVirtualPageNumber
TRUE to print horizontal page number.
BOOL | m_bPrintPageRectangle
TRUE to draw rectangle around page.
int | m_RecordNumberWidth
Column width for row/record numbers.
BOOL | m_bForceDynamicMarkupForCell
TRUE if use Markup for Grid Record Item.
BOOL | m_bForceShowDropMarker
TRUE if Force Show Drop Marker.
BOOL | m_bShowNonActiveInPlaceButton
TRUE if use Show Non-Active In-Place Button (Combo, Expand, Spin).
BOOL | m_bPrintWatermark
TRUE to print watermark.
BOOL | m_bUseGroupRowSelectionState
TRUE if use GroupSelectionState Glyph.
BOOL | m_bForceShowTooltip
TRUE if use show tooltip for any cell width case.
BOOL | m_bCleanTooltip
TRUE if use show tooltip without markup.
BOOL | m_bGrayIfDisable
TRUE is disable draw in gray (standard behavior).
int | m_nRowHeightDefault
The default row height.
BOOL | m_bCompactText
TRUE to ignore Icon for Narrow column to show more text.
BOOL | m_bUseDropMarker
FALSE to not draw drop marked when dragging/dropping, TRUE by default.
BOOL | m_bSortTriangleOffsetFromRight
Offset of sort triangle.
int | m_nTreeColumnLineLength
This is the extra line length to apply to tree column lines if there is no expand button.
int | m_nBaseParentRecordIndent
This is initial number of pixels a parent node will be indented when in a group.

Protected Member Functions

virtual void | DrawTextLine (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nFlag, int &nCharCounter, int &nHyperlinkCounter)
Draws a line of text with respect to the drawing rectangle.
virtual int | DrawString (int *pnCurrDrawPos, CDC *pDC, const CString &strDraw, CRect rcDraw, UINT nFormat)
Draw a simple string into rectangle.
virtual void | DrawColumnBackground (CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, BOOL &bColumnPressed, BOOL &bDraggingFromHeader, CXTPGridHeader *pHeader=NULL)
This method is called to draw the background of a column using the current column style.
virtual void | DrawGridPattern (CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush)
Generates a custom grid pattern if necessary.
virtual void | DrawGridPattern (CDC *pDC, CXTPBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush)
Generates a custom grid pattern if necessary.
virtual void | DrawGridPattern (CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr)
Generates a custom grid pattern.
virtual void | DrawInplaceButtonFrame (CDC *pDC, CXTPGridInplaceButton *pButton)
Draws the in-place button frame.
virtual BOOL | DrawInplaceButtonIcon (CDC *pDC, CXTPGridInplaceButton *pButton)
Draws the in-place button icon.
virtual int | CalcColumnHeight (CDC *pDC, CXTPGridColumn *pColumn, int nTotalWidth=0)
Calculates the optimal height for a specified column.
virtual void | DrawMultiLineText (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, BOOL bWordBreak=TRUE)
Draws multi-line text.
virtual void | DrawSingleLineText (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nStartPos, int nEndPos, int nActualWidth)
Draws single-line text.
virtual int | DrawLink (int *pnCurrDrawPos, XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CXTPGridHyperlink *pHyperlink, CString strText, CRect rcLink, int nFlag, BOOL bTrim=FALSE)
Draws a hyperlink string using hyperlink text settings (i.e.

Protected Attributes

int | m_nRowHeight
Grid row default height.
int | m_nHeaderHeight
Column header height.
int | m_nFooterHeight
Column footer height.
int | m_nGroupGridLineHeight
The height of the group grid line.
CXTPImageManager * | m_pGlyphs
An additional image list for the Grid control.
BOOL | m_bIsPreviewMode
TRUE to show the item preview, FALSE to hide.
int | m_nResizingWidth
The width of the column resizing marker area.
int | m_nMaxPreviewLines
Restrict maximum lines for preview text.
CSize | m_szGlyph
Glyph size.
CXTPBrush | m_xtpBrushTreeStructure
Brush to draw tree nodes.
CXTPBrush | m_xtpBrushGroupGridLineStyle
Brush to draw group row grid lines.
int | m_nFreezeColsDividerStyle
A set of flags from XTPGridFreezeColsDividerStyle.
BOOL | m_bFixedRowHeight
TRUE if fixed rows used.
BOOL | m_bColumnWidthWYSIWYG
TRUE if columns width WYSIWYG mode used.
BOOL | m_bShowWYSIWYGMarkers
TRUE if in non-print mode header show red page-end markers.
BOOL | m_bLastColumnWidthWYSIWYG
TRUE if last column width WYSIWYG mode used.
BOOL | m_bDrawGridForEmptySpace
TRUE if grid fills the empty space (if any) after the body rows.
BOOL | m_bPrintGroupRowIcon
TRUE if printout draw collapse-expand icon for group row.
BOOL | m_bColumnPlusMinusSign
TRUE if expand/collapse icons are used, FALSE if directional arrows are used.
BOOL | m_bFixedInplaceButtonHeight
TRUE if fixed in-place button height is used.
XTPGridGridStyle | m_nGroupGridLineStyle
Current style for group row grid lines.
XTPGridColumnStyle | m_columnStyle
Column drawing style.
CXTPWinThemeWrapper * | m_themeHeader
Header theme wrapper.
CXTPWinThemeWrapper * | m_themeButton
In-place button theme wrapper.
CXTPWinThemeWrapper * | m_themeCombo
Combo box in-place button theme wrapper.
CXTPWinThemeWrapper * | m_themeSpin
Spin in-place button theme wrapper.
CXTPGridControl * | m_pControl
Pointer to the Grid control object.
CXTPMarkupUIElement * | m_pMarkupUIElement_NoGroupBy
The no group by markup UI element.
CString | m_strMarkupUIElement_NoGroupBy
The no group by markup UI element string.
CXTPBrush | m_xtpBrushVeriticalGrid
Brush to draw vertical grid lines.
CXTPBrush | m_xtpBrushHorizontalGrid
Brush to draw horizontal grid lines.
XTPGridGridStyle m_nGridLineStylePreviousV
Previous style for vertical grid lines.
XTPGridGridStyle m_nGridLineStylePreviousH
Previous style for horizontal grid lines.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

Utility class that handles most drawing activities.

It stores all of the settings required by a control to perform drawing operations (i.e. fonts, colors, and styles for all other classes of a control). It also implements all functions for drawing typical graphical primitives and functions that directly work with the device context.

Can be overridden to provide another look and feel for the control. Thus, you have an easy way to change the "skin" of your control. Just provide your own implementation of CXTPGridPaintManager and there is no need to touch the functionality for other classes of the control.

You create a CXTPGridPaintManager object by calling its constructor. Furthermore, you can call getter and setter functions to change every setting as you wish.

See also
CXTPGridControl overview, CXTPGridRow, CXTPGridGroupRow, CXTPGridColumn, CXTPGridHeader

Constructor & Destructor Documentation

◆ CXTPGridPaintManager()

CXTPGridPaintManager ( )

Default CXTPGridPaintManager constructor, handles properties initialization.

See also
RefreshMetrics

Member Function Documentation

◆ CalcColumnHeight()

virtual int CalcColumnHeight | ( | CDC * | pDC,
 |  | CXTPGridColumn * | pColumn,
 |  | int | nTotalWidth = 0 )
 protectedvirtual

Calculates the optimal height for a specified column.

Parameters
pDC | Pointer to the device context.
pColumn | Pointer to a CXTPGridColumn object.
nTotalWidth | Total header width (used only for printing).
Returns
The optimal height for the specified column.

◆ CalculateRowHeight()

virtual int CalculateRowHeight | ( | CDC * | pDC,
 |  | const CString & | strText,
 |  | int | nMaxWidth,
 |  | BOOL | bWordBreak = TRUE )
 virtual

Calculates the height required for a rectangle bounding multi-line text to draw the multi-line text when the width of the rectangle is fixed.

Parameters
pDC | Pointer to the device context.
strText | Reference to a text string.
nMaxWidth | Maximum width of the rectangle bounding the text.
bWordBreak | TRUE to break lines by words, FALSE to only allow new line characters to increase the row height.
Returns
The height required for the rectangle to draw the multi-line text.

◆ DrawBitmap()

virtual int DrawBitmap | ( | CDC * | pDC,
 |  | CXTPGridControl * | pControl,
 |  | CRect | rcColumn,
 |  | int | iImage )
 virtual

Draws a bitmap.

Parameters
pDC | Pointer to the used device context.
pControl | Pointer to the Grid control where the bitmap will be drawn.
rcColumn | Bitmap area rectangle coordinates.
iImage | Image index. Remarks You use this function to draw a bitmap in the column rectangle. If the provided rectangle is too small, the bitmap will not be drawn. Generally, the column rectangle must be big enough to contain text (if presented) and a bitmap.
Returns
The width of the drawn bitmap.

Example:

// draws bitmap with id ID_READ
pPaintManager->DrawBitmap(pDC, pControl, rcColumn, ID_READ);

◆ DrawCollapsedBitmap()

virtual CSize DrawCollapsedBitmap | ( | CDC * | pDC,
 |  | const CXTPGridRow * | pRow,
 |  | CRect & | rcBitmap )
 virtual

Draws a collapsed bitmap.

Parameters
pDC | Pointer to the used device context.
pRow | Pointer to a grid row.
rcBitmap | Reference to bitmap area rectangle coordinates.
Returns
The size of the drawn bitmap.

Reimplemented in CXTPGridThemeOffice2013, CXTPGridThemeResource, and CXTPTrackThemeResource.

◆ DrawColumn()

virtual void DrawColumn | ( | CDC * | pDC,
 |  | CXTPGridColumn * | pColumn,
 |  | CXTPGridHeader * | pHeader,
 |  | CRect | rcColumn,
 |  | BOOL | bDrawExternal = FALSE,
 |  | int | nShadowWidth = 0 )
 virtual

Draws a column header with all related attributes (sort order, icon, etc.).

Parameters
pDC | Pointer to the used device context.
pColumn | Pointer to column header area rectangle coordinates.
pHeader | Pointer to the grid header.
rcColumn | Column area rectangle coordinates.
bDrawExternal | TRUE to draw the column above the header; the default value for this parameter is FALSE.
nShadowWidth | Size in pixels for the bottom shadow; the default value for this parameter is 0.

Example:

CXTPGridPaintManager* pPaintManager = m_pControl->GetPaintManager();
CXTPGridColumn* pColumn = CXTPGridColumn* pColumn = m_pColumns->GetAt(1);
CRect rcHeader(rcClient);
int nHeaderHeight = m_pControl->GetHeaderHeight();
rcHeader.bottom = rcHeader.top + nHeaderHeight;
GetPaintManager()->DrawColumn(pDC, pColumn, this, rcHeader);

Reimplemented in CXTPGridThemeOffice2003, and CXTPTrackThemeOffice2003.

◆ DrawColumnBackground()

virtual void DrawColumnBackground | ( | CDC * | pDC,
 |  | CXTPGridColumn * | pColumn,
 |  | CRect | rcColumn,
 |  | BOOL & | bColumnPressed,
 |  | BOOL & | bDraggingFromHeader,
 |  | CXTPGridHeader * | pHeader = NULL )
 protectedvirtual

This method is called to draw the background of a column using the current column style.

Parameters
pDC | Pointer to the used device context.
pColumn | Pointer to the column whose background must be drawn.
rcColumn | Bounding rectangle of the column.
bColumnPressed | TRUE if the column is pressed by the user.
bDraggingFromHeader | TRUE if the column is being dragged from the header area.
pHeader | Pointer to the header that the column belongs to.

Reimplemented in CXTPGridThemeDefault, CXTPGridThemeExplorer, CXTPGridThemeOffice2003, CXTPGridThemeOffice2003Luna, CXTPGridThemeOffice2013, CXTPGridThemeOfficeXP, CXTPGridThemeResource, CXTPTrackThemeDefault, CXTPTrackThemeExplorer, CXTPTrackThemeOffice2003, CXTPTrackThemeOffice2003Luna, CXTPTrackThemeOffice2013, CXTPTrackThemeOfficeXP, and CXTPTrackThemeResource.

◆ DrawColumnFooter()

virtual void DrawColumnFooter | ( | CDC * | pDC,
 |  | CXTPGridColumn * | pColumn,
 |  | CXTPGridHeader * | pHeader,
 |  | CRect | rcColumn )
 virtual

Draws the column footer with all related attributes (e.g.

footer text).

Parameters
pDC | Pointer to the used device context.
pColumn | Pointer to column header area rectangle coordinates.
pHeader | Pointer to the grid header.
rcColumn | Column area rectangle coordinates.

◆ DrawColumnFooterDivider()

virtual void DrawColumnFooterDivider | ( | CDC * | pDC,
 |  | CXTPGridColumn * | pColumn,
 |  | CRect | rcColumn )
 virtual

Draws the column footer divider.

Parameters
pDC | Pointer to the used device context.
pColumn | Pointer to column header area rectangle coordinates.
rcColumn | Column area rectangle coordinates.

Reimplemented in CXTPGridThemeOffice2003Luna, CXTPGridThemeResource, CXTPTrackThemeOffice2003Luna, and CXTPTrackThemeResource.

◆ DrawColumnIcon()

virtual int DrawColumnIcon | ( | CDC * | pDC,
 |  | CXTPGridColumn * | pColumn,
 |  | CRect | rcColumn,
 |  | CRect | rcIcon,
 |  | int | iIcon )
 virtual

Draws an icon for a column.

Parameters
pDC | Pointer to the used device context.
pColumn | Pointer to a column object.
rcColumn | Column rectangle.
rcIcon | Image bounding rectangle.
iIcon | Image index.
Returns
The width of the drawn bitmap.

◆ DrawColumnText()

virtual void DrawColumnText | ( | CDC * | pDC,
 |  | CRect | rcText,
 |  | CString | strCaption,
 |  | int | nHeaderAlignment,
 |  | BOOL | bIsHeader,
 |  | BOOL | bColumnPressed )
 virtual

Draws text for the column header.

Parameters
pDC | Pointer to the used device context.
rcText | Size and position of the text to render.
strCaption | NULL-terminated string representing the caption text.
nHeaderAlignment | DT_ text alignment flags.
bIsHeader | TRUE if the column is to be rendered for the header.
bColumnPressed | TRUE if the column is pressed by the user.

Reimplemented in CXTPGridThemeOffice2013, CXTPGridThemeResource, CXTPTrackThemeOffice2013, and CXTPTrackThemeResource.

◆ DrawConnector()

void DrawConnector | ( | CDC * | pDC,
 |  | CPoint | ptFrom,
 |  | CPoint | ptTo )

Draws a column connector for the Group By box.

Parameters
pDC | Pointer to the used device context.
ptFrom | Source point of the connector.
ptTo | Target point of the connector.

You use this function to draw a line that represents a chain of columns in the Group By box. It connects columns in the Group By box together.

Example:

DrawConnector(pDC, CPoint(rcItem.right 5, rcItem.bottom), CPoint(x, rcItem.bottom
+ 4));

◆ DrawFocusedRow()

virtual void DrawFocusedRow | ( | CDC * | pDC,
 |  | CRect | rcRow )
 virtual

Draws focused rows.

Parameters
pDC | Pointer to the used device context.
rcRow | Area rectangle coordinates.

Example:

CRect rcClient(GetParent()->GetClientRect());
CXTPGridHeader* pHeader = m_pColumns->GetGridHeader();
CXTPGridPaintManager* pPaintManager = m_pControl->GetPaintManager();
GetPaintManager()->DrawResizingRect(pDC, pHeader, rcClient);

Reimplemented in CXTPGridThemeOffice2013, and CXTPTrackThemeOffice2013.

◆ DrawFreezeColsDivider()

virtual void DrawFreezeColsDivider | ( | CDC * | pDC,
 |  | const CRect & | rc,
 |  | CXTPGridControl * | pControl,
 |  | CXTPGridRow * | pRow = NULL )
 virtual

Draws a freeze column divider.

Parameters
pDC | Pointer to the used device context.
rc | Reference to rectangle coordinates.
pControl | Pointer to a Grid control.
pRow | Pointer to a row.

◆ DrawGlyph()

virtual CSize DrawGlyph | ( | CDC * | pDC,
 |  | CRect | rcColumn,
 |  | int | iImage )
 virtual

Draws the standard glyphs of the Grid control.

Parameters
pDC | Pointer to the used device context.
rcColumn | Bitmap area rectangle coordinates.
iImage | Image index.
Returns
The size of the drawn bitmap.

Reimplemented in CXTPGridThemeExplorer, and CXTPTrackThemeExplorer.

◆ DrawGrid()

virtual void DrawGrid | ( | CDC * | pDC,
 |  | XTPGridOrientation | orientation,
 |  | CRect | rcGrid )
 virtual

Draws a grid for the control.

Parameters
pDC | Pointer to the used device context.
orientation | Determines the grid lines to be tested.
rcGrid | Grid area rectangle coordinates.

Example:

// draw vertical grid in Row
CRect rcGridItem(rcRowRect);
pPaintManager->DrawGrid(pDC, TRUE, rcGridItem);

// draw horizontal grid in Row
CPaintDC pDC(this);
CRect rcGridItem(rcRowRect);
pPaintManager->DrawGrid(pDC, FALSE, rcGridItem);

◆ DrawGridPattern() [1/3]

virtual void DrawGridPattern | ( | CDC * | pDC,
 |  | CBrush * | pBrush,
 |  | CRect | rc,
 |  | const void * | pPattern,
 |  | COLORREF | clr )
 protectedvirtual

Generates a custom grid pattern.

This method only uses pPattern initially.

Parameters
pDC | Pointer to the device context.
pBrush | Pointer to a CBrush object.
rc | Rectangle area.
pPattern | Pointer to a short-integer array containing the initial bitmap bit values. If this parameter is NULL, then the new bitmap is left uninitialized.
clr | Pattern color.

◆ DrawGridPattern() [2/3]

virtual void DrawGridPattern | ( | CDC * | pDC,
 |  | CBrush * | pBrush,
 |  | CRect | rc,
 |  | const void * | pPattern,
 |  | COLORREF | clr,
 |  | BOOL | bUpdateBrush )
 protectedvirtual

Generates a custom grid pattern if necessary.

Otherwise, uses the initially created grid pattern.

Parameters
pDC | Pointer to the device context.
pBrush | Pointer to a CBrush object.
rc | Rectangle area.
pPattern | Pointer to a short-integer array containing the initial bitmap bit values. If this parameter is NULL, then the new bitmap is left uninitialized.
clr | Pattern color.
bUpdateBrush | TRUE to recreate pBrush from pPattern, FALSE otherwise.

◆ DrawGridPattern() [3/3]

virtual void DrawGridPattern | ( | CDC * | pDC,
 |  | CXTPBrush * | pBrush,
 |  | CRect | rc,
 |  | const void * | pPattern,
 |  | COLORREF | clr,
 |  | BOOL | bUpdateBrush )
 protectedvirtual

Generates a custom grid pattern if necessary.

Otherwise, uses the initially created grid pattern.

Parameters
pDC | Pointer to the device context.
pBrush | Pointer to a CBrush object.
rc | Rectangle area.
pPattern | Pointer to a short-integer array containing the initial bitmap bit values. If this parameter is NULL, then the new bitmap is left uninitialized.
clr | Pattern color.
bUpdateBrush | TRUE to recreate pBrush from pPattern, FALSE otherwise.

◆ DrawGroupRow()

virtual void DrawGroupRow | ( | CDC * | pDC,
 |  | CXTPGridGroupRow * | pRow,
 |  | CRect | rcRow,
 |  | XTP_GRIDRECORDITEM_METRICS * | pMetrics )
 virtual

Draws a group row.

Parameters
pDC | Pointer to the used device context.
pRow | Pointer to the Group Row.
rcRow | Group row area rectangle coordinates.
pMetrics | Pointer to an XTP_GRIDRECORDITEM_METRICS structure.

Example:

CXTPGridPaintManager* pPaintManager = m_pControl->GetPaintManager();
pDC->SetBkMode(TRANSPARENT);
pPaintManager->DrawGroupRow(pDC, this, rcRow);

Reimplemented in CXTPGridThemeOffice2013, and CXTPTrackThemeOffice2013.

◆ DrawHorizontalLine()

void DrawHorizontalLine | ( | CDC * | pDC,
 |  | int | xPos,
 |  | int | yPos,
 |  | int | cx,
 |  | COLORREF | clr )

Draws a horizontal line.

Parameters
pDC | Pointer to the used device context.
xPos | Horizontal coordinate of the beginning of the line.
yPos | Vertical coordinate of the beginning of the line.
cx | Length of the line.
clr | Color of the line.

This member function is called anywhere in the control where a simple horizontal line must be drawn.

◆ DrawInplaceButton()

virtual void DrawInplaceButton | ( | CDC * | pDC,
 |  | CXTPGridInplaceButton * | pButton )
 virtual

Draws the in-place button of the Grid control.

Parameters
pDC | Pointer to the device context.
pButton | Pointer to the in-place button to draw.

◆ DrawInplaceButtonFrame()

virtual void DrawInplaceButtonFrame | ( | CDC * | pDC,
 |  | CXTPGridInplaceButton * | pButton )
 protectedvirtual

Draws the in-place button frame.

Parameters
pDC | Pointer to the device context.
pButton | Pointer to the in-place button.

◆ DrawInplaceButtonIcon()

virtual BOOL DrawInplaceButtonIcon | ( | CDC * | pDC,
 |  | CXTPGridInplaceButton * | pButton )
 protectedvirtual

Draws the in-place button icon.

Parameters
pDC | Pointer to the device context.
pButton | Pointer to the in-place button.
Returns
TRUE if the icon was drawn successfully, otherwise FALSE.

◆ DrawInplaceComboButton()

virtual BOOL DrawInplaceComboButton | ( | CDC * | pDC,
 |  | CRect * | pRc )
 virtual

Draws the combo button of the Grid control.

Parameters
pDC | Pointer to the device context.
pRc | Pointer to the rectangle to draw.
Returns
TRUE if the operation was successful, otherwise FALSE.

◆ DrawInplaceExpandButton()

virtual BOOL DrawInplaceExpandButton | ( | CDC * | pDC,
 |  | CRect * | pRc )
 virtual

Draws the expand button of the Grid control.

Parameters
pDC | Pointer to the device context.
pRc | Pointer to the rectangle to draw.
Returns
TRUE if the operation was successful, otherwise FALSE.

◆ DrawInplaceSpinButton()

virtual BOOL DrawInplaceSpinButton | ( | CDC * | pDC,
 |  | CRect * | pRc )
 virtual

Draws the spin button of the Grid control.

Parameters
pDC | Pointer to the device context.
pRc | Pointer to the rectangle to draw.
Returns
TRUE if the operation was successful, otherwise FALSE.

◆ DrawItemBitmap()

virtual void DrawItemBitmap | ( | XTP_GRIDRECORDITEM_DRAWARGS * | pDrawArgs,
 |  | CRect & | rcItem,
 |  | int | nImage )
 virtual

Draws an item bitmap.

Override this method to draw a custom bitmap.

Parameters
pDrawArgs | Pointer to an XTP_GRIDRECORDITEM_DRAWARGS structure containing drawing arguments.
rcItem | Reference to item area rectangle coordinates.
nImage | Image index.

◆ DrawItemCaption()

virtual void DrawItemCaption | ( | XTP_GRIDRECORDITEM_DRAWARGS * | pDrawArgs,
 |  | XTP_GRIDRECORDITEM_METRICS * | pMetrics )
 virtual

Draws an item caption.

Override this method to draw a custom caption.

Parameters
pDrawArgs | Pointer to an XTP_GRIDRECORDITEM_DRAWARGS structure containing drawing arguments.
pMetrics | Pointer to an XTP_GRIDRECORDITEM_METRICS structure containing item metrics.

◆ DrawItemControl()

virtual void DrawItemControl | ( | XTP_GRIDRECORDITEM_DRAWARGS * | pDrawArgs,
 |  | CXTPGridRecordItemControl * | pControl,
 |  | CRect & | rcItem )
 virtual

Draws an item control.

Override this method to draw a custom control.

Parameters
pDrawArgs | Pointer to an XTP_GRIDRECORDITEM_DRAWARGS structure containing drawing arguments.
pControl | Pointer to the control to draw.
rcItem | Reference to item area rectangle coordinates.

◆ DrawLink()

virtual int DrawLink | ( | int * | pnCurrDrawPos,
 |  | XTP_GRIDRECORDITEM_DRAWARGS * | pDrawArgs,
 |  | XTP_GRIDRECORDITEM_METRICS * | pMetrics,
 |  | CXTPGridHyperlink * | pHyperlink,
 |  | CString | strText,
 |  | CRect | rcLink,
 |  | int | nFlag,
 |  | BOOL | bTrim = FALSE )
 protectedvirtual

Draws a hyperlink string using hyperlink text settings (i.e.

removes blanks).

Parameters
pnCurrDrawPos | Pointer to the current drawing position (is updated after each call to this function).
pDrawArgs | Pointer to an XTP_GRIDRECORDITEM_DRAWARGS structure containing drawing arguments.
pMetrics | Pointer to an XTP_GRIDRECORDITEM_METRICS structure containing item metrics.
pHyperlink | Pointer to a CXTPGridHyperlink object.
strText | Text string.
rcLink | Link hot spot area rectangle coordinates.
nFlag | Flag can allow next values:

DT_END_ELLIPSIS truncate text by ellipses.

DT_WORDBREAK truncate text by word end.

Parameters
bTrim TRUE to trim the hyperlink, FALSE otherwise.

This member function is used internally by DrawTextLine to draw the hyperlink chunk of a text string and update the hyperlink's hot spot. If the hyperlink begins/ends with blanks, then the blanks are removed.

Returns
The position in the string where drawing was stopped.

◆ DrawMultiLineText()

virtual void DrawMultiLineText | ( | XTP_GRIDRECORDITEM_DRAWARGS * | pDrawArgs,
 |  | XTP_GRIDRECORDITEM_METRICS * | pMetrics,
 |  | const CString & | strText,
 |  | CRect | rcItem,
 |  | BOOL | bWordBreak = TRUE )
 protectedvirtual

Draws multi-line text.

Parameters
pDrawArgs | Pointer to an XTP_GRIDRECORDITEM_DRAWARGS structure containing drawing arguments.
pMetrics | Pointer to an XTP_GRIDRECORDITEM_METRICS structure containing item metrics.
strText | Reference to a text string.
rcItem | Item area rectangle coordinates.
bWordBreak | TRUE to break lines by words, FALSE to only allow new line characters to force new lines.

This method keeps hyperlinks active.

◆ DrawNoGroupByText()

virtual void DrawNoGroupByText | ( | CDC * | pDC,
 |  | CRect | rcItem )
 virtual

Draws the "No items" text message in the Group By area when there are no items inside it.

Override this method for custom drawing.

Parameters
pDC | Pointer to the used device context.
rcItem | Text area rectangle coordinates.
See also
CXTPGridPaintManager::m_strNoGroupBy

Reimplemented in CXTPGridThemeResource, and CXTPTrackThemeResource.

◆ DrawRowNumber()

virtual void DrawRowNumber | ( | CDC * | pDC,
 |  | CRect | rcNumber,
 |  | CXTPGridRow * | pRow )
 virtual

Draws a row number.

Override this method to draw differently.

Parameters
pDC | Pointer to a valid device context.
rcNumber | Number area rectangle coordinates.
pRow | Pointer to the grid row.

◆ DrawSectionDivider()

void DrawSectionDivider | ( | CDC * | pDC,
 |  | const CRect & | rc,
 |  | XTPGridSectionDividerPosition | dividerPosition,
 |  | XTPGridSectionDividerStyle | dividerStyle,
 |  | CXTPPaintManagerColor | dividerColor )

Draws the divider between grid sections (e.g.

dividing header record rows and body rows).

Parameters
pDC | Pointer to the used device context.
rc | Reference to rectangle coordinates.
dividerPosition | Position of the section divider; must be one of the values defined by the XTPGridSectionDividerPosition enumeration.
dividerStyle | Style of the section divider; must be one of the values defined by the XTPGridSectionDividerStyle enumeration.
dividerColor | Color of the section divider.

◆ DrawShellIcon()

virtual CSize DrawShellIcon | ( | CDC * | pDC,
 |  | CRect | rcColumn,
 |  | int | iImage )
 virtual

Draws the shell icon.

Parameters
pDC | Pointer to the used device context.
rcColumn | Bitmap area rectangle coordinates.
iImage | Image index.
Returns
The size of the drawn bitmap.

◆ DrawSingleLineText()

virtual void DrawSingleLineText | ( | XTP_GRIDRECORDITEM_DRAWARGS * | pDrawArgs,
 |  | XTP_GRIDRECORDITEM_METRICS * | pMetrics,
 |  | const CString & | strText,
 |  | CRect | rcItem,
 |  | int | nStartPos,
 |  | int | nEndPos,
 |  | int | nActualWidth )
 protectedvirtual

Draws single-line text.

Parameters
pDrawArgs | Pointer to an XTP_GRIDRECORDITEM_DRAWARGS structure containing drawing arguments.
pMetrics | Pointer to an XTP_GRIDRECORDITEM_METRICS structure containing item metrics.
strText | Reference to a text string.
rcItem | Item area rectangle coordinates.
nStartPos | Start position in strText.
nEndPos | End position in strText.
nActualWidth | Width of the text to be drawn.

This method keeps hyperlinks active.

◆ DrawString()

virtual int DrawString | ( | int * | pnCurrDrawPos,
 |  | CDC * | pDC,
 |  | const CString & | strDraw,
 |  | CRect | rcDraw,
 |  | UINT | nFormat )
 protectedvirtual

Draw a simple string into rectangle.

Parameters
pnCurrDrawPos | Pointer to the current drawing position (is updated after each call to this function).
pDC | Point to used device context.
strDraw | Reference to a text string.
rcDraw | Text area rectangle coordinates.
nFormat | Flag can allow next values:

DT_END_ELLIPSIS truncate text by ellipses.

DT_WORDBREAK truncate text by word end.

This member function is used internally by DrawTextLine to draw the plain chunk of a text string.

Returns
The position in the string where drawing was stopped.

◆ DrawTextLine()

virtual void DrawTextLine | ( | XTP_GRIDRECORDITEM_DRAWARGS * | pDrawArgs,
 |  | XTP_GRIDRECORDITEM_METRICS * | pMetrics,
 |  | const CString & | strText,
 |  | CRect | rcItem,
 |  | int | nFlag,
 |  | int & | nCharCounter,
 |  | int & | nHyperlinkCounter )
 protectedvirtual

Draws a line of text with respect to the drawing rectangle.

Parameters
pDrawArgs | Pointer to an XTP_GRIDRECORDITEM_DRAWARGS structure containing drawing arguments.
pMetrics | Pointer to an XTP_GRIDRECORDITEM_METRICS structure containing item metrics.
strText | Reference to a text string.
rcItem | Item area rectangle coordinates.
nFlag | Flag can be the following values:

DT_END_ELLIPSIS truncate text by ellipses.

DT_WORDBREAK truncate text by word end.

Parameters
nCharCounter | Reference to a printed char counter; accepts value before and returns value after drawing.
nHyperlinkCounter | Reference to printed hyperlinks counter; accepts value before and returns value after drawing.

This member function is used internally by DrawText() and draws one line of text. It processes plain/hyperlink text for one line. For multi-line text, it processes the last line and then truncates the text either by ellipses or by word.

◆ DrawTreeStructure()

virtual void DrawTreeStructure | ( | XTP_GRIDRECORDITEM_DRAWARGS * | pDrawArgs,
 |  | XTP_GRIDRECORDITEM_METRICS * | pMetrics,
 |  | CRect | rcItem,
 |  | CSize | sizeGlyph )
 virtual

Draws tree elements of the Grid control.

Parameters
pDrawArgs | Pointer to an XTP_GRIDRECORDITEM_DRAWARGS structure containing drawing arguments.
pMetrics | Pointer to an XTP_GRIDRECORDITEM_METRICS structure containing item metrics.
rcItem | Item area rectangle coordinates.
sizeGlyph | Item glyph rectangle coordinates.

◆ DrawTriangle()

virtual void DrawTriangle | ( | CDC * | pDC,
 |  | CRect | rcTriangle,
 |  | BOOL | bToDown,
 |  | BOOL | bDraggingFromHeader,
 |  | int | nShadowWidth,
 |  | BOOL | bColumnPressed )
 virtual

Draws a triangle that shows the sort order of the column.

Parameters
pDC | Pointer to the used device context.
rcTriangle | Triangle area rectangle coordinates.
bToDown | TRUE to turn the top of the triangle downward, FALSE to turn the top of the triangle upward.
bDraggingFromHeader | TRUE if the column is being dragged from the header area.
nShadowWidth | Size, in pixels, of the shadow to draw under the triangle image, or 0 to disable the shadow; the default value for this parameter is 0.
bColumnPressed | TRUE if the column is pressed by the user.

This function is used to draw a triangle image on the header of the column that is sorted. The triangle represents the direction of the sort: ascending or descending. The size of the triangle depends on the rectangle area provided.

Example:

// draw ascendant triangle
CRect rcTriangle;
rcTriangle.CopyRect(rcHeader);
rcTriangle.DeflateRect(40, 5, 5, 5);
DrawTriangle(pDC, rcTriangle, TRUE);

// draw descendant triangle
CRect rcTriangle;
rcTriangle.CopyRect(rcHeader);
rcTriangle.DeflateRect(40, 5, 5, 5);
DrawTriangle(pDC, rcTriangle, FALSE);

Reimplemented in CXTPGridThemeExplorer, CXTPGridThemeOffice2013, CXTPGridThemeResource, and CXTPTrackThemeOffice2013.

◆ DrawVerticalLine()

void DrawVerticalLine | ( | CDC * | pDC,
 |  | int | xPos,
 |  | int | yPos,
 |  | int | cy,
 |  | COLORREF | clr )

Draws a vertical line.

Parameters
pDC | Pointer to the used device context.
xPos | Horizontal coordinate of the beginning of the line.
yPos | Vertical coordinate of the beginning of the line.
cy | Length of the line.
clr | Color of the line.

This member function is called anywhere in the control where a simple vertical line must be drawn.

◆ DrawVerticalTimeLineMarker()

virtual void DrawVerticalTimeLineMarker | ( | CDC * | pDC,
 |  | int | xPos,
 |  | CXTPGridControl * | pControl,
 |  | COLORREF | color = RGB(0, 255, 0) )
 virtual

Draws a vertical timeline marker.

Parameters
pDC | Pointer to the used device context.
xPos | The x- coordinate where the vertical timeline marker will be drawn.
pControl | Pointer to a Grid control.
color | Color of the marker.

◆ EnablePreviewMode()

AFX_INLINE void EnablePreviewMode ( BOOL bIsPreviewMode )

Enables/disables preview mode for the control.

Parameters
bIsPreviewMode TRUE to enable preview mode, FALSE to disable preview mode.

Preview mode has two states: enabled and disabled. When preview is enabled, the control tries to show additional bands with preview text.

Example:

// enable preview mode
EnablePreviewMode(TRUE);

// disable preview mode
EnablePreviewMode(FALSE);

◆ FillFooter()

virtual void FillFooter | ( | CDC * | pDC,
 |  | CRect | rcFooter )
 virtual

Fills a column footer control area by its background.

Parameters
pDC | Pointer to the used device context.
rcFooter | Footer area rectangle coordinates.

Reimplemented in CXTPGridThemeOffice2003Luna, CXTPGridThemeResource, CXTPTrackThemeOffice2003Luna, and CXTPTrackThemeResource.

◆ FillGroupByControl()

virtual void FillGroupByControl | ( | CDC * | pDC,
 |  | CRect & | rcGroupBy )
 virtual

Draws the Group By box.

Parameters
pDC | Pointer to the used device context.
rcGroupBy | Reference to Group By box area rectangle coordinates.

Example:

CXTPGridPaintManager* pPaintManager = m_pControl->GetPaintManager();
pPaintManager->FillGroupByControl(pDC, rcGroupBy);

◆ FillGroupRowMetrics()

virtual void FillGroupRowMetrics | ( | CXTPGridGroupRow * | pRow,
 |  | XTP_GRIDRECORDITEM_METRICS * | pMetrics,
 |  | BOOL | bPrinting )
 virtual

Fills the font and color members of the metrics structure for a specified group row.

Parameters
pRow | Pointer to the group row.
pMetrics | Pointer to the metrics structure to be filled.
bPrinting | TRUE if printing mode is enabled.

Reimplemented in CXTPGridThemeOffice2013, and CXTPTrackThemeOffice2013.

◆ FillHeaderControl()

virtual void FillHeaderControl | ( | CDC * | pDC,
 |  | CRect | rcHeader )
 virtual

Fills a column header control area by its background.

Parameters
pDC | Pointer to the used device context.
rcHeader | Header area rectangle coordinates.

Example:

CXTPGridPaintManager* pPaintManager = m_pControl->GetPaintManager();
CRect rcHeader(rcClient);
int nHeaderHeight = m_pControl->GetHeaderHeight();
rcHeader.bottom = rcHeader.top + nHeaderHeight;
pPaintManager->FillHeaderControl(pDC, rcHeader);

◆ FillIndent()

virtual void FillIndent | ( | CDC * | pDC,
 |  | CRect | rcRow )
 virtual

Fills an indent area by its background.

Parameters
pDC | Pointer to the used device context.
rcRow | Row area rectangle coordinates.

Example:

CXTPGridPaintManager* pPaintManager = m_pControl->GetPaintManager();
CRect rcRow(rcClient);
// Get default row height
int nRowHeight = m_pControl->GetRowHeight(FALSE)
rcRow.bottom = rcRow.top + nRowHeight;
pPaintManager->FillIndent(pDC, rcRow);

◆ FillItemShade()

virtual void FillItemShade | ( | CDC * | pDC,
 |  | CRect | rcItem )
 virtual

Fills an item shade by its background if necessary.

Parameters
pDC | Pointer to the used device context.
rcItem | Item area rectangle coordinates.

Example:

CXTPGridPaintManager* pPaintManager = m_pControl->GetPaintManager();
CRect rcItem(m_rcRow);
pPaintManager->FillItemShade(pDC, rcItem);

◆ FillRow()

virtual void FillRow | ( | CDC * | pDC,
 |  | CXTPGridRow * | pRow,
 |  | CRect | rcRow )
 virtual

Fills a specified row with its background color.

Parameters
pDC | Pointer to the used device context.
pRow | Pointer to the row.
rcRow | Row area rectangle coordinates.

Example:

// paint row background
pPaintManager->FillRow(pDC, this, rcRow);

◆ FindRowAdjacentToMerged()

int FindRowAdjacentToMerged | ( | const CXTPGridColumns * | pColumns,
 |  | const CXTPGridRow * | pRow,
 |  | BOOL | bUpward )

Wrapper for the FindRowAdjacentToMergedEx method.

Searches the topmost or bottommost row depending on the height of the current row.

Parameters
pColumns | Pointer to a CXTPGridColumns object.
pRow | Pointer to a CXTPGridRow object.
bUpward | TRUE to set the search direction upward from the current row, FALSE to set the search direction downward.
Returns
The index of the adjacent row.

◆ FindRowAdjacentToMergedEx()

BOOL FindRowAdjacentToMergedEx | ( | const CXTPGridColumns * | pColumns,
 |  | const CXTPGridRow * | pRow,
 |  | int & | nAdjRowIndex,
 |  | BOOL | bUpward )

Searches the topmost or bottommost row depending on the height of the current row.

The height of rows depends on merged cells which can contain big text or other content.

Parameters
pColumns | Pointer to a CXTPGridColumns object.
pRow | Pointer to a CXTPGridRow object.
bUpward | TRUE to set the search direction upward from the current row,
nAdjRowIndex | Adjust row index value. FALSE to set the search direction downward.
Returns
TRUE if successful, otherwise FALSE.

◆ GetColumnOffice2007CustomThemeBaseColor()

AFX_INLINE COLORREF GetColumnOffice2007CustomThemeBaseColor ( ) const

Gets the header's custom theme base color for Office2007 column style.

Returns
The custom theme base color for Office2007 column style. A value of -1 means that the standard theme is used.
See also
SetColumnOffice2007CustomThemeBaseColor

◆ GetColumnStyle()

AFX_INLINE XTPGridColumnStyle GetColumnStyle ( ) const

Gets the header style.

Returns
The header style; one of the values defined by the XTPGridColumnStyle enumeration.
See also
SetColumnStyle, XTPGridColumnStyle

◆ GetControlBackColor()

virtual COLORREF GetControlBackColor ( CXTPGridControl * pControl )
virtual

Retrieves the parent Grid control's background color.

Parameters
pControl Pointer to the parent Grid control object.
Returns
The color used to fill the parent Grid control's client rectangle.

◆ GetFooterHeight()

virtual int GetFooterHeight | ( | CXTPGridControl * | pControl,
 |  | CDC * | pDC,
 |  | int | nTotalWidth = 0 )
 virtual

Calculates the optimal footer height.

Parameters
pControl | Pointer to a Grid control.
pDC | Pointer to the used device context.
nTotalWidth | Total footer width; used only for printing.
Returns
The optimal footer height.

◆ GetFreezeColsDividerStyle()

AFX_INLINE int GetFreezeColsDividerStyle ( ) const

Gets the style of the freeze columns divider line.

Returns
The style of the freeze columns divider line, one of the values defined by the XTPGridFreezeColsDividerStyle enumeration.
See also
XTPGridFreezeColsDividerStyle

◆ GetGlyphs()

AFX_INLINE CXTPImageManager * GetGlyphs ( ) const

Gets a pointer to the additional image list with glyphs.

The additional image list is usually used for bitmaps of collapsed icons, etc. You call this member function to get a pointer to the additional image list and manipulate its contents as you wish.

Returns
A pointer to the additional imahe list with glyphs.

◆ GetHeaderHeight() [1/2]

AFX_INLINE int GetHeaderHeight ( )
virtual

Gets the column header height.

Returns
The current height of the rectangle where the column's headers are drawn.

◆ GetHeaderHeight() [2/2]

virtual int GetHeaderHeight | ( | CXTPGridControl * | pControl,
 |  | CDC * | pDC,
 |  | int | nTotalWidth = 0 )
 virtual

Calculates the optimal header height.

Parameters
pControl | Pointer to a Grid control.
pDC | Pointer to the used device context.
nTotalWidth | Total header width; used only for printing.
Returns
The optimal header height.

◆ GetItemHeight()

int GetItemHeight | ( | XTP_GRIDRECORDITEM_DRAWARGS & | drawArgs,
 |  | int | nWidth )

Retrieves the height of a record item for a given width.

Parameters
drawArgs | Draws arguments.
nWidth | Width of the rectangle where the item will be drawn.
Returns
The height of the record item for the given width.

◆ GetMaxPreviewLines()

AFX_INLINE int GetMaxPreviewLines ( )

Gets the maximum number of lines of text for a preview item.

Returns
The maximum number of lines of text for a preview item.

◆ GetPreviewItemHeight()

virtual int GetPreviewItemHeight | ( | CDC * | pDC,
 |  | CXTPGridRow * | pRow,
 |  | int | nWidth,
 |  | int | nHeight )
 virtual

Retrieves the height of a preview item for print mode.

Parameters
pDC | Pointer to the used device context.
pRow | Pointer to a CXTPGridRow object.
nWidth | Width of the preview item.
nHeight | Height of the preview item.
Returns
The height of the default rectangle where the preview item will be drawn.

Example:

int nPreviewItemHeight = GetPreviewItemHeight(pDC, pRow, nWidth, nHeight)

◆ GetPreviewLinesCount()

int GetPreviewLinesCount | ( | CDC * | pDC,
 |  | CRect & | rcText,
 |  | const CString & | strText )

Calculates the number of lines required to draw a specified preview text string, taking into account the maximum number of lines of text for a preview item.

Parameters
pDC | Pointer to the used device context.
rcText | Reference to text area rectangle coordinates.
strText | Reference to the preview text string.

This function calculates the number of lines required to draw the specified preview text string based on the length of the preview text string, the preview text font, and the width of the provided rectangle. If the calculated number of lines is greater than the maximum number of lines of text for a preview item, then the maximum number of lines of text for a preview item will be returned instead.

Returns
If the calculated number of lines required to draw the preview text string is greater than the maximum number of lines of text for a preview item, then the maximum number of lines of text for a preview item will be returned. Otherwise, the calculated number of lines will be returned.

◆ GetRowHeight() [1/2]

virtual int GetRowHeight | ( | CDC * | pDC,
 |  | CXTPGridRow * | pRow )
 virtual

Retrieves the default row height for print mode (i.e.

the height of the default rectangle where the row's items will be drawn).

Parameters
pDC | Pointer to the used device context.
pRow | Pointer to a grid row.
Returns
The default row height for print mode.

Example:

int nRowHeight = GetRowHeight(pDC, pRow)

Reimplemented in CXTPGridThemeOffice2013, and CXTPTrackThemeOffice2013.

◆ GetRowHeight() [2/2]

virtual int GetRowHeight | ( | CDC * | pDC,
 |  | CXTPGridRow * | pRow,
 |  | int | nTotalWidth )
 virtual

Retrieves the default row height for print mode (i.e.

the height of the default rectangle where the row's items will be drawn).

Parameters
pDC | Pointer to the used device context.
pRow | Pointer to a grid row.
nTotalWidth | Width of the row.
Returns
The default row height for print mode.

Example:

int nRowHeight = GetRowHeight(pDC, pRow)

Reimplemented in CXTPGridThemeOffice2013.

◆ GetRowHeightEx()

int GetRowHeightEx | ( | CDC * | pDC,
 |  | CXTPGridRow * | pRow,
 |  | int | nTotalWidth,
 |  | const BOOL | firstLevel = TRUE )

Retrieves the default row height for print mode (i.e.

the height of the default rectangle where the row's items will be drawn).

Parameters
pDC | Pointer to the used device context.
pRow | Pointer to a grid row.
nTotalWidth | Width of the row.
firstLevel | Represents the first level.
Returns
The default row height for print mode.

Example:

int nRowHeight = GetRowHeight(pDC, pRow)

◆ GetSectionDividerHeight()

int GetSectionDividerHeight ( XTPGridFixedRowsDividerStyle dividerStyle )

Gets the height of the section divider.

Parameters
dividerStyle Section divider style; must be one of the values defined by the XTPGridFixedRowsDividerStyle enumeration.
Returns
The height of the section divider.
See also
XTPGridFixedRowsDividerStyle

◆ GetTextFont()

AFX_INLINE CFont * GetTextFont ( )

Gets the default text font used for control items.

Returns
The default text font used for control items.

◆ IsColumHotTrackingEnabled()

virtual BOOL IsColumHotTrackingEnabled ( ) const
virtual

Determines if hot tracking is enabled for the current column style.

Returns
TRUE if hot tracking is enabled, otherwise FALSE.

Hot tracking can only be used for the xtpGridColumnOffice2003 and xtpGridColumnExplorer styles.

See also
m_columnStyle, m_bHotTracking

Reimplemented in CXTPGridThemeExplorer, CXTPGridThemeOffice2003Luna, CXTPTrackThemeExplorer, and CXTPTrackThemeOffice2003Luna.

◆ IsColumnPlusMinusSign()

AFX_INLINE BOOL IsColumnPlusMinusSign ( ) const

Determines if columns use expand/collapse icons (+/-) or directional arrows.

Returns
TRUE if columns use expand/collapse icons (+/-), FALSE if columns use directional arrows.

◆ IsColumnWidthWYSIWYG()

AFX_INLINE BOOL IsColumnWidthWYSIWYG ( ) const

Determines if the paint manager supports column width WYSIWYG mode.

Returns
TRUE if the paint manager supports column width WYSIWYG mode, otherwise FALSE.

◆ IsDrawGridForEmptySpace()

AFX_INLINE BOOL IsDrawGridForEmptySpace ( ) const

Determines if the grid fills empty space after body rows.

By default, the grid does not fill empty space after body rows.

Returns
TRUE if the grid fills empty space after body rows, otherwise FALSE.

◆ IsFixedInplaceButtonHeight()

AFX_INLINE BOOL IsFixedInplaceButtonHeight ( ) const

Determines if the paint manager supports fixed or variable in-place button height.

Returns
TRUE if the paint manager supports fixed in-place button height, FALSE if the paint manager supports variable in-place button height.
See also
SetInplaceButtonHeight

◆ IsFixedRowHeight()

AFX_INLINE BOOL IsFixedRowHeight ( ) const

Determines if the paint manager supports fixed or variable row height.

Returns
TRUE if the paint manager supports fixed row height, FALSE if the paint manager supports variable row height.
See also
GetRowHeight

◆ IsGridVisible() [1/2]

BOOL IsGridVisible ( BOOL bVertical ) const

Determines the visibility of specified grid lines.

Parameters
bVertical Determines the grid lines to be tested; TRUE to test vertical grid lines, FALSE to test horizontal grid lines.
Returns
TRUE if the tested grid lines are visible, otherwise FALSE.

◆ IsGridVisible() [2/2]

BOOL IsGridVisible ( XTPGridOrientation orientation ) const

Determines the visibility of specified grid lines.

Parameters
orientation Determines the grid lines to be tested. must be one of the values defined by the XTPGridOrientation enumeration.
Returns
TRUE if the tested grid lines are visible, otherwise FALSE.

◆ IsLastColumnWidthWYSIWYG()

AFX_INLINE BOOL IsLastColumnWidthWYSIWYG ( ) const

Determines if the paint manager supports last column width WYSIWYG mode.

Returns
TRUE if the paint manager supports last column width WYSIWYG mode, otherwise FALSE.

◆ IsPreviewMode()

AFX_INLINE BOOL IsPreviewMode ( ) const

Determines if preview mode is enabled/disabled for the control.

Returns
TRUE if preview mode is enabled, FALSE if preview mode is disabled.

◆ IsPrintGroupRowIcon()

AFX_INLINE BOOL IsPrintGroupRowIcon ( ) const

Determines if the group row collapse-expand icon is drawn in print mode.

Returns
TRUE if the group row collapse-expand icon is drawn in print mode, otherwise FALSE.

◆ IsShowWYSIWYGMarkers()

AFX_INLINE BOOL IsShowWYSIWYGMarkers ( ) const

Determines if the paint manager shows WYSIWYG page-end markers.

Returns
TRUE if the paint manager shows WYSIWYG page-end markers, otherwise FALSE.

◆ IsUseDropMarker()

AFX_INLINE BOOL IsUseDropMarker ( ) const

Determines if a drop marker will be used when dragging and dropping.

Returns
TRUE if a drop marker will be used when dragging and dropping, FALSE if no markers will be used.

◆ OnDrawAction()

virtual BOOL OnDrawAction ( XTP_GRIDRECORDITEM_DRAWARGS * pDrawArgs )
virtual

Override this method to perform custom activities for the item before processing it.

Parameters
pDrawArgs Pointer to an XTP_GRIDRECORDITEM_DRAWARGS structure containing drawing arguments.
Returns
TRUE if the item requires further processing.

◆ RecalcTotalHightOfMergedRows()

int RecalcTotalHightOfMergedRows | ( | CXTPGridColumns * | pColumns,
 |  | CDC * | pDC,
 |  | CXTPGridRow * | pRow,
 |  | int | nRowHeight,
 |  | int | nTotalWidth )

Recalculates row height according to the height of merged items.

Parameters
pColumns | Pointer to a CXTPGridColumns object.
pDC | Pointer to the used device context.
pRow | Pointer to a CXTPGridRow object.
nRowHeight | Height of pRow without merge cells.
nTotalWidth | Width of the row for print mode.
Returns
The height of the default rectangle where the row's items will be drawn.

◆ RefreshMetrics()

virtual void RefreshMetrics ( )
virtual

Initializes all drawings defaults (fonts, colors, etc.).

Most of them are system defaults.

See also
CXTPGridPaintManager

Reimplemented in CXTPGridThemeNativeWindows10, CXTPGridThemeNativeWindows11, CXTPGridThemeOffice2003Luna, CXTPGridThemeOffice2013, CXTPGridThemeResource, CXTPGridThemeVisualStudio2012Blue, CXTPGridThemeVisualStudio2012Dark, CXTPGridThemeVisualStudio2012Light, CXTPGridThemeVisualStudio2015, CXTPGridThemeVisualStudio2017, CXTPGridThemeVisualStudio2019, CXTPGridThemeVisualStudio2022, CXTPTrackPaintManager, CXTPTrackThemeNativeWindows10, CXTPTrackThemeNativeWindows11, CXTPTrackThemeOffice2003Luna, CXTPTrackThemeOffice2013, CXTPTrackThemeResource, CXTPTrackThemeVisualStudio2012Blue, CXTPTrackThemeVisualStudio2012Dark, CXTPTrackThemeVisualStudio2012Light, CXTPTrackThemeVisualStudio2015, CXTPTrackThemeVisualStudio2017, CXTPTrackThemeVisualStudio2019, and CXTPTrackThemeVisualStudio2022.

◆ SetCaptionFont()

void SetCaptionFont ( LOGFONT & lf )

Creates and sets the default caption font.

Parameters
lf Reference to a LOGFONT structure.
See also
LOGFONT, SetTextFont

◆ SetColumnOffice2007CustomThemeBaseColor()

AFX_INLINE void SetColumnOffice2007CustomThemeBaseColor ( COLORREF clrBaseColor )

Sets the header's custom theme base color for Office2007 column style.

Parameters
clrBaseColor Custom theme base color for Office2007 column style. Set this value to -1 to use the standard theme.
See also
GetColumnOffice2007CustomThemeBaseColor

◆ SetColumnPlusMinusSign()

AFX_INLINE void SetColumnPlusMinusSign ( BOOL bDraw )

Specifies if columns use expand/collapse icons (+/-) or directional arrows.

Parameters
bDraw TRUE to set columns to use expand/collapse icons (+/-), FALSE to set columns to use directional arrows.

◆ SetColumnStyle()

void SetColumnStyle ( XTPGridColumnStyle columnStyle )

Sets the header style.

Parameters
columnStyle Header style to be set; must be one of the values defined by the XTPGridColumnStyle enumeration.
See also
GetColumnStyle, XTPGridColumnStyle

◆ SetColumnWidthWYSIWYG()

AFX_INLINE void SetColumnWidthWYSIWYG ( BOOL bColumnWidthWYSIWYG )

Sets if the paint manager supports column width WYSIWYG mode.

Parameters
bColumnWidthWYSIWYG TRUE to set column width WYSIWYG mode, FALSE otherwise.

◆ SetDrawGridForEmptySpace()

AFX_INLINE void SetDrawGridForEmptySpace ( BOOL bDrawGrid )

Sets if the grid fills empty space after body rows.

Parameters
bDrawGrid TRUE to set the grid to fill empty space after body rows, FALSE otherwise.

◆ SetFixedRowHeight()

void SetFixedRowHeight ( BOOL bFixedRowHeight )

Sets if the paint manager supports fixed or variable row height.

Parameters
bFixedRowHeight TRUE to set fixed row height, FALSE to set variable row height.
See also
GetRowHeight

◆ SetFreezeColsDividerStyle()

AFX_INLINE void SetFreezeColsDividerStyle ( int nStyle )

Sets the style for the freeze columns divider line.

Parameters
nStyle Style for the freeze columns divider line; must be one of the values defined by the XTPGridFreezeColsDividerStyle enumeration.
See also
XTPGridFreezeColsDividerStyle

◆ SetGridControl()

AFX_INLINE void SetGridControl ( CXTPGridControl * pControl )
virtual

Sets the associated Grid control for the paint manager.

Parameters
pControl Pointer to the Grid control to set.

◆ SetHeaderHeight()

virtual void SetHeaderHeight ( int nHeight )
virtual

Sets the column header height.

Parameters
nHeight Header height to be set.

◆ SetInplaceButtonHeight()

AFX_INLINE void SetInplaceButtonHeight ( BOOL bFixedInplaceButtonHeight )

Sets if the paint manager supports fixed or variable in-place button height.

Parameters
bFixedInplaceButtonHeight TRUE to set fixed in-place button height, FALSE to set variable in-place button height.
See also
IsFixedInplaceButtonHeight

◆ SetLastColumnWidthWYSIWYG()

AFX_INLINE void SetLastColumnWidthWYSIWYG ( BOOL bColumnWidthWYSIWYG )

Sets if the paint manager supports last column width WYSIWYG mode.

Parameters
bColumnWidthWYSIWYG TRUE to set last column width WYSIWYG mode, FALSE otherwise.

◆ SetMaxPreviewLines()

AFX_INLINE int SetMaxPreviewLines ( int nMaxLines )

Sets the maximum number of lines of text for a preview item.

Parameters
nMaxLines New maximum number of lines of text for a preview item.

You use this member function to bound the height of a textPreview item by setting the maximum rows of text for it.

Returns
The previous maximum number of lines of text for a preview item.

Example:

int nOldMaxLines = SetMaxPreviewLines(4);

◆ SetPreviewIndent()

void SetPreviewIndent | ( | int | nLeft,
 |  | int | nTop,
 |  | int | nRight,
 |  | int | nBottom )

Sets the preview item indent.

Parameters
nLeft | Left indent to be set.
nTop | Top indent to be set.
nRight | Right indent to be set.
nBottom | Bottom indent to be set.

◆ SetPrintGroupRowIcon()

AFX_INLINE void SetPrintGroupRowIcon ( BOOL bDraw )

Sets if the group row collapse-expand icon is drawn in print mode.

Parameters
bDraw TRUE to set the group row collapse-expand icon to be drawn in print mode, FALSE otherwise.

◆ SetTextFont()

void SetTextFont ( LOGFONT & lf )

Creates and sets the default text font.

Parameters
lf Reference to a LOGFONT structure.
See also
LOGFONT, SetCaptionFont

◆ ShowWYSIWYGMarkers()

AFX_INLINE void ShowWYSIWYGMarkers ( BOOL bSet )

Sets if the paint manager shows WYSIWYG page-end markers.

Parameters
bSet TRUE to show WYSIWYG page-end markers, FALSE otherwise.

Member Data Documentation

◆ m_bForceShowDropMarker

BOOL m_bForceShowDropMarker

TRUE if Force Show Drop Marker.

used to support external (OLE) drag and drop handler and take care of drop marker line drawing and auto-scrolling.

◆ m_nGridLineStylePreviousH

XTPGridGridStyle m_nGridLineStylePreviousH
protected

Previous style for horizontal grid lines.

Used for update brush.

◆ m_nGridLineStylePreviousV

XTPGridGridStyle m_nGridLineStylePreviousV
protected

Previous style for vertical grid lines.

Used for update brush.

The documentation for this class was generated from the following file:
  • XTPGridPaintManager.h


Toolkit Pro: CXTPGridRecord Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPGridRecord Class Reference

CXTPGridRecord represents a collection of CXTPGridRecordItem objects or objects of classes that are children of CXTPGridRecordItem. More...

Inheritance diagram for CXTPGridRecord:
[legend]

Public Member Functions

CXTPGridRecord ()
Constructs a CXTPGridRecord object.
virtual | ~CXTPGridRecord ()
Destroys a CXTPGridRecord object, handles cleanup and deallocation.
int | GetItemCount () const
Gets the number of items inside the record.
CXTPGridRecordItem * | GetItem (int nIndex) const
Retrieves a record item by its index/column.
CXTPGridRecordItem * | GetItem (CXTPGridColumn *pColumn) const
Retrieves a record item by its index/column.
CXTPGridRecordItemPreview * | GetItemPreview () const
Gets the associated preview item of the record.
void | SetPreviewItem (CXTPGridRecordItemPreview *pItemPreview)
Sets the associated preview item for the record.
BOOL | IsVisible () const
Gets the visible state of the record.
void | SetVisible (BOOL bVisible)
Sets the visible state for the record.
BOOL | IsLocked () const
Gets the locked state of the record.
void | SetLocked (BOOL bLocked)
Sets the locked state for the record.
BOOL | IsEditable () const
Gets the editable state of the record.
void | SetEditable (BOOL bEditable=TRUE)
Sets the editable state for the record.
CXTPGridRecords * GetChilds ()
Gets the list of child items of the record.
CXTPGridRecords * | GetRecords () const
Gets the list of parent items of the record.
BOOL | HasChildren () const
Determines if the record has child records.
void | RemoveAll ()
Removes all items from the record.
int | IndexOf (const CXTPGridRecordItem *pItem) const
Gets the index of a specified record item object.
virtual void | GetItemMetrics (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pItemMetrics)
Calculates item metrics based on specified draw arguments.
virtual BOOL | UpdateRecordField (int row, int index, CString sText)
Updates DataSet in VirtualMode without involving _RecordsetPtr.
BOOL | IsExpanded () const
Gets the expanded state of the record.
virtual void | SetExpanded (BOOL bExpanded)
Sets the expanded state for the record.
virtual BOOL | IsFiltered () const
Determines if the record is filtered.
int | GetIndex () const
Gets the record index in the array.
CXTPGridRecordItem * | AddItem (CXTPGridRecordItem *pItem)
Adds a record item to the internal records item collection.
virtual void | DoPropExchange (CXTPPropExchange *pPX)
Call this member function to store/load a grid record with record items using the specified data object.
void | Delete ()
Removes the record.
void | TreeAddRef ()
Increments the reference counter of a record and all of its children.
void | TreeRelease ()
Decrements the reference counter of a record and all of its children.
void | SetBookmark (VARIANT vtBookmark)
Sets the bookmark for the data source record.
VARIANT | GetBookmark () const
Gets the bookmark to the data source record.
CXTPMarkupContext * | GetMarkupContext () const
Gets the markup context.
CXTPGridRecord * | GetParentRecord () const
Gets the parent record.
int | GetFreeHeight ()
Gets the height of rows in FreeHeight RC mode.
void | SetFreeHeight (int nFreeHeight)
Sets the height for rows in FreeHeight RC mode.
- Public Member Functions inherited from CXTPHeapObjectT< CXTPCmdTarget, CXTPGridDataAllocator >
void *PASCAL | operator new (size_t nSize)
Allocate memory block of nSize bytes.
void PASCAL | operator delete (void *p)
Free memory block previously allocated by operator new.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Attributes

CArray< CXTPGridRecordItem *, CXTPGridRecordItem * > | m_arrItems
An internal storage for record items.
CXTPGridRecordItemPreview * | m_pPreviewItem
Preview item for record.
CXTPGridControl * | m_pControl
Pointer to the parent Grid control.
CXTPGridRecords * | m_pRecords
Parent records collection.
CXTPGridRecords * | m_pChildren
A collection of children records.
BOOL | m_bExpanded
TRUE if the record is expanded, FALSE otherwise.
BOOL | m_bEditable
TRUE if the record is editable, FALSE otherwise.
BOOL | m_bVisible
TRUE if the record is visible, FALSE otherwise.
BOOL | m_bLocked
TRUE if the record is locked, FALSE otherwise.
BOOL | m_bSelected
TRUE if the record is selected, FALSE otherwise.
int | m_nFreeHeight
Height of a visual row in FreeHeight RC mode.
int | m_nIndex
Index of the record within the collection records.
VARIANT | m_vtBookmark
Bookmark to data source record for data binding.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

CXTPGridRecord represents a collection of CXTPGridRecordItem objects or objects of classes that are children of CXTPGridRecordItem.

A collection of such items is one record in a GridControl list. You create an object of CXTPGridRecord by simply calling its constructor. After calling its constructor, you can add items to the record.

Example:

// add new record to the record list
CXTPGridRecords* pList = new CXTPGridRecords();
pList->Add(new CXTPGridRecord());

Member Function Documentation

◆ AddItem()

CXTPGridRecordItem * AddItem ( CXTPGridRecordItem * pItem )

Adds a record item to the internal records item collection.

Parameters
pItem Pointer to the record item to add.
Returns
A pointer to the newly added record item.

◆ DoPropExchange()

virtual void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Call this member function to store/load a grid record with record items using the specified data object.

Parameters
pPX Source/destination CXTPPropExchange data object reference.

◆ GetBookmark()

AFX_INLINE VARIANT GetBookmark ( ) const

Gets the bookmark to the data source record.

Returns
The bookmark to the data source record.

◆ GetChilds()

CXTPGridRecords * GetChilds ( )

Gets the list of child items of the record.

A grid record can have a list of child items. This method is used to get a pointer to that list.

Returns
A pointer to the list of child items of the record.

◆ GetFreeHeight()

AFX_INLINE int GetFreeHeight ( )

Gets the height of rows in FreeHeight RC mode.

Returns
The height of rows in FreeHeight RC mode.

◆ GetIndex()

int GetIndex ( ) const

Gets the record index in the array.

Returns
The record index in the array.

◆ GetItem() [1/2]

CXTPGridRecordItem * GetItem ( CXTPGridColumn * pColumn ) const

Retrieves a record item by its index/column.

Parameters
pColumn Pointer to the column of the record item.

You use this member function to get a record item from the collection by its index. If the provided index is less than 0 or greater than the value returned by GetItemCount, then GetItem will return NULL.

Returns
A pointer to the record item if successful, otherwise NULL.
See also
GetItemCount

◆ GetItem() [2/2]

AFX_INLINE CXTPGridRecordItem * GetItem ( int nIndex ) const

Retrieves a record item by its index/column.

Parameters
nIndex Zero-based index of the record item in the collection.

You use this member function to get a record item from the collection by its index. If the provided index is less than 0 or greater than the value returned by GetItemCount, then GetItem will return NULL.

Returns
A pointer to the record item if successful, otherwise NULL.
See also
GetItemCount

◆ GetItemCount()

AFX_INLINE int GetItemCount ( ) const

Gets the number of items inside the record.

Returns
The number of items inside the record.
See also
GetItem

◆ GetItemMetrics()

AFX_INLINE void GetItemMetrics | ( | XTP_GRIDRECORDITEM_DRAWARGS * | pDrawArgs,
 |  | XTP_GRIDRECORDITEM_METRICS * | pItemMetrics )
 virtual

Calculates item metrics based on specified draw arguments.

Can be overridden by descendants.

Parameters
pDrawArgs | Pointer to an XTP_GRIDRECORDITEM_DRAWARGS structure used to calculate item metrics.
pItemMetrics | Pointer to an XTP_GRIDRECORDITEM_METRICS structure to fill with values.

◆ GetItemPreview()

CXTPGridRecordItemPreview * GetItemPreview ( ) const

Gets the associated preview item of the record.

Preview items are stored separately from all other items. A record can have only one preview item. If a GridRecord does not have a preview item, then GetItemPreview() will return NULL.

Returns
The associated preview item if successful, otherwise NULL.
See also
SetPreviewItem

◆ GetMarkupContext()

CXTPMarkupContext * GetMarkupContext ( ) const

Gets the markup context.

Returns
A pointer to the markup context.

◆ GetParentRecord()

CXTPGridRecord * GetParentRecord ( ) const

Gets the parent record.

Returns
A pointer to the parent record.

◆ GetRecords()

AFX_INLINE CXTPGridRecords * GetRecords ( ) const

Gets the list of parent items of the record.

Returns
A pointer to the list of parent items of the record.

◆ HasChildren()

BOOL HasChildren ( ) const

Determines if the record has child records.

Returns
TRUE if the record has child records, otherwise FALSE.
See also
GetChilds

◆ IndexOf()

int IndexOf ( const CXTPGridRecordItem * pItem ) const

Gets the index of a specified record item object.

Parameters
pItem Pointer to the record item whose index must be retrieved.
Returns
The zero-based index of the specified record item if successful, otherwise a value of -1.

◆ IsEditable()

AFX_INLINE BOOL IsEditable ( ) const

Gets the editable state of the record.

Returns
TRUE if the record is editable, otherwise FALSE.
See also
SetEditable

◆ IsExpanded()

AFX_INLINE BOOL IsExpanded ( ) const

Gets the expanded state of the record.

If the expanded state is set to TRUE, then the control will attempt to draw the record with all of its children.

Returns
TRUE if the record is expanded, otherwise FALSE.
See also
SetExpanded

◆ IsFiltered()

virtual BOOL IsFiltered ( ) const
virtual

Determines if the record is filtered.

Returns
TRUE if the record is filtered, otherwise FALSE.

◆ IsLocked()

AFX_INLINE BOOL IsLocked ( ) const

Gets the locked state of the record.

Returns
TRUE if the record is locked, FALSE if the record is unlocked.
See also
SetLocked

◆ IsVisible()

AFX_INLINE BOOL IsVisible ( ) const

Gets the visible state of the record.

Returns
TRUE if the record is visible, FALSE if the record is hidden.
See also
SetVisible

◆ SetBookmark()

AFX_INLINE void SetBookmark ( VARIANT vtBookmark )

Sets the bookmark for the data source record.

Parameters
vtBookmark Bookmark to be set.

◆ SetEditable()

void SetEditable ( BOOL bEditable = TRUE )

Sets the editable state for the record.

Parameters
bEditable TRUE to set the record to editable, FALSE otherwise.

◆ SetExpanded()

virtual void SetExpanded ( BOOL bExpanded )
virtual

Sets the expanded state for the record.

Parameters
bExpanded TRUE to set the record state to expanded.

If the expanded state is set to TRUE, then the control will attempt to draw the record with all of its children.

See also
IsExpanded

◆ SetFreeHeight()

AFX_INLINE void SetFreeHeight ( int nFreeHeight )

Sets the height for rows in FreeHeight RC mode.

Parameters
nFreeHeight Height to be set.

◆ SetLocked()

AFX_INLINE void SetLocked ( BOOL bLocked )

Sets the locked state for the record.

Parameters
bLocked TRUE to set the record to locked, FALSE to set the record to unlocked.

You should set the record to locked when the record should not be sorted on hide.

See also
IsLocked

◆ SetPreviewItem()

void SetPreviewItem ( CXTPGridRecordItemPreview * pItemPreview )

Sets the associated preview item for the record.

Parameters
pItemPreview Pointer to the preview item to set.

Preview items are stored separately from all other items. A record can have only one preview item.

See also
GetItemPreview

◆ SetVisible()

AFX_INLINE void SetVisible ( BOOL bVisible )

Sets the visible state for the record.

Parameters
bVisible TRUE to set the record to visible, FALSE to set the record to hidden.
See also
IsVisible

◆ UpdateRecordField()

AFX_INLINE BOOL UpdateRecordField | ( | int | row,
 |  | int | index,
 |  | CString | sText )
 virtual

Updates DataSet in VirtualMode without involving _RecordsetPtr.

Can be overridden by descendants.

Parameters
row | Row.
index | Index.
sText | Value as a string.
Returns
TRUE if successful.
The documentation for this class was generated from the following file:
  • XTPGridRecord.h


Toolkit Pro: CXTPGridRecordItem Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPGridRecordItem Class Reference

Class for working with single list cell. More...

Inheritance diagram for CXTPGridRecordItem:
[legend]

Public Member Functions

CXTPGridRecordItem ()
CXTPGridRecordItem default constructor.
virtual | ~CXTPGridRecordItem ()
CXTPGridRecordItem default destructor.
virtual int | Draw (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs)
Should be overridden by descendants for drawing itself.
virtual void | OnDrawCaption (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics)
Should be overridden by descendants for drawing itself.
virtual void | OnDrawControls (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CRect &rcItem)
Should be overridden by descendants for drawing itself.
CXTPGridRecordItemControl * | HitTest (CPoint ptPoint)
Determines which grid record item control, if any, is at a specified point.
virtual int | HitTestHyperlink (CPoint ptClick)
Determines if a mouse click occurred on a hyperlink.
virtual BOOL | OnLButtonDown (XTP_GRIDRECORDITEM_CLICKARGS *pClickArgs)
Processes mouse left button down clicks.
virtual BOOL | OnLButtonUp (XTP_GRIDRECORDITEM_CLICKARGS *pClickArgs)
Processes mouse left button up clicks.
virtual void | OnClick (XTP_GRIDRECORDITEM_CLICKARGS *pClickArgs)
Processes single mouse clicks.
virtual void | OnDblClick (XTP_GRIDRECORDITEM_CLICKARGS *pClickArgs)
Processes double mouse clicks.
virtual void | OnMouseMove (UINT nFlags, CPoint point, CXTPGridControl *pControl=NULL)
Processes the move mouse event.
virtual CString | GetCaption ()
Gets the text caption of the item.
CString | GetColumnCaptionPrefix (CXTPGridColumn *pColumn) const
Gets the caption prefix of a specified column.
virtual CString | GetCaption (CXTPGridColumn *pColumn)
Retrieves the text caption of the record item.
virtual void | GetCaptionRect (XTP_GRIDRECORDITEM_ARGS *pDrawArgs, CRect &rcItem)
Retrieves the caption text bounding rectangle.
virtual CString | GetGroupCaption (CXTPGridColumn *pColumn)
Gets the group caption text.
virtual COleVariant | GetGroupCaptionValue (CXTPGridColumn *pColumn)
Gets the group caption native value.
virtual int | GetGroupCaptionID (CXTPGridColumn *pColumn)
Gets the group caption ID.
virtual int | CompareGroupCaption (CXTPGridColumn *pColumn, CXTPGridRecordItem *pItem)
Compares the group caption of the current record item with the group caption of a provided record item/group row.
virtual int | CompareGroupCaption (CXTPGridColumn *pColumn, CXTPGridGroupRow *pGroupRow)
Compares the group caption of the current record item with the group caption of a provided record item/group row.
virtual int | Compare (CXTPGridColumn *pColumn, CXTPGridRecordItem *pItem)
Compares the current record item with a provided record item.
virtual void | SetFont (CFont *pFont)
Sets the record item text font.
virtual CFont * | GetFont ()
Gets the record item text font.
virtual CString | GetTooltip () const
Gets the tooltip text of the record item.
virtual void | SetTooltip (LPCTSTR lpszTooltip)
Sets the tooltip text for the record item.
virtual void | SetTextColor (COLORREF clrText)
Sets the record item text color.
virtual COLORREF | GetTextColor ()
Gets the record item text color.
virtual void | SetBold (BOOL bBold=TRUE)
Sets the bold state of the record item font.
virtual BOOL | IsBold () const
Determines the bold state of the record item font.
virtual void | SetBackgroundColor (COLORREF clrBackground)
Sets the record item text background color.
virtual COLORREF | GetBackgroundColor ()
Gets the record item text background color.
virtual CString | GetFormula () const
Gets the record item formula.
virtual void | SetFormula (LPCTSTR sFormula)
Sets the record item formula.
virtual CString | GetFormatString () const
Gets the record item caption format string.
virtual void | SetFormatString (LPCTSTR strFormat)
Sets the record item caption format string.
virtual BOOL | IsEditable () const
Determines the editable state of the record item.
virtual BOOL | SetEditable (BOOL bEditable=TRUE)
Sets the editable state for the record item.
virtual int | AddHyperlink (CXTPGridHyperlink *pHyperlink)
Adds a new hyperlink to the record item.
virtual int | GetHyperlinksCount () const
Gets the number of hyperlinks in the record item.
virtual CXTPGridHyperlink * | GetHyperlinkAt (int nHyperlink) const
Retrieves the hyperlink at a specified index.
virtual void | RemoveHyperlinkAt (int nHyperlink)
Removes the hyperlink at a specified index.
virtual void | GetItemMetrics (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pItemMetrics)
Calculates preview item metrics based on specified draw arguments.
virtual BOOL | IsPreviewItem () const
Determines if the record item is a preview item.
int | GetIndex () const
Gets the index of the record item.
virtual int | GetIconIndex () const
Gets the ID of the associated resource bitmap.
virtual int | SetIconIndex (int nIconIndex)
Sets the ID for the associated resource bitmap.
int | GetAlignment () const
Gets the alignment value of the record item.
int | SetAlignment (int nAlignment)
Sets the alignment value for the record item.
virtual int | GetSortPriority () const
Gets the sort priority of the record item.
virtual void | SetSortPriority (int nSortPriority)
Sets the sort priority for the record item.
virtual int | GetGroupPriority () const
Gets the group priority of the record item.
virtual void | SetGroupPriority (int nGroupPriority)
Sets the group priority for the record item.
virtual void | SetGroupCaption (LPCTSTR strCaption)
Sets the group caption for the record item.
virtual void | SetCaption (LPCTSTR strCaption)
Sets the caption for the record item.
void | UpdateValue ()
Causes formula computed value to be updated.
virtual void | SetChecked (BOOL bChecked)
Sets if the record item is checked.
virtual BOOL | IsChecked () const
Determines if the record item is checked.
void | SetCheckedState (int iState)
Sets the checked state for the record item.
int | GetCheckedState () const
Gets the checked state of the record item.
virtual void | HasCheckbox (BOOL bHasCheckbox, BOOL bTristate=FALSE)
Adds check box area for item.
virtual BOOL | GetHasCheckbox () const
Determines if item has check box area.
BOOL | GetCanEditCheckboxItem () const
Returns whether items with a check box will go into edit mode on click.
void | SetCanEditCheckboxItem (BOOL bSet)
Specifies whether items with a check box will go into edit mode on click.
void | SetRecord (CXTPGridRecord *pGridRecord)
Sets the parent record object.
CXTPGridRecord * | GetRecord () const
Gets the parent record object.
virtual DWORD_PTR | GetItemData () const
Retrieves the application-supplied, 32-bit value associated with the record item.
virtual void | SetItemData (DWORD_PTR dwData)
Sets the 32-bit value associated with the record item.
virtual BOOL | IsFocusable () const
Determines if the record item can receive focus.
virtual void | SetFocusable (BOOL bFocusable)
Specifies if the record item can receive focus.
virtual void | DoPropExchange (CXTPPropExchange *pPX)
Call this member function to store/load a grid record item using the specified data object.
CXTPMarkupUIElement * | GetMarkupUIElement () const
Gets the Markup element that renders the item.
virtual void | ResetMarkupUIElement ()
Resets the Markup element.
virtual INT_PTR | OnToolHitTest (CPoint point, TOOLINFO *pTI)
The framework calls this member function to determine whether a point is in the bounding rectangle of the specified tool.
BOOL | IsChildOfMerge () const
Determines if the current item is in a merge group and, if so, if it is not the left-top (main) item of the group.
virtual void | OnCancelEdit (CXTPGridControl *pControl, BOOL bApply)
This method is called when the user cancels editing an item.
virtual void | OnValidateEdit (XTP_GRIDRECORDITEM_ARGS *pItemArgs)
This method is called to save the value from an in-place edit.
virtual void | OnEditChanged (XTP_GRIDRECORDITEM_ARGS *pItemArgs, LPCTSTR szText)
This method is called when the value of the in-place edit control is changed.
virtual BOOL | OnEditChanging (XTP_GRIDRECORDITEM_ARGS *pItemArgs, CString &rstrNewText)
This method is called before the value of the in-place editor is changed by the user.
virtual void | OnEditCanceled (XTP_GRIDRECORDITEM_ARGS *pItemArgs)
This method is called when in-place editing has been canceled and the value has not changed.
virtual void | OnConstraintChanged (XTP_GRIDRECORDITEM_ARGS *pItemArgs, CXTPGridRecordItemConstraint *pConstraint)
This method is called when the value of the selected contraint of the in-place list is changed by the user.
virtual DWORD | GetSelectedConstraintData (XTP_GRIDRECORDITEM_ARGS *pItemArgs)
Gets the value associated with a selected constraint.
virtual void | OnInplaceButtonDown (CXTPGridInplaceButton *pButton)
This method is called when the user presses the in-place button of the item.
CXTPGridRecordItemEditOptions * | GetEditOptions (CXTPGridColumn *pColumn)
Gets the edit options of the item.
CXTPGridRecordItemControls * GetItemControls ()
Gets the item controls list.
BOOL | CreateBorder ()
Creates a border for this item.
BOOL | DestroyBorder ()
Destroys the border of this item.
CXTPGridBorder * | GetBorder () const
Gets the border of this item.
void | SetGridControl (CXTPGridControl *pControl)
Sets the parent grid object.
- Public Member Functions inherited from CXTPHeapObjectT< CXTPCmdTarget, CXTPGridDataAllocator >
void *PASCAL | operator new (size_t nSize)
Allocate memory block of nSize bytes.
void PASCAL | operator delete (void *p)
Free memory block previously allocated by operator new.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

virtual void | DrawCheckBox (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CRect &rcItem)
Draws the check box bitmap.
CXTPGridHyperlinks * GetHyperlinks ()
Gets the hyperlinks collection.
virtual BOOL | OnRequestEdit (XTP_GRIDRECORDITEM_ARGS *pItemArgs)
This method is called when an editable item enters edit mode.
virtual void | OnBeginEdit (XTP_GRIDRECORDITEM_ARGS *pItemArgs)
This method is called when the user begins to edit an item.
virtual BOOL | OnChar (XTP_GRIDRECORDITEM_ARGS *pItemArgs, UINT nChar)
This method is called when the user presses a key.

Protected Attributes

CXTPGridControl * | m_pControl
Parent Grid control.
CXTPGridRecord * | m_pRecord
Pointer to the associated record.
CXTPGridBorder * | m_pBorder
Item border.
CFont * | m_pFontCaption
Storage for item caption font.
COLORREF | m_clrText
Storage for item text color.
COLORREF | m_clrBackground
Storage for item background color.
BOOL | m_bBoldText
TRUE if bold text.
CString | m_strFormatString
Stores string for extra formatting of item caption.
CString | m_strFormula
Stores Formula with simple algorithm to calculate.
BOOL | m_bEditable
Stores editable flag.
CXTPGridHyperlinks * | m_pHyperlinks
Array of the Item's hyperlinks.
int | m_nIconIndex
ID of the bitmap from the application resources.
int | m_nSortPriority
Sort priority.
int | m_nGroupPriority
Group priority.
CString | m_strGroupCaption
Caption of the group.
CString | m_strCaption
Caption of the item.
BOOL | m_bFocusable
TRUE if item accept focus.
int | m_checkState
TRUE if item checked.
BOOL | m_bHasCheckbox
TRUE if item has check box.
BOOL | m_bCanEditCheckboxItem
TRUE if an item with a check box will get an edit control (only useful if column is wide)
BOOL | m_bTristateCheckbox
TRUE if the check box is tri-state.
DWORD_PTR | m_dwData
The 32-bit value associated with the item.
CString | m_strTooltip
Tooltip of the item.
CXTPGridRecordItemEditOptions * | m_pEditOptions
Edit options of the item.
XTPGridColumnIconAlignment | m_Alignment
Alignment style for item.
CXTPGridRecordItemControls * | m_pItemControls
Record item control list.
CXTPGridRecordItemControl * | m_pFocusedItemControl
Focused record item control.
BOOL | m_bItemControlUnderMouse
TRUE if an item control is under the mouse pointer.
CXTPGridRecordItemControlHookWnd * | m_pItemControlHookWnd
Item control hook window.
CRect | m_rcGlyph
Coordinates of drawn glyph.
CXTPMarkupUIElement * | m_pMarkupUIElement
Markup element.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

Class for working with single list cell.

Base class for extended list cells. It determines the behavior of all specific record items. You don't use its class directly in the control. If you wish to add your own Record Item to the control, you must inherit it from CXTPGridRecordItem. Most member functions in this class are virtual.

See also
CXTPGridRecordItemDateTime, CXTPGridRecordItemNumber, CXTPGridRecordItemPreview, CXTPGridRecordItemText, CXTPGridRecordItemVariant

Member Function Documentation

◆ AddHyperlink()

virtual int AddHyperlink ( CXTPGridHyperlink * pHyperlink )
virtual

Adds a new hyperlink to the record item.

Parameters
pHyperlink Pointer to the hyperlink to add.

Each record item can have a number of hyperlinks. To add a new hyperlink to the record item, you must first create the new instance of hyperlink class.

Returns
The zero-based ID of the newly added hyperlink.

Example:

AddHyperlink(new CXTPGridHyperlink(27, 7);
See also
CXTPGridHyperlink.

◆ Compare()

virtual int Compare | ( | CXTPGridColumn * | pColumn,
 |  | CXTPGridRecordItem * | pItem )
 virtual

Compares the current record item with a provided record item.

Provides default behavior for descendants.

Parameters
pColumn | Pointer to the corresponding column of the current record item.
pItem | Pointer to the record item to compare with the current record item.
Returns
Zero if the current record item is equal to pItem; Less than zero if the current record item is less than pItem; Greater than zero if the current record item is greater than pItem.

Reimplemented in CXTPGridRecordItemDateTime, CXTPGridRecordItemNumber, and CXTPGridRecordItemVariant.

◆ CompareGroupCaption() [1/2]

virtual int CompareGroupCaption | ( | CXTPGridColumn * | pColumn,
 |  | CXTPGridGroupRow * | pGroupRow )
 virtual

Compares the group caption of the current record item with the group caption of a provided record item/group row.

Parameters
pColumn | Pointer to the corresponding column of the current record item.
pGroupRow | Pointer to the group row with the group caption to compare with the group caption of the current record item.
Returns
Zero if the group caption of the current record item is identical to the group caption of pItem/pGroupRow; Less than zero if the group caption of the current record item is less than the group caption of pItem/pGroupRow; Greater than zero if the group caption of the current record item is greater than the group caption of pItem/pGroupRow.

Reimplemented in CXTPGridRecordItemDateTime, CXTPGridRecordItemNumber, and CXTPGridRecordItemVariant.

◆ CompareGroupCaption() [2/2]

virtual int CompareGroupCaption | ( | CXTPGridColumn * | pColumn,
 |  | CXTPGridRecordItem * | pItem )
 virtual

Compares the group caption of the current record item with the group caption of a provided record item/group row.

Parameters
pColumn | Pointer to the corresponding column of the current record item.
pItem | Pointer to the record item with the group caption to compare with the group caption of the current record item.
Returns
Zero if the group caption of the current record item is identical to the group caption of pItem/pGroupRow; Less than zero if the group caption of the current record item is less than the group caption of pItem/pGroupRow; Greater than zero if the group caption of the current record item is greater than the group caption of pItem/pGroupRow.

Reimplemented in CXTPGridRecordItemDateTime, CXTPGridRecordItemNumber, and CXTPGridRecordItemVariant.

◆ CreateBorder()

BOOL CreateBorder ( )

Creates a border for this item.

Returns
TRUE if successful; otherwise FALSE.

◆ DestroyBorder()

BOOL DestroyBorder ( )

Destroys the border of this item.

Returns
TRUE if successful; otherwise FALSE.

◆ DoPropExchange()

virtual void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Call this member function to store/load a grid record item using the specified data object.

Parameters
pPX Source/destination CXTPPropExchange data object reference.

Reimplemented in CXTPGridRecordItemDateTime, CXTPGridRecordItemNumber, CXTPGridRecordItemPreview, CXTPGridRecordItemText, CXTPGridRecordItemVariant, and CXTPTrackControlItem.

◆ Draw()

virtual int Draw ( XTP_GRIDRECORDITEM_DRAWARGS * pDrawArgs )
virtual

Should be overridden by descendants for drawing itself.

Parameters
pDrawArgs Pointer to an XTP_GRIDRECORDITEM_DRAWARGS structure containing drawing arguments.
Returns
The text width of the record item.

This function simply prepares and calls the necessary drawing functions from PaintManager to draw a grid item. As such, you must provide your own implementation of PaintManager in order to change the appearance of your grid item.

Example:

// fill structure
XTP_GRIDRECORDITEM_DRAWARGS drawArgs;
drawArgs.pDC = pDC;
drawArgs.pControl = m_pControl;
drawArgs.pRow = this;
// call function
Draw(&drawArgs);
See also
XTP_GRIDRECORDITEM_DRAWARGS

Reimplemented in CXTPTrackControlItem.

◆ DrawCheckBox()

virtual void DrawCheckBox | ( | XTP_GRIDRECORDITEM_DRAWARGS * | pDrawArgs,
 |  | CRect & | rcItem )
 protectedvirtual

Draws the check box bitmap.

Parameters
pDrawArgs | Pointer to an XTP_GRIDRECORDITEM_DRAWARGS structure containing drawing arguments.
rcItem | Item area rectangle coordinates.

◆ GetAlignment()

AFX_INLINE int GetAlignment ( ) const

Gets the alignment value of the record item.

Returns
The alignment value of the record item; one of the values defined by the XTPGridColumnIconAlignment enumeration.

◆ GetBackgroundColor()

virtual COLORREF GetBackgroundColor ( )
virtual

Gets the record item text background color.

Returns
The record item text background color.

◆ GetBorder()

CXTPGridBorder * GetBorder ( ) const

Gets the border of this item.

Returns
A pointer to the border of this item.

◆ GetCanEditCheckboxItem()

BOOL GetCanEditCheckboxItem ( ) const

Returns whether items with a check box will go into edit mode on click.

Returns
TRUE if items with a check box will go into edit mode on click.

◆ GetCaption() [1/2]

virtual CString GetCaption ( )
virtual

Gets the text caption of the item.

Can be overridden by descendants.

Returns
The text caption of the item, or an empty string for a base record item class.

Reimplemented in CXTPGridRecordItemDateTime, CXTPGridRecordItemNumber, CXTPGridRecordItemPreview, CXTPGridRecordItemText, CXTPGridRecordItemVariant, and CXTPTrackControlItem.

◆ GetCaption() [2/2]

virtual CString GetCaption ( CXTPGridColumn * pColumn )
virtual

Retrieves the text caption of the record item.

Parameters
pColumn Pointer to the corresponding column of the record item.

Can be overridden by descendants.

Returns
The text caption of the record item, or an empty string for a base record item class.

Reimplemented in CXTPGridRecordItemDateTime, CXTPGridRecordItemNumber, CXTPGridRecordItemPreview, CXTPGridRecordItemText, CXTPGridRecordItemVariant, and CXTPTrackControlItem.

◆ GetCaptionRect()

virtual void GetCaptionRect | ( | XTP_GRIDRECORDITEM_ARGS * | pDrawArgs,
 |  | CRect & | rcItem )
 virtual

Retrieves the caption text bounding rectangle.

Parameters
pDrawArgs | Pointer to an XTP_GRIDRECORDITEM_DRAWARGS structure containing drawing arguments.
rcItem | Reference to a CRect object that receives the caption text bounding rectangle.

Reimplemented in CXTPGridRecordItemPreview.

◆ GetCheckedState()

AFX_INLINE int GetCheckedState ( ) const

Gets the checked state of the record item.

Returns
An integer value denoting the state of the check box; one of the values defined by the XTPGridCheckState enumeration.
See also
SetChecked, HasCheckbox

◆ GetColumnCaptionPrefix()

CString GetColumnCaptionPrefix ( CXTPGridColumn * pColumn ) const

Gets the caption prefix of a specified column.

Parameters
pColumn Pointer to a CXTPGridColumn object.
Returns
The caption prefix of the specified column.

◆ GetEditOptions()

CXTPGridRecordItemEditOptions * GetEditOptions ( CXTPGridColumn * pColumn )

Gets the edit options of the item.

Parameters
pColumn Pointer to the corresponding column of the item.
Returns
A pointer to the CXTPGridRecordItemEditOptions object.

◆ GetFont()

virtual CFont * GetFont ( )
virtual

Gets the record item text font.

Returns
A pointer to the record item text font.

◆ GetFormatString()

AFX_INLINE CString GetFormatString ( ) const
virtual

Gets the record item caption format string.

Returns
The record item caption format string.

◆ GetFormula()

AFX_INLINE CString GetFormula ( ) const
virtual

Gets the record item formula.

Returns
The record item formula.

◆ GetGroupCaption()

virtual CString GetGroupCaption ( CXTPGridColumn * pColumn )
virtual

Gets the group caption text.

Parameters
pColumn Pointer to a CXTPGridColumn object.
Returns
The group caption text.

◆ GetGroupCaptionID()

virtual int GetGroupCaptionID ( CXTPGridColumn * pColumn )
virtual

Gets the group caption ID.

Parameters
pColumn Pointer to a CXTPGridColumn object.
Returns
The group caption ID.

◆ GetGroupCaptionValue()

virtual COleVariant GetGroupCaptionValue ( CXTPGridColumn * pColumn )
virtual

Gets the group caption native value.

Parameters
pColumn Pointer to a CXTPGridColumn object.
Returns
The group caption native value.

Reimplemented in CXTPGridRecordItemDateTime, CXTPGridRecordItemNumber, and CXTPGridRecordItemVariant.

◆ GetGroupPriority()

AFX_INLINE int GetGroupPriority ( ) const
virtual

Gets the group priority of the record item.

Returns
The group priority of the record item.
See also
GetSortPriority, SetSortPriority, SetGroupPriority, GetGroupPriority

◆ GetHasCheckbox()

AFX_INLINE BOOL GetHasCheckbox ( ) const
virtual

Determines if item has check box area.

Returns
TRUE if item has check box; otherwise FALSE
See also
SetChecked, IsChecked

◆ GetHyperlinkAt()

virtual CXTPGridHyperlink * GetHyperlinkAt ( int nHyperlink ) const
virtual

Retrieves the hyperlink at a specified index.

Parameters
nHyperlink Zero-based index of the hyperlink to retrieve.

To process a hyperlink, you get a pointer to it by calling GetHyperlinkAt();

Returns
A pointer to the hyperlink at the specified index.

Example:

int nHyperlinks = GetHyperlinksCount();
CXTPGridHyperlink* pHyperlink;
for(int nHyperlink = 0; nHyperlink < nHyperlinks; nHyperlink++)
{
   pHyperlink = GetHyperlinkAt(nHyperlink);
   // YOUR PROCESSING HERE
   // ...
   //
}
See also
CXTPGridHyperlink.

◆ GetHyperlinks()

CXTPGridHyperlinks * GetHyperlinks ( )
protected

Gets the hyperlinks collection.

Returns
A pointer to a CXTPGridHyperlinks object.

◆ GetHyperlinksCount()

virtual int GetHyperlinksCount ( ) const
virtual

Gets the number of hyperlinks in the record item.

Each record item can have a number of hyperlinks. To process all of the hyperlinks of a record item, you must get the number of hyperlinks in the record item by using the GetHyperlinksCount() member function.

Returns
The number of hyperlinks in the record item.

◆ GetIconIndex()

AFX_INLINE int GetIconIndex ( ) const
virtual

Gets the ID of the associated resource bitmap.

Returns
The ID of the associated resource bitmap.

◆ GetIndex()

int GetIndex ( ) const

Gets the index of the record item.

Returns
The index of the record item.

◆ GetItemControls()

CXTPGridRecordItemControls * GetItemControls ( )

Gets the item controls list.

Returns
A pointer to the CXTPGridRecordItemControls object.

◆ GetItemData()

AFX_INLINE DWORD_PTR GetItemData ( ) const
virtual

Retrieves the application-supplied, 32-bit value associated with the record item.

Returns
The 32-bit value associated with the record item.

◆ GetItemMetrics()

virtual void GetItemMetrics | ( | XTP_GRIDRECORDITEM_DRAWARGS * | pDrawArgs,
 |  | XTP_GRIDRECORDITEM_METRICS * | pItemMetrics )
 virtual

Calculates preview item metrics based on specified draw arguments.

Can be overridden by descendants.

Parameters
pDrawArgs | Pointer to an XTP_GRIDRECORDITEM_DRAWARGS structure used to calculate item metrics.
pItemMetrics | Pointer to an XTP_GRIDRECORDITEM_METRICS structure to fill with values.
See also
XTP_GRIDRECORDITEM_DRAWARGS, XTP_GRIDRECORDITEM_METRICS

Reimplemented in CXTPGridRecordItemPreview.

◆ GetMarkupUIElement()

AFX_INLINE CXTPMarkupUIElement * GetMarkupUIElement ( ) const

Gets the Markup element that renders the item.

Returns
A pointer to the Markup element that renders the item.

◆ GetRecord()

AFX_INLINE CXTPGridRecord * GetRecord ( ) const

Gets the parent record object.

Returns
A pointer to the parent record object.

◆ GetSelectedConstraintData()

AFX_INLINE DWORD GetSelectedConstraintData ( XTP_GRIDRECORDITEM_ARGS * pItemArgs )
virtual

Gets the value associated with a selected constraint.

Parameters
pItemArgs Pointer to an XTP_GRIDRECORDITEM_ARGS structure containing item arguments.
Returns
The value associated with the selected constraint.

Reimplemented in CXTPGridRecordItemVariant.

◆ GetSortPriority()

AFX_INLINE int GetSortPriority ( ) const
virtual

Gets the sort priority of the record item.

Returns
The sort priority of the record item.
See also
GetSortPriority, SetSortPriority, SetGroupPriority, GetGroupPriority

◆ GetTextColor()

virtual COLORREF GetTextColor ( )
virtual

Gets the record item text color.

Returns
The record item text color.

◆ GetTooltip()

AFX_INLINE CString GetTooltip ( ) const
virtual

Gets the tooltip text of the record item.

Returns
The tooltip text of the record item

◆ HasCheckbox()

AFX_INLINE void HasCheckbox | ( | BOOL | bHasCheckbox,
 |  | BOOL | bTristate = FALSE )
 virtual

Adds check box area for item.

Parameters
bHasCheckbox | TRUE if item has check box area.
bTristate | TRUE is tri-state checkbox, FALSE if usual
See also
SetChecked, IsChecked

◆ HitTest()

CXTPGridRecordItemControl * HitTest ( CPoint ptPoint )

Determines which grid record item control, if any, is at a specified point.

Parameters
ptPoint Point to test.

Call this member function to test the item contents at the specified point.

Returns
A pointer to the grid record item control at the specified point, if any, otherwise NULL.

◆ HitTestHyperlink()

virtual int HitTestHyperlink ( CPoint ptClick )
virtual

Determines if a mouse click occurred on a hyperlink.

Parameters
ptClick Point of the mouse click.
Returns
Zero-based index of the clicked link, if any, otherwise a value of -1.

◆ IsBold()

AFX_INLINE BOOL IsBold ( ) const
virtual

Determines the bold state of the record item font.

Returns
TRUE if the record item font is bold, FALSE if the record item font is normal.

◆ IsChecked()

AFX_INLINE BOOL IsChecked ( ) const
virtual

Determines if the record item is checked.

Returns
TRUE if the record item is checked, otherwise FALSE.
See also
SetChecked, HasCheckbox

◆ IsChildOfMerge()

BOOL IsChildOfMerge ( ) const

Determines if the current item is in a merge group and, if so, if it is not the left-top (main) item of the group.

If the current item is in a merge group and is not the left-top (main) item of the group, then the current item receives properties from the main item of the merge group.

Returns
TRUE if the current item is in a merge group and is not the left-top (main) item of the group, otherwise FALSE.

◆ IsEditable()

virtual BOOL IsEditable ( ) const
virtual

Determines the editable state of the record item.

Returns
The editable state of the record item.

◆ IsFocusable()

virtual BOOL IsFocusable ( ) const
virtual

Determines if the record item can receive focus.

Returns
TRUE if the record item can receive focus, otherwise FALSE.

◆ IsPreviewItem()

AFX_INLINE BOOL IsPreviewItem ( ) const
virtual

Determines if the record item is a preview item.

Returns
TRUE if the record item is a preview item, otherwise FALSE.

Reimplemented in CXTPGridRecordItemPreview.

◆ OnBeginEdit()

virtual void OnBeginEdit ( XTP_GRIDRECORDITEM_ARGS * pItemArgs )
protectedvirtual

This method is called when the user begins to edit an item.

Parameters
pItemArgs Pointer to an XTP_GRIDRECORDITEM_ARGS structure containing item arguments.

Reimplemented in CXTPGridRecordItemPreview.

◆ OnCancelEdit()

virtual void OnCancelEdit | ( | CXTPGridControl * | pControl,
 |  | BOOL | bApply )
 virtual

This method is called when the user cancels editing an item.

Parameters
pControl | Pointer to the parent Grid control.
bApply | TRUE to save the value of the in-place edit.

◆ OnChar()

virtual BOOL OnChar | ( | XTP_GRIDRECORDITEM_ARGS * | pItemArgs,
 |  | UINT | nChar )
 protectedvirtual

This method is called when the user presses a key.

Parameters
pItemArgs | Pointer to an XTP_GRIDRECORDITEM_ARGS structure containing item arguments.
nChar | Pressed character code.
Returns
TRUE if the item processed the key.

◆ OnClick()

virtual void OnClick ( XTP_GRIDRECORDITEM_CLICKARGS * pClickArgs )
virtual

Processes single mouse clicks.

Parameters
pClickArgs Pointer to an XTP_GRIDRECORDITEM_CLICKARGS structure containing click arguments.

Usually this function is called by GridRow's OnClick function.

See also
XTP_GRIDRECORDITEM_CLICKARGS

Reimplemented in CXTPTrackControlItem.

◆ OnConstraintChanged()

virtual void OnConstraintChanged | ( | XTP_GRIDRECORDITEM_ARGS * | pItemArgs,
 |  | CXTPGridRecordItemConstraint * | pConstraint )
 virtual

This method is called when the value of the selected contraint of the in-place list is changed by the user.

Parameters
pItemArgs | Pointer to an XTP_GRIDRECORDITEM_ARGS structure containing item arguments.
pConstraint | Pointer to the selected constraint.

Reimplemented in CXTPGridRecordItemVariant.

◆ OnDblClick()

virtual void OnDblClick ( XTP_GRIDRECORDITEM_CLICKARGS * pClickArgs )
virtual

Processes double mouse clicks.

Parameters
pClickArgs Pointer to an XTP_GRIDRECORDITEM_CLICKARGS structure containing click arguments.

Usually this function is called by GridRow's OnDblClick function.

See also
XTP_GRIDRECORDITEM_CLICKARGS

Reimplemented in CXTPTrackControlItem.

◆ OnDrawCaption()

virtual void OnDrawCaption | ( | XTP_GRIDRECORDITEM_DRAWARGS * | pDrawArgs,
 |  | XTP_GRIDRECORDITEM_METRICS * | pMetrics )
 virtual

Should be overridden by descendants for drawing itself.

Parameters
pDrawArgs | Pointer to an XTP_GRIDRECORDITEM_DRAWARGS structure containing drawing arguments.
pMetrics | Pointer to an XTP_GRIDRECORDITEM_METRICS structure containing item metrics.

Reimplemented in CXTPGridRecordItemPercentNumber, and CXTPGridRecordItemPreview.

◆ OnDrawControls()

virtual void OnDrawControls | ( | XTP_GRIDRECORDITEM_DRAWARGS * | pDrawArgs,
 |  | CRect & | rcItem )
 virtual

Should be overridden by descendants for drawing itself.

Parameters
pDrawArgs | Pointer to an XTP_GRIDRECORDITEM_DRAWARGS structure containing drawing arguments.
rcItem | Reference to an item rectangle.

◆ OnEditCanceled()

AFX_INLINE void OnEditCanceled ( XTP_GRIDRECORDITEM_ARGS * pItemArgs )
virtual

This method is called when in-place editing has been canceled and the value has not changed.

Parameters
pItemArgs Pointer to an XTP_GRIDRECORDITEM_ARGS structure containing item arguments.

◆ OnEditChanged()

virtual void OnEditChanged | ( | XTP_GRIDRECORDITEM_ARGS * | pItemArgs,
 |  | LPCTSTR | szText )
 virtual

This method is called when the value of the in-place edit control is changed.

Parameters
pItemArgs | Pointer to an XTP_GRIDRECORDITEM_ARGS structure containing item arguments.
szText | New in-place edit text. virtual void OnEditChanged(XTP_GRIDRECORDITEM_ARGS* pItemArgs, LPCTSTR szText) { UNREFERENCED_PARAMETER(pItemArgs); UNREFERENCED_PARAMETER(szText); }

Reimplemented in CXTPGridRecordItemDateTime, CXTPGridRecordItemNumber, CXTPGridRecordItemPreview, CXTPGridRecordItemText, and CXTPGridRecordItemVariant.

◆ OnEditChanging()

virtual BOOL OnEditChanging | ( | XTP_GRIDRECORDITEM_ARGS * | pItemArgs,
 |  | CString & | rstrNewText )
 virtual

This method is called before the value of the in-place editor is changed by the user.

Parameters
pItemArgs | Pointer to an XTP_GRIDRECORDITEM_ARGS structure containing item arguments.
rstrNewText | New string to be set in the editor.
Returns
FALSE to cancel the edit operation. virtual BOOL OnEditChanging(XTP_GRIDRECORDITEM_ARGS* pItemArgs, CString& rstrNewText) { UNREFERENCED_PARAMETER(pItemArgs); UNREFERENCED_PARAMETER(rstrNewText); return TRUE; }

Reimplemented in CXTPGridRecordItemVariant.

◆ OnInplaceButtonDown()

virtual void OnInplaceButtonDown ( CXTPGridInplaceButton * pButton )
virtual

This method is called when the user presses the in-place button of the item.

Parameters
pButton Pointer to the in-place button of the item.

◆ OnLButtonDown()

virtual BOOL OnLButtonDown ( XTP_GRIDRECORDITEM_CLICKARGS * pClickArgs )
virtual

Processes mouse left button down clicks.

Parameters
pClickArgs Pointer to an XTP_GRIDRECORDITEM_CLICKARGS structure containing click arguments.
Returns
TRUE if the implementation handles the mouse click event and no further handling is required, otherwise FALSE.

Usually this function is called by GridRow's OnLButtonDown function.

See also
XTP_GRIDRECORDITEM_CLICKARGS

Reimplemented in CXTPTrackControlItem.

◆ OnLButtonUp()

virtual BOOL OnLButtonUp ( XTP_GRIDRECORDITEM_CLICKARGS * pClickArgs )
virtual

Processes mouse left button up clicks.

Parameters
pClickArgs Pointer to an XTP_GRIDRECORDITEM_CLICKARGS structure containing click arguments.
Returns
TRUE if the implementation handles the mouse click event and no further handling is required, otherwise FALSE.

Usually this function is called by GridRow's OnLButtonUp function.

See also
XTP_GRIDRECORDITEM_CLICKARGS

Reimplemented in CXTPTrackControlItem.

◆ OnMouseMove()

virtual void OnMouseMove | ( | UINT | nFlags,
 |  | CPoint | point,
 |  | CXTPGridControl * | pControl = NULL )
 virtual

Processes the move mouse event.

Parameters
point | Specifies the x- and y- coordinates of the cursor.
nFlags | Additional flags.
pControl | Pointer to the Grid control.

Usually this function is called by GridRow's OnMouseMove function.

Reimplemented in CXTPTrackControlItem.

◆ OnRequestEdit()

virtual BOOL OnRequestEdit ( XTP_GRIDRECORDITEM_ARGS * pItemArgs )
protectedvirtual

This method is called when an editable item enters edit mode.

Parameters
pItemArgs Pointer to an XTP_GRIDRECORDITEM_ARGS structure.

An item can enter edit mode when the user clicks on it and starts typing, or when a check box item is checked/unchecked.

Returns
TRUE if the edit request was successful, FALSE if the edit request was canceled.

◆ OnToolHitTest()

virtual INT_PTR OnToolHitTest | ( | CPoint | point,
 |  | TOOLINFO * | pTI )
 virtual

The framework calls this member function to determine whether a point is in the bounding rectangle of the specified tool.

Parameters
point | Specifies the x- and y-coordinate of the cursor. These coordinates are always relative to the upper-left corner of the window
pTI | Pointer to a TOOLINFO structure.
Returns
If the tooltip control was found, the window control ID. If the tooltip control was not found, -1.

Reimplemented in CXTPTrackControlItem.

◆ OnValidateEdit()

virtual void OnValidateEdit ( XTP_GRIDRECORDITEM_ARGS * pItemArgs )
virtual

This method is called to save the value from an in-place edit.

Parameters
pItemArgs Pointer to an XTP_GRIDRECORDITEM_ARGS structure containing item arguments.

◆ RemoveHyperlinkAt()

virtual void RemoveHyperlinkAt ( int nHyperlink )
virtual

Removes the hyperlink at a specified index.

Parameters
nHyperlink Zero-based index of the hyperlink to remove.

◆ ResetMarkupUIElement()

virtual void ResetMarkupUIElement ( )
virtual

Resets the Markup element.

See also
GetMarkupUIElement, CXTPGridControl::EnableMarkup

◆ SetAlignment()

AFX_INLINE int SetAlignment ( int nAlignment )

Sets the alignment value for the record item.

Parameters
nAlignment Alignment value to be set; must be one of the values defined by the XTPGridColumnIconAlignment enumeration.
Returns
The previous alignment value of the record item; one of the values defined by the XTPGridColumnIconAlignment enumeration.

◆ SetBackgroundColor()

virtual void SetBackgroundColor ( COLORREF clrBackground )
virtual

Sets the record item text background color.

Parameters
clrBackground Record item text background color to be set.

◆ SetBold()

virtual void SetBold ( BOOL bBold = TRUE )
virtual

Sets the bold state of the record item font.

Parameters
bBold TRUE to set the record item font to bold, FALSE to set the record item font to normal.

◆ SetCanEditCheckboxItem()

void SetCanEditCheckboxItem ( BOOL bSet )

Specifies whether items with a check box will go into edit mode on click.

Parameters
bSet TRUE for items with a check box will go into edit mode on click.

◆ SetCaption()

virtual void SetCaption ( LPCTSTR strCaption )
virtual

Sets the caption for the record item.

Parameters
strCaption Caption to be set.

Reimplemented in CXTPGridRecordItemPreview.

◆ SetChecked()

AFX_INLINE void SetChecked ( BOOL bChecked )
virtual

Sets if the record item is checked.

Parameters
bChecked TRUE if the record item is checked.
See also
IsChecked, HasCheckbox

◆ SetCheckedState()

AFX_INLINE void SetCheckedState ( int iState )

Sets the checked state for the record item.

Parameters
iState Integer value denoting the state of the check box; must be one of the values defined by the XTPGridCheckState enumeration.
See also
SetChecked, HasCheckbox

◆ SetEditable()

AFX_INLINE BOOL SetEditable ( BOOL bEditable = TRUE )
virtual

Sets the editable state for the record item.

Parameters
bEditable TRUE to set the record item to editable, FALSE otherwise.
Returns
The previous editable state of the record item.

◆ SetFocusable()

AFX_INLINE void SetFocusable ( BOOL bFocusable )
virtual

Specifies if the record item can receive focus.

Parameters
bFocusable TRUE to allow the record item to receive focus, FALSE to disallow the record item from receiving focus.

This method specifies if the grid item can receive focus and overrides the CXTPGridControl::FocusSubItems setting which only allows for individual items to receive focus. If FALSE, then the record item cannot be edited and combo/expand buttons will not be displayed.

◆ SetFont()

virtual void SetFont ( CFont * pFont )
virtual

Sets the record item text font.

Parameters
pFont New font to be set.

◆ SetFormatString()

AFX_INLINE void SetFormatString ( LPCTSTR strFormat )
virtual

Sets the record item caption format string.

Parameters
strFormat Record item caption format string to be set.

If the record item caption format string is set, then the caption text will be formatted according to this format string before it is drawn. This is convenient in many cases (e.g. when drawing dates). The format string is C like style; see the sprintf() C function or the CString.Format() member function.

◆ SetFormula()

AFX_INLINE void SetFormula ( LPCTSTR sFormula )
virtual

Sets the record item formula.

Parameters
sFormula Record item formula to be set.

◆ SetGridControl()

AFX_INLINE void SetGridControl ( CXTPGridControl * pControl )

Sets the parent grid object.

Parameters
pControl Pointer to a CXTPGridControl object.

◆ SetGroupCaption()

AFX_INLINE void SetGroupCaption ( LPCTSTR strCaption )
virtual

Sets the group caption for the record item.

Parameters
strCaption Group caption to be set.

◆ SetGroupPriority()

AFX_INLINE void SetGroupPriority ( int nGroupPriority )
virtual

Sets the group priority for the record item.

Parameters
nGroupPriority Group priority to be set.
See also
GetSortPriority, SetSortPriority, SetGroupPriority, GetGroupPriority

◆ SetIconIndex()

AFX_INLINE int SetIconIndex ( int nIconIndex )
virtual

Sets the ID for the associated resource bitmap.

Parameters
nIconIndex ID of the resource bitmap to set.
Returns
The ID of the previous associated resource bitmap.

◆ SetItemData()

AFX_INLINE void SetItemData ( DWORD_PTR dwData )
virtual

Sets the 32-bit value associated with the record item.

Parameters
dwData New value to be set.

◆ SetRecord()

AFX_INLINE void SetRecord ( CXTPGridRecord * pGridRecord )

Sets the parent record object.

Parameters
pGridRecord Pointer to a CXTPGridRecord object.

◆ SetSortPriority()

AFX_INLINE void SetSortPriority ( int nSortPriority )
virtual

Sets the sort priority for the record item.

Parameters
nSortPriority Sort priority to be set.
See also
GetSortPriority, SetSortPriority, SetGroupPriority, GetGroupPriority

◆ SetTextColor()

virtual void SetTextColor ( COLORREF clrText )
virtual

Sets the record item text color.

Parameters
clrText New color to be set.

◆ SetTooltip()

AFX_INLINE void SetTooltip ( LPCTSTR lpszTooltip )
virtual

Sets the tooltip text for the record item.

Parameters
lpszTooltip Tooltip text to be set.
The documentation for this class was generated from the following file:
  • XTPGridRecordItem.h


Toolkit Pro: CXTPGridRecordItemButton Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPGridRecordItemButton Class Reference

This class represents an item button and inherits basic functionality from the CXTPGridRecordItemControl class. More...

Inheritance diagram for CXTPGridRecordItemButton:
[legend]

Public Member Functions

CXTPGridRecordItemButton (LPCTSTR szCaption=_T(""))
Creates an item button.
virtual void | DoPropExchange (CXTPPropExchange *pPX)
Call this member function to store/load a grid item button using the specified data object.
virtual void | OnLButtonDown (XTP_GRIDRECORDITEM_CLICKARGS *pClickArgs)
Processes mouse left button down clicks.
virtual void | OnLButtonUp (XTP_GRIDRECORDITEM_CLICKARGS *pClickArgs)
Processes mouse left button up clicks.
virtual void | OnMouseEnter (UINT nFlags, CPoint point)
Notifies the item control that the mouse cursor has entered the item button's area.
virtual void | OnMouseLeave (UINT nFlags, CPoint point)
Notifies the item control that the mouse cursor has left the item button's area.
virtual void | OnMouseMove (UINT nFlags, CPoint point)
Processes the move mouse event.
- Public Member Functions inherited from CXTPGridRecordItemControl
CXTPGridRecordItemControl (LPCTSTR szCaption=_T(""))
Creates a CXTPGridRecordItemControl object.
virtual | ~CXTPGridRecordItemControl ()
Destroys a CXTPGridRecordItemControl, handles cleanup and deallocation.
CString | GetCaption () const
Gets the item control caption.
void | SetCaption (LPCTSTR szCaption)
Sets the item control caption.
int | GetType () const
Gets the item control type.
int | GetIndex () const
Gets the item control index.
CFont * | GetFont ()
Gets the font of the item control caption.
void | SetFont (CFont *pFont)
Sets the font for the item control caption.
COLORREF | GetCaptionColor () const
Gets the color of the item control caption.
void | SetCaptionColor (COLORREF clrCaption)
Sets the color of the item control caption.
CSize | GetSize () const
Gets the item control size.
void | SetSize (CSize sizeControl)
Sets the item control size.
int | GetWidth () const
Gets the item control width.
void | SetWidth (int nWidth)
Sets the item control width.
int | GetHeight () const
Gets the item control height.
void | SetHeight (int nHeight)
Sets the item control height.
CRect | GetRect () const
Gets the item control rectangle (i.e.
UINT | GetFlags () const
Gets the item control flags.
void | SetFlags (UINT unFlags)
Sets the item control flags.
int | GetAlignment () const
Gets the item control alignment.
void | SetAlignment (int nAlignment)
Sets the item control alignment.
BOOL | GetEnable () const
Determines if the item control is enabled/disabled.
void | SetEnable (BOOL bEnable)
Enables/disables the item control.
int | GetState () const
Gets the item control state.
void | SetState (int nNewState)
Sets the item control state.
void | SetThemed (BOOL bThemed)
Specifies the themed state of the item control.
BOOL | GetThemed () const
Determines the themed state of the item control.
void | SetIconIndex (int nState, int nIconIndex)
Sets the icon index for a specified control state.
int | GetIconIndex (int nState) const
Retrieves the icon index of a specified item control state.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Attributes

int | m_nSavedState
Button state when the mouse cursor leaves the button area.
- Protected Attributes inherited from CXTPGridRecordItemControl
int | m_nType
Control type.
int | m_nIndex
Control index.
CString | m_strCaption
Control caption.
CXTPFont | m_xtpFontCaption
Control caption font.
COLORREF | m_clrCaption
Control caption color.
CSize | m_sizeControl
Control size.
CRect | m_rcControl
Control rectangle.
UINT | m_unFlags
Control flags.
XTPGridItemControlAlignment m_Alignment
Control alignment.
BOOL | m_bEnabled
Control enable flag.
int | m_nState
Control state.
BOOL | m_bThemed
TRUE if control is themed, FALSE otherwise.
CMap< int, int, int, int > | m_mapIcon
Control icon map.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Member Functions inherited from CXTPGridRecordItemControl
void | SetRect (CRect rcControl)
Sets the item control rectangle (i.e.

Detailed Description

This class represents an item button and inherits basic functionality from the CXTPGridRecordItemControl class.

You create an item button simply by calling its constructor with one parameter - a text string.

See also
CXTPGridRecordItemControl

Constructor & Destructor Documentation

◆ CXTPGridRecordItemButton()

CXTPGridRecordItemButton ( LPCTSTR szCaption = _T("") )

Creates an item button.

Parameters
szCaption Button caption.

Member Function Documentation

◆ DoPropExchange()

virtual void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Call this member function to store/load a grid item button using the specified data object.

Parameters
pPX Source/destination CXTPPropExchange data object reference.

Reimplemented from CXTPGridRecordItemControl.

◆ OnLButtonDown()

virtual void OnLButtonDown ( XTP_GRIDRECORDITEM_CLICKARGS * pClickArgs )
virtual

Processes mouse left button down clicks.

Parameters
pClickArgs Pointer to an XTP_GRIDRECORDITEM_CLICKARGS structure containing mouse click arguments.

Usually this function is called by GridRecordItem's OnLButtonDown function.

See also
XTP_GRIDRECORDITEM_CLICKARGS

Reimplemented from CXTPGridRecordItemControl.

◆ OnLButtonUp()

virtual void OnLButtonUp ( XTP_GRIDRECORDITEM_CLICKARGS * pClickArgs )
virtual

Processes mouse left button up clicks.

Parameters
pClickArgs Pointer to an XTP_GRIDRECORDITEM_CLICKARGS structure containing mouse click arguments.

Usually this function is called by GridRecordItem's OnLButtonUp function.

See also
XTP_GRIDRECORDITEM_CLICKARGS

Reimplemented from CXTPGridRecordItemControl.

◆ OnMouseEnter()

virtual void OnMouseEnter | ( | UINT | nFlags,
 |  | CPoint | point )
 virtual

Notifies the item control that the mouse cursor has entered the item button's area.

Parameters
nFlags | Additional flags.
point | Mouse cursor position.

Usually this function is called by GridRecordItem's OnMouseMove function.

Reimplemented from CXTPGridRecordItemControl.

◆ OnMouseLeave()

virtual void OnMouseLeave | ( | UINT | nFlags,
 |  | CPoint | point )
 virtual

Notifies the item control that the mouse cursor has left the item button's area.

Parameters
nFlags | Additional flags.
point | Mouse cursor position.

Usually this function is called by GridRecordItem's OnMouseMove function.

Reimplemented from CXTPGridRecordItemControl.

◆ OnMouseMove()

virtual void OnMouseMove | ( | UINT | nFlags,
 |  | CPoint | point )
 virtual

Processes the move mouse event.

Parameters
nFlags | Additional flags.
point | Mouse cursor position.

Usually this function is called by GridRecordItem's OnMouseMove function.

Reimplemented from CXTPGridRecordItemControl.

The documentation for this class was generated from the following file:
  • XTPGridRecordItemControls.h


Toolkit Pro: CXTPGridRecordItemCheckbox Class Reference

Public Member Functions | List of all members
CXTPGridRecordItemCheckbox Class Reference

This class represents a checkbox-only cell and inherits basic functionality from the CXTPGridRecordItem class. More...

Inheritance diagram for CXTPGridRecordItemCheckbox:
[legend]

Public Member Functions

CXTPGridRecordItemCheckbox (XTPGridCheckState state=xtpGridCheckStateChecked, BOOL bTristateCheckbox=FALSE)
Creates a record checkbox item.
- Public Member Functions inherited from CXTPGridRecordItem
CXTPGridRecordItem ()
CXTPGridRecordItem default constructor.
virtual | ~CXTPGridRecordItem ()
CXTPGridRecordItem default destructor.
virtual int | Draw (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs)
Should be overridden by descendants for drawing itself.
virtual void | OnDrawCaption (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics)
Should be overridden by descendants for drawing itself.
virtual void | OnDrawControls (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CRect &rcItem)
Should be overridden by descendants for drawing itself.
CXTPGridRecordItemControl * | HitTest (CPoint ptPoint)
Determines which grid record item control, if any, is at a specified point.
virtual int | HitTestHyperlink (CPoint ptClick)
Determines if a mouse click occurred on a hyperlink.
virtual BOOL | OnLButtonDown (XTP_GRIDRECORDITEM_CLICKARGS *pClickArgs)
Processes mouse left button down clicks.
virtual BOOL | OnLButtonUp (XTP_GRIDRECORDITEM_CLICKARGS *pClickArgs)
Processes mouse left button up clicks.
virtual void | OnClick (XTP_GRIDRECORDITEM_CLICKARGS *pClickArgs)
Processes single mouse clicks.
virtual void | OnDblClick (XTP_GRIDRECORDITEM_CLICKARGS *pClickArgs)
Processes double mouse clicks.
virtual void | OnMouseMove (UINT nFlags, CPoint point, CXTPGridControl *pControl=NULL)
Processes the move mouse event.
virtual CString | GetCaption ()
Gets the text caption of the item.
CString | GetColumnCaptionPrefix (CXTPGridColumn *pColumn) const
Gets the caption prefix of a specified column.
virtual CString | GetCaption (CXTPGridColumn *pColumn)
Retrieves the text caption of the record item.
virtual void | GetCaptionRect (XTP_GRIDRECORDITEM_ARGS *pDrawArgs, CRect &rcItem)
Retrieves the caption text bounding rectangle.
virtual CString | GetGroupCaption (CXTPGridColumn *pColumn)
Gets the group caption text.
virtual COleVariant | GetGroupCaptionValue (CXTPGridColumn *pColumn)
Gets the group caption native value.
virtual int | GetGroupCaptionID (CXTPGridColumn *pColumn)
Gets the group caption ID.
virtual int | CompareGroupCaption (CXTPGridColumn *pColumn, CXTPGridRecordItem *pItem)
Compares the group caption of the current record item with the group caption of a provided record item/group row.
virtual int | CompareGroupCaption (CXTPGridColumn *pColumn, CXTPGridGroupRow *pGroupRow)
Compares the group caption of the current record item with the group caption of a provided record item/group row.
virtual int | Compare (CXTPGridColumn *pColumn, CXTPGridRecordItem *pItem)
Compares the current record item with a provided record item.
virtual void | SetFont (CFont *pFont)
Sets the record item text font.
virtual CFont * | GetFont ()
Gets the record item text font.
virtual CString | GetTooltip () const
Gets the tooltip text of the record item.
virtual void | SetTooltip (LPCTSTR lpszTooltip)
Sets the tooltip text for the record item.
virtual void | SetTextColor (COLORREF clrText)
Sets the record item text color.
virtual COLORREF | GetTextColor ()
Gets the record item text color.
virtual void | SetBold (BOOL bBold=TRUE)
Sets the bold state of the record item font.
virtual BOOL | IsBold () const
Determines the bold state of the record item font.
virtual void | SetBackgroundColor (COLORREF clrBackground)
Sets the record item text background color.
virtual COLORREF | GetBackgroundColor ()
Gets the record item text background color.
virtual CString | GetFormula () const
Gets the record item formula.
virtual void | SetFormula (LPCTSTR sFormula)
Sets the record item formula.
virtual CString | GetFormatString () const
Gets the record item caption format string.
virtual void | SetFormatString (LPCTSTR strFormat)
Sets the record item caption format string.
virtual BOOL | IsEditable () const
Determines the editable state of the record item.
virtual BOOL | SetEditable (BOOL bEditable=TRUE)
Sets the editable state for the record item.
virtual int | AddHyperlink (CXTPGridHyperlink *pHyperlink)
Adds a new hyperlink to the record item.
virtual int | GetHyperlinksCount () const
Gets the number of hyperlinks in the record item.
virtual CXTPGridHyperlink * | GetHyperlinkAt (int nHyperlink) const
Retrieves the hyperlink at a specified index.
virtual void | RemoveHyperlinkAt (int nHyperlink)
Removes the hyperlink at a specified index.
virtual void | GetItemMetrics (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pItemMetrics)
Calculates preview item metrics based on specified draw arguments.
virtual BOOL | IsPreviewItem () const
Determines if the record item is a preview item.
int | GetIndex () const
Gets the index of the record item.
virtual int | GetIconIndex () const
Gets the ID of the associated resource bitmap.
virtual int | SetIconIndex (int nIconIndex)
Sets the ID for the associated resource bitmap.
int | GetAlignment () const
Gets the alignment value of the record item.
int | SetAlignment (int nAlignment)
Sets the alignment value for the record item.
virtual int | GetSortPriority () const
Gets the sort priority of the record item.
virtual void | SetSortPriority (int nSortPriority)
Sets the sort priority for the record item.
virtual int | GetGroupPriority () const
Gets the group priority of the record item.
virtual void | SetGroupPriority (int nGroupPriority)
Sets the group priority for the record item.
virtual void | SetGroupCaption (LPCTSTR strCaption)
Sets the group caption for the record item.
virtual void | SetCaption (LPCTSTR strCaption)
Sets the caption for the record item.
void | UpdateValue ()
Causes formula computed value to be updated.
virtual void | SetChecked (BOOL bChecked)
Sets if the record item is checked.
virtual BOOL | IsChecked () const
Determines if the record item is checked.
void | SetCheckedState (int iState)
Sets the checked state for the record item.
int | GetCheckedState () const
Gets the checked state of the record item.
virtual void | HasCheckbox (BOOL bHasCheckbox, BOOL bTristate=FALSE)
Adds check box area for item.
virtual BOOL | GetHasCheckbox () const
Determines if item has check box area.
BOOL | GetCanEditCheckboxItem () const
Returns whether items with a check box will go into edit mode on click.
void | SetCanEditCheckboxItem (BOOL bSet)
Specifies whether items with a check box will go into edit mode on click.
void | SetRecord (CXTPGridRecord *pGridRecord)
Sets the parent record object.
CXTPGridRecord * | GetRecord () const
Gets the parent record object.
virtual DWORD_PTR | GetItemData () const
Retrieves the application-supplied, 32-bit value associated with the record item.
virtual void | SetItemData (DWORD_PTR dwData)
Sets the 32-bit value associated with the record item.
virtual BOOL | IsFocusable () const
Determines if the record item can receive focus.
virtual void | SetFocusable (BOOL bFocusable)
Specifies if the record item can receive focus.
virtual void | DoPropExchange (CXTPPropExchange *pPX)
Call this member function to store/load a grid record item using the specified data object.
CXTPMarkupUIElement * | GetMarkupUIElement () const
Gets the Markup element that renders the item.
virtual void | ResetMarkupUIElement ()
Resets the Markup element.
virtual INT_PTR | OnToolHitTest (CPoint point, TOOLINFO *pTI)
The framework calls this member function to determine whether a point is in the bounding rectangle of the specified tool.
BOOL | IsChildOfMerge () const
Determines if the current item is in a merge group and, if so, if it is not the left-top (main) item of the group.
virtual void | OnCancelEdit (CXTPGridControl *pControl, BOOL bApply)
This method is called when the user cancels editing an item.
virtual void | OnValidateEdit (XTP_GRIDRECORDITEM_ARGS *pItemArgs)
This method is called to save the value from an in-place edit.
virtual void | OnEditChanged (XTP_GRIDRECORDITEM_ARGS *pItemArgs, LPCTSTR szText)
This method is called when the value of the in-place edit control is changed.
virtual BOOL | OnEditChanging (XTP_GRIDRECORDITEM_ARGS *pItemArgs, CString &rstrNewText)
This method is called before the value of the in-place editor is changed by the user.
virtual void | OnEditCanceled (XTP_GRIDRECORDITEM_ARGS *pItemArgs)
This method is called when in-place editing has been canceled and the value has not changed.
virtual void | OnConstraintChanged (XTP_GRIDRECORDITEM_ARGS *pItemArgs, CXTPGridRecordItemConstraint *pConstraint)
This method is called when the value of the selected contraint of the in-place list is changed by the user.
virtual DWORD | GetSelectedConstraintData (XTP_GRIDRECORDITEM_ARGS *pItemArgs)
Gets the value associated with a selected constraint.
virtual void | OnInplaceButtonDown (CXTPGridInplaceButton *pButton)
This method is called when the user presses the in-place button of the item.
CXTPGridRecordItemEditOptions * | GetEditOptions (CXTPGridColumn *pColumn)
Gets the edit options of the item.
CXTPGridRecordItemControls * GetItemControls ()
Gets the item controls list.
BOOL | CreateBorder ()
Creates a border for this item.
BOOL | DestroyBorder ()
Destroys the border of this item.
CXTPGridBorder * | GetBorder () const
Gets the border of this item.
void | SetGridControl (CXTPGridControl *pControl)
Sets the parent grid object.
- Public Member Functions inherited from CXTPHeapObjectT< CXTPCmdTarget, CXTPGridDataAllocator >
void *PASCAL | operator new (size_t nSize)
Allocate memory block of nSize bytes.
void PASCAL | operator delete (void *p)
Free memory block previously allocated by operator new.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPGridRecordItem
- Protected Member Functions inherited from CXTPGridRecordItem
virtual void | DrawCheckBox (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CRect &rcItem)
Draws the check box bitmap.
CXTPGridHyperlinks * GetHyperlinks ()
Gets the hyperlinks collection.
virtual BOOL | OnRequestEdit (XTP_GRIDRECORDITEM_ARGS *pItemArgs)
This method is called when an editable item enters edit mode.
virtual void | OnBeginEdit (XTP_GRIDRECORDITEM_ARGS *pItemArgs)
This method is called when the user begins to edit an item.
virtual BOOL | OnChar (XTP_GRIDRECORDITEM_ARGS *pItemArgs, UINT nChar)
This method is called when the user presses a key.
- Protected Attributes inherited from CXTPGridRecordItem
CXTPGridControl * | m_pControl
Parent Grid control.
CXTPGridRecord * | m_pRecord
Pointer to the associated record.
CXTPGridBorder * | m_pBorder
Item border.
CFont * | m_pFontCaption
Storage for item caption font.
COLORREF | m_clrText
Storage for item text color.
COLORREF | m_clrBackground
Storage for item background color.
BOOL | m_bBoldText
TRUE if bold text.
CString | m_strFormatString
Stores string for extra formatting of item caption.
CString | m_strFormula
Stores Formula with simple algorithm to calculate.
BOOL | m_bEditable
Stores editable flag.
CXTPGridHyperlinks * | m_pHyperlinks
Array of the Item's hyperlinks.
int | m_nIconIndex
ID of the bitmap from the application resources.
int | m_nSortPriority
Sort priority.
int | m_nGroupPriority
Group priority.
CString | m_strGroupCaption
Caption of the group.
CString | m_strCaption
Caption of the item.
BOOL | m_bFocusable
TRUE if item accept focus.
int | m_checkState
TRUE if item checked.
BOOL | m_bHasCheckbox
TRUE if item has check box.
BOOL | m_bCanEditCheckboxItem
TRUE if an item with a check box will get an edit control (only useful if column is wide)
BOOL | m_bTristateCheckbox
TRUE if the check box is tri-state.
DWORD_PTR | m_dwData
The 32-bit value associated with the item.
CString | m_strTooltip
Tooltip of the item.
CXTPGridRecordItemEditOptions * | m_pEditOptions
Edit options of the item.
XTPGridColumnIconAlignment | m_Alignment
Alignment style for item.
CXTPGridRecordItemControls * | m_pItemControls
Record item control list.
CXTPGridRecordItemControl * | m_pFocusedItemControl
Focused record item control.
BOOL | m_bItemControlUnderMouse
TRUE if an item control is under the mouse pointer.
CXTPGridRecordItemControlHookWnd * | m_pItemControlHookWnd
Item control hook window.
CRect | m_rcGlyph
Coordinates of drawn glyph.
CXTPMarkupUIElement * | m_pMarkupUIElement
Markup element.

Detailed Description

This class represents a checkbox-only cell and inherits basic functionality from the CXTPGridRecordItem class.

You create a checkbox record item simply by calling a constructor with parameters checkbox checkState and tristate

See also
CXTPGridRecordItem

Constructor & Destructor Documentation

◆ CXTPGridRecordItemCheckbox()

CXTPGridRecordItemCheckbox | ( | XTPGridCheckState | state = xtpGridCheckStateChecked,
 |  | BOOL | bTristateCheckbox = FALSE )

Creates a record checkbox item.

Parameters
state | Checkbox item state to set.
bTristateCheckbox | TRUE for a tri-state style checkbox.
See also
void SetChecked(BOOL bChecked), BOOL IsChecked(), void SetCheckedState(int iState), int GetCheckedState()
The documentation for this class was generated from the following file:
  • XTPGridRecordItemCheckbox.h


Toolkit Pro: CXTPGridRecordItemConstraint Class Reference

Public Member Functions | Public Attributes | Protected Attributes | List of all members
CXTPGridRecordItemConstraint Class Reference

CXTPGridRecordItemConstraint is a CXTPCmdTarget derived class. More...

Inheritance diagram for CXTPGridRecordItemConstraint:
[legend]

Public Member Functions

CXTPGridRecordItemConstraint ()
Constructs a CXTPPropertyGridItemConstraint object.
int GetIndex () const
Retrieve the index of this constraint within the collection of constraints.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Public Attributes

CString | m_strConstraint
Caption text of this constraint.
DWORD_PTR | m_dwData
The 32-bit value associated with the item.

Protected Attributes

int m_nIndex
Index of the constraint.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

CXTPGridRecordItemConstraint is a CXTPCmdTarget derived class.

It represents a single item constraint.

Member Function Documentation

◆ GetIndex()

int GetIndex ( ) const

Retrieve the index of this constraint within the collection of constraints.

Returns
The index of this constraint within the collection of constraints.

Member Data Documentation

◆ m_strConstraint

CString m_strConstraint

Caption text of this constraint.

This is the text displayed for this constraint.

The documentation for this class was generated from the following file:
  • XTPGridRecordItemConstraint.h


Toolkit Pro: CXTPGridRecordItemConstraints Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPGridRecordItemConstraints Class Reference

CXTPGridRecordItemConstraints is a CXTPCmdTarget derived class. More...

Inheritance diagram for CXTPGridRecordItemConstraints:
[legend]

Public Member Functions

CXTPGridRecordItemConstraints ()
Constructs a CXTPGridRecordItemConstraints object.
~CXTPGridRecordItemConstraints ()
Destroys a CXTPPropertyGridItemConstraints object, handles cleanup and deallocation.
int | GetCount () const
Determines the total number of constraints in the list.
void | RemoveAll ()
Removes all constraints from the list of constraints.
CXTPGridRecordItemConstraint * | GetAt (int nIndex) const
Retrieves the constraint at a specified index from the collection of constraints.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Attributes

CArray< CXTPGridRecordItemConstraint *, CXTPGridRecordItemConstraint * > m_arrConstraints
Collection of constraints.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

CXTPGridRecordItemConstraints is a CXTPCmdTarget derived class.

It represents the item constraints collection.

Member Function Documentation

◆ GetAt()

CXTPGridRecordItemConstraint * GetAt ( int nIndex ) const

Retrieves the constraint at a specified index from the collection of constraints.

Parameters
nIndex Index of the constraint to retrieve.
Returns
A pointer to the constraint at the specified index in the collection of constraints.

◆ GetCount()

int GetCount ( ) const

Determines the total number of constraints in the list.

Returns
The total number of constraints added to the GridRecordItem and/or GridColumn.
The documentation for this class was generated from the following file:
  • XTPGridRecordItemConstraint.h


Toolkit Pro: CXTPGridRecordItemControl Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPGridRecordItemControl Class Reference

This class represents a generic item control and handles control's behaviour, common for all derived item controls. More...

Inheritance diagram for CXTPGridRecordItemControl:
[legend]

Public Member Functions

CXTPGridRecordItemControl (LPCTSTR szCaption=_T(""))
Creates a CXTPGridRecordItemControl object.
virtual | ~CXTPGridRecordItemControl ()
Destroys a CXTPGridRecordItemControl, handles cleanup and deallocation.
virtual void | DoPropExchange (CXTPPropExchange *pPX)
Call this member function to store/load a grid item control using the specified data object.
CString | GetCaption () const
Gets the item control caption.
void | SetCaption (LPCTSTR szCaption)
Sets the item control caption.
int | GetType () const
Gets the item control type.
int | GetIndex () const
Gets the item control index.
CFont * | GetFont ()
Gets the font of the item control caption.
void | SetFont (CFont *pFont)
Sets the font for the item control caption.
COLORREF | GetCaptionColor () const
Gets the color of the item control caption.
void | SetCaptionColor (COLORREF clrCaption)
Sets the color of the item control caption.
CSize | GetSize () const
Gets the item control size.
void | SetSize (CSize sizeControl)
Sets the item control size.
int | GetWidth () const
Gets the item control width.
void | SetWidth (int nWidth)
Sets the item control width.
int | GetHeight () const
Gets the item control height.
void | SetHeight (int nHeight)
Sets the item control height.
CRect | GetRect () const
Gets the item control rectangle (i.e.
UINT | GetFlags () const
Gets the item control flags.
void | SetFlags (UINT unFlags)
Sets the item control flags.
int | GetAlignment () const
Gets the item control alignment.
void | SetAlignment (int nAlignment)
Sets the item control alignment.
BOOL | GetEnable () const
Determines if the item control is enabled/disabled.
void | SetEnable (BOOL bEnable)
Enables/disables the item control.
int | GetState () const
Gets the item control state.
void | SetState (int nNewState)
Sets the item control state.
void | SetThemed (BOOL bThemed)
Specifies the themed state of the item control.
BOOL | GetThemed () const
Determines the themed state of the item control.
void | SetIconIndex (int nState, int nIconIndex)
Sets the icon index for a specified control state.
int | GetIconIndex (int nState) const
Retrieves the icon index of a specified item control state.
virtual void | OnLButtonDown (XTP_GRIDRECORDITEM_CLICKARGS *pClickArgs)
Processes mouse left button down clicks.
virtual void | OnLButtonUp (XTP_GRIDRECORDITEM_CLICKARGS *pClickArgs)
Processes mouse left button up clicks.
virtual void | OnMouseEnter (UINT nFlags, CPoint point)
Notifies the item control that the mouse cursor has entered the item control's area.
virtual void | OnMouseLeave (UINT nFlags, CPoint point)
Notifies the item control that the mouse cursor has left the item control's area.
virtual void | OnMouseMove (UINT nFlags, CPoint point)
Processes the move mouse event.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

void SetRect (CRect rcControl)
Sets the item control rectangle (i.e.

Protected Attributes

int | m_nType
Control type.
int | m_nIndex
Control index.
CString | m_strCaption
Control caption.
CXTPFont | m_xtpFontCaption
Control caption font.
COLORREF | m_clrCaption
Control caption color.
CSize | m_sizeControl
Control size.
CRect | m_rcControl
Control rectangle.
UINT | m_unFlags
Control flags.
XTPGridItemControlAlignment m_Alignment
Control alignment.
BOOL | m_bEnabled
Control enable flag.
int | m_nState
Control state.
BOOL | m_bThemed
TRUE if control is themed, FALSE otherwise.
CMap< int, int, int, int > | m_mapIcon
Control icon map.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

This class represents a generic item control and handles control's behaviour, common for all derived item controls.

You cannot use this class directly in the control. If you wish to add your own item control, you must inherit it from CXTPGridRecordItemControl. Some member functions in this class are virtual.

See also
CXTPGridRecordItemButton

Constructor & Destructor Documentation

◆ CXTPGridRecordItemControl()

CXTPGridRecordItemControl ( LPCTSTR szCaption = _T("") )

Creates a CXTPGridRecordItemControl object.

Parameters
szCaption Item control caption.

Member Function Documentation

◆ DoPropExchange()

virtual void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Call this member function to store/load a grid item control using the specified data object.

Parameters
pPX Source/destination CXTPPropExchange data object reference.

Reimplemented in CXTPGridRecordItemButton.

◆ GetAlignment()

AFX_INLINE int GetAlignment ( ) const

Gets the item control alignment.

Returns
The item control alignment.
See also
XTPGridItemControlAlignment, SetAlignment

◆ GetCaption()

AFX_INLINE CString GetCaption ( ) const

Gets the item control caption.

Returns
The item control caption.
See also
SetCaption

◆ GetCaptionColor()

AFX_INLINE COLORREF GetCaptionColor ( ) const

Gets the color of the item control caption.

Returns
The color of the item control caption.
See also
SetCaptionColor

◆ GetEnable()

AFX_INLINE BOOL GetEnable ( ) const

Determines if the item control is enabled/disabled.

Returns
TRUE if the item control is enabled, FALSE if the item control is disabled.
See also
SetEnable

◆ GetFlags()

AFX_INLINE UINT GetFlags ( ) const

Gets the item control flags.

Returns
The item control flags.
See also
SetFlags

◆ GetFont()

CFont * GetFont ( )

Gets the font of the item control caption.

Returns
A pointer to the font of the item control caption.
See also
SetFont

◆ GetHeight()

AFX_INLINE int GetHeight ( ) const

Gets the item control height.

Returns
The item control height.
See also
GetSize, SetSize, GetWidth, SetWidth, SetHeight

◆ GetIconIndex()

int GetIconIndex ( int nState ) const

Retrieves the icon index of a specified item control state.

Parameters
nState Item control state whose icon index must be retrieved.
Returns
The icon index of the specified item control state.
See also
SetIconIndex

◆ GetIndex()

AFX_INLINE int GetIndex ( ) const

Gets the item control index.

Returns
The item control index.

◆ GetRect()

AFX_INLINE CRect GetRect ( ) const

Gets the item control rectangle (i.e.

the rectangle occupied by the item control).

Returns
The item control rectangle.

◆ GetSize()

AFX_INLINE CSize GetSize ( ) const

Gets the item control size.

Returns
The item control size.
See also
SetSize, GetWidth, SetWidth, GetHeight, SetHeight

◆ GetState()

AFX_INLINE int GetState ( ) const

Gets the item control state.

The item control state is control specific.

Returns
The item control state.

◆ GetThemed()

AFX_INLINE BOOL GetThemed ( ) const

Determines the themed state of the item control.

Returns
TRUE if item control is themed, otherwise FALSE.

◆ GetType()

AFX_INLINE int GetType ( ) const

Gets the item control type.

Returns
The item control type.
See also
XTPGridItemControlType

◆ GetWidth()

AFX_INLINE int GetWidth ( ) const

Gets the item control width.

Returns
The item control width.
See also
GetSize, SetSize, SetWidth, GetHeight, SetHeight

◆ OnLButtonDown()

virtual void OnLButtonDown ( XTP_GRIDRECORDITEM_CLICKARGS * pClickArgs )
inlinevirtual

Processes mouse left button down clicks.

Parameters
pClickArgs Pointer to an XTP_GRIDRECORDITEM_CLICKARGS structure containing mouse click arguments.

Usually this function is called by GridRecordItem's OnLButtonDown function.

See also
XTP_GRIDRECORDITEM_CLICKARGS

Reimplemented in CXTPGridRecordItemButton.

◆ OnLButtonUp()

virtual void OnLButtonUp ( XTP_GRIDRECORDITEM_CLICKARGS * pClickArgs )
inlinevirtual

Processes mouse left button up clicks.

Parameters
pClickArgs Pointer to an XTP_GRIDRECORDITEM_CLICKARGS structure containing mouse click arguments.

Usually this function is called by GridRecordItem's OnLButtonUp function.

See also
XTP_GRIDRECORDITEM_CLICKARGS

Reimplemented in CXTPGridRecordItemButton.

◆ OnMouseEnter()

virtual void OnMouseEnter | ( | UINT | nFlags,
 |  | CPoint | point )
 inlinevirtual

Notifies the item control that the mouse cursor has entered the item control's area.

Parameters
nFlags | Additional flags.
point | Mouse cursor position.

Usually this function is called by GridRecordItem's OnMouseMove function.

Reimplemented in CXTPGridRecordItemButton.

◆ OnMouseLeave()

virtual void OnMouseLeave | ( | UINT | nFlags,
 |  | CPoint | point )
 inlinevirtual

Notifies the item control that the mouse cursor has left the item control's area.

Parameters
nFlags | Additional flags.
point | Mouse cursor position.

Usually this function is called by GridRecordItem's OnMouseMove function.

Reimplemented in CXTPGridRecordItemButton.

◆ OnMouseMove()

virtual void OnMouseMove | ( | UINT | nFlags,
 |  | CPoint | point )
 inlinevirtual

Processes the move mouse event.

Parameters
nFlags | Additional flags.
point | Mouse cursor position.

Usually this function is called by GridRecordItem's OnMouseMove function.

Reimplemented in CXTPGridRecordItemButton.

◆ SetAlignment()

AFX_INLINE void SetAlignment ( int nAlignment )

Sets the item control alignment.

Parameters
nAlignment Item control alignment to be set.
See also
XTPGridItemControlAlignment, GetAlignment

◆ SetCaption()

AFX_INLINE void SetCaption ( LPCTSTR szCaption )

Sets the item control caption.

Parameters
szCaption Item control caption to be set.
See also
GetCaption

◆ SetCaptionColor()

AFX_INLINE void SetCaptionColor ( COLORREF clrCaption )

Sets the color of the item control caption.

Parameters
clrCaption New color to be set.
See also
GetCaptionColor

◆ SetEnable()

AFX_INLINE void SetEnable ( BOOL bEnable )

Enables/disables the item control.

Parameters
bEnable TRUE to enable the item control, FALSE to disable the item control.

If the control is disabled, then it is drawn as disabled and will not react to user input.

See also
GetEnable

◆ SetFlags()

AFX_INLINE void SetFlags ( UINT unFlags )

Sets the item control flags.

Parameters
unFlags Item control flags to be set.
See also
GetFlags

◆ SetFont()

void SetFont ( CFont * pFont )

Sets the font for the item control caption.

Parameters
pFont New font to be set.
See also
GetFont

◆ SetHeight()

AFX_INLINE void SetHeight ( int nHeight )

Sets the item control height.

Parameters
nHeight Item control height to be set.

If the height is set to less than 0, then the control height will be the same as the cell height.

See also
GetSize, SetSize, GetWidth, SetWidth, GetHeight

◆ SetIconIndex()

AFX_INLINE void SetIconIndex | ( | int | nState,
 |  | int | nIconIndex )

Sets the icon index for a specified control state.

Parameters
nState | Item control state.
nIconIndex | Icon index for the specified state.

The icon specified for the specified control state is drawn during control drawing. If no icon is specified for a certain state, then the icon for state = 0 is drawn. If no icon specified for any state, then no icon is drawn.

See also
GetIconIndex

◆ SetRect()

AFX_INLINE void SetRect ( CRect rcControl )
protected

Sets the item control rectangle (i.e.

the rectangle occupied by the item control).

Parameters
rcControl Item control rectangle to be set.
See also
GetRect

◆ SetSize()

AFX_INLINE void SetSize ( CSize sizeControl )

Sets the item control size.

Parameters
sizeControl Item control size to be set.

If the item control size is set to (<=0, <=0), then the control will occupy the rest of the cell.

See also
GetSize, GetWidth, SetWidth, GetHeight, SetHeight

◆ SetState()

AFX_INLINE void SetState ( int nNewState )

Sets the item control state.

The item control state is control specific.

Parameters
nNewState A new control specific state value.

◆ SetThemed()

AFX_INLINE void SetThemed ( BOOL bThemed )

Specifies the themed state of the item control.

Parameters
bThemed TRUE to set the item control to themed, FALSE otherwise.

◆ SetWidth()

AFX_INLINE void SetWidth ( int nWidth )

Sets the item control width.

Parameters
nWidth Item control width to be set.

If the width is set to less than 0, then the control will occupy the rest of the cell width.

See also
GetSize, SetSize, GetWidth, GetHeight, SetHeight

Member Data Documentation

◆ m_Alignment

XTPGridItemControlAlignment m_Alignment
protected

Control alignment.

See XTPGridItemControlAlignment for details.

◆ m_nState

int m_nState
protected

Control state.

Depends on control type.

◆ m_nType

int m_nType
protected

Control type.

See XTPGridItemControlType for details.

◆ m_sizeControl

CSize m_sizeControl
protected

Control size.

If size is (<=0, <=0), then the control occupies the entire cell.

The documentation for this class was generated from the following file:
  • XTPGridRecordItemControls.h


Toolkit Pro: CXTPGridRecordItemControlHookWnd Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPGridRecordItemControlHookWnd Class Reference

This class represents an item control hook window. More...

Public Member Functions

CXTPGridRecordItemControlHookWnd (XTP_GRIDRECORDITEM_CLICKARGS *pClickArgs)
Constructs a CXTPGridRecordItemControlHookWnd window.
~CXTPGridRecordItemControlHookWnd ()
Destroys a CXTPGridRecordItemControlHookWnd object, handles cleanup and deallocation.

Protected Attributes

XTP_GRIDRECORDITEM_CLICKARGS m_ClickArgs
Parameters of the cell.

Detailed Description

This class represents an item control hook window.

An instance of this window is created whenever the user presses the left mouse button on an item control. Furthermore, all mouse input will go to this window until the user releases the left mouse button. The window hooks mouse events and redirects them to the grid record item.

See also
CXTPGridRecordItem, CXTPGridRecordItemControl

Constructor & Destructor Documentation

◆ CXTPGridRecordItemControlHookWnd()

CXTPGridRecordItemControlHookWnd ( XTP_GRIDRECORDITEM_CLICKARGS * pClickArgs )

Constructs a CXTPGridRecordItemControlHookWnd window.

Parameters
pClickArgs Pointer to an XTP_GRIDRECORDITEM_CLICKARGS structure containing the parameters of the cell.
The documentation for this class was generated from the following file:
  • XTPGridRecordItemControls.h


Toolkit Pro: CXTPGridRecordItemControls Class Reference

Public Member Functions | Public Attributes | Protected Member Functions | List of all members
CXTPGridRecordItemControls Class Reference

This class represents the inplace controls of a single item. More...

Inheritance diagram for CXTPGridRecordItemControls:
[legend]

Public Member Functions

CXTPGridRecordItemControls ()
Constructs a CXTPGridRecordItemControls object.
CXTPGridRecordItemControls (CXTPGridRecordItem *pRecordItem)
Constructs a CXTPGridRecordItemControls object.
~CXTPGridRecordItemControls ()
Destroys a CXTPGridRecordItemControls object, handles cleanup and deallocation.
virtual void | DoPropExchange (CXTPPropExchange *pPX)
Call this member function to store/load a grid item controls list using the specified data object.
CXTPGridRecordItemControl * | AddControl (int nType, int nIndex=-1)
Adds a new control to the controls list.
CXTPGridRecordItemControl * | AddControl (CXTPGridRecordItemControl *pControl, int nIndex=-1)
Adds a new control to the controls list.
virtual void | RemoveAll ()
Removes all controls from the list.
virtual void | RemoveAt (int nIndex)
Removes a control from the list by its index.
virtual void | RemoveAt (int nIndex, int nCount)
Removes a control from the list by its index.
virtual void | CopyFrom (CXTPGridRecordItemControls *pSrc)
Copies all controls from a specified CXTPGridRecordItemControls object to this CXTPGridRecordItemControls object.
- Public Member Functions inherited from CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE >
CXTPArrayT ()
Default object constructor.
virtual | ~CXTPArrayT ()
Default object destructor.
virtual int | GetSize () const
This member function is used to obtain the number of elements in the collection.
virtual void | SetSize (int nNewSize, int nGrowBy=-1)
This member function is used to change the array size.
virtual TYPE | GetAt (int nIndex) const
This member function returns an element at the specified numeric index.
virtual void | SetAt (int nIndex, ARG_TYPE newElement)
This member function is used to set a new element to the position specified in the nIndex parameter.
virtual TYPE & | ElementAt (int nIndex)
This member function returns a reference to element at the specified numeric index.
virtual const TYPE * | GetData () const
This member function is used to Direct Access to the element data.
virtual TYPE * | GetData ()
This member function is used to Direct Access to the element data.
virtual void | SetAtGrow (int nIndex, ARG_TYPE newElement)
This member function is used to set a new element to the position specified in the nIndex parameter.
virtual int | Add (ARG_TYPE newElement)
This member function adds a new element to the end of the array.
virtual int | Append (const CXTPArrayT &src)
This member function adds the elements from a specified array to the end of this array.
virtual void | Copy (const CXTPArrayT &src)
This member function overwrites the contents of this array with the contents of a specified array.
TYPE | operator[] (int nIndex) const
This operator returns the array element at a specified numeric index.
TYPE & | operator[] (int nIndex)
This operator returns a reference to the array element at a specified numeric index.
virtual void | InsertAt (int nIndex, ARG_TYPE newElement, int nCount=1)
This member function is used to insert a number of copies of an element, specified by the nCount parameter, to the array starting at the position specified by the nIndex parameter.
virtual void | InsertAt (int nStartIndex, CXTPArrayT *pNewArray)
This member function is used to insert an array of elements to the array starting at the position specified by the nStartIndex parameter.
virtual int | FindElement (ARG_TYPE nElement) const
Call this member function to find an element in the collection.
virtual void | AddIfNeed (ARG_TYPE newElement)
Call this member function to add a specified element to the collection if it is not present already.
virtual BOOL | RemoveElement (ARG_TYPE nElement)
Call this member function to remove all elements with a specified value from the collection.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Public Attributes

CXTPGridRecordItem * m_pRecordItem
Pointer to parent record item.

Protected Member Functions

virtual void RefreshIndexes (int nIndexStart=0)
Recalculates the indices of all record item controls in the list that appear at or after a specified index.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Attributes inherited from CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE >
CArray< TYPE, ARG_TYPE > | m_arElements
Elements storage.

Detailed Description

This class represents the inplace controls of a single item.

This class represents an array of pointers to CXTPGridRecordItemControl objects. InternalRelease is called for each item in the array destructor. Also serialization for array items is provided (see the DoPropExchange method).

Constructor & Destructor Documentation

◆ CXTPGridRecordItemControls()

CXTPGridRecordItemControls ( CXTPGridRecordItem * pRecordItem )

Constructs a CXTPGridRecordItemControls object.

Parameters
pRecordItem Pointer to the parent record item.

Member Function Documentation

◆ AddControl() [1/2]

CXTPGridRecordItemControl * AddControl | ( | CXTPGridRecordItemControl * | pControl,
 |  | int | nIndex = -1 )

Adds a new control to the controls list.

Parameters
pControl | Pointer to the control to be added.
nIndex | Ordinal for position
Returns
A pointer to the newly added grid record item control object.

◆ AddControl() [2/2]

CXTPGridRecordItemControl * AddControl | ( | int | nType,
 |  | int | nIndex = -1 )

Adds a new control to the controls list.

Parameters
nType | Type of control to be added.
nIndex | Ordinal for position.
Returns
A pointer to the newly added grid record item control object.

◆ CopyFrom()

virtual void CopyFrom ( CXTPGridRecordItemControls * pSrc )
virtual

Copies all controls from a specified CXTPGridRecordItemControls object to this CXTPGridRecordItemControls object.

Parameters
pSrc Pointer to a CXTPGridRecordItemControls object to copy from.

◆ DoPropExchange()

virtual void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Call this member function to store/load a grid item controls list using the specified data object.

Parameters
pPX Source/destination CXTPPropExchange data object reference.

◆ RefreshIndexes()

virtual void RefreshIndexes ( int nIndexStart = 0 )
protectedvirtual

Recalculates the indices of all record item controls in the list that appear at or after a specified index.

Parameters
nIndexStart Specifies the zero-based index of the item before the first item

◆ RemoveAll()

virtual void RemoveAll ( )
virtual

Removes all controls from the list.

void RemoveControls();

Removes all controls from the list.

Reimplemented from CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE >.

◆ RemoveAt() [1/2]

virtual void RemoveAt ( int nIndex )
virtual

Removes a control from the list by its index.

Parameters
nIndex Index of the control to remove.

◆ RemoveAt() [2/2]

virtual void RemoveAt | ( | int | nIndex,
 |  | int | nCount )
 virtual

Removes a control from the list by its index.

Parameters
nIndex | Index of the control to remove.
nCount | The number of elements to remove.

Reimplemented from CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE >.

The documentation for this class was generated from the following file:
  • XTPGridRecordItemControls.h


Toolkit Pro: CXTPGridRecordItemDateTime Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPGridRecordItemDateTime Class Reference

Represents a time cell and inherits basic functionality from the CXTPGridRecordItem class. More...

Inheritance diagram for CXTPGridRecordItemDateTime:
[legend]

Public Member Functions

CXTPGridRecordItemDateTime (COleDateTime odtValue=(DATE) 0)
Creates a record date/time item.
virtual CString | GetCaption (CXTPGridColumn *pColumn)
Retrieves the text caption of the current item.
virtual int | Compare (CXTPGridColumn *pColumn, CXTPGridRecordItem *pItem)
Compares the current record item with a provided record item.
virtual COleVariant | GetGroupCaptionValue (CXTPGridColumn *pColumn)
Retrieves the group caption native value.
virtual int | CompareGroupCaption (CXTPGridColumn *pColumn, CXTPGridGroupRow *pGroupRow)
Compares the group caption of the current record item with the group caption of a provided group row.
virtual void | OnEditChanged (XTP_GRIDRECORDITEM_ARGS *pItemArgs, LPCTSTR szText)
This method is called when the value of the in-place edit control is changed.
COleDateTime | GetValue ()
Gets the value of the item.
void | SetValue (COleDateTime odtValue)
Sets the value of the item.
virtual void | DoPropExchange (CXTPPropExchange *pPX)
Call this member function to store/load a grid record item using the specified data object.
virtual CString | GetCaption ()
Gets the text caption of the item.
virtual int | CompareGroupCaption (CXTPGridColumn *pColumn, CXTPGridRecordItem *pItem)
Compares the group caption of the current record item with the group caption of a provided record item/group row.
- Public Member Functions inherited from CXTPGridRecordItem
CXTPGridRecordItem ()
CXTPGridRecordItem default constructor.
virtual | ~CXTPGridRecordItem ()
CXTPGridRecordItem default destructor.
virtual int | Draw (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs)
Should be overridden by descendants for drawing itself.
virtual void | OnDrawCaption (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics)
Should be overridden by descendants for drawing itself.
virtual void | OnDrawControls (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CRect &rcItem)
Should be overridden by descendants for drawing itself.
CXTPGridRecordItemControl * | HitTest (CPoint ptPoint)
Determines which grid record item control, if any, is at a specified point.
virtual int | HitTestHyperlink (CPoint ptClick)
Determines if a mouse click occurred on a hyperlink.
virtual BOOL | OnLButtonDown (XTP_GRIDRECORDITEM_CLICKARGS *pClickArgs)
Processes mouse left button down clicks.
virtual BOOL | OnLButtonUp (XTP_GRIDRECORDITEM_CLICKARGS *pClickArgs)
Processes mouse left button up clicks.
virtual void | OnClick (XTP_GRIDRECORDITEM_CLICKARGS *pClickArgs)
Processes single mouse clicks.
virtual void | OnDblClick (XTP_GRIDRECORDITEM_CLICKARGS *pClickArgs)
Processes double mouse clicks.
virtual void | OnMouseMove (UINT nFlags, CPoint point, CXTPGridControl *pControl=NULL)
Processes the move mouse event.
CString | GetColumnCaptionPrefix (CXTPGridColumn *pColumn) const
Gets the caption prefix of a specified column.
virtual void | GetCaptionRect (XTP_GRIDRECORDITEM_ARGS *pDrawArgs, CRect &rcItem)
Retrieves the caption text bounding rectangle.
virtual CString | GetGroupCaption (CXTPGridColumn *pColumn)
Gets the group caption text.
virtual int | GetGroupCaptionID (CXTPGridColumn *pColumn)
Gets the group caption ID.
virtual void | SetFont (CFont *pFont)
Sets the record item text font.
virtual CFont * | GetFont ()
Gets the record item text font.
virtual CString | GetTooltip () const
Gets the tooltip text of the record item.
virtual void | SetTooltip (LPCTSTR lpszTooltip)
Sets the tooltip text for the record item.
virtual void | SetTextColor (COLORREF clrText)
Sets the record item text color.
virtual COLORREF | GetTextColor ()
Gets the record item text color.
virtual void | SetBold (BOOL bBold=TRUE)
Sets the bold state of the record item font.
virtual BOOL | IsBold () const
Determines the bold state of the record item font.
virtual void | SetBackgroundColor (COLORREF clrBackground)
Sets the record item text background color.
virtual COLORREF | GetBackgroundColor ()
Gets the record item text background color.
virtual CString | GetFormula () const
Gets the record item formula.
virtual void | SetFormula (LPCTSTR sFormula)
Sets the record item formula.
virtual CString | GetFormatString () const
Gets the record item caption format string.
virtual void | SetFormatString (LPCTSTR strFormat)
Sets the record item caption format string.
virtual BOOL | IsEditable () const
Determines the editable state of the record item.
virtual BOOL | SetEditable (BOOL bEditable=TRUE)
Sets the editable state for the record item.
virtual int | AddHyperlink (CXTPGridHyperlink *pHyperlink)
Adds a new hyperlink to the record item.
virtual int | GetHyperlinksCount () const
Gets the number of hyperlinks in the record item.
virtual CXTPGridHyperlink * | GetHyperlinkAt (int nHyperlink) const
Retrieves the hyperlink at a specified index.
virtual void | RemoveHyperlinkAt (int nHyperlink)
Removes the hyperlink at a specified index.
virtual void | GetItemMetrics (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pItemMetrics)
Calculates preview item metrics based on specified draw arguments.
virtual BOOL | IsPreviewItem () const
Determines if the record item is a preview item.
int | GetIndex () const
Gets the index of the record item.
virtual int | GetIconIndex () const
Gets the ID of the associated resource bitmap.
virtual int | SetIconIndex (int nIconIndex)
Sets the ID for the associated resource bitmap.
int | GetAlignment () const
Gets the alignment value of the record item.
int | SetAlignment (int nAlignment)
Sets the alignment value for the record item.
virtual int | GetSortPriority () const
Gets the sort priority of the record item.
virtual void | SetSortPriority (int nSortPriority)
Sets the sort priority for the record item.
virtual int | GetGroupPriority () const
Gets the group priority of the record item.
virtual void | SetGroupPriority (int nGroupPriority)
Sets the group priority for the record item.
virtual void | SetGroupCaption (LPCTSTR strCaption)
Sets the group caption for the record item.
virtual void | SetCaption (LPCTSTR strCaption)
Sets the caption for the record item.
void | UpdateValue ()
Causes formula computed value to be updated.
virtual void | SetChecked (BOOL bChecked)
Sets if the record item is checked.
virtual BOOL | IsChecked () const
Determines if the record item is checked.
void | SetCheckedState (int iState)
Sets the checked state for the record item.
int | GetCheckedState () const
Gets the checked state of the record item.
virtual void | HasCheckbox (BOOL bHasCheckbox, BOOL bTristate=FALSE)
Adds check box area for item.
virtual BOOL | GetHasCheckbox () const
Determines if item has check box area.
BOOL | GetCanEditCheckboxItem () const
Returns whether items with a check box will go into edit mode on click.
void | SetCanEditCheckboxItem (BOOL bSet)
Specifies whether items with a check box will go into edit mode on click.
void | SetRecord (CXTPGridRecord *pGridRecord)
Sets the parent record object.
CXTPGridRecord * | GetRecord () const
Gets the parent record object.
virtual DWORD_PTR | GetItemData () const
Retrieves the application-supplied, 32-bit value associated with the record item.
virtual void | SetItemData (DWORD_PTR dwData)
Sets the 32-bit value associated with the record item.
virtual BOOL | IsFocusable () const
Determines if the record item can receive focus.
virtual void | SetFocusable (BOOL bFocusable)
Specifies if the record item can receive focus.
CXTPMarkupUIElement * | GetMarkupUIElement () const
Gets the Markup element that renders the item.
virtual void | ResetMarkupUIElement ()
Resets the Markup element.
virtual INT_PTR | OnToolHitTest (CPoint point, TOOLINFO *pTI)
The framework calls this member function to determine whether a point is in the bounding rectangle of the specified tool.
BOOL | IsChildOfMerge () const
Determines if the current item is in a merge group and, if so, if it is not the left-top (main) item of the group.
virtual void | OnCancelEdit (CXTPGridControl *pControl, BOOL bApply)
This method is called when the user cancels editing an item.
virtual void | OnValidateEdit (XTP_GRIDRECORDITEM_ARGS *pItemArgs)
This method is called to save the value from an in-place edit.
virtual BOOL | OnEditChanging (XTP_GRIDRECORDITEM_ARGS *pItemArgs, CString &rstrNewText)
This method is called before the value of the in-place editor is changed by the user.
virtual void | OnEditCanceled (XTP_GRIDRECORDITEM_ARGS *pItemArgs)
This method is called when in-place editing has been canceled and the value has not changed.
virtual void | OnConstraintChanged (XTP_GRIDRECORDITEM_ARGS *pItemArgs, CXTPGridRecordItemConstraint *pConstraint)
This method is called when the value of the selected contraint of the in-place list is changed by the user.
virtual DWORD | GetSelectedConstraintData (XTP_GRIDRECORDITEM_ARGS *pItemArgs)
Gets the value associated with a selected constraint.
virtual void | OnInplaceButtonDown (CXTPGridInplaceButton *pButton)
This method is called when the user presses the in-place button of the item.
CXTPGridRecordItemEditOptions * | GetEditOptions (CXTPGridColumn *pColumn)
Gets the edit options of the item.
CXTPGridRecordItemControls * GetItemControls ()
Gets the item controls list.
BOOL | CreateBorder ()
Creates a border for this item.
BOOL | DestroyBorder ()
Destroys the border of this item.
CXTPGridBorder * | GetBorder () const
Gets the border of this item.
void | SetGridControl (CXTPGridControl *pControl)
Sets the parent grid object.
- Public Member Functions inherited from CXTPHeapObjectT< CXTPCmdTarget, CXTPGridDataAllocator >
void *PASCAL | operator new (size_t nSize)
Allocate memory block of nSize bytes.
void PASCAL | operator delete (void *p)
Free memory block previously allocated by operator new.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Attributes

COleDateTime | m_odtValue
Cell value.
- Protected Attributes inherited from CXTPGridRecordItem
CXTPGridControl * | m_pControl
Parent Grid control.
CXTPGridRecord * | m_pRecord
Pointer to the associated record.
CXTPGridBorder * | m_pBorder
Item border.
CFont * | m_pFontCaption
Storage for item caption font.
COLORREF | m_clrText
Storage for item text color.
COLORREF | m_clrBackground
Storage for item background color.
BOOL | m_bBoldText
TRUE if bold text.
CString | m_strFormatString
Stores string for extra formatting of item caption.
CString | m_strFormula
Stores Formula with simple algorithm to calculate.
BOOL | m_bEditable
Stores editable flag.
CXTPGridHyperlinks * | m_pHyperlinks
Array of the Item's hyperlinks.
int | m_nIconIndex
ID of the bitmap from the application resources.
int | m_nSortPriority
Sort priority.
int | m_nGroupPriority
Group priority.
CString | m_strGroupCaption
Caption of the group.
CString | m_strCaption
Caption of the item.
BOOL | m_bFocusable
TRUE if item accept focus.
int | m_checkState
TRUE if item checked.
BOOL | m_bHasCheckbox
TRUE if item has check box.
BOOL | m_bCanEditCheckboxItem
TRUE if an item with a check box will get an edit control (only useful if column is wide)
BOOL | m_bTristateCheckbox
TRUE if the check box is tri-state.
DWORD_PTR | m_dwData
The 32-bit value associated with the item.
CString | m_strTooltip
Tooltip of the item.
CXTPGridRecordItemEditOptions * | m_pEditOptions
Edit options of the item.
XTPGridColumnIconAlignment | m_Alignment
Alignment style for item.
CXTPGridRecordItemControls * | m_pItemControls
Record item control list.
CXTPGridRecordItemControl * | m_pFocusedItemControl
Focused record item control.
BOOL | m_bItemControlUnderMouse
TRUE if an item control is under the mouse pointer.
CXTPGridRecordItemControlHookWnd * | m_pItemControlHookWnd
Item control hook window.
CRect | m_rcGlyph
Coordinates of drawn glyph.
CXTPMarkupUIElement * | m_pMarkupUIElement
Markup element.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPGridRecordItem
- Protected Member Functions inherited from CXTPGridRecordItem
virtual void | DrawCheckBox (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CRect &rcItem)
Draws the check box bitmap.
CXTPGridHyperlinks * GetHyperlinks ()
Gets the hyperlinks collection.
virtual BOOL | OnRequestEdit (XTP_GRIDRECORDITEM_ARGS *pItemArgs)
This method is called when an editable item enters edit mode.
virtual void | OnBeginEdit (XTP_GRIDRECORDITEM_ARGS *pItemArgs)
This method is called when the user begins to edit an item.
virtual BOOL | OnChar (XTP_GRIDRECORDITEM_ARGS *pItemArgs, UINT nChar)
This method is called when the user presses a key.

Detailed Description

Represents a time cell and inherits basic functionality from the CXTPGridRecordItem class.

You create a CXTPGridRecordItemDateTime record item simply by calling its constructor with one parameter - its initial date/time item value.

See also
CXTPGridRecordItem

Constructor & Destructor Documentation

◆ CXTPGridRecordItemDateTime()

CXTPGridRecordItemDateTime ( COleDateTime odtValue = (DATE) 0 )

Creates a record date/time item.

Parameters
odtValue Date/time item value to set.

Member Function Documentation

◆ Compare()

virtual int Compare | ( | CXTPGridColumn * | pColumn,
 |  | CXTPGridRecordItem * | pItem )
 virtual

Compares the current record item with a provided record item.

Parameters
pColumn | Pointer to the corresponding column of the current record item.
pItem | Pointer to the record item to compare with the current record item.

Overwrites parents' member function.

Returns
Zero if the current record item is equal to pItem; Less than zero if the current record item is less than pItem; Greater than zero if the current record item is greater than pItem.

Reimplemented from CXTPGridRecordItem.

◆ CompareGroupCaption() [1/2]

virtual int CompareGroupCaption | ( | CXTPGridColumn * | pColumn,
 |  | CXTPGridGroupRow * | pGroupRow )
 virtual

Compares the group caption of the current record item with the group caption of a provided group row.

Parameters
pColumn | Pointer to the corresponding column of the current record item.
pGroupRow | Pointer to the group row with the group caption to compare with the group caption of the current record item.
Returns
Zero if the group caption of the current record item is identical to the group caption of pGroupRow; Less than zero if the group caption of the current record item is less than the group caption of pGroupRow; Greater than zero if the group caption of the current record item is greater than the group caption of pGroupRow.

Reimplemented from CXTPGridRecordItem.

◆ CompareGroupCaption() [2/2]

virtual int CompareGroupCaption | ( | CXTPGridColumn * | pColumn,
 |  | CXTPGridRecordItem * | pItem )
 virtual

Compares the group caption of the current record item with the group caption of a provided record item/group row.

Parameters
pColumn | Pointer to the corresponding column of the current record item.
pItem | Pointer to the record item with the group caption to compare with the group caption of the current record item.
Returns
Zero if the group caption of the current record item is identical to the group caption of pItem/pGroupRow; Less than zero if the group caption of the current record item is less than the group caption of pItem/pGroupRow; Greater than zero if the group caption of the current record item is greater than the group caption of pItem/pGroupRow.

Reimplemented from CXTPGridRecordItem.

◆ DoPropExchange()

virtual void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Call this member function to store/load a grid record item using the specified data object.

Parameters
pPX Source/destination CXTPPropExchange data object reference.

Reimplemented from CXTPGridRecordItem.

◆ GetCaption() [1/2]

virtual CString GetCaption ( )
virtual

Gets the text caption of the item.

Can be overridden by descendants.

Returns
The text caption of the item, or an empty string for a base record item class.

Reimplemented from CXTPGridRecordItem.

◆ GetCaption() [2/2]

virtual CString GetCaption ( CXTPGridColumn * pColumn )
virtual

Retrieves the text caption of the current item.

Parameters
pColumn Pointer to the corresponding column of the current item.

Overwrites parents' member function.

Returns
The text caption of the current item.

Reimplemented from CXTPGridRecordItem.

◆ GetGroupCaptionValue()

virtual COleVariant GetGroupCaptionValue ( CXTPGridColumn * pColumn )
virtual

Retrieves the group caption native value.

Parameters
pColumn Pointer to a CXTPGridColumn object.
Returns
The group caption native value.

Reimplemented from CXTPGridRecordItem.

◆ GetValue()

AFX_INLINE COleDateTime GetValue ( )

Gets the value of the item.

Returns
A date-time item value.

◆ OnEditChanged()

virtual void OnEditChanged | ( | XTP_GRIDRECORDITEM_ARGS * | pItemArgs,
 |  | LPCTSTR | szText )
 virtual

This method is called when the value of the in-place edit control is changed.

Parameters
pItemArgs | Pointer to an XTP_GRIDRECORDITEM_ARGS structure containing item arguments.
szText | New in-place edit text.

Reimplemented from CXTPGridRecordItem.

◆ SetValue()

AFX_INLINE void SetValue ( COleDateTime odtValue )

Sets the value of the item.

Parameters
odtValue New date-time item value.
The documentation for this class was generated from the following file:
  • XTPGridRecordItemDateTime.h


Toolkit Pro: CXTPGridRecordItemEditOptions Class Reference

Public Member Functions | Public Attributes | List of all members
CXTPGridRecordItemEditOptions Class Reference

This class represents edit options for a single item or column. More...

Inheritance diagram for CXTPGridRecordItemEditOptions:
[legend]

Public Member Functions

CXTPGridRecordItemEditOptions ()
Constructs a CXTPGridRecordItemEditOptions object.
~CXTPGridRecordItemEditOptions ()
Destroys a CXTPGridRecordItemEditOptions object, handles cleanup and deallocation.
CXTPGridRecordItemConstraint * | AddConstraint (LPCTSTR lpszConstraint, DWORD_PTR dwData=0)
Adds a new constraint to the constraint list.
CXTPGridRecordItemConstraint * | FindConstraint (DWORD_PTR dwData)
Finds a constraint by its value.
CXTPGridRecordItemConstraint * | FindConstraint (LPCTSTR lpszConstraint)
Finds a constraint by its caption.
CXTPGridRecordItemConstraints * GetConstraints ()
Gets the constraints list.
CXTPGridInplaceButton * | AddComboButton (BOOL bInside=FALSE)
Adds a drop-down combo button to the CXTPGridRecordItem.
CXTPGridInplaceButton * | AddExpandButton (BOOL bInside=FALSE)
Adds an expand button to the CXTPGridRecordItem.
CXTPGridInplaceButton * | AddSpinButton (BOOL bInside=FALSE)
Adds a spin button to the CXTPGridRecordItem.
CXTPGridInplaceButton * | GetButton (int nIndex)
Retrieves a button by its index.
void | RemoveButtons ()
Removes all buttons of the CXTPGridRecordItem.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Public Attributes

BOOL | m_bAllowEdit
TRUE to enable changing the value of the field, FALSE to enable read-mode.
BOOL | m_bConstraintEdit
TRUE to prevent possibility to type in a custom value in the edit box if applicable.
CXTPGridRecordItemConstraints * | m_pConstraints
Constraint list.
CXTPGridInplaceButtons | arrInplaceButtons
Array of in-place buttons.
BOOL | m_bSelectTextOnEdit
Select all text on edit.
BOOL | m_bScrollTextOnEdit
Scroll text on edit.
BOOL | m_bExpandOnSelect
TRUE to expand expandable contents on edit.
DWORD | m_dwEditStyle
Edit Style (ES_MULTILINE, ES_NUMBER...).
int | m_nMaxLength
Maximum number of characters that can be entered into an editable item (Edit limit).

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

This class represents edit options for a single item or column.

Member Function Documentation

◆ AddComboButton()

CXTPGridInplaceButton * AddComboButton ( BOOL bInside = FALSE )

Adds a drop-down combo button to the CXTPGridRecordItem.

Parameters
bInside TRUE to keep the drop-down combo button inside the parent control rectangle.
Returns
A pointer to the newly added CXTPGridInplaceButton object.

This method adds a drop-down combo button to the GridRecordItem. When the button is pressed, it will display all of the data items that were added as CXTPGridRecordItemConstraints.

◆ AddConstraint()

CXTPGridRecordItemConstraint * AddConstraint | ( | LPCTSTR | lpszConstraint,
 |  | DWORD_PTR | dwData = 0 )

Adds a new constraint to the constraint list.

Parameters
lpszConstraint | Caption of the constraint to be added.
dwData | The 32-bit value associated with the constraint.
Returns
A pointer to the newly added CXTPGridRecordItemConstraint object.

◆ AddExpandButton()

CXTPGridInplaceButton * AddExpandButton ( BOOL bInside = FALSE )

Adds an expand button to the CXTPGridRecordItem.

Parameters
bInside TRUE to keep the expand button inside the parent control rectangle.
Returns
A pointer to the newly added CXTPGridInplaceButton object.

A small button with three ellipses is displayed and you can use this button to display your own custom dialog.

◆ AddSpinButton()

CXTPGridInplaceButton * AddSpinButton ( BOOL bInside = FALSE )

Adds a spin button to the CXTPGridRecordItem.

Parameters
bInside TRUE to keep the spin button inside the parent control rectangle.
Returns
A pointer to the newly added CXTPGridInplaceButton object.

A spin control with two buttons is displayed and you can use this button to change the cell numeric value.

◆ FindConstraint() [1/2]

CXTPGridRecordItemConstraint * FindConstraint ( DWORD_PTR dwData )

Finds a constraint by its value.

Parameters
dwData The 32-bit value associated with the constraint.
Returns
A pointer to the CXTPGridRecordItemConstraint object if found, otherwise NULL.

◆ FindConstraint() [2/2]

CXTPGridRecordItemConstraint * FindConstraint ( LPCTSTR lpszConstraint )

Finds a constraint by its caption.

Parameters
lpszConstraint Caption of the constraint.
Returns
A pointer to the CXTPGridRecordItemConstraint object if found, otherwise NULL.

◆ GetButton()

CXTPGridInplaceButton * GetButton ( int nIndex )

Retrieves a button by its index.

Parameters
nIndex Index of the button to retrieve.
Returns
A pointer to a CXTPGridInplaceButton object.

◆ GetConstraints()

CXTPGridRecordItemConstraints * GetConstraints ( )
inline

Gets the constraints list.

Returns
A pointer to the CXTPGridRecordItemConstraints object.

Member Data Documentation

◆ m_bAllowEdit

BOOL m_bAllowEdit

TRUE to enable changing the value of the field, FALSE to enable read-mode.

If FALSE, then m_bConstraintEdit is ignored.

The documentation for this class was generated from the following file:
  • XTPGridRecordItem.h


Toolkit Pro: CXTPGridRecordItemNumber Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPGridRecordItemNumber Class Reference

This class represents a numeric cell and inherits basic functionality from the CXTPGridRecordItem class. More...

Inheritance diagram for CXTPGridRecordItemNumber:
[legend]

Public Member Functions

CXTPGridRecordItemNumber (double dValue=0)
Creates a record numeric item with default formatting.
CXTPGridRecordItemNumber (double dValue, LPCTSTR strFormat)
Creates a record numeric item with specified formatting.
virtual CString | GetCaption (CXTPGridColumn *pColumn)
Retrieves the text caption of the current item.
double | GetValue ()
Gets the value of the item.
void | SetValue (double dValue)
Sets the value for the item.
virtual void | OnEditChanged (XTP_GRIDRECORDITEM_ARGS *pItemArgs, LPCTSTR szText)
This method is called when the value of the in-place edit control is changed.
virtual int | Compare (CXTPGridColumn *pColumn, CXTPGridRecordItem *pItem)
Compares the current record item with a provided record item.
virtual COleVariant | GetGroupCaptionValue (CXTPGridColumn *pColumn)
Retrieves the group caption native value.
virtual int | CompareGroupCaption (CXTPGridColumn *pColumn, CXTPGridGroupRow *pGroupRow)
Compares the group caption of the current record item with the group caption of a provided group row.
virtual void | DoPropExchange (CXTPPropExchange *pPX)
Call this member function to store/load a grid record item using the specified data object.
virtual CString | GetCaption ()
Gets the text caption of the item.
virtual int | CompareGroupCaption (CXTPGridColumn *pColumn, CXTPGridRecordItem *pItem)
Compares the group caption of the current record item with the group caption of a provided record item/group row.
- Public Member Functions inherited from CXTPGridRecordItem
CXTPGridRecordItem ()
CXTPGridRecordItem default constructor.
virtual | ~CXTPGridRecordItem ()
CXTPGridRecordItem default destructor.
virtual int | Draw (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs)
Should be overridden by descendants for drawing itself.
virtual void | OnDrawCaption (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics)
Should be overridden by descendants for drawing itself.
virtual void | OnDrawControls (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CRect &rcItem)
Should be overridden by descendants for drawing itself.
CXTPGridRecordItemControl * | HitTest (CPoint ptPoint)
Determines which grid record item control, if any, is at a specified point.
virtual int | HitTestHyperlink (CPoint ptClick)
Determines if a mouse click occurred on a hyperlink.
virtual BOOL | OnLButtonDown (XTP_GRIDRECORDITEM_CLICKARGS *pClickArgs)
Processes mouse left button down clicks.
virtual BOOL | OnLButtonUp (XTP_GRIDRECORDITEM_CLICKARGS *pClickArgs)
Processes mouse left button up clicks.
virtual void | OnClick (XTP_GRIDRECORDITEM_CLICKARGS *pClickArgs)
Processes single mouse clicks.
virtual void | OnDblClick (XTP_GRIDRECORDITEM_CLICKARGS *pClickArgs)
Processes double mouse clicks.
virtual void | OnMouseMove (UINT nFlags, CPoint point, CXTPGridControl *pControl=NULL)
Processes the move mouse event.
CString | GetColumnCaptionPrefix (CXTPGridColumn *pColumn) const
Gets the caption prefix of a specified column.
virtual void | GetCaptionRect (XTP_GRIDRECORDITEM_ARGS *pDrawArgs, CRect &rcItem)
Retrieves the caption text bounding rectangle.
virtual CString | GetGroupCaption (CXTPGridColumn *pColumn)
Gets the group caption text.
virtual int | GetGroupCaptionID (CXTPGridColumn *pColumn)
Gets the group caption ID.
virtual void | SetFont (CFont *pFont)
Sets the record item text font.
virtual CFont * | GetFont ()
Gets the record item text font.
virtual CString | GetTooltip () const
Gets the tooltip text of the record item.
virtual void | SetTooltip (LPCTSTR lpszTooltip)
Sets the tooltip text for the record item.
virtual void | SetTextColor (COLORREF clrText)
Sets the record item text color.
virtual COLORREF | GetTextColor ()
Gets the record item text color.
virtual void | SetBold (BOOL bBold=TRUE)
Sets the bold state of the record item font.
virtual BOOL | IsBold () const
Determines the bold state of the record item font.
virtual void | SetBackgroundColor (COLORREF clrBackground)
Sets the record item text background color.
virtual COLORREF | GetBackgroundColor ()
Gets the record item text background color.
virtual CString | GetFormula () const
Gets the record item formula.
virtual void | SetFormula (LPCTSTR sFormula)
Sets the record item formula.
virtual CString | GetFormatString () const
Gets the record item caption format string.
virtual void | SetFormatString (LPCTSTR strFormat)
Sets the record item caption format string.
virtual BOOL | IsEditable () const
Determines the editable state of the record item.
virtual BOOL | SetEditable (BOOL bEditable=TRUE)
Sets the editable state for the record item.
virtual int | AddHyperlink (CXTPGridHyperlink *pHyperlink)
Adds a new hyperlink to the record item.
virtual int | GetHyperlinksCount () const
Gets the number of hyperlinks in the record item.
virtual CXTPGridHyperlink * | GetHyperlinkAt (int nHyperlink) const
Retrieves the hyperlink at a specified index.
virtual void | RemoveHyperlinkAt (int nHyperlink)
Removes the hyperlink at a specified index.
virtual void | GetItemMetrics (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pItemMetrics)
Calculates preview item metrics based on specified draw arguments.
virtual BOOL | IsPreviewItem () const
Determines if the record item is a preview item.
int | GetIndex () const
Gets the index of the record item.
virtual int | GetIconIndex () const
Gets the ID of the associated resource bitmap.
virtual int | SetIconIndex (int nIconIndex)
Sets the ID for the associated resource bitmap.
int | GetAlignment () const
Gets the alignment value of the record item.
int | SetAlignment (int nAlignment)
Sets the alignment value for the record item.
virtual int | GetSortPriority () const
Gets the sort priority of the record item.
virtual void | SetSortPriority (int nSortPriority)
Sets the sort priority for the record item.
virtual int | GetGroupPriority () const
Gets the group priority of the record item.
virtual void | SetGroupPriority (int nGroupPriority)
Sets the group priority for the record item.
virtual void | SetGroupCaption (LPCTSTR strCaption)
Sets the group caption for the record item.
virtual void | SetCaption (LPCTSTR strCaption)
Sets the caption for the record item.
void | UpdateValue ()
Causes formula computed value to be updated.
virtual void | SetChecked (BOOL bChecked)
Sets if the record item is checked.
virtual BOOL | IsChecked () const
Determines if the record item is checked.
void | SetCheckedState (int iState)
Sets the checked state for the record item.
int | GetCheckedState () const
Gets the checked state of the record item.
virtual void | HasCheckbox (BOOL bHasCheckbox, BOOL bTristate=FALSE)
Adds check box area for item.
virtual BOOL | GetHasCheckbox () const
Determines if item has check box area.
BOOL | GetCanEditCheckboxItem () const
Returns whether items with a check box will go into edit mode on click.
void | SetCanEditCheckboxItem (BOOL bSet)
Specifies whether items with a check box will go into edit mode on click.
void | SetRecord (CXTPGridRecord *pGridRecord)
Sets the parent record object.
CXTPGridRecord * | GetRecord () const
Gets the parent record object.
virtual DWORD_PTR | GetItemData () const
Retrieves the application-supplied, 32-bit value associated with the record item.
virtual void | SetItemData (DWORD_PTR dwData)
Sets the 32-bit value associated with the record item.
virtual BOOL | IsFocusable () const
Determines if the record item can receive focus.
virtual void | SetFocusable (BOOL bFocusable)
Specifies if the record item can receive focus.
CXTPMarkupUIElement * | GetMarkupUIElement () const
Gets the Markup element that renders the item.
virtual void | ResetMarkupUIElement ()
Resets the Markup element.
virtual INT_PTR | OnToolHitTest (CPoint point, TOOLINFO *pTI)
The framework calls this member function to determine whether a point is in the bounding rectangle of the specified tool.
BOOL | IsChildOfMerge () const
Determines if the current item is in a merge group and, if so, if it is not the left-top (main) item of the group.
virtual void | OnCancelEdit (CXTPGridControl *pControl, BOOL bApply)
This method is called when the user cancels editing an item.
virtual void | OnValidateEdit (XTP_GRIDRECORDITEM_ARGS *pItemArgs)
This method is called to save the value from an in-place edit.
virtual BOOL | OnEditChanging (XTP_GRIDRECORDITEM_ARGS *pItemArgs, CString &rstrNewText)
This method is called before the value of the in-place editor is changed by the user.
virtual void | OnEditCanceled (XTP_GRIDRECORDITEM_ARGS *pItemArgs)
This method is called when in-place editing has been canceled and the value has not changed.
virtual void | OnConstraintChanged (XTP_GRIDRECORDITEM_ARGS *pItemArgs, CXTPGridRecordItemConstraint *pConstraint)
This method is called when the value of the selected contraint of the in-place list is changed by the user.
virtual DWORD | GetSelectedConstraintData (XTP_GRIDRECORDITEM_ARGS *pItemArgs)
Gets the value associated with a selected constraint.
virtual void | OnInplaceButtonDown (CXTPGridInplaceButton *pButton)
This method is called when the user presses the in-place button of the item.
CXTPGridRecordItemEditOptions * | GetEditOptions (CXTPGridColumn *pColumn)
Gets the edit options of the item.
CXTPGridRecordItemControls * GetItemControls ()
Gets the item controls list.
BOOL | CreateBorder ()
Creates a border for this item.
BOOL | DestroyBorder ()
Destroys the border of this item.
CXTPGridBorder * | GetBorder () const
Gets the border of this item.
void | SetGridControl (CXTPGridControl *pControl)
Sets the parent grid object.
- Public Member Functions inherited from CXTPHeapObjectT< CXTPCmdTarget, CXTPGridDataAllocator >
void *PASCAL | operator new (size_t nSize)
Allocate memory block of nSize bytes.
void PASCAL | operator delete (void *p)
Free memory block previously allocated by operator new.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Attributes

double | m_dValue
Cell value.
- Protected Attributes inherited from CXTPGridRecordItem
CXTPGridControl * | m_pControl
Parent Grid control.
CXTPGridRecord * | m_pRecord
Pointer to the associated record.
CXTPGridBorder * | m_pBorder
Item border.
CFont * | m_pFontCaption
Storage for item caption font.
COLORREF | m_clrText
Storage for item text color.
COLORREF | m_clrBackground
Storage for item background color.
BOOL | m_bBoldText
TRUE if bold text.
CString | m_strFormatString
Stores string for extra formatting of item caption.
CString | m_strFormula
Stores Formula with simple algorithm to calculate.
BOOL | m_bEditable
Stores editable flag.
CXTPGridHyperlinks * | m_pHyperlinks
Array of the Item's hyperlinks.
int | m_nIconIndex
ID of the bitmap from the application resources.
int | m_nSortPriority
Sort priority.
int | m_nGroupPriority
Group priority.
CString | m_strGroupCaption
Caption of the group.
CString | m_strCaption
Caption of the item.
BOOL | m_bFocusable
TRUE if item accept focus.
int | m_checkState
TRUE if item checked.
BOOL | m_bHasCheckbox
TRUE if item has check box.
BOOL | m_bCanEditCheckboxItem
TRUE if an item with a check box will get an edit control (only useful if column is wide)
BOOL | m_bTristateCheckbox
TRUE if the check box is tri-state.
DWORD_PTR | m_dwData
The 32-bit value associated with the item.
CString | m_strTooltip
Tooltip of the item.
CXTPGridRecordItemEditOptions * | m_pEditOptions
Edit options of the item.
XTPGridColumnIconAlignment | m_Alignment
Alignment style for item.
CXTPGridRecordItemControls * | m_pItemControls
Record item control list.
CXTPGridRecordItemControl * | m_pFocusedItemControl
Focused record item control.
BOOL | m_bItemControlUnderMouse
TRUE if an item control is under the mouse pointer.
CXTPGridRecordItemControlHookWnd * | m_pItemControlHookWnd
Item control hook window.
CRect | m_rcGlyph
Coordinates of drawn glyph.
CXTPMarkupUIElement * | m_pMarkupUIElement
Markup element.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPGridRecordItem
- Protected Member Functions inherited from CXTPGridRecordItem
virtual void | DrawCheckBox (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CRect &rcItem)
Draws the check box bitmap.
CXTPGridHyperlinks * GetHyperlinks ()
Gets the hyperlinks collection.
virtual BOOL | OnRequestEdit (XTP_GRIDRECORDITEM_ARGS *pItemArgs)
This method is called when an editable item enters edit mode.
virtual void | OnBeginEdit (XTP_GRIDRECORDITEM_ARGS *pItemArgs)
This method is called when the user begins to edit an item.
virtual BOOL | OnChar (XTP_GRIDRECORDITEM_ARGS *pItemArgs, UINT nChar)
This method is called when the user presses a key.

Detailed Description

This class represents a numeric cell and inherits basic functionality from the CXTPGridRecordItem class.

You create a number record item simply by calling its constructor with one parameter - its numeric value. There is an additional constructor with a second parameter - its format string. Format string allows you to determine exactly in which format the numeric value will be represented on the screen. It could be useful for displaying money values, etc.

See also
CXTPGridRecordItem

Constructor & Destructor Documentation

◆ CXTPGridRecordItemNumber() [1/2]

CXTPGridRecordItemNumber ( double dValue = 0 )

Creates a record numeric item with default formatting.

Parameters
dValue Numeric item value to be set.

◆ CXTPGridRecordItemNumber() [2/2]

CXTPGridRecordItemNumber | ( | double | dValue,
 |  | LPCTSTR | strFormat )

Creates a record numeric item with specified formatting.

Parameters
dValue | Numeric item value to be set.
strFormat | Format string for creating the caption value of the item.

If the format string is set, then the value of the item will be formatted according to this format string before it is drawn. This is convenient in many cases (e.g. when drawing dates). The format string is C like style; see the sprintf() C function or the CString.Format() member function.

Member Function Documentation

◆ Compare()

virtual int Compare | ( | CXTPGridColumn * | pColumn,
 |  | CXTPGridRecordItem * | pItem )
 virtual

Compares the current record item with a provided record item.

Parameters
pColumn | Pointer to the corresponding column of the current record item.
pItem | Pointer to the record item to compare with the current record item.

Overwrites parents' member function.

Returns
Zero if the current record item is equal to pItem; Less than zero if the current record item is less than pItem; Greater than zero if the current record item is greater than pItem.

Reimplemented from CXTPGridRecordItem.

◆ CompareGroupCaption() [1/2]

virtual int CompareGroupCaption | ( | CXTPGridColumn * | pColumn,
 |  | CXTPGridGroupRow * | pGroupRow )
 virtual

Compares the group caption of the current record item with the group caption of a provided group row.

Parameters
pColumn | Pointer to the corresponding column of the current record item.
pGroupRow | Pointer to the group row with the group caption to compare with the group caption of the current record item.
Returns
Zero if the group caption of the current record item is identical to the group caption of pGroupRow; Less than zero if the group caption of the current record item is less than the group caption of pGroupRow; Greater than zero if the group caption of the current record item is greater than the group caption of pGroupRow.

Reimplemented from CXTPGridRecordItem.

◆ CompareGroupCaption() [2/2]

virtual int CompareGroupCaption | ( | CXTPGridColumn * | pColumn,
 |  | CXTPGridRecordItem * | pItem )
 virtual

Compares the group caption of the current record item with the group caption of a provided record item/group row.

Parameters
pColumn | Pointer to the corresponding column of the current record item.
pItem | Pointer to the record item with the group caption to compare with the group caption of the current record item.
Returns
Zero if the group caption of the current record item is identical to the group caption of pItem/pGroupRow; Less than zero if the group caption of the current record item is less than the group caption of pItem/pGroupRow; Greater than zero if the group caption of the current record item is greater than the group caption of pItem/pGroupRow.

Reimplemented from CXTPGridRecordItem.

◆ DoPropExchange()

virtual void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Call this member function to store/load a grid record item using the specified data object.

Parameters
pPX Source/destination CXTPPropExchange data object reference.

Reimplemented from CXTPGridRecordItem.

◆ GetCaption() [1/2]

virtual CString GetCaption ( )
virtual

Gets the text caption of the item.

Can be overridden by descendants.

Returns
The text caption of the item, or an empty string for a base record item class.

Reimplemented from CXTPGridRecordItem.

◆ GetCaption() [2/2]

virtual CString GetCaption ( CXTPGridColumn * pColumn )
virtual

Retrieves the text caption of the current item.

Parameters
pColumn Pointer to the corresponding column of the current item.

Overwrites parents' member function.

Returns
The text caption of the current item.

Reimplemented from CXTPGridRecordItem.

◆ GetGroupCaptionValue()

virtual COleVariant GetGroupCaptionValue ( CXTPGridColumn * pColumn )
virtual

Retrieves the group caption native value.

Parameters
pColumn Pointer to a CXTPGridColumn object.
Returns
The group caption native value.

Reimplemented from CXTPGridRecordItem.

◆ GetValue()

AFX_INLINE double GetValue ( )

Gets the value of the item.

Returns
The numeric item value.

◆ OnEditChanged()

virtual void OnEditChanged | ( | XTP_GRIDRECORDITEM_ARGS * | pItemArgs,
 |  | LPCTSTR | szText )
 virtual

This method is called when the value of the in-place edit control is changed.

Parameters
pItemArgs | Pointer to an XTP_GRIDRECORDITEM_ARGS structure containing item arguments.
szText | New in-place edit text.

Reimplemented from CXTPGridRecordItem.

◆ SetValue()

AFX_INLINE void SetValue ( double dValue )

Sets the value for the item.

Parameters
dValue New numeric item value.
The documentation for this class was generated from the following file:
  • XTPGridRecordItemNumber.h


Toolkit Pro: CXTPGridRecordItemPercentNumber Class Reference

Public Member Functions | Public Attributes | List of all members
CXTPGridRecordItemPercentNumber Class Reference

This class represents a numeric percent cell and inherits basic functionality from the CXTPGridRecordItemNumber class. More...

Inheritance diagram for CXTPGridRecordItemPercentNumber:
[legend]

Public Member Functions

CXTPGridRecordItemPercentNumber (double dValue=0, COLORREF clr=RGB(224, 224, 224), BOOL bPercentCompleteDisplay=TRUE)
Constructs a CXTPGridRecordItemPercentNumber object using specified percentage and color values.
void | OnDrawCaption (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics)
Should be overridden by descendants for drawing itself.
- Public Member Functions inherited from CXTPGridRecordItemNumber
CXTPGridRecordItemNumber (double dValue=0)
Creates a record numeric item with default formatting.
CXTPGridRecordItemNumber (double dValue, LPCTSTR strFormat)
Creates a record numeric item with specified formatting.
virtual CString | GetCaption (CXTPGridColumn *pColumn)
Retrieves the text caption of the current item.
double | GetValue ()
Gets the value of the item.
void | SetValue (double dValue)
Sets the value for the item.
virtual void | OnEditChanged (XTP_GRIDRECORDITEM_ARGS *pItemArgs, LPCTSTR szText)
This method is called when the value of the in-place edit control is changed.
virtual int | Compare (CXTPGridColumn *pColumn, CXTPGridRecordItem *pItem)
Compares the current record item with a provided record item.
virtual COleVariant | GetGroupCaptionValue (CXTPGridColumn *pColumn)
Retrieves the group caption native value.
virtual int | CompareGroupCaption (CXTPGridColumn *pColumn, CXTPGridGroupRow *pGroupRow)
Compares the group caption of the current record item with the group caption of a provided group row.
virtual void | DoPropExchange (CXTPPropExchange *pPX)
Call this member function to store/load a grid record item using the specified data object.
virtual CString | GetCaption ()
Gets the text caption of the item.
virtual int | CompareGroupCaption (CXTPGridColumn *pColumn, CXTPGridRecordItem *pItem)
Compares the group caption of the current record item with the group caption of a provided record item/group row.
- Public Member Functions inherited from CXTPGridRecordItem
CXTPGridRecordItem ()
CXTPGridRecordItem default constructor.
virtual | ~CXTPGridRecordItem ()
CXTPGridRecordItem default destructor.
virtual int | Draw (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs)
Should be overridden by descendants for drawing itself.
virtual void | OnDrawControls (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CRect &rcItem)
Should be overridden by descendants for drawing itself.
CXTPGridRecordItemControl * | HitTest (CPoint ptPoint)
Determines which grid record item control, if any, is at a specified point.
virtual int | HitTestHyperlink (CPoint ptClick)
Determines if a mouse click occurred on a hyperlink.
virtual BOOL | OnLButtonDown (XTP_GRIDRECORDITEM_CLICKARGS *pClickArgs)
Processes mouse left button down clicks.
virtual BOOL | OnLButtonUp (XTP_GRIDRECORDITEM_CLICKARGS *pClickArgs)
Processes mouse left button up clicks.
virtual void | OnClick (XTP_GRIDRECORDITEM_CLICKARGS *pClickArgs)
Processes single mouse clicks.
virtual void | OnDblClick (XTP_GRIDRECORDITEM_CLICKARGS *pClickArgs)
Processes double mouse clicks.
virtual void | OnMouseMove (UINT nFlags, CPoint point, CXTPGridControl *pControl=NULL)
Processes the move mouse event.
CString | GetColumnCaptionPrefix (CXTPGridColumn *pColumn) const
Gets the caption prefix of a specified column.
virtual void | GetCaptionRect (XTP_GRIDRECORDITEM_ARGS *pDrawArgs, CRect &rcItem)
Retrieves the caption text bounding rectangle.
virtual CString | GetGroupCaption (CXTPGridColumn *pColumn)
Gets the group caption text.
virtual int | GetGroupCaptionID (CXTPGridColumn *pColumn)
Gets the group caption ID.
virtual void | SetFont (CFont *pFont)
Sets the record item text font.
virtual CFont * | GetFont ()
Gets the record item text font.
virtual CString | GetTooltip () const
Gets the tooltip text of the record item.
virtual void | SetTooltip (LPCTSTR lpszTooltip)
Sets the tooltip text for the record item.
virtual void | SetTextColor (COLORREF clrText)
Sets the record item text color.
virtual COLORREF | GetTextColor ()
Gets the record item text color.
virtual void | SetBold (BOOL bBold=TRUE)
Sets the bold state of the record item font.
virtual BOOL | IsBold () const
Determines the bold state of the record item font.
virtual void | SetBackgroundColor (COLORREF clrBackground)
Sets the record item text background color.
virtual COLORREF | GetBackgroundColor ()
Gets the record item text background color.
virtual CString | GetFormula () const
Gets the record item formula.
virtual void | SetFormula (LPCTSTR sFormula)
Sets the record item formula.
virtual CString | GetFormatString () const
Gets the record item caption format string.
virtual void | SetFormatString (LPCTSTR strFormat)
Sets the record item caption format string.
virtual BOOL | IsEditable () const
Determines the editable state of the record item.
virtual BOOL | SetEditable (BOOL bEditable=TRUE)
Sets the editable state for the record item.
virtual int | AddHyperlink (CXTPGridHyperlink *pHyperlink)
Adds a new hyperlink to the record item.
virtual int | GetHyperlinksCount () const
Gets the number of hyperlinks in the record item.
virtual CXTPGridHyperlink * | GetHyperlinkAt (int nHyperlink) const
Retrieves the hyperlink at a specified index.
virtual void | RemoveHyperlinkAt (int nHyperlink)
Removes the hyperlink at a specified index.
virtual void | GetItemMetrics (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pItemMetrics)
Calculates preview item metrics based on specified draw arguments.
virtual BOOL | IsPreviewItem () const
Determines if the record item is a preview item.
int | GetIndex () const
Gets the index of the record item.
virtual int | GetIconIndex () const
Gets the ID of the associated resource bitmap.
virtual int | SetIconIndex (int nIconIndex)
Sets the ID for the associated resource bitmap.
int | GetAlignment () const
Gets the alignment value of the record item.
int | SetAlignment (int nAlignment)
Sets the alignment value for the record item.
virtual int | GetSortPriority () const
Gets the sort priority of the record item.
virtual void | SetSortPriority (int nSortPriority)
Sets the sort priority for the record item.
virtual int | GetGroupPriority () const
Gets the group priority of the record item.
virtual void | SetGroupPriority (int nGroupPriority)
Sets the group priority for the record item.
virtual void | SetGroupCaption (LPCTSTR strCaption)
Sets the group caption for the record item.
virtual void | SetCaption (LPCTSTR strCaption)
Sets the caption for the record item.
void | UpdateValue ()
Causes formula computed value to be updated.
virtual void | SetChecked (BOOL bChecked)
Sets if the record item is checked.
virtual BOOL | IsChecked () const
Determines if the record item is checked.
void | SetCheckedState (int iState)
Sets the checked state for the record item.
int | GetCheckedState () const
Gets the checked state of the record item.
virtual void | HasCheckbox (BOOL bHasCheckbox, BOOL bTristate=FALSE)
Adds check box area for item.
virtual BOOL | GetHasCheckbox () const
Determines if item has check box area.
BOOL | GetCanEditCheckboxItem () const
Returns whether items with a check box will go into edit mode on click.
void | SetCanEditCheckboxItem (BOOL bSet)
Specifies whether items with a check box will go into edit mode on click.
void | SetRecord (CXTPGridRecord *pGridRecord)
Sets the parent record object.
CXTPGridRecord * | GetRecord () const
Gets the parent record object.
virtual DWORD_PTR | GetItemData () const
Retrieves the application-supplied, 32-bit value associated with the record item.
virtual void | SetItemData (DWORD_PTR dwData)
Sets the 32-bit value associated with the record item.
virtual BOOL | IsFocusable () const
Determines if the record item can receive focus.
virtual void | SetFocusable (BOOL bFocusable)
Specifies if the record item can receive focus.
CXTPMarkupUIElement * | GetMarkupUIElement () const
Gets the Markup element that renders the item.
virtual void | ResetMarkupUIElement ()
Resets the Markup element.
virtual INT_PTR | OnToolHitTest (CPoint point, TOOLINFO *pTI)
The framework calls this member function to determine whether a point is in the bounding rectangle of the specified tool.
BOOL | IsChildOfMerge () const
Determines if the current item is in a merge group and, if so, if it is not the left-top (main) item of the group.
virtual void | OnCancelEdit (CXTPGridControl *pControl, BOOL bApply)
This method is called when the user cancels editing an item.
virtual void | OnValidateEdit (XTP_GRIDRECORDITEM_ARGS *pItemArgs)
This method is called to save the value from an in-place edit.
virtual BOOL | OnEditChanging (XTP_GRIDRECORDITEM_ARGS *pItemArgs, CString &rstrNewText)
This method is called before the value of the in-place editor is changed by the user.
virtual void | OnEditCanceled (XTP_GRIDRECORDITEM_ARGS *pItemArgs)
This method is called when in-place editing has been canceled and the value has not changed.
virtual void | OnConstraintChanged (XTP_GRIDRECORDITEM_ARGS *pItemArgs, CXTPGridRecordItemConstraint *pConstraint)
This method is called when the value of the selected contraint of the in-place list is changed by the user.
virtual DWORD | GetSelectedConstraintData (XTP_GRIDRECORDITEM_ARGS *pItemArgs)
Gets the value associated with a selected constraint.
virtual void | OnInplaceButtonDown (CXTPGridInplaceButton *pButton)
This method is called when the user presses the in-place button of the item.
CXTPGridRecordItemEditOptions * | GetEditOptions (CXTPGridColumn *pColumn)
Gets the edit options of the item.
CXTPGridRecordItemControls * GetItemControls ()
Gets the item controls list.
BOOL | CreateBorder ()
Creates a border for this item.
BOOL | DestroyBorder ()
Destroys the border of this item.
CXTPGridBorder * | GetBorder () const
Gets the border of this item.
void | SetGridControl (CXTPGridControl *pControl)
Sets the parent grid object.
- Public Member Functions inherited from CXTPHeapObjectT< CXTPCmdTarget, CXTPGridDataAllocator >
void *PASCAL | operator new (size_t nSize)
Allocate memory block of nSize bytes.
void PASCAL | operator delete (void *p)
Free memory block previously allocated by operator new.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Public Attributes

COLORREF | m_clr
Color.
BOOL | m_bPercentCompleteDisplay
Flag.
- Public Attributes inherited from CXTPGridRecordItem

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Member Functions inherited from CXTPGridRecordItem
virtual void | DrawCheckBox (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CRect &rcItem)
Draws the check box bitmap.
CXTPGridHyperlinks * GetHyperlinks ()
Gets the hyperlinks collection.
virtual BOOL | OnRequestEdit (XTP_GRIDRECORDITEM_ARGS *pItemArgs)
This method is called when an editable item enters edit mode.
virtual void | OnBeginEdit (XTP_GRIDRECORDITEM_ARGS *pItemArgs)
This method is called when the user begins to edit an item.
virtual BOOL | OnChar (XTP_GRIDRECORDITEM_ARGS *pItemArgs, UINT nChar)
This method is called when the user presses a key.
- Protected Attributes inherited from CXTPGridRecordItemNumber
double | m_dValue
Cell value.
- Protected Attributes inherited from CXTPGridRecordItem
CXTPGridControl * | m_pControl
Parent Grid control.
CXTPGridRecord * | m_pRecord
Pointer to the associated record.
CXTPGridBorder * | m_pBorder
Item border.
CFont * | m_pFontCaption
Storage for item caption font.
COLORREF | m_clrText
Storage for item text color.
COLORREF | m_clrBackground
Storage for item background color.
BOOL | m_bBoldText
TRUE if bold text.
CString | m_strFormatString
Stores string for extra formatting of item caption.
CString | m_strFormula
Stores Formula with simple algorithm to calculate.
BOOL | m_bEditable
Stores editable flag.
CXTPGridHyperlinks * | m_pHyperlinks
Array of the Item's hyperlinks.
int | m_nIconIndex
ID of the bitmap from the application resources.
int | m_nSortPriority
Sort priority.
int | m_nGroupPriority
Group priority.
CString | m_strGroupCaption
Caption of the group.
CString | m_strCaption
Caption of the item.
BOOL | m_bFocusable
TRUE if item accept focus.
int | m_checkState
TRUE if item checked.
BOOL | m_bHasCheckbox
TRUE if item has check box.
BOOL | m_bCanEditCheckboxItem
TRUE if an item with a check box will get an edit control (only useful if column is wide)
BOOL | m_bTristateCheckbox
TRUE if the check box is tri-state.
DWORD_PTR | m_dwData
The 32-bit value associated with the item.
CString | m_strTooltip
Tooltip of the item.
CXTPGridRecordItemEditOptions * | m_pEditOptions
Edit options of the item.
XTPGridColumnIconAlignment | m_Alignment
Alignment style for item.
CXTPGridRecordItemControls * | m_pItemControls
Record item control list.
CXTPGridRecordItemControl * | m_pFocusedItemControl
Focused record item control.
BOOL | m_bItemControlUnderMouse
TRUE if an item control is under the mouse pointer.
CXTPGridRecordItemControlHookWnd * | m_pItemControlHookWnd
Item control hook window.
CRect | m_rcGlyph
Coordinates of drawn glyph.
CXTPMarkupUIElement * | m_pMarkupUIElement
Markup element.

Detailed Description

This class represents a numeric percent cell and inherits basic functionality from the CXTPGridRecordItemNumber class.

See also
CXTPGridRecordItemNumber

Constructor & Destructor Documentation

◆ CXTPGridRecordItemPercentNumber()

CXTPGridRecordItemPercentNumber | ( | double | dValue = 0,
 |  | COLORREF | clr = RGB(224, 224, 224),
 |  | BOOL | bPercentCompleteDisplay = TRUE )

Constructs a CXTPGridRecordItemPercentNumber object using specified percentage and color values.

Parameters
dValue | Percentage value.
clr | Color value.
bPercentCompleteDisplay | TRUE to show as a colored rectangle inside.

Member Function Documentation

◆ OnDrawCaption()

void OnDrawCaption | ( | XTP_GRIDRECORDITEM_DRAWARGS * | pDrawArgs,
 |  | XTP_GRIDRECORDITEM_METRICS * | pMetrics )
 virtual

Should be overridden by descendants for drawing itself.

Parameters
pDrawArgs | Pointer to an XTP_GRIDRECORDITEM_DRAWARGS structure containing drawing arguments.
pMetrics | Pointer to an XTP_GRIDRECORDITEM_METRICS structure containing item metrics.

Reimplemented from CXTPGridRecordItem.

The documentation for this class was generated from the following file:
  • XTPGridRecordItemNumber.h


Toolkit Pro: CXTPGridRecordItemPreview Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPGridRecordItemPreview Class Reference

This represents a preview cell and inherits basic functionality from the CXTPGridRecordItem class. More...

Inheritance diagram for CXTPGridRecordItemPreview:
[legend]

Public Member Functions

CXTPGridRecordItemPreview (LPCTSTR szPreviewText=_T(""))
Creates a new preview record item.
void | SetPreviewText (LPCTSTR strPreviewText)
Set the preview text for the item.
virtual CString | GetPreviewText ()
Gets the preview text of the item.
virtual int | GetPreviewHeight (CDC *pDC, CXTPGridRow *pRow, int nWidth)
Retrieves the height of the preview area.
CString | GetCaption (CXTPGridColumn *pColumn)
Gets the caption of the item.
virtual void | SetCaption (LPCTSTR strCaption)
Sets the caption for the item.
virtual void | OnDrawCaption (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics)
Should be overridden by descendants for drawing itself.
virtual void | GetItemMetrics (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pItemMetrics)
Fills an XTP_GRIDRECORDITEM_METRICS structure.
BOOL | IsPreviewItem () const
Determines if the item is a preview item.
virtual void | OnEditChanged (XTP_GRIDRECORDITEM_ARGS *pItemArgs, LPCTSTR szText)
This method is called when the value of the in-place edit control is changed.
virtual void | GetCaptionRect (XTP_GRIDRECORDITEM_ARGS *pDrawArgs, CRect &rcItem)
Retrieves the caption text of the bounding rectangle.
virtual void | DoPropExchange (CXTPPropExchange *pPX)
Call this member function to store/load a grid record item using the specified data object.
virtual CString | GetCaption ()
Gets the text caption of the item.
- Public Member Functions inherited from CXTPGridRecordItem
CXTPGridRecordItem ()
CXTPGridRecordItem default constructor.
virtual | ~CXTPGridRecordItem ()
CXTPGridRecordItem default destructor.
virtual int | Draw (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs)
Should be overridden by descendants for drawing itself.
virtual void | OnDrawControls (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CRect &rcItem)
Should be overridden by descendants for drawing itself.
CXTPGridRecordItemControl * | HitTest (CPoint ptPoint)
Determines which grid record item control, if any, is at a specified point.
virtual int | HitTestHyperlink (CPoint ptClick)
Determines if a mouse click occurred on a hyperlink.
virtual BOOL | OnLButtonDown (XTP_GRIDRECORDITEM_CLICKARGS *pClickArgs)
Processes mouse left button down clicks.
virtual BOOL | OnLButtonUp (XTP_GRIDRECORDITEM_CLICKARGS *pClickArgs)
Processes mouse left button up clicks.
virtual void | OnClick (XTP_GRIDRECORDITEM_CLICKARGS *pClickArgs)
Processes single mouse clicks.
virtual void | OnDblClick (XTP_GRIDRECORDITEM_CLICKARGS *pClickArgs)
Processes double mouse clicks.
virtual void | OnMouseMove (UINT nFlags, CPoint point, CXTPGridControl *pControl=NULL)
Processes the move mouse event.
CString | GetColumnCaptionPrefix (CXTPGridColumn *pColumn) const
Gets the caption prefix of a specified column.
virtual CString | GetGroupCaption (CXTPGridColumn *pColumn)
Gets the group caption text.
virtual COleVariant | GetGroupCaptionValue (CXTPGridColumn *pColumn)
Gets the group caption native value.
virtual int | GetGroupCaptionID (CXTPGridColumn *pColumn)
Gets the group caption ID.
virtual int | CompareGroupCaption (CXTPGridColumn *pColumn, CXTPGridRecordItem *pItem)
Compares the group caption of the current record item with the group caption of a provided record item/group row.
virtual int | CompareGroupCaption (CXTPGridColumn *pColumn, CXTPGridGroupRow *pGroupRow)
Compares the group caption of the current record item with the group caption of a provided record item/group row.
virtual int | Compare (CXTPGridColumn *pColumn, CXTPGridRecordItem *pItem)
Compares the current record item with a provided record item.
virtual void | SetFont (CFont *pFont)
Sets the record item text font.
virtual CFont * | GetFont ()
Gets the record item text font.
virtual CString | GetTooltip () const
Gets the tooltip text of the record item.
virtual void | SetTooltip (LPCTSTR lpszTooltip)
Sets the tooltip text for the record item.
virtual void | SetTextColor (COLORREF clrText)
Sets the record item text color.
virtual COLORREF | GetTextColor ()
Gets the record item text color.
virtual void | SetBold (BOOL bBold=TRUE)
Sets the bold state of the record item font.
virtual BOOL | IsBold () const
Determines the bold state of the record item font.
virtual void | SetBackgroundColor (COLORREF clrBackground)
Sets the record item text background color.
virtual COLORREF | GetBackgroundColor ()
Gets the record item text background color.
virtual CString | GetFormula () const
Gets the record item formula.
virtual void | SetFormula (LPCTSTR sFormula)
Sets the record item formula.
virtual CString | GetFormatString () const
Gets the record item caption format string.
virtual void | SetFormatString (LPCTSTR strFormat)
Sets the record item caption format string.
virtual BOOL | IsEditable () const
Determines the editable state of the record item.
virtual BOOL | SetEditable (BOOL bEditable=TRUE)
Sets the editable state for the record item.
virtual int | AddHyperlink (CXTPGridHyperlink *pHyperlink)
Adds a new hyperlink to the record item.
virtual int | GetHyperlinksCount () const
Gets the number of hyperlinks in the record item.
virtual CXTPGridHyperlink * | GetHyperlinkAt (int nHyperlink) const
Retrieves the hyperlink at a specified index.
virtual void | RemoveHyperlinkAt (int nHyperlink)
Removes the hyperlink at a specified index.
int | GetIndex () const
Gets the index of the record item.
virtual int | GetIconIndex () const
Gets the ID of the associated resource bitmap.
virtual int | SetIconIndex (int nIconIndex)
Sets the ID for the associated resource bitmap.
int | GetAlignment () const
Gets the alignment value of the record item.
int | SetAlignment (int nAlignment)
Sets the alignment value for the record item.
virtual int | GetSortPriority () const
Gets the sort priority of the record item.
virtual void | SetSortPriority (int nSortPriority)
Sets the sort priority for the record item.
virtual int | GetGroupPriority () const
Gets the group priority of the record item.
virtual void | SetGroupPriority (int nGroupPriority)
Sets the group priority for the record item.
virtual void | SetGroupCaption (LPCTSTR strCaption)
Sets the group caption for the record item.
void | UpdateValue ()
Causes formula computed value to be updated.
virtual void | SetChecked (BOOL bChecked)
Sets if the record item is checked.
virtual BOOL | IsChecked () const
Determines if the record item is checked.
void | SetCheckedState (int iState)
Sets the checked state for the record item.
int | GetCheckedState () const
Gets the checked state of the record item.
virtual void | HasCheckbox (BOOL bHasCheckbox, BOOL bTristate=FALSE)
Adds check box area for item.
virtual BOOL | GetHasCheckbox () const
Determines if item has check box area.
BOOL | GetCanEditCheckboxItem () const
Returns whether items with a check box will go into edit mode on click.
void | SetCanEditCheckboxItem (BOOL bSet)
Specifies whether items with a check box will go into edit mode on click.
void | SetRecord (CXTPGridRecord *pGridRecord)
Sets the parent record object.
CXTPGridRecord * | GetRecord () const
Gets the parent record object.
virtual DWORD_PTR | GetItemData () const
Retrieves the application-supplied, 32-bit value associated with the record item.
virtual void | SetItemData (DWORD_PTR dwData)
Sets the 32-bit value associated with the record item.
virtual BOOL | IsFocusable () const
Determines if the record item can receive focus.
virtual void | SetFocusable (BOOL bFocusable)
Specifies if the record item can receive focus.
CXTPMarkupUIElement * | GetMarkupUIElement () const
Gets the Markup element that renders the item.
virtual void | ResetMarkupUIElement ()
Resets the Markup element.
virtual INT_PTR | OnToolHitTest (CPoint point, TOOLINFO *pTI)
The framework calls this member function to determine whether a point is in the bounding rectangle of the specified tool.
BOOL | IsChildOfMerge () const
Determines if the current item is in a merge group and, if so, if it is not the left-top (main) item of the group.
virtual void | OnCancelEdit (CXTPGridControl *pControl, BOOL bApply)
This method is called when the user cancels editing an item.
virtual void | OnValidateEdit (XTP_GRIDRECORDITEM_ARGS *pItemArgs)
This method is called to save the value from an in-place edit.
virtual BOOL | OnEditChanging (XTP_GRIDRECORDITEM_ARGS *pItemArgs, CString &rstrNewText)
This method is called before the value of the in-place editor is changed by the user.
virtual void | OnEditCanceled (XTP_GRIDRECORDITEM_ARGS *pItemArgs)
This method is called when in-place editing has been canceled and the value has not changed.
virtual void | OnConstraintChanged (XTP_GRIDRECORDITEM_ARGS *pItemArgs, CXTPGridRecordItemConstraint *pConstraint)
This method is called when the value of the selected contraint of the in-place list is changed by the user.
virtual DWORD | GetSelectedConstraintData (XTP_GRIDRECORDITEM_ARGS *pItemArgs)
Gets the value associated with a selected constraint.
virtual void | OnInplaceButtonDown (CXTPGridInplaceButton *pButton)
This method is called when the user presses the in-place button of the item.
CXTPGridRecordItemEditOptions * | GetEditOptions (CXTPGridColumn *pColumn)
Gets the edit options of the item.
CXTPGridRecordItemControls * GetItemControls ()
Gets the item controls list.
BOOL | CreateBorder ()
Creates a border for this item.
BOOL | DestroyBorder ()
Destroys the border of this item.
CXTPGridBorder * | GetBorder () const
Gets the border of this item.
void | SetGridControl (CXTPGridControl *pControl)
Sets the parent grid object.
- Public Member Functions inherited from CXTPHeapObjectT< CXTPCmdTarget, CXTPGridDataAllocator >
void *PASCAL | operator new (size_t nSize)
Allocate memory block of nSize bytes.
void PASCAL | operator delete (void *p)
Free memory block previously allocated by operator new.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

virtual void | OnBeginEdit (XTP_GRIDRECORDITEM_ARGS *pItemArgs)
This method is called when the user begins to edit an item.
- Protected Member Functions inherited from CXTPGridRecordItem
virtual void | DrawCheckBox (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CRect &rcItem)
Draws the check box bitmap.
CXTPGridHyperlinks * GetHyperlinks ()
Gets the hyperlinks collection.
virtual BOOL | OnRequestEdit (XTP_GRIDRECORDITEM_ARGS *pItemArgs)
This method is called when an editable item enters edit mode.
virtual BOOL | OnChar (XTP_GRIDRECORDITEM_ARGS *pItemArgs, UINT nChar)
This method is called when the user presses a key.

Protected Attributes

CString | m_strPreviewText
Preview content.
- Protected Attributes inherited from CXTPGridRecordItem
CXTPGridControl * | m_pControl
Parent Grid control.
CXTPGridRecord * | m_pRecord
Pointer to the associated record.
CXTPGridBorder * | m_pBorder
Item border.
CFont * | m_pFontCaption
Storage for item caption font.
COLORREF | m_clrText
Storage for item text color.
COLORREF | m_clrBackground
Storage for item background color.
BOOL | m_bBoldText
TRUE if bold text.
CString | m_strFormatString
Stores string for extra formatting of item caption.
CString | m_strFormula
Stores Formula with simple algorithm to calculate.
BOOL | m_bEditable
Stores editable flag.
CXTPGridHyperlinks * | m_pHyperlinks
Array of the Item's hyperlinks.
int | m_nIconIndex
ID of the bitmap from the application resources.
int | m_nSortPriority
Sort priority.
int | m_nGroupPriority
Group priority.
CString | m_strGroupCaption
Caption of the group.
CString | m_strCaption
Caption of the item.
BOOL | m_bFocusable
TRUE if item accept focus.
int | m_checkState
TRUE if item checked.
BOOL | m_bHasCheckbox
TRUE if item has check box.
BOOL | m_bCanEditCheckboxItem
TRUE if an item with a check box will get an edit control (only useful if column is wide)
BOOL | m_bTristateCheckbox
TRUE if the check box is tri-state.
DWORD_PTR | m_dwData
The 32-bit value associated with the item.
CString | m_strTooltip
Tooltip of the item.
CXTPGridRecordItemEditOptions * | m_pEditOptions
Edit options of the item.
XTPGridColumnIconAlignment | m_Alignment
Alignment style for item.
CXTPGridRecordItemControls * | m_pItemControls
Record item control list.
CXTPGridRecordItemControl * | m_pFocusedItemControl
Focused record item control.
BOOL | m_bItemControlUnderMouse
TRUE if an item control is under the mouse pointer.
CXTPGridRecordItemControlHookWnd * | m_pItemControlHookWnd
Item control hook window.
CRect | m_rcGlyph
Coordinates of drawn glyph.
CXTPMarkupUIElement * | m_pMarkupUIElement
Markup element.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPGridRecordItem

Detailed Description

This represents a preview cell and inherits basic functionality from the CXTPGridRecordItem class.

You create a CXTPGridRecordItemPreview record item simply by calling its constructor with one parameter - its preview text.

See also
CXTPGridRecordItem

Constructor & Destructor Documentation

◆ CXTPGridRecordItemPreview()

CXTPGridRecordItemPreview ( LPCTSTR szPreviewText = _T("") )

Creates a new preview record item.

Parameters
szPreviewText Pointer to the preview text to set.

Member Function Documentation

◆ DoPropExchange()

virtual void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Call this member function to store/load a grid record item using the specified data object.

Parameters
pPX Source/destination CXTPPropExchange data object reference.

Reimplemented from CXTPGridRecordItem.

◆ GetCaption() [1/2]

virtual CString GetCaption ( )
virtual

Gets the text caption of the item.

Can be overridden by descendants.

Returns
The text caption of the item, or an empty string for a base record item class.

Reimplemented from CXTPGridRecordItem.

◆ GetCaption() [2/2]

CString GetCaption ( CXTPGridColumn * pColumn )
virtual

Gets the caption of the item.

Parameters
pColumn Pointer to the corresponding column of the item.
Returns
The caption of the item.

Reimplemented from CXTPGridRecordItem.

◆ GetCaptionRect()

virtual void GetCaptionRect | ( | XTP_GRIDRECORDITEM_ARGS * | pDrawArgs,
 |  | CRect & | rcItem )
 virtual

Retrieves the caption text of the bounding rectangle.

Parameters
pDrawArgs | Pointer to an XTP_GRIDRECORDITEM_DRAWARGS structure containing drawing arguments.
rcItem | Reference to a CRect object that receives the caption text bounding rectangle.

Reimplemented from CXTPGridRecordItem.

◆ GetItemMetrics()

virtual void GetItemMetrics | ( | XTP_GRIDRECORDITEM_DRAWARGS * | pDrawArgs,
 |  | XTP_GRIDRECORDITEM_METRICS * | pItemMetrics )
 virtual

Fills an XTP_GRIDRECORDITEM_METRICS structure.

Parameters
pDrawArgs | Pointer to an XTP_GRIDRECORDITEM_DRAWARGS structure containing drawing arguments used for calculating item metrics.
pItemMetrics | Pointer to an XTP_GRIDRECORDITEM_METRICS structure to fill with item metrics.

Calculates preview item metrics based on provided draw arguments. Overwrites parents' member function

See also
XTP_GRIDRECORDITEM_DRAWARGS, XTP_GRIDRECORDITEM_METRICS

Reimplemented from CXTPGridRecordItem.

◆ GetPreviewHeight()

virtual int GetPreviewHeight | ( | CDC * | pDC,
 |  | CXTPGridRow * | pRow,
 |  | int | nWidth )
 virtual

Retrieves the height of the preview area.

Parameters
pDC | Pointer to the control drawing context.
pRow | Pointer to the corresponding row.
nWidth | Width of the row.
Returns
The height of the preview area.

◆ GetPreviewText()

AFX_INLINE CString GetPreviewText ( )
virtual

Gets the preview text of the item.

Returns
The preview text of the item.

◆ IsPreviewItem()

AFX_INLINE BOOL IsPreviewItem ( ) const
virtual

Determines if the item is a preview item.

Returns
TRUE if the item is a preview item, otherwise FALSE.

Reimplemented from CXTPGridRecordItem.

◆ OnBeginEdit()

virtual void OnBeginEdit ( XTP_GRIDRECORDITEM_ARGS * pItemArgs )
protectedvirtual

This method is called when the user begins to edit an item.

Parameters
pItemArgs Pointer to an XTP_GRIDRECORDITEM_ARGS structure containing item arguments.

Reimplemented from CXTPGridRecordItem.

◆ OnDrawCaption()

virtual void OnDrawCaption | ( | XTP_GRIDRECORDITEM_DRAWARGS * | pDrawArgs,
 |  | XTP_GRIDRECORDITEM_METRICS * | pMetrics )
 virtual

Should be overridden by descendants for drawing itself.

Parameters
pDrawArgs | Pointer to an XTP_GRIDRECORDITEM_DRAWARGS structure containing drawing arguments.
pMetrics | Pointer to an XTP_GRIDRECORDITEM_METRICS structure containing item metrics.

Reimplemented from CXTPGridRecordItem.

◆ OnEditChanged()

virtual void OnEditChanged | ( | XTP_GRIDRECORDITEM_ARGS * | pItemArgs,
 |  | LPCTSTR | szText )
 virtual

This method is called when the value of the in-place edit control is changed.

Parameters
pItemArgs | Pointer to an XTP_GRIDRECORDITEM_ARGS structure containing item arguments.
szText | New in-place edit text.

Reimplemented from CXTPGridRecordItem.

◆ SetCaption()

virtual void SetCaption ( LPCTSTR strCaption )
virtual

Sets the caption for the item.

Parameters
strCaption New caption to be set.

Reimplemented from CXTPGridRecordItem.

◆ SetPreviewText()

void SetPreviewText ( LPCTSTR strPreviewText )

Set the preview text for the item.

Parameters
strPreviewText New preview text to be set.
The documentation for this class was generated from the following file:
  • XTPGridRecordItemPreview.h


Toolkit Pro: CXTPGridRecordItemText Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPGridRecordItemText Class Reference

This class represents a text-only cell and inherits basic functionality from the CXTPGridRecordItem class. More...

Inheritance diagram for CXTPGridRecordItemText:
[legend]

Public Member Functions

CXTPGridRecordItemText (LPCTSTR szText=_T(""))
Creates a record text item.
CString | GetCaption (CXTPGridColumn *pColumn)
Retrieves the text caption of the current item.
void | SetValue (LPCTSTR szText)
Sets the value for the item.
virtual void | OnEditChanged (XTP_GRIDRECORDITEM_ARGS *pItemArgs, LPCTSTR szText)
This method is called when the value of the in-place edit control is changed.
CString | GetValue ()
Gets the value of the item.
virtual void | DoPropExchange (CXTPPropExchange *pPX)
Call this member function to store/load a grid record item using the specified data object.
virtual CString | GetCaption ()
Gets the text caption of the item.
- Public Member Functions inherited from CXTPGridRecordItem
CXTPGridRecordItem ()
CXTPGridRecordItem default constructor.
virtual | ~CXTPGridRecordItem ()
CXTPGridRecordItem default destructor.
virtual int | Draw (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs)
Should be overridden by descendants for drawing itself.
virtual void | OnDrawCaption (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics)
Should be overridden by descendants for drawing itself.
virtual void | OnDrawControls (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CRect &rcItem)
Should be overridden by descendants for drawing itself.
CXTPGridRecordItemControl * | HitTest (CPoint ptPoint)
Determines which grid record item control, if any, is at a specified point.
virtual int | HitTestHyperlink (CPoint ptClick)
Determines if a mouse click occurred on a hyperlink.
virtual BOOL | OnLButtonDown (XTP_GRIDRECORDITEM_CLICKARGS *pClickArgs)
Processes mouse left button down clicks.
virtual BOOL | OnLButtonUp (XTP_GRIDRECORDITEM_CLICKARGS *pClickArgs)
Processes mouse left button up clicks.
virtual void | OnClick (XTP_GRIDRECORDITEM_CLICKARGS *pClickArgs)
Processes single mouse clicks.
virtual void | OnDblClick (XTP_GRIDRECORDITEM_CLICKARGS *pClickArgs)
Processes double mouse clicks.
virtual void | OnMouseMove (UINT nFlags, CPoint point, CXTPGridControl *pControl=NULL)
Processes the move mouse event.
CString | GetColumnCaptionPrefix (CXTPGridColumn *pColumn) const
Gets the caption prefix of a specified column.
virtual void | GetCaptionRect (XTP_GRIDRECORDITEM_ARGS *pDrawArgs, CRect &rcItem)
Retrieves the caption text bounding rectangle.
virtual CString | GetGroupCaption (CXTPGridColumn *pColumn)
Gets the group caption text.
virtual COleVariant | GetGroupCaptionValue (CXTPGridColumn *pColumn)
Gets the group caption native value.
virtual int | GetGroupCaptionID (CXTPGridColumn *pColumn)
Gets the group caption ID.
virtual int | CompareGroupCaption (CXTPGridColumn *pColumn, CXTPGridRecordItem *pItem)
Compares the group caption of the current record item with the group caption of a provided record item/group row.
virtual int | CompareGroupCaption (CXTPGridColumn *pColumn, CXTPGridGroupRow *pGroupRow)
Compares the group caption of the current record item with the group caption of a provided record item/group row.
virtual int | Compare (CXTPGridColumn *pColumn, CXTPGridRecordItem *pItem)
Compares the current record item with a provided record item.
virtual void | SetFont (CFont *pFont)
Sets the record item text font.
virtual CFont * | GetFont ()
Gets the record item text font.
virtual CString | GetTooltip () const
Gets the tooltip text of the record item.
virtual void | SetTooltip (LPCTSTR lpszTooltip)
Sets the tooltip text for the record item.
virtual void | SetTextColor (COLORREF clrText)
Sets the record item text color.
virtual COLORREF | GetTextColor ()
Gets the record item text color.
virtual void | SetBold (BOOL bBold=TRUE)
Sets the bold state of the record item font.
virtual BOOL | IsBold () const
Determines the bold state of the record item font.
virtual void | SetBackgroundColor (COLORREF clrBackground)
Sets the record item text background color.
virtual COLORREF | GetBackgroundColor ()
Gets the record item text background color.
virtual CString | GetFormula () const
Gets the record item formula.
virtual void | SetFormula (LPCTSTR sFormula)
Sets the record item formula.
virtual CString | GetFormatString () const
Gets the record item caption format string.
virtual void | SetFormatString (LPCTSTR strFormat)
Sets the record item caption format string.
virtual BOOL | IsEditable () const
Determines the editable state of the record item.
virtual BOOL | SetEditable (BOOL bEditable=TRUE)
Sets the editable state for the record item.
virtual int | AddHyperlink (CXTPGridHyperlink *pHyperlink)
Adds a new hyperlink to the record item.
virtual int | GetHyperlinksCount () const
Gets the number of hyperlinks in the record item.
virtual CXTPGridHyperlink * | GetHyperlinkAt (int nHyperlink) const
Retrieves the hyperlink at a specified index.
virtual void | RemoveHyperlinkAt (int nHyperlink)
Removes the hyperlink at a specified index.
virtual void | GetItemMetrics (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pItemMetrics)
Calculates preview item metrics based on specified draw arguments.
virtual BOOL | IsPreviewItem () const
Determines if the record item is a preview item.
int | GetIndex () const
Gets the index of the record item.
virtual int | GetIconIndex () const
Gets the ID of the associated resource bitmap.
virtual int | SetIconIndex (int nIconIndex)
Sets the ID for the associated resource bitmap.
int | GetAlignment () const
Gets the alignment value of the record item.
int | SetAlignment (int nAlignment)
Sets the alignment value for the record item.
virtual int | GetSortPriority () const
Gets the sort priority of the record item.
virtual void | SetSortPriority (int nSortPriority)
Sets the sort priority for the record item.
virtual int | GetGroupPriority () const
Gets the group priority of the record item.
virtual void | SetGroupPriority (int nGroupPriority)
Sets the group priority for the record item.
virtual void | SetGroupCaption (LPCTSTR strCaption)
Sets the group caption for the record item.
virtual void | SetCaption (LPCTSTR strCaption)
Sets the caption for the record item.
void | UpdateValue ()
Causes formula computed value to be updated.
virtual void | SetChecked (BOOL bChecked)
Sets if the record item is checked.
virtual BOOL | IsChecked () const
Determines if the record item is checked.
void | SetCheckedState (int iState)
Sets the checked state for the record item.
int | GetCheckedState () const
Gets the checked state of the record item.
virtual void | HasCheckbox (BOOL bHasCheckbox, BOOL bTristate=FALSE)
Adds check box area for item.
virtual BOOL | GetHasCheckbox () const
Determines if item has check box area.
BOOL | GetCanEditCheckboxItem () const
Returns whether items with a check box will go into edit mode on click.
void | SetCanEditCheckboxItem (BOOL bSet)
Specifies whether items with a check box will go into edit mode on click.
void | SetRecord (CXTPGridRecord *pGridRecord)
Sets the parent record object.
CXTPGridRecord * | GetRecord () const
Gets the parent record object.
virtual DWORD_PTR | GetItemData () const
Retrieves the application-supplied, 32-bit value associated with the record item.
virtual void | SetItemData (DWORD_PTR dwData)
Sets the 32-bit value associated with the record item.
virtual BOOL | IsFocusable () const
Determines if the record item can receive focus.
virtual void | SetFocusable (BOOL bFocusable)
Specifies if the record item can receive focus.
CXTPMarkupUIElement * | GetMarkupUIElement () const
Gets the Markup element that renders the item.
virtual void | ResetMarkupUIElement ()
Resets the Markup element.
virtual INT_PTR | OnToolHitTest (CPoint point, TOOLINFO *pTI)
The framework calls this member function to determine whether a point is in the bounding rectangle of the specified tool.
BOOL | IsChildOfMerge () const
Determines if the current item is in a merge group and, if so, if it is not the left-top (main) item of the group.
virtual void | OnCancelEdit (CXTPGridControl *pControl, BOOL bApply)
This method is called when the user cancels editing an item.
virtual void | OnValidateEdit (XTP_GRIDRECORDITEM_ARGS *pItemArgs)
This method is called to save the value from an in-place edit.
virtual BOOL | OnEditChanging (XTP_GRIDRECORDITEM_ARGS *pItemArgs, CString &rstrNewText)
This method is called before the value of the in-place editor is changed by the user.
virtual void | OnEditCanceled (XTP_GRIDRECORDITEM_ARGS *pItemArgs)
This method is called when in-place editing has been canceled and the value has not changed.
virtual void | OnConstraintChanged (XTP_GRIDRECORDITEM_ARGS *pItemArgs, CXTPGridRecordItemConstraint *pConstraint)
This method is called when the value of the selected contraint of the in-place list is changed by the user.
virtual DWORD | GetSelectedConstraintData (XTP_GRIDRECORDITEM_ARGS *pItemArgs)
Gets the value associated with a selected constraint.
virtual void | OnInplaceButtonDown (CXTPGridInplaceButton *pButton)
This method is called when the user presses the in-place button of the item.
CXTPGridRecordItemEditOptions * | GetEditOptions (CXTPGridColumn *pColumn)
Gets the edit options of the item.
CXTPGridRecordItemControls * GetItemControls ()
Gets the item controls list.
BOOL | CreateBorder ()
Creates a border for this item.
BOOL | DestroyBorder ()
Destroys the border of this item.
CXTPGridBorder * | GetBorder () const
Gets the border of this item.
void | SetGridControl (CXTPGridControl *pControl)
Sets the parent grid object.
- Public Member Functions inherited from CXTPHeapObjectT< CXTPCmdTarget, CXTPGridDataAllocator >
void *PASCAL | operator new (size_t nSize)
Allocate memory block of nSize bytes.
void PASCAL | operator delete (void *p)
Free memory block previously allocated by operator new.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Attributes

CString | m_strText
Item text value.
- Protected Attributes inherited from CXTPGridRecordItem
CXTPGridControl * | m_pControl
Parent Grid control.
CXTPGridRecord * | m_pRecord
Pointer to the associated record.
CXTPGridBorder * | m_pBorder
Item border.
CFont * | m_pFontCaption
Storage for item caption font.
COLORREF | m_clrText
Storage for item text color.
COLORREF | m_clrBackground
Storage for item background color.
BOOL | m_bBoldText
TRUE if bold text.
CString | m_strFormatString
Stores string for extra formatting of item caption.
CString | m_strFormula
Stores Formula with simple algorithm to calculate.
BOOL | m_bEditable
Stores editable flag.
CXTPGridHyperlinks * | m_pHyperlinks
Array of the Item's hyperlinks.
int | m_nIconIndex
ID of the bitmap from the application resources.
int | m_nSortPriority
Sort priority.
int | m_nGroupPriority
Group priority.
CString | m_strGroupCaption
Caption of the group.
CString | m_strCaption
Caption of the item.
BOOL | m_bFocusable
TRUE if item accept focus.
int | m_checkState
TRUE if item checked.
BOOL | m_bHasCheckbox
TRUE if item has check box.
BOOL | m_bCanEditCheckboxItem
TRUE if an item with a check box will get an edit control (only useful if column is wide)
BOOL | m_bTristateCheckbox
TRUE if the check box is tri-state.
DWORD_PTR | m_dwData
The 32-bit value associated with the item.
CString | m_strTooltip
Tooltip of the item.
CXTPGridRecordItemEditOptions * | m_pEditOptions
Edit options of the item.
XTPGridColumnIconAlignment | m_Alignment
Alignment style for item.
CXTPGridRecordItemControls * | m_pItemControls
Record item control list.
CXTPGridRecordItemControl * | m_pFocusedItemControl
Focused record item control.
BOOL | m_bItemControlUnderMouse
TRUE if an item control is under the mouse pointer.
CXTPGridRecordItemControlHookWnd * | m_pItemControlHookWnd
Item control hook window.
CRect | m_rcGlyph
Coordinates of drawn glyph.
CXTPMarkupUIElement * | m_pMarkupUIElement
Markup element.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPGridRecordItem
- Protected Member Functions inherited from CXTPGridRecordItem
virtual void | DrawCheckBox (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CRect &rcItem)
Draws the check box bitmap.
CXTPGridHyperlinks * GetHyperlinks ()
Gets the hyperlinks collection.
virtual BOOL | OnRequestEdit (XTP_GRIDRECORDITEM_ARGS *pItemArgs)
This method is called when an editable item enters edit mode.
virtual void | OnBeginEdit (XTP_GRIDRECORDITEM_ARGS *pItemArgs)
This method is called when the user begins to edit an item.
virtual BOOL | OnChar (XTP_GRIDRECORDITEM_ARGS *pItemArgs, UINT nChar)
This method is called when the user presses a key.

Detailed Description

This class represents a text-only cell and inherits basic functionality from the CXTPGridRecordItem class.

You create a text record item simply by calling a constructor with one parameter - its text value.

See also
CXTPGridRecordItem

Constructor & Destructor Documentation

◆ CXTPGridRecordItemText()

CXTPGridRecordItemText ( LPCTSTR szText = _T("") )

Creates a record text item.

Parameters
szText Text item value to set.

Member Function Documentation

◆ DoPropExchange()

virtual void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Call this member function to store/load a grid record item using the specified data object.

Parameters
pPX Source/destination CXTPPropExchange data object reference.

Reimplemented from CXTPGridRecordItem.

◆ GetCaption() [1/2]

virtual CString GetCaption ( )
virtual

Gets the text caption of the item.

Can be overridden by descendants.

Returns
The text caption of the item, or an empty string for a base record item class.

Reimplemented from CXTPGridRecordItem.

◆ GetCaption() [2/2]

CString GetCaption ( CXTPGridColumn * pColumn )
virtual

Retrieves the text caption of the current item.

Parameters
pColumn Pointer to the corresponding column of the current item.

Overwrites parents' member function.

Returns
The text caption of the current item.

Reimplemented from CXTPGridRecordItem.

◆ GetValue()

AFX_INLINE CString GetValue ( )

Gets the value of the item.

Returns
The text item value.

◆ OnEditChanged()

virtual void OnEditChanged | ( | XTP_GRIDRECORDITEM_ARGS * | pItemArgs,
 |  | LPCTSTR | szText )
 virtual

This method is called when the value of the in-place edit control is changed.

Parameters
pItemArgs | Pointer to an XTP_GRIDRECORDITEM_ARGS structure containing item arguments.
szText | New in-place edit text.

Reimplemented from CXTPGridRecordItem.

◆ SetValue()

void SetValue ( LPCTSTR szText )

Sets the value for the item.

Parameters
szText New text item value.
The documentation for this class was generated from the following file:
  • XTPGridRecordItemText.h


Toolkit Pro: CXTPGridRecordItemVariant Class Reference

Public Member Functions | Public Attributes | Static Public Attributes | Protected Member Functions | List of all members
CXTPGridRecordItemVariant Class Reference

Represents a variant item and inherits basic functionality from the CXTPGridRecordItem class. More...

Inheritance diagram for CXTPGridRecordItemVariant:
[legend]

Public Member Functions

CXTPGridRecordItemVariant (const VARIANT &lpValue=COleVariant((long) 0))
Creates a record variant item.
CString | GetCaption (CXTPGridColumn *pColumn)
Retrieves the text caption of the current item.
void | SetValue (const COleVariant &var)
Sets the value for the item.
void | SetValue (const VARIANT &var)
Sets the value for the item.
void | SetValue (const VARIANT *var)
Sets the value for the item.
COleVariant | GetValue ()
Gets the value of the item.
int | Compare (CXTPGridColumn *pCol, CXTPGridRecordItem *pItem)
Compares the current item with a provided item.
virtual COleVariant | GetGroupCaptionValue (CXTPGridColumn *pColumn)
Retrieves the group caption native value.
virtual int | CompareGroupCaption (CXTPGridColumn *pColumn, CXTPGridGroupRow *pGroupRow)
Compares the group caption of the current record item with the group caption of a provided group row.
virtual void | OnEditChanged (XTP_GRIDRECORDITEM_ARGS *pItemArgs, LPCTSTR szText)
This method is called when the value of the in-place edit control is changed.
void | OnConstraintChanged (XTP_GRIDRECORDITEM_ARGS *pItemArgs, CXTPGridRecordItemConstraint *pConstraint)
This method is called when the value of the selected contraint of the in-place list is changed by the user.
DWORD | GetSelectedConstraintData (XTP_GRIDRECORDITEM_ARGS *pItemArgs)
Retrieves the value associated with the selected constraint.
virtual void | DoPropExchange (CXTPPropExchange *pPX)
Call this member function to store/load a grid record item using the specified data object.
virtual CString | GetCaption ()
Gets the text caption of the item.
virtual int | CompareGroupCaption (CXTPGridColumn *pColumn, CXTPGridRecordItem *pItem)
Compares the group caption of the current record item with the group caption of a provided record item/group row.
- Public Member Functions inherited from CXTPGridRecordItem
CXTPGridRecordItem ()
CXTPGridRecordItem default constructor.
virtual | ~CXTPGridRecordItem ()
CXTPGridRecordItem default destructor.
virtual int | Draw (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs)
Should be overridden by descendants for drawing itself.
virtual void | OnDrawCaption (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics)
Should be overridden by descendants for drawing itself.
virtual void | OnDrawControls (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CRect &rcItem)
Should be overridden by descendants for drawing itself.
CXTPGridRecordItemControl * | HitTest (CPoint ptPoint)
Determines which grid record item control, if any, is at a specified point.
virtual int | HitTestHyperlink (CPoint ptClick)
Determines if a mouse click occurred on a hyperlink.
virtual BOOL | OnLButtonDown (XTP_GRIDRECORDITEM_CLICKARGS *pClickArgs)
Processes mouse left button down clicks.
virtual BOOL | OnLButtonUp (XTP_GRIDRECORDITEM_CLICKARGS *pClickArgs)
Processes mouse left button up clicks.
virtual void | OnClick (XTP_GRIDRECORDITEM_CLICKARGS *pClickArgs)
Processes single mouse clicks.
virtual void | OnDblClick (XTP_GRIDRECORDITEM_CLICKARGS *pClickArgs)
Processes double mouse clicks.
virtual void | OnMouseMove (UINT nFlags, CPoint point, CXTPGridControl *pControl=NULL)
Processes the move mouse event.
CString | GetColumnCaptionPrefix (CXTPGridColumn *pColumn) const
Gets the caption prefix of a specified column.
virtual void | GetCaptionRect (XTP_GRIDRECORDITEM_ARGS *pDrawArgs, CRect &rcItem)
Retrieves the caption text bounding rectangle.
virtual CString | GetGroupCaption (CXTPGridColumn *pColumn)
Gets the group caption text.
virtual int | GetGroupCaptionID (CXTPGridColumn *pColumn)
Gets the group caption ID.
virtual void | SetFont (CFont *pFont)
Sets the record item text font.
virtual CFont * | GetFont ()
Gets the record item text font.
virtual CString | GetTooltip () const
Gets the tooltip text of the record item.
virtual void | SetTooltip (LPCTSTR lpszTooltip)
Sets the tooltip text for the record item.
virtual void | SetTextColor (COLORREF clrText)
Sets the record item text color.
virtual COLORREF | GetTextColor ()
Gets the record item text color.
virtual void | SetBold (BOOL bBold=TRUE)
Sets the bold state of the record item font.
virtual BOOL | IsBold () const
Determines the bold state of the record item font.
virtual void | SetBackgroundColor (COLORREF clrBackground)
Sets the record item text background color.
virtual COLORREF | GetBackgroundColor ()
Gets the record item text background color.
virtual CString | GetFormula () const
Gets the record item formula.
virtual void | SetFormula (LPCTSTR sFormula)
Sets the record item formula.
virtual CString | GetFormatString () const
Gets the record item caption format string.
virtual void | SetFormatString (LPCTSTR strFormat)
Sets the record item caption format string.
virtual BOOL | IsEditable () const
Determines the editable state of the record item.
virtual BOOL | SetEditable (BOOL bEditable=TRUE)
Sets the editable state for the record item.
virtual int | AddHyperlink (CXTPGridHyperlink *pHyperlink)
Adds a new hyperlink to the record item.
virtual int | GetHyperlinksCount () const
Gets the number of hyperlinks in the record item.
virtual CXTPGridHyperlink * | GetHyperlinkAt (int nHyperlink) const
Retrieves the hyperlink at a specified index.
virtual void | RemoveHyperlinkAt (int nHyperlink)
Removes the hyperlink at a specified index.
virtual void | GetItemMetrics (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pItemMetrics)
Calculates preview item metrics based on specified draw arguments.
virtual BOOL | IsPreviewItem () const
Determines if the record item is a preview item.
int | GetIndex () const
Gets the index of the record item.
virtual int | GetIconIndex () const
Gets the ID of the associated resource bitmap.
virtual int | SetIconIndex (int nIconIndex)
Sets the ID for the associated resource bitmap.
int | GetAlignment () const
Gets the alignment value of the record item.
int | SetAlignment (int nAlignment)
Sets the alignment value for the record item.
virtual int | GetSortPriority () const
Gets the sort priority of the record item.
virtual void | SetSortPriority (int nSortPriority)
Sets the sort priority for the record item.
virtual int | GetGroupPriority () const
Gets the group priority of the record item.
virtual void | SetGroupPriority (int nGroupPriority)
Sets the group priority for the record item.
virtual void | SetGroupCaption (LPCTSTR strCaption)
Sets the group caption for the record item.
virtual void | SetCaption (LPCTSTR strCaption)
Sets the caption for the record item.
void | UpdateValue ()
Causes formula computed value to be updated.
virtual void | SetChecked (BOOL bChecked)
Sets if the record item is checked.
virtual BOOL | IsChecked () const
Determines if the record item is checked.
void | SetCheckedState (int iState)
Sets the checked state for the record item.
int | GetCheckedState () const
Gets the checked state of the record item.
virtual void | HasCheckbox (BOOL bHasCheckbox, BOOL bTristate=FALSE)
Adds check box area for item.
virtual BOOL | GetHasCheckbox () const
Determines if item has check box area.
BOOL | GetCanEditCheckboxItem () const
Returns whether items with a check box will go into edit mode on click.
void | SetCanEditCheckboxItem (BOOL bSet)
Specifies whether items with a check box will go into edit mode on click.
void | SetRecord (CXTPGridRecord *pGridRecord)
Sets the parent record object.
CXTPGridRecord * | GetRecord () const
Gets the parent record object.
virtual DWORD_PTR | GetItemData () const
Retrieves the application-supplied, 32-bit value associated with the record item.
virtual void | SetItemData (DWORD_PTR dwData)
Sets the 32-bit value associated with the record item.
virtual BOOL | IsFocusable () const
Determines if the record item can receive focus.
virtual void | SetFocusable (BOOL bFocusable)
Specifies if the record item can receive focus.
CXTPMarkupUIElement * | GetMarkupUIElement () const
Gets the Markup element that renders the item.
virtual void | ResetMarkupUIElement ()
Resets the Markup element.
virtual INT_PTR | OnToolHitTest (CPoint point, TOOLINFO *pTI)
The framework calls this member function to determine whether a point is in the bounding rectangle of the specified tool.
BOOL | IsChildOfMerge () const
Determines if the current item is in a merge group and, if so, if it is not the left-top (main) item of the group.
virtual void | OnCancelEdit (CXTPGridControl *pControl, BOOL bApply)
This method is called when the user cancels editing an item.
virtual void | OnValidateEdit (XTP_GRIDRECORDITEM_ARGS *pItemArgs)
This method is called to save the value from an in-place edit.
virtual void | OnEditCanceled (XTP_GRIDRECORDITEM_ARGS *pItemArgs)
This method is called when in-place editing has been canceled and the value has not changed.
virtual void | OnInplaceButtonDown (CXTPGridInplaceButton *pButton)
This method is called when the user presses the in-place button of the item.
CXTPGridRecordItemEditOptions * | GetEditOptions (CXTPGridColumn *pColumn)
Gets the edit options of the item.
CXTPGridRecordItemControls * GetItemControls ()
Gets the item controls list.
BOOL | CreateBorder ()
Creates a border for this item.
BOOL | DestroyBorder ()
Destroys the border of this item.
CXTPGridBorder * | GetBorder () const
Gets the border of this item.
void | SetGridControl (CXTPGridControl *pControl)
Sets the parent grid object.
- Public Member Functions inherited from CXTPHeapObjectT< CXTPCmdTarget, CXTPGridDataAllocator >
void *PASCAL | operator new (size_t nSize)
Allocate memory block of nSize bytes.
void PASCAL | operator delete (void *p)
Free memory block previously allocated by operator new.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Public Attributes

COleVariant m_oleValue
Item value.
- Public Attributes inherited from CXTPGridRecordItem

Static Public Attributes

static int m_nSortLocale
Sort locale.

Protected Member Functions

virtual BOOL | OnValueChanging (XTP_GRIDRECORDITEM_ARGS *pItemArgs, LPVARIANT lpNewValue)
This method is called before the value of the item is changed by the user.
virtual BOOL | OnEditChanging (XTP_GRIDRECORDITEM_ARGS *pItemArgs, CString &rstrNewText)
This method is called before the value of the in-place editor is changed by the user.
- Protected Member Functions inherited from CXTPGridRecordItem
virtual void | DrawCheckBox (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CRect &rcItem)
Draws the check box bitmap.
CXTPGridHyperlinks * GetHyperlinks ()
Gets the hyperlinks collection.
virtual BOOL | OnRequestEdit (XTP_GRIDRECORDITEM_ARGS *pItemArgs)
This method is called when an editable item enters edit mode.
virtual void | OnBeginEdit (XTP_GRIDRECORDITEM_ARGS *pItemArgs)
This method is called when the user begins to edit an item.
virtual BOOL | OnChar (XTP_GRIDRECORDITEM_ARGS *pItemArgs, UINT nChar)
This method is called when the user presses a key.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Attributes inherited from CXTPGridRecordItem
CXTPGridControl * | m_pControl
Parent Grid control.
CXTPGridRecord * | m_pRecord
Pointer to the associated record.
CXTPGridBorder * | m_pBorder
Item border.
CFont * | m_pFontCaption
Storage for item caption font.
COLORREF | m_clrText
Storage for item text color.
COLORREF | m_clrBackground
Storage for item background color.
BOOL | m_bBoldText
TRUE if bold text.
CString | m_strFormatString
Stores string for extra formatting of item caption.
CString | m_strFormula
Stores Formula with simple algorithm to calculate.
BOOL | m_bEditable
Stores editable flag.
CXTPGridHyperlinks * | m_pHyperlinks
Array of the Item's hyperlinks.
int | m_nIconIndex
ID of the bitmap from the application resources.
int | m_nSortPriority
Sort priority.
int | m_nGroupPriority
Group priority.
CString | m_strGroupCaption
Caption of the group.
CString | m_strCaption
Caption of the item.
BOOL | m_bFocusable
TRUE if item accept focus.
int | m_checkState
TRUE if item checked.
BOOL | m_bHasCheckbox
TRUE if item has check box.
BOOL | m_bCanEditCheckboxItem
TRUE if an item with a check box will get an edit control (only useful if column is wide)
BOOL | m_bTristateCheckbox
TRUE if the check box is tri-state.
DWORD_PTR | m_dwData
The 32-bit value associated with the item.
CString | m_strTooltip
Tooltip of the item.
CXTPGridRecordItemEditOptions * | m_pEditOptions
Edit options of the item.
XTPGridColumnIconAlignment | m_Alignment
Alignment style for item.
CXTPGridRecordItemControls * | m_pItemControls
Record item control list.
CXTPGridRecordItemControl * | m_pFocusedItemControl
Focused record item control.
BOOL | m_bItemControlUnderMouse
TRUE if an item control is under the mouse pointer.
CXTPGridRecordItemControlHookWnd * | m_pItemControlHookWnd
Item control hook window.
CRect | m_rcGlyph
Coordinates of drawn glyph.
CXTPMarkupUIElement * | m_pMarkupUIElement
Markup element.

Detailed Description

Represents a variant item and inherits basic functionality from the CXTPGridRecordItem class.

You can create a bitmap record item simply by calling a constructor with one parameter - a value of VARIANT type.

See also
CXTPGridRecordItem

Constructor & Destructor Documentation

◆ CXTPGridRecordItemVariant()

CXTPGridRecordItemVariant ( const VARIANT & lpValue = COleVariant((long) 0) )

Creates a record variant item.

Parameters
lpValue Pointer to the VARIANT item value to set.

Member Function Documentation

◆ Compare()

int Compare | ( | CXTPGridColumn * | pCol,
 |  | CXTPGridRecordItem * | pItem )
 virtual

Compares the current item with a provided item.

Parameters
pCol | Pointer to the corresponding column of the current item.
pItem | Pointer to the item to compare with the current item.

Overwrites parents' member function.

Returns
Zero if the current item is equal to pItem; Less than zero if the current item is less than pItem; Greater than zero if the current item is greater than pItem.

Reimplemented from CXTPGridRecordItem.

◆ CompareGroupCaption() [1/2]

virtual int CompareGroupCaption | ( | CXTPGridColumn * | pColumn,
 |  | CXTPGridGroupRow * | pGroupRow )
 virtual

Compares the group caption of the current record item with the group caption of a provided group row.

Parameters
pColumn | Pointer to the corresponding column of the current record item.
pGroupRow | Pointer to the group row with the group caption to compare with the group caption of the current record item.
Returns
Zero if the group caption of the current record item is identical to the group caption of pGroupRow; Less than zero if the group caption of the current record item is less than the group caption of pGroupRow; Greater than zero if the group caption of the current record item is greater than the group caption of pGroupRow.

Reimplemented from CXTPGridRecordItem.

◆ CompareGroupCaption() [2/2]

virtual int CompareGroupCaption | ( | CXTPGridColumn * | pColumn,
 |  | CXTPGridRecordItem * | pItem )
 virtual

Compares the group caption of the current record item with the group caption of a provided record item/group row.

Parameters
pColumn | Pointer to the corresponding column of the current record item.
pItem | Pointer to the record item with the group caption to compare with the group caption of the current record item.
Returns
Zero if the group caption of the current record item is identical to the group caption of pItem/pGroupRow; Less than zero if the group caption of the current record item is less than the group caption of pItem/pGroupRow; Greater than zero if the group caption of the current record item is greater than the group caption of pItem/pGroupRow.

Reimplemented from CXTPGridRecordItem.

◆ DoPropExchange()

virtual void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Call this member function to store/load a grid record item using the specified data object.

Parameters
pPX Source/destination CXTPPropExchange data object reference.

Reimplemented from CXTPGridRecordItem.

◆ GetCaption() [1/2]

virtual CString GetCaption ( )
virtual

Gets the text caption of the item.

Can be overridden by descendants.

Returns
The text caption of the item, or an empty string for a base record item class.

Reimplemented from CXTPGridRecordItem.

◆ GetCaption() [2/2]

CString GetCaption ( CXTPGridColumn * pColumn )
virtual

Retrieves the text caption of the current item.

Parameters
pColumn Pointer to the corresponding column of the current item.

Overwrites parents' member function.

Returns
The text caption of the current item.

Reimplemented from CXTPGridRecordItem.

◆ GetGroupCaptionValue()

virtual COleVariant GetGroupCaptionValue ( CXTPGridColumn * pColumn )
virtual

Retrieves the group caption native value.

Parameters
pColumn Pointer to a CXTPGridColumn object.
Returns
The group caption native value.

Reimplemented from CXTPGridRecordItem.

◆ GetSelectedConstraintData()

DWORD GetSelectedConstraintData ( XTP_GRIDRECORDITEM_ARGS * pItemArgs )
virtual

Retrieves the value associated with the selected constraint.

Parameters
pItemArgs Pointer to an XTP_GRIDRECORDITEM_ARGS structure containing item arguments.
Returns
The value associated with the selected constraint.

Reimplemented from CXTPGridRecordItem.

◆ GetValue()

COleVariant GetValue ( )

Gets the value of the item.

Returns
The VARIANT item value.

◆ OnConstraintChanged()

void OnConstraintChanged | ( | XTP_GRIDRECORDITEM_ARGS * | pItemArgs,
 |  | CXTPGridRecordItemConstraint * | pConstraint )
 virtual

This method is called when the value of the selected contraint of the in-place list is changed by the user.

Parameters
pItemArgs | Pointer to an XTP_GRIDRECORDITEM_ARGS structure containing item arguments.
pConstraint | Pointer to the selected constraint.

Reimplemented from CXTPGridRecordItem.

◆ OnEditChanged()

virtual void OnEditChanged | ( | XTP_GRIDRECORDITEM_ARGS * | pItemArgs,
 |  | LPCTSTR | szText )
 virtual

This method is called when the value of the in-place edit control is changed.

Parameters
pItemArgs | Pointer to an XTP_GRIDRECORDITEM_ARGS structure containing item arguments.
szText | New in-place edit text.

Reimplemented from CXTPGridRecordItem.

◆ OnEditChanging()

virtual BOOL OnEditChanging | ( | XTP_GRIDRECORDITEM_ARGS * | pItemArgs,
 |  | CString & | rstrNewText )
 protectedvirtual

This method is called before the value of the in-place editor is changed by the user.

Parameters
pItemArgs | Pointer to an XTP_GRIDRECORDITEM_ARGS structure containing item arguments.
rstrNewText | New string to be set in the editor.
Returns
FALSE to cancel the edit operation.

Reimplemented from CXTPGridRecordItem.

◆ OnValueChanging()

virtual BOOL OnValueChanging | ( | XTP_GRIDRECORDITEM_ARGS * | pItemArgs,
 |  | LPVARIANT | lpNewValue )
 protectedvirtual

This method is called before the value of the item is changed by the user.

Parameters
pItemArgs | Pointer to an XTP_GRIDRECORDITEM_ARGS structure containing item arguments.
lpNewValue | New value to be set.
Returns
FALSE to cancel the edit operation.

◆ SetValue() [1/3]

void SetValue ( const COleVariant & var )

Sets the value for the item.

Parameters
var Reference to the new COleVarient item value.

◆ SetValue() [2/3]

void SetValue ( const VARIANT & var )

Sets the value for the item.

Parameters
var Reference to the new VARIANT item value.

◆ SetValue() [3/3]

void SetValue ( const VARIANT * var )

Sets the value for the item.

Parameters
var Pointer to the new VARIANT item value.
The documentation for this class was generated from the following file:
  • XTPGridRecordItemVariant.h


Toolkit Pro: CXTPGridRecords Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPGridRecords Class Reference

This class represents a grid records collection. More...

Inheritance diagram for CXTPGridRecords:
[legend]

Public Member Functions

CXTPGridRecords (BOOL bArray=FALSE)
Constructs an empty CXTPGridRecord pointer array.
CXTPGridRecords (CXTPGridRecord *pOwnerRecord)
Constructs an empty CXTPGridRecord pointer array in case it is used as a member of a CXTPGridRecord object to store children.
virtual | ~CXTPGridRecords ()
Destroys a CXTPGridRecords object, handles cleanup and deallocation.
CXTPGridRecord * | GetOwnerRecord () const
Obtains an associated owner record pointer.
int | GetCount () const
Gets the number of record elements in this collection.
CXTPGridRecord * | GetAt (int nIndex) const
Gets the record element at a specified numeric index in this collection.
CXTPGridRecord * | Add (CXTPGridRecord *pRecord)
Adds a new record element to the end of this collection.
virtual void | DoPropExchange (CXTPPropExchange *pPX)
Call this member function to store/load a grid records collection.
void | RemoveAll ()
Removes all the elements from this collection.
void | RemoveAt (int nIndex)
Removes a specified record from this collection by its index.
int | RemoveRecord (CXTPGridRecord *pRecord)
Removes a specified record from this collection.
void | InsertAt (int nIndex, CXTPGridRecord *pRecord)
Inserts a specified record at a specified index in this collection.
void | Move (int nIndex, CXTPGridRecords *pRecords)
Moves specified records to a specified index in this collection.
void | MoveRecord (int nIndex, CXTPGridRecord *pRecord, BOOL bUpdateIndexes=FALSE)
Moves a specified record to a specified index in this collection.
CXTPMarkupContext * | GetMarkupContext () const
Gets the markup context.
void | SetMarkupContext (CXTPMarkupContext *pMarkupContext)
Sets the markup context.
void | SetCaseSensitive (BOOL bCaseSensitive)
Specifies if string comparisons should be case-sensitive.
BOOL | IsCaseSensitive () const
Determines if string comparisons are case-sensitive.
virtual int | Compare (const CString &str1, const CString &str2) const
Helper function to compare two strings.
virtual void | SetSize (INT_PTR nNewSize, INT_PTR nGrowBy=-1)
Changes the size of this collection.
virtual void | SetAt (INT_PTR nIndex, CXTPGridRecord *pRecord)
Sets a specified record element to a specified index in this collection.
virtual void | UpdateIndexes (int nStart=0)
Updates record element indices.
virtual CXTPGridRecord * | FindRecordByBookmark (VARIANT vtBookmark, BOOL bSearchInChildren)
Retrieves a record element by its bookmark.
virtual CXTPGridRecordItem * | FindRecordItem (int nStartRecord, int nEndRecord, int nStartColumn, int nEndColumn, int nRecord, int nItem, LPCTSTR pcszText, int nFlags)
Retrieves a record item by its text.
virtual void | PrepareToDropping (CXTPGridRecord *pTargetRecord, CXTPGridRecords *pTargetRecords, BOOL bChangeParent)
This method is called before record dropping is processed.
virtual void | CleanOfRedundant ()
Removes redundant records.
- Public Member Functions inherited from CXTPHeapObjectT< CXTPCmdTarget, CXTPGridDataAllocator >
void *PASCAL | operator new (size_t nSize)
Allocate memory block of nSize bytes.
void PASCAL | operator delete (void *p)
Free memory block previously allocated by operator new.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Attributes

CArray< CXTPGridRecord *, CXTPGridRecord * > | m_arrRecords
Internal storage array for record items.
int | m_nVirtualRecordsCount
Virtual records count.
CXTPGridControl * | m_pControl
Pointer to the parent Grid control.
BOOL | m_bCaseSensitive
Indicates whether string comparisons are case-sensitive.
CXTPGridRecord * | m_pOwnerRecord
Pointer to the owner record object (or NULL).
CXTPMarkupContext * | m_pMarkupContext
Markup context;.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

This class represents a grid records collection.

It supports an array of CXTPGridRecord pointers.

Example: See example for the CXTPGridRecords::Add method.

See also
CXTPGridRecord

Constructor & Destructor Documentation

◆ CXTPGridRecords() [1/2]

CXTPGridRecords ( BOOL bArray = FALSE )

Constructs an empty CXTPGridRecord pointer array.

Parameters
bArray Flag for array-based case (if TRUE).

Example:

// Declare a local CXTPGridRecords object.
CXTPGridRecords myList;

// Declare a dynamic CXTPGridRecords object.
CXTPGridRecords* pTree = new CXTPGridRecords();

◆ CXTPGridRecords() [2/2]

CXTPGridRecords ( CXTPGridRecord * pOwnerRecord )

Constructs an empty CXTPGridRecord pointer array in case it is used as a member of a CXTPGridRecord object to store children.

Parameters
pOwnerRecord Pointer to the owner CXTPGridRecord object.

Member Function Documentation

◆ Add()

CXTPGridRecord * Add ( CXTPGridRecord * pRecord )

Adds a new record element to the end of this collection.

Parameters
pRecord Pointer to the new record element to be added.

Use this method to add a specified CXTPGridRecord pointer to the end of the CXTPGridRecords collection.

Returns
A pointer to the newly added record element.

Example:

CXTPGridRecords* pList = new CXTPGridRecords();
pList->Add(new CXTPGridRecord());
pList->Add(new CXTPGridRecord());
CXTPGridRecord* pRecord0 = pList->GetAt(0);
CXTPGridRecord* pRecord1 = pList->GetAt(1);
_ASSERTE(2 == pList->GetCount());
pList->RemoveAll();
_ASSERTE(0 == pList->GetCount());
See also
CXTPGridRecords overview, GetAt, RemoveAll, GetCount

◆ Compare()

virtual int Compare | ( | const CString & | str1,
 |  | const CString & | str2 ) const
 virtual

Helper function to compare two strings.

Parameters
str1 | First string to compare.
str2 | Second string to compare.
Returns
Zero if str1 is identical to str2; Less than zero if str1 is less than str2; Greater than zero if str1 is greater than str2.
See also
SetCaseSensitive

◆ DoPropExchange()

virtual void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Call this member function to store/load a grid records collection.

Parameters
pPX Source/destination CXTPPropExchange data object reference.

◆ FindRecordByBookmark()

virtual CXTPGridRecord * FindRecordByBookmark | ( | VARIANT | vtBookmark,
 |  | BOOL | bSearchInChildren )
 virtual

Retrieves a record element by its bookmark.

Parameters
vtBookmark | Bookmark of the record element to retrieve.
bSearchInChildren | TRUE to search in children too, FALSE otherwise.
Returns
A pointer to the record element if successful, otherwise NULL.

◆ FindRecordItem()

virtual CXTPGridRecordItem * FindRecordItem | ( | int | nStartRecord,
 |  | int | nEndRecord,
 |  | int | nStartColumn,
 |  | int | nEndColumn,
 |  | int | nRecord,
 |  | int | nItem,
 |  | LPCTSTR | pcszText,
 |  | int | nFlags )
 virtual

Retrieves a record item by its text.

Parameters
nStartRecord | Starting record index.
nEndRecord | Ending record index.
nStartColumn | Starting column index.
nEndColumn | Ending column index.
nRecord | Record index to start the search from.
nItem | Record item index to start the search from.
pcszText | Search text.
nFlags | Search parameters.
Returns
A pointer to the record item if successful, otherwise NULL.

◆ GetAt()

CXTPGridRecord * GetAt ( int nIndex ) const

Gets the record element at a specified numeric index in this collection.

Parameters
nIndex Integer index that is greater than or equal to 0 and less than the value returned by GetCount.
Returns
A pointer to the record element at the specified numeric index.

Example: See example for the CXTPGridRecords::Add method.

◆ GetCount()

int GetCount ( ) const

Gets the number of record elements in this collection.

Call this method to retrieve the number of elements in the array. Since indexes are zero-based, the size is 1 greater than the largest index.

Returns
The number of record elements in this collection.

Example: See example for the CXTPGridRecords::Add method.

See also
CXTPGridRecords overview

◆ GetMarkupContext()

AFX_INLINE CXTPMarkupContext * GetMarkupContext ( ) const

Gets the markup context.

Returns
A pointer to the markup context.

◆ GetOwnerRecord()

AFX_INLINE CXTPGridRecord * GetOwnerRecord ( ) const

Obtains an associated owner record pointer.

Returns
An associated owner record pointer, or NULL if no owner record is associated with the records collection.

◆ InsertAt()

void InsertAt | ( | int | nIndex,
 |  | CXTPGridRecord * | pRecord )

Inserts a specified record at a specified index in this collection.

Parameters
nIndex | Index to insert the specified record at.
pRecord | Record to be inserted.

InsertAt inserts an element at a specified index in this array. In the process, it shifts up (by incrementing the index) the existing element at this index, and it shifts up all the elements above it.

Example: See example for the CXTPGridRecords::Add method.

◆ IsCaseSensitive()

AFX_INLINE BOOL IsCaseSensitive ( ) const

Determines if string comparisons are case-sensitive.

Returns
TRUE if string comparisons are case-sensitive, otherwise FALSE.
See also
SetCaseSensitive

◆ Move()

void Move | ( | int | nIndex,
 |  | CXTPGridRecords * | pRecords )

Moves specified records to a specified index in this collection.

Parameters
nIndex | Index to move the specified records to.
pRecords | Records to be moved.

◆ MoveRecord()

void MoveRecord | ( | int | nIndex,
 |  | CXTPGridRecord * | pRecord,
 |  | BOOL | bUpdateIndexes = FALSE )

Moves a specified record to a specified index in this collection.

Parameters
nIndex | Index to move the specified record to.
pRecord | Record to be moved.
bUpdateIndexes | Flag to update indexes to 0-N set.

◆ PrepareToDropping()

virtual void PrepareToDropping | ( | CXTPGridRecord * | pTargetRecord,
 |  | CXTPGridRecords * | pTargetRecords,
 |  | BOOL | bChangeParent )
 virtual

This method is called before record dropping is processed.

Parameters
pTargetRecord | Pointer to the record which is the target for dropping. Set to NULL to skip recursion checking. Also can be NULL when records are dropped on the top level of the Grid control.
pTargetRecords | Pointer to the records which are the target for dropping.
bChangeParent | TRUE to change the parent of the current CXTPGridRecords.

◆ RemoveAll()

void RemoveAll ( )

Removes all the elements from this collection.

Removes all the pointers from this array and releases the instances of all stored CXTPGridRecord objects.

Example: See example for the CXTPGridRecords::Add method.

See also
CXTPGridRecords overview

◆ RemoveAt()

void RemoveAt ( int nIndex )

Removes a specified record from this collection by its index.

Parameters
nIndex Index of the record to remove.

◆ RemoveRecord()

int RemoveRecord ( CXTPGridRecord * pRecord )

Removes a specified record from this collection.

Parameters
pRecord Pointer to the record to be removed.
Returns
The index of the removed record, or a value of -1 if the specified record does not exist within this collection.

◆ SetAt()

virtual void SetAt | ( | INT_PTR | nIndex,
 |  | CXTPGridRecord * | pRecord )
 virtual

Sets a specified record element to a specified index in this collection.

Parameters
nIndex | Integer index to set the specified record element to; must be greater than or equal to zero and less than the value returned by GetCount.
pRecord | Pointer to the CXTPGridRecord object to add.

◆ SetCaseSensitive()

AFX_INLINE void SetCaseSensitive ( BOOL bCaseSensitive )

Specifies if string comparisons should be case-sensitive.

Parameters
bCaseSensitive TRUE to set string comparisons to be case-sensitive, FALSE otherwise; the default value for this parameter is FALSE.
See also
IsCaseSensitive

◆ SetMarkupContext()

AFX_INLINE void SetMarkupContext ( CXTPMarkupContext * pMarkupContext )

Sets the markup context.

Parameters
pMarkupContext Pointer to the markup context to be set.

◆ SetSize()

virtual void SetSize | ( | INT_PTR | nNewSize,
 |  | INT_PTR | nGrowBy = -1 )
 virtual

Changes the size of this collection.

Parameters
nNewSize | New size for this collection.
nGrowBy | Minimum number of element slots to allocate in the event that a size increase is necessary.

◆ UpdateIndexes()

virtual void UpdateIndexes ( int nStart = 0 )
virtual

Updates record element indices.

Parameters
nStart Integer index to begin the update from.
The documentation for this class was generated from the following file:
  • XTPGridRecords.h


Toolkit Pro: CXTPGridRow Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPGridRow Class Reference

CXTPGridRow class represents a row of the Grid control window. More...

Inheritance diagram for CXTPGridRow:
[legend]

Public Member Functions

CXTPGridRow ()
Constructs a CXTPGridRow object.
virtual | ~CXTPGridRow ()
Destroys a CXTPGridRow object, handles cleanup and deallocation.
virtual void | InitRow (CXTPGridRow *pRow)
Performs initial initialization for the current row.
virtual void | InitRow (CXTPGridControl *pControl, CXTPGridSection *pSection, CXTPGridRecord *pRecord)
Performs initial initialization for the current row.
virtual CXTPGridRecord * | GetRecord () const
Gets the record associated with the current row.
virtual void | Draw (CDC *pDC, CRect rcRow, CRect rcClip, int nLeftOffset, CXTPGridRecordMergeItems &mergeItems, int nColumnFrom, int nColumnTo)
Draws the current row on the specified device context.
virtual int | GetHeight (CDC *pDC, int nWidth)
Calculates the height of the current row depending on the specified device context.
virtual int | GetIndex () const
Gets the current row index in the view.
virtual BOOL | IsFocused () const
Gets the focused state of the current row.
virtual BOOL | IsSelected () const
Gets the selected state of the current row.
virtual BOOL | IsExpanded () const
Gets the expanded state of the current row.
virtual void | SetExpanded (BOOL bExpanded, BOOL bRecursive=FALSE)
Sets the expanded state for the current row.
virtual void | _SetExpanded (BOOL bExpanded, BOOL bRecursive, BOOL bNotify)
Sets the expanded state for the current row.
void | SetFullExpanded (BOOL bExpanded)
Sets the expanded state for the current row and its children.
virtual BOOL | IsVisible () const
Determines the visible state of the current row.
virtual void | SetVisible (BOOL bVisible)
Sets the visible state for the current row.
virtual BOOL | IsLockExpand () const
Determines if the user's ability to collapse/expand rows is locked.
virtual void | LockExpand (BOOL bLockExpand)
Specifies if the user's ability to collapse/expand rows should be locked.
virtual void | SetSelected (BOOL bSelected)
Sets the selected state for the current row.
virtual void | SelectChilds ()
Selects all child items of the current row.
virtual BOOL | IsGroupRow () const
Determines if the current row is a group row.
virtual CXTPGridRecordItem * | HitTest (CPoint ptPoint, CRect *pRectItem=NULL, CXTPGridColumn **ppColumn=NULL) const
Determines which grid item, if any, is at a specified point.
virtual void | OnClick (CPoint ptClicked)
Processes single mouse clicks.
virtual BOOL | OnLButtonDown (XTP_GRIDRECORDITEM_CLICKARGS *pClickArgs)
Processes mouse left button down clicks.
virtual BOOL | OnLButtonUp (XTP_GRIDRECORDITEM_CLICKARGS *pClickArgs)
Processes mouse left button up clicks.
virtual void | OnDblClick (CPoint ptClicked)
Processes double mouse clicks.
virtual void | OnMouseMove (UINT nFlags, CPoint point)
Processes the move mouse event.
virtual void | OnContextMenu (CPoint ptClick)
Processes context menu.
virtual void | ShowToolTip (CPoint ptTip, CXTPGridTip *pTipWnd)
Shows a specified tooltip window at a specified position.
virtual void | SetControl (CXTPGridControl *pControl)
Sets the parent Grid control.
virtual CXTPGridControl * | GetControl () const
Gets the parent Grid control.
virtual CXTPGridRow * | GetParentRow () const
Gets the parent row of the current row.
virtual CXTPGridRows * | GetParentRows () const
Gets the parent rows of the current row.
virtual int | GetTreeDepth () const
Gets the depth of the current row in tree view.
virtual BOOL | HasParent (CXTPGridRow *pRow)
Determines if a specified row has a parent row in tree view.
virtual CXTPGridRows * | GetChilds (BOOL bCreate=TRUE)
Gets the child collection of the current row.
virtual CXTPGridRow * | AddChild (CXTPGridRow *pRow)
Adds a child row to the current row.
virtual BOOL | HasChildren () const
Determines if the current row has child rows in tree view.
virtual CXTPGridRow * | GetNextSiblingRow () const
Gets the next sibling row of the current row.
virtual void | SetCollapseRect (CRect rcCollapse)
Sets the coordinates of the collapse/expand button for the current row.
virtual BOOL | IsPreviewVisible () const
Determines if the preview item is visible for the current row.
virtual BOOL | IsItemsVisible () const
Determines if items are visible.
virtual CRect | GetRect () const
Gets the coordinates of the row rectangle.
virtual void | GetItemMetrics (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pItemMetrics)
Gets the drawing metrics of the current row.
virtual int | GetGroupLevel () const
Gets the row depth level when the current row is a group row.
virtual CRect | GetItemRect (CXTPGridRecordItem *pItem)
Gets the rectangle of a specified item.
virtual BOOL | IsLastTreeRow () const
Determine if the current row is the last tree row or is not a part of a tree row.
virtual void | EnsureVisible ()
Ensures that the current row is visible.
virtual void | ShiftTreeIndent (CRect &rcItem, CXTPGridColumn *pColumn) const
Updates the rectangle of an item.
virtual void | FillMetrics (CXTPGridColumn *pColumn, CXTPGridRecordItem *pItem, XTP_GRIDRECORDITEM_METRICS *pMetrics)
Fills an XTP_GRIDRECORDITEM_METRICS structure with drawing metrics.
virtual INT_PTR | OnToolHitTest (CPoint point, TOOLINFO *pTI)
The framework calls this member function to determine whether a point is in the bounding rectangle of the specified tool.
XTPGridRowType | GetType () const
Determine the type of the current row (i.e.
CXTPGridSection * | GetSection () const
Gets the section that the current row belongs to.
BOOL | HasMergedItems () const
Determines if the current row has merged items.
void | SetMergeHeight (int nMergeHeight)
Sets the height of the current row calculated during merge cell processing.
int | GetMergeHeight () const
Gets the height of the current row calculated during merge cell processing.
- Public Member Functions inherited from CXTPHeapObjectT< CXTPGridRowBase, CXTPGridRowAllocator >
void *PASCAL | operator new (size_t nSize)
Allocate memory block of nSize bytes.
void PASCAL | operator delete (void *p)
Free memory block previously allocated by operator new.

Protected Member Functions

CRect | GetItemRect (CXTPGridRecordItem *pItem, BOOL bAsMerged)
Gets the rectangle of a specified item.
virtual void | SetIndex (int nNewIndex)
Sets the index of the current row in the corresponding rows collection.
int | GetLastChildRow (CXTPGridRows *pChildren) const
Gets the index of the last child row in a specified child row collection.

Protected Attributes

CXTPGridControl * | m_pControl
Pointer to the parent Grid control.
CXTPGridRecord * | m_pRecord
Pointer to the associated CXTPGridRecord object.
CXTPGridRow * | m_pParentRow
Pointer to the parent row in the tree.
CXTPGridRows * | m_pParentRows
Pointer to the parent rows in the tree.
CXTPGridRows * | m_pChilds
Pointer to collection of children.
CXTPGridSection * | m_pSection
Pointer to section the row belongs to.
CRect | m_rcRow
A rectangle where a row is to be drawn.
CRect | m_rcCollapse
A rectangle with coordinates of collapse/expand bitmap.
int | m_nIndex
Item index.
int | m_nGroupLevel
Contains row depth level when row is a group row.
int | m_nRowLevel
Row depth level in a tree.
BOOL | m_bVisible
TRUE if this row should be visible, FALSE if row is hidden.
BOOL | m_bExpanded
TRUE if row is expanded in a tree view, FALSE if row is collapsed.
BOOL | m_bLockExpand
TRUE if row cannot be expanded/collapsed by the user.
BOOL | m_bHasSelectedChilds
TRUE if the row has selected children (on any deep level).
int | m_nPreviewHeight
Height of the preview item of this row.
int | m_nFreeHeight
Height of row in FreeHeight RC mode.
int | m_nMergeHeight
Height of row which calculated on merge cells processing.
int | m_nChildIndex
Index of row inside parent rows.

Detailed Description

CXTPGridRow class represents a row of the Grid control window.

Each row item has a corresponding CXTPGridRecord and each CXTPGridRecord could have a list of sub-items associated with it. By clicking a row item, the user can expand and collapse the associated list of sub-items.

CXTPGridRow handles the behavior of a grid row. It processes user mouse and keyboard events, implements external control member functions, and handles drawing logic for the row.

A collection of grid row items is combined into CXTPGridRows and can be accessed through the CXTPGridControl::GetRows() method.

See also
CXTPGridControl overview, CXTPGridRows, CXTPGridRecord, CXTPGridRecordItem, CXTPGridGroupRow

Member Function Documentation

◆ _SetExpanded()

virtual void _SetExpanded | ( | BOOL | bExpanded,
 |  | BOOL | bRecursive,
 |  | BOOL | bNotify )
 virtual

Sets the expanded state for the current row.

Parameters
bExpanded | TRUE to expand the current row.
bRecursive | TRUE to recursively expand all levels of child rows. By default, this parameter is FALSE.
bNotify | TRUE to send notify message.

Call this member function if you want to expand or collapse the current row.

See also
IsExpanded

◆ AddChild()

virtual CXTPGridRow * AddChild ( CXTPGridRow * pRow )
virtual

Adds a child row to the current row.

Parameters
pRow Pointer to the child row to add.

Call this member function if you want to add a CXTPGridRow object as a child row for the current row in tree view mode.

Returns
A pointer to the newly added child row object.
See also
GetParentRow, HasParent, GetTreeDepth, GetChilds

◆ Draw()

virtual void Draw | ( | CDC * | pDC,
 |  | CRect | rcRow,
 |  | CRect | rcClip,
 |  | int | nLeftOffset,
 |  | CXTPGridRecordMergeItems & | mergeItems,
 |  | int | nColumnFrom,
 |  | int | nColumnTo )
 virtual

Draws the current row on the specified device context.

Parameters
pDC | Pointer to the device context in which the drawing occurs.
rcRow | Position of the row in client window coordinates.
rcClip | Position of the row in client window coordinates.
nLeftOffset | Left offset of the drawing, in pixels (horizontal scroll position).
mergeItems | Reference to the set of merged grid records.
nColumnFrom | Index of the column to begin drawing.
nColumnTo | Index of the column to end drawing.

This function simply prepares data for drawing and calls the necessary drawing functions from PaintManager to draw a grid item. As such, you must provide your own implementation of PaintManager in order to change the appearance of your grid item.

See also
CXTPPaintManager

Reimplemented in CXTPGridGroupRow.

◆ EnsureVisible()

virtual void EnsureVisible ( )
virtual

Ensures that the current row is visible.

This will cause the Grid control to scroll to this row.

This method is also called by CXTPGridControl::SetFocusedRow to make the newly focused row visible.

◆ FillMetrics()

virtual void FillMetrics | ( | CXTPGridColumn * | pColumn,
 |  | CXTPGridRecordItem * | pItem,
 |  | XTP_GRIDRECORDITEM_METRICS * | pMetrics )
 virtual

Fills an XTP_GRIDRECORDITEM_METRICS structure with drawing metrics.

Parameters
pColumn | Pointer to the column of the item.
pItem | Pointer to the item to be drawn.
pMetrics | Pointer to an XTP_GRIDRECORDITEM_METRICS structure to fill.
See also
GetItemMetrics

◆ GetChilds()

virtual CXTPGridRows * GetChilds ( BOOL bCreate = TRUE )
virtual

Gets the child collection of the current row.

Parameters
bCreate TRUE to create an empty child collection for the current row if the current row does not already have a child collection.

Call this member function to retrieve access to the current row's collection of row children.

Returns
A pointer to the child collection of the current row.
See also
CXTPGridRows overview, GetParentRow, HasParent, GetTreeDepth, AddChild, HasChildren

◆ GetControl()

AFX_INLINE CXTPGridControl * GetControl ( ) const
virtual

Gets the parent Grid control.

Call this member function to get a pointer to the CXTPGridControl which this item belongs to.

Returns
A pointer to the parent Grid control object.
See also
CXTPGridControl overview

◆ GetGroupLevel()

AFX_INLINE int GetGroupLevel ( ) const
virtual

Gets the row depth level when the current row is a group row.

Returns
The row depth level when the current row is a group row.

◆ GetHeight()

virtual int GetHeight | ( | CDC * | pDC,
 |  | int | nWidth )
 virtual

Calculates the height of the current row depending on the specified device context.

Parameters
pDC | Pointer to the device context.
nWidth | Row width.

Row height depends of many factors: provided device context, font to print text, visibility of rows items. GetHeight() accounts for all of these factors to get the real height of row.

Returns
The height of the row in logical units.

◆ GetIndex()

virtual int GetIndex ( ) const
virtual

Gets the current row index in the view.

GridControl draws row in some order. It depends of Index value You use GetIndex() to get current index value for particular row

Returns
The current row index in the view.

◆ GetItemMetrics()

virtual void GetItemMetrics | ( | XTP_GRIDRECORDITEM_DRAWARGS * | pDrawArgs,
 |  | XTP_GRIDRECORDITEM_METRICS * | pItemMetrics )
 virtual

Gets the drawing metrics of the current row.

Parameters
pDrawArgs | Pointer to an XTP_GRIDRECORDITEM_DRAWARGS structure for calculating metrics.
pItemMetrics | Pointer to an XTP_GRIDRECORDITEM_METRICS
See also
XTP_GRIDRECORDITEM_DRAWARGS, XTP_GRIDRECORDITEM_METRICS

◆ GetItemRect() [1/2]

virtual CRect GetItemRect ( CXTPGridRecordItem * pItem )
virtual

Gets the rectangle of a specified item.

Parameters
pItem Pointer to a CXTPGridRecordItem object.
Returns
The rectangle of the specified item.

◆ GetItemRect() [2/2]

CRect GetItemRect | ( | CXTPGridRecordItem * | pItem,
 |  | BOOL | bAsMerged )
 protected

Gets the rectangle of a specified item.

Parameters
pItem | Pointer to a CXTPGridRecordItem object.
bAsMerged | TRUE if the specified item is merged.
Returns
The rectangle of the item.

◆ GetLastChildRow()

int GetLastChildRow ( CXTPGridRows * pChildren ) const
protected

Gets the index of the last child row in a specified child row collection.

Parameters
pChildren Pointer to a child row collection.
Returns
The index of the last child row in the specified child row collection.

◆ GetMergeHeight()

AFX_INLINE int GetMergeHeight ( ) const

Gets the height of the current row calculated during merge cell processing.

A merge height of -1 means undefined height. When calculating the height of any merge cell, the height of all related merge cells must also be calculated. These calculated values are saved to prevent repeating the same actions for all related rows.

Returns
Height of row calculated during merge cell processing

◆ GetNextSiblingRow()

virtual CXTPGridRow * GetNextSiblingRow ( ) const
virtual

Gets the next sibling row of the current row.

When grid rows are arranged as a tree view, this member function returns a pointer to the next CXTPGridRow item.

Returns
A pointer to the next sibling row of the current row, if any, or NULL if the current row does not have a next sibling row.
See also
HasParent, GetTreeDepth, GetChilds, AddChild, HasChildren

◆ GetParentRow()

AFX_INLINE CXTPGridRow * GetParentRow ( ) const
virtual

Gets the parent row of the current row.

When grid rows are arranged as a tree view, this member function returns a pointer to the parent CXTPGridRow item.

Returns
A pointer to the parent row of the current row, if any, or NULL if the current row does not have a parent row.
See also
HasParent, GetTreeDepth, GetChilds, AddChild, HasChildren

◆ GetParentRows()

AFX_INLINE CXTPGridRows * GetParentRows ( ) const
virtual

Gets the parent rows of the current row.

When grid rows are arranged as a tree view, this member function returns a pointer to the parent CXTPGridRows item.

Returns
A pointer to the parent rows of the current row, if any, or NULL if the current row does not have parent rows.
See also
HasParent, GetTreeDepth, GetChilds, AddChild, HasChildren

◆ GetRecord()

AFX_INLINE CXTPGridRecord * GetRecord ( ) const
virtual

Gets the record associated with the current row.

Returns
A pointer to the record associated with the current row.

Example:

CXTPGridRecord* pRecord = pRow->GetRecord();
See also
CXTPGridRecord overview

◆ GetRect()

AFX_INLINE CRect GetRect ( ) const
virtual

Gets the coordinates of the row rectangle.

Returns
The coordinates of the row rectangle in grid window client coordinates.

Call this member function to determine the coordinates of the region where the current row is drawn on the parent window.

See also
SetCollapseRect

◆ GetSection()

AFX_INLINE CXTPGridSection * GetSection ( ) const

Gets the section that the current row belongs to.

Returns
A pointer to the section that the current row belongs to.

◆ GetTreeDepth()

virtual int GetTreeDepth ( ) const
virtual

Gets the depth of the current row in tree view.

When grid rows are arranged as a tree view, this member function returns the depth level of the row (i.e. the number of parent elements for the row.)

Returns
The depth of the current row in tree view.
See also
GetParentRow, HasParent, GetChilds, AddChild, HasChildren

◆ GetType()

XTPGridRowType GetType ( ) const

Determine the type of the current row (i.e.

body, header, or footer).

Returns
The type of the current row; one of the values defined by the XTPGridRowType enumeration.

◆ HasChildren()

virtual BOOL HasChildren ( ) const
virtual

Determines if the current row has child rows in tree view.

When grid rows are arranged as a tree view, this member function calculates whether the current row has child rows or not.

Returns
TRUE if the current row has child rows, otherwise FALSE.
See also
HasParent, GetParentRow, GetTreeDepth, GetChilds, AddChild, HasChildren

◆ HasMergedItems()

BOOL HasMergedItems ( ) const

Determines if the current row has merged items.

Returns
TRUE if the current row has merged items, otherwise FALSE.

◆ HasParent()

virtual BOOL HasParent ( CXTPGridRow * pRow )
virtual

Determines if a specified row has a parent row in tree view.

Parameters
pRow Pointer to the row to check.

When grid rows are arranged as a tree view, this member function calculates whether the specified row has a parent row or not.

Returns
TRUE if the specified row has a parent, otherwise FALSE.
See also
HasParent, GetParentRow, GetTreeDepth, GetChilds, AddChild, HasChildren

◆ HitTest()

virtual CXTPGridRecordItem * HitTest | ( | CPoint | ptPoint,
 |  | CRect * | pRectItem = NULL,
 |  | CXTPGridColumn ** | ppColumn = NULL ) const
 virtual

Determines which grid item, if any, is at a specified point.

Parameters
ptPoint | Point to test.
pRectItem | Pointer to a CRect object to receive the item rect.
ppColumn | Double pointer to a CXTPGridColumn to receive the column at the specified point.

Call this member function to hit test row contents at a specified point.

Returns
The record item at the specified position, if any, or NULL otherwise.

◆ InitRow() [1/2]

virtual void InitRow | ( | CXTPGridControl * | pControl,
 |  | CXTPGridSection * | pSection,
 |  | CXTPGridRecord * | pRecord )
 virtual

Performs initial initialization for the current row.

Parameters
pControl | Pointer to the parent Grid control.
pSection | Pointer to the parent section.
pRecord | Pointer to the record associated with the row.

◆ InitRow() [2/2]

virtual void InitRow ( CXTPGridRow * pRow )
virtual

Performs initial initialization for the current row.

Parameters
pRow Pointer to the row whose settings will be copied.

◆ IsExpanded()

virtual BOOL IsExpanded ( ) const
virtual

Gets the expanded state of the current row.

Call this member function if you want to determine whether the current row is expanded in the Grid control or not.

Returns
TRUE if the current row is expanded, otherwise FALSE.
See also
SetExpanded

◆ IsFocused()

virtual BOOL IsFocused ( ) const
virtual

Gets the focused state of the current row.

Call this member function if you want to determine whether the current row is focused in the Grid control or not.

Returns
TRUE if the current row is focused, otherwise FALSE.
See also
IsSelected

◆ IsGroupRow()

virtual BOOL IsGroupRow ( ) const
virtual

Determines if the current row is a group row.

Call this member function if you want to determine whether the current row is a group row or not.

Returns
TRUE if the current row is a group row, otherwise FALSE.

Reimplemented in CXTPGridGroupRow.

◆ IsItemsVisible()

virtual BOOL IsItemsVisible ( ) const
virtual

Determines if items are visible.

Returns
TRUE if items are visible.
See also
IsPreviewVisible

◆ IsLastTreeRow()

virtual BOOL IsLastTreeRow ( ) const
virtual

Determine if the current row is the last tree row or is not a part of a tree row.

Returns
TRUE if the current row is the last tree row, FALSE if the current row is either not the last tree row or not a part of a tree row.

◆ IsLockExpand()

virtual BOOL IsLockExpand ( ) const
virtual

Determines if the user's ability to collapse/expand rows is locked.

Returns
TRUE if the user's ability to collapse/expand rows is locked.

◆ IsPreviewVisible()

virtual BOOL IsPreviewVisible ( ) const
virtual

Determines if the preview item is visible for the current row.

Returns
TRUE if the preview item is visiblefor the current row, otherwise FALSE.
See also
CXTPGridRecordItemPreview overview, CXTPGridRecord::GetItemPreview

◆ IsSelected()

virtual BOOL IsSelected ( ) const
virtual

Gets the selected state of the current row.

Call this member function if you want to determine whether the current row is selected in the Grid control or not.

Returns
TRUE if current row is selected, otherwise FALSE.
See also
IsFocused

◆ IsVisible()

virtual BOOL IsVisible ( ) const
virtual

Determines the visible state of the current row.

Call this member function if you want to determine whether the current row is visible in the Grid control or not.

Returns
TRUE if the current row is visible, otherwise FALSE.
See also
SetVisible

◆ LockExpand()

virtual void LockExpand ( BOOL bLockExpand )
virtual

Specifies if the user's ability to collapse/expand rows should be locked.

Parameters
bLockExpand TRUE to lock the user's ability to collapse/expand rows.

◆ OnClick()

virtual void OnClick ( CPoint ptClicked )
virtual

Processes single mouse clicks.

Called by the framework when the user has clicked the mouse button in the row area.

Parameters
ptClicked Position of the cursor, in screen coordinates, at the time of the mouse click.

Call this member function if you want a row to process a mouse button single click message. You should provide the method with the coordinates of the mouse message to proceed.

See also
OnDblClick, OnMouseMove, OnContextMenu

Reimplemented in CXTPGridGroupRow.

◆ OnContextMenu()

virtual void OnContextMenu ( CPoint ptClick )
virtual

Processes context menu.

Called by the framework when the user has clicked the right mouse button (right clicked) in the window.

Parameters
ptClick Position of the cursor, in screen coordinates, at the time of the mouse click.

Call this member function if you want a row to process a mouse right button down (context menu call) message. You should provide the method with the coordinates of the mouse message to proceed.

See also
OnClick, OnDblClick, OnMouseMove

◆ OnDblClick()

virtual void OnDblClick ( CPoint ptClicked )
virtual

Processes double mouse clicks.

Called by the framework when the user has double-clicked the mouse button in the row area.

Parameters
ptClicked Position of the cursor, in screen coordinates, at the time of the mouse click.

Call this member function if you want a row to process a mouse button double click message. You should provide the method with the coordinates of the mouse message to proceed.

See also
OnClick, OnMouseMove, OnContextMenu

Reimplemented in CXTPGridGroupRow.

◆ OnLButtonDown()

virtual BOOL OnLButtonDown ( XTP_GRIDRECORDITEM_CLICKARGS * pClickArgs )
virtual

Processes mouse left button down clicks.

Parameters
pClickArgs Pointer to an XTP_GRIDRECORDITEM_CLICKARGS structure containing click arguments.
Returns
TRUE if the implementation handles the mouse click event and no further handling is required, otherwise FALSE.
See also
OnLButtonUp, OnClick

◆ OnLButtonUp()

virtual BOOL OnLButtonUp ( XTP_GRIDRECORDITEM_CLICKARGS * pClickArgs )
virtual

Processes mouse left button up clicks.

Parameters
pClickArgs Pointer to an XTP_GRIDRECORDITEM_CLICKARGS structure containing click arguments.
Returns
TRUE if the implementation handles the mouse click event and no further handling is required, otherwise FALSE.
See also
OnLButtonDown, OnClick

◆ OnMouseMove()

virtual void OnMouseMove | ( | UINT | nFlags,
 |  | CPoint | point )
 virtual

Processes the move mouse event.

Parameters
nFlags | Indicates whether various virtual keys are down.
point | Point coordinates where the message was fired from.

Call this member function if you want a row to process a mouse move message. You should provide the method with the coordinates of the mouse message to proceed and a flag showing which of virtual keys were down.

See also
OnClick, OnDblClick, OnContextMenu

◆ OnToolHitTest()

virtual INT_PTR OnToolHitTest | ( | CPoint | point,
 |  | TOOLINFO * | pTI )
 virtual

The framework calls this member function to determine whether a point is in the bounding rectangle of the specified tool.

Parameters
point | Specifies the x- and y-coordinate of the cursor. These coordinates are always relative to the upper-left corner of the window
pTI | A pointer to a TOOLINFO structure.
Returns
If the tooltip control was found, the window control ID. If the tooltip control was not found, -1.

Reimplemented in CXTPGridGroupRow.

◆ SetCollapseRect()

AFX_INLINE void SetCollapseRect ( CRect rcCollapse )
virtual

Sets the coordinates of the collapse/expand button for the current row.

Parameters
rcCollapse Rectangle in grid window client coordinates.

Call this member function to set the coordinates of the collapse/expand button for the current row. Note that it could be different depending on the row tree depth.

See also
GetTreeDepth, GetRect

◆ SetControl()

AFX_INLINE void SetControl ( CXTPGridControl * pControl )
virtual

Sets the parent Grid control.

Parameters
pControl Pointer to the parent Grid control to be set.

Call this member function to set a pointer to the CXTPGridControl which this item belongs to.

See also
CXTPGridControl overview

Reimplemented in CXTPGridGroupRow.

◆ SetExpanded()

virtual void SetExpanded | ( | BOOL | bExpanded,
 |  | BOOL | bRecursive = FALSE )
 virtual

Sets the expanded state for the current row.

Parameters
bExpanded | TRUE to expand the current row.
bRecursive | TRUE to recursively expand all levels of child rows. By default, this parameter is FALSE.

Call this member function if you want to expand or collapse the current row.

See also
IsExpanded

◆ SetFullExpanded()

void SetFullExpanded ( BOOL bExpanded )

Sets the expanded state for the current row and its children.

Parameters
bExpanded TRUE to expand the current row and its children.

Call this member function if you want to expand or collapse the current row and its children.

◆ SetIndex()

AFX_INLINE void SetIndex ( int nNewIndex )
protectedvirtual

Sets the index of the current row in the corresponding rows collection.

Parameters
nNewIndex Index to be set.

◆ SetMergeHeight()

AFX_INLINE void SetMergeHeight ( int nMergeHeight )

Sets the height of the current row calculated during merge cell processing.

Parameters
nMergeHeight A new merge hight value.

A merge height of -1 means undefined height. When calculating the height of any merge cell, the height of all related merge cells must also be calculated. These calculated values are saved to prevent repeating the same actions for all related rows.

◆ SetSelected()

virtual void SetSelected ( BOOL bSelected )
virtual

Sets the selected state for the current row.

If multiple selection is enabled, then this row will be added to the selection.

Parameters
bSelected TRUE to select the row, FALSE to unselect the row.

◆ SetVisible()

virtual void SetVisible ( BOOL bVisible )
virtual

Sets the visible state for the current row.

Parameters
bVisible TRUE to set the current row to visible, FALSE to set the current row to hidden.

Call this member function if you want to show or hide the current row.

See also
IsVisible

◆ ShiftTreeIndent()

virtual void ShiftTreeIndent | ( | CRect & | rcItem,
 |  | CXTPGridColumn * | pColumn ) const
 virtual

Updates the rectangle of an item.

Parameters
rcItem | Reference to the bounding rectangle of the item cell.
pColumn | Pointer to a CXTPGridColumn object; this column will be checked to determine if it is a tree column.
See also
CXTPGridColumn::IsTreeColumn

◆ ShowToolTip()

virtual void ShowToolTip | ( | CPoint | ptTip,
 |  | CXTPGridTip * | pTipWnd )
 virtual

Shows a specified tooltip window at a specified position.

Parameters
ptTip | Screen position to show the tooltip window at.
pTipWnd | Pointer to the tooltip window to show.

Call this member function if you want to show a grid tooltip window for this row.

See also
CXTPGridTip overview

Member Data Documentation

◆ m_nMergeHeight

int m_nMergeHeight
protected

Height of row which calculated on merge cells processing.

(-1) means undefined height.

The documentation for this class was generated from the following file:
  • XTPGridRow.h


Toolkit Pro: CXTPGridRows Class Reference

Public Member Functions | Static Public Member Functions | Protected Attributes | List of all members
CXTPGridRows Class Reference

This class represents a rows collection class. More...

Inheritance diagram for CXTPGridRows:
[legend]

Public Member Functions

CXTPGridRows ()
Constructs an empty CXTPGridRow pointer array.
virtual | ~CXTPGridRows ()
Destroys a CXTPGridRows object, handles cleanup and deallocation.
virtual BOOL | Contains (const CXTPGridRow *pRow) const
Determines if this row collection contains a specified row.
virtual void | Clear (BOOL bResetRow=TRUE)
Removes all the elements from this collection.
int | GetCount () const
Gets the number of row elements in this collection.
virtual CXTPGridRow * | GetAt (int nIndex) const
Gets the row element at a specified numeric index in this collection.
virtual CXTPGridScreenRows * | GetScreenRows ()
Gets the currently displayed rows of this collection.
virtual int | GetFocusedRowIndex () const
Gets the index of the currently focused row.
virtual BOOL | HasFocus () const
Determines if a row in this collection currently has focus.
virtual void | SetFocusedRowIndex (int nRow)
Sets the index of the currently focused row.
virtual CXTPGridRow * | GetFocusedRow ()
Gets the currently focused row in the Grid control's view.
virtual int | Add (CXTPGridRow *pRow)
Adds a new row element to the end of this collection.
virtual void | RemoveAt (int nIndex)
Removes a specified row from this collection by its index.
virtual void | RemoveAt (int nStartIndex, int nCount)
Removes a specified row from this collection by its index.
virtual int | RemoveRow (CXTPGridRow *pRow)
Removes a specified row from this collection.
virtual void | InsertAt (int nIndex, CXTPGridRow *pRow)
Inserts a specified row at a specified index in this collection.
virtual CXTPGridRow * | GetNext (CXTPGridRow *pRow, BOOL bSkipGroupFocus)
Gets the next row in the list.
virtual CXTPGridRow * | GetPrev (CXTPGridRow *pRow, BOOL bSkipGroupFocus)
Gets the previous row in the list.
virtual void | SetVirtualMode (CXTPGridRow *pRow, int nCount)
Call this method to set virtual mode with nCount rows.
virtual CXTPGridRow * | Find (CXTPGridRecord *pRecord)
Retrieves the row associated with a specified record.
virtual CXTPGridRow * | Find (CXTPGridRecord *pRecord, BOOL bRecursive)
Retrieves the row associated with a specified record.
virtual CXTPGridRow * | FindInTree (CXTPGridRecord *pRecord)
Retrieves the row associated with a specified record.
virtual CXTPGridRow * | FindInsertionPos (CXTPGridRow *pRow, BOOL &bInsertAfter)
Searches for a position to insert a specified row at.
virtual void | RefreshChildIndices (BOOL bRunInChildren=TRUE)
Recalculates the child indices of all rows in the collection.
void | ClearMergeHeight ()
Resets the merge height for all rows (i.e.
virtual void | SortEx (XTPGridRowsCompareFunc pCompareFunc)
Sorts rows in the collection.
virtual void | Sort ()
Sorts rows in the collection.
virtual CXTPGridRecordItem * | FindRecordItemByRows (int nStartIndex, int nEndIndex, int nStartColumn, int nEndColumn, int nRecordIndex, int nItem, LPCTSTR pcszText, int nFlags)
Finds a record item by rows.
- Public Member Functions inherited from CXTPHeapObjectT< CXTPCmdTarget, CXTPGridDataAllocator >
void *PASCAL | operator new (size_t nSize)
Allocate memory block of nSize bytes.
void PASCAL | operator delete (void *p)
Free memory block previously allocated by operator new.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Static Public Member Functions

static int AFX_CDECL | CompareRows (const CXTPGridRow **pRow1, const CXTPGridRow **pRow2)
Compares two rows using groups and sort orders of the Grid control.
static int AFX_CDECL | CompareRows2 (const CXTPGridRow **pRow1, const CXTPGridRow **pRow2)
Compares two rows using groups and sort orders of the Grid control.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Protected Attributes

CXTPGridRow * | m_pVirtualRow
Virtual row.
CXTPGridScreenRows * | m_pScreenRows
Rows currently presented on screen.
int | m_nVirtualRowsCount
Count of virtual rows.
int | m_nFocusedRow
Current focused row index.

Detailed Description

This class represents a rows collection class.

It supports an array of CXTPGridRow pointers.

Example: See CXTPGridRows::Add for an example of how to work with this class.

See also
CXTPGridRow, CXTPGridSelectedRows

Constructor & Destructor Documentation

◆ CXTPGridRows()

CXTPGridRows ( )

Constructs an empty CXTPGridRow pointer array.

Example:

// Declare a local CXTPGridRows object.
CXTPGridRows myList;

// Declare a dynamic CXTPGridRows object.
CXTPGridRows* pTree = new CXTPGridRows();

Member Function Documentation

◆ Add()

virtual int Add ( CXTPGridRow * pRow )
virtual

Adds a new row element to the end of this collection.

Parameters
pRow Pointer to the new row element to be added.

Use this method to add the specified CXTPGridRow pointer to the end of the CXTPGridRows collection.

Returns
The index of the newly added row element.

Example:

CXTPGridRows* pTree = new CXTPGridRows();
pTree->Add(new CXTPGridRow(pControl, pRecord1));
pTree->Add(new CXTPGridRow(pControl, pRecord2));
CXTPGridRow* pRow0 = pTree->GetAt(0);
CXTPGridRow* pRow1 = pTree->GetAt(1);
_ASSERTE(pRow0 == pTree->GetPrev(pRow1));
_ASSERTE(pRow1 == pTree->GetNext(pRow0));
pTree->RemoveAt(0);
_ASSERTE(1 == pTree->GetCount());
pTree->InsertAt(0, pRow0);
_ASSERTE(2 == pTree->GetCount());
pTree->Clear();
_ASSERTE(0 == pTree->GetCount());
See also
CXTPGridRows overview, GetAt, InsertAt, Clear, GetNext, GetPrev, GetCount

◆ Clear()

virtual void Clear ( BOOL bResetRow = TRUE )
virtual

Removes all the elements from this collection.

Parameters
bResetRow TRUE to remove the visible flag of child rows.

Removes all the pointers from this array and releases the instances of all stored CXTPGridRow objects.

Example: See example for the CXTPGridRows::Add method.

See also
CXTPGridRows overview

◆ ClearMergeHeight()

void ClearMergeHeight ( )

Resets the merge height for all rows (i.e.

resets CXTPGridRow::m_nMergeHeight to -1 for all rows).

◆ CompareRows()

static int AFX_CDECL CompareRows | ( | const CXTPGridRow ** | pRow1,
 |  | const CXTPGridRow ** | pRow2 )
 static

Compares two rows using groups and sort orders of the Grid control.

Parameters
pRow1 | First row for comparison.
pRow2 | Second row for comparison.

This function is called directly by the Sort method.

The default implementation returns the result of the comparison of *pRow1 and *pRow2.

This implementation uses CXTPGridRecordItem::Compare to compare two corresponding items from row records. First it compares the record items by group order, then by sort order. It returns the first comparison result that differs by equality. If no differences are found, then it returns 0.

Returns
Zero if pRow1 is equal to pRow2; Less than zero if pRow1 is less than pRow2; Greater than zero if pRow1 is greater than pRow2.
See also
Sort, CXTPGridRecordItem::Compare

◆ CompareRows2()

static int AFX_CDECL CompareRows2 | ( | const CXTPGridRow ** | pRow1,
 |  | const CXTPGridRow ** | pRow2 )
 static

Compares two rows using groups and sort orders of the Grid control.

Parameters
pRow1 | First row for comparison.
pRow2 | Second row for comparison.

This function is called directly by the Sort method.

The default implementation returns the result of the comparison of *pRow1 and *pRow2.

This implementation uses CXTPGridRecordItem::Compare to compare two corresponding items from row records. First it compares the record items by group order, then by sort order. It returns the first comparison result that differs by equality. If no differences are found, then it returns 0.

Returns
Zero if pRow1 is equal to pRow2; Less than zero if pRow1 is less than pRow2; Greater than zero if pRow1 is greater than pRow2.
See also
Sort, CXTPGridRecordItem::Compare

◆ Contains()

virtual BOOL Contains ( const CXTPGridRow * pRow ) const
virtual

Determines if this row collection contains a specified row.

Parameters
pRow Pointer to a CXTPGridRow.
Returns
TRUE if this row collection contains the specified row.

◆ Find() [1/2]

virtual CXTPGridRow * Find ( CXTPGridRecord * pRecord )
virtual

Retrieves the row associated with a specified record.

Parameters
pRecord Pointer to the CXTPGridRecord object to find.

This function will not search through row children.

Returns
A pointer to the row associated with the specified record if successful, otherwise NULL.

◆ Find() [2/2]

virtual CXTPGridRow * Find | ( | CXTPGridRecord * | pRecord,
 |  | BOOL | bRecursive )
 virtual

Retrieves the row associated with a specified record.

Parameters
pRecord | Pointer to the CXTPGridRecord object to find.
bRecursive | TRUE to copy recursively.

This function will not search through row children.

Returns
A pointer to the row associated with the specified record if successful, otherwise NULL.

◆ FindInsertionPos()

virtual CXTPGridRow * FindInsertionPos | ( | CXTPGridRow * | pRow,
 |  | BOOL & | bInsertAfter )
 virtual

Searches for a position to insert a specified row at.

Parameters
pRow | Pointer to the CXTPGridRow object to be inserted.
bInsertAfter | Reference to a BOOL value to be set to TRUE by this method if the specified row must be inserted after the found row.

This method will search through child rows.

Returns
A pointer to the found CXTPGridRow object if successful, otherwise NULL.

◆ FindInTree()

virtual CXTPGridRow * FindInTree ( CXTPGridRecord * pRecord )
virtual

Retrieves the row associated with a specified record.

Parameters
pRecord Pointer to the CXTPGridRecord object to find.

This function will search through row children.

Returns
A pointer to the row associated with the specified record if successful, otherwise NULL.

◆ FindRecordItemByRows()

virtual CXTPGridRecordItem * FindRecordItemByRows | ( | int | nStartIndex,
 |  | int | nEndIndex,
 |  | int | nStartColumn,
 |  | int | nEndColumn,
 |  | int | nRecordIndex,
 |  | int | nItem,
 |  | LPCTSTR | pcszText,
 |  | int | nFlags )
 virtual

Finds a record item by rows.

Parameters
nStartIndex | Starting index.
nEndIndex | Ending index.
nStartColumn | Starting column.
nEndColumn | Ending column.
nItem | Record item index to start the search from.
nRecordIndex | Record index to start the search from.
pcszText | Search text.
nFlags | Search flags.

The various values for nFlags are:

xtpGridTextSearchExactPhrase Search exact phrase.

xtpGridTextSearchMatchCase Match case during search.

xtpGridTextSearchBackward Search backwards.

xtpGridTextSearchExactStart Search phrase where the start of the phrase

matches exactly. For those familiar with grep, this is just like using the "^" to state that the text must start with the specified search.

Returns
A pointer to the found record item if successful, otherwise NULL.

◆ GetAt()

virtual CXTPGridRow * GetAt ( int nIndex ) const
virtual

Gets the row element at a specified numeric index in this collection.

Parameters
nIndex Integer index that is greater than or equal to 0 and less than the value returned by GetCount.
Returns
A pointer to the row element at the specified numeric index.

Example: See example for the CXTPGridRows::Add method.

◆ GetCount()

int GetCount ( ) const

Gets the number of row elements in this collection.

Call this method to retrieve the number of elements in the array. Since indexes are zero-based, the size is 1 greater than the largest index.

Example: See example for the CXTPGridRows::Add method.

Returns
The number of row elements in this collection.
See also
CXTPGridRows overview

◆ GetFocusedRow()

virtual CXTPGridRow * GetFocusedRow ( )
virtual

Gets the currently focused row in the Grid control's view.

Returns
A pointer to the currently focused row if successful, otherwise NULL.

◆ GetFocusedRowIndex()

virtual int GetFocusedRowIndex ( ) const
virtual

Gets the index of the currently focused row.

Returns
The index of the currently focused row.

◆ GetNext()

virtual CXTPGridRow * GetNext | ( | CXTPGridRow * | pRow,
 |  | BOOL | bSkipGroupFocus )
 virtual

Gets the next row in the list.

Parameters
pRow | Pointer to the current row in the list.
bSkipGroupFocus | TRUE to skip all groups.
Returns
A pointer to the next row in the list.

Example: See example for the CXTPGridRows::Add method.

See also
GetPrev, CXTPGridControl::SkipGroupsFocus

◆ GetPrev()

virtual CXTPGridRow * GetPrev | ( | CXTPGridRow * | pRow,
 |  | BOOL | bSkipGroupFocus )
 virtual

Gets the previous row in the list.

Parameters
pRow | Pointer to the current row in the list.
bSkipGroupFocus | TRUE to skip all groups.
Returns
A pointer to the previous row in the list.

Example: See example for the CXTPGridRows::Add method.

See also
GetNext, CXTPGridControl::SkipGroupsFocus

◆ GetScreenRows()

virtual CXTPGridScreenRows * GetScreenRows ( )
virtual

Gets the currently displayed rows of this collection.

Returns
A pointer to a CXTPGridScreenRows object containing the currently displayed rows of this collection.

◆ HasFocus()

virtual BOOL HasFocus ( ) const
virtual

Determines if a row in this collection currently has focus.

Returns
TRUE if a row in this collection currently has focus.

◆ InsertAt()

virtual void InsertAt | ( | int | nIndex,
 |  | CXTPGridRow * | pRow )
 virtual

Inserts a specified row at a specified index in this collection.

Parameters
nIndex | Integer index that is greater than or equal to 0 and less than the value returned by GetCount.
pRow | Row to be inserted.

InsertAt inserts an element at a specified index in this array. In the process, it shifts up (by incrementing the index) the existing element at this index, and it shifts up all the elements above it.

Example: See example for the CXTPGridRows::Add method.

◆ RefreshChildIndices()

virtual void RefreshChildIndices ( BOOL bRunInChildren = TRUE )
virtual

Recalculates the child indices of all rows in the collection.

Parameters
bRunInChildren TRUE to recalculate the child indices of row children.

◆ RemoveAt() [1/2]

virtual void RemoveAt ( int nIndex )
virtual

Removes a specified row from this collection by its index.

Parameters
nIndex Integer index that is greater than or equal to 0 and less than the value returned by GetCount.

In the process, this method shifts down all elements above the removed element. This method also decrements the upper bound of the array, but does not free memory. This class also releases the instance of the removed element.

Example: See example for the CXTPGridRows::Add method.

◆ RemoveAt() [2/2]

virtual void RemoveAt | ( | int | nStartIndex,
 |  | int | nCount )
 virtual

Removes a specified row from this collection by its index.

Parameters
nStartIndex | Integer index that is greater than or equal to 0 and less than the value returned by GetCount.
nCount | Specifies the number of rows to be removed starting at the specified start index.

In the process, this method shifts down all elements above the removed elements. This method also decrements the upper bound of the array, but does not free memory. This class also releases the instance of the removed element.

Example: See example for the CXTPGridRows::Add method.

◆ RemoveRow()

virtual int RemoveRow ( CXTPGridRow * pRow )
virtual

Removes a specified row from this collection.

Parameters
pRow Pointer to the row to be removed.
Returns
The index of the removed row, or a value of -1 if the specified row does not exist within this collection.

◆ SetFocusedRowIndex()

virtual void SetFocusedRowIndex ( int nRow )
virtual

Sets the index of the currently focused row.

Parameters
nRow Row ID.

◆ SetVirtualMode()

virtual void SetVirtualMode | ( | CXTPGridRow * | pRow,
 |  | int | nCount )
 virtual

Call this method to set virtual mode with nCount rows.

Parameters
pRow | Virtual row
nCount | Count of virtual rows

◆ Sort()

virtual void Sort ( )
virtual

Sorts rows in the collection.

This method uses the Visual C++ run-time library (MSVCRT) implementation of the quick-sort function, qsort, for sorting stored CXTPGridRow objects. Sort() internally uses the CompareRows method for comparing two rows.

See also
CompareRows

◆ SortEx()

virtual void SortEx ( XTPGridRowsCompareFunc pCompareFunc )
virtual

Sorts rows in the collection.

Parameters
pCompareFunc Pointer to a T_CompareFunc function to be used to compare rows.

This method uses the Visual C++ run-time library (MSVCRT) implementation of the quick-sort function, qsort, for sorting stored CXTPGridRow objects. Sort() internally uses the CompareRows method for comparing two rows.

See also
CompareRows
The documentation for this class was generated from the following file:
  • XTPGridRows.h


Toolkit Pro: CXTPGridSection Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPGridSection Class Reference

Represents a grid section. More...

Inheritance diagram for CXTPGridSection:
[legend]

Public Member Functions

CXTPGridSection (CXTPGridControl *pControl, XTPGridRowType rowType)
Constructs a grid section.
virtual | ~CXTPGridSection ()
Destructs a grid section.
CXTPGridBorder * | GetBorder () const
Gets the border of this grid section.
void | AllowAccess (BOOL bAllowAccess)
Specifies if the user is allowed to move the selection to rows.
BOOL | IsAllowAccess () const
Determines if the user is allowed to move the selection to rows.
void | AllowEdit (BOOL bAllowEdit)
Specifies if the text in all CXTPGridRecordItem(s) can be edited.
BOOL | IsAllowEdit () const
Determines if the text in all CXTPGridRecordItem(s) can be edited.
void | AllowGroup (BOOL bAllowGroup)
Enables/disables row grouping.
BOOL | IsAllowGroup () const
Determines if row grouping is enabled/disabled.
void | AllowSort (BOOL bAllowSort)
Enables/disables row sorting.
BOOL | IsAllowSort () const
Determines if row sorting is enabled/disabled.
void | AllowFilter (BOOL bAllowFilter)
Enables/disables row filtering.
BOOL | IsAllowFilter () const
Determines if row filtering is enabled/disabled.
void | SelectionEnable (BOOL bEnable)
Enables/disables rows selection.
BOOL | IsSelectionEnabled () const
Determines if rows selection is enabled/disabled.
void | SetVisible (BOOL bVisible=TRUE)
Sets the visible state of the section.
BOOL | IsVisible () const
Gets the visible state of the section.
XTPGridSectionHeightMode | GetHeightMode () const
Gets the current height mode.
void | SetHeightMode (XTPGridSectionHeightMode heightMode)
Sets the current height mode.
int | GetHeight () const
Gets the suggested height.
void | SetHeight (int nHeight)
Sets the suggested height.
XTPGridSectionDividerPosition | GetDividerPosition () const
Gets the divider position for this section.
void | SetDividerPosition (XTPGridSectionDividerPosition dividerPosition)
Sets the divider position for this section.
XTPGridSectionDividerStyle | GetDividerStyle () const
Gets the divider style for this section.
void | SetDividerStyle (XTPGridSectionDividerStyle dividerStyle)
Sets the divider style for this section.
CXTPPaintManagerColor | GetDividerColor () const
Gets the divider color for this section.
void | SetDividerColor (CXTPPaintManagerColor clrDivider)
Sets the divider color for this section.
CRect | GetRect () const
Gets the rectangle of this section.
CRect | GetDividerRect () const
Gets the divider rectangle of this section.
CXTPGridRecords * | GetRecords () const
Gets the collection of data records.
CXTPGridRows * | GetRows () const
Gets the collection of grid rows.
XTPGridRowType | GetRowType () const
Gets the type of the selected rows (i.e.
virtual CXTPGridRecord * | AddRecord (CXTPGridRecord *pRecord)
Adds a record to the records collection.
virtual void | ResetContent ()
Deletes all rows and records from the section.
virtual void | Populate (BOOL bUpdate)
Populates the section with rows.
virtual void | ReSortRows ()
Re-sorts the rows for this section.
virtual void | RefreshIndexes ()
Recalculates the indexes for all rows.
virtual void | RefreshIndexes (int nIndexStart)
Recalculates the indexes for all rows.
virtual int | _DoExpand (int nIndex, CXTPGridRow *pRow, BOOL bUpdateSelection)
Expands all children of a specified row.
virtual int | _DoExpand (int nIndex, CXTPGridRow *pRow)
Expands all children of a specified row.
virtual int | _DoCollapse (CXTPGridRow *pRow)
Collapses all children of the specified row.
virtual void | Draw (CDC *pDC)
Draws this section on a specified device context.
virtual BOOL | IsVirtualMode () const
Determines if virtual mode is enabled/disabled for this section.
void | SetMarkupContext (CXTPMarkupContext *pMarkupContext)
Sets the markup context.
int | GetPopulatedRecordsCount () const
Gets the number of records after using m_strFilterText.
int | GetIndex () const
Gets the index of this section.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

void | BuildTree (CXTPGridRows *pTree, CXTPGridRow *pParentRow, CXTPGridRecords *pRecords)
Builds a rows tree based on the provided data record.
virtual void | SortTree (CXTPGridRows *pTree)
Sorts a rows tree collection according to the sort order for columns.
virtual void | SortRows (CXTPGridRows *pRows)
Sorts a rows collection according to the sort order for columns.
CXTPGridSelectedRows * | GetSelectedRows () const
Gets the collection of selected rows.
CXTPGridRow * | GetFocusedRow () const
Gets the currently focused row in the Grid control's view.
virtual int | GetScrollIndexV ()
Gets the current topmost row.
virtual void | SetScrollIndexV (int nIndex)
Sets the current topmost row.
virtual int | GetScrollOffsetV () const
Gets the vertical scroll offset.
virtual void | SetScrollOffsetV (int nScrollOffsetV)
Sets the vertical scroll offset.
void | CollapseAll ()
Collapses all rows.
void | ExpandAll (BOOL bRecursive)
Expands all rows.

Protected Attributes

CXTPMarkupContext * | m_pMarkupContext
Markup context.
CXTPGridBorder * | m_pBorder
Border.
CXTPGridControl * | m_pControl
Parent control.
CXTPGridRecords * | m_pRecords
Records container.
CXTPGridRows * | m_pRows
Rows container.
CXTPGridRows * | m_pTree
Tree rows container.
int | m_nPopulatedRecordsCount
Number of records after using m_strFilterText.
CRect | m_rcSection
The area occupied by the section.
CRect | m_rcDivider
Divider rectangle.
CXTPPaintManagerColor | m_clrDivider
Divider color.
XTPGridSectionDividerPosition | m_dividerPosition
Divider position.
XTPGridSectionDividerStyle | m_dividerStyle
Divider style.
XTPGridSectionHeightMode | m_heightMode
Height mode algorithm.
int | m_nHeight
Suggested height (Fixed/Relative).
BOOL | m_bAllowAccess
TRUE if rows can be selected.
BOOL | m_bAllowEdit
TRUE if rows can be edited.
BOOL | m_bAllowGroup
TRUE if rows can be grouped.
BOOL | m_bAllowSort
TRUE if rows can be sorted.
BOOL | m_bAllowFilter
TRUE if rows can be filtered.
BOOL | m_bSelectionEnable
TRUE if selection enabled.
BOOL | m_bVisible
TRUE if section is visible.
int | m_nScrollIndexV
Current top row in the visible area.
int | m_nScrollOffsetV
Vertical scroll offset.
CUIntArray | m_UaSorted
Sorted array.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

Represents a grid section.

Constructor & Destructor Documentation

◆ CXTPGridSection()

CXTPGridSection | ( | CXTPGridControl * | pControl,
 |  | XTPGridRowType | rowType )

Constructs a grid section.

Parameters
pControl | Pointer to the grid control.
rowType | Row type identifier.

Member Function Documentation

◆ _DoCollapse()

virtual int _DoCollapse ( CXTPGridRow * pRow )
virtual

Collapses all children of the specified row.

Parameters
pRow Pointer to a row to collapse.
Returns
The number of the collapsed rows.

◆ _DoExpand() [1/2]

virtual int _DoExpand | ( | int | nIndex,
 |  | CXTPGridRow * | pRow )
 virtual

Expands all children of a specified row.

Parameters
nIndex | Index to insert the expanded children at; used in recursion.
pRow | Pointer to a row to expand.
Returns
The number of expanded children.

◆ _DoExpand() [2/2]

virtual int _DoExpand | ( | int | nIndex,
 |  | CXTPGridRow * | pRow,
 |  | BOOL | bUpdateSelection )
 virtual

Expands all children of a specified row.

Parameters
nIndex | Index to insert the expanded children at; used in recursion.
pRow | Pointer to a row to expand.
bUpdateSelection | TRUE to update the rows selection. This is used to prevent multiple invocation of CXTPGridSelectedRows::_OnExpanded in recursion through InsertRow.
Returns
The number of expanded children.

◆ AddRecord()

virtual CXTPGridRecord * AddRecord ( CXTPGridRecord * pRecord )
virtual

Adds a record to the records collection.

Parameters
pRecord Pointer to a record to be added.

Call this member function if you want to add a record to the Grid control's internal storage.

Example:

// this function adds 2 empty records to a Grid control
void Add2Empties(CXTPGridControl* pGridCtrl)
{
    pGridCtrl->AddRecord(new CXTPGridRecord());
    pGridCtrl->AddRecord(new CXTPGridRecord());
}
Returns
Pointer to the recently added record object.
See also
CXTPGridRecord overview, GetRecords

◆ AllowAccess()

AFX_INLINE void AllowAccess ( BOOL bAllowAccess )

Specifies if the user is allowed to move the selection to rows.

Parameters
bAllowAccess TRUE to allow the user to move the selection to rows, FALSE otherwise.
See also
IsAllowAccess

◆ AllowEdit()

AFX_INLINE void AllowEdit ( BOOL bAllowEdit )

Specifies if the text in all CXTPGridRecordItem(s) can be edited.

Parameters
bAllowEdit TRUE to allow the text in CXTPGridRecordItem(s) to be edited, FALSE otherwise.

If bAllowEdit is set to TRUE, then an edit box will be added that allows for CXTPGridRecordItem(s) to be editable. If bAllowEdit is set to FALSE, then the edit box that allows for CXTPGridRecordItem(s) to be editable will be removed.

See also
IsAllowEdit, EditOnClick, IsEditOnClick

◆ AllowFilter()

AFX_INLINE void AllowFilter ( BOOL bAllowFilter )

Enables/disables row filtering.

Parameters
bAllowFilter TRUE to enable row filtering, FALSE to disable row filtering.
See also
IsAllowFilter

◆ AllowGroup()

AFX_INLINE void AllowGroup ( BOOL bAllowGroup )

Enables/disables row grouping.

Parameters
bAllowGroup TRUE to enable row grouping, FALSE to disable row grouping.
See also
IsAllowGroup

◆ AllowSort()

AFX_INLINE void AllowSort ( BOOL bAllowSort )

Enables/disables row sorting.

Parameters
bAllowSort TRUE to enable row sorting, FALSE to disable row sorting.
See also
IsAllowSort

◆ BuildTree()

void BuildTree | ( | CXTPGridRows * | pTree,
 |  | CXTPGridRow * | pParentRow,
 |  | CXTPGridRecords * | pRecords )
 protected

Builds a rows tree based on the provided data record.

Parameters
pTree | Pointer to the rows tree to add items into.
pParentRow | Pointer to the parent tree row.
pRecords | Pointer to the records collection to transfer to rows.

This method recursively calls itself when building nested branches of rows.

◆ CollapseAll()

void CollapseAll ( )
protected

Collapses all rows.

The CollapseAll method collapses all CXTPGridRow objects, including child rows, that are in the Grid control.

See also
ExpandAll, CXTPGridRow::SetExpanded

◆ Draw()

virtual void Draw ( CDC * pDC )
virtual

Draws this section on a specified device context.

Parameters
pDC Pointer to a device context to draw this section on.

◆ ExpandAll()

void ExpandAll ( BOOL bRecursive )
protected

Expands all rows.

Parameters
bRecursive TRUE to recursively expand all levels of child rows, FALSE to only expand one level of child rows.

The ExpandAll method expands all CXTPGridRow objects, including child rows, that are in the Grid control.

See also
CollapseAll, CXTPGridRow::SetExpanded

◆ GetBorder()

CXTPGridBorder * GetBorder ( ) const

Gets the border of this grid section.

Returns
The border of this grid section.

◆ GetDividerColor()

AFX_INLINE CXTPPaintManagerColor GetDividerColor ( ) const

Gets the divider color for this section.

Returns
The divider color for this section.
See also
SetDividerColor

◆ GetDividerPosition()

AFX_INLINE XTPGridSectionDividerPosition GetDividerPosition ( ) const

Gets the divider position for this section.

Returns
The divider position for this section; one of the values defined by the XTPGridSectionDividerPosition enumeration.
See also
SetDividerPosition

◆ GetDividerRect()

AFX_INLINE CRect GetDividerRect ( ) const

Gets the divider rectangle of this section.

Returns
The divider rectangle of this section.

◆ GetDividerStyle()

AFX_INLINE XTPGridSectionDividerStyle GetDividerStyle ( ) const

Gets the divider style for this section.

Returns
The divider style for this section; one of the values defined by the XTPGridSectionDividerStyle enumeration.
See also
SetDividerStyle

◆ GetFocusedRow()

CXTPGridRow * GetFocusedRow ( ) const
protected

Gets the currently focused row in the Grid control's view.

Returns
A pointer to the currently focused row if successful, otherwise NULL.

◆ GetHeight()

AFX_INLINE int GetHeight ( ) const

Gets the suggested height.

Returns
The suggested height.
See also
SetHeightMode

◆ GetHeightMode()

AFX_INLINE XTPGridSectionHeightMode GetHeightMode ( ) const

Gets the current height mode.

Returns
The current height mode; one of the values defined by the XTPGridSectionHeightMode enumeration.
See also
SetHeightMode

◆ GetIndex()

int GetIndex ( ) const

Gets the index of this section.

Returns
The index of this section.

◆ GetPopulatedRecordsCount()

AFX_INLINE int GetPopulatedRecordsCount ( ) const

Gets the number of records after using m_strFilterText.

Returns
The number of records after using m_strFilterText.

◆ GetRecords()

AFX_INLINE CXTPGridRecords * GetRecords ( ) const

Gets the collection of data records.

Returns
A pointer to the collection of data records.

Use this member function to retrieve access to the collection of grid data records. You may then perform standard operations on the collection (e.g. adding, removing, etc.).

See also
CXTPGridRecords overview, AddRecord

◆ GetRect()

AFX_INLINE CRect GetRect ( ) const

Gets the rectangle of this section.

Returns
The rectangle of this section.

◆ GetRows()

AFX_INLINE CXTPGridRows * GetRows ( ) const

Gets the collection of grid rows.

Use this member function to retrieve access to the collection of grid rows, representing the current control view. Note that the rows collection could be rebuilt automatically by executing the Populate method.

Returns
A pointer to the collection of grid rows.

Example: See example for the CXTPGridControl::BeginUpdate method.

See also
CXTPGridRows overview, Populate

◆ GetRowType()

XTPGridRowType GetRowType ( ) const

Gets the type of the selected rows (i.e.

body, header, or footer).

Returns
The type of the selected rows (i.e. body, header, or footer); one of the values defined by the XTPGridRowType enumeration.

◆ GetScrollIndexV()

virtual int GetScrollIndexV ( )
protectedvirtual

Gets the current topmost row.

Returns
The index of the current topmost row.

◆ GetScrollOffsetV()

virtual int GetScrollOffsetV ( ) const
protectedvirtual

Gets the vertical scroll offset.

Returns
The vertical scroll offset.

◆ GetSelectedRows()

CXTPGridSelectedRows * GetSelectedRows ( ) const
protected

Gets the collection of selected rows.

Use this member function to retrieve access to the collection of currently selected grid rows.

Returns
A pointer to the collection of selected rows.
See also
CXTPGridSelectedRows overview.

◆ IsAllowAccess()

AFX_INLINE BOOL IsAllowAccess ( ) const

Determines if the user is allowed to move the selection to rows.

Returns
TRUE if the user is allowed to move the selection to rows, otherwise FALSE.
See also
AllowAccess.

◆ IsAllowEdit()

AFX_INLINE BOOL IsAllowEdit ( ) const

Determines if the text in all CXTPGridRecordItem(s) can be edited.

Returns
TRUE if the text in all CXTPGridRecordItem(s) can be edited, otherwise FALSE.
See also
AllowEdit, EditOnClick, IsEditOnClick

◆ IsAllowFilter()

AFX_INLINE BOOL IsAllowFilter ( ) const

Determines if row filtering is enabled/disabled.

Returns
TRUE if row filtering is enabled, otherwise FALSE.
See also
AllowFilter

◆ IsAllowGroup()

AFX_INLINE BOOL IsAllowGroup ( ) const

Determines if row grouping is enabled/disabled.

Returns
TRUE if row grouping is enabled, otherwise FALSE.
See also
AllowGroup

◆ IsAllowSort()

AFX_INLINE BOOL IsAllowSort ( ) const

Determines if row sorting is enabled/disabled.

Returns
TRUE if row sorting is enabled, otherwise FALSE.
See also
AllowSort

◆ IsSelectionEnabled()

AFX_INLINE BOOL IsSelectionEnabled ( ) const

Determines if rows selection is enabled/disabled.

Returns
TRUE if rows selection is enabled, otherwise FALSE.
See also
SelectionEnable

◆ IsVirtualMode()

virtual BOOL IsVirtualMode ( ) const
virtual

Determines if virtual mode is enabled/disabled for this section.

Returns
TRUE if virtual mode is enabled for this section, FALSE if virtual mode is disabled for this section.

◆ IsVisible()

AFX_INLINE BOOL IsVisible ( ) const

Gets the visible state of the section.

Returns
TRUE if the section is visible, otherwise FALSE.
See also
SetVisible

◆ Populate()

virtual void Populate ( BOOL bUpdate )
virtual

Populates the section with rows.

Parameters
bUpdate TRUE to update the parent Grid control.

◆ RefreshIndexes()

virtual void RefreshIndexes ( int nIndexStart )
virtual

Recalculates the indexes for all rows.

Parameters
nIndexStart Specifies the zero-based index of the item before the first item

◆ SelectionEnable()

AFX_INLINE void SelectionEnable ( BOOL bEnable )

Enables/disables rows selection.

Parameters
bEnable TRUE to enable rows selection, FALSE to disable rows selection.
See also
IsSelectionEnabled

◆ SetDividerColor()

AFX_INLINE void SetDividerColor ( CXTPPaintManagerColor clrDivider )

Sets the divider color for this section.

Parameters
clrDivider New divider color.
See also
GetDividerColor

◆ SetDividerPosition()

AFX_INLINE void SetDividerPosition ( XTPGridSectionDividerPosition dividerPosition )

Sets the divider position for this section.

Parameters
dividerPosition New divider position; must be one of the values defined by the XTPGridSectionDividerPosition enumeration.
See also
GetDividerPosition

◆ SetDividerStyle()

AFX_INLINE void SetDividerStyle ( XTPGridSectionDividerStyle dividerStyle )

Sets the divider style for this section.

Parameters
dividerStyle New divider style; must be one of the values defined by the XTPGridSectionDividerStyle enumeration.
See also
GetDividerStyle

◆ SetHeight()

AFX_INLINE void SetHeight ( int nHeight )

Sets the suggested height.

Parameters
nHeight New suggested height.
See also
GetHeight

◆ SetHeightMode()

AFX_INLINE void SetHeightMode ( XTPGridSectionHeightMode heightMode )

Sets the current height mode.

Parameters
heightMode New height mode; must be one of the values defined by the XTPGridSectionHeightMode enumeration.
See also
GetHeightMode

◆ SetMarkupContext()

void SetMarkupContext ( CXTPMarkupContext * pMarkupContext )

Sets the markup context.

Parameters
pMarkupContext Pointer to the markup context to be set.

◆ SetScrollIndexV()

virtual void SetScrollIndexV ( int nIndex )
protectedvirtual

Sets the current topmost row.

Parameters
nIndex Index of the row to be set as the current topmost row.

◆ SetScrollOffsetV()

virtual void SetScrollOffsetV ( int nScrollOffsetV )
protectedvirtual

Sets the vertical scroll offset.

Parameters
nScrollOffsetV Vertical scroll offset to be set.

◆ SetVisible()

AFX_INLINE void SetVisible ( BOOL bVisible = TRUE )

Sets the visible state of the section.

Parameters
bVisible A BOOL value to define visible state.
See also
IsVisible

◆ SortRows()

virtual void SortRows ( CXTPGridRows * pRows )
protectedvirtual

Sorts a rows collection according to the sort order for columns.

Parameters
pRows Rows collection to sort.

◆ SortTree()

virtual void SortTree ( CXTPGridRows * pTree )
protectedvirtual

Sorts a rows tree collection according to the sort order for columns.

Parameters
pTree Rows tree collection to sort.

Member Data Documentation

◆ m_nScrollIndexV

int m_nScrollIndexV
protected

Current top row in the visible area.

IMPORTANT: With smooth scrolling this member may be -1 when the scrolling offset is changed and the new top row index is not yet recalculated. GetTopRowIndex() always returns the correct value.

The documentation for this class was generated from the following file:
  • XTPGridSection.h


Toolkit Pro: CXTPGridSections Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPGridSections Class Reference

Collection of sections. More...

Inheritance diagram for CXTPGridSections:
[legend]

Public Member Functions

CXTPGridSections (CXTPGridControl *pControl)
Constructs the collection and default sections.
~CXTPGridSections ()
Destructs the collection and sections.
virtual BOOL | EnsureVisible (CDC *pDC, CXTPGridRow *pRow)
Ensures that a Grid control row is at least partially visible.
CXTPGridRow * | GetFocusedRow () const
Gets the currently focused row in the Grid control's view.
CRect | GetRect () const
Retrieves the current rectangle for the sections.
CXTPGridSection * | HitTest (CPoint pt) const
Determines which section, if any, is at a specified point.
virtual void | Draw (CDC *pDC)
Draws the sections to the device context.
virtual void | AdjustLayout (CDC *pDC, CRect rcSections)
Adjusts section areas depending on the current control size.
void | SetMarkupContext (CXTPMarkupContext *pMarkupContext)
Sets the markup context.
virtual void | ReSortRows ()
Re-sorts the rows for all sections.
virtual void | RefreshIndexes (BOOL bAdjustLayout)
Recalculates the indices of all rows.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Attributes

CRect | m_rcSections
Sections rectangle.
CXTPGridControl * | m_pControl
Parent control.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

Collection of sections.

Constructor & Destructor Documentation

◆ CXTPGridSections()

CXTPGridSections ( CXTPGridControl * pControl )

Constructs the collection and default sections.

Parameters
pControl Pointer to the grid control.

Member Function Documentation

◆ AdjustLayout()

virtual void AdjustLayout | ( | CDC * | pDC,
 |  | CRect | rcSections )
 virtual

Adjusts section areas depending on the current control size.

Parameters
pDC | Target device context pointer.
rcSections | Target sections rectangle.

◆ Draw()

virtual void Draw ( CDC * pDC )
virtual

Draws the sections to the device context.

Parameters
pDC Pointer to the used device context.

◆ EnsureVisible()

virtual BOOL EnsureVisible | ( | CDC * | pDC,
 |  | CXTPGridRow * | pRow )
 virtual

Ensures that a Grid control row is at least partially visible.

Parameters
pDC | Pointer to a valid device context.
pRow | Pointer to the CXTPGridRow object whose visibility must be checked.

Ensures that a grid row item is at least partially visible. The list view control is scrolled if necessary.

Returns
TRUE if successful, otherwise FALSE.
See also
MoveDown, MoveUp, MovePageDown, MovePageUp, MoveFirst, MoveLast

◆ GetFocusedRow()

CXTPGridRow * GetFocusedRow ( ) const

Gets the currently focused row in the Grid control's view.

Returns
A pointer to the currently focused row in the Grid control's view if successful, otherwise NULL.

◆ GetRect()

CRect GetRect ( ) const

Retrieves the current rectangle for the sections.

Returns
A CRect containing the current rectangle for the sections.

◆ HitTest()

CXTPGridSection * HitTest ( CPoint pt ) const

Determines which section, if any, is at a specified point.

Parameters
pt Point to test.
Returns
A pointer to the section at the specified point, if any, otherwise NULL.

◆ RefreshIndexes()

virtual void RefreshIndexes ( BOOL bAdjustLayout )
virtual

Recalculates the indices of all rows.

Parameters
bAdjustLayout TRUE to adjust the layout.

◆ SetMarkupContext()

void SetMarkupContext ( CXTPMarkupContext * pMarkupContext )

Sets the markup context.

Parameters
pMarkupContext Pointer to the markup context to be set.
The documentation for this class was generated from the following file:
  • XTPGridSections.h


Toolkit Pro: CXTPGridSelectedRows Class Reference

Public Member Functions | List of all members
CXTPGridSelectedRows Class Reference

Encapsulates a collection of CXTPGridRow pointers that represent the selected rows in a Grid control. More...

Inheritance diagram for CXTPGridSelectedRows:
[legend]

Public Member Functions

CXTPGridSelectedRows (CXTPGridControl *pControl)
Constructs an empty CXTPGridSelectedRows collection.
void | SelectBlock (int nBlockBegin, int nBlockEnd, BOOL bControlKey=TRUE)
Selects a block of rows.
BOOL | Clear ()
Clears itself, removing all elements from the selection.
BOOL | Clear (BOOL bNotifyOnClear)
Clears itself, removing all elements from the selection.
BOOL | Add (CXTPGridRow *pRow)
Adds a row to the selection.
void | AddBlock (int nIndexBegin, int nIndexEnd, BOOL bDeselectIfSelected=FALSE)
Adds a block to the selection.
void | Remove (CXTPGridRow *pRow)
Removes a row from the selection.
BOOL | Contains (const CXTPGridRow *pRow)
Determines if a specified row is contained within the selection.
void | Invert (CXTPGridRow *pRow)
Inverts the selection for a specified row.
BOOL | Select (CXTPGridRow *pRow)
Clears the initial selection and selects a specified row.
void | DeselectBlock (int ib, int ie, BOOL bCollapsed)
Removes block [ib:ie] from the selection.
int | GetCount ()
Gets the number of selected rows in the collection.
CXTPGridRow * | GetAt (int nIndex)
Retrieves a specified row by its index.
POSITION | GetFirstSelectedRowPosition ()
Gets the position of the first selected row in the list Grid control.
CXTPGridRow * | GetNextSelectedRow (POSITION &pos)
Gets the next selected row in the list Grid control.
BOOL | IsChanged () const
Determines if the selection was changed.
void | SetChanged (BOOL bChanged=TRUE)
Specifies if the selection was changed.
BOOL | SwapIfNeed (int &indexB, int &indexE)
Swaps two integers.
void | SetNotifyOnClear (BOOL bNotifyOnClear=TRUE)
Specifies if clear notifications are enabled/disabled during CXTPGridSelectedRows::Select and SelectBlock.
BOOL | GetNotifyOnClear () const
Determines if clear notifications are enabled/disabled during CXTPGridSelectedRows::Select and SelectBlock.
XTPGridRowType | GetRowType () const
Gets the type of the selected rows (i.e.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

Encapsulates a collection of CXTPGridRow pointers that represent the selected rows in a Grid control.

Use this class to programmatically manage a collection of CXTPGridRow pointers that represent the selected rows in a Grid control. This class is commonly used to add or remove rows from the collection.

Typical work flow is using the Add and Remove methods to change the contents of the selection and using the Contains method to check if a specific row is present in the selection.

Example: The following example demonstrates how to programmatically use the CXTPGridSelectedRows class to select rows in the Grid control.

CXTPGridSelectedRows* pSelRows = pGridControl->GetSelectedRows();
pSelRows->Add(pRow1);
pSelRows->Add(pRow2);
_ASSERTE(TRUE == pSelRows->Contains(pRow1));
_ASSERTE(TRUE == pSelRows->Contains(pRow2));
pSelRows->Remove(pRow1);
_ASSERTE(FALSE == pSelRows->Contains(pRow1));
pSelRows->Select(pRow1);
_ASSERTE(TRUE == pSelRows->Contains(pRow1));
_ASSERTE(FALSE == pSelRows->Contains(pRow2));
See also
CXTPGridRow, CXTPGridSelectedRows, CXTPGridControl::GetSelectedRows

Constructor & Destructor Documentation

◆ CXTPGridSelectedRows()

CXTPGridSelectedRows ( CXTPGridControl * pControl )

Constructs an empty CXTPGridSelectedRows collection.

Parameters
pControl Pointer to the parent Grid control.

This collection can only be created in association with the CXTPGridControl object.

Example:

// from CXTPGridControl member function
CXTPGridSelectedRows* pSelectedRows = new CXTPGridSelectedRows(this);
See also
CXTPGridSelectedRows overview

Member Function Documentation

◆ Add()

BOOL Add ( CXTPGridRow * pRow )

Adds a row to the selection.

Parameters
pRow Pointer to the row to be added to the selection.

This method adds a provided row pointer to the selection. After adding, the Contains method will return TRUE for all checking attempts of this row pointer.

Example: See example at CXTPGridSelectedRows overview

Returns
TRUE if successful; otherwise FALSE.
See also
CXTPGridSelectedRows overview, Remove, Select, Clear, Contains

◆ AddBlock()

void AddBlock | ( | int | nIndexBegin,
 |  | int | nIndexEnd,
 |  | BOOL | bDeselectIfSelected = FALSE )

Adds a block to the selection.

Parameters
nIndexBegin | First row index of the block to be selected.
nIndexEnd | Final row index of the block to be selected.
bDeselectIfSelected | TRUE to deselect rows if all rows in the new selection [nIndexBegin:nIndexEnd] were selected before.

◆ Clear() [1/2]

BOOL Clear ( )

Clears itself, removing all elements from the selection.

Returns
TRUE if successful; otherwise FALSE.

◆ Clear() [2/2]

BOOL Clear ( BOOL bNotifyOnClear )

Clears itself, removing all elements from the selection.

Parameters
bNotifyOnClear TRUE to send a clear notification.
Returns
TRUE if successful; otherwise FALSE.

◆ Contains()

BOOL Contains ( const CXTPGridRow * pRow )

Determines if a specified row is contained within the selection.

Parameters
pRow Pointer to the row to check for.

Use this method to determine whether the CXTPGridSelectedRows contains the specified CXTPGridRow pointer.

Returns
TRUE if the row is contained within the selection, otherwise FALSE.

Example: See example at CXTPGridSelectedRows overview

See also
CXTPGridSelectedRows overview, Add, Remove, Select, Clear

◆ DeselectBlock()

void DeselectBlock | ( | int | ib,
 |  | int | ie,
 |  | BOOL | bCollapsed )

Removes block [ib:ie] from the selection.

Parameters
ib | First row index of the block to be deselected.
ie | Last row index of the block to be deselected.
bCollapsed | BOOL flag that specifies if rows are deleted or collapsed. If TRUE, then the selected rows below block [ib:ie] should be moved upward.
See also
CXTPGridSelectedRows overview, Add, Select, Clear, Contains, Remove

◆ GetAt()

CXTPGridRow * GetAt ( int nIndex )

Retrieves a specified row by its index.

Parameters
nIndex Index of the row to retrieve.
Returns
A pointer to the specified row.

Recommended to use the GetFirstSelectedRowPosition and GetNextSelectedRow methods.

See also
GetFirstSelectedRowPosition, GetNextSelectedRow

◆ GetCount()

int GetCount ( )

Gets the number of selected rows in the collection.

Returns
The number of selected rows in the collection.
See also
CXTPGridRows overview

◆ GetFirstSelectedRowPosition()

POSITION GetFirstSelectedRowPosition ( )

Gets the position of the first selected row in the list Grid control.

Returns
The position of the first selected row in the list Grid control if successful, or NULL if no items are selected.

The position of the first selected row in the list Grid control can be used for iteration or object pointer retrieval.

See also
GetNextSelectedItem

◆ GetNextSelectedRow()

CXTPGridRow * GetNextSelectedRow ( POSITION & pos )

Gets the next selected row in the list Grid control.

Parameters
pos Reference to a POSITION value returned by a previous call to GetNextSelectedRow or GetFirstSelectedRowPosition. This value is updated to the next position by this call.
Returns
A pointer to the next selected row in the list Grid control.

◆ GetNotifyOnClear()

AFX_INLINE BOOL GetNotifyOnClear ( ) const

Determines if clear notifications are enabled/disabled during CXTPGridSelectedRows::Select and SelectBlock.

Returns
TRUE if clear notification are enabled, FALSE if clear notifications are disabled.

If clear notifications are enabled (TRUE), then calling CXTPGridSelectedRows::Select and SelectBlock will send xtpGridSelectionClear notifications when the selected rows are internally cleared (i.e. normal behavior). If clear notifications are disabled (FALSE), then clear notifications will not be sent during CXTPGridSelectedRows::Select and SelectBlock.

◆ GetRowType()

AFX_INLINE XTPGridRowType GetRowType ( ) const

Gets the type of the selected rows (i.e.

body, header, or footer).

Returns
The type of the selected rows (i.e. body, header, or footer); one of the values defined by the XTPGridRowType enumeration.

◆ Invert()

void Invert ( CXTPGridRow * pRow )

Inverts the selection for a specified row.

Parameters
pRow Pointer to the row to invert the selection for.

This methods checks the specified row for its presence in the collection and either adds or removes it in the reverse order depending on the result.

Example:

CXTPGridSelectedRows* pSelRows = pGridControl->GetSelectedRows();
_ASSERTE(TRUE == pSelRows->Contains(pRow1));
pSelRows->Invert(pRow1);
_ASSERTE(FALSE == pSelRows->Contains(pRow1));
pSelRows->Invert(pRow1);
_ASSERTE(TRUE == pSelRows->Contains(pRow1));
See also
Add, Remove, Contains

◆ IsChanged()

AFX_INLINE BOOL IsChanged ( ) const

Determines if the selection was changed.

Returns
TRUE if the selection was changed, otherwise FALSE.

◆ Remove()

void Remove ( CXTPGridRow * pRow )

Removes a row from the selection.

Parameters
pRow Pointer to the row to be removed from the selection.

This method removes a provided row pointer from the selection. After removing, the Contains method will return FALSE for all checking attempts of this row pointer.

Example: See example at CXTPGridSelectedRows overview

See also
CXTPGridSelectedRows overview, Add, Select, Clear, Contains

◆ Select()

BOOL Select ( CXTPGridRow * pRow )

Clears the initial selection and selects a specified row.

Parameters
pRow Pointer to the row to select.

This method clears the initial selection and selects only the specified row.

Example: See example at CXTPGridSelectedRows overview

Returns
TRUE if successful; otherwise FALSE.
See also
CXTPGridSelectedRows overview, Add, Remove, Contains, Clear

◆ SelectBlock()

void SelectBlock | ( | int | nBlockBegin,
 |  | int | nBlockEnd,
 |  | BOOL | bControlKey = TRUE )

Selects a block of rows.

Parameters
nBlockBegin | First row index of the block.
nBlockEnd | Final row index of the block.
bControlKey | Indicates the control key button state during the selection operation.

This function uses nBlockBegin and nBlockEnd as the bounds for the required selection. It enumerates the parent Grid control rows collection and adds all rows from nBlockEnd to nBlockEnd inclusively to the selection.

◆ SetChanged()

AFX_INLINE void SetChanged ( BOOL bChanged = TRUE )

Specifies if the selection was changed.

Parameters
bChanged TRUE if the selection was changed, FALSE otherwise. By default, this parameter is TRUE.

◆ SetNotifyOnClear()

AFX_INLINE void SetNotifyOnClear ( BOOL bNotifyOnClear = TRUE )

Specifies if clear notifications are enabled/disabled during CXTPGridSelectedRows::Select and SelectBlock.

Parameters
bNotifyOnClear TRUE to enable clear notifications, FALSE to disable clear notifications. By default, this parameter is TRUE.

If clear notifications are enabled (TRUE), then calling CXTPGridSelectedRows::Select and SelectBlock will send xtpGridSelectionClear notifications when the selected rows are internally cleared (i.e. normal behavior). If clear notifications are disabled (FALSE), then clear notifications will not be sent during CXTPGridSelectedRows::Select and SelectBlock.

◆ SwapIfNeed()

BOOL SwapIfNeed | ( | int & | indexB,
 |  | int & | indexE )

Swaps two integers.

Parameters
indexB | Reference to the first integer.
indexE | Reference to the second integer.

The swap should only occur if indexB is greater than indexE.

Returns
TRUE if the operation was successful, otherwise FALSE.
The documentation for this class was generated from the following file:
  • XTPGridSelectedRows.h


Toolkit Pro: CXTPGridSubListControl Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPGridSubListControl Class Reference

Field chooser list box control. More...

Public Member Functions

CXTPGridSubListControl ()
Constructs a CXTPGridSubListControl object.
~CXTPGridSubListControl ()
Destroys a CXTPGridSubListControl object, handles cleanup and deallocation.
BOOL | SetGridCtrl (CXTPGridControl *pGridCtrl)
Sets the associated Grid control.
CXTPGridControl * GetGridCtrl ()
Gets the associated Grid control.
BOOL | UpdateList ()
Updates columns list data in the field chooser.
virtual BOOL | Include (int iSubItem)
Not used currently.
virtual BOOL | Disable (int iSubItem)
Not used currently.
void | SortAscending (BOOL bSort)
Specifies if the list should be sorted in ascending order.
CString | GetItemCaption (int nIndex)
Retrieves the caption of an item by its index.
CXTPGridColumn * | GetItemColumn (int nIndex)
Retrieves the column object of an item by its index.

Protected Member Functions

int | FindItemData (int nItemData)
Retrieves the index of an item by its data.
BOOL | BeginDrag (int nItem)
Called by the framework when a drag operation starts.
UINT | Dragging (CPoint pt)
Called by the framework when an item is being dragged within the CDragListBox object.
void | CancelDrag ()
Called by the framework when a drag operation has been canceled.
void | Dropped (CPoint pt)
Called by the framework when an item is dropped within a CDragListBox object.

Protected Attributes

CXTPGridControl * | m_pGridCtrl
Pointer to the parent Grid control.
CXTPGridHeaderDragWnd * | m_pDragWnd
Pointer to the associated dragging window.
CRect | m_rcDragWnd
Coordinates of the associated dragging window.
CRect | m_rcDropTarget1
First drop target - the list window itself.
CRect | m_rcDropTarget2
Second drop target - the grid header.
int | m_nDropIndex
Drop item index.
BOOL | m_bSortAscending
TRUE to sort items ascending in the list.

Detailed Description

Field chooser list box control.

This control allows the user to move column names from an associated CXTPGridControl object to and from its header.

To use a field chooser in an existing dialog box of your application, add a standard list box to your dialog template using the dialog editor and then initialize your CXTPGridSubListControl object inside the OnInitialUpdate dialog handler. See example below:

Example:

// CXTPGridSubListControl m_wndSubList;
wndSubList.SubclassDlgItem(IDC_COLUMNLIST, &pFieldChooserDialog);
// CXTPGridControl wndGrid;
wndGrid.GetGridHeader()->SetSubListCtrl(&wndSubList);
See also
CDragListBox, CXTPGridControl, CXTPGridHeader, CXTPGridHeaderDragWnd, GridControl sample application

Constructor & Destructor Documentation

◆ CXTPGridSubListControl()

CXTPGridSubListControl ( )

Constructs a CXTPGridSubListControl object.

You construct a CXTPGridSubListControl object in two steps. First, call the constructor CXTPGridSubListControl. Second, call CListBox::Create. This initializes the Windows list box and attaches it to the CXTPGridSubListControl.

Example:

// Declare a local CXTPGridSubListControl object.
CXTPGridSubListControl mySubList;

// Declare a dynamic CXTPGridSubListControl object.
CXTPGridSubListControl* pMySubList = new CXTPGridSubListControl;
See also
CListBox, CXTPGridSubListControl::SetGridCtrl, CXTPGridHeader::SetSubListCtrl

Member Function Documentation

◆ BeginDrag()

BOOL BeginDrag ( int nItem )
protected

Called by the framework when a drag operation starts.

Parameters
nItem Item being dragged.

Override this function if you want to control what happens when a drag operation begins. This implementation captures the mouse, creates a CXTPGridHeaderDragWnd and stays in drag mode until the user clicks the left or right mouse button or presses ESC, at which time the drag operation is canceled.

Returns
Nonzero if dragging is allowed, otherwise 0.
See also
CDragListBox::BeginDrag

◆ CancelDrag()

void CancelDrag ( )
protected

Called by the framework when a drag operation has been canceled.

Destroys the dragging CXTPGridHeaderDragWnd window and resets the associated Grid control mouse mode.

See also
CDragListBox::CancelDrag

◆ Disable()

virtual BOOL Disable ( int iSubItem )
virtual

Not used currently.

Parameters
iSubItem Sub-item number for disabling.
Returns
Nonzero if successful, otherwise 0.

◆ Dragging()

UINT Dragging ( CPoint pt )
protected

Called by the framework when an item is being dragged within the CDragListBox object.

Parameters
pt CPoint object that contains the x- and y- screen coordinates of the cursor.

This implementation allows dropping items only on the control itself and associated Grid control header. Override this function if you want to provide additional functionality.

Returns
The resource ID of the cursor to be displayed. The following values are possible: DL_COPYCURSOR: Indicates that the item will be copied. DL_MOVECURSOR: Indicates that the item will be moved. DL_STOPCURSOR: Indicates that the current drop target is not acceptable.
See also
CDragListBox::Dragging

◆ Dropped()

void Dropped ( CPoint pt )
protected

Called by the framework when an item is dropped within a CDragListBox object.

Parameters
pt CPoint object that contains the coordinates of the drop site.

Destroys the dragging CXTPGridHeaderDragWnd window and returns control to the caller.

See also
CDragListBox::Dropped

◆ FindItemData()

int FindItemData ( int nItemData )
protected

Retrieves the index of an item by its data.

Parameters
nItemData Data of the item with the index to retrieve.
Returns
The index of the item if successful, otherwise a value of -1.

◆ GetGridCtrl()

CXTPGridControl * GetGridCtrl ( )

Gets the associated Grid control.

Returns
A pointer to the associated Grid control.
See also
CXTPGridHeader::SetSubListCtrl, SetGridCtrl

◆ GetItemCaption()

CString GetItemCaption ( int nIndex )

Retrieves the caption of an item by its index.

Parameters
nIndex Index of the item with the caption to retrieve.
Returns
The caption of the item.

◆ GetItemColumn()

CXTPGridColumn * GetItemColumn ( int nIndex )

Retrieves the column object of an item by its index.

Parameters
nIndex Index of the item with the column object to retrieve.
Returns
A pointer to the CXTPGridColumn object of the item.

◆ Include()

virtual BOOL Include ( int iSubItem )
virtual

Not used currently.

Parameters
iSubItem Sub-item number for including.
Returns
Nonzero if successful, otherwise 0.

◆ SetGridCtrl()

BOOL SetGridCtrl ( CXTPGridControl * pGridCtrl )

Sets the associated Grid control.

Parameters
pGridCtrl Pointer to the associated Grid control to be set.

Usually this method should not be called by the user. Instead the user should call CXTPGridHeader::SetSubListCtrl.

Returns
TRUE if the associated Grid control was set successfully, otherwise FALSE.
See also
CXTPGridHeader::SetSubListCtrl, GetGridCtrl

◆ SortAscending()

void SortAscending ( BOOL bSort )

Specifies if the list should be sorted in ascending order.

Parameters
bSort TRUE to sort the list in ascending order.

◆ UpdateList()

BOOL UpdateList ( )

Updates columns list data in the field chooser.

Reloads the column list from the associated CXTPGridControl object, deletes all visible column items from the internal list, and adds the rest of the invisible items.

Example:

wndSubList.UpdateList();
Returns
TRUE if the update was successful, otherwise FALSE.
The documentation for this class was generated from the following file:
  • XTPGridSubListControl.h


Toolkit Pro: CXTPGridThemeDefault Class Reference

Public Member Functions | List of all members
CXTPGridThemeDefault Class Reference

CXTPGridThemeDefault is a CXTPGridPaintManager derived class that represents an Office 97 style theme. More...

Inheritance diagram for CXTPGridThemeDefault:
[legend]

Public Member Functions

CXTPGridThemeDefault ()
Default paint manager constructor, handles properties initialization.
virtual void | DrawColumnBackground (CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, BOOL &bColumnPressed, BOOL &bDraggingFromHeader, CXTPGridHeader *pHeader=NULL)
This method is called to draw the background of a column using the current column style.
- Public Member Functions inherited from CXTPGridPaintManager
CXTPGridPaintManager ()
Default CXTPGridPaintManager constructor, handles properties initialization.
virtual | ~CXTPGridPaintManager ()
Default CXTPGridPaintManager destructor, handles member items deallocation.
virtual void | SetGridControl (CXTPGridControl *pControl)
Sets the associated Grid control for the paint manager.
virtual void | LoadGlyphs ()
Loads the default images used by the Grid control.
virtual void | RefreshMetrics ()
Initializes all drawings defaults (fonts, colors, etc.).
virtual int | GetRowHeight (CDC *pDC, CXTPGridRow *pRow)
Retrieves the default row height for print mode (i.e.
virtual int | GetRowHeight (CDC *pDC, CXTPGridRow *pRow, int nTotalWidth)
Retrieves the default row height for print mode (i.e.
int | GetRowHeightEx (CDC *pDC, CXTPGridRow *pRow, int nTotalWidth, const BOOL firstLevel=TRUE)
Retrieves the default row height for print mode (i.e.
int | GetItemHeight (XTP_GRIDRECORDITEM_DRAWARGS &drawArgs, int nWidth)
Retrieves the height of a record item for a given width.
BOOL | FindRowAdjacentToMergedEx (const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, int &nAdjRowIndex, BOOL bUpward)
Searches the topmost or bottommost row depending on the height of the current row.
int | FindRowAdjacentToMerged (const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, BOOL bUpward)
Wrapper for the FindRowAdjacentToMergedEx method.
int | RecalcTotalHightOfMergedRows (CXTPGridColumns *pColumns, CDC *pDC, CXTPGridRow *pRow, int nRowHeight, int nTotalWidth)
Recalculates row height according to the height of merged items.
virtual int | GetPreviewItemHeight (CDC *pDC, CXTPGridRow *pRow, int nWidth, int nHeight)
Retrieves the height of a preview item for print mode.
virtual int | GetHeaderHeight ()
Gets the column header height.
virtual int | GetHeaderHeight (CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0)
Calculates the optimal header height.
virtual void | SetHeaderHeight (int nHeight)
Sets the column header height.
virtual int | GetFooterHeight (CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0)
Calculates the optimal footer height.
virtual COLORREF | GetControlBackColor (CXTPGridControl *pControl)
Retrieves the parent Grid control's background color.
virtual void | FillRow (CDC *pDC, CXTPGridRow *pRow, CRect rcRow)
Fills a specified row with its background color.
virtual void | DrawGrid (CDC *pDC, XTPGridOrientation orientation, CRect rcGrid)
Draws a grid for the control.
virtual void | DrawFreezeColsDivider (CDC *pDC, const CRect &rc, CXTPGridControl *pControl, CXTPGridRow *pRow=NULL)
Draws a freeze column divider.
virtual void | DrawVerticalTimeLineMarker (CDC *pDC, int xPos, CXTPGridControl *pControl, COLORREF color=RGB(0, 255, 0))
Draws a vertical timeline marker.
virtual void | DrawGroupRow (CDC *pDC, CXTPGridGroupRow *pRow, CRect rcRow, XTP_GRIDRECORDITEM_METRICS *pMetrics)
Draws a group row.
virtual void | FillGroupRowMetrics (CXTPGridGroupRow *pRow, XTP_GRIDRECORDITEM_METRICS *pMetrics, BOOL bPrinting)
Fills the font and color members of the metrics structure for a specified group row.
virtual void | FillIndent (CDC *pDC, CRect rcRow)
Fills an indent area by its background.
virtual void | FillItemShade (CDC *pDC, CRect rcItem)
Fills an item shade by its background if necessary.
virtual void | FillHeaderControl (CDC *pDC, CRect rcHeader)
Fills a column header control area by its background.
virtual void | FillFooter (CDC *pDC, CRect rcFooter)
Fills a column footer control area by its background.
virtual void | DrawColumnText (CDC *pDC, CRect rcText, CString strCaption, int nHeaderAlignment, BOOL bIsHeader, BOOL bColumnPressed)
Draws text for the column header.
virtual void | DrawColumn (CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn, BOOL bDrawExternal=FALSE, int nShadowWidth=0)
Draws a column header with all related attributes (sort order, icon, etc.).
virtual void | DrawColumnFooterDivider (CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn)
Draws the column footer divider.
virtual void | DrawColumnFooter (CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn)
Draws the column footer with all related attributes (e.g.
virtual BOOL | IsColumHotTrackingEnabled () const
Determines if hot tracking is enabled for the current column style.
virtual void | DrawFocusedRow (CDC *pDC, CRect rcRow)
Draws focused rows.
virtual void | FillGroupByControl (CDC *pDC, CRect &rcGroupBy)
Draws the Group By box.
CXTPImageManager * | GetGlyphs () const
Gets a pointer to the additional image list with glyphs.
void | DrawHorizontalLine (CDC *pDC, int xPos, int yPos, int cx, COLORREF clr)
Draws a horizontal line.
void | DrawVerticalLine (CDC *pDC, int xPos, int yPos, int cy, COLORREF clr)
Draws a vertical line.
virtual void | DrawTriangle (CDC *pDC, CRect rcTriangle, BOOL bToDown, BOOL bDraggingFromHeader, int nShadowWidth, BOOL bColumnPressed)
Draws a triangle that shows the sort order of the column.
void | DrawConnector (CDC *pDC, CPoint ptFrom, CPoint ptTo)
Draws a column connector for the Group By box.
virtual CSize | DrawCollapsedBitmap (CDC *pDC, const CXTPGridRow *pRow, CRect &rcBitmap)
Draws a collapsed bitmap.
virtual int | DrawBitmap (CDC *pDC, CXTPGridControl *pControl, CRect rcColumn, int iImage)
Draws a bitmap.
virtual int | DrawColumnIcon (CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, CRect rcIcon, int iIcon)
Draws an icon for a column.
virtual CSize | DrawGlyph (CDC *pDC, CRect rcColumn, int iImage)
Draws the standard glyphs of the Grid control.
virtual CSize | DrawShellIcon (CDC *pDC, CRect rcColumn, int iImage)
Draws the shell icon.
void | EnablePreviewMode (BOOL bIsPreviewMode)
Enables/disables preview mode for the control.
BOOL | IsPreviewMode () const
Determines if preview mode is enabled/disabled for the control.
CFont * | GetTextFont ()
Gets the default text font used for control items.
int | SetMaxPreviewLines (int nMaxLines)
Sets the maximum number of lines of text for a preview item.
int | GetMaxPreviewLines ()
Gets the maximum number of lines of text for a preview item.
int | GetPreviewLinesCount (CDC *pDC, CRect &rcText, const CString &strText)
Calculates the number of lines required to draw a specified preview text string, taking into account the maximum number of lines of text for a preview item.
BOOL | IsGridVisible (BOOL bVertical) const
Determines the visibility of specified grid lines.
BOOL | IsGridVisible (XTPGridOrientation orientation) const
Determines the visibility of specified grid lines.
void | SetColumnStyle (XTPGridColumnStyle columnStyle)
Sets the header style.
XTPGridColumnStyle | GetColumnStyle () const
Gets the header style.
void | SetColumnOffice2007CustomThemeBaseColor (COLORREF clrBaseColor)
Sets the header's custom theme base color for Office2007 column style.
COLORREF | GetColumnOffice2007CustomThemeBaseColor () const
Gets the header's custom theme base color for Office2007 column style.
void | SetTextFont (LOGFONT &lf)
Creates and sets the default text font.
void | SetCaptionFont (LOGFONT &lf)
Creates and sets the default caption font.
void | SetPreviewIndent (int nLeft, int nTop, int nRight, int nBottom)
Sets the preview item indent.
virtual void | DrawInplaceButton (CDC *pDC, CXTPGridInplaceButton *pButton)
Draws the in-place button of the Grid control.
virtual BOOL | DrawInplaceComboButton (CDC *pDC, CRect *pRc)
Draws the combo button of the Grid control.
virtual BOOL | DrawInplaceExpandButton (CDC *pDC, CRect *pRc)
Draws the expand button of the Grid control.
virtual BOOL | DrawInplaceSpinButton (CDC *pDC, CRect *pRc)
Draws the spin button of the Grid control.
virtual void | DrawTreeStructure (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CRect rcItem, CSize sizeGlyph)
Draws tree elements of the Grid control.
virtual void | DrawItemBitmap (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CRect &rcItem, int nImage)
Draws an item bitmap.
virtual void | DrawItemCaption (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics)
Draws an item caption.
virtual void | DrawRowNumber (CDC *pDC, CRect rcNumber, CXTPGridRow *pRow)
Draws a row number.
virtual void | DrawItemControl (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CXTPGridRecordItemControl *pControl, CRect &rcItem)
Draws an item control.
BOOL | IsFixedRowHeight () const
Determines if the paint manager supports fixed or variable row height.
void | SetFixedRowHeight (BOOL bFixedRowHeight)
Sets if the paint manager supports fixed or variable row height.
BOOL | IsColumnWidthWYSIWYG () const
Determines if the paint manager supports column width WYSIWYG mode.
BOOL | IsLastColumnWidthWYSIWYG () const
Determines if the paint manager supports last column width WYSIWYG mode.
BOOL | IsShowWYSIWYGMarkers () const
Determines if the paint manager shows WYSIWYG page-end markers.
void | ShowWYSIWYGMarkers (BOOL bSet)
Sets if the paint manager shows WYSIWYG page-end markers.
void | SetColumnWidthWYSIWYG (BOOL bColumnWidthWYSIWYG)
Sets if the paint manager supports column width WYSIWYG mode.
void | SetLastColumnWidthWYSIWYG (BOOL bColumnWidthWYSIWYG)
Sets if the paint manager supports last column width WYSIWYG mode.
BOOL | IsFixedInplaceButtonHeight () const
Determines if the paint manager supports fixed or variable in-place button height.
void | SetInplaceButtonHeight (BOOL bFixedInplaceButtonHeight)
Sets if the paint manager supports fixed or variable in-place button height.
int | GetFreezeColsDividerStyle () const
Gets the style of the freeze columns divider line.
void | SetFreezeColsDividerStyle (int nStyle)
Sets the style for the freeze columns divider line.
virtual BOOL | OnDrawAction (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs)
Override this method to perform custom activities for the item before processing it.
virtual void | DrawNoGroupByText (CDC *pDC, CRect rcItem)
Draws the "No items" text message in the Group By area when there are no items inside it.
BOOL | IsDrawGridForEmptySpace () const
Determines if the grid fills empty space after body rows.
void | SetDrawGridForEmptySpace (BOOL bDrawGrid)
Sets if the grid fills empty space after body rows.
BOOL | IsPrintGroupRowIcon () const
Determines if the group row collapse-expand icon is drawn in print mode.
void | SetPrintGroupRowIcon (BOOL bDraw)
Sets if the group row collapse-expand icon is drawn in print mode.
BOOL | IsColumnPlusMinusSign () const
Determines if columns use expand/collapse icons (+/-) or directional arrows.
void | SetColumnPlusMinusSign (BOOL bDraw)
Specifies if columns use expand/collapse icons (+/-) or directional arrows.
virtual int | CalculateRowHeight (CDC *pDC, const CString &strText, int nMaxWidth, BOOL bWordBreak=TRUE)
Calculates the height required for a rectangle bounding multi-line text to draw the multi-line text when the width of the rectangle is fixed.
void | DrawSectionDivider (CDC *pDC, const CRect &rc, XTPGridSectionDividerPosition dividerPosition, XTPGridSectionDividerStyle dividerStyle, CXTPPaintManagerColor dividerColor)
Draws the divider between grid sections (e.g.
int | GetSectionDividerHeight (XTPGridFixedRowsDividerStyle dividerStyle)
Gets the height of the section divider.
BOOL | IsUseDropMarker () const
Determines if a drop marker will be used when dragging and dropping.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPGridPaintManager
CXTPFont | m_xtpFontText
Grid items default text.
CXTPFont | m_xtpFontBoldText
Grid items default bold text.
CXTPFont | m_xtpFontCaption
Column header caption font.
CXTPFont | m_xtpFontPreview
Column header caption font.
CXTPGridHyperlinkStyle * | m_pHyperlinkStyle
Style for links.
CXTPGridHyperlinkStyle * | m_pHyperlinkHoverStyle
Style for hovered links.
CXTPPaintManagerColor | m_clrHighlight
Background color of the highlighted row.
CXTPPaintManagerColor | m_clrBoldText
Grid items bold text color.
CXTPPaintManagerColor | m_clrBoldTextHighlight
Grid items bold text highlight color.
CXTPPaintManagerColor | m_clrWindowText
Grid items default text color.
CXTPPaintManagerColor | m_clrHighlightText
Text color of the highlighted text.
CXTPPaintManagerColor | m_clrHeaderControl
Background color of the grid header.
CXTPPaintManagerColor | m_clrCaptionText
Column header text color.
CXTPPaintManagerColor | m_clrCaptionTextPressed
Column header text color when pressed.
CXTPPaintManagerColor | m_clrControlBack
Background color of the control grid area.
CXTPPaintManagerColor | m_clrGroupRowText
Row text color.
CXTPPaintManagerColor | m_clrGroupShadeBack
Group row background color when indentation shade is enabled.
CXTPPaintManagerColor | m_clrGroupShadeText
Group row foreground color when indentation shade is enabled.
CXTPPaintManagerColor | m_clrGroupShadeBorder
Color for group border's shade.
CXTPPaintManagerColor | m_clrGroupBoxBack
Color of group box.
CXTPPaintManagerColor | m_clrControlDark
Dark background color of the Grid control (used on Group By area).
CXTPPaintManagerColor | m_clrControlLightLight
Light background color used for drawing shades (used on column header area).
CXTPPaintManagerColor | m_clrHotDivider
Color of the column hot divider window (two arrows).
CXTPPaintManagerColor | m_clrIndentControl
Color of the tree indentation area.
CXTPPaintManagerColor | m_clrItemShade
Color of the shade on sorted by column items.
CXTPPaintManagerColor | m_clrBtnFace
Standard button face color.
CXTPPaintManagerColor | m_clrBtnText
Standard button text color.
CXTPPaintManagerColor | m_clrPreviewText
Preview text color.
CXTPPaintManagerColor | m_clrSelectedRow
Selected row background color.
CXTPPaintManagerColor | m_clrSelectedRowText
Selected row text color.
CXTPPaintManagerColor | m_clrBtnFacePressed
Standard button face color when pressed.
CXTPPaintManagerColor | m_clrConnector
Header column connector line color.
CXTPPaintManagerColor | m_clrDisableBitmapLightest
The lightest color of bitmap which covers disabled grid.
CXTPPaintManagerColor | m_clrDisableBitmapDarkest
The darkest color of bitmap which covers disabled grid.
CXTPPaintManagerColorGradient | m_grcGradientColumn
Color of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColorGradient | m_grcGradientColumnHot
HotTracking Color of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColorGradient | m_grcGradientColumnPushed
Pushed Color of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColor | m_clrGradientColumnShadow
Bottom shadow of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColor | m_clrGradientColumnSeparator
Separator of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColor | m_crlNoGroupByText
A color for "No items" text in GroupBy area (see m_strNoGroupBy member).
CXTPPaintManagerColor | m_clrFreezeColsDivider
Freeze Columns Divider color.
COLORREF | m_clrColumnOffice2007CustomTheme
Base color for Office2007 custom theme.
COLORREF | m_clrFormulaSum
Color for Formula Sum fields.
COLORREF | m_clrFormulaSubSum
Color for Formula SubSum fields.
COLORREF | m_clrAlternativeBackground
Color for Alternative Row Background.
BOOL | m_bUseAlternativeBackground
TRUE to use Alternative Row Background, FALSE otherwise.
BOOL | m_bAllowMergeCells
TRUE to Allow Merge Cells, FALSE otherwise.
int | m_nTextIndentForGroupRowsWithNoIcon
Specifies Text indent if a group row icon is not used.
int | m_nTreeIndent
Tree indentation.
int | m_nTreeStructureStyle
Tree structure style.
int | m_nTreeTextIndentRowParent
Text indent, in pixels, for rows with children.
int | m_nTreeTextIndentRowChildren
Text indent, in pixels, for rows without children.
int | m_nTreeTextIndent
Text indent, in pixels, for rows that are neither parent nor children.
int | m_nTreeTextIndentGroupRow
Text indent, in pixels, for group rows.
BOOL | m_bGroupRowTextBold
TRUE to draw group rows with bold text.
BOOL | m_bShadeGroupHeadings
TRUE to show the indentation shade, FALSE otherwise.
BOOL | m_bShadeSortColumn
TRUE to show the items shade in the sorted by column, FALSE otherwise.
BOOL | m_bHotTracking
TRUE to allow column hot tracking.
BOOL | m_bInvertColumnOnClick
TRUE to invert column on click.
CString | m_strNoItems
A string which contains customized "No Items" text for displaying in view when there are no visible rows.
CString | m_strSortBy
A string which contains customized "Sort By" text for displaying in tooltip.
CString | m_strIncreasing
A string which contains customized "Increasing" text for displaying in tooltip.
CString | m_strDecreasing
A string which contains customized "Decreasing" text for displaying in tooltip.
CString | m_strNoGroupBy
A string which contains customized "No items" text message for displaying in Group By area when there are no items inside it.
CString | m_strNoFieldsAvailable
A string which contains customized "No Fields Available" text message for displaying in Field Chooser.
CString | m_strExpand
A string which contains customized "Expand" text for displaying in tooltip.
CString | m_strCollapse
A string which contains customized "Collapse" text for displaying in tooltip.
BOOL | m_bHideSelection
TRUE when hiding Grid control's selection by drawing selected items as others, FALSE otherwise.
BOOL | m_bPrintSortTriangle
TRUE to show the sort triangle in printout.
BOOL | m_bRevertAlignment
TRUE to revert column alignments.
BOOL | m_bUseEditTextAlignment
TRUE to automatically apply edit alignment using column alignment.
BOOL | m_bShowLockIcon
TRUE to show the lock icon, FALSE to hide.
BOOL | m_bUseShellIcon
TRUE to use the shell icon, FALSE otherwise.
int | m_iRecOrRowStart
Start position in numbering (0 or 1 or something user want).
BOOL | m_bRecOrRowNum
TRUE to display record number if support mode is used, FALSE to display row number.
BOOL | m_bMakeUpper
TRUE to display column header and group row text in all caps.
XTPGridTreeStructureStyle | m_treeStructureStyle
Tree structure style.
CRect | m_rcPreviewIndent
Preview indentation.
int | m_nFixedColumnsIndent
Fixed Column total width.
BOOL | m_bMoveScrollbarOnFixedColumnsIndent
Move Scrollbar right follow FixedColumnsIndent.
BOOL | m_bThemedInplaceButtons
Draw in-place buttons using current theme settings.
BOOL | m_bBaseTreeIndent
TRUE to add Extra Tree indentation to cover initial TreeColumn.
CUIntArray | m_arStartCol
Start column in each virtual page.
int | m_PrintPageWidth
Width of print page (run-time)
BOOL | m_bPrintVirtualPageNumber
TRUE to print horizontal page number.
BOOL | m_bPrintPageRectangle
TRUE to draw rectangle around page.
int | m_RecordNumberWidth
Column width for row/record numbers.
BOOL | m_bForceDynamicMarkupForCell
TRUE if use Markup for Grid Record Item.
BOOL | m_bForceShowDropMarker
TRUE if Force Show Drop Marker.
BOOL | m_bShowNonActiveInPlaceButton
TRUE if use Show Non-Active In-Place Button (Combo, Expand, Spin).
BOOL | m_bPrintWatermark
TRUE to print watermark.
BOOL | m_bUseGroupRowSelectionState
TRUE if use GroupSelectionState Glyph.
BOOL | m_bForceShowTooltip
TRUE if use show tooltip for any cell width case.
BOOL | m_bCleanTooltip
TRUE if use show tooltip without markup.
BOOL | m_bGrayIfDisable
TRUE is disable draw in gray (standard behavior).
int | m_nRowHeightDefault
The default row height.
BOOL | m_bCompactText
TRUE to ignore Icon for Narrow column to show more text.
BOOL | m_bUseDropMarker
FALSE to not draw drop marked when dragging/dropping, TRUE by default.
BOOL | m_bSortTriangleOffsetFromRight
Offset of sort triangle.
int | m_nTreeColumnLineLength
This is the extra line length to apply to tree column lines if there is no expand button.
int | m_nBaseParentRecordIndent
This is initial number of pixels a parent node will be indented when in a group.
- Protected Member Functions inherited from CXTPGridPaintManager
virtual void | DrawTextLine (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nFlag, int &nCharCounter, int &nHyperlinkCounter)
Draws a line of text with respect to the drawing rectangle.
virtual int | DrawString (int *pnCurrDrawPos, CDC *pDC, const CString &strDraw, CRect rcDraw, UINT nFormat)
Draw a simple string into rectangle.
virtual void | DrawGridPattern (CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush)
Generates a custom grid pattern if necessary.
virtual void | DrawGridPattern (CDC *pDC, CXTPBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush)
Generates a custom grid pattern if necessary.
virtual void | DrawGridPattern (CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr)
Generates a custom grid pattern.
virtual void | DrawInplaceButtonFrame (CDC *pDC, CXTPGridInplaceButton *pButton)
Draws the in-place button frame.
virtual BOOL | DrawInplaceButtonIcon (CDC *pDC, CXTPGridInplaceButton *pButton)
Draws the in-place button icon.
virtual int | CalcColumnHeight (CDC *pDC, CXTPGridColumn *pColumn, int nTotalWidth=0)
Calculates the optimal height for a specified column.
virtual void | DrawMultiLineText (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, BOOL bWordBreak=TRUE)
Draws multi-line text.
virtual void | DrawSingleLineText (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nStartPos, int nEndPos, int nActualWidth)
Draws single-line text.
virtual int | DrawLink (int *pnCurrDrawPos, XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CXTPGridHyperlink *pHyperlink, CString strText, CRect rcLink, int nFlag, BOOL bTrim=FALSE)
Draws a hyperlink string using hyperlink text settings (i.e.
- Protected Attributes inherited from CXTPGridPaintManager
int | m_nRowHeight
Grid row default height.
int | m_nHeaderHeight
Column header height.
int | m_nFooterHeight
Column footer height.
int | m_nGroupGridLineHeight
The height of the group grid line.
CXTPImageManager * | m_pGlyphs
An additional image list for the Grid control.
BOOL | m_bIsPreviewMode
TRUE to show the item preview, FALSE to hide.
int | m_nResizingWidth
The width of the column resizing marker area.
int | m_nMaxPreviewLines
Restrict maximum lines for preview text.
CSize | m_szGlyph
Glyph size.
CXTPBrush | m_xtpBrushTreeStructure
Brush to draw tree nodes.
CXTPBrush | m_xtpBrushGroupGridLineStyle
Brush to draw group row grid lines.
int | m_nFreezeColsDividerStyle
A set of flags from XTPGridFreezeColsDividerStyle.
BOOL | m_bFixedRowHeight
TRUE if fixed rows used.
BOOL | m_bColumnWidthWYSIWYG
TRUE if columns width WYSIWYG mode used.
BOOL | m_bShowWYSIWYGMarkers
TRUE if in non-print mode header show red page-end markers.
BOOL | m_bLastColumnWidthWYSIWYG
TRUE if last column width WYSIWYG mode used.
BOOL | m_bDrawGridForEmptySpace
TRUE if grid fills the empty space (if any) after the body rows.
BOOL | m_bPrintGroupRowIcon
TRUE if printout draw collapse-expand icon for group row.
BOOL | m_bColumnPlusMinusSign
TRUE if expand/collapse icons are used, FALSE if directional arrows are used.
BOOL | m_bFixedInplaceButtonHeight
TRUE if fixed in-place button height is used.
XTPGridGridStyle | m_nGroupGridLineStyle
Current style for group row grid lines.
XTPGridColumnStyle | m_columnStyle
Column drawing style.
CXTPWinThemeWrapper * | m_themeHeader
Header theme wrapper.
CXTPWinThemeWrapper * | m_themeButton
In-place button theme wrapper.
CXTPWinThemeWrapper * | m_themeCombo
Combo box in-place button theme wrapper.
CXTPWinThemeWrapper * | m_themeSpin
Spin in-place button theme wrapper.
CXTPGridControl * | m_pControl
Pointer to the Grid control object.
CXTPMarkupUIElement * | m_pMarkupUIElement_NoGroupBy
The no group by markup UI element.
CString | m_strMarkupUIElement_NoGroupBy
The no group by markup UI element string.
CXTPBrush | m_xtpBrushVeriticalGrid
Brush to draw vertical grid lines.
CXTPBrush | m_xtpBrushHorizontalGrid
Brush to draw horizontal grid lines.
XTPGridGridStyle m_nGridLineStylePreviousV
Previous style for vertical grid lines.
XTPGridGridStyle m_nGridLineStylePreviousH
Previous style for horizontal grid lines.

Detailed Description

CXTPGridThemeDefault is a CXTPGridPaintManager derived class that represents an Office 97 style theme.

Member Function Documentation

◆ DrawColumnBackground()

virtual void DrawColumnBackground | ( | CDC * | pDC,
 |  | CXTPGridColumn * | pColumn,
 |  | CRect | rcColumn,
 |  | BOOL & | bColumnPressed,
 |  | BOOL & | bDraggingFromHeader,
 |  | CXTPGridHeader * | pHeader = NULL )
 virtual

This method is called to draw the background of a column using the current column style.

Parameters
pDC | Pointer to the used device context.
pColumn | Pointer to the column whose background must be drawn.
rcColumn | Bounding rectangle of the column.
bColumnPressed | TRUE if the column is pressed by the user.
bDraggingFromHeader | TRUE if the column is being dragged from the header area.
pHeader | Pointer to the header that the column belongs to.

Reimplemented from CXTPGridPaintManager.

The documentation for this class was generated from the following file:
  • XTPGridThemeDefault.h


Toolkit Pro: CXTPGridThemeExplorer Class Reference

Public Member Functions | List of all members
CXTPGridThemeExplorer Class Reference

CXTPGridThemeExplorer is a CXTPGridPaintManager derived class that represents an Explorer style theme. More...

Inheritance diagram for CXTPGridThemeExplorer:
[legend]

Public Member Functions

CXTPGridThemeExplorer ()
Default paint manager constructor, handles properties initialization.
virtual void | DrawTriangle (CDC *pDC, CRect rcTriangle, BOOL bToDown, int nShadowWidth=0)
Draws a triangle that shows the sort order of the column.
virtual CSize | DrawGlyph (CDC *pDC, CRect rcColumn, int iImage)
Draws the standard glyphs of the Grid control.
virtual BOOL | IsColumHotTrackingEnabled () const
Determines if hot tracking is enabled for the current column style.
virtual void | DrawColumnBackground (CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, BOOL &bColumnPressed, BOOL &bDraggingFromHeader, CXTPGridHeader *pHeader=NULL)
This method is called to draw the background of a column using the current column style.
void | DrawSectionDivider (CDC *pDC, const CRect &rc, XTPGridSectionDividerPosition dividerPosition, XTPGridSectionDividerStyle dividerStyle, CXTPPaintManagerColor dividerColor)
Draws the divider between grid sections (e.g.
virtual void | DrawTriangle (CDC *pDC, CRect rcTriangle, BOOL bToDown, BOOL bDraggingFromHeader, int nShadowWidth, BOOL bColumnPressed)
Draws a triangle that shows the sort order of the column.
- Public Member Functions inherited from CXTPGridPaintManager
CXTPGridPaintManager ()
Default CXTPGridPaintManager constructor, handles properties initialization.
virtual | ~CXTPGridPaintManager ()
Default CXTPGridPaintManager destructor, handles member items deallocation.
virtual void | SetGridControl (CXTPGridControl *pControl)
Sets the associated Grid control for the paint manager.
virtual void | LoadGlyphs ()
Loads the default images used by the Grid control.
virtual void | RefreshMetrics ()
Initializes all drawings defaults (fonts, colors, etc.).
virtual int | GetRowHeight (CDC *pDC, CXTPGridRow *pRow)
Retrieves the default row height for print mode (i.e.
virtual int | GetRowHeight (CDC *pDC, CXTPGridRow *pRow, int nTotalWidth)
Retrieves the default row height for print mode (i.e.
int | GetRowHeightEx (CDC *pDC, CXTPGridRow *pRow, int nTotalWidth, const BOOL firstLevel=TRUE)
Retrieves the default row height for print mode (i.e.
int | GetItemHeight (XTP_GRIDRECORDITEM_DRAWARGS &drawArgs, int nWidth)
Retrieves the height of a record item for a given width.
BOOL | FindRowAdjacentToMergedEx (const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, int &nAdjRowIndex, BOOL bUpward)
Searches the topmost or bottommost row depending on the height of the current row.
int | FindRowAdjacentToMerged (const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, BOOL bUpward)
Wrapper for the FindRowAdjacentToMergedEx method.
int | RecalcTotalHightOfMergedRows (CXTPGridColumns *pColumns, CDC *pDC, CXTPGridRow *pRow, int nRowHeight, int nTotalWidth)
Recalculates row height according to the height of merged items.
virtual int | GetPreviewItemHeight (CDC *pDC, CXTPGridRow *pRow, int nWidth, int nHeight)
Retrieves the height of a preview item for print mode.
virtual int | GetHeaderHeight ()
Gets the column header height.
virtual int | GetHeaderHeight (CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0)
Calculates the optimal header height.
virtual void | SetHeaderHeight (int nHeight)
Sets the column header height.
virtual int | GetFooterHeight (CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0)
Calculates the optimal footer height.
virtual COLORREF | GetControlBackColor (CXTPGridControl *pControl)
Retrieves the parent Grid control's background color.
virtual void | FillRow (CDC *pDC, CXTPGridRow *pRow, CRect rcRow)
Fills a specified row with its background color.
virtual void | DrawGrid (CDC *pDC, XTPGridOrientation orientation, CRect rcGrid)
Draws a grid for the control.
virtual void | DrawFreezeColsDivider (CDC *pDC, const CRect &rc, CXTPGridControl *pControl, CXTPGridRow *pRow=NULL)
Draws a freeze column divider.
virtual void | DrawVerticalTimeLineMarker (CDC *pDC, int xPos, CXTPGridControl *pControl, COLORREF color=RGB(0, 255, 0))
Draws a vertical timeline marker.
virtual void | DrawGroupRow (CDC *pDC, CXTPGridGroupRow *pRow, CRect rcRow, XTP_GRIDRECORDITEM_METRICS *pMetrics)
Draws a group row.
virtual void | FillGroupRowMetrics (CXTPGridGroupRow *pRow, XTP_GRIDRECORDITEM_METRICS *pMetrics, BOOL bPrinting)
Fills the font and color members of the metrics structure for a specified group row.
virtual void | FillIndent (CDC *pDC, CRect rcRow)
Fills an indent area by its background.
virtual void | FillItemShade (CDC *pDC, CRect rcItem)
Fills an item shade by its background if necessary.
virtual void | FillHeaderControl (CDC *pDC, CRect rcHeader)
Fills a column header control area by its background.
virtual void | FillFooter (CDC *pDC, CRect rcFooter)
Fills a column footer control area by its background.
virtual void | DrawColumnText (CDC *pDC, CRect rcText, CString strCaption, int nHeaderAlignment, BOOL bIsHeader, BOOL bColumnPressed)
Draws text for the column header.
virtual void | DrawColumn (CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn, BOOL bDrawExternal=FALSE, int nShadowWidth=0)
Draws a column header with all related attributes (sort order, icon, etc.).
virtual void | DrawColumnFooterDivider (CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn)
Draws the column footer divider.
virtual void | DrawColumnFooter (CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn)
Draws the column footer with all related attributes (e.g.
virtual void | DrawFocusedRow (CDC *pDC, CRect rcRow)
Draws focused rows.
virtual void | FillGroupByControl (CDC *pDC, CRect &rcGroupBy)
Draws the Group By box.
CXTPImageManager * | GetGlyphs () const
Gets a pointer to the additional image list with glyphs.
void | DrawHorizontalLine (CDC *pDC, int xPos, int yPos, int cx, COLORREF clr)
Draws a horizontal line.
void | DrawVerticalLine (CDC *pDC, int xPos, int yPos, int cy, COLORREF clr)
Draws a vertical line.
void | DrawConnector (CDC *pDC, CPoint ptFrom, CPoint ptTo)
Draws a column connector for the Group By box.
virtual CSize | DrawCollapsedBitmap (CDC *pDC, const CXTPGridRow *pRow, CRect &rcBitmap)
Draws a collapsed bitmap.
virtual int | DrawBitmap (CDC *pDC, CXTPGridControl *pControl, CRect rcColumn, int iImage)
Draws a bitmap.
virtual int | DrawColumnIcon (CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, CRect rcIcon, int iIcon)
Draws an icon for a column.
virtual CSize | DrawShellIcon (CDC *pDC, CRect rcColumn, int iImage)
Draws the shell icon.
void | EnablePreviewMode (BOOL bIsPreviewMode)
Enables/disables preview mode for the control.
BOOL | IsPreviewMode () const
Determines if preview mode is enabled/disabled for the control.
CFont * | GetTextFont ()
Gets the default text font used for control items.
int | SetMaxPreviewLines (int nMaxLines)
Sets the maximum number of lines of text for a preview item.
int | GetMaxPreviewLines ()
Gets the maximum number of lines of text for a preview item.
int | GetPreviewLinesCount (CDC *pDC, CRect &rcText, const CString &strText)
Calculates the number of lines required to draw a specified preview text string, taking into account the maximum number of lines of text for a preview item.
BOOL | IsGridVisible (BOOL bVertical) const
Determines the visibility of specified grid lines.
BOOL | IsGridVisible (XTPGridOrientation orientation) const
Determines the visibility of specified grid lines.
void | SetColumnStyle (XTPGridColumnStyle columnStyle)
Sets the header style.
XTPGridColumnStyle | GetColumnStyle () const
Gets the header style.
void | SetColumnOffice2007CustomThemeBaseColor (COLORREF clrBaseColor)
Sets the header's custom theme base color for Office2007 column style.
COLORREF | GetColumnOffice2007CustomThemeBaseColor () const
Gets the header's custom theme base color for Office2007 column style.
void | SetTextFont (LOGFONT &lf)
Creates and sets the default text font.
void | SetCaptionFont (LOGFONT &lf)
Creates and sets the default caption font.
void | SetPreviewIndent (int nLeft, int nTop, int nRight, int nBottom)
Sets the preview item indent.
virtual void | DrawInplaceButton (CDC *pDC, CXTPGridInplaceButton *pButton)
Draws the in-place button of the Grid control.
virtual BOOL | DrawInplaceComboButton (CDC *pDC, CRect *pRc)
Draws the combo button of the Grid control.
virtual BOOL | DrawInplaceExpandButton (CDC *pDC, CRect *pRc)
Draws the expand button of the Grid control.
virtual BOOL | DrawInplaceSpinButton (CDC *pDC, CRect *pRc)
Draws the spin button of the Grid control.
virtual void | DrawTreeStructure (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CRect rcItem, CSize sizeGlyph)
Draws tree elements of the Grid control.
virtual void | DrawItemBitmap (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CRect &rcItem, int nImage)
Draws an item bitmap.
virtual void | DrawItemCaption (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics)
Draws an item caption.
virtual void | DrawRowNumber (CDC *pDC, CRect rcNumber, CXTPGridRow *pRow)
Draws a row number.
virtual void | DrawItemControl (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CXTPGridRecordItemControl *pControl, CRect &rcItem)
Draws an item control.
BOOL | IsFixedRowHeight () const
Determines if the paint manager supports fixed or variable row height.
void | SetFixedRowHeight (BOOL bFixedRowHeight)
Sets if the paint manager supports fixed or variable row height.
BOOL | IsColumnWidthWYSIWYG () const
Determines if the paint manager supports column width WYSIWYG mode.
BOOL | IsLastColumnWidthWYSIWYG () const
Determines if the paint manager supports last column width WYSIWYG mode.
BOOL | IsShowWYSIWYGMarkers () const
Determines if the paint manager shows WYSIWYG page-end markers.
void | ShowWYSIWYGMarkers (BOOL bSet)
Sets if the paint manager shows WYSIWYG page-end markers.
void | SetColumnWidthWYSIWYG (BOOL bColumnWidthWYSIWYG)
Sets if the paint manager supports column width WYSIWYG mode.
void | SetLastColumnWidthWYSIWYG (BOOL bColumnWidthWYSIWYG)
Sets if the paint manager supports last column width WYSIWYG mode.
BOOL | IsFixedInplaceButtonHeight () const
Determines if the paint manager supports fixed or variable in-place button height.
void | SetInplaceButtonHeight (BOOL bFixedInplaceButtonHeight)
Sets if the paint manager supports fixed or variable in-place button height.
int | GetFreezeColsDividerStyle () const
Gets the style of the freeze columns divider line.
void | SetFreezeColsDividerStyle (int nStyle)
Sets the style for the freeze columns divider line.
virtual BOOL | OnDrawAction (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs)
Override this method to perform custom activities for the item before processing it.
virtual void | DrawNoGroupByText (CDC *pDC, CRect rcItem)
Draws the "No items" text message in the Group By area when there are no items inside it.
BOOL | IsDrawGridForEmptySpace () const
Determines if the grid fills empty space after body rows.
void | SetDrawGridForEmptySpace (BOOL bDrawGrid)
Sets if the grid fills empty space after body rows.
BOOL | IsPrintGroupRowIcon () const
Determines if the group row collapse-expand icon is drawn in print mode.
void | SetPrintGroupRowIcon (BOOL bDraw)
Sets if the group row collapse-expand icon is drawn in print mode.
BOOL | IsColumnPlusMinusSign () const
Determines if columns use expand/collapse icons (+/-) or directional arrows.
void | SetColumnPlusMinusSign (BOOL bDraw)
Specifies if columns use expand/collapse icons (+/-) or directional arrows.
virtual int | CalculateRowHeight (CDC *pDC, const CString &strText, int nMaxWidth, BOOL bWordBreak=TRUE)
Calculates the height required for a rectangle bounding multi-line text to draw the multi-line text when the width of the rectangle is fixed.
void | DrawSectionDivider (CDC *pDC, const CRect &rc, XTPGridSectionDividerPosition dividerPosition, XTPGridSectionDividerStyle dividerStyle, CXTPPaintManagerColor dividerColor)
Draws the divider between grid sections (e.g.
int | GetSectionDividerHeight (XTPGridFixedRowsDividerStyle dividerStyle)
Gets the height of the section divider.
BOOL | IsUseDropMarker () const
Determines if a drop marker will be used when dragging and dropping.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPGridPaintManager
CXTPFont | m_xtpFontText
Grid items default text.
CXTPFont | m_xtpFontBoldText
Grid items default bold text.
CXTPFont | m_xtpFontCaption
Column header caption font.
CXTPFont | m_xtpFontPreview
Column header caption font.
CXTPGridHyperlinkStyle * | m_pHyperlinkStyle
Style for links.
CXTPGridHyperlinkStyle * | m_pHyperlinkHoverStyle
Style for hovered links.
CXTPPaintManagerColor | m_clrHighlight
Background color of the highlighted row.
CXTPPaintManagerColor | m_clrBoldText
Grid items bold text color.
CXTPPaintManagerColor | m_clrBoldTextHighlight
Grid items bold text highlight color.
CXTPPaintManagerColor | m_clrWindowText
Grid items default text color.
CXTPPaintManagerColor | m_clrHighlightText
Text color of the highlighted text.
CXTPPaintManagerColor | m_clrHeaderControl
Background color of the grid header.
CXTPPaintManagerColor | m_clrCaptionText
Column header text color.
CXTPPaintManagerColor | m_clrCaptionTextPressed
Column header text color when pressed.
CXTPPaintManagerColor | m_clrControlBack
Background color of the control grid area.
CXTPPaintManagerColor | m_clrGroupRowText
Row text color.
CXTPPaintManagerColor | m_clrGroupShadeBack
Group row background color when indentation shade is enabled.
CXTPPaintManagerColor | m_clrGroupShadeText
Group row foreground color when indentation shade is enabled.
CXTPPaintManagerColor | m_clrGroupShadeBorder
Color for group border's shade.
CXTPPaintManagerColor | m_clrGroupBoxBack
Color of group box.
CXTPPaintManagerColor | m_clrControlDark
Dark background color of the Grid control (used on Group By area).
CXTPPaintManagerColor | m_clrControlLightLight
Light background color used for drawing shades (used on column header area).
CXTPPaintManagerColor | m_clrHotDivider
Color of the column hot divider window (two arrows).
CXTPPaintManagerColor | m_clrIndentControl
Color of the tree indentation area.
CXTPPaintManagerColor | m_clrItemShade
Color of the shade on sorted by column items.
CXTPPaintManagerColor | m_clrBtnFace
Standard button face color.
CXTPPaintManagerColor | m_clrBtnText
Standard button text color.
CXTPPaintManagerColor | m_clrPreviewText
Preview text color.
CXTPPaintManagerColor | m_clrSelectedRow
Selected row background color.
CXTPPaintManagerColor | m_clrSelectedRowText
Selected row text color.
CXTPPaintManagerColor | m_clrBtnFacePressed
Standard button face color when pressed.
CXTPPaintManagerColor | m_clrConnector
Header column connector line color.
CXTPPaintManagerColor | m_clrDisableBitmapLightest
The lightest color of bitmap which covers disabled grid.
CXTPPaintManagerColor | m_clrDisableBitmapDarkest
The darkest color of bitmap which covers disabled grid.
CXTPPaintManagerColorGradient | m_grcGradientColumn
Color of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColorGradient | m_grcGradientColumnHot
HotTracking Color of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColorGradient | m_grcGradientColumnPushed
Pushed Color of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColor | m_clrGradientColumnShadow
Bottom shadow of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColor | m_clrGradientColumnSeparator
Separator of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColor | m_crlNoGroupByText
A color for "No items" text in GroupBy area (see m_strNoGroupBy member).
CXTPPaintManagerColor | m_clrFreezeColsDivider
Freeze Columns Divider color.
COLORREF | m_clrColumnOffice2007CustomTheme
Base color for Office2007 custom theme.
COLORREF | m_clrFormulaSum
Color for Formula Sum fields.
COLORREF | m_clrFormulaSubSum
Color for Formula SubSum fields.
COLORREF | m_clrAlternativeBackground
Color for Alternative Row Background.
BOOL | m_bUseAlternativeBackground
TRUE to use Alternative Row Background, FALSE otherwise.
BOOL | m_bAllowMergeCells
TRUE to Allow Merge Cells, FALSE otherwise.
int | m_nTextIndentForGroupRowsWithNoIcon
Specifies Text indent if a group row icon is not used.
int | m_nTreeIndent
Tree indentation.
int | m_nTreeStructureStyle
Tree structure style.
int | m_nTreeTextIndentRowParent
Text indent, in pixels, for rows with children.
int | m_nTreeTextIndentRowChildren
Text indent, in pixels, for rows without children.
int | m_nTreeTextIndent
Text indent, in pixels, for rows that are neither parent nor children.
int | m_nTreeTextIndentGroupRow
Text indent, in pixels, for group rows.
BOOL | m_bGroupRowTextBold
TRUE to draw group rows with bold text.
BOOL | m_bShadeGroupHeadings
TRUE to show the indentation shade, FALSE otherwise.
BOOL | m_bShadeSortColumn
TRUE to show the items shade in the sorted by column, FALSE otherwise.
BOOL | m_bHotTracking
TRUE to allow column hot tracking.
BOOL | m_bInvertColumnOnClick
TRUE to invert column on click.
CString | m_strNoItems
A string which contains customized "No Items" text for displaying in view when there are no visible rows.
CString | m_strSortBy
A string which contains customized "Sort By" text for displaying in tooltip.
CString | m_strIncreasing
A string which contains customized "Increasing" text for displaying in tooltip.
CString | m_strDecreasing
A string which contains customized "Decreasing" text for displaying in tooltip.
CString | m_strNoGroupBy
A string which contains customized "No items" text message for displaying in Group By area when there are no items inside it.
CString | m_strNoFieldsAvailable
A string which contains customized "No Fields Available" text message for displaying in Field Chooser.
CString | m_strExpand
A string which contains customized "Expand" text for displaying in tooltip.
CString | m_strCollapse
A string which contains customized "Collapse" text for displaying in tooltip.
BOOL | m_bHideSelection
TRUE when hiding Grid control's selection by drawing selected items as others, FALSE otherwise.
BOOL | m_bPrintSortTriangle
TRUE to show the sort triangle in printout.
BOOL | m_bRevertAlignment
TRUE to revert column alignments.
BOOL | m_bUseEditTextAlignment
TRUE to automatically apply edit alignment using column alignment.
BOOL | m_bShowLockIcon
TRUE to show the lock icon, FALSE to hide.
BOOL | m_bUseShellIcon
TRUE to use the shell icon, FALSE otherwise.
int | m_iRecOrRowStart
Start position in numbering (0 or 1 or something user want).
BOOL | m_bRecOrRowNum
TRUE to display record number if support mode is used, FALSE to display row number.
BOOL | m_bMakeUpper
TRUE to display column header and group row text in all caps.
XTPGridTreeStructureStyle | m_treeStructureStyle
Tree structure style.
CRect | m_rcPreviewIndent
Preview indentation.
int | m_nFixedColumnsIndent
Fixed Column total width.
BOOL | m_bMoveScrollbarOnFixedColumnsIndent
Move Scrollbar right follow FixedColumnsIndent.
BOOL | m_bThemedInplaceButtons
Draw in-place buttons using current theme settings.
BOOL | m_bBaseTreeIndent
TRUE to add Extra Tree indentation to cover initial TreeColumn.
CUIntArray | m_arStartCol
Start column in each virtual page.
int | m_PrintPageWidth
Width of print page (run-time)
BOOL | m_bPrintVirtualPageNumber
TRUE to print horizontal page number.
BOOL | m_bPrintPageRectangle
TRUE to draw rectangle around page.
int | m_RecordNumberWidth
Column width for row/record numbers.
BOOL | m_bForceDynamicMarkupForCell
TRUE if use Markup for Grid Record Item.
BOOL | m_bForceShowDropMarker
TRUE if Force Show Drop Marker.
BOOL | m_bShowNonActiveInPlaceButton
TRUE if use Show Non-Active In-Place Button (Combo, Expand, Spin).
BOOL | m_bPrintWatermark
TRUE to print watermark.
BOOL | m_bUseGroupRowSelectionState
TRUE if use GroupSelectionState Glyph.
BOOL | m_bForceShowTooltip
TRUE if use show tooltip for any cell width case.
BOOL | m_bCleanTooltip
TRUE if use show tooltip without markup.
BOOL | m_bGrayIfDisable
TRUE is disable draw in gray (standard behavior).
int | m_nRowHeightDefault
The default row height.
BOOL | m_bCompactText
TRUE to ignore Icon for Narrow column to show more text.
BOOL | m_bUseDropMarker
FALSE to not draw drop marked when dragging/dropping, TRUE by default.
BOOL | m_bSortTriangleOffsetFromRight
Offset of sort triangle.
int | m_nTreeColumnLineLength
This is the extra line length to apply to tree column lines if there is no expand button.
int | m_nBaseParentRecordIndent
This is initial number of pixels a parent node will be indented when in a group.
- Protected Member Functions inherited from CXTPGridPaintManager
virtual void | DrawTextLine (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nFlag, int &nCharCounter, int &nHyperlinkCounter)
Draws a line of text with respect to the drawing rectangle.
virtual int | DrawString (int *pnCurrDrawPos, CDC *pDC, const CString &strDraw, CRect rcDraw, UINT nFormat)
Draw a simple string into rectangle.
virtual void | DrawGridPattern (CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush)
Generates a custom grid pattern if necessary.
virtual void | DrawGridPattern (CDC *pDC, CXTPBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush)
Generates a custom grid pattern if necessary.
virtual void | DrawGridPattern (CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr)
Generates a custom grid pattern.
virtual void | DrawInplaceButtonFrame (CDC *pDC, CXTPGridInplaceButton *pButton)
Draws the in-place button frame.
virtual BOOL | DrawInplaceButtonIcon (CDC *pDC, CXTPGridInplaceButton *pButton)
Draws the in-place button icon.
virtual int | CalcColumnHeight (CDC *pDC, CXTPGridColumn *pColumn, int nTotalWidth=0)
Calculates the optimal height for a specified column.
virtual void | DrawMultiLineText (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, BOOL bWordBreak=TRUE)
Draws multi-line text.
virtual void | DrawSingleLineText (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nStartPos, int nEndPos, int nActualWidth)
Draws single-line text.
virtual int | DrawLink (int *pnCurrDrawPos, XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CXTPGridHyperlink *pHyperlink, CString strText, CRect rcLink, int nFlag, BOOL bTrim=FALSE)
Draws a hyperlink string using hyperlink text settings (i.e.
- Protected Attributes inherited from CXTPGridPaintManager
int | m_nRowHeight
Grid row default height.
int | m_nHeaderHeight
Column header height.
int | m_nFooterHeight
Column footer height.
int | m_nGroupGridLineHeight
The height of the group grid line.
CXTPImageManager * | m_pGlyphs
An additional image list for the Grid control.
BOOL | m_bIsPreviewMode
TRUE to show the item preview, FALSE to hide.
int | m_nResizingWidth
The width of the column resizing marker area.
int | m_nMaxPreviewLines
Restrict maximum lines for preview text.
CSize | m_szGlyph
Glyph size.
CXTPBrush | m_xtpBrushTreeStructure
Brush to draw tree nodes.
CXTPBrush | m_xtpBrushGroupGridLineStyle
Brush to draw group row grid lines.
int | m_nFreezeColsDividerStyle
A set of flags from XTPGridFreezeColsDividerStyle.
BOOL | m_bFixedRowHeight
TRUE if fixed rows used.
BOOL | m_bColumnWidthWYSIWYG
TRUE if columns width WYSIWYG mode used.
BOOL | m_bShowWYSIWYGMarkers
TRUE if in non-print mode header show red page-end markers.
BOOL | m_bLastColumnWidthWYSIWYG
TRUE if last column width WYSIWYG mode used.
BOOL | m_bDrawGridForEmptySpace
TRUE if grid fills the empty space (if any) after the body rows.
BOOL | m_bPrintGroupRowIcon
TRUE if printout draw collapse-expand icon for group row.
BOOL | m_bColumnPlusMinusSign
TRUE if expand/collapse icons are used, FALSE if directional arrows are used.
BOOL | m_bFixedInplaceButtonHeight
TRUE if fixed in-place button height is used.
XTPGridGridStyle | m_nGroupGridLineStyle
Current style for group row grid lines.
XTPGridColumnStyle | m_columnStyle
Column drawing style.
CXTPWinThemeWrapper * | m_themeHeader
Header theme wrapper.
CXTPWinThemeWrapper * | m_themeButton
In-place button theme wrapper.
CXTPWinThemeWrapper * | m_themeCombo
Combo box in-place button theme wrapper.
CXTPWinThemeWrapper * | m_themeSpin
Spin in-place button theme wrapper.
CXTPGridControl * | m_pControl
Pointer to the Grid control object.
CXTPMarkupUIElement * | m_pMarkupUIElement_NoGroupBy
The no group by markup UI element.
CString | m_strMarkupUIElement_NoGroupBy
The no group by markup UI element string.
CXTPBrush | m_xtpBrushVeriticalGrid
Brush to draw vertical grid lines.
CXTPBrush | m_xtpBrushHorizontalGrid
Brush to draw horizontal grid lines.
XTPGridGridStyle m_nGridLineStylePreviousV
Previous style for vertical grid lines.
XTPGridGridStyle m_nGridLineStylePreviousH
Previous style for horizontal grid lines.

Detailed Description

CXTPGridThemeExplorer is a CXTPGridPaintManager derived class that represents an Explorer style theme.

Member Function Documentation

◆ DrawColumnBackground()

virtual void DrawColumnBackground | ( | CDC * | pDC,
 |  | CXTPGridColumn * | pColumn,
 |  | CRect | rcColumn,
 |  | BOOL & | bColumnPressed,
 |  | BOOL & | bDraggingFromHeader,
 |  | CXTPGridHeader * | pHeader = NULL )
 virtual

This method is called to draw the background of a column using the current column style.

Parameters
pDC | Pointer to the used device context.
pColumn | Pointer to the column whose background must be drawn.
rcColumn | Bounding rectangle of the column.
bColumnPressed | TRUE if the column is pressed by the user.
bDraggingFromHeader | TRUE if the column is being dragged from the header area.
pHeader | Pointer to the header that the column belongs to.

Reimplemented from CXTPGridPaintManager.

◆ DrawGlyph()

virtual CSize DrawGlyph | ( | CDC * | pDC,
 |  | CRect | rcColumn,
 |  | int | iImage )
 virtual

Draws the standard glyphs of the Grid control.

Parameters
pDC | Pointer to the used device context.
rcColumn | Bitmap area rectangle coordinates.
iImage | Image index.
Returns
The size of the drawn bitmap.

Reimplemented from CXTPGridPaintManager.

◆ DrawSectionDivider()

void DrawSectionDivider | ( | CDC * | pDC,
 |  | const CRect & | rc,
 |  | XTPGridSectionDividerPosition | dividerPosition,
 |  | XTPGridSectionDividerStyle | dividerStyle,
 |  | CXTPPaintManagerColor | dividerColor )

Draws the divider between grid sections (e.g.

dividing header record rows and body rows).

Parameters
pDC | Pointer to the used device context.
rc | Reference to rectangle coordinates.
dividerPosition | Position of the section divider; must be one of the values defined by the XTPGridSectionDividerPosition enumeration.
dividerStyle | Style of the section divider; must be one of the values defined by the XTPGridSectionDividerStyle enumeration.
dividerColor | Color of the section divider.

◆ DrawTriangle() [1/2]

virtual void DrawTriangle | ( | CDC * | pDC,
 |  | CRect | rcTriangle,
 |  | BOOL | bToDown,
 |  | BOOL | bDraggingFromHeader,
 |  | int | nShadowWidth,
 |  | BOOL | bColumnPressed )
 virtual

Draws a triangle that shows the sort order of the column.

Parameters
pDC | Pointer to the used device context.
rcTriangle | Triangle area rectangle coordinates.
bToDown | TRUE to turn the top of the triangle downward, FALSE to turn the top of the triangle upward.
bDraggingFromHeader | TRUE if the column is being dragged from the header area.
nShadowWidth | Size, in pixels, of the shadow to draw under the triangle image, or 0 to disable the shadow; the default value for this parameter is 0.
bColumnPressed | TRUE if the column is pressed by the user.

This function is used to draw a triangle image on the header of the column that is sorted. The triangle represents the direction of the sort: ascending or descending. The size of the triangle depends on the rectangle area provided.

Example:

// draw ascendant triangle
CRect rcTriangle;
rcTriangle.CopyRect(rcHeader);
rcTriangle.DeflateRect(40, 5, 5, 5);
DrawTriangle(pDC, rcTriangle, TRUE);

// draw descendant triangle
CRect rcTriangle;
rcTriangle.CopyRect(rcHeader);
rcTriangle.DeflateRect(40, 5, 5, 5);
DrawTriangle(pDC, rcTriangle, FALSE);

Reimplemented from CXTPGridPaintManager.

◆ DrawTriangle() [2/2]

virtual void DrawTriangle | ( | CDC * | pDC,
 |  | CRect | rcTriangle,
 |  | BOOL | bToDown,
 |  | int | nShadowWidth = 0 )
 virtual

Draws a triangle that shows the sort order of the column.

Parameters
pDC | Pointer to the used device context.
rcTriangle | Triangle area rectangle coordinates.
bToDown | TRUE to turn the top of the triangle downward, FALSE to turn the top of the triangle upward.
nShadowWidth | Size, in pixels, of the shadow to draw under the triangle image, or 0 to disable the shadow; the default value for this parameter is 0.

This function is used to draw a triangle image on the header of the column that is sorted. The triangle represents the direction of the sort: ascending or descending. The size of the triangle depends on the rectangle area provided.

Example:

// draw ascendant triangle
CRect rcTriangle;
rcTriangle.CopyRect(rcHeader);
rcTriangle.DeflateRect(40, 5, 5, 5);
DrawTriangle(pDC, rcTriangle, TRUE);

// draw descendant triangle
CRect rcTriangle;
rcTriangle.CopyRect(rcHeader);
rcTriangle.DeflateRect(40, 5, 5, 5);
DrawTriangle(pDC, rcTriangle, FALSE);

◆ IsColumHotTrackingEnabled()

virtual BOOL IsColumHotTrackingEnabled ( ) const
virtual

Determines if hot tracking is enabled for the current column style.

Returns
TRUE if hot tracking is enabled, otherwise FALSE.

Hot tracking can only be used for the xtpGridColumnOffice2003 and xtpGridColumnExplorer styles.

See also
m_columnStyle, m_bHotTracking

Reimplemented from CXTPGridPaintManager.

The documentation for this class was generated from the following file:
  • XTPGridThemeExplorer.h


Toolkit Pro: CXTPGridThemeNativeWindows10 Class Reference

Public Member Functions | List of all members
CXTPGridThemeNativeWindows10 Class Reference

CXTPGridThemeNativeWindows10 is a CXTPGridThemeOffice2013 derived class that represents a Native Windows 10 style theme. More...

Inheritance diagram for CXTPGridThemeNativeWindows10:
[legend]

Public Member Functions

CXTPGridThemeNativeWindows10 ()
Default paint manager constructor, handles properties initialization.
virtual void | RefreshMetrics ()
This method is called to refresh the visual metrics of the Grid control.
- Public Member Functions inherited from CXTPGridThemeOffice2013
CXTPGridThemeOffice2013 ()
Default paint manager constructor, handles properties initialization.
virtual void | LoadGlyphs ()
Loads the default images used by the Grid control.
virtual void | DrawColumnText (CDC *pDC, CRect rcText, CString strCaption, int nHeaderAlignment, BOOL bIsHeader, BOOL bColumnPressed)
Draws text for the column header.
virtual void | DrawColumnBackground (CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, BOOL &bColumnPressed, BOOL &bDraggingFromHeader, CXTPGridHeader *pHeader=NULL)
This method is called to draw the background of a column using the current column style.
virtual void | DrawTriangle (CDC *pDC, CRect rcTriangle, BOOL bToDown, BOOL bDraggingFromHeader, int nShadowWidth, BOOL bColumnPressed)
Draws a triangle that shows the sort order of the column.
virtual CSize | DrawCollapsedBitmap (CDC *pDC, const CXTPGridRow *pRow, CRect &rcBitmap)
Draws a collapsed bitmap.
virtual void | FillGroupRowMetrics (CXTPGridGroupRow *pRow, XTP_GRIDRECORDITEM_METRICS *pMetrics, BOOL bPrinting)
Fills the font and color members of the metrics structure for a specified group row.
virtual void | DrawGroupRow (CDC *pDC, CXTPGridGroupRow *pRow, CRect rcRow, XTP_GRIDRECORDITEM_METRICS *pMetrics)
Draws a group row.
virtual void | DrawFocusedRow (CDC *pDC, CRect rcRow)
Draws focused rows.
virtual int | GetRowHeight (CDC *pDC, CXTPGridRow *pRow)
Retrieves the default row height for print mode (i.e.
virtual int | GetRowHeight (CDC *pDC, CXTPGridRow *pRow, int nTotalWidth)
Retrieves the default row height for print mode (i.e.
- Public Member Functions inherited from CXTPGridPaintManager
CXTPGridPaintManager ()
Default CXTPGridPaintManager constructor, handles properties initialization.
virtual | ~CXTPGridPaintManager ()
Default CXTPGridPaintManager destructor, handles member items deallocation.
virtual void | SetGridControl (CXTPGridControl *pControl)
Sets the associated Grid control for the paint manager.
int | GetRowHeightEx (CDC *pDC, CXTPGridRow *pRow, int nTotalWidth, const BOOL firstLevel=TRUE)
Retrieves the default row height for print mode (i.e.
int | GetItemHeight (XTP_GRIDRECORDITEM_DRAWARGS &drawArgs, int nWidth)
Retrieves the height of a record item for a given width.
BOOL | FindRowAdjacentToMergedEx (const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, int &nAdjRowIndex, BOOL bUpward)
Searches the topmost or bottommost row depending on the height of the current row.
int | FindRowAdjacentToMerged (const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, BOOL bUpward)
Wrapper for the FindRowAdjacentToMergedEx method.
int | RecalcTotalHightOfMergedRows (CXTPGridColumns *pColumns, CDC *pDC, CXTPGridRow *pRow, int nRowHeight, int nTotalWidth)
Recalculates row height according to the height of merged items.
virtual int | GetPreviewItemHeight (CDC *pDC, CXTPGridRow *pRow, int nWidth, int nHeight)
Retrieves the height of a preview item for print mode.
virtual int | GetHeaderHeight ()
Gets the column header height.
virtual int | GetHeaderHeight (CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0)
Calculates the optimal header height.
virtual void | SetHeaderHeight (int nHeight)
Sets the column header height.
virtual int | GetFooterHeight (CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0)
Calculates the optimal footer height.
virtual COLORREF | GetControlBackColor (CXTPGridControl *pControl)
Retrieves the parent Grid control's background color.
virtual void | FillRow (CDC *pDC, CXTPGridRow *pRow, CRect rcRow)
Fills a specified row with its background color.
virtual void | DrawGrid (CDC *pDC, XTPGridOrientation orientation, CRect rcGrid)
Draws a grid for the control.
virtual void | DrawFreezeColsDivider (CDC *pDC, const CRect &rc, CXTPGridControl *pControl, CXTPGridRow *pRow=NULL)
Draws a freeze column divider.
virtual void | DrawVerticalTimeLineMarker (CDC *pDC, int xPos, CXTPGridControl *pControl, COLORREF color=RGB(0, 255, 0))
Draws a vertical timeline marker.
virtual void | FillIndent (CDC *pDC, CRect rcRow)
Fills an indent area by its background.
virtual void | FillItemShade (CDC *pDC, CRect rcItem)
Fills an item shade by its background if necessary.
virtual void | FillHeaderControl (CDC *pDC, CRect rcHeader)
Fills a column header control area by its background.
virtual void | FillFooter (CDC *pDC, CRect rcFooter)
Fills a column footer control area by its background.
virtual void | DrawColumn (CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn, BOOL bDrawExternal=FALSE, int nShadowWidth=0)
Draws a column header with all related attributes (sort order, icon, etc.).
virtual void | DrawColumnFooterDivider (CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn)
Draws the column footer divider.
virtual void | DrawColumnFooter (CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn)
Draws the column footer with all related attributes (e.g.
virtual BOOL | IsColumHotTrackingEnabled () const
Determines if hot tracking is enabled for the current column style.
virtual void | FillGroupByControl (CDC *pDC, CRect &rcGroupBy)
Draws the Group By box.
CXTPImageManager * | GetGlyphs () const
Gets a pointer to the additional image list with glyphs.
void | DrawHorizontalLine (CDC *pDC, int xPos, int yPos, int cx, COLORREF clr)
Draws a horizontal line.
void | DrawVerticalLine (CDC *pDC, int xPos, int yPos, int cy, COLORREF clr)
Draws a vertical line.
void | DrawConnector (CDC *pDC, CPoint ptFrom, CPoint ptTo)
Draws a column connector for the Group By box.
virtual int | DrawBitmap (CDC *pDC, CXTPGridControl *pControl, CRect rcColumn, int iImage)
Draws a bitmap.
virtual int | DrawColumnIcon (CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, CRect rcIcon, int iIcon)
Draws an icon for a column.
virtual CSize | DrawGlyph (CDC *pDC, CRect rcColumn, int iImage)
Draws the standard glyphs of the Grid control.
virtual CSize | DrawShellIcon (CDC *pDC, CRect rcColumn, int iImage)
Draws the shell icon.
void | EnablePreviewMode (BOOL bIsPreviewMode)
Enables/disables preview mode for the control.
BOOL | IsPreviewMode () const
Determines if preview mode is enabled/disabled for the control.
CFont * | GetTextFont ()
Gets the default text font used for control items.
int | SetMaxPreviewLines (int nMaxLines)
Sets the maximum number of lines of text for a preview item.
int | GetMaxPreviewLines ()
Gets the maximum number of lines of text for a preview item.
int | GetPreviewLinesCount (CDC *pDC, CRect &rcText, const CString &strText)
Calculates the number of lines required to draw a specified preview text string, taking into account the maximum number of lines of text for a preview item.
BOOL | IsGridVisible (BOOL bVertical) const
Determines the visibility of specified grid lines.
BOOL | IsGridVisible (XTPGridOrientation orientation) const
Determines the visibility of specified grid lines.
void | SetColumnStyle (XTPGridColumnStyle columnStyle)
Sets the header style.
XTPGridColumnStyle | GetColumnStyle () const
Gets the header style.
void | SetColumnOffice2007CustomThemeBaseColor (COLORREF clrBaseColor)
Sets the header's custom theme base color for Office2007 column style.
COLORREF | GetColumnOffice2007CustomThemeBaseColor () const
Gets the header's custom theme base color for Office2007 column style.
void | SetTextFont (LOGFONT &lf)
Creates and sets the default text font.
void | SetCaptionFont (LOGFONT &lf)
Creates and sets the default caption font.
void | SetPreviewIndent (int nLeft, int nTop, int nRight, int nBottom)
Sets the preview item indent.
virtual void | DrawInplaceButton (CDC *pDC, CXTPGridInplaceButton *pButton)
Draws the in-place button of the Grid control.
virtual BOOL | DrawInplaceComboButton (CDC *pDC, CRect *pRc)
Draws the combo button of the Grid control.
virtual BOOL | DrawInplaceExpandButton (CDC *pDC, CRect *pRc)
Draws the expand button of the Grid control.
virtual BOOL | DrawInplaceSpinButton (CDC *pDC, CRect *pRc)
Draws the spin button of the Grid control.
virtual void | DrawTreeStructure (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CRect rcItem, CSize sizeGlyph)
Draws tree elements of the Grid control.
virtual void | DrawItemBitmap (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CRect &rcItem, int nImage)
Draws an item bitmap.
virtual void | DrawItemCaption (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics)
Draws an item caption.
virtual void | DrawRowNumber (CDC *pDC, CRect rcNumber, CXTPGridRow *pRow)
Draws a row number.
virtual void | DrawItemControl (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CXTPGridRecordItemControl *pControl, CRect &rcItem)
Draws an item control.
BOOL | IsFixedRowHeight () const
Determines if the paint manager supports fixed or variable row height.
void | SetFixedRowHeight (BOOL bFixedRowHeight)
Sets if the paint manager supports fixed or variable row height.
BOOL | IsColumnWidthWYSIWYG () const
Determines if the paint manager supports column width WYSIWYG mode.
BOOL | IsLastColumnWidthWYSIWYG () const
Determines if the paint manager supports last column width WYSIWYG mode.
BOOL | IsShowWYSIWYGMarkers () const
Determines if the paint manager shows WYSIWYG page-end markers.
void | ShowWYSIWYGMarkers (BOOL bSet)
Sets if the paint manager shows WYSIWYG page-end markers.
void | SetColumnWidthWYSIWYG (BOOL bColumnWidthWYSIWYG)
Sets if the paint manager supports column width WYSIWYG mode.
void | SetLastColumnWidthWYSIWYG (BOOL bColumnWidthWYSIWYG)
Sets if the paint manager supports last column width WYSIWYG mode.
BOOL | IsFixedInplaceButtonHeight () const
Determines if the paint manager supports fixed or variable in-place button height.
void | SetInplaceButtonHeight (BOOL bFixedInplaceButtonHeight)
Sets if the paint manager supports fixed or variable in-place button height.
int | GetFreezeColsDividerStyle () const
Gets the style of the freeze columns divider line.
void | SetFreezeColsDividerStyle (int nStyle)
Sets the style for the freeze columns divider line.
virtual BOOL | OnDrawAction (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs)
Override this method to perform custom activities for the item before processing it.
virtual void | DrawNoGroupByText (CDC *pDC, CRect rcItem)
Draws the "No items" text message in the Group By area when there are no items inside it.
BOOL | IsDrawGridForEmptySpace () const
Determines if the grid fills empty space after body rows.
void | SetDrawGridForEmptySpace (BOOL bDrawGrid)
Sets if the grid fills empty space after body rows.
BOOL | IsPrintGroupRowIcon () const
Determines if the group row collapse-expand icon is drawn in print mode.
void | SetPrintGroupRowIcon (BOOL bDraw)
Sets if the group row collapse-expand icon is drawn in print mode.
BOOL | IsColumnPlusMinusSign () const
Determines if columns use expand/collapse icons (+/-) or directional arrows.
void | SetColumnPlusMinusSign (BOOL bDraw)
Specifies if columns use expand/collapse icons (+/-) or directional arrows.
virtual int | CalculateRowHeight (CDC *pDC, const CString &strText, int nMaxWidth, BOOL bWordBreak=TRUE)
Calculates the height required for a rectangle bounding multi-line text to draw the multi-line text when the width of the rectangle is fixed.
void | DrawSectionDivider (CDC *pDC, const CRect &rc, XTPGridSectionDividerPosition dividerPosition, XTPGridSectionDividerStyle dividerStyle, CXTPPaintManagerColor dividerColor)
Draws the divider between grid sections (e.g.
int | GetSectionDividerHeight (XTPGridFixedRowsDividerStyle dividerStyle)
Gets the height of the section divider.
BOOL | IsUseDropMarker () const
Determines if a drop marker will be used when dragging and dropping.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPGridThemeOffice2013
CXTPPaintManagerColor | m_clrGlyph
Header glyph color.
CXTPPaintManagerColor | m_clrGlyphHighlight
Header highlighted glyph color.
CXTPPaintManagerColor | m_clrGlyphExpand
Expand glyph color.
CXTPPaintManagerColor | m_clrGlyphBorder
Expand glyph border color.
CXTPPaintManagerColor | m_clrGlyphContract
Contract glyph color.
- Public Attributes inherited from CXTPGridPaintManager
CXTPFont | m_xtpFontText
Grid items default text.
CXTPFont | m_xtpFontBoldText
Grid items default bold text.
CXTPFont | m_xtpFontCaption
Column header caption font.
CXTPFont | m_xtpFontPreview
Column header caption font.
CXTPGridHyperlinkStyle * | m_pHyperlinkStyle
Style for links.
CXTPGridHyperlinkStyle * | m_pHyperlinkHoverStyle
Style for hovered links.
CXTPPaintManagerColor | m_clrHighlight
Background color of the highlighted row.
CXTPPaintManagerColor | m_clrBoldText
Grid items bold text color.
CXTPPaintManagerColor | m_clrBoldTextHighlight
Grid items bold text highlight color.
CXTPPaintManagerColor | m_clrWindowText
Grid items default text color.
CXTPPaintManagerColor | m_clrHighlightText
Text color of the highlighted text.
CXTPPaintManagerColor | m_clrHeaderControl
Background color of the grid header.
CXTPPaintManagerColor | m_clrCaptionText
Column header text color.
CXTPPaintManagerColor | m_clrCaptionTextPressed
Column header text color when pressed.
CXTPPaintManagerColor | m_clrControlBack
Background color of the control grid area.
CXTPPaintManagerColor | m_clrGroupRowText
Row text color.
CXTPPaintManagerColor | m_clrGroupShadeBack
Group row background color when indentation shade is enabled.
CXTPPaintManagerColor | m_clrGroupShadeText
Group row foreground color when indentation shade is enabled.
CXTPPaintManagerColor | m_clrGroupShadeBorder
Color for group border's shade.
CXTPPaintManagerColor | m_clrGroupBoxBack
Color of group box.
CXTPPaintManagerColor | m_clrControlDark
Dark background color of the Grid control (used on Group By area).
CXTPPaintManagerColor | m_clrControlLightLight
Light background color used for drawing shades (used on column header area).
CXTPPaintManagerColor | m_clrHotDivider
Color of the column hot divider window (two arrows).
CXTPPaintManagerColor | m_clrIndentControl
Color of the tree indentation area.
CXTPPaintManagerColor | m_clrItemShade
Color of the shade on sorted by column items.
CXTPPaintManagerColor | m_clrBtnFace
Standard button face color.
CXTPPaintManagerColor | m_clrBtnText
Standard button text color.
CXTPPaintManagerColor | m_clrPreviewText
Preview text color.
CXTPPaintManagerColor | m_clrSelectedRow
Selected row background color.
CXTPPaintManagerColor | m_clrSelectedRowText
Selected row text color.
CXTPPaintManagerColor | m_clrBtnFacePressed
Standard button face color when pressed.
CXTPPaintManagerColor | m_clrConnector
Header column connector line color.
CXTPPaintManagerColor | m_clrDisableBitmapLightest
The lightest color of bitmap which covers disabled grid.
CXTPPaintManagerColor | m_clrDisableBitmapDarkest
The darkest color of bitmap which covers disabled grid.
CXTPPaintManagerColorGradient | m_grcGradientColumn
Color of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColorGradient | m_grcGradientColumnHot
HotTracking Color of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColorGradient | m_grcGradientColumnPushed
Pushed Color of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColor | m_clrGradientColumnShadow
Bottom shadow of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColor | m_clrGradientColumnSeparator
Separator of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColor | m_crlNoGroupByText
A color for "No items" text in GroupBy area (see m_strNoGroupBy member).
CXTPPaintManagerColor | m_clrFreezeColsDivider
Freeze Columns Divider color.
COLORREF | m_clrColumnOffice2007CustomTheme
Base color for Office2007 custom theme.
COLORREF | m_clrFormulaSum
Color for Formula Sum fields.
COLORREF | m_clrFormulaSubSum
Color for Formula SubSum fields.
COLORREF | m_clrAlternativeBackground
Color for Alternative Row Background.
BOOL | m_bUseAlternativeBackground
TRUE to use Alternative Row Background, FALSE otherwise.
BOOL | m_bAllowMergeCells
TRUE to Allow Merge Cells, FALSE otherwise.
int | m_nTextIndentForGroupRowsWithNoIcon
Specifies Text indent if a group row icon is not used.
int | m_nTreeIndent
Tree indentation.
int | m_nTreeStructureStyle
Tree structure style.
int | m_nTreeTextIndentRowParent
Text indent, in pixels, for rows with children.
int | m_nTreeTextIndentRowChildren
Text indent, in pixels, for rows without children.
int | m_nTreeTextIndent
Text indent, in pixels, for rows that are neither parent nor children.
int | m_nTreeTextIndentGroupRow
Text indent, in pixels, for group rows.
BOOL | m_bGroupRowTextBold
TRUE to draw group rows with bold text.
BOOL | m_bShadeGroupHeadings
TRUE to show the indentation shade, FALSE otherwise.
BOOL | m_bShadeSortColumn
TRUE to show the items shade in the sorted by column, FALSE otherwise.
BOOL | m_bHotTracking
TRUE to allow column hot tracking.
BOOL | m_bInvertColumnOnClick
TRUE to invert column on click.
CString | m_strNoItems
A string which contains customized "No Items" text for displaying in view when there are no visible rows.
CString | m_strSortBy
A string which contains customized "Sort By" text for displaying in tooltip.
CString | m_strIncreasing
A string which contains customized "Increasing" text for displaying in tooltip.
CString | m_strDecreasing
A string which contains customized "Decreasing" text for displaying in tooltip.
CString | m_strNoGroupBy
A string which contains customized "No items" text message for displaying in Group By area when there are no items inside it.
CString | m_strNoFieldsAvailable
A string which contains customized "No Fields Available" text message for displaying in Field Chooser.
CString | m_strExpand
A string which contains customized "Expand" text for displaying in tooltip.
CString | m_strCollapse
A string which contains customized "Collapse" text for displaying in tooltip.
BOOL | m_bHideSelection
TRUE when hiding Grid control's selection by drawing selected items as others, FALSE otherwise.
BOOL | m_bPrintSortTriangle
TRUE to show the sort triangle in printout.
BOOL | m_bRevertAlignment
TRUE to revert column alignments.
BOOL | m_bUseEditTextAlignment
TRUE to automatically apply edit alignment using column alignment.
BOOL | m_bShowLockIcon
TRUE to show the lock icon, FALSE to hide.
BOOL | m_bUseShellIcon
TRUE to use the shell icon, FALSE otherwise.
int | m_iRecOrRowStart
Start position in numbering (0 or 1 or something user want).
BOOL | m_bRecOrRowNum
TRUE to display record number if support mode is used, FALSE to display row number.
BOOL | m_bMakeUpper
TRUE to display column header and group row text in all caps.
XTPGridTreeStructureStyle | m_treeStructureStyle
Tree structure style.
CRect | m_rcPreviewIndent
Preview indentation.
int | m_nFixedColumnsIndent
Fixed Column total width.
BOOL | m_bMoveScrollbarOnFixedColumnsIndent
Move Scrollbar right follow FixedColumnsIndent.
BOOL | m_bThemedInplaceButtons
Draw in-place buttons using current theme settings.
BOOL | m_bBaseTreeIndent
TRUE to add Extra Tree indentation to cover initial TreeColumn.
CUIntArray | m_arStartCol
Start column in each virtual page.
int | m_PrintPageWidth
Width of print page (run-time)
BOOL | m_bPrintVirtualPageNumber
TRUE to print horizontal page number.
BOOL | m_bPrintPageRectangle
TRUE to draw rectangle around page.
int | m_RecordNumberWidth
Column width for row/record numbers.
BOOL | m_bForceDynamicMarkupForCell
TRUE if use Markup for Grid Record Item.
BOOL | m_bForceShowDropMarker
TRUE if Force Show Drop Marker.
BOOL | m_bShowNonActiveInPlaceButton
TRUE if use Show Non-Active In-Place Button (Combo, Expand, Spin).
BOOL | m_bPrintWatermark
TRUE to print watermark.
BOOL | m_bUseGroupRowSelectionState
TRUE if use GroupSelectionState Glyph.
BOOL | m_bForceShowTooltip
TRUE if use show tooltip for any cell width case.
BOOL | m_bCleanTooltip
TRUE if use show tooltip without markup.
BOOL | m_bGrayIfDisable
TRUE is disable draw in gray (standard behavior).
int | m_nRowHeightDefault
The default row height.
BOOL | m_bCompactText
TRUE to ignore Icon for Narrow column to show more text.
BOOL | m_bUseDropMarker
FALSE to not draw drop marked when dragging/dropping, TRUE by default.
BOOL | m_bSortTriangleOffsetFromRight
Offset of sort triangle.
int | m_nTreeColumnLineLength
This is the extra line length to apply to tree column lines if there is no expand button.
int | m_nBaseParentRecordIndent
This is initial number of pixels a parent node will be indented when in a group.
- Protected Member Functions inherited from CXTPGridPaintManager
virtual void | DrawTextLine (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nFlag, int &nCharCounter, int &nHyperlinkCounter)
Draws a line of text with respect to the drawing rectangle.
virtual int | DrawString (int *pnCurrDrawPos, CDC *pDC, const CString &strDraw, CRect rcDraw, UINT nFormat)
Draw a simple string into rectangle.
virtual void | DrawGridPattern (CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush)
Generates a custom grid pattern if necessary.
virtual void | DrawGridPattern (CDC *pDC, CXTPBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush)
Generates a custom grid pattern if necessary.
virtual void | DrawGridPattern (CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr)
Generates a custom grid pattern.
virtual void | DrawInplaceButtonFrame (CDC *pDC, CXTPGridInplaceButton *pButton)
Draws the in-place button frame.
virtual BOOL | DrawInplaceButtonIcon (CDC *pDC, CXTPGridInplaceButton *pButton)
Draws the in-place button icon.
virtual int | CalcColumnHeight (CDC *pDC, CXTPGridColumn *pColumn, int nTotalWidth=0)
Calculates the optimal height for a specified column.
virtual void | DrawMultiLineText (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, BOOL bWordBreak=TRUE)
Draws multi-line text.
virtual void | DrawSingleLineText (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nStartPos, int nEndPos, int nActualWidth)
Draws single-line text.
virtual int | DrawLink (int *pnCurrDrawPos, XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CXTPGridHyperlink *pHyperlink, CString strText, CRect rcLink, int nFlag, BOOL bTrim=FALSE)
Draws a hyperlink string using hyperlink text settings (i.e.
- Protected Attributes inherited from CXTPGridPaintManager
int | m_nRowHeight
Grid row default height.
int | m_nHeaderHeight
Column header height.
int | m_nFooterHeight
Column footer height.
int | m_nGroupGridLineHeight
The height of the group grid line.
CXTPImageManager * | m_pGlyphs
An additional image list for the Grid control.
BOOL | m_bIsPreviewMode
TRUE to show the item preview, FALSE to hide.
int | m_nResizingWidth
The width of the column resizing marker area.
int | m_nMaxPreviewLines
Restrict maximum lines for preview text.
CSize | m_szGlyph
Glyph size.
CXTPBrush | m_xtpBrushTreeStructure
Brush to draw tree nodes.
CXTPBrush | m_xtpBrushGroupGridLineStyle
Brush to draw group row grid lines.
int | m_nFreezeColsDividerStyle
A set of flags from XTPGridFreezeColsDividerStyle.
BOOL | m_bFixedRowHeight
TRUE if fixed rows used.
BOOL | m_bColumnWidthWYSIWYG
TRUE if columns width WYSIWYG mode used.
BOOL | m_bShowWYSIWYGMarkers
TRUE if in non-print mode header show red page-end markers.
BOOL | m_bLastColumnWidthWYSIWYG
TRUE if last column width WYSIWYG mode used.
BOOL | m_bDrawGridForEmptySpace
TRUE if grid fills the empty space (if any) after the body rows.
BOOL | m_bPrintGroupRowIcon
TRUE if printout draw collapse-expand icon for group row.
BOOL | m_bColumnPlusMinusSign
TRUE if expand/collapse icons are used, FALSE if directional arrows are used.
BOOL | m_bFixedInplaceButtonHeight
TRUE if fixed in-place button height is used.
XTPGridGridStyle | m_nGroupGridLineStyle
Current style for group row grid lines.
XTPGridColumnStyle | m_columnStyle
Column drawing style.
CXTPWinThemeWrapper * | m_themeHeader
Header theme wrapper.
CXTPWinThemeWrapper * | m_themeButton
In-place button theme wrapper.
CXTPWinThemeWrapper * | m_themeCombo
Combo box in-place button theme wrapper.
CXTPWinThemeWrapper * | m_themeSpin
Spin in-place button theme wrapper.
CXTPGridControl * | m_pControl
Pointer to the Grid control object.
CXTPMarkupUIElement * | m_pMarkupUIElement_NoGroupBy
The no group by markup UI element.
CString | m_strMarkupUIElement_NoGroupBy
The no group by markup UI element string.
CXTPBrush | m_xtpBrushVeriticalGrid
Brush to draw vertical grid lines.
CXTPBrush | m_xtpBrushHorizontalGrid
Brush to draw horizontal grid lines.
XTPGridGridStyle m_nGridLineStylePreviousV
Previous style for vertical grid lines.
XTPGridGridStyle m_nGridLineStylePreviousH
Previous style for horizontal grid lines.

Detailed Description

CXTPGridThemeNativeWindows10 is a CXTPGridThemeOffice2013 derived class that represents a Native Windows 10 style theme.

The documentation for this class was generated from the following file:
  • XTPGridThemeNativeWindows10.h


Toolkit Pro: CXTPGridThemeNativeWindows11 Class Reference

Public Member Functions | List of all members
CXTPGridThemeNativeWindows11 Class Reference

CXTPGridThemeNativeWindows11 is a CXTPGridThemeOffice2013 derived class that represents a Native Windows 10 style theme. More...

Inheritance diagram for CXTPGridThemeNativeWindows11:
[legend]

Public Member Functions

CXTPGridThemeNativeWindows11 ()
Default paint manager constructor, handles properties initialization.
virtual void | RefreshMetrics ()
This method is called to refresh the visual metrics of the Grid control.
- Public Member Functions inherited from CXTPGridThemeOffice2013
CXTPGridThemeOffice2013 ()
Default paint manager constructor, handles properties initialization.
virtual void | LoadGlyphs ()
Loads the default images used by the Grid control.
virtual void | DrawColumnText (CDC *pDC, CRect rcText, CString strCaption, int nHeaderAlignment, BOOL bIsHeader, BOOL bColumnPressed)
Draws text for the column header.
virtual void | DrawColumnBackground (CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, BOOL &bColumnPressed, BOOL &bDraggingFromHeader, CXTPGridHeader *pHeader=NULL)
This method is called to draw the background of a column using the current column style.
virtual void | DrawTriangle (CDC *pDC, CRect rcTriangle, BOOL bToDown, BOOL bDraggingFromHeader, int nShadowWidth, BOOL bColumnPressed)
Draws a triangle that shows the sort order of the column.
virtual CSize | DrawCollapsedBitmap (CDC *pDC, const CXTPGridRow *pRow, CRect &rcBitmap)
Draws a collapsed bitmap.
virtual void | FillGroupRowMetrics (CXTPGridGroupRow *pRow, XTP_GRIDRECORDITEM_METRICS *pMetrics, BOOL bPrinting)
Fills the font and color members of the metrics structure for a specified group row.
virtual void | DrawGroupRow (CDC *pDC, CXTPGridGroupRow *pRow, CRect rcRow, XTP_GRIDRECORDITEM_METRICS *pMetrics)
Draws a group row.
virtual void | DrawFocusedRow (CDC *pDC, CRect rcRow)
Draws focused rows.
virtual int | GetRowHeight (CDC *pDC, CXTPGridRow *pRow)
Retrieves the default row height for print mode (i.e.
virtual int | GetRowHeight (CDC *pDC, CXTPGridRow *pRow, int nTotalWidth)
Retrieves the default row height for print mode (i.e.
- Public Member Functions inherited from CXTPGridPaintManager
CXTPGridPaintManager ()
Default CXTPGridPaintManager constructor, handles properties initialization.
virtual | ~CXTPGridPaintManager ()
Default CXTPGridPaintManager destructor, handles member items deallocation.
virtual void | SetGridControl (CXTPGridControl *pControl)
Sets the associated Grid control for the paint manager.
int | GetRowHeightEx (CDC *pDC, CXTPGridRow *pRow, int nTotalWidth, const BOOL firstLevel=TRUE)
Retrieves the default row height for print mode (i.e.
int | GetItemHeight (XTP_GRIDRECORDITEM_DRAWARGS &drawArgs, int nWidth)
Retrieves the height of a record item for a given width.
BOOL | FindRowAdjacentToMergedEx (const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, int &nAdjRowIndex, BOOL bUpward)
Searches the topmost or bottommost row depending on the height of the current row.
int | FindRowAdjacentToMerged (const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, BOOL bUpward)
Wrapper for the FindRowAdjacentToMergedEx method.
int | RecalcTotalHightOfMergedRows (CXTPGridColumns *pColumns, CDC *pDC, CXTPGridRow *pRow, int nRowHeight, int nTotalWidth)
Recalculates row height according to the height of merged items.
virtual int | GetPreviewItemHeight (CDC *pDC, CXTPGridRow *pRow, int nWidth, int nHeight)
Retrieves the height of a preview item for print mode.
virtual int | GetHeaderHeight ()
Gets the column header height.
virtual int | GetHeaderHeight (CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0)
Calculates the optimal header height.
virtual void | SetHeaderHeight (int nHeight)
Sets the column header height.
virtual int | GetFooterHeight (CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0)
Calculates the optimal footer height.
virtual COLORREF | GetControlBackColor (CXTPGridControl *pControl)
Retrieves the parent Grid control's background color.
virtual void | FillRow (CDC *pDC, CXTPGridRow *pRow, CRect rcRow)
Fills a specified row with its background color.
virtual void | DrawGrid (CDC *pDC, XTPGridOrientation orientation, CRect rcGrid)
Draws a grid for the control.
virtual void | DrawFreezeColsDivider (CDC *pDC, const CRect &rc, CXTPGridControl *pControl, CXTPGridRow *pRow=NULL)
Draws a freeze column divider.
virtual void | DrawVerticalTimeLineMarker (CDC *pDC, int xPos, CXTPGridControl *pControl, COLORREF color=RGB(0, 255, 0))
Draws a vertical timeline marker.
virtual void | FillIndent (CDC *pDC, CRect rcRow)
Fills an indent area by its background.
virtual void | FillItemShade (CDC *pDC, CRect rcItem)
Fills an item shade by its background if necessary.
virtual void | FillHeaderControl (CDC *pDC, CRect rcHeader)
Fills a column header control area by its background.
virtual void | FillFooter (CDC *pDC, CRect rcFooter)
Fills a column footer control area by its background.
virtual void | DrawColumn (CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn, BOOL bDrawExternal=FALSE, int nShadowWidth=0)
Draws a column header with all related attributes (sort order, icon, etc.).
virtual void | DrawColumnFooterDivider (CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn)
Draws the column footer divider.
virtual void | DrawColumnFooter (CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn)
Draws the column footer with all related attributes (e.g.
virtual BOOL | IsColumHotTrackingEnabled () const
Determines if hot tracking is enabled for the current column style.
virtual void | FillGroupByControl (CDC *pDC, CRect &rcGroupBy)
Draws the Group By box.
CXTPImageManager * | GetGlyphs () const
Gets a pointer to the additional image list with glyphs.
void | DrawHorizontalLine (CDC *pDC, int xPos, int yPos, int cx, COLORREF clr)
Draws a horizontal line.
void | DrawVerticalLine (CDC *pDC, int xPos, int yPos, int cy, COLORREF clr)
Draws a vertical line.
void | DrawConnector (CDC *pDC, CPoint ptFrom, CPoint ptTo)
Draws a column connector for the Group By box.
virtual int | DrawBitmap (CDC *pDC, CXTPGridControl *pControl, CRect rcColumn, int iImage)
Draws a bitmap.
virtual int | DrawColumnIcon (CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, CRect rcIcon, int iIcon)
Draws an icon for a column.
virtual CSize | DrawGlyph (CDC *pDC, CRect rcColumn, int iImage)
Draws the standard glyphs of the Grid control.
virtual CSize | DrawShellIcon (CDC *pDC, CRect rcColumn, int iImage)
Draws the shell icon.
void | EnablePreviewMode (BOOL bIsPreviewMode)
Enables/disables preview mode for the control.
BOOL | IsPreviewMode () const
Determines if preview mode is enabled/disabled for the control.
CFont * | GetTextFont ()
Gets the default text font used for control items.
int | SetMaxPreviewLines (int nMaxLines)
Sets the maximum number of lines of text for a preview item.
int | GetMaxPreviewLines ()
Gets the maximum number of lines of text for a preview item.
int | GetPreviewLinesCount (CDC *pDC, CRect &rcText, const CString &strText)
Calculates the number of lines required to draw a specified preview text string, taking into account the maximum number of lines of text for a preview item.
BOOL | IsGridVisible (BOOL bVertical) const
Determines the visibility of specified grid lines.
BOOL | IsGridVisible (XTPGridOrientation orientation) const
Determines the visibility of specified grid lines.
void | SetColumnStyle (XTPGridColumnStyle columnStyle)
Sets the header style.
XTPGridColumnStyle | GetColumnStyle () const
Gets the header style.
void | SetColumnOffice2007CustomThemeBaseColor (COLORREF clrBaseColor)
Sets the header's custom theme base color for Office2007 column style.
COLORREF | GetColumnOffice2007CustomThemeBaseColor () const
Gets the header's custom theme base color for Office2007 column style.
void | SetTextFont (LOGFONT &lf)
Creates and sets the default text font.
void | SetCaptionFont (LOGFONT &lf)
Creates and sets the default caption font.
void | SetPreviewIndent (int nLeft, int nTop, int nRight, int nBottom)
Sets the preview item indent.
virtual void | DrawInplaceButton (CDC *pDC, CXTPGridInplaceButton *pButton)
Draws the in-place button of the Grid control.
virtual BOOL | DrawInplaceComboButton (CDC *pDC, CRect *pRc)
Draws the combo button of the Grid control.
virtual BOOL | DrawInplaceExpandButton (CDC *pDC, CRect *pRc)
Draws the expand button of the Grid control.
virtual BOOL | DrawInplaceSpinButton (CDC *pDC, CRect *pRc)
Draws the spin button of the Grid control.
virtual void | DrawTreeStructure (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CRect rcItem, CSize sizeGlyph)
Draws tree elements of the Grid control.
virtual void | DrawItemBitmap (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CRect &rcItem, int nImage)
Draws an item bitmap.
virtual void | DrawItemCaption (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics)
Draws an item caption.
virtual void | DrawRowNumber (CDC *pDC, CRect rcNumber, CXTPGridRow *pRow)
Draws a row number.
virtual void | DrawItemControl (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CXTPGridRecordItemControl *pControl, CRect &rcItem)
Draws an item control.
BOOL | IsFixedRowHeight () const
Determines if the paint manager supports fixed or variable row height.
void | SetFixedRowHeight (BOOL bFixedRowHeight)
Sets if the paint manager supports fixed or variable row height.
BOOL | IsColumnWidthWYSIWYG () const
Determines if the paint manager supports column width WYSIWYG mode.
BOOL | IsLastColumnWidthWYSIWYG () const
Determines if the paint manager supports last column width WYSIWYG mode.
BOOL | IsShowWYSIWYGMarkers () const
Determines if the paint manager shows WYSIWYG page-end markers.
void | ShowWYSIWYGMarkers (BOOL bSet)
Sets if the paint manager shows WYSIWYG page-end markers.
void | SetColumnWidthWYSIWYG (BOOL bColumnWidthWYSIWYG)
Sets if the paint manager supports column width WYSIWYG mode.
void | SetLastColumnWidthWYSIWYG (BOOL bColumnWidthWYSIWYG)
Sets if the paint manager supports last column width WYSIWYG mode.
BOOL | IsFixedInplaceButtonHeight () const
Determines if the paint manager supports fixed or variable in-place button height.
void | SetInplaceButtonHeight (BOOL bFixedInplaceButtonHeight)
Sets if the paint manager supports fixed or variable in-place button height.
int | GetFreezeColsDividerStyle () const
Gets the style of the freeze columns divider line.
void | SetFreezeColsDividerStyle (int nStyle)
Sets the style for the freeze columns divider line.
virtual BOOL | OnDrawAction (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs)
Override this method to perform custom activities for the item before processing it.
virtual void | DrawNoGroupByText (CDC *pDC, CRect rcItem)
Draws the "No items" text message in the Group By area when there are no items inside it.
BOOL | IsDrawGridForEmptySpace () const
Determines if the grid fills empty space after body rows.
void | SetDrawGridForEmptySpace (BOOL bDrawGrid)
Sets if the grid fills empty space after body rows.
BOOL | IsPrintGroupRowIcon () const
Determines if the group row collapse-expand icon is drawn in print mode.
void | SetPrintGroupRowIcon (BOOL bDraw)
Sets if the group row collapse-expand icon is drawn in print mode.
BOOL | IsColumnPlusMinusSign () const
Determines if columns use expand/collapse icons (+/-) or directional arrows.
void | SetColumnPlusMinusSign (BOOL bDraw)
Specifies if columns use expand/collapse icons (+/-) or directional arrows.
virtual int | CalculateRowHeight (CDC *pDC, const CString &strText, int nMaxWidth, BOOL bWordBreak=TRUE)
Calculates the height required for a rectangle bounding multi-line text to draw the multi-line text when the width of the rectangle is fixed.
void | DrawSectionDivider (CDC *pDC, const CRect &rc, XTPGridSectionDividerPosition dividerPosition, XTPGridSectionDividerStyle dividerStyle, CXTPPaintManagerColor dividerColor)
Draws the divider between grid sections (e.g.
int | GetSectionDividerHeight (XTPGridFixedRowsDividerStyle dividerStyle)
Gets the height of the section divider.
BOOL | IsUseDropMarker () const
Determines if a drop marker will be used when dragging and dropping.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPGridThemeOffice2013
CXTPPaintManagerColor | m_clrGlyph
Header glyph color.
CXTPPaintManagerColor | m_clrGlyphHighlight
Header highlighted glyph color.
CXTPPaintManagerColor | m_clrGlyphExpand
Expand glyph color.
CXTPPaintManagerColor | m_clrGlyphBorder
Expand glyph border color.
CXTPPaintManagerColor | m_clrGlyphContract
Contract glyph color.
- Public Attributes inherited from CXTPGridPaintManager
CXTPFont | m_xtpFontText
Grid items default text.
CXTPFont | m_xtpFontBoldText
Grid items default bold text.
CXTPFont | m_xtpFontCaption
Column header caption font.
CXTPFont | m_xtpFontPreview
Column header caption font.
CXTPGridHyperlinkStyle * | m_pHyperlinkStyle
Style for links.
CXTPGridHyperlinkStyle * | m_pHyperlinkHoverStyle
Style for hovered links.
CXTPPaintManagerColor | m_clrHighlight
Background color of the highlighted row.
CXTPPaintManagerColor | m_clrBoldText
Grid items bold text color.
CXTPPaintManagerColor | m_clrBoldTextHighlight
Grid items bold text highlight color.
CXTPPaintManagerColor | m_clrWindowText
Grid items default text color.
CXTPPaintManagerColor | m_clrHighlightText
Text color of the highlighted text.
CXTPPaintManagerColor | m_clrHeaderControl
Background color of the grid header.
CXTPPaintManagerColor | m_clrCaptionText
Column header text color.
CXTPPaintManagerColor | m_clrCaptionTextPressed
Column header text color when pressed.
CXTPPaintManagerColor | m_clrControlBack
Background color of the control grid area.
CXTPPaintManagerColor | m_clrGroupRowText
Row text color.
CXTPPaintManagerColor | m_clrGroupShadeBack
Group row background color when indentation shade is enabled.
CXTPPaintManagerColor | m_clrGroupShadeText
Group row foreground color when indentation shade is enabled.
CXTPPaintManagerColor | m_clrGroupShadeBorder
Color for group border's shade.
CXTPPaintManagerColor | m_clrGroupBoxBack
Color of group box.
CXTPPaintManagerColor | m_clrControlDark
Dark background color of the Grid control (used on Group By area).
CXTPPaintManagerColor | m_clrControlLightLight
Light background color used for drawing shades (used on column header area).
CXTPPaintManagerColor | m_clrHotDivider
Color of the column hot divider window (two arrows).
CXTPPaintManagerColor | m_clrIndentControl
Color of the tree indentation area.
CXTPPaintManagerColor | m_clrItemShade
Color of the shade on sorted by column items.
CXTPPaintManagerColor | m_clrBtnFace
Standard button face color.
CXTPPaintManagerColor | m_clrBtnText
Standard button text color.
CXTPPaintManagerColor | m_clrPreviewText
Preview text color.
CXTPPaintManagerColor | m_clrSelectedRow
Selected row background color.
CXTPPaintManagerColor | m_clrSelectedRowText
Selected row text color.
CXTPPaintManagerColor | m_clrBtnFacePressed
Standard button face color when pressed.
CXTPPaintManagerColor | m_clrConnector
Header column connector line color.
CXTPPaintManagerColor | m_clrDisableBitmapLightest
The lightest color of bitmap which covers disabled grid.
CXTPPaintManagerColor | m_clrDisableBitmapDarkest
The darkest color of bitmap which covers disabled grid.
CXTPPaintManagerColorGradient | m_grcGradientColumn
Color of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColorGradient | m_grcGradientColumnHot
HotTracking Color of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColorGradient | m_grcGradientColumnPushed
Pushed Color of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColor | m_clrGradientColumnShadow
Bottom shadow of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColor | m_clrGradientColumnSeparator
Separator of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColor | m_crlNoGroupByText
A color for "No items" text in GroupBy area (see m_strNoGroupBy member).
CXTPPaintManagerColor | m_clrFreezeColsDivider
Freeze Columns Divider color.
COLORREF | m_clrColumnOffice2007CustomTheme
Base color for Office2007 custom theme.
COLORREF | m_clrFormulaSum
Color for Formula Sum fields.
COLORREF | m_clrFormulaSubSum
Color for Formula SubSum fields.
COLORREF | m_clrAlternativeBackground
Color for Alternative Row Background.
BOOL | m_bUseAlternativeBackground
TRUE to use Alternative Row Background, FALSE otherwise.
BOOL | m_bAllowMergeCells
TRUE to Allow Merge Cells, FALSE otherwise.
int | m_nTextIndentForGroupRowsWithNoIcon
Specifies Text indent if a group row icon is not used.
int | m_nTreeIndent
Tree indentation.
int | m_nTreeStructureStyle
Tree structure style.
int | m_nTreeTextIndentRowParent
Text indent, in pixels, for rows with children.
int | m_nTreeTextIndentRowChildren
Text indent, in pixels, for rows without children.
int | m_nTreeTextIndent
Text indent, in pixels, for rows that are neither parent nor children.
int | m_nTreeTextIndentGroupRow
Text indent, in pixels, for group rows.
BOOL | m_bGroupRowTextBold
TRUE to draw group rows with bold text.
BOOL | m_bShadeGroupHeadings
TRUE to show the indentation shade, FALSE otherwise.
BOOL | m_bShadeSortColumn
TRUE to show the items shade in the sorted by column, FALSE otherwise.
BOOL | m_bHotTracking
TRUE to allow column hot tracking.
BOOL | m_bInvertColumnOnClick
TRUE to invert column on click.
CString | m_strNoItems
A string which contains customized "No Items" text for displaying in view when there are no visible rows.
CString | m_strSortBy
A string which contains customized "Sort By" text for displaying in tooltip.
CString | m_strIncreasing
A string which contains customized "Increasing" text for displaying in tooltip.
CString | m_strDecreasing
A string which contains customized "Decreasing" text for displaying in tooltip.
CString | m_strNoGroupBy
A string which contains customized "No items" text message for displaying in Group By area when there are no items inside it.
CString | m_strNoFieldsAvailable
A string which contains customized "No Fields Available" text message for displaying in Field Chooser.
CString | m_strExpand
A string which contains customized "Expand" text for displaying in tooltip.
CString | m_strCollapse
A string which contains customized "Collapse" text for displaying in tooltip.
BOOL | m_bHideSelection
TRUE when hiding Grid control's selection by drawing selected items as others, FALSE otherwise.
BOOL | m_bPrintSortTriangle
TRUE to show the sort triangle in printout.
BOOL | m_bRevertAlignment
TRUE to revert column alignments.
BOOL | m_bUseEditTextAlignment
TRUE to automatically apply edit alignment using column alignment.
BOOL | m_bShowLockIcon
TRUE to show the lock icon, FALSE to hide.
BOOL | m_bUseShellIcon
TRUE to use the shell icon, FALSE otherwise.
int | m_iRecOrRowStart
Start position in numbering (0 or 1 or something user want).
BOOL | m_bRecOrRowNum
TRUE to display record number if support mode is used, FALSE to display row number.
BOOL | m_bMakeUpper
TRUE to display column header and group row text in all caps.
XTPGridTreeStructureStyle | m_treeStructureStyle
Tree structure style.
CRect | m_rcPreviewIndent
Preview indentation.
int | m_nFixedColumnsIndent
Fixed Column total width.
BOOL | m_bMoveScrollbarOnFixedColumnsIndent
Move Scrollbar right follow FixedColumnsIndent.
BOOL | m_bThemedInplaceButtons
Draw in-place buttons using current theme settings.
BOOL | m_bBaseTreeIndent
TRUE to add Extra Tree indentation to cover initial TreeColumn.
CUIntArray | m_arStartCol
Start column in each virtual page.
int | m_PrintPageWidth
Width of print page (run-time)
BOOL | m_bPrintVirtualPageNumber
TRUE to print horizontal page number.
BOOL | m_bPrintPageRectangle
TRUE to draw rectangle around page.
int | m_RecordNumberWidth
Column width for row/record numbers.
BOOL | m_bForceDynamicMarkupForCell
TRUE if use Markup for Grid Record Item.
BOOL | m_bForceShowDropMarker
TRUE if Force Show Drop Marker.
BOOL | m_bShowNonActiveInPlaceButton
TRUE if use Show Non-Active In-Place Button (Combo, Expand, Spin).
BOOL | m_bPrintWatermark
TRUE to print watermark.
BOOL | m_bUseGroupRowSelectionState
TRUE if use GroupSelectionState Glyph.
BOOL | m_bForceShowTooltip
TRUE if use show tooltip for any cell width case.
BOOL | m_bCleanTooltip
TRUE if use show tooltip without markup.
BOOL | m_bGrayIfDisable
TRUE is disable draw in gray (standard behavior).
int | m_nRowHeightDefault
The default row height.
BOOL | m_bCompactText
TRUE to ignore Icon for Narrow column to show more text.
BOOL | m_bUseDropMarker
FALSE to not draw drop marked when dragging/dropping, TRUE by default.
BOOL | m_bSortTriangleOffsetFromRight
Offset of sort triangle.
int | m_nTreeColumnLineLength
This is the extra line length to apply to tree column lines if there is no expand button.
int | m_nBaseParentRecordIndent
This is initial number of pixels a parent node will be indented when in a group.
- Protected Member Functions inherited from CXTPGridPaintManager
virtual void | DrawTextLine (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nFlag, int &nCharCounter, int &nHyperlinkCounter)
Draws a line of text with respect to the drawing rectangle.
virtual int | DrawString (int *pnCurrDrawPos, CDC *pDC, const CString &strDraw, CRect rcDraw, UINT nFormat)
Draw a simple string into rectangle.
virtual void | DrawGridPattern (CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush)
Generates a custom grid pattern if necessary.
virtual void | DrawGridPattern (CDC *pDC, CXTPBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush)
Generates a custom grid pattern if necessary.
virtual void | DrawGridPattern (CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr)
Generates a custom grid pattern.
virtual void | DrawInplaceButtonFrame (CDC *pDC, CXTPGridInplaceButton *pButton)
Draws the in-place button frame.
virtual BOOL | DrawInplaceButtonIcon (CDC *pDC, CXTPGridInplaceButton *pButton)
Draws the in-place button icon.
virtual int | CalcColumnHeight (CDC *pDC, CXTPGridColumn *pColumn, int nTotalWidth=0)
Calculates the optimal height for a specified column.
virtual void | DrawMultiLineText (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, BOOL bWordBreak=TRUE)
Draws multi-line text.
virtual void | DrawSingleLineText (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nStartPos, int nEndPos, int nActualWidth)
Draws single-line text.
virtual int | DrawLink (int *pnCurrDrawPos, XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CXTPGridHyperlink *pHyperlink, CString strText, CRect rcLink, int nFlag, BOOL bTrim=FALSE)
Draws a hyperlink string using hyperlink text settings (i.e.
- Protected Attributes inherited from CXTPGridPaintManager
int | m_nRowHeight
Grid row default height.
int | m_nHeaderHeight
Column header height.
int | m_nFooterHeight
Column footer height.
int | m_nGroupGridLineHeight
The height of the group grid line.
CXTPImageManager * | m_pGlyphs
An additional image list for the Grid control.
BOOL | m_bIsPreviewMode
TRUE to show the item preview, FALSE to hide.
int | m_nResizingWidth
The width of the column resizing marker area.
int | m_nMaxPreviewLines
Restrict maximum lines for preview text.
CSize | m_szGlyph
Glyph size.
CXTPBrush | m_xtpBrushTreeStructure
Brush to draw tree nodes.
CXTPBrush | m_xtpBrushGroupGridLineStyle
Brush to draw group row grid lines.
int | m_nFreezeColsDividerStyle
A set of flags from XTPGridFreezeColsDividerStyle.
BOOL | m_bFixedRowHeight
TRUE if fixed rows used.
BOOL | m_bColumnWidthWYSIWYG
TRUE if columns width WYSIWYG mode used.
BOOL | m_bShowWYSIWYGMarkers
TRUE if in non-print mode header show red page-end markers.
BOOL | m_bLastColumnWidthWYSIWYG
TRUE if last column width WYSIWYG mode used.
BOOL | m_bDrawGridForEmptySpace
TRUE if grid fills the empty space (if any) after the body rows.
BOOL | m_bPrintGroupRowIcon
TRUE if printout draw collapse-expand icon for group row.
BOOL | m_bColumnPlusMinusSign
TRUE if expand/collapse icons are used, FALSE if directional arrows are used.
BOOL | m_bFixedInplaceButtonHeight
TRUE if fixed in-place button height is used.
XTPGridGridStyle | m_nGroupGridLineStyle
Current style for group row grid lines.
XTPGridColumnStyle | m_columnStyle
Column drawing style.
CXTPWinThemeWrapper * | m_themeHeader
Header theme wrapper.
CXTPWinThemeWrapper * | m_themeButton
In-place button theme wrapper.
CXTPWinThemeWrapper * | m_themeCombo
Combo box in-place button theme wrapper.
CXTPWinThemeWrapper * | m_themeSpin
Spin in-place button theme wrapper.
CXTPGridControl * | m_pControl
Pointer to the Grid control object.
CXTPMarkupUIElement * | m_pMarkupUIElement_NoGroupBy
The no group by markup UI element.
CString | m_strMarkupUIElement_NoGroupBy
The no group by markup UI element string.
CXTPBrush | m_xtpBrushVeriticalGrid
Brush to draw vertical grid lines.
CXTPBrush | m_xtpBrushHorizontalGrid
Brush to draw horizontal grid lines.
XTPGridGridStyle m_nGridLineStylePreviousV
Previous style for vertical grid lines.
XTPGridGridStyle m_nGridLineStylePreviousH
Previous style for horizontal grid lines.

Detailed Description

CXTPGridThemeNativeWindows11 is a CXTPGridThemeOffice2013 derived class that represents a Native Windows 10 style theme.

The documentation for this class was generated from the following file:
  • XTPGridThemeNativeWindows11.h


Toolkit Pro: CXTPGridThemeOffice2003 Class Reference

Public Member Functions | List of all members
CXTPGridThemeOffice2003 Class Reference

CXTPGridThemeOffice2003 is a CXTPGridPaintManager derived class that represents an Office 2003 style theme. More...

Inheritance diagram for CXTPGridThemeOffice2003:
[legend]

Public Member Functions

CXTPGridThemeOffice2003 ()
Default paint manager constructor, handles properties initialization.
virtual void | DrawColumnBackground (CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, BOOL &bColumnPressed, BOOL &bDraggingFromHeader, CXTPGridHeader *pHeader=NULL)
This method is called to draw the background of a column using the current column style.
virtual void | DrawColumn (CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn, BOOL bDrawExternal=FALSE, int nShadowWidth=0)
Draws a column header with all related attributes (sort order, icon, etc.).
void | DrawSectionDivider (CDC *pDC, const CRect &rc, XTPGridSectionDividerPosition dividerPosition, XTPGridSectionDividerStyle dividerStyle, CXTPPaintManagerColor dividerColor)
Draws the divider between grid sections (e.g.
- Public Member Functions inherited from CXTPGridPaintManager
CXTPGridPaintManager ()
Default CXTPGridPaintManager constructor, handles properties initialization.
virtual | ~CXTPGridPaintManager ()
Default CXTPGridPaintManager destructor, handles member items deallocation.
virtual void | SetGridControl (CXTPGridControl *pControl)
Sets the associated Grid control for the paint manager.
virtual void | LoadGlyphs ()
Loads the default images used by the Grid control.
virtual void | RefreshMetrics ()
Initializes all drawings defaults (fonts, colors, etc.).
virtual int | GetRowHeight (CDC *pDC, CXTPGridRow *pRow)
Retrieves the default row height for print mode (i.e.
virtual int | GetRowHeight (CDC *pDC, CXTPGridRow *pRow, int nTotalWidth)
Retrieves the default row height for print mode (i.e.
int | GetRowHeightEx (CDC *pDC, CXTPGridRow *pRow, int nTotalWidth, const BOOL firstLevel=TRUE)
Retrieves the default row height for print mode (i.e.
int | GetItemHeight (XTP_GRIDRECORDITEM_DRAWARGS &drawArgs, int nWidth)
Retrieves the height of a record item for a given width.
BOOL | FindRowAdjacentToMergedEx (const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, int &nAdjRowIndex, BOOL bUpward)
Searches the topmost or bottommost row depending on the height of the current row.
int | FindRowAdjacentToMerged (const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, BOOL bUpward)
Wrapper for the FindRowAdjacentToMergedEx method.
int | RecalcTotalHightOfMergedRows (CXTPGridColumns *pColumns, CDC *pDC, CXTPGridRow *pRow, int nRowHeight, int nTotalWidth)
Recalculates row height according to the height of merged items.
virtual int | GetPreviewItemHeight (CDC *pDC, CXTPGridRow *pRow, int nWidth, int nHeight)
Retrieves the height of a preview item for print mode.
virtual int | GetHeaderHeight ()
Gets the column header height.
virtual int | GetHeaderHeight (CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0)
Calculates the optimal header height.
virtual void | SetHeaderHeight (int nHeight)
Sets the column header height.
virtual int | GetFooterHeight (CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0)
Calculates the optimal footer height.
virtual COLORREF | GetControlBackColor (CXTPGridControl *pControl)
Retrieves the parent Grid control's background color.
virtual void | FillRow (CDC *pDC, CXTPGridRow *pRow, CRect rcRow)
Fills a specified row with its background color.
virtual void | DrawGrid (CDC *pDC, XTPGridOrientation orientation, CRect rcGrid)
Draws a grid for the control.
virtual void | DrawFreezeColsDivider (CDC *pDC, const CRect &rc, CXTPGridControl *pControl, CXTPGridRow *pRow=NULL)
Draws a freeze column divider.
virtual void | DrawVerticalTimeLineMarker (CDC *pDC, int xPos, CXTPGridControl *pControl, COLORREF color=RGB(0, 255, 0))
Draws a vertical timeline marker.
virtual void | DrawGroupRow (CDC *pDC, CXTPGridGroupRow *pRow, CRect rcRow, XTP_GRIDRECORDITEM_METRICS *pMetrics)
Draws a group row.
virtual void | FillGroupRowMetrics (CXTPGridGroupRow *pRow, XTP_GRIDRECORDITEM_METRICS *pMetrics, BOOL bPrinting)
Fills the font and color members of the metrics structure for a specified group row.
virtual void | FillIndent (CDC *pDC, CRect rcRow)
Fills an indent area by its background.
virtual void | FillItemShade (CDC *pDC, CRect rcItem)
Fills an item shade by its background if necessary.
virtual void | FillHeaderControl (CDC *pDC, CRect rcHeader)
Fills a column header control area by its background.
virtual void | FillFooter (CDC *pDC, CRect rcFooter)
Fills a column footer control area by its background.
virtual void | DrawColumnText (CDC *pDC, CRect rcText, CString strCaption, int nHeaderAlignment, BOOL bIsHeader, BOOL bColumnPressed)
Draws text for the column header.
virtual void | DrawColumnFooterDivider (CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn)
Draws the column footer divider.
virtual void | DrawColumnFooter (CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn)
Draws the column footer with all related attributes (e.g.
virtual BOOL | IsColumHotTrackingEnabled () const
Determines if hot tracking is enabled for the current column style.
virtual void | DrawFocusedRow (CDC *pDC, CRect rcRow)
Draws focused rows.
virtual void | FillGroupByControl (CDC *pDC, CRect &rcGroupBy)
Draws the Group By box.
CXTPImageManager * | GetGlyphs () const
Gets a pointer to the additional image list with glyphs.
void | DrawHorizontalLine (CDC *pDC, int xPos, int yPos, int cx, COLORREF clr)
Draws a horizontal line.
void | DrawVerticalLine (CDC *pDC, int xPos, int yPos, int cy, COLORREF clr)
Draws a vertical line.
virtual void | DrawTriangle (CDC *pDC, CRect rcTriangle, BOOL bToDown, BOOL bDraggingFromHeader, int nShadowWidth, BOOL bColumnPressed)
Draws a triangle that shows the sort order of the column.
void | DrawConnector (CDC *pDC, CPoint ptFrom, CPoint ptTo)
Draws a column connector for the Group By box.
virtual CSize | DrawCollapsedBitmap (CDC *pDC, const CXTPGridRow *pRow, CRect &rcBitmap)
Draws a collapsed bitmap.
virtual int | DrawBitmap (CDC *pDC, CXTPGridControl *pControl, CRect rcColumn, int iImage)
Draws a bitmap.
virtual int | DrawColumnIcon (CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, CRect rcIcon, int iIcon)
Draws an icon for a column.
virtual CSize | DrawGlyph (CDC *pDC, CRect rcColumn, int iImage)
Draws the standard glyphs of the Grid control.
virtual CSize | DrawShellIcon (CDC *pDC, CRect rcColumn, int iImage)
Draws the shell icon.
void | EnablePreviewMode (BOOL bIsPreviewMode)
Enables/disables preview mode for the control.
BOOL | IsPreviewMode () const
Determines if preview mode is enabled/disabled for the control.
CFont * | GetTextFont ()
Gets the default text font used for control items.
int | SetMaxPreviewLines (int nMaxLines)
Sets the maximum number of lines of text for a preview item.
int | GetMaxPreviewLines ()
Gets the maximum number of lines of text for a preview item.
int | GetPreviewLinesCount (CDC *pDC, CRect &rcText, const CString &strText)
Calculates the number of lines required to draw a specified preview text string, taking into account the maximum number of lines of text for a preview item.
BOOL | IsGridVisible (BOOL bVertical) const
Determines the visibility of specified grid lines.
BOOL | IsGridVisible (XTPGridOrientation orientation) const
Determines the visibility of specified grid lines.
void | SetColumnStyle (XTPGridColumnStyle columnStyle)
Sets the header style.
XTPGridColumnStyle | GetColumnStyle () const
Gets the header style.
void | SetColumnOffice2007CustomThemeBaseColor (COLORREF clrBaseColor)
Sets the header's custom theme base color for Office2007 column style.
COLORREF | GetColumnOffice2007CustomThemeBaseColor () const
Gets the header's custom theme base color for Office2007 column style.
void | SetTextFont (LOGFONT &lf)
Creates and sets the default text font.
void | SetCaptionFont (LOGFONT &lf)
Creates and sets the default caption font.
void | SetPreviewIndent (int nLeft, int nTop, int nRight, int nBottom)
Sets the preview item indent.
virtual void | DrawInplaceButton (CDC *pDC, CXTPGridInplaceButton *pButton)
Draws the in-place button of the Grid control.
virtual BOOL | DrawInplaceComboButton (CDC *pDC, CRect *pRc)
Draws the combo button of the Grid control.
virtual BOOL | DrawInplaceExpandButton (CDC *pDC, CRect *pRc)
Draws the expand button of the Grid control.
virtual BOOL | DrawInplaceSpinButton (CDC *pDC, CRect *pRc)
Draws the spin button of the Grid control.
virtual void | DrawTreeStructure (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CRect rcItem, CSize sizeGlyph)
Draws tree elements of the Grid control.
virtual void | DrawItemBitmap (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CRect &rcItem, int nImage)
Draws an item bitmap.
virtual void | DrawItemCaption (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics)
Draws an item caption.
virtual void | DrawRowNumber (CDC *pDC, CRect rcNumber, CXTPGridRow *pRow)
Draws a row number.
virtual void | DrawItemControl (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CXTPGridRecordItemControl *pControl, CRect &rcItem)
Draws an item control.
BOOL | IsFixedRowHeight () const
Determines if the paint manager supports fixed or variable row height.
void | SetFixedRowHeight (BOOL bFixedRowHeight)
Sets if the paint manager supports fixed or variable row height.
BOOL | IsColumnWidthWYSIWYG () const
Determines if the paint manager supports column width WYSIWYG mode.
BOOL | IsLastColumnWidthWYSIWYG () const
Determines if the paint manager supports last column width WYSIWYG mode.
BOOL | IsShowWYSIWYGMarkers () const
Determines if the paint manager shows WYSIWYG page-end markers.
void | ShowWYSIWYGMarkers (BOOL bSet)
Sets if the paint manager shows WYSIWYG page-end markers.
void | SetColumnWidthWYSIWYG (BOOL bColumnWidthWYSIWYG)
Sets if the paint manager supports column width WYSIWYG mode.
void | SetLastColumnWidthWYSIWYG (BOOL bColumnWidthWYSIWYG)
Sets if the paint manager supports last column width WYSIWYG mode.
BOOL | IsFixedInplaceButtonHeight () const
Determines if the paint manager supports fixed or variable in-place button height.
void | SetInplaceButtonHeight (BOOL bFixedInplaceButtonHeight)
Sets if the paint manager supports fixed or variable in-place button height.
int | GetFreezeColsDividerStyle () const
Gets the style of the freeze columns divider line.
void | SetFreezeColsDividerStyle (int nStyle)
Sets the style for the freeze columns divider line.
virtual BOOL | OnDrawAction (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs)
Override this method to perform custom activities for the item before processing it.
virtual void | DrawNoGroupByText (CDC *pDC, CRect rcItem)
Draws the "No items" text message in the Group By area when there are no items inside it.
BOOL | IsDrawGridForEmptySpace () const
Determines if the grid fills empty space after body rows.
void | SetDrawGridForEmptySpace (BOOL bDrawGrid)
Sets if the grid fills empty space after body rows.
BOOL | IsPrintGroupRowIcon () const
Determines if the group row collapse-expand icon is drawn in print mode.
void | SetPrintGroupRowIcon (BOOL bDraw)
Sets if the group row collapse-expand icon is drawn in print mode.
BOOL | IsColumnPlusMinusSign () const
Determines if columns use expand/collapse icons (+/-) or directional arrows.
void | SetColumnPlusMinusSign (BOOL bDraw)
Specifies if columns use expand/collapse icons (+/-) or directional arrows.
virtual int | CalculateRowHeight (CDC *pDC, const CString &strText, int nMaxWidth, BOOL bWordBreak=TRUE)
Calculates the height required for a rectangle bounding multi-line text to draw the multi-line text when the width of the rectangle is fixed.
void | DrawSectionDivider (CDC *pDC, const CRect &rc, XTPGridSectionDividerPosition dividerPosition, XTPGridSectionDividerStyle dividerStyle, CXTPPaintManagerColor dividerColor)
Draws the divider between grid sections (e.g.
int | GetSectionDividerHeight (XTPGridFixedRowsDividerStyle dividerStyle)
Gets the height of the section divider.
BOOL | IsUseDropMarker () const
Determines if a drop marker will be used when dragging and dropping.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPGridPaintManager
CXTPFont | m_xtpFontText
Grid items default text.
CXTPFont | m_xtpFontBoldText
Grid items default bold text.
CXTPFont | m_xtpFontCaption
Column header caption font.
CXTPFont | m_xtpFontPreview
Column header caption font.
CXTPGridHyperlinkStyle * | m_pHyperlinkStyle
Style for links.
CXTPGridHyperlinkStyle * | m_pHyperlinkHoverStyle
Style for hovered links.
CXTPPaintManagerColor | m_clrHighlight
Background color of the highlighted row.
CXTPPaintManagerColor | m_clrBoldText
Grid items bold text color.
CXTPPaintManagerColor | m_clrBoldTextHighlight
Grid items bold text highlight color.
CXTPPaintManagerColor | m_clrWindowText
Grid items default text color.
CXTPPaintManagerColor | m_clrHighlightText
Text color of the highlighted text.
CXTPPaintManagerColor | m_clrHeaderControl
Background color of the grid header.
CXTPPaintManagerColor | m_clrCaptionText
Column header text color.
CXTPPaintManagerColor | m_clrCaptionTextPressed
Column header text color when pressed.
CXTPPaintManagerColor | m_clrControlBack
Background color of the control grid area.
CXTPPaintManagerColor | m_clrGroupRowText
Row text color.
CXTPPaintManagerColor | m_clrGroupShadeBack
Group row background color when indentation shade is enabled.
CXTPPaintManagerColor | m_clrGroupShadeText
Group row foreground color when indentation shade is enabled.
CXTPPaintManagerColor | m_clrGroupShadeBorder
Color for group border's shade.
CXTPPaintManagerColor | m_clrGroupBoxBack
Color of group box.
CXTPPaintManagerColor | m_clrControlDark
Dark background color of the Grid control (used on Group By area).
CXTPPaintManagerColor | m_clrControlLightLight
Light background color used for drawing shades (used on column header area).
CXTPPaintManagerColor | m_clrHotDivider
Color of the column hot divider window (two arrows).
CXTPPaintManagerColor | m_clrIndentControl
Color of the tree indentation area.
CXTPPaintManagerColor | m_clrItemShade
Color of the shade on sorted by column items.
CXTPPaintManagerColor | m_clrBtnFace
Standard button face color.
CXTPPaintManagerColor | m_clrBtnText
Standard button text color.
CXTPPaintManagerColor | m_clrPreviewText
Preview text color.
CXTPPaintManagerColor | m_clrSelectedRow
Selected row background color.
CXTPPaintManagerColor | m_clrSelectedRowText
Selected row text color.
CXTPPaintManagerColor | m_clrBtnFacePressed
Standard button face color when pressed.
CXTPPaintManagerColor | m_clrConnector
Header column connector line color.
CXTPPaintManagerColor | m_clrDisableBitmapLightest
The lightest color of bitmap which covers disabled grid.
CXTPPaintManagerColor | m_clrDisableBitmapDarkest
The darkest color of bitmap which covers disabled grid.
CXTPPaintManagerColorGradient | m_grcGradientColumn
Color of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColorGradient | m_grcGradientColumnHot
HotTracking Color of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColorGradient | m_grcGradientColumnPushed
Pushed Color of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColor | m_clrGradientColumnShadow
Bottom shadow of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColor | m_clrGradientColumnSeparator
Separator of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColor | m_crlNoGroupByText
A color for "No items" text in GroupBy area (see m_strNoGroupBy member).
CXTPPaintManagerColor | m_clrFreezeColsDivider
Freeze Columns Divider color.
COLORREF | m_clrColumnOffice2007CustomTheme
Base color for Office2007 custom theme.
COLORREF | m_clrFormulaSum
Color for Formula Sum fields.
COLORREF | m_clrFormulaSubSum
Color for Formula SubSum fields.
COLORREF | m_clrAlternativeBackground
Color for Alternative Row Background.
BOOL | m_bUseAlternativeBackground
TRUE to use Alternative Row Background, FALSE otherwise.
BOOL | m_bAllowMergeCells
TRUE to Allow Merge Cells, FALSE otherwise.
int | m_nTextIndentForGroupRowsWithNoIcon
Specifies Text indent if a group row icon is not used.
int | m_nTreeIndent
Tree indentation.
int | m_nTreeStructureStyle
Tree structure style.
int | m_nTreeTextIndentRowParent
Text indent, in pixels, for rows with children.
int | m_nTreeTextIndentRowChildren
Text indent, in pixels, for rows without children.
int | m_nTreeTextIndent
Text indent, in pixels, for rows that are neither parent nor children.
int | m_nTreeTextIndentGroupRow
Text indent, in pixels, for group rows.
BOOL | m_bGroupRowTextBold
TRUE to draw group rows with bold text.
BOOL | m_bShadeGroupHeadings
TRUE to show the indentation shade, FALSE otherwise.
BOOL | m_bShadeSortColumn
TRUE to show the items shade in the sorted by column, FALSE otherwise.
BOOL | m_bHotTracking
TRUE to allow column hot tracking.
BOOL | m_bInvertColumnOnClick
TRUE to invert column on click.
CString | m_strNoItems
A string which contains customized "No Items" text for displaying in view when there are no visible rows.
CString | m_strSortBy
A string which contains customized "Sort By" text for displaying in tooltip.
CString | m_strIncreasing
A string which contains customized "Increasing" text for displaying in tooltip.
CString | m_strDecreasing
A string which contains customized "Decreasing" text for displaying in tooltip.
CString | m_strNoGroupBy
A string which contains customized "No items" text message for displaying in Group By area when there are no items inside it.
CString | m_strNoFieldsAvailable
A string which contains customized "No Fields Available" text message for displaying in Field Chooser.
CString | m_strExpand
A string which contains customized "Expand" text for displaying in tooltip.
CString | m_strCollapse
A string which contains customized "Collapse" text for displaying in tooltip.
BOOL | m_bHideSelection
TRUE when hiding Grid control's selection by drawing selected items as others, FALSE otherwise.
BOOL | m_bPrintSortTriangle
TRUE to show the sort triangle in printout.
BOOL | m_bRevertAlignment
TRUE to revert column alignments.
BOOL | m_bUseEditTextAlignment
TRUE to automatically apply edit alignment using column alignment.
BOOL | m_bShowLockIcon
TRUE to show the lock icon, FALSE to hide.
BOOL | m_bUseShellIcon
TRUE to use the shell icon, FALSE otherwise.
int | m_iRecOrRowStart
Start position in numbering (0 or 1 or something user want).
BOOL | m_bRecOrRowNum
TRUE to display record number if support mode is used, FALSE to display row number.
BOOL | m_bMakeUpper
TRUE to display column header and group row text in all caps.
XTPGridTreeStructureStyle | m_treeStructureStyle
Tree structure style.
CRect | m_rcPreviewIndent
Preview indentation.
int | m_nFixedColumnsIndent
Fixed Column total width.
BOOL | m_bMoveScrollbarOnFixedColumnsIndent
Move Scrollbar right follow FixedColumnsIndent.
BOOL | m_bThemedInplaceButtons
Draw in-place buttons using current theme settings.
BOOL | m_bBaseTreeIndent
TRUE to add Extra Tree indentation to cover initial TreeColumn.
CUIntArray | m_arStartCol
Start column in each virtual page.
int | m_PrintPageWidth
Width of print page (run-time)
BOOL | m_bPrintVirtualPageNumber
TRUE to print horizontal page number.
BOOL | m_bPrintPageRectangle
TRUE to draw rectangle around page.
int | m_RecordNumberWidth
Column width for row/record numbers.
BOOL | m_bForceDynamicMarkupForCell
TRUE if use Markup for Grid Record Item.
BOOL | m_bForceShowDropMarker
TRUE if Force Show Drop Marker.
BOOL | m_bShowNonActiveInPlaceButton
TRUE if use Show Non-Active In-Place Button (Combo, Expand, Spin).
BOOL | m_bPrintWatermark
TRUE to print watermark.
BOOL | m_bUseGroupRowSelectionState
TRUE if use GroupSelectionState Glyph.
BOOL | m_bForceShowTooltip
TRUE if use show tooltip for any cell width case.
BOOL | m_bCleanTooltip
TRUE if use show tooltip without markup.
BOOL | m_bGrayIfDisable
TRUE is disable draw in gray (standard behavior).
int | m_nRowHeightDefault
The default row height.
BOOL | m_bCompactText
TRUE to ignore Icon for Narrow column to show more text.
BOOL | m_bUseDropMarker
FALSE to not draw drop marked when dragging/dropping, TRUE by default.
BOOL | m_bSortTriangleOffsetFromRight
Offset of sort triangle.
int | m_nTreeColumnLineLength
This is the extra line length to apply to tree column lines if there is no expand button.
int | m_nBaseParentRecordIndent
This is initial number of pixels a parent node will be indented when in a group.
- Protected Member Functions inherited from CXTPGridPaintManager
virtual void | DrawTextLine (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nFlag, int &nCharCounter, int &nHyperlinkCounter)
Draws a line of text with respect to the drawing rectangle.
virtual int | DrawString (int *pnCurrDrawPos, CDC *pDC, const CString &strDraw, CRect rcDraw, UINT nFormat)
Draw a simple string into rectangle.
virtual void | DrawGridPattern (CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush)
Generates a custom grid pattern if necessary.
virtual void | DrawGridPattern (CDC *pDC, CXTPBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush)
Generates a custom grid pattern if necessary.
virtual void | DrawGridPattern (CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr)
Generates a custom grid pattern.
virtual void | DrawInplaceButtonFrame (CDC *pDC, CXTPGridInplaceButton *pButton)
Draws the in-place button frame.
virtual BOOL | DrawInplaceButtonIcon (CDC *pDC, CXTPGridInplaceButton *pButton)
Draws the in-place button icon.
virtual int | CalcColumnHeight (CDC *pDC, CXTPGridColumn *pColumn, int nTotalWidth=0)
Calculates the optimal height for a specified column.
virtual void | DrawMultiLineText (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, BOOL bWordBreak=TRUE)
Draws multi-line text.
virtual void | DrawSingleLineText (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nStartPos, int nEndPos, int nActualWidth)
Draws single-line text.
virtual int | DrawLink (int *pnCurrDrawPos, XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CXTPGridHyperlink *pHyperlink, CString strText, CRect rcLink, int nFlag, BOOL bTrim=FALSE)
Draws a hyperlink string using hyperlink text settings (i.e.
- Protected Attributes inherited from CXTPGridPaintManager
int | m_nRowHeight
Grid row default height.
int | m_nHeaderHeight
Column header height.
int | m_nFooterHeight
Column footer height.
int | m_nGroupGridLineHeight
The height of the group grid line.
CXTPImageManager * | m_pGlyphs
An additional image list for the Grid control.
BOOL | m_bIsPreviewMode
TRUE to show the item preview, FALSE to hide.
int | m_nResizingWidth
The width of the column resizing marker area.
int | m_nMaxPreviewLines
Restrict maximum lines for preview text.
CSize | m_szGlyph
Glyph size.
CXTPBrush | m_xtpBrushTreeStructure
Brush to draw tree nodes.
CXTPBrush | m_xtpBrushGroupGridLineStyle
Brush to draw group row grid lines.
int | m_nFreezeColsDividerStyle
A set of flags from XTPGridFreezeColsDividerStyle.
BOOL | m_bFixedRowHeight
TRUE if fixed rows used.
BOOL | m_bColumnWidthWYSIWYG
TRUE if columns width WYSIWYG mode used.
BOOL | m_bShowWYSIWYGMarkers
TRUE if in non-print mode header show red page-end markers.
BOOL | m_bLastColumnWidthWYSIWYG
TRUE if last column width WYSIWYG mode used.
BOOL | m_bDrawGridForEmptySpace
TRUE if grid fills the empty space (if any) after the body rows.
BOOL | m_bPrintGroupRowIcon
TRUE if printout draw collapse-expand icon for group row.
BOOL | m_bColumnPlusMinusSign
TRUE if expand/collapse icons are used, FALSE if directional arrows are used.
BOOL | m_bFixedInplaceButtonHeight
TRUE if fixed in-place button height is used.
XTPGridGridStyle | m_nGroupGridLineStyle
Current style for group row grid lines.
XTPGridColumnStyle | m_columnStyle
Column drawing style.
CXTPWinThemeWrapper * | m_themeHeader
Header theme wrapper.
CXTPWinThemeWrapper * | m_themeButton
In-place button theme wrapper.
CXTPWinThemeWrapper * | m_themeCombo
Combo box in-place button theme wrapper.
CXTPWinThemeWrapper * | m_themeSpin
Spin in-place button theme wrapper.
CXTPGridControl * | m_pControl
Pointer to the Grid control object.
CXTPMarkupUIElement * | m_pMarkupUIElement_NoGroupBy
The no group by markup UI element.
CString | m_strMarkupUIElement_NoGroupBy
The no group by markup UI element string.
CXTPBrush | m_xtpBrushVeriticalGrid
Brush to draw vertical grid lines.
CXTPBrush | m_xtpBrushHorizontalGrid
Brush to draw horizontal grid lines.
XTPGridGridStyle m_nGridLineStylePreviousV
Previous style for vertical grid lines.
XTPGridGridStyle m_nGridLineStylePreviousH
Previous style for horizontal grid lines.

Detailed Description

CXTPGridThemeOffice2003 is a CXTPGridPaintManager derived class that represents an Office 2003 style theme.

Member Function Documentation

◆ DrawColumn()

virtual void DrawColumn | ( | CDC * | pDC,
 |  | CXTPGridColumn * | pColumn,
 |  | CXTPGridHeader * | pHeader,
 |  | CRect | rcColumn,
 |  | BOOL | bDrawExternal = FALSE,
 |  | int | nShadowWidth = 0 )
 virtual

Draws a column header with all related attributes (sort order, icon, etc.).

Parameters
pDC | Pointer to the used device context.
pColumn | Pointer to column header area rectangle coordinates.
pHeader | Pointer to the grid header.
rcColumn | Column area rectangle coordinates.
bDrawExternal | TRUE to draw the column above the header; the default value for this parameter is FALSE.
nShadowWidth | Size in pixels for the bottom shadow; the default value for this parameter is 0.

Example:

CXTPGridPaintManager* pPaintManager = m_pControl->GetPaintManager();
CXTPGridColumn* pColumn = CXTPGridColumn* pColumn = m_pColumns->GetAt(1);
CRect rcHeader(rcClient);
int nHeaderHeight = m_pControl->GetHeaderHeight();
rcHeader.bottom = rcHeader.top + nHeaderHeight;
GetPaintManager()->DrawColumn(pDC, pColumn, this, rcHeader);

Reimplemented from CXTPGridPaintManager.

◆ DrawColumnBackground()

virtual void DrawColumnBackground | ( | CDC * | pDC,
 |  | CXTPGridColumn * | pColumn,
 |  | CRect | rcColumn,
 |  | BOOL & | bColumnPressed,
 |  | BOOL & | bDraggingFromHeader,
 |  | CXTPGridHeader * | pHeader = NULL )
 virtual

This method is called to draw the background of a column using the current column style.

Parameters
pDC | Pointer to the used device context.
pColumn | Pointer to the column whose background must be drawn.
rcColumn | Bounding rectangle of the column.
bColumnPressed | TRUE if the column is pressed by the user.
bDraggingFromHeader | TRUE if the column is being dragged from the header area.
pHeader | Pointer to the header that the column belongs to.

Reimplemented from CXTPGridPaintManager.

◆ DrawSectionDivider()

void DrawSectionDivider | ( | CDC * | pDC,
 |  | const CRect & | rc,
 |  | XTPGridSectionDividerPosition | dividerPosition,
 |  | XTPGridSectionDividerStyle | dividerStyle,
 |  | CXTPPaintManagerColor | dividerColor )

Draws the divider between grid sections (e.g.

dividing header record rows and body rows).

Parameters
pDC | Pointer to the used device context.
rc | Reference to rectangle coordinates.
dividerPosition | Position of the section divider; must be one of the values defined by the XTPGridSectionDividerPosition enumeration.
dividerStyle | Style of the section divider; must be one of the values defined by the XTPGridSectionDividerStyle enumeration.
dividerColor | Color of the section divider.
The documentation for this class was generated from the following file:
  • XTPGridThemeOffice2003.h


Toolkit Pro: CXTPGridThemeOffice2003Luna Class Reference

Public Member Functions | List of all members
CXTPGridThemeOffice2003Luna Class Reference

CXTPGridThemeOffice2003Luna is a CXTPGridPaintManager derived class that represents an Office 2003 Luna style theme. More...

Inheritance diagram for CXTPGridThemeOffice2003Luna:
[legend]

Public Member Functions

CXTPGridThemeOffice2003Luna ()
Default paint manager constructor, handles properties initialization.
virtual void | RefreshMetrics ()
This method is called to refresh the visual metrics of the Grid control.
virtual void | FillFooter (CDC *pDC, CRect rcFooter)
Fills the column footer control area by its background.
virtual BOOL | IsColumHotTrackingEnabled () const
Determines if hot tracking is enabled for the current column style.
virtual void | DrawColumnBackground (CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, BOOL &bColumnPressed, BOOL &bDraggingFromHeader, CXTPGridHeader *pHeader=NULL)
This method is called to draw the background of a column using the current column style.
virtual void | DrawColumnFooterDivider (CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn)
Draws the column footer divider.
void | DrawSectionDivider (CDC *pDC, const CRect &rc, XTPGridSectionDividerPosition dividerPosition, XTPGridSectionDividerStyle dividerStyle, CXTPPaintManagerColor dividerColor)
Draws the divider between grid sections (e.g.
- Public Member Functions inherited from CXTPGridPaintManager
CXTPGridPaintManager ()
Default CXTPGridPaintManager constructor, handles properties initialization.
virtual | ~CXTPGridPaintManager ()
Default CXTPGridPaintManager destructor, handles member items deallocation.
virtual void | SetGridControl (CXTPGridControl *pControl)
Sets the associated Grid control for the paint manager.
virtual void | LoadGlyphs ()
Loads the default images used by the Grid control.
virtual int | GetRowHeight (CDC *pDC, CXTPGridRow *pRow)
Retrieves the default row height for print mode (i.e.
virtual int | GetRowHeight (CDC *pDC, CXTPGridRow *pRow, int nTotalWidth)
Retrieves the default row height for print mode (i.e.
int | GetRowHeightEx (CDC *pDC, CXTPGridRow *pRow, int nTotalWidth, const BOOL firstLevel=TRUE)
Retrieves the default row height for print mode (i.e.
int | GetItemHeight (XTP_GRIDRECORDITEM_DRAWARGS &drawArgs, int nWidth)
Retrieves the height of a record item for a given width.
BOOL | FindRowAdjacentToMergedEx (const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, int &nAdjRowIndex, BOOL bUpward)
Searches the topmost or bottommost row depending on the height of the current row.
int | FindRowAdjacentToMerged (const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, BOOL bUpward)
Wrapper for the FindRowAdjacentToMergedEx method.
int | RecalcTotalHightOfMergedRows (CXTPGridColumns *pColumns, CDC *pDC, CXTPGridRow *pRow, int nRowHeight, int nTotalWidth)
Recalculates row height according to the height of merged items.
virtual int | GetPreviewItemHeight (CDC *pDC, CXTPGridRow *pRow, int nWidth, int nHeight)
Retrieves the height of a preview item for print mode.
virtual int | GetHeaderHeight ()
Gets the column header height.
virtual int | GetHeaderHeight (CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0)
Calculates the optimal header height.
virtual void | SetHeaderHeight (int nHeight)
Sets the column header height.
virtual int | GetFooterHeight (CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0)
Calculates the optimal footer height.
virtual COLORREF | GetControlBackColor (CXTPGridControl *pControl)
Retrieves the parent Grid control's background color.
virtual void | FillRow (CDC *pDC, CXTPGridRow *pRow, CRect rcRow)
Fills a specified row with its background color.
virtual void | DrawGrid (CDC *pDC, XTPGridOrientation orientation, CRect rcGrid)
Draws a grid for the control.
virtual void | DrawFreezeColsDivider (CDC *pDC, const CRect &rc, CXTPGridControl *pControl, CXTPGridRow *pRow=NULL)
Draws a freeze column divider.
virtual void | DrawVerticalTimeLineMarker (CDC *pDC, int xPos, CXTPGridControl *pControl, COLORREF color=RGB(0, 255, 0))
Draws a vertical timeline marker.
virtual void | DrawGroupRow (CDC *pDC, CXTPGridGroupRow *pRow, CRect rcRow, XTP_GRIDRECORDITEM_METRICS *pMetrics)
Draws a group row.
virtual void | FillGroupRowMetrics (CXTPGridGroupRow *pRow, XTP_GRIDRECORDITEM_METRICS *pMetrics, BOOL bPrinting)
Fills the font and color members of the metrics structure for a specified group row.
virtual void | FillIndent (CDC *pDC, CRect rcRow)
Fills an indent area by its background.
virtual void | FillItemShade (CDC *pDC, CRect rcItem)
Fills an item shade by its background if necessary.
virtual void | FillHeaderControl (CDC *pDC, CRect rcHeader)
Fills a column header control area by its background.
virtual void | DrawColumnText (CDC *pDC, CRect rcText, CString strCaption, int nHeaderAlignment, BOOL bIsHeader, BOOL bColumnPressed)
Draws text for the column header.
virtual void | DrawColumn (CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn, BOOL bDrawExternal=FALSE, int nShadowWidth=0)
Draws a column header with all related attributes (sort order, icon, etc.).
virtual void | DrawColumnFooter (CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn)
Draws the column footer with all related attributes (e.g.
virtual void | DrawFocusedRow (CDC *pDC, CRect rcRow)
Draws focused rows.
virtual void | FillGroupByControl (CDC *pDC, CRect &rcGroupBy)
Draws the Group By box.
CXTPImageManager * | GetGlyphs () const
Gets a pointer to the additional image list with glyphs.
void | DrawHorizontalLine (CDC *pDC, int xPos, int yPos, int cx, COLORREF clr)
Draws a horizontal line.
void | DrawVerticalLine (CDC *pDC, int xPos, int yPos, int cy, COLORREF clr)
Draws a vertical line.
virtual void | DrawTriangle (CDC *pDC, CRect rcTriangle, BOOL bToDown, BOOL bDraggingFromHeader, int nShadowWidth, BOOL bColumnPressed)
Draws a triangle that shows the sort order of the column.
void | DrawConnector (CDC *pDC, CPoint ptFrom, CPoint ptTo)
Draws a column connector for the Group By box.
virtual CSize | DrawCollapsedBitmap (CDC *pDC, const CXTPGridRow *pRow, CRect &rcBitmap)
Draws a collapsed bitmap.
virtual int | DrawBitmap (CDC *pDC, CXTPGridControl *pControl, CRect rcColumn, int iImage)
Draws a bitmap.
virtual int | DrawColumnIcon (CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, CRect rcIcon, int iIcon)
Draws an icon for a column.
virtual CSize | DrawGlyph (CDC *pDC, CRect rcColumn, int iImage)
Draws the standard glyphs of the Grid control.
virtual CSize | DrawShellIcon (CDC *pDC, CRect rcColumn, int iImage)
Draws the shell icon.
void | EnablePreviewMode (BOOL bIsPreviewMode)
Enables/disables preview mode for the control.
BOOL | IsPreviewMode () const
Determines if preview mode is enabled/disabled for the control.
CFont * | GetTextFont ()
Gets the default text font used for control items.
int | SetMaxPreviewLines (int nMaxLines)
Sets the maximum number of lines of text for a preview item.
int | GetMaxPreviewLines ()
Gets the maximum number of lines of text for a preview item.
int | GetPreviewLinesCount (CDC *pDC, CRect &rcText, const CString &strText)
Calculates the number of lines required to draw a specified preview text string, taking into account the maximum number of lines of text for a preview item.
BOOL | IsGridVisible (BOOL bVertical) const
Determines the visibility of specified grid lines.
BOOL | IsGridVisible (XTPGridOrientation orientation) const
Determines the visibility of specified grid lines.
void | SetColumnStyle (XTPGridColumnStyle columnStyle)
Sets the header style.
XTPGridColumnStyle | GetColumnStyle () const
Gets the header style.
void | SetColumnOffice2007CustomThemeBaseColor (COLORREF clrBaseColor)
Sets the header's custom theme base color for Office2007 column style.
COLORREF | GetColumnOffice2007CustomThemeBaseColor () const
Gets the header's custom theme base color for Office2007 column style.
void | SetTextFont (LOGFONT &lf)
Creates and sets the default text font.
void | SetCaptionFont (LOGFONT &lf)
Creates and sets the default caption font.
void | SetPreviewIndent (int nLeft, int nTop, int nRight, int nBottom)
Sets the preview item indent.
virtual void | DrawInplaceButton (CDC *pDC, CXTPGridInplaceButton *pButton)
Draws the in-place button of the Grid control.
virtual BOOL | DrawInplaceComboButton (CDC *pDC, CRect *pRc)
Draws the combo button of the Grid control.
virtual BOOL | DrawInplaceExpandButton (CDC *pDC, CRect *pRc)
Draws the expand button of the Grid control.
virtual BOOL | DrawInplaceSpinButton (CDC *pDC, CRect *pRc)
Draws the spin button of the Grid control.
virtual void | DrawTreeStructure (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CRect rcItem, CSize sizeGlyph)
Draws tree elements of the Grid control.
virtual void | DrawItemBitmap (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CRect &rcItem, int nImage)
Draws an item bitmap.
virtual void | DrawItemCaption (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics)
Draws an item caption.
virtual void | DrawRowNumber (CDC *pDC, CRect rcNumber, CXTPGridRow *pRow)
Draws a row number.
virtual void | DrawItemControl (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CXTPGridRecordItemControl *pControl, CRect &rcItem)
Draws an item control.
BOOL | IsFixedRowHeight () const
Determines if the paint manager supports fixed or variable row height.
void | SetFixedRowHeight (BOOL bFixedRowHeight)
Sets if the paint manager supports fixed or variable row height.
BOOL | IsColumnWidthWYSIWYG () const
Determines if the paint manager supports column width WYSIWYG mode.
BOOL | IsLastColumnWidthWYSIWYG () const
Determines if the paint manager supports last column width WYSIWYG mode.
BOOL | IsShowWYSIWYGMarkers () const
Determines if the paint manager shows WYSIWYG page-end markers.
void | ShowWYSIWYGMarkers (BOOL bSet)
Sets if the paint manager shows WYSIWYG page-end markers.
void | SetColumnWidthWYSIWYG (BOOL bColumnWidthWYSIWYG)
Sets if the paint manager supports column width WYSIWYG mode.
void | SetLastColumnWidthWYSIWYG (BOOL bColumnWidthWYSIWYG)
Sets if the paint manager supports last column width WYSIWYG mode.
BOOL | IsFixedInplaceButtonHeight () const
Determines if the paint manager supports fixed or variable in-place button height.
void | SetInplaceButtonHeight (BOOL bFixedInplaceButtonHeight)
Sets if the paint manager supports fixed or variable in-place button height.
int | GetFreezeColsDividerStyle () const
Gets the style of the freeze columns divider line.
void | SetFreezeColsDividerStyle (int nStyle)
Sets the style for the freeze columns divider line.
virtual BOOL | OnDrawAction (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs)
Override this method to perform custom activities for the item before processing it.
virtual void | DrawNoGroupByText (CDC *pDC, CRect rcItem)
Draws the "No items" text message in the Group By area when there are no items inside it.
BOOL | IsDrawGridForEmptySpace () const
Determines if the grid fills empty space after body rows.
void | SetDrawGridForEmptySpace (BOOL bDrawGrid)
Sets if the grid fills empty space after body rows.
BOOL | IsPrintGroupRowIcon () const
Determines if the group row collapse-expand icon is drawn in print mode.
void | SetPrintGroupRowIcon (BOOL bDraw)
Sets if the group row collapse-expand icon is drawn in print mode.
BOOL | IsColumnPlusMinusSign () const
Determines if columns use expand/collapse icons (+/-) or directional arrows.
void | SetColumnPlusMinusSign (BOOL bDraw)
Specifies if columns use expand/collapse icons (+/-) or directional arrows.
virtual int | CalculateRowHeight (CDC *pDC, const CString &strText, int nMaxWidth, BOOL bWordBreak=TRUE)
Calculates the height required for a rectangle bounding multi-line text to draw the multi-line text when the width of the rectangle is fixed.
void | DrawSectionDivider (CDC *pDC, const CRect &rc, XTPGridSectionDividerPosition dividerPosition, XTPGridSectionDividerStyle dividerStyle, CXTPPaintManagerColor dividerColor)
Draws the divider between grid sections (e.g.
int | GetSectionDividerHeight (XTPGridFixedRowsDividerStyle dividerStyle)
Gets the height of the section divider.
BOOL | IsUseDropMarker () const
Determines if a drop marker will be used when dragging and dropping.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPGridPaintManager
CXTPFont | m_xtpFontText
Grid items default text.
CXTPFont | m_xtpFontBoldText
Grid items default bold text.
CXTPFont | m_xtpFontCaption
Column header caption font.
CXTPFont | m_xtpFontPreview
Column header caption font.
CXTPGridHyperlinkStyle * | m_pHyperlinkStyle
Style for links.
CXTPGridHyperlinkStyle * | m_pHyperlinkHoverStyle
Style for hovered links.
CXTPPaintManagerColor | m_clrHighlight
Background color of the highlighted row.
CXTPPaintManagerColor | m_clrBoldText
Grid items bold text color.
CXTPPaintManagerColor | m_clrBoldTextHighlight
Grid items bold text highlight color.
CXTPPaintManagerColor | m_clrWindowText
Grid items default text color.
CXTPPaintManagerColor | m_clrHighlightText
Text color of the highlighted text.
CXTPPaintManagerColor | m_clrHeaderControl
Background color of the grid header.
CXTPPaintManagerColor | m_clrCaptionText
Column header text color.
CXTPPaintManagerColor | m_clrCaptionTextPressed
Column header text color when pressed.
CXTPPaintManagerColor | m_clrControlBack
Background color of the control grid area.
CXTPPaintManagerColor | m_clrGroupRowText
Row text color.
CXTPPaintManagerColor | m_clrGroupShadeBack
Group row background color when indentation shade is enabled.
CXTPPaintManagerColor | m_clrGroupShadeText
Group row foreground color when indentation shade is enabled.
CXTPPaintManagerColor | m_clrGroupShadeBorder
Color for group border's shade.
CXTPPaintManagerColor | m_clrGroupBoxBack
Color of group box.
CXTPPaintManagerColor | m_clrControlDark
Dark background color of the Grid control (used on Group By area).
CXTPPaintManagerColor | m_clrControlLightLight
Light background color used for drawing shades (used on column header area).
CXTPPaintManagerColor | m_clrHotDivider
Color of the column hot divider window (two arrows).
CXTPPaintManagerColor | m_clrIndentControl
Color of the tree indentation area.
CXTPPaintManagerColor | m_clrItemShade
Color of the shade on sorted by column items.
CXTPPaintManagerColor | m_clrBtnFace
Standard button face color.
CXTPPaintManagerColor | m_clrBtnText
Standard button text color.
CXTPPaintManagerColor | m_clrPreviewText
Preview text color.
CXTPPaintManagerColor | m_clrSelectedRow
Selected row background color.
CXTPPaintManagerColor | m_clrSelectedRowText
Selected row text color.
CXTPPaintManagerColor | m_clrBtnFacePressed
Standard button face color when pressed.
CXTPPaintManagerColor | m_clrConnector
Header column connector line color.
CXTPPaintManagerColor | m_clrDisableBitmapLightest
The lightest color of bitmap which covers disabled grid.
CXTPPaintManagerColor | m_clrDisableBitmapDarkest
The darkest color of bitmap which covers disabled grid.
CXTPPaintManagerColorGradient | m_grcGradientColumn
Color of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColorGradient | m_grcGradientColumnHot
HotTracking Color of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColorGradient | m_grcGradientColumnPushed
Pushed Color of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColor | m_clrGradientColumnShadow
Bottom shadow of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColor | m_clrGradientColumnSeparator
Separator of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColor | m_crlNoGroupByText
A color for "No items" text in GroupBy area (see m_strNoGroupBy member).
CXTPPaintManagerColor | m_clrFreezeColsDivider
Freeze Columns Divider color.
COLORREF | m_clrColumnOffice2007CustomTheme
Base color for Office2007 custom theme.
COLORREF | m_clrFormulaSum
Color for Formula Sum fields.
COLORREF | m_clrFormulaSubSum
Color for Formula SubSum fields.
COLORREF | m_clrAlternativeBackground
Color for Alternative Row Background.
BOOL | m_bUseAlternativeBackground
TRUE to use Alternative Row Background, FALSE otherwise.
BOOL | m_bAllowMergeCells
TRUE to Allow Merge Cells, FALSE otherwise.
int | m_nTextIndentForGroupRowsWithNoIcon
Specifies Text indent if a group row icon is not used.
int | m_nTreeIndent
Tree indentation.
int | m_nTreeStructureStyle
Tree structure style.
int | m_nTreeTextIndentRowParent
Text indent, in pixels, for rows with children.
int | m_nTreeTextIndentRowChildren
Text indent, in pixels, for rows without children.
int | m_nTreeTextIndent
Text indent, in pixels, for rows that are neither parent nor children.
int | m_nTreeTextIndentGroupRow
Text indent, in pixels, for group rows.
BOOL | m_bGroupRowTextBold
TRUE to draw group rows with bold text.
BOOL | m_bShadeGroupHeadings
TRUE to show the indentation shade, FALSE otherwise.
BOOL | m_bShadeSortColumn
TRUE to show the items shade in the sorted by column, FALSE otherwise.
BOOL | m_bHotTracking
TRUE to allow column hot tracking.
BOOL | m_bInvertColumnOnClick
TRUE to invert column on click.
CString | m_strNoItems
A string which contains customized "No Items" text for displaying in view when there are no visible rows.
CString | m_strSortBy
A string which contains customized "Sort By" text for displaying in tooltip.
CString | m_strIncreasing
A string which contains customized "Increasing" text for displaying in tooltip.
CString | m_strDecreasing
A string which contains customized "Decreasing" text for displaying in tooltip.
CString | m_strNoGroupBy
A string which contains customized "No items" text message for displaying in Group By area when there are no items inside it.
CString | m_strNoFieldsAvailable
A string which contains customized "No Fields Available" text message for displaying in Field Chooser.
CString | m_strExpand
A string which contains customized "Expand" text for displaying in tooltip.
CString | m_strCollapse
A string which contains customized "Collapse" text for displaying in tooltip.
BOOL | m_bHideSelection
TRUE when hiding Grid control's selection by drawing selected items as others, FALSE otherwise.
BOOL | m_bPrintSortTriangle
TRUE to show the sort triangle in printout.
BOOL | m_bRevertAlignment
TRUE to revert column alignments.
BOOL | m_bUseEditTextAlignment
TRUE to automatically apply edit alignment using column alignment.
BOOL | m_bShowLockIcon
TRUE to show the lock icon, FALSE to hide.
BOOL | m_bUseShellIcon
TRUE to use the shell icon, FALSE otherwise.
int | m_iRecOrRowStart
Start position in numbering (0 or 1 or something user want).
BOOL | m_bRecOrRowNum
TRUE to display record number if support mode is used, FALSE to display row number.
BOOL | m_bMakeUpper
TRUE to display column header and group row text in all caps.
XTPGridTreeStructureStyle | m_treeStructureStyle
Tree structure style.
CRect | m_rcPreviewIndent
Preview indentation.
int | m_nFixedColumnsIndent
Fixed Column total width.
BOOL | m_bMoveScrollbarOnFixedColumnsIndent
Move Scrollbar right follow FixedColumnsIndent.
BOOL | m_bThemedInplaceButtons
Draw in-place buttons using current theme settings.
BOOL | m_bBaseTreeIndent
TRUE to add Extra Tree indentation to cover initial TreeColumn.
CUIntArray | m_arStartCol
Start column in each virtual page.
int | m_PrintPageWidth
Width of print page (run-time)
BOOL | m_bPrintVirtualPageNumber
TRUE to print horizontal page number.
BOOL | m_bPrintPageRectangle
TRUE to draw rectangle around page.
int | m_RecordNumberWidth
Column width for row/record numbers.
BOOL | m_bForceDynamicMarkupForCell
TRUE if use Markup for Grid Record Item.
BOOL | m_bForceShowDropMarker
TRUE if Force Show Drop Marker.
BOOL | m_bShowNonActiveInPlaceButton
TRUE if use Show Non-Active In-Place Button (Combo, Expand, Spin).
BOOL | m_bPrintWatermark
TRUE to print watermark.
BOOL | m_bUseGroupRowSelectionState
TRUE if use GroupSelectionState Glyph.
BOOL | m_bForceShowTooltip
TRUE if use show tooltip for any cell width case.
BOOL | m_bCleanTooltip
TRUE if use show tooltip without markup.
BOOL | m_bGrayIfDisable
TRUE is disable draw in gray (standard behavior).
int | m_nRowHeightDefault
The default row height.
BOOL | m_bCompactText
TRUE to ignore Icon for Narrow column to show more text.
BOOL | m_bUseDropMarker
FALSE to not draw drop marked when dragging/dropping, TRUE by default.
BOOL | m_bSortTriangleOffsetFromRight
Offset of sort triangle.
int | m_nTreeColumnLineLength
This is the extra line length to apply to tree column lines if there is no expand button.
int | m_nBaseParentRecordIndent
This is initial number of pixels a parent node will be indented when in a group.
- Protected Member Functions inherited from CXTPGridPaintManager
virtual void | DrawTextLine (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nFlag, int &nCharCounter, int &nHyperlinkCounter)
Draws a line of text with respect to the drawing rectangle.
virtual int | DrawString (int *pnCurrDrawPos, CDC *pDC, const CString &strDraw, CRect rcDraw, UINT nFormat)
Draw a simple string into rectangle.
virtual void | DrawGridPattern (CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush)
Generates a custom grid pattern if necessary.
virtual void | DrawGridPattern (CDC *pDC, CXTPBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush)
Generates a custom grid pattern if necessary.
virtual void | DrawGridPattern (CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr)
Generates a custom grid pattern.
virtual void | DrawInplaceButtonFrame (CDC *pDC, CXTPGridInplaceButton *pButton)
Draws the in-place button frame.
virtual BOOL | DrawInplaceButtonIcon (CDC *pDC, CXTPGridInplaceButton *pButton)
Draws the in-place button icon.
virtual int | CalcColumnHeight (CDC *pDC, CXTPGridColumn *pColumn, int nTotalWidth=0)
Calculates the optimal height for a specified column.
virtual void | DrawMultiLineText (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, BOOL bWordBreak=TRUE)
Draws multi-line text.
virtual void | DrawSingleLineText (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nStartPos, int nEndPos, int nActualWidth)
Draws single-line text.
virtual int | DrawLink (int *pnCurrDrawPos, XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CXTPGridHyperlink *pHyperlink, CString strText, CRect rcLink, int nFlag, BOOL bTrim=FALSE)
Draws a hyperlink string using hyperlink text settings (i.e.
- Protected Attributes inherited from CXTPGridPaintManager
int | m_nRowHeight
Grid row default height.
int | m_nHeaderHeight
Column header height.
int | m_nFooterHeight
Column footer height.
int | m_nGroupGridLineHeight
The height of the group grid line.
CXTPImageManager * | m_pGlyphs
An additional image list for the Grid control.
BOOL | m_bIsPreviewMode
TRUE to show the item preview, FALSE to hide.
int | m_nResizingWidth
The width of the column resizing marker area.
int | m_nMaxPreviewLines
Restrict maximum lines for preview text.
CSize | m_szGlyph
Glyph size.
CXTPBrush | m_xtpBrushTreeStructure
Brush to draw tree nodes.
CXTPBrush | m_xtpBrushGroupGridLineStyle
Brush to draw group row grid lines.
int | m_nFreezeColsDividerStyle
A set of flags from XTPGridFreezeColsDividerStyle.
BOOL | m_bFixedRowHeight
TRUE if fixed rows used.
BOOL | m_bColumnWidthWYSIWYG
TRUE if columns width WYSIWYG mode used.
BOOL | m_bShowWYSIWYGMarkers
TRUE if in non-print mode header show red page-end markers.
BOOL | m_bLastColumnWidthWYSIWYG
TRUE if last column width WYSIWYG mode used.
BOOL | m_bDrawGridForEmptySpace
TRUE if grid fills the empty space (if any) after the body rows.
BOOL | m_bPrintGroupRowIcon
TRUE if printout draw collapse-expand icon for group row.
BOOL | m_bColumnPlusMinusSign
TRUE if expand/collapse icons are used, FALSE if directional arrows are used.
BOOL | m_bFixedInplaceButtonHeight
TRUE if fixed in-place button height is used.
XTPGridGridStyle | m_nGroupGridLineStyle
Current style for group row grid lines.
XTPGridColumnStyle | m_columnStyle
Column drawing style.
CXTPWinThemeWrapper * | m_themeHeader
Header theme wrapper.
CXTPWinThemeWrapper * | m_themeButton
In-place button theme wrapper.
CXTPWinThemeWrapper * | m_themeCombo
Combo box in-place button theme wrapper.
CXTPWinThemeWrapper * | m_themeSpin
Spin in-place button theme wrapper.
CXTPGridControl * | m_pControl
Pointer to the Grid control object.
CXTPMarkupUIElement * | m_pMarkupUIElement_NoGroupBy
The no group by markup UI element.
CString | m_strMarkupUIElement_NoGroupBy
The no group by markup UI element string.
CXTPBrush | m_xtpBrushVeriticalGrid
Brush to draw vertical grid lines.
CXTPBrush | m_xtpBrushHorizontalGrid
Brush to draw horizontal grid lines.
XTPGridGridStyle m_nGridLineStylePreviousV
Previous style for vertical grid lines.
XTPGridGridStyle m_nGridLineStylePreviousH
Previous style for horizontal grid lines.

Detailed Description

CXTPGridThemeOffice2003Luna is a CXTPGridPaintManager derived class that represents an Office 2003 Luna style theme.

Member Function Documentation

◆ DrawColumnBackground()

virtual void DrawColumnBackground | ( | CDC * | pDC,
 |  | CXTPGridColumn * | pColumn,
 |  | CRect | rcColumn,
 |  | BOOL & | bColumnPressed,
 |  | BOOL & | bDraggingFromHeader,
 |  | CXTPGridHeader * | pHeader = NULL )
 virtual

This method is called to draw the background of a column using the current column style.

Parameters
pDC | Pointer to the used device context.
pColumn | Pointer to the column whose background must be drawn.
rcColumn | Bounding rectangle of the column.
bColumnPressed | TRUE if the column is pressed by the user.
bDraggingFromHeader | TRUE if the column is being dragged from the header area.
pHeader | Pointer to the header that the column belongs to.

Reimplemented from CXTPGridPaintManager.

◆ DrawColumnFooterDivider()

virtual void DrawColumnFooterDivider | ( | CDC * | pDC,
 |  | CXTPGridColumn * | pColumn,
 |  | CRect | rcColumn )
 virtual

Draws the column footer divider.

Parameters
pDC | Pointer to the used device context.
pColumn | Pointer to column header area rectangle coordinates.
rcColumn | Column area rectangle coordinates.

Reimplemented from CXTPGridPaintManager.

◆ DrawSectionDivider()

void DrawSectionDivider | ( | CDC * | pDC,
 |  | const CRect & | rc,
 |  | XTPGridSectionDividerPosition | dividerPosition,
 |  | XTPGridSectionDividerStyle | dividerStyle,
 |  | CXTPPaintManagerColor | dividerColor )

Draws the divider between grid sections (e.g.

dividing header record rows and body rows).

Parameters
pDC | Pointer to the used device context.
rc | Reference to rectangle coordinates.
dividerPosition | Position of the section divider; must be one of the values defined by the XTPGridSectionDividerPosition enumeration.
dividerStyle | Style of the section divider; must be one of the values defined by the XTPGridSectionDividerStyle enumeration.
dividerColor | Color of the section divider.

◆ FillFooter()

virtual void FillFooter | ( | CDC * | pDC,
 |  | CRect | rcFooter )
 virtual

Fills the column footer control area by its background.

Parameters
pDC | Pointer to the used device context.
rcFooter | Footer area rectangle coordinates.

Reimplemented from CXTPGridPaintManager.

◆ IsColumHotTrackingEnabled()

virtual BOOL IsColumHotTrackingEnabled ( ) const
virtual

Determines if hot tracking is enabled for the current column style.

Returns
TRUE if hot tracking is enabled, otherwise FALSE.

Hot tracking can only be used for the xtpGridColumnOffice2003 and xtpGridColumnExplorer styles.

See also
m_columnStyle, m_bHotTracking

Reimplemented from CXTPGridPaintManager.

The documentation for this class was generated from the following file:
  • XTPGridThemeOffice2003Luna.h


Toolkit Pro: CXTPGridThemeOffice2013 Class Reference

Public Member Functions | Public Attributes | List of all members
CXTPGridThemeOffice2013 Class Reference

CXTPGridThemeOffice2013 is a CXTPGridPaintManager derived class that represents an Office 2013 style theme. More...

Inheritance diagram for CXTPGridThemeOffice2013:
[legend]

Public Member Functions

CXTPGridThemeOffice2013 ()
Default paint manager constructor, handles properties initialization.
virtual void | LoadGlyphs ()
Loads the default images used by the Grid control.
virtual void | RefreshMetrics ()
This method is called to refresh the visual metrics of the Grid control.
virtual void | DrawColumnText (CDC *pDC, CRect rcText, CString strCaption, int nHeaderAlignment, BOOL bIsHeader, BOOL bColumnPressed)
Draws text for the column header.
virtual void | DrawColumnBackground (CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, BOOL &bColumnPressed, BOOL &bDraggingFromHeader, CXTPGridHeader *pHeader=NULL)
This method is called to draw the background of a column using the current column style.
virtual void | DrawTriangle (CDC *pDC, CRect rcTriangle, BOOL bToDown, BOOL bDraggingFromHeader, int nShadowWidth, BOOL bColumnPressed)
Draws a triangle that shows the sort order of the column.
virtual CSize | DrawCollapsedBitmap (CDC *pDC, const CXTPGridRow *pRow, CRect &rcBitmap)
Draws a collapsed bitmap.
virtual void | FillGroupRowMetrics (CXTPGridGroupRow *pRow, XTP_GRIDRECORDITEM_METRICS *pMetrics, BOOL bPrinting)
Fills the font and color members of the metrics structure for a specified group row.
virtual void | DrawGroupRow (CDC *pDC, CXTPGridGroupRow *pRow, CRect rcRow, XTP_GRIDRECORDITEM_METRICS *pMetrics)
Draws a group row.
virtual void | DrawFocusedRow (CDC *pDC, CRect rcRow)
Draws focused rows.
virtual int | GetRowHeight (CDC *pDC, CXTPGridRow *pRow)
Retrieves the default row height for print mode (i.e.
virtual int | GetRowHeight (CDC *pDC, CXTPGridRow *pRow, int nTotalWidth)
Retrieves the default row height for print mode (i.e.
- Public Member Functions inherited from CXTPGridPaintManager
CXTPGridPaintManager ()
Default CXTPGridPaintManager constructor, handles properties initialization.
virtual | ~CXTPGridPaintManager ()
Default CXTPGridPaintManager destructor, handles member items deallocation.
virtual void | SetGridControl (CXTPGridControl *pControl)
Sets the associated Grid control for the paint manager.
int | GetRowHeightEx (CDC *pDC, CXTPGridRow *pRow, int nTotalWidth, const BOOL firstLevel=TRUE)
Retrieves the default row height for print mode (i.e.
int | GetItemHeight (XTP_GRIDRECORDITEM_DRAWARGS &drawArgs, int nWidth)
Retrieves the height of a record item for a given width.
BOOL | FindRowAdjacentToMergedEx (const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, int &nAdjRowIndex, BOOL bUpward)
Searches the topmost or bottommost row depending on the height of the current row.
int | FindRowAdjacentToMerged (const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, BOOL bUpward)
Wrapper for the FindRowAdjacentToMergedEx method.
int | RecalcTotalHightOfMergedRows (CXTPGridColumns *pColumns, CDC *pDC, CXTPGridRow *pRow, int nRowHeight, int nTotalWidth)
Recalculates row height according to the height of merged items.
virtual int | GetPreviewItemHeight (CDC *pDC, CXTPGridRow *pRow, int nWidth, int nHeight)
Retrieves the height of a preview item for print mode.
virtual int | GetHeaderHeight ()
Gets the column header height.
virtual int | GetHeaderHeight (CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0)
Calculates the optimal header height.
virtual void | SetHeaderHeight (int nHeight)
Sets the column header height.
virtual int | GetFooterHeight (CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0)
Calculates the optimal footer height.
virtual COLORREF | GetControlBackColor (CXTPGridControl *pControl)
Retrieves the parent Grid control's background color.
virtual void | FillRow (CDC *pDC, CXTPGridRow *pRow, CRect rcRow)
Fills a specified row with its background color.
virtual void | DrawGrid (CDC *pDC, XTPGridOrientation orientation, CRect rcGrid)
Draws a grid for the control.
virtual void | DrawFreezeColsDivider (CDC *pDC, const CRect &rc, CXTPGridControl *pControl, CXTPGridRow *pRow=NULL)
Draws a freeze column divider.
virtual void | DrawVerticalTimeLineMarker (CDC *pDC, int xPos, CXTPGridControl *pControl, COLORREF color=RGB(0, 255, 0))
Draws a vertical timeline marker.
virtual void | FillIndent (CDC *pDC, CRect rcRow)
Fills an indent area by its background.
virtual void | FillItemShade (CDC *pDC, CRect rcItem)
Fills an item shade by its background if necessary.
virtual void | FillHeaderControl (CDC *pDC, CRect rcHeader)
Fills a column header control area by its background.
virtual void | FillFooter (CDC *pDC, CRect rcFooter)
Fills a column footer control area by its background.
virtual void | DrawColumn (CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn, BOOL bDrawExternal=FALSE, int nShadowWidth=0)
Draws a column header with all related attributes (sort order, icon, etc.).
virtual void | DrawColumnFooterDivider (CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn)
Draws the column footer divider.
virtual void | DrawColumnFooter (CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn)
Draws the column footer with all related attributes (e.g.
virtual BOOL | IsColumHotTrackingEnabled () const
Determines if hot tracking is enabled for the current column style.
virtual void | FillGroupByControl (CDC *pDC, CRect &rcGroupBy)
Draws the Group By box.
CXTPImageManager * | GetGlyphs () const
Gets a pointer to the additional image list with glyphs.
void | DrawHorizontalLine (CDC *pDC, int xPos, int yPos, int cx, COLORREF clr)
Draws a horizontal line.
void | DrawVerticalLine (CDC *pDC, int xPos, int yPos, int cy, COLORREF clr)
Draws a vertical line.
void | DrawConnector (CDC *pDC, CPoint ptFrom, CPoint ptTo)
Draws a column connector for the Group By box.
virtual int | DrawBitmap (CDC *pDC, CXTPGridControl *pControl, CRect rcColumn, int iImage)
Draws a bitmap.
virtual int | DrawColumnIcon (CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, CRect rcIcon, int iIcon)
Draws an icon for a column.
virtual CSize | DrawGlyph (CDC *pDC, CRect rcColumn, int iImage)
Draws the standard glyphs of the Grid control.
virtual CSize | DrawShellIcon (CDC *pDC, CRect rcColumn, int iImage)
Draws the shell icon.
void | EnablePreviewMode (BOOL bIsPreviewMode)
Enables/disables preview mode for the control.
BOOL | IsPreviewMode () const
Determines if preview mode is enabled/disabled for the control.
CFont * | GetTextFont ()
Gets the default text font used for control items.
int | SetMaxPreviewLines (int nMaxLines)
Sets the maximum number of lines of text for a preview item.
int | GetMaxPreviewLines ()
Gets the maximum number of lines of text for a preview item.
int | GetPreviewLinesCount (CDC *pDC, CRect &rcText, const CString &strText)
Calculates the number of lines required to draw a specified preview text string, taking into account the maximum number of lines of text for a preview item.
BOOL | IsGridVisible (BOOL bVertical) const
Determines the visibility of specified grid lines.
BOOL | IsGridVisible (XTPGridOrientation orientation) const
Determines the visibility of specified grid lines.
void | SetColumnStyle (XTPGridColumnStyle columnStyle)
Sets the header style.
XTPGridColumnStyle | GetColumnStyle () const
Gets the header style.
void | SetColumnOffice2007CustomThemeBaseColor (COLORREF clrBaseColor)
Sets the header's custom theme base color for Office2007 column style.
COLORREF | GetColumnOffice2007CustomThemeBaseColor () const
Gets the header's custom theme base color for Office2007 column style.
void | SetTextFont (LOGFONT &lf)
Creates and sets the default text font.
void | SetCaptionFont (LOGFONT &lf)
Creates and sets the default caption font.
void | SetPreviewIndent (int nLeft, int nTop, int nRight, int nBottom)
Sets the preview item indent.
virtual void | DrawInplaceButton (CDC *pDC, CXTPGridInplaceButton *pButton)
Draws the in-place button of the Grid control.
virtual BOOL | DrawInplaceComboButton (CDC *pDC, CRect *pRc)
Draws the combo button of the Grid control.
virtual BOOL | DrawInplaceExpandButton (CDC *pDC, CRect *pRc)
Draws the expand button of the Grid control.
virtual BOOL | DrawInplaceSpinButton (CDC *pDC, CRect *pRc)
Draws the spin button of the Grid control.
virtual void | DrawTreeStructure (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CRect rcItem, CSize sizeGlyph)
Draws tree elements of the Grid control.
virtual void | DrawItemBitmap (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CRect &rcItem, int nImage)
Draws an item bitmap.
virtual void | DrawItemCaption (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics)
Draws an item caption.
virtual void | DrawRowNumber (CDC *pDC, CRect rcNumber, CXTPGridRow *pRow)
Draws a row number.
virtual void | DrawItemControl (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CXTPGridRecordItemControl *pControl, CRect &rcItem)
Draws an item control.
BOOL | IsFixedRowHeight () const
Determines if the paint manager supports fixed or variable row height.
void | SetFixedRowHeight (BOOL bFixedRowHeight)
Sets if the paint manager supports fixed or variable row height.
BOOL | IsColumnWidthWYSIWYG () const
Determines if the paint manager supports column width WYSIWYG mode.
BOOL | IsLastColumnWidthWYSIWYG () const
Determines if the paint manager supports last column width WYSIWYG mode.
BOOL | IsShowWYSIWYGMarkers () const
Determines if the paint manager shows WYSIWYG page-end markers.
void | ShowWYSIWYGMarkers (BOOL bSet)
Sets if the paint manager shows WYSIWYG page-end markers.
void | SetColumnWidthWYSIWYG (BOOL bColumnWidthWYSIWYG)
Sets if the paint manager supports column width WYSIWYG mode.
void | SetLastColumnWidthWYSIWYG (BOOL bColumnWidthWYSIWYG)
Sets if the paint manager supports last column width WYSIWYG mode.
BOOL | IsFixedInplaceButtonHeight () const
Determines if the paint manager supports fixed or variable in-place button height.
void | SetInplaceButtonHeight (BOOL bFixedInplaceButtonHeight)
Sets if the paint manager supports fixed or variable in-place button height.
int | GetFreezeColsDividerStyle () const
Gets the style of the freeze columns divider line.
void | SetFreezeColsDividerStyle (int nStyle)
Sets the style for the freeze columns divider line.
virtual BOOL | OnDrawAction (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs)
Override this method to perform custom activities for the item before processing it.
virtual void | DrawNoGroupByText (CDC *pDC, CRect rcItem)
Draws the "No items" text message in the Group By area when there are no items inside it.
BOOL | IsDrawGridForEmptySpace () const
Determines if the grid fills empty space after body rows.
void | SetDrawGridForEmptySpace (BOOL bDrawGrid)
Sets if the grid fills empty space after body rows.
BOOL | IsPrintGroupRowIcon () const
Determines if the group row collapse-expand icon is drawn in print mode.
void | SetPrintGroupRowIcon (BOOL bDraw)
Sets if the group row collapse-expand icon is drawn in print mode.
BOOL | IsColumnPlusMinusSign () const
Determines if columns use expand/collapse icons (+/-) or directional arrows.
void | SetColumnPlusMinusSign (BOOL bDraw)
Specifies if columns use expand/collapse icons (+/-) or directional arrows.
virtual int | CalculateRowHeight (CDC *pDC, const CString &strText, int nMaxWidth, BOOL bWordBreak=TRUE)
Calculates the height required for a rectangle bounding multi-line text to draw the multi-line text when the width of the rectangle is fixed.
void | DrawSectionDivider (CDC *pDC, const CRect &rc, XTPGridSectionDividerPosition dividerPosition, XTPGridSectionDividerStyle dividerStyle, CXTPPaintManagerColor dividerColor)
Draws the divider between grid sections (e.g.
int | GetSectionDividerHeight (XTPGridFixedRowsDividerStyle dividerStyle)
Gets the height of the section divider.
BOOL | IsUseDropMarker () const
Determines if a drop marker will be used when dragging and dropping.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Public Attributes

CXTPPaintManagerColor | m_clrGlyph
Header glyph color.
CXTPPaintManagerColor | m_clrGlyphHighlight
Header highlighted glyph color.
CXTPPaintManagerColor | m_clrGlyphExpand
Expand glyph color.
CXTPPaintManagerColor | m_clrGlyphBorder
Expand glyph border color.
CXTPPaintManagerColor | m_clrGlyphContract
Contract glyph color.
- Public Attributes inherited from CXTPGridPaintManager
CXTPFont | m_xtpFontText
Grid items default text.
CXTPFont | m_xtpFontBoldText
Grid items default bold text.
CXTPFont | m_xtpFontCaption
Column header caption font.
CXTPFont | m_xtpFontPreview
Column header caption font.
CXTPGridHyperlinkStyle * | m_pHyperlinkStyle
Style for links.
CXTPGridHyperlinkStyle * | m_pHyperlinkHoverStyle
Style for hovered links.
CXTPPaintManagerColor | m_clrHighlight
Background color of the highlighted row.
CXTPPaintManagerColor | m_clrBoldText
Grid items bold text color.
CXTPPaintManagerColor | m_clrBoldTextHighlight
Grid items bold text highlight color.
CXTPPaintManagerColor | m_clrWindowText
Grid items default text color.
CXTPPaintManagerColor | m_clrHighlightText
Text color of the highlighted text.
CXTPPaintManagerColor | m_clrHeaderControl
Background color of the grid header.
CXTPPaintManagerColor | m_clrCaptionText
Column header text color.
CXTPPaintManagerColor | m_clrCaptionTextPressed
Column header text color when pressed.
CXTPPaintManagerColor | m_clrControlBack
Background color of the control grid area.
CXTPPaintManagerColor | m_clrGroupRowText
Row text color.
CXTPPaintManagerColor | m_clrGroupShadeBack
Group row background color when indentation shade is enabled.
CXTPPaintManagerColor | m_clrGroupShadeText
Group row foreground color when indentation shade is enabled.
CXTPPaintManagerColor | m_clrGroupShadeBorder
Color for group border's shade.
CXTPPaintManagerColor | m_clrGroupBoxBack
Color of group box.
CXTPPaintManagerColor | m_clrControlDark
Dark background color of the Grid control (used on Group By area).
CXTPPaintManagerColor | m_clrControlLightLight
Light background color used for drawing shades (used on column header area).
CXTPPaintManagerColor | m_clrHotDivider
Color of the column hot divider window (two arrows).
CXTPPaintManagerColor | m_clrIndentControl
Color of the tree indentation area.
CXTPPaintManagerColor | m_clrItemShade
Color of the shade on sorted by column items.
CXTPPaintManagerColor | m_clrBtnFace
Standard button face color.
CXTPPaintManagerColor | m_clrBtnText
Standard button text color.
CXTPPaintManagerColor | m_clrPreviewText
Preview text color.
CXTPPaintManagerColor | m_clrSelectedRow
Selected row background color.
CXTPPaintManagerColor | m_clrSelectedRowText
Selected row text color.
CXTPPaintManagerColor | m_clrBtnFacePressed
Standard button face color when pressed.
CXTPPaintManagerColor | m_clrConnector
Header column connector line color.
CXTPPaintManagerColor | m_clrDisableBitmapLightest
The lightest color of bitmap which covers disabled grid.
CXTPPaintManagerColor | m_clrDisableBitmapDarkest
The darkest color of bitmap which covers disabled grid.
CXTPPaintManagerColorGradient | m_grcGradientColumn
Color of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColorGradient | m_grcGradientColumnHot
HotTracking Color of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColorGradient | m_grcGradientColumnPushed
Pushed Color of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColor | m_clrGradientColumnShadow
Bottom shadow of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColor | m_clrGradientColumnSeparator
Separator of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColor | m_crlNoGroupByText
A color for "No items" text in GroupBy area (see m_strNoGroupBy member).
CXTPPaintManagerColor | m_clrFreezeColsDivider
Freeze Columns Divider color.
COLORREF | m_clrColumnOffice2007CustomTheme
Base color for Office2007 custom theme.
COLORREF | m_clrFormulaSum
Color for Formula Sum fields.
COLORREF | m_clrFormulaSubSum
Color for Formula SubSum fields.
COLORREF | m_clrAlternativeBackground
Color for Alternative Row Background.
BOOL | m_bUseAlternativeBackground
TRUE to use Alternative Row Background, FALSE otherwise.
BOOL | m_bAllowMergeCells
TRUE to Allow Merge Cells, FALSE otherwise.
int | m_nTextIndentForGroupRowsWithNoIcon
Specifies Text indent if a group row icon is not used.
int | m_nTreeIndent
Tree indentation.
int | m_nTreeStructureStyle
Tree structure style.
int | m_nTreeTextIndentRowParent
Text indent, in pixels, for rows with children.
int | m_nTreeTextIndentRowChildren
Text indent, in pixels, for rows without children.
int | m_nTreeTextIndent
Text indent, in pixels, for rows that are neither parent nor children.
int | m_nTreeTextIndentGroupRow
Text indent, in pixels, for group rows.
BOOL | m_bGroupRowTextBold
TRUE to draw group rows with bold text.
BOOL | m_bShadeGroupHeadings
TRUE to show the indentation shade, FALSE otherwise.
BOOL | m_bShadeSortColumn
TRUE to show the items shade in the sorted by column, FALSE otherwise.
BOOL | m_bHotTracking
TRUE to allow column hot tracking.
BOOL | m_bInvertColumnOnClick
TRUE to invert column on click.
CString | m_strNoItems
A string which contains customized "No Items" text for displaying in view when there are no visible rows.
CString | m_strSortBy
A string which contains customized "Sort By" text for displaying in tooltip.
CString | m_strIncreasing
A string which contains customized "Increasing" text for displaying in tooltip.
CString | m_strDecreasing
A string which contains customized "Decreasing" text for displaying in tooltip.
CString | m_strNoGroupBy
A string which contains customized "No items" text message for displaying in Group By area when there are no items inside it.
CString | m_strNoFieldsAvailable
A string which contains customized "No Fields Available" text message for displaying in Field Chooser.
CString | m_strExpand
A string which contains customized "Expand" text for displaying in tooltip.
CString | m_strCollapse
A string which contains customized "Collapse" text for displaying in tooltip.
BOOL | m_bHideSelection
TRUE when hiding Grid control's selection by drawing selected items as others, FALSE otherwise.
BOOL | m_bPrintSortTriangle
TRUE to show the sort triangle in printout.
BOOL | m_bRevertAlignment
TRUE to revert column alignments.
BOOL | m_bUseEditTextAlignment
TRUE to automatically apply edit alignment using column alignment.
BOOL | m_bShowLockIcon
TRUE to show the lock icon, FALSE to hide.
BOOL | m_bUseShellIcon
TRUE to use the shell icon, FALSE otherwise.
int | m_iRecOrRowStart
Start position in numbering (0 or 1 or something user want).
BOOL | m_bRecOrRowNum
TRUE to display record number if support mode is used, FALSE to display row number.
BOOL | m_bMakeUpper
TRUE to display column header and group row text in all caps.
XTPGridTreeStructureStyle | m_treeStructureStyle
Tree structure style.
CRect | m_rcPreviewIndent
Preview indentation.
int | m_nFixedColumnsIndent
Fixed Column total width.
BOOL | m_bMoveScrollbarOnFixedColumnsIndent
Move Scrollbar right follow FixedColumnsIndent.
BOOL | m_bThemedInplaceButtons
Draw in-place buttons using current theme settings.
BOOL | m_bBaseTreeIndent
TRUE to add Extra Tree indentation to cover initial TreeColumn.
CUIntArray | m_arStartCol
Start column in each virtual page.
int | m_PrintPageWidth
Width of print page (run-time)
BOOL | m_bPrintVirtualPageNumber
TRUE to print horizontal page number.
BOOL | m_bPrintPageRectangle
TRUE to draw rectangle around page.
int | m_RecordNumberWidth
Column width for row/record numbers.
BOOL | m_bForceDynamicMarkupForCell
TRUE if use Markup for Grid Record Item.
BOOL | m_bForceShowDropMarker
TRUE if Force Show Drop Marker.
BOOL | m_bShowNonActiveInPlaceButton
TRUE if use Show Non-Active In-Place Button (Combo, Expand, Spin).
BOOL | m_bPrintWatermark
TRUE to print watermark.
BOOL | m_bUseGroupRowSelectionState
TRUE if use GroupSelectionState Glyph.
BOOL | m_bForceShowTooltip
TRUE if use show tooltip for any cell width case.
BOOL | m_bCleanTooltip
TRUE if use show tooltip without markup.
BOOL | m_bGrayIfDisable
TRUE is disable draw in gray (standard behavior).
int | m_nRowHeightDefault
The default row height.
BOOL | m_bCompactText
TRUE to ignore Icon for Narrow column to show more text.
BOOL | m_bUseDropMarker
FALSE to not draw drop marked when dragging/dropping, TRUE by default.
BOOL | m_bSortTriangleOffsetFromRight
Offset of sort triangle.
int | m_nTreeColumnLineLength
This is the extra line length to apply to tree column lines if there is no expand button.
int | m_nBaseParentRecordIndent
This is initial number of pixels a parent node will be indented when in a group.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Member Functions inherited from CXTPGridPaintManager
virtual void | DrawTextLine (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nFlag, int &nCharCounter, int &nHyperlinkCounter)
Draws a line of text with respect to the drawing rectangle.
virtual int | DrawString (int *pnCurrDrawPos, CDC *pDC, const CString &strDraw, CRect rcDraw, UINT nFormat)
Draw a simple string into rectangle.
virtual void | DrawGridPattern (CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush)
Generates a custom grid pattern if necessary.
virtual void | DrawGridPattern (CDC *pDC, CXTPBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush)
Generates a custom grid pattern if necessary.
virtual void | DrawGridPattern (CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr)
Generates a custom grid pattern.
virtual void | DrawInplaceButtonFrame (CDC *pDC, CXTPGridInplaceButton *pButton)
Draws the in-place button frame.
virtual BOOL | DrawInplaceButtonIcon (CDC *pDC, CXTPGridInplaceButton *pButton)
Draws the in-place button icon.
virtual int | CalcColumnHeight (CDC *pDC, CXTPGridColumn *pColumn, int nTotalWidth=0)
Calculates the optimal height for a specified column.
virtual void | DrawMultiLineText (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, BOOL bWordBreak=TRUE)
Draws multi-line text.
virtual void | DrawSingleLineText (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nStartPos, int nEndPos, int nActualWidth)
Draws single-line text.
virtual int | DrawLink (int *pnCurrDrawPos, XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CXTPGridHyperlink *pHyperlink, CString strText, CRect rcLink, int nFlag, BOOL bTrim=FALSE)
Draws a hyperlink string using hyperlink text settings (i.e.
- Protected Attributes inherited from CXTPGridPaintManager
int | m_nRowHeight
Grid row default height.
int | m_nHeaderHeight
Column header height.
int | m_nFooterHeight
Column footer height.
int | m_nGroupGridLineHeight
The height of the group grid line.
CXTPImageManager * | m_pGlyphs
An additional image list for the Grid control.
BOOL | m_bIsPreviewMode
TRUE to show the item preview, FALSE to hide.
int | m_nResizingWidth
The width of the column resizing marker area.
int | m_nMaxPreviewLines
Restrict maximum lines for preview text.
CSize | m_szGlyph
Glyph size.
CXTPBrush | m_xtpBrushTreeStructure
Brush to draw tree nodes.
CXTPBrush | m_xtpBrushGroupGridLineStyle
Brush to draw group row grid lines.
int | m_nFreezeColsDividerStyle
A set of flags from XTPGridFreezeColsDividerStyle.
BOOL | m_bFixedRowHeight
TRUE if fixed rows used.
BOOL | m_bColumnWidthWYSIWYG
TRUE if columns width WYSIWYG mode used.
BOOL | m_bShowWYSIWYGMarkers
TRUE if in non-print mode header show red page-end markers.
BOOL | m_bLastColumnWidthWYSIWYG
TRUE if last column width WYSIWYG mode used.
BOOL | m_bDrawGridForEmptySpace
TRUE if grid fills the empty space (if any) after the body rows.
BOOL | m_bPrintGroupRowIcon
TRUE if printout draw collapse-expand icon for group row.
BOOL | m_bColumnPlusMinusSign
TRUE if expand/collapse icons are used, FALSE if directional arrows are used.
BOOL | m_bFixedInplaceButtonHeight
TRUE if fixed in-place button height is used.
XTPGridGridStyle | m_nGroupGridLineStyle
Current style for group row grid lines.
XTPGridColumnStyle | m_columnStyle
Column drawing style.
CXTPWinThemeWrapper * | m_themeHeader
Header theme wrapper.
CXTPWinThemeWrapper * | m_themeButton
In-place button theme wrapper.
CXTPWinThemeWrapper * | m_themeCombo
Combo box in-place button theme wrapper.
CXTPWinThemeWrapper * | m_themeSpin
Spin in-place button theme wrapper.
CXTPGridControl * | m_pControl
Pointer to the Grid control object.
CXTPMarkupUIElement * | m_pMarkupUIElement_NoGroupBy
The no group by markup UI element.
CString | m_strMarkupUIElement_NoGroupBy
The no group by markup UI element string.
CXTPBrush | m_xtpBrushVeriticalGrid
Brush to draw vertical grid lines.
CXTPBrush | m_xtpBrushHorizontalGrid
Brush to draw horizontal grid lines.
XTPGridGridStyle m_nGridLineStylePreviousV
Previous style for vertical grid lines.
XTPGridGridStyle m_nGridLineStylePreviousH
Previous style for horizontal grid lines.

Detailed Description

CXTPGridThemeOffice2013 is a CXTPGridPaintManager derived class that represents an Office 2013 style theme.

Member Function Documentation

◆ DrawCollapsedBitmap()

virtual CSize DrawCollapsedBitmap | ( | CDC * | pDC,
 |  | const CXTPGridRow * | pRow,
 |  | CRect & | rcBitmap )
 virtual

Draws a collapsed bitmap.

Parameters
pDC | Pointer to the used device context.
pRow | Pointer to a grid row.
rcBitmap | Reference to bitmap area rectangle coordinates.
Returns
The size of the drawn bitmap.

Reimplemented from CXTPGridPaintManager.

◆ DrawColumnBackground()

virtual void DrawColumnBackground | ( | CDC * | pDC,
 |  | CXTPGridColumn * | pColumn,
 |  | CRect | rcColumn,
 |  | BOOL & | bColumnPressed,
 |  | BOOL & | bDraggingFromHeader,
 |  | CXTPGridHeader * | pHeader = NULL )
 virtual

This method is called to draw the background of a column using the current column style.

Parameters
pDC | Pointer to the used device context.
pColumn | Pointer to the column whose background must be drawn.
rcColumn | Bounding rectangle of the column.
bColumnPressed | TRUE if the column is pressed by the user.
bDraggingFromHeader | TRUE if the column is being dragged from the header area.
pHeader | Pointer to the header that the column belongs to.

Reimplemented from CXTPGridPaintManager.

◆ DrawColumnText()

virtual void DrawColumnText | ( | CDC * | pDC,
 |  | CRect | rcText,
 |  | CString | strCaption,
 |  | int | nHeaderAlignment,
 |  | BOOL | bIsHeader,
 |  | BOOL | bColumnPressed )
 virtual

Draws text for the column header.

Parameters
pDC | Pointer to the used device context.
rcText | Size and position of the text to render.
strCaption | NULL-terminated string representing the caption text.
nHeaderAlignment | DT_ text alignment flags.
bIsHeader | TRUE if the column is to be rendered for the header.
bColumnPressed | TRUE if the column is pressed by the user.

Reimplemented from CXTPGridPaintManager.

◆ DrawFocusedRow()

virtual void DrawFocusedRow | ( | CDC * | pDC,
 |  | CRect | rcRow )
 virtual

Draws focused rows.

Parameters
pDC | Pointer to the used device context.
rcRow | Area rectangle coordinates.

Example:

CRect rcClient(GetParent()->GetClientRect());
CXTPGridHeader* pHeader = m_pColumns->GetGridHeader();
CXTPGridPaintManager* pPaintManager = m_pControl->GetPaintManager();
GetPaintManager()->DrawResizingRect(pDC, pHeader, rcClient);

Reimplemented from CXTPGridPaintManager.

◆ DrawGroupRow()

virtual void DrawGroupRow | ( | CDC * | pDC,
 |  | CXTPGridGroupRow * | pRow,
 |  | CRect | rcRow,
 |  | XTP_GRIDRECORDITEM_METRICS * | pMetrics )
 virtual

Draws a group row.

Parameters
pDC | Pointer to the used device context.
pRow | Pointer to the group row.
rcRow | Group row area rectangle coordinates.
pMetrics | Pointer to a metrics structure.

Example:

CXTPGridPaintManager* pPaintManager = m_pControl->GetPaintManager();
pDC->SetBkMode(TRANSPARENT);
pPaintManager->DrawGroupRow(pDC, this, rcRow);

Reimplemented from CXTPGridPaintManager.

◆ DrawTriangle()

virtual void DrawTriangle | ( | CDC * | pDC,
 |  | CRect | rcTriangle,
 |  | BOOL | bToDown,
 |  | BOOL | bDraggingFromHeader,
 |  | int | nShadowWidth,
 |  | BOOL | bColumnPressed )
 virtual

Draws a triangle that shows the sort order of the column.

Parameters
pDC | Pointer to the used device context.
rcTriangle | Triangle area rectangle coordinates.
bToDown | TRUE to turn the top of the triangle downward, FALSE to turn the top of the triangle upward.
bDraggingFromHeader | TRUE if the column is being dragged from the header area.
nShadowWidth | Size, in pixels, of the shadow to draw under the triangle image, or 0 to disable the shadow; the default value for this parameter is 0.
bColumnPressed | TRUE if the column is pressed by the user.

This function is used to draw a triangle image on the header of the column that is sorted. The triangle represents the direction of the sort: ascending or descending. The size of the triangle depends on the rectangle area provided.

Example:

// draw ascendant triangle
CRect rcTriangle;
rcTriangle.CopyRect(rcHeader);
rcTriangle.DeflateRect(40, 5, 5, 5);
DrawTriangle(pDC, rcTriangle, TRUE);

// draw descendant triangle
CRect rcTriangle;
rcTriangle.CopyRect(rcHeader);
rcTriangle.DeflateRect(40, 5, 5, 5);
DrawTriangle(pDC, rcTriangle, FALSE);

Reimplemented from CXTPGridPaintManager.

◆ FillGroupRowMetrics()

virtual void FillGroupRowMetrics | ( | CXTPGridGroupRow * | pRow,
 |  | XTP_GRIDRECORDITEM_METRICS * | pMetrics,
 |  | BOOL | bPrinting )
 virtual

Fills the font and color members of the metrics structure for a specified group row.

Parameters
pRow | Pointer to the group row.
pMetrics | Pointer to the metrics structure to be filled.
bPrinting | TRUE if printing mode is enabled.

Reimplemented from CXTPGridPaintManager.

◆ GetRowHeight() [1/2]

virtual int GetRowHeight | ( | CDC * | pDC,
 |  | CXTPGridRow * | pRow )
 virtual

Retrieves the default row height for print mode (i.e.

the height of the default rectangle where the row's items will be drawn).

Parameters
pDC | Pointer to the used device context.
pRow | Pointer to a grid row.
Returns
The default row height for print mode.

Example:

int nRowHeight = GetRowHeight(pDC, pRow)

Reimplemented from CXTPGridPaintManager.

◆ GetRowHeight() [2/2]

virtual int GetRowHeight | ( | CDC * | pDC,
 |  | CXTPGridRow * | pRow,
 |  | int | nTotalWidth )
 virtual

Retrieves the default row height for print mode (i.e.

the height of the default rectangle where the row's items will be drawn).

Parameters
pDC | Pointer to the used device context.
pRow | Pointer to a grid row.
nTotalWidth | Width of the row.
Returns
The default row height for print mode.

Example:

int nRowHeight = GetRowHeight(pDC, pRow)

Reimplemented from CXTPGridPaintManager.

The documentation for this class was generated from the following file:
  • XTPGridThemeOffice2013.h


Toolkit Pro: CXTPGridThemeOfficeXP Class Reference

Public Member Functions | List of all members
CXTPGridThemeOfficeXP Class Reference

CXTPGridThemeOfficeXP is a CXTPGridPaintManager derived class that represents an Office XP style theme. More...

Inheritance diagram for CXTPGridThemeOfficeXP:
[legend]

Public Member Functions

CXTPGridThemeOfficeXP ()
Default paint manager constructor, handles properties initialization.
virtual void | DrawColumnBackground (CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, BOOL &bColumnPressed, BOOL &bDraggingFromHeader, CXTPGridHeader *pHeader=NULL)
This method is called to draw the background of a column using the current column style.
- Public Member Functions inherited from CXTPGridPaintManager
CXTPGridPaintManager ()
Default CXTPGridPaintManager constructor, handles properties initialization.
virtual | ~CXTPGridPaintManager ()
Default CXTPGridPaintManager destructor, handles member items deallocation.
virtual void | SetGridControl (CXTPGridControl *pControl)
Sets the associated Grid control for the paint manager.
virtual void | LoadGlyphs ()
Loads the default images used by the Grid control.
virtual void | RefreshMetrics ()
Initializes all drawings defaults (fonts, colors, etc.).
virtual int | GetRowHeight (CDC *pDC, CXTPGridRow *pRow)
Retrieves the default row height for print mode (i.e.
virtual int | GetRowHeight (CDC *pDC, CXTPGridRow *pRow, int nTotalWidth)
Retrieves the default row height for print mode (i.e.
int | GetRowHeightEx (CDC *pDC, CXTPGridRow *pRow, int nTotalWidth, const BOOL firstLevel=TRUE)
Retrieves the default row height for print mode (i.e.
int | GetItemHeight (XTP_GRIDRECORDITEM_DRAWARGS &drawArgs, int nWidth)
Retrieves the height of a record item for a given width.
BOOL | FindRowAdjacentToMergedEx (const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, int &nAdjRowIndex, BOOL bUpward)
Searches the topmost or bottommost row depending on the height of the current row.
int | FindRowAdjacentToMerged (const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, BOOL bUpward)
Wrapper for the FindRowAdjacentToMergedEx method.
int | RecalcTotalHightOfMergedRows (CXTPGridColumns *pColumns, CDC *pDC, CXTPGridRow *pRow, int nRowHeight, int nTotalWidth)
Recalculates row height according to the height of merged items.
virtual int | GetPreviewItemHeight (CDC *pDC, CXTPGridRow *pRow, int nWidth, int nHeight)
Retrieves the height of a preview item for print mode.
virtual int | GetHeaderHeight ()
Gets the column header height.
virtual int | GetHeaderHeight (CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0)
Calculates the optimal header height.
virtual void | SetHeaderHeight (int nHeight)
Sets the column header height.
virtual int | GetFooterHeight (CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0)
Calculates the optimal footer height.
virtual COLORREF | GetControlBackColor (CXTPGridControl *pControl)
Retrieves the parent Grid control's background color.
virtual void | FillRow (CDC *pDC, CXTPGridRow *pRow, CRect rcRow)
Fills a specified row with its background color.
virtual void | DrawGrid (CDC *pDC, XTPGridOrientation orientation, CRect rcGrid)
Draws a grid for the control.
virtual void | DrawFreezeColsDivider (CDC *pDC, const CRect &rc, CXTPGridControl *pControl, CXTPGridRow *pRow=NULL)
Draws a freeze column divider.
virtual void | DrawVerticalTimeLineMarker (CDC *pDC, int xPos, CXTPGridControl *pControl, COLORREF color=RGB(0, 255, 0))
Draws a vertical timeline marker.
virtual void | DrawGroupRow (CDC *pDC, CXTPGridGroupRow *pRow, CRect rcRow, XTP_GRIDRECORDITEM_METRICS *pMetrics)
Draws a group row.
virtual void | FillGroupRowMetrics (CXTPGridGroupRow *pRow, XTP_GRIDRECORDITEM_METRICS *pMetrics, BOOL bPrinting)
Fills the font and color members of the metrics structure for a specified group row.
virtual void | FillIndent (CDC *pDC, CRect rcRow)
Fills an indent area by its background.
virtual void | FillItemShade (CDC *pDC, CRect rcItem)
Fills an item shade by its background if necessary.
virtual void | FillHeaderControl (CDC *pDC, CRect rcHeader)
Fills a column header control area by its background.
virtual void | FillFooter (CDC *pDC, CRect rcFooter)
Fills a column footer control area by its background.
virtual void | DrawColumnText (CDC *pDC, CRect rcText, CString strCaption, int nHeaderAlignment, BOOL bIsHeader, BOOL bColumnPressed)
Draws text for the column header.
virtual void | DrawColumn (CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn, BOOL bDrawExternal=FALSE, int nShadowWidth=0)
Draws a column header with all related attributes (sort order, icon, etc.).
virtual void | DrawColumnFooterDivider (CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn)
Draws the column footer divider.
virtual void | DrawColumnFooter (CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn)
Draws the column footer with all related attributes (e.g.
virtual BOOL | IsColumHotTrackingEnabled () const
Determines if hot tracking is enabled for the current column style.
virtual void | DrawFocusedRow (CDC *pDC, CRect rcRow)
Draws focused rows.
virtual void | FillGroupByControl (CDC *pDC, CRect &rcGroupBy)
Draws the Group By box.
CXTPImageManager * | GetGlyphs () const
Gets a pointer to the additional image list with glyphs.
void | DrawHorizontalLine (CDC *pDC, int xPos, int yPos, int cx, COLORREF clr)
Draws a horizontal line.
void | DrawVerticalLine (CDC *pDC, int xPos, int yPos, int cy, COLORREF clr)
Draws a vertical line.
virtual void | DrawTriangle (CDC *pDC, CRect rcTriangle, BOOL bToDown, BOOL bDraggingFromHeader, int nShadowWidth, BOOL bColumnPressed)
Draws a triangle that shows the sort order of the column.
void | DrawConnector (CDC *pDC, CPoint ptFrom, CPoint ptTo)
Draws a column connector for the Group By box.
virtual CSize | DrawCollapsedBitmap (CDC *pDC, const CXTPGridRow *pRow, CRect &rcBitmap)
Draws a collapsed bitmap.
virtual int | DrawBitmap (CDC *pDC, CXTPGridControl *pControl, CRect rcColumn, int iImage)
Draws a bitmap.
virtual int | DrawColumnIcon (CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, CRect rcIcon, int iIcon)
Draws an icon for a column.
virtual CSize | DrawGlyph (CDC *pDC, CRect rcColumn, int iImage)
Draws the standard glyphs of the Grid control.
virtual CSize | DrawShellIcon (CDC *pDC, CRect rcColumn, int iImage)
Draws the shell icon.
void | EnablePreviewMode (BOOL bIsPreviewMode)
Enables/disables preview mode for the control.
BOOL | IsPreviewMode () const
Determines if preview mode is enabled/disabled for the control.
CFont * | GetTextFont ()
Gets the default text font used for control items.
int | SetMaxPreviewLines (int nMaxLines)
Sets the maximum number of lines of text for a preview item.
int | GetMaxPreviewLines ()
Gets the maximum number of lines of text for a preview item.
int | GetPreviewLinesCount (CDC *pDC, CRect &rcText, const CString &strText)
Calculates the number of lines required to draw a specified preview text string, taking into account the maximum number of lines of text for a preview item.
BOOL | IsGridVisible (BOOL bVertical) const
Determines the visibility of specified grid lines.
BOOL | IsGridVisible (XTPGridOrientation orientation) const
Determines the visibility of specified grid lines.
void | SetColumnStyle (XTPGridColumnStyle columnStyle)
Sets the header style.
XTPGridColumnStyle | GetColumnStyle () const
Gets the header style.
void | SetColumnOffice2007CustomThemeBaseColor (COLORREF clrBaseColor)
Sets the header's custom theme base color for Office2007 column style.
COLORREF | GetColumnOffice2007CustomThemeBaseColor () const
Gets the header's custom theme base color for Office2007 column style.
void | SetTextFont (LOGFONT &lf)
Creates and sets the default text font.
void | SetCaptionFont (LOGFONT &lf)
Creates and sets the default caption font.
void | SetPreviewIndent (int nLeft, int nTop, int nRight, int nBottom)
Sets the preview item indent.
virtual void | DrawInplaceButton (CDC *pDC, CXTPGridInplaceButton *pButton)
Draws the in-place button of the Grid control.
virtual BOOL | DrawInplaceComboButton (CDC *pDC, CRect *pRc)
Draws the combo button of the Grid control.
virtual BOOL | DrawInplaceExpandButton (CDC *pDC, CRect *pRc)
Draws the expand button of the Grid control.
virtual BOOL | DrawInplaceSpinButton (CDC *pDC, CRect *pRc)
Draws the spin button of the Grid control.
virtual void | DrawTreeStructure (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CRect rcItem, CSize sizeGlyph)
Draws tree elements of the Grid control.
virtual void | DrawItemBitmap (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CRect &rcItem, int nImage)
Draws an item bitmap.
virtual void | DrawItemCaption (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics)
Draws an item caption.
virtual void | DrawRowNumber (CDC *pDC, CRect rcNumber, CXTPGridRow *pRow)
Draws a row number.
virtual void | DrawItemControl (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CXTPGridRecordItemControl *pControl, CRect &rcItem)
Draws an item control.
BOOL | IsFixedRowHeight () const
Determines if the paint manager supports fixed or variable row height.
void | SetFixedRowHeight (BOOL bFixedRowHeight)
Sets if the paint manager supports fixed or variable row height.
BOOL | IsColumnWidthWYSIWYG () const
Determines if the paint manager supports column width WYSIWYG mode.
BOOL | IsLastColumnWidthWYSIWYG () const
Determines if the paint manager supports last column width WYSIWYG mode.
BOOL | IsShowWYSIWYGMarkers () const
Determines if the paint manager shows WYSIWYG page-end markers.
void | ShowWYSIWYGMarkers (BOOL bSet)
Sets if the paint manager shows WYSIWYG page-end markers.
void | SetColumnWidthWYSIWYG (BOOL bColumnWidthWYSIWYG)
Sets if the paint manager supports column width WYSIWYG mode.
void | SetLastColumnWidthWYSIWYG (BOOL bColumnWidthWYSIWYG)
Sets if the paint manager supports last column width WYSIWYG mode.
BOOL | IsFixedInplaceButtonHeight () const
Determines if the paint manager supports fixed or variable in-place button height.
void | SetInplaceButtonHeight (BOOL bFixedInplaceButtonHeight)
Sets if the paint manager supports fixed or variable in-place button height.
int | GetFreezeColsDividerStyle () const
Gets the style of the freeze columns divider line.
void | SetFreezeColsDividerStyle (int nStyle)
Sets the style for the freeze columns divider line.
virtual BOOL | OnDrawAction (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs)
Override this method to perform custom activities for the item before processing it.
virtual void | DrawNoGroupByText (CDC *pDC, CRect rcItem)
Draws the "No items" text message in the Group By area when there are no items inside it.
BOOL | IsDrawGridForEmptySpace () const
Determines if the grid fills empty space after body rows.
void | SetDrawGridForEmptySpace (BOOL bDrawGrid)
Sets if the grid fills empty space after body rows.
BOOL | IsPrintGroupRowIcon () const
Determines if the group row collapse-expand icon is drawn in print mode.
void | SetPrintGroupRowIcon (BOOL bDraw)
Sets if the group row collapse-expand icon is drawn in print mode.
BOOL | IsColumnPlusMinusSign () const
Determines if columns use expand/collapse icons (+/-) or directional arrows.
void | SetColumnPlusMinusSign (BOOL bDraw)
Specifies if columns use expand/collapse icons (+/-) or directional arrows.
virtual int | CalculateRowHeight (CDC *pDC, const CString &strText, int nMaxWidth, BOOL bWordBreak=TRUE)
Calculates the height required for a rectangle bounding multi-line text to draw the multi-line text when the width of the rectangle is fixed.
void | DrawSectionDivider (CDC *pDC, const CRect &rc, XTPGridSectionDividerPosition dividerPosition, XTPGridSectionDividerStyle dividerStyle, CXTPPaintManagerColor dividerColor)
Draws the divider between grid sections (e.g.
int | GetSectionDividerHeight (XTPGridFixedRowsDividerStyle dividerStyle)
Gets the height of the section divider.
BOOL | IsUseDropMarker () const
Determines if a drop marker will be used when dragging and dropping.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPGridPaintManager
CXTPFont | m_xtpFontText
Grid items default text.
CXTPFont | m_xtpFontBoldText
Grid items default bold text.
CXTPFont | m_xtpFontCaption
Column header caption font.
CXTPFont | m_xtpFontPreview
Column header caption font.
CXTPGridHyperlinkStyle * | m_pHyperlinkStyle
Style for links.
CXTPGridHyperlinkStyle * | m_pHyperlinkHoverStyle
Style for hovered links.
CXTPPaintManagerColor | m_clrHighlight
Background color of the highlighted row.
CXTPPaintManagerColor | m_clrBoldText
Grid items bold text color.
CXTPPaintManagerColor | m_clrBoldTextHighlight
Grid items bold text highlight color.
CXTPPaintManagerColor | m_clrWindowText
Grid items default text color.
CXTPPaintManagerColor | m_clrHighlightText
Text color of the highlighted text.
CXTPPaintManagerColor | m_clrHeaderControl
Background color of the grid header.
CXTPPaintManagerColor | m_clrCaptionText
Column header text color.
CXTPPaintManagerColor | m_clrCaptionTextPressed
Column header text color when pressed.
CXTPPaintManagerColor | m_clrControlBack
Background color of the control grid area.
CXTPPaintManagerColor | m_clrGroupRowText
Row text color.
CXTPPaintManagerColor | m_clrGroupShadeBack
Group row background color when indentation shade is enabled.
CXTPPaintManagerColor | m_clrGroupShadeText
Group row foreground color when indentation shade is enabled.
CXTPPaintManagerColor | m_clrGroupShadeBorder
Color for group border's shade.
CXTPPaintManagerColor | m_clrGroupBoxBack
Color of group box.
CXTPPaintManagerColor | m_clrControlDark
Dark background color of the Grid control (used on Group By area).
CXTPPaintManagerColor | m_clrControlLightLight
Light background color used for drawing shades (used on column header area).
CXTPPaintManagerColor | m_clrHotDivider
Color of the column hot divider window (two arrows).
CXTPPaintManagerColor | m_clrIndentControl
Color of the tree indentation area.
CXTPPaintManagerColor | m_clrItemShade
Color of the shade on sorted by column items.
CXTPPaintManagerColor | m_clrBtnFace
Standard button face color.
CXTPPaintManagerColor | m_clrBtnText
Standard button text color.
CXTPPaintManagerColor | m_clrPreviewText
Preview text color.
CXTPPaintManagerColor | m_clrSelectedRow
Selected row background color.
CXTPPaintManagerColor | m_clrSelectedRowText
Selected row text color.
CXTPPaintManagerColor | m_clrBtnFacePressed
Standard button face color when pressed.
CXTPPaintManagerColor | m_clrConnector
Header column connector line color.
CXTPPaintManagerColor | m_clrDisableBitmapLightest
The lightest color of bitmap which covers disabled grid.
CXTPPaintManagerColor | m_clrDisableBitmapDarkest
The darkest color of bitmap which covers disabled grid.
CXTPPaintManagerColorGradient | m_grcGradientColumn
Color of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColorGradient | m_grcGradientColumnHot
HotTracking Color of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColorGradient | m_grcGradientColumnPushed
Pushed Color of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColor | m_clrGradientColumnShadow
Bottom shadow of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColor | m_clrGradientColumnSeparator
Separator of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColor | m_crlNoGroupByText
A color for "No items" text in GroupBy area (see m_strNoGroupBy member).
CXTPPaintManagerColor | m_clrFreezeColsDivider
Freeze Columns Divider color.
COLORREF | m_clrColumnOffice2007CustomTheme
Base color for Office2007 custom theme.
COLORREF | m_clrFormulaSum
Color for Formula Sum fields.
COLORREF | m_clrFormulaSubSum
Color for Formula SubSum fields.
COLORREF | m_clrAlternativeBackground
Color for Alternative Row Background.
BOOL | m_bUseAlternativeBackground
TRUE to use Alternative Row Background, FALSE otherwise.
BOOL | m_bAllowMergeCells
TRUE to Allow Merge Cells, FALSE otherwise.
int | m_nTextIndentForGroupRowsWithNoIcon
Specifies Text indent if a group row icon is not used.
int | m_nTreeIndent
Tree indentation.
int | m_nTreeStructureStyle
Tree structure style.
int | m_nTreeTextIndentRowParent
Text indent, in pixels, for rows with children.
int | m_nTreeTextIndentRowChildren
Text indent, in pixels, for rows without children.
int | m_nTreeTextIndent
Text indent, in pixels, for rows that are neither parent nor children.
int | m_nTreeTextIndentGroupRow
Text indent, in pixels, for group rows.
BOOL | m_bGroupRowTextBold
TRUE to draw group rows with bold text.
BOOL | m_bShadeGroupHeadings
TRUE to show the indentation shade, FALSE otherwise.
BOOL | m_bShadeSortColumn
TRUE to show the items shade in the sorted by column, FALSE otherwise.
BOOL | m_bHotTracking
TRUE to allow column hot tracking.
BOOL | m_bInvertColumnOnClick
TRUE to invert column on click.
CString | m_strNoItems
A string which contains customized "No Items" text for displaying in view when there are no visible rows.
CString | m_strSortBy
A string which contains customized "Sort By" text for displaying in tooltip.
CString | m_strIncreasing
A string which contains customized "Increasing" text for displaying in tooltip.
CString | m_strDecreasing
A string which contains customized "Decreasing" text for displaying in tooltip.
CString | m_strNoGroupBy
A string which contains customized "No items" text message for displaying in Group By area when there are no items inside it.
CString | m_strNoFieldsAvailable
A string which contains customized "No Fields Available" text message for displaying in Field Chooser.
CString | m_strExpand
A string which contains customized "Expand" text for displaying in tooltip.
CString | m_strCollapse
A string which contains customized "Collapse" text for displaying in tooltip.
BOOL | m_bHideSelection
TRUE when hiding Grid control's selection by drawing selected items as others, FALSE otherwise.
BOOL | m_bPrintSortTriangle
TRUE to show the sort triangle in printout.
BOOL | m_bRevertAlignment
TRUE to revert column alignments.
BOOL | m_bUseEditTextAlignment
TRUE to automatically apply edit alignment using column alignment.
BOOL | m_bShowLockIcon
TRUE to show the lock icon, FALSE to hide.
BOOL | m_bUseShellIcon
TRUE to use the shell icon, FALSE otherwise.
int | m_iRecOrRowStart
Start position in numbering (0 or 1 or something user want).
BOOL | m_bRecOrRowNum
TRUE to display record number if support mode is used, FALSE to display row number.
BOOL | m_bMakeUpper
TRUE to display column header and group row text in all caps.
XTPGridTreeStructureStyle | m_treeStructureStyle
Tree structure style.
CRect | m_rcPreviewIndent
Preview indentation.
int | m_nFixedColumnsIndent
Fixed Column total width.
BOOL | m_bMoveScrollbarOnFixedColumnsIndent
Move Scrollbar right follow FixedColumnsIndent.
BOOL | m_bThemedInplaceButtons
Draw in-place buttons using current theme settings.
BOOL | m_bBaseTreeIndent
TRUE to add Extra Tree indentation to cover initial TreeColumn.
CUIntArray | m_arStartCol
Start column in each virtual page.
int | m_PrintPageWidth
Width of print page (run-time)
BOOL | m_bPrintVirtualPageNumber
TRUE to print horizontal page number.
BOOL | m_bPrintPageRectangle
TRUE to draw rectangle around page.
int | m_RecordNumberWidth
Column width for row/record numbers.
BOOL | m_bForceDynamicMarkupForCell
TRUE if use Markup for Grid Record Item.
BOOL | m_bForceShowDropMarker
TRUE if Force Show Drop Marker.
BOOL | m_bShowNonActiveInPlaceButton
TRUE if use Show Non-Active In-Place Button (Combo, Expand, Spin).
BOOL | m_bPrintWatermark
TRUE to print watermark.
BOOL | m_bUseGroupRowSelectionState
TRUE if use GroupSelectionState Glyph.
BOOL | m_bForceShowTooltip
TRUE if use show tooltip for any cell width case.
BOOL | m_bCleanTooltip
TRUE if use show tooltip without markup.
BOOL | m_bGrayIfDisable
TRUE is disable draw in gray (standard behavior).
int | m_nRowHeightDefault
The default row height.
BOOL | m_bCompactText
TRUE to ignore Icon for Narrow column to show more text.
BOOL | m_bUseDropMarker
FALSE to not draw drop marked when dragging/dropping, TRUE by default.
BOOL | m_bSortTriangleOffsetFromRight
Offset of sort triangle.
int | m_nTreeColumnLineLength
This is the extra line length to apply to tree column lines if there is no expand button.
int | m_nBaseParentRecordIndent
This is initial number of pixels a parent node will be indented when in a group.
- Protected Member Functions inherited from CXTPGridPaintManager
virtual void | DrawTextLine (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nFlag, int &nCharCounter, int &nHyperlinkCounter)
Draws a line of text with respect to the drawing rectangle.
virtual int | DrawString (int *pnCurrDrawPos, CDC *pDC, const CString &strDraw, CRect rcDraw, UINT nFormat)
Draw a simple string into rectangle.
virtual void | DrawGridPattern (CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush)
Generates a custom grid pattern if necessary.
virtual void | DrawGridPattern (CDC *pDC, CXTPBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush)
Generates a custom grid pattern if necessary.
virtual void | DrawGridPattern (CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr)
Generates a custom grid pattern.
virtual void | DrawInplaceButtonFrame (CDC *pDC, CXTPGridInplaceButton *pButton)
Draws the in-place button frame.
virtual BOOL | DrawInplaceButtonIcon (CDC *pDC, CXTPGridInplaceButton *pButton)
Draws the in-place button icon.
virtual int | CalcColumnHeight (CDC *pDC, CXTPGridColumn *pColumn, int nTotalWidth=0)
Calculates the optimal height for a specified column.
virtual void | DrawMultiLineText (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, BOOL bWordBreak=TRUE)
Draws multi-line text.
virtual void | DrawSingleLineText (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nStartPos, int nEndPos, int nActualWidth)
Draws single-line text.
virtual int | DrawLink (int *pnCurrDrawPos, XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CXTPGridHyperlink *pHyperlink, CString strText, CRect rcLink, int nFlag, BOOL bTrim=FALSE)
Draws a hyperlink string using hyperlink text settings (i.e.
- Protected Attributes inherited from CXTPGridPaintManager
int | m_nRowHeight
Grid row default height.
int | m_nHeaderHeight
Column header height.
int | m_nFooterHeight
Column footer height.
int | m_nGroupGridLineHeight
The height of the group grid line.
CXTPImageManager * | m_pGlyphs
An additional image list for the Grid control.
BOOL | m_bIsPreviewMode
TRUE to show the item preview, FALSE to hide.
int | m_nResizingWidth
The width of the column resizing marker area.
int | m_nMaxPreviewLines
Restrict maximum lines for preview text.
CSize | m_szGlyph
Glyph size.
CXTPBrush | m_xtpBrushTreeStructure
Brush to draw tree nodes.
CXTPBrush | m_xtpBrushGroupGridLineStyle
Brush to draw group row grid lines.
int | m_nFreezeColsDividerStyle
A set of flags from XTPGridFreezeColsDividerStyle.
BOOL | m_bFixedRowHeight
TRUE if fixed rows used.
BOOL | m_bColumnWidthWYSIWYG
TRUE if columns width WYSIWYG mode used.
BOOL | m_bShowWYSIWYGMarkers
TRUE if in non-print mode header show red page-end markers.
BOOL | m_bLastColumnWidthWYSIWYG
TRUE if last column width WYSIWYG mode used.
BOOL | m_bDrawGridForEmptySpace
TRUE if grid fills the empty space (if any) after the body rows.
BOOL | m_bPrintGroupRowIcon
TRUE if printout draw collapse-expand icon for group row.
BOOL | m_bColumnPlusMinusSign
TRUE if expand/collapse icons are used, FALSE if directional arrows are used.
BOOL | m_bFixedInplaceButtonHeight
TRUE if fixed in-place button height is used.
XTPGridGridStyle | m_nGroupGridLineStyle
Current style for group row grid lines.
XTPGridColumnStyle | m_columnStyle
Column drawing style.
CXTPWinThemeWrapper * | m_themeHeader
Header theme wrapper.
CXTPWinThemeWrapper * | m_themeButton
In-place button theme wrapper.
CXTPWinThemeWrapper * | m_themeCombo
Combo box in-place button theme wrapper.
CXTPWinThemeWrapper * | m_themeSpin
Spin in-place button theme wrapper.
CXTPGridControl * | m_pControl
Pointer to the Grid control object.
CXTPMarkupUIElement * | m_pMarkupUIElement_NoGroupBy
The no group by markup UI element.
CString | m_strMarkupUIElement_NoGroupBy
The no group by markup UI element string.
CXTPBrush | m_xtpBrushVeriticalGrid
Brush to draw vertical grid lines.
CXTPBrush | m_xtpBrushHorizontalGrid
Brush to draw horizontal grid lines.
XTPGridGridStyle m_nGridLineStylePreviousV
Previous style for vertical grid lines.
XTPGridGridStyle m_nGridLineStylePreviousH
Previous style for horizontal grid lines.

Detailed Description

CXTPGridThemeOfficeXP is a CXTPGridPaintManager derived class that represents an Office XP style theme.

Member Function Documentation

◆ DrawColumnBackground()

virtual void DrawColumnBackground | ( | CDC * | pDC,
 |  | CXTPGridColumn * | pColumn,
 |  | CRect | rcColumn,
 |  | BOOL & | bColumnPressed,
 |  | BOOL & | bDraggingFromHeader,
 |  | CXTPGridHeader * | pHeader = NULL )
 virtual

This method is called to draw the background of a column using the current column style.

Parameters
pDC | Pointer to the used device context.
pColumn | Pointer to the column whose background must be drawn.
rcColumn | Bounding rectangle of the column.
bColumnPressed | TRUE if the column is pressed by the user.
bDraggingFromHeader | TRUE if the column is being dragged from the header area.
pHeader | Pointer to the header that the column belongs to.

Reimplemented from CXTPGridPaintManager.

The documentation for this class was generated from the following file:
  • XTPGridThemeOfficeXP.h


Toolkit Pro: CXTPGridThemeResource Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPGridThemeResource Class Reference

CXTPGridThemeResource is a CXTPGridPaintManager derived class that represents a Resource style theme. More...

Inheritance diagram for CXTPGridThemeResource:
[legend]

Public Member Functions

CXTPGridThemeResource ()
Default paint manager constructor, handles properties initialization.
virtual void | RefreshMetrics ()
This method is called to refresh the visual metrics of the Grid control.
CSize | DrawCollapsedBitmap (CDC *pDC, const CXTPGridRow *pRow, CRect &rcBitmap)
Draws a collapsed bitmap.
virtual void | DrawNoGroupByText (CDC *pDC, CRect rcItem)
This method used to draw a "No items" text message in the Group By area when there are no items inside it.
virtual void | FillFooter (CDC *pDC, CRect rcFooter)
Fills the column footer control area by its background.
virtual void | DrawTriangle (CDC *pDC, CRect rcTriangle, BOOL bToDown, int nShadowWidth, BOOL bColumnPressed)
Draws a triangle that shows the sort order of the column.
virtual void | DrawColumnFooterDivider (CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn)
Draws the column footer divider.
virtual void | DrawColumnText (CDC *pDC, CRect rcText, CString strCaption, int nHeaderAlignment, BOOL bIsHeader, BOOL bColumnPressed)
Draws text for the column header.
void | DrawSectionDivider (CDC *pDC, const CRect &rc, XTPGridSectionDividerPosition dividerPosition, XTPGridSectionDividerStyle dividerStyle, CXTPPaintManagerColor dividerColor)
Draws the divider between grid sections (e.g.
virtual void | DrawTriangle (CDC *pDC, CRect rcTriangle, BOOL bToDown, BOOL bDraggingFromHeader, int nShadowWidth, BOOL bColumnPressed)
Draws a triangle that shows the sort order of the column.
- Public Member Functions inherited from CXTPGridPaintManager
CXTPGridPaintManager ()
Default CXTPGridPaintManager constructor, handles properties initialization.
virtual | ~CXTPGridPaintManager ()
Default CXTPGridPaintManager destructor, handles member items deallocation.
virtual void | SetGridControl (CXTPGridControl *pControl)
Sets the associated Grid control for the paint manager.
virtual void | LoadGlyphs ()
Loads the default images used by the Grid control.
virtual int | GetRowHeight (CDC *pDC, CXTPGridRow *pRow)
Retrieves the default row height for print mode (i.e.
virtual int | GetRowHeight (CDC *pDC, CXTPGridRow *pRow, int nTotalWidth)
Retrieves the default row height for print mode (i.e.
int | GetRowHeightEx (CDC *pDC, CXTPGridRow *pRow, int nTotalWidth, const BOOL firstLevel=TRUE)
Retrieves the default row height for print mode (i.e.
int | GetItemHeight (XTP_GRIDRECORDITEM_DRAWARGS &drawArgs, int nWidth)
Retrieves the height of a record item for a given width.
BOOL | FindRowAdjacentToMergedEx (const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, int &nAdjRowIndex, BOOL bUpward)
Searches the topmost or bottommost row depending on the height of the current row.
int | FindRowAdjacentToMerged (const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, BOOL bUpward)
Wrapper for the FindRowAdjacentToMergedEx method.
int | RecalcTotalHightOfMergedRows (CXTPGridColumns *pColumns, CDC *pDC, CXTPGridRow *pRow, int nRowHeight, int nTotalWidth)
Recalculates row height according to the height of merged items.
virtual int | GetPreviewItemHeight (CDC *pDC, CXTPGridRow *pRow, int nWidth, int nHeight)
Retrieves the height of a preview item for print mode.
virtual int | GetHeaderHeight ()
Gets the column header height.
virtual int | GetHeaderHeight (CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0)
Calculates the optimal header height.
virtual void | SetHeaderHeight (int nHeight)
Sets the column header height.
virtual int | GetFooterHeight (CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0)
Calculates the optimal footer height.
virtual COLORREF | GetControlBackColor (CXTPGridControl *pControl)
Retrieves the parent Grid control's background color.
virtual void | FillRow (CDC *pDC, CXTPGridRow *pRow, CRect rcRow)
Fills a specified row with its background color.
virtual void | DrawGrid (CDC *pDC, XTPGridOrientation orientation, CRect rcGrid)
Draws a grid for the control.
virtual void | DrawFreezeColsDivider (CDC *pDC, const CRect &rc, CXTPGridControl *pControl, CXTPGridRow *pRow=NULL)
Draws a freeze column divider.
virtual void | DrawVerticalTimeLineMarker (CDC *pDC, int xPos, CXTPGridControl *pControl, COLORREF color=RGB(0, 255, 0))
Draws a vertical timeline marker.
virtual void | DrawGroupRow (CDC *pDC, CXTPGridGroupRow *pRow, CRect rcRow, XTP_GRIDRECORDITEM_METRICS *pMetrics)
Draws a group row.
virtual void | FillGroupRowMetrics (CXTPGridGroupRow *pRow, XTP_GRIDRECORDITEM_METRICS *pMetrics, BOOL bPrinting)
Fills the font and color members of the metrics structure for a specified group row.
virtual void | FillIndent (CDC *pDC, CRect rcRow)
Fills an indent area by its background.
virtual void | FillItemShade (CDC *pDC, CRect rcItem)
Fills an item shade by its background if necessary.
virtual void | FillHeaderControl (CDC *pDC, CRect rcHeader)
Fills a column header control area by its background.
virtual void | DrawColumn (CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn, BOOL bDrawExternal=FALSE, int nShadowWidth=0)
Draws a column header with all related attributes (sort order, icon, etc.).
virtual void | DrawColumnFooter (CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn)
Draws the column footer with all related attributes (e.g.
virtual BOOL | IsColumHotTrackingEnabled () const
Determines if hot tracking is enabled for the current column style.
virtual void | DrawFocusedRow (CDC *pDC, CRect rcRow)
Draws focused rows.
virtual void | FillGroupByControl (CDC *pDC, CRect &rcGroupBy)
Draws the Group By box.
CXTPImageManager * | GetGlyphs () const
Gets a pointer to the additional image list with glyphs.
void | DrawHorizontalLine (CDC *pDC, int xPos, int yPos, int cx, COLORREF clr)
Draws a horizontal line.
void | DrawVerticalLine (CDC *pDC, int xPos, int yPos, int cy, COLORREF clr)
Draws a vertical line.
void | DrawConnector (CDC *pDC, CPoint ptFrom, CPoint ptTo)
Draws a column connector for the Group By box.
virtual int | DrawBitmap (CDC *pDC, CXTPGridControl *pControl, CRect rcColumn, int iImage)
Draws a bitmap.
virtual int | DrawColumnIcon (CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, CRect rcIcon, int iIcon)
Draws an icon for a column.
virtual CSize | DrawGlyph (CDC *pDC, CRect rcColumn, int iImage)
Draws the standard glyphs of the Grid control.
virtual CSize | DrawShellIcon (CDC *pDC, CRect rcColumn, int iImage)
Draws the shell icon.
void | EnablePreviewMode (BOOL bIsPreviewMode)
Enables/disables preview mode for the control.
BOOL | IsPreviewMode () const
Determines if preview mode is enabled/disabled for the control.
CFont * | GetTextFont ()
Gets the default text font used for control items.
int | SetMaxPreviewLines (int nMaxLines)
Sets the maximum number of lines of text for a preview item.
int | GetMaxPreviewLines ()
Gets the maximum number of lines of text for a preview item.
int | GetPreviewLinesCount (CDC *pDC, CRect &rcText, const CString &strText)
Calculates the number of lines required to draw a specified preview text string, taking into account the maximum number of lines of text for a preview item.
BOOL | IsGridVisible (BOOL bVertical) const
Determines the visibility of specified grid lines.
BOOL | IsGridVisible (XTPGridOrientation orientation) const
Determines the visibility of specified grid lines.
void | SetColumnStyle (XTPGridColumnStyle columnStyle)
Sets the header style.
XTPGridColumnStyle | GetColumnStyle () const
Gets the header style.
void | SetColumnOffice2007CustomThemeBaseColor (COLORREF clrBaseColor)
Sets the header's custom theme base color for Office2007 column style.
COLORREF | GetColumnOffice2007CustomThemeBaseColor () const
Gets the header's custom theme base color for Office2007 column style.
void | SetTextFont (LOGFONT &lf)
Creates and sets the default text font.
void | SetCaptionFont (LOGFONT &lf)
Creates and sets the default caption font.
void | SetPreviewIndent (int nLeft, int nTop, int nRight, int nBottom)
Sets the preview item indent.
virtual void | DrawInplaceButton (CDC *pDC, CXTPGridInplaceButton *pButton)
Draws the in-place button of the Grid control.
virtual BOOL | DrawInplaceComboButton (CDC *pDC, CRect *pRc)
Draws the combo button of the Grid control.
virtual BOOL | DrawInplaceExpandButton (CDC *pDC, CRect *pRc)
Draws the expand button of the Grid control.
virtual BOOL | DrawInplaceSpinButton (CDC *pDC, CRect *pRc)
Draws the spin button of the Grid control.
virtual void | DrawTreeStructure (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CRect rcItem, CSize sizeGlyph)
Draws tree elements of the Grid control.
virtual void | DrawItemBitmap (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CRect &rcItem, int nImage)
Draws an item bitmap.
virtual void | DrawItemCaption (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics)
Draws an item caption.
virtual void | DrawRowNumber (CDC *pDC, CRect rcNumber, CXTPGridRow *pRow)
Draws a row number.
virtual void | DrawItemControl (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CXTPGridRecordItemControl *pControl, CRect &rcItem)
Draws an item control.
BOOL | IsFixedRowHeight () const
Determines if the paint manager supports fixed or variable row height.
void | SetFixedRowHeight (BOOL bFixedRowHeight)
Sets if the paint manager supports fixed or variable row height.
BOOL | IsColumnWidthWYSIWYG () const
Determines if the paint manager supports column width WYSIWYG mode.
BOOL | IsLastColumnWidthWYSIWYG () const
Determines if the paint manager supports last column width WYSIWYG mode.
BOOL | IsShowWYSIWYGMarkers () const
Determines if the paint manager shows WYSIWYG page-end markers.
void | ShowWYSIWYGMarkers (BOOL bSet)
Sets if the paint manager shows WYSIWYG page-end markers.
void | SetColumnWidthWYSIWYG (BOOL bColumnWidthWYSIWYG)
Sets if the paint manager supports column width WYSIWYG mode.
void | SetLastColumnWidthWYSIWYG (BOOL bColumnWidthWYSIWYG)
Sets if the paint manager supports last column width WYSIWYG mode.
BOOL | IsFixedInplaceButtonHeight () const
Determines if the paint manager supports fixed or variable in-place button height.
void | SetInplaceButtonHeight (BOOL bFixedInplaceButtonHeight)
Sets if the paint manager supports fixed or variable in-place button height.
int | GetFreezeColsDividerStyle () const
Gets the style of the freeze columns divider line.
void | SetFreezeColsDividerStyle (int nStyle)
Sets the style for the freeze columns divider line.
virtual BOOL | OnDrawAction (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs)
Override this method to perform custom activities for the item before processing it.
BOOL | IsDrawGridForEmptySpace () const
Determines if the grid fills empty space after body rows.
void | SetDrawGridForEmptySpace (BOOL bDrawGrid)
Sets if the grid fills empty space after body rows.
BOOL | IsPrintGroupRowIcon () const
Determines if the group row collapse-expand icon is drawn in print mode.
void | SetPrintGroupRowIcon (BOOL bDraw)
Sets if the group row collapse-expand icon is drawn in print mode.
BOOL | IsColumnPlusMinusSign () const
Determines if columns use expand/collapse icons (+/-) or directional arrows.
void | SetColumnPlusMinusSign (BOOL bDraw)
Specifies if columns use expand/collapse icons (+/-) or directional arrows.
virtual int | CalculateRowHeight (CDC *pDC, const CString &strText, int nMaxWidth, BOOL bWordBreak=TRUE)
Calculates the height required for a rectangle bounding multi-line text to draw the multi-line text when the width of the rectangle is fixed.
void | DrawSectionDivider (CDC *pDC, const CRect &rc, XTPGridSectionDividerPosition dividerPosition, XTPGridSectionDividerStyle dividerStyle, CXTPPaintManagerColor dividerColor)
Draws the divider between grid sections (e.g.
int | GetSectionDividerHeight (XTPGridFixedRowsDividerStyle dividerStyle)
Gets the height of the section divider.
BOOL | IsUseDropMarker () const
Determines if a drop marker will be used when dragging and dropping.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

virtual void | DrawColumnBackground (CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, BOOL &bColumnPressed, BOOL &bDraggingFromHeader, CXTPGridHeader *pHeader=NULL)
This method is called to draw the background of a column using the current column style.
- Protected Member Functions inherited from CXTPGridPaintManager
virtual void | DrawTextLine (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nFlag, int &nCharCounter, int &nHyperlinkCounter)
Draws a line of text with respect to the drawing rectangle.
virtual int | DrawString (int *pnCurrDrawPos, CDC *pDC, const CString &strDraw, CRect rcDraw, UINT nFormat)
Draw a simple string into rectangle.
virtual void | DrawGridPattern (CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush)
Generates a custom grid pattern if necessary.
virtual void | DrawGridPattern (CDC *pDC, CXTPBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush)
Generates a custom grid pattern if necessary.
virtual void | DrawGridPattern (CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr)
Generates a custom grid pattern.
virtual void | DrawInplaceButtonFrame (CDC *pDC, CXTPGridInplaceButton *pButton)
Draws the in-place button frame.
virtual BOOL | DrawInplaceButtonIcon (CDC *pDC, CXTPGridInplaceButton *pButton)
Draws the in-place button icon.
virtual int | CalcColumnHeight (CDC *pDC, CXTPGridColumn *pColumn, int nTotalWidth=0)
Calculates the optimal height for a specified column.
virtual void | DrawMultiLineText (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, BOOL bWordBreak=TRUE)
Draws multi-line text.
virtual void | DrawSingleLineText (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nStartPos, int nEndPos, int nActualWidth)
Draws single-line text.
virtual int | DrawLink (int *pnCurrDrawPos, XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CXTPGridHyperlink *pHyperlink, CString strText, CRect rcLink, int nFlag, BOOL bTrim=FALSE)
Draws a hyperlink string using hyperlink text settings (i.e.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPGridPaintManager
CXTPFont | m_xtpFontText
Grid items default text.
CXTPFont | m_xtpFontBoldText
Grid items default bold text.
CXTPFont | m_xtpFontCaption
Column header caption font.
CXTPFont | m_xtpFontPreview
Column header caption font.
CXTPGridHyperlinkStyle * | m_pHyperlinkStyle
Style for links.
CXTPGridHyperlinkStyle * | m_pHyperlinkHoverStyle
Style for hovered links.
CXTPPaintManagerColor | m_clrHighlight
Background color of the highlighted row.
CXTPPaintManagerColor | m_clrBoldText
Grid items bold text color.
CXTPPaintManagerColor | m_clrBoldTextHighlight
Grid items bold text highlight color.
CXTPPaintManagerColor | m_clrWindowText
Grid items default text color.
CXTPPaintManagerColor | m_clrHighlightText
Text color of the highlighted text.
CXTPPaintManagerColor | m_clrHeaderControl
Background color of the grid header.
CXTPPaintManagerColor | m_clrCaptionText
Column header text color.
CXTPPaintManagerColor | m_clrCaptionTextPressed
Column header text color when pressed.
CXTPPaintManagerColor | m_clrControlBack
Background color of the control grid area.
CXTPPaintManagerColor | m_clrGroupRowText
Row text color.
CXTPPaintManagerColor | m_clrGroupShadeBack
Group row background color when indentation shade is enabled.
CXTPPaintManagerColor | m_clrGroupShadeText
Group row foreground color when indentation shade is enabled.
CXTPPaintManagerColor | m_clrGroupShadeBorder
Color for group border's shade.
CXTPPaintManagerColor | m_clrGroupBoxBack
Color of group box.
CXTPPaintManagerColor | m_clrControlDark
Dark background color of the Grid control (used on Group By area).
CXTPPaintManagerColor | m_clrControlLightLight
Light background color used for drawing shades (used on column header area).
CXTPPaintManagerColor | m_clrHotDivider
Color of the column hot divider window (two arrows).
CXTPPaintManagerColor | m_clrIndentControl
Color of the tree indentation area.
CXTPPaintManagerColor | m_clrItemShade
Color of the shade on sorted by column items.
CXTPPaintManagerColor | m_clrBtnFace
Standard button face color.
CXTPPaintManagerColor | m_clrBtnText
Standard button text color.
CXTPPaintManagerColor | m_clrPreviewText
Preview text color.
CXTPPaintManagerColor | m_clrSelectedRow
Selected row background color.
CXTPPaintManagerColor | m_clrSelectedRowText
Selected row text color.
CXTPPaintManagerColor | m_clrBtnFacePressed
Standard button face color when pressed.
CXTPPaintManagerColor | m_clrConnector
Header column connector line color.
CXTPPaintManagerColor | m_clrDisableBitmapLightest
The lightest color of bitmap which covers disabled grid.
CXTPPaintManagerColor | m_clrDisableBitmapDarkest
The darkest color of bitmap which covers disabled grid.
CXTPPaintManagerColorGradient | m_grcGradientColumn
Color of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColorGradient | m_grcGradientColumnHot
HotTracking Color of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColorGradient | m_grcGradientColumnPushed
Pushed Color of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColor | m_clrGradientColumnShadow
Bottom shadow of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColor | m_clrGradientColumnSeparator
Separator of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColor | m_crlNoGroupByText
A color for "No items" text in GroupBy area (see m_strNoGroupBy member).
CXTPPaintManagerColor | m_clrFreezeColsDivider
Freeze Columns Divider color.
COLORREF | m_clrColumnOffice2007CustomTheme
Base color for Office2007 custom theme.
COLORREF | m_clrFormulaSum
Color for Formula Sum fields.
COLORREF | m_clrFormulaSubSum
Color for Formula SubSum fields.
COLORREF | m_clrAlternativeBackground
Color for Alternative Row Background.
BOOL | m_bUseAlternativeBackground
TRUE to use Alternative Row Background, FALSE otherwise.
BOOL | m_bAllowMergeCells
TRUE to Allow Merge Cells, FALSE otherwise.
int | m_nTextIndentForGroupRowsWithNoIcon
Specifies Text indent if a group row icon is not used.
int | m_nTreeIndent
Tree indentation.
int | m_nTreeStructureStyle
Tree structure style.
int | m_nTreeTextIndentRowParent
Text indent, in pixels, for rows with children.
int | m_nTreeTextIndentRowChildren
Text indent, in pixels, for rows without children.
int | m_nTreeTextIndent
Text indent, in pixels, for rows that are neither parent nor children.
int | m_nTreeTextIndentGroupRow
Text indent, in pixels, for group rows.
BOOL | m_bGroupRowTextBold
TRUE to draw group rows with bold text.
BOOL | m_bShadeGroupHeadings
TRUE to show the indentation shade, FALSE otherwise.
BOOL | m_bShadeSortColumn
TRUE to show the items shade in the sorted by column, FALSE otherwise.
BOOL | m_bHotTracking
TRUE to allow column hot tracking.
BOOL | m_bInvertColumnOnClick
TRUE to invert column on click.
CString | m_strNoItems
A string which contains customized "No Items" text for displaying in view when there are no visible rows.
CString | m_strSortBy
A string which contains customized "Sort By" text for displaying in tooltip.
CString | m_strIncreasing
A string which contains customized "Increasing" text for displaying in tooltip.
CString | m_strDecreasing
A string which contains customized "Decreasing" text for displaying in tooltip.
CString | m_strNoGroupBy
A string which contains customized "No items" text message for displaying in Group By area when there are no items inside it.
CString | m_strNoFieldsAvailable
A string which contains customized "No Fields Available" text message for displaying in Field Chooser.
CString | m_strExpand
A string which contains customized "Expand" text for displaying in tooltip.
CString | m_strCollapse
A string which contains customized "Collapse" text for displaying in tooltip.
BOOL | m_bHideSelection
TRUE when hiding Grid control's selection by drawing selected items as others, FALSE otherwise.
BOOL | m_bPrintSortTriangle
TRUE to show the sort triangle in printout.
BOOL | m_bRevertAlignment
TRUE to revert column alignments.
BOOL | m_bUseEditTextAlignment
TRUE to automatically apply edit alignment using column alignment.
BOOL | m_bShowLockIcon
TRUE to show the lock icon, FALSE to hide.
BOOL | m_bUseShellIcon
TRUE to use the shell icon, FALSE otherwise.
int | m_iRecOrRowStart
Start position in numbering (0 or 1 or something user want).
BOOL | m_bRecOrRowNum
TRUE to display record number if support mode is used, FALSE to display row number.
BOOL | m_bMakeUpper
TRUE to display column header and group row text in all caps.
XTPGridTreeStructureStyle | m_treeStructureStyle
Tree structure style.
CRect | m_rcPreviewIndent
Preview indentation.
int | m_nFixedColumnsIndent
Fixed Column total width.
BOOL | m_bMoveScrollbarOnFixedColumnsIndent
Move Scrollbar right follow FixedColumnsIndent.
BOOL | m_bThemedInplaceButtons
Draw in-place buttons using current theme settings.
BOOL | m_bBaseTreeIndent
TRUE to add Extra Tree indentation to cover initial TreeColumn.
CUIntArray | m_arStartCol
Start column in each virtual page.
int | m_PrintPageWidth
Width of print page (run-time)
BOOL | m_bPrintVirtualPageNumber
TRUE to print horizontal page number.
BOOL | m_bPrintPageRectangle
TRUE to draw rectangle around page.
int | m_RecordNumberWidth
Column width for row/record numbers.
BOOL | m_bForceDynamicMarkupForCell
TRUE if use Markup for Grid Record Item.
BOOL | m_bForceShowDropMarker
TRUE if Force Show Drop Marker.
BOOL | m_bShowNonActiveInPlaceButton
TRUE if use Show Non-Active In-Place Button (Combo, Expand, Spin).
BOOL | m_bPrintWatermark
TRUE to print watermark.
BOOL | m_bUseGroupRowSelectionState
TRUE if use GroupSelectionState Glyph.
BOOL | m_bForceShowTooltip
TRUE if use show tooltip for any cell width case.
BOOL | m_bCleanTooltip
TRUE if use show tooltip without markup.
BOOL | m_bGrayIfDisable
TRUE is disable draw in gray (standard behavior).
int | m_nRowHeightDefault
The default row height.
BOOL | m_bCompactText
TRUE to ignore Icon for Narrow column to show more text.
BOOL | m_bUseDropMarker
FALSE to not draw drop marked when dragging/dropping, TRUE by default.
BOOL | m_bSortTriangleOffsetFromRight
Offset of sort triangle.
int | m_nTreeColumnLineLength
This is the extra line length to apply to tree column lines if there is no expand button.
int | m_nBaseParentRecordIndent
This is initial number of pixels a parent node will be indented when in a group.
- Protected Attributes inherited from CXTPGridPaintManager
int | m_nRowHeight
Grid row default height.
int | m_nHeaderHeight
Column header height.
int | m_nFooterHeight
Column footer height.
int | m_nGroupGridLineHeight
The height of the group grid line.
CXTPImageManager * | m_pGlyphs
An additional image list for the Grid control.
BOOL | m_bIsPreviewMode
TRUE to show the item preview, FALSE to hide.
int | m_nResizingWidth
The width of the column resizing marker area.
int | m_nMaxPreviewLines
Restrict maximum lines for preview text.
CSize | m_szGlyph
Glyph size.
CXTPBrush | m_xtpBrushTreeStructure
Brush to draw tree nodes.
CXTPBrush | m_xtpBrushGroupGridLineStyle
Brush to draw group row grid lines.
int | m_nFreezeColsDividerStyle
A set of flags from XTPGridFreezeColsDividerStyle.
BOOL | m_bFixedRowHeight
TRUE if fixed rows used.
BOOL | m_bColumnWidthWYSIWYG
TRUE if columns width WYSIWYG mode used.
BOOL | m_bShowWYSIWYGMarkers
TRUE if in non-print mode header show red page-end markers.
BOOL | m_bLastColumnWidthWYSIWYG
TRUE if last column width WYSIWYG mode used.
BOOL | m_bDrawGridForEmptySpace
TRUE if grid fills the empty space (if any) after the body rows.
BOOL | m_bPrintGroupRowIcon
TRUE if printout draw collapse-expand icon for group row.
BOOL | m_bColumnPlusMinusSign
TRUE if expand/collapse icons are used, FALSE if directional arrows are used.
BOOL | m_bFixedInplaceButtonHeight
TRUE if fixed in-place button height is used.
XTPGridGridStyle | m_nGroupGridLineStyle
Current style for group row grid lines.
XTPGridColumnStyle | m_columnStyle
Column drawing style.
CXTPWinThemeWrapper * | m_themeHeader
Header theme wrapper.
CXTPWinThemeWrapper * | m_themeButton
In-place button theme wrapper.
CXTPWinThemeWrapper * | m_themeCombo
Combo box in-place button theme wrapper.
CXTPWinThemeWrapper * | m_themeSpin
Spin in-place button theme wrapper.
CXTPGridControl * | m_pControl
Pointer to the Grid control object.
CXTPMarkupUIElement * | m_pMarkupUIElement_NoGroupBy
The no group by markup UI element.
CString | m_strMarkupUIElement_NoGroupBy
The no group by markup UI element string.
CXTPBrush | m_xtpBrushVeriticalGrid
Brush to draw vertical grid lines.
CXTPBrush | m_xtpBrushHorizontalGrid
Brush to draw horizontal grid lines.
XTPGridGridStyle m_nGridLineStylePreviousV
Previous style for vertical grid lines.
XTPGridGridStyle m_nGridLineStylePreviousH
Previous style for horizontal grid lines.

Detailed Description

CXTPGridThemeResource is a CXTPGridPaintManager derived class that represents a Resource style theme.

Member Function Documentation

◆ DrawCollapsedBitmap()

CSize DrawCollapsedBitmap | ( | CDC * | pDC,
 |  | const CXTPGridRow * | pRow,
 |  | CRect & | rcBitmap )
 virtual

Draws a collapsed bitmap.

Parameters
pDC | Pointer to the used device context.
pRow | Pointer to the row.
rcBitmap | Reference to bitmap area rectangle coordinates.
Returns
The size of the drawn bitmap.

Reimplemented from CXTPGridPaintManager.

◆ DrawColumnBackground()

virtual void DrawColumnBackground | ( | CDC * | pDC,
 |  | CXTPGridColumn * | pColumn,
 |  | CRect | rcColumn,
 |  | BOOL & | bColumnPressed,
 |  | BOOL & | bDraggingFromHeader,
 |  | CXTPGridHeader * | pHeader = NULL )
 protectedvirtual

This method is called to draw the background of a column using the current column style.

Parameters
pDC | Pointer to the used device context.
pColumn | Pointer to the column whose background must be drawn.
rcColumn | Bounding rectangle of the column.
bColumnPressed | TRUE if the column is pressed by the user.
bDraggingFromHeader | TRUE if the column is being dragged from the header area.
pHeader | Pointer to the header that the column belongs to.

Reimplemented from CXTPGridPaintManager.

◆ DrawColumnFooterDivider()

virtual void DrawColumnFooterDivider | ( | CDC * | pDC,
 |  | CXTPGridColumn * | pColumn,
 |  | CRect | rcColumn )
 virtual

Draws the column footer divider.

Parameters
pDC | Pointer to the used device context.
pColumn | Column header area rectangle coordinates.
rcColumn | Column area rectangle coordinates.

Reimplemented from CXTPGridPaintManager.

◆ DrawColumnText()

virtual void DrawColumnText | ( | CDC * | pDC,
 |  | CRect | rcText,
 |  | CString | strCaption,
 |  | int | nHeaderAlignment,
 |  | BOOL | bIsHeader,
 |  | BOOL | bColumnPressed )
 virtual

Draws text for the column header.

Parameters
pDC | Pointer to the used device context.
rcText | Size and position of the text to render.
strCaption | NULL-terminated string representing the caption text.
nHeaderAlignment | DT_ text alignment flags.
bIsHeader | TRUE if the column is to be rendered for the header.
bColumnPressed | TRUE if the column is pressed by the user.

Reimplemented from CXTPGridPaintManager.

◆ DrawNoGroupByText()

virtual void DrawNoGroupByText | ( | CDC * | pDC,
 |  | CRect | rcItem )
 virtual

This method used to draw a "No items" text message in the Group By area when there are no items inside it.

Override it for custom drawing.

Parameters
pDC | Pointer to the used device context.
rcItem | Reference to text area rectangle coordinates.
See also
CXTPGridPaintManager::m_strNoGroupBy

Reimplemented from CXTPGridPaintManager.

◆ DrawSectionDivider()

void DrawSectionDivider | ( | CDC * | pDC,
 |  | const CRect & | rc,
 |  | XTPGridSectionDividerPosition | dividerPosition,
 |  | XTPGridSectionDividerStyle | dividerStyle,
 |  | CXTPPaintManagerColor | dividerColor )

Draws the divider between grid sections (e.g.

dividing header record rows and body rows).

Parameters
pDC | Pointer to the used device context.
rc | Reference to rectangle coordinates.
dividerPosition | Position of the section divider; must be one of the values defined by the XTPGridSectionDividerPosition enumeration.
dividerStyle | Style of the section divider; must be one of the values defined by the XTPGridSectionDividerStyle enumeration.
dividerColor | Color of the section divider.

◆ DrawTriangle() [1/2]

virtual void DrawTriangle | ( | CDC * | pDC,
 |  | CRect | rcTriangle,
 |  | BOOL | bToDown,
 |  | BOOL | bDraggingFromHeader,
 |  | int | nShadowWidth,
 |  | BOOL | bColumnPressed )
 virtual

Draws a triangle that shows the sort order of the column.

Parameters
pDC | Pointer to the used device context.
rcTriangle | Triangle area rectangle coordinates.
bToDown | TRUE to turn the top of the triangle downward, FALSE to turn the top of the triangle upward.
bDraggingFromHeader | TRUE if the column is being dragged from the header area.
nShadowWidth | Size, in pixels, of the shadow to draw under the triangle image, or 0 to disable the shadow; the default value for this parameter is 0.
bColumnPressed | TRUE if the column is pressed by the user.

This function is used to draw a triangle image on the header of the column that is sorted. The triangle represents the direction of the sort: ascending or descending. The size of the triangle depends on the rectangle area provided.

Example:

// draw ascendant triangle
CRect rcTriangle;
rcTriangle.CopyRect(rcHeader);
rcTriangle.DeflateRect(40, 5, 5, 5);
DrawTriangle(pDC, rcTriangle, TRUE);

// draw descendant triangle
CRect rcTriangle;
rcTriangle.CopyRect(rcHeader);
rcTriangle.DeflateRect(40, 5, 5, 5);
DrawTriangle(pDC, rcTriangle, FALSE);

Reimplemented from CXTPGridPaintManager.

◆ DrawTriangle() [2/2]

virtual void DrawTriangle | ( | CDC * | pDC,
 |  | CRect | rcTriangle,
 |  | BOOL | bToDown,
 |  | int | nShadowWidth,
 |  | BOOL | bColumnPressed )
 virtual

Draws a triangle that shows the sort order of the column.

Parameters
pDC | Pointer to the used device context.
rcTriangle | Triangle area rectangle coordinates.
bToDown | TRUE to turn the top of the triangle downward, FALSE to turn the top of the triangle upward.
nShadowWidth | Size, in pixels, of the shadow to draw under the triangle image, or 0 to disable the shadow; the default value for this parameter is 0.
bColumnPressed | TRUE if the column is pressed by the user.

This function is used to draw a triangle image on the header of the column that is sorted. The triangle represents the direction of the sort: ascending or descending. The size of the triangle depends on the rectangle area provided.

Example:

// draw ascendant triangle
CRect rcTriangle;
rcTriangle.CopyRect(rcHeader);
rcTriangle.DeflateRect(40, 5, 5, 5);
DrawTriangle(pDC, rcTriangle, TRUE);

// draw descendant triangle
CRect rcTriangle;
rcTriangle.CopyRect(rcHeader);
rcTriangle.DeflateRect(40, 5, 5, 5);
DrawTriangle(pDC, rcTriangle, FALSE);

◆ FillFooter()

virtual void FillFooter | ( | CDC * | pDC,
 |  | CRect | rcFooter )
 virtual

Fills the column footer control area by its background.

Parameters
pDC | Pointer to the used device context.
rcFooter | Footer area rectangle coordinates.

Reimplemented from CXTPGridPaintManager.

The documentation for this class was generated from the following file:
  • XTPGridThemeResource.h


Toolkit Pro: CXTPGridThemeVisualStudio2012Blue Class Reference

Public Member Functions | List of all members
CXTPGridThemeVisualStudio2012Blue Class Reference

CXTPGridThemeVisualStudio2012Blue is a CXTPGridThemeOffice2013 derived class that represents a Visual Studio 2012 Blue style theme. More...

Inheritance diagram for CXTPGridThemeVisualStudio2012Blue:
[legend]

Public Member Functions

CXTPGridThemeVisualStudio2012Blue ()
Default paint manager constructor, handles properties initialization.
virtual void | LoadGlyphs ()
Loads the default images used by the Grid control.
virtual void | RefreshMetrics ()
This method is called to refresh the visual metrics of the Grid control.
- Public Member Functions inherited from CXTPGridThemeOffice2013
CXTPGridThemeOffice2013 ()
Default paint manager constructor, handles properties initialization.
virtual void | DrawColumnText (CDC *pDC, CRect rcText, CString strCaption, int nHeaderAlignment, BOOL bIsHeader, BOOL bColumnPressed)
Draws text for the column header.
virtual void | DrawColumnBackground (CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, BOOL &bColumnPressed, BOOL &bDraggingFromHeader, CXTPGridHeader *pHeader=NULL)
This method is called to draw the background of a column using the current column style.
virtual void | DrawTriangle (CDC *pDC, CRect rcTriangle, BOOL bToDown, BOOL bDraggingFromHeader, int nShadowWidth, BOOL bColumnPressed)
Draws a triangle that shows the sort order of the column.
virtual CSize | DrawCollapsedBitmap (CDC *pDC, const CXTPGridRow *pRow, CRect &rcBitmap)
Draws a collapsed bitmap.
virtual void | FillGroupRowMetrics (CXTPGridGroupRow *pRow, XTP_GRIDRECORDITEM_METRICS *pMetrics, BOOL bPrinting)
Fills the font and color members of the metrics structure for a specified group row.
virtual void | DrawGroupRow (CDC *pDC, CXTPGridGroupRow *pRow, CRect rcRow, XTP_GRIDRECORDITEM_METRICS *pMetrics)
Draws a group row.
virtual void | DrawFocusedRow (CDC *pDC, CRect rcRow)
Draws focused rows.
virtual int | GetRowHeight (CDC *pDC, CXTPGridRow *pRow)
Retrieves the default row height for print mode (i.e.
virtual int | GetRowHeight (CDC *pDC, CXTPGridRow *pRow, int nTotalWidth)
Retrieves the default row height for print mode (i.e.
- Public Member Functions inherited from CXTPGridPaintManager
CXTPGridPaintManager ()
Default CXTPGridPaintManager constructor, handles properties initialization.
virtual | ~CXTPGridPaintManager ()
Default CXTPGridPaintManager destructor, handles member items deallocation.
virtual void | SetGridControl (CXTPGridControl *pControl)
Sets the associated Grid control for the paint manager.
int | GetRowHeightEx (CDC *pDC, CXTPGridRow *pRow, int nTotalWidth, const BOOL firstLevel=TRUE)
Retrieves the default row height for print mode (i.e.
int | GetItemHeight (XTP_GRIDRECORDITEM_DRAWARGS &drawArgs, int nWidth)
Retrieves the height of a record item for a given width.
BOOL | FindRowAdjacentToMergedEx (const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, int &nAdjRowIndex, BOOL bUpward)
Searches the topmost or bottommost row depending on the height of the current row.
int | FindRowAdjacentToMerged (const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, BOOL bUpward)
Wrapper for the FindRowAdjacentToMergedEx method.
int | RecalcTotalHightOfMergedRows (CXTPGridColumns *pColumns, CDC *pDC, CXTPGridRow *pRow, int nRowHeight, int nTotalWidth)
Recalculates row height according to the height of merged items.
virtual int | GetPreviewItemHeight (CDC *pDC, CXTPGridRow *pRow, int nWidth, int nHeight)
Retrieves the height of a preview item for print mode.
virtual int | GetHeaderHeight ()
Gets the column header height.
virtual int | GetHeaderHeight (CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0)
Calculates the optimal header height.
virtual void | SetHeaderHeight (int nHeight)
Sets the column header height.
virtual int | GetFooterHeight (CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0)
Calculates the optimal footer height.
virtual COLORREF | GetControlBackColor (CXTPGridControl *pControl)
Retrieves the parent Grid control's background color.
virtual void | FillRow (CDC *pDC, CXTPGridRow *pRow, CRect rcRow)
Fills a specified row with its background color.
virtual void | DrawGrid (CDC *pDC, XTPGridOrientation orientation, CRect rcGrid)
Draws a grid for the control.
virtual void | DrawFreezeColsDivider (CDC *pDC, const CRect &rc, CXTPGridControl *pControl, CXTPGridRow *pRow=NULL)
Draws a freeze column divider.
virtual void | DrawVerticalTimeLineMarker (CDC *pDC, int xPos, CXTPGridControl *pControl, COLORREF color=RGB(0, 255, 0))
Draws a vertical timeline marker.
virtual void | FillIndent (CDC *pDC, CRect rcRow)
Fills an indent area by its background.
virtual void | FillItemShade (CDC *pDC, CRect rcItem)
Fills an item shade by its background if necessary.
virtual void | FillHeaderControl (CDC *pDC, CRect rcHeader)
Fills a column header control area by its background.
virtual void | FillFooter (CDC *pDC, CRect rcFooter)
Fills a column footer control area by its background.
virtual void | DrawColumn (CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn, BOOL bDrawExternal=FALSE, int nShadowWidth=0)
Draws a column header with all related attributes (sort order, icon, etc.).
virtual void | DrawColumnFooterDivider (CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn)
Draws the column footer divider.
virtual void | DrawColumnFooter (CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn)
Draws the column footer with all related attributes (e.g.
virtual BOOL | IsColumHotTrackingEnabled () const
Determines if hot tracking is enabled for the current column style.
virtual void | FillGroupByControl (CDC *pDC, CRect &rcGroupBy)
Draws the Group By box.
CXTPImageManager * | GetGlyphs () const
Gets a pointer to the additional image list with glyphs.
void | DrawHorizontalLine (CDC *pDC, int xPos, int yPos, int cx, COLORREF clr)
Draws a horizontal line.
void | DrawVerticalLine (CDC *pDC, int xPos, int yPos, int cy, COLORREF clr)
Draws a vertical line.
void | DrawConnector (CDC *pDC, CPoint ptFrom, CPoint ptTo)
Draws a column connector for the Group By box.
virtual int | DrawBitmap (CDC *pDC, CXTPGridControl *pControl, CRect rcColumn, int iImage)
Draws a bitmap.
virtual int | DrawColumnIcon (CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, CRect rcIcon, int iIcon)
Draws an icon for a column.
virtual CSize | DrawGlyph (CDC *pDC, CRect rcColumn, int iImage)
Draws the standard glyphs of the Grid control.
virtual CSize | DrawShellIcon (CDC *pDC, CRect rcColumn, int iImage)
Draws the shell icon.
void | EnablePreviewMode (BOOL bIsPreviewMode)
Enables/disables preview mode for the control.
BOOL | IsPreviewMode () const
Determines if preview mode is enabled/disabled for the control.
CFont * | GetTextFont ()
Gets the default text font used for control items.
int | SetMaxPreviewLines (int nMaxLines)
Sets the maximum number of lines of text for a preview item.
int | GetMaxPreviewLines ()
Gets the maximum number of lines of text for a preview item.
int | GetPreviewLinesCount (CDC *pDC, CRect &rcText, const CString &strText)
Calculates the number of lines required to draw a specified preview text string, taking into account the maximum number of lines of text for a preview item.
BOOL | IsGridVisible (BOOL bVertical) const
Determines the visibility of specified grid lines.
BOOL | IsGridVisible (XTPGridOrientation orientation) const
Determines the visibility of specified grid lines.
void | SetColumnStyle (XTPGridColumnStyle columnStyle)
Sets the header style.
XTPGridColumnStyle | GetColumnStyle () const
Gets the header style.
void | SetColumnOffice2007CustomThemeBaseColor (COLORREF clrBaseColor)
Sets the header's custom theme base color for Office2007 column style.
COLORREF | GetColumnOffice2007CustomThemeBaseColor () const
Gets the header's custom theme base color for Office2007 column style.
void | SetTextFont (LOGFONT &lf)
Creates and sets the default text font.
void | SetCaptionFont (LOGFONT &lf)
Creates and sets the default caption font.
void | SetPreviewIndent (int nLeft, int nTop, int nRight, int nBottom)
Sets the preview item indent.
virtual void | DrawInplaceButton (CDC *pDC, CXTPGridInplaceButton *pButton)
Draws the in-place button of the Grid control.
virtual BOOL | DrawInplaceComboButton (CDC *pDC, CRect *pRc)
Draws the combo button of the Grid control.
virtual BOOL | DrawInplaceExpandButton (CDC *pDC, CRect *pRc)
Draws the expand button of the Grid control.
virtual BOOL | DrawInplaceSpinButton (CDC *pDC, CRect *pRc)
Draws the spin button of the Grid control.
virtual void | DrawTreeStructure (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CRect rcItem, CSize sizeGlyph)
Draws tree elements of the Grid control.
virtual void | DrawItemBitmap (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CRect &rcItem, int nImage)
Draws an item bitmap.
virtual void | DrawItemCaption (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics)
Draws an item caption.
virtual void | DrawRowNumber (CDC *pDC, CRect rcNumber, CXTPGridRow *pRow)
Draws a row number.
virtual void | DrawItemControl (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CXTPGridRecordItemControl *pControl, CRect &rcItem)
Draws an item control.
BOOL | IsFixedRowHeight () const
Determines if the paint manager supports fixed or variable row height.
void | SetFixedRowHeight (BOOL bFixedRowHeight)
Sets if the paint manager supports fixed or variable row height.
BOOL | IsColumnWidthWYSIWYG () const
Determines if the paint manager supports column width WYSIWYG mode.
BOOL | IsLastColumnWidthWYSIWYG () const
Determines if the paint manager supports last column width WYSIWYG mode.
BOOL | IsShowWYSIWYGMarkers () const
Determines if the paint manager shows WYSIWYG page-end markers.
void | ShowWYSIWYGMarkers (BOOL bSet)
Sets if the paint manager shows WYSIWYG page-end markers.
void | SetColumnWidthWYSIWYG (BOOL bColumnWidthWYSIWYG)
Sets if the paint manager supports column width WYSIWYG mode.
void | SetLastColumnWidthWYSIWYG (BOOL bColumnWidthWYSIWYG)
Sets if the paint manager supports last column width WYSIWYG mode.
BOOL | IsFixedInplaceButtonHeight () const
Determines if the paint manager supports fixed or variable in-place button height.
void | SetInplaceButtonHeight (BOOL bFixedInplaceButtonHeight)
Sets if the paint manager supports fixed or variable in-place button height.
int | GetFreezeColsDividerStyle () const
Gets the style of the freeze columns divider line.
void | SetFreezeColsDividerStyle (int nStyle)
Sets the style for the freeze columns divider line.
virtual BOOL | OnDrawAction (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs)
Override this method to perform custom activities for the item before processing it.
virtual void | DrawNoGroupByText (CDC *pDC, CRect rcItem)
Draws the "No items" text message in the Group By area when there are no items inside it.
BOOL | IsDrawGridForEmptySpace () const
Determines if the grid fills empty space after body rows.
void | SetDrawGridForEmptySpace (BOOL bDrawGrid)
Sets if the grid fills empty space after body rows.
BOOL | IsPrintGroupRowIcon () const
Determines if the group row collapse-expand icon is drawn in print mode.
void | SetPrintGroupRowIcon (BOOL bDraw)
Sets if the group row collapse-expand icon is drawn in print mode.
BOOL | IsColumnPlusMinusSign () const
Determines if columns use expand/collapse icons (+/-) or directional arrows.
void | SetColumnPlusMinusSign (BOOL bDraw)
Specifies if columns use expand/collapse icons (+/-) or directional arrows.
virtual int | CalculateRowHeight (CDC *pDC, const CString &strText, int nMaxWidth, BOOL bWordBreak=TRUE)
Calculates the height required for a rectangle bounding multi-line text to draw the multi-line text when the width of the rectangle is fixed.
void | DrawSectionDivider (CDC *pDC, const CRect &rc, XTPGridSectionDividerPosition dividerPosition, XTPGridSectionDividerStyle dividerStyle, CXTPPaintManagerColor dividerColor)
Draws the divider between grid sections (e.g.
int | GetSectionDividerHeight (XTPGridFixedRowsDividerStyle dividerStyle)
Gets the height of the section divider.
BOOL | IsUseDropMarker () const
Determines if a drop marker will be used when dragging and dropping.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPGridThemeOffice2013
CXTPPaintManagerColor | m_clrGlyph
Header glyph color.
CXTPPaintManagerColor | m_clrGlyphHighlight
Header highlighted glyph color.
CXTPPaintManagerColor | m_clrGlyphExpand
Expand glyph color.
CXTPPaintManagerColor | m_clrGlyphBorder
Expand glyph border color.
CXTPPaintManagerColor | m_clrGlyphContract
Contract glyph color.
- Public Attributes inherited from CXTPGridPaintManager
CXTPFont | m_xtpFontText
Grid items default text.
CXTPFont | m_xtpFontBoldText
Grid items default bold text.
CXTPFont | m_xtpFontCaption
Column header caption font.
CXTPFont | m_xtpFontPreview
Column header caption font.
CXTPGridHyperlinkStyle * | m_pHyperlinkStyle
Style for links.
CXTPGridHyperlinkStyle * | m_pHyperlinkHoverStyle
Style for hovered links.
CXTPPaintManagerColor | m_clrHighlight
Background color of the highlighted row.
CXTPPaintManagerColor | m_clrBoldText
Grid items bold text color.
CXTPPaintManagerColor | m_clrBoldTextHighlight
Grid items bold text highlight color.
CXTPPaintManagerColor | m_clrWindowText
Grid items default text color.
CXTPPaintManagerColor | m_clrHighlightText
Text color of the highlighted text.
CXTPPaintManagerColor | m_clrHeaderControl
Background color of the grid header.
CXTPPaintManagerColor | m_clrCaptionText
Column header text color.
CXTPPaintManagerColor | m_clrCaptionTextPressed
Column header text color when pressed.
CXTPPaintManagerColor | m_clrControlBack
Background color of the control grid area.
CXTPPaintManagerColor | m_clrGroupRowText
Row text color.
CXTPPaintManagerColor | m_clrGroupShadeBack
Group row background color when indentation shade is enabled.
CXTPPaintManagerColor | m_clrGroupShadeText
Group row foreground color when indentation shade is enabled.
CXTPPaintManagerColor | m_clrGroupShadeBorder
Color for group border's shade.
CXTPPaintManagerColor | m_clrGroupBoxBack
Color of group box.
CXTPPaintManagerColor | m_clrControlDark
Dark background color of the Grid control (used on Group By area).
CXTPPaintManagerColor | m_clrControlLightLight
Light background color used for drawing shades (used on column header area).
CXTPPaintManagerColor | m_clrHotDivider
Color of the column hot divider window (two arrows).
CXTPPaintManagerColor | m_clrIndentControl
Color of the tree indentation area.
CXTPPaintManagerColor | m_clrItemShade
Color of the shade on sorted by column items.
CXTPPaintManagerColor | m_clrBtnFace
Standard button face color.
CXTPPaintManagerColor | m_clrBtnText
Standard button text color.
CXTPPaintManagerColor | m_clrPreviewText
Preview text color.
CXTPPaintManagerColor | m_clrSelectedRow
Selected row background color.
CXTPPaintManagerColor | m_clrSelectedRowText
Selected row text color.
CXTPPaintManagerColor | m_clrBtnFacePressed
Standard button face color when pressed.
CXTPPaintManagerColor | m_clrConnector
Header column connector line color.
CXTPPaintManagerColor | m_clrDisableBitmapLightest
The lightest color of bitmap which covers disabled grid.
CXTPPaintManagerColor | m_clrDisableBitmapDarkest
The darkest color of bitmap which covers disabled grid.
CXTPPaintManagerColorGradient | m_grcGradientColumn
Color of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColorGradient | m_grcGradientColumnHot
HotTracking Color of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColorGradient | m_grcGradientColumnPushed
Pushed Color of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColor | m_clrGradientColumnShadow
Bottom shadow of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColor | m_clrGradientColumnSeparator
Separator of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColor | m_crlNoGroupByText
A color for "No items" text in GroupBy area (see m_strNoGroupBy member).
CXTPPaintManagerColor | m_clrFreezeColsDivider
Freeze Columns Divider color.
COLORREF | m_clrColumnOffice2007CustomTheme
Base color for Office2007 custom theme.
COLORREF | m_clrFormulaSum
Color for Formula Sum fields.
COLORREF | m_clrFormulaSubSum
Color for Formula SubSum fields.
COLORREF | m_clrAlternativeBackground
Color for Alternative Row Background.
BOOL | m_bUseAlternativeBackground
TRUE to use Alternative Row Background, FALSE otherwise.
BOOL | m_bAllowMergeCells
TRUE to Allow Merge Cells, FALSE otherwise.
int | m_nTextIndentForGroupRowsWithNoIcon
Specifies Text indent if a group row icon is not used.
int | m_nTreeIndent
Tree indentation.
int | m_nTreeStructureStyle
Tree structure style.
int | m_nTreeTextIndentRowParent
Text indent, in pixels, for rows with children.
int | m_nTreeTextIndentRowChildren
Text indent, in pixels, for rows without children.
int | m_nTreeTextIndent
Text indent, in pixels, for rows that are neither parent nor children.
int | m_nTreeTextIndentGroupRow
Text indent, in pixels, for group rows.
BOOL | m_bGroupRowTextBold
TRUE to draw group rows with bold text.
BOOL | m_bShadeGroupHeadings
TRUE to show the indentation shade, FALSE otherwise.
BOOL | m_bShadeSortColumn
TRUE to show the items shade in the sorted by column, FALSE otherwise.
BOOL | m_bHotTracking
TRUE to allow column hot tracking.
BOOL | m_bInvertColumnOnClick
TRUE to invert column on click.
CString | m_strNoItems
A string which contains customized "No Items" text for displaying in view when there are no visible rows.
CString | m_strSortBy
A string which contains customized "Sort By" text for displaying in tooltip.
CString | m_strIncreasing
A string which contains customized "Increasing" text for displaying in tooltip.
CString | m_strDecreasing
A string which contains customized "Decreasing" text for displaying in tooltip.
CString | m_strNoGroupBy
A string which contains customized "No items" text message for displaying in Group By area when there are no items inside it.
CString | m_strNoFieldsAvailable
A string which contains customized "No Fields Available" text message for displaying in Field Chooser.
CString | m_strExpand
A string which contains customized "Expand" text for displaying in tooltip.
CString | m_strCollapse
A string which contains customized "Collapse" text for displaying in tooltip.
BOOL | m_bHideSelection
TRUE when hiding Grid control's selection by drawing selected items as others, FALSE otherwise.
BOOL | m_bPrintSortTriangle
TRUE to show the sort triangle in printout.
BOOL | m_bRevertAlignment
TRUE to revert column alignments.
BOOL | m_bUseEditTextAlignment
TRUE to automatically apply edit alignment using column alignment.
BOOL | m_bShowLockIcon
TRUE to show the lock icon, FALSE to hide.
BOOL | m_bUseShellIcon
TRUE to use the shell icon, FALSE otherwise.
int | m_iRecOrRowStart
Start position in numbering (0 or 1 or something user want).
BOOL | m_bRecOrRowNum
TRUE to display record number if support mode is used, FALSE to display row number.
BOOL | m_bMakeUpper
TRUE to display column header and group row text in all caps.
XTPGridTreeStructureStyle | m_treeStructureStyle
Tree structure style.
CRect | m_rcPreviewIndent
Preview indentation.
int | m_nFixedColumnsIndent
Fixed Column total width.
BOOL | m_bMoveScrollbarOnFixedColumnsIndent
Move Scrollbar right follow FixedColumnsIndent.
BOOL | m_bThemedInplaceButtons
Draw in-place buttons using current theme settings.
BOOL | m_bBaseTreeIndent
TRUE to add Extra Tree indentation to cover initial TreeColumn.
CUIntArray | m_arStartCol
Start column in each virtual page.
int | m_PrintPageWidth
Width of print page (run-time)
BOOL | m_bPrintVirtualPageNumber
TRUE to print horizontal page number.
BOOL | m_bPrintPageRectangle
TRUE to draw rectangle around page.
int | m_RecordNumberWidth
Column width for row/record numbers.
BOOL | m_bForceDynamicMarkupForCell
TRUE if use Markup for Grid Record Item.
BOOL | m_bForceShowDropMarker
TRUE if Force Show Drop Marker.
BOOL | m_bShowNonActiveInPlaceButton
TRUE if use Show Non-Active In-Place Button (Combo, Expand, Spin).
BOOL | m_bPrintWatermark
TRUE to print watermark.
BOOL | m_bUseGroupRowSelectionState
TRUE if use GroupSelectionState Glyph.
BOOL | m_bForceShowTooltip
TRUE if use show tooltip for any cell width case.
BOOL | m_bCleanTooltip
TRUE if use show tooltip without markup.
BOOL | m_bGrayIfDisable
TRUE is disable draw in gray (standard behavior).
int | m_nRowHeightDefault
The default row height.
BOOL | m_bCompactText
TRUE to ignore Icon for Narrow column to show more text.
BOOL | m_bUseDropMarker
FALSE to not draw drop marked when dragging/dropping, TRUE by default.
BOOL | m_bSortTriangleOffsetFromRight
Offset of sort triangle.
int | m_nTreeColumnLineLength
This is the extra line length to apply to tree column lines if there is no expand button.
int | m_nBaseParentRecordIndent
This is initial number of pixels a parent node will be indented when in a group.
- Protected Member Functions inherited from CXTPGridPaintManager
virtual void | DrawTextLine (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nFlag, int &nCharCounter, int &nHyperlinkCounter)
Draws a line of text with respect to the drawing rectangle.
virtual int | DrawString (int *pnCurrDrawPos, CDC *pDC, const CString &strDraw, CRect rcDraw, UINT nFormat)
Draw a simple string into rectangle.
virtual void | DrawGridPattern (CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush)
Generates a custom grid pattern if necessary.
virtual void | DrawGridPattern (CDC *pDC, CXTPBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush)
Generates a custom grid pattern if necessary.
virtual void | DrawGridPattern (CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr)
Generates a custom grid pattern.
virtual void | DrawInplaceButtonFrame (CDC *pDC, CXTPGridInplaceButton *pButton)
Draws the in-place button frame.
virtual BOOL | DrawInplaceButtonIcon (CDC *pDC, CXTPGridInplaceButton *pButton)
Draws the in-place button icon.
virtual int | CalcColumnHeight (CDC *pDC, CXTPGridColumn *pColumn, int nTotalWidth=0)
Calculates the optimal height for a specified column.
virtual void | DrawMultiLineText (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, BOOL bWordBreak=TRUE)
Draws multi-line text.
virtual void | DrawSingleLineText (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nStartPos, int nEndPos, int nActualWidth)
Draws single-line text.
virtual int | DrawLink (int *pnCurrDrawPos, XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CXTPGridHyperlink *pHyperlink, CString strText, CRect rcLink, int nFlag, BOOL bTrim=FALSE)
Draws a hyperlink string using hyperlink text settings (i.e.
- Protected Attributes inherited from CXTPGridPaintManager
int | m_nRowHeight
Grid row default height.
int | m_nHeaderHeight
Column header height.
int | m_nFooterHeight
Column footer height.
int | m_nGroupGridLineHeight
The height of the group grid line.
CXTPImageManager * | m_pGlyphs
An additional image list for the Grid control.
BOOL | m_bIsPreviewMode
TRUE to show the item preview, FALSE to hide.
int | m_nResizingWidth
The width of the column resizing marker area.
int | m_nMaxPreviewLines
Restrict maximum lines for preview text.
CSize | m_szGlyph
Glyph size.
CXTPBrush | m_xtpBrushTreeStructure
Brush to draw tree nodes.
CXTPBrush | m_xtpBrushGroupGridLineStyle
Brush to draw group row grid lines.
int | m_nFreezeColsDividerStyle
A set of flags from XTPGridFreezeColsDividerStyle.
BOOL | m_bFixedRowHeight
TRUE if fixed rows used.
BOOL | m_bColumnWidthWYSIWYG
TRUE if columns width WYSIWYG mode used.
BOOL | m_bShowWYSIWYGMarkers
TRUE if in non-print mode header show red page-end markers.
BOOL | m_bLastColumnWidthWYSIWYG
TRUE if last column width WYSIWYG mode used.
BOOL | m_bDrawGridForEmptySpace
TRUE if grid fills the empty space (if any) after the body rows.
BOOL | m_bPrintGroupRowIcon
TRUE if printout draw collapse-expand icon for group row.
BOOL | m_bColumnPlusMinusSign
TRUE if expand/collapse icons are used, FALSE if directional arrows are used.
BOOL | m_bFixedInplaceButtonHeight
TRUE if fixed in-place button height is used.
XTPGridGridStyle | m_nGroupGridLineStyle
Current style for group row grid lines.
XTPGridColumnStyle | m_columnStyle
Column drawing style.
CXTPWinThemeWrapper * | m_themeHeader
Header theme wrapper.
CXTPWinThemeWrapper * | m_themeButton
In-place button theme wrapper.
CXTPWinThemeWrapper * | m_themeCombo
Combo box in-place button theme wrapper.
CXTPWinThemeWrapper * | m_themeSpin
Spin in-place button theme wrapper.
CXTPGridControl * | m_pControl
Pointer to the Grid control object.
CXTPMarkupUIElement * | m_pMarkupUIElement_NoGroupBy
The no group by markup UI element.
CString | m_strMarkupUIElement_NoGroupBy
The no group by markup UI element string.
CXTPBrush | m_xtpBrushVeriticalGrid
Brush to draw vertical grid lines.
CXTPBrush | m_xtpBrushHorizontalGrid
Brush to draw horizontal grid lines.
XTPGridGridStyle m_nGridLineStylePreviousV
Previous style for vertical grid lines.
XTPGridGridStyle m_nGridLineStylePreviousH
Previous style for horizontal grid lines.

Detailed Description

CXTPGridThemeVisualStudio2012Blue is a CXTPGridThemeOffice2013 derived class that represents a Visual Studio 2012 Blue style theme.

The documentation for this class was generated from the following file:
  • XTPGridThemeVisualStudio2012.h


Toolkit Pro: CXTPGridThemeVisualStudio2012Dark Class Reference

Public Member Functions | List of all members
CXTPGridThemeVisualStudio2012Dark Class Reference

CXTPGridThemeVisualStudio2012Dark is a CXTPGridThemeOffice2013 derived class that represents a Visual Studio 2012 Dark style theme. More...

Inheritance diagram for CXTPGridThemeVisualStudio2012Dark:
[legend]

Public Member Functions

CXTPGridThemeVisualStudio2012Dark ()
Default paint manager constructor, handles properties initialization.
virtual void | LoadGlyphs ()
Loads the default images used by the Grid control.
virtual void | RefreshMetrics ()
This method is called to refresh the visual metrics of the Grid control.
- Public Member Functions inherited from CXTPGridThemeOffice2013
CXTPGridThemeOffice2013 ()
Default paint manager constructor, handles properties initialization.
virtual void | DrawColumnText (CDC *pDC, CRect rcText, CString strCaption, int nHeaderAlignment, BOOL bIsHeader, BOOL bColumnPressed)
Draws text for the column header.
virtual void | DrawColumnBackground (CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, BOOL &bColumnPressed, BOOL &bDraggingFromHeader, CXTPGridHeader *pHeader=NULL)
This method is called to draw the background of a column using the current column style.
virtual void | DrawTriangle (CDC *pDC, CRect rcTriangle, BOOL bToDown, BOOL bDraggingFromHeader, int nShadowWidth, BOOL bColumnPressed)
Draws a triangle that shows the sort order of the column.
virtual CSize | DrawCollapsedBitmap (CDC *pDC, const CXTPGridRow *pRow, CRect &rcBitmap)
Draws a collapsed bitmap.
virtual void | FillGroupRowMetrics (CXTPGridGroupRow *pRow, XTP_GRIDRECORDITEM_METRICS *pMetrics, BOOL bPrinting)
Fills the font and color members of the metrics structure for a specified group row.
virtual void | DrawGroupRow (CDC *pDC, CXTPGridGroupRow *pRow, CRect rcRow, XTP_GRIDRECORDITEM_METRICS *pMetrics)
Draws a group row.
virtual void | DrawFocusedRow (CDC *pDC, CRect rcRow)
Draws focused rows.
virtual int | GetRowHeight (CDC *pDC, CXTPGridRow *pRow)
Retrieves the default row height for print mode (i.e.
virtual int | GetRowHeight (CDC *pDC, CXTPGridRow *pRow, int nTotalWidth)
Retrieves the default row height for print mode (i.e.
- Public Member Functions inherited from CXTPGridPaintManager
CXTPGridPaintManager ()
Default CXTPGridPaintManager constructor, handles properties initialization.
virtual | ~CXTPGridPaintManager ()
Default CXTPGridPaintManager destructor, handles member items deallocation.
virtual void | SetGridControl (CXTPGridControl *pControl)
Sets the associated Grid control for the paint manager.
int | GetRowHeightEx (CDC *pDC, CXTPGridRow *pRow, int nTotalWidth, const BOOL firstLevel=TRUE)
Retrieves the default row height for print mode (i.e.
int | GetItemHeight (XTP_GRIDRECORDITEM_DRAWARGS &drawArgs, int nWidth)
Retrieves the height of a record item for a given width.
BOOL | FindRowAdjacentToMergedEx (const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, int &nAdjRowIndex, BOOL bUpward)
Searches the topmost or bottommost row depending on the height of the current row.
int | FindRowAdjacentToMerged (const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, BOOL bUpward)
Wrapper for the FindRowAdjacentToMergedEx method.
int | RecalcTotalHightOfMergedRows (CXTPGridColumns *pColumns, CDC *pDC, CXTPGridRow *pRow, int nRowHeight, int nTotalWidth)
Recalculates row height according to the height of merged items.
virtual int | GetPreviewItemHeight (CDC *pDC, CXTPGridRow *pRow, int nWidth, int nHeight)
Retrieves the height of a preview item for print mode.
virtual int | GetHeaderHeight ()
Gets the column header height.
virtual int | GetHeaderHeight (CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0)
Calculates the optimal header height.
virtual void | SetHeaderHeight (int nHeight)
Sets the column header height.
virtual int | GetFooterHeight (CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0)
Calculates the optimal footer height.
virtual COLORREF | GetControlBackColor (CXTPGridControl *pControl)
Retrieves the parent Grid control's background color.
virtual void | FillRow (CDC *pDC, CXTPGridRow *pRow, CRect rcRow)
Fills a specified row with its background color.
virtual void | DrawGrid (CDC *pDC, XTPGridOrientation orientation, CRect rcGrid)
Draws a grid for the control.
virtual void | DrawFreezeColsDivider (CDC *pDC, const CRect &rc, CXTPGridControl *pControl, CXTPGridRow *pRow=NULL)
Draws a freeze column divider.
virtual void | DrawVerticalTimeLineMarker (CDC *pDC, int xPos, CXTPGridControl *pControl, COLORREF color=RGB(0, 255, 0))
Draws a vertical timeline marker.
virtual void | FillIndent (CDC *pDC, CRect rcRow)
Fills an indent area by its background.
virtual void | FillItemShade (CDC *pDC, CRect rcItem)
Fills an item shade by its background if necessary.
virtual void | FillHeaderControl (CDC *pDC, CRect rcHeader)
Fills a column header control area by its background.
virtual void | FillFooter (CDC *pDC, CRect rcFooter)
Fills a column footer control area by its background.
virtual void | DrawColumn (CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn, BOOL bDrawExternal=FALSE, int nShadowWidth=0)
Draws a column header with all related attributes (sort order, icon, etc.).
virtual void | DrawColumnFooterDivider (CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn)
Draws the column footer divider.
virtual void | DrawColumnFooter (CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn)
Draws the column footer with all related attributes (e.g.
virtual BOOL | IsColumHotTrackingEnabled () const
Determines if hot tracking is enabled for the current column style.
virtual void | FillGroupByControl (CDC *pDC, CRect &rcGroupBy)
Draws the Group By box.
CXTPImageManager * | GetGlyphs () const
Gets a pointer to the additional image list with glyphs.
void | DrawHorizontalLine (CDC *pDC, int xPos, int yPos, int cx, COLORREF clr)
Draws a horizontal line.
void | DrawVerticalLine (CDC *pDC, int xPos, int yPos, int cy, COLORREF clr)
Draws a vertical line.
void | DrawConnector (CDC *pDC, CPoint ptFrom, CPoint ptTo)
Draws a column connector for the Group By box.
virtual int | DrawBitmap (CDC *pDC, CXTPGridControl *pControl, CRect rcColumn, int iImage)
Draws a bitmap.
virtual int | DrawColumnIcon (CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, CRect rcIcon, int iIcon)
Draws an icon for a column.
virtual CSize | DrawGlyph (CDC *pDC, CRect rcColumn, int iImage)
Draws the standard glyphs of the Grid control.
virtual CSize | DrawShellIcon (CDC *pDC, CRect rcColumn, int iImage)
Draws the shell icon.
void | EnablePreviewMode (BOOL bIsPreviewMode)
Enables/disables preview mode for the control.
BOOL | IsPreviewMode () const
Determines if preview mode is enabled/disabled for the control.
CFont * | GetTextFont ()
Gets the default text font used for control items.
int | SetMaxPreviewLines (int nMaxLines)
Sets the maximum number of lines of text for a preview item.
int | GetMaxPreviewLines ()
Gets the maximum number of lines of text for a preview item.
int | GetPreviewLinesCount (CDC *pDC, CRect &rcText, const CString &strText)
Calculates the number of lines required to draw a specified preview text string, taking into account the maximum number of lines of text for a preview item.
BOOL | IsGridVisible (BOOL bVertical) const
Determines the visibility of specified grid lines.
BOOL | IsGridVisible (XTPGridOrientation orientation) const
Determines the visibility of specified grid lines.
void | SetColumnStyle (XTPGridColumnStyle columnStyle)
Sets the header style.
XTPGridColumnStyle | GetColumnStyle () const
Gets the header style.
void | SetColumnOffice2007CustomThemeBaseColor (COLORREF clrBaseColor)
Sets the header's custom theme base color for Office2007 column style.
COLORREF | GetColumnOffice2007CustomThemeBaseColor () const
Gets the header's custom theme base color for Office2007 column style.
void | SetTextFont (LOGFONT &lf)
Creates and sets the default text font.
void | SetCaptionFont (LOGFONT &lf)
Creates and sets the default caption font.
void | SetPreviewIndent (int nLeft, int nTop, int nRight, int nBottom)
Sets the preview item indent.
virtual void | DrawInplaceButton (CDC *pDC, CXTPGridInplaceButton *pButton)
Draws the in-place button of the Grid control.
virtual BOOL | DrawInplaceComboButton (CDC *pDC, CRect *pRc)
Draws the combo button of the Grid control.
virtual BOOL | DrawInplaceExpandButton (CDC *pDC, CRect *pRc)
Draws the expand button of the Grid control.
virtual BOOL | DrawInplaceSpinButton (CDC *pDC, CRect *pRc)
Draws the spin button of the Grid control.
virtual void | DrawTreeStructure (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CRect rcItem, CSize sizeGlyph)
Draws tree elements of the Grid control.
virtual void | DrawItemBitmap (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CRect &rcItem, int nImage)
Draws an item bitmap.
virtual void | DrawItemCaption (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics)
Draws an item caption.
virtual void | DrawRowNumber (CDC *pDC, CRect rcNumber, CXTPGridRow *pRow)
Draws a row number.
virtual void | DrawItemControl (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CXTPGridRecordItemControl *pControl, CRect &rcItem)
Draws an item control.
BOOL | IsFixedRowHeight () const
Determines if the paint manager supports fixed or variable row height.
void | SetFixedRowHeight (BOOL bFixedRowHeight)
Sets if the paint manager supports fixed or variable row height.
BOOL | IsColumnWidthWYSIWYG () const
Determines if the paint manager supports column width WYSIWYG mode.
BOOL | IsLastColumnWidthWYSIWYG () const
Determines if the paint manager supports last column width WYSIWYG mode.
BOOL | IsShowWYSIWYGMarkers () const
Determines if the paint manager shows WYSIWYG page-end markers.
void | ShowWYSIWYGMarkers (BOOL bSet)
Sets if the paint manager shows WYSIWYG page-end markers.
void | SetColumnWidthWYSIWYG (BOOL bColumnWidthWYSIWYG)
Sets if the paint manager supports column width WYSIWYG mode.
void | SetLastColumnWidthWYSIWYG (BOOL bColumnWidthWYSIWYG)
Sets if the paint manager supports last column width WYSIWYG mode.
BOOL | IsFixedInplaceButtonHeight () const
Determines if the paint manager supports fixed or variable in-place button height.
void | SetInplaceButtonHeight (BOOL bFixedInplaceButtonHeight)
Sets if the paint manager supports fixed or variable in-place button height.
int | GetFreezeColsDividerStyle () const
Gets the style of the freeze columns divider line.
void | SetFreezeColsDividerStyle (int nStyle)
Sets the style for the freeze columns divider line.
virtual BOOL | OnDrawAction (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs)
Override this method to perform custom activities for the item before processing it.
virtual void | DrawNoGroupByText (CDC *pDC, CRect rcItem)
Draws the "No items" text message in the Group By area when there are no items inside it.
BOOL | IsDrawGridForEmptySpace () const
Determines if the grid fills empty space after body rows.
void | SetDrawGridForEmptySpace (BOOL bDrawGrid)
Sets if the grid fills empty space after body rows.
BOOL | IsPrintGroupRowIcon () const
Determines if the group row collapse-expand icon is drawn in print mode.
void | SetPrintGroupRowIcon (BOOL bDraw)
Sets if the group row collapse-expand icon is drawn in print mode.
BOOL | IsColumnPlusMinusSign () const
Determines if columns use expand/collapse icons (+/-) or directional arrows.
void | SetColumnPlusMinusSign (BOOL bDraw)
Specifies if columns use expand/collapse icons (+/-) or directional arrows.
virtual int | CalculateRowHeight (CDC *pDC, const CString &strText, int nMaxWidth, BOOL bWordBreak=TRUE)
Calculates the height required for a rectangle bounding multi-line text to draw the multi-line text when the width of the rectangle is fixed.
void | DrawSectionDivider (CDC *pDC, const CRect &rc, XTPGridSectionDividerPosition dividerPosition, XTPGridSectionDividerStyle dividerStyle, CXTPPaintManagerColor dividerColor)
Draws the divider between grid sections (e.g.
int | GetSectionDividerHeight (XTPGridFixedRowsDividerStyle dividerStyle)
Gets the height of the section divider.
BOOL | IsUseDropMarker () const
Determines if a drop marker will be used when dragging and dropping.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPGridThemeOffice2013
CXTPPaintManagerColor | m_clrGlyph
Header glyph color.
CXTPPaintManagerColor | m_clrGlyphHighlight
Header highlighted glyph color.
CXTPPaintManagerColor | m_clrGlyphExpand
Expand glyph color.
CXTPPaintManagerColor | m_clrGlyphBorder
Expand glyph border color.
CXTPPaintManagerColor | m_clrGlyphContract
Contract glyph color.
- Public Attributes inherited from CXTPGridPaintManager
CXTPFont | m_xtpFontText
Grid items default text.
CXTPFont | m_xtpFontBoldText
Grid items default bold text.
CXTPFont | m_xtpFontCaption
Column header caption font.
CXTPFont | m_xtpFontPreview
Column header caption font.
CXTPGridHyperlinkStyle * | m_pHyperlinkStyle
Style for links.
CXTPGridHyperlinkStyle * | m_pHyperlinkHoverStyle
Style for hovered links.
CXTPPaintManagerColor | m_clrHighlight
Background color of the highlighted row.
CXTPPaintManagerColor | m_clrBoldText
Grid items bold text color.
CXTPPaintManagerColor | m_clrBoldTextHighlight
Grid items bold text highlight color.
CXTPPaintManagerColor | m_clrWindowText
Grid items default text color.
CXTPPaintManagerColor | m_clrHighlightText
Text color of the highlighted text.
CXTPPaintManagerColor | m_clrHeaderControl
Background color of the grid header.
CXTPPaintManagerColor | m_clrCaptionText
Column header text color.
CXTPPaintManagerColor | m_clrCaptionTextPressed
Column header text color when pressed.
CXTPPaintManagerColor | m_clrControlBack
Background color of the control grid area.
CXTPPaintManagerColor | m_clrGroupRowText
Row text color.
CXTPPaintManagerColor | m_clrGroupShadeBack
Group row background color when indentation shade is enabled.
CXTPPaintManagerColor | m_clrGroupShadeText
Group row foreground color when indentation shade is enabled.
CXTPPaintManagerColor | m_clrGroupShadeBorder
Color for group border's shade.
CXTPPaintManagerColor | m_clrGroupBoxBack
Color of group box.
CXTPPaintManagerColor | m_clrControlDark
Dark background color of the Grid control (used on Group By area).
CXTPPaintManagerColor | m_clrControlLightLight
Light background color used for drawing shades (used on column header area).
CXTPPaintManagerColor | m_clrHotDivider
Color of the column hot divider window (two arrows).
CXTPPaintManagerColor | m_clrIndentControl
Color of the tree indentation area.
CXTPPaintManagerColor | m_clrItemShade
Color of the shade on sorted by column items.
CXTPPaintManagerColor | m_clrBtnFace
Standard button face color.
CXTPPaintManagerColor | m_clrBtnText
Standard button text color.
CXTPPaintManagerColor | m_clrPreviewText
Preview text color.
CXTPPaintManagerColor | m_clrSelectedRow
Selected row background color.
CXTPPaintManagerColor | m_clrSelectedRowText
Selected row text color.
CXTPPaintManagerColor | m_clrBtnFacePressed
Standard button face color when pressed.
CXTPPaintManagerColor | m_clrConnector
Header column connector line color.
CXTPPaintManagerColor | m_clrDisableBitmapLightest
The lightest color of bitmap which covers disabled grid.
CXTPPaintManagerColor | m_clrDisableBitmapDarkest
The darkest color of bitmap which covers disabled grid.
CXTPPaintManagerColorGradient | m_grcGradientColumn
Color of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColorGradient | m_grcGradientColumnHot
HotTracking Color of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColorGradient | m_grcGradientColumnPushed
Pushed Color of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColor | m_clrGradientColumnShadow
Bottom shadow of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColor | m_clrGradientColumnSeparator
Separator of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColor | m_crlNoGroupByText
A color for "No items" text in GroupBy area (see m_strNoGroupBy member).
CXTPPaintManagerColor | m_clrFreezeColsDivider
Freeze Columns Divider color.
COLORREF | m_clrColumnOffice2007CustomTheme
Base color for Office2007 custom theme.
COLORREF | m_clrFormulaSum
Color for Formula Sum fields.
COLORREF | m_clrFormulaSubSum
Color for Formula SubSum fields.
COLORREF | m_clrAlternativeBackground
Color for Alternative Row Background.
BOOL | m_bUseAlternativeBackground
TRUE to use Alternative Row Background, FALSE otherwise.
BOOL | m_bAllowMergeCells
TRUE to Allow Merge Cells, FALSE otherwise.
int | m_nTextIndentForGroupRowsWithNoIcon
Specifies Text indent if a group row icon is not used.
int | m_nTreeIndent
Tree indentation.
int | m_nTreeStructureStyle
Tree structure style.
int | m_nTreeTextIndentRowParent
Text indent, in pixels, for rows with children.
int | m_nTreeTextIndentRowChildren
Text indent, in pixels, for rows without children.
int | m_nTreeTextIndent
Text indent, in pixels, for rows that are neither parent nor children.
int | m_nTreeTextIndentGroupRow
Text indent, in pixels, for group rows.
BOOL | m_bGroupRowTextBold
TRUE to draw group rows with bold text.
BOOL | m_bShadeGroupHeadings
TRUE to show the indentation shade, FALSE otherwise.
BOOL | m_bShadeSortColumn
TRUE to show the items shade in the sorted by column, FALSE otherwise.
BOOL | m_bHotTracking
TRUE to allow column hot tracking.
BOOL | m_bInvertColumnOnClick
TRUE to invert column on click.
CString | m_strNoItems
A string which contains customized "No Items" text for displaying in view when there are no visible rows.
CString | m_strSortBy
A string which contains customized "Sort By" text for displaying in tooltip.
CString | m_strIncreasing
A string which contains customized "Increasing" text for displaying in tooltip.
CString | m_strDecreasing
A string which contains customized "Decreasing" text for displaying in tooltip.
CString | m_strNoGroupBy
A string which contains customized "No items" text message for displaying in Group By area when there are no items inside it.
CString | m_strNoFieldsAvailable
A string which contains customized "No Fields Available" text message for displaying in Field Chooser.
CString | m_strExpand
A string which contains customized "Expand" text for displaying in tooltip.
CString | m_strCollapse
A string which contains customized "Collapse" text for displaying in tooltip.
BOOL | m_bHideSelection
TRUE when hiding Grid control's selection by drawing selected items as others, FALSE otherwise.
BOOL | m_bPrintSortTriangle
TRUE to show the sort triangle in printout.
BOOL | m_bRevertAlignment
TRUE to revert column alignments.
BOOL | m_bUseEditTextAlignment
TRUE to automatically apply edit alignment using column alignment.
BOOL | m_bShowLockIcon
TRUE to show the lock icon, FALSE to hide.
BOOL | m_bUseShellIcon
TRUE to use the shell icon, FALSE otherwise.
int | m_iRecOrRowStart
Start position in numbering (0 or 1 or something user want).
BOOL | m_bRecOrRowNum
TRUE to display record number if support mode is used, FALSE to display row number.
BOOL | m_bMakeUpper
TRUE to display column header and group row text in all caps.
XTPGridTreeStructureStyle | m_treeStructureStyle
Tree structure style.
CRect | m_rcPreviewIndent
Preview indentation.
int | m_nFixedColumnsIndent
Fixed Column total width.
BOOL | m_bMoveScrollbarOnFixedColumnsIndent
Move Scrollbar right follow FixedColumnsIndent.
BOOL | m_bThemedInplaceButtons
Draw in-place buttons using current theme settings.
BOOL | m_bBaseTreeIndent
TRUE to add Extra Tree indentation to cover initial TreeColumn.
CUIntArray | m_arStartCol
Start column in each virtual page.
int | m_PrintPageWidth
Width of print page (run-time)
BOOL | m_bPrintVirtualPageNumber
TRUE to print horizontal page number.
BOOL | m_bPrintPageRectangle
TRUE to draw rectangle around page.
int | m_RecordNumberWidth
Column width for row/record numbers.
BOOL | m_bForceDynamicMarkupForCell
TRUE if use Markup for Grid Record Item.
BOOL | m_bForceShowDropMarker
TRUE if Force Show Drop Marker.
BOOL | m_bShowNonActiveInPlaceButton
TRUE if use Show Non-Active In-Place Button (Combo, Expand, Spin).
BOOL | m_bPrintWatermark
TRUE to print watermark.
BOOL | m_bUseGroupRowSelectionState
TRUE if use GroupSelectionState Glyph.
BOOL | m_bForceShowTooltip
TRUE if use show tooltip for any cell width case.
BOOL | m_bCleanTooltip
TRUE if use show tooltip without markup.
BOOL | m_bGrayIfDisable
TRUE is disable draw in gray (standard behavior).
int | m_nRowHeightDefault
The default row height.
BOOL | m_bCompactText
TRUE to ignore Icon for Narrow column to show more text.
BOOL | m_bUseDropMarker
FALSE to not draw drop marked when dragging/dropping, TRUE by default.
BOOL | m_bSortTriangleOffsetFromRight
Offset of sort triangle.
int | m_nTreeColumnLineLength
This is the extra line length to apply to tree column lines if there is no expand button.
int | m_nBaseParentRecordIndent
This is initial number of pixels a parent node will be indented when in a group.
- Protected Member Functions inherited from CXTPGridPaintManager
virtual void | DrawTextLine (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nFlag, int &nCharCounter, int &nHyperlinkCounter)
Draws a line of text with respect to the drawing rectangle.
virtual int | DrawString (int *pnCurrDrawPos, CDC *pDC, const CString &strDraw, CRect rcDraw, UINT nFormat)
Draw a simple string into rectangle.
virtual void | DrawGridPattern (CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush)
Generates a custom grid pattern if necessary.
virtual void | DrawGridPattern (CDC *pDC, CXTPBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush)
Generates a custom grid pattern if necessary.
virtual void | DrawGridPattern (CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr)
Generates a custom grid pattern.
virtual void | DrawInplaceButtonFrame (CDC *pDC, CXTPGridInplaceButton *pButton)
Draws the in-place button frame.
virtual BOOL | DrawInplaceButtonIcon (CDC *pDC, CXTPGridInplaceButton *pButton)
Draws the in-place button icon.
virtual int | CalcColumnHeight (CDC *pDC, CXTPGridColumn *pColumn, int nTotalWidth=0)
Calculates the optimal height for a specified column.
virtual void | DrawMultiLineText (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, BOOL bWordBreak=TRUE)
Draws multi-line text.
virtual void | DrawSingleLineText (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nStartPos, int nEndPos, int nActualWidth)
Draws single-line text.
virtual int | DrawLink (int *pnCurrDrawPos, XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CXTPGridHyperlink *pHyperlink, CString strText, CRect rcLink, int nFlag, BOOL bTrim=FALSE)
Draws a hyperlink string using hyperlink text settings (i.e.
- Protected Attributes inherited from CXTPGridPaintManager
int | m_nRowHeight
Grid row default height.
int | m_nHeaderHeight
Column header height.
int | m_nFooterHeight
Column footer height.
int | m_nGroupGridLineHeight
The height of the group grid line.
CXTPImageManager * | m_pGlyphs
An additional image list for the Grid control.
BOOL | m_bIsPreviewMode
TRUE to show the item preview, FALSE to hide.
int | m_nResizingWidth
The width of the column resizing marker area.
int | m_nMaxPreviewLines
Restrict maximum lines for preview text.
CSize | m_szGlyph
Glyph size.
CXTPBrush | m_xtpBrushTreeStructure
Brush to draw tree nodes.
CXTPBrush | m_xtpBrushGroupGridLineStyle
Brush to draw group row grid lines.
int | m_nFreezeColsDividerStyle
A set of flags from XTPGridFreezeColsDividerStyle.
BOOL | m_bFixedRowHeight
TRUE if fixed rows used.
BOOL | m_bColumnWidthWYSIWYG
TRUE if columns width WYSIWYG mode used.
BOOL | m_bShowWYSIWYGMarkers
TRUE if in non-print mode header show red page-end markers.
BOOL | m_bLastColumnWidthWYSIWYG
TRUE if last column width WYSIWYG mode used.
BOOL | m_bDrawGridForEmptySpace
TRUE if grid fills the empty space (if any) after the body rows.
BOOL | m_bPrintGroupRowIcon
TRUE if printout draw collapse-expand icon for group row.
BOOL | m_bColumnPlusMinusSign
TRUE if expand/collapse icons are used, FALSE if directional arrows are used.
BOOL | m_bFixedInplaceButtonHeight
TRUE if fixed in-place button height is used.
XTPGridGridStyle | m_nGroupGridLineStyle
Current style for group row grid lines.
XTPGridColumnStyle | m_columnStyle
Column drawing style.
CXTPWinThemeWrapper * | m_themeHeader
Header theme wrapper.
CXTPWinThemeWrapper * | m_themeButton
In-place button theme wrapper.
CXTPWinThemeWrapper * | m_themeCombo
Combo box in-place button theme wrapper.
CXTPWinThemeWrapper * | m_themeSpin
Spin in-place button theme wrapper.
CXTPGridControl * | m_pControl
Pointer to the Grid control object.
CXTPMarkupUIElement * | m_pMarkupUIElement_NoGroupBy
The no group by markup UI element.
CString | m_strMarkupUIElement_NoGroupBy
The no group by markup UI element string.
CXTPBrush | m_xtpBrushVeriticalGrid
Brush to draw vertical grid lines.
CXTPBrush | m_xtpBrushHorizontalGrid
Brush to draw horizontal grid lines.
XTPGridGridStyle m_nGridLineStylePreviousV
Previous style for vertical grid lines.
XTPGridGridStyle m_nGridLineStylePreviousH
Previous style for horizontal grid lines.

Detailed Description

CXTPGridThemeVisualStudio2012Dark is a CXTPGridThemeOffice2013 derived class that represents a Visual Studio 2012 Dark style theme.

The documentation for this class was generated from the following file:
  • XTPGridThemeVisualStudio2012.h


Toolkit Pro: CXTPGridThemeVisualStudio2012Light Class Reference

Public Member Functions | List of all members
CXTPGridThemeVisualStudio2012Light Class Reference

CXTPGridThemeVisualStudio2012Light is a CXTPGridThemeOffice2013 derived class that represents a Visual Studio 2012 Light style theme. More...

Inheritance diagram for CXTPGridThemeVisualStudio2012Light:
[legend]

Public Member Functions

CXTPGridThemeVisualStudio2012Light ()
Default paint manager constructor, handles properties initialization.
virtual void | LoadGlyphs ()
Loads the default images used by the Grid control.
virtual void | RefreshMetrics ()
This method is called to refresh the visual metrics of the Grid control.
- Public Member Functions inherited from CXTPGridThemeOffice2013
CXTPGridThemeOffice2013 ()
Default paint manager constructor, handles properties initialization.
virtual void | DrawColumnText (CDC *pDC, CRect rcText, CString strCaption, int nHeaderAlignment, BOOL bIsHeader, BOOL bColumnPressed)
Draws text for the column header.
virtual void | DrawColumnBackground (CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, BOOL &bColumnPressed, BOOL &bDraggingFromHeader, CXTPGridHeader *pHeader=NULL)
This method is called to draw the background of a column using the current column style.
virtual void | DrawTriangle (CDC *pDC, CRect rcTriangle, BOOL bToDown, BOOL bDraggingFromHeader, int nShadowWidth, BOOL bColumnPressed)
Draws a triangle that shows the sort order of the column.
virtual CSize | DrawCollapsedBitmap (CDC *pDC, const CXTPGridRow *pRow, CRect &rcBitmap)
Draws a collapsed bitmap.
virtual void | FillGroupRowMetrics (CXTPGridGroupRow *pRow, XTP_GRIDRECORDITEM_METRICS *pMetrics, BOOL bPrinting)
Fills the font and color members of the metrics structure for a specified group row.
virtual void | DrawGroupRow (CDC *pDC, CXTPGridGroupRow *pRow, CRect rcRow, XTP_GRIDRECORDITEM_METRICS *pMetrics)
Draws a group row.
virtual void | DrawFocusedRow (CDC *pDC, CRect rcRow)
Draws focused rows.
virtual int | GetRowHeight (CDC *pDC, CXTPGridRow *pRow)
Retrieves the default row height for print mode (i.e.
virtual int | GetRowHeight (CDC *pDC, CXTPGridRow *pRow, int nTotalWidth)
Retrieves the default row height for print mode (i.e.
- Public Member Functions inherited from CXTPGridPaintManager
CXTPGridPaintManager ()
Default CXTPGridPaintManager constructor, handles properties initialization.
virtual | ~CXTPGridPaintManager ()
Default CXTPGridPaintManager destructor, handles member items deallocation.
virtual void | SetGridControl (CXTPGridControl *pControl)
Sets the associated Grid control for the paint manager.
int | GetRowHeightEx (CDC *pDC, CXTPGridRow *pRow, int nTotalWidth, const BOOL firstLevel=TRUE)
Retrieves the default row height for print mode (i.e.
int | GetItemHeight (XTP_GRIDRECORDITEM_DRAWARGS &drawArgs, int nWidth)
Retrieves the height of a record item for a given width.
BOOL | FindRowAdjacentToMergedEx (const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, int &nAdjRowIndex, BOOL bUpward)
Searches the topmost or bottommost row depending on the height of the current row.
int | FindRowAdjacentToMerged (const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, BOOL bUpward)
Wrapper for the FindRowAdjacentToMergedEx method.
int | RecalcTotalHightOfMergedRows (CXTPGridColumns *pColumns, CDC *pDC, CXTPGridRow *pRow, int nRowHeight, int nTotalWidth)
Recalculates row height according to the height of merged items.
virtual int | GetPreviewItemHeight (CDC *pDC, CXTPGridRow *pRow, int nWidth, int nHeight)
Retrieves the height of a preview item for print mode.
virtual int | GetHeaderHeight ()
Gets the column header height.
virtual int | GetHeaderHeight (CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0)
Calculates the optimal header height.
virtual void | SetHeaderHeight (int nHeight)
Sets the column header height.
virtual int | GetFooterHeight (CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0)
Calculates the optimal footer height.
virtual COLORREF | GetControlBackColor (CXTPGridControl *pControl)
Retrieves the parent Grid control's background color.
virtual void | FillRow (CDC *pDC, CXTPGridRow *pRow, CRect rcRow)
Fills a specified row with its background color.
virtual void | DrawGrid (CDC *pDC, XTPGridOrientation orientation, CRect rcGrid)
Draws a grid for the control.
virtual void | DrawFreezeColsDivider (CDC *pDC, const CRect &rc, CXTPGridControl *pControl, CXTPGridRow *pRow=NULL)
Draws a freeze column divider.
virtual void | DrawVerticalTimeLineMarker (CDC *pDC, int xPos, CXTPGridControl *pControl, COLORREF color=RGB(0, 255, 0))
Draws a vertical timeline marker.
virtual void | FillIndent (CDC *pDC, CRect rcRow)
Fills an indent area by its background.
virtual void | FillItemShade (CDC *pDC, CRect rcItem)
Fills an item shade by its background if necessary.
virtual void | FillHeaderControl (CDC *pDC, CRect rcHeader)
Fills a column header control area by its background.
virtual void | FillFooter (CDC *pDC, CRect rcFooter)
Fills a column footer control area by its background.
virtual void | DrawColumn (CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn, BOOL bDrawExternal=FALSE, int nShadowWidth=0)
Draws a column header with all related attributes (sort order, icon, etc.).
virtual void | DrawColumnFooterDivider (CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn)
Draws the column footer divider.
virtual void | DrawColumnFooter (CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn)
Draws the column footer with all related attributes (e.g.
virtual BOOL | IsColumHotTrackingEnabled () const
Determines if hot tracking is enabled for the current column style.
virtual void | FillGroupByControl (CDC *pDC, CRect &rcGroupBy)
Draws the Group By box.
CXTPImageManager * | GetGlyphs () const
Gets a pointer to the additional image list with glyphs.
void | DrawHorizontalLine (CDC *pDC, int xPos, int yPos, int cx, COLORREF clr)
Draws a horizontal line.
void | DrawVerticalLine (CDC *pDC, int xPos, int yPos, int cy, COLORREF clr)
Draws a vertical line.
void | DrawConnector (CDC *pDC, CPoint ptFrom, CPoint ptTo)
Draws a column connector for the Group By box.
virtual int | DrawBitmap (CDC *pDC, CXTPGridControl *pControl, CRect rcColumn, int iImage)
Draws a bitmap.
virtual int | DrawColumnIcon (CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, CRect rcIcon, int iIcon)
Draws an icon for a column.
virtual CSize | DrawGlyph (CDC *pDC, CRect rcColumn, int iImage)
Draws the standard glyphs of the Grid control.
virtual CSize | DrawShellIcon (CDC *pDC, CRect rcColumn, int iImage)
Draws the shell icon.
void | EnablePreviewMode (BOOL bIsPreviewMode)
Enables/disables preview mode for the control.
BOOL | IsPreviewMode () const
Determines if preview mode is enabled/disabled for the control.
CFont * | GetTextFont ()
Gets the default text font used for control items.
int | SetMaxPreviewLines (int nMaxLines)
Sets the maximum number of lines of text for a preview item.
int | GetMaxPreviewLines ()
Gets the maximum number of lines of text for a preview item.
int | GetPreviewLinesCount (CDC *pDC, CRect &rcText, const CString &strText)
Calculates the number of lines required to draw a specified preview text string, taking into account the maximum number of lines of text for a preview item.
BOOL | IsGridVisible (BOOL bVertical) const
Determines the visibility of specified grid lines.
BOOL | IsGridVisible (XTPGridOrientation orientation) const
Determines the visibility of specified grid lines.
void | SetColumnStyle (XTPGridColumnStyle columnStyle)
Sets the header style.
XTPGridColumnStyle | GetColumnStyle () const
Gets the header style.
void | SetColumnOffice2007CustomThemeBaseColor (COLORREF clrBaseColor)
Sets the header's custom theme base color for Office2007 column style.
COLORREF | GetColumnOffice2007CustomThemeBaseColor () const
Gets the header's custom theme base color for Office2007 column style.
void | SetTextFont (LOGFONT &lf)
Creates and sets the default text font.
void | SetCaptionFont (LOGFONT &lf)
Creates and sets the default caption font.
void | SetPreviewIndent (int nLeft, int nTop, int nRight, int nBottom)
Sets the preview item indent.
virtual void | DrawInplaceButton (CDC *pDC, CXTPGridInplaceButton *pButton)
Draws the in-place button of the Grid control.
virtual BOOL | DrawInplaceComboButton (CDC *pDC, CRect *pRc)
Draws the combo button of the Grid control.
virtual BOOL | DrawInplaceExpandButton (CDC *pDC, CRect *pRc)
Draws the expand button of the Grid control.
virtual BOOL | DrawInplaceSpinButton (CDC *pDC, CRect *pRc)
Draws the spin button of the Grid control.
virtual void | DrawTreeStructure (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CRect rcItem, CSize sizeGlyph)
Draws tree elements of the Grid control.
virtual void | DrawItemBitmap (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CRect &rcItem, int nImage)
Draws an item bitmap.
virtual void | DrawItemCaption (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics)
Draws an item caption.
virtual void | DrawRowNumber (CDC *pDC, CRect rcNumber, CXTPGridRow *pRow)
Draws a row number.
virtual void | DrawItemControl (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CXTPGridRecordItemControl *pControl, CRect &rcItem)
Draws an item control.
BOOL | IsFixedRowHeight () const
Determines if the paint manager supports fixed or variable row height.
void | SetFixedRowHeight (BOOL bFixedRowHeight)
Sets if the paint manager supports fixed or variable row height.
BOOL | IsColumnWidthWYSIWYG () const
Determines if the paint manager supports column width WYSIWYG mode.
BOOL | IsLastColumnWidthWYSIWYG () const
Determines if the paint manager supports last column width WYSIWYG mode.
BOOL | IsShowWYSIWYGMarkers () const
Determines if the paint manager shows WYSIWYG page-end markers.
void | ShowWYSIWYGMarkers (BOOL bSet)
Sets if the paint manager shows WYSIWYG page-end markers.
void | SetColumnWidthWYSIWYG (BOOL bColumnWidthWYSIWYG)
Sets if the paint manager supports column width WYSIWYG mode.
void | SetLastColumnWidthWYSIWYG (BOOL bColumnWidthWYSIWYG)
Sets if the paint manager supports last column width WYSIWYG mode.
BOOL | IsFixedInplaceButtonHeight () const
Determines if the paint manager supports fixed or variable in-place button height.
void | SetInplaceButtonHeight (BOOL bFixedInplaceButtonHeight)
Sets if the paint manager supports fixed or variable in-place button height.
int | GetFreezeColsDividerStyle () const
Gets the style of the freeze columns divider line.
void | SetFreezeColsDividerStyle (int nStyle)
Sets the style for the freeze columns divider line.
virtual BOOL | OnDrawAction (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs)
Override this method to perform custom activities for the item before processing it.
virtual void | DrawNoGroupByText (CDC *pDC, CRect rcItem)
Draws the "No items" text message in the Group By area when there are no items inside it.
BOOL | IsDrawGridForEmptySpace () const
Determines if the grid fills empty space after body rows.
void | SetDrawGridForEmptySpace (BOOL bDrawGrid)
Sets if the grid fills empty space after body rows.
BOOL | IsPrintGroupRowIcon () const
Determines if the group row collapse-expand icon is drawn in print mode.
void | SetPrintGroupRowIcon (BOOL bDraw)
Sets if the group row collapse-expand icon is drawn in print mode.
BOOL | IsColumnPlusMinusSign () const
Determines if columns use expand/collapse icons (+/-) or directional arrows.
void | SetColumnPlusMinusSign (BOOL bDraw)
Specifies if columns use expand/collapse icons (+/-) or directional arrows.
virtual int | CalculateRowHeight (CDC *pDC, const CString &strText, int nMaxWidth, BOOL bWordBreak=TRUE)
Calculates the height required for a rectangle bounding multi-line text to draw the multi-line text when the width of the rectangle is fixed.
void | DrawSectionDivider (CDC *pDC, const CRect &rc, XTPGridSectionDividerPosition dividerPosition, XTPGridSectionDividerStyle dividerStyle, CXTPPaintManagerColor dividerColor)
Draws the divider between grid sections (e.g.
int | GetSectionDividerHeight (XTPGridFixedRowsDividerStyle dividerStyle)
Gets the height of the section divider.
BOOL | IsUseDropMarker () const
Determines if a drop marker will be used when dragging and dropping.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPGridThemeOffice2013
CXTPPaintManagerColor | m_clrGlyph
Header glyph color.
CXTPPaintManagerColor | m_clrGlyphHighlight
Header highlighted glyph color.
CXTPPaintManagerColor | m_clrGlyphExpand
Expand glyph color.
CXTPPaintManagerColor | m_clrGlyphBorder
Expand glyph border color.
CXTPPaintManagerColor | m_clrGlyphContract
Contract glyph color.
- Public Attributes inherited from CXTPGridPaintManager
CXTPFont | m_xtpFontText
Grid items default text.
CXTPFont | m_xtpFontBoldText
Grid items default bold text.
CXTPFont | m_xtpFontCaption
Column header caption font.
CXTPFont | m_xtpFontPreview
Column header caption font.
CXTPGridHyperlinkStyle * | m_pHyperlinkStyle
Style for links.
CXTPGridHyperlinkStyle * | m_pHyperlinkHoverStyle
Style for hovered links.
CXTPPaintManagerColor | m_clrHighlight
Background color of the highlighted row.
CXTPPaintManagerColor | m_clrBoldText
Grid items bold text color.
CXTPPaintManagerColor | m_clrBoldTextHighlight
Grid items bold text highlight color.
CXTPPaintManagerColor | m_clrWindowText
Grid items default text color.
CXTPPaintManagerColor | m_clrHighlightText
Text color of the highlighted text.
CXTPPaintManagerColor | m_clrHeaderControl
Background color of the grid header.
CXTPPaintManagerColor | m_clrCaptionText
Column header text color.
CXTPPaintManagerColor | m_clrCaptionTextPressed
Column header text color when pressed.
CXTPPaintManagerColor | m_clrControlBack
Background color of the control grid area.
CXTPPaintManagerColor | m_clrGroupRowText
Row text color.
CXTPPaintManagerColor | m_clrGroupShadeBack
Group row background color when indentation shade is enabled.
CXTPPaintManagerColor | m_clrGroupShadeText
Group row foreground color when indentation shade is enabled.
CXTPPaintManagerColor | m_clrGroupShadeBorder
Color for group border's shade.
CXTPPaintManagerColor | m_clrGroupBoxBack
Color of group box.
CXTPPaintManagerColor | m_clrControlDark
Dark background color of the Grid control (used on Group By area).
CXTPPaintManagerColor | m_clrControlLightLight
Light background color used for drawing shades (used on column header area).
CXTPPaintManagerColor | m_clrHotDivider
Color of the column hot divider window (two arrows).
CXTPPaintManagerColor | m_clrIndentControl
Color of the tree indentation area.
CXTPPaintManagerColor | m_clrItemShade
Color of the shade on sorted by column items.
CXTPPaintManagerColor | m_clrBtnFace
Standard button face color.
CXTPPaintManagerColor | m_clrBtnText
Standard button text color.
CXTPPaintManagerColor | m_clrPreviewText
Preview text color.
CXTPPaintManagerColor | m_clrSelectedRow
Selected row background color.
CXTPPaintManagerColor | m_clrSelectedRowText
Selected row text color.
CXTPPaintManagerColor | m_clrBtnFacePressed
Standard button face color when pressed.
CXTPPaintManagerColor | m_clrConnector
Header column connector line color.
CXTPPaintManagerColor | m_clrDisableBitmapLightest
The lightest color of bitmap which covers disabled grid.
CXTPPaintManagerColor | m_clrDisableBitmapDarkest
The darkest color of bitmap which covers disabled grid.
CXTPPaintManagerColorGradient | m_grcGradientColumn
Color of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColorGradient | m_grcGradientColumnHot
HotTracking Color of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColorGradient | m_grcGradientColumnPushed
Pushed Color of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColor | m_clrGradientColumnShadow
Bottom shadow of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColor | m_clrGradientColumnSeparator
Separator of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColor | m_crlNoGroupByText
A color for "No items" text in GroupBy area (see m_strNoGroupBy member).
CXTPPaintManagerColor | m_clrFreezeColsDivider
Freeze Columns Divider color.
COLORREF | m_clrColumnOffice2007CustomTheme
Base color for Office2007 custom theme.
COLORREF | m_clrFormulaSum
Color for Formula Sum fields.
COLORREF | m_clrFormulaSubSum
Color for Formula SubSum fields.
COLORREF | m_clrAlternativeBackground
Color for Alternative Row Background.
BOOL | m_bUseAlternativeBackground
TRUE to use Alternative Row Background, FALSE otherwise.
BOOL | m_bAllowMergeCells
TRUE to Allow Merge Cells, FALSE otherwise.
int | m_nTextIndentForGroupRowsWithNoIcon
Specifies Text indent if a group row icon is not used.
int | m_nTreeIndent
Tree indentation.
int | m_nTreeStructureStyle
Tree structure style.
int | m_nTreeTextIndentRowParent
Text indent, in pixels, for rows with children.
int | m_nTreeTextIndentRowChildren
Text indent, in pixels, for rows without children.
int | m_nTreeTextIndent
Text indent, in pixels, for rows that are neither parent nor children.
int | m_nTreeTextIndentGroupRow
Text indent, in pixels, for group rows.
BOOL | m_bGroupRowTextBold
TRUE to draw group rows with bold text.
BOOL | m_bShadeGroupHeadings
TRUE to show the indentation shade, FALSE otherwise.
BOOL | m_bShadeSortColumn
TRUE to show the items shade in the sorted by column, FALSE otherwise.
BOOL | m_bHotTracking
TRUE to allow column hot tracking.
BOOL | m_bInvertColumnOnClick
TRUE to invert column on click.
CString | m_strNoItems
A string which contains customized "No Items" text for displaying in view when there are no visible rows.
CString | m_strSortBy
A string which contains customized "Sort By" text for displaying in tooltip.
CString | m_strIncreasing
A string which contains customized "Increasing" text for displaying in tooltip.
CString | m_strDecreasing
A string which contains customized "Decreasing" text for displaying in tooltip.
CString | m_strNoGroupBy
A string which contains customized "No items" text message for displaying in Group By area when there are no items inside it.
CString | m_strNoFieldsAvailable
A string which contains customized "No Fields Available" text message for displaying in Field Chooser.
CString | m_strExpand
A string which contains customized "Expand" text for displaying in tooltip.
CString | m_strCollapse
A string which contains customized "Collapse" text for displaying in tooltip.
BOOL | m_bHideSelection
TRUE when hiding Grid control's selection by drawing selected items as others, FALSE otherwise.
BOOL | m_bPrintSortTriangle
TRUE to show the sort triangle in printout.
BOOL | m_bRevertAlignment
TRUE to revert column alignments.
BOOL | m_bUseEditTextAlignment
TRUE to automatically apply edit alignment using column alignment.
BOOL | m_bShowLockIcon
TRUE to show the lock icon, FALSE to hide.
BOOL | m_bUseShellIcon
TRUE to use the shell icon, FALSE otherwise.
int | m_iRecOrRowStart
Start position in numbering (0 or 1 or something user want).
BOOL | m_bRecOrRowNum
TRUE to display record number if support mode is used, FALSE to display row number.
BOOL | m_bMakeUpper
TRUE to display column header and group row text in all caps.
XTPGridTreeStructureStyle | m_treeStructureStyle
Tree structure style.
CRect | m_rcPreviewIndent
Preview indentation.
int | m_nFixedColumnsIndent
Fixed Column total width.
BOOL | m_bMoveScrollbarOnFixedColumnsIndent
Move Scrollbar right follow FixedColumnsIndent.
BOOL | m_bThemedInplaceButtons
Draw in-place buttons using current theme settings.
BOOL | m_bBaseTreeIndent
TRUE to add Extra Tree indentation to cover initial TreeColumn.
CUIntArray | m_arStartCol
Start column in each virtual page.
int | m_PrintPageWidth
Width of print page (run-time)
BOOL | m_bPrintVirtualPageNumber
TRUE to print horizontal page number.
BOOL | m_bPrintPageRectangle
TRUE to draw rectangle around page.
int | m_RecordNumberWidth
Column width for row/record numbers.
BOOL | m_bForceDynamicMarkupForCell
TRUE if use Markup for Grid Record Item.
BOOL | m_bForceShowDropMarker
TRUE if Force Show Drop Marker.
BOOL | m_bShowNonActiveInPlaceButton
TRUE if use Show Non-Active In-Place Button (Combo, Expand, Spin).
BOOL | m_bPrintWatermark
TRUE to print watermark.
BOOL | m_bUseGroupRowSelectionState
TRUE if use GroupSelectionState Glyph.
BOOL | m_bForceShowTooltip
TRUE if use show tooltip for any cell width case.
BOOL | m_bCleanTooltip
TRUE if use show tooltip without markup.
BOOL | m_bGrayIfDisable
TRUE is disable draw in gray (standard behavior).
int | m_nRowHeightDefault
The default row height.
BOOL | m_bCompactText
TRUE to ignore Icon for Narrow column to show more text.
BOOL | m_bUseDropMarker
FALSE to not draw drop marked when dragging/dropping, TRUE by default.
BOOL | m_bSortTriangleOffsetFromRight
Offset of sort triangle.
int | m_nTreeColumnLineLength
This is the extra line length to apply to tree column lines if there is no expand button.
int | m_nBaseParentRecordIndent
This is initial number of pixels a parent node will be indented when in a group.
- Protected Member Functions inherited from CXTPGridPaintManager
virtual void | DrawTextLine (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nFlag, int &nCharCounter, int &nHyperlinkCounter)
Draws a line of text with respect to the drawing rectangle.
virtual int | DrawString (int *pnCurrDrawPos, CDC *pDC, const CString &strDraw, CRect rcDraw, UINT nFormat)
Draw a simple string into rectangle.
virtual void | DrawGridPattern (CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush)
Generates a custom grid pattern if necessary.
virtual void | DrawGridPattern (CDC *pDC, CXTPBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush)
Generates a custom grid pattern if necessary.
virtual void | DrawGridPattern (CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr)
Generates a custom grid pattern.
virtual void | DrawInplaceButtonFrame (CDC *pDC, CXTPGridInplaceButton *pButton)
Draws the in-place button frame.
virtual BOOL | DrawInplaceButtonIcon (CDC *pDC, CXTPGridInplaceButton *pButton)
Draws the in-place button icon.
virtual int | CalcColumnHeight (CDC *pDC, CXTPGridColumn *pColumn, int nTotalWidth=0)
Calculates the optimal height for a specified column.
virtual void | DrawMultiLineText (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, BOOL bWordBreak=TRUE)
Draws multi-line text.
virtual void | DrawSingleLineText (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nStartPos, int nEndPos, int nActualWidth)
Draws single-line text.
virtual int | DrawLink (int *pnCurrDrawPos, XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CXTPGridHyperlink *pHyperlink, CString strText, CRect rcLink, int nFlag, BOOL bTrim=FALSE)
Draws a hyperlink string using hyperlink text settings (i.e.
- Protected Attributes inherited from CXTPGridPaintManager
int | m_nRowHeight
Grid row default height.
int | m_nHeaderHeight
Column header height.
int | m_nFooterHeight
Column footer height.
int | m_nGroupGridLineHeight
The height of the group grid line.
CXTPImageManager * | m_pGlyphs
An additional image list for the Grid control.
BOOL | m_bIsPreviewMode
TRUE to show the item preview, FALSE to hide.
int | m_nResizingWidth
The width of the column resizing marker area.
int | m_nMaxPreviewLines
Restrict maximum lines for preview text.
CSize | m_szGlyph
Glyph size.
CXTPBrush | m_xtpBrushTreeStructure
Brush to draw tree nodes.
CXTPBrush | m_xtpBrushGroupGridLineStyle
Brush to draw group row grid lines.
int | m_nFreezeColsDividerStyle
A set of flags from XTPGridFreezeColsDividerStyle.
BOOL | m_bFixedRowHeight
TRUE if fixed rows used.
BOOL | m_bColumnWidthWYSIWYG
TRUE if columns width WYSIWYG mode used.
BOOL | m_bShowWYSIWYGMarkers
TRUE if in non-print mode header show red page-end markers.
BOOL | m_bLastColumnWidthWYSIWYG
TRUE if last column width WYSIWYG mode used.
BOOL | m_bDrawGridForEmptySpace
TRUE if grid fills the empty space (if any) after the body rows.
BOOL | m_bPrintGroupRowIcon
TRUE if printout draw collapse-expand icon for group row.
BOOL | m_bColumnPlusMinusSign
TRUE if expand/collapse icons are used, FALSE if directional arrows are used.
BOOL | m_bFixedInplaceButtonHeight
TRUE if fixed in-place button height is used.
XTPGridGridStyle | m_nGroupGridLineStyle
Current style for group row grid lines.
XTPGridColumnStyle | m_columnStyle
Column drawing style.
CXTPWinThemeWrapper * | m_themeHeader
Header theme wrapper.
CXTPWinThemeWrapper * | m_themeButton
In-place button theme wrapper.
CXTPWinThemeWrapper * | m_themeCombo
Combo box in-place button theme wrapper.
CXTPWinThemeWrapper * | m_themeSpin
Spin in-place button theme wrapper.
CXTPGridControl * | m_pControl
Pointer to the Grid control object.
CXTPMarkupUIElement * | m_pMarkupUIElement_NoGroupBy
The no group by markup UI element.
CString | m_strMarkupUIElement_NoGroupBy
The no group by markup UI element string.
CXTPBrush | m_xtpBrushVeriticalGrid
Brush to draw vertical grid lines.
CXTPBrush | m_xtpBrushHorizontalGrid
Brush to draw horizontal grid lines.
XTPGridGridStyle m_nGridLineStylePreviousV
Previous style for vertical grid lines.
XTPGridGridStyle m_nGridLineStylePreviousH
Previous style for horizontal grid lines.

Detailed Description

CXTPGridThemeVisualStudio2012Light is a CXTPGridThemeOffice2013 derived class that represents a Visual Studio 2012 Light style theme.

The documentation for this class was generated from the following file:
  • XTPGridThemeVisualStudio2012.h


Toolkit Pro: CXTPGridThemeVisualStudio2015 Class Reference

Public Member Functions | List of all members
CXTPGridThemeVisualStudio2015 Class Reference

CXTPGridThemeVisualStudio2015 is a CXTPGridThemeOffice2013 derived class that represents a Visual Studio 2015 style theme. More...

Inheritance diagram for CXTPGridThemeVisualStudio2015:
[legend]

Public Member Functions

CXTPGridThemeVisualStudio2015 ()
Default paint manager constructor, handles properties initialization.
virtual void | RefreshMetrics ()
This method is called to refresh the visual metrics of the Grid control.
- Public Member Functions inherited from CXTPGridThemeOffice2013
CXTPGridThemeOffice2013 ()
Default paint manager constructor, handles properties initialization.
virtual void | LoadGlyphs ()
Loads the default images used by the Grid control.
virtual void | DrawColumnText (CDC *pDC, CRect rcText, CString strCaption, int nHeaderAlignment, BOOL bIsHeader, BOOL bColumnPressed)
Draws text for the column header.
virtual void | DrawColumnBackground (CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, BOOL &bColumnPressed, BOOL &bDraggingFromHeader, CXTPGridHeader *pHeader=NULL)
This method is called to draw the background of a column using the current column style.
virtual void | DrawTriangle (CDC *pDC, CRect rcTriangle, BOOL bToDown, BOOL bDraggingFromHeader, int nShadowWidth, BOOL bColumnPressed)
Draws a triangle that shows the sort order of the column.
virtual CSize | DrawCollapsedBitmap (CDC *pDC, const CXTPGridRow *pRow, CRect &rcBitmap)
Draws a collapsed bitmap.
virtual void | FillGroupRowMetrics (CXTPGridGroupRow *pRow, XTP_GRIDRECORDITEM_METRICS *pMetrics, BOOL bPrinting)
Fills the font and color members of the metrics structure for a specified group row.
virtual void | DrawGroupRow (CDC *pDC, CXTPGridGroupRow *pRow, CRect rcRow, XTP_GRIDRECORDITEM_METRICS *pMetrics)
Draws a group row.
virtual void | DrawFocusedRow (CDC *pDC, CRect rcRow)
Draws focused rows.
virtual int | GetRowHeight (CDC *pDC, CXTPGridRow *pRow)
Retrieves the default row height for print mode (i.e.
virtual int | GetRowHeight (CDC *pDC, CXTPGridRow *pRow, int nTotalWidth)
Retrieves the default row height for print mode (i.e.
- Public Member Functions inherited from CXTPGridPaintManager
CXTPGridPaintManager ()
Default CXTPGridPaintManager constructor, handles properties initialization.
virtual | ~CXTPGridPaintManager ()
Default CXTPGridPaintManager destructor, handles member items deallocation.
virtual void | SetGridControl (CXTPGridControl *pControl)
Sets the associated Grid control for the paint manager.
int | GetRowHeightEx (CDC *pDC, CXTPGridRow *pRow, int nTotalWidth, const BOOL firstLevel=TRUE)
Retrieves the default row height for print mode (i.e.
int | GetItemHeight (XTP_GRIDRECORDITEM_DRAWARGS &drawArgs, int nWidth)
Retrieves the height of a record item for a given width.
BOOL | FindRowAdjacentToMergedEx (const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, int &nAdjRowIndex, BOOL bUpward)
Searches the topmost or bottommost row depending on the height of the current row.
int | FindRowAdjacentToMerged (const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, BOOL bUpward)
Wrapper for the FindRowAdjacentToMergedEx method.
int | RecalcTotalHightOfMergedRows (CXTPGridColumns *pColumns, CDC *pDC, CXTPGridRow *pRow, int nRowHeight, int nTotalWidth)
Recalculates row height according to the height of merged items.
virtual int | GetPreviewItemHeight (CDC *pDC, CXTPGridRow *pRow, int nWidth, int nHeight)
Retrieves the height of a preview item for print mode.
virtual int | GetHeaderHeight ()
Gets the column header height.
virtual int | GetHeaderHeight (CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0)
Calculates the optimal header height.
virtual void | SetHeaderHeight (int nHeight)
Sets the column header height.
virtual int | GetFooterHeight (CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0)
Calculates the optimal footer height.
virtual COLORREF | GetControlBackColor (CXTPGridControl *pControl)
Retrieves the parent Grid control's background color.
virtual void | FillRow (CDC *pDC, CXTPGridRow *pRow, CRect rcRow)
Fills a specified row with its background color.
virtual void | DrawGrid (CDC *pDC, XTPGridOrientation orientation, CRect rcGrid)
Draws a grid for the control.
virtual void | DrawFreezeColsDivider (CDC *pDC, const CRect &rc, CXTPGridControl *pControl, CXTPGridRow *pRow=NULL)
Draws a freeze column divider.
virtual void | DrawVerticalTimeLineMarker (CDC *pDC, int xPos, CXTPGridControl *pControl, COLORREF color=RGB(0, 255, 0))
Draws a vertical timeline marker.
virtual void | FillIndent (CDC *pDC, CRect rcRow)
Fills an indent area by its background.
virtual void | FillItemShade (CDC *pDC, CRect rcItem)
Fills an item shade by its background if necessary.
virtual void | FillHeaderControl (CDC *pDC, CRect rcHeader)
Fills a column header control area by its background.
virtual void | FillFooter (CDC *pDC, CRect rcFooter)
Fills a column footer control area by its background.
virtual void | DrawColumn (CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn, BOOL bDrawExternal=FALSE, int nShadowWidth=0)
Draws a column header with all related attributes (sort order, icon, etc.).
virtual void | DrawColumnFooterDivider (CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn)
Draws the column footer divider.
virtual void | DrawColumnFooter (CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn)
Draws the column footer with all related attributes (e.g.
virtual BOOL | IsColumHotTrackingEnabled () const
Determines if hot tracking is enabled for the current column style.
virtual void | FillGroupByControl (CDC *pDC, CRect &rcGroupBy)
Draws the Group By box.
CXTPImageManager * | GetGlyphs () const
Gets a pointer to the additional image list with glyphs.
void | DrawHorizontalLine (CDC *pDC, int xPos, int yPos, int cx, COLORREF clr)
Draws a horizontal line.
void | DrawVerticalLine (CDC *pDC, int xPos, int yPos, int cy, COLORREF clr)
Draws a vertical line.
void | DrawConnector (CDC *pDC, CPoint ptFrom, CPoint ptTo)
Draws a column connector for the Group By box.
virtual int | DrawBitmap (CDC *pDC, CXTPGridControl *pControl, CRect rcColumn, int iImage)
Draws a bitmap.
virtual int | DrawColumnIcon (CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, CRect rcIcon, int iIcon)
Draws an icon for a column.
virtual CSize | DrawGlyph (CDC *pDC, CRect rcColumn, int iImage)
Draws the standard glyphs of the Grid control.
virtual CSize | DrawShellIcon (CDC *pDC, CRect rcColumn, int iImage)
Draws the shell icon.
void | EnablePreviewMode (BOOL bIsPreviewMode)
Enables/disables preview mode for the control.
BOOL | IsPreviewMode () const
Determines if preview mode is enabled/disabled for the control.
CFont * | GetTextFont ()
Gets the default text font used for control items.
int | SetMaxPreviewLines (int nMaxLines)
Sets the maximum number of lines of text for a preview item.
int | GetMaxPreviewLines ()
Gets the maximum number of lines of text for a preview item.
int | GetPreviewLinesCount (CDC *pDC, CRect &rcText, const CString &strText)
Calculates the number of lines required to draw a specified preview text string, taking into account the maximum number of lines of text for a preview item.
BOOL | IsGridVisible (BOOL bVertical) const
Determines the visibility of specified grid lines.
BOOL | IsGridVisible (XTPGridOrientation orientation) const
Determines the visibility of specified grid lines.
void | SetColumnStyle (XTPGridColumnStyle columnStyle)
Sets the header style.
XTPGridColumnStyle | GetColumnStyle () const
Gets the header style.
void | SetColumnOffice2007CustomThemeBaseColor (COLORREF clrBaseColor)
Sets the header's custom theme base color for Office2007 column style.
COLORREF | GetColumnOffice2007CustomThemeBaseColor () const
Gets the header's custom theme base color for Office2007 column style.
void | SetTextFont (LOGFONT &lf)
Creates and sets the default text font.
void | SetCaptionFont (LOGFONT &lf)
Creates and sets the default caption font.
void | SetPreviewIndent (int nLeft, int nTop, int nRight, int nBottom)
Sets the preview item indent.
virtual void | DrawInplaceButton (CDC *pDC, CXTPGridInplaceButton *pButton)
Draws the in-place button of the Grid control.
virtual BOOL | DrawInplaceComboButton (CDC *pDC, CRect *pRc)
Draws the combo button of the Grid control.
virtual BOOL | DrawInplaceExpandButton (CDC *pDC, CRect *pRc)
Draws the expand button of the Grid control.
virtual BOOL | DrawInplaceSpinButton (CDC *pDC, CRect *pRc)
Draws the spin button of the Grid control.
virtual void | DrawTreeStructure (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CRect rcItem, CSize sizeGlyph)
Draws tree elements of the Grid control.
virtual void | DrawItemBitmap (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CRect &rcItem, int nImage)
Draws an item bitmap.
virtual void | DrawItemCaption (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics)
Draws an item caption.
virtual void | DrawRowNumber (CDC *pDC, CRect rcNumber, CXTPGridRow *pRow)
Draws a row number.
virtual void | DrawItemControl (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CXTPGridRecordItemControl *pControl, CRect &rcItem)
Draws an item control.
BOOL | IsFixedRowHeight () const
Determines if the paint manager supports fixed or variable row height.
void | SetFixedRowHeight (BOOL bFixedRowHeight)
Sets if the paint manager supports fixed or variable row height.
BOOL | IsColumnWidthWYSIWYG () const
Determines if the paint manager supports column width WYSIWYG mode.
BOOL | IsLastColumnWidthWYSIWYG () const
Determines if the paint manager supports last column width WYSIWYG mode.
BOOL | IsShowWYSIWYGMarkers () const
Determines if the paint manager shows WYSIWYG page-end markers.
void | ShowWYSIWYGMarkers (BOOL bSet)
Sets if the paint manager shows WYSIWYG page-end markers.
void | SetColumnWidthWYSIWYG (BOOL bColumnWidthWYSIWYG)
Sets if the paint manager supports column width WYSIWYG mode.
void | SetLastColumnWidthWYSIWYG (BOOL bColumnWidthWYSIWYG)
Sets if the paint manager supports last column width WYSIWYG mode.
BOOL | IsFixedInplaceButtonHeight () const
Determines if the paint manager supports fixed or variable in-place button height.
void | SetInplaceButtonHeight (BOOL bFixedInplaceButtonHeight)
Sets if the paint manager supports fixed or variable in-place button height.
int | GetFreezeColsDividerStyle () const
Gets the style of the freeze columns divider line.
void | SetFreezeColsDividerStyle (int nStyle)
Sets the style for the freeze columns divider line.
virtual BOOL | OnDrawAction (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs)
Override this method to perform custom activities for the item before processing it.
virtual void | DrawNoGroupByText (CDC *pDC, CRect rcItem)
Draws the "No items" text message in the Group By area when there are no items inside it.
BOOL | IsDrawGridForEmptySpace () const
Determines if the grid fills empty space after body rows.
void | SetDrawGridForEmptySpace (BOOL bDrawGrid)
Sets if the grid fills empty space after body rows.
BOOL | IsPrintGroupRowIcon () const
Determines if the group row collapse-expand icon is drawn in print mode.
void | SetPrintGroupRowIcon (BOOL bDraw)
Sets if the group row collapse-expand icon is drawn in print mode.
BOOL | IsColumnPlusMinusSign () const
Determines if columns use expand/collapse icons (+/-) or directional arrows.
void | SetColumnPlusMinusSign (BOOL bDraw)
Specifies if columns use expand/collapse icons (+/-) or directional arrows.
virtual int | CalculateRowHeight (CDC *pDC, const CString &strText, int nMaxWidth, BOOL bWordBreak=TRUE)
Calculates the height required for a rectangle bounding multi-line text to draw the multi-line text when the width of the rectangle is fixed.
void | DrawSectionDivider (CDC *pDC, const CRect &rc, XTPGridSectionDividerPosition dividerPosition, XTPGridSectionDividerStyle dividerStyle, CXTPPaintManagerColor dividerColor)
Draws the divider between grid sections (e.g.
int | GetSectionDividerHeight (XTPGridFixedRowsDividerStyle dividerStyle)
Gets the height of the section divider.
BOOL | IsUseDropMarker () const
Determines if a drop marker will be used when dragging and dropping.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPGridThemeOffice2013
CXTPPaintManagerColor | m_clrGlyph
Header glyph color.
CXTPPaintManagerColor | m_clrGlyphHighlight
Header highlighted glyph color.
CXTPPaintManagerColor | m_clrGlyphExpand
Expand glyph color.
CXTPPaintManagerColor | m_clrGlyphBorder
Expand glyph border color.
CXTPPaintManagerColor | m_clrGlyphContract
Contract glyph color.
- Public Attributes inherited from CXTPGridPaintManager
CXTPFont | m_xtpFontText
Grid items default text.
CXTPFont | m_xtpFontBoldText
Grid items default bold text.
CXTPFont | m_xtpFontCaption
Column header caption font.
CXTPFont | m_xtpFontPreview
Column header caption font.
CXTPGridHyperlinkStyle * | m_pHyperlinkStyle
Style for links.
CXTPGridHyperlinkStyle * | m_pHyperlinkHoverStyle
Style for hovered links.
CXTPPaintManagerColor | m_clrHighlight
Background color of the highlighted row.
CXTPPaintManagerColor | m_clrBoldText
Grid items bold text color.
CXTPPaintManagerColor | m_clrBoldTextHighlight
Grid items bold text highlight color.
CXTPPaintManagerColor | m_clrWindowText
Grid items default text color.
CXTPPaintManagerColor | m_clrHighlightText
Text color of the highlighted text.
CXTPPaintManagerColor | m_clrHeaderControl
Background color of the grid header.
CXTPPaintManagerColor | m_clrCaptionText
Column header text color.
CXTPPaintManagerColor | m_clrCaptionTextPressed
Column header text color when pressed.
CXTPPaintManagerColor | m_clrControlBack
Background color of the control grid area.
CXTPPaintManagerColor | m_clrGroupRowText
Row text color.
CXTPPaintManagerColor | m_clrGroupShadeBack
Group row background color when indentation shade is enabled.
CXTPPaintManagerColor | m_clrGroupShadeText
Group row foreground color when indentation shade is enabled.
CXTPPaintManagerColor | m_clrGroupShadeBorder
Color for group border's shade.
CXTPPaintManagerColor | m_clrGroupBoxBack
Color of group box.
CXTPPaintManagerColor | m_clrControlDark
Dark background color of the Grid control (used on Group By area).
CXTPPaintManagerColor | m_clrControlLightLight
Light background color used for drawing shades (used on column header area).
CXTPPaintManagerColor | m_clrHotDivider
Color of the column hot divider window (two arrows).
CXTPPaintManagerColor | m_clrIndentControl
Color of the tree indentation area.
CXTPPaintManagerColor | m_clrItemShade
Color of the shade on sorted by column items.
CXTPPaintManagerColor | m_clrBtnFace
Standard button face color.
CXTPPaintManagerColor | m_clrBtnText
Standard button text color.
CXTPPaintManagerColor | m_clrPreviewText
Preview text color.
CXTPPaintManagerColor | m_clrSelectedRow
Selected row background color.
CXTPPaintManagerColor | m_clrSelectedRowText
Selected row text color.
CXTPPaintManagerColor | m_clrBtnFacePressed
Standard button face color when pressed.
CXTPPaintManagerColor | m_clrConnector
Header column connector line color.
CXTPPaintManagerColor | m_clrDisableBitmapLightest
The lightest color of bitmap which covers disabled grid.
CXTPPaintManagerColor | m_clrDisableBitmapDarkest
The darkest color of bitmap which covers disabled grid.
CXTPPaintManagerColorGradient | m_grcGradientColumn
Color of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColorGradient | m_grcGradientColumnHot
HotTracking Color of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColorGradient | m_grcGradientColumnPushed
Pushed Color of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColor | m_clrGradientColumnShadow
Bottom shadow of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColor | m_clrGradientColumnSeparator
Separator of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColor | m_crlNoGroupByText
A color for "No items" text in GroupBy area (see m_strNoGroupBy member).
CXTPPaintManagerColor | m_clrFreezeColsDivider
Freeze Columns Divider color.
COLORREF | m_clrColumnOffice2007CustomTheme
Base color for Office2007 custom theme.
COLORREF | m_clrFormulaSum
Color for Formula Sum fields.
COLORREF | m_clrFormulaSubSum
Color for Formula SubSum fields.
COLORREF | m_clrAlternativeBackground
Color for Alternative Row Background.
BOOL | m_bUseAlternativeBackground
TRUE to use Alternative Row Background, FALSE otherwise.
BOOL | m_bAllowMergeCells
TRUE to Allow Merge Cells, FALSE otherwise.
int | m_nTextIndentForGroupRowsWithNoIcon
Specifies Text indent if a group row icon is not used.
int | m_nTreeIndent
Tree indentation.
int | m_nTreeStructureStyle
Tree structure style.
int | m_nTreeTextIndentRowParent
Text indent, in pixels, for rows with children.
int | m_nTreeTextIndentRowChildren
Text indent, in pixels, for rows without children.
int | m_nTreeTextIndent
Text indent, in pixels, for rows that are neither parent nor children.
int | m_nTreeTextIndentGroupRow
Text indent, in pixels, for group rows.
BOOL | m_bGroupRowTextBold
TRUE to draw group rows with bold text.
BOOL | m_bShadeGroupHeadings
TRUE to show the indentation shade, FALSE otherwise.
BOOL | m_bShadeSortColumn
TRUE to show the items shade in the sorted by column, FALSE otherwise.
BOOL | m_bHotTracking
TRUE to allow column hot tracking.
BOOL | m_bInvertColumnOnClick
TRUE to invert column on click.
CString | m_strNoItems
A string which contains customized "No Items" text for displaying in view when there are no visible rows.
CString | m_strSortBy
A string which contains customized "Sort By" text for displaying in tooltip.
CString | m_strIncreasing
A string which contains customized "Increasing" text for displaying in tooltip.
CString | m_strDecreasing
A string which contains customized "Decreasing" text for displaying in tooltip.
CString | m_strNoGroupBy
A string which contains customized "No items" text message for displaying in Group By area when there are no items inside it.
CString | m_strNoFieldsAvailable
A string which contains customized "No Fields Available" text message for displaying in Field Chooser.
CString | m_strExpand
A string which contains customized "Expand" text for displaying in tooltip.
CString | m_strCollapse
A string which contains customized "Collapse" text for displaying in tooltip.
BOOL | m_bHideSelection
TRUE when hiding Grid control's selection by drawing selected items as others, FALSE otherwise.
BOOL | m_bPrintSortTriangle
TRUE to show the sort triangle in printout.
BOOL | m_bRevertAlignment
TRUE to revert column alignments.
BOOL | m_bUseEditTextAlignment
TRUE to automatically apply edit alignment using column alignment.
BOOL | m_bShowLockIcon
TRUE to show the lock icon, FALSE to hide.
BOOL | m_bUseShellIcon
TRUE to use the shell icon, FALSE otherwise.
int | m_iRecOrRowStart
Start position in numbering (0 or 1 or something user want).
BOOL | m_bRecOrRowNum
TRUE to display record number if support mode is used, FALSE to display row number.
BOOL | m_bMakeUpper
TRUE to display column header and group row text in all caps.
XTPGridTreeStructureStyle | m_treeStructureStyle
Tree structure style.
CRect | m_rcPreviewIndent
Preview indentation.
int | m_nFixedColumnsIndent
Fixed Column total width.
BOOL | m_bMoveScrollbarOnFixedColumnsIndent
Move Scrollbar right follow FixedColumnsIndent.
BOOL | m_bThemedInplaceButtons
Draw in-place buttons using current theme settings.
BOOL | m_bBaseTreeIndent
TRUE to add Extra Tree indentation to cover initial TreeColumn.
CUIntArray | m_arStartCol
Start column in each virtual page.
int | m_PrintPageWidth
Width of print page (run-time)
BOOL | m_bPrintVirtualPageNumber
TRUE to print horizontal page number.
BOOL | m_bPrintPageRectangle
TRUE to draw rectangle around page.
int | m_RecordNumberWidth
Column width for row/record numbers.
BOOL | m_bForceDynamicMarkupForCell
TRUE if use Markup for Grid Record Item.
BOOL | m_bForceShowDropMarker
TRUE if Force Show Drop Marker.
BOOL | m_bShowNonActiveInPlaceButton
TRUE if use Show Non-Active In-Place Button (Combo, Expand, Spin).
BOOL | m_bPrintWatermark
TRUE to print watermark.
BOOL | m_bUseGroupRowSelectionState
TRUE if use GroupSelectionState Glyph.
BOOL | m_bForceShowTooltip
TRUE if use show tooltip for any cell width case.
BOOL | m_bCleanTooltip
TRUE if use show tooltip without markup.
BOOL | m_bGrayIfDisable
TRUE is disable draw in gray (standard behavior).
int | m_nRowHeightDefault
The default row height.
BOOL | m_bCompactText
TRUE to ignore Icon for Narrow column to show more text.
BOOL | m_bUseDropMarker
FALSE to not draw drop marked when dragging/dropping, TRUE by default.
BOOL | m_bSortTriangleOffsetFromRight
Offset of sort triangle.
int | m_nTreeColumnLineLength
This is the extra line length to apply to tree column lines if there is no expand button.
int | m_nBaseParentRecordIndent
This is initial number of pixels a parent node will be indented when in a group.
- Protected Member Functions inherited from CXTPGridPaintManager
virtual void | DrawTextLine (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nFlag, int &nCharCounter, int &nHyperlinkCounter)
Draws a line of text with respect to the drawing rectangle.
virtual int | DrawString (int *pnCurrDrawPos, CDC *pDC, const CString &strDraw, CRect rcDraw, UINT nFormat)
Draw a simple string into rectangle.
virtual void | DrawGridPattern (CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush)
Generates a custom grid pattern if necessary.
virtual void | DrawGridPattern (CDC *pDC, CXTPBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush)
Generates a custom grid pattern if necessary.
virtual void | DrawGridPattern (CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr)
Generates a custom grid pattern.
virtual void | DrawInplaceButtonFrame (CDC *pDC, CXTPGridInplaceButton *pButton)
Draws the in-place button frame.
virtual BOOL | DrawInplaceButtonIcon (CDC *pDC, CXTPGridInplaceButton *pButton)
Draws the in-place button icon.
virtual int | CalcColumnHeight (CDC *pDC, CXTPGridColumn *pColumn, int nTotalWidth=0)
Calculates the optimal height for a specified column.
virtual void | DrawMultiLineText (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, BOOL bWordBreak=TRUE)
Draws multi-line text.
virtual void | DrawSingleLineText (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nStartPos, int nEndPos, int nActualWidth)
Draws single-line text.
virtual int | DrawLink (int *pnCurrDrawPos, XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CXTPGridHyperlink *pHyperlink, CString strText, CRect rcLink, int nFlag, BOOL bTrim=FALSE)
Draws a hyperlink string using hyperlink text settings (i.e.
- Protected Attributes inherited from CXTPGridPaintManager
int | m_nRowHeight
Grid row default height.
int | m_nHeaderHeight
Column header height.
int | m_nFooterHeight
Column footer height.
int | m_nGroupGridLineHeight
The height of the group grid line.
CXTPImageManager * | m_pGlyphs
An additional image list for the Grid control.
BOOL | m_bIsPreviewMode
TRUE to show the item preview, FALSE to hide.
int | m_nResizingWidth
The width of the column resizing marker area.
int | m_nMaxPreviewLines
Restrict maximum lines for preview text.
CSize | m_szGlyph
Glyph size.
CXTPBrush | m_xtpBrushTreeStructure
Brush to draw tree nodes.
CXTPBrush | m_xtpBrushGroupGridLineStyle
Brush to draw group row grid lines.
int | m_nFreezeColsDividerStyle
A set of flags from XTPGridFreezeColsDividerStyle.
BOOL | m_bFixedRowHeight
TRUE if fixed rows used.
BOOL | m_bColumnWidthWYSIWYG
TRUE if columns width WYSIWYG mode used.
BOOL | m_bShowWYSIWYGMarkers
TRUE if in non-print mode header show red page-end markers.
BOOL | m_bLastColumnWidthWYSIWYG
TRUE if last column width WYSIWYG mode used.
BOOL | m_bDrawGridForEmptySpace
TRUE if grid fills the empty space (if any) after the body rows.
BOOL | m_bPrintGroupRowIcon
TRUE if printout draw collapse-expand icon for group row.
BOOL | m_bColumnPlusMinusSign
TRUE if expand/collapse icons are used, FALSE if directional arrows are used.
BOOL | m_bFixedInplaceButtonHeight
TRUE if fixed in-place button height is used.
XTPGridGridStyle | m_nGroupGridLineStyle
Current style for group row grid lines.
XTPGridColumnStyle | m_columnStyle
Column drawing style.
CXTPWinThemeWrapper * | m_themeHeader
Header theme wrapper.
CXTPWinThemeWrapper * | m_themeButton
In-place button theme wrapper.
CXTPWinThemeWrapper * | m_themeCombo
Combo box in-place button theme wrapper.
CXTPWinThemeWrapper * | m_themeSpin
Spin in-place button theme wrapper.
CXTPGridControl * | m_pControl
Pointer to the Grid control object.
CXTPMarkupUIElement * | m_pMarkupUIElement_NoGroupBy
The no group by markup UI element.
CString | m_strMarkupUIElement_NoGroupBy
The no group by markup UI element string.
CXTPBrush | m_xtpBrushVeriticalGrid
Brush to draw vertical grid lines.
CXTPBrush | m_xtpBrushHorizontalGrid
Brush to draw horizontal grid lines.
XTPGridGridStyle m_nGridLineStylePreviousV
Previous style for vertical grid lines.
XTPGridGridStyle m_nGridLineStylePreviousH
Previous style for horizontal grid lines.

Detailed Description

CXTPGridThemeVisualStudio2015 is a CXTPGridThemeOffice2013 derived class that represents a Visual Studio 2015 style theme.

The documentation for this class was generated from the following file:
  • XTPGridThemeVisualStudio2015.h


Toolkit Pro: CXTPGridThemeVisualStudio2017 Class Reference

Public Member Functions | List of all members
CXTPGridThemeVisualStudio2017 Class Reference

CXTPGridThemeVisualStudio2017 is a CXTPGridThemeOffice2013 derived class that represents a Visual Studio 2017 style theme. More...

Inheritance diagram for CXTPGridThemeVisualStudio2017:
[legend]

Public Member Functions

CXTPGridThemeVisualStudio2017 ()
Default paint manager constructor, handles properties initialization.
virtual void | RefreshMetrics ()
This method is called to refresh the visual metrics of the Grid control.
- Public Member Functions inherited from CXTPGridThemeOffice2013
CXTPGridThemeOffice2013 ()
Default paint manager constructor, handles properties initialization.
virtual void | LoadGlyphs ()
Loads the default images used by the Grid control.
virtual void | DrawColumnText (CDC *pDC, CRect rcText, CString strCaption, int nHeaderAlignment, BOOL bIsHeader, BOOL bColumnPressed)
Draws text for the column header.
virtual void | DrawColumnBackground (CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, BOOL &bColumnPressed, BOOL &bDraggingFromHeader, CXTPGridHeader *pHeader=NULL)
This method is called to draw the background of a column using the current column style.
virtual void | DrawTriangle (CDC *pDC, CRect rcTriangle, BOOL bToDown, BOOL bDraggingFromHeader, int nShadowWidth, BOOL bColumnPressed)
Draws a triangle that shows the sort order of the column.
virtual CSize | DrawCollapsedBitmap (CDC *pDC, const CXTPGridRow *pRow, CRect &rcBitmap)
Draws a collapsed bitmap.
virtual void | FillGroupRowMetrics (CXTPGridGroupRow *pRow, XTP_GRIDRECORDITEM_METRICS *pMetrics, BOOL bPrinting)
Fills the font and color members of the metrics structure for a specified group row.
virtual void | DrawGroupRow (CDC *pDC, CXTPGridGroupRow *pRow, CRect rcRow, XTP_GRIDRECORDITEM_METRICS *pMetrics)
Draws a group row.
virtual void | DrawFocusedRow (CDC *pDC, CRect rcRow)
Draws focused rows.
virtual int | GetRowHeight (CDC *pDC, CXTPGridRow *pRow)
Retrieves the default row height for print mode (i.e.
virtual int | GetRowHeight (CDC *pDC, CXTPGridRow *pRow, int nTotalWidth)
Retrieves the default row height for print mode (i.e.
- Public Member Functions inherited from CXTPGridPaintManager
CXTPGridPaintManager ()
Default CXTPGridPaintManager constructor, handles properties initialization.
virtual | ~CXTPGridPaintManager ()
Default CXTPGridPaintManager destructor, handles member items deallocation.
virtual void | SetGridControl (CXTPGridControl *pControl)
Sets the associated Grid control for the paint manager.
int | GetRowHeightEx (CDC *pDC, CXTPGridRow *pRow, int nTotalWidth, const BOOL firstLevel=TRUE)
Retrieves the default row height for print mode (i.e.
int | GetItemHeight (XTP_GRIDRECORDITEM_DRAWARGS &drawArgs, int nWidth)
Retrieves the height of a record item for a given width.
BOOL | FindRowAdjacentToMergedEx (const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, int &nAdjRowIndex, BOOL bUpward)
Searches the topmost or bottommost row depending on the height of the current row.
int | FindRowAdjacentToMerged (const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, BOOL bUpward)
Wrapper for the FindRowAdjacentToMergedEx method.
int | RecalcTotalHightOfMergedRows (CXTPGridColumns *pColumns, CDC *pDC, CXTPGridRow *pRow, int nRowHeight, int nTotalWidth)
Recalculates row height according to the height of merged items.
virtual int | GetPreviewItemHeight (CDC *pDC, CXTPGridRow *pRow, int nWidth, int nHeight)
Retrieves the height of a preview item for print mode.
virtual int | GetHeaderHeight ()
Gets the column header height.
virtual int | GetHeaderHeight (CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0)
Calculates the optimal header height.
virtual void | SetHeaderHeight (int nHeight)
Sets the column header height.
virtual int | GetFooterHeight (CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0)
Calculates the optimal footer height.
virtual COLORREF | GetControlBackColor (CXTPGridControl *pControl)
Retrieves the parent Grid control's background color.
virtual void | FillRow (CDC *pDC, CXTPGridRow *pRow, CRect rcRow)
Fills a specified row with its background color.
virtual void | DrawGrid (CDC *pDC, XTPGridOrientation orientation, CRect rcGrid)
Draws a grid for the control.
virtual void | DrawFreezeColsDivider (CDC *pDC, const CRect &rc, CXTPGridControl *pControl, CXTPGridRow *pRow=NULL)
Draws a freeze column divider.
virtual void | DrawVerticalTimeLineMarker (CDC *pDC, int xPos, CXTPGridControl *pControl, COLORREF color=RGB(0, 255, 0))
Draws a vertical timeline marker.
virtual void | FillIndent (CDC *pDC, CRect rcRow)
Fills an indent area by its background.
virtual void | FillItemShade (CDC *pDC, CRect rcItem)
Fills an item shade by its background if necessary.
virtual void | FillHeaderControl (CDC *pDC, CRect rcHeader)
Fills a column header control area by its background.
virtual void | FillFooter (CDC *pDC, CRect rcFooter)
Fills a column footer control area by its background.
virtual void | DrawColumn (CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn, BOOL bDrawExternal=FALSE, int nShadowWidth=0)
Draws a column header with all related attributes (sort order, icon, etc.).
virtual void | DrawColumnFooterDivider (CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn)
Draws the column footer divider.
virtual void | DrawColumnFooter (CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn)
Draws the column footer with all related attributes (e.g.
virtual BOOL | IsColumHotTrackingEnabled () const
Determines if hot tracking is enabled for the current column style.
virtual void | FillGroupByControl (CDC *pDC, CRect &rcGroupBy)
Draws the Group By box.
CXTPImageManager * | GetGlyphs () const
Gets a pointer to the additional image list with glyphs.
void | DrawHorizontalLine (CDC *pDC, int xPos, int yPos, int cx, COLORREF clr)
Draws a horizontal line.
void | DrawVerticalLine (CDC *pDC, int xPos, int yPos, int cy, COLORREF clr)
Draws a vertical line.
void | DrawConnector (CDC *pDC, CPoint ptFrom, CPoint ptTo)
Draws a column connector for the Group By box.
virtual int | DrawBitmap (CDC *pDC, CXTPGridControl *pControl, CRect rcColumn, int iImage)
Draws a bitmap.
virtual int | DrawColumnIcon (CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, CRect rcIcon, int iIcon)
Draws an icon for a column.
virtual CSize | DrawGlyph (CDC *pDC, CRect rcColumn, int iImage)
Draws the standard glyphs of the Grid control.
virtual CSize | DrawShellIcon (CDC *pDC, CRect rcColumn, int iImage)
Draws the shell icon.
void | EnablePreviewMode (BOOL bIsPreviewMode)
Enables/disables preview mode for the control.
BOOL | IsPreviewMode () const
Determines if preview mode is enabled/disabled for the control.
CFont * | GetTextFont ()
Gets the default text font used for control items.
int | SetMaxPreviewLines (int nMaxLines)
Sets the maximum number of lines of text for a preview item.
int | GetMaxPreviewLines ()
Gets the maximum number of lines of text for a preview item.
int | GetPreviewLinesCount (CDC *pDC, CRect &rcText, const CString &strText)
Calculates the number of lines required to draw a specified preview text string, taking into account the maximum number of lines of text for a preview item.
BOOL | IsGridVisible (BOOL bVertical) const
Determines the visibility of specified grid lines.
BOOL | IsGridVisible (XTPGridOrientation orientation) const
Determines the visibility of specified grid lines.
void | SetColumnStyle (XTPGridColumnStyle columnStyle)
Sets the header style.
XTPGridColumnStyle | GetColumnStyle () const
Gets the header style.
void | SetColumnOffice2007CustomThemeBaseColor (COLORREF clrBaseColor)
Sets the header's custom theme base color for Office2007 column style.
COLORREF | GetColumnOffice2007CustomThemeBaseColor () const
Gets the header's custom theme base color for Office2007 column style.
void | SetTextFont (LOGFONT &lf)
Creates and sets the default text font.
void | SetCaptionFont (LOGFONT &lf)
Creates and sets the default caption font.
void | SetPreviewIndent (int nLeft, int nTop, int nRight, int nBottom)
Sets the preview item indent.
virtual void | DrawInplaceButton (CDC *pDC, CXTPGridInplaceButton *pButton)
Draws the in-place button of the Grid control.
virtual BOOL | DrawInplaceComboButton (CDC *pDC, CRect *pRc)
Draws the combo button of the Grid control.
virtual BOOL | DrawInplaceExpandButton (CDC *pDC, CRect *pRc)
Draws the expand button of the Grid control.
virtual BOOL | DrawInplaceSpinButton (CDC *pDC, CRect *pRc)
Draws the spin button of the Grid control.
virtual void | DrawTreeStructure (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CRect rcItem, CSize sizeGlyph)
Draws tree elements of the Grid control.
virtual void | DrawItemBitmap (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CRect &rcItem, int nImage)
Draws an item bitmap.
virtual void | DrawItemCaption (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics)
Draws an item caption.
virtual void | DrawRowNumber (CDC *pDC, CRect rcNumber, CXTPGridRow *pRow)
Draws a row number.
virtual void | DrawItemControl (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CXTPGridRecordItemControl *pControl, CRect &rcItem)
Draws an item control.
BOOL | IsFixedRowHeight () const
Determines if the paint manager supports fixed or variable row height.
void | SetFixedRowHeight (BOOL bFixedRowHeight)
Sets if the paint manager supports fixed or variable row height.
BOOL | IsColumnWidthWYSIWYG () const
Determines if the paint manager supports column width WYSIWYG mode.
BOOL | IsLastColumnWidthWYSIWYG () const
Determines if the paint manager supports last column width WYSIWYG mode.
BOOL | IsShowWYSIWYGMarkers () const
Determines if the paint manager shows WYSIWYG page-end markers.
void | ShowWYSIWYGMarkers (BOOL bSet)
Sets if the paint manager shows WYSIWYG page-end markers.
void | SetColumnWidthWYSIWYG (BOOL bColumnWidthWYSIWYG)
Sets if the paint manager supports column width WYSIWYG mode.
void | SetLastColumnWidthWYSIWYG (BOOL bColumnWidthWYSIWYG)
Sets if the paint manager supports last column width WYSIWYG mode.
BOOL | IsFixedInplaceButtonHeight () const
Determines if the paint manager supports fixed or variable in-place button height.
void | SetInplaceButtonHeight (BOOL bFixedInplaceButtonHeight)
Sets if the paint manager supports fixed or variable in-place button height.
int | GetFreezeColsDividerStyle () const
Gets the style of the freeze columns divider line.
void | SetFreezeColsDividerStyle (int nStyle)
Sets the style for the freeze columns divider line.
virtual BOOL | OnDrawAction (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs)
Override this method to perform custom activities for the item before processing it.
virtual void | DrawNoGroupByText (CDC *pDC, CRect rcItem)
Draws the "No items" text message in the Group By area when there are no items inside it.
BOOL | IsDrawGridForEmptySpace () const
Determines if the grid fills empty space after body rows.
void | SetDrawGridForEmptySpace (BOOL bDrawGrid)
Sets if the grid fills empty space after body rows.
BOOL | IsPrintGroupRowIcon () const
Determines if the group row collapse-expand icon is drawn in print mode.
void | SetPrintGroupRowIcon (BOOL bDraw)
Sets if the group row collapse-expand icon is drawn in print mode.
BOOL | IsColumnPlusMinusSign () const
Determines if columns use expand/collapse icons (+/-) or directional arrows.
void | SetColumnPlusMinusSign (BOOL bDraw)
Specifies if columns use expand/collapse icons (+/-) or directional arrows.
virtual int | CalculateRowHeight (CDC *pDC, const CString &strText, int nMaxWidth, BOOL bWordBreak=TRUE)
Calculates the height required for a rectangle bounding multi-line text to draw the multi-line text when the width of the rectangle is fixed.
void | DrawSectionDivider (CDC *pDC, const CRect &rc, XTPGridSectionDividerPosition dividerPosition, XTPGridSectionDividerStyle dividerStyle, CXTPPaintManagerColor dividerColor)
Draws the divider between grid sections (e.g.
int | GetSectionDividerHeight (XTPGridFixedRowsDividerStyle dividerStyle)
Gets the height of the section divider.
BOOL | IsUseDropMarker () const
Determines if a drop marker will be used when dragging and dropping.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPGridThemeOffice2013
CXTPPaintManagerColor | m_clrGlyph
Header glyph color.
CXTPPaintManagerColor | m_clrGlyphHighlight
Header highlighted glyph color.
CXTPPaintManagerColor | m_clrGlyphExpand
Expand glyph color.
CXTPPaintManagerColor | m_clrGlyphBorder
Expand glyph border color.
CXTPPaintManagerColor | m_clrGlyphContract
Contract glyph color.
- Public Attributes inherited from CXTPGridPaintManager
CXTPFont | m_xtpFontText
Grid items default text.
CXTPFont | m_xtpFontBoldText
Grid items default bold text.
CXTPFont | m_xtpFontCaption
Column header caption font.
CXTPFont | m_xtpFontPreview
Column header caption font.
CXTPGridHyperlinkStyle * | m_pHyperlinkStyle
Style for links.
CXTPGridHyperlinkStyle * | m_pHyperlinkHoverStyle
Style for hovered links.
CXTPPaintManagerColor | m_clrHighlight
Background color of the highlighted row.
CXTPPaintManagerColor | m_clrBoldText
Grid items bold text color.
CXTPPaintManagerColor | m_clrBoldTextHighlight
Grid items bold text highlight color.
CXTPPaintManagerColor | m_clrWindowText
Grid items default text color.
CXTPPaintManagerColor | m_clrHighlightText
Text color of the highlighted text.
CXTPPaintManagerColor | m_clrHeaderControl
Background color of the grid header.
CXTPPaintManagerColor | m_clrCaptionText
Column header text color.
CXTPPaintManagerColor | m_clrCaptionTextPressed
Column header text color when pressed.
CXTPPaintManagerColor | m_clrControlBack
Background color of the control grid area.
CXTPPaintManagerColor | m_clrGroupRowText
Row text color.
CXTPPaintManagerColor | m_clrGroupShadeBack
Group row background color when indentation shade is enabled.
CXTPPaintManagerColor | m_clrGroupShadeText
Group row foreground color when indentation shade is enabled.
CXTPPaintManagerColor | m_clrGroupShadeBorder
Color for group border's shade.
CXTPPaintManagerColor | m_clrGroupBoxBack
Color of group box.
CXTPPaintManagerColor | m_clrControlDark
Dark background color of the Grid control (used on Group By area).
CXTPPaintManagerColor | m_clrControlLightLight
Light background color used for drawing shades (used on column header area).
CXTPPaintManagerColor | m_clrHotDivider
Color of the column hot divider window (two arrows).
CXTPPaintManagerColor | m_clrIndentControl
Color of the tree indentation area.
CXTPPaintManagerColor | m_clrItemShade
Color of the shade on sorted by column items.
CXTPPaintManagerColor | m_clrBtnFace
Standard button face color.
CXTPPaintManagerColor | m_clrBtnText
Standard button text color.
CXTPPaintManagerColor | m_clrPreviewText
Preview text color.
CXTPPaintManagerColor | m_clrSelectedRow
Selected row background color.
CXTPPaintManagerColor | m_clrSelectedRowText
Selected row text color.
CXTPPaintManagerColor | m_clrBtnFacePressed
Standard button face color when pressed.
CXTPPaintManagerColor | m_clrConnector
Header column connector line color.
CXTPPaintManagerColor | m_clrDisableBitmapLightest
The lightest color of bitmap which covers disabled grid.
CXTPPaintManagerColor | m_clrDisableBitmapDarkest
The darkest color of bitmap which covers disabled grid.
CXTPPaintManagerColorGradient | m_grcGradientColumn
Color of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColorGradient | m_grcGradientColumnHot
HotTracking Color of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColorGradient | m_grcGradientColumnPushed
Pushed Color of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColor | m_clrGradientColumnShadow
Bottom shadow of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColor | m_clrGradientColumnSeparator
Separator of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColor | m_crlNoGroupByText
A color for "No items" text in GroupBy area (see m_strNoGroupBy member).
CXTPPaintManagerColor | m_clrFreezeColsDivider
Freeze Columns Divider color.
COLORREF | m_clrColumnOffice2007CustomTheme
Base color for Office2007 custom theme.
COLORREF | m_clrFormulaSum
Color for Formula Sum fields.
COLORREF | m_clrFormulaSubSum
Color for Formula SubSum fields.
COLORREF | m_clrAlternativeBackground
Color for Alternative Row Background.
BOOL | m_bUseAlternativeBackground
TRUE to use Alternative Row Background, FALSE otherwise.
BOOL | m_bAllowMergeCells
TRUE to Allow Merge Cells, FALSE otherwise.
int | m_nTextIndentForGroupRowsWithNoIcon
Specifies Text indent if a group row icon is not used.
int | m_nTreeIndent
Tree indentation.
int | m_nTreeStructureStyle
Tree structure style.
int | m_nTreeTextIndentRowParent
Text indent, in pixels, for rows with children.
int | m_nTreeTextIndentRowChildren
Text indent, in pixels, for rows without children.
int | m_nTreeTextIndent
Text indent, in pixels, for rows that are neither parent nor children.
int | m_nTreeTextIndentGroupRow
Text indent, in pixels, for group rows.
BOOL | m_bGroupRowTextBold
TRUE to draw group rows with bold text.
BOOL | m_bShadeGroupHeadings
TRUE to show the indentation shade, FALSE otherwise.
BOOL | m_bShadeSortColumn
TRUE to show the items shade in the sorted by column, FALSE otherwise.
BOOL | m_bHotTracking
TRUE to allow column hot tracking.
BOOL | m_bInvertColumnOnClick
TRUE to invert column on click.
CString | m_strNoItems
A string which contains customized "No Items" text for displaying in view when there are no visible rows.
CString | m_strSortBy
A string which contains customized "Sort By" text for displaying in tooltip.
CString | m_strIncreasing
A string which contains customized "Increasing" text for displaying in tooltip.
CString | m_strDecreasing
A string which contains customized "Decreasing" text for displaying in tooltip.
CString | m_strNoGroupBy
A string which contains customized "No items" text message for displaying in Group By area when there are no items inside it.
CString | m_strNoFieldsAvailable
A string which contains customized "No Fields Available" text message for displaying in Field Chooser.
CString | m_strExpand
A string which contains customized "Expand" text for displaying in tooltip.
CString | m_strCollapse
A string which contains customized "Collapse" text for displaying in tooltip.
BOOL | m_bHideSelection
TRUE when hiding Grid control's selection by drawing selected items as others, FALSE otherwise.
BOOL | m_bPrintSortTriangle
TRUE to show the sort triangle in printout.
BOOL | m_bRevertAlignment
TRUE to revert column alignments.
BOOL | m_bUseEditTextAlignment
TRUE to automatically apply edit alignment using column alignment.
BOOL | m_bShowLockIcon
TRUE to show the lock icon, FALSE to hide.
BOOL | m_bUseShellIcon
TRUE to use the shell icon, FALSE otherwise.
int | m_iRecOrRowStart
Start position in numbering (0 or 1 or something user want).
BOOL | m_bRecOrRowNum
TRUE to display record number if support mode is used, FALSE to display row number.
BOOL | m_bMakeUpper
TRUE to display column header and group row text in all caps.
XTPGridTreeStructureStyle | m_treeStructureStyle
Tree structure style.
CRect | m_rcPreviewIndent
Preview indentation.
int | m_nFixedColumnsIndent
Fixed Column total width.
BOOL | m_bMoveScrollbarOnFixedColumnsIndent
Move Scrollbar right follow FixedColumnsIndent.
BOOL | m_bThemedInplaceButtons
Draw in-place buttons using current theme settings.
BOOL | m_bBaseTreeIndent
TRUE to add Extra Tree indentation to cover initial TreeColumn.
CUIntArray | m_arStartCol
Start column in each virtual page.
int | m_PrintPageWidth
Width of print page (run-time)
BOOL | m_bPrintVirtualPageNumber
TRUE to print horizontal page number.
BOOL | m_bPrintPageRectangle
TRUE to draw rectangle around page.
int | m_RecordNumberWidth
Column width for row/record numbers.
BOOL | m_bForceDynamicMarkupForCell
TRUE if use Markup for Grid Record Item.
BOOL | m_bForceShowDropMarker
TRUE if Force Show Drop Marker.
BOOL | m_bShowNonActiveInPlaceButton
TRUE if use Show Non-Active In-Place Button (Combo, Expand, Spin).
BOOL | m_bPrintWatermark
TRUE to print watermark.
BOOL | m_bUseGroupRowSelectionState
TRUE if use GroupSelectionState Glyph.
BOOL | m_bForceShowTooltip
TRUE if use show tooltip for any cell width case.
BOOL | m_bCleanTooltip
TRUE if use show tooltip without markup.
BOOL | m_bGrayIfDisable
TRUE is disable draw in gray (standard behavior).
int | m_nRowHeightDefault
The default row height.
BOOL | m_bCompactText
TRUE to ignore Icon for Narrow column to show more text.
BOOL | m_bUseDropMarker
FALSE to not draw drop marked when dragging/dropping, TRUE by default.
BOOL | m_bSortTriangleOffsetFromRight
Offset of sort triangle.
int | m_nTreeColumnLineLength
This is the extra line length to apply to tree column lines if there is no expand button.
int | m_nBaseParentRecordIndent
This is initial number of pixels a parent node will be indented when in a group.
- Protected Member Functions inherited from CXTPGridPaintManager
virtual void | DrawTextLine (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nFlag, int &nCharCounter, int &nHyperlinkCounter)
Draws a line of text with respect to the drawing rectangle.
virtual int | DrawString (int *pnCurrDrawPos, CDC *pDC, const CString &strDraw, CRect rcDraw, UINT nFormat)
Draw a simple string into rectangle.
virtual void | DrawGridPattern (CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush)
Generates a custom grid pattern if necessary.
virtual void | DrawGridPattern (CDC *pDC, CXTPBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush)
Generates a custom grid pattern if necessary.
virtual void | DrawGridPattern (CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr)
Generates a custom grid pattern.
virtual void | DrawInplaceButtonFrame (CDC *pDC, CXTPGridInplaceButton *pButton)
Draws the in-place button frame.
virtual BOOL | DrawInplaceButtonIcon (CDC *pDC, CXTPGridInplaceButton *pButton)
Draws the in-place button icon.
virtual int | CalcColumnHeight (CDC *pDC, CXTPGridColumn *pColumn, int nTotalWidth=0)
Calculates the optimal height for a specified column.
virtual void | DrawMultiLineText (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, BOOL bWordBreak=TRUE)
Draws multi-line text.
virtual void | DrawSingleLineText (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nStartPos, int nEndPos, int nActualWidth)
Draws single-line text.
virtual int | DrawLink (int *pnCurrDrawPos, XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CXTPGridHyperlink *pHyperlink, CString strText, CRect rcLink, int nFlag, BOOL bTrim=FALSE)
Draws a hyperlink string using hyperlink text settings (i.e.
- Protected Attributes inherited from CXTPGridPaintManager
int | m_nRowHeight
Grid row default height.
int | m_nHeaderHeight
Column header height.
int | m_nFooterHeight
Column footer height.
int | m_nGroupGridLineHeight
The height of the group grid line.
CXTPImageManager * | m_pGlyphs
An additional image list for the Grid control.
BOOL | m_bIsPreviewMode
TRUE to show the item preview, FALSE to hide.
int | m_nResizingWidth
The width of the column resizing marker area.
int | m_nMaxPreviewLines
Restrict maximum lines for preview text.
CSize | m_szGlyph
Glyph size.
CXTPBrush | m_xtpBrushTreeStructure
Brush to draw tree nodes.
CXTPBrush | m_xtpBrushGroupGridLineStyle
Brush to draw group row grid lines.
int | m_nFreezeColsDividerStyle
A set of flags from XTPGridFreezeColsDividerStyle.
BOOL | m_bFixedRowHeight
TRUE if fixed rows used.
BOOL | m_bColumnWidthWYSIWYG
TRUE if columns width WYSIWYG mode used.
BOOL | m_bShowWYSIWYGMarkers
TRUE if in non-print mode header show red page-end markers.
BOOL | m_bLastColumnWidthWYSIWYG
TRUE if last column width WYSIWYG mode used.
BOOL | m_bDrawGridForEmptySpace
TRUE if grid fills the empty space (if any) after the body rows.
BOOL | m_bPrintGroupRowIcon
TRUE if printout draw collapse-expand icon for group row.
BOOL | m_bColumnPlusMinusSign
TRUE if expand/collapse icons are used, FALSE if directional arrows are used.
BOOL | m_bFixedInplaceButtonHeight
TRUE if fixed in-place button height is used.
XTPGridGridStyle | m_nGroupGridLineStyle
Current style for group row grid lines.
XTPGridColumnStyle | m_columnStyle
Column drawing style.
CXTPWinThemeWrapper * | m_themeHeader
Header theme wrapper.
CXTPWinThemeWrapper * | m_themeButton
In-place button theme wrapper.
CXTPWinThemeWrapper * | m_themeCombo
Combo box in-place button theme wrapper.
CXTPWinThemeWrapper * | m_themeSpin
Spin in-place button theme wrapper.
CXTPGridControl * | m_pControl
Pointer to the Grid control object.
CXTPMarkupUIElement * | m_pMarkupUIElement_NoGroupBy
The no group by markup UI element.
CString | m_strMarkupUIElement_NoGroupBy
The no group by markup UI element string.
CXTPBrush | m_xtpBrushVeriticalGrid
Brush to draw vertical grid lines.
CXTPBrush | m_xtpBrushHorizontalGrid
Brush to draw horizontal grid lines.
XTPGridGridStyle m_nGridLineStylePreviousV
Previous style for vertical grid lines.
XTPGridGridStyle m_nGridLineStylePreviousH
Previous style for horizontal grid lines.

Detailed Description

CXTPGridThemeVisualStudio2017 is a CXTPGridThemeOffice2013 derived class that represents a Visual Studio 2017 style theme.

The documentation for this class was generated from the following file:
  • XTPGridThemeVisualStudio2017.h


Toolkit Pro: CXTPGridThemeVisualStudio2019 Class Reference

Public Member Functions | List of all members
CXTPGridThemeVisualStudio2019 Class Reference

CXTPGridThemeVisualStudio2019 is a CXTPGridThemeOffice2013 derived class that represents a Visual Studio 2019 style theme. More...

Inheritance diagram for CXTPGridThemeVisualStudio2019:
[legend]

Public Member Functions

CXTPGridThemeVisualStudio2019 ()
Default paint manager constructor, handles properties initialization.
virtual void | RefreshMetrics ()
This method is called to refresh the visual metrics of the Grid control.
- Public Member Functions inherited from CXTPGridThemeOffice2013
CXTPGridThemeOffice2013 ()
Default paint manager constructor, handles properties initialization.
virtual void | LoadGlyphs ()
Loads the default images used by the Grid control.
virtual void | DrawColumnText (CDC *pDC, CRect rcText, CString strCaption, int nHeaderAlignment, BOOL bIsHeader, BOOL bColumnPressed)
Draws text for the column header.
virtual void | DrawColumnBackground (CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, BOOL &bColumnPressed, BOOL &bDraggingFromHeader, CXTPGridHeader *pHeader=NULL)
This method is called to draw the background of a column using the current column style.
virtual void | DrawTriangle (CDC *pDC, CRect rcTriangle, BOOL bToDown, BOOL bDraggingFromHeader, int nShadowWidth, BOOL bColumnPressed)
Draws a triangle that shows the sort order of the column.
virtual CSize | DrawCollapsedBitmap (CDC *pDC, const CXTPGridRow *pRow, CRect &rcBitmap)
Draws a collapsed bitmap.
virtual void | FillGroupRowMetrics (CXTPGridGroupRow *pRow, XTP_GRIDRECORDITEM_METRICS *pMetrics, BOOL bPrinting)
Fills the font and color members of the metrics structure for a specified group row.
virtual void | DrawGroupRow (CDC *pDC, CXTPGridGroupRow *pRow, CRect rcRow, XTP_GRIDRECORDITEM_METRICS *pMetrics)
Draws a group row.
virtual void | DrawFocusedRow (CDC *pDC, CRect rcRow)
Draws focused rows.
virtual int | GetRowHeight (CDC *pDC, CXTPGridRow *pRow)
Retrieves the default row height for print mode (i.e.
virtual int | GetRowHeight (CDC *pDC, CXTPGridRow *pRow, int nTotalWidth)
Retrieves the default row height for print mode (i.e.
- Public Member Functions inherited from CXTPGridPaintManager
CXTPGridPaintManager ()
Default CXTPGridPaintManager constructor, handles properties initialization.
virtual | ~CXTPGridPaintManager ()
Default CXTPGridPaintManager destructor, handles member items deallocation.
virtual void | SetGridControl (CXTPGridControl *pControl)
Sets the associated Grid control for the paint manager.
int | GetRowHeightEx (CDC *pDC, CXTPGridRow *pRow, int nTotalWidth, const BOOL firstLevel=TRUE)
Retrieves the default row height for print mode (i.e.
int | GetItemHeight (XTP_GRIDRECORDITEM_DRAWARGS &drawArgs, int nWidth)
Retrieves the height of a record item for a given width.
BOOL | FindRowAdjacentToMergedEx (const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, int &nAdjRowIndex, BOOL bUpward)
Searches the topmost or bottommost row depending on the height of the current row.
int | FindRowAdjacentToMerged (const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, BOOL bUpward)
Wrapper for the FindRowAdjacentToMergedEx method.
int | RecalcTotalHightOfMergedRows (CXTPGridColumns *pColumns, CDC *pDC, CXTPGridRow *pRow, int nRowHeight, int nTotalWidth)
Recalculates row height according to the height of merged items.
virtual int | GetPreviewItemHeight (CDC *pDC, CXTPGridRow *pRow, int nWidth, int nHeight)
Retrieves the height of a preview item for print mode.
virtual int | GetHeaderHeight ()
Gets the column header height.
virtual int | GetHeaderHeight (CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0)
Calculates the optimal header height.
virtual void | SetHeaderHeight (int nHeight)
Sets the column header height.
virtual int | GetFooterHeight (CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0)
Calculates the optimal footer height.
virtual COLORREF | GetControlBackColor (CXTPGridControl *pControl)
Retrieves the parent Grid control's background color.
virtual void | FillRow (CDC *pDC, CXTPGridRow *pRow, CRect rcRow)
Fills a specified row with its background color.
virtual void | DrawGrid (CDC *pDC, XTPGridOrientation orientation, CRect rcGrid)
Draws a grid for the control.
virtual void | DrawFreezeColsDivider (CDC *pDC, const CRect &rc, CXTPGridControl *pControl, CXTPGridRow *pRow=NULL)
Draws a freeze column divider.
virtual void | DrawVerticalTimeLineMarker (CDC *pDC, int xPos, CXTPGridControl *pControl, COLORREF color=RGB(0, 255, 0))
Draws a vertical timeline marker.
virtual void | FillIndent (CDC *pDC, CRect rcRow)
Fills an indent area by its background.
virtual void | FillItemShade (CDC *pDC, CRect rcItem)
Fills an item shade by its background if necessary.
virtual void | FillHeaderControl (CDC *pDC, CRect rcHeader)
Fills a column header control area by its background.
virtual void | FillFooter (CDC *pDC, CRect rcFooter)
Fills a column footer control area by its background.
virtual void | DrawColumn (CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn, BOOL bDrawExternal=FALSE, int nShadowWidth=0)
Draws a column header with all related attributes (sort order, icon, etc.).
virtual void | DrawColumnFooterDivider (CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn)
Draws the column footer divider.
virtual void | DrawColumnFooter (CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn)
Draws the column footer with all related attributes (e.g.
virtual BOOL | IsColumHotTrackingEnabled () const
Determines if hot tracking is enabled for the current column style.
virtual void | FillGroupByControl (CDC *pDC, CRect &rcGroupBy)
Draws the Group By box.
CXTPImageManager * | GetGlyphs () const
Gets a pointer to the additional image list with glyphs.
void | DrawHorizontalLine (CDC *pDC, int xPos, int yPos, int cx, COLORREF clr)
Draws a horizontal line.
void | DrawVerticalLine (CDC *pDC, int xPos, int yPos, int cy, COLORREF clr)
Draws a vertical line.
void | DrawConnector (CDC *pDC, CPoint ptFrom, CPoint ptTo)
Draws a column connector for the Group By box.
virtual int | DrawBitmap (CDC *pDC, CXTPGridControl *pControl, CRect rcColumn, int iImage)
Draws a bitmap.
virtual int | DrawColumnIcon (CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, CRect rcIcon, int iIcon)
Draws an icon for a column.
virtual CSize | DrawGlyph (CDC *pDC, CRect rcColumn, int iImage)
Draws the standard glyphs of the Grid control.
virtual CSize | DrawShellIcon (CDC *pDC, CRect rcColumn, int iImage)
Draws the shell icon.
void | EnablePreviewMode (BOOL bIsPreviewMode)
Enables/disables preview mode for the control.
BOOL | IsPreviewMode () const
Determines if preview mode is enabled/disabled for the control.
CFont * | GetTextFont ()
Gets the default text font used for control items.
int | SetMaxPreviewLines (int nMaxLines)
Sets the maximum number of lines of text for a preview item.
int | GetMaxPreviewLines ()
Gets the maximum number of lines of text for a preview item.
int | GetPreviewLinesCount (CDC *pDC, CRect &rcText, const CString &strText)
Calculates the number of lines required to draw a specified preview text string, taking into account the maximum number of lines of text for a preview item.
BOOL | IsGridVisible (BOOL bVertical) const
Determines the visibility of specified grid lines.
BOOL | IsGridVisible (XTPGridOrientation orientation) const
Determines the visibility of specified grid lines.
void | SetColumnStyle (XTPGridColumnStyle columnStyle)
Sets the header style.
XTPGridColumnStyle | GetColumnStyle () const
Gets the header style.
void | SetColumnOffice2007CustomThemeBaseColor (COLORREF clrBaseColor)
Sets the header's custom theme base color for Office2007 column style.
COLORREF | GetColumnOffice2007CustomThemeBaseColor () const
Gets the header's custom theme base color for Office2007 column style.
void | SetTextFont (LOGFONT &lf)
Creates and sets the default text font.
void | SetCaptionFont (LOGFONT &lf)
Creates and sets the default caption font.
void | SetPreviewIndent (int nLeft, int nTop, int nRight, int nBottom)
Sets the preview item indent.
virtual void | DrawInplaceButton (CDC *pDC, CXTPGridInplaceButton *pButton)
Draws the in-place button of the Grid control.
virtual BOOL | DrawInplaceComboButton (CDC *pDC, CRect *pRc)
Draws the combo button of the Grid control.
virtual BOOL | DrawInplaceExpandButton (CDC *pDC, CRect *pRc)
Draws the expand button of the Grid control.
virtual BOOL | DrawInplaceSpinButton (CDC *pDC, CRect *pRc)
Draws the spin button of the Grid control.
virtual void | DrawTreeStructure (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CRect rcItem, CSize sizeGlyph)
Draws tree elements of the Grid control.
virtual void | DrawItemBitmap (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CRect &rcItem, int nImage)
Draws an item bitmap.
virtual void | DrawItemCaption (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics)
Draws an item caption.
virtual void | DrawRowNumber (CDC *pDC, CRect rcNumber, CXTPGridRow *pRow)
Draws a row number.
virtual void | DrawItemControl (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CXTPGridRecordItemControl *pControl, CRect &rcItem)
Draws an item control.
BOOL | IsFixedRowHeight () const
Determines if the paint manager supports fixed or variable row height.
void | SetFixedRowHeight (BOOL bFixedRowHeight)
Sets if the paint manager supports fixed or variable row height.
BOOL | IsColumnWidthWYSIWYG () const
Determines if the paint manager supports column width WYSIWYG mode.
BOOL | IsLastColumnWidthWYSIWYG () const
Determines if the paint manager supports last column width WYSIWYG mode.
BOOL | IsShowWYSIWYGMarkers () const
Determines if the paint manager shows WYSIWYG page-end markers.
void | ShowWYSIWYGMarkers (BOOL bSet)
Sets if the paint manager shows WYSIWYG page-end markers.
void | SetColumnWidthWYSIWYG (BOOL bColumnWidthWYSIWYG)
Sets if the paint manager supports column width WYSIWYG mode.
void | SetLastColumnWidthWYSIWYG (BOOL bColumnWidthWYSIWYG)
Sets if the paint manager supports last column width WYSIWYG mode.
BOOL | IsFixedInplaceButtonHeight () const
Determines if the paint manager supports fixed or variable in-place button height.
void | SetInplaceButtonHeight (BOOL bFixedInplaceButtonHeight)
Sets if the paint manager supports fixed or variable in-place button height.
int | GetFreezeColsDividerStyle () const
Gets the style of the freeze columns divider line.
void | SetFreezeColsDividerStyle (int nStyle)
Sets the style for the freeze columns divider line.
virtual BOOL | OnDrawAction (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs)
Override this method to perform custom activities for the item before processing it.
virtual void | DrawNoGroupByText (CDC *pDC, CRect rcItem)
Draws the "No items" text message in the Group By area when there are no items inside it.
BOOL | IsDrawGridForEmptySpace () const
Determines if the grid fills empty space after body rows.
void | SetDrawGridForEmptySpace (BOOL bDrawGrid)
Sets if the grid fills empty space after body rows.
BOOL | IsPrintGroupRowIcon () const
Determines if the group row collapse-expand icon is drawn in print mode.
void | SetPrintGroupRowIcon (BOOL bDraw)
Sets if the group row collapse-expand icon is drawn in print mode.
BOOL | IsColumnPlusMinusSign () const
Determines if columns use expand/collapse icons (+/-) or directional arrows.
void | SetColumnPlusMinusSign (BOOL bDraw)
Specifies if columns use expand/collapse icons (+/-) or directional arrows.
virtual int | CalculateRowHeight (CDC *pDC, const CString &strText, int nMaxWidth, BOOL bWordBreak=TRUE)
Calculates the height required for a rectangle bounding multi-line text to draw the multi-line text when the width of the rectangle is fixed.
void | DrawSectionDivider (CDC *pDC, const CRect &rc, XTPGridSectionDividerPosition dividerPosition, XTPGridSectionDividerStyle dividerStyle, CXTPPaintManagerColor dividerColor)
Draws the divider between grid sections (e.g.
int | GetSectionDividerHeight (XTPGridFixedRowsDividerStyle dividerStyle)
Gets the height of the section divider.
BOOL | IsUseDropMarker () const
Determines if a drop marker will be used when dragging and dropping.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPGridThemeOffice2013
CXTPPaintManagerColor | m_clrGlyph
Header glyph color.
CXTPPaintManagerColor | m_clrGlyphHighlight
Header highlighted glyph color.
CXTPPaintManagerColor | m_clrGlyphExpand
Expand glyph color.
CXTPPaintManagerColor | m_clrGlyphBorder
Expand glyph border color.
CXTPPaintManagerColor | m_clrGlyphContract
Contract glyph color.
- Public Attributes inherited from CXTPGridPaintManager
CXTPFont | m_xtpFontText
Grid items default text.
CXTPFont | m_xtpFontBoldText
Grid items default bold text.
CXTPFont | m_xtpFontCaption
Column header caption font.
CXTPFont | m_xtpFontPreview
Column header caption font.
CXTPGridHyperlinkStyle * | m_pHyperlinkStyle
Style for links.
CXTPGridHyperlinkStyle * | m_pHyperlinkHoverStyle
Style for hovered links.
CXTPPaintManagerColor | m_clrHighlight
Background color of the highlighted row.
CXTPPaintManagerColor | m_clrBoldText
Grid items bold text color.
CXTPPaintManagerColor | m_clrBoldTextHighlight
Grid items bold text highlight color.
CXTPPaintManagerColor | m_clrWindowText
Grid items default text color.
CXTPPaintManagerColor | m_clrHighlightText
Text color of the highlighted text.
CXTPPaintManagerColor | m_clrHeaderControl
Background color of the grid header.
CXTPPaintManagerColor | m_clrCaptionText
Column header text color.
CXTPPaintManagerColor | m_clrCaptionTextPressed
Column header text color when pressed.
CXTPPaintManagerColor | m_clrControlBack
Background color of the control grid area.
CXTPPaintManagerColor | m_clrGroupRowText
Row text color.
CXTPPaintManagerColor | m_clrGroupShadeBack
Group row background color when indentation shade is enabled.
CXTPPaintManagerColor | m_clrGroupShadeText
Group row foreground color when indentation shade is enabled.
CXTPPaintManagerColor | m_clrGroupShadeBorder
Color for group border's shade.
CXTPPaintManagerColor | m_clrGroupBoxBack
Color of group box.
CXTPPaintManagerColor | m_clrControlDark
Dark background color of the Grid control (used on Group By area).
CXTPPaintManagerColor | m_clrControlLightLight
Light background color used for drawing shades (used on column header area).
CXTPPaintManagerColor | m_clrHotDivider
Color of the column hot divider window (two arrows).
CXTPPaintManagerColor | m_clrIndentControl
Color of the tree indentation area.
CXTPPaintManagerColor | m_clrItemShade
Color of the shade on sorted by column items.
CXTPPaintManagerColor | m_clrBtnFace
Standard button face color.
CXTPPaintManagerColor | m_clrBtnText
Standard button text color.
CXTPPaintManagerColor | m_clrPreviewText
Preview text color.
CXTPPaintManagerColor | m_clrSelectedRow
Selected row background color.
CXTPPaintManagerColor | m_clrSelectedRowText
Selected row text color.
CXTPPaintManagerColor | m_clrBtnFacePressed
Standard button face color when pressed.
CXTPPaintManagerColor | m_clrConnector
Header column connector line color.
CXTPPaintManagerColor | m_clrDisableBitmapLightest
The lightest color of bitmap which covers disabled grid.
CXTPPaintManagerColor | m_clrDisableBitmapDarkest
The darkest color of bitmap which covers disabled grid.
CXTPPaintManagerColorGradient | m_grcGradientColumn
Color of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColorGradient | m_grcGradientColumnHot
HotTracking Color of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColorGradient | m_grcGradientColumnPushed
Pushed Color of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColor | m_clrGradientColumnShadow
Bottom shadow of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColor | m_clrGradientColumnSeparator
Separator of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColor | m_crlNoGroupByText
A color for "No items" text in GroupBy area (see m_strNoGroupBy member).
CXTPPaintManagerColor | m_clrFreezeColsDivider
Freeze Columns Divider color.
COLORREF | m_clrColumnOffice2007CustomTheme
Base color for Office2007 custom theme.
COLORREF | m_clrFormulaSum
Color for Formula Sum fields.
COLORREF | m_clrFormulaSubSum
Color for Formula SubSum fields.
COLORREF | m_clrAlternativeBackground
Color for Alternative Row Background.
BOOL | m_bUseAlternativeBackground
TRUE to use Alternative Row Background, FALSE otherwise.
BOOL | m_bAllowMergeCells
TRUE to Allow Merge Cells, FALSE otherwise.
int | m_nTextIndentForGroupRowsWithNoIcon
Specifies Text indent if a group row icon is not used.
int | m_nTreeIndent
Tree indentation.
int | m_nTreeStructureStyle
Tree structure style.
int | m_nTreeTextIndentRowParent
Text indent, in pixels, for rows with children.
int | m_nTreeTextIndentRowChildren
Text indent, in pixels, for rows without children.
int | m_nTreeTextIndent
Text indent, in pixels, for rows that are neither parent nor children.
int | m_nTreeTextIndentGroupRow
Text indent, in pixels, for group rows.
BOOL | m_bGroupRowTextBold
TRUE to draw group rows with bold text.
BOOL | m_bShadeGroupHeadings
TRUE to show the indentation shade, FALSE otherwise.
BOOL | m_bShadeSortColumn
TRUE to show the items shade in the sorted by column, FALSE otherwise.
BOOL | m_bHotTracking
TRUE to allow column hot tracking.
BOOL | m_bInvertColumnOnClick
TRUE to invert column on click.
CString | m_strNoItems
A string which contains customized "No Items" text for displaying in view when there are no visible rows.
CString | m_strSortBy
A string which contains customized "Sort By" text for displaying in tooltip.
CString | m_strIncreasing
A string which contains customized "Increasing" text for displaying in tooltip.
CString | m_strDecreasing
A string which contains customized "Decreasing" text for displaying in tooltip.
CString | m_strNoGroupBy
A string which contains customized "No items" text message for displaying in Group By area when there are no items inside it.
CString | m_strNoFieldsAvailable
A string which contains customized "No Fields Available" text message for displaying in Field Chooser.
CString | m_strExpand
A string which contains customized "Expand" text for displaying in tooltip.
CString | m_strCollapse
A string which contains customized "Collapse" text for displaying in tooltip.
BOOL | m_bHideSelection
TRUE when hiding Grid control's selection by drawing selected items as others, FALSE otherwise.
BOOL | m_bPrintSortTriangle
TRUE to show the sort triangle in printout.
BOOL | m_bRevertAlignment
TRUE to revert column alignments.
BOOL | m_bUseEditTextAlignment
TRUE to automatically apply edit alignment using column alignment.
BOOL | m_bShowLockIcon
TRUE to show the lock icon, FALSE to hide.
BOOL | m_bUseShellIcon
TRUE to use the shell icon, FALSE otherwise.
int | m_iRecOrRowStart
Start position in numbering (0 or 1 or something user want).
BOOL | m_bRecOrRowNum
TRUE to display record number if support mode is used, FALSE to display row number.
BOOL | m_bMakeUpper
TRUE to display column header and group row text in all caps.
XTPGridTreeStructureStyle | m_treeStructureStyle
Tree structure style.
CRect | m_rcPreviewIndent
Preview indentation.
int | m_nFixedColumnsIndent
Fixed Column total width.
BOOL | m_bMoveScrollbarOnFixedColumnsIndent
Move Scrollbar right follow FixedColumnsIndent.
BOOL | m_bThemedInplaceButtons
Draw in-place buttons using current theme settings.
BOOL | m_bBaseTreeIndent
TRUE to add Extra Tree indentation to cover initial TreeColumn.
CUIntArray | m_arStartCol
Start column in each virtual page.
int | m_PrintPageWidth
Width of print page (run-time)
BOOL | m_bPrintVirtualPageNumber
TRUE to print horizontal page number.
BOOL | m_bPrintPageRectangle
TRUE to draw rectangle around page.
int | m_RecordNumberWidth
Column width for row/record numbers.
BOOL | m_bForceDynamicMarkupForCell
TRUE if use Markup for Grid Record Item.
BOOL | m_bForceShowDropMarker
TRUE if Force Show Drop Marker.
BOOL | m_bShowNonActiveInPlaceButton
TRUE if use Show Non-Active In-Place Button (Combo, Expand, Spin).
BOOL | m_bPrintWatermark
TRUE to print watermark.
BOOL | m_bUseGroupRowSelectionState
TRUE if use GroupSelectionState Glyph.
BOOL | m_bForceShowTooltip
TRUE if use show tooltip for any cell width case.
BOOL | m_bCleanTooltip
TRUE if use show tooltip without markup.
BOOL | m_bGrayIfDisable
TRUE is disable draw in gray (standard behavior).
int | m_nRowHeightDefault
The default row height.
BOOL | m_bCompactText
TRUE to ignore Icon for Narrow column to show more text.
BOOL | m_bUseDropMarker
FALSE to not draw drop marked when dragging/dropping, TRUE by default.
BOOL | m_bSortTriangleOffsetFromRight
Offset of sort triangle.
int | m_nTreeColumnLineLength
This is the extra line length to apply to tree column lines if there is no expand button.
int | m_nBaseParentRecordIndent
This is initial number of pixels a parent node will be indented when in a group.
- Protected Member Functions inherited from CXTPGridPaintManager
virtual void | DrawTextLine (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nFlag, int &nCharCounter, int &nHyperlinkCounter)
Draws a line of text with respect to the drawing rectangle.
virtual int | DrawString (int *pnCurrDrawPos, CDC *pDC, const CString &strDraw, CRect rcDraw, UINT nFormat)
Draw a simple string into rectangle.
virtual void | DrawGridPattern (CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush)
Generates a custom grid pattern if necessary.
virtual void | DrawGridPattern (CDC *pDC, CXTPBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush)
Generates a custom grid pattern if necessary.
virtual void | DrawGridPattern (CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr)
Generates a custom grid pattern.
virtual void | DrawInplaceButtonFrame (CDC *pDC, CXTPGridInplaceButton *pButton)
Draws the in-place button frame.
virtual BOOL | DrawInplaceButtonIcon (CDC *pDC, CXTPGridInplaceButton *pButton)
Draws the in-place button icon.
virtual int | CalcColumnHeight (CDC *pDC, CXTPGridColumn *pColumn, int nTotalWidth=0)
Calculates the optimal height for a specified column.
virtual void | DrawMultiLineText (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, BOOL bWordBreak=TRUE)
Draws multi-line text.
virtual void | DrawSingleLineText (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nStartPos, int nEndPos, int nActualWidth)
Draws single-line text.
virtual int | DrawLink (int *pnCurrDrawPos, XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CXTPGridHyperlink *pHyperlink, CString strText, CRect rcLink, int nFlag, BOOL bTrim=FALSE)
Draws a hyperlink string using hyperlink text settings (i.e.
- Protected Attributes inherited from CXTPGridPaintManager
int | m_nRowHeight
Grid row default height.
int | m_nHeaderHeight
Column header height.
int | m_nFooterHeight
Column footer height.
int | m_nGroupGridLineHeight
The height of the group grid line.
CXTPImageManager * | m_pGlyphs
An additional image list for the Grid control.
BOOL | m_bIsPreviewMode
TRUE to show the item preview, FALSE to hide.
int | m_nResizingWidth
The width of the column resizing marker area.
int | m_nMaxPreviewLines
Restrict maximum lines for preview text.
CSize | m_szGlyph
Glyph size.
CXTPBrush | m_xtpBrushTreeStructure
Brush to draw tree nodes.
CXTPBrush | m_xtpBrushGroupGridLineStyle
Brush to draw group row grid lines.
int | m_nFreezeColsDividerStyle
A set of flags from XTPGridFreezeColsDividerStyle.
BOOL | m_bFixedRowHeight
TRUE if fixed rows used.
BOOL | m_bColumnWidthWYSIWYG
TRUE if columns width WYSIWYG mode used.
BOOL | m_bShowWYSIWYGMarkers
TRUE if in non-print mode header show red page-end markers.
BOOL | m_bLastColumnWidthWYSIWYG
TRUE if last column width WYSIWYG mode used.
BOOL | m_bDrawGridForEmptySpace
TRUE if grid fills the empty space (if any) after the body rows.
BOOL | m_bPrintGroupRowIcon
TRUE if printout draw collapse-expand icon for group row.
BOOL | m_bColumnPlusMinusSign
TRUE if expand/collapse icons are used, FALSE if directional arrows are used.
BOOL | m_bFixedInplaceButtonHeight
TRUE if fixed in-place button height is used.
XTPGridGridStyle | m_nGroupGridLineStyle
Current style for group row grid lines.
XTPGridColumnStyle | m_columnStyle
Column drawing style.
CXTPWinThemeWrapper * | m_themeHeader
Header theme wrapper.
CXTPWinThemeWrapper * | m_themeButton
In-place button theme wrapper.
CXTPWinThemeWrapper * | m_themeCombo
Combo box in-place button theme wrapper.
CXTPWinThemeWrapper * | m_themeSpin
Spin in-place button theme wrapper.
CXTPGridControl * | m_pControl
Pointer to the Grid control object.
CXTPMarkupUIElement * | m_pMarkupUIElement_NoGroupBy
The no group by markup UI element.
CString | m_strMarkupUIElement_NoGroupBy
The no group by markup UI element string.
CXTPBrush | m_xtpBrushVeriticalGrid
Brush to draw vertical grid lines.
CXTPBrush | m_xtpBrushHorizontalGrid
Brush to draw horizontal grid lines.
XTPGridGridStyle m_nGridLineStylePreviousV
Previous style for vertical grid lines.
XTPGridGridStyle m_nGridLineStylePreviousH
Previous style for horizontal grid lines.

Detailed Description

CXTPGridThemeVisualStudio2019 is a CXTPGridThemeOffice2013 derived class that represents a Visual Studio 2019 style theme.

The documentation for this class was generated from the following file:
  • XTPGridThemeVisualStudio2019.h


Toolkit Pro: CXTPGridThemeVisualStudio2022 Class Reference

Public Member Functions | List of all members
CXTPGridThemeVisualStudio2022 Class Reference

CXTPGridThemeVisualStudio2022 is a CXTPGridThemeOffice2013 derived class that represents a Visual Studio 2022 style theme. More...

Inheritance diagram for CXTPGridThemeVisualStudio2022:
[legend]

Public Member Functions

CXTPGridThemeVisualStudio2022 ()
Default paint manager constructor, handles properties initialization.
virtual void | RefreshMetrics ()
This method is called to refresh the visual metrics of the Grid control.
- Public Member Functions inherited from CXTPGridThemeOffice2013
CXTPGridThemeOffice2013 ()
Default paint manager constructor, handles properties initialization.
virtual void | LoadGlyphs ()
Loads the default images used by the Grid control.
virtual void | DrawColumnText (CDC *pDC, CRect rcText, CString strCaption, int nHeaderAlignment, BOOL bIsHeader, BOOL bColumnPressed)
Draws text for the column header.
virtual void | DrawColumnBackground (CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, BOOL &bColumnPressed, BOOL &bDraggingFromHeader, CXTPGridHeader *pHeader=NULL)
This method is called to draw the background of a column using the current column style.
virtual void | DrawTriangle (CDC *pDC, CRect rcTriangle, BOOL bToDown, BOOL bDraggingFromHeader, int nShadowWidth, BOOL bColumnPressed)
Draws a triangle that shows the sort order of the column.
virtual CSize | DrawCollapsedBitmap (CDC *pDC, const CXTPGridRow *pRow, CRect &rcBitmap)
Draws a collapsed bitmap.
virtual void | FillGroupRowMetrics (CXTPGridGroupRow *pRow, XTP_GRIDRECORDITEM_METRICS *pMetrics, BOOL bPrinting)
Fills the font and color members of the metrics structure for a specified group row.
virtual void | DrawGroupRow (CDC *pDC, CXTPGridGroupRow *pRow, CRect rcRow, XTP_GRIDRECORDITEM_METRICS *pMetrics)
Draws a group row.
virtual void | DrawFocusedRow (CDC *pDC, CRect rcRow)
Draws focused rows.
virtual int | GetRowHeight (CDC *pDC, CXTPGridRow *pRow)
Retrieves the default row height for print mode (i.e.
virtual int | GetRowHeight (CDC *pDC, CXTPGridRow *pRow, int nTotalWidth)
Retrieves the default row height for print mode (i.e.
- Public Member Functions inherited from CXTPGridPaintManager
CXTPGridPaintManager ()
Default CXTPGridPaintManager constructor, handles properties initialization.
virtual | ~CXTPGridPaintManager ()
Default CXTPGridPaintManager destructor, handles member items deallocation.
virtual void | SetGridControl (CXTPGridControl *pControl)
Sets the associated Grid control for the paint manager.
int | GetRowHeightEx (CDC *pDC, CXTPGridRow *pRow, int nTotalWidth, const BOOL firstLevel=TRUE)
Retrieves the default row height for print mode (i.e.
int | GetItemHeight (XTP_GRIDRECORDITEM_DRAWARGS &drawArgs, int nWidth)
Retrieves the height of a record item for a given width.
BOOL | FindRowAdjacentToMergedEx (const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, int &nAdjRowIndex, BOOL bUpward)
Searches the topmost or bottommost row depending on the height of the current row.
int | FindRowAdjacentToMerged (const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, BOOL bUpward)
Wrapper for the FindRowAdjacentToMergedEx method.
int | RecalcTotalHightOfMergedRows (CXTPGridColumns *pColumns, CDC *pDC, CXTPGridRow *pRow, int nRowHeight, int nTotalWidth)
Recalculates row height according to the height of merged items.
virtual int | GetPreviewItemHeight (CDC *pDC, CXTPGridRow *pRow, int nWidth, int nHeight)
Retrieves the height of a preview item for print mode.
virtual int | GetHeaderHeight ()
Gets the column header height.
virtual int | GetHeaderHeight (CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0)
Calculates the optimal header height.
virtual void | SetHeaderHeight (int nHeight)
Sets the column header height.
virtual int | GetFooterHeight (CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0)
Calculates the optimal footer height.
virtual COLORREF | GetControlBackColor (CXTPGridControl *pControl)
Retrieves the parent Grid control's background color.
virtual void | FillRow (CDC *pDC, CXTPGridRow *pRow, CRect rcRow)
Fills a specified row with its background color.
virtual void | DrawGrid (CDC *pDC, XTPGridOrientation orientation, CRect rcGrid)
Draws a grid for the control.
virtual void | DrawFreezeColsDivider (CDC *pDC, const CRect &rc, CXTPGridControl *pControl, CXTPGridRow *pRow=NULL)
Draws a freeze column divider.
virtual void | DrawVerticalTimeLineMarker (CDC *pDC, int xPos, CXTPGridControl *pControl, COLORREF color=RGB(0, 255, 0))
Draws a vertical timeline marker.
virtual void | FillIndent (CDC *pDC, CRect rcRow)
Fills an indent area by its background.
virtual void | FillItemShade (CDC *pDC, CRect rcItem)
Fills an item shade by its background if necessary.
virtual void | FillHeaderControl (CDC *pDC, CRect rcHeader)
Fills a column header control area by its background.
virtual void | FillFooter (CDC *pDC, CRect rcFooter)
Fills a column footer control area by its background.
virtual void | DrawColumn (CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn, BOOL bDrawExternal=FALSE, int nShadowWidth=0)
Draws a column header with all related attributes (sort order, icon, etc.).
virtual void | DrawColumnFooterDivider (CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn)
Draws the column footer divider.
virtual void | DrawColumnFooter (CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn)
Draws the column footer with all related attributes (e.g.
virtual BOOL | IsColumHotTrackingEnabled () const
Determines if hot tracking is enabled for the current column style.
virtual void | FillGroupByControl (CDC *pDC, CRect &rcGroupBy)
Draws the Group By box.
CXTPImageManager * | GetGlyphs () const
Gets a pointer to the additional image list with glyphs.
void | DrawHorizontalLine (CDC *pDC, int xPos, int yPos, int cx, COLORREF clr)
Draws a horizontal line.
void | DrawVerticalLine (CDC *pDC, int xPos, int yPos, int cy, COLORREF clr)
Draws a vertical line.
void | DrawConnector (CDC *pDC, CPoint ptFrom, CPoint ptTo)
Draws a column connector for the Group By box.
virtual int | DrawBitmap (CDC *pDC, CXTPGridControl *pControl, CRect rcColumn, int iImage)
Draws a bitmap.
virtual int | DrawColumnIcon (CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, CRect rcIcon, int iIcon)
Draws an icon for a column.
virtual CSize | DrawGlyph (CDC *pDC, CRect rcColumn, int iImage)
Draws the standard glyphs of the Grid control.
virtual CSize | DrawShellIcon (CDC *pDC, CRect rcColumn, int iImage)
Draws the shell icon.
void | EnablePreviewMode (BOOL bIsPreviewMode)
Enables/disables preview mode for the control.
BOOL | IsPreviewMode () const
Determines if preview mode is enabled/disabled for the control.
CFont * | GetTextFont ()
Gets the default text font used for control items.
int | SetMaxPreviewLines (int nMaxLines)
Sets the maximum number of lines of text for a preview item.
int | GetMaxPreviewLines ()
Gets the maximum number of lines of text for a preview item.
int | GetPreviewLinesCount (CDC *pDC, CRect &rcText, const CString &strText)
Calculates the number of lines required to draw a specified preview text string, taking into account the maximum number of lines of text for a preview item.
BOOL | IsGridVisible (BOOL bVertical) const
Determines the visibility of specified grid lines.
BOOL | IsGridVisible (XTPGridOrientation orientation) const
Determines the visibility of specified grid lines.
void | SetColumnStyle (XTPGridColumnStyle columnStyle)
Sets the header style.
XTPGridColumnStyle | GetColumnStyle () const
Gets the header style.
void | SetColumnOffice2007CustomThemeBaseColor (COLORREF clrBaseColor)
Sets the header's custom theme base color for Office2007 column style.
COLORREF | GetColumnOffice2007CustomThemeBaseColor () const
Gets the header's custom theme base color for Office2007 column style.
void | SetTextFont (LOGFONT &lf)
Creates and sets the default text font.
void | SetCaptionFont (LOGFONT &lf)
Creates and sets the default caption font.
void | SetPreviewIndent (int nLeft, int nTop, int nRight, int nBottom)
Sets the preview item indent.
virtual void | DrawInplaceButton (CDC *pDC, CXTPGridInplaceButton *pButton)
Draws the in-place button of the Grid control.
virtual BOOL | DrawInplaceComboButton (CDC *pDC, CRect *pRc)
Draws the combo button of the Grid control.
virtual BOOL | DrawInplaceExpandButton (CDC *pDC, CRect *pRc)
Draws the expand button of the Grid control.
virtual BOOL | DrawInplaceSpinButton (CDC *pDC, CRect *pRc)
Draws the spin button of the Grid control.
virtual void | DrawTreeStructure (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CRect rcItem, CSize sizeGlyph)
Draws tree elements of the Grid control.
virtual void | DrawItemBitmap (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CRect &rcItem, int nImage)
Draws an item bitmap.
virtual void | DrawItemCaption (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics)
Draws an item caption.
virtual void | DrawRowNumber (CDC *pDC, CRect rcNumber, CXTPGridRow *pRow)
Draws a row number.
virtual void | DrawItemControl (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CXTPGridRecordItemControl *pControl, CRect &rcItem)
Draws an item control.
BOOL | IsFixedRowHeight () const
Determines if the paint manager supports fixed or variable row height.
void | SetFixedRowHeight (BOOL bFixedRowHeight)
Sets if the paint manager supports fixed or variable row height.
BOOL | IsColumnWidthWYSIWYG () const
Determines if the paint manager supports column width WYSIWYG mode.
BOOL | IsLastColumnWidthWYSIWYG () const
Determines if the paint manager supports last column width WYSIWYG mode.
BOOL | IsShowWYSIWYGMarkers () const
Determines if the paint manager shows WYSIWYG page-end markers.
void | ShowWYSIWYGMarkers (BOOL bSet)
Sets if the paint manager shows WYSIWYG page-end markers.
void | SetColumnWidthWYSIWYG (BOOL bColumnWidthWYSIWYG)
Sets if the paint manager supports column width WYSIWYG mode.
void | SetLastColumnWidthWYSIWYG (BOOL bColumnWidthWYSIWYG)
Sets if the paint manager supports last column width WYSIWYG mode.
BOOL | IsFixedInplaceButtonHeight () const
Determines if the paint manager supports fixed or variable in-place button height.
void | SetInplaceButtonHeight (BOOL bFixedInplaceButtonHeight)
Sets if the paint manager supports fixed or variable in-place button height.
int | GetFreezeColsDividerStyle () const
Gets the style of the freeze columns divider line.
void | SetFreezeColsDividerStyle (int nStyle)
Sets the style for the freeze columns divider line.
virtual BOOL | OnDrawAction (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs)
Override this method to perform custom activities for the item before processing it.
virtual void | DrawNoGroupByText (CDC *pDC, CRect rcItem)
Draws the "No items" text message in the Group By area when there are no items inside it.
BOOL | IsDrawGridForEmptySpace () const
Determines if the grid fills empty space after body rows.
void | SetDrawGridForEmptySpace (BOOL bDrawGrid)
Sets if the grid fills empty space after body rows.
BOOL | IsPrintGroupRowIcon () const
Determines if the group row collapse-expand icon is drawn in print mode.
void | SetPrintGroupRowIcon (BOOL bDraw)
Sets if the group row collapse-expand icon is drawn in print mode.
BOOL | IsColumnPlusMinusSign () const
Determines if columns use expand/collapse icons (+/-) or directional arrows.
void | SetColumnPlusMinusSign (BOOL bDraw)
Specifies if columns use expand/collapse icons (+/-) or directional arrows.
virtual int | CalculateRowHeight (CDC *pDC, const CString &strText, int nMaxWidth, BOOL bWordBreak=TRUE)
Calculates the height required for a rectangle bounding multi-line text to draw the multi-line text when the width of the rectangle is fixed.
void | DrawSectionDivider (CDC *pDC, const CRect &rc, XTPGridSectionDividerPosition dividerPosition, XTPGridSectionDividerStyle dividerStyle, CXTPPaintManagerColor dividerColor)
Draws the divider between grid sections (e.g.
int | GetSectionDividerHeight (XTPGridFixedRowsDividerStyle dividerStyle)
Gets the height of the section divider.
BOOL | IsUseDropMarker () const
Determines if a drop marker will be used when dragging and dropping.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPGridThemeOffice2013
CXTPPaintManagerColor | m_clrGlyph
Header glyph color.
CXTPPaintManagerColor | m_clrGlyphHighlight
Header highlighted glyph color.
CXTPPaintManagerColor | m_clrGlyphExpand
Expand glyph color.
CXTPPaintManagerColor | m_clrGlyphBorder
Expand glyph border color.
CXTPPaintManagerColor | m_clrGlyphContract
Contract glyph color.
- Public Attributes inherited from CXTPGridPaintManager
CXTPFont | m_xtpFontText
Grid items default text.
CXTPFont | m_xtpFontBoldText
Grid items default bold text.
CXTPFont | m_xtpFontCaption
Column header caption font.
CXTPFont | m_xtpFontPreview
Column header caption font.
CXTPGridHyperlinkStyle * | m_pHyperlinkStyle
Style for links.
CXTPGridHyperlinkStyle * | m_pHyperlinkHoverStyle
Style for hovered links.
CXTPPaintManagerColor | m_clrHighlight
Background color of the highlighted row.
CXTPPaintManagerColor | m_clrBoldText
Grid items bold text color.
CXTPPaintManagerColor | m_clrBoldTextHighlight
Grid items bold text highlight color.
CXTPPaintManagerColor | m_clrWindowText
Grid items default text color.
CXTPPaintManagerColor | m_clrHighlightText
Text color of the highlighted text.
CXTPPaintManagerColor | m_clrHeaderControl
Background color of the grid header.
CXTPPaintManagerColor | m_clrCaptionText
Column header text color.
CXTPPaintManagerColor | m_clrCaptionTextPressed
Column header text color when pressed.
CXTPPaintManagerColor | m_clrControlBack
Background color of the control grid area.
CXTPPaintManagerColor | m_clrGroupRowText
Row text color.
CXTPPaintManagerColor | m_clrGroupShadeBack
Group row background color when indentation shade is enabled.
CXTPPaintManagerColor | m_clrGroupShadeText
Group row foreground color when indentation shade is enabled.
CXTPPaintManagerColor | m_clrGroupShadeBorder
Color for group border's shade.
CXTPPaintManagerColor | m_clrGroupBoxBack
Color of group box.
CXTPPaintManagerColor | m_clrControlDark
Dark background color of the Grid control (used on Group By area).
CXTPPaintManagerColor | m_clrControlLightLight
Light background color used for drawing shades (used on column header area).
CXTPPaintManagerColor | m_clrHotDivider
Color of the column hot divider window (two arrows).
CXTPPaintManagerColor | m_clrIndentControl
Color of the tree indentation area.
CXTPPaintManagerColor | m_clrItemShade
Color of the shade on sorted by column items.
CXTPPaintManagerColor | m_clrBtnFace
Standard button face color.
CXTPPaintManagerColor | m_clrBtnText
Standard button text color.
CXTPPaintManagerColor | m_clrPreviewText
Preview text color.
CXTPPaintManagerColor | m_clrSelectedRow
Selected row background color.
CXTPPaintManagerColor | m_clrSelectedRowText
Selected row text color.
CXTPPaintManagerColor | m_clrBtnFacePressed
Standard button face color when pressed.
CXTPPaintManagerColor | m_clrConnector
Header column connector line color.
CXTPPaintManagerColor | m_clrDisableBitmapLightest
The lightest color of bitmap which covers disabled grid.
CXTPPaintManagerColor | m_clrDisableBitmapDarkest
The darkest color of bitmap which covers disabled grid.
CXTPPaintManagerColorGradient | m_grcGradientColumn
Color of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColorGradient | m_grcGradientColumnHot
HotTracking Color of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColorGradient | m_grcGradientColumnPushed
Pushed Color of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColor | m_clrGradientColumnShadow
Bottom shadow of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColor | m_clrGradientColumnSeparator
Separator of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColor | m_crlNoGroupByText
A color for "No items" text in GroupBy area (see m_strNoGroupBy member).
CXTPPaintManagerColor | m_clrFreezeColsDivider
Freeze Columns Divider color.
COLORREF | m_clrColumnOffice2007CustomTheme
Base color for Office2007 custom theme.
COLORREF | m_clrFormulaSum
Color for Formula Sum fields.
COLORREF | m_clrFormulaSubSum
Color for Formula SubSum fields.
COLORREF | m_clrAlternativeBackground
Color for Alternative Row Background.
BOOL | m_bUseAlternativeBackground
TRUE to use Alternative Row Background, FALSE otherwise.
BOOL | m_bAllowMergeCells
TRUE to Allow Merge Cells, FALSE otherwise.
int | m_nTextIndentForGroupRowsWithNoIcon
Specifies Text indent if a group row icon is not used.
int | m_nTreeIndent
Tree indentation.
int | m_nTreeStructureStyle
Tree structure style.
int | m_nTreeTextIndentRowParent
Text indent, in pixels, for rows with children.
int | m_nTreeTextIndentRowChildren
Text indent, in pixels, for rows without children.
int | m_nTreeTextIndent
Text indent, in pixels, for rows that are neither parent nor children.
int | m_nTreeTextIndentGroupRow
Text indent, in pixels, for group rows.
BOOL | m_bGroupRowTextBold
TRUE to draw group rows with bold text.
BOOL | m_bShadeGroupHeadings
TRUE to show the indentation shade, FALSE otherwise.
BOOL | m_bShadeSortColumn
TRUE to show the items shade in the sorted by column, FALSE otherwise.
BOOL | m_bHotTracking
TRUE to allow column hot tracking.
BOOL | m_bInvertColumnOnClick
TRUE to invert column on click.
CString | m_strNoItems
A string which contains customized "No Items" text for displaying in view when there are no visible rows.
CString | m_strSortBy
A string which contains customized "Sort By" text for displaying in tooltip.
CString | m_strIncreasing
A string which contains customized "Increasing" text for displaying in tooltip.
CString | m_strDecreasing
A string which contains customized "Decreasing" text for displaying in tooltip.
CString | m_strNoGroupBy
A string which contains customized "No items" text message for displaying in Group By area when there are no items inside it.
CString | m_strNoFieldsAvailable
A string which contains customized "No Fields Available" text message for displaying in Field Chooser.
CString | m_strExpand
A string which contains customized "Expand" text for displaying in tooltip.
CString | m_strCollapse
A string which contains customized "Collapse" text for displaying in tooltip.
BOOL | m_bHideSelection
TRUE when hiding Grid control's selection by drawing selected items as others, FALSE otherwise.
BOOL | m_bPrintSortTriangle
TRUE to show the sort triangle in printout.
BOOL | m_bRevertAlignment
TRUE to revert column alignments.
BOOL | m_bUseEditTextAlignment
TRUE to automatically apply edit alignment using column alignment.
BOOL | m_bShowLockIcon
TRUE to show the lock icon, FALSE to hide.
BOOL | m_bUseShellIcon
TRUE to use the shell icon, FALSE otherwise.
int | m_iRecOrRowStart
Start position in numbering (0 or 1 or something user want).
BOOL | m_bRecOrRowNum
TRUE to display record number if support mode is used, FALSE to display row number.
BOOL | m_bMakeUpper
TRUE to display column header and group row text in all caps.
XTPGridTreeStructureStyle | m_treeStructureStyle
Tree structure style.
CRect | m_rcPreviewIndent
Preview indentation.
int | m_nFixedColumnsIndent
Fixed Column total width.
BOOL | m_bMoveScrollbarOnFixedColumnsIndent
Move Scrollbar right follow FixedColumnsIndent.
BOOL | m_bThemedInplaceButtons
Draw in-place buttons using current theme settings.
BOOL | m_bBaseTreeIndent
TRUE to add Extra Tree indentation to cover initial TreeColumn.
CUIntArray | m_arStartCol
Start column in each virtual page.
int | m_PrintPageWidth
Width of print page (run-time)
BOOL | m_bPrintVirtualPageNumber
TRUE to print horizontal page number.
BOOL | m_bPrintPageRectangle
TRUE to draw rectangle around page.
int | m_RecordNumberWidth
Column width for row/record numbers.
BOOL | m_bForceDynamicMarkupForCell
TRUE if use Markup for Grid Record Item.
BOOL | m_bForceShowDropMarker
TRUE if Force Show Drop Marker.
BOOL | m_bShowNonActiveInPlaceButton
TRUE if use Show Non-Active In-Place Button (Combo, Expand, Spin).
BOOL | m_bPrintWatermark
TRUE to print watermark.
BOOL | m_bUseGroupRowSelectionState
TRUE if use GroupSelectionState Glyph.
BOOL | m_bForceShowTooltip
TRUE if use show tooltip for any cell width case.
BOOL | m_bCleanTooltip
TRUE if use show tooltip without markup.
BOOL | m_bGrayIfDisable
TRUE is disable draw in gray (standard behavior).
int | m_nRowHeightDefault
The default row height.
BOOL | m_bCompactText
TRUE to ignore Icon for Narrow column to show more text.
BOOL | m_bUseDropMarker
FALSE to not draw drop marked when dragging/dropping, TRUE by default.
BOOL | m_bSortTriangleOffsetFromRight
Offset of sort triangle.
int | m_nTreeColumnLineLength
This is the extra line length to apply to tree column lines if there is no expand button.
int | m_nBaseParentRecordIndent
This is initial number of pixels a parent node will be indented when in a group.
- Protected Member Functions inherited from CXTPGridPaintManager
virtual void | DrawTextLine (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nFlag, int &nCharCounter, int &nHyperlinkCounter)
Draws a line of text with respect to the drawing rectangle.
virtual int | DrawString (int *pnCurrDrawPos, CDC *pDC, const CString &strDraw, CRect rcDraw, UINT nFormat)
Draw a simple string into rectangle.
virtual void | DrawGridPattern (CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush)
Generates a custom grid pattern if necessary.
virtual void | DrawGridPattern (CDC *pDC, CXTPBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush)
Generates a custom grid pattern if necessary.
virtual void | DrawGridPattern (CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr)
Generates a custom grid pattern.
virtual void | DrawInplaceButtonFrame (CDC *pDC, CXTPGridInplaceButton *pButton)
Draws the in-place button frame.
virtual BOOL | DrawInplaceButtonIcon (CDC *pDC, CXTPGridInplaceButton *pButton)
Draws the in-place button icon.
virtual int | CalcColumnHeight (CDC *pDC, CXTPGridColumn *pColumn, int nTotalWidth=0)
Calculates the optimal height for a specified column.
virtual void | DrawMultiLineText (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, BOOL bWordBreak=TRUE)
Draws multi-line text.
virtual void | DrawSingleLineText (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nStartPos, int nEndPos, int nActualWidth)
Draws single-line text.
virtual int | DrawLink (int *pnCurrDrawPos, XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CXTPGridHyperlink *pHyperlink, CString strText, CRect rcLink, int nFlag, BOOL bTrim=FALSE)
Draws a hyperlink string using hyperlink text settings (i.e.
- Protected Attributes inherited from CXTPGridPaintManager
int | m_nRowHeight
Grid row default height.
int | m_nHeaderHeight
Column header height.
int | m_nFooterHeight
Column footer height.
int | m_nGroupGridLineHeight
The height of the group grid line.
CXTPImageManager * | m_pGlyphs
An additional image list for the Grid control.
BOOL | m_bIsPreviewMode
TRUE to show the item preview, FALSE to hide.
int | m_nResizingWidth
The width of the column resizing marker area.
int | m_nMaxPreviewLines
Restrict maximum lines for preview text.
CSize | m_szGlyph
Glyph size.
CXTPBrush | m_xtpBrushTreeStructure
Brush to draw tree nodes.
CXTPBrush | m_xtpBrushGroupGridLineStyle
Brush to draw group row grid lines.
int | m_nFreezeColsDividerStyle
A set of flags from XTPGridFreezeColsDividerStyle.
BOOL | m_bFixedRowHeight
TRUE if fixed rows used.
BOOL | m_bColumnWidthWYSIWYG
TRUE if columns width WYSIWYG mode used.
BOOL | m_bShowWYSIWYGMarkers
TRUE if in non-print mode header show red page-end markers.
BOOL | m_bLastColumnWidthWYSIWYG
TRUE if last column width WYSIWYG mode used.
BOOL | m_bDrawGridForEmptySpace
TRUE if grid fills the empty space (if any) after the body rows.
BOOL | m_bPrintGroupRowIcon
TRUE if printout draw collapse-expand icon for group row.
BOOL | m_bColumnPlusMinusSign
TRUE if expand/collapse icons are used, FALSE if directional arrows are used.
BOOL | m_bFixedInplaceButtonHeight
TRUE if fixed in-place button height is used.
XTPGridGridStyle | m_nGroupGridLineStyle
Current style for group row grid lines.
XTPGridColumnStyle | m_columnStyle
Column drawing style.
CXTPWinThemeWrapper * | m_themeHeader
Header theme wrapper.
CXTPWinThemeWrapper * | m_themeButton
In-place button theme wrapper.
CXTPWinThemeWrapper * | m_themeCombo
Combo box in-place button theme wrapper.
CXTPWinThemeWrapper * | m_themeSpin
Spin in-place button theme wrapper.
CXTPGridControl * | m_pControl
Pointer to the Grid control object.
CXTPMarkupUIElement * | m_pMarkupUIElement_NoGroupBy
The no group by markup UI element.
CString | m_strMarkupUIElement_NoGroupBy
The no group by markup UI element string.
CXTPBrush | m_xtpBrushVeriticalGrid
Brush to draw vertical grid lines.
CXTPBrush | m_xtpBrushHorizontalGrid
Brush to draw horizontal grid lines.
XTPGridGridStyle m_nGridLineStylePreviousV
Previous style for vertical grid lines.
XTPGridGridStyle m_nGridLineStylePreviousH
Previous style for horizontal grid lines.

Detailed Description

CXTPGridThemeVisualStudio2022 is a CXTPGridThemeOffice2013 derived class that represents a Visual Studio 2022 style theme.

The documentation for this class was generated from the following file:
  • XTPGridThemeVisualStudio2022.h


Toolkit Pro: CXTPGridThickness Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPGridThickness Class Reference

The CXTPGridThickness class describes the thickness of the left, top, right, and bottom sides of a rectangle. More...

Inheritance diagram for CXTPGridThickness:
[legend]

Public Member Functions

CXTPGridThickness ()
Constructs a CXTPGridThickness object and sets the left, top, right, and bottom thickness to 0.
CXTPGridThickness (const CXTPGridThickness &thickness)
Constructs a CXTPGridThickness object and sets the left, top, right, and bottom thickness.
CXTPGridThickness (const int nThickness)
Constructs a CXTPGridThickness object and sets the left, top, right, and bottom thickness.
CXTPGridThickness (const int nLeft, const int nTop, const int nRight, const int nBottom)
Constructs a CXTPGridThickness object and sets the left, top, right, and bottom thickness.
void | Set (const CXTPGridThickness &thickness)
Sets the left, top, right, and bottom thickness.
void | Set (const int nThickness)
Sets the left, top, right, and bottom thickness.
void | Set (const int nLeft, const int nTop, const int nRight, const int nBottom)
Sets the left, top, right, and bottom thickness.
int | GetLeft () const
Gets the left thickness.
void | SetLeft (const int nThickness)
Sets the left thickness.
int | GetTop () const
Gets the top thickness.
void | SetTop (const int nThickness)
Sets the top thickness.
int | GetRight () const
Gets the right thickness.
void | SetRight (const int nThickness)
Sets the right thickness.
int | GetBottom () const
Gets the bottom thickness.
void | SetBottom (const int nThickness)
Sets the bottom thickness.
CXTPGridThickness & | operator= (const CXTPGridThickness &thickness)
Sets the left, top, right, and bottom thickness.
CXTPGridThickness & | operator= (const int nThickness)
Sets the left, top, right, and bottom thickness.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Attributes

int | m_nLeft
Left thickness.
int | m_nTop
Top thickness.
int | m_nRight
Right thickness.
int | m_nBottom
Bottom thickness.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

The CXTPGridThickness class describes the thickness of the left, top, right, and bottom sides of a rectangle.

Constructor & Destructor Documentation

◆ CXTPGridThickness() [1/3]

CXTPGridThickness ( const CXTPGridThickness & thickness )

Constructs a CXTPGridThickness object and sets the left, top, right, and bottom thickness.

Parameters
thickness The left, top, right, and bottom thickness.

◆ CXTPGridThickness() [2/3]

CXTPGridThickness ( const int nThickness )

Constructs a CXTPGridThickness object and sets the left, top, right, and bottom thickness.

Parameters
nThickness The left, top, right, and bottom thickness.

◆ CXTPGridThickness() [3/3]

CXTPGridThickness | ( | const int | nLeft,
 |  | const int | nTop,
 |  | const int | nRight,
 |  | const int | nBottom )

Constructs a CXTPGridThickness object and sets the left, top, right, and bottom thickness.

Parameters
nLeft | The left thickness.
nTop | The top thickness.
nRight | The right thickness.
nBottom | The bottom thickness.

Member Function Documentation

◆ GetBottom()

int GetBottom ( ) const

Gets the bottom thickness.

Returns
The bottom thickness.

◆ GetLeft()

int GetLeft ( ) const

Gets the left thickness.

Returns
The left thickness.

◆ GetRight()

int GetRight ( ) const

Gets the right thickness.

Returns
The right thickness.

◆ GetTop()

int GetTop ( ) const

Gets the top thickness.

Returns
The top thickness.

◆ operator=() [1/2]

CXTPGridThickness & operator= ( const CXTPGridThickness & thickness )

Sets the left, top, right, and bottom thickness.

Parameters
thickness The left, top, right, and bottom thickness.
Returns
Self reference.

◆ operator=() [2/2]

CXTPGridThickness & operator= ( const int nThickness )

Sets the left, top, right, and bottom thickness.

Parameters
nThickness The left, top, right, and bottom thickness.
Returns
Self reference.

◆ Set() [1/3]

void Set ( const CXTPGridThickness & thickness )

Sets the left, top, right, and bottom thickness.

Parameters
thickness The left, top, right, and bottom thickness.

◆ Set() [2/3]

void Set | ( | const int | nLeft,
 |  | const int | nTop,
 |  | const int | nRight,
 |  | const int | nBottom )

Sets the left, top, right, and bottom thickness.

Parameters
nLeft | The left thickness.
nTop | The top thickness.
nRight | The right thickness.
nBottom | The bottom thickness.

◆ Set() [3/3]

void Set ( const int nThickness )

Sets the left, top, right, and bottom thickness.

Parameters
nThickness The left, top, right, and bottom thickness.

◆ SetBottom()

void SetBottom ( const int nThickness )

Sets the bottom thickness.

Parameters
nThickness New bottom thickness.

◆ SetLeft()

void SetLeft ( const int nThickness )

Sets the left thickness.

Parameters
nThickness New left thickness.

◆ SetRight()

void SetRight ( const int nThickness )

Sets the right thickness.

Parameters
nThickness New right thickness.

◆ SetTop()

void SetTop ( const int nThickness )

Sets the top thickness.

Parameters
nThickness New top thickness.
The documentation for this class was generated from the following file:
  • XTPGridThickness.h


Toolkit Pro: CXTPGridTip Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPGridTip Class Reference

The CXTPGridTip class encapsulates the functionality of a "tip control", a small pop-up window that displays a single line of text describing the hidden text when hovering an item on the grid area. More...

Public Member Functions

CXTPGridTip ()
Constructs a CXTPGridTip object.
virtual | ~CXTPGridTip ()
Destroys a CXTPGridTip object, handles cleanup and deallocation.
virtual BOOL | Create (CWnd *pParentWnd)
Creates a grid tip window.
BOOL | IsMultilineForce () const
Determines if the tooltip text contains the new line character.
CString | GetTooltipText () const
Gets the tooltip text.
void | SetTooltipText (LPCTSTR str)
Sets the tooltip text.
void | SetFont (CFont *pFont)
Sets the font of the tooltip text.
void | SetHoverRect (CRect rc)
Sets the coordinates of the tooltip hover rectangle.
CRect | GetHoverRect () const
Gets the coordinates of the tooltip hover rectangle.
void | SetTooltipRect (CRect rc)
Sets the tooltip rectangle.
CRect | GetTooltipRect () const
Gets the tooltip rectangle.
void | Activate (BOOL bActive, BOOL bMultiline)
Call this function to activate/deactivate the tooltip control.

Protected Attributes

CRect | m_rcHover
Hover window coordinates.
CRect | m_rcTooltip
Tooltip window coordinates.
CWnd * | m_pParentWnd
Pointer to the parent grid window.
CString | m_strTooltipText
Tooltip text to display.
CXTPGridRecordItem * | m_pItem
Item which tooltip is visible.
int | m_nRowIndex
Index of item's row.
CXTPFont | m_xtpFontToolTip
Font for displaying tooltip text.
BOOL | m_bMultiline
Multiline tooltip flag.
CXTPGridControl * | m_pGridControl
Parent Grid Control.

Detailed Description

The CXTPGridTip class encapsulates the functionality of a "tip control", a small pop-up window that displays a single line of text describing the hidden text when hovering an item on the grid area.

CXTPGridTip provides the functionality to control the the tip text, the size of the tip window itself, and the text font of the tip.

This class is used by the Grid control internally.

See also
CXTPGridControl, CXTPGridRow::ShowToolTip

Constructor & Destructor Documentation

◆ CXTPGridTip()

CXTPGridTip ( )

Constructs a CXTPGridTip object.

You construct a CXTPGridTip object in two steps. First, call the CXTPGridTip constructor and then call Create. This initializes the window and attaches it to the parent window.

Example:

// Declare a local CXTPGridTip object.
CXTPGridTip wndTip;

// Declare a dynamic CXTPGridTip object.
CXTPGridTip* pTipWnd = new CXTPGridTip;
See also
CWnd, Create, Activate, CXTPGridRow::ShowToolTip

Member Function Documentation

◆ Activate()

void Activate | ( | BOOL | bActive,
 |  | BOOL | bMultiline )

Call this function to activate/deactivate the tooltip control.

Parameters
bActive | TRUE to activate the tooltip control, FALSE to deactivate.
bMultiline | TRUE if the tooltip is multiline, FALSE otherwise.

When a tooltip control is active, tooltip information appears when the cursor is on a tool that is registered with the control. When a tooltip control is inactive, tooltip information does not appear when the cursor is on a tool that is registered with the control.

See also
Create, CXTPGridTip::CXTPGridTip, SetTooltipText

◆ Create()

virtual BOOL Create ( CWnd * pParentWnd )
virtual

Creates a grid tip window.

Parameters
pParentWnd Parent Grid control window.

You construct a CXTPGridTip object in two steps. First, call the CXTPGridTip constructor and then call Create. This initializes the window and attaches it to the parent window.

Returns
TRUE if the grid tip window was created successfully, otherwise FALSE.
See also
CXTPGridTip::CXTPGridTip, Activate

◆ GetHoverRect()

AFX_INLINE CRect GetHoverRect ( ) const

Gets the coordinates of the tooltip hover rectangle.

Returns
A CRect object containing the tooltip hover rectangle in parent window coordinates.
See also
SetHoverRect

◆ GetTooltipRect()

AFX_INLINE CRect GetTooltipRect ( ) const

Gets the tooltip rectangle.

Returns
A CRect object containing the tooltip rectangle.

◆ GetTooltipText()

AFX_INLINE CString GetTooltipText ( ) const

Gets the tooltip text.

Returns
The tooltip text.
See also
SetTooltipText

◆ IsMultilineForce()

BOOL IsMultilineForce ( ) const

Determines if the tooltip text contains the new line character.

Returns
TRUE if the tooltip text contains the new line character, otherwise FALSE.

◆ SetFont()

void SetFont ( CFont * pFont )

Sets the font of the tooltip text.

Parameters
pFont Pointer to the font to be set.

◆ SetHoverRect()

AFX_INLINE void SetHoverRect ( CRect rc )

Sets the coordinates of the tooltip hover rectangle.

Parameters
rc CRect object containing the tooltip hover rectangle in parent window coordinates.

This method should be called before activating the tooltip window.

See also
GetHoverRect

◆ SetTooltipRect()

AFX_INLINE void SetTooltipRect ( CRect rc )

Sets the tooltip rectangle.

Parameters
rc CRect object containing the tooltip rectangle.

◆ SetTooltipText()

AFX_INLINE void SetTooltipText ( LPCTSTR str )

Sets the tooltip text.

Parameters
str New tooltip text.

This method should be called before activating the tooltip window.

See also
GetTooltipText
The documentation for this class was generated from the following file:
  • XTPGridTip.h


Toolkit Pro: CXTPGridView Class Reference

Public Member Functions | Public Attributes | Protected Member Functions | Protected Attributes | List of all members
CXTPGridView Class Reference

The CXTPGridView class provides an implementation of the Grid control as a view class. More...

Public Member Functions

void | SetTheme (XTPGridPaintTheme paintTheme, BOOL bEnableMetrics=FALSE)
Sets the Grid control theme.
virtual CXTPGridControl & | GetGridCtrl () const
Gets the Grid control.
void | SetGridCtrl (CXTPGridControl *pGrid)
Sets the Grid control.
CXTPGridPaintManager * | GetPaintManager () const
Gets the paint manager of the Grid control.
CXTPGridViewPrintOptions * | GetPrintOptions () const
Gets the print options of this view.
void | UpdateScrollBars ()
Updates the visibility and positions of scrollbars.

Public Attributes

BOOL | m_bAllowCut
If TRUE, then the cut operation is allowed.
BOOL | m_bAllowPaste
If TRUE, then the paste operation is allowed.
BOOL | m_bPrintDirect
If TRUE, then the print dialog is bypassed.
BOOL | m_bResizeControlWithView
If FALSE, then the attached Grid control will not be resized with the view.

Protected Member Functions

CXTPGridView ()
Protected constructor used by dynamic creation.
virtual | ~CXTPGridView ()
Destroys a CXTPGridView object, handles cleanup and deallocation.
virtual int | PrintPage (CDC *pDC, CPrintInfo *pInfo, CRect rcPage, int nRowFrom, int nColumnFrom, int nColumnTo)
Prints a single page of the Grid control.
virtual int | PrintGrid (CDC *pDC, CPrintInfo *pInfo, CRect rcPage, int nRowFrom, int nColumnFrom, int nColumnTo)
Prints the Grid control (columns, header, and rows) on the page.
virtual void | PrintHeader (CDC *pDC, CRect rcHeader)
Prints the header of each page.
virtual void | PrintFooter (CDC *pDC, CRect rcFooter)
Prints the footer of each page.
virtual int | PrintPageHeader (CDC *pDC, CPrintInfo *pInfo, CRect rcPage, BOOL bOnlyCalculate, int nPageNumber, int nNumberOfPages, int nHorizontalPageNumber, int nNumberOfHorizontalPages)
Prints the page header of the Grid control.
virtual int | PrintPageFooter (CDC *pDC, CPrintInfo *pInfo, CRect rcPage, BOOL bOnlyCalculate, int nPageNumber, int nNumberOfPages, int nHorizontalPageNumber, int nNumberOfHorizontalPages)
Prints the page footer of the Grid control.
void | SetScrollBarCtrl (CScrollBar *pScrollBar, BOOL bHor=FALSE)
Sets the external scrollbar control.
void | SetSliderCtrl (CSliderCtrl *pSlider)
Sets the external slider control.
int | PrintFixedRowsDivider (CDC *pDC, const CRect &rc, BOOL bHeaderRows)
Prints either the header or footer divider.
int | SetupStartCol (CDC *pDC, CPrintInfo *pInfo)
Prepares an array of columns for printing.
CScrollBar * | GetScrollBarCtrl (int nBar) const
Retrieves a specified scrollbar control.

Protected Attributes

BOOL | m_bSwitchMode
Tells whether to switch between modes (icon and grid).
BOOL | m_bShowRowNumber
TRUE to show the row number, FALSE otherwise.
CBitmap | m_bmpGrayDC
A temporary bitmap to convert a colored Grid control image to 'gray' colors when printing in black and white mode.
CXTPGridControl | m_wndGrid
Child Grid control window.
CXTPGridControl * | m_pGrid
Child Grid control pointer.
BOOL | m_bPrintSelection
TRUE if only printing the currently selected rows in the grid, FALSE if printing the entire grid.
CXTPGridViewPrintOptions * | m_pPrintOptions
Printing options.
CScrollBar * | m_pScrollBarVer
Pointer to external vertical scrollbar control.
CScrollBar * | m_pScrollBarHor
Pointer to external horizontal scrollbar control.

Detailed Description

The CXTPGridView class provides an implementation of the Grid control as a view class.

Use the GetGridCtrl method to access methods of CXTPGridControl.

See also
CXTPGridControl

Member Function Documentation

◆ GetGridCtrl()

virtual CXTPGridControl & GetGridCtrl ( ) const
virtual

Gets the Grid control.

Returns
A reference to the Grid control object.

◆ GetPaintManager()

CXTPGridPaintManager * GetPaintManager ( ) const

Gets the paint manager of the Grid control.

Returns
A pointer to the paint manager of the Grid control.

◆ GetPrintOptions()

AFX_INLINE CXTPGridViewPrintOptions * GetPrintOptions ( ) const

Gets the print options of this view.

Returns
A pointer to a CXTPGridViewPrintOptions object describing the print options of this view.

◆ GetScrollBarCtrl()

CScrollBar * GetScrollBarCtrl ( int nBar ) const
protected

Retrieves a specified scrollbar control.

Parameters
nBar Orientation flag; SB_HORZ to retrieve a horizontal scrollbar, SB_VERT to retrieve a vertical scrollbar.
Returns
A pointer to a CScrollBar object.

◆ PrintFixedRowsDivider()

int PrintFixedRowsDivider | ( | CDC * | pDC,
 |  | const CRect & | rc,
 |  | BOOL | bHeaderRows )
 protected

Prints either the header or footer divider.

Parameters
pDC | Pointer to a device context for page output.
rc | Reference to the bounding rectangle of the divider.
bHeaderRows | TRUE to print the header divider, FALSE to print the footer divider.
Returns
The height of the printed divider.

◆ PrintFooter()

virtual void PrintFooter | ( | CDC * | pDC,
 |  | CRect | rcFooter )
 protectedvirtual

Prints the footer of each page.

Parameters
pDC | Pointer to a device context for page output.
rcFooter | Footer bounding rectangle.

◆ PrintGrid()

virtual int PrintGrid | ( | CDC * | pDC,
 |  | CPrintInfo * | pInfo,
 |  | CRect | rcPage,
 |  | int | nRowFrom,
 |  | int | nColumnFrom,
 |  | int | nColumnTo )
 protectedvirtual

Prints the Grid control (columns, header, and rows) on the page.

Parameters
pDC | Pointer to a device context for page output.
pInfo | Pointer to a CPrintInfo structure that describes the current print job.
rcPage | Page bounding rectangle.
nRowFrom | First row to print.
nColumnFrom | First column to print.
nColumnTo | Next column after the last column to print.

This method calls the PrintHeader and PrintRows methods.

Returns
The index of the last printed row.

◆ PrintHeader()

virtual void PrintHeader | ( | CDC * | pDC,
 |  | CRect | rcHeader )
 protectedvirtual

Prints the header of each page.

Parameters
pDC | Pointer to a device context for page output.
rcHeader | Header bounding rectangle.

◆ PrintPage()

virtual int PrintPage | ( | CDC * | pDC,
 |  | CPrintInfo * | pInfo,
 |  | CRect | rcPage,
 |  | int | nRowFrom,
 |  | int | nColumnFrom,
 |  | int | nColumnTo )
 protectedvirtual

Prints a single page of the Grid control.

Parameters
pDC | Pointer to a device context for page output.
pInfo | Pointer to a CPrintInfo structure that describes the current print job.
rcPage | Page bounding rectangle.
nRowFrom | First row to print.
nColumnFrom | First column to print.
nColumnTo | Next column after the last column to print.

This method prints the page header, page footer, and calls the PrintGrid method.

Returns
The index of the last printed row.

◆ PrintPageFooter()

virtual int PrintPageFooter | ( | CDC * | pDC,
 |  | CPrintInfo * | pInfo,
 |  | CRect | rcPage,
 |  | BOOL | bOnlyCalculate,
 |  | int | nPageNumber,
 |  | int | nNumberOfPages,
 |  | int | nHorizontalPageNumber,
 |  | int | nNumberOfHorizontalPages )
 protectedvirtual

Prints the page footer of the Grid control.

Parameters
pDC | Pointer to a device context for page output.
pInfo | Pointer to a CPrintInfo structure that describes the current print job.
rcPage | Page print area.
bOnlyCalculate | TRUE to only calculate, FALSE to calculate and print.
nPageNumber | The printed page number.
nNumberOfPages | The total number of printed pages.
nHorizontalPageNumber | The printed horizontal page number.
nNumberOfHorizontalPages | The total number of printed horizontal pages.
Returns
The footer height in device units.

◆ PrintPageHeader()

virtual int PrintPageHeader | ( | CDC * | pDC,
 |  | CPrintInfo * | pInfo,
 |  | CRect | rcPage,
 |  | BOOL | bOnlyCalculate,
 |  | int | nPageNumber,
 |  | int | nNumberOfPages,
 |  | int | nHorizontalPageNumber,
 |  | int | nNumberOfHorizontalPages )
 protectedvirtual

Prints the page header of the Grid control.

Parameters
pDC | Pointer to a device context for page output.
pInfo | Pointer to a CPrintInfo structure that describes the current print job.
rcPage | Page print area.
bOnlyCalculate | TRUE to only calculate, FALSE to calculate and print.
nPageNumber | The printed page number.
nNumberOfPages | The total number of printed pages.
nHorizontalPageNumber | The printed horizontal page number.
nNumberOfHorizontalPages | The total number of printed horizontal pages.
Returns
The header height in device units.

◆ SetGridCtrl()

void SetGridCtrl ( CXTPGridControl * pGrid )

Sets the Grid control.

Parameters
pGrid Pointer to the Grid control object to be set.

◆ SetScrollBarCtrl()

void SetScrollBarCtrl | ( | CScrollBar * | pScrollBar,
 |  | BOOL | bHor = FALSE )
 protected

Sets the external scrollbar control.

Parameters
pScrollBar | Pointer to a CScrollBar object.
bHor | Orientation flag; TRUE for a horizontal scrollbar, FALSE for a vertical scrollbar.
See also
CScrollBar

◆ SetSliderCtrl()

void SetSliderCtrl ( CSliderCtrl * pSlider )
protected

Sets the external slider control.

Parameters
pSlider Pointer to a CSliderCtrl object.

◆ SetTheme()

void SetTheme | ( | XTPGridPaintTheme | paintTheme,
 |  | BOOL | bEnableMetrics = FALSE )

Sets the Grid control theme.

Parameters
paintTheme | Grid control theme; must be one of the values listed in the Remarks section.
bEnableMetrics | TRUE to allow the theme to override control metrics.

paintTheme can be one of the following values: xtpGridThemeDefault: Enables default theme. xtpGridThemeOfficeXP: Enables Office XP style theme. xtpGridThemeOffice2003: Enables Office 2003 style theme. xtpGridThemeOffice2007: Enables Office 2007 style theme. xtpGridThemeOffice2010: Enables Office 2010 style theme. xtpGridThemeOffice2013: Enables Office 2013 style theme. xtpGridThemeVisualStudio2005: Enables Visual Studio 2005 style theme. xtpGridThemeVisualStudio2010: Enables Visual Studio 2010 style theme. xtpGridThemeVisualStudio2012Light: Enables VS 2012 Light style Property Grid theme. xtpGridThemeVisualStudio2012Dark: Enables VS 2012 Dark style Property Grid theme. xtpGridThemeResource: Enables visual style theme.

◆ SetupStartCol()

int SetupStartCol | ( | CDC * | pDC,
 |  | CPrintInfo * | pInfo )
 protected

Prepares an array of columns for printing.

Parameters
pDC | Pointer to a device context for page output.
pInfo | Printing information.
Returns
The number of columns prepared for printing.

Member Data Documentation

◆ m_bPrintDirect

BOOL m_bPrintDirect

If TRUE, then the print dialog is bypassed.

FALSE by default.

◆ m_bResizeControlWithView

BOOL m_bResizeControlWithView

If FALSE, then the attached Grid control will not be resized with the view.

TRUE by default.

The documentation for this class was generated from the following file:
  • XTPGridView.h


Toolkit Pro: CXTPGridViewPrintOptions Class Reference

Public Member Functions | Public Attributes | List of all members
CXTPGridViewPrintOptions Class Reference

This class is used to store printing options. More...

Public Member Functions

CXTPGridViewPrintOptions ()
Constructs a CXTPGridViewPrintOptions object.
virtual LCID | GetActiveLCID ()
Override this member function in a derived class to retrieve the active locale ID.
virtual void | Set (const CXTPGridViewPrintOptions *pSrc)
Copies members from a specified source object.

Public Attributes

BOOL | m_bRepeatHeaderRows
If TRUE, then the header rows will be printed on every page.
BOOL | m_bRepeatFooterRows
If TRUE, then the footer rows will be printed on every page.

Detailed Description

This class is used to store printing options.

See also
CXTPPrintOptions, CXTPPrintPageHeaderFooter

Member Function Documentation

◆ GetActiveLCID()

virtual LCID GetActiveLCID ( )
virtual

Override this member function in a derived class to retrieve the active locale ID.

Returns
Locale ID. Base implementation returns LOCALE_USER_DEFAULT;

◆ Set()

virtual void Set ( const CXTPGridViewPrintOptions * pSrc )
virtual

Copies members from a specified source object.

Parameters
pSrc Pointer to a source object to copy data from.

Member Data Documentation

◆ m_bRepeatFooterRows

BOOL m_bRepeatFooterRows

If TRUE, then the footer rows will be printed on every page.

FALSE by default.

◆ m_bRepeatHeaderRows

BOOL m_bRepeatHeaderRows

If TRUE, then the header rows will be printed on every page.

FALSE by default.

The documentation for this class was generated from the following file:
  • XTPGridPageSetupDialog.h


Toolkit Pro: CXTPGroupLine Class Reference

Public Member Functions | List of all members
CXTPGroupLine Class Reference

CXTPGroupLine is a CStatic derived class. More...

Public Member Functions

CXTPGroupLine ()
Constructs a CXTPGroupLine object.

Detailed Description

CXTPGroupLine is a CStatic derived class.

It used in CXTPCustomizeOptionsPage page to draw group line static control.

The documentation for this class was generated from the following file:
  • XTPCustomizePageOptions.h


Toolkit Pro: CXTPHeaderCtrl Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPHeaderCtrl Class Reference

CXTPHeaderCtrl is a CHeaderCtrl derived class. More...

Public Member Functions

CXTPHeaderCtrl ()
Constructs a CXTPHeaderCtrl object.
virtual | ~CXTPHeaderCtrl ()
Destroys a CXTPHeaderCtrl object, handles cleanup and deallocation.
void | EnableAutoSize (bool bEnable=true)
Call this member function to enable auto-sizing for the header control.
void | FreezeColumn (int iCol)
Call this member function to freeze a column in the header control.
void | ThawColumn (int iCol)
Call this member function to thaw a column in the header control.
void | ThawAllColumns ()
Call this member function to thaw all columns in the header control.
bool | IsColFrozen (int iCol)
Call this member function to determine if a specified column is frozen.
void | SetMinSize (int iMinSize)
Call this member to set the minimum size for auto-sizing columns.
int | SetSortImage (int iSortCol, BOOL bSortAsc)
This member function will set the sort image for the specified column.
int | GetSortedCol (BOOL *pbSortAsc=NULL)
Call this member function to return the index to the currently sorted column.
void | SetBitmap (int iCol, UINT uBitmapID, DWORD dwRemove=NULL)
Call this member function to set the bitmap image for the specified header item.
void | SetBitmap (int iCol, UINT uBitmapID, BOOL bRemove, COLORREF crMask)
Call this member function to set the bitmap image for the specified header item.
virtual BOOL | ItemPressed (int iItem)
Call this member function to determine if the specified header item is pressed (selected).
virtual void | OnThemeChanged ()
This member function is called whenever the theme has changed.
BOOL | IsThemeValid () const
This member function is called to check if the header control is using a theme.
int | HitTest (CPoint pt, UINT *pFlags=NULL) const
Tests a point to determine which header item, if any, is at the specified point.
BOOL | RecalcLayout ()
Called by the header control to recalculate the size and layout for the header control and header items.
virtual void | InitializeHeader (BOOL bBoldFont)
This member function must be called after creation to initialize the font that the header will use.
virtual void | SetMenuID (UINT popupMenuID, int nPos=0)
This member function is called to associate a menu and toolbar resource with the context menu.
virtual void | SetFontBold (BOOL bBoldFont=TRUE)
This member function can be used to toggle the font from bold to normal.
virtual void | ShowSortArrow (BOOL bSortArrow)
Call this member function to enable/disable the column sort arrow.
virtual BOOL | SetAlingment (int nFlag)
Call this member function to set the text justification for the header control.
BOOL | GetAscending () const
Call this member function to determine if the current sorting order is ascending.
void | EnablePopupMenus (BOOL bEnableMenus)
Call this member function to enable/disable the pop-up menu display whenever a user right clicks on the header control.
BOOL | HasSortArrow ()
Call this member function to determine if the header control displays a sort arrow.
void | ResizeColumnsToFit ()
Call this member function to resize all header columns equally to fit the available client area.
CXTPImageManager * | GetImageManager () const
Retrieves the image manager associated with the header.
void | SetImageManager (CXTPImageManager *pImageManager)
Call this method to assign a new image manager.
BOOL | SetTheme (XTPControlTheme eTheme)
Call this member to change the visual theme of the control.
BOOL | SetTheme (CXTPHeaderCtrlTheme *pTheme)
Call this member to change the visual theme of the control.
CXTPHeaderCtrlTheme * GetTheme ()
Call this member function to get a pointer to the currently selected theme.
BOOL | IsDpiBitmapScalingEnabled () const
Gets DPI bitmap scaling flag.
void | EnableDpiBitmapScaling (BOOL bEnable=TRUE)
Sets DPI bitmap scaling flag.

Protected Member Functions

virtual bool | DetermineRTL ()
This member function is used by the header control to determine the text alignment for the system locale.
virtual void | ApplyFieldWidths (int iNewWidth)
This member function is used by the header control to auto-size the columns for the list control.
virtual void | FitFieldWidths (int iNewWidth)
This member function is used by the header control to determine the new width for auto-sized columns and to resize the columns accordingly.
virtual int | GetFrozenColWidth ()
This member function is used by the header control to determine the total width of all frozen columns in the header control.
void | SendNotify (int iIndex)
Called to send WM_NOTIFY to tell the parent's owner that a column needs to be sorted.
virtual void | RefreshMetrics ()
Call this member function to refresh theme colors and redraw the control.

Protected Attributes

int | m_iMinSize
Minimum column size for an auto-size header control.
int | m_nPos
Index of the pop-up menu contained in the menu.
int | m_iOverIndex
Column that the mouse is currently hovering over.
int | m_nSortedCol
Last column pressed during sort.
bool | m_bRTL
Used internally to determine if text is right-to-left or left-to-right (depends on system locale).
bool | m_bAutoSize
true if the header control columns are auto-sizing.
BOOL | m_bEnableMenus
TRUE to disable the pop-up menu display.
BOOL | m_bAscending
Used, when column is pressed, to draw a sort arrow.
BOOL | m_bLBtnDown
TRUE if the left mouse button is pressed.
BOOL | m_bPainted
Used during paint operations.
UINT | m_popupMenuID
Pop-up menu resource ID.
CPoint | m_pt
Point where right click took place.
CList< int, int & > | m_arFrozenCols
List of columns that are not sizable.
CXTPHeaderCtrlTheme * | m_pTheme
Pointer to the active theme.
CXTPImageManager * | m_pImageManager
Pointer to the ImageManager associated with the header.
BOOL | m_bDpiBitmapScaling
DPI bitmap scaling flag.
BOOL | m_bDpiBitmapScalingModified
Indicates that m_bDpiBitmapScaling has been modified.

Detailed Description

CXTPHeaderCtrl is a CHeaderCtrl derived class.

It is used to create a CXTPHeaderCtrl window similar to CHeaderCtrl, but with additional functionality.

A "header control" is a window that is usually positioned above columns of text or numbers. It contains a title for each column, and it can be divided into parts. The user can drag the dividers that separate the parts to set the width of each column.

Use a header control, represented by class CXTPHeaderCtrl, to display column headers for a columnar list. For example, a header control would be useful for implementing column controls in a spreadsheet.

The header control is usually divided into parts, called "header items", each bearing a title for the associated column of text or numbers. Depending on the styles you set, you can provide a number of direct ways for users to manipulate the header items.

Member Function Documentation

◆ ApplyFieldWidths()

virtual void ApplyFieldWidths ( int iNewWidth )
protectedvirtual

This member function is used by the header control to auto-size the columns for the list control.

Parameters
iNewWidth New width to resize all columns to.

◆ DetermineRTL()

virtual bool DetermineRTL ( )
protectedvirtual

This member function is used by the header control to determine the text alignment for the system locale.

Returns
true if the text alignment is right-to-left (RTL), or false if the text alignment is left-to-right (LTR).

◆ EnableAutoSize()

void EnableAutoSize ( bool bEnable = true )

Call this member function to enable auto-sizing for the header control.

This will cause the columns in the list control to be sized to fit in the available space when the list control is resized.

Parameters
bEnable true to enable an auto-sizing header control.

◆ EnableDpiBitmapScaling()

void EnableDpiBitmapScaling ( BOOL bEnable = TRUE )

Sets DPI bitmap scaling flag.

If set, all raster icons and bitmaps used in the control will be stretched automatically if DPI scaling factor for control's window isn't equal to 100%. The default value is derived from CXTPDpi::IsDpiBitmapScalingEnabled. Once changed the new value will be used.

Parameters
bEnable TRUE to enable bitmaps scaling, FALSE to disable.

◆ EnablePopupMenus()

void EnablePopupMenus ( BOOL bEnableMenus )

Call this member function to enable/disable the pop-up menu display whenever a user right clicks on the header control.

Parameters
bEnableMenus TRUE to enable pop-up menus, FALSE to disable.

◆ FitFieldWidths()

virtual void FitFieldWidths ( int iNewWidth )
protectedvirtual

This member function is used by the header control to determine the new width for auto-sized columns and to resize the columns accordingly.

Parameters
iNewWidth New width to resize all columns to. If iNewWidth is '0', then columns are equally sized to fit the available client area.

◆ FreezeColumn()

void FreezeColumn ( int iCol )

Call this member function to freeze a column in the header control.

Freezing a column will disable sizing for the column.

Parameters
iCol Index of the column to freeze.

◆ GetAscending()

BOOL GetAscending ( ) const

Call this member function to determine if the current sorting order is ascending.

Returns
TRUE if the sorting order is ascending, otherwise FALSE.

◆ GetFrozenColWidth()

virtual int GetFrozenColWidth ( )
protectedvirtual

This member function is used by the header control to determine the total width of all frozen columns in the header control.

Returns
The combined size, in pixels, of all frozen columns.

◆ GetImageManager()

CXTPImageManager * GetImageManager ( ) const

Retrieves the image manager associated with the header.

Returns
Pointer to the image manager object that stores images in the header.

◆ GetSortedCol()

int GetSortedCol ( BOOL * pbSortAsc = NULL )

Call this member function to return the index to the currently sorted column.

Parameters
pbSortAsc Set to TRUE if ascending, otherwise FALSE.
Returns
The index of the currently sorted column.

◆ GetTheme()

CXTPHeaderCtrlTheme * GetTheme ( )

Call this member function to get a pointer to the currently selected theme.

Returns
A pointer to a CXTPHeaderCtrlTheme object representing the currently selected theme.

◆ HasSortArrow()

BOOL HasSortArrow ( )

Call this member function to determine if the header control displays a sort arrow.

Returns
TRUE if the header control displays a sort arrow, otherwise FALSE.

◆ HitTest()

int HitTest | ( | CPoint | pt,
 |  | UINT * | pFlags = NULL ) const

Tests a point to determine which header item, if any, is at the specified point.

Parameters
pt | POINT structure that contains the point to be hit test, in client coordinates.
pFlags | Variable that receives information about the results of a hit test. This member can be one or more of the values listed in the Remarks section.

pFlags can be one or more of the following values: HHT_ABOVE: The point is above the header control's bounding rectangle. HHT_BELOW: The point is below the header control's bounding rectangle. HHT_NOWHERE: The point is inside the header control's bounding rectangle but is not over a header item. HHT_ONDIVIDER: The point is on the divider between two header items. HHT_ONDIVOPEN: The point is on the divider of an item that has a width of zero. Dragging the divider reveals the item instead of resizing the item to the left of the divider. HHT_ONHEADER: The point is inside the header control's bounding rectangle. HHT_ONFILTER: Version 5.80 The point is over the filter area. HHT_ONFILTERBUTTON: Version 5.80 The point is on the filter button. HHT_TOLEFT: The point is to the left of the header control's bounding rectangle. HHT_TORIGHT: The point is to the right of the header control's bounding rectangle.

Returns
If the hit test is successful, returns the index of the item at the hit test point, if any. Otherwise, returns a value of -1.

◆ InitializeHeader()

virtual void InitializeHeader ( BOOL bBoldFont )
virtual

This member function must be called after creation to initialize the font that the header will use.

Parameters
bBoldFont TRUE if the header's font should be bold.

◆ IsColFrozen()

bool IsColFrozen ( int iCol )

Call this member function to determine if a specified column is frozen.

Parameters
iCol Index of the column to check.
Returns
true if the column is frozen, otherwise false.

◆ IsDpiBitmapScalingEnabled()

BOOL IsDpiBitmapScalingEnabled ( ) const

Gets DPI bitmap scaling flag.

If set, all raster icons and bitmaps used in the control will be stretched automatically if DPI scaling factor for control's window isn't equal to 100%. The default value is derived from CXTPDpi::IsDpiBitmapScalingEnabled. Once changed the new value will be used.

Returns
The current value of the DPI bitmap scaling flag for the control.

◆ IsThemeValid()

BOOL IsThemeValid ( ) const

This member function is called to check if the header control is using a theme.

Returns
TRUE if a theme is used, otherwise FALSE.

◆ ItemPressed()

virtual BOOL ItemPressed ( int iItem )
virtual

Call this member function to determine if the specified header item is pressed (selected).

Parameters
iItem Index of the header item to check.
Returns
TRUE if the specified header item is pressed (selected).

◆ OnThemeChanged()

virtual void OnThemeChanged ( )
virtual

This member function is called whenever the theme has changed.

Override this member function to add additional functionality whenever the control theme changes.

◆ RecalcLayout()

BOOL RecalcLayout ( )

Called by the header control to recalculate the size and layout for the header control and header items.

Returns
TRUE if successful, otherwise FALSE.

◆ SendNotify()

void SendNotify ( int iIndex )
protected

Called to send WM_NOTIFY to tell the parent's owner that a column needs to be sorted.

Parameters
iIndex Index of the column to be sorted.

◆ SetAlingment()

virtual BOOL SetAlingment ( int nFlag )
virtual

Call this member function to set the text justification for the header control.

Parameters
nFlag Text alignment; either LVCFMT_CENTER, LVCFMT_LEFT, or LVCFMT_RIGHT.
Returns
TRUE if successful, otherwise FALSE.

◆ SetBitmap() [1/2]

void SetBitmap | ( | int | iCol,
 |  | UINT | uBitmapID,
 |  | BOOL | bRemove,
 |  | COLORREF | crMask )

Call this member function to set the bitmap image for the specified header item.

Parameters
iCol | Zero-based index of the column to set the sort image for.
uBitmapID | Resource ID of the bitmap to use.
bRemove | TRUE to remove a bitmap, FALSE if adding a bitmap.
crMask Color used to generate the mask. Each pixel of this color in the given bitmap is changed to black and the corresponding bit in the mask is set to one. Example: The following example demonstrates the use of SetBitmap.
// add bitmap images.
m_header.SetBitmap(0, IDB_COLUMN_0, FALSE, RGB(0, 255, 0));
m_header.SetBitmap(1, IDB_COLUMN_1, FALSE, RGB(0, 255, 0));
m_header.SetBitmap(2, IDB_COLUMN_2, FALSE, RGB(0, 255, 0));

◆ SetBitmap() [2/2]

void SetBitmap | ( | int | iCol,
 |  | UINT | uBitmapID,
 |  | DWORD | dwRemove = NULL )

Call this member function to set the bitmap image for the specified header item.

Parameters
iCol | Zero-based index of the column to set the sort image for.
uBitmapID | Resource ID of the bitmap to use.
dwRemove Indicates the header format style to remove, see HD_ITEM structure. Example: The following example demonstrates the use of SetBitmap.
// add bitmap images.
m_header.SetBitmap(0, IDB_COLUMN_0, FALSE, RGB(0, 255, 0));
m_header.SetBitmap(1, IDB_COLUMN_1, FALSE, RGB(0, 255, 0));
m_header.SetBitmap(2, IDB_COLUMN_2, FALSE, RGB(0, 255, 0));

◆ SetFontBold()

virtual void SetFontBold ( BOOL bBoldFont = TRUE )
virtual

This member function can be used to toggle the font from bold to normal.

Parameters
bBoldFont TRUE if the header's font should be bold.

◆ SetImageManager()

void SetImageManager ( CXTPImageManager * pImageManager )

Call this method to assign a new image manager.

Parameters
pImageManager Pointer to the new image manager object that will store images in the header.

◆ SetMenuID()

virtual void SetMenuID | ( | UINT | popupMenuID,
 |  | int | nPos = 0 )
 virtual

This member function is called to associate a menu and toolbar resource with the context menu.

Parameters
popupMenuID | Resource ID for the pop-up menu used with the header.
nPos | Position of the submenu to be displayed.

◆ SetMinSize()

void SetMinSize ( int iMinSize )

Call this member to set the minimum size for auto-sizing columns.

The minimum size represents the smallest size that all columns can be sized to.

Parameters
iMinSize Minimum column size.

◆ SetSortImage()

int SetSortImage | ( | int | iSortCol,
 |  | BOOL | bSortAsc )

This member function will set the sort image for the specified column.

Parameters
iSortCol | Zero-based index of the column to set the sort image for.
bSortAsc | TRUE if ascending, otherwise FALSE.
Returns
A zero-based index of the previously sorted column.

◆ SetTheme() [1/2]

BOOL SetTheme ( CXTPHeaderCtrlTheme * pTheme )

Call this member to change the visual theme of the control.

Parameters
pTheme New window theme pointer.
Returns
TRUE if successful; otherwise FALSE.

◆ SetTheme() [2/2]

BOOL SetTheme ( XTPControlTheme eTheme )

Call this member to change the visual theme of the control.

Parameters
eTheme New window theme. Can be any of the values listed in the Remarks section.

eTheme can be one of the following values: xtpControlThemeDefault: Use default theme. xtpControlThemeNativeWinXP: Use Windows Explorer theme. xtpControlThemeOfficeXP: Use Office XP theme. xtpControlThemeOffice2003: Use Office 2003 theme.

Returns
TRUE if successful; otherwise FALSE.

◆ ShowSortArrow()

virtual void ShowSortArrow ( BOOL bSortArrow )
virtual

Call this member function to enable/disable the column sort arrow.

Parameters
bSortArrow TRUE to draw the column sort arrow.

◆ ThawAllColumns()

void ThawAllColumns ( )

Call this member function to thaw all columns in the header control.

This will will enable sizing for any column that was previously frozen.

◆ ThawColumn()

void ThawColumn ( int iCol )

Call this member function to thaw a column in the header control.

Thawing a column will enable sizing for the column if it was previously frozen.

Parameters
iCol Index of the column to thaw.
The documentation for this class was generated from the following file:
  • XTPHeaderCtrl.h


Toolkit Pro: CXTPHeaderCtrlTheme Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPHeaderCtrlTheme Class Reference

CXTPHeaderCtrlTheme is a theme class used to draw a Windows classic style theme for the header control. More...

Inheritance diagram for CXTPHeaderCtrlTheme:
[legend]

Public Member Functions

CXTPHeaderCtrlTheme ()
Constructs a CXTPHeaderCtrlTheme object using the specified header control.
virtual | ~CXTPHeaderCtrlTheme ()
Destroys a CXTPHeaderCtrlTheme object, handles cleanup and deallocation.
CXTPWinThemeWrapper * GetThemeWrapper ()
Call this member function to return a pointer to the Windows theme API wrapper for this control.
virtual void | DrawHeader (CDC *pDC, CXTPHeaderCtrl *pHeaderCtrl)
Call this member function from the header control's WM_PAINT message to perform themed drawing.
virtual void | RefreshMetrics (CXTPHeaderCtrl *pHeader)
Call this member whenever the system colors need to be updated.
virtual BOOL | UseWinXPThemes (CXTPHeaderCtrl *pHeaderCtrl)
This member function can be called to determine if Windows XP themes can be displayed for the header control.
virtual void | SetDrawStyle (DWORD dwDrawStyle, CXTPHeaderCtrl *pHeaderCtrl)
Call this member function to set the desired HDRARROW_XTP_drawing styles for the header theme.
virtual DWORD | GetDrawStyle () const
Call this member function to return the current drawing style used by the header theme.
virtual BOOL | Layout (LPHDLAYOUT lpHDL, CXTPHeaderCtrl *pHeaderCtrl)
Retrieves the size and position of a header control within a given rectangle.
virtual void | CleanUp (CXTPHeaderCtrl *pHeaderCtrl)
Cleans up allocated GDI resources used by the theme.
virtual BOOL | SetBitmap (int iCol, UINT uBitmapID, BOOL bRemove, COLORREF crMask, CXTPHeaderCtrl *pHeaderCtrl)
Call this member function to set the bitmap image for the specified header item.
BOOL | HasSortArrow ()
Call this member function to determine if the header control displays a sort arrow.
- Public Member Functions inherited from CXTPControlTheme
CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme | GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

virtual void | OnDrawBackground (LPDRAWITEMSTRUCT lpDIS)
This member function is called by the theme to draw the header control's background.
virtual BOOL | OnDrawBackgroundWinThemed (LPDRAWITEMSTRUCT lpDIS)
This member function is called by the theme to draw the header control's background using Windows themes.
virtual void | OnDrawItemBackground (LPDRAWITEMSTRUCT lpDIS)
This member function is called by the theme to draw the background for the header item specified by lpDIS->itemID.
virtual BOOL | OnDrawItemBackgroundWinThemed (LPDRAWITEMSTRUCT lpDIS)
This member function is called by the theme to draw the background using Windows themes for the header item specified by lpDIS->itemID.
virtual void | OnDrawItemSortArrow (LPDRAWITEMSTRUCT lpDIS, BOOL bAscending)
This member function is called by the theme to draw the sort used to display the sort order for a header item specified by lpDIS->itemID.
virtual void | OnDrawItemText (LPDRAWITEMSTRUCT lpDIS, CXTPHeaderCtrl *pHeaderCtrl)
This member function is called to draw the text for the header item specified by lpDIS->itemID.
virtual void | OnDrawItemBitmap (LPDRAWITEMSTRUCT lpDIS, CRect &rcText, CXTPHeaderCtrl *pHeaderCtrl)
This member function is called to draw a bitmap for the header item specified by lpDIS->itemID.
virtual void | DrawSortArrow (CDC *pDC, LPPOINT ptsArrow, BOOL bAscending)
This member function is called by CXTPHeaderCtrlTheme::OnDrawItemSortArrow to draw the sort arrow.

Protected Attributes

int | m_iArrowPadding
Spacing between text and sort arrow.
DWORD | m_dwDrawStyle
Style flags used by theme, see CXTPHeaderCtrlTheme::SetDrawStyle().
BOOL | m_bUseWinThemes
TRUE to use Windows XP themes when available.
CSize | m_sizePadding
Leading and trailing padding for text display.
CSize | m_sizeArrow
Width and height of sort arrow.
COLORREF | m_crText
RGB value for text color.
COLORREF | m_cr3DFace
RGB value for header background color.
COLORREF | m_cr3DShadow
RGB value for border shadow color.
COLORREF | m_cr3DDkShadow
RGB value for border dark shadow color.
COLORREF | m_cr3DHighLight
RGB value for border highlight color.
CXTPWinThemeWrapper * | m_themeHeader
Wraps the Windows XP theme API that is used to display Windows XP themes.
- Protected Attributes inherited from CXTPControlTheme
XTPControlTheme | m_nTheme
Currently selected theme style index.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlTheme
static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

CXTPHeaderCtrlTheme is a theme class used to draw a Windows classic style theme for the header control.

The CXTPHeaderCtrlTheme class provides theme capability to the CXTPHeaderCtrl class. You can derive a class from CXTPHeaderCtrlTheme to create custom user defined themes.

To use this class, first subclass your header control using the Windows API SubclassWindow and a CXTPHeaderCtrl base class. Once you have done this, you can call SetTheme and pass in a pointer to the theme you wish to use for the header control.

Member Function Documentation

◆ CleanUp()

virtual void CleanUp ( CXTPHeaderCtrl * pHeaderCtrl )
virtual

Cleans up allocated GDI resources used by the theme.

Parameters
pHeaderCtrl Pointer to a CXTPHeaderCtrl object.

The CXTPHeaderCtrlTheme class calls this member function to free GDI resources that have been allocated during draw routines.

◆ DrawHeader()

virtual void DrawHeader | ( | CDC * | pDC,
 |  | CXTPHeaderCtrl * | pHeaderCtrl )
 virtual

Call this member function from the header control's WM_PAINT message to perform themed drawing.

Parameters
pDC | Pointer to a valid device context.
pHeaderCtrl | Pointer to a CXTPHeaderCtrl object.

Called by the CXTPHeaderCtrlTheme class to render the header for the CXTPHeaderCtrl object.

◆ DrawSortArrow()

virtual void DrawSortArrow | ( | CDC * | pDC,
 |  | LPPOINT | ptsArrow,
 |  | BOOL | bAscending )
 protectedvirtual

This member function is called by CXTPHeaderCtrlTheme::OnDrawItemSortArrow to draw the sort arrow.

Parameters
pDC | Pointer to a valid device context.
ptsArrow | POINT array used to define the 3 points of the arrow drawn.
bAscending | TRUE if the arrow is to be drawn ascending.

Reimplemented in CXTPHeaderCtrlThemeExplorer, and CXTPHeaderCtrlThemeResource.

◆ GetDrawStyle()

virtual DWORD GetDrawStyle ( ) const
virtual

Call this member function to return the current drawing style used by the header theme.

Returns
The current HDRARROW_XTP_(xt theme) settings for the header control. See SetDrawStyle for the complete list of available styles.
See also
SetDrawStyle

◆ GetThemeWrapper()

CXTPWinThemeWrapper * GetThemeWrapper ( )

Call this member function to return a pointer to the Windows theme API wrapper for this control.

Returns
A CXTPWinThemeWrapper pointer.

◆ HasSortArrow()

BOOL HasSortArrow ( )

Call this member function to determine if the header control displays a sort arrow.

Returns
TRUE if the header control displays a sort arrow, otherwise FALSE.

◆ Layout()

virtual BOOL Layout | ( | LPHDLAYOUT | lpHDL,
 |  | CXTPHeaderCtrl * | pHeaderCtrl )
 virtual

Retrieves the size and position of a header control within a given rectangle.

This function is used to determine the appropriate dimensions for a new header control that is to occupy the given rectangle.

Parameters
lpHDL | Pointer to an HDLAYOUT structure, which contains information used to set the size and position of a header control.
pHeaderCtrl | Pointer to a CXTPHeaderCtrl object.
Returns
Nonzero if successful, otherwise 0.

Reimplemented in CXTPHeaderCtrlThemeExplorer, and CXTPHeaderCtrlThemeOffice2003.

◆ OnDrawBackground()

virtual void OnDrawBackground ( LPDRAWITEMSTRUCT lpDIS )
protectedvirtual

This member function is called by the theme to draw the header control's background.

Parameters
lpDIS A long pointer to a DRAWITEMSTRUCT structure. The structure contains information about the item to be drawn and the type of drawing required.

Reimplemented in CXTPHeaderCtrlThemeExplorer, CXTPHeaderCtrlThemeOffice2003, CXTPHeaderCtrlThemeOfficeXP, and CXTPHeaderCtrlThemeResource.

◆ OnDrawBackgroundWinThemed()

virtual BOOL OnDrawBackgroundWinThemed ( LPDRAWITEMSTRUCT lpDIS )
protectedvirtual

This member function is called by the theme to draw the header control's background using Windows themes.

Parameters
lpDIS A long pointer to a DRAWITEMSTRUCT structure. The structure contains information about the item to be drawn and the type of drawing required.
Returns
TRUE if successful, otherwise FALSE.

◆ OnDrawItemBackground()

virtual void OnDrawItemBackground ( LPDRAWITEMSTRUCT lpDIS )
protectedvirtual

This member function is called by the theme to draw the background for the header item specified by lpDIS->itemID.

Parameters
lpDIS A long pointer to a DRAWITEMSTRUCT structure. The structure contains information about the item to be drawn and the type of drawing required.

Reimplemented in CXTPHeaderCtrlThemeOffice2003, CXTPHeaderCtrlThemeOfficeXP, and CXTPHeaderCtrlThemeResource.

◆ OnDrawItemBackgroundWinThemed()

virtual BOOL OnDrawItemBackgroundWinThemed ( LPDRAWITEMSTRUCT lpDIS )
protectedvirtual

This member function is called by the theme to draw the background using Windows themes for the header item specified by lpDIS->itemID.

Parameters
lpDIS A long pointer to a DRAWITEMSTRUCT structure. The structure contains information about the item to be drawn and the type of drawing required.
Returns
TRUE if successful, otherwise FALSE.

Reimplemented in CXTPHeaderCtrlThemeExplorer.

◆ OnDrawItemBitmap()

virtual void OnDrawItemBitmap | ( | LPDRAWITEMSTRUCT | lpDIS,
 |  | CRect & | rcText,
 |  | CXTPHeaderCtrl * | pHeaderCtrl )
 protectedvirtual

This member function is called to draw a bitmap for the header item specified by lpDIS->itemID.

Parameters
lpDIS | A long pointer to a DRAWITEMSTRUCT structure. The structure contains information about the item to be drawn and the type of drawing required.
rcText | Size of the area where the header item text is displayed.
pHeaderCtrl | Pointer to a CXTPHeaderCtrl object.

◆ OnDrawItemSortArrow()

virtual void OnDrawItemSortArrow | ( | LPDRAWITEMSTRUCT | lpDIS,
 |  | BOOL | bAscending )
 protectedvirtual

This member function is called by the theme to draw the sort used to display the sort order for a header item specified by lpDIS->itemID.

Parameters
lpDIS | A long pointer to a DRAWITEMSTRUCT structure. The structure contains information about the item to be drawn and the type of drawing required.
bAscending | TRUE if the arrow is to be draw ascending.

Reimplemented in CXTPHeaderCtrlThemeResource.

◆ OnDrawItemText()

virtual void OnDrawItemText | ( | LPDRAWITEMSTRUCT | lpDIS,
 |  | CXTPHeaderCtrl * | pHeaderCtrl )
 protectedvirtual

This member function is called to draw the text for the header item specified by lpDIS->itemID.

Parameters
lpDIS | A long pointer to a DRAWITEMSTRUCT structure. The structure contains information about the item to be drawn and the type of drawing required.
pHeaderCtrl | Pointer to a CXTPHeaderCtrl object.

Reimplemented in CXTPHeaderCtrlThemeResource.

◆ RefreshMetrics()

virtual void RefreshMetrics ( CXTPHeaderCtrl * pHeader )
virtual

Call this member whenever the system colors need to be updated.

Parameters
pHeader Pointer to the CXTPHeaderCtrl object.

Reimplemented in CXTPHeaderCtrlThemeResource.

◆ SetBitmap()

virtual BOOL SetBitmap | ( | int | iCol,
 |  | UINT | uBitmapID,
 |  | BOOL | bRemove,
 |  | COLORREF | crMask,
 |  | CXTPHeaderCtrl * | pHeaderCtrl )
 virtual

Call this member function to set the bitmap image for the specified header item.

Parameters
iCol | Zero-based index of the column to set the sort image for.
uBitmapID | Resource ID of the bitmap to use.
bRemove | TRUE to remove a bitmap, FALSE if adding a bitmap.
crMask | Color used to generate the mask. Each pixel of this color in the given bitmap is changed to black and the corresponding bit in the mask is set to one.
pHeaderCtrl | Pointer to a CXTPHeaderCtrl object.
Returns
TRUE if successful, otherwise FALSE.

◆ SetDrawStyle()

virtual void SetDrawStyle | ( | DWORD | dwDrawStyle,
 |  | CXTPHeaderCtrl * | pHeaderCtrl )
 virtual

Call this member function to set the desired HDRARROW_XTP_drawing styles for the header theme.

Parameters
dwDrawStyle | The desired styles for the header control theme. Can be one or more of the values listed in the remarks section.
pHeaderCtrl | Pointer to a CXTPHeaderCtrl object.

Does not affect the WS_ (window style) settings. Styles to be added or removed can be combined by using the bitwise OR (|) operator. It can be one or more of the following:

HDR_XTP_WINDEF: Allows the header control to display Windows XP themes when they are available. HDR_XTP_HOTTRACKING: Allows the header control to display mouse over effects for the header control. HDR_XTP_SORTARROW: Allows the header control to display a sort arrow to indicate sort order.

See also
GetDrawStyle

◆ UseWinXPThemes()

virtual BOOL UseWinXPThemes ( CXTPHeaderCtrl * pHeaderCtrl )
virtual

This member function can be called to determine if Windows XP themes can be displayed for the header control.

Parameters
pHeaderCtrl Pointer to a CXTPHeaderCtrl object.
Returns
TRUE if Windows themes can be displayed, otherwise FALSE.
The documentation for this class was generated from the following file:
  • XTPHeaderCtrlTheme.h


Toolkit Pro: CXTPHeaderCtrlThemeExplorer Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPHeaderCtrlThemeExplorer Class Reference

CXTPHeaderCtrlThemeExplorer is a CXTPHeaderCtrlThemeOffice2003 derived theme class used to draw an Office XP style theme for the header control. More...

Inheritance diagram for CXTPHeaderCtrlThemeExplorer:
[legend]

Public Member Functions

CXTPHeaderCtrlThemeExplorer ()
Constructs a CXTPHeaderCtrlThemeExplorer object using the specified header control.
virtual | ~CXTPHeaderCtrlThemeExplorer ()
Destroys a CXTPHeaderCtrlThemeExplorer object, handles cleanup and deallocation.
virtual BOOL | Layout (LPHDLAYOUT lpHDL, CXTPHeaderCtrl *pHeaderCtrl)
Retrieves the size and position of a header control within a given rectangle.
- Public Member Functions inherited from CXTPHeaderCtrlThemeOffice2003
CXTPHeaderCtrlThemeOffice2003 ()
Constructs a CXTPHeaderCtrlThemeOffice2003 object using the specified header control.
virtual | ~CXTPHeaderCtrlThemeOffice2003 ()
Destroys a CXTPHeaderCtrlThemeOffice2003 object, handles cleanup and deallocation.
- Public Member Functions inherited from CXTPHeaderCtrlTheme
CXTPHeaderCtrlTheme ()
Constructs a CXTPHeaderCtrlTheme object using the specified header control.
virtual | ~CXTPHeaderCtrlTheme ()
Destroys a CXTPHeaderCtrlTheme object, handles cleanup and deallocation.
CXTPWinThemeWrapper * GetThemeWrapper ()
Call this member function to return a pointer to the Windows theme API wrapper for this control.
virtual void | DrawHeader (CDC *pDC, CXTPHeaderCtrl *pHeaderCtrl)
Call this member function from the header control's WM_PAINT message to perform themed drawing.
virtual void | RefreshMetrics (CXTPHeaderCtrl *pHeader)
Call this member whenever the system colors need to be updated.
virtual BOOL | UseWinXPThemes (CXTPHeaderCtrl *pHeaderCtrl)
This member function can be called to determine if Windows XP themes can be displayed for the header control.
virtual void | SetDrawStyle (DWORD dwDrawStyle, CXTPHeaderCtrl *pHeaderCtrl)
Call this member function to set the desired HDRARROW_XTP_drawing styles for the header theme.
virtual DWORD | GetDrawStyle () const
Call this member function to return the current drawing style used by the header theme.
virtual void | CleanUp (CXTPHeaderCtrl *pHeaderCtrl)
Cleans up allocated GDI resources used by the theme.
virtual BOOL | SetBitmap (int iCol, UINT uBitmapID, BOOL bRemove, COLORREF crMask, CXTPHeaderCtrl *pHeaderCtrl)
Call this member function to set the bitmap image for the specified header item.
BOOL | HasSortArrow ()
Call this member function to determine if the header control displays a sort arrow.
- Public Member Functions inherited from CXTPControlTheme
CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme | GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

virtual BOOL | OnDrawItemBackgroundWinThemed (LPDRAWITEMSTRUCT lpDIS)
This member function is called by the theme to draw the background using Windows themes for the header item specified by lpDIS->itemID.
virtual void | DrawSortArrow (CDC *pDC, LPPOINT ptsArrow, BOOL bAscending)
This member function is called by CXTPHeaderCtrlTheme::OnDrawItemSortArrow to draw the sort arrow.
virtual void | OnDrawBackground (LPDRAWITEMSTRUCT lpDIS)
This member function is called by the theme to draw the header control's background.
- Protected Member Functions inherited from CXTPHeaderCtrlThemeOffice2003
virtual void | OnDrawItemBackground (LPDRAWITEMSTRUCT lpDIS)
This member function is called by the theme to draw the background for the header item specified by lpDIS->itemID.
- Protected Member Functions inherited from CXTPHeaderCtrlTheme
virtual BOOL | OnDrawBackgroundWinThemed (LPDRAWITEMSTRUCT lpDIS)
This member function is called by the theme to draw the header control's background using Windows themes.
virtual void | OnDrawItemSortArrow (LPDRAWITEMSTRUCT lpDIS, BOOL bAscending)
This member function is called by the theme to draw the sort used to display the sort order for a header item specified by lpDIS->itemID.
virtual void | OnDrawItemText (LPDRAWITEMSTRUCT lpDIS, CXTPHeaderCtrl *pHeaderCtrl)
This member function is called to draw the text for the header item specified by lpDIS->itemID.
virtual void | OnDrawItemBitmap (LPDRAWITEMSTRUCT lpDIS, CRect &rcText, CXTPHeaderCtrl *pHeaderCtrl)
This member function is called to draw a bitmap for the header item specified by lpDIS->itemID.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlTheme
static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Attributes inherited from CXTPHeaderCtrlTheme
int | m_iArrowPadding
Spacing between text and sort arrow.
DWORD | m_dwDrawStyle
Style flags used by theme, see CXTPHeaderCtrlTheme::SetDrawStyle().
BOOL | m_bUseWinThemes
TRUE to use Windows XP themes when available.
CSize | m_sizePadding
Leading and trailing padding for text display.
CSize | m_sizeArrow
Width and height of sort arrow.
COLORREF | m_crText
RGB value for text color.
COLORREF | m_cr3DFace
RGB value for header background color.
COLORREF | m_cr3DShadow
RGB value for border shadow color.
COLORREF | m_cr3DDkShadow
RGB value for border dark shadow color.
COLORREF | m_cr3DHighLight
RGB value for border highlight color.
CXTPWinThemeWrapper * | m_themeHeader
Wraps the Windows XP theme API that is used to display Windows XP themes.
- Protected Attributes inherited from CXTPControlTheme
XTPControlTheme | m_nTheme
Currently selected theme style index.

Detailed Description

CXTPHeaderCtrlThemeExplorer is a CXTPHeaderCtrlThemeOffice2003 derived theme class used to draw an Office XP style theme for the header control.

The CXTPHeaderCtrlThemeExplorer class provides theme capability to the CXTPHeaderCtrl class. You can derive a class from CXTPHeaderCtrlThemeExplorer to create custom user-defined themes.

To use this class, first subclass your header control using the Windows API SubclassWindow and a CXTPHeaderCtrl base class. Once you have done this, you can call SetTheme and pass in a pointer to the theme you wish to use for the header control.

Member Function Documentation

◆ DrawSortArrow()

virtual void DrawSortArrow | ( | CDC * | pDC,
 |  | LPPOINT | ptsArrow,
 |  | BOOL | bAscending )
 protectedvirtual

This member function is called by CXTPHeaderCtrlTheme::OnDrawItemSortArrow to draw the sort arrow.

Parameters
pDC | Pointer to a valid device context.
ptsArrow | POINT array used to define the 3 points of the arrow drawn.
bAscending | TRUE if the arrow is to be draw ascending.

Reimplemented from CXTPHeaderCtrlTheme.

◆ Layout()

virtual BOOL Layout | ( | LPHDLAYOUT | lpHDL,
 |  | CXTPHeaderCtrl * | pHeaderCtrl )
 virtual

Retrieves the size and position of a header control within a given rectangle.

This function is used to determine the appropriate dimensions for a new header control that is to occupy the given rectangle.

Parameters
lpHDL | Pointer to an HDLAYOUT structure, which contains information used to set the size and position of a header control.
pHeaderCtrl | Pointer to a CXTPHeaderCtrl object.
Returns
Nonzero if successful, otherwise 0.

Reimplemented from CXTPHeaderCtrlThemeOffice2003.

◆ OnDrawBackground()

virtual void OnDrawBackground ( LPDRAWITEMSTRUCT lpDIS )
protectedvirtual

This member function is called by the theme to draw the header control's background.

Parameters
lpDIS A long pointer to a DRAWITEMSTRUCT structure. The structure contains information about the item to be drawn and the type of drawing required.

Reimplemented from CXTPHeaderCtrlThemeOffice2003.

◆ OnDrawItemBackgroundWinThemed()

virtual BOOL OnDrawItemBackgroundWinThemed ( LPDRAWITEMSTRUCT lpDIS )
protectedvirtual

This member function is called by the theme to draw the background using Windows themes for the header item specified by lpDIS->itemID.

Parameters
lpDIS A long pointer to a DRAWITEMSTRUCT structure. The structure contains information about the item to be drawn and the type of drawing required.
Returns
TRUE if successful, otherwise FALSE.

Reimplemented from CXTPHeaderCtrlTheme.

The documentation for this class was generated from the following file:
  • XTPHeaderCtrlTheme.h


Toolkit Pro: CXTPHeaderCtrlThemeOffice2003 Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPHeaderCtrlThemeOffice2003 Class Reference

CXTPHeaderCtrlThemeOffice2003 is a CXTPHeaderCtrlTheme derived theme class used to draw an Office 2003 style theme for the header control. More...

Inheritance diagram for CXTPHeaderCtrlThemeOffice2003:
[legend]

Public Member Functions

CXTPHeaderCtrlThemeOffice2003 ()
Constructs a CXTPHeaderCtrlThemeOffice2003 object using the specified header control.
virtual | ~CXTPHeaderCtrlThemeOffice2003 ()
Destroys a CXTPHeaderCtrlThemeOffice2003 object, handles cleanup and deallocation.
virtual BOOL | Layout (LPHDLAYOUT lpHDL, CXTPHeaderCtrl *pHeaderCtrl)
Retrieves the size and position of a header control within a given rectangle.
- Public Member Functions inherited from CXTPHeaderCtrlTheme
CXTPHeaderCtrlTheme ()
Constructs a CXTPHeaderCtrlTheme object using the specified header control.
virtual | ~CXTPHeaderCtrlTheme ()
Destroys a CXTPHeaderCtrlTheme object, handles cleanup and deallocation.
CXTPWinThemeWrapper * GetThemeWrapper ()
Call this member function to return a pointer to the Windows theme API wrapper for this control.
virtual void | DrawHeader (CDC *pDC, CXTPHeaderCtrl *pHeaderCtrl)
Call this member function from the header control's WM_PAINT message to perform themed drawing.
virtual void | RefreshMetrics (CXTPHeaderCtrl *pHeader)
Call this member whenever the system colors need to be updated.
virtual BOOL | UseWinXPThemes (CXTPHeaderCtrl *pHeaderCtrl)
This member function can be called to determine if Windows XP themes can be displayed for the header control.
virtual void | SetDrawStyle (DWORD dwDrawStyle, CXTPHeaderCtrl *pHeaderCtrl)
Call this member function to set the desired HDRARROW_XTP_drawing styles for the header theme.
virtual DWORD | GetDrawStyle () const
Call this member function to return the current drawing style used by the header theme.
virtual void | CleanUp (CXTPHeaderCtrl *pHeaderCtrl)
Cleans up allocated GDI resources used by the theme.
virtual BOOL | SetBitmap (int iCol, UINT uBitmapID, BOOL bRemove, COLORREF crMask, CXTPHeaderCtrl *pHeaderCtrl)
Call this member function to set the bitmap image for the specified header item.
BOOL | HasSortArrow ()
Call this member function to determine if the header control displays a sort arrow.
- Public Member Functions inherited from CXTPControlTheme
CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme | GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

virtual void | OnDrawBackground (LPDRAWITEMSTRUCT lpDIS)
This member function is called by the theme to draw the header control's background.
virtual void | OnDrawItemBackground (LPDRAWITEMSTRUCT lpDIS)
This member function is called by the theme to draw the background for the header item specified by lpDIS->itemID.
- Protected Member Functions inherited from CXTPHeaderCtrlTheme
virtual BOOL | OnDrawBackgroundWinThemed (LPDRAWITEMSTRUCT lpDIS)
This member function is called by the theme to draw the header control's background using Windows themes.
virtual BOOL | OnDrawItemBackgroundWinThemed (LPDRAWITEMSTRUCT lpDIS)
This member function is called by the theme to draw the background using Windows themes for the header item specified by lpDIS->itemID.
virtual void | OnDrawItemSortArrow (LPDRAWITEMSTRUCT lpDIS, BOOL bAscending)
This member function is called by the theme to draw the sort used to display the sort order for a header item specified by lpDIS->itemID.
virtual void | OnDrawItemText (LPDRAWITEMSTRUCT lpDIS, CXTPHeaderCtrl *pHeaderCtrl)
This member function is called to draw the text for the header item specified by lpDIS->itemID.
virtual void | OnDrawItemBitmap (LPDRAWITEMSTRUCT lpDIS, CRect &rcText, CXTPHeaderCtrl *pHeaderCtrl)
This member function is called to draw a bitmap for the header item specified by lpDIS->itemID.
virtual void | DrawSortArrow (CDC *pDC, LPPOINT ptsArrow, BOOL bAscending)
This member function is called by CXTPHeaderCtrlTheme::OnDrawItemSortArrow to draw the sort arrow.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlTheme
static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Attributes inherited from CXTPHeaderCtrlTheme
int | m_iArrowPadding
Spacing between text and sort arrow.
DWORD | m_dwDrawStyle
Style flags used by theme, see CXTPHeaderCtrlTheme::SetDrawStyle().
BOOL | m_bUseWinThemes
TRUE to use Windows XP themes when available.
CSize | m_sizePadding
Leading and trailing padding for text display.
CSize | m_sizeArrow
Width and height of sort arrow.
COLORREF | m_crText
RGB value for text color.
COLORREF | m_cr3DFace
RGB value for header background color.
COLORREF | m_cr3DShadow
RGB value for border shadow color.
COLORREF | m_cr3DDkShadow
RGB value for border dark shadow color.
COLORREF | m_cr3DHighLight
RGB value for border highlight color.
CXTPWinThemeWrapper * | m_themeHeader
Wraps the Windows XP theme API that is used to display Windows XP themes.
- Protected Attributes inherited from CXTPControlTheme
XTPControlTheme | m_nTheme
Currently selected theme style index.

Detailed Description

CXTPHeaderCtrlThemeOffice2003 is a CXTPHeaderCtrlTheme derived theme class used to draw an Office 2003 style theme for the header control.

The CXTPHeaderCtrlThemeOffice2003 class provides theme capability to the CXTPHeaderCtrl class. You can derive a class from CXTPHeaderCtrlThemeOffice2003 to create custom user-defined themes.

To use this class, first subclass your header control using the Windows API SubclassWindow and a CXTPHeaderCtrl base class. Once you have done this, you can call SetTheme and pass in a pointer to the theme you wish to use for the header control.

Member Function Documentation

◆ Layout()

virtual BOOL Layout | ( | LPHDLAYOUT | lpHDL,
 |  | CXTPHeaderCtrl * | pHeaderCtrl )
 virtual

Retrieves the size and position of a header control within a given rectangle.

This function is used to determine the appropriate dimensions for a new header control that is to occupy the given rectangle.

Parameters
lpHDL | Pointer to an HDLAYOUT structure, which contains information used to set the size and position of a header control.
pHeaderCtrl | Pointer to a CXTPHeaderCtrl object.
Returns
Nonzero if successful, otherwise 0.

Reimplemented from CXTPHeaderCtrlTheme.

Reimplemented in CXTPHeaderCtrlThemeExplorer.

◆ OnDrawBackground()

virtual void OnDrawBackground ( LPDRAWITEMSTRUCT lpDIS )
protectedvirtual

This member function is called by the theme to draw the header control's background.

Parameters
lpDIS A long pointer to a DRAWITEMSTRUCT structure. The structure contains information about the item to be drawn and the type of drawing required.

Reimplemented from CXTPHeaderCtrlTheme.

Reimplemented in CXTPHeaderCtrlThemeExplorer.

◆ OnDrawItemBackground()

virtual void OnDrawItemBackground ( LPDRAWITEMSTRUCT lpDIS )
protectedvirtual

This member function is called by the theme to draw the background for the header item specified by lpDIS->itemID.

Parameters
lpDIS A long pointer to a DRAWITEMSTRUCT structure. The structure contains information about the item to be drawn and the type of drawing required.

Reimplemented from CXTPHeaderCtrlTheme.

The documentation for this class was generated from the following file:
  • XTPHeaderCtrlTheme.h


Toolkit Pro: CXTPHeaderCtrlThemeOfficeXP Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPHeaderCtrlThemeOfficeXP Class Reference

CXTPHeaderCtrlThemeOfficeXP is a CXTPHeaderCtrlTheme derived theme class used to draw an Office XP style theme for the header control. More...

Inheritance diagram for CXTPHeaderCtrlThemeOfficeXP:
[legend]

Public Member Functions

CXTPHeaderCtrlThemeOfficeXP ()
Constructs a CXTPHeaderCtrlThemeOfficeXP object using the specified header control.
virtual | ~CXTPHeaderCtrlThemeOfficeXP ()
Destroys a CXTPHeaderCtrlThemeOfficeXP object, handles cleanup and deallocation.
- Public Member Functions inherited from CXTPHeaderCtrlTheme
CXTPHeaderCtrlTheme ()
Constructs a CXTPHeaderCtrlTheme object using the specified header control.
virtual | ~CXTPHeaderCtrlTheme ()
Destroys a CXTPHeaderCtrlTheme object, handles cleanup and deallocation.
CXTPWinThemeWrapper * GetThemeWrapper ()
Call this member function to return a pointer to the Windows theme API wrapper for this control.
virtual void | DrawHeader (CDC *pDC, CXTPHeaderCtrl *pHeaderCtrl)
Call this member function from the header control's WM_PAINT message to perform themed drawing.
virtual void | RefreshMetrics (CXTPHeaderCtrl *pHeader)
Call this member whenever the system colors need to be updated.
virtual BOOL | UseWinXPThemes (CXTPHeaderCtrl *pHeaderCtrl)
This member function can be called to determine if Windows XP themes can be displayed for the header control.
virtual void | SetDrawStyle (DWORD dwDrawStyle, CXTPHeaderCtrl *pHeaderCtrl)
Call this member function to set the desired HDRARROW_XTP_drawing styles for the header theme.
virtual DWORD | GetDrawStyle () const
Call this member function to return the current drawing style used by the header theme.
virtual BOOL | Layout (LPHDLAYOUT lpHDL, CXTPHeaderCtrl *pHeaderCtrl)
Retrieves the size and position of a header control within a given rectangle.
virtual void | CleanUp (CXTPHeaderCtrl *pHeaderCtrl)
Cleans up allocated GDI resources used by the theme.
virtual BOOL | SetBitmap (int iCol, UINT uBitmapID, BOOL bRemove, COLORREF crMask, CXTPHeaderCtrl *pHeaderCtrl)
Call this member function to set the bitmap image for the specified header item.
BOOL | HasSortArrow ()
Call this member function to determine if the header control displays a sort arrow.
- Public Member Functions inherited from CXTPControlTheme
CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme | GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

virtual void | OnDrawBackground (LPDRAWITEMSTRUCT lpDIS)
This member function is called by the theme to draw the header control's background.
virtual void | OnDrawItemBackground (LPDRAWITEMSTRUCT lpDIS)
This member function is called by the theme to draw the background for the header item specified by lpDIS->itemID.
- Protected Member Functions inherited from CXTPHeaderCtrlTheme
virtual BOOL | OnDrawBackgroundWinThemed (LPDRAWITEMSTRUCT lpDIS)
This member function is called by the theme to draw the header control's background using Windows themes.
virtual BOOL | OnDrawItemBackgroundWinThemed (LPDRAWITEMSTRUCT lpDIS)
This member function is called by the theme to draw the background using Windows themes for the header item specified by lpDIS->itemID.
virtual void | OnDrawItemSortArrow (LPDRAWITEMSTRUCT lpDIS, BOOL bAscending)
This member function is called by the theme to draw the sort used to display the sort order for a header item specified by lpDIS->itemID.
virtual void | OnDrawItemText (LPDRAWITEMSTRUCT lpDIS, CXTPHeaderCtrl *pHeaderCtrl)
This member function is called to draw the text for the header item specified by lpDIS->itemID.
virtual void | OnDrawItemBitmap (LPDRAWITEMSTRUCT lpDIS, CRect &rcText, CXTPHeaderCtrl *pHeaderCtrl)
This member function is called to draw a bitmap for the header item specified by lpDIS->itemID.
virtual void | DrawSortArrow (CDC *pDC, LPPOINT ptsArrow, BOOL bAscending)
This member function is called by CXTPHeaderCtrlTheme::OnDrawItemSortArrow to draw the sort arrow.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlTheme
static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Attributes inherited from CXTPHeaderCtrlTheme
int | m_iArrowPadding
Spacing between text and sort arrow.
DWORD | m_dwDrawStyle
Style flags used by theme, see CXTPHeaderCtrlTheme::SetDrawStyle().
BOOL | m_bUseWinThemes
TRUE to use Windows XP themes when available.
CSize | m_sizePadding
Leading and trailing padding for text display.
CSize | m_sizeArrow
Width and height of sort arrow.
COLORREF | m_crText
RGB value for text color.
COLORREF | m_cr3DFace
RGB value for header background color.
COLORREF | m_cr3DShadow
RGB value for border shadow color.
COLORREF | m_cr3DDkShadow
RGB value for border dark shadow color.
COLORREF | m_cr3DHighLight
RGB value for border highlight color.
CXTPWinThemeWrapper * | m_themeHeader
Wraps the Windows XP theme API that is used to display Windows XP themes.
- Protected Attributes inherited from CXTPControlTheme
XTPControlTheme | m_nTheme
Currently selected theme style index.

Detailed Description

CXTPHeaderCtrlThemeOfficeXP is a CXTPHeaderCtrlTheme derived theme class used to draw an Office XP style theme for the header control.

The CXTPHeaderCtrlThemeOfficeXP class provides theme capability to the CXTPHeaderCtrl class. You can derive a class from CXTPHeaderCtrlThemeOfficeXP to create custom user-defined themes.

To use this class, first subclass your header control using the Windows API SubclassWindow and a CXTPHeaderCtrl base class. Once you have done this, you can call SetTheme and pass in a pointer to the theme you wish to use for the header control.

Member Function Documentation

◆ OnDrawBackground()

virtual void OnDrawBackground ( LPDRAWITEMSTRUCT lpDIS )
protectedvirtual

This member function is called by the theme to draw the header control's background.

Parameters
lpDIS A long pointer to a DRAWITEMSTRUCT structure. The structure contains information about the item to be drawn and the type of drawing required.

Reimplemented from CXTPHeaderCtrlTheme.

Reimplemented in CXTPHeaderCtrlThemeResource.

◆ OnDrawItemBackground()

virtual void OnDrawItemBackground ( LPDRAWITEMSTRUCT lpDIS )
protectedvirtual

This member function is called by the theme to draw the background for the header item specified by lpDIS->itemID.

Parameters
lpDIS A long pointer to a DRAWITEMSTRUCT structure. The structure contains information about the item to be drawn and the type of drawing required.

Reimplemented from CXTPHeaderCtrlTheme.

Reimplemented in CXTPHeaderCtrlThemeResource.

The documentation for this class was generated from the following file:
  • XTPHeaderCtrlTheme.h


Toolkit Pro: CXTPHeaderCtrlThemeResource Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPHeaderCtrlThemeResource Class Reference

CXTPHeaderCtrlThemeResource is a CXTPHeaderCtrlThemeOfficeXP derived theme class used to draw a resource .dll style theme for the header control. More...

Inheritance diagram for CXTPHeaderCtrlThemeResource:
[legend]

Public Member Functions

CXTPHeaderCtrlThemeResource ()
Constructs a CXTPHeaderCtrlThemeResource object using the specified header control.
virtual void | RefreshMetrics (CXTPHeaderCtrl *pHeader)
Call this member whenever the system colors need to be updated.
- Public Member Functions inherited from CXTPHeaderCtrlThemeOfficeXP
CXTPHeaderCtrlThemeOfficeXP ()
Constructs a CXTPHeaderCtrlThemeOfficeXP object using the specified header control.
virtual | ~CXTPHeaderCtrlThemeOfficeXP ()
Destroys a CXTPHeaderCtrlThemeOfficeXP object, handles cleanup and deallocation.
- Public Member Functions inherited from CXTPHeaderCtrlTheme
CXTPHeaderCtrlTheme ()
Constructs a CXTPHeaderCtrlTheme object using the specified header control.
virtual | ~CXTPHeaderCtrlTheme ()
Destroys a CXTPHeaderCtrlTheme object, handles cleanup and deallocation.
CXTPWinThemeWrapper * GetThemeWrapper ()
Call this member function to return a pointer to the Windows theme API wrapper for this control.
virtual void | DrawHeader (CDC *pDC, CXTPHeaderCtrl *pHeaderCtrl)
Call this member function from the header control's WM_PAINT message to perform themed drawing.
virtual BOOL | UseWinXPThemes (CXTPHeaderCtrl *pHeaderCtrl)
This member function can be called to determine if Windows XP themes can be displayed for the header control.
virtual void | SetDrawStyle (DWORD dwDrawStyle, CXTPHeaderCtrl *pHeaderCtrl)
Call this member function to set the desired HDRARROW_XTP_drawing styles for the header theme.
virtual DWORD | GetDrawStyle () const
Call this member function to return the current drawing style used by the header theme.
virtual BOOL | Layout (LPHDLAYOUT lpHDL, CXTPHeaderCtrl *pHeaderCtrl)
Retrieves the size and position of a header control within a given rectangle.
virtual void | CleanUp (CXTPHeaderCtrl *pHeaderCtrl)
Cleans up allocated GDI resources used by the theme.
virtual BOOL | SetBitmap (int iCol, UINT uBitmapID, BOOL bRemove, COLORREF crMask, CXTPHeaderCtrl *pHeaderCtrl)
Call this member function to set the bitmap image for the specified header item.
BOOL | HasSortArrow ()
Call this member function to determine if the header control displays a sort arrow.
- Public Member Functions inherited from CXTPControlTheme
CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme | GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

virtual void | OnDrawBackground (LPDRAWITEMSTRUCT lpDIS)
This member function is called by the theme to draw the header control's background.
virtual void | OnDrawItemBackground (LPDRAWITEMSTRUCT lpDIS)
This member function is called by the theme to draw the background for the header item specified by lpDIS->itemID.
virtual void | DrawSortArrow (CDC *pDC, LPPOINT ptsArrow, BOOL bAscending)
This member function is called by CXTPHeaderCtrlTheme::OnDrawItemSortArrow to draw the sort arrow.
virtual void | OnDrawItemSortArrow (LPDRAWITEMSTRUCT lpDIS, BOOL bAscending)
This member function is called by the theme to draw the sort used to display the sort order for a header item specified by lpDIS->itemID.
virtual void | OnDrawItemText (LPDRAWITEMSTRUCT lpDIS, CXTPHeaderCtrl *pHeaderCtrl)
This member function is called to draw the text for the header item specified by lpDIS->itemID.
- Protected Member Functions inherited from CXTPHeaderCtrlThemeOfficeXP
- Protected Member Functions inherited from CXTPHeaderCtrlTheme
virtual BOOL | OnDrawBackgroundWinThemed (LPDRAWITEMSTRUCT lpDIS)
This member function is called by the theme to draw the header control's background using Windows themes.
virtual BOOL | OnDrawItemBackgroundWinThemed (LPDRAWITEMSTRUCT lpDIS)
This member function is called by the theme to draw the background using Windows themes for the header item specified by lpDIS->itemID.
virtual void | OnDrawItemBitmap (LPDRAWITEMSTRUCT lpDIS, CRect &rcText, CXTPHeaderCtrl *pHeaderCtrl)
This member function is called to draw a bitmap for the header item specified by lpDIS->itemID.

Protected Attributes

CXTPPaintManagerColorGradient | m_crgBack
Gradient item background color.
CXTPPaintManagerColorGradient | m_crgBackPressed
Gradient pressed item background color.
- Protected Attributes inherited from CXTPHeaderCtrlTheme
int | m_iArrowPadding
Spacing between text and sort arrow.
DWORD | m_dwDrawStyle
Style flags used by theme, see CXTPHeaderCtrlTheme::SetDrawStyle().
BOOL | m_bUseWinThemes
TRUE to use Windows XP themes when available.
CSize | m_sizePadding
Leading and trailing padding for text display.
CSize | m_sizeArrow
Width and height of sort arrow.
COLORREF | m_crText
RGB value for text color.
COLORREF | m_cr3DFace
RGB value for header background color.
COLORREF | m_cr3DShadow
RGB value for border shadow color.
COLORREF | m_cr3DDkShadow
RGB value for border dark shadow color.
COLORREF | m_cr3DHighLight
RGB value for border highlight color.
CXTPWinThemeWrapper * | m_themeHeader
Wraps the Windows XP theme API that is used to display Windows XP themes.
- Protected Attributes inherited from CXTPControlTheme
XTPControlTheme | m_nTheme
Currently selected theme style index.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlTheme
static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

CXTPHeaderCtrlThemeResource is a CXTPHeaderCtrlThemeOfficeXP derived theme class used to draw a resource .dll style theme for the header control.

The CXTPHeaderCtrlThemeResource class provides theme capability to the CXTPHeaderCtrl class. You can derive a class from CXTPHeaderCtrlThemeResource to create custom user-defined themes.

To use this class, first subclass your header control using the Windows API SubclassWindow and a CXTPHeaderCtrl base class. Once you have done this, you can call SetTheme and pass in a pointer to the theme you wish to use for the header control.

Member Function Documentation

◆ DrawSortArrow()

virtual void DrawSortArrow | ( | CDC * | pDC,
 |  | LPPOINT | ptsArrow,
 |  | BOOL | bAscending )
 protectedvirtual

This member function is called by CXTPHeaderCtrlTheme::OnDrawItemSortArrow to draw the sort arrow.

Parameters
pDC | Pointer to a valid device context.
ptsArrow | POINT array used to define the 3 points of the arrow drawn.
bAscending | TRUE if the arrow is to be draw ascending.

Reimplemented from CXTPHeaderCtrlTheme.

◆ OnDrawBackground()

virtual void OnDrawBackground ( LPDRAWITEMSTRUCT lpDIS )
protectedvirtual

This member function is called by the theme to draw the header control's background.

Parameters
lpDIS A long pointer to a DRAWITEMSTRUCT structure. The structure contains information about the item to be drawn and the type of drawing required.

Reimplemented from CXTPHeaderCtrlThemeOfficeXP.

◆ OnDrawItemBackground()

virtual void OnDrawItemBackground ( LPDRAWITEMSTRUCT lpDIS )
protectedvirtual

This member function is called by the theme to draw the background for the header item specified by lpDIS->itemID.

Parameters
lpDIS A long pointer to a DRAWITEMSTRUCT structure. The structure contains information about the item to be drawn and the type of drawing required.

Reimplemented from CXTPHeaderCtrlThemeOfficeXP.

◆ OnDrawItemSortArrow()

virtual void OnDrawItemSortArrow | ( | LPDRAWITEMSTRUCT | lpDIS,
 |  | BOOL | bAscending )
 protectedvirtual

This member function is called by the theme to draw the sort used to display the sort order for a header item specified by lpDIS->itemID.

Parameters
lpDIS | A long pointer to a DRAWITEMSTRUCT structure. The structure contains information about the item to be drawn and the type of drawing required.
bAscending | TRUE if the arrow is to be drawn ascending.

Reimplemented from CXTPHeaderCtrlTheme.

◆ OnDrawItemText()

virtual void OnDrawItemText | ( | LPDRAWITEMSTRUCT | lpDIS,
 |  | CXTPHeaderCtrl * | pHeaderCtrl )
 protectedvirtual

This member function is called to draw the text for the header item specified by lpDIS->itemID.

Parameters
lpDIS | A long pointer to a DRAWITEMSTRUCT structure. The structure contains information about the item to be drawn and the type of drawing required.
pHeaderCtrl | Pointer to a CXTPHeaderCtrl object.

Reimplemented from CXTPHeaderCtrlTheme.

◆ RefreshMetrics()

virtual void RefreshMetrics ( CXTPHeaderCtrl * pHeader )
virtual

Call this member whenever the system colors need to be updated.

Parameters
pHeader Pointer to the CXTPHeaderCtrl object.

Reimplemented from CXTPHeaderCtrlTheme.

The documentation for this class was generated from the following file:
  • XTPHeaderCtrlTheme.h


Toolkit Pro: CXTPHeapAllocatorT< _TData > Class Template Reference

Static Public Member Functions | List of all members
CXTPHeapAllocatorT< _TData > Class Template Reference

This template class used as a base class for allocators which can use a custom (separate) heap. More...

Static Public Member Functions

static void *AFX_CDECL | Alloc_mem (size_t nBytes)
Allocate memory block of nBytes size.
static void AFX_CDECL | Free_mem (void *p)
Free memory block previously allocated by Alloc_mem.

Detailed Description

template<class _TData>
class CXTPHeapAllocatorT< _TData >

This template class used as a base class for allocators which can use a custom (separate) heap.

Each allocator use own heap or standard heap. To use custom heap set ms_bUseCustomHeap member to TRUE.

Parameters
_TData This class must contain following static members for allocator:

struct allocatorClassData { static HANDLE ms_hCustomHeap; // handle to the custom heap static LONG ms_dwRefs; // allocated blocks count; static BOOL ms_bLFHEnabled; // report is LFH enabled for custom heap; static BOOL ms_bUseCustomHeap; // Define does allocator use custom heap or default heap; };

See also
XTP_DECLARE_HEAP_ALLOCATOR, XTP_IMPLEMENT_HEAP_ALLOCATOR, CXTPHeapObjectT

Member Function Documentation

◆ Alloc_mem()

template<class _TData >
static void *AFX_CDECL Alloc_mem ( size_t nBytes )
inlinestatic

Allocate memory block of nBytes size.

Parameters
nBytes An integer that specifies the number of bytes to be read or written.
Returns
A pointer to allocated block or NULL.
See also
Free_mem

◆ Free_mem()

template<class _TData >
static void AFX_CDECL Free_mem ( void * p )
inlinestatic

Free memory block previously allocated by Alloc_mem.

Parameters
p [in] Pointer to a memory block.
Returns
See also
Alloc_mem
The documentation for this class was generated from the following file:
  • XTPCustomHeap.h


Toolkit Pro: CXTPHeapObjectT< _TObject, _TAllocator > Class Template Reference

Public Member Functions | List of all members
CXTPHeapObjectT< _TObject, _TAllocator > Class Template Reference

This template class used as a helper class to override new/delete operators and use custom heap allocators inside them. More...

Inheritance diagram for CXTPHeapObjectT< _TObject, _TAllocator >:
[legend]

Public Member Functions

void *PASCAL | operator new (size_t nSize)
Allocate memory block of nSize bytes.
void PASCAL | operator delete (void *p)
Free memory block previously allocated by operator new.

Detailed Description

template<class _TObject, class _TAllocator>
class CXTPHeapObjectT< _TObject, _TAllocator >

This template class used as a helper class to override new/delete operators and use custom heap allocators inside them.

Parameters
_TObject | A base class;
_TAllocator | An allocator class name;

Example:

// Allocator must be declared (and implemented)
// probably in header (*.h) file:
XTP_DECLARE_HEAP_ALLOCATOR(CMyCustomHeapAllocator)

// in implementation (*.cpp) file:
XTP_IMPLEMENT_HEAP_ALLOCATOR(CMyCustomHeapAllocator, TRUE)

// To enable custom heap allocations use second parameter in
// XTP_IMPLEMENT_HEAP_ALLOCATOR macro or set corresponding flag
// on initialization, before any allocations:
//
CMyCustomHeapAllocator::ms_bUseCustomHeap = TRUE;

// One way to use:
class CMyClass : public CXTPHeapObjectT<CMyClassBase, CMyCustomHeapAllocator>
{
    // ...
};
CMyClass* pMyClassObj = new CMyClass();

// Other way to use:
class CMyClass : public CMyClassBase
{
    // ...
};

class CMyClass_heap : public CXTPHeapObjectT<CMyClass, CMyCustomHeapAllocator>
{
    // ...
};
CMyClass* pMyClassObj = new CMyClass_heap();
See also
XTP_DECLARE_HEAP_ALLOCATOR, XTP_IMPLEMENT_HEAP_ALLOCATOR,

Member Function Documentation

◆ operator delete()

template<class _TObject , class _TAllocator >
void PASCAL operator delete ( void * p )
inline

Free memory block previously allocated by operator new.

Parameters
p [in] Pointer to a memory block.
Returns
See also
operator new

◆ operator new()

template<class _TObject , class _TAllocator >
void *PASCAL operator new ( size_t nSize )
inline

Allocate memory block of nSize bytes.

Parameters
nSize Requested block size.
Returns
A pointer to allocated block or NULL.
See also
operator delete
The documentation for this class was generated from the following file:
  • XTPCustomHeap.h


Toolkit Pro: CXTPHeapString Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPHeapString Class Reference

This class used to store strings. More...

Inheritance diagram for CXTPHeapString:
[legend]

Public Member Functions

CXTPHeapString ()
Default object constructor.
CXTPHeapString (LPCTSTR pcszString)
Object constructor.
virtual | ~CXTPHeapString ()
Default object destructor.
virtual BOOL | IsEmpty () const
Use this function to determine is string empty.
LPCTSTR | operator= (LPCTSTR pcszString)
Assign new string value.
BOOL | operator== (LPCTSTR pcszString) const
Determine are strings equal.
BOOL | operator!= (LPCTSTR pcszString) const
Determine are strings different.
operator LPCTSTR () const
operator LPCTSTR.
operator CString () const
operator CString.
virtual BSTR | AllocSysString () const
Allocates a BSTR from stored string data.
virtual void | SetString (LPCTSTR pcszString)
Use this method to set new string value.

Protected Member Functions

virtual void | _AllocStringData (int nNewStrLen)
This method is used to allocate string data buffer.
virtual void | _FreeStringData ()
This method is used to free string data buffer previously allocated in _AllocStringData.

Protected Attributes

int | m_nStrLen
Stored string length (without null character).
LPTSTR | m_pcszString
Pointer to a stored string (or NULL).

Detailed Description

This class used to store strings.

It automatically allocate/deallocate memory for string data.

Override _AllocStringData, _FreeStringData to change default memory allocation.

See also
CXTPHeapStringT, XTP_DECLARE_HEAP_ALLOCATOR, CXTPHeapAllocatorT

Constructor & Destructor Documentation

◆ CXTPHeapString() [1/2]

CXTPHeapString ( )

Default object constructor.

See also
~CXTPHeapString

◆ CXTPHeapString() [2/2]

CXTPHeapString ( LPCTSTR pcszString )

Object constructor.

Parameters
pcszString [in] Pointer to a source string.
See also
~CXTPHeapString

◆ ~CXTPHeapString()

virtual ~CXTPHeapString ( )
virtual

Default object destructor.

See also
CXTPHeapString

Member Function Documentation

◆ _AllocStringData()

virtual void _AllocStringData ( int nNewStrLen )
protectedvirtual

This method is used to allocate string data buffer.

Parameters
nNewStrLen [in] New string length without null character.

Reimplemented in CXTPHeapStringT< _TAllocator >.

◆ AllocSysString()

virtual BSTR AllocSysString ( ) const
virtual

Allocates a BSTR from stored string data.

Returns
The newly allocated string.

◆ IsEmpty()

virtual BOOL IsEmpty ( ) const
virtual

Use this function to determine is string empty.

Returns
TRUE if stored string is empty, FALSE otherwise.

◆ operator CString()

operator CString ( ) const

operator CString.

Returns
A CString object which contains stored string.

◆ operator LPCTSTR()

operator LPCTSTR ( ) const

operator LPCTSTR.

Returns
Pointer to a stored string.

◆ operator!=()

BOOL operator!= ( LPCTSTR pcszString ) const

Determine are strings different.

Parameters
pcszString [in] Pointer to a string to compare.
Returns
TRUE if strings are different, FALSE otherwise.

◆ operator=()

LPCTSTR operator= ( LPCTSTR pcszString )

Assign new string value.

Parameters
pcszString [in] Pointer to a source string.
Returns
Stored string value.

◆ operator==()

BOOL operator== ( LPCTSTR pcszString ) const

Determine are strings equal.

Parameters
pcszString [in] Pointer to a string to compare.
Returns
TRUE if strings are equal, FALSE otherwise.

◆ SetString()

virtual void SetString ( LPCTSTR pcszString )
virtual

Use this method to set new string value.

Parameters
pcszString [in] Pointer to a source string.
The documentation for this class was generated from the following file:
  • XTPCustomHeap.h


Toolkit Pro: CXTPHeapStringT< _TAllocator > Class Template Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPHeapStringT< _TAllocator > Class Template Reference

This template used to store strings using different allocators. More...

Inheritance diagram for CXTPHeapStringT< _TAllocator >:
[legend]

Public Member Functions

CXTPHeapStringT (LPCTSTR pcszString=_T(""))
Default object constructor.
virtual | ~CXTPHeapStringT ()
Default object destructor.
LPCTSTR | operator= (LPCTSTR pcszString)
Assign new string value.
BOOL | operator== (LPCTSTR pcszString) const
Determine are strings equal.
BOOL | operator!= (LPCTSTR pcszString) const
Determine are strings different.
operator LPCTSTR () const
operator LPCTSTR.
operator CString () const
operator CString.
- Public Member Functions inherited from CXTPHeapString
CXTPHeapString ()
Default object constructor.
CXTPHeapString (LPCTSTR pcszString)
Object constructor.
virtual | ~CXTPHeapString ()
Default object destructor.
virtual BOOL | IsEmpty () const
Use this function to determine is string empty.
LPCTSTR | operator= (LPCTSTR pcszString)
Assign new string value.
BOOL | operator== (LPCTSTR pcszString) const
Determine are strings equal.
BOOL | operator!= (LPCTSTR pcszString) const
Determine are strings different.
operator LPCTSTR () const
operator LPCTSTR.
operator CString () const
operator CString.
virtual BSTR | AllocSysString () const
Allocates a BSTR from stored string data.
virtual void | SetString (LPCTSTR pcszString)
Use this method to set new string value.

Protected Member Functions

virtual void | _AllocStringData (int nNewStrLen)
This method is used to allocate string data buffer.
virtual void | _FreeStringData ()
This method is used to free string data buffer previously allocated in _AllocStringData.
- Protected Member Functions inherited from CXTPHeapString

Additional Inherited Members

- Protected Attributes inherited from CXTPHeapString
int | m_nStrLen
Stored string length (without null character).
LPTSTR | m_pcszString
Pointer to a stored string (or NULL).

Detailed Description

template<class _TAllocator>
class CXTPHeapStringT< _TAllocator >

This template used to store strings using different allocators.

String data stored in default or separate (custom) heap. Specially useful for VC 6.0 instead of CString, because CString Release implementation allocates data using some cache and data is not deallocated when CString destroyed.

See also
CXTPHeapString, XTP_DECLARE_HEAP_ALLOCATOR, CXTPHeapAllocatorT

Constructor & Destructor Documentation

◆ CXTPHeapStringT()

template<class _TAllocator >
CXTPHeapStringT ( LPCTSTR pcszString = _T("") )
inline

Default object constructor.

Parameters
pcszString [in] Pointer to a source string.
See also
~CXTPHeapStringT

◆ ~CXTPHeapStringT()

template<class _TAllocator >
virtual ~CXTPHeapStringT ( )
inlinevirtual

Default object destructor.

See also
CXTPHeapString

Member Function Documentation

◆ _AllocStringData()

template<class _TAllocator >
virtual void _AllocStringData ( int nNewStrLen )
inlineprotectedvirtual

This method is used to allocate string data buffer.

Parameters
nNewStrLen [in] New string length without null character.

Reimplemented from CXTPHeapString.

◆ operator CString()

template<class _TAllocator >
operator CString ( ) const
inline

operator CString.

Returns
A CString object which contains stored string.

◆ operator LPCTSTR()

template<class _TAllocator >
operator LPCTSTR ( ) const
inline

operator LPCTSTR.

Returns
Pointer to a stored string.

◆ operator!=()

template<class _TAllocator >
BOOL operator!= ( LPCTSTR pcszString ) const
inline

Determine are strings different.

Parameters
pcszString [in] Pointer to a string to compare.
Returns
TRUE if strings are different, FALSE otherwise.

◆ operator=()

template<class _TAllocator >
LPCTSTR operator= ( LPCTSTR pcszString )
inline

Assign new string value.

Parameters
pcszString [in] Pointer to a source string.
Returns
Stored string value.

◆ operator==()

template<class _TAllocator >
BOOL operator== ( LPCTSTR pcszString ) const
inline

Determine are strings equal.

Parameters
pcszString [in] Pointer to a string to compare.
Returns
TRUE if strings are equal, FALSE otherwise.
The documentation for this class was generated from the following file:
  • XTPCustomHeap.h


Toolkit Pro: CXTPHexEdit Class Reference

Public Member Functions | Public Attributes | Protected Types | Protected Attributes | List of all members
CXTPHexEdit Class Reference

CXTPHexEdit is a CEdit derived class. More...

Public Member Functions

CXTPHexEdit ()
Constructs a CXTPHexEdit object.
virtual | ~CXTPHexEdit ()
Destroys a CXTPHexEdit object, handles cleanup and deallocation.
virtual BOOL | Create (DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID)
This method creates the HexEdit control.
virtual BOOL | Create (LPCTSTR lpszClassName, LPCTSTR lpszWindowName, DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID, CCreateContext *pContext=NULL)
This method creates the HexEdit control.
COLORREF | GetActualBackColor ()
Call this member function to return the current background color of the hex edit control.
COLORREF | GetActualTextColor ()
Call this member function to return the current text color of the hex edit control.
COLORREF | GetActualHighlightBackColor ()
Call this member function to return the current highlight background color of the hex edit control.
COLORREF | GetActualHighlightTextColor ()
Call this member function to return the current highlight text color of the hex edit control.
void | SetBackColor (COLORREF crBack)
Call this member function to set the background color for the hex edit control.
COLORREF | GetBackColor ()
Call this member function to retrieve the current background color of the hex edit control.
void | SetTextColor (COLORREF crText)
Call this member function to set the text color for the hex edit control.
COLORREF | GetTextColor ()
Call this member function to retrieve the current text color of the hex edit control.
void | SetDisabledBackColor (COLORREF crDisabledBack)
Call this member function to set the disabled background color for the hex edit control.
COLORREF | GetDisabledBackColor ()
Call this member function to retrieve the current disabled background color of the hex edit control.
void | SetDisabledTextColor (COLORREF crDisabledText)
Call this member function to set the disabled text color for the hex edit control.
COLORREF | GetDisabledTextColor ()
Call this member function to retrieve the current disabled text color of the hex edit control.
void | SetHighlightTextColor (COLORREF crHighlightText)
Call this member function to set the highlighted text color for the hex edit control.
COLORREF | GetHighlightTextColor ()
Call this member function to retrieve the current highlighted text color of the hex edit control.
void | SetHighlightBackColor (COLORREF crHighlight)
Call this member function to set the highlight background color for the hex edit control.
COLORREF | GetHighlightBackColor ()
Call this member function to retrieve the current highlight background color of the hex edit control.
void | SetDisabledHighlightTextColor (COLORREF crDisabledHighlightText)
Call this member function to set the disabled highlight text color for the hex edit control.
COLORREF | GetDisabledHighlightTextColor ()
Call this member function to retrieve the current disabled highlight text color of the hex edit control.
void | SetDisabledHighlightBackColor (COLORREF crDisabledHighlight)
Call this member function to set the disabled highlight background color for the hex edit control.
COLORREF | GetDisabledHighlightBackColor ()
Call this member function to retrieve the current disabled highlight background color of the hex edit control.
void | RestoreDefaultFont ()
This member function sets the font for the hex edit control to the default "Courier New" font.
void | SetHexFont (CFont *pFont)
This member function sets the font used by the hex edit control.
void | SetHexFont (LOGFONT *pLogFont)
This member function sets the font used by the hex edit control.
void | EnableCaret (bool bEnable)
This member function enables/disables a flashing screen caret.
void | EnableScrollBars (bool bVertical, bool bHorizontal)
This member function enables/disables a vertical and horizontal scrollbar display.
DWORD | SetAddressBase (DWORD dwBase)
Call this member function to set the base address for the hex edit control.
int | GetData (LPBYTE pData, int nBufferLength)
Call this method to extract the data in the hex edit control.
void | SetData (LPBYTE pData, int nLength, int nMaxLength=0)
Call this member function to initialize the hex edit control with data specified by 'pData'.
bool | SetAllowDeletes (bool bVal=true)
Call this method to allow/disallow the deletion of characters within the control.
bool | GetAllowDeletes () const
This member function retrieves the current value of the Allow Deletes setting.
CSize | GetSel ()
Call this member function to get the size of the current selection.
void | GetSel (int &nSelStart, int &nSelEnd)
Call this member function to get the size of the current selection.
void | SetSel (int nSelStart, int nSelEnd)
Call this member function to set the current selection.
void | SetBPR (int nBytePerRow)
Call this member function to set the number of bytes per row.
void | SetOptions (BOOL bShowAddress, BOOL bShowHex, BOOL bShowAscii, BOOL bAddressIsWide)
Call this member function to set the display options for the hex edit control.
BOOL | IsReadOnly () const
Call this member function to determine if the control is in a read-only state.
virtual void | OnChange ()
This method is called when the user changes text.

Public Attributes

int | m_nLength
Length of data.
int | m_nTopIndex
Offset of first visible byte on the screen.
int | m_nCurrentAddress
Address under the cursor.
int | m_nSelStart
Start address of the selection.
int | m_nSelEnd
End address of the selection.
int | m_nBytePerRow
Bytes per row.
int | m_nLinesPerPage
Lines per page.
int | m_nLineHeight
Height in pixels of a single line displayed in the control.
int | m_nNullWidth
Width in pixels of a single character displayed in the control (uniform width).
int | m_nOffHex
Internally used value - X position where hex part starts.
int | m_nOffAscii
Internally used value - X position where ASCII part starts.
int | m_nOffAddress
Internally used value - X position where address part starts.
bool | m_bAllowDeletes
A boolean value indicating whether or not deletions are allowed.
BOOL | m_bDynamicBPR
Calculate bytes-per-row dynamically.
BOOL | m_bShowAddress
TRUE when showing the address part.
BOOL | m_bShowAscii
TRUE when showing the ASCII part.
BOOL | m_bShowHex
TRUE when showing the hex part.
BOOL | m_bAddressIsWide
4/8 byte address.
BOOL | m_bUpdate
Value used internally to indicate that the font and size info need to be updated on the next paint cycle.
UINT | m_nMaxLength
Maximum size of data.
DWORD | m_dwBaseAddress
Base address for data.
CPoint | m_ptEditPos
Current caret position.
LPBYTE | m_pData
Pointer to data.
EditMode | m_eEditMode
Current editing mode: address/hex/ASCII.

Protected Types

enum EditMode { editNone , editAscii , editHigh , editLow }
Enumeration used to determine current editing mode. More...

Protected Attributes

BOOL | m_bShowCaret
TRUE to display a flashing caret at the current caret position.
CSize | m_szCaret
Current size of caret.
CXTPFont | m_xtpFontHex
Represents the default font used by the hex edit control.
COLORREF | m_crBack
RGB value that represents the background color of the hex edit control.
COLORREF | m_crText
RGB value that represents the text color of the hex edit control.
COLORREF | m_crDisabledBack
RGB value that represents the disabled background color for the hex edit control.
COLORREF | m_crDisabledText
RGB value that represents the disabled text color of the hex edit control.
COLORREF | m_crHighlightText
RGB value that represents the highlighted text color of the hex edit control.
COLORREF | m_crHighlightBack
RGB value that represents the highlighted background color of the hex edit control.
COLORREF | m_crDisabledHighlightText
RGB value that represents the disabled highlighted text color of the hex edit control.
COLORREF | m_crDisabledHighlightBack
RGB value that represents the disabled highlighted background color of the hex edit control.

Detailed Description

CXTPHexEdit is a CEdit derived class.

It is used to create an edit control which will allow editing in hex display format.

Member Enumeration Documentation

◆ EditMode

enum EditMode
protected

Enumeration used to determine current editing mode.

EditMode type defines the constants used by the CXTPHexEdit class to determine the current editing mode.

See also
CXTPHexEdit
editNone, editAscii, editHigh, editLow
Enumerator
editNone | No editing mode specified.
editAscii | ASCII editing mode.
editHigh | High editing mode.
editLow | Low editing mode.

Member Function Documentation

◆ Create() [1/2]

virtual BOOL Create | ( | DWORD | dwStyle,
 |  | const RECT & | rect,
 |  | CWnd * | pParentWnd,
 |  | UINT | nID )
 virtual

This method creates the HexEdit control.

Parameters
dwStyle | Style for the HexEdit.
rect | Specifies the size and position of the HexEdit control.
pParentWnd | Specifies the parent window of the HexEdit control.
nID | Specifies the HexEdit control ID.
Returns
TRUE if successful, otherwise FALSE.

◆ Create() [2/2]

virtual BOOL Create | ( | LPCTSTR | lpszClassName,
 |  | LPCTSTR | lpszWindowName,
 |  | DWORD | dwStyle,
 |  | const RECT & | rect,
 |  | CWnd * | pParentWnd,
 |  | UINT | nID,
 |  | CCreateContext * | pContext = NULL )
 virtual

This method creates the HexEdit control.

Parameters
dwStyle | Style for the HexEdit.
rect | Specifies the size and position of the HexEdit control.
pParentWnd | Specifies the parent window of the HexEdit control.
nID | Specifies the HexEdit control ID.
lpszClassName | Class Name ("EDIT" by default).
lpszWindowName | Window Name.
pContext | Pointer to the CCreateContext.
Returns
TRUE if successful, otherwise FALSE.

◆ EnableCaret()

void EnableCaret ( bool bEnable )

This member function enables/disables a flashing screen caret.

Parameters
bEnable true to enable caret, false to disable.

◆ EnableScrollBars()

void EnableScrollBars | ( | bool | bVertical,
 |  | bool | bHorizontal )

This member function enables/disables a vertical and horizontal scrollbar display.

Parameters
bVertical | true to display vertical scrollbar.
bHorizontal | true to display horizontal scrollbar.

◆ GetActualBackColor()

COLORREF GetActualBackColor ( )

Call this member function to return the current background color of the hex edit control.

The current background color depends on the enabled, disabled, or read-only state of the control.

Returns
An RGB value that represents the current background color of the control.

◆ GetActualHighlightBackColor()

COLORREF GetActualHighlightBackColor ( )

Call this member function to return the current highlight background color of the hex edit control.

The current highlight background color depends on the enabled, disabled, or read-only state of the control.

Returns
An RGB value that represents the current highlight background color of the control.

◆ GetActualHighlightTextColor()

COLORREF GetActualHighlightTextColor ( )

Call this member function to return the current highlight text color of the hex edit control.

The current highlight text color depends on the enabled, disabled, or read-only state of the control.

Returns
An RGB value that represents the current highlight text color of the control.

◆ GetActualTextColor()

COLORREF GetActualTextColor ( )

Call this member function to return the current text color of the hex edit control.

The current text color depends on the enabled, disabled, or read-only state of the control.

Returns
An RGB value that represents the current text color of the control.

◆ GetAllowDeletes()

bool GetAllowDeletes ( ) const

This member function retrieves the current value of the Allow Deletes setting.

Returns
true if the Allow Deletes setting is enabled, or false if it is disabled.
See also
SetAllowDeletes

◆ GetBackColor()

COLORREF GetBackColor ( )

Call this member function to retrieve the current background color of the hex edit control.

Returns
An RGB value that represents the current background color of the hex edit control.

◆ GetData()

int GetData | ( | LPBYTE | pData,
 |  | int | nBufferLength )

Call this method to extract the data in the hex edit control.

Parameters
pData | Pointer to the buffer that will be receiving the data.
nBufferLength | Length of the target data buffer.
Returns
The length of the data.

◆ GetDisabledBackColor()

COLORREF GetDisabledBackColor ( )

Call this member function to retrieve the current disabled background color of the hex edit control.

Returns
An RGB value that represents the current disabled background color of the hex edit control.

◆ GetDisabledHighlightBackColor()

COLORREF GetDisabledHighlightBackColor ( )

Call this member function to retrieve the current disabled highlight background color of the hex edit control.

Returns
An RGB value that represents the current disabled highlight background color of the hex edit control.

◆ GetDisabledHighlightTextColor()

COLORREF GetDisabledHighlightTextColor ( )

Call this member function to retrieve the current disabled highlight text color of the hex edit control.

Returns
An RGB value that represents the current disabled highlight text color of the hex edit control.

◆ GetDisabledTextColor()

COLORREF GetDisabledTextColor ( )

Call this member function to retrieve the current disabled text color of the hex edit control.

Returns
An RGB value that represents the current disabled text color of the hex edit control.

◆ GetHighlightBackColor()

COLORREF GetHighlightBackColor ( )

Call this member function to retrieve the current highlight background color of the hex edit control.

Returns
An RGB value that represents the current highlight background color of the hex edit control.

◆ GetHighlightTextColor()

COLORREF GetHighlightTextColor ( )

Call this member function to retrieve the current highlighted text color of the hex edit control.

Returns
An RGB value that represents the current highlighted text color of the hex edit control.

◆ GetSel() [1/2]

CSize GetSel ( )

Call this member function to get the size of the current selection.

non-selected character past the end of the current selection.

Returns
A CSize object.

◆ GetSel() [2/2]

void GetSel | ( | int & | nSelStart,
 |  | int & | nSelEnd )

Call this member function to get the size of the current selection.

Parameters
nSelStart | Reference to an integer that will receive the position of the first character in the current selection.
nSelEnd | Reference to an integer that will receive the position of the first non-selected character past the end of the current selection.

◆ GetTextColor()

COLORREF GetTextColor ( )

Call this member function to retrieve the current text color of the hex edit control.

Returns
An RGB value that represents the current text color of the hex edit control.

◆ IsReadOnly()

BOOL IsReadOnly ( ) const

Call this member function to determine if the control is in a read-only state.

Returns
TRUE if the control is in a read-only state, otherwise FALSE.

◆ SetAddressBase()

DWORD SetAddressBase ( DWORD dwBase )

Call this member function to set the base address for the hex edit control.

Parameters
dwBase A DWORD value that represents the base address.
Returns
A DWORD value.

◆ SetAllowDeletes()

bool SetAllowDeletes ( bool bVal = true )

Call this method to allow/disallow the deletion of characters within the control.

For instance, calling SetAllowDeletes(false) will disable the delete, backspace, and other such keys.

Parameters
bVal true to allow the deletion of characters within the control, false to disallow.
Returns
The previous value of the Allow Deletes setting.

◆ SetBackColor()

void SetBackColor ( COLORREF crBack )

Call this member function to set the background color for the hex edit control.

Parameters
crBack An RGB value that represents the background color for the hex edit control.

◆ SetBPR()

void SetBPR ( int nBytePerRow )

Call this member function to set the number of bytes per row.

Parameters
nBytePerRow Represents the number of bytes to display.

◆ SetData()

void SetData | ( | LPBYTE | pData,
 |  | int | nLength,
 |  | int | nMaxLength = 0 )

Call this member function to initialize the hex edit control with data specified by 'pData'.

Parameters
pData | Pointer to a buffer that contains the initial data for the control.
nLength | Length of the data buffer.
nMaxLength | Optional maximum length that the buffer can grow, or -1 if you want to allow the buffer to grow indefinitely.

◆ SetDisabledBackColor()

void SetDisabledBackColor ( COLORREF crDisabledBack )

Call this member function to set the disabled background color for the hex edit control.

Parameters
crDisabledBack An RGB value that represents the disabled background color for the hex edit control.

◆ SetDisabledHighlightBackColor()

void SetDisabledHighlightBackColor ( COLORREF crDisabledHighlight )

Call this member function to set the disabled highlight background color for the hex edit control.

Parameters
crDisabledHighlight An RGB value that represents the disabled highlight background color for the hex edit control.

◆ SetDisabledHighlightTextColor()

void SetDisabledHighlightTextColor ( COLORREF crDisabledHighlightText )

Call this member function to set the disabled highlight text color for the hex edit control.

Parameters
crDisabledHighlightText An RGB value that represents the disabled highlight text color for the hex edit control.

◆ SetDisabledTextColor()

void SetDisabledTextColor ( COLORREF crDisabledText )

Call this member function to set the disabled text color for the hex edit control.

Parameters
crDisabledText An RGB value that represents the disabled text color for the hex edit control.

◆ SetHexFont() [1/2]

void SetHexFont ( CFont * pFont )

This member function sets the font used by the hex edit control.

Parameters
pFont Pointer to a valid CFont object.

◆ SetHexFont() [2/2]

void SetHexFont ( LOGFONT * pLogFont )

This member function sets the font used by the hex edit control.

Parameters
pLogFont Pointer to a valid LOGFONT structure.

◆ SetHighlightBackColor()

void SetHighlightBackColor ( COLORREF crHighlight )

Call this member function to set the highlight background color for the hex edit control.

Parameters
crHighlight An RGB value that represents the highlight background color for the hex edit control.

◆ SetHighlightTextColor()

void SetHighlightTextColor ( COLORREF crHighlightText )

Call this member function to set the highlighted text color for the hex edit control.

Parameters
crHighlightText An RGB value that represents the highlighted text color for the hex edit control.

◆ SetOptions()

void SetOptions | ( | BOOL | bShowAddress,
 |  | BOOL | bShowHex,
 |  | BOOL | bShowAscii,
 |  | BOOL | bAddressIsWide )

Call this member function to set the display options for the hex edit control.

Parameters
bShowAddress | TRUE to display the address value.
bShowHex | TRUE to display the hex value.
bShowAscii | TRUE to display the ASCII value.
bAddressIsWide | TRUE if the display is 8 byte, FALSE for 4 byte display.

◆ SetSel()

void SetSel | ( | int | nSelStart,
 |  | int | nSelEnd )

Call this member function to set the current selection.

Parameters
nSelStart | Represents the position of the first character in the selection.
nSelEnd | Represents the position of the last character in the selection.

◆ SetTextColor()

void SetTextColor ( COLORREF crText )

Call this member function to set the text color for the hex edit control.

Parameters
crText An RGB value that represents the text color for the hex edit control.
The documentation for this class was generated from the following file:
  • XTPHexEdit.h


Toolkit Pro: CXTPHookManager Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPHookManager Class Reference

CXTPHookManager is standalone class. More...

Public Member Functions

~CXTPHookManager ()
Destroys a CXTPHookManager object, handles cleanup and de- allocation.
void | SetHook (HWND hWnd, CXTPHookManagerHookAble *pHook)
This member function will hook a window so that its messages are intercepted before they are passed on to the specified window.
BOOL | SetHook (int idHook, CXTPHookManagerHookAble *pHook, DWORD dwThreadId=0)
Sets local windows hook.
void | RemoveHook (HWND hWnd, CXTPHookManagerHookAble *pHook)
Removes a hook associated with a window.
void | RemoveAll (HWND hWnd)
Removes all hooks associated with a window.
void | RemoveAll (CXTPHookManagerHookAble *pHook)
Removes a hookable object and associated hooks if applicable.
void | RemoveAll (int idHook)
Removes a local windows hook and all its associated hookable objects.
CHookSink * | Lookup (HWND hWnd)
Searches collection of Hookable interfaces that receive hooks of specified window.
LRESULT | Default ()
Calls the default window procedure.
LRESULT | Default (WPARAM wParam, LPARAM lParam)
Calls the default window procedure.
LRESULT | Default (HWND hWnd, UINT message, WPARAM wParam, LPARAM lParam)
Calls the default window procedure.

Protected Member Functions

CXTPHookManager ()
Constructs a CXTPHookManager object.

Detailed Description

CXTPHookManager is standalone class.

It is used to hook a CWnd object in order to intercept and act upon window messages that are received.

To access CXTPHookManager methods use XTPHookManager function

See also
XTPHookManager, CXTPHookManagerHookAble

Member Function Documentation

◆ Default() [1/3]

LRESULT Default ( )

Calls the default window procedure.

Returns
Result value of default message processing.

◆ Default() [2/3]

LRESULT Default | ( | HWND | hWnd,
 |  | UINT | message,
 |  | WPARAM | wParam,
 |  | LPARAM | lParam )

Calls the default window procedure.

Parameters
hWnd | [in] handle to HWND
message | [in] message id
wParam | [in] Specifies additional message information. The content of this parameter depends on the value of the Msg parameter.
lParam | [in] Specifies additional message information. The content of this parameter depends on the value of the Msg parameter.
Returns
Result value of default message processing.

◆ Default() [3/3]

LRESULT Default | ( | WPARAM | wParam,
 |  | LPARAM | lParam )

Calls the default window procedure.

Parameters
wParam | [in] Specifies additional message information. The content of this parameter depends on the value of the Msg parameter.
lParam | [in] Specifies additional message information. The content of this parameter depends on the value of the Msg parameter.
Returns
Result value of default message processing.

◆ Lookup()

CHookSink * Lookup ( HWND hWnd )

Searches collection of Hookable interfaces that receive hooks of specified window.

Parameters
hWnd A handle to a window need to test
Returns
CHookSink pointer if found; otherwise returns NULL;

◆ RemoveAll() [1/3]

void RemoveAll ( CXTPHookManagerHookAble * pHook )

Removes a hookable object and associated hooks if applicable.

Parameters
pHook Hookable class that hooks need to remove

◆ RemoveAll() [2/3]

void RemoveAll ( HWND hWnd )

Removes all hooks associated with a window.

Parameters
hWnd A handle to a window that hooks need to remove

◆ RemoveAll() [3/3]

void RemoveAll ( int idHook )

Removes a local windows hook and all its associated hookable objects.

Parameters
idHook Local windows hook ID. See platform SDK documentation of SetWindowsHooksEx.

◆ RemoveHook()

void RemoveHook | ( | HWND | hWnd,
 |  | CXTPHookManagerHookAble * | pHook )

Removes a hook associated with a window.

Parameters
hWnd | A handle to a window that hooks need to remove
pHook | Hookable class that hooks need to remove

◆ SetHook() [1/2]

void SetHook | ( | HWND | hWnd,
 |  | CXTPHookManagerHookAble * | pHook )

This member function will hook a window so that its messages are intercepted before they are passed on to the specified window.

Parameters
hWnd | A handle to a window that represents that represents the window to hook.
pHook | Hookable class that will receive messages

◆ SetHook() [2/2]

BOOL SetHook | ( | int | idHook,
 |  | CXTPHookManagerHookAble * | pHook,
 |  | DWORD | dwThreadId = 0 )

Sets local windows hook.

Parameters
idHook | Local windows hook ID. See platform SDK documentation of SetWindowsHooksEx.
pHook | Hookable class that will receive messages
dwThreadId | Target thread identified. If 0 the calling thread ID is used.
Returns
TRUE if local windows hook is installed..
The documentation for this class was generated from the following file:
  • XTPHookManager.h


Toolkit Pro: CXTPHookManagerHookAble Class Reference

Public Member Functions | Public Attributes | List of all members
CXTPHookManagerHookAble Class Reference

HookAble interface. More...

Inheritance diagram for CXTPHookManagerHookAble:
[legend]

Public Member Functions

CXTPHookManagerHookAble ()
Constructs a CXTPHookManagerHookAble object.
virtual | ~CXTPHookManagerHookAble ()
Destroys a CXTPHookManagerHookAble object, handles cleanup and deallocation.
virtual int | OnHookMessage (HWND hWnd, UINT nMessage, WPARAM &wParam, LPARAM &lParam, LRESULT &lResult)
This member function is called by WindowProc, or is called during message reflection.
virtual int | OnPostHookMessage (HWND hWnd, UINT nMessage, WPARAM &wParam, LPARAM &lParam, LRESULT &lResult)
This member function is called after a message has been processed by default window procedure.
virtual void | OnHookAttached (HWND hWnd)
This member function is called right after a hook is attached to the window.
virtual void | OnHookDetached ()
This member function is called right before a hook is to be detached from the window.

Public Attributes

BOOL m_bAutoDestroy
TRUE to automatically delete hook.

Detailed Description

HookAble interface.

See also
CXTPHookManager, CXTPHookManager::SetHook

Member Function Documentation

◆ OnHookAttached()

virtual void OnHookAttached ( HWND hWnd )
virtual

This member function is called right after a hook is attached to the window.

Parameters
hWnd Window handle to which a hook is being attached. Always NULL for windows hooks.
See also
OnHookDetached

◆ OnHookDetached()

virtual void OnHookDetached ( )
virtual

This member function is called right before a hook is to be detached from the window.

See also
OnHookAttached

◆ OnHookMessage()

virtual int OnHookMessage | ( | HWND | hWnd,
 |  | UINT | nMessage,
 |  | WPARAM & | wParam,
 |  | LPARAM & | lParam,
 |  | LRESULT & | lResult )
 virtual

This member function is called by WindowProc, or is called during message reflection.

Parameters
hWnd | Window handle that the message belongs to. Always NULL for windows hooks.
nMessage | Specifies the message to be sent. For windows hooks it contains the hook code value.
wParam | Specifies additional message-dependent information.
lParam | Specifies additional message-dependent information.
lResult | The return value of WindowProc. Depends on the message; may be NULL. For windows hooks it is a return value from a hook procedure. Refer to SetWindowsHookEx documentation for your platform SDK for more details.
Returns
TRUE if message was processed. Ignored for windows hooks.
See also
OnPostHookMessage

Reimplemented in CXTPCommandBar, CXTPCommandBarsFrameHook, CXTPControlComboBoxList, CXTPControlCustom, CXTPMenuBar, and CXTPRibbonBackstageView.

◆ OnPostHookMessage()

virtual int OnPostHookMessage | ( | HWND | hWnd,
 |  | UINT | nMessage,
 |  | WPARAM & | wParam,
 |  | LPARAM & | lParam,
 |  | LRESULT & | lResult )
 virtual

This member function is called after a message has been processed by default window procedure.

Never called for windows hooks.

Parameters
hWnd | Window handle that the message belongs to.
nMessage | Specifies the message to be sent.
wParam | Specifies additional message-dependent information.
lParam | Specifies additional message-dependent information.
lResult | The return value of WindowProc. Depends on the message; may be NULL.
Returns
TRUE if message was processed.
See also
OnHookMessage
The documentation for this class was generated from the following file:
  • XTPHookManager.h


Toolkit Pro: CXTPHyperLink Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPHyperLink Class Reference

CXTPHyperLink is a CStatic derived class. More...

Public Member Functions

CXTPHyperLink ()
Constructs a CXTPHyperLink object.
virtual | ~CXTPHyperLink ()
Destroys a CXTPHyperLink object, handles cleanup and deallocation.
void | EnableShellExecute (bool bEnable)
Call this member function to enable/disable ShellExecute to be called for the URL that is specified for the hyperlink control.
virtual void | SetURL (LPCTSTR lpszLink)
This member function sets the URL for the hyperlink control.
virtual CString | GetURL () const
This member function retrieves the URL for the hyperlink.
virtual void | SetColors (COLORREF clrLink, COLORREF clrVisited, COLORREF clrHover)
This member function will set the RGB color values for the hyperlink text.
virtual COLORREF | GetLinkColor () const
This member function retrieves the current hyperlink text color.
virtual COLORREF | GetVisitedColor () const
This member function retrieves the current hyperlink text color when the link has been activated.
virtual COLORREF | GetHoverColor () const
This member function retrieves the current hyperlink text color when the mouse hovers over the hyperlink.
virtual void | SetVisited (bool bVisited=true)
This member function will cause the control to display the hyperlink text color as visited.
virtual bool | GetVisited () const
This member function checks to see if the user has visited the URL associated with the hyperlink.
virtual void | SetLinkCursor (HCURSOR hCursor)
This member function will set the cursor associated with the hyperlink control.
virtual HCURSOR | GetLinkCursor () const
This member function will get a handle to the current cursor associated with the hyperlink control.
virtual void | SetUnderline (bool bUnderline=true)
This member function will cause the hyperlink to display the text as underlined.
virtual bool | GetUnderline () const
This member function checks to see if the hyperlink text is underlined.
virtual void | SetBackColor (COLORREF clrBack)
This member function will set the background fill color for the hyperlink control.
virtual COLORREF | GetBackColor () const
This member function will retrieve the current background fill color for the hyperlink control.
virtual bool | GotoURL (LPCTSTR lpszLink=NULL, int nShowCmd=SW_SHOW, LPCTSTR lpszParams=NULL, LPCTSTR lpszDir=NULL)
This member function is called to execute the shell command associated with the current URL.
virtual bool | IsTextControl ()
This member function checks to see if the hyperlink control is a text control.
void | EnableToolTips (bool bEnable=true)
Call this member function to enable/disable tooltips for the hyperlink control.
void | SetTipText (LPCTSTR lpszTipText)
Call this member function to set the tooltip text for the tooltip associated with the hyperlink control.
virtual bool | IsLinkHot ()
Call this member to determine if the hyperlink is currently hot.
virtual void | ReportError (int iErrorNo)
This member function is called by the CXTPHyperLink object to display a message box whenever an error occurs.

Protected Member Functions

virtual bool | Init ()
This member function is called by the CXTPHyperLink class to perform initialization when the window is created or sub-classed.
virtual bool | InitFont ()
This member function is called by the CXTPHyperLink class to initialize the font to be used by the hyperlink control.
virtual BOOL | CreateFont (CFont &font, BOOL bUnderline)
This member function is called by the CXTPHyperLink class to initialize a font to be used by the hyperlink control.

Protected Attributes

bool | m_bShellExec
true to cause the hyperlink to call ShellExecute for the specified URL.
bool | m_bPreSubclassInit
true when initializing from PreSubclassWindow.
bool | m_bUnderline
Set to true for underlined text.
bool | m_bMouseOver
Set to true when the cursor is hovering over the control.
bool | m_bVisited
Set to true when the hyperlink has been activated.
bool | m_bTipEnabled
Set to false to disable tooltips.
CXTPFont | m_xtpFont
Font used by the hyperlink control.
CString | m_strLink
String object that represents the URL for this control.
CString | m_strTipText
String object that represents the tooltip text for this control.
HCURSOR | m_hcurHand
Handle to the default cursor for this control.
COLORREF | m_clrLink
An RGB value representing the color for the hyperlink text color.
COLORREF | m_clrHover
An RGB value representing the color for the hyperlink text color when the mouse is hovering.
COLORREF | m_clrVisited
An RGB value representing the color for the hyperlink text color when the URL has been visited.
COLORREF | m_clrBack
An RGB value representing the background fill color for the hyperlink control.
CToolTipCtrl | m_toolTip
Tooltip to be displayed for the control.

Detailed Description

CXTPHyperLink is a CStatic derived class.

It is used to display a text string that is used as a hyperlink control. The link's active, hover, and selected color attributes are configurable.

Member Function Documentation

◆ CreateFont()

virtual BOOL CreateFont | ( | CFont & | font,
 |  | BOOL | bUnderline )
 protectedvirtual

This member function is called by the CXTPHyperLink class to initialize a font to be used by the hyperlink control.

Parameters
font | Reference to the font to be created.
bUnderline | TRUE to create underlined font.
Returns
TRUE if the control was successfully initialized, otherwise FALSE.

◆ EnableShellExecute()

void EnableShellExecute ( bool bEnable )

Call this member function to enable/disable ShellExecute to be called for the URL that is specified for the hyperlink control.

If disabled, you can add a BN_CLICKED message handler to perform your own task when the link is clicked.

Parameters
bEnable true to enable ShellExecute, false to disable.

◆ EnableToolTips()

void EnableToolTips ( bool bEnable = true )

Call this member function to enable/disable tooltips for the hyperlink control.

Parameters
bEnable true to enable tooltips, false to disable.

◆ GetBackColor()

virtual COLORREF GetBackColor ( ) const
virtual

This member function will retrieve the current background fill color for the hyperlink control.

Returns
A COLORREF value representing the background fill color for the hyperlink control.

◆ GetHoverColor()

virtual COLORREF GetHoverColor ( ) const
virtual

This member function retrieves the current hyperlink text color when the mouse hovers over the hyperlink.

Returns
An RGB color value that represents the current hyperlink text color when the mouse hovers over the hyperlink.

◆ GetLinkColor()

virtual COLORREF GetLinkColor ( ) const
virtual

This member function retrieves the current hyperlink text color.

Returns
An RGB color value that represents the current hyperlink text color.

◆ GetLinkCursor()

virtual HCURSOR GetLinkCursor ( ) const
virtual

This member function will get a handle to the current cursor associated with the hyperlink control.

Returns
A handle to the current cursor for the hyperlink control.

◆ GetUnderline()

virtual bool GetUnderline ( ) const
virtual

This member function checks to see if the hyperlink text is underlined.

Returns
true if the hyperlink text is underlined, otherwise false.

◆ GetURL()

virtual CString GetURL ( ) const
virtual

This member function retrieves the URL for the hyperlink.

Returns
A CString object that represents the URL for the hyperlink control.

◆ GetVisited()

virtual bool GetVisited ( ) const
virtual

This member function checks to see if the user has visited the URL associated with the hyperlink.

Returns
true if the URL has been visited, otherwise false.

◆ GetVisitedColor()

virtual COLORREF GetVisitedColor ( ) const
virtual

This member function retrieves the current hyperlink text color when the link has been activated.

Returns
An RGB color value that represents the current hyperlink text color when the link has been activated.

◆ GotoURL()

virtual bool GotoURL | ( | LPCTSTR | lpszLink = NULL,
 |  | int | nShowCmd = SW_SHOW,
 |  | LPCTSTR | lpszParams = NULL,
 |  | LPCTSTR | lpszDir = NULL )
 virtual

This member function is called to execute the shell command associated with the current URL.

Parameters
lpszLink | Pointer to a NULL-terminated string that represents the URL to jump to. If NULL, then the default URL is activated.
nShowCmd | Display state for the shell command associated with the URL. The default is SW_SHOW.
lpszParams | Pointer to a NULL-terminated string that represents additional parameters that are to be passed to the ShellExecute command.
lpszDir | Pointer to a NULL-terminated string that represents the default directory.
Returns
TRUE if successful, otherwise FALSE.

◆ Init()

virtual bool Init ( )
protectedvirtual

This member function is called by the CXTPHyperLink class to perform initialization when the window is created or sub-classed.

Returns
true if the window was successfully initialized, otherwise false.

◆ InitFont()

virtual bool InitFont ( )
protectedvirtual

This member function is called by the CXTPHyperLink class to initialize the font to be used by the hyperlink control.

Returns
true if the font was successfully initialized, otherwise false.

◆ IsLinkHot()

virtual bool IsLinkHot ( )
virtual

Call this member to determine if the hyperlink is currently hot.

The hyperlink is hot when the mouse pointer is positioned over it.

Returns
true if the hyperlink is currently hot, otherwise false.

◆ IsTextControl()

virtual bool IsTextControl ( )
virtual

This member function checks to see if the hyperlink control is a text control.

Returns
true if the hyperlink control is a text control, otherwise false.

◆ ReportError()

virtual void ReportError ( int iErrorNo )
virtual

This member function is called by the CXTPHyperLink object to display a message box whenever an error occurs.

Parameters
iErrorNo See the ShellExecute API for a list of error codes.

◆ SetBackColor()

virtual void SetBackColor ( COLORREF clrBack )
virtual

This member function will set the background fill color for the hyperlink control.

By default, the hyperlink control uses the system color for COLOR_3DFACE.

Parameters
clrBack An RGB value representing the background fill color.

◆ SetColors()

virtual void SetColors | ( | COLORREF | clrLink,
 |  | COLORREF | clrVisited,
 |  | COLORREF | clrHover )
 virtual

This member function will set the RGB color values for the hyperlink text.

Parameters
clrLink | An RGB value representing the color for the hyperlink text color.
clrVisited | An RGB value representing the color for the hyperlink text color when the mouse is hovering.
clrHover | An RGB value representing the color for the hyperlink text color when the URL has been visited.

◆ SetLinkCursor()

virtual void SetLinkCursor ( HCURSOR hCursor )
virtual

This member function will set the cursor associated with the hyperlink control.

The associated cursor will be displayed when the mouse hovers over the hyperlink control.

Parameters
hCursor Handle of the cursor to be associated with the hyperlink control.

◆ SetTipText()

void SetTipText ( LPCTSTR lpszTipText )

Call this member function to set the tooltip text for the tooltip associated with the hyperlink control.

Parameters
lpszTipText A NULL-terminated string that represents the new tooltip text to display.

◆ SetUnderline()

virtual void SetUnderline ( bool bUnderline = true )
virtual

This member function will cause the hyperlink to display the text as underlined.

Parameters
bUnderline A boolean flag that, when set to true, causes the control to display the text as underlined. By default, this parameter is 'true'.

◆ SetURL()

virtual void SetURL ( LPCTSTR lpszLink )
virtual

This member function sets the URL for the hyperlink control.

Parameters
lpszLink A NULL-terminated character string that represents the URL for the hyperlink.

◆ SetVisited()

virtual void SetVisited ( bool bVisited = true )
virtual

This member function will cause the control to display the hyperlink text color as visited.

Parameters
bVisited A boolean flag that, when set to true, causes the control to display the hyperlink text color as visited.
The documentation for this class was generated from the following file:
  • XTPHyperLink.h


Toolkit Pro: CXTPIconHandle Class Reference

Public Member Functions | Static Public Member Functions | Protected Attributes | List of all members
CXTPIconHandle Class Reference

CXTPIconHandle is a standalone helper class. More...

Public Member Functions

CXTPIconHandle ()
Constructs a CXTPIconHandle object.
CXTPIconHandle (HICON hIcon)
Constructs a CXTPIconHandle object.
virtual | ~CXTPIconHandle ()
Destroys a CXTPIconHandle object, handles cleanup and deallocation.
operator HICON () const
This operator is used to retrieve a handle to the icon associated with the CXTPIconHandle object.
CXTPIconHandle & | operator= (HICON hIcon)
This operator is used to initialize the icon associated with the CXTPIconHandle object.
CSize | GetExtent () const
This member function gets the extent of an icon.
HICON | ScaleToFit (CSize desiredExtent) const
This member function scales an icon to fit into a rectangle.

Static Public Member Functions

static CSize AFX_CDECL | GetExtent (HICON hIcon)
This member function gets the extent of an icon.
static HICON AFX_CDECL | ScaleToFit (HICON hIcon, CSize desiredExtent)
This member function scales an icon to fit into a rectangle.

Protected Attributes

HICON m_hIcon
Handle to a dynamically created icon.

Detailed Description

CXTPIconHandle is a standalone helper class.

It is used to automatically destroy dynamically created hIcon handles.

Constructor & Destructor Documentation

◆ CXTPIconHandle()

CXTPIconHandle ( HICON hIcon )

Constructs a CXTPIconHandle object.

Parameters
hIcon Handle to a dynamically created icon.

Member Function Documentation

◆ GetExtent() [1/2]

CSize GetExtent ( ) const

This member function gets the extent of an icon.

Returns
A CSize object.

◆ GetExtent() [2/2]

static CSize AFX_CDECL GetExtent ( HICON hIcon )
static

This member function gets the extent of an icon.

Parameters
hIcon Icon handle whose dimensions are to be retrieved.
Returns
A CSize object.

◆ operator HICON()

operator HICON ( ) const

This operator is used to retrieve a handle to the icon associated with the CXTPIconHandle object.

Returns
An HICON handle to the icon.

◆ operator=()

CXTPIconHandle & operator= ( HICON hIcon )

This operator is used to initialize the icon associated with the CXTPIconHandle object.

Parameters
hIcon Handle to a dynamically created icon.
Returns
A reference to a CXTPIconHandle object.

◆ ScaleToFit() [1/2]

HICON ScaleToFit ( CSize desiredExtent ) const

This member function scales an icon to fit into a rectangle.

The width and height ratio is retained as much as possible. The caller assumes ownership of the returned icon handle.

Parameters
desiredExtent Desired icon extent.
Returns
An icon handle.

◆ ScaleToFit() [2/2]

static HICON AFX_CDECL ScaleToFit | ( | HICON | hIcon,
 |  | CSize | desiredExtent )
 static

This member function scales an icon to fit into a rectangle.

The width and height ratio is retained as much as possible. The caller assumes ownership of the returned icon handle.

Parameters
hIcon | Icon to be fitted.
desiredExtent | Desired icon extent.
Returns
An icon handle.
The documentation for this class was generated from the following file:
  • XTPUtil.h


Toolkit Pro: CXTPImageEditorDlg Class Reference

Public Types | Public Member Functions | List of all members
CXTPImageEditorDlg Class Reference

CXTPImageEditorDlg is a CDialog derived class. More...

Public Types

enum { IDD = XTP_IDD_IMAGEEDITOR_DIALOG }

Public Member Functions

CXTPImageEditorDlg (CWnd *pParent=NULL, BOOL bCommandBarsEditor=FALSE)
Constructs a CXTPImageEditorDlg object.
void | SetIcon (CXTPImageManagerIconHandle &pHandle)
Sets the icon to edit.
void | SetIconSize (CSize szIcon)
Sets the icon size to edit.
void | GetIcon (CXTPImageManagerIconHandle *pHandle)
Retrieves the edited icon.

Detailed Description

CXTPImageEditorDlg is a CDialog derived class.

It represents the dialog for icons edition.

Member Enumeration Documentation

◆ anonymous enum

anonymous enum
Enumerator
IDD

Dialog resource identifier.

Constructor & Destructor Documentation

◆ CXTPImageEditorDlg()

CXTPImageEditorDlg | ( | CWnd * | pParent = NULL,
 |  | BOOL | bCommandBarsEditor = FALSE )

Constructs a CXTPImageEditorDlg object.

Parameters
pParent | Pointer to the object's parent window.
bCommandBarsEditor | TRUE if Dialog used in Customize mode.

Member Function Documentation

◆ GetIcon()

void GetIcon ( CXTPImageManagerIconHandle * pHandle )

Retrieves the edited icon.

Parameters
pHandle Handle of the icon.

◆ SetIcon()

void SetIcon ( CXTPImageManagerIconHandle & pHandle )

Sets the icon to edit.

Parameters
pHandle Reference to a CXTPImageManagerIconHandle object that represents the handle of the icon.

◆ SetIconSize()

void SetIconSize ( CSize szIcon )

Sets the icon size to edit.

Parameters
szIcon Icon size.
The documentation for this class was generated from the following file:
  • XTPImageEditor.h


Toolkit Pro: CXTPImageList Class Reference

Public Member Functions | List of all members
CXTPImageList Class Reference

CXTPImageList extends CImageList with add additional functionality for images resizing that depends on DPI. More...

Public Member Functions

CXTPImageList ()
Constructs a CXTPImageList object.
virtual | ~CXTPImageList ()
Destroys a CXTPImageList object, handles cleanup and deallocation.
BOOL | Create (int cx, int cy, UINT nFlags, int nInitial, int nGrow)
Initializes an image list and attaches it to a CXTPImageList object.
BOOL | Create (UINT nBitmapID, int cx, int nGrow, COLORREF crMask)
Initializes an image list and attaches it to a CXTPImageList object.
BOOL | Create (LPCTSTR lpszBitmapID, int cx, int nGrow, COLORREF crMask)
Initializes an image list and attaches it to a CXTPImageList object.
BOOL | Create (CXTPImageList &imagelist1, int nImage1, CXTPImageList &imagelist2, int nImage2, int dx, int dy)
Initializes an image list and attaches it to a CXTPImageList object.
BOOL | Create (CXTPImageList *pImageList)
Initializes an image list and attaches it to a CXTPImageList object.
operator HIMAGELIST () const
Use this operator to get the attached handle of the CXTPImageList object.
HIMAGELIST | GetSafeHandle () const
Call this function to retrieve the m_hImageList data member.
BOOL | Attach (HIMAGELIST hImageList)
Attaches an image list to a CXTPImageList object.
HIMAGELIST | Detach ()
Call this function to detach an image list object from a CXTPImageList object.
int | GetImageCount () const
Call this function to retrieve the number of images in an image list.
COLORREF | SetBkColor (COLORREF cr)
Call this function to set the background color for an image list.
COLORREF | GetBkColor () const
Call this function to retrieve the current background color for an image list.
BOOL | GetImageInfo (int nImage, IMAGEINFO *pImageInfo) const
Call this function to retrieve information about an image.
BOOL | DeleteImageList ()
Call this function to delete an image list.
BOOL | SetImageCount (UINT uNewCount)
Call this member function to reset the number of images in a CXTPImageList object.
int | Add (CBitmap *pbmImage, CBitmap *pbmMask)
Call this function to add one or more images or an icon to an image list.
int | Add (CBitmap *pbmImage, COLORREF crMask)
Call this function to add one or more images or an icon to an image list.
int | Add (HICON hIcon)
Call this function to add one or more images or an icon to an image list.
BOOL | Remove (int nImage)
Call this function to remove an image from an image list object.
BOOL | Replace (int nImage, CBitmap *pbmImage, CBitmap *pbmMask)
Call this function to replace an image in an image list with a new image.
int | Replace (int nImage, HICON hIcon)
Call this function to replace an image in an image list with a new image.
HICON | ExtractIcon (int nImage)
Call this function to create an icon based on an image and its related mask in an image list.
BOOL | Draw (CDC *pDC, int nImage, POINT pt, UINT nStyle)
Call this function to draw the image that is being dragged during a drag-and-drop operation.
BOOL | SetOverlayImage (int nImage, int nOverlay)
Call this function to add the zero-based index of an image to the list of images to be used as overlay masks.
BOOL | Copy (int iDst, int iSrc, UINT uFlags=ILCF_MOVE)
This member function implements the behavior of the Win32 function ImageList_Copy, as described in the Windows SDK.
BOOL | Copy (int iDst, CXTPImageList *pSrc, int iSrc, UINT uFlags=ILCF_MOVE)
This member function implements the behavior of the Win32 function ImageList_Copy, as described in the Windows SDK.
BOOL | DrawIndirect (IMAGELISTDRAWPARAMS *pimldp)
Call this member function to draw an image from an image list.
BOOL | Read (CArchive *pArchive)
Call this function to read an image list from an archive.
BOOL | Write (CArchive *pArchive)
Call this function to write an image list object to an archive.
BOOL | BeginDrag (int nImage, CPoint ptHotSpot)
Call this function to begin dragging an image.
BOOL | SetDragCursorImage (int nDrag, CPoint ptHotSpot)
Creates a new drag image by combining the given image (typically a mouse cursor image) with the current drag image.
CImageList * | GetNativeGdiObject ()
Obtains a pointer to the encapsulated CImageList object.
const CImageList * | GetNativeGdiObject () const
Obtains a pointer to the encapsulated CImageList object.
operator CImageList & ()
Converts an object to CImageList reference making it possible to use CXTPImageList with MFC classes and methods that use CImageList reference as an argument.
operator const CImageList & () const
Converts an object to CImageList constant reference making it possible to use CXTPImageList with MFC classes and methods that use CImageList or CGdiObject constant reference as an argument.

Detailed Description

CXTPImageList extends CImageList with add additional functionality for images resizing that depends on DPI.

Member Function Documentation

◆ Add() [1/3]

int Add | ( | CBitmap * | pbmImage,
 |  | CBitmap * | pbmMask )

Call this function to add one or more images or an icon to an image list.

Parameters
pbmImage | Pointer to the bitmap containing the image or images. The number of images is inferred from the width of the bitmap.
pbmMask | Pointer to the bitmap containing the mask. If no mask is used with the image list, this parameter is ignored.
Returns
Zero-based index of the first new image if successful; otherwise -1.

◆ Add() [2/3]

int Add | ( | CBitmap * | pbmImage,
 |  | COLORREF | crMask )

Call this function to add one or more images or an icon to an image list.

Parameters
pbmImage | Pointer to the bitmap containing the image or images. The number of images is inferred from the width of the bitmap.
crMask | Color used to generate the mask. Each pixel of this color in the given bitmap is changed to black and the corresponding bit in the mask is set to one.
Returns
Zero-based index of the first new image if successful; otherwise -1.

◆ Add() [3/3]

int Add ( HICON hIcon )

Call this function to add one or more images or an icon to an image list.

Parameters
hIcon Handle of the icon that contains the bitmap and mask for the new image.
Returns
Zero-based index of the first new image if successful; otherwise -1.

◆ Attach()

BOOL Attach ( HIMAGELIST hImageList )

Attaches an image list to a CXTPImageList object.

Parameters
hImageList A handle to an image list object.
Returns
Nonzero if the attachment was successful; otherwise 0.

◆ BeginDrag()

BOOL BeginDrag | ( | int | nImage,
 |  | CPoint | ptHotSpot )

Call this function to begin dragging an image.

Parameters
nImage | Zero-based index of the image to drag.
ptHotSpot | Coordinates of the starting drag position (typically, the cursor position). The coordinates are relative to the upper left corner of the image.
Returns
Nonzero if successful; otherwise 0.

◆ Copy() [1/2]

BOOL Copy | ( | int | iDst,
 |  | CXTPImageList * | pSrc,
 |  | int | iSrc,
 |  | UINT | uFlags = ILCF_MOVE )

This member function implements the behavior of the Win32 function ImageList_Copy, as described in the Windows SDK.

Parameters
iDst | The zero-based index of the image to be used as the destination of the copy operation.
pSrc | A pointer to a CXTPImageList object that is the target of the copy operation.
iSrc | The zero-based index of the image to be used as the source of the copy operation.
uFlags | The bit flag value that specifies the type of copy operation to be made.
Returns
Nonzero if successful; otherwise zero.

◆ Copy() [2/2]

BOOL Copy | ( | int | iDst,
 |  | int | iSrc,
 |  | UINT | uFlags = ILCF_MOVE )

This member function implements the behavior of the Win32 function ImageList_Copy, as described in the Windows SDK.

Parameters
iDst | The zero-based index of the image to be used as the destination of the copy operation.
iSrc | The zero-based index of the image to be used as the source of the copy operation.
uFlags | The bit flag value that specifies the type of copy operation to be made.
Returns
Nonzero if successful; otherwise zero.

◆ Create() [1/5]

BOOL Create | ( | CXTPImageList & | imagelist1,
 |  | int | nImage1,
 |  | CXTPImageList & | imagelist2,
 |  | int | nImage2,
 |  | int | dx,
 |  | int | dy )

Initializes an image list and attaches it to a CXTPImageList object.

Parameters
imagelist1 | A reference to a CXTPImageList object.
nImage1 | Index of the first existing image.
imagelist2 | A reference to a CXTPImageList object.
nImage2 | Index of the second existing image.
dx | Offset of the x-axis of the second image in relationship to the first image, in pixels.
dy | Offset of the y-axis of the second image in relationship to the first image, in pixels.
Returns
Nonzero if successful; otherwise 0.

◆ Create() [2/5]

BOOL Create ( CXTPImageList * pImageList )

Initializes an image list and attaches it to a CXTPImageList object.

Parameters
pImageList A pointer to a CXTPImageList object.
Returns
Nonzero if successful; otherwise 0.

◆ Create() [3/5]

BOOL Create | ( | int | cx,
 |  | int | cy,
 |  | UINT | nFlags,
 |  | int | nInitial,
 |  | int | nGrow )

Initializes an image list and attaches it to a CXTPImageList object.

Parameters
cx | Dimensions of each image, in pixels.
cy | Dimensions of each image, in pixels.
nFlags | Specifies the type of image list to create. This parameter can be a combination of the following values, but it can include only one of the ILC_COLOR values.
nInitial | Number of images that the image list initially contains.
nGrow | Number of images by which the image list can grow when the system needs to resize the list to make room for new images. This parameter represents the number of new images the resized image list can contain.
Returns
Nonzero if successful; otherwise 0.

◆ Create() [4/5]

BOOL Create | ( | LPCTSTR | lpszBitmapID,
 |  | int | cx,
 |  | int | nGrow,
 |  | COLORREF | crMask )

Initializes an image list and attaches it to a CXTPImageList object.

Parameters
lpszBitmapID | A string containing the resource IDs of the images.
cx | Dimensions of each image, in pixels.
nGrow | Number of images by which the image list can grow when the system needs to resize the list to make room for new images. This parameter represents the number of new images the resized image list can contain.
crMask | Color used to generate a mask. Each pixel of this color in the specified bitmap is changed to black, and the corresponding bit in the mask is set to one.
Returns
Nonzero if successful; otherwise 0.

◆ Create() [5/5]

BOOL Create | ( | UINT | nBitmapID,
 |  | int | cx,
 |  | int | nGrow,
 |  | COLORREF | crMask )

Initializes an image list and attaches it to a CXTPImageList object.

Parameters
nBitmapID | Resource IDs of the bitmap to be associated with the image list.
cx | Dimensions of each image, in pixels.
nGrow | Number of images by which the image list can grow when the system needs to resize the list to make room for new images. This parameter represents the number of new images the resized image list can contain.
crMask | Color used to generate a mask. Each pixel of this color in the specified bitmap is changed to black, and the corresponding bit in the mask is set to one.
Returns
Nonzero if successful; otherwise 0.

◆ DeleteImageList()

BOOL DeleteImageList ( )

Call this function to delete an image list.

Returns
Nonzero if successful; otherwise 0.

◆ Detach()

HIMAGELIST Detach ( )

Call this function to detach an image list object from a CXTPImageList object.

Returns
A handle to an image list object.

◆ Draw()

BOOL Draw | ( | CDC * | pDC,
 |  | int | nImage,
 |  | POINT | pt,
 |  | UINT | nStyle )

Call this function to draw the image that is being dragged during a drag-and-drop operation.

Parameters
pDC | Pointer to the destination device context.
nImage | Zero-based index of the image to draw.
pt | Location at which to draw within the specified device context.
nStyle | Flag specifying the drawing style. Refer to the platform SDK's documentation on ImageList_Draw function for ILD_* flags summary.
Returns
Nonzero if successful; otherwise 0.

◆ DrawIndirect()

BOOL DrawIndirect ( IMAGELISTDRAWPARAMS * pimldp )

Call this member function to draw an image from an image list.

Parameters
pimldp A pointer to an IMAGELISTDRAWPARAMS structure that contains information about the draw operation.
Returns
TRUE if the image is successfully drawn; otherwise FALSE.

◆ ExtractIcon()

HICON ExtractIcon ( int nImage )

Call this function to create an icon based on an image and its related mask in an image list.

Parameters
nImage Zero-based index of the image.
Returns
Handle of the icon if successful; otherwise NULL.

◆ GetBkColor()

COLORREF GetBkColor ( ) const

Call this function to retrieve the current background color for an image list.

Returns
The RGB color value of the CXTPImageList object background color.

◆ GetImageCount()

int GetImageCount ( ) const

Call this function to retrieve the number of images in an image list.

Returns
The number of images.

◆ GetImageInfo()

BOOL GetImageInfo | ( | int | nImage,
 |  | IMAGEINFO * | pImageInfo ) const

Call this function to retrieve information about an image.

Parameters
nImage | Zero-based index of the image.
pImageInfo | Pointer to an IMAGEINFO structure that receives information about the image. The information in this structure can be used to directly manipulate the bitmaps for the image.
Returns
Nonzero if successful; otherwise 0.

◆ GetNativeGdiObject() [1/2]

CImageList * GetNativeGdiObject ( )

Obtains a pointer to the encapsulated CImageList object.

Returns
A pointer to the encapsulated CImageList object.

◆ GetNativeGdiObject() [2/2]

const CImageList * GetNativeGdiObject ( ) const

Obtains a pointer to the encapsulated CImageList object.

Returns
A pointer to the encapsulated CImageList object.

◆ GetSafeHandle()

HIMAGELIST GetSafeHandle ( ) const

Call this function to retrieve the m_hImageList data member.

Returns
A handle to the attached image list; otherwise NULL if no object is attached.

◆ operator CImageList &()

operator CImageList & ( )

Converts an object to CImageList reference making it possible to use CXTPImageList with MFC classes and methods that use CImageList reference as an argument.

Returns
An encapsulated CImageList object reference.

◆ operator const CImageList &()

operator const CImageList & ( ) const

Converts an object to CImageList constant reference making it possible to use CXTPImageList with MFC classes and methods that use CImageList or CGdiObject constant reference as an argument.

Returns
An encapsulated CImageList constant object reference.

◆ operator HIMAGELIST()

operator HIMAGELIST ( ) const

Use this operator to get the attached handle of the CXTPImageList object.

Returns
If successful, a handle to the image list represented by the CXTPImageList object; otherwise NULL.

◆ Read()

BOOL Read ( CArchive * pArchive )

Call this function to read an image list from an archive.

Parameters
pArchive A pointer to a CArchive object from which the image list is to be read.
Returns
Nonzero if successful; otherwise 0.

◆ Remove()

BOOL Remove ( int nImage )

Call this function to remove an image from an image list object.

Parameters
nImage Zero-based index of the image to remove.
Returns
Nonzero if successful; otherwise 0.

◆ Replace() [1/2]

BOOL Replace | ( | int | nImage,
 |  | CBitmap * | pbmImage,
 |  | CBitmap * | pbmMask )

Call this function to replace an image in an image list with a new image.

Parameters
nImage | Zero-based index of the image to replace.
pbmImage | A pointer to the bitmap containing the image.
pbmMask | A pointer to the bitmap containing the mask. If no mask is used with the image list, this parameter is ignored.
Returns
Nonzero if successful; otherwise 0.

◆ Replace() [2/2]

int Replace | ( | int | nImage,
 |  | HICON | hIcon )

Call this function to replace an image in an image list with a new image.

Parameters
nImage | Zero-based index of the image to replace.
hIcon | A handle to the icon that contains the bitmap and mask for the new image.
Returns
Zero-based index of the image if successful; otherwise -1.

◆ SetBkColor()

COLORREF SetBkColor ( COLORREF cr )

Call this function to set the background color for an image list.

Parameters
cr Background color to set. It can be CLR_NONE. In that case, images are drawn transparently using the mask.
Returns
The previous background color if successful; otherwise CLR_NONE.

◆ SetDragCursorImage()

BOOL SetDragCursorImage | ( | int | nDrag,
 |  | CPoint | ptHotSpot )

Creates a new drag image by combining the given image (typically a mouse cursor image) with the current drag image.

Parameters
nDrag | Index of the new image to be combined with the drag image.
ptHotSpot | Position of the hot spot within the new image.
Returns
Nonzero if successful; otherwise 0.

◆ SetImageCount()

BOOL SetImageCount ( UINT uNewCount )

Call this member function to reset the number of images in a CXTPImageList object.

Parameters
uNewCount The value specifying the new total number of images in the image list.
Returns
Nonzero if successful; otherwise zero.

◆ SetOverlayImage()

BOOL SetOverlayImage | ( | int | nImage,
 |  | int | nOverlay )

Call this function to add the zero-based index of an image to the list of images to be used as overlay masks.

Parameters
nImage | Zero-based index of the image to use as an overlay mask.
nOverlay | One-based index of the overlay mask.
Returns
Nonzero if successful; otherwise 0.

◆ Write()

BOOL Write ( CArchive * pArchive )

Call this function to write an image list object to an archive.

Parameters
pArchive A pointer to a CArchive object in which the image list is to be stored.
Returns
Nonzero if successful; otherwise 0.
The documentation for this class was generated from the following file:
  • XTPImageList.h


Toolkit Pro: CXTPImageManager Class Reference

Public Member Functions | Static Public Member Functions | Public Attributes | Static Public Attributes | List of all members
CXTPImageManager Class Reference

CXTPImageManager is a standalone class. More...

Inheritance diagram for CXTPImageManager:
[legend]

Public Member Functions

CXTPImageManager ()
Constructs a CXTPImageManager object.
~CXTPImageManager ()
Destroys a CXTPImageManager object, handles cleanup and deallocation.
BOOL | SetIcons (UINT nIDResourceToolBar, XTPImageState imageState=xtpImageNormal)
Adds the icons.
BOOL | SetIcons (UINT nIDResourceToolBar, UINT nIDResourceBitmap, XTPImageState imageState=xtpImageNormal)
Adds the icons.
BOOL | SetIcons (CBitmap &bmpIcons, UINT *pCommands, int nCount, CSize szIcon, XTPImageState imageState=xtpImageNormal, BOOL bAlpha=FALSE)
Adds the icons.
BOOL | SetIcons (UINT nIDResourceToolBar, CBitmap &bmpIcons, XTPImageState imageState=xtpImageNormal)
Adds the icons.
BOOL | SetIcons (UINT nIDResourceBitmap, UINT *pCommands, int nCount, CSize szIcon, XTPImageState imageState=xtpImageNormal)
Adds the icons.
BOOL | SetIcons (LPCTSTR lpszResourceBitmap, UINT *pCommands, int nCount, CSize szIcon, XTPImageState imageState=xtpImageNormal)
Adds the icons.
BOOL | SetIcons (CImageList &imlIcons, UINT *pCommands, int nCount, CSize szIcon, XTPImageState imageState=xtpImageNormal)
Adds the icons.
BOOL | SetIcons (UINT nIDResourceToolBar, CImageList &imlIcons, XTPImageState imageState=xtpImageNormal)
Adds the icons.
BOOL | SetIconFromIcoFile (LPCTSTR lpszFileName, UINT nIDCommand, CSize szIcon, XTPImageState imageState)
This method loads an icon from an .ico file.
BOOL | SetImageList (HIMAGELIST hImageList, int nBaseCommand, BOOL bDestroyImageList=FALSE)
Call this method to attach images from an HIMAGELIST control to the image manager.
BOOL | SetImageList (UINT nIDResourceBitmap, int cx, int nBaseCommand=0, COLORREF clrMask=(COLORREF) -1)
Call this method to create a system HIMAGELIST from a bitmap and add it to the image manager.
void | AddIcons (CXTPImageManager *pImageManager)
Adds the icons from another image manager.
void | AddIcons (CXTPImageManagerIconSet *pIconSet)
Adds the icons from another image manager.
BOOL | SetIcon (const CXTPImageManagerIconHandle &hIcon, UINT nIDCommand, CSize szIcon=0, XTPImageState imageState=xtpImageNormal)
Adds the icon.
BOOL | SetIcon (UINT nIDResourceIcon, UINT nIDCommand, CSize szIcon=0, XTPImageState imageState=xtpImageNormal)
Adds the icon.
BOOL | SetIcon (LPCTSTR lpszResourceIcon, UINT nIDCommand, CSize szIcon=0, XTPImageState imageState=xtpImageNormal)
Sets the icon.
BOOL | SetVectorIcon (LPCTSTR lpResourceType, UINT nIDResource, UINT nIDCommand, UINT nWidth, XTPImageState imageState=xtpImageNormal)
Sets a vector icon for the specific image state and command identifier.
BOOL | SetVectorIcon (LPCTSTR lpResourceType, LPCTSTR lpResource, UINT nIDCommand, UINT nWidth, XTPImageState imageState=xtpImageNormal)
Sets a vector icon for the specific image state and command identifier.
BOOL | SetVectorIcon (HMODULE hModule, LPCTSTR lpResourceType, UINT nIDResource, UINT nIDCommand, UINT nWidth, XTPImageState imageState=xtpImageNormal)
Sets a vector icon for the specific image state and command identifier.
BOOL | SetVectorIcon (HMODULE hModule, LPCTSTR lpResourceType, LPCTSTR lpResource, UINT nIDCommand, UINT nWidth, XTPImageState imageState=xtpImageNormal)
Sets a vector icon for the specific image state and command identifier.
BOOL | SetVectorIcon (CXTPImageManagerVectorImageHandle hImage, UINT nIDCommand, UINT nWidth, XTPImageState imageState=xtpImageNormal)
Sets a vector icon for the specific image state and command identifier.
BOOL | SetVectorIcon (LPCTSTR lpResourceType, UINT nIDResourceNormal, UINT nIDResourceDisabled, UINT nIDResourceHot, UINT nIDResourceChecked, UINT nIDResourcePressed, UINT nIDCommand, UINT nWidth)
Sets a vector icon for the specific image state and command identifier.
BOOL | SetVectorIcon (LPCTSTR lpResourceType, LPCTSTR lpIDResourceNormal, LPCTSTR lpIDResourceDisabled, LPCTSTR lpIDResourceHot, LPCTSTR lpIDResourceChecked, LPCTSTR lpIDResourcePressed, UINT nIDCommand, UINT nWidth)
Sets a vector icon for the specific image state and command identifier.
BOOL | SetVectorIcon (HMODULE hModule, LPCTSTR lpResourceType, UINT nIDResourceNormal, UINT nIDResourceDisabled, UINT nIDResourceHot, UINT nIDResourceChecked, UINT nIDResourcePressed, UINT nIDCommand, UINT nWidth)
Sets a vector icon for the specific image state and command identifier.
BOOL | SetVectorIcon (HMODULE hModule, LPCTSTR lpResourceType, LPCTSTR lpIDResourceNormal, LPCTSTR lpIDResourceDisabled, LPCTSTR lpIDResourceHot, LPCTSTR lpIDResourceChecked, LPCTSTR lpIDResourcePressed, UINT nIDCommand, UINT nWidth)
Sets a vector icon for the specific image state and command identifier.
BOOL | SetVectorIcon (CXTPImageManagerVectorImageHandle hImageNormal, CXTPImageManagerVectorImageHandle hImageDisabled, CXTPImageManagerVectorImageHandle hImageHot, CXTPImageManagerVectorImageHandle hImageChecked, CXTPImageManagerVectorImageHandle hImagePressed, UINT nIDCommand, UINT nWidth)
Sets a vector icon for the specific image state and command identifier.
BOOL | SetVectorIcon (IStream *pStream, UINT nIDCommand, UINT nWidth, XTPImageState imageState)
Sets a vector icon for the specific image state and command identifier.
COLORREF | SetMaskColor (COLORREF clrMask)
Call this method to set the mask color of the bitmaps that will be added.
COLORREF | GetMaskColor () const
Retrieves mask color.
void | DrawReverted (BOOL bDrawReverted)
Mirrors images around the y-axis, useful in RTL (Right-To-Left) Languages.
void | RemoveAll ()
Removes all icons.
void | RemoveIcon (UINT nIDCommand)
Removes the specified icon.
void | RefreshAll ()
Redraws all icons.
UINT | AddCustomIcon (const CXTPImageManagerIconHandle &hIcon)
This method is used by CommandBars to add custom icons.
CXTPImageManagerIcon * | GetImage (UINT nCommand, int nWidth=16) const
Call this member to get the icon with the specified ID and width.
BOOL | IsPrimaryImageExists (UINT nCommand, int nWidth) const
Call this method to determine if a non-scaled image exists in the image manager.
CXTPImageManagerIconSet * | GetIconSet (UINT nCommand) const
Call this member to get the icon set with the specified ID.
CXTPImageManagerImageList * | GetImageList (UINT nCommand) const
Call this member to get the icon set with the specified ID from an image list.
CMap< UINT, UINT, CXTPImageManagerIconSet *, CXTPImageManagerIconSet * > * | GetImages ()
Retrieves a collection of images.
BOOL | Lookup (UINT nCommand) const
Checks if an icon set exists with a specified ID.
BOOL | IsDrawReverted () const
Checks if the icons are drawn mirrored/reverted.
BOOL | IsDrawReverted (CDC *pDC) const
Checks if the icons are drawn mirrored/reverted.
CXTPImageManagerResource * | GetResource (CSize szIcon)
Retrieves resources of a specified size.
void | Serialize (CArchive &ar)
Either reads icons from or writes icons to an archive.
void | Serialize (UINT nCommand, CArchive &ar)
Either reads icons from or writes icons to an archive.
void | DoPropExchange (CXTPPropExchange *pPX)
Either reads icons from or writes icons to an archive.
void | DoPropExchange (UINT nCommand, CXTPPropExchange *pPX)
Either reads icons from or writes icons to an archive.
BOOL | IsAlphaIconsSupported () const
Determines if the OS supports alpha icons.
BOOL | TransparentBlt (HDC hdcDest, const CRect &rcDest, HDC hdcSrc, const CRect &rcSrc, UINT crTransparent) const
The TransparentBlt function performs a bit-block transfer of the color data corresponding to a rectangle of pixels from a specified source device context into a destination device context.
BOOL | AlphaBlend (HDC hdcDest, const CRect &rcDest, HDC hdcSrc, const CRect &rcSrc) const
The AlphaBlend function displays bitmaps that have transparent or semi-transparent pixels.
BOOL | AlphaBlend2 (HDC hdcDest, const CRect &rcDest, HDC hdcSrc, const CRect &rcSrc, BYTE Transparency) const
The AlphaBlend function displays bitmaps that have transparent or semi-transparent pixels.
BOOL | DisableBitmap (HDC hDC, const CRect &rcRect, COLORREF clrDisabledLight=(COLORREF) -1, COLORREF clrDisabledDark=(COLORREF) -1)
This function makes a rectangle in a specified device context disabled.
BOOL | BlackWhiteBitmap (HDC hDC, const CRect &rcRect, int nBlackAndWhiteContrast=0)
This function makes a rectangle in a specified device context gray scale.
BOOL | SetIconFromResource (HINSTANCE hInst, LPCTSTR lpszResourceName, UINT nIDCommand, CSize szIcon, XTPImageState imageState)
This method adds all icons of a specified size from resources.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Static Public Member Functions

static BOOL AFX_CDECL | IsAlphaBitmapResource (UINT nIDResourceBitmap)
Checks if a bitmap with a specified resource has alpha channel.
static BOOL AFX_CDECL | IsPngBitmapResource (UINT nIDResourceBitmap)
Determines if a resource contains a .PNG image.
static BOOL AFX_CDECL | IsAlphaIconsImageListSupported ()
Determines if the OS supports alpha image list.
static COLORREF AFX_CDECL | GetBitmapMaskColor (CBitmap &bmp, CPoint pt=0)
Retrieves the color of the top-left pixel.
static COLORREF AFX_CDECL | GetBitmapMaskColor (UINT nIDBitmap, CPoint pt=0)
Retrieves the color of the top-left pixel.
static HBITMAP AFX_CDECL | ResampleAlphaLayer (HBITMAP bmpAlpha, COLORREF clrMask)
This method creates a 24bit bitmap from a 32bit alpha bitmap to draw it in old OSs.
static HBITMAP AFX_CDECL | ResampleAlphaLayer (UINT nIDBitmap, COLORREF clrMask)
This method creates a 24bit bitmap from a 32bit alpha bitmap to draw it in old OSs.
static HBITMAP AFX_CDECL | Create32BPPDIBSection (HDC hDC, int iWidth, int iHeight, LPBYTE *lpBits=NULL)
This helper method creates a 32bit bitmap.
static BOOL AFX_CDECL | McTransparentBlt (HDC hdcDest, int nXOriginDest, int nYOriginDest, int nWidthDest, int nHeightDest, HDC hdcSrc, int nXOriginSrc, int nYOriginSrc, int nWidthSrc, int nHeightSrc, UINT crTransparent)
Fall back for systems without MSIMG32.DLL.
static void AFX_CDECL | PreMultiplyAlphaBitmapBits (LPVOID lpBits, SIZE_T nSize, PBOOL pbAlpha=NULL)
Pre-multiplies alpha bitmap bits to be used in AlphaBlend.
static void AFX_CDECL | PreMultiplyAlphaBitmapBits (LPVOID lpBits, CSize size, PBOOL pbAlpha=NULL)
Pre-multiplies alpha bitmap bits to be used in AlphaBlend.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Public Attributes

BOOL m_bUseResources
TRUE to create a single bitmap for all icons.

Static Public Attributes

static double | m_dDisabledBrightnessFactor
Brightness factor of disabled icons.
static double | m_dDisabledAlphaFactor
Alpha factor of disabled icons.
static BOOL | m_bAutoResample
TRUE to automatically re-sample alpha bitmaps if msimg32 is not found.
static CLIPFORMAT | m_nImageClipFormat
Clipboard format of icons.
static CLIPFORMAT | m_nAlphaClipFormat
Clipboard format of icons.

Detailed Description

CXTPImageManager is a standalone class.

It is used to manipulate icons.

Member Function Documentation

◆ AddCustomIcon()

UINT AddCustomIcon ( const CXTPImageManagerIconHandle & hIcon )

This method is used by CommandBars to add custom icons.

Parameters
hIcon Icon handler to be added.
Returns
Identifier of the newly added icon.

◆ AddIcons() [1/2]

void AddIcons ( CXTPImageManager * pImageManager )

Adds the icons from another image manager.

Parameters
pImageManager A pointer to another image manager. The icons in pImageManager will be added to this image manager.

◆ AddIcons() [2/2]

void AddIcons ( CXTPImageManagerIconSet * pIconSet )

Adds the icons from another image manager.

Parameters
pIconSet A pointer to an image manager icon set. The icons in pIconSet will be added to this image manager.

◆ AlphaBlend()

BOOL AlphaBlend | ( | HDC | hdcDest,
 |  | const CRect & | rcDest,
 |  | HDC | hdcSrc,
 |  | const CRect & | rcSrc ) const

The AlphaBlend function displays bitmaps that have transparent or semi-transparent pixels.

Parameters
hdcDest | Handle to destination DC.
rcDest | Destination rectangle.
hdcSrc | Handle to source DC.
rcSrc | Source rectangle.
Returns
TRUE if successful.
See also
TransparentBlt

◆ AlphaBlend2()

BOOL AlphaBlend2 | ( | HDC | hdcDest,
 |  | const CRect & | rcDest,
 |  | HDC | hdcSrc,
 |  | const CRect & | rcSrc,
 |  | BYTE | Transparency ) const

The AlphaBlend function displays bitmaps that have transparent or semi-transparent pixels.

Parameters
hdcDest | Handle to destination DC.
rcDest | Destination rectangle.
hdcSrc | Handle to source DC.
rcSrc | Source rectangle.
Transparency | Transparency for whole image to draw.
Returns
TRUE if successful.
See also
TransparentBlt

◆ BlackWhiteBitmap()

BOOL BlackWhiteBitmap | ( | HDC | hDC,
 |  | const CRect & | rcRect,
 |  | int | nBlackAndWhiteContrast = 0 )

This function makes a rectangle in a specified device context gray scale.

Parameters
hDC | A handle to DC.
rcRect | A rectangle to be made gray scale.
nBlackAndWhiteContrast | Black-white contrast as integer from 0 to 255.
Returns
TRUE if successful.
See also
DisableBitmap

◆ Create32BPPDIBSection()

static HBITMAP AFX_CDECL Create32BPPDIBSection | ( | HDC | hDC,
 |  | int | iWidth,
 |  | int | iHeight,
 |  | LPBYTE * | lpBits = NULL )
 static

This helper method creates a 32bit bitmap.

Parameters
hDC | Pointer to a valid context (can be NULL).
iWidth | Width of bitmap.
iHeight | Height of bitmap.
lpBits | Pointer to bits to return.
Returns
The newly created bitmap handle.

◆ DisableBitmap()

BOOL DisableBitmap | ( | HDC | hDC,
 |  | const CRect & | rcRect,
 |  | COLORREF | clrDisabledLight = (COLORREF) -1,
 |  | COLORREF | clrDisabledDark = (COLORREF) -1 )

This function makes a rectangle in a specified device context disabled.

Parameters
hDC | A handle to DC.
rcRect | A rectangle to be disabled.
clrDisabledLight | The lightest color of icon to generate.
clrDisabledDark | The darkest color of icon to generate.
Returns
TRUE if successful.
See also
BlackWhiteBitmap

◆ DoPropExchange() [1/2]

void DoPropExchange ( CXTPPropExchange * pPX )

Either reads icons from or writes icons to an archive.

Parameters
pPX A CXTPPropExchange object to serialize to or from.

◆ DoPropExchange() [2/2]

void DoPropExchange | ( | UINT | nCommand,
 |  | CXTPPropExchange * | pPX )

Either reads icons from or writes icons to an archive.

Parameters
nCommand | Specified command to serialize.
pPX | A CXTPPropExchange object to serialize to or from.

◆ DrawReverted()

void DrawReverted ( BOOL bDrawReverted )

Mirrors images around the y-axis, useful in RTL (Right-To-Left) Languages.

Parameters
bDrawReverted If TRUE, images are "flipped" or Mirrored. This should be used when displaying images in an application that uses RTL (Right-To-Left) Languages.

◆ GetBitmapMaskColor() [1/2]

static COLORREF AFX_CDECL GetBitmapMaskColor | ( | CBitmap & | bmp,
 |  | CPoint | pt = 0 )
 static

Retrieves the color of the top-left pixel.

Parameters
bmp | CBitmap reference.
pt | Location of the pixel to retrieve.
Returns
A COLORREF value that will be used as a transparent color.

◆ GetBitmapMaskColor() [2/2]

static COLORREF AFX_CDECL GetBitmapMaskColor | ( | UINT | nIDBitmap,
 |  | CPoint | pt = 0 )
 static

Retrieves the color of the top-left pixel.

Parameters
nIDBitmap | Bitmap identifier.
pt | Location of the pixel to retrieve.
Returns
A COLORREF value that will be used as a transparent color.

◆ GetIconSet()

CXTPImageManagerIconSet * GetIconSet ( UINT nCommand ) const

Call this member to get the icon set with the specified ID.

Parameters
nCommand ID of the icon set to be retrieved.
Returns
A pointer to a CXTPImageManagerIconSet object.

◆ GetImage()

CXTPImageManagerIcon * GetImage | ( | UINT | nCommand,
 |  | int | nWidth = 16 ) const

Call this member to get the icon with the specified ID and width.

Parameters
nCommand | ID of the icon to be retrieved.
nWidth | Width of the icon to be retrieved.
Returns
A pointer to a CXTPImageManagerIcon object.

◆ GetImageList()

CXTPImageManagerImageList * GetImageList ( UINT nCommand ) const

Call this member to get the icon set with the specified ID from an image list.

Parameters
nCommand ID of the icon set to be retrieved.
Returns
A pointer to a CXTPImageManagerImageList object.

◆ GetImages()

CMap< UINT, UINT, CXTPImageManagerIconSet *, CXTPImageManagerIconSet * > * GetImages ( )

Retrieves a collection of images.

Returns
A CMap object.

◆ GetMaskColor()

COLORREF GetMaskColor ( ) const

Retrieves mask color.

Returns
Current mask color.

◆ GetResource()

CXTPImageManagerResource * GetResource ( CSize szIcon )

Retrieves resources of a specified size.

Parameters
szIcon Size of resources to retrieve.
Returns
Pointer to a CXTPImageManagerResource object containing all icons of the specified size.

◆ IsAlphaBitmapResource()

static BOOL AFX_CDECL IsAlphaBitmapResource ( UINT nIDResourceBitmap )
static

Checks if a bitmap with a specified resource has alpha channel.

Parameters
nIDResourceBitmap Resource identifier of the bitmap to check.
Returns
TRUE if the bitmap has alpha channel, otherwise FALSE.

◆ IsAlphaIconsImageListSupported()

static BOOL AFX_CDECL IsAlphaIconsImageListSupported ( )
static

Determines if the OS supports alpha image list.

Returns
TRUE if successful; otherwise returns FALSE
See also
IsAlphaIconsSupported

◆ IsAlphaIconsSupported()

BOOL IsAlphaIconsSupported ( ) const

Determines if the OS supports alpha icons.

Returns
TRUE if successful; otherwise returns FALSE.
See also
IsAlphaIconsImageListSupported

◆ IsDrawReverted() [1/2]

BOOL IsDrawReverted ( ) const

Checks if the icons are drawn mirrored/reverted.

Returns
TRUE if the icons are drawn mirrored/reverted, FALSE if icons are drawn normal.

◆ IsDrawReverted() [2/2]

BOOL IsDrawReverted ( CDC * pDC ) const

Checks if the icons are drawn mirrored/reverted.

Parameters
pDC Pointer to the device context to check.
Returns
TRUE if the icons are drawn mirrored/reverted, FALSE if icons are drawn normal.

◆ IsPngBitmapResource()

static BOOL AFX_CDECL IsPngBitmapResource ( UINT nIDResourceBitmap )
static

Determines if a resource contains a .PNG image.

Parameters
nIDResourceBitmap ID of the resource to check.
Returns
TRUE if the resource contains a .PNG image.

◆ IsPrimaryImageExists()

BOOL IsPrimaryImageExists | ( | UINT | nCommand,
 |  | int | nWidth ) const

Call this method to determine if a non-scaled image exists in the image manager.

Parameters
nCommand | Image identifier to check.
nWidth | Image width to check.
Returns
TRUE if a non-scaled image exists in the image manager.
See also
GetImage

◆ Lookup()

BOOL Lookup ( UINT nCommand ) const

Checks if an icon set exists with a specified ID.

Parameters
nCommand ID of the icon set to check for.
Returns
TRUE if successful, otherwise FALSE.

◆ McTransparentBlt()

static BOOL AFX_CDECL McTransparentBlt | ( | HDC | hdcDest,
 |  | int | nXOriginDest,
 |  | int | nYOriginDest,
 |  | int | nWidthDest,
 |  | int | nHeightDest,
 |  | HDC | hdcSrc,
 |  | int | nXOriginSrc,
 |  | int | nYOriginSrc,
 |  | int | nWidthSrc,
 |  | int | nHeightSrc,
 |  | UINT | crTransparent )
 static

Fall back for systems without MSIMG32.DLL.

Parameters
hdcDest | A handle to the destination device context.
nXOriginDest | The x-coordinate, in logical units, of the upper-left corner of the destination rectangle.
nYOriginDest | The y-coordinate, in logical units, of the upper-left corner of the destination rectangle.
nWidthDest | The width, in logical units, of the destination rectangle.
nHeightDest | The height, in logical units, of the destination rectangle.
hdcSrc | A handle to the source device context.
nXOriginSrc | The x-coordinate, in logical units, of the source rectangle.
nYOriginSrc | The y-coordinate, in logical units, of the source rectangle.
nWidthSrc | The width, in logical units, of the source rectangle.
nHeightSrc | The height, in logical units, of the source rectangle.
crTransparent | The RGB color in the source bitmap to treat as transparent.
Returns
If the function suceeds True, if not False

◆ PreMultiplyAlphaBitmapBits() [1/2]

static void AFX_CDECL PreMultiplyAlphaBitmapBits | ( | LPVOID | lpBits,
 |  | CSize | size,
 |  | PBOOL | pbAlpha = NULL )
 static

Pre-multiplies alpha bitmap bits to be used in AlphaBlend.

Parameters
lpBits | Alpha bitmap bits.
size | Alpha bitmap dimensions.
pbAlpha | An optional pointer to a boolean variable that will be set to TRUE if alpha bits are detected.
Returns

◆ PreMultiplyAlphaBitmapBits() [2/2]

static void AFX_CDECL PreMultiplyAlphaBitmapBits | ( | LPVOID | lpBits,
 |  | SIZE_T | nSize,
 |  | PBOOL | pbAlpha = NULL )
 static

Pre-multiplies alpha bitmap bits to be used in AlphaBlend.

Parameters
lpBits | Alpha bitmap bits.
nSize | Alpha bitmap bit buffer size in bytes.
pbAlpha | An optional pointer to a boolean variable that will be set to TRUE if alpha bits are detected.
Returns

◆ RemoveIcon()

void RemoveIcon ( UINT nIDCommand )

Removes the specified icon.

Parameters
nIDCommand ID of the icon to be removed.

◆ ResampleAlphaLayer() [1/2]

static HBITMAP AFX_CDECL ResampleAlphaLayer | ( | HBITMAP | bmpAlpha,
 |  | COLORREF | clrMask )
 static

This method creates a 24bit bitmap from a 32bit alpha bitmap to draw it in old OSs.

Parameters
bmpAlpha | Resource bitmap identifier.
clrMask | Mask color to be used.
Returns
Reduced bitmap handler.

◆ ResampleAlphaLayer() [2/2]

static HBITMAP AFX_CDECL ResampleAlphaLayer | ( | UINT | nIDBitmap,
 |  | COLORREF | clrMask )
 static

This method creates a 24bit bitmap from a 32bit alpha bitmap to draw it in old OSs.

Parameters
nIDBitmap | Resource bitmap identifier.
clrMask | Mask color to be used.
Returns
Reduced bitmap handler.

◆ Serialize() [1/2]

void Serialize ( CArchive & ar )

Either reads icons from or writes icons to an archive.

Parameters
ar A CArchive object to serialize to or from.

◆ Serialize() [2/2]

void Serialize | ( | UINT | nCommand,
 |  | CArchive & | ar )

Either reads icons from or writes icons to an archive.

Parameters
nCommand | Specified command to serialize.
ar | A CArchive object to serialize to or from.

◆ SetIcon() [1/3]

BOOL SetIcon | ( | const CXTPImageManagerIconHandle & | hIcon,
 |  | UINT | nIDCommand,
 |  | CSize | szIcon = 0,
 |  | XTPImageState | imageState = xtpImageNormal )

Adds the icon.

Parameters
hIcon | Icon handle to add.
nIDCommand | Icon identifier.
szIcon | Size of the icons.
imageState | Images state.
Returns
TRUE if successful, otherwise FALSE.
See also
XTPImageState, SetIcons

◆ SetIcon() [2/3]

BOOL SetIcon | ( | LPCTSTR | lpszResourceIcon,
 |  | UINT | nIDCommand,
 |  | CSize | szIcon = 0,
 |  | XTPImageState | imageState = xtpImageNormal )

Sets the icon.

Parameters
lpszResourceIcon | Icon resource identifier.
nIDCommand | Icon identifier.
szIcon | Size of the icons.
imageState | Images state.
Returns
TRUE if successful, otherwise FALSE.
See also
XTPImageState, SetIcons

◆ SetIcon() [3/3]

BOOL SetIcon | ( | UINT | nIDResourceIcon,
 |  | UINT | nIDCommand,
 |  | CSize | szIcon = 0,
 |  | XTPImageState | imageState = xtpImageNormal )

Adds the icon.

Parameters
nIDResourceIcon | Icon resource identifier.
nIDCommand | Icon identifier.
szIcon | Size of the icons.
imageState | Images state.
Returns
TRUE if successful, otherwise FALSE.
See also
XTPImageState, SetIcons

◆ SetIconFromIcoFile()

BOOL SetIconFromIcoFile | ( | LPCTSTR | lpszFileName,
 |  | UINT | nIDCommand,
 |  | CSize | szIcon,
 |  | XTPImageState | imageState )

This method loads an icon from an .ico file.

Parameters
lpszFileName | Path to .ico file.
nIDCommand | Icon command.
szIcon | Size of the icons.
imageState | Images state.
Returns
TRUE if successful, otherwise FALSE.

◆ SetIconFromResource()

BOOL SetIconFromResource | ( | HINSTANCE | hInst,
 |  | LPCTSTR | lpszResourceName,
 |  | UINT | nIDCommand,
 |  | CSize | szIcon,
 |  | XTPImageState | imageState )

This method adds all icons of a specified size from resources.

Parameters
hInst | Module instance to load icons from.
lpszResourceName | Icon resource identifier.
nIDCommand | Command to assign for the icon.
szIcon | Size of the icon to load (0 to load all formats).
imageState | Image state to assign for the icon.
Returns
TRUE if successful.

◆ SetIcons() [1/8]

BOOL SetIcons | ( | CBitmap & | bmpIcons,
 |  | UINT * | pCommands,
 |  | int | nCount,
 |  | CSize | szIcon,
 |  | XTPImageState | imageState = xtpImageNormal,
 |  | BOOL | bAlpha = FALSE )

Adds the icons.

Parameters
bmpIcons | Bitmap containing the icons to be added.
pCommands | Pointer to an array of IDs.
nCount | Number of elements in the array pointed to by lpIDArray.
szIcon | Size of the icons.
imageState | Images state.
bAlpha | TRUE if the bitmap has alpha channel.
Returns
TRUE if successful, otherwise FALSE.

Example:

static UINT buttons[] =
{
   ID_BACK,
   ID_FORWARD,
   ID_STOP,
   ID_REFRESH,
   ID_HOME
}

XTPImageManager()->SetMaskColor(RGB(0, 0xFF, 0));

XTPImageManager()->SetIcons(IDR_TOOLBAR_NORMAL_SMALL, buttons, _countof(buttons), CSize(16,
16), xtpImageNormal); XTPImageManager()->SetIcons(IDR_TOOLBAR_HOT_SMALL, buttons,
_countof(buttons), CSize(16, 16), xtpImageHot);

XTPImageManager()->SetIcons(IDR_TOOLBAR_NORMAL_LARGE, buttons, _countof(buttons), CSize(24,
24), xtpImageNormal); XTPImageManager()->SetIcons(IDR_TOOLBAR_HOT_LARGE, buttons,
_countof(buttons), CSize(24, 24), xtpImageHot);
See also
XTPImageState, SetIcon

◆ SetIcons() [2/8]

BOOL SetIcons | ( | CImageList & | imlIcons,
 |  | UINT * | pCommands,
 |  | int | nCount,
 |  | CSize | szIcon,
 |  | XTPImageState | imageState = xtpImageNormal )

Adds the icons.

Parameters
imlIcons | Image list containing the icons to be added.
pCommands | Pointer to an array of IDs.
nCount | Number of elements in the array pointed to by lpIDArray.
szIcon | Size of the icons.
imageState | Images state.
Returns
TRUE if successful, otherwise FALSE.

Example:

static UINT buttons[] =
{
   ID_BACK,
   ID_FORWARD,
   ID_STOP,
   ID_REFRESH,
   ID_HOME
}

XTPImageManager()->SetMaskColor(RGB(0, 0xFF, 0));

XTPImageManager()->SetIcons(IDR_TOOLBAR_NORMAL_SMALL, buttons, _countof(buttons), CSize(16,
16), xtpImageNormal); XTPImageManager()->SetIcons(IDR_TOOLBAR_HOT_SMALL, buttons,
_countof(buttons), CSize(16, 16), xtpImageHot);

XTPImageManager()->SetIcons(IDR_TOOLBAR_NORMAL_LARGE, buttons, _countof(buttons), CSize(24,
24), xtpImageNormal); XTPImageManager()->SetIcons(IDR_TOOLBAR_HOT_LARGE, buttons,
_countof(buttons), CSize(24, 24), xtpImageHot);
See also
XTPImageState, SetIcon

◆ SetIcons() [3/8]

BOOL SetIcons | ( | LPCTSTR | lpszResourceBitmap,
 |  | UINT * | pCommands,
 |  | int | nCount,
 |  | CSize | szIcon,
 |  | XTPImageState | imageState = xtpImageNormal )

Adds the icons.

Parameters
lpszResourceBitmap | Bitmap resource identifier.
pCommands | Pointer to an array of IDs.
nCount | Number of elements in the array pointed to by lpIDArray.
szIcon | Size of the icons.
imageState | Images state.
Returns
TRUE if successful, otherwise FALSE.

Example:

static UINT buttons[] =
{
   ID_BACK,
   ID_FORWARD,
   ID_STOP,
   ID_REFRESH,
   ID_HOME
}

XTPImageManager()->SetMaskColor(RGB(0, 0xFF, 0));

XTPImageManager()->SetIcons(IDR_TOOLBAR_NORMAL_SMALL, buttons, _countof(buttons), CSize(16,
16), xtpImageNormal); XTPImageManager()->SetIcons(IDR_TOOLBAR_HOT_SMALL, buttons,
_countof(buttons), CSize(16, 16), xtpImageHot);

XTPImageManager()->SetIcons(IDR_TOOLBAR_NORMAL_LARGE, buttons, _countof(buttons), CSize(24,
24), xtpImageNormal); XTPImageManager()->SetIcons(IDR_TOOLBAR_HOT_LARGE, buttons,
_countof(buttons), CSize(24, 24), xtpImageHot);
See also
XTPImageState, SetIcon

◆ SetIcons() [4/8]

BOOL SetIcons | ( | UINT | nIDResourceBitmap,
 |  | UINT * | pCommands,
 |  | int | nCount,
 |  | CSize | szIcon,
 |  | XTPImageState | imageState = xtpImageNormal )

Adds the icons.

Parameters
nIDResourceBitmap | Bitmap resource identifier.
pCommands | Pointer to an array of IDs.
nCount | Number of elements in the array pointed to by lpIDArray.
szIcon | Size of the icons.
imageState | Images state.
Returns
TRUE if successful, otherwise FALSE.

Example:

static UINT buttons[] =
{
   ID_BACK,
   ID_FORWARD,
   ID_STOP,
   ID_REFRESH,
   ID_HOME
}

XTPImageManager()->SetMaskColor(RGB(0, 0xFF, 0));

XTPImageManager()->SetIcons(IDR_TOOLBAR_NORMAL_SMALL, buttons, _countof(buttons), CSize(16,
16), xtpImageNormal); XTPImageManager()->SetIcons(IDR_TOOLBAR_HOT_SMALL, buttons,
_countof(buttons), CSize(16, 16), xtpImageHot);

XTPImageManager()->SetIcons(IDR_TOOLBAR_NORMAL_LARGE, buttons, _countof(buttons), CSize(24,
24), xtpImageNormal); XTPImageManager()->SetIcons(IDR_TOOLBAR_HOT_LARGE, buttons,
_countof(buttons), CSize(24, 24), xtpImageHot);
See also
XTPImageState, SetIcon

◆ SetIcons() [5/8]

BOOL SetIcons | ( | UINT | nIDResourceToolBar,
 |  | CBitmap & | bmpIcons,
 |  | XTPImageState | imageState = xtpImageNormal )

Adds the icons.

Parameters
nIDResourceToolBar | Toolbar resource identifier.
bmpIcons | Bitmap containing the icons to be added.
imageState | Images state.
Returns
TRUE if successful, otherwise FALSE.

Example:

static UINT buttons[] =
{
   ID_BACK,
   ID_FORWARD,
   ID_STOP,
   ID_REFRESH,
   ID_HOME
}

XTPImageManager()->SetMaskColor(RGB(0, 0xFF, 0));

XTPImageManager()->SetIcons(IDR_TOOLBAR_NORMAL_SMALL, buttons, _countof(buttons), CSize(16,
16), xtpImageNormal); XTPImageManager()->SetIcons(IDR_TOOLBAR_HOT_SMALL, buttons,
_countof(buttons), CSize(16, 16), xtpImageHot);

XTPImageManager()->SetIcons(IDR_TOOLBAR_NORMAL_LARGE, buttons, _countof(buttons), CSize(24,
24), xtpImageNormal); XTPImageManager()->SetIcons(IDR_TOOLBAR_HOT_LARGE, buttons,
_countof(buttons), CSize(24, 24), xtpImageHot);
See also
XTPImageState, SetIcon

◆ SetIcons() [6/8]

BOOL SetIcons | ( | UINT | nIDResourceToolBar,
 |  | CImageList & | imlIcons,
 |  | XTPImageState | imageState = xtpImageNormal )

Adds the icons.

Parameters
nIDResourceToolBar | Toolbar resource identifier.
imlIcons | Image list containing the icons to be added.
imageState | Images state.
Returns
TRUE if successful, otherwise FALSE.

Example:

static UINT buttons[] =
{
   ID_BACK,
   ID_FORWARD,
   ID_STOP,
   ID_REFRESH,
   ID_HOME
}

XTPImageManager()->SetMaskColor(RGB(0, 0xFF, 0));

XTPImageManager()->SetIcons(IDR_TOOLBAR_NORMAL_SMALL, buttons, _countof(buttons), CSize(16,
16), xtpImageNormal); XTPImageManager()->SetIcons(IDR_TOOLBAR_HOT_SMALL, buttons,
_countof(buttons), CSize(16, 16), xtpImageHot);

XTPImageManager()->SetIcons(IDR_TOOLBAR_NORMAL_LARGE, buttons, _countof(buttons), CSize(24,
24), xtpImageNormal); XTPImageManager()->SetIcons(IDR_TOOLBAR_HOT_LARGE, buttons,
_countof(buttons), CSize(24, 24), xtpImageHot);
See also
XTPImageState, SetIcon

◆ SetIcons() [7/8]

BOOL SetIcons | ( | UINT | nIDResourceToolBar,
 |  | UINT | nIDResourceBitmap,
 |  | XTPImageState | imageState = xtpImageNormal )

Adds the icons.

Parameters
nIDResourceToolBar | Resource identifier.
nIDResourceBitmap | Bitmap resource identifier.
imageState | Images state.
Returns
TRUE if successful, otherwise FALSE.

Example:

static UINT buttons[] =
{
   ID_BACK,
   ID_FORWARD,
   ID_STOP,
   ID_REFRESH,
   ID_HOME
}

XTPImageManager()->SetMaskColor(RGB(0, 0xFF, 0));

XTPImageManager()->SetIcons(IDR_TOOLBAR_NORMAL_SMALL, buttons, _countof(buttons), CSize(16,
16), xtpImageNormal); XTPImageManager()->SetIcons(IDR_TOOLBAR_HOT_SMALL, buttons,
_countof(buttons), CSize(16, 16), xtpImageHot);

XTPImageManager()->SetIcons(IDR_TOOLBAR_NORMAL_LARGE, buttons, _countof(buttons), CSize(24,
24), xtpImageNormal); XTPImageManager()->SetIcons(IDR_TOOLBAR_HOT_LARGE, buttons,
_countof(buttons), CSize(24, 24), xtpImageHot);
See also
XTPImageState, SetIcon

◆ SetIcons() [8/8]

BOOL SetIcons | ( | UINT | nIDResourceToolBar,
 |  | XTPImageState | imageState = xtpImageNormal )

Adds the icons.

Parameters
nIDResourceToolBar | Toolbar resource identifier.
imageState | Images state.
Returns
TRUE if successful, otherwise FALSE.

Example:

static UINT buttons[] =
{
   ID_BACK,
   ID_FORWARD,
   ID_STOP,
   ID_REFRESH,
   ID_HOME
}

XTPImageManager()->SetMaskColor(RGB(0, 0xFF, 0));

XTPImageManager()->SetIcons(IDR_TOOLBAR_NORMAL_SMALL, buttons, _countof(buttons), CSize(16,
16), xtpImageNormal); XTPImageManager()->SetIcons(IDR_TOOLBAR_HOT_SMALL, buttons,
_countof(buttons), CSize(16, 16), xtpImageHot);

XTPImageManager()->SetIcons(IDR_TOOLBAR_NORMAL_LARGE, buttons, _countof(buttons), CSize(24,
24), xtpImageNormal); XTPImageManager()->SetIcons(IDR_TOOLBAR_HOT_LARGE, buttons,
_countof(buttons), CSize(24, 24), xtpImageHot);
See also
XTPImageState, SetIcon

◆ SetImageList() [1/2]

BOOL SetImageList | ( | HIMAGELIST | hImageList,
 |  | int | nBaseCommand,
 |  | BOOL | bDestroyImageList = FALSE )

Call this method to attach images from an HIMAGELIST control to the image manager.

Parameters
hImageList | Pointer to an image list that holds icons.
nBaseCommand | ID to start numbering icons from the image list.
bDestroyImageList | TRUE to destroy the image list control after the icons are copied to the image manager. By default, this parameter is FALSE.
Returns
TRUE if successful, otherwise FALSE.

◆ SetImageList() [2/2]

BOOL SetImageList | ( | UINT | nIDResourceBitmap,
 |  | int | cx,
 |  | int | nBaseCommand = 0,
 |  | COLORREF | clrMask = (COLORREF) -1 )

Call this method to create a system HIMAGELIST from a bitmap and add it to the image manager.

Parameters
nIDResourceBitmap | Bitmap resource identifier.
cx | Width of the icons.
nBaseCommand | ID to start numbering icons from the image list.
clrMask | Mask color for bitmap.
Returns
TRUE if successful, otherwise FALSE.

The SetIcons method loads bitmaps and creates a HICON for each icon in the bitmap. SetImageList creates only one HIMAGELIST. Use SetImageList to create only one GDI object for all icons.

See also
SetIcons

◆ SetMaskColor()

COLORREF SetMaskColor ( COLORREF clrMask )

Call this method to set the mask color of the bitmaps that will be added.

Parameters
clrMask Mask color to be set.
Returns
Previous mask color.

◆ SetVectorIcon() [1/11]

BOOL SetVectorIcon | ( | CXTPImageManagerVectorImageHandle | hImage,
 |  | UINT | nIDCommand,
 |  | UINT | nWidth,
 |  | XTPImageState | imageState = xtpImageNormal )

Sets a vector icon for the specific image state and command identifier.

Parameters
hImage | Pre-loaded vector image handle.
nIDCommand | Associated command identifier.
nWidth | Preferred width of the icon.
imageState | Associated image state.
Returns
TRUE if the vector icon image has been successfully added.

◆ SetVectorIcon() [2/11]

BOOL SetVectorIcon | ( | CXTPImageManagerVectorImageHandle | hImageNormal,
 |  | CXTPImageManagerVectorImageHandle | hImageDisabled,
 |  | CXTPImageManagerVectorImageHandle | hImageHot,
 |  | CXTPImageManagerVectorImageHandle | hImageChecked,
 |  | CXTPImageManagerVectorImageHandle | hImagePressed,
 |  | UINT | nIDCommand,
 |  | UINT | nWidth )

Sets a vector icon for the specific image state and command identifier.

Parameters
hImageNormal | Pre-loaded normal state vector image handle.
hImageDisabled | Pre-loaded disabled state vector image handle.
hImageHot | Pre-loaded hot state vector image handle.
hImageChecked | Pre-loaded checked state vector image handle.
hImagePressed | Pre-loaded pressed state vector image handle.
nIDCommand | Associated command identifier.
nWidth | Preferred width of the icon.
Returns
TRUE if the vector icon image has been successfully added.

◆ SetVectorIcon() [3/11]

BOOL SetVectorIcon | ( | HMODULE | hModule,
 |  | LPCTSTR | lpResourceType,
 |  | LPCTSTR | lpIDResourceNormal,
 |  | LPCTSTR | lpIDResourceDisabled,
 |  | LPCTSTR | lpIDResourceHot,
 |  | LPCTSTR | lpIDResourceChecked,
 |  | LPCTSTR | lpIDResourcePressed,
 |  | UINT | nIDCommand,
 |  | UINT | nWidth )

Sets a vector icon for the specific image state and command identifier.

Parameters
hModule | Module's instance handle where to look for the icon resource.
lpResourceType | Vector icon resource type name.
lpIDResourceNormal | Normal state vector icon resource identifier.
lpIDResourceDisabled | Disabled state vector icon resource identifier.
lpIDResourceHot | Hot state vector icon resource identifier.
lpIDResourceChecked | Checked state vector icon resource identifier.
lpIDResourcePressed | Pressed state vector icon resource identifier.
nIDCommand | Associated command identifier.
nWidth | Preferred width of the icon.
Returns
TRUE if the vector icon image has been successfully added.

◆ SetVectorIcon() [4/11]

BOOL SetVectorIcon | ( | HMODULE | hModule,
 |  | LPCTSTR | lpResourceType,
 |  | LPCTSTR | lpResource,
 |  | UINT | nIDCommand,
 |  | UINT | nWidth,
 |  | XTPImageState | imageState = xtpImageNormal )

Sets a vector icon for the specific image state and command identifier.

Parameters
hModule | Module\'s instance handle where to look for the icon resource.
lpResourceType | Vector icon resource type name.
lpResource | Icon resource name.
nIDCommand | Associated command identifier.
nWidth | Preferred width of the icon.
imageState | Associated image state.
Returns
TRUE if the vector icon image has been successfully added.

◆ SetVectorIcon() [5/11]

BOOL SetVectorIcon | ( | HMODULE | hModule,
 |  | LPCTSTR | lpResourceType,
 |  | UINT | nIDResource,
 |  | UINT | nIDCommand,
 |  | UINT | nWidth,
 |  | XTPImageState | imageState = xtpImageNormal )

Sets a vector icon for the specific image state and command identifier.

Parameters
hModule | Module's instance handle where to look for the icon resource.
lpResourceType | Vector icon resource type name.
nIDResource | Vector icon resource identifier.
nIDCommand | Associated command identifier.
nWidth | Preferred width of the icon.
imageState | Associated image state.
Returns
TRUE if the vector icon image has been successfully added.

◆ SetVectorIcon() [6/11]

BOOL SetVectorIcon | ( | HMODULE | hModule,
 |  | LPCTSTR | lpResourceType,
 |  | UINT | nIDResourceNormal,
 |  | UINT | nIDResourceDisabled,
 |  | UINT | nIDResourceHot,
 |  | UINT | nIDResourceChecked,
 |  | UINT | nIDResourcePressed,
 |  | UINT | nIDCommand,
 |  | UINT | nWidth )

Sets a vector icon for the specific image state and command identifier.

Parameters
hModule | Module's instance handle where to look for the icon resource.
lpResourceType | Vector icon resource type name.
nIDResourceNormal | Normal state vector icon resource identifier.
nIDResourceDisabled | Disabled state vector icon resource identifier.
nIDResourceHot | Hot state vector icon resource identifier.
nIDResourceChecked | Checked state vector icon resource identifier.
nIDResourcePressed | Pressed state vector icon resource identifier.
nIDCommand | Associated command identifier.
nWidth | Preferred width of the icon.
Returns
TRUE if the vector icon image has been successfully added.

◆ SetVectorIcon() [7/11]

BOOL SetVectorIcon | ( | IStream * | pStream,
 |  | UINT | nIDCommand,
 |  | UINT | nWidth,
 |  | XTPImageState | imageState )

Sets a vector icon for the specific image state and command identifier.

Parameters
pStream | Vector icon data source.
nIDCommand | Associated command identifier.
nWidth | Preferred width of the icon.
imageState | Associated image state.
Returns
TRUE if the vector icon image has been successfully added.

◆ SetVectorIcon() [8/11]

BOOL SetVectorIcon | ( | LPCTSTR | lpResourceType,
 |  | LPCTSTR | lpIDResourceNormal,
 |  | LPCTSTR | lpIDResourceDisabled,
 |  | LPCTSTR | lpIDResourceHot,
 |  | LPCTSTR | lpIDResourceChecked,
 |  | LPCTSTR | lpIDResourcePressed,
 |  | UINT | nIDCommand,
 |  | UINT | nWidth )

Sets a vector icon for the specific image state and command identifier.

Parameters
lpResourceType | Vector icon resource type name.
lpIDResourceNormal | Normal state vector icon resource identifier.
lpIDResourceDisabled | Disabled state vector icon resource identifier.
lpIDResourceHot | Hot state vector icon resource identifier.
lpIDResourceChecked | Checked state vector icon resource identifier.
lpIDResourcePressed | Pressed state vector icon resource identifier.
nIDCommand | Associated command identifier.
nWidth | Preferred width of the icon.
Returns
TRUE if the vector icon image has been successfully added.

◆ SetVectorIcon() [9/11]

BOOL SetVectorIcon | ( | LPCTSTR | lpResourceType,
 |  | LPCTSTR | lpResource,
 |  | UINT | nIDCommand,
 |  | UINT | nWidth,
 |  | XTPImageState | imageState = xtpImageNormal )

Sets a vector icon for the specific image state and command identifier.

Parameters
lpResourceType | Vector icon resource type name.
lpResource | Vector icon resource identifier.
nIDCommand | Associated command identifier.
nWidth | Preferred width of the icon.
imageState | Associated image state.
Returns
TRUE if the vector icon image has been successfully added.

◆ SetVectorIcon() [10/11]

BOOL SetVectorIcon | ( | LPCTSTR | lpResourceType,
 |  | UINT | nIDResource,
 |  | UINT | nIDCommand,
 |  | UINT | nWidth,
 |  | XTPImageState | imageState = xtpImageNormal )

Sets a vector icon for the specific image state and command identifier.

Parameters
lpResourceType | Vector icon resource type name.
nIDResource | Vector icon resource identifier.
nIDCommand | Associated command identifier.
nWidth | Preferred width of the icon.
imageState | Associated image state.
Returns
TRUE if the vector icon image has been successfully added.

◆ SetVectorIcon() [11/11]

BOOL SetVectorIcon | ( | LPCTSTR | lpResourceType,
 |  | UINT | nIDResourceNormal,
 |  | UINT | nIDResourceDisabled,
 |  | UINT | nIDResourceHot,
 |  | UINT | nIDResourceChecked,
 |  | UINT | nIDResourcePressed,
 |  | UINT | nIDCommand,
 |  | UINT | nWidth )

Sets a vector icon for the specific image state and command identifier.

Parameters
lpResourceType | Vector icon resource type name.
nIDResourceNormal | Normal state vector icon resource identifier.
nIDResourceDisabled | Disabled state vector icon resource identifier.
nIDResourceHot | Hot state vector icon resource identifier.
nIDResourceChecked | Checked state vector icon resource identifier.
nIDResourcePressed | Pressed state vector icon resource identifier.
nIDCommand | Icon command identifier.
nWidth | Preferred width of the icon.
Returns
TRUE if the vector icon image has been successfully added.

◆ TransparentBlt()

BOOL TransparentBlt | ( | HDC | hdcDest,
 |  | const CRect & | rcDest,
 |  | HDC | hdcSrc,
 |  | const CRect & | rcSrc,
 |  | UINT | crTransparent ) const

The TransparentBlt function performs a bit-block transfer of the color data corresponding to a rectangle of pixels from a specified source device context into a destination device context.

Parameters
hdcDest | Handle to destination DC.
rcDest | Destination rectangle.
hdcSrc | Handle to source DC.
rcSrc | Source rectangle.
crTransparent | Color to make transparent.
Returns
TRUE if successful.
See also
AlphaBlend
The documentation for this class was generated from the following file:
  • XTPImageManager.h


Toolkit Pro: CXTPImageManagerIcon Class Reference

Public Member Functions | Static Public Member Functions | Public Attributes | List of all members
CXTPImageManagerIcon Class Reference

Icons holder class. More...

Inheritance diagram for CXTPImageManagerIcon:
[legend]

Public Member Functions

CXTPImageManagerIcon (UINT nID, int nWidth, int nHeight, CXTPImageManagerIconSet *pIconSet=NULL)
Constructs a CXTPImageManagerIcon object.
CXTPImageManagerIcon (UINT nID, int nWidth, int nHeight, CXTPImageManagerImageList *pImageList)
Constructs a CXTPImageManagerIcon object.
CXTPImageManagerIcon (UINT nID, CXTPImageManagerIconSet *pIconSet=NULL, CSize szRecommendedExtent=CSize(0))
Constructs a CXTPImageManagerIcon object.
~CXTPImageManagerIcon ()
Destroys a CXTPImageManagerIcon object, handles cleanup and deallocation.
UINT | GetID () const
Retrieves the image identifier.
BOOL | IsAlpha () const
Checks if the image has alpha channel.
BOOL | IsScaled () const
Checks if icons were scaled from another CXTPImageManagerIcon object.
CXTPImageManagerImageList * GetImageList ()
Obtains a pointer to an associated image list if the icon object is an icon in an image list.
const CXTPImageManagerImageList * | GetImageList () const
Obtains a pointer to an associated image list if the icon object is an icon in an image list.
CXTPImageManagerIconHandle & GetIcon ()
Retrieves the icon handle.
CXTPImageManagerIconHandle & | GetIcon (XTPImageState imageState)
Retrieves the icon handle.
CXTPImageManagerIconHandle & GetFadedIcon ()
Retrieves the faded icon.
CXTPImageManagerIconHandle & GetShadowIcon ()
Retrieves the shadow for the icon.
CXTPImageManagerIconHandle & GetCheckedIcon ()
Retrieves the checked icon.
CXTPImageManagerIconHandle & GetPressedIcon ()
Retrieves the pressed icon.
CXTPImageManagerIconHandle & GetHotIcon ()
Retrieves hot icon.
CXTPImageManagerIconHandle & | GetDisabledIcon (BOOL bCreateIfNotExists=TRUE)
Retrieves the disabled icon.
BOOL | HasIcon (XTPImageState imageState) const
Determines if a state specific icon exists.
BOOL | HasNormalIcon () const
Determines if a state specific icon exists.
BOOL | HasDisabledIcon () const
Determines if a state specific icon exists.
BOOL | HasCheckedIcon () const
Determines if a state specific icon exists.
BOOL | HasPressedIcon () const
Determines if a state specific icon exists.
BOOL | HasHotIcon () const
Determines if a state specific icon exists.
void | CreateDisabledIcon (COLORREF clrDisabledLight=(COLORREF) -1, COLORREF clrDisabledDark=(COLORREF) -1)
Creates a disabled icon.
BOOL | SetIcon (const CXTPImageManagerIconHandle &hIcon)
Sets the icon.
BOOL | SetIcon (const CXTPImageManagerIconHandle &hIcon, XTPImageState imageState)
Sets the icon.
BOOL | SetIcon (UINT nIDResourceIcon, int nWidth, int nHeight, XTPIconSizeMatching nSizeMatching=xtpIconSizeExact)
Sets the icon.
void | SetDisabledIcon (const CXTPImageManagerIconHandle &hIcon)
Sets the disabled icon.
void | SetHotIcon (const CXTPImageManagerIconHandle &hIcon)
Sets the hot icon.
void | SetCheckedIcon (const CXTPImageManagerIconHandle &hIcon)
Sets the checked icon.
void | SetNormalIcon (const CXTPImageManagerIconHandle &hIcon)
Sets the icon.
void | SetPressedIcon (const CXTPImageManagerIconHandle &hIcon)
Sets the pressed icon.
CSize | GetExtent () const
Retrieves the size of the icon.
CSize | GetRecommendedExtent () const
Retrieves the recommended size of the icon.
int | GetHeight () const
Retrieves the icon height.
int | GetWidth () const
Retrieves the icon width.
void | Serialize (CArchive &ar)
Either reads this object from or writes this object to an archive.
void | Copy (CXTPImageManagerIcon *pIcon)
Makes the current icon a copy of a provided icon.
void | SerializeIcon (CXTPImageManagerIconHandle &hIcon, CArchive &ar, long nSchema)
Either reads this object from or writes this object to an archive.
void | SerializeIcon (CXTPImageManagerVectorImageHandle &hIcon, CArchive &ar, long nSchema)
Either reads this object from or writes this object to an archive.
void | Draw (CDC *pDC, CPoint pt)
Draws the image at a specified location.
void | Draw (CDC *pDC, CPoint pt, CSize szIcon)
Draws the image at a specified location.
void | Draw (CDC *pDC, CPoint pt, XTPImageState imageState)
Draws the image at a specified location.
void | Draw (CDC *pDC, CPoint pt, XTPImageState imageState, CSize szIcon)
Draws the image at a specified location.
void | Draw (CDC *pDC, CPoint pt, CXTPImageManagerIconHandle &hIcon, CSize szIcon=0, COLORREF clrBK=CLR_NONE, COLORREF clrFG=CLR_NONE, UINT uiFlags=0)
Draws the image at a specified location.
void | Draw (CDC *pDC, CPoint pt, CXTPImageManagerVectorImageHandle hIcon, CSize szIcon=0)
Draws the image at a specified location.
BOOL | IsDirectDrawSupported (XTPImageState imageState=xtpImageNormal) const
Determines if the encapsulated vector image supports drawing its bits directly into a memory buffer.
SIZE_T | DirectDraw (PVOID pBits, SIZE_T cbSize, CPoint pt, CSize szIcon)
Draw vector image bits directly into the specified memoby buffer.
SIZE_T | DirectDraw (PVOID pBits, SIZE_T cbSize, CPoint pt, XTPImageState imageState, CSize szIcon)
Draw vector image bits directly into the specified memoby buffer.
SIZE_T | DirectDraw (PVOID pBits, SIZE_T cbSize, CPoint pt, CXTPImageManagerVectorImageHandle hIcon, CSize szIcon=0)
Draw vector image bits directly into the specified memoby buffer.
void | DrawMono (CDC *pDC, CPoint pt, CXTPImageManagerIconHandle &hIcon, CSize szIcon, COLORREF clrBrush)
Draws the image using the brush specified by the clrBrush parameter.
void | Refresh ()
Redraws Fade and Shadow icons.
CXTPMarkupContext * CreateMarkupContext ()
Creates a markup context if it is necessary for the icon and has not already been created.
CXTPMarkupContext * GetMarkupContext ()
Retrieves the markup context for the icon.
BOOL | SetVectorIcon (CXTPImageManagerVectorImageHandle hIcon)
Sets the icon for a specified state.
BOOL | SetVectorIcon (CXTPImageManagerVectorImageHandle hIcon, XTPImageState imageState)
Sets the icon for a specified state.
BOOL | SetVectorDisabledIcon (CXTPImageManagerVectorImageHandle hIcon)
Sets the icon for a specified state.
BOOL | SetVectorHotIcon (CXTPImageManagerVectorImageHandle hIcon)
Sets the icon for a specified state.
BOOL | SetVectorCheckedIcon (CXTPImageManagerVectorImageHandle hIcon)
Sets the icon for a specified state.
BOOL | SetVectorPressedIcon (CXTPImageManagerVectorImageHandle hIcon)
Sets the icon for a specified state.
CXTPImageManagerVectorImageHandle | GetVectorIcon () const
Obtains the vector icon handle for a specified state.
CXTPImageManagerVectorImageHandle | GetVectorIcon (XTPImageState imageState) const
Obtains the vector icon handle for a specified state.
CXTPImageManagerVectorImageHandle | GetVectorCheckedIcon () const
Obtains the vector icon handle for a specified state.
CXTPImageManagerVectorImageHandle | GetVectorPressedIcon () const
Obtains the vector icon handle for a specified state.
CXTPImageManagerVectorImageHandle | GetVectorHotIcon () const
Obtains the vector icon handle for a specified state.
CXTPImageManagerVectorImageHandle | GetVectorDisabledIcon () const
Obtains the vector icon handle for a specified state.
BOOL | IsRasterIcon () const
Checks if the current icon is a raster icon.
BOOL | IsVectorIcon () const
Checks if the current icon is a vector icon.
BOOL | IsUndefinedIcon () const
Checks if the current icon has an underfined type, i.e.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Static Public Member Functions

static CSize AFX_CDECL | GetExtent (HICON hIcon)
Retrieves the size of the icon.
static BOOL AFX_CDECL | IsAlphaBitmapFile (LPCTSTR pszFileName)
This method tests if the file is an alpha bitmap.
static BOOL AFX_CDECL | IsPngBitmapFile (LPCTSTR pszFileName)
This method tests if the file is a .png image.
static HBITMAP AFX_CDECL | LoadAlphaIcon (LPCTSTR pszFileName, int nWidth)
This method loads an alpha bitmap from an icon file.
static HBITMAP AFX_CDECL | LoadAlphaBitmap (UINT nIDResource)
This method loads an alpha bitmap from a resource file.
static HBITMAP AFX_CDECL | LoadAlphaBitmap (HMODULE hModule, LPCTSTR lpszResource)
This method loads an alpha bitmap from a resource file.
static HBITMAP AFX_CDECL | LoadBitmapFromFile (LPCTSTR lpszFileName, BOOL *lbAlphaBitmap=NULL)
This method loads a bitmap or .png from a file on disk.
static HBITMAP AFX_CDECL | LoadBitmapFromResource (LPCTSTR lpszResource, BOOL *lbAlphaBitmap)
This method loads an alpha bitmap or .png from a resource file.
static HBITMAP AFX_CDECL | LoadBitmapFromResource (HMODULE hModule, LPCTSTR lpszResource, BOOL *lbAlphaBitmap)
This method loads an alpha bitmap or .png from a resource file.
static BOOL AFX_CDECL | IsAlphaBitmapResource (HMODULE hModule, LPCTSTR lpBitmapName)
Checks if a bitmap with a specified resource has alpha channel.
static BOOL AFX_CDECL | IsPngBitmapResource (HMODULE hModule, LPCTSTR lpBitmapName)
Checks if a bitmap with a specified resource is a .png resource.
static void AFX_CDECL | DrawAlphaBitmap (CDC *pDC, HBITMAP hBitmap, CPoint ptDest, CSize szDest, CPoint ptSrc=0, CSize szSrc=0)
The DrawAlphaBitmap function displays bitmaps that have transparent or semitransparent pixels.
static HBITMAP AFX_CDECL | PreMultiplyAlphaBitmap (HBITMAP hBitmap, BOOL *pbAlpha=NULL, LPBYTE *lpBits=NULL)
Creates valid alpha bits to use in AlphaBlend.
static HBITMAP AFX_CDECL | InvertAlphaBitmap (HBITMAP hBitmap)
This method is called to create a mirror copy of a bitmap.
static BOOL AFX_CDECL | GetBitmapBits (CDC &dcSrc, HBITMAP hBitmap, PBITMAPINFO &pbmi, LPVOID &pBits, UINT &nSize)
This helper method retrieves information about an alpha bitmap and its alpha bits.
static HBITMAP AFX_CDECL | CopyAlphaBitmap (HBITMAP hBitmap, LPBYTE *lpBits=NULL)
Copies an alpha bitmap.
static BOOL AFX_CDECL | IsAlphaIconHandle (HICON hIcon)
Determines whether the provided icon is translucent or not.
static HICON AFX_CDECL | ScaleToFit (HICON hIcon, CSize szExtent, int nWidth)
Use this method to scale an icon.
static void AFX_CDECL | DrawIconComposited (CDC *pDC, CPoint pt, CSize szIcon, HICON hIcon)
Call this method to draw a non-alpha icon in a composited Vista Glass rectangle.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Public Attributes

BOOL m_bDrawComposited
Draw on Vista composited rects.

Detailed Description

Icons holder class.

Constructor & Destructor Documentation

◆ CXTPImageManagerIcon() [1/3]

CXTPImageManagerIcon | ( | UINT | nID,
 |  | int | nWidth,
 |  | int | nHeight,
 |  | CXTPImageManagerIconSet * | pIconSet = NULL )

Constructs a CXTPImageManagerIcon object.

Parameters
nID | Icon identifier.
nWidth | Initial width for the icon.
nHeight | Initial height for the icon.
pIconSet | Parent icon set icon will belong.

◆ CXTPImageManagerIcon() [2/3]

CXTPImageManagerIcon | ( | UINT | nID,
 |  | int | nWidth,
 |  | int | nHeight,
 |  | CXTPImageManagerImageList * | pImageList )

Constructs a CXTPImageManagerIcon object.

Parameters
nID | Icon identifier.
nWidth | Initial width for the icon.
nHeight | Initial height for the icon.
pImageList | Parent icon set icon will belong.

◆ CXTPImageManagerIcon() [3/3]

CXTPImageManagerIcon | ( | UINT | nID,
 |  | CXTPImageManagerIconSet * | pIconSet = NULL,
 |  | CSize | szRecommendedExtent = CSize(0) )

Constructs a CXTPImageManagerIcon object.

Parameters
nID | Icon identifier.
pIconSet | Parent icon set icon will belong.
szRecommendedExtent | Recommended icon size that suits the icon best. A zero value size component assumes no recommended value.

Member Function Documentation

◆ Copy()

void Copy ( CXTPImageManagerIcon * pIcon )

Makes the current icon a copy of a provided icon.

Parameters
pIcon An icon pointer to copy from.

◆ CopyAlphaBitmap()

static HBITMAP AFX_CDECL CopyAlphaBitmap | ( | HBITMAP | hBitmap,
 |  | LPBYTE * | lpBits = NULL )
 static

Copies an alpha bitmap.

Parameters
hBitmap | Bitmap handler to be copied.
lpBits | Points to a BYTE structure, defaults.to NULL.
Returns
New alpha bitmap handler.

◆ CreateDisabledIcon()

void CreateDisabledIcon | ( | COLORREF | clrDisabledLight = (COLORREF) -1,
 |  | COLORREF | clrDisabledDark = (COLORREF) -1 )

Creates a disabled icon.

Parameters
clrDisabledLight | The lightest color of icon to generate.
clrDisabledDark | The darkest color of icon to generate.

◆ CreateMarkupContext()

CXTPMarkupContext * CreateMarkupContext ( )

Creates a markup context if it is necessary for the icon and has not already been created.

Returns
A pointer to the created or existing markup context, or NULL if such a context is not required for the icon type.

◆ DirectDraw() [1/3]

SIZE_T DirectDraw | ( | PVOID | pBits,
 |  | SIZE_T | cbSize,
 |  | CPoint | pt,
 |  | CSize | szIcon )

Draw vector image bits directly into the specified memoby buffer.

Parameters
pBits | Memory buffer pointer that is at least of szIcon.cx * szIcon.cy * 4 bytes length.
cbSize | Memory buffer size in bytes.
pt | Top left output image coordinates.
szIcon | The output icon size.
Returns
The number of bytes written to the specified memory buffer or 0 if no image data has been drawn.

By default the icon associated with xtpImageNormal image state is assumed. Image data consists of Width * Height DWORD color entries where each DWORD color entry has the following color format: AlphaMask = 0xff000000, RedMask = 0x00ff0000, GreenMask = 0x0000ff00, BlueMask = 0x000000ff.

See also
IsDirectDrawSupported

◆ DirectDraw() [2/3]

SIZE_T DirectDraw | ( | PVOID | pBits,
 |  | SIZE_T | cbSize,
 |  | CPoint | pt,
 |  | CXTPImageManagerVectorImageHandle | hIcon,
 |  | CSize | szIcon = 0 )

Draw vector image bits directly into the specified memoby buffer.

Parameters
pBits | Memory buffer pointer that is at least of szIcon.cx * szIcon.cy * 4 bytes length.
cbSize | Memory buffer size in bytes.
pt | Top left output image coordinates.
szIcon | The output icon size.
hIcon | The handle of a vector icon to draw.
Returns
The number of bytes written to the specified memory buffer or 0 if no image data has been drawn.

By default the icon associated with xtpImageNormal image state is assumed. Image data consists of Width * Height DWORD color entries where each DWORD color entry has the following color format: AlphaMask = 0xff000000, RedMask = 0x00ff0000, GreenMask = 0x0000ff00, BlueMask = 0x000000ff.

See also
IsDirectDrawSupported

◆ DirectDraw() [3/3]

SIZE_T DirectDraw | ( | PVOID | pBits,
 |  | SIZE_T | cbSize,
 |  | CPoint | pt,
 |  | XTPImageState | imageState,
 |  | CSize | szIcon )

Draw vector image bits directly into the specified memoby buffer.

Parameters
pBits | Memory buffer pointer that is at least of szIcon.cx * szIcon.cy * 4 bytes length.
cbSize | Memory buffer size in bytes.
pt | Top left output image coordinates.
imageState | The specific image identified to otain the icon for.
szIcon | The output icon size.
Returns
The number of bytes written to the specified memory buffer or 0 if no image data has been drawn.

By default the icon associated with xtpImageNormal image state is assumed. Image data consists of Width * Height DWORD color entries where each DWORD color entry has the following color format: AlphaMask = 0xff000000, RedMask = 0x00ff0000, GreenMask = 0x0000ff00, BlueMask = 0x000000ff.

See also
IsDirectDrawSupported

◆ Draw() [1/6]

void Draw | ( | CDC * | pDC,
 |  | CPoint | pt )

Draws the image at a specified location.

Parameters
pDC | Destination device context.
pt | Specifies the location of the image.

◆ Draw() [2/6]

void Draw | ( | CDC * | pDC,
 |  | CPoint | pt,
 |  | CSize | szIcon )

Draws the image at a specified location.

Parameters
pDC | Destination device context.
pt | Specifies the location of the image.
szIcon | Specifies the size of the image.

◆ Draw() [3/6]

void Draw | ( | CDC * | pDC,
 |  | CPoint | pt,
 |  | CXTPImageManagerIconHandle & | hIcon,
 |  | CSize | szIcon = 0,
 |  | COLORREF | clrBK = CLR_NONE,
 |  | COLORREF | clrFG = CLR_NONE,
 |  | UINT | uiFlags = 0 )

Draws the image at a specified location.

Parameters
pDC | Destination device context.
pt | Specifies the location of the image.
hIcon | A handle to an icon.
szIcon | Specifies the size of the image.
clrBK | Background color of the image.
clrFG | Foreground color of the image.
uiFlags | Drawing style and, optionally, the overlay image.

◆ Draw() [4/6]

void Draw | ( | CDC * | pDC,
 |  | CPoint | pt,
 |  | CXTPImageManagerVectorImageHandle | hIcon,
 |  | CSize | szIcon = 0 )

Draws the image at a specified location.

Parameters
pDC | Destination device context.
pt | Specifies the location of the image.
hIcon | A handle to an icon.
szIcon | Specifies the size of the image.

◆ Draw() [5/6]

void Draw | ( | CDC * | pDC,
 |  | CPoint | pt,
 |  | XTPImageState | imageState )

Draws the image at a specified location.

Parameters
pDC | Destination device context.
pt | Specifies the location of the image.
imageState | State specific image to draw.

◆ Draw() [6/6]

void Draw | ( | CDC * | pDC,
 |  | CPoint | pt,
 |  | XTPImageState | imageState,
 |  | CSize | szIcon )

Draws the image at a specified location.

Parameters
pDC | Destination device context.
pt | Specifies the location of the image.
imageState | State specific image to draw.
szIcon | Specifies the size of the image.

◆ DrawAlphaBitmap()

static void AFX_CDECL DrawAlphaBitmap | ( | CDC * | pDC,
 |  | HBITMAP | hBitmap,
 |  | CPoint | ptDest,
 |  | CSize | szDest,
 |  | CPoint | ptSrc = 0,
 |  | CSize | szSrc = 0 )
 static

The DrawAlphaBitmap function displays bitmaps that have transparent or semitransparent pixels.

Parameters
pDC | Pointer to destination device context.
ptDest | Upper-left corner of the destination rectangle.
ptSrc | Upper-left corner of the source rectangle.
hBitmap | Alpha bitmap handler.
szDest | Destination size.
szSrc | Source size.
Returns

◆ DrawIconComposited()

static void AFX_CDECL DrawIconComposited | ( | CDC * | pDC,
 |  | CPoint | pt,
 |  | CSize | szIcon,
 |  | HICON | hIcon )
 static

Call this method to draw a non-alpha icon in a composited Vista Glass rectangle.

Parameters
pDC | Pointer to device context.
pt | Pointer to draw icon.
szIcon | Size of the icon.
hIcon | Icon handle to draw.
Returns

◆ DrawMono()

void DrawMono | ( | CDC * | pDC,
 |  | CPoint | pt,
 |  | CXTPImageManagerIconHandle & | hIcon,
 |  | CSize | szIcon,
 |  | COLORREF | clrBrush )

Draws the image using the brush specified by the clrBrush parameter.

Parameters
pDC | Destination device context.
pt | Specifies the location of the image.
hIcon | A handle to an icon.
szIcon | The output icon size.
clrBrush | Color of the brush used to draw the image.

◆ GetBitmapBits()

static BOOL AFX_CDECL GetBitmapBits | ( | CDC & | dcSrc,
 |  | HBITMAP | hBitmap,
 |  | PBITMAPINFO & | pbmi,
 |  | LPVOID & | pBits,
 |  | UINT & | nSize )
 static

This helper method retrieves information about an alpha bitmap and its alpha bits.

Parameters
dcSrc | Reference to CDC.
hBitmap | Alpha bitmap.
pbmi | Bitmap information.
pBits | Bitmap bits.
nSize | Size of bits array.
Returns
TRUE if successful, otherwise FALSE.

◆ GetCheckedIcon()

CXTPImageManagerIconHandle & GetCheckedIcon ( )

Retrieves the checked icon.

Returns
Icon handle.

◆ GetDisabledIcon()

CXTPImageManagerIconHandle & GetDisabledIcon ( BOOL bCreateIfNotExists = TRUE )

Retrieves the disabled icon.

Parameters
bCreateIfNotExists TRUE to create the disabled icon if the image does not exist. By default, this parameter is TRUE.
Returns
Icon handle.

◆ GetExtent() [1/2]

CSize GetExtent ( ) const

Retrieves the size of the icon.

Returns
Size of the icon.
See also
GetRecommendedExtent

◆ GetExtent() [2/2]

static CSize AFX_CDECL GetExtent ( HICON hIcon )
static

Retrieves the size of the icon.

Parameters
hIcon Icon handle.
Returns
Size of the icon.
See also
GetRecommendedExtent

◆ GetFadedIcon()

CXTPImageManagerIconHandle & GetFadedIcon ( )

Retrieves the faded icon.

Returns
Icon handle.

◆ GetHeight()

int GetHeight ( ) const

Retrieves the icon height.

Returns
Height of the icon.

◆ GetHotIcon()

CXTPImageManagerIconHandle & GetHotIcon ( )

Retrieves hot icon.

Returns
Icon handle.

◆ GetIcon() [1/2]

CXTPImageManagerIconHandle & GetIcon ( )

Retrieves the icon handle.

Returns
Icon handle.
See also
XTPImageState

◆ GetIcon() [2/2]

CXTPImageManagerIconHandle & GetIcon ( XTPImageState imageState )

Retrieves the icon handle.

Parameters
imageState Image state for the icon to retrieve.
Returns
Icon handle.
See also
XTPImageState

◆ GetID()

UINT GetID ( ) const

Retrieves the image identifier.

Returns
Identifier of the image.

◆ GetImageList() [1/2]

CXTPImageManagerImageList * GetImageList ( )

Obtains a pointer to an associated image list if the icon object is an icon in an image list.

If the returned pointer is not NULL, then the icon ID should be used as an icon index in the returned image list.

Returns
Pointer value to an associated image list, or NULL.

◆ GetImageList() [2/2]

const CXTPImageManagerImageList * GetImageList ( ) const

Obtains a pointer to an associated image list if the icon object is an icon in an image list.

If the returned pointer is not NULL, then the icon ID should be used as an icon index in the returned image list.

Returns
Pointer value to an associated image list, or NULL.

◆ GetMarkupContext()

CXTPMarkupContext * GetMarkupContext ( )

Retrieves the markup context for the icon.

Returns
The markup context for the icon.

◆ GetPressedIcon()

CXTPImageManagerIconHandle & GetPressedIcon ( )

Retrieves the pressed icon.

Returns
Icon handle.

◆ GetRecommendedExtent()

CSize GetRecommendedExtent ( ) const

Retrieves the recommended size of the icon.

It is an optional size and may not be specified by default. Usually it's the size that the icon was added to its icon manager with. For raster icons its value almost always equals to GetExtent returned value. But for vector icons that have no extent it will be the size that it was added to the collection.

Returns
The recommended size of the icon.
See also
GetExtent

◆ GetShadowIcon()

CXTPImageManagerIconHandle & GetShadowIcon ( )

Retrieves the shadow for the icon.

Returns
Icon handle.

◆ GetVectorCheckedIcon()

CXTPImageManagerVectorImageHandle GetVectorCheckedIcon ( ) const

Obtains the vector icon handle for a specified state.

Returns
State specific icon handle.

◆ GetVectorDisabledIcon()

CXTPImageManagerVectorImageHandle GetVectorDisabledIcon ( ) const

Obtains the vector icon handle for a specified state.

Returns
State specific icon handle.

◆ GetVectorHotIcon()

CXTPImageManagerVectorImageHandle GetVectorHotIcon ( ) const

Obtains the vector icon handle for a specified state.

Returns
State specific icon handle.

◆ GetVectorIcon() [1/2]

CXTPImageManagerVectorImageHandle GetVectorIcon ( ) const

Obtains the vector icon handle for a specified state.

Returns
State specific icon handle.

◆ GetVectorIcon() [2/2]

CXTPImageManagerVectorImageHandle GetVectorIcon ( XTPImageState imageState ) const

Obtains the vector icon handle for a specified state.

Parameters
imageState Image state identifier to obtain the icon for.
Returns
State specific icon handle.

◆ GetVectorPressedIcon()

CXTPImageManagerVectorImageHandle GetVectorPressedIcon ( ) const

Obtains the vector icon handle for a specified state.

Returns
State specific icon handle.

◆ GetWidth()

int GetWidth ( ) const

Retrieves the icon width.

Returns
Width of the icon.

◆ HasCheckedIcon()

BOOL HasCheckedIcon ( ) const

Determines if a state specific icon exists.

Returns
TRUE if the state specific icon exists.

◆ HasDisabledIcon()

BOOL HasDisabledIcon ( ) const

Determines if a state specific icon exists.

Returns
TRUE if the state specific icon exists.

◆ HasHotIcon()

BOOL HasHotIcon ( ) const

Determines if a state specific icon exists.

Returns
TRUE if the state specific icon exists.

◆ HasIcon()

BOOL HasIcon ( XTPImageState imageState ) const

Determines if a state specific icon exists.

Parameters
imageState Image state for which to check icon existence.
Returns
TRUE if the state specific icon exists.

◆ HasNormalIcon()

BOOL HasNormalIcon ( ) const

Determines if a state specific icon exists.

Returns
TRUE if the state specific icon exists.

◆ HasPressedIcon()

BOOL HasPressedIcon ( ) const

Determines if a state specific icon exists.

Returns
TRUE if the state specific icon exists.

◆ InvertAlphaBitmap()

static HBITMAP AFX_CDECL InvertAlphaBitmap ( HBITMAP hBitmap )
static

This method is called to create a mirror copy of a bitmap.

Parameters
hBitmap Bitmap handle to be copied.
Returns
New mirror bitmap

◆ IsAlpha()

BOOL IsAlpha ( ) const

Checks if the image has alpha channel.

Returns
TRUE if the image has alpha channel, otherwise FALSE.

◆ IsAlphaBitmapFile()

static BOOL AFX_CDECL IsAlphaBitmapFile ( LPCTSTR pszFileName )
static

This method tests if the file is an alpha bitmap.

Parameters
pszFileName File path.
Returns
TRUE if the file is an alpha bitmap.

◆ IsAlphaBitmapResource()

static BOOL AFX_CDECL IsAlphaBitmapResource | ( | HMODULE | hModule,
 |  | LPCTSTR | lpBitmapName )
 static

Checks if a bitmap with a specified resource has alpha channel.

Parameters
hModule | Module of the bitmap to check.
lpBitmapName | Resource name of the bitmap to check.
Returns
TRUE if the bitmap has alpha channel, otherwise FALSE.

◆ IsAlphaIconHandle()

static BOOL AFX_CDECL IsAlphaIconHandle ( HICON hIcon )
static

Determines whether the provided icon is translucent or not.

Parameters
hIcon Icon handle to check.
Returns
TRUE if the icon provided is translucent, otherwise FALSE.

◆ IsDirectDrawSupported()

BOOL IsDirectDrawSupported ( XTPImageState imageState = xtpImageNormal ) const

Determines if the encapsulated vector image supports drawing its bits directly into a memory buffer.

Parameters
imageState State specific image to draw.
Returns
TRUE if direct buffer drawing is supported.
See also
DirectDraw

◆ IsPngBitmapFile()

static BOOL AFX_CDECL IsPngBitmapFile ( LPCTSTR pszFileName )
static

This method tests if the file is a .png image.

Parameters
pszFileName File path.
Returns
TRUE if the file is a .png image.

◆ IsPngBitmapResource()

static BOOL AFX_CDECL IsPngBitmapResource | ( | HMODULE | hModule,
 |  | LPCTSTR | lpBitmapName )
 static

Checks if a bitmap with a specified resource is a .png resource.

Parameters
hModule | Module of the bitmap to check.
lpBitmapName | Resource name of the bitmap to check.
Returns
TRUE if the bitmap is a png resource, otherwise FALSE.

◆ IsRasterIcon()

BOOL IsRasterIcon ( ) const

Checks if the current icon is a raster icon.

Returns
TRUE if the current icon is a raster icon.

◆ IsScaled()

BOOL IsScaled ( ) const

Checks if icons were scaled from another CXTPImageManagerIcon object.

Returns
TRUE if icons were scaled from another CXTPImageManagerIcon object.

◆ IsUndefinedIcon()

BOOL IsUndefinedIcon ( ) const

Checks if the current icon has an underfined type, i.e.

no icon is associated with it.

Returns
TRUE if the current icon is an undefined icon.

◆ IsVectorIcon()

BOOL IsVectorIcon ( ) const

Checks if the current icon is a vector icon.

Returns
TRUE if the current icon is a vector icon.

◆ LoadAlphaBitmap() [1/2]

static HBITMAP AFX_CDECL LoadAlphaBitmap | ( | HMODULE | hModule,
 |  | LPCTSTR | lpszResource )
 static

This method loads an alpha bitmap from a resource file.

Parameters
hModule | Handle to the instance of the module whose executable file contains the bitmap to be loaded.
lpszResource | Long pointer to a null-terminated string that contains the name of the bitmap resource to be loaded.

Do not use LoadImage to load an alpha bitmap. It loses alpha channel in some Windows.

Returns
Alpha bitmap handler.

◆ LoadAlphaBitmap() [2/2]

static HBITMAP AFX_CDECL LoadAlphaBitmap ( UINT nIDResource )
static

This method loads an alpha bitmap from a resource file.

Parameters
nIDResource Resource identifier.

Do not use LoadImage to load an alpha bitmap. It loses alpha channel in some Windows.

Returns
Alpha bitmap handler.

◆ LoadAlphaIcon()

static HBITMAP AFX_CDECL LoadAlphaIcon | ( | LPCTSTR | pszFileName,
 |  | int | nWidth )
 static

This method loads an alpha bitmap from an icon file.

Parameters
pszFileName | File path.
nWidth | Icon width to load.
Returns
Alpha bitmap if an icon with the specified width was found, otherwise NULL.

◆ LoadBitmapFromFile()

static HBITMAP AFX_CDECL LoadBitmapFromFile | ( | LPCTSTR | lpszFileName,
 |  | BOOL * | lbAlphaBitmap = NULL )
 static

This method loads a bitmap or .png from a file on disk.

Parameters
lpszFileName | File name of a bitmap or .png file.
lbAlphaBitmap | Determines if a bitmap contains an alpha layer.
Returns
Bitmap handler.

◆ LoadBitmapFromResource() [1/2]

static HBITMAP AFX_CDECL LoadBitmapFromResource | ( | HMODULE | hModule,
 |  | LPCTSTR | lpszResource,
 |  | BOOL * | lbAlphaBitmap )
 static

This method loads an alpha bitmap or .png from a resource file.

Parameters
hModule | Handle to the instance of the module whose executable file contains the bitmap to be loaded.
lpszResource | Long pointer to a null-terminated string that contains the name of the bitmap resource to be loaded.
lbAlphaBitmap | Determines if a bitmap contains an alpha layer.
Returns
Alpha bitmap handler.

◆ LoadBitmapFromResource() [2/2]

static HBITMAP AFX_CDECL LoadBitmapFromResource | ( | LPCTSTR | lpszResource,
 |  | BOOL * | lbAlphaBitmap )
 static

This method loads an alpha bitmap or .png from a resource file.

Parameters
lpszResource | Long pointer to a null-terminated string that contains the name of the bitmap resource to be loaded.
lbAlphaBitmap | Determines if a bitmap contains an alpha layer.
Returns
Alpha bitmap handler.

◆ PreMultiplyAlphaBitmap()

static HBITMAP AFX_CDECL PreMultiplyAlphaBitmap | ( | HBITMAP | hBitmap,
 |  | BOOL * | pbAlpha = NULL,
 |  | LPBYTE * | lpBits = NULL )
 static

Creates valid alpha bits to use in AlphaBlend.

Parameters
hBitmap | Alpha bitmap handler.
pbAlpha | Reference to a BOOLEAN, TRUE for Alpha.
lpBits | Pointer to a BYTE structure.
Returns
Valid alpha bits.
See also
BLENDFUNCTION, AlphaBlend

◆ ScaleToFit()

static HICON AFX_CDECL ScaleToFit | ( | HICON | hIcon,
 |  | CSize | szExtent,
 |  | int | nWidth )
 static

Use this method to scale an icon.

Parameters
hIcon | Icon to be scaled.
szExtent | Source icon size.
nWidth | Width of the result icon.
Returns
A scaled icon handle.

◆ Serialize()

void Serialize ( CArchive & ar )

Either reads this object from or writes this object to an archive.

Parameters
ar A CArchive object to serialize to or from.

◆ SerializeIcon() [1/2]

void SerializeIcon | ( | CXTPImageManagerIconHandle & | hIcon,
 |  | CArchive & | ar,
 |  | long | nSchema )

Either reads this object from or writes this object to an archive.

Parameters
hIcon | Icon to be serialized.
ar | A CArchive object to serialize to or from.
nSchema | Schema data.

◆ SerializeIcon() [2/2]

void SerializeIcon | ( | CXTPImageManagerVectorImageHandle & | hIcon,
 |  | CArchive & | ar,
 |  | long | nSchema )

Either reads this object from or writes this object to an archive.

Parameters
hIcon | Icon to be serialized.
ar | A CArchive object to serialize to or from.
nSchema | Schema data.

◆ SetCheckedIcon()

void SetCheckedIcon ( const CXTPImageManagerIconHandle & hIcon )

Sets the checked icon.

Parameters
hIcon Icon handle to set.

◆ SetDisabledIcon()

void SetDisabledIcon ( const CXTPImageManagerIconHandle & hIcon )

Sets the disabled icon.

Parameters
hIcon Icon handle to set.

◆ SetHotIcon()

void SetHotIcon ( const CXTPImageManagerIconHandle & hIcon )

Sets the hot icon.

Parameters
hIcon Icon handle to set.

◆ SetIcon() [1/3]

BOOL SetIcon ( const CXTPImageManagerIconHandle & hIcon )

Sets the icon.

Parameters
hIcon Icon handle to set.
Returns
TRUE if successful, otherwise FALSE.

◆ SetIcon() [2/3]

BOOL SetIcon | ( | const CXTPImageManagerIconHandle & | hIcon,
 |  | XTPImageState | imageState )

Sets the icon.

Parameters
hIcon | Icon handle to set.
imageState | State of the icon.
Returns
TRUE if successful, otherwise FALSE.

◆ SetIcon() [3/3]

BOOL SetIcon | ( | UINT | nIDResourceIcon,
 |  | int | nWidth,
 |  | int | nHeight,
 |  | XTPIconSizeMatching | nSizeMatching = xtpIconSizeExact )

Sets the icon.

Parameters
nIDResourceIcon | Icon resource identifier.
nWidth | Width of the icon.
nHeight | Height of the icon.
nSizeMatching | Specifies how icon size is matched. By default, exact matching is specified. Used only if group icon resources.
Returns
TRUE if successful, otherwise FALSE.

◆ SetNormalIcon()

void SetNormalIcon ( const CXTPImageManagerIconHandle & hIcon )

Sets the icon.

Parameters
hIcon Icon handle to set.

◆ SetPressedIcon()

void SetPressedIcon ( const CXTPImageManagerIconHandle & hIcon )

Sets the pressed icon.

Parameters
hIcon Icon handle to set.

◆ SetVectorCheckedIcon()

BOOL SetVectorCheckedIcon ( CXTPImageManagerVectorImageHandle hIcon )

Sets the icon for a specified state.

Parameters
hIcon Icon handle to use for the specified state.
Returns
TRUE if the icon was successfully set.

◆ SetVectorDisabledIcon()

BOOL SetVectorDisabledIcon ( CXTPImageManagerVectorImageHandle hIcon )

Sets the icon for a specified state.

Parameters
hIcon Icon handle to use for the specified state.
Returns
TRUE if the icon was successfully set.

◆ SetVectorHotIcon()

BOOL SetVectorHotIcon ( CXTPImageManagerVectorImageHandle hIcon )

Sets the icon for a specified state.

Parameters
hIcon Icon handle to use for the specified state.
Returns
TRUE if the icon was successfully set.

◆ SetVectorIcon() [1/2]

BOOL SetVectorIcon ( CXTPImageManagerVectorImageHandle hIcon )

Sets the icon for a specified state.

Parameters
hIcon Icon handle to use for the specified state.
Returns
TRUE if the icon was successfully set.

◆ SetVectorIcon() [2/2]

BOOL SetVectorIcon | ( | CXTPImageManagerVectorImageHandle | hIcon,
 |  | XTPImageState | imageState )

Sets the icon for a specified state.

Parameters
hIcon | Icon handle to use for the specified state.
imageState | Image state identifier to set the icon for.
Returns
TRUE if the icon was successfully set.

◆ SetVectorPressedIcon()

BOOL SetVectorPressedIcon ( CXTPImageManagerVectorImageHandle hIcon )

Sets the icon for a specified state.

Parameters
hIcon Icon handle to use for the specified state.
Returns
TRUE if the icon was successfully set.
The documentation for this class was generated from the following file:
  • XTPImageManager.h


Toolkit Pro: CXTPImageManagerIconHandle Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPImageManagerIconHandle Class Reference

CXTPImageManagerIconHandle is a HICON wrapper class. More...

Public Member Functions

CXTPImageManagerIconHandle ()
Constructs a CXTPImageManagerIconHandle object.
CXTPImageManagerIconHandle (HICON hIcon, BOOL bUseResources=TRUE, BOOL bSharedHandle=TRUE)
Constructs a CXTPImageManagerIconHandle object.
CXTPImageManagerIconHandle (HBITMAP hBitmap, BOOL bSharedHandle=TRUE)
Constructs a CXTPImageManagerIconHandle object.
CXTPImageManagerIconHandle (const CXTPImageManagerIconHandle &hHandle)
Constructs a CXTPImageManagerIconHandle object.
~CXTPImageManagerIconHandle ()
Destroys a CXTPImageManagerIconHandle object, handles cleanup and deallocation.
operator HICON () const
This operator returns a HICON object whose value is copied from this CXTPImageManagerIconHandle object.
void | CopyHandle (HBITMAP hBitmap)
Copies data from an HBITMAP or CXTPImageManagerIconHandle object.
void | CopyHandle (const CXTPImageManagerIconHandle &handle)
Copies data from an HBITMAP or CXTPImageManagerIconHandle object.
BOOL | IsAlpha () const
Checks if the image has alpha channel.
BOOL | IsEmpty () const
Checks if the class has no icon.
HBITMAP | GetBitmap () const
Retrieves bitmap handle.
HICON | GetIcon () const
Retrieves the icon handle.
CSize | GetExtent () const
Retrieves the size of the icon.
void | Draw (CDC *pDC, CPoint pt, CSize szIcon, BOOL bDrawComposited=FALSE)
Call this method to draw icons.
HICON | GetDpiScaled (int nDpi=0) const
Obtains a new icon handle with the icon image scaled to the specified DPI.
void | Clear ()
Release bitmap and icon handlers.
BOOL | CreateIconFromResource (LPCTSTR lpszResourceName, CSize szIcon, BOOL bGroupResource=TRUE, XTPIconSizeMatching nSizeMatching=xtpIconSizeExact)
Creates an icon from resource bits describing the icon.
BOOL | CreateIconFromResource (HINSTANCE hInst, LPCTSTR lpszResourceName, CSize szIcon, BOOL bGroupResource, XTPIconSizeMatching nSizeMatching=xtpIconSizeExact)
Creates an icon from resource bits describing the icon.
void | Attach (HICON hIcon, BOOL bSharedHandle)
Attaches an object to an existing icon handle.
void | Attach (HBITMAP hBitmap, BOOL bSharedHandle)
Attaches an object to an existing bitmap handle.
LPBYTE | PreMultiply ()
Creates an alpha bitmap with a valid alpha layer.
void | Detach ()
Detaches the handle from the associated icon handle without releasing the resource.

Protected Member Functions

void Init ()
Initializes icons.

Protected Attributes

HICON | m_hIcon
The underlying HICON handler for this CXTPImageManagerIconHandle object.
HBITMAP | m_hBitmap
The underlying Alpha bitmap handler for this CXTPImageManagerIconHandle object.
LPBYTE | m_pBits
Alpha bitmap bits.
BOOL | m_bClearHandles
TRUE if object must destroy handlers.
CXTPImageManager * | m_pImageManager
Pointer to parent Image Manager.
XTP_IMAGERESOURCE_INFO * | m_pRInfo
Pointer to resource info if the icon is part of common resources.
CSize | m_szIcon
Size of the icon.
BOOL | m_bUseResources
TRUE to use common resources.

Detailed Description

CXTPImageManagerIconHandle is a HICON wrapper class.

Constructor & Destructor Documentation

◆ CXTPImageManagerIconHandle() [1/3]

CXTPImageManagerIconHandle | ( | HICON | hIcon,
 |  | BOOL | bUseResources = TRUE,
 |  | BOOL | bSharedHandle = TRUE )

Constructs a CXTPImageManagerIconHandle object.

Parameters
hIcon | Icon handle.
bUseResources | TRUE to use resources.
bSharedHandle | If FALSE, the resource will be destroyed when it is no longer in use.

◆ CXTPImageManagerIconHandle() [2/3]

CXTPImageManagerIconHandle | ( | HBITMAP | hBitmap,
 |  | BOOL | bSharedHandle = TRUE )

Constructs a CXTPImageManagerIconHandle object.

Parameters
hBitmap | Bitmap handle.
bSharedHandle | If FALSE, the resource will be destroyed when it is no longer in use.

◆ CXTPImageManagerIconHandle() [3/3]

CXTPImageManagerIconHandle ( const CXTPImageManagerIconHandle & hHandle )

Constructs a CXTPImageManagerIconHandle object.

Parameters
hHandle CXTPImageManagerIconHandle reference.

Member Function Documentation

◆ Attach() [1/2]

void Attach | ( | HBITMAP | hBitmap,
 |  | BOOL | bSharedHandle )

Attaches an object to an existing bitmap handle.

Parameters
hBitmap | Alpha bitmap handler.
bSharedHandle | If FALSE, the resource will be destroyed when it is no longer in use.

◆ Attach() [2/2]

void Attach | ( | HICON | hIcon,
 |  | BOOL | bSharedHandle )

Attaches an object to an existing icon handle.

Parameters
hIcon | Source icon handler.
bSharedHandle | If FALSE, the resource will be destroyed when it is no longer in use.

◆ CopyHandle() [1/2]

void CopyHandle ( const CXTPImageManagerIconHandle & handle )

Copies data from an HBITMAP or CXTPImageManagerIconHandle object.

Parameters
handle CXTPImageManagerIconHandle object.

◆ CopyHandle() [2/2]

void CopyHandle ( HBITMAP hBitmap )

Copies data from an HBITMAP or CXTPImageManagerIconHandle object.

Parameters
hBitmap Alpha bitmap handler.

◆ CreateIconFromResource() [1/2]

BOOL CreateIconFromResource | ( | HINSTANCE | hInst,
 |  | LPCTSTR | lpszResourceName,
 |  | CSize | szIcon,
 |  | BOOL | bGroupResource,
 |  | XTPIconSizeMatching | nSizeMatching = xtpIconSizeExact )

Creates an icon from resource bits describing the icon.

Parameters
hInst | Application instance handler.
lpszResourceName | Resource name identifier.
szIcon | Specifies the desired width and height, in pixels, of the icon.
bGroupResource | TRUE to check if the RT_GROUP_ICON resource exists.
nSizeMatching | Specifies how icon size is matched. By default, exact matching is specified. Used only if bGroupResource is TRUE.
Returns
TRUE if successful, otherwise FALSE.

◆ CreateIconFromResource() [2/2]

BOOL CreateIconFromResource | ( | LPCTSTR | lpszResourceName,
 |  | CSize | szIcon,
 |  | BOOL | bGroupResource = TRUE,
 |  | XTPIconSizeMatching | nSizeMatching = xtpIconSizeExact )

Creates an icon from resource bits describing the icon.

Parameters
lpszResourceName | Resource name identifier.
szIcon | Specifies the desired width and height, in pixels, of the icon.
bGroupResource | TRUE to check if the RT_GROUP_ICON resource exists.
nSizeMatching | Specifies how icon size is matched. By default, exact matching is specified. Used only if bGroupResource is TRUE.
Returns
TRUE if successful, otherwise FALSE.

◆ Draw()

void Draw | ( | CDC * | pDC,
 |  | CPoint | pt,
 |  | CSize | szIcon,
 |  | BOOL | bDrawComposited = FALSE )

Call this method to draw icons.

Parameters
pDC | Pointer to the device context to draw into.
pt | Positioning of the icon to draw.
szIcon | Size of the icon to draw.
bDrawComposited | TRUE to draw inside Vista Composited area.

◆ GetBitmap()

HBITMAP GetBitmap ( ) const

Retrieves bitmap handle.

Returns
32bit alpha bitmap.

◆ GetDpiScaled()

HICON GetDpiScaled ( int nDpi = 0 ) const

Obtains a new icon handle with the icon image scaled to the specified DPI.

Parameters
nDpi Custom DPI level or 0 for the current DPI value.
Returns
A new scaled icon handle. The caller is responsible for destroying the handle.

◆ GetExtent()

CSize GetExtent ( ) const

Retrieves the size of the icon.

Returns
Size of the icon.

◆ GetIcon()

HICON GetIcon ( ) const

Retrieves the icon handle.

Returns
Icon handle.

◆ IsAlpha()

BOOL IsAlpha ( ) const

Checks if the image has alpha channel.

Returns
TRUE if the image has alpha channel, otherwise FALSE.

◆ IsEmpty()

BOOL IsEmpty ( ) const

Checks if the class has no icon.

Returns
TRUE if the m_hIcon member is NULL.

◆ operator HICON()

operator HICON ( ) const

This operator returns a HICON object whose value is copied from this CXTPImageManagerIconHandle object.

Returns
HICON handle.

◆ PreMultiply()

LPBYTE PreMultiply ( )

Creates an alpha bitmap with a valid alpha layer.

Returns
TRUE if successful, otherwise FALSE.
The documentation for this class was generated from the following file:
  • XTPImageManager.h


Toolkit Pro: CXTPImageManagerIconSet Class Reference

Public Types | Public Member Functions | List of all members
CXTPImageManagerIconSet Class Reference

CXTPImageManagerIconSet represents the collection of icons for a specified identifier. More...

Inheritance diagram for CXTPImageManagerIconSet:
[legend]

Public Types

typedef CMap< UINT, UINT, CXTPImageManagerIcon *, CXTPImageManagerIcon * > CIconSetMap
Icons collection.

Public Member Functions

CXTPImageManagerIconSet (UINT nID, CXTPImageManager *pImageManager)
Constructs a CXTPImageManagerIconSet object.
~CXTPImageManagerIconSet ()
Destroys a CXTPImageManagerIconSet object, handles cleanup and deallocation.
CXTPImageManagerIcon * | GetIcon (UINT nWidth, BOOL bScaled=TRUE)
Call this member to get the icon with the specified width.
CIconSetMap * GetIcons ()
Retrieves the collection of icons.
UINT | GetID () const
Retrieves the identifier of the collection set.
void | RemoveAll ()
Removes all icons.
void | RefreshAll ()
Redraws all icons.
BOOL | SetVectorIcon (IStream *pStream, UINT nWidth)
Sets state dependent icon from various icon sources.
BOOL | SetVectorDisabledIcon (IStream *pStream, UINT nWidth)
Sets state dependent icon from various icon sources.
BOOL | SetVectorHotIcon (IStream *pStream, UINT nWidth)
Sets state dependent icon from various icon sources.
BOOL | SetVectorCheckedIcon (IStream *pStream, UINT nWidth)
Sets state dependent icon from various icon sources.
BOOL | SetVectorPressedIcon (IStream *pStream, UINT nWidth)
Sets state dependent icon from various icon sources.
BOOL | SetVectorIcon (CXTPImageManagerVectorImageHandle hIcon, UINT nWidth)
Sets state dependent icon from various icon sources.
BOOL | SetVectorDisabledIcon (CXTPImageManagerVectorImageHandle hIcon, UINT nWidth)
Sets state dependent icon from various icon sources.
BOOL | SetVectorHotIcon (CXTPImageManagerVectorImageHandle hIcon, UINT nWidth)
Sets state dependent icon from various icon sources.
BOOL | SetVectorCheckedIcon (CXTPImageManagerVectorImageHandle hIcon, UINT nWidth)
Sets state dependent icon from various icon sources.
BOOL | SetVectorPressedIcon (CXTPImageManagerVectorImageHandle hIcon, UINT nWidth)
Sets state dependent icon from various icon sources.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

CXTPImageManagerIconSet represents the collection of icons for a specified identifier.

Constructor & Destructor Documentation

◆ CXTPImageManagerIconSet()

CXTPImageManagerIconSet | ( | UINT | nID,
 |  | CXTPImageManager * | pImageManager )

Constructs a CXTPImageManagerIconSet object.

Parameters
nID | Icon set identifier.
pImageManager | Parent image manager to which CXTPImageManagerIconSet belongs.

Member Function Documentation

◆ GetIcon()

CXTPImageManagerIcon * GetIcon | ( | UINT | nWidth,
 |  | BOOL | bScaled = TRUE )

Call this member to get the icon with the specified width.

Parameters
nWidth | Width of the icon to retrieve.
bScaled | TRUE to scale the icon.
Returns
A pointer to a CXTPImageManagerIcon object.

◆ GetIcons()

CIconSetMap * GetIcons ( )

Retrieves the collection of icons.

Returns
A pointer to a CIconSetMap object.

◆ GetID()

UINT GetID ( ) const

Retrieves the identifier of the collection set.

Returns
Identifier of icons.

◆ SetVectorCheckedIcon() [1/2]

BOOL SetVectorCheckedIcon | ( | CXTPImageManagerVectorImageHandle | hIcon,
 |  | UINT | nWidth )

Sets state dependent icon from various icon sources.

Parameters
hIcon | Pre-loaded vector image handle.
nWidth | Preferred width of the icon.
Returns
TRUE if the vector icon image has been successfully added.

◆ SetVectorCheckedIcon() [2/2]

BOOL SetVectorCheckedIcon | ( | IStream * | pStream,
 |  | UINT | nWidth )

Sets state dependent icon from various icon sources.

Parameters
pStream | Vector icon data source.
nWidth | Preferred width of the icon.
Returns
TRUE if the vector icon image has been successfully added.

◆ SetVectorDisabledIcon() [1/2]

BOOL SetVectorDisabledIcon | ( | CXTPImageManagerVectorImageHandle | hIcon,
 |  | UINT | nWidth )

Sets state dependent icon from various icon sources.

Parameters
hIcon | Pre-loaded vector image handle.
nWidth | Preferred width of the icon.
Returns
TRUE if the vector icon image has been successfully added.

◆ SetVectorDisabledIcon() [2/2]

BOOL SetVectorDisabledIcon | ( | IStream * | pStream,
 |  | UINT | nWidth )

Sets state dependent icon from various icon sources.

Parameters
pStream | Vector icon data source.
nWidth | Preferred width of the icon.
Returns
TRUE if the vector icon image has been successfully added.

◆ SetVectorHotIcon() [1/2]

BOOL SetVectorHotIcon | ( | CXTPImageManagerVectorImageHandle | hIcon,
 |  | UINT | nWidth )

Sets state dependent icon from various icon sources.

Parameters
hIcon | Pre-loaded vector image handle.
nWidth | Preferred width of the icon.
Returns
TRUE if the vector icon image has been successfully added.

◆ SetVectorHotIcon() [2/2]

BOOL SetVectorHotIcon | ( | IStream * | pStream,
 |  | UINT | nWidth )

Sets state dependent icon from various icon sources.

Parameters
pStream | Vector icon data source.
nWidth | Preferred width of the icon.
Returns
TRUE if the vector icon image has been successfully added.

◆ SetVectorIcon() [1/2]

BOOL SetVectorIcon | ( | CXTPImageManagerVectorImageHandle | hIcon,
 |  | UINT | nWidth )

Sets state dependent icon from various icon sources.

Parameters
hIcon | Pre-loaded vector image handle.
nWidth | Preferred width of the icon.
Returns
TRUE if the vector icon image has been successfully added.

◆ SetVectorIcon() [2/2]

BOOL SetVectorIcon | ( | IStream * | pStream,
 |  | UINT | nWidth )

Sets state dependent icon from various icon sources.

Parameters
pStream | Vector icon data source.
nWidth | Preferred width of the icon.
Returns
TRUE if the vector icon image has been successfully added.

◆ SetVectorPressedIcon() [1/2]

BOOL SetVectorPressedIcon | ( | CXTPImageManagerVectorImageHandle | hIcon,
 |  | UINT | nWidth )

Sets state dependent icon from various icon sources.

Parameters
hIcon | Pre-loaded vector image handle.
nWidth | Preferred width of the icon.
Returns
TRUE if the vector icon image has been successfully added.

◆ SetVectorPressedIcon() [2/2]

BOOL SetVectorPressedIcon | ( | IStream * | pStream,
 |  | UINT | nWidth )

Sets state dependent icon from various icon sources.

Parameters
pStream | Vector icon data source.
nWidth | Preferred width of the icon.
Returns
TRUE if the vector icon image has been successfully added.
The documentation for this class was generated from the following file:
  • XTPImageManager.h


Toolkit Pro: CXTPImageManagerImageList Class Reference

Public Member Functions | List of all members
CXTPImageManagerImageList Class Reference

This class is used to connect ImageManager with specified HIMAGELIST. More...

Public Member Functions

CXTPImageManagerImageList ()
Constructs a CXTPImageManagerImageList class.
~CXTPImageManagerImageList ()
Destroys a CXTPImageManagerImageList object, handles cleanup and deallocation.
BOOL | Lookup (UINT nCommand)
Call this method to determine if ImageList handles a command with a specified command ID.
CXTPImageManagerIcon * | GetIcon (UINT nCommand)
Draws the icon for a command with a specified command ID.
void | Draw (CDC *pDC, CPoint pt, CXTPImageManagerIcon *pIcon, CSize szIcon, COLORREF clrBK=CLR_NONE, COLORREF clrFG=CLR_NONE, UINT uiFlags=0)
Call this method to draw a specified icon.
void | RemoveAll ()
Cleans all temporary icons.
CSize | GetIconSize () const
Retrieves the size of images inside HIMAGELIST.
HICON | GetIconHandle (UINT nCommand) const
Retrieves the icon handle for an image specified by a command ID.
HBITMAP | GetBitmapHandle (UINT nCommand) const
Retrieves the bitmap handle for an image specified by a command ID.

Detailed Description

This class is used to connect ImageManager with specified HIMAGELIST.

Member Function Documentation

◆ Draw()

void Draw | ( | CDC * | pDC,
 |  | CPoint | pt,
 |  | CXTPImageManagerIcon * | pIcon,
 |  | CSize | szIcon,
 |  | COLORREF | clrBK = CLR_NONE,
 |  | COLORREF | clrFG = CLR_NONE,
 |  | UINT | uiFlags = 0 )

Call this method to draw a specified icon.

Parameters
pDC | Device context to draw into.
pt | Position of the icon to draw.
pIcon | Pointer to the icon to draw.
szIcon | Size of the icon.
clrBK | Background color of the image.
clrFG | Foreground color of the image.
uiFlags | Drawing style and, optionally, the overlay image.

◆ GetBitmapHandle()

HBITMAP GetBitmapHandle ( UINT nCommand ) const

Retrieves the bitmap handle for an image specified by a command ID.

Parameters
nCommand Command ID.
Returns
Bitmap handle, or NULL.

◆ GetIcon()

CXTPImageManagerIcon * GetIcon ( UINT nCommand )

Draws the icon for a command with a specified command ID.

Parameters
nCommand Command ID.
Returns
A pointer to a CXTPImageManagerIcon object that can be used to draw the icon for the command with the specified command ID.

◆ GetIconHandle()

HICON GetIconHandle ( UINT nCommand ) const

Retrieves the icon handle for an image specified by a command ID.

Parameters
nCommand Command ID.
Returns
Icon handle, or NULL.

◆ GetIconSize()

CSize GetIconSize ( ) const

Retrieves the size of images inside HIMAGELIST.

Returns
The size of images inside HIMAGELIST.

◆ Lookup()

BOOL Lookup ( UINT nCommand )

Call this method to determine if ImageList handles a command with a specified command ID.

Parameters
nCommand Command ID to check.
Returns
TRUE if ImageList handles the command with the specified command ID.
The documentation for this class was generated from the following file:
  • XTPImageManager.h


Toolkit Pro: CXTPImageManagerResource Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPImageManagerResource Class Reference

Public Member Functions

CXTPImageManagerResource (CXTPImageManager *pImageManager, CSize szIcon)
Constructs a CXTPImageManagerResource object used to create common bitmap for all icons of image manager.
~CXTPImageManagerResource ()
Destroys a CXTPImageManagerResource object, handles cleanup and de- allocation.
XTP_IMAGERESOURCE_INFO * | Add (const CXTPImageManagerIconHandle &hHandle)
This method is called to add new icon to common bitmap fo resource manger.
void | Clear (XTP_IMAGERESOURCE_INFO *pRInfo)
Clears image in specified position.
void | Draw (CDC *pDC, XTP_IMAGERESOURCE_INFO *pRInfo, CPoint pt, CSize szIcon, BOOL bDrawComposited)
This method is called to draw image.
void | CreateIcon (CXTPImageManagerIconHandle &hHandle, XTP_IMAGERESOURCE_INFO *pRInfo)
Creates new icon from bitmap specified by pRInfo parameter.
CSize | GetExtent () const
Returns size of iconsmanaged by this Resource.

Protected Attributes

HBITMAP | m_hbmpImage
Handle of bitmap contained all images of the resources.
HBITMAP | m_hbmpMask
Handle of bitmap contained mask for images of the resources.
CXTPBitmapDC | m_dc
Helper device context class for quick image select.
BYTE * | m_pBits
Bits of m_hbmpImage.
CXTPImageManager * | m_pImageManager
Parent CXTPImageManager object.
CSize | m_szIcon
Size of images of the resources.
int | m_nAllocWidth
Total allocated with of the resources.
CArray< XTP_IMAGERESOURCE_INFO *, XTP_IMAGERESOURCE_INFO * > | m_arrIcons
List of used icons.
CArray< XTP_IMAGERESOURCE_INFO *, XTP_IMAGERESOURCE_INFO * > | m_arrAlloc
List of free icons.
CRITICAL_SECTION | m_cs
Critical section for multithreading support.

Detailed Description

Parameters
Standalone class used to manage Image resources.

Constructor & Destructor Documentation

◆ CXTPImageManagerResource()

CXTPImageManagerResource | ( | CXTPImageManager * | pImageManager,
 |  | CSize | szIcon )

Constructs a CXTPImageManagerResource object used to create common bitmap for all icons of image manager.

Parameters
pImageManager | : Pointer to Parent ImageManager class
szIcon | : Size of images that will be managed by this resource

Member Function Documentation

◆ Add()

XTP_IMAGERESOURCE_INFO * Add ( const CXTPImageManagerIconHandle & hHandle )

This method is called to add new icon to common bitmap fo resource manger.

Parameters
hHandle : Handle of image to add
Returns
Returns pointer to XTP_IMAGERESOURCE_INFO contained position and style of new icon.

◆ Clear()

void Clear ( XTP_IMAGERESOURCE_INFO * pRInfo )

Clears image in specified position.

Parameters
pRInfo : Posiotion of image to clear

◆ CreateIcon()

void CreateIcon | ( | CXTPImageManagerIconHandle & | hHandle,
 |  | XTP_IMAGERESOURCE_INFO * | pRInfo )

Creates new icon from bitmap specified by pRInfo parameter.

Parameters
hHandle | Handle of icon to be created
pRInfo | Posiotion of icon inside m_hbmpImage to create

◆ Draw()

void Draw | ( | CDC * | pDC,
 |  | XTP_IMAGERESOURCE_INFO * | pRInfo,
 |  | CPoint | pt,
 |  | CSize | szIcon,
 |  | BOOL | bDrawComposited )

This method is called to draw image.

Parameters
pDC | Pointer to a valid device context.
pRInfo | Pointer to XTP_IMAGERESOURCE_INFO
pt | Point to start drawing.
szIcon | Size of the icon.
bDrawComposited | BOOL flag of composite or not way of draw

◆ GetExtent()

CSize GetExtent ( ) const

Returns size of iconsmanaged by this Resource.

Returns
Size of images contained inside m_hbmpImage
The documentation for this class was generated from the following file:
  • XTPImageManagerResource.h


Toolkit Pro: CXTPImageManagerVectorImageHandle Class Reference

Public Member Functions | Static Public Member Functions | List of all members
CXTPImageManagerVectorImageHandle Class Reference

Represents a generic interface for a vector image of any possible format to be used with CXTPImageManager. More...

Public Member Functions

CXTPImageManagerVectorImageHandle ()
Construct an empty vector image handle object.
virtual | ~CXTPImageManagerVectorImageHandle ()
Handles object destruction, releases vector image resources.
CXTPImageManagerVectorImageHandle (const CXTPImageManagerVectorImageHandle &rhs)
Construct a copy of the vector image handle object.
CXTPImageManagerVectorImageHandle & | operator= (const CXTPImageManagerVectorImageHandle &rhs)
Make the current vector image handle identical to the provided image handle.
operator BOOL () const
Checks if the current vector image handle has a valid image associated with it.
BOOL | IsMarkupImage () const
Determines if the handle is associated with Markup image.
BOOL | IsSvgImage () const
Determines if the handle is associated with SVG image.
void | Draw (CDC *pDC, CPoint pt, CSize szIcon)
Draws the image associated with the handle.
BOOL | IsDirectDrawSupported () const
Determines if the encapsulated vector image supports drawing its bits directly into a memory buffer.
SIZE_T | DirectDraw (PVOID pBits, SIZE_T cbSize, CPoint pt, CSize szIcon)
Draws vector image bits directly into the specified memoby buffer.
HGLOBAL | GetSerializationData () const
Obtains a handle to image specific serialization data that can be used storing and re-storing an image from.
CXTPMarkupContext * GetMarkupContext ()
Retrieves the markup context for the icon.
IStream * | GetDataStream () const
Retrieves the data stream for the icon.

Static Public Member Functions

static CXTPImageManagerVectorImageHandle | CreateMarkupHandle (CXTPMarkupContext *pContext, BOOL bSharedContext, HGLOBAL SerializationData)
Creates a Markup image handle.
static CXTPImageManagerVectorImageHandle | CreateMarkupHandle (CXTPMarkupContext *pContext, BOOL bSharedContext, IStream *pStream)
Creates a Markup image handle.
static CXTPImageManagerVectorImageHandle | CreateMarkupHandle (CXTPMarkupContext *pContext, BOOL bSharedContext, LPCSTR lpszCode, INT_PTR nLength=-1)
Creates a Markup image handle.
static CXTPImageManagerVectorImageHandle | CreateMarkupHandle (CXTPMarkupContext *pContext, BOOL bSharedContext, LPCWSTR lpszCode, INT_PTR nLength=-1)
Creates a Markup image handle.
static CXTPImageManagerVectorImageHandle | CreateSvgHandle (HGLOBAL SerializationData)
Creates an SVG image handle.
static CXTPImageManagerVectorImageHandle | CreateSvgHandle (IStream *pStream)
Creates an SVG image handle.
static CXTPImageManagerVectorImageHandle | CreateSvgHandle (LPCSTR lpszCode, INT_PTR nLength=-1)
Creates an SVG image handle.

Detailed Description

Represents a generic interface for a vector image of any possible format to be used with CXTPImageManager.

Constructor & Destructor Documentation

◆ CXTPImageManagerVectorImageHandle()

CXTPImageManagerVectorImageHandle ( const CXTPImageManagerVectorImageHandle & rhs )

Construct a copy of the vector image handle object.

Parameters
rhs a source vector image handle.

Member Function Documentation

◆ CreateMarkupHandle() [1/4]

static CXTPImageManagerVectorImageHandle CreateMarkupHandle | ( | CXTPMarkupContext * | pContext,
 |  | BOOL | bSharedContext,
 |  | HGLOBAL | SerializationData )
 static

Creates a Markup image handle.

Parameters
pContext | User provided markup context pointer.
bSharedContext | If TRUE, the user provided markup context pointer is assumed to be shared, i.e. used and managed by the caller. FALSE gives the image handle exclusize rights to manage and release the context once it is no longer needed.
SerializationData | Markup image serialization data handle that must be allocated using GlobalAlloc(GMEM_MOVEABLE | GMEM_NODISCARD, ...).
Returns
Serialization data handle. The handle is managed by the object so the caller must not deallocate or change it.

◆ CreateMarkupHandle() [2/4]

static CXTPImageManagerVectorImageHandle CreateMarkupHandle | ( | CXTPMarkupContext * | pContext,
 |  | BOOL | bSharedContext,
 |  | IStream * | pStream )
 static

Creates a Markup image handle.

Parameters
pContext | User provided markup context pointer.
bSharedContext | If TRUE, the user provided markup context pointer is assumed to be shared, i.e. used and managed by the caller. FALSE gives the image handle exclusize rights to manage and release the context once it is no longer needed.
pStream | Markup image data stream pointer.
Returns
Serialization data handle. The handle is managed by the object so the caller must not deallocate or change it.

◆ CreateMarkupHandle() [3/4]

static CXTPImageManagerVectorImageHandle CreateMarkupHandle | ( | CXTPMarkupContext * | pContext,
 |  | BOOL | bSharedContext,
 |  | LPCSTR | lpszCode,
 |  | INT_PTR | nLength = -1 )
 static

Creates a Markup image handle.

Parameters
pContext | User provided markup context pointer.
bSharedContext | If TRUE, the user provided markup context pointer is assumed to be shared, i.e. used and managed by the caller. FALSE gives the image handle exclusize rights to manage and release the context once it is no longer needed.
lpszCode | Markup image code pointer.
nLength | Optional markup image code length in characters.
Returns
Serialization data handle. The handle is managed by the object so the caller must not deallocate or change it.

◆ CreateMarkupHandle() [4/4]

static CXTPImageManagerVectorImageHandle CreateMarkupHandle | ( | CXTPMarkupContext * | pContext,
 |  | BOOL | bSharedContext,
 |  | LPCWSTR | lpszCode,
 |  | INT_PTR | nLength = -1 )
 static

Creates a Markup image handle.

Parameters
pContext | User provided markup context pointer.
bSharedContext | If TRUE, the user provided markup context pointer is assumed to be shared, i.e. used and managed by the caller. FALSE gives the image handle exclusize rights to manage and release the context once it is no longer needed.
lpszCode | Markup image code pointer.
nLength | Optional markup image code length in characters.
Returns
Serialization data handle. The handle is managed by the object so the caller must not deallocate or change it.

◆ CreateSvgHandle() [1/3]

static CXTPImageManagerVectorImageHandle CreateSvgHandle ( HGLOBAL SerializationData )
static

Creates an SVG image handle.

Parameters
SerializationData SVG image serialization data handle that must be allocated using GlobalAlloc(GMEM_MOVEABLE | GMEM_NODISCARD, ...).
Returns
Serialization data handle. The handle is managed by the object so the caller must not deallocate or change it.

◆ CreateSvgHandle() [2/3]

static CXTPImageManagerVectorImageHandle CreateSvgHandle ( IStream * pStream )
static

Creates an SVG image handle.

Parameters
pStream SVG image data stream pointer.
Returns
Serialization data handle. The handle is managed by the object so the caller must not deallocate or change it.

◆ CreateSvgHandle() [3/3]

static CXTPImageManagerVectorImageHandle CreateSvgHandle | ( | LPCSTR | lpszCode,
 |  | INT_PTR | nLength = -1 )
 static

Creates an SVG image handle.

Parameters
lpszCode | SVG image code pointer.
nLength | Optional markup image code length in characters.
Returns
Serialization data handle. The handle is managed by the object so the caller must not deallocate or change it.

◆ DirectDraw()

SIZE_T DirectDraw | ( | PVOID | pBits,
 |  | SIZE_T | cbSize,
 |  | CPoint | pt,
 |  | CSize | szIcon )

Draws vector image bits directly into the specified memoby buffer.

Parameters
pBits | Memory buffer pointer that is at least of szIcon.cx * szIcon.cy * 4 bytes length.
cbSize | Memory buffer size in bytes.
pt | Top left output image coordinates.
szIcon | The output icon size.
Returns
The number of bytes written to the specified memory buffer or 0 if no image data has been drawn.

Image data consists of Width * Height DWORD color entries where each DWORD color entry has the following color format: AlphaMask = 0xff000000, RedMask = 0x00ff0000, GreenMask = 0x0000ff00, BlueMask = 0x000000ff.

See also
IsDirectDrawSupported

◆ Draw()

void Draw | ( | CDC * | pDC,
 |  | CPoint | pt,
 |  | CSize | szIcon )

Draws the image associated with the handle.

Parameters
pDC | Target device context pointer.
pt | Target top-left corner location.
szIcon | Target image size.

◆ GetDataStream()

AFX_INLINE IStream * GetDataStream ( ) const

Retrieves the data stream for the icon.

Returns
The data stream for the icon.

◆ GetMarkupContext()

AFX_INLINE CXTPMarkupContext * GetMarkupContext ( )

Retrieves the markup context for the icon.

Returns
The markup context for the icon.

◆ GetSerializationData()

HGLOBAL GetSerializationData ( ) const

Obtains a handle to image specific serialization data that can be used storing and re-storing an image from.

Returns
Serialization data handle. The handle is managed by the object so the caller must not deallocate or change it.

◆ IsDirectDrawSupported()

BOOL IsDirectDrawSupported ( ) const

Determines if the encapsulated vector image supports drawing its bits directly into a memory buffer.

Returns
TRUE if direct buffer drawing is supported.
See also
DirectDraw

◆ IsMarkupImage()

BOOL IsMarkupImage ( ) const

Determines if the handle is associated with Markup image.

Returns
TRUE if the handle is associated with Markup image.

◆ IsSvgImage()

BOOL IsSvgImage ( ) const

Determines if the handle is associated with SVG image.

Returns
TRUE if the handle is associated with SVG image.

◆ operator BOOL()

operator BOOL ( ) const

Checks if the current vector image handle has a valid image associated with it.

Returns
TRUE if the handle is a valid image.

◆ operator=()

CXTPImageManagerVectorImageHandle & operator= ( const CXTPImageManagerVectorImageHandle & rhs )

Make the current vector image handle identical to the provided image handle.

Parameters
rhs a source vector image handle.
Returns
Self reference.
The documentation for this class was generated from the following file:
  • XTPImageManager.h


Toolkit Pro: CXTPInternalCollectionT< _TObject > Class Template Reference

Public Types | Public Member Functions | List of all members
CXTPInternalCollectionT< _TObject > Class Template Reference

Public Types

typedef _TObject | TObject
Stored objects type definition.
typedef CXTPSmartPtrInternalT< _TObject > | TObjectPtr
Stored objects smart-pointer type definition.

Public Member Functions

CXTPInternalCollectionT ()
Default object constructor.
virtual | ~CXTPInternalCollectionT ()
Default object destructor.
virtual _TObject * | GetAt (int nIndex, BOOL bWithAddRef=TRUE)
Get one of stored objects by index.
virtual int | AddPtr (_TObject *pObj, BOOL bCallAddRef=FALSE)
Add object pointer to the array.

Detailed Description

template<class _TObject>
class CXTPInternalCollectionT< _TObject >

This internal class is used as collection for pointers of objects, derived from CCmdTarget or other class, which has InternalAddRef(), InternalRelease() methods. InternalAddRef() is called for stored object. InternalRelease() is called when object is removed. Also this collection object derived from IXTPInternalUnknown.

See also
CXTPSmartPtrInternalT, CXTPInternalUnknown

Member Function Documentation

◆ AddPtr()

template<class _TObject >
virtual int AddPtr | ( | _TObject * | pObj,
 |  | BOOL | bCallAddRef = FALSE )
 inlinevirtual

Add object pointer to the array.

Parameters
pObj | [in] Pointer to the storing object.
bCallAddRef | [in] If TRUE InternalAddRef() is called before adding pointer. It is TRUE by default.
Returns
Added object index.

This method add a new element to the collection and calls InternalAddRef() if specified.

See also
CArray::Add, IXTPInternalUnknown.

◆ GetAt()

template<class _TObject >
virtual _TObject * GetAt | ( | int | nIndex,
 |  | BOOL | bWithAddRef = TRUE )
 inlinevirtual

Get one of stored objects by index.

Parameters
nIndex | [in] Zero-based index of the stored object.
bWithAddRef | [in] If TRUE, InternalAddRef() will be called before returning the pointer. By default, this parameter is TRUE.
Returns
Pointer to one of stored objects by index.

This function gets pointer to one of stored objects by index and calls InternalAddRef() if specified.

See also
CArray::GetAt, IXTPInternalUnknown.
The documentation for this class was generated from the following file:
  • XTPSmartPtrInternalT.h


Toolkit Pro: CXTPItemEdit Class Reference

Public Member Functions | Public Attributes | Protected Attributes | List of all members
CXTPItemEdit Class Reference

CXTPItemEdit is a CXTPBrowseEdit derived class. More...

Inheritance diagram for CXTPItemEdit:
[legend]

Public Member Functions

CXTPItemEdit ()
Constructs a CXTPItemEdit object that can be used as an "in-place" edit field and can be dynamically created for controls such as a list box.
BOOL | Create (CWnd *pParent, const CRect &rect, CString &strWindowText, DWORD dwBStyle=BES_XTP_CHOOSEDIR, bool bAutoDelete=true)
Constructs a CXTPItemEdit object that can be used as an "in-place" edit field and can be dynamically created for controls such as a list box.
virtual | ~CXTPItemEdit ()
Destroys a CXTPItemEdit object, handles cleanup and deallocation.
virtual void | EndLabelEdit ()
This member function is called whenever the control loses focus.
- Public Member Functions inherited from CXTPBrowseEdit
CXTPBrowseEdit ()
Constructs a CXTPBrowseEdit object.
virtual | ~CXTPBrowseEdit ()
Destroys a CXTPBrowseEdit object, handles cleanup and deallocation.
bool | IsBrowsing ()
Call this member function to determine if the browse edit control is in the middle of a browse operation.
void | SetGap (int nGap)
Call this member function to set the gap between the browse button and the edit window.
virtual void | SetFileDialog (CFileDialog *pFileDialog)
This member function will set a CFileDialog derived class object to be the file open dialog.
virtual void | SetDlgOpenFile (BOOL bOpenFileDialog=TRUE)
This member function will set the File Open dialog style.
void | SetDlgDefExt (LPCTSTR lpszDefExt=NULL)
This member function sets the default extension for the File Open dialog.
void | SetDlgFileName (LPCTSTR lpszFileName=NULL)
This member function sets the default file name for the File Open dialog.
virtual void | SetDlgStyle (DWORD dwFlags=OFN_HIDEREADONLY|OFN_OVERWRITEPROMPT)
This member function sets the style flags for the File Open dialog.
void | SetDlgFilter (LPCTSTR lpszFilter=NULL)
This member function sets the file filter for the File Open dialog.
void | SetDlgTitle (LPCTSTR lpszTitle=NULL)
This member function sets the title for the directory dialog.
void | SetDlgInitialDir (LPCTSTR lpszInitialDir)
This member function sets the initial directory for the directory dialog.
virtual bool | Initialize (CWnd *pParentWnd, DWORD dwBStyle, UINT nMenu=0, int nSubMenuIndx=0)
This member function is called to initialize the browse edit control.
virtual bool | Initialize (CWnd *pParentWnd)
This member function is called to initialize the browse edit control.
virtual void | OnBrowse ()
This member function is called whenever the browse button is pressed and can be overridden to perform custom browse functions.
virtual void | ChooseDirectory ()
This member function is called by the browse edit control to display a directory chooser dialog.
virtual void | ChooseFile ()
This member function is called by the browse edit control to display a File Open dialog.
virtual void | PopupMenu ()
This member function is called by the browse edit control to create and track a pop-up menu.
virtual void | PositionBrowseButton ()
This member function is called by the browse edit control to position the browse button in relation to the edit control.
CXTPBrowseButton * GetBrowseButton ()
Call this member function to get a reference to the browse button.
- Public Member Functions inherited from CXTPEdit
CXTPEdit ()
Constructs a CXTPEdit object.
virtual | ~CXTPEdit ()
Destroys a CXTPEdit object, handles cleanup and deallocation.
BOOL | SetEditMask (LPCTSTR lpszMask, LPCTSTR lpszLiteral, LPCTSTR lpszDefault=NULL)
This member function will set the mask for the edit control.
void | SetPattern (LPCTSTR lpszPattern)
Call this member function to set the pattern for the edit mask.
virtual BOOL | CanPaste ()
Call this member function to determine if the Clipboard contains information that can be pasted into this edit view.
BOOL | HasSelection () const
Call this member function to determine if a selection has been made.
void | AdjustBuddyRect (CWnd *pBuddy, CRect &rcUpDown, int nAlignment)
Called by the framework to adjust the size of the area to draw the buddy control borders on.
void | DrawBuddyBorders (CWnd *pBuddy, CDC *pDC, CRect rc, int nAlignment)
Called by the framework to draw the borders for the associated buddy window.
virtual void | RefreshMetrics ()
This member is called to update the color, text and other visual elements of the control.
virtual void | SetTheme (XTPControlTheme nTheme)
Call this member to switch the visual theme of the control.
XTPControlTheme GetThemeID ()
Call this member function to get the style for the theme.
CXTPEditTheme * GetTheme ()
Call this member to retrieve a pointer to the current theme.
BOOL | GetFlatStyle () const
Gets the flat style appearance of the button control.
void | SetFlatStyle (BOOL bFlatStyle=TRUE)
Sets the flat style appearance of the button control.
BOOL | GetUseVisualStyle () const
Determines if the control is drawn using visual styles/SkinFramework, if supported.
void | SetUseVisualStyle (BOOL bUseVisualStyle=TRUE)
Enables Windows XP visual styles for the control.
BOOL | IsPatternValid ()
Called by the framework to determine if the pattern set using SetPattern() is valid.
void | ShowThemedBorder (BOOL bShowThemedBorder)
Call this member function to enable/disable theme border display.
BOOL | IsHighlighted () const
Call this member function to determine if the edit state is highlighted, meaning that the mouse cursor is currently hovering over the control.
BOOL | IsFocused () const
Call this member function to determine if the edit-box has input focus.
BOOL | IsFlatStyle () const
Gets the flat style appearance of the edit control.
BOOL | ShowBorder () const
Call this member to determine if non-client borders are displayed.
- Public Member Functions inherited from CXTPMaskEditT< CEdit >
CXTPMaskEditT ()
Constructs a CXTPMaskEditT object.
void | SetUseMask (BOOL bUseMask)
Call this member function to enable or disable the mask for the mask edit control.
BOOL | CanUseMask () const
This member function is called to determine if the mask for the edit control can be used.
void | SetOverType (BOOL bOverType)
This member function is called to enable or disable type over, also known as insert mode.
BOOL | CanOverType () const
This member function is called to determine if type over has been enabled.
BOOL | PosInRange (int iPos) const
This member function is called to determine if the index specified by 'iPos' is a valid index for the currently displayed edit text.
TCHAR | GetPromptChar () const
This member function retrieves the character that is currently used as the mask prompt.
CString | GetPromptString (int nLength) const
This helper member function retrieves the string contains nLength prompt characters.
void | SetPromptChar (TCHAR ch, BOOL bAutoReplace=TRUE)
This member function is called to set the prompt character that is displayed to the user that indicates the field can be edited.
afx_msg BOOL | MaskCut ()
This member function is called to perform a cut operation using the currently selected text.
afx_msg BOOL | MaskCopy ()
This member function is called to perform a copy operation using the currently selected text.
void | MaskReplaceSel (LPCTSTR lpszNewText)
This member function is called to perform a replace operation using the currently selected text.
afx_msg BOOL | MaskPaste ()
This member function is called to perform a paste operation using the current clipboard text.
void | MaskDeleteSel ()
This member function is called to delete the selection.
afx_msg BOOL | MaskClear ()
This member function is called to clear the current text selection.
afx_msg BOOL | MaskUndo ()
This member function is called to undo the previous action.
afx_msg void | MaskSelectAll ()
This member function is called to select all text in the mask edit control.
BOOL | IsModified () const
This member function is called to determine if the text has been modified.
void | SetMaskedText (LPCTSTR lpszMaskedText, int iPos=0, BOOL bUpdateWindow=TRUE)
This method called to set masked text for the edit control.
TCHAR | ConvertUnicodeAlpha (TCHAR nChar, BOOL bUpperCase) const
Converts character to Upper/Lower case.
virtual BOOL | CheckChar (TCHAR &nChar, int nPos)
This member function is used internally to validate the character indicated by 'nChar'.
virtual BOOL | ProcessMask (TCHAR &nChar, int nEndPos)
This member function is used internally to process the character passed in by 'nChar' whose index is specified by 'nEndPos'.
virtual BOOL | PreTranslateMessage (MSG *pMsg)
Used by class CWinApp to translate window messages before they are dispatched to theTranslateMessage andDispatchMessage Windows functions.
void | DeleteCharAt (int iPos)
Deletes character in specified position.
void | InsertCharAt (int iPos, TCHAR nChar)
Inserts character to specified position.
BOOL | CopyToClipboard (const CString &strText)
Copies text to system clipboard.
CString | GetMaskedText (int nStartPos=0, int nEndPos=-1) const
Retrieves masked text of the control.

Public Attributes

bool | m_bModified
true if the item was modified.
bool | m_bAutoDelete
true if self-deleting.
bool | m_bEscapeKey
true if the edit window was closed with the escape key.
CString | m_strWindowText
The edit controls text.

Protected Attributes

bool | m_bClosePosted
Used internally to determine if a WM_CLOSE message has been sent.
- Protected Attributes inherited from CXTPBrowseEdit
int | m_nGap
Distance between the button and edit control.
bool | m_bBrowsing
true if in browse operation.
BOOL | m_bOpenFileDialog
TRUE for Open File dialog, FALSE for Save As.
UINT | m_nMenu
Pop-up menu ID.
UINT | m_nSubMenuIndx
Index of a pop-up submenu.
DWORD | m_dwFlags
File dialog styles.
DWORD | m_dwBStyle
Search type.
CString | m_strDefExt
Default file extension.
CString | m_strFileName
Default file name.
CString | m_strFilter
Default file filter.
CString | m_strInitialDir
Initial directory.
CString | m_strTitle
Directory dialog title.
CFileDialog * | m_pFileDialog
Pointer to a valid CFileDialog object.
CXTPBrowseButton | m_btnBrowse
Pointer to a push button.
- Protected Attributes inherited from CXTPEdit
CXTPEditTheme * | m_pTheme
Pointer to the current edit theme.
BOOL | m_bPreSubclassInit
TRUE if the control has been subclassed.
BOOL | m_bShowBorder
TRUE if non-client borders are displayed.
BOOL | m_bHighlighted
TRUE when the mouse is hovering over the control.
BOOL | m_bFocused
TRUE when the control has input focus.
CXTPRegExp * | m_pRegExp
Pointer to the CXTPRegExp object for this control.
- Protected Attributes inherited from CXTPMaskEditT< CEdit >
int | m_nStartChar
Current position of the first character in the current selection.
int | m_nEndChar
Current position of the first non-selected character past the end of the current selection.
BOOL | m_bUseMask
TRUE to use the edit mask.
BOOL | m_bOverType
TRUE to over type the text, set with VK_INSERT key press.
BOOL | m_bRedo
TRUE to redo, or FALSE to undo.
BOOL | m_bModified
TRUE if mask edit has been modified.
TCHAR | m_chPrompt
Prompt character used to identify the text entry.
CString | m_strMask
Buffer that holds the actual edit mask value.
CString | m_strDefault
Contains the edit controls default display text.
CString | m_strUndoBuffer
Holds the contents of the undo buffer.
CString | m_strRedoBuffer
Holds the contents of the redo buffer.
CString | m_strWindowText
Buffer that holds the actual edit text.
CString | m_strLiteral
Literal format that restricts where the user can enter text.
BOOL | m_bUpdateUndo
TRUE to update undo.

Additional Inherited Members

- Static Public Attributes inherited from CXTPBrowseEdit
static int | m_nDefaultGap
Default distance between the button and edit control.
- Protected Member Functions inherited from CXTPEdit
HBRUSH | GetClientBrush (CDC *pDC)
Retrieves a handle to the client background brush.
void | RedrawEdit ()
Called by the framework to redraw the edit control.
void | RedrawFocusedFrame ()
Called by the framework to redraw the focus rectangle for the edit control.
- Protected Member Functions inherited from CXTPMaskEditT< CEdit >
virtual BOOL | OnCommand (WPARAM wParam, LPARAM lParam)
The framework calls this member function when the user selects an item from a menu.

Detailed Description

CXTPItemEdit is a CXTPBrowseEdit derived class.

It is used to create a CXTPItemEdit window that can be used as an "in-place" edit field that can be dynamically created for controls such as a list box.

Member Function Documentation

◆ Create()

BOOL Create | ( | CWnd * | pParent,
 |  | const CRect & | rect,
 |  | CString & | strWindowText,
 |  | DWORD | dwBStyle = BES_XTP_CHOOSEDIR,
 |  | bool | bAutoDelete = true )

Constructs a CXTPItemEdit object that can be used as an "in-place" edit field and can be dynamically created for controls such as a list box.

Parameters
pParent | Pointer to the parent window.
rect | Size of the edit item.
strWindowText | Text to be initially displayed in the edit field.
dwBStyle | Specifies the browse edit style for the in-place edit field. See CXTPBrowseEdit::SetBrowseStyle for available styles.
bAutoDelete | Set to true if the object is to be self-deleting.
Returns
TRUE if successful, FALSE otherwise.

◆ EndLabelEdit()

virtual void EndLabelEdit ( )
virtual

This member function is called whenever the control loses focus.

This will destroy the window, and notify the parent via WM_COMMAND that the editing has been completed. The two possible commands are: ON_BEN_XTP_LABELEDITEND and ON_BEN_XTP_LABELEDITCANCEL

The documentation for this class was generated from the following file:
  • XTPBrowseEdit.h


Toolkit Pro: CXTPKeyboardManager Class Reference

Public Member Functions | Protected Attributes | Static Protected Attributes | List of all members
CXTPKeyboardManager Class Reference

CXTPKeyboardManager class used to handle keyboard hooks. More...

Public Member Functions

CXTPKeyboardManager ()
Constructs a CXTPKeyboardManager object.
~CXTPKeyboardManager ()
Destroys a CXTPKeyboardManager object, handles cleanup and deallocation.
void | SetupKeyboardHook (BOOL bSetup=TRUE)
This method is called to start/end keyboard hooks.
void | SetupCallWndProcHook (BOOL bSetup=TRUE)
This method is called to start/end message hooks.
void | HookKeyboard (CXTPHookManagerHookAble *pHook)
Call this method to hook keyboard notifications.
void | UnhookKeyboard (CXTPHookManagerHookAble *pHook)
Call this method to unhook keyboard notifications.
BOOL | IsKeyboardHooked () const
Determines if the keyboard is hooked.
BOOL | ProcessKeyboardHooks (UINT nMessage, WPARAM wParam, LPARAM lParam=0)
This method is called to process keyboard hooks.
void | LockInput ()
Increments/decrements input lock counter.
void | UnlockInput ()
Increments/decrements input lock counter.
BOOL | IsInputLocked () const
Determines if there is at least one input lock.

Protected Attributes

HHOOK | m_hHookKeyboard
Keyboard hook.
HHOOK | m_hHookCallWndProc
Message hook.
HHOOK | m_hHookGetMessage
Message hook.
LONG | m_nInputLockCount
Number of input locks.
CList< CXTPHookManagerHookAble *, CXTPHookManagerHookAble * > | m_lstKeyboardHooks
List of keyboard hooks.

Static Protected Attributes

static CThreadLocal< CXTPKeyboardManager > _xtpKeyboardThreadState
Instance of Keyboard hook.

Detailed Description

CXTPKeyboardManager class used to handle keyboard hooks.

Member Function Documentation

◆ HookKeyboard()

void HookKeyboard ( CXTPHookManagerHookAble * pHook )

Call this method to hook keyboard notifications.

Parameters
pHook CXTPHookManagerHookAble object that will receive keyboard notifications.
See also
UnhookKeyboard

◆ IsInputLocked()

AFX_INLINE BOOL IsInputLocked ( ) const

Determines if there is at least one input lock.

Returns
TRUE if there is at least one input lock enabled.
See also
LockInput, UnlockInput

◆ IsKeyboardHooked()

AFX_INLINE BOOL IsKeyboardHooked ( ) const

Determines if the keyboard is hooked.

Returns
TRUE if the keyboard is hooked, otherwise FALSE.

◆ LockInput()

void LockInput ( )

Increments/decrements input lock counter.

If there is at least one input lock enabled then tracking won't be reported in any event.

See also
IsInputLocked

◆ ProcessKeyboardHooks()

BOOL ProcessKeyboardHooks | ( | UINT | nMessage,
 |  | WPARAM | wParam,
 |  | LPARAM | lParam = 0 )

This method is called to process keyboard hooks.

Parameters
nMessage | Message to process.
wParam | Message specified parameter.
lParam | Message specified parameter.
Returns
TRUE if the message was processed, otherwise FALSE.

◆ SetupCallWndProcHook()

void SetupCallWndProcHook ( BOOL bSetup = TRUE )

This method is called to start/end message hooks.

Parameters
bSetup TRUE to start message hooks, FALSE to end message hooks.
See also
SetupKeyboardHook

◆ SetupKeyboardHook()

void SetupKeyboardHook ( BOOL bSetup = TRUE )

This method is called to start/end keyboard hooks.

Parameters
bSetup TRUE to start keyboard hooks, FALSE to end keyboard hooks.
See also
SetupCallWndProcHook

◆ UnhookKeyboard()

void UnhookKeyboard ( CXTPHookManagerHookAble * pHook )

Call this method to unhook keyboard notifications.

Parameters
pHook CXTPHookManagerHookAble object to remove.
See also
HookKeyboard

◆ UnlockInput()

void UnlockInput ( )

Increments/decrements input lock counter.

If there is at least one input lock enabled then tracking won't be reported in any event.

See also
IsInputLocked
The documentation for this class was generated from the following file:
  • XTPKeyboardManager.h


Toolkit Pro: CXTPListBase Class Reference

Classes | Public Types | Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPListBase Class Reference

CXTPListBase is a non-inherited class. More...

Inheritance diagram for CXTPListBase:
[legend]

Classes

struct ROWCOLOR
ROWCOLOR structure is used by the CXTPListBase class to store user-defined background and text color settings for a particular row in a list control. More...

Public Types

typedef CList< ROWCOLOR, ROWCOLOR & > CRowColorList
List for maintaining ROWCOLOR structures.

Public Member Functions

CXTPListBase ()
Constructs a CXTPListBase object.
virtual | ~CXTPListBase ()
Destroys a CXTPListBase object, handles cleanup and deallocation.
CXTPHeaderCtrl * | XTPGetHeaderCtrl () const
Call this member function to get a pointer to the flat header control.
virtual int | SetSortImage (int nCol, BOOL bAsc)
This member function will set the sort image for the specified column.
virtual int | GetStoredWidth (int nCol)
This member function will return the column width stored in the registry.
virtual void | SetStoredWidth (int nCol)
This member function will set the column width from the registry settings.
virtual void | LoadColumnWidths ()
This member function loads the column widths from the registry.
virtual void | SaveColumnWidths ()
This member function saves the column widths to the registry.
virtual void | AutoSizeColumn (int nCol=-1)
Automatically sizes a specified column.
virtual void | AutoSizeColumn (int nCol, BOOL bUseHeader)
Automatically sizes a specified column.
virtual void | AutoSaveColumns (LPCTSTR lpszSection=NULL, LPCTSTR lpszEntry=NULL, LPCTSTR lpszDefault=NULL)
Initializes the auto save feature.
virtual bool | SubclassHeader (bool bBoldFont=false)
Call this member function to subclass the flat header control.
virtual bool | SortList (int nCol, bool bAscending)
Override this member function in your derived class to perform custom sort routines.
virtual void | SetExtendedStyle (DWORD dwExStyle)
This member function is called to set extended styles for the list control, ie: LVS_EX_FULLROWSELECT, LVS_EX_GRIDLINES, etc.
virtual DWORD | GetExtendedStyle ()
This member function is called to retrieve the list control extended style.
virtual void | DisableColumnSizing (bool bDisable)
Call this member function to disable/enable column sizing.
void | SetMinimumColSize (int nSize)
Call this member function to set a minimum column size.
int | GetMinimumColSize ()
Call this member function to get the minimum column size for the list control.
int | GetMaximumColSize ()
Call this member function to get the maximum column size for the list control.
virtual int | HitTestEx (CPoint &point, int *col) const
Call this member function to determine the row index and column index for a 'point'.
virtual int | AddColumn (LPCTSTR lpszColHeading, int nWidth=-1, int nFormat=LVCFMT_LEFT)
Call this member function to add a column after the right most column.
virtual bool | BuildColumns (int nCols, int *nWidth, int *nColString)
This member function will build the columns for the list control.
virtual bool | BuildColumns (int nCols, int *nWidth, CString *strColString)
This member function will build the columns for the list control.
virtual int | GetColumnCount ()
This member function gets the number of columns in the list.
virtual int | CopyRow (int nFrom, int nTo)
This member function copies a row to a new location.
virtual bool | MoveRow (int nFrom, int nTo)
This member function moves a row to a new location.
CHeaderCtrl * | _xtGetHeaderCtrl () const
This member function is a utility function to retrieve the associated header control.
void | SetRowColors (COLORREF clrText, COLORREF clrTextBk)
This member function sets the row, text, and background colors for the list control.
void | SetRowColor (ROWCOLOR *lpRowColor, BOOL bRedraw=TRUE)
This member function sets the text and background colors for the specified row in the list control.
void | SetRowColor (int iRow, COLORREF crText, COLORREF crBack, BOOL bRedraw=TRUE)
This member function sets the text and background colors for the specified row in the list control.
void | RemoveRowColors ()
Call this member function to remove all user-defined row colors from the list control.
virtual ROWCOLOR * | Lookup (int iRow)
Call this member function to determine if the specified row contains user-defined color attributes.
virtual BOOL | ModifyExtendedStyle (DWORD dwRemove, DWORD dwAdd)
Call this member function to modify the extended style for the list control.
COLORREF | GetListBackColor () const
Call this member function to retrieve the RGB color value used for the column background color.
void | SetListBackColor (COLORREF crListBack)
Call this member function to set the RGB color value used for the list background color.
COLORREF | GetListTextColor () const
Call this member function to retrieve the RGB color value used for the column text color.
void | SetListTextColor (COLORREF crListText)
Call this member function to set the RGB color value used for the list text color.
COLORREF | GetSortBackColor () const
Call this member function to retrieve the RGB color value used for the sorted column background color.
void | SetSortBackColor (COLORREF crSortBack)
Call this member function to set the RGB color value used for the sorted column background color.
COLORREF | GetSortTextColor () const
Call this member function to retrieve the RGB color value used for the sorted column text color.
void | SetSortTextColor (COLORREF crSortText)
Call this member function to set the RGB color value used for the sorted column text color.
void | EnableUserSortColor (bool bEnable)
Call this member function to enable/disable sorted column colors.
bool | IsUserSortColor () const
Call this member function to determine if sorted column colors are enabled.
void | EnableUserListColor (bool bEnable)
Call this member function to enable/disable user-defined colors.
bool | IsUserListColor () const
Call this member function to determine if user-defined colors are enabled.
void | EnableUserRowColor (bool bEnable)
Call this member function to enable/disable user-defined row colors.
bool | IsUserRowColor () const
Call this member function to determine if user-defined row colors are enabled.
void | SetAutoFont (bool bAutoFont)
Call this member function to automatically set the font for the list control when the control is initialized to use the toolkit default font.

Protected Member Functions

virtual bool | Init ()
This member function is called by the CXTPListBase class to perform initialization when the window is created or sub-classed.
void | ImplAttach (CListCtrl *pListCtrl)
Sets the list control pointer.
virtual BOOL | OnNotify (WPARAM wParam, LPARAM lParam, LRESULT *pResult)
Called from the derived class OnNotify method.
void | RefreshMetrics ()
Updates colors and size values.

Protected Attributes

int | m_nMinColWidth
Minimum width for columns.
int | m_nMaxColWidth
Maximum width for columns.
int | m_nSortedCol
Index of the currently selected column.
bool | m_bAutoFont
If true, then the font will automatically be set for the control.
bool | m_bAutoSave
true if saving the column widths.
bool | m_bListColor
true if user-defined colors are used for background and text.
bool | m_bRowColor
true if rows are drawn with user-defined colors.
bool | m_bSortColor
true if the sorted column is drawn in color.
bool | m_bAscending
Flag to determine the sorting order.
bool | m_bNoColSizing
If true, then column sizing is disabled.
CString | m_strSection
Registry section name.
CString | m_strEntry
Registry entry name.
CString | m_strDefault
Registry default value.
COLORREF | m_crListText
RGB value representing the row text color.
COLORREF | m_crListBack
RGB value representing the row text background color.
COLORREF | m_crSortText
RGB value for sort column text color.
COLORREF | m_crSortBack
RGB value for sort column background color.
CRowColorList | m_arRowColor
List of user-defined text and background row colors.
CXTPHeaderCtrl | m_wndHeader
Subclassed flat header control.
CListCtrl_Friendly * | m_pListCtrl
List control instance.

Detailed Description

CXTPListBase is a non-inherited class.

It implements the extended list control services provided by the Xtreme Toolkit list control classes.

Member Typedef Documentation

◆ CRowColorList

CList<ROWCOLOR, ROWCOLOR&> CRowColorList

List for maintaining ROWCOLOR structures.

CList definition used by the CXTPListBase class to maintain a list of ROWCOLOR structures representing each row that has a user-defined color setting for the list control.

See also
CXTPListBase, CXTPListBase::SetRowColor, RemoveRowColors, Lookup, ROWCOLOR

Member Function Documentation

◆ _xtGetHeaderCtrl()

CHeaderCtrl * _xtGetHeaderCtrl ( ) const

This member function is a utility function to retrieve the associated header control.

Returns
A CHeaderCtrl pointer to the associated header control.

◆ AddColumn()

virtual int AddColumn | ( | LPCTSTR | lpszColHeading,
 |  | int | nWidth = -1,
 |  | int | nFormat = LVCFMT_LEFT )
 virtual

Call this member function to add a column after the right most column.

Parameters
lpszColHeading | The column's heading.
nWidth | Width of the column in pixels. If this parameter is -1, then the column width is the same as the previous column.
nFormat | The alignment of the column. It can be LVCFMT_LEFT, LVCFMT_RIGHT, or LVCFMT_CENTER.
Returns
The index of the new column if successful, or -1 if unsuccessful.

◆ AutoSaveColumns()

virtual void AutoSaveColumns | ( | LPCTSTR | lpszSection = NULL,
 |  | LPCTSTR | lpszEntry = NULL,
 |  | LPCTSTR | lpszDefault = NULL )
 virtual

Initializes the auto save feature.

Parameters
lpszSection | Registry section name. If NULL, then the default is "Settings".
lpszEntry | Registry entry name. If NULL, then the default is "Column Info".
lpszDefault | Registry default value. If NULL, then the default ID.

This member function will initialize the auto save feature. If called, column widths will be saved to the system registry when the list control window is destroyed.

◆ AutoSizeColumn() [1/2]

virtual void AutoSizeColumn | ( | int | nCol,
 |  | BOOL | bUseHeader )
 virtual

Automatically sizes a specified column.

Parameters
nCol | Zero-based index of the column, or -1 to indicate all columns.
bUseHeader | Automatically sizes the column to fit the header text. If you use this value with the last column, its width is set to fill the remaining width of the list-view control.

◆ AutoSizeColumn() [2/2]

virtual void AutoSizeColumn ( int nCol = -1 )
virtual

Automatically sizes a specified column.

Parameters
nCol Zero-based index of the column, or -1 to indicate all columns.

◆ BuildColumns() [1/2]

virtual bool BuildColumns | ( | int | nCols,
 |  | int * | nWidth,
 |  | CString * | strColString )
 virtual

This member function will build the columns for the list control.

Parameters
nCols | [in] Number of columns contained in the list control.
nWidth | [in] 'int' array containing the column widths.
strColString | [in] CString array containing the string for each column.

Call this member function to automatically generate the columns for the list control. This is done by passing in an array of column indexes specified by nCols, an array of column widths specified by nWidth, and an array of column labels specified by nColString or strColString. Example: The following example demonstrates the use of BuildColumns:

static int arColWidths[] = {
   24,
   21,
   100,
   180,
   120
};

static CString arColLabels[] = {
   _T(" "),
   _T(" "),
   _T("From"),
   _T("Subject"),
   _T("Received")
};

// Insert the columns.
BuildColumns(_countof(arColWidths), arColWidths, arColLabels);
Returns
true if successful, or false if an error occurred.

◆ BuildColumns() [2/2]

virtual bool BuildColumns | ( | int | nCols,
 |  | int * | nWidth,
 |  | int * | nColString )
 virtual

This member function will build the columns for the list control.

Parameters
nCols | [in] Number of columns contained in the list control.
nWidth | [in] 'int' array containing the column widths.
nColString | [in] 'int' array containing the string resource ID for each column.

Call this member function to automatically generate the columns for the list control. This is done by passing in an array of column indexes specified by nCols, an array of column widths specified by nWidth, and an array of column labels specified by nColString or strColString. Example: The following example demonstrates the use of BuildColumns:

static int arColWidths[] = {
   24,
   21,
   100,
   180,
   120
};

static CString arColLabels[] = {
   _T(" "),
   _T(" "),
   _T("From"),
   _T("Subject"),
   _T("Received")
};

// Insert the columns.
BuildColumns(_countof(arColWidths), arColWidths, arColLabels);
Returns
true if successful, or false if an error occurred.

◆ CopyRow()

virtual int CopyRow | ( | int | nFrom,
 |  | int | nTo )
 virtual

This member function copies a row to a new location.

Parameters
nFrom | Index of the source row.
nTo | Index of the destination row.
Returns
The index of the source row specified by 'nFrom'.

◆ DisableColumnSizing()

virtual void DisableColumnSizing ( bool bDisable )
virtual

Call this member function to disable/enable column sizing.

Parameters
bDisable true to disable column sizing, false to enable.

◆ EnableUserListColor()

void EnableUserListColor ( bool bEnable )

Call this member function to enable/disable user-defined colors.

Parameters
bEnable true to enable user-defined colors, false to disable.

◆ EnableUserRowColor()

void EnableUserRowColor ( bool bEnable )

Call this member function to enable/disable user-defined row colors.

Parameters
bEnable true to enable user-defined row colors, false to disable.

◆ EnableUserSortColor()

void EnableUserSortColor ( bool bEnable )

Call this member function to enable/disable sorted column colors.

Parameters
bEnable true to enable sorted column colors, false to disable.

◆ GetColumnCount()

virtual int GetColumnCount ( )
virtual

This member function gets the number of columns in the list.

Returns
An integer value that represents the number of columns in the list.

◆ GetExtendedStyle()

virtual DWORD GetExtendedStyle ( )
virtual

This member function is called to retrieve the list control extended style.

Returns
A DWORD value that represents the extended style of the list control.

◆ GetListBackColor()

COLORREF GetListBackColor ( ) const

Call this member function to retrieve the RGB color value used for the column background color.

Returns
Returns an RGB value representing the column background color.

◆ GetListTextColor()

COLORREF GetListTextColor ( ) const

Call this member function to retrieve the RGB color value used for the column text color.

Returns
Returns an RGB value representing the column text color.

◆ GetMaximumColSize()

int GetMaximumColSize ( )

Call this member function to get the maximum column size for the list control.

Returns
An integer value that represents the maximum column size for the list control.

◆ GetMinimumColSize()

int GetMinimumColSize ( )

Call this member function to get the minimum column size for the list control.

Returns
An integer value that represents the minimum column size for the list control.

◆ GetSortBackColor()

COLORREF GetSortBackColor ( ) const

Call this member function to retrieve the RGB color value used for the sorted column background color.

Returns
Returns an RGB value representing the sorted column background color.

◆ GetSortTextColor()

COLORREF GetSortTextColor ( ) const

Call this member function to retrieve the RGB color value used for the sorted column text color.

Returns
Returns an RGB value representing the sorted column text color.

◆ GetStoredWidth()

virtual int GetStoredWidth ( int nCol )
virtual

This member function will return the column width stored in the registry.

Parameters
nCol Zero-based index of the column.
Returns
The column width stored in the registry.

◆ HitTestEx()

virtual int HitTestEx | ( | CPoint & | point,
 |  | int * | col ) const
 virtual

Call this member function to determine the row index and column index for a 'point'.

Parameters
point | Point to be tested.
col | Address of the column index.
Returns
The row index, or -1 if 'point' is not over a row.

◆ ImplAttach()

void ImplAttach ( CListCtrl * pListCtrl )
protected

Sets the list control pointer.

Parameters
pListCtrl Pointer to the CListCtrl object to attach.

This member function is called by the derived class to set the list control pointer for this implementation.

◆ Init()

virtual bool Init ( )
protectedvirtual

This member function is called by the CXTPListBase class to perform initialization when the window is created or sub-classed.

Returns
TRUE if the window was successfully initialized, otherwise FALSE.

Reimplemented in CXTPShellListBase.

◆ IsUserListColor()

bool IsUserListColor ( ) const

Call this member function to determine if user-defined colors are enabled.

Returns
true if user-defined colors are enabled, otherwise false.

◆ IsUserRowColor()

bool IsUserRowColor ( ) const

Call this member function to determine if user-defined row colors are enabled.

Returns
true if user-defined row colors are enabled, otherwise false.

◆ IsUserSortColor()

bool IsUserSortColor ( ) const

Call this member function to determine if sorted column colors are enabled.

Returns
true if sorted column colors are enabled, otherwise false.

◆ Lookup()

virtual ROWCOLOR * Lookup ( int iRow )
virtual

Call this member function to determine if the specified row contains user-defined color attributes.

Parameters
iRow Index of the row to check.
Returns
A pointer to a ROWCOLOR structure if successful, otherwise NULL.

◆ ModifyExtendedStyle()

virtual BOOL ModifyExtendedStyle | ( | DWORD | dwRemove,
 |  | DWORD | dwAdd )
 virtual

Call this member function to modify the extended style for the list control.

Parameters
dwRemove | Specifies window styles to be removed during style modification.
dwAdd | Specifies window styles to be added during style modification.
Returns
TRUE if successful, otherwise FALSE.

◆ MoveRow()

virtual bool MoveRow | ( | int | nFrom,
 |  | int | nTo )
 virtual

This member function moves a row to a new location.

Parameters
nFrom | Index of the source row.
nTo | Index of the destination row.
Returns
true if successful, or false if an error occurred.

◆ OnNotify()

virtual BOOL OnNotify | ( | WPARAM | wParam,
 |  | LPARAM | lParam,
 |  | LRESULT * | pResult )
 protectedvirtual

Called from the derived class OnNotify method.

Parameters
wParam | Identifies the control that sends the message if the message is from a control. Otherwise, wParam is 0.
lParam | Pointer to a notification message (NMHDR) structure that contains the notification code and additional information. For some notification messages, this parameter points to a larger structure that has the NMHDR structure as its first member.
pResult | Pointer to an LRESULT variable in which to store the result code if the message is handled.

The derived class calls this member function to process the message map for a control notification. The derived class should call this member function from the CWnd::OnNotify override.

Returns
An application returns nonzero if it processes this message, otherwise 0.

◆ RefreshMetrics()

void RefreshMetrics ( )
protected

Updates colors and size values.

This member function is called whenever there is a need to refresh the colors and size values that are set using system values. Usually called when the operating system color or settings change.

◆ SetAutoFont()

void SetAutoFont ( bool bAutoFont )

Call this member function to automatically set the font for the list control when the control is initialized to use the toolkit default font.

This will also reset the font for the header control as well.

Parameters
bAutoFont true to enable auto font, otherwise false.

◆ SetExtendedStyle()

virtual void SetExtendedStyle ( DWORD dwExStyle )
virtual

This member function is called to set extended styles for the list control, ie: LVS_EX_FULLROWSELECT, LVS_EX_GRIDLINES, etc.

See MSDN documentation for a complete list of available styles.

Parameters
dwExStyle DWORD value that specifies the extended list-view control style. This parameter can be a combination of Extended List-View Styles.

◆ SetListBackColor()

void SetListBackColor ( COLORREF crListBack )

Call this member function to set the RGB color value used for the list background color.

Parameters
crListBack An RGB value representing the list background color.

◆ SetListTextColor()

void SetListTextColor ( COLORREF crListText )

Call this member function to set the RGB color value used for the list text color.

Parameters
crListText An RGB value representing the list text color.

◆ SetMinimumColSize()

void SetMinimumColSize ( int nSize )

Call this member function to set a minimum column size.

Parameters
nSize Size in pixels of the column's minimum size.

◆ SetRowColor() [1/2]

void SetRowColor | ( | int | iRow,
 |  | COLORREF | crText,
 |  | COLORREF | crBack,
 |  | BOOL | bRedraw = TRUE )

This member function sets the text and background colors for the specified row in the list control.

Parameters
bRedraw | TRUE to invalidate control.
iRow | Index of the row to set the colors for.
crText | An RGB value representing the row text color.
crBack | An RGB value representing the row background color.

◆ SetRowColor() [2/2]

void SetRowColor | ( | ROWCOLOR * | lpRowColor,
 |  | BOOL | bRedraw = TRUE )

This member function sets the text and background colors for the specified row in the list control.

Parameters
lpRowColor | Pointer to a ROWCOLOR that contains the RGB row color information.
bRedraw | TRUE to invalidate the control.

◆ SetRowColors()

void SetRowColors | ( | COLORREF | clrText,
 |  | COLORREF | clrTextBk )

This member function sets the row, text, and background colors for the list control.

Parameters
clrText | An RGB value representing the row text color.
clrTextBk | An RGB value representing the row background color.

The iIndex version sets the text and background colors for the specified row in the list control.

◆ SetSortBackColor()

void SetSortBackColor ( COLORREF crSortBack )

Call this member function to set the RGB color value used for the sorted column background color.

Parameters
crSortBack An RGB value representing the sorted column background color.

◆ SetSortImage()

virtual int SetSortImage | ( | int | nCol,
 |  | BOOL | bAsc )
 virtual

This member function will set the sort image for the specified column.

Parameters
nCol | Zero-based index of the column to set the sort image for.
bAsc | TRUE if ascending, otherwise FALSE.
Returns
The zero-based index of the previously sorted column.

◆ SetSortTextColor()

void SetSortTextColor ( COLORREF crSortText )

Call this member function to set the RGB color value used for the sorted column text color.

Parameters
crSortText An RGB value representing the sorted column text color.

◆ SetStoredWidth()

virtual void SetStoredWidth ( int nCol )
virtual

This member function will set the column width from the registry settings.

Parameters
nCol Zero-based index of the column.

◆ SortList()

virtual bool SortList | ( | int | nCol,
 |  | bool | bAscending )
 virtual

Override this member function in your derived class to perform custom sort routines.

Parameters
nCol | Passed in from the control. Index of the column clicked.
bAscending | Passed in from the control. true if sort order should be ascending.
Returns
TRUE if successful, FALSE otherwise.

Reimplemented in CXTPShellListBase.

◆ SubclassHeader()

virtual bool SubclassHeader ( bool bBoldFont = false )
virtual

Call this member function to subclass the flat header control.

Parameters
bBoldFont true to use a bold font in the header control.
Returns
TRUE if successful, FALSE otherwise.

◆ XTPGetHeaderCtrl()

CXTPHeaderCtrl * XTPGetHeaderCtrl ( ) const

Call this member function to get a pointer to the flat header control.

Returns
A pointer to a CXTPHeaderCtrl object if subclassed, otherwise NULL.
The documentation for this class was generated from the following file:
  • XTPListBase.h


Toolkit Pro: CXTPListBase::ROWCOLOR Struct Reference

  • CXTPListBase
  • ROWCOLOR
Public Attributes | List of all members
CXTPListBase::ROWCOLOR Struct Reference

ROWCOLOR structure is used by the CXTPListBase class to store user-defined background and text color settings for a particular row in a list control. More...

Public Attributes

int | iRow
List control row index.
COLORREF | crBack
RGB value for text background color.
COLORREF | crText
RGB value for text foreground color.
LPARAM | lParam
User-defined data.

Detailed Description

ROWCOLOR structure is used by the CXTPListBase class to store user-defined background and text color settings for a particular row in a list control.

See also
CRowColorList, SetRowColor, RemoveRowColors, Lookup
The documentation for this struct was generated from the following file:
  • XTPListBase.h


Toolkit Pro: CXTPListBox Class Reference

Public Member Functions | Public Attributes | Protected Member Functions | List of all members
CXTPListBox Class Reference

CXTPListBox is a CListBox derived class. More...

Inheritance diagram for CXTPListBox:
[legend]

Public Member Functions

CXTPListBox ()
Constructs a CXTPListBox object.
virtual | ~CXTPListBox ()
Destroys a CXTPListBox object, handles cleanup and deallocation.
virtual void | Initialize (bool bAutoFont=true)
Call this member function to initialize the list box.
virtual COLORREF | GetBackColor ()
Called to retrieve the background color for the list box.
void | SetListStyle (XTPListBoxStyle style)
Call this method to set the style of the list box.
XTPListBoxStyle | GetListStyle () const
Call this method to retrieve the style of the list box.
void | SetTheme (XTPControlTheme nTheme)
This member function sets the drawing theme for the control.
virtual void | RefreshMetrics ()
Call this member function to refresh theme colors and redraw the control.
BOOL | HasFocus () const
Call this member function to determine if the list box control has input focus.

Public Attributes

CXTPListBoxTheme * | m_pTheme
Pointer to the currently active theme.
XTPControlTheme | m_theme
List box theme.
int | m_nItemHeight
Height of the items.
int | m_nTextPadding
Text padding.
int | m_nHotItem
Hot item index.

Protected Member Functions

BOOL TryItemFromPoint (CPoint pt, BOOL &bOutside, int &nIndex) const
This method determines the list box item nearest to the point specified in pt when there is at least one item in the list box.

Detailed Description

CXTPListBox is a CListBox derived class.

CXTPListBox extends the standard list box control to enable flicker free drawing.

Member Function Documentation

◆ GetBackColor()

virtual COLORREF GetBackColor ( )
virtual

Called to retrieve the background color for the list box.

Returns
An RGB value representing the background color.

◆ GetListStyle()

XTPListBoxStyle GetListStyle ( ) const

Call this method to retrieve the style of the list box.

Returns
An XTPListBoxStyle value that contains the style of the list box.
See also
XTPListBoxStyle, SetListStyle

◆ HasFocus()

BOOL HasFocus ( ) const

Call this member function to determine if the list box control has input focus.

Returns
TRUE if the list box has focus, otherwise FALSE.

◆ Initialize()

virtual void Initialize ( bool bAutoFont = true )
virtual

Call this member function to initialize the list box.

This method should be called directly after creating or sub-classing the control.

Parameters
bAutoFont true to enable automatic font initialization.

Reimplemented in CXTPEditListBox, and CXTPFontListBox.

◆ SetListStyle()

void SetListStyle ( XTPListBoxStyle style )

Call this method to set the style of the list box.

Parameters
style An XTPListBoxStyle constant used to specify which theme to be used by the control. This method is here only for backward compatibilty with older versions and may be removed with a future release. Plese use the SetTheme() method instead.
See also
XTPListBoxStyle, GetListStyle, SetTheme

◆ SetTheme()

void SetTheme ( XTPControlTheme nTheme )

This member function sets the drawing theme for the control.

Parameters
nTheme A XTPControlTheme constant used to specify which theme is to be used for the control.
See also
XTPControlTheme

◆ TryItemFromPoint()

BOOL TryItemFromPoint | ( | CPoint | pt,
 |  | BOOL & | bOutside,
 |  | int & | nIndex ) const
 protected

This method determines the list box item nearest to the point specified in pt when there is at least one item in the list box.

Parameters
pt | Specifies the point for which to find the nearest item, specified relative to the upper-left corner of the client area of the list box.
bOutside | Specifies the reference to a BOOL variable which will be set to TRUE if pt is outside the client area of the list box, FALSE if pt is inside the client area of the list box.
nIndex | Receives the index of the item that was nearest to the point specified in pt if successful, otherwise -1.
Returns
TRUE if an item is detected at the specified point, otherwise FALSE.
The documentation for this class was generated from the following file:
  • XTPListBox.h


Toolkit Pro: CXTPListBoxTheme Class Reference

Public Member Functions | List of all members
CXTPListBoxTheme Class Referenceabstract

CXTPListBoxTheme is the base class used by CXTPListBox themes to draw the list box control. More...

Inheritance diagram for CXTPListBoxTheme:
[legend]

Public Member Functions

virtual | ~CXTPListBoxTheme ()
Handles theme destruction.
virtual void | DrawItem (CDC *pDC, CXTPListBox *pListBox, LPDRAWITEMSTRUCT lpDIS)=0
This method is called to draw the CXTPListBox object.
virtual void | DrawItemText (CDC *pDC, CRect rcText, CXTPListBox *pListBox, LPDRAWITEMSTRUCT lpDIS)
This method is called to draw text for the CXTPListBox object.
virtual void | RefreshMetrics ()=0
Called to update the colors and metrics used to draw the CXTPListBox object.
virtual COLORREF | GetBackColor ()
Called to retrieve the background color for the list box.
virtual BOOL | DrawNcBorders (CDC *pDC, CRect rc)
Call this member function to draw the list control borders.

Detailed Description

CXTPListBoxTheme is the base class used by CXTPListBox themes to draw the list box control.

Member Function Documentation

◆ DrawItem()

virtual void DrawItem | ( | CDC * | pDC,
 |  | CXTPListBox * | pListBox,
 |  | LPDRAWITEMSTRUCT | lpDIS )
 pure virtual

This method is called to draw the CXTPListBox object.

Parameters
pDC | Pointer to a valid device context.
pListBox | Pointer to a valid CXTPListBox object.
lpDIS | A long pointer to a DRAWITEMSTRUCT structure. The structure contains information about the item to be drawn and the type of drawing required.

Implemented in CXTPListBoxThemeDefault, CXTPListBoxThemeOffice2003, CXTPListBoxThemeOffice2013, CXTPListBoxThemeOfficeXP, and CXTPListBoxThemeResource.

◆ DrawItemText()

virtual void DrawItemText | ( | CDC * | pDC,
 |  | CRect | rcText,
 |  | CXTPListBox * | pListBox,
 |  | LPDRAWITEMSTRUCT | lpDIS )
 virtual

This method is called to draw text for the CXTPListBox object.

Parameters
pDC | Pointer to a valid device context.
rcText | Size of the area to draw the text to.
pListBox | Pointer to a valid CXTPListBox object.
lpDIS | A long pointer to a DRAWITEMSTRUCT structure. The structure contains information about the item to be drawn and the type of drawing required.

◆ DrawNcBorders()

virtual BOOL DrawNcBorders | ( | CDC * | pDC,
 |  | CRect | rc )
 virtual

Call this member function to draw the list control borders.

Parameters
pDC | Pointer to a valid device context.
rc | Size of the area to draw.
Returns
TRUE if non-client border drawing is handled, otherwise FALSE.

Reimplemented in CXTPListBoxThemeOffice2013.

◆ GetBackColor()

virtual COLORREF GetBackColor ( )
virtual

Called to retrieve the background color for the list box.

Returns
An RGB value representing the background color.

Reimplemented in CXTPListBoxThemeOffice2013.

The documentation for this class was generated from the following file:
  • XTPListBox.h


Toolkit Pro: CXTPListBoxThemeDefault Class Reference

Public Member Functions | List of all members
CXTPListBoxThemeDefault Class Reference

CXTPListBoxThemeDefault is used by CXTPListBox to draw a default style list box. More...

Inheritance diagram for CXTPListBoxThemeDefault:
[legend]

Public Member Functions

virtual void | DrawItem (CDC *pDC, CXTPListBox *pListBox, LPDRAWITEMSTRUCT lpDIS)
This method is called to draw the CXTPListBox object.
virtual void | RefreshMetrics ()
Called to update the colors and metrics used to draw the CXTPListBox object.
- Public Member Functions inherited from CXTPListBoxTheme
virtual | ~CXTPListBoxTheme ()
Handles theme destruction.
virtual void | DrawItemText (CDC *pDC, CRect rcText, CXTPListBox *pListBox, LPDRAWITEMSTRUCT lpDIS)
This method is called to draw text for the CXTPListBox object.
virtual COLORREF | GetBackColor ()
Called to retrieve the background color for the list box.
virtual BOOL | DrawNcBorders (CDC *pDC, CRect rc)
Call this member function to draw the list control borders.

Detailed Description

CXTPListBoxThemeDefault is used by CXTPListBox to draw a default style list box.

Member Function Documentation

◆ DrawItem()

virtual void DrawItem | ( | CDC * | pDC,
 |  | CXTPListBox * | pListBox,
 |  | LPDRAWITEMSTRUCT | lpDIS )
 virtual

This method is called to draw the CXTPListBox object.

Parameters
pDC | Pointer to a valid device context.
pListBox | Pointer to a valid CXTPListBox object.
lpDIS | A long pointer to a DRAWITEMSTRUCT structure. The structure contains information about the item to be drawn and the type of drawing required.

Implements CXTPListBoxTheme.

The documentation for this class was generated from the following file:
  • XTPListBoxThemeDefault.h


Toolkit Pro: CXTPListBoxThemeNativeWindows10 Class Reference

Public Member Functions | List of all members
CXTPListBoxThemeNativeWindows10 Class Reference

CXTPListBoxThemeNativeWindows10 is used by CXTPListBox to draw a Native Windows 10 style list box. More...

Inheritance diagram for CXTPListBoxThemeNativeWindows10:
[legend]

Public Member Functions

CXTPListBoxThemeNativeWindows10 ()
Default constructor.
- Public Member Functions inherited from CXTPListBoxThemeOffice2013
CXTPListBoxThemeOffice2013 ()
Default constructor.
virtual void | DrawItem (CDC *pDC, CXTPListBox *pListBox, LPDRAWITEMSTRUCT lpDIS)
This method is called to draw the CXTPListBox object.
virtual void | RefreshMetrics ()
Called to update the colors and metrics used to draw the CXTPListBox object.
virtual COLORREF | GetBackColor ()
Called to retrieve the background color for the listbox.
virtual BOOL | DrawNcBorders (CDC *pDC, CRect rc)
Call this member function to draw the list control borders.
- Public Member Functions inherited from CXTPListBoxTheme
virtual | ~CXTPListBoxTheme ()
Handles theme destruction.
virtual void | DrawItemText (CDC *pDC, CRect rcText, CXTPListBox *pListBox, LPDRAWITEMSTRUCT lpDIS)
This method is called to draw text for the CXTPListBox object.

Additional Inherited Members

- Public Attributes inherited from CXTPListBoxThemeOffice2013
COLORREF | m_clrBack
List-box background color.
COLORREF | m_clrBorder
List-box border color.
COLORREF | m_clrItemText
List-box item normal text color.
COLORREF | m_clrItemTextHighlight
List-box item highlighted text color.
COLORREF | m_clrItemTextSelected
List-box item selected text color.
COLORREF | m_clrItemBack
List-box item normal background color.
COLORREF | m_clrItemBackHighlight
List-box item highlighted background color.
COLORREF | m_clrItemBackSelected
List-box item selected background color.
COLORREF | m_clrItemBorder
List-box item normal border color.
COLORREF | m_clrItemBorderHighlight
List-box item highlighted border color.
COLORREF | m_clrItemBorderSelected
List-box item selected border color.

Detailed Description

CXTPListBoxThemeNativeWindows10 is used by CXTPListBox to draw a Native Windows 10 style list box.

The documentation for this class was generated from the following file:
  • XTPListBoxThemeNativeWindows10.h


Toolkit Pro: CXTPListBoxThemeNativeWindows11 Class Reference

Public Member Functions | List of all members
CXTPListBoxThemeNativeWindows11 Class Reference

CXTPListBoxThemeNativeWindows11 is used by CXTPListBox to draw a Native Windows 10 style list box. More...

Inheritance diagram for CXTPListBoxThemeNativeWindows11:
[legend]

Public Member Functions

CXTPListBoxThemeNativeWindows11 ()
Default constructor.
- Public Member Functions inherited from CXTPListBoxThemeOffice2013
CXTPListBoxThemeOffice2013 ()
Default constructor.
virtual void | DrawItem (CDC *pDC, CXTPListBox *pListBox, LPDRAWITEMSTRUCT lpDIS)
This method is called to draw the CXTPListBox object.
virtual void | RefreshMetrics ()
Called to update the colors and metrics used to draw the CXTPListBox object.
virtual COLORREF | GetBackColor ()
Called to retrieve the background color for the listbox.
virtual BOOL | DrawNcBorders (CDC *pDC, CRect rc)
Call this member function to draw the list control borders.
- Public Member Functions inherited from CXTPListBoxTheme
virtual | ~CXTPListBoxTheme ()
Handles theme destruction.
virtual void | DrawItemText (CDC *pDC, CRect rcText, CXTPListBox *pListBox, LPDRAWITEMSTRUCT lpDIS)
This method is called to draw text for the CXTPListBox object.

Additional Inherited Members

- Public Attributes inherited from CXTPListBoxThemeOffice2013
COLORREF | m_clrBack
List-box background color.
COLORREF | m_clrBorder
List-box border color.
COLORREF | m_clrItemText
List-box item normal text color.
COLORREF | m_clrItemTextHighlight
List-box item highlighted text color.
COLORREF | m_clrItemTextSelected
List-box item selected text color.
COLORREF | m_clrItemBack
List-box item normal background color.
COLORREF | m_clrItemBackHighlight
List-box item highlighted background color.
COLORREF | m_clrItemBackSelected
List-box item selected background color.
COLORREF | m_clrItemBorder
List-box item normal border color.
COLORREF | m_clrItemBorderHighlight
List-box item highlighted border color.
COLORREF | m_clrItemBorderSelected
List-box item selected border color.

Detailed Description

CXTPListBoxThemeNativeWindows11 is used by CXTPListBox to draw a Native Windows 10 style list box.

The documentation for this class was generated from the following file:
  • XTPListBoxThemeNativeWindows11.h


Toolkit Pro: CXTPListBoxThemeOffice2003 Class Reference

Public Member Functions | List of all members
CXTPListBoxThemeOffice2003 Class Reference

CXTPListBoxThemeOffice2003 is used by CXTPListBox to draw an Office 2003 style list box. More...

Inheritance diagram for CXTPListBoxThemeOffice2003:
[legend]

Public Member Functions

virtual void | DrawItem (CDC *pDC, CXTPListBox *pListBox, LPDRAWITEMSTRUCT lpDIS)
This method is called to draw the CXTPListBox object.
virtual void | RefreshMetrics ()
Called to update the colors and metrics used to draw the CXTPListBox object.
- Public Member Functions inherited from CXTPListBoxThemeOfficeXP
- Public Member Functions inherited from CXTPListBoxTheme
virtual | ~CXTPListBoxTheme ()
Handles theme destruction.
virtual void | DrawItemText (CDC *pDC, CRect rcText, CXTPListBox *pListBox, LPDRAWITEMSTRUCT lpDIS)
This method is called to draw text for the CXTPListBox object.
virtual COLORREF | GetBackColor ()
Called to retrieve the background color for the list box.
virtual BOOL | DrawNcBorders (CDC *pDC, CRect rc)
Call this member function to draw the list control borders.

Detailed Description

CXTPListBoxThemeOffice2003 is used by CXTPListBox to draw an Office 2003 style list box.

Member Function Documentation

◆ DrawItem()

virtual void DrawItem | ( | CDC * | pDC,
 |  | CXTPListBox * | pListBox,
 |  | LPDRAWITEMSTRUCT | lpDIS )
 virtual

This method is called to draw the CXTPListBox object.

Parameters
pDC | Pointer to a valid device context.
pListBox | Pointer to a valid CXTPListBox object.
lpDIS | A long pointer to a DRAWITEMSTRUCT structure. The structure contains information about the item to be drawn and the type of drawing required.

Reimplemented from CXTPListBoxThemeOfficeXP.

The documentation for this class was generated from the following file:
  • XTPListBoxThemeOffice2003.h


Toolkit Pro: CXTPListBoxThemeOffice2013 Class Reference

Public Member Functions | Public Attributes | List of all members
CXTPListBoxThemeOffice2013 Class Reference

CXTPListBoxThemeOffice2013 is used by CXTPListBox to draw an Office 2013 style list box. More...

Inheritance diagram for CXTPListBoxThemeOffice2013:
[legend]

Public Member Functions

CXTPListBoxThemeOffice2013 ()
Default constructor.
virtual void | DrawItem (CDC *pDC, CXTPListBox *pListBox, LPDRAWITEMSTRUCT lpDIS)
This method is called to draw the CXTPListBox object.
virtual void | RefreshMetrics ()
Called to update the colors and metrics used to draw the CXTPListBox object.
virtual COLORREF | GetBackColor ()
Called to retrieve the background color for the listbox.
virtual BOOL | DrawNcBorders (CDC *pDC, CRect rc)
Call this member function to draw the list control borders.
- Public Member Functions inherited from CXTPListBoxTheme
virtual | ~CXTPListBoxTheme ()
Handles theme destruction.
virtual void | DrawItemText (CDC *pDC, CRect rcText, CXTPListBox *pListBox, LPDRAWITEMSTRUCT lpDIS)
This method is called to draw text for the CXTPListBox object.

Public Attributes

COLORREF | m_clrBack
List-box background color.
COLORREF | m_clrBorder
List-box border color.
COLORREF | m_clrItemText
List-box item normal text color.
COLORREF | m_clrItemTextHighlight
List-box item highlighted text color.
COLORREF | m_clrItemTextSelected
List-box item selected text color.
COLORREF | m_clrItemBack
List-box item normal background color.
COLORREF | m_clrItemBackHighlight
List-box item highlighted background color.
COLORREF | m_clrItemBackSelected
List-box item selected background color.
COLORREF | m_clrItemBorder
List-box item normal border color.
COLORREF | m_clrItemBorderHighlight
List-box item highlighted border color.
COLORREF | m_clrItemBorderSelected
List-box item selected border color.

Detailed Description

CXTPListBoxThemeOffice2013 is used by CXTPListBox to draw an Office 2013 style list box.

Member Function Documentation

◆ DrawItem()

virtual void DrawItem | ( | CDC * | pDC,
 |  | CXTPListBox * | pListBox,
 |  | LPDRAWITEMSTRUCT | lpDIS )
 virtual

This method is called to draw the CXTPListBox object.

Parameters
pDC | Pointer to a valid device context.
pListBox | Pointer to a valid CXTPListBox object.
lpDIS | A long pointer to a DRAWITEMSTRUCT structure. The structure contains information about the item to be drawn and the type of drawing required.

Implements CXTPListBoxTheme.

◆ DrawNcBorders()

virtual BOOL DrawNcBorders | ( | CDC * | pDC,
 |  | CRect | rc )
 virtual

Call this member function to draw the list control borders.

Parameters
pDC | Pointer to a valid device context.
rc | Size of the area to draw.
Returns
TRUE if non-client border drawing is handled, otherwise FALSE.

Reimplemented from CXTPListBoxTheme.

◆ GetBackColor()

virtual COLORREF GetBackColor ( )
virtual

Called to retrieve the background color for the listbox.

Returns
An RGB value representing the background color.

Reimplemented from CXTPListBoxTheme.

The documentation for this class was generated from the following file:
  • XTPListBoxThemeOffice2013.h


Toolkit Pro: CXTPListBoxThemeOfficeXP Class Reference

Public Member Functions | List of all members
CXTPListBoxThemeOfficeXP Class Reference

CXTPListBoxThemeOfficeXP is used by CXTPListBox to draw an Office XP style list box. More...

Inheritance diagram for CXTPListBoxThemeOfficeXP:
[legend]

Public Member Functions

virtual void | DrawItem (CDC *pDC, CXTPListBox *pListBox, LPDRAWITEMSTRUCT lpDIS)
This method is called to draw the CXTPListBox object.
virtual void | RefreshMetrics ()
Called to update the colors and metrics used to draw the CXTPListBox object.
- Public Member Functions inherited from CXTPListBoxTheme
virtual | ~CXTPListBoxTheme ()
Handles theme destruction.
virtual void | DrawItemText (CDC *pDC, CRect rcText, CXTPListBox *pListBox, LPDRAWITEMSTRUCT lpDIS)
This method is called to draw text for the CXTPListBox object.
virtual COLORREF | GetBackColor ()
Called to retrieve the background color for the list box.
virtual BOOL | DrawNcBorders (CDC *pDC, CRect rc)
Call this member function to draw the list control borders.

Detailed Description

CXTPListBoxThemeOfficeXP is used by CXTPListBox to draw an Office XP style list box.

Member Function Documentation

◆ DrawItem()

virtual void DrawItem | ( | CDC * | pDC,
 |  | CXTPListBox * | pListBox,
 |  | LPDRAWITEMSTRUCT | lpDIS )
 virtual

This method is called to draw the CXTPListBox object.

Parameters
pDC | Pointer to a valid device context.
pListBox | Pointer to a valid CXTPListBox object.
lpDIS | A long pointer to a DRAWITEMSTRUCT structure. The structure contains information about the item to be drawn and the type of drawing required.

Implements CXTPListBoxTheme.

Reimplemented in CXTPListBoxThemeOffice2003.

The documentation for this class was generated from the following file:
  • XTPListBoxThemeOfficeXP.h


Toolkit Pro: CXTPListBoxThemeResource Class Reference

Public Member Functions | List of all members
CXTPListBoxThemeResource Class Reference

CXTPListBoxThemeResource is used by CXTPListBox to draw a resource style list box. More...

Inheritance diagram for CXTPListBoxThemeResource:
[legend]

Public Member Functions

virtual void | DrawItem (CDC *pDC, CXTPListBox *pListBox, LPDRAWITEMSTRUCT lpDIS)
This method is called to draw the CXTPListBox object.
virtual void | RefreshMetrics ()
Called to update the colors and metrics used to draw the CXTPListBox object.
- Public Member Functions inherited from CXTPListBoxTheme
virtual | ~CXTPListBoxTheme ()
Handles theme destruction.
virtual void | DrawItemText (CDC *pDC, CRect rcText, CXTPListBox *pListBox, LPDRAWITEMSTRUCT lpDIS)
This method is called to draw text for the CXTPListBox object.
virtual COLORREF | GetBackColor ()
Called to retrieve the background color for the list box.
virtual BOOL | DrawNcBorders (CDC *pDC, CRect rc)
Call this member function to draw the list control borders.

Detailed Description

CXTPListBoxThemeResource is used by CXTPListBox to draw a resource style list box.

Member Function Documentation

◆ DrawItem()

virtual void DrawItem | ( | CDC * | pDC,
 |  | CXTPListBox * | pListBox,
 |  | LPDRAWITEMSTRUCT | lpDIS )
 virtual

This method is called to draw the CXTPListBox object.

Parameters
pDC | Pointer to a valid device context.
pListBox | Pointer to a valid CXTPListBox object.
lpDIS | A long pointer to a DRAWITEMSTRUCT structure. The structure contains information about the item to be drawn and the type of drawing required.

Implements CXTPListBoxTheme.

The documentation for this class was generated from the following file:
  • XTPListBoxThemeResource.h


Toolkit Pro: CXTPListBoxThemeVisualStudio2015 Class Reference

Public Member Functions | List of all members
CXTPListBoxThemeVisualStudio2015 Class Reference

CXTPListBoxThemeVisualStudio2015 is used by CXTPListBox to draw a Visual Studio 2015 style list box. More...

Inheritance diagram for CXTPListBoxThemeVisualStudio2015:
[legend]

Public Member Functions

CXTPListBoxThemeVisualStudio2015 ()
Default constructor.
- Public Member Functions inherited from CXTPListBoxThemeOffice2013
CXTPListBoxThemeOffice2013 ()
Default constructor.
virtual void | DrawItem (CDC *pDC, CXTPListBox *pListBox, LPDRAWITEMSTRUCT lpDIS)
This method is called to draw the CXTPListBox object.
virtual void | RefreshMetrics ()
Called to update the colors and metrics used to draw the CXTPListBox object.
virtual COLORREF | GetBackColor ()
Called to retrieve the background color for the listbox.
virtual BOOL | DrawNcBorders (CDC *pDC, CRect rc)
Call this member function to draw the list control borders.
- Public Member Functions inherited from CXTPListBoxTheme
virtual | ~CXTPListBoxTheme ()
Handles theme destruction.
virtual void | DrawItemText (CDC *pDC, CRect rcText, CXTPListBox *pListBox, LPDRAWITEMSTRUCT lpDIS)
This method is called to draw text for the CXTPListBox object.

Additional Inherited Members

- Public Attributes inherited from CXTPListBoxThemeOffice2013
COLORREF | m_clrBack
List-box background color.
COLORREF | m_clrBorder
List-box border color.
COLORREF | m_clrItemText
List-box item normal text color.
COLORREF | m_clrItemTextHighlight
List-box item highlighted text color.
COLORREF | m_clrItemTextSelected
List-box item selected text color.
COLORREF | m_clrItemBack
List-box item normal background color.
COLORREF | m_clrItemBackHighlight
List-box item highlighted background color.
COLORREF | m_clrItemBackSelected
List-box item selected background color.
COLORREF | m_clrItemBorder
List-box item normal border color.
COLORREF | m_clrItemBorderHighlight
List-box item highlighted border color.
COLORREF | m_clrItemBorderSelected
List-box item selected border color.

Detailed Description

CXTPListBoxThemeVisualStudio2015 is used by CXTPListBox to draw a Visual Studio 2015 style list box.

The documentation for this class was generated from the following file:
  • XTPListBoxThemeVisualStudio2015.h


Toolkit Pro: CXTPListBoxThemeVisualStudio2017 Class Reference

Public Member Functions | List of all members
CXTPListBoxThemeVisualStudio2017 Class Reference

CXTPListBoxThemeVisualStudio2017 is used by CXTPListBox to draw a Visual Studio 2017 style list box. More...

Inheritance diagram for CXTPListBoxThemeVisualStudio2017:
[legend]

Public Member Functions

CXTPListBoxThemeVisualStudio2017 ()
Default constructor.
- Public Member Functions inherited from CXTPListBoxThemeOffice2013
CXTPListBoxThemeOffice2013 ()
Default constructor.
virtual void | DrawItem (CDC *pDC, CXTPListBox *pListBox, LPDRAWITEMSTRUCT lpDIS)
This method is called to draw the CXTPListBox object.
virtual void | RefreshMetrics ()
Called to update the colors and metrics used to draw the CXTPListBox object.
virtual COLORREF | GetBackColor ()
Called to retrieve the background color for the listbox.
virtual BOOL | DrawNcBorders (CDC *pDC, CRect rc)
Call this member function to draw the list control borders.
- Public Member Functions inherited from CXTPListBoxTheme
virtual | ~CXTPListBoxTheme ()
Handles theme destruction.
virtual void | DrawItemText (CDC *pDC, CRect rcText, CXTPListBox *pListBox, LPDRAWITEMSTRUCT lpDIS)
This method is called to draw text for the CXTPListBox object.

Additional Inherited Members

- Public Attributes inherited from CXTPListBoxThemeOffice2013
COLORREF | m_clrBack
List-box background color.
COLORREF | m_clrBorder
List-box border color.
COLORREF | m_clrItemText
List-box item normal text color.
COLORREF | m_clrItemTextHighlight
List-box item highlighted text color.
COLORREF | m_clrItemTextSelected
List-box item selected text color.
COLORREF | m_clrItemBack
List-box item normal background color.
COLORREF | m_clrItemBackHighlight
List-box item highlighted background color.
COLORREF | m_clrItemBackSelected
List-box item selected background color.
COLORREF | m_clrItemBorder
List-box item normal border color.
COLORREF | m_clrItemBorderHighlight
List-box item highlighted border color.
COLORREF | m_clrItemBorderSelected
List-box item selected border color.

Detailed Description

CXTPListBoxThemeVisualStudio2017 is used by CXTPListBox to draw a Visual Studio 2017 style list box.

The documentation for this class was generated from the following file:
  • XTPListBoxThemeVisualStudio2017.h


Toolkit Pro: CXTPListBoxThemeVisualStudio2019 Class Reference

Public Member Functions | List of all members
CXTPListBoxThemeVisualStudio2019 Class Reference

CXTPListBoxThemeVisualStudio2019 is used by CXTPListBox to draw a Visual Studio 2019 style list box. More...

Inheritance diagram for CXTPListBoxThemeVisualStudio2019:
[legend]

Public Member Functions

CXTPListBoxThemeVisualStudio2019 ()
Default constructor.
- Public Member Functions inherited from CXTPListBoxThemeOffice2013
CXTPListBoxThemeOffice2013 ()
Default constructor.
virtual void | DrawItem (CDC *pDC, CXTPListBox *pListBox, LPDRAWITEMSTRUCT lpDIS)
This method is called to draw the CXTPListBox object.
virtual void | RefreshMetrics ()
Called to update the colors and metrics used to draw the CXTPListBox object.
virtual COLORREF | GetBackColor ()
Called to retrieve the background color for the listbox.
virtual BOOL | DrawNcBorders (CDC *pDC, CRect rc)
Call this member function to draw the list control borders.
- Public Member Functions inherited from CXTPListBoxTheme
virtual | ~CXTPListBoxTheme ()
Handles theme destruction.
virtual void | DrawItemText (CDC *pDC, CRect rcText, CXTPListBox *pListBox, LPDRAWITEMSTRUCT lpDIS)
This method is called to draw text for the CXTPListBox object.

Additional Inherited Members

- Public Attributes inherited from CXTPListBoxThemeOffice2013
COLORREF | m_clrBack
List-box background color.
COLORREF | m_clrBorder
List-box border color.
COLORREF | m_clrItemText
List-box item normal text color.
COLORREF | m_clrItemTextHighlight
List-box item highlighted text color.
COLORREF | m_clrItemTextSelected
List-box item selected text color.
COLORREF | m_clrItemBack
List-box item normal background color.
COLORREF | m_clrItemBackHighlight
List-box item highlighted background color.
COLORREF | m_clrItemBackSelected
List-box item selected background color.
COLORREF | m_clrItemBorder
List-box item normal border color.
COLORREF | m_clrItemBorderHighlight
List-box item highlighted border color.
COLORREF | m_clrItemBorderSelected
List-box item selected border color.

Detailed Description

CXTPListBoxThemeVisualStudio2019 is used by CXTPListBox to draw a Visual Studio 2019 style list box.

The documentation for this class was generated from the following file:
  • XTPListBoxThemeVisualStudio2019.h


Toolkit Pro: CXTPListBoxThemeVisualStudio2022 Class Reference

Public Member Functions | List of all members
CXTPListBoxThemeVisualStudio2022 Class Reference

CXTPListBoxThemeVisualStudio2022 is used by CXTPListBox to draw a Visual Studio 2022 style list box. More...

Inheritance diagram for CXTPListBoxThemeVisualStudio2022:
[legend]

Public Member Functions

CXTPListBoxThemeVisualStudio2022 ()
Default constructor.
- Public Member Functions inherited from CXTPListBoxThemeOffice2013
CXTPListBoxThemeOffice2013 ()
Default constructor.
virtual void | DrawItem (CDC *pDC, CXTPListBox *pListBox, LPDRAWITEMSTRUCT lpDIS)
This method is called to draw the CXTPListBox object.
virtual void | RefreshMetrics ()
Called to update the colors and metrics used to draw the CXTPListBox object.
virtual COLORREF | GetBackColor ()
Called to retrieve the background color for the listbox.
virtual BOOL | DrawNcBorders (CDC *pDC, CRect rc)
Call this member function to draw the list control borders.
- Public Member Functions inherited from CXTPListBoxTheme
virtual | ~CXTPListBoxTheme ()
Handles theme destruction.
virtual void | DrawItemText (CDC *pDC, CRect rcText, CXTPListBox *pListBox, LPDRAWITEMSTRUCT lpDIS)
This method is called to draw text for the CXTPListBox object.

Additional Inherited Members

- Public Attributes inherited from CXTPListBoxThemeOffice2013
COLORREF | m_clrBack
List-box background color.
COLORREF | m_clrBorder
List-box border color.
COLORREF | m_clrItemText
List-box item normal text color.
COLORREF | m_clrItemTextHighlight
List-box item highlighted text color.
COLORREF | m_clrItemTextSelected
List-box item selected text color.
COLORREF | m_clrItemBack
List-box item normal background color.
COLORREF | m_clrItemBackHighlight
List-box item highlighted background color.
COLORREF | m_clrItemBackSelected
List-box item selected background color.
COLORREF | m_clrItemBorder
List-box item normal border color.
COLORREF | m_clrItemBorderHighlight
List-box item highlighted border color.
COLORREF | m_clrItemBorderSelected
List-box item selected border color.

Detailed Description

CXTPListBoxThemeVisualStudio2022 is used by CXTPListBox to draw a Visual Studio 2022 style list box.

The documentation for this class was generated from the following file:
  • XTPListBoxThemeVisualStudio2022.h


Toolkit Pro: CXTPListCtrl Class Reference

Public Member Functions | List of all members
CXTPListCtrl Class Reference

CXTPListCtrl is a multiple inheritance class derived from CListCtrl and CXTPListBase. More...

Public Member Functions

CXTPListCtrl ()
Constructs a CXTPListCtrl object.
virtual ~CXTPListCtrl ()
Destroys a CXTPListCtrl object, handles cleanup and deallocation.

Detailed Description

CXTPListCtrl is a multiple inheritance class derived from CListCtrl and CXTPListBase.

This class implements a flat header and generic sorting routines. See CXTPListBase for additional functionality.

See also
CXTPListBase
The documentation for this class was generated from the following file:
  • XTPListCtrlView.h


Toolkit Pro: CXTPListView Class Reference

Public Member Functions | List of all members
CXTPListView Class Reference

CXTPListView is a multiple inheritance class derived from CListView and CXTPListBase. More...

Public Member Functions

CXTPListView ()
Constructs a CXTPListView object.
virtual ~CXTPListView ()
Destroys a CXTPListView object, handles cleanup and deallocation.

Detailed Description

CXTPListView is a multiple inheritance class derived from CListView and CXTPListBase.

This class implements a flat header and generic sorting routines.

See also
CXTPListBase
The documentation for this class was generated from the following file:
  • XTPListCtrlView.h


Toolkit Pro: CXTPLockGuard Class Reference

Public Member Functions | List of all members
CXTPLockGuard Class Reference

Critical Sections Lock/Unlock helper. More...

Public Member Functions

CXTPLockGuard (CRITICAL_SECTION &key)
Constructs a CXTPLockGuard object.
~CXTPLockGuard ()
Destroys a CXTPCriticalSection object, handles cleanup and deallocation.
void | LockThread ()
This method call EnterCritical of key object.
void | UnLockThread ()
This method call LeaveCritical of key object.

Detailed Description

Critical Sections Lock/Unlock helper.

Constructor & Destructor Documentation

◆ CXTPLockGuard()

CXTPLockGuard ( CRITICAL_SECTION & key )

Constructs a CXTPLockGuard object.

Parameters
key CRITICAL_SECTION used to lock thread
The documentation for this class was generated from the following file:
  • XTPSystemHelpers.h


Toolkit Pro: CXTPLogFont Class Reference

Public Member Functions | Public Attributes | List of all members
CXTPLogFont Class Reference

CXTPLogFont is a self initializing LOGFONT derived class. More...

Public Member Functions

CXTPLogFont ()
Constructs a CXTPLogFont object.
CXTPLogFont (const CXTPLogFont &rhs)
Constructs a CXTPLogFont object.
CXTPLogFont (const LOGFONT &logFont)
Constructs a CXTPLogFont object.
CXTPLogFont & | operator= (const CXTPLogFont &rhs)
Assigns the specified value.
CXTPLogFont & | operator= (const LOGFONT &logFont)
Assigns the specified value.

Public Attributes

DWORD dwType
Used to hold the font type, i.e.

Detailed Description

CXTPLogFont is a self initializing LOGFONT derived class.

It will allow you to create or copy a LOGFONT object, and defines the attributes of a font.

Constructor & Destructor Documentation

◆ CXTPLogFont() [1/2]

CXTPLogFont ( const CXTPLogFont & rhs )

Constructs a CXTPLogFont object.

Parameters
rhs The CXTPLogFont object to copy from.

◆ CXTPLogFont() [2/2]

CXTPLogFont ( const LOGFONT & logFont )

Constructs a CXTPLogFont object.

Parameters
logFont The LOGFONT structure to initialize the class object with.

Member Function Documentation

◆ operator=() [1/2]

CXTPLogFont & operator= ( const CXTPLogFont & rhs )

Assigns the specified value.

Returns
A reference to itself.
Parameters
rhs The CXTPLogFont object to copy from.

◆ operator=() [2/2]

CXTPLogFont & operator= ( const LOGFONT & logFont )

Assigns the specified value.

Returns
A reference to itself.
Parameters
logFont The LOGFONT structure to copy from.

Member Data Documentation

◆ dwType

DWORD dwType

Used to hold the font type, i.e.

TT_FONT, DEVICE_FONT.

The documentation for this class was generated from the following file:
  • XTPGlobal.h


Toolkit Pro: CXTPMarkupBorder Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPMarkupBorder Class Reference

CXTPMarkupBorder is a CXTPMarkupDecorator derived class. More...

Inheritance diagram for CXTPMarkupBorder:
[legend]

Public Member Functions

void | SetPadding (int nLeft, int nTop, int nRight, int nBottom)
Sets a value that indicates the thickness of the padding space between the boundaries of the content area and the content displayed by a border.
void | SetPadding (int nPadding)
Sets a value that indicates the thickness of the padding space between the boundaries of the content area and the content displayed by a border.
CXTPMarkupThickness * | GetPadding () const
Retrieves a value that indicates the thickness of the padding space between the boundaries of the content area and the content displayed by a border.
void | SetBorderThickness (int nLeft, int nTop, int nRight, int nBottom)
Sets the thickness of the border.
void | SetBorderThickness (int nBorderThickness)
Sets the thickness of the border.
CXTPMarkupThickness * | GetBorderThickness () const
Gets the thickness of the border.
void | SetBackground (CXTPMarkupBrush *pBrush)
Sets the background brush for the border object.
CXTPMarkupBrush * | GetBackground () const
Gets the background brush of the border object.
void | SetBorderBrush (CXTPMarkupBrush *pBrush)
Sets the border brush for the border object.
CXTPMarkupBrush * | GetBorderBrush () const
Gets the border brush of the border object.
void | SetCornerRadius (int nCornerRadius)
Sets the corner radius for the border.
CXTPMarkupThickness * | GetCornerRadius () const
Gets the corner radius of the border.
CSize | GetSize () const
Gets the total horizontal and vertical size of the padding, border, and margin.
- Public Member Functions inherited from CXTPMarkupDecorator
void | SetChild (CXTPMarkupUIElement *pChild)
Sets a new child object for the decorator element.
CXTPMarkupUIElement * | GetChild () const
Retrieves the child object of the decorator element.
- Public Member Functions inherited from CXTPMarkupFrameworkElement
void | SetMargin (int nLeft, int nTop, int nRight, int nBottom)
Call this method to set the outer margin of an element.
void | SetMargin (int nMargin)
Call this method to set the outer margin of an element.
CXTPMarkupThickness * | GetMargin () const
Call this method to get the outer margin of an element.
void | SetMinWidth (int nWidth)
Sets the minimum width constraint for the element.
void | SetMaxWidth (int nWidth)
Sets the maximum width constraint for the element.
void | SetWidth (int nWidth)
Sets the width for the element.
void | SetMinHeight (int nHeight)
Sets the minimum height constraint for the element.
void | SetMaxHeight (int nHeight)
Sets the maximum height constraint for the element.
void | SetHeight (int nHeight)
Sets the height for the element.
int | GetMinWidth () const
Gets the minimum width constraint of the element.
int | GetMaxWidth () const
Gets the maximum width constraint of the element.
int | GetWidth () const
Gets the width of the element.
int | GetMinHeight () const
Gets the minimum height constraint of the element.
int | GetMaxHeight () const
Gets the maximum height constraint of the element.
int | GetHeight () const
Gets the height of the element.
CXTPMarkupObject * | GetTag () const
Gets the tag object of the element.
void | SetTag (CXTPMarkupObject *pTag)
Sets the tag object for the element.
void | SetHorizontalAlignment (XTPMarkupHorizontalAlignment alignment)
Sets the horizontal alignment characteristics applied to this element when it is composed within a parent element (e.g.
void | SetVerticalAlignment (XTPMarkupVerticalAlignment alignment)
Sets the vertical alignment characteristics applied to this element when it is composed within a parent element (e.g.
XTPMarkupHorizontalAlignment | GetHorizontalAlignment () const
Gets the horizontal alignment characteristics applied to this element when it is composed within a parent element (e.g.
XTPMarkupVerticalAlignment | GetVerticalAlignment () const
Gets the vertical alignment characteristics applied to this element when it is composed within a parent element (e.g.
CSize | GetActualSize () const
Retrieves the actual size of the element after it is measured and arranged within a parent element (e.g.
void | SetClipToBounds (BOOL bClipToBounds)
Specifies if child elements should be clipped inside element bounds.
BOOL | GetClipToBounds () const
Determines if child elements are clipped inside element bounds.
CXTPMarkupStyle * | GetStyle () const
Gets the attached style of the element.
- Public Member Functions inherited from CXTPMarkupUIElement
void | Arrange (CRect rcFinalRect)
Positions child elements and determines a size for a CXTPMarkupUIElement.
void | Measure (CXTPMarkupDrawingContext *pDC, CSize szAvailableSize)
Updates the DesiredSize of a CXTPMarkupUIElement.
CSize | GetDesiredSize () const
Gets the size that this element computed during the measure pass of the layout process.
CRect | GetFinalRect () const
Gets the final render size of this element.
XTPMarkupVisibility | GetVisibility () const
Gets the user interface (UI) visibility of this element.
void | SetVisibility (XTPMarkupVisibility visibility)
Sets the user interface (UI) visibility of this element.
BOOL | IsFocusable () const
Gets or sets a value indicating whether this element can receive focus.
virtual BOOL | IsVisible () const
Gets a value indicating whether this element is visible in the user interface (UI).
BOOL | IsEnabled () const
Gets or sets a value indicating whether this element is enabled in the user interface (UI).
virtual void | InvalidateArrange ()
Invalidates the arrange state (layout) for the element.
virtual void | InvalidateVisual ()
Invalidates the rendering of the element, and forces a new complete layout pass.
virtual void | InvalidateMeasure ()
Invalidates the measurement state (layout) for the element.
- Public Member Functions inherited from CXTPMarkupVisual
CXTPMarkupVisual ()
Provides the base initialization for objects derived from the CXTPMarkupVisual class.
virtual | ~CXTPMarkupVisual ()
Destroys a CXTPMarkupVisual object, handles cleanup and deallocation.
void | Render (CXTPMarkupDrawingContext *drawingContext)
Call this method to draw a Visual object inside a drawing context.
CXTPMarkupInputElement * | InputHitTest (CPoint point) const
Determines if a point belongs to this object.
virtual int | GetVisualChildrenCount () const
Gets the number of child elements for the Visual.
virtual CXTPMarkupVisual * | GetVisualChild (int nIndex) const
Retrieves the child Visual object located at a specified index within the parent VisualCollection.
virtual int | GetLogicalChildrenCount () const
Retrieves the number of logical child elements of this object.
virtual CXTPMarkupObject * | GetLogicalChild (int nIndex) const
Retrieves the logical child element located at a specified index within the parent collection.
CRect | GetBoundRect () const
Retrieves the bounding rectangle of the element.
CRect | GetUpdateRect () const
Computes the update rectangle.
CSize | GetRenderSize () const
Gets the final render size of this element.
CPoint | GetVisualOffset () const
Gets or sets the offset value of the visual object.
CXTPMarkupVisual * | GetVisualParent () const
Gets the Visual tree parent of the Visual object.

Protected Member Functions

CXTPMarkupBorder ()
Constructs a CXTPMarkupBorder object.
virtual | ~CXTPMarkupBorder ()
Destroys a CXTPMarkupBorder object, handles cleanup and deallocation.
- Protected Member Functions inherited from CXTPMarkupDecorator
CXTPMarkupDecorator ()
Constructs a CXTPMarkupDecorator object.
virtual | ~CXTPMarkupDecorator ()
Destroys a CXTPMarkupDecorator object, handles cleanup and deallocation.
- Protected Member Functions inherited from CXTPMarkupFrameworkElement
CXTPMarkupFrameworkElement ()
Initializes a new instance of the CXTPMarkupFrameworkElement class.
virtual | ~CXTPMarkupFrameworkElement ()
Destroys a CXTPMarkupFrameworkElement object, handles cleanup and deallocation.
- Protected Member Functions inherited from CXTPMarkupUIElement
CXTPMarkupUIElement ()
Initializes a new instance of the CXTPMarkupUIElement class.
virtual | ~CXTPMarkupUIElement ()
Destroys a CXTPMarkupUIElement object, handles cleanup and deallocation.
CXTPMarkupRenderTransform * | GetRenderTransform () const
Obtains a pointer to the RenderTransform object.
virtual void | ArrangeCore (CRect rcFinalRect)
Defines the template for the core-level arrange layout definition.
virtual CSize | MeasureCore (CXTPMarkupDrawingContext *pDC, CSize szAvailableSize)
When overridden in a derived class, provides measurement logic for sizing this element properly with consideration of the size of any child element content.
virtual BOOL | GetLayoutClip (CRect &rc) const
Retrieves an alternative clipping geometry that represents the region that would be clipped if child elements were clipped inside element bounds.
virtual void | InvalidateMeasureOverride (CXTPMarkupDrawingContext *pDC)
Override this method to provide a custom reaction to an InvalidateMeasure call.
virtual TransformationMatrices | ApplyRenderTransform (CXTPMarkupDrawingContext *pContext)
Applies render transformation if necessary.
virtual void | RestoreRenderTransform (CXTPMarkupDrawingContext *pContext, TransformationMatrices &matrices)
Restores a previously applied render transformation.
virtual double | GetOpacity () const
Gets either the default or explicitly set opacity factor value.
- Protected Member Functions inherited from CXTPMarkupVisual
BOOL | PtInRectTransform (const RECT &rect, const POINT &point) const
Checks if a point is inside a rectangle with transformation applied.
POINT | GetAbsoluteVisualOffset () const
Gets the absolute element visual offset.
virtual void | OnRender (CXTPMarkupDrawingContext *drawingContext)
When overridden in a derived class, participates in rendering operations that are directed by the layout system.
virtual void | OnRenderFocusVisual (CXTPMarkupDrawingContext *drawingContext)
This method is called to render the focus rectangle of a focused object.
virtual CXTPMarkupInputElement * | InputHitTestOverride (CPoint point) const
Override this method in the derived class to provide visual hit testing of a child object.
virtual void | RenderClipped (CXTPMarkupDrawingContext *drawingContext)
Called by the framework when an element is clipped and no rendering will occur.

Additional Inherited Members

- Static Public Attributes inherited from CXTPMarkupUIElement
static CXTPMarkupDependencyProperty * | m_pClipToBoundsProperty
Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element.
static CXTPMarkupDependencyProperty * | m_pVisibilityProperty
A value indicating whether this element is visible in the user interface (UI).
static CXTPMarkupDependencyProperty * | m_pFocusableProperty
A value that indicates whether the element can receive focus.
static CXTPMarkupDependencyProperty * | m_pIsEnabledProperty
A value indicating whether thiselement is enabled in the user interface (UI).
static CXTPMarkupDependencyProperty * | m_pRenderTransformProperty
Gets or sets transform information that affects the rendering position of this element.
static CXTPMarkupDependencyProperty * | m_pRenderTransformOriginProperty
Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element.
static CXTPMarkupDependencyProperty * | m_pOpacityProperty
Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI).
- Protected Attributes inherited from CXTPMarkupUIElement
CSize | m_szDesiredSize
Gets the size that this element computed during the measure pass of the layout process.
CRect | m_rcFinalRect
Final position of the visual element.
BOOL | m_bMeasureDirty
TRUE if object hasn't recalculated its size.
BOOL | m_bNeverMeasured
TRUE if object has never ran Measure to update its size.
CSize | m_szPreviousAvailableSize
Previous available size of measure call.
BOOL | m_bArrangeDirty
TRUE if object position can be invalid.
BOOL | m_bNeverArranged
TRUE if Arrange was never called for this object.
BOOL | m_bArrangeInProgress
TRUE if Arrange is currently executed.
BOOL | m_bMeasureInProgress
TRUE if Measure is currently executed.
- Protected Attributes inherited from CXTPMarkupVisual
CPoint | m_ptVisualOffset
The offset value of the visual object.
CSize | m_szRenderSize
The rendered size for this element.
CRect | m_rcBoundRect
Bounding rectangle of the element.
CRect | m_rcUpdateRect
Update rectangle.
CRect | m_rcPrevUpdateRect
Previous update rectangle.

Detailed Description

CXTPMarkupBorder is a CXTPMarkupDecorator derived class.

It implements the Border XAML Tag.

Member Function Documentation

◆ GetBackground()

CXTPMarkupBrush * GetBackground ( ) const

Gets the background brush of the border object.

Returns
A pointer to the background brush of the border object.

◆ GetBorderBrush()

CXTPMarkupBrush * GetBorderBrush ( ) const

Gets the border brush of the border object.

Returns
A pointer to the border brush of the border object.

◆ GetBorderThickness()

CXTPMarkupThickness * GetBorderThickness ( ) const

Gets the thickness of the border.

Returns
A pointer to a CXTPMarkupThickness object containing border widths.
See also
SetBorderThickness

◆ GetCornerRadius()

CXTPMarkupThickness * GetCornerRadius ( ) const

Gets the corner radius of the border.

Returns
A pointer to a CXTPMarkupThickness object containing the corner radius of the border.
See also
SetCornerRadius

◆ GetPadding()

CXTPMarkupThickness * GetPadding ( ) const

Retrieves a value that indicates the thickness of the padding space between the boundaries of the content area and the content displayed by a border.

Returns
A pointer to a CXTPMarkupThickness object that indicates the thickness of the padding space between the boundaries of the content area and the content displayed by a border.
See also
SetPadding

◆ GetSize()

CSize GetSize ( ) const

Gets the total horizontal and vertical size of the padding, border, and margin.

Returns
A CSize object containing the total horizontal and vertical size of the padding, border, and margin.

◆ SetBackground()

void SetBackground ( CXTPMarkupBrush * pBrush )

Sets the background brush for the border object.

Parameters
pBrush Pointer to a CBrush object.

◆ SetBorderBrush()

void SetBorderBrush ( CXTPMarkupBrush * pBrush )

Sets the border brush for the border object.

Parameters
pBrush Pointer to a CBrush object.

◆ SetBorderThickness() [1/2]

void SetBorderThickness ( int nBorderThickness )

Sets the thickness of the border.

Parameters
nBorderThickness Thickness for all borders.

◆ SetBorderThickness() [2/2]

void SetBorderThickness | ( | int | nLeft,
 |  | int | nTop,
 |  | int | nRight,
 |  | int | nBottom )

Sets the thickness of the border.

Parameters
nLeft | Left border width.
nTop | Top border width.
nRight | Right border width.
nBottom | Bottom border width.

◆ SetCornerRadius()

void SetCornerRadius ( int nCornerRadius )

Sets the corner radius for the border.

Parameters
nCornerRadius New corner radius for the border.

◆ SetPadding() [1/2]

void SetPadding | ( | int | nLeft,
 |  | int | nTop,
 |  | int | nRight,
 |  | int | nBottom )

Sets a value that indicates the thickness of the padding space between the boundaries of the content area and the content displayed by a border.

Parameters
nLeft | Left space.
nTop | Top space.
nRight | Right space.
nBottom | Bottom space.

◆ SetPadding() [2/2]

void SetPadding ( int nPadding )

Sets a value that indicates the thickness of the padding space between the boundaries of the content area and the content displayed by a border.

Parameters
nPadding All borders.
The documentation for this class was generated from the following file:
  • XTPMarkupBorder.h


Toolkit Pro: CXTPMarkupButton Class Reference

Protected Member Functions | List of all members
CXTPMarkupButton Class Reference

CXTPMarkupButton is a CXTPMarkupButtonBase derived class. More...

Inheritance diagram for CXTPMarkupButton:
[legend]

Protected Member Functions

CXTPMarkupButton ()
Constructs a CXTPMarkupButton object.
virtual | ~CXTPMarkupButton ()
Destroys a CXTPMarkupButton object, handles cleanup and deallocation.
- Protected Member Functions inherited from CXTPMarkupButtonBase
CXTPMarkupButtonBase ()
Constructs a CXTPMarkupButtonBase object.
~CXTPMarkupButtonBase ()
Destroys a CXTPMarkupButtonBase object, handles cleanup and deallocation.
virtual void | OnClick ()
Virtual method called when the user clicks the button.
- Protected Member Functions inherited from CXTPMarkupContentControl
CXTPMarkupContentControl ()
Constructs a CXTPMarkupContentControl object.
virtual | ~CXTPMarkupContentControl ()
Destroys a CXTPMarkupContentControl object, handles cleanup and deallocation.
- Protected Member Functions inherited from CXTPMarkupFrameworkElement
CXTPMarkupFrameworkElement ()
Initializes a new instance of the CXTPMarkupFrameworkElement class.
virtual | ~CXTPMarkupFrameworkElement ()
Destroys a CXTPMarkupFrameworkElement object, handles cleanup and deallocation.
- Protected Member Functions inherited from CXTPMarkupUIElement
CXTPMarkupUIElement ()
Initializes a new instance of the CXTPMarkupUIElement class.
virtual | ~CXTPMarkupUIElement ()
Destroys a CXTPMarkupUIElement object, handles cleanup and deallocation.
CXTPMarkupRenderTransform * | GetRenderTransform () const
Obtains a pointer to the RenderTransform object.
virtual void | ArrangeCore (CRect rcFinalRect)
Defines the template for the core-level arrange layout definition.
virtual CSize | MeasureCore (CXTPMarkupDrawingContext *pDC, CSize szAvailableSize)
When overridden in a derived class, provides measurement logic for sizing this element properly with consideration of the size of any child element content.
virtual BOOL | GetLayoutClip (CRect &rc) const
Retrieves an alternative clipping geometry that represents the region that would be clipped if child elements were clipped inside element bounds.
virtual void | InvalidateMeasureOverride (CXTPMarkupDrawingContext *pDC)
Override this method to provide a custom reaction to an InvalidateMeasure call.
virtual TransformationMatrices | ApplyRenderTransform (CXTPMarkupDrawingContext *pContext)
Applies render transformation if necessary.
virtual void | RestoreRenderTransform (CXTPMarkupDrawingContext *pContext, TransformationMatrices &matrices)
Restores a previously applied render transformation.
virtual double | GetOpacity () const
Gets either the default or explicitly set opacity factor value.
- Protected Member Functions inherited from CXTPMarkupVisual
BOOL | PtInRectTransform (const RECT &rect, const POINT &point) const
Checks if a point is inside a rectangle with transformation applied.
POINT | GetAbsoluteVisualOffset () const
Gets the absolute element visual offset.
virtual void | OnRender (CXTPMarkupDrawingContext *drawingContext)
When overridden in a derived class, participates in rendering operations that are directed by the layout system.
virtual void | OnRenderFocusVisual (CXTPMarkupDrawingContext *drawingContext)
This method is called to render the focus rectangle of a focused object.
virtual CXTPMarkupInputElement * | InputHitTestOverride (CPoint point) const
Override this method in the derived class to provide visual hit testing of a child object.
virtual void | RenderClipped (CXTPMarkupDrawingContext *drawingContext)
Called by the framework when an element is clipped and no rendering will occur.

Additional Inherited Members

- Public Member Functions inherited from CXTPMarkupButtonBase
BOOL | IsPressed () const
Determines if the button is currently pressed.
- Public Member Functions inherited from CXTPMarkupContentControl
CXTPMarkupUIElement * | GetContent () const
Gets the child object of the ControlContent element.
void | SetContent (CXTPMarkupUIElement *pContent)
Sets the child object for the ControlContent element.
- Public Member Functions inherited from CXTPMarkupControl
void | SetPadding (int nLeft, int nTop, int nRight, int nBottom)
Sets a value that indicates the thickness of the padding space between the boundaries of the content area and the content displayed by a control.
void | SetPadding (int nPadding)
Sets a value that indicates the thickness of the padding space between the boundaries of the content area and the content displayed by a control.
CXTPMarkupThickness * | GetPadding () const
Retrieves a value that indicates the thickness of the padding space between the boundaries of the content area and the content displayed by a control.
void | SetBackground (CXTPMarkupBrush *pBrush)
Sets the background brush for the control object.
CXTPMarkupBrush * | GetBackground () const
Gets the background brush of the control object.
void | SetForeground (CXTPMarkupBrush *pBrush)
Sets the default text brush for the control object.
CXTPMarkupBrush * | GetForeground () const
Gets the default text brush of the control object.
- Public Member Functions inherited from CXTPMarkupFrameworkElement
void | SetMargin (int nLeft, int nTop, int nRight, int nBottom)
Call this method to set the outer margin of an element.
void | SetMargin (int nMargin)
Call this method to set the outer margin of an element.
CXTPMarkupThickness * | GetMargin () const
Call this method to get the outer margin of an element.
void | SetMinWidth (int nWidth)
Sets the minimum width constraint for the element.
void | SetMaxWidth (int nWidth)
Sets the maximum width constraint for the element.
void | SetWidth (int nWidth)
Sets the width for the element.
void | SetMinHeight (int nHeight)
Sets the minimum height constraint for the element.
void | SetMaxHeight (int nHeight)
Sets the maximum height constraint for the element.
void | SetHeight (int nHeight)
Sets the height for the element.
int | GetMinWidth () const
Gets the minimum width constraint of the element.
int | GetMaxWidth () const
Gets the maximum width constraint of the element.
int | GetWidth () const
Gets the width of the element.
int | GetMinHeight () const
Gets the minimum height constraint of the element.
int | GetMaxHeight () const
Gets the maximum height constraint of the element.
int | GetHeight () const
Gets the height of the element.
CXTPMarkupObject * | GetTag () const
Gets the tag object of the element.
void | SetTag (CXTPMarkupObject *pTag)
Sets the tag object for the element.
void | SetHorizontalAlignment (XTPMarkupHorizontalAlignment alignment)
Sets the horizontal alignment characteristics applied to this element when it is composed within a parent element (e.g.
void | SetVerticalAlignment (XTPMarkupVerticalAlignment alignment)
Sets the vertical alignment characteristics applied to this element when it is composed within a parent element (e.g.
XTPMarkupHorizontalAlignment | GetHorizontalAlignment () const
Gets the horizontal alignment characteristics applied to this element when it is composed within a parent element (e.g.
XTPMarkupVerticalAlignment | GetVerticalAlignment () const
Gets the vertical alignment characteristics applied to this element when it is composed within a parent element (e.g.
CSize | GetActualSize () const
Retrieves the actual size of the element after it is measured and arranged within a parent element (e.g.
void | SetClipToBounds (BOOL bClipToBounds)
Specifies if child elements should be clipped inside element bounds.
BOOL | GetClipToBounds () const
Determines if child elements are clipped inside element bounds.
CXTPMarkupStyle * | GetStyle () const
Gets the attached style of the element.
- Public Member Functions inherited from CXTPMarkupUIElement
void | Arrange (CRect rcFinalRect)
Positions child elements and determines a size for a CXTPMarkupUIElement.
void | Measure (CXTPMarkupDrawingContext *pDC, CSize szAvailableSize)
Updates the DesiredSize of a CXTPMarkupUIElement.
CSize | GetDesiredSize () const
Gets the size that this element computed during the measure pass of the layout process.
CRect | GetFinalRect () const
Gets the final render size of this element.
XTPMarkupVisibility | GetVisibility () const
Gets the user interface (UI) visibility of this element.
void | SetVisibility (XTPMarkupVisibility visibility)
Sets the user interface (UI) visibility of this element.
BOOL | IsFocusable () const
Gets or sets a value indicating whether this element can receive focus.
virtual BOOL | IsVisible () const
Gets a value indicating whether this element is visible in the user interface (UI).
BOOL | IsEnabled () const
Gets or sets a value indicating whether this element is enabled in the user interface (UI).
virtual void | InvalidateArrange ()
Invalidates the arrange state (layout) for the element.
virtual void | InvalidateVisual ()
Invalidates the rendering of the element, and forces a new complete layout pass.
virtual void | InvalidateMeasure ()
Invalidates the measurement state (layout) for the element.
- Public Member Functions inherited from CXTPMarkupVisual
CXTPMarkupVisual ()
Provides the base initialization for objects derived from the CXTPMarkupVisual class.
virtual | ~CXTPMarkupVisual ()
Destroys a CXTPMarkupVisual object, handles cleanup and deallocation.
void | Render (CXTPMarkupDrawingContext *drawingContext)
Call this method to draw a Visual object inside a drawing context.
CXTPMarkupInputElement * | InputHitTest (CPoint point) const
Determines if a point belongs to this object.
virtual int | GetVisualChildrenCount () const
Gets the number of child elements for the Visual.
virtual CXTPMarkupVisual * | GetVisualChild (int nIndex) const
Retrieves the child Visual object located at a specified index within the parent VisualCollection.
virtual int | GetLogicalChildrenCount () const
Retrieves the number of logical child elements of this object.
virtual CXTPMarkupObject * | GetLogicalChild (int nIndex) const
Retrieves the logical child element located at a specified index within the parent collection.
CRect | GetBoundRect () const
Retrieves the bounding rectangle of the element.
CRect | GetUpdateRect () const
Computes the update rectangle.
CSize | GetRenderSize () const
Gets the final render size of this element.
CPoint | GetVisualOffset () const
Gets or sets the offset value of the visual object.
CXTPMarkupVisual * | GetVisualParent () const
Gets the Visual tree parent of the Visual object.
- Static Public Attributes inherited from CXTPMarkupUIElement
static CXTPMarkupDependencyProperty * | m_pClipToBoundsProperty
Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element.
static CXTPMarkupDependencyProperty * | m_pVisibilityProperty
A value indicating whether this element is visible in the user interface (UI).
static CXTPMarkupDependencyProperty * | m_pFocusableProperty
A value that indicates whether the element can receive focus.
static CXTPMarkupDependencyProperty * | m_pIsEnabledProperty
A value indicating whether thiselement is enabled in the user interface (UI).
static CXTPMarkupDependencyProperty * | m_pRenderTransformProperty
Gets or sets transform information that affects the rendering position of this element.
static CXTPMarkupDependencyProperty * | m_pRenderTransformOriginProperty
Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element.
static CXTPMarkupDependencyProperty * | m_pOpacityProperty
Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI).
- Protected Attributes inherited from CXTPMarkupUIElement
CSize | m_szDesiredSize
Gets the size that this element computed during the measure pass of the layout process.
CRect | m_rcFinalRect
Final position of the visual element.
BOOL | m_bMeasureDirty
TRUE if object hasn't recalculated its size.
BOOL | m_bNeverMeasured
TRUE if object has never ran Measure to update its size.
CSize | m_szPreviousAvailableSize
Previous available size of measure call.
BOOL | m_bArrangeDirty
TRUE if object position can be invalid.
BOOL | m_bNeverArranged
TRUE if Arrange was never called for this object.
BOOL | m_bArrangeInProgress
TRUE if Arrange is currently executed.
BOOL | m_bMeasureInProgress
TRUE if Measure is currently executed.
- Protected Attributes inherited from CXTPMarkupVisual
CPoint | m_ptVisualOffset
The offset value of the visual object.
CSize | m_szRenderSize
The rendered size for this element.
CRect | m_rcBoundRect
Bounding rectangle of the element.
CRect | m_rcUpdateRect
Update rectangle.
CRect | m_rcPrevUpdateRect
Previous update rectangle.

Detailed Description

CXTPMarkupButton is a CXTPMarkupButtonBase derived class.

It implements the Button XAML Tag.

The documentation for this class was generated from the following file:
  • XTPMarkupButton.h


Toolkit Pro: CXTPMarkupButtonBase Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPMarkupButtonBase Class Reference

CXTPMarkupButtonBase is a CXTPMarkupContentControl derived class. More...

Inheritance diagram for CXTPMarkupButtonBase:
[legend]

Public Member Functions

BOOL | IsPressed () const
Determines if the button is currently pressed.
- Public Member Functions inherited from CXTPMarkupContentControl
CXTPMarkupUIElement * | GetContent () const
Gets the child object of the ControlContent element.
void | SetContent (CXTPMarkupUIElement *pContent)
Sets the child object for the ControlContent element.
- Public Member Functions inherited from CXTPMarkupControl
void | SetPadding (int nLeft, int nTop, int nRight, int nBottom)
Sets a value that indicates the thickness of the padding space between the boundaries of the content area and the content displayed by a control.
void | SetPadding (int nPadding)
Sets a value that indicates the thickness of the padding space between the boundaries of the content area and the content displayed by a control.
CXTPMarkupThickness * | GetPadding () const
Retrieves a value that indicates the thickness of the padding space between the boundaries of the content area and the content displayed by a control.
void | SetBackground (CXTPMarkupBrush *pBrush)
Sets the background brush for the control object.
CXTPMarkupBrush * | GetBackground () const
Gets the background brush of the control object.
void | SetForeground (CXTPMarkupBrush *pBrush)
Sets the default text brush for the control object.
CXTPMarkupBrush * | GetForeground () const
Gets the default text brush of the control object.
- Public Member Functions inherited from CXTPMarkupFrameworkElement
void | SetMargin (int nLeft, int nTop, int nRight, int nBottom)
Call this method to set the outer margin of an element.
void | SetMargin (int nMargin)
Call this method to set the outer margin of an element.
CXTPMarkupThickness * | GetMargin () const
Call this method to get the outer margin of an element.
void | SetMinWidth (int nWidth)
Sets the minimum width constraint for the element.
void | SetMaxWidth (int nWidth)
Sets the maximum width constraint for the element.
void | SetWidth (int nWidth)
Sets the width for the element.
void | SetMinHeight (int nHeight)
Sets the minimum height constraint for the element.
void | SetMaxHeight (int nHeight)
Sets the maximum height constraint for the element.
void | SetHeight (int nHeight)
Sets the height for the element.
int | GetMinWidth () const
Gets the minimum width constraint of the element.
int | GetMaxWidth () const
Gets the maximum width constraint of the element.
int | GetWidth () const
Gets the width of the element.
int | GetMinHeight () const
Gets the minimum height constraint of the element.
int | GetMaxHeight () const
Gets the maximum height constraint of the element.
int | GetHeight () const
Gets the height of the element.
CXTPMarkupObject * | GetTag () const
Gets the tag object of the element.
void | SetTag (CXTPMarkupObject *pTag)
Sets the tag object for the element.
void | SetHorizontalAlignment (XTPMarkupHorizontalAlignment alignment)
Sets the horizontal alignment characteristics applied to this element when it is composed within a parent element (e.g.
void | SetVerticalAlignment (XTPMarkupVerticalAlignment alignment)
Sets the vertical alignment characteristics applied to this element when it is composed within a parent element (e.g.
XTPMarkupHorizontalAlignment | GetHorizontalAlignment () const
Gets the horizontal alignment characteristics applied to this element when it is composed within a parent element (e.g.
XTPMarkupVerticalAlignment | GetVerticalAlignment () const
Gets the vertical alignment characteristics applied to this element when it is composed within a parent element (e.g.
CSize | GetActualSize () const
Retrieves the actual size of the element after it is measured and arranged within a parent element (e.g.
void | SetClipToBounds (BOOL bClipToBounds)
Specifies if child elements should be clipped inside element bounds.
BOOL | GetClipToBounds () const
Determines if child elements are clipped inside element bounds.
CXTPMarkupStyle * | GetStyle () const
Gets the attached style of the element.
- Public Member Functions inherited from CXTPMarkupUIElement
void | Arrange (CRect rcFinalRect)
Positions child elements and determines a size for a CXTPMarkupUIElement.
void | Measure (CXTPMarkupDrawingContext *pDC, CSize szAvailableSize)
Updates the DesiredSize of a CXTPMarkupUIElement.
CSize | GetDesiredSize () const
Gets the size that this element computed during the measure pass of the layout process.
CRect | GetFinalRect () const
Gets the final render size of this element.
XTPMarkupVisibility | GetVisibility () const
Gets the user interface (UI) visibility of this element.
void | SetVisibility (XTPMarkupVisibility visibility)
Sets the user interface (UI) visibility of this element.
BOOL | IsFocusable () const
Gets or sets a value indicating whether this element can receive focus.
virtual BOOL | IsVisible () const
Gets a value indicating whether this element is visible in the user interface (UI).
BOOL | IsEnabled () const
Gets or sets a value indicating whether this element is enabled in the user interface (UI).
virtual void | InvalidateArrange ()
Invalidates the arrange state (layout) for the element.
virtual void | InvalidateVisual ()
Invalidates the rendering of the element, and forces a new complete layout pass.
virtual void | InvalidateMeasure ()
Invalidates the measurement state (layout) for the element.
- Public Member Functions inherited from CXTPMarkupVisual
CXTPMarkupVisual ()
Provides the base initialization for objects derived from the CXTPMarkupVisual class.
virtual | ~CXTPMarkupVisual ()
Destroys a CXTPMarkupVisual object, handles cleanup and deallocation.
void | Render (CXTPMarkupDrawingContext *drawingContext)
Call this method to draw a Visual object inside a drawing context.
CXTPMarkupInputElement * | InputHitTest (CPoint point) const
Determines if a point belongs to this object.
virtual int | GetVisualChildrenCount () const
Gets the number of child elements for the Visual.
virtual CXTPMarkupVisual * | GetVisualChild (int nIndex) const
Retrieves the child Visual object located at a specified index within the parent VisualCollection.
virtual int | GetLogicalChildrenCount () const
Retrieves the number of logical child elements of this object.
virtual CXTPMarkupObject * | GetLogicalChild (int nIndex) const
Retrieves the logical child element located at a specified index within the parent collection.
CRect | GetBoundRect () const
Retrieves the bounding rectangle of the element.
CRect | GetUpdateRect () const
Computes the update rectangle.
CSize | GetRenderSize () const
Gets the final render size of this element.
CPoint | GetVisualOffset () const
Gets or sets the offset value of the visual object.
CXTPMarkupVisual * | GetVisualParent () const
Gets the Visual tree parent of the Visual object.

Protected Member Functions

CXTPMarkupButtonBase ()
Constructs a CXTPMarkupButtonBase object.
~CXTPMarkupButtonBase ()
Destroys a CXTPMarkupButtonBase object, handles cleanup and deallocation.
virtual void | OnClick ()
Virtual method called when the user clicks the button.
- Protected Member Functions inherited from CXTPMarkupContentControl
CXTPMarkupContentControl ()
Constructs a CXTPMarkupContentControl object.
virtual | ~CXTPMarkupContentControl ()
Destroys a CXTPMarkupContentControl object, handles cleanup and deallocation.
- Protected Member Functions inherited from CXTPMarkupFrameworkElement
CXTPMarkupFrameworkElement ()
Initializes a new instance of the CXTPMarkupFrameworkElement class.
virtual | ~CXTPMarkupFrameworkElement ()
Destroys a CXTPMarkupFrameworkElement object, handles cleanup and deallocation.
- Protected Member Functions inherited from CXTPMarkupUIElement
CXTPMarkupUIElement ()
Initializes a new instance of the CXTPMarkupUIElement class.
virtual | ~CXTPMarkupUIElement ()
Destroys a CXTPMarkupUIElement object, handles cleanup and deallocation.
CXTPMarkupRenderTransform * | GetRenderTransform () const
Obtains a pointer to the RenderTransform object.
virtual void | ArrangeCore (CRect rcFinalRect)
Defines the template for the core-level arrange layout definition.
virtual CSize | MeasureCore (CXTPMarkupDrawingContext *pDC, CSize szAvailableSize)
When overridden in a derived class, provides measurement logic for sizing this element properly with consideration of the size of any child element content.
virtual BOOL | GetLayoutClip (CRect &rc) const
Retrieves an alternative clipping geometry that represents the region that would be clipped if child elements were clipped inside element bounds.
virtual void | InvalidateMeasureOverride (CXTPMarkupDrawingContext *pDC)
Override this method to provide a custom reaction to an InvalidateMeasure call.
virtual TransformationMatrices | ApplyRenderTransform (CXTPMarkupDrawingContext *pContext)
Applies render transformation if necessary.
virtual void | RestoreRenderTransform (CXTPMarkupDrawingContext *pContext, TransformationMatrices &matrices)
Restores a previously applied render transformation.
virtual double | GetOpacity () const
Gets either the default or explicitly set opacity factor value.
- Protected Member Functions inherited from CXTPMarkupVisual
BOOL | PtInRectTransform (const RECT &rect, const POINT &point) const
Checks if a point is inside a rectangle with transformation applied.
POINT | GetAbsoluteVisualOffset () const
Gets the absolute element visual offset.
virtual void | OnRender (CXTPMarkupDrawingContext *drawingContext)
When overridden in a derived class, participates in rendering operations that are directed by the layout system.
virtual void | OnRenderFocusVisual (CXTPMarkupDrawingContext *drawingContext)
This method is called to render the focus rectangle of a focused object.
virtual CXTPMarkupInputElement * | InputHitTestOverride (CPoint point) const
Override this method in the derived class to provide visual hit testing of a child object.
virtual void | RenderClipped (CXTPMarkupDrawingContext *drawingContext)
Called by the framework when an element is clipped and no rendering will occur.

Additional Inherited Members

- Static Public Attributes inherited from CXTPMarkupUIElement
static CXTPMarkupDependencyProperty * | m_pClipToBoundsProperty
Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element.
static CXTPMarkupDependencyProperty * | m_pVisibilityProperty
A value indicating whether this element is visible in the user interface (UI).
static CXTPMarkupDependencyProperty * | m_pFocusableProperty
A value that indicates whether the element can receive focus.
static CXTPMarkupDependencyProperty * | m_pIsEnabledProperty
A value indicating whether thiselement is enabled in the user interface (UI).
static CXTPMarkupDependencyProperty * | m_pRenderTransformProperty
Gets or sets transform information that affects the rendering position of this element.
static CXTPMarkupDependencyProperty * | m_pRenderTransformOriginProperty
Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element.
static CXTPMarkupDependencyProperty * | m_pOpacityProperty
Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI).
- Protected Attributes inherited from CXTPMarkupUIElement
CSize | m_szDesiredSize
Gets the size that this element computed during the measure pass of the layout process.
CRect | m_rcFinalRect
Final position of the visual element.
BOOL | m_bMeasureDirty
TRUE if object hasn't recalculated its size.
BOOL | m_bNeverMeasured
TRUE if object has never ran Measure to update its size.
CSize | m_szPreviousAvailableSize
Previous available size of measure call.
BOOL | m_bArrangeDirty
TRUE if object position can be invalid.
BOOL | m_bNeverArranged
TRUE if Arrange was never called for this object.
BOOL | m_bArrangeInProgress
TRUE if Arrange is currently executed.
BOOL | m_bMeasureInProgress
TRUE if Measure is currently executed.
- Protected Attributes inherited from CXTPMarkupVisual
CPoint | m_ptVisualOffset
The offset value of the visual object.
CSize | m_szRenderSize
The rendered size for this element.
CRect | m_rcBoundRect
Bounding rectangle of the element.
CRect | m_rcUpdateRect
Update rectangle.
CRect | m_rcPrevUpdateRect
Previous update rectangle.

Detailed Description

CXTPMarkupButtonBase is a CXTPMarkupContentControl derived class.

It implements a base class for the Button element.

Member Function Documentation

◆ IsPressed()

BOOL IsPressed ( ) const

Determines if the button is currently pressed.

Returns
TRUE if the button is currently pressed.
The documentation for this class was generated from the following file:
  • XTPMarkupButtonBase.h


Toolkit Pro: CXTPMarkupCheckBox Class Reference

Protected Member Functions | List of all members
CXTPMarkupCheckBox Class Reference

CXTPMarkupCheckBox is a CXTPMarkupToggleButton derived class. More...

Inheritance diagram for CXTPMarkupCheckBox:
[legend]

Protected Member Functions

CXTPMarkupCheckBox ()
Constructs a CXTPMarkupCheckBox object.
~CXTPMarkupCheckBox ()
Destroys a CXTPMarkupCheckBox object, handles cleanup and deallocation.
- Protected Member Functions inherited from CXTPMarkupToggleButton
virtual void | OnClick ()
Virtual method called when the user clicks the button.
virtual void | OnToggle ()
Virtual method called when the state is toggled by the user.
virtual void | OnChecked (CXTPMarkupRoutedEventArgs *e)
Virtual method called when the user sets the state to checked.
virtual void | OnUnchecked (CXTPMarkupRoutedEventArgs *e)
Virtual method called when the user sets the state to unchecked.
virtual void | OnIndeterminate (CXTPMarkupRoutedEventArgs *e)
Virtual method called when the user sets the state to indeterminate.
- Protected Member Functions inherited from CXTPMarkupButtonBase
CXTPMarkupButtonBase ()
Constructs a CXTPMarkupButtonBase object.
~CXTPMarkupButtonBase ()
Destroys a CXTPMarkupButtonBase object, handles cleanup and deallocation.
- Protected Member Functions inherited from CXTPMarkupContentControl
CXTPMarkupContentControl ()
Constructs a CXTPMarkupContentControl object.
virtual | ~CXTPMarkupContentControl ()
Destroys a CXTPMarkupContentControl object, handles cleanup and deallocation.
- Protected Member Functions inherited from CXTPMarkupFrameworkElement
CXTPMarkupFrameworkElement ()
Initializes a new instance of the CXTPMarkupFrameworkElement class.
virtual | ~CXTPMarkupFrameworkElement ()
Destroys a CXTPMarkupFrameworkElement object, handles cleanup and deallocation.
- Protected Member Functions inherited from CXTPMarkupUIElement
CXTPMarkupUIElement ()
Initializes a new instance of the CXTPMarkupUIElement class.
virtual | ~CXTPMarkupUIElement ()
Destroys a CXTPMarkupUIElement object, handles cleanup and deallocation.
CXTPMarkupRenderTransform * | GetRenderTransform () const
Obtains a pointer to the RenderTransform object.
virtual void | ArrangeCore (CRect rcFinalRect)
Defines the template for the core-level arrange layout definition.
virtual CSize | MeasureCore (CXTPMarkupDrawingContext *pDC, CSize szAvailableSize)
When overridden in a derived class, provides measurement logic for sizing this element properly with consideration of the size of any child element content.
virtual BOOL | GetLayoutClip (CRect &rc) const
Retrieves an alternative clipping geometry that represents the region that would be clipped if child elements were clipped inside element bounds.
virtual void | InvalidateMeasureOverride (CXTPMarkupDrawingContext *pDC)
Override this method to provide a custom reaction to an InvalidateMeasure call.
virtual TransformationMatrices | ApplyRenderTransform (CXTPMarkupDrawingContext *pContext)
Applies render transformation if necessary.
virtual void | RestoreRenderTransform (CXTPMarkupDrawingContext *pContext, TransformationMatrices &matrices)
Restores a previously applied render transformation.
virtual double | GetOpacity () const
Gets either the default or explicitly set opacity factor value.
- Protected Member Functions inherited from CXTPMarkupVisual
BOOL | PtInRectTransform (const RECT &rect, const POINT &point) const
Checks if a point is inside a rectangle with transformation applied.
POINT | GetAbsoluteVisualOffset () const
Gets the absolute element visual offset.
virtual void | OnRender (CXTPMarkupDrawingContext *drawingContext)
When overridden in a derived class, participates in rendering operations that are directed by the layout system.
virtual void | OnRenderFocusVisual (CXTPMarkupDrawingContext *drawingContext)
This method is called to render the focus rectangle of a focused object.
virtual CXTPMarkupInputElement * | InputHitTestOverride (CPoint point) const
Override this method in the derived class to provide visual hit testing of a child object.
virtual void | RenderClipped (CXTPMarkupDrawingContext *drawingContext)
Called by the framework when an element is clipped and no rendering will occur.

Additional Inherited Members

- Public Member Functions inherited from CXTPMarkupToggleButton
void | SetChecked (BOOL bChecked)
Call this method to set the checked state for a button.
BOOL | GetChecked () const
Determines the checked state of a button.
void | SetThreeState (BOOL bThreeState)
Specifies if the button supports two or three states.
BOOL | IsThreeState () const
Determines if the button supports two or three states.
- Public Member Functions inherited from CXTPMarkupButtonBase
BOOL | IsPressed () const
Determines if the button is currently pressed.
- Public Member Functions inherited from CXTPMarkupContentControl
CXTPMarkupUIElement * | GetContent () const
Gets the child object of the ControlContent element.
void | SetContent (CXTPMarkupUIElement *pContent)
Sets the child object for the ControlContent element.
- Public Member Functions inherited from CXTPMarkupControl
void | SetPadding (int nLeft, int nTop, int nRight, int nBottom)
Sets a value that indicates the thickness of the padding space between the boundaries of the content area and the content displayed by a control.
void | SetPadding (int nPadding)
Sets a value that indicates the thickness of the padding space between the boundaries of the content area and the content displayed by a control.
CXTPMarkupThickness * | GetPadding () const
Retrieves a value that indicates the thickness of the padding space between the boundaries of the content area and the content displayed by a control.
void | SetBackground (CXTPMarkupBrush *pBrush)
Sets the background brush for the control object.
CXTPMarkupBrush * | GetBackground () const
Gets the background brush of the control object.
void | SetForeground (CXTPMarkupBrush *pBrush)
Sets the default text brush for the control object.
CXTPMarkupBrush * | GetForeground () const
Gets the default text brush of the control object.
- Public Member Functions inherited from CXTPMarkupFrameworkElement
void | SetMargin (int nLeft, int nTop, int nRight, int nBottom)
Call this method to set the outer margin of an element.
void | SetMargin (int nMargin)
Call this method to set the outer margin of an element.
CXTPMarkupThickness * | GetMargin () const
Call this method to get the outer margin of an element.
void | SetMinWidth (int nWidth)
Sets the minimum width constraint for the element.
void | SetMaxWidth (int nWidth)
Sets the maximum width constraint for the element.
void | SetWidth (int nWidth)
Sets the width for the element.
void | SetMinHeight (int nHeight)
Sets the minimum height constraint for the element.
void | SetMaxHeight (int nHeight)
Sets the maximum height constraint for the element.
void | SetHeight (int nHeight)
Sets the height for the element.
int | GetMinWidth () const
Gets the minimum width constraint of the element.
int | GetMaxWidth () const
Gets the maximum width constraint of the element.
int | GetWidth () const
Gets the width of the element.
int | GetMinHeight () const
Gets the minimum height constraint of the element.
int | GetMaxHeight () const
Gets the maximum height constraint of the element.
int | GetHeight () const
Gets the height of the element.
CXTPMarkupObject * | GetTag () const
Gets the tag object of the element.
void | SetTag (CXTPMarkupObject *pTag)
Sets the tag object for the element.
void | SetHorizontalAlignment (XTPMarkupHorizontalAlignment alignment)
Sets the horizontal alignment characteristics applied to this element when it is composed within a parent element (e.g.
void | SetVerticalAlignment (XTPMarkupVerticalAlignment alignment)
Sets the vertical alignment characteristics applied to this element when it is composed within a parent element (e.g.
XTPMarkupHorizontalAlignment | GetHorizontalAlignment () const
Gets the horizontal alignment characteristics applied to this element when it is composed within a parent element (e.g.
XTPMarkupVerticalAlignment | GetVerticalAlignment () const
Gets the vertical alignment characteristics applied to this element when it is composed within a parent element (e.g.
CSize | GetActualSize () const
Retrieves the actual size of the element after it is measured and arranged within a parent element (e.g.
void | SetClipToBounds (BOOL bClipToBounds)
Specifies if child elements should be clipped inside element bounds.
BOOL | GetClipToBounds () const
Determines if child elements are clipped inside element bounds.
CXTPMarkupStyle * | GetStyle () const
Gets the attached style of the element.
- Public Member Functions inherited from CXTPMarkupUIElement
void | Arrange (CRect rcFinalRect)
Positions child elements and determines a size for a CXTPMarkupUIElement.
void | Measure (CXTPMarkupDrawingContext *pDC, CSize szAvailableSize)
Updates the DesiredSize of a CXTPMarkupUIElement.
CSize | GetDesiredSize () const
Gets the size that this element computed during the measure pass of the layout process.
CRect | GetFinalRect () const
Gets the final render size of this element.
XTPMarkupVisibility | GetVisibility () const
Gets the user interface (UI) visibility of this element.
void | SetVisibility (XTPMarkupVisibility visibility)
Sets the user interface (UI) visibility of this element.
BOOL | IsFocusable () const
Gets or sets a value indicating whether this element can receive focus.
virtual BOOL | IsVisible () const
Gets a value indicating whether this element is visible in the user interface (UI).
BOOL | IsEnabled () const
Gets or sets a value indicating whether this element is enabled in the user interface (UI).
virtual void | InvalidateArrange ()
Invalidates the arrange state (layout) for the element.
virtual void | InvalidateVisual ()
Invalidates the rendering of the element, and forces a new complete layout pass.
virtual void | InvalidateMeasure ()
Invalidates the measurement state (layout) for the element.
- Public Member Functions inherited from CXTPMarkupVisual
CXTPMarkupVisual ()
Provides the base initialization for objects derived from the CXTPMarkupVisual class.
virtual | ~CXTPMarkupVisual ()
Destroys a CXTPMarkupVisual object, handles cleanup and deallocation.
void | Render (CXTPMarkupDrawingContext *drawingContext)
Call this method to draw a Visual object inside a drawing context.
CXTPMarkupInputElement * | InputHitTest (CPoint point) const
Determines if a point belongs to this object.
virtual int | GetVisualChildrenCount () const
Gets the number of child elements for the Visual.
virtual CXTPMarkupVisual * | GetVisualChild (int nIndex) const
Retrieves the child Visual object located at a specified index within the parent VisualCollection.
virtual int | GetLogicalChildrenCount () const
Retrieves the number of logical child elements of this object.
virtual CXTPMarkupObject * | GetLogicalChild (int nIndex) const
Retrieves the logical child element located at a specified index within the parent collection.
CRect | GetBoundRect () const
Retrieves the bounding rectangle of the element.
CRect | GetUpdateRect () const
Computes the update rectangle.
CSize | GetRenderSize () const
Gets the final render size of this element.
CPoint | GetVisualOffset () const
Gets or sets the offset value of the visual object.
CXTPMarkupVisual * | GetVisualParent () const
Gets the Visual tree parent of the Visual object.
- Static Public Attributes inherited from CXTPMarkupUIElement
static CXTPMarkupDependencyProperty * | m_pClipToBoundsProperty
Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element.
static CXTPMarkupDependencyProperty * | m_pVisibilityProperty
A value indicating whether this element is visible in the user interface (UI).
static CXTPMarkupDependencyProperty * | m_pFocusableProperty
A value that indicates whether the element can receive focus.
static CXTPMarkupDependencyProperty * | m_pIsEnabledProperty
A value indicating whether thiselement is enabled in the user interface (UI).
static CXTPMarkupDependencyProperty * | m_pRenderTransformProperty
Gets or sets transform information that affects the rendering position of this element.
static CXTPMarkupDependencyProperty * | m_pRenderTransformOriginProperty
Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element.
static CXTPMarkupDependencyProperty * | m_pOpacityProperty
Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI).
- Protected Attributes inherited from CXTPMarkupUIElement
CSize | m_szDesiredSize
Gets the size that this element computed during the measure pass of the layout process.
CRect | m_rcFinalRect
Final position of the visual element.
BOOL | m_bMeasureDirty
TRUE if object hasn't recalculated its size.
BOOL | m_bNeverMeasured
TRUE if object has never ran Measure to update its size.
CSize | m_szPreviousAvailableSize
Previous available size of measure call.
BOOL | m_bArrangeDirty
TRUE if object position can be invalid.
BOOL | m_bNeverArranged
TRUE if Arrange was never called for this object.
BOOL | m_bArrangeInProgress
TRUE if Arrange is currently executed.
BOOL | m_bMeasureInProgress
TRUE if Measure is currently executed.
- Protected Attributes inherited from CXTPMarkupVisual
CPoint | m_ptVisualOffset
The offset value of the visual object.
CSize | m_szRenderSize
The rendered size for this element.
CRect | m_rcBoundRect
Bounding rectangle of the element.
CRect | m_rcUpdateRect
Update rectangle.
CRect | m_rcPrevUpdateRect
Previous update rectangle.

Detailed Description

CXTPMarkupCheckBox is a CXTPMarkupToggleButton derived class.

It implements the CheckBox XAML Tag.

The documentation for this class was generated from the following file:
  • XTPMarkupCheckBox.h


Toolkit Pro: CXTPMarkupColumnDefinition Class Reference

Public Member Functions | List of all members
CXTPMarkupColumnDefinition Class Reference

CXTPMarkupColumnDefinition is a CXTPMarkupDefinitionBase derived class. More...

Inheritance diagram for CXTPMarkupColumnDefinition:
[legend]

Public Member Functions

CXTPMarkupColumnDefinition ()
Constructs a CXTPMarkupColumnDefinition object.
void | SetMinWidth (int nWidth)
Sets the minimum width constraint for the column.
void | SetMaxWidth (int nWidth)
Sets the maximum width constraint for the column.
void | SetWidth (int nWidth)
Sets the width for the column.
void | SetWidth (CXTPMarkupGridLength *pLength)
Sets the width for the column.
- Public Member Functions inherited from CXTPMarkupDefinitionBase
int | GetUserMinSize () const
Retrieves the minimum constraint for user-defined column or row size.
int | GetUserMaxSize () const
Retrieves the maximum constraint for user-defined column or row size.
CXTPMarkupGridLength * | GetUserSize () const
Retrieves the user-defined column or row size.

Additional Inherited Members

- Protected Member Functions inherited from CXTPMarkupDefinitionBase
CXTPMarkupDefinitionBase (BOOL bIsColumnDefinition=FALSE)
Constructs a CXTPMarkupDefinitionBase object.

Detailed Description

CXTPMarkupColumnDefinition is a CXTPMarkupDefinitionBase derived class.

It implements the ColumnDefinition XAML Tag.

Member Function Documentation

◆ SetMaxWidth()

void SetMaxWidth ( int nWidth )

Sets the maximum width constraint for the column.

Parameters
nWidth New maximum width constraint.

◆ SetMinWidth()

void SetMinWidth ( int nWidth )

Sets the minimum width constraint for the column.

Parameters
nWidth New minimum width constraint.

◆ SetWidth() [1/2]

void SetWidth ( CXTPMarkupGridLength * pLength )

Sets the width for the column.

Parameters
pLength New width for the column.

◆ SetWidth() [2/2]

void SetWidth ( int nWidth )

Sets the width for the column.

Parameters
nWidth New width for the column.
The documentation for this class was generated from the following file:
  • XTPMarkupColumnDefinition.h


Toolkit Pro: CXTPMarkupColumnDefinitionCollection Class Reference

Public Member Functions | List of all members
CXTPMarkupColumnDefinitionCollection Class Reference

CXTPMarkupColumnDefinitionCollection is a CXTPMarkupDefinitionCollection derived class. More...

Inheritance diagram for CXTPMarkupColumnDefinitionCollection:
[legend]

Public Member Functions

CXTPMarkupColumnDefinitionCollection ()
Constructs a CXTPMarkupColumnDefinitionCollection object.
- Public Member Functions inherited from CXTPMarkupDefinitionCollection
CXTPMarkupDefinitionCollection ()
Constructs a CXTPMarkupDefinitionCollection object.
CXTPMarkupDefinitionBase * GetItem (int nIndex) const
Retrieves a CXTPMarkupDefinitionBase object by its index.

Detailed Description

CXTPMarkupColumnDefinitionCollection is a CXTPMarkupDefinitionCollection derived class.

It implements a collection of CXTPMarkupColumnDefinition classes.

The documentation for this class was generated from the following file:
  • XTPMarkupColumnDefinitionCollection.h


Toolkit Pro: CXTPMarkupContentControl Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPMarkupContentControl Class Reference

CXTPMarkupContentControl is a CXTPMarkupControl derived class. More...

Inheritance diagram for CXTPMarkupContentControl:
[legend]

Public Member Functions

CXTPMarkupUIElement * | GetContent () const
Gets the child object of the ControlContent element.
void | SetContent (CXTPMarkupUIElement *pContent)
Sets the child object for the ControlContent element.
- Public Member Functions inherited from CXTPMarkupControl
void | SetPadding (int nLeft, int nTop, int nRight, int nBottom)
Sets a value that indicates the thickness of the padding space between the boundaries of the content area and the content displayed by a control.
void | SetPadding (int nPadding)
Sets a value that indicates the thickness of the padding space between the boundaries of the content area and the content displayed by a control.
CXTPMarkupThickness * | GetPadding () const
Retrieves a value that indicates the thickness of the padding space between the boundaries of the content area and the content displayed by a control.
void | SetBackground (CXTPMarkupBrush *pBrush)
Sets the background brush for the control object.
CXTPMarkupBrush * | GetBackground () const
Gets the background brush of the control object.
void | SetForeground (CXTPMarkupBrush *pBrush)
Sets the default text brush for the control object.
CXTPMarkupBrush * | GetForeground () const
Gets the default text brush of the control object.
- Public Member Functions inherited from CXTPMarkupFrameworkElement
void | SetMargin (int nLeft, int nTop, int nRight, int nBottom)
Call this method to set the outer margin of an element.
void | SetMargin (int nMargin)
Call this method to set the outer margin of an element.
CXTPMarkupThickness * | GetMargin () const
Call this method to get the outer margin of an element.
void | SetMinWidth (int nWidth)
Sets the minimum width constraint for the element.
void | SetMaxWidth (int nWidth)
Sets the maximum width constraint for the element.
void | SetWidth (int nWidth)
Sets the width for the element.
void | SetMinHeight (int nHeight)
Sets the minimum height constraint for the element.
void | SetMaxHeight (int nHeight)
Sets the maximum height constraint for the element.
void | SetHeight (int nHeight)
Sets the height for the element.
int | GetMinWidth () const
Gets the minimum width constraint of the element.
int | GetMaxWidth () const
Gets the maximum width constraint of the element.
int | GetWidth () const
Gets the width of the element.
int | GetMinHeight () const
Gets the minimum height constraint of the element.
int | GetMaxHeight () const
Gets the maximum height constraint of the element.
int | GetHeight () const
Gets the height of the element.
CXTPMarkupObject * | GetTag () const
Gets the tag object of the element.
void | SetTag (CXTPMarkupObject *pTag)
Sets the tag object for the element.
void | SetHorizontalAlignment (XTPMarkupHorizontalAlignment alignment)
Sets the horizontal alignment characteristics applied to this element when it is composed within a parent element (e.g.
void | SetVerticalAlignment (XTPMarkupVerticalAlignment alignment)
Sets the vertical alignment characteristics applied to this element when it is composed within a parent element (e.g.
XTPMarkupHorizontalAlignment | GetHorizontalAlignment () const
Gets the horizontal alignment characteristics applied to this element when it is composed within a parent element (e.g.
XTPMarkupVerticalAlignment | GetVerticalAlignment () const
Gets the vertical alignment characteristics applied to this element when it is composed within a parent element (e.g.
CSize | GetActualSize () const
Retrieves the actual size of the element after it is measured and arranged within a parent element (e.g.
void | SetClipToBounds (BOOL bClipToBounds)
Specifies if child elements should be clipped inside element bounds.
BOOL | GetClipToBounds () const
Determines if child elements are clipped inside element bounds.
CXTPMarkupStyle * | GetStyle () const
Gets the attached style of the element.
- Public Member Functions inherited from CXTPMarkupUIElement
void | Arrange (CRect rcFinalRect)
Positions child elements and determines a size for a CXTPMarkupUIElement.
void | Measure (CXTPMarkupDrawingContext *pDC, CSize szAvailableSize)
Updates the DesiredSize of a CXTPMarkupUIElement.
CSize | GetDesiredSize () const
Gets the size that this element computed during the measure pass of the layout process.
CRect | GetFinalRect () const
Gets the final render size of this element.
XTPMarkupVisibility | GetVisibility () const
Gets the user interface (UI) visibility of this element.
void | SetVisibility (XTPMarkupVisibility visibility)
Sets the user interface (UI) visibility of this element.
BOOL | IsFocusable () const
Gets or sets a value indicating whether this element can receive focus.
virtual BOOL | IsVisible () const
Gets a value indicating whether this element is visible in the user interface (UI).
BOOL | IsEnabled () const
Gets or sets a value indicating whether this element is enabled in the user interface (UI).
virtual void | InvalidateArrange ()
Invalidates the arrange state (layout) for the element.
virtual void | InvalidateVisual ()
Invalidates the rendering of the element, and forces a new complete layout pass.
virtual void | InvalidateMeasure ()
Invalidates the measurement state (layout) for the element.
- Public Member Functions inherited from CXTPMarkupVisual
CXTPMarkupVisual ()
Provides the base initialization for objects derived from the CXTPMarkupVisual class.
virtual | ~CXTPMarkupVisual ()
Destroys a CXTPMarkupVisual object, handles cleanup and deallocation.
void | Render (CXTPMarkupDrawingContext *drawingContext)
Call this method to draw a Visual object inside a drawing context.
CXTPMarkupInputElement * | InputHitTest (CPoint point) const
Determines if a point belongs to this object.
virtual int | GetVisualChildrenCount () const
Gets the number of child elements for the Visual.
virtual CXTPMarkupVisual * | GetVisualChild (int nIndex) const
Retrieves the child Visual object located at a specified index within the parent VisualCollection.
virtual int | GetLogicalChildrenCount () const
Retrieves the number of logical child elements of this object.
virtual CXTPMarkupObject * | GetLogicalChild (int nIndex) const
Retrieves the logical child element located at a specified index within the parent collection.
CRect | GetBoundRect () const
Retrieves the bounding rectangle of the element.
CRect | GetUpdateRect () const
Computes the update rectangle.
CSize | GetRenderSize () const
Gets the final render size of this element.
CPoint | GetVisualOffset () const
Gets or sets the offset value of the visual object.
CXTPMarkupVisual * | GetVisualParent () const
Gets the Visual tree parent of the Visual object.

Protected Member Functions

CXTPMarkupContentControl ()
Constructs a CXTPMarkupContentControl object.
virtual | ~CXTPMarkupContentControl ()
Destroys a CXTPMarkupContentControl object, handles cleanup and deallocation.
- Protected Member Functions inherited from CXTPMarkupFrameworkElement
CXTPMarkupFrameworkElement ()
Initializes a new instance of the CXTPMarkupFrameworkElement class.
virtual | ~CXTPMarkupFrameworkElement ()
Destroys a CXTPMarkupFrameworkElement object, handles cleanup and deallocation.
- Protected Member Functions inherited from CXTPMarkupUIElement
CXTPMarkupUIElement ()
Initializes a new instance of the CXTPMarkupUIElement class.
virtual | ~CXTPMarkupUIElement ()
Destroys a CXTPMarkupUIElement object, handles cleanup and deallocation.
CXTPMarkupRenderTransform * | GetRenderTransform () const
Obtains a pointer to the RenderTransform object.
virtual void | ArrangeCore (CRect rcFinalRect)
Defines the template for the core-level arrange layout definition.
virtual CSize | MeasureCore (CXTPMarkupDrawingContext *pDC, CSize szAvailableSize)
When overridden in a derived class, provides measurement logic for sizing this element properly with consideration of the size of any child element content.
virtual BOOL | GetLayoutClip (CRect &rc) const
Retrieves an alternative clipping geometry that represents the region that would be clipped if child elements were clipped inside element bounds.
virtual void | InvalidateMeasureOverride (CXTPMarkupDrawingContext *pDC)
Override this method to provide a custom reaction to an InvalidateMeasure call.
virtual TransformationMatrices | ApplyRenderTransform (CXTPMarkupDrawingContext *pContext)
Applies render transformation if necessary.
virtual void | RestoreRenderTransform (CXTPMarkupDrawingContext *pContext, TransformationMatrices &matrices)
Restores a previously applied render transformation.
virtual double | GetOpacity () const
Gets either the default or explicitly set opacity factor value.
- Protected Member Functions inherited from CXTPMarkupVisual
BOOL | PtInRectTransform (const RECT &rect, const POINT &point) const
Checks if a point is inside a rectangle with transformation applied.
POINT | GetAbsoluteVisualOffset () const
Gets the absolute element visual offset.
virtual void | OnRender (CXTPMarkupDrawingContext *drawingContext)
When overridden in a derived class, participates in rendering operations that are directed by the layout system.
virtual void | OnRenderFocusVisual (CXTPMarkupDrawingContext *drawingContext)
This method is called to render the focus rectangle of a focused object.
virtual CXTPMarkupInputElement * | InputHitTestOverride (CPoint point) const
Override this method in the derived class to provide visual hit testing of a child object.
virtual void | RenderClipped (CXTPMarkupDrawingContext *drawingContext)
Called by the framework when an element is clipped and no rendering will occur.

Additional Inherited Members

- Static Public Attributes inherited from CXTPMarkupUIElement
static CXTPMarkupDependencyProperty * | m_pClipToBoundsProperty
Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element.
static CXTPMarkupDependencyProperty * | m_pVisibilityProperty
A value indicating whether this element is visible in the user interface (UI).
static CXTPMarkupDependencyProperty * | m_pFocusableProperty
A value that indicates whether the element can receive focus.
static CXTPMarkupDependencyProperty * | m_pIsEnabledProperty
A value indicating whether thiselement is enabled in the user interface (UI).
static CXTPMarkupDependencyProperty * | m_pRenderTransformProperty
Gets or sets transform information that affects the rendering position of this element.
static CXTPMarkupDependencyProperty * | m_pRenderTransformOriginProperty
Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element.
static CXTPMarkupDependencyProperty * | m_pOpacityProperty
Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI).
- Protected Attributes inherited from CXTPMarkupUIElement
CSize | m_szDesiredSize
Gets the size that this element computed during the measure pass of the layout process.
CRect | m_rcFinalRect
Final position of the visual element.
BOOL | m_bMeasureDirty
TRUE if object hasn't recalculated its size.
BOOL | m_bNeverMeasured
TRUE if object has never ran Measure to update its size.
CSize | m_szPreviousAvailableSize
Previous available size of measure call.
BOOL | m_bArrangeDirty
TRUE if object position can be invalid.
BOOL | m_bNeverArranged
TRUE if Arrange was never called for this object.
BOOL | m_bArrangeInProgress
TRUE if Arrange is currently executed.
BOOL | m_bMeasureInProgress
TRUE if Measure is currently executed.
- Protected Attributes inherited from CXTPMarkupVisual
CPoint | m_ptVisualOffset
The offset value of the visual object.
CSize | m_szRenderSize
The rendered size for this element.
CRect | m_rcBoundRect
Bounding rectangle of the element.
CRect | m_rcUpdateRect
Update rectangle.
CRect | m_rcPrevUpdateRect
Previous update rectangle.

Detailed Description

CXTPMarkupContentControl is a CXTPMarkupControl derived class.

It implements a base class for all control elements with a single child.

Member Function Documentation

◆ GetContent()

CXTPMarkupUIElement * GetContent ( ) const

Gets the child object of the ControlContent element.

Returns
The child CXTPMarkupUIElement object.
See also
SetContent

◆ SetContent()

void SetContent ( CXTPMarkupUIElement * pContent )

Sets the child object for the ControlContent element.

Parameters
pContent New child CXTPMarkupUIElement object.
See also
GetContent
The documentation for this class was generated from the following file:
  • XTPMarkupContentControl.h


Toolkit Pro: CXTPMarkupContext Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPMarkupContext Class Reference

CXTPMarkupContext is a standalone class used to provide common settings for Markup objects. More...

Inheritance diagram for CXTPMarkupContext:
[legend]

Public Member Functions

CXTPMarkupContext ()
Constructs a CXTPMarkupContext object.
IXTPMarkupClientSite * | GetClientSite () const
Gets a client site pointer.
void | SetClientSite (IXTPMarkupClientSite *pSite)
Sets a client site pointer.
void | Shutdown ()
Performs internal cleanup necessary for the final release.
LOGFONT * | GetDefaultLogFont ()
Gets the default font properties of markup objects.
COLORREF | GetDefaultForeground ()
Gets the default text color of TextBlock objects.
void | SetDefaultTextColor (COLORREF clr)
Sets the default text color for TextBlock objects.
void | SetDefaultFont (HFONT font)
Sets the default font for TextBlock objects.
void | SetDefaultFont (LOGFONT *font)
Sets the default font for TextBlock objects.
XTPMarkupSmoothingMode | GetDefaultSmoothingMode () const
Gets the default smoothing mode to be used for any drawing context that uses the context.
XTPMarkupSmoothingMode | SetDefaultSmoothingMode (XTPMarkupSmoothingMode smoothingMode)
Sets the default smoothing mode to be used for any drawing context that uses the context.
BOOL | GetDefaultTextSmoothing () const
Determines/specifies if text smoothing is enabled for any drawing context that uses the context.
BOOL | SetDefaultTextSmoothing (BOOL bEnableTextSmoothing)
Determines/specifies if text smoothing is enabled for any drawing context that uses the context.
CXTPMarkupUIElement * | Parse (LPCSTR lpszBuffer)
Creates a Markup tree from its XML string.
CXTPMarkupUIElement * | Parse (LPCWSTR lpszBuffer)
Creates a Markup tree from its XML string.
CString | ValidateXML (LPCSTR lpszBuffer)
Validates XML correctness.
CString | ValidateXML (LPCWSTR lpszBuffer)
Validates XML correctness.
void | AddHandler (CXTPMarkupRoutedEvent *pEvent, CXTPMarkupDelegate *pDelegate)
Connects a Markup event with a class member or static method delegate.
void | SetDelegate (LPCWSTR lpszDelegate, CXTPMarkupDelegate *pDelegate)
Sets a delegate for a Markup text event.
void | EnableGdiPlus (BOOL bEnable)
Enables/disables GDI+ usage.
BOOL | IsGdiPlusEnabled () const
Determines if GDI+ is enabled/disabled.
CXTPToolTipContext * | GetToolTipContext () const
Call this method to get a pointer to the tooltip context.
BOOL | GetUseCustomToolTipPosition () const
Determines if custom positioning for tooltips is enabled/disabled.
void | SetUseCustomToolTipPosition (BOOL bUse, CPoint ptPos=CPoint(0, 0))
Enables/disables custom positioning for tooltips.
CPoint | GetCustomToolTipPosition () const
Gets the custom x- and y- coordinates of the tooltip window.
void | SetImageManager (CXTPImageManager *pImageManager)
Sets the isolated image manager for elements inside the Markup context.
CXTPImageManager * | GetImageManager () const
Gets the isolated image manager for elements inside the Markup context.
void | SetImageColorKey (COLORREF crColorKey)
Sets the context specific color key for an image element.
COLORREF | GetImageColorKey () const
Gets the context specific color key for an image element.
CXTPMarkupStaticExtension * GetExtensionRoot ()
Gets a pointer to the extension root object used to add custom Markup extensions.
BOOL | IsDpiAware () const
Determines if context DPI awareness is enabled (i.e.
void | SetDpiAware (BOOL bSet=TRUE)
Enables/disables context DPI awareness.
void | SetDpiAware (BOOL bSet, HWND hWnd)
Enables/disables context DPI awareness.
void | SetDpiAware (BOOL bSet, HDC hDC)
Enables/disables context DPI awareness.
int | ScaleX (int x) const
Performs x- and y- coordinate scaling according to active DPI settings if the Markup context is DPI aware.
int | ScaleY (int y) const
Performs x- and y- coordinate scaling according to active DPI settings if the Markup context is DPI aware.
float | ScaleX (float x) const
Performs x- and y- coordinate scaling according to active DPI settings if the Markup context is DPI aware.
float | ScaleY (float y) const
Performs x- and y- coordinate scaling according to active DPI settings if the Markup context is DPI aware.
double | ScaleX (double x) const
Performs x- and y- coordinate scaling according to active DPI settings if the Markup context is DPI aware.
double | ScaleY (double y) const
Performs x- and y- coordinate scaling according to active DPI settings if the Markup context is DPI aware.
CSize | Scale (const SIZE &size) const
Performs x- and y- coordinate scaling according to active DPI settings if the Markup context is DPI aware.
void | LoadScriptCodeChunk (CXTPMarkupBuilder *pBuilder, LPCWSTR lpszLanguage, LPCWSTR lpszCode, LPCWSTR lpszRequires=NULL)
Loads a chunk of script code in a specified language.
void | RunScriptEngine (CXTPMarkupBuilder *pBuilder)
Runs script engine.
CXTPActiveScriptEngine * GetScriptEngine ()
Obtains the associated ActiveScript engine object pointer if there is a scripting context assigned to the markup context.
void | AddCustomScriptItem (LPCWSTR lpName, LPDISPATCH pDisp)
Adds a custom scripting named item to the associated scripting context.
void | RemoveCustomScriptItem (LPCWSTR lpName)
Removes a previously added named sciripting item from the context.
HWND | GetContextWindow () const
Gets a window handle associated with markup context.
void | SetContextWindow (HWND hWnd, LPCRECT pUpdateRect=NULL)
Sets a window handle associated with markup context.

Protected Member Functions

virtual ~CXTPMarkupContext ()
Destroys a CXTPMarkupContext object, handles cleanup and deallocation.

Detailed Description

CXTPMarkupContext is a standalone class used to provide common settings for Markup objects.

Member Function Documentation

◆ AddCustomScriptItem()

void AddCustomScriptItem | ( | LPCWSTR | lpName,
 |  | LPDISPATCH | pDisp )

Adds a custom scripting named item to the associated scripting context.

Once added, the associated scripting item object can be accessed in the script code by its name as a global object.

Parameters
lpName | Scripting item name pointer.
pDisp | Scripting item object. The markup context will hold its reference until removed.
See also
RemoveCustomScriptItem, GetScriptEngine

◆ AddHandler()

void AddHandler | ( | CXTPMarkupRoutedEvent * | pEvent,
 |  | CXTPMarkupDelegate * | pDelegate )

Connects a Markup event with a class member or static method delegate.

Parameters
pEvent | Markup event.
pDelegate | Class member or static method delegate.

Example:

m_wndStatic.AddHandler(CXTPMarkupHyperlink::m_pClickEvent,
CreateMarkupClassDelegate(this, &CMarkupSampleDlg::OnHyperlinkClick));

◆ EnableGdiPlus()

AFX_INLINE void EnableGdiPlus ( BOOL bEnable )

Enables/disables GDI+ usage.

Parameters
bEnable TRUE to enable GDI+ usage, FALSE to disable.

◆ GetClientSite()

AFX_INLINE IXTPMarkupClientSite * GetClientSite ( ) const

Gets a client site pointer.

Returns
The current client site interface poitner. The context object is not responsible for the client site pointer deallocation.

◆ GetContextWindow()

AFX_INLINE HWND GetContextWindow ( ) const

Gets a window handle associated with markup context.

The specified window provides a devices context to render markup on and receives related notifications.

Returns
The associated window handler.

◆ GetCustomToolTipPosition()

AFX_INLINE CPoint GetCustomToolTipPosition ( ) const

Gets the custom x- and y- coordinates of the tooltip window.

These coordinates are always relative to the upper-left corner of the window.

Returns
A CPoint object containing the custom x- and y- coordinates of the tooltip window.
See also
GetUseCustomToolTipPosition, SetUseCustomToolTipPosition

◆ GetDefaultForeground()

AFX_INLINE COLORREF GetDefaultForeground ( )

Gets the default text color of TextBlock objects.

Returns
The default text color of TextBlock objects.

◆ GetDefaultLogFont()

AFX_INLINE LOGFONT * GetDefaultLogFont ( )

Gets the default font properties of markup objects.

Returns
The default font properties of markup objects.

◆ GetDefaultSmoothingMode()

AFX_INLINE XTPMarkupSmoothingMode GetDefaultSmoothingMode ( ) const

Gets the default smoothing mode to be used for any drawing context that uses the context.

By default, smoothing mode is applied to all graphical elements except text. To enable text smoothing, refer to SetDefaultTextSmoothing.

Returns
Current/previous smoothing mode; returns one of the values defined by the XTPMarkupSmoothingMode enumeration.
See also
GetDefaultTextSmoothing, SetDefaultTextSmoothing

◆ GetDefaultTextSmoothing()

AFX_INLINE BOOL GetDefaultTextSmoothing ( ) const

Determines/specifies if text smoothing is enabled for any drawing context that uses the context.

By default, smoothing mode is applied to all graphical elements except text.

Returns
Current/previous text smoothing setting. TRUE if text smoothing is/was enabled, FALSE if text smoothing is/was disabled.
See also
GetDefaultSmoothingMode, SetDefaultSmoothingMode

◆ GetExtensionRoot()

CXTPMarkupStaticExtension * GetExtensionRoot ( )

Gets a pointer to the extension root object used to add custom Markup extensions.

Returns
A pointer to the extension root object.

◆ GetImageColorKey()

COLORREF GetImageColorKey ( ) const

Gets the context specific color key for an image element.

Returns
If the context specific color key is not COLORREF_NULL, then the context specific color key will be returned. If the context specific color key is COLORREF_NULL, then the color mask of the assigned image manager will be returned. If the color mask of the assigned image manager is also COLORREF_NULL, then a default value of RGB(0, 0xff, 0) will be returned instead.

◆ GetImageManager()

CXTPImageManager * GetImageManager ( ) const

Gets the isolated image manager for elements inside the Markup context.

Returns
The isolated image manager for elements inside the Markup context.

Function returns XTPImageManager(); by default, call SetImageManager to set isolated images.

◆ GetScriptEngine()

AFX_INLINE CXTPActiveScriptEngine * GetScriptEngine ( )

Obtains the associated ActiveScript engine object pointer if there is a scripting context assigned to the markup context.

Returns
A valid ActiveScript engine object pointer or NULL is no scripting context assigned to the markup context.
See also
AddCustomScriptItem, RemoveCustomScriptItem

◆ GetToolTipContext()

AFX_INLINE CXTPToolTipContext * GetToolTipContext ( ) const

Call this method to get a pointer to the tooltip context.

Returns
A pointer to the tooltip context.

◆ GetUseCustomToolTipPosition()

AFX_INLINE BOOL GetUseCustomToolTipPosition ( ) const

Determines if custom positioning for tooltips is enabled/disabled.

Returns
TRUE if custom positioning for tooltips is enabled, FALSE if custom positioning for tooltips is disabled.
See also
SetUseCustomToolTipPosition, GetCustomToolTipPosition

◆ IsDpiAware()

AFX_INLINE BOOL IsDpiAware ( ) const

Determines if context DPI awareness is enabled (i.e.

graphics are scaled according to active DPI settings).

Returns
TRUE if context DPI awareness is enabled.

◆ IsGdiPlusEnabled()

AFX_INLINE BOOL IsGdiPlusEnabled ( ) const

Determines if GDI+ is enabled/disabled.

Returns
TRUE if GDI+ usage is enabled, FALSE if GDI+ usage is disabled.

◆ LoadScriptCodeChunk()

void LoadScriptCodeChunk | ( | CXTPMarkupBuilder * | pBuilder,
 |  | LPCWSTR | lpszLanguage,
 |  | LPCWSTR | lpszCode,
 |  | LPCWSTR | lpszRequires = NULL )

Loads a chunk of script code in a specified language.

Parameters
pBuilder | Pointer to the Markup builder from which code is loaded.
lpszLanguage | Script code language.
lpszCode | Script code.
lpszRequires | An optional comma separated list of requirements.

◆ Parse() [1/2]

CXTPMarkupUIElement * Parse ( LPCSTR lpszBuffer )

Creates a Markup tree from its XML string.

Parameters
lpszBuffer XML Markup string.
Returns
The top level Markup element.

◆ Parse() [2/2]

CXTPMarkupUIElement * Parse ( LPCWSTR lpszBuffer )

Creates a Markup tree from its XML string.

Parameters
lpszBuffer XML Markup string.
Returns
The top level Markup element.

◆ RemoveCustomScriptItem()

void RemoveCustomScriptItem ( LPCWSTR lpName )

Removes a previously added named sciripting item from the context.

Parameters
lpName Scripting item name pointer.
See also
AddCustomScriptItem, GetScriptEngine

◆ RunScriptEngine()

void RunScriptEngine ( CXTPMarkupBuilder * pBuilder )

Runs script engine.

Parameters
pBuilder Pointer to the Markup builder that runs script engine.

◆ Scale()

CSize Scale ( const SIZE & size ) const

Performs x- and y- coordinate scaling according to active DPI settings if the Markup context is DPI aware.

Parameters
size Represents the item size.
Returns
If the Markup context is DPI aware, then a scaled value is returned. If the Markup context is not DPI aware, then an unchanged value is returned.
See also
SetDpiAware

◆ ScaleX() [1/3]

double ScaleX ( double x ) const

Performs x- and y- coordinate scaling according to active DPI settings if the Markup context is DPI aware.

Parameters
x Coordinates to scale according to active DPI settings.
Returns
If the Markup context is DPI aware, then a scaled value is returned. If the Markup context is not DPI aware, then an unchanged value is returned.
See also
SetDpiAware

◆ ScaleX() [2/3]

float ScaleX ( float x ) const

Performs x- and y- coordinate scaling according to active DPI settings if the Markup context is DPI aware.

Parameters
x Coordinates to scale according to active DPI settings.
Returns
If the Markup context is DPI aware, then a scaled value is returned. If the Markup context is not DPI aware, then an unchanged value is returned.
See also
SetDpiAware

◆ ScaleX() [3/3]

int ScaleX ( int x ) const

Performs x- and y- coordinate scaling according to active DPI settings if the Markup context is DPI aware.

Parameters
x Coordinates to scale according to active DPI settings.
Returns
If the Markup context is DPI aware, then a scaled value is returned. If the Markup context is not DPI aware, then an unchanged value is returned.
See also
SetDpiAware

◆ ScaleY() [1/3]

double ScaleY ( double y ) const

Performs x- and y- coordinate scaling according to active DPI settings if the Markup context is DPI aware.

Parameters
y Coordinates to scale according to active DPI settings.
Returns
If the Markup context is DPI aware, then a scaled value is returned. If the Markup context is not DPI aware, then an unchanged value is returned.
See also
SetDpiAware

◆ ScaleY() [2/3]

float ScaleY ( float y ) const

Performs x- and y- coordinate scaling according to active DPI settings if the Markup context is DPI aware.

Parameters
y Coordinates to scale according to active DPI settings.
Returns
If the Markup context is DPI aware, then a scaled value is returned. If the Markup context is not DPI aware, then an unchanged value is returned.
See also
SetDpiAware

◆ ScaleY() [3/3]

int ScaleY ( int y ) const

Performs x- and y- coordinate scaling according to active DPI settings if the Markup context is DPI aware.

Parameters
y Coordinates to scale according to active DPI settings.
Returns
If the Markup context is DPI aware, then a scaled value is returned. If the Markup context is not DPI aware, then an unchanged value is returned.
See also
SetDpiAware

◆ SetClientSite()

AFX_INLINE void SetClientSite ( IXTPMarkupClientSite * pSite )

Sets a client site pointer.

Parameters
pSite A new client site interface pointer or NULL.

◆ SetContextWindow()

void SetContextWindow | ( | HWND | hWnd,
 |  | LPCRECT | pUpdateRect = NULL )

Sets a window handle associated with markup context.

The specified window provides a devices context to render markup on and receives related notifications.

Parameters
hWnd | Window handle.
pUpdateRect | An optional update rectangle pointer.

◆ SetDefaultFont() [1/2]

AFX_INLINE void SetDefaultFont ( HFONT font )

Sets the default font for TextBlock objects.

Parameters
font New default font to set.

◆ SetDefaultFont() [2/2]

AFX_INLINE void SetDefaultFont ( LOGFONT * font )

Sets the default font for TextBlock objects.

Parameters
font New default font to set.

◆ SetDefaultSmoothingMode()

AFX_INLINE XTPMarkupSmoothingMode SetDefaultSmoothingMode ( XTPMarkupSmoothingMode smoothingMode )

Sets the default smoothing mode to be used for any drawing context that uses the context.

By default, smoothing mode is applied to all graphical elements except text. To enable text smoothing, refer to SetDefaultTextSmoothing.

Parameters
smoothingMode New smoothing mode to set; must be one of the values defined by the XTPMarkupSmoothingMode enumeration.
Returns
Current/previous smoothing mode; returns one of the values defined by the XTPMarkupSmoothingMode enumeration.
See also
GetDefaultTextSmoothing, SetDefaultTextSmoothing

◆ SetDefaultTextColor()

AFX_INLINE void SetDefaultTextColor ( COLORREF clr )

Sets the default text color for TextBlock objects.

Parameters
clr New default text color to set.

◆ SetDefaultTextSmoothing()

AFX_INLINE BOOL SetDefaultTextSmoothing ( BOOL bEnableTextSmoothing )

Determines/specifies if text smoothing is enabled for any drawing context that uses the context.

By default, smoothing mode is applied to all graphical elements except text.

Parameters
bEnableTextSmoothing TRUE to enable text smoothing according to the overall smoothing mode.
Returns
Current/previous text smoothing setting. TRUE if text smoothing is/was enabled, FALSE if text smoothing is/was disabled.
See also
GetDefaultSmoothingMode, SetDefaultSmoothingMode

◆ SetDelegate()

void SetDelegate | ( | LPCWSTR | lpszDelegate,
 |  | CXTPMarkupDelegate * | pDelegate )

Sets a delegate for a Markup text event.

Parameters
lpszDelegate | Text event delegate.
pDelegate | Method delegate.

Example:

<TextBlock><Hyperlink Click='OnClick'>FTSE 100</Hyperlink></TextBlock>
....
pPopup->GetMarkupContext()->SetDelegate(L"OnClick",
CreateMarkupFunctionDelegate(&HyperlinkClick));

◆ SetDpiAware() [1/3]

void SetDpiAware | ( | BOOL | bSet,
 |  | HDC | hDC )

Enables/disables context DPI awareness.

Parameters
bSet | TRUE to enable DPI awareness (i.e. make graphics scale according to active DPI settings).
hDC | If specified, then the device context information will be used for DPI translation.

◆ SetDpiAware() [2/3]

void SetDpiAware | ( | BOOL | bSet,
 |  | HWND | hWnd )

Enables/disables context DPI awareness.

Parameters
bSet | TRUE to enable DPI awareness (i.e. make graphics scale according to active DPI settings).
hWnd | If specified, then the window's device context information will be used for DPI translation.

◆ SetDpiAware() [3/3]

AFX_INLINE void SetDpiAware ( BOOL bSet = TRUE )

Enables/disables context DPI awareness.

Parameters
bSet TRUE to enable DPI awareness (i.e. make graphics scale according to active DPI settings).

◆ SetImageColorKey()

AFX_INLINE void SetImageColorKey ( COLORREF crColorKey )

Sets the context specific color key for an image element.

Parameters
crColorKey New color key value, or COLORREF_NULL.

If the context specific color key is set to COLORREF_NULL, then the color mask of the assigned image manager will be used in place of the context specific color key. If the color mask of the assigned image manager is also COLORREF_NULL, then a default value of RGB(0, 0xff, 0) will be used instead.

◆ SetImageManager()

void SetImageManager ( CXTPImageManager * pImageManager )

Sets the isolated image manager for elements inside the Markup context.

Parameters
pImageManager New image manager to use.

Example:

m_pMarkupContext->SetImageManager(new CXTPImageManager());

◆ SetUseCustomToolTipPosition()

AFX_INLINE void SetUseCustomToolTipPosition | ( | BOOL | bUse,
 |  | CPoint | ptPos = CPoint(0, 0) )

Enables/disables custom positioning for tooltips.

Parameters
bUse | TRUE to enable custom positioning for tooltips, FALSE to disable.
ptPos | CPoint that specifies the x- and y- coordinates of the tooltip window. These coordinates are always relative to the upper-left corner of the window.

This feature can be used before calling CXTPToolTipContext::FilterToolTipMessage to place a tooltip window in a desirable location.

See also
GetUseCustomToolTipPosition, GetCustomToolTipPosition

◆ Shutdown()

void Shutdown ( )

Performs internal cleanup necessary for the final release.

The context can be reused after shutdown, but all previous data and states will be lost.

◆ ValidateXML() [1/2]

CString ValidateXML ( LPCSTR lpszBuffer )

Validates XML correctness.

Parameters
lpszBuffer XML data to parse and validate.
Returns
A validation status message.

◆ ValidateXML() [2/2]

CString ValidateXML ( LPCWSTR lpszBuffer )

Validates XML correctness.

Parameters
lpszBuffer XML data to parse and validate.
Returns
A validation status message.
The documentation for this class was generated from the following file:
  • XTPMarkupContext.h


Toolkit Pro: CXTPMarkupControl Class Reference

Public Member Functions | List of all members
CXTPMarkupControl Class Reference

CXTPMarkupControl is a CXTPMarkupFrameworkElement derived class. More...

Inheritance diagram for CXTPMarkupControl:
[legend]

Public Member Functions

void | SetPadding (int nLeft, int nTop, int nRight, int nBottom)
Sets a value that indicates the thickness of the padding space between the boundaries of the content area and the content displayed by a control.
void | SetPadding (int nPadding)
Sets a value that indicates the thickness of the padding space between the boundaries of the content area and the content displayed by a control.
CXTPMarkupThickness * | GetPadding () const
Retrieves a value that indicates the thickness of the padding space between the boundaries of the content area and the content displayed by a control.
void | SetBackground (CXTPMarkupBrush *pBrush)
Sets the background brush for the control object.
CXTPMarkupBrush * | GetBackground () const
Gets the background brush of the control object.
void | SetForeground (CXTPMarkupBrush *pBrush)
Sets the default text brush for the control object.
CXTPMarkupBrush * | GetForeground () const
Gets the default text brush of the control object.
- Public Member Functions inherited from CXTPMarkupFrameworkElement
void | SetMargin (int nLeft, int nTop, int nRight, int nBottom)
Call this method to set the outer margin of an element.
void | SetMargin (int nMargin)
Call this method to set the outer margin of an element.
CXTPMarkupThickness * | GetMargin () const
Call this method to get the outer margin of an element.
void | SetMinWidth (int nWidth)
Sets the minimum width constraint for the element.
void | SetMaxWidth (int nWidth)
Sets the maximum width constraint for the element.
void | SetWidth (int nWidth)
Sets the width for the element.
void | SetMinHeight (int nHeight)
Sets the minimum height constraint for the element.
void | SetMaxHeight (int nHeight)
Sets the maximum height constraint for the element.
void | SetHeight (int nHeight)
Sets the height for the element.
int | GetMinWidth () const
Gets the minimum width constraint of the element.
int | GetMaxWidth () const
Gets the maximum width constraint of the element.
int | GetWidth () const
Gets the width of the element.
int | GetMinHeight () const
Gets the minimum height constraint of the element.
int | GetMaxHeight () const
Gets the maximum height constraint of the element.
int | GetHeight () const
Gets the height of the element.
CXTPMarkupObject * | GetTag () const
Gets the tag object of the element.
void | SetTag (CXTPMarkupObject *pTag)
Sets the tag object for the element.
void | SetHorizontalAlignment (XTPMarkupHorizontalAlignment alignment)
Sets the horizontal alignment characteristics applied to this element when it is composed within a parent element (e.g.
void | SetVerticalAlignment (XTPMarkupVerticalAlignment alignment)
Sets the vertical alignment characteristics applied to this element when it is composed within a parent element (e.g.
XTPMarkupHorizontalAlignment | GetHorizontalAlignment () const
Gets the horizontal alignment characteristics applied to this element when it is composed within a parent element (e.g.
XTPMarkupVerticalAlignment | GetVerticalAlignment () const
Gets the vertical alignment characteristics applied to this element when it is composed within a parent element (e.g.
CSize | GetActualSize () const
Retrieves the actual size of the element after it is measured and arranged within a parent element (e.g.
void | SetClipToBounds (BOOL bClipToBounds)
Specifies if child elements should be clipped inside element bounds.
BOOL | GetClipToBounds () const
Determines if child elements are clipped inside element bounds.
CXTPMarkupStyle * | GetStyle () const
Gets the attached style of the element.
- Public Member Functions inherited from CXTPMarkupUIElement
void | Arrange (CRect rcFinalRect)
Positions child elements and determines a size for a CXTPMarkupUIElement.
void | Measure (CXTPMarkupDrawingContext *pDC, CSize szAvailableSize)
Updates the DesiredSize of a CXTPMarkupUIElement.
CSize | GetDesiredSize () const
Gets the size that this element computed during the measure pass of the layout process.
CRect | GetFinalRect () const
Gets the final render size of this element.
XTPMarkupVisibility | GetVisibility () const
Gets the user interface (UI) visibility of this element.
void | SetVisibility (XTPMarkupVisibility visibility)
Sets the user interface (UI) visibility of this element.
BOOL | IsFocusable () const
Gets or sets a value indicating whether this element can receive focus.
virtual BOOL | IsVisible () const
Gets a value indicating whether this element is visible in the user interface (UI).
BOOL | IsEnabled () const
Gets or sets a value indicating whether this element is enabled in the user interface (UI).
virtual void | InvalidateArrange ()
Invalidates the arrange state (layout) for the element.
virtual void | InvalidateVisual ()
Invalidates the rendering of the element, and forces a new complete layout pass.
virtual void | InvalidateMeasure ()
Invalidates the measurement state (layout) for the element.
- Public Member Functions inherited from CXTPMarkupVisual
CXTPMarkupVisual ()
Provides the base initialization for objects derived from the CXTPMarkupVisual class.
virtual | ~CXTPMarkupVisual ()
Destroys a CXTPMarkupVisual object, handles cleanup and deallocation.
void | Render (CXTPMarkupDrawingContext *drawingContext)
Call this method to draw a Visual object inside a drawing context.
CXTPMarkupInputElement * | InputHitTest (CPoint point) const
Determines if a point belongs to this object.
virtual int | GetVisualChildrenCount () const
Gets the number of child elements for the Visual.
virtual CXTPMarkupVisual * | GetVisualChild (int nIndex) const
Retrieves the child Visual object located at a specified index within the parent VisualCollection.
virtual int | GetLogicalChildrenCount () const
Retrieves the number of logical child elements of this object.
virtual CXTPMarkupObject * | GetLogicalChild (int nIndex) const
Retrieves the logical child element located at a specified index within the parent collection.
CRect | GetBoundRect () const
Retrieves the bounding rectangle of the element.
CRect | GetUpdateRect () const
Computes the update rectangle.
CSize | GetRenderSize () const
Gets the final render size of this element.
CPoint | GetVisualOffset () const
Gets or sets the offset value of the visual object.
CXTPMarkupVisual * | GetVisualParent () const
Gets the Visual tree parent of the Visual object.

Additional Inherited Members

- Static Public Attributes inherited from CXTPMarkupUIElement
static CXTPMarkupDependencyProperty * | m_pClipToBoundsProperty
Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element.
static CXTPMarkupDependencyProperty * | m_pVisibilityProperty
A value indicating whether this element is visible in the user interface (UI).
static CXTPMarkupDependencyProperty * | m_pFocusableProperty
A value that indicates whether the element can receive focus.
static CXTPMarkupDependencyProperty * | m_pIsEnabledProperty
A value indicating whether thiselement is enabled in the user interface (UI).
static CXTPMarkupDependencyProperty * | m_pRenderTransformProperty
Gets or sets transform information that affects the rendering position of this element.
static CXTPMarkupDependencyProperty * | m_pRenderTransformOriginProperty
Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element.
static CXTPMarkupDependencyProperty * | m_pOpacityProperty
Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI).
- Protected Member Functions inherited from CXTPMarkupFrameworkElement
CXTPMarkupFrameworkElement ()
Initializes a new instance of the CXTPMarkupFrameworkElement class.
virtual | ~CXTPMarkupFrameworkElement ()
Destroys a CXTPMarkupFrameworkElement object, handles cleanup and deallocation.
- Protected Member Functions inherited from CXTPMarkupUIElement
CXTPMarkupUIElement ()
Initializes a new instance of the CXTPMarkupUIElement class.
virtual | ~CXTPMarkupUIElement ()
Destroys a CXTPMarkupUIElement object, handles cleanup and deallocation.
CXTPMarkupRenderTransform * | GetRenderTransform () const
Obtains a pointer to the RenderTransform object.
virtual void | ArrangeCore (CRect rcFinalRect)
Defines the template for the core-level arrange layout definition.
virtual CSize | MeasureCore (CXTPMarkupDrawingContext *pDC, CSize szAvailableSize)
When overridden in a derived class, provides measurement logic for sizing this element properly with consideration of the size of any child element content.
virtual BOOL | GetLayoutClip (CRect &rc) const
Retrieves an alternative clipping geometry that represents the region that would be clipped if child elements were clipped inside element bounds.
virtual void | InvalidateMeasureOverride (CXTPMarkupDrawingContext *pDC)
Override this method to provide a custom reaction to an InvalidateMeasure call.
virtual TransformationMatrices | ApplyRenderTransform (CXTPMarkupDrawingContext *pContext)
Applies render transformation if necessary.
virtual void | RestoreRenderTransform (CXTPMarkupDrawingContext *pContext, TransformationMatrices &matrices)
Restores a previously applied render transformation.
virtual double | GetOpacity () const
Gets either the default or explicitly set opacity factor value.
- Protected Member Functions inherited from CXTPMarkupVisual
BOOL | PtInRectTransform (const RECT &rect, const POINT &point) const
Checks if a point is inside a rectangle with transformation applied.
POINT | GetAbsoluteVisualOffset () const
Gets the absolute element visual offset.
virtual void | OnRender (CXTPMarkupDrawingContext *drawingContext)
When overridden in a derived class, participates in rendering operations that are directed by the layout system.
virtual void | OnRenderFocusVisual (CXTPMarkupDrawingContext *drawingContext)
This method is called to render the focus rectangle of a focused object.
virtual CXTPMarkupInputElement * | InputHitTestOverride (CPoint point) const
Override this method in the derived class to provide visual hit testing of a child object.
virtual void | RenderClipped (CXTPMarkupDrawingContext *drawingContext)
Called by the framework when an element is clipped and no rendering will occur.
- Protected Attributes inherited from CXTPMarkupUIElement
CSize | m_szDesiredSize
Gets the size that this element computed during the measure pass of the layout process.
CRect | m_rcFinalRect
Final position of the visual element.
BOOL | m_bMeasureDirty
TRUE if object hasn't recalculated its size.
BOOL | m_bNeverMeasured
TRUE if object has never ran Measure to update its size.
CSize | m_szPreviousAvailableSize
Previous available size of measure call.
BOOL | m_bArrangeDirty
TRUE if object position can be invalid.
BOOL | m_bNeverArranged
TRUE if Arrange was never called for this object.
BOOL | m_bArrangeInProgress
TRUE if Arrange is currently executed.
BOOL | m_bMeasureInProgress
TRUE if Measure is currently executed.
- Protected Attributes inherited from CXTPMarkupVisual
CPoint | m_ptVisualOffset
The offset value of the visual object.
CSize | m_szRenderSize
The rendered size for this element.
CRect | m_rcBoundRect
Bounding rectangle of the element.
CRect | m_rcUpdateRect
Update rectangle.
CRect | m_rcPrevUpdateRect
Previous update rectangle.

Detailed Description

CXTPMarkupControl is a CXTPMarkupFrameworkElement derived class.

It implements a base class for all control elements.

Member Function Documentation

◆ GetBackground()

CXTPMarkupBrush * GetBackground ( ) const

Gets the background brush of the control object.

Returns
A pointer to the background brush of the control object.

◆ GetForeground()

CXTPMarkupBrush * GetForeground ( ) const

Gets the default text brush of the control object.

Returns
A pointer to the default text brush of the control object.

◆ GetPadding()

CXTPMarkupThickness * GetPadding ( ) const

Retrieves a value that indicates the thickness of the padding space between the boundaries of the content area and the content displayed by a control.

Returns
A pointer to a CXTPMarkupThickness object that indicates the thickness of the padding space between the boundaries of the content area and the content displayed by a control.
See also
SetPadding

◆ SetBackground()

void SetBackground ( CXTPMarkupBrush * pBrush )

Sets the background brush for the control object.

Parameters
pBrush Pointer to a CBrush object.

◆ SetForeground()

void SetForeground ( CXTPMarkupBrush * pBrush )

Sets the default text brush for the control object.

Parameters
pBrush Pointer to a CBrush object.

◆ SetPadding() [1/2]

void SetPadding | ( | int | nLeft,
 |  | int | nTop,
 |  | int | nRight,
 |  | int | nBottom )

Sets a value that indicates the thickness of the padding space between the boundaries of the content area and the content displayed by a control.

Parameters
nLeft | Left space.
nTop | Top space.
nRight | Right space.
nBottom | Bottom space.

◆ SetPadding() [2/2]

void SetPadding ( int nPadding )

Sets a value that indicates the thickness of the padding space between the boundaries of the content area and the content displayed by a control.

Parameters
nPadding All borders.
The documentation for this class was generated from the following file:
  • XTPMarkupControl.h


Toolkit Pro: CXTPMarkupDecorator Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPMarkupDecorator Class Reference

CXTPMarkupDecorator is a CXTPMarkupFrameworkElement derived class. More...

Inheritance diagram for CXTPMarkupDecorator:
[legend]

Public Member Functions

void | SetChild (CXTPMarkupUIElement *pChild)
Sets a new child object for the decorator element.
CXTPMarkupUIElement * | GetChild () const
Retrieves the child object of the decorator element.
- Public Member Functions inherited from CXTPMarkupFrameworkElement
void | SetMargin (int nLeft, int nTop, int nRight, int nBottom)
Call this method to set the outer margin of an element.
void | SetMargin (int nMargin)
Call this method to set the outer margin of an element.
CXTPMarkupThickness * | GetMargin () const
Call this method to get the outer margin of an element.
void | SetMinWidth (int nWidth)
Sets the minimum width constraint for the element.
void | SetMaxWidth (int nWidth)
Sets the maximum width constraint for the element.
void | SetWidth (int nWidth)
Sets the width for the element.
void | SetMinHeight (int nHeight)
Sets the minimum height constraint for the element.
void | SetMaxHeight (int nHeight)
Sets the maximum height constraint for the element.
void | SetHeight (int nHeight)
Sets the height for the element.
int | GetMinWidth () const
Gets the minimum width constraint of the element.
int | GetMaxWidth () const
Gets the maximum width constraint of the element.
int | GetWidth () const
Gets the width of the element.
int | GetMinHeight () const
Gets the minimum height constraint of the element.
int | GetMaxHeight () const
Gets the maximum height constraint of the element.
int | GetHeight () const
Gets the height of the element.
CXTPMarkupObject * | GetTag () const
Gets the tag object of the element.
void | SetTag (CXTPMarkupObject *pTag)
Sets the tag object for the element.
void | SetHorizontalAlignment (XTPMarkupHorizontalAlignment alignment)
Sets the horizontal alignment characteristics applied to this element when it is composed within a parent element (e.g.
void | SetVerticalAlignment (XTPMarkupVerticalAlignment alignment)
Sets the vertical alignment characteristics applied to this element when it is composed within a parent element (e.g.
XTPMarkupHorizontalAlignment | GetHorizontalAlignment () const
Gets the horizontal alignment characteristics applied to this element when it is composed within a parent element (e.g.
XTPMarkupVerticalAlignment | GetVerticalAlignment () const
Gets the vertical alignment characteristics applied to this element when it is composed within a parent element (e.g.
CSize | GetActualSize () const
Retrieves the actual size of the element after it is measured and arranged within a parent element (e.g.
void | SetClipToBounds (BOOL bClipToBounds)
Specifies if child elements should be clipped inside element bounds.
BOOL | GetClipToBounds () const
Determines if child elements are clipped inside element bounds.
CXTPMarkupStyle * | GetStyle () const
Gets the attached style of the element.
- Public Member Functions inherited from CXTPMarkupUIElement
void | Arrange (CRect rcFinalRect)
Positions child elements and determines a size for a CXTPMarkupUIElement.
void | Measure (CXTPMarkupDrawingContext *pDC, CSize szAvailableSize)
Updates the DesiredSize of a CXTPMarkupUIElement.
CSize | GetDesiredSize () const
Gets the size that this element computed during the measure pass of the layout process.
CRect | GetFinalRect () const
Gets the final render size of this element.
XTPMarkupVisibility | GetVisibility () const
Gets the user interface (UI) visibility of this element.
void | SetVisibility (XTPMarkupVisibility visibility)
Sets the user interface (UI) visibility of this element.
BOOL | IsFocusable () const
Gets or sets a value indicating whether this element can receive focus.
virtual BOOL | IsVisible () const
Gets a value indicating whether this element is visible in the user interface (UI).
BOOL | IsEnabled () const
Gets or sets a value indicating whether this element is enabled in the user interface (UI).
virtual void | InvalidateArrange ()
Invalidates the arrange state (layout) for the element.
virtual void | InvalidateVisual ()
Invalidates the rendering of the element, and forces a new complete layout pass.
virtual void | InvalidateMeasure ()
Invalidates the measurement state (layout) for the element.
- Public Member Functions inherited from CXTPMarkupVisual
CXTPMarkupVisual ()
Provides the base initialization for objects derived from the CXTPMarkupVisual class.
virtual | ~CXTPMarkupVisual ()
Destroys a CXTPMarkupVisual object, handles cleanup and deallocation.
void | Render (CXTPMarkupDrawingContext *drawingContext)
Call this method to draw a Visual object inside a drawing context.
CXTPMarkupInputElement * | InputHitTest (CPoint point) const
Determines if a point belongs to this object.
virtual int | GetVisualChildrenCount () const
Gets the number of child elements for the Visual.
virtual CXTPMarkupVisual * | GetVisualChild (int nIndex) const
Retrieves the child Visual object located at a specified index within the parent VisualCollection.
virtual int | GetLogicalChildrenCount () const
Retrieves the number of logical child elements of this object.
virtual CXTPMarkupObject * | GetLogicalChild (int nIndex) const
Retrieves the logical child element located at a specified index within the parent collection.
CRect | GetBoundRect () const
Retrieves the bounding rectangle of the element.
CRect | GetUpdateRect () const
Computes the update rectangle.
CSize | GetRenderSize () const
Gets the final render size of this element.
CPoint | GetVisualOffset () const
Gets or sets the offset value of the visual object.
CXTPMarkupVisual * | GetVisualParent () const
Gets the Visual tree parent of the Visual object.

Protected Member Functions

CXTPMarkupDecorator ()
Constructs a CXTPMarkupDecorator object.
virtual | ~CXTPMarkupDecorator ()
Destroys a CXTPMarkupDecorator object, handles cleanup and deallocation.
- Protected Member Functions inherited from CXTPMarkupFrameworkElement
CXTPMarkupFrameworkElement ()
Initializes a new instance of the CXTPMarkupFrameworkElement class.
virtual | ~CXTPMarkupFrameworkElement ()
Destroys a CXTPMarkupFrameworkElement object, handles cleanup and deallocation.
- Protected Member Functions inherited from CXTPMarkupUIElement
CXTPMarkupUIElement ()
Initializes a new instance of the CXTPMarkupUIElement class.
virtual | ~CXTPMarkupUIElement ()
Destroys a CXTPMarkupUIElement object, handles cleanup and deallocation.
CXTPMarkupRenderTransform * | GetRenderTransform () const
Obtains a pointer to the RenderTransform object.
virtual void | ArrangeCore (CRect rcFinalRect)
Defines the template for the core-level arrange layout definition.
virtual CSize | MeasureCore (CXTPMarkupDrawingContext *pDC, CSize szAvailableSize)
When overridden in a derived class, provides measurement logic for sizing this element properly with consideration of the size of any child element content.
virtual BOOL | GetLayoutClip (CRect &rc) const
Retrieves an alternative clipping geometry that represents the region that would be clipped if child elements were clipped inside element bounds.
virtual void | InvalidateMeasureOverride (CXTPMarkupDrawingContext *pDC)
Override this method to provide a custom reaction to an InvalidateMeasure call.
virtual TransformationMatrices | ApplyRenderTransform (CXTPMarkupDrawingContext *pContext)
Applies render transformation if necessary.
virtual void | RestoreRenderTransform (CXTPMarkupDrawingContext *pContext, TransformationMatrices &matrices)
Restores a previously applied render transformation.
virtual double | GetOpacity () const
Gets either the default or explicitly set opacity factor value.
- Protected Member Functions inherited from CXTPMarkupVisual
BOOL | PtInRectTransform (const RECT &rect, const POINT &point) const
Checks if a point is inside a rectangle with transformation applied.
POINT | GetAbsoluteVisualOffset () const
Gets the absolute element visual offset.
virtual void | OnRender (CXTPMarkupDrawingContext *drawingContext)
When overridden in a derived class, participates in rendering operations that are directed by the layout system.
virtual void | OnRenderFocusVisual (CXTPMarkupDrawingContext *drawingContext)
This method is called to render the focus rectangle of a focused object.
virtual CXTPMarkupInputElement * | InputHitTestOverride (CPoint point) const
Override this method in the derived class to provide visual hit testing of a child object.
virtual void | RenderClipped (CXTPMarkupDrawingContext *drawingContext)
Called by the framework when an element is clipped and no rendering will occur.

Additional Inherited Members

- Static Public Attributes inherited from CXTPMarkupUIElement
static CXTPMarkupDependencyProperty * | m_pClipToBoundsProperty
Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element.
static CXTPMarkupDependencyProperty * | m_pVisibilityProperty
A value indicating whether this element is visible in the user interface (UI).
static CXTPMarkupDependencyProperty * | m_pFocusableProperty
A value that indicates whether the element can receive focus.
static CXTPMarkupDependencyProperty * | m_pIsEnabledProperty
A value indicating whether thiselement is enabled in the user interface (UI).
static CXTPMarkupDependencyProperty * | m_pRenderTransformProperty
Gets or sets transform information that affects the rendering position of this element.
static CXTPMarkupDependencyProperty * | m_pRenderTransformOriginProperty
Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element.
static CXTPMarkupDependencyProperty * | m_pOpacityProperty
Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI).
- Protected Attributes inherited from CXTPMarkupUIElement
CSize | m_szDesiredSize
Gets the size that this element computed during the measure pass of the layout process.
CRect | m_rcFinalRect
Final position of the visual element.
BOOL | m_bMeasureDirty
TRUE if object hasn't recalculated its size.
BOOL | m_bNeverMeasured
TRUE if object has never ran Measure to update its size.
CSize | m_szPreviousAvailableSize
Previous available size of measure call.
BOOL | m_bArrangeDirty
TRUE if object position can be invalid.
BOOL | m_bNeverArranged
TRUE if Arrange was never called for this object.
BOOL | m_bArrangeInProgress
TRUE if Arrange is currently executed.
BOOL | m_bMeasureInProgress
TRUE if Measure is currently executed.
- Protected Attributes inherited from CXTPMarkupVisual
CPoint | m_ptVisualOffset
The offset value of the visual object.
CSize | m_szRenderSize
The rendered size for this element.
CRect | m_rcBoundRect
Bounding rectangle of the element.
CRect | m_rcUpdateRect
Update rectangle.
CRect | m_rcPrevUpdateRect
Previous update rectangle.

Detailed Description

CXTPMarkupDecorator is a CXTPMarkupFrameworkElement derived class.

It implements a basic framework element with a single child.

Member Function Documentation

◆ GetChild()

CXTPMarkupUIElement * GetChild ( ) const

Retrieves the child object of the decorator element.

Returns
The child CXTPMarkupUIElement object.
See also
SetChild

◆ SetChild()

void SetChild ( CXTPMarkupUIElement * pChild )

Sets a new child object for the decorator element.

Parameters
pChild New child CXTPMarkupUIElement object.
See also
GetChild
The documentation for this class was generated from the following file:
  • XTPMarkupDecorator.h


Toolkit Pro: CXTPMarkupDefinitionBase Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPMarkupDefinitionBase Class Reference

CXTPMarkupDefinitionBase is the base class for CXTPMarkupColumnDefinition and CXTPMarkupRowDefinition that defines constraints and definitions for grid rows and columns. More...

Inheritance diagram for CXTPMarkupDefinitionBase:
[legend]

Public Member Functions

int | GetUserMinSize () const
Retrieves the minimum constraint for user-defined column or row size.
int | GetUserMaxSize () const
Retrieves the maximum constraint for user-defined column or row size.
CXTPMarkupGridLength * | GetUserSize () const
Retrieves the user-defined column or row size.

Protected Member Functions

CXTPMarkupDefinitionBase (BOOL bIsColumnDefinition=FALSE)
Constructs a CXTPMarkupDefinitionBase object.

Detailed Description

CXTPMarkupDefinitionBase is the base class for CXTPMarkupColumnDefinition and CXTPMarkupRowDefinition that defines constraints and definitions for grid rows and columns.

Constructor & Destructor Documentation

◆ CXTPMarkupDefinitionBase()

CXTPMarkupDefinitionBase ( BOOL bIsColumnDefinition = FALSE )
protected

Constructs a CXTPMarkupDefinitionBase object.

Parameters
bIsColumnDefinition TRUE for CXTPMarkupColumnDefinition, FALSE for CXTPMarkupRowDefinition.

Member Function Documentation

◆ GetUserMaxSize()

int GetUserMaxSize ( ) const

Retrieves the maximum constraint for user-defined column or row size.

Returns
The maximum constraint for user-defined column or row size.

◆ GetUserMinSize()

int GetUserMinSize ( ) const

Retrieves the minimum constraint for user-defined column or row size.

Returns
The minimum constraint for user-defined column or row size.

◆ GetUserSize()

CXTPMarkupGridLength * GetUserSize ( ) const

Retrieves the user-defined column or row size.

Returns
The user-defined column or row size.
The documentation for this class was generated from the following file:
  • XTPMarkupDefinitionBase.h


Toolkit Pro: CXTPMarkupDefinitionCollection Class Reference

Public Member Functions | List of all members
CXTPMarkupDefinitionCollection Class Reference

CXTPMarkupDefinitionCollection is the base class for CXTPMarkupDefinitionCollection and CXTPMarkupDefinitionCollection. More...

Inheritance diagram for CXTPMarkupDefinitionCollection:
[legend]

Public Member Functions

CXTPMarkupDefinitionCollection ()
Constructs a CXTPMarkupDefinitionCollection object.
CXTPMarkupDefinitionBase * GetItem (int nIndex) const
Retrieves a CXTPMarkupDefinitionBase object by its index.

Detailed Description

CXTPMarkupDefinitionCollection is the base class for CXTPMarkupDefinitionCollection and CXTPMarkupDefinitionCollection.

It implements the RowDefinition XAML Tag.

Member Function Documentation

◆ GetItem()

AFX_INLINE CXTPMarkupDefinitionBase * GetItem ( int nIndex ) const

Retrieves a CXTPMarkupDefinitionBase object by its index.

Parameters
nIndex Index of the CXTPMarkupDefinitionBase object to retrieve.
Returns
A CXTPMarkupDefinitionBase object.
The documentation for this class was generated from the following file:
  • XTPMarkupGrid.h


Toolkit Pro: CXTPMarkupDeviceDependentImage Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPMarkupDeviceDependentImage Class Referenceabstract

Implements an abstract device dependent image. More...

Inheritance diagram for CXTPMarkupDeviceDependentImage:
[legend]

Public Member Functions

virtual | ~CXTPMarkupDeviceDependentImage ()
Handles device dependent image object deallocation.
virtual BOOL | Load (LPCWSTR lpszSource, int nWidth, int nHeight=0)=0
Loads an image from a specified resource.
const CSize & | GetSize () const
Obtains the image size, in pixels.
BOOL | IsLoaded () const
Checks if an image is loaded.
BOOL | IsIcon () const
Checks if the loaded image is an icon.
IXTPMarkupDeviceDependentImageSite * | GetSite () const
Obtains the site object pointer.

Protected Member Functions

CXTPMarkupDeviceDependentImage (IXTPMarkupDeviceDependentImageSite *pSite)
Constructs a device dependent image object.

Detailed Description

Implements an abstract device dependent image.

Whether it is a GDI or GDI+ device context, each has its own implementation, optimization, set of supported formats, and capabilities.

Constructor & Destructor Documentation

◆ CXTPMarkupDeviceDependentImage()

CXTPMarkupDeviceDependentImage ( IXTPMarkupDeviceDependentImageSite * pSite )
explicitprotected

Constructs a device dependent image object.

Parameters
pSite Valid pointer to an image site interface.

Member Function Documentation

◆ GetSite()

AFX_INLINE IXTPMarkupDeviceDependentImageSite * GetSite ( ) const

Obtains the site object pointer.

Returns
The site object pointer.

◆ GetSize()

AFX_INLINE const CSize & GetSize ( ) const

Obtains the image size, in pixels.

Returns
The image size, in pixels.

◆ IsIcon()

AFX_INLINE BOOL IsIcon ( ) const

Checks if the loaded image is an icon.

Returns
TRUE if the loaded image is an icon.

◆ IsLoaded()

AFX_INLINE BOOL IsLoaded ( ) const

Checks if an image is loaded.

Returns
TRUE if an image is loaded.

◆ Load()

virtual BOOL Load | ( | LPCWSTR | lpszSource,
 |  | int | nWidth,
 |  | int | nHeight = 0 )
 pure virtual

Loads an image from a specified resource.

Parameters
lpszSource | Pointer to a string that indicates the image source. Can be a relative or full file path, file:// path, res:// path, or an integer in decimal representation that indicates the icon index.
nWidth | Width of the image to be loaded. Used only for icons. Can be 0 if not relevant.
nHeight | Width of the image to be loaded. Used only for XAML and SVG icons.
Returns
TRUE if the image is loaded successfully.

Implemented in CXTPMarkupGdiImage, and CXTPMarkupGdiPlusImage.

The documentation for this class was generated from the following file:
  • XTPMarkupDeviceDependentImage.h


Toolkit Pro: CXTPMarkupDockPanel Class Reference

Public Member Functions | Static Public Member Functions | Protected Member Functions | List of all members
CXTPMarkupDockPanel Class Reference

CXTPMarkupDockPanel is a CXTPMarkupPanel derived class. More...

Inheritance diagram for CXTPMarkupDockPanel:
[legend]

Public Member Functions

void | SetLastChildFill (BOOL bLastChildFill)
Specifies if the last child element inside the whole client area of DockPanel should be filled.
BOOL | GetLastChildFill () const
Determines if the last child element inside the whole client area of DockPanel is filled.
- Public Member Functions inherited from CXTPMarkupPanel
CXTPMarkupUIElementCollection * | GetChildren () const
Retrieves the collection of child elements.
void | SetBackground (CXTPMarkupBrush *pBrush)
Sets the background brush for the panel object.
CXTPMarkupBrush * | GetBackground () const
Gets the background brush of the panel object.
- Public Member Functions inherited from CXTPMarkupFrameworkElement
void | SetMargin (int nLeft, int nTop, int nRight, int nBottom)
Call this method to set the outer margin of an element.
void | SetMargin (int nMargin)
Call this method to set the outer margin of an element.
CXTPMarkupThickness * | GetMargin () const
Call this method to get the outer margin of an element.
void | SetMinWidth (int nWidth)
Sets the minimum width constraint for the element.
void | SetMaxWidth (int nWidth)
Sets the maximum width constraint for the element.
void | SetWidth (int nWidth)
Sets the width for the element.
void | SetMinHeight (int nHeight)
Sets the minimum height constraint for the element.
void | SetMaxHeight (int nHeight)
Sets the maximum height constraint for the element.
void | SetHeight (int nHeight)
Sets the height for the element.
int | GetMinWidth () const
Gets the minimum width constraint of the element.
int | GetMaxWidth () const
Gets the maximum width constraint of the element.
int | GetWidth () const
Gets the width of the element.
int | GetMinHeight () const
Gets the minimum height constraint of the element.
int | GetMaxHeight () const
Gets the maximum height constraint of the element.
int | GetHeight () const
Gets the height of the element.
CXTPMarkupObject * | GetTag () const
Gets the tag object of the element.
void | SetTag (CXTPMarkupObject *pTag)
Sets the tag object for the element.
void | SetHorizontalAlignment (XTPMarkupHorizontalAlignment alignment)
Sets the horizontal alignment characteristics applied to this element when it is composed within a parent element (e.g.
void | SetVerticalAlignment (XTPMarkupVerticalAlignment alignment)
Sets the vertical alignment characteristics applied to this element when it is composed within a parent element (e.g.
XTPMarkupHorizontalAlignment | GetHorizontalAlignment () const
Gets the horizontal alignment characteristics applied to this element when it is composed within a parent element (e.g.
XTPMarkupVerticalAlignment | GetVerticalAlignment () const
Gets the vertical alignment characteristics applied to this element when it is composed within a parent element (e.g.
CSize | GetActualSize () const
Retrieves the actual size of the element after it is measured and arranged within a parent element (e.g.
void | SetClipToBounds (BOOL bClipToBounds)
Specifies if child elements should be clipped inside element bounds.
BOOL | GetClipToBounds () const
Determines if child elements are clipped inside element bounds.
CXTPMarkupStyle * | GetStyle () const
Gets the attached style of the element.
- Public Member Functions inherited from CXTPMarkupUIElement
void | Arrange (CRect rcFinalRect)
Positions child elements and determines a size for a CXTPMarkupUIElement.
void | Measure (CXTPMarkupDrawingContext *pDC, CSize szAvailableSize)
Updates the DesiredSize of a CXTPMarkupUIElement.
CSize | GetDesiredSize () const
Gets the size that this element computed during the measure pass of the layout process.
CRect | GetFinalRect () const
Gets the final render size of this element.
XTPMarkupVisibility | GetVisibility () const
Gets the user interface (UI) visibility of this element.
void | SetVisibility (XTPMarkupVisibility visibility)
Sets the user interface (UI) visibility of this element.
BOOL | IsFocusable () const
Gets or sets a value indicating whether this element can receive focus.
virtual BOOL | IsVisible () const
Gets a value indicating whether this element is visible in the user interface (UI).
BOOL | IsEnabled () const
Gets or sets a value indicating whether this element is enabled in the user interface (UI).
virtual void | InvalidateArrange ()
Invalidates the arrange state (layout) for the element.
virtual void | InvalidateVisual ()
Invalidates the rendering of the element, and forces a new complete layout pass.
virtual void | InvalidateMeasure ()
Invalidates the measurement state (layout) for the element.
- Public Member Functions inherited from CXTPMarkupVisual
CXTPMarkupVisual ()
Provides the base initialization for objects derived from the CXTPMarkupVisual class.
virtual | ~CXTPMarkupVisual ()
Destroys a CXTPMarkupVisual object, handles cleanup and deallocation.
void | Render (CXTPMarkupDrawingContext *drawingContext)
Call this method to draw a Visual object inside a drawing context.
CXTPMarkupInputElement * | InputHitTest (CPoint point) const
Determines if a point belongs to this object.
virtual int | GetVisualChildrenCount () const
Gets the number of child elements for the Visual.
virtual CXTPMarkupVisual * | GetVisualChild (int nIndex) const
Retrieves the child Visual object located at a specified index within the parent VisualCollection.
virtual int | GetLogicalChildrenCount () const
Retrieves the number of logical child elements of this object.
virtual CXTPMarkupObject * | GetLogicalChild (int nIndex) const
Retrieves the logical child element located at a specified index within the parent collection.
CRect | GetBoundRect () const
Retrieves the bounding rectangle of the element.
CRect | GetUpdateRect () const
Computes the update rectangle.
CSize | GetRenderSize () const
Gets the final render size of this element.
CPoint | GetVisualOffset () const
Gets or sets the offset value of the visual object.
CXTPMarkupVisual * | GetVisualParent () const
Gets the Visual tree parent of the Visual object.

Static Public Member Functions

static void AFX_CDECL | SetDock (CXTPMarkupUIElement *pElement, XTPMarkupDock dock)
Sets the dock position for a child element.
static XTPMarkupDock AFX_CDECL | GetDock (CXTPMarkupUIElement *pElement)
Retrieves the dock position of a child element.

Protected Member Functions

CXTPMarkupDockPanel ()
Constructs a CXTPMarkupDockPanel object.
virtual | ~CXTPMarkupDockPanel ()
Destroys a CXTPMarkupDockPanel object, handles cleanup and deallocation.
- Protected Member Functions inherited from CXTPMarkupPanel
CXTPMarkupPanel ()
Constructs a CXTPMarkupPanel object.
virtual | ~CXTPMarkupPanel ()
Destroys a CXTPMarkupPanel object, handles cleanup and deallocation.
- Protected Member Functions inherited from CXTPMarkupFrameworkElement
CXTPMarkupFrameworkElement ()
Initializes a new instance of the CXTPMarkupFrameworkElement class.
virtual | ~CXTPMarkupFrameworkElement ()
Destroys a CXTPMarkupFrameworkElement object, handles cleanup and deallocation.
- Protected Member Functions inherited from CXTPMarkupUIElement
CXTPMarkupUIElement ()
Initializes a new instance of the CXTPMarkupUIElement class.
virtual | ~CXTPMarkupUIElement ()
Destroys a CXTPMarkupUIElement object, handles cleanup and deallocation.
CXTPMarkupRenderTransform * | GetRenderTransform () const
Obtains a pointer to the RenderTransform object.
virtual void | ArrangeCore (CRect rcFinalRect)
Defines the template for the core-level arrange layout definition.
virtual CSize | MeasureCore (CXTPMarkupDrawingContext *pDC, CSize szAvailableSize)
When overridden in a derived class, provides measurement logic for sizing this element properly with consideration of the size of any child element content.
virtual BOOL | GetLayoutClip (CRect &rc) const
Retrieves an alternative clipping geometry that represents the region that would be clipped if child elements were clipped inside element bounds.
virtual void | InvalidateMeasureOverride (CXTPMarkupDrawingContext *pDC)
Override this method to provide a custom reaction to an InvalidateMeasure call.
virtual TransformationMatrices | ApplyRenderTransform (CXTPMarkupDrawingContext *pContext)
Applies render transformation if necessary.
virtual void | RestoreRenderTransform (CXTPMarkupDrawingContext *pContext, TransformationMatrices &matrices)
Restores a previously applied render transformation.
virtual double | GetOpacity () const
Gets either the default or explicitly set opacity factor value.
- Protected Member Functions inherited from CXTPMarkupVisual
BOOL | PtInRectTransform (const RECT &rect, const POINT &point) const
Checks if a point is inside a rectangle with transformation applied.
POINT | GetAbsoluteVisualOffset () const
Gets the absolute element visual offset.
virtual void | OnRender (CXTPMarkupDrawingContext *drawingContext)
When overridden in a derived class, participates in rendering operations that are directed by the layout system.
virtual void | OnRenderFocusVisual (CXTPMarkupDrawingContext *drawingContext)
This method is called to render the focus rectangle of a focused object.
virtual CXTPMarkupInputElement * | InputHitTestOverride (CPoint point) const
Override this method in the derived class to provide visual hit testing of a child object.
virtual void | RenderClipped (CXTPMarkupDrawingContext *drawingContext)
Called by the framework when an element is clipped and no rendering will occur.

Additional Inherited Members

- Static Public Attributes inherited from CXTPMarkupUIElement
static CXTPMarkupDependencyProperty * | m_pClipToBoundsProperty
Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element.
static CXTPMarkupDependencyProperty * | m_pVisibilityProperty
A value indicating whether this element is visible in the user interface (UI).
static CXTPMarkupDependencyProperty * | m_pFocusableProperty
A value that indicates whether the element can receive focus.
static CXTPMarkupDependencyProperty * | m_pIsEnabledProperty
A value indicating whether thiselement is enabled in the user interface (UI).
static CXTPMarkupDependencyProperty * | m_pRenderTransformProperty
Gets or sets transform information that affects the rendering position of this element.
static CXTPMarkupDependencyProperty * | m_pRenderTransformOriginProperty
Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element.
static CXTPMarkupDependencyProperty * | m_pOpacityProperty
Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI).
- Protected Attributes inherited from CXTPMarkupUIElement
CSize | m_szDesiredSize
Gets the size that this element computed during the measure pass of the layout process.
CRect | m_rcFinalRect
Final position of the visual element.
BOOL | m_bMeasureDirty
TRUE if object hasn't recalculated its size.
BOOL | m_bNeverMeasured
TRUE if object has never ran Measure to update its size.
CSize | m_szPreviousAvailableSize
Previous available size of measure call.
BOOL | m_bArrangeDirty
TRUE if object position can be invalid.
BOOL | m_bNeverArranged
TRUE if Arrange was never called for this object.
BOOL | m_bArrangeInProgress
TRUE if Arrange is currently executed.
BOOL | m_bMeasureInProgress
TRUE if Measure is currently executed.
- Protected Attributes inherited from CXTPMarkupVisual
CPoint | m_ptVisualOffset
The offset value of the visual object.
CSize | m_szRenderSize
The rendered size for this element.
CRect | m_rcBoundRect
Bounding rectangle of the element.
CRect | m_rcUpdateRect
Update rectangle.
CRect | m_rcPrevUpdateRect
Previous update rectangle.

Detailed Description

CXTPMarkupDockPanel is a CXTPMarkupPanel derived class.

It implements the DockPanel XAML Tag.

Member Function Documentation

◆ GetDock()

static XTPMarkupDock AFX_CDECL GetDock ( CXTPMarkupUIElement * pElement )
static

Retrieves the dock position of a child element.

Parameters
pElement Pointer to the child element whose dock position must be retrieved.
Returns
The dock position of the child element; returns one of the values defined by the XTPMarkupDock enumeration.

◆ GetLastChildFill()

BOOL GetLastChildFill ( ) const

Determines if the last child element inside the whole client area of DockPanel is filled.

Returns
TRUE if the last child element is filled, otherwise FALSE.

◆ SetDock()

static void AFX_CDECL SetDock | ( | CXTPMarkupUIElement * | pElement,
 |  | XTPMarkupDock | dock )
 static

Sets the dock position for a child element.

Parameters
pElement | Pointer to the child element whose dock position must be set.
dock | New dock position for the child element; must be one of the values defined by the XTPMarkupDock enumeration.
Returns

◆ SetLastChildFill()

void SetLastChildFill ( BOOL bLastChildFill )

Specifies if the last child element inside the whole client area of DockPanel should be filled.

Parameters
bLastChildFill TRUE to fill the last child element, FALSE otherwise.
The documentation for this class was generated from the following file:
  • XTPMarkupDockPanel.h


Toolkit Pro: CXTPMarkupExtension Class Reference

Protected Member Functions | List of all members
CXTPMarkupExtension Class Reference

Base class for all markup extension objects. More...

Inheritance diagram for CXTPMarkupExtension:
[legend]

Protected Member Functions

CXTPMarkupExtension ()
Constructs markup extension object.

Detailed Description

Base class for all markup extension objects.

The documentation for this class was generated from the following file:
  • XTPMarkupExtension.h


Toolkit Pro: CXTPMarkupFrameworkElement Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPMarkupFrameworkElement Class Reference

This class represents the provided framework-level implementation built on CXTPMarkupUIElement. More...

Inheritance diagram for CXTPMarkupFrameworkElement:
[legend]

Public Member Functions

void | SetMargin (int nLeft, int nTop, int nRight, int nBottom)
Call this method to set the outer margin of an element.
void | SetMargin (int nMargin)
Call this method to set the outer margin of an element.
CXTPMarkupThickness * | GetMargin () const
Call this method to get the outer margin of an element.
void | SetMinWidth (int nWidth)
Sets the minimum width constraint for the element.
void | SetMaxWidth (int nWidth)
Sets the maximum width constraint for the element.
void | SetWidth (int nWidth)
Sets the width for the element.
void | SetMinHeight (int nHeight)
Sets the minimum height constraint for the element.
void | SetMaxHeight (int nHeight)
Sets the maximum height constraint for the element.
void | SetHeight (int nHeight)
Sets the height for the element.
int | GetMinWidth () const
Gets the minimum width constraint of the element.
int | GetMaxWidth () const
Gets the maximum width constraint of the element.
int | GetWidth () const
Gets the width of the element.
int | GetMinHeight () const
Gets the minimum height constraint of the element.
int | GetMaxHeight () const
Gets the maximum height constraint of the element.
int | GetHeight () const
Gets the height of the element.
CXTPMarkupObject * | GetTag () const
Gets the tag object of the element.
void | SetTag (CXTPMarkupObject *pTag)
Sets the tag object for the element.
void | SetHorizontalAlignment (XTPMarkupHorizontalAlignment alignment)
Sets the horizontal alignment characteristics applied to this element when it is composed within a parent element (e.g.
void | SetVerticalAlignment (XTPMarkupVerticalAlignment alignment)
Sets the vertical alignment characteristics applied to this element when it is composed within a parent element (e.g.
XTPMarkupHorizontalAlignment | GetHorizontalAlignment () const
Gets the horizontal alignment characteristics applied to this element when it is composed within a parent element (e.g.
XTPMarkupVerticalAlignment | GetVerticalAlignment () const
Gets the vertical alignment characteristics applied to this element when it is composed within a parent element (e.g.
CSize | GetActualSize () const
Retrieves the actual size of the element after it is measured and arranged within a parent element (e.g.
void | SetClipToBounds (BOOL bClipToBounds)
Specifies if child elements should be clipped inside element bounds.
BOOL | GetClipToBounds () const
Determines if child elements are clipped inside element bounds.
CXTPMarkupStyle * | GetStyle () const
Gets the attached style of the element.
- Public Member Functions inherited from CXTPMarkupUIElement
void | Arrange (CRect rcFinalRect)
Positions child elements and determines a size for a CXTPMarkupUIElement.
void | Measure (CXTPMarkupDrawingContext *pDC, CSize szAvailableSize)
Updates the DesiredSize of a CXTPMarkupUIElement.
CSize | GetDesiredSize () const
Gets the size that this element computed during the measure pass of the layout process.
CRect | GetFinalRect () const
Gets the final render size of this element.
XTPMarkupVisibility | GetVisibility () const
Gets the user interface (UI) visibility of this element.
void | SetVisibility (XTPMarkupVisibility visibility)
Sets the user interface (UI) visibility of this element.
BOOL | IsFocusable () const
Gets or sets a value indicating whether this element can receive focus.
virtual BOOL | IsVisible () const
Gets a value indicating whether this element is visible in the user interface (UI).
BOOL | IsEnabled () const
Gets or sets a value indicating whether this element is enabled in the user interface (UI).
virtual void | InvalidateArrange ()
Invalidates the arrange state (layout) for the element.
virtual void | InvalidateVisual ()
Invalidates the rendering of the element, and forces a new complete layout pass.
virtual void | InvalidateMeasure ()
Invalidates the measurement state (layout) for the element.
- Public Member Functions inherited from CXTPMarkupVisual
CXTPMarkupVisual ()
Provides the base initialization for objects derived from the CXTPMarkupVisual class.
virtual | ~CXTPMarkupVisual ()
Destroys a CXTPMarkupVisual object, handles cleanup and deallocation.
void | Render (CXTPMarkupDrawingContext *drawingContext)
Call this method to draw a Visual object inside a drawing context.
CXTPMarkupInputElement * | InputHitTest (CPoint point) const
Determines if a point belongs to this object.
virtual int | GetVisualChildrenCount () const
Gets the number of child elements for the Visual.
virtual CXTPMarkupVisual * | GetVisualChild (int nIndex) const
Retrieves the child Visual object located at a specified index within the parent VisualCollection.
virtual int | GetLogicalChildrenCount () const
Retrieves the number of logical child elements of this object.
virtual CXTPMarkupObject * | GetLogicalChild (int nIndex) const
Retrieves the logical child element located at a specified index within the parent collection.
CRect | GetBoundRect () const
Retrieves the bounding rectangle of the element.
CRect | GetUpdateRect () const
Computes the update rectangle.
CSize | GetRenderSize () const
Gets the final render size of this element.
CPoint | GetVisualOffset () const
Gets or sets the offset value of the visual object.
CXTPMarkupVisual * | GetVisualParent () const
Gets the Visual tree parent of the Visual object.

Protected Member Functions

CXTPMarkupFrameworkElement ()
Initializes a new instance of the CXTPMarkupFrameworkElement class.
virtual | ~CXTPMarkupFrameworkElement ()
Destroys a CXTPMarkupFrameworkElement object, handles cleanup and deallocation.
- Protected Member Functions inherited from CXTPMarkupUIElement
CXTPMarkupUIElement ()
Initializes a new instance of the CXTPMarkupUIElement class.
virtual | ~CXTPMarkupUIElement ()
Destroys a CXTPMarkupUIElement object, handles cleanup and deallocation.
CXTPMarkupRenderTransform * | GetRenderTransform () const
Obtains a pointer to the RenderTransform object.
virtual void | ArrangeCore (CRect rcFinalRect)
Defines the template for the core-level arrange layout definition.
virtual CSize | MeasureCore (CXTPMarkupDrawingContext *pDC, CSize szAvailableSize)
When overridden in a derived class, provides measurement logic for sizing this element properly with consideration of the size of any child element content.
virtual BOOL | GetLayoutClip (CRect &rc) const
Retrieves an alternative clipping geometry that represents the region that would be clipped if child elements were clipped inside element bounds.
virtual void | InvalidateMeasureOverride (CXTPMarkupDrawingContext *pDC)
Override this method to provide a custom reaction to an InvalidateMeasure call.
virtual TransformationMatrices | ApplyRenderTransform (CXTPMarkupDrawingContext *pContext)
Applies render transformation if necessary.
virtual void | RestoreRenderTransform (CXTPMarkupDrawingContext *pContext, TransformationMatrices &matrices)
Restores a previously applied render transformation.
virtual double | GetOpacity () const
Gets either the default or explicitly set opacity factor value.
- Protected Member Functions inherited from CXTPMarkupVisual
BOOL | PtInRectTransform (const RECT &rect, const POINT &point) const
Checks if a point is inside a rectangle with transformation applied.
POINT | GetAbsoluteVisualOffset () const
Gets the absolute element visual offset.
virtual void | OnRender (CXTPMarkupDrawingContext *drawingContext)
When overridden in a derived class, participates in rendering operations that are directed by the layout system.
virtual void | OnRenderFocusVisual (CXTPMarkupDrawingContext *drawingContext)
This method is called to render the focus rectangle of a focused object.
virtual CXTPMarkupInputElement * | InputHitTestOverride (CPoint point) const
Override this method in the derived class to provide visual hit testing of a child object.
virtual void | RenderClipped (CXTPMarkupDrawingContext *drawingContext)
Called by the framework when an element is clipped and no rendering will occur.

Additional Inherited Members

- Static Public Attributes inherited from CXTPMarkupUIElement
static CXTPMarkupDependencyProperty * | m_pClipToBoundsProperty
Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element.
static CXTPMarkupDependencyProperty * | m_pVisibilityProperty
A value indicating whether this element is visible in the user interface (UI).
static CXTPMarkupDependencyProperty * | m_pFocusableProperty
A value that indicates whether the element can receive focus.
static CXTPMarkupDependencyProperty * | m_pIsEnabledProperty
A value indicating whether thiselement is enabled in the user interface (UI).
static CXTPMarkupDependencyProperty * | m_pRenderTransformProperty
Gets or sets transform information that affects the rendering position of this element.
static CXTPMarkupDependencyProperty * | m_pRenderTransformOriginProperty
Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element.
static CXTPMarkupDependencyProperty * | m_pOpacityProperty
Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI).
- Protected Attributes inherited from CXTPMarkupUIElement
CSize | m_szDesiredSize
Gets the size that this element computed during the measure pass of the layout process.
CRect | m_rcFinalRect
Final position of the visual element.
BOOL | m_bMeasureDirty
TRUE if object hasn't recalculated its size.
BOOL | m_bNeverMeasured
TRUE if object has never ran Measure to update its size.
CSize | m_szPreviousAvailableSize
Previous available size of measure call.
BOOL | m_bArrangeDirty
TRUE if object position can be invalid.
BOOL | m_bNeverArranged
TRUE if Arrange was never called for this object.
BOOL | m_bArrangeInProgress
TRUE if Arrange is currently executed.
BOOL | m_bMeasureInProgress
TRUE if Measure is currently executed.
- Protected Attributes inherited from CXTPMarkupVisual
CPoint | m_ptVisualOffset
The offset value of the visual object.
CSize | m_szRenderSize
The rendered size for this element.
CRect | m_rcBoundRect
Bounding rectangle of the element.
CRect | m_rcUpdateRect
Update rectangle.
CRect | m_rcPrevUpdateRect
Previous update rectangle.

Detailed Description

This class represents the provided framework-level implementation built on CXTPMarkupUIElement.

Member Function Documentation

◆ GetActualSize()

CSize GetActualSize ( ) const

Retrieves the actual size of the element after it is measured and arranged within a parent element (e.g.

a panel or items control).

Returns
A CSize object containing the actual size of the element.

◆ GetClipToBounds()

BOOL GetClipToBounds ( ) const

Determines if child elements are clipped inside element bounds.

Returns
TRUE if child elements are clipped inside element bounds.

◆ GetHeight()

int GetHeight ( ) const

Gets the height of the element.

Returns
The height of the element.

◆ GetHorizontalAlignment()

XTPMarkupHorizontalAlignment GetHorizontalAlignment ( ) const

Gets the horizontal alignment characteristics applied to this element when it is composed within a parent element (e.g.

a panel or items control).

Returns
An XTPMarkupHorizontalAlignment enumeration value.

◆ GetMargin()

CXTPMarkupThickness * GetMargin ( ) const

Call this method to get the outer margin of an element.

Returns
A pointer to a CXTPMarkupThickness object containing outer margin values.

◆ GetMaxHeight()

int GetMaxHeight ( ) const

Gets the maximum height constraint of the element.

Returns
The maximum height constraint.

◆ GetMaxWidth()

int GetMaxWidth ( ) const

Gets the maximum width constraint of the element.

Returns
The maximum width constraint.

◆ GetMinHeight()

int GetMinHeight ( ) const

Gets the minimum height constraint of the element.

Returns
The minimum height constraint.

◆ GetMinWidth()

int GetMinWidth ( ) const

Gets the minimum width constraint of the element.

Returns
The minimum width constraint.

◆ GetStyle()

AFX_INLINE CXTPMarkupStyle * GetStyle ( ) const

Gets the attached style of the element.

Returns
The attached style of the element.

◆ GetTag()

CXTPMarkupObject * GetTag ( ) const

Gets the tag object of the element.

Returns
The tag object.

◆ GetVerticalAlignment()

XTPMarkupVerticalAlignment GetVerticalAlignment ( ) const

Gets the vertical alignment characteristics applied to this element when it is composed within a parent element (e.g.

a panel or items control).

Returns
An XTPMarkupVerticalAlignment enumeration value.

◆ GetWidth()

int GetWidth ( ) const

Gets the width of the element.

Returns
The width of the element.

◆ SetClipToBounds()

void SetClipToBounds ( BOOL bClipToBounds )

Specifies if child elements should be clipped inside element bounds.

Parameters
bClipToBounds TRUE to clip child elements inside element bounds.

◆ SetHeight()

void SetHeight ( int nHeight )

Sets the height for the element.

Parameters
nHeight New height for the element.

◆ SetHorizontalAlignment()

void SetHorizontalAlignment ( XTPMarkupHorizontalAlignment alignment )

Sets the horizontal alignment characteristics applied to this element when it is composed within a parent element (e.g.

a panel or items control).

Parameters
alignment New XTPMarkupHorizontalAlignment enumeration value.

◆ SetMargin() [1/2]

void SetMargin | ( | int | nLeft,
 |  | int | nTop,
 |  | int | nRight,
 |  | int | nBottom )

Call this method to set the outer margin of an element.

Parameters
nLeft | Left margin.
nTop | Top margin.
nRight | Right margin.
nBottom | Bottom margin.

◆ SetMargin() [2/2]

void SetMargin ( int nMargin )

Call this method to set the outer margin of an element.

Parameters
nMargin Width, in pixels, for the margin.

◆ SetMaxHeight()

void SetMaxHeight ( int nHeight )

Sets the maximum height constraint for the element.

Parameters
nHeight New maximum height constraint.

◆ SetMaxWidth()

void SetMaxWidth ( int nWidth )

Sets the maximum width constraint for the element.

Parameters
nWidth New maximum width constraint.

◆ SetMinHeight()

void SetMinHeight ( int nHeight )

Sets the minimum height constraint for the element.

Parameters
nHeight New minimum height constraint.

◆ SetMinWidth()

void SetMinWidth ( int nWidth )

Sets the minimum width constraint for the element.

Parameters
nWidth New minimum width constraint.

◆ SetTag()

void SetTag ( CXTPMarkupObject * pTag )

Sets the tag object for the element.

Parameters
pTag New tag object to set.

◆ SetVerticalAlignment()

void SetVerticalAlignment ( XTPMarkupVerticalAlignment alignment )

Sets the vertical alignment characteristics applied to this element when it is composed within a parent element (e.g.

a panel or items control).

Parameters
alignment New XTPMarkupVerticalAlignment enumeration value.

◆ SetWidth()

void SetWidth ( int nWidth )

Sets the width for the element.

Parameters
nWidth New width for the element.
The documentation for this class was generated from the following file:
  • XTPMarkupFrameworkElement.h


Toolkit Pro: CXTPMarkupGdiImage Class Reference

Public Member Functions | List of all members
CXTPMarkupGdiImage Class Reference

Implements an abstract GDI device dependent image. More...

Inheritance diagram for CXTPMarkupGdiImage:
[legend]

Public Member Functions

CXTPMarkupGdiImage (IXTPMarkupDeviceDependentImageSite *pSite)
Constructs a device dependent image object.
virtual | ~CXTPMarkupGdiImage ()
Handles device dependent image object deallocation.
virtual BOOL | Load (LPCWSTR lpszSource, int nWidth, int nHeight=0)
Loads an image from a specified resource.
CXTPImageManagerIcon * GetNativeImage ()
Obtains the wrapped image pointer.
- Public Member Functions inherited from CXTPMarkupDeviceDependentImage
virtual | ~CXTPMarkupDeviceDependentImage ()
Handles device dependent image object deallocation.
const CSize & | GetSize () const
Obtains the image size, in pixels.
BOOL | IsLoaded () const
Checks if an image is loaded.
BOOL | IsIcon () const
Checks if the loaded image is an icon.
IXTPMarkupDeviceDependentImageSite * | GetSite () const
Obtains the site object pointer.

Additional Inherited Members

- Protected Member Functions inherited from CXTPMarkupDeviceDependentImage
CXTPMarkupDeviceDependentImage (IXTPMarkupDeviceDependentImageSite *pSite)
Constructs a device dependent image object.
- Protected Attributes inherited from CXTPMarkupDeviceDependentImage

Detailed Description

Implements an abstract GDI device dependent image.

Constructor & Destructor Documentation

◆ CXTPMarkupGdiImage()

CXTPMarkupGdiImage ( IXTPMarkupDeviceDependentImageSite * pSite )
explicit

Constructs a device dependent image object.

Parameters
pSite Valid pointer to an image site interface.

Member Function Documentation

◆ GetNativeImage()

AFX_INLINE CXTPImageManagerIcon * GetNativeImage ( )

Obtains the wrapped image pointer.

Returns
The wrapped image pointer.

◆ Load()

virtual BOOL Load | ( | LPCWSTR | lpszSource,
 |  | int | nWidth,
 |  | int | nHeight = 0 )
 virtual

Loads an image from a specified resource.

Parameters
lpszSource | Pointer to a string that indicates the image source. Can be a relative or full file path, file:// path, res:// path, or an integer in decimal representation that indicates the icon index.
nWidth | Width of the image to be loaded. Used only for icons. Can be 0 if not relevant.
nHeight | Width of the image to be loaded. Used only for XAML and SVG icons.
Returns
TRUE if the image is loaded successfully.

Implements CXTPMarkupDeviceDependentImage.

The documentation for this class was generated from the following file:
  • XTPMarkupGdiImage.h


Toolkit Pro: CXTPMarkupGdiPlusImage Class Reference

Public Member Functions | List of all members
CXTPMarkupGdiPlusImage Class Reference

Implements an abstract GDI+ device dependent image. More...

Inheritance diagram for CXTPMarkupGdiPlusImage:
[legend]

Public Member Functions

CXTPMarkupGdiPlusImage (CXTPGdiPlus *pReserved, IXTPMarkupDeviceDependentImageSite *pSite)
Constructs a device dependent image object.
virtual | ~CXTPMarkupGdiPlusImage ()
Handles device dependent image object deallocation.
virtual BOOL | Load (LPCWSTR lpszSource, int nWidth, int nHeight=0)
Loads an image from a specified resource.
Gdiplus::GpImage * | GetGpImage ()
Obtains the GDI+ wrapped image pointer.
CXTPImageManagerIcon * GetIcon ()
Obtains the icon wrapped image pointer.
- Public Member Functions inherited from CXTPMarkupDeviceDependentImage
virtual | ~CXTPMarkupDeviceDependentImage ()
Handles device dependent image object deallocation.
const CSize & | GetSize () const
Obtains the image size, in pixels.
BOOL | IsLoaded () const
Checks if an image is loaded.
BOOL | IsIcon () const
Checks if the loaded image is an icon.
IXTPMarkupDeviceDependentImageSite * | GetSite () const
Obtains the site object pointer.

Additional Inherited Members

- Protected Member Functions inherited from CXTPMarkupDeviceDependentImage
CXTPMarkupDeviceDependentImage (IXTPMarkupDeviceDependentImageSite *pSite)
Constructs a device dependent image object.
- Protected Attributes inherited from CXTPMarkupDeviceDependentImage

Detailed Description

Implements an abstract GDI+ device dependent image.

Constructor & Destructor Documentation

◆ CXTPMarkupGdiPlusImage()

CXTPMarkupGdiPlusImage | ( | CXTPGdiPlus * | pReserved,
 |  | IXTPMarkupDeviceDependentImageSite * | pSite )

Constructs a device dependent image object.

Parameters
pReserved | Reserved. Not used.
pSite | Valid pointer to an image site interface.

Member Function Documentation

◆ GetGpImage()

AFX_INLINE Gdiplus::GpImage * GetGpImage ( )

Obtains the GDI+ wrapped image pointer.

Returns
The GDI+ wrapped image pointer if successful, otherwise NULL.

◆ GetIcon()

AFX_INLINE CXTPImageManagerIcon * GetIcon ( )

Obtains the icon wrapped image pointer.

Returns
The icon wrapped image pointer if successful, otherwise NULL.

◆ Load()

virtual BOOL Load | ( | LPCWSTR | lpszSource,
 |  | int | nWidth,
 |  | int | nHeight = 0 )
 virtual

Loads an image from a specified resource.

Parameters
lpszSource | Pointer to a string that indicates the image source. Can be a relative or full file path, file:// path, res:// path, or an integer in decimal representation that indicates the icon index.
nWidth | Width of the image to be loaded. Used only for icons. Can be 0 if not relevant.
nHeight | Width of the image to be loaded. Used only for XAML and SVG icons.
Returns
TRUE if the image is loaded successfully.

Implements CXTPMarkupDeviceDependentImage.

The documentation for this class was generated from the following file:
  • XTPMarkupGdiPlusImage.h


Toolkit Pro: CXTPMarkupGdiPlusMatrixTransform Class Reference

Public Member Functions | List of all members
CXTPMarkupGdiPlusMatrixTransform Class Reference

GDI+ MatrixTransform implementation. More...

Inheritance diagram for CXTPMarkupGdiPlusMatrixTransform:
[legend]

Public Member Functions

CXTPMarkupGdiPlusMatrixTransform ()
Constructs a CXTPMarkupGdiPlusMatrixTransform object.
virtual BOOL TransformMatrix (const CXTPGdiPlus *pReserved, GpMatrix *pMatrix)
Performs GDI+ matrix scaling.
- Public Member Functions inherited from CXTPMarkupMatrixTransform
- Public Member Functions inherited from CXTPMarkupTransform

Additional Inherited Members

- Static Public Attributes inherited from CXTPMarkupMatrixTransform
- Protected Member Functions inherited from CXTPMarkupGdiPlusTransformObject< CXTPMarkupMatrixTransform >
CXTPMarkupGdiPlusTransformObject ()
Prevents a class from being instantiated.
- Protected Member Functions inherited from CXTPMarkupTransform
CXTPMarkupTransform ()
Prevents a class from being instantiated.
- Protected Member Functions inherited from CXTPMarkupGdiPlusTransformObjectImpl
CXTPMarkupGdiPlusTransformObjectImpl ()
Prevents a class from being instantiated.
CXTPMarkupTransformationMatrix * | ApplyTransform (const CXTPMarkupTransformationMatrix *pMatrix)
Applies abstract transformation on a markup transformation matrix.
virtual | ~CXTPMarkupGdiPlusTransformObjectImpl ()
Handles object destruction.
- Protected Attributes inherited from CXTPMarkupTransform

Detailed Description

GDI+ MatrixTransform implementation.

Member Function Documentation

◆ TransformMatrix()

virtual BOOL TransformMatrix | ( | const CXTPGdiPlus * | pReserved,
 |  | GpMatrix * | pMatrix )
 virtual

Performs GDI+ matrix scaling.

Parameters
pReserved | Reserved. Not used.
pMatrix | Native GDI+ matrix to transform instance pointer.
Returns
TRUE if successful.

Implements CXTPMarkupGdiPlusTransformObjectImpl.

The documentation for this class was generated from the following file:
  • XTPMarkupGdiPlusMatrixTransform.h


Toolkit Pro: CXTPMarkupGdiPlusRotateTransform Class Reference

Public Member Functions | List of all members
CXTPMarkupGdiPlusRotateTransform Class Reference

GDI+ RotateTransform implementation. More...

Inheritance diagram for CXTPMarkupGdiPlusRotateTransform:
[legend]

Public Member Functions

CXTPMarkupGdiPlusRotateTransform ()
Constructs a CXTPMarkupGdiPlusRotateTransform object.
virtual BOOL | TransformMatrix (const CXTPGdiPlus *pReserved, GpMatrix *pMatrix)
Performs GDI+ matrix rotation.
- Public Member Functions inherited from CXTPMarkupRotateTransform
double | GetAngle () const
Gets the angle value.
void | SetAngle (double angle)
Sets the angle value.
double | GetCenterX () const
Gets the center X value.
void | SetCenterX (double centerX)
Sets the center X value.
double | GetCenterY () const
Gets the center Y value.
void | SetCenterY (double centerY)
Sets the center Y value.
- Public Member Functions inherited from CXTPMarkupTransform

Additional Inherited Members

- Static Public Attributes inherited from CXTPMarkupRotateTransform
static CXTPMarkupDependencyProperty * | m_pPropertyAngle
Angle property.
static CXTPMarkupDependencyProperty * | m_pPropertyCenterX
CenterX property.
static CXTPMarkupDependencyProperty * | m_pPropertyCenterY
CenterY property.
- Protected Member Functions inherited from CXTPMarkupGdiPlusTransformObject< CXTPMarkupRotateTransform >
CXTPMarkupGdiPlusTransformObject ()
Prevents a class from being instantiated.
- Protected Member Functions inherited from CXTPMarkupTransform
CXTPMarkupTransform ()
Prevents a class from being instantiated.
- Protected Member Functions inherited from CXTPMarkupGdiPlusTransformObjectImpl
CXTPMarkupGdiPlusTransformObjectImpl ()
Prevents a class from being instantiated.
CXTPMarkupTransformationMatrix * | ApplyTransform (const CXTPMarkupTransformationMatrix *pMatrix)
Applies abstract transformation on a markup transformation matrix.
virtual | ~CXTPMarkupGdiPlusTransformObjectImpl ()
Handles object destruction.
- Protected Attributes inherited from CXTPMarkupTransform

Detailed Description

GDI+ RotateTransform implementation.

Member Function Documentation

◆ TransformMatrix()

virtual BOOL TransformMatrix | ( | const CXTPGdiPlus * | pReserved,
 |  | GpMatrix * | pMatrix )
 virtual

Performs GDI+ matrix rotation.

Parameters
pReserved | Reserved. Not used.
pMatrix | Native GDI+ matrix to transform instance pointer.
Returns
TRUE if successful.

Implements CXTPMarkupGdiPlusTransformObjectImpl.

The documentation for this class was generated from the following file:
  • XTPMarkupGdiPlusRotateTransform.h


Toolkit Pro: CXTPMarkupGdiPlusScaleTransform Class Reference

Public Member Functions | List of all members
CXTPMarkupGdiPlusScaleTransform Class Reference

GDI+ ScaleTransform implementation. More...

Inheritance diagram for CXTPMarkupGdiPlusScaleTransform:
[legend]

Public Member Functions

CXTPMarkupGdiPlusScaleTransform ()
Constructs a CXTPMarkupGdiPlusScaleTransform object.
virtual BOOL | TransformMatrix (const CXTPGdiPlus *pReserved, GpMatrix *pMatrix)
Performs GDI+ matrix scaling.
- Public Member Functions inherited from CXTPMarkupScaleTransform
double | GetScaleX () const
Gets the scale X value.
void | SetScaleX (double scaleX)
Sets the scale X value.
double | GetScaleY () const
Gets the scale Y value.
void | SetScaleY (double scaleY)
Sets the scale Y value.
double | GetCenterX () const
Gets the center X value.
void | SetCenterX (double centerX)
Sets the center X value.
double | GetCenterY () const
Gets the center Y value.
void | SetCenterY (double centerY)
Sets the center Y value.
- Public Member Functions inherited from CXTPMarkupTransform

Additional Inherited Members

- Static Public Attributes inherited from CXTPMarkupScaleTransform
static CXTPMarkupDependencyProperty * | m_pPropertyScaleX
ScaleX property.
static CXTPMarkupDependencyProperty * | m_pPropertyScaleY
ScaleY property.
static CXTPMarkupDependencyProperty * | m_pPropertyCenterX
CenterX property.
static CXTPMarkupDependencyProperty * | m_pPropertyCenterY
CenterY property.
- Protected Member Functions inherited from CXTPMarkupGdiPlusTransformObject< CXTPMarkupScaleTransform >
CXTPMarkupGdiPlusTransformObject ()
Prevents a class from being instantiated.
- Protected Member Functions inherited from CXTPMarkupTransform
CXTPMarkupTransform ()
Prevents a class from being instantiated.
- Protected Member Functions inherited from CXTPMarkupGdiPlusTransformObjectImpl
CXTPMarkupGdiPlusTransformObjectImpl ()
Prevents a class from being instantiated.
CXTPMarkupTransformationMatrix * | ApplyTransform (const CXTPMarkupTransformationMatrix *pMatrix)
Applies abstract transformation on a markup transformation matrix.
virtual | ~CXTPMarkupGdiPlusTransformObjectImpl ()
Handles object destruction.
- Protected Attributes inherited from CXTPMarkupTransform

Detailed Description

GDI+ ScaleTransform implementation.

Member Function Documentation

◆ TransformMatrix()

virtual BOOL TransformMatrix | ( | const CXTPGdiPlus * | pReserved,
 |  | GpMatrix * | pMatrix )
 virtual

Performs GDI+ matrix scaling.

Parameters
pReserved | Reserved. Not used.
pMatrix | Native GDI+ matrix to transform instance pointer.
Returns
TRUE if successful.

Implements CXTPMarkupGdiPlusTransformObjectImpl.

The documentation for this class was generated from the following file:
  • XTPMarkupGdiPlusScaleTransform.h


Toolkit Pro: CXTPMarkupGdiPlusSkewTransform Class Reference

List of all members
CXTPMarkupGdiPlusSkewTransform Class Reference

GDI+ SkewTransform implementation. More...

Inheritance diagram for CXTPMarkupGdiPlusSkewTransform:
[legend]

Additional Inherited Members

- Public Member Functions inherited from CXTPMarkupSkewTransform
double | GetAngleX () const
Gets the angle X value.
void | SetAngleX (double angleX)
Sets the angle X value.
double | GetAngleY () const
Gets the angle Y value.
void | SetAngleY (double angleY)
Sets the angle Y value.
double | GetCenterX () const
Gets the center X value.
void | SetCenterX (double centerX)
Sets the center X value.
double | GetCenterY () const
Gets the center Y value.
void | SetCenterY (double centerY)
Sets the center Y value.
- Public Member Functions inherited from CXTPMarkupTransform
- Static Public Attributes inherited from CXTPMarkupSkewTransform
static CXTPMarkupDependencyProperty * | m_pPropertyAngleX
AngleX property.
static CXTPMarkupDependencyProperty * | m_pPropertyAngleY
AngleY property.
static CXTPMarkupDependencyProperty * | m_pPropertyCenterX
CenterX property.
static CXTPMarkupDependencyProperty * | m_pPropertyCenterY
CenterY property.
- Protected Member Functions inherited from CXTPMarkupGdiPlusTransformObject< CXTPMarkupSkewTransform >
CXTPMarkupGdiPlusTransformObject ()
Prevents a class from being instantiated.
- Protected Member Functions inherited from CXTPMarkupTransform
CXTPMarkupTransform ()
Prevents a class from being instantiated.
- Protected Member Functions inherited from CXTPMarkupGdiPlusTransformObjectImpl
CXTPMarkupGdiPlusTransformObjectImpl ()
Prevents a class from being instantiated.
CXTPMarkupTransformationMatrix * | ApplyTransform (const CXTPMarkupTransformationMatrix *pMatrix)
Applies abstract transformation on a markup transformation matrix.
virtual | ~CXTPMarkupGdiPlusTransformObjectImpl ()
Handles object destruction.
- Protected Attributes inherited from CXTPMarkupTransform

Detailed Description

GDI+ SkewTransform implementation.

The documentation for this class was generated from the following file:
  • XTPMarkupGdiPlusSkewTransform.h


Toolkit Pro: CXTPMarkupGdiPlusTransformationMatrix Class Reference

Public Member Functions | List of all members
CXTPMarkupGdiPlusTransformationMatrix Class Reference

Encapsulates GDI+ transformation matrix access. More...

Inheritance diagram for CXTPMarkupGdiPlusTransformationMatrix:
[legend]

Public Member Functions

CXTPMarkupGdiPlusTransformationMatrix (CXTPGdiPlus *pReserved, GpMatrix *pMatrix)
Constructs a GDI+ markup matrix.
~CXTPMarkupGdiPlusTransformationMatrix ()
Cleans up resources held.
GpMatrix * | GetMatrix ()
Provides access to the native GDI+ matrix instance.
const GpMatrix * | GetMatrix () const
Provides access to the native GDI+ matrix instance.
virtual CXTPMarkupTransformationMatrix * | Clone () const
Clones a matrix object.
virtual void | Offset (const POINT &offset)
Adds offset to the current matrix.
virtual BOOL | PtInRect (const RECT &rect, const POINT &absoluteOffset, const POINT &point) const
Checks if a point is inside a rectangle with transformation applied.
virtual CRect | GetBoundRect (const RECT &rect, const POINT &absoluteOffset) const
Computes the bounding rectangle after transformation.
- Public Member Functions inherited from CXTPMarkupTransformationMatrix
virtual | ~CXTPMarkupTransformationMatrix ()
Destroys a CXTPMarkupTransformationMatrix object, handles cleanup and deallocation.

Additional Inherited Members

- Protected Member Functions inherited from CXTPMarkupTransformationMatrix
CXTPMarkupTransformationMatrix ()
Constructs a CXTPMarkupTransformationMatrix object.

Detailed Description

Encapsulates GDI+ transformation matrix access.

Constructor & Destructor Documentation

◆ CXTPMarkupGdiPlusTransformationMatrix()

CXTPMarkupGdiPlusTransformationMatrix | ( | CXTPGdiPlus * | pReserved,
 |  | GpMatrix * | pMatrix )

Constructs a GDI+ markup matrix.

Parameters
pReserved | Reserved. Not used.
pMatrix | A pointer to a native GDI+ matrix. The wrapper takes exclusive ownership of the native GDI+ matrix passed.

Member Function Documentation

◆ Clone()

virtual CXTPMarkupTransformationMatrix * Clone ( ) const
virtual

Clones a matrix object.

Returns
A pointer to the cloned matrix. It is the responsibility of the caller to delete the returned object.

Implements CXTPMarkupTransformationMatrix.

◆ GetBoundRect()

virtual CRect GetBoundRect | ( | const RECT & | rect,
 |  | const POINT & | absoluteOffset ) const
 virtual

Computes the bounding rectangle after transformation.

Parameters
rect | Rectangle in relative coordinates to transform.
absoluteOffset | Absolute offset of the rectangle.
Returns
A CRect object containing the bounding rectangle after transformation.

Reimplemented from CXTPMarkupTransformationMatrix.

◆ GetMatrix() [1/2]

AFX_INLINE GpMatrix * GetMatrix ( )

Provides access to the native GDI+ matrix instance.

Returns
A pointer to the native GDI+ matrix instance.

◆ GetMatrix() [2/2]

AFX_INLINE const GpMatrix * GetMatrix ( ) const

Provides access to the native GDI+ matrix instance.

Returns
A pointer to the native GDI+ matrix instance.

◆ Offset()

virtual void Offset ( const POINT & offset )
virtual

Adds offset to the current matrix.

Parameters
offset Offset to add.

Reimplemented from CXTPMarkupTransformationMatrix.

◆ PtInRect()

virtual BOOL PtInRect | ( | const RECT & | rect,
 |  | const POINT & | absoluteOffset,
 |  | const POINT & | point ) const
 virtual

Checks if a point is inside a rectangle with transformation applied.

Parameters
rect | Rectangle in relative coordinates to test in.
absoluteOffset | Absolute offset of the rectangle.
point | Absolute point to test.
Returns
TRUE if the point hits the specified rectangle.

Reimplemented from CXTPMarkupTransformationMatrix.

The documentation for this class was generated from the following file:
  • XTPMarkupGdiPlusTransformationMatrix.h


Toolkit Pro: CXTPMarkupGdiPlusTransformObject< BaseTransform > Class Template Reference

Protected Member Functions | List of all members
CXTPMarkupGdiPlusTransformObject< BaseTransform > Class Template Reference

Base class for all GDI+ markup transformation objects. More...

Inheritance diagram for CXTPMarkupGdiPlusTransformObject< BaseTransform >:
[legend]

Protected Member Functions

CXTPMarkupGdiPlusTransformObject ()
Prevents a class from being instantiated.
- Protected Member Functions inherited from CXTPMarkupGdiPlusTransformObjectImpl
CXTPMarkupGdiPlusTransformObjectImpl ()
Prevents a class from being instantiated.
virtual BOOL | TransformMatrix (const CXTPGdiPlus *pReserved, GpMatrix *pMatrix)=0
An abstract method that performs a native GDI+ matrix transformation.
CXTPMarkupTransformationMatrix * | ApplyTransform (const CXTPMarkupTransformationMatrix *pMatrix)
Applies abstract transformation on a markup transformation matrix.
virtual | ~CXTPMarkupGdiPlusTransformObjectImpl ()
Handles object destruction.

Detailed Description

template<class BaseTransform>
class CXTPMarkupGdiPlusTransformObject< BaseTransform >

Base class for all GDI+ markup transformation objects.

Parameters
BaseTransform A target transformation class.
The documentation for this class was generated from the following file:
  • XTPMarkupGdiPlusTransformObject.h


Toolkit Pro: CXTPMarkupGdiPlusTransformObjectImpl Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPMarkupGdiPlusTransformObjectImpl Class Referenceabstract

Implements GDI+ markup matrix access and delegates the actual transformation to a derived class. More...

Inheritance diagram for CXTPMarkupGdiPlusTransformObjectImpl:
[legend]

Public Member Functions

virtual ~CXTPMarkupGdiPlusTransformObjectImpl ()
Handles object destruction.

Protected Member Functions

CXTPMarkupGdiPlusTransformObjectImpl ()
Prevents a class from being instantiated.
virtual BOOL | TransformMatrix (const CXTPGdiPlus *pReserved, GpMatrix *pMatrix)=0
An abstract method that performs a native GDI+ matrix transformation.
CXTPMarkupTransformationMatrix * | ApplyTransform (const CXTPMarkupTransformationMatrix *pMatrix)
Applies abstract transformation on a markup transformation matrix.

Detailed Description

Implements GDI+ markup matrix access and delegates the actual transformation to a derived class.

Member Function Documentation

◆ ApplyTransform()

CXTPMarkupTransformationMatrix * ApplyTransform ( const CXTPMarkupTransformationMatrix * pMatrix )
protected

Applies abstract transformation on a markup transformation matrix.

Parameters
pMatrix Pointer to a markup transformation matrix to be transformed.
Returns
A pointer to the transformed markup matrix if successful, NULL if failed or not supported. It is the responsibility of the callee to delete the returned object.

◆ TransformMatrix()

virtual BOOL TransformMatrix | ( | const CXTPGdiPlus * | pReserved,
 |  | GpMatrix * | pMatrix )
 protectedpure virtual

An abstract method that performs a native GDI+ matrix transformation.

Parameters
pReserved | Reserved. Not used.
pMatrix | Native GDI+ matrix to transform instance pointer.
Returns
TRUE if successful.

Implemented in CXTPMarkupGdiPlusMatrixTransform, CXTPMarkupGdiPlusRotateTransform, and CXTPMarkupGdiPlusScaleTransform.

The documentation for this class was generated from the following file:
  • XTPMarkupGdiPlusTransformObject.h


Toolkit Pro: CXTPMarkupGdiPlusTranslateTransform Class Reference

List of all members
CXTPMarkupGdiPlusTranslateTransform Class Reference

GDI+ TranslateTransform implementation. More...

Inheritance diagram for CXTPMarkupGdiPlusTranslateTransform:
[legend]

Additional Inherited Members

- Public Member Functions inherited from CXTPMarkupTranslateTransform
double | GetX () const
Gets the X value.
void | SetX (double x)
Sets the X value.
double | GetY () const
Gets the Y value.
void | SetY (double y)
Sets the Y value.
- Public Member Functions inherited from CXTPMarkupTransform
- Static Public Attributes inherited from CXTPMarkupTranslateTransform
static CXTPMarkupDependencyProperty * | m_pPropertyX
X property.
static CXTPMarkupDependencyProperty * | m_pPropertyY
Y property.
- Protected Member Functions inherited from CXTPMarkupGdiPlusTransformObject< CXTPMarkupTranslateTransform >
CXTPMarkupGdiPlusTransformObject ()
Prevents a class from being instantiated.
- Protected Member Functions inherited from CXTPMarkupTransform
CXTPMarkupTransform ()
Prevents a class from being instantiated.
- Protected Member Functions inherited from CXTPMarkupGdiPlusTransformObjectImpl
CXTPMarkupGdiPlusTransformObjectImpl ()
Prevents a class from being instantiated.
CXTPMarkupTransformationMatrix * | ApplyTransform (const CXTPMarkupTransformationMatrix *pMatrix)
Applies abstract transformation on a markup transformation matrix.
virtual | ~CXTPMarkupGdiPlusTransformObjectImpl ()
Handles object destruction.
- Protected Attributes inherited from CXTPMarkupTransform

Detailed Description

GDI+ TranslateTransform implementation.

The documentation for this class was generated from the following file:
  • XTPMarkupGdiPlusTranslateTransform.h


Toolkit Pro: CXTPMarkupGrid Class Reference

Public Member Functions | Static Public Member Functions | Protected Member Functions | List of all members
CXTPMarkupGrid Class Reference

CXTPMarkupGrid is a CXTPMarkupPanel derived class. More...

Inheritance diagram for CXTPMarkupGrid:
[legend]

Public Member Functions

CXTPMarkupColumnDefinitionCollection * | GetColumnDefinitions () const
Retrieves the collection of constraints and definitions for grid columns.
CXTPMarkupRowDefinitionCollection * | GetRowDefinitions () const
Retrieves the collection of constraints and definitions for grid rows.
- Public Member Functions inherited from CXTPMarkupPanel
CXTPMarkupUIElementCollection * | GetChildren () const
Retrieves the collection of child elements.
void | SetBackground (CXTPMarkupBrush *pBrush)
Sets the background brush for the panel object.
CXTPMarkupBrush * | GetBackground () const
Gets the background brush of the panel object.
- Public Member Functions inherited from CXTPMarkupFrameworkElement
void | SetMargin (int nLeft, int nTop, int nRight, int nBottom)
Call this method to set the outer margin of an element.
void | SetMargin (int nMargin)
Call this method to set the outer margin of an element.
CXTPMarkupThickness * | GetMargin () const
Call this method to get the outer margin of an element.
void | SetMinWidth (int nWidth)
Sets the minimum width constraint for the element.
void | SetMaxWidth (int nWidth)
Sets the maximum width constraint for the element.
void | SetWidth (int nWidth)
Sets the width for the element.
void | SetMinHeight (int nHeight)
Sets the minimum height constraint for the element.
void | SetMaxHeight (int nHeight)
Sets the maximum height constraint for the element.
void | SetHeight (int nHeight)
Sets the height for the element.
int | GetMinWidth () const
Gets the minimum width constraint of the element.
int | GetMaxWidth () const
Gets the maximum width constraint of the element.
int | GetWidth () const
Gets the width of the element.
int | GetMinHeight () const
Gets the minimum height constraint of the element.
int | GetMaxHeight () const
Gets the maximum height constraint of the element.
int | GetHeight () const
Gets the height of the element.
CXTPMarkupObject * | GetTag () const
Gets the tag object of the element.
void | SetTag (CXTPMarkupObject *pTag)
Sets the tag object for the element.
void | SetHorizontalAlignment (XTPMarkupHorizontalAlignment alignment)
Sets the horizontal alignment characteristics applied to this element when it is composed within a parent element (e.g.
void | SetVerticalAlignment (XTPMarkupVerticalAlignment alignment)
Sets the vertical alignment characteristics applied to this element when it is composed within a parent element (e.g.
XTPMarkupHorizontalAlignment | GetHorizontalAlignment () const
Gets the horizontal alignment characteristics applied to this element when it is composed within a parent element (e.g.
XTPMarkupVerticalAlignment | GetVerticalAlignment () const
Gets the vertical alignment characteristics applied to this element when it is composed within a parent element (e.g.
CSize | GetActualSize () const
Retrieves the actual size of the element after it is measured and arranged within a parent element (e.g.
void | SetClipToBounds (BOOL bClipToBounds)
Specifies if child elements should be clipped inside element bounds.
BOOL | GetClipToBounds () const
Determines if child elements are clipped inside element bounds.
CXTPMarkupStyle * | GetStyle () const
Gets the attached style of the element.
- Public Member Functions inherited from CXTPMarkupUIElement
void | Arrange (CRect rcFinalRect)
Positions child elements and determines a size for a CXTPMarkupUIElement.
void | Measure (CXTPMarkupDrawingContext *pDC, CSize szAvailableSize)
Updates the DesiredSize of a CXTPMarkupUIElement.
CSize | GetDesiredSize () const
Gets the size that this element computed during the measure pass of the layout process.
CRect | GetFinalRect () const
Gets the final render size of this element.
XTPMarkupVisibility | GetVisibility () const
Gets the user interface (UI) visibility of this element.
void | SetVisibility (XTPMarkupVisibility visibility)
Sets the user interface (UI) visibility of this element.
BOOL | IsFocusable () const
Gets or sets a value indicating whether this element can receive focus.
virtual BOOL | IsVisible () const
Gets a value indicating whether this element is visible in the user interface (UI).
BOOL | IsEnabled () const
Gets or sets a value indicating whether this element is enabled in the user interface (UI).
virtual void | InvalidateArrange ()
Invalidates the arrange state (layout) for the element.
virtual void | InvalidateVisual ()
Invalidates the rendering of the element, and forces a new complete layout pass.
virtual void | InvalidateMeasure ()
Invalidates the measurement state (layout) for the element.
- Public Member Functions inherited from CXTPMarkupVisual
CXTPMarkupVisual ()
Provides the base initialization for objects derived from the CXTPMarkupVisual class.
virtual | ~CXTPMarkupVisual ()
Destroys a CXTPMarkupVisual object, handles cleanup and deallocation.
void | Render (CXTPMarkupDrawingContext *drawingContext)
Call this method to draw a Visual object inside a drawing context.
CXTPMarkupInputElement * | InputHitTest (CPoint point) const
Determines if a point belongs to this object.
virtual int | GetVisualChildrenCount () const
Gets the number of child elements for the Visual.
virtual CXTPMarkupVisual * | GetVisualChild (int nIndex) const
Retrieves the child Visual object located at a specified index within the parent VisualCollection.
virtual int | GetLogicalChildrenCount () const
Retrieves the number of logical child elements of this object.
virtual CXTPMarkupObject * | GetLogicalChild (int nIndex) const
Retrieves the logical child element located at a specified index within the parent collection.
CRect | GetBoundRect () const
Retrieves the bounding rectangle of the element.
CRect | GetUpdateRect () const
Computes the update rectangle.
CSize | GetRenderSize () const
Gets the final render size of this element.
CPoint | GetVisualOffset () const
Gets or sets the offset value of the visual object.
CXTPMarkupVisual * | GetVisualParent () const
Gets the Visual tree parent of the Visual object.

Static Public Member Functions

static void AFX_CDECL | SetColumn (CXTPMarkupUIElement *pElement, int nColumn)
Sets a column index for a grid child element.
static int AFX_CDECL | GetColumn (CXTPMarkupUIElement *pElement)
Retrieves the column index of a grid child element.
static void AFX_CDECL | SetRow (CXTPMarkupUIElement *pElement, int nRow)
Sets the row index for a grid child element.
static int AFX_CDECL | GetRow (CXTPMarkupUIElement *pElement)
Retrieves the row index of a grid child element.
static void AFX_CDECL | SetColumnSpan (CXTPMarkupUIElement *pElement, int nColumnSpan)
Sets the total number of columns that child content spans within a grid.
static int AFX_CDECL | GetColumnSpan (CXTPMarkupUIElement *pElement)
Gets the total number of columns that child content spans within a grid.
static void AFX_CDECL | SetRowSpan (CXTPMarkupUIElement *pElement, int nRowSpan)
Sets the total number of rows that child content spans within a grid.
static int AFX_CDECL | GetRowSpan (CXTPMarkupUIElement *pElement)
Gets the total number of rows that child content spans within a grid.

Protected Member Functions

CXTPMarkupGrid ()
Constructs a CXTPMarkupGrid object.
virtual | ~CXTPMarkupGrid ()
Destroys a CXTPMarkupGrid object, handles cleanup and deallocation.
- Protected Member Functions inherited from CXTPMarkupPanel
CXTPMarkupPanel ()
Constructs a CXTPMarkupPanel object.
virtual | ~CXTPMarkupPanel ()
Destroys a CXTPMarkupPanel object, handles cleanup and deallocation.
- Protected Member Functions inherited from CXTPMarkupFrameworkElement
CXTPMarkupFrameworkElement ()
Initializes a new instance of the CXTPMarkupFrameworkElement class.
virtual | ~CXTPMarkupFrameworkElement ()
Destroys a CXTPMarkupFrameworkElement object, handles cleanup and deallocation.
- Protected Member Functions inherited from CXTPMarkupUIElement
CXTPMarkupUIElement ()
Initializes a new instance of the CXTPMarkupUIElement class.
virtual | ~CXTPMarkupUIElement ()
Destroys a CXTPMarkupUIElement object, handles cleanup and deallocation.
CXTPMarkupRenderTransform * | GetRenderTransform () const
Obtains a pointer to the RenderTransform object.
virtual void | ArrangeCore (CRect rcFinalRect)
Defines the template for the core-level arrange layout definition.
virtual CSize | MeasureCore (CXTPMarkupDrawingContext *pDC, CSize szAvailableSize)
When overridden in a derived class, provides measurement logic for sizing this element properly with consideration of the size of any child element content.
virtual BOOL | GetLayoutClip (CRect &rc) const
Retrieves an alternative clipping geometry that represents the region that would be clipped if child elements were clipped inside element bounds.
virtual void | InvalidateMeasureOverride (CXTPMarkupDrawingContext *pDC)
Override this method to provide a custom reaction to an InvalidateMeasure call.
virtual TransformationMatrices | ApplyRenderTransform (CXTPMarkupDrawingContext *pContext)
Applies render transformation if necessary.
virtual void | RestoreRenderTransform (CXTPMarkupDrawingContext *pContext, TransformationMatrices &matrices)
Restores a previously applied render transformation.
virtual double | GetOpacity () const
Gets either the default or explicitly set opacity factor value.
- Protected Member Functions inherited from CXTPMarkupVisual
BOOL | PtInRectTransform (const RECT &rect, const POINT &point) const
Checks if a point is inside a rectangle with transformation applied.
POINT | GetAbsoluteVisualOffset () const
Gets the absolute element visual offset.
virtual void | OnRender (CXTPMarkupDrawingContext *drawingContext)
When overridden in a derived class, participates in rendering operations that are directed by the layout system.
virtual void | OnRenderFocusVisual (CXTPMarkupDrawingContext *drawingContext)
This method is called to render the focus rectangle of a focused object.
virtual CXTPMarkupInputElement * | InputHitTestOverride (CPoint point) const
Override this method in the derived class to provide visual hit testing of a child object.
virtual void | RenderClipped (CXTPMarkupDrawingContext *drawingContext)
Called by the framework when an element is clipped and no rendering will occur.

Additional Inherited Members

- Static Public Attributes inherited from CXTPMarkupUIElement
static CXTPMarkupDependencyProperty * | m_pClipToBoundsProperty
Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element.
static CXTPMarkupDependencyProperty * | m_pVisibilityProperty
A value indicating whether this element is visible in the user interface (UI).
static CXTPMarkupDependencyProperty * | m_pFocusableProperty
A value that indicates whether the element can receive focus.
static CXTPMarkupDependencyProperty * | m_pIsEnabledProperty
A value indicating whether thiselement is enabled in the user interface (UI).
static CXTPMarkupDependencyProperty * | m_pRenderTransformProperty
Gets or sets transform information that affects the rendering position of this element.
static CXTPMarkupDependencyProperty * | m_pRenderTransformOriginProperty
Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element.
static CXTPMarkupDependencyProperty * | m_pOpacityProperty
Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI).
- Protected Attributes inherited from CXTPMarkupUIElement
CSize | m_szDesiredSize
Gets the size that this element computed during the measure pass of the layout process.
CRect | m_rcFinalRect
Final position of the visual element.
BOOL | m_bMeasureDirty
TRUE if object hasn't recalculated its size.
BOOL | m_bNeverMeasured
TRUE if object has never ran Measure to update its size.
CSize | m_szPreviousAvailableSize
Previous available size of measure call.
BOOL | m_bArrangeDirty
TRUE if object position can be invalid.
BOOL | m_bNeverArranged
TRUE if Arrange was never called for this object.
BOOL | m_bArrangeInProgress
TRUE if Arrange is currently executed.
BOOL | m_bMeasureInProgress
TRUE if Measure is currently executed.
- Protected Attributes inherited from CXTPMarkupVisual
CPoint | m_ptVisualOffset
The offset value of the visual object.
CSize | m_szRenderSize
The rendered size for this element.
CRect | m_rcBoundRect
Bounding rectangle of the element.
CRect | m_rcUpdateRect
Update rectangle.
CRect | m_rcPrevUpdateRect
Previous update rectangle.

Detailed Description

CXTPMarkupGrid is a CXTPMarkupPanel derived class.

It implements the Grid XAML Tag.

Member Function Documentation

◆ GetColumn()

static int AFX_CDECL GetColumn ( CXTPMarkupUIElement * pElement )
static

Retrieves the column index of a grid child element.

Parameters
pElement Grid child element whose column index must be retrieved.
Returns
The column index of the grid child element.

◆ GetColumnDefinitions()

AFX_INLINE CXTPMarkupColumnDefinitionCollection * GetColumnDefinitions ( ) const

Retrieves the collection of constraints and definitions for grid columns.

Returns
A pointer to the collection of CXTPMarkupColumnDefinition classes.

◆ GetColumnSpan()

static int AFX_CDECL GetColumnSpan ( CXTPMarkupUIElement * pElement )
static

Gets the total number of columns that child content spans within a grid.

Parameters
pElement Pointer to a child element of the grid to check.
Returns
The total number of columns that child content spans within the grid.

◆ GetRow()

static int AFX_CDECL GetRow ( CXTPMarkupUIElement * pElement )
static

Retrieves the row index of a grid child element.

Parameters
pElement Grid child element whose row index must be retrieved.
Returns
The row index of the grid child element.

◆ GetRowDefinitions()

AFX_INLINE CXTPMarkupRowDefinitionCollection * GetRowDefinitions ( ) const

Retrieves the collection of constraints and definitions for grid rows.

Returns
A pointer to the collection of CXTPMarkupRowDefinition classes.

◆ GetRowSpan()

static int AFX_CDECL GetRowSpan ( CXTPMarkupUIElement * pElement )
static

Gets the total number of rows that child content spans within a grid.

Parameters
pElement Pointer to a child element of the grid to check.
Returns
The total number of rows that child content spans within the grid.

◆ SetColumn()

static void AFX_CDECL SetColumn | ( | CXTPMarkupUIElement * | pElement,
 |  | int | nColumn )
 static

Sets a column index for a grid child element.

Parameters
pElement | Grid child element.
nColumn | Column index to set for pElement.
Returns

◆ SetColumnSpan()

static void AFX_CDECL SetColumnSpan | ( | CXTPMarkupUIElement * | pElement,
 |  | int | nColumnSpan )
 static

Sets the total number of columns that child content spans within a grid.

Parameters
pElement | Pointer to a child element of the grid.
nColumnSpan | Number of columns that the child content should span.
Returns

◆ SetRow()

static void AFX_CDECL SetRow | ( | CXTPMarkupUIElement * | pElement,
 |  | int | nRow )
 static

Sets the row index for a grid child element.

Parameters
pElement | Grid child element.
nRow | Row index to set for pElement.
Returns

◆ SetRowSpan()

static void AFX_CDECL SetRowSpan | ( | CXTPMarkupUIElement * | pElement,
 |  | int | nRowSpan )
 static

Sets the total number of rows that child content spans within a grid.

Parameters
pElement | Pointer to a child element of the grid.
nRowSpan | Number of rows that the child content should span.
Returns
The documentation for this class was generated from the following file:
  • XTPMarkupGrid.h


Toolkit Pro: CXTPMarkupGridLength Class Reference

Public Types | Public Member Functions | Public Attributes | List of all members
CXTPMarkupGridLength Class Reference

CXTPMarkupGridLength is a class defined length of grid rows and columns. More...

Public Types

enum GridUnitType { unitTypeAuto , unitTypePixel , unitTypeStar }
Unit type of the length. More...

Public Member Functions

CXTPMarkupGridLength (double nValue=0, GridUnitType type=unitTypePixel)
Constructs a CXTPMarkupGridLength object.
GridUnitType | GetUnitType () const
Gets the unit type of the length.
double | GetValue () const
Gets the value of the length.
BOOL | IsStar () const
Determines if the length is calculated in percents (unitTypeStar).
BOOL | IsAuto () const
Determines if the length is calculated automatically (unitTypeAuto).
CXTPMarkupObject * | ConvertFrom (CXTPMarkupBuilder *pBuilder, CXTPMarkupObject *pObject) const
Helper method used to convert string to length.

Public Attributes

double | m_nValue
Value.
GridUnitType | m_type
Unit type.

Detailed Description

CXTPMarkupGridLength is a class defined length of grid rows and columns.

Member Enumeration Documentation

◆ GridUnitType

enum GridUnitType

Unit type of the length.

Enumerator
unitTypeAuto | Automatically calculated length.
unitTypePixel | Length in pixels.
unitTypeStar | Length in percents.

Constructor & Destructor Documentation

◆ CXTPMarkupGridLength()

CXTPMarkupGridLength | ( | double | nValue = 0,
 |  | GridUnitType | type = unitTypePixel )

Constructs a CXTPMarkupGridLength object.

Parameters
nValue | Length of the grid elements.
type | Unit type of the length; must be one of the values defined by the GridUnitType enumeration.

Member Function Documentation

◆ ConvertFrom()

CXTPMarkupObject * ConvertFrom | ( | CXTPMarkupBuilder * | pBuilder,
 |  | CXTPMarkupObject * | pObject ) const

Helper method used to convert string to length.

Parameters
pBuilder | Pointer to a builder object.
pObject | String representation of the length.
Returns
A pointer to a new CXTPMarkupGridLength object.

◆ GetUnitType()

AFX_INLINE CXTPMarkupGridLength::GridUnitType GetUnitType ( ) const

Gets the unit type of the length.

Returns
The unit type of the length; returns one of the values defined by the GridUnitType enumeration. unitTypePixel will be returned if the length is calculated in pixels, unitTypeStar will be returned if the length is calculated in percents.

◆ GetValue()

AFX_INLINE double GetValue ( ) const

Gets the value of the length.

Returns
The value of the length, in pixels or percents.

◆ IsAuto()

BOOL IsAuto ( ) const
inline

Determines if the length is calculated automatically (unitTypeAuto).

Returns
TRUE if the unit type of the length is unitTypeAuto.

◆ IsStar()

BOOL IsStar ( ) const
inline

Determines if the length is calculated in percents (unitTypeStar).

Returns
TRUE if the unit type of the length is unitTypeStar.
The documentation for this class was generated from the following file:
  • XTPMarkupGridLength.h


Toolkit Pro: CXTPMarkupImage Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPMarkupImage Class Reference

CXTPMarkupImage is a CXTPMarkupFrameworkElement derived class. More...

Inheritance diagram for CXTPMarkupImage:
[legend]

Public Member Functions

void | SetSource (LPCTSTR lpszSource)
Sets the source of the image to load.
CString | GetSource ()
Retrieves the source of the image to load.
void | SetStretch (XTPMarkupStretch stretch)
Sets the stretch type of the image.
XTPMarkupStretch | GetStretch () const
Gets the current stretch type of the image.
CSize | GetOriginalSize () const
Retrieves the original size of the image (not scaled).
- Public Member Functions inherited from CXTPMarkupFrameworkElement
void | SetMargin (int nLeft, int nTop, int nRight, int nBottom)
Call this method to set the outer margin of an element.
void | SetMargin (int nMargin)
Call this method to set the outer margin of an element.
CXTPMarkupThickness * | GetMargin () const
Call this method to get the outer margin of an element.
void | SetMinWidth (int nWidth)
Sets the minimum width constraint for the element.
void | SetMaxWidth (int nWidth)
Sets the maximum width constraint for the element.
void | SetWidth (int nWidth)
Sets the width for the element.
void | SetMinHeight (int nHeight)
Sets the minimum height constraint for the element.
void | SetMaxHeight (int nHeight)
Sets the maximum height constraint for the element.
void | SetHeight (int nHeight)
Sets the height for the element.
int | GetMinWidth () const
Gets the minimum width constraint of the element.
int | GetMaxWidth () const
Gets the maximum width constraint of the element.
int | GetWidth () const
Gets the width of the element.
int | GetMinHeight () const
Gets the minimum height constraint of the element.
int | GetMaxHeight () const
Gets the maximum height constraint of the element.
int | GetHeight () const
Gets the height of the element.
CXTPMarkupObject * | GetTag () const
Gets the tag object of the element.
void | SetTag (CXTPMarkupObject *pTag)
Sets the tag object for the element.
void | SetHorizontalAlignment (XTPMarkupHorizontalAlignment alignment)
Sets the horizontal alignment characteristics applied to this element when it is composed within a parent element (e.g.
void | SetVerticalAlignment (XTPMarkupVerticalAlignment alignment)
Sets the vertical alignment characteristics applied to this element when it is composed within a parent element (e.g.
XTPMarkupHorizontalAlignment | GetHorizontalAlignment () const
Gets the horizontal alignment characteristics applied to this element when it is composed within a parent element (e.g.
XTPMarkupVerticalAlignment | GetVerticalAlignment () const
Gets the vertical alignment characteristics applied to this element when it is composed within a parent element (e.g.
CSize | GetActualSize () const
Retrieves the actual size of the element after it is measured and arranged within a parent element (e.g.
void | SetClipToBounds (BOOL bClipToBounds)
Specifies if child elements should be clipped inside element bounds.
BOOL | GetClipToBounds () const
Determines if child elements are clipped inside element bounds.
CXTPMarkupStyle * | GetStyle () const
Gets the attached style of the element.
- Public Member Functions inherited from CXTPMarkupUIElement
void | Arrange (CRect rcFinalRect)
Positions child elements and determines a size for a CXTPMarkupUIElement.
void | Measure (CXTPMarkupDrawingContext *pDC, CSize szAvailableSize)
Updates the DesiredSize of a CXTPMarkupUIElement.
CSize | GetDesiredSize () const
Gets the size that this element computed during the measure pass of the layout process.
CRect | GetFinalRect () const
Gets the final render size of this element.
XTPMarkupVisibility | GetVisibility () const
Gets the user interface (UI) visibility of this element.
void | SetVisibility (XTPMarkupVisibility visibility)
Sets the user interface (UI) visibility of this element.
BOOL | IsFocusable () const
Gets or sets a value indicating whether this element can receive focus.
virtual BOOL | IsVisible () const
Gets a value indicating whether this element is visible in the user interface (UI).
BOOL | IsEnabled () const
Gets or sets a value indicating whether this element is enabled in the user interface (UI).
virtual void | InvalidateArrange ()
Invalidates the arrange state (layout) for the element.
virtual void | InvalidateVisual ()
Invalidates the rendering of the element, and forces a new complete layout pass.
virtual void | InvalidateMeasure ()
Invalidates the measurement state (layout) for the element.
- Public Member Functions inherited from CXTPMarkupVisual
CXTPMarkupVisual ()
Provides the base initialization for objects derived from the CXTPMarkupVisual class.
virtual | ~CXTPMarkupVisual ()
Destroys a CXTPMarkupVisual object, handles cleanup and deallocation.
void | Render (CXTPMarkupDrawingContext *drawingContext)
Call this method to draw a Visual object inside a drawing context.
CXTPMarkupInputElement * | InputHitTest (CPoint point) const
Determines if a point belongs to this object.
virtual int | GetVisualChildrenCount () const
Gets the number of child elements for the Visual.
virtual CXTPMarkupVisual * | GetVisualChild (int nIndex) const
Retrieves the child Visual object located at a specified index within the parent VisualCollection.
virtual int | GetLogicalChildrenCount () const
Retrieves the number of logical child elements of this object.
virtual CXTPMarkupObject * | GetLogicalChild (int nIndex) const
Retrieves the logical child element located at a specified index within the parent collection.
CRect | GetBoundRect () const
Retrieves the bounding rectangle of the element.
CRect | GetUpdateRect () const
Computes the update rectangle.
CSize | GetRenderSize () const
Gets the final render size of this element.
CPoint | GetVisualOffset () const
Gets or sets the offset value of the visual object.
CXTPMarkupVisual * | GetVisualParent () const
Gets the Visual tree parent of the Visual object.

Protected Member Functions

CXTPMarkupImage ()
Constructs a CXTPMarkupImage object.
virtual | ~CXTPMarkupImage ()
Destroys a CXTPMarkupImage object, handles cleanup and deallocation.
- Protected Member Functions inherited from CXTPMarkupFrameworkElement
CXTPMarkupFrameworkElement ()
Initializes a new instance of the CXTPMarkupFrameworkElement class.
virtual | ~CXTPMarkupFrameworkElement ()
Destroys a CXTPMarkupFrameworkElement object, handles cleanup and deallocation.
- Protected Member Functions inherited from CXTPMarkupUIElement
CXTPMarkupUIElement ()
Initializes a new instance of the CXTPMarkupUIElement class.
virtual | ~CXTPMarkupUIElement ()
Destroys a CXTPMarkupUIElement object, handles cleanup and deallocation.
CXTPMarkupRenderTransform * | GetRenderTransform () const
Obtains a pointer to the RenderTransform object.
virtual void | ArrangeCore (CRect rcFinalRect)
Defines the template for the core-level arrange layout definition.
virtual CSize | MeasureCore (CXTPMarkupDrawingContext *pDC, CSize szAvailableSize)
When overridden in a derived class, provides measurement logic for sizing this element properly with consideration of the size of any child element content.
virtual BOOL | GetLayoutClip (CRect &rc) const
Retrieves an alternative clipping geometry that represents the region that would be clipped if child elements were clipped inside element bounds.
virtual void | InvalidateMeasureOverride (CXTPMarkupDrawingContext *pDC)
Override this method to provide a custom reaction to an InvalidateMeasure call.
virtual TransformationMatrices | ApplyRenderTransform (CXTPMarkupDrawingContext *pContext)
Applies render transformation if necessary.
virtual void | RestoreRenderTransform (CXTPMarkupDrawingContext *pContext, TransformationMatrices &matrices)
Restores a previously applied render transformation.
virtual double | GetOpacity () const
Gets either the default or explicitly set opacity factor value.
- Protected Member Functions inherited from CXTPMarkupVisual
BOOL | PtInRectTransform (const RECT &rect, const POINT &point) const
Checks if a point is inside a rectangle with transformation applied.
POINT | GetAbsoluteVisualOffset () const
Gets the absolute element visual offset.
virtual void | OnRender (CXTPMarkupDrawingContext *drawingContext)
When overridden in a derived class, participates in rendering operations that are directed by the layout system.
virtual void | OnRenderFocusVisual (CXTPMarkupDrawingContext *drawingContext)
This method is called to render the focus rectangle of a focused object.
virtual CXTPMarkupInputElement * | InputHitTestOverride (CPoint point) const
Override this method in the derived class to provide visual hit testing of a child object.
virtual void | RenderClipped (CXTPMarkupDrawingContext *drawingContext)
Called by the framework when an element is clipped and no rendering will occur.

Additional Inherited Members

- Static Public Attributes inherited from CXTPMarkupUIElement
static CXTPMarkupDependencyProperty * | m_pClipToBoundsProperty
Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element.
static CXTPMarkupDependencyProperty * | m_pVisibilityProperty
A value indicating whether this element is visible in the user interface (UI).
static CXTPMarkupDependencyProperty * | m_pFocusableProperty
A value that indicates whether the element can receive focus.
static CXTPMarkupDependencyProperty * | m_pIsEnabledProperty
A value indicating whether thiselement is enabled in the user interface (UI).
static CXTPMarkupDependencyProperty * | m_pRenderTransformProperty
Gets or sets transform information that affects the rendering position of this element.
static CXTPMarkupDependencyProperty * | m_pRenderTransformOriginProperty
Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element.
static CXTPMarkupDependencyProperty * | m_pOpacityProperty
Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI).
- Protected Attributes inherited from CXTPMarkupUIElement
CSize | m_szDesiredSize
Gets the size that this element computed during the measure pass of the layout process.
CRect | m_rcFinalRect
Final position of the visual element.
BOOL | m_bMeasureDirty
TRUE if object hasn't recalculated its size.
BOOL | m_bNeverMeasured
TRUE if object has never ran Measure to update its size.
CSize | m_szPreviousAvailableSize
Previous available size of measure call.
BOOL | m_bArrangeDirty
TRUE if object position can be invalid.
BOOL | m_bNeverArranged
TRUE if Arrange was never called for this object.
BOOL | m_bArrangeInProgress
TRUE if Arrange is currently executed.
BOOL | m_bMeasureInProgress
TRUE if Measure is currently executed.
- Protected Attributes inherited from CXTPMarkupVisual
CPoint | m_ptVisualOffset
The offset value of the visual object.
CSize | m_szRenderSize
The rendered size for this element.
CRect | m_rcBoundRect
Bounding rectangle of the element.
CRect | m_rcUpdateRect
Update rectangle.
CRect | m_rcPrevUpdateRect
Previous update rectangle.

Detailed Description

CXTPMarkupImage is a CXTPMarkupFrameworkElement derived class.

It implements the Image XAML Tag.

Member Function Documentation

◆ GetOriginalSize()

CSize GetOriginalSize ( ) const

Retrieves the original size of the image (not scaled).

Returns
A CSize object containing the original size of the image.

◆ GetSource()

CString GetSource ( )

Retrieves the source of the image to load.

Returns
The string contained URI of the image to load.

◆ GetStretch()

XTPMarkupStretch GetStretch ( ) const

Gets the current stretch type of the image.

Returns
The current stretch type.

◆ SetSource()

void SetSource ( LPCTSTR lpszSource )

Sets the source of the image to load.

Parameters
lpszSource String contained URI of the image to load.

Example:

pImage->SetSource("file://c:\\image.bmp); // Load from file
pImage->SetSource("res://#125"); // Load from resources
pImage->SetSource("125");  // Use Image manager index

◆ SetStretch()

void SetStretch ( XTPMarkupStretch stretch )

Sets the stretch type of the image.

Parameters
stretch New stretch type.
The documentation for this class was generated from the following file:
  • XTPMarkupImage.h


Toolkit Pro: CXTPMarkupMatrixTransform Class Reference

Public Member Functions | List of all members
CXTPMarkupMatrixTransform Class Reference

Default MatrixTransform implementation. More...

Inheritance diagram for CXTPMarkupMatrixTransform:
[legend]

Public Member Functions

virtual CXTPMarkupTransformationMatrix * ApplyTransform (const CXTPMarkupTransformationMatrix *pMatrix)
Does nothing in default implementation.
- Public Member Functions inherited from CXTPMarkupTransform

Additional Inherited Members

- Protected Member Functions inherited from CXTPMarkupTransform
CXTPMarkupTransform ()
Prevents a class from being instantiated.
- Protected Attributes inherited from CXTPMarkupTransform

Detailed Description

Default MatrixTransform implementation.

Member Function Documentation

◆ ApplyTransform()

virtual CXTPMarkupTransformationMatrix * ApplyTransform ( const CXTPMarkupTransformationMatrix * pMatrix )
virtual

Does nothing in default implementation.

Parameters
pMatrix Pointer to a markup transformation matrix to be transformed.
Returns
NULL in default implementation.

Reimplemented from CXTPMarkupTransform.

The documentation for this class was generated from the following file:
  • XTPMarkupMatrixTransform.h


Toolkit Pro: CXTPMarkupPage Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPMarkupPage Class Reference

CXTPMarkupPage is a CXTPMarkupFrameworkElement derived class. More...

Inheritance diagram for CXTPMarkupPage:
[legend]

Public Member Functions

void | SetContent (CXTPMarkupUIElement *pContent)
Sets the child object for the page element.
CXTPMarkupUIElement * | GetContent () const
Retrieves the child object for the page element.
- Public Member Functions inherited from CXTPMarkupFrameworkElement
void | SetMargin (int nLeft, int nTop, int nRight, int nBottom)
Call this method to set the outer margin of an element.
void | SetMargin (int nMargin)
Call this method to set the outer margin of an element.
CXTPMarkupThickness * | GetMargin () const
Call this method to get the outer margin of an element.
void | SetMinWidth (int nWidth)
Sets the minimum width constraint for the element.
void | SetMaxWidth (int nWidth)
Sets the maximum width constraint for the element.
void | SetWidth (int nWidth)
Sets the width for the element.
void | SetMinHeight (int nHeight)
Sets the minimum height constraint for the element.
void | SetMaxHeight (int nHeight)
Sets the maximum height constraint for the element.
void | SetHeight (int nHeight)
Sets the height for the element.
int | GetMinWidth () const
Gets the minimum width constraint of the element.
int | GetMaxWidth () const
Gets the maximum width constraint of the element.
int | GetWidth () const
Gets the width of the element.
int | GetMinHeight () const
Gets the minimum height constraint of the element.
int | GetMaxHeight () const
Gets the maximum height constraint of the element.
int | GetHeight () const
Gets the height of the element.
CXTPMarkupObject * | GetTag () const
Gets the tag object of the element.
void | SetTag (CXTPMarkupObject *pTag)
Sets the tag object for the element.
void | SetHorizontalAlignment (XTPMarkupHorizontalAlignment alignment)
Sets the horizontal alignment characteristics applied to this element when it is composed within a parent element (e.g.
void | SetVerticalAlignment (XTPMarkupVerticalAlignment alignment)
Sets the vertical alignment characteristics applied to this element when it is composed within a parent element (e.g.
XTPMarkupHorizontalAlignment | GetHorizontalAlignment () const
Gets the horizontal alignment characteristics applied to this element when it is composed within a parent element (e.g.
XTPMarkupVerticalAlignment | GetVerticalAlignment () const
Gets the vertical alignment characteristics applied to this element when it is composed within a parent element (e.g.
CSize | GetActualSize () const
Retrieves the actual size of the element after it is measured and arranged within a parent element (e.g.
void | SetClipToBounds (BOOL bClipToBounds)
Specifies if child elements should be clipped inside element bounds.
BOOL | GetClipToBounds () const
Determines if child elements are clipped inside element bounds.
CXTPMarkupStyle * | GetStyle () const
Gets the attached style of the element.
- Public Member Functions inherited from CXTPMarkupUIElement
void | Arrange (CRect rcFinalRect)
Positions child elements and determines a size for a CXTPMarkupUIElement.
void | Measure (CXTPMarkupDrawingContext *pDC, CSize szAvailableSize)
Updates the DesiredSize of a CXTPMarkupUIElement.
CSize | GetDesiredSize () const
Gets the size that this element computed during the measure pass of the layout process.
CRect | GetFinalRect () const
Gets the final render size of this element.
XTPMarkupVisibility | GetVisibility () const
Gets the user interface (UI) visibility of this element.
void | SetVisibility (XTPMarkupVisibility visibility)
Sets the user interface (UI) visibility of this element.
BOOL | IsFocusable () const
Gets or sets a value indicating whether this element can receive focus.
virtual BOOL | IsVisible () const
Gets a value indicating whether this element is visible in the user interface (UI).
BOOL | IsEnabled () const
Gets or sets a value indicating whether this element is enabled in the user interface (UI).
virtual void | InvalidateArrange ()
Invalidates the arrange state (layout) for the element.
virtual void | InvalidateVisual ()
Invalidates the rendering of the element, and forces a new complete layout pass.
virtual void | InvalidateMeasure ()
Invalidates the measurement state (layout) for the element.
- Public Member Functions inherited from CXTPMarkupVisual
CXTPMarkupVisual ()
Provides the base initialization for objects derived from the CXTPMarkupVisual class.
virtual | ~CXTPMarkupVisual ()
Destroys a CXTPMarkupVisual object, handles cleanup and deallocation.
void | Render (CXTPMarkupDrawingContext *drawingContext)
Call this method to draw a Visual object inside a drawing context.
CXTPMarkupInputElement * | InputHitTest (CPoint point) const
Determines if a point belongs to this object.
virtual int | GetVisualChildrenCount () const
Gets the number of child elements for the Visual.
virtual CXTPMarkupVisual * | GetVisualChild (int nIndex) const
Retrieves the child Visual object located at a specified index within the parent VisualCollection.
virtual int | GetLogicalChildrenCount () const
Retrieves the number of logical child elements of this object.
virtual CXTPMarkupObject * | GetLogicalChild (int nIndex) const
Retrieves the logical child element located at a specified index within the parent collection.
CRect | GetBoundRect () const
Retrieves the bounding rectangle of the element.
CRect | GetUpdateRect () const
Computes the update rectangle.
CSize | GetRenderSize () const
Gets the final render size of this element.
CPoint | GetVisualOffset () const
Gets or sets the offset value of the visual object.
CXTPMarkupVisual * | GetVisualParent () const
Gets the Visual tree parent of the Visual object.

Protected Member Functions

CXTPMarkupPage ()
Constructs a CXTPMarkupPage object.
virtual | ~CXTPMarkupPage ()
Destroys a CXTPMarkupPage object, handles cleanup and deallocation.
- Protected Member Functions inherited from CXTPMarkupFrameworkElement
CXTPMarkupFrameworkElement ()
Initializes a new instance of the CXTPMarkupFrameworkElement class.
virtual | ~CXTPMarkupFrameworkElement ()
Destroys a CXTPMarkupFrameworkElement object, handles cleanup and deallocation.
- Protected Member Functions inherited from CXTPMarkupUIElement
CXTPMarkupUIElement ()
Initializes a new instance of the CXTPMarkupUIElement class.
virtual | ~CXTPMarkupUIElement ()
Destroys a CXTPMarkupUIElement object, handles cleanup and deallocation.
CXTPMarkupRenderTransform * | GetRenderTransform () const
Obtains a pointer to the RenderTransform object.
virtual void | ArrangeCore (CRect rcFinalRect)
Defines the template for the core-level arrange layout definition.
virtual CSize | MeasureCore (CXTPMarkupDrawingContext *pDC, CSize szAvailableSize)
When overridden in a derived class, provides measurement logic for sizing this element properly with consideration of the size of any child element content.
virtual BOOL | GetLayoutClip (CRect &rc) const
Retrieves an alternative clipping geometry that represents the region that would be clipped if child elements were clipped inside element bounds.
virtual void | InvalidateMeasureOverride (CXTPMarkupDrawingContext *pDC)
Override this method to provide a custom reaction to an InvalidateMeasure call.
virtual TransformationMatrices | ApplyRenderTransform (CXTPMarkupDrawingContext *pContext)
Applies render transformation if necessary.
virtual void | RestoreRenderTransform (CXTPMarkupDrawingContext *pContext, TransformationMatrices &matrices)
Restores a previously applied render transformation.
virtual double | GetOpacity () const
Gets either the default or explicitly set opacity factor value.
- Protected Member Functions inherited from CXTPMarkupVisual
BOOL | PtInRectTransform (const RECT &rect, const POINT &point) const
Checks if a point is inside a rectangle with transformation applied.
POINT | GetAbsoluteVisualOffset () const
Gets the absolute element visual offset.
virtual void | OnRender (CXTPMarkupDrawingContext *drawingContext)
When overridden in a derived class, participates in rendering operations that are directed by the layout system.
virtual void | OnRenderFocusVisual (CXTPMarkupDrawingContext *drawingContext)
This method is called to render the focus rectangle of a focused object.
virtual CXTPMarkupInputElement * | InputHitTestOverride (CPoint point) const
Override this method in the derived class to provide visual hit testing of a child object.
virtual void | RenderClipped (CXTPMarkupDrawingContext *drawingContext)
Called by the framework when an element is clipped and no rendering will occur.

Additional Inherited Members

- Static Public Attributes inherited from CXTPMarkupUIElement
static CXTPMarkupDependencyProperty * | m_pClipToBoundsProperty
Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element.
static CXTPMarkupDependencyProperty * | m_pVisibilityProperty
A value indicating whether this element is visible in the user interface (UI).
static CXTPMarkupDependencyProperty * | m_pFocusableProperty
A value that indicates whether the element can receive focus.
static CXTPMarkupDependencyProperty * | m_pIsEnabledProperty
A value indicating whether thiselement is enabled in the user interface (UI).
static CXTPMarkupDependencyProperty * | m_pRenderTransformProperty
Gets or sets transform information that affects the rendering position of this element.
static CXTPMarkupDependencyProperty * | m_pRenderTransformOriginProperty
Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element.
static CXTPMarkupDependencyProperty * | m_pOpacityProperty
Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI).
- Protected Attributes inherited from CXTPMarkupUIElement
CSize | m_szDesiredSize
Gets the size that this element computed during the measure pass of the layout process.
CRect | m_rcFinalRect
Final position of the visual element.
BOOL | m_bMeasureDirty
TRUE if object hasn't recalculated its size.
BOOL | m_bNeverMeasured
TRUE if object has never ran Measure to update its size.
CSize | m_szPreviousAvailableSize
Previous available size of measure call.
BOOL | m_bArrangeDirty
TRUE if object position can be invalid.
BOOL | m_bNeverArranged
TRUE if Arrange was never called for this object.
BOOL | m_bArrangeInProgress
TRUE if Arrange is currently executed.
BOOL | m_bMeasureInProgress
TRUE if Measure is currently executed.
- Protected Attributes inherited from CXTPMarkupVisual
CPoint | m_ptVisualOffset
The offset value of the visual object.
CSize | m_szRenderSize
The rendered size for this element.
CRect | m_rcBoundRect
Bounding rectangle of the element.
CRect | m_rcUpdateRect
Update rectangle.
CRect | m_rcPrevUpdateRect
Previous update rectangle.

Detailed Description

CXTPMarkupPage is a CXTPMarkupFrameworkElement derived class.

It implements the Page XAML Tag.

Member Function Documentation

◆ GetContent()

CXTPMarkupUIElement * GetContent ( ) const

Retrieves the child object for the page element.

Returns
A pointer to a CXTPMarkupUIElement object.
See also
SetContent

◆ SetContent()

void SetContent ( CXTPMarkupUIElement * pContent )

Sets the child object for the page element.

Parameters
pContent Pointer to a CXTPMarkupUIElement object.
See also
GetContent
The documentation for this class was generated from the following file:
  • XTPMarkupPage.h


Toolkit Pro: CXTPMarkupPanel Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPMarkupPanel Class Reference

CXTPMarkupPanel is a CXTPMarkupFrameworkElement derived class. More...

Inheritance diagram for CXTPMarkupPanel:
[legend]

Public Member Functions

CXTPMarkupUIElementCollection * | GetChildren () const
Retrieves the collection of child elements.
void | SetBackground (CXTPMarkupBrush *pBrush)
Sets the background brush for the panel object.
CXTPMarkupBrush * | GetBackground () const
Gets the background brush of the panel object.
- Public Member Functions inherited from CXTPMarkupFrameworkElement
void | SetMargin (int nLeft, int nTop, int nRight, int nBottom)
Call this method to set the outer margin of an element.
void | SetMargin (int nMargin)
Call this method to set the outer margin of an element.
CXTPMarkupThickness * | GetMargin () const
Call this method to get the outer margin of an element.
void | SetMinWidth (int nWidth)
Sets the minimum width constraint for the element.
void | SetMaxWidth (int nWidth)
Sets the maximum width constraint for the element.
void | SetWidth (int nWidth)
Sets the width for the element.
void | SetMinHeight (int nHeight)
Sets the minimum height constraint for the element.
void | SetMaxHeight (int nHeight)
Sets the maximum height constraint for the element.
void | SetHeight (int nHeight)
Sets the height for the element.
int | GetMinWidth () const
Gets the minimum width constraint of the element.
int | GetMaxWidth () const
Gets the maximum width constraint of the element.
int | GetWidth () const
Gets the width of the element.
int | GetMinHeight () const
Gets the minimum height constraint of the element.
int | GetMaxHeight () const
Gets the maximum height constraint of the element.
int | GetHeight () const
Gets the height of the element.
CXTPMarkupObject * | GetTag () const
Gets the tag object of the element.
void | SetTag (CXTPMarkupObject *pTag)
Sets the tag object for the element.
void | SetHorizontalAlignment (XTPMarkupHorizontalAlignment alignment)
Sets the horizontal alignment characteristics applied to this element when it is composed within a parent element (e.g.
void | SetVerticalAlignment (XTPMarkupVerticalAlignment alignment)
Sets the vertical alignment characteristics applied to this element when it is composed within a parent element (e.g.
XTPMarkupHorizontalAlignment | GetHorizontalAlignment () const
Gets the horizontal alignment characteristics applied to this element when it is composed within a parent element (e.g.
XTPMarkupVerticalAlignment | GetVerticalAlignment () const
Gets the vertical alignment characteristics applied to this element when it is composed within a parent element (e.g.
CSize | GetActualSize () const
Retrieves the actual size of the element after it is measured and arranged within a parent element (e.g.
void | SetClipToBounds (BOOL bClipToBounds)
Specifies if child elements should be clipped inside element bounds.
BOOL | GetClipToBounds () const
Determines if child elements are clipped inside element bounds.
CXTPMarkupStyle * | GetStyle () const
Gets the attached style of the element.
- Public Member Functions inherited from CXTPMarkupUIElement
void | Arrange (CRect rcFinalRect)
Positions child elements and determines a size for a CXTPMarkupUIElement.
void | Measure (CXTPMarkupDrawingContext *pDC, CSize szAvailableSize)
Updates the DesiredSize of a CXTPMarkupUIElement.
CSize | GetDesiredSize () const
Gets the size that this element computed during the measure pass of the layout process.
CRect | GetFinalRect () const
Gets the final render size of this element.
XTPMarkupVisibility | GetVisibility () const
Gets the user interface (UI) visibility of this element.
void | SetVisibility (XTPMarkupVisibility visibility)
Sets the user interface (UI) visibility of this element.
BOOL | IsFocusable () const
Gets or sets a value indicating whether this element can receive focus.
virtual BOOL | IsVisible () const
Gets a value indicating whether this element is visible in the user interface (UI).
BOOL | IsEnabled () const
Gets or sets a value indicating whether this element is enabled in the user interface (UI).
virtual void | InvalidateArrange ()
Invalidates the arrange state (layout) for the element.
virtual void | InvalidateVisual ()
Invalidates the rendering of the element, and forces a new complete layout pass.
virtual void | InvalidateMeasure ()
Invalidates the measurement state (layout) for the element.
- Public Member Functions inherited from CXTPMarkupVisual
CXTPMarkupVisual ()
Provides the base initialization for objects derived from the CXTPMarkupVisual class.
virtual | ~CXTPMarkupVisual ()
Destroys a CXTPMarkupVisual object, handles cleanup and deallocation.
void | Render (CXTPMarkupDrawingContext *drawingContext)
Call this method to draw a Visual object inside a drawing context.
CXTPMarkupInputElement * | InputHitTest (CPoint point) const
Determines if a point belongs to this object.
virtual int | GetVisualChildrenCount () const
Gets the number of child elements for the Visual.
virtual CXTPMarkupVisual * | GetVisualChild (int nIndex) const
Retrieves the child Visual object located at a specified index within the parent VisualCollection.
virtual int | GetLogicalChildrenCount () const
Retrieves the number of logical child elements of this object.
virtual CXTPMarkupObject * | GetLogicalChild (int nIndex) const
Retrieves the logical child element located at a specified index within the parent collection.
CRect | GetBoundRect () const
Retrieves the bounding rectangle of the element.
CRect | GetUpdateRect () const
Computes the update rectangle.
CSize | GetRenderSize () const
Gets the final render size of this element.
CPoint | GetVisualOffset () const
Gets or sets the offset value of the visual object.
CXTPMarkupVisual * | GetVisualParent () const
Gets the Visual tree parent of the Visual object.

Protected Member Functions

CXTPMarkupPanel ()
Constructs a CXTPMarkupPanel object.
virtual | ~CXTPMarkupPanel ()
Destroys a CXTPMarkupPanel object, handles cleanup and deallocation.
- Protected Member Functions inherited from CXTPMarkupFrameworkElement
CXTPMarkupFrameworkElement ()
Initializes a new instance of the CXTPMarkupFrameworkElement class.
virtual | ~CXTPMarkupFrameworkElement ()
Destroys a CXTPMarkupFrameworkElement object, handles cleanup and deallocation.
- Protected Member Functions inherited from CXTPMarkupUIElement
CXTPMarkupUIElement ()
Initializes a new instance of the CXTPMarkupUIElement class.
virtual | ~CXTPMarkupUIElement ()
Destroys a CXTPMarkupUIElement object, handles cleanup and deallocation.
CXTPMarkupRenderTransform * | GetRenderTransform () const
Obtains a pointer to the RenderTransform object.
virtual void | ArrangeCore (CRect rcFinalRect)
Defines the template for the core-level arrange layout definition.
virtual CSize | MeasureCore (CXTPMarkupDrawingContext *pDC, CSize szAvailableSize)
When overridden in a derived class, provides measurement logic for sizing this element properly with consideration of the size of any child element content.
virtual BOOL | GetLayoutClip (CRect &rc) const
Retrieves an alternative clipping geometry that represents the region that would be clipped if child elements were clipped inside element bounds.
virtual void | InvalidateMeasureOverride (CXTPMarkupDrawingContext *pDC)
Override this method to provide a custom reaction to an InvalidateMeasure call.
virtual TransformationMatrices | ApplyRenderTransform (CXTPMarkupDrawingContext *pContext)
Applies render transformation if necessary.
virtual void | RestoreRenderTransform (CXTPMarkupDrawingContext *pContext, TransformationMatrices &matrices)
Restores a previously applied render transformation.
virtual double | GetOpacity () const
Gets either the default or explicitly set opacity factor value.
- Protected Member Functions inherited from CXTPMarkupVisual
BOOL | PtInRectTransform (const RECT &rect, const POINT &point) const
Checks if a point is inside a rectangle with transformation applied.
POINT | GetAbsoluteVisualOffset () const
Gets the absolute element visual offset.
virtual void | OnRender (CXTPMarkupDrawingContext *drawingContext)
When overridden in a derived class, participates in rendering operations that are directed by the layout system.
virtual void | OnRenderFocusVisual (CXTPMarkupDrawingContext *drawingContext)
This method is called to render the focus rectangle of a focused object.
virtual CXTPMarkupInputElement * | InputHitTestOverride (CPoint point) const
Override this method in the derived class to provide visual hit testing of a child object.
virtual void | RenderClipped (CXTPMarkupDrawingContext *drawingContext)
Called by the framework when an element is clipped and no rendering will occur.

Additional Inherited Members

- Static Public Attributes inherited from CXTPMarkupUIElement
static CXTPMarkupDependencyProperty * | m_pClipToBoundsProperty
Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element.
static CXTPMarkupDependencyProperty * | m_pVisibilityProperty
A value indicating whether this element is visible in the user interface (UI).
static CXTPMarkupDependencyProperty * | m_pFocusableProperty
A value that indicates whether the element can receive focus.
static CXTPMarkupDependencyProperty * | m_pIsEnabledProperty
A value indicating whether thiselement is enabled in the user interface (UI).
static CXTPMarkupDependencyProperty * | m_pRenderTransformProperty
Gets or sets transform information that affects the rendering position of this element.
static CXTPMarkupDependencyProperty * | m_pRenderTransformOriginProperty
Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element.
static CXTPMarkupDependencyProperty * | m_pOpacityProperty
Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI).
- Protected Attributes inherited from CXTPMarkupUIElement
CSize | m_szDesiredSize
Gets the size that this element computed during the measure pass of the layout process.
CRect | m_rcFinalRect
Final position of the visual element.
BOOL | m_bMeasureDirty
TRUE if object hasn't recalculated its size.
BOOL | m_bNeverMeasured
TRUE if object has never ran Measure to update its size.
CSize | m_szPreviousAvailableSize
Previous available size of measure call.
BOOL | m_bArrangeDirty
TRUE if object position can be invalid.
BOOL | m_bNeverArranged
TRUE if Arrange was never called for this object.
BOOL | m_bArrangeInProgress
TRUE if Arrange is currently executed.
BOOL | m_bMeasureInProgress
TRUE if Measure is currently executed.
- Protected Attributes inherited from CXTPMarkupVisual
CPoint | m_ptVisualOffset
The offset value of the visual object.
CSize | m_szRenderSize
The rendered size for this element.
CRect | m_rcBoundRect
Bounding rectangle of the element.
CRect | m_rcUpdateRect
Update rectangle.
CRect | m_rcPrevUpdateRect
Previous update rectangle.

Detailed Description

CXTPMarkupPanel is a CXTPMarkupFrameworkElement derived class.

It implements a base class for all container objects with multiple children.

Member Function Documentation

◆ GetBackground()

CXTPMarkupBrush * GetBackground ( ) const

Gets the background brush of the panel object.

Returns
A pointer to the background brush of the panel object.

◆ GetChildren()

AFX_INLINE CXTPMarkupUIElementCollection * GetChildren ( ) const

Retrieves the collection of child elements.

Returns
A pointer to a CXTPMarkupUIElementCollection object.

◆ SetBackground()

void SetBackground ( CXTPMarkupBrush * pBrush )

Sets the background brush for the panel object.

Parameters
pBrush Pointer to a CBrush object.
The documentation for this class was generated from the following file:
  • XTPMarkupPanel.h


Toolkit Pro: CXTPMarkupRadioButton Class Reference

Protected Member Functions | List of all members
CXTPMarkupRadioButton Class Reference

CXTPMarkupRadioButton is a CXTPMarkupToggleButton derived class. More...

Inheritance diagram for CXTPMarkupRadioButton:
[legend]

Protected Member Functions

CXTPMarkupRadioButton ()
Constructs a CXTPMarkupRadioButton object.
~CXTPMarkupRadioButton ()
Destroys a CXTPMarkupRadioButton object, handles cleanup and deallocation.
- Protected Member Functions inherited from CXTPMarkupToggleButton
virtual void | OnClick ()
Virtual method called when the user clicks the button.
virtual void | OnToggle ()
Virtual method called when the state is toggled by the user.
virtual void | OnChecked (CXTPMarkupRoutedEventArgs *e)
Virtual method called when the user sets the state to checked.
virtual void | OnUnchecked (CXTPMarkupRoutedEventArgs *e)
Virtual method called when the user sets the state to unchecked.
virtual void | OnIndeterminate (CXTPMarkupRoutedEventArgs *e)
Virtual method called when the user sets the state to indeterminate.
- Protected Member Functions inherited from CXTPMarkupButtonBase
CXTPMarkupButtonBase ()
Constructs a CXTPMarkupButtonBase object.
~CXTPMarkupButtonBase ()
Destroys a CXTPMarkupButtonBase object, handles cleanup and deallocation.
- Protected Member Functions inherited from CXTPMarkupContentControl
CXTPMarkupContentControl ()
Constructs a CXTPMarkupContentControl object.
virtual | ~CXTPMarkupContentControl ()
Destroys a CXTPMarkupContentControl object, handles cleanup and deallocation.
- Protected Member Functions inherited from CXTPMarkupFrameworkElement
CXTPMarkupFrameworkElement ()
Initializes a new instance of the CXTPMarkupFrameworkElement class.
virtual | ~CXTPMarkupFrameworkElement ()
Destroys a CXTPMarkupFrameworkElement object, handles cleanup and deallocation.
- Protected Member Functions inherited from CXTPMarkupUIElement
CXTPMarkupUIElement ()
Initializes a new instance of the CXTPMarkupUIElement class.
virtual | ~CXTPMarkupUIElement ()
Destroys a CXTPMarkupUIElement object, handles cleanup and deallocation.
CXTPMarkupRenderTransform * | GetRenderTransform () const
Obtains a pointer to the RenderTransform object.
virtual void | ArrangeCore (CRect rcFinalRect)
Defines the template for the core-level arrange layout definition.
virtual CSize | MeasureCore (CXTPMarkupDrawingContext *pDC, CSize szAvailableSize)
When overridden in a derived class, provides measurement logic for sizing this element properly with consideration of the size of any child element content.
virtual BOOL | GetLayoutClip (CRect &rc) const
Retrieves an alternative clipping geometry that represents the region that would be clipped if child elements were clipped inside element bounds.
virtual void | InvalidateMeasureOverride (CXTPMarkupDrawingContext *pDC)
Override this method to provide a custom reaction to an InvalidateMeasure call.
virtual TransformationMatrices | ApplyRenderTransform (CXTPMarkupDrawingContext *pContext)
Applies render transformation if necessary.
virtual void | RestoreRenderTransform (CXTPMarkupDrawingContext *pContext, TransformationMatrices &matrices)
Restores a previously applied render transformation.
virtual double | GetOpacity () const
Gets either the default or explicitly set opacity factor value.
- Protected Member Functions inherited from CXTPMarkupVisual
BOOL | PtInRectTransform (const RECT &rect, const POINT &point) const
Checks if a point is inside a rectangle with transformation applied.
POINT | GetAbsoluteVisualOffset () const
Gets the absolute element visual offset.
virtual void | OnRender (CXTPMarkupDrawingContext *drawingContext)
When overridden in a derived class, participates in rendering operations that are directed by the layout system.
virtual void | OnRenderFocusVisual (CXTPMarkupDrawingContext *drawingContext)
This method is called to render the focus rectangle of a focused object.
virtual CXTPMarkupInputElement * | InputHitTestOverride (CPoint point) const
Override this method in the derived class to provide visual hit testing of a child object.
virtual void | RenderClipped (CXTPMarkupDrawingContext *drawingContext)
Called by the framework when an element is clipped and no rendering will occur.

Additional Inherited Members

- Public Member Functions inherited from CXTPMarkupToggleButton
void | SetChecked (BOOL bChecked)
Call this method to set the checked state for a button.
BOOL | GetChecked () const
Determines the checked state of a button.
void | SetThreeState (BOOL bThreeState)
Specifies if the button supports two or three states.
BOOL | IsThreeState () const
Determines if the button supports two or three states.
- Public Member Functions inherited from CXTPMarkupButtonBase
BOOL | IsPressed () const
Determines if the button is currently pressed.
- Public Member Functions inherited from CXTPMarkupContentControl
CXTPMarkupUIElement * | GetContent () const
Gets the child object of the ControlContent element.
void | SetContent (CXTPMarkupUIElement *pContent)
Sets the child object for the ControlContent element.
- Public Member Functions inherited from CXTPMarkupControl
void | SetPadding (int nLeft, int nTop, int nRight, int nBottom)
Sets a value that indicates the thickness of the padding space between the boundaries of the content area and the content displayed by a control.
void | SetPadding (int nPadding)
Sets a value that indicates the thickness of the padding space between the boundaries of the content area and the content displayed by a control.
CXTPMarkupThickness * | GetPadding () const
Retrieves a value that indicates the thickness of the padding space between the boundaries of the content area and the content displayed by a control.
void | SetBackground (CXTPMarkupBrush *pBrush)
Sets the background brush for the control object.
CXTPMarkupBrush * | GetBackground () const
Gets the background brush of the control object.
void | SetForeground (CXTPMarkupBrush *pBrush)
Sets the default text brush for the control object.
CXTPMarkupBrush * | GetForeground () const
Gets the default text brush of the control object.
- Public Member Functions inherited from CXTPMarkupFrameworkElement
void | SetMargin (int nLeft, int nTop, int nRight, int nBottom)
Call this method to set the outer margin of an element.
void | SetMargin (int nMargin)
Call this method to set the outer margin of an element.
CXTPMarkupThickness * | GetMargin () const
Call this method to get the outer margin of an element.
void | SetMinWidth (int nWidth)
Sets the minimum width constraint for the element.
void | SetMaxWidth (int nWidth)
Sets the maximum width constraint for the element.
void | SetWidth (int nWidth)
Sets the width for the element.
void | SetMinHeight (int nHeight)
Sets the minimum height constraint for the element.
void | SetMaxHeight (int nHeight)
Sets the maximum height constraint for the element.
void | SetHeight (int nHeight)
Sets the height for the element.
int | GetMinWidth () const
Gets the minimum width constraint of the element.
int | GetMaxWidth () const
Gets the maximum width constraint of the element.
int | GetWidth () const
Gets the width of the element.
int | GetMinHeight () const
Gets the minimum height constraint of the element.
int | GetMaxHeight () const
Gets the maximum height constraint of the element.
int | GetHeight () const
Gets the height of the element.
CXTPMarkupObject * | GetTag () const
Gets the tag object of the element.
void | SetTag (CXTPMarkupObject *pTag)
Sets the tag object for the element.
void | SetHorizontalAlignment (XTPMarkupHorizontalAlignment alignment)
Sets the horizontal alignment characteristics applied to this element when it is composed within a parent element (e.g.
void | SetVerticalAlignment (XTPMarkupVerticalAlignment alignment)
Sets the vertical alignment characteristics applied to this element when it is composed within a parent element (e.g.
XTPMarkupHorizontalAlignment | GetHorizontalAlignment () const
Gets the horizontal alignment characteristics applied to this element when it is composed within a parent element (e.g.
XTPMarkupVerticalAlignment | GetVerticalAlignment () const
Gets the vertical alignment characteristics applied to this element when it is composed within a parent element (e.g.
CSize | GetActualSize () const
Retrieves the actual size of the element after it is measured and arranged within a parent element (e.g.
void | SetClipToBounds (BOOL bClipToBounds)
Specifies if child elements should be clipped inside element bounds.
BOOL | GetClipToBounds () const
Determines if child elements are clipped inside element bounds.
CXTPMarkupStyle * | GetStyle () const
Gets the attached style of the element.
- Public Member Functions inherited from CXTPMarkupUIElement
void | Arrange (CRect rcFinalRect)
Positions child elements and determines a size for a CXTPMarkupUIElement.
void | Measure (CXTPMarkupDrawingContext *pDC, CSize szAvailableSize)
Updates the DesiredSize of a CXTPMarkupUIElement.
CSize | GetDesiredSize () const
Gets the size that this element computed during the measure pass of the layout process.
CRect | GetFinalRect () const
Gets the final render size of this element.
XTPMarkupVisibility | GetVisibility () const
Gets the user interface (UI) visibility of this element.
void | SetVisibility (XTPMarkupVisibility visibility)
Sets the user interface (UI) visibility of this element.
BOOL | IsFocusable () const
Gets or sets a value indicating whether this element can receive focus.
virtual BOOL | IsVisible () const
Gets a value indicating whether this element is visible in the user interface (UI).
BOOL | IsEnabled () const
Gets or sets a value indicating whether this element is enabled in the user interface (UI).
virtual void | InvalidateArrange ()
Invalidates the arrange state (layout) for the element.
virtual void | InvalidateVisual ()
Invalidates the rendering of the element, and forces a new complete layout pass.
virtual void | InvalidateMeasure ()
Invalidates the measurement state (layout) for the element.
- Public Member Functions inherited from CXTPMarkupVisual
CXTPMarkupVisual ()
Provides the base initialization for objects derived from the CXTPMarkupVisual class.
virtual | ~CXTPMarkupVisual ()
Destroys a CXTPMarkupVisual object, handles cleanup and deallocation.
void | Render (CXTPMarkupDrawingContext *drawingContext)
Call this method to draw a Visual object inside a drawing context.
CXTPMarkupInputElement * | InputHitTest (CPoint point) const
Determines if a point belongs to this object.
virtual int | GetVisualChildrenCount () const
Gets the number of child elements for the Visual.
virtual CXTPMarkupVisual * | GetVisualChild (int nIndex) const
Retrieves the child Visual object located at a specified index within the parent VisualCollection.
virtual int | GetLogicalChildrenCount () const
Retrieves the number of logical child elements of this object.
virtual CXTPMarkupObject * | GetLogicalChild (int nIndex) const
Retrieves the logical child element located at a specified index within the parent collection.
CRect | GetBoundRect () const
Retrieves the bounding rectangle of the element.
CRect | GetUpdateRect () const
Computes the update rectangle.
CSize | GetRenderSize () const
Gets the final render size of this element.
CPoint | GetVisualOffset () const
Gets or sets the offset value of the visual object.
CXTPMarkupVisual * | GetVisualParent () const
Gets the Visual tree parent of the Visual object.
- Static Public Attributes inherited from CXTPMarkupUIElement
static CXTPMarkupDependencyProperty * | m_pClipToBoundsProperty
Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element.
static CXTPMarkupDependencyProperty * | m_pVisibilityProperty
A value indicating whether this element is visible in the user interface (UI).
static CXTPMarkupDependencyProperty * | m_pFocusableProperty
A value that indicates whether the element can receive focus.
static CXTPMarkupDependencyProperty * | m_pIsEnabledProperty
A value indicating whether thiselement is enabled in the user interface (UI).
static CXTPMarkupDependencyProperty * | m_pRenderTransformProperty
Gets or sets transform information that affects the rendering position of this element.
static CXTPMarkupDependencyProperty * | m_pRenderTransformOriginProperty
Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element.
static CXTPMarkupDependencyProperty * | m_pOpacityProperty
Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI).
- Protected Attributes inherited from CXTPMarkupUIElement
CSize | m_szDesiredSize
Gets the size that this element computed during the measure pass of the layout process.
CRect | m_rcFinalRect
Final position of the visual element.
BOOL | m_bMeasureDirty
TRUE if object hasn't recalculated its size.
BOOL | m_bNeverMeasured
TRUE if object has never ran Measure to update its size.
CSize | m_szPreviousAvailableSize
Previous available size of measure call.
BOOL | m_bArrangeDirty
TRUE if object position can be invalid.
BOOL | m_bNeverArranged
TRUE if Arrange was never called for this object.
BOOL | m_bArrangeInProgress
TRUE if Arrange is currently executed.
BOOL | m_bMeasureInProgress
TRUE if Measure is currently executed.
- Protected Attributes inherited from CXTPMarkupVisual
CPoint | m_ptVisualOffset
The offset value of the visual object.
CSize | m_szRenderSize
The rendered size for this element.
CRect | m_rcBoundRect
Bounding rectangle of the element.
CRect | m_rcUpdateRect
Update rectangle.
CRect | m_rcPrevUpdateRect
Previous update rectangle.

Detailed Description

CXTPMarkupRadioButton is a CXTPMarkupToggleButton derived class.

It implements the RadioButton XAML Tag.

The documentation for this class was generated from the following file:
  • XTPMarkupRadioButton.h


Toolkit Pro: CXTPMarkupRotateTransform Class Reference

Public Member Functions | Static Public Attributes | List of all members
CXTPMarkupRotateTransform Class Reference

Default RotateTransform implementation. More...

Inheritance diagram for CXTPMarkupRotateTransform:
[legend]

Public Member Functions

double | GetAngle () const
Gets the angle value.
void | SetAngle (double angle)
Sets the angle value.
double | GetCenterX () const
Gets the center X value.
void | SetCenterX (double centerX)
Sets the center X value.
double | GetCenterY () const
Gets the center Y value.
void | SetCenterY (double centerY)
Sets the center Y value.
virtual CXTPMarkupTransformationMatrix * | ApplyTransform (const CXTPMarkupTransformationMatrix *pMatrix)
Does nothing in default implementation.
- Public Member Functions inherited from CXTPMarkupTransform

Static Public Attributes

static CXTPMarkupDependencyProperty * | m_pPropertyAngle
Angle property.
static CXTPMarkupDependencyProperty * | m_pPropertyCenterX
CenterX property.
static CXTPMarkupDependencyProperty * | m_pPropertyCenterY
CenterY property.

Additional Inherited Members

- Protected Member Functions inherited from CXTPMarkupTransform
CXTPMarkupTransform ()
Prevents a class from being instantiated.
- Protected Attributes inherited from CXTPMarkupTransform

Detailed Description

Default RotateTransform implementation.

Member Function Documentation

◆ ApplyTransform()

virtual CXTPMarkupTransformationMatrix * ApplyTransform ( const CXTPMarkupTransformationMatrix * pMatrix )
virtual

Does nothing in default implementation.

Parameters
pMatrix Pointer to a markup transformation matrix to be transformed.
Returns
NULL in default implementation.

Reimplemented from CXTPMarkupTransform.

◆ GetAngle()

double GetAngle ( ) const

Gets the angle value.

Returns
The angle value.

◆ GetCenterX()

double GetCenterX ( ) const

Gets the center X value.

Returns
The center X value.

◆ GetCenterY()

double GetCenterY ( ) const

Gets the center Y value.

Returns
The center Y value.

◆ SetAngle()

void SetAngle ( double angle )

Sets the angle value.

Parameters
angle New angle value.

◆ SetCenterX()

void SetCenterX ( double centerX )

Sets the center X value.

Parameters
centerX New center X value.

◆ SetCenterY()

void SetCenterY ( double centerY )

Sets the center Y value.

Parameters
centerY New center Y value.
The documentation for this class was generated from the following file:
  • XTPMarkupRotateTransform.h


Toolkit Pro: CXTPMarkupRowDefinition Class Reference

Public Member Functions | List of all members
CXTPMarkupRowDefinition Class Reference

CXTPMarkupRowDefinition is a CXTPMarkupDefinitionBase derived class. More...

Inheritance diagram for CXTPMarkupRowDefinition:
[legend]

Public Member Functions

CXTPMarkupRowDefinition ()
Constructs a CXTPMarkupRowDefinition object.
void | SetMinHeight (int nHeight)
Sets the minimum height constraint for the row.
void | SetMaxHeight (int nHeight)
Sets the maximum height constraint for the row.
void | SetHeight (int nHeight)
Sets the height for the row.
void | SetHeight (CXTPMarkupGridLength *pLength)
Sets the height for the row.
- Public Member Functions inherited from CXTPMarkupDefinitionBase
int | GetUserMinSize () const
Retrieves the minimum constraint for user-defined column or row size.
int | GetUserMaxSize () const
Retrieves the maximum constraint for user-defined column or row size.
CXTPMarkupGridLength * | GetUserSize () const
Retrieves the user-defined column or row size.

Additional Inherited Members

- Protected Member Functions inherited from CXTPMarkupDefinitionBase
CXTPMarkupDefinitionBase (BOOL bIsColumnDefinition=FALSE)
Constructs a CXTPMarkupDefinitionBase object.

Detailed Description

CXTPMarkupRowDefinition is a CXTPMarkupDefinitionBase derived class.

It implements the RowDefinition XAML Tag.

Member Function Documentation

◆ SetHeight() [1/2]

void SetHeight ( CXTPMarkupGridLength * pLength )

Sets the height for the row.

Parameters
pLength New height for the row.

◆ SetHeight() [2/2]

void SetHeight ( int nHeight )

Sets the height for the row.

Parameters
nHeight New height for the row.

◆ SetMaxHeight()

void SetMaxHeight ( int nHeight )

Sets the maximum height constraint for the row.

Parameters
nHeight New maximum height constraint.

◆ SetMinHeight()

void SetMinHeight ( int nHeight )

Sets the minimum height constraint for the row.

Parameters
nHeight New minimum height constraint.
The documentation for this class was generated from the following file:
  • XTPMarkupRowDefinition.h


Toolkit Pro: CXTPMarkupRowDefinitionCollection Class Reference

Public Member Functions | List of all members
CXTPMarkupRowDefinitionCollection Class Reference

CXTPMarkupRowDefinitionCollection is a CXTPMarkupDefinitionCollection derived class. More...

Inheritance diagram for CXTPMarkupRowDefinitionCollection:
[legend]

Public Member Functions

CXTPMarkupRowDefinitionCollection ()
Constructs a CXTPMarkupRowDefinitionCollection object.
- Public Member Functions inherited from CXTPMarkupDefinitionCollection
CXTPMarkupDefinitionCollection ()
Constructs a CXTPMarkupDefinitionCollection object.
CXTPMarkupDefinitionBase * GetItem (int nIndex) const
Retrieves a CXTPMarkupDefinitionBase object by its index.

Detailed Description

CXTPMarkupRowDefinitionCollection is a CXTPMarkupDefinitionCollection derived class.

It implements a collection of CXTPMarkupRowDefinition classes.

The documentation for this class was generated from the following file:
  • XTPMarkupRowDefinitionCollection.h


Toolkit Pro: CXTPMarkupScaleTransform Class Reference

Public Member Functions | Static Public Attributes | List of all members
CXTPMarkupScaleTransform Class Reference

Default ScaleTransform implementation. More...

Inheritance diagram for CXTPMarkupScaleTransform:
[legend]

Public Member Functions

double | GetScaleX () const
Gets the scale X value.
void | SetScaleX (double scaleX)
Sets the scale X value.
double | GetScaleY () const
Gets the scale Y value.
void | SetScaleY (double scaleY)
Sets the scale Y value.
double | GetCenterX () const
Gets the center X value.
void | SetCenterX (double centerX)
Sets the center X value.
double | GetCenterY () const
Gets the center Y value.
void | SetCenterY (double centerY)
Sets the center Y value.
virtual CXTPMarkupTransformationMatrix * | ApplyTransform (const CXTPMarkupTransformationMatrix *pMatrix)
Does nothing in default implementation.
- Public Member Functions inherited from CXTPMarkupTransform

Static Public Attributes

static CXTPMarkupDependencyProperty * | m_pPropertyScaleX
ScaleX property.
static CXTPMarkupDependencyProperty * | m_pPropertyScaleY
ScaleY property.
static CXTPMarkupDependencyProperty * | m_pPropertyCenterX
CenterX property.
static CXTPMarkupDependencyProperty * | m_pPropertyCenterY
CenterY property.

Additional Inherited Members

- Protected Member Functions inherited from CXTPMarkupTransform
CXTPMarkupTransform ()
Prevents a class from being instantiated.
- Protected Attributes inherited from CXTPMarkupTransform

Detailed Description

Default ScaleTransform implementation.

Member Function Documentation

◆ ApplyTransform()

virtual CXTPMarkupTransformationMatrix * ApplyTransform ( const CXTPMarkupTransformationMatrix * pMatrix )
virtual

Does nothing in default implementation.

Parameters
pMatrix Pointer to a markup transformation matrix to be transformed.
Returns
NULL in default implementation.

Reimplemented from CXTPMarkupTransform.

◆ GetCenterX()

double GetCenterX ( ) const

Gets the center X value.

Returns
The center X value.

◆ GetCenterY()

double GetCenterY ( ) const

Gets the center Y value.

Returns
The center Y value.

◆ GetScaleX()

double GetScaleX ( ) const

Gets the scale X value.

Returns
The scale X value.

◆ GetScaleY()

double GetScaleY ( ) const

Gets the scale Y value.

Returns
The scale Y value.

◆ SetCenterX()

void SetCenterX ( double centerX )

Sets the center X value.

Parameters
centerX New center X value.

◆ SetCenterY()

void SetCenterY ( double centerY )

Sets the center Y value.

Parameters
centerY New center Y value.

◆ SetScaleX()

void SetScaleX ( double scaleX )

Sets the scale X value.

Parameters
scaleX New scale X value.

◆ SetScaleY()

void SetScaleY ( double scaleY )

Sets the scale Y value.

Parameters
scaleY New scale Y value.
The documentation for this class was generated from the following file:
  • XTPMarkupScaleTransform.h


Toolkit Pro: CXTPMarkupSkewTransform Class Reference

Public Member Functions | Static Public Attributes | List of all members
CXTPMarkupSkewTransform Class Reference

Default SkewTransform implementation. More...

Inheritance diagram for CXTPMarkupSkewTransform:
[legend]

Public Member Functions

double | GetAngleX () const
Gets the angle X value.
void | SetAngleX (double angleX)
Sets the angle X value.
double | GetAngleY () const
Gets the angle Y value.
void | SetAngleY (double angleY)
Sets the angle Y value.
double | GetCenterX () const
Gets the center X value.
void | SetCenterX (double centerX)
Sets the center X value.
double | GetCenterY () const
Gets the center Y value.
void | SetCenterY (double centerY)
Sets the center Y value.
virtual CXTPMarkupTransformationMatrix * | ApplyTransform (const CXTPMarkupTransformationMatrix *pMatrix)
Does nothing in default implementation.
- Public Member Functions inherited from CXTPMarkupTransform

Static Public Attributes

static CXTPMarkupDependencyProperty * | m_pPropertyAngleX
AngleX property.
static CXTPMarkupDependencyProperty * | m_pPropertyAngleY
AngleY property.
static CXTPMarkupDependencyProperty * | m_pPropertyCenterX
CenterX property.
static CXTPMarkupDependencyProperty * | m_pPropertyCenterY
CenterY property.

Additional Inherited Members

- Protected Member Functions inherited from CXTPMarkupTransform
CXTPMarkupTransform ()
Prevents a class from being instantiated.
- Protected Attributes inherited from CXTPMarkupTransform

Detailed Description

Default SkewTransform implementation.

Member Function Documentation

◆ ApplyTransform()

virtual CXTPMarkupTransformationMatrix * ApplyTransform ( const CXTPMarkupTransformationMatrix * pMatrix )
virtual

Does nothing in default implementation.

Parameters
pMatrix Pointer to a markup transformation matrix to be transformed.
Returns
NULL in default implementation.

Reimplemented from CXTPMarkupTransform.

◆ GetAngleX()

double GetAngleX ( ) const

Gets the angle X value.

Returns
The angle X value.

◆ GetAngleY()

double GetAngleY ( ) const

Gets the angle Y value.

Returns
The angle Y value.

◆ GetCenterX()

double GetCenterX ( ) const

Gets the center X value.

Returns
The center X value.

◆ GetCenterY()

double GetCenterY ( ) const

Gets the center Y value.

Returns
The center Y value.

◆ SetAngleX()

void SetAngleX ( double angleX )

Sets the angle X value.

Parameters
angleX New angle X value.

◆ SetAngleY()

void SetAngleY ( double angleY )

Sets the angle Y value.

Parameters
angleY New angle Y value.

◆ SetCenterX()

void SetCenterX ( double centerX )

Sets the center X value.

Parameters
centerX New center X value.

◆ SetCenterY()

void SetCenterY ( double centerY )

Sets the center Y value.

Parameters
centerY New center Y value.
The documentation for this class was generated from the following file:
  • XTPMarkupSkewTransform.h


Toolkit Pro: CXTPMarkupStackPanel Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPMarkupStackPanel Class Reference

CXTPMarkupStackPanel is a CXTPMarkupPanel derived class. More...

Inheritance diagram for CXTPMarkupStackPanel:
[legend]

Public Member Functions

void | SetOrientation (XTPMarkupOrientation orientation)
Sets the orientation of child elements inside StackPanel.
XTPMarkupOrientation | GetOrientation () const
Retrieves the current orientation of child elements inside StackPanel.
- Public Member Functions inherited from CXTPMarkupPanel
CXTPMarkupUIElementCollection * | GetChildren () const
Retrieves the collection of child elements.
void | SetBackground (CXTPMarkupBrush *pBrush)
Sets the background brush for the panel object.
CXTPMarkupBrush * | GetBackground () const
Gets the background brush of the panel object.
- Public Member Functions inherited from CXTPMarkupFrameworkElement
void | SetMargin (int nLeft, int nTop, int nRight, int nBottom)
Call this method to set the outer margin of an element.
void | SetMargin (int nMargin)
Call this method to set the outer margin of an element.
CXTPMarkupThickness * | GetMargin () const
Call this method to get the outer margin of an element.
void | SetMinWidth (int nWidth)
Sets the minimum width constraint for the element.
void | SetMaxWidth (int nWidth)
Sets the maximum width constraint for the element.
void | SetWidth (int nWidth)
Sets the width for the element.
void | SetMinHeight (int nHeight)
Sets the minimum height constraint for the element.
void | SetMaxHeight (int nHeight)
Sets the maximum height constraint for the element.
void | SetHeight (int nHeight)
Sets the height for the element.
int | GetMinWidth () const
Gets the minimum width constraint of the element.
int | GetMaxWidth () const
Gets the maximum width constraint of the element.
int | GetWidth () const
Gets the width of the element.
int | GetMinHeight () const
Gets the minimum height constraint of the element.
int | GetMaxHeight () const
Gets the maximum height constraint of the element.
int | GetHeight () const
Gets the height of the element.
CXTPMarkupObject * | GetTag () const
Gets the tag object of the element.
void | SetTag (CXTPMarkupObject *pTag)
Sets the tag object for the element.
void | SetHorizontalAlignment (XTPMarkupHorizontalAlignment alignment)
Sets the horizontal alignment characteristics applied to this element when it is composed within a parent element (e.g.
void | SetVerticalAlignment (XTPMarkupVerticalAlignment alignment)
Sets the vertical alignment characteristics applied to this element when it is composed within a parent element (e.g.
XTPMarkupHorizontalAlignment | GetHorizontalAlignment () const
Gets the horizontal alignment characteristics applied to this element when it is composed within a parent element (e.g.
XTPMarkupVerticalAlignment | GetVerticalAlignment () const
Gets the vertical alignment characteristics applied to this element when it is composed within a parent element (e.g.
CSize | GetActualSize () const
Retrieves the actual size of the element after it is measured and arranged within a parent element (e.g.
void | SetClipToBounds (BOOL bClipToBounds)
Specifies if child elements should be clipped inside element bounds.
BOOL | GetClipToBounds () const
Determines if child elements are clipped inside element bounds.
CXTPMarkupStyle * | GetStyle () const
Gets the attached style of the element.
- Public Member Functions inherited from CXTPMarkupUIElement
void | Arrange (CRect rcFinalRect)
Positions child elements and determines a size for a CXTPMarkupUIElement.
void | Measure (CXTPMarkupDrawingContext *pDC, CSize szAvailableSize)
Updates the DesiredSize of a CXTPMarkupUIElement.
CSize | GetDesiredSize () const
Gets the size that this element computed during the measure pass of the layout process.
CRect | GetFinalRect () const
Gets the final render size of this element.
XTPMarkupVisibility | GetVisibility () const
Gets the user interface (UI) visibility of this element.
void | SetVisibility (XTPMarkupVisibility visibility)
Sets the user interface (UI) visibility of this element.
BOOL | IsFocusable () const
Gets or sets a value indicating whether this element can receive focus.
virtual BOOL | IsVisible () const
Gets a value indicating whether this element is visible in the user interface (UI).
BOOL | IsEnabled () const
Gets or sets a value indicating whether this element is enabled in the user interface (UI).
virtual void | InvalidateArrange ()
Invalidates the arrange state (layout) for the element.
virtual void | InvalidateVisual ()
Invalidates the rendering of the element, and forces a new complete layout pass.
virtual void | InvalidateMeasure ()
Invalidates the measurement state (layout) for the element.
- Public Member Functions inherited from CXTPMarkupVisual
CXTPMarkupVisual ()
Provides the base initialization for objects derived from the CXTPMarkupVisual class.
virtual | ~CXTPMarkupVisual ()
Destroys a CXTPMarkupVisual object, handles cleanup and deallocation.
void | Render (CXTPMarkupDrawingContext *drawingContext)
Call this method to draw a Visual object inside a drawing context.
CXTPMarkupInputElement * | InputHitTest (CPoint point) const
Determines if a point belongs to this object.
virtual int | GetVisualChildrenCount () const
Gets the number of child elements for the Visual.
virtual CXTPMarkupVisual * | GetVisualChild (int nIndex) const
Retrieves the child Visual object located at a specified index within the parent VisualCollection.
virtual int | GetLogicalChildrenCount () const
Retrieves the number of logical child elements of this object.
virtual CXTPMarkupObject * | GetLogicalChild (int nIndex) const
Retrieves the logical child element located at a specified index within the parent collection.
CRect | GetBoundRect () const
Retrieves the bounding rectangle of the element.
CRect | GetUpdateRect () const
Computes the update rectangle.
CSize | GetRenderSize () const
Gets the final render size of this element.
CPoint | GetVisualOffset () const
Gets or sets the offset value of the visual object.
CXTPMarkupVisual * | GetVisualParent () const
Gets the Visual tree parent of the Visual object.

Protected Member Functions

CXTPMarkupStackPanel ()
Constructs a CXTPMarkupStackPanel object.
virtual | ~CXTPMarkupStackPanel ()
Destroys a CXTPMarkupStackPanel object, handles cleanup and deallocation.
- Protected Member Functions inherited from CXTPMarkupPanel
CXTPMarkupPanel ()
Constructs a CXTPMarkupPanel object.
virtual | ~CXTPMarkupPanel ()
Destroys a CXTPMarkupPanel object, handles cleanup and deallocation.
- Protected Member Functions inherited from CXTPMarkupFrameworkElement
CXTPMarkupFrameworkElement ()
Initializes a new instance of the CXTPMarkupFrameworkElement class.
virtual | ~CXTPMarkupFrameworkElement ()
Destroys a CXTPMarkupFrameworkElement object, handles cleanup and deallocation.
- Protected Member Functions inherited from CXTPMarkupUIElement
CXTPMarkupUIElement ()
Initializes a new instance of the CXTPMarkupUIElement class.
virtual | ~CXTPMarkupUIElement ()
Destroys a CXTPMarkupUIElement object, handles cleanup and deallocation.
CXTPMarkupRenderTransform * | GetRenderTransform () const
Obtains a pointer to the RenderTransform object.
virtual void | ArrangeCore (CRect rcFinalRect)
Defines the template for the core-level arrange layout definition.
virtual CSize | MeasureCore (CXTPMarkupDrawingContext *pDC, CSize szAvailableSize)
When overridden in a derived class, provides measurement logic for sizing this element properly with consideration of the size of any child element content.
virtual BOOL | GetLayoutClip (CRect &rc) const
Retrieves an alternative clipping geometry that represents the region that would be clipped if child elements were clipped inside element bounds.
virtual void | InvalidateMeasureOverride (CXTPMarkupDrawingContext *pDC)
Override this method to provide a custom reaction to an InvalidateMeasure call.
virtual TransformationMatrices | ApplyRenderTransform (CXTPMarkupDrawingContext *pContext)
Applies render transformation if necessary.
virtual void | RestoreRenderTransform (CXTPMarkupDrawingContext *pContext, TransformationMatrices &matrices)
Restores a previously applied render transformation.
virtual double | GetOpacity () const
Gets either the default or explicitly set opacity factor value.
- Protected Member Functions inherited from CXTPMarkupVisual
BOOL | PtInRectTransform (const RECT &rect, const POINT &point) const
Checks if a point is inside a rectangle with transformation applied.
POINT | GetAbsoluteVisualOffset () const
Gets the absolute element visual offset.
virtual void | OnRender (CXTPMarkupDrawingContext *drawingContext)
When overridden in a derived class, participates in rendering operations that are directed by the layout system.
virtual void | OnRenderFocusVisual (CXTPMarkupDrawingContext *drawingContext)
This method is called to render the focus rectangle of a focused object.
virtual CXTPMarkupInputElement * | InputHitTestOverride (CPoint point) const
Override this method in the derived class to provide visual hit testing of a child object.
virtual void | RenderClipped (CXTPMarkupDrawingContext *drawingContext)
Called by the framework when an element is clipped and no rendering will occur.

Additional Inherited Members

- Static Public Attributes inherited from CXTPMarkupUIElement
static CXTPMarkupDependencyProperty * | m_pClipToBoundsProperty
Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element.
static CXTPMarkupDependencyProperty * | m_pVisibilityProperty
A value indicating whether this element is visible in the user interface (UI).
static CXTPMarkupDependencyProperty * | m_pFocusableProperty
A value that indicates whether the element can receive focus.
static CXTPMarkupDependencyProperty * | m_pIsEnabledProperty
A value indicating whether thiselement is enabled in the user interface (UI).
static CXTPMarkupDependencyProperty * | m_pRenderTransformProperty
Gets or sets transform information that affects the rendering position of this element.
static CXTPMarkupDependencyProperty * | m_pRenderTransformOriginProperty
Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element.
static CXTPMarkupDependencyProperty * | m_pOpacityProperty
Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI).
- Protected Attributes inherited from CXTPMarkupUIElement
CSize | m_szDesiredSize
Gets the size that this element computed during the measure pass of the layout process.
CRect | m_rcFinalRect
Final position of the visual element.
BOOL | m_bMeasureDirty
TRUE if object hasn't recalculated its size.
BOOL | m_bNeverMeasured
TRUE if object has never ran Measure to update its size.
CSize | m_szPreviousAvailableSize
Previous available size of measure call.
BOOL | m_bArrangeDirty
TRUE if object position can be invalid.
BOOL | m_bNeverArranged
TRUE if Arrange was never called for this object.
BOOL | m_bArrangeInProgress
TRUE if Arrange is currently executed.
BOOL | m_bMeasureInProgress
TRUE if Measure is currently executed.
- Protected Attributes inherited from CXTPMarkupVisual
CPoint | m_ptVisualOffset
The offset value of the visual object.
CSize | m_szRenderSize
The rendered size for this element.
CRect | m_rcBoundRect
Bounding rectangle of the element.
CRect | m_rcUpdateRect
Update rectangle.
CRect | m_rcPrevUpdateRect
Previous update rectangle.

Detailed Description

CXTPMarkupStackPanel is a CXTPMarkupPanel derived class.

It implements the StackPanel XAML Tag.

Member Function Documentation

◆ GetOrientation()

XTPMarkupOrientation GetOrientation ( ) const

Retrieves the current orientation of child elements inside StackPanel.

Returns
An XTPMarkupOrientation enumeration value; xtpMarkupOrientationHorizontal if elements are positioned horizontally, xtpMarkupOrientationVertical if elements are positioned vertically.

◆ SetOrientation()

void SetOrientation ( XTPMarkupOrientation orientation )

Sets the orientation of child elements inside StackPanel.

Parameters
orientation An XTPMarkupOrientation enumeration value; xtpMarkupOrientationHorizontal to position elements horizontally, xtpMarkupOrientationVertical to position elements vertically.
The documentation for this class was generated from the following file:
  • XTPMarkupStackPanel.h


Toolkit Pro: CXTPMarkupStaticExtension Class Reference

Public Member Functions | Static Public Member Functions | Protected Member Functions | List of all members
CXTPMarkupStaticExtension Class Reference

A base class for a markup static extension composite object. More...

Inheritance diagram for CXTPMarkupStaticExtension:
[legend]

Public Member Functions

CXTPMarkupStaticExtension (LPCWSTR lpzName)
Constructs a composite CXTPMarkupStaticExtension instance.
virtual | ~CXTPMarkupStaticExtension ()
Destroys a CXTPMarkupStaticExtension object, handles cleanup and deallocation.
LPCWSTR | GetName () const
Gets the name of the current extension.
BOOL | IsProperty () const
Determines if the current extension is a property extension.
void | Extend (CXTPMarkupStaticExtension *pExtension, BOOL bReplace=FALSE)
Extends the current extension object with another sub-extension.
CXTPMarkupStaticExtension * | FindExtension (LPCWSTR lpzName) const
Tries to find an extension by its name or relative path.
virtual CXTPMarkupObject * | ProvideValue (LPCWSTR lpzValue)
Provides the value of a composite extension object.
virtual CXTPMarkupObject * | ProvideValue ()
Provides the value of a property extension object.

Static Public Member Functions

static BOOL AFX_CDECL Parse (LPCWSTR lpzValue, LPCWSTR &lpzSubValue)
Parses a static extension expression of form Name.Value[.Value[...]].

Protected Member Functions

CXTPMarkupStaticExtension (LPCWSTR lpzName, BOOL bProperty)
Constructs a composite or property CXTPMarkupStaticExtension instance.
virtual void OnPrepareValue ()
A derived implementation can override this method for preparing a property value.

Detailed Description

A base class for a markup static extension composite object.

Constructor & Destructor Documentation

◆ CXTPMarkupStaticExtension() [1/2]

CXTPMarkupStaticExtension | ( | LPCWSTR | lpzName,
 |  | BOOL | bProperty )
 protected

Constructs a composite or property CXTPMarkupStaticExtension instance.

Parameters
lpzName | Pointer to an extension name.
bProperty | TRUE if the object is a property object (i.e. it cannot be extended with other extensions and it provides a final value of an extension).

◆ CXTPMarkupStaticExtension() [2/2]

CXTPMarkupStaticExtension ( LPCWSTR lpzName )

Constructs a composite CXTPMarkupStaticExtension instance.

Parameters
lpzName Pointer to an extension name.

Member Function Documentation

◆ Extend()

void Extend | ( | CXTPMarkupStaticExtension * | pExtension,
 |  | BOOL | bReplace = FALSE )

Extends the current extension object with another sub-extension.

Parameters
pExtension | Pointer to a sub-extension object to be added to the current extension. The sub-extension object will be deallocated during parent extension destruction.
bReplace | TRUE to replace an existing extension. The default value is FALSE.

◆ FindExtension()

CXTPMarkupStaticExtension * FindExtension ( LPCWSTR lpzName ) const

Tries to find an extension by its name or relative path.

Parameters
lpzName Pointer to an extension name or relative path of form Name[.Name[...]].
Returns
A pointer to an extension if such an extension is found, otherwise NULL.

◆ GetName()

AFX_INLINE LPCWSTR GetName ( ) const

Gets the name of the current extension.

Returns
A reference to the name of the current extension.

◆ IsProperty()

AFX_INLINE BOOL IsProperty ( ) const

Determines if the current extension is a property extension.

Returns
TRUE if the current extension is a property extension.

◆ Parse()

static BOOL AFX_CDECL Parse | ( | LPCWSTR | lpzValue,
 |  | LPCWSTR & | lpzSubValue )
 static

Parses a static extension expression of form Name.Value[.Value[...]].

where both name and value has to be of form [a-zA-Z_]+.

Parameters
lpzValue | Entire static extension value.
lpzSubValue | On successful completion, contains a pointer to a sub-value of the extension object.
Returns
TRUE if parsed successfully.

◆ ProvideValue() [1/2]

virtual CXTPMarkupObject * ProvideValue ( )
virtual

Provides the value of a property extension object.

Returns
A pointer to a markup object that represents the value of the property extension object if successful, or NULL if no value is found. It is the responsibility of the caller to release the object.

Reimplemented in CXTPMarkupStaticExtensionProperty.

◆ ProvideValue() [2/2]

virtual CXTPMarkupObject * ProvideValue ( LPCWSTR lpzValue )
virtual

Provides the value of a composite extension object.

Parameters
lpzValue Composite extension value of form Value[.Value[...]].
Returns
A pointer to a markup object that represents the value of the composite extension object if successful, or NULL if no value is found. It is the responsibility of the caller to release the object.

Reimplemented in CXTPMarkupStaticExtensionProperty.

The documentation for this class was generated from the following file:
  • XTPMarkupStaticExtension.h


Toolkit Pro: CXTPMarkupStaticExtensionBooleanProperty Class Reference

Public Member Functions | List of all members
CXTPMarkupStaticExtensionBooleanProperty Class Reference

A convenience class that represents a boolean static extension property. More...

Inheritance diagram for CXTPMarkupStaticExtensionBooleanProperty:
[legend]

Public Member Functions

CXTPMarkupStaticExtensionBooleanProperty (LPCWSTR lpzName, BOOL bValue=FALSE)
Constructs a CXTPMarkupStaticExtensionBooleanProperty with an optional initial property value.
void | SetValue (BOOL bValue)
Sets the property value.
BOOL | GetRawValue () const
Gets the property value.
- Public Member Functions inherited from CXTPMarkupStaticExtensionProperty
CXTPMarkupStaticExtensionProperty (LPCWSTR lpzName, CXTPMarkupObject *pObject=NULL)
Constructs a CXTPMarkupStaticExtensionProperty with an optional initial property value.
~CXTPMarkupStaticExtensionProperty ()
Destroys a CXTPMarkupStaticExtensionProperty object, handles cleanup and deallocation.
CXTPMarkupObject * | GetValue ()
Obtains the property value.
void | SetValue (CXTPMarkupObject *pObject)
Sets the property value.
virtual CXTPMarkupObject * | ProvideValue ()
Provides the value of a property extension object.
virtual CXTPMarkupObject * | ProvideValue (LPCWSTR lpzValue)
Provides the value of a composite extension object.
- Public Member Functions inherited from CXTPMarkupStaticExtension
CXTPMarkupStaticExtension (LPCWSTR lpzName)
Constructs a composite CXTPMarkupStaticExtension instance.
virtual | ~CXTPMarkupStaticExtension ()
Destroys a CXTPMarkupStaticExtension object, handles cleanup and deallocation.
LPCWSTR | GetName () const
Gets the name of the current extension.
BOOL | IsProperty () const
Determines if the current extension is a property extension.
void | Extend (CXTPMarkupStaticExtension *pExtension, BOOL bReplace=FALSE)
Extends the current extension object with another sub-extension.
CXTPMarkupStaticExtension * | FindExtension (LPCWSTR lpzName) const
Tries to find an extension by its name or relative path.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPMarkupStaticExtension
static BOOL AFX_CDECL | Parse (LPCWSTR lpzValue, LPCWSTR &lpzSubValue)
Parses a static extension expression of form Name.Value[.Value[...]].
- Protected Member Functions inherited from CXTPMarkupStaticExtension
CXTPMarkupStaticExtension (LPCWSTR lpzName, BOOL bProperty)
Constructs a composite or property CXTPMarkupStaticExtension instance.
virtual void | OnPrepareValue ()
A derived implementation can override this method for preparing a property value.
- Protected Attributes inherited from CXTPMarkupStaticExtensionProperty

Detailed Description

A convenience class that represents a boolean static extension property.

Constructor & Destructor Documentation

◆ CXTPMarkupStaticExtensionBooleanProperty()

CXTPMarkupStaticExtensionBooleanProperty | ( | LPCWSTR | lpzName,
 |  | BOOL | bValue = FALSE )

Constructs a CXTPMarkupStaticExtensionBooleanProperty with an optional initial property value.

Parameters
lpzName | Static extension property name.
bValue | Optional initial property value.

Member Function Documentation

◆ GetRawValue()

BOOL GetRawValue ( ) const

Gets the property value.

Returns
The property value.

◆ SetValue()

void SetValue ( BOOL bValue )

Sets the property value.

Parameters
bValue New property value.
The documentation for this class was generated from the following file:
  • XTPMarkupStaticExtension.h


Toolkit Pro: CXTPMarkupStaticExtensionBrushProperty Class Reference

Public Member Functions | List of all members
CXTPMarkupStaticExtensionBrushProperty Class Reference

A convenience class that represents a brush static extension property. More...

Inheritance diagram for CXTPMarkupStaticExtensionBrushProperty:
[legend]

Public Member Functions

CXTPMarkupStaticExtensionBrushProperty (LPCWSTR lpzName, COLORREF crValue=RGB(0, 0, 0))
Constructs a CXTPMarkupStaticExtensionBrushProperty with an optional initial property value.
CXTPMarkupStaticExtensionBrushProperty (LPCWSTR lpzName, COLORREF crValue, BYTE bAlpha)
Constructs a CXTPMarkupStaticExtensionBrushProperty with an optional initial property value.
void | SetValue (COLORREF crValue)
Sets the property value.
void | SetValue (COLORREF crValue, BYTE bAlpha)
Sets the property value.
COLORREF | GetRawValue () const
Gets the property value.
- Public Member Functions inherited from CXTPMarkupStaticExtensionProperty
CXTPMarkupStaticExtensionProperty (LPCWSTR lpzName, CXTPMarkupObject *pObject=NULL)
Constructs a CXTPMarkupStaticExtensionProperty with an optional initial property value.
~CXTPMarkupStaticExtensionProperty ()
Destroys a CXTPMarkupStaticExtensionProperty object, handles cleanup and deallocation.
CXTPMarkupObject * | GetValue ()
Obtains the property value.
void | SetValue (CXTPMarkupObject *pObject)
Sets the property value.
virtual CXTPMarkupObject * | ProvideValue ()
Provides the value of a property extension object.
virtual CXTPMarkupObject * | ProvideValue (LPCWSTR lpzValue)
Provides the value of a composite extension object.
- Public Member Functions inherited from CXTPMarkupStaticExtension
CXTPMarkupStaticExtension (LPCWSTR lpzName)
Constructs a composite CXTPMarkupStaticExtension instance.
virtual | ~CXTPMarkupStaticExtension ()
Destroys a CXTPMarkupStaticExtension object, handles cleanup and deallocation.
LPCWSTR | GetName () const
Gets the name of the current extension.
BOOL | IsProperty () const
Determines if the current extension is a property extension.
void | Extend (CXTPMarkupStaticExtension *pExtension, BOOL bReplace=FALSE)
Extends the current extension object with another sub-extension.
CXTPMarkupStaticExtension * | FindExtension (LPCWSTR lpzName) const
Tries to find an extension by its name or relative path.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPMarkupStaticExtension
static BOOL AFX_CDECL | Parse (LPCWSTR lpzValue, LPCWSTR &lpzSubValue)
Parses a static extension expression of form Name.Value[.Value[...]].
- Protected Member Functions inherited from CXTPMarkupStaticExtension
CXTPMarkupStaticExtension (LPCWSTR lpzName, BOOL bProperty)
Constructs a composite or property CXTPMarkupStaticExtension instance.
virtual void | OnPrepareValue ()
A derived implementation can override this method for preparing a property value.
- Protected Attributes inherited from CXTPMarkupStaticExtensionProperty

Detailed Description

A convenience class that represents a brush static extension property.

Constructor & Destructor Documentation

◆ CXTPMarkupStaticExtensionBrushProperty() [1/2]

CXTPMarkupStaticExtensionBrushProperty | ( | LPCWSTR | lpzName,
 |  | COLORREF | crValue = RGB(0, 0, 0) )

Constructs a CXTPMarkupStaticExtensionBrushProperty with an optional initial property value.

Parameters
lpzName | Static extension property name.
crValue | Optional initial property value.

◆ CXTPMarkupStaticExtensionBrushProperty() [2/2]

CXTPMarkupStaticExtensionBrushProperty | ( | LPCWSTR | lpzName,
 |  | COLORREF | crValue,
 |  | BYTE | bAlpha )

Constructs a CXTPMarkupStaticExtensionBrushProperty with an optional initial property value.

Parameters
lpzName | Static extension property name.
crValue | Initial property color value.
bAlpha | Initial property color alpha-channel value.

Member Function Documentation

◆ GetRawValue()

COLORREF GetRawValue ( ) const

Gets the property value.

Returns
The property value.

◆ SetValue() [1/2]

void SetValue ( COLORREF crValue )

Sets the property value.

Parameters
crValue New property value.

◆ SetValue() [2/2]

void SetValue | ( | COLORREF | crValue,
 |  | BYTE | bAlpha )

Sets the property value.

Parameters
crValue | Initial property color value.
bAlpha | Initial property color alpha-channel value.
The documentation for this class was generated from the following file:
  • XTPMarkupStaticExtension.h


Toolkit Pro: CXTPMarkupStaticExtensionColorProperty Class Reference

Public Member Functions | List of all members
CXTPMarkupStaticExtensionColorProperty Class Reference

A convenience class that represents an RGB color static extension property. More...

Inheritance diagram for CXTPMarkupStaticExtensionColorProperty:
[legend]

Public Member Functions

CXTPMarkupStaticExtensionColorProperty (LPCWSTR lpzName, COLORREF crValue=RGB(0, 0, 0))
Constructs a CXTPMarkupStaticExtensionColorProperty with an optional initial property value.
CXTPMarkupStaticExtensionColorProperty (LPCWSTR lpzName, COLORREF crValue, BYTE bAlpha)
Constructs a CXTPMarkupStaticExtensionColorProperty with an optional initial property value.
void | SetValue (COLORREF crValue)
Sets the property value.
void | SetValue (COLORREF crValue, BYTE bAlpha)
Sets the property value.
COLORREF | GetRawValue () const
Gets the property value.
- Public Member Functions inherited from CXTPMarkupStaticExtensionProperty
CXTPMarkupStaticExtensionProperty (LPCWSTR lpzName, CXTPMarkupObject *pObject=NULL)
Constructs a CXTPMarkupStaticExtensionProperty with an optional initial property value.
~CXTPMarkupStaticExtensionProperty ()
Destroys a CXTPMarkupStaticExtensionProperty object, handles cleanup and deallocation.
CXTPMarkupObject * | GetValue ()
Obtains the property value.
void | SetValue (CXTPMarkupObject *pObject)
Sets the property value.
virtual CXTPMarkupObject * | ProvideValue ()
Provides the value of a property extension object.
virtual CXTPMarkupObject * | ProvideValue (LPCWSTR lpzValue)
Provides the value of a composite extension object.
- Public Member Functions inherited from CXTPMarkupStaticExtension
CXTPMarkupStaticExtension (LPCWSTR lpzName)
Constructs a composite CXTPMarkupStaticExtension instance.
virtual | ~CXTPMarkupStaticExtension ()
Destroys a CXTPMarkupStaticExtension object, handles cleanup and deallocation.
LPCWSTR | GetName () const
Gets the name of the current extension.
BOOL | IsProperty () const
Determines if the current extension is a property extension.
void | Extend (CXTPMarkupStaticExtension *pExtension, BOOL bReplace=FALSE)
Extends the current extension object with another sub-extension.
CXTPMarkupStaticExtension * | FindExtension (LPCWSTR lpzName) const
Tries to find an extension by its name or relative path.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPMarkupStaticExtension
static BOOL AFX_CDECL | Parse (LPCWSTR lpzValue, LPCWSTR &lpzSubValue)
Parses a static extension expression of form Name.Value[.Value[...]].
- Protected Member Functions inherited from CXTPMarkupStaticExtension
CXTPMarkupStaticExtension (LPCWSTR lpzName, BOOL bProperty)
Constructs a composite or property CXTPMarkupStaticExtension instance.
virtual void | OnPrepareValue ()
A derived implementation can override this method for preparing a property value.
- Protected Attributes inherited from CXTPMarkupStaticExtensionProperty

Detailed Description

A convenience class that represents an RGB color static extension property.

Constructor & Destructor Documentation

◆ CXTPMarkupStaticExtensionColorProperty() [1/2]

CXTPMarkupStaticExtensionColorProperty | ( | LPCWSTR | lpzName,
 |  | COLORREF | crValue = RGB(0, 0, 0) )

Constructs a CXTPMarkupStaticExtensionColorProperty with an optional initial property value.

Parameters
lpzName | Static extension property name.
crValue | Optional initial property value.

◆ CXTPMarkupStaticExtensionColorProperty() [2/2]

CXTPMarkupStaticExtensionColorProperty | ( | LPCWSTR | lpzName,
 |  | COLORREF | crValue,
 |  | BYTE | bAlpha )

Constructs a CXTPMarkupStaticExtensionColorProperty with an optional initial property value.

Parameters
lpzName | Static extension property name.
crValue | Initial property color value.
bAlpha | Initial property color alpha-channel value.

Member Function Documentation

◆ GetRawValue()

COLORREF GetRawValue ( ) const

Gets the property value.

Returns
The property value.

◆ SetValue() [1/2]

void SetValue ( COLORREF crValue )

Sets the property value.

Parameters
crValue New property value.

◆ SetValue() [2/2]

void SetValue | ( | COLORREF | crValue,
 |  | BYTE | bAlpha )

Sets the property value.

Parameters
crValue | Initial property color value.
bAlpha | Initial property color alpha-channel value.
The documentation for this class was generated from the following file:
  • XTPMarkupStaticExtension.h


Toolkit Pro: CXTPMarkupStaticExtensionDoubleProperty Class Reference

Public Member Functions | List of all members
CXTPMarkupStaticExtensionDoubleProperty Class Reference

A convenience class that represents a double static extension property. More...

Inheritance diagram for CXTPMarkupStaticExtensionDoubleProperty:
[legend]

Public Member Functions

CXTPMarkupStaticExtensionDoubleProperty (LPCWSTR lpzName, double dblValue=0)
Constructs a CXTPMarkupStaticExtensionDoubleProperty with an optional initial property value.
void | SetValue (double dblValue)
Sets the property value.
double | GetRawValue () const
Gets the property value.
- Public Member Functions inherited from CXTPMarkupStaticExtensionProperty
CXTPMarkupStaticExtensionProperty (LPCWSTR lpzName, CXTPMarkupObject *pObject=NULL)
Constructs a CXTPMarkupStaticExtensionProperty with an optional initial property value.
~CXTPMarkupStaticExtensionProperty ()
Destroys a CXTPMarkupStaticExtensionProperty object, handles cleanup and deallocation.
CXTPMarkupObject * | GetValue ()
Obtains the property value.
void | SetValue (CXTPMarkupObject *pObject)
Sets the property value.
virtual CXTPMarkupObject * | ProvideValue ()
Provides the value of a property extension object.
virtual CXTPMarkupObject * | ProvideValue (LPCWSTR lpzValue)
Provides the value of a composite extension object.
- Public Member Functions inherited from CXTPMarkupStaticExtension
CXTPMarkupStaticExtension (LPCWSTR lpzName)
Constructs a composite CXTPMarkupStaticExtension instance.
virtual | ~CXTPMarkupStaticExtension ()
Destroys a CXTPMarkupStaticExtension object, handles cleanup and deallocation.
LPCWSTR | GetName () const
Gets the name of the current extension.
BOOL | IsProperty () const
Determines if the current extension is a property extension.
void | Extend (CXTPMarkupStaticExtension *pExtension, BOOL bReplace=FALSE)
Extends the current extension object with another sub-extension.
CXTPMarkupStaticExtension * | FindExtension (LPCWSTR lpzName) const
Tries to find an extension by its name or relative path.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPMarkupStaticExtension
static BOOL AFX_CDECL | Parse (LPCWSTR lpzValue, LPCWSTR &lpzSubValue)
Parses a static extension expression of form Name.Value[.Value[...]].
- Protected Member Functions inherited from CXTPMarkupStaticExtension
CXTPMarkupStaticExtension (LPCWSTR lpzName, BOOL bProperty)
Constructs a composite or property CXTPMarkupStaticExtension instance.
virtual void | OnPrepareValue ()
A derived implementation can override this method for preparing a property value.
- Protected Attributes inherited from CXTPMarkupStaticExtensionProperty

Detailed Description

A convenience class that represents a double static extension property.

Constructor & Destructor Documentation

◆ CXTPMarkupStaticExtensionDoubleProperty()

CXTPMarkupStaticExtensionDoubleProperty | ( | LPCWSTR | lpzName,
 |  | double | dblValue = 0 )

Constructs a CXTPMarkupStaticExtensionDoubleProperty with an optional initial property value.

Parameters
lpzName | Static extension property name.
dblValue | Optional initial property value.

Member Function Documentation

◆ GetRawValue()

double GetRawValue ( ) const

Gets the property value.

Returns
The property value.

◆ SetValue()

void SetValue ( double dblValue )

Sets the property value.

Parameters
dblValue New property value.
The documentation for this class was generated from the following file:
  • XTPMarkupStaticExtension.h


Toolkit Pro: CXTPMarkupStaticExtensionIntegerProperty Class Reference

Public Member Functions | List of all members
CXTPMarkupStaticExtensionIntegerProperty Class Reference

A convenience class that represents an integer static extension property. More...

Inheritance diagram for CXTPMarkupStaticExtensionIntegerProperty:
[legend]

Public Member Functions

CXTPMarkupStaticExtensionIntegerProperty (LPCWSTR lpzName, int nValue=0)
Constructs a CXTPMarkupStaticExtensionIntegerProperty with an optional initial property value.
void | SetValue (int nValue)
Sets the property value.
int | GetRawValue () const
Gets the property value.
- Public Member Functions inherited from CXTPMarkupStaticExtensionProperty
CXTPMarkupStaticExtensionProperty (LPCWSTR lpzName, CXTPMarkupObject *pObject=NULL)
Constructs a CXTPMarkupStaticExtensionProperty with an optional initial property value.
~CXTPMarkupStaticExtensionProperty ()
Destroys a CXTPMarkupStaticExtensionProperty object, handles cleanup and deallocation.
CXTPMarkupObject * | GetValue ()
Obtains the property value.
void | SetValue (CXTPMarkupObject *pObject)
Sets the property value.
virtual CXTPMarkupObject * | ProvideValue ()
Provides the value of a property extension object.
virtual CXTPMarkupObject * | ProvideValue (LPCWSTR lpzValue)
Provides the value of a composite extension object.
- Public Member Functions inherited from CXTPMarkupStaticExtension
CXTPMarkupStaticExtension (LPCWSTR lpzName)
Constructs a composite CXTPMarkupStaticExtension instance.
virtual | ~CXTPMarkupStaticExtension ()
Destroys a CXTPMarkupStaticExtension object, handles cleanup and deallocation.
LPCWSTR | GetName () const
Gets the name of the current extension.
BOOL | IsProperty () const
Determines if the current extension is a property extension.
void | Extend (CXTPMarkupStaticExtension *pExtension, BOOL bReplace=FALSE)
Extends the current extension object with another sub-extension.
CXTPMarkupStaticExtension * | FindExtension (LPCWSTR lpzName) const
Tries to find an extension by its name or relative path.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPMarkupStaticExtension
static BOOL AFX_CDECL | Parse (LPCWSTR lpzValue, LPCWSTR &lpzSubValue)
Parses a static extension expression of form Name.Value[.Value[...]].
- Protected Member Functions inherited from CXTPMarkupStaticExtension
CXTPMarkupStaticExtension (LPCWSTR lpzName, BOOL bProperty)
Constructs a composite or property CXTPMarkupStaticExtension instance.
virtual void | OnPrepareValue ()
A derived implementation can override this method for preparing a property value.
- Protected Attributes inherited from CXTPMarkupStaticExtensionProperty

Detailed Description

A convenience class that represents an integer static extension property.

Constructor & Destructor Documentation

◆ CXTPMarkupStaticExtensionIntegerProperty()

CXTPMarkupStaticExtensionIntegerProperty | ( | LPCWSTR | lpzName,
 |  | int | nValue = 0 )

Constructs a CXTPMarkupStaticExtensionIntegerProperty with an optional initial property value.

Parameters
lpzName | Static extension property name.
nValue | Optional initial property value.

Member Function Documentation

◆ GetRawValue()

int GetRawValue ( ) const

Gets the property value.

Returns
The property value.

◆ SetValue()

void SetValue ( int nValue )

Sets the property value.

Parameters
nValue New property value.
The documentation for this class was generated from the following file:
  • XTPMarkupStaticExtension.h


Toolkit Pro: CXTPMarkupStaticExtensionProperty Class Reference

Public Member Functions | List of all members
CXTPMarkupStaticExtensionProperty Class Reference

A convenience base class for all static extension properties. More...

Inheritance diagram for CXTPMarkupStaticExtensionProperty:
[legend]

Public Member Functions

CXTPMarkupStaticExtensionProperty (LPCWSTR lpzName, CXTPMarkupObject *pObject=NULL)
Constructs a CXTPMarkupStaticExtensionProperty with an optional initial property value.
~CXTPMarkupStaticExtensionProperty ()
Destroys a CXTPMarkupStaticExtensionProperty object, handles cleanup and deallocation.
CXTPMarkupObject * | GetValue ()
Obtains the property value.
void | SetValue (CXTPMarkupObject *pObject)
Sets the property value.
virtual CXTPMarkupObject * | ProvideValue ()
Provides the value of a property extension object.
virtual CXTPMarkupObject * | ProvideValue (LPCWSTR lpzValue)
Provides the value of a composite extension object.
- Public Member Functions inherited from CXTPMarkupStaticExtension
CXTPMarkupStaticExtension (LPCWSTR lpzName)
Constructs a composite CXTPMarkupStaticExtension instance.
virtual | ~CXTPMarkupStaticExtension ()
Destroys a CXTPMarkupStaticExtension object, handles cleanup and deallocation.
LPCWSTR | GetName () const
Gets the name of the current extension.
BOOL | IsProperty () const
Determines if the current extension is a property extension.
void | Extend (CXTPMarkupStaticExtension *pExtension, BOOL bReplace=FALSE)
Extends the current extension object with another sub-extension.
CXTPMarkupStaticExtension * | FindExtension (LPCWSTR lpzName) const
Tries to find an extension by its name or relative path.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPMarkupStaticExtension
static BOOL AFX_CDECL | Parse (LPCWSTR lpzValue, LPCWSTR &lpzSubValue)
Parses a static extension expression of form Name.Value[.Value[...]].
- Protected Member Functions inherited from CXTPMarkupStaticExtension
CXTPMarkupStaticExtension (LPCWSTR lpzName, BOOL bProperty)
Constructs a composite or property CXTPMarkupStaticExtension instance.
virtual void | OnPrepareValue ()
A derived implementation can override this method for preparing a property value.

Detailed Description

A convenience base class for all static extension properties.

Constructor & Destructor Documentation

◆ CXTPMarkupStaticExtensionProperty()

CXTPMarkupStaticExtensionProperty | ( | LPCWSTR | lpzName,
 |  | CXTPMarkupObject * | pObject = NULL )

Constructs a CXTPMarkupStaticExtensionProperty with an optional initial property value.

Parameters
lpzName | Static extension property name.
pObject | Optional pointer to an initial property value. It is the responsibility of the class to release the value object instance.

Member Function Documentation

◆ GetValue()

AFX_INLINE CXTPMarkupObject * GetValue ( )

Obtains the property value.

Returns
A pointer to the property value or NULL if no value is assigned.

◆ ProvideValue() [1/2]

virtual CXTPMarkupObject * ProvideValue ( )
virtual

Provides the value of a property extension object.

Returns
A pointer to a markup object that represents the value of the property extension object if successful, or NULL if no value is found. It is the responsibility of the caller to release the object.

Reimplemented from CXTPMarkupStaticExtension.

◆ ProvideValue() [2/2]

virtual CXTPMarkupObject * ProvideValue ( LPCWSTR lpzValue )
virtual

Provides the value of a composite extension object.

Parameters
lpzValue Composite extension value of form Value[.Value[...]].
Returns
A pointer to a markup object that represents the value of the composite extension object if successful, or NULL if no value is found. It is the responsibility of the caller to release the object.

Reimplemented from CXTPMarkupStaticExtension.

◆ SetValue()

void SetValue ( CXTPMarkupObject * pObject )

Sets the property value.

Parameters
pObject Pointer to the property value or NULL. It is the responsibility of the class to release the value object instance.
The documentation for this class was generated from the following file:
  • XTPMarkupStaticExtension.h


Toolkit Pro: CXTPMarkupStaticExtensionStringProperty Class Reference

Public Member Functions | List of all members
CXTPMarkupStaticExtensionStringProperty Class Reference

A convenience class that represents a string static extension property. More...

Inheritance diagram for CXTPMarkupStaticExtensionStringProperty:
[legend]

Public Member Functions

CXTPMarkupStaticExtensionStringProperty (LPCWSTR lpzName, LPCWSTR lpzValue=NULL)
Constructs a CXTPMarkupStaticExtensionStringProperty with an optional initial property value.
CXTPMarkupStaticExtensionStringProperty (LPCWSTR lpzName, LPCSTR lpzValue=NULL)
Constructs a CXTPMarkupStaticExtensionStringProperty with an optional initial property value.
void | SetValue (LPCWSTR lpzValue)
Sets the property value.
void | SetValue (LPCSTR lpzValue)
Sets the property value.
LPCWSTR | GetRawValue () const
Obtains a pointer to a raw object value.
- Public Member Functions inherited from CXTPMarkupStaticExtensionProperty
CXTPMarkupStaticExtensionProperty (LPCWSTR lpzName, CXTPMarkupObject *pObject=NULL)
Constructs a CXTPMarkupStaticExtensionProperty with an optional initial property value.
~CXTPMarkupStaticExtensionProperty ()
Destroys a CXTPMarkupStaticExtensionProperty object, handles cleanup and deallocation.
CXTPMarkupObject * | GetValue ()
Obtains the property value.
void | SetValue (CXTPMarkupObject *pObject)
Sets the property value.
virtual CXTPMarkupObject * | ProvideValue ()
Provides the value of a property extension object.
virtual CXTPMarkupObject * | ProvideValue (LPCWSTR lpzValue)
Provides the value of a composite extension object.
- Public Member Functions inherited from CXTPMarkupStaticExtension
CXTPMarkupStaticExtension (LPCWSTR lpzName)
Constructs a composite CXTPMarkupStaticExtension instance.
virtual | ~CXTPMarkupStaticExtension ()
Destroys a CXTPMarkupStaticExtension object, handles cleanup and deallocation.
LPCWSTR | GetName () const
Gets the name of the current extension.
BOOL | IsProperty () const
Determines if the current extension is a property extension.
void | Extend (CXTPMarkupStaticExtension *pExtension, BOOL bReplace=FALSE)
Extends the current extension object with another sub-extension.
CXTPMarkupStaticExtension * | FindExtension (LPCWSTR lpzName) const
Tries to find an extension by its name or relative path.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPMarkupStaticExtension
static BOOL AFX_CDECL | Parse (LPCWSTR lpzValue, LPCWSTR &lpzSubValue)
Parses a static extension expression of form Name.Value[.Value[...]].
- Protected Member Functions inherited from CXTPMarkupStaticExtension
CXTPMarkupStaticExtension (LPCWSTR lpzName, BOOL bProperty)
Constructs a composite or property CXTPMarkupStaticExtension instance.
virtual void | OnPrepareValue ()
A derived implementation can override this method for preparing a property value.
- Protected Attributes inherited from CXTPMarkupStaticExtensionProperty

Detailed Description

A convenience class that represents a string static extension property.

Constructor & Destructor Documentation

◆ CXTPMarkupStaticExtensionStringProperty() [1/2]

CXTPMarkupStaticExtensionStringProperty | ( | LPCWSTR | lpzName,
 |  | LPCWSTR | lpzValue = NULL )

Constructs a CXTPMarkupStaticExtensionStringProperty with an optional initial property value.

Parameters
lpzName | Static extension property name.
lpzValue | Optional pointer to an initial property value.

◆ CXTPMarkupStaticExtensionStringProperty() [2/2]

CXTPMarkupStaticExtensionStringProperty | ( | LPCWSTR | lpzName,
 |  | LPCSTR | lpzValue = NULL )

Constructs a CXTPMarkupStaticExtensionStringProperty with an optional initial property value.

Parameters
lpzName | Static extension property name.
lpzValue | Optional pointer to an initial property value.

Member Function Documentation

◆ GetRawValue()

LPCWSTR GetRawValue ( ) const

Obtains a pointer to a raw object value.

Returns
A pointer to a raw object value, or NULL if no value is assigned.

◆ SetValue() [1/2]

void SetValue ( LPCSTR lpzValue )

Sets the property value.

Parameters
lpzValue Pointer to the property value or NULL. The string will be duplicated.

◆ SetValue() [2/2]

void SetValue ( LPCWSTR lpzValue )

Sets the property value.

Parameters
lpzValue Pointer to the property value or NULL. The string will be duplicated.
The documentation for this class was generated from the following file:
  • XTPMarkupStaticExtension.h


Toolkit Pro: CXTPMarkupSystemBrushKeyStaticExtension Class Reference

Public Member Functions | List of all members
CXTPMarkupSystemBrushKeyStaticExtension Class Reference

A property static extension object that represents a system brush key. More...

Inheritance diagram for CXTPMarkupSystemBrushKeyStaticExtension:
[legend]

Public Member Functions

CXTPMarkupSystemBrushKeyStaticExtension (LPCWSTR lpzName, int nColorIndex)
Constructs a system brush key extension object.
- Public Member Functions inherited from CXTPMarkupStaticExtensionProperty
CXTPMarkupStaticExtensionProperty (LPCWSTR lpzName, CXTPMarkupObject *pObject=NULL)
Constructs a CXTPMarkupStaticExtensionProperty with an optional initial property value.
~CXTPMarkupStaticExtensionProperty ()
Destroys a CXTPMarkupStaticExtensionProperty object, handles cleanup and deallocation.
CXTPMarkupObject * | GetValue ()
Obtains the property value.
void | SetValue (CXTPMarkupObject *pObject)
Sets the property value.
virtual CXTPMarkupObject * | ProvideValue ()
Provides the value of a property extension object.
virtual CXTPMarkupObject * | ProvideValue (LPCWSTR lpzValue)
Provides the value of a composite extension object.
- Public Member Functions inherited from CXTPMarkupStaticExtension
CXTPMarkupStaticExtension (LPCWSTR lpzName)
Constructs a composite CXTPMarkupStaticExtension instance.
virtual | ~CXTPMarkupStaticExtension ()
Destroys a CXTPMarkupStaticExtension object, handles cleanup and deallocation.
LPCWSTR | GetName () const
Gets the name of the current extension.
BOOL | IsProperty () const
Determines if the current extension is a property extension.
void | Extend (CXTPMarkupStaticExtension *pExtension, BOOL bReplace=FALSE)
Extends the current extension object with another sub-extension.
CXTPMarkupStaticExtension * | FindExtension (LPCWSTR lpzName) const
Tries to find an extension by its name or relative path.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPMarkupStaticExtension
static BOOL AFX_CDECL | Parse (LPCWSTR lpzValue, LPCWSTR &lpzSubValue)
Parses a static extension expression of form Name.Value[.Value[...]].
- Protected Member Functions inherited from CXTPMarkupStaticExtension
CXTPMarkupStaticExtension (LPCWSTR lpzName, BOOL bProperty)
Constructs a composite or property CXTPMarkupStaticExtension instance.
virtual void | OnPrepareValue ()
A derived implementation can override this method for preparing a property value.
- Protected Attributes inherited from CXTPMarkupStaticExtensionProperty

Detailed Description

A property static extension object that represents a system brush key.

Constructor & Destructor Documentation

◆ CXTPMarkupSystemBrushKeyStaticExtension()

CXTPMarkupSystemBrushKeyStaticExtension | ( | LPCWSTR | lpzName,
 |  | int | nColorIndex )

Constructs a system brush key extension object.

Parameters
lpzName | System brush name. Has to satisfy extension name rules.
nColorIndex | System color index. Refer to the GetSysColor Win32 API function documentation for possible values.
See also
CXTPMarkupStaticExtension::Parse
The documentation for this class was generated from the following file:
  • XTPMarkupSystemColorsStaticExtension.h


Toolkit Pro: CXTPMarkupSystemBrushStaticExtension Class Reference

Public Member Functions | Static Public Member Functions | List of all members
CXTPMarkupSystemBrushStaticExtension Class Reference

A property static extension object that represents a system brush. More...

Inheritance diagram for CXTPMarkupSystemBrushStaticExtension:
[legend]

Public Member Functions

CXTPMarkupSystemBrushStaticExtension (LPCWSTR lpzName, int nColorIndex)
Constructs a system brush extension object.
- Public Member Functions inherited from CXTPMarkupStaticExtensionProperty
CXTPMarkupStaticExtensionProperty (LPCWSTR lpzName, CXTPMarkupObject *pObject=NULL)
Constructs a CXTPMarkupStaticExtensionProperty with an optional initial property value.
~CXTPMarkupStaticExtensionProperty ()
Destroys a CXTPMarkupStaticExtensionProperty object, handles cleanup and deallocation.
CXTPMarkupObject * | GetValue ()
Obtains the property value.
void | SetValue (CXTPMarkupObject *pObject)
Sets the property value.
virtual CXTPMarkupObject * | ProvideValue ()
Provides the value of a property extension object.
virtual CXTPMarkupObject * | ProvideValue (LPCWSTR lpzValue)
Provides the value of a composite extension object.
- Public Member Functions inherited from CXTPMarkupStaticExtension
CXTPMarkupStaticExtension (LPCWSTR lpzName)
Constructs a composite CXTPMarkupStaticExtension instance.
virtual | ~CXTPMarkupStaticExtension ()
Destroys a CXTPMarkupStaticExtension object, handles cleanup and deallocation.
LPCWSTR | GetName () const
Gets the name of the current extension.
BOOL | IsProperty () const
Determines if the current extension is a property extension.
void | Extend (CXTPMarkupStaticExtension *pExtension, BOOL bReplace=FALSE)
Extends the current extension object with another sub-extension.
CXTPMarkupStaticExtension * | FindExtension (LPCWSTR lpzName) const
Tries to find an extension by its name or relative path.

Static Public Member Functions

static CXTPMarkupBrush *AFX_CDECL | GetSystemBrush (int nColorIndex)
Creates a system brush markup object.
- Static Public Member Functions inherited from CXTPMarkupStaticExtension
static BOOL AFX_CDECL | Parse (LPCWSTR lpzValue, LPCWSTR &lpzSubValue)
Parses a static extension expression of form Name.Value[.Value[...]].

Additional Inherited Members

- Protected Member Functions inherited from CXTPMarkupStaticExtension
CXTPMarkupStaticExtension (LPCWSTR lpzName, BOOL bProperty)
Constructs a composite or property CXTPMarkupStaticExtension instance.
virtual void OnPrepareValue ()
A derived implementation can override this method for preparing a property value.
- Protected Attributes inherited from CXTPMarkupStaticExtensionProperty

Detailed Description

A property static extension object that represents a system brush.

Constructor & Destructor Documentation

◆ CXTPMarkupSystemBrushStaticExtension()

CXTPMarkupSystemBrushStaticExtension | ( | LPCWSTR | lpzName,
 |  | int | nColorIndex )

Constructs a system brush extension object.

Parameters
lpzName | System brush name. Has to satisfy extension name rules.
nColorIndex | System color index. Refer to the GetSysColor Win32 API function documentation for possible values.
See also
CXTPMarkupStaticExtension::Parse

Member Function Documentation

◆ GetSystemBrush()

static CXTPMarkupBrush *AFX_CDECL GetSystemBrush ( int nColorIndex )
static

Creates a system brush markup object.

Parameters
nColorIndex System color index. Refer to the GetSysColor Win32 API function documentation for possible values.
Returns
A pointer to a CXTPMarkupBrush object. A caller is responsible for releasing an object.
The documentation for this class was generated from the following file:
  • XTPMarkupSystemColorsStaticExtension.h


Toolkit Pro: CXTPMarkupSystemColorKeyStaticExtension Class Reference

Public Member Functions | List of all members
CXTPMarkupSystemColorKeyStaticExtension Class Reference

A property static extension object that represents a system color key. More...

Inheritance diagram for CXTPMarkupSystemColorKeyStaticExtension:
[legend]

Public Member Functions

CXTPMarkupSystemColorKeyStaticExtension (LPCWSTR lpzName, int nColorIndex)
Constructs a system color key extension object.
- Public Member Functions inherited from CXTPMarkupStaticExtensionProperty
CXTPMarkupStaticExtensionProperty (LPCWSTR lpzName, CXTPMarkupObject *pObject=NULL)
Constructs a CXTPMarkupStaticExtensionProperty with an optional initial property value.
~CXTPMarkupStaticExtensionProperty ()
Destroys a CXTPMarkupStaticExtensionProperty object, handles cleanup and deallocation.
CXTPMarkupObject * | GetValue ()
Obtains the property value.
void | SetValue (CXTPMarkupObject *pObject)
Sets the property value.
virtual CXTPMarkupObject * | ProvideValue ()
Provides the value of a property extension object.
virtual CXTPMarkupObject * | ProvideValue (LPCWSTR lpzValue)
Provides the value of a composite extension object.
- Public Member Functions inherited from CXTPMarkupStaticExtension
CXTPMarkupStaticExtension (LPCWSTR lpzName)
Constructs a composite CXTPMarkupStaticExtension instance.
virtual | ~CXTPMarkupStaticExtension ()
Destroys a CXTPMarkupStaticExtension object, handles cleanup and deallocation.
LPCWSTR | GetName () const
Gets the name of the current extension.
BOOL | IsProperty () const
Determines if the current extension is a property extension.
void | Extend (CXTPMarkupStaticExtension *pExtension, BOOL bReplace=FALSE)
Extends the current extension object with another sub-extension.
CXTPMarkupStaticExtension * | FindExtension (LPCWSTR lpzName) const
Tries to find an extension by its name or relative path.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPMarkupStaticExtension
static BOOL AFX_CDECL | Parse (LPCWSTR lpzValue, LPCWSTR &lpzSubValue)
Parses a static extension expression of form Name.Value[.Value[...]].
- Protected Member Functions inherited from CXTPMarkupStaticExtension
CXTPMarkupStaticExtension (LPCWSTR lpzName, BOOL bProperty)
Constructs a composite or property CXTPMarkupStaticExtension instance.
virtual void | OnPrepareValue ()
A derived implementation can override this method for preparing a property value.
- Protected Attributes inherited from CXTPMarkupStaticExtensionProperty

Detailed Description

A property static extension object that represents a system color key.

Constructor & Destructor Documentation

◆ CXTPMarkupSystemColorKeyStaticExtension()

CXTPMarkupSystemColorKeyStaticExtension | ( | LPCWSTR | lpzName,
 |  | int | nColorIndex )

Constructs a system color key extension object.

Parameters
lpzName | System color name. Has to satisfy extension name rules.
nColorIndex | System color index. Refer to the GetSysColor Win32 API function documentation for possible values.
See also
CXTPMarkupStaticExtension::Parse
The documentation for this class was generated from the following file:
  • XTPMarkupSystemColorsStaticExtension.h


Toolkit Pro: CXTPMarkupSystemColorsStaticExtension Class Reference

Public Member Functions | List of all members
CXTPMarkupSystemColorsStaticExtension Class Reference

A composite static extension object that represents system colors. More...

Inheritance diagram for CXTPMarkupSystemColorsStaticExtension:
[legend]

Public Member Functions

CXTPMarkupSystemColorsStaticExtension ()
Constructs a CXTPMarkupSystemColorsStaticExtension object.
- Public Member Functions inherited from CXTPMarkupStaticExtension
CXTPMarkupStaticExtension (LPCWSTR lpzName)
Constructs a composite CXTPMarkupStaticExtension instance.
virtual | ~CXTPMarkupStaticExtension ()
Destroys a CXTPMarkupStaticExtension object, handles cleanup and deallocation.
LPCWSTR | GetName () const
Gets the name of the current extension.
BOOL | IsProperty () const
Determines if the current extension is a property extension.
void | Extend (CXTPMarkupStaticExtension *pExtension, BOOL bReplace=FALSE)
Extends the current extension object with another sub-extension.
CXTPMarkupStaticExtension * | FindExtension (LPCWSTR lpzName) const
Tries to find an extension by its name or relative path.
virtual CXTPMarkupObject * | ProvideValue (LPCWSTR lpzValue)
Provides the value of a composite extension object.
virtual CXTPMarkupObject * | ProvideValue ()
Provides the value of a property extension object.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPMarkupStaticExtension
static BOOL AFX_CDECL | Parse (LPCWSTR lpzValue, LPCWSTR &lpzSubValue)
Parses a static extension expression of form Name.Value[.Value[...]].
- Protected Member Functions inherited from CXTPMarkupStaticExtension
CXTPMarkupStaticExtension (LPCWSTR lpzName, BOOL bProperty)
Constructs a composite or property CXTPMarkupStaticExtension instance.
virtual void | OnPrepareValue ()
A derived implementation can override this method for preparing a property value.

Detailed Description

A composite static extension object that represents system colors.

The documentation for this class was generated from the following file:
  • XTPMarkupSystemColorsStaticExtension.h


Toolkit Pro: CXTPMarkupSystemColorStaticExtension Class Reference

Public Member Functions | Static Public Member Functions | List of all members
CXTPMarkupSystemColorStaticExtension Class Reference

A property static extension object that represents a system color. More...

Inheritance diagram for CXTPMarkupSystemColorStaticExtension:
[legend]

Public Member Functions

CXTPMarkupSystemColorStaticExtension (LPCWSTR lpzName, int nColorIndex)
Constructs a system color extension object.
- Public Member Functions inherited from CXTPMarkupStaticExtensionProperty
CXTPMarkupStaticExtensionProperty (LPCWSTR lpzName, CXTPMarkupObject *pObject=NULL)
Constructs a CXTPMarkupStaticExtensionProperty with an optional initial property value.
~CXTPMarkupStaticExtensionProperty ()
Destroys a CXTPMarkupStaticExtensionProperty object, handles cleanup and deallocation.
CXTPMarkupObject * | GetValue ()
Obtains the property value.
void | SetValue (CXTPMarkupObject *pObject)
Sets the property value.
virtual CXTPMarkupObject * | ProvideValue ()
Provides the value of a property extension object.
virtual CXTPMarkupObject * | ProvideValue (LPCWSTR lpzValue)
Provides the value of a composite extension object.
- Public Member Functions inherited from CXTPMarkupStaticExtension
CXTPMarkupStaticExtension (LPCWSTR lpzName)
Constructs a composite CXTPMarkupStaticExtension instance.
virtual | ~CXTPMarkupStaticExtension ()
Destroys a CXTPMarkupStaticExtension object, handles cleanup and deallocation.
LPCWSTR | GetName () const
Gets the name of the current extension.
BOOL | IsProperty () const
Determines if the current extension is a property extension.
void | Extend (CXTPMarkupStaticExtension *pExtension, BOOL bReplace=FALSE)
Extends the current extension object with another sub-extension.
CXTPMarkupStaticExtension * | FindExtension (LPCWSTR lpzName) const
Tries to find an extension by its name or relative path.

Static Public Member Functions

static CXTPMarkupColor *AFX_CDECL | GetSystemColor (int nColorIndex)
Creates a system color markup object.
- Static Public Member Functions inherited from CXTPMarkupStaticExtension
static BOOL AFX_CDECL | Parse (LPCWSTR lpzValue, LPCWSTR &lpzSubValue)
Parses a static extension expression of form Name.Value[.Value[...]].

Additional Inherited Members

- Protected Member Functions inherited from CXTPMarkupStaticExtension
CXTPMarkupStaticExtension (LPCWSTR lpzName, BOOL bProperty)
Constructs a composite or property CXTPMarkupStaticExtension instance.
virtual void OnPrepareValue ()
A derived implementation can override this method for preparing a property value.
- Protected Attributes inherited from CXTPMarkupStaticExtensionProperty

Detailed Description

A property static extension object that represents a system color.

Constructor & Destructor Documentation

◆ CXTPMarkupSystemColorStaticExtension()

CXTPMarkupSystemColorStaticExtension | ( | LPCWSTR | lpzName,
 |  | int | nColorIndex )

Constructs a system color extension object.

Parameters
lpzName | System color name. Has to satisfy extension name rules.
nColorIndex | System color index. Refer to the GetSysColor Win32 API function documentation for possible values.
See also
CXTPMarkupStaticExtension::Parse

Member Function Documentation

◆ GetSystemColor()

static CXTPMarkupColor *AFX_CDECL GetSystemColor ( int nColorIndex )
static

Creates a system color markup object.

Parameters
nColorIndex System color index. Refer to the GetSysColor Win32 API function documentation for possible values.
Returns
A pointer to a CXTPMarkupColor object. A caller is responsible for releasing an object.
The documentation for this class was generated from the following file:
  • XTPMarkupSystemColorsStaticExtension.h


Toolkit Pro: CXTPMarkupTextBlock Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPMarkupTextBlock Class Reference

CXTPMarkupTextBlock is a CXTPMarkupFrameworkElement derived class. More...

Inheritance diagram for CXTPMarkupTextBlock:
[legend]

Public Member Functions

void | SetText (LPCWSTR lpszText)
Sets the text for the TextBlock object.
CString | GetText () const
Gets the current text of the TextBlock object.
CXTPMarkupInlineCollection * | GetInlines () const
Gets a pointer to the CXTPMarkupInlineCollection object containing the TextBlock object's inline blocks.
void | SetBackground (CXTPMarkupBrush *pBrush)
Sets the background brush for the TextBlock object.
CXTPMarkupBrush * | GetBackground () const
Gets the background brush of the TextBlock object.
void | SetForeground (CXTPMarkupBrush *pBrush)
Sets the default text brush for the TextBlock object.
CXTPMarkupBrush * | GetForeground () const
Gets the default text brush of the TextBlock object.
void | SetTextAlignment (XTPMarkupTextAlignment alignment)
Sets the text alignment for the TextBlock object.
XTPMarkupTextAlignment | GetTextAlignment () const
Gets the text alignment of the TextBlock object.
void | SetTextWrapping (XTPMarkupTextWrapping nTextWrapping)
Sets the text wrapping type for the bounding rectangle (how text will be wrapped inside the bounding rectangle).
void | SetTextWrapping (BOOL bTextWrapping)
Sets the text wrapping type for the bounding rectangle (how text will be wrapped inside the bounding rectangle).
XTPMarkupTextWrapping | GetTextWrapping () const
Gets the text wrapping type of the bounding rectangle (how text is wrapped inside the bounding rectangle).
void | SetTextTrimming (XTPMarkupTextTrimming bTextTrimming)
Sets the text trimming style (how text will be trimmed when content overflows the content area).
XTPMarkupTextTrimming | GetTextTrimming () const
Gets the current text trimming style (how text is trimmed when content overflows the content area).
void | SetPadding (int nLeft, int nTop, int nRight, int nBottom)
Sets a value that indicates the thickness of the padding space between the boundaries of the content area and the content displayed by a TextBlock.
void | SetPadding (int nPadding)
Sets a value that indicates the thickness of the padding space between the boundaries of the content area and the content displayed by a TextBlock.
CXTPMarkupThickness * | GetPadding () const
Retrieves a value that indicates the thickness of the padding space between the boundaries of the content area and the content displayed by a TextBlock.
void | SetFontSize (int nFontSize)
Sets the font size for the TextBlock object.
int | GetFontSize () const
Gets the font size of the TextBlock object.
void | SetFontWeight (int nFontWeight)
Sets the font weight for the TextBlock object.
int | GetFontWeight () const
Gets the font weight of the TextBlock object.
void | SetFontFamily (LPCWSTR lpszFontFamily)
Sets the typeface name for the font.
LPCWSTR | GetFontFamily () const
Gets the typeface name of the font.
void | SetFontStyle (int nFontStyle)
Sets the font style for the TextBlock object.
int | GetFontStyle () const
Gets the font style of the TextBlock object.
void | SetTextDecorations (int nTextDecorations)
Sets the font text decoration for the TextBlock object.
int | GetTextDecorations () const
Gets the font text decoration of the TextBlock object.
- Public Member Functions inherited from CXTPMarkupFrameworkElement
void | SetMargin (int nLeft, int nTop, int nRight, int nBottom)
Call this method to set the outer margin of an element.
void | SetMargin (int nMargin)
Call this method to set the outer margin of an element.
CXTPMarkupThickness * | GetMargin () const
Call this method to get the outer margin of an element.
void | SetMinWidth (int nWidth)
Sets the minimum width constraint for the element.
void | SetMaxWidth (int nWidth)
Sets the maximum width constraint for the element.
void | SetWidth (int nWidth)
Sets the width for the element.
void | SetMinHeight (int nHeight)
Sets the minimum height constraint for the element.
void | SetMaxHeight (int nHeight)
Sets the maximum height constraint for the element.
void | SetHeight (int nHeight)
Sets the height for the element.
int | GetMinWidth () const
Gets the minimum width constraint of the element.
int | GetMaxWidth () const
Gets the maximum width constraint of the element.
int | GetWidth () const
Gets the width of the element.
int | GetMinHeight () const
Gets the minimum height constraint of the element.
int | GetMaxHeight () const
Gets the maximum height constraint of the element.
int | GetHeight () const
Gets the height of the element.
CXTPMarkupObject * | GetTag () const
Gets the tag object of the element.
void | SetTag (CXTPMarkupObject *pTag)
Sets the tag object for the element.
void | SetHorizontalAlignment (XTPMarkupHorizontalAlignment alignment)
Sets the horizontal alignment characteristics applied to this element when it is composed within a parent element (e.g.
void | SetVerticalAlignment (XTPMarkupVerticalAlignment alignment)
Sets the vertical alignment characteristics applied to this element when it is composed within a parent element (e.g.
XTPMarkupHorizontalAlignment | GetHorizontalAlignment () const
Gets the horizontal alignment characteristics applied to this element when it is composed within a parent element (e.g.
XTPMarkupVerticalAlignment | GetVerticalAlignment () const
Gets the vertical alignment characteristics applied to this element when it is composed within a parent element (e.g.
CSize | GetActualSize () const
Retrieves the actual size of the element after it is measured and arranged within a parent element (e.g.
void | SetClipToBounds (BOOL bClipToBounds)
Specifies if child elements should be clipped inside element bounds.
BOOL | GetClipToBounds () const
Determines if child elements are clipped inside element bounds.
CXTPMarkupStyle * | GetStyle () const
Gets the attached style of the element.
- Public Member Functions inherited from CXTPMarkupUIElement
void | Arrange (CRect rcFinalRect)
Positions child elements and determines a size for a CXTPMarkupUIElement.
void | Measure (CXTPMarkupDrawingContext *pDC, CSize szAvailableSize)
Updates the DesiredSize of a CXTPMarkupUIElement.
CSize | GetDesiredSize () const
Gets the size that this element computed during the measure pass of the layout process.
CRect | GetFinalRect () const
Gets the final render size of this element.
XTPMarkupVisibility | GetVisibility () const
Gets the user interface (UI) visibility of this element.
void | SetVisibility (XTPMarkupVisibility visibility)
Sets the user interface (UI) visibility of this element.
BOOL | IsFocusable () const
Gets or sets a value indicating whether this element can receive focus.
virtual BOOL | IsVisible () const
Gets a value indicating whether this element is visible in the user interface (UI).
BOOL | IsEnabled () const
Gets or sets a value indicating whether this element is enabled in the user interface (UI).
virtual void | InvalidateArrange ()
Invalidates the arrange state (layout) for the element.
virtual void | InvalidateVisual ()
Invalidates the rendering of the element, and forces a new complete layout pass.
virtual void | InvalidateMeasure ()
Invalidates the measurement state (layout) for the element.
- Public Member Functions inherited from CXTPMarkupVisual
CXTPMarkupVisual ()
Provides the base initialization for objects derived from the CXTPMarkupVisual class.
virtual | ~CXTPMarkupVisual ()
Destroys a CXTPMarkupVisual object, handles cleanup and deallocation.
void | Render (CXTPMarkupDrawingContext *drawingContext)
Call this method to draw a Visual object inside a drawing context.
CXTPMarkupInputElement * | InputHitTest (CPoint point) const
Determines if a point belongs to this object.
virtual int | GetVisualChildrenCount () const
Gets the number of child elements for the Visual.
virtual CXTPMarkupVisual * | GetVisualChild (int nIndex) const
Retrieves the child Visual object located at a specified index within the parent VisualCollection.
virtual int | GetLogicalChildrenCount () const
Retrieves the number of logical child elements of this object.
virtual CXTPMarkupObject * | GetLogicalChild (int nIndex) const
Retrieves the logical child element located at a specified index within the parent collection.
CRect | GetBoundRect () const
Retrieves the bounding rectangle of the element.
CRect | GetUpdateRect () const
Computes the update rectangle.
CSize | GetRenderSize () const
Gets the final render size of this element.
CPoint | GetVisualOffset () const
Gets or sets the offset value of the visual object.
CXTPMarkupVisual * | GetVisualParent () const
Gets the Visual tree parent of the Visual object.

Protected Member Functions

CXTPMarkupTextBlock ()
Constructs a CXTPMarkupTextBlock object.
virtual | ~CXTPMarkupTextBlock ()
Destroys a CXTPMarkupTextBlock object, handles cleanup and deallocation.
- Protected Member Functions inherited from CXTPMarkupFrameworkElement
CXTPMarkupFrameworkElement ()
Initializes a new instance of the CXTPMarkupFrameworkElement class.
virtual | ~CXTPMarkupFrameworkElement ()
Destroys a CXTPMarkupFrameworkElement object, handles cleanup and deallocation.
- Protected Member Functions inherited from CXTPMarkupUIElement
CXTPMarkupUIElement ()
Initializes a new instance of the CXTPMarkupUIElement class.
virtual | ~CXTPMarkupUIElement ()
Destroys a CXTPMarkupUIElement object, handles cleanup and deallocation.
CXTPMarkupRenderTransform * | GetRenderTransform () const
Obtains a pointer to the RenderTransform object.
virtual void | ArrangeCore (CRect rcFinalRect)
Defines the template for the core-level arrange layout definition.
virtual CSize | MeasureCore (CXTPMarkupDrawingContext *pDC, CSize szAvailableSize)
When overridden in a derived class, provides measurement logic for sizing this element properly with consideration of the size of any child element content.
virtual BOOL | GetLayoutClip (CRect &rc) const
Retrieves an alternative clipping geometry that represents the region that would be clipped if child elements were clipped inside element bounds.
virtual void | InvalidateMeasureOverride (CXTPMarkupDrawingContext *pDC)
Override this method to provide a custom reaction to an InvalidateMeasure call.
virtual TransformationMatrices | ApplyRenderTransform (CXTPMarkupDrawingContext *pContext)
Applies render transformation if necessary.
virtual void | RestoreRenderTransform (CXTPMarkupDrawingContext *pContext, TransformationMatrices &matrices)
Restores a previously applied render transformation.
virtual double | GetOpacity () const
Gets either the default or explicitly set opacity factor value.
- Protected Member Functions inherited from CXTPMarkupVisual
BOOL | PtInRectTransform (const RECT &rect, const POINT &point) const
Checks if a point is inside a rectangle with transformation applied.
POINT | GetAbsoluteVisualOffset () const
Gets the absolute element visual offset.
virtual void | OnRender (CXTPMarkupDrawingContext *drawingContext)
When overridden in a derived class, participates in rendering operations that are directed by the layout system.
virtual void | OnRenderFocusVisual (CXTPMarkupDrawingContext *drawingContext)
This method is called to render the focus rectangle of a focused object.
virtual CXTPMarkupInputElement * | InputHitTestOverride (CPoint point) const
Override this method in the derived class to provide visual hit testing of a child object.
virtual void | RenderClipped (CXTPMarkupDrawingContext *drawingContext)
Called by the framework when an element is clipped and no rendering will occur.

Protected Attributes

CXTPMarkupInlineCollection * | m_pInlines
Inline collection of TextBlock.
- Protected Attributes inherited from CXTPMarkupUIElement
CSize | m_szDesiredSize
Gets the size that this element computed during the measure pass of the layout process.
CRect | m_rcFinalRect
Final position of the visual element.
BOOL | m_bMeasureDirty
TRUE if object hasn't recalculated its size.
BOOL | m_bNeverMeasured
TRUE if object has never ran Measure to update its size.
CSize | m_szPreviousAvailableSize
Previous available size of measure call.
BOOL | m_bArrangeDirty
TRUE if object position can be invalid.
BOOL | m_bNeverArranged
TRUE if Arrange was never called for this object.
BOOL | m_bArrangeInProgress
TRUE if Arrange is currently executed.
BOOL | m_bMeasureInProgress
TRUE if Measure is currently executed.
- Protected Attributes inherited from CXTPMarkupVisual
CPoint | m_ptVisualOffset
The offset value of the visual object.
CSize | m_szRenderSize
The rendered size for this element.
CRect | m_rcBoundRect
Bounding rectangle of the element.
CRect | m_rcUpdateRect
Update rectangle.
CRect | m_rcPrevUpdateRect
Previous update rectangle.

Additional Inherited Members

- Static Public Attributes inherited from CXTPMarkupUIElement
static CXTPMarkupDependencyProperty * | m_pClipToBoundsProperty
Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element.
static CXTPMarkupDependencyProperty * | m_pVisibilityProperty
A value indicating whether this element is visible in the user interface (UI).
static CXTPMarkupDependencyProperty * | m_pFocusableProperty
A value that indicates whether the element can receive focus.
static CXTPMarkupDependencyProperty * | m_pIsEnabledProperty
A value indicating whether thiselement is enabled in the user interface (UI).
static CXTPMarkupDependencyProperty * | m_pRenderTransformProperty
Gets or sets transform information that affects the rendering position of this element.
static CXTPMarkupDependencyProperty * | m_pRenderTransformOriginProperty
Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element.
static CXTPMarkupDependencyProperty * | m_pOpacityProperty
Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI).

Detailed Description

CXTPMarkupTextBlock is a CXTPMarkupFrameworkElement derived class.

It implements the TextBlock XAML Tag.

Member Function Documentation

◆ GetBackground()

CXTPMarkupBrush * GetBackground ( ) const

Gets the background brush of the TextBlock object.

Returns
A pointer to the background brush of the TextBlock object.

◆ GetFontFamily()

LPCWSTR GetFontFamily ( ) const

Gets the typeface name of the font.

Returns
The typeface name of the font if it was set, otherwise NULL.

◆ GetFontSize()

int GetFontSize ( ) const

Gets the font size of the TextBlock object.

Returns
The font size of the TextBlock object if it was set.

◆ GetFontStyle()

int GetFontStyle ( ) const

Gets the font style of the TextBlock object.

Returns
The font style of the TextBlock object if it was set.

◆ GetFontWeight()

int GetFontWeight ( ) const

Gets the font weight of the TextBlock object.

Returns
The font weight of the TextBlock object if it was set.

◆ GetForeground()

CXTPMarkupBrush * GetForeground ( ) const

Gets the default text brush of the TextBlock object.

Returns
A pointer to the default text brush of the TextBlock object.

◆ GetInlines()

AFX_INLINE CXTPMarkupInlineCollection * GetInlines ( ) const

Gets a pointer to the CXTPMarkupInlineCollection object containing the TextBlock object's inline blocks.

Returns
A pointer to the CXTPMarkupInlineCollection object containing the TextBlock object's inline blocks.

◆ GetPadding()

CXTPMarkupThickness * GetPadding ( ) const

Retrieves a value that indicates the thickness of the padding space between the boundaries of the content area and the content displayed by a TextBlock.

Returns
A pointer to a CXTPMarkupThickness object that indicates the thickness of the padding space between the boundaries of the content area and the content displayed by a TextBlock.
See also
SetPadding

◆ GetText()

CString GetText ( ) const

Gets the current text of the TextBlock object.

Returns
A CString object containing the current text of the TextBlock object.

◆ GetTextAlignment()

XTPMarkupTextAlignment GetTextAlignment ( ) const

Gets the text alignment of the TextBlock object.

Returns
The text alignment of the TextBlock object; returns one of the values defined by the XTPMarkupTextAlignment enumeration.
See also
XTPMarkupTextAlignment, SetTextAlignment

◆ GetTextDecorations()

int GetTextDecorations ( ) const

Gets the font text decoration of the TextBlock object.

Returns
The font text decoration of the TextBlock object if it was set.

◆ GetTextTrimming()

XTPMarkupTextTrimming GetTextTrimming ( ) const

Gets the current text trimming style (how text is trimmed when content overflows the content area).

Returns
The current text trimming style; returns one of the values defined by the XTPMarkupTextTrimming enumeration.

◆ GetTextWrapping()

XTPMarkupTextWrapping GetTextWrapping ( ) const

Gets the text wrapping type of the bounding rectangle (how text is wrapped inside the bounding rectangle).

Returns
The text wrapping type; returns one of the values defined by the XTPMarkupTextWrapping enumeration.
See also
XTPMarkupTextWrapping, SetTextWrapping

◆ SetBackground()

void SetBackground ( CXTPMarkupBrush * pBrush )

Sets the background brush for the TextBlock object.

Parameters
pBrush Pointer to a CBrush object.

◆ SetFontFamily()

void SetFontFamily ( LPCWSTR lpszFontFamily )

Sets the typeface name for the font.

Parameters
lpszFontFamily New typeface name to be set.

◆ SetFontSize()

void SetFontSize ( int nFontSize )

Sets the font size for the TextBlock object.

Parameters
nFontSize New font size to be set.

◆ SetFontStyle()

void SetFontStyle ( int nFontStyle )

Sets the font style for the TextBlock object.

Parameters
nFontStyle New font style to be set.

Italic (nFontStyle = 1) and Normal (FontStyle = 0) are supported.

◆ SetFontWeight()

void SetFontWeight ( int nFontWeight )

Sets the font weight for the TextBlock object.

Parameters
nFontWeight New font weight to be set.

◆ SetForeground()

void SetForeground ( CXTPMarkupBrush * pBrush )

Sets the default text brush for the TextBlock object.

Parameters
pBrush Pointer to a CBrush object.

◆ SetPadding() [1/2]

void SetPadding | ( | int | nLeft,
 |  | int | nTop,
 |  | int | nRight,
 |  | int | nBottom )

Sets a value that indicates the thickness of the padding space between the boundaries of the content area and the content displayed by a TextBlock.

Parameters
nLeft | Left space.
nTop | Top space.
nRight | Right space.
nBottom | Bottom space.

◆ SetPadding() [2/2]

void SetPadding ( int nPadding )

Sets a value that indicates the thickness of the padding space between the boundaries of the content area and the content displayed by a TextBlock.

Parameters
nPadding All borders.

◆ SetText()

void SetText ( LPCWSTR lpszText )

Sets the text for the TextBlock object.

Parameters
lpszText New text to be set.

◆ SetTextAlignment()

void SetTextAlignment ( XTPMarkupTextAlignment alignment )

Sets the text alignment for the TextBlock object.

Parameters
alignment New alignment to be set; must be one of the values defined by the XTPMarkupTextAlignment enumeration.
See also
XTPMarkupTextAlignment, GetTextAlignment

◆ SetTextDecorations()

void SetTextDecorations ( int nTextDecorations )

Sets the font text decoration for the TextBlock object.

Parameters
nTextDecorations New font text decoration to be set.

Underline (1) and Strikethrough(2) are supported.

◆ SetTextTrimming()

void SetTextTrimming ( XTPMarkupTextTrimming bTextTrimming )

Sets the text trimming style (how text will be trimmed when content overflows the content area).

Parameters
bTextTrimming New text trimming style to be set; must be one of the values defined by the XTPMarkupTextTrimming enumeration.

The TextTrimming property has no effect unless the TextWrapping property is set to NoWrap.

◆ SetTextWrapping() [1/2]

void SetTextWrapping ( BOOL bTextWrapping )

Sets the text wrapping type for the bounding rectangle (how text will be wrapped inside the bounding rectangle).

Parameters
bTextWrapping TRUE for text wrapping.
See also
XTPMarkupTextWrapping, SetTextWrapping

◆ SetTextWrapping() [2/2]

void SetTextWrapping ( XTPMarkupTextWrapping nTextWrapping )

Sets the text wrapping type for the bounding rectangle (how text will be wrapped inside the bounding rectangle).

Parameters
nTextWrapping New text wrapping type to be set; must be one of the values defined by the XTPMarkupTextWrapping enumeration.
See also
XTPMarkupTextWrapping, SetTextWrapping
The documentation for this class was generated from the following file:
  • XTPMarkupTextBlock.h


Toolkit Pro: CXTPMarkupThemePart Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPMarkupThemePart Class Reference

The CXTPMarkupThemePart class is used to create a theme part object used for rendering. More...

Public Member Functions

CXTPMarkupThemePart ()
Constructs a CXTPMarkupThemePart object.
virtual | ~CXTPMarkupThemePart ()
Destructor, handles cleanup and deallocation.
BOOL | LoadPart (HZIP hZip, LPCTSTR pszFileName, CXTPMarkupContext *pMarkupContext)
This member function is ca.led to load the theme part.
void | RenderMarkup (CDC *pDC, CRect rc)
This member function is called to render the markup theme part.
CSize | Measure (int cx, int cy)
Called to determine a theme part's size.

Protected Attributes

CXTPMarkupUIElement * m_pMarkupUIElement
Points to a CXTPMarkupUIElement object.

Detailed Description

The CXTPMarkupThemePart class is used to create a theme part object used for rendering.

Member Function Documentation

◆ LoadPart()

BOOL LoadPart | ( | HZIP | hZip,
 |  | LPCTSTR | pszFileName,
 |  | CXTPMarkupContext * | pMarkupContext )

This member function is ca.led to load the theme part.

Parameters
hZip | Zip file handle.
pszFileName | String representing file name.
pMarkupContext | Points to a CXTPMarkupContext object.
Returns
TRUE if successful, otherwise FALSE.

◆ Measure()

CSize Measure | ( | int | cx,
 |  | int | cy )

Called to determine a theme part's size.

Parameters
cx | Theme part width.
cy | Theme part height.
Returns
A CSize object representing the theme part's width and height.

◆ RenderMarkup()

void RenderMarkup | ( | CDC * | pDC,
 |  | CRect | rc )

This member function is called to render the markup theme part.

Parameters
pDC | Points to a valid device context.
rc | Size of area to render.
The documentation for this class was generated from the following file:
  • XTPMarkupTheme.h


Toolkit Pro: CXTPMarkupThickness Class Reference

Public Member Functions | List of all members
CXTPMarkupThickness Class Reference

The CXTPMarkupThickness class describes the thickness of the left, top, right, and bottom sides of a rectangle. More...

Public Member Functions

CXTPMarkupThickness ()
Constructs a CXTPMarkupThickness object and sets the left, top, right, and bottom thickness to 0.
CXTPMarkupThickness (const CXTPMarkupThickness &other)
Constructs a CXTPMarkupThickness object and sets the left, top, right, and bottom thickness.
CXTPMarkupThickness (long nThickness)
Constructs a CXTPMarkupThickness object and sets the left, top, right, and bottom thickness.
CXTPMarkupThickness (long nXThickness, long nYThickness)
Constructs a CXTPMarkupThickness object and sets the left/right and top/bottom thickness.
CXTPMarkupThickness (long nLeft, long nTop, long nRight, long nBottom)
Constructs a CXTPMarkupThickness object and sets the left, top, right, and bottom thickness.
long | GetLeft () const
Gets the left thickness.
void | SetLeft (long nThickness)
Sets the left thickness.
long | GetTop () const
Gets the top thickness.
long | GetRight () const
Gets the right thickness.
long | GetBottom () const
Gets the bottom thickness.

Detailed Description

The CXTPMarkupThickness class describes the thickness of the left, top, right, and bottom sides of a rectangle.

Constructor & Destructor Documentation

◆ CXTPMarkupThickness() [1/4]

CXTPMarkupThickness ( const CXTPMarkupThickness & other )

Constructs a CXTPMarkupThickness object and sets the left, top, right, and bottom thickness.

Parameters
other The left, top, right, and bottom thickness.

◆ CXTPMarkupThickness() [2/4]

CXTPMarkupThickness ( long nThickness )

Constructs a CXTPMarkupThickness object and sets the left, top, right, and bottom thickness.

Parameters
nThickness The left, top, right, and bottom thickness.

◆ CXTPMarkupThickness() [3/4]

CXTPMarkupThickness | ( | long | nXThickness,
 |  | long | nYThickness )

Constructs a CXTPMarkupThickness object and sets the left/right and top/bottom thickness.

Parameters
nXThickness | The left and right thickness.
nYThickness | The top and bottom thickness.

◆ CXTPMarkupThickness() [4/4]

CXTPMarkupThickness | ( | long | nLeft,
 |  | long | nTop,
 |  | long | nRight,
 |  | long | nBottom )

Constructs a CXTPMarkupThickness object and sets the left, top, right, and bottom thickness.

Parameters
nLeft | The left thickness.
nTop | The top thickness.
nRight | The right thickness.
nBottom | The bottom thickness.

Member Function Documentation

◆ GetBottom()

AFX_INLINE long GetBottom ( ) const

Gets the bottom thickness.

Returns
The bottom thickness.

◆ GetLeft()

AFX_INLINE long GetLeft ( ) const

Gets the left thickness.

Returns
The left thickness.

◆ GetRight()

AFX_INLINE long GetRight ( ) const

Gets the right thickness.

Returns
The right thickness.

◆ GetTop()

AFX_INLINE long GetTop ( ) const

Gets the top thickness.

Returns
The top thickness.

◆ SetLeft()

void SetLeft ( long nThickness )

Sets the left thickness.

Parameters
nThickness New left thickness.
The documentation for this class was generated from the following file:
  • XTPMarkupThickness.h


Toolkit Pro: CXTPMarkupToggleButton Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPMarkupToggleButton Class Reference

CXTPMarkupToggleButton is a CXTPMarkupButtonBase derived class. More...

Inheritance diagram for CXTPMarkupToggleButton:
[legend]

Public Member Functions

void | SetChecked (BOOL bChecked)
Call this method to set the checked state for a button.
BOOL | GetChecked () const
Determines the checked state of a button.
void | SetThreeState (BOOL bThreeState)
Specifies if the button supports two or three states.
BOOL | IsThreeState () const
Determines if the button supports two or three states.
- Public Member Functions inherited from CXTPMarkupButtonBase
BOOL | IsPressed () const
Determines if the button is currently pressed.
- Public Member Functions inherited from CXTPMarkupContentControl
CXTPMarkupUIElement * | GetContent () const
Gets the child object of the ControlContent element.
void | SetContent (CXTPMarkupUIElement *pContent)
Sets the child object for the ControlContent element.
- Public Member Functions inherited from CXTPMarkupControl
void | SetPadding (int nLeft, int nTop, int nRight, int nBottom)
Sets a value that indicates the thickness of the padding space between the boundaries of the content area and the content displayed by a control.
void | SetPadding (int nPadding)
Sets a value that indicates the thickness of the padding space between the boundaries of the content area and the content displayed by a control.
CXTPMarkupThickness * | GetPadding () const
Retrieves a value that indicates the thickness of the padding space between the boundaries of the content area and the content displayed by a control.
void | SetBackground (CXTPMarkupBrush *pBrush)
Sets the background brush for the control object.
CXTPMarkupBrush * | GetBackground () const
Gets the background brush of the control object.
void | SetForeground (CXTPMarkupBrush *pBrush)
Sets the default text brush for the control object.
CXTPMarkupBrush * | GetForeground () const
Gets the default text brush of the control object.
- Public Member Functions inherited from CXTPMarkupFrameworkElement
void | SetMargin (int nLeft, int nTop, int nRight, int nBottom)
Call this method to set the outer margin of an element.
void | SetMargin (int nMargin)
Call this method to set the outer margin of an element.
CXTPMarkupThickness * | GetMargin () const
Call this method to get the outer margin of an element.
void | SetMinWidth (int nWidth)
Sets the minimum width constraint for the element.
void | SetMaxWidth (int nWidth)
Sets the maximum width constraint for the element.
void | SetWidth (int nWidth)
Sets the width for the element.
void | SetMinHeight (int nHeight)
Sets the minimum height constraint for the element.
void | SetMaxHeight (int nHeight)
Sets the maximum height constraint for the element.
void | SetHeight (int nHeight)
Sets the height for the element.
int | GetMinWidth () const
Gets the minimum width constraint of the element.
int | GetMaxWidth () const
Gets the maximum width constraint of the element.
int | GetWidth () const
Gets the width of the element.
int | GetMinHeight () const
Gets the minimum height constraint of the element.
int | GetMaxHeight () const
Gets the maximum height constraint of the element.
int | GetHeight () const
Gets the height of the element.
CXTPMarkupObject * | GetTag () const
Gets the tag object of the element.
void | SetTag (CXTPMarkupObject *pTag)
Sets the tag object for the element.
void | SetHorizontalAlignment (XTPMarkupHorizontalAlignment alignment)
Sets the horizontal alignment characteristics applied to this element when it is composed within a parent element (e.g.
void | SetVerticalAlignment (XTPMarkupVerticalAlignment alignment)
Sets the vertical alignment characteristics applied to this element when it is composed within a parent element (e.g.
XTPMarkupHorizontalAlignment | GetHorizontalAlignment () const
Gets the horizontal alignment characteristics applied to this element when it is composed within a parent element (e.g.
XTPMarkupVerticalAlignment | GetVerticalAlignment () const
Gets the vertical alignment characteristics applied to this element when it is composed within a parent element (e.g.
CSize | GetActualSize () const
Retrieves the actual size of the element after it is measured and arranged within a parent element (e.g.
void | SetClipToBounds (BOOL bClipToBounds)
Specifies if child elements should be clipped inside element bounds.
BOOL | GetClipToBounds () const
Determines if child elements are clipped inside element bounds.
CXTPMarkupStyle * | GetStyle () const
Gets the attached style of the element.
- Public Member Functions inherited from CXTPMarkupUIElement
void | Arrange (CRect rcFinalRect)
Positions child elements and determines a size for a CXTPMarkupUIElement.
void | Measure (CXTPMarkupDrawingContext *pDC, CSize szAvailableSize)
Updates the DesiredSize of a CXTPMarkupUIElement.
CSize | GetDesiredSize () const
Gets the size that this element computed during the measure pass of the layout process.
CRect | GetFinalRect () const
Gets the final render size of this element.
XTPMarkupVisibility | GetVisibility () const
Gets the user interface (UI) visibility of this element.
void | SetVisibility (XTPMarkupVisibility visibility)
Sets the user interface (UI) visibility of this element.
BOOL | IsFocusable () const
Gets or sets a value indicating whether this element can receive focus.
virtual BOOL | IsVisible () const
Gets a value indicating whether this element is visible in the user interface (UI).
BOOL | IsEnabled () const
Gets or sets a value indicating whether this element is enabled in the user interface (UI).
virtual void | InvalidateArrange ()
Invalidates the arrange state (layout) for the element.
virtual void | InvalidateVisual ()
Invalidates the rendering of the element, and forces a new complete layout pass.
virtual void | InvalidateMeasure ()
Invalidates the measurement state (layout) for the element.
- Public Member Functions inherited from CXTPMarkupVisual
CXTPMarkupVisual ()
Provides the base initialization for objects derived from the CXTPMarkupVisual class.
virtual | ~CXTPMarkupVisual ()
Destroys a CXTPMarkupVisual object, handles cleanup and deallocation.
void | Render (CXTPMarkupDrawingContext *drawingContext)
Call this method to draw a Visual object inside a drawing context.
CXTPMarkupInputElement * | InputHitTest (CPoint point) const
Determines if a point belongs to this object.
virtual int | GetVisualChildrenCount () const
Gets the number of child elements for the Visual.
virtual CXTPMarkupVisual * | GetVisualChild (int nIndex) const
Retrieves the child Visual object located at a specified index within the parent VisualCollection.
virtual int | GetLogicalChildrenCount () const
Retrieves the number of logical child elements of this object.
virtual CXTPMarkupObject * | GetLogicalChild (int nIndex) const
Retrieves the logical child element located at a specified index within the parent collection.
CRect | GetBoundRect () const
Retrieves the bounding rectangle of the element.
CRect | GetUpdateRect () const
Computes the update rectangle.
CSize | GetRenderSize () const
Gets the final render size of this element.
CPoint | GetVisualOffset () const
Gets or sets the offset value of the visual object.
CXTPMarkupVisual * | GetVisualParent () const
Gets the Visual tree parent of the Visual object.

Protected Member Functions

virtual void | OnClick ()
Virtual method called when the user clicks the button.
virtual void | OnToggle ()
Virtual method called when the state is toggled by the user.
virtual void | OnChecked (CXTPMarkupRoutedEventArgs *e)
Virtual method called when the user sets the state to checked.
virtual void | OnUnchecked (CXTPMarkupRoutedEventArgs *e)
Virtual method called when the user sets the state to unchecked.
virtual void | OnIndeterminate (CXTPMarkupRoutedEventArgs *e)
Virtual method called when the user sets the state to indeterminate.
- Protected Member Functions inherited from CXTPMarkupButtonBase
CXTPMarkupButtonBase ()
Constructs a CXTPMarkupButtonBase object.
~CXTPMarkupButtonBase ()
Destroys a CXTPMarkupButtonBase object, handles cleanup and deallocation.
- Protected Member Functions inherited from CXTPMarkupContentControl
CXTPMarkupContentControl ()
Constructs a CXTPMarkupContentControl object.
virtual | ~CXTPMarkupContentControl ()
Destroys a CXTPMarkupContentControl object, handles cleanup and deallocation.
- Protected Member Functions inherited from CXTPMarkupFrameworkElement
CXTPMarkupFrameworkElement ()
Initializes a new instance of the CXTPMarkupFrameworkElement class.
virtual | ~CXTPMarkupFrameworkElement ()
Destroys a CXTPMarkupFrameworkElement object, handles cleanup and deallocation.
- Protected Member Functions inherited from CXTPMarkupUIElement
CXTPMarkupUIElement ()
Initializes a new instance of the CXTPMarkupUIElement class.
virtual | ~CXTPMarkupUIElement ()
Destroys a CXTPMarkupUIElement object, handles cleanup and deallocation.
CXTPMarkupRenderTransform * | GetRenderTransform () const
Obtains a pointer to the RenderTransform object.
virtual void | ArrangeCore (CRect rcFinalRect)
Defines the template for the core-level arrange layout definition.
virtual CSize | MeasureCore (CXTPMarkupDrawingContext *pDC, CSize szAvailableSize)
When overridden in a derived class, provides measurement logic for sizing this element properly with consideration of the size of any child element content.
virtual BOOL | GetLayoutClip (CRect &rc) const
Retrieves an alternative clipping geometry that represents the region that would be clipped if child elements were clipped inside element bounds.
virtual void | InvalidateMeasureOverride (CXTPMarkupDrawingContext *pDC)
Override this method to provide a custom reaction to an InvalidateMeasure call.
virtual TransformationMatrices | ApplyRenderTransform (CXTPMarkupDrawingContext *pContext)
Applies render transformation if necessary.
virtual void | RestoreRenderTransform (CXTPMarkupDrawingContext *pContext, TransformationMatrices &matrices)
Restores a previously applied render transformation.
virtual double | GetOpacity () const
Gets either the default or explicitly set opacity factor value.
- Protected Member Functions inherited from CXTPMarkupVisual
BOOL | PtInRectTransform (const RECT &rect, const POINT &point) const
Checks if a point is inside a rectangle with transformation applied.
POINT | GetAbsoluteVisualOffset () const
Gets the absolute element visual offset.
virtual void | OnRender (CXTPMarkupDrawingContext *drawingContext)
When overridden in a derived class, participates in rendering operations that are directed by the layout system.
virtual void | OnRenderFocusVisual (CXTPMarkupDrawingContext *drawingContext)
This method is called to render the focus rectangle of a focused object.
virtual CXTPMarkupInputElement * | InputHitTestOverride (CPoint point) const
Override this method in the derived class to provide visual hit testing of a child object.
virtual void | RenderClipped (CXTPMarkupDrawingContext *drawingContext)
Called by the framework when an element is clipped and no rendering will occur.

Additional Inherited Members

- Static Public Attributes inherited from CXTPMarkupUIElement
static CXTPMarkupDependencyProperty * | m_pClipToBoundsProperty
Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element.
static CXTPMarkupDependencyProperty * | m_pVisibilityProperty
A value indicating whether this element is visible in the user interface (UI).
static CXTPMarkupDependencyProperty * | m_pFocusableProperty
A value that indicates whether the element can receive focus.
static CXTPMarkupDependencyProperty * | m_pIsEnabledProperty
A value indicating whether thiselement is enabled in the user interface (UI).
static CXTPMarkupDependencyProperty * | m_pRenderTransformProperty
Gets or sets transform information that affects the rendering position of this element.
static CXTPMarkupDependencyProperty * | m_pRenderTransformOriginProperty
Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element.
static CXTPMarkupDependencyProperty * | m_pOpacityProperty
Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI).
- Protected Attributes inherited from CXTPMarkupUIElement
CSize | m_szDesiredSize
Gets the size that this element computed during the measure pass of the layout process.
CRect | m_rcFinalRect
Final position of the visual element.
BOOL | m_bMeasureDirty
TRUE if object hasn't recalculated its size.
BOOL | m_bNeverMeasured
TRUE if object has never ran Measure to update its size.
CSize | m_szPreviousAvailableSize
Previous available size of measure call.
BOOL | m_bArrangeDirty
TRUE if object position can be invalid.
BOOL | m_bNeverArranged
TRUE if Arrange was never called for this object.
BOOL | m_bArrangeInProgress
TRUE if Arrange is currently executed.
BOOL | m_bMeasureInProgress
TRUE if Measure is currently executed.
- Protected Attributes inherited from CXTPMarkupVisual
CPoint | m_ptVisualOffset
The offset value of the visual object.
CSize | m_szRenderSize
The rendered size for this element.
CRect | m_rcBoundRect
Bounding rectangle of the element.
CRect | m_rcUpdateRect
Update rectangle.
CRect | m_rcPrevUpdateRect
Previous update rectangle.

Detailed Description

CXTPMarkupToggleButton is a CXTPMarkupButtonBase derived class.

It implements a base class for Radio and CheckBox buttons.

Member Function Documentation

◆ GetChecked()

BOOL GetChecked ( ) const

Determines the checked state of a button.

Returns
TRUE if the button is checked, otherwise FALSE.

◆ IsThreeState()

BOOL IsThreeState ( ) const

Determines if the button supports two or three states.

Returns
TRUE if the button supports three states (Checked, Normal, and Indeterminate).

◆ OnChecked()

virtual void OnChecked ( CXTPMarkupRoutedEventArgs * e )
protectedvirtual

Virtual method called when the user sets the state to checked.

Parameters
e Mouse pointer information.

◆ OnIndeterminate()

virtual void OnIndeterminate ( CXTPMarkupRoutedEventArgs * e )
protectedvirtual

Virtual method called when the user sets the state to indeterminate.

Parameters
e Mouse pointer information.

◆ OnUnchecked()

virtual void OnUnchecked ( CXTPMarkupRoutedEventArgs * e )
protectedvirtual

Virtual method called when the user sets the state to unchecked.

Parameters
e Mouse pointer information.

◆ SetChecked()

void SetChecked ( BOOL bChecked )

Call this method to set the checked state for a button.

Parameters
bChecked TRUE to set the button to checked, FALSE otherwise.

◆ SetThreeState()

void SetThreeState ( BOOL bThreeState )

Specifies if the button supports two or three states.

Parameters
bThreeState TRUE to set the button to support three states (Checked, Normal, and Indeterminate).
The documentation for this class was generated from the following file:
  • XTPMarkupToggleButton.h


Toolkit Pro: CXTPMarkupTransform Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPMarkupTransform Class Reference

Base class for all markup transformation objects. More...

Inheritance diagram for CXTPMarkupTransform:
[legend]

Public Member Functions

virtual CXTPMarkupTransformationMatrix * ApplyTransform (const CXTPMarkupTransformationMatrix *pMatrix)
Applies abstract transformation on a markup transformation matrix.

Protected Member Functions

CXTPMarkupTransform ()
Prevents a class from being instantiated.

Detailed Description

Base class for all markup transformation objects.

Member Function Documentation

◆ ApplyTransform()

virtual CXTPMarkupTransformationMatrix * ApplyTransform ( const CXTPMarkupTransformationMatrix * pMatrix )
virtual

Applies abstract transformation on a markup transformation matrix.

Parameters
pMatrix Pointer to a markup transformation matrix to be transformed.
Returns
A pointer to the transformed markup matrix if successful, NULL if failed or not supported. It is the responsibility of the callee to delete the returned object.

Reimplemented in CXTPMarkupMatrixTransform, CXTPMarkupRotateTransform, CXTPMarkupScaleTransform, CXTPMarkupSkewTransform, and CXTPMarkupTranslateTransform.

The documentation for this class was generated from the following file:
  • XTPMarkupTransform.h


Toolkit Pro: CXTPMarkupTransformationMatrix Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPMarkupTransformationMatrix Class Referenceabstract

An abstract class for device context transformation matrix. More...

Inheritance diagram for CXTPMarkupTransformationMatrix:
[legend]

Public Member Functions

virtual | ~CXTPMarkupTransformationMatrix ()
Destroys a CXTPMarkupTransformationMatrix object, handles cleanup and deallocation.
virtual CXTPMarkupTransformationMatrix * | Clone () const =0
Clones a matrix object.
virtual void | Offset (const POINT &offset)
Adds offset to the current matrix.
virtual BOOL | PtInRect (const RECT &rect, const POINT &absoluteOffset, const POINT &point) const
Checks if a point is inside a rectangle with transformation applied.
virtual CRect | GetBoundRect (const RECT &rect, const POINT &absoluteOffset) const
Computes the bounding rectangle after transformation.

Protected Member Functions

CXTPMarkupTransformationMatrix ()
Constructs a CXTPMarkupTransformationMatrix object.

Detailed Description

An abstract class for device context transformation matrix.

Member Function Documentation

◆ Clone()

virtual CXTPMarkupTransformationMatrix * Clone ( ) const
pure virtual

Clones a matrix object.

Returns
A pointer to the cloned matrix. It is the responsibility of the caller to delete the returned object.

Implemented in CXTPMarkupGdiPlusTransformationMatrix.

◆ GetBoundRect()

virtual CRect GetBoundRect | ( | const RECT & | rect,
 |  | const POINT & | absoluteOffset ) const
 virtual

Computes the bounding rectangle after transformation.

Parameters
rect | Rectangle in relative coordinates to transform.
absoluteOffset | Absolute offset of the rectangle.
Returns
A CRect object containing the bounding rectangle after transformation.

Reimplemented in CXTPMarkupGdiPlusTransformationMatrix.

◆ Offset()

virtual void Offset ( const POINT & offset )
virtual

Adds offset to the current matrix.

Parameters
offset Offset to add.

Reimplemented in CXTPMarkupGdiPlusTransformationMatrix.

◆ PtInRect()

virtual BOOL PtInRect | ( | const RECT & | rect,
 |  | const POINT & | absoluteOffset,
 |  | const POINT & | point ) const
 virtual

Checks if a point is inside a rectangle with transformation applied.

Parameters
rect | Rectangle in relative coordinates to test in.
absoluteOffset | Absolute offset of the rectangle.
point | Absolute point to test.
Returns
TRUE if the point hits the specified rectangle.

Reimplemented in CXTPMarkupGdiPlusTransformationMatrix.

The documentation for this class was generated from the following file:
  • XTPMarkupTransformationMatrix.h


Toolkit Pro: CXTPMarkupTranslateTransform Class Reference

Public Member Functions | Static Public Attributes | List of all members
CXTPMarkupTranslateTransform Class Reference

Default TranslateTransform implementation. More...

Inheritance diagram for CXTPMarkupTranslateTransform:
[legend]

Public Member Functions

double | GetX () const
Gets the X value.
void | SetX (double x)
Sets the X value.
double | GetY () const
Gets the Y value.
void | SetY (double y)
Sets the Y value.
virtual CXTPMarkupTransformationMatrix * | ApplyTransform (const CXTPMarkupTransformationMatrix *pMatrix)
Does nothing in default implementation.
- Public Member Functions inherited from CXTPMarkupTransform

Static Public Attributes

static CXTPMarkupDependencyProperty * | m_pPropertyX
X property.
static CXTPMarkupDependencyProperty * | m_pPropertyY
Y property.

Additional Inherited Members

- Protected Member Functions inherited from CXTPMarkupTransform
CXTPMarkupTransform ()
Prevents a class from being instantiated.
- Protected Attributes inherited from CXTPMarkupTransform

Detailed Description

Default TranslateTransform implementation.

Member Function Documentation

◆ ApplyTransform()

virtual CXTPMarkupTransformationMatrix * ApplyTransform ( const CXTPMarkupTransformationMatrix * pMatrix )
virtual

Does nothing in default implementation.

Parameters
pMatrix Pointer to a markup transformation matrix to be transformed.
Returns
NULL in default implementation.

Reimplemented from CXTPMarkupTransform.

◆ GetX()

double GetX ( ) const

Gets the X value.

Returns
The X value.

◆ GetY()

double GetY ( ) const

Gets the Y value.

Returns
The Y value.

◆ SetX()

void SetX ( double x )

Sets the X value.

Parameters
x New X value.

◆ SetY()

void SetY ( double y )

Sets the Y value.

Parameters
y New Y value.
The documentation for this class was generated from the following file:
  • XTPMarkupTranslateTransform.h


Toolkit Pro: CXTPMarkupTreeCtrl Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPMarkupTreeCtrl Class Reference

Tree control class that allows for adding markup items. More...

Inheritance diagram for CXTPMarkupTreeCtrl:
[legend]

Public Member Functions

CXTPMarkupTreeCtrl ()
Constructs a markup tree control.
virtual | ~CXTPMarkupTreeCtrl ()
Handles markup tree control deallocation.
CXTPMarkupContext * GetMarkupContext ()
Obtains the markup context associated with the markup tree.
HTREEITEM | AddItem (LPCTSTR lpszItem, int nImage, int nSelectedImage, HTREEITEM hParent=TVI_ROOT, HTREEITEM hInsertAfter=TVI_LAST)
Adds a new markup item.
- Public Member Functions inherited from CXTPTreeCtrl
CXTPTreeCtrl ()
Constructs a CXTPTreeCtrl object.
virtual | ~CXTPTreeCtrl ()
Destroys a CXTPTreeCtrl object, handles cleanup and deallocation.
- Public Member Functions inherited from CXTPMarkupContext
CXTPMarkupContext ()
Constructs a CXTPMarkupContext object.
IXTPMarkupClientSite * | GetClientSite () const
Gets a client site pointer.
void | SetClientSite (IXTPMarkupClientSite *pSite)
Sets a client site pointer.
void | Shutdown ()
Performs internal cleanup necessary for the final release.
LOGFONT * | GetDefaultLogFont ()
Gets the default font properties of markup objects.
COLORREF | GetDefaultForeground ()
Gets the default text color of TextBlock objects.
void | SetDefaultTextColor (COLORREF clr)
Sets the default text color for TextBlock objects.
void | SetDefaultFont (HFONT font)
Sets the default font for TextBlock objects.
void | SetDefaultFont (LOGFONT *font)
Sets the default font for TextBlock objects.
XTPMarkupSmoothingMode | GetDefaultSmoothingMode () const
Gets the default smoothing mode to be used for any drawing context that uses the context.
XTPMarkupSmoothingMode | SetDefaultSmoothingMode (XTPMarkupSmoothingMode smoothingMode)
Sets the default smoothing mode to be used for any drawing context that uses the context.
BOOL | GetDefaultTextSmoothing () const
Determines/specifies if text smoothing is enabled for any drawing context that uses the context.
BOOL | SetDefaultTextSmoothing (BOOL bEnableTextSmoothing)
Determines/specifies if text smoothing is enabled for any drawing context that uses the context.
CXTPMarkupUIElement * | Parse (LPCSTR lpszBuffer)
Creates a Markup tree from its XML string.
CXTPMarkupUIElement * | Parse (LPCWSTR lpszBuffer)
Creates a Markup tree from its XML string.
CString | ValidateXML (LPCSTR lpszBuffer)
Validates XML correctness.
CString | ValidateXML (LPCWSTR lpszBuffer)
Validates XML correctness.
void | AddHandler (CXTPMarkupRoutedEvent *pEvent, CXTPMarkupDelegate *pDelegate)
Connects a Markup event with a class member or static method delegate.
void | SetDelegate (LPCWSTR lpszDelegate, CXTPMarkupDelegate *pDelegate)
Sets a delegate for a Markup text event.
void | EnableGdiPlus (BOOL bEnable)
Enables/disables GDI+ usage.
BOOL | IsGdiPlusEnabled () const
Determines if GDI+ is enabled/disabled.
CXTPToolTipContext * | GetToolTipContext () const
Call this method to get a pointer to the tooltip context.
BOOL | GetUseCustomToolTipPosition () const
Determines if custom positioning for tooltips is enabled/disabled.
void | SetUseCustomToolTipPosition (BOOL bUse, CPoint ptPos=CPoint(0, 0))
Enables/disables custom positioning for tooltips.
CPoint | GetCustomToolTipPosition () const
Gets the custom x- and y- coordinates of the tooltip window.
void | SetImageManager (CXTPImageManager *pImageManager)
Sets the isolated image manager for elements inside the Markup context.
CXTPImageManager * | GetImageManager () const
Gets the isolated image manager for elements inside the Markup context.
void | SetImageColorKey (COLORREF crColorKey)
Sets the context specific color key for an image element.
COLORREF | GetImageColorKey () const
Gets the context specific color key for an image element.
CXTPMarkupStaticExtension * GetExtensionRoot ()
Gets a pointer to the extension root object used to add custom Markup extensions.
BOOL | IsDpiAware () const
Determines if context DPI awareness is enabled (i.e.
void | SetDpiAware (BOOL bSet=TRUE)
Enables/disables context DPI awareness.
void | SetDpiAware (BOOL bSet, HWND hWnd)
Enables/disables context DPI awareness.
void | SetDpiAware (BOOL bSet, HDC hDC)
Enables/disables context DPI awareness.
int | ScaleX (int x) const
Performs x- and y- coordinate scaling according to active DPI settings if the Markup context is DPI aware.
int | ScaleY (int y) const
Performs x- and y- coordinate scaling according to active DPI settings if the Markup context is DPI aware.
float | ScaleX (float x) const
Performs x- and y- coordinate scaling according to active DPI settings if the Markup context is DPI aware.
float | ScaleY (float y) const
Performs x- and y- coordinate scaling according to active DPI settings if the Markup context is DPI aware.
double | ScaleX (double x) const
Performs x- and y- coordinate scaling according to active DPI settings if the Markup context is DPI aware.
double | ScaleY (double y) const
Performs x- and y- coordinate scaling according to active DPI settings if the Markup context is DPI aware.
CSize | Scale (const SIZE &size) const
Performs x- and y- coordinate scaling according to active DPI settings if the Markup context is DPI aware.
void | LoadScriptCodeChunk (CXTPMarkupBuilder *pBuilder, LPCWSTR lpszLanguage, LPCWSTR lpszCode, LPCWSTR lpszRequires=NULL)
Loads a chunk of script code in a specified language.
void | RunScriptEngine (CXTPMarkupBuilder *pBuilder)
Runs script engine.
CXTPActiveScriptEngine * GetScriptEngine ()
Obtains the associated ActiveScript engine object pointer if there is a scripting context assigned to the markup context.
void | AddCustomScriptItem (LPCWSTR lpName, LPDISPATCH pDisp)
Adds a custom scripting named item to the associated scripting context.
void | RemoveCustomScriptItem (LPCWSTR lpName)
Removes a previously added named sciripting item from the context.
HWND | GetContextWindow () const
Gets a window handle associated with markup context.
void | SetContextWindow (HWND hWnd, LPCRECT pUpdateRect=NULL)
Sets a window handle associated with markup context.

Protected Member Functions

void | DrawMarkupItem (NMTVCUSTOMDRAW *lpLVCD)
Draws a markup item.
CString | GetPlainMarkupItemText (CXTPMarkupUIElement *pUIElement) const
Obtains plain markup item text, i.e.
CSize | GetItemTextExtent (CDC *pDC, LPCTSTR lpszText, int nCount) const
Obtains item text extent.
HTREEITEM | HitTestMarkupItem (CPoint point)
Performs item hit test.
- Protected Member Functions inherited from CXTPMarkupContext
virtual | ~CXTPMarkupContext ()
Destroys a CXTPMarkupContext object, handles cleanup and deallocation.

Detailed Description

Tree control class that allows for adding markup items.

Member Function Documentation

◆ AddItem()

HTREEITEM AddItem | ( | LPCTSTR | lpszItem,
 |  | int | nImage,
 |  | int | nSelectedImage,
 |  | HTREEITEM | hParent = TVI_ROOT,
 |  | HTREEITEM | hInsertAfter = TVI_LAST )

Adds a new markup item.

Parameters
lpszItem | Pointer to a NULL-terminated string that contains either plain item text or markup text to display.
nImage | Zero-based normal image index.
nSelectedImage | Zero-based selected image index.
hParent | Parent item handle.
hInsertAfter | Item handle to insert a new item after.
Returns
A newly inserted item handle if successful, otherwise NULL.

◆ DrawMarkupItem()

void DrawMarkupItem ( NMTVCUSTOMDRAW * lpLVCD )
protected

Draws a markup item.

Parameters
lpLVCD Pointer to a NMTVCUSTOMDRAW structure.

◆ GetItemTextExtent()

CSize GetItemTextExtent | ( | CDC * | pDC,
 |  | LPCTSTR | lpszText,
 |  | int | nCount ) const
 protected

Obtains item text extent.

Takes into account control's font.

Parameters
pDC | Control's device context pointer.
lpszText | Pointer to NULL-terminated string for which to compute size information.
nCount | Number of characters in the string pointed to by lpszText.
Returns
Size of text in device units.

◆ GetMarkupContext()

CXTPMarkupContext * GetMarkupContext ( )

Obtains the markup context associated with the markup tree.

Returns
A pointer to the markup context associated with the markup tree.

◆ GetPlainMarkupItemText()

CString GetPlainMarkupItemText ( CXTPMarkupUIElement * pUIElement ) const
protected

Obtains plain markup item text, i.e.

text without markup elements.

Parameters
pUIElement Pointer to a markup element for which to obtain plain text.
Returns
Plain markup item text.

◆ HitTestMarkupItem()

HTREEITEM HitTestMarkupItem ( CPoint point )
protected

Performs item hit test.

Parameters
point Point in client coordinates where to perform hit test.
Returns
Item handle located at the specified point, or NULL if no item is found.
The documentation for this class was generated from the following file:
  • XTPMarkupTreeCtrl.h


Toolkit Pro: CXTPMarkupUIElement Class Reference

Public Member Functions | Static Public Attributes | Protected Member Functions | Protected Attributes | List of all members
CXTPMarkupUIElement Class Reference

Base class for XML Markup core level implementations. More...

Inheritance diagram for CXTPMarkupUIElement:
[legend]

Public Member Functions

void | Arrange (CRect rcFinalRect)
Positions child elements and determines a size for a CXTPMarkupUIElement.
void | Measure (CXTPMarkupDrawingContext *pDC, CSize szAvailableSize)
Updates the DesiredSize of a CXTPMarkupUIElement.
CSize | GetDesiredSize () const
Gets the size that this element computed during the measure pass of the layout process.
CRect | GetFinalRect () const
Gets the final render size of this element.
XTPMarkupVisibility | GetVisibility () const
Gets the user interface (UI) visibility of this element.
void | SetVisibility (XTPMarkupVisibility visibility)
Sets the user interface (UI) visibility of this element.
BOOL | IsFocusable () const
Gets or sets a value indicating whether this element can receive focus.
virtual BOOL | IsVisible () const
Gets a value indicating whether this element is visible in the user interface (UI).
BOOL | IsEnabled () const
Gets or sets a value indicating whether this element is enabled in the user interface (UI).
virtual void | InvalidateArrange ()
Invalidates the arrange state (layout) for the element.
virtual void | InvalidateVisual ()
Invalidates the rendering of the element, and forces a new complete layout pass.
virtual void | InvalidateMeasure ()
Invalidates the measurement state (layout) for the element.
- Public Member Functions inherited from CXTPMarkupVisual
CXTPMarkupVisual ()
Provides the base initialization for objects derived from the CXTPMarkupVisual class.
virtual | ~CXTPMarkupVisual ()
Destroys a CXTPMarkupVisual object, handles cleanup and deallocation.
void | Render (CXTPMarkupDrawingContext *drawingContext)
Call this method to draw a Visual object inside a drawing context.
CXTPMarkupInputElement * | InputHitTest (CPoint point) const
Determines if a point belongs to this object.
virtual int | GetVisualChildrenCount () const
Gets the number of child elements for the Visual.
virtual CXTPMarkupVisual * | GetVisualChild (int nIndex) const
Retrieves the child Visual object located at a specified index within the parent VisualCollection.
virtual int | GetLogicalChildrenCount () const
Retrieves the number of logical child elements of this object.
virtual CXTPMarkupObject * | GetLogicalChild (int nIndex) const
Retrieves the logical child element located at a specified index within the parent collection.
CRect | GetBoundRect () const
Retrieves the bounding rectangle of the element.
CRect | GetUpdateRect () const
Computes the update rectangle.
CSize | GetRenderSize () const
Gets the final render size of this element.
CPoint | GetVisualOffset () const
Gets or sets the offset value of the visual object.
CXTPMarkupVisual * | GetVisualParent () const
Gets the Visual tree parent of the Visual object.

Static Public Attributes

static CXTPMarkupDependencyProperty * | m_pClipToBoundsProperty
Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element.
static CXTPMarkupDependencyProperty * | m_pVisibilityProperty
A value indicating whether this element is visible in the user interface (UI).
static CXTPMarkupDependencyProperty * | m_pFocusableProperty
A value that indicates whether the element can receive focus.
static CXTPMarkupDependencyProperty * | m_pIsEnabledProperty
A value indicating whether thiselement is enabled in the user interface (UI).
static CXTPMarkupDependencyProperty * | m_pRenderTransformProperty
Gets or sets transform information that affects the rendering position of this element.
static CXTPMarkupDependencyProperty * | m_pRenderTransformOriginProperty
Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element.
static CXTPMarkupDependencyProperty * | m_pOpacityProperty
Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI).

Protected Member Functions

CXTPMarkupUIElement ()
Initializes a new instance of the CXTPMarkupUIElement class.
virtual | ~CXTPMarkupUIElement ()
Destroys a CXTPMarkupUIElement object, handles cleanup and deallocation.
CXTPMarkupRenderTransform * | GetRenderTransform () const
Obtains a pointer to the RenderTransform object.
virtual void | ArrangeCore (CRect rcFinalRect)
Defines the template for the core-level arrange layout definition.
virtual CSize | MeasureCore (CXTPMarkupDrawingContext *pDC, CSize szAvailableSize)
When overridden in a derived class, provides measurement logic for sizing this element properly with consideration of the size of any child element content.
virtual BOOL | GetLayoutClip (CRect &rc) const
Retrieves an alternative clipping geometry that represents the region that would be clipped if child elements were clipped inside element bounds.
virtual void | InvalidateMeasureOverride (CXTPMarkupDrawingContext *pDC)
Override this method to provide a custom reaction to an InvalidateMeasure call.
virtual TransformationMatrices | ApplyRenderTransform (CXTPMarkupDrawingContext *pContext)
Applies render transformation if necessary.
virtual void | RestoreRenderTransform (CXTPMarkupDrawingContext *pContext, TransformationMatrices &matrices)
Restores a previously applied render transformation.
virtual double | GetOpacity () const
Gets either the default or explicitly set opacity factor value.
- Protected Member Functions inherited from CXTPMarkupVisual
BOOL | PtInRectTransform (const RECT &rect, const POINT &point) const
Checks if a point is inside a rectangle with transformation applied.
POINT | GetAbsoluteVisualOffset () const
Gets the absolute element visual offset.
virtual void | OnRender (CXTPMarkupDrawingContext *drawingContext)
When overridden in a derived class, participates in rendering operations that are directed by the layout system.
virtual void | OnRenderFocusVisual (CXTPMarkupDrawingContext *drawingContext)
This method is called to render the focus rectangle of a focused object.
virtual CXTPMarkupInputElement * | InputHitTestOverride (CPoint point) const
Override this method in the derived class to provide visual hit testing of a child object.
virtual void | RenderClipped (CXTPMarkupDrawingContext *drawingContext)
Called by the framework when an element is clipped and no rendering will occur.

Protected Attributes

CSize | m_szDesiredSize
Gets the size that this element computed during the measure pass of the layout process.
CRect | m_rcFinalRect
Final position of the visual element.
BOOL | m_bMeasureDirty
TRUE if object hasn't recalculated its size.
BOOL | m_bNeverMeasured
TRUE if object has never ran Measure to update its size.
CSize | m_szPreviousAvailableSize
Previous available size of measure call.
BOOL | m_bArrangeDirty
TRUE if object position can be invalid.
BOOL | m_bNeverArranged
TRUE if Arrange was never called for this object.
BOOL | m_bArrangeInProgress
TRUE if Arrange is currently executed.
BOOL | m_bMeasureInProgress
TRUE if Measure is currently executed.
- Protected Attributes inherited from CXTPMarkupVisual
CPoint | m_ptVisualOffset
The offset value of the visual object.
CSize | m_szRenderSize
The rendered size for this element.
CRect | m_rcBoundRect
Bounding rectangle of the element.
CRect | m_rcUpdateRect
Update rectangle.
CRect | m_rcPrevUpdateRect
Previous update rectangle.

Detailed Description

Base class for XML Markup core level implementations.

Member Function Documentation

◆ ApplyRenderTransform()

virtual TransformationMatrices ApplyRenderTransform ( CXTPMarkupDrawingContext * pContext )
protectedvirtual

Applies render transformation if necessary.

Parameters
pContext Drawing context to apply the render transformation for.
Returns
A structure that optionally describes the previous and the new transformation matrices.

Reimplemented from CXTPMarkupVisual.

◆ Arrange()

void Arrange ( CRect rcFinalRect )

Positions child elements and determines a size for a CXTPMarkupUIElement.

Parent elements call this method from their ArrangeOverride implementation to form a recursive layout update. This method constitutes the second pass of a layout update.

Parameters
rcFinalRect The final size that the parent computes for the child element, provided as a CRect instance.

◆ ArrangeCore()

virtual void ArrangeCore ( CRect rcFinalRect )
protectedvirtual

Defines the template for the core-level arrange layout definition.

Parameters
rcFinalRect The final area within the parent that an element should use to arrange itself and its child elements.

◆ GetDesiredSize()

AFX_INLINE CSize GetDesiredSize ( ) const

Gets the size that this element computed during the measure pass of the layout process.

Returns
The size that this element computed during the measure pass of the layout process; this size becomes the DesiredSize for the arrange pass.

DesiredSize is typically checked as one of the measurement factors when you implement layout behavior overrides such as ArrangeOverride, MeasureOverride, or OnRender.

◆ GetFinalRect()

AFX_INLINE CRect GetFinalRect ( ) const

Gets the final render size of this element.

Returns
The rendered size of this element.

◆ GetLayoutClip()

virtual BOOL GetLayoutClip ( CRect & rc ) const
protectedvirtual

Retrieves an alternative clipping geometry that represents the region that would be clipped if child elements were clipped inside element bounds.

Parameters
rc The available size provided by the element.
Returns
The potential clipping geometry.

Reimplemented from CXTPMarkupVisual.

◆ GetOpacity()

virtual double GetOpacity ( ) const
protectedvirtual

Gets either the default or explicitly set opacity factor value.

Returns
An opacity factor value in the range 0..1.

Reimplemented from CXTPMarkupVisual.

◆ GetRenderTransform()

CXTPMarkupRenderTransform * GetRenderTransform ( ) const
protected

Obtains a pointer to the RenderTransform object.

Returns
A pointer to the RenderTransform object, or NULL if the RenderTransform object is not specified for the currect Markup element.

◆ GetVisibility()

XTPMarkupVisibility GetVisibility ( ) const

Gets the user interface (UI) visibility of this element.

This is a dependency property.

Returns
An XTPMarkupVisibility enumerator value.

◆ InvalidateArrange()

virtual void InvalidateArrange ( )
virtual

Invalidates the arrange state (layout) for the element.

Frequent calls to InvalidateArrange have significant performance consequences. Therefore, avoid calling this method unless you absolutely require a precise layout state for subsequent calls to other APIs in your code.

◆ InvalidateMeasure()

virtual void InvalidateMeasure ( )
virtual

Invalidates the measurement state (layout) for the element.

Calling this method also calls InvalidateArrange internally, there is no need to call InvalidateMeasure and InvalidateArrange in succession.

◆ InvalidateMeasureOverride()

virtual void InvalidateMeasureOverride ( CXTPMarkupDrawingContext * pDC )
protectedvirtual

Override this method to provide a custom reaction to an InvalidateMeasure call.

Parameters
pDC Device context to measure.

◆ InvalidateVisual()

virtual void InvalidateVisual ( )
virtual

Invalidates the rendering of the element, and forces a new complete layout pass.

OnRender is called after the layout cycle is completed.

This method calls InvalidateArrange internally.

◆ IsEnabled()

BOOL IsEnabled ( ) const

Gets or sets a value indicating whether this element is enabled in the user interface (UI).

This is a dependency property.

Returns
TRUE if the element is enabled, otherwise FALSE. The default value is TRUE.

◆ IsFocusable()

BOOL IsFocusable ( ) const

Gets or sets a value indicating whether this element can receive focus.

This is a dependency property.

Returns
TRUE if this element is focusable, otherwise FALSE. The default is FALSE.

◆ IsVisible()

virtual BOOL IsVisible ( ) const
virtual

Gets a value indicating whether this element is visible in the user interface (UI).

This is a dependency property.

Returns
TRUE if this element is visible, otherwise FALSE.

Reimplemented from CXTPMarkupVisual.

◆ Measure()

void Measure | ( | CXTPMarkupDrawingContext * | pDC,
 |  | CSize | szAvailableSize )

Updates the DesiredSize of a CXTPMarkupUIElement.

Parent elements call this method from their own MeasureOveride implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update.

Parameters
pDC | Pointer to a CXTPMarkupDrawingContext.
szAvailableSize | The available space that a parent element can allocate to a child element. A child element can request a larger space than what is available; the provided size might be accommodated if scrolling is possible in the content model for the current element.

◆ MeasureCore()

virtual CSize MeasureCore | ( | CXTPMarkupDrawingContext * | pDC,
 |  | CSize | szAvailableSize )
 protectedvirtual

When overridden in a derived class, provides measurement logic for sizing this element properly with consideration of the size of any child element content.

Parameters
pDC | Device context.
szAvailableSize | The available size that the parent element can allocate for the child.
Returns
The desired size of this element in layout.

◆ RestoreRenderTransform()

virtual void RestoreRenderTransform | ( | CXTPMarkupDrawingContext * | pContext,
 |  | TransformationMatrices & | matrices )
 protectedvirtual

Restores a previously applied render transformation.

Parameters
pContext | Drawing context to restore the render transformation for.
matrices | Transformation matrices previously returned by a call to ApplyRenderTransform.

Reimplemented from CXTPMarkupVisual.

◆ SetVisibility()

void SetVisibility ( XTPMarkupVisibility visibility )

Sets the user interface (UI) visibility of this element.

This is a dependency property.

Parameters
visibility An XTPMarkupVisibility enumerator value; the default value is visible.

Member Data Documentation

◆ m_pClipToBoundsProperty

CXTPMarkupDependencyProperty* m_pClipToBoundsProperty
static

Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element.

This is a dependency property.

The documentation for this class was generated from the following file:
  • XTPMarkupUIElement.h


Toolkit Pro: CXTPMarkupUIElementCollection Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPMarkupUIElementCollection Class Reference

CXTPMarkupUIElementCollection is a CXTPMarkupCollection derived class. More...

Public Member Functions

CXTPMarkupUIElementCollection ()
Constructs a CXTPMarkupUIElementCollection object.
~CXTPMarkupUIElementCollection ()
Destroys a CXTPMarkupUIElementCollection object, handles cleanup and deallocation.
CXTPMarkupUIElement * GetItem (int nIndex) const
Retrieves a CXTPMarkupUIElement object by its index.

Protected Member Functions

void OnChanged ()
This method is called when the collection is changed.

Detailed Description

CXTPMarkupUIElementCollection is a CXTPMarkupCollection derived class.

It implements a basic collection of CXTPMarkupUIElement elements.

Member Function Documentation

◆ GetItem()

AFX_INLINE CXTPMarkupUIElement * GetItem ( int nIndex ) const

Retrieves a CXTPMarkupUIElement object by its index.

Parameters
nIndex Index of the CXTPMarkupUIElement object to retrieve.
Returns
A pointer to the CXTPMarkupUIElement object.
The documentation for this class was generated from the following file:
  • XTPMarkupUIElementCollection.h


Toolkit Pro: CXTPMarkupUniformGrid Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPMarkupUniformGrid Class Reference

CXTPMarkupUniformGrid is a CXTPMarkupPanel derived class. More...

Inheritance diagram for CXTPMarkupUniformGrid:
[legend]

Public Member Functions

void | SetColumns (int nColumns)
Sets the number of columns in the grid.
int | GetColumns () const
Gets the number of columns in the grid.
void | SetRows (int nRows)
Sets the number of rows in the grid.
int | GetRows () const
Gets the number of rows in the grid.
void | SetFirstColumn (int nFirstColumn)
Sets the position for the first column of the first row of the grid.
int | GetFirstColumn () const
Gets the position of the first column of the first row of the grid.
- Public Member Functions inherited from CXTPMarkupPanel
CXTPMarkupUIElementCollection * | GetChildren () const
Retrieves the collection of child elements.
void | SetBackground (CXTPMarkupBrush *pBrush)
Sets the background brush for the panel object.
CXTPMarkupBrush * | GetBackground () const
Gets the background brush of the panel object.
- Public Member Functions inherited from CXTPMarkupFrameworkElement
void | SetMargin (int nLeft, int nTop, int nRight, int nBottom)
Call this method to set the outer margin of an element.
void | SetMargin (int nMargin)
Call this method to set the outer margin of an element.
CXTPMarkupThickness * | GetMargin () const
Call this method to get the outer margin of an element.
void | SetMinWidth (int nWidth)
Sets the minimum width constraint for the element.
void | SetMaxWidth (int nWidth)
Sets the maximum width constraint for the element.
void | SetWidth (int nWidth)
Sets the width for the element.
void | SetMinHeight (int nHeight)
Sets the minimum height constraint for the element.
void | SetMaxHeight (int nHeight)
Sets the maximum height constraint for the element.
void | SetHeight (int nHeight)
Sets the height for the element.
int | GetMinWidth () const
Gets the minimum width constraint of the element.
int | GetMaxWidth () const
Gets the maximum width constraint of the element.
int | GetWidth () const
Gets the width of the element.
int | GetMinHeight () const
Gets the minimum height constraint of the element.
int | GetMaxHeight () const
Gets the maximum height constraint of the element.
int | GetHeight () const
Gets the height of the element.
CXTPMarkupObject * | GetTag () const
Gets the tag object of the element.
void | SetTag (CXTPMarkupObject *pTag)
Sets the tag object for the element.
void | SetHorizontalAlignment (XTPMarkupHorizontalAlignment alignment)
Sets the horizontal alignment characteristics applied to this element when it is composed within a parent element (e.g.
void | SetVerticalAlignment (XTPMarkupVerticalAlignment alignment)
Sets the vertical alignment characteristics applied to this element when it is composed within a parent element (e.g.
XTPMarkupHorizontalAlignment | GetHorizontalAlignment () const
Gets the horizontal alignment characteristics applied to this element when it is composed within a parent element (e.g.
XTPMarkupVerticalAlignment | GetVerticalAlignment () const
Gets the vertical alignment characteristics applied to this element when it is composed within a parent element (e.g.
CSize | GetActualSize () const
Retrieves the actual size of the element after it is measured and arranged within a parent element (e.g.
void | SetClipToBounds (BOOL bClipToBounds)
Specifies if child elements should be clipped inside element bounds.
BOOL | GetClipToBounds () const
Determines if child elements are clipped inside element bounds.
CXTPMarkupStyle * | GetStyle () const
Gets the attached style of the element.
- Public Member Functions inherited from CXTPMarkupUIElement
void | Arrange (CRect rcFinalRect)
Positions child elements and determines a size for a CXTPMarkupUIElement.
void | Measure (CXTPMarkupDrawingContext *pDC, CSize szAvailableSize)
Updates the DesiredSize of a CXTPMarkupUIElement.
CSize | GetDesiredSize () const
Gets the size that this element computed during the measure pass of the layout process.
CRect | GetFinalRect () const
Gets the final render size of this element.
XTPMarkupVisibility | GetVisibility () const
Gets the user interface (UI) visibility of this element.
void | SetVisibility (XTPMarkupVisibility visibility)
Sets the user interface (UI) visibility of this element.
BOOL | IsFocusable () const
Gets or sets a value indicating whether this element can receive focus.
virtual BOOL | IsVisible () const
Gets a value indicating whether this element is visible in the user interface (UI).
BOOL | IsEnabled () const
Gets or sets a value indicating whether this element is enabled in the user interface (UI).
virtual void | InvalidateArrange ()
Invalidates the arrange state (layout) for the element.
virtual void | InvalidateVisual ()
Invalidates the rendering of the element, and forces a new complete layout pass.
virtual void | InvalidateMeasure ()
Invalidates the measurement state (layout) for the element.
- Public Member Functions inherited from CXTPMarkupVisual
CXTPMarkupVisual ()
Provides the base initialization for objects derived from the CXTPMarkupVisual class.
virtual | ~CXTPMarkupVisual ()
Destroys a CXTPMarkupVisual object, handles cleanup and deallocation.
void | Render (CXTPMarkupDrawingContext *drawingContext)
Call this method to draw a Visual object inside a drawing context.
CXTPMarkupInputElement * | InputHitTest (CPoint point) const
Determines if a point belongs to this object.
virtual int | GetVisualChildrenCount () const
Gets the number of child elements for the Visual.
virtual CXTPMarkupVisual * | GetVisualChild (int nIndex) const
Retrieves the child Visual object located at a specified index within the parent VisualCollection.
virtual int | GetLogicalChildrenCount () const
Retrieves the number of logical child elements of this object.
virtual CXTPMarkupObject * | GetLogicalChild (int nIndex) const
Retrieves the logical child element located at a specified index within the parent collection.
CRect | GetBoundRect () const
Retrieves the bounding rectangle of the element.
CRect | GetUpdateRect () const
Computes the update rectangle.
CSize | GetRenderSize () const
Gets the final render size of this element.
CPoint | GetVisualOffset () const
Gets or sets the offset value of the visual object.
CXTPMarkupVisual * | GetVisualParent () const
Gets the Visual tree parent of the Visual object.

Protected Member Functions

CXTPMarkupUniformGrid ()
Constructs a CXTPMarkupUniformGrid object.
virtual | ~CXTPMarkupUniformGrid ()
Destroys a CXTPMarkupUniformGrid object, handles cleanup and deallocation.
- Protected Member Functions inherited from CXTPMarkupPanel
CXTPMarkupPanel ()
Constructs a CXTPMarkupPanel object.
virtual | ~CXTPMarkupPanel ()
Destroys a CXTPMarkupPanel object, handles cleanup and deallocation.
- Protected Member Functions inherited from CXTPMarkupFrameworkElement
CXTPMarkupFrameworkElement ()
Initializes a new instance of the CXTPMarkupFrameworkElement class.
virtual | ~CXTPMarkupFrameworkElement ()
Destroys a CXTPMarkupFrameworkElement object, handles cleanup and deallocation.
- Protected Member Functions inherited from CXTPMarkupUIElement
CXTPMarkupUIElement ()
Initializes a new instance of the CXTPMarkupUIElement class.
virtual | ~CXTPMarkupUIElement ()
Destroys a CXTPMarkupUIElement object, handles cleanup and deallocation.
CXTPMarkupRenderTransform * | GetRenderTransform () const
Obtains a pointer to the RenderTransform object.
virtual void | ArrangeCore (CRect rcFinalRect)
Defines the template for the core-level arrange layout definition.
virtual CSize | MeasureCore (CXTPMarkupDrawingContext *pDC, CSize szAvailableSize)
When overridden in a derived class, provides measurement logic for sizing this element properly with consideration of the size of any child element content.
virtual BOOL | GetLayoutClip (CRect &rc) const
Retrieves an alternative clipping geometry that represents the region that would be clipped if child elements were clipped inside element bounds.
virtual void | InvalidateMeasureOverride (CXTPMarkupDrawingContext *pDC)
Override this method to provide a custom reaction to an InvalidateMeasure call.
virtual TransformationMatrices | ApplyRenderTransform (CXTPMarkupDrawingContext *pContext)
Applies render transformation if necessary.
virtual void | RestoreRenderTransform (CXTPMarkupDrawingContext *pContext, TransformationMatrices &matrices)
Restores a previously applied render transformation.
virtual double | GetOpacity () const
Gets either the default or explicitly set opacity factor value.
- Protected Member Functions inherited from CXTPMarkupVisual
BOOL | PtInRectTransform (const RECT &rect, const POINT &point) const
Checks if a point is inside a rectangle with transformation applied.
POINT | GetAbsoluteVisualOffset () const
Gets the absolute element visual offset.
virtual void | OnRender (CXTPMarkupDrawingContext *drawingContext)
When overridden in a derived class, participates in rendering operations that are directed by the layout system.
virtual void | OnRenderFocusVisual (CXTPMarkupDrawingContext *drawingContext)
This method is called to render the focus rectangle of a focused object.
virtual CXTPMarkupInputElement * | InputHitTestOverride (CPoint point) const
Override this method in the derived class to provide visual hit testing of a child object.
virtual void | RenderClipped (CXTPMarkupDrawingContext *drawingContext)
Called by the framework when an element is clipped and no rendering will occur.

Additional Inherited Members

- Static Public Attributes inherited from CXTPMarkupUIElement
static CXTPMarkupDependencyProperty * | m_pClipToBoundsProperty
Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element.
static CXTPMarkupDependencyProperty * | m_pVisibilityProperty
A value indicating whether this element is visible in the user interface (UI).
static CXTPMarkupDependencyProperty * | m_pFocusableProperty
A value that indicates whether the element can receive focus.
static CXTPMarkupDependencyProperty * | m_pIsEnabledProperty
A value indicating whether thiselement is enabled in the user interface (UI).
static CXTPMarkupDependencyProperty * | m_pRenderTransformProperty
Gets or sets transform information that affects the rendering position of this element.
static CXTPMarkupDependencyProperty * | m_pRenderTransformOriginProperty
Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element.
static CXTPMarkupDependencyProperty * | m_pOpacityProperty
Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI).
- Protected Attributes inherited from CXTPMarkupUIElement
CSize | m_szDesiredSize
Gets the size that this element computed during the measure pass of the layout process.
CRect | m_rcFinalRect
Final position of the visual element.
BOOL | m_bMeasureDirty
TRUE if object hasn't recalculated its size.
BOOL | m_bNeverMeasured
TRUE if object has never ran Measure to update its size.
CSize | m_szPreviousAvailableSize
Previous available size of measure call.
BOOL | m_bArrangeDirty
TRUE if object position can be invalid.
BOOL | m_bNeverArranged
TRUE if Arrange was never called for this object.
BOOL | m_bArrangeInProgress
TRUE if Arrange is currently executed.
BOOL | m_bMeasureInProgress
TRUE if Measure is currently executed.
- Protected Attributes inherited from CXTPMarkupVisual
CPoint | m_ptVisualOffset
The offset value of the visual object.
CSize | m_szRenderSize
The rendered size for this element.
CRect | m_rcBoundRect
Bounding rectangle of the element.
CRect | m_rcUpdateRect
Update rectangle.
CRect | m_rcPrevUpdateRect
Previous update rectangle.

Detailed Description

CXTPMarkupUniformGrid is a CXTPMarkupPanel derived class.

It implements the UniformGrid XAML Tag.

Member Function Documentation

◆ GetColumns()

int GetColumns ( ) const

Gets the number of columns in the grid.

Returns
The number of columns in the grid.

◆ GetFirstColumn()

int GetFirstColumn ( ) const

Gets the position of the first column of the first row of the grid.

The position of the first column of the first row of the grid.

Returns
Returns position of the first column in the first row of the grid

◆ GetRows()

int GetRows ( ) const

Gets the number of rows in the grid.

Returns
The number of rows in the grid.

◆ SetColumns()

void SetColumns ( int nColumns )

Sets the number of columns in the grid.

Parameters
nColumns Number of columns to set.

◆ SetFirstColumn()

void SetFirstColumn ( int nFirstColumn )

Sets the position for the first column of the first row of the grid.

Parameters
nFirstColumn Position to be set.

◆ SetRows()

void SetRows ( int nRows )

Sets the number of rows in the grid.

Parameters
nRows Number of rows to set.
The documentation for this class was generated from the following file:
  • XTPMarkupUniformGrid.h


Toolkit Pro: CXTPMarkupViewbox Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPMarkupViewbox Class Reference

CXTPMarkupViewbox is a CXTPMarkupDecorator derived class. More...

Inheritance diagram for CXTPMarkupViewbox:
[legend]

Public Member Functions

void | SetStretch (XTPMarkupStretch stretch)
Sets the stretch type of the image.
XTPMarkupStretch | GetStretch () const
Gets the current stretch type of the image.
- Public Member Functions inherited from CXTPMarkupDecorator
void | SetChild (CXTPMarkupUIElement *pChild)
Sets a new child object for the decorator element.
CXTPMarkupUIElement * | GetChild () const
Retrieves the child object of the decorator element.
- Public Member Functions inherited from CXTPMarkupFrameworkElement
void | SetMargin (int nLeft, int nTop, int nRight, int nBottom)
Call this method to set the outer margin of an element.
void | SetMargin (int nMargin)
Call this method to set the outer margin of an element.
CXTPMarkupThickness * | GetMargin () const
Call this method to get the outer margin of an element.
void | SetMinWidth (int nWidth)
Sets the minimum width constraint for the element.
void | SetMaxWidth (int nWidth)
Sets the maximum width constraint for the element.
void | SetWidth (int nWidth)
Sets the width for the element.
void | SetMinHeight (int nHeight)
Sets the minimum height constraint for the element.
void | SetMaxHeight (int nHeight)
Sets the maximum height constraint for the element.
void | SetHeight (int nHeight)
Sets the height for the element.
int | GetMinWidth () const
Gets the minimum width constraint of the element.
int | GetMaxWidth () const
Gets the maximum width constraint of the element.
int | GetWidth () const
Gets the width of the element.
int | GetMinHeight () const
Gets the minimum height constraint of the element.
int | GetMaxHeight () const
Gets the maximum height constraint of the element.
int | GetHeight () const
Gets the height of the element.
CXTPMarkupObject * | GetTag () const
Gets the tag object of the element.
void | SetTag (CXTPMarkupObject *pTag)
Sets the tag object for the element.
void | SetHorizontalAlignment (XTPMarkupHorizontalAlignment alignment)
Sets the horizontal alignment characteristics applied to this element when it is composed within a parent element (e.g.
void | SetVerticalAlignment (XTPMarkupVerticalAlignment alignment)
Sets the vertical alignment characteristics applied to this element when it is composed within a parent element (e.g.
XTPMarkupHorizontalAlignment | GetHorizontalAlignment () const
Gets the horizontal alignment characteristics applied to this element when it is composed within a parent element (e.g.
XTPMarkupVerticalAlignment | GetVerticalAlignment () const
Gets the vertical alignment characteristics applied to this element when it is composed within a parent element (e.g.
CSize | GetActualSize () const
Retrieves the actual size of the element after it is measured and arranged within a parent element (e.g.
void | SetClipToBounds (BOOL bClipToBounds)
Specifies if child elements should be clipped inside element bounds.
BOOL | GetClipToBounds () const
Determines if child elements are clipped inside element bounds.
CXTPMarkupStyle * | GetStyle () const
Gets the attached style of the element.
- Public Member Functions inherited from CXTPMarkupUIElement
void | Arrange (CRect rcFinalRect)
Positions child elements and determines a size for a CXTPMarkupUIElement.
void | Measure (CXTPMarkupDrawingContext *pDC, CSize szAvailableSize)
Updates the DesiredSize of a CXTPMarkupUIElement.
CSize | GetDesiredSize () const
Gets the size that this element computed during the measure pass of the layout process.
CRect | GetFinalRect () const
Gets the final render size of this element.
XTPMarkupVisibility | GetVisibility () const
Gets the user interface (UI) visibility of this element.
void | SetVisibility (XTPMarkupVisibility visibility)
Sets the user interface (UI) visibility of this element.
BOOL | IsFocusable () const
Gets or sets a value indicating whether this element can receive focus.
virtual BOOL | IsVisible () const
Gets a value indicating whether this element is visible in the user interface (UI).
BOOL | IsEnabled () const
Gets or sets a value indicating whether this element is enabled in the user interface (UI).
virtual void | InvalidateArrange ()
Invalidates the arrange state (layout) for the element.
virtual void | InvalidateVisual ()
Invalidates the rendering of the element, and forces a new complete layout pass.
virtual void | InvalidateMeasure ()
Invalidates the measurement state (layout) for the element.
- Public Member Functions inherited from CXTPMarkupVisual
CXTPMarkupVisual ()
Provides the base initialization for objects derived from the CXTPMarkupVisual class.
virtual | ~CXTPMarkupVisual ()
Destroys a CXTPMarkupVisual object, handles cleanup and deallocation.
void | Render (CXTPMarkupDrawingContext *drawingContext)
Call this method to draw a Visual object inside a drawing context.
CXTPMarkupInputElement * | InputHitTest (CPoint point) const
Determines if a point belongs to this object.
virtual int | GetVisualChildrenCount () const
Gets the number of child elements for the Visual.
virtual CXTPMarkupVisual * | GetVisualChild (int nIndex) const
Retrieves the child Visual object located at a specified index within the parent VisualCollection.
virtual int | GetLogicalChildrenCount () const
Retrieves the number of logical child elements of this object.
virtual CXTPMarkupObject * | GetLogicalChild (int nIndex) const
Retrieves the logical child element located at a specified index within the parent collection.
CRect | GetBoundRect () const
Retrieves the bounding rectangle of the element.
CRect | GetUpdateRect () const
Computes the update rectangle.
CSize | GetRenderSize () const
Gets the final render size of this element.
CPoint | GetVisualOffset () const
Gets or sets the offset value of the visual object.
CXTPMarkupVisual * | GetVisualParent () const
Gets the Visual tree parent of the Visual object.

Protected Member Functions

CXTPMarkupViewbox ()
Constructs a CXTPMarkupViewbox object.
virtual | ~CXTPMarkupViewbox ()
Destroys a CXTPMarkupViewbox object, handles cleanup and deallocation.
- Protected Member Functions inherited from CXTPMarkupDecorator
CXTPMarkupDecorator ()
Constructs a CXTPMarkupDecorator object.
virtual | ~CXTPMarkupDecorator ()
Destroys a CXTPMarkupDecorator object, handles cleanup and deallocation.
- Protected Member Functions inherited from CXTPMarkupFrameworkElement
CXTPMarkupFrameworkElement ()
Initializes a new instance of the CXTPMarkupFrameworkElement class.
virtual | ~CXTPMarkupFrameworkElement ()
Destroys a CXTPMarkupFrameworkElement object, handles cleanup and deallocation.
- Protected Member Functions inherited from CXTPMarkupUIElement
CXTPMarkupUIElement ()
Initializes a new instance of the CXTPMarkupUIElement class.
virtual | ~CXTPMarkupUIElement ()
Destroys a CXTPMarkupUIElement object, handles cleanup and deallocation.
CXTPMarkupRenderTransform * | GetRenderTransform () const
Obtains a pointer to the RenderTransform object.
virtual void | ArrangeCore (CRect rcFinalRect)
Defines the template for the core-level arrange layout definition.
virtual CSize | MeasureCore (CXTPMarkupDrawingContext *pDC, CSize szAvailableSize)
When overridden in a derived class, provides measurement logic for sizing this element properly with consideration of the size of any child element content.
virtual BOOL | GetLayoutClip (CRect &rc) const
Retrieves an alternative clipping geometry that represents the region that would be clipped if child elements were clipped inside element bounds.
virtual void | InvalidateMeasureOverride (CXTPMarkupDrawingContext *pDC)
Override this method to provide a custom reaction to an InvalidateMeasure call.
virtual TransformationMatrices | ApplyRenderTransform (CXTPMarkupDrawingContext *pContext)
Applies render transformation if necessary.
virtual void | RestoreRenderTransform (CXTPMarkupDrawingContext *pContext, TransformationMatrices &matrices)
Restores a previously applied render transformation.
virtual double | GetOpacity () const
Gets either the default or explicitly set opacity factor value.
- Protected Member Functions inherited from CXTPMarkupVisual
BOOL | PtInRectTransform (const RECT &rect, const POINT &point) const
Checks if a point is inside a rectangle with transformation applied.
POINT | GetAbsoluteVisualOffset () const
Gets the absolute element visual offset.
virtual void | OnRender (CXTPMarkupDrawingContext *drawingContext)
When overridden in a derived class, participates in rendering operations that are directed by the layout system.
virtual void | OnRenderFocusVisual (CXTPMarkupDrawingContext *drawingContext)
This method is called to render the focus rectangle of a focused object.
virtual CXTPMarkupInputElement * | InputHitTestOverride (CPoint point) const
Override this method in the derived class to provide visual hit testing of a child object.
virtual void | RenderClipped (CXTPMarkupDrawingContext *drawingContext)
Called by the framework when an element is clipped and no rendering will occur.

Additional Inherited Members

- Static Public Attributes inherited from CXTPMarkupUIElement
static CXTPMarkupDependencyProperty * | m_pClipToBoundsProperty
Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element.
static CXTPMarkupDependencyProperty * | m_pVisibilityProperty
A value indicating whether this element is visible in the user interface (UI).
static CXTPMarkupDependencyProperty * | m_pFocusableProperty
A value that indicates whether the element can receive focus.
static CXTPMarkupDependencyProperty * | m_pIsEnabledProperty
A value indicating whether thiselement is enabled in the user interface (UI).
static CXTPMarkupDependencyProperty * | m_pRenderTransformProperty
Gets or sets transform information that affects the rendering position of this element.
static CXTPMarkupDependencyProperty * | m_pRenderTransformOriginProperty
Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element.
static CXTPMarkupDependencyProperty * | m_pOpacityProperty
Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI).
- Protected Attributes inherited from CXTPMarkupUIElement
CSize | m_szDesiredSize
Gets the size that this element computed during the measure pass of the layout process.
CRect | m_rcFinalRect
Final position of the visual element.
BOOL | m_bMeasureDirty
TRUE if object hasn't recalculated its size.
BOOL | m_bNeverMeasured
TRUE if object has never ran Measure to update its size.
CSize | m_szPreviousAvailableSize
Previous available size of measure call.
BOOL | m_bArrangeDirty
TRUE if object position can be invalid.
BOOL | m_bNeverArranged
TRUE if Arrange was never called for this object.
BOOL | m_bArrangeInProgress
TRUE if Arrange is currently executed.
BOOL | m_bMeasureInProgress
TRUE if Measure is currently executed.
- Protected Attributes inherited from CXTPMarkupVisual
CPoint | m_ptVisualOffset
The offset value of the visual object.
CSize | m_szRenderSize
The rendered size for this element.
CRect | m_rcBoundRect
Bounding rectangle of the element.
CRect | m_rcUpdateRect
Update rectangle.
CRect | m_rcPrevUpdateRect
Previous update rectangle.

Detailed Description

CXTPMarkupViewbox is a CXTPMarkupDecorator derived class.

It implements the Border XAML Tag.

Member Function Documentation

◆ GetStretch()

XTPMarkupStretch GetStretch ( ) const

Gets the current stretch type of the image.

Returns
The current stretch type.

◆ SetStretch()

void SetStretch ( XTPMarkupStretch stretch )

Sets the stretch type of the image.

Parameters
stretch New stretch type.
The documentation for this class was generated from the following file:
  • XTPMarkupViewbox.h


Toolkit Pro: CXTPMarkupVisual Class Reference

Classes | Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPMarkupVisual Class Reference

Provides rendering support for XML Markup, which includes hit testing, coordinate transformation, and bounding box calculations. More...

Inheritance diagram for CXTPMarkupVisual:
[legend]

Classes

struct TransformationMatrices
A structure that optionally describes the previous and the new transformation matrices. More...

Public Member Functions

CXTPMarkupVisual ()
Provides the base initialization for objects derived from the CXTPMarkupVisual class.
virtual | ~CXTPMarkupVisual ()
Destroys a CXTPMarkupVisual object, handles cleanup and deallocation.
void | Render (CXTPMarkupDrawingContext *drawingContext)
Call this method to draw a Visual object inside a drawing context.
CXTPMarkupInputElement * | InputHitTest (CPoint point) const
Determines if a point belongs to this object.
virtual int | GetVisualChildrenCount () const
Gets the number of child elements for the Visual.
virtual CXTPMarkupVisual * | GetVisualChild (int nIndex) const
Retrieves the child Visual object located at a specified index within the parent VisualCollection.
virtual int | GetLogicalChildrenCount () const
Retrieves the number of logical child elements of this object.
virtual CXTPMarkupObject * | GetLogicalChild (int nIndex) const
Retrieves the logical child element located at a specified index within the parent collection.
CRect | GetBoundRect () const
Retrieves the bounding rectangle of the element.
CRect | GetUpdateRect () const
Computes the update rectangle.
CSize | GetRenderSize () const
Gets the final render size of this element.
CPoint | GetVisualOffset () const
Gets or sets the offset value of the visual object.
virtual BOOL | GetLayoutClip (CRect &rc) const
Retrieves an alternative clipping geometry that represents the region that would be clipped if child elements were clipped inside element bounds.
CXTPMarkupVisual * | GetVisualParent () const
Gets the Visual tree parent of the Visual object.

Protected Member Functions

virtual TransformationMatrices | ApplyRenderTransform (CXTPMarkupDrawingContext *pContext)
Applies render transformation if necessary.
virtual void | RestoreRenderTransform (CXTPMarkupDrawingContext *pContext, TransformationMatrices &matrices)
Restores a previously applied render transformation.
BOOL | PtInRectTransform (const RECT &rect, const POINT &point) const
Checks if a point is inside a rectangle with transformation applied.
POINT | GetAbsoluteVisualOffset () const
Gets the absolute element visual offset.
virtual void | OnRender (CXTPMarkupDrawingContext *drawingContext)
When overridden in a derived class, participates in rendering operations that are directed by the layout system.
virtual void | OnRenderFocusVisual (CXTPMarkupDrawingContext *drawingContext)
This method is called to render the focus rectangle of a focused object.
virtual CXTPMarkupInputElement * | InputHitTestOverride (CPoint point) const
Override this method in the derived class to provide visual hit testing of a child object.
virtual void | RenderClipped (CXTPMarkupDrawingContext *drawingContext)
Called by the framework when an element is clipped and no rendering will occur.
virtual double | GetOpacity () const
Gets either the default or explicitly set opacity factor value.
virtual BOOL | IsVisible () const
Checks if the element is currently visible.

Protected Attributes

CPoint | m_ptVisualOffset
The offset value of the visual object.
CSize | m_szRenderSize
The rendered size for this element.
CRect | m_rcBoundRect
Bounding rectangle of the element.
CRect | m_rcUpdateRect
Update rectangle.
CRect | m_rcPrevUpdateRect
Previous update rectangle.

Detailed Description

Provides rendering support for XML Markup, which includes hit testing, coordinate transformation, and bounding box calculations.

Member Function Documentation

◆ ApplyRenderTransform()

AFX_INLINE CXTPMarkupVisual::TransformationMatrices ApplyRenderTransform ( CXTPMarkupDrawingContext * pContext )
protectedvirtual

Applies render transformation if necessary.

Parameters
pContext Drawing context to apply the render transformation for.
Returns
A structure that optionally describes the previous and the new transformation matrices.

Reimplemented in CXTPMarkupUIElement.

◆ GetAbsoluteVisualOffset()

POINT GetAbsoluteVisualOffset ( ) const
protected

Gets the absolute element visual offset.

Returns
The absolute element visual offset.

◆ GetBoundRect()

AFX_INLINE CRect GetBoundRect ( ) const

Retrieves the bounding rectangle of the element.

Returns
A CRect object containing the bounding rectangle of the element.

◆ GetLayoutClip()

virtual BOOL GetLayoutClip ( CRect & rc ) const
virtual

Retrieves an alternative clipping geometry that represents the region that would be clipped if child elements were clipped inside element bounds.

Parameters
rc The available size provided by the element.
Returns
The potential clipping geometry.

Reimplemented in CXTPMarkupUIElement.

◆ GetLogicalChild()

virtual CXTPMarkupObject * GetLogicalChild ( int nIndex ) const
virtual

Retrieves the logical child element located at a specified index within the parent collection.

Parameters
nIndex Specified index within the parent collection.
Returns
The logical child element located at the specified index within the parent collection.

Logical children allow you to iterate over child elements. This is useful for elements that may not have a defined, dedicated collection, but still contain more than one child element.

◆ GetLogicalChildrenCount()

virtual int GetLogicalChildrenCount ( ) const
virtual

Retrieves the number of logical child elements of this object.

Returns
The number of logical child elements of this object.

◆ GetOpacity()

virtual double GetOpacity ( ) const
protectedvirtual

Gets either the default or explicitly set opacity factor value.

Returns
An opacity factor value in the range 0..1.

Reimplemented in CXTPMarkupUIElement.

◆ GetRenderSize()

AFX_INLINE CSize GetRenderSize ( ) const

Gets the final render size of this element.

Returns
The final render size of this element.

◆ GetUpdateRect()

CRect GetUpdateRect ( ) const

Computes the update rectangle.

Returns
The update rectangle.

◆ GetVisualChild()

virtual CXTPMarkupVisual * GetVisualChild ( int nIndex ) const
virtual

Retrieves the child Visual object located at a specified index within the parent VisualCollection.

Parameters
nIndex Specified index within the parent VisualCollection.
Returns
The child Visual object located at the specified index within the parent VisualCollection.

◆ GetVisualChildrenCount()

virtual int GetVisualChildrenCount ( ) const
virtual

Gets the number of child elements for the Visual.

By default, a Visual has no children. Therefore, the default implementation always returns 0.

Returns
The number of child elements for the Visual.

◆ GetVisualOffset()

AFX_INLINE CPoint GetVisualOffset ( ) const

Gets or sets the offset value of the visual object.

Returns
The offset value of the visual object.

◆ GetVisualParent()

CXTPMarkupVisual * GetVisualParent ( ) const

Gets the Visual tree parent of the Visual object.

Returns
The Visual tree parent of the Visual object.

◆ InputHitTest()

CXTPMarkupInputElement * InputHitTest ( CPoint point ) const

Determines if a point belongs to this object.

Parameters
point Point to test.
Returns
The CXTPMarkupInputElement at the specified point, if any, otherwise NULL.

◆ InputHitTestOverride()

virtual CXTPMarkupInputElement * InputHitTestOverride ( CPoint point ) const
protectedvirtual

Override this method in the derived class to provide visual hit testing of a child object.

Parameters
point Position of the cursor to test.
Returns
The CXTPMarkupInputElement at the specified position, if any, otherwise NULL.

◆ IsVisible()

virtual BOOL IsVisible ( ) const
protectedvirtual

Checks if the element is currently visible.

Returns
TRUE if visible, FALSE otherwise.

Reimplemented in CXTPMarkupUIElement.

◆ OnRender()

AFX_INLINE void OnRender ( CXTPMarkupDrawingContext * drawingContext )
protectedvirtual

When overridden in a derived class, participates in rendering operations that are directed by the layout system.

Parameters
drawingContext Drawing context to draw in.

◆ OnRenderFocusVisual()

AFX_INLINE void OnRenderFocusVisual ( CXTPMarkupDrawingContext * drawingContext )
protectedvirtual

This method is called to render the focus rectangle of a focused object.

Parameters
drawingContext Drawing context to draw in.

◆ PtInRectTransform()

BOOL PtInRectTransform | ( | const RECT & | rect,
 |  | const POINT & | point ) const
 protected

Checks if a point is inside a rectangle with transformation applied.

Parameters
rect | Rectangle relative to object position.
point | Point to check.
Returns
TRUE if the point is inside the specified rectangle.

◆ Render()

void Render ( CXTPMarkupDrawingContext * drawingContext )

Call this method to draw a Visual object inside a drawing context.

Parameters
drawingContext Drawing context to draw in.

◆ RenderClipped()

virtual void RenderClipped ( CXTPMarkupDrawingContext * drawingContext )
protectedvirtual

Called by the framework when an element is clipped and no rendering will occur.

Parameters
drawingContext Pointer to the markup drawing context.

◆ RestoreRenderTransform()

AFX_INLINE void RestoreRenderTransform | ( | CXTPMarkupDrawingContext * | pContext,
 |  | TransformationMatrices & | matrices )
 protectedvirtual

Restores a previously applied render transformation.

Parameters
pContext | Drawing context to restore the render transformation for.
matrices | Transformation matrices previously returned by a call to ApplyRenderTransform.

Reimplemented in CXTPMarkupUIElement.

The documentation for this class was generated from the following file:
  • XTPMarkupInputElement.h


Toolkit Pro: CXTPMarkupVisual::TransformationMatrices Struct Reference

  • CXTPMarkupVisual
  • TransformationMatrices
Public Member Functions | Public Attributes | List of all members
CXTPMarkupVisual::TransformationMatrices Struct Reference

A structure that optionally describes the previous and the new transformation matrices. More...

Public Member Functions

TransformationMatrices ()
Constructs an empty object.
TransformationMatrices (CXTPMarkupTransformationMatrix *pOldMatrix, CXTPMarkupTransformationMatrix *pNewMatrix)
Constructs an object with specified old and new tranformation matrices.

Public Attributes

CXTPMarkupTransformationMatrix * | pOldMatrix
A pointer to an old tranformation matrix.
CXTPMarkupTransformationMatrix * | pNewMatrix
A pointer to a new tranformation matrix.

Detailed Description

A structure that optionally describes the previous and the new transformation matrices.

Constructor & Destructor Documentation

◆ TransformationMatrices()

AFX_INLINE TransformationMatrices | ( | CXTPMarkupTransformationMatrix * | pOldMatrix,
 |  | CXTPMarkupTransformationMatrix * | pNewMatrix )

Constructs an object with specified old and new tranformation matrices.

Parameters
pOldMatrix | A pointer to an old tranformation matrix.
pNewMatrix | A pointer to a new tranformation matrix.
The documentation for this struct was generated from the following file:
  • XTPMarkupInputElement.h


Toolkit Pro: CXTPMarkupWrapPanel Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPMarkupWrapPanel Class Reference

CXTPMarkupWrapPanel is a CXTPMarkupPanel derived class. More...

Inheritance diagram for CXTPMarkupWrapPanel:
[legend]

Public Member Functions

void | SetOrientation (XTPMarkupOrientation orientation)
Sets the orientation of child elements inside WrapPanel.
XTPMarkupOrientation | GetOrientation () const
Retrieves the current orientation of child elements inside WrapPanel.
- Public Member Functions inherited from CXTPMarkupPanel
CXTPMarkupUIElementCollection * | GetChildren () const
Retrieves the collection of child elements.
void | SetBackground (CXTPMarkupBrush *pBrush)
Sets the background brush for the panel object.
CXTPMarkupBrush * | GetBackground () const
Gets the background brush of the panel object.
- Public Member Functions inherited from CXTPMarkupFrameworkElement
void | SetMargin (int nLeft, int nTop, int nRight, int nBottom)
Call this method to set the outer margin of an element.
void | SetMargin (int nMargin)
Call this method to set the outer margin of an element.
CXTPMarkupThickness * | GetMargin () const
Call this method to get the outer margin of an element.
void | SetMinWidth (int nWidth)
Sets the minimum width constraint for the element.
void | SetMaxWidth (int nWidth)
Sets the maximum width constraint for the element.
void | SetWidth (int nWidth)
Sets the width for the element.
void | SetMinHeight (int nHeight)
Sets the minimum height constraint for the element.
void | SetMaxHeight (int nHeight)
Sets the maximum height constraint for the element.
void | SetHeight (int nHeight)
Sets the height for the element.
int | GetMinWidth () const
Gets the minimum width constraint of the element.
int | GetMaxWidth () const
Gets the maximum width constraint of the element.
int | GetWidth () const
Gets the width of the element.
int | GetMinHeight () const
Gets the minimum height constraint of the element.
int | GetMaxHeight () const
Gets the maximum height constraint of the element.
int | GetHeight () const
Gets the height of the element.
CXTPMarkupObject * | GetTag () const
Gets the tag object of the element.
void | SetTag (CXTPMarkupObject *pTag)
Sets the tag object for the element.
void | SetHorizontalAlignment (XTPMarkupHorizontalAlignment alignment)
Sets the horizontal alignment characteristics applied to this element when it is composed within a parent element (e.g.
void | SetVerticalAlignment (XTPMarkupVerticalAlignment alignment)
Sets the vertical alignment characteristics applied to this element when it is composed within a parent element (e.g.
XTPMarkupHorizontalAlignment | GetHorizontalAlignment () const
Gets the horizontal alignment characteristics applied to this element when it is composed within a parent element (e.g.
XTPMarkupVerticalAlignment | GetVerticalAlignment () const
Gets the vertical alignment characteristics applied to this element when it is composed within a parent element (e.g.
CSize | GetActualSize () const
Retrieves the actual size of the element after it is measured and arranged within a parent element (e.g.
void | SetClipToBounds (BOOL bClipToBounds)
Specifies if child elements should be clipped inside element bounds.
BOOL | GetClipToBounds () const
Determines if child elements are clipped inside element bounds.
CXTPMarkupStyle * | GetStyle () const
Gets the attached style of the element.
- Public Member Functions inherited from CXTPMarkupUIElement
void | Arrange (CRect rcFinalRect)
Positions child elements and determines a size for a CXTPMarkupUIElement.
void | Measure (CXTPMarkupDrawingContext *pDC, CSize szAvailableSize)
Updates the DesiredSize of a CXTPMarkupUIElement.
CSize | GetDesiredSize () const
Gets the size that this element computed during the measure pass of the layout process.
CRect | GetFinalRect () const
Gets the final render size of this element.
XTPMarkupVisibility | GetVisibility () const
Gets the user interface (UI) visibility of this element.
void | SetVisibility (XTPMarkupVisibility visibility)
Sets the user interface (UI) visibility of this element.
BOOL | IsFocusable () const
Gets or sets a value indicating whether this element can receive focus.
virtual BOOL | IsVisible () const
Gets a value indicating whether this element is visible in the user interface (UI).
BOOL | IsEnabled () const
Gets or sets a value indicating whether this element is enabled in the user interface (UI).
virtual void | InvalidateArrange ()
Invalidates the arrange state (layout) for the element.
virtual void | InvalidateVisual ()
Invalidates the rendering of the element, and forces a new complete layout pass.
virtual void | InvalidateMeasure ()
Invalidates the measurement state (layout) for the element.
- Public Member Functions inherited from CXTPMarkupVisual
CXTPMarkupVisual ()
Provides the base initialization for objects derived from the CXTPMarkupVisual class.
virtual | ~CXTPMarkupVisual ()
Destroys a CXTPMarkupVisual object, handles cleanup and deallocation.
void | Render (CXTPMarkupDrawingContext *drawingContext)
Call this method to draw a Visual object inside a drawing context.
CXTPMarkupInputElement * | InputHitTest (CPoint point) const
Determines if a point belongs to this object.
virtual int | GetVisualChildrenCount () const
Gets the number of child elements for the Visual.
virtual CXTPMarkupVisual * | GetVisualChild (int nIndex) const
Retrieves the child Visual object located at a specified index within the parent VisualCollection.
virtual int | GetLogicalChildrenCount () const
Retrieves the number of logical child elements of this object.
virtual CXTPMarkupObject * | GetLogicalChild (int nIndex) const
Retrieves the logical child element located at a specified index within the parent collection.
CRect | GetBoundRect () const
Retrieves the bounding rectangle of the element.
CRect | GetUpdateRect () const
Computes the update rectangle.
CSize | GetRenderSize () const
Gets the final render size of this element.
CPoint | GetVisualOffset () const
Gets or sets the offset value of the visual object.
CXTPMarkupVisual * | GetVisualParent () const
Gets the Visual tree parent of the Visual object.

Protected Member Functions

CXTPMarkupWrapPanel ()
Constructs a CXTPMarkupWrapPanel object.
virtual | ~CXTPMarkupWrapPanel ()
Destroys a CXTPMarkupWrapPanel object, handles cleanup and deallocation.
- Protected Member Functions inherited from CXTPMarkupPanel
CXTPMarkupPanel ()
Constructs a CXTPMarkupPanel object.
virtual | ~CXTPMarkupPanel ()
Destroys a CXTPMarkupPanel object, handles cleanup and deallocation.
- Protected Member Functions inherited from CXTPMarkupFrameworkElement
CXTPMarkupFrameworkElement ()
Initializes a new instance of the CXTPMarkupFrameworkElement class.
virtual | ~CXTPMarkupFrameworkElement ()
Destroys a CXTPMarkupFrameworkElement object, handles cleanup and deallocation.
- Protected Member Functions inherited from CXTPMarkupUIElement
CXTPMarkupUIElement ()
Initializes a new instance of the CXTPMarkupUIElement class.
virtual | ~CXTPMarkupUIElement ()
Destroys a CXTPMarkupUIElement object, handles cleanup and deallocation.
CXTPMarkupRenderTransform * | GetRenderTransform () const
Obtains a pointer to the RenderTransform object.
virtual void | ArrangeCore (CRect rcFinalRect)
Defines the template for the core-level arrange layout definition.
virtual CSize | MeasureCore (CXTPMarkupDrawingContext *pDC, CSize szAvailableSize)
When overridden in a derived class, provides measurement logic for sizing this element properly with consideration of the size of any child element content.
virtual BOOL | GetLayoutClip (CRect &rc) const
Retrieves an alternative clipping geometry that represents the region that would be clipped if child elements were clipped inside element bounds.
virtual void | InvalidateMeasureOverride (CXTPMarkupDrawingContext *pDC)
Override this method to provide a custom reaction to an InvalidateMeasure call.
virtual TransformationMatrices | ApplyRenderTransform (CXTPMarkupDrawingContext *pContext)
Applies render transformation if necessary.
virtual void | RestoreRenderTransform (CXTPMarkupDrawingContext *pContext, TransformationMatrices &matrices)
Restores a previously applied render transformation.
virtual double | GetOpacity () const
Gets either the default or explicitly set opacity factor value.
- Protected Member Functions inherited from CXTPMarkupVisual
BOOL | PtInRectTransform (const RECT &rect, const POINT &point) const
Checks if a point is inside a rectangle with transformation applied.
POINT | GetAbsoluteVisualOffset () const
Gets the absolute element visual offset.
virtual void | OnRender (CXTPMarkupDrawingContext *drawingContext)
When overridden in a derived class, participates in rendering operations that are directed by the layout system.
virtual void | OnRenderFocusVisual (CXTPMarkupDrawingContext *drawingContext)
This method is called to render the focus rectangle of a focused object.
virtual CXTPMarkupInputElement * | InputHitTestOverride (CPoint point) const
Override this method in the derived class to provide visual hit testing of a child object.
virtual void | RenderClipped (CXTPMarkupDrawingContext *drawingContext)
Called by the framework when an element is clipped and no rendering will occur.

Additional Inherited Members

- Static Public Attributes inherited from CXTPMarkupUIElement
static CXTPMarkupDependencyProperty * | m_pClipToBoundsProperty
Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element.
static CXTPMarkupDependencyProperty * | m_pVisibilityProperty
A value indicating whether this element is visible in the user interface (UI).
static CXTPMarkupDependencyProperty * | m_pFocusableProperty
A value that indicates whether the element can receive focus.
static CXTPMarkupDependencyProperty * | m_pIsEnabledProperty
A value indicating whether thiselement is enabled in the user interface (UI).
static CXTPMarkupDependencyProperty * | m_pRenderTransformProperty
Gets or sets transform information that affects the rendering position of this element.
static CXTPMarkupDependencyProperty * | m_pRenderTransformOriginProperty
Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element.
static CXTPMarkupDependencyProperty * | m_pOpacityProperty
Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI).
- Protected Attributes inherited from CXTPMarkupUIElement
CSize | m_szDesiredSize
Gets the size that this element computed during the measure pass of the layout process.
CRect | m_rcFinalRect
Final position of the visual element.
BOOL | m_bMeasureDirty
TRUE if object hasn't recalculated its size.
BOOL | m_bNeverMeasured
TRUE if object has never ran Measure to update its size.
CSize | m_szPreviousAvailableSize
Previous available size of measure call.
BOOL | m_bArrangeDirty
TRUE if object position can be invalid.
BOOL | m_bNeverArranged
TRUE if Arrange was never called for this object.
BOOL | m_bArrangeInProgress
TRUE if Arrange is currently executed.
BOOL | m_bMeasureInProgress
TRUE if Measure is currently executed.
- Protected Attributes inherited from CXTPMarkupVisual
CPoint | m_ptVisualOffset
The offset value of the visual object.
CSize | m_szRenderSize
The rendered size for this element.
CRect | m_rcBoundRect
Bounding rectangle of the element.
CRect | m_rcUpdateRect
Update rectangle.
CRect | m_rcPrevUpdateRect
Previous update rectangle.

Detailed Description

CXTPMarkupWrapPanel is a CXTPMarkupPanel derived class.

It implements the WrapPanel XAML Tag.

Member Function Documentation

◆ GetOrientation()

XTPMarkupOrientation GetOrientation ( ) const

Retrieves the current orientation of child elements inside WrapPanel.

Returns
An XTPMarkupOrientation enumeration value; xtpMarkupOrientationHorizontal if elements are positioned horizontally, xtpMarkupOrientationVertical if elements are positioned vertically.

◆ SetOrientation()

void SetOrientation ( XTPMarkupOrientation orientation )

Sets the orientation of child elements inside WrapPanel.

Parameters
orientation An XTPMarkupOrientation enumeration value; xtpMarkupOrientationHorizontal to position elements horizontally, xtpMarkupOrientationVertical to position elements vertically.
The documentation for this class was generated from the following file:
  • XTPMarkupWrapPanel.h


Toolkit Pro: CXTPMarkupXtpScript Class Reference

Public Member Functions | List of all members
CXTPMarkupXtpScript Class Reference

Contains a code in the script language chosen. More...

Inheritance diagram for CXTPMarkupXtpScript:
[legend]

Public Member Functions

LPCWSTR | GetLanguage () const
Obtains the script language name, which is the same as the script language AppID.
LPCWSTR | GetSource () const
Obtains the referenced script location.
LPCWSTR | GetRequires () const
Obtains the comma separated list of requirements.
virtual void | SetContentObject (CXTPMarkupBuilder *pBuilder, CXTPMarkupObject *pContent)
Sets the script code.

Additional Inherited Members

- Protected Member Functions inherited from CXTPMarkupExtension
CXTPMarkupExtension ()
Constructs markup extension object.

Detailed Description

Contains a code in the script language chosen.

Member Function Documentation

◆ GetLanguage()

LPCWSTR GetLanguage ( ) const

Obtains the script language name, which is the same as the script language AppID.

Returns
The script language name.

◆ GetRequires()

LPCWSTR GetRequires ( ) const

Obtains the comma separated list of requirements.

Returns
The list of requirements.

◆ GetSource()

LPCWSTR GetSource ( ) const

Obtains the referenced script location.

Returns
The referenced script location.

◆ SetContentObject()

virtual void SetContentObject | ( | CXTPMarkupBuilder * | pBuilder,
 |  | CXTPMarkupObject * | pContent )
 virtual

Sets the script code.

Parameters
pBuilder | Pointer to a CXTPMarkupBuilder object that runs script engine.
pContent | Pointer to a CXTPMarkupObject object that represents the code.
The documentation for this class was generated from the following file:
  • XTPMarkupXtpScript.h


Toolkit Pro: CXTPMarqueeCtrl Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPMarqueeCtrl Class Reference

CXTPMarqueeCtrl is a CProgressCtrl derived class. More...

Public Member Functions

CXTPMarqueeCtrl ()
Constructs a CXTPMarqueeCtrl object.
virtual | ~CXTPMarqueeCtrl ()
Destroys a CXTPMarqueeCtrl object, handles cleanup and deallocation.
CXTPMarqueeCtrlPaintManager * | GetPaintManager () const
This member function obtains a pointer to the associated paint manager object.
void | SetTheme (CXTPMarqueeCtrlPaintManager *pPaintManager=NULL)
This member function sets the new control drawing theme.
void | SetTheme (XTPControlTheme nTheme)
Call this member to switch the visual theme of the control.
void | RefreshMetrics ()
This member is called to update the color and chunk bitmaps used by the marquee progress control.
void | SetMarquee (BOOL bMarqueeMode=TRUE, int nInterval=50, int nGap=2, int cx=12, int *piTrans=NULL)
Turns marquee mode on/off for the current progress bar control.
BOOL | IsSmooth ()
Determines if the PBS_SMOOTH style has been set for the marquee progress bar.
BOOL | IsVertical ()
Determines if the PBS_VERTICAL style has been set for the marquee progress bar.
BOOL | IsMarquee ()
Determines if the PBS_MARQUEE style has been set for the marquee progress bar.
void | SetColors (COLORREF crBack, COLORREF crChunk)
This member function sets the background and progress indicator colors for the progress bar.

Protected Member Functions

virtual BOOL | OnInitControl ()
This member function is called when the progress bar has been created or subclassed.
virtual BOOL | UseWinThemes ()
This member function is called to determine if Windows themes are enabled for the calling application.

Protected Attributes

int | m_nGap
Size in pixels between each chunk in the marquee.
int | m_nPos
Current position of the marquee animation.
int | m_cxChunk
Size in pixels of each chunk in the marquee.
BYTE | m_chAlpha [5]
Represents the transparency for each chunk in the marquee.
BOOL | m_bIsSubclassed
TRUE if the progress bar was subclassed.
CXTPMarqueeCtrlPaintManager * | m_pPaintManager
progress.

Detailed Description

CXTPMarqueeCtrl is a CProgressCtrl derived class.

It is used to create a customizable Marquee style progress control. Using the SetMarquee method, you can set the speed, gap between marquee chunks, width, and transparency for each chunk. See the sample located in the Controls/MarqueeProgress for more details.

Member Function Documentation

◆ GetPaintManager()

CXTPMarqueeCtrlPaintManager * GetPaintManager ( ) const

This member function obtains a pointer to the associated paint manager object.

The paint manager object is used for drawing the date picker window.

Returns
Pointer to the associated paint manager object.
See also
SetTheme, SetPaintManager

◆ IsMarquee()

BOOL IsMarquee ( )

Determines if the PBS_MARQUEE style has been set for the marquee progress bar.

Returns
TRUE if the progress bar has PBS_MARQUEE style set, otherwise FALSE.

◆ IsSmooth()

BOOL IsSmooth ( )

Determines if the PBS_SMOOTH style has been set for the marquee progress bar.

Returns
TRUE if the progress bar has PBS_SMOOTH style set, otherwise FALSE.

◆ IsVertical()

BOOL IsVertical ( )

Determines if the PBS_VERTICAL style has been set for the marquee progress bar.

Returns
TRUE if the progress bar has PBS_VERTICAL style set, otherwise FALSE.

◆ OnInitControl()

virtual BOOL OnInitControl ( )
protectedvirtual

This member function is called when the progress bar has been created or subclassed.

Returns
TRUE if the control has been successfully initialized, otherwise FALSE.

◆ SetColors()

void SetColors | ( | COLORREF | crBack,
 |  | COLORREF | crChunk )

This member function sets the background and progress indicator colors for the progress bar.

Parameters
crBack | A COLORREF value that specifies the new background color.
crChunk | A COLORREF value that specifies the new progress indicator bar color.

◆ SetMarquee()

void SetMarquee | ( | BOOL | bMarqueeMode = TRUE,
 |  | int | nInterval = 50,
 |  | int | nGap = 2,
 |  | int | cx = 12,
 |  | int * | piTrans = NULL )

Turns marquee mode on/off for the current progress bar control.

Parameters
bMarqueeMode | TRUE to turn marquee mode on, FALSE to turn marquee mode off.
nInterval | Time in milliseconds between updates of the marquee animation.
nGap | Size in pixels of the gap between each chunk displayed in the marquee progress bar.
cx | Size in pixels of each chunk displayed in the marquee progress bar.
piTrans Array of 5 integers representing the amount of transparency for each chunk displayed in the marquee progress bar as a percent ranging from 0 to 100. This method assumes that the array contains 5 integers. Example: The following code example starts and stops the marquee scrolling animation:
int piAlpha[5] = { 25, 50, 75, 100, 100 };
m_wndProgress.SetMarquee(TRUE, 50, 2, 12, piAlpha);

◆ SetTheme() [1/2]

void SetTheme ( CXTPMarqueeCtrlPaintManager * pPaintManager = NULL )

This member function sets the new control drawing theme.

Parameters
pPaintManager Pointer to the new paint manager object or derived class. If NULL, then the default paint manager object is set.

Call this member function to set the paint manager object that is used for drawing a date picker window.

See also
GetPaintManager

◆ SetTheme() [2/2]

void SetTheme ( XTPControlTheme nTheme )

Call this member to switch the visual theme of the control.

Parameters
nTheme New visual theme. Can be any of the values listed in the Remarks section.

nStyle can be one of the following: xtpControlThemeDefault: Standard appearance style. xtpControlThemeFlat: Flat appearance style. xtpControlThemeUltraFlat: Ultra flat appearance style. xtpControlThemeOffice2000: Office 2000 appearance style. xtpControlThemeOfficeXP: Office XP appearance style. xtpControlThemeOffice2003: Office 2003 appearance style. xtpControlThemeResource: Office 2007 appearance style.

◆ UseWinThemes()

virtual BOOL UseWinThemes ( )
protectedvirtual

This member function is called to determine if Windows themes are enabled for the calling application.

Returns
TRUE if Windows themes are enabled, otherwise FALSE.
The documentation for this class was generated from the following file:
  • XTPMarqueeCtrl.h


Toolkit Pro: CXTPMarqueeCtrlPaintManager Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPMarqueeCtrlPaintManager Class Reference

The CXTPMarqueeCtrlPaintManager class is derived from CCmdTarget and is used by the progress bar to perform all default drawing routines. More...

Inheritance diagram for CXTPMarqueeCtrlPaintManager:
[legend]

Public Member Functions

CXTPMarqueeCtrlPaintManager ()
Default paint manager constructor.
virtual | ~CXTPMarqueeCtrlPaintManager ()
Default paint manager destructor.
virtual void | RefreshMetrics ()
This member function performs initialization for the Paint Manager.
virtual void | DrawBackground (CXTPMarqueeCtrl *pWndCtrl, CDC *pDC, CRect &rcClient)
This member function is called by the progress bar to draw the non-client borders.
virtual void | DrawMarquee (CXTPMarqueeCtrl *pWndCtrl, CDC *pDC, CRect &rcClient)
This member function is called by the progress bar to draw the client area of the control.
BOOL | UsingWinThemes (BOOL bCheckReady=FALSE)
Used by the progress bar to determine if Windows themes should be used to draw the control.
void | UseWinThemes (BOOL bUseWinThemes=TRUE)
Call this member function to draw the control using the current Windows theme.
COLORREF | SetBorderColor (COLORREF clrNew)
This member function sets the border color for the progress bar.
COLORREF | SetBarColor (COLORREF clrNew)
This member function sets the bar color for the progress bar.
COLORREF | SetBackColor (COLORREF clrNew)
This member function sets the background color for the progress bar.
COLORREF | GetBorderColor ()
This member function gets the border color for the progress bar.
COLORREF | GetBarColor ()
This member function gets the bar color for the progress bar.
COLORREF | GetBackColor ()
This member function gets the background color for the progress bar.

Protected Member Functions

virtual void | DeflateRect (CDC *pDC, CRect &rcClient)
This member function is called by the progress bar to adjust the bar drawing size; can be overridden in derived classes.
virtual void | DrawChunk (CXTPMarqueeCtrl *pWndCtrl, CDC *pDC, CXTPCompatibleDC &dcChunk, int i, int &x, int &y, int cx, int cy)
This member function is called by the progress bar to draw a section of the progress indicator.

Protected Attributes

BOOL | m_bUseWinTheme
TRUE when using Windows themes.
XTPControlTheme | m_nTheme
Theme identifier.
CXTPWinThemeWrapper | m_winTheme
Wrapper used when drawing Windows themes.
CXTPPaintManagerColor | m_clr3DHilite
An RGB value representing the border color.
CXTPPaintManagerColor | m_clr3DShadow
An RGB value representing the border color.
CXTPPaintManagerColor | m_clrBar
An RGB value representing the bar color.
CXTPPaintManagerColor | m_clrBack
An RGB value representing the back color.

Detailed Description

The CXTPMarqueeCtrlPaintManager class is derived from CCmdTarget and is used by the progress bar to perform all default drawing routines.

Constructor & Destructor Documentation

◆ CXTPMarqueeCtrlPaintManager()

CXTPMarqueeCtrlPaintManager ( )

Default paint manager constructor.

Handles initial initialization.

See also
RefreshMetrics()

◆ ~CXTPMarqueeCtrlPaintManager()

virtual ~CXTPMarqueeCtrlPaintManager ( )
virtual

Default paint manager destructor.

Handles cleanup and deallocation.

Member Function Documentation

◆ DeflateRect()

virtual void DeflateRect | ( | CDC * | pDC,
 |  | CRect & | rcClient )
 protectedvirtual

This member function is called by the progress bar to adjust the bar drawing size; can be overridden in derived classes.

Parameters
pDC | Points to the device context used for drawing.
rcClient | Represents client area to draw.
See also
XTPPROGRESSDRAWSTRUCT

Reimplemented in CXTPMarqueeCtrlThemeFlat, CXTPMarqueeCtrlThemeNativeWindows, and CXTPMarqueeCtrlThemeNativeWinXP.

◆ DrawBackground()

virtual void DrawBackground | ( | CXTPMarqueeCtrl * | pWndCtrl,
 |  | CDC * | pDC,
 |  | CRect & | rcClient )
 virtual

This member function is called by the progress bar to draw the non-client borders.

Parameters
pWndCtrl | Points to a CXTPMarqueeCtrl object.
pDC | Pointer to a valid device context.
rcClient | Size of the non-client border area.

Reimplemented in CXTPMarqueeCtrlThemeResource.

◆ DrawChunk()

virtual void DrawChunk | ( | CXTPMarqueeCtrl * | pWndCtrl,
 |  | CDC * | pDC,
 |  | CXTPCompatibleDC & | dcChunk,
 |  | int | i,
 |  | int & | x,
 |  | int & | y,
 |  | int | cx,
 |  | int | cy )
 protectedvirtual

This member function is called by the progress bar to draw a section of the progress indicator.

Parameters
pWndCtrl | Points to the CXTPMarqueeCtrl object.
pDC | Points to the device context used for drawing.
dcChunk | Reference to a CXTPCompatibleDC device context.
i | Index value for the item drawn.
x | Left position.
y | Top position.
cx | Item width.
cy | Item height.

Reimplemented in CXTPMarqueeCtrlThemeResource.

◆ DrawMarquee()

virtual void DrawMarquee | ( | CXTPMarqueeCtrl * | pWndCtrl,
 |  | CDC * | pDC,
 |  | CRect & | rcClient )
 virtual

This member function is called by the progress bar to draw the client area of the control.

Parameters
pWndCtrl | Points to a CXTPMarqueeCtrl object.
pDC | Pointer to a valid device context.
rcClient | Size of the non-client border area.
See also
XTPPROGRESSDRAWSTRUCT

Reimplemented in CXTPMarqueeCtrlThemeFlat.

◆ GetBackColor()

COLORREF GetBackColor ( )

This member function gets the background color for the progress bar.

Returns
The COLORREF value used for the background.

◆ GetBarColor()

COLORREF GetBarColor ( )

This member function gets the bar color for the progress bar.

Returns
The COLORREF value used for the bar.

◆ GetBorderColor()

COLORREF GetBorderColor ( )

This member function gets the border color for the progress bar.

Returns
The COLORREF value used for the border.

◆ RefreshMetrics()

virtual void RefreshMetrics ( )
virtual

This member function performs initialization for the Paint Manager.

Initializes all drawing defaults (fonts, colors, etc.).

Reimplemented in CXTPMarqueeCtrlThemeFlat, CXTPMarqueeCtrlThemeOffice2000, CXTPMarqueeCtrlThemeOffice2003, CXTPMarqueeCtrlThemeOffice2013, CXTPMarqueeCtrlThemeOfficeXP, and CXTPMarqueeCtrlThemeUltraFlat.

◆ SetBackColor()

COLORREF SetBackColor ( COLORREF clrNew )

This member function sets the background color for the progress bar.

Parameters
clrNew A COLORREF value that specifies the new background color.
Returns
The COLORREF value used for the background.

◆ SetBarColor()

COLORREF SetBarColor ( COLORREF clrNew )

This member function sets the bar color for the progress bar.

Parameters
clrNew A COLORREF value that specifies the new bar color.
Returns
The COLORREF value used for the bar.

◆ SetBorderColor()

COLORREF SetBorderColor ( COLORREF clrNew )

This member function sets the border color for the progress bar.

Parameters
clrNew A COLORREF value that specifies the new border color.
Returns
The COLORREF value used for the border.

◆ UseWinThemes()

void UseWinThemes ( BOOL bUseWinThemes = TRUE )

Call this member function to draw the control using the current Windows theme.

This will override any themes currently set.

Parameters
bUseWinThemes TRUE to enable Windows themes.

◆ UsingWinThemes()

BOOL UsingWinThemes ( BOOL bCheckReady = FALSE )

Used by the progress bar to determine if Windows themes should be used to draw the control.

Parameters
bCheckReady TRUE to perform an additional check IsAppThemeReady().
Returns
TRUE if the progress bar is drawn using default Windows themes.
The documentation for this class was generated from the following file:
  • XTPMarqueeCtrlPaintManager.h


Toolkit Pro: CXTPMarqueeCtrlThemeFlat Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPMarqueeCtrlThemeFlat Class Reference

The CXTPMarqueeCtrlThemeFlat class is derived from CXTPMarqueeCtrlPaintManager and is used by the progress bar to draw a flat style progress bar. More...

Inheritance diagram for CXTPMarqueeCtrlThemeFlat:
[legend]

Public Member Functions

CXTPMarqueeCtrlThemeFlat ()
Default paint manager constructor.
virtual void | RefreshMetrics ()
This member function performs initialization for the Paint Manager.
- Public Member Functions inherited from CXTPMarqueeCtrlPaintManager
CXTPMarqueeCtrlPaintManager ()
Default paint manager constructor.
virtual | ~CXTPMarqueeCtrlPaintManager ()
Default paint manager destructor.
virtual void | DrawBackground (CXTPMarqueeCtrl *pWndCtrl, CDC *pDC, CRect &rcClient)
This member function is called by the progress bar to draw the non-client borders.
BOOL | UsingWinThemes (BOOL bCheckReady=FALSE)
Used by the progress bar to determine if Windows themes should be used to draw the control.
void | UseWinThemes (BOOL bUseWinThemes=TRUE)
Call this member function to draw the control using the current Windows theme.
COLORREF | SetBorderColor (COLORREF clrNew)
This member function sets the border color for the progress bar.
COLORREF | SetBarColor (COLORREF clrNew)
This member function sets the bar color for the progress bar.
COLORREF | SetBackColor (COLORREF clrNew)
This member function sets the background color for the progress bar.
COLORREF | GetBorderColor ()
This member function gets the border color for the progress bar.
COLORREF | GetBarColor ()
This member function gets the bar color for the progress bar.
COLORREF | GetBackColor ()
This member function gets the background color for the progress bar.

Protected Member Functions

virtual void | DeflateRect (CDC *pDC, CRect &rcClient)
This member function is called by the progress bar to adjust the bar drawing size; can be overridden in derived classes.
virtual void | DrawMarquee (CXTPMarqueeCtrl *pWndCtrl, CDC *pDC, CRect &rcClient)
This member function is called by the progress bar to draw the client area of the control.
- Protected Member Functions inherited from CXTPMarqueeCtrlPaintManager
virtual void | DrawChunk (CXTPMarqueeCtrl *pWndCtrl, CDC *pDC, CXTPCompatibleDC &dcChunk, int i, int &x, int &y, int cx, int cy)
This member function is called by the progress bar to draw a section of the progress indicator.

Additional Inherited Members

- Protected Attributes inherited from CXTPMarqueeCtrlPaintManager
BOOL | m_bUseWinTheme
TRUE when using Windows themes.
XTPControlTheme | m_nTheme
Theme identifier.
CXTPWinThemeWrapper | m_winTheme
Wrapper used when drawing Windows themes.
CXTPPaintManagerColor | m_clr3DHilite
An RGB value representing the border color.
CXTPPaintManagerColor | m_clr3DShadow
An RGB value representing the border color.
CXTPPaintManagerColor | m_clrBar
An RGB value representing the bar color.
CXTPPaintManagerColor | m_clrBack
An RGB value representing the back color.

Detailed Description

The CXTPMarqueeCtrlThemeFlat class is derived from CXTPMarqueeCtrlPaintManager and is used by the progress bar to draw a flat style progress bar.

Constructor & Destructor Documentation

◆ CXTPMarqueeCtrlThemeFlat()

CXTPMarqueeCtrlThemeFlat ( )

Default paint manager constructor.

Handles initial initialization.

See also
RefreshMetrics()

Member Function Documentation

◆ DeflateRect()

virtual void DeflateRect | ( | CDC * | pDC,
 |  | CRect & | rcClient )
 protectedvirtual

This member function is called by the progress bar to adjust the bar drawing size; can be overridden in derived classes.

Parameters
pDC | Pointer to a valid device context.
rcClient | Size of the non-client border area.
See also
XTPPROGRESSDRAWSTRUCT

Reimplemented from CXTPMarqueeCtrlPaintManager.

◆ DrawMarquee()

virtual void DrawMarquee | ( | CXTPMarqueeCtrl * | pWndCtrl,
 |  | CDC * | pDC,
 |  | CRect & | rcClient )
 protectedvirtual

This member function is called by the progress bar to draw the client area of the control.

Parameters
pWndCtrl | Points to a CXTPMarqueeCtrl object.
pDC | Pointer to a valid device context.
rcClient | Size of the non-client border area.
See also
XTPPROGRESSDRAWSTRUCT

Reimplemented from CXTPMarqueeCtrlPaintManager.

◆ RefreshMetrics()

virtual void RefreshMetrics ( )
virtual

This member function performs initialization for the Paint Manager.

Initializes all drawing defaults (fonts, colors, etc.).

Reimplemented from CXTPMarqueeCtrlPaintManager.

Reimplemented in CXTPMarqueeCtrlThemeUltraFlat.

The documentation for this class was generated from the following file:
  • XTPMarqueeCtrlPaintManager.h


Toolkit Pro: CXTPMarqueeCtrlThemeNativeWindows Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPMarqueeCtrlThemeNativeWindows Class Reference

The CXTPMarqueeCtrlThemeNativeWindows class is derived from CXTPMarqueeCtrlPaintManager and is used by the progress bar to draw a native Windows style progress bar. More...

Inheritance diagram for CXTPMarqueeCtrlThemeNativeWindows:
[legend]

Public Member Functions

CXTPMarqueeCtrlThemeNativeWindows ()
Default paint manager constructor.
- Public Member Functions inherited from CXTPMarqueeCtrlPaintManager
CXTPMarqueeCtrlPaintManager ()
Default paint manager constructor.
virtual | ~CXTPMarqueeCtrlPaintManager ()
Default paint manager destructor.
virtual void | RefreshMetrics ()
This member function performs initialization for the Paint Manager.
virtual void | DrawBackground (CXTPMarqueeCtrl *pWndCtrl, CDC *pDC, CRect &rcClient)
This member function is called by the progress bar to draw the non-client borders.
virtual void | DrawMarquee (CXTPMarqueeCtrl *pWndCtrl, CDC *pDC, CRect &rcClient)
This member function is called by the progress bar to draw the client area of the control.
BOOL | UsingWinThemes (BOOL bCheckReady=FALSE)
Used by the progress bar to determine if Windows themes should be used to draw the control.
void | UseWinThemes (BOOL bUseWinThemes=TRUE)
Call this member function to draw the control using the current Windows theme.
COLORREF | SetBorderColor (COLORREF clrNew)
This member function sets the border color for the progress bar.
COLORREF | SetBarColor (COLORREF clrNew)
This member function sets the bar color for the progress bar.
COLORREF | SetBackColor (COLORREF clrNew)
This member function sets the background color for the progress bar.
COLORREF | GetBorderColor ()
This member function gets the border color for the progress bar.
COLORREF | GetBarColor ()
This member function gets the bar color for the progress bar.
COLORREF | GetBackColor ()
This member function gets the background color for the progress bar.

Protected Member Functions

virtual void | DeflateRect (CDC *pDC, CRect &rcClient)
This member function is called by the progress bar to adjust the bar drawing size; can be overridden in derived classes.
- Protected Member Functions inherited from CXTPMarqueeCtrlPaintManager
virtual void | DrawChunk (CXTPMarqueeCtrl *pWndCtrl, CDC *pDC, CXTPCompatibleDC &dcChunk, int i, int &x, int &y, int cx, int cy)
This member function is called by the progress bar to draw a section of the progress indicator.

Additional Inherited Members

- Protected Attributes inherited from CXTPMarqueeCtrlPaintManager
BOOL | m_bUseWinTheme
TRUE when using Windows themes.
XTPControlTheme | m_nTheme
Theme identifier.
CXTPWinThemeWrapper | m_winTheme
Wrapper used when drawing Windows themes.
CXTPPaintManagerColor | m_clr3DHilite
An RGB value representing the border color.
CXTPPaintManagerColor | m_clr3DShadow
An RGB value representing the border color.
CXTPPaintManagerColor | m_clrBar
An RGB value representing the bar color.
CXTPPaintManagerColor | m_clrBack
An RGB value representing the back color.

Detailed Description

The CXTPMarqueeCtrlThemeNativeWindows class is derived from CXTPMarqueeCtrlPaintManager and is used by the progress bar to draw a native Windows style progress bar.

Constructor & Destructor Documentation

◆ CXTPMarqueeCtrlThemeNativeWindows()

CXTPMarqueeCtrlThemeNativeWindows ( )

Default paint manager constructor.

Handles initial initialization.

See also
RefreshMetrics()

Member Function Documentation

◆ DeflateRect()

virtual void DeflateRect | ( | CDC * | pDC,
 |  | CRect & | rcClient )
 protectedvirtual

This member function is called by the progress bar to adjust the bar drawing size; can be overridden in derived classes.

Parameters
pDC | Pointer to a valid device context.
rcClient | Size of the non-client border area.
See also
XTPPROGRESSDRAWSTRUCT

Reimplemented from CXTPMarqueeCtrlPaintManager.

The documentation for this class was generated from the following file:
  • XTPMarqueeCtrlPaintManager.h


Toolkit Pro: CXTPMarqueeCtrlThemeNativeWinXP Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPMarqueeCtrlThemeNativeWinXP Class Reference

The CXTPMarqueeCtrlThemeNativeWinXP class is derived from CXTPMarqueeCtrlPaintManager and is used by the progress bar to draw a native Windows style progress bar. More...

Inheritance diagram for CXTPMarqueeCtrlThemeNativeWinXP:
[legend]

Public Member Functions

CXTPMarqueeCtrlThemeNativeWinXP ()
Default paint manager constructor.
- Public Member Functions inherited from CXTPMarqueeCtrlPaintManager
CXTPMarqueeCtrlPaintManager ()
Default paint manager constructor.
virtual | ~CXTPMarqueeCtrlPaintManager ()
Default paint manager destructor.
virtual void | RefreshMetrics ()
This member function performs initialization for the Paint Manager.
virtual void | DrawBackground (CXTPMarqueeCtrl *pWndCtrl, CDC *pDC, CRect &rcClient)
This member function is called by the progress bar to draw the non-client borders.
virtual void | DrawMarquee (CXTPMarqueeCtrl *pWndCtrl, CDC *pDC, CRect &rcClient)
This member function is called by the progress bar to draw the client area of the control.
BOOL | UsingWinThemes (BOOL bCheckReady=FALSE)
Used by the progress bar to determine if Windows themes should be used to draw the control.
void | UseWinThemes (BOOL bUseWinThemes=TRUE)
Call this member function to draw the control using the current Windows theme.
COLORREF | SetBorderColor (COLORREF clrNew)
This member function sets the border color for the progress bar.
COLORREF | SetBarColor (COLORREF clrNew)
This member function sets the bar color for the progress bar.
COLORREF | SetBackColor (COLORREF clrNew)
This member function sets the background color for the progress bar.
COLORREF | GetBorderColor ()
This member function gets the border color for the progress bar.
COLORREF | GetBarColor ()
This member function gets the bar color for the progress bar.
COLORREF | GetBackColor ()
This member function gets the background color for the progress bar.

Protected Member Functions

virtual void | DeflateRect (XTPPROGRESSDRAWSTRUCT &ds)
This member function is called by the progress bar to adjust the bar drawing size; can be overridden in derived classes.
virtual void | DeflateRect (CDC *pDC, CRect &rcClient)
This member function is called by the progress bar to adjust the bar drawing size; can be overridden in derived classes.
- Protected Member Functions inherited from CXTPMarqueeCtrlPaintManager
virtual void | DrawChunk (CXTPMarqueeCtrl *pWndCtrl, CDC *pDC, CXTPCompatibleDC &dcChunk, int i, int &x, int &y, int cx, int cy)
This member function is called by the progress bar to draw a section of the progress indicator.

Additional Inherited Members

- Protected Attributes inherited from CXTPMarqueeCtrlPaintManager
BOOL | m_bUseWinTheme
TRUE when using Windows themes.
XTPControlTheme | m_nTheme
Theme identifier.
CXTPWinThemeWrapper | m_winTheme
Wrapper used when drawing Windows themes.
CXTPPaintManagerColor | m_clr3DHilite
An RGB value representing the border color.
CXTPPaintManagerColor | m_clr3DShadow
An RGB value representing the border color.
CXTPPaintManagerColor | m_clrBar
An RGB value representing the bar color.
CXTPPaintManagerColor | m_clrBack
An RGB value representing the back color.

Detailed Description

The CXTPMarqueeCtrlThemeNativeWinXP class is derived from CXTPMarqueeCtrlPaintManager and is used by the progress bar to draw a native Windows style progress bar.

Constructor & Destructor Documentation

◆ CXTPMarqueeCtrlThemeNativeWinXP()

CXTPMarqueeCtrlThemeNativeWinXP ( )

Default paint manager constructor.

Handles initial initialization.

See also
RefreshMetrics()

Member Function Documentation

◆ DeflateRect() [1/2]

virtual void DeflateRect | ( | CDC * | pDC,
 |  | CRect & | rcClient )
 protectedvirtual

This member function is called by the progress bar to adjust the bar drawing size; can be overridden in derived classes.

Parameters
pDC | Points to the device context used for drawing.
rcClient | Represents client area to draw.
See also
XTPPROGRESSDRAWSTRUCT

Reimplemented from CXTPMarqueeCtrlPaintManager.

◆ DeflateRect() [2/2]

virtual void DeflateRect ( XTPPROGRESSDRAWSTRUCT & ds )
protectedvirtual

This member function is called by the progress bar to adjust the bar drawing size; can be overridden in derived classes.

Parameters
ds Struct used by the progress bar during paint operations.
See also
XTPPROGRESSDRAWSTRUCT
The documentation for this class was generated from the following file:
  • XTPMarqueeCtrlPaintManager.h


Toolkit Pro: CXTPMarqueeCtrlThemeOffice2000 Class Reference

Public Member Functions | List of all members
CXTPMarqueeCtrlThemeOffice2000 Class Reference

The CXTPMarqueeCtrlThemeFlat class is derived from CXTPMarqueeCtrlPaintManager and is used by the progress bar to draw an Office 2000 style progress bar. More...

Inheritance diagram for CXTPMarqueeCtrlThemeOffice2000:
[legend]

Public Member Functions

CXTPMarqueeCtrlThemeOffice2000 ()
Default paint manager constructor.
virtual void | RefreshMetrics ()
This member function performs initialization for the Paint Manager.
- Public Member Functions inherited from CXTPMarqueeCtrlPaintManager
CXTPMarqueeCtrlPaintManager ()
Default paint manager constructor.
virtual | ~CXTPMarqueeCtrlPaintManager ()
Default paint manager destructor.
virtual void | DrawBackground (CXTPMarqueeCtrl *pWndCtrl, CDC *pDC, CRect &rcClient)
This member function is called by the progress bar to draw the non-client borders.
virtual void | DrawMarquee (CXTPMarqueeCtrl *pWndCtrl, CDC *pDC, CRect &rcClient)
This member function is called by the progress bar to draw the client area of the control.
BOOL | UsingWinThemes (BOOL bCheckReady=FALSE)
Used by the progress bar to determine if Windows themes should be used to draw the control.
void | UseWinThemes (BOOL bUseWinThemes=TRUE)
Call this member function to draw the control using the current Windows theme.
COLORREF | SetBorderColor (COLORREF clrNew)
This member function sets the border color for the progress bar.
COLORREF | SetBarColor (COLORREF clrNew)
This member function sets the bar color for the progress bar.
COLORREF | SetBackColor (COLORREF clrNew)
This member function sets the background color for the progress bar.
COLORREF | GetBorderColor ()
This member function gets the border color for the progress bar.
COLORREF | GetBarColor ()
This member function gets the bar color for the progress bar.
COLORREF | GetBackColor ()
This member function gets the background color for the progress bar.

Additional Inherited Members

- Protected Member Functions inherited from CXTPMarqueeCtrlPaintManager
virtual void | DeflateRect (CDC *pDC, CRect &rcClient)
This member function is called by the progress bar to adjust the bar drawing size; can be overridden in derived classes.
virtual void | DrawChunk (CXTPMarqueeCtrl *pWndCtrl, CDC *pDC, CXTPCompatibleDC &dcChunk, int i, int &x, int &y, int cx, int cy)
This member function is called by the progress bar to draw a section of the progress indicator.
- Protected Attributes inherited from CXTPMarqueeCtrlPaintManager
BOOL | m_bUseWinTheme
TRUE when using Windows themes.
XTPControlTheme | m_nTheme
Theme identifier.
CXTPWinThemeWrapper | m_winTheme
Wrapper used when drawing Windows themes.
CXTPPaintManagerColor | m_clr3DHilite
An RGB value representing the border color.
CXTPPaintManagerColor | m_clr3DShadow
An RGB value representing the border color.
CXTPPaintManagerColor | m_clrBar
An RGB value representing the bar color.
CXTPPaintManagerColor | m_clrBack
An RGB value representing the back color.

Detailed Description

The CXTPMarqueeCtrlThemeFlat class is derived from CXTPMarqueeCtrlPaintManager and is used by the progress bar to draw an Office 2000 style progress bar.

Constructor & Destructor Documentation

◆ CXTPMarqueeCtrlThemeOffice2000()

CXTPMarqueeCtrlThemeOffice2000 ( )

Default paint manager constructor.

Handles initial initialization.

See also
RefreshMetrics()

Member Function Documentation

◆ RefreshMetrics()

virtual void RefreshMetrics ( )
virtual

This member function performs initialization for the Paint Manager.

Initializes all drawing defaults (fonts, colors, etc.).

Reimplemented from CXTPMarqueeCtrlPaintManager.

Reimplemented in CXTPMarqueeCtrlThemeOffice2003, CXTPMarqueeCtrlThemeOffice2013, and CXTPMarqueeCtrlThemeOfficeXP.

The documentation for this class was generated from the following file:
  • XTPMarqueeCtrlPaintManager.h


Toolkit Pro: CXTPMarqueeCtrlThemeOffice2003 Class Reference

Public Member Functions | List of all members
CXTPMarqueeCtrlThemeOffice2003 Class Reference

The CXTPMarqueeCtrlThemeFlat class is derived from CXTPMarqueeCtrlPaintManager and is used by the progress bar to draw an Office 2003 style progress bar. More...

Inheritance diagram for CXTPMarqueeCtrlThemeOffice2003:
[legend]

Public Member Functions

CXTPMarqueeCtrlThemeOffice2003 ()
Default paint manager constructor.
virtual void | RefreshMetrics ()
This member function performs initialization for the Paint Manager.
- Public Member Functions inherited from CXTPMarqueeCtrlThemeOffice2000
CXTPMarqueeCtrlThemeOffice2000 ()
Default paint manager constructor.
- Public Member Functions inherited from CXTPMarqueeCtrlPaintManager
CXTPMarqueeCtrlPaintManager ()
Default paint manager constructor.
virtual | ~CXTPMarqueeCtrlPaintManager ()
Default paint manager destructor.
virtual void | DrawBackground (CXTPMarqueeCtrl *pWndCtrl, CDC *pDC, CRect &rcClient)
This member function is called by the progress bar to draw the non-client borders.
virtual void | DrawMarquee (CXTPMarqueeCtrl *pWndCtrl, CDC *pDC, CRect &rcClient)
This member function is called by the progress bar to draw the client area of the control.
BOOL | UsingWinThemes (BOOL bCheckReady=FALSE)
Used by the progress bar to determine if Windows themes should be used to draw the control.
void | UseWinThemes (BOOL bUseWinThemes=TRUE)
Call this member function to draw the control using the current Windows theme.
COLORREF | SetBorderColor (COLORREF clrNew)
This member function sets the border color for the progress bar.
COLORREF | SetBarColor (COLORREF clrNew)
This member function sets the bar color for the progress bar.
COLORREF | SetBackColor (COLORREF clrNew)
This member function sets the background color for the progress bar.
COLORREF | GetBorderColor ()
This member function gets the border color for the progress bar.
COLORREF | GetBarColor ()
This member function gets the bar color for the progress bar.
COLORREF | GetBackColor ()
This member function gets the background color for the progress bar.

Additional Inherited Members

- Protected Member Functions inherited from CXTPMarqueeCtrlPaintManager
virtual void | DeflateRect (CDC *pDC, CRect &rcClient)
This member function is called by the progress bar to adjust the bar drawing size; can be overridden in derived classes.
virtual void | DrawChunk (CXTPMarqueeCtrl *pWndCtrl, CDC *pDC, CXTPCompatibleDC &dcChunk, int i, int &x, int &y, int cx, int cy)
This member function is called by the progress bar to draw a section of the progress indicator.
- Protected Attributes inherited from CXTPMarqueeCtrlPaintManager
BOOL | m_bUseWinTheme
TRUE when using Windows themes.
XTPControlTheme | m_nTheme
Theme identifier.
CXTPWinThemeWrapper | m_winTheme
Wrapper used when drawing Windows themes.
CXTPPaintManagerColor | m_clr3DHilite
An RGB value representing the border color.
CXTPPaintManagerColor | m_clr3DShadow
An RGB value representing the border color.
CXTPPaintManagerColor | m_clrBar
An RGB value representing the bar color.
CXTPPaintManagerColor | m_clrBack
An RGB value representing the back color.

Detailed Description

The CXTPMarqueeCtrlThemeFlat class is derived from CXTPMarqueeCtrlPaintManager and is used by the progress bar to draw an Office 2003 style progress bar.

Constructor & Destructor Documentation

◆ CXTPMarqueeCtrlThemeOffice2003()

CXTPMarqueeCtrlThemeOffice2003 ( )

Default paint manager constructor.

Handles initial initialization.

See also
RefreshMetrics()

Member Function Documentation

◆ RefreshMetrics()

virtual void RefreshMetrics ( )
virtual

This member function performs initialization for the Paint Manager.

Initializes all drawing defaults (fonts, colors, etc.).

Reimplemented from CXTPMarqueeCtrlThemeOffice2000.

The documentation for this class was generated from the following file:
  • XTPMarqueeCtrlPaintManager.h


Toolkit Pro: CXTPMarqueeCtrlThemeOffice2013 Class Reference

Public Member Functions | List of all members
CXTPMarqueeCtrlThemeOffice2013 Class Reference

The CXTPMarqueeCtrlThemeFlat class is derived from CXTPMarqueeCtrlPaintManager and is used by the progress bar to draw an Office 2013 style progress bar. More...

Inheritance diagram for CXTPMarqueeCtrlThemeOffice2013:
[legend]

Public Member Functions

CXTPMarqueeCtrlThemeOffice2013 ()
Default paint manager constructor.
virtual void | RefreshMetrics ()
This member function performs initialization for the Paint Manager.
- Public Member Functions inherited from CXTPMarqueeCtrlThemeOffice2000
CXTPMarqueeCtrlThemeOffice2000 ()
Default paint manager constructor.
- Public Member Functions inherited from CXTPMarqueeCtrlPaintManager
CXTPMarqueeCtrlPaintManager ()
Default paint manager constructor.
virtual | ~CXTPMarqueeCtrlPaintManager ()
Default paint manager destructor.
virtual void | DrawBackground (CXTPMarqueeCtrl *pWndCtrl, CDC *pDC, CRect &rcClient)
This member function is called by the progress bar to draw the non-client borders.
virtual void | DrawMarquee (CXTPMarqueeCtrl *pWndCtrl, CDC *pDC, CRect &rcClient)
This member function is called by the progress bar to draw the client area of the control.
BOOL | UsingWinThemes (BOOL bCheckReady=FALSE)
Used by the progress bar to determine if Windows themes should be used to draw the control.
void | UseWinThemes (BOOL bUseWinThemes=TRUE)
Call this member function to draw the control using the current Windows theme.
COLORREF | SetBorderColor (COLORREF clrNew)
This member function sets the border color for the progress bar.
COLORREF | SetBarColor (COLORREF clrNew)
This member function sets the bar color for the progress bar.
COLORREF | SetBackColor (COLORREF clrNew)
This member function sets the background color for the progress bar.
COLORREF | GetBorderColor ()
This member function gets the border color for the progress bar.
COLORREF | GetBarColor ()
This member function gets the bar color for the progress bar.
COLORREF | GetBackColor ()
This member function gets the background color for the progress bar.

Additional Inherited Members

- Protected Member Functions inherited from CXTPMarqueeCtrlPaintManager
virtual void | DeflateRect (CDC *pDC, CRect &rcClient)
This member function is called by the progress bar to adjust the bar drawing size; can be overridden in derived classes.
virtual void | DrawChunk (CXTPMarqueeCtrl *pWndCtrl, CDC *pDC, CXTPCompatibleDC &dcChunk, int i, int &x, int &y, int cx, int cy)
This member function is called by the progress bar to draw a section of the progress indicator.
- Protected Attributes inherited from CXTPMarqueeCtrlPaintManager
BOOL | m_bUseWinTheme
TRUE when using Windows themes.
XTPControlTheme | m_nTheme
Theme identifier.
CXTPWinThemeWrapper | m_winTheme
Wrapper used when drawing Windows themes.
CXTPPaintManagerColor | m_clr3DHilite
An RGB value representing the border color.
CXTPPaintManagerColor | m_clr3DShadow
An RGB value representing the border color.
CXTPPaintManagerColor | m_clrBar
An RGB value representing the bar color.
CXTPPaintManagerColor | m_clrBack
An RGB value representing the back color.

Detailed Description

The CXTPMarqueeCtrlThemeFlat class is derived from CXTPMarqueeCtrlPaintManager and is used by the progress bar to draw an Office 2013 style progress bar.

Constructor & Destructor Documentation

◆ CXTPMarqueeCtrlThemeOffice2013()

CXTPMarqueeCtrlThemeOffice2013 ( )

Default paint manager constructor.

Handles initial initialization.

See also
RefreshMetrics()

Member Function Documentation

◆ RefreshMetrics()

virtual void RefreshMetrics ( )
virtual

This member function performs initialization for the Paint Manager.

Initializes all drawing defaults (fonts, colors, etc.).

Reimplemented from CXTPMarqueeCtrlThemeOffice2000.

The documentation for this class was generated from the following file:
  • XTPMarqueeCtrlPaintManager.h


Toolkit Pro: CXTPMarqueeCtrlThemeOfficeXP Class Reference

Public Member Functions | List of all members
CXTPMarqueeCtrlThemeOfficeXP Class Reference

The CXTPMarqueeCtrlThemeXP class is derived from CXTPMarqueeCtrlThemeFlat and is used by the progress bar to draw an Office XP style progress bar. More...

Inheritance diagram for CXTPMarqueeCtrlThemeOfficeXP:
[legend]

Public Member Functions

CXTPMarqueeCtrlThemeOfficeXP ()
Default paint manager constructor.
virtual void | RefreshMetrics ()
This member function performs initialization for the Paint Manager.
- Public Member Functions inherited from CXTPMarqueeCtrlThemeOffice2000
CXTPMarqueeCtrlThemeOffice2000 ()
Default paint manager constructor.
- Public Member Functions inherited from CXTPMarqueeCtrlPaintManager
CXTPMarqueeCtrlPaintManager ()
Default paint manager constructor.
virtual | ~CXTPMarqueeCtrlPaintManager ()
Default paint manager destructor.
virtual void | DrawBackground (CXTPMarqueeCtrl *pWndCtrl, CDC *pDC, CRect &rcClient)
This member function is called by the progress bar to draw the non-client borders.
virtual void | DrawMarquee (CXTPMarqueeCtrl *pWndCtrl, CDC *pDC, CRect &rcClient)
This member function is called by the progress bar to draw the client area of the control.
BOOL | UsingWinThemes (BOOL bCheckReady=FALSE)
Used by the progress bar to determine if Windows themes should be used to draw the control.
void | UseWinThemes (BOOL bUseWinThemes=TRUE)
Call this member function to draw the control using the current Windows theme.
COLORREF | SetBorderColor (COLORREF clrNew)
This member function sets the border color for the progress bar.
COLORREF | SetBarColor (COLORREF clrNew)
This member function sets the bar color for the progress bar.
COLORREF | SetBackColor (COLORREF clrNew)
This member function sets the background color for the progress bar.
COLORREF | GetBorderColor ()
This member function gets the border color for the progress bar.
COLORREF | GetBarColor ()
This member function gets the bar color for the progress bar.
COLORREF | GetBackColor ()
This member function gets the background color for the progress bar.

Additional Inherited Members

- Protected Member Functions inherited from CXTPMarqueeCtrlPaintManager
virtual void | DeflateRect (CDC *pDC, CRect &rcClient)
This member function is called by the progress bar to adjust the bar drawing size; can be overridden in derived classes.
virtual void | DrawChunk (CXTPMarqueeCtrl *pWndCtrl, CDC *pDC, CXTPCompatibleDC &dcChunk, int i, int &x, int &y, int cx, int cy)
This member function is called by the progress bar to draw a section of the progress indicator.
- Protected Attributes inherited from CXTPMarqueeCtrlPaintManager
BOOL | m_bUseWinTheme
TRUE when using Windows themes.
XTPControlTheme | m_nTheme
Theme identifier.
CXTPWinThemeWrapper | m_winTheme
Wrapper used when drawing Windows themes.
CXTPPaintManagerColor | m_clr3DHilite
An RGB value representing the border color.
CXTPPaintManagerColor | m_clr3DShadow
An RGB value representing the border color.
CXTPPaintManagerColor | m_clrBar
An RGB value representing the bar color.
CXTPPaintManagerColor | m_clrBack
An RGB value representing the back color.

Detailed Description

The CXTPMarqueeCtrlThemeXP class is derived from CXTPMarqueeCtrlThemeFlat and is used by the progress bar to draw an Office XP style progress bar.

Constructor & Destructor Documentation

◆ CXTPMarqueeCtrlThemeOfficeXP()

CXTPMarqueeCtrlThemeOfficeXP ( )

Default paint manager constructor.

Handles initial initialization.

See also
RefreshMetrics()

Member Function Documentation

◆ RefreshMetrics()

virtual void RefreshMetrics ( )
virtual

This member function performs initialization for the Paint Manager.

Initializes all drawing defaults (fonts, colors, etc.).

Reimplemented from CXTPMarqueeCtrlThemeOffice2000.

The documentation for this class was generated from the following file:
  • XTPMarqueeCtrlPaintManager.h


Toolkit Pro: CXTPMarqueeCtrlThemeResource Class Reference

Public Member Functions | List of all members
CXTPMarqueeCtrlThemeResource Class Reference

The CXTPMarqueeCtrlThemeFlat class is derived from CXTPMarqueeCtrlPaintManager and is used by the progress bar to draw an progress bar using a resource DLL. More...

Inheritance diagram for CXTPMarqueeCtrlThemeResource:
[legend]

Public Member Functions

CXTPMarqueeCtrlThemeResource ()
Default paint manager constructor.
virtual void | DrawBackground (CXTPMarqueeCtrl *pWndCtrl, CDC *pDC, CRect &rcClient)
This member function is called by the progress bar to draw the non-client borders.
virtual void | DrawChunk (CXTPMarqueeCtrl *pWndCtrl, CDC *pDC, CXTPCompatibleDC &dcChunk, int i, int &x, int &y, int cx, int cy)
This member function is called by the progress bar to draw a section of the progress indicator.
- Public Member Functions inherited from CXTPMarqueeCtrlThemeOffice2000
CXTPMarqueeCtrlThemeOffice2000 ()
Default paint manager constructor.
virtual void | RefreshMetrics ()
This member function performs initialization for the Paint Manager.
- Public Member Functions inherited from CXTPMarqueeCtrlPaintManager
CXTPMarqueeCtrlPaintManager ()
Default paint manager constructor.
virtual | ~CXTPMarqueeCtrlPaintManager ()
Default paint manager destructor.
virtual void | DrawMarquee (CXTPMarqueeCtrl *pWndCtrl, CDC *pDC, CRect &rcClient)
This member function is called by the progress bar to draw the client area of the control.
BOOL | UsingWinThemes (BOOL bCheckReady=FALSE)
Used by the progress bar to determine if Windows themes should be used to draw the control.
void | UseWinThemes (BOOL bUseWinThemes=TRUE)
Call this member function to draw the control using the current Windows theme.
COLORREF | SetBorderColor (COLORREF clrNew)
This member function sets the border color for the progress bar.
COLORREF | SetBarColor (COLORREF clrNew)
This member function sets the bar color for the progress bar.
COLORREF | SetBackColor (COLORREF clrNew)
This member function sets the background color for the progress bar.
COLORREF | GetBorderColor ()
This member function gets the border color for the progress bar.
COLORREF | GetBarColor ()
This member function gets the bar color for the progress bar.
COLORREF | GetBackColor ()
This member function gets the background color for the progress bar.

Additional Inherited Members

- Protected Member Functions inherited from CXTPMarqueeCtrlPaintManager
virtual void | DeflateRect (CDC *pDC, CRect &rcClient)
This member function is called by the progress bar to adjust the bar drawing size; can be overridden in derived classes.
- Protected Attributes inherited from CXTPMarqueeCtrlPaintManager
BOOL | m_bUseWinTheme
TRUE when using Windows themes.
XTPControlTheme | m_nTheme
Theme identifier.
CXTPWinThemeWrapper | m_winTheme
Wrapper used when drawing Windows themes.
CXTPPaintManagerColor | m_clr3DHilite
An RGB value representing the border color.
CXTPPaintManagerColor | m_clr3DShadow
An RGB value representing the border color.
CXTPPaintManagerColor | m_clrBar
An RGB value representing the bar color.
CXTPPaintManagerColor | m_clrBack
An RGB value representing the back color.

Detailed Description

The CXTPMarqueeCtrlThemeFlat class is derived from CXTPMarqueeCtrlPaintManager and is used by the progress bar to draw an progress bar using a resource DLL.

Constructor & Destructor Documentation

◆ CXTPMarqueeCtrlThemeResource()

CXTPMarqueeCtrlThemeResource ( )

Default paint manager constructor.

Handles initial initialization.

See also
RefreshMetrics()

Member Function Documentation

◆ DrawBackground()

virtual void DrawBackground | ( | CXTPMarqueeCtrl * | pWndCtrl,
 |  | CDC * | pDC,
 |  | CRect & | rcClient )
 virtual

This member function is called by the progress bar to draw the non-client borders.

Parameters
pWndCtrl | Points to a CXTPMarqueeCtrl object.
pDC | Pointer to a valid device context.
rcClient | Size of the non-client border area.

Reimplemented from CXTPMarqueeCtrlPaintManager.

◆ DrawChunk()

virtual void DrawChunk | ( | CXTPMarqueeCtrl * | pWndCtrl,
 |  | CDC * | pDC,
 |  | CXTPCompatibleDC & | dcChunk,
 |  | int | i,
 |  | int & | x,
 |  | int & | y,
 |  | int | cx,
 |  | int | cy )
 virtual

This member function is called by the progress bar to draw a section of the progress indicator.

Parameters
pWndCtrl | Points to the CXTPMarqueeCtrl object.
pDC | Points to the device context used for drawing.
dcChunk | Reference to a CXTPCompatibleDC device context.
i | Index value for the item drawn.
x | Left position.
y | Top position.
cx | Item width.
cy | Item height.

Reimplemented from CXTPMarqueeCtrlPaintManager.

The documentation for this class was generated from the following file:
  • XTPMarqueeCtrlPaintManager.h


Toolkit Pro: CXTPMarqueeCtrlThemeUltraFlat Class Reference

Public Member Functions | List of all members
CXTPMarqueeCtrlThemeUltraFlat Class Reference

The CXTPMarqueeCtrlThemeUltraFlat class is derived from CXTPMarqueeCtrlThemeFlat and is used by the progress bar to draw a flat style progress bar with no borders. More...

Inheritance diagram for CXTPMarqueeCtrlThemeUltraFlat:
[legend]

Public Member Functions

CXTPMarqueeCtrlThemeUltraFlat ()
Default paint manager constructor.
virtual void | RefreshMetrics ()
This member function performs initialization for the Paint Manager.
- Public Member Functions inherited from CXTPMarqueeCtrlThemeFlat
CXTPMarqueeCtrlThemeFlat ()
Default paint manager constructor.
- Public Member Functions inherited from CXTPMarqueeCtrlPaintManager
CXTPMarqueeCtrlPaintManager ()
Default paint manager constructor.
virtual | ~CXTPMarqueeCtrlPaintManager ()
Default paint manager destructor.
virtual void | DrawBackground (CXTPMarqueeCtrl *pWndCtrl, CDC *pDC, CRect &rcClient)
This member function is called by the progress bar to draw the non-client borders.
BOOL | UsingWinThemes (BOOL bCheckReady=FALSE)
Used by the progress bar to determine if Windows themes should be used to draw the control.
void | UseWinThemes (BOOL bUseWinThemes=TRUE)
Call this member function to draw the control using the current Windows theme.
COLORREF | SetBorderColor (COLORREF clrNew)
This member function sets the border color for the progress bar.
COLORREF | SetBarColor (COLORREF clrNew)
This member function sets the bar color for the progress bar.
COLORREF | SetBackColor (COLORREF clrNew)
This member function sets the background color for the progress bar.
COLORREF | GetBorderColor ()
This member function gets the border color for the progress bar.
COLORREF | GetBarColor ()
This member function gets the bar color for the progress bar.
COLORREF | GetBackColor ()
This member function gets the background color for the progress bar.

Additional Inherited Members

- Protected Member Functions inherited from CXTPMarqueeCtrlThemeFlat
virtual void | DeflateRect (CDC *pDC, CRect &rcClient)
This member function is called by the progress bar to adjust the bar drawing size; can be overridden in derived classes.
virtual void | DrawMarquee (CXTPMarqueeCtrl *pWndCtrl, CDC *pDC, CRect &rcClient)
This member function is called by the progress bar to draw the client area of the control.
- Protected Member Functions inherited from CXTPMarqueeCtrlPaintManager
virtual void | DrawChunk (CXTPMarqueeCtrl *pWndCtrl, CDC *pDC, CXTPCompatibleDC &dcChunk, int i, int &x, int &y, int cx, int cy)
This member function is called by the progress bar to draw a section of the progress indicator.
- Protected Attributes inherited from CXTPMarqueeCtrlPaintManager
BOOL | m_bUseWinTheme
TRUE when using Windows themes.
XTPControlTheme | m_nTheme
Theme identifier.
CXTPWinThemeWrapper | m_winTheme
Wrapper used when drawing Windows themes.
CXTPPaintManagerColor | m_clr3DHilite
An RGB value representing the border color.
CXTPPaintManagerColor | m_clr3DShadow
An RGB value representing the border color.
CXTPPaintManagerColor | m_clrBar
An RGB value representing the bar color.
CXTPPaintManagerColor | m_clrBack
An RGB value representing the back color.

Detailed Description

The CXTPMarqueeCtrlThemeUltraFlat class is derived from CXTPMarqueeCtrlThemeFlat and is used by the progress bar to draw a flat style progress bar with no borders.

Constructor & Destructor Documentation

◆ CXTPMarqueeCtrlThemeUltraFlat()

CXTPMarqueeCtrlThemeUltraFlat ( )

Default paint manager constructor.

Handles initial initialization.

See also
RefreshMetrics()

Member Function Documentation

◆ RefreshMetrics()

virtual void RefreshMetrics ( )
virtual

This member function performs initialization for the Paint Manager.

Initializes all drawing defaults (fonts, colors, etc.).

Reimplemented from CXTPMarqueeCtrlThemeFlat.

The documentation for this class was generated from the following file:
  • XTPMarqueeCtrlPaintManager.h


Toolkit Pro: CXTPMarqueeCtrlThemeVisualStudio2015 Class Reference

Public Member Functions | List of all members
CXTPMarqueeCtrlThemeVisualStudio2015 Class Reference

The CXTPMarqueeCtrlThemeFlat class is derived from CXTPMarqueeCtrlPaintManager and is used by the progress bar to draw a Visual Studio 2015 style progress bar. More...

Inheritance diagram for CXTPMarqueeCtrlThemeVisualStudio2015:
[legend]

Public Member Functions

CXTPMarqueeCtrlThemeVisualStudio2015 ()
Default paint manager constructor.
- Public Member Functions inherited from CXTPMarqueeCtrlThemeOffice2013
CXTPMarqueeCtrlThemeOffice2013 ()
Default paint manager constructor.
virtual void | RefreshMetrics ()
This member function performs initialization for the Paint Manager.
- Public Member Functions inherited from CXTPMarqueeCtrlThemeOffice2000
CXTPMarqueeCtrlThemeOffice2000 ()
Default paint manager constructor.
- Public Member Functions inherited from CXTPMarqueeCtrlPaintManager
CXTPMarqueeCtrlPaintManager ()
Default paint manager constructor.
virtual | ~CXTPMarqueeCtrlPaintManager ()
Default paint manager destructor.
virtual void | DrawBackground (CXTPMarqueeCtrl *pWndCtrl, CDC *pDC, CRect &rcClient)
This member function is called by the progress bar to draw the non-client borders.
virtual void | DrawMarquee (CXTPMarqueeCtrl *pWndCtrl, CDC *pDC, CRect &rcClient)
This member function is called by the progress bar to draw the client area of the control.
BOOL | UsingWinThemes (BOOL bCheckReady=FALSE)
Used by the progress bar to determine if Windows themes should be used to draw the control.
void | UseWinThemes (BOOL bUseWinThemes=TRUE)
Call this member function to draw the control using the current Windows theme.
COLORREF | SetBorderColor (COLORREF clrNew)
This member function sets the border color for the progress bar.
COLORREF | SetBarColor (COLORREF clrNew)
This member function sets the bar color for the progress bar.
COLORREF | SetBackColor (COLORREF clrNew)
This member function sets the background color for the progress bar.
COLORREF | GetBorderColor ()
This member function gets the border color for the progress bar.
COLORREF | GetBarColor ()
This member function gets the bar color for the progress bar.
COLORREF | GetBackColor ()
This member function gets the background color for the progress bar.

Additional Inherited Members

- Protected Member Functions inherited from CXTPMarqueeCtrlPaintManager
virtual void | DeflateRect (CDC *pDC, CRect &rcClient)
This member function is called by the progress bar to adjust the bar drawing size; can be overridden in derived classes.
virtual void | DrawChunk (CXTPMarqueeCtrl *pWndCtrl, CDC *pDC, CXTPCompatibleDC &dcChunk, int i, int &x, int &y, int cx, int cy)
This member function is called by the progress bar to draw a section of the progress indicator.
- Protected Attributes inherited from CXTPMarqueeCtrlPaintManager
BOOL | m_bUseWinTheme
TRUE when using Windows themes.
XTPControlTheme | m_nTheme
Theme identifier.
CXTPWinThemeWrapper | m_winTheme
Wrapper used when drawing Windows themes.
CXTPPaintManagerColor | m_clr3DHilite
An RGB value representing the border color.
CXTPPaintManagerColor | m_clr3DShadow
An RGB value representing the border color.
CXTPPaintManagerColor | m_clrBar
An RGB value representing the bar color.
CXTPPaintManagerColor | m_clrBack
An RGB value representing the back color.

Detailed Description

The CXTPMarqueeCtrlThemeFlat class is derived from CXTPMarqueeCtrlPaintManager and is used by the progress bar to draw a Visual Studio 2015 style progress bar.

Constructor & Destructor Documentation

◆ CXTPMarqueeCtrlThemeVisualStudio2015()

CXTPMarqueeCtrlThemeVisualStudio2015 ( )

Default paint manager constructor.

Handles initial initialization.

See also
RefreshMetrics()
The documentation for this class was generated from the following file:
  • XTPMarqueeCtrlPaintManager.h


Toolkit Pro: CXTPMarqueeCtrlThemeVisualStudio2017 Class Reference

Public Member Functions | List of all members
CXTPMarqueeCtrlThemeVisualStudio2017 Class Reference

The CXTPMarqueeCtrlThemeFlat class is derived from CXTPMarqueeCtrlPaintManager and is used by the progress bar to draw a Visual Studio 2017 style progress bar. More...

Inheritance diagram for CXTPMarqueeCtrlThemeVisualStudio2017:
[legend]

Public Member Functions

CXTPMarqueeCtrlThemeVisualStudio2017 ()
Default paint manager constructor.
- Public Member Functions inherited from CXTPMarqueeCtrlThemeOffice2013
CXTPMarqueeCtrlThemeOffice2013 ()
Default paint manager constructor.
virtual void | RefreshMetrics ()
This member function performs initialization for the Paint Manager.
- Public Member Functions inherited from CXTPMarqueeCtrlThemeOffice2000
CXTPMarqueeCtrlThemeOffice2000 ()
Default paint manager constructor.
- Public Member Functions inherited from CXTPMarqueeCtrlPaintManager
CXTPMarqueeCtrlPaintManager ()
Default paint manager constructor.
virtual | ~CXTPMarqueeCtrlPaintManager ()
Default paint manager destructor.
virtual void | DrawBackground (CXTPMarqueeCtrl *pWndCtrl, CDC *pDC, CRect &rcClient)
This member function is called by the progress bar to draw the non-client borders.
virtual void | DrawMarquee (CXTPMarqueeCtrl *pWndCtrl, CDC *pDC, CRect &rcClient)
This member function is called by the progress bar to draw the client area of the control.
BOOL | UsingWinThemes (BOOL bCheckReady=FALSE)
Used by the progress bar to determine if Windows themes should be used to draw the control.
void | UseWinThemes (BOOL bUseWinThemes=TRUE)
Call this member function to draw the control using the current Windows theme.
COLORREF | SetBorderColor (COLORREF clrNew)
This member function sets the border color for the progress bar.
COLORREF | SetBarColor (COLORREF clrNew)
This member function sets the bar color for the progress bar.
COLORREF | SetBackColor (COLORREF clrNew)
This member function sets the background color for the progress bar.
COLORREF | GetBorderColor ()
This member function gets the border color for the progress bar.
COLORREF | GetBarColor ()
This member function gets the bar color for the progress bar.
COLORREF | GetBackColor ()
This member function gets the background color for the progress bar.

Additional Inherited Members

- Protected Member Functions inherited from CXTPMarqueeCtrlPaintManager
virtual void | DeflateRect (CDC *pDC, CRect &rcClient)
This member function is called by the progress bar to adjust the bar drawing size; can be overridden in derived classes.
virtual void | DrawChunk (CXTPMarqueeCtrl *pWndCtrl, CDC *pDC, CXTPCompatibleDC &dcChunk, int i, int &x, int &y, int cx, int cy)
This member function is called by the progress bar to draw a section of the progress indicator.
- Protected Attributes inherited from CXTPMarqueeCtrlPaintManager
BOOL | m_bUseWinTheme
TRUE when using Windows themes.
XTPControlTheme | m_nTheme
Theme identifier.
CXTPWinThemeWrapper | m_winTheme
Wrapper used when drawing Windows themes.
CXTPPaintManagerColor | m_clr3DHilite
An RGB value representing the border color.
CXTPPaintManagerColor | m_clr3DShadow
An RGB value representing the border color.
CXTPPaintManagerColor | m_clrBar
An RGB value representing the bar color.
CXTPPaintManagerColor | m_clrBack
An RGB value representing the back color.

Detailed Description

The CXTPMarqueeCtrlThemeFlat class is derived from CXTPMarqueeCtrlPaintManager and is used by the progress bar to draw a Visual Studio 2017 style progress bar.

Constructor & Destructor Documentation

◆ CXTPMarqueeCtrlThemeVisualStudio2017()

CXTPMarqueeCtrlThemeVisualStudio2017 ( )

Default paint manager constructor.

Handles initial initialization.

See also
RefreshMetrics()
The documentation for this class was generated from the following file:
  • XTPMarqueeCtrlPaintManager.h


Toolkit Pro: CXTPMarqueeCtrlThemeVisualStudio2019 Class Reference

Public Member Functions | List of all members
CXTPMarqueeCtrlThemeVisualStudio2019 Class Reference

The CXTPMarqueeCtrlThemeFlat class is derived from CXTPMarqueeCtrlPaintManager and is used by the progress bar to draw a Visual Studio 2019 style progress bar. More...

Inheritance diagram for CXTPMarqueeCtrlThemeVisualStudio2019:
[legend]

Public Member Functions

CXTPMarqueeCtrlThemeVisualStudio2019 ()
Default paint manager constructor.
- Public Member Functions inherited from CXTPMarqueeCtrlThemeOffice2013
CXTPMarqueeCtrlThemeOffice2013 ()
Default paint manager constructor.
virtual void | RefreshMetrics ()
This member function performs initialization for the Paint Manager.
- Public Member Functions inherited from CXTPMarqueeCtrlThemeOffice2000
CXTPMarqueeCtrlThemeOffice2000 ()
Default paint manager constructor.
- Public Member Functions inherited from CXTPMarqueeCtrlPaintManager
CXTPMarqueeCtrlPaintManager ()
Default paint manager constructor.
virtual | ~CXTPMarqueeCtrlPaintManager ()
Default paint manager destructor.
virtual void | DrawBackground (CXTPMarqueeCtrl *pWndCtrl, CDC *pDC, CRect &rcClient)
This member function is called by the progress bar to draw the non-client borders.
virtual void | DrawMarquee (CXTPMarqueeCtrl *pWndCtrl, CDC *pDC, CRect &rcClient)
This member function is called by the progress bar to draw the client area of the control.
BOOL | UsingWinThemes (BOOL bCheckReady=FALSE)
Used by the progress bar to determine if Windows themes should be used to draw the control.
void | UseWinThemes (BOOL bUseWinThemes=TRUE)
Call this member function to draw the control using the current Windows theme.
COLORREF | SetBorderColor (COLORREF clrNew)
This member function sets the border color for the progress bar.
COLORREF | SetBarColor (COLORREF clrNew)
This member function sets the bar color for the progress bar.
COLORREF | SetBackColor (COLORREF clrNew)
This member function sets the background color for the progress bar.
COLORREF | GetBorderColor ()
This member function gets the border color for the progress bar.
COLORREF | GetBarColor ()
This member function gets the bar color for the progress bar.
COLORREF | GetBackColor ()
This member function gets the background color for the progress bar.

Additional Inherited Members

- Protected Member Functions inherited from CXTPMarqueeCtrlPaintManager
virtual void | DeflateRect (CDC *pDC, CRect &rcClient)
This member function is called by the progress bar to adjust the bar drawing size; can be overridden in derived classes.
virtual void | DrawChunk (CXTPMarqueeCtrl *pWndCtrl, CDC *pDC, CXTPCompatibleDC &dcChunk, int i, int &x, int &y, int cx, int cy)
This member function is called by the progress bar to draw a section of the progress indicator.
- Protected Attributes inherited from CXTPMarqueeCtrlPaintManager
BOOL | m_bUseWinTheme
TRUE when using Windows themes.
XTPControlTheme | m_nTheme
Theme identifier.
CXTPWinThemeWrapper | m_winTheme
Wrapper used when drawing Windows themes.
CXTPPaintManagerColor | m_clr3DHilite
An RGB value representing the border color.
CXTPPaintManagerColor | m_clr3DShadow
An RGB value representing the border color.
CXTPPaintManagerColor | m_clrBar
An RGB value representing the bar color.
CXTPPaintManagerColor | m_clrBack
An RGB value representing the back color.

Detailed Description

The CXTPMarqueeCtrlThemeFlat class is derived from CXTPMarqueeCtrlPaintManager and is used by the progress bar to draw a Visual Studio 2019 style progress bar.

Constructor & Destructor Documentation

◆ CXTPMarqueeCtrlThemeVisualStudio2019()

CXTPMarqueeCtrlThemeVisualStudio2019 ( )

Default paint manager constructor.

Handles initial initialization.

See also
RefreshMetrics()
The documentation for this class was generated from the following file:
  • XTPMarqueeCtrlPaintManager.h


Toolkit Pro: CXTPMarqueeCtrlThemeVisualStudio2022 Class Reference

Public Member Functions | List of all members
CXTPMarqueeCtrlThemeVisualStudio2022 Class Reference

The CXTPMarqueeCtrlThemeFlat class is derived from CXTPMarqueeCtrlPaintManager and is used by the progress bar to draw a Visual Studio 2022 style progress bar. More...

Inheritance diagram for CXTPMarqueeCtrlThemeVisualStudio2022:
[legend]

Public Member Functions

CXTPMarqueeCtrlThemeVisualStudio2022 ()
Default paint manager constructor.
- Public Member Functions inherited from CXTPMarqueeCtrlThemeOffice2013
CXTPMarqueeCtrlThemeOffice2013 ()
Default paint manager constructor.
virtual void | RefreshMetrics ()
This member function performs initialization for the Paint Manager.
- Public Member Functions inherited from CXTPMarqueeCtrlThemeOffice2000
CXTPMarqueeCtrlThemeOffice2000 ()
Default paint manager constructor.
- Public Member Functions inherited from CXTPMarqueeCtrlPaintManager
CXTPMarqueeCtrlPaintManager ()
Default paint manager constructor.
virtual | ~CXTPMarqueeCtrlPaintManager ()
Default paint manager destructor.
virtual void | DrawBackground (CXTPMarqueeCtrl *pWndCtrl, CDC *pDC, CRect &rcClient)
This member function is called by the progress bar to draw the non-client borders.
virtual void | DrawMarquee (CXTPMarqueeCtrl *pWndCtrl, CDC *pDC, CRect &rcClient)
This member function is called by the progress bar to draw the client area of the control.
BOOL | UsingWinThemes (BOOL bCheckReady=FALSE)
Used by the progress bar to determine if Windows themes should be used to draw the control.
void | UseWinThemes (BOOL bUseWinThemes=TRUE)
Call this member function to draw the control using the current Windows theme.
COLORREF | SetBorderColor (COLORREF clrNew)
This member function sets the border color for the progress bar.
COLORREF | SetBarColor (COLORREF clrNew)
This member function sets the bar color for the progress bar.
COLORREF | SetBackColor (COLORREF clrNew)
This member function sets the background color for the progress bar.
COLORREF | GetBorderColor ()
This member function gets the border color for the progress bar.
COLORREF | GetBarColor ()
This member function gets the bar color for the progress bar.
COLORREF | GetBackColor ()
This member function gets the background color for the progress bar.

Additional Inherited Members

- Protected Member Functions inherited from CXTPMarqueeCtrlPaintManager
virtual void | DeflateRect (CDC *pDC, CRect &rcClient)
This member function is called by the progress bar to adjust the bar drawing size; can be overridden in derived classes.
virtual void | DrawChunk (CXTPMarqueeCtrl *pWndCtrl, CDC *pDC, CXTPCompatibleDC &dcChunk, int i, int &x, int &y, int cx, int cy)
This member function is called by the progress bar to draw a section of the progress indicator.
- Protected Attributes inherited from CXTPMarqueeCtrlPaintManager
BOOL | m_bUseWinTheme
TRUE when using Windows themes.
XTPControlTheme | m_nTheme
Theme identifier.
CXTPWinThemeWrapper | m_winTheme
Wrapper used when drawing Windows themes.
CXTPPaintManagerColor | m_clr3DHilite
An RGB value representing the border color.
CXTPPaintManagerColor | m_clr3DShadow
An RGB value representing the border color.
CXTPPaintManagerColor | m_clrBar
An RGB value representing the bar color.
CXTPPaintManagerColor | m_clrBack
An RGB value representing the back color.

Detailed Description

The CXTPMarqueeCtrlThemeFlat class is derived from CXTPMarqueeCtrlPaintManager and is used by the progress bar to draw a Visual Studio 2022 style progress bar.

Constructor & Destructor Documentation

◆ CXTPMarqueeCtrlThemeVisualStudio2022()

CXTPMarqueeCtrlThemeVisualStudio2022 ( )

Default paint manager constructor.

Handles initial initialization.

See also
RefreshMetrics()
The documentation for this class was generated from the following file:
  • XTPMarqueeCtrlPaintManager.h


Toolkit Pro: CXTPMaskEdit Class Reference

Public Member Functions | List of all members
CXTPMaskEdit Class Reference

CXTPMaskEdit is a CXTPEdit derived class. More...

Inheritance diagram for CXTPMaskEdit:
[legend]

Public Member Functions

CXTPMaskEdit ()
Constructs a CXTPMaskEdit object.
virtual bool | Initialize (CWnd *pParentWnd)
Initializes the CXTPMaskEdit control.
- Public Member Functions inherited from CXTPEdit
CXTPEdit ()
Constructs a CXTPEdit object.
virtual | ~CXTPEdit ()
Destroys a CXTPEdit object, handles cleanup and deallocation.
BOOL | SetEditMask (LPCTSTR lpszMask, LPCTSTR lpszLiteral, LPCTSTR lpszDefault=NULL)
This member function will set the mask for the edit control.
void | SetPattern (LPCTSTR lpszPattern)
Call this member function to set the pattern for the edit mask.
virtual BOOL | CanPaste ()
Call this member function to determine if the Clipboard contains information that can be pasted into this edit view.
BOOL | HasSelection () const
Call this member function to determine if a selection has been made.
void | AdjustBuddyRect (CWnd *pBuddy, CRect &rcUpDown, int nAlignment)
Called by the framework to adjust the size of the area to draw the buddy control borders on.
void | DrawBuddyBorders (CWnd *pBuddy, CDC *pDC, CRect rc, int nAlignment)
Called by the framework to draw the borders for the associated buddy window.
virtual void | RefreshMetrics ()
This member is called to update the color, text and other visual elements of the control.
virtual void | SetTheme (XTPControlTheme nTheme)
Call this member to switch the visual theme of the control.
XTPControlTheme GetThemeID ()
Call this member function to get the style for the theme.
CXTPEditTheme * GetTheme ()
Call this member to retrieve a pointer to the current theme.
BOOL | GetFlatStyle () const
Gets the flat style appearance of the button control.
void | SetFlatStyle (BOOL bFlatStyle=TRUE)
Sets the flat style appearance of the button control.
BOOL | GetUseVisualStyle () const
Determines if the control is drawn using visual styles/SkinFramework, if supported.
void | SetUseVisualStyle (BOOL bUseVisualStyle=TRUE)
Enables Windows XP visual styles for the control.
BOOL | IsPatternValid ()
Called by the framework to determine if the pattern set using SetPattern() is valid.
void | ShowThemedBorder (BOOL bShowThemedBorder)
Call this member function to enable/disable theme border display.
BOOL | IsHighlighted () const
Call this member function to determine if the edit state is highlighted, meaning that the mouse cursor is currently hovering over the control.
BOOL | IsFocused () const
Call this member function to determine if the edit-box has input focus.
BOOL | IsFlatStyle () const
Gets the flat style appearance of the edit control.
BOOL | ShowBorder () const
Call this member to determine if non-client borders are displayed.
- Public Member Functions inherited from CXTPMaskEditT< CEdit >
CXTPMaskEditT ()
Constructs a CXTPMaskEditT object.
void | SetUseMask (BOOL bUseMask)
Call this member function to enable or disable the mask for the mask edit control.
BOOL | CanUseMask () const
This member function is called to determine if the mask for the edit control can be used.
void | SetOverType (BOOL bOverType)
This member function is called to enable or disable type over, also known as insert mode.
BOOL | CanOverType () const
This member function is called to determine if type over has been enabled.
BOOL | PosInRange (int iPos) const
This member function is called to determine if the index specified by 'iPos' is a valid index for the currently displayed edit text.
TCHAR | GetPromptChar () const
This member function retrieves the character that is currently used as the mask prompt.
CString | GetPromptString (int nLength) const
This helper member function retrieves the string contains nLength prompt characters.
void | SetPromptChar (TCHAR ch, BOOL bAutoReplace=TRUE)
This member function is called to set the prompt character that is displayed to the user that indicates the field can be edited.
afx_msg BOOL | MaskCut ()
This member function is called to perform a cut operation using the currently selected text.
afx_msg BOOL | MaskCopy ()
This member function is called to perform a copy operation using the currently selected text.
void | MaskReplaceSel (LPCTSTR lpszNewText)
This member function is called to perform a replace operation using the currently selected text.
afx_msg BOOL | MaskPaste ()
This member function is called to perform a paste operation using the current clipboard text.
void | MaskDeleteSel ()
This member function is called to delete the selection.
afx_msg BOOL | MaskClear ()
This member function is called to clear the current text selection.
afx_msg BOOL | MaskUndo ()
This member function is called to undo the previous action.
afx_msg void | MaskSelectAll ()
This member function is called to select all text in the mask edit control.
BOOL | IsModified () const
This member function is called to determine if the text has been modified.
void | SetMaskedText (LPCTSTR lpszMaskedText, int iPos=0, BOOL bUpdateWindow=TRUE)
This method called to set masked text for the edit control.
TCHAR | ConvertUnicodeAlpha (TCHAR nChar, BOOL bUpperCase) const
Converts character to Upper/Lower case.
virtual BOOL | CheckChar (TCHAR &nChar, int nPos)
This member function is used internally to validate the character indicated by 'nChar'.
virtual BOOL | ProcessMask (TCHAR &nChar, int nEndPos)
This member function is used internally to process the character passed in by 'nChar' whose index is specified by 'nEndPos'.
virtual BOOL | PreTranslateMessage (MSG *pMsg)
Used by class CWinApp to translate window messages before they are dispatched to theTranslateMessage andDispatchMessage Windows functions.
void | DeleteCharAt (int iPos)
Deletes character in specified position.
void | InsertCharAt (int iPos, TCHAR nChar)
Inserts character to specified position.
BOOL | CopyToClipboard (const CString &strText)
Copies text to system clipboard.
CString | GetMaskedText (int nStartPos=0, int nEndPos=-1) const
Retrieves masked text of the control.

Additional Inherited Members

- Protected Member Functions inherited from CXTPEdit
HBRUSH | GetClientBrush (CDC *pDC)
Retrieves a handle to the client background brush.
void | RedrawEdit ()
Called by the framework to redraw the edit control.
void | RedrawFocusedFrame ()
Called by the framework to redraw the focus rectangle for the edit control.
- Protected Member Functions inherited from CXTPMaskEditT< CEdit >
virtual BOOL | OnCommand (WPARAM wParam, LPARAM lParam)
The framework calls this member function when the user selects an item from a menu.
- Protected Attributes inherited from CXTPEdit
CXTPEditTheme * | m_pTheme
Pointer to the current edit theme.
BOOL | m_bPreSubclassInit
TRUE if the control has been subclassed.
BOOL | m_bShowBorder
TRUE if non-client borders are displayed.
BOOL | m_bHighlighted
TRUE when the mouse is hovering over the control.
BOOL | m_bFocused
TRUE when the control has input focus.
CXTPRegExp * | m_pRegExp
Pointer to the CXTPRegExp object for this control.
- Protected Attributes inherited from CXTPMaskEditT< CEdit >
int | m_nStartChar
Current position of the first character in the current selection.
int | m_nEndChar
Current position of the first non-selected character past the end of the current selection.
BOOL | m_bUseMask
TRUE to use the edit mask.
BOOL | m_bOverType
TRUE to over type the text, set with VK_INSERT key press.
BOOL | m_bRedo
TRUE to redo, or FALSE to undo.
BOOL | m_bModified
TRUE if mask edit has been modified.
TCHAR | m_chPrompt
Prompt character used to identify the text entry.
CString | m_strMask
Buffer that holds the actual edit mask value.
CString | m_strDefault
Contains the edit controls default display text.
CString | m_strUndoBuffer
Holds the contents of the undo buffer.
CString | m_strRedoBuffer
Holds the contents of the redo buffer.
CString | m_strWindowText
Buffer that holds the actual edit text.
CString | m_strLiteral
Literal format that restricts where the user can enter text.
BOOL | m_bUpdateUndo
TRUE to update undo.

Detailed Description

CXTPMaskEdit is a CXTPEdit derived class.

It allows text masking to be applied to the control to format it for special editing restrictions.

Member Function Documentation

◆ Initialize()

virtual bool Initialize ( CWnd * pParentWnd )
virtual

Initializes the CXTPMaskEdit control.

Call this member function to initialize the edit control. You can call this after you have created or subclassed your edit control.

Parameters
pParentWnd Pointer to the parent of the edit control.
Returns
true if the control was successfully initialized, otherwise false.
The documentation for this class was generated from the following file:
  • XTPMaskEdit.h


Toolkit Pro: CXTPMaskEditT< TBase > Class Template Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPMaskEditT< TBase > Class Template Reference

CXTPMaskEditT is a template class. More...

Inheritance diagram for CXTPMaskEditT< TBase >:
[legend]

Public Member Functions

CXTPMaskEditT ()
Constructs a CXTPMaskEditT object.
void | SetUseMask (BOOL bUseMask)
Call this member function to enable or disable the mask for the mask edit control.
BOOL | CanUseMask () const
This member function is called to determine if the mask for the edit control can be used.
void | SetOverType (BOOL bOverType)
This member function is called to enable or disable type over, also known as insert mode.
BOOL | CanOverType () const
This member function is called to determine if type over has been enabled.
BOOL | PosInRange (int iPos) const
This member function is called to determine if the index specified by 'iPos' is a valid index for the currently displayed edit text.
TCHAR | GetPromptChar () const
This member function retrieves the character that is currently used as the mask prompt.
CString | GetPromptString (int nLength) const
This helper member function retrieves the string contains nLength prompt characters.
void | SetPromptChar (TCHAR ch, BOOL bAutoReplace=TRUE)
This member function is called to set the prompt character that is displayed to the user that indicates the field can be edited.
afx_msg BOOL | MaskCut ()
This member function is called to perform a cut operation using the currently selected text.
afx_msg BOOL | MaskCopy ()
This member function is called to perform a copy operation using the currently selected text.
void | MaskReplaceSel (LPCTSTR lpszNewText)
This member function is called to perform a replace operation using the currently selected text.
afx_msg BOOL | MaskPaste ()
This member function is called to perform a paste operation using the current clipboard text.
void | MaskDeleteSel ()
This member function is called to delete the selection.
afx_msg BOOL | MaskClear ()
This member function is called to clear the current text selection.
afx_msg BOOL | MaskUndo ()
This member function is called to undo the previous action.
afx_msg void | MaskSelectAll ()
This member function is called to select all text in the mask edit control.
BOOL | IsModified () const
This member function is called to determine if the text has been modified.
void | SetMaskedText (LPCTSTR lpszMaskedText, int iPos=0, BOOL bUpdateWindow=TRUE)
This method called to set masked text for the edit control.
virtual BOOL | SetEditMask (LPCTSTR lpszMask, LPCTSTR lpszLiteral, LPCTSTR lpszDefault=NULL)
This member function will set the mask for the edit control.
TCHAR | ConvertUnicodeAlpha (TCHAR nChar, BOOL bUpperCase) const
Converts character to Upper/Lower case.
virtual BOOL | CheckChar (TCHAR &nChar, int nPos)
This member function is used internally to validate the character indicated by 'nChar'.
virtual BOOL | ProcessMask (TCHAR &nChar, int nEndPos)
This member function is used internally to process the character passed in by 'nChar' whose index is specified by 'nEndPos'.
virtual BOOL | PreTranslateMessage (MSG *pMsg)
Used by class CWinApp to translate window messages before they are dispatched to theTranslateMessage andDispatchMessage Windows functions.
void | DeleteCharAt (int iPos)
Deletes character in specified position.
void | InsertCharAt (int iPos, TCHAR nChar)
Inserts character to specified position.
BOOL | CopyToClipboard (const CString &strText)
Copies text to system clipboard.
CString | GetMaskedText (int nStartPos=0, int nEndPos=-1) const
Retrieves masked text of the control.

Protected Member Functions

virtual BOOL OnCommand (WPARAM wParam, LPARAM lParam)
The framework calls this member function when the user selects an item from a menu.

Protected Attributes

int | m_nStartChar
Current position of the first character in the current selection.
int | m_nEndChar
Current position of the first non-selected character past the end of the current selection.
BOOL | m_bUseMask
TRUE to use the edit mask.
BOOL | m_bOverType
TRUE to over type the text, set with VK_INSERT key press.
BOOL | m_bRedo
TRUE to redo, or FALSE to undo.
BOOL | m_bModified
TRUE if mask edit has been modified.
TCHAR | m_chPrompt
Prompt character used to identify the text entry.
CString | m_strMask
Buffer that holds the actual edit mask value.
CString | m_strDefault
Contains the edit controls default display text.
CString | m_strUndoBuffer
Holds the contents of the undo buffer.
CString | m_strRedoBuffer
Holds the contents of the redo buffer.
CString | m_strWindowText
Buffer that holds the actual edit text.
CString | m_strLiteral
Literal format that restricts where the user can enter text.
BOOL | m_bUpdateUndo
TRUE to update undo.

Detailed Description

template<class TBase>
class CXTPMaskEditT< TBase >

CXTPMaskEditT is a template class.

It allows text masking to be applied to the control to format it for special editing restrictions.

Member Function Documentation

◆ CanOverType()

template<class TBase >
BOOL CanOverType ( ) const
inline

This member function is called to determine if type over has been enabled.

Returns
TRUE if type over is enabled, otherwise returns FALSE.

◆ CanUseMask()

template<class TBase >
BOOL CanUseMask ( ) const
inline

This member function is called to determine if the mask for the edit control can be used.

Returns
TRUE if the mask can be used, otherwise returns FALSE.

◆ CheckChar()

template<class TBase >
virtual BOOL CheckChar | ( | TCHAR & | nChar,
 |  | int | nPos )
 inlinevirtual

This member function is used internally to validate the character indicated by 'nChar'.

Parameters
nChar | Contains the character code value of the key.
nPos | Sting length.
Returns
TRUE if successful, otherwise returns FALSE.

◆ ConvertUnicodeAlpha()

template<class TBase >
TCHAR ConvertUnicodeAlpha | ( | TCHAR | nChar,
 |  | BOOL | bUpperCase ) const
 inline

Converts character to Upper/Lower case.

Parameters
nChar | Char to be converted
bUpperCase | TRUE to convert to upper case
Returns
Converted character.

◆ CopyToClipboard()

template<class TBase >
BOOL CopyToClipboard ( const CString & strText )
inline

Copies text to system clipboard.

Parameters
strText Text to be copied
Returns
TRUE if successful; otherwise returns FALSE

◆ DeleteCharAt()

template<class TBase >
void DeleteCharAt ( int iPos )
inline

Deletes character in specified position.

Parameters
iPos Position for character to be deleted.

◆ GetMaskedText()

template<class TBase >
CString GetMaskedText | ( | int | nStartPos = 0,
 |  | int | nEndPos = -1 ) const
 inline

Retrieves masked text of the control.

Parameters
nStartPos | Start position
nEndPos | End position
Returns
Masked text of the control.

◆ GetPromptChar()

template<class TBase >
TCHAR GetPromptChar ( ) const
inline

This member function retrieves the character that is currently used as the mask prompt.

The mask prompt indicates that the field is editable.

Returns
A TCHAR data type.

◆ GetPromptString()

template<class TBase >
CString GetPromptString ( int nLength ) const
inline

This helper member function retrieves the string contains nLength prompt characters.

Parameters
nLength Length of string to create.
Returns
CString contains nLength prompt characters

◆ InsertCharAt()

template<class TBase >
void InsertCharAt | ( | int | iPos,
 |  | TCHAR | nChar )
 inline

Inserts character to specified position.

Parameters
iPos | Position to insert
nChar | Character to be inserted

◆ IsModified()

template<class TBase >
BOOL IsModified ( ) const
inline

This member function is called to determine if the text has been modified.

Returns
TRUE if the text has changed, otherwise returns FALSE.

◆ MaskClear()

template<class TBase >
afx_msg BOOL MaskClear ( )
inline

This member function is called to clear the current text selection.

Returns
TRUE if successful, FALSE otherwise.

◆ MaskCopy()

template<class TBase >
afx_msg BOOL MaskCopy ( )
inline

This member function is called to perform a copy operation using the currently selected text.

Returns
TRUE if successful, FALSE otherwise.

◆ MaskCut()

template<class TBase >
afx_msg BOOL MaskCut ( )
inline

This member function is called to perform a cut operation using the currently selected text.

Returns
TRUE if successful, FALSE otherwise.

◆ MaskPaste()

template<class TBase >
afx_msg BOOL MaskPaste ( )
inline

This member function is called to perform a paste operation using the current clipboard text.

Returns
TRUE if successful, FALSE otherwise.

◆ MaskReplaceSel()

template<class TBase >
void MaskReplaceSel ( LPCTSTR lpszNewText )
inline

This member function is called to perform a replace operation using the currently selected text.

Parameters
lpszNewText Text to replace.

◆ MaskUndo()

template<class TBase >
afx_msg BOOL MaskUndo ( )
inline

This member function is called to undo the previous action.

Returns
TRUE if successful, FALSE otherwise.

◆ OnCommand()

template<class TBase >
virtual BOOL OnCommand | ( | WPARAM | wParam,
 |  | LPARAM | lParam )
 inlineprotectedvirtual

The framework calls this member function when the user selects an item from a menu.

Parameters
wParam | The low-order word of wParam identifies the command ID of the menu item, control, or accelerator. The high-order word of wParam specifies the notification message if the message is from a control. If the message is from an accelerator, the high-order word is 1. If the message is from a menu, the high-order word is 0
lParam | Identifies the control that sends the message if the message is from a control. Otherwise, lParam is 0.
Returns
An application returns nonzero if it processes this message; otherwise 0.

◆ PosInRange()

template<class TBase >
BOOL PosInRange ( int iPos ) const
inline

This member function is called to determine if the index specified by 'iPos' is a valid index for the currently displayed edit text.

Parameters
iPos Index of the character to check.
Returns
TRUE if the index is valid, otherwise returns FALSE.

◆ PreTranslateMessage()

template<class TBase >
virtual BOOL PreTranslateMessage ( MSG * pMsg )
inlinevirtual

Used by class CWinApp to translate window messages before they are dispatched to theTranslateMessage andDispatchMessage Windows functions.

Parameters
pMsg Points to a MSG structure that contains the message to process.
Returns
Nonzero if the message was translated and should not be dispatched; 0 if the message was not translated and should be dispatched.

◆ ProcessMask()

template<class TBase >
virtual BOOL ProcessMask | ( | TCHAR & | nChar,
 |  | int | nEndPos )
 inlinevirtual

This member function is used internally to process the character passed in by 'nChar' whose index is specified by 'nEndPos'.

Parameters
nChar | Contains the character code value of the key.
nEndPos | Index of character in display string.
Returns
TRUE if successful, otherwise returns FALSE.

Reimplemented in CXTPDateEdit, and CXTPTimeEdit.

◆ SetEditMask()

template<class TBase >
virtual BOOL SetEditMask | ( | LPCTSTR | lpszMask,
 |  | LPCTSTR | lpszLiteral,
 |  | LPCTSTR | lpszDefault = NULL )
 inlinevirtual

This member function will set the mask for the edit control.

Parameters
lpszMask | The format for the mask field. For example, if you wanted to set the mask for a phone number, and you only wanted digits to be entered, your mask might look like this; _T("(000) 000-0000").
lpszLiteral | The literal format is entered here. Wherever you place an underscore ('_') is where the user will be allowed to enter data only. Using the phone number example; _T("(___) ___-____").
lpszDefault | Text that is to be displayed when the control is initialized. For example; _T("(800) 555-1212"). If NULL, 'lpszLiteral' is used to initialize the edit text.

The values that can be set are:

Mask Character         Description
---------------------  ------------------------
0                      Numeric (0-9)
9                      Numeric (0-9) or space (' ')
#                      Numeric (0-9) or space (' ') or ('+') or ('-')
L                      Alpha (a-Z)
?                      Alpha (a-Z) or space (' ')
A                      Alpha numeric (0-9 and a-Z)
a                      Alpha numeric (0-9 and a-Z) or space (' ')
&                      All print character only
H                      Uppercase hex digit (0-9 and A-F)
h                      Lowercase hex digit (0-9 and a-f)
X                      Uppercase hex digit (0-9 and A-F) and space (' ')
x                      Lowercase hex digit (0-9 and a-f) and space (' ')
>                      Forces characters to upper case (A-Z) or any Unicode character
<                      Forces characters to lower case (a-z) or any Unicode character
C                      Uppercase ASCII character
c                      Lowercase ASCII character
Returns
TRUE if successful, FALSE otherwise.

Reimplemented in CXTPEdit.

◆ SetMaskedText()

template<class TBase >
void SetMaskedText | ( | LPCTSTR | lpszMaskedText,
 |  | int | iPos = 0,
 |  | BOOL | bUpdateWindow = TRUE )
 inline

This method called to set masked text for the edit control.

Parameters
lpszMaskedText | Text string without mask.
iPos | Start position from which current masked text will be updated. Default value 0 (the first position).
bUpdateWindow | If TRUE edit control window text and selection will be updated, otherwise only internal members take changes.

If a mask is used, then the mask will be applied to the text in lpszMaskedText.

◆ SetOverType()

template<class TBase >
void SetOverType ( BOOL bOverType )
inline

This member function is called to enable or disable type over, also known as insert mode.

Parameters
bOverType TRUE to enable type over.

◆ SetPromptChar()

template<class TBase >
void SetPromptChar | ( | TCHAR | ch,
 |  | BOOL | bAutoReplace = TRUE )
 inline

This member function is called to set the prompt character that is displayed to the user that indicates the field can be edited.

Parameters
ch | A TCHAR data type.
bAutoReplace | TRUE to auto replace

◆ SetUseMask()

template<class TBase >
void SetUseMask ( BOOL bUseMask )
inline

Call this member function to enable or disable the mask for the mask edit control.

Parameters
bUseMask TRUE to enable the mask. FALSE to disable the mask.
The documentation for this class was generated from the following file:
  • XTPMaskEditT.h


Toolkit Pro: CXTPMathUtils Class Reference

Static Public Member Functions | Static Public Attributes | List of all members
CXTPMathUtils Class Reference

This class provide some mathematical utility functions. More...

Static Public Member Functions

static double AFX_CDECL | NormalizeRadian (double angleRadian)
Call this function to normalize angle in radian i.e.
static double AFX_CDECL | NormalizeDegree (double angle)
Call this function to normalize angle in degree i.e.
static int AFX_CDECL | Sign (double value)
Call this function to check the sign of a double value.
static int AFX_CDECL | Compare (double value1, double value2)
Call this function to compare two double values.It also checks whether they are equal or almost equal.
static int AFX_CDECL | Compare (double value1, double value2, double epsilon)
Call this function to compare two double values.It also checks whether they are equal or almost equal based on a 3rd value.
static double AFX_CDECL | Radian2Degree (double angleRadian)
Call this function to convert radian angle to degree.
static double AFX_CDECL | Degree2Radian (double angleDegree)
Call this function to convert degree angle to radian.
static int AFX_CDECL | Round (double dValue)
Rounds a real value taking into account its sign and returns result as integer.
static double AFX_CDECL | GetNaN ()
Obtains Not-a-Number (NaN) value for double type.
static BOOL AFX_CDECL | IsNan (double x)
Checks if the value provided is Not-a-Number (NaN) value.
static void AFX_CDECL | ComputeTriangleNormal (double x1, double y1, double z1, double x2, double y2, double z2, double x3, double y3, double z4, double &nx, double &ny, double &nz, bool normalize=true, bool ccw=false)
Computes a normal for a triangle specified.
static double AFX_CDECL | GetSegmentLength (double x1, double y1, double x2, double y2)
Computes 2D line segment length.
static double AFX_CDECL | GetSegmentLength (double x1, double y1, double z1, double x2, double y2, double z2)
Computes 3D line segment length.
static BOOL AFX_CDECL | HitTestLineSegment (double x1, double y1, double x2, double y2, double xPoint, double yPoint, int nLineThickness)
Tests if the point specified hits a line segment determined by two points.
static BOOL AFX_CDECL | GetLinesIntersection (double x11, double y11, double x12, double y12, double x21, double y21, double x22, double y22, double &xi, double &yi)
Computes a point where two lines detemined by four points intersect.
static void AFX_CDECL | ComputeVectorCrossProduct (double x1, double y1, double z1, double x2, double y2, double z2, double &rx, double &ry, double &rz)
Computes vector cross product.
static double AFX_CDECL | ComputeVectorDotProduct (double x1, double y1, double z1, double x2, double y2, double z2)
Computes vector cross product.
static double AFX_CDECL | ComputeVectorLength (double x, double y, double z)
Computes vector length.

Static Public Attributes

static const double | m_dPI
Pi value.
static const double | m_dEPS
The smallest possible double value, or epsilon.

Detailed Description

This class provide some mathematical utility functions.

Member Function Documentation

◆ Compare() [1/2]

static int AFX_CDECL Compare | ( | double | value1,
 |  | double | value2 )
 static

Call this function to compare two double values.It also checks whether they are equal or almost equal.

Parameters
value1 | The first value.
value2 | The second value.
Returns
+1 if the value1 is greater than value2, -1 if vice versa. 0 if they are equal or almost equal.

It is a static function.

◆ Compare() [2/2]

static int AFX_CDECL Compare | ( | double | value1,
 |  | double | value2,
 |  | double | epsilon )
 static

Call this function to compare two double values.It also checks whether they are equal or almost equal based on a 3rd value.

Parameters
value1 | The first value.
value2 | The second value.
epsilon | The equality threshold.
Returns
+1 if the value1 is greater than value2, -1 if vice versa. 0 if they are equal or almost equal.

It is a static function.

◆ ComputeTriangleNormal()

static void AFX_CDECL ComputeTriangleNormal | ( | double | x1,
 |  | double | y1,
 |  | double | z1,
 |  | double | x2,
 |  | double | y2,
 |  | double | z2,
 |  | double | x3,
 |  | double | y3,
 |  | double | z4,
 |  | double & | nx,
 |  | double & | ny,
 |  | double & | nz,
 |  | bool | normalize = true,
 |  | bool | ccw = false )
 static

Computes a normal for a triangle specified.

Parameters
x1 | 1st triangle X coordinate.
y1 | 1st triangle Y coordinate.
z1 | 1st triangle Z coordinate.
x2 | 2nd triangle X coordinate.
y2 | 2nd triangle Y coordinate.
z2 | 2nd triangle Z coordinate.
x3 | 3rd triangle X coordinate.
y3 | 3rd triangle Y coordinate.
z4 | 3rd triangle Z coordinate.
nx | Result normal X value.
ny | Result normal Y value.
nz | Result normal Z value.
normalize | If true the result normal vector is clamped to 0..1 range.
ccw | Determines which side of the triangle the normal vector will be directed from. By default triangle points are assumed to be in close-wise order which determines the front face of the triangle for which the normal is computed. In order to reverse normal vector this value has to be false which means counter clock wise vertex unwinding.
Returns

◆ ComputeVectorCrossProduct()

static void AFX_CDECL ComputeVectorCrossProduct | ( | double | x1,
 |  | double | y1,
 |  | double | z1,
 |  | double | x2,
 |  | double | y2,
 |  | double | z2,
 |  | double & | rx,
 |  | double & | ry,
 |  | double & | rz )
 static

Computes vector cross product.

Parameters
x1 | 1st vector X coordinate.
y1 | 1st vector Y coordinate.
z1 | 1st vector Z coordinate.
x2 | 2nd vector X coordinate.
y2 | 2nd vector Y coordinate.
z2 | 2nd vector Z coordinate.
rx | Result vector X coordinate.
ry | Result vector Y coordinate.
rz | Result vector Z coordinate.
See also
ComputeVectorDotProduct, ComputeVectorLength
Returns

◆ ComputeVectorDotProduct()

static double AFX_CDECL ComputeVectorDotProduct | ( | double | x1,
 |  | double | y1,
 |  | double | z1,
 |  | double | x2,
 |  | double | y2,
 |  | double | z2 )
 static

Computes vector cross product.

Parameters
x1 | 1st vector X coordinate.
y1 | 1st vector Y coordinate.
z1 | 1st vector Z coordinate.
x2 | 2nd vector X coordinate.
y2 | 2nd vector Y coordinate.
z2 | 2nd vector Z coordinate.
Returns
Vector dot product value.
See also
ComputeVectorCrossProduct, ComputeVectorLength

◆ ComputeVectorLength()

static double AFX_CDECL ComputeVectorLength | ( | double | x,
 |  | double | y,
 |  | double | z )
 static

Computes vector length.

Parameters
x | Vector X coordinate.
y | Vector Y coordinate.
z | Vector Z coordinate.
Returns
Vector length value.
See also
ComputeVectorCrossProduct, ComputeVectorDotProduct

◆ Degree2Radian()

static double AFX_CDECL Degree2Radian ( double angleDegree )
static

Call this function to convert degree angle to radian.

Parameters
angleDegree The angle in degree.
Returns
A double value denoting the angle in radian.

It is a static function.

◆ GetLinesIntersection()

static BOOL AFX_CDECL GetLinesIntersection | ( | double | x11,
 |  | double | y11,
 |  | double | x12,
 |  | double | y12,
 |  | double | x21,
 |  | double | y21,
 |  | double | x22,
 |  | double | y22,
 |  | double & | xi,
 |  | double & | yi )
 static

Computes a point where two lines detemined by four points intersect.

Parameters
x11 | Line's one 1st point X coordinate.
y11 | Line's one 1st point Y coordinate.
x12 | Line's one 2nd point X coordinate.
y12 | Line's one 2nd point Y coordinate.
x21 | Line's two 1st point X coordinate.
y21 | Line's two 1st point Y coordinate.
x22 | Line's two 2nd point X coordinate.
y22 | Line's two 2nd point Y coordinate.
xi | On successful completion takes a value of X coordinate of line intersection position.
yi | On successful completion takes a value of Y coordinate of line intersection position.
Returns
TRUE if lines intersect and intersection point is found.

◆ GetNaN()

static double AFX_CDECL GetNaN ( )
static

Obtains Not-a-Number (NaN) value for double type.

Returns
Double NaN value.
See also
IsNan

◆ GetSegmentLength() [1/2]

static double AFX_CDECL GetSegmentLength | ( | double | x1,
 |  | double | y1,
 |  | double | x2,
 |  | double | y2 )
 static

Computes 2D line segment length.

Parameters
x1 | 1st point X coordinate.
y1 | 1st point Y coordinate.
x2 | 2nd point X coordinate.
y2 | 2nd point Y coordinate.
Returns
The distance between points provided.

◆ GetSegmentLength() [2/2]

static double AFX_CDECL GetSegmentLength | ( | double | x1,
 |  | double | y1,
 |  | double | z1,
 |  | double | x2,
 |  | double | y2,
 |  | double | z2 )
 static

Computes 3D line segment length.

Parameters
x1 | 1st point X coordinate.
y1 | 1st point Y coordinate.
z1 | 1st point Z coordinate.
x2 | 2nd point X coordinate.
y2 | 2nd point Y coordinate.
z2 | 2nd point Z coordinate.
Returns
The distance between points provided.

◆ HitTestLineSegment()

static BOOL AFX_CDECL HitTestLineSegment | ( | double | x1,
 |  | double | y1,
 |  | double | x2,
 |  | double | y2,
 |  | double | xPoint,
 |  | double | yPoint,
 |  | int | nLineThickness )
 static

Tests if the point specified hits a line segment determined by two points.

Parameters
x1 | 1st point X coordinate.
y1 | 1st point Y coordinate.
x2 | 2nd point X coordinate.
y2 | 2nd point Y coordinate.
xPoint | X coordinate of the point being tested.
yPoint | Y coordinate of the point being tested.
nLineThickness | Line thickness.
Returns
TRUE if the point provided hits the line segment.

◆ IsNan()

static BOOL AFX_CDECL IsNan ( double x )
static

Checks if the value provided is Not-a-Number (NaN) value.

Parameters
x A value to check.
Returns
TRUE if the value provided is NaN value.
See also
GetNaN

◆ NormalizeDegree()

static double AFX_CDECL NormalizeDegree ( double angle )
static

Call this function to normalize angle in degree i.e.

bring the value within the range of 0 and 360.

Parameters
angle Angle in degree.
Returns
A double value denoting the normalized degree.

It is a static function.

◆ NormalizeRadian()

static double AFX_CDECL NormalizeRadian ( double angleRadian )
static

Call this function to normalize angle in radian i.e.

bring the value within the range of 0 - 2PI.

Parameters
angleRadian Angle in radians.
Returns
A double value denoting the normalized radian.

It is a static function.

◆ Radian2Degree()

static double AFX_CDECL Radian2Degree ( double angleRadian )
static

Call this function to convert radian angle to degree.

Parameters
angleRadian The angle in radian.
Returns
A double value denoting the angle in degree.

It is a static function.

◆ Round()

static int AFX_CDECL Round ( double dValue )
static

Rounds a real value taking into account its sign and returns result as integer.

Parameters
dValue A value to be rounded.
Returns
A rounded value casted to integer type.

◆ Sign()

static int AFX_CDECL Sign ( double value )
static

Call this function to check the sign of a double value.

Parameters
value The double value.
Returns
+1 if the value is positive and -1 if the value negative.

It is a static function.

The documentation for this class was generated from the following file:
  • XTPMathUtils.h


Toolkit Pro: CXTPMatrix< T > Class Template Reference

Public Member Functions | List of all members
CXTPMatrix< T > Class Template Reference

Represents a matrix object built upon a continuos array of elements and provides basic algorithms for it. More...

Inheritance diagram for CXTPMatrix< T >:
[legend]

Public Member Functions

CXTPMatrix (UINT nWidth, UINT nHeight)
Constructs a matrix object of the specified size where each element is set to zero.
~CXTPMatrix ()
Handles matrix deallocation.
UINT | GetWidth () const
Obtains the width of the matrix.
UINT | GetHeight () const
Obtains the height of the matrix.
T * | GetData ()
Obtains a point to the first element of the continuous array upon which the matrix is built.
const T * | GetData () const
Obtains a point to the first element of the continuous array upon which the matrix is built.
CXTPMatrix< T > * | Clone () const
Clones the matrix.
BOOL | Equals (const CXTPMatrix< T > &m) const
Compares the current matrix to the matrix oject specified.
T | GetAt (UINT nCol, UINT nRow) const
Obtains an element value at the specified location.
void | SetAt (UINT nCol, UINT nRow, T value)
Sets element value at the specified location.
void | Set (const CXTPMatrix< T > &m)
Makes the current matrix identical to the matrix provided.
void | SetZero ()
Sets all matrix elements to 0.
void | SetIdentity ()
Make the current matrix an identity matrix, i.e.
void | Add (const CXTPMatrix< T > &m)
Adds the matrix provided to the current matrix.
void | Subtract (const CXTPMatrix< T > &m)
Subtracts the matrix provided from the current matrix.
void | Rotate (T xQuat, T yQuat, T zQuat, T wQuat)
Rotates 4x4 matrix using quaternion parameters.
CXTPMatrix< T > * | Multiply (const CXTPMatrix< T > &m) const
Multiplies the current matrix of size MxN to the provided matrix of size LxM.
CXTPMatrix< T > * | Transpose () const
Creates a transposed matrix, i.e.

Detailed Description

template<class T>
class CXTPMatrix< T >

Represents a matrix object built upon a continuos array of elements and provides basic algorithms for it.

Constructor & Destructor Documentation

◆ CXTPMatrix()

template<class T >
AFX_INLINE CXTPMatrix | ( | UINT | nWidth,
 |  | UINT | nHeight )

Constructs a matrix object of the specified size where each element is set to zero.

If either side is equal to 0 then the matrix is considered to be a valid empty matrix.

Parameters
nWidth | The width of the matrix.
nHeight | The height of the matrix.

Member Function Documentation

◆ Add()

template<class T >
AFX_INLINE void Add ( const CXTPMatrix< T > & m )

Adds the matrix provided to the current matrix.

Both matrixes have to be of the same size.

Parameters
m A matrix to add to the current matrix.
See also
Subtract, Multiply, Rotate, Transpose

◆ Clone()

template<class T >
AFX_INLINE CXTPMatrix< T > * Clone ( ) const

Clones the matrix.

Returns
A pointer to the new cloned matrix object. The caller is responsible for releasing resources using delete operator.

◆ Equals()

template<class T >
AFX_INLINE BOOL Equals ( const CXTPMatrix< T > & m ) const

Compares the current matrix to the matrix oject specified.

Parameters
m A matrix to compare to.
Returns
TRUE if the dimensions and all emlements of both matrices are identical.

◆ GetAt()

template<class T >
AFX_INLINE T GetAt | ( | UINT | nCol,
 |  | UINT | nRow ) const

Obtains an element value at the specified location.

Parameters
nCol | Zero-based column index.
nRow | Zero-based row index.
Returns
Element value at the specified location.
See also
SetAt

◆ GetData() [1/2]

template<class T >
AFX_INLINE T * GetData ( )

Obtains a point to the first element of the continuous array upon which the matrix is built.

Returns
The value of the pointer of the first element in the array or NULL if matrix is empty.

◆ GetData() [2/2]

template<class T >
AFX_INLINE const T * GetData ( ) const

Obtains a point to the first element of the continuous array upon which the matrix is built.

Returns
The value of the pointer of the first element in the array or NULL if matrix is empty.

◆ GetHeight()

template<class T >
AFX_INLINE UINT GetHeight ( ) const

Obtains the height of the matrix.

Returns
The height of the matrix.
See also
GetWidth

◆ GetWidth()

template<class T >
AFX_INLINE UINT GetWidth ( ) const

Obtains the width of the matrix.

Returns
The width of the matrix.
See also
GetHeight

◆ Multiply()

template<class T >
AFX_INLINE CXTPMatrix< T > * Multiply ( const CXTPMatrix< T > & m ) const

Multiplies the current matrix of size MxN to the provided matrix of size LxM.

The current matrix is on the left hand side of the multiplication expression.

Parameters
m A matrix to be multiplied with. A caller is responsible for releasing allocation resources using delete operator.
Returns
A new matrix of size LxN which contains the result of matrix multiplication.
See also
Add, Subtract, Transpose, Rotate

◆ Rotate()

template<class T >
AFX_INLINE void Rotate | ( | T | xQuat,
 |  | T | yQuat,
 |  | T | zQuat,
 |  | T | wQuat )

Rotates 4x4 matrix using quaternion parameters.

Parameters
xQuat | X coordinate of the rotation vector.
yQuat | Y coordinate of the rotation vector.
zQuat | Z coordinate of the rotation vector.
wQuat | Rotation angle.
See also
Add, Subtract, Multiply, Transpose

◆ Set()

template<class T >
AFX_INLINE void Set ( const CXTPMatrix< T > & m )

Makes the current matrix identical to the matrix provided.

Parameters
m A matrix object to make the current matrix identical to.

◆ SetAt()

template<class T >
AFX_INLINE void SetAt | ( | UINT | nCol,
 |  | UINT | nRow,
 |  | T | value )

Sets element value at the specified location.

Parameters
nCol | Zero-based column index.
nRow | Zero-based row index.
value | A new element value.
See also
GetAt

◆ SetIdentity()

template<class T >
AFX_INLINE void SetIdentity ( )

Make the current matrix an identity matrix, i.e.

all elements are set to 0 and the main diagonal elements are set to 1. Requires the matrix to be a square matrix.

See also
SetZero

◆ SetZero()

template<class T >
AFX_INLINE void SetZero ( )

Sets all matrix elements to 0.

See also
SetIdentity

◆ Subtract()

template<class T >
AFX_INLINE void Subtract ( const CXTPMatrix< T > & m )

Subtracts the matrix provided from the current matrix.

Both matrixes have to be of the same size.

Parameters
m A matrix to subtract from the current matrix.
See also
Add, Multiply, Rotate, Transpose

◆ Transpose()

template<class T >
AFX_INLINE CXTPMatrix< T > * Transpose ( ) const

Creates a transposed matrix, i.e.

rows and columns are swapped.

Returns
A new transposed matrix object. A caller is responsible for releasing allocation resources using delete operator.
See also
Add, Subtract, Multiply, Rotate
The documentation for this class was generated from the following files:
  • XTPChartDrawingObjectFactory.h
  • XTPMatrix.h


Toolkit Pro: CXTPMDIClientWnd Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPMDIClientWnd Class Reference

CXTPMDIClientWnd is a CWnd derived helper class for the CXTPMDIWndTab tab control. More...

Public Member Functions

CXTPMDIClientWnd (CXTPMDIWndTab *pMDIWndTab)
Constructs a CXTPMDIClientWnd object.
virtual | ~CXTPMDIClientWnd ()
Destroys a CXTPMDIClientWnd object, handles cleanup and deallocation.
void | SetBorderGap (int iSize)
This member function will set the size of the gap between the client area and the tab control.

Protected Attributes

int | m_iBorderGap
Amount, in pixels, between the client and the tab control.
CXTPMDIWndTab * | m_pMDIWndTab
Pointer to the MDI tab control.

Detailed Description

CXTPMDIClientWnd is a CWnd derived helper class for the CXTPMDIWndTab tab control.

This class routes messages sent to the client window back to the tab control.

Constructor & Destructor Documentation

◆ CXTPMDIClientWnd()

CXTPMDIClientWnd ( CXTPMDIWndTab * pMDIWndTab )

Constructs a CXTPMDIClientWnd object.

Parameters
pMDIWndTab Pointer to a CXTPMDITabWnd object.

Member Function Documentation

◆ SetBorderGap()

void SetBorderGap ( int iSize )

This member function will set the size of the gap between the client area and the tab control.

Parameters
iSize Amount, in pixels, of gap between the tab control and the client.
The documentation for this class was generated from the following file:
  • XTPMDIWndTab.h


Toolkit Pro: CXTPMDIFrameWnd Class Reference

Public Member Functions | List of all members
CXTPMDIFrameWnd Class Reference

CXTPMDIFrameWnd is a CXTPFrameWndBase derived class. More...

Inheritance diagram for CXTPMDIFrameWnd:
[legend]

Public Member Functions

DECLARE_DYNCREATE (CXTPMDIFrameWnd) CXTPMDIFrameWnd()
Constructs a CXTPMDIFrameWnd object.
void | UpdateMDIChildrenTheme ()
Sends a theme update notification to all MDI children.
- Public Member Functions inherited from CXTPFrameWndBase< CMDIFrameWnd >
CXTPFrameWndBase ()
Constructs a CXTPFrameWndBase object.
~CXTPFrameWndBase ()
Destroys a CXTPFrameWndBase object, handles cleanup and deallocation.
- Public Member Functions inherited from CXTPCommandBarsSiteBase< CMDIFrameWnd >
CXTPCommandBarsSiteBase ()
Constructs a CXTPCommandBarsSiteBase object.
~CXTPCommandBarsSiteBase ()
Destroys a CXTPCommandBarsSiteBase object, handles cleanup and deallocation.
virtual BOOL | InitCommandBars (CRuntimeClass *pCommandBarsClass=RUNTIME_CLASS(CXTPCommandBars))
Creates command bars.
void | DockRightOf (CXTPToolBar *pBarToDock, CXTPToolBar *pBarOnLeft)
This member function will re-dock a toolbar specified by 'pBarToDock' to the right of a newly docked toolbar specified by 'pBarOnLeft'.
virtual void | SaveCommandBars (LPCTSTR lpszProfileName)
Call this function to save the state information to the registry or .INI file.
virtual void | LoadCommandBars (LPCTSTR lpszProfileName, BOOL bSilent=FALSE)
Call this function to retrieve state information from the registry or .INI file.
CXTPCommandBars * | GetCommandBars () const
Call this member to retrieve a pointer to the CommandBars object.

Detailed Description

CXTPMDIFrameWnd is a CXTPFrameWndBase derived class.

The documentation for this class was generated from the following file:
  • XTPFrameWnd.h


Toolkit Pro: CXTPMDIFrameWndEx Class Reference

Public Member Functions | List of all members
CXTPMDIFrameWndEx Class Referenceabstract

CXTPMDIFrameWndEx is a CXTPMDIFrameWnd derived class. More...

Inheritance diagram for CXTPMDIFrameWndEx:
[legend]

Public Member Functions

DECLARE_DYNAMIC (CXTPMDIFrameWndEx) CXTPMDIFrameWndEx()
Constructs a CXTPMDIFrameWndEx object.
virtual | ~CXTPMDIFrameWndEx ()
Handles CXTPMDIFrameWndEx object destruction.
virtual CXTPTabClientWnd * | GetTabClientWnd ()=0
Obtains the associated tab client pointer.
- Public Member Functions inherited from CXTPMDIFrameWnd
DECLARE_DYNCREATE (CXTPMDIFrameWnd) CXTPMDIFrameWnd()
Constructs a CXTPMDIFrameWnd object.
void | UpdateMDIChildrenTheme ()
Sends a theme update notification to all MDI children.
- Public Member Functions inherited from CXTPFrameWndBase< CMDIFrameWnd >
CXTPFrameWndBase ()
Constructs a CXTPFrameWndBase object.
~CXTPFrameWndBase ()
Destroys a CXTPFrameWndBase object, handles cleanup and deallocation.
- Public Member Functions inherited from CXTPCommandBarsSiteBase< CMDIFrameWnd >
CXTPCommandBarsSiteBase ()
Constructs a CXTPCommandBarsSiteBase object.
~CXTPCommandBarsSiteBase ()
Destroys a CXTPCommandBarsSiteBase object, handles cleanup and deallocation.
virtual BOOL | InitCommandBars (CRuntimeClass *pCommandBarsClass=RUNTIME_CLASS(CXTPCommandBars))
Creates command bars.
void | DockRightOf (CXTPToolBar *pBarToDock, CXTPToolBar *pBarOnLeft)
This member function will re-dock a toolbar specified by 'pBarToDock' to the right of a newly docked toolbar specified by 'pBarOnLeft'.
virtual void | SaveCommandBars (LPCTSTR lpszProfileName)
Call this function to save the state information to the registry or .INI file.
virtual void | LoadCommandBars (LPCTSTR lpszProfileName, BOOL bSilent=FALSE)
Call this function to retrieve state information from the registry or .INI file.
CXTPCommandBars * | GetCommandBars () const
Call this member to retrieve a pointer to the CommandBars object.

Detailed Description

CXTPMDIFrameWndEx is a CXTPMDIFrameWnd derived class.

Member Function Documentation

◆ GetTabClientWnd()

virtual CXTPTabClientWnd * GetTabClientWnd ( )
pure virtual

Obtains the associated tab client pointer.

Returns
The associated tab client pointer.
The documentation for this class was generated from the following file:
  • XTPFrameWnd.h


Toolkit Pro: CXTPMDIWndTab Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPMDIWndTab Class Reference

The CXTPMDIWndTab class is used for creating a tabbed MDI document interface. More...

Public Member Functions

CXTPMDIWndTab ()
Constructs a CXTPMDIWndTab object.
virtual | ~CXTPMDIWndTab ()
Destroys a CXTPMDIWndTab object, handles cleanup and deallocation.
bool | SetTabIcon (int iIndex, HICON &hIcon)
Call this member function to set the icon for the tab item specified by 'iIndex'.
bool | SetTabIcon (HWND hChildWnd, HICON &hIcon)
Call this member function to set the icon for the tab item specified by 'iIndex'.
bool | SetTabLabel (int iIndex, CString &strLabel)
Call this member function to set the label for the tab item specified by 'iIndex'.
bool | SetTabLabel (HWND hChildWnd, CString &strLabel)
Call this member function to set the label for the tab item specified by 'iIndex'.
virtual BOOL | Install (CMDIFrameWnd *pMDIFrameWnd, DWORD dwStyle=TCS_BOTTOM|TCS_HOTTRACK, BOOL bNoIcons=TRUE)
This member function will install the MDI tab views with your application.
virtual BOOL | UnInstall ()
This member function will uninstall the MDI tab views from your application.
int | TabFromPoint (CPoint point) const
Call this member function to retrieve the tab index from the current cursor position.
CMDIChildWnd * | GetFrameWnd (int iIndex=-1) const
This member function will retrieve a pointer to the child frame associated with the tab item.
CMDIChildWnd * | GetFrameWnd (CPoint point) const
This member function will retrieve a pointer to the child frame associated with the tab item.
void | SetMenuID (UINT popupMenuID, int nPos=0, UINT nDefCmd=(UINT) -1)
This member function is used to set the resource ID for the pop-up menu used by the tab control.
void | SetBorderGap (int iSize)
This member function will set the size of the gap between the client area and the tab control.
CString | GetChildWndText (HWND hWnd) const
This member function will get the text for the specified MDI child window.

Protected Member Functions

virtual BOOL | Init ()
This member function is called by the CXTPMDIWndTab class to perform initialization when the window is created or sub-classed.
virtual void | InitializeFont ()
This member function is called to initialize the font for the tab control associated with this view.
virtual void | InsertTabWnd (CMDIChildWnd *pChildFrame, BOOL bRecalcLayout=TRUE)
This member function is called to insert a child frame into the MDI tab control.
BOOL | RefreshActiveSel ()
This member function is called by the tab control to ensure that the current selection matches the active document.
void | RefreshTabLabels ()
This member function is called by the tab control to ensure that the tab labels match their corresponding views.
void | RefreshIndexes ()
This member function is called by the tab control to ensure that the stored indexes match their corresponding tab indexes.
virtual void | OnMDICreate (HWND hWnd)
Called when a WM_MDICREATE message is sent to a multiple-document interface (MDI) client window to create an MDI child window.
virtual void | OnMDIDestroy (HWND hWnd)
Called when a WM_MDIDESTROY message is sent to a multiple-document interface (MDI) client window to close an MDI child window.
virtual void | OnMDIActivate (HWND hWnd)
Called when a WM_MDIACTIVATE message is sent to a multiple-document interface (MDI) client window to instruct the client window to activate a different MDI child window.
virtual void | RecalcLayout (BOOL bDelayRecalc)
Called to refresh the tab labels and frame window layout.

Protected Attributes

int | m_iBorderGap
Amount, in pixels, between the client and the tab control.
int | m_iHitTest
Index of the tab that received a right click.
int | m_nPos
Index of the pop-up menu contained in the menu.
UINT | m_nDefCmd
Command ID of the default menu item for the pop-up menu.
UINT | m_popupMenuID
Pop-up menu resource ID.
HWND | m_hActiveChild
Active MDI child.
BOOL | m_bNoIcons
TRUE if no icons are used.
DWORD | m_dwInitSignature
Initialization state signature to synch up posted init requests.
CImageList | m_imageList
Tab image list.
CMDIFrameWnd * | m_pMDIFrameWnd
Pointer to the owner frame.
CMDIChildList | m_arMDIChildern
Array of the MDI windows added to the tab control.
CXTPMDIClientWnd * | m_pMDIClientWnd
Window that receives messages on behalf of the MDI client.
CIconWndMap | m_mapTabIcons
Hash table that maps icons to the MDI child frame windows.
CStringMap | m_mapTabLabels
Hash table that maps labels to the MDI child frame windows.

Detailed Description

The CXTPMDIWndTab class is used for creating a tabbed MDI document interface.

CXTPMDIWndTab is derived from CTabCtrl and CXTPTabCtrlBase and is used to create a tab control for a multiple document interface (MDI) application. Example: The following example demonstrates the use of CXTPMDIWndTab:

// Install the MDI tab window.
m_wndMDITabWindow.Install(this, NULL, TRUE);
m_wndMDITabWindow.SetBorderGap(1);

Member Function Documentation

◆ GetChildWndText()

CString GetChildWndText ( HWND hWnd ) const

This member function will get the text for the specified MDI child window.

Parameters
hWnd Handle to a valid CMDIChildWnd object.
Returns
A const CString object that represents the document title.

◆ GetFrameWnd() [1/2]

CMDIChildWnd * GetFrameWnd ( CPoint point ) const

This member function will retrieve a pointer to the child frame associated with the tab item.

Parameters
point CPoint object that represents the cursor position.
Returns
A CWnd object if successful, otherwise NULL.

◆ GetFrameWnd() [2/2]

CMDIChildWnd * GetFrameWnd ( int iIndex = -1 ) const

This member function will retrieve a pointer to the child frame associated with the tab item.

Parameters
iIndex Index of the tab control. If -1, then the tab under the mouse when the last right click was performed will be used.
Returns
A CWnd object if successful, otherwise NULL.

◆ Init()

virtual BOOL Init ( )
protectedvirtual

This member function is called by the CXTPMDIWndTab class to perform initialization when the window is created or sub-classed.

Returns
TRUE if the window was successfully initialized, otherwise FALSE.

◆ InsertTabWnd()

virtual void InsertTabWnd | ( | CMDIChildWnd * | pChildFrame,
 |  | BOOL | bRecalcLayout = TRUE )
 protectedvirtual

This member function is called to insert a child frame into the MDI tab control.

Parameters
pChildFrame | A pointer to a valid child frame window.
bRecalcLayout | TRUE to force the MDI frame window to recalculate the layout.

◆ Install()

virtual BOOL Install | ( | CMDIFrameWnd * | pMDIFrameWnd,
 |  | DWORD | dwStyle = TCS_BOTTOM|TCS_HOTTRACK,
 |  | BOOL | bNoIcons = TRUE )
 virtual

This member function will install the MDI tab views with your application.

Parameters
pMDIFrameWnd | Pointer to the parent MDI frame window.
dwStyle | Style for the tab control. It can be any of the TCS_ values.
bNoIcons | TRUE to not display icons.
Returns
TRUE if successful, otherwise returns FALSE.

◆ OnMDIActivate()

virtual void OnMDIActivate ( HWND hWnd )
protectedvirtual

Called when a WM_MDIACTIVATE message is sent to a multiple-document interface (MDI) client window to instruct the client window to activate a different MDI child window.

Parameters
hWnd Handle to the destination control.

◆ OnMDICreate()

virtual void OnMDICreate ( HWND hWnd )
protectedvirtual

Called when a WM_MDICREATE message is sent to a multiple-document interface (MDI) client window to create an MDI child window.

Parameters
hWnd Handle to the destination control.

◆ OnMDIDestroy()

virtual void OnMDIDestroy ( HWND hWnd )
protectedvirtual

Called when a WM_MDIDESTROY message is sent to a multiple-document interface (MDI) client window to close an MDI child window.

Parameters
hWnd Handle to the destination control.

◆ RecalcLayout()

virtual void RecalcLayout ( BOOL bDelayRecalc )
protectedvirtual

Called to refresh the tab labels and frame window layout.

Parameters
bDelayRecalc TRUE to call DelayRecalcLayout for the parent frame.

◆ RefreshActiveSel()

BOOL RefreshActiveSel ( )
protected

This member function is called by the tab control to ensure that the current selection matches the active document.

Returns
FALSE if there is no active document, otherwise TRUE.

◆ SetBorderGap()

void SetBorderGap ( int iSize )

This member function will set the size of the gap between the client area and the tab control.

Parameters
iSize Amount, in pixels, of gap between the tab control and the client.

◆ SetMenuID()

void SetMenuID | ( | UINT | popupMenuID,
 |  | int | nPos = 0,
 |  | UINT | nDefCmd = (UINT) -1 )

This member function is used to set the resource ID for the pop-up menu used by the tab control.

Parameters
popupMenuID | ID for the tab control pop-up menu.
nPos | Index position in the menu resource.
nDefCmd | ID of the default menu command. Will display bold.

◆ SetTabIcon() [1/2]

bool SetTabIcon | ( | HWND | hChildWnd,
 |  | HICON & | hIcon )

Call this member function to set the icon for the tab item specified by 'iIndex'.

Parameters
hChildWnd | Valid HWND of the MDI child window to set the tab icon for.
hIcon | Reference to a HICON handle that represents the tab icon.
Returns
true if successful, otherwise false.

◆ SetTabIcon() [2/2]

bool SetTabIcon | ( | int | iIndex,
 |  | HICON & | hIcon )

Call this member function to set the icon for the tab item specified by 'iIndex'.

Parameters
iIndex | Zero-based index of the tab to set the tab icon for.
hIcon | Reference to a HICON handle that represents the tab icon.
Returns
true if successful, otherwise false.

◆ SetTabLabel() [1/2]

bool SetTabLabel | ( | HWND | hChildWnd,
 |  | CString & | strLabel )

Call this member function to set the label for the tab item specified by 'iIndex'.

Parameters
hChildWnd | Valid HWND of the MDI child window to set the tab text for.
strLabel | Reference to a CString object that represents the tab label.
Returns
true if successful, otherwise false.

◆ SetTabLabel() [2/2]

bool SetTabLabel | ( | int | iIndex,
 |  | CString & | strLabel )

Call this member function to set the label for the tab item specified by 'iIndex'.

Parameters
iIndex | Zero-based index of the tab to set the tab text for.
strLabel | Reference to a CString object that represents the tab label.
Returns
true if successful, otherwise false.

◆ TabFromPoint()

int TabFromPoint ( CPoint point ) const

Call this member function to retrieve the tab index from the current cursor position.

Parameters
point Pointer to a CPoint object that contains the cursor screen coordinates. Use default for the current cursor position.
Returns
The zero-based index of the tab, or -1 if no tab is at the specified point.

◆ UnInstall()

virtual BOOL UnInstall ( )
virtual

This member function will uninstall the MDI tab views from your application.

Returns
TRUE if successful, otherwise FALSE.
The documentation for this class was generated from the following file:
  • XTPMDIWndTab.h


Toolkit Pro: CXTPMemFile Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPMemFile Class Reference

CXTPMemFile is a CMemFile derived class. More...

Public Member Functions

CXTPMemFile (UINT nGrowBytes=1024)
Constructs a CXTPMemFile object.
CXTPMemFile (BYTE *lpBuffer, UINT nBufferSize, UINT nGrowBytes=0)
Constructs a CXTPMemFile object.
CXTPMemFile (LPCTSTR lpszFileName, UINT uiOpenFlags)
Constructs a CXTPMemFile object.
virtual | ~CXTPMemFile ()
Destroys a CXTPMemFile object, handles cleanup and deallocation.
virtual void | Flush ()
This member function forces any data remaining in the file buffer to be written to the file.
virtual BOOL | Open (LPCTSTR lpszFileName, UINT nOpenFlags, CFileException *pError=NULL)
This member function opens and loads a physical file into memory.
virtual void | Close ()
This member function saves the contents of the memory to the disk and closes it.
virtual BOOL | ReadString (CString &rString)
This member function reads a string.
virtual void | WriteString (LPCTSTR lpsz)
This method writes data from a buffer to the file associated with the CArchive object.
virtual bool | Duplicate (CFile *fDuplicate)
This member function will initialize the CXTPMemFile object with the information specified in the 'fDuplicate' object.
virtual bool | Duplicate (LPCTSTR strDup)
This member function will initialize the CXTPMemFile object with the information specified in the 'fDuplicate' object.
virtual bool | Discard ()
This member function discards all changes to the file since Open() or last Flush().
virtual DWORD | Insert (CFile *fSrc, DWORD dwSourcePos, DWORD dwDestPos, DWORD dwBytes)
This member function inserts any file and retrieves the length of the actual copied bytes.
virtual DWORD | Insert (LPCTSTR strSrc, DWORD dwSourcePos, DWORD dwDestPos, DWORD dwBytes)
This member function inserts any file and retrieves the length of the actual copied bytes.
virtual DWORD | Extract (CFile *fDest, DWORD dwStartPos, DWORD dwBytes)
This member function extracts bytes to a file and retrieves the length of the actual copied bytes.
virtual DWORD | Extract (LPCTSTR strDest, DWORD dwStartPos, DWORD dwBytes)
This member function extracts bytes to a file and retrieves the length of the actual copied bytes.
LONG | FindData (void *pData, DWORD dwDataLen, LONG lStartPos)
This member function finds data in the file.
void | operator= (CFile *fDup)
This member operator will initialize the CXTPMemFile object with the object specified by 'fDup'.
void | operator= (CString strDup)
This member operator will initialize the CXTPMemFile object with the object specified by 'strDup'.
void | operator= (DWORD dwFilePos)
This member operator will adjust the file position.
void | operator+= (CFile *fApp)
This member operator will append the CXTPMemFile object with the object specified by 'fApp'.
void | operator+= (CString strApp)
This member operator will append the CXTPMemFile object with the object specified by 'strApp'.
BYTE | operator[] (DWORD dwFilePos)
This member operator will perform indexing operations for the CXTPMemFile object.

Protected Member Functions

virtual bool | Load ()
This member function loads the file into memory.
virtual bool | Save ()
This member function saves the file to disk.
virtual bool | Import (CFile *fImp)
This member function imports the data of a CFile derived object (operator=).
virtual bool | Append (CFile *fApp)
This member function appends a CFile derived object to the file (operator+=).

Detailed Description

CXTPMemFile is a CMemFile derived class.

It is used to create a CXTPMemFile object to support memory files.

These memory files behave like disk files except that the file is stored in RAM rather than on disk. A memory file is useful for fast temporary storage or for transferring raw bytes or serialized objects between independent processes.

CXTPMemFile objects can automatically allocate their own memory, or you can attach your own memory block to the CXTPMemFile object by calling Attach. In either case, memory for growing the memory file automatically is allocated in nGrowBytes-sized increments if 'nGrowBytes' is not zero.

The memory block will automatically be deleted upon destruction of the CXTPMemFile object if the memory was originally allocated by the CXTPMemFile object. Otherwise, you are responsible for de-allocating the memory you attached to the object.

You can access the memory block through the pointer supplied when you detach it from the CXTPMemFile object by calling Detach.

The most common use of CXTPMemFile is to create a CXTPMemFile object and use it by calling CFile member functions. Note that creating a CXTPMemFile automatically opens it: you do not call CFile::Open, which is only used for disk files. Because CXTPMemFile doesn't use a disk file, the data member CFile::m_hFile is not used and has no meaning.

The CFile member functions Duplicate, LockRange, and UnlockRange are not implemented for CXTPMemFile. If you call these functions on a CXTPMemFile object, you will get a CNotSupportedException.

CXTPMemFile uses the run-time library functions malloc, realloc, and free to allocate, reallocate, and deallocate memory and the intrinsic memcpy to block copy memory when reading and writing. If you would like to change this behavior or the behavior when CXTPMemFile grows a file, derive your own class from CXTPMemFile and override the appropriate functions.

Constructor & Destructor Documentation

◆ CXTPMemFile() [1/3]

CXTPMemFile ( UINT nGrowBytes = 1024 )

Constructs a CXTPMemFile object.

This overload opens an empty memory file. Note that the file is opened by the constructor and that you should not call CFile::Open.

Parameters
nGrowBytes The memory allocation increment in bytes.

◆ CXTPMemFile() [2/3]

CXTPMemFile | ( | BYTE * | lpBuffer,
 |  | UINT | nBufferSize,
 |  | UINT | nGrowBytes = 0 )

Constructs a CXTPMemFile object.

This overload opens an empty memory file. Note that the file is opened by the constructor and that you should not call CFile::Open.

Parameters
nGrowBytes | The memory allocation increment in bytes.
lpBuffer | Pointer to the buffer to be attached to CXTPMemFile.
nBufferSize | An integer that specifies the size of the buffer in bytes.

◆ CXTPMemFile() [3/3]

CXTPMemFile | ( | LPCTSTR | lpszFileName,
 |  | UINT | uiOpenFlags )

Constructs a CXTPMemFile object.

This overload opens an empty memory file. Note that the file is opened by the constructor and that you should not call CFile::Open.

Parameters
lpszFileName | A string that is the path to the desired file. The path can be relative, absolute, or a network name (UNC).
uiOpenFlags | A UINT that defines the file's sharing and access mode. It specifies the action to take when opening the file. You can combine options by using the bitwise-OR (|) operator. One access permission and one share option are required. The modeCreate and modeNoInherit modes are optional. See the CFile constructor for a list of mode options.

Member Function Documentation

◆ Append()

virtual bool Append ( CFile * fApp )
protectedvirtual

This member function appends a CFile derived object to the file (operator+=).

Parameters
fApp A pointer to a valid CFile object.
Returns
true if successful, otherwise false.

◆ Discard()

virtual bool Discard ( )
virtual

This member function discards all changes to the file since Open() or last Flush().

Returns
true if successful, otherwise false.

◆ Duplicate() [1/2]

virtual bool Duplicate ( CFile * fDuplicate )
virtual

This member function will initialize the CXTPMemFile object with the information specified in the 'fDuplicate' object.

Parameters
fDuplicate A pointer to a valid CFile object.
Returns
true if successful, otherwise false.

◆ Duplicate() [2/2]

virtual bool Duplicate ( LPCTSTR strDup )
virtual

This member function will initialize the CXTPMemFile object with the information specified in the 'fDuplicate' object.

Parameters
strDup A NULL-terminated string.
Returns
true if successful, otherwise false.

◆ Extract() [1/2]

virtual DWORD Extract | ( | CFile * | fDest,
 |  | DWORD | dwStartPos,
 |  | DWORD | dwBytes )
 virtual

This member function extracts bytes to a file and retrieves the length of the actual copied bytes.

Parameters
fDest | A pointer to a valid CFile object.
dwStartPos | Represents the starting position.
dwBytes | Number of bytes to extract.
Returns
A DWORD value that represents the length of the copied bytes.

◆ Extract() [2/2]

virtual DWORD Extract | ( | LPCTSTR | strDest,
 |  | DWORD | dwStartPos,
 |  | DWORD | dwBytes )
 virtual

This member function extracts bytes to a file and retrieves the length of the actual copied bytes.

Parameters
strDest | Specifies a NULL-terminated string that is the path to the desired file.
dwStartPos | Represents the starting position.
dwBytes | Number of bytes to extract.
Returns
A DWORD value that represents the length of the copied bytes.

◆ FindData()

LONG FindData | ( | void * | pData,
 |  | DWORD | dwDataLen,
 |  | LONG | lStartPos )

This member function finds data in the file.

Parameters
pData | Pointer to the buffer to receive the data found.
dwDataLen | Size of the data to find.
lStartPos | Starting position.
Returns
A LONG data type.

◆ Flush()

virtual void Flush ( )
virtual

This member function forces any data remaining in the file buffer to be written to the file.

The use of Flush does not guarantee flushing of CArchive buffers. If you are using an archive, call CArchive::Flush first.

◆ Import()

virtual bool Import ( CFile * fImp )
protectedvirtual

This member function imports the data of a CFile derived object (operator=).

Parameters
fImp A pointer to a valid CFile object.
Returns
true if successful, otherwise false.

◆ Insert() [1/2]

virtual DWORD Insert | ( | CFile * | fSrc,
 |  | DWORD | dwSourcePos,
 |  | DWORD | dwDestPos,
 |  | DWORD | dwBytes )
 virtual

This member function inserts any file and retrieves the length of the actual copied bytes.

Parameters
fSrc | A pointer to a valid CFile object.
dwSourcePos | Represents the source file position.
dwDestPos | Represents the destination file position.
dwBytes | Number of bytes to insert.
Returns
A DWORD value that represents the length of the copied bytes.

◆ Insert() [2/2]

virtual DWORD Insert | ( | LPCTSTR | strSrc,
 |  | DWORD | dwSourcePos,
 |  | DWORD | dwDestPos,
 |  | DWORD | dwBytes )
 virtual

This member function inserts any file and retrieves the length of the actual copied bytes.

Parameters
strSrc | Specifies a NULL-terminated string that is the path to the desired file.
dwSourcePos | Represents the source file position.
dwDestPos | Represents the destination file position.
dwBytes | Number of bytes to insert.
Returns
A DWORD value that represents the length of the copied bytes.

◆ Load()

virtual bool Load ( )
protectedvirtual

This member function loads the file into memory.

Returns
true if successful, otherwise false.

◆ Open()

virtual BOOL Open | ( | LPCTSTR | lpszFileName,
 |  | UINT | nOpenFlags,
 |  | CFileException * | pError = NULL )
 virtual

This member function opens and loads a physical file into memory.

Parameters
lpszFileName | Specifies a NULL-terminated string that is the path to the desired file.
nOpenFlags | Specifies a UINT that defines the sharing and access mode in the file. It specifies the action to take when opening the file. You can combine options by using the bitwise-OR (|) operator. One access permission and one share option are required. The modeCreate and modeNoInherit modes are optional. See the CFile constructor for a list of mode options.
pError | Specifies a pointer to an existing file-exception object that receives the status of a failed operation.
Returns
true if successful, or false if it fails.

◆ operator+=() [1/2]

void operator+= ( CFile * fApp )

This member operator will append the CXTPMemFile object with the object specified by 'fApp'.

Parameters
fApp A pointer to a valid CFile object.

◆ operator+=() [2/2]

void operator+= ( CString strApp )

This member operator will append the CXTPMemFile object with the object specified by 'strApp'.

Parameters
strApp Specifies a NULL-terminated string that is the path to the desired file.

◆ operator=() [1/3]

void operator= ( CFile * fDup )

This member operator will initialize the CXTPMemFile object with the object specified by 'fDup'.

Parameters
fDup A pointer to a valid CFile object.

◆ operator=() [2/3]

void operator= ( CString strDup )

This member operator will initialize the CXTPMemFile object with the object specified by 'strDup'.

Parameters
strDup Specifies a NULL-terminated string that is the path to the desired file.

◆ operator=() [3/3]

void operator= ( DWORD dwFilePos )

This member operator will adjust the file position.

Parameters
dwFilePos A DWORD value that specifies the file position.

◆ operator[]()

BYTE operator[] ( DWORD dwFilePos )

This member operator will perform indexing operations for the CXTPMemFile object.

Parameters
dwFilePos A DWORD value that specifies the file position.
Returns
A BYTE data type.

◆ ReadString()

virtual BOOL ReadString ( CString & rString )
virtual

This member function reads a string.

Parameters
rString A CString reference to an object to receive the string that is read.
Returns
TRUE if successful, or FALSE if there is an error.

◆ Save()

virtual bool Save ( )
protectedvirtual

This member function saves the file to disk.

Returns
true if successful, otherwise false.

◆ WriteString()

virtual void WriteString ( LPCTSTR lpsz )
virtual

This method writes data from a buffer to the file associated with the CArchive object.

The terminating null character, \0, is not written to the file, nor is a newline character automatically written.

Parameters
lpsz Specifies a pointer to a buffer containing a NULL-terminated text string.
The documentation for this class was generated from the following file:
  • XTPMemFile.h


Toolkit Pro: CXTPMenuBar Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPMenuBar Class Reference

CXTPMenuBar is a CXTPToolBar derived class. More...

Inheritance diagram for CXTPMenuBar:
[legend]

Public Member Functions

CXTPMenuBar ()
Constructs a CXTPMenuBar object.
~CXTPMenuBar ()
Destroys a CXTPMenuBar object, handles cleanup and deallocation.
virtual BOOL | LoadMenuBar (UINT nIDResource)
Loads a menu from the resource.
void | FreeMDIMenus ()
Destroy all MDI menus.
void | RefreshMenu ()
This member function will refresh the menus.
UINT | GetCurrentMenuResource () const
Call this method to retrieve the identifier of the currently visible menu.
UINT | GetDefaultMenuResource () const
Call this method to retrieve the identifier of the default menu.
CXTPMenuBarMDIMenus * | GetMDIMenus () const
Retrieves the collection of application MDI menus.
virtual void | SwitchMDIMenu (UINT nIDMenu, CMenu *pMenu=NULL)
This method is called to switch to an MDI menu from the MDI menus collection.
CXTPMenuBarMDIMenuInfo * | AddMDIMenu (UINT nIDResource)
Call this method to manually load an MDI menu in application initialization.
void | SwitchActiveMenu ()
Call this method to switch the menu to the active document menu.
virtual void | Reset (BOOL bShowWarningMessage)
Call this method to reset the controls to their original states.
- Public Member Functions inherited from CXTPToolBar
CXTPToolBar ()
Constructs a CXTPToolBar object.
~CXTPToolBar ()
Destroys a CXTPToolBar object, handles cleanup and deallocation.
virtual void | SetVisible (BOOL bVisible)
Call this member to set the visibility of the toolbar.
virtual BOOL | IsVisible () const
Call this member to check the visibility of the toolbar.
BOOL | SetPosition (XTPBarPosition barPosition)
Call this member to set the position of the toolbar.
BOOL | LoadToolBar (UINT nIDResource, BOOL bLoadIcons=TRUE)
Call this member function to load the toolbar specified by nIDResource.
BOOL | CreateToolBar (DWORD dwStyle, CWnd *pParentWnd, UINT nID=AFX_IDW_TOOLBAR)
This method creates the ToolBar control.
void | GetBarInfo (CToolBarInfo *pInfo)
Retrieves bar information for serialization routines.
void | SetBarInfo (CToolBarInfo *pInfo)
Sets bar information.
virtual CSize | CalcDockingLayout (int nLength, DWORD dwMode, int nWidth=0)
This method calculates the dimensions of a toolbar.
virtual CSize | CalcDynamicLayout (int nLength, DWORD dwMode)
This method calculates the dimensions of a toolbar.
void | EnableDocking (DWORD dwFlags=xtpFlagAlignAny|xtpFlagFloating|xtpFlagHideWrap)
Call this method to set docking flags.
BOOL | IsBuiltIn () const
Determines if the toolbar is built-in.
CXTPDockBar * | GetDockBar () const
Retrieves the parent dock bar.
void | OnSetPreviewMode (BOOL bPreview)
Call this method to show/hide toolbars in preview mode.
BOOL | OnHookKeyDown (UINT nChar, LPARAM lParam)
The framework calls this member function when a non-system key is pressed.
void | SetContextMenuPresent (BOOL bPresent)
Call this method to show/hide the toolbar in a context menu.
BOOL | IsContextMenuPresent () const
Call this member to determine if this toolbar is included in the right-click context menu.
void | SetCustomizeDialogPresent (BOOL bPresent)
Call this method to show/hide the toolbar in a customize dialog.
BOOL | IsCustomizeDialogPresent () const
Call this member to determine if this toolbar is included in the customize dialog.
void | ModifyBarStyle (DWORD dwRemove, DWORD dwAdd)
Modifies the styles of the toolbar.
void | SetCloseable (BOOL bCloseable)
Call this method to enable/disable the closeable property of the command bar.
BOOL | IsCloseable () const
Call this method to retrieve the closeable property of the command bar.
BOOL | IsTemporary () const
Call this method to determine if the control is temporary.
void | SetTemporary (BOOL bTemporary)
Call this method to set the control to temporary.
void | ShowExpandButton (BOOL bShowExpandButton)
Call this method to show/hide the expand button of the toolbar.
void | OnRecalcLayout ()
This method recalculates the position of the toolbar.
BOOL | IsWindowVisible () const
Determines if the toolbar is visible on the screen.
- Public Member Functions inherited from CXTPCommandBar
int | IsTrackingMode () const
Call this member to get the tracking state.
CXTPControls * | GetControls () const
Call this member to get the controls collection.
void | SetControls (CXTPControls *pControls)
Call this member to set the controls collection of the command bar.
XTPBarType | GetType () const
Call this member to get the type of the command bar.
void | SetTextOrientation (XTPBarTextOrientation nTextOrientation)
Call this member to change text orientation.
XTPBarTextOrientation | GetTextOrientation () const
Call this member to get the text orientation.
XTPBarPosition | GetPosition () const
Call this member to get the position of the command bar.
void | DelayLayout ()
Call this member to recalculate the layout.
virtual void | DelayRedraw ()
Call this member to redraw the command bar.
virtual BOOL | SetTrackingMode (int bMode, BOOL bSelectFirst=TRUE, BOOL bKeyboard=FALSE)
Call this member to change the tracking state.
virtual BOOL | LoadMenu (CMenu *pMenu, BOOL bRemoveControls=TRUE)
Call this member to convert menu items to command bar controls.
CXTPControl * | GetControl (int nIndex) const
Call this member to return the control at the specified index.
int | GetControlCount () const
Call this member to get the count of the controls.
virtual BOOL | SetSelected (int nSelected, BOOL bKeyboard=FALSE)
Call this member to select the specified control.
CXTPControl * | GetSelected () const
Call this member to get the currently selected control.
BOOL | SetPopuped (int nPopuped, BOOL bKeyboard=FALSE)
Call this member to pop-up the specified control.
void | SetTitle (LPCTSTR lpszTitle)
Call this member to set a title for this command bar.
CString | GetTitle () const
Call this member to get a title for this command bar.
CXTPCommandBars * | GetCommandBars () const
Call this member to get the command bar's object.
void | SetCommandBars (CXTPCommandBars *pCommandBars)
Call this member to set the command bar's object.
CWnd * | GetSite () const
Call this member to get the command bar's site.
CFrameWnd * | GetFrameSite () const
Call this member to get the command bar's site as CFrameWnd.
void | SetFlags (DWORD dwFlagsAdd, DWORD dwFlagsRemove=0)
Call this member to set the command bar's flags.
BOOL | SetButtons (UINT *pButtons, int nCount)
Call this member to set the controls from the button array.
void | SetIconSize (CSize size)
Call this function to set the size of the actual bitmapped images to be added to a toolbar.
virtual CSize | GetIconSize () const
Call this member function to get the size of the toolbar icon.
CSize | GetLargeIconSize (BOOL bAutoSize) const
Call this method to get the large icon size of the toolbar.
void | SetButtonSize (CSize size)
Sets the size of the buttons in the command bar.
virtual CSize | GetButtonSize () const
Call this function to get the size of the command bar button.
void | ShowTextBelowIcons (BOOL bTextBelow=TRUE)
Call this member to show the caption below control's icon.
BOOL | IsTextBelowIcons () const
Checks whether the caption is below the control's icon.
virtual BOOL | Popup (CXTPControlPopup *pControlPopup, BOOL bSelectFirst=FALSE)
This method is called to pop-up the command bar.
HWND | GetTrackFocus () const
Call this method to retrieve the current focused control.
void | SetTrackFocus (HWND hwnd)
Call this method to set focus to the window.
int | FindAccel (TCHAR chAccel) const
Call this method to get the index of the control with the specified accelerator character.
int | FindAccelEx (UINT chAccel, BOOL &bSelectOnly) const
Call this method to get the index of the control with the specified accelerator character.
BOOL | IsCustomizeMode () const
Call this method to check if the command bars are in customize mode.
virtual DROPEFFECT | OnCustomizeDragEnter (CXTPControl *pDataObject, CPoint point)
This member is called when a control is entered into the command bar.
virtual void | OnCustomizeDragLeave ()
This method is called when a control leaves the command bar.
virtual DROPEFFECT | OnCustomizeDragOver (CXTPControl *pDataObject, CPoint point)
This member is called when control is over the command bar.
virtual void | OnCustomizeDrop (CXTPControl *pDataObject, DROPEFFECT &dropEffect, CPoint ptDrop, CPoint ptDrag)
This method is called when a control is dropped to the command bar.
virtual BOOL | IsCustomizable () const
Call this method to check if the command bar is customizable.
BOOL | IsCustomizeDialogPresent () const
Call this method to check if the command bar is present in Customize dialog.
void | EnableCustomization (BOOL bEnable=TRUE)
Call this method to enable/disable customization of the command bar.
virtual void | OnTrackLost ()
Call this method to remove the tracking state of the command bar.
virtual void | OnTrackEnter ()
Call this method to track the command bar.
CWnd * | GetOwnerSite () const
Call this method to retrieve the owner window of the command bar.
void | InvalidateParents ()
Call this method to redraw all parent command bars.
DWORD | GetFlags () const
Call this method to retrieve the current behavior modification flags of the command bar.
UINT | GetBarID () const
Call this method to retrieve the identifier of the command bar.
void | SetBarID (UINT nID)
Call this method to set the identifier of the command bar.
virtual void | OnControlSelected (BOOL bSelected, CXTPControl *pControl)
This method is called when a child control becomes selected.
BOOL | SetStatusText (const CString &strDescription)
This method is called to set the description context.
void | SetCommandBarData (DWORD_PTR dwData)
This method sets the 32-bit value associated with the command bar.
DWORD_PTR | GetCommandBarData () const
This method retrieves the application-supplied, 32-bit value associated with the command bar.
virtual CXTPCommandBar * | GetParentCommandBar () const
This method retrieves the parent command bar.
CXTPCommandBar * | GetRootParent () const
Call this method to retrieve the top-level parent command bar.
CXTPPaintManager * | GetPaintManager () const
Call this method to retrieve the paint manager.
CXTPImageManager * | GetImageManager () const
Call this method to retrieve the image manager.
void | SetWidth (int nWidth)
Call this member to set the width of the floated or pop-up toolbar.
int | GetWidth () const
Call this member to get the width of the floated or pop-up toolbar.
void | SetPaintManager (CXTPPaintManager *pPaintManager)
Call this member to set the specified paint manager.
void | SetImageManager (CXTPImageManager *pImageManager)
Call this member to set the specified image manager.
BOOL | IsLayoutRTL () const
Call this member function to determine if the command bar layout is Right-to-Left (RTL).
virtual BOOL | IsDialogBar () const
Call this member function to determine if the command bar is a CXTPDialogBar.
virtual BOOL | IsRibbonBar () const
Call this member function to determine if the command bar is a CXTPRibbonBar.
virtual BOOL | IsMenuTitleBar () const
Call this member function to determine if the command bar is a CXTPMenuTitleBar.
virtual BOOL | IsPopupBar () const
Call this member function to determine if the command bar is a CXTPPopupBar.
virtual BOOL | IsKeyboardCuesVisible () const
Determines if underlines are visible in the command bar control.
void | SetGrabFocus (BOOL bGrabFocus)
This method is called internally to prevent the command bar from grabbing edit focus.
virtual void | Redraw (LPCRECT lpRect=0, BOOL bAnimate=TRUE)
The framework calls this member function to redraw the command bar.
virtual void | DrawCommandBar (CDC *pDC, CRect rcClipBox)
This method is called to draw the command bar in the given context.
void | EnableAnimation (BOOL bEnable=TRUE)
Call this method to enable animation for the command bar.
void | EnableDoubleBuffer (BOOL bEnable=TRUE)
Call this method to enable double buffer for toolbar drawing.
BOOL | IsAnimationEnabled () const
Determines if animation is enabled for the specified command bar.
virtual void | EnsureVisible (CXTPControl *pControl)
Call this method to ensure that a specified control is visible on the toolbar.
XTPButtonStyle | GetDefaultButtonStyle () const
Call this method to retrieve the default button style of the command bar.
void | SetDefaultButtonStyle (XTPButtonStyle buttonStyle)
Call this method to set the default button style of the command bar.
void | LockRedraw ()
Call this method to freeze redrawing until UnlockRedraw is called.
void | UnlockRedraw ()
Call this method to unfreeze redrawing.
void | SetShowGripper (BOOL bShow)
Call this method to set the visibility of the command bar's gripper.
BOOL | GetShowGripper () const
Call this method to check if the command bar's gripper is visible.
virtual void | FillCommandBarEntry (CDC *pDC)
This method is called to draw the background of the command bar.
virtual BOOL | IsResizable () const
Specifies whether the pop-up gallery can be resized by the user.
BOOL | IsKeyboardTipsVisible () const
Call this method to check if keyboard tips are visible for the command bar.
virtual void | CreateKeyboardTips ()
This method is called to create a keyboard tips collection for the command bar.
void | OnKeyboardTipChar (UINT chAccel)
This method is called when the user presses a key while keyboard tips are visible.
virtual void | OnKeyboardTip (CXTPCommandBarKeyboardTip *pTip)
This method is called when a keyboard tip is found for the command bar.
void | HideKeyboardTips ()
Call this method to hide keyboard tips.
void | LockMouseMove (CXTPControl *pControl)
Locks the mouse cursor for a specified control.
void | UnlockMouseMove ()
Unlocks the mouse cursor.
- Public Member Functions inherited from CXTPHookManagerHookAble
CXTPHookManagerHookAble ()
Constructs a CXTPHookManagerHookAble object.
virtual | ~CXTPHookManagerHookAble ()
Destroys a CXTPHookManagerHookAble object, handles cleanup and deallocation.
virtual int | OnPostHookMessage (HWND hWnd, UINT nMessage, WPARAM &wParam, LPARAM &lParam, LRESULT &lResult)
This member function is called after a message has been processed by default window procedure.
virtual void | OnHookAttached (HWND hWnd)
This member function is called right after a hook is attached to the window.
virtual void | OnHookDetached ()
This member function is called right before a hook is to be detached from the window.

Protected Member Functions

int | OnHookMessage (HWND hWnd, UINT nMessage, WPARAM &wParam, LPARAM &lParam, LRESULT &lResult)
This member function is called by WindowProc, or is called during message reflection.
void | DoPropExchange (CXTPPropExchange *pPX)
Either reads this object from or writes this object to an archive.
virtual void | Copy (CXTPCommandBar *pCommandBar, BOOL bRecursive=FALSE)
This method makes a copy of the command bar.
void | SetupHook ()
This method is called to create hooks for the main window.
void | SetupMenu ()
This method is called to create the menu for the main window.
HWND | GetActiveMdiChildWnd (BOOL *bMaximized=NULL)
Call this method to get the handle to the active MDI child window.
void | SyncActiveMdiChild ()
Call this method to update the active MDI window hooks.
virtual void | RefreshSysButtons ()
Call this method to update the system buttons of the menu bar.
void | SwitchMDIMenu (HMENU hMenu)
Call this method to switch the current MDI menu.
void | GenerateCommandBarList (DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam)
Call this method to assign self-identifiers for the serialization process.
void | RestoreCommandBarList (CXTPCommandBarList *pCommandBarList)
Call this method during the serialization process to restore pop-ups from a list of command bars.
BOOL | ShouldSerializeBar ()
Call this method to check if the toolbar has changed and must be saved.
- Protected Member Functions inherited from CXTPToolBar
virtual BOOL | Create (CWnd *pParentWnd, BOOL bFloat)
Creates a toolbar.
virtual CRect | GetBorders ()
This method retrieves the borders of the toolbar.
virtual void | OnPaintManagerChanged ()
This method is called when the paint manager is changed.
virtual void | MergeToolBar (CXTPCommandBar *pCommandBar, BOOL bSilent)
This method is called to restore a toolbar to a previous state.
virtual void | MergeToolBar (CXTPCommandBar *pCommandBar, BOOL bSilent, int nDefaultConfirmationChoice)
This method is called to restore a toolbar to a previous state.
- Protected Member Functions inherited from CXTPCommandBar
CXTPCommandBar ()
Constructs a CXTPCommandBar object.
virtual | ~CXTPCommandBar ()
Destroys a CXTPCommandBar object, handles cleanup and deallocation.
virtual BOOL | ProcessSpecialKey (XTPSpecialKey key)
This method is called to process special keys.
virtual void | OnControlsChanged ()
This method is called when the controls array is changed.
virtual int | OnMouseHitTest (CPoint pt)
This method is called to determine mouse hit code.
virtual void | UpdateShortcuts ()
Updates the control's shortcuts.
UINT | GetActiveDocTemplate () const
Retrieves the active MDI document template.
BOOL | IsHelpMode () const
Determines if the parent frame is in help mode.
virtual void | OnRemoved ()
This method is called when a toolbar is removed from the command bars collection.

Protected Attributes

BOOL | m_bMdiApp
TRUE if parent frame is CMDIFrameWnd derived.
HWND | m_hWndActiveChild
Active MDI window handle.
HMENU | m_hMenuDefault
Default menu handle.
UINT | m_nIDResource
Resource of default menu.
UINT | m_nIDResourceCurrent
Currently active menu.
CXTPMenuBarMDIMenus * | m_pMDIMenus
MDI menus.
- Protected Attributes inherited from CXTPToolBar
CXTPDockBar * | m_pDockBar
Parent dock bar.
CXTPDockContext * | m_pDockContext
Docking context.
BOOL | m_bBuiltIn
TRUE if toolbar is built-in.
BOOL | m_bTearOff
TRUE if toolbar is tear-offed.
BOOL | m_bPreviewVisible
TRUE if Toolbar was visible in preview mode.
BOOL | m_bPreviewMode
TRUE if Toolbar was visible in preview mode.
BOOL | m_bTemporary
TRUE if Toolbar is temporary (If it will be saved when the CommandBar layout is saved.)
BOOL | m_bShowExpandButton
TRUE to show expand button of toolbar.
BOOL | m_bContextMenuPresent
TRUE if the command bar is present in context menu.
BOOL | m_bInRecalcLayout
TRUE if RecalcLayout method is called.
BOOL | m_bVisible
TRUE if the command bar is visible.
- Protected Attributes inherited from CXTPCommandBar
BOOL | m_bGrabFocus
TRUE to grab current focus.
int | m_nMRUWidth
Recent width.
int | m_nSelected
Selected control index.
int | m_nPopuped
Pop-up'ed control index.
HWND | m_hwndFocus
The handle of the window that currently has focus.
UINT | m_nBarID
Command bar's identifier.
BOOL | m_bTracking
TRUE if the command bar is in tracking mode.
CWnd * | m_pSite
Command bar's site.
DWORD | m_nIdleFlags
Idle flags.
DWORD | m_dwFlags
Command bar's flags.
DWORD | m_dwStyle
Command bar's styles.
CString | m_strTitle
Command bar's caption.
XTPBarType | m_barType
Type of the command bar.
CXTPControls * | m_pControls
A pointer to controls collection.
XTPBarPosition | m_barPosition
Position of the command bar.
CXTPCommandBars * | m_pCommandBars
parent command bars class.
CWnd * | m_pOwner
Owner window.
CSize | m_szIcons
Size of the command bar's icons.
CSize | m_szButtons
Size of the command bar's buttons.
BOOL | m_bTextBelow
TRUE if text is shown below the CommandBar buttons.
BOOL | m_bExecOnRButton
TRUE if the control button is executed on a right-click.
BOOL | m_bIgnoreUpdateHandler
TRUE to skip update handler for all child controls.
BOOL | m_bRecursePopup
TRUE if pop-up bar was opened recursively.
BOOL | m_bKeyboardSelect
TRUE if last item was selected by keyboard.
BOOL | m_bCloseable
TRUE if the CommandBar can be closed and-or Hidden.
BOOL | m_bCustomizable
TRUE if command bar is customizable.
CRect | m_rcMarker
Marker position.
BOOL | m_bVerticalMarker
TRUE to draw marker vertically.
DWORD_PTR | m_dwData
The 32-bit value associated with the command bar.
UINT * | m_pReturnCmd
Return command holder.
BOOL | m_bCustomizeDialogPresent
TRUE if the command bar is present in Customize dialog.
BOOL | m_bAnimatePopup
TRUE to animate pop-up bar.
BOOL | m_nLockRedraw
TRUE if all drawing routines skipped.
CXTPPaintManager * | m_pPaintManager
Selected paint manager for command bar.
CXTPImageManager * | m_pImageManager
Selected image manager for command bar.
BOOL | m_bMultiLine
True if multi line commandbar.
XTPButtonStyle | m_buttonStyle
Default button Style.
XTPBarTextOrientation | m_nTextOrientation
Commandbar text orientation.
CXTPToolTipContext * | m_pToolTipContext
Tool tip Context.
CXTPCommandBarAnimation * | m_pAnimation
Animation context.
CSize | m_szButtonSpacing
Spacing used between toolbar buttons.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPToolBar
static BOOL AFX_CDECL | DoUpdateCustomizeMenuControl (CXTPControl *pControl, CCmdTarget *pTarget)
Tries to update a Customize menu control.
- Public Attributes inherited from CXTPCommandBar
int | m_nStateFlags
State of the command bars.
BOOL | m_bComboBar
TRUE if it is combobox list.
BOOL | m_bTrackOnHover
TRUE to select item if mouse stay over control.
- Public Attributes inherited from CXTPHookManagerHookAble
BOOL | m_bAutoDestroy
TRUE to automatically delete hook.
- Static Public Attributes inherited from CXTPCommandBar
static int | s_nHoverDelay
Hover delay time.
static int | s_nExpandDelay
Expand delay time.
static int | s_nExpandHoverDelay
Expand hover delay.

Detailed Description

CXTPMenuBar is a CXTPToolBar derived class.

It represents a menu bar of a frame window.

Member Function Documentation

◆ AddMDIMenu()

CXTPMenuBarMDIMenuInfo * AddMDIMenu ( UINT nIDResource )

Call this method to manually load an MDI menu in application initialization.

Parameters
nIDResource Template identifier
Returns
A pointer to a newly created menu information object or a pointer to the existing menu information object if it has been previously added.

◆ Copy()

virtual void Copy | ( | CXTPCommandBar * | pCommandBar,
 |  | BOOL | bRecursive = FALSE )
 protectedvirtual

This method makes a copy of the command bar.

Parameters
pCommandBar | Command bar to be copied.
bRecursive | TRUE to copy recursively.

Reimplemented from CXTPToolBar.

◆ DoPropExchange()

void DoPropExchange ( CXTPPropExchange * pPX )
protectedvirtual

Either reads this object from or writes this object to an archive.

Parameters
pPX A CXTPPropExchange object to serialize to or from.

Reimplemented from CXTPToolBar.

◆ GenerateCommandBarList()

void GenerateCommandBarList | ( | DWORD & | nID,
 |  | CXTPCommandBarList * | pCommandBarList,
 |  | XTP_COMMANDBARS_PROPEXCHANGE_PARAM * | pParam )
 protectedvirtual

Call this method to assign self-identifiers for the serialization process.

Parameters
nID | Identifier to assign.
pCommandBarList | List of CommandBars.
pParam | Address of an XTP_COMMANDBARS_PROPEXCHANGE_PARAM structure.

Reimplemented from CXTPCommandBar.

◆ GetActiveMdiChildWnd()

HWND GetActiveMdiChildWnd ( BOOL * bMaximized = NULL )
protected

Call this method to get the handle to the active MDI child window.

Parameters
bMaximized If this parameter is not NULL, it is a pointer to a value that indicates the maximized state of the MDI child window.
Returns
The handle to the active MDI child window.

◆ GetCurrentMenuResource()

AFX_INLINE UINT GetCurrentMenuResource ( ) const

Call this method to retrieve the identifier of the currently visible menu.

Returns
The identifier of the currently visible menu.

◆ GetDefaultMenuResource()

AFX_INLINE UINT GetDefaultMenuResource ( ) const

Call this method to retrieve the identifier of the default menu.

Returns
The identifier of the default menu.

◆ GetMDIMenus()

AFX_INLINE CXTPMenuBarMDIMenus * GetMDIMenus ( ) const

Retrieves the collection of application MDI menus.

Returns
A pointer to the collection of application MDI menus.

◆ LoadMenuBar()

virtual BOOL LoadMenuBar ( UINT nIDResource )
virtual

Loads a menu from the resource.

Parameters
nIDResource Menu identifier to load.
Returns
TRUE if successful, otherwise FALSE.

◆ OnHookMessage()

int OnHookMessage | ( | HWND | hWnd,
 |  | UINT | nMessage,
 |  | WPARAM & | wParam,
 |  | LPARAM & | lParam,
 |  | LRESULT & | lResult )
 protectedvirtual

This member function is called by WindowProc, or is called during message reflection.

Parameters
hWnd | Window handle message belongs to.
nMessage | Specifies the message to be sent.
wParam | Specifies additional message-dependent information.
lParam | Specifies additional message-dependent information.
lResult | The return value of WindowProc. Depends on the message; may be NULL.
Returns
A non-zero value if a hooked message is processed, 0 otherwise.

Reimplemented from CXTPCommandBar.

◆ Reset()

virtual void Reset ( BOOL bShowWarningMessage )
virtual

Call this method to reset the controls to their original states.

Parameters
bShowWarningMessage TRUE to show warning message.

Reimplemented from CXTPToolBar.

Reimplemented in CXTPRibbonBar.

◆ RestoreCommandBarList()

void RestoreCommandBarList ( CXTPCommandBarList * pCommandBarList )
protectedvirtual

Call this method during the serialization process to restore pop-ups from a list of command bars.

Parameters
pCommandBarList List of command bars.

Reimplemented from CXTPCommandBar.

◆ ShouldSerializeBar()

BOOL ShouldSerializeBar ( )
protectedvirtual

Call this method to check if the toolbar has changed and must be saved.

Returns
TRUE if the toolbar has changed and must be saved, otherwise FALSE.

Reimplemented from CXTPToolBar.

◆ SwitchActiveMenu()

void SwitchActiveMenu ( )

Call this method to switch the menu to the active document menu.

See also
GetActiveDocTemplate, SwitchMDIMenu

◆ SwitchMDIMenu() [1/2]

void SwitchMDIMenu ( HMENU hMenu )
protected

Call this method to switch the current MDI menu.

Parameters
hMenu Active menu to select.

◆ SwitchMDIMenu() [2/2]

virtual void SwitchMDIMenu | ( | UINT | nIDMenu,
 |  | CMenu * | pMenu = NULL )
 virtual

This method is called to switch to an MDI menu from the MDI menus collection.

Parameters
nIDMenu | Menu identifier to switch.
pMenu | Menu to switch.
See also
SwitchActiveMenu
The documentation for this class was generated from the following file:
  • XTPMenuBar.h


Toolkit Pro: CXTPMenuBarMDIMenuInfo Class Reference

Public Member Functions | Public Attributes | List of all members
CXTPMenuBarMDIMenuInfo Class Reference

CXTPMenuBarMDIMenuInfo structure used to describe the parameters of application MDI menus. More...

Inheritance diagram for CXTPMenuBarMDIMenuInfo:
[legend]

Public Member Functions

CXTPMenuBarMDIMenuInfo (CXTPCommandBars *pCommandBars, UINT nIDResource)
Constructs a CXTPMenuBarMDIMenuInfo object.
~CXTPMenuBarMDIMenuInfo ()
Destroys a CXTPMenuBarMDIMenuInfo object, handles cleanup and deallocation.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Public Attributes

CXTPControls * | m_pControls
Menu controls.
CString | m_strTitle
Title of MDI menu.
CString | m_strDescription
Description of MDI menu.
HICON | m_hIcon
Menu Icon.
UINT | m_nIDResource
Template identifier.
BOOL | m_bChanged
TRUE if menu was changed.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

CXTPMenuBarMDIMenuInfo structure used to describe the parameters of application MDI menus.

Constructor & Destructor Documentation

◆ CXTPMenuBarMDIMenuInfo()

CXTPMenuBarMDIMenuInfo | ( | CXTPCommandBars * | pCommandBars,
 |  | UINT | nIDResource )

Constructs a CXTPMenuBarMDIMenuInfo object.

Parameters
pCommandBars | Parent commandbars.
nIDResource | Template identifier.
The documentation for this class was generated from the following file:
  • XTPMenuBar.h


Toolkit Pro: CXTPMenuBarMDIMenus Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPMenuBarMDIMenus Class Reference

CXTPMenuBarMDIMenus represents a collection of MDI menus for CXTPMenuBar. More...

Inheritance diagram for CXTPMenuBarMDIMenus:
[legend]

Public Member Functions

CXTPMenuBarMDIMenus (CXTPMenuBar *pMenuBar)
Constructs a CXTPMenuBarMDIMenus object.
~CXTPMenuBarMDIMenus ()
Destroys a CXTPMenuBarMDIMenus object, handles cleanup and deallocation.
int GetCount () const
Gets the number of MDI menus in the collection.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Attributes

CMap< UINT, UINT, CXTPMenuBarMDIMenuInfo *, CXTPMenuBarMDIMenuInfo * > | m_mapMenus
Menu map.
CXTPMenuBar * | m_pMenuBar
Parent Menu Bar.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

CXTPMenuBarMDIMenus represents a collection of MDI menus for CXTPMenuBar.

Constructor & Destructor Documentation

◆ CXTPMenuBarMDIMenus()

CXTPMenuBarMDIMenus ( CXTPMenuBar * pMenuBar )

Constructs a CXTPMenuBarMDIMenus object.

Parameters
pMenuBar Parent CXTPMenuBar.

Member Function Documentation

◆ GetCount()

int GetCount ( ) const

Gets the number of MDI menus in the collection.

Returns
The number of MDI menus in the collection.
The documentation for this class was generated from the following file:
  • XTPMenuBar.h


Toolkit Pro: CXTPMessageBar Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPMessageBar Class Reference

CXTPMessageBar is a CControlBar derived class. More...

Public Member Functions

CXTPMessageBar ()
Constructs a CXTPMessageBar object.
virtual | ~CXTPMessageBar ()
Destroys a CXTPMessageBar object, handles cleanup and deallocation.
BOOL | Create (CXTPCommandBars *pCommandBars, DWORD dwStyle=WS_CHILD|WS_VISIBLE|CBRS_TOP, UINT nID=XTP_IDW_MESSAGE_BAR)
Creates a message bar.
void | SetMessage (LPCTSTR lpszMessage)
Sets the message displayed in the message bar.
void | EnableMarkup (BOOL bEnableMarkup=TRUE)
Call this method to enable markup for the text inside the message bar.
void | AddButton (UINT nID, LPCTSTR lpszCaption, LPCTSTR lpszToolTop=NULL)
Adds a button to the message bar.
void | RemoveButtons ()
Removes all buttons from the message bar.
virtual void | Click (CXTPMessageBarButton *pButton)
Generates a click event for the button, simulating a click by a user.
CRect | GetMessageRect ()
Call this member to get the bounding rectangle of the message box.
CXTPPaintManager * | GetPaintManager () const
This member function obtains the paint manager.
CXTPMessageBarPaintManager * | GetMessageBarPaintManager () const
This member function obtains the paint manager used for drawing a message bar.
CXTPMessageBarButton * | HitTestButton (CPoint point) const
Tests a point to determine which message bar button, if any, is at the specified point.
CXTPMessageBarButton * | FindButton (UINT nID) const
Call this member to find the specified button.
CXTPMarkupContext * | GetMarkupContext () const
Retrieves a pointer to the markup context.
int | GetHeight () const
This member function obtains the height of the message bar.
void | SetHeight (int nHeight)
This member function sets the custom height of the message bar.
void | SetAutoSize (BOOL bAutoSize)
This member function enables auto-sizing of the message bar.

Protected Member Functions

virtual void | FillMessageBar (CDC *pDC)
Draws the message bar.
virtual CSize | MeasureContent (CDC *pDC)
Gets the size of the content in the message bar.
virtual CSize | MeasureButton (CDC *pDC, CXTPMessageBarButton *pButton)
Gets the size of a button.
virtual void | DrawContent (CDC *pDC)
Draws the content of the message bar.
virtual void | RecalcLayout (CDC *pDC)
Call this member function to recalculate the layout of the message bar.
virtual void | DrawButton (CDC *pDC, CXTPMessageBarButton *pButton)
Call this member to draw a button in the message bar.
void | DrawButtons (CDC *pDC)
Call this member to draw the buttons in the message bar.

Protected Attributes

int | m_nCustomHeight
Custom height value.
BOOL | m_bAutoSize
If TRUE the height of the bar will be adjusted to the content.
CString | m_strContent
Content string of the message bar.
CXTPMarkupUIElement * | m_pUIElement
Store pointer to CXTPMarkupUIElement object.
CXTPMarkupContext * | m_pMarkupContext
Store pointer to CXTPMarkupContext object.
CXTPCommandBars * | m_pCommandBars
Store pointer to CXTPCommandBars object.
CXTPMessageBarButton * | m_pHotButton
Current hot button.
CArray< CXTPMessageBarButton *, CXTPMessageBarButton * > | m_arrButtons
Collection of buttons in the message bar.
CRect | m_rcContent
Bounding rectangle of the content in the message bar.

Detailed Description

CXTPMessageBar is a CControlBar derived class.

It can be used to show some information in the top of a frame.

Member Function Documentation

◆ AddButton()

void AddButton | ( | UINT | nID,
 |  | LPCTSTR | lpszCaption,
 |  | LPCTSTR | lpszToolTop = NULL )

Adds a button to the message bar.

Parameters
nID | ID of the button.
lpszCaption | Text displayed inside the button.
lpszToolTop | Text displayed as a tooltip when the mouse is placed over the button.

◆ Click()

virtual void Click ( CXTPMessageBarButton * pButton )
virtual

Generates a click event for the button, simulating a click by a user.

Parameters
pButton Reference to the button to click.

◆ Create()

BOOL Create | ( | CXTPCommandBars * | pCommandBars,
 |  | DWORD | dwStyle = WS_CHILD|WS_VISIBLE|CBRS_TOP,
 |  | UINT | nID = XTP_IDW_MESSAGE_BAR )

Creates a message bar.

Parameters
pCommandBars | Parent CommandBar control to attach the message bar.
dwStyle | Style of the message bar.
nID | Id of the message bar.
Returns
TRUE if successful, FALSE otherwise.

◆ DrawButton()

virtual void DrawButton | ( | CDC * | pDC,
 |  | CXTPMessageBarButton * | pButton )
 protectedvirtual

Call this member to draw a button in the message bar.

Parameters
pDC | Pointer to a valid device context.
pButton | Button to draw.

◆ DrawButtons()

void DrawButtons ( CDC * pDC )
protected

Call this member to draw the buttons in the message bar.

Parameters
pDC Pointer to a valid device context.

◆ DrawContent()

virtual void DrawContent ( CDC * pDC )
protectedvirtual

Draws the content of the message bar.

Parameters
pDC Pointer to a valid device context.

◆ EnableMarkup()

void EnableMarkup ( BOOL bEnableMarkup = TRUE )

Call this method to enable markup for the text inside the message bar.

Parameters
bEnableMarkup TRUE to enable markup, FALSE to disable markup.

◆ FillMessageBar()

virtual void FillMessageBar ( CDC * pDC )
protectedvirtual

Draws the message bar.

Parameters
pDC Pointer to a valid device context.

◆ FindButton()

CXTPMessageBarButton * FindButton ( UINT nID ) const

Call this member to find the specified button.

Parameters
nID Button's ID.
Returns
The CXTPMessageBarButton object if successful; otherwise NULL.

◆ GetHeight()

int GetHeight ( ) const

This member function obtains the height of the message bar.

If a custom value has been previously set by SetHeight, that value is returned. Otherwise it will return the paint manager specific value.

Returns
Returns height of message bar

◆ GetMarkupContext()

AFX_INLINE CXTPMarkupContext * GetMarkupContext ( ) const

Retrieves a pointer to the markup context.

Returns
A pointer to a CXTPMarkupContext object.

◆ GetMessageBarPaintManager()

CXTPMessageBarPaintManager * GetMessageBarPaintManager ( ) const

This member function obtains the paint manager used for drawing a message bar.

Returns
A pointer to the paint manager used for drawing a message bar.

◆ GetMessageRect()

CRect GetMessageRect ( )

Call this member to get the bounding rectangle of the message box.

Returns
The bounding rectangle of the message box.

◆ GetPaintManager()

CXTPPaintManager * GetPaintManager ( ) const

This member function obtains the paint manager.

Returns
A pointer to the paint manager.

◆ HitTestButton()

CXTPMessageBarButton * HitTestButton ( CPoint point ) const

Tests a point to determine which message bar button, if any, is at the specified point.

Parameters
point POINT structure that contains the point to be hit test, in client coordinates.
Returns
If the hit test is successful, contains a reference to the CXTPMessageBarButton at the hit test point, if any, or - 1 otherwise.

◆ MeasureButton()

virtual CSize MeasureButton | ( | CDC * | pDC,
 |  | CXTPMessageBarButton * | pButton )
 protectedvirtual

Gets the size of a button.

Parameters
pDC | Pointer to a valid device context.
pButton | Button to measure.
Returns
Returns the size of a button.

◆ MeasureContent()

virtual CSize MeasureContent ( CDC * pDC )
protectedvirtual

Gets the size of the content in the message bar.

Parameters
pDC Pointer to a valid device context.
Returns
Returns the size of the content.

◆ RecalcLayout()

virtual void RecalcLayout ( CDC * pDC )
protectedvirtual

Call this member function to recalculate the layout of the message bar.

Parameters
pDC Pointer to a valid device context.

◆ SetAutoSize()

void SetAutoSize ( BOOL bAutoSize )

This member function enables auto-sizing of the message bar.

If auto-sizing is enabled, then the height of the message bar will be adjusted to the content.

Parameters
bAutoSize TRUE to enable automatic sizing, FALSE otherwise.

◆ SetHeight()

void SetHeight ( int nHeight )

This member function sets the custom height of the message bar.

If auto-sizing is enabled, then this value will be used as the minimum height of the message bar.

Parameters
nHeight A new height value in pixels.

◆ SetMessage()

void SetMessage ( LPCTSTR lpszMessage )

Sets the message displayed in the message bar.

Parameters
lpszMessage String of text or XML Markup to display in the message bar.

The message displayed can contain simple text or it can contain a XML string as in the sample below. Use XML strings to add items such as images and formatted text.

Member Data Documentation

◆ m_nCustomHeight

int m_nCustomHeight
protected

Custom height value.

If 0, height value provided be paint manager is used.

The documentation for this class was generated from the following file:
  • XTPMessageBar.h


Toolkit Pro: CXTPMessageBarButton Class Reference

Public Member Functions | Public Attributes | List of all members
CXTPMessageBarButton Class Reference

CXTPMessageBarButton is a standalone class. More...

Public Member Functions

CXTPMessageBarButton ()
Constructs a CXTPMessageBarButton object.
~CXTPMessageBarButton ()
Destroys a CXTPMessageBarButton object, handles cleanup and deallocation.
void PerformClick (CXTPMessageBar *pBar, CPoint pt)
Generates a click event for the button, simulating a click by a user.

Public Attributes

CRect | m_rcButton
Bounding rectangle for the button.
CString | m_strCaption
Text displayed in the button.
CString | m_strToolTip
Tooltip text displayed for the button.
BOOL | m_bPressed
TRUE if the button is currently pressed.
BOOL | m_bHot
TRUE if the button is in a "hot" state, meaning the mouse cursor is hovered over the button.
UINT | m_nID
Id of the button.
CXTPMarkupUIElement * | m_pUIElement
Store pointer to CXTPMarkupUIElement object.

Detailed Description

CXTPMessageBarButton is a standalone class.

It represents a single button of a message bar.

Member Function Documentation

◆ PerformClick()

void PerformClick | ( | CXTPMessageBar * | pBar,
 |  | CPoint | pt )

Generates a click event for the button, simulating a click by a user.

Parameters
pBar | Reference to the message bar the button belongs to.
pt | Point in which to simulate a click.
The documentation for this class was generated from the following file:
  • XTPMessageBar.h


Toolkit Pro: CXTPMessageBarPaintManager Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPMessageBarPaintManager Class Reference

The CXTPMessageBarPaintManager class is used by the message bar to perform standard paint routines. More...

Inheritance diagram for CXTPMessageBarPaintManager:
[legend]

Public Member Functions

CXTPMessageBarPaintManager (CXTPPaintManager *pPaintManager)
Message bar constructor.
virtual | ~CXTPMessageBarPaintManager ()
Handles object destruction.
virtual void | RefreshMetrics ()
Call to update class colors and settings.
virtual void | FillMessageBar (CDC *pDC, CXTPMessageBar *pBar)
Draws the message bar.
virtual void | DrawMessageBarButton (CDC *pDC, CXTPMessageBarButton *pButton)
Call this member to draw a button in the message bar.
virtual CRect | GetCloseButtonRect (int x, int y, int cy)
Call this member to retrieve the close button coordinates.
virtual CSize | GetDefaultButtonSize () const
virtual int | GetHeight () const
virtual CRect | GetPadding () const

Protected Attributes

CXTPPaintManagerColor | m_clrBack
Message bar background color.
CXTPPaintManagerColor | m_clrText
Message bar text color.
CXTPPaintManagerColor | m_clrBorder
Message bar border color.
CXTPPaintManagerColor | m_clrInfoBack
Message bar info background color.
CXTPPaintManager * | m_pPaintManager
Pointer to the owner paint manager.

Detailed Description

The CXTPMessageBarPaintManager class is used by the message bar to perform standard paint routines.

Constructor & Destructor Documentation

◆ CXTPMessageBarPaintManager()

CXTPMessageBarPaintManager ( CXTPPaintManager * pPaintManager )

Message bar constructor.

Parameters
pPaintManager Pointer to the owner paint manager.

Member Function Documentation

◆ DrawMessageBarButton()

virtual void DrawMessageBarButton | ( | CDC * | pDC,
 |  | CXTPMessageBarButton * | pButton )
 virtual

Call this member to draw a button in the message bar.

Parameters
pDC | Pointer to a valid device context.
pButton | Button to draw.

Reimplemented in CXTPMessageBarThemeOffice2010, and CXTPMessageBarThemeOffice2013.

◆ FillMessageBar()

virtual void FillMessageBar | ( | CDC * | pDC,
 |  | CXTPMessageBar * | pBar )
 virtual

Draws the message bar.

Parameters
pDC | Pointer to a valid device context.
pBar | Points to a CXTPMessageBar object.

Reimplemented in CXTPMessageBarThemeOffice2010, and CXTPMessageBarThemeOffice2013.

◆ GetCloseButtonRect()

virtual CRect GetCloseButtonRect | ( | int | x,
 |  | int | y,
 |  | int | cy )
 virtual

Call this member to retrieve the close button coordinates.

Parameters
x | Specifies the left position.
y | Specifies the right position.
cy | Specifies the height of the client area.
Returns
A CRect object containing the location of the close button.

Reimplemented in CXTPMessageBarThemeOffice2010, and CXTPMessageBarThemeOffice2013.

◆ GetDefaultButtonSize()

virtual CSize GetDefaultButtonSize ( ) const
virtual
Returns
Returns the paint manager specific default button size value.

◆ GetHeight()

virtual int GetHeight ( ) const
virtual
Returns
Returns the paint manager specific bar height value.

◆ GetPadding()

virtual CRect GetPadding ( ) const
virtual
Returns
Returns the paint manager specific bar padding value.
The documentation for this class was generated from the following file:
  • XTPMessageBarPaintManager.h


Toolkit Pro: CXTPMessageBarThemeNativeWindows10 Class Reference

Public Member Functions | List of all members
CXTPMessageBarThemeNativeWindows10 Class Reference

The CXTPMessageBarThemeNativeWindows10 class is used by the message bar to draw a Native Windows 10 style message bar. More...

Inheritance diagram for CXTPMessageBarThemeNativeWindows10:
[legend]

Public Member Functions

CXTPMessageBarThemeNativeWindows10 (CXTPPaintManager *pPaintManager)
Message bar constructor.
- Public Member Functions inherited from CXTPMessageBarThemeOffice2013
CXTPMessageBarThemeOffice2013 (CXTPPaintManager *pPaintManager)
Message bar constructor.
virtual void | RefreshMetrics ()
Call to update class colors and settings.
virtual void | FillMessageBar (CDC *pDC, CXTPMessageBar *pBar)
Draws the message bar.
virtual void | DrawMessageBarButton (CDC *pDC, CXTPMessageBarButton *pButton)
Call this member to draw a button in the message bar.
virtual CRect | GetCloseButtonRect (int x, int y, int cy)
Call this member to retrieve the close button coordinates.
- Public Member Functions inherited from CXTPMessageBarPaintManager
CXTPMessageBarPaintManager (CXTPPaintManager *pPaintManager)
Message bar constructor.
virtual | ~CXTPMessageBarPaintManager ()
Handles object destruction.
virtual CSize | GetDefaultButtonSize () const
virtual int | GetHeight () const
virtual CRect | GetPadding () const

Additional Inherited Members

- Protected Attributes inherited from CXTPMessageBarThemeOffice2013
CXTPPaintManagerColor | m_clrTextHilite
Message bar text hilite color.
CXTPPaintManagerColor | m_clrButtonBack
Message bar button background color.
CXTPPaintManagerColor | m_clrButtonBackHilite
Message bar button background hilite color.
CXTPPaintManagerColor | m_clrButtonBackPushed
Message bar button background pushed color.
CXTPPaintManagerColor | m_clrButtonBorder
Message bar button border color.
CXTPPaintManagerColor | m_clrButtonBorderHilite
Message bar button border hilite color.
CXTPPaintManagerColor | m_clrButtonBorderPushed
Message bar button border pushed color.
- Protected Attributes inherited from CXTPMessageBarPaintManager
CXTPPaintManagerColor | m_clrBack
Message bar background color.
CXTPPaintManagerColor | m_clrText
Message bar text color.
CXTPPaintManagerColor | m_clrBorder
Message bar border color.
CXTPPaintManagerColor | m_clrInfoBack
Message bar info background color.
CXTPPaintManager * | m_pPaintManager
Pointer to the owner paint manager.

Detailed Description

The CXTPMessageBarThemeNativeWindows10 class is used by the message bar to draw a Native Windows 10 style message bar.

Constructor & Destructor Documentation

◆ CXTPMessageBarThemeNativeWindows10()

CXTPMessageBarThemeNativeWindows10 ( CXTPPaintManager * pPaintManager )

Message bar constructor.

Parameters
pPaintManager Pointer to the owner paint manager.
The documentation for this class was generated from the following file:
  • XTPMessageBarThemeNativeWindows10.h


Toolkit Pro: CXTPMessageBarThemeNativeWindows11 Class Reference

Public Member Functions | List of all members
CXTPMessageBarThemeNativeWindows11 Class Reference

The CXTPMessageBarThemeNativeWindows11 class is used by the message bar to draw a Native Windows 10 style message bar. More...

Inheritance diagram for CXTPMessageBarThemeNativeWindows11:
[legend]

Public Member Functions

CXTPMessageBarThemeNativeWindows11 (CXTPPaintManager *pPaintManager)
Message bar constructor.
- Public Member Functions inherited from CXTPMessageBarThemeOffice2013
CXTPMessageBarThemeOffice2013 (CXTPPaintManager *pPaintManager)
Message bar constructor.
virtual void | RefreshMetrics ()
Call to update class colors and settings.
virtual void | FillMessageBar (CDC *pDC, CXTPMessageBar *pBar)
Draws the message bar.
virtual void | DrawMessageBarButton (CDC *pDC, CXTPMessageBarButton *pButton)
Call this member to draw a button in the message bar.
virtual CRect | GetCloseButtonRect (int x, int y, int cy)
Call this member to retrieve the close button coordinates.
- Public Member Functions inherited from CXTPMessageBarPaintManager
CXTPMessageBarPaintManager (CXTPPaintManager *pPaintManager)
Message bar constructor.
virtual | ~CXTPMessageBarPaintManager ()
Handles object destruction.
virtual CSize | GetDefaultButtonSize () const
virtual int | GetHeight () const
virtual CRect | GetPadding () const

Additional Inherited Members

- Protected Attributes inherited from CXTPMessageBarThemeOffice2013
CXTPPaintManagerColor | m_clrTextHilite
Message bar text hilite color.
CXTPPaintManagerColor | m_clrButtonBack
Message bar button background color.
CXTPPaintManagerColor | m_clrButtonBackHilite
Message bar button background hilite color.
CXTPPaintManagerColor | m_clrButtonBackPushed
Message bar button background pushed color.
CXTPPaintManagerColor | m_clrButtonBorder
Message bar button border color.
CXTPPaintManagerColor | m_clrButtonBorderHilite
Message bar button border hilite color.
CXTPPaintManagerColor | m_clrButtonBorderPushed
Message bar button border pushed color.
- Protected Attributes inherited from CXTPMessageBarPaintManager
CXTPPaintManagerColor | m_clrBack
Message bar background color.
CXTPPaintManagerColor | m_clrText
Message bar text color.
CXTPPaintManagerColor | m_clrBorder
Message bar border color.
CXTPPaintManagerColor | m_clrInfoBack
Message bar info background color.
CXTPPaintManager * | m_pPaintManager
Pointer to the owner paint manager.

Detailed Description

The CXTPMessageBarThemeNativeWindows11 class is used by the message bar to draw a Native Windows 10 style message bar.

Constructor & Destructor Documentation

◆ CXTPMessageBarThemeNativeWindows11()

CXTPMessageBarThemeNativeWindows11 ( CXTPPaintManager * pPaintManager )

Message bar constructor.

Parameters
pPaintManager Pointer to the owner paint manager.
The documentation for this class was generated from the following file:
  • XTPMessageBarThemeNativeWindows11.h


Toolkit Pro: CXTPMessageBarThemeOffice2010 Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPMessageBarThemeOffice2010 Class Reference

The CXTPMessageBarThemeOffice2010 class is used by the message bar to draw an Office 2010 style message bar. More...

Inheritance diagram for CXTPMessageBarThemeOffice2010:
[legend]

Public Member Functions

CXTPMessageBarThemeOffice2010 (CXTPPaintManager *pPaintManager)
Message bar constructor.
virtual void | RefreshMetrics ()
Call to update class colors and settings.
virtual void | FillMessageBar (CDC *pDC, CXTPMessageBar *pBar)
Draws the message bar.
virtual void | DrawMessageBarButton (CDC *pDC, CXTPMessageBarButton *pButton)
Call this member to draw a button in the message bar.
virtual CRect | GetCloseButtonRect (int x, int y, int cy)
Call this member to retrieve the close button coordinates.
- Public Member Functions inherited from CXTPMessageBarPaintManager
CXTPMessageBarPaintManager (CXTPPaintManager *pPaintManager)
Message bar constructor.
virtual | ~CXTPMessageBarPaintManager ()
Handles object destruction.
virtual CSize | GetDefaultButtonSize () const
virtual int | GetHeight () const
virtual CRect | GetPadding () const

Protected Attributes

CXTPPaintManagerColor | m_clrTextHilite
Message bar text hilite color.
- Protected Attributes inherited from CXTPMessageBarPaintManager
CXTPPaintManagerColor | m_clrBack
Message bar background color.
CXTPPaintManagerColor | m_clrText
Message bar text color.
CXTPPaintManagerColor | m_clrBorder
Message bar border color.
CXTPPaintManagerColor | m_clrInfoBack
Message bar info background color.
CXTPPaintManager * | m_pPaintManager
Pointer to the owner paint manager.

Detailed Description

The CXTPMessageBarThemeOffice2010 class is used by the message bar to draw an Office 2010 style message bar.

Constructor & Destructor Documentation

◆ CXTPMessageBarThemeOffice2010()

CXTPMessageBarThemeOffice2010 ( CXTPPaintManager * pPaintManager )

Message bar constructor.

Parameters
pPaintManager Pointer to the owner paint manager.

Member Function Documentation

◆ DrawMessageBarButton()

virtual void DrawMessageBarButton | ( | CDC * | pDC,
 |  | CXTPMessageBarButton * | pButton )
 virtual

Call this member to draw a button in the message bar.

Parameters
pDC | Pointer to a valid device context.
pButton | Button to draw.

Reimplemented from CXTPMessageBarPaintManager.

◆ FillMessageBar()

virtual void FillMessageBar | ( | CDC * | pDC,
 |  | CXTPMessageBar * | pBar )
 virtual

Draws the message bar.

Parameters
pDC | Pointer to a valid device context.
pBar | Points to a CXTPMessageBar object.

Reimplemented from CXTPMessageBarPaintManager.

◆ GetCloseButtonRect()

virtual CRect GetCloseButtonRect | ( | int | x,
 |  | int | y,
 |  | int | cy )
 virtual

Call this member to retrieve the close button coordinates.

Parameters
x | Specifies the left position.
y | Specifies the right position.
cy | Specifies the height of the client area.
Returns
A CRect object containing the location of the close button.

Reimplemented from CXTPMessageBarPaintManager.

The documentation for this class was generated from the following file:
  • XTPMessageBarThemeOffice2010.h


Toolkit Pro: CXTPMessageBarThemeOffice2013 Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPMessageBarThemeOffice2013 Class Reference

The CXTPMessageBarThemeOffice2013 class is used by the message bar to draw an Office 2013 style message bar. More...

Inheritance diagram for CXTPMessageBarThemeOffice2013:
[legend]

Public Member Functions

CXTPMessageBarThemeOffice2013 (CXTPPaintManager *pPaintManager)
Message bar constructor.
virtual void | RefreshMetrics ()
Call to update class colors and settings.
virtual void | FillMessageBar (CDC *pDC, CXTPMessageBar *pBar)
Draws the message bar.
virtual void | DrawMessageBarButton (CDC *pDC, CXTPMessageBarButton *pButton)
Call this member to draw a button in the message bar.
virtual CRect | GetCloseButtonRect (int x, int y, int cy)
Call this member to retrieve the close button coordinates.
- Public Member Functions inherited from CXTPMessageBarPaintManager
CXTPMessageBarPaintManager (CXTPPaintManager *pPaintManager)
Message bar constructor.
virtual | ~CXTPMessageBarPaintManager ()
Handles object destruction.
virtual CSize | GetDefaultButtonSize () const
virtual int | GetHeight () const
virtual CRect | GetPadding () const

Protected Attributes

CXTPPaintManagerColor | m_clrTextHilite
Message bar text hilite color.
CXTPPaintManagerColor | m_clrButtonBack
Message bar button background color.
CXTPPaintManagerColor | m_clrButtonBackHilite
Message bar button background hilite color.
CXTPPaintManagerColor | m_clrButtonBackPushed
Message bar button background pushed color.
CXTPPaintManagerColor | m_clrButtonBorder
Message bar button border color.
CXTPPaintManagerColor | m_clrButtonBorderHilite
Message bar button border hilite color.
CXTPPaintManagerColor | m_clrButtonBorderPushed
Message bar button border pushed color.
- Protected Attributes inherited from CXTPMessageBarPaintManager
CXTPPaintManagerColor | m_clrBack
Message bar background color.
CXTPPaintManagerColor | m_clrText
Message bar text color.
CXTPPaintManagerColor | m_clrBorder
Message bar border color.
CXTPPaintManagerColor | m_clrInfoBack
Message bar info background color.
CXTPPaintManager * | m_pPaintManager
Pointer to the owner paint manager.

Detailed Description

The CXTPMessageBarThemeOffice2013 class is used by the message bar to draw an Office 2013 style message bar.

Constructor & Destructor Documentation

◆ CXTPMessageBarThemeOffice2013()

CXTPMessageBarThemeOffice2013 ( CXTPPaintManager * pPaintManager )

Message bar constructor.

Parameters
pPaintManager Pointer to the owner paint manager.

Member Function Documentation

◆ DrawMessageBarButton()

virtual void DrawMessageBarButton | ( | CDC * | pDC,
 |  | CXTPMessageBarButton * | pButton )
 virtual

Call this member to draw a button in the message bar.

Parameters
pDC | Pointer to a valid device context.
pButton | Button to draw.

Reimplemented from CXTPMessageBarPaintManager.

◆ FillMessageBar()

virtual void FillMessageBar | ( | CDC * | pDC,
 |  | CXTPMessageBar * | pBar )
 virtual

Draws the message bar.

Parameters
pDC | Pointer to a valid device context.
pBar | Points to a CXTPMessageBar object.

Reimplemented from CXTPMessageBarPaintManager.

◆ GetCloseButtonRect()

virtual CRect GetCloseButtonRect | ( | int | x,
 |  | int | y,
 |  | int | cy )
 virtual

Call this member to retrieve the close button coordinates.

Parameters
x | Specifies the left position.
y | Specifies the right position.
cy | Specifies the height of the client area.
Returns
A CRect object containing the location of the close button.

Reimplemented from CXTPMessageBarPaintManager.

The documentation for this class was generated from the following file:
  • XTPMessageBarThemeOffice2013.h


Toolkit Pro: CXTPMessageBarThemeVisualStudio2015 Class Reference

Public Member Functions | List of all members
CXTPMessageBarThemeVisualStudio2015 Class Reference

The CXTPMessageBarThemeVisualStudio2015 class is used by the message bar to draw a Visual Studio 2015 style message bar. More...

Inheritance diagram for CXTPMessageBarThemeVisualStudio2015:
[legend]

Public Member Functions

CXTPMessageBarThemeVisualStudio2015 (CXTPPaintManager *pPaintManager)
Message bar constructor.
- Public Member Functions inherited from CXTPMessageBarThemeOffice2013
CXTPMessageBarThemeOffice2013 (CXTPPaintManager *pPaintManager)
Message bar constructor.
virtual void | RefreshMetrics ()
Call to update class colors and settings.
virtual void | FillMessageBar (CDC *pDC, CXTPMessageBar *pBar)
Draws the message bar.
virtual void | DrawMessageBarButton (CDC *pDC, CXTPMessageBarButton *pButton)
Call this member to draw a button in the message bar.
virtual CRect | GetCloseButtonRect (int x, int y, int cy)
Call this member to retrieve the close button coordinates.
- Public Member Functions inherited from CXTPMessageBarPaintManager
CXTPMessageBarPaintManager (CXTPPaintManager *pPaintManager)
Message bar constructor.
virtual | ~CXTPMessageBarPaintManager ()
Handles object destruction.
virtual CSize | GetDefaultButtonSize () const
virtual int | GetHeight () const
virtual CRect | GetPadding () const

Additional Inherited Members

- Protected Attributes inherited from CXTPMessageBarThemeOffice2013
CXTPPaintManagerColor | m_clrTextHilite
Message bar text hilite color.
CXTPPaintManagerColor | m_clrButtonBack
Message bar button background color.
CXTPPaintManagerColor | m_clrButtonBackHilite
Message bar button background hilite color.
CXTPPaintManagerColor | m_clrButtonBackPushed
Message bar button background pushed color.
CXTPPaintManagerColor | m_clrButtonBorder
Message bar button border color.
CXTPPaintManagerColor | m_clrButtonBorderHilite
Message bar button border hilite color.
CXTPPaintManagerColor | m_clrButtonBorderPushed
Message bar button border pushed color.
- Protected Attributes inherited from CXTPMessageBarPaintManager
CXTPPaintManagerColor | m_clrBack
Message bar background color.
CXTPPaintManagerColor | m_clrText
Message bar text color.
CXTPPaintManagerColor | m_clrBorder
Message bar border color.
CXTPPaintManagerColor | m_clrInfoBack
Message bar info background color.
CXTPPaintManager * | m_pPaintManager
Pointer to the owner paint manager.

Detailed Description

The CXTPMessageBarThemeVisualStudio2015 class is used by the message bar to draw a Visual Studio 2015 style message bar.

Constructor & Destructor Documentation

◆ CXTPMessageBarThemeVisualStudio2015()

CXTPMessageBarThemeVisualStudio2015 ( CXTPPaintManager * pPaintManager )

Message bar constructor.

Parameters
pPaintManager Pointer to the owner paint manager.
The documentation for this class was generated from the following file:
  • XTPMessageBarThemeVisualStudio2015.h


Toolkit Pro: CXTPMessageBarThemeVisualStudio2017 Class Reference

Public Member Functions | List of all members
CXTPMessageBarThemeVisualStudio2017 Class Reference

The CXTPMessageBarThemeVisualStudio2017 class is used by the message bar to draw a Visual Studio 2017 style message bar. More...

Inheritance diagram for CXTPMessageBarThemeVisualStudio2017:
[legend]

Public Member Functions

CXTPMessageBarThemeVisualStudio2017 (CXTPPaintManager *pPaintManager)
Message bar constructor.
- Public Member Functions inherited from CXTPMessageBarThemeOffice2013
CXTPMessageBarThemeOffice2013 (CXTPPaintManager *pPaintManager)
Message bar constructor.
virtual void | RefreshMetrics ()
Call to update class colors and settings.
virtual void | FillMessageBar (CDC *pDC, CXTPMessageBar *pBar)
Draws the message bar.
virtual void | DrawMessageBarButton (CDC *pDC, CXTPMessageBarButton *pButton)
Call this member to draw a button in the message bar.
virtual CRect | GetCloseButtonRect (int x, int y, int cy)
Call this member to retrieve the close button coordinates.
- Public Member Functions inherited from CXTPMessageBarPaintManager
CXTPMessageBarPaintManager (CXTPPaintManager *pPaintManager)
Message bar constructor.
virtual | ~CXTPMessageBarPaintManager ()
Handles object destruction.
virtual CSize | GetDefaultButtonSize () const
virtual int | GetHeight () const
virtual CRect | GetPadding () const

Additional Inherited Members

- Protected Attributes inherited from CXTPMessageBarThemeOffice2013
CXTPPaintManagerColor | m_clrTextHilite
Message bar text hilite color.
CXTPPaintManagerColor | m_clrButtonBack
Message bar button background color.
CXTPPaintManagerColor | m_clrButtonBackHilite
Message bar button background hilite color.
CXTPPaintManagerColor | m_clrButtonBackPushed
Message bar button background pushed color.
CXTPPaintManagerColor | m_clrButtonBorder
Message bar button border color.
CXTPPaintManagerColor | m_clrButtonBorderHilite
Message bar button border hilite color.
CXTPPaintManagerColor | m_clrButtonBorderPushed
Message bar button border pushed color.
- Protected Attributes inherited from CXTPMessageBarPaintManager
CXTPPaintManagerColor | m_clrBack
Message bar background color.
CXTPPaintManagerColor | m_clrText
Message bar text color.
CXTPPaintManagerColor | m_clrBorder
Message bar border color.
CXTPPaintManagerColor | m_clrInfoBack
Message bar info background color.
CXTPPaintManager * | m_pPaintManager
Pointer to the owner paint manager.

Detailed Description

The CXTPMessageBarThemeVisualStudio2017 class is used by the message bar to draw a Visual Studio 2017 style message bar.

Constructor & Destructor Documentation

◆ CXTPMessageBarThemeVisualStudio2017()

CXTPMessageBarThemeVisualStudio2017 ( CXTPPaintManager * pPaintManager )

Message bar constructor.

Parameters
pPaintManager Pointer to the owner paint manager.
The documentation for this class was generated from the following file:
  • XTPMessageBarThemeVisualStudio2017.h


Toolkit Pro: CXTPMessageBarThemeVisualStudio2019 Class Reference

Public Member Functions | List of all members
CXTPMessageBarThemeVisualStudio2019 Class Reference

The CXTPMessageBarThemeVisualStudio2019 class is used by the message bar to draw a Visual Studio 2019 style message bar. More...

Inheritance diagram for CXTPMessageBarThemeVisualStudio2019:
[legend]

Public Member Functions

CXTPMessageBarThemeVisualStudio2019 (CXTPPaintManager *pPaintManager)
Message bar constructor.
- Public Member Functions inherited from CXTPMessageBarThemeOffice2013
CXTPMessageBarThemeOffice2013 (CXTPPaintManager *pPaintManager)
Message bar constructor.
virtual void | RefreshMetrics ()
Call to update class colors and settings.
virtual void | FillMessageBar (CDC *pDC, CXTPMessageBar *pBar)
Draws the message bar.
virtual void | DrawMessageBarButton (CDC *pDC, CXTPMessageBarButton *pButton)
Call this member to draw a button in the message bar.
virtual CRect | GetCloseButtonRect (int x, int y, int cy)
Call this member to retrieve the close button coordinates.
- Public Member Functions inherited from CXTPMessageBarPaintManager
CXTPMessageBarPaintManager (CXTPPaintManager *pPaintManager)
Message bar constructor.
virtual | ~CXTPMessageBarPaintManager ()
Handles object destruction.
virtual CSize | GetDefaultButtonSize () const
virtual int | GetHeight () const
virtual CRect | GetPadding () const

Additional Inherited Members

- Protected Attributes inherited from CXTPMessageBarThemeOffice2013
CXTPPaintManagerColor | m_clrTextHilite
Message bar text hilite color.
CXTPPaintManagerColor | m_clrButtonBack
Message bar button background color.
CXTPPaintManagerColor | m_clrButtonBackHilite
Message bar button background hilite color.
CXTPPaintManagerColor | m_clrButtonBackPushed
Message bar button background pushed color.
CXTPPaintManagerColor | m_clrButtonBorder
Message bar button border color.
CXTPPaintManagerColor | m_clrButtonBorderHilite
Message bar button border hilite color.
CXTPPaintManagerColor | m_clrButtonBorderPushed
Message bar button border pushed color.
- Protected Attributes inherited from CXTPMessageBarPaintManager
CXTPPaintManagerColor | m_clrBack
Message bar background color.
CXTPPaintManagerColor | m_clrText
Message bar text color.
CXTPPaintManagerColor | m_clrBorder
Message bar border color.
CXTPPaintManagerColor | m_clrInfoBack
Message bar info background color.
CXTPPaintManager * | m_pPaintManager
Pointer to the owner paint manager.

Detailed Description

The CXTPMessageBarThemeVisualStudio2019 class is used by the message bar to draw a Visual Studio 2019 style message bar.

Constructor & Destructor Documentation

◆ CXTPMessageBarThemeVisualStudio2019()

CXTPMessageBarThemeVisualStudio2019 ( CXTPPaintManager * pPaintManager )

Message bar constructor.

Parameters
pPaintManager Pointer to the owner paint manager.
The documentation for this class was generated from the following file:
  • XTPMessageBarThemeVisualStudio2019.h


Toolkit Pro: CXTPMessageBarThemeVisualStudio2022 Class Reference

Public Member Functions | List of all members
CXTPMessageBarThemeVisualStudio2022 Class Reference

The CXTPMessageBarThemeVisualStudio2022 class is used by the message bar to draw a Visual Studio 2022 style message bar. More...

Inheritance diagram for CXTPMessageBarThemeVisualStudio2022:
[legend]

Public Member Functions

CXTPMessageBarThemeVisualStudio2022 (CXTPPaintManager *pPaintManager)
Message bar constructor.
- Public Member Functions inherited from CXTPMessageBarThemeOffice2013
CXTPMessageBarThemeOffice2013 (CXTPPaintManager *pPaintManager)
Message bar constructor.
virtual void | RefreshMetrics ()
Call to update class colors and settings.
virtual void | FillMessageBar (CDC *pDC, CXTPMessageBar *pBar)
Draws the message bar.
virtual void | DrawMessageBarButton (CDC *pDC, CXTPMessageBarButton *pButton)
Call this member to draw a button in the message bar.
virtual CRect | GetCloseButtonRect (int x, int y, int cy)
Call this member to retrieve the close button coordinates.
- Public Member Functions inherited from CXTPMessageBarPaintManager
CXTPMessageBarPaintManager (CXTPPaintManager *pPaintManager)
Message bar constructor.
virtual | ~CXTPMessageBarPaintManager ()
Handles object destruction.
virtual CSize | GetDefaultButtonSize () const
virtual int | GetHeight () const
virtual CRect | GetPadding () const

Additional Inherited Members

- Protected Attributes inherited from CXTPMessageBarThemeOffice2013
CXTPPaintManagerColor | m_clrTextHilite
Message bar text hilite color.
CXTPPaintManagerColor | m_clrButtonBack
Message bar button background color.
CXTPPaintManagerColor | m_clrButtonBackHilite
Message bar button background hilite color.
CXTPPaintManagerColor | m_clrButtonBackPushed
Message bar button background pushed color.
CXTPPaintManagerColor | m_clrButtonBorder
Message bar button border color.
CXTPPaintManagerColor | m_clrButtonBorderHilite
Message bar button border hilite color.
CXTPPaintManagerColor | m_clrButtonBorderPushed
Message bar button border pushed color.
- Protected Attributes inherited from CXTPMessageBarPaintManager
CXTPPaintManagerColor | m_clrBack
Message bar background color.
CXTPPaintManagerColor | m_clrText
Message bar text color.
CXTPPaintManagerColor | m_clrBorder
Message bar border color.
CXTPPaintManagerColor | m_clrInfoBack
Message bar info background color.
CXTPPaintManager * | m_pPaintManager
Pointer to the owner paint manager.

Detailed Description

The CXTPMessageBarThemeVisualStudio2022 class is used by the message bar to draw a Visual Studio 2022 style message bar.

Constructor & Destructor Documentation

◆ CXTPMessageBarThemeVisualStudio2022()

CXTPMessageBarThemeVisualStudio2022 ( CXTPPaintManager * pPaintManager )

Message bar constructor.

Parameters
pPaintManager Pointer to the owner paint manager.
The documentation for this class was generated from the following file:
  • XTPMessageBarThemeVisualStudio2022.h


Toolkit Pro: CXTPMiniToolBar Class Reference

Public Member Functions | Static Public Member Functions | Protected Types | Protected Member Functions | Protected Attributes | List of all members
CXTPMiniToolBar Class Reference

Represents a MiniToolbar object. More...

Inheritance diagram for CXTPMiniToolBar:
[legend]

Public Member Functions

virtual BOOL | TrackMiniBar (UINT nFlags, int xPos, int yPos)
Call this method to show the minibar in a specific position.
virtual BOOL | TrackPopupMenu (CXTPPopupBar *pPopupMenu, UINT nFlags, int xPos, int yPos)
Call this member to display a floating pop-up menu at the specified location.
virtual BOOL | OnHookKeyDown (UINT nChar, LPARAM lParam)
The framework calls this member function when a non-system key is pressed.
void | SetCustomControlKeyboardInteraction (BOOL bInteract=TRUE)
Call this method to enable/disable keyboard interaction with custom controls.
- Public Member Functions inherited from CXTPPopupBar
void | SetTearOffPopup (LPCTSTR lpszCaption, UINT nID, int nWidth=400)
This method adds the tear-off state to the pop-up bar.
BOOL | IsTearOffPopup (CString &strCaption, UINT &nID, int &nWidth)
Determines if the pop-up bar has the tear-off state.
virtual BOOL | IsVisible () const
Call this member to determine if the pop-up menu is visible/displayed.
BOOL | Popup (int xPos, int yPos, LPCRECT rcExclude)
This method opens the pop-up bar.
BOOL | Popup (CXTPControlPopup *pControlPopup, BOOL bSelectFirst=FALSE)
This method opens the pop-up bar.
CXTPControlPopup * | GetControlPopup () const
Call this member to retrieve the control's pop-up.
void | ExpandBar ()
This method expands the bar.
BOOL | DestroyWindow ()
Call this member to destroy the window.
void | SetPopupToolBar (BOOL bToolBarType)
Call this method to make the pop-up bar look like a pop-up toolbar.
void | SetDefaultItem (UINT uItem, BOOL fByPos=FALSE)
Sets the default menu item for the specified pop-up bar.
UINT | GetDefaultItem (UINT gmdiFlags, BOOL fByPos=FALSE)
Determines the default menu item on the specified pop-up bar.
BOOL | IsDoubleGripper () const
Call this method to determine if the pop-up bar has a double gripper.
void | SetDoubleGripper (BOOL bDoubleGripper=TRUE)
Call this member to set a double gripper for the pop-up bar.
virtual BOOL | IsPopupBar () const
Call this member function to determine if the command bar is a CXTPPopupBar.
BOOL | IsContextMenu () const
Determines if the pop-up bar is a context menu.
void | PumpMessage ()
Translates all messages in the message queue.
virtual BOOL | Create ()
Creates the pop-up bar.
virtual CRect | CalculatePopupRect (CPoint ptPopup, CSize sz)
This method is called to calculate the destination rectangle of the pop-up bar.
void | SetPopupFlags (DWORD dwPopupFlags)
Call this method to set the pop-up direction.
virtual BOOL | SetTrackingMode (int bMode, BOOL bSelectFirst=TRUE, BOOL bKeyboard=FALSE)
Call this member to change the tracking state.
void | SetBorders (CRect rcBorders)
Sets the toolbar's borders.
void | DisableShadow ()
Disables shadow use.
BOOL | IsResizable () const
Determines if the control can be resized by the user.
virtual CRect | GetBorders ()
Call this method to get the border margins of the command bar.
- Public Member Functions inherited from CXTPCommandBar
int | IsTrackingMode () const
Call this member to get the tracking state.
CXTPControls * | GetControls () const
Call this member to get the controls collection.
void | SetControls (CXTPControls *pControls)
Call this member to set the controls collection of the command bar.
XTPBarType | GetType () const
Call this member to get the type of the command bar.
void | SetTextOrientation (XTPBarTextOrientation nTextOrientation)
Call this member to change text orientation.
XTPBarTextOrientation | GetTextOrientation () const
Call this member to get the text orientation.
XTPBarPosition | GetPosition () const
Call this member to get the position of the command bar.
void | DelayLayout ()
Call this member to recalculate the layout.
virtual BOOL | LoadMenu (CMenu *pMenu, BOOL bRemoveControls=TRUE)
Call this member to convert menu items to command bar controls.
CXTPControl * | GetControl (int nIndex) const
Call this member to return the control at the specified index.
int | GetControlCount () const
Call this member to get the count of the controls.
CXTPControl * | GetSelected () const
Call this member to get the currently selected control.
BOOL | SetPopuped (int nPopuped, BOOL bKeyboard=FALSE)
Call this member to pop-up the specified control.
void | SetTitle (LPCTSTR lpszTitle)
Call this member to set a title for this command bar.
CString | GetTitle () const
Call this member to get a title for this command bar.
CXTPCommandBars * | GetCommandBars () const
Call this member to get the command bar's object.
void | SetCommandBars (CXTPCommandBars *pCommandBars)
Call this member to set the command bar's object.
CWnd * | GetSite () const
Call this member to get the command bar's site.
CFrameWnd * | GetFrameSite () const
Call this member to get the command bar's site as CFrameWnd.
void | SetFlags (DWORD dwFlagsAdd, DWORD dwFlagsRemove=0)
Call this member to set the command bar's flags.
BOOL | SetButtons (UINT *pButtons, int nCount)
Call this member to set the controls from the button array.
virtual BOOL | LoadToolBar (UINT nIDResource, BOOL bLoadIcons=TRUE)
Call this member function to load the toolbar specified by nIDResource.
void | SetIconSize (CSize size)
Call this function to set the size of the actual bitmapped images to be added to a toolbar.
virtual CSize | GetIconSize () const
Call this member function to get the size of the toolbar icon.
CSize | GetLargeIconSize (BOOL bAutoSize) const
Call this method to get the large icon size of the toolbar.
void | SetButtonSize (CSize size)
Sets the size of the buttons in the command bar.
virtual CSize | GetButtonSize () const
Call this function to get the size of the command bar button.
void | ShowTextBelowIcons (BOOL bTextBelow=TRUE)
Call this member to show the caption below control's icon.
BOOL | IsTextBelowIcons () const
Checks whether the caption is below the control's icon.
HWND | GetTrackFocus () const
Call this method to retrieve the current focused control.
void | SetTrackFocus (HWND hwnd)
Call this method to set focus to the window.
virtual void | SetVisible (BOOL bVisible)
Call this method to set the visibility state of the control.
virtual BOOL | SetPosition (XTPBarPosition barPosition)
Call this member function to set the position of the command bar.
int | FindAccel (TCHAR chAccel) const
Call this method to get the index of the control with the specified accelerator character.
int | FindAccelEx (UINT chAccel, BOOL &bSelectOnly) const
Call this method to get the index of the control with the specified accelerator character.
BOOL | IsCustomizeMode () const
Call this method to check if the command bars are in customize mode.
virtual DROPEFFECT | OnCustomizeDragEnter (CXTPControl *pDataObject, CPoint point)
This member is called when a control is entered into the command bar.
virtual void | OnCustomizeDragLeave ()
This method is called when a control leaves the command bar.
virtual DROPEFFECT | OnCustomizeDragOver (CXTPControl *pDataObject, CPoint point)
This member is called when control is over the command bar.
virtual void | OnCustomizeDrop (CXTPControl *pDataObject, DROPEFFECT &dropEffect, CPoint ptDrop, CPoint ptDrag)
This method is called when a control is dropped to the command bar.
virtual BOOL | IsCustomizable () const
Call this method to check if the command bar is customizable.
BOOL | IsCustomizeDialogPresent () const
Call this method to check if the command bar is present in Customize dialog.
void | EnableCustomization (BOOL bEnable=TRUE)
Call this method to enable/disable customization of the command bar.
virtual void | OnTrackLost ()
Call this method to remove the tracking state of the command bar.
virtual void | OnTrackEnter ()
Call this method to track the command bar.
CWnd * | GetOwnerSite () const
Call this method to retrieve the owner window of the command bar.
void | InvalidateParents ()
Call this method to redraw all parent command bars.
DWORD | GetFlags () const
Call this method to retrieve the current behavior modification flags of the command bar.
UINT | GetBarID () const
Call this method to retrieve the identifier of the command bar.
void | SetBarID (UINT nID)
Call this method to set the identifier of the command bar.
virtual void | OnControlSelected (BOOL bSelected, CXTPControl *pControl)
This method is called when a child control becomes selected.
BOOL | SetStatusText (const CString &strDescription)
This method is called to set the description context.
void | SetCommandBarData (DWORD_PTR dwData)
This method sets the 32-bit value associated with the command bar.
DWORD_PTR | GetCommandBarData () const
This method retrieves the application-supplied, 32-bit value associated with the command bar.
CXTPCommandBar * | GetRootParent () const
Call this method to retrieve the top-level parent command bar.
CXTPPaintManager * | GetPaintManager () const
Call this method to retrieve the paint manager.
CXTPImageManager * | GetImageManager () const
Call this method to retrieve the image manager.
void | SetWidth (int nWidth)
Call this member to set the width of the floated or pop-up toolbar.
int | GetWidth () const
Call this member to get the width of the floated or pop-up toolbar.
void | SetPaintManager (CXTPPaintManager *pPaintManager)
Call this member to set the specified paint manager.
void | SetImageManager (CXTPImageManager *pImageManager)
Call this member to set the specified image manager.
BOOL | IsLayoutRTL () const
Call this member function to determine if the command bar layout is Right-to-Left (RTL).
virtual BOOL | IsDialogBar () const
Call this member function to determine if the command bar is a CXTPDialogBar.
virtual BOOL | IsRibbonBar () const
Call this member function to determine if the command bar is a CXTPRibbonBar.
virtual BOOL | IsMenuTitleBar () const
Call this member function to determine if the command bar is a CXTPMenuTitleBar.
virtual BOOL | IsKeyboardCuesVisible () const
Determines if underlines are visible in the command bar control.
void | SetGrabFocus (BOOL bGrabFocus)
This method is called internally to prevent the command bar from grabbing edit focus.
virtual void | Redraw (LPCRECT lpRect=0, BOOL bAnimate=TRUE)
The framework calls this member function to redraw the command bar.
void | EnableAnimation (BOOL bEnable=TRUE)
Call this method to enable animation for the command bar.
void | EnableDoubleBuffer (BOOL bEnable=TRUE)
Call this method to enable double buffer for toolbar drawing.
BOOL | IsAnimationEnabled () const
Determines if animation is enabled for the specified command bar.
virtual int | OnHookMessage (HWND hWnd, UINT nMessage, WPARAM &wParam, LPARAM &lParam, LRESULT &lResult)
This member function is called by WindowProc, or is called during message reflection.
virtual void | EnsureVisible (CXTPControl *pControl)
Call this method to ensure that a specified control is visible on the toolbar.
XTPButtonStyle | GetDefaultButtonStyle () const
Call this method to retrieve the default button style of the command bar.
void | SetDefaultButtonStyle (XTPButtonStyle buttonStyle)
Call this method to set the default button style of the command bar.
void | LockRedraw ()
Call this method to freeze redrawing until UnlockRedraw is called.
void | UnlockRedraw ()
Call this method to unfreeze redrawing.
void | SetShowGripper (BOOL bShow)
Call this method to set the visibility of the command bar's gripper.
BOOL | GetShowGripper () const
Call this method to check if the command bar's gripper is visible.
virtual void | FillCommandBarEntry (CDC *pDC)
This method is called to draw the background of the command bar.
BOOL | IsKeyboardTipsVisible () const
Call this method to check if keyboard tips are visible for the command bar.
virtual void | CreateKeyboardTips ()
This method is called to create a keyboard tips collection for the command bar.
void | OnKeyboardTipChar (UINT chAccel)
This method is called when the user presses a key while keyboard tips are visible.
virtual void | OnKeyboardTip (CXTPCommandBarKeyboardTip *pTip)
This method is called when a keyboard tip is found for the command bar.
void | HideKeyboardTips ()
Call this method to hide keyboard tips.
void | LockMouseMove (CXTPControl *pControl)
Locks the mouse cursor for a specified control.
void | UnlockMouseMove ()
Unlocks the mouse cursor.
- Public Member Functions inherited from CXTPHookManagerHookAble
CXTPHookManagerHookAble ()
Constructs a CXTPHookManagerHookAble object.
virtual | ~CXTPHookManagerHookAble ()
Destroys a CXTPHookManagerHookAble object, handles cleanup and deallocation.
virtual int | OnPostHookMessage (HWND hWnd, UINT nMessage, WPARAM &wParam, LPARAM &lParam, LRESULT &lResult)
This member function is called after a message has been processed by default window procedure.
virtual void | OnHookAttached (HWND hWnd)
This member function is called right after a hook is attached to the window.
virtual void | OnHookDetached ()
This member function is called right before a hook is to be detached from the window.

Static Public Member Functions

static CXTPMiniToolBar *AFX_CDECL | CreateMiniToolBar (CXTPCommandBars *pCommandBars)
Call this method to create a CXTPMiniToolBar class.
- Static Public Member Functions inherited from CXTPPopupToolBar
static CXTPPopupToolBar *AFX_CDECL | CreatePopupToolBar (CXTPCommandBars *pCommandBars)
Creates a pop-up toolbar object.
- Static Public Member Functions inherited from CXTPPopupBar
static CXTPPopupBar *AFX_CDECL | CreatePopupBar (CXTPCommandBars *pCommandBars)
Creates a pop-up bar object.

Protected Types

typedef BOOL(WINAPI *) | LPFNUPDATELAYEREDWINDOW(HWND hwnd, HDC hdcDst, POINT *pptDst, SIZE *psize, HDC hdcSrc, POINT *pptSrc, COLORREF crKey, BLENDFUNCTION *pblend, DWORD dwFlags)
UpdateLayeredWindow declaration.
typedef BOOL(WINAPI *) | PFNSETLAYEREDWINDOWATTRIBUTES(HWND hwnd, COLORREF crKey, BYTE bAlpha, DWORD dwFlags)
SetLayeredWindowAttributes declaration.

Protected Member Functions

CXTPMiniToolBar ()
Constructs a CXTPMiniToolBar object.
virtual | ~CXTPMiniToolBar ()
Destroys a CXTPMiniToolBar object, handles cleanup and deallocation.
virtual void | PumpMessage ()
Translates all messages in the message queue.
virtual void | UpdateOpacity ()
Updates the opacity of the mini toolbar and pop-up menu.
BOOL | CursorInWindow () const
Specifies whether the mouse cursor is hovered over the mini toolbar.
- Protected Member Functions inherited from CXTPPopupToolBar
CSize | CalcDynamicLayout (int nLength, DWORD dwMode)
This method is called to get the size of the command bar.
- Protected Member Functions inherited from CXTPPopupBar
CXTPPopupBar ()
Constructs a CXTPPopupBar object.
virtual | ~CXTPPopupBar ()
Destroys a CXTPPopupBar object, handles cleanup and deallocation.
virtual void | DelayRedraw ()
Redraw the pop-up bar.
virtual BOOL | SetSelected (int nSelected, BOOL bKeyboard=FALSE)
Call this member to select the specified control.
void | UpdateLocation (CSize sz)
This method sets the pop-up bar's position.
virtual void | UpdateFlags ()
Update flags.
void | UpdateExpandingState ()
Update expanding state.
virtual void | DrawCommandBar (CDC *pDC, CRect rcClipBox)
This method is called to draw the command bar in the given context.
virtual void | OnControlsChanged ()
This method is called when the controls array is changed.
virtual void | OnRecalcLayout ()
This method is called to recalculate the command bar layout.
CXTPCommandBar * | GetParentCommandBar () const
Call this member to retrieve the parent command bar.
virtual void | DoPropExchange (CXTPPropExchange *pPX)
Either reads this object from or writes this object to an archive.
virtual void | Copy (CXTPCommandBar *pCommandBar, BOOL bRecursive=FALSE)
Call this method make a copy of the command bar.
virtual void | AdjustExcludeRect (CRect &rc, BOOL bVertical)
Updates rectangle to set the position where the child pop-up bar becomes visible.
virtual void | Animate ()
Animates pop-up window.
- Protected Member Functions inherited from CXTPCommandBar
CXTPCommandBar ()
Constructs a CXTPCommandBar object.
virtual | ~CXTPCommandBar ()
Destroys a CXTPCommandBar object, handles cleanup and deallocation.
virtual BOOL | ProcessSpecialKey (XTPSpecialKey key)
This method is called to process special keys.
virtual int | OnMouseHitTest (CPoint pt)
This method is called to determine mouse hit code.
virtual void | UpdateShortcuts ()
Updates the control's shortcuts.
UINT | GetActiveDocTemplate () const
Retrieves the active MDI document template.
virtual void | GenerateCommandBarList (DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam)
This method is called to assign self identifiers for the serialization process.
virtual void | RestoreCommandBarList (CXTPCommandBarList *pCommandBarList)
This method is called in the serialization process to restore pop-ups from a list of command bars.
BOOL | IsHelpMode () const
Determines if the parent frame is in help mode.
virtual void | OnRemoved ()
This method is called when a toolbar is removed from the command bars collection.

Protected Attributes

PFNSETLAYEREDWINDOWATTRIBUTES | m_pfnSetLayeredWindowAttributes
Point to Transparency proc in USER32.dll module.
LPFNUPDATELAYEREDWINDOW | m_pfnUpdateLayeredWindow
Point to UpdateLayeredWindow proc in USER32.dll module.
BOOL | m_bActivated
TRUE if the mini toolbar is activated.
int | m_nOpacity
Opacity level.
BOOL | m_bTracking
TRUE if the command bar is in tracking mode.
CXTPPopupBar * | m_pContextMenu
Context menu that is displayed in customization mode when a user right-clicks on a control.
- Protected Attributes inherited from CXTPPopupBar
CXTPControlPopup * | m_pControlPopup
Control that pop-up'ed the bar.
CPoint | m_ptPopup
Position of the bar.
CRect | m_rcExclude
Excluded area.
DWORD | m_popupFlags
Flags of the bar.
BOOL | m_bDynamicLayout
TRUE if DynamicLayout routine executed.
BOOL | m_bCollapsed
TRUE if pop-up bar is collapsed.
BOOL | m_bExpanded
TRUE if pop-up bar is expanded.
BOOL | m_bExpanding
TRUE if pop-up bar is expanding.
BOOL | m_bTearOffPopup
TRUE if pop-up bar has tear-off option.
CRect | m_rcTearOffGripper
Tear-off gripper position.
CRect | m_rcResizeGripper
Resizable gripper position.
BOOL | m_bResizable
TRUE to allow resize.
BOOL | m_bTearOffSelected
TRUE if gripper selected.
UINT_PTR | m_nTearOffTimer
Tear-off timer.
BOOL | m_bTearOffTracking
Tear-off tracking mode.
CSize | m_szTearOffBar
Size of the bar.
CXTPToolBar * | m_pTearOffBar
Tear-off toolbar pointer.
CString | m_strTearOffCaption
Caption of the Tear-off toolbar.
UINT | m_nTearOffID
ID of the Tear-off toolbar.
int | m_nTearOffWidth
Width of the Tear-off toolbar.
BOOL | m_bShowShadow
TRUE to show the shadow.
CRect | m_rcBorders
Borders of the bar.
BOOL | m_bDoubleGripper
TRUE if pop-up is state pop-up type.
BOOL | m_bContextMenu
TRUE if pop-up bar is context menu.
int | m_nMaxHeight
Maximum height the pop-up bar can become.
- Protected Attributes inherited from CXTPCommandBar
BOOL | m_bGrabFocus
TRUE to grab current focus.
int | m_nMRUWidth
Recent width.
int | m_nSelected
Selected control index.
int | m_nPopuped
Pop-up'ed control index.
HWND | m_hwndFocus
The handle of the window that currently has focus.
UINT | m_nBarID
Command bar's identifier.
BOOL | m_bTracking
TRUE if the command bar is in tracking mode.
CWnd * | m_pSite
Command bar's site.
DWORD | m_nIdleFlags
Idle flags.
DWORD | m_dwFlags
Command bar's flags.
DWORD | m_dwStyle
Command bar's styles.
CString | m_strTitle
Command bar's caption.
XTPBarType | m_barType
Type of the command bar.
CXTPControls * | m_pControls
A pointer to controls collection.
XTPBarPosition | m_barPosition
Position of the command bar.
CXTPCommandBars * | m_pCommandBars
parent command bars class.
CWnd * | m_pOwner
Owner window.
CSize | m_szIcons
Size of the command bar's icons.
CSize | m_szButtons
Size of the command bar's buttons.
BOOL | m_bTextBelow
TRUE if text is shown below the CommandBar buttons.
BOOL | m_bExecOnRButton
TRUE if the control button is executed on a right-click.
BOOL | m_bIgnoreUpdateHandler
TRUE to skip update handler for all child controls.
BOOL | m_bRecursePopup
TRUE if pop-up bar was opened recursively.
BOOL | m_bKeyboardSelect
TRUE if last item was selected by keyboard.
BOOL | m_bCloseable
TRUE if the CommandBar can be closed and-or Hidden.
BOOL | m_bCustomizable
TRUE if command bar is customizable.
CRect | m_rcMarker
Marker position.
BOOL | m_bVerticalMarker
TRUE to draw marker vertically.
DWORD_PTR | m_dwData
The 32-bit value associated with the command bar.
UINT * | m_pReturnCmd
Return command holder.
BOOL | m_bCustomizeDialogPresent
TRUE if the command bar is present in Customize dialog.
BOOL | m_bAnimatePopup
TRUE to animate pop-up bar.
BOOL | m_nLockRedraw
TRUE if all drawing routines skipped.
CXTPPaintManager * | m_pPaintManager
Selected paint manager for command bar.
CXTPImageManager * | m_pImageManager
Selected image manager for command bar.
BOOL | m_bMultiLine
True if multi line commandbar.
XTPButtonStyle | m_buttonStyle
Default button Style.
XTPBarTextOrientation | m_nTextOrientation
Commandbar text orientation.
CXTPToolTipContext * | m_pToolTipContext
Tool tip Context.
CXTPCommandBarAnimation * | m_pAnimation
Animation context.
CSize | m_szButtonSpacing
Spacing used between toolbar buttons.

Additional Inherited Members

- Public Attributes inherited from CXTPCommandBar
int | m_nStateFlags
State of the command bars.
BOOL | m_bComboBar
TRUE if it is combobox list.
BOOL | m_bTrackOnHover
TRUE to select item if mouse stay over control.
- Public Attributes inherited from CXTPHookManagerHookAble
BOOL | m_bAutoDestroy
TRUE to automatically delete hook.
- Static Public Attributes inherited from CXTPPopupBar
static double | m_dMaxWidthDivisor
Maximum available width of pop-up.
- Static Public Attributes inherited from CXTPCommandBar
static int | s_nHoverDelay
Hover delay time.
static int | s_nExpandDelay
Expand delay time.
static int | s_nExpandHoverDelay
Expand hover delay.

Detailed Description

Represents a MiniToolbar object.

MiniToolBar is an Office 2007 style context toolbar which has many uses. For example, you might want to display a MiniToolbar presenting some of the more commonly used commands that a user would probably want to use in a given situation like selecting text. For example, this can save the user a lot of time by making font related tasks available without fumbling through tabs or menus. So, to effectively use a MiniToolbar, you would place all commands that the user would most probably want to use when performing a given action.

Member Typedef Documentation

◆ LPFNUPDATELAYEREDWINDOW

BOOL(WINAPI *) LPFNUPDATELAYEREDWINDOW(HWND hwnd, HDC hdcDst, POINT *pptDst, SIZE *psize, HDC hdcSrc, POINT *pptSrc, COLORREF crKey, BLENDFUNCTION *pblend, DWORD dwFlags)
protected

UpdateLayeredWindow declaration.

Parameters
LPFNUPDATELAYEREDWINDOW Struct that contains the position, size, shape, content, and translucency of a layered window.

Required for transparent Windows, but they are not present in the VC6 headers. They are only present on Win2k or later.

Returns
TRUE if successful, otherwise FALSE.

◆ PFNSETLAYEREDWINDOWATTRIBUTES

BOOL(WINAPI *) PFNSETLAYEREDWINDOWATTRIBUTES(HWND hwnd, COLORREF crKey, BYTE bAlpha, DWORD dwFlags)
protected

SetLayeredWindowAttributes declaration.

Parameters
PFNSETLAYEREDWINDOWATTRIBUTES Struct that contains the opacity and transparency color key of a layered window.

Required for transparent Windows, but they are not present in the VC6 headers. They are only present on Win2k or later.

Returns
TRUE if successful, otherwise FALSE.

Member Function Documentation

◆ CreateMiniToolBar()

static CXTPMiniToolBar *AFX_CDECL CreateMiniToolBar ( CXTPCommandBars * pCommandBars )
static

Call this method to create a CXTPMiniToolBar class.

Parameters
pCommandBars Pointer to owner CXTPCommandBars.
Returns
Pointer to the newly created CXTPMiniToolBar object.

◆ CursorInWindow()

BOOL CursorInWindow ( ) const
protected

Specifies whether the mouse cursor is hovered over the mini toolbar.

Returns
TRUE if the mouse cursor is hovered over the mini toolbar, otherwise FALSE.

◆ OnHookKeyDown()

virtual BOOL OnHookKeyDown | ( | UINT | nChar,
 |  | LPARAM | lParam )
 virtual

The framework calls this member function when a non-system key is pressed.

Parameters
nChar | Specifies the virtual key code of the given key.
lParam | Specifies additional message-dependent information.
Returns
TRUE if the key was handled, otherwise FALSE.

Reimplemented from CXTPPopupBar.

◆ SetCustomControlKeyboardInteraction()

void SetCustomControlKeyboardInteraction ( BOOL bInteract = TRUE )

Call this method to enable/disable keyboard interaction with custom controls.

Parameters
bInteract TRUE to enable keyboard interaction with custom controls.

xtpControlCustom is disabled by default. The MiniToolbar closes when keyboard events occur within a custom control.

◆ TrackMiniBar()

virtual BOOL TrackMiniBar | ( | UINT | nFlags,
 |  | int | xPos,
 |  | int | yPos )
 virtual

Call this method to show the minibar in a specific position.

Parameters
nFlags | Reserved, currently not used.
xPos | Specifies the horizontal position (in screen coordinates) of the minibar.
yPos | Specifies the vertical position (in screen coordinates) of the top of the minibar.
Returns
TRUE if successful, otherwise FALSE.

◆ TrackPopupMenu()

virtual BOOL TrackPopupMenu | ( | CXTPPopupBar * | pPopupMenu,
 |  | UINT | nFlags,
 |  | int | xPos,
 |  | int | yPos )
 virtual

Call this member to display a floating pop-up menu at the specified location.

Parameters
pPopupMenu | Pointer to a CXTPPopupBar object.
nFlags | Reserved, currently not used.
xPos | Specifies the horizontal position (in screen coordinates) of the pop-up menu.
yPos | Specifies the vertical position (in screen coordinates) of the top of the menu on the screen.
Returns
TRUE if successful, otherwise FALSE.
The documentation for this class was generated from the following file:
  • XTPMiniToolBar.h


Toolkit Pro: CXTPModuleHandle Class Reference

Public Types | Public Member Functions | List of all members
CXTPModuleHandle Class Reference

CXTPModuleHandle class is helper for LoadLibray/GetModuleHandle methods. More...

Public Types

enum XTPModuleState { xtpModNone , xtpModMapped , xtpModLoaded }
Module state enum. More...

Public Member Functions

CXTPModuleHandle ()
Constructs a CXTPModuleHandle object.
CXTPModuleHandle (LPCTSTR lpszModuleName)
Constructs a CXTPModuleHandle object.
virtual | ~CXTPModuleHandle ()
Destroys a CXTPModuleHandle object, handles cleanup and deallocation.
BOOL | Init (LPCTSTR lpszModuleName)
Call this method to LoadLibrary.
BOOL | LoadLibrary (LPCTSTR lpszModuleName)
This member function is called to load the library specified by 'lpszModule'.
BOOL | GetModuleHandle (LPCTSTR lpszModuleName)
The GetModuleHandle function retrieves a module handle for the specified module if the file has been mapped into the address space of the calling process.
BOOL | FreeLibrary ()
The FreeLibrary function decrements the reference count of the loaded dynamic-link library (DLL).
BOOL | GetProcAddress (FARPROC *ppFnPtr, LPCSTR lpProcName, DWORD dwMinVer=NULL)
The GetProcAddress function retrieves the address of the specified exported dynamic-link library (DLL) function.
DWORD | GetVersion ()
Use this member function to return the version number of the module attached to this CLoadLibrary object.
operator HMODULE () const
This overloaded operator returns a handle to the module indicating success.
HMODULE | GetHandle () const
This method returns a handle to the module indicating success.
CString | GetName () const
XTPModuleState | GetModuleState () const

Detailed Description

CXTPModuleHandle class is helper for LoadLibray/GetModuleHandle methods.

Member Enumeration Documentation

◆ XTPModuleState

enum XTPModuleState

Module state enum.

Enumerator
xtpModNone | Indicates no module found.
xtpModMapped | Indicates the module handle was set using GetModuleHandle.
xtpModLoaded | Indicates the module handle was set using LoadLibrary.

Constructor & Destructor Documentation

◆ CXTPModuleHandle()

CXTPModuleHandle ( LPCTSTR lpszModuleName )

Constructs a CXTPModuleHandle object.

Parameters
lpszModuleName Pointer to a null-terminated string that names the .DLL file. The name specified is the filename of the module and is not related to the name stored in the library module itself, as specified by the LIBRARY keyword in the module- definition (.DEF) file. If the string specifies a path but the file does not exist in the specified directory, the function fails. When specifying a path, be sure to use backslashes (\), not forward slashes (/).

Member Function Documentation

◆ FreeLibrary()

BOOL FreeLibrary ( )

The FreeLibrary function decrements the reference count of the loaded dynamic-link library (DLL).

Returns
TRUE if successful, FALSE otherwise.

◆ GetHandle()

HMODULE GetHandle ( ) const

This method returns a handle to the module indicating success.

NULL indicates failure.

Returns
A handle to the module if successful, otherwise returns NULL.

◆ GetModuleHandle()

BOOL GetModuleHandle ( LPCTSTR lpszModuleName )

The GetModuleHandle function retrieves a module handle for the specified module if the file has been mapped into the address space of the calling process.

Parameters
lpszModuleName Pointer to a null-terminated string that contains the name of the module (either a .dll or .exe file).
Returns
TRUE if successful, FALSE otherwise.

◆ GetModuleState()

XTPModuleState GetModuleState ( ) const
Returns
Returns module state

◆ GetName()

CString GetName ( ) const
Returns
Returns Path to loaded library

◆ GetProcAddress()

BOOL GetProcAddress | ( | FARPROC * | ppFnPtr,
 |  | LPCSTR | lpProcName,
 |  | DWORD | dwMinVer = NULL )

The GetProcAddress function retrieves the address of the specified exported dynamic-link library (DLL) function.

Parameters
dwMinVer | Specifies the minimum acceptable module version.
ppFnPtr | Receives a retrieved function pointer upon successful execution.
lpProcName | Specifies the procedure name.
Returns
TRUE if successful, FALSE otherwise.

◆ GetVersion()

DWORD GetVersion ( )

Use this member function to return the version number of the module attached to this CLoadLibrary object.

The high-order word of the return value represents the major version number and the low-order word of the returned value represents the minor version number.

Returns
A DWORD value if successful, otherwise 0L.

◆ Init()

BOOL Init ( LPCTSTR lpszModuleName )

Call this method to LoadLibrary.

Parameters
lpszModuleName Pointer to a null-terminated string that names the .DLL file. The name specified is the filename of the module and is not related to the name stored in the library module itself, as specified by the LIBRARY keyword in the module- definition (.DEF) file. If the string specifies a path but the file does not exist in the specified directory, the function fails. When specifying a path, be sure to use backslashes (\), not forward slashes (/).
Returns
TRUE if successful, FALSE otherwise.

◆ LoadLibrary()

BOOL LoadLibrary ( LPCTSTR lpszModuleName )

This member function is called to load the library specified by 'lpszModule'.

Once the library is loaded, you can retrieve the instance handle by using the HINSTANCE operator.

Parameters
lpszModuleName Pointer to a null-terminated string that names the .DLL file. The name specified is the filename of the module and is not related to the name stored in the library module itself, as specified by the LIBRARY keyword in the module- definition (.DEF) file. If the string specifies a path but the file does not exist in the specified directory, the function fails. When specifying a path, be sure to use backslashes (\), not forward slashes (/).
Returns
TRUE if successful, FALSE otherwise.

◆ operator HMODULE()

operator HMODULE ( ) const

This overloaded operator returns a handle to the module indicating success.

NULL indicates failure.

Returns
A handle to the module if successful, otherwise returns NULL.
The documentation for this class was generated from the following file:
  • XTPSystemHelpers.h


Toolkit Pro: CXTPMouseManager Class Reference

Classes | Public Member Functions | Static Public Member Functions | List of all members
CXTPMouseManager Class Reference

CXTPMouseManager is standalone class. More...

Classes

class CTrackArray
Array of the tracking bars. More...

Public Member Functions

CXTPMouseManager ()
Constructs a CXTPMouseManager object.
~CXTPMouseManager ()
Destroys a CXTPMouseManager object, handles cleanup and deallocation.
void | SetTrack (CXTPCommandBar *pTrack, BOOL bCaptureMouse=TRUE)
Adds a tracking bar.
void | RemoveTrack (CXTPCommandBar *pTrack)
Removes the tracking bar.
void | SendTrackLost ()
Removes all tracking bars.
void | TrackMouseLeave (HWND hwnd)
Hooks window for the mouse leave event.
BOOL | IsTrackedLock (const CXTPCommandBar *pItem=NULL)
Checks if the command bar is tracked.
void | SetSelected (CXTPCommandBar *pSelected)
Sets the selected command bar.
void | RemoveSelected (CXTPCommandBar *pSelected)
Removes the selected command bar.
void | LockMouseMove ()
Captures the mouse cursor.
void | UnlockMouseMove ()
Unlocks the mouse cursor.
BOOL | IsMouseLocked () const
Checks if the mouse cursor locked.
BOOL | IsForceExpanded () const
Check if the command bar needs to be expanded.
void | SetForceExpanded (BOOL bForceExpanded)
Sets expanded state.
void | AddTrustedWindow (HWND hWnd)
Adds a window to the trusted window list.
void | RemoveTrustedWindow (HWND hWnd)
Removes a window from the trusted window list.
void | IgnoreLButtonUp ()
This method is called to disable one WM_RBUTTONUP message.
CXTPCommandBar * | HitTest (POINT point) const
This method determines where a point lies in a specified item.

Static Public Member Functions

static BOOL AFX_CDECL | IsTopParentActive (HWND hWnd)
Call this method to check if the top parent window is active.
static void AFX_CDECL | RefreshCursor ()

Detailed Description

CXTPMouseManager is standalone class.

It used in CommandBars to manage the mouse.

Member Function Documentation

◆ AddTrustedWindow()

void AddTrustedWindow ( HWND hWnd )

Adds a window to the trusted window list.

Parameters
hWnd Window handle.

◆ HitTest()

CXTPCommandBar * HitTest ( POINT point ) const

This method determines where a point lies in a specified item.

Parameters
point Specifies the point to be tested.
Returns
A pointer to a CXTPCommandBar item that occupies the specified point or NULL if no item occupies the point.

◆ IsForceExpanded()

AFX_INLINE BOOL IsForceExpanded ( ) const

Check if the command bar needs to be expanded.

Returns
TRUE if successful; otherwise returns FALSE

◆ IsMouseLocked()

AFX_INLINE BOOL IsMouseLocked ( ) const

Checks if the mouse cursor locked.

Returns
TRUE if the mouse cursor is locked, otherwise FALSE.

◆ IsTopParentActive()

static BOOL AFX_CDECL IsTopParentActive ( HWND hWnd )
static

Call this method to check if the top parent window is active.

Parameters
hWnd Window handle.
Returns
TRUE if the top parent window is active, otherwise FALSE.

◆ IsTrackedLock()

BOOL IsTrackedLock ( const CXTPCommandBar * pItem = NULL )

Checks if the command bar is tracked.

Parameters
pItem Pointer to a CXTPCommandBar object.
Returns
TRUE if successful, otherwise FALSE.

◆ RefreshCursor()

static void AFX_CDECL RefreshCursor ( )
static
Returns
Refreshes the mouse cursor.

◆ RemoveSelected()

AFX_INLINE void RemoveSelected ( CXTPCommandBar * pSelected )

Removes the selected command bar.

Parameters
pSelected Pointer to a CXTPCommandBar object.

◆ RemoveTrack()

void RemoveTrack ( CXTPCommandBar * pTrack )

Removes the tracking bar.

Parameters
pTrack Pointer to a CXTPCommandBar object.

◆ RemoveTrustedWindow()

void RemoveTrustedWindow ( HWND hWnd )

Removes a window from the trusted window list.

Parameters
hWnd Window handle.

◆ SetForceExpanded()

AFX_INLINE void SetForceExpanded ( BOOL bForceExpanded )

Sets expanded state.

Parameters
bForceExpanded TRUE to expand bars.

◆ SetSelected()

AFX_INLINE void SetSelected ( CXTPCommandBar * pSelected )

Sets the selected command bar.

Parameters
pSelected Pointer to a CXTPCommandBar object.

◆ SetTrack()

void SetTrack | ( | CXTPCommandBar * | pTrack,
 |  | BOOL | bCaptureMouse = TRUE )

Adds a tracking bar.

Parameters
pTrack | Pointer to a CXTPCommandBar object.
bCaptureMouse | TRUE to capture the mouse.

◆ TrackMouseLeave()

void TrackMouseLeave ( HWND hwnd )

Hooks window for the mouse leave event.

Parameters
hwnd Window handle.
The documentation for this class was generated from the following file:
  • XTPMouseManager.h


Toolkit Pro: CXTPMouseManager::CTrackArray Class Reference

  • CXTPMouseManager
  • CTrackArray
Public Member Functions | List of all members
CXTPMouseManager::CTrackArray Class Reference

Array of the tracking bars. More...

Public Member Functions

int Find (const CXTPCommandBar *pCommandBar) const
Call this method to find the position of a specified command bar.

Detailed Description

Array of the tracking bars.

Member Function Documentation

◆ Find()

int Find ( const CXTPCommandBar * pCommandBar ) const

Call this method to find the position of a specified command bar.

Parameters
pCommandBar CommandBar to find.
Returns
The position of the command bar in the list if successful. If unsuccessful, a value of -1.
The documentation for this class was generated from the following file:
  • XTPMouseManager.h


Toolkit Pro: CXTPMsgPreviewProvider Class Reference

List of all members
CXTPMsgPreviewProvider Class Reference

Provides a preview handler for the Outlook Message (MSG) file type. More...

Inheritance diagram for CXTPMsgPreviewProvider:
[legend]

Additional Inherited Members

- Public Member Functions inherited from IXTPPreviewProvider
virtual | ~IXTPPreviewProvider ()
Handles object destruction.
- Protected Member Functions inherited from CXTPPreviewProviderBase
CXTPPreviewProviderBase ()
Handles object construction.
void | BindHost (IXTPPreviewHost &host)
The method is called by the host preview control when the provider is initially bound to the host.
IXTPPreviewHost & | GetHost () const
Obtains the preview host interface that the provider is bound to.

Detailed Description

Provides a preview handler for the Outlook Message (MSG) file type.

See also
CXTPSystemPreviewProvider, CXTPCommonPicturePreviewProvider, CXTPGifPreviewProvider, CXTPTextPreviewProvider, CXTPXamlPreviewProvider
The documentation for this class was generated from the following file:
  • XTPMsgPreviewProvider.h


Toolkit Pro: CXTPMultiMonitor Class Reference

Public Member Functions | List of all members
CXTPMultiMonitor Class Reference

MultiMonitor API wrapper class. More...

Public Member Functions

CRect | GetWorkArea ()
This function retrieves work area for the display monitor that the mouse cursor is currently positioned over.
CRect | GetWorkArea (const POINT &point)
This function retrieves work area for the display monitor that the mouse cursor is currently positioned over.
CRect | GetWorkArea (LPCRECT rect)
This function retrieves work area for the display monitor that the mouse cursor is currently positioned over.
CRect | GetWorkArea (const CWnd *pWnd)
This function retrieves work area for the display monitor that the mouse cursor is currently positioned over.
CRect | GetWorkArea (HWND hWnd)
This function retrieves work area for the display monitor that the mouse cursor is currently positioned over.
CRect | GetScreenArea (const CWnd *pWnd)
This function retrieves work area for the display monitor that the mouse cursor is currently positioned over.
CRect | GetScreenArea (HWND hWnd)
This function retrieves work area for the display monitor that the mouse cursor is currently positioned over.
CRect | GetScreenArea (const POINT &point)
This function retrieves work area for the display monitor that the mouse cursor is currently positioned over.
CRect | GetScreenArea (LPCRECT rect)
This function retrieves work area for the display monitor that the mouse cursor is currently positioned over.
BOOL | GetDisplaySettings (const CWnd *pWnd, DEVMODE *lpDevMode)
Obtains display settings for a monitor associated with the window handle provided.
BOOL | GetDisplaySettings (HWND hWnd, DEVMODE *lpDevMode)
Obtains display settings for a monitor associated with the window handle provided.

Detailed Description

MultiMonitor API wrapper class.

Member Function Documentation

◆ GetDisplaySettings() [1/2]

BOOL GetDisplaySettings | ( | const CWnd * | pWnd,
 |  | DEVMODE * | lpDevMode )

Obtains display settings for a monitor associated with the window handle provided.

Parameters
pWnd | Window object pointer
lpDevMode | Points to DEVMODE object instance with dmSize field initialized to a valid structure size value. Upon successful completion this object will contain valid display settings.
Returns
TRUE if display settings obtained successfully.

◆ GetDisplaySettings() [2/2]

BOOL GetDisplaySettings | ( | HWND | hWnd,
 |  | DEVMODE * | lpDevMode )

Obtains display settings for a monitor associated with the window handle provided.

Parameters
hWnd | Window handle
lpDevMode | Points to DEVMODE object instance with dmSize field initialized to a valid structure size value. Upon successful completion this object will contain valid display settings.
Returns
TRUE if display settings obtained successfully.

◆ GetScreenArea() [1/4]

CRect GetScreenArea ( const CWnd * pWnd )

This function retrieves work area for the display monitor that the mouse cursor is currently positioned over.

Parameters
pWnd Pointer to the window of interest.
Returns
If the mouse cursor is positioned over a display monitor, the return value is a CRect object that specifies the work area rectangle of the display monitor, expressed in virtual-screen coordinates. Otherwise, returns the size of the work area on the primary display monitor.

◆ GetScreenArea() [2/4]

CRect GetScreenArea ( const POINT & point )

This function retrieves work area for the display monitor that the mouse cursor is currently positioned over.

Parameters
point Point of interest.
Returns
If the mouse cursor is positioned over a display monitor, the return value is a CRect object that specifies the work area rectangle of the display monitor, expressed in virtual-screen coordinates. Otherwise, returns the size of the work area on the primary display monitor.

◆ GetScreenArea() [3/4]

CRect GetScreenArea ( HWND hWnd )

This function retrieves work area for the display monitor that the mouse cursor is currently positioned over.

Parameters
hWnd Handle to the window of interest.
Returns
If the mouse cursor is positioned over a display monitor, the return value is a CRect object that specifies the work area rectangle of the display monitor, expressed in virtual-screen coordinates. Otherwise, returns the size of the work area on the primary display monitor.

◆ GetScreenArea() [4/4]

CRect GetScreenArea ( LPCRECT rect )

This function retrieves work area for the display monitor that the mouse cursor is currently positioned over.

Parameters
rect Reference to a CRect class that specifies the coordinates of the rectangle of interest in virtual screen coordinates.
Returns
If the mouse cursor is positioned over a display monitor, the return value is a CRect object that specifies the work area rectangle of the display monitor, expressed in virtual-screen coordinates. Otherwise, returns the size of the work area on the primary display monitor.

◆ GetWorkArea() [1/5]

CRect GetWorkArea ( )

This function retrieves work area for the display monitor that the mouse cursor is currently positioned over.

Returns
If the mouse cursor is positioned over a display monitor, the return value is a CRect object that specifies the work area rectangle of the display monitor, expressed in virtual-screen coordinates. Otherwise, returns the size of the work area on the primary display monitor.

◆ GetWorkArea() [2/5]

CRect GetWorkArea ( const CWnd * pWnd )

This function retrieves work area for the display monitor that the mouse cursor is currently positioned over.

Parameters
pWnd Pointer to the window of interest.
Returns
If the mouse cursor is positioned over a display monitor, the return value is a CRect object that specifies the work area rectangle of the display monitor, expressed in virtual-screen coordinates. Otherwise, returns the size of the work area on the primary display monitor.

◆ GetWorkArea() [3/5]

CRect GetWorkArea ( const POINT & point )

This function retrieves work area for the display monitor that the mouse cursor is currently positioned over.

Parameters
point Point of interest.
Returns
If the mouse cursor is positioned over a display monitor, the return value is a CRect object that specifies the work area rectangle of the display monitor, expressed in virtual-screen coordinates. Otherwise, returns the size of the work area on the primary display monitor.

◆ GetWorkArea() [4/5]

CRect GetWorkArea ( HWND hWnd )

This function retrieves work area for the display monitor that the mouse cursor is currently positioned over.

Parameters
hWnd Handle to the window of interest.
Returns
If the mouse cursor is positioned over a display monitor, the return value is a CRect object that specifies the work area rectangle of the display monitor, expressed in virtual-screen coordinates. Otherwise, returns the size of the work area on the primary display monitor.

◆ GetWorkArea() [5/5]

CRect GetWorkArea ( LPCRECT rect )

This function retrieves work area for the display monitor that the mouse cursor is currently positioned over.

Parameters
rect Reference to a CRect class that specifies the coordinates of the rectangle of interest in virtual screen coordinates.
Returns
If the mouse cursor is positioned over a display monitor, the return value is a CRect object that specifies the work area rectangle of the display monitor, expressed in virtual-screen coordinates. Otherwise, returns the size of the work area on the primary display monitor.
The documentation for this class was generated from the following file:
  • XTPSystemHelpers.h


Toolkit Pro: CXTPNonClientMetrics Class Reference

Public Member Functions | List of all members
CXTPNonClientMetrics Class Reference

CXTPNonClientMetrics is a self-initializing NONCLIENTMETRICS derived class. More...

Public Member Functions

CXTPNonClientMetrics ()
Constructs a CXTPNonClientMetrics object.

Detailed Description

CXTPNonClientMetrics is a self-initializing NONCLIENTMETRICS derived class.

It contains the scalable metrics associated with the non-client area of a non-minimized window. This class is used by the SPI_GETNONCLIENTMETRICS and SPI_SETNONCLIENTMETRICS actions of SystemParametersInfo.

Example: The following example demonstrates using CXTPNonClientMetrics.

CXTPLogFont lfMenuFont;
CXTPNonClientMetrics ncm;

lfMenuFont.lfCharSet = (BYTE)GetTextCharsetInfo (dc, NULL, 0);
lfMenuFont.lfHeight  = ncm.lfMenuFont.lfHeight;
lfMenuFont.lfWeight  = ncm.lfMenuFont.lfWeight;
lfMenuFont.lfItalic  = ncm.lfMenuFont.lfItalic;

STRCPY_S(lfMenuFont.lfFaceName, LF_FACESIZE, ncm.lfMenuFont.lfFaceName);
The documentation for this class was generated from the following file:
  • XTPSystemHelpers.h


Toolkit Pro: CXTPNotifyConnection Class Reference

Classes | Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPNotifyConnection Class Reference

This class is used as implementation of Connection interface in a XTPNotification mechanism. More...

Inheritance diagram for CXTPNotifyConnection:
[legend]

Classes

class | CEmptySyncObject
This struct is derived from CSyncObject and should be used instead of CCriticalSection to improve performance and to provide compatibility. More...
struct | CONNECTION_DESCRIPTOR
This struct is used in the implementation of the class CXTPNotifyConnection to store connection between a Connection object, Notification code and the sink object. More...

Public Member Functions

CXTPNotifyConnection ()
Default object constructor.
virtual | ~CXTPNotifyConnection ()
Default object destructor.
XTP_CONNECTION_ID | Advise (XTP_NOTIFY_CODE dwNotifyCode, CXTPNotifySinkBase *pSink)
Establishes a connection between the connection object and a sink object.
void | Unadvise (XTP_CONNECTION_ID ConnectionID)
Terminate a connection between the connection object and a sink object.
void | RemoveAll ()
Remove All connections information.
BOOL | SendEvent (XTP_NOTIFY_CODE dwNotifyCode, WPARAM wParam, LPARAM lParam, DWORD dwFlags=0)
Send event with specified EventCode.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

int | FindConnection (XTP_CONNECTION_ID ConnectionID)
Find connection information in the m_arConnections array.
virtual CSyncObject * | GetDataLock ()
Get synchronization object to lock internal class data.

Protected Attributes

CArray< CONNECTION_DESCRIPTOR *, CONNECTION_DESCRIPTOR * > | m_arrConnections
store connections between a Connection object, Notification code and the sink object.
CArray< CONNECTION_DESCRIPTOR, CONNECTION_DESCRIPTOR & > | m_arrSendQueueCache
used in SendEvent method for safety reason
int | m_nSendQueueCacheSize
used in SendEvent method together with m_arrSendQueueCache.
CEmptySyncObject | m_emptyLocker
Pseudo-locker object.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

This class is used as implementation of Connection interface in a XTPNotification mechanism.

This mechanism consists of Connection object(s) and Sink object(s). The first are used to send notification messages and the second are used to receive these notification. Each notification has unique number (or EventCode or NotificationCode) for a given connection object or for the whole system. This depends on implementation. Using system unique NotificationCodes is a preferred way to avoid potential errors with intersected NotificationCodes.

See also
CXTPNotifySinkBase overview, CXTPNotifyConnection overview

Constructor & Destructor Documentation

◆ CXTPNotifyConnection()

CXTPNotifyConnection ( )

Default object constructor.

See also
~CXTPNotifyConnection()

◆ ~CXTPNotifyConnection()

virtual ~CXTPNotifyConnection ( )
virtual

Default object destructor.

See also
CXTPNotifyConnection()

Member Function Documentation

◆ Advise()

XTP_CONNECTION_ID Advise | ( | XTP_NOTIFY_CODE | dwNotifyCode,
 |  | CXTPNotifySinkBase * | pSink )

Establishes a connection between the connection object and a sink object.

Parameters
dwNotifyCode | EventCode of a Notification.
pSink | Pointer to the Sink object which will receive events with specified code.

Call this method to establish a connection with the event source and the sink object. pSink->OnEvent(...) method will be called if event with specified EventCode will occur. Use Unadvise() method with returned connection ID to terminate the connection call.

Returns
The unique connection ID used for Unadvise() method.
See also
CXTPNotifySinkBase overview, Unadvise() method.

◆ FindConnection()

int FindConnection ( XTP_CONNECTION_ID ConnectionID )
protected

Find connection information in the m_arConnections array.

Parameters
ConnectionID The unique connection ID.

Call this method to find connection description in the m_arConnections array using specified connection ID.

Returns
The zero-based index of connection description in the m_arConnections array that matches the requested ConnectionID; -1 if the it is not found.
See also
Advise method, CONNECTION_DESCRIPTOR

◆ GetDataLock()

virtual CSyncObject * GetDataLock ( )
protectedvirtual

Get synchronization object to lock internal class data.

This method is used as prototype for derived classes to support multi threaded clients calls. In base implementation pointer to an empty locker object is returned.

Returns
Pointer to the locker object.
See also
CCriticalSection, CSingleLock, CSyncObject.

Reimplemented in CXTPNotifyConnectionMT.

◆ RemoveAll()

void RemoveAll ( )

Remove All connections information.

Call this method to remove all connections added using Advise method.

See also
Advise method

◆ SendEvent()

BOOL SendEvent | ( | XTP_NOTIFY_CODE | dwNotifyCode,
 |  | WPARAM | wParam,
 |  | LPARAM | lParam,
 |  | DWORD | dwFlags = 0 )

Send event with specified EventCode.

Parameters
dwNotifyCode | EventCode of a Notification.
wParam | First parameter specific for this Notification.
lParam | Second parameter specific for this Notification.
dwFlags | Additional flags, default is 0. See XTPNotifyFlags.

Call this method to send event with specified EventCode to sinks which where advised to this EventCode using Advise method.

Returns
TRUE if event was sent to any client (if any client exists), FALSE otherwise.
See also
Advise(), XTPNotifyFlags.

◆ Unadvise()

void Unadvise ( XTP_CONNECTION_ID ConnectionID )

Terminate a connection between the connection object and a sink object.

Parameters
ConnectionID The unique connection ID previously returned in Advise() call.

Call this method to Terminate a connection with the event source and the sink object.

See also
Advise() method.
The documentation for this class was generated from the following file:
  • XTPNotifyConnection.h


Toolkit Pro: CXTPNotifyConnection::CEmptySyncObject Class Reference

  • CXTPNotifyConnection
  • CEmptySyncObject
Public Member Functions | List of all members
CXTPNotifyConnection::CEmptySyncObject Class Reference

This struct is derived from CSyncObject and should be used instead of CCriticalSection to improve performance and to provide compatibility. More...

Public Member Functions

CEmptySyncObject ()
Default object constructor.
virtual BOOL | Lock (DWORD dwTimeout=INFINITE)
Set object state as locked.
virtual BOOL | Unlock ()
Set object state as unlocked.
virtual BOOL | Unlock (LONG lCount, LPLONG lPrevCount=NULL)
Set object state as unlocked.

Detailed Description

This struct is derived from CSyncObject and should be used instead of CCriticalSection to improve performance and to provide compatibility.

It just provide CSyncObject interface with empty Lock and Unlock methods.

See also
CCriticalSection, CSingleLock, CSyncObject.

Member Function Documentation

◆ Lock()

virtual BOOL Lock ( DWORD dwTimeout = INFINITE )
virtual

Set object state as locked.

Parameters
dwTimeout Specifies the amount of time to wait for the synchronization object to be available (signaled)

Empty Lock method.

Returns
TRUE
See also
CCriticalSection::Lock, CSingleLock, CSyncObject.

◆ Unlock() [1/2]

virtual BOOL Unlock ( )
virtual

Set object state as unlocked.

Empty Unlock method.

Returns
TRUE
See also
CCriticalSection::Unlock, CSingleLock, CSyncObject.

◆ Unlock() [2/2]

virtual BOOL Unlock | ( | LONG | lCount,
 |  | LPLONG | lPrevCount = NULL )
 virtual

Set object state as unlocked.

Parameters
lCount | Number of accesses to release
lPrevCount | Points to a variable to receive the previous count of the synchronization object

Empty Unlock method.

Returns
TRUE
See also
CCriticalSection::Unlock, CSingleLock, CSyncObject.
The documentation for this class was generated from the following file:
  • XTPNotifyConnection.h


Toolkit Pro: CXTPNotifyConnection::CONNECTION_DESCRIPTOR Struct Reference

  • CXTPNotifyConnection
  • CONNECTION_DESCRIPTOR
Public Attributes | List of all members
CXTPNotifyConnection::CONNECTION_DESCRIPTOR Struct Reference

This struct is used in the implementation of the class CXTPNotifyConnection to store connection between a Connection object, Notification code and the sink object. More...

Public Attributes

XTP_NOTIFY_CODE | dwNotifyCode
The Notification code.
CXTPNotifySinkBase * pSink
The pointer to the sink object.
XTP_CONNECTION_ID | dwConnectionID
The unique connection ID used for Unadvise() method.

Detailed Description

This struct is used in the implementation of the class CXTPNotifyConnection to store connection between a Connection object, Notification code and the sink object.

See also
CXTPNotifyConnection overview, CXTPNotifySinkBase overview

Member Data Documentation

◆ pSink

CXTPNotifySinkBase* pSink

The pointer to the sink object.

(with InternalAddRef)

The documentation for this struct was generated from the following file:
  • XTPNotifyConnection.h


Toolkit Pro: CXTPNotifyConnectionMT Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPNotifyConnectionMT Class Reference

This class is used as thread-safety implementation of Connection interface in a XTPNotification mechanism. More...

Inheritance diagram for CXTPNotifyConnectionMT:
[legend]

Public Member Functions

CXTPNotifyConnectionMT ()
Default object constructor.
virtual | ~CXTPNotifyConnectionMT ()
Default object destructor.
BOOL | PostEvent (XTP_NOTIFY_CODE dwNotifyCode, WPARAM wParam, LPARAM lParam, DWORD dwFlags=0)
Post event with specified EventCode.
- Public Member Functions inherited from CXTPNotifyConnection
CXTPNotifyConnection ()
Default object constructor.
virtual | ~CXTPNotifyConnection ()
Default object destructor.
XTP_CONNECTION_ID | Advise (XTP_NOTIFY_CODE dwNotifyCode, CXTPNotifySinkBase *pSink)
Establishes a connection between the connection object and a sink object.
void | Unadvise (XTP_CONNECTION_ID ConnectionID)
Terminate a connection between the connection object and a sink object.
void | RemoveAll ()
Remove All connections information.
BOOL | SendEvent (XTP_NOTIFY_CODE dwNotifyCode, WPARAM wParam, LPARAM lParam, DWORD dwFlags=0)
Send event with specified EventCode.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

virtual CSyncObject * | GetDataLock ()
Get synchronization object to lock internal class data.
- Protected Member Functions inherited from CXTPNotifyConnection
int | FindConnection (XTP_CONNECTION_ID ConnectionID)
Find connection information in the m_arConnections array.

Protected Attributes

CCriticalSection | m_DataLockerCS
Data locker object.
- Protected Attributes inherited from CXTPNotifyConnection
CArray< CONNECTION_DESCRIPTOR *, CONNECTION_DESCRIPTOR * > | m_arrConnections
store connections between a Connection object, Notification code and the sink object.
CArray< CONNECTION_DESCRIPTOR, CONNECTION_DESCRIPTOR & > | m_arrSendQueueCache
used in SendEvent method for safety reason
int | m_nSendQueueCacheSize
used in SendEvent method together with m_arrSendQueueCache.
CEmptySyncObject | m_emptyLocker
Pseudo-locker object.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

This class is used as thread-safety implementation of Connection interface in a XTPNotification mechanism.

This mechanism consists of Connection object(s) and Sink object(s). The first are used to send notification messages and the second are used to receive these notification. Each notification has unique number (or EventCode or NotificationCode) for a given connection object or for the whole system. This depends on implementation. Using system unique NotificationCodes is a preferred way to avoid potential errors with intersected NotificationCodes.

See also
CXTPNotifySinkBase, CXTPNotifyConnection

Member Function Documentation

◆ GetDataLock()

virtual CSyncObject * GetDataLock ( )
protectedvirtual

Get synchronization object to lock internal class data.

This method is used to support multi threaded clients calls..

Returns
Pointer to the locker object (CCriticalSection).
See also
CCriticalSection, CSingleLock, CSyncObject.

Reimplemented from CXTPNotifyConnection.

◆ PostEvent()

BOOL PostEvent | ( | XTP_NOTIFY_CODE | dwNotifyCode,
 |  | WPARAM | wParam,
 |  | LPARAM | lParam,
 |  | DWORD | dwFlags = 0 )

Post event with specified EventCode.

Parameters
dwNotifyCode | EventCode of a Notification.
wParam | First parameter specific for this Notification.
lParam | Second parameter specific for this Notification.
dwFlags | Additional flags, default is 0. See XTPNotifyFlags.

Call this method to post event with specified EventCode to sinks which where advised to this EventCode using Advise method. Event will be posted only to the sinks which implementations support Post event possibility, like standard multithreaded sinks. The sink implementation is responsible for the Post mechanism. For posted event the appropriate bit of dwFlags is set automatically and SendEvent is called.

Returns
TRUE if event was sent to any client (if any client exists), FALSE otherwise.
See also
Advise(), SendEvent(), XTPNotifyFlags
The documentation for this class was generated from the following file:
  • XTPNotifyConnection.h


Toolkit Pro: CXTPNotifySinkBase Class Reference

Classes | Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPNotifySinkBase Class Referenceabstract

This class is used as implementation of Sink interface in a XTPNotification mechanism. More...

Inheritance diagram for CXTPNotifySinkBase:
[legend]

Classes

struct ADVISE_DESCRIPTOR
This struct is used in to store connection between a Connection object(s), Notification code and the sink object. More...

Public Member Functions

CXTPNotifySinkBase ()
Default object constructor.
virtual void | OnEvent (XTP_NOTIFY_CODE dwNotifyCode, WPARAM wParam, LPARAM lParam, DWORD dwFlags)=0
Event with specified dwNotifyCode was occurred.
void | UnadviseAll ()
Terminate all connections between the connection object(s) and this sink object.
void | Unadvise (XTP_CONNECTION_ID id)
Terminate a connection between the connection object and this sink object.

Protected Member Functions

virtual | ~CXTPNotifySinkBase ()
Default object destructor.
XTP_CONNECTION_ID | Advise (CXTPNotifyConnection *pConnection, XTP_NOTIFY_CODE dwNotifyCode)
Establishes a connection between the connection object and a sink object.

Protected Attributes

CMap< XTP_CONNECTION_ID, XTP_CONNECTION_ID &, ADVISE_DESCRIPTOR, ADVISE_DESCRIPTOR & > m_mapAdviseData
store connections between a Connection objects, Notification code and this sink object.

Detailed Description

This class is used as implementation of Sink interface in a XTPNotification mechanism.

This mechanism consists of Connection object(s) and Sink object(s). The first are used to send notification messages and the second are used to receive these notification. Each notification has unique number (or dwNotifyCode or NotificationCode) for a given connection object or for the whole system. This depends on implementation. Using system unique NotificationCodes is a preferred way to avoid potential errors with intersected NotificationCodes.

See also
CXTPNotifySinkBase overview, DECLARE_XTPSINK macro, CXTPNotifyConnection overview

Constructor & Destructor Documentation

◆ CXTPNotifySinkBase()

CXTPNotifySinkBase ( )

Default object constructor.

See also
~CXTPNotifySinkBase()

◆ ~CXTPNotifySinkBase()

virtual ~CXTPNotifySinkBase ( )
protectedvirtual

Default object destructor.

See also
CXTPNotifySinkBase()

Member Function Documentation

◆ Advise()

XTP_CONNECTION_ID Advise | ( | CXTPNotifyConnection * | pConnection,
 |  | XTP_NOTIFY_CODE | dwNotifyCode )
 protected

Establishes a connection between the connection object and a sink object.

Parameters
pConnection | Pointer to the Connection object.
dwNotifyCode | Notify Code of a Notification.

Call this method to establish a connection with the event source and the sink object. OnEvent(...) method will be called if event with specified dwNotifyCode will occur. Use Unadvise() method with returned connection ID to terminate the connection call.

Returns
The unique connection ID used for Unadvise() method.
See also
CXTPNotifySinkBase, Unadvise method, GetParam method, CXTPNotifyConnection, CXTPNotifyConnection::Advise method

◆ OnEvent()

virtual void OnEvent | ( | XTP_NOTIFY_CODE | dwNotifyCode,
 |  | WPARAM | wParam,
 |  | LPARAM | lParam,
 |  | DWORD | dwFlags )
 pure virtual

Event with specified dwNotifyCode was occurred.

Parameters
dwNotifyCode | EventCode of a Notification.
wParam | First parameter specific for this Notification.
lParam | Second parameter specific for this Notification.
dwFlags | Additional flags. See XTPNotifyFlags.

This method is called by Connection object to notify advice sink that event with specified EventCode was occurred. It should be override in your derived class to receive notification(s).

See also
DECLARE_XTPSINK macro, DECLARE_XTPSINK_MT macro, CXTPNotifyConnection, CXTPNotifyConnection::Advise method

Implemented in CXTPCalendarResourcesNf.

◆ Unadvise()

void Unadvise ( XTP_CONNECTION_ID id )

Terminate a connection between the connection object and this sink object.

Parameters
id The unique connection ID previously returned in Advise() call.

Call this method to Terminate a connection with the event source and this sink object.

See also
CXTPNotifySinkBase, UnadviseAll method, Advise method, CXTPNotifyConnection, CXTPNotifyConnection::Unadvise method

◆ UnadviseAll()

void UnadviseAll ( )

Terminate all connections between the connection object(s) and this sink object.

Call this method to Terminate all connections with the event source(s) and this sink object.

See also
CXTPNotifySinkBase, UnadviseAll method, Advise method, CXTPNotifyConnection, CXTPNotifyConnection::Unadvise method
The documentation for this class was generated from the following file:
  • XTPNotifyConnection.h


Toolkit Pro: CXTPNotifySinkBase::ADVISE_DESCRIPTOR Struct Reference

  • CXTPNotifySinkBase
  • ADVISE_DESCRIPTOR
Public Attributes | List of all members
CXTPNotifySinkBase::ADVISE_DESCRIPTOR Struct Reference

This struct is used in to store connection between a Connection object(s), Notification code and the sink object. More...

Public Attributes

XTP_NOTIFY_CODE | dwNotifyCode
The Notification code.
CXTPNotifyConnection * pConnection
The pointer to the connection object.
XTP_CONNECTION_ID | dwConnectionID
Original Connection ID returned by pConnection->Advise() method.

Detailed Description

This struct is used in to store connection between a Connection object(s), Notification code and the sink object.

See also
CXTPNotifySinkBase overview,

Member Data Documentation

◆ pConnection

CXTPNotifyConnection* pConnection

The pointer to the connection object.

(with InternalAddRef)

The documentation for this struct was generated from the following file:
  • XTPNotifyConnection.h


Toolkit Pro: CXTPObservable< Owner, Observer > Class Template Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPObservable< Owner, Observer > Class Template Reference

Provides a basic implementation of the Observable design pattern. More...

Inheritance diagram for CXTPObservable< Owner, Observer >:
[legend]

Public Member Functions

void | Subscribe (Observer *pObserver, CXTPSubscriptionList< Owner, Observer > *pSubcriptionList=NULL)
Subscribes a unique observer for events.
void | Unsubscribe (Observer *pObserver)
Unsubscribes an observer from events.
void | Notify (void(Observer::*method)(Owner *))
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(Observer::*method)(Owner *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
template<class T , class O >
void | NotifyDynamic (void(T::*method)(O *))
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
template<class T , class O >
void | NotifyDynamicReversed (void(T::*method)(O *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
template<class A1 >
void | Notify (void(Observer::*method)(Owner *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
template<class A1 >
void | NotifyReversed (void(Observer::*method)(Owner *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
template<class T , class O , class A1 >
void | NotifyDynamic (void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
template<class T , class O , class A1 >
void | NotifyDynamicReversed (void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
template<class A1 , class A2 >
void | Notify (void(Observer::*method)(Owner *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
template<class A1 , class A2 >
void | NotifyReversed (void(Observer::*method)(Owner *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
template<class T , class O , class A1 , class A2 >
void | NotifyDynamic (void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
template<class T , class O , class A1 , class A2 >
void | NotifyDynamicReversed (void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
template<class A1 , class A2 , class A3 >
void | Notify (void(Observer::*method)(Owner *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
template<class A1 , class A2 , class A3 >
void | NotifyReversed (void(Observer::*method)(Owner *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
template<class T , class O , class A1 , class A2 , class A3 >
void | NotifyDynamic (void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
template<class T , class O , class A1 , class A2 , class A3 >
void | NotifyDynamicReversed (void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.

Protected Member Functions

CXTPObservable ()
Constructs an observable object.
~CXTPObservable ()
Handles observable object destruction.

Detailed Description

template<class Owner, class Observer>
class CXTPObservable< Owner, Observer >

Provides a basic implementation of the Observable design pattern.

Parameters
Owner | Type of the derived owner class.
Observer | Type of an observer object.

Member Function Documentation

◆ Notify() [1/4]

template<class Owner , class Observer >
void Notify ( void(Observer::* method )(Owner *) )
inline

Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.

Parameters
method A pointer to the observer's method to be called for each subscribed observer.

◆ Notify() [2/4]

template<class Owner , class Observer >
template<class A1 >
void Notify | ( | void(Observer::* | method )(Owner *, A1),
 |  | A1 | arg1 )
 inline

Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.

Parameters
method | A pointer to the observer's method to be called for each subscribed observer.
arg1 | The first argument to be passed to each call of the specified method for each subscribed observer.

◆ Notify() [3/4]

template<class Owner , class Observer >
template<class A1 , class A2 >
void Notify | ( | void(Observer::* | method )(Owner *, A1, A2),
 |  | A1 | arg1,
 |  | A2 | arg2 )
 inline

Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.

Parameters
method | A pointer to the observer's method to be called for each subscribed observer.
arg1 | The first argument to be passed to each call of the specified method for each subscribed observer.
arg2 | The second argument to be passed to each call of the specified method for each subscribed observer.

◆ Notify() [4/4]

template<class Owner , class Observer >
template<class A1 , class A2 , class A3 >
void Notify | ( | void(Observer::* | method )(Owner *, A1, A2, A3),
 |  | A1 | arg1,
 |  | A2 | arg2,
 |  | A3 | arg3 )
 inline

Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.

Parameters
method | A pointer to the observer's method to be called for each subscribed observer.
arg1 | The first argument to be passed to each call of the specified method for each subscribed observer.
arg2 | The second argument to be passed to each call of the specified method for each subscribed observer.
arg3 | The third argument to be passed to each call of the specified method for each subscribed observer.

◆ NotifyDynamic() [1/4]

template<class Owner , class Observer >
template<class T , class O >
void NotifyDynamic ( void(T::* method )(O *) )
inline

Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.

Parameters
method A pointer to the observer's method to be called for each subscribed observer.

◆ NotifyDynamic() [2/4]

template<class Owner , class Observer >
template<class T , class O , class A1 >
void NotifyDynamic | ( | void(T::* | method )(O *, A1),
 |  | A1 | arg1 )
 inline

Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.

Parameters
method | A pointer to the observer's method to be called for each subscribed observer.
arg1 | The first argument to be passed to each call of the specified method for each subscribed observer.

◆ NotifyDynamic() [3/4]

template<class Owner , class Observer >
template<class T , class O , class A1 , class A2 >
void NotifyDynamic | ( | void(T::* | method )(O *, A1, A2),
 |  | A1 | arg1,
 |  | A2 | arg2 )
 inline

Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.

Parameters
method | A pointer to the observer's method to be called for each subscribed observer.
arg1 | The first argument to be passed to each call of the specified method for each subscribed observer.
arg2 | The second argument to be passed to each call of the specified method for each subscribed observer.

◆ NotifyDynamic() [4/4]

template<class Owner , class Observer >
template<class T , class O , class A1 , class A2 , class A3 >
void NotifyDynamic | ( | void(T::* | method )(O *, A1, A2, A3),
 |  | A1 | arg1,
 |  | A2 | arg2,
 |  | A3 | arg3 )
 inline

Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.

Parameters
method | A pointer to the observer's method to be called for each subscribed observer.
arg1 | The first argument to be passed to each call of the specified method for each subscribed observer.
arg2 | The second argument to be passed to each call of the specified method for each subscribed observer.
arg3 | The third argument to be passed to each call of the specified method for each subscribed observer.

◆ NotifyDynamicReversed() [1/4]

template<class Owner , class Observer >
template<class T , class O >
void NotifyDynamicReversed ( void(T::* method )(O *) )
inline

Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.

Parameters
method A pointer to the observer's method to be called for each subscribed observer.

◆ NotifyDynamicReversed() [2/4]

template<class Owner , class Observer >
template<class T , class O , class A1 >
void NotifyDynamicReversed | ( | void(T::* | method )(O *, A1),
 |  | A1 | arg1 )
 inline

Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.

Parameters
method | A pointer to the observer's method to be called for each subscribed observer.
arg1 | The first argument to be passed to each call of the specified method for each subscribed observer.

◆ NotifyDynamicReversed() [3/4]

template<class Owner , class Observer >
template<class T , class O , class A1 , class A2 >
void NotifyDynamicReversed | ( | void(T::* | method )(O *, A1, A2),
 |  | A1 | arg1,
 |  | A2 | arg2 )
 inline

Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.

Parameters
method | A pointer to the observer's method to be called for each subscribed observer.
arg1 | The first argument to be passed to each call of the specified method for each subscribed observer.
arg2 | The second argument to be passed to each call of the specified method for each subscribed observer.

◆ NotifyDynamicReversed() [4/4]

template<class Owner , class Observer >
template<class T , class O , class A1 , class A2 , class A3 >
void NotifyDynamicReversed | ( | void(T::* | method )(O *, A1, A2, A3),
 |  | A1 | arg1,
 |  | A2 | arg2,
 |  | A3 | arg3 )
 inline

Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.

Parameters
method | A pointer to the observer's method to be called for each subscribed observer.
arg1 | The first argument to be passed to each call of the specified method for each subscribed observer.
arg2 | The second argument to be passed to each call of the specified method for each subscribed observer.
arg3 | The third argument to be passed to each call of the specified method for each subscribed observer.

◆ NotifyReversed() [1/4]

template<class Owner , class Observer >
void NotifyReversed ( void(Observer::* method )(Owner *) )
inline

Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.

Parameters
method A pointer to the observer's method to be called for each subscribed observer.

◆ NotifyReversed() [2/4]

template<class Owner , class Observer >
template<class A1 >
void NotifyReversed | ( | void(Observer::* | method )(Owner *, A1),
 |  | A1 | arg1 )
 inline

Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.

Parameters
method | A pointer to the observer's method to be called for each subscribed observer.
arg1 | The first argument to be passed to each call of the specified method for each subscribed observer.

◆ NotifyReversed() [3/4]

template<class Owner , class Observer >
template<class A1 , class A2 >
void NotifyReversed | ( | void(Observer::* | method )(Owner *, A1, A2),
 |  | A1 | arg1,
 |  | A2 | arg2 )
 inline

Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.

Parameters
method | A pointer to the observer's method to be called for each subscribed observer.
arg1 | The first argument to be passed to each call of the specified method for each subscribed observer.
arg2 | The second argument to be passed to each call of the specified method for each subscribed observer.

◆ NotifyReversed() [4/4]

template<class Owner , class Observer >
template<class A1 , class A2 , class A3 >
void NotifyReversed | ( | void(Observer::* | method )(Owner *, A1, A2, A3),
 |  | A1 | arg1,
 |  | A2 | arg2,
 |  | A3 | arg3 )
 inline

Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.

Parameters
method | A pointer to the observer's method to be called for each subscribed observer.
arg1 | The first argument to be passed to each call of the specified method for each subscribed observer.
arg2 | The second argument to be passed to each call of the specified method for each subscribed observer.
arg3 | The third argument to be passed to each call of the specified method for each subscribed observer.

◆ Subscribe()

template<class Owner , class Observer >
AFX_INLINE void Subscribe | ( | Observer * | pObserver,
 |  | CXTPSubscriptionList< Owner, Observer > * | pSubcriptionList = NULL )

Subscribes a unique observer for events.

Parameters
pObserver | A pointer to an observer object to be subscribed to events.
pSubcriptionList | An optional pointer to the subscriber list. If provided, then the observable object pointer is added to the subscription list.

◆ Unsubscribe()

template<class Owner , class Observer >
AFX_INLINE void Unsubscribe ( Observer * pObserver )

Unsubscribes an observer from events.

Parameters
pObserver A pointer to the observer object to unsubscribe from events.

If an observer has been previously subscribed with the provided subscription list pointer, then the subscription list is notified about observer unsubscription for removing the observable object from the list.

See also
CXTPObservable::Subscribe
The documentation for this class was generated from the following file:
  • XTPSystemHelpers.h


Toolkit Pro: CXTPOpenGLListPool Class Reference

Public Member Functions | List of all members
CXTPOpenGLListPool Class Reference

Provides a convenient API around an OpenGL list for reliable list management. More...

Inheritance diagram for CXTPOpenGLListPool:
[legend]

Public Member Functions

GLuint | AllocateList (GLenum mode)
Allocates an OpenGL list.
void | CommitList ()
Commits a list that has been allocated during a previous call to AllocateList.
void | ReclaimList (GLuint id)
Reclaims a previously allocated and committed OpenGL list and releases all associated resources.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPSingleton< CXTPOpenGLListPool >
static CXTPOpenGLListPool &AFX_CDECL Instance ()
Obtains encapsulated singleton instance reference.

Detailed Description

Provides a convenient API around an OpenGL list for reliable list management.

Member Function Documentation

◆ AllocateList()

GLuint AllocateList ( GLenum mode )

Allocates an OpenGL list.

Once allocated, the list must be committed using the CommitList method after being populated.

Parameters
mode List compilation flags, can be either GL_COMPILE or GL_COMPILE_AND_EXECUTE.
Returns
The OpenGL list identifier if successful, otherwise 0.
See also
CommitList, ReclaimList

◆ CommitList()

void CommitList ( )

Commits a list that has been allocated during a previous call to AllocateList.

See also
AllocateList

◆ ReclaimList()

void ReclaimList ( GLuint id )

Reclaims a previously allocated and committed OpenGL list and releases all associated resources.

Parameters
id List ID to reclaim.
See also
AllocateList, CommitList
The documentation for this class was generated from the following file:
  • XTPOpenGLListPool.h


Toolkit Pro: CXTPOpenGLUtils Class Reference

Static Public Member Functions | List of all members
CXTPOpenGLUtils Class Reference

Provides a set of common OpenGL utilities. More...

Static Public Member Functions

static void | Vertex (const CXTPPoint3d &ptVertex)
Sets a vertex from point coordinates.
static void | Vertex (const CXTPPoint3d &ptVertex, const CXTPPoint3d &vNormal)
Sets a vertex and its normal from point coordinates.
static void | Rotate (double dYaw, double dPitch, double dRoll)
Rotates the active matrix using Euler angles.
static BOOL | Project (const CXTPPoint3d &pt3d, CPoint &pt2d, double *pdWinZ=NULL)
Projects 3D space coordinates between the near and far planes to 2D space coordinates of the current viewport.
static BOOL | Unproject (const CPoint &pt2d, CXTPPoint3d &pt3d, double dWinZ=0.)
Unprojects 2D space coordinates of the current viewport to 3D space coordinates between the near and far planes.
static void | MultiplyByMatrix (CXTPPoint3d &v, const CXTPMatrix< double > &matrix)
Multiplies a vector by a specified matrix.
static void | MultiplyByMatrix (CXTPPoint3d &v, GLenum name)
Multiplies a vector by a specified OpenGL matrix.
static CXTPPoint3d | ComputeTriangleNormal (const CXTPPoint3d &vA, const CXTPPoint3d &vB, const CXTPPoint3d &vC, bool ccw=false)
Computes a normal for a specified triangle.

Detailed Description

Provides a set of common OpenGL utilities.

Member Function Documentation

◆ ComputeTriangleNormal()

static CXTPPoint3d ComputeTriangleNormal | ( | const CXTPPoint3d & | vA,
 |  | const CXTPPoint3d & | vB,
 |  | const CXTPPoint3d & | vC,
 |  | bool | ccw = false )
 static

Computes a normal for a specified triangle.

Parameters
vA | 1st triangle point.
vB | 2nd triangle point.
vC | 3rd triangle point.
ccw | Determines which side of the triangle that the normal vector will be directed from. By default, triangle points are assumed to be in clockwise order which determines the front face of the triangle for which the normal is computed. In order to reverse a normal vector, this value has to be false which means counter-clockwise vertex unwinding.
Returns
Computed normal vector.

◆ MultiplyByMatrix() [1/2]

static void MultiplyByMatrix | ( | CXTPPoint3d & | v,
 |  | const CXTPMatrix< double > & | matrix )
 static

Multiplies a vector by a specified matrix.

Parameters
v | Vector to multiply by the matrix.
matrix | Matrix by which the vector is multiplied.

◆ MultiplyByMatrix() [2/2]

static void MultiplyByMatrix | ( | CXTPPoint3d & | v,
 |  | GLenum | name )
 static

Multiplies a vector by a specified OpenGL matrix.

Parameters
v | Vector to multiply by the OpenGL matrix.
name | Name of an OpenGL matrix by which the vector is multiplied.

◆ Project()

static BOOL Project | ( | const CXTPPoint3d & | pt3d,
 |  | CPoint & | pt2d,
 |  | double * | pdWinZ = NULL )
 static

Projects 3D space coordinates between the near and far planes to 2D space coordinates of the current viewport.

Parameters
pt3d | Reference to a CPoint object containing the 3D space coordinates between the near and far planes.
pt2d | Reference to a CPoint object to receive the resulting 2D space point coordinates of the current viewport.
pdWinZ | Z-plane coordinate of the specified 3D point (i.e. the position between the near plane (0) and the far plane (1)); can be NULL.
Returns
TRUE if the coordinates are mapped successfully.
See also
Unproject

◆ Rotate()

static void Rotate | ( | double | dYaw,
 |  | double | dPitch,
 |  | double | dRoll )
 static

Rotates the active matrix using Euler angles.

Parameters
dYaw | Yaw angle value in degrees.
dPitch | Pitch angle value in degrees.
dRoll | Roll angle value in degrees.

◆ Unproject()

static BOOL Unproject | ( | const CPoint & | pt2d,
 |  | CXTPPoint3d & | pt3d,
 |  | double | dWinZ = 0. )
 static

Unprojects 2D space coordinates of the current viewport to 3D space coordinates between the near and far planes.

Parameters
pt2d | Reference to a CPoint object containing the 2D space coordinates of the current viewport.
pt3d | Reference to a CPoint object to receive the resulting 3D space coordinates between the near and far planes.
dWinZ | Z-plane coordinate of the specified 3D point (i.e. the position between the near plane (0) and the far plane (1)).
Returns
TRUE if the coordinates are mapped successfully.
See also
Project

◆ Vertex() [1/2]

static void Vertex ( const CXTPPoint3d & ptVertex )
static

Sets a vertex from point coordinates.

Parameters
ptVertex Vertex coordinates.

◆ Vertex() [2/2]

static void Vertex | ( | const CXTPPoint3d & | ptVertex,
 |  | const CXTPPoint3d & | vNormal )
 static

Sets a vertex and its normal from point coordinates.

Parameters
ptVertex | Vertex coordinates.
vNormal | Normal coordinates.
The documentation for this class was generated from the following file:
  • XTPOpenGLUtils.h


Toolkit Pro: CXTPOriginalControls Class Reference

Public Member Functions | List of all members
CXTPOriginalControls Class Reference

CXTPOriginalControls object. More...

Inheritance diagram for CXTPOriginalControls:
[legend]

Public Member Functions

CXTPOriginalControls ()
Constructs a CXTPOriginalControls object.
- Public Member Functions inherited from CXTPControls
CXTPControls ()
Internal helper structure.
virtual | ~CXTPControls ()
Destroys a CXTPControls object, handles cleanup and deallocation.
CXTPControl * | GetAt (int nIndex) const
Call this member to return the control at the specified index.
int | CommandToIndex (int nIDFind) const
This member function returns the index of the first control, starting at position 0, whose command ID matches nIDFind.
CXTPControl * | Add (CXTPControl *pControl, int nId, LPCTSTR lpszParameter=NULL, int nBefore=-1, BOOL bTemporary=FALSE)
Call this member to add a new control.
CXTPControl * | Add (XTPControlType controlType, int nId, LPCTSTR lpszParameter=NULL, int nBefore=-1, BOOL bTemporary=FALSE)
Call this member to add a new control.
CXTPControl * | Add (CXTPControl *pControl)
Call this member to add a new control.
CXTPControl * | InsertAt (CXTPControl *pControl, int nBefore)
Call this member to insert a new control.
CXTPControl * | AddMenuItem (CMenu *pMenu, int nIndex)
Call this member to add a new control.
virtual void | Remove (CXTPControl *pControl)
Call this member to remove a control.
void | Remove (int nIndex)
Call this member to remove a control.
void | RemoveAll ()
Call this member to remove all controls.
int | GetCount () const
Call this member to get the count of the controls.
CXTPControl * | FindControl (int nId) const
Call this member to find the specified control.
CXTPControl * | FindControl (XTPControlType type, int nId, BOOL bVisible, BOOL bRecursive) const
Call this member to find the specified control.
BOOL | LoadMenu (CMenu *pMenu)
Call this member to convert menu items to command bar controls.
CXTPControl * | GetFirst () const
Call this member to retrieve the first control.
void | GetNext (CXTPControl *&pControl) const
Finds the next control in the given direction.
long | GetNext (long nIndex, int nDirection=+1, BOOL bKeyboard=TRUE, BOOL bSkipTemporary=FALSE, BOOL bSkipCollapsed=TRUE) const
Finds the next control in the given direction.
CXTPControl * | HitTest (CPoint point) const
This member function determines which control, if any, is at a specified point.
CXTPControl * | SetControlType (CXTPControl *pControl, XTPControlType type)
Call this member to change the type of the control.
CXTPControl * | SetControlType (int nIndex, XTPControlType type)
Call this member to change the type of the control.
CXTPControl * | AddClone (CXTPControl *pClone, int nBefore=-1, BOOL bRecursive=FALSE)
Call this member to add a copy of a control.
CSize | CalcDynamicSize (CDC *pDC, int nLength, DWORD dwMode, const CRect &rcBorder, int nWidth=0)
This method is called internally to reposition controls and determine their size.
CSize | CalcPopupSize (CDC *pDC, int nLength, int nWidth, const CRect &rcBorder)
This method is called internally to reposition controls and determine their size for a pop-up bar.
int | GetVisibleCount (BOOL bIgnoreWrap=FALSE) const
Call this member to get the number of visible controls.
CXTPControl * | GetVisibleAt (int nIndex, BOOL bIgnoreWraps=FALSE) const
Finds a specified control by its ID.
void | SetCommandBars (CXTPCommandBars *pCommandBars)
Call this member to attach the specified command bars object.
CXTPControls * | Duplicate (BOOL bRecursive=FALSE)
Makes a copy of all controls.
virtual void | Copy (CXTPControls *pControls, BOOL bRecursive=FALSE)
This method is called to copy the control.
CXTPCommandBars * | GetCommandBars () const
Retrieves the parent command bars object.
void | MoveBefore (CXTPControl *pControl, int nBefore)
Moves the control to a specified position.
void | SetParent (CXTPCommandBar *pParent)
Attaches the parent command bar.
void | CreateOriginalControls ()
Creates the original controls set.
void | ClearOriginalControls ()
Removes the original controls set.
CXTPOriginalControls * | GetOriginalControls () const
Retrieves the original controls set.
void | SetOriginalControls (CXTPOriginalControls *pControls)
Call this method to assign original controls.
BOOL | Compare (const CXTPControls *pControls)
Call this member to compare the controls.
BOOL | IsChanged () const
Returns the changed status flag of the control.
virtual void | DoPropExchange (CXTPPropExchange *pPX)
Either reads this object from or writes this object to an archive.
virtual BOOL | ShouldSerializeControl (CXTPControl *pControl)
Call this method to check if the control has been changed and must be saved.
CXTPCommandBar * | GetParent () const
Call this member to get the parent command bar.
BOOL | IsOriginalControls () const
Determines if all controls in the collection are original (i.e.
void | Sort ()
Sorts the commands list.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Member Functions inherited from CXTPControls
virtual void | OnControlAdded (CXTPControl *pControl)
This method is called when a control is added to the collection.
virtual void | OnControlRemoved (CXTPControl *pControl)
This method is called when a control is removed from the collection.
virtual BOOL | OnControlRemoving (CXTPControl *pControl)
This method is called when a control is about to be removed from the collection.
- Protected Attributes inherited from CXTPControls
CXTPCommandBar * | m_pParent
Parent Command Bar.
CArray< CXTPControl *, CXTPControl * > | m_arrControls
Collection of controls.
CXTPCommandBars * | m_pCommandBars
Parent Command Bars.
CXTPOriginalControls * | m_pOriginalControls
Original controls collection.
BOOL | m_bOriginalControls
TRUE if all controls are original and unmodified.

Detailed Description

CXTPOriginalControls object.

The documentation for this class was generated from the following file:
  • XTPControls.h


Toolkit Pro: CXTPPageScroller Class Reference

Public Member Functions | List of all members
CXTPPageScroller Class Reference

CXTPPageScroller is a CWnd derived class. More...

Public Member Functions

CXTPPageScroller ()
Constructs a CXTPPageScroller object.
virtual | ~CXTPPageScroller ()
Destroys a CXTPPageScroller object, handles cleanup and deallocation.
virtual BOOL | Create (DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID)
This member function creates a pager child window and attaches it to this CWnd object.
void | SetChild (HWND hwndChild)
This member function sets the contained window for the pager control.
void | RecalcSize ()
This member function forces the pager control to recalculate the size of the contained window.
void | ForwardMouse (BOOL bForward)
This member function enables/disables mouse forwarding for the pager control.
COLORREF | SetBkColor (COLORREF clr)
This member function sets the current background color for the pager control.
COLORREF | GetBkColor ()
This member function retrieves the current background color for the pager control.
int | SetBorder (int iBorder)
This member function sets the current border size for the pager control.
int | GetBorder ()
This member function retrieves the current border size for the pager control.
void | SetPos (int iPos)
This member function sets the scroll position for the pager control.
int | GetPos ()
This member function retrieves the current scroll position of the pager control.
int | SetButtonSize (int iSize)
This member function sets the current button size for the pager control.
int | GetButtonSize ()
This member function retrieves the current button size for the pager control.
DWORD | GetButtonState (int iButton)
This member function retrieves the state of the specified button in a pager control.
void | GetDropTarget (IDropTarget **ppdt)
This member function retrieves a pager control's IDropTarget interface pointer.

Detailed Description

CXTPPageScroller is a CWnd derived class.

Use CXTPPageScroller to define a display area for a window that does not have enough display area to show all of its content.

The page scroller control creates a window container that provides arrows to extend over the edges of the display area. If the window is larger than the display area, then the arrows are attached to the edges of the window, allowing it to be scrolled within the display area. Scrolling is supported in either a horizontal or vertical direction.

See ShortcutList and PageScroller examples.

Member Function Documentation

◆ Create()

virtual BOOL Create | ( | DWORD | dwStyle,
 |  | const RECT & | rect,
 |  | CWnd * | pParentWnd,
 |  | UINT | nID )
 virtual

This member function creates a pager child window and attaches it to this CWnd object.

Parameters
dwStyle | Specifies the window style attributes. See the Remarks section for a list of styles to use.
rect | The size and position of the window, in client coordinates of 'pParentWnd'.
pParentWnd | The parent window.
nID | The ID of the child window.
Returns
Nonzero if successful, otherwise zero.

Styles to be added or removed can be combined by using the bitwise OR (|) operator. It can be one or more of the following:

PGS_AUTOSCROLL: The pager control will scroll when the user hovers the mouse over one of the scroll buttons. PGS_DRAGNDROP: The contained window can be a drag-and-drop target. The pager control will automatically scroll if an item is dragged from outside the pager over one of the scroll buttons. PGS_HORZ: Creates a pager control that can be scrolled horizontally. This style and the PGS_VERT style are mutually exclusive and cannot be combined. PGS_VERT: Creates a pager control that can be scrolled vertically. This is the default direction; no direction style is specified. This style and the PGS_HORZ style are mutually exclusive and cannot be combined.

◆ ForwardMouse()

void ForwardMouse ( BOOL bForward )

This member function enables/disables mouse forwarding for the pager control.

When mouse forwarding is enabled, the pager control forwards WM_MOUSEMOVE messages to the contained window.

Parameters
bForward A BOOL value that determines if mouse forwarding is enabled or disabled. If this value is nonzero, then mouse forwarding is enabled. If this value is zero, then mouse forwarding is disabled.

◆ GetBkColor()

COLORREF GetBkColor ( )

This member function retrieves the current background color for the pager control.

Returns
A COLORREF value that contains the current background color.

◆ GetBorder()

int GetBorder ( )

This member function retrieves the current border size for the pager control.

Returns
An integer value that contains the current border size in pixels.

◆ GetButtonSize()

int GetButtonSize ( )

This member function retrieves the current button size for the pager control.

Returns
An integer value that contains the current button size in pixels.

◆ GetButtonState()

DWORD GetButtonState ( int iButton )

This member function retrieves the state of the specified button in a pager control.

Parameters
iButton Indicates which button to retrieve the state for. See the description for 'iButton' in PGM_GETBUTTONSTATE for a list of possible values.
Returns
The state of the button specified in 'iButton'. See the return value description in PGM_GETBUTTONSTATE for a list of possible values.

◆ GetDropTarget()

void GetDropTarget ( IDropTarget ** ppdt )

This member function retrieves a pager control's IDropTarget interface pointer.

Parameters
ppdt Address of an IDropTarget pointer that receives the interface pointer. It is the caller's responsibility to call Release on this pointer when it is no longer needed.

◆ GetPos()

int GetPos ( )

This member function retrieves the current scroll position of the pager control.

Returns
An integer value that contains the current scroll position in pixels.

◆ RecalcSize()

void RecalcSize ( )

This member function forces the pager control to recalculate the size of the contained window.

Using this command will result in a PGN_CALCSIZE notification being sent.

◆ SetBkColor()

COLORREF SetBkColor ( COLORREF clr )

This member function sets the current background color for the pager control.

Parameters
clr A COLORREF value that contains the new background color of the pager control.
Returns
A COLORREF value that contains the previous background color.

◆ SetBorder()

int SetBorder ( int iBorder )

This member function sets the current border size for the pager control.

Parameters
iBorder New size of the border, in pixels. This value should not be larger than the pager button or less than zero. If 'iBorder' is too large, the border will be drawn the same size as the button. If 'iBorder' is negative, the border size will be set to zero.
Returns
An integer value that contains the previous border size in pixels.

◆ SetButtonSize()

int SetButtonSize ( int iSize )

This member function sets the current button size for the pager control.

Parameters
iSize Integer value that contains the new button size in pixels.
Returns
An integer value that contains the previous button size in pixels.

◆ SetChild()

void SetChild ( HWND hwndChild )

This member function sets the contained window for the pager control.

This command will not change the parent of the contained window. It only assigns a window handle to the pager control for scrolling. In most cases, the contained window will be a child window. If this is the case, then the contained window should be a child of the pager control.

Parameters
hwndChild Handle to the window to be contained.

◆ SetPos()

void SetPos ( int iPos )

This member function sets the scroll position for the pager control.

Parameters
iPos Integer value that contains the new scroll position in pixels.
The documentation for this class was generated from the following file:
  • XTPPageScroller.h


Toolkit Pro: CXTPPaintManager Class Reference

Classes | Public Member Functions | Static Public Member Functions | Public Attributes | Protected Member Functions | Protected Attributes | List of all members
CXTPPaintManager Class Referenceabstract

Paint manager of the command bars. More...

Inheritance diagram for CXTPPaintManager:
[legend]

Classes

struct CLogFont
CLogFont is a self initializing LOGFONT derived class. More...

Public Member Functions

virtual void | SetImageHandle (HMODULE hResource, LPCTSTR lpszIniFileName)
Specifies the resource that contains the bitmaps to be loaded for the theme.
CSize | DrawControl (CDC *pDC, CXTPControl *pButton, BOOL bDraw=TRUE)
This method is called to draw the control.
virtual CSize | DrawControlPopupParent (CDC *pDC, CXTPControl *pButton, BOOL bDraw)
This method is called to draw the control placed on the pop- up bar.
virtual CSize | DrawControlToolBarParent (CDC *pDC, CXTPControl *pButton, BOOL bDraw)
This method is called to draw the control placed on the toolbar.
virtual void | DrawSplitButtonFrame (CDC *pDC, CXTPControl *pButton, CRect rc)=0
This method is called to draw the frame for the SplitButton control.
virtual CSize | DrawControlComboBox (CDC *pDC, CXTPControlComboBox *pCombo, BOOL bDraw)
This method is called to draw the control.
virtual COLORREF | GetControlEditBackColor (CXTPControl *pControl)
This method returns the edit control back color to draw.
virtual CSize | DrawControlEdit (CDC *pDC, CXTPControlEdit *pEdit, BOOL bDraw)
This method is called to draw the control.
virtual CSize | DrawListBoxControl (CDC *pDC, CXTPControl *pButton, CRect rc, BOOL bSelected, BOOL bDraw, CXTPCommandBars *pCommandBars=0)=0
This method is called to draw the control placed on the ListBox.
virtual void | FillCommandBarEntry (CDC *pDC, CXTPCommandBar *pBar)=0
This method is called to fill the command bar's face.
virtual void | DrawControlEntry (CDC *pDC, CXTPControl *pButton)
This method is called to fill the control's face.
virtual COLORREF | GetControlTextColor (CXTPControl *pButton)
Call this method to get the control text color to draw.
virtual COLORREF | GetControlBackColor (CXTPControl *pButton)
Call this method to get the control back color to draw.
virtual COLORREF | GetRectangleTextColor (BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition)=0
This method retrieves a button's text color.
virtual void | DrawRectangle (CDC *pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition)=0
This method is called to fill the control's face.
virtual void | DrawGalleryItemBack (CDC *pDC, CRect rcItem, BOOL bEnabled, BOOL bSelected, BOOL bPressed, BOOL bChecked, XTPBarType barType)
This method is called to draw the background for a gallery menu item.
virtual BOOL | DrawRectangle (CDC *pDC, CXTPControl *pButton)
This method is called to fill the control's face.
virtual CSize | DrawCommandBarGripper (CDC *pDC, CXTPCommandBar *pBar, BOOL bDraw=TRUE)
This method is called to draw the command bar's gripper.
virtual CSize | DrawCommandBarSeparator (CDC *pDC, CXTPCommandBar *pBar, CXTPControl *pControl, BOOL bDraw=TRUE)=0
This method is called to draw a command bar's separator.
virtual void | DrawCommandBarGroupSeparator (CDC *pDC, CXTPCommandBar *pBar, CXTPControl *pLeftControl, CXTPControl *pRightControl, BOOL bDraw=TRUE)
This method is called to draw a command bar's group separator.
virtual void | AdjustExcludeRect (CRect &rc, CXTPControl *pControl, BOOL bVertical)=0
This method is called to determine the offset of a pop-up'ed bar.
virtual void | FillDockBar (CDC *pDC, CXTPDockBar *pBar)
This method is called to fill a dock bar.
virtual void | FillWorkspace (CDC *pDC, CRect rc, CRect rcExclude)
This method is called to fill a workspace.
virtual void | RefreshMetrics ()
This method is called to refresh the visual metrics of the manager.
int | GetShadowOptions () const
Determines the kind of shadow to use.
virtual void | DrawExpandGlyph (CDC *pDC, CXTPControl *pButton, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clr)
Draw expand or hidden glyphs for a button.
virtual void | DrawExpandGlyph (CDC *pDC, CXTPControl *pButton, COLORREF clr, BOOL bVertical)
Draw expand or hidden glyphs for a button.
virtual void | DrawHiddenGlyph (CDC *pDC, CXTPControl *pButton, COLORREF clr, BOOL bVertical)
Draw expand or hidden glyphs for a button.
virtual CSize | DrawSpecialControl (CDC *pDC, XTPSpecialControl controlType, CXTPControl *pButton, CXTPCommandBar *pBar, BOOL bDraw, LPVOID lpParam)
This method is called to draw the specified controls.
virtual CRect | GetCommandBarBorders (CXTPCommandBar *pBar)
This method is called to retrieve the command bar's borders.
virtual CSize | DrawTearOffGripper (CDC *pDC, CRect rcGripper, BOOL bSelected, BOOL bDraw)=0
This method is called to draw a tear-off gripper of a pop-up bar.
virtual void | DrawPopupResizeGripper (CDC *pDC, CRect rcGripper, int nFlags)=0
This method is called to draw a pop-up bar's resize gripper.
virtual void | DrawImage (CDC *pDC, CPoint pt, CSize sz, CXTPImageManagerIcon *pImage, BOOL bSelected, BOOL bPressed, BOOL bEnabled=TRUE, BOOL bChecked=FALSE, BOOL bPopuped=FALSE, BOOL bToolBarImage=TRUE)=0
This method is called to draw the image of the control.
virtual CSize | DrawDialogBarGripper (CDC *pDC, CXTPDialogBar *pBar, BOOL bDraw)=0
Call this member to draw a dialog bar's gripper.
virtual CRect | GetSplitButtonCommandRect (CXTPControl *pButton)
Determines split button command rectangle.
virtual void | SetCommandBarRegion (CXTPCommandBar *pCommandBar)
Call this method to set the bounding region of a pop-up bar.
virtual CSize | DrawControlCheckBoxMark (CDC *pDC, CRect rc, BOOL bDraw, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled)
This method is called to draw a check box mark area.
virtual CSize | DrawControlCheckBoxMark (CDC *pDC, CXTPControl *pButton, CRect rc, BOOL bDraw)
This method is called to draw a check box mark area.
virtual CSize | DrawControlRadioButtonMark (CDC *pDC, CRect rc, BOOL bDraw, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled)
This method is called to draw a radio button mark area.
virtual void | DrawPopupBarGripper (CDC *pDC, int xPos, int yPos, int cx, int cy, BOOL bExpanded=FALSE)
This method is called to draw a pop-up bar's right gripper.
XTPPaintTheme GetCurrentTheme ()
Call this member to get the current visual theme.
virtual XTPPaintTheme | BaseTheme ()=0
Retrieves the base theme of the manager.
virtual BOOL | RequiresResourceImages ()
Used by the paint manager to determine if the theme requires a resource DLL to load image and color information.
virtual CFont * | GetControlFont (CXTPControl *pControl)
Call this member to retrieve the font of the command bar control.
virtual CFont * | GetCommandBarFont (CXTPCommandBar *pCommandBar)
Call this member to retrieve the font of the command bar.
virtual XTPBarTextOrientation | GetControlTextOrientation (CXTPControl *pControl)
Call this member to determine how to draw text.
virtual void | UpdateFonts ()
Refreshes the fonts to use.
virtual void | UpdateColors ()
Refreshes the standard colors to use.
void | SetCommandBarsFontIndirect (LOGFONT *pLogFont, BOOL bUseStandardFont=FALSE)
Call this member to set command bar's font.
CFont * | GetRegularFont ()
Returns the general font.
CFont * | GetRegularBoldFont ()
Returns the general bold font.
CFont * | GetIconFont ()
Returns the icon font.
CFont * | GetSmCaptionFont ()
Call this method to retrieve the caption of a floating mini frame.
void | UseOfficeFont (bool bUseOfficeFont)
Call this method to use Tahoma font despite system metrics.
int | GetControlHeight () const
This method returns the common controls height.
virtual CSize | GetDefaultCommandBarSize (CXTPCommandBar *pBar)
Computes default command bar size taking into account command bar font.
void | Rectangle (CDC *pDC, LPCRECT rc, int nPen, const int nBrush)
Draws a rectangle.
void | Rectangle (CDC *pDC, LPCRECT rc, COLORREF clrPen, COLORREF clrBrush)
Draws a rectangle.
void | RoundRect (CDC *pDC, LPCRECT rc, COLORREF clrPen, COLORREF clrBrush)
Draws a rectangle.
void | Draw3dRect (CDC *pDC, LPCRECT rc, int nTopLeft, int nBottomRight)
Call this member function to draw a three-dimensional rectangle.
void | Draw3dRect (CDC *pDC, LPCRECT rc, int frameThickness, COLORREF clrPen, COLORREF clrBrush)
Call this member function to draw a rectangle with predetermined thickness.
virtual void | DrawPopupBarCheckMark (CDC *pDC, CRect rcCheck, BOOL bEnabled, COLORREF clr)
Call this member function to draw a check mark.
void | DrawCheckMark (CDC *pDC, CRect rcCheck, COLORREF clr=0)
Call this member function to draw a check mark.
virtual void | DrawPopupBarRadioMark (CDC *pDC, CRect rcCheck, BOOL bEnabled, COLORREF clr)
Call this member function to draw a radio button.
virtual void | DrawComboExpandMark (CDC *pDC, CRect rc, COLORREF clr)
Call this member function to draw a combobox expand symbol.
virtual void | DrawControlMDIButton (CDC *pDC, CXTPControlButton *pButton)
Call this member function to draw menu MDI buttons.
void | Line (CDC *pDC, CPoint p0, CPoint p1)
Draws a line.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1, const int nPen)
Draws a line.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1, COLORREF clrPen)
Draws a line.
void | HorizontalLine (CDC *pDC, int x0, int y0, int x1, COLORREF clrPen)
Call this member function to draw a horizontal line using the specified coordinages and RGB color value.
void | VerticalLine (CDC *pDC, int x0, int y0, int y1, COLORREF clrPen)
Call this member function to draw a vertical line using the specified coordinages and RGB color value.
virtual void | DrawDropDownGlyph (CDC *pDC, CXTPControl *pControl, CPoint pt, BOOL bSelected, BOOL bPopuped, BOOL bEnabled, BOOL bVert)
This member function is called to draw a split button expand symbol.
void | Pixel (CDC *pDC, int xPos, int yPos, int nPen)
Sets the pixel at the point.
void | GradientFill (CDC *pDC, LPRECT lpRect, COLORREF crFrom, COLORREF crTo, BOOL bHorz, LPCRECT lpRectClip=NULL)
Gradient fills the rectangle.
XTP_COMMANDBARS_ICONSINFO * GetIconsInfo ()
virtual void | Animate (CDC *pDestDC, CDC *pSrcDC, CRect rc, XTPAnimationType animationType)
This method is called to animate the pop-up bar.
virtual void | AnimateExpanding (CXTPCommandBar *pCommandBar, CDC *pDestDC, CDC *pSrcDC, BOOL bExpandDown)
This method is called to animate the expanding process.
void | SetAnimationDelay (int nAnimationSteps, int nAnimationTime)
Call this method to set animation delay.
COLORREF | GetXtremeColor (UINT nIndex)
This function retrieves the current color of the specified XP display element.
void | SetColors (int cElements, CONST INT *lpaElements, CONST COLORREF *lpaRgbValues)
Call this member to set the colors for each element to the color in the specified color array.
CSize | DrawControlText (CDC *pDC, CXTPControl *pControl, CRect rcText, BOOL bDraw, BOOL bVert, BOOL bCentered, BOOL bTriangled)
This method is called to draw control text.
virtual void | UpdateRTLCaption (CString &strCaption)
This method is called to prepare a caption for Right-To-Left draw.
XTPCurrentSystemTheme GetCurrentSystemTheme ()
Call this member function to determine the current Windows XP theme in use.
void | SetLunaTheme (XTPCurrentSystemTheme systemTheme)
Call this method to force system theme.
virtual int | GetPopupBarGripperWidth (CXTPCommandBar *pBar)
Calculates the gripper of a pop-up bar.
virtual CXTPControlGalleryPaintManager * | GetGalleryPaintManager () const
Retrieves paint manager used to draw galleries.
virtual CXTPScrollBarPaintManager * | GetScrollBarPaintManager () const
Retrieves paint manager used to draw scrollbars.
virtual CXTPSliderPaintManager * | GetSliderPaintManager () const
Retrieves paint manager used to draw slider panes.
virtual CXTPProgressPaintManager * | GetProgressPaintManager () const
Retrieves paint manager used to draw progress bars.
virtual CXTPFramePaintManager * | GetFramePaintManager ()
Retrieves paint manager used to draw frames.
virtual CXTPStatusBarPaintManager * | GetStatusBarPaintManager ()
Retrieves paint manager used to draw the status bar.
virtual CXTPRibbonPaintManager * | GetRibbonPaintManager ()
Retrieves the ribbon paint manager.
virtual CXTPMessageBarPaintManager * | GetMessageBarPaintManager ()
Retrieves paint manager used to draw message bars.
CXTPShadowManager * | GetShadowManager () const
Retrieves shadow manager used to draw shadows.
BOOL | IsUseSystemAccentColorEnabled () const
Determines whether xtpApplicationUseSystemAccentColor application ambient property is set.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.
- Public Member Functions inherited from CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents >
void | Subscribe (IXTPPaintManagerEvents *pObserver, CXTPSubscriptionList< CXTPPaintManager, IXTPPaintManagerEvents > *pSubcriptionList=NULL)
Subscribes a unique observer for events.
void | Unsubscribe (IXTPPaintManagerEvents *pObserver)
Unsubscribes an observer from events.
void | Notify (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *))
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *))
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.

Static Public Member Functions

static CXTPPaintManager *AFX_CDECL | GetInstanceAddRef ()
Obtains a pointer to a global paint manager object and increments its reference counter.
static void AFX_CDECL | ReleaseInstance ()
Decrements global paint manager's reference counter and deletes its instance when the reference counter reaches 0.
static CXTPPaintManager *AFX_CDECL | CreateTheme (XTPPaintTheme paintTheme)
Creates a new CXTPPaintManager object.
static void AFX_CDECL | SetTheme (XTPPaintTheme paintTheme)
Call this member to switch the visual theme of the Command Bars.
static void AFX_CDECL | SetCustomTheme (CXTPPaintManager *pTheme)
Call this member to set a custom theme.
static void AFX_CDECL | Triangle (CDC *pDC, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clr)
Draws a triangle.
static BOOL AFX_CDECL | FontExists (LPCTSTR lpszFaceName)
Determines if a specified font exists in the system.
static void AFX_CDECL | StripMnemonics (CString &strClear)
This member function will search a string, strip off the mnemonic '&', and reformat the string.
static CXTPPaintManager *AFX_CDECL | GetGlobalPaintManager ()
Call this method to get the pointer to the global paint manager.
static void AFX_CDECL | SetGlobalPaintManager (CXTPPaintManager *pPaintManager)
Call this method to set the pointer to the global paint manager.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Public Attributes

COLORREF | m_clrMessageBarText
Message bar text color.
CRect | m_rcMessageBarMargin
Margin of the message bar.
CXTPFramePaintManager * | m_pFramePaintManager
Frame paint manager.
CXTPStatusBarPaintManager * | m_pStatusBarPaintManager
Paint manager of the status bar.
CXTPRibbonPaintManager * | m_pRibbonPaintManager
Ribbon paint Manager.
CXTPControlGalleryPaintManager * | m_pGalleryPaintManager
Gallery paint manager.
CXTPProgressPaintManager * | m_pProgressPaintManager
Progress bar paint manager.
CXTPSliderPaintManager * | m_pSliderPaintManager
Slider pane paint manager.
CXTPScrollBarPaintManager * | m_pScrollBarPaintManager
Scrollbar paint manager.
CXTPPaintManagerColorGradient | m_clrDisabledIcon
Disabled icons color.
CXTPPaintManagerColor | m_clrFloatingGripper
Gripper color of floating toolbar.
CXTPPaintManagerColor | m_clrFloatingGripperText
Gripper text color of floating toolbar.
BOOL | m_bThickCheckMark
TRUE to draw thick check mark.
BOOL | m_bShowShadow
TRUE to show shadow.
BOOL | m_bThemedStatusBar
TRUE to draw status bar using WinXP theme.
BOOL | m_bThemedCheckBox
TRUE to draw check box using WinXP theme.
BOOL | m_bClearTypeTextQuality
TRUE to enable ClearType text for the font.
BOOL | m_bFlatToolBar
TRUE to draw toolbars flat.
BOOL | m_bFlatMenuBar
TRUE to draw menubar flat.
int | m_nPopupBarTextPadding
Distance between gripper and control text.
BOOL | m_bSelectImageInPopupBar
TRUE to select image as in explorer theme.
BOOL | m_bEnableAnimation
TRUE to enable animation for all toolbars.
BOOL | m_bOffice2007Padding
TRUE if Office2007 metrics used.
BOOL | m_bOffsetPopupLabelText
TRUE if labels in pop-ups drawn with offset.
BOOL | m_bWrapCaptionBelowText
Wrap text for xtpButtonIconAndCaptionBelow buttons.
CXTPPaintManagerFont | m_fontSmCaption
Small caption font.
CXTPPaintManagerFont | m_fontIcon
Icon font.
CXTPPaintManagerFont | m_fontIconBold
Icon bold font.
CXTPPaintManagerFont | m_fontToolTip
Tooltip font.
int | m_nSplitButtonDropDownWidth
Split button drop down width in toolbars.
int | m_nSplitButtonDropDownHeight
Split button drop down height in toolbars.
int | m_nSplitButtonPopupWidth
Split button drop down width in pop-ups.
BOOL | m_bAutoResizeIcons
TRUE to automatically resize icons using current DPI.
int | m_nStatusBarMinHeight
Minimum height for the status bar.
PVOID | m_pfnSetLayeredWindowAttributes
point to Transparency proc in USER32.dll module.
CRect | m_rcStatusBarBorder
Bounding rectangle of the status bar border.
BOOL | m_bUseOfficeFont
TRUE to use Tahoma font.
CString | m_strOfficeFont
Office font.
int | m_nTextHeight
Regular text field height (not font height).

Protected Member Functions

CXTPPaintManager ()
Constructs a CXTPPaintManager object.
virtual ~CXTPPaintManager ()
Destroys a CXTPPaintManager object, handles cleanup and deallocation.
- Protected Member Functions inherited from CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents >
CXTPObservable ()
Constructs an observable object.
~CXTPObservable ()
Handles observable object destruction.

Protected Attributes

CXTPFont | m_xtpFontRegular
Regular font.
CXTPFont | m_xtpFontRegularBold
Regular bold font.
CXTPFont | m_xtpFontVert
Vertical font.
CXTPFont | m_xtpFontVertBold
Vertical font.
int | m_nEditHeight
Edit text height.
int | m_nFontHeight
Custom font height (optional).
BOOL | m_bUseStandardFont
TRUE to use system font.
BOOL | m_bEmbossedDisabledText
TRUE to draw disabled text embossed.
CXTPWinThemeWrapper * | m_themeStatusBar
StatusBar theme helper.
CXTPWinThemeWrapper * | m_themeButton
Buttons theme helper.
XTPPaintTheme | m_themeCurrent
Current theme.
XTP_COMMANDBARS_ICONSINFO | m_iconsInfo
Specific icons options.
int | m_nAnimationSteps
Steps of the animation.
int | m_nAnimationTime
Time of the animation.
BOOL | m_bShowKeyboardCues
TRUE to show keyboard cues - deprecated.
CXTPPaintManagerColor | m_arrColor [XPCOLOR_LAST+1]
Self colors array.
XTPCurrentSystemTheme | m_systemTheme
Current system theme.
CXTPShadowManager * | m_pShadowManager
Shadow manager.

Detailed Description

Paint manager of the command bars.

Member Function Documentation

◆ AdjustExcludeRect()

virtual void AdjustExcludeRect | ( | CRect & | rc,
 |  | CXTPControl * | pControl,
 |  | BOOL | bVertical )
 pure virtual

This method is called to determine the offset of a pop-up'ed bar.

Parameters
rc | Control's bounding rectangle.
pControl | Pointer to a CXTPControl object.
bVertical | TRUE if control is docked vertically.

Implemented in CXTPCommandBarsNativeXPTheme, CXTPCommandBarsOffice2000Theme, CXTPCommandBarsOfficeXPTheme, CXTPRibbonTheme, CXTPVisualStudio2008Theme, and CXTPVisualStudio2010Theme.

◆ Animate()

virtual void Animate | ( | CDC * | pDestDC,
 |  | CDC * | pSrcDC,
 |  | CRect | rc,
 |  | XTPAnimationType | animationType )
 virtual

This method is called to animate the pop-up bar.

Parameters
pDestDC | Pointer to the device context you must draw to.
pSrcDC | Device context that contains the bitmap you must take.
rc | Bounding rectangle.
animationType | Type of animation to perform.
See also
SetAnimationDelay

◆ AnimateExpanding()

virtual void AnimateExpanding | ( | CXTPCommandBar * | pCommandBar,
 |  | CDC * | pDestDC,
 |  | CDC * | pSrcDC,
 |  | BOOL | bExpandDown )
 virtual

This method is called to animate the expanding process.

Parameters
pCommandBar | Command bar to animate.
pDestDC | Pointer to the device context you must draw to.
pSrcDC | Device context that contains the bitmap you must take.
bExpandDown | TRUE to animate expanding top-to-bottom, FALSE to animate expanding bottom-to-top.

◆ BaseTheme()

virtual XTPPaintTheme BaseTheme ( )
pure virtual

Retrieves the base theme of the manager.

Returns
Returns the base theme.

Implemented in CXTPCommandBarsNativeXPTheme, CXTPCommandBarsOffice2000Theme, CXTPCommandBarsOffice2003Theme, CXTPCommandBarsOffice2013Theme, CXTPCommandBarsOfficeXPTheme, CXTPCommandBarsVisualStudio2012Theme, CXTPResourceTheme, CXTPRibbonTheme, CXTPVisualStudio2005Theme, CXTPVisualStudio2008Theme, and CXTPVisualStudio2010Theme.

◆ CreateTheme()

static CXTPPaintManager *AFX_CDECL CreateTheme ( XTPPaintTheme paintTheme )
static

Creates a new CXTPPaintManager object.

Parameters
paintTheme Theme to be created.
Returns
Pointer to a new CXTPPaintManager object.

Example:

pCommandBars->SetPaintManager(CXTPPaintManager::CreateTheme(xtpThemeOfficeXP);

◆ Draw3dRect() [1/2]

void Draw3dRect | ( | CDC * | pDC,
 |  | LPCRECT | rc,
 |  | int | frameThickness,
 |  | COLORREF | clrPen,
 |  | COLORREF | clrBrush )

Call this member function to draw a rectangle with predetermined thickness.

Parameters
pDC | Pointer to a valid device context.
rc | Specifies the rectangle in logical units.
frameThickness | Thickness of the rectangle frame.
clrPen | Specifies the color used to paint the rectangle.
clrBrush | Specifies the color used to fill the rectangle.

◆ Draw3dRect() [2/2]

void Draw3dRect | ( | CDC * | pDC,
 |  | LPCRECT | rc,
 |  | int | nTopLeft,
 |  | int | nBottomRight )

Call this member function to draw a three-dimensional rectangle.

Parameters
pDC | Pointer to a valid device context.
rc | Specifies the rectangle in logical units.
nTopLeft | Specifies the color of the top and left sides of the three-dimensional rectangle.
nBottomRight | Specifies the color of the bottom and right sides of the three-dimensional rectangle.

◆ DrawCheckMark()

void DrawCheckMark | ( | CDC * | pDC,
 |  | CRect | rcCheck,
 |  | COLORREF | clr = 0 )
 inline

Call this member function to draw a check mark.

Parameters
pDC | Pointer to a valid device context.
rcCheck | Specifies the rectangle in logical units.
clr | Color to fill.

◆ DrawComboExpandMark()

virtual void DrawComboExpandMark | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | COLORREF | clr )
 virtual

Call this member function to draw a combobox expand symbol.

Parameters
pDC | Pointer to a valid device context.
rc | Specifies the rectangle in logical units.
clr | Color to fill.

◆ DrawCommandBarGripper()

virtual CSize DrawCommandBarGripper | ( | CDC * | pDC,
 |  | CXTPCommandBar * | pBar,
 |  | BOOL | bDraw = TRUE )
 virtual

This method is called to draw the command bar's gripper.

Parameters
pDC | Pointer to a valid device context.
pBar | Pointer to a CXTPCommandBar object.
bDraw | TRUE to draw, FALSE to retrieve the size of the gripper.
Returns
Size of the gripper.

Reimplemented in CXTPCommandBarsNativeWindows10Theme, CXTPCommandBarsNativeWindows11Theme, CXTPCommandBarsNativeXPTheme, CXTPCommandBarsOffice2000Theme, CXTPCommandBarsOffice2003Theme, CXTPCommandBarsOffice2013Theme, CXTPCommandBarsOfficeXPTheme, CXTPCommandBarsVisualStudio2012Theme, CXTPCommandBarsVisualStudio2015Theme, CXTPCommandBarsVisualStudio2017Theme, CXTPCommandBarsVisualStudio2019Theme, CXTPCommandBarsVisualStudio2022Theme, and CXTPRibbonTheme.

◆ DrawCommandBarGroupSeparator()

virtual void DrawCommandBarGroupSeparator | ( | CDC * | pDC,
 |  | CXTPCommandBar * | pBar,
 |  | CXTPControl * | pLeftControl,
 |  | CXTPControl * | pRightControl,
 |  | BOOL | bDraw = TRUE )
 virtual

This method is called to draw a command bar's group separator.

Parameters
pDC | Pointer to a valid device context.
pBar | Pointer to a CXTPCommandBar object.
pLeftControl | Pointer to a left CXTPControl object.
pRightControl | Pointer to a left CXTPControl object.
bDraw | TRUE to draw, FALSE to retrieve the size of the separator.

Reimplemented in CXTPCommandBarsOffice2013Theme.

◆ DrawCommandBarSeparator()

virtual CSize DrawCommandBarSeparator | ( | CDC * | pDC,
 |  | CXTPCommandBar * | pBar,
 |  | CXTPControl * | pControl,
 |  | BOOL | bDraw = TRUE )
 pure virtual

This method is called to draw a command bar's separator.

Parameters
pDC | Pointer to a valid device context.
pBar | Pointer to a CXTPCommandBar object.
pControl | Pointer to a CXTPControl object.
bDraw | TRUE to draw, FALSE to retrieve the size of the separator.
Returns
Size of the separator.

Implemented in CXTPCommandBarsNativeXPTheme, CXTPCommandBarsOffice2000Theme, CXTPCommandBarsOffice2003Theme, CXTPCommandBarsOffice2013Theme, CXTPCommandBarsOfficeXPTheme, CXTPCommandBarsVisualStudio2012Theme, CXTPRibbonTheme, CXTPVisualStudio2008Theme, and CXTPVisualStudio2010Theme.

◆ DrawControl()

CSize DrawControl | ( | CDC * | pDC,
 |  | CXTPControl * | pButton,
 |  | BOOL | bDraw = TRUE )

This method is called to draw the control.

Parameters
pDC | Pointer to a valid device context.
pButton | Pointer to a CXTPControl object.
bDraw | TRUE to draw, FALSE to retrieve the size of the control.
Returns
Size of the control.

◆ DrawControlCheckBoxMark() [1/2]

virtual CSize DrawControlCheckBoxMark | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | BOOL | bDraw,
 |  | BOOL | bSelected,
 |  | BOOL | bPressed,
 |  | BOOL | bChecked,
 |  | BOOL | bEnabled )
 virtual

This method is called to draw a check box mark area.

Parameters
pDC | Pointer to a valid device context.
rc | Bounding rectangle.
bDraw | TRUE to draw, FALSE to find size.
bSelected | TRUE if control is selected.
bPressed | TRUE if control is pressed.
bChecked | TRUE if control is checked.
bEnabled | TRUE if control is enabled.
Returns
Size of check box mark.

Reimplemented in CXTPCommandBarsOffice2013Theme, CXTPCommandBarsOfficeXPTheme, and CXTPCommandBarsVisualStudio2012Theme.

◆ DrawControlCheckBoxMark() [2/2]

virtual CSize DrawControlCheckBoxMark | ( | CDC * | pDC,
 |  | CXTPControl * | pButton,
 |  | CRect | rc,
 |  | BOOL | bDraw )
 virtual

This method is called to draw a check box mark area.

Parameters
pDC | Pointer to a valid device context.
pButton | Pointer to the checkbox control.
rc | Bounding rectangle of the check box itself (not control).
bDraw | TRUE to draw, FALSE to find size.
Returns
Size of check box mark.

Reimplemented in CXTPCommandBarsOffice2013Theme, and CXTPCommandBarsOfficeXPTheme.

◆ DrawControlComboBox()

virtual CSize DrawControlComboBox | ( | CDC * | pDC,
 |  | CXTPControlComboBox * | pCombo,
 |  | BOOL | bDraw )
 virtual

This method is called to draw the control.

Parameters
pDC | Pointer to a valid device context
pCombo | ComboBox to draw.
bDraw | TRUE to draw, FALSE to retrieve the size of the control.
Returns
Size of the control.

Reimplemented in CXTPCommandBarsNativeWindows10Theme, CXTPCommandBarsNativeWindows11Theme, CXTPCommandBarsOffice2000Theme, CXTPCommandBarsOffice2013Theme, CXTPCommandBarsOfficeXPTheme, CXTPCommandBarsVisualStudio2012Theme, CXTPCommandBarsVisualStudio2015Theme, CXTPCommandBarsVisualStudio2017Theme, CXTPCommandBarsVisualStudio2019Theme, CXTPCommandBarsVisualStudio2022Theme, and CXTPRibbonTheme.

◆ DrawControlEdit()

virtual CSize DrawControlEdit | ( | CDC * | pDC,
 |  | CXTPControlEdit * | pEdit,
 |  | BOOL | bDraw )
 virtual

This method is called to draw the control.

Parameters
pDC | Pointer to a valid device context.
pEdit | Edit control to draw.
bDraw | TRUE to draw, FALSE to retrieve the size of the control.
Returns
Size of the control.

Reimplemented in CXTPCommandBarsOffice2000Theme, CXTPCommandBarsOffice2013Theme, CXTPCommandBarsOfficeXPTheme, and CXTPRibbonTheme.

◆ DrawControlEntry()

virtual void DrawControlEntry | ( | CDC * | pDC,
 |  | CXTPControl * | pButton )
 virtual

This method is called to fill the control's face.

Parameters
pDC | Pointer to a valid device context.
pButton | Pointer to a CXTPControl object to draw.

Reimplemented in CXTPCommandBarsNativeXPTheme, and CXTPRibbonTheme.

◆ DrawControlMDIButton()

virtual void DrawControlMDIButton | ( | CDC * | pDC,
 |  | CXTPControlButton * | pButton )
 virtual

Call this member function to draw menu MDI buttons.

Parameters
pDC | Pointer to a valid device context.
pButton | Button to draw.

Reimplemented in CXTPCommandBarsNativeXPTheme, and CXTPCommandBarsOffice2013Theme.

◆ DrawControlPopupParent()

virtual CSize DrawControlPopupParent | ( | CDC * | pDC,
 |  | CXTPControl * | pButton,
 |  | BOOL | bDraw )
 virtual

This method is called to draw the control placed on the pop- up bar.

Parameters
pDC | Pointer to a valid device context.
pButton | Pointer to a CXTPControl object.
bDraw | TRUE to draw, FALSE to retrieve the size of the control.
Returns
Size of the control.

Reimplemented in CXTPCommandBarsOffice2000Theme, and CXTPCommandBarsOfficeXPTheme.

◆ DrawControlRadioButtonMark()

virtual CSize DrawControlRadioButtonMark | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | BOOL | bDraw,
 |  | BOOL | bSelected,
 |  | BOOL | bPressed,
 |  | BOOL | bChecked,
 |  | BOOL | bEnabled )
 virtual

This method is called to draw a radio button mark area.

Parameters
pDC | Pointer to a valid device context.
rc | Bounding rectangle.
bDraw | TRUE to draw, FALSE to find size.
bSelected | TRUE if control is selected.
bPressed | TRUE if control is pressed.
bChecked | TRUE if control is checked.
bEnabled | TRUE if control is enabled.
Returns
Size of radio button mark.

Reimplemented in CXTPCommandBarsOffice2013Theme, and CXTPCommandBarsOfficeXPTheme.

◆ DrawControlText()

CSize DrawControlText | ( | CDC * | pDC,
 |  | CXTPControl * | pControl,
 |  | CRect | rcText,
 |  | BOOL | bDraw,
 |  | BOOL | bVert,
 |  | BOOL | bCentered,
 |  | BOOL | bTriangled )

This method is called to draw control text.

Parameters
pDC | Pointer to a valid device context.
pControl | Pointer to the control to draw.
rcText | Bounding rectangle of the text.
bDraw | TRUE to draw text, FALSE to calculate size.
bVert | TRUE if text is vertical.
bCentered | TRUE if text is centered.
bTriangled | TRUE if triangle drawn.
Returns
Size of the text.

◆ DrawControlToolBarParent()

virtual CSize DrawControlToolBarParent | ( | CDC * | pDC,
 |  | CXTPControl * | pButton,
 |  | BOOL | bDraw )
 virtual

This method is called to draw the control placed on the toolbar.

Parameters
pDC | Pointer to a valid device context.
pButton | Pointer to a CXTPControl object.
bDraw | TRUE to draw, FALSE to retrieve the size of the control.
Returns
Size of the control.

◆ DrawDialogBarGripper()

virtual CSize DrawDialogBarGripper | ( | CDC * | pDC,
 |  | CXTPDialogBar * | pBar,
 |  | BOOL | bDraw )
 pure virtual

Call this member to draw a dialog bar's gripper.

Parameters
pDC | Pointer to a valid device context.
pBar | Dialog Bar pointer.
bDraw | TRUE to draw gripper, FALSE to calculate size.
Returns
Size of gripper to be drawn.

Implemented in CXTPCommandBarsNativeXPTheme, CXTPCommandBarsOffice2000Theme, CXTPCommandBarsOffice2003Theme, and CXTPCommandBarsOfficeXPTheme.

◆ DrawDropDownGlyph()

virtual void DrawDropDownGlyph | ( | CDC * | pDC,
 |  | CXTPControl * | pControl,
 |  | CPoint | pt,
 |  | BOOL | bSelected,
 |  | BOOL | bPopuped,
 |  | BOOL | bEnabled,
 |  | BOOL | bVert )
 virtual

This member function is called to draw a split button expand symbol.

Parameters
pDC | Pointer to a valid device context.
pControl | Pointer to a CXTPControl object.
pt | Position of expand symbol.
bSelected | TRUE if the control is selected.
bPopuped | TRUE if the control is pop-up'ed.
bEnabled | TRUE if the control is enabled.
bVert | TRUE if control is vertical.

Reimplemented in CXTPCommandBarsOffice2013Theme, and CXTPCommandBarsVisualStudio2012Theme.

◆ DrawExpandGlyph() [1/2]

virtual void DrawExpandGlyph | ( | CDC * | pDC,
 |  | CXTPControl * | pButton,
 |  | COLORREF | clr,
 |  | BOOL | bVertical )
 virtual

Draw expand or hidden glyphs for a button.

Parameters
pDC | Output device context pointer.
pButton | Target button pointer.
clr | Glyph color.
bVertical | TRUE if vertically positioned glyph is to be drawn.

Reimplemented in CXTPCommandBarsOffice2013Theme, and CXTPCommandBarsVisualStudio2012Theme.

◆ DrawExpandGlyph() [2/2]

virtual void DrawExpandGlyph | ( | CDC * | pDC,
 |  | CXTPControl * | pButton,
 |  | CPoint | pt0,
 |  | CPoint | pt1,
 |  | CPoint | pt2,
 |  | COLORREF | clr )
 virtual

Draw expand or hidden glyphs for a button.

Parameters
pDC | Output device context pointer.
pButton | Target button pointer.
pt0 | Expand glyph triangle coordinates.
pt1 | Expand glyph triangle coordinates.
pt2 | Expand glyph triangle coordinates.
clr | Glyph color.

Reimplemented in CXTPCommandBarsOffice2013Theme, and CXTPCommandBarsVisualStudio2012Theme.

◆ DrawGalleryItemBack()

virtual void DrawGalleryItemBack | ( | CDC * | pDC,
 |  | CRect | rcItem,
 |  | BOOL | bEnabled,
 |  | BOOL | bSelected,
 |  | BOOL | bPressed,
 |  | BOOL | bChecked,
 |  | XTPBarType | barType )
 virtual

This method is called to draw the background for a gallery menu item.

Parameters
pDC | Pointer to a valid device context.
rcItem | Rectangle to draw.
bSelected | TRUE if the control is selected.
bPressed | TRUE if the control is pushed.
bEnabled | TRUE if the control is enabled.
bChecked | TRUE if the control is checked.
barType | Parent's bar type.

Reimplemented in CXTPCommandBarsNativeWindows10Theme, CXTPCommandBarsNativeWindows11Theme, CXTPCommandBarsOffice2013Theme, CXTPCommandBarsVisualStudio2015Theme, CXTPCommandBarsVisualStudio2017Theme, CXTPCommandBarsVisualStudio2019Theme, and CXTPCommandBarsVisualStudio2022Theme.

◆ DrawHiddenGlyph()

virtual void DrawHiddenGlyph | ( | CDC * | pDC,
 |  | CXTPControl * | pButton,
 |  | COLORREF | clr,
 |  | BOOL | bVertical )
 virtual

Draw expand or hidden glyphs for a button.

Parameters
pDC | Output device context pointer.
pButton | Target button pointer.
clr | Glyph color.
bVertical | TRUE if vertically positioned glyph is to be drawn.

Reimplemented in CXTPCommandBarsOffice2013Theme, and CXTPCommandBarsVisualStudio2012Theme.

◆ DrawImage()

virtual void DrawImage | ( | CDC * | pDC,
 |  | CPoint | pt,
 |  | CSize | sz,
 |  | CXTPImageManagerIcon * | pImage,
 |  | BOOL | bSelected,
 |  | BOOL | bPressed,
 |  | BOOL | bEnabled = TRUE,
 |  | BOOL | bChecked = FALSE,
 |  | BOOL | bPopuped = FALSE,
 |  | BOOL | bToolBarImage = TRUE )
 pure virtual

This method is called to draw the image of the control.

Parameters
pDC | Pointer to a valid device context.
pt | Position to draw.
sz | Size of the image.
pImage | Pointer to a CXTPImageManagerIcon object.
bSelected | TRUE if the control is selected.
bPressed | TRUE if the control is pushed.
bEnabled | TRUE if the control is enabled.
bChecked | TRUE if the control is checked.
bPopuped | TRUE if the control is pop-up'ed.
bToolBarImage | TRUE if it is a toolbar image.

Implemented in CXTPCommandBarsOffice2000Theme, and CXTPCommandBarsOfficeXPTheme.

◆ DrawListBoxControl()

virtual CSize DrawListBoxControl | ( | CDC * | pDC,
 |  | CXTPControl * | pButton,
 |  | CRect | rc,
 |  | BOOL | bSelected,
 |  | BOOL | bDraw,
 |  | CXTPCommandBars * | pCommandBars = 0 )
 pure virtual

This method is called to draw the control placed on the ListBox.

Parameters
pDC | Pointer to a valid device context.
pButton | Pointer to a CXTPControl object.
rc | Bounding rectangle to draw.
bSelected | TRUE if the control is selected.
bDraw | TRUE to draw, FALSE to retrieve the size of the control.
pCommandBars | CommandBars object which metrics need to use.
Returns
Size of the control.

Implemented in CXTPCommandBarsOffice2000Theme, and CXTPCommandBarsOfficeXPTheme.

◆ DrawPopupBarCheckMark()

virtual void DrawPopupBarCheckMark | ( | CDC * | pDC,
 |  | CRect | rcCheck,
 |  | BOOL | bEnabled,
 |  | COLORREF | clr )
 virtual

Call this member function to draw a check mark.

Parameters
pDC | Pointer to a valid device context.
rcCheck | Specifies the rectangle in logical units.
clr | Color to fill.
bEnabled | TRUE to enable, FALSE to disable the button.

Reimplemented in CXTPCommandBarsNativeXPTheme, and CXTPRibbonTheme.

◆ DrawPopupBarGripper()

virtual void DrawPopupBarGripper | ( | CDC * | pDC,
 |  | int | xPos,
 |  | int | yPos,
 |  | int | cx,
 |  | int | cy,
 |  | BOOL | bExpanded = FALSE )
 virtual

This method is called to draw a pop-up bar's right gripper.

Parameters
pDC | Pointer to a valid device context.
xPos | Specifies the logical x coordinate of the upper-left corner of the rectangle.
yPos | Specifies the logical y coordinate of the upper-left corner of the destination rectangle.
cx | Specifies the width of the rectangle.
cy | Specifies the height of the rectangle.
bExpanded | TRUE if expanded.

Reimplemented in CXTPCommandBarsNativeXPTheme, CXTPCommandBarsOffice2003Theme, CXTPCommandBarsOffice2013Theme, CXTPCommandBarsOfficeXPTheme, CXTPCommandBarsVisualStudio2012Theme, CXTPRibbonTheme, CXTPVisualStudio2008Theme, and CXTPVisualStudio2010Theme.

◆ DrawPopupBarRadioMark()

virtual void DrawPopupBarRadioMark | ( | CDC * | pDC,
 |  | CRect | rcCheck,
 |  | BOOL | bEnabled,
 |  | COLORREF | clr )
 virtual

Call this member function to draw a radio button.

Parameters
pDC | Pointer to a valid device context.
rcCheck | Specifies the rectangle in logical units.
clr | Color to fill.
bEnabled | TRUE to enable, FALSE to disable the button.

Reimplemented in CXTPCommandBarsNativeXPTheme, and CXTPRibbonTheme.

◆ DrawPopupResizeGripper()

virtual void DrawPopupResizeGripper | ( | CDC * | pDC,
 |  | CRect | rcGripper,
 |  | int | nFlags )
 pure virtual

This method is called to draw a pop-up bar's resize gripper.

Parameters
pDC | Pointer to a valid device context.
rcGripper | Bounding rectangle of the gripper.
nFlags | Position of resize gripper.

Implemented in CXTPCommandBarsOffice2000Theme, CXTPCommandBarsOfficeXPTheme, and CXTPRibbonTheme.

◆ DrawRectangle() [1/2]

virtual void DrawRectangle | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | BOOL | bSelected,
 |  | BOOL | bPressed,
 |  | BOOL | bEnabled,
 |  | BOOL | bChecked,
 |  | BOOL | bPopuped,
 |  | XTPBarType | barType,
 |  | XTPBarPosition | barPosition )
 pure virtual

This method is called to fill the control's face.

Parameters
pDC | Pointer to a valid device context.
rc | Rectangle to draw.
bSelected | TRUE if the control is selected.
bPressed | TRUE if the control is pushed.
bEnabled | TRUE if the control is enabled.
bChecked | TRUE if the control is checked.
bPopuped | TRUE if the control is pop-up'ed.
barType | Parent's bar type.
barPosition | Parent's bar position.

Implemented in CXTPCommandBarsNativeWindows10Theme, CXTPCommandBarsNativeWindows11Theme, CXTPCommandBarsNativeXPTheme, CXTPCommandBarsOffice2000Theme, CXTPCommandBarsOffice2003Theme, CXTPCommandBarsOffice2013Theme, CXTPCommandBarsOfficeXPTheme, CXTPCommandBarsVisualStudio2012Theme, CXTPCommandBarsVisualStudio2015Theme, CXTPCommandBarsVisualStudio2017Theme, CXTPCommandBarsVisualStudio2019Theme, CXTPCommandBarsVisualStudio2022Theme, CXTPRibbonTheme, CXTPVisualStudio2008Theme, and CXTPVisualStudio2010Theme.

◆ DrawRectangle() [2/2]

virtual BOOL DrawRectangle | ( | CDC * | pDC,
 |  | CXTPControl * | pButton )
 virtual

This method is called to fill the control's face.

Parameters
pDC | Pointer to a valid device context.
pButton | pointer to a button
Returns
TRUE if the rectange was drawn, otherwise FALSE.

Reimplemented in CXTPCommandBarsNativeWindows10Theme, CXTPCommandBarsNativeWindows11Theme, CXTPCommandBarsNativeXPTheme, CXTPCommandBarsOffice2000Theme, CXTPCommandBarsOffice2003Theme, CXTPCommandBarsOffice2013Theme, CXTPCommandBarsOfficeXPTheme, CXTPCommandBarsVisualStudio2012Theme, CXTPCommandBarsVisualStudio2015Theme, CXTPCommandBarsVisualStudio2017Theme, CXTPCommandBarsVisualStudio2019Theme, CXTPCommandBarsVisualStudio2022Theme, CXTPRibbonTheme, CXTPVisualStudio2008Theme, and CXTPVisualStudio2010Theme.

◆ DrawSpecialControl()

virtual CSize DrawSpecialControl | ( | CDC * | pDC,
 |  | XTPSpecialControl | controlType,
 |  | CXTPControl * | pButton,
 |  | CXTPCommandBar * | pBar,
 |  | BOOL | bDraw,
 |  | LPVOID | lpParam )
 virtual

This method is called to draw the specified controls.

Parameters
pDC | Pointer to a valid device context.
controlType | Special control enumerator.
pButton | Pointer to a CXTPControl object to draw.
pBar | Parent CXTPCommandBar object.
bDraw | TRUE to draw, FALSE to retrieve the size of the control.
lpParam | Specified parameter.
Returns
Size of the control.

Reimplemented in CXTPCommandBarsNativeXPTheme, CXTPCommandBarsOffice2000Theme, CXTPCommandBarsOffice2003Theme, and CXTPRibbonTheme.

◆ DrawSplitButtonFrame()

virtual void DrawSplitButtonFrame | ( | CDC * | pDC,
 |  | CXTPControl * | pButton,
 |  | CRect | rc )
 pure virtual

This method is called to draw the frame for the SplitButton control.

Parameters
pDC | Pointer to a valid device context.
pButton | Pointer to a CXTPControl object.
rc | Bounding rectangle to draw.

Implemented in CXTPCommandBarsNativeWindows10Theme, CXTPCommandBarsNativeWindows11Theme, CXTPCommandBarsNativeXPTheme, CXTPCommandBarsOffice2000Theme, CXTPCommandBarsOffice2013Theme, CXTPCommandBarsOfficeXPTheme, CXTPCommandBarsVisualStudio2012Theme, CXTPCommandBarsVisualStudio2015Theme, CXTPCommandBarsVisualStudio2017Theme, CXTPCommandBarsVisualStudio2019Theme, CXTPCommandBarsVisualStudio2022Theme, and CXTPRibbonTheme.

◆ DrawTearOffGripper()

virtual CSize DrawTearOffGripper | ( | CDC * | pDC,
 |  | CRect | rcGripper,
 |  | BOOL | bSelected,
 |  | BOOL | bDraw )
 pure virtual

This method is called to draw a tear-off gripper of a pop-up bar.

Parameters
pDC | Pointer to a valid device context.
rcGripper | Bounding rectangle of the gripper.
bSelected | TRUE if the gripper is selected.
bDraw | TRUE to draw, FALSE to retrieve the size of the gripper.
Returns
Size of the gripper.

Implemented in CXTPCommandBarsOffice2000Theme, CXTPCommandBarsOffice2003Theme, and CXTPCommandBarsOfficeXPTheme.

◆ FillCommandBarEntry()

virtual void FillCommandBarEntry | ( | CDC * | pDC,
 |  | CXTPCommandBar * | pBar )
 pure virtual

This method is called to fill the command bar's face.

Parameters
pDC | Pointer to a valid device context.
pBar | Pointer to a CXTPCommandBar object to draw.

Implemented in CXTPCommandBarsNativeWindows11Theme, CXTPCommandBarsNativeXPTheme, CXTPCommandBarsOffice2000Theme, CXTPCommandBarsOffice2003Theme, CXTPCommandBarsOffice2013Theme, CXTPCommandBarsOfficeXPTheme, CXTPCommandBarsVisualStudio2012Theme, CXTPRibbonTheme, and CXTPVisualStudio2010Theme.

◆ FillDockBar()

virtual void FillDockBar | ( | CDC * | pDC,
 |  | CXTPDockBar * | pBar )
 virtual

This method is called to fill a dock bar.

Parameters
pDC | Pointer to a valid device context.
pBar | Pointer to a CXTPDockBar object.

Reimplemented in CXTPCommandBarsNativeWindows11Theme, CXTPCommandBarsNativeXPTheme, CXTPCommandBarsOffice2003Theme, CXTPCommandBarsOffice2013Theme, and CXTPCommandBarsVisualStudio2012Theme.

◆ FillWorkspace()

virtual void FillWorkspace | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | CRect | rcExclude )
 virtual

This method is called to fill a workspace.

Parameters
pDC | Pointer to device context.
rc | Bounding rectangle.
rcExclude | Excluded rectangle.

Reimplemented in CXTPCommandBarsOffice2013Theme, and CXTPResourceTheme.

◆ FontExists()

static BOOL AFX_CDECL FontExists ( LPCTSTR lpszFaceName )
static

Determines if a specified font exists in the system.

Parameters
lpszFaceName Font to test.
Returns
TRUE if font exists, otherwise FALSE.

◆ GetCommandBarBorders()

virtual CRect GetCommandBarBorders ( CXTPCommandBar * pBar )
virtual

This method is called to retrieve the command bar's borders.

Parameters
pBar Pointer to a CXTPCommandBar object.
Returns
Borders of the command bar.

Reimplemented in CXTPCommandBarsNativeWindows11Theme, CXTPCommandBarsOffice2000Theme, CXTPCommandBarsOffice2003Theme, CXTPVisualStudio2008Theme, and CXTPVisualStudio2010Theme.

◆ GetCommandBarFont()

virtual CFont * GetCommandBarFont ( CXTPCommandBar * pCommandBar )
virtual

Call this member to retrieve the font of the command bar.

Parameters
pCommandBar Pointer to a CXTPCommandBar object to determine the font used to draw text.
Returns
A pointer to a CFont object.

◆ GetControlBackColor()

virtual COLORREF GetControlBackColor ( CXTPControl * pButton )
virtual

Call this method to get the control back color to draw.

Parameters
pButton Pointer to a CXTPControl object to draw.
Returns
The control back color to draw.

Reimplemented in CXTPCommandBarsOffice2013Theme.

◆ GetControlEditBackColor()

virtual COLORREF GetControlEditBackColor ( CXTPControl * pControl )
virtual

This method returns the edit control back color to draw.

Parameters
pControl Pointer to a CXTPControl object to get the back color from.
Returns
Edit control back color.

Reimplemented in CXTPCommandBarsOffice2013Theme, CXTPCommandBarsVisualStudio2012Theme, and CXTPRibbonTheme.

◆ GetControlFont()

virtual CFont * GetControlFont ( CXTPControl * pControl )
virtual

Call this member to retrieve the font of the command bar control.

Parameters
pControl Pointer to a CXTPCommandBar object.
Returns
A pointer to a CFont object.

◆ GetControlHeight()

int GetControlHeight ( ) const

This method returns the common controls height.

Returns
Controls height.

◆ GetControlTextColor()

virtual COLORREF GetControlTextColor ( CXTPControl * pButton )
virtual

Call this method to get the control text color to draw.

Parameters
pButton Pointer to a CXTPControl object to draw.
Returns
The control text color to draw.

Reimplemented in CXTPCommandBarsNativeWindows10Theme, CXTPCommandBarsNativeWindows11Theme, CXTPCommandBarsNativeXPTheme, CXTPCommandBarsOffice2013Theme, CXTPCommandBarsVisualStudio2015Theme, CXTPCommandBarsVisualStudio2017Theme, CXTPCommandBarsVisualStudio2019Theme, CXTPCommandBarsVisualStudio2022Theme, and CXTPRibbonTheme.

◆ GetControlTextOrientation()

virtual XTPBarTextOrientation GetControlTextOrientation ( CXTPControl * pControl )
virtual

Call this member to determine how to draw text.

Parameters
pControl Pointer to a CXTPControl object.
Returns
The current text orientation as defined by the XTPBarTextOrientation enumeration.

◆ GetCurrentSystemTheme()

XTPCurrentSystemTheme GetCurrentSystemTheme ( )

Call this member function to determine the current Windows XP theme in use.

Returns
A XTPCurrentSystemTheme enumeration that represents the current Windows XP theme in use; can be one of the following values: xtpSystemThemeUnknown: Indicates no known theme in use. xtpSystemThemeBlue: Indicates blue theme in use. xtpSystemThemeOlive: Indicates olive theme in use. xtpSystemThemeSilver: Indicates silver theme in use.
See also
SetLunaTheme, RefreshLunaColors

◆ GetCurrentTheme()

XTPPaintTheme GetCurrentTheme ( )
inline

Call this member to get the current visual theme.

Returns
The current theme.

◆ GetDefaultCommandBarSize()

virtual CSize GetDefaultCommandBarSize ( CXTPCommandBar * pBar )
virtual

Computes default command bar size taking into account command bar font.

Command bar elements' sizes are not considered.

Parameters
pBar Command bar object pointer to check size for.
Returns
Default command bar size.

◆ GetFramePaintManager()

virtual CXTPFramePaintManager * GetFramePaintManager ( )
virtual

Retrieves paint manager used to draw frames.

Returns
Pointer to a CXTPFramePaintManager object.

Reimplemented in CXTPCommandBarsModernUITheme, and CXTPResourceTheme.

◆ GetGalleryPaintManager()

AFX_INLINE CXTPControlGalleryPaintManager * GetGalleryPaintManager ( ) const
virtual

Retrieves paint manager used to draw galleries.

Returns
Pointer to a CXTPControlGalleryPaintManager object.

◆ GetGlobalPaintManager()

static CXTPPaintManager *AFX_CDECL GetGlobalPaintManager ( )
static

Call this method to get the pointer to the global paint manager.

Returns
If the global paint manager is set, then the pointer to the global paint manager will be returned. If no global paint manager is set, then a NULL value will be returned.
See also
SetGlobalPaintManager, XTPPaintManager

◆ GetIconFont()

AFX_INLINE CFont * GetIconFont ( )

Returns the icon font.

Returns
A pointer to a CFont object.

◆ GetIconsInfo()

XTP_COMMANDBARS_ICONSINFO * GetIconsInfo ( )
Returns
Retrieves a specific icon's options.
See also
XTP_COMMANDBARS_ICONSINFO

◆ GetInstanceAddRef()

static CXTPPaintManager *AFX_CDECL GetInstanceAddRef ( )
static

Obtains a pointer to a global paint manager object and increments its reference counter.

If a paint manager object has not yet been created, then the function creates it and initializes its default state.

Returns
A pointer to a global paint manager object.

◆ GetMessageBarPaintManager()

virtual CXTPMessageBarPaintManager * GetMessageBarPaintManager ( )
virtual

Retrieves paint manager used to draw message bars.

Returns
Pointer to a CXTPMessageBarPaintManager object.

◆ GetPopupBarGripperWidth()

virtual int GetPopupBarGripperWidth ( CXTPCommandBar * pBar )
virtual

Calculates the gripper of a pop-up bar.

Parameters
pBar Pop-up bar.
Returns
Width of gripper to draw.

Reimplemented in CXTPCommandBarsNativeXPTheme.

◆ GetProgressPaintManager()

AFX_INLINE CXTPProgressPaintManager * GetProgressPaintManager ( ) const
virtual

Retrieves paint manager used to draw progress bars.

Returns
Pointer to a CXTPProgressPaintManager object.

◆ GetRectangleTextColor()

virtual COLORREF GetRectangleTextColor | ( | BOOL | bSelected,
 |  | BOOL | bPressed,
 |  | BOOL | bEnabled,
 |  | BOOL | bChecked,
 |  | BOOL | bPopuped,
 |  | XTPBarType | barType,
 |  | XTPBarPosition | barPosition )
 pure virtual

This method retrieves a button's text color.

Parameters
bSelected | TRUE if the control is selected.
bPressed | TRUE if the control is pushed.
bEnabled | TRUE if the control is enabled.
bChecked | TRUE if the control is checked.
bPopuped | TRUE if the control is pop-up'ed.
barType | Parent's bar type.
barPosition | Parent's bar position.
Returns
A button's text color.

Implemented in CXTPCommandBarsNativeXPTheme, CXTPCommandBarsOffice2000Theme, CXTPCommandBarsOffice2013Theme, CXTPCommandBarsOfficeXPTheme, CXTPResourceTheme, CXTPRibbonTheme, CXTPVisualStudio2008Theme, and CXTPVisualStudio2010Theme.

◆ GetRegularBoldFont()

AFX_INLINE CFont * GetRegularBoldFont ( )

Returns the general bold font.

Returns
A Pointer to a CFont object.

◆ GetRegularFont()

AFX_INLINE CFont * GetRegularFont ( )

Returns the general font.

Returns
A Pointer to a CFont object.

◆ GetRibbonPaintManager()

virtual CXTPRibbonPaintManager * GetRibbonPaintManager ( )
virtual

Retrieves the ribbon paint manager.

Returns
A pointer to a CXTPRibbonPaintManager object.

Reimplemented in CXTPCommandBarsModernUITheme, and CXTPResourceTheme.

◆ GetScrollBarPaintManager()

AFX_INLINE CXTPScrollBarPaintManager * GetScrollBarPaintManager ( ) const
virtual

Retrieves paint manager used to draw scrollbars.

Returns
Pointer to a CXTPScrollBarPaintManager object.

◆ GetShadowManager()

AFX_INLINE CXTPShadowManager * GetShadowManager ( ) const

Retrieves shadow manager used to draw shadows.

Returns
Pointer to a CXTPShadowManager object.

◆ GetShadowOptions()

int GetShadowOptions ( ) const

Determines the kind of shadow to use.

Returns
Combination of XTPShadowOptions flags. See Also XTPShadowOptions

◆ GetSliderPaintManager()

AFX_INLINE CXTPSliderPaintManager * GetSliderPaintManager ( ) const
virtual

Retrieves paint manager used to draw slider panes.

Returns
Pointer to a CXTPSliderPaintManager object.

◆ GetSmCaptionFont()

AFX_INLINE CFont * GetSmCaptionFont ( )

Call this method to retrieve the caption of a floating mini frame.

Returns
A pointer to a CFont object.

◆ GetSplitButtonCommandRect()

virtual CRect GetSplitButtonCommandRect ( CXTPControl * pButton )
virtual

Determines split button command rectangle.

Parameters
pButton Button to test.
Returns
Bounding rectangle of command part of split button

◆ GetStatusBarPaintManager()

virtual CXTPStatusBarPaintManager * GetStatusBarPaintManager ( )
virtual

Retrieves paint manager used to draw the status bar.

Returns
Pointer to a CXTPStatusBarPaintManager object.

◆ GetXtremeColor()

COLORREF GetXtremeColor ( UINT nIndex )

This function retrieves the current color of the specified XP display element.

Display elements are the parts of a window and the display that appear on the system display screen. The function returns the red, green, blue (RGB) color value of the given element. To provide a consistent look to all Windows applications, the operating system provides and maintains global settings that define the colors of various aspects of the display. These settings as a group are sometimes referred to as a "color scheme." To view the current color settings, click Control Panel, double-click the Display icon, and then click the "Appearance" tab.

Parameters
nIndex Specifies the display element whose color is to be retrieved. This parameter can be one of the following values displayed in the table below:
  Constant                      Value           Description
  COLOR_SCROLLBAR                     0             Scroll bar
  COLOR_BACKGROUND                  1             Desktop color
  COLOR_ACTIVECAPTION                 2             Color of the title bar for the active
*window, Specifies the left side color in the color gradient of an active window's title bar if
*the gradient effect is enabled. COLOR_INACTIVECAPTION             3             Color of the
*title bar for the inactive window, Specifies the left side color in the color gradient of an
*inactive window's title bar if the gradient effect is enabled. COLOR_MENU 4
*Menu background color COLOR_WINDOW                      5             Window background color
  COLOR_WINDOWFRAME                 6             Window frame color
  COLOR_MENUTEXT                    7             Color of text on menus
  COLOR_WINDOWTEXT                  8             Color of text in windows
  COLOR_CAPTIONTEXT                 9             Color of text in caption, size box, and
*scroll arrow COLOR_ACTIVEBORDER                10            Border color of active window
  COLOR_INACTIVEBORDER              11            Border color of inactive window
  COLOR_APPWORKSPACE                12            Background color of multiple-document
*interface (MDI) applications COLOR_HIGHLIGHT                   13            Background color
*of items selected in a control COLOR_HIGHLIGHTTEXT               14            Text color of
*items selected in a control COLOR_BTNFACE                     15            Face color for
*three-dimensional display elements and for dialog box backgrounds. COLOR_BTNSHADOW 16 Color of
*shading on the edge of command buttons COLOR_GRAYTEXT                    17            Grayed
*(disabled) text COLOR_BTNTEXT                     18            Text color on push buttons
  COLOR_INACTIVECAPTIONTEXT         19            Color of text in an inactive caption
  COLOR_BTNHIGHLIGHT                20            Highlight color for 3-D display elements
  COLOR_3DDKSHADOW                  21            Darkest shadow color for 3-D display elements
  COLOR_3DLIGHT                     22            Second lightest 3-D color after 3DHighlight,
*Light color for three-dimensional display elements (for edges facing the light source.)
  COLOR_INFOTEXT                    23            Color of text in ToolTips
  COLOR_INFOBK                      24            Background color of ToolTips
  COLOR_HOTLIGHT                    25            Color for a hot-tracked item. Single clicking
*a hot-tracked item executes the item. COLOR_GRADIENTACTIVECAPTION       26         Right
*side color in the color gradient of an active window's title bar. COLOR_ACTIVECAPTION
*27         specifies the left side color. COLOR_GRADIENTINACTIVECAPTION     28 Right side
*color in the color gradient of an inactive window's title bar. COLOR_INACTIVECAPTION 29
*specifies the left side color. XPCOLOR_TOOLBAR_FACE              30            Toolbar
*background color. XPCOLOR_HIGHLIGHT                 31            Menu item selected color.
  XPCOLOR_HIGHLIGHT_BORDER          32            Menu item selected border color.
  XPCOLOR_HIGHLIGHT_PUSHED          33            Menu item pushed color.
  XPCOLOR_ICONSHADDOW               34            Menu item icon shadow.
  XPCOLOR_MENUBAR_GRAYTEXT          35            Menu bar gray text
  XPCOLOR_GRAYTEXT                  35            Menu item disabled text color.
  XPCOLOR_HIGHLIGHT_CHECKED         36            Menu item checked color.
  XPCOLOR_HIGHLIGHT_CHECKED_BORDER  37            An RGB value that represents the menu item
*checked border color. XPCOLOR_TOOLBAR_GRIPPER           38            Toolbar gripper color.
  XPCOLOR_SEPARATOR                 39            Toolbar separator color.
  XPCOLOR_DISABLED                  40            Menu icon disabled color.
  XPCOLOR_MENUBAR_FACE              41            Menu item text background color.
  XPCOLOR_MENUBAR_EXPANDED          42            Hidden menu commands background color.
  XPCOLOR_MENUBAR_BORDER            43            Menu border color.
  XPCOLOR_MENUBAR_TEXT              44            Menu item text color.
  XPCOLOR_HIGHLIGHT_TEXT            45            Menu item selected text color.
  XPCOLOR_CHECKED_TEXT              45          Color for text displayed in a checked button.
  XPCOLOR_TOOLBAR_TEXT              46            Toolbar text color.
  XPCOLOR_PUSHED_TEXT               47            Toolbar pushed text color.
  XPCOLOR_TAB_INACTIVE_BACK         48            Inactive tab background color.
  XPCOLOR_TAB_INACTIVE_TEXT         49            Inactive tab text color.
  XPCOLOR_HIGHLIGHT_PUSHED_BORDER   50            An RGB value that represents the border color
*for pushed in 3D elements. XPCOLOR_3DFACE                    51            Face color for
*three- dimensional display elements and for dialog box backgrounds. XPCOLOR_3DSHADOW 52 Shadow
*color for three-dimensional display elements (for edges facing away from the light source).
  XPCOLOR_EDITCTRLBORDER              53            Color for the border color of edit controls.
  XPCOLOR_FRAME                     54          Office 2003 frame color.
  XPCOLOR_SPLITTER_FACE             55            Splitter face color.
  XPCOLOR_LABEL                     56            Color for label control (xtpControlLabel)
  XPCOLOR_STATICFRAME               57            Static frame color
  XPCOLOR_HIGHLIGHT_DISABLED_BORDER 58            Highlighted disabled border color
  XPCOLOR_SHADOW_FACTOR             59            Shadow factor color
  XPCOLOR_TOOLBAR_GRAYTEXT          60            Toolbar gray text color
  XPCOLOR_FLOATBAR_BORDER           61            Floatbar border color
  XPCOLOR_LAST                      62            The last color value
Returns
The red, green, blue (RGB) color value of the given element.

◆ GradientFill()

void GradientFill | ( | CDC * | pDC,
 |  | LPRECT | lpRect,
 |  | COLORREF | crFrom,
 |  | COLORREF | crTo,
 |  | BOOL | bHorz,
 |  | LPCRECT | lpRectClip = NULL )

Gradient fills the rectangle.

Parameters
pDC | Pointer to a valid device context.
lpRect | Specifies the rectangle in logical units.
crFrom | Start color.
crTo | Endpoint color.
bHorz | TRUE to fill horizontally.
lpRectClip | Pointer to a RECT structure that contains a clipping rectangle. This parameter is optional and may be set to NULL.

◆ HorizontalLine()

void HorizontalLine | ( | CDC * | pDC,
 |  | int | x0,
 |  | int | y0,
 |  | int | x1,
 |  | COLORREF | clrPen )

Call this member function to draw a horizontal line using the specified coordinages and RGB color value.

Parameters
pDC | Pointer to a valid device context.
x0 | Specifies the logical x coordinate of the start position.
y0 | Specifies the logical y coordinate of the start position.
x1 | Specifies the logical x coordinate of the endpoint for the line.
clrPen | RGB value that specifies the color used to paint the line.

◆ IsUseSystemAccentColorEnabled()

BOOL IsUseSystemAccentColorEnabled ( ) const

Determines whether xtpApplicationUseSystemAccentColor application ambient property is set.

Returns
TRUE if use of system accent color is required, FALSE otherwise.

◆ Line() [1/3]

void Line | ( | CDC * | pDC,
 |  | CPoint | p0,
 |  | CPoint | p1 )

Draws a line.

Parameters
pDC | Pointer to a valid device context.
p0 | Specifies the logical coordinates of the start position.
p1 | Specifies the logical coordinates of the endpoint for the line.

◆ Line() [2/3]

void Line | ( | CDC * | pDC,
 |  | int | x0,
 |  | int | y0,
 |  | int | x1,
 |  | int | y1,
 |  | COLORREF | clrPen )

Draws a line.

Parameters
pDC | Pointer to a valid device context.
x0 | Specifies the logical x coordinate of the start position.
y0 | Specifies the logical y coordinate of the start position.
x1 | Specifies the logical x coordinate of the endpoint for the line.
y1 | Specifies the logical y coordinate of the endpoint for the line.
clrPen | RGB value that specifies the color used to paint the line.

◆ Line() [3/3]

void Line | ( | CDC * | pDC,
 |  | int | x0,
 |  | int | y0,
 |  | int | x1,
 |  | int | y1,
 |  | const int | nPen )

Draws a line.

Parameters
pDC | Pointer to a valid device context.
x0 | Specifies the logical x coordinate of the start position.
y0 | Specifies the logical y coordinate of the start position.
x1 | Specifies the logical x coordinate of the endpoint for the line.
y1 | Specifies the logical y coordinate of the endpoint for the line.
nPen | Specifies the index of the color used to paint the line.

◆ Pixel()

void Pixel | ( | CDC * | pDC,
 |  | int | xPos,
 |  | int | yPos,
 |  | int | nPen )

Sets the pixel at the point.

Parameters
pDC | Pointer to a valid device context.
xPos | Specifies the logical x coordinate of the point to be set.
yPos | Specifies the logical y coordinate of the point to be set.
nPen | Specifies the color used to paint the point.

◆ Rectangle() [1/2]

void Rectangle | ( | CDC * | pDC,
 |  | LPCRECT | rc,
 |  | COLORREF | clrPen,
 |  | COLORREF | clrBrush )

Draws a rectangle.

Parameters
pDC | Pointer to a valid device context.
rc | Specifies the rectangle in logical units.
clrPen | Specifies the color used to paint the rectangle.
clrBrush | Specifies the color used to fill the rectangle.

◆ Rectangle() [2/2]

void Rectangle | ( | CDC * | pDC,
 |  | LPCRECT | rc,
 |  | int | nPen,
 |  | const int | nBrush )

Draws a rectangle.

Parameters
pDC | Pointer to a valid device context.
rc | Specifies the rectangle in logical units.
nPen | Specifies the color used to paint the rectangle.
nBrush | Specifies the color used to fill the rectangle.

◆ ReleaseInstance()

static void AFX_CDECL ReleaseInstance ( )
static

Decrements global paint manager's reference counter and deletes its instance when the reference counter reaches 0.

Does nothing if global paint manager has not been created.

Returns

◆ RequiresResourceImages()

AFX_INLINE BOOL RequiresResourceImages ( )
virtual

Used by the paint manager to determine if the theme requires a resource DLL to load image and color information.

Returns
Returns TRUE if the theme requires a resource DLL, otherwise FALSE.

Reimplemented in CXTPCommandBarsOffice2013Theme, CXTPCommandBarsVisualStudio2012Theme, and CXTPResourceTheme.

◆ RoundRect()

void RoundRect | ( | CDC * | pDC,
 |  | LPCRECT | rc,
 |  | COLORREF | clrPen,
 |  | COLORREF | clrBrush )

Draws a rectangle.

Parameters
pDC | Pointer to a valid device context.
rc | Specifies the rectangle in logical units.
clrPen | Specifies the color used to paint the rectangle.
clrBrush | Specifies the color used to fill the rectangle.

◆ SetAnimationDelay()

AFX_INLINE void SetAnimationDelay | ( | int | nAnimationSteps,
 |  | int | nAnimationTime )

Call this method to set animation delay.

Parameters
nAnimationSteps | Number of steps to take during animation.
nAnimationTime | Amount of time to rest, in milliseconds, between each step.

◆ SetColors()

void SetColors | ( | int | cElements,
 |  | CONST INT * | lpaElements,
 |  | CONST COLORREF * | lpaRgbValues )

Call this member to set the colors for each element to the color in the specified color array.

Parameters
cElements | Number of elements in the array.
lpaElements | Array of elements.
lpaRgbValues | Array of RGB values.

◆ SetCommandBarRegion()

virtual void SetCommandBarRegion ( CXTPCommandBar * pCommandBar )
virtual

Call this method to set the bounding region of a pop-up bar.

Parameters
pCommandBar Pointer to the pop-up bar whose bounding region must be set.

Reimplemented in CXTPRibbonTheme.

◆ SetCommandBarsFontIndirect()

void SetCommandBarsFontIndirect | ( | LOGFONT * | pLogFont,
 |  | BOOL | bUseStandardFont = FALSE )

Call this member to set command bar's font.

Parameters
pLogFont | New LOGFONT to use for text.
bUseStandardFont | When calling SetCommandBarsFontIndirect, always use FALSE, this will indicate that pLogFont should be used as the new font.

◆ SetCustomTheme()

static void AFX_CDECL SetCustomTheme ( CXTPPaintManager * pTheme )
static

Call this member to set a custom theme.

Parameters
pTheme Theme to be set.
Returns

◆ SetGlobalPaintManager()

static void AFX_CDECL SetGlobalPaintManager ( CXTPPaintManager * pPaintManager )
static

Call this method to set the pointer to the global paint manager.

Parameters
pPaintManager A new global paint manager pointer.
Returns
See also
GetGlobalPaintManager, XTPPaintManager

◆ SetImageHandle()

virtual void SetImageHandle | ( | HMODULE | hResource,
 |  | LPCTSTR | lpszIniFileName )
 virtual

Specifies the resource that contains the bitmaps to be loaded for the theme.

This allows images to be loaded from something other than bitmap files.

Parameters
hResource | Handle to a visual style .dll file handle or some other resource that contains the images to load for the theme.
lpszIniFileName | String identifier of .ini file with color specifications.

The images are the bitmaps that represent all the visual components of the Ribbon Bar. For example tab buttons, group buttons, menu buttons, toolbar buttons, option button, toolbar dropdown, etc. The images are loaded using LoadImage and are stored in the m_pImages image collection. Images for the Office 2007 theme can be found in the /Source/Ribbon/Res folder.

Example:

XTPPaintManager()->SetImageHandle(XTPSkinManager()->GetResourceFile()->GetModuleHandle());
See also
LoadImage, m_pImages

Reimplemented in CXTPResourceTheme.

◆ SetLunaTheme()

void SetLunaTheme ( XTPCurrentSystemTheme systemTheme )

Call this method to force system theme.

Parameters
systemTheme Theme to use. Can be any of the values listed in the Remarks section.

Theme can be one of the following: xtpSystemThemeUnknown: Disables luna theme support. xtpSystemThemeBlue: Enables blue theme. xtpSystemThemeOlive: Enables olive theme. xtpSystemThemeSilver: Enables silver theme.

◆ SetTheme()

static void AFX_CDECL SetTheme ( XTPPaintTheme paintTheme )
static

Call this member to switch the visual theme of the Command Bars.

Parameters
paintTheme Theme to be set. Can be any of the values listed in the Remarks section.

paintTheme can be one of following: xtpThemeOfficeXP: Enables Office XP theme. xtpThemeOffice2000: Enables Office 2000 theme. xtpThemeOffice2003: Enables Office 2003 theme. xtpThemeNativeWinXP: Enables Windows XP themes support. xtpThemeVisualStudio2005: Enables Visual Studio 2005 theme.

Returns

◆ StripMnemonics()

static void AFX_CDECL StripMnemonics ( CString & strClear )
static

This member function will search a string, strip off the mnemonic '&', and reformat the string.

Parameters
strClear Text to strip.
Returns

◆ Triangle()

static void AFX_CDECL Triangle | ( | CDC * | pDC,
 |  | CPoint | pt0,
 |  | CPoint | pt1,
 |  | CPoint | pt2,
 |  | COLORREF | clr )
 static

Draws a triangle.

Parameters
pDC | Pointer to a valid device context.
pt0 | Specifies the logical coordinates of the first point.
pt1 | Specifies the logical coordinates of the second point.
pt2 | Specifies the logical coordinates of the third point.
clr | Color to fill.
Returns

◆ UpdateRTLCaption()

virtual void UpdateRTLCaption ( CString & strCaption )
virtual

This method is called to prepare a caption for Right-To-Left draw.

Parameters
strCaption Caption to modify.

◆ UseOfficeFont()

void UseOfficeFont ( bool bUseOfficeFont )

Call this method to use Tahoma font despite system metrics.

Parameters
bUseOfficeFont TRUE to use office font.

◆ VerticalLine()

void VerticalLine | ( | CDC * | pDC,
 |  | int | x0,
 |  | int | y0,
 |  | int | y1,
 |  | COLORREF | clrPen )

Call this member function to draw a vertical line using the specified coordinages and RGB color value.

Parameters
pDC | Pointer to a valid device context
x0 | Specifies the logical x coordinate of the start position.
y0 | Specifies the logical y coordinate of the start position.
y1 | Specifies the logical y coordinate of the endpoint for the line.
clrPen | RGB value that specifies the color used to paint the line.
The documentation for this class was generated from the following file:
  • XTPPaintManager.h


Toolkit Pro: CXTPPaintManager::CLogFont Struct Reference

  • CXTPPaintManager
  • CLogFont
Public Member Functions | List of all members
CXTPPaintManager::CLogFont Struct Reference

CLogFont is a self initializing LOGFONT derived class. More...

Public Member Functions

CLogFont ()
Constructs a CLogFont object.

Detailed Description

CLogFont is a self initializing LOGFONT derived class.

It will allow you to create or copy a LOGFONT object, and defines the attributes of a font.

The documentation for this struct was generated from the following file:
  • XTPPaintManager.h


Toolkit Pro: CXTPPaintManagerColor Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPPaintManagerColor Class Reference

The CXTPPaintManagerColor class is used to manage COLORREF values for determining default and application defined colors. More...

Public Member Functions

CXTPPaintManagerColor ()
Constructs a CXTPPaintManagerColor object and initializes default and application defined colors for the class.
CXTPPaintManagerColor (COLORREF clr)
Constructs a CXTPPaintManagerColor object and initializes default and application defined colors for the class.
virtual | ~CXTPPaintManagerColor ()
Handles object destruction.
BOOL | IsDefaultValue () const
This member function determines if application defined colors are used.
BOOL | IsStandardValue () const
This member function determines if the standard color is set and used.
BOOL | IsCustomValue () const
This member function determines if the custom color is set and used.
COLORREF | GetStandardColor () const
This member function will retrieves the default color for the CXTPPaintManagerColor class.
void | SetCustomValue (COLORREF clr)
This member function will sets the application defined color for the CXTPPaintManagerColor class.
void | SetStandardValue (COLORREF clr)
This member function will sets the default color for the CXTPPaintManagerColor class.
void | SetDefaultValue ()
This member function will remove the application defined color (if any) that was defined for the CXTPPaintManagerColor class.
operator COLORREF () const
Operator used to retrieve an RGB color value that represents the current color defined for the CXTPPaintManagerColor class.
const CXTPPaintManagerColor & | operator= (COLORREF clr)
This operator assigns a new COLORREF value for the application defined color.
const CXTPPaintManagerColor & | operator= (const CXTPPaintManagerColor &refclr)
This operator assigns a new COLORREF value for the application defined color.
virtual void | Serialize (CArchive &ar)
This method reads or writes data from or to an archive.

Protected Attributes

COLORREF | m_clrStandardValue
Standard color.
COLORREF | m_clrCustomValue
Application defined color.

Detailed Description

The CXTPPaintManagerColor class is used to manage COLORREF values for determining default and application defined colors.

Constructor & Destructor Documentation

◆ CXTPPaintManagerColor() [1/2]

CXTPPaintManagerColor ( )

Constructs a CXTPPaintManagerColor object and initializes default and application defined colors for the class.

See also
SetStandardValue, SetCustomValue

◆ CXTPPaintManagerColor() [2/2]

CXTPPaintManagerColor ( COLORREF clr )

Constructs a CXTPPaintManagerColor object and initializes default and application defined colors for the class.

Parameters
clr n RGB value that represents default color to set.
See also
SetStandardValue, SetCustomValue

Member Function Documentation

◆ GetStandardColor()

COLORREF GetStandardColor ( ) const

This member function will retrieves the default color for the CXTPPaintManagerColor class.

Returns
An RGB value that represents the default color.

◆ IsCustomValue()

BOOL IsCustomValue ( ) const

This member function determines if the custom color is set and used.

Returns
TRUE if custom color is set, otherwise FALSE.

◆ IsDefaultValue()

BOOL IsDefaultValue ( ) const

This member function determines if application defined colors are used.

Returns
TRUE if application defined colors are used, otherwise FALSE.

◆ IsStandardValue()

BOOL IsStandardValue ( ) const

This member function determines if the standard color is set and used.

Returns
TRUE if standard color is set and custom color is not set, otherwise FALSE.

◆ operator COLORREF()

operator COLORREF ( ) const

Operator used to retrieve an RGB color value that represents the current color defined for the CXTPPaintManagerColor class.

Returns
An RGB value that represents the current color.

◆ operator=() [1/2]

const CXTPPaintManagerColor & operator= ( COLORREF clr )

This operator assigns a new COLORREF value for the application defined color.

Parameters
clr RGB value that represents application defined color to set. color to set.
Returns
Self reference.
See also
SetStandardValue, SetCustomValue

◆ operator=() [2/2]

const CXTPPaintManagerColor & operator= ( const CXTPPaintManagerColor & refclr )

This operator assigns a new COLORREF value for the application defined color.

Parameters
refclr Reference to CXTPPaintManagerColor value that represents application defined color to set.
Returns
Self reference.
See also
SetStandardValue, SetCustomValue

◆ Serialize()

virtual void Serialize ( CArchive & ar )
virtual

This method reads or writes data from or to an archive.

Parameters
ar A CArchive object to serialize to or from.

◆ SetCustomValue()

void SetCustomValue ( COLORREF clr )

This member function will sets the application defined color for the CXTPPaintManagerColor class.

Parameters
clr n RGB value that represents application defined color to set.

◆ SetStandardValue()

void SetStandardValue ( COLORREF clr )

This member function will sets the default color for the CXTPPaintManagerColor class.

Parameters
clr n RGB value that represents default color to set.
The documentation for this class was generated from the following file:
  • XTPColorManager.h


Toolkit Pro: CXTPPaintManagerColorGradient Class Reference

Public Member Functions | Public Attributes | List of all members
CXTPPaintManagerColorGradient Class Reference

The CXTPPaintManagerColorGradient class is used to manage COLORREF values for determining light and dark gradient colors. More...

Public Member Functions

CXTPPaintManagerColorGradient ()
Constructs a CXTPPaintManagerColorGradient object and initializes default dark and light colors equal to the specified COLORREF value.
CXTPPaintManagerColorGradient (const COLORREF clr)
Constructs a CXTPPaintManagerColorGradient object and initializes default dark and light colors equal to the specified COLORREF value.
CXTPPaintManagerColorGradient (const CXTPPaintManagerColor clr)
Constructs a CXTPPaintManagerColorGradient object and initializes default dark and light colors equal to the specified COLORREF value.
CXTPPaintManagerColorGradient (COLORREF clrLight, COLORREF clrDark)
Constructs a CXTPPaintManagerColorGradient object and initializes default dark and light colors equal to the specified COLORREF value.
virtual | ~CXTPPaintManagerColorGradient ()
Handles object destruction.
void | SetStandardValue (const COLORREF clr)
This member function sets the value of the default dark and light colors equal to the specified COLORREF value.
void | SetStandardValue (CXTPPaintManagerColorGradient &clrref)
This member function sets the value of the default dark and light colors equal to the specified COLORREF value.
void | SetStandardValue (COLORREF clrLight, COLORREF clrDark, float fGradientFactor=0.5f)
This member function sets the value of the default dark and light colors equal to the specified COLORREF value.
void | SetCustomValue (const COLORREF clr)
This member function will sets the application defined 4 color gradient values for the CXTPPaintManagerColorGradient class.
void | SetCustomValue (CXTPPaintManagerColorGradient &clrref)
This member function will sets the application defined 4 color gradient values for the CXTPPaintManagerColorGradient class.
void | SetCustomValue (COLORREF clrLight, COLORREF clrDark)
This member function will sets the application defined 4 color gradient values for the CXTPPaintManagerColorGradient class.
operator COLORREF () const
Operator used to retrieve an RGB color value that represents the dark gradient color used for the CXTPPaintManagerColorGradient class.
operator CXTPPaintManagerColor & ()
Retrieves a reference to the CXTPPaintManagerColor dark gradient color member.
const CXTPPaintManagerColorGradient & | operator= (const CXTPPaintManagerColorGradient &refSrc)
This operator copy all values from the specified source object;.
BOOL | IsNull () const
Determines if the CXTPPaintManagerColorGradient object's colors have been initialized.
virtual void | Serialize (CArchive &ar)
This method reads or writes data from or to an archive.

Public Attributes

CXTPPaintManagerColor | clrLight
Light color.
CXTPPaintManagerColor | clrDark
Dark color.
float | fGradientFactor
Gradient divider factor.

Detailed Description

The CXTPPaintManagerColorGradient class is used to manage COLORREF values for determining light and dark gradient colors.

See also
CXTPPaintManagerColor

Constructor & Destructor Documentation

◆ CXTPPaintManagerColorGradient() [1/4]

CXTPPaintManagerColorGradient ( )

Constructs a CXTPPaintManagerColorGradient object and initializes default dark and light colors equal to the specified COLORREF value.

See also
SetStandardValue, SetCustomValue

◆ CXTPPaintManagerColorGradient() [2/4]

CXTPPaintManagerColorGradient ( const COLORREF clr )

Constructs a CXTPPaintManagerColorGradient object and initializes default dark and light colors equal to the specified COLORREF value.

Parameters
clr An RGB COLORREF value representing the dark and light colors.
See also
SetStandardValue, SetCustomValue

◆ CXTPPaintManagerColorGradient() [3/4]

CXTPPaintManagerColorGradient ( const CXTPPaintManagerColor clr )

Constructs a CXTPPaintManagerColorGradient object and initializes default dark and light colors equal to the specified COLORREF value.

Parameters
clr An RGB COLORREF value representing the dark and light colors.
See also
SetStandardValue, SetCustomValue

◆ CXTPPaintManagerColorGradient() [4/4]

CXTPPaintManagerColorGradient | ( | COLORREF | clrLight,
 |  | COLORREF | clrDark )

Constructs a CXTPPaintManagerColorGradient object and initializes default dark and light colors equal to the specified COLORREF value.

Parameters
clrLight | An RGB COLORREF value representing the light color.
clrDark | An RGB COLORREF value representing the dark color.
See also
SetStandardValue, SetCustomValue

Member Function Documentation

◆ IsNull()

BOOL IsNull ( ) const

Determines if the CXTPPaintManagerColorGradient object's colors have been initialized.

Returns
TRUE if both light and dark gradient colors have not been initialized, otherwise FALSE.

◆ operator COLORREF()

operator COLORREF ( ) const

Operator used to retrieve an RGB color value that represents the dark gradient color used for the CXTPPaintManagerColorGradient class.

Returns
An RGB value that represents the dark gradient color.

◆ operator CXTPPaintManagerColor &()

operator CXTPPaintManagerColor & ( )

Retrieves a reference to the CXTPPaintManagerColor dark gradient color member.

Returns
A reference to the CXTPPaintManagerColor dark gradient color used for the CXTPPaintManagerColorGradient class.

◆ operator=()

const CXTPPaintManagerColorGradient & operator= ( const CXTPPaintManagerColorGradient & refSrc )

This operator copy all values from the specified source object;.

Parameters
refSrc Reference to CXTPPaintManagerColorGradient source object.
Returns
Self reference.
See also
SetStandardValue, SetCustomValue

◆ Serialize()

virtual void Serialize ( CArchive & ar )
virtual

This method reads or writes data from or to an archive.

Parameters
ar A CArchive object to serialize to or from.

◆ SetCustomValue() [1/3]

void SetCustomValue | ( | COLORREF | clrLight,
 |  | COLORREF | clrDark )

This member function will sets the application defined 4 color gradient values for the CXTPPaintManagerColorGradient class.

Parameters
clrLight | An RGB COLORREF value representing the light color.
clrDark | An RGB COLORREF value representing the dark color.

◆ SetCustomValue() [2/3]

void SetCustomValue ( const COLORREF clr )

This member function will sets the application defined 4 color gradient values for the CXTPPaintManagerColorGradient class.

Parameters
clr An RGB COLORREF value representing the dark and light colors.

◆ SetCustomValue() [3/3]

void SetCustomValue ( CXTPPaintManagerColorGradient & clrref )

This member function will sets the application defined 4 color gradient values for the CXTPPaintManagerColorGradient class.

Parameters
clrref An reference to CXTPPaintManagerColorGradient value representing the dark and light colors.

◆ SetStandardValue() [1/3]

void SetStandardValue | ( | COLORREF | clrLight,
 |  | COLORREF | clrDark,
 |  | float | fGradientFactor = 0.5f )

This member function sets the value of the default dark and light colors equal to the specified COLORREF value.

Parameters
clrLight | An RGB COLORREF value representing the light color.
clrDark | An RGB COLORREF value representing the dark color.
fGradientFactor | Gradient divider factor

◆ SetStandardValue() [2/3]

void SetStandardValue ( const COLORREF clr )

This member function sets the value of the default dark and light colors equal to the specified COLORREF value.

Parameters
clr An RGB COLORREF value representing the dark and light colors.

◆ SetStandardValue() [3/3]

void SetStandardValue ( CXTPPaintManagerColorGradient & clrref )

This member function sets the value of the default dark and light colors equal to the specified COLORREF value.

Parameters
clrref An reference to CXTPPaintManagerColorGradient value representing the dark and light colors.
The documentation for this class was generated from the following file:
  • XTPColorManager.h


Toolkit Pro: CXTPPaintManagerFont Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPPaintManagerFont Class Reference

PaintManagers used CFont wrapper. More...

Public Member Functions

CXTPPaintManagerFont ()
Constructs a CXTPPaintManagerFont object.
BOOL | SetCustomFont (const LOGFONT *lpLogFont)
Sets application defined font.
void | EnableCustomFont (BOOL bEnable=TRUE)
Call this method to enable/disable use of custom font.
BOOL | SetStandardFont (const LOGFONT *lpLogFont)
Sets paint manager's font.

Protected Attributes

BOOL m_bStandardFont
TRUE to use standard font;.

Detailed Description

PaintManagers used CFont wrapper.

Member Function Documentation

◆ EnableCustomFont()

void EnableCustomFont ( BOOL bEnable = TRUE )

Call this method to enable/disable use of custom font.

Parameters
bEnable TRUE if custom font is to be used.
See also
SetCustomFont, SetStandardFont

◆ SetCustomFont()

BOOL SetCustomFont ( const LOGFONT * lpLogFont )

Sets application defined font.

Parameters
lpLogFont Application defined font.
Returns
TRUE if successful, otherwise FALSE.

◆ SetStandardFont()

BOOL SetStandardFont ( const LOGFONT * lpLogFont )

Sets paint manager's font.

Parameters
lpLogFont PaintManager's defined font.
Returns
TRUE if successful, otherwise FALSE.
The documentation for this class was generated from the following file:
  • XTPPaintManager.h


Toolkit Pro: CXTPPasswordPeek Class Reference

Public Member Functions | List of all members
CXTPPasswordPeek Class Reference

CXTPPasswordPeek is a CXTPEdit derived class. More...

Inheritance diagram for CXTPPasswordPeek:
[legend]

Public Member Functions

CXTPPasswordPeek ()
Constructs a CXTPPasswordPeek object.
virtual | ~CXTPPasswordPeek ()
Destroys a CXTPPasswordPeek object, handles cleanup and deallocation.
CXTPImageManager * GetImageManager ()
Call this method to retrieve the image manager.
void | SetImageManager (CXTPImageManager *pImageManager)
Call this member to set the specified image manager.
void | PeekButtonEnable (BOOL bEnable=TRUE)
Call this member to enable or disable peek button.
BOOL | IsPeekButtonEnabled ()
Call this member to get the state of the peek button.
virtual void | InitIcons ()
This member function is used to icons initialization.
virtual void | OnDrawButton (CDC *pDC, CRect rect, BOOL bIsButtonPressed, BOOL bIsButtonHot)
This method is used to draw the peek button.
virtual void | OnChangeLayout ()
This method is used to configure peek button layout.
- Public Member Functions inherited from CXTPEdit
CXTPEdit ()
Constructs a CXTPEdit object.
virtual | ~CXTPEdit ()
Destroys a CXTPEdit object, handles cleanup and deallocation.
BOOL | SetEditMask (LPCTSTR lpszMask, LPCTSTR lpszLiteral, LPCTSTR lpszDefault=NULL)
This member function will set the mask for the edit control.
void | SetPattern (LPCTSTR lpszPattern)
Call this member function to set the pattern for the edit mask.
virtual BOOL | CanPaste ()
Call this member function to determine if the Clipboard contains information that can be pasted into this edit view.
BOOL | HasSelection () const
Call this member function to determine if a selection has been made.
void | AdjustBuddyRect (CWnd *pBuddy, CRect &rcUpDown, int nAlignment)
Called by the framework to adjust the size of the area to draw the buddy control borders on.
void | DrawBuddyBorders (CWnd *pBuddy, CDC *pDC, CRect rc, int nAlignment)
Called by the framework to draw the borders for the associated buddy window.
virtual void | RefreshMetrics ()
This member is called to update the color, text and other visual elements of the control.
virtual void | SetTheme (XTPControlTheme nTheme)
Call this member to switch the visual theme of the control.
XTPControlTheme GetThemeID ()
Call this member function to get the style for the theme.
CXTPEditTheme * GetTheme ()
Call this member to retrieve a pointer to the current theme.
BOOL | GetFlatStyle () const
Gets the flat style appearance of the button control.
void | SetFlatStyle (BOOL bFlatStyle=TRUE)
Sets the flat style appearance of the button control.
BOOL | GetUseVisualStyle () const
Determines if the control is drawn using visual styles/SkinFramework, if supported.
void | SetUseVisualStyle (BOOL bUseVisualStyle=TRUE)
Enables Windows XP visual styles for the control.
BOOL | IsPatternValid ()
Called by the framework to determine if the pattern set using SetPattern() is valid.
void | ShowThemedBorder (BOOL bShowThemedBorder)
Call this member function to enable/disable theme border display.
BOOL | IsHighlighted () const
Call this member function to determine if the edit state is highlighted, meaning that the mouse cursor is currently hovering over the control.
BOOL | IsFocused () const
Call this member function to determine if the edit-box has input focus.
BOOL | IsFlatStyle () const
Gets the flat style appearance of the edit control.
BOOL | ShowBorder () const
Call this member to determine if non-client borders are displayed.
- Public Member Functions inherited from CXTPMaskEditT< CEdit >
CXTPMaskEditT ()
Constructs a CXTPMaskEditT object.
void | SetUseMask (BOOL bUseMask)
Call this member function to enable or disable the mask for the mask edit control.
BOOL | CanUseMask () const
This member function is called to determine if the mask for the edit control can be used.
void | SetOverType (BOOL bOverType)
This member function is called to enable or disable type over, also known as insert mode.
BOOL | CanOverType () const
This member function is called to determine if type over has been enabled.
BOOL | PosInRange (int iPos) const
This member function is called to determine if the index specified by 'iPos' is a valid index for the currently displayed edit text.
TCHAR | GetPromptChar () const
This member function retrieves the character that is currently used as the mask prompt.
CString | GetPromptString (int nLength) const
This helper member function retrieves the string contains nLength prompt characters.
void | SetPromptChar (TCHAR ch, BOOL bAutoReplace=TRUE)
This member function is called to set the prompt character that is displayed to the user that indicates the field can be edited.
afx_msg BOOL | MaskCut ()
This member function is called to perform a cut operation using the currently selected text.
afx_msg BOOL | MaskCopy ()
This member function is called to perform a copy operation using the currently selected text.
void | MaskReplaceSel (LPCTSTR lpszNewText)
This member function is called to perform a replace operation using the currently selected text.
afx_msg BOOL | MaskPaste ()
This member function is called to perform a paste operation using the current clipboard text.
void | MaskDeleteSel ()
This member function is called to delete the selection.
afx_msg BOOL | MaskClear ()
This member function is called to clear the current text selection.
afx_msg BOOL | MaskUndo ()
This member function is called to undo the previous action.
afx_msg void | MaskSelectAll ()
This member function is called to select all text in the mask edit control.
BOOL | IsModified () const
This member function is called to determine if the text has been modified.
void | SetMaskedText (LPCTSTR lpszMaskedText, int iPos=0, BOOL bUpdateWindow=TRUE)
This method called to set masked text for the edit control.
TCHAR | ConvertUnicodeAlpha (TCHAR nChar, BOOL bUpperCase) const
Converts character to Upper/Lower case.
virtual BOOL | CheckChar (TCHAR &nChar, int nPos)
This member function is used internally to validate the character indicated by 'nChar'.
virtual BOOL | ProcessMask (TCHAR &nChar, int nEndPos)
This member function is used internally to process the character passed in by 'nChar' whose index is specified by 'nEndPos'.
virtual BOOL | PreTranslateMessage (MSG *pMsg)
Used by class CWinApp to translate window messages before they are dispatched to theTranslateMessage andDispatchMessage Windows functions.
void | DeleteCharAt (int iPos)
Deletes character in specified position.
void | InsertCharAt (int iPos, TCHAR nChar)
Inserts character to specified position.
BOOL | CopyToClipboard (const CString &strText)
Copies text to system clipboard.
CString | GetMaskedText (int nStartPos=0, int nEndPos=-1) const
Retrieves masked text of the control.

Additional Inherited Members

- Protected Member Functions inherited from CXTPEdit
HBRUSH | GetClientBrush (CDC *pDC)
Retrieves a handle to the client background brush.
void | RedrawEdit ()
Called by the framework to redraw the edit control.
void | RedrawFocusedFrame ()
Called by the framework to redraw the focus rectangle for the edit control.
- Protected Member Functions inherited from CXTPMaskEditT< CEdit >
virtual BOOL | OnCommand (WPARAM wParam, LPARAM lParam)
The framework calls this member function when the user selects an item from a menu.
- Protected Attributes inherited from CXTPEdit
CXTPEditTheme * | m_pTheme
Pointer to the current edit theme.
BOOL | m_bPreSubclassInit
TRUE if the control has been subclassed.
BOOL | m_bShowBorder
TRUE if non-client borders are displayed.
BOOL | m_bHighlighted
TRUE when the mouse is hovering over the control.
BOOL | m_bFocused
TRUE when the control has input focus.
CXTPRegExp * | m_pRegExp
Pointer to the CXTPRegExp object for this control.
- Protected Attributes inherited from CXTPMaskEditT< CEdit >
int | m_nStartChar
Current position of the first character in the current selection.
int | m_nEndChar
Current position of the first non-selected character past the end of the current selection.
BOOL | m_bUseMask
TRUE to use the edit mask.
BOOL | m_bOverType
TRUE to over type the text, set with VK_INSERT key press.
BOOL | m_bRedo
TRUE to redo, or FALSE to undo.
BOOL | m_bModified
TRUE if mask edit has been modified.
TCHAR | m_chPrompt
Prompt character used to identify the text entry.
CString | m_strMask
Buffer that holds the actual edit mask value.
CString | m_strDefault
Contains the edit controls default display text.
CString | m_strUndoBuffer
Holds the contents of the undo buffer.
CString | m_strRedoBuffer
Holds the contents of the redo buffer.
CString | m_strWindowText
Buffer that holds the actual edit text.
CString | m_strLiteral
Literal format that restricts where the user can enter text.
BOOL | m_bUpdateUndo
TRUE to update undo.

Detailed Description

CXTPPasswordPeek is a CXTPEdit derived class.

Member Function Documentation

◆ GetImageManager()

CXTPImageManager * GetImageManager ( )

Call this method to retrieve the image manager.

Returns
A pointer to a CXTPImageManager object.

◆ IsPeekButtonEnabled()

BOOL IsPeekButtonEnabled ( )

Call this member to get the state of the peek button.

Returns
TRUE if the item is enabled, otherwise FALSE.

◆ OnDrawButton()

virtual void OnDrawButton | ( | CDC * | pDC,
 |  | CRect | rect,
 |  | BOOL | bIsButtonPressed,
 |  | BOOL | bIsButtonHot )
 virtual

This method is used to draw the peek button.

Parameters
pDC | Pointer to a valid device context.
rect | Rect of peek button.
bIsButtonPressed | TRUE if peek button pressed.
bIsButtonHot | TRUE if peek button hot.

◆ PeekButtonEnable()

void PeekButtonEnable ( BOOL bEnable = TRUE )

Call this member to enable or disable peek button.

Parameters
bEnable TRUE to enable the item, FALSE to disable the item.
See also
IsPeekButtonEnabled

◆ SetImageManager()

void SetImageManager ( CXTPImageManager * pImageManager )

Call this member to set the specified image manager.

Parameters
pImageManager Pointer to a CXTPImageManager object to be set.
The documentation for this class was generated from the following file:
  • XTPPasswordPeek.h


Toolkit Pro: CXTPPen Class Reference

Public Member Functions | List of all members
CXTPPen Class Reference

Provides a convenient object oriented interface for HPEN GDI object and uses GDI handle caching. More...

Inheritance diagram for CXTPPen:
[legend]

Public Member Functions

CXTPPen ()
Constructs an empty CXTPPen object.
CXTPPen (int nPenStyle, int nWidth, COLORREF crColor)
Constructs a CXTPPen object.
CXTPPen (int nPenStyle, int nWidth, const LOGBRUSH *pLogBrush, int nStyleCount=0, const DWORD *lpStyle=NULL)
Constructs a CXTPPen object.
~CXTPPen ()
Handles CXTPPen object destruction.
BOOL | CreatePen (int nPenStyle, int nWidth, COLORREF crColor)
Creates a pen with specified parameters.
BOOL | CreatePen (int nPenStyle, int nWidth, const LOGBRUSH *pLogBrush, int nStyleCount=0, const DWORD *lpStyle=NULL)
Creates a pen with specified parameters.
BOOL | CreatePenIndirect (LPLOGPEN lpLogPen)
Creates a pen with specified parameters.
int | GetLogPen (LOGPEN *pLogPen)
Call this function to retrieve a copy of the LOGPEN structure that describes the encapsulated GDI object.
int | GetExtLogPen (EXTLOGPEN *pLogPen)
Call this function to retrieve a copy of the EXTLOGPEN structure that describes the encapsulated GDI object.
CPen * | GetNativeGdiObject ()
Obtains a pointer to the encapsulated GDI object as CPen type.
const CPen * | GetNativeGdiObject () const
Obtains a pointer to the encapsulated GDI object as CPen type.
operator HPEN () const
Casts an object to an encapsulated GDI handle.
operator CPen & ()
Converts an object to CPen reference making it possible to use CXTPPen with MFC classes and methods that use CPen or CGdiObject reference as an argument.
operator const CPen & () const
Converts an object to CPen constant reference making it possible to use CXTPPen with MFC classes and methods that use CPen or CGdiObject constant reference as an argument.
- Public Member Functions inherited from CXTPGdiObject
virtual | ~CXTPGdiObject ()=0
Handles CXTPGdiObject destruction.
operator HGDIOBJ () const
Casts an object to an encapsulated GDI handle.
HGDIOBJ | GetSafeHandle () const
Returns m_hObject unless this is NULL, in which case NULL is returned.
BOOL | DeleteObject ()
Decrements reference counter for a cached GDI object or delete the cached GDI object once the reference counter is equal to zero.
int | GetObject (int nCount, LPVOID lpObject) const
Fills a buffer with data that defines a specified object.
UINT | GetObjectType () const
Retrieves the type of the GDI object.
BOOL | CreateStockObject (int nIndex)
Retrieves a handle to one of the predefined stock Windows GDI pens, brushes, or fonts, and attaches the GDI object to the CGdiObject object.
BOOL | operator== (const CXTPGdiObject &obj) const
Determines if two GDI objects are logically equal.
BOOL | operator!= (const CXTPGdiObject &obj) const
Determines if two GDI objects are logically not equal.
operator CGdiObject & ()
Converts an object to CGdiObject reference making it possible to use CXTPGdiObject with MFC classes and methods that use CGdiObject reference as an argument.
operator const CGdiObject & () const
Converts an object to CGdiObject constance reference making it possible to use CXTPGdiObject with MFC classes and methods that use CGdiObject reference as an argument.
__declspec (property(get=GetSafeHandle)) HGDIOBJ m_hObject
A read-only encapsulated GDI handle value.
void | SetHandleOwnershipNotGuaranteed ()
Sets handle ownership guaranteed status.
BOOL | IsHandleOwnershipGuaranteed () const
Determines handle ownership guaranteed status.

Additional Inherited Members

- Protected Member Functions inherited from CXTPGdiObject
CXTPGdiObject ()
Performs internal CXTPGdiObject construction logic.

Detailed Description

Provides a convenient object oriented interface for HPEN GDI object and uses GDI handle caching.

Mimics CPen's interface from MFC however cannot be cast to CPen or CGdiObject types.

XTP GDI objects use cached GDI handles so one native GDI handle can be shared across several XTP GDI object instances. The lifetime of a handle is controlled by XTP GDI reference counter, meaning a handle is deleted only when the last XTP GDI object that references a particular handle is destroyed or DeleteObject is called. Note, because an encapsulated GDI handle is cached and shared, passing m_hObject to DeleteObject from Windows SDK or convering an XTP GDI object to CGdiObject& and making a call to CGdiObject::DeleteObject will delete a cached handle and leave all XTP GDI object that reference the delete handle in an undetermined state. This will also affect every place in a program where the cached handles are used. So use the encapsulated GDI handle or CGdiObject very carefully and for read-only purposes.

See also
CXTPGdiObject, CXTPFont, CXTPBrush

Constructor & Destructor Documentation

◆ CXTPPen() [1/2]

CXTPPen | ( | int | nPenStyle,
 |  | int | nWidth,
 |  | COLORREF | crColor )

Constructs a CXTPPen object.

Parameters
nPenStyle | Specifies the pen style.
nWidth | Specifies the width of the pen.
crColor | Contains an RGB color for the pen.

If the requested pen has already been created from another CXTPPen instance and not yet deleted the same pen will be re-used and its reference counter will be incremented.

◆ CXTPPen() [2/2]

CXTPPen | ( | int | nPenStyle,
 |  | int | nWidth,
 |  | const LOGBRUSH * | pLogBrush,
 |  | int | nStyleCount = 0,
 |  | const DWORD * | lpStyle = NULL )

Constructs a CXTPPen object.

Parameters
nPenStyle | Specifies the pen style.
nWidth | Specifies the width of the pen.
pLogBrush | A pointer to LOGBRUSH structure used differently depending on pen style.
nStyleCount | The number of optional style parameters.
lpStyle | An optional pointer to the array of style parameters.

If the requested pen has already been created from another CXTPPen instance and not yet deleted the same pen will be re-used and its reference counter will be incremented.

Member Function Documentation

◆ CreatePen() [1/2]

BOOL CreatePen | ( | int | nPenStyle,
 |  | int | nWidth,
 |  | COLORREF | crColor )

Creates a pen with specified parameters.

Parameters
nPenStyle | Specifies the pen style.
nWidth | Specifies the width of the pen.
crColor | Contains an RGB color for the pen.
Returns
TRUE if a pen is successfully created.

If the requested pen has already been created from another CXTPPen instance and not yet deleted the same pen will be re-used and its reference counter will be incremented.

◆ CreatePen() [2/2]

BOOL CreatePen | ( | int | nPenStyle,
 |  | int | nWidth,
 |  | const LOGBRUSH * | pLogBrush,
 |  | int | nStyleCount = 0,
 |  | const DWORD * | lpStyle = NULL )

Creates a pen with specified parameters.

Parameters
nPenStyle | Specifies the pen style.
nWidth | Specifies the width of the pen.
pLogBrush | A pointer to LOGBRUSH structure used differently depending on pen style.
nStyleCount | The number of optional style parameters.
lpStyle | An optional pointer to the array of style parameters.
Returns
TRUE if a pen is successfully created.

If the requested pen has already been created from another CXTPPen instance and not yet deleted the same pen will be re-used and its reference counter will be incremented.

◆ CreatePenIndirect()

BOOL CreatePenIndirect ( LPLOGPEN lpLogPen )

Creates a pen with specified parameters.

Parameters
lpLogPen A pointer to LOGPEN structu describing a pen to be created.
Returns
TRUE if a pen is successfully created.

If the requested pen has already been created from another CXTPPen instance and not yet deleted the same pen will be re-used and its reference counter will be incremented.

◆ GetExtLogPen()

int GetExtLogPen ( EXTLOGPEN * pLogPen )

Call this function to retrieve a copy of the EXTLOGPEN structure that describes the encapsulated GDI object.

Parameters
pLogPen Pointer to the EXTLOGPEN structure to receive the pen information.
Returns
Nonzero if the function succeeds, otherwise 0.

◆ GetLogPen()

int GetLogPen ( LOGPEN * pLogPen )

Call this function to retrieve a copy of the LOGPEN structure that describes the encapsulated GDI object.

Parameters
pLogPen Pointer to the LOGPEN structure to receive the pen information.
Returns
Nonzero if the function succeeds, otherwise 0.

◆ GetNativeGdiObject() [1/2]

CPen * GetNativeGdiObject ( )

Obtains a pointer to the encapsulated GDI object as CPen type.

The returned object must not be deleted or modified as it will affect every place in a program where the cached handle is used.

Returns
A pointer to the encapsulated GDI object as CPen type.

◆ GetNativeGdiObject() [2/2]

const CPen * GetNativeGdiObject ( ) const

Obtains a pointer to the encapsulated GDI object as CPen type.

The returned object must not be deleted or modified as it will affect every place in a program where the cached handle is used.

Returns
A pointer to the encapsulated GDI object as CPen type.

◆ operator const CPen &()

operator const CPen & ( ) const

Converts an object to CPen constant reference making it possible to use CXTPPen with MFC classes and methods that use CPen or CGdiObject constant reference as an argument.

Returns
An encapsulated CPen constant reference.

The returned object must not be deleted or modified as it will affect every place in a program where the cached handle is used.

◆ operator CPen &()

operator CPen & ( )

Converts an object to CPen reference making it possible to use CXTPPen with MFC classes and methods that use CPen or CGdiObject reference as an argument.

Returns
An encapsulated CPen reference.

The returned object must not be deleted or modified as it will affect every place in a program where the cached handle is used.

◆ operator HPEN()

operator HPEN ( ) const

Casts an object to an encapsulated GDI handle.

The returned handle must not be passed to DeleteObject and should be used for read-only purposes, i.e. GDI object state should not be modified as it will affect every place in a program where the cached hande is used.

Returns
Encapsulated GDI handle or NULL.
The documentation for this class was generated from the following file:
  • XTPGdiObjects.h


Toolkit Pro: CXTPPoint2T< T > Class Template Reference

Public Member Functions | Public Attributes | List of all members
CXTPPoint2T< T > Class Template Reference

This class represents a two-dimensional point. More...

Inheritance diagram for CXTPPoint2T< T >:
[legend]

Public Member Functions

CXTPPoint2T ()
Constructs an empty CXTPPoint2T object with all components equal to 0.
CXTPPoint2T (const CXTPPoint2T &point)
Constructs a CXTPPoint2T object from another CXTPPoint2T object.
CXTPPoint2T (int x, int y)
Constructs a CXTPPoint2T object.
CXTPPoint2T (float x, float y)
Constructs a CXTPPoint2T object.
CXTPPoint2T (double x, double y)
Constructs a CXTPPoint2T object.
void | SetPoint (T x, T y)
Sets point component values.
void | Offset (T dx, T dy)
Offsets the point to another location.
CXTPPoint2T< int > | Round () const
Rounds point to integer values.
bool | operator== (const CXTPPoint2T &point) const
Compares two points.
bool | operator!= (const CXTPPoint2T &point) const
Compares two points.
bool | IsZero () const
Determines if the point object is zero, i.e.
operator CXTPPoint2i () const
Converts point to point with integer components.
operator CXTPPoint2f () const
Converts point to point with float components.
operator CXTPPoint2d () const
Converts point to point with double components.

Public Attributes

T | X
The X coordinate.
T | Y
The Y coordinate.

Detailed Description

template<class T>
class CXTPPoint2T< T >

This class represents a two-dimensional point.

Parameters
T type of a single point coordinate component. Must be an integral type.

Constructor & Destructor Documentation

◆ CXTPPoint2T() [1/4]

template<class T >
CXTPPoint2T ( const CXTPPoint2T< T > & point )
inline

Constructs a CXTPPoint2T object from another CXTPPoint2T object.

Parameters
point A reference to a source point object.

◆ CXTPPoint2T() [2/4]

template<class T >
CXTPPoint2T | ( | int | x,
 |  | int | y )
 inline

Constructs a CXTPPoint2T object.

Parameters
x | The X coordinate.
y | The Y coordinate.

◆ CXTPPoint2T() [3/4]

template<class T >
CXTPPoint2T | ( | float | x,
 |  | float | y )
 inline

Constructs a CXTPPoint2T object.

Parameters
x | The X coordinate.
y | The Y coordinate.

◆ CXTPPoint2T() [4/4]

template<class T >
CXTPPoint2T | ( | double | x,
 |  | double | y )
 inline

Constructs a CXTPPoint2T object.

Parameters
x | The X coordinate.
y | The Y coordinate.

Member Function Documentation

◆ IsZero()

template<class T >
bool IsZero ( ) const
inline

Determines if the point object is zero, i.e.

each component is equal to 0.

Returns
true if the point object is empty, false otherwise.

◆ Offset()

template<class T >
void Offset | ( | T | dx,
 |  | T | dy )
 inline

Offsets the point to another location.

The differentials provided are added to each component.

Parameters
dx | The change in X coordinate.
dy | The change in Y coordinate.

◆ operator CXTPPoint2d()

template<class T >
operator CXTPPoint2d ( ) const
inline

Converts point to point with double components.

Returns
Converted point object.

◆ operator CXTPPoint2f()

template<class T >
operator CXTPPoint2f ( ) const
inline

Converts point to point with float components.

Returns
Converted point object.

◆ operator CXTPPoint2i()

template<class T >
operator CXTPPoint2i ( ) const
inline

Converts point to point with integer components.

Returns
Converted point object.

◆ operator!=()

template<class T >
bool operator!= ( const CXTPPoint2T< T > & point ) const
inline

Compares two points.

Parameters
point point object reference to compare to.
Returns
true if points are not equal, otherwise the return value is false.

◆ operator==()

template<class T >
bool operator== ( const CXTPPoint2T< T > & point ) const
inline

Compares two points.

Parameters
point point object reference to compare to.
Returns
true if points are equal, otherwise the return value is false.

◆ Round()

template<class T >
CXTPPoint2T< int > Round ( ) const
inline

Rounds point to integer values.

Returns
A rounded CXTPPoint2T object with integer components.

◆ SetPoint()

template<class T >
void SetPoint | ( | T | x,
 |  | T | y )
 inline

Sets point component values.

Parameters
x | The X coordinate.
y | The Y coordinate.
The documentation for this class was generated from the following file:
  • XTPPoint2.h


Toolkit Pro: CXTPPoint3T< T > Class Template Reference

Public Member Functions | Public Attributes | List of all members
CXTPPoint3T< T > Class Template Reference

This class represents a three-dimensional point. More...

Inheritance diagram for CXTPPoint3T< T >:
[legend]

Public Member Functions

CXTPPoint3T ()
Constructs an empty CXTPPoint3T object with all components equal to 0.
CXTPPoint3T (T x, T y, T z=T(0))
Constructs a CXTPPoint3T object.
CXTPPoint3T (const CXTPPoint2i &point)
Constructs a CXTPPoint3T object from CXTPPoint2i point.
CXTPPoint3T (const CXTPPoint2f &point)
Constructs a CXTPPoint3T object from CXTPPoint2f point.
CXTPPoint3T (const CXTPPoint2d &point)
Constructs a CXTPPoint3T object from CXTPPoint2d point.
CXTPPoint3T (const CXTPPoint3i &point)
Constructs a CXTPPoint3T object from CXTPPoint3i object.
CXTPPoint3T (const CXTPPoint3f &point)
Constructs a CXTPPoint3T object from CXTPPoint3f object.
CXTPPoint3T (const CXTPPoint3d &point)
Constructs a CXTPPoint3T object from CXTPPoint3d object.
operator CXTPPoint2i () const
Converts point to CXTPPoint2i point type.
operator CXTPPoint2f () const
Converts point to CXTPPoint2f point type.
operator CXTPPoint2d () const
Converts point to CXTPPoint2i point type.
operator CXTPPoint3i () const
Converts point to CXTPPoint3i point type.
operator CXTPPoint3f () const
Converts point to CXTPPoint3f point type.
operator CXTPPoint3d () const
Converts point to CXTPPoint3d point type.
void | SetPoint (T x, T y, T z=T(0))
Sets point component values.
void | Offset (T dx, T dy, T dz=T(0))
Offsets the point to another location.
CXTPPoint3T< int > | Round () const
Rounds point to integer values.
bool | operator== (const CXTPPoint3T &point) const
Compares two points.
bool | operator!= (const CXTPPoint3T &point) const
Compares two points.
bool | IsZero () const
Determines if the point object is zero, i.e.

Public Attributes

T | X
The X coordinate.
T | Y
The Y coordinate.
T | Z
The Z coordinate.

Detailed Description

template<class T>
class CXTPPoint3T< T >

This class represents a three-dimensional point.

Parameters
T type of a single point coordinate component. Must be an integral type.

Constructor & Destructor Documentation

◆ CXTPPoint3T() [1/7]

template<class T >
CXTPPoint3T | ( | T | x,
 |  | T | y,
 |  | T | z = T(0) )
 inline

Constructs a CXTPPoint3T object.

Parameters
x | The X coordinate.
y | The Y coordinate.
z | The Z coordinate.

◆ CXTPPoint3T() [2/7]

template<class T >
CXTPPoint3T ( const CXTPPoint2i & point )
inline

Constructs a CXTPPoint3T object from CXTPPoint2i point.

Parameters
point A reference to a source point object.

◆ CXTPPoint3T() [3/7]

template<class T >
CXTPPoint3T ( const CXTPPoint2f & point )
inline

Constructs a CXTPPoint3T object from CXTPPoint2f point.

Parameters
point A reference to a source point object.

◆ CXTPPoint3T() [4/7]

template<class T >
CXTPPoint3T ( const CXTPPoint2d & point )
inline

Constructs a CXTPPoint3T object from CXTPPoint2d point.

Parameters
point A reference to a source point object.

◆ CXTPPoint3T() [5/7]

template<class T >
CXTPPoint3T ( const CXTPPoint3i & point )
inline

Constructs a CXTPPoint3T object from CXTPPoint3i object.

Parameters
point A reference to a source point object.

◆ CXTPPoint3T() [6/7]

template<class T >
CXTPPoint3T ( const CXTPPoint3f & point )
inline

Constructs a CXTPPoint3T object from CXTPPoint3f object.

Parameters
point A reference to a source point object.

◆ CXTPPoint3T() [7/7]

template<class T >
CXTPPoint3T ( const CXTPPoint3d & point )
inline

Constructs a CXTPPoint3T object from CXTPPoint3d object.

Parameters
point A reference to a source point object.

Member Function Documentation

◆ IsZero()

template<class T >
bool IsZero ( ) const
inline

Determines if the point object is zero, i.e.

each component is equal to 0.

Returns
true if the point object is empty, false otherwise.

◆ Offset()

template<class T >
void Offset | ( | T | dx,
 |  | T | dy,
 |  | T | dz = T(0) )
 inline

Offsets the point to another location.

The differentials provided are added to each component.

Parameters
dx | The change in X coordinate.
dy | The change in Y coordinate.
dz | The change in Z coordinate.

◆ operator CXTPPoint2d()

template<class T >
operator CXTPPoint2d ( ) const
inline

Converts point to CXTPPoint2i point type.

Returns
A converted point object.

◆ operator CXTPPoint2f()

template<class T >
operator CXTPPoint2f ( ) const
inline

Converts point to CXTPPoint2f point type.

Returns
A converted point object.

◆ operator CXTPPoint2i()

template<class T >
operator CXTPPoint2i ( ) const
inline

Converts point to CXTPPoint2i point type.

Returns
A converted point object.

◆ operator CXTPPoint3d()

template<class T >
operator CXTPPoint3d ( ) const
inline

Converts point to CXTPPoint3d point type.

Returns
A converted point object.

◆ operator CXTPPoint3f()

template<class T >
operator CXTPPoint3f ( ) const
inline

Converts point to CXTPPoint3f point type.

Returns
A converted point object.

◆ operator CXTPPoint3i()

template<class T >
operator CXTPPoint3i ( ) const
inline

Converts point to CXTPPoint3i point type.

Returns
A converted point object.

◆ operator!=()

template<class T >
bool operator!= ( const CXTPPoint3T< T > & point ) const
inline

Compares two points.

Parameters
point point object reference to compare to.
Returns
true if points are not equal, otherwise the return value is false.

◆ operator==()

template<class T >
bool operator== ( const CXTPPoint3T< T > & point ) const
inline

Compares two points.

Parameters
point point object reference to compare to.
Returns
true if points are equal, otherwise the return value is false.

◆ Round()

template<class T >
CXTPPoint3T< int > Round ( ) const
inline

Rounds point to integer values.

Returns
A rounded CXTPPoint3T object with integer components.

◆ SetPoint()

template<class T >
void SetPoint | ( | T | x,
 |  | T | y,
 |  | T | z = T(0) )
 inline

Sets point component values.

Parameters
x | The X coordinate.
y | The Y coordinate.
z | The Z coordinate.
The documentation for this class was generated from the following file:
  • XTPPoint3.h


Toolkit Pro: CXTPPopupBar Class Reference

Public Member Functions | Static Public Member Functions | Static Public Attributes | Protected Member Functions | Protected Attributes | List of all members
CXTPPopupBar Class Reference

CXTPPopupBar is a CXTPCommandBar derived class. More...

Inheritance diagram for CXTPPopupBar:
[legend]

Public Member Functions

void | SetTearOffPopup (LPCTSTR lpszCaption, UINT nID, int nWidth=400)
This method adds the tear-off state to the pop-up bar.
BOOL | IsTearOffPopup (CString &strCaption, UINT &nID, int &nWidth)
Determines if the pop-up bar has the tear-off state.
virtual BOOL | IsVisible () const
Call this member to determine if the pop-up menu is visible/displayed.
BOOL | Popup (int xPos, int yPos, LPCRECT rcExclude)
This method opens the pop-up bar.
BOOL | Popup (CXTPControlPopup *pControlPopup, BOOL bSelectFirst=FALSE)
This method opens the pop-up bar.
CXTPControlPopup * | GetControlPopup () const
Call this member to retrieve the control's pop-up.
void | ExpandBar ()
This method expands the bar.
BOOL | DestroyWindow ()
Call this member to destroy the window.
void | SetPopupToolBar (BOOL bToolBarType)
Call this method to make the pop-up bar look like a pop-up toolbar.
void | SetDefaultItem (UINT uItem, BOOL fByPos=FALSE)
Sets the default menu item for the specified pop-up bar.
UINT | GetDefaultItem (UINT gmdiFlags, BOOL fByPos=FALSE)
Determines the default menu item on the specified pop-up bar.
BOOL | IsDoubleGripper () const
Call this method to determine if the pop-up bar has a double gripper.
void | SetDoubleGripper (BOOL bDoubleGripper=TRUE)
Call this member to set a double gripper for the pop-up bar.
virtual BOOL | IsPopupBar () const
Call this member function to determine if the command bar is a CXTPPopupBar.
BOOL | IsContextMenu () const
Determines if the pop-up bar is a context menu.
void | PumpMessage ()
Translates all messages in the message queue.
virtual CSize | CalcDynamicLayout (int nLength, DWORD dwMode)
This method is called to get the size of the command bar.
virtual BOOL | Create ()
Creates the pop-up bar.
virtual CRect | CalculatePopupRect (CPoint ptPopup, CSize sz)
This method is called to calculate the destination rectangle of the pop-up bar.
void | SetPopupFlags (DWORD dwPopupFlags)
Call this method to set the pop-up direction.
virtual BOOL | SetTrackingMode (int bMode, BOOL bSelectFirst=TRUE, BOOL bKeyboard=FALSE)
Call this member to change the tracking state.
void | SetBorders (CRect rcBorders)
Sets the toolbar's borders.
void | DisableShadow ()
Disables shadow use.
BOOL | IsResizable () const
Determines if the control can be resized by the user.
virtual CRect | GetBorders ()
Call this method to get the border margins of the command bar.
- Public Member Functions inherited from CXTPCommandBar
int | IsTrackingMode () const
Call this member to get the tracking state.
CXTPControls * | GetControls () const
Call this member to get the controls collection.
void | SetControls (CXTPControls *pControls)
Call this member to set the controls collection of the command bar.
XTPBarType | GetType () const
Call this member to get the type of the command bar.
void | SetTextOrientation (XTPBarTextOrientation nTextOrientation)
Call this member to change text orientation.
XTPBarTextOrientation | GetTextOrientation () const
Call this member to get the text orientation.
XTPBarPosition | GetPosition () const
Call this member to get the position of the command bar.
void | DelayLayout ()
Call this member to recalculate the layout.
virtual BOOL | LoadMenu (CMenu *pMenu, BOOL bRemoveControls=TRUE)
Call this member to convert menu items to command bar controls.
CXTPControl * | GetControl (int nIndex) const
Call this member to return the control at the specified index.
int | GetControlCount () const
Call this member to get the count of the controls.
CXTPControl * | GetSelected () const
Call this member to get the currently selected control.
BOOL | SetPopuped (int nPopuped, BOOL bKeyboard=FALSE)
Call this member to pop-up the specified control.
void | SetTitle (LPCTSTR lpszTitle)
Call this member to set a title for this command bar.
CString | GetTitle () const
Call this member to get a title for this command bar.
CXTPCommandBars * | GetCommandBars () const
Call this member to get the command bar's object.
void | SetCommandBars (CXTPCommandBars *pCommandBars)
Call this member to set the command bar's object.
CWnd * | GetSite () const
Call this member to get the command bar's site.
CFrameWnd * | GetFrameSite () const
Call this member to get the command bar's site as CFrameWnd.
void | SetFlags (DWORD dwFlagsAdd, DWORD dwFlagsRemove=0)
Call this member to set the command bar's flags.
BOOL | SetButtons (UINT *pButtons, int nCount)
Call this member to set the controls from the button array.
virtual BOOL | LoadToolBar (UINT nIDResource, BOOL bLoadIcons=TRUE)
Call this member function to load the toolbar specified by nIDResource.
void | SetIconSize (CSize size)
Call this function to set the size of the actual bitmapped images to be added to a toolbar.
virtual CSize | GetIconSize () const
Call this member function to get the size of the toolbar icon.
CSize | GetLargeIconSize (BOOL bAutoSize) const
Call this method to get the large icon size of the toolbar.
void | SetButtonSize (CSize size)
Sets the size of the buttons in the command bar.
virtual CSize | GetButtonSize () const
Call this function to get the size of the command bar button.
void | ShowTextBelowIcons (BOOL bTextBelow=TRUE)
Call this member to show the caption below control's icon.
BOOL | IsTextBelowIcons () const
Checks whether the caption is below the control's icon.
HWND | GetTrackFocus () const
Call this method to retrieve the current focused control.
void | SetTrackFocus (HWND hwnd)
Call this method to set focus to the window.
virtual void | SetVisible (BOOL bVisible)
Call this method to set the visibility state of the control.
virtual BOOL | SetPosition (XTPBarPosition barPosition)
Call this member function to set the position of the command bar.
int | FindAccel (TCHAR chAccel) const
Call this method to get the index of the control with the specified accelerator character.
int | FindAccelEx (UINT chAccel, BOOL &bSelectOnly) const
Call this method to get the index of the control with the specified accelerator character.
BOOL | IsCustomizeMode () const
Call this method to check if the command bars are in customize mode.
virtual DROPEFFECT | OnCustomizeDragEnter (CXTPControl *pDataObject, CPoint point)
This member is called when a control is entered into the command bar.
virtual void | OnCustomizeDragLeave ()
This method is called when a control leaves the command bar.
virtual DROPEFFECT | OnCustomizeDragOver (CXTPControl *pDataObject, CPoint point)
This member is called when control is over the command bar.
virtual void | OnCustomizeDrop (CXTPControl *pDataObject, DROPEFFECT &dropEffect, CPoint ptDrop, CPoint ptDrag)
This method is called when a control is dropped to the command bar.
virtual BOOL | IsCustomizable () const
Call this method to check if the command bar is customizable.
BOOL | IsCustomizeDialogPresent () const
Call this method to check if the command bar is present in Customize dialog.
void | EnableCustomization (BOOL bEnable=TRUE)
Call this method to enable/disable customization of the command bar.
virtual void | OnTrackLost ()
Call this method to remove the tracking state of the command bar.
virtual void | OnTrackEnter ()
Call this method to track the command bar.
CWnd * | GetOwnerSite () const
Call this method to retrieve the owner window of the command bar.
void | InvalidateParents ()
Call this method to redraw all parent command bars.
DWORD | GetFlags () const
Call this method to retrieve the current behavior modification flags of the command bar.
UINT | GetBarID () const
Call this method to retrieve the identifier of the command bar.
void | SetBarID (UINT nID)
Call this method to set the identifier of the command bar.
virtual void | OnControlSelected (BOOL bSelected, CXTPControl *pControl)
This method is called when a child control becomes selected.
BOOL | SetStatusText (const CString &strDescription)
This method is called to set the description context.
void | SetCommandBarData (DWORD_PTR dwData)
This method sets the 32-bit value associated with the command bar.
DWORD_PTR | GetCommandBarData () const
This method retrieves the application-supplied, 32-bit value associated with the command bar.
CXTPCommandBar * | GetRootParent () const
Call this method to retrieve the top-level parent command bar.
CXTPPaintManager * | GetPaintManager () const
Call this method to retrieve the paint manager.
CXTPImageManager * | GetImageManager () const
Call this method to retrieve the image manager.
void | SetWidth (int nWidth)
Call this member to set the width of the floated or pop-up toolbar.
int | GetWidth () const
Call this member to get the width of the floated or pop-up toolbar.
void | SetPaintManager (CXTPPaintManager *pPaintManager)
Call this member to set the specified paint manager.
void | SetImageManager (CXTPImageManager *pImageManager)
Call this member to set the specified image manager.
BOOL | IsLayoutRTL () const
Call this member function to determine if the command bar layout is Right-to-Left (RTL).
virtual BOOL | IsDialogBar () const
Call this member function to determine if the command bar is a CXTPDialogBar.
virtual BOOL | IsRibbonBar () const
Call this member function to determine if the command bar is a CXTPRibbonBar.
virtual BOOL | IsMenuTitleBar () const
Call this member function to determine if the command bar is a CXTPMenuTitleBar.
virtual BOOL | IsKeyboardCuesVisible () const
Determines if underlines are visible in the command bar control.
void | SetGrabFocus (BOOL bGrabFocus)
This method is called internally to prevent the command bar from grabbing edit focus.
virtual void | Redraw (LPCRECT lpRect=0, BOOL bAnimate=TRUE)
The framework calls this member function to redraw the command bar.
void | EnableAnimation (BOOL bEnable=TRUE)
Call this method to enable animation for the command bar.
void | EnableDoubleBuffer (BOOL bEnable=TRUE)
Call this method to enable double buffer for toolbar drawing.
BOOL | IsAnimationEnabled () const
Determines if animation is enabled for the specified command bar.
virtual int | OnHookMessage (HWND hWnd, UINT nMessage, WPARAM &wParam, LPARAM &lParam, LRESULT &lResult)
This member function is called by WindowProc, or is called during message reflection.
virtual void | EnsureVisible (CXTPControl *pControl)
Call this method to ensure that a specified control is visible on the toolbar.
XTPButtonStyle | GetDefaultButtonStyle () const
Call this method to retrieve the default button style of the command bar.
void | SetDefaultButtonStyle (XTPButtonStyle buttonStyle)
Call this method to set the default button style of the command bar.
void | LockRedraw ()
Call this method to freeze redrawing until UnlockRedraw is called.
void | UnlockRedraw ()
Call this method to unfreeze redrawing.
void | SetShowGripper (BOOL bShow)
Call this method to set the visibility of the command bar's gripper.
BOOL | GetShowGripper () const
Call this method to check if the command bar's gripper is visible.
virtual void | FillCommandBarEntry (CDC *pDC)
This method is called to draw the background of the command bar.
BOOL | IsKeyboardTipsVisible () const
Call this method to check if keyboard tips are visible for the command bar.
virtual void | CreateKeyboardTips ()
This method is called to create a keyboard tips collection for the command bar.
void | OnKeyboardTipChar (UINT chAccel)
This method is called when the user presses a key while keyboard tips are visible.
virtual void | OnKeyboardTip (CXTPCommandBarKeyboardTip *pTip)
This method is called when a keyboard tip is found for the command bar.
void | HideKeyboardTips ()
Call this method to hide keyboard tips.
void | LockMouseMove (CXTPControl *pControl)
Locks the mouse cursor for a specified control.
void | UnlockMouseMove ()
Unlocks the mouse cursor.
- Public Member Functions inherited from CXTPHookManagerHookAble
CXTPHookManagerHookAble ()
Constructs a CXTPHookManagerHookAble object.
virtual | ~CXTPHookManagerHookAble ()
Destroys a CXTPHookManagerHookAble object, handles cleanup and deallocation.
virtual int | OnPostHookMessage (HWND hWnd, UINT nMessage, WPARAM &wParam, LPARAM &lParam, LRESULT &lResult)
This member function is called after a message has been processed by default window procedure.
virtual void | OnHookAttached (HWND hWnd)
This member function is called right after a hook is attached to the window.
virtual void | OnHookDetached ()
This member function is called right before a hook is to be detached from the window.

Static Public Member Functions

static CXTPPopupBar *AFX_CDECL CreatePopupBar (CXTPCommandBars *pCommandBars)
Creates a pop-up bar object.

Static Public Attributes

static double | m_dMaxWidthDivisor
Maximum available width of pop-up.
- Static Public Attributes inherited from CXTPCommandBar
static int | s_nHoverDelay
Hover delay time.
static int | s_nExpandDelay
Expand delay time.
static int | s_nExpandHoverDelay
Expand hover delay.

Protected Member Functions

CXTPPopupBar ()
Constructs a CXTPPopupBar object.
virtual | ~CXTPPopupBar ()
Destroys a CXTPPopupBar object, handles cleanup and deallocation.
virtual void | DelayRedraw ()
Redraw the pop-up bar.
virtual BOOL | SetSelected (int nSelected, BOOL bKeyboard=FALSE)
Call this member to select the specified control.
void | UpdateLocation (CSize sz)
This method sets the pop-up bar's position.
virtual void | UpdateFlags ()
Update flags.
void | UpdateExpandingState ()
Update expanding state.
virtual void | DrawCommandBar (CDC *pDC, CRect rcClipBox)
This method is called to draw the command bar in the given context.
virtual void | OnControlsChanged ()
This method is called when the controls array is changed.
virtual void | OnRecalcLayout ()
This method is called to recalculate the command bar layout.
CXTPCommandBar * | GetParentCommandBar () const
Call this member to retrieve the parent command bar.
virtual void | DoPropExchange (CXTPPropExchange *pPX)
Either reads this object from or writes this object to an archive.
virtual void | Copy (CXTPCommandBar *pCommandBar, BOOL bRecursive=FALSE)
Call this method make a copy of the command bar.
virtual BOOL | OnHookKeyDown (UINT nChar, LPARAM lParam)
The framework calls this member function when a non-system key is pressed.
virtual void | AdjustExcludeRect (CRect &rc, BOOL bVertical)
Updates rectangle to set the position where the child pop-up bar becomes visible.
virtual void | Animate ()
Animates pop-up window.
- Protected Member Functions inherited from CXTPCommandBar
CXTPCommandBar ()
Constructs a CXTPCommandBar object.
virtual | ~CXTPCommandBar ()
Destroys a CXTPCommandBar object, handles cleanup and deallocation.
virtual BOOL | ProcessSpecialKey (XTPSpecialKey key)
This method is called to process special keys.
virtual int | OnMouseHitTest (CPoint pt)
This method is called to determine mouse hit code.
virtual void | UpdateShortcuts ()
Updates the control's shortcuts.
UINT | GetActiveDocTemplate () const
Retrieves the active MDI document template.
virtual void | GenerateCommandBarList (DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam)
This method is called to assign self identifiers for the serialization process.
virtual void | RestoreCommandBarList (CXTPCommandBarList *pCommandBarList)
This method is called in the serialization process to restore pop-ups from a list of command bars.
BOOL | IsHelpMode () const
Determines if the parent frame is in help mode.
virtual void | OnRemoved ()
This method is called when a toolbar is removed from the command bars collection.

Protected Attributes

CXTPControlPopup * | m_pControlPopup
Control that pop-up'ed the bar.
CPoint | m_ptPopup
Position of the bar.
CRect | m_rcExclude
Excluded area.
DWORD | m_popupFlags
Flags of the bar.
BOOL | m_bDynamicLayout
TRUE if DynamicLayout routine executed.
BOOL | m_bCollapsed
TRUE if pop-up bar is collapsed.
BOOL | m_bExpanded
TRUE if pop-up bar is expanded.
BOOL | m_bExpanding
TRUE if pop-up bar is expanding.
BOOL | m_bTearOffPopup
TRUE if pop-up bar has tear-off option.
CRect | m_rcTearOffGripper
Tear-off gripper position.
CRect | m_rcResizeGripper
Resizable gripper position.
BOOL | m_bResizable
TRUE to allow resize.
BOOL | m_bTearOffSelected
TRUE if gripper selected.
UINT_PTR | m_nTearOffTimer
Tear-off timer.
BOOL | m_bTearOffTracking
Tear-off tracking mode.
CSize | m_szTearOffBar
Size of the bar.
CXTPToolBar * | m_pTearOffBar
Tear-off toolbar pointer.
CString | m_strTearOffCaption
Caption of the Tear-off toolbar.
UINT | m_nTearOffID
ID of the Tear-off toolbar.
int | m_nTearOffWidth
Width of the Tear-off toolbar.
BOOL | m_bShowShadow
TRUE to show the shadow.
CRect | m_rcBorders
Borders of the bar.
BOOL | m_bDoubleGripper
TRUE if pop-up is state pop-up type.
BOOL | m_bContextMenu
TRUE if pop-up bar is context menu.
int | m_nMaxHeight
Maximum height the pop-up bar can become.
- Protected Attributes inherited from CXTPCommandBar
BOOL | m_bGrabFocus
TRUE to grab current focus.
int | m_nMRUWidth
Recent width.
int | m_nSelected
Selected control index.
int | m_nPopuped
Pop-up'ed control index.
HWND | m_hwndFocus
The handle of the window that currently has focus.
UINT | m_nBarID
Command bar's identifier.
BOOL | m_bTracking
TRUE if the command bar is in tracking mode.
CWnd * | m_pSite
Command bar's site.
DWORD | m_nIdleFlags
Idle flags.
DWORD | m_dwFlags
Command bar's flags.
DWORD | m_dwStyle
Command bar's styles.
CString | m_strTitle
Command bar's caption.
XTPBarType | m_barType
Type of the command bar.
CXTPControls * | m_pControls
A pointer to controls collection.
XTPBarPosition | m_barPosition
Position of the command bar.
CXTPCommandBars * | m_pCommandBars
parent command bars class.
CWnd * | m_pOwner
Owner window.
CSize | m_szIcons
Size of the command bar's icons.
CSize | m_szButtons
Size of the command bar's buttons.
BOOL | m_bTextBelow
TRUE if text is shown below the CommandBar buttons.
BOOL | m_bExecOnRButton
TRUE if the control button is executed on a right-click.
BOOL | m_bIgnoreUpdateHandler
TRUE to skip update handler for all child controls.
BOOL | m_bRecursePopup
TRUE if pop-up bar was opened recursively.
BOOL | m_bKeyboardSelect
TRUE if last item was selected by keyboard.
BOOL | m_bCloseable
TRUE if the CommandBar can be closed and-or Hidden.
BOOL | m_bCustomizable
TRUE if command bar is customizable.
CRect | m_rcMarker
Marker position.
BOOL | m_bVerticalMarker
TRUE to draw marker vertically.
DWORD_PTR | m_dwData
The 32-bit value associated with the command bar.
UINT * | m_pReturnCmd
Return command holder.
BOOL | m_bCustomizeDialogPresent
TRUE if the command bar is present in Customize dialog.
BOOL | m_bAnimatePopup
TRUE to animate pop-up bar.
BOOL | m_nLockRedraw
TRUE if all drawing routines skipped.
CXTPPaintManager * | m_pPaintManager
Selected paint manager for command bar.
CXTPImageManager * | m_pImageManager
Selected image manager for command bar.
BOOL | m_bMultiLine
True if multi line commandbar.
XTPButtonStyle | m_buttonStyle
Default button Style.
XTPBarTextOrientation | m_nTextOrientation
Commandbar text orientation.
CXTPToolTipContext * | m_pToolTipContext
Tool tip Context.
CXTPCommandBarAnimation * | m_pAnimation
Animation context.
CSize | m_szButtonSpacing
Spacing used between toolbar buttons.

Additional Inherited Members

- Public Attributes inherited from CXTPCommandBar
int | m_nStateFlags
State of the command bars.
BOOL | m_bComboBar
TRUE if it is combobox list.
BOOL | m_bTrackOnHover
TRUE to select item if mouse stay over control.
- Public Attributes inherited from CXTPHookManagerHookAble
BOOL | m_bAutoDestroy
TRUE to automatically delete hook.

Detailed Description

CXTPPopupBar is a CXTPCommandBar derived class.

It represents a submenu of a menu bar.

Member Function Documentation

◆ AdjustExcludeRect()

virtual void AdjustExcludeRect | ( | CRect & | rc,
 |  | BOOL | bVertical )
 protectedvirtual

Updates rectangle to set the position where the child pop-up bar becomes visible.

Parameters
rc | CRect object specifying the size of the area.
bVertical | TRUE if the control is located vertically in its parent.

Reimplemented in CXTPRibbonSystemPopupBarPage.

◆ CalcDynamicLayout()

virtual CSize CalcDynamicLayout | ( | int | nLength,
 |  | DWORD | dwMode )
 virtual

This method is called to get the size of the command bar.

Parameters
nLength | The requested dimension of the control bar, either horizontal or vertical, depending on dwMode.
dwMode | See CControlBar::CalcDynamicLayout for a list of supported flags.
Returns
Size of the command bar.

Reimplemented from CXTPCommandBar.

Reimplemented in CXTPPopupToolBar, CXTPRibbonSystemPopupBar, CXTPRibbonSystemPopupBarPage, and CXTPRibbonTabPopupToolBar.

◆ CalculatePopupRect()

virtual CRect CalculatePopupRect | ( | CPoint | ptPopup,
 |  | CSize | sz )
 virtual

This method is called to calculate the destination rectangle of the pop-up bar.

Parameters
ptPopup | Point to display the pop-up bar.
sz | Size of the pop-up bar.
Returns
Rectangle where the pop-up bar will be located.

Reimplemented in CXTPRibbonTabPopupToolBar.

◆ Copy()

virtual void Copy | ( | CXTPCommandBar * | pCommandBar,
 |  | BOOL | bRecursive = FALSE )
 protectedvirtual

Call this method make a copy of the command bar.

Parameters
pCommandBar | Command bar to be copied.
bRecursive | TRUE to copy recursively.

Reimplemented from CXTPCommandBar.

Reimplemented in CXTPControlComboBoxList, and CXTPControlFontComboBoxList.

◆ Create()

virtual BOOL Create ( )
virtual

Creates the pop-up bar.

Returns
TRUE if successful; otherwise FALSE.

◆ CreatePopupBar()

static CXTPPopupBar *AFX_CDECL CreatePopupBar ( CXTPCommandBars * pCommandBars )
static

Creates a pop-up bar object.

Parameters
pCommandBars Pointer to a CXTPCommandBars object.
Returns
A pointer to a CXTPPopupBar object.

◆ DestroyWindow()

BOOL DestroyWindow ( )

Call this member to destroy the window.

Returns
TRUE if successful, otherwise FALSE.

◆ DoPropExchange()

virtual void DoPropExchange ( CXTPPropExchange * pPX )
protectedvirtual

Either reads this object from or writes this object to an archive.

Parameters
pPX A CXTPPropExchange object to serialize to or from.

Reimplemented from CXTPCommandBar.

Reimplemented in CXTPControlComboBoxList, and CXTPControlFontComboBoxList.

◆ DrawCommandBar()

virtual void DrawCommandBar | ( | CDC * | pDC,
 |  | CRect | rcClipBox )
 protectedvirtual

This method is called to draw the command bar in the given context.

Parameters
pDC | Pointer to a valid device context.
rcClipBox | The rectangular area of the control that is invalid.

Reimplemented from CXTPCommandBar.

Reimplemented in CXTPControlComboBoxList, and CXTPRibbonTabPopupToolBar.

◆ GetBorders()

virtual CRect GetBorders ( )
virtual

Call this method to get the border margins of the command bar.

Returns
A CRect object containing the border margins.

Reimplemented from CXTPCommandBar.

Reimplemented in CXTPRibbonSystemPopupBar.

◆ GetControlPopup()

AFX_INLINE CXTPControlPopup * GetControlPopup ( ) const

Call this member to retrieve the control's pop-up.

Returns
A pointer to a CXTPControlPopup object.

◆ GetDefaultItem()

UINT GetDefaultItem | ( | UINT | gmdiFlags,
 |  | BOOL | fByPos = FALSE )

Determines the default menu item on the specified pop-up bar.

Parameters
gmdiFlags | Reserved. Should be NULL.
fByPos | Value specifying whether to retrieve the menu item's identifier or its position. If this parameter is FALSE, the identifier is returned. Otherwise, the position is returned.
Returns
If the function succeeds, the return value is the identifier or position of the menu item. If the function fails, the return value is -1.

◆ GetParentCommandBar()

CXTPCommandBar * GetParentCommandBar ( ) const
protectedvirtual

Call this member to retrieve the parent command bar.

Returns
A pointer to a CXTPCommandBar object.

Reimplemented from CXTPCommandBar.

◆ IsContextMenu()

AFX_INLINE BOOL IsContextMenu ( ) const

Determines if the pop-up bar is a context menu.

Returns
TRUE if the pop-up bar is a context menu.
See also
CXTPCommandBarsContextMenus

◆ IsDoubleGripper()

AFX_INLINE BOOL IsDoubleGripper ( ) const

Call this method to determine if the pop-up bar has a double gripper.

Returns
TRUE if the pop-up bar has a double gripper, otherwise FALSE.

◆ IsPopupBar()

AFX_INLINE BOOL IsPopupBar ( ) const
virtual

Call this member function to determine if the command bar is a CXTPPopupBar.

Returns
TRUE if the command bar is a CXTPPopupBar, otherwise FALSE.
See also
CXTPCommandBar, CXTPPopupBar

Reimplemented from CXTPCommandBar.

◆ IsResizable()

AFX_INLINE BOOL IsResizable ( ) const
virtual

Determines if the control can be resized by the user.

Returns
TRUE if the control can be resized by the user, otherwise FALSE.

Reimplemented from CXTPCommandBar.

◆ IsTearOffPopup()

BOOL IsTearOffPopup | ( | CString & | strCaption,
 |  | UINT & | nID,
 |  | int & | nWidth )

Determines if the pop-up bar has the tear-off state.

Parameters
strCaption | Caption of the tear-off toolbar.
nID | Identifier of the toolbar to be created.
nWidth | Width of the toolbar.
Returns
TRUE if the pop-up bar has the tear-off state, otherwise FALSE.

◆ IsVisible()

virtual BOOL IsVisible ( ) const
virtual

Call this member to determine if the pop-up menu is visible/displayed.

Returns
TRUE if the pop-up menu is visible/displayed, FALSE if the pop-up menu is currently hidden.

Reimplemented from CXTPCommandBar.

◆ OnHookKeyDown()

virtual BOOL OnHookKeyDown | ( | UINT | nChar,
 |  | LPARAM | lParam )
 protectedvirtual

The framework calls this member function when a non-system key is pressed.

Parameters
nChar | Specifies the virtual key code of the given key.
lParam | Specifies additional message-dependent information.
Returns
TRUE if the key was handled, otherwise FALSE.

Reimplemented from CXTPCommandBar.

Reimplemented in CXTPControlComboBoxList, and CXTPMiniToolBar.

◆ Popup() [1/2]

BOOL Popup | ( | CXTPControlPopup * | pControlPopup,
 |  | BOOL | bSelectFirst = FALSE )
 virtual

This method opens the pop-up bar.

Parameters
pControlPopup | Pointer to a CXTPControlPopup object.
bSelectFirst | TRUE to select the first item.
Returns
TRUE if successful, otherwise FALSE.

Reimplemented from CXTPCommandBar.

◆ Popup() [2/2]

BOOL Popup | ( | int | xPos,
 |  | int | yPos,
 |  | LPCRECT | rcExclude )

This method opens the pop-up bar.

Parameters
xPos | Specifies the logical x coordinate of the pop-up bar
yPos | Specifies the logical y coordinate of the position.
rcExclude | Excluded area.
Returns
TRUE if successful, otherwise FALSE.

◆ SetBorders()

AFX_INLINE void SetBorders ( CRect rcBorders )

Sets the toolbar's borders.

Parameters
rcBorders Borders of the toolbar.

◆ SetDefaultItem()

void SetDefaultItem | ( | UINT | uItem,
 |  | BOOL | fByPos = FALSE )

Sets the default menu item for the specified pop-up bar.

Parameters
uItem | Identifier or position of the new default menu item or -1 for no default item. The meaning of this parameter depends on the value of fByPos.
fByPos | Value specifying the meaning of uItem. If this parameter is FALSE, uItem is a menu item identifier. Otherwise, it is a menu item position.

◆ SetDoubleGripper()

AFX_INLINE void SetDoubleGripper ( BOOL bDoubleGripper = TRUE )

Call this member to set a double gripper for the pop-up bar.

Parameters
bDoubleGripper TRUE to set a double gripper for the pop-up bar.

◆ SetPopupFlags()

AFX_INLINE void SetPopupFlags ( DWORD dwPopupFlags )

Call this method to set the pop-up direction.

Parameters
dwPopupFlags Direction of pop-up to open. See XTPPopupDirection enumerator.
See also
XTPPopupDirection

◆ SetPopupToolBar()

void SetPopupToolBar ( BOOL bToolBarType )

Call this method to make the pop-up bar look like a pop-up toolbar.

Parameters
bToolBarType TRUE to make the pop-up bar as a pop-up toolbar.

◆ SetSelected()

virtual BOOL SetSelected | ( | int | nSelected,
 |  | BOOL | bKeyboard = FALSE )
 protectedvirtual

Call this member to select the specified control.

Parameters
nSelected | An integer index of the item to be selected.
bKeyboard | TRUE if the item was selected using the keyboard.
Returns
TRUE if the method was successful, otherwise FALSE.

Reimplemented from CXTPCommandBar.

◆ SetTearOffPopup()

void SetTearOffPopup | ( | LPCTSTR | lpszCaption,
 |  | UINT | nID,
 |  | int | nWidth = 400 )

This method adds the tear-off state to the pop-up bar.

Parameters
lpszCaption | Caption of the tear-off toolbar.
nID | Identifier of the toolbar to be created.
nWidth | Width of the toolbar.

◆ SetTrackingMode()

virtual BOOL SetTrackingMode | ( | int | bMode,
 |  | BOOL | bSelectFirst = TRUE,
 |  | BOOL | bKeyboard = FALSE )
 virtual

Call this member to change the tracking state.

Parameters
bMode | TRUE to set the tracking mode, otherwise FALSE.
bSelectFirst | TRUE to select the first item.
bKeyboard | TRUE if the item is pop-up'ed by the keyboard.
Returns
TRUE if the method was successful, otherwise FALSE.
See also
IsTrackingMode.

Reimplemented from CXTPCommandBar.

Reimplemented in CXTPControlComboBoxList, and CXTPRibbonTabPopupToolBar.

◆ UpdateLocation()

void UpdateLocation ( CSize sz )
protected

This method sets the pop-up bar's position.

Parameters
sz Size of the pop-up bar.
The documentation for this class was generated from the following file:
  • XTPPopupBar.h


Toolkit Pro: CXTPPopupControl Class Reference

Classes | Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPPopupControl Class Reference

CXTPPopupControl is a class for control of a pop-up window. More...

Classes

struct POPUPSTATE
Pop-up state descriptor. More...

Public Member Functions

CXTPPopupControl (BOOL bAutoDelete=FALSE)
Constructs a CXTPPopupControl object.
virtual | ~CXTPPopupControl ()
Destroys a CXTPPopupControl object, handles cleanup and deallocation.
void | SetPopupPos (CPoint ptPopup)
Call this member function to set the position of a pop-up window.
CPoint | GetPopupPos () const
Call this member function to get the position of a pop-up window.
void | SetPopupSize (CSize szPopup)
Call this member function to set the size of a pop-up window.
CSize | GetPopupSize () const
Call this member function to get the size of a pop-up window.
BOOL | Show (CWnd *pParent, int nID=0)
Call this member function to create and expand a pop-up window.
BOOL | ShowModal (CWnd *pParent, int nID=0)
Call this method to show a modal pop-up control.
void | Hide ()
Call this member function to collapse a pop-up window.
BOOL | Close ()
Call this member to destroy a pop-up window.
void | SetTransparency (BYTE bTransp)
Call this member function to set the transparency value of a pop-up window.
BYTE | GetTransparency () const
Call this member function to get the transparency value of a pop-up window.
void | SetShowDelay (DWORD dwShowDelay)
Call this member function to set the show delay value for a pop-up window.
DWORD | GetShowDelay () const
Call this member function to get the show delay value for a pop-up window.
void | SetAnimateDelay (DWORD dwAnimateDelay)
Call this member function to set the animate delay value for a pop-up window.
DWORD | GetAnimateDelay () const
Call this member function to get the animate delay value for a pop-up window.
void | SetPopupAnimation (XTPPopupAnimation popupAnimation)
Call this member function to set the pop-up animation method.
void | SetPopupAnimation ()
Call this member function to set the default pop-up animation method.
XTPPopupAnimation | GetPopupAnimation () const
Call this member function to get the pop-up animation method.
XTPPopupState | GetPopupState () const
Call this member function to get the current state of a pop-up window.
void | SetTheme (XTPPopupPaintTheme theme)
Call this member function to set the paint theme or paint manager used for drawing a pop-up window.
void | SetTheme (CXTPPopupPaintManager *pPaintManager)
Call this member function to set the paint theme or paint manager used for drawing a pop-up window.
CXTPPopupPaintManager * | GetPaintManager () const
Call this member function to get the paint manager object used for drawing a pop-up window.
XTPPopupPaintTheme | GetTheme () const
Call this member function to get the paint theme that the pop-up window is currently using.
void | RedrawControl ()
Call this member function to redraw all controlled items of a pop-up window.
CXTPPopupItem * | AddItem (CXTPPopupItem *pItem)
Call this member function to install a new controlled item in a pop-up window.
void | RemoveAllItems ()
Call this member function to remove all controlled items from a pop-up window.
void | RemoveItem (CXTPPopupItem *pItem)
Call this member function to remove a controlled item from a pop-up window.
void | RemoveItem (int nIndex)
Call this member function to remove a controlled item from a pop-up window.
int | GetItemCount () const
Call this member function to get the count of controlled items in a pop-up window.
CXTPPopupItem * | GetItem (int nIndex) const
Call this member function to get the controlled item at a specified index.
CXTPPopupItem * | HitTest (CPoint pt) const
Call this member function to test a point for controlled items of a pop-up window.
void | AllowMove (BOOL bAllowMove)
Call this member to specify whether the user can click and drag the pop-up window when it is displayed.
void | SetBackgroundBitmap (int nBackgroundBitmap)
Call this member to set the bitmap index for the background.
int | GetBackgroundBitmap () const
Call this member to get the bitmap index for the background.
void | SetAutoDelete (BOOL bAutoDelete)
Call this member to allow the pop-up control to delete itself automatically upon final release.
void | SetDefaultLocation (XTPPopupLocation nPopupLocation)
Call this member to set the default pop-up location.
BOOL | GetSplashScreenMode () const
Call this member to see if splash screen mode has been enabled.
void | SetSplashScreenMode (BOOL bSet)
Call this member to set splash screen mode.
int | GetID () const
Retrieves the ID assigned to the pop-up window when it was created.
BOOL | IsLayoutRTL () const
Determines if right-to-left (RTL) mode is set.
void | SetLayoutRTL (BOOL bRightToLeft)
Specifies if right-to-left (RTL) mode should be set.
void | SetImageManager (CXTPImageManager *pImageManager)
Call this method to set a new image manager.
CXTPImageManager * | GetImageManager () const
Call this method to get a pointer to the image manager of the pop-up control.
void | EnableMarkup (BOOL bEnableMarkup)
Call this method to enable markup for the pop-up control.
CXTPMarkupContext * | GetMarkupContext () const
Retrieves the markup context associated with the pop-up control.
BOOL | IsDpiBitmapScalingEnabled () const
Gets DPI bitmap scaling flag.
void | EnableDpiBitmapScaling (BOOL bEnable=TRUE)
Sets DPI bitmap scaling flag.

Protected Member Functions

virtual BOOL | Create (CWnd *pParentWnd)
Creates a pop-up window.
virtual void | OnClick (CXTPPopupItem *pItem)
This method is called when the user clicks on a controlled item.
virtual void | OnExpanding (BOOL bUpdateCurrent)
This method is called to start the expanding animation.
virtual void | OnCollapsing ()
This method is called to start the collapsing animation.
virtual void | OnShow ()
This method is called to show the control.
virtual void | Notify (WPARAM wParam, LPARAM lParam)
This method is called to notify the parent about an action that occurred.
void | Animate (int nStep)
This method animates the pop-up control.
void | UpdateState (BOOL bInit=FALSE)
Updates the position in the animation according to the current animation step.
void | SetPopupState (XTPPopupState popupState)
This method is called when the current state of the control changes.
BOOL | SetLayeredWindowAttributes (int bAlpha)
Updates the current control's transparency.
void | TrackMove ()
Loop of control moving.

Protected Attributes

CXTPPopupPaintManager * | m_pPaintManager
Pointer to CXTPPopupPaintManager object.
CArray< CXTPPopupItem *, CXTPPopupItem * > | m_arrItems
Array for controlled items.
CXTPPopupItem * | m_pSelected
Pointer to selected item.
CXTPPopupItem * | m_pPressed
Pointer to pressed item.
XTPPopupAnimation | m_popupAnimation
Current animation method.
XTPPopupState | m_popupState
Current pop-up state.
CSize | m_szPopup
Current XY location of a pop-up window.
CPoint | m_ptPopup
Current XY size of a pop-up window.
int | m_nID
Control ID for the pop-up window.
int | m_nTransparency
Current value transparency of a pop-up window.
int | m_nCurrentTransparency
Current transparency of a pop-up window.
UINT | m_uShowDelay
Value of show delay of a pop-up window.
UINT | m_uAnimationDelay
Value of animation delay of a pop-up window.
UINT | m_nAnimationInterval
Value of animation interval of a pop-up window.
int | m_nStep
Value of step animation of a pop-up window.
XTPPopupPaintTheme | m_paintTheme
Currently used theme.
BOOL | m_bAllowMove
If TRUE, then the user can click and drag the pop-up window anywhere on the screen.
POPUPSTATE | m_stateTarget
Target descriptor.
POPUPSTATE | m_stateCurrent
Current descriptor.
CXTPImageManager * | m_pImageManager
Images of pop-up items.
BOOL | m_bRightToLeft
Right-To-Left layout.
CXTPMarkupContext * | m_pMarkupContext
Associated Markup Context.
int | m_nBackgroundBitmap
Image index used as the background of the pop-up control.
BOOL | m_bAutoDelete
TRUE to delete the pop-up after it will be closed.
XTPPopupLocation | m_nPopupLocation
Default locations for the pop-up control to display.
HCURSOR | m_hHandCursor
The system hand cursor for hyperlink items.
BOOL | m_bSplashScreenMode
TRUE to ignore mouse movement.

Detailed Description

CXTPPopupControl is a class for control of a pop-up window.

Constructor & Destructor Documentation

◆ CXTPPopupControl()

CXTPPopupControl ( BOOL bAutoDelete = FALSE )

Constructs a CXTPPopupControl object.

Parameters
bAutoDelete If TRUE, then the object will be deleted automatically upon final release.

Member Function Documentation

◆ AddItem()

CXTPPopupItem * AddItem ( CXTPPopupItem * pItem )

Call this member function to install a new controlled item in a pop-up window.

Parameters
pItem Pointer to a CXTPPopupItem object which will be installed in a pop-up window.
Returns
Pointer to the installed CXTPPopupItem object.

◆ AllowMove()

void AllowMove ( BOOL bAllowMove )

Call this member to specify whether the user can click and drag the pop-up window when it is displayed.

Parameters
bAllowMove TRUE to allow the user to click and drag the pop-up window anywhere on the screen. FALSE to prevent the pop-up window from being moved by the user.

◆ Animate()

void Animate ( int nStep )
protected

This method animates the pop-up control.

Parameters
nStep Current step of the animation.

◆ Close()

BOOL Close ( )

Call this member to destroy a pop-up window.

Returns
TRUE if successful, otherwise FALSE.

◆ Create()

virtual BOOL Create ( CWnd * pParentWnd )
protectedvirtual

Creates a pop-up window.

Parameters
pParentWnd Pointer to the parent window.
Returns
TRUE if successful, otherwise FALSE.

◆ EnableDpiBitmapScaling()

void EnableDpiBitmapScaling ( BOOL bEnable = TRUE )

Sets DPI bitmap scaling flag.

If set, all raster icons and bitmaps used in the control will be stretched automatically if DPI scaling factor for control's window isn't equal to 100%. The default value is derived from CXTPDpi::IsDpiBitmapScalingEnabled. Once changed the new value will be used.

Parameters
bEnable TRUE to enable bitmaps scaling, FALSE to disable.

◆ EnableMarkup()

void EnableMarkup ( BOOL bEnableMarkup )

Call this method to enable markup for the pop-up control.

Parameters
bEnableMarkup TRUE to enable markup.

◆ GetAnimateDelay()

DWORD GetAnimateDelay ( ) const

Call this member function to get the animate delay value for a pop-up window.

Returns
Animate delay value in milliseconds.

◆ GetBackgroundBitmap()

int GetBackgroundBitmap ( ) const

Call this member to get the bitmap index for the background.

Returns
The bitmap index for the background.
See also
SetBackgroundBitmap

◆ GetID()

int GetID ( ) const

Retrieves the ID assigned to the pop-up window when it was created.

Returns
An integer value representing the pop-up window ID.

◆ GetImageManager()

CXTPImageManager * GetImageManager ( ) const

Call this method to get a pointer to the image manager of the pop-up control.

Returns
A pointer to the image manager of the pop-up control.

The image manager is used to hold all of the icons displayed in the pop-up control.

See also
SetImageManager

◆ GetItem()

CXTPPopupItem * GetItem ( int nIndex ) const

Call this member function to get the controlled item at a specified index.

Parameters
nIndex Index of the controlled item.
Returns
Pointer to a CXTPPopupItem object.

◆ GetItemCount()

int GetItemCount ( ) const

Call this member function to get the count of controlled items in a pop-up window.

Returns
Count of controlled items.

◆ GetMarkupContext()

CXTPMarkupContext * GetMarkupContext ( ) const

Retrieves the markup context associated with the pop-up control.

Returns
A pointer to a CXTPMarkupContext object.

◆ GetPaintManager()

CXTPPopupPaintManager * GetPaintManager ( ) const

Call this member function to get the paint manager object used for drawing a pop-up window.

Returns
Pointer to the paint manager object.

◆ GetPopupAnimation()

XTPPopupAnimation GetPopupAnimation ( ) const

Call this member function to get the pop-up animation method.

Returns
Method in use. See XTPPopupAnimation enum.

◆ GetPopupPos()

CPoint GetPopupPos ( ) const

Call this member function to get the position of a pop-up window.

Returns
A CPoint object containing an XY location.

◆ GetPopupSize()

CSize GetPopupSize ( ) const

Call this member function to get the size of a pop-up window.

Returns
A CSize object containing an XY size.

◆ GetPopupState()

XTPPopupState GetPopupState ( ) const

Call this member function to get the current state of a pop-up window.

Returns
Current state. See XTPPopupState enum.

◆ GetShowDelay()

DWORD GetShowDelay ( ) const

Call this member function to get the show delay value for a pop-up window.

Returns
Show delay value in milliseconds.

◆ GetSplashScreenMode()

BOOL GetSplashScreenMode ( ) const

Call this member to see if splash screen mode has been enabled.

Returns
TRUE if splash screen mode has been enabled.

◆ GetTheme()

XTPPopupPaintTheme GetTheme ( ) const

Call this member function to get the paint theme that the pop-up window is currently using.

Returns
The paint theme that the pop-up window is currently using.
See also
SetTheme, XTPPopupPaintTheme

◆ GetTransparency()

BYTE GetTransparency ( ) const

Call this member function to get the transparency value of a pop-up window.

Returns
Transparency value of a pop-up window.

◆ HitTest()

CXTPPopupItem * HitTest ( CPoint pt ) const

Call this member function to test a point for controlled items of a pop-up window.

Parameters
pt A CPoint object containing an XY location to test.
Returns
Pointer to a CXTPPopupItem object if the test is successful, otherwise NULL.

◆ IsDpiBitmapScalingEnabled()

BOOL IsDpiBitmapScalingEnabled ( ) const

Gets DPI bitmap scaling flag.

If set, all raster icons and bitmaps used in the control will be stretched automatically if DPI scaling factor for control's window isn't equal to 100%. The default value is derived from CXTPDpi::IsDpiBitmapScalingEnabled. Once changed the new value will be used.

Returns
The current value of the DPI bitmap scaling flag for the control.

◆ IsLayoutRTL()

BOOL IsLayoutRTL ( ) const

Determines if right-to-left (RTL) mode is set.

Returns
TRUE if text is displayed using right-to-left (RTL) reading-order properties.

◆ Notify()

virtual void Notify | ( | WPARAM | wParam,
 |  | LPARAM | lParam )
 protectedvirtual

This method is called to notify the parent about an action that occurred.

Parameters
wParam | The action that occurred.
lParam | Extended parameter.

◆ OnClick()

virtual void OnClick ( CXTPPopupItem * pItem )
protectedvirtual

This method is called when the user clicks on a controlled item.

Parameters
pItem A pointer to the item that was clicked.

◆ OnExpanding()

virtual void OnExpanding ( BOOL bUpdateCurrent )
protectedvirtual

This method is called to start the expanding animation.

Parameters
bUpdateCurrent TRUE to update the current state.

◆ RemoveItem() [1/2]

void RemoveItem ( CXTPPopupItem * pItem )

Call this member function to remove a controlled item from a pop-up window.

Parameters
pItem Pointer to the CXTPPopupItem object which will be removed.

◆ RemoveItem() [2/2]

void RemoveItem ( int nIndex )

Call this member function to remove a controlled item from a pop-up window.

Parameters
nIndex Index of the CXTPPopupItem object to remove from the control.

◆ SetAnimateDelay()

void SetAnimateDelay ( DWORD dwAnimateDelay )

Call this member function to set the animate delay value for a pop-up window.

Parameters
dwAnimateDelay Animate delay value in milliseconds.

◆ SetAutoDelete()

void SetAutoDelete ( BOOL bAutoDelete )

Call this member to allow the pop-up control to delete itself automatically upon final release.

Parameters
bAutoDelete If TRUE, then the object will be deleted automatically upon final release.

◆ SetBackgroundBitmap()

void SetBackgroundBitmap ( int nBackgroundBitmap )

Call this member to set the bitmap index for the background.

Parameters
nBackgroundBitmap The bitmap index for the background.

◆ SetDefaultLocation()

void SetDefaultLocation ( XTPPopupLocation nPopupLocation )

Call this member to set the default pop-up location.

Parameters
nPopupLocation Default Popup Location (Near TaskBar, BottomLeft or Center).
See also
SetPopupPos

◆ SetImageManager()

void SetImageManager ( CXTPImageManager * pImageManager )

Call this method to set a new image manager.

Parameters
pImageManager A pointer to the CXTPImageManager object to be set. Example:
CXTPImageManager* pImageManager = new CXTPImageManager();
pImageManager->SetIcons(IDR_MAINFRAME);
m_wndPopupControl.SetImageManager(pImageManager);
See also
GetImageManager

◆ SetLayeredWindowAttributes()

BOOL SetLayeredWindowAttributes ( int bAlpha )
protected

Updates the current control's transparency.

Parameters
bAlpha Current alpha level of the window.
Returns
TRUE if successful, otherwise FALSE.

◆ SetLayoutRTL()

void SetLayoutRTL ( BOOL bRightToLeft )

Specifies if right-to-left (RTL) mode should be set.

Parameters
bRightToLeft TRUE to display text using right-to-left (RTL) reading-order properties.

◆ SetPopupAnimation()

void SetPopupAnimation ( XTPPopupAnimation popupAnimation )

Call this member function to set the pop-up animation method.

Parameters
popupAnimation Method to use. See XTPPopupAnimation enum.

◆ SetPopupPos()

void SetPopupPos ( CPoint ptPopup )

Call this member function to set the position of a pop-up window.

Parameters
ptPopup A CPoint object containing an XY location.

◆ SetPopupSize()

void SetPopupSize ( CSize szPopup )

Call this member function to set the size of a pop-up window.

Parameters
szPopup A CSize object containing an XY size.

◆ SetPopupState()

void SetPopupState ( XTPPopupState popupState )
protected

This method is called when the current state of the control changes.

Parameters
popupState Current state of the control.

◆ SetShowDelay()

void SetShowDelay ( DWORD dwShowDelay )

Call this member function to set the show delay value for a pop-up window.

Parameters
dwShowDelay Show delay value in milliseconds.

◆ SetSplashScreenMode()

void SetSplashScreenMode ( BOOL bSet )

Call this member to set splash screen mode.

Parameters
bSet TRUE to enable splash screen mode.

◆ SetTheme() [1/2]

void SetTheme ( CXTPPopupPaintManager * pPaintManager )

Call this member function to set the paint theme or paint manager used for drawing a pop-up window.

Parameters
pPaintManager Pointer to the paint manager object to use.

◆ SetTheme() [2/2]

void SetTheme ( XTPPopupPaintTheme theme )

Call this member function to set the paint theme or paint manager used for drawing a pop-up window.

Parameters
theme Paint theme to use. See XTPPopupPaintTheme enum.

◆ SetTransparency()

void SetTransparency ( BYTE bTransp )

Call this member function to set the transparency value of a pop-up window.

Parameters
bTransp Value of transparency (0...255). If bTransp = 0, then the pop-up window is fully transparent, if bTransp = 255, then the pop-up window is fully opaque.

◆ Show()

BOOL Show | ( | CWnd * | pParent,
 |  | int | nID = 0 )

Call this member function to create and expand a pop-up window.

Parameters
pParent | Pointer to a CWnd object that represents the parent window.
nID | ID for the pop-up window.
Returns
TRUE if successful, otherwise FALSE.

◆ ShowModal()

BOOL ShowModal | ( | CWnd * | pParent,
 |  | int | nID = 0 )

Call this method to show a modal pop-up control.

Parameters
pParent | Pointer to a CWnd object that represents the parent window.
nID | ID for pop-up window.
Returns
TRUE if successful, otherwise FALSE.

◆ UpdateState()

void UpdateState ( BOOL bInit = FALSE )
protected

Updates the position in the animation according to the current animation step.

Parameters
bInit Initial step of the animation.

Member Data Documentation

◆ m_bAllowMove

BOOL m_bAllowMove
protected

If TRUE, then the user can click and drag the pop-up window anywhere on the screen.

If FALSE, then the pop-up window cannot be moved by the user.

The documentation for this class was generated from the following file:
  • XTPPopupControl.h


Toolkit Pro: CXTPPopupControl::POPUPSTATE Struct Reference

  • CXTPPopupControl
  • POPUPSTATE
Public Attributes | List of all members
CXTPPopupControl::POPUPSTATE Struct Reference

Pop-up state descriptor. More...

Public Attributes

CRect | rcPopup
Pop-up position.
int | nTransparency
Pop-up transparency.

Detailed Description

Pop-up state descriptor.

See also
CXTPPopupControl::m_stateTarget, CXTPPopupControl::m_stateCurrent
The documentation for this struct was generated from the following file:
  • XTPPopupControl.h


Toolkit Pro: CXTPPopupItem Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPPopupItem Class Reference

CXTPPopupItem is a class used to manage a pop-up item object. More...

Inheritance diagram for CXTPPopupItem:
[legend]

Public Member Functions

CXTPPopupItem (LPRECT rcItem=NULL, LPCTSTR lpszCaption=NULL, COLORREF clrBack=(COLORREF) -1, COLORREF clrBorder=(COLORREF) -1)
Constructs a CXTPPopupItem object.
~CXTPPopupItem ()
Destroys a CXTPPopupItem object.
virtual void | Draw (CDC *pDC)
This method is called to draw the item.
CRect | GetRect () const
Call this member function to get the bounding rectangle of an item.
BOOL | IsButton () const
Call this member function to get the button state of an item.
void | SetButton (BOOL bButton)
Call this member function to set the button state for an item.
BOOL | IsSelected () const
Call this member function to get the selected state of an item.
BOOL | IsPressed () const
Call this member function to get the pressed state of an item.
void | SetID (int nID)
Call this member function to set the ID number for an item.
int | GetID () const
Call this member function to get the ID number of an item.
void | SetCaption (LPCTSTR str)
Call this member function to set the text for an item.
CString | GetCaption () const
Call this member function to get the text of an item.
void | SetRTFText (LPCTSTR str)
Call this member function to set the RichText for an item.
void | SetRTFText (UINT nIDResource)
Call this member function to set the RichText for an item.
void | SetMarkupText (LPCTSTR str)
Call this method to set the Markup text for the item.
void | FitToContent ()
Call this method to set item size using the size of its content.
void | SetTextColor (COLORREF clrText, COLORREF clrHotText=(COLORREF) -1)
Call this member function to set the color for an item's text.
COLORREF | GetTextColor () const
Call this member function to get the color of an item's text.
COLORREF | GetBackgroundColor () const
Call this member to get the background color of an item.
COLORREF | GetBorderColor () const
Call this member to get the border color of an item.
void | SetTextAlignment (int nAlign)
Call this member function to set the alignment style for an item's text.
int | GetTextAlignment () const
Call this member function to get the alignment style of an item's text.
void | SetTextFont (CFont *pFntText)
Call this member function to set the font for an item's text.
void | SetTextFont (PLOGFONT pLogfText)
Call this member function to set the font for an item's text.
virtual CFont * | GetTextFont ()
Call this member function to get the font of an item's text.
BOOL | IsHyperLink () const
Call this member function to determine if hyperlink support is enabled for a text item.
BOOL | IsHandCursor () const
Call this member function to determine if the sytem hand cursor should be displayed when the mouse moves over this item.
void | SetHyperLink (BOOL bHyperLink)
Call this member function to enable hyperlink support for a text item.
void | SetHandCursor (BOOL bHandCursor)
Call this member function to enable the system hand cursor displayed when the mouse moves over this item.
BOOL | IsBold () const
Call this member function to get the bold state of a text item.
BOOL | IsUnderline () const
Call this member function to get the underlined state of a text item.
void | SetBold (BOOL bBold)
Call this member function to set the bold state for a text item.
void | SetUnderline (BOOL bUnderline)
Call this member function to set the underlined state of a text item.
void | CalculateHeight ()
Call this member function to update the rectangular height of a text.
void | CalculateWidth ()
Call this member function to update the rectangular width of a text.
BOOL | SetIcon (HICON hIcon, XTPPopupItemIcon itemIcon=xtpPopupItemIconNormal)
Call this member function to set the normal, selected, or pressed icon from an icon item.
BOOL | SetIcon (UINT nIDIcon, XTPPopupItemIcon itemIcon=xtpPopupItemIconNormal)
Call this member function to set the normal, selected, or pressed icon from an icon item.
BOOL | SetIcons (UINT nIDBitmap, COLORREF clrTransparent, int itemIcon)
Call this member function to set the normal, selected, or pressed icon from a resource bitmap picture.
BOOL | SetIcons (HBITMAP hBitmap, COLORREF clrTransparent, int itemIcon, BOOL bAlphaBitmap=FALSE)
Call this member function to set the normal, selected, or pressed icon from a resource bitmap picture.
CXTPImageManagerIcon * | GetImage () const
Retrieves the icon image associated with the item.
CXTPPopupControl * | GetPopupControl () const
Retrieves the parent CXTPPopupControl object.
void | CenterIcon ()
Calculates the offset to center an icon.
CPoint | GetIconOffset () const
Call this method to retrieve the icon offset.
int | GetIconIndex () const
Call this method to retrieve the icon index of the item.
void | SetIconIndex (int nIconIndex)
Call this method to set the icon index of the item.
CXTPMarkupUIElement * | GetMarkupUIElement () const
Call this method to get the Markup element that renders the item.
CXTPRichRender * | GetRichRender () const
Call this method to get the Rich Render element that renders the item.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

void | RedrawControl ()
Call this method to redraw the parent control.
virtual void | OnItemInserted ()
This method is called when an item is inserted in the control.

Protected Attributes

int | m_nID
ID of the pop-up item.
int | m_nIndex
Zero-based index of the item in the parent pop-up control's item list.
int | m_nIconIndex
Zero-based index of the item's icon in the parent control's image list.
BOOL | m_bButton
TRUE if the pop-up item is a button, otherwise FALSE.
BOOL | m_bHyperLink
TRUE if the pop-up item is a hyperlink, otherwise FALSE.
BOOL | m_bBold
TRUE if the pop-up item's text is bold, otherwise FALSE.
BOOL | m_bUnderline
TRUE if the pop-up item's text is underlined on mouse over, otherwise FALSE.
UINT | m_nAlign
Specifies the method of formatting the text.
CXTPFont | m_xtpFontText
Pop-up item's fntText.
CRect | m_rcItem
Size and location of the pop-up item.
CPoint | m_ptOffset
x- and y- coordinates representing the offset for the pop-up item's icon.
CString | m_strCaption
Pop-up item's display text.
COLORREF | m_clrText
An RGB color value representing the item's normal text color.
COLORREF | m_clrHotText
An RGB color value representing the item's mouse over text color.
COLORREF | m_clrBack
An RGB color value representing the item's background color.
COLORREF | m_clrBorder
An RGB color value representing the item's border color.
CXTPPopupControl * | m_pControl
Pointer to the CXTPPopupControl object containing this item/.
CXTPRichRender * | m_pRichRender
Richtext Render.
CXTPMarkupUIElement * | m_pUIElement
Markup Element that renders the item.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

CXTPPopupItem is a class used to manage a pop-up item object.

Constructor & Destructor Documentation

◆ CXTPPopupItem()

CXTPPopupItem | ( | LPRECT | rcItem = NULL,
 |  | LPCTSTR | lpszCaption = NULL,
 |  | COLORREF | clrBack = (COLORREF) -1,
 |  | COLORREF | clrBorder = (COLORREF) -1 )

Constructs a CXTPPopupItem object.

Parameters
rcItem | Bounding rectangle of the item.
lpszCaption | NULL-terminated string specifying the caption text.
clrBack | Background color of the item.
clrBorder | Border color of the item

Member Function Documentation

◆ Draw()

virtual void Draw ( CDC * pDC )
virtual

This method is called to draw the item.

Parameters
pDC A CDC pointer that represents the current device context.

◆ GetBackgroundColor()

COLORREF GetBackgroundColor ( ) const

Call this member to get the background color of an item.

Returns
The background color of a pop-up control item.

◆ GetBorderColor()

COLORREF GetBorderColor ( ) const

Call this member to get the border color of an item.

Returns
The border color of a pop-up control item.

◆ GetCaption()

CString GetCaption ( ) const

Call this member function to get the text of an item.

Returns
A CString object that represents the item text.

◆ GetIconIndex()

int GetIconIndex ( ) const

Call this method to retrieve the icon index of the item.

Returns
Icon index.
See also
SetIconIndex, CXTPPopupControl::GetImageManager

◆ GetIconOffset()

CPoint GetIconOffset ( ) const

Call this method to retrieve the icon offset.

Returns
Position of the icon inside the item's bounding rectangle.

◆ GetID()

int GetID ( ) const

Call this member function to get the ID number of an item.

Returns
The ID number value of the item.

◆ GetImage()

CXTPImageManagerIcon * GetImage ( ) const

Retrieves the icon image associated with the item.

Returns
A CXTPImageManagerIcon pointer to the icon.

◆ GetMarkupUIElement()

CXTPMarkupUIElement * GetMarkupUIElement ( ) const

Call this method to get the Markup element that renders the item.

Returns
Pointer to the Markup element.

◆ GetPopupControl()

CXTPPopupControl * GetPopupControl ( ) const

Retrieves the parent CXTPPopupControl object.

Returns
A pointer to the parent CXTPPopupControl object.

◆ GetRect()

CRect GetRect ( ) const

Call this member function to get the bounding rectangle of an item.

Returns
The bounding rectangle of the item.

◆ GetRichRender()

CXTPRichRender * GetRichRender ( ) const

Call this method to get the Rich Render element that renders the item.

Returns
Pointer to the Rich Render element.

◆ GetTextAlignment()

int GetTextAlignment ( ) const

Call this member function to get the alignment style of an item's text.

Returns
The alignment style of an item's text.

◆ GetTextColor()

COLORREF GetTextColor ( ) const

Call this member function to get the color of an item's text.

Returns
A COLORREF object that represents the color of an item's text.

◆ GetTextFont()

virtual CFont * GetTextFont ( )
virtual

Call this member function to get the font of an item's text.

Returns
Pointer to a CFont object.

◆ IsBold()

BOOL IsBold ( ) const

Call this member function to get the bold state of a text item.

Returns
TRUE if the item state is bold, otherwise FALSE.

◆ IsButton()

BOOL IsButton ( ) const

Call this member function to get the button state of an item.

Returns
TRUE if button state is enabled, otherwise FALSE.

◆ IsHandCursor()

BOOL IsHandCursor ( ) const

Call this member function to determine if the sytem hand cursor should be displayed when the mouse moves over this item.

Returns
TRUE if the hand cursor should be displayed, otherwise FALSE.

◆ IsHyperLink()

BOOL IsHyperLink ( ) const

Call this member function to determine if hyperlink support is enabled for a text item.

Returns
TRUE if hyperlink support is enabled, otherwise FALSE.

◆ IsPressed()

BOOL IsPressed ( ) const

Call this member function to get the pressed state of an item.

Returns
TRUE if the item is pressed, otherwise FALSE.

◆ IsSelected()

BOOL IsSelected ( ) const

Call this member function to get the selected state of an item.

Returns
TRUE if the item is selected, otherwise FALSE.

◆ IsUnderline()

BOOL IsUnderline ( ) const

Call this member function to get the underlined state of a text item.

The item state is underlined if the item is a hyperlink whose text is drawn underlined when the mouse hovers over it.

Returns
TRUE if the item state is underlined when the mouse hovers over it, otherwise FALSE.

◆ SetBold()

void SetBold ( BOOL bBold )

Call this member function to set the bold state for a text item.

Parameters
bBold TRUE to set the item state to bold, FALSE otherwise.

◆ SetButton()

void SetButton ( BOOL bButton )

Call this member function to set the button state for an item.

Parameters
bButton TRUE to enable button state, FALSE otherwise.

◆ SetCaption()

void SetCaption ( LPCTSTR str )

Call this member function to set the text for an item.

Parameters
str A LPCTSTR object that represents the item text.

◆ SetHandCursor()

void SetHandCursor ( BOOL bHandCursor )

Call this member function to enable the system hand cursor displayed when the mouse moves over this item.

Parameters
bHandCursor TRUE to enable the system hand cursor, FALSE otherwise.

◆ SetHyperLink()

void SetHyperLink ( BOOL bHyperLink )

Call this member function to enable hyperlink support for a text item.

Parameters
bHyperLink TRUE to enable hyperlink support, FALSE otherwise.

◆ SetIcon() [1/2]

BOOL SetIcon | ( | HICON | hIcon,
 |  | XTPPopupItemIcon | itemIcon = xtpPopupItemIconNormal )

Call this member function to set the normal, selected, or pressed icon from an icon item.

Parameters
hIcon | Handle to the icon.
itemIcon | Type of icon in use. See XTPPopupItemIcon.
Returns
TRUE if successful, otherwise FALSE.

◆ SetIcon() [2/2]

BOOL SetIcon | ( | UINT | nIDIcon,
 |  | XTPPopupItemIcon | itemIcon = xtpPopupItemIconNormal )

Call this member function to set the normal, selected, or pressed icon from an icon item.

Parameters
nIDIcon | ID for the icon.
itemIcon | Type of icon in use. See XTPPopupItemIcon.
Returns
TRUE if successful, otherwise FALSE.

◆ SetIconIndex()

void SetIconIndex ( int nIconIndex )

Call this method to set the icon index of the item.

Parameters
nIconIndex Icon index to be set.
See also
GetIconIndex, CXTPPopupControl::GetImageManager

◆ SetIcons() [1/2]

BOOL SetIcons | ( | HBITMAP | hBitmap,
 |  | COLORREF | clrTransparent,
 |  | int | itemIcon,
 |  | BOOL | bAlphaBitmap = FALSE )

Call this member function to set the normal, selected, or pressed icon from a resource bitmap picture.

Parameters
hBitmap | Bitmap handle to set.
clrTransparent | Transparent color.
itemIcon | Type of icon in use. See XTPPopupItemIcon.
bAlphaBitmap | TRUE if the bitmaps specified by hBitmap is alpha blended.
Returns
TRUE if successful, otherwise FALSE.

◆ SetIcons() [2/2]

BOOL SetIcons | ( | UINT | nIDBitmap,
 |  | COLORREF | clrTransparent,
 |  | int | itemIcon )

Call this member function to set the normal, selected, or pressed icon from a resource bitmap picture.

Parameters
nIDBitmap | Resource ID for the bitmap.
clrTransparent | Transparent color.
itemIcon | Type of icon in use. See XTPPopupItemIcon.
Returns
TRUE if successful, otherwise FALSE.

◆ SetID()

void SetID ( int nID )

Call this member function to set the ID number for an item.

Parameters
nID The ID number value for the item.

◆ SetMarkupText()

void SetMarkupText ( LPCTSTR str )

Call this method to set the Markup text for the item.

Parameters
str A LPCTSTR object that represents the Markup text.

◆ SetRTFText() [1/2]

void SetRTFText ( LPCTSTR str )

Call this member function to set the RichText for an item.

Parameters
str A LPCTSTR object that represents the item text.

◆ SetRTFText() [2/2]

void SetRTFText ( UINT nIDResource )

Call this member function to set the RichText for an item.

Parameters
nIDResource The ID number value of the resource used.

◆ SetTextAlignment()

void SetTextAlignment ( int nAlign )

Call this member function to set the alignment style for an item's text.

Parameters
nAlign The alignment style of an item's text.

◆ SetTextColor()

void SetTextColor | ( | COLORREF | clrText,
 |  | COLORREF | clrHotText = (COLORREF) -1 )

Call this member function to set the color for an item's text.

Parameters
clrText | An RGB color value that represents the item's text color.
clrHotText | An RGB color value that represents the item's text color when the mouse is hovering over it.

◆ SetTextFont() [1/2]

void SetTextFont ( CFont * pFntText )

Call this member function to set the font for an item's text.

Parameters
pFntText Pointer to a CFont object.

◆ SetTextFont() [2/2]

void SetTextFont ( PLOGFONT pLogfText )

Call this member function to set the font for an item's text.

Parameters
pLogfText Pointer to a LOGFONT structure.

◆ SetUnderline()

void SetUnderline ( BOOL bUnderline )

Call this member function to set the underlined state of a text item.

If bUnderline is TRUE and the item is a hyperlink, then text will be drawn underlined when the mouse hovers over it.

Parameters
bUnderline TRUE to set the item state to underlined when the mouse hovers over it, FALSE otherwise.

Member Data Documentation

◆ m_nAlign

UINT m_nAlign
protected

Specifies the method of formatting the text.

It can be any combination of the values described for the nAlign parameter in CDC::DrawText.

The documentation for this class was generated from the following file:
  • XTPPopupItem.h


Toolkit Pro: CXTPPopupPaintManager Class Reference

Public Member Functions | Public Attributes | List of all members
CXTPPopupPaintManager Class Reference

CXTPPopupPaintManager is a class used to perform specialized drawing tasks. More...

Inheritance diagram for CXTPPopupPaintManager:
[legend]

Public Member Functions

CXTPPopupPaintManager ()
Constructs a CXTPPopupPaintManager object.
virtual | ~CXTPPopupPaintManager ()
Destroys a CXTPPopupPaintManager object.
virtual void | DrawBackground (CDC *pDC, CXTPPopupControl *pControl, CRect rcClient)
Call this member function to draw the background of a pop-up window.
void | DrawItem (CDC *pDC, CXTPPopupItem *pItem)
Call this member function to draw the controlled item object of a pop-up window.
virtual void | DrawButton (CDC *pDC, CXTPPopupItem *pItem)
Call this method to draw the rectangle of a button.
virtual void | DrawItemIcon (CDC *pDC, CXTPPopupItem *pItem)
Call this method to draw the icon of a button.
void | SetFont (HFONT hFont)
Sets the font for text used in a pop-up control.
virtual void | RefreshMetrics ()
Call this member function to refresh draw metrics.

Public Attributes

CXTPPaintManagerColorGradient | m_clrBackground
Gradient background color.
CXTPPaintManagerColorGradient | m_clrFrame
3D frame color.
CXTPFont | m_xtpFontText
Default font of text.
COLORREF | m_clrText
Default color of text.
COLORREF | m_clrButtonSelected
Color of selected button.
COLORREF | m_clrButtonPressed
Color of pressed button.
CXTPPaintManagerColorGradient | m_clrButtonSelectedBorder
3D border color of selected button.
CXTPPaintManagerColorGradient | m_clrButtonPressedBorder
3D border color of pressed button.

Detailed Description

CXTPPopupPaintManager is a class used to perform specialized drawing tasks.

Member Function Documentation

◆ DrawBackground()

virtual void DrawBackground | ( | CDC * | pDC,
 |  | CXTPPopupControl * | pControl,
 |  | CRect | rcClient )
 virtual

Call this member function to draw the background of a pop-up window.

Parameters
pDC | Pointer to the device context.
rcClient | Size of the area to fill.
pControl | Pop-up control to draw.

Reimplemented in CXTPPopupThemeMSN, CXTPPopupThemeOffice2000, CXTPPopupThemeOffice2003, and CXTPPopupThemeOfficeXP.

◆ DrawButton()

virtual void DrawButton | ( | CDC * | pDC,
 |  | CXTPPopupItem * | pItem )
 virtual

Call this method to draw the rectangle of a button.

Parameters
pDC | Pointer to the device context.
pItem | Pointer to a CXTPPopupItem object.

◆ DrawItem()

void DrawItem | ( | CDC * | pDC,
 |  | CXTPPopupItem * | pItem )

Call this member function to draw the controlled item object of a pop-up window.

Parameters
pDC | Pointer to the device context.
pItem | Pointer to a CXTPPopupItem object.

◆ DrawItemIcon()

virtual void DrawItemIcon | ( | CDC * | pDC,
 |  | CXTPPopupItem * | pItem )
 virtual

Call this method to draw the icon of a button.

Parameters
pDC | Pointer to the device context.
pItem | Pointer to a CXTPPopupItem object.

◆ SetFont()

void SetFont ( HFONT hFont )

Sets the font for text used in a pop-up control.

Parameters
hFont Font handle to use.
The documentation for this class was generated from the following file:
  • XTPPopupPaintManager.h


Toolkit Pro: CXTPPopupThemeMSN Class Reference

Public Member Functions | List of all members
CXTPPopupThemeMSN Class Reference

CXTPPopupThemeMSN is a class used to perform MSN Messenger drawing tasks. More...

Inheritance diagram for CXTPPopupThemeMSN:
[legend]

Public Member Functions

CXTPPopupThemeMSN ()
Constructs a CXTPPopupThemeMSN object.
virtual | ~CXTPPopupThemeMSN ()
Destroys a CXTPPopupThemeMSN object.
void | RefreshMetrics ()
Call this member function to refresh draw metrics.
virtual void | DrawBackground (CDC *pDC, CXTPPopupControl *pControl, CRect rcClient)
Call this member function to draw the background of a pop-up window.
- Public Member Functions inherited from CXTPPopupThemeOffice2000
CXTPPopupThemeOffice2000 ()
Constructs a CXTPPopupThemeOffice2000 object.
virtual | ~CXTPPopupThemeOffice2000 ()
Destroys a CXTPPopupThemeOffice2000 object.
void | RefreshMetrics ()
Call this member function to refresh draw metrics.
- Public Member Functions inherited from CXTPPopupPaintManager
CXTPPopupPaintManager ()
Constructs a CXTPPopupPaintManager object.
virtual | ~CXTPPopupPaintManager ()
Destroys a CXTPPopupPaintManager object.
void | DrawItem (CDC *pDC, CXTPPopupItem *pItem)
Call this member function to draw the controlled item object of a pop-up window.
virtual void | DrawButton (CDC *pDC, CXTPPopupItem *pItem)
Call this method to draw the rectangle of a button.
virtual void | DrawItemIcon (CDC *pDC, CXTPPopupItem *pItem)
Call this method to draw the icon of a button.
void | SetFont (HFONT hFont)
Sets the font for text used in a pop-up control.

Additional Inherited Members

- Public Attributes inherited from CXTPPopupPaintManager
CXTPPaintManagerColorGradient | m_clrBackground
Gradient background color.
CXTPPaintManagerColorGradient | m_clrFrame
3D frame color.
CXTPFont | m_xtpFontText
Default font of text.
COLORREF | m_clrText
Default color of text.
COLORREF | m_clrButtonSelected
Color of selected button.
COLORREF | m_clrButtonPressed
Color of pressed button.
CXTPPaintManagerColorGradient | m_clrButtonSelectedBorder
3D border color of selected button.
CXTPPaintManagerColorGradient | m_clrButtonPressedBorder
3D border color of pressed button.

Detailed Description

CXTPPopupThemeMSN is a class used to perform MSN Messenger drawing tasks.

Member Function Documentation

◆ DrawBackground()

virtual void DrawBackground | ( | CDC * | pDC,
 |  | CXTPPopupControl * | pControl,
 |  | CRect | rcClient )
 virtual

Call this member function to draw the background of a pop-up window.

Parameters
pDC | Pointer to the device context.
rcClient | Size of the area to fill.
pControl | Pop-up control to draw.

Reimplemented from CXTPPopupThemeOffice2000.

The documentation for this class was generated from the following file:
  • XTPPopupThemeMSN.h


Toolkit Pro: CXTPPopupThemeOffice2000 Class Reference

Public Member Functions | List of all members
CXTPPopupThemeOffice2000 Class Reference

CXTPPopupThemeOffice2000 is a class used to perform Office 2000 drawing tasks. More...

Inheritance diagram for CXTPPopupThemeOffice2000:
[legend]

Public Member Functions

CXTPPopupThemeOffice2000 ()
Constructs a CXTPPopupThemeOffice2000 object.
virtual | ~CXTPPopupThemeOffice2000 ()
Destroys a CXTPPopupThemeOffice2000 object.
void | RefreshMetrics ()
Call this member function to refresh draw metrics.
virtual void | DrawBackground (CDC *pDC, CXTPPopupControl *pControl, CRect rcClient)
Call this member function to draw the background of a pop-up window.
- Public Member Functions inherited from CXTPPopupPaintManager
CXTPPopupPaintManager ()
Constructs a CXTPPopupPaintManager object.
virtual | ~CXTPPopupPaintManager ()
Destroys a CXTPPopupPaintManager object.
void | DrawItem (CDC *pDC, CXTPPopupItem *pItem)
Call this member function to draw the controlled item object of a pop-up window.
virtual void | DrawButton (CDC *pDC, CXTPPopupItem *pItem)
Call this method to draw the rectangle of a button.
virtual void | DrawItemIcon (CDC *pDC, CXTPPopupItem *pItem)
Call this method to draw the icon of a button.
void | SetFont (HFONT hFont)
Sets the font for text used in a pop-up control.

Additional Inherited Members

- Public Attributes inherited from CXTPPopupPaintManager
CXTPPaintManagerColorGradient | m_clrBackground
Gradient background color.
CXTPPaintManagerColorGradient | m_clrFrame
3D frame color.
CXTPFont | m_xtpFontText
Default font of text.
COLORREF | m_clrText
Default color of text.
COLORREF | m_clrButtonSelected
Color of selected button.
COLORREF | m_clrButtonPressed
Color of pressed button.
CXTPPaintManagerColorGradient | m_clrButtonSelectedBorder
3D border color of selected button.
CXTPPaintManagerColorGradient | m_clrButtonPressedBorder
3D border color of pressed button.

Detailed Description

CXTPPopupThemeOffice2000 is a class used to perform Office 2000 drawing tasks.

Member Function Documentation

◆ DrawBackground()

virtual void DrawBackground | ( | CDC * | pDC,
 |  | CXTPPopupControl * | pControl,
 |  | CRect | rcClient )
 virtual

Call this member function to draw the background of a pop-up window.

Parameters
pDC | Pointer to the device context.
rcClient | Size of the area to fill.
pControl | Pop-up control to draw.

Reimplemented from CXTPPopupPaintManager.

Reimplemented in CXTPPopupThemeMSN, CXTPPopupThemeOffice2003, and CXTPPopupThemeOfficeXP.

The documentation for this class was generated from the following file:
  • XTPPopupThemeOffice2000.h


Toolkit Pro: CXTPPopupThemeOffice2003 Class Reference

Public Member Functions | Public Attributes | List of all members
CXTPPopupThemeOffice2003 Class Reference

CXTPPopupThemeOffice2003 is a class used to perform Office 2003 drawing tasks. More...

Inheritance diagram for CXTPPopupThemeOffice2003:
[legend]

Public Member Functions

CXTPPopupThemeOffice2003 ()
Constructs a CXTPPopupThemeOffice2003 object.
virtual | ~CXTPPopupThemeOffice2003 ()
Destroys a CXTPPopupThemeOffice2003 object.
void | RefreshMetrics ()
Call this member function to refresh draw metrics.
virtual void | DrawBackground (CDC *pDC, CXTPPopupControl *pControl, CRect rcClient)
Call this member function to draw the background of a pop-up window.
- Public Member Functions inherited from CXTPPopupThemeOfficeXP
CXTPPopupThemeOfficeXP ()
Constructs a CXTPPopupThemeOfficeXP object.
virtual | ~CXTPPopupThemeOfficeXP ()
Destroys a CXTPPopupThemeOfficeXP object.
void | RefreshMetrics ()
Call this member function to refresh draw metrics.
- Public Member Functions inherited from CXTPPopupThemeOffice2000
CXTPPopupThemeOffice2000 ()
Constructs a CXTPPopupThemeOffice2000 object.
virtual | ~CXTPPopupThemeOffice2000 ()
Destroys a CXTPPopupThemeOffice2000 object.
- Public Member Functions inherited from CXTPPopupPaintManager
CXTPPopupPaintManager ()
Constructs a CXTPPopupPaintManager object.
virtual | ~CXTPPopupPaintManager ()
Destroys a CXTPPopupPaintManager object.
void | DrawItem (CDC *pDC, CXTPPopupItem *pItem)
Call this member function to draw the controlled item object of a pop-up window.
virtual void | DrawButton (CDC *pDC, CXTPPopupItem *pItem)
Call this method to draw the rectangle of a button.
virtual void | DrawItemIcon (CDC *pDC, CXTPPopupItem *pItem)
Call this method to draw the icon of a button.
void | SetFont (HFONT hFont)
Sets the font for text used in a pop-up control.

Public Attributes

CXTPPaintManagerColorGradient | m_clrGripper
Color of the pop-up gripper for the.
- Public Attributes inherited from CXTPPopupPaintManager
CXTPPaintManagerColorGradient | m_clrBackground
Gradient background color.
CXTPPaintManagerColorGradient | m_clrFrame
3D frame color.
CXTPFont | m_xtpFontText
Default font of text.
COLORREF | m_clrText
Default color of text.
COLORREF | m_clrButtonSelected
Color of selected button.
COLORREF | m_clrButtonPressed
Color of pressed button.
CXTPPaintManagerColorGradient | m_clrButtonSelectedBorder
3D border color of selected button.
CXTPPaintManagerColorGradient | m_clrButtonPressedBorder
3D border color of pressed button.

Detailed Description

CXTPPopupThemeOffice2003 is a class used to perform Office 2003 drawing tasks.

Member Function Documentation

◆ DrawBackground()

virtual void DrawBackground | ( | CDC * | pDC,
 |  | CXTPPopupControl * | pControl,
 |  | CRect | rcClient )
 virtual

Call this member function to draw the background of a pop-up window.

Parameters
pDC | Pointer to the device context.
rcClient | Size of the area to fill.
pControl | Pop-up control to draw.

Reimplemented from CXTPPopupThemeOfficeXP.

The documentation for this class was generated from the following file:
  • XTPPopupThemeOffice2003.h


Toolkit Pro: CXTPPopupThemeOffice2013 Class Reference

Public Member Functions | List of all members
CXTPPopupThemeOffice2013 Class Reference

CXTPPopupThemeOffice2013 is a class used to perform Office 2013 drawing tasks. More...

Inheritance diagram for CXTPPopupThemeOffice2013:
[legend]

Public Member Functions

CXTPPopupThemeOffice2013 ()
Constructs a CXTPPopupThemeOffice2013 object.
virtual | ~CXTPPopupThemeOffice2013 ()
Destroys a CXTPPopupThemeOffice2013 object.
void | RefreshMetrics ()
Call this member function to refresh draw metrics.
- Public Member Functions inherited from CXTPPopupThemeOffice2003
CXTPPopupThemeOffice2003 ()
Constructs a CXTPPopupThemeOffice2003 object.
virtual | ~CXTPPopupThemeOffice2003 ()
Destroys a CXTPPopupThemeOffice2003 object.
virtual void | DrawBackground (CDC *pDC, CXTPPopupControl *pControl, CRect rcClient)
Call this member function to draw the background of a pop-up window.
- Public Member Functions inherited from CXTPPopupThemeOfficeXP
CXTPPopupThemeOfficeXP ()
Constructs a CXTPPopupThemeOfficeXP object.
virtual | ~CXTPPopupThemeOfficeXP ()
Destroys a CXTPPopupThemeOfficeXP object.
void | RefreshMetrics ()
Call this member function to refresh draw metrics.
- Public Member Functions inherited from CXTPPopupThemeOffice2000
CXTPPopupThemeOffice2000 ()
Constructs a CXTPPopupThemeOffice2000 object.
virtual | ~CXTPPopupThemeOffice2000 ()
Destroys a CXTPPopupThemeOffice2000 object.
- Public Member Functions inherited from CXTPPopupPaintManager
CXTPPopupPaintManager ()
Constructs a CXTPPopupPaintManager object.
virtual | ~CXTPPopupPaintManager ()
Destroys a CXTPPopupPaintManager object.
void | DrawItem (CDC *pDC, CXTPPopupItem *pItem)
Call this member function to draw the controlled item object of a pop-up window.
virtual void | DrawButton (CDC *pDC, CXTPPopupItem *pItem)
Call this method to draw the rectangle of a button.
virtual void | DrawItemIcon (CDC *pDC, CXTPPopupItem *pItem)
Call this method to draw the icon of a button.
void | SetFont (HFONT hFont)
Sets the font for text used in a pop-up control.

Additional Inherited Members

- Public Attributes inherited from CXTPPopupThemeOffice2003
CXTPPaintManagerColorGradient | m_clrGripper
Color of the pop-up gripper for the.
- Public Attributes inherited from CXTPPopupPaintManager
CXTPPaintManagerColorGradient | m_clrBackground
Gradient background color.
CXTPPaintManagerColorGradient | m_clrFrame
3D frame color.
CXTPFont | m_xtpFontText
Default font of text.
COLORREF | m_clrText
Default color of text.
COLORREF | m_clrButtonSelected
Color of selected button.
COLORREF | m_clrButtonPressed
Color of pressed button.
CXTPPaintManagerColorGradient | m_clrButtonSelectedBorder
3D border color of selected button.
CXTPPaintManagerColorGradient | m_clrButtonPressedBorder
3D border color of pressed button.

Detailed Description

CXTPPopupThemeOffice2013 is a class used to perform Office 2013 drawing tasks.

The documentation for this class was generated from the following file:
  • XTPPopupThemeOffice2013.h


Toolkit Pro: CXTPPopupThemeOfficeXP Class Reference

Public Member Functions | List of all members
CXTPPopupThemeOfficeXP Class Reference

CXTPPopupThemeOfficeXP is a class used to perform Office XP drawing tasks. More...

Inheritance diagram for CXTPPopupThemeOfficeXP:
[legend]

Public Member Functions

CXTPPopupThemeOfficeXP ()
Constructs a CXTPPopupThemeOfficeXP object.
virtual | ~CXTPPopupThemeOfficeXP ()
Destroys a CXTPPopupThemeOfficeXP object.
void | RefreshMetrics ()
Call this member function to refresh draw metrics.
virtual void | DrawBackground (CDC *pDC, CXTPPopupControl *pControl, CRect rcClient)
Call this member function to draw the background of a pop-up window.
- Public Member Functions inherited from CXTPPopupThemeOffice2000
CXTPPopupThemeOffice2000 ()
Constructs a CXTPPopupThemeOffice2000 object.
virtual | ~CXTPPopupThemeOffice2000 ()
Destroys a CXTPPopupThemeOffice2000 object.
- Public Member Functions inherited from CXTPPopupPaintManager
CXTPPopupPaintManager ()
Constructs a CXTPPopupPaintManager object.
virtual | ~CXTPPopupPaintManager ()
Destroys a CXTPPopupPaintManager object.
void | DrawItem (CDC *pDC, CXTPPopupItem *pItem)
Call this member function to draw the controlled item object of a pop-up window.
virtual void | DrawButton (CDC *pDC, CXTPPopupItem *pItem)
Call this method to draw the rectangle of a button.
virtual void | DrawItemIcon (CDC *pDC, CXTPPopupItem *pItem)
Call this method to draw the icon of a button.
void | SetFont (HFONT hFont)
Sets the font for text used in a pop-up control.

Additional Inherited Members

- Public Attributes inherited from CXTPPopupPaintManager
CXTPPaintManagerColorGradient | m_clrBackground
Gradient background color.
CXTPPaintManagerColorGradient | m_clrFrame
3D frame color.
CXTPFont | m_xtpFontText
Default font of text.
COLORREF | m_clrText
Default color of text.
COLORREF | m_clrButtonSelected
Color of selected button.
COLORREF | m_clrButtonPressed
Color of pressed button.
CXTPPaintManagerColorGradient | m_clrButtonSelectedBorder
3D border color of selected button.
CXTPPaintManagerColorGradient | m_clrButtonPressedBorder
3D border color of pressed button.

Detailed Description

CXTPPopupThemeOfficeXP is a class used to perform Office XP drawing tasks.

Member Function Documentation

◆ DrawBackground()

virtual void DrawBackground | ( | CDC * | pDC,
 |  | CXTPPopupControl * | pControl,
 |  | CRect | rcClient )
 virtual

Call this member function to draw the background of a pop-up window.

Parameters
pDC | Pointer to the device context.
rcClient | Size of the area to fill.
pControl | Pop-up control to draw.

Reimplemented from CXTPPopupThemeOffice2000.

Reimplemented in CXTPPopupThemeOffice2003.

The documentation for this class was generated from the following file:
  • XTPPopupThemeOfficeXP.h


Toolkit Pro: CXTPPopupThemeResource Class Reference

Public Member Functions | List of all members
CXTPPopupThemeResource Class Reference

CXTPPopupThemeResource is a class used to perform resource drawing tasks. More...

Inheritance diagram for CXTPPopupThemeResource:
[legend]

Public Member Functions

CXTPPopupThemeResource ()
Constructs a CXTPPopupThemeOffice2003 object.
void | RefreshMetrics ()
Call this member function to refresh draw metrics.
- Public Member Functions inherited from CXTPPopupThemeOffice2003
CXTPPopupThemeOffice2003 ()
Constructs a CXTPPopupThemeOffice2003 object.
virtual | ~CXTPPopupThemeOffice2003 ()
Destroys a CXTPPopupThemeOffice2003 object.
virtual void | DrawBackground (CDC *pDC, CXTPPopupControl *pControl, CRect rcClient)
Call this member function to draw the background of a pop-up window.
- Public Member Functions inherited from CXTPPopupThemeOfficeXP
CXTPPopupThemeOfficeXP ()
Constructs a CXTPPopupThemeOfficeXP object.
virtual | ~CXTPPopupThemeOfficeXP ()
Destroys a CXTPPopupThemeOfficeXP object.
- Public Member Functions inherited from CXTPPopupThemeOffice2000
CXTPPopupThemeOffice2000 ()
Constructs a CXTPPopupThemeOffice2000 object.
virtual | ~CXTPPopupThemeOffice2000 ()
Destroys a CXTPPopupThemeOffice2000 object.
- Public Member Functions inherited from CXTPPopupPaintManager
CXTPPopupPaintManager ()
Constructs a CXTPPopupPaintManager object.
virtual | ~CXTPPopupPaintManager ()
Destroys a CXTPPopupPaintManager object.
void | DrawItem (CDC *pDC, CXTPPopupItem *pItem)
Call this member function to draw the controlled item object of a pop-up window.
virtual void | DrawButton (CDC *pDC, CXTPPopupItem *pItem)
Call this method to draw the rectangle of a button.
virtual void | DrawItemIcon (CDC *pDC, CXTPPopupItem *pItem)
Call this method to draw the icon of a button.
void | SetFont (HFONT hFont)
Sets the font for text used in a pop-up control.

Additional Inherited Members

- Public Attributes inherited from CXTPPopupThemeOffice2003
CXTPPaintManagerColorGradient | m_clrGripper
Color of the pop-up gripper for the.
- Public Attributes inherited from CXTPPopupPaintManager
CXTPPaintManagerColorGradient | m_clrBackground
Gradient background color.
CXTPPaintManagerColorGradient | m_clrFrame
3D frame color.
CXTPFont | m_xtpFontText
Default font of text.
COLORREF | m_clrText
Default color of text.
COLORREF | m_clrButtonSelected
Color of selected button.
COLORREF | m_clrButtonPressed
Color of pressed button.
CXTPPaintManagerColorGradient | m_clrButtonSelectedBorder
3D border color of selected button.
CXTPPaintManagerColorGradient | m_clrButtonPressedBorder
3D border color of pressed button.

Detailed Description

CXTPPopupThemeResource is a class used to perform resource drawing tasks.

The documentation for this class was generated from the following file:
  • XTPPopupThemeResource.h


Toolkit Pro: CXTPPopupToolBar Class Reference

Static Public Member Functions | Protected Member Functions | List of all members
CXTPPopupToolBar Class Reference

CXTPPopupToolBar is a CXTPPopupBar derived class. More...

Inheritance diagram for CXTPPopupToolBar:
[legend]

Static Public Member Functions

static CXTPPopupToolBar *AFX_CDECL | CreatePopupToolBar (CXTPCommandBars *pCommandBars)
Creates a pop-up toolbar object.
- Static Public Member Functions inherited from CXTPPopupBar
static CXTPPopupBar *AFX_CDECL | CreatePopupBar (CXTPCommandBars *pCommandBars)
Creates a pop-up bar object.

Protected Member Functions

CSize | CalcDynamicLayout (int nLength, DWORD dwMode)
This method is called to get the size of the command bar.
- Protected Member Functions inherited from CXTPPopupBar
CXTPPopupBar ()
Constructs a CXTPPopupBar object.
virtual | ~CXTPPopupBar ()
Destroys a CXTPPopupBar object, handles cleanup and deallocation.
virtual void | DelayRedraw ()
Redraw the pop-up bar.
virtual BOOL | SetSelected (int nSelected, BOOL bKeyboard=FALSE)
Call this member to select the specified control.
void | UpdateLocation (CSize sz)
This method sets the pop-up bar's position.
virtual void | UpdateFlags ()
Update flags.
void | UpdateExpandingState ()
Update expanding state.
virtual void | DrawCommandBar (CDC *pDC, CRect rcClipBox)
This method is called to draw the command bar in the given context.
virtual void | OnControlsChanged ()
This method is called when the controls array is changed.
virtual void | OnRecalcLayout ()
This method is called to recalculate the command bar layout.
CXTPCommandBar * | GetParentCommandBar () const
Call this member to retrieve the parent command bar.
virtual void | DoPropExchange (CXTPPropExchange *pPX)
Either reads this object from or writes this object to an archive.
virtual void | Copy (CXTPCommandBar *pCommandBar, BOOL bRecursive=FALSE)
Call this method make a copy of the command bar.
virtual BOOL | OnHookKeyDown (UINT nChar, LPARAM lParam)
The framework calls this member function when a non-system key is pressed.
virtual void | AdjustExcludeRect (CRect &rc, BOOL bVertical)
Updates rectangle to set the position where the child pop-up bar becomes visible.
virtual void | Animate ()
Animates pop-up window.
- Protected Member Functions inherited from CXTPCommandBar
CXTPCommandBar ()
Constructs a CXTPCommandBar object.
virtual | ~CXTPCommandBar ()
Destroys a CXTPCommandBar object, handles cleanup and deallocation.
virtual BOOL | ProcessSpecialKey (XTPSpecialKey key)
This method is called to process special keys.
virtual int | OnMouseHitTest (CPoint pt)
This method is called to determine mouse hit code.
virtual void | UpdateShortcuts ()
Updates the control's shortcuts.
UINT | GetActiveDocTemplate () const
Retrieves the active MDI document template.
virtual void | GenerateCommandBarList (DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam)
This method is called to assign self identifiers for the serialization process.
virtual void | RestoreCommandBarList (CXTPCommandBarList *pCommandBarList)
This method is called in the serialization process to restore pop-ups from a list of command bars.
BOOL | IsHelpMode () const
Determines if the parent frame is in help mode.
virtual void | OnRemoved ()
This method is called when a toolbar is removed from the command bars collection.

Additional Inherited Members

- Public Member Functions inherited from CXTPPopupBar
void | SetTearOffPopup (LPCTSTR lpszCaption, UINT nID, int nWidth=400)
This method adds the tear-off state to the pop-up bar.
BOOL | IsTearOffPopup (CString &strCaption, UINT &nID, int &nWidth)
Determines if the pop-up bar has the tear-off state.
virtual BOOL | IsVisible () const
Call this member to determine if the pop-up menu is visible/displayed.
BOOL | Popup (int xPos, int yPos, LPCRECT rcExclude)
This method opens the pop-up bar.
BOOL | Popup (CXTPControlPopup *pControlPopup, BOOL bSelectFirst=FALSE)
This method opens the pop-up bar.
CXTPControlPopup * | GetControlPopup () const
Call this member to retrieve the control's pop-up.
void | ExpandBar ()
This method expands the bar.
BOOL | DestroyWindow ()
Call this member to destroy the window.
void | SetPopupToolBar (BOOL bToolBarType)
Call this method to make the pop-up bar look like a pop-up toolbar.
void | SetDefaultItem (UINT uItem, BOOL fByPos=FALSE)
Sets the default menu item for the specified pop-up bar.
UINT | GetDefaultItem (UINT gmdiFlags, BOOL fByPos=FALSE)
Determines the default menu item on the specified pop-up bar.
BOOL | IsDoubleGripper () const
Call this method to determine if the pop-up bar has a double gripper.
void | SetDoubleGripper (BOOL bDoubleGripper=TRUE)
Call this member to set a double gripper for the pop-up bar.
virtual BOOL | IsPopupBar () const
Call this member function to determine if the command bar is a CXTPPopupBar.
BOOL | IsContextMenu () const
Determines if the pop-up bar is a context menu.
void | PumpMessage ()
Translates all messages in the message queue.
virtual BOOL | Create ()
Creates the pop-up bar.
virtual CRect | CalculatePopupRect (CPoint ptPopup, CSize sz)
This method is called to calculate the destination rectangle of the pop-up bar.
void | SetPopupFlags (DWORD dwPopupFlags)
Call this method to set the pop-up direction.
virtual BOOL | SetTrackingMode (int bMode, BOOL bSelectFirst=TRUE, BOOL bKeyboard=FALSE)
Call this member to change the tracking state.
void | SetBorders (CRect rcBorders)
Sets the toolbar's borders.
void | DisableShadow ()
Disables shadow use.
BOOL | IsResizable () const
Determines if the control can be resized by the user.
virtual CRect | GetBorders ()
Call this method to get the border margins of the command bar.
- Public Member Functions inherited from CXTPCommandBar
int | IsTrackingMode () const
Call this member to get the tracking state.
CXTPControls * | GetControls () const
Call this member to get the controls collection.
void | SetControls (CXTPControls *pControls)
Call this member to set the controls collection of the command bar.
XTPBarType | GetType () const
Call this member to get the type of the command bar.
void | SetTextOrientation (XTPBarTextOrientation nTextOrientation)
Call this member to change text orientation.
XTPBarTextOrientation | GetTextOrientation () const
Call this member to get the text orientation.
XTPBarPosition | GetPosition () const
Call this member to get the position of the command bar.
void | DelayLayout ()
Call this member to recalculate the layout.
virtual BOOL | LoadMenu (CMenu *pMenu, BOOL bRemoveControls=TRUE)
Call this member to convert menu items to command bar controls.
CXTPControl * | GetControl (int nIndex) const
Call this member to return the control at the specified index.
int | GetControlCount () const
Call this member to get the count of the controls.
CXTPControl * | GetSelected () const
Call this member to get the currently selected control.
BOOL | SetPopuped (int nPopuped, BOOL bKeyboard=FALSE)
Call this member to pop-up the specified control.
void | SetTitle (LPCTSTR lpszTitle)
Call this member to set a title for this command bar.
CString | GetTitle () const
Call this member to get a title for this command bar.
CXTPCommandBars * | GetCommandBars () const
Call this member to get the command bar's object.
void | SetCommandBars (CXTPCommandBars *pCommandBars)
Call this member to set the command bar's object.
CWnd * | GetSite () const
Call this member to get the command bar's site.
CFrameWnd * | GetFrameSite () const
Call this member to get the command bar's site as CFrameWnd.
void | SetFlags (DWORD dwFlagsAdd, DWORD dwFlagsRemove=0)
Call this member to set the command bar's flags.
BOOL | SetButtons (UINT *pButtons, int nCount)
Call this member to set the controls from the button array.
virtual BOOL | LoadToolBar (UINT nIDResource, BOOL bLoadIcons=TRUE)
Call this member function to load the toolbar specified by nIDResource.
void | SetIconSize (CSize size)
Call this function to set the size of the actual bitmapped images to be added to a toolbar.
virtual CSize | GetIconSize () const
Call this member function to get the size of the toolbar icon.
CSize | GetLargeIconSize (BOOL bAutoSize) const
Call this method to get the large icon size of the toolbar.
void | SetButtonSize (CSize size)
Sets the size of the buttons in the command bar.
virtual CSize | GetButtonSize () const
Call this function to get the size of the command bar button.
void | ShowTextBelowIcons (BOOL bTextBelow=TRUE)
Call this member to show the caption below control's icon.
BOOL | IsTextBelowIcons () const
Checks whether the caption is below the control's icon.
HWND | GetTrackFocus () const
Call this method to retrieve the current focused control.
void | SetTrackFocus (HWND hwnd)
Call this method to set focus to the window.
virtual void | SetVisible (BOOL bVisible)
Call this method to set the visibility state of the control.
virtual BOOL | SetPosition (XTPBarPosition barPosition)
Call this member function to set the position of the command bar.
int | FindAccel (TCHAR chAccel) const
Call this method to get the index of the control with the specified accelerator character.
int | FindAccelEx (UINT chAccel, BOOL &bSelectOnly) const
Call this method to get the index of the control with the specified accelerator character.
BOOL | IsCustomizeMode () const
Call this method to check if the command bars are in customize mode.
virtual DROPEFFECT | OnCustomizeDragEnter (CXTPControl *pDataObject, CPoint point)
This member is called when a control is entered into the command bar.
virtual void | OnCustomizeDragLeave ()
This method is called when a control leaves the command bar.
virtual DROPEFFECT | OnCustomizeDragOver (CXTPControl *pDataObject, CPoint point)
This member is called when control is over the command bar.
virtual void | OnCustomizeDrop (CXTPControl *pDataObject, DROPEFFECT &dropEffect, CPoint ptDrop, CPoint ptDrag)
This method is called when a control is dropped to the command bar.
virtual BOOL | IsCustomizable () const
Call this method to check if the command bar is customizable.
BOOL | IsCustomizeDialogPresent () const
Call this method to check if the command bar is present in Customize dialog.
void | EnableCustomization (BOOL bEnable=TRUE)
Call this method to enable/disable customization of the command bar.
virtual void | OnTrackLost ()
Call this method to remove the tracking state of the command bar.
virtual void | OnTrackEnter ()
Call this method to track the command bar.
CWnd * | GetOwnerSite () const
Call this method to retrieve the owner window of the command bar.
void | InvalidateParents ()
Call this method to redraw all parent command bars.
DWORD | GetFlags () const
Call this method to retrieve the current behavior modification flags of the command bar.
UINT | GetBarID () const
Call this method to retrieve the identifier of the command bar.
void | SetBarID (UINT nID)
Call this method to set the identifier of the command bar.
virtual void | OnControlSelected (BOOL bSelected, CXTPControl *pControl)
This method is called when a child control becomes selected.
BOOL | SetStatusText (const CString &strDescription)
This method is called to set the description context.
void | SetCommandBarData (DWORD_PTR dwData)
This method sets the 32-bit value associated with the command bar.
DWORD_PTR | GetCommandBarData () const
This method retrieves the application-supplied, 32-bit value associated with the command bar.
CXTPCommandBar * | GetRootParent () const
Call this method to retrieve the top-level parent command bar.
CXTPPaintManager * | GetPaintManager () const
Call this method to retrieve the paint manager.
CXTPImageManager * | GetImageManager () const
Call this method to retrieve the image manager.
void | SetWidth (int nWidth)
Call this member to set the width of the floated or pop-up toolbar.
int | GetWidth () const
Call this member to get the width of the floated or pop-up toolbar.
void | SetPaintManager (CXTPPaintManager *pPaintManager)
Call this member to set the specified paint manager.
void | SetImageManager (CXTPImageManager *pImageManager)
Call this member to set the specified image manager.
BOOL | IsLayoutRTL () const
Call this member function to determine if the command bar layout is Right-to-Left (RTL).
virtual BOOL | IsDialogBar () const
Call this member function to determine if the command bar is a CXTPDialogBar.
virtual BOOL | IsRibbonBar () const
Call this member function to determine if the command bar is a CXTPRibbonBar.
virtual BOOL | IsMenuTitleBar () const
Call this member function to determine if the command bar is a CXTPMenuTitleBar.
virtual BOOL | IsKeyboardCuesVisible () const
Determines if underlines are visible in the command bar control.
void | SetGrabFocus (BOOL bGrabFocus)
This method is called internally to prevent the command bar from grabbing edit focus.
virtual void | Redraw (LPCRECT lpRect=0, BOOL bAnimate=TRUE)
The framework calls this member function to redraw the command bar.
void | EnableAnimation (BOOL bEnable=TRUE)
Call this method to enable animation for the command bar.
void | EnableDoubleBuffer (BOOL bEnable=TRUE)
Call this method to enable double buffer for toolbar drawing.
BOOL | IsAnimationEnabled () const
Determines if animation is enabled for the specified command bar.
virtual int | OnHookMessage (HWND hWnd, UINT nMessage, WPARAM &wParam, LPARAM &lParam, LRESULT &lResult)
This member function is called by WindowProc, or is called during message reflection.
virtual void | EnsureVisible (CXTPControl *pControl)
Call this method to ensure that a specified control is visible on the toolbar.
XTPButtonStyle | GetDefaultButtonStyle () const
Call this method to retrieve the default button style of the command bar.
void | SetDefaultButtonStyle (XTPButtonStyle buttonStyle)
Call this method to set the default button style of the command bar.
void | LockRedraw ()
Call this method to freeze redrawing until UnlockRedraw is called.
void | UnlockRedraw ()
Call this method to unfreeze redrawing.
void | SetShowGripper (BOOL bShow)
Call this method to set the visibility of the command bar's gripper.
BOOL | GetShowGripper () const
Call this method to check if the command bar's gripper is visible.
virtual void | FillCommandBarEntry (CDC *pDC)
This method is called to draw the background of the command bar.
BOOL | IsKeyboardTipsVisible () const
Call this method to check if keyboard tips are visible for the command bar.
virtual void | CreateKeyboardTips ()
This method is called to create a keyboard tips collection for the command bar.
void | OnKeyboardTipChar (UINT chAccel)
This method is called when the user presses a key while keyboard tips are visible.
virtual void | OnKeyboardTip (CXTPCommandBarKeyboardTip *pTip)
This method is called when a keyboard tip is found for the command bar.
void | HideKeyboardTips ()
Call this method to hide keyboard tips.
void | LockMouseMove (CXTPControl *pControl)
Locks the mouse cursor for a specified control.
void | UnlockMouseMove ()
Unlocks the mouse cursor.
- Public Member Functions inherited from CXTPHookManagerHookAble
CXTPHookManagerHookAble ()
Constructs a CXTPHookManagerHookAble object.
virtual | ~CXTPHookManagerHookAble ()
Destroys a CXTPHookManagerHookAble object, handles cleanup and deallocation.
virtual int | OnPostHookMessage (HWND hWnd, UINT nMessage, WPARAM &wParam, LPARAM &lParam, LRESULT &lResult)
This member function is called after a message has been processed by default window procedure.
virtual void | OnHookAttached (HWND hWnd)
This member function is called right after a hook is attached to the window.
virtual void | OnHookDetached ()
This member function is called right before a hook is to be detached from the window.
- Public Attributes inherited from CXTPCommandBar
int | m_nStateFlags
State of the command bars.
BOOL | m_bComboBar
TRUE if it is combobox list.
BOOL | m_bTrackOnHover
TRUE to select item if mouse stay over control.
- Public Attributes inherited from CXTPHookManagerHookAble
BOOL | m_bAutoDestroy
TRUE to automatically delete hook.
- Static Public Attributes inherited from CXTPPopupBar
static double | m_dMaxWidthDivisor
Maximum available width of pop-up.
- Static Public Attributes inherited from CXTPCommandBar
static int | s_nHoverDelay
Hover delay time.
static int | s_nExpandDelay
Expand delay time.
static int | s_nExpandHoverDelay
Expand hover delay.
- Protected Attributes inherited from CXTPPopupBar
CXTPControlPopup * | m_pControlPopup
Control that pop-up'ed the bar.
CPoint | m_ptPopup
Position of the bar.
CRect | m_rcExclude
Excluded area.
DWORD | m_popupFlags
Flags of the bar.
BOOL | m_bDynamicLayout
TRUE if DynamicLayout routine executed.
BOOL | m_bCollapsed
TRUE if pop-up bar is collapsed.
BOOL | m_bExpanded
TRUE if pop-up bar is expanded.
BOOL | m_bExpanding
TRUE if pop-up bar is expanding.
BOOL | m_bTearOffPopup
TRUE if pop-up bar has tear-off option.
CRect | m_rcTearOffGripper
Tear-off gripper position.
CRect | m_rcResizeGripper
Resizable gripper position.
BOOL | m_bResizable
TRUE to allow resize.
BOOL | m_bTearOffSelected
TRUE if gripper selected.
UINT_PTR | m_nTearOffTimer
Tear-off timer.
BOOL | m_bTearOffTracking
Tear-off tracking mode.
CSize | m_szTearOffBar
Size of the bar.
CXTPToolBar * | m_pTearOffBar
Tear-off toolbar pointer.
CString | m_strTearOffCaption
Caption of the Tear-off toolbar.
UINT | m_nTearOffID
ID of the Tear-off toolbar.
int | m_nTearOffWidth
Width of the Tear-off toolbar.
BOOL | m_bShowShadow
TRUE to show the shadow.
CRect | m_rcBorders
Borders of the bar.
BOOL | m_bDoubleGripper
TRUE if pop-up is state pop-up type.
BOOL | m_bContextMenu
TRUE if pop-up bar is context menu.
int | m_nMaxHeight
Maximum height the pop-up bar can become.
- Protected Attributes inherited from CXTPCommandBar
BOOL | m_bGrabFocus
TRUE to grab current focus.
int | m_nMRUWidth
Recent width.
int | m_nSelected
Selected control index.
int | m_nPopuped
Pop-up'ed control index.
HWND | m_hwndFocus
The handle of the window that currently has focus.
UINT | m_nBarID
Command bar's identifier.
BOOL | m_bTracking
TRUE if the command bar is in tracking mode.
CWnd * | m_pSite
Command bar's site.
DWORD | m_nIdleFlags
Idle flags.
DWORD | m_dwFlags
Command bar's flags.
DWORD | m_dwStyle
Command bar's styles.
CString | m_strTitle
Command bar's caption.
XTPBarType | m_barType
Type of the command bar.
CXTPControls * | m_pControls
A pointer to controls collection.
XTPBarPosition | m_barPosition
Position of the command bar.
CXTPCommandBars * | m_pCommandBars
parent command bars class.
CWnd * | m_pOwner
Owner window.
CSize | m_szIcons
Size of the command bar's icons.
CSize | m_szButtons
Size of the command bar's buttons.
BOOL | m_bTextBelow
TRUE if text is shown below the CommandBar buttons.
BOOL | m_bExecOnRButton
TRUE if the control button is executed on a right-click.
BOOL | m_bIgnoreUpdateHandler
TRUE to skip update handler for all child controls.
BOOL | m_bRecursePopup
TRUE if pop-up bar was opened recursively.
BOOL | m_bKeyboardSelect
TRUE if last item was selected by keyboard.
BOOL | m_bCloseable
TRUE if the CommandBar can be closed and-or Hidden.
BOOL | m_bCustomizable
TRUE if command bar is customizable.
CRect | m_rcMarker
Marker position.
BOOL | m_bVerticalMarker
TRUE to draw marker vertically.
DWORD_PTR | m_dwData
The 32-bit value associated with the command bar.
UINT * | m_pReturnCmd
Return command holder.
BOOL | m_bCustomizeDialogPresent
TRUE if the command bar is present in Customize dialog.
BOOL | m_bAnimatePopup
TRUE to animate pop-up bar.
BOOL | m_nLockRedraw
TRUE if all drawing routines skipped.
CXTPPaintManager * | m_pPaintManager
Selected paint manager for command bar.
CXTPImageManager * | m_pImageManager
Selected image manager for command bar.
BOOL | m_bMultiLine
True if multi line commandbar.
XTPButtonStyle | m_buttonStyle
Default button Style.
XTPBarTextOrientation | m_nTextOrientation
Commandbar text orientation.
CXTPToolTipContext * | m_pToolTipContext
Tool tip Context.
CXTPCommandBarAnimation * | m_pAnimation
Animation context.
CSize | m_szButtonSpacing
Spacing used between toolbar buttons.

Detailed Description

CXTPPopupToolBar is a CXTPPopupBar derived class.

Member Function Documentation

◆ CalcDynamicLayout()

CSize CalcDynamicLayout | ( | int | nLength,
 |  | DWORD | dwMode )
 protectedvirtual

This method is called to get the size of the command bar.

Parameters
nLength | The requested dimension of the control bar, either horizontal or vertical, depending on dwMode.
dwMode | See CControlBar::CalcDynamicLayout for list of supported flags.
Returns
Size of the command bar.

Reimplemented from CXTPPopupBar.

Reimplemented in CXTPRibbonTabPopupToolBar.

◆ CreatePopupToolBar()

static CXTPPopupToolBar *AFX_CDECL CreatePopupToolBar ( CXTPCommandBars * pCommandBars )
static

Creates a pop-up toolbar object.

Parameters
pCommandBars Pointer to a CXTPCommandBars object.
Returns
A pointer to a CXTPPopupToolBar object.
The documentation for this class was generated from the following file:
  • XTPPopupBar.h


Toolkit Pro: CXTPPreviewCtrl Class Reference

Public Member Functions | List of all members
CXTPPreviewCtrl Class Reference

Implements the preview control that can display visual preview data provided by the best matching preview provider registered to the control. More...

Public Member Functions

CXTPPreviewCtrl ()
Handles control construction.
virtual | ~CXTPPreviewCtrl ()
Handles control destruction.
BOOL | RegisterWindowClass (HINSTANCE hInstance=NULL)
Registers the window class if it has not already been registered.
virtual BOOL | Create (DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID, CCreateContext *pContext=NULL)
Creates a preview control window object.
virtual BOOL | CreateEx (DWORD dwExStyle, DWORD dwStyle, int x, int y, int nWidth, int nHeight, HWND hWndParent, HMENU nIDorHMenu, LPVOID lpParam=NULL)
Creates a preview control window object.
virtual BOOL | CreateEx (DWORD dwExStyle, DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID, LPVOID lpParam=NULL)
Creates a preview control window object.
void | Preview (LPCTSTR lpFilePath)
Sets a path to a file to preview.
void | Preview (IStream *pStream, LPCTSTR lpImpliedFileName)
Sets a path to a file to preview.
void | Reset ()
Resets the currently loaded preview.
void | AddProvider (IXTPPreviewProvider *provider, LPCTSTR associations=NULL)
Adds a new preview provider object.
void | AddDefaultProviders ()
Adds all known providers with their default associations in the following order:
void | SetLoadingMessage (LPCTSTR message)
Customizes the message displayed when a preview is being loaded.
void | SetFailedMessage (LPCTSTR message)
Customizes the message displayed when a preview cannot be obtained.
COLORREF | GetBackgroundColor () const
Provides access to the background color value used for filling the preview area.
void | SetBackgroundColor (COLORREF cr)
Sets the background color value used for filling the preview area.
COLORREF | GetForegroundColor () const
Provides access to the foreground color value used for text messages in the preview area.
void | SetForegroundColor (COLORREF cr)
Sets the foreground color value used for text messages in the preview area.
void | EnableAutoPreviewActivate (BOOL bEnable=TRUE)
Sets an automatic preview activation on loading.
BOOL | IsAutoPreviewActivateEnabled () const
Gets an automatic preview activation on loading.

Detailed Description

Implements the preview control that can display visual preview data provided by the best matching preview provider registered to the control.

Member Function Documentation

◆ AddDefaultProviders()

void AddDefaultProviders ( )

Adds all known providers with their default associations in the following order:

  1. CXTPSystemPreviewProvider
  2. CXTPCommonPicturePreviewProvider
  3. CXTPGifPreviewProvider
  4. CXTPMsgPreviewProvider
  5. CXTPTextPreviewProvider
  6. CXTPXamlPreviewProvider
    See also
    AddProvider

◆ AddProvider()

void AddProvider | ( | IXTPPreviewProvider * | provider,
 |  | LPCTSTR | associations = NULL )

Adds a new preview provider object.

The object will be destroyed by the control upon control destruction.

Parameters
provider | A new provider object pointer.
associations | A string that specifies a list of custom supported file extensions that will be used in addition to the default list of supported extensions provided by the provider (e.g. "doc;docx;xls;xlsx"), or NULL to use only provider supported extensions.

Every time a new preview request is issued, the providers get checked in the order of addition. The first provider that is able to create a preview object for a new preview target is selected.

See also
IXTPPreviewProvider::GetDefaultFileAssociations, IXTPPreviewProvider::CreatePreview

◆ Create()

virtual BOOL Create | ( | DWORD | dwStyle,
 |  | const RECT & | rect,
 |  | CWnd * | pParentWnd,
 |  | UINT | nID,
 |  | CCreateContext * | pContext = NULL )
 virtual

Creates a preview control window object.

Parameters
dwStyle | Bitwise combination (OR) of window styles; otherwise NULL for the default window style.
rect | The size and location of the window relative to the screen or the parent window.
pParentWnd | For a child window, pointer to the parent window; otherwise, a pointer to the owner window if the window has an owner.
nID | For a child window, the window ID; otherwise, the ID of a menu for the window.
pContext | CCreateContext pointer or NULL.
Returns
TRUE if the method was successful, otherwise FALSE.

◆ CreateEx() [1/2]

virtual BOOL CreateEx | ( | DWORD | dwExStyle,
 |  | DWORD | dwStyle,
 |  | const RECT & | rect,
 |  | CWnd * | pParentWnd,
 |  | UINT | nID,
 |  | LPVOID | lpParam = NULL )
 virtual

Creates a preview control window object.

Parameters
dwExStyle | Bitwise combination (OR) of extended window styles; otherwise NULL for the default extended window style.
dwStyle | Bitwise combination (OR) of window styles; otherwise NULL for the default window style.
rect | The size and location of the window relative to the screen or the parent window.
pParentWnd | For a child window, pointer to the parent window; otherwise, a pointer to the owner window if the window has an owner.
nID | For a child window, the window ID; otherwise, the ID of a menu for the window.
lpParam | Pointer to user data that is passed to the CWnd::OnCreate method in the lpCreateParams field.
Returns
TRUE if the method was successful, otherwise FALSE.

◆ CreateEx() [2/2]

virtual BOOL CreateEx | ( | DWORD | dwExStyle,
 |  | DWORD | dwStyle,
 |  | int | x,
 |  | int | y,
 |  | int | nWidth,
 |  | int | nHeight,
 |  | HWND | hWndParent,
 |  | HMENU | nIDorHMenu,
 |  | LPVOID | lpParam = NULL )
 virtual

Creates a preview control window object.

Parameters
dwExStyle | Bitwise combination (OR) of extended window styles; otherwise NULL for the default extended window style.
dwStyle | Bitwise combination (OR) of window styles; otherwise NULL for the default window style.
x | The initial horizontal distance of the window from the left side of the screen or the parent window.
y | The initial vertical distance of the window from the top of the screen or the parent window.
nWidth | The width, in pixels, of the window.
nHeight | The height, in pixels, of the window.
hWndParent | For a child window, the handle to the parent window; otherwise, the handle of the owner window if the window has an owner.
nIDorHMenu | For a child window, the window ID; otherwise, the ID of a menu for the window.
lpParam | Pointer to user data that is passed to the CWnd::OnCreate method in the lpCreateParams field.
Returns
TRUE if the method was successful, otherwise FALSE.

◆ EnableAutoPreviewActivate()

void EnableAutoPreviewActivate ( BOOL bEnable = TRUE )

Sets an automatic preview activation on loading.

By default this behavior is not enabled because it is undefined how some system provided preview handlers will behave on activation. If the behavior is enabled then every time when a new preview is loaded its provider tries actiate, set focus, or do whatever else is deemed to be an activate state of a preview for that particular provider. A provider may not support this behavior at all if it makes no sense for provided preview, for example a static picture.

Parameters
bEnable TRUE to enable the behavior, FALSE to disable.

◆ GetBackgroundColor()

COLORREF GetBackgroundColor ( ) const

Provides access to the background color value used for filling the preview area.

Returns
Current color value.
See also
GetForegroundColor

◆ GetForegroundColor()

COLORREF GetForegroundColor ( ) const

Provides access to the foreground color value used for text messages in the preview area.

Returns
Current color value.
See also
GetBackgroundColor

◆ IsAutoPreviewActivateEnabled()

BOOL IsAutoPreviewActivateEnabled ( ) const

Gets an automatic preview activation on loading.

By default this behavior is not enabled because it is undefined how some system provided preview handlers will behave on activation. If the behavior is enabled then every time when a new preview is loaded its provider tries actiate, set focus, or do whatever else is deemed to be an activate state of a preview for that particular provider. A provider may not support this behavior at all if it makes no sense for provided preview, for example a static picture.

Returns
The current state of the behavior.

◆ Preview() [1/2]

void Preview | ( | IStream * | pStream,
 |  | LPCTSTR | lpImpliedFileName )

Sets a path to a file to preview.

Parameters
pStream | Preview data source stream. If NULL then lpImpliedFileName must be a
lpImpliedFileName | An implied file name associated with stream data. Its extension determines the preview provider type used for stream data. full path.

◆ Preview() [2/2]

void Preview ( LPCTSTR lpFilePath )

Sets a path to a file to preview.

Parameters
lpFilePath File path to preview.

◆ RegisterWindowClass()

BOOL RegisterWindowClass ( HINSTANCE hInstance = NULL )

Registers the window class if it has not already been registered.

Parameters
hInstance Instance of the resource where the control is located.
Returns
TRUE if the window class was successfully registered, otherwise FALSE.

◆ SetBackgroundColor()

void SetBackgroundColor ( COLORREF cr )

Sets the background color value used for filling the preview area.

Parameters
cr New color value.
See also
GetForegroundColor

◆ SetFailedMessage()

void SetFailedMessage ( LPCTSTR message )

Customizes the message displayed when a preview cannot be obtained.

Parameters
message Custom message. Every occurence of the '' symbol in the string will be replaced with the preview target path/name.
See also
SetLoadingMessage

◆ SetForegroundColor()

void SetForegroundColor ( COLORREF cr )

Sets the foreground color value used for text messages in the preview area.

Parameters
cr New color value.
See also
GetBackgroundColor

◆ SetLoadingMessage()

void SetLoadingMessage ( LPCTSTR message )

Customizes the message displayed when a preview is being loaded.

Parameters
message Custom message. Every occurence of the '' symbol in the string will be replaced with the preview target path/name.
See also
SetFailedMessage
The documentation for this class was generated from the following file:
  • XTPPreviewCtrl.h


Toolkit Pro: CXTPPreviewProviderBase Class Reference

Protected Member Functions | List of all members
CXTPPreviewProviderBase Class Reference

Base class for a preview provider which implements common behavior to be exposed by a preview provider. More...

Inheritance diagram for CXTPPreviewProviderBase:
[legend]

Protected Member Functions

CXTPPreviewProviderBase ()
Handles object construction.
void | BindHost (IXTPPreviewHost &host)
The method is called by the host preview control when the provider is initially bound to the host.
IXTPPreviewHost & | GetHost () const
Obtains the preview host interface that the provider is bound to.

Additional Inherited Members

- Public Member Functions inherited from IXTPPreviewProvider
virtual | ~IXTPPreviewProvider ()
Handles object destruction.
virtual LPCTSTR | GetDefaultFileAssociations () const =0
Obtains the list of file extensions supported by the associated preview implementation.
virtual IXTPPreview * | CreatePreview (LPCTSTR pFilePath, HWND hwndParent)=0
Creates a preview object for the specified file.
virtual IXTPPreview * | CreatePreview (IStream &stream, LPCTSTR pImpliedFileName, HWND hwndParent)=0
Creates a preview object for the specified file.

Detailed Description

Base class for a preview provider which implements common behavior to be exposed by a preview provider.

See also
IXTPPreviewProvider

Member Function Documentation

◆ BindHost()

void BindHost ( IXTPPreviewHost & host )
protectedvirtual

The method is called by the host preview control when the provider is initially bound to the host.

Parameters
host Host interface.

Implements IXTPPreviewProvider.

◆ GetHost()

IXTPPreviewHost & GetHost ( ) const
protected

Obtains the preview host interface that the provider is bound to.

Returns
Preview host interface.
The documentation for this class was generated from the following file:
  • XTPPreviewAbstract.h


Toolkit Pro: CXTPPreviewView Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPPreviewView Class Reference

CXTPPreviewView is a CPreviewView derived class that represents a print preview window with a themed toolBar. More...

Public Member Functions

void | SetZoomState (UINT nNewState, UINT nPage, CPoint point)
Sets the zoom state of the preview window.
int | GetZoomState () const
Returns the current zoom state of the preview window.
CXTPToolBar * GetCommandBar ()
Call this method to get a pointer to the toolbar of the preview window.

Protected Member Functions

CXTPPreviewView (int nPageCount=9)
Constructs a CXTPPreviewView object.
virtual ~CXTPPreviewView ()
Destroys a CXTPPreviewView object, handles cleanup and deallocation.

Protected Attributes

PAGE_INFO * | m_pPageInfo2
Embedded array for the default implementation - replaces MFC one of size 2!
CXTPToolBar * | m_pCommandBar
Pointer to the "built-in" print preview toolbar.
int | m_cxPixelsPerInch
Width of pixels in preview mode.
int | m_cyPixelsPerInch
Height of pixels in preview mode.
int | m_Across
number across the page, >= 1
int | m_Down
number down the page, >= 1
CPoint | m_PageOffset
amount to move the page from one position to the next

Detailed Description

CXTPPreviewView is a CPreviewView derived class that represents a print preview window with a themed toolBar.

Constructor & Destructor Documentation

◆ CXTPPreviewView()

CXTPPreviewView ( int nPageCount = 9 )
protected

Constructs a CXTPPreviewView object.

Parameters
nPageCount Number of pages to be displayed in print preview mode. You must increase the page count to make sure there is an entry available for each page that can be displayed.

Member Function Documentation

◆ GetCommandBar()

AFX_INLINE CXTPToolBar * GetCommandBar ( )

Call this method to get a pointer to the toolbar of the preview window.

Returns
Pointer to the toolbar of the preview window.

◆ GetZoomState()

int GetZoomState ( ) const

Returns the current zoom state of the preview window.

Returns
Current zoom state of the preview window.

◆ SetZoomState()

void SetZoomState | ( | UINT | nNewState,
 |  | UINT | nPage,
 |  | CPoint | point )

Sets the zoom state of the preview window.

Parameters
nNewState | Zoom state to use. Possible values (XTP_ZOOM_WHOLEPAGE, XTP_ZOOM_PAGEWIDTH) or you can specify an integer that represents a percentage to zoom the page.
nPage | Page number to zoom.
point | Point on page to zoom.
The documentation for this class was generated from the following file:
  • XTPPreviewView.h


Toolkit Pro: CXTPProgressBase Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPProgressBase Class Referenceabstract

CXTPControlProgressBase is base class for all progress objects. More...

Inheritance diagram for CXTPProgressBase:
[legend]

Public Member Functions

CXTPProgressBase ()
Constructs a CXTPProgressBase object.
virtual | ~CXTPProgressBase ()
Destroys a CXTPProgressBase object, handles cleanup and deallocation.
void | SetRange (int nLower, int nUpper)
Sets the upper and lower limits of the progress bar control's range.
void | GetRange (int &nLower, int &nUpper) const
Gets the upper and lower limits of the progress bar control's range.
int | GetPos () const
Gets the current position of the progress bar, whose return value is always between the values for the Max and Min properties, inclusive.
void | SetPos (int nPos)
Sets the current position of the progress bar, whose return value is always between the values for the Max and Min properties, inclusive.
virtual CRect | GetProgressRect ()=0
This method is called to get bounding rectangle of progressbar.

Protected Member Functions

virtual void | RedrawProgress ()=0
This method is called to redraw progress bar.
virtual CXTPProgressPaintManager * | GetProgressPaintManager () const =0
This method is called to retrieve pointer to CXTPProgressPaintManager.

Protected Attributes

int | m_nMin
Minimum.
int | m_nMax
Maximum.
int | m_nPos
Current position.

Detailed Description

CXTPControlProgressBase is base class for all progress objects.

Member Function Documentation

◆ GetPos()

int GetPos ( ) const

Gets the current position of the progress bar, whose return value is always between the values for the Max and Min properties, inclusive.

Returns
Current position of the progress bar.

◆ GetProgressPaintManager()

virtual CXTPProgressPaintManager * GetProgressPaintManager ( ) const
protectedpure virtual

This method is called to retrieve pointer to CXTPProgressPaintManager.

Returns
Returns a pointer to CXTPProgressPaintManager

Implemented in CXTPControlProgress, and CXTPStatusBarProgressPane.

◆ GetProgressRect()

virtual CRect GetProgressRect ( )
pure virtual

This method is called to get bounding rectangle of progressbar.

Returns
Progress rectangle.

Implemented in CXTPControlProgress, and CXTPStatusBarProgressPane.

◆ GetRange()

void GetRange | ( | int & | nLower,
 |  | int & | nUpper ) const

Gets the upper and lower limits of the progress bar control's range.

Parameters
nLower | Lower limit of the progress bar control's range.
nUpper | Upper limit of the progress bar control's range.

◆ SetPos()

void SetPos ( int nPos )

Sets the current position of the progress bar, whose return value is always between the values for the Max and Min properties, inclusive.

Parameters
nPos Position to move progress bar.

◆ SetRange()

void SetRange | ( | int | nLower,
 |  | int | nUpper )

Sets the upper and lower limits of the progress bar control's range.

Parameters
nLower | Lower limit of the progress bar control's range.
nUpper | Upper limit of the progress bar control's range.
The documentation for this class was generated from the following file:
  • XTPProgressBase.h


Toolkit Pro: CXTPProgressCtrl Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPProgressCtrl Class Reference

The ProgressBar control shows the progress of a lengthy operation by filling a rectangle with chunks from left to right. More...

Public Member Functions

CXTPProgressCtrl ()
Constructs a CXTPProgressCtrl object.
virtual | ~CXTPProgressCtrl ()
Handles cleanup, destroys object.
CXTPProgressCtrlPaintManager * | GetPaintManager () const
This member function obtains a pointer to the associated paint manager object.
void | SetTheme (CXTPProgressCtrlPaintManager *pPaintManager=NULL)
This member function sets the new control drawing theme.
COLORREF | SetBorderColor (COLORREF clrNew)
This member function sets the border color for the progress bar.
COLORREF | SetBarColor (COLORREF clrNew)
This member function sets the bar color for the progress bar.
COLORREF | SetBkColor (COLORREF clrNew)
This member function sets the background color for the progress bar.
COLORREF | SetTextColor (COLORREF clrNew)
This member function sets the text color for the progress bar.
BOOL | SetMarquee (BOOL fMarqueeMode, int nInterval)
Turns marquee mode on/off for the current progress bar control.
void | SetTheme (XTPControlTheme nTheme)
Call this member to switch the visual theme of the control.
BOOL | GetFlatStyle () const
Gets the flat style appearance of the button control.
void | SetFlatStyle (BOOL bFlatStyle=TRUE)
Sets the flat style appearance of the button control.
BOOL | GetUseVisualStyle () const
Determines if the control is drawn using visual styles/SkinFramework, if supported.
void | SetUseVisualStyle (BOOL bUseVisualStyle=TRUE)
Enables Windows XP visual styles for the control.

Protected Member Functions

void | RefreshMetrics ()
This member is called to update the color, text, and other visual elements of the control.
void | DrawNcBorders (CDC *pDC, CRect rc)
This member function is called by the progress bar to draw non-client area borders.
void | DoPaint (CDC *pDC)
A helper for rendering the control appearance.
COLORREF | GetBorderColor ()
This member function gets the border color for the progress bar.
COLORREF | GetBarColor ()
This member function gets the bar color for the progress bar.
COLORREF | GetBackColor ()
This member function gets the background color for the progress bar.
COLORREF | GetTextColor ()
This member function gets the text color for the progress bar.
BOOL | HasText ()
This member function check the progress bar for text.

Protected Attributes

int | m_nMarqueePos
Position of the Marquee progress bar.
int | m_nMarqueeDelay
TRUE if delay is enabled.
BOOL | m_bPreSubclassInit
TRUE if the progress bar has been subsclassed.
BOOL | m_bFlatStyle
TRUE if the progress bar is drawn flat (deprecated).
CXTPProgressCtrlPaintManager * | m_pPaintManager
Pointer to the progress bar paint manager.

Detailed Description

The ProgressBar control shows the progress of a lengthy operation by filling a rectangle with chunks from left to right.

A ProgressBar control has a range and a current position. The range represents the entire duration of the operation. The current position represents the progress the application has made toward completing the operation. The Max and Min properties set the limits of the range. The Value property specifies the current position within that range. Because chunks are used to fill in the control, the amount filled in only approximates the Value property's current setting. Based on the control's size, the Value property determines when to display the next chunk.

Member Function Documentation

◆ DoPaint()

void DoPaint ( CDC * pDC )
protected

A helper for rendering the control appearance.

Parameters
pDC Pointer to a valid device context.

◆ DrawNcBorders()

void DrawNcBorders | ( | CDC * | pDC,
 |  | CRect | rc )
 protected

This member function is called by the progress bar to draw non-client area borders.

Parameters
pDC | Pointer to a valid device context.
rc | Size of the area to draw.

◆ GetBackColor()

COLORREF GetBackColor ( )
protected

This member function gets the background color for the progress bar.

Returns
The COLORREF value used for the background.

◆ GetBarColor()

COLORREF GetBarColor ( )
protected

This member function gets the bar color for the progress bar.

Returns
The COLORREF value used for the bar.

◆ GetBorderColor()

COLORREF GetBorderColor ( )
protected

This member function gets the border color for the progress bar.

Returns
The COLORREF value used for the border.

◆ GetFlatStyle()

BOOL GetFlatStyle ( ) const

Gets the flat style appearance of the button control.

The control will appear flat until the mouse pointer moves over it, at which point it appears three-dimensional.

Returns
TRUE if the flat style is used, otherwise FALSE.

◆ GetPaintManager()

CXTPProgressCtrlPaintManager * GetPaintManager ( ) const

This member function obtains a pointer to the associated paint manager object.

The paint manager object is used for drawing the date picker window.

Returns
Pointer to the associated paint manager object.
See also
SetTheme, SetPaintManager

◆ GetTextColor()

COLORREF GetTextColor ( )
protected

This member function gets the text color for the progress bar.

Returns
The COLORREF value used for the text.

◆ GetUseVisualStyle()

BOOL GetUseVisualStyle ( ) const

Determines if the control is drawn using visual styles/SkinFramework, if supported.

This method enables Windows XP visual styles for the control. This Control will draw using visual styles if both the control and the operating system support it. Visual styles and SkinFramework skins are specifications for the appearance of controls. GetUseVisualStyle determines whether to use the currently set Windows XP visual style. If using SkinFramework, then it determines whether to use the currently set style of the SkinFramework.

Returns
TRUE if the currently set Windows XP visual style will be used to theme the control. If using SkinFramework, then the currently set style of the SkinFramework will be used to skin the control. FALSE if the currently set appearance/style in the OS will be used.

◆ HasText()

BOOL HasText ( )
protected

This member function check the progress bar for text.

Returns
TRUE if the progress bar has text, otherwise returns FALSE.

◆ SetBarColor()

COLORREF SetBarColor ( COLORREF clrNew )

This member function sets the bar color for the progress bar.

Parameters
clrNew A COLORREF value that specifies the new bar color.
Returns
The COLORREF value used for the bar.

◆ SetBkColor()

COLORREF SetBkColor ( COLORREF clrNew )

This member function sets the background color for the progress bar.

Parameters
clrNew A COLORREF value that specifies the new background color.
Returns
The COLORREF value used for the background.

◆ SetBorderColor()

COLORREF SetBorderColor ( COLORREF clrNew )

This member function sets the border color for the progress bar.

Parameters
clrNew A COLORREF value that specifies the new border color.
Returns
The COLORREF value used for the bar.

◆ SetFlatStyle()

void SetFlatStyle ( BOOL bFlatStyle = TRUE )

Sets the flat style appearance of the button control.

Parameters
bFlatStyle TRUE to use the flat style, FALSE otherwise.

The control will appear flat until the mouse pointer moves over it, at which point it appears three-dimensional.

◆ SetMarquee()

BOOL SetMarquee | ( | BOOL | fMarqueeMode,
 |  | int | nInterval )

Turns marquee mode on/off for the current progress bar control.

Parameters
fMarqueeMode TRUE to turn marquee mode on, FALSE to turn marquee mode off.
nInterval Time in milliseconds between updates of the marquee animation. Example: The following code example starts and stops the marquee scrolling animation:
int piAlpha[5] = { 25, 50, 75, 100, 100 };
m_wndProgress.SetMarquee(TRUE, 50);
Returns
True to turn on marquee mode, False to turn off

◆ SetTextColor()

COLORREF SetTextColor ( COLORREF clrNew )

This member function sets the text color for the progress bar.

Parameters
clrNew A COLORREF value that specifies the new text color.
Returns
The COLORREF value used for text.

◆ SetTheme() [1/2]

void SetTheme ( CXTPProgressCtrlPaintManager * pPaintManager = NULL )

This member function sets the new control drawing theme.

Parameters
pPaintManager Pointer to the new paint manager object or derived class. If NULL, then the default paint manager object is set.

Call this member function to set the paint manager object that is used for drawing a date picker window.

See also
GetPaintManager

◆ SetTheme() [2/2]

void SetTheme ( XTPControlTheme nTheme )

Call this member to switch the visual theme of the control.

Parameters
nTheme New visual theme. Can be any of the values listed in the Remarks section.

nStyle can be one of the following: xtpControlThemeDefault: Standard appearance style. xtpControlThemeFlat: Flat appearance style. xtpControlThemeUltraFlat: Ultra flat appearance style. xtpControlThemeOffice2000: Office 2000 appearance style. xtpControlThemeOfficeXP: Office XP appearance style. xtpControlThemeOffice2003: Office 2003 appearance style. xtpControlThemeResource: Office 2007 appearance style.

◆ SetUseVisualStyle()

void SetUseVisualStyle ( BOOL bUseVisualStyle = TRUE )

Enables Windows XP visual styles for the control.

This method enables Windows XP visual styles for the control. This Control will draw using visual styles if both the control and the operating system support it. Visual styles and SkinFramework skins are specifications for the appearance of controls. GetUseVisualStyle determines whether to use the currently set Windows XP visual style. If using SkinFramework, then it determines whether to use the currently set style of the SkinFramework.

Parameters
bUseVisualStyle TRUE if the currently set Windows XP visual style will be used to theme the control. If using SkinFramework, then the currently set style of the SkinFramework will be used to skin the control. FALSE if the currently set appearance/style in the OS will be used.
The documentation for this class was generated from the following file:
  • XTPProgressCtrl.h


Toolkit Pro: CXTPProgressCtrlPaintManager Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPProgressCtrlPaintManager Class Reference

The CXTPProgressCtrlPaintManager class is derived from CXTPCmdTarget and is used by the progress bar to perform all default drawing routines. More...

Inheritance diagram for CXTPProgressCtrlPaintManager:
[legend]

Public Member Functions

CXTPProgressCtrlPaintManager ()
Default paint manager constructor.
virtual | ~CXTPProgressCtrlPaintManager ()
Default paint manager destructor.
virtual void | RefreshMetrics ()
This member function performs initialization for the Paint Manager.
COLORREF | SetBorderColor (COLORREF clrNew)
This member function sets the border color for the progress bar.
COLORREF | SetBarColor (COLORREF clrNew)
This member function sets the bar color for the progress bar.
COLORREF | SetBackColor (COLORREF clrNew)
This member function sets the background color for the progress bar.
COLORREF | SetTextColor (COLORREF clrNew)
This member function sets the text color for the progress bar.
COLORREF | GetBorderColor ()
This member function gets the border color for the progress bar.
COLORREF | GetBarColor ()
This member function gets the bar color for the progress bar.
COLORREF | GetBackColor ()
This member function gets the background color for the progress bar.
COLORREF | GetTextColor ()
This member function gets the text color for the progress bar.
virtual void | DrawNcBorders (CDC *pDC, CRect rc)
This member function is called by the progress bar to draw the non-client borders.
virtual void | Draw (XTPPROGRESSDRAWSTRUCT &ds)
This member function is called by the progress bar to draw the client area of the control.
virtual void | DrawText (XTPPROGRESSDRAWSTRUCT &ds)
This member function is called by the progress bar to draw the progress text for the control.
BOOL | UsingWinThemes (BOOL bCheckReady=FALSE)
Used by the progress bar to determine if Windows themes should be used to draw the control.
void | UseWinThemes (BOOL bUseWinThemes=TRUE)
Call this member function to draw the control using the current Windows theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

virtual void DeflateRect (XTPPROGRESSDRAWSTRUCT &ds)
This member function is called by the progress bar to adjust the bar drawing size; can be overridden in derived classes.

Protected Attributes

BOOL | m_bUseWinTheme
TRUE when using Windows themes.
XTPControlTheme | m_nTheme
Theme identifier.
CXTPWinThemeWrapper | m_winTheme
Wrapper used when drawing Windows themes.
CXTPPaintManagerColor | m_clrBorder
An RGB value representing the border color.
CXTPPaintManagerColor | m_clrBar
An RGB value representing the bar color.
CXTPPaintManagerColor | m_clrBack
An RGB value representing the back color.
CXTPPaintManagerColor | m_clrText
An RGB value representing the text color.
CXTPPaintManagerColor | m_clrBarText
An RGB value representing the hilite text color.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

The CXTPProgressCtrlPaintManager class is derived from CXTPCmdTarget and is used by the progress bar to perform all default drawing routines.

Constructor & Destructor Documentation

◆ CXTPProgressCtrlPaintManager()

CXTPProgressCtrlPaintManager ( )

Default paint manager constructor.

Handles initial initialization.

See also
RefreshMetrics()

◆ ~CXTPProgressCtrlPaintManager()

virtual ~CXTPProgressCtrlPaintManager ( )
virtual

Default paint manager destructor.

Handles cleanup and deallocation.

Member Function Documentation

◆ DeflateRect()

virtual void DeflateRect ( XTPPROGRESSDRAWSTRUCT & ds )
protectedvirtual

This member function is called by the progress bar to adjust the bar drawing size; can be overridden in derived classes.

Parameters
ds Struct used by the progress bar during paint operations.
See also
XTPPROGRESSDRAWSTRUCT

Reimplemented in CXTPProgressCtrlThemeFlat, CXTPProgressCtrlThemeNativeWindows, and CXTPProgressCtrlThemeNativeWinXP.

◆ Draw()

virtual void Draw ( XTPPROGRESSDRAWSTRUCT & ds )
virtual

This member function is called by the progress bar to draw the client area of the control.

Parameters
ds Struct used by the progress bar during paint operations.
See also
XTPPROGRESSDRAWSTRUCT

Reimplemented in CXTPProgressCtrlThemeOffice2013, and CXTPProgressCtrlThemeResource.

◆ DrawNcBorders()

virtual void DrawNcBorders | ( | CDC * | pDC,
 |  | CRect | rc )
 virtual

This member function is called by the progress bar to draw the non-client borders.

Parameters
pDC | Pointer to a valid device context.
rc | Size of the non-client border area.

Reimplemented in CXTPProgressCtrlThemeOffice2000, CXTPProgressCtrlThemeOffice2003, CXTPProgressCtrlThemeOffice2013, and CXTPProgressCtrlThemeOfficeXP.

◆ DrawText()

virtual void DrawText ( XTPPROGRESSDRAWSTRUCT & ds )
virtual

This member function is called by the progress bar to draw the progress text for the control.

Parameters
ds Struct used by the progress bar during paint operations.
See also
XTPPROGRESSDRAWSTRUCT

◆ GetBackColor()

COLORREF GetBackColor ( )

This member function gets the background color for the progress bar.

Returns
The COLORREF value used for the background.

◆ GetBarColor()

COLORREF GetBarColor ( )

This member function gets the bar color for the progress bar.

Returns
The COLORREF value used for the bar.

◆ GetBorderColor()

COLORREF GetBorderColor ( )

This member function gets the border color for the progress bar.

Returns
The COLORREF value used for the border.

◆ GetTextColor()

COLORREF GetTextColor ( )

This member function gets the text color for the progress bar.

Returns
The COLORREF value used for the text.

◆ RefreshMetrics()

virtual void RefreshMetrics ( )
virtual

This member function performs initialization for the Paint Manager.

Initializes all drawing defaults (fonts, colors, etc.).

Reimplemented in CXTPProgressCtrlThemeFlat, CXTPProgressCtrlThemeOffice2003, CXTPProgressCtrlThemeOffice2013, CXTPProgressCtrlThemeUltraFlat, and CXTPProgressCtrlThemeVisualStudio2015.

◆ SetBackColor()

COLORREF SetBackColor ( COLORREF clrNew )

This member function sets the background color for the progress bar.

Parameters
clrNew A COLORREF value that specifies the new background color.
Returns
The COLORREF value used for the background.

◆ SetBarColor()

COLORREF SetBarColor ( COLORREF clrNew )

This member function sets the bar color for the progress bar.

Parameters
clrNew A COLORREF value that specifies the new bar color.
Returns
The COLORREF value used for the bar.

◆ SetBorderColor()

COLORREF SetBorderColor ( COLORREF clrNew )

This member function sets the border color for the progress bar.

Parameters
clrNew A COLORREF value that specifies the new border color.
Returns
The COLORREF value used for the border.

◆ SetTextColor()

COLORREF SetTextColor ( COLORREF clrNew )

This member function sets the text color for the progress bar.

Parameters
clrNew A COLORREF value that specifies the new text color.
Returns
The COLORREF value used for text.

◆ UseWinThemes()

void UseWinThemes ( BOOL bUseWinThemes = TRUE )

Call this member function to draw the control using the current Windows theme.

This will override any themes currently set.

Parameters
bUseWinThemes TRUE to enable Windows themes.

◆ UsingWinThemes()

BOOL UsingWinThemes ( BOOL bCheckReady = FALSE )

Used by the progress bar to determine if Windows themes should be used to draw the control.

Parameters
bCheckReady TRUE to perform an additional check IsAppThemeReady().
Returns
TRUE if the progress bar is drawn using default Windows themes.
The documentation for this class was generated from the following file:
  • XTPProgressCtrlPaintManager.h


Toolkit Pro: CXTPProgressCtrlThemeFlat Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPProgressCtrlThemeFlat Class Reference

The CXTPProgressCtrlThemeFlat class is derived from CXTPProgressCtrlPaintManager and is used by the progress bar to draw a flat style progress bar. More...

Inheritance diagram for CXTPProgressCtrlThemeFlat:
[legend]

Public Member Functions

CXTPProgressCtrlThemeFlat ()
Default paint manager constructor.
virtual void | RefreshMetrics ()
This member function performs initialization for the Paint Manager.
- Public Member Functions inherited from CXTPProgressCtrlPaintManager
CXTPProgressCtrlPaintManager ()
Default paint manager constructor.
virtual | ~CXTPProgressCtrlPaintManager ()
Default paint manager destructor.
COLORREF | SetBorderColor (COLORREF clrNew)
This member function sets the border color for the progress bar.
COLORREF | SetBarColor (COLORREF clrNew)
This member function sets the bar color for the progress bar.
COLORREF | SetBackColor (COLORREF clrNew)
This member function sets the background color for the progress bar.
COLORREF | SetTextColor (COLORREF clrNew)
This member function sets the text color for the progress bar.
COLORREF | GetBorderColor ()
This member function gets the border color for the progress bar.
COLORREF | GetBarColor ()
This member function gets the bar color for the progress bar.
COLORREF | GetBackColor ()
This member function gets the background color for the progress bar.
COLORREF | GetTextColor ()
This member function gets the text color for the progress bar.
virtual void | DrawNcBorders (CDC *pDC, CRect rc)
This member function is called by the progress bar to draw the non-client borders.
virtual void | Draw (XTPPROGRESSDRAWSTRUCT &ds)
This member function is called by the progress bar to draw the client area of the control.
virtual void | DrawText (XTPPROGRESSDRAWSTRUCT &ds)
This member function is called by the progress bar to draw the progress text for the control.
BOOL | UsingWinThemes (BOOL bCheckReady=FALSE)
Used by the progress bar to determine if Windows themes should be used to draw the control.
void | UseWinThemes (BOOL bUseWinThemes=TRUE)
Call this member function to draw the control using the current Windows theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

virtual void DeflateRect (XTPPROGRESSDRAWSTRUCT &ds)
This member function is called by the progress bar to adjust the bar drawing size; can be overridden in derived classes.
- Protected Member Functions inherited from CXTPProgressCtrlPaintManager

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Attributes inherited from CXTPProgressCtrlPaintManager
BOOL | m_bUseWinTheme
TRUE when using Windows themes.
XTPControlTheme | m_nTheme
Theme identifier.
CXTPWinThemeWrapper | m_winTheme
Wrapper used when drawing Windows themes.
CXTPPaintManagerColor | m_clrBorder
An RGB value representing the border color.
CXTPPaintManagerColor | m_clrBar
An RGB value representing the bar color.
CXTPPaintManagerColor | m_clrBack
An RGB value representing the back color.
CXTPPaintManagerColor | m_clrText
An RGB value representing the text color.
CXTPPaintManagerColor | m_clrBarText
An RGB value representing the hilite text color.

Detailed Description

The CXTPProgressCtrlThemeFlat class is derived from CXTPProgressCtrlPaintManager and is used by the progress bar to draw a flat style progress bar.

Constructor & Destructor Documentation

◆ CXTPProgressCtrlThemeFlat()

CXTPProgressCtrlThemeFlat ( )

Default paint manager constructor.

Handles initial initialization.

See also
RefreshMetrics()

Member Function Documentation

◆ DeflateRect()

virtual void DeflateRect ( XTPPROGRESSDRAWSTRUCT & ds )
protectedvirtual

This member function is called by the progress bar to adjust the bar drawing size; can be overridden in derived classes.

Parameters
ds Struct used by the progress bar during paint operations.
See also
XTPPROGRESSDRAWSTRUCT

Reimplemented from CXTPProgressCtrlPaintManager.

◆ RefreshMetrics()

virtual void RefreshMetrics ( )
virtual

This member function performs initialization for the Paint Manager.

Initializes all drawing defaults (fonts, colors, etc.).

Reimplemented from CXTPProgressCtrlPaintManager.

Reimplemented in CXTPProgressCtrlThemeUltraFlat.

The documentation for this class was generated from the following file:
  • XTPProgressCtrlPaintManager.h


Toolkit Pro: CXTPProgressCtrlThemeNativeWindows Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPProgressCtrlThemeNativeWindows Class Reference

The CXTPProgressCtrlThemeNativeWindows class is derived from CXTPProgressCtrlPaintManager and is used by the progress bar to draw a native Windows style progress bar. More...

Inheritance diagram for CXTPProgressCtrlThemeNativeWindows:
[legend]

Public Member Functions

CXTPProgressCtrlThemeNativeWindows ()
Default paint manager constructor.
- Public Member Functions inherited from CXTPProgressCtrlPaintManager
CXTPProgressCtrlPaintManager ()
Default paint manager constructor.
virtual | ~CXTPProgressCtrlPaintManager ()
Default paint manager destructor.
virtual void | RefreshMetrics ()
This member function performs initialization for the Paint Manager.
COLORREF | SetBorderColor (COLORREF clrNew)
This member function sets the border color for the progress bar.
COLORREF | SetBarColor (COLORREF clrNew)
This member function sets the bar color for the progress bar.
COLORREF | SetBackColor (COLORREF clrNew)
This member function sets the background color for the progress bar.
COLORREF | SetTextColor (COLORREF clrNew)
This member function sets the text color for the progress bar.
COLORREF | GetBorderColor ()
This member function gets the border color for the progress bar.
COLORREF | GetBarColor ()
This member function gets the bar color for the progress bar.
COLORREF | GetBackColor ()
This member function gets the background color for the progress bar.
COLORREF | GetTextColor ()
This member function gets the text color for the progress bar.
virtual void | DrawNcBorders (CDC *pDC, CRect rc)
This member function is called by the progress bar to draw the non-client borders.
virtual void | Draw (XTPPROGRESSDRAWSTRUCT &ds)
This member function is called by the progress bar to draw the client area of the control.
virtual void | DrawText (XTPPROGRESSDRAWSTRUCT &ds)
This member function is called by the progress bar to draw the progress text for the control.
BOOL | UsingWinThemes (BOOL bCheckReady=FALSE)
Used by the progress bar to determine if Windows themes should be used to draw the control.
void | UseWinThemes (BOOL bUseWinThemes=TRUE)
Call this member function to draw the control using the current Windows theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

virtual void DeflateRect (XTPPROGRESSDRAWSTRUCT &ds)
This member function is called by the progress bar to adjust the bar drawing size; can be overridden in derived classes.
- Protected Member Functions inherited from CXTPProgressCtrlPaintManager

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Attributes inherited from CXTPProgressCtrlPaintManager
BOOL | m_bUseWinTheme
TRUE when using Windows themes.
XTPControlTheme | m_nTheme
Theme identifier.
CXTPWinThemeWrapper | m_winTheme
Wrapper used when drawing Windows themes.
CXTPPaintManagerColor | m_clrBorder
An RGB value representing the border color.
CXTPPaintManagerColor | m_clrBar
An RGB value representing the bar color.
CXTPPaintManagerColor | m_clrBack
An RGB value representing the back color.
CXTPPaintManagerColor | m_clrText
An RGB value representing the text color.
CXTPPaintManagerColor | m_clrBarText
An RGB value representing the hilite text color.

Detailed Description

The CXTPProgressCtrlThemeNativeWindows class is derived from CXTPProgressCtrlPaintManager and is used by the progress bar to draw a native Windows style progress bar.

Constructor & Destructor Documentation

◆ CXTPProgressCtrlThemeNativeWindows()

CXTPProgressCtrlThemeNativeWindows ( )

Default paint manager constructor.

Handles initial initialization.

See also
RefreshMetrics()

Member Function Documentation

◆ DeflateRect()

virtual void DeflateRect ( XTPPROGRESSDRAWSTRUCT & ds )
protectedvirtual

This member function is called by the progress bar to adjust the bar drawing size; can be overridden in derived classes.

Parameters
ds Struct used by the progress bar during paint operations.
See also
XTPPROGRESSDRAWSTRUCT

Reimplemented from CXTPProgressCtrlPaintManager.

The documentation for this class was generated from the following file:
  • XTPProgressCtrlPaintManager.h


Toolkit Pro: CXTPProgressCtrlThemeNativeWinXP Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPProgressCtrlThemeNativeWinXP Class Reference

The CXTPProgressCtrlThemeNativeWinXP class is derived from CXTPProgressCtrlPaintManager and is used by the progress bar to draw a native Windows style progress bar. More...

Inheritance diagram for CXTPProgressCtrlThemeNativeWinXP:
[legend]

Public Member Functions

CXTPProgressCtrlThemeNativeWinXP ()
Default paint manager constructor.
- Public Member Functions inherited from CXTPProgressCtrlPaintManager
CXTPProgressCtrlPaintManager ()
Default paint manager constructor.
virtual | ~CXTPProgressCtrlPaintManager ()
Default paint manager destructor.
virtual void | RefreshMetrics ()
This member function performs initialization for the Paint Manager.
COLORREF | SetBorderColor (COLORREF clrNew)
This member function sets the border color for the progress bar.
COLORREF | SetBarColor (COLORREF clrNew)
This member function sets the bar color for the progress bar.
COLORREF | SetBackColor (COLORREF clrNew)
This member function sets the background color for the progress bar.
COLORREF | SetTextColor (COLORREF clrNew)
This member function sets the text color for the progress bar.
COLORREF | GetBorderColor ()
This member function gets the border color for the progress bar.
COLORREF | GetBarColor ()
This member function gets the bar color for the progress bar.
COLORREF | GetBackColor ()
This member function gets the background color for the progress bar.
COLORREF | GetTextColor ()
This member function gets the text color for the progress bar.
virtual void | DrawNcBorders (CDC *pDC, CRect rc)
This member function is called by the progress bar to draw the non-client borders.
virtual void | Draw (XTPPROGRESSDRAWSTRUCT &ds)
This member function is called by the progress bar to draw the client area of the control.
virtual void | DrawText (XTPPROGRESSDRAWSTRUCT &ds)
This member function is called by the progress bar to draw the progress text for the control.
BOOL | UsingWinThemes (BOOL bCheckReady=FALSE)
Used by the progress bar to determine if Windows themes should be used to draw the control.
void | UseWinThemes (BOOL bUseWinThemes=TRUE)
Call this member function to draw the control using the current Windows theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

virtual void DeflateRect (XTPPROGRESSDRAWSTRUCT &ds)
This member function is called by the progress bar to adjust the bar drawing size; can be overridden in derived classes.
- Protected Member Functions inherited from CXTPProgressCtrlPaintManager

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Attributes inherited from CXTPProgressCtrlPaintManager
BOOL | m_bUseWinTheme
TRUE when using Windows themes.
XTPControlTheme | m_nTheme
Theme identifier.
CXTPWinThemeWrapper | m_winTheme
Wrapper used when drawing Windows themes.
CXTPPaintManagerColor | m_clrBorder
An RGB value representing the border color.
CXTPPaintManagerColor | m_clrBar
An RGB value representing the bar color.
CXTPPaintManagerColor | m_clrBack
An RGB value representing the back color.
CXTPPaintManagerColor | m_clrText
An RGB value representing the text color.
CXTPPaintManagerColor | m_clrBarText
An RGB value representing the hilite text color.

Detailed Description

The CXTPProgressCtrlThemeNativeWinXP class is derived from CXTPProgressCtrlPaintManager and is used by the progress bar to draw a native Windows style progress bar.

Constructor & Destructor Documentation

◆ CXTPProgressCtrlThemeNativeWinXP()

CXTPProgressCtrlThemeNativeWinXP ( )

Default paint manager constructor.

Handles initial initialization.

See also
RefreshMetrics()

Member Function Documentation

◆ DeflateRect()

virtual void DeflateRect ( XTPPROGRESSDRAWSTRUCT & ds )
protectedvirtual

This member function is called by the progress bar to adjust the bar drawing size; can be overridden in derived classes.

Parameters
ds Struct used by the progress bar during paint operations.
See also
XTPPROGRESSDRAWSTRUCT

Reimplemented from CXTPProgressCtrlPaintManager.

The documentation for this class was generated from the following file:
  • XTPProgressCtrlPaintManager.h


Toolkit Pro: CXTPProgressCtrlThemeOffice2000 Class Reference

Public Member Functions | List of all members
CXTPProgressCtrlThemeOffice2000 Class Reference

The CXTPProgressCtrlThemeFlat class is derived from CXTPProgressCtrlPaintManager and is used by the progress bar to draw an Office 2000 style progress bar. More...

Inheritance diagram for CXTPProgressCtrlThemeOffice2000:
[legend]

Public Member Functions

CXTPProgressCtrlThemeOffice2000 ()
Default paint manager constructor.
virtual void | DrawNcBorders (CDC *pDC, CRect rc)
This member function is called by the progress bar to draw the non-client borders.
- Public Member Functions inherited from CXTPProgressCtrlPaintManager
CXTPProgressCtrlPaintManager ()
Default paint manager constructor.
virtual | ~CXTPProgressCtrlPaintManager ()
Default paint manager destructor.
virtual void | RefreshMetrics ()
This member function performs initialization for the Paint Manager.
COLORREF | SetBorderColor (COLORREF clrNew)
This member function sets the border color for the progress bar.
COLORREF | SetBarColor (COLORREF clrNew)
This member function sets the bar color for the progress bar.
COLORREF | SetBackColor (COLORREF clrNew)
This member function sets the background color for the progress bar.
COLORREF | SetTextColor (COLORREF clrNew)
This member function sets the text color for the progress bar.
COLORREF | GetBorderColor ()
This member function gets the border color for the progress bar.
COLORREF | GetBarColor ()
This member function gets the bar color for the progress bar.
COLORREF | GetBackColor ()
This member function gets the background color for the progress bar.
COLORREF | GetTextColor ()
This member function gets the text color for the progress bar.
virtual void | Draw (XTPPROGRESSDRAWSTRUCT &ds)
This member function is called by the progress bar to draw the client area of the control.
virtual void | DrawText (XTPPROGRESSDRAWSTRUCT &ds)
This member function is called by the progress bar to draw the progress text for the control.
BOOL | UsingWinThemes (BOOL bCheckReady=FALSE)
Used by the progress bar to determine if Windows themes should be used to draw the control.
void | UseWinThemes (BOOL bUseWinThemes=TRUE)
Call this member function to draw the control using the current Windows theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Member Functions inherited from CXTPProgressCtrlPaintManager
virtual void | DeflateRect (XTPPROGRESSDRAWSTRUCT &ds)
This member function is called by the progress bar to adjust the bar drawing size; can be overridden in derived classes.
- Protected Attributes inherited from CXTPProgressCtrlPaintManager
BOOL | m_bUseWinTheme
TRUE when using Windows themes.
XTPControlTheme | m_nTheme
Theme identifier.
CXTPWinThemeWrapper | m_winTheme
Wrapper used when drawing Windows themes.
CXTPPaintManagerColor | m_clrBorder
An RGB value representing the border color.
CXTPPaintManagerColor | m_clrBar
An RGB value representing the bar color.
CXTPPaintManagerColor | m_clrBack
An RGB value representing the back color.
CXTPPaintManagerColor | m_clrText
An RGB value representing the text color.
CXTPPaintManagerColor | m_clrBarText
An RGB value representing the hilite text color.

Detailed Description

The CXTPProgressCtrlThemeFlat class is derived from CXTPProgressCtrlPaintManager and is used by the progress bar to draw an Office 2000 style progress bar.

Constructor & Destructor Documentation

◆ CXTPProgressCtrlThemeOffice2000()

CXTPProgressCtrlThemeOffice2000 ( )

Default paint manager constructor.

Handles initial initialization.

See also
RefreshMetrics()

Member Function Documentation

◆ DrawNcBorders()

virtual void DrawNcBorders | ( | CDC * | pDC,
 |  | CRect | rc )
 virtual

This member function is called by the progress bar to draw the non-client borders.

Parameters
pDC | Pointer to a valid device context.
rc | Size of the non-client border area.

Reimplemented from CXTPProgressCtrlPaintManager.

Reimplemented in CXTPProgressCtrlThemeOffice2003, CXTPProgressCtrlThemeOffice2013, and CXTPProgressCtrlThemeOfficeXP.

The documentation for this class was generated from the following file:
  • XTPProgressCtrlPaintManager.h


Toolkit Pro: CXTPProgressCtrlThemeOffice2003 Class Reference

Public Member Functions | List of all members
CXTPProgressCtrlThemeOffice2003 Class Reference

The CXTPProgressCtrlThemeFlat class is derived from CXTPProgressCtrlPaintManager and is used by the progress bar to draw an Office 2003 style progress bar. More...

Inheritance diagram for CXTPProgressCtrlThemeOffice2003:
[legend]

Public Member Functions

CXTPProgressCtrlThemeOffice2003 ()
Default paint manager constructor.
virtual void | RefreshMetrics ()
This member function performs initialization for the Paint Manager.
virtual void | DrawNcBorders (CDC *pDC, CRect rc)
This member function is called by the progress bar to draw the non-client borders.
- Public Member Functions inherited from CXTPProgressCtrlThemeOffice2000
CXTPProgressCtrlThemeOffice2000 ()
Default paint manager constructor.
- Public Member Functions inherited from CXTPProgressCtrlPaintManager
CXTPProgressCtrlPaintManager ()
Default paint manager constructor.
virtual | ~CXTPProgressCtrlPaintManager ()
Default paint manager destructor.
COLORREF | SetBorderColor (COLORREF clrNew)
This member function sets the border color for the progress bar.
COLORREF | SetBarColor (COLORREF clrNew)
This member function sets the bar color for the progress bar.
COLORREF | SetBackColor (COLORREF clrNew)
This member function sets the background color for the progress bar.
COLORREF | SetTextColor (COLORREF clrNew)
This member function sets the text color for the progress bar.
COLORREF | GetBorderColor ()
This member function gets the border color for the progress bar.
COLORREF | GetBarColor ()
This member function gets the bar color for the progress bar.
COLORREF | GetBackColor ()
This member function gets the background color for the progress bar.
COLORREF | GetTextColor ()
This member function gets the text color for the progress bar.
virtual void | Draw (XTPPROGRESSDRAWSTRUCT &ds)
This member function is called by the progress bar to draw the client area of the control.
virtual void | DrawText (XTPPROGRESSDRAWSTRUCT &ds)
This member function is called by the progress bar to draw the progress text for the control.
BOOL | UsingWinThemes (BOOL bCheckReady=FALSE)
Used by the progress bar to determine if Windows themes should be used to draw the control.
void | UseWinThemes (BOOL bUseWinThemes=TRUE)
Call this member function to draw the control using the current Windows theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Member Functions inherited from CXTPProgressCtrlPaintManager
virtual void | DeflateRect (XTPPROGRESSDRAWSTRUCT &ds)
This member function is called by the progress bar to adjust the bar drawing size; can be overridden in derived classes.
- Protected Attributes inherited from CXTPProgressCtrlPaintManager
BOOL | m_bUseWinTheme
TRUE when using Windows themes.
XTPControlTheme | m_nTheme
Theme identifier.
CXTPWinThemeWrapper | m_winTheme
Wrapper used when drawing Windows themes.
CXTPPaintManagerColor | m_clrBorder
An RGB value representing the border color.
CXTPPaintManagerColor | m_clrBar
An RGB value representing the bar color.
CXTPPaintManagerColor | m_clrBack
An RGB value representing the back color.
CXTPPaintManagerColor | m_clrText
An RGB value representing the text color.
CXTPPaintManagerColor | m_clrBarText
An RGB value representing the hilite text color.

Detailed Description

The CXTPProgressCtrlThemeFlat class is derived from CXTPProgressCtrlPaintManager and is used by the progress bar to draw an Office 2003 style progress bar.

Constructor & Destructor Documentation

◆ CXTPProgressCtrlThemeOffice2003()

CXTPProgressCtrlThemeOffice2003 ( )

Default paint manager constructor.

Handles initial initialization.

See also
RefreshMetrics()

Member Function Documentation

◆ DrawNcBorders()

virtual void DrawNcBorders | ( | CDC * | pDC,
 |  | CRect | rc )
 virtual

This member function is called by the progress bar to draw the non-client borders.

Parameters
pDC | Pointer to a valid device context.
rc | Size of the non-client border area.

Reimplemented from CXTPProgressCtrlThemeOffice2000.

◆ RefreshMetrics()

virtual void RefreshMetrics ( )
virtual

This member function performs initialization for the Paint Manager.

Initializes all drawing defaults (fonts, colors, etc.).

Reimplemented from CXTPProgressCtrlPaintManager.

The documentation for this class was generated from the following file:
  • XTPProgressCtrlPaintManager.h


Toolkit Pro: CXTPProgressCtrlThemeOffice2013 Class Reference

Public Member Functions | List of all members
CXTPProgressCtrlThemeOffice2013 Class Reference

The CXTPProgressCtrlThemeFlat class is derived from CXTPProgressCtrlPaintManager and is used by the progress bar to draw an Office 2013 style progress bar. More...

Inheritance diagram for CXTPProgressCtrlThemeOffice2013:
[legend]

Public Member Functions

CXTPProgressCtrlThemeOffice2013 ()
Default paint manager constructor.
virtual void | RefreshMetrics ()
This member function performs initialization for the Paint Manager.
virtual void | DrawNcBorders (CDC *pDC, CRect rc)
This member function is called by the progress bar to draw the non-client borders.
virtual void | Draw (XTPPROGRESSDRAWSTRUCT &ds)
This member function is called by the progress bar to draw the client area of the control.
- Public Member Functions inherited from CXTPProgressCtrlThemeOffice2000
CXTPProgressCtrlThemeOffice2000 ()
Default paint manager constructor.
- Public Member Functions inherited from CXTPProgressCtrlPaintManager
CXTPProgressCtrlPaintManager ()
Default paint manager constructor.
virtual | ~CXTPProgressCtrlPaintManager ()
Default paint manager destructor.
COLORREF | SetBorderColor (COLORREF clrNew)
This member function sets the border color for the progress bar.
COLORREF | SetBarColor (COLORREF clrNew)
This member function sets the bar color for the progress bar.
COLORREF | SetBackColor (COLORREF clrNew)
This member function sets the background color for the progress bar.
COLORREF | SetTextColor (COLORREF clrNew)
This member function sets the text color for the progress bar.
COLORREF | GetBorderColor ()
This member function gets the border color for the progress bar.
COLORREF | GetBarColor ()
This member function gets the bar color for the progress bar.
COLORREF | GetBackColor ()
This member function gets the background color for the progress bar.
COLORREF | GetTextColor ()
This member function gets the text color for the progress bar.
virtual void | DrawText (XTPPROGRESSDRAWSTRUCT &ds)
This member function is called by the progress bar to draw the progress text for the control.
BOOL | UsingWinThemes (BOOL bCheckReady=FALSE)
Used by the progress bar to determine if Windows themes should be used to draw the control.
void | UseWinThemes (BOOL bUseWinThemes=TRUE)
Call this member function to draw the control using the current Windows theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Member Functions inherited from CXTPProgressCtrlPaintManager
virtual void | DeflateRect (XTPPROGRESSDRAWSTRUCT &ds)
This member function is called by the progress bar to adjust the bar drawing size; can be overridden in derived classes.
- Protected Attributes inherited from CXTPProgressCtrlPaintManager
BOOL | m_bUseWinTheme
TRUE when using Windows themes.
XTPControlTheme | m_nTheme
Theme identifier.
CXTPWinThemeWrapper | m_winTheme
Wrapper used when drawing Windows themes.
CXTPPaintManagerColor | m_clrBorder
An RGB value representing the border color.
CXTPPaintManagerColor | m_clrBar
An RGB value representing the bar color.
CXTPPaintManagerColor | m_clrBack
An RGB value representing the back color.
CXTPPaintManagerColor | m_clrText
An RGB value representing the text color.
CXTPPaintManagerColor | m_clrBarText
An RGB value representing the hilite text color.

Detailed Description

The CXTPProgressCtrlThemeFlat class is derived from CXTPProgressCtrlPaintManager and is used by the progress bar to draw an Office 2013 style progress bar.

Constructor & Destructor Documentation

◆ CXTPProgressCtrlThemeOffice2013()

CXTPProgressCtrlThemeOffice2013 ( )

Default paint manager constructor.

Handles initial initialization.

See also
RefreshMetrics()

Member Function Documentation

◆ Draw()

virtual void Draw ( XTPPROGRESSDRAWSTRUCT & ds )
virtual

This member function is called by the progress bar to draw the client area of the control.

Parameters
ds Struct used by the progress bar during paint operations.
See also
XTPPROGRESSDRAWSTRUCT

Reimplemented from CXTPProgressCtrlPaintManager.

◆ DrawNcBorders()

virtual void DrawNcBorders | ( | CDC * | pDC,
 |  | CRect | rc )
 virtual

This member function is called by the progress bar to draw the non-client borders.

Parameters
pDC | Pointer to a valid device context.
rc | Size of the non-client border area.

Reimplemented from CXTPProgressCtrlThemeOffice2000.

◆ RefreshMetrics()

virtual void RefreshMetrics ( )
virtual

This member function performs initialization for the Paint Manager.

Initializes all drawing defaults (fonts, colors, etc.).

Reimplemented from CXTPProgressCtrlPaintManager.

Reimplemented in CXTPProgressCtrlThemeVisualStudio2015.

The documentation for this class was generated from the following file:
  • XTPProgressCtrlPaintManager.h


Toolkit Pro: CXTPProgressCtrlThemeOfficeXP Class Reference

Public Member Functions | List of all members
CXTPProgressCtrlThemeOfficeXP Class Reference

The CXTPProgressCtrlThemeXP class is derived from CXTPProgressCtrlThemeFlat and is used by the progress bar to draw an Office XP style progress bar. More...

Inheritance diagram for CXTPProgressCtrlThemeOfficeXP:
[legend]

Public Member Functions

CXTPProgressCtrlThemeOfficeXP ()
Default paint manager constructor.
virtual void | DrawNcBorders (CDC *pDC, CRect rc)
This member function is called by the progress bar to draw the non-client borders.
- Public Member Functions inherited from CXTPProgressCtrlThemeOffice2000
CXTPProgressCtrlThemeOffice2000 ()
Default paint manager constructor.
- Public Member Functions inherited from CXTPProgressCtrlPaintManager
CXTPProgressCtrlPaintManager ()
Default paint manager constructor.
virtual | ~CXTPProgressCtrlPaintManager ()
Default paint manager destructor.
virtual void | RefreshMetrics ()
This member function performs initialization for the Paint Manager.
COLORREF | SetBorderColor (COLORREF clrNew)
This member function sets the border color for the progress bar.
COLORREF | SetBarColor (COLORREF clrNew)
This member function sets the bar color for the progress bar.
COLORREF | SetBackColor (COLORREF clrNew)
This member function sets the background color for the progress bar.
COLORREF | SetTextColor (COLORREF clrNew)
This member function sets the text color for the progress bar.
COLORREF | GetBorderColor ()
This member function gets the border color for the progress bar.
COLORREF | GetBarColor ()
This member function gets the bar color for the progress bar.
COLORREF | GetBackColor ()
This member function gets the background color for the progress bar.
COLORREF | GetTextColor ()
This member function gets the text color for the progress bar.
virtual void | Draw (XTPPROGRESSDRAWSTRUCT &ds)
This member function is called by the progress bar to draw the client area of the control.
virtual void | DrawText (XTPPROGRESSDRAWSTRUCT &ds)
This member function is called by the progress bar to draw the progress text for the control.
BOOL | UsingWinThemes (BOOL bCheckReady=FALSE)
Used by the progress bar to determine if Windows themes should be used to draw the control.
void | UseWinThemes (BOOL bUseWinThemes=TRUE)
Call this member function to draw the control using the current Windows theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Member Functions inherited from CXTPProgressCtrlPaintManager
virtual void | DeflateRect (XTPPROGRESSDRAWSTRUCT &ds)
This member function is called by the progress bar to adjust the bar drawing size; can be overridden in derived classes.
- Protected Attributes inherited from CXTPProgressCtrlPaintManager
BOOL | m_bUseWinTheme
TRUE when using Windows themes.
XTPControlTheme | m_nTheme
Theme identifier.
CXTPWinThemeWrapper | m_winTheme
Wrapper used when drawing Windows themes.
CXTPPaintManagerColor | m_clrBorder
An RGB value representing the border color.
CXTPPaintManagerColor | m_clrBar
An RGB value representing the bar color.
CXTPPaintManagerColor | m_clrBack
An RGB value representing the back color.
CXTPPaintManagerColor | m_clrText
An RGB value representing the text color.
CXTPPaintManagerColor | m_clrBarText
An RGB value representing the hilite text color.

Detailed Description

The CXTPProgressCtrlThemeXP class is derived from CXTPProgressCtrlThemeFlat and is used by the progress bar to draw an Office XP style progress bar.

Constructor & Destructor Documentation

◆ CXTPProgressCtrlThemeOfficeXP()

CXTPProgressCtrlThemeOfficeXP ( )

Default paint manager constructor.

Handles initial initialization.

See also
RefreshMetrics()

Member Function Documentation

◆ DrawNcBorders()

virtual void DrawNcBorders | ( | CDC * | pDC,
 |  | CRect | rc )
 virtual

This member function is called by the progress bar to draw the non-client borders.

Parameters
pDC | Pointer to a valid device context.
rc | Size of the non-client border area.

Reimplemented from CXTPProgressCtrlThemeOffice2000.

The documentation for this class was generated from the following file:
  • XTPProgressCtrlPaintManager.h


Toolkit Pro: CXTPProgressCtrlThemeResource Class Reference

Public Member Functions | List of all members
CXTPProgressCtrlThemeResource Class Reference

The CXTPProgressCtrlThemeFlat class is derived from CXTPProgressCtrlPaintManager and is used by the progress bar to draw an progress bar using a resource DLL. More...

Inheritance diagram for CXTPProgressCtrlThemeResource:
[legend]

Public Member Functions

CXTPProgressCtrlThemeResource ()
Default paint manager constructor.
virtual void | Draw (XTPPROGRESSDRAWSTRUCT &ds)
This member function is called by the progress bar to draw the client area of the control.
- Public Member Functions inherited from CXTPProgressCtrlThemeOffice2000
CXTPProgressCtrlThemeOffice2000 ()
Default paint manager constructor.
virtual void | DrawNcBorders (CDC *pDC, CRect rc)
This member function is called by the progress bar to draw the non-client borders.
- Public Member Functions inherited from CXTPProgressCtrlPaintManager
CXTPProgressCtrlPaintManager ()
Default paint manager constructor.
virtual | ~CXTPProgressCtrlPaintManager ()
Default paint manager destructor.
virtual void | RefreshMetrics ()
This member function performs initialization for the Paint Manager.
COLORREF | SetBorderColor (COLORREF clrNew)
This member function sets the border color for the progress bar.
COLORREF | SetBarColor (COLORREF clrNew)
This member function sets the bar color for the progress bar.
COLORREF | SetBackColor (COLORREF clrNew)
This member function sets the background color for the progress bar.
COLORREF | SetTextColor (COLORREF clrNew)
This member function sets the text color for the progress bar.
COLORREF | GetBorderColor ()
This member function gets the border color for the progress bar.
COLORREF | GetBarColor ()
This member function gets the bar color for the progress bar.
COLORREF | GetBackColor ()
This member function gets the background color for the progress bar.
COLORREF | GetTextColor ()
This member function gets the text color for the progress bar.
virtual void | DrawText (XTPPROGRESSDRAWSTRUCT &ds)
This member function is called by the progress bar to draw the progress text for the control.
BOOL | UsingWinThemes (BOOL bCheckReady=FALSE)
Used by the progress bar to determine if Windows themes should be used to draw the control.
void | UseWinThemes (BOOL bUseWinThemes=TRUE)
Call this member function to draw the control using the current Windows theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Member Functions inherited from CXTPProgressCtrlPaintManager
virtual void | DeflateRect (XTPPROGRESSDRAWSTRUCT &ds)
This member function is called by the progress bar to adjust the bar drawing size; can be overridden in derived classes.
- Protected Attributes inherited from CXTPProgressCtrlPaintManager
BOOL | m_bUseWinTheme
TRUE when using Windows themes.
XTPControlTheme | m_nTheme
Theme identifier.
CXTPWinThemeWrapper | m_winTheme
Wrapper used when drawing Windows themes.
CXTPPaintManagerColor | m_clrBorder
An RGB value representing the border color.
CXTPPaintManagerColor | m_clrBar
An RGB value representing the bar color.
CXTPPaintManagerColor | m_clrBack
An RGB value representing the back color.
CXTPPaintManagerColor | m_clrText
An RGB value representing the text color.
CXTPPaintManagerColor | m_clrBarText
An RGB value representing the hilite text color.

Detailed Description

The CXTPProgressCtrlThemeFlat class is derived from CXTPProgressCtrlPaintManager and is used by the progress bar to draw an progress bar using a resource DLL.

Constructor & Destructor Documentation

◆ CXTPProgressCtrlThemeResource()

CXTPProgressCtrlThemeResource ( )

Default paint manager constructor.

Handles initial initialization.

See also
RefreshMetrics()

Member Function Documentation

◆ Draw()

virtual void Draw ( XTPPROGRESSDRAWSTRUCT & ds )
virtual

This member function is called by the progress bar to draw the client area of the control.

Parameters
ds Struct used by the progress bar during paint operations.
See also
XTPPROGRESSDRAWSTRUCT

Reimplemented from CXTPProgressCtrlPaintManager.

The documentation for this class was generated from the following file:
  • XTPProgressCtrlPaintManager.h


Toolkit Pro: CXTPProgressCtrlThemeUltraFlat Class Reference

Public Member Functions | List of all members
CXTPProgressCtrlThemeUltraFlat Class Reference

The CXTPProgressCtrlThemeUltraFlat class is derived from CXTPProgressCtrlThemeFlat and is used by the progress bar to draw a flat style progress bar with no borders. More...

Inheritance diagram for CXTPProgressCtrlThemeUltraFlat:
[legend]

Public Member Functions

CXTPProgressCtrlThemeUltraFlat ()
Default paint manager constructor.
virtual void | RefreshMetrics ()
This member function performs initialization for the Paint Manager.
- Public Member Functions inherited from CXTPProgressCtrlThemeFlat
CXTPProgressCtrlThemeFlat ()
Default paint manager constructor.
- Public Member Functions inherited from CXTPProgressCtrlPaintManager
CXTPProgressCtrlPaintManager ()
Default paint manager constructor.
virtual | ~CXTPProgressCtrlPaintManager ()
Default paint manager destructor.
COLORREF | SetBorderColor (COLORREF clrNew)
This member function sets the border color for the progress bar.
COLORREF | SetBarColor (COLORREF clrNew)
This member function sets the bar color for the progress bar.
COLORREF | SetBackColor (COLORREF clrNew)
This member function sets the background color for the progress bar.
COLORREF | SetTextColor (COLORREF clrNew)
This member function sets the text color for the progress bar.
COLORREF | GetBorderColor ()
This member function gets the border color for the progress bar.
COLORREF | GetBarColor ()
This member function gets the bar color for the progress bar.
COLORREF | GetBackColor ()
This member function gets the background color for the progress bar.
COLORREF | GetTextColor ()
This member function gets the text color for the progress bar.
virtual void | DrawNcBorders (CDC *pDC, CRect rc)
This member function is called by the progress bar to draw the non-client borders.
virtual void | Draw (XTPPROGRESSDRAWSTRUCT &ds)
This member function is called by the progress bar to draw the client area of the control.
virtual void | DrawText (XTPPROGRESSDRAWSTRUCT &ds)
This member function is called by the progress bar to draw the progress text for the control.
BOOL | UsingWinThemes (BOOL bCheckReady=FALSE)
Used by the progress bar to determine if Windows themes should be used to draw the control.
void | UseWinThemes (BOOL bUseWinThemes=TRUE)
Call this member function to draw the control using the current Windows theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Member Functions inherited from CXTPProgressCtrlThemeFlat
virtual void | DeflateRect (XTPPROGRESSDRAWSTRUCT &ds)
This member function is called by the progress bar to adjust the bar drawing size; can be overridden in derived classes.
- Protected Member Functions inherited from CXTPProgressCtrlPaintManager
- Protected Attributes inherited from CXTPProgressCtrlPaintManager
BOOL | m_bUseWinTheme
TRUE when using Windows themes.
XTPControlTheme | m_nTheme
Theme identifier.
CXTPWinThemeWrapper | m_winTheme
Wrapper used when drawing Windows themes.
CXTPPaintManagerColor | m_clrBorder
An RGB value representing the border color.
CXTPPaintManagerColor | m_clrBar
An RGB value representing the bar color.
CXTPPaintManagerColor | m_clrBack
An RGB value representing the back color.
CXTPPaintManagerColor | m_clrText
An RGB value representing the text color.
CXTPPaintManagerColor | m_clrBarText
An RGB value representing the hilite text color.

Detailed Description

The CXTPProgressCtrlThemeUltraFlat class is derived from CXTPProgressCtrlThemeFlat and is used by the progress bar to draw a flat style progress bar with no borders.

Constructor & Destructor Documentation

◆ CXTPProgressCtrlThemeUltraFlat()

CXTPProgressCtrlThemeUltraFlat ( )

Default paint manager constructor.

Handles initial initialization.

See also
RefreshMetrics()

Member Function Documentation

◆ RefreshMetrics()

virtual void RefreshMetrics ( )
virtual

This member function performs initialization for the Paint Manager.

Initializes all drawing defaults (fonts, colors, etc.).

Reimplemented from CXTPProgressCtrlThemeFlat.

The documentation for this class was generated from the following file:
  • XTPProgressCtrlPaintManager.h


Toolkit Pro: CXTPProgressCtrlThemeVisualStudio2015 Class Reference

Public Member Functions | List of all members
CXTPProgressCtrlThemeVisualStudio2015 Class Reference

The CXTPProgressCtrlThemeFlat class is derived from CXTPProgressCtrlPaintManager and is used by the progress bar to draw a Visual Studio 2015 style progress bar. More...

Inheritance diagram for CXTPProgressCtrlThemeVisualStudio2015:
[legend]

Public Member Functions

CXTPProgressCtrlThemeVisualStudio2015 ()
Default paint manager constructor.
virtual void | RefreshMetrics ()
This member function performs initialization for the Paint Manager.
- Public Member Functions inherited from CXTPProgressCtrlThemeOffice2013
CXTPProgressCtrlThemeOffice2013 ()
Default paint manager constructor.
virtual void | DrawNcBorders (CDC *pDC, CRect rc)
This member function is called by the progress bar to draw the non-client borders.
virtual void | Draw (XTPPROGRESSDRAWSTRUCT &ds)
This member function is called by the progress bar to draw the client area of the control.
- Public Member Functions inherited from CXTPProgressCtrlThemeOffice2000
CXTPProgressCtrlThemeOffice2000 ()
Default paint manager constructor.
- Public Member Functions inherited from CXTPProgressCtrlPaintManager
CXTPProgressCtrlPaintManager ()
Default paint manager constructor.
virtual | ~CXTPProgressCtrlPaintManager ()
Default paint manager destructor.
COLORREF | SetBorderColor (COLORREF clrNew)
This member function sets the border color for the progress bar.
COLORREF | SetBarColor (COLORREF clrNew)
This member function sets the bar color for the progress bar.
COLORREF | SetBackColor (COLORREF clrNew)
This member function sets the background color for the progress bar.
COLORREF | SetTextColor (COLORREF clrNew)
This member function sets the text color for the progress bar.
COLORREF | GetBorderColor ()
This member function gets the border color for the progress bar.
COLORREF | GetBarColor ()
This member function gets the bar color for the progress bar.
COLORREF | GetBackColor ()
This member function gets the background color for the progress bar.
COLORREF | GetTextColor ()
This member function gets the text color for the progress bar.
virtual void | DrawText (XTPPROGRESSDRAWSTRUCT &ds)
This member function is called by the progress bar to draw the progress text for the control.
BOOL | UsingWinThemes (BOOL bCheckReady=FALSE)
Used by the progress bar to determine if Windows themes should be used to draw the control.
void | UseWinThemes (BOOL bUseWinThemes=TRUE)
Call this member function to draw the control using the current Windows theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Member Functions inherited from CXTPProgressCtrlPaintManager
virtual void | DeflateRect (XTPPROGRESSDRAWSTRUCT &ds)
This member function is called by the progress bar to adjust the bar drawing size; can be overridden in derived classes.
- Protected Attributes inherited from CXTPProgressCtrlPaintManager
BOOL | m_bUseWinTheme
TRUE when using Windows themes.
XTPControlTheme | m_nTheme
Theme identifier.
CXTPWinThemeWrapper | m_winTheme
Wrapper used when drawing Windows themes.
CXTPPaintManagerColor | m_clrBorder
An RGB value representing the border color.
CXTPPaintManagerColor | m_clrBar
An RGB value representing the bar color.
CXTPPaintManagerColor | m_clrBack
An RGB value representing the back color.
CXTPPaintManagerColor | m_clrText
An RGB value representing the text color.
CXTPPaintManagerColor | m_clrBarText
An RGB value representing the hilite text color.

Detailed Description

The CXTPProgressCtrlThemeFlat class is derived from CXTPProgressCtrlPaintManager and is used by the progress bar to draw a Visual Studio 2015 style progress bar.

Constructor & Destructor Documentation

◆ CXTPProgressCtrlThemeVisualStudio2015()

CXTPProgressCtrlThemeVisualStudio2015 ( )

Default paint manager constructor.

Handles initial initialization.

See also
RefreshMetrics()

Member Function Documentation

◆ RefreshMetrics()

virtual void RefreshMetrics ( )
virtual

This member function performs initialization for the Paint Manager.

Initializes all drawing defaults (fonts, colors, etc.).

Reimplemented from CXTPProgressCtrlThemeOffice2013.

The documentation for this class was generated from the following file:
  • XTPProgressCtrlPaintManager.h


Toolkit Pro: CXTPProgressCtrlThemeVisualStudio2017 Class Reference

Public Member Functions | List of all members
CXTPProgressCtrlThemeVisualStudio2017 Class Reference

The CXTPProgressCtrlThemeVisualStudio2017 class is derived from CXTPProgressCtrlThemeOffice2013 and is used by the progress bar to draw a Visual Studio 2017 style progress bar. More...

Inheritance diagram for CXTPProgressCtrlThemeVisualStudio2017:
[legend]

Public Member Functions

CXTPProgressCtrlThemeVisualStudio2017 ()
Default paint manager constructor.
- Public Member Functions inherited from CXTPProgressCtrlThemeOffice2013
CXTPProgressCtrlThemeOffice2013 ()
Default paint manager constructor.
virtual void | RefreshMetrics ()
This member function performs initialization for the Paint Manager.
virtual void | DrawNcBorders (CDC *pDC, CRect rc)
This member function is called by the progress bar to draw the non-client borders.
virtual void | Draw (XTPPROGRESSDRAWSTRUCT &ds)
This member function is called by the progress bar to draw the client area of the control.
- Public Member Functions inherited from CXTPProgressCtrlThemeOffice2000
CXTPProgressCtrlThemeOffice2000 ()
Default paint manager constructor.
- Public Member Functions inherited from CXTPProgressCtrlPaintManager
CXTPProgressCtrlPaintManager ()
Default paint manager constructor.
virtual | ~CXTPProgressCtrlPaintManager ()
Default paint manager destructor.
COLORREF | SetBorderColor (COLORREF clrNew)
This member function sets the border color for the progress bar.
COLORREF | SetBarColor (COLORREF clrNew)
This member function sets the bar color for the progress bar.
COLORREF | SetBackColor (COLORREF clrNew)
This member function sets the background color for the progress bar.
COLORREF | SetTextColor (COLORREF clrNew)
This member function sets the text color for the progress bar.
COLORREF | GetBorderColor ()
This member function gets the border color for the progress bar.
COLORREF | GetBarColor ()
This member function gets the bar color for the progress bar.
COLORREF | GetBackColor ()
This member function gets the background color for the progress bar.
COLORREF | GetTextColor ()
This member function gets the text color for the progress bar.
virtual void | DrawText (XTPPROGRESSDRAWSTRUCT &ds)
This member function is called by the progress bar to draw the progress text for the control.
BOOL | UsingWinThemes (BOOL bCheckReady=FALSE)
Used by the progress bar to determine if Windows themes should be used to draw the control.
void | UseWinThemes (BOOL bUseWinThemes=TRUE)
Call this member function to draw the control using the current Windows theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Member Functions inherited from CXTPProgressCtrlPaintManager
virtual void | DeflateRect (XTPPROGRESSDRAWSTRUCT &ds)
This member function is called by the progress bar to adjust the bar drawing size; can be overridden in derived classes.
- Protected Attributes inherited from CXTPProgressCtrlPaintManager
BOOL | m_bUseWinTheme
TRUE when using Windows themes.
XTPControlTheme | m_nTheme
Theme identifier.
CXTPWinThemeWrapper | m_winTheme
Wrapper used when drawing Windows themes.
CXTPPaintManagerColor | m_clrBorder
An RGB value representing the border color.
CXTPPaintManagerColor | m_clrBar
An RGB value representing the bar color.
CXTPPaintManagerColor | m_clrBack
An RGB value representing the back color.
CXTPPaintManagerColor | m_clrText
An RGB value representing the text color.
CXTPPaintManagerColor | m_clrBarText
An RGB value representing the hilite text color.

Detailed Description

The CXTPProgressCtrlThemeVisualStudio2017 class is derived from CXTPProgressCtrlThemeOffice2013 and is used by the progress bar to draw a Visual Studio 2017 style progress bar.

Constructor & Destructor Documentation

◆ CXTPProgressCtrlThemeVisualStudio2017()

CXTPProgressCtrlThemeVisualStudio2017 ( )

Default paint manager constructor.

Handles initial initialization.

See also
RefreshMetrics()
The documentation for this class was generated from the following file:
  • XTPProgressCtrlPaintManager.h


Toolkit Pro: CXTPProgressCtrlThemeVisualStudio2019 Class Reference

Public Member Functions | List of all members
CXTPProgressCtrlThemeVisualStudio2019 Class Reference

The CXTPProgressCtrlThemeVisualStudio2019 class is derived from CXTPProgressCtrlThemeOffice2013 and is used by the progress bar to draw a Visual Studio 2019 style progress bar. More...

Inheritance diagram for CXTPProgressCtrlThemeVisualStudio2019:
[legend]

Public Member Functions

CXTPProgressCtrlThemeVisualStudio2019 ()
Default paint manager constructor.
- Public Member Functions inherited from CXTPProgressCtrlThemeOffice2013
CXTPProgressCtrlThemeOffice2013 ()
Default paint manager constructor.
virtual void | RefreshMetrics ()
This member function performs initialization for the Paint Manager.
virtual void | DrawNcBorders (CDC *pDC, CRect rc)
This member function is called by the progress bar to draw the non-client borders.
virtual void | Draw (XTPPROGRESSDRAWSTRUCT &ds)
This member function is called by the progress bar to draw the client area of the control.
- Public Member Functions inherited from CXTPProgressCtrlThemeOffice2000
CXTPProgressCtrlThemeOffice2000 ()
Default paint manager constructor.
- Public Member Functions inherited from CXTPProgressCtrlPaintManager
CXTPProgressCtrlPaintManager ()
Default paint manager constructor.
virtual | ~CXTPProgressCtrlPaintManager ()
Default paint manager destructor.
COLORREF | SetBorderColor (COLORREF clrNew)
This member function sets the border color for the progress bar.
COLORREF | SetBarColor (COLORREF clrNew)
This member function sets the bar color for the progress bar.
COLORREF | SetBackColor (COLORREF clrNew)
This member function sets the background color for the progress bar.
COLORREF | SetTextColor (COLORREF clrNew)
This member function sets the text color for the progress bar.
COLORREF | GetBorderColor ()
This member function gets the border color for the progress bar.
COLORREF | GetBarColor ()
This member function gets the bar color for the progress bar.
COLORREF | GetBackColor ()
This member function gets the background color for the progress bar.
COLORREF | GetTextColor ()
This member function gets the text color for the progress bar.
virtual void | DrawText (XTPPROGRESSDRAWSTRUCT &ds)
This member function is called by the progress bar to draw the progress text for the control.
BOOL | UsingWinThemes (BOOL bCheckReady=FALSE)
Used by the progress bar to determine if Windows themes should be used to draw the control.
void | UseWinThemes (BOOL bUseWinThemes=TRUE)
Call this member function to draw the control using the current Windows theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Member Functions inherited from CXTPProgressCtrlPaintManager
virtual void | DeflateRect (XTPPROGRESSDRAWSTRUCT &ds)
This member function is called by the progress bar to adjust the bar drawing size; can be overridden in derived classes.
- Protected Attributes inherited from CXTPProgressCtrlPaintManager
BOOL | m_bUseWinTheme
TRUE when using Windows themes.
XTPControlTheme | m_nTheme
Theme identifier.
CXTPWinThemeWrapper | m_winTheme
Wrapper used when drawing Windows themes.
CXTPPaintManagerColor | m_clrBorder
An RGB value representing the border color.
CXTPPaintManagerColor | m_clrBar
An RGB value representing the bar color.
CXTPPaintManagerColor | m_clrBack
An RGB value representing the back color.
CXTPPaintManagerColor | m_clrText
An RGB value representing the text color.
CXTPPaintManagerColor | m_clrBarText
An RGB value representing the hilite text color.

Detailed Description

The CXTPProgressCtrlThemeVisualStudio2019 class is derived from CXTPProgressCtrlThemeOffice2013 and is used by the progress bar to draw a Visual Studio 2019 style progress bar.

Constructor & Destructor Documentation

◆ CXTPProgressCtrlThemeVisualStudio2019()

CXTPProgressCtrlThemeVisualStudio2019 ( )

Default paint manager constructor.

Handles initial initialization.

See also
RefreshMetrics()
The documentation for this class was generated from the following file:
  • XTPProgressCtrlPaintManager.h


Toolkit Pro: CXTPProgressCtrlThemeVisualStudio2022 Class Reference

Public Member Functions | List of all members
CXTPProgressCtrlThemeVisualStudio2022 Class Reference

The CXTPProgressCtrlThemeVisualStudio2022 class is derived from CXTPProgressCtrlThemeOffice2013 and is used by the progress bar to draw a Visual Studio 2022 style progress bar. More...

Inheritance diagram for CXTPProgressCtrlThemeVisualStudio2022:
[legend]

Public Member Functions

CXTPProgressCtrlThemeVisualStudio2022 ()
Default paint manager constructor.
- Public Member Functions inherited from CXTPProgressCtrlThemeOffice2013
CXTPProgressCtrlThemeOffice2013 ()
Default paint manager constructor.
virtual void | RefreshMetrics ()
This member function performs initialization for the Paint Manager.
virtual void | DrawNcBorders (CDC *pDC, CRect rc)
This member function is called by the progress bar to draw the non-client borders.
virtual void | Draw (XTPPROGRESSDRAWSTRUCT &ds)
This member function is called by the progress bar to draw the client area of the control.
- Public Member Functions inherited from CXTPProgressCtrlThemeOffice2000
CXTPProgressCtrlThemeOffice2000 ()
Default paint manager constructor.
- Public Member Functions inherited from CXTPProgressCtrlPaintManager
CXTPProgressCtrlPaintManager ()
Default paint manager constructor.
virtual | ~CXTPProgressCtrlPaintManager ()
Default paint manager destructor.
COLORREF | SetBorderColor (COLORREF clrNew)
This member function sets the border color for the progress bar.
COLORREF | SetBarColor (COLORREF clrNew)
This member function sets the bar color for the progress bar.
COLORREF | SetBackColor (COLORREF clrNew)
This member function sets the background color for the progress bar.
COLORREF | SetTextColor (COLORREF clrNew)
This member function sets the text color for the progress bar.
COLORREF | GetBorderColor ()
This member function gets the border color for the progress bar.
COLORREF | GetBarColor ()
This member function gets the bar color for the progress bar.
COLORREF | GetBackColor ()
This member function gets the background color for the progress bar.
COLORREF | GetTextColor ()
This member function gets the text color for the progress bar.
virtual void | DrawText (XTPPROGRESSDRAWSTRUCT &ds)
This member function is called by the progress bar to draw the progress text for the control.
BOOL | UsingWinThemes (BOOL bCheckReady=FALSE)
Used by the progress bar to determine if Windows themes should be used to draw the control.
void | UseWinThemes (BOOL bUseWinThemes=TRUE)
Call this member function to draw the control using the current Windows theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Member Functions inherited from CXTPProgressCtrlPaintManager
virtual void | DeflateRect (XTPPROGRESSDRAWSTRUCT &ds)
This member function is called by the progress bar to adjust the bar drawing size; can be overridden in derived classes.
- Protected Attributes inherited from CXTPProgressCtrlPaintManager
BOOL | m_bUseWinTheme
TRUE when using Windows themes.
XTPControlTheme | m_nTheme
Theme identifier.
CXTPWinThemeWrapper | m_winTheme
Wrapper used when drawing Windows themes.
CXTPPaintManagerColor | m_clrBorder
An RGB value representing the border color.
CXTPPaintManagerColor | m_clrBar
An RGB value representing the bar color.
CXTPPaintManagerColor | m_clrBack
An RGB value representing the back color.
CXTPPaintManagerColor | m_clrText
An RGB value representing the text color.
CXTPPaintManagerColor | m_clrBarText
An RGB value representing the hilite text color.

Detailed Description

The CXTPProgressCtrlThemeVisualStudio2022 class is derived from CXTPProgressCtrlThemeOffice2013 and is used by the progress bar to draw a Visual Studio 2022 style progress bar.

Constructor & Destructor Documentation

◆ CXTPProgressCtrlThemeVisualStudio2022()

CXTPProgressCtrlThemeVisualStudio2022 ( )

Default paint manager constructor.

Handles initial initialization.

See also
RefreshMetrics()
The documentation for this class was generated from the following file:
  • XTPProgressCtrlPaintManager.h


Toolkit Pro: CXTPProgressPaintManager Class Reference

Public Member Functions | Public Attributes | Protected Attributes | List of all members
CXTPProgressPaintManager Class Reference

CXTPProgressPaintManager object. More...

Inheritance diagram for CXTPProgressPaintManager:
[legend]

Public Member Functions

CXTPProgressPaintManager (CXTPPaintManager *pPaintManager)
Constructs a CXTPProgressPaintManager object.
virtual | ~CXTPProgressPaintManager ()
Destroys a CXTPProgressPaintManager object, handles cleanup and deallocation.
virtual void | DrawProgress (CDC *pDC, CXTPProgressBase *pProgressBar)
This method is called to draw progress.
virtual void | RefreshMetrics ()
Recalculates metrics.
CXTPPaintManager * | GetPaintManager () const
Gets the parent paint manager object.

Public Attributes

int m_cyProgress
Progress height.

Protected Attributes

CXTPPaintManager * m_pPaintManager
Pointer to parent PaintManager.

Detailed Description

CXTPProgressPaintManager object.

Constructor & Destructor Documentation

◆ CXTPProgressPaintManager()

CXTPProgressPaintManager ( CXTPPaintManager * pPaintManager )

Constructs a CXTPProgressPaintManager object.

Parameters
pPaintManager PaintManager of command bars.

Member Function Documentation

◆ DrawProgress()

virtual void DrawProgress | ( | CDC * | pDC,
 |  | CXTPProgressBase * | pProgressBar )
 virtual

This method is called to draw progress.

Parameters
pDC | Pointer to device context.
pProgressBar | Progress to draw.

Reimplemented in CXTPProgressThemeOffice2013.

◆ GetPaintManager()

AFX_INLINE CXTPPaintManager * GetPaintManager ( ) const

Gets the parent paint manager object.

Returns
A pointer to the parent paint manager object.
The documentation for this class was generated from the following file:
  • XTPProgressPaintManager.h


Toolkit Pro: CXTPProgressThemeNativeWindows10 Class Reference

Public Member Functions | List of all members
CXTPProgressThemeNativeWindows10 Class Reference

CXTPProgressThemeNativeWindows10 object. More...

Inheritance diagram for CXTPProgressThemeNativeWindows10:
[legend]

Public Member Functions

CXTPProgressThemeNativeWindows10 (CXTPPaintManager *pPaintManager)
Constructs a CXTPProgressThemeNativeWindows10 object.
virtual | ~CXTPProgressThemeNativeWindows10 ()
Destroys a CXTPProgressThemeNativeWindows10 object, handles cleanup and deallocation.
- Public Member Functions inherited from CXTPProgressThemeOffice2013
CXTPProgressThemeOffice2013 (CXTPPaintManager *pPaintManager)
Constructs a CXTPProgressThemeOffice2013 object.
virtual | ~CXTPProgressThemeOffice2013 ()
Destroys a CXTPProgressThemeOffice2013 object, handles cleanup and deallocation.
virtual void | DrawProgress (CDC *pDC, CXTPProgressBase *pProgressBar)
This method is called to draw progress.
virtual void | RefreshMetrics ()
Recalculates metrics.
- Public Member Functions inherited from CXTPProgressPaintManager
CXTPProgressPaintManager (CXTPPaintManager *pPaintManager)
Constructs a CXTPProgressPaintManager object.
virtual | ~CXTPProgressPaintManager ()
Destroys a CXTPProgressPaintManager object, handles cleanup and deallocation.
CXTPPaintManager * | GetPaintManager () const
Gets the parent paint manager object.

Additional Inherited Members

- Public Attributes inherited from CXTPProgressPaintManager
int | m_cyProgress
Progress height.
- Protected Attributes inherited from CXTPProgressThemeOffice2013
CXTPPaintManagerColor | m_clrBorder
RGB value representing border color.
CXTPPaintManagerColor | m_clrBar
RGB value representing bar color.
CXTPPaintManagerColor | m_clrBack
RGB value representing back color.
- Protected Attributes inherited from CXTPProgressPaintManager
CXTPPaintManager * | m_pPaintManager
Pointer to parent PaintManager.

Detailed Description

CXTPProgressThemeNativeWindows10 object.

Constructor & Destructor Documentation

◆ CXTPProgressThemeNativeWindows10()

CXTPProgressThemeNativeWindows10 ( CXTPPaintManager * pPaintManager )

Constructs a CXTPProgressThemeNativeWindows10 object.

Parameters
pPaintManager PaintManager of commandbars.
The documentation for this class was generated from the following file:
  • XTPProgressThemeNativeWindows10.h


Toolkit Pro: CXTPProgressThemeNativeWindows11 Class Reference

Public Member Functions | List of all members
CXTPProgressThemeNativeWindows11 Class Reference

CXTPProgressThemeNativeWindows11 object. More...

Inheritance diagram for CXTPProgressThemeNativeWindows11:
[legend]

Public Member Functions

CXTPProgressThemeNativeWindows11 (CXTPPaintManager *pPaintManager)
Constructs a CXTPProgressThemeNativeWindows11 object.
virtual | ~CXTPProgressThemeNativeWindows11 ()
Destroys a CXTPProgressThemeNativeWindows11 object, handles cleanup and deallocation.
- Public Member Functions inherited from CXTPProgressThemeOffice2013
CXTPProgressThemeOffice2013 (CXTPPaintManager *pPaintManager)
Constructs a CXTPProgressThemeOffice2013 object.
virtual | ~CXTPProgressThemeOffice2013 ()
Destroys a CXTPProgressThemeOffice2013 object, handles cleanup and deallocation.
virtual void | DrawProgress (CDC *pDC, CXTPProgressBase *pProgressBar)
This method is called to draw progress.
virtual void | RefreshMetrics ()
Recalculates metrics.
- Public Member Functions inherited from CXTPProgressPaintManager
CXTPProgressPaintManager (CXTPPaintManager *pPaintManager)
Constructs a CXTPProgressPaintManager object.
virtual | ~CXTPProgressPaintManager ()
Destroys a CXTPProgressPaintManager object, handles cleanup and deallocation.
CXTPPaintManager * | GetPaintManager () const
Gets the parent paint manager object.

Additional Inherited Members

- Public Attributes inherited from CXTPProgressPaintManager
int | m_cyProgress
Progress height.
- Protected Attributes inherited from CXTPProgressThemeOffice2013
CXTPPaintManagerColor | m_clrBorder
RGB value representing border color.
CXTPPaintManagerColor | m_clrBar
RGB value representing bar color.
CXTPPaintManagerColor | m_clrBack
RGB value representing back color.
- Protected Attributes inherited from CXTPProgressPaintManager
CXTPPaintManager * | m_pPaintManager
Pointer to parent PaintManager.

Detailed Description

CXTPProgressThemeNativeWindows11 object.

Constructor & Destructor Documentation

◆ CXTPProgressThemeNativeWindows11()

CXTPProgressThemeNativeWindows11 ( CXTPPaintManager * pPaintManager )

Constructs a CXTPProgressThemeNativeWindows11 object.

Parameters
pPaintManager PaintManager of commandbars.
The documentation for this class was generated from the following file:
  • XTPProgressThemeNativeWindows11.h


Toolkit Pro: CXTPProgressThemeOffice2013 Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPProgressThemeOffice2013 Class Reference

CXTPProgressThemeOffice2013 object. More...

Inheritance diagram for CXTPProgressThemeOffice2013:
[legend]

Public Member Functions

CXTPProgressThemeOffice2013 (CXTPPaintManager *pPaintManager)
Constructs a CXTPProgressThemeOffice2013 object.
virtual | ~CXTPProgressThemeOffice2013 ()
Destroys a CXTPProgressThemeOffice2013 object, handles cleanup and deallocation.
virtual void | DrawProgress (CDC *pDC, CXTPProgressBase *pProgressBar)
This method is called to draw progress.
virtual void | RefreshMetrics ()
Recalculates metrics.
- Public Member Functions inherited from CXTPProgressPaintManager
CXTPProgressPaintManager (CXTPPaintManager *pPaintManager)
Constructs a CXTPProgressPaintManager object.
virtual | ~CXTPProgressPaintManager ()
Destroys a CXTPProgressPaintManager object, handles cleanup and deallocation.
CXTPPaintManager * | GetPaintManager () const
Gets the parent paint manager object.

Protected Attributes

CXTPPaintManagerColor | m_clrBorder
RGB value representing border color.
CXTPPaintManagerColor | m_clrBar
RGB value representing bar color.
CXTPPaintManagerColor | m_clrBack
RGB value representing back color.
- Protected Attributes inherited from CXTPProgressPaintManager
CXTPPaintManager * | m_pPaintManager
Pointer to parent PaintManager.

Additional Inherited Members

- Public Attributes inherited from CXTPProgressPaintManager
int m_cyProgress
Progress height.

Detailed Description

CXTPProgressThemeOffice2013 object.

Constructor & Destructor Documentation

◆ CXTPProgressThemeOffice2013()

CXTPProgressThemeOffice2013 ( CXTPPaintManager * pPaintManager )

Constructs a CXTPProgressThemeOffice2013 object.

Parameters
pPaintManager PaintManager of commandbars.

Member Function Documentation

◆ DrawProgress()

virtual void DrawProgress | ( | CDC * | pDC,
 |  | CXTPProgressBase * | pProgressBar )
 virtual

This method is called to draw progress.

Parameters
pDC | Pointer to device context.
pProgressBar | Progress to draw.

Reimplemented from CXTPProgressPaintManager.

The documentation for this class was generated from the following file:
  • XTPProgressThemeOffice2013.h


Toolkit Pro: CXTPProgressThemeVisualStudio2015 Class Reference

Public Member Functions | List of all members
CXTPProgressThemeVisualStudio2015 Class Reference

CXTPProgressThemeVisualStudio2015 object. More...

Inheritance diagram for CXTPProgressThemeVisualStudio2015:
[legend]

Public Member Functions

CXTPProgressThemeVisualStudio2015 (CXTPPaintManager *pPaintManager)
Constructs a CXTPProgressThemeVisualStudio2015 object.
virtual | ~CXTPProgressThemeVisualStudio2015 ()
Destroys a CXTPProgressThemeVisualStudio2015 object, handles cleanup and deallocation.
- Public Member Functions inherited from CXTPProgressThemeOffice2013
CXTPProgressThemeOffice2013 (CXTPPaintManager *pPaintManager)
Constructs a CXTPProgressThemeOffice2013 object.
virtual | ~CXTPProgressThemeOffice2013 ()
Destroys a CXTPProgressThemeOffice2013 object, handles cleanup and deallocation.
virtual void | DrawProgress (CDC *pDC, CXTPProgressBase *pProgressBar)
This method is called to draw progress.
virtual void | RefreshMetrics ()
Recalculates metrics.
- Public Member Functions inherited from CXTPProgressPaintManager
CXTPProgressPaintManager (CXTPPaintManager *pPaintManager)
Constructs a CXTPProgressPaintManager object.
virtual | ~CXTPProgressPaintManager ()
Destroys a CXTPProgressPaintManager object, handles cleanup and deallocation.
CXTPPaintManager * | GetPaintManager () const
Gets the parent paint manager object.

Additional Inherited Members

- Public Attributes inherited from CXTPProgressPaintManager
int | m_cyProgress
Progress height.
- Protected Attributes inherited from CXTPProgressThemeOffice2013
CXTPPaintManagerColor | m_clrBorder
RGB value representing border color.
CXTPPaintManagerColor | m_clrBar
RGB value representing bar color.
CXTPPaintManagerColor | m_clrBack
RGB value representing back color.
- Protected Attributes inherited from CXTPProgressPaintManager
CXTPPaintManager * | m_pPaintManager
Pointer to parent PaintManager.

Detailed Description

CXTPProgressThemeVisualStudio2015 object.

Constructor & Destructor Documentation

◆ CXTPProgressThemeVisualStudio2015()

CXTPProgressThemeVisualStudio2015 ( CXTPPaintManager * pPaintManager )

Constructs a CXTPProgressThemeVisualStudio2015 object.

Parameters
pPaintManager PaintManager of commandbars.
The documentation for this class was generated from the following file:
  • XTPProgressThemeVisualStudio2015.h


Toolkit Pro: CXTPProgressThemeVisualStudio2017 Class Reference

Public Member Functions | List of all members
CXTPProgressThemeVisualStudio2017 Class Reference

CXTPProgressThemeVisualStudio2017 object. More...

Inheritance diagram for CXTPProgressThemeVisualStudio2017:
[legend]

Public Member Functions

CXTPProgressThemeVisualStudio2017 (CXTPPaintManager *pPaintManager)
Constructs a CXTPProgressThemeVisualStudio2017 object.
virtual | ~CXTPProgressThemeVisualStudio2017 ()
Destroys a CXTPProgressThemeVisualStudio2017 object, handles cleanup and deallocation.
- Public Member Functions inherited from CXTPProgressThemeOffice2013
CXTPProgressThemeOffice2013 (CXTPPaintManager *pPaintManager)
Constructs a CXTPProgressThemeOffice2013 object.
virtual | ~CXTPProgressThemeOffice2013 ()
Destroys a CXTPProgressThemeOffice2013 object, handles cleanup and deallocation.
virtual void | DrawProgress (CDC *pDC, CXTPProgressBase *pProgressBar)
This method is called to draw progress.
virtual void | RefreshMetrics ()
Recalculates metrics.
- Public Member Functions inherited from CXTPProgressPaintManager
CXTPProgressPaintManager (CXTPPaintManager *pPaintManager)
Constructs a CXTPProgressPaintManager object.
virtual | ~CXTPProgressPaintManager ()
Destroys a CXTPProgressPaintManager object, handles cleanup and deallocation.
CXTPPaintManager * | GetPaintManager () const
Gets the parent paint manager object.

Additional Inherited Members

- Public Attributes inherited from CXTPProgressPaintManager
int | m_cyProgress
Progress height.
- Protected Attributes inherited from CXTPProgressThemeOffice2013
CXTPPaintManagerColor | m_clrBorder
RGB value representing border color.
CXTPPaintManagerColor | m_clrBar
RGB value representing bar color.
CXTPPaintManagerColor | m_clrBack
RGB value representing back color.
- Protected Attributes inherited from CXTPProgressPaintManager
CXTPPaintManager * | m_pPaintManager
Pointer to parent PaintManager.

Detailed Description

CXTPProgressThemeVisualStudio2017 object.

Constructor & Destructor Documentation

◆ CXTPProgressThemeVisualStudio2017()

CXTPProgressThemeVisualStudio2017 ( CXTPPaintManager * pPaintManager )

Constructs a CXTPProgressThemeVisualStudio2017 object.

Parameters
pPaintManager PaintManager of commandbars.
The documentation for this class was generated from the following file:
  • XTPProgressThemeVisualStudio2017.h


Toolkit Pro: CXTPProgressThemeVisualStudio2019 Class Reference

Public Member Functions | List of all members
CXTPProgressThemeVisualStudio2019 Class Reference

CXTPProgressThemeVisualStudio2019 object. More...

Inheritance diagram for CXTPProgressThemeVisualStudio2019:
[legend]

Public Member Functions

CXTPProgressThemeVisualStudio2019 (CXTPPaintManager *pPaintManager)
Constructs a CXTPProgressThemeVisualStudio2019 object.
virtual | ~CXTPProgressThemeVisualStudio2019 ()
Destroys a CXTPProgressThemeVisualStudio2019 object, handles cleanup and deallocation.
- Public Member Functions inherited from CXTPProgressThemeOffice2013
CXTPProgressThemeOffice2013 (CXTPPaintManager *pPaintManager)
Constructs a CXTPProgressThemeOffice2013 object.
virtual | ~CXTPProgressThemeOffice2013 ()
Destroys a CXTPProgressThemeOffice2013 object, handles cleanup and deallocation.
virtual void | DrawProgress (CDC *pDC, CXTPProgressBase *pProgressBar)
This method is called to draw progress.
virtual void | RefreshMetrics ()
Recalculates metrics.
- Public Member Functions inherited from CXTPProgressPaintManager
CXTPProgressPaintManager (CXTPPaintManager *pPaintManager)
Constructs a CXTPProgressPaintManager object.
virtual | ~CXTPProgressPaintManager ()
Destroys a CXTPProgressPaintManager object, handles cleanup and deallocation.
CXTPPaintManager * | GetPaintManager () const
Gets the parent paint manager object.

Additional Inherited Members

- Public Attributes inherited from CXTPProgressPaintManager
int | m_cyProgress
Progress height.
- Protected Attributes inherited from CXTPProgressThemeOffice2013
CXTPPaintManagerColor | m_clrBorder
RGB value representing border color.
CXTPPaintManagerColor | m_clrBar
RGB value representing bar color.
CXTPPaintManagerColor | m_clrBack
RGB value representing back color.
- Protected Attributes inherited from CXTPProgressPaintManager
CXTPPaintManager * | m_pPaintManager
Pointer to parent PaintManager.

Detailed Description

CXTPProgressThemeVisualStudio2019 object.

Constructor & Destructor Documentation

◆ CXTPProgressThemeVisualStudio2019()

CXTPProgressThemeVisualStudio2019 ( CXTPPaintManager * pPaintManager )

Constructs a CXTPProgressThemeVisualStudio2019 object.

Parameters
pPaintManager PaintManager of commandbars.
The documentation for this class was generated from the following file:
  • XTPProgressThemeVisualStudio2019.h


Toolkit Pro: CXTPProgressThemeVisualStudio2022 Class Reference

Public Member Functions | List of all members
CXTPProgressThemeVisualStudio2022 Class Reference

CXTPProgressThemeVisualStudio2022 object. More...

Inheritance diagram for CXTPProgressThemeVisualStudio2022:
[legend]

Public Member Functions

CXTPProgressThemeVisualStudio2022 (CXTPPaintManager *pPaintManager)
Constructs a CXTPProgressThemeVisualStudio2022 object.
virtual | ~CXTPProgressThemeVisualStudio2022 ()
Destroys a CXTPProgressThemeVisualStudio2022 object, handles cleanup and deallocation.
- Public Member Functions inherited from CXTPProgressThemeOffice2013
CXTPProgressThemeOffice2013 (CXTPPaintManager *pPaintManager)
Constructs a CXTPProgressThemeOffice2013 object.
virtual | ~CXTPProgressThemeOffice2013 ()
Destroys a CXTPProgressThemeOffice2013 object, handles cleanup and deallocation.
virtual void | DrawProgress (CDC *pDC, CXTPProgressBase *pProgressBar)
This method is called to draw progress.
virtual void | RefreshMetrics ()
Recalculates metrics.
- Public Member Functions inherited from CXTPProgressPaintManager
CXTPProgressPaintManager (CXTPPaintManager *pPaintManager)
Constructs a CXTPProgressPaintManager object.
virtual | ~CXTPProgressPaintManager ()
Destroys a CXTPProgressPaintManager object, handles cleanup and deallocation.
CXTPPaintManager * | GetPaintManager () const
Gets the parent paint manager object.

Additional Inherited Members

- Public Attributes inherited from CXTPProgressPaintManager
int | m_cyProgress
Progress height.
- Protected Attributes inherited from CXTPProgressThemeOffice2013
CXTPPaintManagerColor | m_clrBorder
RGB value representing border color.
CXTPPaintManagerColor | m_clrBar
RGB value representing bar color.
CXTPPaintManagerColor | m_clrBack
RGB value representing back color.
- Protected Attributes inherited from CXTPProgressPaintManager
CXTPPaintManager * | m_pPaintManager
Pointer to parent PaintManager.

Detailed Description

CXTPProgressThemeVisualStudio2022 object.

Constructor & Destructor Documentation

◆ CXTPProgressThemeVisualStudio2022()

CXTPProgressThemeVisualStudio2022 ( CXTPPaintManager * pPaintManager )

Constructs a CXTPProgressThemeVisualStudio2022 object.

Parameters
pPaintManager PaintManager of commandbars.
The documentation for this class was generated from the following file:
  • XTPProgressThemeVisualStudio2022.h


Toolkit Pro: CXTPPropertyGrid Class Reference

Public Member Functions | Public Attributes | Protected Member Functions | Protected Attributes | List of all members
CXTPPropertyGrid Class Reference

CXTPPropertyGrid is a CWnd derived class. More...

Public Member Functions

CXTPPropertyGrid ()
Constructs a CXTPPropertyGrid object.
virtual | ~CXTPPropertyGrid ()
Destroys a CXTPPropertyGrid object, handles cleanup and deallocation.
virtual BOOL | Create (const RECT &rect, CWnd *pParentWnd, UINT nID, DWORD dwListStyle=0)
Creates the property grid control.
CXTPPropertyGridItem * | AddCategory (LPCTSTR lpszCaption, CXTPPropertyGridItem *pCategory=NULL)
Adds a new category to the property grid control.
CXTPPropertyGridItem * | AddCategory (int nID, CXTPPropertyGridItem *pCategory=NULL)
Adds a new category to the property grid control.
CXTPPropertyGridItem * | InsertCategory (int nIndex, LPCTSTR lpszCaption, CXTPPropertyGridItem *pCategory=NULL)
Inserts a new category to the property grid control.
CXTPPropertyGridItem * | InsertCategory (int nIndex, int nID, CXTPPropertyGridItem *pCategory=NULL)
Inserts a new category to the property grid control.
void | SetPropertySort (XTPPropertyGridSortOrder sort)
Sets the grouping style for the property grid control.
XTPPropertyGridSortOrder | GetPropertySort () const
Gets the grouping style of the property grid control.
void | ShowToolBar (BOOL bShow=TRUE)
Shows/hides the toolbar control in the property grid window.
void | ShowHelp (BOOL bShow=TRUE)
Shows/hides the description pane in the property grid window.
void | ShowView (BOOL bShow=TRUE)
Shows/hides the view pane.
void | EnableToolTips (BOOL bEnable=TRUE)
Enables/disables tooltips under items.
void | SetCustomColors (COLORREF clrHelpBack, COLORREF clrHelpFore, COLORREF clrViewLine, COLORREF clrViewBack, COLORREF clrViewFore, COLORREF clrCategoryFore=::GetSysColor(COLOR_GRAYTEXT))
Sets the custom colors for the property grid control.
void | SetStandardColors ()
Sets the default colors for the property grid control.
CXTPPropertyGridItem * | FindItem (LPCTSTR strCaption) const
Retrieves an item by its caption/identifier.
CXTPPropertyGridItem * | FindItem (UINT nID) const
Retrieves an item by its caption/identifier.
void | ResetContent ()
Removes all items from the list box of the property grid control.
BOOL | IsHelpVisible () const
Determines the visible state of the help pane.
BOOL | IsBarVisible () const
Determines the visible state of the toolbar.
int | GetHelpHeight () const
Gets the height of the help pane when it is visible.
COLORREF | GetHelpBackColor () const
Gets the background color of the help pane.
COLORREF | GetHelpForeColor () const
Gets the foreground color of the help pane.
CXTPPropertyGridItems * | GetCategories () const
Gets the collection of categories of the property grid.
CXTPPropertyGridVerbs * | GetVerbs () const
Gets the collection of verbs displayed in the verb panel.
CXTPPropertyGridView & | GetGridView () const
Gets the view of the property grid.
CToolBar & | GetToolBar ()
Gets the toolbar of the property grid.
CXTPPropertyGridItem * | GetSelectedItem () const
Gets the currently selected item.
CXTPPropertyGridItem * | GetItem (int nIndex) const
Retrieves the item at a specified index in the list.
void | SetHelpHeight (int nHeight)
Sets the height for the help pane when it is visible.
void | SetViewDivider (double dDivider)
Sets the divider position for the grid view.
void | SetViewDividerPos (int nDivider, BOOL bLockDivider=FALSE)
Sets the divider position for the grid view.
double | GetViewDivider () const
Gets the divider position of the grid view.
void | SetFont (CFont *pFont)
Sets the font of the property grid.
void | SetTheme (XTPPropertyGridPaintTheme paintTheme)
Sets the theme for the property grid.
void | SetCustomTheme (CXTPPropertyGridPaintManager *pPaintManager)
Sets a custom theme for the property grid.
XTPPropertyGridPaintTheme | GetCurrentTheme () const
Gets the theme of the property grid.
void | Refresh ()
Refreshes the items in the list.
void | BeginUpdate (CXTPPropertyGridUpdateContext &context, BOOL bResetContent=TRUE)
"Locks" the property grid.
void | EndUpdate (CXTPPropertyGridUpdateContext &context)
"Unlocks" the property grid.
BOOL | IsVerbsVisible () const
Determines the visible state of the verb panel.
CXTPPropertyGridPaintManager * | GetPaintManager () const
Gets the paint manager associated with the property grid (i.e.
virtual CXTPPropertyGridView * | CreateView () const
Creates a property grid view.
virtual void | OnVerbClick (int nIndex, CPoint pt)
This method is called either when a user clicks on a verb or when a verb has focus and the Enter/Return key is pressed.
virtual void | OnNavigate (XTPPropertyGridUI nUIElement, BOOL bForward, CXTPPropertyGridItem *pItem)
This method is called when items in the property grid are navigated by using keys on the keyboard.
void | NavigateItems (BOOL bTabItems, BOOL bTabCaptions=TRUE)
Enables/disables item navigation by using the Tab key.
void | SetShowInplaceButtonsAlways (BOOL bShow)
Specifies if in-place buttons should always be shown.
BOOL | GetShowInplaceButtonsAlways () const
Determines if in-place buttons are always shown.
void | SetVerbsHeight (int nHeight)
Sets the height of the verb vox when it is visible.
int | GetVerbsHeight () const
Gets the height of the verb box when it is visible.
BOOL | IsHighlightChangedItems () const
Determines if changed item highlighting is enabled/disabled.
void | HighlightChangedItems (BOOL bHighlightChanged)
Enables/disables changed item highlighting.
BOOL | IsHighlightChangedButtonItems () const
Determines if highlighting is enabled/disabled for in-place button text when the item value is changed.
void | HighlightChangedButtonItems (BOOL bHighlightChanged)
Enables/disables highlighting for in-place button text when the item value is changed.
void | RedrawControl ()
Redraws the control.
CXTPImageManager * | GetImageManager () const
Gets the image manager associated with the property grid (i.e.
void | SetImageManager (CXTPImageManager *pImageManager)
Sets the image manager associated with the property grid (i.e.
void | SetVariableItemsHeight (BOOL bVariable=TRUE)
Specifies if variable items height should be allowed.
void | SetInplaceEdit (CXTPPropertyGridInplaceEdit *pInplaceEdit)
Sets the in-place edit control.
void | SetInplaceList (CXTPPropertyGridInplaceList *pInplaceList)
Sets the in-place list box control.
virtual LRESULT | SendNotifyMessage (WPARAM wParam=0, LPARAM lParam=0)
Sends a specified message to the owner window.
int | GetTopIndex () const
Gets the zero-based index of the first visible item (i.e.
void | SetTopIndex (int nIndex)
Sets the zero-based index for the first visible item (i.e.
int | GetCount () const
Gets the number of items in the property grid.
BOOL | RegisterWindowClass (HINSTANCE hInstance=NULL)
Registers the window class if it has not already been registered.
void | SetVariableSplitterPos (BOOL bVariable)
Specifies if the user can resize the property grid splitter.
BOOL | GetVariableSplitterPos () const
Determines if the user can resize the property grid splitter.
void | SetVariableHelpHeight (BOOL bVariable)
Specifies if the user can resize the help box with the mouse.
BOOL | GetVariableHelpHeight () const
Determines if the user can resize the help box with the mouse.
void | SetBorderStyle (XTPPropertyGridBorderStyle borderStyle)
Sets the border style for the property grid.
XTPPropertyGridBorderStyle | GetBorderStyle () const
Gets the border style of the property grid.
CXTPToolTipContext * | GetToolTipContext () const
Gets the tooltip context.
void | EnableMultiSelect (BOOL bMultiSelect=TRUE)
Enables/disables multi-select mode.
int | GetSelectedItems (CArray< int, int > *pItems) const
Gets the number of selected items if multi-select mode is enabled.
BOOL | IsLayoutRTL () const
Determines if right-to-left (RTL) mode is set.
void | SetLayoutRTL (BOOL bRightToLeft)
Specifies if right-to-left (RTL) mode should be set.
void | Reposition ()
Repositions the view and help pane inside the property grid.
void | AllowEdit (BOOL bAllowEdit)
Enables/disables edit operations for the property grid.
void | EnableMarkup (BOOL bEnable=TRUE)
Enables/disables markup for the property grid.
CXTPMarkupContext * | GetMarkupContext () const
Gets the Markup context.

Public Attributes

BOOL m_bHideSelection
TRUE to hide the selection when the control does not have focus.

Protected Member Functions

void | OnInvertTracker (CRect rc)
This method is called by the framework during the resizing of splitters.
virtual int | HitTest (CPoint pt)
Determines if the help splitter, the verb splitter, or a verb was clicked.
virtual void | OnSelectionChanged (CXTPPropertyGridItem *pItem)
This method is called either when a new item is selected in the property grid or when focus is switched from one item to another.
virtual void | OnSortChanged ()
This method is called when the sort order is changed.
virtual void | Reposition (int cx, int cy)
Recalculates both the position and size of the property grid and then resizes the property grid to a specified size.
virtual void | CreateToolbar ()
This method is called when the "built-in" toolbar is created.
void | RefreshToolBarButtons ()
This method is called when the toolbar buttons must be redrawn.
void | OnVerbsChanged ()
This method is called either when a verb receives focus or when focus is switched from one verb to another.
BOOL | CreateGridView (DWORD dwListStyle)
Creates the property grid window.
void | RefeshBindings (CXTPPropertyGridItem *pItem=NULL)
Call this method to refresh all binding in pItem tree.

Protected Attributes

BOOL | m_bHelpVisible
TRUE if the help panel is visible.
BOOL | m_bViewVisible
TRUE if the view panel is visible.
BOOL | m_bEnableTooltips
TRUE if tooltips are enabled.
BOOL | m_bVariableHelpHeight
TRUE to allow the user to resize the help pane.
BOOL | m_bToolBarVisible
TRUE if the built in toolbar is visible.
CXTPPropertyGridToolBar | m_wndToolbar
"built-in" property grid toolbar.
HCURSOR | m_hCursorSplit
Handle to the cursor when positioned over a splitter.
HCURSOR | m_hCursorHand
Handle of the cursor.
BOOL | m_bTabItems
TRUE to navigate items with the tab key.
BOOL | m_bTabCaptions
TRUE to navigate captions with the tab key.
CXTPPropertyGridVerbs * | m_pVerbs
Collection of verbs (links) displayed in the verb panel when the panel is visible.
BOOL | m_bVerbsVisible
TRUE if the verb panel is visible.
XTPPropertyGridPaintTheme | m_themeCurrent
Current theme.
CXTPPropertyGridPaintManager * | m_pPaintManager
Current paint manager.
int | m_nFocusedVerb
Index of the currently focused verb within the collection of verbs.
CXTPPropertyGridView * | m_pView
View pointer.
BOOL | m_bHighlightChanged
TRUE to highlight changed values.
BOOL | m_bHighlightChangedButton
TRUE to highlight changed in-place button value text.
CXTPImageManager * | m_pImageManager
Image manager of the property grid.
BOOL | m_bVariableItemsHeight
TRUE to allow variable items height.
BOOL | m_bPreSubclassWindow
'true' when initialized from PreSubclassWindow.
CXTPPropertyGridInplaceEdit * | m_pInplaceEdit
In-place edit control.
CXTPPropertyGridInplaceList * | m_pInplaceListBox
In-place list box control.
BOOL | m_bShowInplaceButtonsAlways
TRUE to show all in-place buttons.
CXTPToolTipContext * | m_pToolTipContext
Tooltip context.
BOOL | m_bMultiSelect
TRUE for multi-select.
CXTPMarkupContext * | m_pMarkupContext
Markup context of the property grid.
BOOL | m_bAllowEdit
FALSE to prevent all edit operations.

Detailed Description

CXTPPropertyGrid is a CWnd derived class.

It is used to create a property grid control similar to the property window in VS.NET. See the "PropertyGrid" demo for an example of its usage.

Member Function Documentation

◆ AddCategory() [1/2]

CXTPPropertyGridItem * AddCategory | ( | int | nID,
 |  | CXTPPropertyGridItem * | pCategory = NULL )

Adds a new category to the property grid control.

Parameters
nID | Identifier of the new category.
pCategory | Allows for custom classses to be categories. If it is NULL, then the property grid creates a default CXTPPropertyGridItem as a category. If it is not NULL, then the specified item will be used.
Returns
A pointer to the CXTPPropertyGridItem object of the newly added category.

◆ AddCategory() [2/2]

CXTPPropertyGridItem * AddCategory | ( | LPCTSTR | lpszCaption,
 |  | CXTPPropertyGridItem * | pCategory = NULL )

Adds a new category to the property grid control.

Parameters
lpszCaption | Name of the category to be added.
pCategory | Allows for custom classses to be categories. If it is NULL, then the property grid creates a default CXTPPropertyGridItem as a category. If it is not NULL, then the specified item will be used.
Returns
A pointer to the CXTPPropertyGridItem object of the newly added category.

◆ AllowEdit()

void AllowEdit ( BOOL bAllowEdit )

Enables/disables edit operations for the property grid.

Parameters
bAllowEdit TRUE to enable edit opertations for the property grid, FALSE to disable edit operations for the property grid.

◆ BeginUpdate()

void BeginUpdate | ( | CXTPPropertyGridUpdateContext & | context,
 |  | BOOL | bResetContent = TRUE )

"Locks" the property grid.

This method should be called when adding or deleting a large number of items.

Parameters
context | Reference to a CXTPPropertyGridUpdateContext object.
bResetContent | TRUE to delete all items.

Each time you add a new item or category to the grid, the state of the grid is updated and the grid is redrawn.

If you want to delete all items in the grid and then add a lot of new items, then it will be quite slow. To do this, you would call BeginUpdate, then delete all the items. The property grid will be locked until you call EndUpdate.

It might be useful to call BeginWaitCursor to indicate that the grid is "busy" updating.

See also
EndUpdate, CXTPPropertyGridUpdateContext

◆ Create()

virtual BOOL Create | ( | const RECT & | rect,
 |  | CWnd * | pParentWnd,
 |  | UINT | nID,
 |  | DWORD | dwListStyle = 0 )
 virtual

Creates the property grid control.

Parameters
rect | Reference to the size of the control.
pParentWnd | Pointer to the parent of the control.
nID | Identifier of the property grid control.
dwListStyle | List style of the items in the property grid.

Available styles are listed below: LBS_OWNERDRAWFIXED: The owner of the grid is responsible for drawing its contents; the items in the list box are the same height. Should be used with LBS_NOINTEGRALHEIGHT. LBS_OWNERDRAWVARIABLE: The owner of the grid is responsible for drawing its contents; the items in the grid are variable in height. Should be used with LBS_NOINTEGRALHEIGHT. XTP_PGS_OWNERDRAW: Apply this style to the property grid to use the owner draw feature. Catch XTP_PGN_DRAWITEM to draw an item. Recommended to use a custom paint manager instead (SetCustomTheme).

Returns
TRUE if successful, otherwise FALSE.
See also
SetCustomTheme, SetTheme

◆ CreateGridView()

BOOL CreateGridView ( DWORD dwListStyle )
protected

Creates the property grid window.

Parameters
dwListStyle Default list style for the view.
Returns
TRUE if successful, otherwise FALSE.

◆ CreateView()

virtual CXTPPropertyGridView * CreateView ( ) const
virtual

Creates a property grid view.

Override this method to create a custom property grid view.

Starting from version 19.2, PropertyGrid supports scrollbar themes. However, due to technical challenges, having scrollbar themes enabled has also introduced a number of issues for various use cases. If you are affected by any of those issues and would prefer to fallback to pre-19.2 behavior at the price of disabling scrollbar themes, then you can either uncomment the XTP_PROPERTY_GRID_DISABLE_SCROLLBAR_THEMES macro at the beginning of the XTPPropertyGrid.h file or specify that macro as defined in either the C++ compiler properties of the ToolkitPro or PropertyGrid library project for selected configurations and then re-build either the ToolkitPro or PropertyGrid project in order for the change to take effect.

Returns
A pointer to the newly created property grid view.

◆ EnableMarkup()

void EnableMarkup ( BOOL bEnable = TRUE )

Enables/disables markup for the property grid.

Parameters
bEnable TRUE to enable markup for the property grid, FALSE to disable markup for the property grid.

◆ EnableMultiSelect()

void EnableMultiSelect ( BOOL bMultiSelect = TRUE )

Enables/disables multi-select mode.

Parameters
bMultiSelect TRUE to enable multi-select mode, FALSE to disable multi-select mode.
See also
GetSelectedItems

◆ EnableToolTips()

AFX_INLINE void EnableToolTips ( BOOL bEnable = TRUE )

Enables/disables tooltips under items.

Parameters
bEnable TRUE to enable tooltips, FALSE to disable.

◆ EndUpdate()

void EndUpdate ( CXTPPropertyGridUpdateContext & context )

"Unlocks" the property grid.

This method should be called after BeginUpdate.

Parameters
context Reference to a CXTPPropertyGridUpdateContext object.
See also
BeginUpdate, CXTPPropertyGridUpdateContext

◆ FindItem() [1/2]

CXTPPropertyGridItem * FindItem ( LPCTSTR strCaption ) const

Retrieves an item by its caption/identifier.

Parameters
strCaption Caption of the item to retrieve.
Returns
A pointer to the CXTPPropertyGridItem object if found, otherwise NULL.

◆ FindItem() [2/2]

CXTPPropertyGridItem * FindItem ( UINT nID ) const

Retrieves an item by its caption/identifier.

Parameters
nID Indentifier of the item to retrieve.
Returns
A pointer to the CXTPPropertyGridItem object if found, otherwise NULL.

◆ GetBorderStyle()

XTPPropertyGridBorderStyle GetBorderStyle ( ) const

Gets the border style of the property grid.

Returns
The border style of the property grid; one of the values defined by the XTPPropertyGridBorderStyle enumeration.
See also
SetBorderStyle, XTPPropertyGridBorderStyle

◆ GetCategories()

CXTPPropertyGridItems * GetCategories ( ) const

Gets the collection of categories of the property grid.

Returns
A pointer to the collection of categories of the property grid.

◆ GetCount()

int GetCount ( ) const

Gets the number of items in the property grid.

Since indices are zero-based, the value returned by this method will be one greater than the zero-based index of the last item in the property grid.

Returns
The number of items in the property grid if successful, otherwise LB_ERR if an error occurs.

◆ GetCurrentTheme()

AFX_INLINE XTPPropertyGridPaintTheme GetCurrentTheme ( ) const

Gets the theme of the property grid.

Returns
The theme of the property grid; one of the values defined by the XTPPropertyGridPaintTheme enumeration.

◆ GetGridView()

CXTPPropertyGridView & GetGridView ( ) const

Gets the view of the property grid.

Returns
A reference to the view of the property grid.

◆ GetHelpBackColor()

COLORREF GetHelpBackColor ( ) const

Gets the background color of the help pane.

Returns
The background color of the help pane.

◆ GetHelpForeColor()

COLORREF GetHelpForeColor ( ) const

Gets the foreground color of the help pane.

Returns
The foreground color of the help pane.

◆ GetHelpHeight()

int GetHelpHeight ( ) const

Gets the height of the help pane when it is visible.

Returns
The height, in pixels, of the help pane when it is visible.

◆ GetImageManager()

CXTPImageManager * GetImageManager ( ) const

Gets the image manager associated with the property grid (i.e.

the image manager that stores images in the property grid).

Returns
A pointer to the image manager associated with the property grid.

◆ GetItem()

CXTPPropertyGridItem * GetItem ( int nIndex ) const

Retrieves the item at a specified index in the list.

Parameters
nIndex Zero-based index of the item to retrieve.
Returns
A pointer to the item at the specified index in the list.

◆ GetMarkupContext()

AFX_INLINE CXTPMarkupContext * GetMarkupContext ( ) const

Gets the Markup context.

Returns
A pointer to the Markup context.

◆ GetPaintManager()

AFX_INLINE CXTPPropertyGridPaintManager * GetPaintManager ( ) const

Gets the paint manager associated with the property grid (i.e.

the paint manager used to draw the property grid control window).

Returns
A pointer to the paint manager associated with the property grid.

◆ GetPropertySort()

XTPPropertyGridSortOrder GetPropertySort ( ) const

Gets the grouping style of the property grid control.

Returns
The grouping style of the property grid control; one of the values defined by the XTPPropertyGridSortOrder enumeration.
See also
SetPropertySort

◆ GetSelectedItem()

CXTPPropertyGridItem * GetSelectedItem ( ) const

Gets the currently selected item.

Returns
A pointer to the currently selected item, if any, otherwise NULL.

◆ GetSelectedItems()

int GetSelectedItems ( CArray< int, int > * pItems ) const

Gets the number of selected items if multi-select mode is enabled.

Parameters
pItems Pointer to a CArray to receive the indices of the selected items.
Returns
The number of selected items.
See also
EnableMultiSelect

◆ GetShowInplaceButtonsAlways()

AFX_INLINE BOOL GetShowInplaceButtonsAlways ( ) const

Determines if in-place buttons are always shown.

Returns
TRUE if in-place buttons are always shown, FALSE if in-place buttons are only shown when their items are selected.
See also
SetShowInplaceButtonsAlways

◆ GetToolBar()

AFX_INLINE CToolBar & GetToolBar ( )

Gets the toolbar of the property grid.

Returns
A reference to the toolbar of the property grid.

◆ GetToolTipContext()

AFX_INLINE CXTPToolTipContext * GetToolTipContext ( ) const

Gets the tooltip context.

Returns
A pointer to the tooltip context.

◆ GetTopIndex()

int GetTopIndex ( ) const

Gets the zero-based index of the first visible item (i.e.

the top item) in the property grid.

The item with the zero-based index of 0 will be the first visible item in the property grid initially. The first visible item in the property grid may change if the list box is scrolled.

Returns
The zero-based index of the first visible item (i.e. the top item) in the property grid if successful, otherwise a value of -1.

◆ GetVariableHelpHeight()

AFX_INLINE BOOL GetVariableHelpHeight ( ) const

Determines if the user can resize the help box with the mouse.

SetVariableHelpHeight allows the user to resize the help box by moving the mouse cursor over the help splitter that appears between the bottom of the property grid and the top of the help box. A resize mouse cursor will appear when the mouse if positioned over the splitter.

Returns
TRUE if the user can resize the help box with the mouse.
See also
SetHelpHeight, SetVariableHelpHeight

◆ GetVariableSplitterPos()

BOOL GetVariableSplitterPos ( ) const

Determines if the user can resize the property grid splitter.

SetVariableSplitterPos allows the user to resize the property grid splitter by moving the mouse cursor over the splitter and dragging the mouse. A resize mouse cursor will appear when the mouse is positioned over the splitter.

Returns
TRUE if the user can resize the property grid splitter.
See also
SetVariableSplitterPos, SetViewDividerPos

◆ GetVerbs()

AFX_INLINE CXTPPropertyGridVerbs * GetVerbs ( ) const

Gets the collection of verbs displayed in the verb panel.

Returns
A pointer to the collection of verbs displayed in the verb panel.

◆ GetVerbsHeight()

int GetVerbsHeight ( ) const

Gets the height of the verb box when it is visible.

Returns
The height, in pixels, of the verb box.
See also
CXTPPropertyGridVerb, CXTPPropertyGridVerbs, IsVerbsVisible, SetVerbsHeight

◆ GetViewDivider()

double GetViewDivider ( ) const

Gets the divider position of the grid view.

Returns
A double value between 0 and 1 that represents the location of the divider as a percentage from the left side of the view. For example, 0.25 would be returned if the divider is set to divide at 25%.

◆ HighlightChangedButtonItems()

AFX_INLINE void HighlightChangedButtonItems ( BOOL bHighlightChanged )

Enables/disables highlighting for in-place button text when the item value is changed.

Parameters
bHighlightChanged TRUE to enable highlighting for in-place button text when the item value is changed, FALSE to disable highlighting for in-place button text when the item value is changed.
See also
IsHighlightChangedItems, CXTPPropertyGridItem::IsValueChanged

◆ HighlightChangedItems()

AFX_INLINE void HighlightChangedItems ( BOOL bHighlightChanged )

Enables/disables changed item highlighting.

Parameters
bHighlightChanged TRUE to enable changed item highlighting, FALSE to disable changed item highlighting.
See also
IsHighlightChangedItems, CXTPPropertyGridItem::IsValueChanged

◆ HitTest()

virtual int HitTest ( CPoint pt )
protectedvirtual

Determines if the help splitter, the verb splitter, or a verb was clicked.

Parameters
pt Point to be tested.
Returns
The HitTest method returns one of the following values which specifies which part of the property grid is located under the coordinates specified by pt.

xtpPropertyGridHitError: Indicates that something other than the help splitter, the verb splitter, or a verb was clicked. xtpPropertyGridHitHelpSplitter: Indicates that the help splitter was clicked. xtpPropertyGridHitVerbsSplitter: Indicates that the verb splitter was clicked. xtpPropertyGridHitFirstVerb: If the return value is greater than or equal to xtpPropertyGridHitFirstVerb, then the item that was clicked is a verb. You can retrieve the verb index by subtracting xtpPropertyGridHitFirstVerb from the return value. For example:

int iHit = m_wndPropertyGrid.HitTest(pt);
if (iHit >= xtpPropertyGridHitFirstVerb)
{
   // Get the index of the verb.
   m_iVerbIndex = (iHit-xtpPropertyGridHitFirstVerb);
}
See also
XTPPropertyGridHitCode

◆ InsertCategory() [1/2]

CXTPPropertyGridItem * InsertCategory | ( | int | nIndex,
 |  | int | nID,
 |  | CXTPPropertyGridItem * | pCategory = NULL )

Inserts a new category to the property grid control.

Parameters
nID | Identifier of the new category.
nIndex | Index of the category to be inserted.
pCategory | Allows for custom classses to be categories. If it is NULL, then the property grid creates a default CXTPPropertyGridItem as a category. If it is not NULL, then the specified item will be used.
Returns
A pointer to the CXTPPropertyGridItem object of the newly inserted category.

◆ InsertCategory() [2/2]

CXTPPropertyGridItem * InsertCategory | ( | int | nIndex,
 |  | LPCTSTR | lpszCaption,
 |  | CXTPPropertyGridItem * | pCategory = NULL )

Inserts a new category to the property grid control.

Parameters
lpszCaption | Name of the category to be inserted.
nIndex | Index of the category to be inserted.
pCategory | Allows for custom classses to be categories. If it is NULL, then the property grid creates a default CXTPPropertyGridItem as a category. If it is not NULL, then the specified item will be used.
Returns
A pointer to the CXTPPropertyGridItem object of the newly inserted category.

◆ IsBarVisible()

AFX_INLINE BOOL IsBarVisible ( ) const

Determines the visible state of the toolbar.

Returns
TRUE if the toolbar is visible, otherwise FALSE.

◆ IsHelpVisible()

AFX_INLINE BOOL IsHelpVisible ( ) const

Determines the visible state of the help pane.

Returns
TRUE if the help pane is visible, otherwise FALSE.

◆ IsHighlightChangedButtonItems()

AFX_INLINE BOOL IsHighlightChangedButtonItems ( ) const

Determines if highlighting is enabled/disabled for in-place button text when the item value is changed.

Returns
TRUE if highlighting is enabled for in-place button text when the item value is changed, FALSE if highlighting is disabled for in-place button text when the item value is changed.
See also
HighlightChangedItems, CXTPPropertyGridItem::IsValueChanged

◆ IsHighlightChangedItems()

AFX_INLINE BOOL IsHighlightChangedItems ( ) const

Determines if changed item highlighting is enabled/disabled.

Returns
TRUE if changed item highlighting is enabled, FALSE if changed item highlighting is disabled.
See also
HighlightChangedItems, CXTPPropertyGridItem::IsValueChanged

◆ IsLayoutRTL()

BOOL IsLayoutRTL ( ) const

Determines if right-to-left (RTL) mode is set.

Returns
TRUE if text is displayed using right-to-left (RTL) reading-order properties.

◆ IsVerbsVisible()

AFX_INLINE BOOL IsVerbsVisible ( ) const

Determines the visible state of the verb panel.

Returns
TRUE if the verb panel is visible, otherwise FALSE.
See also
CXTPPropertyGridVerb, CXTPPropertyGridVerbs

◆ NavigateItems()

AFX_INLINE void NavigateItems | ( | BOOL | bTabItems,
 |  | BOOL | bTabCaptions = TRUE )

Enables/disables item navigation by using the Tab key.

Parameters
bTabItems | TRUE to enable item navigation by using the Tab key, FALSE to disable item navigation by using the Tab key.
bTabCaptions | TRUE to allow caption items (i.e. items which do not have in-place controls) to function as Tab stops (i.e. can receive focus when the Tab key is pressed), FALSE to prevent caption items from functioning as Tab stops.

If bTabItems is set to TRUE, then focus will move in the following order: caption, item value, item in-place button (if used), next item caption.

◆ OnInvertTracker()

void OnInvertTracker ( CRect rc )
protected

This method is called by the framework during the resizing of splitters.

Parameters
rc Tracking rectangle.

◆ OnNavigate()

virtual void OnNavigate | ( | XTPPropertyGridUI | nUIElement,
 |  | BOOL | bForward,
 |  | CXTPPropertyGridItem * | pItem )
 virtual

This method is called when items in the property grid are navigated by using keys on the keyboard.

This includes navigating the built-in toolbar, verbs, and items in the property grid.

Parameters
nUIElement | Indicates which object should receive focus; must be one of the values defined by the XTPPropertyGridUI enumeration.
bForward | TRUE if either the Tab key is pressed and items are being navigated in the forward direction or if either the Right or Down arrows are being used to navigate the items. FALSE if Shift+Tab is pressed and items are being navigated in the backward direction or if either the Up or Left arrows are being used to navigate the items.
pItem | Pointer to the currently selected item.
See also
XTPPropertyGridUI

◆ OnSelectionChanged()

virtual void OnSelectionChanged ( CXTPPropertyGridItem * pItem )
protectedvirtual

This method is called either when a new item is selected in the property grid or when focus is switched from one item to another.

Parameters
pItem Pointer to the newly selected/focused item.
See also
GetSelectedItem

◆ OnSortChanged()

virtual void OnSortChanged ( )
protectedvirtual

This method is called when the sort order is changed.

See also
SetPropertySort

◆ OnVerbClick()

virtual void OnVerbClick | ( | int | nIndex,
 |  | CPoint | pt )
 virtual

This method is called either when a user clicks on a verb or when a verb has focus and the Enter/Return key is pressed.

Override this method to perform custom actions such as displaying a dialog.

Parameters
nIndex | Index of the verb within the collection of verbs.
pt | Point on screen that was clicked by the user (i.e. the position of the mouse cursor over the verb). This point is stored in the CXTPPropertyGridVerb::m_ptClick member which is a CPoint object. Coordinates are relative to the screen and not to the client.

◆ RefeshBindings()

void RefeshBindings ( CXTPPropertyGridItem * pItem = NULL )
protected

Call this method to refresh all binding in pItem tree.

pItem can be NULL to refresh all items

Parameters
pItem Root item to refresh

◆ RefreshToolBarButtons()

void RefreshToolBarButtons ( )
protected

This method is called when the toolbar buttons must be redrawn.

The toolbar buttons must be redrawn when the sort order is changed while the toolbar is shown. The sort order can be changed either by code or by clicking on a button in the toolbar.

◆ RegisterWindowClass()

BOOL RegisterWindowClass ( HINSTANCE hInstance = NULL )

Registers the window class if it has not already been registered.

Parameters
hInstance Instance of the resource where the property grid is located.
Returns
TRUE if the window class was successfully registered.

◆ Reposition()

virtual void Reposition | ( | int | cx,
 |  | int | cy )
 protectedvirtual

Recalculates both the position and size of the property grid and then resizes the property grid to a specified size.

The new size for the property grid is 0, 0, cx, cy including the area that contains the toolbar and grid, but not including the area that contains the verb and help panel.

Parameters
cx | Bottom-right x- coordinate to be set for the property grid's bounding rectangle.
cy | Bottom-right y- coordinate to be set for the property grid's bounding rectangle.

◆ SendNotifyMessage()

virtual LRESULT SendNotifyMessage | ( | WPARAM | wParam = 0,
 |  | LPARAM | lParam = 0 )
 virtual

Sends a specified message to the owner window.

Parameters
wParam | Specifies additional message-dependent information.
lParam | Specifies additional message-dependent information.
Returns
The result of the message processing; this value depends on the message sent.

◆ SetBorderStyle()

void SetBorderStyle ( XTPPropertyGridBorderStyle borderStyle )

Sets the border style for the property grid.

Parameters
borderStyle Border style to be set; must be one of the values defined by the XTPPropertyGridBorderStyle enumeration.
See also
GetBorderStyle, XTPPropertyGridBorderStyle

◆ SetCustomColors()

void SetCustomColors | ( | COLORREF | clrHelpBack,
 |  | COLORREF | clrHelpFore,
 |  | COLORREF | clrViewLine,
 |  | COLORREF | clrViewBack,
 |  | COLORREF | clrViewFore,
 |  | COLORREF | clrCategoryFore = ::GetSysColor(COLOR_GRAYTEXT) )

Sets the custom colors for the property grid control.

Parameters
clrHelpBack | An RGB value that represents the background color of the description pane.
clrHelpFore | An RGB value that represents the text color of the description pane.
clrViewLine | An RGB value that represents the color of separating lines in the property grid control.
clrViewBack | An RGB value that represents the background color of the property grid control.
clrViewFore | An RGB value that represents the text color of the property grid control.
clrCategoryFore | An RGB value that represents the text color of the category item text.

◆ SetCustomTheme()

void SetCustomTheme ( CXTPPropertyGridPaintManager * pPaintManager )

Sets a custom theme for the property grid.

Parameters
pPaintManager Pointer to a CXTPPropertyGridPaintManager object.

◆ SetFont()

void SetFont ( CFont * pFont )

Sets the font of the property grid.

Parameters
pFont Pointer to the font to be set.

◆ SetHelpHeight()

void SetHelpHeight ( int nHeight )

Sets the height for the help pane when it is visible.

Parameters
nHeight Height, in pixels, to be set.

◆ SetImageManager()

void SetImageManager ( CXTPImageManager * pImageManager )

Sets the image manager associated with the property grid (i.e.

the image manager that stores images in the property grid).

Parameters
pImageManager Pointer to the image manager to be set.

◆ SetInplaceEdit()

void SetInplaceEdit ( CXTPPropertyGridInplaceEdit * pInplaceEdit )

Sets the in-place edit control.

Parameters
pInplaceEdit Pointer to the in-place edit control to be set.

Example:

m_wndPropertyGrid.SetInplaceEdit(new CMyInplaceEdit());
See also
SetInplaceList, CXTPPropertyGridItem::GetInplaceEdit

◆ SetInplaceList()

void SetInplaceList ( CXTPPropertyGridInplaceList * pInplaceList )

Sets the in-place list box control.

Parameters
pInplaceList Pointer to the in-place list box control to be set.

Example:

m_wndPropertyGrid.SetInplaceList(new CMyInplaceList());
See also
SetInplaceEdit, CXTPPropertyGridItem::GetInplaceList

◆ SetLayoutRTL()

void SetLayoutRTL ( BOOL bRightToLeft )

Specifies if right-to-left (RTL) mode should be set.

Parameters
bRightToLeft TRUE to display text using right-to-left (RTL) reading-order properties.

◆ SetPropertySort()

void SetPropertySort ( XTPPropertyGridSortOrder sort )

Sets the grouping style for the property grid control.

Parameters
sort Grouping style to be set; can be any of the values listed in the Remarks section.

sort parameter can be one of the following: xtpPropertyGridSortCategorized: Group items by category. xtpPropertyGridSortAlphabetical: Sort items alphabetically. xtpPropertyGridSortNoSort: Disable sorting.

See also
GetPropertySort

◆ SetShowInplaceButtonsAlways()

AFX_INLINE void SetShowInplaceButtonsAlways ( BOOL bShow )

Specifies if in-place buttons should always be shown.

Parameters
bShow TRUE to always show in-place buttons, FALSE to only show in-place buttons when their items are selected.
See also
GetShowInplaceButtonsAlways

◆ SetTheme()

AFX_INLINE void SetTheme ( XTPPropertyGridPaintTheme paintTheme )

Sets the theme for the property grid.

Parameters
paintTheme Theme to be set defined by the XTPPropertyGridPaintTheme enumeration.

◆ SetTopIndex()

void SetTopIndex ( int nIndex )

Sets the zero-based index for the first visible item (i.e.

the top item) in the property grid.

Parameters
nIndex Zero-based index of the item to be set.

This method ensures that the item with the zero-based index specified by nIndex is visible. This is accomplished by scrolling the property grid until either the item with the zero-based index specified by nIndex appears at the top of the property grid or until the maximum scroll range is reached.

◆ SetVariableHelpHeight()

AFX_INLINE void SetVariableHelpHeight ( BOOL bVariable )

Specifies if the user can resize the help box with the mouse.

Parameters
bVariable TRUE to allow the user to resize the help box with the mouse.

SetVariableHelpHeight allows the user to resize the help box by moving the mouse cursor over the help splitter that appears between the bottom of the property grid and the top of the help box. A resize mouse cursor will appear when the mouse if positioned over the splitter.

See also
SetHelpHeight, GetVariableHelpHeight

◆ SetVariableItemsHeight()

void SetVariableItemsHeight ( BOOL bVariable = TRUE )

Specifies if variable items height should be allowed.

Parameters
bVariable TRUE to allow variable items height.
See also
CXTPPropertyGridItem::SetHeight, CXTPPropertyGridItem::SetMultiLinesCount

◆ SetVariableSplitterPos()

void SetVariableSplitterPos ( BOOL bVariable )

Specifies if the user can resize the property grid splitter.

Parameters
bVariable TRUE to allow the user to resize the property grid splitter.

SetVariableSplitterPos allows the user to resize the property grid splitter by moving the mouse cursor over the splitter and dragging the mouse. A resize mouse cursor will appear when the mouse is positioned over the splitter.

See also
GetVariableSplitterPos, SetViewDividerPos

◆ SetVerbsHeight()

void SetVerbsHeight ( int nHeight )

Sets the height of the verb vox when it is visible.

Parameters
nHeight Height, in pixels, to be set.
See also
CXTPPropertyGridVerb, CXTPPropertyGridVerbs, IsVerbsVisible, GetVerbsHeight

◆ SetViewDivider()

void SetViewDivider ( double dDivider )

Sets the divider position for the grid view.

Parameters
dDivider Double value between 0 and 1 that represents the location of the divider as a percentage from the left side of the view. For example, set this parameter to 0.25 in order to set the divider to divide at 25%.

◆ SetViewDividerPos()

void SetViewDividerPos | ( | int | nDivider,
 |  | BOOL | bLockDivider = FALSE )

Sets the divider position for the grid view.

Parameters
nDivider | Divider position, in pixels, to be set.
bLockDivider | TRUE to prevent the divider from scaling with the property grid when the property grid is resized.

◆ ShowHelp()

void ShowHelp ( BOOL bShow = TRUE )

Shows/hides the description pane in the property grid window.

Parameters
bShow TRUE to show the description pane, FALSE to hide.

◆ ShowToolBar()

void ShowToolBar ( BOOL bShow = TRUE )

Shows/hides the toolbar control in the property grid window.

Parameters
bShow TRUE to show the toolbar control, FALSE to hide.

◆ ShowView()

void ShowView ( BOOL bShow = TRUE )

Shows/hides the view pane.

Parameters
bShow TRUE to show the view pane, FALSE to hide.
The documentation for this class was generated from the following file:
  • XTPPropertyGrid.h


Toolkit Pro: CXTPPropertyGridCoolTheme Class Reference

Public Member Functions | List of all members
CXTPPropertyGridCoolTheme Class Reference

CXTPPropertyGridCoolTheme is a CXTPPropertyGridPaintManager derived class. More...

Inheritance diagram for CXTPPropertyGridCoolTheme:
[legend]

Public Member Functions

CXTPPropertyGridCoolTheme (CXTPPropertyGrid *pGrid)
Constructs a CXTPPropertyGridCoolTheme object.
virtual void | DrawItem (PDRAWITEMSTRUCT lpDrawItemStruct)
Draws a single item for the grid.
void | RefreshMetrics ()
Refreshes the visual metrics of the property grid.
virtual XTPScrollBarTheme | GetScrollBarTheme () const
Gets the scrollbar theme identifier.
- Public Member Functions inherited from CXTPPropertyGridPaintManager
CXTPPropertyGridPaintManager (CXTPPropertyGrid *pGrid)
Constructs a CXTPPropertyGridPaintManager object.
virtual | ~CXTPPropertyGridPaintManager ()
Destroys a CXTPPropertyGridPaintManager object, handles cleanup and deallocation.
virtual COLORREF | GetItemTextColor (CXTPPropertyGridItem *pItem, BOOL bValuePart)
Retrieves the text color of a specified item.
virtual COLORREF | GetItemBackColor (CXTPPropertyGridItem *pItem, BOOL bValuePart)
Retrieves the back color of a specified item.
virtual CFont * | GetItemFont (CXTPPropertyGridItem *pItem, BOOL bValuePart)
Retrieves the font of a specified item.
virtual void | FillPropertyGrid (CDC *pDC)
Draws the background of the property grid.
virtual void | FillPropertyGridView (CDC *pDC)
Draws the background of the view.
virtual void | DrawPropertyGridBorder (CDC *pDC, RECT &rcBorder, XTPPropertyGridWindow nWindow)
Draws grid borders.
virtual void | OnNcCalcSize (RECT &rc)
Adjusts the bounding rectangle of the grid.
virtual void | DrawInplaceListItem (CDC *pDC, CXTPPropertyGridItemConstraint *pConstraint, CRect rc, BOOL bSelected)
Draws a specified constraint in the in-place list.
virtual void | AdjustItemValueRect (CXTPPropertyGridItem *pItem, CRect &rcValue)
Adjusts the rectangle of the value part of a specified item.
virtual void | AdjustItemCaptionRect (CXTPPropertyGridItem *pItem, CRect &rcCaption)
Adjusts the rectangle of the caption part of a specified item.
virtual void | MeasureItem (LPMEASUREITEMSTRUCT lpMeasureItemStruct)
Override this method and fill in a specified MEASUREITEMSTRUCT structure to inform Windows of the list-box dimensions.
virtual void | FillInplaceButton (CDC *pDC, CXTPPropertyGridInplaceButton *pButton)
Draws an in-place button for the grid.
int | HitTestVerbs (CDC *pDC, CRect rcVerbs, CPoint pt)
Determines the index of the verb within the verbs collection, if any, at a specified point.
CXTPPropertyGridItemMetrics * | GetItemMetrics () const
Gets the default item metrics.
CRect | GetSplitterRect (CRect rc, BOOL bIsHelp)
This method is called by the property grid to retrieve the size of either the help window splitter bar or the verbs splitter bar.
virtual int | GetItemsBorderHeight () const
Gets the height of the horizontal grid line between property grid items.
virtual void | SetItemsBorderHeight (int nHeight)
Sets the height of the horizontal grid line between property grid items.
virtual void | SetThinSplitter (BOOL bThinSplitter)
Sets draw a bottom single line for the splitter bar.
virtual void | DrawExpandButton (CDC &dc, CXTPPropertyGridItem *pItem, CRect rcCaption)
Draws an expand button for the grid.
virtual void | DrawCategoryCaptionBackground (CDC *pDC, CXTPPropertyGridItem *pItem, CRect rc)
Draws the background for the bounding rectangle of a category caption.
virtual void | DrawItemValue (CDC *pDC, CXTPPropertyGridItem *pItem, CRect rcValue)
Draws the value part of a property grid item.
virtual void | DrawItemCaption (CDC *pDC, CXTPPropertyGridItem *pItem, CRect rcCaption)
Draws the caption part of a property grid item.
virtual void | DrawInplaceButtons (CDC *pDC, PDRAWITEMSTRUCT lpDrawItemStruct, CXTPPropertyGridItem *pItem, CRect rcValue)
Draws the in-place buttons of a property grid item.
virtual void | DrawCheckBox (CDC *pDC, CXTPPropertyGridItemBool *pButton)
Draws a checkbox for a CXTPPropertyGridItemOption item with with the CheckBox style.
virtual void | DrawCheckMark (CDC *pDC, CRect rc, BOOL bEnabled, BOOL bChecked)
Draws a check mark.
virtual void | DrawRadioMark (CDC *pDC, CRect rc, BOOL bEnabled, BOOL bChecked)
Draws a radio button for a CXTPPropertyGridItemOption item with the RadioButton (default) style.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPPropertyGridPaintManager
XTPPropertyGridInplaceButtonsStyle | m_buttonsStyle
TRUE to use WinXP themes.
CXTPWinThemeWrapper * | m_themeTree
Themes for tree controls.
CXTPWinThemeWrapper * | m_themeButton
Themes for button controls.
CXTPWinThemeWrapper * | m_themeCombo
Themes for combo button.
BOOL | m_bTransparent
TRUE to draw background with parent color.
CXTPPaintManagerColor | m_clrFace
Face color.
CXTPPaintManagerColor | m_clrShadow
Shadow color.
CXTPPaintManagerColor | m_clrHighlight
Highlight color.
CXTPPaintManagerColor | m_clrHighlightText
Highlight text color.
CXTPPaintManagerColor | m_clrNonHighlightBack
Non-highlight background color.
CXTPPaintManagerColor | m_clrNonHighlightText
Non-highlight text color.
CXTPPaintManagerColor | m_clrCategorySeparator
Face color.
CXTPPaintManagerColor | m_clrSplitter
Splitter border color.
- Protected Attributes inherited from CXTPPropertyGridPaintManager
int | m_nItemsBorderHeight
Height, in pixels, of the horizontal border between property grid items.
int | m_nSplitterHeight
Height, in pixels, of the splitter bar.
int | m_nHelpHeight
Height, in pixels, of the description area (help pane).
int | m_nVerbsHeight
Height, in pixels, of the verbs box.
BOOL | m_bThinSplitter
TRUE to draw a single line for the splitter bar.
CXTPPropertyGrid * | m_pGrid
Parent grid class.
CXTPPropertyGridItemMetrics * | m_pMetrics
Default metrics of the item.

Detailed Description

CXTPPropertyGridCoolTheme is a CXTPPropertyGridPaintManager derived class.

It represents a Cool style theme.

Constructor & Destructor Documentation

◆ CXTPPropertyGridCoolTheme()

CXTPPropertyGridCoolTheme ( CXTPPropertyGrid * pGrid )

Constructs a CXTPPropertyGridCoolTheme object.

Parameters
pGrid Pointer to a CXTPPropertyGrid object.

Member Function Documentation

◆ DrawItem()

virtual void DrawItem ( PDRAWITEMSTRUCT lpDrawItemStruct )
virtual

Draws a single item for the grid.

Parameters
lpDrawItemStruct Long pointer to a DRAWITEMSTRUCT structure containing information about the type of drawing required.

Reimplemented from CXTPPropertyGridPaintManager.

◆ GetScrollBarTheme()

virtual XTPScrollBarTheme GetScrollBarTheme ( ) const
virtual

Gets the scrollbar theme identifier.

Returns
The scrollbar theme identifier; one of the values defined by the XTPScrollBarTheme enumeration.

Reimplemented from CXTPPropertyGridPaintManager.

The documentation for this class was generated from the following file:
  • XTPPropertyGridPaintManager.h


Toolkit Pro: CXTPPropertyGridDelphiTheme Class Reference

Public Member Functions | List of all members
CXTPPropertyGridDelphiTheme Class Reference

CXTPPropertyGridDelphiTheme is a CXTPPropertyGridPaintManager derived class. More...

Inheritance diagram for CXTPPropertyGridDelphiTheme:
[legend]

Public Member Functions

CXTPPropertyGridDelphiTheme (CXTPPropertyGrid *pGrid)
Constructs a CXTPPropertyGridDelphiTheme object.
virtual void | DrawItem (PDRAWITEMSTRUCT lpDrawItemStruct)
Draws a single item for the grid.
virtual void | RefreshMetrics ()
Refreshes the visual metrics of the property grid.
virtual XTPScrollBarTheme | GetScrollBarTheme () const
Gets the scrollbar theme identifier.
- Public Member Functions inherited from CXTPPropertyGridPaintManager
CXTPPropertyGridPaintManager (CXTPPropertyGrid *pGrid)
Constructs a CXTPPropertyGridPaintManager object.
virtual | ~CXTPPropertyGridPaintManager ()
Destroys a CXTPPropertyGridPaintManager object, handles cleanup and deallocation.
virtual COLORREF | GetItemTextColor (CXTPPropertyGridItem *pItem, BOOL bValuePart)
Retrieves the text color of a specified item.
virtual COLORREF | GetItemBackColor (CXTPPropertyGridItem *pItem, BOOL bValuePart)
Retrieves the back color of a specified item.
virtual CFont * | GetItemFont (CXTPPropertyGridItem *pItem, BOOL bValuePart)
Retrieves the font of a specified item.
virtual void | FillPropertyGrid (CDC *pDC)
Draws the background of the property grid.
virtual void | FillPropertyGridView (CDC *pDC)
Draws the background of the view.
virtual void | DrawPropertyGridBorder (CDC *pDC, RECT &rcBorder, XTPPropertyGridWindow nWindow)
Draws grid borders.
virtual void | OnNcCalcSize (RECT &rc)
Adjusts the bounding rectangle of the grid.
virtual void | DrawInplaceListItem (CDC *pDC, CXTPPropertyGridItemConstraint *pConstraint, CRect rc, BOOL bSelected)
Draws a specified constraint in the in-place list.
virtual void | AdjustItemValueRect (CXTPPropertyGridItem *pItem, CRect &rcValue)
Adjusts the rectangle of the value part of a specified item.
virtual void | AdjustItemCaptionRect (CXTPPropertyGridItem *pItem, CRect &rcCaption)
Adjusts the rectangle of the caption part of a specified item.
virtual void | MeasureItem (LPMEASUREITEMSTRUCT lpMeasureItemStruct)
Override this method and fill in a specified MEASUREITEMSTRUCT structure to inform Windows of the list-box dimensions.
virtual void | FillInplaceButton (CDC *pDC, CXTPPropertyGridInplaceButton *pButton)
Draws an in-place button for the grid.
int | HitTestVerbs (CDC *pDC, CRect rcVerbs, CPoint pt)
Determines the index of the verb within the verbs collection, if any, at a specified point.
CXTPPropertyGridItemMetrics * | GetItemMetrics () const
Gets the default item metrics.
CRect | GetSplitterRect (CRect rc, BOOL bIsHelp)
This method is called by the property grid to retrieve the size of either the help window splitter bar or the verbs splitter bar.
virtual int | GetItemsBorderHeight () const
Gets the height of the horizontal grid line between property grid items.
virtual void | SetItemsBorderHeight (int nHeight)
Sets the height of the horizontal grid line between property grid items.
virtual void | SetThinSplitter (BOOL bThinSplitter)
Sets draw a bottom single line for the splitter bar.
virtual void | DrawExpandButton (CDC &dc, CXTPPropertyGridItem *pItem, CRect rcCaption)
Draws an expand button for the grid.
virtual void | DrawCategoryCaptionBackground (CDC *pDC, CXTPPropertyGridItem *pItem, CRect rc)
Draws the background for the bounding rectangle of a category caption.
virtual void | DrawItemValue (CDC *pDC, CXTPPropertyGridItem *pItem, CRect rcValue)
Draws the value part of a property grid item.
virtual void | DrawItemCaption (CDC *pDC, CXTPPropertyGridItem *pItem, CRect rcCaption)
Draws the caption part of a property grid item.
virtual void | DrawInplaceButtons (CDC *pDC, PDRAWITEMSTRUCT lpDrawItemStruct, CXTPPropertyGridItem *pItem, CRect rcValue)
Draws the in-place buttons of a property grid item.
virtual void | DrawCheckBox (CDC *pDC, CXTPPropertyGridItemBool *pButton)
Draws a checkbox for a CXTPPropertyGridItemOption item with with the CheckBox style.
virtual void | DrawCheckMark (CDC *pDC, CRect rc, BOOL bEnabled, BOOL bChecked)
Draws a check mark.
virtual void | DrawRadioMark (CDC *pDC, CRect rc, BOOL bEnabled, BOOL bChecked)
Draws a radio button for a CXTPPropertyGridItemOption item with the RadioButton (default) style.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPPropertyGridPaintManager
XTPPropertyGridInplaceButtonsStyle | m_buttonsStyle
TRUE to use WinXP themes.
CXTPWinThemeWrapper * | m_themeTree
Themes for tree controls.
CXTPWinThemeWrapper * | m_themeButton
Themes for button controls.
CXTPWinThemeWrapper * | m_themeCombo
Themes for combo button.
BOOL | m_bTransparent
TRUE to draw background with parent color.
CXTPPaintManagerColor | m_clrFace
Face color.
CXTPPaintManagerColor | m_clrShadow
Shadow color.
CXTPPaintManagerColor | m_clrHighlight
Highlight color.
CXTPPaintManagerColor | m_clrHighlightText
Highlight text color.
CXTPPaintManagerColor | m_clrNonHighlightBack
Non-highlight background color.
CXTPPaintManagerColor | m_clrNonHighlightText
Non-highlight text color.
CXTPPaintManagerColor | m_clrCategorySeparator
Face color.
CXTPPaintManagerColor | m_clrSplitter
Splitter border color.
- Protected Attributes inherited from CXTPPropertyGridPaintManager
int | m_nItemsBorderHeight
Height, in pixels, of the horizontal border between property grid items.
int | m_nSplitterHeight
Height, in pixels, of the splitter bar.
int | m_nHelpHeight
Height, in pixels, of the description area (help pane).
int | m_nVerbsHeight
Height, in pixels, of the verbs box.
BOOL | m_bThinSplitter
TRUE to draw a single line for the splitter bar.
CXTPPropertyGrid * | m_pGrid
Parent grid class.
CXTPPropertyGridItemMetrics * | m_pMetrics
Default metrics of the item.

Detailed Description

CXTPPropertyGridDelphiTheme is a CXTPPropertyGridPaintManager derived class.

It represents a Delphi style theme.

Constructor & Destructor Documentation

◆ CXTPPropertyGridDelphiTheme()

CXTPPropertyGridDelphiTheme ( CXTPPropertyGrid * pGrid )

Constructs a CXTPPropertyGridDelphiTheme object.

Parameters
pGrid Pointer to a CXTPPropertyGrid object.

Member Function Documentation

◆ DrawItem()

virtual void DrawItem ( PDRAWITEMSTRUCT lpDrawItemStruct )
virtual

Draws a single item for the grid.

Parameters
lpDrawItemStruct Long pointer to a DRAWITEMSTRUCT structure containing information about the type of drawing required.

Reimplemented from CXTPPropertyGridPaintManager.

◆ GetScrollBarTheme()

virtual XTPScrollBarTheme GetScrollBarTheme ( ) const
virtual

Gets the scrollbar theme identifier.

Returns
The scrollbar theme identifier; one of the values defined by the XTPScrollBarTheme enumeration.

Reimplemented from CXTPPropertyGridPaintManager.

The documentation for this class was generated from the following file:
  • XTPPropertyGridPaintManager.h


Toolkit Pro: CXTPPropertyGridInplaceButton Class Reference

Public Member Functions | List of all members
CXTPPropertyGridInplaceButton Class Reference

CXTPPropertyGridInplaceButton is a CXTPCmdTarget derived class. More...

Inheritance diagram for CXTPPropertyGridInplaceButton:
[legend]

Public Member Functions

CXTPPropertyGridInplaceButton (UINT nID)
Constructs a CXTPPropertyGridInplaceButton object.
virtual | ~CXTPPropertyGridInplaceButton ()
Destroys a CXTPPropertyGridInplaceButton object, handles cleanup and deallocation.
int | GetWidth ()
Gets the width of the button.
void | SetWidth (int nWidth)
Sets the width for the button.
CString | GetCaption () const
Gets the caption text of the button.
void | SetCaption (LPCTSTR lpszCaption)
Sets the caption text for the button.
int | GetIconIndex () const
Gets the image index of the button.
void | SetTooltip (LPCTSTR lpstrTooltip)
Sets the tooltip text for the item.
CString | GetTooltip () const
Gets the tooltip text of the item.
void | SetIconIndex (int nIconIndex)
Sets the icon index for the button.
virtual CXTPImageManagerIcon * | GetImage () const
Gets the icon of the button.
CXTPPropertyGridItem * | GetItem () const
Gets the parent property grid item.
UINT | GetID () const
Gets the identifier of the button.
CRect | GetRect () const
Gets the bounding rectangle of the button.
BOOL | IsFocused () const
Determines if the button has focus.
BOOL | IsHot () const
Determines if the button is hot (i.e.
BOOL | IsPressed () const
Determines if the button is pressed.
int | GetIndex () const
Gets the index of this button within the collection of in-place buttons of the parent item.
virtual void | OnDraw (CDC *pDC, CRect rc)
Draws the button.
virtual void | OnLButtonDown (UINT nFlags, CPoint point)
This method is called when the user presses the left mouse button on the button.
virtual void | OnKeyDown (UINT nChar)
This method is called when the user presses a key while the button has focus.
CXTPPropertyGridView * | GetGrid () const
Gets the parent property grid view.
BOOL | GetEnabled () const
Determines if the button is enabled/disabled.
void | SetEnabled (BOOL bEnabled)
Enables/disables the button.
BOOL | IsHyperlink () const
Determines if the button acts as a hyperlink.
void | SetHyperlink (BOOL bHyperlink=TRUE)
Specifies if the button should act as a hyperlink.
BOOL | GetShowAlways () const
Determines if the button is always shown.
void | SetShowAlways (BOOL bShowAlways)
Specifies if the button should always be shown.
int | GetAlignment () const
Gets the alignment of the button.
void | SetAlignment (int nAlignment)
Sets the alignment for the button.
BOOL | GetTabStop () const
Specifies if the button is a tab stop (i.e.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

CXTPPropertyGridInplaceButton is a CXTPCmdTarget derived class.

It represents an in-place button in the property grid control.

Constructor & Destructor Documentation

◆ CXTPPropertyGridInplaceButton()

CXTPPropertyGridInplaceButton ( UINT nID )

Constructs a CXTPPropertyGridInplaceButton object.

Parameters
nID Identifier of the button.

Member Function Documentation

◆ GetAlignment()

AFX_INLINE int GetAlignment ( ) const

Gets the alignment of the button.

Returns
The alignment of the button.

◆ GetCaption()

AFX_INLINE CString GetCaption ( ) const

Gets the caption text of the button.

Returns
The caption text of the button.
See also
SetCaption

◆ GetEnabled()

BOOL GetEnabled ( ) const

Determines if the button is enabled/disabled.

Returns
TRUE if the button is enabled, FALSE if the button is disabled.

◆ GetGrid()

AFX_INLINE CXTPPropertyGridView * GetGrid ( ) const

Gets the parent property grid view.

Returns
A pointer to the parent property grid view.

◆ GetIconIndex()

AFX_INLINE int GetIconIndex ( ) const

Gets the image index of the button.

Returns
The image index of the button.
See also
SetIconIndex

◆ GetID()

AFX_INLINE UINT GetID ( ) const

Gets the identifier of the button.

The default identifier for the expand button is XTP_ID_PROPERTYGRID_EXPANDBUTTON. The default identifier for the combo button is XTP_ID_PROPERTYGRID_COMBOBUTTON.

Returns
The indentifier of the button.

◆ GetImage()

virtual CXTPImageManagerIcon * GetImage ( ) const
virtual

Gets the icon of the button.

Returns
A pointer to the icon of the button.
See also
SetIconIndex, CXTPPropertyGrid::GetImageManager

◆ GetIndex()

int GetIndex ( ) const

Gets the index of this button within the collection of in-place buttons of the parent item.

Returns
The index of this button within the collection of in-place buttons of the parent item.

◆ GetItem()

AFX_INLINE CXTPPropertyGridItem * GetItem ( ) const

Gets the parent property grid item.

Returns
A pointer to the parent property grid item.

◆ GetRect()

AFX_INLINE CRect GetRect ( ) const

Gets the bounding rectangle of the button.

Returns
The bounding rectangle of the button.

◆ GetShowAlways()

AFX_INLINE BOOL GetShowAlways ( ) const

Determines if the button is always shown.

Returns
TRUE if the button is always shown, FALSE if the button is only shown when the item is selected.
See also
SetShowAlways

◆ GetTabStop()

AFX_INLINE BOOL GetTabStop ( ) const

Specifies if the button is a tab stop (i.e.

if the user can use the TAB key to move focus to the button).

Returns
TRUE if the button is a tab stop, otherwise FALSE.

◆ GetTooltip()

AFX_INLINE CString GetTooltip ( ) const

Gets the tooltip text of the item.

The tooltip text is displayed when the mouse cursor is over the item.

Returns
The tooltip text of the item.

◆ GetWidth()

int GetWidth ( )

Gets the width of the button.

Returns
The width of the button.
See also
SetWidth

◆ IsFocused()

BOOL IsFocused ( ) const

Determines if the button has focus.

Returns
TRUE if the button has focus, otherwise FALSE.

◆ IsHot()

BOOL IsHot ( ) const

Determines if the button is hot (i.e.

currently highlighted).

Returns
TRUE if the button is hot, otherwise FALSE.

◆ IsHyperlink()

AFX_INLINE BOOL IsHyperlink ( ) const

Determines if the button acts as a hyperlink.

Returns
TRUE if the button acts as a hyperlink, otherwise FALSE.

◆ IsPressed()

BOOL IsPressed ( ) const

Determines if the button is pressed.

Returns
TRUE if the button is pressed, otherwise FALSE.

◆ OnDraw()

virtual void OnDraw | ( | CDC * | pDC,
 |  | CRect | rc )
 virtual

Draws the button.

Override this method to draw a custom button.

Parameters
pDC | Pointer to a valid device context.
rc | Bounding rectangle of the button.

◆ OnKeyDown()

virtual void OnKeyDown ( UINT nChar )
virtual

This method is called when the user presses a key while the button has focus.

Parameters
nChar Specifies the virtual-key code of the given key.

◆ OnLButtonDown()

virtual void OnLButtonDown | ( | UINT | nFlags,
 |  | CPoint | point )
 virtual

This method is called when the user presses the left mouse button on the button.

Parameters
nFlags | Indicates whether various virtual keys are down (see Visual C++ documentation).
point | Specifies the x- and y- coordinates of the cursor.

◆ SetAlignment()

AFX_INLINE void SetAlignment ( int nAlignment )

Sets the alignment for the button.

Parameters
nAlignment Alignment to be set (DT_LEFT or DT_RIGHT).

◆ SetCaption()

void SetCaption ( LPCTSTR lpszCaption )

Sets the caption text for the button.

Parameters
lpszCaption Caption text to be set.
See also
GetCaption

◆ SetEnabled()

void SetEnabled ( BOOL bEnabled )

Enables/disables the button.

Parameters
bEnabled TRUE to enable the button, FALSE to disable the button.

◆ SetHyperlink()

AFX_INLINE void SetHyperlink ( BOOL bHyperlink = TRUE )

Specifies if the button should act as a hyperlink.

Parameters
bHyperlink TRUE to set the button to act as a hyperlink, FALSE to prevent the button from acting as a hyperlink.

◆ SetIconIndex()

AFX_INLINE void SetIconIndex ( int nIconIndex )

Sets the icon index for the button.

Parameters
nIconIndex Icon index to be set.

Icons should be added to the image manager of the property grid prior to using this method.

See also
GetImage, GetIconIndex, CXTPPropertyGrid::GetImageManager

◆ SetShowAlways()

AFX_INLINE void SetShowAlways ( BOOL bShowAlways )

Specifies if the button should always be shown.

Parameters
bShowAlways TRUE to always show the button, FALSE to only show the button when the item is selected.
See also
GetShowAlways

◆ SetTooltip()

AFX_INLINE void SetTooltip ( LPCTSTR lpstrTooltip )

Sets the tooltip text for the item.

Parameters
lpstrTooltip Tooltip text to be set.

The tooltip text is displayed when the mouse cursor is over the item.

◆ SetWidth()

void SetWidth ( int nWidth )

Sets the width for the button.

Parameters
nWidth Width to be set.
See also
GetWidth
The documentation for this class was generated from the following file:
  • XTPPropertyGridInplaceButton.h


Toolkit Pro: CXTPPropertyGridInplaceButtons Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPPropertyGridInplaceButtons Class Reference

CXTPPropertyGridInplaceButtons is a CXTPCmdTarget derived class. More...

Inheritance diagram for CXTPPropertyGridInplaceButtons:
[legend]

Public Member Functions

CXTPPropertyGridInplaceButtons (CXTPPropertyGridItem *pItem)
Constructs a CXTPPropertyGridInplaceButtons object.
~CXTPPropertyGridInplaceButtons ()
Destroys a CXTPPropertyGridInplaceButtons object, handles cleanup and deallocation.
void | AddComboButton ()
Adds a standard combo button to the collection.
void | AddExpandButton ()
Adds a standard expand button to the collection.
CXTPPropertyGridInplaceButton * | AddButton (CXTPPropertyGridInplaceButton *pButton)
Adds a custom button to the collection.
int | GetCount () const
Gets the number of buttons in the collection.
CXTPPropertyGridInplaceButton * | GetAt (int nIndex) const
Retrieves the button at a specified index within the collection.
void | RemoveAll ()
Removes all buttons from the collection.
void | Remove (CXTPPropertyGridInplaceButton *pButton)
Removes a specified button from the collection.
void | Remove (UINT nID)
Removes the button with a specified identifier from the collection.
void | RemoveAt (long nIndex)
Removes the button at a specified index within the collection.
CXTPPropertyGridInplaceButton * | HitTest (CPoint point) const
Determines which button, if any, is at a specified position.
CXTPPropertyGridInplaceButton * | Find (UINT nID) const
Retrieves the button with a specified identifier within the collection.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

virtual void OnButtonRemoved (CXTPPropertyGridInplaceButton *pButton)
This method is called when a button is removed.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

CXTPPropertyGridInplaceButtons is a CXTPCmdTarget derived class.

It represents a collection of in-place buttons for a specified grid item.

Constructor & Destructor Documentation

◆ CXTPPropertyGridInplaceButtons()

CXTPPropertyGridInplaceButtons ( CXTPPropertyGridItem * pItem )

Constructs a CXTPPropertyGridInplaceButtons object.

Parameters
pItem Pointer to the parent CXTPPropertyGridItem object.

Member Function Documentation

◆ AddButton()

CXTPPropertyGridInplaceButton * AddButton ( CXTPPropertyGridInplaceButton * pButton )

Adds a custom button to the collection.

Parameters
pButton Pointer to the button to add.
Returns
A pointer to the newly added CXTPPropertyGridInplaceButton object.

Example:

pItem->GetInplaceButtons()->AddButton(new CXTPPropertyGridInplaceButton(1));

◆ Find()

CXTPPropertyGridInplaceButton * Find ( UINT nID ) const

Retrieves the button with a specified identifier within the collection.

Parameters
nID Identifier of the button to retrieve.
Returns
A pointer to the CXTPPropertyGridInplaceButton object with the specified identifier if successful, otherwise NULL.

◆ GetAt()

AFX_INLINE CXTPPropertyGridInplaceButton * GetAt ( int nIndex ) const

Retrieves the button at a specified index within the collection.

Parameters
nIndex Index of the button to retrieve.
Returns
A pointer to the CXTPPropertyGridInplaceButton object at the specified index if successful, otherwise NULL.

◆ GetCount()

AFX_INLINE int GetCount ( ) const

Gets the number of buttons in the collection.

Returns
The number of buttons in the collection.

◆ HitTest()

CXTPPropertyGridInplaceButton * HitTest ( CPoint point ) const

Determines which button, if any, is at a specified position.

Parameters
point Point to be tested.
Returns
A pointer to the button at the specified position, if any, otherwise NULL.

◆ OnButtonRemoved()

virtual void OnButtonRemoved ( CXTPPropertyGridInplaceButton * pButton )
protectedvirtual

This method is called when a button is removed.

Parameters
pButton Pointer to the button being removed.

This method removes the possible reference from the property grid to the button in this collection.

◆ Remove() [1/2]

void Remove ( CXTPPropertyGridInplaceButton * pButton )

Removes a specified button from the collection.

Parameters
pButton Pointer to the button to remove.

◆ Remove() [2/2]

void Remove ( UINT nID )

Removes the button with a specified identifier from the collection.

Parameters
nID Identifier of the button to remove.

◆ RemoveAt()

void RemoveAt ( long nIndex )

Removes the button at a specified index within the collection.

Parameters
nIndex Index of the button to remove.
The documentation for this class was generated from the following file:
  • XTPPropertyGridInplaceButton.h


Toolkit Pro: CXTPPropertyGridInplaceControl Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPPropertyGridInplaceControl Class Referenceabstract

CXTPPropertyGridInplaceControl is a CWnd derived class that represents the base class for all items with in-place controls. More...

Inheritance diagram for CXTPPropertyGridInplaceControl:
[legend]

Public Member Functions

CXTPPropertyGridInplaceControl (CXTPPropertyGridItem *pItem)
Constructs a CXTPPropertyGridInplaceControl object.
virtual void | OnCreateWindow (CRect &rcValue)=0
This method is called when an item creates its in-place control.
virtual void | OnDestroyWindow ()
This method is called when an item destroys its in-place control.
virtual void | OnAdjustValueRect (CRect &rcValue)=0
This method is called when an item adjusts the rectangle of its value part.
virtual void | OnValueChanged ()
This method is called when the value of the parent item is changed.
virtual BOOL | OnEditMouseWheel (CEdit *pEdit, short zDelta)
This method is called when the user rolls the mouse wheel while in an edit control.

Protected Attributes

CXTPPropertyGridItem * | m_pItem
Parent item pointer.
int | m_nWidth
Width of in-place item.

Detailed Description

CXTPPropertyGridInplaceControl is a CWnd derived class that represents the base class for all items with in-place controls.

Constructor & Destructor Documentation

◆ CXTPPropertyGridInplaceControl()

CXTPPropertyGridInplaceControl ( CXTPPropertyGridItem * pItem )

Constructs a CXTPPropertyGridInplaceControl object.

Parameters
pItem Pointer to the parent CXTPPropertyGridItem object.

Member Function Documentation

◆ OnAdjustValueRect()

virtual void OnAdjustValueRect ( CRect & rcValue )
pure virtual

This method is called when an item adjusts the rectangle of its value part.

Parameters
rcValue Reference to the bounding rectangle of the value part.
See also
OnCreateWindow

Implemented in CXTPPropertyGridInplaceSlider, and CXTPPropertyGridInplaceSpinButton.

◆ OnCreateWindow()

virtual void OnCreateWindow ( CRect & rcValue )
pure virtual

This method is called when an item creates its in-place control.

Parameters
rcValue Reference to the bounding rectangle of the control.
See also
OnDestroyWindow

Implemented in CXTPPropertyGridInplaceSlider, and CXTPPropertyGridInplaceSpinButton.

◆ OnDestroyWindow()

virtual void OnDestroyWindow ( )
virtual

This method is called when an item destroys its in-place control.

See also
OnCreateWindow

◆ OnEditMouseWheel()

AFX_INLINE BOOL OnEditMouseWheel | ( | CEdit * | pEdit,
 |  | short | zDelta )
 virtual

This method is called when the user rolls the mouse wheel while in an edit control.

Parameters
pEdit | Pointer to the currently selected edit control.
zDelta | Mouse wheel delta.
Returns
TRUE if successful, otherwise FALSE.

Reimplemented in CXTPPropertyGridInplaceSlider, and CXTPPropertyGridInplaceSpinButton.

The documentation for this class was generated from the following file:
  • XTPPropertyGridInplaceEdit.h


Toolkit Pro: CXTPPropertyGridInplaceControls Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPPropertyGridInplaceControls Class Reference

CXTPPropertyGridInplaceControls is a standalone class that represents a collection of CXTPPropertyGridInplaceControl classes. More...

Public Member Functions

CXTPPropertyGridInplaceControls ()
Constructs a CXTPPropertyGridInplaceControls object.
~CXTPPropertyGridInplaceControls ()
Destroys a CXTPPropertyGridInplaceControls object, handles cleanup and deallocation.
void | RemoveAll ()
Removes all in-place controls from the collection.
int | GetCount () const
Gets the number of controls in the collection.
void | Add (CXTPPropertyGridInplaceControl *pWindow)
Adds an in-place control to the collection.
CXTPPropertyGridInplaceControl * | GetAt (int nIndex)
Retrieves the in-place control at a specified index in the collection.

Protected Attributes

CArray< CXTPPropertyGridInplaceControl *, CXTPPropertyGridInplaceControl * > m_arrControls
Array of controls.

Detailed Description

CXTPPropertyGridInplaceControls is a standalone class that represents a collection of CXTPPropertyGridInplaceControl classes.

Member Function Documentation

◆ Add()

void Add ( CXTPPropertyGridInplaceControl * pWindow )

Adds an in-place control to the collection.

Parameters
pWindow Pointer to the in-place control to add.
See also
GetAt

◆ GetAt()

CXTPPropertyGridInplaceControl * GetAt ( int nIndex )

Retrieves the in-place control at a specified index in the collection.

Parameters
nIndex Index of the control to retrieve.
Returns
A pointer to the in-place control at the specified index in the collection.
See also
GetCount, Add

◆ GetCount()

int GetCount ( ) const

Gets the number of controls in the collection.

Returns
The number of controls in the collection.
See also
GetAt

◆ RemoveAll()

void RemoveAll ( )

Removes all in-place controls from the collection.

See also
Add
The documentation for this class was generated from the following file:
  • XTPPropertyGridInplaceEdit.h


Toolkit Pro: CXTPPropertyGridInplaceEdit Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPPropertyGridInplaceEdit Class Reference

CXTPPropertyGridInplaceEdit is a CEdit derived class. More...

Inheritance diagram for CXTPPropertyGridInplaceEdit:
[legend]

Public Member Functions

CXTPPropertyGridInplaceEdit ()
Constructs a CXTPPropertyGridInplaceEdit object.
virtual | ~CXTPPropertyGridInplaceEdit ()
Destroys a CXTPPropertyGridInplaceEdit object, handles cleanup and deallocation.
virtual void | SetValue (LPCTSTR strValue)
Sets the value for the edit text.
virtual void | HideWindow ()
Hides the in-place edit control.
virtual void | Create (CXTPPropertyGridItem *pItem, CRect rect)
Creates the in-place edit control.
virtual void | DestroyItem ()
This method is called when the parent item is destroyed.
CXTPPropertyGridItem * GetItem ()
Gets the current item.
virtual BOOL | SelectConstraint (int nDirection, BOOL bCycle)
Selects the next constraint value in the specified direction within the edit control.
- Public Member Functions inherited from CXTPMaskEditT< CEdit >
CXTPMaskEditT ()
Constructs a CXTPMaskEditT object.
void | SetUseMask (BOOL bUseMask)
Call this member function to enable or disable the mask for the mask edit control.
BOOL | CanUseMask () const
This member function is called to determine if the mask for the edit control can be used.
void | SetOverType (BOOL bOverType)
This member function is called to enable or disable type over, also known as insert mode.
BOOL | CanOverType () const
This member function is called to determine if type over has been enabled.
BOOL | PosInRange (int iPos) const
This member function is called to determine if the index specified by 'iPos' is a valid index for the currently displayed edit text.
TCHAR | GetPromptChar () const
This member function retrieves the character that is currently used as the mask prompt.
CString | GetPromptString (int nLength) const
This helper member function retrieves the string contains nLength prompt characters.
void | SetPromptChar (TCHAR ch, BOOL bAutoReplace=TRUE)
This member function is called to set the prompt character that is displayed to the user that indicates the field can be edited.
afx_msg BOOL | MaskCut ()
This member function is called to perform a cut operation using the currently selected text.
afx_msg BOOL | MaskCopy ()
This member function is called to perform a copy operation using the currently selected text.
void | MaskReplaceSel (LPCTSTR lpszNewText)
This member function is called to perform a replace operation using the currently selected text.
afx_msg BOOL | MaskPaste ()
This member function is called to perform a paste operation using the current clipboard text.
void | MaskDeleteSel ()
This member function is called to delete the selection.
afx_msg BOOL | MaskClear ()
This member function is called to clear the current text selection.
afx_msg BOOL | MaskUndo ()
This member function is called to undo the previous action.
afx_msg void | MaskSelectAll ()
This member function is called to select all text in the mask edit control.
BOOL | IsModified () const
This member function is called to determine if the text has been modified.
void | SetMaskedText (LPCTSTR lpszMaskedText, int iPos=0, BOOL bUpdateWindow=TRUE)
This method called to set masked text for the edit control.
virtual BOOL | SetEditMask (LPCTSTR lpszMask, LPCTSTR lpszLiteral, LPCTSTR lpszDefault=NULL)
This member function will set the mask for the edit control.
TCHAR | ConvertUnicodeAlpha (TCHAR nChar, BOOL bUpperCase) const
Converts character to Upper/Lower case.
virtual BOOL | CheckChar (TCHAR &nChar, int nPos)
This member function is used internally to validate the character indicated by 'nChar'.
virtual BOOL | ProcessMask (TCHAR &nChar, int nEndPos)
This member function is used internally to process the character passed in by 'nChar' whose index is specified by 'nEndPos'.
virtual BOOL | PreTranslateMessage (MSG *pMsg)
Used by class CWinApp to translate window messages before they are dispatched to theTranslateMessage andDispatchMessage Windows functions.
void | DeleteCharAt (int iPos)
Deletes character in specified position.
void | InsertCharAt (int iPos, TCHAR nChar)
Inserts character to specified position.
BOOL | CopyToClipboard (const CString &strText)
Copies text to system clipboard.
CString | GetMaskedText (int nStartPos=0, int nEndPos=-1) const
Retrieves masked text of the control.

Protected Attributes

CString | m_strValue
Previous item value.
CXTPBrush | m_xtpBrushBack
Background brush.
COLORREF | m_clrBack
Background color.
CXTPPropertyGridView * | m_pGrid
Parent grid view.
CXTPPropertyGridItem * | m_pItem
Current item.
BOOL | m_bDelayCreate
TRUE to create Edit after activate.
BOOL | m_bCreated
TRUE if the Create method was executed.
BOOL | m_bEditMode
TRUE after edit first receive focus.
BOOL | m_bCancel
User cancel edit with Escape.
BOOL | m_bCheckAutoComplete
Check auto-complete.
BOOL | m_bIgnoreEditChanged
TRUE to ignore edit changed notification.
- Protected Attributes inherited from CXTPMaskEditT< CEdit >
int | m_nStartChar
Current position of the first character in the current selection.
int | m_nEndChar
Current position of the first non-selected character past the end of the current selection.
BOOL | m_bUseMask
TRUE to use the edit mask.
BOOL | m_bOverType
TRUE to over type the text, set with VK_INSERT key press.
BOOL | m_bRedo
TRUE to redo, or FALSE to undo.
BOOL | m_bModified
TRUE if mask edit has been modified.
TCHAR | m_chPrompt
Prompt character used to identify the text entry.
CString | m_strMask
Buffer that holds the actual edit mask value.
CString | m_strDefault
Contains the edit controls default display text.
CString | m_strUndoBuffer
Holds the contents of the undo buffer.
CString | m_strRedoBuffer
Holds the contents of the redo buffer.
CString | m_strWindowText
Buffer that holds the actual edit text.
CString | m_strLiteral
Literal format that restricts where the user can enter text.
BOOL | m_bUpdateUndo
TRUE to update undo.

Additional Inherited Members

- Protected Member Functions inherited from CXTPMaskEditT< CEdit >
virtual BOOL OnCommand (WPARAM wParam, LPARAM lParam)
The framework calls this member function when the user selects an item from a menu.

Detailed Description

CXTPPropertyGridInplaceEdit is a CEdit derived class.

It is an internal class used by the property grid control.

Member Function Documentation

◆ Create()

virtual void Create | ( | CXTPPropertyGridItem * | pItem,
 |  | CRect | rect )
 virtual

Creates the in-place edit control.

Parameters
pItem | Pointer to a CXTPPropertyGridItem object.
rect | Specifies the size and position of the item.

◆ GetItem()

AFX_INLINE CXTPPropertyGridItem * GetItem ( )

Gets the current item.

Returns
A pointer to the current item.

◆ SelectConstraint()

virtual BOOL SelectConstraint | ( | int | nDirection,
 |  | BOOL | bCycle )
 virtual

Selects the next constraint value in the specified direction within the edit control.

Parameters
nDirection | Direction for the constraint search.
bCycle | TRUE to enable starting from the opposite end of the constraint list in case either the beginning or end of the constraint list is reached in the specified direction.
Returns
TRUE if successful, otherwise FALSE.

◆ SetValue()

virtual void SetValue ( LPCTSTR strValue )
virtual

Sets the value for the edit text.

Parameters
strValue Value to be set.
The documentation for this class was generated from the following file:
  • XTPPropertyGridInplaceEdit.h


Toolkit Pro: CXTPPropertyGridInplaceList Class Reference

Public Member Functions | Static Public Attributes | Protected Member Functions | List of all members
CXTPPropertyGridInplaceList Class Reference

CXTPPropertyGridInplaceList is a CListBox derived class. More...

Public Member Functions

CXTPPropertyGridInplaceList ()
Constructs a CXTPPropertyGridInplaceList object.
virtual | ~CXTPPropertyGridInplaceList ()
Destroys a CXTPPropertyGridInplaceList object, handles cleanup and deallocation.
virtual void | Create (CXTPPropertyGridItem *pItem, CRect rect)
Creates an in-place list control.
virtual void | DestroyItem ()
This method is called when the parent item is destroyed.

Static Public Attributes

static BOOL | m_bShowShadow
TRUE to show shadow for inplace list.
static BOOL | m_bTrackSelection
TRUE to select on Mouse move.

Protected Member Functions

virtual void | Cancel ()
Call this method to cancel user changes.
virtual void | Apply ()
Call this method to apply user changes.

Detailed Description

CXTPPropertyGridInplaceList is a CListBox derived class.

It is an internal class used by the property grid control.

Member Function Documentation

◆ Create()

virtual void Create | ( | CXTPPropertyGridItem * | pItem,
 |  | CRect | rect )
 virtual

Creates an in-place list control.

Parameters
pItem | Pointer to the parent item of the list.
rect | Specifies the size and position of the item.
The documentation for this class was generated from the following file:
  • XTPPropertyGridInplaceList.h


Toolkit Pro: CXTPPropertyGridInplaceMonthCal Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPPropertyGridInplaceMonthCal Class Reference

Month calendar pop-up used for CXTPPropertyGridItemDate item. More...

Public Member Functions

CXTPPropertyGridInplaceMonthCal (CXTPPropertyGridItemDate *pItem)
Constructs a CXTPPropertyGridInplaceMonthCal object.
BOOL GetMinReqRect (RECT *pRect) const
Gets the minimal size required to display one month.

Protected Member Functions

void | OnAccept ()
This method is called if the user hits the Enter/Return key while an in-place calendar is displayed or if an item in the in-place calendar is selected.
void | OnCancel ()
This method is called if the user hits the Escape Key or clicks either another part of the property grid or another application while the in-place calendar is displayed.

Protected Attributes

CXTPPropertyGridItemDate * m_pItem
Parent item.

Detailed Description

Month calendar pop-up used for CXTPPropertyGridItemDate item.

Constructor & Destructor Documentation

◆ CXTPPropertyGridInplaceMonthCal()

CXTPPropertyGridInplaceMonthCal ( CXTPPropertyGridItemDate * pItem )
inline

Constructs a CXTPPropertyGridInplaceMonthCal object.

Parameters
pItem Pointer to the parent item.

Member Function Documentation

◆ GetMinReqRect()

AFX_INLINE BOOL GetMinReqRect ( RECT * pRect ) const

Gets the minimal size required to display one month.

Parameters
pRect Pointer to a RECT structure to receive the minimal size required to display one month. This parameter must be a valid address and cannot be NULL.

This member function implements the behavior of the CMonthCalCtrl::GetMinReqRect function.

Returns
Nonzero if successful, otherwise 0.

◆ OnAccept()

void OnAccept ( )
protected

This method is called if the user hits the Enter/Return key while an in-place calendar is displayed or if an item in the in-place calendar is selected.

See also
OnCancel

◆ OnCancel()

void OnCancel ( )
protected

This method is called if the user hits the Escape Key or clicks either another part of the property grid or another application while the in-place calendar is displayed.

See also
OnAccept
The documentation for this class was generated from the following file:
  • XTPPropertyGridItemExt.h


Toolkit Pro: CXTPPropertyGridInplaceMultilineEdit Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPPropertyGridInplaceMultilineEdit Class Reference

CXTPPropertyGridInplaceMultilineEdit is a CEdit derived class. More...

Public Member Functions

CXTPPropertyGridInplaceMultilineEdit ()
Constructs a CXTPPropertyGridInplaceList object.
virtual | ~CXTPPropertyGridInplaceMultilineEdit ()
Destroys a CXTPPropertyGridInplaceList object, handles cleanup and deallocation.
virtual void | Create (CXTPPropertyGridItem *pItem, CRect rect)
Creates an in-place control.

Protected Member Functions

virtual void | Cancel ()
Call this method to cancel user changes.
virtual void | Apply ()
Call this method to apply user changes.

Detailed Description

CXTPPropertyGridInplaceMultilineEdit is a CEdit derived class.

It is an internal class used by the property grid control.

Member Function Documentation

◆ Create()

virtual void Create | ( | CXTPPropertyGridItem * | pItem,
 |  | CRect | rect )
 virtual

Creates an in-place control.

Parameters
pItem | Pointer to the parent item of the control.
rect | Specifies the size and position of the item.
The documentation for this class was generated from the following file:
  • XTPPropertyGridInplaceList.h


Toolkit Pro: CXTPPropertyGridInplaceSlider Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPPropertyGridInplaceSlider Class Reference

CXTPPropertyGridInplaceSlider is a CXTPPropertyGridInplaceControl derived class. More...

Inheritance diagram for CXTPPropertyGridInplaceSlider:
[legend]

Public Member Functions

CXTPPropertyGridInplaceSlider (CXTPPropertyGridItem *pItem)
Constructs a CXTPPropertyGridInplaceSlider object.
virtual void | OnCreateWindow (CRect &rcValue)
This method is called when an item creates its in-place control.
virtual void | OnAdjustValueRect (CRect &rcValue)
This method is called when an item adjusts the rectangle of its value part.
virtual void | OnValueChanged ()
This method is called when the value of the parent item is changed.
CSliderCtrl * | GetSliderCtrl () const
Gets the slider control.
void | SetMin (int nMin)
Sets the lower range for the slider control.
void | SetMax (int nMax)
Sets the upper range for the slider control.
int | GetMin () const
Gets the lower range of the slider control.
int | GetMax () const
Gets the upper range of the slider control.
virtual BOOL | OnEditMouseWheel (CEdit *pEdit, short zDelta)
This method is called when the user rolls the mouse wheel while in an edit control.
- Public Member Functions inherited from CXTPPropertyGridInplaceControl
CXTPPropertyGridInplaceControl (CXTPPropertyGridItem *pItem)
Constructs a CXTPPropertyGridInplaceControl object.
virtual void | OnDestroyWindow ()
This method is called when an item destroys its in-place control.

Protected Member Functions

virtual void OnScroll (UINT nSBCode, UINT nPos)
This method is called when the slider is moved by the user.

Protected Attributes

int | m_nMin
Lower range.
int | m_nMax
Upper range.
int | m_nValue
Value of the slider.
- Protected Attributes inherited from CXTPPropertyGridInplaceControl
CXTPPropertyGridItem * | m_pItem
Parent item pointer.
int | m_nWidth
Width of in-place item.

Detailed Description

CXTPPropertyGridInplaceSlider is a CXTPPropertyGridInplaceControl derived class.

It represents the in-place slider of an item. Call the CXTPPropertyGridItem::AddSliderControl() method to add a slider to a property grid item.

Constructor & Destructor Documentation

◆ CXTPPropertyGridInplaceSlider()

CXTPPropertyGridInplaceSlider ( CXTPPropertyGridItem * pItem )

Constructs a CXTPPropertyGridInplaceSlider object.

Parameters
pItem Pointer to the parent CXTPPropertyGridItem object.

Member Function Documentation

◆ GetMax()

AFX_INLINE int GetMax ( ) const

Gets the upper range of the slider control.

Returns
The upper range of the slider control.

◆ GetMin()

AFX_INLINE int GetMin ( ) const

Gets the lower range of the slider control.

Returns
The lower range of the slider control.

◆ GetSliderCtrl()

AFX_INLINE CSliderCtrl * GetSliderCtrl ( ) const

Gets the slider control.

Returns
A pointer to the slider control.

◆ OnAdjustValueRect()

virtual void OnAdjustValueRect ( CRect & rcValue )
virtual

This method is called when an item adjusts the rectangle of its value part.

Parameters
rcValue Reference to the bounding rectangle of the value part.
See also
OnCreateWindow

Implements CXTPPropertyGridInplaceControl.

◆ OnCreateWindow()

virtual void OnCreateWindow ( CRect & rcValue )
virtual

This method is called when an item creates its in-place control.

Parameters
rcValue Reference to the bounding rectangle of the control.
See also
OnDestroyWindow

Implements CXTPPropertyGridInplaceControl.

◆ OnEditMouseWheel()

virtual BOOL OnEditMouseWheel | ( | CEdit * | pEdit,
 |  | short | zDelta )
 virtual

This method is called when the user rolls the mouse wheel while in an edit control.

Parameters
pEdit | Pointer to the currently selected edit control.
zDelta | Mouse wheel delta.
Returns
TRUE if successful, otherwise FALSE.

Reimplemented from CXTPPropertyGridInplaceControl.

◆ OnScroll()

virtual void OnScroll | ( | UINT | nSBCode,
 |  | UINT | nPos )
 protectedvirtual

This method is called when the slider is moved by the user.

Parameters
nSBCode | Slider code that indicates the user's scrolling request.
nPos | Current slider position.

◆ SetMax()

AFX_INLINE void SetMax ( int nMax )

Sets the upper range for the slider control.

Parameters
nMax Upper range to be set.
See also
SetMin

◆ SetMin()

AFX_INLINE void SetMin ( int nMin )

Sets the lower range for the slider control.

Parameters
nMin Lower range to be set.
See also
SetMax
The documentation for this class was generated from the following file:
  • XTPPropertyGridInplaceEdit.h


Toolkit Pro: CXTPPropertyGridInplaceSpinButton Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPPropertyGridInplaceSpinButton Class Reference

CXTPPropertyGridInplaceSpinButton is a CXTPPropertyGridInplaceControl derived class. More...

Inheritance diagram for CXTPPropertyGridInplaceSpinButton:
[legend]

Public Member Functions

CXTPPropertyGridInplaceSpinButton (CXTPPropertyGridItem *pItem)
Constructs a CXTPPropertyGridInplaceSpinButton object.
virtual void | OnCreateWindow (CRect &rcValue)
This method is called when an item creates its in-place control.
virtual void | OnAdjustValueRect (CRect &rcValue)
This method is called when an item adjusts the rectangle of its value part.
virtual void | OnValueChanged ()
This method is called when the value of the parent item is changed.
CSpinButtonCtrl * | GetSpinButtonCtrl () const
Gets the spin button control.
void | SetMin (int nMin)
Sets the lower range for the spin button control.
void | SetMax (int nMax)
Sets the upper range for the spin button control.
int | GetMin () const
Gets the lower range of the spin button control.
int | GetMax () const
Gets the upper range of the spin button control.
virtual BOOL | OnEditMouseWheel (CEdit *pEdit, short zDelta)
This method is called when the user rolls the mouse wheel while in an edit control.
- Public Member Functions inherited from CXTPPropertyGridInplaceControl
CXTPPropertyGridInplaceControl (CXTPPropertyGridItem *pItem)
Constructs a CXTPPropertyGridInplaceControl object.
virtual void | OnDestroyWindow ()
This method is called when an item destroys its in-place control.

Protected Attributes

int | m_nMin
Lower range.
int | m_nMax
Upper range.
- Protected Attributes inherited from CXTPPropertyGridInplaceControl
CXTPPropertyGridItem * | m_pItem
Parent item pointer.
int | m_nWidth
Width of in-place item.

Detailed Description

CXTPPropertyGridInplaceSpinButton is a CXTPPropertyGridInplaceControl derived class.

It represents the in-place spin button of an item. Call the CXTPPropertyGridItem::AddSpinButton() method to add a spin button to a property grid item.

Constructor & Destructor Documentation

◆ CXTPPropertyGridInplaceSpinButton()

CXTPPropertyGridInplaceSpinButton ( CXTPPropertyGridItem * pItem )

Constructs a CXTPPropertyGridInplaceSpinButton object.

Parameters
pItem Pointer to the parent CXTPPropertyGridItem object.

Member Function Documentation

◆ GetMax()

AFX_INLINE int GetMax ( ) const

Gets the upper range of the spin button control.

Returns
The upper range of the spin button control.

◆ GetMin()

AFX_INLINE int GetMin ( ) const

Gets the lower range of the spin button control.

Returns
The lower range of the spin button control.

◆ GetSpinButtonCtrl()

AFX_INLINE CSpinButtonCtrl * GetSpinButtonCtrl ( ) const

Gets the spin button control.

Returns
A pointer to the spin button control.

◆ OnAdjustValueRect()

virtual void OnAdjustValueRect ( CRect & rcValue )
virtual

This method is called when an item adjusts the rectangle of its value part.

Parameters
rcValue Reference to the bounding rectangle of the value part.
See also
OnCreateWindow

Implements CXTPPropertyGridInplaceControl.

◆ OnCreateWindow()

virtual void OnCreateWindow ( CRect & rcValue )
virtual

This method is called when an item creates its in-place control.

Parameters
rcValue Reference to the bounding rectangle of the control.
See also
OnDestroyWindow

Implements CXTPPropertyGridInplaceControl.

◆ OnEditMouseWheel()

virtual BOOL OnEditMouseWheel | ( | CEdit * | pEdit,
 |  | short | zDelta )
 virtual

This method is called when the user rolls the mouse wheel while in an edit control.

Parameters
pEdit | Pointer to the currently selected edit control.
zDelta | Mouse wheel delta.
Returns
TRUE if successful, otherwise FALSE.

Reimplemented from CXTPPropertyGridInplaceControl.

◆ SetMax()

AFX_INLINE void SetMax ( int nMax )

Sets the upper range for the spin button control.

Parameters
nMax Upper range to be set.
See also
SetMin

◆ SetMin()

AFX_INLINE void SetMin ( int nMin )

Sets the lower range for the spin button control.

Parameters
nMin Lower range to be set.
See also
SetMax
The documentation for this class was generated from the following file:
  • XTPPropertyGridInplaceEdit.h


Toolkit Pro: CXTPPropertyGridItem Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPPropertyGridItem Class Reference

CXTPPropertyGridItem is the base class representing an item of the Property Grid control. More...

Inheritance diagram for CXTPPropertyGridItem:
[legend]

Public Member Functions

CXTPPropertyGridItem (LPCTSTR lpszCaption, LPCTSTR strValue=NULL, CString *pBindString=NULL)
Constructs a CXTPPropertyGridItem object.
CXTPPropertyGridItem (UINT nID, LPCTSTR strValue=NULL, CString *pBindString=NULL)
Constructs a CXTPPropertyGridItem object.
virtual | ~CXTPPropertyGridItem ()
Destroys a CXTPPropertyGridItem object, handles cleanup and deallocation.
void | SetCaption (LPCTSTR lpszCaption)
Sets the caption text for the item.
void | SetPrompt (LPCTSTR lpszPrompt)
Loads a string from a STRINGTABLE resource to set the caption and description for the item.
void | SetDescription (LPCTSTR lpszDescription)
Sets the description text for the item.
void | SetMarkupTemplate (LPCTSTR lpstrMarkupTemplate)
Sets the markup text for the item.
void | SetTooltip (LPCTSTR lpstrTooltip)
Sets the tooltip text for the item.
CString | GetTooltip () const
Gets the tooltip text of the item.
virtual void | SetReadOnly (BOOL bReadOnly=TRUE)
Specifies if the item state should be set to read-only or to read/write.
void | SetID (UINT nID)
Sets the identifier for the item.
void | SetFlags (UINT nFlags)
Sets a specific flag for the item.
CString | GetCaption () const
Gets the caption text of the item.
CString | GetDescription () const
Gets the description text of the item.
virtual CString | GetMarkupTemplate () const
Gets the markup text of the item.
virtual BOOL | GetReadOnly () const
Determines if the item state is set to read-only or to read/write.
virtual BOOL | IsAllowEdit () const
Determines if items in the property grid are allowed to be edited by the user.
UINT | GetID () const
Gets the identifier of the item.
int | GetIndex () const
Gets the index of the item within the property grid list.
CString | GetValue () const
Gets the value of the item.
CString | GetDefaultValue () const
Gets the default value of the item.
UINT | GetFlags () const
Gets the flags of the item.
BOOL | IsCategory () const
Determines if the item is a category.
CXTPPropertyGridItem * | AddChildItem (CXTPPropertyGridItem *pItem)
Adds a child item.
void | Move (CXTPPropertyGridItem *pParent, int nIndex=-1)
Moves the item to another category.
CXTPPropertyGridItem * | InsertChildItem (int nIndex, CXTPPropertyGridItem *pItem)
Inserts a child item.
BOOL | HasChilds () const
Determines if the item has children.
BOOL | HasVisibleChilds () const
Determines if the item has visible children.
CXTPPropertyGridItems * | GetChilds () const
Gets the item's list of child items.
BOOL | HasParent (CXTPPropertyGridItem *pParent)
Determines if the item has a specified item as a parent.
CXTPPropertyGridItemConstraints * | GetConstraints () const
Gets the item's list of constraints.
void | SetConstraintEdit (BOOL bConstraintEdit=TRUE)
Enables/disables constraint editing mode.
void | SetAutoComplete (BOOL bAutoComplete=TRUE)
Enables/disables auto-complete for the constraint list.
BOOL | GetConstraintEdit () const
Determines if constraint editing mode is enabled/disabled.
void | Expand ()
Expands the item.
void | Collapse ()
Collapses the item.
void | SetExpandable (BOOL bExpandable)
Specifies if the item should be expandable by the user.
BOOL | IsExpandable () const
Determines if the item is expandable by the user.
void | Select ()
Selects the item.
CRect | GetItemRect () const
Gets the bounding rectangle of the item.
virtual CRect | GetValueRect ()
Gets the bounding rectangle of the item value's text.
virtual void | SetValue (CString strValue)
Sets the value of the item.
void | SetHidden (BOOL bHidden)
Hides/shows the item.
BOOL | IsHidden () const
Determines if the item is hidden/shown.
virtual void | OnValueChanged (CString strValue)
This method is called when the value of the item is changed.
virtual void | OnMarkupChanged ()
This method is called when the markup text of the item is changed.
CXTPPropertyGridView * | GetGrid () const
Gets the parent window.
BOOL | IsVisible () const
Determines the visible state of the item.
BOOL | IsExpanded () const
Determines the expanded state of the item.
CXTPPropertyGridItem * | GetParentItem () const
Gets the parent item of this item, if any.
int | GetIndent () const
Gets the indent of the item.
virtual BOOL | OnDrawItemValue (CDC &dc, CRect rcValue)
This method is called when an item is drawn.
virtual void | OnDrawItemConstraint (CDC *pDC, CXTPPropertyGridItemConstraint *pConstraint, CRect rc, BOOL bSelected)
This method is called when a constraint in an in-place list is drawn.
virtual CSize | OnMergeItemConstraint (CDC *pDC, CXTPPropertyGridItemConstraint *pConstraint)
This method is called to get size of constraint in in-place list.
virtual void | MeasureItem (LPMEASUREITEMSTRUCT lpMeasureItemStruct)
Override this method and fill in a specified MEASUREITEMSTRUCT structure to inform Windows of the list-box dimensions.
BOOL | IsSelected () const
Determines the selected stae of the item.
void | BindToString (CString *pBindString)
Binds the item to a specified CString object.
void | Remove ()
Removes this item.
void | SetMask (LPCTSTR strMask, LPCTSTR strLiteral, TCHAR chPrompt=_T('_'))
Applies a specified mask to a CXTPPropertyGridItem data field to create a restrictive field for text entry.
void | SetPasswordMask (TCHAR chMask=_T(' *'))
Sets a password mask for the item.
CString | GetMaskedText () const
Gets the actual text value of the item without mask characters.
virtual BOOL | IsValueChanged () const
Determines if the value of the item was changed by the user.
virtual void | ResetValue ()
Resets the value of the item to its default value.
void | SetDefaultValue (LPCTSTR lpszDefaultValue)
Sets the default value for the item.
void | SetMaskedText (LPCTSTR lpszMaskedText)
Sets the actual text value for the item without mask characters.
virtual CString | GetViewValue ()
Gets the value of the item that the user is currently viewing.
void | SetItemData (DWORD_PTR dwData)
Sets the 32-bit value associated with the item.
DWORD_PTR | GetItemData () const
Gets the application-supplied, 32-bit value associated with the item.
virtual CXTPPropertyGridInplaceEdit & | GetInplaceEdit ()
Gets the in-place edit control of the item.
virtual void | SetFocusToInplaceControl ()
Sets focus to the in-place control of the item.
virtual BOOL | IsInplaceButtonVisible (CXTPPropertyGridInplaceButton *pButton) const
Determines if a specified in-place button is visible.
CXTPPropertyGridInplaceButtons * | GetInplaceButtons () const
Gets the collection of in-place buttons of the item.
CXTPPropertyGridInplaceControls * | GetInplaceControls () const
Gets the collection of in-place controls of the item.
void | AddComboButton ()
Adds a standard combo button.
void | AddExpandButton ()
Adds a standard expand button.
CXTPPropertyGridInplaceSlider * AddSliderControl ()
Adds a slider control.
CXTPPropertyGridInplaceSpinButton * AddSpinButton ()
Adds a spin button control.
CXTPPropertyGridItemMetrics * | GetValueMetrics () const
Gets the metrics of the value part.
CXTPPropertyGridItemMetrics * | GetCaptionMetrics () const
Gets the metrics of the caption part.
CXTPPropertyGridItemMetrics * | GetMetrics (BOOL bValueMetrics, BOOL bCreate=TRUE) const
Gets the metrics of the value/caption part.
int | GetHeight () const
Gets the variable height of the item.
void | SetHeight (int nHeight)
Sets the variable height of the item.
BOOL | IsMultiLine () const
Determines if the item is multi-line (i.e.
int | GetMultiLinesCount () const
Gets the number of lines of the item.
void | SetMultiLinesCount (int nLinesCount)
Sets the number of lines for the item.
void | EnsureVisible ()
Ensures that this item is visible.
virtual BOOL | OnRequestEdit ()
This method is called before the user begins editing the item.
virtual BOOL | OnAfterEdit (CString &strValue)
This method is called before the user applies a new value to the item.
virtual void | OnCancelEdit ()
This method is called if the user cancels editing the item.
void | SetEditStyle (DWORD dwEditStyle)
Sets the edit style for the item.
void | SetDropDownItemCount (int nDropDownItemCount)
Sets the number of items in the dropdown list.
int | GetDropDownItemCount () const
Gets the number of items in the dropdown list.
virtual void | OnValidateEdit ()
This method is called to check the value from the in-place edit control.
CXTPMarkupUIElement * | GetMarkupCaption () const
Gets the CXTPMarkupUIElement object that renders the caption of the item.
CXTPMarkupUIElement * | GetMarkupDescription () const
Gets the CXTPMarkupUIElement object that renders the description of the item in the Help pane.
CXTPMarkupUIElement * | GetMarkupValue () const
Gets the CXTPMarkupUIElement object that renders the value of the item in the property grid.
virtual DWORD | GetEditStyle () const
Gets the edit style of the item.
void | RedrawItem ()
Redraws the item.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

virtual void | SetVisible (BOOL bVisible)
Sets the visible state of the item.
virtual void | OnIndexChanged ()
This method is called when the index of the item is changed.
virtual void | OnSelect ()
This method is called when an item is selected.
virtual void | OnDeselect ()
This method is called when an item is de-selected.
virtual BOOL | OnChar (UINT nChar)
This method is called when a key is pressed.
virtual void | OnLButtonDblClk (UINT nFlags, CPoint point)
This method is called when the user double-clicks the left mouse button on the item.
virtual void | OnRButtonDown (UINT nFlags, CPoint point)
This method is called when the user presses the right mouse button on the item.
virtual BOOL | OnLButtonDown (UINT nFlags, CPoint point)
This method is called when the user presses the left mouse button on the item.
virtual void | OnLButtonUp (UINT nFlags, CPoint point)
This method is called when the user releases the left mouse button on the item.
virtual BOOL | OnKeyDown (UINT nChar)
This method is called when a non-system key is pressed.
virtual void | OnAddChildItem ()
This method is called when an item is added to the parent.
virtual void | OnInplaceButtonDown (CXTPPropertyGridInplaceButton *pButton)
This method is called when the user presses the in-place button.
virtual CXTPPropertyGridInplaceList & | GetInplaceList ()
Gets the in-place list control of the item.
virtual void | SetEditText (const CString &str)
Sets the text for the in-place edit control.
virtual void | OnBeforeInsert ()
This method is called before the item becomes visible in the property grid.
virtual void | OnConstraintsChanged ()
This method is called when constraints are added to the item (i.e.
virtual void | OnCaptionChanged ()
This method is called when the caption of the item is changed.
virtual BOOL | OnInpaceControlFocus (BOOL bForward)
This method is called by the property grid to set focus to an in-place child window.
virtual CString | GetInPlacedEditValue ()
Gets the text of the in-place edit control.
void | NotifyValueChanged ()
This method is called when the item's value is changed.
BOOL | SelectNextConstraint ()
Selects the next constraint in the list of constraints.
BOOL | PtInValueRect (CPoint point)
Determines if a specified point is within the value rectangle.

Protected Attributes

BOOL | m_bConstraintEdit
TRUE to constraint edit.
int | m_nIndex
Index of the item.
int | m_nIndent
Indent of the item.
UINT | m_nID
Identifier of the item.
UINT | m_nFlags
Item's flags.
BOOL | m_bReadOnly
TRUE if the item state is set to read-only, FALSE if the item state is set to read/write.
BOOL | m_bVisible
Visibility of the item.
BOOL | m_bCategory
TRUE if the item is a category.
BOOL | m_bExpandable
TRUE if the item can be expanded.
BOOL | m_bExpanded
TRUE if the item is expanded.
CString | m_strValue
Value of the item.
CString | m_strDefaultValue
Default value of the item.
CString | m_strCaption
Caption of the item.
CString | m_strDescription
Description of the item.
CString | m_strTooltip
Tooltip text.
CXTPPropertyGridItem * | m_pParent
Parent item.
CXTPPropertyGridView * | m_pGrid
Parent grid class.
CXTPPropertyGridItems * | m_pChilds
Child items.
CXTPPropertyGridItemConstraints * | m_pConstraints
Item's constraints.
BOOL | m_bAutoComplete
TRUE to enable auto-complete for the item.
CXTPPropertyGridItemMetrics * | m_pValueMetrics
Value part metrics.
CXTPPropertyGridItemMetrics * | m_pCaptionMetrics
Caption part metrics.
CXTPPropertyGridInplaceButtons * | m_pInplaceButtons
In-place buttons array.
CXTPPropertyGridInplaceControls * | m_pInplaceControls
In-place controls array.
int | m_nDropDownItemCount
Maximum drop down items.
CString * | m_pBindString
Bound string.
CString | m_strFormat
Format of the double value.
CString | m_strMask
String to use as edit mask.
CString | m_strLiteral
String to use as literal.
CString | m_strMarkupTemplate
String that represents item's display when markup is on.
TCHAR | m_chPrompt
Character used as a space holder for a character.
BOOL | m_bUseMask
TRUE to use an edit mask to display item data.
BOOL | m_bPassword
TRUE to use a password mask.
DWORD_PTR | m_dwData
The 32-bit value associated with the item.
BOOL | m_bHidden
TRUE if the item is hidden, FALSE if the item is shown.
int | m_nHeight
Item's height; -1 to use the default.
int | m_nLinesCount
Number of lines in a multi-line item.
DWORD | m_dwEditStyle
Edit style.
CXTPMarkupUIElement * | m_pMarkupCaption
Markup UIElement for item's caption.
CXTPMarkupUIElement * | m_pMarkupDescription
Markup UIElement for item's description.
CXTPMarkupUIElement * | m_pMarkupValue
Markup UIElement for item's value.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

CXTPPropertyGridItem is the base class representing an item of the Property Grid control.

Constructor & Destructor Documentation

◆ CXTPPropertyGridItem() [1/2]

CXTPPropertyGridItem | ( | LPCTSTR | lpszCaption,
 |  | LPCTSTR | strValue = NULL,
 |  | CString * | pBindString = NULL )

Constructs a CXTPPropertyGridItem object.

Parameters
lpszCaption | Caption of the item.
strValue | Initial value of the item.
pBindString | If not NULL, then the value of this item is bound the value of this variable.

Class CXTPPropertyGridItem has no default constructor.

When using the second constructor, the Identifier (nID) of the second constructor can be linked with a STRINGTABLE resource with the same ID in such form "Caption\\nDescription".

BINDING: Variables can be bound to an item in two ways, the first is to pass in a variable at the time of creation, the second allows variables to be bound to an item after creation with the BindToString member.

Bound variables store the values of the property grid items and can be accessed without using the property grid methods and properties. Bound variables allow the property grid to store data in variables. When the value of a PropertyGridItem is changed, the value of the bound variable will be changed to the PropertyGridItem value. The advantage of binding is that the variable can be used and manipulated without using PropertyGridItem methods and properties.

NOTE: If the value of the variable is changed without using the PropertyGrid, the PropertyGridItem value will not be updated until you call CXTPPropertyGrid::Refresh.

See also
BindToString

◆ CXTPPropertyGridItem() [2/2]

CXTPPropertyGridItem | ( | UINT | nID,
 |  | LPCTSTR | strValue = NULL,
 |  | CString * | pBindString = NULL )

Constructs a CXTPPropertyGridItem object.

Parameters
nID | Identifier of the item.
strValue | Initial value of the item.
pBindString | If not NULL, then the value of this item is bound the value of this variable.

Class CXTPPropertyGridItem has no default constructor.

When using the second constructor, the Identifier (nID) of the second constructor can be linked with a STRINGTABLE resource with the same ID in such form "Caption\\nDescription".

BINDING: Variables can be bound to an item in two ways, the first is to pass in a variable at the time of creation, the second allows variables to be bound to an item after creation with the BindToString member.

Bound variables store the values of the property grid items and can be accessed without using the property grid methods and properties. Bound variables allow the property grid to store data in variables. When the value of a PropertyGridItem is changed, the value of the bound variable will be changed to the PropertyGridItem value. The advantage of binding is that the variable can be used and manipulated without using PropertyGridItem methods and properties.

NOTE: If the value of the variable is changed without using the PropertyGrid, the PropertyGridItem value will not be updated until you call CXTPPropertyGrid::Refresh.

See also
BindToString

Member Function Documentation

◆ AddChildItem()

CXTPPropertyGridItem * AddChildItem ( CXTPPropertyGridItem * pItem )

Adds a child item.

Parameters
pItem Pointer to the CXTPPropertyGridItem object to add as a child.
Returns
A pointer to the newly added CXTPPropertyGridItem child object.

◆ AddSliderControl()

CXTPPropertyGridInplaceSlider * AddSliderControl ( )

Adds a slider control.

Returns
A pointer to the newly added CXTPPropertyGridInplaceSlider object.

◆ AddSpinButton()

CXTPPropertyGridInplaceSpinButton * AddSpinButton ( )

Adds a spin button control.

Returns
A pointer to the newly added CXTPPropertyGridInplaceSpinButton object.

◆ BindToString()

void BindToString ( CString * pBindString )

Binds the item to a specified CString object.

Parameters
pBindString Pointer to a CString object.

Variables can be bound to an item in two ways, the first is to pass in a variable at the time of creation, the second allows variables to be bound to an item after creation with the BindToString member.

Bound variables store the values of the property grid items and can be accessed without using the property grid methods and properties. Bound variables allow the property grid to store data in variables. When the value of a PropertyGridItem is changed, the value of the bound variable will be changed to the PropertyGridItem value. The advantage of binding is that the variable can be used and manipulated without using PropertyGridItem methods and properties.

NOTE: If the value of the variable is changed without using the PropertyGrid, the PropertyGridItem value will not be updated until you call CXTPPropertyGrid::Refresh.

◆ GetCaption()

AFX_INLINE CString GetCaption ( ) const

Gets the caption text of the item.

Returns
The caption text of the item.

◆ GetCaptionMetrics()

CXTPPropertyGridItemMetrics * GetCaptionMetrics ( ) const

Gets the metrics of the caption part.

Returns
A pointer to a CXTPPropertyGridItemMetrics object containing the metrics (color, style) of the caption part.
See also
CXTPPropertyGridItemMetrics, GetValueMetrics

◆ GetChilds()

AFX_INLINE CXTPPropertyGridItems * GetChilds ( ) const

Gets the item's list of child items.

Returns
A pointer to the item's list of child items.

◆ GetConstraintEdit()

AFX_INLINE BOOL GetConstraintEdit ( ) const

Determines if constraint editing mode is enabled/disabled.

If constraint editing mode is enabled, then only values from the constraint list can be input to the edit.

Returns
TRUE if constraint editing mode is enabled, FALSE if constraint editing mode is disabled.

◆ GetConstraints()

AFX_INLINE CXTPPropertyGridItemConstraints * GetConstraints ( ) const

Gets the item's list of constraints.

Returns
A pointer to the item's list of constraints.

Example:

 CXTPPropertyGridItemConstraints* pList = pItem->GetConstraints();
See also
CXTPPropertyGridItemConstraints::AddConstraint, OnConstraintsChanged

◆ GetDefaultValue()

AFX_INLINE CString GetDefaultValue ( ) const

Gets the default value of the item.

Returns
The default value of the item.

◆ GetDescription()

AFX_INLINE CString GetDescription ( ) const

Gets the description text of the item.

The description text is displayed in the help panel.

Returns
The description text of the item.

◆ GetDropDownItemCount()

AFX_INLINE int GetDropDownItemCount ( ) const

Gets the number of items in the dropdown list.

Returns
The number of items in the dropdown list.
See also
SetDropDownItemCount

◆ GetEditStyle()

virtual DWORD GetEditStyle ( ) const
virtual

Gets the edit style of the item.

Override this method if you need a custom style.

By default, this method returns WS_CHILD | ES_AUTOHSCROLL.

Returns
The edit style of the item.

◆ GetFlags()

UINT GetFlags ( ) const

Gets the flags of the item.

The value returned by this method should be a member of XTPPropertyGridItemFlags.

Returns
The flags of the item.
See also
XTPPropertyGridItemFlags

◆ GetGrid()

AFX_INLINE CXTPPropertyGridView * GetGrid ( ) const

Gets the parent window.

Returns
A pointer to the parent window.

◆ GetHeight()

AFX_INLINE int GetHeight ( ) const

Gets the variable height of the item.

Returns
The height of the item, or a value of -1 if default values are used.

◆ GetID()

AFX_INLINE UINT GetID ( ) const

Gets the identifier of the item.

Returns
The identifier of the item.

◆ GetIndent()

AFX_INLINE int GetIndent ( ) const

Gets the indent of the item.

Returns
The indent of the item.

◆ GetIndex()

int GetIndex ( ) const

Gets the index of the item within the property grid list.

Returns
The index of the item within the property grid list.

◆ GetInplaceButtons()

CXTPPropertyGridInplaceButtons * GetInplaceButtons ( ) const

Gets the collection of in-place buttons of the item.

Returns
A pointer to the collection of in-place buttons of the item.

◆ GetInplaceControls()

CXTPPropertyGridInplaceControls * GetInplaceControls ( ) const

Gets the collection of in-place controls of the item.

Returns
A pointer to the collection of in-place controls of the item.

◆ GetInPlacedEditValue()

virtual CString GetInPlacedEditValue ( )
inlineprotectedvirtual

Gets the text of the in-place edit control.

It is sometimes useful to override the default behavior of this method.

Returns
Gets the text of the in-place edit control

◆ GetInplaceEdit()

virtual CXTPPropertyGridInplaceEdit & GetInplaceEdit ( )
virtual

Gets the in-place edit control of the item.

Returns
A reference to the in-place edit control of the item.

◆ GetInplaceList()

virtual CXTPPropertyGridInplaceList & GetInplaceList ( )
protectedvirtual

Gets the in-place list control of the item.

Returns
A reference to the in-place list control of the item.

◆ GetItemData()

AFX_INLINE DWORD_PTR GetItemData ( ) const

Gets the application-supplied, 32-bit value associated with the item.

Returns
The 32-bit value associated with the item.

◆ GetItemRect()

CRect GetItemRect ( ) const

Gets the bounding rectangle of the item.

Returns
The bounding rectangle of the item.

◆ GetMarkupCaption()

AFX_INLINE CXTPMarkupUIElement * GetMarkupCaption ( ) const

Gets the CXTPMarkupUIElement object that renders the caption of the item.

Returns
A pointer to the CXTPMarkupUIElement object that renders the caption of the item.

◆ GetMarkupDescription()

AFX_INLINE CXTPMarkupUIElement * GetMarkupDescription ( ) const

Gets the CXTPMarkupUIElement object that renders the description of the item in the Help pane.

Returns
A pointer to the CXTPMarkupUIElement object that renders the description of the item in the Help pane.

◆ GetMarkupTemplate()

AFX_INLINE CString GetMarkupTemplate ( ) const
virtual

Gets the markup text of the item.

Returns
The markup text of the item.

◆ GetMarkupValue()

AFX_INLINE CXTPMarkupUIElement * GetMarkupValue ( ) const

Gets the CXTPMarkupUIElement object that renders the value of the item in the property grid.

Returns
A pointer to the CXTPMarkupUIElement object that renders the value of the item in the property grid.

◆ GetMaskedText()

CString GetMaskedText ( ) const

Gets the actual text value of the item without mask characters.

Mask characters are added by methods such as SetMask.

Returns
The actual text value of the item without mask characters.
See also
SetMaskedText, SetMask

◆ GetMetrics()

CXTPPropertyGridItemMetrics * GetMetrics | ( | BOOL | bValueMetrics,
 |  | BOOL | bCreate = TRUE ) const

Gets the metrics of the value/caption part.

Parameters
bValueMetrics | TRUE to get the metrics of the value part, FALSE to get the metrics of the caption part.
bCreate | TRUE to call the GetValueMetrics/GetCaptionMetrics method to get the metrics of the value/caption part.
Returns
A pointer to a CXTPPropertyGridItemMetrics object containing the metrics (color, style) of the value/caption part.
See also
CXTPPropertyGridItemMetrics, GetValueMetrics

◆ GetMultiLinesCount()

AFX_INLINE int GetMultiLinesCount ( ) const

Gets the number of lines of the item.

Returns
The number of lines of the item.

◆ GetParentItem()

AFX_INLINE CXTPPropertyGridItem * GetParentItem ( ) const

Gets the parent item of this item, if any.

Returns
A pointer to the parent item of this item, if any, otherwise NULL.

◆ GetReadOnly()

AFX_INLINE BOOL GetReadOnly ( ) const
virtual

Determines if the item state is set to read-only or to read/write.

Returns
TRUE if the item state is set to read-only, FALSE if the item state is set to read/write.

◆ GetTooltip()

AFX_INLINE CString GetTooltip ( ) const

Gets the tooltip text of the item.

The tooltip text is displayed when the mouse cursor is over the item.

Returns
The tooltip text of the item.

◆ GetValue()

AFX_INLINE CString GetValue ( ) const

Gets the value of the item.

Returns
The value of the item.

◆ GetValueMetrics()

CXTPPropertyGridItemMetrics * GetValueMetrics ( ) const

Gets the metrics of the value part.

Returns
A pointer to a CXTPPropertyGridItemMetrics object containing the metrics (color, style) of the value part.
See also
CXTPPropertyGridItemMetrics, GetCaptionMetrics

◆ GetValueRect()

virtual CRect GetValueRect ( )
virtual

Gets the bounding rectangle of the item value's text.

Override this method to change it.

Returns
The bounding rectangle of the item value's text.

Reimplemented in CXTPPropertyGridItemColor, and CXTPPropertyGridItemFont.

◆ GetViewValue()

virtual CString GetViewValue ( )
virtual

Gets the value of the item that the user is currently viewing.

The return value of this method includes the formatting used for the value of the item. For example, if a password mask is shown, then the return value of this method would be a CString filled with asterisks (*). Otherwise, if a password mask is not shown, the return value would be the same as the GetValue method.

Returns
The value of the item that the user is currently viewing.

Reimplemented in CXTPPropertyGridItemBool.

◆ HasChilds()

AFX_INLINE BOOL HasChilds ( ) const

Determines if the item has children.

Returns
TRUE if the item has children, otherwise FALSE.

◆ HasParent()

BOOL HasParent ( CXTPPropertyGridItem * pParent )

Determines if the item has a specified item as a parent.

Parameters
pParent Pointer to a CXTPPropertyGridItem object.
Returns
TRUE if the item has the specified item as a parent, otherwise FALSE.

◆ HasVisibleChilds()

BOOL HasVisibleChilds ( ) const

Determines if the item has visible children.

Returns
TRUE if the item has visible children, otherwise FALSE.

◆ InsertChildItem()

CXTPPropertyGridItem * InsertChildItem | ( | int | nIndex,
 |  | CXTPPropertyGridItem * | pItem )

Inserts a child item.

Parameters
pItem | Pointer to the CXTPPropertyGridItem object to insert as a child.
nIndex | Index to insert the item at.
Returns
A pointer to the newly inserted CXTPPropertyGridItem child object.

◆ IsAllowEdit()

virtual BOOL IsAllowEdit ( ) const
virtual

Determines if items in the property grid are allowed to be edited by the user.

Returns
TRUE if items in the property grid are allowed to be edited by the user, FALSE if items in the property grid are not allowed to be edited by the user.

◆ IsCategory()

AFX_INLINE BOOL IsCategory ( ) const

Determines if the item is a category.

Returns
TRUE if the item is a category, otherwise FALSE.

◆ IsExpandable()

AFX_INLINE BOOL IsExpandable ( ) const

Determines if the item is expandable by the user.

Returns
TRUE if the item is expandable by the user, otherwise FALSE.

◆ IsExpanded()

AFX_INLINE BOOL IsExpanded ( ) const

Determines the expanded state of the item.

Returns
TRUE if the item is expanded, otherwise FALSE.

◆ IsHidden()

BOOL IsHidden ( ) const

Determines if the item is hidden/shown.

Returns
TRUE if the item is hidden, FALSE if the item is shown.

◆ IsInplaceButtonVisible()

virtual BOOL IsInplaceButtonVisible ( CXTPPropertyGridInplaceButton * pButton ) const
virtual

Determines if a specified in-place button is visible.

Parameters
pButton Pointer to a CXTPPropertyGridInplaceButton object.
Returns
TRUE if the specified in-place button is visible, otherwise FALSE.
See also
CXTPPropertyGrid::SetShowInplaceButtonsAlways

◆ IsMultiLine()

AFX_INLINE BOOL IsMultiLine ( ) const

Determines if the item is multi-line (i.e.

more than one line).

Returns
TRUE if the item is multi-line, otherwise FALSE.
See also
SetMultiLinesCount

◆ IsSelected()

BOOL IsSelected ( ) const

Determines the selected stae of the item.

Returns
TRUE if the item is selected, otherwise FALSE.

◆ IsValueChanged()

virtual BOOL IsValueChanged ( ) const
virtual

Determines if the value of the item was changed by the user.

Call CXTPPropertyGrid::HighlightChangedItems to highlight all items with changed values.

Returns
TRUE if the value of the item was changed by the user.
See also
CXTPPropertyGrid::HighlightChangedItems, ResetValue, SetDefaultValue

◆ IsVisible()

AFX_INLINE BOOL IsVisible ( ) const

Determines the visible state of the item.

Returns
TRUE if the item is visible, otherwise FALSE.

◆ MeasureItem()

virtual void MeasureItem ( LPMEASUREITEMSTRUCT lpMeasureItemStruct )
virtual

Override this method and fill in a specified MEASUREITEMSTRUCT structure to inform Windows of the list-box dimensions.

Parameters
lpMeasureItemStruct Long pointer to a MEASUREITEMSTRUCT structure.

Reimplemented in CXTPPropertyGridItemOption.

◆ Move()

void Move | ( | CXTPPropertyGridItem * | pParent,
 |  | int | nIndex = -1 )

Moves the item to another category.

Parameters
pParent | Pointer to the category to move the item to.
nIndex | Index to insert the item at.

◆ NotifyValueChanged()

void NotifyValueChanged ( )
protected

This method is called when the item's value is changed.

See also
CXTPPropertyGridItem::OnValueChanged

◆ OnAfterEdit()

virtual BOOL OnAfterEdit ( CString & strValue )
virtual

This method is called before the user applies a new value to the item.

Parameters
strValue Value to be set.
Returns
TRUE to allow the new item value, FALSE to disallow.

◆ OnBeforeInsert()

virtual void OnBeforeInsert ( )
protectedvirtual

This method is called before the item becomes visible in the property grid.

Before the item is inserted, it is first checked to see if it is bound to a variable. If it is, then the value of the item is updated with the value stored in the bound variable.

OnBeforeInsert is called when an item is inserted, when a category is inserted, when a category or item is expanded, and when the sort property has changed.

Reimplemented in CXTPPropertyGridItemBool, CXTPPropertyGridItemColor, CXTPPropertyGridItemDate, CXTPPropertyGridItemDouble, CXTPPropertyGridItemEnum, CXTPPropertyGridItemFlags, CXTPPropertyGridItemNumber, CXTPPropertyGridItemOption, CXTPPropertyGridItemPoint, and CXTPPropertyGridItemSize.

◆ OnChar()

virtual BOOL OnChar ( UINT nChar )
protectedvirtual

This method is called when a key is pressed.

Parameters
nChar Specifies the virtual-key code of the given key.
Returns
TRUE if the key was processed, otherwise FALSE.

◆ OnConstraintsChanged()

AFX_INLINE void OnConstraintsChanged ( )
protectedvirtual

This method is called when constraints are added to the item (i.e.

when CXTPPropertyGridItemConstraints::AddConstraint is called).

See also
CXTPPropertyGridItemConstraints::AddConstraint, GetConstraints

Reimplemented in CXTPPropertyGridItemEnum, and CXTPPropertyGridItemFlags.

◆ OnDrawItemConstraint()

virtual void OnDrawItemConstraint | ( | CDC * | pDC,
 |  | CXTPPropertyGridItemConstraint * | pConstraint,
 |  | CRect | rc,
 |  | BOOL | bSelected )
 virtual

This method is called when a constraint in an in-place list is drawn.

Override this method if needed.

Parameters
pDC | Pointer to the device context to be used for rendering an image of the item.
pConstraint | Pointer to the constraint to be drawn.
rc | Bounding rectangle of the constraint.
bSelected | TRUE if the item is selected.

◆ OnDrawItemValue()

AFX_INLINE BOOL OnDrawItemValue | ( | CDC & | dc,
 |  | CRect | rcValue )
 virtual

This method is called when an item is drawn.

Override this method if needed.

Parameters
dc | Reference to the device context to be used for rendering an image of the item.
rcValue | Bounding rectangle of the item.
Returns
TRUE if the item is self-drawn.

Reimplemented in CXTPPropertyGridItemBool, CXTPPropertyGridItemColor, CXTPPropertyGridItemFont, and CXTPPropertyGridItemOption.

◆ OnInpaceControlFocus()

virtual BOOL OnInpaceControlFocus ( BOOL bForward )
protectedvirtual

This method is called by the property grid to set focus to an in-place child window.

Parameters
bForward TRUE if the user moves focus forward (with Tab), FALSE if the user moves focus backword (with Shift+Tab).
Returns
TRUE if successful, otherwise FALSE.

Reimplemented in CXTPPropertyGridItemOption.

◆ OnInplaceButtonDown()

virtual void OnInplaceButtonDown ( CXTPPropertyGridInplaceButton * pButton )
protectedvirtual

This method is called when the user presses the in-place button.

Override this method to show an item-specific dialog.

Parameters
pButton Pointer to the button that was pressed.

Reimplemented in CXTPPropertyGridItemColor, CXTPPropertyGridItemDate, CXTPPropertyGridItemFont, and CXTPPropertyGridItemMultilineString.

◆ OnKeyDown()

AFX_INLINE BOOL OnKeyDown ( UINT nChar )
protectedvirtual

This method is called when a non-system key is pressed.

Parameters
nChar Specifies the virtual-key code of the given key.
Returns
TRUE if the key was processed, otherwise FALSE.

Reimplemented in CXTPPropertyGridItemBool, and CXTPPropertyGridItemOption.

◆ OnLButtonDblClk()

virtual void OnLButtonDblClk | ( | UINT | nFlags,
 |  | CPoint | point )
 protectedvirtual

This method is called when the user double-clicks the left mouse button on the item.

Parameters
nFlags | Indicates whether various virtual keys are down (see Visual C++ documentation).
point | Specifies the x- and y- coordinates of the cursor.

Reimplemented in CXTPPropertyGridItemBool, and CXTPPropertyGridItemOption.

◆ OnLButtonDown()

virtual BOOL OnLButtonDown | ( | UINT | nFlags,
 |  | CPoint | point )
 protectedvirtual

This method is called when the user presses the left mouse button on the item.

Parameters
nFlags | Indicates whether various virtual keys are down (see Visual C++ documentation).
point | Specifies the x- and y- coordinates of the cursor.
Returns
TRUE if the message was processed, otherwise FALSE.

Reimplemented in CXTPPropertyGridItemBool, and CXTPPropertyGridItemOption.

◆ OnLButtonUp()

virtual void OnLButtonUp | ( | UINT | nFlags,
 |  | CPoint | point )
 protectedvirtual

This method is called when the user releases the left mouse button on the item.

Parameters
nFlags | Indicates whether various virtual keys are down (see Visual C++ documentation).
point | Specifies the x- and y- coordinates of the cursor.

◆ OnMarkupChanged()

virtual void OnMarkupChanged ( )
virtual

This method is called when the markup text of the item is changed.

Override this method if needed.

◆ OnMergeItemConstraint()

virtual CSize OnMergeItemConstraint | ( | CDC * | pDC,
 |  | CXTPPropertyGridItemConstraint * | pConstraint )
 virtual

This method is called to get size of constraint in in-place list.

Override this function if needed.

Parameters
pDC | Reference to the device context to be used for rendering an image of the item.
pConstraint | Constraint to be drawn
Returns
Gets size of constraint in in-place list

◆ OnRButtonDown()

AFX_INLINE void OnRButtonDown | ( | UINT | nFlags,
 |  | CPoint | point )
 protectedvirtual

This method is called when the user presses the right mouse button on the item.

Parameters
nFlags | Indicates whether various virtual keys are down (see Visual C++ documentation).
point | Specifies the x- and y- coordinates of the cursor.

◆ OnRequestEdit()

virtual BOOL OnRequestEdit ( )
virtual

This method is called before the user begins editing the item.

Returns
TRUE to allow the user to edit the item, FALSE to disallow.

◆ OnValueChanged()

virtual void OnValueChanged ( CString strValue )
virtual

This method is called when the value of the item is changed.

Override this method if needed.

Parameters
strValue New value of the item.

Reimplemented in CXTPPropertyGridItemDate.

◆ PtInValueRect()

BOOL PtInValueRect ( CPoint point )
protected

Determines if a specified point is within the value rectangle.

Parameters
point Point to be tested.
Returns
TRUE if the specified point is within the value rectangle, otherwise FALSE.

◆ ResetValue()

virtual void ResetValue ( )
virtual

Resets the value of the item to its default value.

See also
SetDefaultValue, IsValueChanged

◆ SelectNextConstraint()

BOOL SelectNextConstraint ( )
protected

Selects the next constraint in the list of constraints.

Returns
TRUE if successful, otherwise FALSE.

◆ SetAutoComplete()

AFX_INLINE void SetAutoComplete ( BOOL bAutoComplete = TRUE )

Enables/disables auto-complete for the constraint list.

Parameters
bAutoComplete TRUE to enable auto-complete, FALSE to disable auto-complete.

◆ SetCaption()

AFX_INLINE void SetCaption ( LPCTSTR lpszCaption )

Sets the caption text for the item.

Parameters
lpszCaption Caption text to be set.
See also
SetPrompt

◆ SetConstraintEdit()

AFX_INLINE void SetConstraintEdit ( BOOL bConstraintEdit = TRUE )

Enables/disables constraint editing mode.

Parameters
bConstraintEdit TRUE to enable constraint editing mode, FALSE to disable constraint editing mode.

If constraint editing mode is enabled, then only values from the constraint list can be input to the edit.

◆ SetDefaultValue()

void SetDefaultValue ( LPCTSTR lpszDefaultValue )

Sets the default value for the item.

Parameters
lpszDefaultValue Value to be set.
See also
ResetValue, IsValueChanged

◆ SetDescription()

void SetDescription ( LPCTSTR lpszDescription )

Sets the description text for the item.

Parameters
lpszDescription Description text to be set.

The description text is displayed in the help panel.

See also
SetPrompt

◆ SetDropDownItemCount()

AFX_INLINE void SetDropDownItemCount ( int nDropDownItemCount )

Sets the number of items in the dropdown list.

Parameters
nDropDownItemCount Number of items to be set.

◆ SetEditStyle()

AFX_INLINE void SetEditStyle ( DWORD dwEditStyle )

Sets the edit style for the item.

Parameters
dwEditStyle Edit style to be set.

Example:

pItem->SetEditStyle(ES_MULTILINE | ES_AUTOVSCROLL);

◆ SetEditText()

virtual void SetEditText ( const CString & str )
protectedvirtual

Sets the text for the in-place edit control.

Parameters
str Reference to the text to be set.

◆ SetExpandable()

AFX_INLINE void SetExpandable ( BOOL bExpandable )

Specifies if the item should be expandable by the user.

Parameters
bExpandable TRUE to set the item to be expandable by the user, FALSE otherwise.

◆ SetFlags()

void SetFlags ( UINT nFlags )

Sets a specific flag for the item.

Parameters
nFlags Flag to set; can be any of the values listed in the Remarks section.

nFlags value can be one or more of the following: xtpPropertyGridItemHasEdit: Item has an edit control. xtpPropertyGridItemHasExpandButton: Item has an expand button. xtpPropertyGridItemHasComboButton: Item has a combo button.

See also
XTPPropertyGridItemFlags, OnInplaceButtonDown

◆ SetHeight()

void SetHeight ( int nHeight )

Sets the variable height of the item.

Parameters
nHeight Height to be set, or a value of -1 to use default values.

Call CXTPPropertyGrid::SetVariableItemsHeight to use variable height items.

See also
CXTPPropertyGrid::SetVariableItemsHeight, SetMultiLinesCount

◆ SetHidden()

void SetHidden ( BOOL bHidden )

Hides/shows the item.

Parameters
bHidden TRUE to hide the item, FALSE to show the item.

◆ SetID()

AFX_INLINE void SetID ( UINT nID )

Sets the identifier for the item.

Parameters
nID Identifier to be set.

◆ SetItemData()

AFX_INLINE void SetItemData ( DWORD_PTR dwData )

Sets the 32-bit value associated with the item.

Parameters
dwData 32-bit value to associate with the item.

◆ SetMarkupTemplate()

void SetMarkupTemplate ( LPCTSTR lpstrMarkupTemplate )

Sets the markup text for the item.

Parameters
lpstrMarkupTemplate Markup template to display when markup is on. Use the XTP_PG_ITEMVALUE_TO_REPLACE_IN_MARKUP string for the item's plain text value substitution.

◆ SetMask()

void SetMask | ( | LPCTSTR | strMask,
 |  | LPCTSTR | strLiteral,
 |  | TCHAR | chPrompt = _T('_') )

Applies a specified mask to a CXTPPropertyGridItem data field to create a restrictive field for text entry.

Parameters
strMask | Mask of the item.
strLiteral | Defines the prompt area of the mask where text entry is allowed. This value should match the areas that you have already defined as mask fields. By default, the prompt character is '_'.

Phone No: (___) ___-____

Parameters
chPrompt (Optional) This value is the prompt character used in strLiteral to indicate a place holder. By default, this parameter is the underscore '_' character.

You can use any of these characters for defining your edit mask:

Mask Character  Description
---------------------  ------------------------
0                      Numeric (0-9)
9                      Numeric (0-9) or space (' ')
#                      Numeric (0-9) or space (' ') or ('+') or ('-')
L                      Alpha (a-Z)
?                      Alpha (a-Z) or space (' ')
A                      Alpha numeric (0-9 and a-Z)
a                      Alpha numeric (0-9 and a-Z) or space (' ')
&                      All print character only
H                      Uppercase hex digit (0-9 and A-F)
h                      Lowercase hex digit (0-9 and a-f)
X                      Uppercase hex digit (0-9 and A-F) and space (' ')
x                      Lowercase hex digit (0-9 and a-f) and space (' ')
>                      Forces characters to upper case (A-Z) or any Unicode character
<                      Forces characters to lower case (a-z) or any Unicode character
C                      Uppercase ASCII character
c                      Lowercase ASCII character

Any of these characters can be combined with additional characters to create a restrictive field for text entry. For example, if you wanted to display a prompt for a telephone number and wanted to restrict only numeric values, but wanted to display the area code inside of parentheses '(' and ')' then you could define your mask as:

Phone No: (000) 000-0000

See also
GetMaskedText, SetMaskedText

◆ SetMaskedText()

void SetMaskedText ( LPCTSTR lpszMaskedText )

Sets the actual text value for the item without mask characters.

Parameters
lpszMaskedText Text string without mask.

Mask characters are added by methods such as SetMask. If a mask is used, then the mask will be applied to the text string passed through lpszMaskedText.

See also
GetMaskedText, SetMask

◆ SetMultiLinesCount()

void SetMultiLinesCount ( int nLinesCount )

Sets the number of lines for the item.

Parameters
nLinesCount Number of lines to be set.

Call CXTPPropertyGrid::SetVariableItemsHeight to use variable height items.

◆ SetPasswordMask()

AFX_INLINE void SetPasswordMask ( TCHAR chMask = _T('*') )

Sets a password mask for the item.

Parameters
chMask Character to be used as the password mask; by default, this parameter is the asterisk (*) character.

The password mask is the character used to replace the characters of the item's text when displayed. The actual text value of the item can be retrieved by using the GetMaskedText method.

See also
GetMaskedText

◆ SetPrompt()

void SetPrompt ( LPCTSTR lpszPrompt )

Loads a string from a STRINGTABLE resource to set the caption and description for the item.

Parameters
lpszPrompt String from a STRINGTABLE resource that contains the caption and description of the item. The caption and description must be separated by "\\n" if both are included. The description can be omitted in order to only set the caption.

Resource strings are in the format "Caption\\nDescription".

See also
SetCaption, SetDescription

◆ SetReadOnly()

virtual void SetReadOnly ( BOOL bReadOnly = TRUE )
virtual

Specifies if the item state should be set to read-only or to read/write.

Parameters
bReadOnly TRUE to set the item state to read-only, FALSE to set the item state to read/write.

Reimplemented in CXTPPropertyGridItemFlags.

◆ SetTooltip()

AFX_INLINE void SetTooltip ( LPCTSTR lpstrTooltip )

Sets the tooltip text for the item.

Parameters
lpstrTooltip Tooltip text to be set.

The tooltip text is displayed when the mouse cursor is over the item.

◆ SetValue()

virtual void SetValue ( CString strValue )
virtual

Sets the value of the item.

Override this method to add new functionality. You should call the base class version of this function from your override.

Parameters
strValue Value to be set.

Reimplemented in CXTPPropertyGridItemBool, CXTPPropertyGridItemColor, CXTPPropertyGridItemDate, CXTPPropertyGridItemDouble, CXTPPropertyGridItemEnum, CXTPPropertyGridItemFlags, CXTPPropertyGridItemNumber, and CXTPPropertyGridItemOption.

◆ SetVisible()

AFX_INLINE void SetVisible ( BOOL bVisible )
protectedvirtual

Sets the visible state of the item.

Parameters
bVisible TRUE to set the item to visible.

Member Data Documentation

◆ m_bPassword

BOOL m_bPassword
protected

TRUE to use a password mask.

If TRUE, then each character will be replaced with an asterisk (*).

◆ m_chPrompt

TCHAR m_chPrompt
protected

Character used as a space holder for a character.

This is used in m_strLiteral.

◆ m_strLiteral

CString m_strLiteral
protected

String to use as literal.

This is the same as the edit mask, but all mask characters are replaced with m_chPrompt.

◆ m_strMarkupTemplate

CString m_strMarkupTemplate
protected

String that represents item's display when markup is on.

Use XTP_PG_ITEMVALUE_TO_REPLACE_IN_MARKUP for item text value substitution.

The documentation for this class was generated from the following file:
  • XTPPropertyGridItem.h


Toolkit Pro: CXTPPropertyGridItemBool Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPPropertyGridItemBool Class Reference

CXTPPropertyGridItemBool is a CXTPPropertyGridItem derived class. More...

Inheritance diagram for CXTPPropertyGridItemBool:
[legend]

Public Member Functions

CXTPPropertyGridItemBool (LPCTSTR strCaption, BOOL bValue=FALSE, BOOL *pBindBool=NULL)
Constructs a CXTPPropertyGridItemBool object.
CXTPPropertyGridItemBool (UINT nID, BOOL bValue=FALSE, BOOL *pBindBool=NULL)
Constructs a CXTPPropertyGridItemBool object.
virtual | ~CXTPPropertyGridItemBool ()
Destroys a CXTPPropertyGridItemBool object.
virtual void | SetBool (BOOL bValue)
Sets the BOOL value for the item.
virtual BOOL | GetBool () const
Gets the BOOL value of the item.
virtual void | BindToBool (BOOL *pBindBool)
Binds the item to a specified BOOL value.
BOOL | SetTrueFalseText (LPCTSTR strTrueText, LPCTSTR strFalseText)
Sets the values for the TRUE and FALSE labels in the drop list.
void | SetCheckBoxStyle (BOOL bCheckBoxStyle=TRUE)
Specifies if the item should be drawn as a check box frame.
BOOL | IsCheckBoxStyle () const
Determines if the item is drawn as a check box frame.
- Public Member Functions inherited from CXTPPropertyGridItem
CXTPPropertyGridItem (LPCTSTR lpszCaption, LPCTSTR strValue=NULL, CString *pBindString=NULL)
Constructs a CXTPPropertyGridItem object.
CXTPPropertyGridItem (UINT nID, LPCTSTR strValue=NULL, CString *pBindString=NULL)
Constructs a CXTPPropertyGridItem object.
virtual | ~CXTPPropertyGridItem ()
Destroys a CXTPPropertyGridItem object, handles cleanup and deallocation.
void | SetCaption (LPCTSTR lpszCaption)
Sets the caption text for the item.
void | SetPrompt (LPCTSTR lpszPrompt)
Loads a string from a STRINGTABLE resource to set the caption and description for the item.
void | SetDescription (LPCTSTR lpszDescription)
Sets the description text for the item.
void | SetMarkupTemplate (LPCTSTR lpstrMarkupTemplate)
Sets the markup text for the item.
void | SetTooltip (LPCTSTR lpstrTooltip)
Sets the tooltip text for the item.
CString | GetTooltip () const
Gets the tooltip text of the item.
virtual void | SetReadOnly (BOOL bReadOnly=TRUE)
Specifies if the item state should be set to read-only or to read/write.
void | SetID (UINT nID)
Sets the identifier for the item.
void | SetFlags (UINT nFlags)
Sets a specific flag for the item.
CString | GetCaption () const
Gets the caption text of the item.
CString | GetDescription () const
Gets the description text of the item.
virtual CString | GetMarkupTemplate () const
Gets the markup text of the item.
virtual BOOL | GetReadOnly () const
Determines if the item state is set to read-only or to read/write.
virtual BOOL | IsAllowEdit () const
Determines if items in the property grid are allowed to be edited by the user.
UINT | GetID () const
Gets the identifier of the item.
int | GetIndex () const
Gets the index of the item within the property grid list.
CString | GetValue () const
Gets the value of the item.
CString | GetDefaultValue () const
Gets the default value of the item.
UINT | GetFlags () const
Gets the flags of the item.
BOOL | IsCategory () const
Determines if the item is a category.
CXTPPropertyGridItem * | AddChildItem (CXTPPropertyGridItem *pItem)
Adds a child item.
void | Move (CXTPPropertyGridItem *pParent, int nIndex=-1)
Moves the item to another category.
CXTPPropertyGridItem * | InsertChildItem (int nIndex, CXTPPropertyGridItem *pItem)
Inserts a child item.
BOOL | HasChilds () const
Determines if the item has children.
BOOL | HasVisibleChilds () const
Determines if the item has visible children.
CXTPPropertyGridItems * | GetChilds () const
Gets the item's list of child items.
BOOL | HasParent (CXTPPropertyGridItem *pParent)
Determines if the item has a specified item as a parent.
CXTPPropertyGridItemConstraints * | GetConstraints () const
Gets the item's list of constraints.
void | SetConstraintEdit (BOOL bConstraintEdit=TRUE)
Enables/disables constraint editing mode.
void | SetAutoComplete (BOOL bAutoComplete=TRUE)
Enables/disables auto-complete for the constraint list.
BOOL | GetConstraintEdit () const
Determines if constraint editing mode is enabled/disabled.
void | Expand ()
Expands the item.
void | Collapse ()
Collapses the item.
void | SetExpandable (BOOL bExpandable)
Specifies if the item should be expandable by the user.
BOOL | IsExpandable () const
Determines if the item is expandable by the user.
void | Select ()
Selects the item.
CRect | GetItemRect () const
Gets the bounding rectangle of the item.
virtual CRect | GetValueRect ()
Gets the bounding rectangle of the item value's text.
void | SetHidden (BOOL bHidden)
Hides/shows the item.
BOOL | IsHidden () const
Determines if the item is hidden/shown.
virtual void | OnValueChanged (CString strValue)
This method is called when the value of the item is changed.
virtual void | OnMarkupChanged ()
This method is called when the markup text of the item is changed.
CXTPPropertyGridView * | GetGrid () const
Gets the parent window.
BOOL | IsVisible () const
Determines the visible state of the item.
BOOL | IsExpanded () const
Determines the expanded state of the item.
CXTPPropertyGridItem * | GetParentItem () const
Gets the parent item of this item, if any.
int | GetIndent () const
Gets the indent of the item.
virtual void | OnDrawItemConstraint (CDC *pDC, CXTPPropertyGridItemConstraint *pConstraint, CRect rc, BOOL bSelected)
This method is called when a constraint in an in-place list is drawn.
virtual CSize | OnMergeItemConstraint (CDC *pDC, CXTPPropertyGridItemConstraint *pConstraint)
This method is called to get size of constraint in in-place list.
virtual void | MeasureItem (LPMEASUREITEMSTRUCT lpMeasureItemStruct)
Override this method and fill in a specified MEASUREITEMSTRUCT structure to inform Windows of the list-box dimensions.
BOOL | IsSelected () const
Determines the selected stae of the item.
void | BindToString (CString *pBindString)
Binds the item to a specified CString object.
void | Remove ()
Removes this item.
void | SetMask (LPCTSTR strMask, LPCTSTR strLiteral, TCHAR chPrompt=_T('_'))
Applies a specified mask to a CXTPPropertyGridItem data field to create a restrictive field for text entry.
void | SetPasswordMask (TCHAR chMask=_T(' *'))
Sets a password mask for the item.
CString | GetMaskedText () const
Gets the actual text value of the item without mask characters.
virtual BOOL | IsValueChanged () const
Determines if the value of the item was changed by the user.
virtual void | ResetValue ()
Resets the value of the item to its default value.
void | SetDefaultValue (LPCTSTR lpszDefaultValue)
Sets the default value for the item.
void | SetMaskedText (LPCTSTR lpszMaskedText)
Sets the actual text value for the item without mask characters.
void | SetItemData (DWORD_PTR dwData)
Sets the 32-bit value associated with the item.
DWORD_PTR | GetItemData () const
Gets the application-supplied, 32-bit value associated with the item.
virtual CXTPPropertyGridInplaceEdit & | GetInplaceEdit ()
Gets the in-place edit control of the item.
virtual void | SetFocusToInplaceControl ()
Sets focus to the in-place control of the item.
virtual BOOL | IsInplaceButtonVisible (CXTPPropertyGridInplaceButton *pButton) const
Determines if a specified in-place button is visible.
CXTPPropertyGridInplaceButtons * | GetInplaceButtons () const
Gets the collection of in-place buttons of the item.
CXTPPropertyGridInplaceControls * | GetInplaceControls () const
Gets the collection of in-place controls of the item.
void | AddComboButton ()
Adds a standard combo button.
void | AddExpandButton ()
Adds a standard expand button.
CXTPPropertyGridInplaceSlider * AddSliderControl ()
Adds a slider control.
CXTPPropertyGridInplaceSpinButton * AddSpinButton ()
Adds a spin button control.
CXTPPropertyGridItemMetrics * | GetValueMetrics () const
Gets the metrics of the value part.
CXTPPropertyGridItemMetrics * | GetCaptionMetrics () const
Gets the metrics of the caption part.
CXTPPropertyGridItemMetrics * | GetMetrics (BOOL bValueMetrics, BOOL bCreate=TRUE) const
Gets the metrics of the value/caption part.
int | GetHeight () const
Gets the variable height of the item.
void | SetHeight (int nHeight)
Sets the variable height of the item.
BOOL | IsMultiLine () const
Determines if the item is multi-line (i.e.
int | GetMultiLinesCount () const
Gets the number of lines of the item.
void | SetMultiLinesCount (int nLinesCount)
Sets the number of lines for the item.
void | EnsureVisible ()
Ensures that this item is visible.
virtual BOOL | OnRequestEdit ()
This method is called before the user begins editing the item.
virtual BOOL | OnAfterEdit (CString &strValue)
This method is called before the user applies a new value to the item.
virtual void | OnCancelEdit ()
This method is called if the user cancels editing the item.
void | SetEditStyle (DWORD dwEditStyle)
Sets the edit style for the item.
void | SetDropDownItemCount (int nDropDownItemCount)
Sets the number of items in the dropdown list.
int | GetDropDownItemCount () const
Gets the number of items in the dropdown list.
virtual void | OnValidateEdit ()
This method is called to check the value from the in-place edit control.
CXTPMarkupUIElement * | GetMarkupCaption () const
Gets the CXTPMarkupUIElement object that renders the caption of the item.
CXTPMarkupUIElement * | GetMarkupDescription () const
Gets the CXTPMarkupUIElement object that renders the description of the item in the Help pane.
CXTPMarkupUIElement * | GetMarkupValue () const
Gets the CXTPMarkupUIElement object that renders the value of the item in the property grid.
virtual DWORD | GetEditStyle () const
Gets the edit style of the item.
void | RedrawItem ()
Redraws the item.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

virtual void | SetValue (CString strValue)
Sets the value of the item.
BOOL | SetValueText (CString &strValueText, LPCTSTR strNewText)
Searches the drop list for labels with the value specified by strValueText and updates them with the value specified by strNewText.
virtual void | OnBeforeInsert ()
This method is called before the item becomes visible in the property grid.
virtual BOOL | OnDrawItemValue (CDC &dc, CRect rcValue)
This method is called when an item is drawn.
virtual CString | GetViewValue ()
Gets the value of the item that the user is currently viewing.
virtual BOOL | OnLButtonDown (UINT nFlags, CPoint point)
This method is called when the user presses the left mouse button on the item.
virtual BOOL | OnKeyDown (UINT nChar)
This method is called when the user presses a key.
virtual void | OnLButtonDblClk (UINT nFlags, CPoint point)
This method is called when the user double-clicks the left mouse button on the item.
BOOL | PtInCheckBoxRect (CPoint point)
Determines if a specified point is inside the checkbox displayed if the item has a checkbox style.
- Protected Member Functions inherited from CXTPPropertyGridItem
virtual void | SetVisible (BOOL bVisible)
Sets the visible state of the item.
virtual void | OnIndexChanged ()
This method is called when the index of the item is changed.
virtual void | OnSelect ()
This method is called when an item is selected.
virtual void | OnDeselect ()
This method is called when an item is de-selected.
virtual BOOL | OnChar (UINT nChar)
This method is called when a key is pressed.
virtual void | OnRButtonDown (UINT nFlags, CPoint point)
This method is called when the user presses the right mouse button on the item.
virtual void | OnLButtonUp (UINT nFlags, CPoint point)
This method is called when the user releases the left mouse button on the item.
virtual void | OnAddChildItem ()
This method is called when an item is added to the parent.
virtual void | OnInplaceButtonDown (CXTPPropertyGridInplaceButton *pButton)
This method is called when the user presses the in-place button.
virtual CXTPPropertyGridInplaceList & | GetInplaceList ()
Gets the in-place list control of the item.
virtual void | SetEditText (const CString &str)
Sets the text for the in-place edit control.
virtual void | OnConstraintsChanged ()
This method is called when constraints are added to the item (i.e.
virtual void | OnCaptionChanged ()
This method is called when the caption of the item is changed.
virtual BOOL | OnInpaceControlFocus (BOOL bForward)
This method is called by the property grid to set focus to an in-place child window.
virtual CString | GetInPlacedEditValue ()
Gets the text of the in-place edit control.
void | NotifyValueChanged ()
This method is called when the item's value is changed.
BOOL | SelectNextConstraint ()
Selects the next constraint in the list of constraints.
BOOL | PtInValueRect (CPoint point)
Determines if a specified point is within the value rectangle.

Protected Attributes

BOOL | m_bValue
Value of the item.
BOOL * | m_pBindBool
Pointer to the variable bound to this item.
CString | m_strTrueText
Text of the TRUE label.
CString | m_strFalseText
Text of the FALSE label.
BOOL | m_bCheckBoxStyle
Checkbox style.
- Protected Attributes inherited from CXTPPropertyGridItem
BOOL | m_bConstraintEdit
TRUE to constraint edit.
int | m_nIndex
Index of the item.
int | m_nIndent
Indent of the item.
UINT | m_nID
Identifier of the item.
UINT | m_nFlags
Item's flags.
BOOL | m_bReadOnly
TRUE if the item state is set to read-only, FALSE if the item state is set to read/write.
BOOL | m_bVisible
Visibility of the item.
BOOL | m_bCategory
TRUE if the item is a category.
BOOL | m_bExpandable
TRUE if the item can be expanded.
BOOL | m_bExpanded
TRUE if the item is expanded.
CString | m_strValue
Value of the item.
CString | m_strDefaultValue
Default value of the item.
CString | m_strCaption
Caption of the item.
CString | m_strDescription
Description of the item.
CString | m_strTooltip
Tooltip text.
CXTPPropertyGridItem * | m_pParent
Parent item.
CXTPPropertyGridView * | m_pGrid
Parent grid class.
CXTPPropertyGridItems * | m_pChilds
Child items.
CXTPPropertyGridItemConstraints * | m_pConstraints
Item's constraints.
BOOL | m_bAutoComplete
TRUE to enable auto-complete for the item.
CXTPPropertyGridItemMetrics * | m_pValueMetrics
Value part metrics.
CXTPPropertyGridItemMetrics * | m_pCaptionMetrics
Caption part metrics.
CXTPPropertyGridInplaceButtons * | m_pInplaceButtons
In-place buttons array.
CXTPPropertyGridInplaceControls * | m_pInplaceControls
In-place controls array.
int | m_nDropDownItemCount
Maximum drop down items.
CString * | m_pBindString
Bound string.
CString | m_strFormat
Format of the double value.
CString | m_strMask
String to use as edit mask.
CString | m_strLiteral
String to use as literal.
CString | m_strMarkupTemplate
String that represents item's display when markup is on.
TCHAR | m_chPrompt
Character used as a space holder for a character.
BOOL | m_bUseMask
TRUE to use an edit mask to display item data.
BOOL | m_bPassword
TRUE to use a password mask.
DWORD_PTR | m_dwData
The 32-bit value associated with the item.
BOOL | m_bHidden
TRUE if the item is hidden, FALSE if the item is shown.
int | m_nHeight
Item's height; -1 to use the default.
int | m_nLinesCount
Number of lines in a multi-line item.
DWORD | m_dwEditStyle
Edit style.
CXTPMarkupUIElement * | m_pMarkupCaption
Markup UIElement for item's caption.
CXTPMarkupUIElement * | m_pMarkupDescription
Markup UIElement for item's description.
CXTPMarkupUIElement * | m_pMarkupValue
Markup UIElement for item's value.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Static Protected Member Functions inherited from CXTPPropertyGridItem

Detailed Description

CXTPPropertyGridItemBool is a CXTPPropertyGridItem derived class.

It is used to create a BOOL value item in a Property Grid control.

Constructor & Destructor Documentation

◆ CXTPPropertyGridItemBool() [1/2]

CXTPPropertyGridItemBool | ( | LPCTSTR | strCaption,
 |  | BOOL | bValue = FALSE,
 |  | BOOL * | pBindBool = NULL )

Constructs a CXTPPropertyGridItemBool object.

Parameters
strCaption | Caption of the item.
bValue | Initial BOOL value of the item.
pBindBool | If not NULL, then the value of the item is bound the value of this variable.

Class CXTPPropertyGridItemBool has no default constructor.

When using the second constructor, the Identifier (nID) of the second constructor can be linked with a STRINGTABLE resource with the same ID in such form "Caption\\nDescription".

BINDING: Variables can be bound to an item in two ways, the first is to pass in a variable at the time of creation, the second allows variables to be bound to an item after creation with the BindToBool member.

Bound variables store the values of the property grid items and can be accessed without using the property grid methods and properties. Bound variables allow the property grid to store data in variables. When the value of a PropertyGridItem is changed, the value of the bound variable will be changed to the PropertyGridItem value. The advantage of binding is that the variable can be used and manipulated without using PropertyGridItem methods and properties.

NOTE: If the value of the variable is changed without using the PropertyGrid, the PropertyGridItem value will not be updated until you call CXTPPropertyGrid::Refresh.

See also
BindToBool

◆ CXTPPropertyGridItemBool() [2/2]

CXTPPropertyGridItemBool | ( | UINT | nID,
 |  | BOOL | bValue = FALSE,
 |  | BOOL * | pBindBool = NULL )

Constructs a CXTPPropertyGridItemBool object.

Parameters
nID | Identifier of the item.
bValue | Initial BOOL value of the item.
pBindBool | If not NULL, then the value of the item is bound the value of this variable.

Class CXTPPropertyGridItemBool has no default constructor.

When using the second constructor, the Identifier (nID) of the second constructor can be linked with a STRINGTABLE resource with the same ID in such form "Caption\\nDescription".

BINDING: Variables can be bound to an item in two ways, the first is to pass in a variable at the time of creation, the second allows variables to be bound to an item after creation with the BindToBool member.

Bound variables store the values of the property grid items and can be accessed without using the property grid methods and properties. Bound variables allow the property grid to store data in variables. When the value of a PropertyGridItem is changed, the value of the bound variable will be changed to the PropertyGridItem value. The advantage of binding is that the variable can be used and manipulated without using PropertyGridItem methods and properties.

NOTE: If the value of the variable is changed without using the PropertyGrid, the PropertyGridItem value will not be updated until you call CXTPPropertyGrid::Refresh.

See also
BindToBool

Member Function Documentation

◆ BindToBool()

virtual void BindToBool ( BOOL * pBindBool )
virtual

Binds the item to a specified BOOL value.

Parameters
pBindBool Pointer to a BOOL value.

Variables can be bound to an item in two ways, the first is to pass in a variable at the time of creation, the second allows variables to be bound to an item after creation with the BindToBool member.

Bound variables store the values of the property grid items and can be accessed without using the property grid methods and properties. Bound variables allow the property grid to store data in variables. When the value of a PropertyGridItem is changed, the value of the bound variable will be changed to the PropertyGridItem value. The advantage of binding is that the variable can be used and manipulated without using PropertyGridItem methods and properties.

NOTE: If the value of the variable is changed without using the PropertyGrid, the PropertyGridItem value will not be updated until you call CXTPPropertyGrid::Refresh.

◆ GetBool()

AFX_INLINE BOOL GetBool ( ) const
virtual

Gets the BOOL value of the item.

Returns
The BOOL value of the item (i.e. TRUE if the item's value is TRUE, FALSE if the item's value is FALSE).

◆ GetViewValue()

virtual CString GetViewValue ( )
protectedvirtual

Gets the value of the item that the user is currently viewing.

The return value of this method includes the formatting used for the value of the item. For example, if a password mask is shown, then the return value of this method would be a CString filled with asterisks (*). Otherwise, if a password mask is not shown, the return value would be the same as the GetValue method.

Returns
The value of the item that the user is currently viewing.

Reimplemented from CXTPPropertyGridItem.

◆ IsCheckBoxStyle()

BOOL IsCheckBoxStyle ( ) const

Determines if the item is drawn as a check box frame.

Returns
TRUE if the item is drawn as a check box frame, otherwise FALSE.
See also
SetCheckBoxStyle

◆ OnBeforeInsert()

virtual void OnBeforeInsert ( )
protectedvirtual

This method is called before the item becomes visible in the property grid.

Before the item is inserted, it is first checked to see if it is bound to a variable. If it is, then the value of the item is updated with the value stored in the bound variable.

OnBeforeInsert is called when an item is inserted, when a category is inserted, when a category or item is expanded, and when the sort property has changed.

Reimplemented from CXTPPropertyGridItem.

◆ OnDrawItemValue()

virtual BOOL OnDrawItemValue | ( | CDC & | dc,
 |  | CRect | rcValue )
 protectedvirtual

This method is called when an item is drawn.

Override this method if needed.

Parameters
dc | Reference to the device context to be used for rendering an image of the item.
rcValue | Bounding rectangle of the item.
Returns
TRUE if the item is self-drawn.

Reimplemented from CXTPPropertyGridItem.

◆ OnKeyDown()

virtual BOOL OnKeyDown ( UINT nChar )
protectedvirtual

This method is called when the user presses a key.

Parameters
nChar Specifies the virtual-key code of the given key.

This method checks if the item has a checkbox style, is not read-only, and if the user pressed the Spacebar key. If these three criteria are met, then the checkbox will be be checked/un-checked.

Returns
TRUE if the item has a checkbox style, is not read-only, and if the user pressed the Spacebar key, otherwise FALSE.
See also
PtInCheckBoxRect

Reimplemented from CXTPPropertyGridItem.

◆ OnLButtonDblClk()

virtual void OnLButtonDblClk | ( | UINT | nFlags,
 |  | CPoint | point )
 protectedvirtual

This method is called when the user double-clicks the left mouse button on the item.

Parameters
nFlags | Indicates whether various virtual keys are down (see Visual C++ documentation).
point | Specifies the x- and y- coordinates of the cursor.

Reimplemented from CXTPPropertyGridItem.

◆ OnLButtonDown()

virtual BOOL OnLButtonDown | ( | UINT | nFlags,
 |  | CPoint | point )
 protectedvirtual

This method is called when the user presses the left mouse button on the item.

Parameters
nFlags | Indicates whether various virtual keys are down (see Visual C++ documentation).
point | Specifies the x- and y- coordinates of the cursor.
Returns
TRUE if the message was processed, otherwise FALSE.

Reimplemented from CXTPPropertyGridItem.

◆ PtInCheckBoxRect()

BOOL PtInCheckBoxRect ( CPoint point )
protected

Determines if a specified point is inside the checkbox displayed if the item has a checkbox style.

Parameters
point Point to be tested.
Returns
TRUE if the specified point is inside the checkbox, otherwise FALSE.
See also
OnKeyDown

◆ SetBool()

virtual void SetBool ( BOOL bValue )
virtual

Sets the BOOL value for the item.

Parameters
bValue BOOL value to be set.

◆ SetCheckBoxStyle()

void SetCheckBoxStyle ( BOOL bCheckBoxStyle = TRUE )

Specifies if the item should be drawn as a check box frame.

Parameters
bCheckBoxStyle TRUE to draw the item as a check box frame, FALSE otherwise.
See also
IsCheckBoxStyle

◆ SetTrueFalseText()

BOOL SetTrueFalseText | ( | LPCTSTR | strTrueText,
 |  | LPCTSTR | strFalseText )

Sets the values for the TRUE and FALSE labels in the drop list.

Parameters
strTrueText | NULL-terminated string that represents the TRUE label.
strFalseText | NULL-terminated string that represents the FALSE label.

By default, the values for the TRUE and FALSE labels in the drop list are set to "True" and "False" respectively.

Returns
TRUE if successful, otherwise FALSE.

◆ SetValue()

virtual void SetValue ( CString strValue )
protectedvirtual

Sets the value of the item.

Override this method to add new functionality. You should call the base class version of this function from your override.

Parameters
strValue Value to be set.

Reimplemented from CXTPPropertyGridItem.

◆ SetValueText()

BOOL SetValueText | ( | CString & | strValueText,
 |  | LPCTSTR | strNewText )
 protected

Searches the drop list for labels with the value specified by strValueText and updates them with the value specified by strNewText.

Parameters
strValueText | NULL-terminated string that represents the current value of labels that must be updated.
strNewText | NULL-terminated string that represents the new value for labels that must be updated.

If the value specified by strValueText is also the current value of the property grid item, then the value of that item will be updated as well.

Returns
TRUE if successful, otherwise FALSE.
The documentation for this class was generated from the following file:
  • XTPPropertyGridItemBool.h


Toolkit Pro: CXTPPropertyGridItemCategory Class Reference

Public Member Functions | List of all members
CXTPPropertyGridItemCategory Class Reference

CXTPPropertyGridItemCategory is a CXTPPropertyGridItem derived class. More...

Inheritance diagram for CXTPPropertyGridItemCategory:
[legend]

Public Member Functions

CXTPPropertyGridItemCategory (LPCTSTR strCaption)
Constructs a CXTPPropertyGridItemCategory object.
CXTPPropertyGridItemCategory (UINT nID)
Constructs a CXTPPropertyGridItemCategory object.
- Public Member Functions inherited from CXTPPropertyGridItem
CXTPPropertyGridItem (LPCTSTR lpszCaption, LPCTSTR strValue=NULL, CString *pBindString=NULL)
Constructs a CXTPPropertyGridItem object.
CXTPPropertyGridItem (UINT nID, LPCTSTR strValue=NULL, CString *pBindString=NULL)
Constructs a CXTPPropertyGridItem object.
virtual | ~CXTPPropertyGridItem ()
Destroys a CXTPPropertyGridItem object, handles cleanup and deallocation.
void | SetCaption (LPCTSTR lpszCaption)
Sets the caption text for the item.
void | SetPrompt (LPCTSTR lpszPrompt)
Loads a string from a STRINGTABLE resource to set the caption and description for the item.
void | SetDescription (LPCTSTR lpszDescription)
Sets the description text for the item.
void | SetMarkupTemplate (LPCTSTR lpstrMarkupTemplate)
Sets the markup text for the item.
void | SetTooltip (LPCTSTR lpstrTooltip)
Sets the tooltip text for the item.
CString | GetTooltip () const
Gets the tooltip text of the item.
virtual void | SetReadOnly (BOOL bReadOnly=TRUE)
Specifies if the item state should be set to read-only or to read/write.
void | SetID (UINT nID)
Sets the identifier for the item.
void | SetFlags (UINT nFlags)
Sets a specific flag for the item.
CString | GetCaption () const
Gets the caption text of the item.
CString | GetDescription () const
Gets the description text of the item.
virtual CString | GetMarkupTemplate () const
Gets the markup text of the item.
virtual BOOL | GetReadOnly () const
Determines if the item state is set to read-only or to read/write.
virtual BOOL | IsAllowEdit () const
Determines if items in the property grid are allowed to be edited by the user.
UINT | GetID () const
Gets the identifier of the item.
int | GetIndex () const
Gets the index of the item within the property grid list.
CString | GetValue () const
Gets the value of the item.
CString | GetDefaultValue () const
Gets the default value of the item.
UINT | GetFlags () const
Gets the flags of the item.
BOOL | IsCategory () const
Determines if the item is a category.
CXTPPropertyGridItem * | AddChildItem (CXTPPropertyGridItem *pItem)
Adds a child item.
void | Move (CXTPPropertyGridItem *pParent, int nIndex=-1)
Moves the item to another category.
CXTPPropertyGridItem * | InsertChildItem (int nIndex, CXTPPropertyGridItem *pItem)
Inserts a child item.
BOOL | HasChilds () const
Determines if the item has children.
BOOL | HasVisibleChilds () const
Determines if the item has visible children.
CXTPPropertyGridItems * | GetChilds () const
Gets the item's list of child items.
BOOL | HasParent (CXTPPropertyGridItem *pParent)
Determines if the item has a specified item as a parent.
CXTPPropertyGridItemConstraints * | GetConstraints () const
Gets the item's list of constraints.
void | SetConstraintEdit (BOOL bConstraintEdit=TRUE)
Enables/disables constraint editing mode.
void | SetAutoComplete (BOOL bAutoComplete=TRUE)
Enables/disables auto-complete for the constraint list.
BOOL | GetConstraintEdit () const
Determines if constraint editing mode is enabled/disabled.
void | Expand ()
Expands the item.
void | Collapse ()
Collapses the item.
void | SetExpandable (BOOL bExpandable)
Specifies if the item should be expandable by the user.
BOOL | IsExpandable () const
Determines if the item is expandable by the user.
void | Select ()
Selects the item.
CRect | GetItemRect () const
Gets the bounding rectangle of the item.
virtual CRect | GetValueRect ()
Gets the bounding rectangle of the item value's text.
virtual void | SetValue (CString strValue)
Sets the value of the item.
void | SetHidden (BOOL bHidden)
Hides/shows the item.
BOOL | IsHidden () const
Determines if the item is hidden/shown.
virtual void | OnValueChanged (CString strValue)
This method is called when the value of the item is changed.
virtual void | OnMarkupChanged ()
This method is called when the markup text of the item is changed.
CXTPPropertyGridView * | GetGrid () const
Gets the parent window.
BOOL | IsVisible () const
Determines the visible state of the item.
BOOL | IsExpanded () const
Determines the expanded state of the item.
CXTPPropertyGridItem * | GetParentItem () const
Gets the parent item of this item, if any.
int | GetIndent () const
Gets the indent of the item.
virtual BOOL | OnDrawItemValue (CDC &dc, CRect rcValue)
This method is called when an item is drawn.
virtual void | OnDrawItemConstraint (CDC *pDC, CXTPPropertyGridItemConstraint *pConstraint, CRect rc, BOOL bSelected)
This method is called when a constraint in an in-place list is drawn.
virtual CSize | OnMergeItemConstraint (CDC *pDC, CXTPPropertyGridItemConstraint *pConstraint)
This method is called to get size of constraint in in-place list.
virtual void | MeasureItem (LPMEASUREITEMSTRUCT lpMeasureItemStruct)
Override this method and fill in a specified MEASUREITEMSTRUCT structure to inform Windows of the list-box dimensions.
BOOL | IsSelected () const
Determines the selected stae of the item.
void | BindToString (CString *pBindString)
Binds the item to a specified CString object.
void | Remove ()
Removes this item.
void | SetMask (LPCTSTR strMask, LPCTSTR strLiteral, TCHAR chPrompt=_T('_'))
Applies a specified mask to a CXTPPropertyGridItem data field to create a restrictive field for text entry.
void | SetPasswordMask (TCHAR chMask=_T(' *'))
Sets a password mask for the item.
CString | GetMaskedText () const
Gets the actual text value of the item without mask characters.
virtual BOOL | IsValueChanged () const
Determines if the value of the item was changed by the user.
virtual void | ResetValue ()
Resets the value of the item to its default value.
void | SetDefaultValue (LPCTSTR lpszDefaultValue)
Sets the default value for the item.
void | SetMaskedText (LPCTSTR lpszMaskedText)
Sets the actual text value for the item without mask characters.
virtual CString | GetViewValue ()
Gets the value of the item that the user is currently viewing.
void | SetItemData (DWORD_PTR dwData)
Sets the 32-bit value associated with the item.
DWORD_PTR | GetItemData () const
Gets the application-supplied, 32-bit value associated with the item.
virtual CXTPPropertyGridInplaceEdit & | GetInplaceEdit ()
Gets the in-place edit control of the item.
virtual void | SetFocusToInplaceControl ()
Sets focus to the in-place control of the item.
virtual BOOL | IsInplaceButtonVisible (CXTPPropertyGridInplaceButton *pButton) const
Determines if a specified in-place button is visible.
CXTPPropertyGridInplaceButtons * | GetInplaceButtons () const
Gets the collection of in-place buttons of the item.
CXTPPropertyGridInplaceControls * | GetInplaceControls () const
Gets the collection of in-place controls of the item.
void | AddComboButton ()
Adds a standard combo button.
void | AddExpandButton ()
Adds a standard expand button.
CXTPPropertyGridInplaceSlider * AddSliderControl ()
Adds a slider control.
CXTPPropertyGridInplaceSpinButton * AddSpinButton ()
Adds a spin button control.
CXTPPropertyGridItemMetrics * | GetValueMetrics () const
Gets the metrics of the value part.
CXTPPropertyGridItemMetrics * | GetCaptionMetrics () const
Gets the metrics of the caption part.
CXTPPropertyGridItemMetrics * | GetMetrics (BOOL bValueMetrics, BOOL bCreate=TRUE) const
Gets the metrics of the value/caption part.
int | GetHeight () const
Gets the variable height of the item.
void | SetHeight (int nHeight)
Sets the variable height of the item.
BOOL | IsMultiLine () const
Determines if the item is multi-line (i.e.
int | GetMultiLinesCount () const
Gets the number of lines of the item.
void | SetMultiLinesCount (int nLinesCount)
Sets the number of lines for the item.
void | EnsureVisible ()
Ensures that this item is visible.
virtual BOOL | OnRequestEdit ()
This method is called before the user begins editing the item.
virtual BOOL | OnAfterEdit (CString &strValue)
This method is called before the user applies a new value to the item.
virtual void | OnCancelEdit ()
This method is called if the user cancels editing the item.
void | SetEditStyle (DWORD dwEditStyle)
Sets the edit style for the item.
void | SetDropDownItemCount (int nDropDownItemCount)
Sets the number of items in the dropdown list.
int | GetDropDownItemCount () const
Gets the number of items in the dropdown list.
virtual void | OnValidateEdit ()
This method is called to check the value from the in-place edit control.
CXTPMarkupUIElement * | GetMarkupCaption () const
Gets the CXTPMarkupUIElement object that renders the caption of the item.
CXTPMarkupUIElement * | GetMarkupDescription () const
Gets the CXTPMarkupUIElement object that renders the description of the item in the Help pane.
CXTPMarkupUIElement * | GetMarkupValue () const
Gets the CXTPMarkupUIElement object that renders the value of the item in the property grid.
virtual DWORD | GetEditStyle () const
Gets the edit style of the item.
void | RedrawItem ()
Redraws the item.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Member Functions inherited from CXTPPropertyGridItem
virtual void | SetVisible (BOOL bVisible)
Sets the visible state of the item.
virtual void | OnIndexChanged ()
This method is called when the index of the item is changed.
virtual void | OnSelect ()
This method is called when an item is selected.
virtual void | OnDeselect ()
This method is called when an item is de-selected.
virtual BOOL | OnChar (UINT nChar)
This method is called when a key is pressed.
virtual void | OnLButtonDblClk (UINT nFlags, CPoint point)
This method is called when the user double-clicks the left mouse button on the item.
virtual void | OnRButtonDown (UINT nFlags, CPoint point)
This method is called when the user presses the right mouse button on the item.
virtual BOOL | OnLButtonDown (UINT nFlags, CPoint point)
This method is called when the user presses the left mouse button on the item.
virtual void | OnLButtonUp (UINT nFlags, CPoint point)
This method is called when the user releases the left mouse button on the item.
virtual BOOL | OnKeyDown (UINT nChar)
This method is called when a non-system key is pressed.
virtual void | OnAddChildItem ()
This method is called when an item is added to the parent.
virtual void | OnInplaceButtonDown (CXTPPropertyGridInplaceButton *pButton)
This method is called when the user presses the in-place button.
virtual CXTPPropertyGridInplaceList & | GetInplaceList ()
Gets the in-place list control of the item.
virtual void | SetEditText (const CString &str)
Sets the text for the in-place edit control.
virtual void | OnBeforeInsert ()
This method is called before the item becomes visible in the property grid.
virtual void | OnConstraintsChanged ()
This method is called when constraints are added to the item (i.e.
virtual void | OnCaptionChanged ()
This method is called when the caption of the item is changed.
virtual BOOL | OnInpaceControlFocus (BOOL bForward)
This method is called by the property grid to set focus to an in-place child window.
virtual CString | GetInPlacedEditValue ()
Gets the text of the in-place edit control.
void | NotifyValueChanged ()
This method is called when the item's value is changed.
BOOL | SelectNextConstraint ()
Selects the next constraint in the list of constraints.
BOOL | PtInValueRect (CPoint point)
Determines if a specified point is within the value rectangle.
- Static Protected Member Functions inherited from CXTPPropertyGridItem
- Protected Attributes inherited from CXTPPropertyGridItem
BOOL | m_bConstraintEdit
TRUE to constraint edit.
int | m_nIndex
Index of the item.
int | m_nIndent
Indent of the item.
UINT | m_nID
Identifier of the item.
UINT | m_nFlags
Item's flags.
BOOL | m_bReadOnly
TRUE if the item state is set to read-only, FALSE if the item state is set to read/write.
BOOL | m_bVisible
Visibility of the item.
BOOL | m_bCategory
TRUE if the item is a category.
BOOL | m_bExpandable
TRUE if the item can be expanded.
BOOL | m_bExpanded
TRUE if the item is expanded.
CString | m_strValue
Value of the item.
CString | m_strDefaultValue
Default value of the item.
CString | m_strCaption
Caption of the item.
CString | m_strDescription
Description of the item.
CString | m_strTooltip
Tooltip text.
CXTPPropertyGridItem * | m_pParent
Parent item.
CXTPPropertyGridView * | m_pGrid
Parent grid class.
CXTPPropertyGridItems * | m_pChilds
Child items.
CXTPPropertyGridItemConstraints * | m_pConstraints
Item's constraints.
BOOL | m_bAutoComplete
TRUE to enable auto-complete for the item.
CXTPPropertyGridItemMetrics * | m_pValueMetrics
Value part metrics.
CXTPPropertyGridItemMetrics * | m_pCaptionMetrics
Caption part metrics.
CXTPPropertyGridInplaceButtons * | m_pInplaceButtons
In-place buttons array.
CXTPPropertyGridInplaceControls * | m_pInplaceControls
In-place controls array.
int | m_nDropDownItemCount
Maximum drop down items.
CString * | m_pBindString
Bound string.
CString | m_strFormat
Format of the double value.
CString | m_strMask
String to use as edit mask.
CString | m_strLiteral
String to use as literal.
CString | m_strMarkupTemplate
String that represents item's display when markup is on.
TCHAR | m_chPrompt
Character used as a space holder for a character.
BOOL | m_bUseMask
TRUE to use an edit mask to display item data.
BOOL | m_bPassword
TRUE to use a password mask.
DWORD_PTR | m_dwData
The 32-bit value associated with the item.
BOOL | m_bHidden
TRUE if the item is hidden, FALSE if the item is shown.
int | m_nHeight
Item's height; -1 to use the default.
int | m_nLinesCount
Number of lines in a multi-line item.
DWORD | m_dwEditStyle
Edit style.
CXTPMarkupUIElement * | m_pMarkupCaption
Markup UIElement for item's caption.
CXTPMarkupUIElement * | m_pMarkupDescription
Markup UIElement for item's description.
CXTPMarkupUIElement * | m_pMarkupValue
Markup UIElement for item's value.

Detailed Description

CXTPPropertyGridItemCategory is a CXTPPropertyGridItem derived class.

Use it to add a sub-category to a property grid control. Note: The parent item for the category must also be a category.

Constructor & Destructor Documentation

◆ CXTPPropertyGridItemCategory() [1/2]

CXTPPropertyGridItemCategory ( LPCTSTR strCaption )

Constructs a CXTPPropertyGridItemCategory object.

Parameters
strCaption Caption of the item.

Class CXTPPropertyGridItemCategory has no default constructor.

When using the second constructor, the Identifier (nID) of the second constructor can be linked with a STRINGTABLE resource with the same ID in such form "Caption\\nDescription".

◆ CXTPPropertyGridItemCategory() [2/2]

CXTPPropertyGridItemCategory ( UINT nID )

Constructs a CXTPPropertyGridItemCategory object.

Parameters
nID Identifier of the item.

Class CXTPPropertyGridItemCategory has no default constructor.

When using the second constructor, the Identifier (nID) of the second constructor can be linked with a STRINGTABLE resource with the same ID in such form "Caption\\nDescription".

The documentation for this class was generated from the following file:
  • XTPPropertyGridItem.h


Toolkit Pro: CXTPPropertyGridItemColor Class Reference

Public Member Functions | Static Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPPropertyGridItemColor Class Reference

CXTPPropertyGridItemColor is a CXTPPropertyGridItem derived class. More...

Inheritance diagram for CXTPPropertyGridItemColor:
[legend]

Public Member Functions

CXTPPropertyGridItemColor (LPCTSTR strCaption, COLORREF clr=0, COLORREF *pBindColor=NULL)
Constructs a CXTPPropertyGridItemColor object.
CXTPPropertyGridItemColor (UINT nID, COLORREF clr=0, COLORREF *pBindColor=NULL)
Constructs a CXTPPropertyGridItemColor object.
virtual | ~CXTPPropertyGridItemColor ()
Destroys a CXTPPropertyGridItemColor object.
virtual void | SetColor (COLORREF clr)
Sets the COLORREF value for the item.
virtual COLORREF | GetColor () const
Gets the COLORREF value of the item.
virtual void | BindToColor (COLORREF *pBindColor)
Binds the item to a specified COLORREF value.
void | SetEditorStyle (XTPPropertyGridItemColorEditor editor)
Sets the editor type for the item.
XTPPropertyGridItemColorEditor GetEditorStyle ()
Gets the editor type of the item.
- Public Member Functions inherited from CXTPPropertyGridItem
CXTPPropertyGridItem (LPCTSTR lpszCaption, LPCTSTR strValue=NULL, CString *pBindString=NULL)
Constructs a CXTPPropertyGridItem object.
CXTPPropertyGridItem (UINT nID, LPCTSTR strValue=NULL, CString *pBindString=NULL)
Constructs a CXTPPropertyGridItem object.
virtual | ~CXTPPropertyGridItem ()
Destroys a CXTPPropertyGridItem object, handles cleanup and deallocation.
void | SetCaption (LPCTSTR lpszCaption)
Sets the caption text for the item.
void | SetPrompt (LPCTSTR lpszPrompt)
Loads a string from a STRINGTABLE resource to set the caption and description for the item.
void | SetDescription (LPCTSTR lpszDescription)
Sets the description text for the item.
void | SetMarkupTemplate (LPCTSTR lpstrMarkupTemplate)
Sets the markup text for the item.
void | SetTooltip (LPCTSTR lpstrTooltip)
Sets the tooltip text for the item.
CString | GetTooltip () const
Gets the tooltip text of the item.
virtual void | SetReadOnly (BOOL bReadOnly=TRUE)
Specifies if the item state should be set to read-only or to read/write.
void | SetID (UINT nID)
Sets the identifier for the item.
void | SetFlags (UINT nFlags)
Sets a specific flag for the item.
CString | GetCaption () const
Gets the caption text of the item.
CString | GetDescription () const
Gets the description text of the item.
virtual CString | GetMarkupTemplate () const
Gets the markup text of the item.
virtual BOOL | GetReadOnly () const
Determines if the item state is set to read-only or to read/write.
virtual BOOL | IsAllowEdit () const
Determines if items in the property grid are allowed to be edited by the user.
UINT | GetID () const
Gets the identifier of the item.
int | GetIndex () const
Gets the index of the item within the property grid list.
CString | GetValue () const
Gets the value of the item.
CString | GetDefaultValue () const
Gets the default value of the item.
UINT | GetFlags () const
Gets the flags of the item.
BOOL | IsCategory () const
Determines if the item is a category.
CXTPPropertyGridItem * | AddChildItem (CXTPPropertyGridItem *pItem)
Adds a child item.
void | Move (CXTPPropertyGridItem *pParent, int nIndex=-1)
Moves the item to another category.
CXTPPropertyGridItem * | InsertChildItem (int nIndex, CXTPPropertyGridItem *pItem)
Inserts a child item.
BOOL | HasChilds () const
Determines if the item has children.
BOOL | HasVisibleChilds () const
Determines if the item has visible children.
CXTPPropertyGridItems * | GetChilds () const
Gets the item's list of child items.
BOOL | HasParent (CXTPPropertyGridItem *pParent)
Determines if the item has a specified item as a parent.
CXTPPropertyGridItemConstraints * | GetConstraints () const
Gets the item's list of constraints.
void | SetConstraintEdit (BOOL bConstraintEdit=TRUE)
Enables/disables constraint editing mode.
void | SetAutoComplete (BOOL bAutoComplete=TRUE)
Enables/disables auto-complete for the constraint list.
BOOL | GetConstraintEdit () const
Determines if constraint editing mode is enabled/disabled.
void | Expand ()
Expands the item.
void | Collapse ()
Collapses the item.
void | SetExpandable (BOOL bExpandable)
Specifies if the item should be expandable by the user.
BOOL | IsExpandable () const
Determines if the item is expandable by the user.
void | Select ()
Selects the item.
CRect | GetItemRect () const
Gets the bounding rectangle of the item.
void | SetHidden (BOOL bHidden)
Hides/shows the item.
BOOL | IsHidden () const
Determines if the item is hidden/shown.
virtual void | OnValueChanged (CString strValue)
This method is called when the value of the item is changed.
virtual void | OnMarkupChanged ()
This method is called when the markup text of the item is changed.
CXTPPropertyGridView * | GetGrid () const
Gets the parent window.
BOOL | IsVisible () const
Determines the visible state of the item.
BOOL | IsExpanded () const
Determines the expanded state of the item.
CXTPPropertyGridItem * | GetParentItem () const
Gets the parent item of this item, if any.
int | GetIndent () const
Gets the indent of the item.
virtual void | OnDrawItemConstraint (CDC *pDC, CXTPPropertyGridItemConstraint *pConstraint, CRect rc, BOOL bSelected)
This method is called when a constraint in an in-place list is drawn.
virtual CSize | OnMergeItemConstraint (CDC *pDC, CXTPPropertyGridItemConstraint *pConstraint)
This method is called to get size of constraint in in-place list.
virtual void | MeasureItem (LPMEASUREITEMSTRUCT lpMeasureItemStruct)
Override this method and fill in a specified MEASUREITEMSTRUCT structure to inform Windows of the list-box dimensions.
BOOL | IsSelected () const
Determines the selected stae of the item.
void | BindToString (CString *pBindString)
Binds the item to a specified CString object.
void | Remove ()
Removes this item.
void | SetMask (LPCTSTR strMask, LPCTSTR strLiteral, TCHAR chPrompt=_T('_'))
Applies a specified mask to a CXTPPropertyGridItem data field to create a restrictive field for text entry.
void | SetPasswordMask (TCHAR chMask=_T(' *'))
Sets a password mask for the item.
CString | GetMaskedText () const
Gets the actual text value of the item without mask characters.
virtual BOOL | IsValueChanged () const
Determines if the value of the item was changed by the user.
virtual void | ResetValue ()
Resets the value of the item to its default value.
void | SetDefaultValue (LPCTSTR lpszDefaultValue)
Sets the default value for the item.
void | SetMaskedText (LPCTSTR lpszMaskedText)
Sets the actual text value for the item without mask characters.
virtual CString | GetViewValue ()
Gets the value of the item that the user is currently viewing.
void | SetItemData (DWORD_PTR dwData)
Sets the 32-bit value associated with the item.
DWORD_PTR | GetItemData () const
Gets the application-supplied, 32-bit value associated with the item.
virtual CXTPPropertyGridInplaceEdit & | GetInplaceEdit ()
Gets the in-place edit control of the item.
virtual void | SetFocusToInplaceControl ()
Sets focus to the in-place control of the item.
virtual BOOL | IsInplaceButtonVisible (CXTPPropertyGridInplaceButton *pButton) const
Determines if a specified in-place button is visible.
CXTPPropertyGridInplaceButtons * | GetInplaceButtons () const
Gets the collection of in-place buttons of the item.
CXTPPropertyGridInplaceControls * | GetInplaceControls () const
Gets the collection of in-place controls of the item.
void | AddComboButton ()
Adds a standard combo button.
void | AddExpandButton ()
Adds a standard expand button.
CXTPPropertyGridInplaceSlider * AddSliderControl ()
Adds a slider control.
CXTPPropertyGridInplaceSpinButton * AddSpinButton ()
Adds a spin button control.
CXTPPropertyGridItemMetrics * | GetValueMetrics () const
Gets the metrics of the value part.
CXTPPropertyGridItemMetrics * | GetCaptionMetrics () const
Gets the metrics of the caption part.
CXTPPropertyGridItemMetrics * | GetMetrics (BOOL bValueMetrics, BOOL bCreate=TRUE) const
Gets the metrics of the value/caption part.
int | GetHeight () const
Gets the variable height of the item.
void | SetHeight (int nHeight)
Sets the variable height of the item.
BOOL | IsMultiLine () const
Determines if the item is multi-line (i.e.
int | GetMultiLinesCount () const
Gets the number of lines of the item.
void | SetMultiLinesCount (int nLinesCount)
Sets the number of lines for the item.
void | EnsureVisible ()
Ensures that this item is visible.
virtual BOOL | OnRequestEdit ()
This method is called before the user begins editing the item.
virtual BOOL | OnAfterEdit (CString &strValue)
This method is called before the user applies a new value to the item.
virtual void | OnCancelEdit ()
This method is called if the user cancels editing the item.
void | SetEditStyle (DWORD dwEditStyle)
Sets the edit style for the item.
void | SetDropDownItemCount (int nDropDownItemCount)
Sets the number of items in the dropdown list.
int | GetDropDownItemCount () const
Gets the number of items in the dropdown list.
virtual void | OnValidateEdit ()
This method is called to check the value from the in-place edit control.
CXTPMarkupUIElement * | GetMarkupCaption () const
Gets the CXTPMarkupUIElement object that renders the caption of the item.
CXTPMarkupUIElement * | GetMarkupDescription () const
Gets the CXTPMarkupUIElement object that renders the description of the item in the Help pane.
CXTPMarkupUIElement * | GetMarkupValue () const
Gets the CXTPMarkupUIElement object that renders the value of the item in the property grid.
virtual DWORD | GetEditStyle () const
Gets the edit style of the item.
void | RedrawItem ()
Redraws the item.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Static Public Member Functions

static COLORREF AFX_CDECL | StringToRGB (LPCTSTR str)
Converts a specified string to a COLORREF.
static CString AFX_CDECL | RGBToString (COLORREF clr)
Converts a specified COLORREF to a string.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Protected Member Functions

virtual BOOL | OnDrawItemValue (CDC &dc, CRect rcValue)
This method is called when an item is drawn.
virtual CRect | GetValueRect ()
Gets the bounding rectangle of the item value's text.
virtual void | SetValue (CString strValue)
Sets the value of the item.
virtual void | OnInplaceButtonDown (CXTPPropertyGridInplaceButton *pButton)
This method is called when the user presses the in-place button.
virtual void | OnBeforeInsert ()
This method is called before the item becomes visible in the property grid.
- Protected Member Functions inherited from CXTPPropertyGridItem
virtual void | SetVisible (BOOL bVisible)
Sets the visible state of the item.
virtual void | OnIndexChanged ()
This method is called when the index of the item is changed.
virtual void | OnSelect ()
This method is called when an item is selected.
virtual void | OnDeselect ()
This method is called when an item is de-selected.
virtual BOOL | OnChar (UINT nChar)
This method is called when a key is pressed.
virtual void | OnLButtonDblClk (UINT nFlags, CPoint point)
This method is called when the user double-clicks the left mouse button on the item.
virtual void | OnRButtonDown (UINT nFlags, CPoint point)
This method is called when the user presses the right mouse button on the item.
virtual BOOL | OnLButtonDown (UINT nFlags, CPoint point)
This method is called when the user presses the left mouse button on the item.
virtual void | OnLButtonUp (UINT nFlags, CPoint point)
This method is called when the user releases the left mouse button on the item.
virtual BOOL | OnKeyDown (UINT nChar)
This method is called when a non-system key is pressed.
virtual void | OnAddChildItem ()
This method is called when an item is added to the parent.
virtual CXTPPropertyGridInplaceList & | GetInplaceList ()
Gets the in-place list control of the item.
virtual void | SetEditText (const CString &str)
Sets the text for the in-place edit control.
virtual void | OnConstraintsChanged ()
This method is called when constraints are added to the item (i.e.
virtual void | OnCaptionChanged ()
This method is called when the caption of the item is changed.
virtual BOOL | OnInpaceControlFocus (BOOL bForward)
This method is called by the property grid to set focus to an in-place child window.
virtual CString | GetInPlacedEditValue ()
Gets the text of the in-place edit control.
void | NotifyValueChanged ()
This method is called when the item's value is changed.
BOOL | SelectNextConstraint ()
Selects the next constraint in the list of constraints.
BOOL | PtInValueRect (CPoint point)
Determines if a specified point is within the value rectangle.

Protected Attributes

COLORREF | m_clrValue
Color value of the item.
COLORREF * | m_pBindColor
Pointer to the variable bound to this item.
XTPPropertyGridItemColorEditor | m_colorEditor
Editor type of the item.
- Protected Attributes inherited from CXTPPropertyGridItem
BOOL | m_bConstraintEdit
TRUE to constraint edit.
int | m_nIndex
Index of the item.
int | m_nIndent
Indent of the item.
UINT | m_nID
Identifier of the item.
UINT | m_nFlags
Item's flags.
BOOL | m_bReadOnly
TRUE if the item state is set to read-only, FALSE if the item state is set to read/write.
BOOL | m_bVisible
Visibility of the item.
BOOL | m_bCategory
TRUE if the item is a category.
BOOL | m_bExpandable
TRUE if the item can be expanded.
BOOL | m_bExpanded
TRUE if the item is expanded.
CString | m_strValue
Value of the item.
CString | m_strDefaultValue
Default value of the item.
CString | m_strCaption
Caption of the item.
CString | m_strDescription
Description of the item.
CString | m_strTooltip
Tooltip text.
CXTPPropertyGridItem * | m_pParent
Parent item.
CXTPPropertyGridView * | m_pGrid
Parent grid class.
CXTPPropertyGridItems * | m_pChilds
Child items.
CXTPPropertyGridItemConstraints * | m_pConstraints
Item's constraints.
BOOL | m_bAutoComplete
TRUE to enable auto-complete for the item.
CXTPPropertyGridItemMetrics * | m_pValueMetrics
Value part metrics.
CXTPPropertyGridItemMetrics * | m_pCaptionMetrics
Caption part metrics.
CXTPPropertyGridInplaceButtons * | m_pInplaceButtons
In-place buttons array.
CXTPPropertyGridInplaceControls * | m_pInplaceControls
In-place controls array.
int | m_nDropDownItemCount
Maximum drop down items.
CString * | m_pBindString
Bound string.
CString | m_strFormat
Format of the double value.
CString | m_strMask
String to use as edit mask.
CString | m_strLiteral
String to use as literal.
CString | m_strMarkupTemplate
String that represents item's display when markup is on.
TCHAR | m_chPrompt
Character used as a space holder for a character.
BOOL | m_bUseMask
TRUE to use an edit mask to display item data.
BOOL | m_bPassword
TRUE to use a password mask.
DWORD_PTR | m_dwData
The 32-bit value associated with the item.
BOOL | m_bHidden
TRUE if the item is hidden, FALSE if the item is shown.
int | m_nHeight
Item's height; -1 to use the default.
int | m_nLinesCount
Number of lines in a multi-line item.
DWORD | m_dwEditStyle
Edit style.
CXTPMarkupUIElement * | m_pMarkupCaption
Markup UIElement for item's caption.
CXTPMarkupUIElement * | m_pMarkupDescription
Markup UIElement for item's description.
CXTPMarkupUIElement * | m_pMarkupValue
Markup UIElement for item's value.

Detailed Description

CXTPPropertyGridItemColor is a CXTPPropertyGridItem derived class.

It is used to create a COLORREF value item in a Property Grid control.

Constructor & Destructor Documentation

◆ CXTPPropertyGridItemColor() [1/2]

CXTPPropertyGridItemColor | ( | LPCTSTR | strCaption,
 |  | COLORREF | clr = 0,
 |  | COLORREF * | pBindColor = NULL )

Constructs a CXTPPropertyGridItemColor object.

Parameters
strCaption | Caption of the item.
clr | Initial COLORREF value of the item.
pBindColor | If not NULL, then the value of the item is bound the value of this variable.

Class CXTPPropertyGridItemColor has no default constructor.

When using the second constructor, the Identifier (nID) of the second constructor can be linked with a STRINGTABLE resource with the same ID in such form "Caption\\nDescription".

BINDING: Variables can be bound to an item in two ways, the first is to pass in a variable at the time of creation, the second allows variables to be bound to an item after creation with the BindToColor member.

Bound variables store the values of the property grid items and can be accessed without using the property grid methods and properties. Bound variables allow the property grid to store data in variables. When the value of a PropertyGridItem is changed, the value of the bound variable will be changed to the PropertyGridItem value. The advantage of binding is that the variable can be used and manipulated without using PropertyGridItem methods and properties.

NOTE: If the value of the variable is changed without using the PropertyGrid, the PropertyGridItem value will not be updated until you call CXTPPropertyGrid::Refresh.

See also
BindToColor

◆ CXTPPropertyGridItemColor() [2/2]

CXTPPropertyGridItemColor | ( | UINT | nID,
 |  | COLORREF | clr = 0,
 |  | COLORREF * | pBindColor = NULL )

Constructs a CXTPPropertyGridItemColor object.

Parameters
nID | Identifier of the item.
clr | Initial COLORREF value of the item.
pBindColor | If not NULL, then the value of the item is bound the value of this variable.

Class CXTPPropertyGridItemColor has no default constructor.

When using the second constructor, the Identifier (nID) of the second constructor can be linked with a STRINGTABLE resource with the same ID in such form "Caption\\nDescription".

BINDING: Variables can be bound to an item in two ways, the first is to pass in a variable at the time of creation, the second allows variables to be bound to an item after creation with the BindToColor member.

Bound variables store the values of the property grid items and can be accessed without using the property grid methods and properties. Bound variables allow the property grid to store data in variables. When the value of a PropertyGridItem is changed, the value of the bound variable will be changed to the PropertyGridItem value. The advantage of binding is that the variable can be used and manipulated without using PropertyGridItem methods and properties.

NOTE: If the value of the variable is changed without using the PropertyGrid, the PropertyGridItem value will not be updated until you call CXTPPropertyGrid::Refresh.

See also
BindToColor

Member Function Documentation

◆ BindToColor()

virtual void BindToColor ( COLORREF * pBindColor )
virtual

Binds the item to a specified COLORREF value.

Parameters
pBindColor Pointer to a COLORREF value.

Variables can be bound to an item in two ways, the first is to pass in a variable at the time of creation, the second allows variables to be bound to an item after creation with the BindToColor member.

Bound variables store the values of the property grid items and can be accessed without using the property grid methods and properties. Bound variables allow the property grid to store data in variables. When the value of a PropertyGridItem is changed, the value of the bound variable will be changed to the PropertyGridItem value. The advantage of binding is that the variable can be used and manipulated without using PropertyGridItem methods and properties.

NOTE: If the value of the variable is changed without using the PropertyGrid, the PropertyGridItem value will not be updated until you call CXTPPropertyGrid::Refresh.

◆ GetColor()

AFX_INLINE COLORREF GetColor ( ) const
virtual

Gets the COLORREF value of the item.

Returns
The COLORREF value of the item.

◆ GetEditorStyle()

XTPPropertyGridItemColorEditor GetEditorStyle ( )

Gets the editor type of the item.

Returns
The editor type of the item; one of the values defined by the XTPPropertyGridItemColorEditor enumeration.
See also
SetEditorStyle, XTPPropertyGridItemColorEditor

◆ GetValueRect()

virtual CRect GetValueRect ( )
protectedvirtual

Gets the bounding rectangle of the item value's text.

Override this method to change it.

Returns
The bounding rectangle of the item value's text.

Reimplemented from CXTPPropertyGridItem.

◆ OnBeforeInsert()

virtual void OnBeforeInsert ( )
protectedvirtual

This method is called before the item becomes visible in the property grid.

Before the item is inserted, it is first checked to see if it is bound to a variable. If it is, then the value of the item is updated with the value stored in the bound variable.

OnBeforeInsert is called when an item is inserted, when a category is inserted, when a category or item is expanded, and when the sort property has changed.

Reimplemented from CXTPPropertyGridItem.

◆ OnDrawItemValue()

virtual BOOL OnDrawItemValue | ( | CDC & | dc,
 |  | CRect | rcValue )
 protectedvirtual

This method is called when an item is drawn.

Override this method if needed.

Parameters
dc | Reference to the device context to be used for rendering an image of the item.
rcValue | Bounding rectangle of the item.
Returns
TRUE if the item is self-drawn.

Reimplemented from CXTPPropertyGridItem.

◆ OnInplaceButtonDown()

virtual void OnInplaceButtonDown ( CXTPPropertyGridInplaceButton * pButton )
protectedvirtual

This method is called when the user presses the in-place button.

Override this method to show an item-specific dialog.

Parameters
pButton Pointer to the button that was pressed.

The in-place button is the button that the user presses to display the color picker dialog.

Reimplemented from CXTPPropertyGridItem.

◆ RGBToString()

static CString AFX_CDECL RGBToString ( COLORREF clr )
static

Converts a specified COLORREF to a string.

Parameters
clr COLORREF to be coverted.
Returns
The converted string (in the format RRR;GGG;BBB).

◆ SetColor()

virtual void SetColor ( COLORREF clr )
virtual

Sets the COLORREF value for the item.

Parameters
clr COLORREF value to be set.

◆ SetEditorStyle()

void SetEditorStyle ( XTPPropertyGridItemColorEditor editor )

Sets the editor type for the item.

Parameters
editor Editor type to be set; can be one of the following:

xtpPropertyGridItemColorPopup Color pop-up editor.

xtpPropertyGridItemColorStandardDialog Standard color dialog editor.

xtpPropertyGridItemColorExtendedDialog Extended color Editor editor.

See also
GetEditorStyle, XTPPropertyGridItemColorEditor

◆ SetValue()

virtual void SetValue ( CString strValue )
protectedvirtual

Sets the value of the item.

Override this method to add new functionality. You should call the base class version of this function from your override.

Parameters
strValue Value to be set.

Reimplemented from CXTPPropertyGridItem.

◆ StringToRGB()

static COLORREF AFX_CDECL StringToRGB ( LPCTSTR str )
static

Converts a specified string to a COLORREF.

Parameters
str String to be converted (in the format RRR;GGG;BBB).
Returns
The converted COLORREF.
The documentation for this class was generated from the following file:
  • XTPPropertyGridItemColor.h


Toolkit Pro: CXTPPropertyGridItemConstraint Class Reference

Public Member Functions | Public Attributes | Protected Attributes | List of all members
CXTPPropertyGridItemConstraint Class Reference

CXTPPropertyGridItemConstraint is a CXTPCmdTarget derived class. More...

Inheritance diagram for CXTPPropertyGridItemConstraint:
[legend]

Public Member Functions

CXTPPropertyGridItemConstraint ()
Constructs a CXTPPropertyGridItemConstraint object.
virtual int | GetIndex () const
Retrieves the index of this constraint within the collection of constraints.
virtual CXTPImageManagerIcon * | GetImage () const
Retrieves the image of this constraint so that it can be used outside of Codejock components.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Public Attributes

CString | m_strConstraint
Caption text of this constraint.
DWORD_PTR | m_dwData
text displayed for this constraint.
int | m_nImage
Image index.
BOOL | m_bEnabled
TRUE if this constraint is enabled.

Protected Attributes

int | m_nIndex
Index of this constraint.
CXTPPropertyGridItem * | m_pItem
Parent item.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

CXTPPropertyGridItemConstraint is a CXTPCmdTarget derived class.

It represents a single item constraint.

Member Function Documentation

◆ GetImage()

virtual CXTPImageManagerIcon * GetImage ( ) const
virtual

Retrieves the image of this constraint so that it can be used outside of Codejock components.

Returns
A pointer to a CXTPImageManagerIcon object containing the image of this constraint.

◆ GetIndex()

AFX_INLINE int GetIndex ( ) const
virtual

Retrieves the index of this constraint within the collection of constraints.

Returns
The index of this constrant within the collection of constraints.

Member Data Documentation

◆ m_strConstraint

CString m_strConstraint

Caption text of this constraint.

This is the

The documentation for this class was generated from the following file:
  • XTPPropertyGridItem.h


Toolkit Pro: CXTPPropertyGridItemConstraints Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPPropertyGridItemConstraints Class Reference

CXTPPropertyGridItemConstraints is a CXTPCmdTarget derived class. More...

Inheritance diagram for CXTPPropertyGridItemConstraints:
[legend]

Public Member Functions

virtual CXTPPropertyGridItemConstraint * | AddConstraint (LPCTSTR str, DWORD_PTR dwData=0, int nImage=-1)
Adds a specified constraint to the collection of constraints.
int | GetCount () const
Gets the number of constraints in the collection.
BOOL | IsEmpty () const
Determines if any constraints have been added to the collection.
void | RemoveAll ()
Removes all constraints from the collection.
void | RemoveAt (int nIndex)
Removes the constraint at a specified index within the collection.
void | SetCurrent (int nIndex)
Sets the current constraint.
int | GetCurrent () const
Gets the index of the current constraint.
int | FindConstraint (LPCTSTR str) const
Retrieves the index of a specified constraint.
int | FindConstraint (DWORD_PTR dwData) const
Retrieves the index of a specified constraint.
CString | GetAt (int nIndex) const
Retrieves the caption of the constraint at a specified index within the collection.
CXTPPropertyGridItemConstraint * | GetConstraintAt (int nIndex) const
Retrieves the constraint at a specified index within the collection.
virtual void | Sort ()
Sorts constraints alphabetically.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

CXTPPropertyGridItemConstraints (CXTPPropertyGridItem *pItem)
Constructs a CXTPPropertyGridItemConstraints object.
~CXTPPropertyGridItemConstraints ()
Destroys a CXTPPropertyGridItemConstraints object, handles cleanup and deallocation.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

CXTPPropertyGridItemConstraints is a CXTPCmdTarget derived class.

It represents the item constraints collection.

Each PropertyGridItem has its own collection of constraints. The CXTPPropertyGridItem::GetConstraints method allows for access to the constraints of a single item. If a combo button is added to the property grid item, then all the constraints in the item's constraints collection will be displayed in the drop-down list. The AddConstraint method is used to add constraints to the collection.

See also
CXTPPropertyGridItem::GetConstraints, CXTPPropertyGridItem::SetConstraintEdit, AddConstraint

Constructor & Destructor Documentation

◆ CXTPPropertyGridItemConstraints()

CXTPPropertyGridItemConstraints ( CXTPPropertyGridItem * pItem )
protected

Constructs a CXTPPropertyGridItemConstraints object.

Parameters
pItem Pointer to the parent CXTPPropertyGridItem object.

Member Function Documentation

◆ AddConstraint()

virtual CXTPPropertyGridItemConstraint * AddConstraint | ( | LPCTSTR | str,
 |  | DWORD_PTR | dwData = 0,
 |  | int | nImage = -1 )
 virtual

Adds a specified constraint to the collection of constraints.

Parameters
str | Constraint to add.
dwData | Data associated with the constraint.
nImage | Image of the constraint.
Returns
A pointer to the newly added constraint.
See also
CXTPPropertyGridItem::OnConstraintsChanged

◆ FindConstraint() [1/2]

int FindConstraint ( DWORD_PTR dwData ) const

Retrieves the index of a specified constraint.

Parameters
dwData Data associated with the constraint with the index to retrieve.
Returns
The zero-based index of the constraint if successful, otherwise a value of -1.

◆ FindConstraint() [2/2]

int FindConstraint ( LPCTSTR str ) const

Retrieves the index of a specified constraint.

Parameters
str Constraint with the index to retrieve.
Returns
The zero-based index of the constraint if successful, otherwise a value of -1.

◆ GetAt()

CString GetAt ( int nIndex ) const

Retrieves the caption of the constraint at a specified index within the collection.

Parameters
nIndex Index of the constraint with the caption to retrieve.

This method only retrieves the caption of the constaint at a specified index. To retrieve the entire constraint at a specified index, use the GetConstraintAt method.

Returns
The caption of the constraint at the specified index if successful, otherwise "".
See also
GetConstraintAt

◆ GetConstraintAt()

CXTPPropertyGridItemConstraint * GetConstraintAt ( int nIndex ) const

Retrieves the constraint at a specified index within the collection.

Parameters
nIndex Index of the constraint to retrieve.

This method retrieves the entire constraint at a specified index. To retrieve only the caption of the constaint at a specified index, use the GetAt method.

Returns
A pointer to the constraint at the specified index.
See also
GetAt

◆ GetCount()

AFX_INLINE int GetCount ( ) const

Gets the number of constraints in the collection.

Returns
The number of constraints in the collection.

◆ GetCurrent()

AFX_INLINE int GetCurrent ( ) const

Gets the index of the current constraint.

Returns
The index of the current constraint.

◆ IsEmpty()

AFX_INLINE BOOL IsEmpty ( ) const

Determines if any constraints have been added to the collection.

Returns
TRUE if there are no constraints in the collection, FALSE if there is at least one constraint in the collection.

◆ RemoveAll()

void RemoveAll ( )

Removes all constraints from the collection.

See also
RemoveAt

◆ RemoveAt()

void RemoveAt ( int nIndex )

Removes the constraint at a specified index within the collection.

Parameters
nIndex Index of the constraint to remove.
See also
RemoveAll

◆ SetCurrent()

AFX_INLINE void SetCurrent ( int nIndex )

Sets the current constraint.

Parameters
nIndex Index of the constraint to be set.
The documentation for this class was generated from the following file:
  • XTPPropertyGridItem.h


Toolkit Pro: CXTPPropertyGridItemDate Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPPropertyGridItemDate Class Reference

CXTPPropertyGridItemDate is a CXTPPropertyGridItem derived class. More...

Inheritance diagram for CXTPPropertyGridItemDate:
[legend]

Public Member Functions

CXTPPropertyGridItemDate (LPCTSTR strCaption, const COleDateTime &oleDate, COleDateTime *pBindDate=NULL)
Constructs a CXTPPropertyGridItemDate object.
CXTPPropertyGridItemDate (UINT nID, const COleDateTime &oleDate, COleDateTime *pBindDate=NULL)
Constructs a CXTPPropertyGridItemDate object.
virtual void | SetDate (const COleDateTime &oleDate)
Sets the date value for the item.
virtual BOOL | GetAsSystemTime (SYSTEMTIME &sysTime)
Converts the time in the COleDateTime object to be represented as a SYSTEMTIME data structure.
virtual const COleDateTime & | GetDate () const
Gets the date value of the item.
virtual long | GetDay ()
Gets the day of the date value of the item.
virtual void | SetDay (long nDay)
Sets the day for the date value of the item.
virtual long | GetMonth ()
Gets the month of the date value of the item.
virtual void | SetMonth (long nMonth)
Sets the month for the date value of the item.
virtual long | GetYear ()
Gets the year of the date value of the item.
virtual void | SetYear (long nYear)
Sets the year for the date value of the item.
virtual BOOL | ParseDateTime (COleDateTime &dt, LPCTSTR strValue)
Parses the month, day, and year from a specified COleDateTime object.
virtual void | SetDateFormat (LPCTSTR strFormat)
Changes the date format.
void | AllowNullDate (LPCTSTR lpszNullValue)
Sets the displayed text for a NULL date.
CString | GetAllowNullDateString () const
Gets the displayed text for a NULL date.
void | BindToDate (COleDateTime *pBindDate)
Binds the item to a specified COleDateTime object.
- Public Member Functions inherited from CXTPPropertyGridItem
CXTPPropertyGridItem (LPCTSTR lpszCaption, LPCTSTR strValue=NULL, CString *pBindString=NULL)
Constructs a CXTPPropertyGridItem object.
CXTPPropertyGridItem (UINT nID, LPCTSTR strValue=NULL, CString *pBindString=NULL)
Constructs a CXTPPropertyGridItem object.
virtual | ~CXTPPropertyGridItem ()
Destroys a CXTPPropertyGridItem object, handles cleanup and deallocation.
void | SetCaption (LPCTSTR lpszCaption)
Sets the caption text for the item.
void | SetPrompt (LPCTSTR lpszPrompt)
Loads a string from a STRINGTABLE resource to set the caption and description for the item.
void | SetDescription (LPCTSTR lpszDescription)
Sets the description text for the item.
void | SetMarkupTemplate (LPCTSTR lpstrMarkupTemplate)
Sets the markup text for the item.
void | SetTooltip (LPCTSTR lpstrTooltip)
Sets the tooltip text for the item.
CString | GetTooltip () const
Gets the tooltip text of the item.
virtual void | SetReadOnly (BOOL bReadOnly=TRUE)
Specifies if the item state should be set to read-only or to read/write.
void | SetID (UINT nID)
Sets the identifier for the item.
void | SetFlags (UINT nFlags)
Sets a specific flag for the item.
CString | GetCaption () const
Gets the caption text of the item.
CString | GetDescription () const
Gets the description text of the item.
virtual CString | GetMarkupTemplate () const
Gets the markup text of the item.
virtual BOOL | GetReadOnly () const
Determines if the item state is set to read-only or to read/write.
virtual BOOL | IsAllowEdit () const
Determines if items in the property grid are allowed to be edited by the user.
UINT | GetID () const
Gets the identifier of the item.
int | GetIndex () const
Gets the index of the item within the property grid list.
CString | GetValue () const
Gets the value of the item.
CString | GetDefaultValue () const
Gets the default value of the item.
UINT | GetFlags () const
Gets the flags of the item.
BOOL | IsCategory () const
Determines if the item is a category.
CXTPPropertyGridItem * | AddChildItem (CXTPPropertyGridItem *pItem)
Adds a child item.
void | Move (CXTPPropertyGridItem *pParent, int nIndex=-1)
Moves the item to another category.
CXTPPropertyGridItem * | InsertChildItem (int nIndex, CXTPPropertyGridItem *pItem)
Inserts a child item.
BOOL | HasChilds () const
Determines if the item has children.
BOOL | HasVisibleChilds () const
Determines if the item has visible children.
CXTPPropertyGridItems * | GetChilds () const
Gets the item's list of child items.
BOOL | HasParent (CXTPPropertyGridItem *pParent)
Determines if the item has a specified item as a parent.
CXTPPropertyGridItemConstraints * | GetConstraints () const
Gets the item's list of constraints.
void | SetConstraintEdit (BOOL bConstraintEdit=TRUE)
Enables/disables constraint editing mode.
void | SetAutoComplete (BOOL bAutoComplete=TRUE)
Enables/disables auto-complete for the constraint list.
BOOL | GetConstraintEdit () const
Determines if constraint editing mode is enabled/disabled.
void | Expand ()
Expands the item.
void | Collapse ()
Collapses the item.
void | SetExpandable (BOOL bExpandable)
Specifies if the item should be expandable by the user.
BOOL | IsExpandable () const
Determines if the item is expandable by the user.
void | Select ()
Selects the item.
CRect | GetItemRect () const
Gets the bounding rectangle of the item.
virtual CRect | GetValueRect ()
Gets the bounding rectangle of the item value's text.
void | SetHidden (BOOL bHidden)
Hides/shows the item.
BOOL | IsHidden () const
Determines if the item is hidden/shown.
virtual void | OnMarkupChanged ()
This method is called when the markup text of the item is changed.
CXTPPropertyGridView * | GetGrid () const
Gets the parent window.
BOOL | IsVisible () const
Determines the visible state of the item.
BOOL | IsExpanded () const
Determines the expanded state of the item.
CXTPPropertyGridItem * | GetParentItem () const
Gets the parent item of this item, if any.
int | GetIndent () const
Gets the indent of the item.
virtual BOOL | OnDrawItemValue (CDC &dc, CRect rcValue)
This method is called when an item is drawn.
virtual void | OnDrawItemConstraint (CDC *pDC, CXTPPropertyGridItemConstraint *pConstraint, CRect rc, BOOL bSelected)
This method is called when a constraint in an in-place list is drawn.
virtual CSize | OnMergeItemConstraint (CDC *pDC, CXTPPropertyGridItemConstraint *pConstraint)
This method is called to get size of constraint in in-place list.
virtual void | MeasureItem (LPMEASUREITEMSTRUCT lpMeasureItemStruct)
Override this method and fill in a specified MEASUREITEMSTRUCT structure to inform Windows of the list-box dimensions.
BOOL | IsSelected () const
Determines the selected stae of the item.
void | BindToString (CString *pBindString)
Binds the item to a specified CString object.
void | Remove ()
Removes this item.
void | SetMask (LPCTSTR strMask, LPCTSTR strLiteral, TCHAR chPrompt=_T('_'))
Applies a specified mask to a CXTPPropertyGridItem data field to create a restrictive field for text entry.
void | SetPasswordMask (TCHAR chMask=_T(' *'))
Sets a password mask for the item.
CString | GetMaskedText () const
Gets the actual text value of the item without mask characters.
virtual BOOL | IsValueChanged () const
Determines if the value of the item was changed by the user.
virtual void | ResetValue ()
Resets the value of the item to its default value.
void | SetDefaultValue (LPCTSTR lpszDefaultValue)
Sets the default value for the item.
void | SetMaskedText (LPCTSTR lpszMaskedText)
Sets the actual text value for the item without mask characters.
virtual CString | GetViewValue ()
Gets the value of the item that the user is currently viewing.
void | SetItemData (DWORD_PTR dwData)
Sets the 32-bit value associated with the item.
DWORD_PTR | GetItemData () const
Gets the application-supplied, 32-bit value associated with the item.
virtual CXTPPropertyGridInplaceEdit & | GetInplaceEdit ()
Gets the in-place edit control of the item.
virtual void | SetFocusToInplaceControl ()
Sets focus to the in-place control of the item.
virtual BOOL | IsInplaceButtonVisible (CXTPPropertyGridInplaceButton *pButton) const
Determines if a specified in-place button is visible.
CXTPPropertyGridInplaceButtons * | GetInplaceButtons () const
Gets the collection of in-place buttons of the item.
CXTPPropertyGridInplaceControls * | GetInplaceControls () const
Gets the collection of in-place controls of the item.
void | AddComboButton ()
Adds a standard combo button.
void | AddExpandButton ()
Adds a standard expand button.
CXTPPropertyGridInplaceSlider * AddSliderControl ()
Adds a slider control.
CXTPPropertyGridInplaceSpinButton * AddSpinButton ()
Adds a spin button control.
CXTPPropertyGridItemMetrics * | GetValueMetrics () const
Gets the metrics of the value part.
CXTPPropertyGridItemMetrics * | GetCaptionMetrics () const
Gets the metrics of the caption part.
CXTPPropertyGridItemMetrics * | GetMetrics (BOOL bValueMetrics, BOOL bCreate=TRUE) const
Gets the metrics of the value/caption part.
int | GetHeight () const
Gets the variable height of the item.
void | SetHeight (int nHeight)
Sets the variable height of the item.
BOOL | IsMultiLine () const
Determines if the item is multi-line (i.e.
int | GetMultiLinesCount () const
Gets the number of lines of the item.
void | SetMultiLinesCount (int nLinesCount)
Sets the number of lines for the item.
void | EnsureVisible ()
Ensures that this item is visible.
virtual BOOL | OnRequestEdit ()
This method is called before the user begins editing the item.
virtual BOOL | OnAfterEdit (CString &strValue)
This method is called before the user applies a new value to the item.
virtual void | OnCancelEdit ()
This method is called if the user cancels editing the item.
void | SetEditStyle (DWORD dwEditStyle)
Sets the edit style for the item.
void | SetDropDownItemCount (int nDropDownItemCount)
Sets the number of items in the dropdown list.
int | GetDropDownItemCount () const
Gets the number of items in the dropdown list.
virtual void | OnValidateEdit ()
This method is called to check the value from the in-place edit control.
CXTPMarkupUIElement * | GetMarkupCaption () const
Gets the CXTPMarkupUIElement object that renders the caption of the item.
CXTPMarkupUIElement * | GetMarkupDescription () const
Gets the CXTPMarkupUIElement object that renders the description of the item in the Help pane.
CXTPMarkupUIElement * | GetMarkupValue () const
Gets the CXTPMarkupUIElement object that renders the value of the item in the property grid.
virtual DWORD | GetEditStyle () const
Gets the edit style of the item.
void | RedrawItem ()
Redraws the item.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

virtual CString | Format (const COleDateTime &oleDate)
virtual void | OnInplaceButtonDown (CXTPPropertyGridInplaceButton *pButton)
This method is called when the user presses the in-place button.
virtual void | SetValue (CString strValue)
Sets the value of the item.
void | OnValueChanged (CString strValue)
This method is called when the value of the item is changed.
virtual void | OnBeforeInsert ()
This method is called before the item becomes visible in the property grid.
- Protected Member Functions inherited from CXTPPropertyGridItem
virtual void | SetVisible (BOOL bVisible)
Sets the visible state of the item.
virtual void | OnIndexChanged ()
This method is called when the index of the item is changed.
virtual void | OnSelect ()
This method is called when an item is selected.
virtual void | OnDeselect ()
This method is called when an item is de-selected.
virtual BOOL | OnChar (UINT nChar)
This method is called when a key is pressed.
virtual void | OnLButtonDblClk (UINT nFlags, CPoint point)
This method is called when the user double-clicks the left mouse button on the item.
virtual void | OnRButtonDown (UINT nFlags, CPoint point)
This method is called when the user presses the right mouse button on the item.
virtual BOOL | OnLButtonDown (UINT nFlags, CPoint point)
This method is called when the user presses the left mouse button on the item.
virtual void | OnLButtonUp (UINT nFlags, CPoint point)
This method is called when the user releases the left mouse button on the item.
virtual BOOL | OnKeyDown (UINT nChar)
This method is called when a non-system key is pressed.
virtual void | OnAddChildItem ()
This method is called when an item is added to the parent.
virtual CXTPPropertyGridInplaceList & | GetInplaceList ()
Gets the in-place list control of the item.
virtual void | SetEditText (const CString &str)
Sets the text for the in-place edit control.
virtual void | OnConstraintsChanged ()
This method is called when constraints are added to the item (i.e.
virtual void | OnCaptionChanged ()
This method is called when the caption of the item is changed.
virtual BOOL | OnInpaceControlFocus (BOOL bForward)
This method is called by the property grid to set focus to an in-place child window.
virtual CString | GetInPlacedEditValue ()
Gets the text of the in-place edit control.
void | NotifyValueChanged ()
This method is called when the item's value is changed.
BOOL | SelectNextConstraint ()
Selects the next constraint in the list of constraints.
BOOL | PtInValueRect (CPoint point)
Determines if a specified point is within the value rectangle.

Protected Attributes

COleDateTime | m_oleDate
Currently selected date.
CString | m_strNullValue
String value to be displayed for the Date item when the current date is NULL.
COleDateTime * | m_pBindDate
Pointer to the variable bound to this item.
- Protected Attributes inherited from CXTPPropertyGridItem
BOOL | m_bConstraintEdit
TRUE to constraint edit.
int | m_nIndex
Index of the item.
int | m_nIndent
Indent of the item.
UINT | m_nID
Identifier of the item.
UINT | m_nFlags
Item's flags.
BOOL | m_bReadOnly
TRUE if the item state is set to read-only, FALSE if the item state is set to read/write.
BOOL | m_bVisible
Visibility of the item.
BOOL | m_bCategory
TRUE if the item is a category.
BOOL | m_bExpandable
TRUE if the item can be expanded.
BOOL | m_bExpanded
TRUE if the item is expanded.
CString | m_strValue
Value of the item.
CString | m_strDefaultValue
Default value of the item.
CString | m_strCaption
Caption of the item.
CString | m_strDescription
Description of the item.
CString | m_strTooltip
Tooltip text.
CXTPPropertyGridItem * | m_pParent
Parent item.
CXTPPropertyGridView * | m_pGrid
Parent grid class.
CXTPPropertyGridItems * | m_pChilds
Child items.
CXTPPropertyGridItemConstraints * | m_pConstraints
Item's constraints.
BOOL | m_bAutoComplete
TRUE to enable auto-complete for the item.
CXTPPropertyGridItemMetrics * | m_pValueMetrics
Value part metrics.
CXTPPropertyGridItemMetrics * | m_pCaptionMetrics
Caption part metrics.
CXTPPropertyGridInplaceButtons * | m_pInplaceButtons
In-place buttons array.
CXTPPropertyGridInplaceControls * | m_pInplaceControls
In-place controls array.
int | m_nDropDownItemCount
Maximum drop down items.
CString * | m_pBindString
Bound string.
CString | m_strFormat
Format of the double value.
CString | m_strMask
String to use as edit mask.
CString | m_strLiteral
String to use as literal.
CString | m_strMarkupTemplate
String that represents item's display when markup is on.
TCHAR | m_chPrompt
Character used as a space holder for a character.
BOOL | m_bUseMask
TRUE to use an edit mask to display item data.
BOOL | m_bPassword
TRUE to use a password mask.
DWORD_PTR | m_dwData
The 32-bit value associated with the item.
BOOL | m_bHidden
TRUE if the item is hidden, FALSE if the item is shown.
int | m_nHeight
Item's height; -1 to use the default.
int | m_nLinesCount
Number of lines in a multi-line item.
DWORD | m_dwEditStyle
Edit style.
CXTPMarkupUIElement * | m_pMarkupCaption
Markup UIElement for item's caption.
CXTPMarkupUIElement * | m_pMarkupDescription
Markup UIElement for item's description.
CXTPMarkupUIElement * | m_pMarkupValue
Markup UIElement for item's value.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Static Protected Member Functions inherited from CXTPPropertyGridItem

Detailed Description

CXTPPropertyGridItemDate is a CXTPPropertyGridItem derived class.

It is used to create a Date item in a Property Grid control.

When the in-place button for a date item is pressed, a CXTPPropertyGridInplaceMonthCal object is created, which is a User Interface that allows the user to easily select a date.

Example: This sample illustrates how to add an item of type Date to your grid:

CXTPPropertyGridItem* pStandard   = m_wndPropertyGrid.AddCategory(_T("Appointments"));

//Create a Date object with the date 12/26/2004.  Note that no time information is entered
//because this information is ignored.
COleDateTime dates(2004, 12, 26, 0, 0, 0);

//Adds a date item to the property grid and set the date to the value stored in dates
CXTPPropertyGridItemDate* pDate = (CXTPPropertyGridItemDate*)(pStandard->AddChildItem(new
CXTPPropertyGridItemDate(_T("Date item"), dates)));

//Set the date format to MM/DD/YYYY
pDate->SetDateFormat("\%m/\%d/\%Y");

//Changes the date to 3/22/2001
COleDateTime newDate(2003, 5, 12, 0, 0, 0);

//Changes the date of the Date item.
pDate->SetDate(newDate);

//Gets the currently set date
TRACE(_T("Current Date= \%d/\%d/\%d\n"), pDate->GetMonth(), pDate->GetDay(), pDate->GetYear());
See also
SetDate, GetMonth, GetDay, GetYear, SetDateFormat

Constructor & Destructor Documentation

◆ CXTPPropertyGridItemDate() [1/2]

CXTPPropertyGridItemDate | ( | LPCTSTR | strCaption,
 |  | const COleDateTime & | oleDate,
 |  | COleDateTime * | pBindDate = NULL )

Constructs a CXTPPropertyGridItemDate object.

Parameters
strCaption | Caption of the item.
oleDate | Reference to a COleDateTime object containing the initial date value of the item.
pBindDate | If not NULL, then the value of the item is bound the value of this variable.

◆ CXTPPropertyGridItemDate() [2/2]

CXTPPropertyGridItemDate | ( | UINT | nID,
 |  | const COleDateTime & | oleDate,
 |  | COleDateTime * | pBindDate = NULL )

Constructs a CXTPPropertyGridItemDate object.

Parameters
nID | Identifier of the item.
oleDate | Reference to a COleDateTime object containing the initial date value of the item.
pBindDate | If not NULL, then the value of the item is bound the value of this variable.

Member Function Documentation

◆ AllowNullDate()

void AllowNullDate ( LPCTSTR lpszNullValue )

Sets the displayed text for a NULL date.

Parameters
lpszNullValue Text to be set.

◆ BindToDate()

void BindToDate ( COleDateTime * pBindDate )

Binds the item to a specified COleDateTime object.

Parameters
pBindDate Pointer to a COleDateTime object.

Variables can be bound to an item in two ways, the first is to pass in a variable at the time of creation, the second allows variables to be bound to an item after creation with the BindToDate member.

Bound variables store the values of the property grid items and can be accessed without using the property grid methods and properties. Bound variables allow the property grid to store data in variables. When the value of a PropertyGridItem is changed, the value of the bound variable will be changed to the PropertyGridItem value. The advantage of binding is that the variable can be used and manipulated without using PropertyGridItem methods and properties.

NOTE: If the value of the variable is changed without using the PropertyGrid, the PropertyGridItem value will not be updated until you call CXTPPropertyGrid::Refresh.

◆ Format()

virtual CString Format ( const COleDateTime & oleDate )
protectedvirtual
Parameters
oleDate Reference to the COleDateTime object to be formatted.
Returns
Formats a specified COleDateTime object

◆ GetAllowNullDateString()

CString GetAllowNullDateString ( ) const

Gets the displayed text for a NULL date.

Returns
The displayed text for a NULL date.

◆ GetAsSystemTime()

virtual BOOL GetAsSystemTime ( SYSTEMTIME & sysTime )
virtual

Converts the time in the COleDateTime object to be represented as a SYSTEMTIME data structure.

The resulting time will be stored in the SYSTEMTIME data structure specified by sysTime.

Parameters
sysTime Reference to a SYSTEMTIME data structure to receive the resulting time.

The SYSTEMTIME data structure initialized by this method will have its wMilliseconds member set to zero.

Returns
TRUE if the time in the COleDateTime object was successfully stored in the SYSTEMTIME data structure specified by sysTime.

Example: This sample code illustrates how to use the GetAsSystemTime member:

CXTPPropertyGridItem* pStandard   = m_wndPropertyGrid.AddCategory(_T("Appointments"));

//Create a Date object with the date 12/26/2004.  Note that no time information is entered
//because this information is ignored.
COleDateTime dates(2004, 12, 26, 0, 0, 0);

//Adds a date item to the property grid and set the date to the value stored in dates
CXTPPropertyGridItemDate* pDate = (CXTPPropertyGridItemDate*)(pStandard->AddChildItem(new
CXTPPropertyGridItemDate(_T("Date item"), dates)));

//Creates a SYSTEMTIME object
SYSTEMTIME sysTime;

//Stores the day, month, and year into the SYSTEMTIME structure, all other members will be 0.
if (pDate->GetAsSystemTime(sysTime))
TRACE(_T("SysTime Current Date= \%d/\%d/\%d\n"), sysTime.wMonth, sysTime.wDay,
sysTime.wYear);

◆ GetDate()

AFX_INLINE const COleDateTime & GetDate ( ) const
virtual

Gets the date value of the item.

Returns
A reference to a COleDateTime object containing the date value.

◆ GetDay()

virtual long GetDay ( )
virtual

Gets the day of the date value of the item.

Returns
The day of the date value of the item.

◆ GetMonth()

virtual long GetMonth ( )
virtual

Gets the month of the date value of the item.

Returns
The month of the date value of the item.

◆ GetYear()

virtual long GetYear ( )
virtual

Gets the year of the date value of the item.

Returns
The year of the date value of the item.

◆ OnBeforeInsert()

virtual void OnBeforeInsert ( )
protectedvirtual

This method is called before the item becomes visible in the property grid.

Before the item is inserted, it is first checked to see if it is bound to a variable. If it is, then the value of the item is updated with the value stored in the bound variable.

OnBeforeInsert is called when an item is inserted, when a category is inserted, when a category or item is expanded, and when the sort property has changed.

Reimplemented from CXTPPropertyGridItem.

◆ OnInplaceButtonDown()

virtual void OnInplaceButtonDown ( CXTPPropertyGridInplaceButton * pButton )
protectedvirtual

This method is called when the user presses the in-place button.

Override this method to show an item-specific dialog.

Parameters
pButton Pointer to the button that was pressed.

The in-place button is the button that the user presses to display the date picker dialog.

Reimplemented from CXTPPropertyGridItem.

◆ OnValueChanged()

void OnValueChanged ( CString strValue )
protectedvirtual

This method is called when the value of the item is changed.

Override this method if needed.

Parameters
strValue New value of the item.

Reimplemented from CXTPPropertyGridItem.

◆ ParseDateTime()

virtual BOOL ParseDateTime | ( | COleDateTime & | dt,
 |  | LPCTSTR | strValue )
 virtual

Parses the month, day, and year from a specified COleDateTime object.

Parameters
dt | Reference to a COleDateTime object containing the month, day, and year.
strValue | The date format: %m Month as decimal number (01 12). %d Day of month as decimal number (01 31). %Y Year with century, as decimal number. Format string for 05/22/2004 is "%m%d%Y".
Returns
TRUE if a valid date was extracted, FALSE if either an invalid or a NULL date was extracted.

◆ SetDate()

virtual void SetDate ( const COleDateTime & oleDate )
virtual

Sets the date value for the item.

Parameters
oleDate Reference to a COleDateTime object containing the date value. This value must include the month, day, and year and all time information should be set to zero.

Example: This sample illustrates how to set the currently selected date in and item of type CXTPPropertyGridItemDate:

CXTPPropertyGridItem* pStandard   = m_wndPropertyGrid.AddCategory(_T("Appointments"));

//Create a Date object with the date 12/26/2004.  Note that no time information is entered
//because this information is ignored.
COleDateTime dates(2004, 12, 26, 0, 0, 0);

//Adds a date item to the property grid and set the date to the value stored in dates
CXTPPropertyGridItemDate* pDate = (CXTPPropertyGridItemDate*)(pStandard->AddChildItem(new
CXTPPropertyGridItemDate(_T("Date item"), dates)));

//Set the date format to MM/DD/YYYY
pDate->SetDateFormat("\%m/\%d/\%Y");

//Changes the date to 3/22/2001
COleDateTime newDate(2003, 5, 12, 0, 0, 0);

//Changes the date of the Date item.
pDate->SetDate(newDate);

//Gets the currently set date
TRACE(_T("Current Date= \%d/\%d/\%d\n"), pDate->GetMonth(), pDate->GetDay(),
pDate->GetYear());

◆ SetDateFormat()

virtual void SetDateFormat ( LPCTSTR strFormat )
virtual

Changes the date format.

Parameters
strFormat The date format: %m Month as decimal number (01 12). %d Day of month as decimal number (01 31). %Y Year with century, as decimal number. Format string for 05/22/2004 is "\%m\%d\%Y".

Example: This sample code illustrates how to change the date format of of type CXTPPropertyGridItemDate:

CXTPPropertyGridItem* pStandard   = m_wndPropertyGrid.AddCategory(_T("Appointments"));

//Create a Date object with the date 12/26/2004.  Note that no time information is entered
//because this information is ignored.
COleDateTime dates(2004, 12, 26, 0, 0, 0);

//Adds a date item to the property grid and set the date to the value stored in dates
CXTPPropertyGridItemDate* pDate = (CXTPPropertyGridItemDate*)(pStandard->AddChildItem(new
CXTPPropertyGridItemDate(_T("Date item"), dates)));

//Set the date format to MM/DD/YYYY
pDate->SetDateFormat("\%m/\%d/\%Y");

◆ SetDay()

virtual void SetDay ( long nDay )
virtual

Sets the day for the date value of the item.

Parameters
nDay Day to be set.

◆ SetMonth()

virtual void SetMonth ( long nMonth )
virtual

Sets the month for the date value of the item.

Parameters
nMonth Month to be set.

◆ SetValue()

virtual void SetValue ( CString strValue )
protectedvirtual

Sets the value of the item.

Override this method to add new functionality. You should call the base class version of this function from your override.

Parameters
strValue Value to be set.

Reimplemented from CXTPPropertyGridItem.

◆ SetYear()

virtual void SetYear ( long nYear )
virtual

Sets the year for the date value of the item.

Parameters
nYear Year to be set.

Member Data Documentation

◆ m_oleDate

COleDateTime m_oleDate
protected

Currently selected date.

Only Month, Day, and Year are used.

The documentation for this class was generated from the following file:
  • XTPPropertyGridItemExt.h


Toolkit Pro: CXTPPropertyGridItemDouble Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPPropertyGridItemDouble Class Reference

CXTPPropertyGridItemDouble is a CXTPPropertyGridItem derived class. More...

Inheritance diagram for CXTPPropertyGridItemDouble:
[legend]

Public Member Functions

CXTPPropertyGridItemDouble (LPCTSTR strCaption, double fValue=0, LPCTSTR strFormat=NULL, double *pBindNumber=NULL)
Constructs a CXTPPropertyGridItemDouble object.
CXTPPropertyGridItemDouble (UINT nID, double fValue=0, LPCTSTR strFormat=NULL, double *pBindNumber=NULL)
Constructs a CXTPPropertyGridItemDouble object.
virtual | ~CXTPPropertyGridItemDouble ()
Destroys a CXTPPropertyGridItemDouble object.
virtual void | SetDouble (double fValue)
Sets the double value for the item.
virtual double | GetDouble () const
Gets the double value of the item.
virtual void | BindToDouble (double *pBindDouble)
Binds the item to a specified double value.
void | UseSystemDecimalSymbol (BOOL bUseSystemDecimalSymbol)
Specifies which type of symbol should be used to divide the whole and decimal parts of numbers.
- Public Member Functions inherited from CXTPPropertyGridItem
CXTPPropertyGridItem (LPCTSTR lpszCaption, LPCTSTR strValue=NULL, CString *pBindString=NULL)
Constructs a CXTPPropertyGridItem object.
CXTPPropertyGridItem (UINT nID, LPCTSTR strValue=NULL, CString *pBindString=NULL)
Constructs a CXTPPropertyGridItem object.
virtual | ~CXTPPropertyGridItem ()
Destroys a CXTPPropertyGridItem object, handles cleanup and deallocation.
void | SetCaption (LPCTSTR lpszCaption)
Sets the caption text for the item.
void | SetPrompt (LPCTSTR lpszPrompt)
Loads a string from a STRINGTABLE resource to set the caption and description for the item.
void | SetDescription (LPCTSTR lpszDescription)
Sets the description text for the item.
void | SetMarkupTemplate (LPCTSTR lpstrMarkupTemplate)
Sets the markup text for the item.
void | SetTooltip (LPCTSTR lpstrTooltip)
Sets the tooltip text for the item.
CString | GetTooltip () const
Gets the tooltip text of the item.
virtual void | SetReadOnly (BOOL bReadOnly=TRUE)
Specifies if the item state should be set to read-only or to read/write.
void | SetID (UINT nID)
Sets the identifier for the item.
void | SetFlags (UINT nFlags)
Sets a specific flag for the item.
CString | GetCaption () const
Gets the caption text of the item.
CString | GetDescription () const
Gets the description text of the item.
virtual CString | GetMarkupTemplate () const
Gets the markup text of the item.
virtual BOOL | GetReadOnly () const
Determines if the item state is set to read-only or to read/write.
virtual BOOL | IsAllowEdit () const
Determines if items in the property grid are allowed to be edited by the user.
UINT | GetID () const
Gets the identifier of the item.
int | GetIndex () const
Gets the index of the item within the property grid list.
CString | GetValue () const
Gets the value of the item.
CString | GetDefaultValue () const
Gets the default value of the item.
UINT | GetFlags () const
Gets the flags of the item.
BOOL | IsCategory () const
Determines if the item is a category.
CXTPPropertyGridItem * | AddChildItem (CXTPPropertyGridItem *pItem)
Adds a child item.
void | Move (CXTPPropertyGridItem *pParent, int nIndex=-1)
Moves the item to another category.
CXTPPropertyGridItem * | InsertChildItem (int nIndex, CXTPPropertyGridItem *pItem)
Inserts a child item.
BOOL | HasChilds () const
Determines if the item has children.
BOOL | HasVisibleChilds () const
Determines if the item has visible children.
CXTPPropertyGridItems * | GetChilds () const
Gets the item's list of child items.
BOOL | HasParent (CXTPPropertyGridItem *pParent)
Determines if the item has a specified item as a parent.
CXTPPropertyGridItemConstraints * | GetConstraints () const
Gets the item's list of constraints.
void | SetConstraintEdit (BOOL bConstraintEdit=TRUE)
Enables/disables constraint editing mode.
void | SetAutoComplete (BOOL bAutoComplete=TRUE)
Enables/disables auto-complete for the constraint list.
BOOL | GetConstraintEdit () const
Determines if constraint editing mode is enabled/disabled.
void | Expand ()
Expands the item.
void | Collapse ()
Collapses the item.
void | SetExpandable (BOOL bExpandable)
Specifies if the item should be expandable by the user.
BOOL | IsExpandable () const
Determines if the item is expandable by the user.
void | Select ()
Selects the item.
CRect | GetItemRect () const
Gets the bounding rectangle of the item.
virtual CRect | GetValueRect ()
Gets the bounding rectangle of the item value's text.
void | SetHidden (BOOL bHidden)
Hides/shows the item.
BOOL | IsHidden () const
Determines if the item is hidden/shown.
virtual void | OnValueChanged (CString strValue)
This method is called when the value of the item is changed.
virtual void | OnMarkupChanged ()
This method is called when the markup text of the item is changed.
CXTPPropertyGridView * | GetGrid () const
Gets the parent window.
BOOL | IsVisible () const
Determines the visible state of the item.
BOOL | IsExpanded () const
Determines the expanded state of the item.
CXTPPropertyGridItem * | GetParentItem () const
Gets the parent item of this item, if any.
int | GetIndent () const
Gets the indent of the item.
virtual BOOL | OnDrawItemValue (CDC &dc, CRect rcValue)
This method is called when an item is drawn.
virtual void | OnDrawItemConstraint (CDC *pDC, CXTPPropertyGridItemConstraint *pConstraint, CRect rc, BOOL bSelected)
This method is called when a constraint in an in-place list is drawn.
virtual CSize | OnMergeItemConstraint (CDC *pDC, CXTPPropertyGridItemConstraint *pConstraint)
This method is called to get size of constraint in in-place list.
virtual void | MeasureItem (LPMEASUREITEMSTRUCT lpMeasureItemStruct)
Override this method and fill in a specified MEASUREITEMSTRUCT structure to inform Windows of the list-box dimensions.
BOOL | IsSelected () const
Determines the selected stae of the item.
void | BindToString (CString *pBindString)
Binds the item to a specified CString object.
void | Remove ()
Removes this item.
void | SetMask (LPCTSTR strMask, LPCTSTR strLiteral, TCHAR chPrompt=_T('_'))
Applies a specified mask to a CXTPPropertyGridItem data field to create a restrictive field for text entry.
void | SetPasswordMask (TCHAR chMask=_T(' *'))
Sets a password mask for the item.
CString | GetMaskedText () const
Gets the actual text value of the item without mask characters.
virtual BOOL | IsValueChanged () const
Determines if the value of the item was changed by the user.
virtual void | ResetValue ()
Resets the value of the item to its default value.
void | SetDefaultValue (LPCTSTR lpszDefaultValue)
Sets the default value for the item.
void | SetMaskedText (LPCTSTR lpszMaskedText)
Sets the actual text value for the item without mask characters.
virtual CString | GetViewValue ()
Gets the value of the item that the user is currently viewing.
void | SetItemData (DWORD_PTR dwData)
Sets the 32-bit value associated with the item.
DWORD_PTR | GetItemData () const
Gets the application-supplied, 32-bit value associated with the item.
virtual CXTPPropertyGridInplaceEdit & | GetInplaceEdit ()
Gets the in-place edit control of the item.
virtual void | SetFocusToInplaceControl ()
Sets focus to the in-place control of the item.
virtual BOOL | IsInplaceButtonVisible (CXTPPropertyGridInplaceButton *pButton) const
Determines if a specified in-place button is visible.
CXTPPropertyGridInplaceButtons * | GetInplaceButtons () const
Gets the collection of in-place buttons of the item.
CXTPPropertyGridInplaceControls * | GetInplaceControls () const
Gets the collection of in-place controls of the item.
void | AddComboButton ()
Adds a standard combo button.
void | AddExpandButton ()
Adds a standard expand button.
CXTPPropertyGridInplaceSlider * AddSliderControl ()
Adds a slider control.
CXTPPropertyGridInplaceSpinButton * AddSpinButton ()
Adds a spin button control.
CXTPPropertyGridItemMetrics * | GetValueMetrics () const
Gets the metrics of the value part.
CXTPPropertyGridItemMetrics * | GetCaptionMetrics () const
Gets the metrics of the caption part.
CXTPPropertyGridItemMetrics * | GetMetrics (BOOL bValueMetrics, BOOL bCreate=TRUE) const
Gets the metrics of the value/caption part.
int | GetHeight () const
Gets the variable height of the item.
void | SetHeight (int nHeight)
Sets the variable height of the item.
BOOL | IsMultiLine () const
Determines if the item is multi-line (i.e.
int | GetMultiLinesCount () const
Gets the number of lines of the item.
void | SetMultiLinesCount (int nLinesCount)
Sets the number of lines for the item.
void | EnsureVisible ()
Ensures that this item is visible.
virtual BOOL | OnRequestEdit ()
This method is called before the user begins editing the item.
virtual BOOL | OnAfterEdit (CString &strValue)
This method is called before the user applies a new value to the item.
virtual void | OnCancelEdit ()
This method is called if the user cancels editing the item.
void | SetEditStyle (DWORD dwEditStyle)
Sets the edit style for the item.
void | SetDropDownItemCount (int nDropDownItemCount)
Sets the number of items in the dropdown list.
int | GetDropDownItemCount () const
Gets the number of items in the dropdown list.
virtual void | OnValidateEdit ()
This method is called to check the value from the in-place edit control.
CXTPMarkupUIElement * | GetMarkupCaption () const
Gets the CXTPMarkupUIElement object that renders the caption of the item.
CXTPMarkupUIElement * | GetMarkupDescription () const
Gets the CXTPMarkupUIElement object that renders the description of the item in the Help pane.
CXTPMarkupUIElement * | GetMarkupValue () const
Gets the CXTPMarkupUIElement object that renders the value of the item in the property grid.
virtual DWORD | GetEditStyle () const
Gets the edit style of the item.
void | RedrawItem ()
Redraws the item.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

virtual void | SetValue (CString strValue)
Sets the value of the item.
virtual void | OnBeforeInsert ()
This method is called before the item becomes visible in the property grid.
virtual double | StringToDouble (LPCTSTR lpszValue)
Converts a specified string to a double.
virtual CString | DoubleToString (double dValue)
Converts a specified double to a string.
- Protected Member Functions inherited from CXTPPropertyGridItem
virtual void | SetVisible (BOOL bVisible)
Sets the visible state of the item.
virtual void | OnIndexChanged ()
This method is called when the index of the item is changed.
virtual void | OnSelect ()
This method is called when an item is selected.
virtual void | OnDeselect ()
This method is called when an item is de-selected.
virtual BOOL | OnChar (UINT nChar)
This method is called when a key is pressed.
virtual void | OnLButtonDblClk (UINT nFlags, CPoint point)
This method is called when the user double-clicks the left mouse button on the item.
virtual void | OnRButtonDown (UINT nFlags, CPoint point)
This method is called when the user presses the right mouse button on the item.
virtual BOOL | OnLButtonDown (UINT nFlags, CPoint point)
This method is called when the user presses the left mouse button on the item.
virtual void | OnLButtonUp (UINT nFlags, CPoint point)
This method is called when the user releases the left mouse button on the item.
virtual BOOL | OnKeyDown (UINT nChar)
This method is called when a non-system key is pressed.
virtual void | OnAddChildItem ()
This method is called when an item is added to the parent.
virtual void | OnInplaceButtonDown (CXTPPropertyGridInplaceButton *pButton)
This method is called when the user presses the in-place button.
virtual CXTPPropertyGridInplaceList & | GetInplaceList ()
Gets the in-place list control of the item.
virtual void | SetEditText (const CString &str)
Sets the text for the in-place edit control.
virtual void | OnConstraintsChanged ()
This method is called when constraints are added to the item (i.e.
virtual void | OnCaptionChanged ()
This method is called when the caption of the item is changed.
virtual BOOL | OnInpaceControlFocus (BOOL bForward)
This method is called by the property grid to set focus to an in-place child window.
virtual CString | GetInPlacedEditValue ()
Gets the text of the in-place edit control.
void | NotifyValueChanged ()
This method is called when the item's value is changed.
BOOL | SelectNextConstraint ()
Selects the next constraint in the list of constraints.
BOOL | PtInValueRect (CPoint point)
Determines if a specified point is within the value rectangle.

Protected Attributes

double | m_fValue
Double value of the item.
double * | m_pBindDouble
Pointer to the variable bound to this item.
BOOL | m_bUseSystemDecimalSymbol
TRUE to use the system defined decimal symbol, FALSE to always use a decimal point ".".
- Protected Attributes inherited from CXTPPropertyGridItem
BOOL | m_bConstraintEdit
TRUE to constraint edit.
int | m_nIndex
Index of the item.
int | m_nIndent
Indent of the item.
UINT | m_nID
Identifier of the item.
UINT | m_nFlags
Item's flags.
BOOL | m_bReadOnly
TRUE if the item state is set to read-only, FALSE if the item state is set to read/write.
BOOL | m_bVisible
Visibility of the item.
BOOL | m_bCategory
TRUE if the item is a category.
BOOL | m_bExpandable
TRUE if the item can be expanded.
BOOL | m_bExpanded
TRUE if the item is expanded.
CString | m_strValue
Value of the item.
CString | m_strDefaultValue
Default value of the item.
CString | m_strCaption
Caption of the item.
CString | m_strDescription
Description of the item.
CString | m_strTooltip
Tooltip text.
CXTPPropertyGridItem * | m_pParent
Parent item.
CXTPPropertyGridView * | m_pGrid
Parent grid class.
CXTPPropertyGridItems * | m_pChilds
Child items.
CXTPPropertyGridItemConstraints * | m_pConstraints
Item's constraints.
BOOL | m_bAutoComplete
TRUE to enable auto-complete for the item.
CXTPPropertyGridItemMetrics * | m_pValueMetrics
Value part metrics.
CXTPPropertyGridItemMetrics * | m_pCaptionMetrics
Caption part metrics.
CXTPPropertyGridInplaceButtons * | m_pInplaceButtons
In-place buttons array.
CXTPPropertyGridInplaceControls * | m_pInplaceControls
In-place controls array.
int | m_nDropDownItemCount
Maximum drop down items.
CString * | m_pBindString
Bound string.
CString | m_strFormat
Format of the double value.
CString | m_strMask
String to use as edit mask.
CString | m_strLiteral
String to use as literal.
CString | m_strMarkupTemplate
String that represents item's display when markup is on.
TCHAR | m_chPrompt
Character used as a space holder for a character.
BOOL | m_bUseMask
TRUE to use an edit mask to display item data.
BOOL | m_bPassword
TRUE to use a password mask.
DWORD_PTR | m_dwData
The 32-bit value associated with the item.
BOOL | m_bHidden
TRUE if the item is hidden, FALSE if the item is shown.
int | m_nHeight
Item's height; -1 to use the default.
int | m_nLinesCount
Number of lines in a multi-line item.
DWORD | m_dwEditStyle
Edit style.
CXTPMarkupUIElement * | m_pMarkupCaption
Markup UIElement for item's caption.
CXTPMarkupUIElement * | m_pMarkupDescription
Markup UIElement for item's description.
CXTPMarkupUIElement * | m_pMarkupValue
Markup UIElement for item's value.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Static Protected Member Functions inherited from CXTPPropertyGridItem

Detailed Description

CXTPPropertyGridItemDouble is a CXTPPropertyGridItem derived class.

It is used to create a double value item in a Property Grid control.

Constructor & Destructor Documentation

◆ CXTPPropertyGridItemDouble() [1/2]

CXTPPropertyGridItemDouble | ( | LPCTSTR | strCaption,
 |  | double | fValue = 0,
 |  | LPCTSTR | strFormat = NULL,
 |  | double * | pBindNumber = NULL )

Constructs a CXTPPropertyGridItemDouble object.

Parameters
strCaption | Caption of the item.
fValue | Initial double value of the item.
strFormat | The number of digits after the decimal point. For example, "%0.5f" would display five digits after the decimal point.
pBindNumber | If not NULL, then the value of this item is bound the value of this variable.

Class CXTPPropertyGridItemDouble has no default constructor.

When using the second constructor, the Identifier (nID) of the second constructor can be linked with a STRINGTABLE resource with the same id in such form "Caption\\nDescription".

BINDING: Variables can be bound to an item in two ways, the first is to pass in a variable at the time of creation, the second allows variables to be bound to an item after creation with the BindToDouble member.

Bound variables store the values of the property grid items and can be accessed without using the property grid methods and properties. Bound variables allow the property grid to store data in variables. When the value of a PropertyGridItem is changed, the value of the bound variable will be changed to the PropertyGridItem value. The advantage of binding is that the variable can be used and manipulated without using PropertyGridItem methods and properties.

NOTE: If the value of the variable is changed without using the PropertyGrid, the PropertyGridItem value will not be updated until you call CXTPPropertyGrid::Refresh.

See also
BindToDouble

◆ CXTPPropertyGridItemDouble() [2/2]

CXTPPropertyGridItemDouble | ( | UINT | nID,
 |  | double | fValue = 0,
 |  | LPCTSTR | strFormat = NULL,
 |  | double * | pBindNumber = NULL )

Constructs a CXTPPropertyGridItemDouble object.

Parameters
nID | Identifier of the item.
fValue | Initial double value of the item.
strFormat | The number of digits after the decimal point. For example, "%0.5f" would display five digits after the decimal point.
pBindNumber | If not NULL, then the value of this item is bound the value of this variable.

Class CXTPPropertyGridItemDouble has no default constructor.

When using the second constructor, the Identifier (nID) of the second constructor can be linked with a STRINGTABLE resource with the same id in such form "Caption\\nDescription".

BINDING: Variables can be bound to an item in two ways, the first is to pass in a variable at the time of creation, the second allows variables to be bound to an item after creation with the BindToDouble member.

Bound variables store the values of the property grid items and can be accessed without using the property grid methods and properties. Bound variables allow the property grid to store data in variables. When the value of a PropertyGridItem is changed, the value of the bound variable will be changed to the PropertyGridItem value. The advantage of binding is that the variable can be used and manipulated without using PropertyGridItem methods and properties.

NOTE: If the value of the variable is changed without using the PropertyGrid, the PropertyGridItem value will not be updated until you call CXTPPropertyGrid::Refresh.

See also
BindToDouble

Member Function Documentation

◆ BindToDouble()

virtual void BindToDouble ( double * pBindDouble )
virtual

Binds the item to a specified double value.

Parameters
pBindDouble Pointer to a double value.

Variables can be bound to an item in two ways, the first is to pass in a variable at the time of creation, the second allows variables to be bound to an item after creation with the BindToDouble member.

Bound variables store the values of the property grid items and can be accessed without using the property grid methods and properties. Bound variables allow the property grid to store data in variables. When the value of a PropertyGridItem is changed, the value of the bound variable will be changed to the PropertyGridItem value. The advantage of binding is that the variable can be used and manipulated without using PropertyGridItem methods and properties.

NOTE: If the value of the variable is changed without using the PropertyGrid, the PropertyGridItem value will not be updated until you call CXTPPropertyGrid::Refresh.

◆ DoubleToString()

virtual CString DoubleToString ( double dValue )
protectedvirtual

Converts a specified double to a string.

Parameters
dValue Double to be converted.
Returns
The converted string.
See also
StringToDouble

◆ GetDouble()

AFX_INLINE double GetDouble ( ) const
virtual

Gets the double value of the item.

Returns
The double value of the item.

◆ OnBeforeInsert()

virtual void OnBeforeInsert ( )
protectedvirtual

This method is called before the item becomes visible in the property grid.

Before the item is inserted, it is first checked to see if it is bound to a variable. If it is, then the value of the item is updated with the value stored in the bound variable.

OnBeforeInsert is called when an item is inserted, when a category is inserted, when a category or item is expanded, and when the sort property has changed.

Reimplemented from CXTPPropertyGridItem.

◆ SetDouble()

virtual void SetDouble ( double fValue )
virtual

Sets the double value for the item.

Parameters
fValue Double value to be set.

◆ SetValue()

virtual void SetValue ( CString strValue )
protectedvirtual

Sets the value of the item.

Override this method to add new functionality. You should call the base class version of this function from your override.

Parameters
strValue Value to be set.

Reimplemented from CXTPPropertyGridItem.

◆ StringToDouble()

virtual double StringToDouble ( LPCTSTR lpszValue )
protectedvirtual

Converts a specified string to a double.

Parameters
lpszValue String to be converted.
Returns
The converted double.
See also
DoubleToString

◆ UseSystemDecimalSymbol()

AFX_INLINE void UseSystemDecimalSymbol ( BOOL bUseSystemDecimalSymbol )

Specifies which type of symbol should be used to divide the whole and decimal parts of numbers.

Parameters
bUseSystemDecimalSymbol TRUE to use the system defined decimal symbol, FALSE to always use a decimal point ".".

Setting bUseSystemDecimalSymbol to FALSE causes the decimal point "." to always be used to separate the whole and decimal parts of numbers.

Setting bUseSystemDecimalSymbol to TRUE causes the system defined symbol to be used to separate the whole and decimal parts of numbers. For example, if bUseSystemDecimalSymbol is set to TRUE, then a comma "," will be used in Europe to separate the whole and decimal parts of numbers.

The documentation for this class was generated from the following file:
  • XTPPropertyGridItemNumber.h


Toolkit Pro: CXTPPropertyGridItemEnum Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPPropertyGridItemEnum Class Reference

CXTPPropertyGridItemEnum is a CXTPPropertyGridItem derived class. More...

Inheritance diagram for CXTPPropertyGridItemEnum:
[legend]

Public Member Functions

CXTPPropertyGridItemEnum (LPCTSTR strCaption, int nValue=0, int *pBindEnum=NULL)
Constructs a CXTPPropertyGridItemEnum object.
CXTPPropertyGridItemEnum (UINT nID, int nValue=0, int *pBindEnum=NULL)
Constructs a CXTPPropertyGridItemEnum object.
virtual | ~CXTPPropertyGridItemEnum ()
Destroys a CXTPPropertyGridItemEnum object.
virtual void | SetEnum (int nValue)
The first method sets the value for the item.
virtual void | SetEnum (CXTPPropertyGridItemConstraint *pConstraint)
The first method sets the value for the item.
virtual int | GetEnum () const
Gets the value of the item.
virtual void | BindToEnum (int *pBindEnum)
Binds the item to a specified integer value.
- Public Member Functions inherited from CXTPPropertyGridItem
CXTPPropertyGridItem (LPCTSTR lpszCaption, LPCTSTR strValue=NULL, CString *pBindString=NULL)
Constructs a CXTPPropertyGridItem object.
CXTPPropertyGridItem (UINT nID, LPCTSTR strValue=NULL, CString *pBindString=NULL)
Constructs a CXTPPropertyGridItem object.
virtual | ~CXTPPropertyGridItem ()
Destroys a CXTPPropertyGridItem object, handles cleanup and deallocation.
void | SetCaption (LPCTSTR lpszCaption)
Sets the caption text for the item.
void | SetPrompt (LPCTSTR lpszPrompt)
Loads a string from a STRINGTABLE resource to set the caption and description for the item.
void | SetDescription (LPCTSTR lpszDescription)
Sets the description text for the item.
void | SetMarkupTemplate (LPCTSTR lpstrMarkupTemplate)
Sets the markup text for the item.
void | SetTooltip (LPCTSTR lpstrTooltip)
Sets the tooltip text for the item.
CString | GetTooltip () const
Gets the tooltip text of the item.
virtual void | SetReadOnly (BOOL bReadOnly=TRUE)
Specifies if the item state should be set to read-only or to read/write.
void | SetID (UINT nID)
Sets the identifier for the item.
void | SetFlags (UINT nFlags)
Sets a specific flag for the item.
CString | GetCaption () const
Gets the caption text of the item.
CString | GetDescription () const
Gets the description text of the item.
virtual CString | GetMarkupTemplate () const
Gets the markup text of the item.
virtual BOOL | GetReadOnly () const
Determines if the item state is set to read-only or to read/write.
virtual BOOL | IsAllowEdit () const
Determines if items in the property grid are allowed to be edited by the user.
UINT | GetID () const
Gets the identifier of the item.
int | GetIndex () const
Gets the index of the item within the property grid list.
CString | GetValue () const
Gets the value of the item.
CString | GetDefaultValue () const
Gets the default value of the item.
UINT | GetFlags () const
Gets the flags of the item.
BOOL | IsCategory () const
Determines if the item is a category.
CXTPPropertyGridItem * | AddChildItem (CXTPPropertyGridItem *pItem)
Adds a child item.
void | Move (CXTPPropertyGridItem *pParent, int nIndex=-1)
Moves the item to another category.
CXTPPropertyGridItem * | InsertChildItem (int nIndex, CXTPPropertyGridItem *pItem)
Inserts a child item.
BOOL | HasChilds () const
Determines if the item has children.
BOOL | HasVisibleChilds () const
Determines if the item has visible children.
CXTPPropertyGridItems * | GetChilds () const
Gets the item's list of child items.
BOOL | HasParent (CXTPPropertyGridItem *pParent)
Determines if the item has a specified item as a parent.
CXTPPropertyGridItemConstraints * | GetConstraints () const
Gets the item's list of constraints.
void | SetConstraintEdit (BOOL bConstraintEdit=TRUE)
Enables/disables constraint editing mode.
void | SetAutoComplete (BOOL bAutoComplete=TRUE)
Enables/disables auto-complete for the constraint list.
BOOL | GetConstraintEdit () const
Determines if constraint editing mode is enabled/disabled.
void | Expand ()
Expands the item.
void | Collapse ()
Collapses the item.
void | SetExpandable (BOOL bExpandable)
Specifies if the item should be expandable by the user.
BOOL | IsExpandable () const
Determines if the item is expandable by the user.
void | Select ()
Selects the item.
CRect | GetItemRect () const
Gets the bounding rectangle of the item.
virtual CRect | GetValueRect ()
Gets the bounding rectangle of the item value's text.
void | SetHidden (BOOL bHidden)
Hides/shows the item.
BOOL | IsHidden () const
Determines if the item is hidden/shown.
virtual void | OnValueChanged (CString strValue)
This method is called when the value of the item is changed.
virtual void | OnMarkupChanged ()
This method is called when the markup text of the item is changed.
CXTPPropertyGridView * | GetGrid () const
Gets the parent window.
BOOL | IsVisible () const
Determines the visible state of the item.
BOOL | IsExpanded () const
Determines the expanded state of the item.
CXTPPropertyGridItem * | GetParentItem () const
Gets the parent item of this item, if any.
int | GetIndent () const
Gets the indent of the item.
virtual BOOL | OnDrawItemValue (CDC &dc, CRect rcValue)
This method is called when an item is drawn.
virtual void | OnDrawItemConstraint (CDC *pDC, CXTPPropertyGridItemConstraint *pConstraint, CRect rc, BOOL bSelected)
This method is called when a constraint in an in-place list is drawn.
virtual CSize | OnMergeItemConstraint (CDC *pDC, CXTPPropertyGridItemConstraint *pConstraint)
This method is called to get size of constraint in in-place list.
virtual void | MeasureItem (LPMEASUREITEMSTRUCT lpMeasureItemStruct)
Override this method and fill in a specified MEASUREITEMSTRUCT structure to inform Windows of the list-box dimensions.
BOOL | IsSelected () const
Determines the selected stae of the item.
void | BindToString (CString *pBindString)
Binds the item to a specified CString object.
void | Remove ()
Removes this item.
void | SetMask (LPCTSTR strMask, LPCTSTR strLiteral, TCHAR chPrompt=_T('_'))
Applies a specified mask to a CXTPPropertyGridItem data field to create a restrictive field for text entry.
void | SetPasswordMask (TCHAR chMask=_T(' *'))
Sets a password mask for the item.
CString | GetMaskedText () const
Gets the actual text value of the item without mask characters.
virtual BOOL | IsValueChanged () const
Determines if the value of the item was changed by the user.
virtual void | ResetValue ()
Resets the value of the item to its default value.
void | SetDefaultValue (LPCTSTR lpszDefaultValue)
Sets the default value for the item.
void | SetMaskedText (LPCTSTR lpszMaskedText)
Sets the actual text value for the item without mask characters.
virtual CString | GetViewValue ()
Gets the value of the item that the user is currently viewing.
void | SetItemData (DWORD_PTR dwData)
Sets the 32-bit value associated with the item.
DWORD_PTR | GetItemData () const
Gets the application-supplied, 32-bit value associated with the item.
virtual CXTPPropertyGridInplaceEdit & | GetInplaceEdit ()
Gets the in-place edit control of the item.
virtual void | SetFocusToInplaceControl ()
Sets focus to the in-place control of the item.
virtual BOOL | IsInplaceButtonVisible (CXTPPropertyGridInplaceButton *pButton) const
Determines if a specified in-place button is visible.
CXTPPropertyGridInplaceButtons * | GetInplaceButtons () const
Gets the collection of in-place buttons of the item.
CXTPPropertyGridInplaceControls * | GetInplaceControls () const
Gets the collection of in-place controls of the item.
void | AddComboButton ()
Adds a standard combo button.
void | AddExpandButton ()
Adds a standard expand button.
CXTPPropertyGridInplaceSlider * AddSliderControl ()
Adds a slider control.
CXTPPropertyGridInplaceSpinButton * AddSpinButton ()
Adds a spin button control.
CXTPPropertyGridItemMetrics * | GetValueMetrics () const
Gets the metrics of the value part.
CXTPPropertyGridItemMetrics * | GetCaptionMetrics () const
Gets the metrics of the caption part.
CXTPPropertyGridItemMetrics * | GetMetrics (BOOL bValueMetrics, BOOL bCreate=TRUE) const
Gets the metrics of the value/caption part.
int | GetHeight () const
Gets the variable height of the item.
void | SetHeight (int nHeight)
Sets the variable height of the item.
BOOL | IsMultiLine () const
Determines if the item is multi-line (i.e.
int | GetMultiLinesCount () const
Gets the number of lines of the item.
void | SetMultiLinesCount (int nLinesCount)
Sets the number of lines for the item.
void | EnsureVisible ()
Ensures that this item is visible.
virtual BOOL | OnRequestEdit ()
This method is called before the user begins editing the item.
virtual BOOL | OnAfterEdit (CString &strValue)
This method is called before the user applies a new value to the item.
virtual void | OnCancelEdit ()
This method is called if the user cancels editing the item.
void | SetEditStyle (DWORD dwEditStyle)
Sets the edit style for the item.
void | SetDropDownItemCount (int nDropDownItemCount)
Sets the number of items in the dropdown list.
int | GetDropDownItemCount () const
Gets the number of items in the dropdown list.
virtual void | OnValidateEdit ()
This method is called to check the value from the in-place edit control.
CXTPMarkupUIElement * | GetMarkupCaption () const
Gets the CXTPMarkupUIElement object that renders the caption of the item.
CXTPMarkupUIElement * | GetMarkupDescription () const
Gets the CXTPMarkupUIElement object that renders the description of the item in the Help pane.
CXTPMarkupUIElement * | GetMarkupValue () const
Gets the CXTPMarkupUIElement object that renders the value of the item in the property grid.
virtual DWORD | GetEditStyle () const
Gets the edit style of the item.
void | RedrawItem ()
Redraws the item.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

virtual void | SetValue (CString strValue)
Sets the value of the item.
virtual void | OnBeforeInsert ()
This method is called before the item becomes visible in the property grid.
virtual void | OnConstraintsChanged ()
This method is called when constraints are added to the item (i.e.
- Protected Member Functions inherited from CXTPPropertyGridItem
virtual void | SetVisible (BOOL bVisible)
Sets the visible state of the item.
virtual void | OnIndexChanged ()
This method is called when the index of the item is changed.
virtual void | OnSelect ()
This method is called when an item is selected.
virtual void | OnDeselect ()
This method is called when an item is de-selected.
virtual BOOL | OnChar (UINT nChar)
This method is called when a key is pressed.
virtual void | OnLButtonDblClk (UINT nFlags, CPoint point)
This method is called when the user double-clicks the left mouse button on the item.
virtual void | OnRButtonDown (UINT nFlags, CPoint point)
This method is called when the user presses the right mouse button on the item.
virtual BOOL | OnLButtonDown (UINT nFlags, CPoint point)
This method is called when the user presses the left mouse button on the item.
virtual void | OnLButtonUp (UINT nFlags, CPoint point)
This method is called when the user releases the left mouse button on the item.
virtual BOOL | OnKeyDown (UINT nChar)
This method is called when a non-system key is pressed.
virtual void | OnAddChildItem ()
This method is called when an item is added to the parent.
virtual void | OnInplaceButtonDown (CXTPPropertyGridInplaceButton *pButton)
This method is called when the user presses the in-place button.
virtual CXTPPropertyGridInplaceList & | GetInplaceList ()
Gets the in-place list control of the item.
virtual void | SetEditText (const CString &str)
Sets the text for the in-place edit control.
virtual void | OnCaptionChanged ()
This method is called when the caption of the item is changed.
virtual BOOL | OnInpaceControlFocus (BOOL bForward)
This method is called by the property grid to set focus to an in-place child window.
virtual CString | GetInPlacedEditValue ()
Gets the text of the in-place edit control.
void | NotifyValueChanged ()
This method is called when the item's value is changed.
BOOL | SelectNextConstraint ()
Selects the next constraint in the list of constraints.
BOOL | PtInValueRect (CPoint point)
Determines if a specified point is within the value rectangle.

Protected Attributes

int | m_nValue
Value of the item.
int * | m_pBindEnum
Pointer to the variable bound to this item.
- Protected Attributes inherited from CXTPPropertyGridItem
BOOL | m_bConstraintEdit
TRUE to constraint edit.
int | m_nIndex
Index of the item.
int | m_nIndent
Indent of the item.
UINT | m_nID
Identifier of the item.
UINT | m_nFlags
Item's flags.
BOOL | m_bReadOnly
TRUE if the item state is set to read-only, FALSE if the item state is set to read/write.
BOOL | m_bVisible
Visibility of the item.
BOOL | m_bCategory
TRUE if the item is a category.
BOOL | m_bExpandable
TRUE if the item can be expanded.
BOOL | m_bExpanded
TRUE if the item is expanded.
CString | m_strValue
Value of the item.
CString | m_strDefaultValue
Default value of the item.
CString | m_strCaption
Caption of the item.
CString | m_strDescription
Description of the item.
CString | m_strTooltip
Tooltip text.
CXTPPropertyGridItem * | m_pParent
Parent item.
CXTPPropertyGridView * | m_pGrid
Parent grid class.
CXTPPropertyGridItems * | m_pChilds
Child items.
CXTPPropertyGridItemConstraints * | m_pConstraints
Item's constraints.
BOOL | m_bAutoComplete
TRUE to enable auto-complete for the item.
CXTPPropertyGridItemMetrics * | m_pValueMetrics
Value part metrics.
CXTPPropertyGridItemMetrics * | m_pCaptionMetrics
Caption part metrics.
CXTPPropertyGridInplaceButtons * | m_pInplaceButtons
In-place buttons array.
CXTPPropertyGridInplaceControls * | m_pInplaceControls
In-place controls array.
int | m_nDropDownItemCount
Maximum drop down items.
CString * | m_pBindString
Bound string.
CString | m_strFormat
Format of the double value.
CString | m_strMask
String to use as edit mask.
CString | m_strLiteral
String to use as literal.
CString | m_strMarkupTemplate
String that represents item's display when markup is on.
TCHAR | m_chPrompt
Character used as a space holder for a character.
BOOL | m_bUseMask
TRUE to use an edit mask to display item data.
BOOL | m_bPassword
TRUE to use a password mask.
DWORD_PTR | m_dwData
The 32-bit value associated with the item.
BOOL | m_bHidden
TRUE if the item is hidden, FALSE if the item is shown.
int | m_nHeight
Item's height; -1 to use the default.
int | m_nLinesCount
Number of lines in a multi-line item.
DWORD | m_dwEditStyle
Edit style.
CXTPMarkupUIElement * | m_pMarkupCaption
Markup UIElement for item's caption.
CXTPMarkupUIElement * | m_pMarkupDescription
Markup UIElement for item's description.
CXTPMarkupUIElement * | m_pMarkupValue
Markup UIElement for item's value.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Static Protected Member Functions inherited from CXTPPropertyGridItem

Detailed Description

CXTPPropertyGridItemEnum is a CXTPPropertyGridItem derived class.

It is used to create an enum value item in a Property Grid control.

An enum item is used to display a list of constraints. This is very similar to a normal constraint list. The difference is that an enum constraint list will return the value of the constraint when selected, while a normal constraint will return the text of the constraint.

Example: This code illustrates how to add an item of type enum to your grid:

//Adds a category to the grid called "Software"
CXTPPropertyGridItem* pStandard   = m_wndPropertyGrid.AddCategory(_T("Software"));

//Adds a CXTPPropertyGridItemFlags item with a caption of "Current OS" and an initial value of 2
//This will cause the constraint with a value of 2 to be selected
CXTPPropertyGridItemEnum* pItem = (CXTPPropertyGridItemEnum*)(pStandard->AddChildItem(new
CXTPPropertyGridItemEnum(_T("Current OS"), 2)));

//Adds some constraints along with a value
pItem->GetConstraints()->AddConstraint(_T("Windows 98"), 1);
pItem->GetConstraints()->AddConstraint(_T("Windows 2000"), 2);
pItem->GetConstraints()->AddConstraint(_T("Windows XP"), 3);

//GetEnum will return the Data value of the constraint selected
TRACE(_T("Enum Item Value= %d\n"), pItem->GetEnum());

//GetValue will return the String of the constraint selected
TRACE(_T("Enum Item String= %s\n"), pItem->GetValue());
See also
CXTPPropertyGridItemEnum::SetEnum, CXTPPropertyGridItemEnum::GetEnum, CXTPPropertyGridItem::GetValue

Constructor & Destructor Documentation

◆ CXTPPropertyGridItemEnum() [1/2]

CXTPPropertyGridItemEnum | ( | LPCTSTR | strCaption,
 |  | int | nValue = 0,
 |  | int * | pBindEnum = NULL )

Constructs a CXTPPropertyGridItemEnum object.

Parameters
strCaption | Caption of the item.
nValue | Initial value of the item; this should be the value of a constraint.
pBindEnum | If not NULL, then the value of this item is bound the value of this variable.

Class CXTPPropertyGridItemEnum has no default constructor.

When using the second constructor, the Identifier (nID) of the second constructor can be linked with a STRINGTABLE resource with the same ID in such form "Caption\\nDescription".

BINDING: Variables can be bound to an item in two ways, the first is to pass in a variable at the time of creation, the second allows variables to be bound to an item after creation with the BindToEnum member.

Bound variables store the values of the property grid items and can be accessed without using the property grid methods and properties. Bound variables allow the property grid to store data in variables. When the value of a PropertyGridItem is changed, the value of the bound variable will be changed to the PropertyGridItem value. The advantage of binding is that the variable can be used and manipulated without using PropertyGridItem methods and properties.

NOTE: If the value of the variable is changed without using the PropertyGrid, the PropertyGridItem value will not be updated until you call CXTPPropertyGrid::Refresh.

See also
BindToEnum

◆ CXTPPropertyGridItemEnum() [2/2]

CXTPPropertyGridItemEnum | ( | UINT | nID,
 |  | int | nValue = 0,
 |  | int * | pBindEnum = NULL )

Constructs a CXTPPropertyGridItemEnum object.

Parameters
nID | Identifier of the item.
nValue | Initial value of the item; this should be the value of a constraint.
pBindEnum | If not NULL, then the value of this item is bound the value of this variable.

Class CXTPPropertyGridItemEnum has no default constructor.

When using the second constructor, the Identifier (nID) of the second constructor can be linked with a STRINGTABLE resource with the same ID in such form "Caption\\nDescription".

BINDING: Variables can be bound to an item in two ways, the first is to pass in a variable at the time of creation, the second allows variables to be bound to an item after creation with the BindToEnum member.

Bound variables store the values of the property grid items and can be accessed without using the property grid methods and properties. Bound variables allow the property grid to store data in variables. When the value of a PropertyGridItem is changed, the value of the bound variable will be changed to the PropertyGridItem value. The advantage of binding is that the variable can be used and manipulated without using PropertyGridItem methods and properties.

NOTE: If the value of the variable is changed without using the PropertyGrid, the PropertyGridItem value will not be updated until you call CXTPPropertyGrid::Refresh.

See also
BindToEnum

Member Function Documentation

◆ BindToEnum()

virtual void BindToEnum ( int * pBindEnum )
virtual

Binds the item to a specified integer value.

Parameters
pBindEnum Pointer to an integer value.

Variables can be bound to an item in two ways, the first is to pass in a variable at the time of creation, the second allows variables to be bound to an item after creation with the BindToEnum member.

Bound variables store the values of the property grid items and can be accessed without using the property grid methods and properties. Bound variables allow the property grid to store data in variables. When the value of a PropertyGridItem is changed, the value of the bound variable will be changed to the PropertyGridItem value. The advantage of binding is that the variable can be used and manipulated without using PropertyGridItem methods and properties.

NOTE: If the value of the variable is changed without using the PropertyGrid, the PropertyGridItem value will not be updated until you call CXTPPropertyGrid::Refresh.

◆ GetEnum()

AFX_INLINE int GetEnum ( ) const
virtual

Gets the value of the item.

Returns
The value of the item (i.e. the value of the selected constraint (not the text)).
See also
CXTPPropertyGridItemEnum, SetEnum

◆ OnBeforeInsert()

virtual void OnBeforeInsert ( )
protectedvirtual

This method is called before the item becomes visible in the property grid.

Before the item is inserted, it is first checked to see if it is bound to a variable. If it is, then the value of the item is updated with the value stored in the bound variable.

OnBeforeInsert is called when an item is inserted, when a category is inserted, when a category or item is expanded, and when the sort property has changed.

Reimplemented from CXTPPropertyGridItem.

◆ OnConstraintsChanged()

virtual void OnConstraintsChanged ( )
protectedvirtual

This method is called when constraints are added to the item (i.e.

when CXTPPropertyGridItemConstraints::AddConstraint is called).

See also
CXTPPropertyGridItemConstraints::AddConstraint

Reimplemented from CXTPPropertyGridItem.

◆ SetEnum() [1/2]

virtual void SetEnum ( CXTPPropertyGridItemConstraint * pConstraint )
virtual

The first method sets the value for the item.

The second method is called when user clicks an item in the constraint list.

Parameters
pConstraint Pointer to the currently selected constraint.
See also
CXTPPropertyGridItemEnum, GetEnum

◆ SetEnum() [2/2]

virtual void SetEnum ( int nValue )
virtual

The first method sets the value for the item.

The second method is called when user clicks an item in the constraint list.

Parameters
nValue Value to be set; this should be the value of a constraint.
See also
CXTPPropertyGridItemEnum, GetEnum

◆ SetValue()

virtual void SetValue ( CString strValue )
protectedvirtual

Sets the value of the item.

Override this method to add new functionality. You should call the base class version of this function from your override.

Parameters
strValue Value to be set.

Reimplemented from CXTPPropertyGridItem.

Member Data Documentation

◆ m_nValue

int m_nValue
protected

Value of the item.

This will contain the value of the selected constraint (not the text).

The documentation for this class was generated from the following file:
  • XTPPropertyGridItemBool.h


Toolkit Pro: CXTPPropertyGridItemFlags Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPPropertyGridItemFlags Class Reference

CXTPPropertyGridItemFlags is a CXTPPropertyGridItem derived class. More...

Inheritance diagram for CXTPPropertyGridItemFlags:
[legend]

Public Member Functions

CXTPPropertyGridItemFlags (LPCTSTR strCaption, int nValue=0, int *pBindFlags=NULL)
Constructs a CXTPPropertyGridItemFlag object.
CXTPPropertyGridItemFlags (UINT nID, int nValue=0, int *pBindFlags=NULL)
Constructs a CXTPPropertyGridItemFlag object.
virtual | ~CXTPPropertyGridItemFlags ()
Destroys a CXTPPropertyGridItemFlags object.
virtual void | SetFlags (int nValue)
Sets the value of the item.
virtual int | GetFlags () const
Gets the value of the item.
virtual void | BindToFlags (int *pBindFlags)
Binds the item to a specified integer value.
- Public Member Functions inherited from CXTPPropertyGridItem
CXTPPropertyGridItem (LPCTSTR lpszCaption, LPCTSTR strValue=NULL, CString *pBindString=NULL)
Constructs a CXTPPropertyGridItem object.
CXTPPropertyGridItem (UINT nID, LPCTSTR strValue=NULL, CString *pBindString=NULL)
Constructs a CXTPPropertyGridItem object.
virtual | ~CXTPPropertyGridItem ()
Destroys a CXTPPropertyGridItem object, handles cleanup and deallocation.
void | SetCaption (LPCTSTR lpszCaption)
Sets the caption text for the item.
void | SetPrompt (LPCTSTR lpszPrompt)
Loads a string from a STRINGTABLE resource to set the caption and description for the item.
void | SetDescription (LPCTSTR lpszDescription)
Sets the description text for the item.
void | SetMarkupTemplate (LPCTSTR lpstrMarkupTemplate)
Sets the markup text for the item.
void | SetTooltip (LPCTSTR lpstrTooltip)
Sets the tooltip text for the item.
CString | GetTooltip () const
Gets the tooltip text of the item.
void | SetID (UINT nID)
Sets the identifier for the item.
void | SetFlags (UINT nFlags)
Sets a specific flag for the item.
CString | GetCaption () const
Gets the caption text of the item.
CString | GetDescription () const
Gets the description text of the item.
virtual CString | GetMarkupTemplate () const
Gets the markup text of the item.
virtual BOOL | GetReadOnly () const
Determines if the item state is set to read-only or to read/write.
virtual BOOL | IsAllowEdit () const
Determines if items in the property grid are allowed to be edited by the user.
UINT | GetID () const
Gets the identifier of the item.
int | GetIndex () const
Gets the index of the item within the property grid list.
CString | GetValue () const
Gets the value of the item.
CString | GetDefaultValue () const
Gets the default value of the item.
UINT | GetFlags () const
Gets the flags of the item.
BOOL | IsCategory () const
Determines if the item is a category.
CXTPPropertyGridItem * | AddChildItem (CXTPPropertyGridItem *pItem)
Adds a child item.
void | Move (CXTPPropertyGridItem *pParent, int nIndex=-1)
Moves the item to another category.
CXTPPropertyGridItem * | InsertChildItem (int nIndex, CXTPPropertyGridItem *pItem)
Inserts a child item.
BOOL | HasChilds () const
Determines if the item has children.
BOOL | HasVisibleChilds () const
Determines if the item has visible children.
CXTPPropertyGridItems * | GetChilds () const
Gets the item's list of child items.
BOOL | HasParent (CXTPPropertyGridItem *pParent)
Determines if the item has a specified item as a parent.
CXTPPropertyGridItemConstraints * | GetConstraints () const
Gets the item's list of constraints.
void | SetConstraintEdit (BOOL bConstraintEdit=TRUE)
Enables/disables constraint editing mode.
void | SetAutoComplete (BOOL bAutoComplete=TRUE)
Enables/disables auto-complete for the constraint list.
BOOL | GetConstraintEdit () const
Determines if constraint editing mode is enabled/disabled.
void | Expand ()
Expands the item.
void | Collapse ()
Collapses the item.
void | SetExpandable (BOOL bExpandable)
Specifies if the item should be expandable by the user.
BOOL | IsExpandable () const
Determines if the item is expandable by the user.
void | Select ()
Selects the item.
CRect | GetItemRect () const
Gets the bounding rectangle of the item.
virtual CRect | GetValueRect ()
Gets the bounding rectangle of the item value's text.
void | SetHidden (BOOL bHidden)
Hides/shows the item.
BOOL | IsHidden () const
Determines if the item is hidden/shown.
virtual void | OnValueChanged (CString strValue)
This method is called when the value of the item is changed.
virtual void | OnMarkupChanged ()
This method is called when the markup text of the item is changed.
CXTPPropertyGridView * | GetGrid () const
Gets the parent window.
BOOL | IsVisible () const
Determines the visible state of the item.
BOOL | IsExpanded () const
Determines the expanded state of the item.
CXTPPropertyGridItem * | GetParentItem () const
Gets the parent item of this item, if any.
int | GetIndent () const
Gets the indent of the item.
virtual BOOL | OnDrawItemValue (CDC &dc, CRect rcValue)
This method is called when an item is drawn.
virtual void | OnDrawItemConstraint (CDC *pDC, CXTPPropertyGridItemConstraint *pConstraint, CRect rc, BOOL bSelected)
This method is called when a constraint in an in-place list is drawn.
virtual CSize | OnMergeItemConstraint (CDC *pDC, CXTPPropertyGridItemConstraint *pConstraint)
This method is called to get size of constraint in in-place list.
virtual void | MeasureItem (LPMEASUREITEMSTRUCT lpMeasureItemStruct)
Override this method and fill in a specified MEASUREITEMSTRUCT structure to inform Windows of the list-box dimensions.
BOOL | IsSelected () const
Determines the selected stae of the item.
void | BindToString (CString *pBindString)
Binds the item to a specified CString object.
void | Remove ()
Removes this item.
void | SetMask (LPCTSTR strMask, LPCTSTR strLiteral, TCHAR chPrompt=_T('_'))
Applies a specified mask to a CXTPPropertyGridItem data field to create a restrictive field for text entry.
void | SetPasswordMask (TCHAR chMask=_T(' *'))
Sets a password mask for the item.
CString | GetMaskedText () const
Gets the actual text value of the item without mask characters.
virtual BOOL | IsValueChanged () const
Determines if the value of the item was changed by the user.
virtual void | ResetValue ()
Resets the value of the item to its default value.
void | SetDefaultValue (LPCTSTR lpszDefaultValue)
Sets the default value for the item.
void | SetMaskedText (LPCTSTR lpszMaskedText)
Sets the actual text value for the item without mask characters.
virtual CString | GetViewValue ()
Gets the value of the item that the user is currently viewing.
void | SetItemData (DWORD_PTR dwData)
Sets the 32-bit value associated with the item.
DWORD_PTR | GetItemData () const
Gets the application-supplied, 32-bit value associated with the item.
virtual CXTPPropertyGridInplaceEdit & | GetInplaceEdit ()
Gets the in-place edit control of the item.
virtual void | SetFocusToInplaceControl ()
Sets focus to the in-place control of the item.
virtual BOOL | IsInplaceButtonVisible (CXTPPropertyGridInplaceButton *pButton) const
Determines if a specified in-place button is visible.
CXTPPropertyGridInplaceButtons * | GetInplaceButtons () const
Gets the collection of in-place buttons of the item.
CXTPPropertyGridInplaceControls * | GetInplaceControls () const
Gets the collection of in-place controls of the item.
void | AddComboButton ()
Adds a standard combo button.
void | AddExpandButton ()
Adds a standard expand button.
CXTPPropertyGridInplaceSlider * AddSliderControl ()
Adds a slider control.
CXTPPropertyGridInplaceSpinButton * AddSpinButton ()
Adds a spin button control.
CXTPPropertyGridItemMetrics * | GetValueMetrics () const
Gets the metrics of the value part.
CXTPPropertyGridItemMetrics * | GetCaptionMetrics () const
Gets the metrics of the caption part.
CXTPPropertyGridItemMetrics * | GetMetrics (BOOL bValueMetrics, BOOL bCreate=TRUE) const
Gets the metrics of the value/caption part.
int | GetHeight () const
Gets the variable height of the item.
void | SetHeight (int nHeight)
Sets the variable height of the item.
BOOL | IsMultiLine () const
Determines if the item is multi-line (i.e.
int | GetMultiLinesCount () const
Gets the number of lines of the item.
void | SetMultiLinesCount (int nLinesCount)
Sets the number of lines for the item.
void | EnsureVisible ()
Ensures that this item is visible.
virtual BOOL | OnRequestEdit ()
This method is called before the user begins editing the item.
virtual BOOL | OnAfterEdit (CString &strValue)
This method is called before the user applies a new value to the item.
virtual void | OnCancelEdit ()
This method is called if the user cancels editing the item.
void | SetEditStyle (DWORD dwEditStyle)
Sets the edit style for the item.
void | SetDropDownItemCount (int nDropDownItemCount)
Sets the number of items in the dropdown list.
int | GetDropDownItemCount () const
Gets the number of items in the dropdown list.
virtual void | OnValidateEdit ()
This method is called to check the value from the in-place edit control.
CXTPMarkupUIElement * | GetMarkupCaption () const
Gets the CXTPMarkupUIElement object that renders the caption of the item.
CXTPMarkupUIElement * | GetMarkupDescription () const
Gets the CXTPMarkupUIElement object that renders the description of the item in the Help pane.
CXTPMarkupUIElement * | GetMarkupValue () const
Gets the CXTPMarkupUIElement object that renders the value of the item in the property grid.
virtual DWORD | GetEditStyle () const
Gets the edit style of the item.
void | RedrawItem ()
Redraws the item.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

virtual void | SetValue (CString strValue)
Sets the value of the item.
virtual void | OnBeforeInsert ()
This method is called before the item becomes visible in the property grid.
virtual void | OnConstraintsChanged ()
This method is called when constraints are added to the item (i.e.
virtual void | SetReadOnly (BOOL bReadOnly)
Specifies if the item state should be set to read-only or to read/write.
virtual CString | GetFlagsString ()
Gets the string notation of the selected flags.
virtual void | UpdateChilds ()
Refreshes BOOL child items.
- Protected Member Functions inherited from CXTPPropertyGridItem
virtual void | SetVisible (BOOL bVisible)
Sets the visible state of the item.
virtual void | OnIndexChanged ()
This method is called when the index of the item is changed.
virtual void | OnSelect ()
This method is called when an item is selected.
virtual void | OnDeselect ()
This method is called when an item is de-selected.
virtual BOOL | OnChar (UINT nChar)
This method is called when a key is pressed.
virtual void | OnLButtonDblClk (UINT nFlags, CPoint point)
This method is called when the user double-clicks the left mouse button on the item.
virtual void | OnRButtonDown (UINT nFlags, CPoint point)
This method is called when the user presses the right mouse button on the item.
virtual BOOL | OnLButtonDown (UINT nFlags, CPoint point)
This method is called when the user presses the left mouse button on the item.
virtual void | OnLButtonUp (UINT nFlags, CPoint point)
This method is called when the user releases the left mouse button on the item.
virtual BOOL | OnKeyDown (UINT nChar)
This method is called when a non-system key is pressed.
virtual void | OnAddChildItem ()
This method is called when an item is added to the parent.
virtual void | OnInplaceButtonDown (CXTPPropertyGridInplaceButton *pButton)
This method is called when the user presses the in-place button.
virtual CXTPPropertyGridInplaceList & | GetInplaceList ()
Gets the in-place list control of the item.
virtual void | SetEditText (const CString &str)
Sets the text for the in-place edit control.
virtual void | OnCaptionChanged ()
This method is called when the caption of the item is changed.
virtual BOOL | OnInpaceControlFocus (BOOL bForward)
This method is called by the property grid to set focus to an in-place child window.
virtual CString | GetInPlacedEditValue ()
Gets the text of the in-place edit control.
void | NotifyValueChanged ()
This method is called when the item's value is changed.
BOOL | SelectNextConstraint ()
Selects the next constraint in the list of constraints.
BOOL | PtInValueRect (CPoint point)
Determines if a specified point is within the value rectangle.

Protected Attributes

int | m_nValue
Value of the item.
- Protected Attributes inherited from CXTPPropertyGridItem
BOOL | m_bConstraintEdit
TRUE to constraint edit.
int | m_nIndex
Index of the item.
int | m_nIndent
Indent of the item.
UINT | m_nID
Identifier of the item.
UINT | m_nFlags
Item's flags.
BOOL | m_bReadOnly
TRUE if the item state is set to read-only, FALSE if the item state is set to read/write.
BOOL | m_bVisible
Visibility of the item.
BOOL | m_bCategory
TRUE if the item is a category.
BOOL | m_bExpandable
TRUE if the item can be expanded.
BOOL | m_bExpanded
TRUE if the item is expanded.
CString | m_strValue
Value of the item.
CString | m_strDefaultValue
Default value of the item.
CString | m_strCaption
Caption of the item.
CString | m_strDescription
Description of the item.
CString | m_strTooltip
Tooltip text.
CXTPPropertyGridItem * | m_pParent
Parent item.
CXTPPropertyGridView * | m_pGrid
Parent grid class.
CXTPPropertyGridItems * | m_pChilds
Child items.
CXTPPropertyGridItemConstraints * | m_pConstraints
Item's constraints.
BOOL | m_bAutoComplete
TRUE to enable auto-complete for the item.
CXTPPropertyGridItemMetrics * | m_pValueMetrics
Value part metrics.
CXTPPropertyGridItemMetrics * | m_pCaptionMetrics
Caption part metrics.
CXTPPropertyGridInplaceButtons * | m_pInplaceButtons
In-place buttons array.
CXTPPropertyGridInplaceControls * | m_pInplaceControls
In-place controls array.
int | m_nDropDownItemCount
Maximum drop down items.
CString * | m_pBindString
Bound string.
CString | m_strFormat
Format of the double value.
CString | m_strMask
String to use as edit mask.
CString | m_strLiteral
String to use as literal.
CString | m_strMarkupTemplate
String that represents item's display when markup is on.
TCHAR | m_chPrompt
Character used as a space holder for a character.
BOOL | m_bUseMask
TRUE to use an edit mask to display item data.
BOOL | m_bPassword
TRUE to use a password mask.
DWORD_PTR | m_dwData
The 32-bit value associated with the item.
BOOL | m_bHidden
TRUE if the item is hidden, FALSE if the item is shown.
int | m_nHeight
Item's height; -1 to use the default.
int | m_nLinesCount
Number of lines in a multi-line item.
DWORD | m_dwEditStyle
Edit style.
CXTPMarkupUIElement * | m_pMarkupCaption
Markup UIElement for item's caption.
CXTPMarkupUIElement * | m_pMarkupDescription
Markup UIElement for item's description.
CXTPMarkupUIElement * | m_pMarkupValue
Markup UIElement for item's value.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Static Protected Member Functions inherited from CXTPPropertyGridItem

Detailed Description

CXTPPropertyGridItemFlags is a CXTPPropertyGridItem derived class.

It is used to create a Flags value item in a Property Grid control.

A flag item is used to combine multiple boolean values into a single item. When using a flag item, you must add constraints to the flag item. Each constraint will have a value of TRUE or FALSE. The flag item will have an expand button that when clicked will display all boolean constraints for that item. The value of the flag item will be the sum of all the boolean constraints with a value of TRUE.

NOTE: Constraint values must be in powers of 2 if you will have an "All" constraint that indicates that the value of all boolean constraints is TRUE or FALSE.

In the example below, the flag item's initial value will be 9, this value is stored in CXTPPropertyGridItemFlags::m_nValue and can be set with SetFlags and retrieved with GetFlags. The string value will be "[Windows 98; Windows 95]" and this value is stored in CXTPPropertyGridItem::m_strValue, which can be retrieved with CXTPPropertyGridItem::GetValue. You must use the SetFlags method to change the flag items value by code. The string value is what is displayed to the user.

Example: This sample illustrates how to add an item of type Flags to your grid:

//Adds a category to the grid called "Software"
CXTPPropertyGridItem* pStandard   = m_wndPropertyGrid.AddCategory(_T("Software"));

//Adds a CXTPPropertyGridItemFlags item with a caption of "Supported OS" and an initial value of
9 CXTPPropertyGridItemFlags* pItem = (CXTPPropertyGridItemFlags*)(pStandard->AddChildItem(new
CXTPPropertyGridItemFlags(_T("Supported OS"), 1 + 8)));

//Adds a constraint that will set all items TRUE or FALSE, note the value of the constraint is
the sum
//of all the other constraints.  This item will also be updated when the values of the other
constraints
//have changed.
pItem->GetConstraints()->AddConstraint(_T("All Windows"), 1 + 2 + 4 + 8 + 16 + 32);

//Adds a constraint that can have a value of TRUE or FALSE
pItem->GetConstraints()->AddConstraint(_T("Windows 98"), 1);
pItem->GetConstraints()->AddConstraint(_T("Windows 2000"), 2);
pItem->GetConstraints()->AddConstraint(_T("Windows XP"), 4);
pItem->GetConstraints()->AddConstraint(_T("Windows 95"), 8);
pItem->GetConstraints()->AddConstraint(_T("Windows NT"), 16);
pItem->GetConstraints()->AddConstraint(_T("Windows 2003"), 32);

//This changes the value of the flag item to 21 and the string
//caption to [Windows 98; Windows XP; Windows NT]
pItem->SetFlags(21);

//GetFlags will return the sum of all true constraints
TRACE(_T("Flags Item Value= %d\n"), pItem->GetFlags());

//GetValue will return a string containing the text of all true constraints
TRACE(_T("Flags Item String= %s\n"), pItem->GetValue());
See also
CXTPPropertyGridItemFlags::SetFlags, CXTPPropertyGridItemFlags::GetFlags, CXTPPropertyGridItem::GetValue

Constructor & Destructor Documentation

◆ CXTPPropertyGridItemFlags() [1/2]

CXTPPropertyGridItemFlags | ( | LPCTSTR | strCaption,
 |  | int | nValue = 0,
 |  | int * | pBindFlags = NULL )

Constructs a CXTPPropertyGridItemFlag object.

Parameters
strCaption | Caption of the item.
nValue | Initial value of the item. See the description of CXTPPropertyGridItemFlags for a more detailed description of this value.
pBindFlags | If not NULL, then the value of the item is bound the value of this variable.

Class CXTPPropertyGridItemFlags has no default constructor.

When using the second constructor, the Identifier (nID) of the second constructor can be linked with a STRINGTABLE resource with the same ID in such form "Caption\\nDescription".

BINDING: Variables can be bound to an item in two ways, the first is to pass in a variable at the time of creation, the second allows variables to be bound to an item after creation with the BindToFlags member.

Bound variables store the values of the property grid items and can be accessed without using the property grid methods and properties. Bound variables allow the property grid to store data in variables. When the value of a PropertyGridItem is changed, the value of the bound variable will be changed to the PropertyGridItem value. The advantage of binding is that the variable can be used and manipulated without using PropertyGridItem methods and properties.

NOTE: If the value of the variable is changed without using the PropertyGrid, the PropertyGridItem value will not be updated until you call CXTPPropertyGrid::Refresh.

See also
BindToFlags

◆ CXTPPropertyGridItemFlags() [2/2]

CXTPPropertyGridItemFlags | ( | UINT | nID,
 |  | int | nValue = 0,
 |  | int * | pBindFlags = NULL )

Constructs a CXTPPropertyGridItemFlag object.

Parameters
nID | Identifier of the item.
nValue | Initial value of the item. See the description of CXTPPropertyGridItemFlags for a more detailed description of this value.
pBindFlags | If not NULL, then the value of the item is bound the value of this variable.

Class CXTPPropertyGridItemFlags has no default constructor.

When using the second constructor, the Identifier (nID) of the second constructor can be linked with a STRINGTABLE resource with the same ID in such form "Caption\\nDescription".

BINDING: Variables can be bound to an item in two ways, the first is to pass in a variable at the time of creation, the second allows variables to be bound to an item after creation with the BindToFlags member.

Bound variables store the values of the property grid items and can be accessed without using the property grid methods and properties. Bound variables allow the property grid to store data in variables. When the value of a PropertyGridItem is changed, the value of the bound variable will be changed to the PropertyGridItem value. The advantage of binding is that the variable can be used and manipulated without using PropertyGridItem methods and properties.

NOTE: If the value of the variable is changed without using the PropertyGrid, the PropertyGridItem value will not be updated until you call CXTPPropertyGrid::Refresh.

See also
BindToFlags

Member Function Documentation

◆ BindToFlags()

virtual void BindToFlags ( int * pBindFlags )
virtual

Binds the item to a specified integer value.

Parameters
pBindFlags Pointer to an integer value.

Variables can be bound to an item in two ways, the first is to pass in a variable at the time of creation, the second allows variables to be bound to an item after creation with the BindToFlags member.

Bound variables store the values of the property grid items and can be accessed without using the property grid methods and properties. Bound variables allow the property grid to store data in variables. When the value of a PropertyGridItem is changed, the value of the bound variable will be changed to the PropertyGridItem value. The advantage of binding is that the variable can be used and manipulated without using PropertyGridItem methods and properties.

NOTE: If the value of the variable is changed without using the PropertyGrid, the PropertyGridItem value will not be updated until you call CXTPPropertyGrid::Refresh.

◆ GetFlags()

AFX_INLINE int GetFlags ( ) const
virtual

Gets the value of the item.

Returns
The value of the flag item; this should be the sum of the constraint values that have a value of TRUE (not the text). See the description of CXTPPropertyGridItemFlags for a more detailed description of this value.

See CXTPPropertyGridItemFlags for more information. To get the text, use the CXTPPropertyGrid::GetValue method.

See also
CXTPPropertyGridItemFlags, SetFlags, CXTPPropertyGrid::GetValue.

◆ GetFlagsString()

virtual CString GetFlagsString ( )
protectedvirtual

Gets the string notation of the selected flags.

Returns
The string notation of the selected flags.

◆ OnBeforeInsert()

virtual void OnBeforeInsert ( )
protectedvirtual

This method is called before the item becomes visible in the property grid.

Before the item is inserted, it is first checked to see if it is bound to a variable. If it is, then the value of the item is updated with the value stored in the bound variable.

OnBeforeInsert is called when an item is inserted, when a category is inserted, when a category or item is expanded, and when the sort property has changed.

Reimplemented from CXTPPropertyGridItem.

◆ OnConstraintsChanged()

virtual void OnConstraintsChanged ( )
protectedvirtual

This method is called when constraints are added to the item (i.e.

when CXTPPropertyGridItemConstraints::AddConstraint is called).

See also
CXTPPropertyGridItemConstraints::AddConstraint

Reimplemented from CXTPPropertyGridItem.

◆ SetFlags()

virtual void SetFlags ( int nValue )
virtual

Sets the value of the item.

Parameters
nValue Value to be set; this should be the sum of the constraint values that have a value of TRUE (not the text). See the description of CXTPPropertyGridItemFlags for a more detailed description of this value.

See CXTPPropertyGridItemFlags for more information. To set the text, use the SetValue method.

See also
CXTPPropertyGridItemFlags, GetFlags, SetValue

◆ SetReadOnly()

virtual void SetReadOnly ( BOOL bReadOnly )
protectedvirtual

Specifies if the item state should be set to read-only or to read/write.

Parameters
bReadOnly TRUE to set the item state to read-only, FALSE to set the item state to read/write.

Reimplemented from CXTPPropertyGridItem.

◆ SetValue()

virtual void SetValue ( CString strValue )
protectedvirtual

Sets the value of the item.

Override this method to add new functionality. You should call the base class version of this function from your override.

Parameters
strValue Value to be set.

Reimplemented from CXTPPropertyGridItem.

Member Data Documentation

◆ m_nValue

int m_nValue
protected

Value of the item.

This is the sum of the constraint values that have a value of TRUE.

The documentation for this class was generated from the following file:
  • XTPPropertyGridItemFlags.h


Toolkit Pro: CXTPPropertyGridItemFont Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPPropertyGridItemFont Class Reference

CXTPPropertyGridItemFont is a CXTPPropertyGridItem derived class. More...

Inheritance diagram for CXTPPropertyGridItemFont:
[legend]

Public Member Functions

CXTPPropertyGridItemFont (LPCTSTR strCaption, LOGFONT &font)
Constructs a CXTPPropertyGridItemFont object.
CXTPPropertyGridItemFont (UINT nID, LOGFONT &font)
Constructs a CXTPPropertyGridItemFont object.
virtual | ~CXTPPropertyGridItemFont ()
Destroys a CXTPPropertyGridItemFont object.
virtual void | SetFont (LOGFONT &font)
Sets the LOGFONT value for the item.
virtual void | GetFont (LOGFONT *lf)
Gets the LOGFONT value of the item.
virtual void | SetColor (COLORREF clr)
Sets the COLORREF value for the item.
virtual COLORREF | GetColor ()
Gets the COLORREF value of the item.
- Public Member Functions inherited from CXTPPropertyGridItem
CXTPPropertyGridItem (LPCTSTR lpszCaption, LPCTSTR strValue=NULL, CString *pBindString=NULL)
Constructs a CXTPPropertyGridItem object.
CXTPPropertyGridItem (UINT nID, LPCTSTR strValue=NULL, CString *pBindString=NULL)
Constructs a CXTPPropertyGridItem object.
virtual | ~CXTPPropertyGridItem ()
Destroys a CXTPPropertyGridItem object, handles cleanup and deallocation.
void | SetCaption (LPCTSTR lpszCaption)
Sets the caption text for the item.
void | SetPrompt (LPCTSTR lpszPrompt)
Loads a string from a STRINGTABLE resource to set the caption and description for the item.
void | SetDescription (LPCTSTR lpszDescription)
Sets the description text for the item.
void | SetMarkupTemplate (LPCTSTR lpstrMarkupTemplate)
Sets the markup text for the item.
void | SetTooltip (LPCTSTR lpstrTooltip)
Sets the tooltip text for the item.
CString | GetTooltip () const
Gets the tooltip text of the item.
virtual void | SetReadOnly (BOOL bReadOnly=TRUE)
Specifies if the item state should be set to read-only or to read/write.
void | SetID (UINT nID)
Sets the identifier for the item.
void | SetFlags (UINT nFlags)
Sets a specific flag for the item.
CString | GetCaption () const
Gets the caption text of the item.
CString | GetDescription () const
Gets the description text of the item.
virtual CString | GetMarkupTemplate () const
Gets the markup text of the item.
virtual BOOL | GetReadOnly () const
Determines if the item state is set to read-only or to read/write.
virtual BOOL | IsAllowEdit () const
Determines if items in the property grid are allowed to be edited by the user.
UINT | GetID () const
Gets the identifier of the item.
int | GetIndex () const
Gets the index of the item within the property grid list.
CString | GetValue () const
Gets the value of the item.
CString | GetDefaultValue () const
Gets the default value of the item.
UINT | GetFlags () const
Gets the flags of the item.
BOOL | IsCategory () const
Determines if the item is a category.
CXTPPropertyGridItem * | AddChildItem (CXTPPropertyGridItem *pItem)
Adds a child item.
void | Move (CXTPPropertyGridItem *pParent, int nIndex=-1)
Moves the item to another category.
CXTPPropertyGridItem * | InsertChildItem (int nIndex, CXTPPropertyGridItem *pItem)
Inserts a child item.
BOOL | HasChilds () const
Determines if the item has children.
BOOL | HasVisibleChilds () const
Determines if the item has visible children.
CXTPPropertyGridItems * | GetChilds () const
Gets the item's list of child items.
BOOL | HasParent (CXTPPropertyGridItem *pParent)
Determines if the item has a specified item as a parent.
CXTPPropertyGridItemConstraints * | GetConstraints () const
Gets the item's list of constraints.
void | SetConstraintEdit (BOOL bConstraintEdit=TRUE)
Enables/disables constraint editing mode.
void | SetAutoComplete (BOOL bAutoComplete=TRUE)
Enables/disables auto-complete for the constraint list.
BOOL | GetConstraintEdit () const
Determines if constraint editing mode is enabled/disabled.
void | Expand ()
Expands the item.
void | Collapse ()
Collapses the item.
void | SetExpandable (BOOL bExpandable)
Specifies if the item should be expandable by the user.
BOOL | IsExpandable () const
Determines if the item is expandable by the user.
void | Select ()
Selects the item.
CRect | GetItemRect () const
Gets the bounding rectangle of the item.
virtual void | SetValue (CString strValue)
Sets the value of the item.
void | SetHidden (BOOL bHidden)
Hides/shows the item.
BOOL | IsHidden () const
Determines if the item is hidden/shown.
virtual void | OnValueChanged (CString strValue)
This method is called when the value of the item is changed.
virtual void | OnMarkupChanged ()
This method is called when the markup text of the item is changed.
CXTPPropertyGridView * | GetGrid () const
Gets the parent window.
BOOL | IsVisible () const
Determines the visible state of the item.
BOOL | IsExpanded () const
Determines the expanded state of the item.
CXTPPropertyGridItem * | GetParentItem () const
Gets the parent item of this item, if any.
int | GetIndent () const
Gets the indent of the item.
virtual void | OnDrawItemConstraint (CDC *pDC, CXTPPropertyGridItemConstraint *pConstraint, CRect rc, BOOL bSelected)
This method is called when a constraint in an in-place list is drawn.
virtual CSize | OnMergeItemConstraint (CDC *pDC, CXTPPropertyGridItemConstraint *pConstraint)
This method is called to get size of constraint in in-place list.
virtual void | MeasureItem (LPMEASUREITEMSTRUCT lpMeasureItemStruct)
Override this method and fill in a specified MEASUREITEMSTRUCT structure to inform Windows of the list-box dimensions.
BOOL | IsSelected () const
Determines the selected stae of the item.
void | BindToString (CString *pBindString)
Binds the item to a specified CString object.
void | Remove ()
Removes this item.
void | SetMask (LPCTSTR strMask, LPCTSTR strLiteral, TCHAR chPrompt=_T('_'))
Applies a specified mask to a CXTPPropertyGridItem data field to create a restrictive field for text entry.
void | SetPasswordMask (TCHAR chMask=_T(' *'))
Sets a password mask for the item.
CString | GetMaskedText () const
Gets the actual text value of the item without mask characters.
virtual BOOL | IsValueChanged () const
Determines if the value of the item was changed by the user.
virtual void | ResetValue ()
Resets the value of the item to its default value.
void | SetDefaultValue (LPCTSTR lpszDefaultValue)
Sets the default value for the item.
void | SetMaskedText (LPCTSTR lpszMaskedText)
Sets the actual text value for the item without mask characters.
virtual CString | GetViewValue ()
Gets the value of the item that the user is currently viewing.
void | SetItemData (DWORD_PTR dwData)
Sets the 32-bit value associated with the item.
DWORD_PTR | GetItemData () const
Gets the application-supplied, 32-bit value associated with the item.
virtual CXTPPropertyGridInplaceEdit & | GetInplaceEdit ()
Gets the in-place edit control of the item.
virtual void | SetFocusToInplaceControl ()
Sets focus to the in-place control of the item.
virtual BOOL | IsInplaceButtonVisible (CXTPPropertyGridInplaceButton *pButton) const
Determines if a specified in-place button is visible.
CXTPPropertyGridInplaceButtons * | GetInplaceButtons () const
Gets the collection of in-place buttons of the item.
CXTPPropertyGridInplaceControls * | GetInplaceControls () const
Gets the collection of in-place controls of the item.
void | AddComboButton ()
Adds a standard combo button.
void | AddExpandButton ()
Adds a standard expand button.
CXTPPropertyGridInplaceSlider * AddSliderControl ()
Adds a slider control.
CXTPPropertyGridInplaceSpinButton * AddSpinButton ()
Adds a spin button control.
CXTPPropertyGridItemMetrics * | GetValueMetrics () const
Gets the metrics of the value part.
CXTPPropertyGridItemMetrics * | GetCaptionMetrics () const
Gets the metrics of the caption part.
CXTPPropertyGridItemMetrics * | GetMetrics (BOOL bValueMetrics, BOOL bCreate=TRUE) const
Gets the metrics of the value/caption part.
int | GetHeight () const
Gets the variable height of the item.
void | SetHeight (int nHeight)
Sets the variable height of the item.
BOOL | IsMultiLine () const
Determines if the item is multi-line (i.e.
int | GetMultiLinesCount () const
Gets the number of lines of the item.
void | SetMultiLinesCount (int nLinesCount)
Sets the number of lines for the item.
void | EnsureVisible ()
Ensures that this item is visible.
virtual BOOL | OnRequestEdit ()
This method is called before the user begins editing the item.
virtual BOOL | OnAfterEdit (CString &strValue)
This method is called before the user applies a new value to the item.
virtual void | OnCancelEdit ()
This method is called if the user cancels editing the item.
void | SetEditStyle (DWORD dwEditStyle)
Sets the edit style for the item.
void | SetDropDownItemCount (int nDropDownItemCount)
Sets the number of items in the dropdown list.
int | GetDropDownItemCount () const
Gets the number of items in the dropdown list.
virtual void | OnValidateEdit ()
This method is called to check the value from the in-place edit control.
CXTPMarkupUIElement * | GetMarkupCaption () const
Gets the CXTPMarkupUIElement object that renders the caption of the item.
CXTPMarkupUIElement * | GetMarkupDescription () const
Gets the CXTPMarkupUIElement object that renders the description of the item in the Help pane.
CXTPMarkupUIElement * | GetMarkupValue () const
Gets the CXTPMarkupUIElement object that renders the value of the item in the property grid.
virtual DWORD | GetEditStyle () const
Gets the edit style of the item.
void | RedrawItem ()
Redraws the item.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

virtual void | OnInplaceButtonDown (CXTPPropertyGridInplaceButton *pButton)
This method is called when the user presses the in-place button.
virtual BOOL | OnDrawItemValue (CDC &dc, CRect rcValue)
This method is called when an item is drawn.
virtual CRect | GetValueRect ()
Gets the bounding rectangle of the item value's text.
virtual CString | FontToString (const LOGFONT &lfValue)
Converts a specified LOGFONT to a string that contains the name and pt of the font.
- Protected Member Functions inherited from CXTPPropertyGridItem
virtual void | SetVisible (BOOL bVisible)
Sets the visible state of the item.
virtual void | OnIndexChanged ()
This method is called when the index of the item is changed.
virtual void | OnSelect ()
This method is called when an item is selected.
virtual void | OnDeselect ()
This method is called when an item is de-selected.
virtual BOOL | OnChar (UINT nChar)
This method is called when a key is pressed.
virtual void | OnLButtonDblClk (UINT nFlags, CPoint point)
This method is called when the user double-clicks the left mouse button on the item.
virtual void | OnRButtonDown (UINT nFlags, CPoint point)
This method is called when the user presses the right mouse button on the item.
virtual BOOL | OnLButtonDown (UINT nFlags, CPoint point)
This method is called when the user presses the left mouse button on the item.
virtual void | OnLButtonUp (UINT nFlags, CPoint point)
This method is called when the user releases the left mouse button on the item.
virtual BOOL | OnKeyDown (UINT nChar)
This method is called when a non-system key is pressed.
virtual void | OnAddChildItem ()
This method is called when an item is added to the parent.
virtual CXTPPropertyGridInplaceList & | GetInplaceList ()
Gets the in-place list control of the item.
virtual void | SetEditText (const CString &str)
Sets the text for the in-place edit control.
virtual void | OnBeforeInsert ()
This method is called before the item becomes visible in the property grid.
virtual void | OnConstraintsChanged ()
This method is called when constraints are added to the item (i.e.
virtual void | OnCaptionChanged ()
This method is called when the caption of the item is changed.
virtual BOOL | OnInpaceControlFocus (BOOL bForward)
This method is called by the property grid to set focus to an in-place child window.
virtual CString | GetInPlacedEditValue ()
Gets the text of the in-place edit control.
void | NotifyValueChanged ()
This method is called when the item's value is changed.
BOOL | SelectNextConstraint ()
Selects the next constraint in the list of constraints.
BOOL | PtInValueRect (CPoint point)
Determines if a specified point is within the value rectangle.

Protected Attributes

LOGFONT | m_lfValue
LOGFONT value of the item.
COLORREF | m_clrValue
Font color.
- Protected Attributes inherited from CXTPPropertyGridItem
BOOL | m_bConstraintEdit
TRUE to constraint edit.
int | m_nIndex
Index of the item.
int | m_nIndent
Indent of the item.
UINT | m_nID
Identifier of the item.
UINT | m_nFlags
Item's flags.
BOOL | m_bReadOnly
TRUE if the item state is set to read-only, FALSE if the item state is set to read/write.
BOOL | m_bVisible
Visibility of the item.
BOOL | m_bCategory
TRUE if the item is a category.
BOOL | m_bExpandable
TRUE if the item can be expanded.
BOOL | m_bExpanded
TRUE if the item is expanded.
CString | m_strValue
Value of the item.
CString | m_strDefaultValue
Default value of the item.
CString | m_strCaption
Caption of the item.
CString | m_strDescription
Description of the item.
CString | m_strTooltip
Tooltip text.
CXTPPropertyGridItem * | m_pParent
Parent item.
CXTPPropertyGridView * | m_pGrid
Parent grid class.
CXTPPropertyGridItems * | m_pChilds
Child items.
CXTPPropertyGridItemConstraints * | m_pConstraints
Item's constraints.
BOOL | m_bAutoComplete
TRUE to enable auto-complete for the item.
CXTPPropertyGridItemMetrics * | m_pValueMetrics
Value part metrics.
CXTPPropertyGridItemMetrics * | m_pCaptionMetrics
Caption part metrics.
CXTPPropertyGridInplaceButtons * | m_pInplaceButtons
In-place buttons array.
CXTPPropertyGridInplaceControls * | m_pInplaceControls
In-place controls array.
int | m_nDropDownItemCount
Maximum drop down items.
CString * | m_pBindString
Bound string.
CString | m_strFormat
Format of the double value.
CString | m_strMask
String to use as edit mask.
CString | m_strLiteral
String to use as literal.
CString | m_strMarkupTemplate
String that represents item's display when markup is on.
TCHAR | m_chPrompt
Character used as a space holder for a character.
BOOL | m_bUseMask
TRUE to use an edit mask to display item data.
BOOL | m_bPassword
TRUE to use a password mask.
DWORD_PTR | m_dwData
The 32-bit value associated with the item.
BOOL | m_bHidden
TRUE if the item is hidden, FALSE if the item is shown.
int | m_nHeight
Item's height; -1 to use the default.
int | m_nLinesCount
Number of lines in a multi-line item.
DWORD | m_dwEditStyle
Edit style.
CXTPMarkupUIElement * | m_pMarkupCaption
Markup UIElement for item's caption.
CXTPMarkupUIElement * | m_pMarkupDescription
Markup UIElement for item's description.
CXTPMarkupUIElement * | m_pMarkupValue
Markup UIElement for item's value.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Static Protected Member Functions inherited from CXTPPropertyGridItem

Detailed Description

CXTPPropertyGridItemFont is a CXTPPropertyGridItem derived class.

It is used to create a Font value item in a Property Grid control.

Constructor & Destructor Documentation

◆ CXTPPropertyGridItemFont() [1/2]

CXTPPropertyGridItemFont | ( | LPCTSTR | strCaption,
 |  | LOGFONT & | font )

Constructs a CXTPPropertyGridItemFont object.

Parameters
strCaption | Caption of the item.
font | Reference to the initial LOGFONT value of the item.

◆ CXTPPropertyGridItemFont() [2/2]

CXTPPropertyGridItemFont | ( | UINT | nID,
 |  | LOGFONT & | font )

Constructs a CXTPPropertyGridItemFont object.

Parameters
nID | Identifier of the item.
font | Reference to the initial LOGFONT value of the item.

Member Function Documentation

◆ FontToString()

virtual CString FontToString ( const LOGFONT & lfValue )
protectedvirtual

Converts a specified LOGFONT to a string that contains the name and pt of the font.

Parameters
lfValue LOGFONT to be converted.
Returns
The converted string that contains the name and pt of the font.

◆ GetColor()

virtual COLORREF GetColor ( )
virtual

Gets the COLORREF value of the item.

Returns
The COLORREF value of the item.

◆ GetFont()

virtual void GetFont ( LOGFONT * lf )
virtual

Gets the LOGFONT value of the item.

Parameters
lf Pointer to the LOGFONT value to receive the LOGFONT value of the item.

◆ GetValueRect()

virtual CRect GetValueRect ( )
protectedvirtual

Gets the bounding rectangle of the item value's text.

Override this method to change it.

Returns
The bounding rectangle of the item value's text.

Reimplemented from CXTPPropertyGridItem.

◆ OnDrawItemValue()

virtual BOOL OnDrawItemValue | ( | CDC & | dc,
 |  | CRect | rcValue )
 protectedvirtual

This method is called when an item is drawn.

Override this method if needed.

Parameters
dc | Reference to the device context to be used for rendering an image of the item.
rcValue | Bounding rectangle of the item.
Returns
TRUE if the item is self-drawn.

Reimplemented from CXTPPropertyGridItem.

◆ OnInplaceButtonDown()

virtual void OnInplaceButtonDown ( CXTPPropertyGridInplaceButton * pButton )
protectedvirtual

This method is called when the user presses the in-place button.

Override this method to show an item-specific dialog.

Parameters
pButton Pointer to the button that was pressed.

The in-place button is the button that the user presses to display the font picker dialog.

Reimplemented from CXTPPropertyGridItem.

◆ SetColor()

virtual void SetColor ( COLORREF clr )
virtual

Sets the COLORREF value for the item.

Parameters
clr COLORREF value to be set.

◆ SetFont()

virtual void SetFont ( LOGFONT & font )
virtual

Sets the LOGFONT value for the item.

Parameters
font Reference to the LOGFONT value to be set.
The documentation for this class was generated from the following file:
  • XTPPropertyGridItemFont.h


Toolkit Pro: CXTPPropertyGridItemMetrics Class Reference

Public Member Functions | Public Attributes | Protected Attributes | List of all members
CXTPPropertyGridItemMetrics Class Reference

Standalone class used by CXTPPropertyGridPaintManager to store item metrics. More...

Inheritance diagram for CXTPPropertyGridItemMetrics:
[legend]

Public Member Functions

CXTPPropertyGridItemMetrics (CXTPPropertyGridPaintManager *pPaintManager)
Constructs a CXTPPropertyGridItemMetrics object.
virtual void SetDefaultValues ()
Resets all color values to their default values.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Public Attributes

CXTPFont | m_xtpFontNormal
Normal font.
CXTPFont | m_xtpFontBold
Bold font.
CXTPFont | m_xtpFontUnderline
Underline Font.
int | m_nImage
Image index.
CXTPPaintManagerColor | m_clrHelpBack
Color of the description background.
CXTPPaintManagerColor | m_clrHelpFore
Color of the description text.
CXTPPaintManagerColor | m_clrLine
Line color.
CXTPPaintManagerColor | m_clrFore
Color of the item's text.
CXTPPaintManagerColor | m_clrCategoryFore
Color of the category text.
CXTPPaintManagerColor | m_clrBack
Background color.
CXTPPaintManagerColor | m_clrReadOnlyFore
Color of read-only text.
CXTPPaintManagerColor | m_clrVerbFace
Text color of verbs.
UINT | m_uDrawTextFormat
Text formatting style for the property item.
int | m_nMaxLength
Maximum number of characters that can be entered into an editable item (Edit limit).

Protected Attributes

CXTPPropertyGridPaintManager * m_pPaintManager
Pointer to the paint manager used to draw the property grid.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

Standalone class used by CXTPPropertyGridPaintManager to store item metrics.

Constructor & Destructor Documentation

◆ CXTPPropertyGridItemMetrics()

CXTPPropertyGridItemMetrics ( CXTPPropertyGridPaintManager * pPaintManager )

Constructs a CXTPPropertyGridItemMetrics object.

Parameters
pPaintManager Pointer to the parent CXTPPropertyGridPaintManager object.
The documentation for this class was generated from the following file:
  • XTPPropertyGridPaintManager.h


Toolkit Pro: CXTPPropertyGridItemMultilineString Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPPropertyGridItemMultilineString Class Reference

CXTPPropertyGridItemMultilineString is a CXTPPropertyGridItem derived class. More...

Inheritance diagram for CXTPPropertyGridItemMultilineString:
[legend]

Public Member Functions

CXTPPropertyGridItemMultilineString (LPCTSTR lpszCaption, LPCTSTR strValue=NULL, CString *pBindString=NULL)
Constructs a CXTPPropertyGridItemMultilineString object.
CXTPPropertyGridItemMultilineString (UINT nID, LPCTSTR strValue=NULL, CString *pBindString=NULL)
Constructs a CXTPPropertyGridItemMultilineString object.
- Public Member Functions inherited from CXTPPropertyGridItem
CXTPPropertyGridItem (LPCTSTR lpszCaption, LPCTSTR strValue=NULL, CString *pBindString=NULL)
Constructs a CXTPPropertyGridItem object.
CXTPPropertyGridItem (UINT nID, LPCTSTR strValue=NULL, CString *pBindString=NULL)
Constructs a CXTPPropertyGridItem object.
virtual | ~CXTPPropertyGridItem ()
Destroys a CXTPPropertyGridItem object, handles cleanup and deallocation.
void | SetCaption (LPCTSTR lpszCaption)
Sets the caption text for the item.
void | SetPrompt (LPCTSTR lpszPrompt)
Loads a string from a STRINGTABLE resource to set the caption and description for the item.
void | SetDescription (LPCTSTR lpszDescription)
Sets the description text for the item.
void | SetMarkupTemplate (LPCTSTR lpstrMarkupTemplate)
Sets the markup text for the item.
void | SetTooltip (LPCTSTR lpstrTooltip)
Sets the tooltip text for the item.
CString | GetTooltip () const
Gets the tooltip text of the item.
virtual void | SetReadOnly (BOOL bReadOnly=TRUE)
Specifies if the item state should be set to read-only or to read/write.
void | SetID (UINT nID)
Sets the identifier for the item.
void | SetFlags (UINT nFlags)
Sets a specific flag for the item.
CString | GetCaption () const
Gets the caption text of the item.
CString | GetDescription () const
Gets the description text of the item.
virtual CString | GetMarkupTemplate () const
Gets the markup text of the item.
virtual BOOL | GetReadOnly () const
Determines if the item state is set to read-only or to read/write.
virtual BOOL | IsAllowEdit () const
Determines if items in the property grid are allowed to be edited by the user.
UINT | GetID () const
Gets the identifier of the item.
int | GetIndex () const
Gets the index of the item within the property grid list.
CString | GetValue () const
Gets the value of the item.
CString | GetDefaultValue () const
Gets the default value of the item.
UINT | GetFlags () const
Gets the flags of the item.
BOOL | IsCategory () const
Determines if the item is a category.
CXTPPropertyGridItem * | AddChildItem (CXTPPropertyGridItem *pItem)
Adds a child item.
void | Move (CXTPPropertyGridItem *pParent, int nIndex=-1)
Moves the item to another category.
CXTPPropertyGridItem * | InsertChildItem (int nIndex, CXTPPropertyGridItem *pItem)
Inserts a child item.
BOOL | HasChilds () const
Determines if the item has children.
BOOL | HasVisibleChilds () const
Determines if the item has visible children.
CXTPPropertyGridItems * | GetChilds () const
Gets the item's list of child items.
BOOL | HasParent (CXTPPropertyGridItem *pParent)
Determines if the item has a specified item as a parent.
CXTPPropertyGridItemConstraints * | GetConstraints () const
Gets the item's list of constraints.
void | SetConstraintEdit (BOOL bConstraintEdit=TRUE)
Enables/disables constraint editing mode.
void | SetAutoComplete (BOOL bAutoComplete=TRUE)
Enables/disables auto-complete for the constraint list.
BOOL | GetConstraintEdit () const
Determines if constraint editing mode is enabled/disabled.
void | Expand ()
Expands the item.
void | Collapse ()
Collapses the item.
void | SetExpandable (BOOL bExpandable)
Specifies if the item should be expandable by the user.
BOOL | IsExpandable () const
Determines if the item is expandable by the user.
void | Select ()
Selects the item.
CRect | GetItemRect () const
Gets the bounding rectangle of the item.
virtual CRect | GetValueRect ()
Gets the bounding rectangle of the item value's text.
virtual void | SetValue (CString strValue)
Sets the value of the item.
void | SetHidden (BOOL bHidden)
Hides/shows the item.
BOOL | IsHidden () const
Determines if the item is hidden/shown.
virtual void | OnValueChanged (CString strValue)
This method is called when the value of the item is changed.
virtual void | OnMarkupChanged ()
This method is called when the markup text of the item is changed.
CXTPPropertyGridView * | GetGrid () const
Gets the parent window.
BOOL | IsVisible () const
Determines the visible state of the item.
BOOL | IsExpanded () const
Determines the expanded state of the item.
CXTPPropertyGridItem * | GetParentItem () const
Gets the parent item of this item, if any.
int | GetIndent () const
Gets the indent of the item.
virtual BOOL | OnDrawItemValue (CDC &dc, CRect rcValue)
This method is called when an item is drawn.
virtual void | OnDrawItemConstraint (CDC *pDC, CXTPPropertyGridItemConstraint *pConstraint, CRect rc, BOOL bSelected)
This method is called when a constraint in an in-place list is drawn.
virtual CSize | OnMergeItemConstraint (CDC *pDC, CXTPPropertyGridItemConstraint *pConstraint)
This method is called to get size of constraint in in-place list.
virtual void | MeasureItem (LPMEASUREITEMSTRUCT lpMeasureItemStruct)
Override this method and fill in a specified MEASUREITEMSTRUCT structure to inform Windows of the list-box dimensions.
BOOL | IsSelected () const
Determines the selected stae of the item.
void | BindToString (CString *pBindString)
Binds the item to a specified CString object.
void | Remove ()
Removes this item.
void | SetMask (LPCTSTR strMask, LPCTSTR strLiteral, TCHAR chPrompt=_T('_'))
Applies a specified mask to a CXTPPropertyGridItem data field to create a restrictive field for text entry.
void | SetPasswordMask (TCHAR chMask=_T(' *'))
Sets a password mask for the item.
CString | GetMaskedText () const
Gets the actual text value of the item without mask characters.
virtual BOOL | IsValueChanged () const
Determines if the value of the item was changed by the user.
virtual void | ResetValue ()
Resets the value of the item to its default value.
void | SetDefaultValue (LPCTSTR lpszDefaultValue)
Sets the default value for the item.
void | SetMaskedText (LPCTSTR lpszMaskedText)
Sets the actual text value for the item without mask characters.
virtual CString | GetViewValue ()
Gets the value of the item that the user is currently viewing.
void | SetItemData (DWORD_PTR dwData)
Sets the 32-bit value associated with the item.
DWORD_PTR | GetItemData () const
Gets the application-supplied, 32-bit value associated with the item.
virtual CXTPPropertyGridInplaceEdit & | GetInplaceEdit ()
Gets the in-place edit control of the item.
virtual void | SetFocusToInplaceControl ()
Sets focus to the in-place control of the item.
virtual BOOL | IsInplaceButtonVisible (CXTPPropertyGridInplaceButton *pButton) const
Determines if a specified in-place button is visible.
CXTPPropertyGridInplaceButtons * | GetInplaceButtons () const
Gets the collection of in-place buttons of the item.
CXTPPropertyGridInplaceControls * | GetInplaceControls () const
Gets the collection of in-place controls of the item.
void | AddComboButton ()
Adds a standard combo button.
void | AddExpandButton ()
Adds a standard expand button.
CXTPPropertyGridInplaceSlider * AddSliderControl ()
Adds a slider control.
CXTPPropertyGridInplaceSpinButton * AddSpinButton ()
Adds a spin button control.
CXTPPropertyGridItemMetrics * | GetValueMetrics () const
Gets the metrics of the value part.
CXTPPropertyGridItemMetrics * | GetCaptionMetrics () const
Gets the metrics of the caption part.
CXTPPropertyGridItemMetrics * | GetMetrics (BOOL bValueMetrics, BOOL bCreate=TRUE) const
Gets the metrics of the value/caption part.
int | GetHeight () const
Gets the variable height of the item.
void | SetHeight (int nHeight)
Sets the variable height of the item.
BOOL | IsMultiLine () const
Determines if the item is multi-line (i.e.
int | GetMultiLinesCount () const
Gets the number of lines of the item.
void | SetMultiLinesCount (int nLinesCount)
Sets the number of lines for the item.
void | EnsureVisible ()
Ensures that this item is visible.
virtual BOOL | OnRequestEdit ()
This method is called before the user begins editing the item.
virtual BOOL | OnAfterEdit (CString &strValue)
This method is called before the user applies a new value to the item.
virtual void | OnCancelEdit ()
This method is called if the user cancels editing the item.
void | SetEditStyle (DWORD dwEditStyle)
Sets the edit style for the item.
void | SetDropDownItemCount (int nDropDownItemCount)
Sets the number of items in the dropdown list.
int | GetDropDownItemCount () const
Gets the number of items in the dropdown list.
virtual void | OnValidateEdit ()
This method is called to check the value from the in-place edit control.
CXTPMarkupUIElement * | GetMarkupCaption () const
Gets the CXTPMarkupUIElement object that renders the caption of the item.
CXTPMarkupUIElement * | GetMarkupDescription () const
Gets the CXTPMarkupUIElement object that renders the description of the item in the Help pane.
CXTPMarkupUIElement * | GetMarkupValue () const
Gets the CXTPMarkupUIElement object that renders the value of the item in the property grid.
virtual DWORD | GetEditStyle () const
Gets the edit style of the item.
void | RedrawItem ()
Redraws the item.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

virtual void | OnInplaceButtonDown (CXTPPropertyGridInplaceButton *pButton)
This method is called when the user presses the in-place button.
- Protected Member Functions inherited from CXTPPropertyGridItem
virtual void | SetVisible (BOOL bVisible)
Sets the visible state of the item.
virtual void | OnIndexChanged ()
This method is called when the index of the item is changed.
virtual void | OnSelect ()
This method is called when an item is selected.
virtual void | OnDeselect ()
This method is called when an item is de-selected.
virtual BOOL | OnChar (UINT nChar)
This method is called when a key is pressed.
virtual void | OnLButtonDblClk (UINT nFlags, CPoint point)
This method is called when the user double-clicks the left mouse button on the item.
virtual void | OnRButtonDown (UINT nFlags, CPoint point)
This method is called when the user presses the right mouse button on the item.
virtual BOOL | OnLButtonDown (UINT nFlags, CPoint point)
This method is called when the user presses the left mouse button on the item.
virtual void | OnLButtonUp (UINT nFlags, CPoint point)
This method is called when the user releases the left mouse button on the item.
virtual BOOL | OnKeyDown (UINT nChar)
This method is called when a non-system key is pressed.
virtual void | OnAddChildItem ()
This method is called when an item is added to the parent.
virtual CXTPPropertyGridInplaceList & | GetInplaceList ()
Gets the in-place list control of the item.
virtual void | SetEditText (const CString &str)
Sets the text for the in-place edit control.
virtual void | OnBeforeInsert ()
This method is called before the item becomes visible in the property grid.
virtual void | OnConstraintsChanged ()
This method is called when constraints are added to the item (i.e.
virtual void | OnCaptionChanged ()
This method is called when the caption of the item is changed.
virtual BOOL | OnInpaceControlFocus (BOOL bForward)
This method is called by the property grid to set focus to an in-place child window.
virtual CString | GetInPlacedEditValue ()
Gets the text of the in-place edit control.
void | NotifyValueChanged ()
This method is called when the item's value is changed.
BOOL | SelectNextConstraint ()
Selects the next constraint in the list of constraints.
BOOL | PtInValueRect (CPoint point)
Determines if a specified point is within the value rectangle.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Static Protected Member Functions inherited from CXTPPropertyGridItem
- Protected Attributes inherited from CXTPPropertyGridItem
BOOL | m_bConstraintEdit
TRUE to constraint edit.
int | m_nIndex
Index of the item.
int | m_nIndent
Indent of the item.
UINT | m_nID
Identifier of the item.
UINT | m_nFlags
Item's flags.
BOOL | m_bReadOnly
TRUE if the item state is set to read-only, FALSE if the item state is set to read/write.
BOOL | m_bVisible
Visibility of the item.
BOOL | m_bCategory
TRUE if the item is a category.
BOOL | m_bExpandable
TRUE if the item can be expanded.
BOOL | m_bExpanded
TRUE if the item is expanded.
CString | m_strValue
Value of the item.
CString | m_strDefaultValue
Default value of the item.
CString | m_strCaption
Caption of the item.
CString | m_strDescription
Description of the item.
CString | m_strTooltip
Tooltip text.
CXTPPropertyGridItem * | m_pParent
Parent item.
CXTPPropertyGridView * | m_pGrid
Parent grid class.
CXTPPropertyGridItems * | m_pChilds
Child items.
CXTPPropertyGridItemConstraints * | m_pConstraints
Item's constraints.
BOOL | m_bAutoComplete
TRUE to enable auto-complete for the item.
CXTPPropertyGridItemMetrics * | m_pValueMetrics
Value part metrics.
CXTPPropertyGridItemMetrics * | m_pCaptionMetrics
Caption part metrics.
CXTPPropertyGridInplaceButtons * | m_pInplaceButtons
In-place buttons array.
CXTPPropertyGridInplaceControls * | m_pInplaceControls
In-place controls array.
int | m_nDropDownItemCount
Maximum drop down items.
CString * | m_pBindString
Bound string.
CString | m_strFormat
Format of the double value.
CString | m_strMask
String to use as edit mask.
CString | m_strLiteral
String to use as literal.
CString | m_strMarkupTemplate
String that represents item's display when markup is on.
TCHAR | m_chPrompt
Character used as a space holder for a character.
BOOL | m_bUseMask
TRUE to use an edit mask to display item data.
BOOL | m_bPassword
TRUE to use a password mask.
DWORD_PTR | m_dwData
The 32-bit value associated with the item.
BOOL | m_bHidden
TRUE if the item is hidden, FALSE if the item is shown.
int | m_nHeight
Item's height; -1 to use the default.
int | m_nLinesCount
Number of lines in a multi-line item.
DWORD | m_dwEditStyle
Edit style.
CXTPMarkupUIElement * | m_pMarkupCaption
Markup UIElement for item's caption.
CXTPMarkupUIElement * | m_pMarkupDescription
Markup UIElement for item's description.
CXTPMarkupUIElement * | m_pMarkupValue
Markup UIElement for item's value.

Detailed Description

CXTPPropertyGridItemMultilineString is a CXTPPropertyGridItem derived class.

It is used to create an item with an in-place multi-line edit box.

Constructor & Destructor Documentation

◆ CXTPPropertyGridItemMultilineString() [1/2]

CXTPPropertyGridItemMultilineString | ( | LPCTSTR | lpszCaption,
 |  | LPCTSTR | strValue = NULL,
 |  | CString * | pBindString = NULL )

Constructs a CXTPPropertyGridItemMultilineString object.

Parameters
lpszCaption | Caption of the item.
strValue | Initial value of the item.
pBindString | If not NULL, then the value of the item is bound the value of this variable.

◆ CXTPPropertyGridItemMultilineString() [2/2]

CXTPPropertyGridItemMultilineString | ( | UINT | nID,
 |  | LPCTSTR | strValue = NULL,
 |  | CString * | pBindString = NULL )

Constructs a CXTPPropertyGridItemMultilineString object.

Parameters
nID | Identifier of the item.
strValue | Initial value of the item.
pBindString | If not NULL, then the value of the item is bound the value of this variable.

Member Function Documentation

◆ OnInplaceButtonDown()

virtual void OnInplaceButtonDown ( CXTPPropertyGridInplaceButton * pButton )
protectedvirtual

This method is called when the user presses the in-place button.

Override this method to show an item-specific dialog.

Parameters
pButton Pointer to the button that was pressed.

The in-place button is the button that the user presses to display the date picker dialog.

Reimplemented from CXTPPropertyGridItem.

The documentation for this class was generated from the following file:
  • XTPPropertyGridItemExt.h


Toolkit Pro: CXTPPropertyGridItemNumber Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPPropertyGridItemNumber Class Reference

CXTPPropertyGridItemNumber is a CXTPPropertyGridItem derived class. More...

Inheritance diagram for CXTPPropertyGridItemNumber:
[legend]

Public Member Functions

CXTPPropertyGridItemNumber (LPCTSTR strCaption, long nValue=0, long *pBindNumber=NULL)
Constructs a CXTPPropertyGridItemNumber object.
CXTPPropertyGridItemNumber (UINT nID, long nValue=0, long *pBindNumber=NULL)
Constructs a CXTPPropertyGridItemNumber object.
virtual | ~CXTPPropertyGridItemNumber ()
Destroys a CXTPPropertyGridItemNumber object.
virtual void | SetNumber (long nValue)
Sets the long value for the item.
virtual long | GetNumber () const
Gets the long value of the item.
virtual void | BindToNumber (long *pBindNumber)
Binds the item to a specified long value.
- Public Member Functions inherited from CXTPPropertyGridItem
CXTPPropertyGridItem (LPCTSTR lpszCaption, LPCTSTR strValue=NULL, CString *pBindString=NULL)
Constructs a CXTPPropertyGridItem object.
CXTPPropertyGridItem (UINT nID, LPCTSTR strValue=NULL, CString *pBindString=NULL)
Constructs a CXTPPropertyGridItem object.
virtual | ~CXTPPropertyGridItem ()
Destroys a CXTPPropertyGridItem object, handles cleanup and deallocation.
void | SetCaption (LPCTSTR lpszCaption)
Sets the caption text for the item.
void | SetPrompt (LPCTSTR lpszPrompt)
Loads a string from a STRINGTABLE resource to set the caption and description for the item.
void | SetDescription (LPCTSTR lpszDescription)
Sets the description text for the item.
void | SetMarkupTemplate (LPCTSTR lpstrMarkupTemplate)
Sets the markup text for the item.
void | SetTooltip (LPCTSTR lpstrTooltip)
Sets the tooltip text for the item.
CString | GetTooltip () const
Gets the tooltip text of the item.
virtual void | SetReadOnly (BOOL bReadOnly=TRUE)
Specifies if the item state should be set to read-only or to read/write.
void | SetID (UINT nID)
Sets the identifier for the item.
void | SetFlags (UINT nFlags)
Sets a specific flag for the item.
CString | GetCaption () const
Gets the caption text of the item.
CString | GetDescription () const
Gets the description text of the item.
virtual CString | GetMarkupTemplate () const
Gets the markup text of the item.
virtual BOOL | GetReadOnly () const
Determines if the item state is set to read-only or to read/write.
virtual BOOL | IsAllowEdit () const
Determines if items in the property grid are allowed to be edited by the user.
UINT | GetID () const
Gets the identifier of the item.
int | GetIndex () const
Gets the index of the item within the property grid list.
CString | GetValue () const
Gets the value of the item.
CString | GetDefaultValue () const
Gets the default value of the item.
UINT | GetFlags () const
Gets the flags of the item.
BOOL | IsCategory () const
Determines if the item is a category.
CXTPPropertyGridItem * | AddChildItem (CXTPPropertyGridItem *pItem)
Adds a child item.
void | Move (CXTPPropertyGridItem *pParent, int nIndex=-1)
Moves the item to another category.
CXTPPropertyGridItem * | InsertChildItem (int nIndex, CXTPPropertyGridItem *pItem)
Inserts a child item.
BOOL | HasChilds () const
Determines if the item has children.
BOOL | HasVisibleChilds () const
Determines if the item has visible children.
CXTPPropertyGridItems * | GetChilds () const
Gets the item's list of child items.
BOOL | HasParent (CXTPPropertyGridItem *pParent)
Determines if the item has a specified item as a parent.
CXTPPropertyGridItemConstraints * | GetConstraints () const
Gets the item's list of constraints.
void | SetConstraintEdit (BOOL bConstraintEdit=TRUE)
Enables/disables constraint editing mode.
void | SetAutoComplete (BOOL bAutoComplete=TRUE)
Enables/disables auto-complete for the constraint list.
BOOL | GetConstraintEdit () const
Determines if constraint editing mode is enabled/disabled.
void | Expand ()
Expands the item.
void | Collapse ()
Collapses the item.
void | SetExpandable (BOOL bExpandable)
Specifies if the item should be expandable by the user.
BOOL | IsExpandable () const
Determines if the item is expandable by the user.
void | Select ()
Selects the item.
CRect | GetItemRect () const
Gets the bounding rectangle of the item.
virtual CRect | GetValueRect ()
Gets the bounding rectangle of the item value's text.
void | SetHidden (BOOL bHidden)
Hides/shows the item.
BOOL | IsHidden () const
Determines if the item is hidden/shown.
virtual void | OnValueChanged (CString strValue)
This method is called when the value of the item is changed.
virtual void | OnMarkupChanged ()
This method is called when the markup text of the item is changed.
CXTPPropertyGridView * | GetGrid () const
Gets the parent window.
BOOL | IsVisible () const
Determines the visible state of the item.
BOOL | IsExpanded () const
Determines the expanded state of the item.
CXTPPropertyGridItem * | GetParentItem () const
Gets the parent item of this item, if any.
int | GetIndent () const
Gets the indent of the item.
virtual BOOL | OnDrawItemValue (CDC &dc, CRect rcValue)
This method is called when an item is drawn.
virtual void | OnDrawItemConstraint (CDC *pDC, CXTPPropertyGridItemConstraint *pConstraint, CRect rc, BOOL bSelected)
This method is called when a constraint in an in-place list is drawn.
virtual CSize | OnMergeItemConstraint (CDC *pDC, CXTPPropertyGridItemConstraint *pConstraint)
This method is called to get size of constraint in in-place list.
virtual void | MeasureItem (LPMEASUREITEMSTRUCT lpMeasureItemStruct)
Override this method and fill in a specified MEASUREITEMSTRUCT structure to inform Windows of the list-box dimensions.
BOOL | IsSelected () const
Determines the selected stae of the item.
void | BindToString (CString *pBindString)
Binds the item to a specified CString object.
void | Remove ()
Removes this item.
void | SetMask (LPCTSTR strMask, LPCTSTR strLiteral, TCHAR chPrompt=_T('_'))
Applies a specified mask to a CXTPPropertyGridItem data field to create a restrictive field for text entry.
void | SetPasswordMask (TCHAR chMask=_T(' *'))
Sets a password mask for the item.
CString | GetMaskedText () const
Gets the actual text value of the item without mask characters.
virtual BOOL | IsValueChanged () const
Determines if the value of the item was changed by the user.
virtual void | ResetValue ()
Resets the value of the item to its default value.
void | SetDefaultValue (LPCTSTR lpszDefaultValue)
Sets the default value for the item.
void | SetMaskedText (LPCTSTR lpszMaskedText)
Sets the actual text value for the item without mask characters.
virtual CString | GetViewValue ()
Gets the value of the item that the user is currently viewing.
void | SetItemData (DWORD_PTR dwData)
Sets the 32-bit value associated with the item.
DWORD_PTR | GetItemData () const
Gets the application-supplied, 32-bit value associated with the item.
virtual CXTPPropertyGridInplaceEdit & | GetInplaceEdit ()
Gets the in-place edit control of the item.
virtual void | SetFocusToInplaceControl ()
Sets focus to the in-place control of the item.
virtual BOOL | IsInplaceButtonVisible (CXTPPropertyGridInplaceButton *pButton) const
Determines if a specified in-place button is visible.
CXTPPropertyGridInplaceButtons * | GetInplaceButtons () const
Gets the collection of in-place buttons of the item.
CXTPPropertyGridInplaceControls * | GetInplaceControls () const
Gets the collection of in-place controls of the item.
void | AddComboButton ()
Adds a standard combo button.
void | AddExpandButton ()
Adds a standard expand button.
CXTPPropertyGridInplaceSlider * AddSliderControl ()
Adds a slider control.
CXTPPropertyGridInplaceSpinButton * AddSpinButton ()
Adds a spin button control.
CXTPPropertyGridItemMetrics * | GetValueMetrics () const
Gets the metrics of the value part.
CXTPPropertyGridItemMetrics * | GetCaptionMetrics () const
Gets the metrics of the caption part.
CXTPPropertyGridItemMetrics * | GetMetrics (BOOL bValueMetrics, BOOL bCreate=TRUE) const
Gets the metrics of the value/caption part.
int | GetHeight () const
Gets the variable height of the item.
void | SetHeight (int nHeight)
Sets the variable height of the item.
BOOL | IsMultiLine () const
Determines if the item is multi-line (i.e.
int | GetMultiLinesCount () const
Gets the number of lines of the item.
void | SetMultiLinesCount (int nLinesCount)
Sets the number of lines for the item.
void | EnsureVisible ()
Ensures that this item is visible.
virtual BOOL | OnRequestEdit ()
This method is called before the user begins editing the item.
virtual BOOL | OnAfterEdit (CString &strValue)
This method is called before the user applies a new value to the item.
virtual void | OnCancelEdit ()
This method is called if the user cancels editing the item.
void | SetEditStyle (DWORD dwEditStyle)
Sets the edit style for the item.
void | SetDropDownItemCount (int nDropDownItemCount)
Sets the number of items in the dropdown list.
int | GetDropDownItemCount () const
Gets the number of items in the dropdown list.
virtual void | OnValidateEdit ()
This method is called to check the value from the in-place edit control.
CXTPMarkupUIElement * | GetMarkupCaption () const
Gets the CXTPMarkupUIElement object that renders the caption of the item.
CXTPMarkupUIElement * | GetMarkupDescription () const
Gets the CXTPMarkupUIElement object that renders the description of the item in the Help pane.
CXTPMarkupUIElement * | GetMarkupValue () const
Gets the CXTPMarkupUIElement object that renders the value of the item in the property grid.
virtual DWORD | GetEditStyle () const
Gets the edit style of the item.
void | RedrawItem ()
Redraws the item.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

virtual void | SetValue (CString strValue)
Sets the value of the item.
virtual void | OnBeforeInsert ()
This method is called before the item becomes visible in the property grid.
- Protected Member Functions inherited from CXTPPropertyGridItem
virtual void | SetVisible (BOOL bVisible)
Sets the visible state of the item.
virtual void | OnIndexChanged ()
This method is called when the index of the item is changed.
virtual void | OnSelect ()
This method is called when an item is selected.
virtual void | OnDeselect ()
This method is called when an item is de-selected.
virtual BOOL | OnChar (UINT nChar)
This method is called when a key is pressed.
virtual void | OnLButtonDblClk (UINT nFlags, CPoint point)
This method is called when the user double-clicks the left mouse button on the item.
virtual void | OnRButtonDown (UINT nFlags, CPoint point)
This method is called when the user presses the right mouse button on the item.
virtual BOOL | OnLButtonDown (UINT nFlags, CPoint point)
This method is called when the user presses the left mouse button on the item.
virtual void | OnLButtonUp (UINT nFlags, CPoint point)
This method is called when the user releases the left mouse button on the item.
virtual BOOL | OnKeyDown (UINT nChar)
This method is called when a non-system key is pressed.
virtual void | OnAddChildItem ()
This method is called when an item is added to the parent.
virtual void | OnInplaceButtonDown (CXTPPropertyGridInplaceButton *pButton)
This method is called when the user presses the in-place button.
virtual CXTPPropertyGridInplaceList & | GetInplaceList ()
Gets the in-place list control of the item.
virtual void | SetEditText (const CString &str)
Sets the text for the in-place edit control.
virtual void | OnConstraintsChanged ()
This method is called when constraints are added to the item (i.e.
virtual void | OnCaptionChanged ()
This method is called when the caption of the item is changed.
virtual BOOL | OnInpaceControlFocus (BOOL bForward)
This method is called by the property grid to set focus to an in-place child window.
virtual CString | GetInPlacedEditValue ()
Gets the text of the in-place edit control.
void | NotifyValueChanged ()
This method is called when the item's value is changed.
BOOL | SelectNextConstraint ()
Selects the next constraint in the list of constraints.
BOOL | PtInValueRect (CPoint point)
Determines if a specified point is within the value rectangle.

Protected Attributes

long | m_nValue
Value of the item.
long * | m_pBindNumber
Pointer to the variable bound to this item.
- Protected Attributes inherited from CXTPPropertyGridItem
BOOL | m_bConstraintEdit
TRUE to constraint edit.
int | m_nIndex
Index of the item.
int | m_nIndent
Indent of the item.
UINT | m_nID
Identifier of the item.
UINT | m_nFlags
Item's flags.
BOOL | m_bReadOnly
TRUE if the item state is set to read-only, FALSE if the item state is set to read/write.
BOOL | m_bVisible
Visibility of the item.
BOOL | m_bCategory
TRUE if the item is a category.
BOOL | m_bExpandable
TRUE if the item can be expanded.
BOOL | m_bExpanded
TRUE if the item is expanded.
CString | m_strValue
Value of the item.
CString | m_strDefaultValue
Default value of the item.
CString | m_strCaption
Caption of the item.
CString | m_strDescription
Description of the item.
CString | m_strTooltip
Tooltip text.
CXTPPropertyGridItem * | m_pParent
Parent item.
CXTPPropertyGridView * | m_pGrid
Parent grid class.
CXTPPropertyGridItems * | m_pChilds
Child items.
CXTPPropertyGridItemConstraints * | m_pConstraints
Item's constraints.
BOOL | m_bAutoComplete
TRUE to enable auto-complete for the item.
CXTPPropertyGridItemMetrics * | m_pValueMetrics
Value part metrics.
CXTPPropertyGridItemMetrics * | m_pCaptionMetrics
Caption part metrics.
CXTPPropertyGridInplaceButtons * | m_pInplaceButtons
In-place buttons array.
CXTPPropertyGridInplaceControls * | m_pInplaceControls
In-place controls array.
int | m_nDropDownItemCount
Maximum drop down items.
CString * | m_pBindString
Bound string.
CString | m_strFormat
Format of the double value.
CString | m_strMask
String to use as edit mask.
CString | m_strLiteral
String to use as literal.
CString | m_strMarkupTemplate
String that represents item's display when markup is on.
TCHAR | m_chPrompt
Character used as a space holder for a character.
BOOL | m_bUseMask
TRUE to use an edit mask to display item data.
BOOL | m_bPassword
TRUE to use a password mask.
DWORD_PTR | m_dwData
The 32-bit value associated with the item.
BOOL | m_bHidden
TRUE if the item is hidden, FALSE if the item is shown.
int | m_nHeight
Item's height; -1 to use the default.
int | m_nLinesCount
Number of lines in a multi-line item.
DWORD | m_dwEditStyle
Edit style.
CXTPMarkupUIElement * | m_pMarkupCaption
Markup UIElement for item's caption.
CXTPMarkupUIElement * | m_pMarkupDescription
Markup UIElement for item's description.
CXTPMarkupUIElement * | m_pMarkupValue
Markup UIElement for item's value.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Static Protected Member Functions inherited from CXTPPropertyGridItem

Detailed Description

CXTPPropertyGridItemNumber is a CXTPPropertyGridItem derived class.

It is used to create an integer value item in a Property Grid control.

Constructor & Destructor Documentation

◆ CXTPPropertyGridItemNumber() [1/2]

CXTPPropertyGridItemNumber | ( | LPCTSTR | strCaption,
 |  | long | nValue = 0,
 |  | long * | pBindNumber = NULL )

Constructs a CXTPPropertyGridItemNumber object.

Parameters
strCaption | Caption of the item.
nValue | Initial long value of the item.
pBindNumber | If not NULL, then the value of the item is bound the value of this variable.

Class CXTPPropertyGridItemNumber has no default constructor.

When using the second constructor, the Identifier (nID) of the second constructor can be linked with a STRINGTABLE resource with the same ID in such form "Caption\\nDescription".

BINDING: Variables can be bound to an item in two ways, the first is to pass in a variable at the time of creation, the second allows variables to be bound to an item after creation with the BindToNumber member.

Bound variables store the values of the property grid items and can be accessed without using the property grid methods and properties. Bound variables allow the property grid to store data in variables. When the value of a PropertyGridItem is changed, the value of the bound variable will be changed to the PropertyGridItem value. The advantage of binding is that the variable can be used and manipulated without using PropertyGridItem methods and properties.

NOTE: If the value of the variable is changed without using the PropertyGrid, the PropertyGridItem value will not be updated until you call CXTPPropertyGrid::Refresh.

See also
BindToNumber

◆ CXTPPropertyGridItemNumber() [2/2]

CXTPPropertyGridItemNumber | ( | UINT | nID,
 |  | long | nValue = 0,
 |  | long * | pBindNumber = NULL )

Constructs a CXTPPropertyGridItemNumber object.

Parameters
nID | Identifier of the item.
nValue | Initial long value of the item.
pBindNumber | If not NULL, then the value of the item is bound the value of this variable.

Class CXTPPropertyGridItemNumber has no default constructor.

When using the second constructor, the Identifier (nID) of the second constructor can be linked with a STRINGTABLE resource with the same ID in such form "Caption\\nDescription".

BINDING: Variables can be bound to an item in two ways, the first is to pass in a variable at the time of creation, the second allows variables to be bound to an item after creation with the BindToNumber member.

Bound variables store the values of the property grid items and can be accessed without using the property grid methods and properties. Bound variables allow the property grid to store data in variables. When the value of a PropertyGridItem is changed, the value of the bound variable will be changed to the PropertyGridItem value. The advantage of binding is that the variable can be used and manipulated without using PropertyGridItem methods and properties.

NOTE: If the value of the variable is changed without using the PropertyGrid, the PropertyGridItem value will not be updated until you call CXTPPropertyGrid::Refresh.

See also
BindToNumber

Member Function Documentation

◆ BindToNumber()

virtual void BindToNumber ( long * pBindNumber )
virtual

Binds the item to a specified long value.

Parameters
pBindNumber Pointer to a long value.

Variables can be bound to an item in two ways, the first is to pass in a variable at the time of creation, the second allows variables to be bound to an item after creation with the BindToNumber member.

Bound variables store the values of the property grid items and can be accessed without using the property grid methods and properties. Bound variables allow the property grid to store data in variables. When the value of a PropertyGridItem is changed, the value of the bound variable will be changed to the PropertyGridItem value. The advantage of binding is that the variable can be used and manipulated without using PropertyGridItem methods and properties.

NOTE: If the value of the variable is changed without using the PropertyGrid, the PropertyGridItem value will not be updated until you call CXTPPropertyGrid::Refresh.

◆ GetNumber()

AFX_INLINE long GetNumber ( ) const
virtual

Gets the long value of the item.

Returns
The long value of the item.

◆ OnBeforeInsert()

virtual void OnBeforeInsert ( )
protectedvirtual

This method is called before the item becomes visible in the property grid.

Before the item is inserted, it is first checked to see if it is bound to a variable. If it is, then the value of the item is updated with the value stored in the bound variable.

OnBeforeInsert is called when an item is inserted, when a category is inserted, when a category or item is expanded, and when the sort property has changed.

Reimplemented from CXTPPropertyGridItem.

◆ SetNumber()

virtual void SetNumber ( long nValue )
virtual

Sets the long value for the item.

Parameters
nValue Long value to be set.

◆ SetValue()

virtual void SetValue ( CString strValue )
protectedvirtual

Sets the value of the item.

Override this method to add new functionality. You should call the base class version of this function from your override.

Parameters
strValue Value to be set.

Reimplemented from CXTPPropertyGridItem.

The documentation for this class was generated from the following file:
  • XTPPropertyGridItemNumber.h


Toolkit Pro: CXTPPropertyGridItemOption Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPPropertyGridItemOption Class Reference

CXTPPropertyGridItemOption is a CXTPPropertyGridItem derived class. More...

Inheritance diagram for CXTPPropertyGridItemOption:
[legend]

Public Member Functions

CXTPPropertyGridItemOption (LPCTSTR strCaption, int nValue=0, int *pBindOption=NULL)
Constructs a CXTPPropertyGridItemOption object.
CXTPPropertyGridItemOption (UINT nID, int nValue=0, int *pBindOption=NULL)
Constructs a CXTPPropertyGridItemOption object.
virtual | ~CXTPPropertyGridItemOption ()
Destroys a CXTPPropertyGridItemOption object.
void | SetOption (int nValue)
Sets the integer value of the item.
void | BindToOption (int *pBindOption)
Binds the item to a specified integer value.
int | GetOption () const
Gets the integer value of the item.
void | SetCheckBoxStyle (BOOL bCheckBoxStyle=TRUE)
Specifies if the item should be drawn as a checkbox or as an option/radio button.
BOOL | IsCheckBoxStyle () const
Determines if the item is drawn as a checkbox or as an option/radio button.
- Public Member Functions inherited from CXTPPropertyGridItem
CXTPPropertyGridItem (LPCTSTR lpszCaption, LPCTSTR strValue=NULL, CString *pBindString=NULL)
Constructs a CXTPPropertyGridItem object.
CXTPPropertyGridItem (UINT nID, LPCTSTR strValue=NULL, CString *pBindString=NULL)
Constructs a CXTPPropertyGridItem object.
virtual | ~CXTPPropertyGridItem ()
Destroys a CXTPPropertyGridItem object, handles cleanup and deallocation.
void | SetCaption (LPCTSTR lpszCaption)
Sets the caption text for the item.
void | SetPrompt (LPCTSTR lpszPrompt)
Loads a string from a STRINGTABLE resource to set the caption and description for the item.
void | SetDescription (LPCTSTR lpszDescription)
Sets the description text for the item.
void | SetMarkupTemplate (LPCTSTR lpstrMarkupTemplate)
Sets the markup text for the item.
void | SetTooltip (LPCTSTR lpstrTooltip)
Sets the tooltip text for the item.
CString | GetTooltip () const
Gets the tooltip text of the item.
virtual void | SetReadOnly (BOOL bReadOnly=TRUE)
Specifies if the item state should be set to read-only or to read/write.
void | SetID (UINT nID)
Sets the identifier for the item.
void | SetFlags (UINT nFlags)
Sets a specific flag for the item.
CString | GetCaption () const
Gets the caption text of the item.
CString | GetDescription () const
Gets the description text of the item.
virtual CString | GetMarkupTemplate () const
Gets the markup text of the item.
virtual BOOL | GetReadOnly () const
Determines if the item state is set to read-only or to read/write.
virtual BOOL | IsAllowEdit () const
Determines if items in the property grid are allowed to be edited by the user.
UINT | GetID () const
Gets the identifier of the item.
int | GetIndex () const
Gets the index of the item within the property grid list.
CString | GetValue () const
Gets the value of the item.
CString | GetDefaultValue () const
Gets the default value of the item.
UINT | GetFlags () const
Gets the flags of the item.
BOOL | IsCategory () const
Determines if the item is a category.
CXTPPropertyGridItem * | AddChildItem (CXTPPropertyGridItem *pItem)
Adds a child item.
void | Move (CXTPPropertyGridItem *pParent, int nIndex=-1)
Moves the item to another category.
CXTPPropertyGridItem * | InsertChildItem (int nIndex, CXTPPropertyGridItem *pItem)
Inserts a child item.
BOOL | HasChilds () const
Determines if the item has children.
BOOL | HasVisibleChilds () const
Determines if the item has visible children.
CXTPPropertyGridItems * | GetChilds () const
Gets the item's list of child items.
BOOL | HasParent (CXTPPropertyGridItem *pParent)
Determines if the item has a specified item as a parent.
CXTPPropertyGridItemConstraints * | GetConstraints () const
Gets the item's list of constraints.
void | SetConstraintEdit (BOOL bConstraintEdit=TRUE)
Enables/disables constraint editing mode.
void | SetAutoComplete (BOOL bAutoComplete=TRUE)
Enables/disables auto-complete for the constraint list.
BOOL | GetConstraintEdit () const
Determines if constraint editing mode is enabled/disabled.
void | Expand ()
Expands the item.
void | Collapse ()
Collapses the item.
void | SetExpandable (BOOL bExpandable)
Specifies if the item should be expandable by the user.
BOOL | IsExpandable () const
Determines if the item is expandable by the user.
void | Select ()
Selects the item.
CRect | GetItemRect () const
Gets the bounding rectangle of the item.
virtual CRect | GetValueRect ()
Gets the bounding rectangle of the item value's text.
void | SetHidden (BOOL bHidden)
Hides/shows the item.
BOOL | IsHidden () const
Determines if the item is hidden/shown.
virtual void | OnValueChanged (CString strValue)
This method is called when the value of the item is changed.
virtual void | OnMarkupChanged ()
This method is called when the markup text of the item is changed.
CXTPPropertyGridView * | GetGrid () const
Gets the parent window.
BOOL | IsVisible () const
Determines the visible state of the item.
BOOL | IsExpanded () const
Determines the expanded state of the item.
CXTPPropertyGridItem * | GetParentItem () const
Gets the parent item of this item, if any.
int | GetIndent () const
Gets the indent of the item.
virtual void | OnDrawItemConstraint (CDC *pDC, CXTPPropertyGridItemConstraint *pConstraint, CRect rc, BOOL bSelected)
This method is called when a constraint in an in-place list is drawn.
virtual CSize | OnMergeItemConstraint (CDC *pDC, CXTPPropertyGridItemConstraint *pConstraint)
This method is called to get size of constraint in in-place list.
BOOL | IsSelected () const
Determines the selected stae of the item.
void | BindToString (CString *pBindString)
Binds the item to a specified CString object.
void | Remove ()
Removes this item.
void | SetMask (LPCTSTR strMask, LPCTSTR strLiteral, TCHAR chPrompt=_T('_'))
Applies a specified mask to a CXTPPropertyGridItem data field to create a restrictive field for text entry.
void | SetPasswordMask (TCHAR chMask=_T(' *'))
Sets a password mask for the item.
CString | GetMaskedText () const
Gets the actual text value of the item without mask characters.
virtual BOOL | IsValueChanged () const
Determines if the value of the item was changed by the user.
virtual void | ResetValue ()
Resets the value of the item to its default value.
void | SetDefaultValue (LPCTSTR lpszDefaultValue)
Sets the default value for the item.
void | SetMaskedText (LPCTSTR lpszMaskedText)
Sets the actual text value for the item without mask characters.
virtual CString | GetViewValue ()
Gets the value of the item that the user is currently viewing.
void | SetItemData (DWORD_PTR dwData)
Sets the 32-bit value associated with the item.
DWORD_PTR | GetItemData () const
Gets the application-supplied, 32-bit value associated with the item.
virtual CXTPPropertyGridInplaceEdit & | GetInplaceEdit ()
Gets the in-place edit control of the item.
virtual void | SetFocusToInplaceControl ()
Sets focus to the in-place control of the item.
virtual BOOL | IsInplaceButtonVisible (CXTPPropertyGridInplaceButton *pButton) const
Determines if a specified in-place button is visible.
CXTPPropertyGridInplaceButtons * | GetInplaceButtons () const
Gets the collection of in-place buttons of the item.
CXTPPropertyGridInplaceControls * | GetInplaceControls () const
Gets the collection of in-place controls of the item.
void | AddComboButton ()
Adds a standard combo button.
void | AddExpandButton ()
Adds a standard expand button.
CXTPPropertyGridInplaceSlider * AddSliderControl ()
Adds a slider control.
CXTPPropertyGridInplaceSpinButton * AddSpinButton ()
Adds a spin button control.
CXTPPropertyGridItemMetrics * | GetValueMetrics () const
Gets the metrics of the value part.
CXTPPropertyGridItemMetrics * | GetCaptionMetrics () const
Gets the metrics of the caption part.
CXTPPropertyGridItemMetrics * | GetMetrics (BOOL bValueMetrics, BOOL bCreate=TRUE) const
Gets the metrics of the value/caption part.
int | GetHeight () const
Gets the variable height of the item.
void | SetHeight (int nHeight)
Sets the variable height of the item.
BOOL | IsMultiLine () const
Determines if the item is multi-line (i.e.
int | GetMultiLinesCount () const
Gets the number of lines of the item.
void | SetMultiLinesCount (int nLinesCount)
Sets the number of lines for the item.
void | EnsureVisible ()
Ensures that this item is visible.
virtual BOOL | OnRequestEdit ()
This method is called before the user begins editing the item.
virtual BOOL | OnAfterEdit (CString &strValue)
This method is called before the user applies a new value to the item.
virtual void | OnCancelEdit ()
This method is called if the user cancels editing the item.
void | SetEditStyle (DWORD dwEditStyle)
Sets the edit style for the item.
void | SetDropDownItemCount (int nDropDownItemCount)
Sets the number of items in the dropdown list.
int | GetDropDownItemCount () const
Gets the number of items in the dropdown list.
virtual void | OnValidateEdit ()
This method is called to check the value from the in-place edit control.
CXTPMarkupUIElement * | GetMarkupCaption () const
Gets the CXTPMarkupUIElement object that renders the caption of the item.
CXTPMarkupUIElement * | GetMarkupDescription () const
Gets the CXTPMarkupUIElement object that renders the description of the item in the Help pane.
CXTPMarkupUIElement * | GetMarkupValue () const
Gets the CXTPMarkupUIElement object that renders the value of the item in the property grid.
virtual DWORD | GetEditStyle () const
Gets the edit style of the item.
void | RedrawItem ()
Redraws the item.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

void | OnBeforeInsert ()
This method is called before the item becomes visible in the property grid.
void | SetValue (CString strValue)
Sets the value of the item.
void | MeasureItem (LPMEASUREITEMSTRUCT lpMeasureItemStruct)
Override this method and fill in a specified MEASUREITEMSTRUCT structure to inform Windows of the list-box dimensions.
BOOL | OnDrawItemValue (CDC &dc, CRect rcValue)
This method is called when an item is drawn.
void | OnLButtonDblClk (UINT nFlags, CPoint point)
This method is called when the user double-clicks the left mouse button on the item.
BOOL | OnLButtonDown (UINT nFlags, CPoint point)
This method is called when the user presses the left mouse button on the item.
BOOL | OnInpaceControlFocus (BOOL bForward)
This method is called by the property grid to set focus to an in-place child window.
void | OnDeselect ()
This method is called when an item is de-selected.
BOOL | OnKeyDown (UINT nChar)
This method is called when a non-system key is pressed.
void | ToggleConstraint (int nIndex)
Toggles the value of the option button.
- Protected Member Functions inherited from CXTPPropertyGridItem
virtual void | SetVisible (BOOL bVisible)
Sets the visible state of the item.
virtual void | OnIndexChanged ()
This method is called when the index of the item is changed.
virtual void | OnSelect ()
This method is called when an item is selected.
virtual BOOL | OnChar (UINT nChar)
This method is called when a key is pressed.
virtual void | OnRButtonDown (UINT nFlags, CPoint point)
This method is called when the user presses the right mouse button on the item.
virtual void | OnLButtonUp (UINT nFlags, CPoint point)
This method is called when the user releases the left mouse button on the item.
virtual void | OnAddChildItem ()
This method is called when an item is added to the parent.
virtual void | OnInplaceButtonDown (CXTPPropertyGridInplaceButton *pButton)
This method is called when the user presses the in-place button.
virtual CXTPPropertyGridInplaceList & | GetInplaceList ()
Gets the in-place list control of the item.
virtual void | SetEditText (const CString &str)
Sets the text for the in-place edit control.
virtual void | OnConstraintsChanged ()
This method is called when constraints are added to the item (i.e.
virtual void | OnCaptionChanged ()
This method is called when the caption of the item is changed.
virtual CString | GetInPlacedEditValue ()
Gets the text of the in-place edit control.
void | NotifyValueChanged ()
This method is called when the item's value is changed.
BOOL | SelectNextConstraint ()
Selects the next constraint in the list of constraints.
BOOL | PtInValueRect (CPoint point)
Determines if a specified point is within the value rectangle.

Protected Attributes

int | m_nValue
Value of the item.
int * | m_pBindOption
Pointer to the variable bound to this item.
BOOL | m_bCheckBoxStyle
TRUE if the option button will be displayed as a check box, FALSE if the option button will be displayed as an option/radio button.
- Protected Attributes inherited from CXTPPropertyGridItem
BOOL | m_bConstraintEdit
TRUE to constraint edit.
int | m_nIndex
Index of the item.
int | m_nIndent
Indent of the item.
UINT | m_nID
Identifier of the item.
UINT | m_nFlags
Item's flags.
BOOL | m_bReadOnly
TRUE if the item state is set to read-only, FALSE if the item state is set to read/write.
BOOL | m_bVisible
Visibility of the item.
BOOL | m_bCategory
TRUE if the item is a category.
BOOL | m_bExpandable
TRUE if the item can be expanded.
BOOL | m_bExpanded
TRUE if the item is expanded.
CString | m_strValue
Value of the item.
CString | m_strDefaultValue
Default value of the item.
CString | m_strCaption
Caption of the item.
CString | m_strDescription
Description of the item.
CString | m_strTooltip
Tooltip text.
CXTPPropertyGridItem * | m_pParent
Parent item.
CXTPPropertyGridView * | m_pGrid
Parent grid class.
CXTPPropertyGridItems * | m_pChilds
Child items.
CXTPPropertyGridItemConstraints * | m_pConstraints
Item's constraints.
BOOL | m_bAutoComplete
TRUE to enable auto-complete for the item.
CXTPPropertyGridItemMetrics * | m_pValueMetrics
Value part metrics.
CXTPPropertyGridItemMetrics * | m_pCaptionMetrics
Caption part metrics.
CXTPPropertyGridInplaceButtons * | m_pInplaceButtons
In-place buttons array.
CXTPPropertyGridInplaceControls * | m_pInplaceControls
In-place controls array.
int | m_nDropDownItemCount
Maximum drop down items.
CString * | m_pBindString
Bound string.
CString | m_strFormat
Format of the double value.
CString | m_strMask
String to use as edit mask.
CString | m_strLiteral
String to use as literal.
CString | m_strMarkupTemplate
String that represents item's display when markup is on.
TCHAR | m_chPrompt
Character used as a space holder for a character.
BOOL | m_bUseMask
TRUE to use an edit mask to display item data.
BOOL | m_bPassword
TRUE to use a password mask.
DWORD_PTR | m_dwData
The 32-bit value associated with the item.
BOOL | m_bHidden
TRUE if the item is hidden, FALSE if the item is shown.
int | m_nHeight
Item's height; -1 to use the default.
int | m_nLinesCount
Number of lines in a multi-line item.
DWORD | m_dwEditStyle
Edit style.
CXTPMarkupUIElement * | m_pMarkupCaption
Markup UIElement for item's caption.
CXTPMarkupUIElement * | m_pMarkupDescription
Markup UIElement for item's description.
CXTPMarkupUIElement * | m_pMarkupValue
Markup UIElement for item's value.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Static Protected Member Functions inherited from CXTPPropertyGridItem

Detailed Description

CXTPPropertyGridItemOption is a CXTPPropertyGridItem derived class.

Constructor & Destructor Documentation

◆ CXTPPropertyGridItemOption() [1/2]

CXTPPropertyGridItemOption | ( | LPCTSTR | strCaption,
 |  | int | nValue = 0,
 |  | int * | pBindOption = NULL )

Constructs a CXTPPropertyGridItemOption object.

Parameters
strCaption | Caption of the item.
nValue | Initial value of the item.
pBindOption | If not NULL, then the value of the item is bound the value of this variable.

Class CXTPPropertyGridItemOption has no default constructor.

When using the second constructor, the Identifier (nID) of the second constructor can be linked with a STRINGTABLE resource with the same id in such form "Caption\\nDescription".

BINDING: Variables can be bound to an item in two ways, the first is to pass in a variable at the time of creation, the second allows variables to be bound to an item after creation with the BindToOption member.

Bound variables store the values of the property grid items and can be accessed without using the property grid methods and properties. Bound variables allow the property grid to store data in variables. When the value of a PropertyGridItem is changed, the value of the bound variable will be changed to the PropertyGridItem value. The advantage of binding is that the variable can be used and manipulated without using PropertyGridItem methods and properties.

NOTE: If the value of the variable is changed without using the PropertyGrid, the PropertyGridItem value will not be updated until you call CXTPPropertyGrid::Refresh.

See also
BindToOption

◆ CXTPPropertyGridItemOption() [2/2]

CXTPPropertyGridItemOption | ( | UINT | nID,
 |  | int | nValue = 0,
 |  | int * | pBindOption = NULL )

Constructs a CXTPPropertyGridItemOption object.

Parameters
nID | Identifier of the item.
nValue | Initial value of the item.
pBindOption | If not NULL, then the value of the item is bound the value of this variable.

Class CXTPPropertyGridItemOption has no default constructor.

When using the second constructor, the Identifier (nID) of the second constructor can be linked with a STRINGTABLE resource with the same id in such form "Caption\\nDescription".

BINDING: Variables can be bound to an item in two ways, the first is to pass in a variable at the time of creation, the second allows variables to be bound to an item after creation with the BindToOption member.

Bound variables store the values of the property grid items and can be accessed without using the property grid methods and properties. Bound variables allow the property grid to store data in variables. When the value of a PropertyGridItem is changed, the value of the bound variable will be changed to the PropertyGridItem value. The advantage of binding is that the variable can be used and manipulated without using PropertyGridItem methods and properties.

NOTE: If the value of the variable is changed without using the PropertyGrid, the PropertyGridItem value will not be updated until you call CXTPPropertyGrid::Refresh.

See also
BindToOption

Member Function Documentation

◆ BindToOption()

void BindToOption ( int * pBindOption )

Binds the item to a specified integer value.

Parameters
pBindOption Pointer to an integer value.

Variables can be bound to an item in two ways, the first is to pass in a variable at the time of creation, the second allows variables to be bound to an item after creation with the BindToNumber member.

Bound variables store the values of the property grid items and can be accessed without using the property grid methods and properties. Bound variables allow the property grid to store data in variables. When the value of a PropertyGridItem is changed, the value of the bound variable will be changed to the PropertyGridItem value. The advantage of binding is that the variable can be used and manipulated without using PropertyGridItem methods and properties.

NOTE: If the value of the variable is changed without using the PropertyGrid, the PropertyGridItem value will not be updated until you call CXTPPropertyGrid::Refresh.

◆ GetOption()

AFX_INLINE int GetOption ( ) const

Gets the integer value of the item.

Returns
The integer value of the item.

◆ IsCheckBoxStyle()

AFX_INLINE BOOL IsCheckBoxStyle ( ) const

Determines if the item is drawn as a checkbox or as an option/radio button.

Returns
TRUE if the item is drawn as a checkbox, FALSE if the item is drawn as an option/radio button.

◆ MeasureItem()

void MeasureItem ( LPMEASUREITEMSTRUCT lpMeasureItemStruct )
protectedvirtual

Override this method and fill in a specified MEASUREITEMSTRUCT structure to inform Windows of the list-box dimensions.

Parameters
lpMeasureItemStruct Long pointer to a MEASUREITEMSTRUCT structure.

Reimplemented from CXTPPropertyGridItem.

◆ OnBeforeInsert()

void OnBeforeInsert ( )
protectedvirtual

This method is called before the item becomes visible in the property grid.

Before the item is inserted, it is first checked to see if it is bound to a variable. If it is, then the value of the item is updated with the value stored in the bound variable.

OnBeforeInsert is called when an item is inserted, when a category is inserted, when a category or item is expanded, and when the sort property has changed.

Reimplemented from CXTPPropertyGridItem.

◆ OnDrawItemValue()

BOOL OnDrawItemValue | ( | CDC & | dc,
 |  | CRect | rcValue )
 protectedvirtual

This method is called when an item is drawn.

Override this method if needed.

Parameters
dc | Reference to the device context to be used for rendering an image of the item.
rcValue | Bounding rectangle of the item.
Returns
TRUE if the item is self-drawn.

Reimplemented from CXTPPropertyGridItem.

◆ OnInpaceControlFocus()

BOOL OnInpaceControlFocus ( BOOL bForward )
protectedvirtual

This method is called by the property grid to set focus to an in-place child window.

Parameters
bForward TRUE if the user moves focus forward (with Tab), FALSE if the user moves focus backword (with Shift+Tab).
Returns
TRUE if successful, otherwise FALSE.

Reimplemented from CXTPPropertyGridItem.

◆ OnKeyDown()

BOOL OnKeyDown ( UINT nChar )
protectedvirtual

This method is called when a non-system key is pressed.

Parameters
nChar Specifies the virtual-key code of the given key.
Returns
True when non-system key is pressed, false otherwise

Reimplemented from CXTPPropertyGridItem.

◆ OnLButtonDblClk()

void OnLButtonDblClk | ( | UINT | nFlags,
 |  | CPoint | point )
 protectedvirtual

This method is called when the user double-clicks the left mouse button on the item.

Parameters
nFlags | Indicates whether various virtual keys are down (see Visual C++ documentation).
point | Specifies the x- and y- coordinates of the cursor.

Reimplemented from CXTPPropertyGridItem.

◆ OnLButtonDown()

BOOL OnLButtonDown | ( | UINT | nFlags,
 |  | CPoint | point )
 protectedvirtual

This method is called when the user presses the left mouse button on the item.

Parameters
nFlags | Indicates whether various virtual keys are down (see Visual C++ documentation).
point | Specifies the x- and y- coordinates of the cursor.
Returns
TRUE if the message was processed, otherwise FALSE.

Reimplemented from CXTPPropertyGridItem.

◆ SetCheckBoxStyle()

AFX_INLINE void SetCheckBoxStyle ( BOOL bCheckBoxStyle = TRUE )

Specifies if the item should be drawn as a checkbox or as an option/radio button.

Parameters
bCheckBoxStyle TRUE if the item should be drawn as a checkbox, FALSE if the item should be drawn as an option/radio button.

◆ SetOption()

void SetOption ( int nValue )

Sets the integer value of the item.

Parameters
nValue Integer value to be set.

◆ SetValue()

void SetValue ( CString strValue )
protectedvirtual

Sets the value of the item.

Override this method to add new functionality. You should call the base class version of this function from your override.

Parameters
strValue Value to be set.

Reimplemented from CXTPPropertyGridItem.

◆ ToggleConstraint()

void ToggleConstraint ( int nIndex )
protected

Toggles the value of the option button.

Parameters
nIndex Index of the option in the options list to be checked.

Member Data Documentation

◆ m_nValue

int m_nValue
protected

Value of the item.

This will contain the value of the selected constraint (not the text).

The documentation for this class was generated from the following file:
  • XTPPropertyGridItemOption.h


Toolkit Pro: CXTPPropertyGridItemPoint Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPPropertyGridItemPoint Class Reference

CXTPPropertyGridItemPoint is a CXTPPropertyGridItem derived class. More...

Inheritance diagram for CXTPPropertyGridItemPoint:
[legend]

Public Member Functions

CXTPPropertyGridItemPoint (LPCTSTR strCaption, CPoint pt=0, CPoint *pBindPoint=NULL)
Constructs a CXTPPropertyGridItemPoint object.
CXTPPropertyGridItemPoint (UINT nID, CPoint pt=0, CPoint *pBindPoint=NULL)
Constructs a CXTPPropertyGridItemPoint object.
virtual | ~CXTPPropertyGridItemPoint ()
Destroys a CXTPPropertyGridItemPoint object.
virtual void | SetPoint (CPoint pt)
Sets the point value for the item.
virtual CPoint | GetPoint () const
Gets the point value of the item.
virtual void | BindToPoint (CPoint *pBindPoint)
Binds the item to a specified CPoint object.
- Public Member Functions inherited from CXTPPropertyGridItem
CXTPPropertyGridItem (LPCTSTR lpszCaption, LPCTSTR strValue=NULL, CString *pBindString=NULL)
Constructs a CXTPPropertyGridItem object.
CXTPPropertyGridItem (UINT nID, LPCTSTR strValue=NULL, CString *pBindString=NULL)
Constructs a CXTPPropertyGridItem object.
virtual | ~CXTPPropertyGridItem ()
Destroys a CXTPPropertyGridItem object, handles cleanup and deallocation.
void | SetCaption (LPCTSTR lpszCaption)
Sets the caption text for the item.
void | SetPrompt (LPCTSTR lpszPrompt)
Loads a string from a STRINGTABLE resource to set the caption and description for the item.
void | SetDescription (LPCTSTR lpszDescription)
Sets the description text for the item.
void | SetMarkupTemplate (LPCTSTR lpstrMarkupTemplate)
Sets the markup text for the item.
void | SetTooltip (LPCTSTR lpstrTooltip)
Sets the tooltip text for the item.
CString | GetTooltip () const
Gets the tooltip text of the item.
virtual void | SetReadOnly (BOOL bReadOnly=TRUE)
Specifies if the item state should be set to read-only or to read/write.
void | SetID (UINT nID)
Sets the identifier for the item.
void | SetFlags (UINT nFlags)
Sets a specific flag for the item.
CString | GetCaption () const
Gets the caption text of the item.
CString | GetDescription () const
Gets the description text of the item.
virtual CString | GetMarkupTemplate () const
Gets the markup text of the item.
virtual BOOL | GetReadOnly () const
Determines if the item state is set to read-only or to read/write.
virtual BOOL | IsAllowEdit () const
Determines if items in the property grid are allowed to be edited by the user.
UINT | GetID () const
Gets the identifier of the item.
int | GetIndex () const
Gets the index of the item within the property grid list.
CString | GetValue () const
Gets the value of the item.
CString | GetDefaultValue () const
Gets the default value of the item.
UINT | GetFlags () const
Gets the flags of the item.
BOOL | IsCategory () const
Determines if the item is a category.
CXTPPropertyGridItem * | AddChildItem (CXTPPropertyGridItem *pItem)
Adds a child item.
void | Move (CXTPPropertyGridItem *pParent, int nIndex=-1)
Moves the item to another category.
CXTPPropertyGridItem * | InsertChildItem (int nIndex, CXTPPropertyGridItem *pItem)
Inserts a child item.
BOOL | HasChilds () const
Determines if the item has children.
BOOL | HasVisibleChilds () const
Determines if the item has visible children.
CXTPPropertyGridItems * | GetChilds () const
Gets the item's list of child items.
BOOL | HasParent (CXTPPropertyGridItem *pParent)
Determines if the item has a specified item as a parent.
CXTPPropertyGridItemConstraints * | GetConstraints () const
Gets the item's list of constraints.
void | SetConstraintEdit (BOOL bConstraintEdit=TRUE)
Enables/disables constraint editing mode.
void | SetAutoComplete (BOOL bAutoComplete=TRUE)
Enables/disables auto-complete for the constraint list.
BOOL | GetConstraintEdit () const
Determines if constraint editing mode is enabled/disabled.
void | Expand ()
Expands the item.
void | Collapse ()
Collapses the item.
void | SetExpandable (BOOL bExpandable)
Specifies if the item should be expandable by the user.
BOOL | IsExpandable () const
Determines if the item is expandable by the user.
void | Select ()
Selects the item.
CRect | GetItemRect () const
Gets the bounding rectangle of the item.
virtual CRect | GetValueRect ()
Gets the bounding rectangle of the item value's text.
void | SetHidden (BOOL bHidden)
Hides/shows the item.
BOOL | IsHidden () const
Determines if the item is hidden/shown.
virtual void | OnValueChanged (CString strValue)
This method is called when the value of the item is changed.
virtual void | OnMarkupChanged ()
This method is called when the markup text of the item is changed.
CXTPPropertyGridView * | GetGrid () const
Gets the parent window.
BOOL | IsVisible () const
Determines the visible state of the item.
BOOL | IsExpanded () const
Determines the expanded state of the item.
CXTPPropertyGridItem * | GetParentItem () const
Gets the parent item of this item, if any.
int | GetIndent () const
Gets the indent of the item.
virtual BOOL | OnDrawItemValue (CDC &dc, CRect rcValue)
This method is called when an item is drawn.
virtual void | OnDrawItemConstraint (CDC *pDC, CXTPPropertyGridItemConstraint *pConstraint, CRect rc, BOOL bSelected)
This method is called when a constraint in an in-place list is drawn.
virtual CSize | OnMergeItemConstraint (CDC *pDC, CXTPPropertyGridItemConstraint *pConstraint)
This method is called to get size of constraint in in-place list.
virtual void | MeasureItem (LPMEASUREITEMSTRUCT lpMeasureItemStruct)
Override this method and fill in a specified MEASUREITEMSTRUCT structure to inform Windows of the list-box dimensions.
BOOL | IsSelected () const
Determines the selected stae of the item.
void | BindToString (CString *pBindString)
Binds the item to a specified CString object.
void | Remove ()
Removes this item.
void | SetMask (LPCTSTR strMask, LPCTSTR strLiteral, TCHAR chPrompt=_T('_'))
Applies a specified mask to a CXTPPropertyGridItem data field to create a restrictive field for text entry.
void | SetPasswordMask (TCHAR chMask=_T(' *'))
Sets a password mask for the item.
CString | GetMaskedText () const
Gets the actual text value of the item without mask characters.
virtual BOOL | IsValueChanged () const
Determines if the value of the item was changed by the user.
virtual void | ResetValue ()
Resets the value of the item to its default value.
void | SetDefaultValue (LPCTSTR lpszDefaultValue)
Sets the default value for the item.
void | SetMaskedText (LPCTSTR lpszMaskedText)
Sets the actual text value for the item without mask characters.
virtual CString | GetViewValue ()
Gets the value of the item that the user is currently viewing.
void | SetItemData (DWORD_PTR dwData)
Sets the 32-bit value associated with the item.
DWORD_PTR | GetItemData () const
Gets the application-supplied, 32-bit value associated with the item.
virtual CXTPPropertyGridInplaceEdit & | GetInplaceEdit ()
Gets the in-place edit control of the item.
virtual void | SetFocusToInplaceControl ()
Sets focus to the in-place control of the item.
virtual BOOL | IsInplaceButtonVisible (CXTPPropertyGridInplaceButton *pButton) const
Determines if a specified in-place button is visible.
CXTPPropertyGridInplaceButtons * | GetInplaceButtons () const
Gets the collection of in-place buttons of the item.
CXTPPropertyGridInplaceControls * | GetInplaceControls () const
Gets the collection of in-place controls of the item.
void | AddComboButton ()
Adds a standard combo button.
void | AddExpandButton ()
Adds a standard expand button.
CXTPPropertyGridInplaceSlider * AddSliderControl ()
Adds a slider control.
CXTPPropertyGridInplaceSpinButton * AddSpinButton ()
Adds a spin button control.
CXTPPropertyGridItemMetrics * | GetValueMetrics () const
Gets the metrics of the value part.
CXTPPropertyGridItemMetrics * | GetCaptionMetrics () const
Gets the metrics of the caption part.
CXTPPropertyGridItemMetrics * | GetMetrics (BOOL bValueMetrics, BOOL bCreate=TRUE) const
Gets the metrics of the value/caption part.
int | GetHeight () const
Gets the variable height of the item.
void | SetHeight (int nHeight)
Sets the variable height of the item.
BOOL | IsMultiLine () const
Determines if the item is multi-line (i.e.
int | GetMultiLinesCount () const
Gets the number of lines of the item.
void | SetMultiLinesCount (int nLinesCount)
Sets the number of lines for the item.
void | EnsureVisible ()
Ensures that this item is visible.
virtual BOOL | OnRequestEdit ()
This method is called before the user begins editing the item.
virtual BOOL | OnAfterEdit (CString &strValue)
This method is called before the user applies a new value to the item.
virtual void | OnCancelEdit ()
This method is called if the user cancels editing the item.
void | SetEditStyle (DWORD dwEditStyle)
Sets the edit style for the item.
void | SetDropDownItemCount (int nDropDownItemCount)
Sets the number of items in the dropdown list.
int | GetDropDownItemCount () const
Gets the number of items in the dropdown list.
virtual void | OnValidateEdit ()
This method is called to check the value from the in-place edit control.
CXTPMarkupUIElement * | GetMarkupCaption () const
Gets the CXTPMarkupUIElement object that renders the caption of the item.
CXTPMarkupUIElement * | GetMarkupDescription () const
Gets the CXTPMarkupUIElement object that renders the description of the item in the Help pane.
CXTPMarkupUIElement * | GetMarkupValue () const
Gets the CXTPMarkupUIElement object that renders the value of the item in the property grid.
virtual DWORD | GetEditStyle () const
Gets the edit style of the item.
void | RedrawItem ()
Redraws the item.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

virtual void | OnBeforeInsert ()
This method is called before the item becomes visible in the property grid.
- Protected Member Functions inherited from CXTPPropertyGridItem
virtual void | SetVisible (BOOL bVisible)
Sets the visible state of the item.
virtual void | OnIndexChanged ()
This method is called when the index of the item is changed.
virtual void | OnSelect ()
This method is called when an item is selected.
virtual void | OnDeselect ()
This method is called when an item is de-selected.
virtual BOOL | OnChar (UINT nChar)
This method is called when a key is pressed.
virtual void | OnLButtonDblClk (UINT nFlags, CPoint point)
This method is called when the user double-clicks the left mouse button on the item.
virtual void | OnRButtonDown (UINT nFlags, CPoint point)
This method is called when the user presses the right mouse button on the item.
virtual BOOL | OnLButtonDown (UINT nFlags, CPoint point)
This method is called when the user presses the left mouse button on the item.
virtual void | OnLButtonUp (UINT nFlags, CPoint point)
This method is called when the user releases the left mouse button on the item.
virtual BOOL | OnKeyDown (UINT nChar)
This method is called when a non-system key is pressed.
virtual void | OnInplaceButtonDown (CXTPPropertyGridInplaceButton *pButton)
This method is called when the user presses the in-place button.
virtual CXTPPropertyGridInplaceList & | GetInplaceList ()
Gets the in-place list control of the item.
virtual void | SetEditText (const CString &str)
Sets the text for the in-place edit control.
virtual void | OnConstraintsChanged ()
This method is called when constraints are added to the item (i.e.
virtual void | OnCaptionChanged ()
This method is called when the caption of the item is changed.
virtual BOOL | OnInpaceControlFocus (BOOL bForward)
This method is called by the property grid to set focus to an in-place child window.
virtual CString | GetInPlacedEditValue ()
Gets the text of the in-place edit control.
void | NotifyValueChanged ()
This method is called when the item's value is changed.
BOOL | SelectNextConstraint ()
Selects the next constraint in the list of constraints.
BOOL | PtInValueRect (CPoint point)
Determines if a specified point is within the value rectangle.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Static Protected Member Functions inherited from CXTPPropertyGridItem
- Protected Attributes inherited from CXTPPropertyGridItem
BOOL | m_bConstraintEdit
TRUE to constraint edit.
int | m_nIndex
Index of the item.
int | m_nIndent
Indent of the item.
UINT | m_nID
Identifier of the item.
UINT | m_nFlags
Item's flags.
BOOL | m_bReadOnly
TRUE if the item state is set to read-only, FALSE if the item state is set to read/write.
BOOL | m_bVisible
Visibility of the item.
BOOL | m_bCategory
TRUE if the item is a category.
BOOL | m_bExpandable
TRUE if the item can be expanded.
BOOL | m_bExpanded
TRUE if the item is expanded.
CString | m_strValue
Value of the item.
CString | m_strDefaultValue
Default value of the item.
CString | m_strCaption
Caption of the item.
CString | m_strDescription
Description of the item.
CString | m_strTooltip
Tooltip text.
CXTPPropertyGridItem * | m_pParent
Parent item.
CXTPPropertyGridView * | m_pGrid
Parent grid class.
CXTPPropertyGridItems * | m_pChilds
Child items.
CXTPPropertyGridItemConstraints * | m_pConstraints
Item's constraints.
BOOL | m_bAutoComplete
TRUE to enable auto-complete for the item.
CXTPPropertyGridItemMetrics * | m_pValueMetrics
Value part metrics.
CXTPPropertyGridItemMetrics * | m_pCaptionMetrics
Caption part metrics.
CXTPPropertyGridInplaceButtons * | m_pInplaceButtons
In-place buttons array.
CXTPPropertyGridInplaceControls * | m_pInplaceControls
In-place controls array.
int | m_nDropDownItemCount
Maximum drop down items.
CString * | m_pBindString
Bound string.
CString | m_strFormat
Format of the double value.
CString | m_strMask
String to use as edit mask.
CString | m_strLiteral
String to use as literal.
CString | m_strMarkupTemplate
String that represents item's display when markup is on.
TCHAR | m_chPrompt
Character used as a space holder for a character.
BOOL | m_bUseMask
TRUE to use an edit mask to display item data.
BOOL | m_bPassword
TRUE to use a password mask.
DWORD_PTR | m_dwData
The 32-bit value associated with the item.
BOOL | m_bHidden
TRUE if the item is hidden, FALSE if the item is shown.
int | m_nHeight
Item's height; -1 to use the default.
int | m_nLinesCount
Number of lines in a multi-line item.
DWORD | m_dwEditStyle
Edit style.
CXTPMarkupUIElement * | m_pMarkupCaption
Markup UIElement for item's caption.
CXTPMarkupUIElement * | m_pMarkupDescription
Markup UIElement for item's description.
CXTPMarkupUIElement * | m_pMarkupValue
Markup UIElement for item's value.

Detailed Description

CXTPPropertyGridItemPoint is a CXTPPropertyGridItem derived class.

It is used to create a point value item in a Property Grid control.

Constructor & Destructor Documentation

◆ CXTPPropertyGridItemPoint() [1/2]

CXTPPropertyGridItemPoint | ( | LPCTSTR | strCaption,
 |  | CPoint | pt = 0,
 |  | CPoint * | pBindPoint = NULL )

Constructs a CXTPPropertyGridItemPoint object.

Parameters
strCaption | Caption of the item.
pt | Initial point value of item.
pBindPoint | If not NULL, then the value of this item is bound the value of this variable.

Class CXTPPropertyGridItemPoint has no default constructor.

When using the second constructor, the Identifier (nID) of the second constructor can be linked with a STRINGTABLE resource with the same id in such form "Caption\\nDescription".

BINDING: Variables can be bound to an item in two ways, the first is to pass in a variable at the time of creation, the second allows variables to be bound to an item after creation with the BindToPoint member.

Bound variables store the values of the property grid items and can be accessed without using the property grid methods and properties. Bound variables allow the property grid to store data in variables. When the value of a PropertyGridItem is changed, the value of the bound variable will be changed to the PropertyGridItem value. The advantage of binding is that the variable can be used and manipulated without using PropertyGridItem methods and properties.

NOTE: If the value of the variable is changed without using the PropertyGrid, the PropertyGridItem value will not be updated until you call CXTPPropertyGrid::Refresh.

See also
BindToPoint

◆ CXTPPropertyGridItemPoint() [2/2]

CXTPPropertyGridItemPoint | ( | UINT | nID,
 |  | CPoint | pt = 0,
 |  | CPoint * | pBindPoint = NULL )

Constructs a CXTPPropertyGridItemPoint object.

Parameters
nID | Identifier of the item.
pt | Initial point value of item.
pBindPoint | If not NULL, then the value of this item is bound the value of this variable.

Class CXTPPropertyGridItemPoint has no default constructor.

When using the second constructor, the Identifier (nID) of the second constructor can be linked with a STRINGTABLE resource with the same id in such form "Caption\\nDescription".

BINDING: Variables can be bound to an item in two ways, the first is to pass in a variable at the time of creation, the second allows variables to be bound to an item after creation with the BindToPoint member.

Bound variables store the values of the property grid items and can be accessed without using the property grid methods and properties. Bound variables allow the property grid to store data in variables. When the value of a PropertyGridItem is changed, the value of the bound variable will be changed to the PropertyGridItem value. The advantage of binding is that the variable can be used and manipulated without using PropertyGridItem methods and properties.

NOTE: If the value of the variable is changed without using the PropertyGrid, the PropertyGridItem value will not be updated until you call CXTPPropertyGrid::Refresh.

See also
BindToPoint

Member Function Documentation

◆ BindToPoint()

virtual void BindToPoint ( CPoint * pBindPoint )
virtual

Binds the item to a specified CPoint object.

Parameters
pBindPoint Pointer to a CPoint object.

Variables can be bound to an item in two ways, the first is to pass in a variable at the time of creation, the second allows variables to be bound to an item after creation with the BindToPoint member.

Bound variables store the values of the property grid items and can be accessed without using the property grid methods and properties. Bound variables allow the property grid to store data in variables. When the value of a PropertyGridItem is changed, the value of the bound variable will be changed to the PropertyGridItem value. The advantage of binding is that the variable can be used and manipulated without using PropertyGridItem methods and properties.

NOTE: If the value of the variable is changed without using the PropertyGrid, the PropertyGridItem value will not be updated until you call CXTPPropertyGrid::Refresh.

◆ GetPoint()

AFX_INLINE CPoint GetPoint ( ) const
virtual

Gets the point value of the item.

Returns
The point value of the item.

◆ OnBeforeInsert()

virtual void OnBeforeInsert ( )
protectedvirtual

This method is called before the item becomes visible in the property grid.

Before the item is inserted, it is first checked to see if it is bound to a variable. If it is, then the value of the item is updated with the value stored in the bound variable.

OnBeforeInsert is called when an item is inserted, when a category is inserted, when a category or item is expanded, and when the sort property has changed.

Reimplemented from CXTPPropertyGridItem.

◆ SetPoint()

virtual void SetPoint ( CPoint pt )
virtual

Sets the point value for the item.

Parameters
pt Point value to be set.
The documentation for this class was generated from the following file:
  • XTPPropertyGridItemSize.h


Toolkit Pro: CXTPPropertyGridItems Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPPropertyGridItems Class Reference

CXTPPropertyGridItems is a CList derived class. More...

Inheritance diagram for CXTPPropertyGridItems:
[legend]

Public Member Functions

CXTPPropertyGridItem * | FindItem (UINT nID) const
Retrieves an item by its identifier.
CXTPPropertyGridItem * | FindItem (LPCTSTR strCaption) const
Retrieves an item by its caption.
int | Find (CXTPPropertyGridItem *pItem) const
Retrieves the index of a specified item within the collection of items.
void | Clear ()
Clears all items from the collection of items.
long | GetCount () const
Gets the number of items within the collection of items.
BOOL | IsEmpty () const
Determines if any items have been added to the property grid.
CXTPPropertyGridItem * | GetAt (int nIndex) const
Retrieves the item at a specified index within the collection of items.
void | RemoveAt (int nIndex)
Removes the item at a specified index within the collection of items.
void | Sort ()
Sorts the collection of items in alphabetical order.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

CXTPPropertyGridItems ()
Constructs a CXTPPropertyGridItems object.
void | AddTail (CXTPPropertyGridItem *pItem)
Adds an item/collection of items to the end (tail) of the property grid's collection of items.
void | AddTail (CXTPPropertyGridItems *pItems)
Adds an item/collection of items to the end (tail) of the property grid's collection of items.
void | InsertAt (int nIndex, CXTPPropertyGridItem *pItem)
Inserts a specified item at a specified index within the property grid's collection of items.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

CXTPPropertyGridItems is a CList derived class.

It represents the items collection with some internal functionality.

Member Function Documentation

◆ AddTail() [1/2]

AFX_INLINE void AddTail ( CXTPPropertyGridItem * pItem )
protected

Adds an item/collection of items to the end (tail) of the property grid's collection of items.

Parameters
pItem Pointer to an item to add.

Property grid's collection of items can be empty prior to calling this method.

◆ AddTail() [2/2]

void AddTail ( CXTPPropertyGridItems * pItems )
protected

Adds an item/collection of items to the end (tail) of the property grid's collection of items.

Parameters
pItems Pointer to a collection of items to add.

Property grid's collection of items can be empty prior to calling this method.

◆ Find()

int Find ( CXTPPropertyGridItem * pItem ) const

Retrieves the index of a specified item within the collection of items.

Parameters
pItem Pointer to the CXTPPropertyGridItem object whose index must be retrieved.
Returns
The index of the specified item within the collection of items if found, otherwise a value of -1.

◆ FindItem() [1/2]

CXTPPropertyGridItem * FindItem ( LPCTSTR strCaption ) const

Retrieves an item by its caption.

Parameters
strCaption Caption of the item to retrieve.
Returns
A pointer to the CXTPPropertyGridItem object if found, otherwise NULL.

◆ FindItem() [2/2]

CXTPPropertyGridItem * FindItem ( UINT nID ) const

Retrieves an item by its identifier.

Parameters
nID Indentifier of the item to retrieve.
Returns
A pointer to the CXTPPropertyGridItem object if found, otherwise NULL.

◆ GetAt()

CXTPPropertyGridItem * GetAt ( int nIndex ) const

Retrieves the item at a specified index within the collection of items.

Parameters
nIndex Index of the item to retrieve.
Returns
A pointer to the CXTPPropertyGridItem object at the specified index if successful, otherwise a value of 0.

◆ GetCount()

AFX_INLINE long GetCount ( ) const

Gets the number of items within the collection of items.

Returns
The number of items within the collection of items.

◆ InsertAt()

AFX_INLINE void InsertAt | ( | int | nIndex,
 |  | CXTPPropertyGridItem * | pItem )
 protected

Inserts a specified item at a specified index within the property grid's collection of items.

Parameters
nIndex | Index to insert the item at.
pItem | Pointer to the item to insert.

◆ IsEmpty()

AFX_INLINE BOOL IsEmpty ( ) const

Determines if any items have been added to the property grid.

Returns
TRUE if there are no items in the property grid, FALSE if there is at least one item in the property grid.

◆ RemoveAt()

void RemoveAt ( int nIndex )

Removes the item at a specified index within the collection of items.

Parameters
nIndex Index of the item to remove.

◆ Sort()

void Sort ( )

Sorts the collection of items in alphabetical order.

This method uses the Visual C++ run-time library (MSVCRT) implementation of the quick-sort function, qsort, for sorting stored CXTPPropertyGridItem objects.

The documentation for this class was generated from the following file:
  • XTPPropertyGridItem.h


Toolkit Pro: CXTPPropertyGridItemSize Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPPropertyGridItemSize Class Reference

CXTPPropertyGridItemSize is a CXTPPropertyGridItem derived class. More...

Inheritance diagram for CXTPPropertyGridItemSize:
[legend]

Public Member Functions

CXTPPropertyGridItemSize (LPCTSTR strCaption, CSize size=0, CSize *pBindSize=NULL)
Constructs a CXTPPropertyGridItemSize object.
CXTPPropertyGridItemSize (UINT nID, CSize size=0, CSize *pBindSize=NULL)
Constructs a CXTPPropertyGridItemSize object.
virtual | ~CXTPPropertyGridItemSize ()
Destroys a CXTPPropertyGridItemSize object.
virtual void | SetSize (CSize size)
Sets the size value for the item.
virtual CSize | GetSize () const
Gets the size value of the item.
virtual void | BindToSize (CSize *pBindSize)
Binds the item to a specified CSize object.
- Public Member Functions inherited from CXTPPropertyGridItem
CXTPPropertyGridItem (LPCTSTR lpszCaption, LPCTSTR strValue=NULL, CString *pBindString=NULL)
Constructs a CXTPPropertyGridItem object.
CXTPPropertyGridItem (UINT nID, LPCTSTR strValue=NULL, CString *pBindString=NULL)
Constructs a CXTPPropertyGridItem object.
virtual | ~CXTPPropertyGridItem ()
Destroys a CXTPPropertyGridItem object, handles cleanup and deallocation.
void | SetCaption (LPCTSTR lpszCaption)
Sets the caption text for the item.
void | SetPrompt (LPCTSTR lpszPrompt)
Loads a string from a STRINGTABLE resource to set the caption and description for the item.
void | SetDescription (LPCTSTR lpszDescription)
Sets the description text for the item.
void | SetMarkupTemplate (LPCTSTR lpstrMarkupTemplate)
Sets the markup text for the item.
void | SetTooltip (LPCTSTR lpstrTooltip)
Sets the tooltip text for the item.
CString | GetTooltip () const
Gets the tooltip text of the item.
virtual void | SetReadOnly (BOOL bReadOnly=TRUE)
Specifies if the item state should be set to read-only or to read/write.
void | SetID (UINT nID)
Sets the identifier for the item.
void | SetFlags (UINT nFlags)
Sets a specific flag for the item.
CString | GetCaption () const
Gets the caption text of the item.
CString | GetDescription () const
Gets the description text of the item.
virtual CString | GetMarkupTemplate () const
Gets the markup text of the item.
virtual BOOL | GetReadOnly () const
Determines if the item state is set to read-only or to read/write.
virtual BOOL | IsAllowEdit () const
Determines if items in the property grid are allowed to be edited by the user.
UINT | GetID () const
Gets the identifier of the item.
int | GetIndex () const
Gets the index of the item within the property grid list.
CString | GetValue () const
Gets the value of the item.
CString | GetDefaultValue () const
Gets the default value of the item.
UINT | GetFlags () const
Gets the flags of the item.
BOOL | IsCategory () const
Determines if the item is a category.
CXTPPropertyGridItem * | AddChildItem (CXTPPropertyGridItem *pItem)
Adds a child item.
void | Move (CXTPPropertyGridItem *pParent, int nIndex=-1)
Moves the item to another category.
CXTPPropertyGridItem * | InsertChildItem (int nIndex, CXTPPropertyGridItem *pItem)
Inserts a child item.
BOOL | HasChilds () const
Determines if the item has children.
BOOL | HasVisibleChilds () const
Determines if the item has visible children.
CXTPPropertyGridItems * | GetChilds () const
Gets the item's list of child items.
BOOL | HasParent (CXTPPropertyGridItem *pParent)
Determines if the item has a specified item as a parent.
CXTPPropertyGridItemConstraints * | GetConstraints () const
Gets the item's list of constraints.
void | SetConstraintEdit (BOOL bConstraintEdit=TRUE)
Enables/disables constraint editing mode.
void | SetAutoComplete (BOOL bAutoComplete=TRUE)
Enables/disables auto-complete for the constraint list.
BOOL | GetConstraintEdit () const
Determines if constraint editing mode is enabled/disabled.
void | Expand ()
Expands the item.
void | Collapse ()
Collapses the item.
void | SetExpandable (BOOL bExpandable)
Specifies if the item should be expandable by the user.
BOOL | IsExpandable () const
Determines if the item is expandable by the user.
void | Select ()
Selects the item.
CRect | GetItemRect () const
Gets the bounding rectangle of the item.
virtual CRect | GetValueRect ()
Gets the bounding rectangle of the item value's text.
void | SetHidden (BOOL bHidden)
Hides/shows the item.
BOOL | IsHidden () const
Determines if the item is hidden/shown.
virtual void | OnValueChanged (CString strValue)
This method is called when the value of the item is changed.
virtual void | OnMarkupChanged ()
This method is called when the markup text of the item is changed.
CXTPPropertyGridView * | GetGrid () const
Gets the parent window.
BOOL | IsVisible () const
Determines the visible state of the item.
BOOL | IsExpanded () const
Determines the expanded state of the item.
CXTPPropertyGridItem * | GetParentItem () const
Gets the parent item of this item, if any.
int | GetIndent () const
Gets the indent of the item.
virtual BOOL | OnDrawItemValue (CDC &dc, CRect rcValue)
This method is called when an item is drawn.
virtual void | OnDrawItemConstraint (CDC *pDC, CXTPPropertyGridItemConstraint *pConstraint, CRect rc, BOOL bSelected)
This method is called when a constraint in an in-place list is drawn.
virtual CSize | OnMergeItemConstraint (CDC *pDC, CXTPPropertyGridItemConstraint *pConstraint)
This method is called to get size of constraint in in-place list.
virtual void | MeasureItem (LPMEASUREITEMSTRUCT lpMeasureItemStruct)
Override this method and fill in a specified MEASUREITEMSTRUCT structure to inform Windows of the list-box dimensions.
BOOL | IsSelected () const
Determines the selected stae of the item.
void | BindToString (CString *pBindString)
Binds the item to a specified CString object.
void | Remove ()
Removes this item.
void | SetMask (LPCTSTR strMask, LPCTSTR strLiteral, TCHAR chPrompt=_T('_'))
Applies a specified mask to a CXTPPropertyGridItem data field to create a restrictive field for text entry.
void | SetPasswordMask (TCHAR chMask=_T(' *'))
Sets a password mask for the item.
CString | GetMaskedText () const
Gets the actual text value of the item without mask characters.
virtual BOOL | IsValueChanged () const
Determines if the value of the item was changed by the user.
virtual void | ResetValue ()
Resets the value of the item to its default value.
void | SetDefaultValue (LPCTSTR lpszDefaultValue)
Sets the default value for the item.
void | SetMaskedText (LPCTSTR lpszMaskedText)
Sets the actual text value for the item without mask characters.
virtual CString | GetViewValue ()
Gets the value of the item that the user is currently viewing.
void | SetItemData (DWORD_PTR dwData)
Sets the 32-bit value associated with the item.
DWORD_PTR | GetItemData () const
Gets the application-supplied, 32-bit value associated with the item.
virtual CXTPPropertyGridInplaceEdit & | GetInplaceEdit ()
Gets the in-place edit control of the item.
virtual void | SetFocusToInplaceControl ()
Sets focus to the in-place control of the item.
virtual BOOL | IsInplaceButtonVisible (CXTPPropertyGridInplaceButton *pButton) const
Determines if a specified in-place button is visible.
CXTPPropertyGridInplaceButtons * | GetInplaceButtons () const
Gets the collection of in-place buttons of the item.
CXTPPropertyGridInplaceControls * | GetInplaceControls () const
Gets the collection of in-place controls of the item.
void | AddComboButton ()
Adds a standard combo button.
void | AddExpandButton ()
Adds a standard expand button.
CXTPPropertyGridInplaceSlider * AddSliderControl ()
Adds a slider control.
CXTPPropertyGridInplaceSpinButton * AddSpinButton ()
Adds a spin button control.
CXTPPropertyGridItemMetrics * | GetValueMetrics () const
Gets the metrics of the value part.
CXTPPropertyGridItemMetrics * | GetCaptionMetrics () const
Gets the metrics of the caption part.
CXTPPropertyGridItemMetrics * | GetMetrics (BOOL bValueMetrics, BOOL bCreate=TRUE) const
Gets the metrics of the value/caption part.
int | GetHeight () const
Gets the variable height of the item.
void | SetHeight (int nHeight)
Sets the variable height of the item.
BOOL | IsMultiLine () const
Determines if the item is multi-line (i.e.
int | GetMultiLinesCount () const
Gets the number of lines of the item.
void | SetMultiLinesCount (int nLinesCount)
Sets the number of lines for the item.
void | EnsureVisible ()
Ensures that this item is visible.
virtual BOOL | OnRequestEdit ()
This method is called before the user begins editing the item.
virtual BOOL | OnAfterEdit (CString &strValue)
This method is called before the user applies a new value to the item.
virtual void | OnCancelEdit ()
This method is called if the user cancels editing the item.
void | SetEditStyle (DWORD dwEditStyle)
Sets the edit style for the item.
void | SetDropDownItemCount (int nDropDownItemCount)
Sets the number of items in the dropdown list.
int | GetDropDownItemCount () const
Gets the number of items in the dropdown list.
virtual void | OnValidateEdit ()
This method is called to check the value from the in-place edit control.
CXTPMarkupUIElement * | GetMarkupCaption () const
Gets the CXTPMarkupUIElement object that renders the caption of the item.
CXTPMarkupUIElement * | GetMarkupDescription () const
Gets the CXTPMarkupUIElement object that renders the description of the item in the Help pane.
CXTPMarkupUIElement * | GetMarkupValue () const
Gets the CXTPMarkupUIElement object that renders the value of the item in the property grid.
virtual DWORD | GetEditStyle () const
Gets the edit style of the item.
void | RedrawItem ()
Redraws the item.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

virtual void | OnBeforeInsert ()
This method is called before the item becomes visible in the property grid.
- Protected Member Functions inherited from CXTPPropertyGridItem
virtual void | SetVisible (BOOL bVisible)
Sets the visible state of the item.
virtual void | OnIndexChanged ()
This method is called when the index of the item is changed.
virtual void | OnSelect ()
This method is called when an item is selected.
virtual void | OnDeselect ()
This method is called when an item is de-selected.
virtual BOOL | OnChar (UINT nChar)
This method is called when a key is pressed.
virtual void | OnLButtonDblClk (UINT nFlags, CPoint point)
This method is called when the user double-clicks the left mouse button on the item.
virtual void | OnRButtonDown (UINT nFlags, CPoint point)
This method is called when the user presses the right mouse button on the item.
virtual BOOL | OnLButtonDown (UINT nFlags, CPoint point)
This method is called when the user presses the left mouse button on the item.
virtual void | OnLButtonUp (UINT nFlags, CPoint point)
This method is called when the user releases the left mouse button on the item.
virtual BOOL | OnKeyDown (UINT nChar)
This method is called when a non-system key is pressed.
virtual void | OnInplaceButtonDown (CXTPPropertyGridInplaceButton *pButton)
This method is called when the user presses the in-place button.
virtual CXTPPropertyGridInplaceList & | GetInplaceList ()
Gets the in-place list control of the item.
virtual void | SetEditText (const CString &str)
Sets the text for the in-place edit control.
virtual void | OnConstraintsChanged ()
This method is called when constraints are added to the item (i.e.
virtual void | OnCaptionChanged ()
This method is called when the caption of the item is changed.
virtual BOOL | OnInpaceControlFocus (BOOL bForward)
This method is called by the property grid to set focus to an in-place child window.
virtual CString | GetInPlacedEditValue ()
Gets the text of the in-place edit control.
void | NotifyValueChanged ()
This method is called when the item's value is changed.
BOOL | SelectNextConstraint ()
Selects the next constraint in the list of constraints.
BOOL | PtInValueRect (CPoint point)
Determines if a specified point is within the value rectangle.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Static Protected Member Functions inherited from CXTPPropertyGridItem
- Protected Attributes inherited from CXTPPropertyGridItem
BOOL | m_bConstraintEdit
TRUE to constraint edit.
int | m_nIndex
Index of the item.
int | m_nIndent
Indent of the item.
UINT | m_nID
Identifier of the item.
UINT | m_nFlags
Item's flags.
BOOL | m_bReadOnly
TRUE if the item state is set to read-only, FALSE if the item state is set to read/write.
BOOL | m_bVisible
Visibility of the item.
BOOL | m_bCategory
TRUE if the item is a category.
BOOL | m_bExpandable
TRUE if the item can be expanded.
BOOL | m_bExpanded
TRUE if the item is expanded.
CString | m_strValue
Value of the item.
CString | m_strDefaultValue
Default value of the item.
CString | m_strCaption
Caption of the item.
CString | m_strDescription
Description of the item.
CString | m_strTooltip
Tooltip text.
CXTPPropertyGridItem * | m_pParent
Parent item.
CXTPPropertyGridView * | m_pGrid
Parent grid class.
CXTPPropertyGridItems * | m_pChilds
Child items.
CXTPPropertyGridItemConstraints * | m_pConstraints
Item's constraints.
BOOL | m_bAutoComplete
TRUE to enable auto-complete for the item.
CXTPPropertyGridItemMetrics * | m_pValueMetrics
Value part metrics.
CXTPPropertyGridItemMetrics * | m_pCaptionMetrics
Caption part metrics.
CXTPPropertyGridInplaceButtons * | m_pInplaceButtons
In-place buttons array.
CXTPPropertyGridInplaceControls * | m_pInplaceControls
In-place controls array.
int | m_nDropDownItemCount
Maximum drop down items.
CString * | m_pBindString
Bound string.
CString | m_strFormat
Format of the double value.
CString | m_strMask
String to use as edit mask.
CString | m_strLiteral
String to use as literal.
CString | m_strMarkupTemplate
String that represents item's display when markup is on.
TCHAR | m_chPrompt
Character used as a space holder for a character.
BOOL | m_bUseMask
TRUE to use an edit mask to display item data.
BOOL | m_bPassword
TRUE to use a password mask.
DWORD_PTR | m_dwData
The 32-bit value associated with the item.
BOOL | m_bHidden
TRUE if the item is hidden, FALSE if the item is shown.
int | m_nHeight
Item's height; -1 to use the default.
int | m_nLinesCount
Number of lines in a multi-line item.
DWORD | m_dwEditStyle
Edit style.
CXTPMarkupUIElement * | m_pMarkupCaption
Markup UIElement for item's caption.
CXTPMarkupUIElement * | m_pMarkupDescription
Markup UIElement for item's description.
CXTPMarkupUIElement * | m_pMarkupValue
Markup UIElement for item's value.

Detailed Description

CXTPPropertyGridItemSize is a CXTPPropertyGridItem derived class.

It is used to create a size value item in a Property Grid control.

Constructor & Destructor Documentation

◆ CXTPPropertyGridItemSize() [1/2]

CXTPPropertyGridItemSize | ( | LPCTSTR | strCaption,
 |  | CSize | size = 0,
 |  | CSize * | pBindSize = NULL )

Constructs a CXTPPropertyGridItemSize object.

Parameters
strCaption | Caption of the item.
size | Initial size value of the item.
pBindSize | If not NULL, then the value of the item is bound the value of this variable.

Class CXTPPropertyGridItemSize has no default constructor.

When using the second constructor, the Identifier (nID) of the second constructor can be linked with a STRINGTABLE resource with the same ID in such form "Caption\\nDescription".

BINDING: Variables can be bound to an item in two ways, the first is to pass in a variable at the time of creation, the second allows variables to be bound to an item after creation with the BindToSize member.

Bound variables store the values of the property grid items and can be accessed without using the property grid methods and properties. Bound variables allow the property grid to store data in variables. When the value of a PropertyGridItem is changed, the value of the bound variable will be changed to the PropertyGridItem value. The advantage of binding is that the variable can be used and manipulated without using PropertyGridItem methods and properties.

NOTE: If the value of the variable is changed without using the PropertyGrid, the PropertyGridItem value will not be updated until you call CXTPPropertyGrid::Refresh.

See also
BindToSize

◆ CXTPPropertyGridItemSize() [2/2]

CXTPPropertyGridItemSize | ( | UINT | nID,
 |  | CSize | size = 0,
 |  | CSize * | pBindSize = NULL )

Constructs a CXTPPropertyGridItemSize object.

Parameters
nID | Identifier of the item.
size | Initial size value of the item.
pBindSize | If not NULL, then the value of the item is bound the value of this variable.

Class CXTPPropertyGridItemSize has no default constructor.

When using the second constructor, the Identifier (nID) of the second constructor can be linked with a STRINGTABLE resource with the same ID in such form "Caption\\nDescription".

BINDING: Variables can be bound to an item in two ways, the first is to pass in a variable at the time of creation, the second allows variables to be bound to an item after creation with the BindToSize member.

Bound variables store the values of the property grid items and can be accessed without using the property grid methods and properties. Bound variables allow the property grid to store data in variables. When the value of a PropertyGridItem is changed, the value of the bound variable will be changed to the PropertyGridItem value. The advantage of binding is that the variable can be used and manipulated without using PropertyGridItem methods and properties.

NOTE: If the value of the variable is changed without using the PropertyGrid, the PropertyGridItem value will not be updated until you call CXTPPropertyGrid::Refresh.

See also
BindToSize

Member Function Documentation

◆ BindToSize()

virtual void BindToSize ( CSize * pBindSize )
virtual

Binds the item to a specified CSize object.

Parameters
pBindSize Pointer to a CSize object.

Variables can be bound to an item in two ways, the first is to pass in a variable at the time of creation, the second allows variables to be bound to an item after creation with the BindToSize member.

Bound variables store the values of the property grid items and can be accessed without using the property grid methods and properties. Bound variables allow the property grid to store data in variables. When the value of a PropertyGridItem is changed, the value of the bound variable will be changed to the PropertyGridItem value. The advantage of binding is that the variable can be used and manipulated without using PropertyGridItem methods and properties.

NOTE: If the value of the variable is changed without using the PropertyGrid, the PropertyGridItem value will not be updated until you call CXTPPropertyGrid::Refresh.

◆ GetSize()

AFX_INLINE CSize GetSize ( ) const
virtual

Gets the size value of the item.

Returns
The size value of the item.

◆ OnBeforeInsert()

virtual void OnBeforeInsert ( )
protectedvirtual

This method is called before the item becomes visible in the property grid.

Before the item is inserted, it is first checked to see if it is bound to a variable. If it is, then the value of the item is updated with the value stored in the bound variable.

OnBeforeInsert is called when an item is inserted, when a category is inserted, when a category or item is expanded, and when the sort property has changed.

Reimplemented from CXTPPropertyGridItem.

◆ SetSize()

virtual void SetSize ( CSize size )
virtual

Sets the size value for the item.

Parameters
size size value to be set.
The documentation for this class was generated from the following file:
  • XTPPropertyGridItemSize.h


Toolkit Pro: CXTPPropertyGridNativeWindows10Theme Class Reference

Public Member Functions | List of all members
CXTPPropertyGridNativeWindows10Theme Class Reference

CXTPPropertyGridNativeWindows10Theme is a CXTPPropertyGridVisualStudio2010Theme derived class. More...

Inheritance diagram for CXTPPropertyGridNativeWindows10Theme:
[legend]

Public Member Functions

CXTPPropertyGridNativeWindows10Theme (CXTPPropertyGrid *pGrid)
Constructs a CXTPPropertyGridNativeWindows10Theme object.
virtual void | DrawExpandButton (CDC &dc, CXTPPropertyGridItem *pItem, CRect rcCaption)
Draws an expand button for the grid.
virtual void | RefreshMetrics ()
Refreshes the visual metrics of the property grid.
virtual XTPScrollBarTheme | GetScrollBarTheme () const
Gets the scrollbar theme identifier.
- Public Member Functions inherited from CXTPPropertyGridVisualStudio2010Theme
CXTPPropertyGridVisualStudio2010Theme (CXTPPropertyGrid *pGrid)
Constructs a CXTPPropertyGridVisualStudio2010Theme object.
~CXTPPropertyGridVisualStudio2010Theme ()
Destroys a CXTPPropertyGridVisualStudio2010Theme object, handles cleanup and deallocation.
- Public Member Functions inherited from CXTPPropertyGridPaintManager
CXTPPropertyGridPaintManager (CXTPPropertyGrid *pGrid)
Constructs a CXTPPropertyGridPaintManager object.
virtual | ~CXTPPropertyGridPaintManager ()
Destroys a CXTPPropertyGridPaintManager object, handles cleanup and deallocation.
virtual COLORREF | GetItemTextColor (CXTPPropertyGridItem *pItem, BOOL bValuePart)
Retrieves the text color of a specified item.
virtual COLORREF | GetItemBackColor (CXTPPropertyGridItem *pItem, BOOL bValuePart)
Retrieves the back color of a specified item.
virtual CFont * | GetItemFont (CXTPPropertyGridItem *pItem, BOOL bValuePart)
Retrieves the font of a specified item.
virtual void | FillPropertyGrid (CDC *pDC)
Draws the background of the property grid.
virtual void | FillPropertyGridView (CDC *pDC)
Draws the background of the view.
virtual void | DrawPropertyGridBorder (CDC *pDC, RECT &rcBorder, XTPPropertyGridWindow nWindow)
Draws grid borders.
virtual void | OnNcCalcSize (RECT &rc)
Adjusts the bounding rectangle of the grid.
virtual void | DrawItem (PDRAWITEMSTRUCT lpDrawItemStruct)
Draws a single item of the grid.
virtual void | DrawInplaceListItem (CDC *pDC, CXTPPropertyGridItemConstraint *pConstraint, CRect rc, BOOL bSelected)
Draws a specified constraint in the in-place list.
virtual void | AdjustItemValueRect (CXTPPropertyGridItem *pItem, CRect &rcValue)
Adjusts the rectangle of the value part of a specified item.
virtual void | AdjustItemCaptionRect (CXTPPropertyGridItem *pItem, CRect &rcCaption)
Adjusts the rectangle of the caption part of a specified item.
virtual void | MeasureItem (LPMEASUREITEMSTRUCT lpMeasureItemStruct)
Override this method and fill in a specified MEASUREITEMSTRUCT structure to inform Windows of the list-box dimensions.
virtual void | FillInplaceButton (CDC *pDC, CXTPPropertyGridInplaceButton *pButton)
Draws an in-place button for the grid.
int | HitTestVerbs (CDC *pDC, CRect rcVerbs, CPoint pt)
Determines the index of the verb within the verbs collection, if any, at a specified point.
CXTPPropertyGridItemMetrics * | GetItemMetrics () const
Gets the default item metrics.
CRect | GetSplitterRect (CRect rc, BOOL bIsHelp)
This method is called by the property grid to retrieve the size of either the help window splitter bar or the verbs splitter bar.
virtual int | GetItemsBorderHeight () const
Gets the height of the horizontal grid line between property grid items.
virtual void | SetItemsBorderHeight (int nHeight)
Sets the height of the horizontal grid line between property grid items.
virtual void | SetThinSplitter (BOOL bThinSplitter)
Sets draw a bottom single line for the splitter bar.
virtual void | DrawCategoryCaptionBackground (CDC *pDC, CXTPPropertyGridItem *pItem, CRect rc)
Draws the background for the bounding rectangle of a category caption.
virtual void | DrawItemValue (CDC *pDC, CXTPPropertyGridItem *pItem, CRect rcValue)
Draws the value part of a property grid item.
virtual void | DrawItemCaption (CDC *pDC, CXTPPropertyGridItem *pItem, CRect rcCaption)
Draws the caption part of a property grid item.
virtual void | DrawInplaceButtons (CDC *pDC, PDRAWITEMSTRUCT lpDrawItemStruct, CXTPPropertyGridItem *pItem, CRect rcValue)
Draws the in-place buttons of a property grid item.
virtual void | DrawCheckBox (CDC *pDC, CXTPPropertyGridItemBool *pButton)
Draws a checkbox for a CXTPPropertyGridItemOption item with with the CheckBox style.
virtual void | DrawCheckMark (CDC *pDC, CRect rc, BOOL bEnabled, BOOL bChecked)
Draws a check mark.
virtual void | DrawRadioMark (CDC *pDC, CRect rc, BOOL bEnabled, BOOL bChecked)
Draws a radio button for a CXTPPropertyGridItemOption item with the RadioButton (default) style.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPPropertyGridPaintManager
XTPPropertyGridInplaceButtonsStyle | m_buttonsStyle
TRUE to use WinXP themes.
CXTPWinThemeWrapper * | m_themeTree
Themes for tree controls.
CXTPWinThemeWrapper * | m_themeButton
Themes for button controls.
CXTPWinThemeWrapper * | m_themeCombo
Themes for combo button.
BOOL | m_bTransparent
TRUE to draw background with parent color.
CXTPPaintManagerColor | m_clrFace
Face color.
CXTPPaintManagerColor | m_clrShadow
Shadow color.
CXTPPaintManagerColor | m_clrHighlight
Highlight color.
CXTPPaintManagerColor | m_clrHighlightText
Highlight text color.
CXTPPaintManagerColor | m_clrNonHighlightBack
Non-highlight background color.
CXTPPaintManagerColor | m_clrNonHighlightText
Non-highlight text color.
CXTPPaintManagerColor | m_clrCategorySeparator
Face color.
CXTPPaintManagerColor | m_clrSplitter
Splitter border color.
- Protected Attributes inherited from CXTPPropertyGridPaintManager
int | m_nItemsBorderHeight
Height, in pixels, of the horizontal border between property grid items.
int | m_nSplitterHeight
Height, in pixels, of the splitter bar.
int | m_nHelpHeight
Height, in pixels, of the description area (help pane).
int | m_nVerbsHeight
Height, in pixels, of the verbs box.
BOOL | m_bThinSplitter
TRUE to draw a single line for the splitter bar.
CXTPPropertyGrid * | m_pGrid
Parent grid class.
CXTPPropertyGridItemMetrics * | m_pMetrics
Default metrics of the item.

Detailed Description

CXTPPropertyGridNativeWindows10Theme is a CXTPPropertyGridVisualStudio2010Theme derived class.

It represents a Native Windows 10 style theme.

Constructor & Destructor Documentation

◆ CXTPPropertyGridNativeWindows10Theme()

CXTPPropertyGridNativeWindows10Theme ( CXTPPropertyGrid * pGrid )

Constructs a CXTPPropertyGridNativeWindows10Theme object.

Parameters
pGrid Pointer to a CXTPPropertyGrid object.

Member Function Documentation

◆ DrawExpandButton()

virtual void DrawExpandButton | ( | CDC & | dc,
 |  | CXTPPropertyGridItem * | pItem,
 |  | CRect | rcCaption )
 virtual

Draws an expand button for the grid.

Parameters
dc | Reference to a valid device context.
pItem | Pointer to a CXTPPropertyGridItem object.
rcCaption | Caption button rectangle.

Reimplemented from CXTPPropertyGridVisualStudio2010Theme.

◆ GetScrollBarTheme()

virtual XTPScrollBarTheme GetScrollBarTheme ( ) const
virtual

Gets the scrollbar theme identifier.

Returns
The scrollbar theme identifier; one of the values defined by the XTPScrollBarTheme enumeration.

Reimplemented from CXTPPropertyGridVisualStudio2010Theme.

The documentation for this class was generated from the following file:
  • XTPPropertyGridPaintManager.h


Toolkit Pro: CXTPPropertyGridNativeWindows11Theme Class Reference

Public Member Functions | List of all members
CXTPPropertyGridNativeWindows11Theme Class Reference

CXTPPropertyGridNativeWindows11Theme is a CXTPPropertyGridVisualStudio2010Theme derived class. More...

Inheritance diagram for CXTPPropertyGridNativeWindows11Theme:
[legend]

Public Member Functions

CXTPPropertyGridNativeWindows11Theme (CXTPPropertyGrid *pGrid)
Constructs a CXTPPropertyGridNativeWindows11Theme object.
virtual void | DrawExpandButton (CDC &dc, CXTPPropertyGridItem *pItem, CRect rcCaption)
Draws an expand button for the grid.
virtual void | RefreshMetrics ()
Refreshes the visual metrics of the property grid.
virtual XTPScrollBarTheme | GetScrollBarTheme () const
Gets the scrollbar theme identifier.
- Public Member Functions inherited from CXTPPropertyGridVisualStudio2010Theme
CXTPPropertyGridVisualStudio2010Theme (CXTPPropertyGrid *pGrid)
Constructs a CXTPPropertyGridVisualStudio2010Theme object.
~CXTPPropertyGridVisualStudio2010Theme ()
Destroys a CXTPPropertyGridVisualStudio2010Theme object, handles cleanup and deallocation.
- Public Member Functions inherited from CXTPPropertyGridPaintManager
CXTPPropertyGridPaintManager (CXTPPropertyGrid *pGrid)
Constructs a CXTPPropertyGridPaintManager object.
virtual | ~CXTPPropertyGridPaintManager ()
Destroys a CXTPPropertyGridPaintManager object, handles cleanup and deallocation.
virtual COLORREF | GetItemTextColor (CXTPPropertyGridItem *pItem, BOOL bValuePart)
Retrieves the text color of a specified item.
virtual COLORREF | GetItemBackColor (CXTPPropertyGridItem *pItem, BOOL bValuePart)
Retrieves the back color of a specified item.
virtual CFont * | GetItemFont (CXTPPropertyGridItem *pItem, BOOL bValuePart)
Retrieves the font of a specified item.
virtual void | FillPropertyGrid (CDC *pDC)
Draws the background of the property grid.
virtual void | FillPropertyGridView (CDC *pDC)
Draws the background of the view.
virtual void | DrawPropertyGridBorder (CDC *pDC, RECT &rcBorder, XTPPropertyGridWindow nWindow)
Draws grid borders.
virtual void | OnNcCalcSize (RECT &rc)
Adjusts the bounding rectangle of the grid.
virtual void | DrawItem (PDRAWITEMSTRUCT lpDrawItemStruct)
Draws a single item of the grid.
virtual void | DrawInplaceListItem (CDC *pDC, CXTPPropertyGridItemConstraint *pConstraint, CRect rc, BOOL bSelected)
Draws a specified constraint in the in-place list.
virtual void | AdjustItemValueRect (CXTPPropertyGridItem *pItem, CRect &rcValue)
Adjusts the rectangle of the value part of a specified item.
virtual void | AdjustItemCaptionRect (CXTPPropertyGridItem *pItem, CRect &rcCaption)
Adjusts the rectangle of the caption part of a specified item.
virtual void | MeasureItem (LPMEASUREITEMSTRUCT lpMeasureItemStruct)
Override this method and fill in a specified MEASUREITEMSTRUCT structure to inform Windows of the list-box dimensions.
virtual void | FillInplaceButton (CDC *pDC, CXTPPropertyGridInplaceButton *pButton)
Draws an in-place button for the grid.
int | HitTestVerbs (CDC *pDC, CRect rcVerbs, CPoint pt)
Determines the index of the verb within the verbs collection, if any, at a specified point.
CXTPPropertyGridItemMetrics * | GetItemMetrics () const
Gets the default item metrics.
CRect | GetSplitterRect (CRect rc, BOOL bIsHelp)
This method is called by the property grid to retrieve the size of either the help window splitter bar or the verbs splitter bar.
virtual int | GetItemsBorderHeight () const
Gets the height of the horizontal grid line between property grid items.
virtual void | SetItemsBorderHeight (int nHeight)
Sets the height of the horizontal grid line between property grid items.
virtual void | SetThinSplitter (BOOL bThinSplitter)
Sets draw a bottom single line for the splitter bar.
virtual void | DrawCategoryCaptionBackground (CDC *pDC, CXTPPropertyGridItem *pItem, CRect rc)
Draws the background for the bounding rectangle of a category caption.
virtual void | DrawItemValue (CDC *pDC, CXTPPropertyGridItem *pItem, CRect rcValue)
Draws the value part of a property grid item.
virtual void | DrawItemCaption (CDC *pDC, CXTPPropertyGridItem *pItem, CRect rcCaption)
Draws the caption part of a property grid item.
virtual void | DrawInplaceButtons (CDC *pDC, PDRAWITEMSTRUCT lpDrawItemStruct, CXTPPropertyGridItem *pItem, CRect rcValue)
Draws the in-place buttons of a property grid item.
virtual void | DrawCheckBox (CDC *pDC, CXTPPropertyGridItemBool *pButton)
Draws a checkbox for a CXTPPropertyGridItemOption item with with the CheckBox style.
virtual void | DrawCheckMark (CDC *pDC, CRect rc, BOOL bEnabled, BOOL bChecked)
Draws a check mark.
virtual void | DrawRadioMark (CDC *pDC, CRect rc, BOOL bEnabled, BOOL bChecked)
Draws a radio button for a CXTPPropertyGridItemOption item with the RadioButton (default) style.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPPropertyGridPaintManager
XTPPropertyGridInplaceButtonsStyle | m_buttonsStyle
TRUE to use WinXP themes.
CXTPWinThemeWrapper * | m_themeTree
Themes for tree controls.
CXTPWinThemeWrapper * | m_themeButton
Themes for button controls.
CXTPWinThemeWrapper * | m_themeCombo
Themes for combo button.
BOOL | m_bTransparent
TRUE to draw background with parent color.
CXTPPaintManagerColor | m_clrFace
Face color.
CXTPPaintManagerColor | m_clrShadow
Shadow color.
CXTPPaintManagerColor | m_clrHighlight
Highlight color.
CXTPPaintManagerColor | m_clrHighlightText
Highlight text color.
CXTPPaintManagerColor | m_clrNonHighlightBack
Non-highlight background color.
CXTPPaintManagerColor | m_clrNonHighlightText
Non-highlight text color.
CXTPPaintManagerColor | m_clrCategorySeparator
Face color.
CXTPPaintManagerColor | m_clrSplitter
Splitter border color.
- Protected Attributes inherited from CXTPPropertyGridPaintManager
int | m_nItemsBorderHeight
Height, in pixels, of the horizontal border between property grid items.
int | m_nSplitterHeight
Height, in pixels, of the splitter bar.
int | m_nHelpHeight
Height, in pixels, of the description area (help pane).
int | m_nVerbsHeight
Height, in pixels, of the verbs box.
BOOL | m_bThinSplitter
TRUE to draw a single line for the splitter bar.
CXTPPropertyGrid * | m_pGrid
Parent grid class.
CXTPPropertyGridItemMetrics * | m_pMetrics
Default metrics of the item.

Detailed Description

CXTPPropertyGridNativeWindows11Theme is a CXTPPropertyGridVisualStudio2010Theme derived class.

It represents a Native Windows 10 style theme.

Constructor & Destructor Documentation

◆ CXTPPropertyGridNativeWindows11Theme()

CXTPPropertyGridNativeWindows11Theme ( CXTPPropertyGrid * pGrid )

Constructs a CXTPPropertyGridNativeWindows11Theme object.

Parameters
pGrid Pointer to a CXTPPropertyGrid object.

Member Function Documentation

◆ DrawExpandButton()

virtual void DrawExpandButton | ( | CDC & | dc,
 |  | CXTPPropertyGridItem * | pItem,
 |  | CRect | rcCaption )
 virtual

Draws an expand button for the grid.

Parameters
dc | Reference to a valid device context.
pItem | Pointer to a CXTPPropertyGridItem object.
rcCaption | Caption button rectangle.

Reimplemented from CXTPPropertyGridVisualStudio2010Theme.

◆ GetScrollBarTheme()

virtual XTPScrollBarTheme GetScrollBarTheme ( ) const
virtual

Gets the scrollbar theme identifier.

Returns
The scrollbar theme identifier; one of the values defined by the XTPScrollBarTheme enumeration.

Reimplemented from CXTPPropertyGridVisualStudio2010Theme.

The documentation for this class was generated from the following file:
  • XTPPropertyGridPaintManager.h


Toolkit Pro: CXTPPropertyGridNativeXPTheme Class Reference

Public Member Functions | List of all members
CXTPPropertyGridNativeXPTheme Class Reference

CXTPPropertyGridNativeXPTheme is a CXTPPropertyGridPaintManager derived class. More...

Inheritance diagram for CXTPPropertyGridNativeXPTheme:
[legend]

Public Member Functions

CXTPPropertyGridNativeXPTheme (CXTPPropertyGrid *pGrid)
Constructs a CXTPPropertyGridNativeXPTheme object.
virtual void | RefreshMetrics ()
Refreshes the visual metrics of the property grid.
virtual XTPScrollBarTheme | GetScrollBarTheme () const
Gets the scrollbar theme identifier.
- Public Member Functions inherited from CXTPPropertyGridPaintManager
CXTPPropertyGridPaintManager (CXTPPropertyGrid *pGrid)
Constructs a CXTPPropertyGridPaintManager object.
virtual | ~CXTPPropertyGridPaintManager ()
Destroys a CXTPPropertyGridPaintManager object, handles cleanup and deallocation.
virtual COLORREF | GetItemTextColor (CXTPPropertyGridItem *pItem, BOOL bValuePart)
Retrieves the text color of a specified item.
virtual COLORREF | GetItemBackColor (CXTPPropertyGridItem *pItem, BOOL bValuePart)
Retrieves the back color of a specified item.
virtual CFont * | GetItemFont (CXTPPropertyGridItem *pItem, BOOL bValuePart)
Retrieves the font of a specified item.
virtual void | FillPropertyGrid (CDC *pDC)
Draws the background of the property grid.
virtual void | FillPropertyGridView (CDC *pDC)
Draws the background of the view.
virtual void | DrawPropertyGridBorder (CDC *pDC, RECT &rcBorder, XTPPropertyGridWindow nWindow)
Draws grid borders.
virtual void | OnNcCalcSize (RECT &rc)
Adjusts the bounding rectangle of the grid.
virtual void | DrawItem (PDRAWITEMSTRUCT lpDrawItemStruct)
Draws a single item of the grid.
virtual void | DrawInplaceListItem (CDC *pDC, CXTPPropertyGridItemConstraint *pConstraint, CRect rc, BOOL bSelected)
Draws a specified constraint in the in-place list.
virtual void | AdjustItemValueRect (CXTPPropertyGridItem *pItem, CRect &rcValue)
Adjusts the rectangle of the value part of a specified item.
virtual void | AdjustItemCaptionRect (CXTPPropertyGridItem *pItem, CRect &rcCaption)
Adjusts the rectangle of the caption part of a specified item.
virtual void | MeasureItem (LPMEASUREITEMSTRUCT lpMeasureItemStruct)
Override this method and fill in a specified MEASUREITEMSTRUCT structure to inform Windows of the list-box dimensions.
virtual void | FillInplaceButton (CDC *pDC, CXTPPropertyGridInplaceButton *pButton)
Draws an in-place button for the grid.
int | HitTestVerbs (CDC *pDC, CRect rcVerbs, CPoint pt)
Determines the index of the verb within the verbs collection, if any, at a specified point.
CXTPPropertyGridItemMetrics * | GetItemMetrics () const
Gets the default item metrics.
CRect | GetSplitterRect (CRect rc, BOOL bIsHelp)
This method is called by the property grid to retrieve the size of either the help window splitter bar or the verbs splitter bar.
virtual int | GetItemsBorderHeight () const
Gets the height of the horizontal grid line between property grid items.
virtual void | SetItemsBorderHeight (int nHeight)
Sets the height of the horizontal grid line between property grid items.
virtual void | SetThinSplitter (BOOL bThinSplitter)
Sets draw a bottom single line for the splitter bar.
virtual void | DrawExpandButton (CDC &dc, CXTPPropertyGridItem *pItem, CRect rcCaption)
Draws an expand button for the grid.
virtual void | DrawCategoryCaptionBackground (CDC *pDC, CXTPPropertyGridItem *pItem, CRect rc)
Draws the background for the bounding rectangle of a category caption.
virtual void | DrawItemValue (CDC *pDC, CXTPPropertyGridItem *pItem, CRect rcValue)
Draws the value part of a property grid item.
virtual void | DrawItemCaption (CDC *pDC, CXTPPropertyGridItem *pItem, CRect rcCaption)
Draws the caption part of a property grid item.
virtual void | DrawInplaceButtons (CDC *pDC, PDRAWITEMSTRUCT lpDrawItemStruct, CXTPPropertyGridItem *pItem, CRect rcValue)
Draws the in-place buttons of a property grid item.
virtual void | DrawCheckBox (CDC *pDC, CXTPPropertyGridItemBool *pButton)
Draws a checkbox for a CXTPPropertyGridItemOption item with with the CheckBox style.
virtual void | DrawCheckMark (CDC *pDC, CRect rc, BOOL bEnabled, BOOL bChecked)
Draws a check mark.
virtual void | DrawRadioMark (CDC *pDC, CRect rc, BOOL bEnabled, BOOL bChecked)
Draws a radio button for a CXTPPropertyGridItemOption item with the RadioButton (default) style.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPPropertyGridPaintManager
XTPPropertyGridInplaceButtonsStyle | m_buttonsStyle
TRUE to use WinXP themes.
CXTPWinThemeWrapper * | m_themeTree
Themes for tree controls.
CXTPWinThemeWrapper * | m_themeButton
Themes for button controls.
CXTPWinThemeWrapper * | m_themeCombo
Themes for combo button.
BOOL | m_bTransparent
TRUE to draw background with parent color.
CXTPPaintManagerColor | m_clrFace
Face color.
CXTPPaintManagerColor | m_clrShadow
Shadow color.
CXTPPaintManagerColor | m_clrHighlight
Highlight color.
CXTPPaintManagerColor | m_clrHighlightText
Highlight text color.
CXTPPaintManagerColor | m_clrNonHighlightBack
Non-highlight background color.
CXTPPaintManagerColor | m_clrNonHighlightText
Non-highlight text color.
CXTPPaintManagerColor | m_clrCategorySeparator
Face color.
CXTPPaintManagerColor | m_clrSplitter
Splitter border color.
- Protected Attributes inherited from CXTPPropertyGridPaintManager
int | m_nItemsBorderHeight
Height, in pixels, of the horizontal border between property grid items.
int | m_nSplitterHeight
Height, in pixels, of the splitter bar.
int | m_nHelpHeight
Height, in pixels, of the description area (help pane).
int | m_nVerbsHeight
Height, in pixels, of the verbs box.
BOOL | m_bThinSplitter
TRUE to draw a single line for the splitter bar.
CXTPPropertyGrid * | m_pGrid
Parent grid class.
CXTPPropertyGridItemMetrics * | m_pMetrics
Default metrics of the item.

Detailed Description

CXTPPropertyGridNativeXPTheme is a CXTPPropertyGridPaintManager derived class.

It represents a Native Windows XP style theme.

Constructor & Destructor Documentation

◆ CXTPPropertyGridNativeXPTheme()

CXTPPropertyGridNativeXPTheme ( CXTPPropertyGrid * pGrid )

Constructs a CXTPPropertyGridNativeXPTheme object.

Parameters
pGrid Pointer to a CXTPPropertyGrid object.

Member Function Documentation

◆ GetScrollBarTheme()

virtual XTPScrollBarTheme GetScrollBarTheme ( ) const
virtual

Gets the scrollbar theme identifier.

Returns
The scrollbar theme identifier; one of the values defined by the XTPScrollBarTheme enumeration.

Reimplemented from CXTPPropertyGridPaintManager.

The documentation for this class was generated from the following file:
  • XTPPropertyGridPaintManager.h


Toolkit Pro: CXTPPropertyGridOffice2003Theme Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPPropertyGridOffice2003Theme Class Reference

CXTPPropertyGridOffice2003Theme is a CXTPPropertyGridPaintManager derived class. More...

Inheritance diagram for CXTPPropertyGridOffice2003Theme:
[legend]

Public Member Functions

CXTPPropertyGridOffice2003Theme (CXTPPropertyGrid *pGrid)
Constructs a CXTPPropertyGridOffice2003Theme object.
virtual void | RefreshMetrics ()
Refreshes the visual metrics of the property grid.
virtual XTPScrollBarTheme | GetScrollBarTheme () const
Gets the scrollbar theme identifier.
- Public Member Functions inherited from CXTPPropertyGridPaintManager
CXTPPropertyGridPaintManager (CXTPPropertyGrid *pGrid)
Constructs a CXTPPropertyGridPaintManager object.
virtual | ~CXTPPropertyGridPaintManager ()
Destroys a CXTPPropertyGridPaintManager object, handles cleanup and deallocation.
virtual COLORREF | GetItemTextColor (CXTPPropertyGridItem *pItem, BOOL bValuePart)
Retrieves the text color of a specified item.
virtual COLORREF | GetItemBackColor (CXTPPropertyGridItem *pItem, BOOL bValuePart)
Retrieves the back color of a specified item.
virtual CFont * | GetItemFont (CXTPPropertyGridItem *pItem, BOOL bValuePart)
Retrieves the font of a specified item.
virtual void | FillPropertyGrid (CDC *pDC)
Draws the background of the property grid.
virtual void | FillPropertyGridView (CDC *pDC)
Draws the background of the view.
virtual void | DrawPropertyGridBorder (CDC *pDC, RECT &rcBorder, XTPPropertyGridWindow nWindow)
Draws grid borders.
virtual void | OnNcCalcSize (RECT &rc)
Adjusts the bounding rectangle of the grid.
virtual void | DrawItem (PDRAWITEMSTRUCT lpDrawItemStruct)
Draws a single item of the grid.
virtual void | DrawInplaceListItem (CDC *pDC, CXTPPropertyGridItemConstraint *pConstraint, CRect rc, BOOL bSelected)
Draws a specified constraint in the in-place list.
virtual void | AdjustItemValueRect (CXTPPropertyGridItem *pItem, CRect &rcValue)
Adjusts the rectangle of the value part of a specified item.
virtual void | AdjustItemCaptionRect (CXTPPropertyGridItem *pItem, CRect &rcCaption)
Adjusts the rectangle of the caption part of a specified item.
virtual void | MeasureItem (LPMEASUREITEMSTRUCT lpMeasureItemStruct)
Override this method and fill in a specified MEASUREITEMSTRUCT structure to inform Windows of the list-box dimensions.
virtual void | FillInplaceButton (CDC *pDC, CXTPPropertyGridInplaceButton *pButton)
Draws an in-place button for the grid.
int | HitTestVerbs (CDC *pDC, CRect rcVerbs, CPoint pt)
Determines the index of the verb within the verbs collection, if any, at a specified point.
CXTPPropertyGridItemMetrics * | GetItemMetrics () const
Gets the default item metrics.
CRect | GetSplitterRect (CRect rc, BOOL bIsHelp)
This method is called by the property grid to retrieve the size of either the help window splitter bar or the verbs splitter bar.
virtual int | GetItemsBorderHeight () const
Gets the height of the horizontal grid line between property grid items.
virtual void | SetItemsBorderHeight (int nHeight)
Sets the height of the horizontal grid line between property grid items.
virtual void | SetThinSplitter (BOOL bThinSplitter)
Sets draw a bottom single line for the splitter bar.
virtual void | DrawExpandButton (CDC &dc, CXTPPropertyGridItem *pItem, CRect rcCaption)
Draws an expand button for the grid.
virtual void | DrawCategoryCaptionBackground (CDC *pDC, CXTPPropertyGridItem *pItem, CRect rc)
Draws the background for the bounding rectangle of a category caption.
virtual void | DrawItemValue (CDC *pDC, CXTPPropertyGridItem *pItem, CRect rcValue)
Draws the value part of a property grid item.
virtual void | DrawItemCaption (CDC *pDC, CXTPPropertyGridItem *pItem, CRect rcCaption)
Draws the caption part of a property grid item.
virtual void | DrawInplaceButtons (CDC *pDC, PDRAWITEMSTRUCT lpDrawItemStruct, CXTPPropertyGridItem *pItem, CRect rcValue)
Draws the in-place buttons of a property grid item.
virtual void | DrawCheckBox (CDC *pDC, CXTPPropertyGridItemBool *pButton)
Draws a checkbox for a CXTPPropertyGridItemOption item with with the CheckBox style.
virtual void | DrawCheckMark (CDC *pDC, CRect rc, BOOL bEnabled, BOOL bChecked)
Draws a check mark.
virtual void | DrawRadioMark (CDC *pDC, CRect rc, BOOL bEnabled, BOOL bChecked)
Draws a radio button for a CXTPPropertyGridItemOption item with the RadioButton (default) style.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Attributes

BOOL | m_bLunaTheme
TRUE to use luna colors, FALSE otherwise.
- Protected Attributes inherited from CXTPPropertyGridPaintManager
int | m_nItemsBorderHeight
Height, in pixels, of the horizontal border between property grid items.
int | m_nSplitterHeight
Height, in pixels, of the splitter bar.
int | m_nHelpHeight
Height, in pixels, of the description area (help pane).
int | m_nVerbsHeight
Height, in pixels, of the verbs box.
BOOL | m_bThinSplitter
TRUE to draw a single line for the splitter bar.
CXTPPropertyGrid * | m_pGrid
Parent grid class.
CXTPPropertyGridItemMetrics * | m_pMetrics
Default metrics of the item.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPPropertyGridPaintManager
XTPPropertyGridInplaceButtonsStyle | m_buttonsStyle
TRUE to use WinXP themes.
CXTPWinThemeWrapper * | m_themeTree
Themes for tree controls.
CXTPWinThemeWrapper * | m_themeButton
Themes for button controls.
CXTPWinThemeWrapper * | m_themeCombo
Themes for combo button.
BOOL | m_bTransparent
TRUE to draw background with parent color.
CXTPPaintManagerColor | m_clrFace
Face color.
CXTPPaintManagerColor | m_clrShadow
Shadow color.
CXTPPaintManagerColor | m_clrHighlight
Highlight color.
CXTPPaintManagerColor | m_clrHighlightText
Highlight text color.
CXTPPaintManagerColor | m_clrNonHighlightBack
Non-highlight background color.
CXTPPaintManagerColor | m_clrNonHighlightText
Non-highlight text color.
CXTPPaintManagerColor | m_clrCategorySeparator
Face color.
CXTPPaintManagerColor | m_clrSplitter
Splitter border color.

Detailed Description

CXTPPropertyGridOffice2003Theme is a CXTPPropertyGridPaintManager derived class.

It represents an Office 2003 style theme.

Constructor & Destructor Documentation

◆ CXTPPropertyGridOffice2003Theme()

CXTPPropertyGridOffice2003Theme ( CXTPPropertyGrid * pGrid )

Constructs a CXTPPropertyGridOffice2003Theme object.

Parameters
pGrid Pointer to a CXTPPropertyGrid object.

Member Function Documentation

◆ GetScrollBarTheme()

virtual XTPScrollBarTheme GetScrollBarTheme ( ) const
virtual

Gets the scrollbar theme identifier.

Returns
The scrollbar theme identifier; one of the values defined by the XTPScrollBarTheme enumeration.

Reimplemented from CXTPPropertyGridPaintManager.

Reimplemented in CXTPPropertyGridOffice2007Theme.

The documentation for this class was generated from the following file:
  • XTPPropertyGridPaintManager.h


Toolkit Pro: CXTPPropertyGridOffice2007Theme Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPPropertyGridOffice2007Theme Class Reference

CXTPPropertyGridOffice2007Theme is a CXTPPropertyGridOffice2003Theme derived class. More...

Inheritance diagram for CXTPPropertyGridOffice2007Theme:
[legend]

Public Member Functions

CXTPPropertyGridOffice2007Theme (CXTPPropertyGrid *pGrid)
Constructs a CXTPPropertyGridOffice2003Theme object.
virtual void | RefreshMetrics ()
Refreshes the visual metrics of the property grid.
- Public Member Functions inherited from CXTPPropertyGridOffice2003Theme
CXTPPropertyGridOffice2003Theme (CXTPPropertyGrid *pGrid)
Constructs a CXTPPropertyGridOffice2003Theme object.
- Public Member Functions inherited from CXTPPropertyGridPaintManager
CXTPPropertyGridPaintManager (CXTPPropertyGrid *pGrid)
Constructs a CXTPPropertyGridPaintManager object.
virtual | ~CXTPPropertyGridPaintManager ()
Destroys a CXTPPropertyGridPaintManager object, handles cleanup and deallocation.
virtual COLORREF | GetItemTextColor (CXTPPropertyGridItem *pItem, BOOL bValuePart)
Retrieves the text color of a specified item.
virtual COLORREF | GetItemBackColor (CXTPPropertyGridItem *pItem, BOOL bValuePart)
Retrieves the back color of a specified item.
virtual CFont * | GetItemFont (CXTPPropertyGridItem *pItem, BOOL bValuePart)
Retrieves the font of a specified item.
virtual void | FillPropertyGrid (CDC *pDC)
Draws the background of the property grid.
virtual void | FillPropertyGridView (CDC *pDC)
Draws the background of the view.
virtual void | DrawPropertyGridBorder (CDC *pDC, RECT &rcBorder, XTPPropertyGridWindow nWindow)
Draws grid borders.
virtual void | OnNcCalcSize (RECT &rc)
Adjusts the bounding rectangle of the grid.
virtual void | DrawItem (PDRAWITEMSTRUCT lpDrawItemStruct)
Draws a single item of the grid.
virtual void | DrawInplaceListItem (CDC *pDC, CXTPPropertyGridItemConstraint *pConstraint, CRect rc, BOOL bSelected)
Draws a specified constraint in the in-place list.
virtual void | AdjustItemValueRect (CXTPPropertyGridItem *pItem, CRect &rcValue)
Adjusts the rectangle of the value part of a specified item.
virtual void | AdjustItemCaptionRect (CXTPPropertyGridItem *pItem, CRect &rcCaption)
Adjusts the rectangle of the caption part of a specified item.
virtual void | MeasureItem (LPMEASUREITEMSTRUCT lpMeasureItemStruct)
Override this method and fill in a specified MEASUREITEMSTRUCT structure to inform Windows of the list-box dimensions.
int | HitTestVerbs (CDC *pDC, CRect rcVerbs, CPoint pt)
Determines the index of the verb within the verbs collection, if any, at a specified point.
CXTPPropertyGridItemMetrics * | GetItemMetrics () const
Gets the default item metrics.
CRect | GetSplitterRect (CRect rc, BOOL bIsHelp)
This method is called by the property grid to retrieve the size of either the help window splitter bar or the verbs splitter bar.
virtual int | GetItemsBorderHeight () const
Gets the height of the horizontal grid line between property grid items.
virtual void | SetItemsBorderHeight (int nHeight)
Sets the height of the horizontal grid line between property grid items.
virtual void | SetThinSplitter (BOOL bThinSplitter)
Sets draw a bottom single line for the splitter bar.
virtual void | DrawCategoryCaptionBackground (CDC *pDC, CXTPPropertyGridItem *pItem, CRect rc)
Draws the background for the bounding rectangle of a category caption.
virtual void | DrawItemValue (CDC *pDC, CXTPPropertyGridItem *pItem, CRect rcValue)
Draws the value part of a property grid item.
virtual void | DrawItemCaption (CDC *pDC, CXTPPropertyGridItem *pItem, CRect rcCaption)
Draws the caption part of a property grid item.
virtual void | DrawInplaceButtons (CDC *pDC, PDRAWITEMSTRUCT lpDrawItemStruct, CXTPPropertyGridItem *pItem, CRect rcValue)
Draws the in-place buttons of a property grid item.
virtual void | DrawCheckBox (CDC *pDC, CXTPPropertyGridItemBool *pButton)
Draws a checkbox for a CXTPPropertyGridItemOption item with with the CheckBox style.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

virtual void | FillInplaceButton (CDC *pDC, CXTPPropertyGridInplaceButton *pButton)
Draws an in-place button for the grid.
virtual void | DrawCheckMark (CDC *pDC, CRect rc, BOOL bEnabled, BOOL bChecked)
Draws a check mark.
virtual void | DrawRadioMark (CDC *pDC, CRect rc, BOOL bEnabled, BOOL bChecked)
Draws a radio button for a CXTPPropertyGridItemOption item with the RadioButton (default) style.
void | DrawExpandButton (CDC &dc, CXTPPropertyGridItem *pItem, CRect rcCaption)
Draws an expand button for the grid.
virtual XTPScrollBarTheme | GetScrollBarTheme () const
Gets the scrollbar theme identifier.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPPropertyGridPaintManager
XTPPropertyGridInplaceButtonsStyle | m_buttonsStyle
TRUE to use WinXP themes.
CXTPWinThemeWrapper * | m_themeTree
Themes for tree controls.
CXTPWinThemeWrapper * | m_themeButton
Themes for button controls.
CXTPWinThemeWrapper * | m_themeCombo
Themes for combo button.
BOOL | m_bTransparent
TRUE to draw background with parent color.
CXTPPaintManagerColor | m_clrFace
Face color.
CXTPPaintManagerColor | m_clrShadow
Shadow color.
CXTPPaintManagerColor | m_clrHighlight
Highlight color.
CXTPPaintManagerColor | m_clrHighlightText
Highlight text color.
CXTPPaintManagerColor | m_clrNonHighlightBack
Non-highlight background color.
CXTPPaintManagerColor | m_clrNonHighlightText
Non-highlight text color.
CXTPPaintManagerColor | m_clrCategorySeparator
Face color.
CXTPPaintManagerColor | m_clrSplitter
Splitter border color.
- Protected Attributes inherited from CXTPPropertyGridOffice2003Theme
BOOL | m_bLunaTheme
TRUE to use luna colors, FALSE otherwise.
- Protected Attributes inherited from CXTPPropertyGridPaintManager
int | m_nItemsBorderHeight
Height, in pixels, of the horizontal border between property grid items.
int | m_nSplitterHeight
Height, in pixels, of the splitter bar.
int | m_nHelpHeight
Height, in pixels, of the description area (help pane).
int | m_nVerbsHeight
Height, in pixels, of the verbs box.
BOOL | m_bThinSplitter
TRUE to draw a single line for the splitter bar.
CXTPPropertyGrid * | m_pGrid
Parent grid class.
CXTPPropertyGridItemMetrics * | m_pMetrics
Default metrics of the item.

Detailed Description

CXTPPropertyGridOffice2007Theme is a CXTPPropertyGridOffice2003Theme derived class.

It represents an Office 2007 style theme.

Constructor & Destructor Documentation

◆ CXTPPropertyGridOffice2007Theme()

CXTPPropertyGridOffice2007Theme ( CXTPPropertyGrid * pGrid )

Constructs a CXTPPropertyGridOffice2003Theme object.

Parameters
pGrid Pointer to a CXTPPropertyGrid object.

Member Function Documentation

◆ DrawCheckMark()

virtual void DrawCheckMark | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | BOOL | bEnabled,
 |  | BOOL | bChecked )
 protectedvirtual

Draws a check mark.

Parameters
pDC | Pointer to a valid device context.
rc | Rectangle in logical units.
bEnabled | TRUE to set to enabled, FALSE to set to disabled.
bChecked | TRUE to set to checked, FALSE to set to unchecked.

Reimplemented from CXTPPropertyGridPaintManager.

◆ DrawExpandButton()

void DrawExpandButton | ( | CDC & | dc,
 |  | CXTPPropertyGridItem * | pItem,
 |  | CRect | rcCaption )
 protectedvirtual

Draws an expand button for the grid.

Parameters
dc | Reference to a valid device context.
pItem | Pointer to a CXTPPropertyGridItem object.
rcCaption | Caption button rectangle.

Reimplemented from CXTPPropertyGridPaintManager.

◆ DrawRadioMark()

virtual void DrawRadioMark | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | BOOL | bEnabled,
 |  | BOOL | bChecked )
 protectedvirtual

Draws a radio button for a CXTPPropertyGridItemOption item with the RadioButton (default) style.

Parameters
pDC | Pointer to a valid device context.
rc | Rectangle in logical units.
bEnabled | TRUE to set to enabled, FALSE to set to disabled.
bChecked | TRUE to set to checked, FALSE to set to unchecked.

Reimplemented from CXTPPropertyGridPaintManager.

◆ FillInplaceButton()

virtual void FillInplaceButton | ( | CDC * | pDC,
 |  | CXTPPropertyGridInplaceButton * | pButton )
 protectedvirtual

Draws an in-place button for the grid.

Parameters
pDC | Pointer to a valid device context.
pButton | Pointer to a CXTPPropertyGridInplaceButton object.

Reimplemented from CXTPPropertyGridPaintManager.

◆ GetScrollBarTheme()

virtual XTPScrollBarTheme GetScrollBarTheme ( ) const
protectedvirtual

Gets the scrollbar theme identifier.

Returns
The scrollbar theme identifier; one of the values defined by the XTPScrollBarTheme enumeration.

Reimplemented from CXTPPropertyGridOffice2003Theme.

The documentation for this class was generated from the following file:
  • XTPPropertyGridPaintManager.h


Toolkit Pro: CXTPPropertyGridOffice2013Theme Class Reference

Public Member Functions | Public Attributes | List of all members
CXTPPropertyGridOffice2013Theme Class Reference

CXTPPropertyGridOffice2013Theme is a CXTPPropertyGridPaintManager derived class. More...

Inheritance diagram for CXTPPropertyGridOffice2013Theme:
[legend]

Public Member Functions

CXTPPropertyGridOffice2013Theme (CXTPPropertyGrid *pGrid)
Constructs a CXTPPropertyGridOffice2013Theme object.
virtual void | RefreshMetrics ()
Refreshes the visual metrics of the property grid.
virtual void | DrawExpandButton (CDC &dc, CXTPPropertyGridItem *pItem, CRect rcCaption)
Draws an expand button for the grid.
virtual XTPScrollBarTheme | GetScrollBarTheme () const
Gets the scrollbar theme identifier.
- Public Member Functions inherited from CXTPPropertyGridPaintManager
CXTPPropertyGridPaintManager (CXTPPropertyGrid *pGrid)
Constructs a CXTPPropertyGridPaintManager object.
virtual | ~CXTPPropertyGridPaintManager ()
Destroys a CXTPPropertyGridPaintManager object, handles cleanup and deallocation.
virtual COLORREF | GetItemTextColor (CXTPPropertyGridItem *pItem, BOOL bValuePart)
Retrieves the text color of a specified item.
virtual COLORREF | GetItemBackColor (CXTPPropertyGridItem *pItem, BOOL bValuePart)
Retrieves the back color of a specified item.
virtual CFont * | GetItemFont (CXTPPropertyGridItem *pItem, BOOL bValuePart)
Retrieves the font of a specified item.
virtual void | FillPropertyGrid (CDC *pDC)
Draws the background of the property grid.
virtual void | FillPropertyGridView (CDC *pDC)
Draws the background of the view.
virtual void | DrawPropertyGridBorder (CDC *pDC, RECT &rcBorder, XTPPropertyGridWindow nWindow)
Draws grid borders.
virtual void | OnNcCalcSize (RECT &rc)
Adjusts the bounding rectangle of the grid.
virtual void | DrawItem (PDRAWITEMSTRUCT lpDrawItemStruct)
Draws a single item of the grid.
virtual void | DrawInplaceListItem (CDC *pDC, CXTPPropertyGridItemConstraint *pConstraint, CRect rc, BOOL bSelected)
Draws a specified constraint in the in-place list.
virtual void | AdjustItemValueRect (CXTPPropertyGridItem *pItem, CRect &rcValue)
Adjusts the rectangle of the value part of a specified item.
virtual void | AdjustItemCaptionRect (CXTPPropertyGridItem *pItem, CRect &rcCaption)
Adjusts the rectangle of the caption part of a specified item.
virtual void | MeasureItem (LPMEASUREITEMSTRUCT lpMeasureItemStruct)
Override this method and fill in a specified MEASUREITEMSTRUCT structure to inform Windows of the list-box dimensions.
virtual void | FillInplaceButton (CDC *pDC, CXTPPropertyGridInplaceButton *pButton)
Draws an in-place button for the grid.
int | HitTestVerbs (CDC *pDC, CRect rcVerbs, CPoint pt)
Determines the index of the verb within the verbs collection, if any, at a specified point.
CXTPPropertyGridItemMetrics * | GetItemMetrics () const
Gets the default item metrics.
CRect | GetSplitterRect (CRect rc, BOOL bIsHelp)
This method is called by the property grid to retrieve the size of either the help window splitter bar or the verbs splitter bar.
virtual int | GetItemsBorderHeight () const
Gets the height of the horizontal grid line between property grid items.
virtual void | SetItemsBorderHeight (int nHeight)
Sets the height of the horizontal grid line between property grid items.
virtual void | SetThinSplitter (BOOL bThinSplitter)
Sets draw a bottom single line for the splitter bar.
virtual void | DrawCategoryCaptionBackground (CDC *pDC, CXTPPropertyGridItem *pItem, CRect rc)
Draws the background for the bounding rectangle of a category caption.
virtual void | DrawItemValue (CDC *pDC, CXTPPropertyGridItem *pItem, CRect rcValue)
Draws the value part of a property grid item.
virtual void | DrawItemCaption (CDC *pDC, CXTPPropertyGridItem *pItem, CRect rcCaption)
Draws the caption part of a property grid item.
virtual void | DrawInplaceButtons (CDC *pDC, PDRAWITEMSTRUCT lpDrawItemStruct, CXTPPropertyGridItem *pItem, CRect rcValue)
Draws the in-place buttons of a property grid item.
virtual void | DrawCheckBox (CDC *pDC, CXTPPropertyGridItemBool *pButton)
Draws a checkbox for a CXTPPropertyGridItemOption item with with the CheckBox style.
virtual void | DrawCheckMark (CDC *pDC, CRect rc, BOOL bEnabled, BOOL bChecked)
Draws a check mark.
virtual void | DrawRadioMark (CDC *pDC, CRect rc, BOOL bEnabled, BOOL bChecked)
Draws a radio button for a CXTPPropertyGridItemOption item with the RadioButton (default) style.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Public Attributes

CXTPPaintManagerColor | m_clrGlyphExpand
Expand glyph color.
CXTPPaintManagerColor | m_clrGlyphBorder
Expand glyph border color.
CXTPPaintManagerColor | m_clrGlyphContract
Contract glyph color.
- Public Attributes inherited from CXTPPropertyGridPaintManager
XTPPropertyGridInplaceButtonsStyle | m_buttonsStyle
TRUE to use WinXP themes.
CXTPWinThemeWrapper * | m_themeTree
Themes for tree controls.
CXTPWinThemeWrapper * | m_themeButton
Themes for button controls.
CXTPWinThemeWrapper * | m_themeCombo
Themes for combo button.
BOOL | m_bTransparent
TRUE to draw background with parent color.
CXTPPaintManagerColor | m_clrFace
Face color.
CXTPPaintManagerColor | m_clrShadow
Shadow color.
CXTPPaintManagerColor | m_clrHighlight
Highlight color.
CXTPPaintManagerColor | m_clrHighlightText
Highlight text color.
CXTPPaintManagerColor | m_clrNonHighlightBack
Non-highlight background color.
CXTPPaintManagerColor | m_clrNonHighlightText
Non-highlight text color.
CXTPPaintManagerColor | m_clrCategorySeparator
Face color.
CXTPPaintManagerColor | m_clrSplitter
Splitter border color.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Attributes inherited from CXTPPropertyGridPaintManager
int | m_nItemsBorderHeight
Height, in pixels, of the horizontal border between property grid items.
int | m_nSplitterHeight
Height, in pixels, of the splitter bar.
int | m_nHelpHeight
Height, in pixels, of the description area (help pane).
int | m_nVerbsHeight
Height, in pixels, of the verbs box.
BOOL | m_bThinSplitter
TRUE to draw a single line for the splitter bar.
CXTPPropertyGrid * | m_pGrid
Parent grid class.
CXTPPropertyGridItemMetrics * | m_pMetrics
Default metrics of the item.

Detailed Description

CXTPPropertyGridOffice2013Theme is a CXTPPropertyGridPaintManager derived class.

It represents an Office 2013 style theme.

Constructor & Destructor Documentation

◆ CXTPPropertyGridOffice2013Theme()

CXTPPropertyGridOffice2013Theme ( CXTPPropertyGrid * pGrid )

Constructs a CXTPPropertyGridOffice2013Theme object.

Parameters
pGrid Pointer to a CXTPPropertyGrid object.

Member Function Documentation

◆ DrawExpandButton()

virtual void DrawExpandButton | ( | CDC & | dc,
 |  | CXTPPropertyGridItem * | pItem,
 |  | CRect | rcCaption )
 virtual

Draws an expand button for the grid.

Parameters
dc | Reference to a valid device context.
pItem | Pointer to a CXTPPropertyGridItem object.
rcCaption | Caption button rectangle.

Reimplemented from CXTPPropertyGridPaintManager.

◆ GetScrollBarTheme()

virtual XTPScrollBarTheme GetScrollBarTheme ( ) const
virtual

Gets the scrollbar theme identifier.

Returns
The scrollbar theme identifier; one of the values defined by the XTPScrollBarTheme enumeration.

Reimplemented from CXTPPropertyGridPaintManager.

The documentation for this class was generated from the following file:
  • XTPPropertyGridPaintManager.h


Toolkit Pro: CXTPPropertyGridOfficeXPTheme Class Reference

Public Member Functions | List of all members
CXTPPropertyGridOfficeXPTheme Class Reference

CXTPPropertyGridOfficeXPTheme is a CXTPPropertyGridPaintManager derived class. More...

Inheritance diagram for CXTPPropertyGridOfficeXPTheme:
[legend]

Public Member Functions

CXTPPropertyGridOfficeXPTheme (CXTPPropertyGrid *pGrid)
Constructs a CXTPPropertyGridOfficeXPTheme object.
void | RefreshMetrics ()
Refreshes the visual metrics of the property grid.
virtual XTPScrollBarTheme | GetScrollBarTheme () const
Gets the scrollbar theme identifier.
- Public Member Functions inherited from CXTPPropertyGridPaintManager
CXTPPropertyGridPaintManager (CXTPPropertyGrid *pGrid)
Constructs a CXTPPropertyGridPaintManager object.
virtual | ~CXTPPropertyGridPaintManager ()
Destroys a CXTPPropertyGridPaintManager object, handles cleanup and deallocation.
virtual COLORREF | GetItemTextColor (CXTPPropertyGridItem *pItem, BOOL bValuePart)
Retrieves the text color of a specified item.
virtual COLORREF | GetItemBackColor (CXTPPropertyGridItem *pItem, BOOL bValuePart)
Retrieves the back color of a specified item.
virtual CFont * | GetItemFont (CXTPPropertyGridItem *pItem, BOOL bValuePart)
Retrieves the font of a specified item.
virtual void | FillPropertyGrid (CDC *pDC)
Draws the background of the property grid.
virtual void | FillPropertyGridView (CDC *pDC)
Draws the background of the view.
virtual void | DrawPropertyGridBorder (CDC *pDC, RECT &rcBorder, XTPPropertyGridWindow nWindow)
Draws grid borders.
virtual void | OnNcCalcSize (RECT &rc)
Adjusts the bounding rectangle of the grid.
virtual void | DrawItem (PDRAWITEMSTRUCT lpDrawItemStruct)
Draws a single item of the grid.
virtual void | DrawInplaceListItem (CDC *pDC, CXTPPropertyGridItemConstraint *pConstraint, CRect rc, BOOL bSelected)
Draws a specified constraint in the in-place list.
virtual void | AdjustItemValueRect (CXTPPropertyGridItem *pItem, CRect &rcValue)
Adjusts the rectangle of the value part of a specified item.
virtual void | AdjustItemCaptionRect (CXTPPropertyGridItem *pItem, CRect &rcCaption)
Adjusts the rectangle of the caption part of a specified item.
virtual void | MeasureItem (LPMEASUREITEMSTRUCT lpMeasureItemStruct)
Override this method and fill in a specified MEASUREITEMSTRUCT structure to inform Windows of the list-box dimensions.
virtual void | FillInplaceButton (CDC *pDC, CXTPPropertyGridInplaceButton *pButton)
Draws an in-place button for the grid.
int | HitTestVerbs (CDC *pDC, CRect rcVerbs, CPoint pt)
Determines the index of the verb within the verbs collection, if any, at a specified point.
CXTPPropertyGridItemMetrics * | GetItemMetrics () const
Gets the default item metrics.
CRect | GetSplitterRect (CRect rc, BOOL bIsHelp)
This method is called by the property grid to retrieve the size of either the help window splitter bar or the verbs splitter bar.
virtual int | GetItemsBorderHeight () const
Gets the height of the horizontal grid line between property grid items.
virtual void | SetItemsBorderHeight (int nHeight)
Sets the height of the horizontal grid line between property grid items.
virtual void | SetThinSplitter (BOOL bThinSplitter)
Sets draw a bottom single line for the splitter bar.
virtual void | DrawExpandButton (CDC &dc, CXTPPropertyGridItem *pItem, CRect rcCaption)
Draws an expand button for the grid.
virtual void | DrawCategoryCaptionBackground (CDC *pDC, CXTPPropertyGridItem *pItem, CRect rc)
Draws the background for the bounding rectangle of a category caption.
virtual void | DrawItemValue (CDC *pDC, CXTPPropertyGridItem *pItem, CRect rcValue)
Draws the value part of a property grid item.
virtual void | DrawItemCaption (CDC *pDC, CXTPPropertyGridItem *pItem, CRect rcCaption)
Draws the caption part of a property grid item.
virtual void | DrawInplaceButtons (CDC *pDC, PDRAWITEMSTRUCT lpDrawItemStruct, CXTPPropertyGridItem *pItem, CRect rcValue)
Draws the in-place buttons of a property grid item.
virtual void | DrawCheckBox (CDC *pDC, CXTPPropertyGridItemBool *pButton)
Draws a checkbox for a CXTPPropertyGridItemOption item with with the CheckBox style.
virtual void | DrawCheckMark (CDC *pDC, CRect rc, BOOL bEnabled, BOOL bChecked)
Draws a check mark.
virtual void | DrawRadioMark (CDC *pDC, CRect rc, BOOL bEnabled, BOOL bChecked)
Draws a radio button for a CXTPPropertyGridItemOption item with the RadioButton (default) style.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPPropertyGridPaintManager
XTPPropertyGridInplaceButtonsStyle | m_buttonsStyle
TRUE to use WinXP themes.
CXTPWinThemeWrapper * | m_themeTree
Themes for tree controls.
CXTPWinThemeWrapper * | m_themeButton
Themes for button controls.
CXTPWinThemeWrapper * | m_themeCombo
Themes for combo button.
BOOL | m_bTransparent
TRUE to draw background with parent color.
CXTPPaintManagerColor | m_clrFace
Face color.
CXTPPaintManagerColor | m_clrShadow
Shadow color.
CXTPPaintManagerColor | m_clrHighlight
Highlight color.
CXTPPaintManagerColor | m_clrHighlightText
Highlight text color.
CXTPPaintManagerColor | m_clrNonHighlightBack
Non-highlight background color.
CXTPPaintManagerColor | m_clrNonHighlightText
Non-highlight text color.
CXTPPaintManagerColor | m_clrCategorySeparator
Face color.
CXTPPaintManagerColor | m_clrSplitter
Splitter border color.
- Protected Attributes inherited from CXTPPropertyGridPaintManager
int | m_nItemsBorderHeight
Height, in pixels, of the horizontal border between property grid items.
int | m_nSplitterHeight
Height, in pixels, of the splitter bar.
int | m_nHelpHeight
Height, in pixels, of the description area (help pane).
int | m_nVerbsHeight
Height, in pixels, of the verbs box.
BOOL | m_bThinSplitter
TRUE to draw a single line for the splitter bar.
CXTPPropertyGrid * | m_pGrid
Parent grid class.
CXTPPropertyGridItemMetrics * | m_pMetrics
Default metrics of the item.

Detailed Description

CXTPPropertyGridOfficeXPTheme is a CXTPPropertyGridPaintManager derived class.

It represents an Office XP style theme.

Constructor & Destructor Documentation

◆ CXTPPropertyGridOfficeXPTheme()

CXTPPropertyGridOfficeXPTheme ( CXTPPropertyGrid * pGrid )

Constructs a CXTPPropertyGridOfficeXPTheme object.

Parameters
pGrid Pointer to a CXTPPropertyGrid object.

Member Function Documentation

◆ GetScrollBarTheme()

virtual XTPScrollBarTheme GetScrollBarTheme ( ) const
virtual

Gets the scrollbar theme identifier.

Returns
The scrollbar theme identifier; one of the values defined by the XTPScrollBarTheme enumeration.

Reimplemented from CXTPPropertyGridPaintManager.

The documentation for this class was generated from the following file:
  • XTPPropertyGridPaintManager.h


Toolkit Pro: CXTPPropertyGridPaintManager Class Reference

Public Member Functions | Public Attributes | Protected Attributes | List of all members
CXTPPropertyGridPaintManager Class Reference

Standalone class used by CXTPPropertyGrid as the paint manager. More...

Inheritance diagram for CXTPPropertyGridPaintManager:
[legend]

Public Member Functions

CXTPPropertyGridPaintManager (CXTPPropertyGrid *pGrid)
Constructs a CXTPPropertyGridPaintManager object.
virtual | ~CXTPPropertyGridPaintManager ()
Destroys a CXTPPropertyGridPaintManager object, handles cleanup and deallocation.
virtual COLORREF | GetItemTextColor (CXTPPropertyGridItem *pItem, BOOL bValuePart)
Retrieves the text color of a specified item.
virtual COLORREF | GetItemBackColor (CXTPPropertyGridItem *pItem, BOOL bValuePart)
Retrieves the back color of a specified item.
virtual CFont * | GetItemFont (CXTPPropertyGridItem *pItem, BOOL bValuePart)
Retrieves the font of a specified item.
virtual void | FillPropertyGrid (CDC *pDC)
Draws the background of the property grid.
virtual void | FillPropertyGridView (CDC *pDC)
Draws the background of the view.
virtual void | DrawPropertyGridBorder (CDC *pDC, RECT &rcBorder, XTPPropertyGridWindow nWindow)
Draws grid borders.
virtual void | OnNcCalcSize (RECT &rc)
Adjusts the bounding rectangle of the grid.
virtual void | DrawItem (PDRAWITEMSTRUCT lpDrawItemStruct)
Draws a single item of the grid.
virtual void | DrawInplaceListItem (CDC *pDC, CXTPPropertyGridItemConstraint *pConstraint, CRect rc, BOOL bSelected)
Draws a specified constraint in the in-place list.
virtual void | AdjustItemValueRect (CXTPPropertyGridItem *pItem, CRect &rcValue)
Adjusts the rectangle of the value part of a specified item.
virtual void | AdjustItemCaptionRect (CXTPPropertyGridItem *pItem, CRect &rcCaption)
Adjusts the rectangle of the caption part of a specified item.
virtual void | MeasureItem (LPMEASUREITEMSTRUCT lpMeasureItemStruct)
Override this method and fill in a specified MEASUREITEMSTRUCT structure to inform Windows of the list-box dimensions.
virtual void | FillInplaceButton (CDC *pDC, CXTPPropertyGridInplaceButton *pButton)
Draws an in-place button for the grid.
virtual void | RefreshMetrics ()
Refreshes the visual metrics of the paint manager.
virtual XTPScrollBarTheme | GetScrollBarTheme () const
Gets the indentifier of the scrollbar theme.
int | HitTestVerbs (CDC *pDC, CRect rcVerbs, CPoint pt)
Determines the index of the verb within the verbs collection, if any, at a specified point.
CXTPPropertyGridItemMetrics * | GetItemMetrics () const
Gets the default item metrics.
CRect | GetSplitterRect (CRect rc, BOOL bIsHelp)
This method is called by the property grid to retrieve the size of either the help window splitter bar or the verbs splitter bar.
virtual int | GetItemsBorderHeight () const
Gets the height of the horizontal grid line between property grid items.
virtual void | SetItemsBorderHeight (int nHeight)
Sets the height of the horizontal grid line between property grid items.
virtual void | SetThinSplitter (BOOL bThinSplitter)
Sets draw a bottom single line for the splitter bar.
virtual void | DrawExpandButton (CDC &dc, CXTPPropertyGridItem *pItem, CRect rcCaption)
Draws an expand button for the grid.
virtual void | DrawCategoryCaptionBackground (CDC *pDC, CXTPPropertyGridItem *pItem, CRect rc)
Draws the background for the bounding rectangle of a category caption.
virtual void | DrawItemValue (CDC *pDC, CXTPPropertyGridItem *pItem, CRect rcValue)
Draws the value part of a property grid item.
virtual void | DrawItemCaption (CDC *pDC, CXTPPropertyGridItem *pItem, CRect rcCaption)
Draws the caption part of a property grid item.
virtual void | DrawInplaceButtons (CDC *pDC, PDRAWITEMSTRUCT lpDrawItemStruct, CXTPPropertyGridItem *pItem, CRect rcValue)
Draws the in-place buttons of a property grid item.
virtual void | DrawCheckBox (CDC *pDC, CXTPPropertyGridItemBool *pButton)
Draws a checkbox for a CXTPPropertyGridItemOption item with with the CheckBox style.
virtual void | DrawCheckMark (CDC *pDC, CRect rc, BOOL bEnabled, BOOL bChecked)
Draws a check mark.
virtual void | DrawRadioMark (CDC *pDC, CRect rc, BOOL bEnabled, BOOL bChecked)
Draws a radio button for a CXTPPropertyGridItemOption item with the RadioButton (default) style.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Public Attributes

XTPPropertyGridInplaceButtonsStyle | m_buttonsStyle
TRUE to use WinXP themes.
CXTPWinThemeWrapper * | m_themeTree
Themes for tree controls.
CXTPWinThemeWrapper * | m_themeButton
Themes for button controls.
CXTPWinThemeWrapper * | m_themeCombo
Themes for combo button.
BOOL | m_bTransparent
TRUE to draw background with parent color.
CXTPPaintManagerColor | m_clrFace
Face color.
CXTPPaintManagerColor | m_clrShadow
Shadow color.
CXTPPaintManagerColor | m_clrHighlight
Highlight color.
CXTPPaintManagerColor | m_clrHighlightText
Highlight text color.
CXTPPaintManagerColor | m_clrNonHighlightBack
Non-highlight background color.
CXTPPaintManagerColor | m_clrNonHighlightText
Non-highlight text color.
CXTPPaintManagerColor | m_clrCategorySeparator
Face color.
CXTPPaintManagerColor | m_clrSplitter
Splitter border color.

Protected Attributes

int | m_nItemsBorderHeight
Height, in pixels, of the horizontal border between property grid items.
int | m_nSplitterHeight
Height, in pixels, of the splitter bar.
int | m_nHelpHeight
Height, in pixels, of the description area (help pane).
int | m_nVerbsHeight
Height, in pixels, of the verbs box.
BOOL | m_bThinSplitter
TRUE to draw a single line for the splitter bar.
CXTPPropertyGrid * | m_pGrid
Parent grid class.
CXTPPropertyGridItemMetrics * | m_pMetrics
Default metrics of the item.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

Standalone class used by CXTPPropertyGrid as the paint manager.

Constructor & Destructor Documentation

◆ CXTPPropertyGridPaintManager()

CXTPPropertyGridPaintManager ( CXTPPropertyGrid * pGrid )

Constructs a CXTPPropertyGridPaintManager object.

Parameters
pGrid Pointer to a CXTPPropertyGrid object.

Member Function Documentation

◆ AdjustItemCaptionRect()

virtual void AdjustItemCaptionRect | ( | CXTPPropertyGridItem * | pItem,
 |  | CRect & | rcCaption )
 virtual

Adjusts the rectangle of the caption part of a specified item.

Parameters
pItem | Pointer to a property grid item.
rcCaption | Reference to the rectangle of the caption part of the specified item.

◆ AdjustItemValueRect()

virtual void AdjustItemValueRect | ( | CXTPPropertyGridItem * | pItem,
 |  | CRect & | rcValue )
 virtual

Adjusts the rectangle of the value part of a specified item.

Parameters
pItem | Pointer to a property grid item.
rcValue | Reference to the rectangle of the value part of the specified item.

◆ DrawCategoryCaptionBackground()

virtual void DrawCategoryCaptionBackground | ( | CDC * | pDC,
 |  | CXTPPropertyGridItem * | pItem,
 |  | CRect | rc )
 virtual

Draws the background for the bounding rectangle of a category caption.

Parameters
pDC | Pointer to a valid device context.
pItem | Pointer to a CXTPPropertyGridItem object.
rc | Bounding rectangle of the category caption.

Reimplemented in CXTPPropertyGridVisualStudio2005Theme.

◆ DrawCheckBox()

virtual void DrawCheckBox | ( | CDC * | pDC,
 |  | CXTPPropertyGridItemBool * | pButton )
 virtual

Draws a checkbox for a CXTPPropertyGridItemOption item with with the CheckBox style.

Parameters
pDC | Pointer to a valid device context.
pButton | Pointer to a CXTPPropertyGridItemBool object.

◆ DrawCheckMark()

virtual void DrawCheckMark | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | BOOL | bEnabled,
 |  | BOOL | bChecked )
 virtual

Draws a check mark.

Parameters
pDC | Pointer to a valid device context.
rc | Rectangle in logical units.
bEnabled | TRUE to set to enabled, FALSE to set to disabled.
bChecked | TRUE to set to checked, FALSE to set to unchecked.

Reimplemented in CXTPPropertyGridOffice2007Theme.

◆ DrawExpandButton()

virtual void DrawExpandButton | ( | CDC & | dc,
 |  | CXTPPropertyGridItem * | pItem,
 |  | CRect | rcCaption )
 virtual

Draws an expand button for the grid.

Parameters
dc | Reference to a valid device context.
pItem | Pointer to a CXTPPropertyGridItem object.
rcCaption | Caption button rectangle.

Reimplemented in CXTPPropertyGridNativeWindows10Theme, CXTPPropertyGridNativeWindows11Theme, CXTPPropertyGridOffice2007Theme, CXTPPropertyGridOffice2013Theme, CXTPPropertyGridVisualStudio2005Theme, CXTPPropertyGridVisualStudio2010Theme, CXTPPropertyGridVisualStudio2012Theme, CXTPPropertyGridVisualStudio2015Theme, CXTPPropertyGridVisualStudio2017Theme, CXTPPropertyGridVisualStudio2019Theme, and CXTPPropertyGridVisualStudio2022Theme.

◆ DrawInplaceButtons()

AFX_INLINE void DrawInplaceButtons | ( | CDC * | pDC,
 |  | PDRAWITEMSTRUCT | lpDrawItemStruct,
 |  | CXTPPropertyGridItem * | pItem,
 |  | CRect | rcValue )
 virtual

Draws the in-place buttons of a property grid item.

Parameters
pDC | Pointer to a valid device context.
lpDrawItemStruct | Long pointer to a DRAWITEMSTRUCT structure containing information about the item to be drawn and the type of drawing required.
pItem | Pointer to a CXTPPropertyGridItem object.
rcValue | Bounding rectangle of the value part.

◆ DrawInplaceListItem()

virtual void DrawInplaceListItem | ( | CDC * | pDC,
 |  | CXTPPropertyGridItemConstraint * | pConstraint,
 |  | CRect | rc,
 |  | BOOL | bSelected )
 virtual

Draws a specified constraint in the in-place list.

Parameters
pDC | Pointer to a valid device context.
pConstraint | Pointer to the constraint to draw.
rc | Bounding rectangle of the constraint.
bSelected | TRUE if the constraint is currently selected.

◆ DrawItem()

virtual void DrawItem ( PDRAWITEMSTRUCT lpDrawItemStruct )
virtual

Draws a single item of the grid.

Parameters
lpDrawItemStruct Long pointer to a DRAWITEMSTRUCT structure containing information about the type of drawing required.

Reimplemented in CXTPPropertyGridCoolTheme, CXTPPropertyGridDelphiTheme, and CXTPPropertyGridSimpleTheme.

◆ DrawItemCaption()

virtual void DrawItemCaption | ( | CDC * | pDC,
 |  | CXTPPropertyGridItem * | pItem,
 |  | CRect | rcCaption )
 virtual

Draws the caption part of a property grid item.

Parameters
pDC | Pointer to a valid device context.
pItem | Pointer to a CXTPPropertyGridItem object.
rcCaption | Bounding rectangle of the caption part.

◆ DrawItemValue()

virtual void DrawItemValue | ( | CDC * | pDC,
 |  | CXTPPropertyGridItem * | pItem,
 |  | CRect | rcValue )
 virtual

Draws the value part of a property grid item.

Parameters
pDC | Pointer to a valid device context.
pItem | Pointer to a CXTPPropertyGridItem object.
rcValue | Bounding rectangle of the value part.

◆ DrawPropertyGridBorder()

virtual void DrawPropertyGridBorder | ( | CDC * | pDC,
 |  | RECT & | rcBorder,
 |  | XTPPropertyGridWindow | nWindow )
 virtual

Draws grid borders.

Parameters
pDC | Pointer to a valid device context.
rcBorder | Reference to the size of the border to draw.
nWindow | XTPPropertyGridWindow enumeration value that specifies the window for which the border is to be drawn; possible values are as follows: 1 = Grid, 2 = Help, 3 = Verb.
See also
FillPropertyGridView

◆ DrawRadioMark()

virtual void DrawRadioMark | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | BOOL | bEnabled,
 |  | BOOL | bChecked )
 virtual

Draws a radio button for a CXTPPropertyGridItemOption item with the RadioButton (default) style.

Parameters
pDC | Pointer to a valid device context.
rc | Rectangle in logical units.
bEnabled | TRUE to set to enabled, FALSE to set to disabled.
bChecked | TRUE to set to checked, FALSE to set to unchecked.

Reimplemented in CXTPPropertyGridOffice2007Theme.

◆ FillInplaceButton()

virtual void FillInplaceButton | ( | CDC * | pDC,
 |  | CXTPPropertyGridInplaceButton * | pButton )
 virtual

Draws an in-place button for the grid.

Parameters
pDC | Pointer to a valid device context.
pButton | Pointer to a CXTPPropertyGridInplaceButton object.

Reimplemented in CXTPPropertyGridOffice2007Theme.

◆ FillPropertyGrid()

virtual void FillPropertyGrid ( CDC * pDC )
virtual

Draws the background of the property grid.

Parameters
pDC Pointer to a valid device context.

◆ FillPropertyGridView()

virtual void FillPropertyGridView ( CDC * pDC )
virtual

Draws the background of the view.

Parameters
pDC Pointer to a valid device context.

◆ GetItemBackColor()

virtual COLORREF GetItemBackColor | ( | CXTPPropertyGridItem * | pItem,
 |  | BOOL | bValuePart )
 virtual

Retrieves the back color of a specified item.

Parameters
pItem | Pointer to the item whose back color must be retrieved.
bValuePart | TRUE if the value part color is needed.
Returns
The back color of the specified item.

◆ GetItemFont()

virtual CFont * GetItemFont | ( | CXTPPropertyGridItem * | pItem,
 |  | BOOL | bValuePart )
 virtual

Retrieves the font of a specified item.

Parameters
pItem | Pointer to the item whose font must be retrieved.
bValuePart | TRUE if the value part font is needed.
Returns
A pointer to a CFont object containing the font of the specified item.

◆ GetItemMetrics()

AFX_INLINE CXTPPropertyGridItemMetrics * GetItemMetrics ( ) const

Gets the default item metrics.

Returns
A pointer to the default item metrics.

◆ GetItemsBorderHeight()

AFX_INLINE int GetItemsBorderHeight ( ) const
virtual

Gets the height of the horizontal grid line between property grid items.

Returns
The height, in pixels, of the horizontal grid line between property grid items.

◆ GetItemTextColor()

virtual COLORREF GetItemTextColor | ( | CXTPPropertyGridItem * | pItem,
 |  | BOOL | bValuePart )
 virtual

Retrieves the text color of a specified item.

Parameters
pItem | Pointer to the item whose text color must be retrieved.
bValuePart | TRUE if the value part color is needed.
Returns
The text color of the specified item.

◆ GetScrollBarTheme()

virtual XTPScrollBarTheme GetScrollBarTheme ( ) const
virtual

Gets the indentifier of the scrollbar theme.

Returns
The identifier of the scrollbar theme; one of the values defined by the XTPScrollBarTheme enumeration.

Reimplemented in CXTPPropertyGridCoolTheme, CXTPPropertyGridDelphiTheme, CXTPPropertyGridNativeWindows10Theme, CXTPPropertyGridNativeWindows11Theme, CXTPPropertyGridNativeXPTheme, CXTPPropertyGridOffice2003Theme, CXTPPropertyGridOffice2007Theme, CXTPPropertyGridOffice2013Theme, CXTPPropertyGridOfficeXPTheme, CXTPPropertyGridSimpleTheme, CXTPPropertyGridVisualStudio2005Theme, CXTPPropertyGridVisualStudio2010Theme, CXTPPropertyGridVisualStudio2012Theme, CXTPPropertyGridVisualStudio2015Theme, CXTPPropertyGridVisualStudio2017Theme, CXTPPropertyGridVisualStudio2019Theme, and CXTPPropertyGridVisualStudio2022Theme.

◆ GetSplitterRect()

CRect GetSplitterRect | ( | CRect | rc,
 |  | BOOL | bIsHelp )

This method is called by the property grid to retrieve the size of either the help window splitter bar or the verbs splitter bar.

Parameters
rc | Size of the property grid client area.
bIsHelp | TRUE to retrieve the height of the help window splitter bar, FALSE to retrieve the height of the verbs splitter bar.
Returns
If bIsHelp is set to TRUE, then the size of the help window splitter bar. if bIsHelp is set to FALSE, then the size of the verbs splitter bar.

◆ HitTestVerbs()

int HitTestVerbs | ( | CDC * | pDC,
 |  | CRect | rcVerbs,
 |  | CPoint | pt )

Determines the index of the verb within the verbs collection, if any, at a specified point.

Parameters
pDC | Reference to a valid device context.
rcVerbs | Bounding rectangle of all verbs.
pt | Point to be tested.
Returns
The index of the verb within the verbs collection, if any, otherwise a value of -1.

◆ MeasureItem()

virtual void MeasureItem ( LPMEASUREITEMSTRUCT lpMeasureItemStruct )
virtual

Override this method and fill in a specified MEASUREITEMSTRUCT structure to inform Windows of the list-box dimensions.

Parameters
lpMeasureItemStruct Long pointer to a MEASUREITEMSTRUCT structure.

◆ OnNcCalcSize()

virtual void OnNcCalcSize ( RECT & rc )
virtual

Adjusts the bounding rectangle of the grid.

Parameters
rc Reference to the bounding rectangle of the grid.

◆ SetItemsBorderHeight()

AFX_INLINE void SetItemsBorderHeight ( int nHeight )
virtual

Sets the height of the horizontal grid line between property grid items.

Parameters
nHeight Height, in pixels, to be set.

◆ SetThinSplitter()

AFX_INLINE void SetThinSplitter ( BOOL bThinSplitter )
virtual

Sets draw a bottom single line for the splitter bar.

Parameters
bThinSplitter TRUE to draw a single line for the splitter bar.
The documentation for this class was generated from the following file:
  • XTPPropertyGridPaintManager.h


Toolkit Pro: CXTPPropertyGridSimpleTheme Class Reference

Public Member Functions | List of all members
CXTPPropertyGridSimpleTheme Class Reference

CXTPPropertyGridSimpleTheme is a CXTPPropertyGridPaintManager derived class. More...

Inheritance diagram for CXTPPropertyGridSimpleTheme:
[legend]

Public Member Functions

CXTPPropertyGridSimpleTheme (CXTPPropertyGrid *pGrid)
Constructs a CXTPPropertyGridSimpleTheme object.
virtual void | DrawItem (PDRAWITEMSTRUCT lpDrawItemStruct)
Draws a single item for the grid.
void | RefreshMetrics ()
Refreshes the visual metrics of the property grid.
virtual XTPScrollBarTheme | GetScrollBarTheme () const
Gets the scrollbar theme identifier.
- Public Member Functions inherited from CXTPPropertyGridPaintManager
CXTPPropertyGridPaintManager (CXTPPropertyGrid *pGrid)
Constructs a CXTPPropertyGridPaintManager object.
virtual | ~CXTPPropertyGridPaintManager ()
Destroys a CXTPPropertyGridPaintManager object, handles cleanup and deallocation.
virtual COLORREF | GetItemTextColor (CXTPPropertyGridItem *pItem, BOOL bValuePart)
Retrieves the text color of a specified item.
virtual COLORREF | GetItemBackColor (CXTPPropertyGridItem *pItem, BOOL bValuePart)
Retrieves the back color of a specified item.
virtual CFont * | GetItemFont (CXTPPropertyGridItem *pItem, BOOL bValuePart)
Retrieves the font of a specified item.
virtual void | FillPropertyGrid (CDC *pDC)
Draws the background of the property grid.
virtual void | FillPropertyGridView (CDC *pDC)
Draws the background of the view.
virtual void | DrawPropertyGridBorder (CDC *pDC, RECT &rcBorder, XTPPropertyGridWindow nWindow)
Draws grid borders.
virtual void | OnNcCalcSize (RECT &rc)
Adjusts the bounding rectangle of the grid.
virtual void | DrawInplaceListItem (CDC *pDC, CXTPPropertyGridItemConstraint *pConstraint, CRect rc, BOOL bSelected)
Draws a specified constraint in the in-place list.
virtual void | AdjustItemValueRect (CXTPPropertyGridItem *pItem, CRect &rcValue)
Adjusts the rectangle of the value part of a specified item.
virtual void | AdjustItemCaptionRect (CXTPPropertyGridItem *pItem, CRect &rcCaption)
Adjusts the rectangle of the caption part of a specified item.
virtual void | MeasureItem (LPMEASUREITEMSTRUCT lpMeasureItemStruct)
Override this method and fill in a specified MEASUREITEMSTRUCT structure to inform Windows of the list-box dimensions.
virtual void | FillInplaceButton (CDC *pDC, CXTPPropertyGridInplaceButton *pButton)
Draws an in-place button for the grid.
int | HitTestVerbs (CDC *pDC, CRect rcVerbs, CPoint pt)
Determines the index of the verb within the verbs collection, if any, at a specified point.
CXTPPropertyGridItemMetrics * | GetItemMetrics () const
Gets the default item metrics.
CRect | GetSplitterRect (CRect rc, BOOL bIsHelp)
This method is called by the property grid to retrieve the size of either the help window splitter bar or the verbs splitter bar.
virtual int | GetItemsBorderHeight () const
Gets the height of the horizontal grid line between property grid items.
virtual void | SetItemsBorderHeight (int nHeight)
Sets the height of the horizontal grid line between property grid items.
virtual void | SetThinSplitter (BOOL bThinSplitter)
Sets draw a bottom single line for the splitter bar.
virtual void | DrawExpandButton (CDC &dc, CXTPPropertyGridItem *pItem, CRect rcCaption)
Draws an expand button for the grid.
virtual void | DrawCategoryCaptionBackground (CDC *pDC, CXTPPropertyGridItem *pItem, CRect rc)
Draws the background for the bounding rectangle of a category caption.
virtual void | DrawItemValue (CDC *pDC, CXTPPropertyGridItem *pItem, CRect rcValue)
Draws the value part of a property grid item.
virtual void | DrawItemCaption (CDC *pDC, CXTPPropertyGridItem *pItem, CRect rcCaption)
Draws the caption part of a property grid item.
virtual void | DrawInplaceButtons (CDC *pDC, PDRAWITEMSTRUCT lpDrawItemStruct, CXTPPropertyGridItem *pItem, CRect rcValue)
Draws the in-place buttons of a property grid item.
virtual void | DrawCheckBox (CDC *pDC, CXTPPropertyGridItemBool *pButton)
Draws a checkbox for a CXTPPropertyGridItemOption item with with the CheckBox style.
virtual void | DrawCheckMark (CDC *pDC, CRect rc, BOOL bEnabled, BOOL bChecked)
Draws a check mark.
virtual void | DrawRadioMark (CDC *pDC, CRect rc, BOOL bEnabled, BOOL bChecked)
Draws a radio button for a CXTPPropertyGridItemOption item with the RadioButton (default) style.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPPropertyGridPaintManager
XTPPropertyGridInplaceButtonsStyle | m_buttonsStyle
TRUE to use WinXP themes.
CXTPWinThemeWrapper * | m_themeTree
Themes for tree controls.
CXTPWinThemeWrapper * | m_themeButton
Themes for button controls.
CXTPWinThemeWrapper * | m_themeCombo
Themes for combo button.
BOOL | m_bTransparent
TRUE to draw background with parent color.
CXTPPaintManagerColor | m_clrFace
Face color.
CXTPPaintManagerColor | m_clrShadow
Shadow color.
CXTPPaintManagerColor | m_clrHighlight
Highlight color.
CXTPPaintManagerColor | m_clrHighlightText
Highlight text color.
CXTPPaintManagerColor | m_clrNonHighlightBack
Non-highlight background color.
CXTPPaintManagerColor | m_clrNonHighlightText
Non-highlight text color.
CXTPPaintManagerColor | m_clrCategorySeparator
Face color.
CXTPPaintManagerColor | m_clrSplitter
Splitter border color.
- Protected Attributes inherited from CXTPPropertyGridPaintManager
int | m_nItemsBorderHeight
Height, in pixels, of the horizontal border between property grid items.
int | m_nSplitterHeight
Height, in pixels, of the splitter bar.
int | m_nHelpHeight
Height, in pixels, of the description area (help pane).
int | m_nVerbsHeight
Height, in pixels, of the verbs box.
BOOL | m_bThinSplitter
TRUE to draw a single line for the splitter bar.
CXTPPropertyGrid * | m_pGrid
Parent grid class.
CXTPPropertyGridItemMetrics * | m_pMetrics
Default metrics of the item.

Detailed Description

CXTPPropertyGridSimpleTheme is a CXTPPropertyGridPaintManager derived class.

It represents a Simple style theme.

Constructor & Destructor Documentation

◆ CXTPPropertyGridSimpleTheme()

CXTPPropertyGridSimpleTheme ( CXTPPropertyGrid * pGrid )

Constructs a CXTPPropertyGridSimpleTheme object.

Parameters
pGrid Pointer to a CXTPPropertyGrid object.

Member Function Documentation

◆ DrawItem()

virtual void DrawItem ( PDRAWITEMSTRUCT lpDrawItemStruct )
virtual

Draws a single item for the grid.

Parameters
lpDrawItemStruct Long pointer to a DRAWITEMSTRUCT structure containing information about the type of drawing required.

Reimplemented from CXTPPropertyGridPaintManager.

◆ GetScrollBarTheme()

virtual XTPScrollBarTheme GetScrollBarTheme ( ) const
virtual

Gets the scrollbar theme identifier.

Returns
The scrollbar theme identifier; one of the values defined by the XTPScrollBarTheme enumeration.

Reimplemented from CXTPPropertyGridPaintManager.

The documentation for this class was generated from the following file:
  • XTPPropertyGridPaintManager.h


Toolkit Pro: CXTPPropertyGridToolBar Class Reference

Public Member Functions | List of all members
CXTPPropertyGridToolBar Class Reference

CXTPPropertyGridToolBar is a CToolBar derived class. More...

Public Member Functions

CXTPPropertyGridToolBar ()
Constructs a CXTPPropertyGridToolBar object.
~CXTPPropertyGridToolBar ()
Destroys a CXTPPropertyGridToolBar object, handles cleanup and deallocation.

Detailed Description

CXTPPropertyGridToolBar is a CToolBar derived class.

It is an internal class used by the property grid control.

The documentation for this class was generated from the following file:
  • XTPPropertyGridToolBar.h


Toolkit Pro: CXTPPropertyGridToolTip Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPPropertyGridToolTip Class Reference

CXTPPropertyGridToolTip is a CWnd derived class. More...

Public Member Functions

CXTPPropertyGridToolTip ()
Constructs a CXTPPropertyGridToolTip object.
void | Activate (BOOL bActive, CXTPPropertyGridItem *pItem, BOOL bValuePart)
Activates/destroys the tooltip control.
void | Create (CXTPPropertyGridView *pParentWnd)
Creates a tooltip control.

Protected Attributes

CXTPPropertyGridView * | m_pGrid
Parent window.
CXTPFont | m_xtpFont
Font used to display the tooltip.

Detailed Description

CXTPPropertyGridToolTip is a CWnd derived class.

It is an internal class used by the property grid control.

Member Function Documentation

◆ Activate()

void Activate | ( | BOOL | bActive,
 |  | CXTPPropertyGridItem * | pItem,
 |  | BOOL | bValuePart )

Activates/destroys the tooltip control.

Parameters
bActive | TRUE to activate the tooltip control, FALSE to destroy.
pItem | Pointer to the item whose tooltip must be shown.
bValuePart | TRUE to show the tooltip of the value part.

◆ Create()

void Create ( CXTPPropertyGridView * pParentWnd )

Creates a tooltip control.

Parameters
pParentWnd Pointer to a CXTPPropertyGridView object.
The documentation for this class was generated from the following file:
  • XTPPropertyGridToolTip.h


Toolkit Pro: CXTPPropertyGridUpdateContext Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPPropertyGridUpdateContext Class Reference

CXTPPropertyGridUpdateContext is a CXTPCmdTarget derived class used to save the state of the property grid such as the currently selected item, XTPPropertyGridSortOrder preference, and the expanding state of each item in the grid. More...

Inheritance diagram for CXTPPropertyGridUpdateContext:
[legend]

Public Member Functions

CXTPPropertyGridUpdateContext ()
Constructs a CXTPPropertyGridUpdateContext object.
BOOL IsEmpty () const
Determines if any items in the grid were expanded before CXTPPropertyGrid::BeginUpdate was called.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Attributes

CMap< UINT, UINT, BOOL, BOOL & > | m_mapState
Stores the expanded state of each item in the grid before CXTPPropertyGrid::BeginUpdate.
UINT | m_nSelected
Stores the ID of the currently selected item before CXTPPropertyGrid::BeginUpdate.
UINT | m_nTopIndex
Stores the index of the top-most visible item in the property grid.
XTPPropertyGridSortOrder | m_propertySort
Stores the currently used sort method of the grid before CXTPPropertyGrid::BeginUpdate.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

CXTPPropertyGridUpdateContext is a CXTPCmdTarget derived class used to save the state of the property grid such as the currently selected item, XTPPropertyGridSortOrder preference, and the expanding state of each item in the grid.

The property grid state information is stored in the CXTPPropertyGridUpdateContext object when CXTPPropertyGrid::BeginUpdate is called. After CXTPPropertyGrid::EndUpdate is called, the expanding state of each item, selected item, and sort preference will be restored.

Each time you add a new item or category to the grid, the state of the grid is updated and the grid is redrawn.

If you want to delete all items in the grid and then add a lot of new items, then it will be quite slow. To do this, you would call BeginUpdate, then delete all the items. The property grid will be locked until you call EndUpdate.

It might be useful to call BeginWaitCursor to indicate that the grid is "busy" updating.

See also
CXTPPropertyGrid::BeginUpdate, CXTPPropertyGrid::EndUpdate

Member Function Documentation

◆ IsEmpty()

AFX_INLINE BOOL IsEmpty ( ) const

Determines if any items in the grid were expanded before CXTPPropertyGrid::BeginUpdate was called.

Only items with children can be expanded.

Returns
TRUE if no items were expanded before BeginUpdate, FALSE if at least one item was expanded.
The documentation for this class was generated from the following file:
  • XTPPropertyGrid.h


Toolkit Pro: CXTPPropertyGridVerb Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPPropertyGridVerb Class Reference

CXTPPropertyGridVerb is used to create a verb link similar to what is seen in Visual Studio .NET. More...

Inheritance diagram for CXTPPropertyGridVerb:
[legend]

Public Member Functions

CXTPPropertyGridVerb ()
Constructs a CXTPPropertyGridVerb object.
CString | GetCaption () const
Gets the text caption of this verb link.
int | GetID () const
Gets the ID of this verb link.
int | GetIndex () const
Gets the index of this verb link within the collection of verb links.
BOOL | IsFocused () const
Determines if this verb link is focused.
void | SetPart (CRect rc)
This method is used internally by PaintManager and PropertyGrid to set the bounding rectangle for verbs.
CRect | GetPart () const
This method is used internally by PaintManager and PropertyGrid to get the bounding rectangle of verbs.
CPoint | GetClickPoint () const
Gets the last position that the user clicked.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Attributes

CString | m_strCaption
Text caption of this verb link.
int | m_nID
ID assigned to this verb link.
int | m_nIndex
Index of this verb link in the collection of verbs.
CRect | m_rcPart
Bounding rectangle of the verb.
CPoint | m_ptClick
The last position that the user clicked.
CXTPPropertyGridVerbs * | m_pVerbs
Collection of verb links.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

CXTPPropertyGridVerb is used to create a verb link similar to what is seen in Visual Studio .NET.

For example, when the DataGrid control is selected at design time in VS .NET, an AutoFormat link button appears in the Properties window just below the property grid and above the help panel. Verbs will be displayed in a separate panel just below the property grid. Verbs are links that can be used to perform actions in your application. When a verb is clicked, CXTPPropertyGrid::OnVerbClick is called by the framework. If both the verb panel and help panel are visible at the same time, then the verb panel is displayed above the help panel.

See also
CXTPPropertyGrid::GetVerbs, CXTPPropertyGridVerbs

Member Function Documentation

◆ GetCaption()

AFX_INLINE CString GetCaption ( ) const

Gets the text caption of this verb link.

Returns
The text caption of this verb link.

◆ GetClickPoint()

AFX_INLINE CPoint GetClickPoint ( ) const

Gets the last position that the user clicked.

Returns
The last position that the user clicked. If it was "clicked" by pressing the Enter/Return key while a verb has focus, then the bottom left position of the "clicked" verb is returned.

◆ GetID()

AFX_INLINE int GetID ( ) const

Gets the ID of this verb link.

Returns
The ID of this verb link.

◆ GetIndex()

AFX_INLINE int GetIndex ( ) const

Gets the index of this verb link within the collection of verb links.

Returns
The index of this verb link within the collection of verb links.

◆ GetPart()

AFX_INLINE CRect GetPart ( ) const

This method is used internally by PaintManager and PropertyGrid to get the bounding rectangle of verbs.

You do not need to call this member. this member.

Returns
The bounding rectangle of the verb.

◆ IsFocused()

AFX_INLINE BOOL IsFocused ( ) const

Determines if this verb link is focused.

If a verb link is focused, then a focus rectangle is placed around the text caption of the verb link.

Returns
TRUE if this verb link is focused, FALSE if this verb link is not focused.

◆ SetPart()

AFX_INLINE void SetPart ( CRect rc )

This method is used internally by PaintManager and PropertyGrid to set the bounding rectangle for verbs.

You do not need to call this member.

Parameters
rc Bounding rectangle of the verb.
The documentation for this class was generated from the following file:
  • XTPPropertyGrid.h


Toolkit Pro: CXTPPropertyGridVerbs Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPPropertyGridVerbs Class Reference

A collection of CXTPPropertyGridVerb objects that are displayed in the verb panel. More...

Inheritance diagram for CXTPPropertyGridVerbs:
[legend]

Public Member Functions

CXTPPropertyGridVerbs ()
Constructs a CXTPPropertyGridVerbs object.
~CXTPPropertyGridVerbs ()
Destroys a CXTPPropertyGridVerbs object, handles cleanup and deallocation.
BOOL | IsEmpty () const
Determines if any verbs have been added to the collection of verbs.
void | RemoveAll ()
Removes all verbs from the collection of verbs.
CXTPPropertyGridVerb * | GetAt (int nIndex) const
Retrieves the verb at a specified index within the collection of verbs.
int | GetCount () const
Gets the total number of verbs in the collection of verbs.
void | Add (LPCTSTR lpszCaption, UINT nID)
Adds a verb link to the verb panel.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Attributes

CArray< CXTPPropertyGridVerb *, CXTPPropertyGridVerb * > | m_arrVerbs
Collection of verb links.
CXTPPropertyGrid * | m_pGrid
Pointer to the property grid that the verbs are drawn on.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

A collection of CXTPPropertyGridVerb objects that are displayed in the verb panel.

See CXTPPropertyGridVerb for a description of verbs.

See also
CXTPPropertyGridVerb

Member Function Documentation

◆ Add()

void Add | ( | LPCTSTR | lpszCaption,
 |  | UINT | nID )

Adds a verb link to the verb panel.

Parameters
lpszCaption | Text caption of the verb link.
nID | ID to assign to the verb link.

Call this method to add a CXTPPropertyGridVerb object to the collection of verbs. Verbs are displayed in the verb panel located just below the property grid and above the help panel.

◆ GetAt()

AFX_INLINE CXTPPropertyGridVerb * GetAt ( int nIndex ) const

Retrieves the verb at a specified index within the collection of verbs.

Parameters
nIndex Index of the verb to retrieve.
Returns
A pointer to the verb at the specified index within the collection of verbs.

◆ GetCount()

int GetCount ( ) const

Gets the total number of verbs in the collection of verbs.

Returns
The total number of verbs in the collection of verbs.

◆ IsEmpty()

AFX_INLINE BOOL IsEmpty ( ) const

Determines if any verbs have been added to the collection of verbs.

Returns
TRUE if there are no verbs in the collection, FALSE if there is at least one verb in the collection.
The documentation for this class was generated from the following file:
  • XTPPropertyGrid.h


Toolkit Pro: CXTPPropertyGridView Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPPropertyGridView Class Reference

CXTPPropertyGridView is a CListBox derived class. More...

Public Member Functions

CXTPPropertyGridView ()
Constructs a CXTPPropertyGridView object.
virtual | ~CXTPPropertyGridView ()
Destroys a CXTPPropertyGridView object, handles cleanup and deallocation.
int | GetDividerPos () const
Gets the position of the divider.
void | SetDividerPos (int nDivider)
Sets the position for the divider.
void | LockDivider ()
Disables auto-calculation for the position of the divider.
CXTPPropertyGridItem * | ItemFromPoint (CPoint point) const
Determines which item, if any, is located at a specified point.
void | Refresh ()
Refreshes the items in the list.
void | ResetContent ()
Removes all items from the list.
CXTPPropertyGridItem * | GetItem (int nIndex) const
Retrieves the item at a specified index in the list.
CXTPPropertyGridItem * | AddCategory (LPCTSTR strCaption, CXTPPropertyGridItem *pCategory=NULL)
Adds a new category to the property grid control.
CXTPPropertyGridItem * | InsertCategory (int nIndex, LPCTSTR strCaption, CXTPPropertyGridItem *pCategory=NULL)
Inserts a new category to the property grid control.
CXTPPropertyGridPaintManager * | GetPaintManager () const
Gets the paint manager associated with the property grid (i.e.
CXTPImageManager * | GetImageManager () const
Gets the image manager associated with the property grid (i.e.
LRESULT | SendNotifyMessage (WPARAM wParam=0, LPARAM lParam=0)
Sends a specified message to the owner window.
CXTPPropertyGrid * | GetPropertyGrid () const
Gets the parent property grid.
void | FocusInplaceButton (CXTPPropertyGridInplaceButton *pButton)
Moves focus to a specified in-place button.

Protected Member Functions

virtual void ShowToolTip (CPoint pt)
Shows the tooltip of the item located at the mouse position.

Protected Attributes

CXTPPropertyGrid * | m_pGrid
Parent CXTPPropertyGrid class.
BOOL | m_bTracking
TRUE if the grid in tracking mode.
CRect | m_rcToolTip
Position of the tooltip.
double | m_dDivider
Divider position.
BOOL | m_bAutoDivider
TRUE to auto-calculate the position of the divider.
HCURSOR | m_hCursor
Handle of the cursor.
CString | m_strTipText
Tooltip text.
XTPPropertyGridSortOrder | m_properetySort
Current sort order.
CXTPPropertyGridItem * | m_pSelected
Current selected item.
CXTPPropertyGridItems * | m_pCategories
Collection of the categories.
CXTPPropertyGridToolTip | m_wndTip
Tooltip control.
int | m_nLockUpdate
TRUE to lock update.
UINT | m_nItemHeight
Default height of the item.
BOOL | m_bVariableSplitterPos
TRUE to allow the user to resize the splitter with the mouse.
CXTPPropertyGridInplaceButton * | m_pFocusedButton
Currently focused button.
CXTPPropertyGridInplaceButton * | m_pHotButton
Currently highlighted button.

Detailed Description

CXTPPropertyGridView is a CListBox derived class.

It is an internal class used by the property grid control.

Member Function Documentation

◆ AddCategory()

CXTPPropertyGridItem * AddCategory | ( | LPCTSTR | strCaption,
 |  | CXTPPropertyGridItem * | pCategory = NULL )

Adds a new category to the property grid control.

Parameters
strCaption | Name of the category to be added.
pCategory | Allows for custom classses to be categories. If it is NULL, then the property grid creates a default CXTPPropertyGridItem as a category. If it is not NULL, then the specified item will be used.
Returns
A pointer to the CXTPPropertyGridItem object of the newly added category.

◆ FocusInplaceButton()

void FocusInplaceButton ( CXTPPropertyGridInplaceButton * pButton )

Moves focus to a specified in-place button.

Parameters
pButton Pointer to a CXTPPropertyGridInplaceButton object.

◆ GetDividerPos()

int GetDividerPos ( ) const

Gets the position of the divider.

Returns
The position of the divider.

◆ GetImageManager()

CXTPImageManager * GetImageManager ( ) const

Gets the image manager associated with the property grid (i.e.

the image manager that stores images in the property grid).

Returns
A pointer to the image manager associated with the property grid.

◆ GetItem()

CXTPPropertyGridItem * GetItem ( int nIndex ) const

Retrieves the item at a specified index in the list.

Parameters
nIndex Zero-based index of the item to retrieve.
Returns
A pointer to the item at the specified index in the list.

◆ GetPaintManager()

CXTPPropertyGridPaintManager * GetPaintManager ( ) const

Gets the paint manager associated with the property grid (i.e.

the paint manager used to draw the property grid control window).

Returns
A pointer to the paint manager associated with the property grid.

◆ GetPropertyGrid()

AFX_INLINE CXTPPropertyGrid * GetPropertyGrid ( ) const

Gets the parent property grid.

Returns
A pointer to the parent property grid.

◆ InsertCategory()

CXTPPropertyGridItem * InsertCategory | ( | int | nIndex,
 |  | LPCTSTR | strCaption,
 |  | CXTPPropertyGridItem * | pCategory = NULL )

Inserts a new category to the property grid control.

Parameters
strCaption | Name of the category to be inserted.
nIndex | Index of the category to be inserted.
pCategory | Allows for custom classses to be categories. If it is NULL, then the property grid creates a default CXTPPropertyGridItem as a category. If it is not NULL, then the specified item will be used.
Returns
A pointer to the CXTPPropertyGridItem object of the newly inserted category.

◆ ItemFromPoint()

CXTPPropertyGridItem * ItemFromPoint ( CPoint point ) const

Determines which item, if any, is located at a specified point.

Parameters
point Point to be tested.
Returns
A pointer to the CXTPPropertyGridItem object at the specified point, if any, otherwise NULL.

◆ SendNotifyMessage()

LRESULT SendNotifyMessage | ( | WPARAM | wParam = 0,
 |  | LPARAM | lParam = 0 )

Sends a specified message to the owner window.

Parameters
wParam | Specifies additional message-dependent information.
lParam | Specifies additional message-dependent information.
Returns
The result of the message processing; this value depends on the message sent.

◆ SetDividerPos()

void SetDividerPos ( int nDivider )

Sets the position for the divider.

Parameters
nDivider Position for the divider.

◆ ShowToolTip()

virtual void ShowToolTip ( CPoint pt )
protectedvirtual

Shows the tooltip of the item located at the mouse position.

Parameters
pt Mouse position.
The documentation for this class was generated from the following file:
  • XTPPropertyGridView.h


Toolkit Pro: CXTPPropertyGridVisualStudio2005Theme Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPPropertyGridVisualStudio2005Theme Class Reference

CXTPPropertyGridVisualStudio2005Theme is a CXTPPropertyGridPaintManager derived class. More...

Inheritance diagram for CXTPPropertyGridVisualStudio2005Theme:
[legend]

Public Member Functions

CXTPPropertyGridVisualStudio2005Theme (CXTPPropertyGrid *pGrid)
Constructs a CXTPPropertyGridVisualStudio2005Theme object.
- Public Member Functions inherited from CXTPPropertyGridPaintManager
CXTPPropertyGridPaintManager (CXTPPropertyGrid *pGrid)
Constructs a CXTPPropertyGridPaintManager object.
virtual | ~CXTPPropertyGridPaintManager ()
Destroys a CXTPPropertyGridPaintManager object, handles cleanup and deallocation.
virtual COLORREF | GetItemTextColor (CXTPPropertyGridItem *pItem, BOOL bValuePart)
Retrieves the text color of a specified item.
virtual COLORREF | GetItemBackColor (CXTPPropertyGridItem *pItem, BOOL bValuePart)
Retrieves the back color of a specified item.
virtual CFont * | GetItemFont (CXTPPropertyGridItem *pItem, BOOL bValuePart)
Retrieves the font of a specified item.
virtual void | FillPropertyGrid (CDC *pDC)
Draws the background of the property grid.
virtual void | FillPropertyGridView (CDC *pDC)
Draws the background of the view.
virtual void | DrawPropertyGridBorder (CDC *pDC, RECT &rcBorder, XTPPropertyGridWindow nWindow)
Draws grid borders.
virtual void | OnNcCalcSize (RECT &rc)
Adjusts the bounding rectangle of the grid.
virtual void | DrawItem (PDRAWITEMSTRUCT lpDrawItemStruct)
Draws a single item of the grid.
virtual void | DrawInplaceListItem (CDC *pDC, CXTPPropertyGridItemConstraint *pConstraint, CRect rc, BOOL bSelected)
Draws a specified constraint in the in-place list.
virtual void | AdjustItemValueRect (CXTPPropertyGridItem *pItem, CRect &rcValue)
Adjusts the rectangle of the value part of a specified item.
virtual void | AdjustItemCaptionRect (CXTPPropertyGridItem *pItem, CRect &rcCaption)
Adjusts the rectangle of the caption part of a specified item.
virtual void | MeasureItem (LPMEASUREITEMSTRUCT lpMeasureItemStruct)
Override this method and fill in a specified MEASUREITEMSTRUCT structure to inform Windows of the list-box dimensions.
virtual void | FillInplaceButton (CDC *pDC, CXTPPropertyGridInplaceButton *pButton)
Draws an in-place button for the grid.
int | HitTestVerbs (CDC *pDC, CRect rcVerbs, CPoint pt)
Determines the index of the verb within the verbs collection, if any, at a specified point.
CXTPPropertyGridItemMetrics * | GetItemMetrics () const
Gets the default item metrics.
CRect | GetSplitterRect (CRect rc, BOOL bIsHelp)
This method is called by the property grid to retrieve the size of either the help window splitter bar or the verbs splitter bar.
virtual int | GetItemsBorderHeight () const
Gets the height of the horizontal grid line between property grid items.
virtual void | SetItemsBorderHeight (int nHeight)
Sets the height of the horizontal grid line between property grid items.
virtual void | SetThinSplitter (BOOL bThinSplitter)
Sets draw a bottom single line for the splitter bar.
virtual void | DrawItemValue (CDC *pDC, CXTPPropertyGridItem *pItem, CRect rcValue)
Draws the value part of a property grid item.
virtual void | DrawItemCaption (CDC *pDC, CXTPPropertyGridItem *pItem, CRect rcCaption)
Draws the caption part of a property grid item.
virtual void | DrawInplaceButtons (CDC *pDC, PDRAWITEMSTRUCT lpDrawItemStruct, CXTPPropertyGridItem *pItem, CRect rcValue)
Draws the in-place buttons of a property grid item.
virtual void | DrawCheckBox (CDC *pDC, CXTPPropertyGridItemBool *pButton)
Draws a checkbox for a CXTPPropertyGridItemOption item with with the CheckBox style.
virtual void | DrawCheckMark (CDC *pDC, CRect rc, BOOL bEnabled, BOOL bChecked)
Draws a check mark.
virtual void | DrawRadioMark (CDC *pDC, CRect rc, BOOL bEnabled, BOOL bChecked)
Draws a radio button for a CXTPPropertyGridItemOption item with the RadioButton (default) style.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

void | DrawCategoryCaptionBackground (CDC *pDC, CXTPPropertyGridItem *pItem, CRect rc)
Draws the background for the bounding rectangle of a category caption.
void | RefreshMetrics ()
Refreshes the visual metrics of the property grid.
void | DrawExpandButton (CDC &dc, CXTPPropertyGridItem *pItem, CRect rcCaption)
Draws an expand button for the grid.
virtual XTPScrollBarTheme | GetScrollBarTheme () const
Gets the scrollbar theme identifier.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPPropertyGridPaintManager
XTPPropertyGridInplaceButtonsStyle | m_buttonsStyle
TRUE to use WinXP themes.
CXTPWinThemeWrapper * | m_themeTree
Themes for tree controls.
CXTPWinThemeWrapper * | m_themeButton
Themes for button controls.
CXTPWinThemeWrapper * | m_themeCombo
Themes for combo button.
BOOL | m_bTransparent
TRUE to draw background with parent color.
CXTPPaintManagerColor | m_clrFace
Face color.
CXTPPaintManagerColor | m_clrShadow
Shadow color.
CXTPPaintManagerColor | m_clrHighlight
Highlight color.
CXTPPaintManagerColor | m_clrHighlightText
Highlight text color.
CXTPPaintManagerColor | m_clrNonHighlightBack
Non-highlight background color.
CXTPPaintManagerColor | m_clrNonHighlightText
Non-highlight text color.
CXTPPaintManagerColor | m_clrCategorySeparator
Face color.
CXTPPaintManagerColor | m_clrSplitter
Splitter border color.
- Protected Attributes inherited from CXTPPropertyGridPaintManager
int | m_nItemsBorderHeight
Height, in pixels, of the horizontal border between property grid items.
int | m_nSplitterHeight
Height, in pixels, of the splitter bar.
int | m_nHelpHeight
Height, in pixels, of the description area (help pane).
int | m_nVerbsHeight
Height, in pixels, of the verbs box.
BOOL | m_bThinSplitter
TRUE to draw a single line for the splitter bar.
CXTPPropertyGrid * | m_pGrid
Parent grid class.
CXTPPropertyGridItemMetrics * | m_pMetrics
Default metrics of the item.

Detailed Description

CXTPPropertyGridVisualStudio2005Theme is a CXTPPropertyGridPaintManager derived class.

It represents a Visual Studio 2005 style theme.

Constructor & Destructor Documentation

◆ CXTPPropertyGridVisualStudio2005Theme()

CXTPPropertyGridVisualStudio2005Theme ( CXTPPropertyGrid * pGrid )

Constructs a CXTPPropertyGridVisualStudio2005Theme object.

Parameters
pGrid Pointer to a CXTPPropertyGrid object.

Member Function Documentation

◆ DrawCategoryCaptionBackground()

void DrawCategoryCaptionBackground | ( | CDC * | pDC,
 |  | CXTPPropertyGridItem * | pItem,
 |  | CRect | rc )
 protectedvirtual

Draws the background for the bounding rectangle of a category caption.

Parameters
pDC | Pointer to a valid device context.
pItem | Pointer to a CXTPPropertyGridItem object.
rc | Bounding rectangle of the category caption.

Reimplemented from CXTPPropertyGridPaintManager.

◆ DrawExpandButton()

void DrawExpandButton | ( | CDC & | dc,
 |  | CXTPPropertyGridItem * | pItem,
 |  | CRect | rcCaption )
 protectedvirtual

Draws an expand button for the grid.

Parameters
dc | Reference to a valid device context.
pItem | Pointer to a CXTPPropertyGridItem object.
rcCaption | Caption button rectangle.

Reimplemented from CXTPPropertyGridPaintManager.

◆ GetScrollBarTheme()

virtual XTPScrollBarTheme GetScrollBarTheme ( ) const
protectedvirtual

Gets the scrollbar theme identifier.

Returns
The scrollbar theme identifier; one of the values defined by the XTPScrollBarTheme enumeration.

Reimplemented from CXTPPropertyGridPaintManager.

The documentation for this class was generated from the following file:
  • XTPPropertyGridPaintManager.h


Toolkit Pro: CXTPPropertyGridVisualStudio2010Theme Class Reference

Public Member Functions | List of all members
CXTPPropertyGridVisualStudio2010Theme Class Reference

CXTPPropertyGridVisualStudio2010Theme is a CXTPPropertyGridPaintManager derived class. More...

Inheritance diagram for CXTPPropertyGridVisualStudio2010Theme:
[legend]

Public Member Functions

CXTPPropertyGridVisualStudio2010Theme (CXTPPropertyGrid *pGrid)
Constructs a CXTPPropertyGridVisualStudio2010Theme object.
~CXTPPropertyGridVisualStudio2010Theme ()
Destroys a CXTPPropertyGridVisualStudio2010Theme object, handles cleanup and deallocation.
virtual void | DrawExpandButton (CDC &dc, CXTPPropertyGridItem *pItem, CRect rcCaption)
Draws an expand button for the grid.
virtual void | RefreshMetrics ()
Refreshes the visual metrics of the property grid.
virtual XTPScrollBarTheme | GetScrollBarTheme () const
Gets the scrollbar theme identifier.
- Public Member Functions inherited from CXTPPropertyGridPaintManager
CXTPPropertyGridPaintManager (CXTPPropertyGrid *pGrid)
Constructs a CXTPPropertyGridPaintManager object.
virtual | ~CXTPPropertyGridPaintManager ()
Destroys a CXTPPropertyGridPaintManager object, handles cleanup and deallocation.
virtual COLORREF | GetItemTextColor (CXTPPropertyGridItem *pItem, BOOL bValuePart)
Retrieves the text color of a specified item.
virtual COLORREF | GetItemBackColor (CXTPPropertyGridItem *pItem, BOOL bValuePart)
Retrieves the back color of a specified item.
virtual CFont * | GetItemFont (CXTPPropertyGridItem *pItem, BOOL bValuePart)
Retrieves the font of a specified item.
virtual void | FillPropertyGrid (CDC *pDC)
Draws the background of the property grid.
virtual void | FillPropertyGridView (CDC *pDC)
Draws the background of the view.
virtual void | DrawPropertyGridBorder (CDC *pDC, RECT &rcBorder, XTPPropertyGridWindow nWindow)
Draws grid borders.
virtual void | OnNcCalcSize (RECT &rc)
Adjusts the bounding rectangle of the grid.
virtual void | DrawItem (PDRAWITEMSTRUCT lpDrawItemStruct)
Draws a single item of the grid.
virtual void | DrawInplaceListItem (CDC *pDC, CXTPPropertyGridItemConstraint *pConstraint, CRect rc, BOOL bSelected)
Draws a specified constraint in the in-place list.
virtual void | AdjustItemValueRect (CXTPPropertyGridItem *pItem, CRect &rcValue)
Adjusts the rectangle of the value part of a specified item.
virtual void | AdjustItemCaptionRect (CXTPPropertyGridItem *pItem, CRect &rcCaption)
Adjusts the rectangle of the caption part of a specified item.
virtual void | MeasureItem (LPMEASUREITEMSTRUCT lpMeasureItemStruct)
Override this method and fill in a specified MEASUREITEMSTRUCT structure to inform Windows of the list-box dimensions.
virtual void | FillInplaceButton (CDC *pDC, CXTPPropertyGridInplaceButton *pButton)
Draws an in-place button for the grid.
int | HitTestVerbs (CDC *pDC, CRect rcVerbs, CPoint pt)
Determines the index of the verb within the verbs collection, if any, at a specified point.
CXTPPropertyGridItemMetrics * | GetItemMetrics () const
Gets the default item metrics.
CRect | GetSplitterRect (CRect rc, BOOL bIsHelp)
This method is called by the property grid to retrieve the size of either the help window splitter bar or the verbs splitter bar.
virtual int | GetItemsBorderHeight () const
Gets the height of the horizontal grid line between property grid items.
virtual void | SetItemsBorderHeight (int nHeight)
Sets the height of the horizontal grid line between property grid items.
virtual void | SetThinSplitter (BOOL bThinSplitter)
Sets draw a bottom single line for the splitter bar.
virtual void | DrawCategoryCaptionBackground (CDC *pDC, CXTPPropertyGridItem *pItem, CRect rc)
Draws the background for the bounding rectangle of a category caption.
virtual void | DrawItemValue (CDC *pDC, CXTPPropertyGridItem *pItem, CRect rcValue)
Draws the value part of a property grid item.
virtual void | DrawItemCaption (CDC *pDC, CXTPPropertyGridItem *pItem, CRect rcCaption)
Draws the caption part of a property grid item.
virtual void | DrawInplaceButtons (CDC *pDC, PDRAWITEMSTRUCT lpDrawItemStruct, CXTPPropertyGridItem *pItem, CRect rcValue)
Draws the in-place buttons of a property grid item.
virtual void | DrawCheckBox (CDC *pDC, CXTPPropertyGridItemBool *pButton)
Draws a checkbox for a CXTPPropertyGridItemOption item with with the CheckBox style.
virtual void | DrawCheckMark (CDC *pDC, CRect rc, BOOL bEnabled, BOOL bChecked)
Draws a check mark.
virtual void | DrawRadioMark (CDC *pDC, CRect rc, BOOL bEnabled, BOOL bChecked)
Draws a radio button for a CXTPPropertyGridItemOption item with the RadioButton (default) style.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPPropertyGridPaintManager
XTPPropertyGridInplaceButtonsStyle | m_buttonsStyle
TRUE to use WinXP themes.
CXTPWinThemeWrapper * | m_themeTree
Themes for tree controls.
CXTPWinThemeWrapper * | m_themeButton
Themes for button controls.
CXTPWinThemeWrapper * | m_themeCombo
Themes for combo button.
BOOL | m_bTransparent
TRUE to draw background with parent color.
CXTPPaintManagerColor | m_clrFace
Face color.
CXTPPaintManagerColor | m_clrShadow
Shadow color.
CXTPPaintManagerColor | m_clrHighlight
Highlight color.
CXTPPaintManagerColor | m_clrHighlightText
Highlight text color.
CXTPPaintManagerColor | m_clrNonHighlightBack
Non-highlight background color.
CXTPPaintManagerColor | m_clrNonHighlightText
Non-highlight text color.
CXTPPaintManagerColor | m_clrCategorySeparator
Face color.
CXTPPaintManagerColor | m_clrSplitter
Splitter border color.
- Protected Attributes inherited from CXTPPropertyGridPaintManager
int | m_nItemsBorderHeight
Height, in pixels, of the horizontal border between property grid items.
int | m_nSplitterHeight
Height, in pixels, of the splitter bar.
int | m_nHelpHeight
Height, in pixels, of the description area (help pane).
int | m_nVerbsHeight
Height, in pixels, of the verbs box.
BOOL | m_bThinSplitter
TRUE to draw a single line for the splitter bar.
CXTPPropertyGrid * | m_pGrid
Parent grid class.
CXTPPropertyGridItemMetrics * | m_pMetrics
Default metrics of the item.

Detailed Description

CXTPPropertyGridVisualStudio2010Theme is a CXTPPropertyGridPaintManager derived class.

It represents a Visual Studio 2010 style theme.

Constructor & Destructor Documentation

◆ CXTPPropertyGridVisualStudio2010Theme()

CXTPPropertyGridVisualStudio2010Theme ( CXTPPropertyGrid * pGrid )

Constructs a CXTPPropertyGridVisualStudio2010Theme object.

Parameters
pGrid Pointer to a CXTPPropertyGrid object.

Member Function Documentation

◆ DrawExpandButton()

virtual void DrawExpandButton | ( | CDC & | dc,
 |  | CXTPPropertyGridItem * | pItem,
 |  | CRect | rcCaption )
 virtual

Draws an expand button for the grid.

Parameters
dc | Reference to a valid device context.
pItem | Pointer to a CXTPPropertyGridItem object.
rcCaption | Caption button rectangle.

Reimplemented from CXTPPropertyGridPaintManager.

Reimplemented in CXTPPropertyGridNativeWindows10Theme, CXTPPropertyGridNativeWindows11Theme, CXTPPropertyGridVisualStudio2015Theme, CXTPPropertyGridVisualStudio2017Theme, CXTPPropertyGridVisualStudio2019Theme, and CXTPPropertyGridVisualStudio2022Theme.

◆ GetScrollBarTheme()

virtual XTPScrollBarTheme GetScrollBarTheme ( ) const
virtual

Gets the scrollbar theme identifier.

Returns
The scrollbar theme identifier; one of the values defined by the XTPScrollBarTheme enumeration.

Reimplemented from CXTPPropertyGridPaintManager.

Reimplemented in CXTPPropertyGridNativeWindows10Theme, CXTPPropertyGridNativeWindows11Theme, CXTPPropertyGridVisualStudio2015Theme, CXTPPropertyGridVisualStudio2017Theme, CXTPPropertyGridVisualStudio2019Theme, and CXTPPropertyGridVisualStudio2022Theme.

The documentation for this class was generated from the following file:
  • XTPPropertyGridPaintManager.h


Toolkit Pro: CXTPPropertyGridVisualStudio2012Theme Class Reference

Public Member Functions | List of all members
CXTPPropertyGridVisualStudio2012Theme Class Reference

CXTPPropertyGridVisualStudio2012Theme is a CXTPPropertyGridVisualStudio2010Theme derived class. More...

Inheritance diagram for CXTPPropertyGridVisualStudio2012Theme:
[legend]

Public Member Functions

CXTPPropertyGridVisualStudio2012Theme (CXTPPropertyGrid *pGrid, BOOL bLight)
Constructs a CXTPPropertyGridVisualStudio2012Theme object.
virtual void | RefreshMetrics ()
Refreshes the visual metrics of the property grid.
virtual void | DrawExpandButton (CDC &dc, CXTPPropertyGridItem *pItem, CRect rcCaption)
Draws an expand button for the grid.
virtual XTPScrollBarTheme | GetScrollBarTheme () const
Gets the scrollbar theme identifier.
- Public Member Functions inherited from CXTPPropertyGridPaintManager
CXTPPropertyGridPaintManager (CXTPPropertyGrid *pGrid)
Constructs a CXTPPropertyGridPaintManager object.
virtual | ~CXTPPropertyGridPaintManager ()
Destroys a CXTPPropertyGridPaintManager object, handles cleanup and deallocation.
virtual COLORREF | GetItemTextColor (CXTPPropertyGridItem *pItem, BOOL bValuePart)
Retrieves the text color of a specified item.
virtual COLORREF | GetItemBackColor (CXTPPropertyGridItem *pItem, BOOL bValuePart)
Retrieves the back color of a specified item.
virtual CFont * | GetItemFont (CXTPPropertyGridItem *pItem, BOOL bValuePart)
Retrieves the font of a specified item.
virtual void | FillPropertyGrid (CDC *pDC)
Draws the background of the property grid.
virtual void | FillPropertyGridView (CDC *pDC)
Draws the background of the view.
virtual void | DrawPropertyGridBorder (CDC *pDC, RECT &rcBorder, XTPPropertyGridWindow nWindow)
Draws grid borders.
virtual void | OnNcCalcSize (RECT &rc)
Adjusts the bounding rectangle of the grid.
virtual void | DrawItem (PDRAWITEMSTRUCT lpDrawItemStruct)
Draws a single item of the grid.
virtual void | DrawInplaceListItem (CDC *pDC, CXTPPropertyGridItemConstraint *pConstraint, CRect rc, BOOL bSelected)
Draws a specified constraint in the in-place list.
virtual void | AdjustItemValueRect (CXTPPropertyGridItem *pItem, CRect &rcValue)
Adjusts the rectangle of the value part of a specified item.
virtual void | AdjustItemCaptionRect (CXTPPropertyGridItem *pItem, CRect &rcCaption)
Adjusts the rectangle of the caption part of a specified item.
virtual void | MeasureItem (LPMEASUREITEMSTRUCT lpMeasureItemStruct)
Override this method and fill in a specified MEASUREITEMSTRUCT structure to inform Windows of the list-box dimensions.
virtual void | FillInplaceButton (CDC *pDC, CXTPPropertyGridInplaceButton *pButton)
Draws an in-place button for the grid.
int | HitTestVerbs (CDC *pDC, CRect rcVerbs, CPoint pt)
Determines the index of the verb within the verbs collection, if any, at a specified point.
CXTPPropertyGridItemMetrics * | GetItemMetrics () const
Gets the default item metrics.
CRect | GetSplitterRect (CRect rc, BOOL bIsHelp)
This method is called by the property grid to retrieve the size of either the help window splitter bar or the verbs splitter bar.
virtual int | GetItemsBorderHeight () const
Gets the height of the horizontal grid line between property grid items.
virtual void | SetItemsBorderHeight (int nHeight)
Sets the height of the horizontal grid line between property grid items.
virtual void | SetThinSplitter (BOOL bThinSplitter)
Sets draw a bottom single line for the splitter bar.
virtual void | DrawCategoryCaptionBackground (CDC *pDC, CXTPPropertyGridItem *pItem, CRect rc)
Draws the background for the bounding rectangle of a category caption.
virtual void | DrawItemValue (CDC *pDC, CXTPPropertyGridItem *pItem, CRect rcValue)
Draws the value part of a property grid item.
virtual void | DrawItemCaption (CDC *pDC, CXTPPropertyGridItem *pItem, CRect rcCaption)
Draws the caption part of a property grid item.
virtual void | DrawInplaceButtons (CDC *pDC, PDRAWITEMSTRUCT lpDrawItemStruct, CXTPPropertyGridItem *pItem, CRect rcValue)
Draws the in-place buttons of a property grid item.
virtual void | DrawCheckBox (CDC *pDC, CXTPPropertyGridItemBool *pButton)
Draws a checkbox for a CXTPPropertyGridItemOption item with with the CheckBox style.
virtual void | DrawCheckMark (CDC *pDC, CRect rc, BOOL bEnabled, BOOL bChecked)
Draws a check mark.
virtual void | DrawRadioMark (CDC *pDC, CRect rc, BOOL bEnabled, BOOL bChecked)
Draws a radio button for a CXTPPropertyGridItemOption item with the RadioButton (default) style.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPPropertyGridPaintManager
XTPPropertyGridInplaceButtonsStyle | m_buttonsStyle
TRUE to use WinXP themes.
CXTPWinThemeWrapper * | m_themeTree
Themes for tree controls.
CXTPWinThemeWrapper * | m_themeButton
Themes for button controls.
CXTPWinThemeWrapper * | m_themeCombo
Themes for combo button.
BOOL | m_bTransparent
TRUE to draw background with parent color.
CXTPPaintManagerColor | m_clrFace
Face color.
CXTPPaintManagerColor | m_clrShadow
Shadow color.
CXTPPaintManagerColor | m_clrHighlight
Highlight color.
CXTPPaintManagerColor | m_clrHighlightText
Highlight text color.
CXTPPaintManagerColor | m_clrNonHighlightBack
Non-highlight background color.
CXTPPaintManagerColor | m_clrNonHighlightText
Non-highlight text color.
CXTPPaintManagerColor | m_clrCategorySeparator
Face color.
CXTPPaintManagerColor | m_clrSplitter
Splitter border color.
- Protected Attributes inherited from CXTPPropertyGridPaintManager
int | m_nItemsBorderHeight
Height, in pixels, of the horizontal border between property grid items.
int | m_nSplitterHeight
Height, in pixels, of the splitter bar.
int | m_nHelpHeight
Height, in pixels, of the description area (help pane).
int | m_nVerbsHeight
Height, in pixels, of the verbs box.
BOOL | m_bThinSplitter
TRUE to draw a single line for the splitter bar.
CXTPPropertyGrid * | m_pGrid
Parent grid class.
CXTPPropertyGridItemMetrics * | m_pMetrics
Default metrics of the item.

Detailed Description

CXTPPropertyGridVisualStudio2012Theme is a CXTPPropertyGridVisualStudio2010Theme derived class.

It represents a Visual Studio 2012 style theme.

Constructor & Destructor Documentation

◆ CXTPPropertyGridVisualStudio2012Theme()

CXTPPropertyGridVisualStudio2012Theme | ( | CXTPPropertyGrid * | pGrid,
 |  | BOOL | bLight )

Constructs a CXTPPropertyGridVisualStudio2012Theme object.

Parameters
pGrid | Pointer to a CXTPPropertyGrid object
bLight | TRUE to use Visual Studio light theme.

Member Function Documentation

◆ DrawExpandButton()

virtual void DrawExpandButton | ( | CDC & | dc,
 |  | CXTPPropertyGridItem * | pItem,
 |  | CRect | rcCaption )
 virtual

Draws an expand button for the grid.

Parameters
dc | Reference to a valid device context.
pItem | Pointer to a CXTPPropertyGridItem object.
rcCaption | Caption button rectangle.

Reimplemented from CXTPPropertyGridPaintManager.

◆ GetScrollBarTheme()

virtual XTPScrollBarTheme GetScrollBarTheme ( ) const
virtual

Gets the scrollbar theme identifier.

Returns
The scrollbar theme identifier; one of the values defined by the XTPScrollBarTheme enumeration.

Reimplemented from CXTPPropertyGridPaintManager.

The documentation for this class was generated from the following file:
  • XTPPropertyGridPaintManager.h


Toolkit Pro: CXTPPropertyGridVisualStudio2015Theme Class Reference

Public Member Functions | List of all members
CXTPPropertyGridVisualStudio2015Theme Class Reference

CXTPPropertyGridVisualStudio2015Theme is a CXTPPropertyGridVisualStudio2010Theme derived class. More...

Inheritance diagram for CXTPPropertyGridVisualStudio2015Theme:
[legend]

Public Member Functions

CXTPPropertyGridVisualStudio2015Theme (CXTPPropertyGrid *pGrid)
Constructs a CXTPPropertyGridVisualStudio2015Theme object.
virtual void | DrawExpandButton (CDC &dc, CXTPPropertyGridItem *pItem, CRect rcCaption)
Draws an expand button for the grid.
virtual void | RefreshMetrics ()
Refreshes the visual metrics of the property grid.
virtual XTPScrollBarTheme | GetScrollBarTheme () const
Gets the scrollbar theme identifier.
- Public Member Functions inherited from CXTPPropertyGridVisualStudio2010Theme
CXTPPropertyGridVisualStudio2010Theme (CXTPPropertyGrid *pGrid)
Constructs a CXTPPropertyGridVisualStudio2010Theme object.
~CXTPPropertyGridVisualStudio2010Theme ()
Destroys a CXTPPropertyGridVisualStudio2010Theme object, handles cleanup and deallocation.
- Public Member Functions inherited from CXTPPropertyGridPaintManager
CXTPPropertyGridPaintManager (CXTPPropertyGrid *pGrid)
Constructs a CXTPPropertyGridPaintManager object.
virtual | ~CXTPPropertyGridPaintManager ()
Destroys a CXTPPropertyGridPaintManager object, handles cleanup and deallocation.
virtual COLORREF | GetItemTextColor (CXTPPropertyGridItem *pItem, BOOL bValuePart)
Retrieves the text color of a specified item.
virtual COLORREF | GetItemBackColor (CXTPPropertyGridItem *pItem, BOOL bValuePart)
Retrieves the back color of a specified item.
virtual CFont * | GetItemFont (CXTPPropertyGridItem *pItem, BOOL bValuePart)
Retrieves the font of a specified item.
virtual void | FillPropertyGrid (CDC *pDC)
Draws the background of the property grid.
virtual void | FillPropertyGridView (CDC *pDC)
Draws the background of the view.
virtual void | DrawPropertyGridBorder (CDC *pDC, RECT &rcBorder, XTPPropertyGridWindow nWindow)
Draws grid borders.
virtual void | OnNcCalcSize (RECT &rc)
Adjusts the bounding rectangle of the grid.
virtual void | DrawItem (PDRAWITEMSTRUCT lpDrawItemStruct)
Draws a single item of the grid.
virtual void | DrawInplaceListItem (CDC *pDC, CXTPPropertyGridItemConstraint *pConstraint, CRect rc, BOOL bSelected)
Draws a specified constraint in the in-place list.
virtual void | AdjustItemValueRect (CXTPPropertyGridItem *pItem, CRect &rcValue)
Adjusts the rectangle of the value part of a specified item.
virtual void | AdjustItemCaptionRect (CXTPPropertyGridItem *pItem, CRect &rcCaption)
Adjusts the rectangle of the caption part of a specified item.
virtual void | MeasureItem (LPMEASUREITEMSTRUCT lpMeasureItemStruct)
Override this method and fill in a specified MEASUREITEMSTRUCT structure to inform Windows of the list-box dimensions.
virtual void | FillInplaceButton (CDC *pDC, CXTPPropertyGridInplaceButton *pButton)
Draws an in-place button for the grid.
int | HitTestVerbs (CDC *pDC, CRect rcVerbs, CPoint pt)
Determines the index of the verb within the verbs collection, if any, at a specified point.
CXTPPropertyGridItemMetrics * | GetItemMetrics () const
Gets the default item metrics.
CRect | GetSplitterRect (CRect rc, BOOL bIsHelp)
This method is called by the property grid to retrieve the size of either the help window splitter bar or the verbs splitter bar.
virtual int | GetItemsBorderHeight () const
Gets the height of the horizontal grid line between property grid items.
virtual void | SetItemsBorderHeight (int nHeight)
Sets the height of the horizontal grid line between property grid items.
virtual void | SetThinSplitter (BOOL bThinSplitter)
Sets draw a bottom single line for the splitter bar.
virtual void | DrawCategoryCaptionBackground (CDC *pDC, CXTPPropertyGridItem *pItem, CRect rc)
Draws the background for the bounding rectangle of a category caption.
virtual void | DrawItemValue (CDC *pDC, CXTPPropertyGridItem *pItem, CRect rcValue)
Draws the value part of a property grid item.
virtual void | DrawItemCaption (CDC *pDC, CXTPPropertyGridItem *pItem, CRect rcCaption)
Draws the caption part of a property grid item.
virtual void | DrawInplaceButtons (CDC *pDC, PDRAWITEMSTRUCT lpDrawItemStruct, CXTPPropertyGridItem *pItem, CRect rcValue)
Draws the in-place buttons of a property grid item.
virtual void | DrawCheckBox (CDC *pDC, CXTPPropertyGridItemBool *pButton)
Draws a checkbox for a CXTPPropertyGridItemOption item with with the CheckBox style.
virtual void | DrawCheckMark (CDC *pDC, CRect rc, BOOL bEnabled, BOOL bChecked)
Draws a check mark.
virtual void | DrawRadioMark (CDC *pDC, CRect rc, BOOL bEnabled, BOOL bChecked)
Draws a radio button for a CXTPPropertyGridItemOption item with the RadioButton (default) style.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPPropertyGridPaintManager
XTPPropertyGridInplaceButtonsStyle | m_buttonsStyle
TRUE to use WinXP themes.
CXTPWinThemeWrapper * | m_themeTree
Themes for tree controls.
CXTPWinThemeWrapper * | m_themeButton
Themes for button controls.
CXTPWinThemeWrapper * | m_themeCombo
Themes for combo button.
BOOL | m_bTransparent
TRUE to draw background with parent color.
CXTPPaintManagerColor | m_clrFace
Face color.
CXTPPaintManagerColor | m_clrShadow
Shadow color.
CXTPPaintManagerColor | m_clrHighlight
Highlight color.
CXTPPaintManagerColor | m_clrHighlightText
Highlight text color.
CXTPPaintManagerColor | m_clrNonHighlightBack
Non-highlight background color.
CXTPPaintManagerColor | m_clrNonHighlightText
Non-highlight text color.
CXTPPaintManagerColor | m_clrCategorySeparator
Face color.
CXTPPaintManagerColor | m_clrSplitter
Splitter border color.
- Protected Attributes inherited from CXTPPropertyGridPaintManager
int | m_nItemsBorderHeight
Height, in pixels, of the horizontal border between property grid items.
int | m_nSplitterHeight
Height, in pixels, of the splitter bar.
int | m_nHelpHeight
Height, in pixels, of the description area (help pane).
int | m_nVerbsHeight
Height, in pixels, of the verbs box.
BOOL | m_bThinSplitter
TRUE to draw a single line for the splitter bar.
CXTPPropertyGrid * | m_pGrid
Parent grid class.
CXTPPropertyGridItemMetrics * | m_pMetrics
Default metrics of the item.

Detailed Description

CXTPPropertyGridVisualStudio2015Theme is a CXTPPropertyGridVisualStudio2010Theme derived class.

It represents a Visual Studio 2015 style theme.

Constructor & Destructor Documentation

◆ CXTPPropertyGridVisualStudio2015Theme()

CXTPPropertyGridVisualStudio2015Theme ( CXTPPropertyGrid * pGrid )

Constructs a CXTPPropertyGridVisualStudio2015Theme object.

Parameters
pGrid Pointer to a CXTPPropertyGrid object.

Member Function Documentation

◆ DrawExpandButton()

virtual void DrawExpandButton | ( | CDC & | dc,
 |  | CXTPPropertyGridItem * | pItem,
 |  | CRect | rcCaption )
 virtual

Draws an expand button for the grid.

Parameters
dc | Reference to a valid device context.
pItem | Pointer to a CXTPPropertyGridItem object.
rcCaption | Caption button rectangle.

Reimplemented from CXTPPropertyGridVisualStudio2010Theme.

◆ GetScrollBarTheme()

virtual XTPScrollBarTheme GetScrollBarTheme ( ) const
virtual

Gets the scrollbar theme identifier.

Returns
The scrollbar theme identifier; one of the values defined by the XTPScrollBarTheme enumeration.

Reimplemented from CXTPPropertyGridVisualStudio2010Theme.

The documentation for this class was generated from the following file:
  • XTPPropertyGridPaintManager.h


Toolkit Pro: CXTPPropertyGridVisualStudio2017Theme Class Reference

Public Member Functions | List of all members
CXTPPropertyGridVisualStudio2017Theme Class Reference

CXTPPropertyGridVisualStudio2017Theme is a CXTPPropertyGridVisualStudio2010Theme derived class. More...

Inheritance diagram for CXTPPropertyGridVisualStudio2017Theme:
[legend]

Public Member Functions

CXTPPropertyGridVisualStudio2017Theme (CXTPPropertyGrid *pGrid)
Constructs a CXTPPropertyGridVisualStudio2017Theme object.
virtual void | DrawExpandButton (CDC &dc, CXTPPropertyGridItem *pItem, CRect rcCaption)
Draws an expand button for the grid.
virtual void | RefreshMetrics ()
Refreshes the visual metrics of the property grid.
virtual XTPScrollBarTheme | GetScrollBarTheme () const
Gets the scrollbar theme identifier.
- Public Member Functions inherited from CXTPPropertyGridVisualStudio2010Theme
CXTPPropertyGridVisualStudio2010Theme (CXTPPropertyGrid *pGrid)
Constructs a CXTPPropertyGridVisualStudio2010Theme object.
~CXTPPropertyGridVisualStudio2010Theme ()
Destroys a CXTPPropertyGridVisualStudio2010Theme object, handles cleanup and deallocation.
- Public Member Functions inherited from CXTPPropertyGridPaintManager
CXTPPropertyGridPaintManager (CXTPPropertyGrid *pGrid)
Constructs a CXTPPropertyGridPaintManager object.
virtual | ~CXTPPropertyGridPaintManager ()
Destroys a CXTPPropertyGridPaintManager object, handles cleanup and deallocation.
virtual COLORREF | GetItemTextColor (CXTPPropertyGridItem *pItem, BOOL bValuePart)
Retrieves the text color of a specified item.
virtual COLORREF | GetItemBackColor (CXTPPropertyGridItem *pItem, BOOL bValuePart)
Retrieves the back color of a specified item.
virtual CFont * | GetItemFont (CXTPPropertyGridItem *pItem, BOOL bValuePart)
Retrieves the font of a specified item.
virtual void | FillPropertyGrid (CDC *pDC)
Draws the background of the property grid.
virtual void | FillPropertyGridView (CDC *pDC)
Draws the background of the view.
virtual void | DrawPropertyGridBorder (CDC *pDC, RECT &rcBorder, XTPPropertyGridWindow nWindow)
Draws grid borders.
virtual void | OnNcCalcSize (RECT &rc)
Adjusts the bounding rectangle of the grid.
virtual void | DrawItem (PDRAWITEMSTRUCT lpDrawItemStruct)
Draws a single item of the grid.
virtual void | DrawInplaceListItem (CDC *pDC, CXTPPropertyGridItemConstraint *pConstraint, CRect rc, BOOL bSelected)
Draws a specified constraint in the in-place list.
virtual void | AdjustItemValueRect (CXTPPropertyGridItem *pItem, CRect &rcValue)
Adjusts the rectangle of the value part of a specified item.
virtual void | AdjustItemCaptionRect (CXTPPropertyGridItem *pItem, CRect &rcCaption)
Adjusts the rectangle of the caption part of a specified item.
virtual void | MeasureItem (LPMEASUREITEMSTRUCT lpMeasureItemStruct)
Override this method and fill in a specified MEASUREITEMSTRUCT structure to inform Windows of the list-box dimensions.
virtual void | FillInplaceButton (CDC *pDC, CXTPPropertyGridInplaceButton *pButton)
Draws an in-place button for the grid.
int | HitTestVerbs (CDC *pDC, CRect rcVerbs, CPoint pt)
Determines the index of the verb within the verbs collection, if any, at a specified point.
CXTPPropertyGridItemMetrics * | GetItemMetrics () const
Gets the default item metrics.
CRect | GetSplitterRect (CRect rc, BOOL bIsHelp)
This method is called by the property grid to retrieve the size of either the help window splitter bar or the verbs splitter bar.
virtual int | GetItemsBorderHeight () const
Gets the height of the horizontal grid line between property grid items.
virtual void | SetItemsBorderHeight (int nHeight)
Sets the height of the horizontal grid line between property grid items.
virtual void | SetThinSplitter (BOOL bThinSplitter)
Sets draw a bottom single line for the splitter bar.
virtual void | DrawCategoryCaptionBackground (CDC *pDC, CXTPPropertyGridItem *pItem, CRect rc)
Draws the background for the bounding rectangle of a category caption.
virtual void | DrawItemValue (CDC *pDC, CXTPPropertyGridItem *pItem, CRect rcValue)
Draws the value part of a property grid item.
virtual void | DrawItemCaption (CDC *pDC, CXTPPropertyGridItem *pItem, CRect rcCaption)
Draws the caption part of a property grid item.
virtual void | DrawInplaceButtons (CDC *pDC, PDRAWITEMSTRUCT lpDrawItemStruct, CXTPPropertyGridItem *pItem, CRect rcValue)
Draws the in-place buttons of a property grid item.
virtual void | DrawCheckBox (CDC *pDC, CXTPPropertyGridItemBool *pButton)
Draws a checkbox for a CXTPPropertyGridItemOption item with with the CheckBox style.
virtual void | DrawCheckMark (CDC *pDC, CRect rc, BOOL bEnabled, BOOL bChecked)
Draws a check mark.
virtual void | DrawRadioMark (CDC *pDC, CRect rc, BOOL bEnabled, BOOL bChecked)
Draws a radio button for a CXTPPropertyGridItemOption item with the RadioButton (default) style.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPPropertyGridPaintManager
XTPPropertyGridInplaceButtonsStyle | m_buttonsStyle
TRUE to use WinXP themes.
CXTPWinThemeWrapper * | m_themeTree
Themes for tree controls.
CXTPWinThemeWrapper * | m_themeButton
Themes for button controls.
CXTPWinThemeWrapper * | m_themeCombo
Themes for combo button.
BOOL | m_bTransparent
TRUE to draw background with parent color.
CXTPPaintManagerColor | m_clrFace
Face color.
CXTPPaintManagerColor | m_clrShadow
Shadow color.
CXTPPaintManagerColor | m_clrHighlight
Highlight color.
CXTPPaintManagerColor | m_clrHighlightText
Highlight text color.
CXTPPaintManagerColor | m_clrNonHighlightBack
Non-highlight background color.
CXTPPaintManagerColor | m_clrNonHighlightText
Non-highlight text color.
CXTPPaintManagerColor | m_clrCategorySeparator
Face color.
CXTPPaintManagerColor | m_clrSplitter
Splitter border color.
- Protected Attributes inherited from CXTPPropertyGridPaintManager
int | m_nItemsBorderHeight
Height, in pixels, of the horizontal border between property grid items.
int | m_nSplitterHeight
Height, in pixels, of the splitter bar.
int | m_nHelpHeight
Height, in pixels, of the description area (help pane).
int | m_nVerbsHeight
Height, in pixels, of the verbs box.
BOOL | m_bThinSplitter
TRUE to draw a single line for the splitter bar.
CXTPPropertyGrid * | m_pGrid
Parent grid class.
CXTPPropertyGridItemMetrics * | m_pMetrics
Default metrics of the item.

Detailed Description

CXTPPropertyGridVisualStudio2017Theme is a CXTPPropertyGridVisualStudio2010Theme derived class.

It represents a Visual Studio 2017 style theme.

Constructor & Destructor Documentation

◆ CXTPPropertyGridVisualStudio2017Theme()

CXTPPropertyGridVisualStudio2017Theme ( CXTPPropertyGrid * pGrid )

Constructs a CXTPPropertyGridVisualStudio2017Theme object.

Parameters
pGrid Pointer to a CXTPPropertyGrid object.

Member Function Documentation

◆ DrawExpandButton()

virtual void DrawExpandButton | ( | CDC & | dc,
 |  | CXTPPropertyGridItem * | pItem,
 |  | CRect | rcCaption )
 virtual

Draws an expand button for the grid.

Parameters
dc | Reference to a valid device context.
pItem | Pointer to a CXTPPropertyGridItem object.
rcCaption | Caption button rectangle.

Reimplemented from CXTPPropertyGridVisualStudio2010Theme.

◆ GetScrollBarTheme()

virtual XTPScrollBarTheme GetScrollBarTheme ( ) const
virtual

Gets the scrollbar theme identifier.

Returns
The scrollbar theme identifier; one of the values defined by the XTPScrollBarTheme enumeration.

Reimplemented from CXTPPropertyGridVisualStudio2010Theme.

The documentation for this class was generated from the following file:
  • XTPPropertyGridPaintManager.h


Toolkit Pro: CXTPPropertyGridVisualStudio2019Theme Class Reference

Public Member Functions | List of all members
CXTPPropertyGridVisualStudio2019Theme Class Reference

CXTPPropertyGridVisualStudio2019Theme is a CXTPPropertyGridVisualStudio2010Theme derived class. More...

Inheritance diagram for CXTPPropertyGridVisualStudio2019Theme:
[legend]

Public Member Functions

CXTPPropertyGridVisualStudio2019Theme (CXTPPropertyGrid *pGrid)
Constructs a CXTPPropertyGridVisualStudio2019Theme object.
virtual void | DrawExpandButton (CDC &dc, CXTPPropertyGridItem *pItem, CRect rcCaption)
Draws an expand button for the grid.
virtual void | RefreshMetrics ()
Refreshes the visual metrics of the property grid.
virtual XTPScrollBarTheme | GetScrollBarTheme () const
Gets the scrollbar theme identifier.
- Public Member Functions inherited from CXTPPropertyGridVisualStudio2010Theme
CXTPPropertyGridVisualStudio2010Theme (CXTPPropertyGrid *pGrid)
Constructs a CXTPPropertyGridVisualStudio2010Theme object.
~CXTPPropertyGridVisualStudio2010Theme ()
Destroys a CXTPPropertyGridVisualStudio2010Theme object, handles cleanup and deallocation.
- Public Member Functions inherited from CXTPPropertyGridPaintManager
CXTPPropertyGridPaintManager (CXTPPropertyGrid *pGrid)
Constructs a CXTPPropertyGridPaintManager object.
virtual | ~CXTPPropertyGridPaintManager ()
Destroys a CXTPPropertyGridPaintManager object, handles cleanup and deallocation.
virtual COLORREF | GetItemTextColor (CXTPPropertyGridItem *pItem, BOOL bValuePart)
Retrieves the text color of a specified item.
virtual COLORREF | GetItemBackColor (CXTPPropertyGridItem *pItem, BOOL bValuePart)
Retrieves the back color of a specified item.
virtual CFont * | GetItemFont (CXTPPropertyGridItem *pItem, BOOL bValuePart)
Retrieves the font of a specified item.
virtual void | FillPropertyGrid (CDC *pDC)
Draws the background of the property grid.
virtual void | FillPropertyGridView (CDC *pDC)
Draws the background of the view.
virtual void | DrawPropertyGridBorder (CDC *pDC, RECT &rcBorder, XTPPropertyGridWindow nWindow)
Draws grid borders.
virtual void | OnNcCalcSize (RECT &rc)
Adjusts the bounding rectangle of the grid.
virtual void | DrawItem (PDRAWITEMSTRUCT lpDrawItemStruct)
Draws a single item of the grid.
virtual void | DrawInplaceListItem (CDC *pDC, CXTPPropertyGridItemConstraint *pConstraint, CRect rc, BOOL bSelected)
Draws a specified constraint in the in-place list.
virtual void | AdjustItemValueRect (CXTPPropertyGridItem *pItem, CRect &rcValue)
Adjusts the rectangle of the value part of a specified item.
virtual void | AdjustItemCaptionRect (CXTPPropertyGridItem *pItem, CRect &rcCaption)
Adjusts the rectangle of the caption part of a specified item.
virtual void | MeasureItem (LPMEASUREITEMSTRUCT lpMeasureItemStruct)
Override this method and fill in a specified MEASUREITEMSTRUCT structure to inform Windows of the list-box dimensions.
virtual void | FillInplaceButton (CDC *pDC, CXTPPropertyGridInplaceButton *pButton)
Draws an in-place button for the grid.
int | HitTestVerbs (CDC *pDC, CRect rcVerbs, CPoint pt)
Determines the index of the verb within the verbs collection, if any, at a specified point.
CXTPPropertyGridItemMetrics * | GetItemMetrics () const
Gets the default item metrics.
CRect | GetSplitterRect (CRect rc, BOOL bIsHelp)
This method is called by the property grid to retrieve the size of either the help window splitter bar or the verbs splitter bar.
virtual int | GetItemsBorderHeight () const
Gets the height of the horizontal grid line between property grid items.
virtual void | SetItemsBorderHeight (int nHeight)
Sets the height of the horizontal grid line between property grid items.
virtual void | SetThinSplitter (BOOL bThinSplitter)
Sets draw a bottom single line for the splitter bar.
virtual void | DrawCategoryCaptionBackground (CDC *pDC, CXTPPropertyGridItem *pItem, CRect rc)
Draws the background for the bounding rectangle of a category caption.
virtual void | DrawItemValue (CDC *pDC, CXTPPropertyGridItem *pItem, CRect rcValue)
Draws the value part of a property grid item.
virtual void | DrawItemCaption (CDC *pDC, CXTPPropertyGridItem *pItem, CRect rcCaption)
Draws the caption part of a property grid item.
virtual void | DrawInplaceButtons (CDC *pDC, PDRAWITEMSTRUCT lpDrawItemStruct, CXTPPropertyGridItem *pItem, CRect rcValue)
Draws the in-place buttons of a property grid item.
virtual void | DrawCheckBox (CDC *pDC, CXTPPropertyGridItemBool *pButton)
Draws a checkbox for a CXTPPropertyGridItemOption item with with the CheckBox style.
virtual void | DrawCheckMark (CDC *pDC, CRect rc, BOOL bEnabled, BOOL bChecked)
Draws a check mark.
virtual void | DrawRadioMark (CDC *pDC, CRect rc, BOOL bEnabled, BOOL bChecked)
Draws a radio button for a CXTPPropertyGridItemOption item with the RadioButton (default) style.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPPropertyGridPaintManager
XTPPropertyGridInplaceButtonsStyle | m_buttonsStyle
TRUE to use WinXP themes.
CXTPWinThemeWrapper * | m_themeTree
Themes for tree controls.
CXTPWinThemeWrapper * | m_themeButton
Themes for button controls.
CXTPWinThemeWrapper * | m_themeCombo
Themes for combo button.
BOOL | m_bTransparent
TRUE to draw background with parent color.
CXTPPaintManagerColor | m_clrFace
Face color.
CXTPPaintManagerColor | m_clrShadow
Shadow color.
CXTPPaintManagerColor | m_clrHighlight
Highlight color.
CXTPPaintManagerColor | m_clrHighlightText
Highlight text color.
CXTPPaintManagerColor | m_clrNonHighlightBack
Non-highlight background color.
CXTPPaintManagerColor | m_clrNonHighlightText
Non-highlight text color.
CXTPPaintManagerColor | m_clrCategorySeparator
Face color.
CXTPPaintManagerColor | m_clrSplitter
Splitter border color.
- Protected Attributes inherited from CXTPPropertyGridPaintManager
int | m_nItemsBorderHeight
Height, in pixels, of the horizontal border between property grid items.
int | m_nSplitterHeight
Height, in pixels, of the splitter bar.
int | m_nHelpHeight
Height, in pixels, of the description area (help pane).
int | m_nVerbsHeight
Height, in pixels, of the verbs box.
BOOL | m_bThinSplitter
TRUE to draw a single line for the splitter bar.
CXTPPropertyGrid * | m_pGrid
Parent grid class.
CXTPPropertyGridItemMetrics * | m_pMetrics
Default metrics of the item.

Detailed Description

CXTPPropertyGridVisualStudio2019Theme is a CXTPPropertyGridVisualStudio2010Theme derived class.

It represents a Visual Studio 2019 style theme.

Constructor & Destructor Documentation

◆ CXTPPropertyGridVisualStudio2019Theme()

CXTPPropertyGridVisualStudio2019Theme ( CXTPPropertyGrid * pGrid )

Constructs a CXTPPropertyGridVisualStudio2019Theme object.

Parameters
pGrid Pointer to a CXTPPropertyGrid object.

Member Function Documentation

◆ DrawExpandButton()

virtual void DrawExpandButton | ( | CDC & | dc,
 |  | CXTPPropertyGridItem * | pItem,
 |  | CRect | rcCaption )
 virtual

Draws an expand button for the grid.

Parameters
dc | Reference to a valid device context.
pItem | Pointer to a CXTPPropertyGridItem object.
rcCaption | Caption button rectangle.

Reimplemented from CXTPPropertyGridVisualStudio2010Theme.

◆ GetScrollBarTheme()

virtual XTPScrollBarTheme GetScrollBarTheme ( ) const
virtual

Gets the scrollbar theme identifier.

Returns
The scrollbar theme identifier; one of the values defined by the XTPScrollBarTheme enumeration.

Reimplemented from CXTPPropertyGridVisualStudio2010Theme.

The documentation for this class was generated from the following file:
  • XTPPropertyGridPaintManager.h


Toolkit Pro: CXTPPropertyGridVisualStudio2022Theme Class Reference

Public Member Functions | List of all members
CXTPPropertyGridVisualStudio2022Theme Class Reference

CXTPPropertyGridVisualStudio2022Theme is a CXTPPropertyGridVisualStudio2010Theme derived class. More...

Inheritance diagram for CXTPPropertyGridVisualStudio2022Theme:
[legend]

Public Member Functions

CXTPPropertyGridVisualStudio2022Theme (CXTPPropertyGrid *pGrid)
Constructs a CXTPPropertyGridVisualStudio2022Theme object.
virtual void | DrawExpandButton (CDC &dc, CXTPPropertyGridItem *pItem, CRect rcCaption)
Draws an expand button for the grid.
virtual void | RefreshMetrics ()
Refreshes the visual metrics of the property grid.
virtual XTPScrollBarTheme | GetScrollBarTheme () const
Gets the scrollbar theme identifier.
- Public Member Functions inherited from CXTPPropertyGridVisualStudio2010Theme
CXTPPropertyGridVisualStudio2010Theme (CXTPPropertyGrid *pGrid)
Constructs a CXTPPropertyGridVisualStudio2010Theme object.
~CXTPPropertyGridVisualStudio2010Theme ()
Destroys a CXTPPropertyGridVisualStudio2010Theme object, handles cleanup and deallocation.
- Public Member Functions inherited from CXTPPropertyGridPaintManager
CXTPPropertyGridPaintManager (CXTPPropertyGrid *pGrid)
Constructs a CXTPPropertyGridPaintManager object.
virtual | ~CXTPPropertyGridPaintManager ()
Destroys a CXTPPropertyGridPaintManager object, handles cleanup and deallocation.
virtual COLORREF | GetItemTextColor (CXTPPropertyGridItem *pItem, BOOL bValuePart)
Retrieves the text color of a specified item.
virtual COLORREF | GetItemBackColor (CXTPPropertyGridItem *pItem, BOOL bValuePart)
Retrieves the back color of a specified item.
virtual CFont * | GetItemFont (CXTPPropertyGridItem *pItem, BOOL bValuePart)
Retrieves the font of a specified item.
virtual void | FillPropertyGrid (CDC *pDC)
Draws the background of the property grid.
virtual void | FillPropertyGridView (CDC *pDC)
Draws the background of the view.
virtual void | DrawPropertyGridBorder (CDC *pDC, RECT &rcBorder, XTPPropertyGridWindow nWindow)
Draws grid borders.
virtual void | OnNcCalcSize (RECT &rc)
Adjusts the bounding rectangle of the grid.
virtual void | DrawItem (PDRAWITEMSTRUCT lpDrawItemStruct)
Draws a single item of the grid.
virtual void | DrawInplaceListItem (CDC *pDC, CXTPPropertyGridItemConstraint *pConstraint, CRect rc, BOOL bSelected)
Draws a specified constraint in the in-place list.
virtual void | AdjustItemValueRect (CXTPPropertyGridItem *pItem, CRect &rcValue)
Adjusts the rectangle of the value part of a specified item.
virtual void | AdjustItemCaptionRect (CXTPPropertyGridItem *pItem, CRect &rcCaption)
Adjusts the rectangle of the caption part of a specified item.
virtual void | MeasureItem (LPMEASUREITEMSTRUCT lpMeasureItemStruct)
Override this method and fill in a specified MEASUREITEMSTRUCT structure to inform Windows of the list-box dimensions.
virtual void | FillInplaceButton (CDC *pDC, CXTPPropertyGridInplaceButton *pButton)
Draws an in-place button for the grid.
int | HitTestVerbs (CDC *pDC, CRect rcVerbs, CPoint pt)
Determines the index of the verb within the verbs collection, if any, at a specified point.
CXTPPropertyGridItemMetrics * | GetItemMetrics () const
Gets the default item metrics.
CRect | GetSplitterRect (CRect rc, BOOL bIsHelp)
This method is called by the property grid to retrieve the size of either the help window splitter bar or the verbs splitter bar.
virtual int | GetItemsBorderHeight () const
Gets the height of the horizontal grid line between property grid items.
virtual void | SetItemsBorderHeight (int nHeight)
Sets the height of the horizontal grid line between property grid items.
virtual void | SetThinSplitter (BOOL bThinSplitter)
Sets draw a bottom single line for the splitter bar.
virtual void | DrawCategoryCaptionBackground (CDC *pDC, CXTPPropertyGridItem *pItem, CRect rc)
Draws the background for the bounding rectangle of a category caption.
virtual void | DrawItemValue (CDC *pDC, CXTPPropertyGridItem *pItem, CRect rcValue)
Draws the value part of a property grid item.
virtual void | DrawItemCaption (CDC *pDC, CXTPPropertyGridItem *pItem, CRect rcCaption)
Draws the caption part of a property grid item.
virtual void | DrawInplaceButtons (CDC *pDC, PDRAWITEMSTRUCT lpDrawItemStruct, CXTPPropertyGridItem *pItem, CRect rcValue)
Draws the in-place buttons of a property grid item.
virtual void | DrawCheckBox (CDC *pDC, CXTPPropertyGridItemBool *pButton)
Draws a checkbox for a CXTPPropertyGridItemOption item with with the CheckBox style.
virtual void | DrawCheckMark (CDC *pDC, CRect rc, BOOL bEnabled, BOOL bChecked)
Draws a check mark.
virtual void | DrawRadioMark (CDC *pDC, CRect rc, BOOL bEnabled, BOOL bChecked)
Draws a radio button for a CXTPPropertyGridItemOption item with the RadioButton (default) style.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPPropertyGridPaintManager
XTPPropertyGridInplaceButtonsStyle | m_buttonsStyle
TRUE to use WinXP themes.
CXTPWinThemeWrapper * | m_themeTree
Themes for tree controls.
CXTPWinThemeWrapper * | m_themeButton
Themes for button controls.
CXTPWinThemeWrapper * | m_themeCombo
Themes for combo button.
BOOL | m_bTransparent
TRUE to draw background with parent color.
CXTPPaintManagerColor | m_clrFace
Face color.
CXTPPaintManagerColor | m_clrShadow
Shadow color.
CXTPPaintManagerColor | m_clrHighlight
Highlight color.
CXTPPaintManagerColor | m_clrHighlightText
Highlight text color.
CXTPPaintManagerColor | m_clrNonHighlightBack
Non-highlight background color.
CXTPPaintManagerColor | m_clrNonHighlightText
Non-highlight text color.
CXTPPaintManagerColor | m_clrCategorySeparator
Face color.
CXTPPaintManagerColor | m_clrSplitter
Splitter border color.
- Protected Attributes inherited from CXTPPropertyGridPaintManager
int | m_nItemsBorderHeight
Height, in pixels, of the horizontal border between property grid items.
int | m_nSplitterHeight
Height, in pixels, of the splitter bar.
int | m_nHelpHeight
Height, in pixels, of the description area (help pane).
int | m_nVerbsHeight
Height, in pixels, of the verbs box.
BOOL | m_bThinSplitter
TRUE to draw a single line for the splitter bar.
CXTPPropertyGrid * | m_pGrid
Parent grid class.
CXTPPropertyGridItemMetrics * | m_pMetrics
Default metrics of the item.

Detailed Description

CXTPPropertyGridVisualStudio2022Theme is a CXTPPropertyGridVisualStudio2010Theme derived class.

It represents a Visual Studio 2022 style theme.

Constructor & Destructor Documentation

◆ CXTPPropertyGridVisualStudio2022Theme()

CXTPPropertyGridVisualStudio2022Theme ( CXTPPropertyGrid * pGrid )

Constructs a CXTPPropertyGridVisualStudio2022Theme object.

Parameters
pGrid Pointer to a CXTPPropertyGrid object.

Member Function Documentation

◆ DrawExpandButton()

virtual void DrawExpandButton | ( | CDC & | dc,
 |  | CXTPPropertyGridItem * | pItem,
 |  | CRect | rcCaption )
 virtual

Draws an expand button for the grid.

Parameters
dc | Reference to a valid device context.
pItem | Pointer to a CXTPPropertyGridItem object.
rcCaption | Caption button rectangle.

Reimplemented from CXTPPropertyGridVisualStudio2010Theme.

◆ GetScrollBarTheme()

virtual XTPScrollBarTheme GetScrollBarTheme ( ) const
virtual

Gets the scrollbar theme identifier.

Returns
The scrollbar theme identifier; one of the values defined by the XTPScrollBarTheme enumeration.

Reimplemented from CXTPPropertyGridVisualStudio2010Theme.

The documentation for this class was generated from the following file:
  • XTPPropertyGridPaintManager.h


Toolkit Pro: CXTPPropertyPage Class Reference

Public Member Functions | Public Attributes | Protected Attributes | List of all members
CXTPPropertyPage Class Reference

CXTPPropertyPage is a CPropertyPage derived class. More...

Inheritance diagram for CXTPPropertyPage:
[legend]

Public Member Functions

CXTPPropertyPage ()
Constructs a CXTPPropertyPage object.
CXTPPropertyPage (UINT nIDTemplate, UINT nIDCaption=0)
Constructs a CXTPPropertyPage object.
CXTPPropertyPage (LPCTSTR lpszTemplateName, UINT nIDCaption=0)
Constructs a CXTPPropertyPage object.
~CXTPPropertyPage ()
Destroys a CXTPPropertyPage object, handles cleanup and deallocation.
CString | GetCaption () const
Retrieves the caption text used for property sheet tabs.
void | SetCaption (LPCTSTR lpszCaption)
Sets the caption text used to draw property sheet tabs.
virtual void | UpdatePage (void)
Forces a page to update its internal data as this data is supposed to be changed from outside the page.
- Public Member Functions inherited from CXTPResize
CXTPResize (CWnd *pWnd, const UINT nFlags=0)
Constructs a CXTPResize object.
virtual | ~CXTPResize ()
Destroys a CXTPResize object, handles cleanup and deallocation.
void | SetResize (UINT nID, XTP_RESIZE left, XTP_RESIZE top, XTP_RESIZE right, XTP_RESIZE bottom)
The SetResize function specifies how much each side of a control will move when the dialog is resized.
void | SetResize (UINT nID, const XTP_RESIZERECT &rrcSizing)
The SetResize function specifies how much each side of a control will move when the dialog is resized.
void | SetResize (UINT nID, HWND hWnd, const XTP_RESIZERECT &rrcSizing)
The SetResize function specifies how much each side of a control will move when the dialog is resized.
void | SetResize (UINT nID, HWND hWnd, const XTP_RESIZEPOINT &rpTopLeft, const XTP_RESIZEPOINT &rpBottomRight)
The SetResize function specifies how much each side of a control will move when the dialog is resized.
void | SetResize (UINT nID, const XTP_RESIZEPOINT &rpTopLeft, const XTP_RESIZEPOINT &rpBottomRight)
The SetResize function specifies how much each side of a control will move when the dialog is resized.
void | SetMinSize (CSize &sz)
This member function sets the minimum size explicitly.
void | SetMaxSize (CSize &sz)
This member function sets the maximum size.
BOOL | SavePlacement (LPCTSTR pszSection)
This member function saves the window placement to the registry.
BOOL | LoadPlacement (LPCTSTR pszSection)
This member function loads saved window placement information from the registry.
BOOL | AutoLoadPlacement (LPCTSTR pszSection)
This member function loads saved window placement information from the registry.

Public Attributes

DWORD_PTR m_dwData
Page specific 32-bit value.

Protected Attributes

CXTPPropertySheet * | m_pSheet
Parent CXTPPropertySheet object.
BOOL | m_bModified
TRUE to indicate that the property page settings have been modified.
- Protected Attributes inherited from CXTPResize
UINT | m_nFlagsXX
Flags passed from the constructor.
CWnd * | m_pWnd
The associative relation to the window to be resized.
CSize | m_szWindow
Last dialog size.
CSize | m_szInitWindow
Initial dialog size.
CSize | m_szMin
Smallest size allowed.
CSize | m_szMax
Largest size allowed.
CString | m_strSection
Section in registry where window placement information is saved.
CXTPSizeIcon | m_scSizeIcon
Size icon window.
CResizeItemArray | m_arrItems
Array of controls.

Additional Inherited Members

- Protected Types inherited from CXTPResize
typedef CArray< CXTPResizeItem *, CXTPResizeItem *& > | CResizeItemArray
Used by CXTPResize to maintain a list of children that are sizable.
- Protected Member Functions inherited from CXTPResize
void | SetResize (CWnd *pWnd, const CXTPResizeRect &rrcSizing, CRect rcWindow)
The SetResize function specifies how much each side of a control will move when the dialog is resized.
BOOL | RemoveResize (UINT nID)
This member function is called to remove the specified dialog item from the list of items to be resized.
void | RemoveAllControls ()
This member function is called to purge the list that contains the dialog items to be sized.
virtual void | Init ()
This member function is called from OnInitDialog or OnInitialUpdate to initialize the resize manager.
virtual void | Size ()
This member function is called from OnSize to move and resize the dialog items that are managed.
void | Reset ()
This member function is called when a property sheet in wizard mode has changed pages to alert the resize manager that the property sheet (common control) has moved the page back to its original size/position on the sheet.
void | Offset (CPoint ptOffset)
Called to offset dialog items by the amount specified by ptOffset.
void | UpdateControlRect (CWnd *pWnd)
Call this method to reset m_rrcWindow for an item.
void | GetMinMaxInfo (MINMAXINFO *pMMI)
This member function is called from OnGetMinMaxInfo to get the maximized position or dimensions or the minimum or maximum tracking size.
virtual void | AdjustResizeRect (CSize &rcWindow)
This method is called in the Size method to adjust a window rectangle to fit real client size.
BOOL | HasFlag (XTPResize eFlag)
This member function is called to determine if the specified flag has been set for the resize manager.
void | SetFlag (XTPResize eFlag)
This member function is called to set a specific flag for the resize manager.
virtual BOOL | Defer (HDWP &hdwp, CXTPResizeItem *pItem, int dx, int dy)
Called by CXTPResize to resize a child window.

Detailed Description

CXTPPropertyPage is a CPropertyPage derived class.

Objects of class CPropertyPage represent individual pages of a property sheet.

See also
CXTPPropertySheet, CXTPPropertySheet::DoModal, CXTPPropertyPageNavigator

Constructor & Destructor Documentation

◆ CXTPPropertyPage() [1/3]

CXTPPropertyPage ( )

Constructs a CXTPPropertyPage object.

Use this member function to construct a CXTPPropertyPage object. To display the property sheet, call DoModal or Create. The string contained in the first parameter will be placed in the caption bar for the property sheet.

◆ CXTPPropertyPage() [2/3]

CXTPPropertyPage | ( | UINT | nIDTemplate,
 |  | UINT | nIDCaption = 0 )

Constructs a CXTPPropertyPage object.

Parameters
nIDTemplate | ID of the template used for this page.
nIDCaption | ID of the name to be placed in the tab for this page. If 0, then the name will be taken from the dialog template for this page.

Use this member function to construct a CXTPPropertyPage object. To display the property sheet, call DoModal or Create. The string contained in the first parameter will be placed in the caption bar for the property sheet.

◆ CXTPPropertyPage() [3/3]

CXTPPropertyPage | ( | LPCTSTR | lpszTemplateName,
 |  | UINT | nIDCaption = 0 )

Constructs a CXTPPropertyPage object.

Parameters
lpszTemplateName | Pointer to a string containing the name of the template for this page. Cannot be NULL.
nIDCaption | ID of the name to be placed in the tab for this page. If 0, then the name will be taken from the dialog template for this page.

Use this member function to construct a CXTPPropertyPage object. To display the property sheet, call DoModal or Create. The string contained in the first parameter will be placed in the caption bar for the property sheet.

Member Function Documentation

◆ GetCaption()

CString GetCaption ( ) const

Retrieves the caption text used for property sheet tabs.

Returns
The caption text used for property sheet tabs.

◆ SetCaption()

void SetCaption ( LPCTSTR lpszCaption )

Sets the caption text used to draw property sheet tabs.

Parameters
lpszCaption New caption text to be set.
The documentation for this class was generated from the following file:
  • XTPPropertyPage.h


Toolkit Pro: CXTPPropertyPageControlNavigator Class Reference

Public Member Functions | List of all members
CXTPPropertyPageControlNavigator Class Reference

CXTPPropertyPageControlNavigator is a CXTPPropertyPageNavigator derived class. More...

Inheritance diagram for CXTPPropertyPageControlNavigator:
[legend]

Public Member Functions

CXTPPropertyPageControlNavigator ()
Constructs a CXTPPropertyPageControlNavigator object.
- Public Member Functions inherited from CXTPPropertyPageNavigator
CXTPPropertyPageNavigator ()
Constructs a CXTPPropertyPageNavigator object.
virtual | ~CXTPPropertyPageNavigator ()
Destroys a CXTPPropertyPageNavigator object, handles cleanup and deallocation.
virtual BOOL | Create ()=0
This method is called to create a page navigator.
virtual void | PageToSize (AFX_SIZEPARENTPARAMS *pLayout, CSize szPage, CRect &rcPage, CSize &szClient)=0
This method is called to reposition a property sheet using the size of a property page.
virtual void | SizeToPage (AFX_SIZEPARENTPARAMS *pLayout, CSize szClient, CRect &rcPage)=0
This method is called to reposition a property page using the size of a property sheet.
virtual void | OnPageSelected (CXTPPropertyPage *pPage)=0
This method is called when a property page becomes selected.
virtual HWND | GetSafeHwnd () const =0
This method is called to get the window handler of a navigator window.
virtual HBRUSH | GetPageBrush (CDC *pDC, CXTPPropertyPage *pPage)=0
Retrieves page brush.
virtual COLORREF | GetPageColor ()=0
Retrieves page color.
virtual void | SetTheme (XTPControlTheme theme)
Call this member to switch the visual theme of the control.

Additional Inherited Members

- Public Attributes inherited from CXTPPropertyPageNavigator
CRect | m_rcNavigatorMargin
Total navigator margin.
CRect | m_rcButtonMargin
Total buttons margin.
CRect | m_rcPageMargin
Total page margin.
- Protected Member Functions inherited from CXTPPropertyPageNavigator
- Protected Attributes inherited from CXTPPropertyPageNavigator
CXTPPropertySheet * | m_pSheet
Parent property sheet object.

Detailed Description

CXTPPropertyPageControlNavigator is a CXTPPropertyPageNavigator derived class.

It represents a base control property page navigator.

See also
CXTPPropertySheet, CXTPPropertySheet::DoModal, CXTPPropertySheet::SetNavigator
The documentation for this class was generated from the following file:
  • XTPPropertyPageNavigator.h


Toolkit Pro: CXTPPropertyPageListNavigator Class Reference

Public Member Functions | List of all members
CXTPPropertyPageListNavigator Class Reference

CXTPPropertyPageListNavigator is a CXTPListBox and CXTPPropertyPageControlNavigator derived class. More...

Inheritance diagram for CXTPPropertyPageListNavigator:
[legend]

Public Member Functions

CXTPPropertyPageListNavigator ()
Constructs a CXTPPropertyPageListNavigator object.
- Public Member Functions inherited from CXTPListBox
CXTPListBox ()
Constructs a CXTPListBox object.
virtual | ~CXTPListBox ()
Destroys a CXTPListBox object, handles cleanup and deallocation.
virtual void | Initialize (bool bAutoFont=true)
Call this member function to initialize the list box.
virtual COLORREF | GetBackColor ()
Called to retrieve the background color for the list box.
void | SetListStyle (XTPListBoxStyle style)
Call this method to set the style of the list box.
XTPListBoxStyle | GetListStyle () const
Call this method to retrieve the style of the list box.
void | SetTheme (XTPControlTheme nTheme)
This member function sets the drawing theme for the control.
virtual void | RefreshMetrics ()
Call this member function to refresh theme colors and redraw the control.
BOOL | HasFocus () const
Call this member function to determine if the list box control has input focus.
- Public Member Functions inherited from CXTPPropertyPageControlNavigator
CXTPPropertyPageControlNavigator ()
Constructs a CXTPPropertyPageControlNavigator object.
- Public Member Functions inherited from CXTPPropertyPageNavigator
CXTPPropertyPageNavigator ()
Constructs a CXTPPropertyPageNavigator object.
virtual | ~CXTPPropertyPageNavigator ()
Destroys a CXTPPropertyPageNavigator object, handles cleanup and deallocation.
virtual BOOL | Create ()=0
This method is called to create a page navigator.
virtual void | PageToSize (AFX_SIZEPARENTPARAMS *pLayout, CSize szPage, CRect &rcPage, CSize &szClient)=0
This method is called to reposition a property sheet using the size of a property page.
virtual void | SizeToPage (AFX_SIZEPARENTPARAMS *pLayout, CSize szClient, CRect &rcPage)=0
This method is called to reposition a property page using the size of a property sheet.
virtual void | OnPageSelected (CXTPPropertyPage *pPage)=0
This method is called when a property page becomes selected.
virtual HWND | GetSafeHwnd () const =0
This method is called to get the window handler of a navigator window.
virtual HBRUSH | GetPageBrush (CDC *pDC, CXTPPropertyPage *pPage)=0
Retrieves page brush.
virtual COLORREF | GetPageColor ()=0
Retrieves page color.
virtual void | SetTheme (XTPControlTheme theme)
Call this member to switch the visual theme of the control.

Additional Inherited Members

- Public Attributes inherited from CXTPListBox
CXTPListBoxTheme * | m_pTheme
Pointer to the currently active theme.
XTPControlTheme | m_theme
List box theme.
int | m_nItemHeight
Height of the items.
int | m_nTextPadding
Text padding.
int | m_nHotItem
Hot item index.
- Public Attributes inherited from CXTPPropertyPageNavigator
CRect | m_rcNavigatorMargin
Total navigator margin.
CRect | m_rcButtonMargin
Total buttons margin.
CRect | m_rcPageMargin
Total page margin.
- Protected Member Functions inherited from CXTPListBox
BOOL | TryItemFromPoint (CPoint pt, BOOL &bOutside, int &nIndex) const
This method determines the list box item nearest to the point specified in pt when there is at least one item in the list box.
- Protected Member Functions inherited from CXTPPropertyPageNavigator
- Protected Attributes inherited from CXTPPropertyPageNavigator
CXTPPropertySheet * | m_pSheet
Parent property sheet object.

Detailed Description

CXTPPropertyPageListNavigator is a CXTPListBox and CXTPPropertyPageControlNavigator derived class.

It represents a list property page navigator.

See also
CXTPPropertySheet, CXTPPropertySheet::DoModal, CXTPPropertySheet::SetNavigator
The documentation for this class was generated from the following file:
  • XTPPropertyPageNavigator.h


Toolkit Pro: CXTPPropertyPageNavigator Class Reference

Public Member Functions | Public Attributes | Protected Attributes | List of all members
CXTPPropertyPageNavigator Class Referenceabstract

CXTPPropertyPageNavigator is a standalone class. More...

Inheritance diagram for CXTPPropertyPageNavigator:
[legend]

Public Member Functions

CXTPPropertyPageNavigator ()
Constructs a CXTPPropertyPageNavigator object.
virtual | ~CXTPPropertyPageNavigator ()
Destroys a CXTPPropertyPageNavigator object, handles cleanup and deallocation.
virtual BOOL | Create ()=0
This method is called to create a page navigator.
virtual void | PageToSize (AFX_SIZEPARENTPARAMS *pLayout, CSize szPage, CRect &rcPage, CSize &szClient)=0
This method is called to reposition a property sheet using the size of a property page.
virtual void | SizeToPage (AFX_SIZEPARENTPARAMS *pLayout, CSize szClient, CRect &rcPage)=0
This method is called to reposition a property page using the size of a property sheet.
virtual void | OnPageSelected (CXTPPropertyPage *pPage)=0
This method is called when a property page becomes selected.
virtual HWND | GetSafeHwnd () const =0
This method is called to get the window handler of a navigator window.
virtual HBRUSH | GetPageBrush (CDC *pDC, CXTPPropertyPage *pPage)=0
Retrieves page brush.
virtual COLORREF | GetPageColor ()=0
Retrieves page color.
virtual void | SetTheme (XTPControlTheme theme)
Call this member to switch the visual theme of the control.

Public Attributes

CRect | m_rcNavigatorMargin
Total navigator margin.
CRect | m_rcButtonMargin
Total buttons margin.
CRect | m_rcPageMargin
Total page margin.

Protected Attributes

CXTPPropertySheet * m_pSheet
Parent property sheet object.

Detailed Description

CXTPPropertyPageNavigator is a standalone class.

CXTPPropertyPageNavigator represents a base navigator object for CXTPPropertySheet.

See also
CXTPPropertySheet, CXTPPropertySheet::DoModal, CXTPPropertySheet::SetNavigator

Member Function Documentation

◆ Create()

virtual BOOL Create ( )
pure virtual

This method is called to create a page navigator.

Returns
TRUE if successful, otherwise FALSE.

◆ GetPageBrush()

virtual HBRUSH GetPageBrush | ( | CDC * | pDC,
 |  | CXTPPropertyPage * | pPage )
 pure virtual

Retrieves page brush.

Parameters
pDC | Pointer to a valid device context.
pPage | Property page to draw.
Returns
The page brush.

◆ GetPageColor()

virtual COLORREF GetPageColor ( )
pure virtual

Retrieves page color.

Returns
The page color.

◆ GetSafeHwnd()

virtual HWND GetSafeHwnd ( ) const
pure virtual

This method is called to get the window handler of a navigator window.

Returns
The window handler of a navigator window.

◆ OnPageSelected()

virtual void OnPageSelected ( CXTPPropertyPage * pPage )
pure virtual

This method is called when a property page becomes selected.

Parameters
pPage The property page that became selected.

◆ PageToSize()

virtual void PageToSize | ( | AFX_SIZEPARENTPARAMS * | pLayout,
 |  | CSize | szPage,
 |  | CRect & | rcPage,
 |  | CSize & | szClient )
 pure virtual

This method is called to reposition a property sheet using the size of a property page.

Parameters
pLayout | Address of an AFX_SIZEPARENTPARAMS structure.
szPage | Page size to calculate from.
rcPage | Result bounding rectangle of property pages.
szClient | Result size of property sheet.

◆ SetTheme()

virtual void SetTheme ( XTPControlTheme theme )
virtual

Call this member to switch the visual theme of the control.

Parameters
theme New visual theme. Can be any of the values listed in the Remarks section.

nTheme can be one of the theme IDs specified by XTPControlTheme.

See also
XTPControlTheme

◆ SizeToPage()

virtual void SizeToPage | ( | AFX_SIZEPARENTPARAMS * | pLayout,
 |  | CSize | szClient,
 |  | CRect & | rcPage )
 pure virtual

This method is called to reposition a property page using the size of a property sheet.

Parameters
pLayout | Address of an AFX_SIZEPARENTPARAMS structure.
szClient | Size of property sheet.
rcPage | Result bounding rectangle of property pages.
The documentation for this class was generated from the following file:
  • XTPPropertyPageNavigator.h


Toolkit Pro: CXTPPropertyPageTreeNavigator Class Reference

Public Member Functions | List of all members
CXTPPropertyPageTreeNavigator Class Reference

CXTPPropertyPageTreeNavigator is a CTreeCtrl and CXTPPropertyPageControlNavigator derived class. More...

Inheritance diagram for CXTPPropertyPageTreeNavigator:
[legend]

Public Member Functions

CXTPPropertyPageTreeNavigator (DWORD dwStyle=TVS_SHOWSELALWAYS)
Constructs a CXTPPropertyPageTreeNavigator object.
- Public Member Functions inherited from CXTPPropertyPageControlNavigator
CXTPPropertyPageControlNavigator ()
Constructs a CXTPPropertyPageControlNavigator object.
- Public Member Functions inherited from CXTPPropertyPageNavigator
CXTPPropertyPageNavigator ()
Constructs a CXTPPropertyPageNavigator object.
virtual | ~CXTPPropertyPageNavigator ()
Destroys a CXTPPropertyPageNavigator object, handles cleanup and deallocation.
virtual BOOL | Create ()=0
This method is called to create a page navigator.
virtual void | PageToSize (AFX_SIZEPARENTPARAMS *pLayout, CSize szPage, CRect &rcPage, CSize &szClient)=0
This method is called to reposition a property sheet using the size of a property page.
virtual void | SizeToPage (AFX_SIZEPARENTPARAMS *pLayout, CSize szClient, CRect &rcPage)=0
This method is called to reposition a property page using the size of a property sheet.
virtual void | OnPageSelected (CXTPPropertyPage *pPage)=0
This method is called when a property page becomes selected.
virtual HWND | GetSafeHwnd () const =0
This method is called to get the window handler of a navigator window.
virtual HBRUSH | GetPageBrush (CDC *pDC, CXTPPropertyPage *pPage)=0
Retrieves page brush.
virtual COLORREF | GetPageColor ()=0
Retrieves page color.
virtual void | SetTheme (XTPControlTheme theme)
Call this member to switch the visual theme of the control.

Additional Inherited Members

- Public Attributes inherited from CXTPPropertyPageNavigator
CRect | m_rcNavigatorMargin
Total navigator margin.
CRect | m_rcButtonMargin
Total buttons margin.
CRect | m_rcPageMargin
Total page margin.
- Protected Member Functions inherited from CXTPPropertyPageNavigator
- Protected Attributes inherited from CXTPPropertyPageNavigator
CXTPPropertySheet * | m_pSheet
Parent property sheet object.

Detailed Description

CXTPPropertyPageTreeNavigator is a CTreeCtrl and CXTPPropertyPageControlNavigator derived class.

It represents a tree property page navigator.

See also
CXTPPropertySheet, CXTPPropertySheet::DoModal, CXTPPropertySheet::SetNavigator

Constructor & Destructor Documentation

◆ CXTPPropertyPageTreeNavigator()

CXTPPropertyPageTreeNavigator ( DWORD dwStyle = TVS_SHOWSELALWAYS )

Constructs a CXTPPropertyPageTreeNavigator object.

Parameters
dwStyle Style of the tree control to be used.
The documentation for this class was generated from the following file:
  • XTPPropertyPageNavigator.h


Toolkit Pro: CXTPPropertySheet Class Reference

Public Member Functions | Public Attributes | Protected Member Functions | Protected Attributes | List of all members
CXTPPropertySheet Class Reference

CXTPPropertySheet is a CXTPDialogEx derived class. More...

Inheritance diagram for CXTPPropertySheet:
[legend]

Public Member Functions

CXTPPropertySheet ()
Constructs a CXTPPropertySheet object.
CXTPPropertySheet (UINT nIDCaption, CWnd *pParentWnd=NULL, UINT iSelectPage=0)
Constructs a CXTPPropertySheet object.
CXTPPropertySheet (LPCTSTR pszCaption, CWnd *pParentWnd=NULL, UINT iSelectPage=0)
Constructs a CXTPPropertySheet object.
~CXTPPropertySheet ()
Destroys a CXTPPropertySheet object, handles cleanup and deallocation.
BOOL | Create (CWnd *pParentWnd=NULL, DWORD dwStyle=(DWORD) -1, DWORD dwExStyle=0)
Displays a modeless property sheet.
INT_PTR | DoModal ()
Call this member function to display a modal property sheet.
void | AddPage (CXTPPropertyPage *pPage)
Adds a page to the property sheet.
void | InsertPage (int nIndex, CXTPPropertyPage *pPage)
Adds a page to the property sheet.
void | RemovePage (int nPage)
This member function removes a page from the property sheet and destroys the associated window.
void | RemovePage (CXTPPropertyPage *pPage)
This member function removes a page from the property sheet and destroys the associated window.
int | GetPageCount () const
Call this member function to determine the number of pages currently in the property sheet.
CXTPPropertyPage * | GetPage (int nPage) const
Call this member function to retrieve a pointer to a specified page in the property sheet.
int | GetPageIndex (CXTPPropertyPage *pPage) const
Call this member function to retrieve the index number of a specified page in the property sheet.
CXTPPropertyPage * | GetActivePage () const
Call this member function to retrieve a pointer to the property sheet window's active page.
int | GetActiveIndex () const
Call this member function to retrieve the index number of the property sheet window's active page.
virtual BOOL | SetActivePage (int nPage)
Call this member function to set the active page.
virtual BOOL | SetActivePage (CXTPPropertyPage *pPage)
Call this member function to set the active page.
void | SetTitle (LPCTSTR lpszText)
Call this member function to set the property sheet's caption (the text displayed in the title bar of a frame window).
CRect | GetPageRect () const
Retrieves the CRect bounding rectangle for all property pages.
CXTPPropertyPageNavigator * | GetNavigator () const
Retrieves the currently used navigator object.
void | SetNavigator (CXTPPropertyPageNavigator *pNavigator)
Sets the navigator object that will be used to switch property pages.
virtual BOOL | AddButton (UINT nIDCaption, UINT nID)
Adds a new button to the property sheet window.
void | RemoveButtons ()
Deletes all buttons from the property sheet.
void | SetPageBorderStyle (XTPPropertyPageBorder nBorder)
Sets a border style around a client page rectangle.
XTPPropertyPageBorder | GetPageBorderStyle () const
Retrieves the border style around a client page rectangle.
void | SetResizable (BOOL bResizable=TRUE)
Call this member to allow the user to resize the property sheet.
void | SetPageSize (CSize szPage)
Call this member to set a custom size for property pages.
void | SetPageSizeMin (CSize szPage)
Call this member to set a minimun size for property pages.
void | SetPageSizeMax (CSize szPage)
Call this member to set a maximum size for property pages.
BOOL | SavePlacement (LPCTSTR pszSection)
This member function saves the window placement to the registry.
BOOL | LoadPlacement (LPCTSTR pszSection)
This member function loads saved window placement information from the registry.
BOOL | AutoLoadPlacement (LPCTSTR pszSection)
This member function loads saved window placement information from the registry.
void | UpdatePages ()
Forces all pages to update themselves as the data that they rely on is supposed to be changed from outside.
void | SetTheme (XTPControlTheme theme)
Call this member to switch the visual theme of the control.
XTPControlTheme GetTheme ()
This method is called to retrieve the current theme ID.
- Public Member Functions inherited from CXTPDialogEx
CXTPDialogEx ()
Constructs a CXTPDialogEx object.
CXTPDialogEx (UINT nIDTemplate, CWnd *pParentWnd=NULL)
Constructs a CXTPDialogEx object.
CXTPDialogEx (LPCTSTR lpszTemplateName, CWnd *pParentWnd=NULL)
Constructs a CXTPDialogEx object.
- Public Member Functions inherited from CXTPDialogBase< CDialog >
CXTPDialogBase ()
Constructs a CXTPDialog object.
CXTPDialogBase (UINT nIDTemplate, CWnd *pParentWnd=NULL)
Constructs a CXTPDialog object.
CXTPDialogBase (LPCTSTR lpszTemplateName, CWnd *pParentWnd=NULL)
Constructs a CXTPDialog object.

Public Attributes

PROPSHEETHEADER m_psh
The Windows PROPSHEETHEADER structure.

Protected Member Functions

virtual BOOL | CreateButtons ()
This method is called to create all property sheet buttons.
virtual BOOL | CreatePage (CXTPPropertyPage *pPage)
This method is called to create a property page window.

Protected Attributes

CString | m_strCaption
Caption of the dialog.
LPDLGTEMPLATE | m_lpDlgTemplate
Dialog template.
CArray< CButton *, CButton * > | m_arrButtons
Array of buttons of property sheet.
CXTPPropertyPageNavigator * | m_pNavigator
Currently used navigator.
CXTPFont | m_xtpFontNormal
Font used to draw buttons and navigator.
CArray< CXTPPropertyPage *, CXTPPropertyPage * > | m_arrPages
Array of propety pages.
CXTPPropertyPage * | m_pActivePage
Pointer to active property page.
CRect | m_rcPage
Bounding rectangle of active page.
CRect | m_rcMinPage
Minimum bounding rectangle of active page.
CRect | m_rcMaxPage
Maximum bounding rectangle of active page.
BOOL | m_bAllowApply
TRUE to allow enable apply button.
BOOL | m_bModeless
TRUE if property sheet was created as modeless window.
BOOL | m_bResizable
TRUE if dialog can be resized.
CSize | m_szWindow
Last window size of property sheet.
CSize | m_szButton
Button size.
CXTPScrollBar | m_scSizeIcon
Resize glyph.
XTPPropertyPageBorder | m_nPageBorderStyle
Client border style.

Detailed Description

CXTPPropertySheet is a CXTPDialogEx derived class.

It represents a property sheet, otherwise known as a tab dialog box. A property sheet consists of a CXTPPropertySheet object and one or more CXTPPropertyPage objects.

See also
CXTPPropertySheet::DoModal, CXTPPropertyPage, CXTPPropertyPageNavigator

Constructor & Destructor Documentation

◆ CXTPPropertySheet() [1/3]

CXTPPropertySheet ( )

Constructs a CXTPPropertySheet object.

To display the property sheet, call DoModal or Create. The string contained in the first parameter will be placed in the caption bar for the property sheet.

◆ CXTPPropertySheet() [2/3]

CXTPPropertySheet | ( | UINT | nIDCaption,
 |  | CWnd * | pParentWnd = NULL,
 |  | UINT | iSelectPage = 0 )

Constructs a CXTPPropertySheet object.

Parameters
nIDCaption | ID of the caption to be used for the property sheet.
pParentWnd | Pointer to the parent window of the property sheet. If NULL, the parent window will be the main window of the application.
iSelectPage | The index of the page that will initially be on top. Default is the first page added to the sheet.

To display the property sheet, call DoModal or Create. The string contained in the first parameter will be placed in the caption bar for the property sheet.

◆ CXTPPropertySheet() [3/3]

CXTPPropertySheet | ( | LPCTSTR | pszCaption,
 |  | CWnd * | pParentWnd = NULL,
 |  | UINT | iSelectPage = 0 )

Constructs a CXTPPropertySheet object.

Parameters
pszCaption | Pointer to a string containing the caption to be used for the property sheet. Cannot be NULL.
pParentWnd | Pointer to the parent window of the property sheet. If NULL, the parent window will be the main window of the application.
iSelectPage | The index of the page that will initially be on top. Default is the first page added to the sheet.

To display the property sheet, call DoModal or Create. The string contained in the first parameter will be placed in the caption bar for the property sheet.

Member Function Documentation

◆ AddButton()

virtual BOOL AddButton | ( | UINT | nIDCaption,
 |  | UINT | nID )
 virtual

Adds a new button to the property sheet window.

Parameters
nIDCaption | ID of the caption to be used for the property sheet button.
nID | Identifier to be used for the property sheet button.
Returns
Nonzero if the property sheet is activated successfully, otherwise 0.
See also
CXTPPropertySheet::RemoveButtons

◆ AddPage()

void AddPage ( CXTPPropertyPage * pPage )

Adds a page to the property sheet.

Parameters
pPage Pointer to the page to be added to the property sheet. Cannot be NULL.

This member function adds the supplied page with the rightmost tab in the property sheet. Add pages to the property sheet in the left-to-right order you want them to appear.

AddPage adds the CPropertyPage object to the CPropertySheet object's list of pages but does not actually create the window for the page. The framework postpones creation of the window for the page until the user selects that page.

See also
CXTPPropertySheet::GetPageCount

◆ AutoLoadPlacement()

BOOL AutoLoadPlacement ( LPCTSTR pszSection )

This member function loads saved window placement information from the registry.

This version is the same as LoadPlacement but there is no need for calling SavePlacement when the window is destroyed. This will be called automatically.

Parameters
pszSection Name of a section in the initialization file or a key in the Windows registry where placement information is stored.
Returns
TRUE if position was changed.

◆ Create()

BOOL Create | ( | CWnd * | pParentWnd = NULL,
 |  | DWORD | dwStyle = (DWORD) -1,
 |  | DWORD | dwExStyle = 0 )

Displays a modeless property sheet.

Parameters
pParentWnd | Pointer to the parent window. If NULL, the parent is the desktop.
dwStyle | Window styles for property sheet.
dwExStyle | Extended window styles for property sheet.

The default style, expressed by passing -1 as dwStyle, is actually WS_SYSMENU | WS_POPUP | WS_CAPTION | DS_MODALFRAME | DS_CONTEXT_HELP | WS_VISIBLE.

To display a modal property sheet, call DoModal instead.

Returns
TRUE if successful, FALSE otherwise.
See also
CXTPPropertySheet::DoModal

◆ CreateButtons()

virtual BOOL CreateButtons ( )
protectedvirtual

This method is called to create all property sheet buttons.

Returns
TRUE if successful, otherwise FALSE.

◆ CreatePage()

virtual BOOL CreatePage ( CXTPPropertyPage * pPage )
protectedvirtual

This method is called to create a property page window.

Parameters
pPage Page to be created.
Returns
TRUE if successful, otherwise FALSE.

◆ DoModal()

INT_PTR DoModal ( )

Call this member function to display a modal property sheet.

Returns
IDOK or IDCANCEL if the function was successful, otherwise 0 or -1.

The return value corresponds to the ID of the control that closed the property sheet. After this function returns, the windows corresponding to the property sheet and all the pages will have been destroyed.

To display a modeless property sheet, call Create instead.

See also
CXTPPropertySheet::Create

◆ GetActiveIndex()

int GetActiveIndex ( ) const

Call this member function to retrieve the index number of the property sheet window's active page.

Returns
The index number of the property sheet window's active page.

The return value for this method can be used as the parameter for GetPage.

See also
CXTPPropertySheet::GetActivePage

◆ GetActivePage()

CXTPPropertyPage * GetActivePage ( ) const

Call this member function to retrieve a pointer to the property sheet window's active page.

Returns
The pointer to the property sheet window's active page.

This method can be used to perform some action on the active page.

See also
CXTPPropertySheet::GetPage

◆ GetNavigator()

CXTPPropertyPageNavigator * GetNavigator ( ) const

Retrieves the currently used navigator object.

Returns
A CXTPPropertyPageNavigator class pointer.
See also
CXTPPropertySheet::SetNavigator

◆ GetPage()

CXTPPropertyPage * GetPage ( int nPage ) const

Call this member function to retrieve a pointer to a specified page in the property sheet.

Parameters
nPage Index of the desired page, starting at 0. Must be between 0 and one less than the number of pages in the property sheet, inclusive.
Returns
The pointer to the page corresponding to the nPage parameter.
See also
CXTPPropertySheet::AddPage, CXTPPropertySheet::GetPageCount

◆ GetPageBorderStyle()

XTPPropertyPageBorder GetPageBorderStyle ( ) const

Retrieves the border style around a client page rectangle.

Returns
An XTPPropertyPageBorder border style.
See also
XTPPropertyPageBorder, CXTPPropertySheet::SetPageBorderStyle

◆ GetPageCount()

int GetPageCount ( ) const

Call this member function to determine the number of pages currently in the property sheet.

Returns
The number of pages in the property sheet.
See also
CXTPPropertySheet::AddPage, CXTPPropertySheet::GetPage

◆ GetPageIndex()

int GetPageIndex ( CXTPPropertyPage * pPage ) const

Call this member function to retrieve the index number of a specified page in the property sheet.

Parameters
pPage Pointer to the page with the index to be found. Cannot be NULL.
Returns
The index number of the page corresponding to the pPage parameter.

This method can be used to get the page index number for the SetActivePage or GetPage methods.

See also
CXTPPropertySheet::GetActivePage

◆ GetPageRect()

CRect GetPageRect ( ) const

Retrieves the CRect bounding rectangle for all property pages.

Returns
The CRect bounding rectangle for all property pages.

◆ GetTheme()

XTPControlTheme GetTheme ( )

This method is called to retrieve the current theme ID.

Returns
A XTPControlTheme value representing the current theme.

◆ InsertPage()

void InsertPage | ( | int | nIndex,
 |  | CXTPPropertyPage * | pPage )

Adds a page to the property sheet.

Parameters
nIndex | Index to insert the page.
pPage | Pointer to the page to be added to the property sheet. Cannot be NULL.

This member function adds the supplied page with the rightmost tab in the property sheet. Add pages to the property sheet in the left-to-right order you want them to appear.

AddPage adds the CPropertyPage object to the CPropertySheet object's list of pages but does not actually create the window for the page. The framework postpones creation of the window for the page until the user selects that page.

See also
CXTPPropertySheet::GetPageCount

◆ LoadPlacement()

BOOL LoadPlacement ( LPCTSTR pszSection )

This member function loads saved window placement information from the registry.

Parameters
pszSection Name of a section in the initialization file or a key in the Windows registry where placement information is stored.
Returns
TRUE if position was changed.

◆ RemoveButtons()

void RemoveButtons ( )

Deletes all buttons from the property sheet.

See also
CXTPPropertySheet::AddButton

◆ RemovePage() [1/2]

void RemovePage ( CXTPPropertyPage * pPage )

This member function removes a page from the property sheet and destroys the associated window.

Parameters
pPage Pointer to the page to be removed from the property sheet. Cannot be NULL. the number of pages in the property sheet, inclusive.
See also
CXTPPropertySheet::AddPage

◆ RemovePage() [2/2]

void RemovePage ( int nPage )

This member function removes a page from the property sheet and destroys the associated window.

\

Parameters
nPage Index of the page to be removed. Must be between 0 and one less than the number of pages in the property sheet, inclusive.
See also
CXTPPropertySheet::AddPage

◆ SavePlacement()

BOOL SavePlacement ( LPCTSTR pszSection )

This member function saves the window placement to the registry.

Parameters
pszSection Name of a section in the initialization file or a key in the Windows registry where placement information is stored.
Returns
TRUE if successful.

◆ SetActivePage() [1/2]

virtual BOOL SetActivePage ( CXTPPropertyPage * pPage )
virtual

Call this member function to set the active page.

Parameters
pPage Pointer to the page to set in the property sheet. It cannot be NULL.
Returns
Nonzero if the property sheet is activated successfully, otherwise 0.

This method should be used if a user's action on one page should cause another page to become the active page.

See also
CXTPPropertySheet::GetActivePage

◆ SetActivePage() [2/2]

virtual BOOL SetActivePage ( int nPage )
virtual

Call this member function to set the active page.

Parameters
nPage Index of the page to set. It must be between 0 and one less than the number of pages in the property sheet, inclusive.
Returns
Nonzero if the property sheet is activated successfully, otherwise 0.

This method should be used if a user's action on one page should cause another page to become the active page.

See also
CXTPPropertySheet::GetActivePage

◆ SetNavigator()

void SetNavigator ( CXTPPropertyPageNavigator * pNavigator )

Sets the navigator object that will be used to switch property pages.

Parameters
pNavigator A CXTPPropertyPageNavigator class pointer that will be set as the new navigator object

CXTPPropertyPageNavigator class used to specify how the user will navigate and switch pages. Default navigator classes are: CXTPPropertyPageTabNavigator: Represents TabControl navigator. CXTPPropertyPageListNavigator: Represents List navigator. CXTPPropertyPageTreeNavigator: Represents Tree navigator. Example:

CXTPPropertyPageListNavigator* pList = new CXTPPropertyPageListNavigator();
pList->SetListStyle(xtpListBoxOffice2007);
ps.SetNavigator(pList);
See also
CXTPPropertySheet::GetNavigator

◆ SetPageBorderStyle()

void SetPageBorderStyle ( XTPPropertyPageBorder nBorder )

Sets a border style around a client page rectangle.

Parameters
nBorder Border style to be set.
See also
XTPPropertyPageBorder, CXTPPropertySheet::GetPageBorderStyle

◆ SetPageSize()

void SetPageSize ( CSize szPage )

Call this member to set a custom size for property pages.

Parameters
szPage New property page size to be set.

◆ SetPageSizeMax()

void SetPageSizeMax ( CSize szPage )

Call this member to set a maximum size for property pages.

Parameters
szPage New property page maximum size to be set.

◆ SetPageSizeMin()

void SetPageSizeMin ( CSize szPage )

Call this member to set a minimun size for property pages.

Parameters
szPage New property page minimun size to be set.

◆ SetResizable()

void SetResizable ( BOOL bResizable = TRUE )

Call this member to allow the user to resize the property sheet.

Parameters
bResizable TRUE to allow the user to resize the property sheet. By default, this parameter is TRUE.

◆ SetTheme()

void SetTheme ( XTPControlTheme theme )

Call this member to switch the visual theme of the control.

Parameters
theme New visual theme. Can be any of the values listed in the Remarks section.

nTheme can be one of the theme IDs specified by XTPControlTheme.

See also
XTPControlTheme

◆ SetTitle()

void SetTitle ( LPCTSTR lpszText )

Call this member function to set the property sheet's caption (the text displayed in the title bar of a frame window).

Parameters
lpszText Pointer to the text to be used as the caption in the title bar of the property sheet.
See also
CXTPPropertySheet::GetPage

Member Data Documentation

◆ m_psh

PROPSHEETHEADER m_psh

The Windows PROPSHEETHEADER structure.

Provides access to basic property sheet parameters.

The documentation for this class was generated from the following file:
  • XTPPropertySheet.h


Toolkit Pro: CXTPPropExchange Class Reference

Public Member Functions | Public Attributes | Static Public Attributes | Protected Member Functions | Protected Attributes | List of all members
CXTPPropExchange Class Referenceabstract

CXTPPropExchange is standalone pure class. More...

Inheritance diagram for CXTPPropExchange:
[legend]

Public Member Functions

CXTPPropExchange ()
Constructs a CXTPPropExchange object.
virtual | ~CXTPPropExchange ()
Destroys a CXTPPropExchange object, handles cleanup and de- allocation.
BOOL | IsLoading () const
This method determines whether properties are being loaded to the class or stored from it.
BOOL | IsStoring () const
This method determines whether properties are being loaded to the class or stored from it.
void | UseDefaultOnLoad (BOOL bUseDefaultOnLoad=TRUE)
Call this method to use default values specified in PX_* functions while load process.
void | UseDefaultOnSave (BOOL bUseDefaultOnSave=TRUE)
Call this method to use default values specified in PX_* functions while save process.
BOOL | IsRootSection () const
Determines if CXTPPropExchange is used as root section.
UINT | GetSchema () const
Gets schema version number associated with the data format being serialized/de-serialized.
void | SetSchema (UINT nSchemaVersion)
Sets schema version number associated with the data format being serialized/de-serialized.
virtual BOOL | ExchangeProp (LPCTSTR pszPropName, VARTYPE vtProp, void *pvProp, const void *pvDefault=NULL)=0
Exchanges a property between a storage and the class.
virtual BOOL | ExchangeBlobProp (LPCTSTR pszPropName, BYTE *&pData, DWORD &nBytes)
This method serializes a property that stores binary large object (BLOB) data.
virtual BOOL | ExchangeRuntimeClass (LPCTSTR pszPropName, CRuntimeClass *&pClass, CRuntimeClass *pDefaultClass)
Exchanges a CRuntimeClass between a storage and the class.
virtual BOOL | ExchangeObjectInstance (CObject *&pObject, CRuntimeClass *pObjectRuntime)
Exchanges a class instance.
virtual CArchive * | GetArchive (LPCTSTR pszPropName)
This method create new Archive to serialize.
virtual void | ReleaseArchive (LPCTSTR pszPropName, CArchive *pArchive)
This method releases CArchive pointer.
void | ExchangeSchema ()
Call this function to serialize or initialize the state of a class's version information.
void | ExchangeLocale ()
Call this function to serialize or initialize the state of a user locale.
virtual CXTPPropExchange * | GetSection (LPCTSTR lpszSection)=0
This method creates new section for text base storages (CXTPPropExchangeXMLNode and CXTPPropExchangeRegistry)
virtual void | EmptySection ()
Call this method to free section information before storing.
virtual void | WriteCount (DWORD dwCount)
Use this member function to Write DWORD number to storage.
virtual DWORD | ReadCount ()
Use this member function to read DWORD number from storage.
virtual void | Write (LPCTSTR pszPropName, const void *lpBuf, UINT nCount)
Writes a specified number of bytes.
virtual UINT | Read (LPCTSTR pszPropName, void *lpBuf, UINT nCount)
Reads a specified number of bytes.
virtual BOOL | IsAllowDefaultValues () const
Call this method to determine if storage supported default values.
virtual BOOL | IsAllowBlobValues () const
Call this method to determine if storage allows exchange plain blob values.
virtual BOOL | OnBeforeExchange ()
This method is called before exchange properties.
virtual CXTPPropExchangeEnumerator * | GetEnumerator (LPCTSTR lpszSection)
Call this method to enumerate child sections.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Public Attributes

DWORD_PTR | m_dwData
User-defined 32-bit value.
CObject * | m_pOwner
User-defined Owner value.

Static Public Attributes

static LCID m_lcidDateTime
User regional language.

Protected Member Functions

void InitSection (CXTPPropExchange *pRootSection)
This methods is called to copy internal data from root section.

Protected Attributes

BOOL | m_bLoading
TRUE if properties are being loaded to the class.
UINT | m_nSchema
Schema of object.
BOOL | m_bChildSection
TRUE if section is child.
BOOL | m_bEmptySection
TRUE if EmptySection method was called.
BOOL | m_bInitialized
TRUE if section was initialized.
BOOL | m_bUseDefaultOnLoad
TRUE if default values must be used in load process.
BOOL | m_bUseDefaultOnSave
TRUE if default values must be used in save process.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

CXTPPropExchange is standalone pure class.

The CXTPPropExchange class allows you to save a complex network of objects in a permanent binary or text form (usually disk storage) that persists after those objects are deleted. Later you can load the objects from persistent storage, reconstituting them in memory. This process of making data persistent is called 'serialization.'

You can use one of derived classes: CXTPPropExchangeArchive to serialize to archive, CXTPPropExchangeRegistry to serialize to registry key, CXTPPropExchangeXMLNode to serialize to XML node.

Example:

CXTPPropExchangeXMLNode px(TRUE, 0, _T("Settings"));
if (px.LoadFromFile(m_strIniFileName))
{
   m_wndTaskPanel.GetGroups()->DoPropExchange(&px);
}

Member Function Documentation

◆ ExchangeBlobProp()

virtual BOOL ExchangeBlobProp | ( | LPCTSTR | pszPropName,
 |  | BYTE *& | pData,
 |  | DWORD & | nBytes )
 virtual

This method serializes a property that stores binary large object (BLOB) data.

Parameters
pszPropName | The name of the property being exchanged.
pData | A pointer to a user-supplied buffer that contains the data to be serialized
nBytes | An integer that specifies the number of bytes to be read or written.
Returns
Nonzero if the exchange was successful; 0 if unsuccessful.

Reimplemented in CXTPPropExchangeArchive, and CXTPPropExchangeRegistry.

◆ ExchangeObjectInstance()

virtual BOOL ExchangeObjectInstance | ( | CObject *& | pObject,
 |  | CRuntimeClass * | pObjectRuntime )
 virtual

Exchanges a class instance.

Parameters
pObject | Object being exchanged.
pObjectRuntime | Default RUntime class of object
Returns
Nonzero if the exchange was successful; 0 if unsuccessful.

Reimplemented in CXTPPropExchangeArchive.

◆ ExchangeProp()

virtual BOOL ExchangeProp | ( | LPCTSTR | pszPropName,
 |  | VARTYPE | vtProp,
 |  | void * | pvProp,
 |  | const void * | pvDefault = NULL )
 pure virtual

Exchanges a property between a storage and the class.

Parameters
pszPropName | The name of the property being exchanged.
vtProp | A symbol specifying the type of the property being exchanged.
pvProp | A pointer to the property's value.
pvDefault | Pointer to a default value for the property.

Possible values of properties are:

Symbol         Property Type
-------------  -------------
VT_I2          short
VT_I4          long
VT_BOOL        BOOL
VT_BSTR        CString
VT_CY          CY
VT_R4          float
VT_R8          double
Returns
Nonzero if the exchange was successful; 0 if unsuccessful.

Implemented in CXTPPropExchangeArchive, CXTPPropExchangeIniFile, CXTPPropExchangeRegistry, and CXTPPropExchangeXMLNode.

◆ ExchangeRuntimeClass()

virtual BOOL ExchangeRuntimeClass | ( | LPCTSTR | pszPropName,
 |  | CRuntimeClass *& | pClass,
 |  | CRuntimeClass * | pDefaultClass )
 virtual

Exchanges a CRuntimeClass between a storage and the class.

Parameters
pszPropName | The name of the property being exchanged.
pClass | CRuntimeClass class pointer.
pDefaultClass | Pointer to a default runtime class for the property.
Returns
Nonzero if the exchange was successful; 0 if unsuccessful.

Reimplemented in CXTPPropExchangeArchive.

◆ GetArchive()

virtual CArchive * GetArchive ( LPCTSTR pszPropName )
virtual

This method create new Archive to serialize.

Parameters
pszPropName The name of the property being exchanged.
Returns
CArchive pointer. You must call ReleaseArchive to free memory.
See also
ReleaseArchive

Reimplemented in CXTPPropExchangeArchive.

◆ GetEnumerator()

virtual CXTPPropExchangeEnumerator * GetEnumerator ( LPCTSTR lpszSection )
virtual

Call this method to enumerate child sections.

Parameters
lpszSection child section name.
Returns
Returns an enumerator for child sections.

Example:

extern CXTPPropExchange* pPX;

CXTPPropExchangeEnumeratorPtr pEnumerator(pPX->GetEnumerator(_T("Icon")));
POSITION posEnum = pEnumerator->GetPosition();

while (posEnum)
{
   CXTPPropExchangeSection secIcon(pEnumerator->GetNext(posEnum));
}
See also
CXTPPropExchangeEnumerator

Reimplemented in CXTPPropExchangeXMLNode.

◆ GetSchema()

UINT GetSchema ( ) const

Gets schema version number associated with the data format being serialized/de-serialized.

Setting a custom schema number requires extreme caution and confidence in the correct value as using a wrong value will result in unexpected behavior when data exchange is performed. The current schema version number can be identified by the _XTP_SCHEMA_CURRENT constant.

Returns
The schema version number associated with the data format.

◆ GetSection()

virtual CXTPPropExchange * GetSection ( LPCTSTR lpszSection )
pure virtual

This method creates new section for text base storages (CXTPPropExchangeXMLNode and CXTPPropExchangeRegistry)

Parameters
lpszSection The name of the section.
Returns
CXTPPropExchange pointer to new section. You must delete this pointer or use CXTPPropExchangeSection to manage it.

Example:

CXTPPropExchangeSection pxTaskPanel(px.GetSection(_T("TaskPanel")));
m_wndTaskPanel.GetGroups()->DoPropExchange(&pxTaskPanel);

Implemented in CXTPPropExchangeArchive, CXTPPropExchangeIniFile, CXTPPropExchangeRegistry, and CXTPPropExchangeXMLNode.

◆ InitSection()

void InitSection ( CXTPPropExchange * pRootSection )
protected

This methods is called to copy internal data from root section.

Parameters
pRootSection Parent section

◆ IsAllowBlobValues()

virtual BOOL IsAllowBlobValues ( ) const
virtual

Call this method to determine if storage allows exchange plain blob values.

Returns
TRUE if storage allows exchange plain blob values.

Reimplemented in CXTPPropExchangeArchive, and CXTPPropExchangeRegistry.

◆ IsAllowDefaultValues()

virtual BOOL IsAllowDefaultValues ( ) const
virtual

Call this method to determine if storage supported default values.

Returns
TRUE if storage allows default values

Reimplemented in CXTPPropExchangeArchive.

◆ IsLoading()

BOOL IsLoading ( ) const

This method determines whether properties are being loaded to the class or stored from it.

Returns
Nonzero if properties are being loaded; otherwise, it is zero.

◆ IsRootSection()

BOOL IsRootSection ( ) const

Determines if CXTPPropExchange is used as root section.

Returns
TRUE if CXTPPropExchange object it root section.

Used only in CXTPPropExchangeXMLNode and CXTPPropExchangeRegistry classes

See also
GetSection

◆ IsStoring()

BOOL IsStoring ( ) const

This method determines whether properties are being loaded to the class or stored from it.

Returns
Nonzero if the properties are currently being used for storing; otherwise 0.

◆ OnBeforeExchange()

virtual BOOL OnBeforeExchange ( )
virtual

This method is called before exchange properties.

Returns
TRUE if storage ready to exchange properties.

Reimplemented in CXTPPropExchangeIniFile, CXTPPropExchangeRegistry, and CXTPPropExchangeXMLNode.

◆ Read()

virtual UINT Read | ( | LPCTSTR | pszPropName,
 |  | void * | lpBuf,
 |  | UINT | nCount )
 virtual

Reads a specified number of bytes.

Parameters
pszPropName | The name of the property being exchanged.
lpBuf | A pointer to a user-supplied buffer that is to receive the data
nCount | An unsigned integer specifying the number of bytes to be read from the archive.
Returns
An unsigned integer containing the number of bytes actually read.

Reimplemented in CXTPPropExchangeArchive.

◆ ReadCount()

virtual DWORD ReadCount ( )
virtual

Use this member function to read DWORD number from storage.

Returns
DWORD number
See also
WriteCount

Reimplemented in CXTPPropExchangeArchive.

◆ ReleaseArchive()

virtual void ReleaseArchive | ( | LPCTSTR | pszPropName,
 |  | CArchive * | pArchive )
 virtual

This method releases CArchive pointer.

Parameters
pszPropName | The name of the property being exchanged.
pArchive | Archive pointer was previously returned by GetArchive member.
See also
GetArchive

Reimplemented in CXTPPropExchangeArchive.

◆ SetSchema()

void SetSchema ( UINT nSchemaVersion )

Sets schema version number associated with the data format being serialized/de-serialized.

Setting a custom schema number requires extreme caution and confidence in the correct value as using a wrong value will result in unexpected behavior when data exchange is performed. The current schema version number can be identified by the _XTP_SCHEMA_CURRENT constant.

Parameters
nSchemaVersion Identifies the schema version

◆ UseDefaultOnLoad()

void UseDefaultOnLoad ( BOOL bUseDefaultOnLoad = TRUE )

Call this method to use default values specified in PX_* functions while load process.

Parameters
bUseDefaultOnLoad TRUE to use default value; FALSE to ignore it.
See also
UseDefaultOnSave, PX_String, PX_Int, PX_Bool

◆ UseDefaultOnSave()

void UseDefaultOnSave ( BOOL bUseDefaultOnSave = TRUE )

Call this method to use default values specified in PX_* functions while save process.

Parameters
bUseDefaultOnSave TRUE to use default value; FALSE to ignore it.
See also
UseDefaultOnLoad, PX_String, PX_Int, PX_Bool

◆ Write()

virtual void Write | ( | LPCTSTR | pszPropName,
 |  | const void * | lpBuf,
 |  | UINT | nCount )
 virtual

Writes a specified number of bytes.

Parameters
pszPropName | The name of the property being exchanged.
lpBuf | A pointer to a user-supplied buffer that contains the data to be written.
nCount | An integer that specifies the number of bytes to be written.

Reimplemented in CXTPPropExchangeArchive.

◆ WriteCount()

virtual void WriteCount ( DWORD dwCount )
virtual

Use this member function to Write DWORD number to storage.

Parameters
dwCount DWORD number
See also
ReadCount

Reimplemented in CXTPPropExchangeArchive.

The documentation for this class was generated from the following file:
  • XTPPropExchange.h


Toolkit Pro: CXTPPropExchangeArchive Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPPropExchangeArchive Class Reference

CXTPPropExchangeArchive is CXTPPropExchange derived class. More...

Inheritance diagram for CXTPPropExchangeArchive:
[legend]

Public Member Functions

CXTPPropExchangeArchive (CArchive &ar)
Constructs a CXTPPropExchangeArchive object.
virtual BOOL | ExchangeProp (LPCTSTR pszPropName, VARTYPE vtProp, void *pvProp, const void *pvDefault=NULL)
Exchanges a property between a storage medium and the control.
virtual BOOL | ExchangeBlobProp (LPCTSTR pszPropName, BYTE *&pData, DWORD &nBytes)
This method serializes a property that stores binary large object (BLOB) data.
virtual BOOL | ExchangeRuntimeClass (LPCTSTR pszPropName, CRuntimeClass *&pClass, CRuntimeClass *pDefaultClass)
Exchanges a CRuntimeClass between a storage and the class.
virtual BOOL | ExchangeObjectInstance (CObject *&pObject, CRuntimeClass *pObjectRuntime)
Exchanges a class instance.
virtual CArchive * | GetArchive (LPCTSTR pszPropName)
This method create new Archive to serialize.
virtual void | ReleaseArchive (LPCTSTR pszPropName, CArchive *pArchive)
This method releases CArchive pointer.
virtual void | Write (LPCTSTR pszPropName, const void *lpBuf, UINT nCount)
Writes a specified number of bytes.
virtual UINT | Read (LPCTSTR pszPropName, void *lpBuf, UINT nCount)
Reads a specified number of bytes.
virtual BOOL | IsAllowDefaultValues () const
Call this method to determine if storage supported default values.
virtual BOOL | IsAllowBlobValues () const
Call this method to determine if storage allows exchange plain blob values.
CXTPPropExchange * | GetSection (LPCTSTR lpszSection)
This method creates new section for text base storages (CXTPPropExchangeXMLNode and CXTPPropExchangeRegistry)
virtual void | WriteCount (DWORD dwCount)
Use this member function to write DWORD number to storage.
virtual DWORD | ReadCount ()
Use this member function to read DWORD number from storage.
- Public Member Functions inherited from CXTPPropExchange
CXTPPropExchange ()
Constructs a CXTPPropExchange object.
virtual | ~CXTPPropExchange ()
Destroys a CXTPPropExchange object, handles cleanup and de- allocation.
BOOL | IsLoading () const
This method determines whether properties are being loaded to the class or stored from it.
BOOL | IsStoring () const
This method determines whether properties are being loaded to the class or stored from it.
void | UseDefaultOnLoad (BOOL bUseDefaultOnLoad=TRUE)
Call this method to use default values specified in PX_* functions while load process.
void | UseDefaultOnSave (BOOL bUseDefaultOnSave=TRUE)
Call this method to use default values specified in PX_* functions while save process.
BOOL | IsRootSection () const
Determines if CXTPPropExchange is used as root section.
UINT | GetSchema () const
Gets schema version number associated with the data format being serialized/de-serialized.
void | SetSchema (UINT nSchemaVersion)
Sets schema version number associated with the data format being serialized/de-serialized.
void | ExchangeSchema ()
Call this function to serialize or initialize the state of a class's version information.
void | ExchangeLocale ()
Call this function to serialize or initialize the state of a user locale.
virtual void | EmptySection ()
Call this method to free section information before storing.
virtual BOOL | OnBeforeExchange ()
This method is called before exchange properties.
virtual CXTPPropExchangeEnumerator * | GetEnumerator (LPCTSTR lpszSection)
Call this method to enumerate child sections.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Attributes

CSelfArchive & | m_ar
Contains the underlying CArchive for this CXTPPropExchangeArchive object.
- Protected Attributes inherited from CXTPPropExchange
BOOL | m_bLoading
TRUE if properties are being loaded to the class.
UINT | m_nSchema
Schema of object.
BOOL | m_bChildSection
TRUE if section is child.
BOOL | m_bEmptySection
TRUE if EmptySection method was called.
BOOL | m_bInitialized
TRUE if section was initialized.
BOOL | m_bUseDefaultOnLoad
TRUE if default values must be used in load process.
BOOL | m_bUseDefaultOnSave
TRUE if default values must be used in save process.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPPropExchange
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPPropExchange
DWORD_PTR | m_dwData
User-defined 32-bit value.
CObject * | m_pOwner
User-defined Owner value.
- Static Public Attributes inherited from CXTPPropExchange
static LCID | m_lcidDateTime
User regional language.
- Protected Member Functions inherited from CXTPPropExchange
void | InitSection (CXTPPropExchange *pRootSection)
This methods is called to copy internal data from root section.

Detailed Description

CXTPPropExchangeArchive is CXTPPropExchange derived class.

The CXTPPropExchangeArchive class allows you to save a complex network of objects in a permanent binary form (usually disk storage) that persists after those objects are deleted. Later you can load the objects from persistent storage, reconstituting them in memory. This process of making data persistent is called 'serialization.'

Example:

CFile myFile("myfile", CFile::modeCreate | CFile::modeWrite);

// Create a storing archive.
CArchive arStore(&myFile, CArchive::store);
CXTPPropExchangeArchive px(arStore);
PX_String(&px, _T("Caption"), m_strCaption);

Constructor & Destructor Documentation

◆ CXTPPropExchangeArchive()

CXTPPropExchangeArchive ( CArchive & ar )

Constructs a CXTPPropExchangeArchive object.

Parameters
ar A reference to the CArchive object that is the ultimate source or destination of the persistent data.

Member Function Documentation

◆ ExchangeBlobProp()

virtual BOOL ExchangeBlobProp | ( | LPCTSTR | pszPropName,
 |  | BYTE *& | pData,
 |  | DWORD & | nBytes )
 virtual

This method serializes a property that stores binary large object (BLOB) data.

Parameters
pszPropName | The name of the property being exchanged.
pData | A pointer to a user-supplied buffer that contains the data to be serialized
nBytes | An integer that specifies the number of bytes to be read or written.
Returns
Nonzero if the exchange was successful; 0 if unsuccessful.

Reimplemented from CXTPPropExchange.

◆ ExchangeObjectInstance()

virtual BOOL ExchangeObjectInstance | ( | CObject *& | pObject,
 |  | CRuntimeClass * | pObjectRuntime )
 virtual

Exchanges a class instance.

Parameters
pObject | Object being exchanged.
pObjectRuntime | Default RUntime class of object
Returns
Nonzero if the exchange was successful; 0 if unsuccessful.

Reimplemented from CXTPPropExchange.

◆ ExchangeProp()

virtual BOOL ExchangeProp | ( | LPCTSTR | pszPropName,
 |  | VARTYPE | vtProp,
 |  | void * | pvProp,
 |  | const void * | pvDefault = NULL )
 virtual

Exchanges a property between a storage medium and the control.

Parameters
pszPropName | The name of the property being exchanged.
vtProp | A symbol specifying the type of the property being exchanged.
pvProp | A pointer to the property's value.
pvDefault | Pointer to a default value for the property.

Possible values of properties are:

Symbol         Property Type
-------------  -------------
VT_I2          short
VT_I4          long
VT_BOOL        BOOL
VT_BSTR        CString
VT_CY          CY
VT_R4          float
VT_R8          double
Returns
Nonzero if the exchange was successful; 0 if unsuccessful.

Implements CXTPPropExchange.

◆ ExchangeRuntimeClass()

virtual BOOL ExchangeRuntimeClass | ( | LPCTSTR | pszPropName,
 |  | CRuntimeClass *& | pClass,
 |  | CRuntimeClass * | pDefaultClass )
 virtual

Exchanges a CRuntimeClass between a storage and the class.

Parameters
pszPropName | The name of the property being exchanged.
pClass | CRuntimeClass class pointer.
pDefaultClass | Pointer to a default runtime class for the property.
Returns
Nonzero if the exchange was successful; 0 if unsuccessful.

Reimplemented from CXTPPropExchange.

◆ GetArchive()

virtual CArchive * GetArchive ( LPCTSTR pszPropName )
virtual

This method create new Archive to serialize.

Parameters
pszPropName The name of the property being exchanged.
Returns
CArchive pointer. You must call ReleaseArchive to free memory.
See also
ReleaseArchive

Reimplemented from CXTPPropExchange.

◆ GetSection()

CXTPPropExchange * GetSection ( LPCTSTR lpszSection )
virtual

This method creates new section for text base storages (CXTPPropExchangeXMLNode and CXTPPropExchangeRegistry)

Parameters
lpszSection The name of the section.
Returns
CXTPPropExchange pointer to new section. You must delete this pointer or use CXTPPropExchangeSection to manage it.

Example:

CXTPPropExchangeSection pxTaskPanel(px.GetSection(_T("TaskPanel")));
m_wndTaskPanel.GetGroups()->DoPropExchange(&pxTaskPanel);

Implements CXTPPropExchange.

◆ IsAllowBlobValues()

virtual BOOL IsAllowBlobValues ( ) const
virtual

Call this method to determine if storage allows exchange plain blob values.

Returns
TRUE if storage allows exchange plain blob values.

Reimplemented from CXTPPropExchange.

◆ IsAllowDefaultValues()

virtual BOOL IsAllowDefaultValues ( ) const
virtual

Call this method to determine if storage supported default values.

Returns
TRUE if storage allows default values

Reimplemented from CXTPPropExchange.

◆ Read()

virtual UINT Read | ( | LPCTSTR | pszPropName,
 |  | void * | lpBuf,
 |  | UINT | nCount )
 virtual

Reads a specified number of bytes.

Parameters
pszPropName | The name of the property being exchanged.
lpBuf | A pointer to a user-supplied buffer that is to receive the data
nCount | An unsigned integer specifying the number of bytes to be read from the archive.
Returns
An unsigned integer containing the number of bytes actually read.

Reimplemented from CXTPPropExchange.

◆ ReadCount()

virtual DWORD ReadCount ( )
virtual

Use this member function to read DWORD number from storage.

Returns
DWORD number
See also
WriteCount

Reimplemented from CXTPPropExchange.

◆ ReleaseArchive()

virtual void ReleaseArchive | ( | LPCTSTR | pszPropName,
 |  | CArchive * | pArchive )
 virtual

This method releases CArchive pointer.

Parameters
pszPropName | The name of the property being exchanged.
pArchive | Archive pointer was previously returned by GetArchive member.
See also
GetArchive

Reimplemented from CXTPPropExchange.

◆ Write()

virtual void Write | ( | LPCTSTR | pszPropName,
 |  | const void * | lpBuf,
 |  | UINT | nCount )
 virtual

Writes a specified number of bytes.

Parameters
pszPropName | The name of the property being exchanged.
lpBuf | A pointer to a user-supplied buffer that contains the data to be written.
nCount | An integer that specifies the number of bytes to be written.

Reimplemented from CXTPPropExchange.

◆ WriteCount()

virtual void WriteCount ( DWORD dwCount )
virtual

Use this member function to write DWORD number to storage.

Parameters
dwCount DWORD number
See also
ReadCount

Reimplemented from CXTPPropExchange.

The documentation for this class was generated from the following file:
  • XTPPropExchangeArchive.h


Toolkit Pro: CXTPPropExchangeEnumerator Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPPropExchangeEnumerator Class Reference

CXTPPropExchangeEnumerator is standalone class. More...

Public Member Functions

CXTPPropExchangeEnumerator (CXTPPropExchange *pContainer, LPCTSTR lpszSection)
Constructs a CXTPPropExchangeEnumerator object.
virtual | ~CXTPPropExchangeEnumerator ()
Destroys a CXTPPropExchangeEnumerator object, handles cleanup and deallocation.
virtual POSITION | GetPosition (DWORD dwCount=0, BOOL bCompactMode=TRUE)
Call this method to init enumerable section.
virtual CXTPPropExchange * | GetNext (POSITION &pos)
Call this method to get next enumerable section to load.

Protected Attributes

CXTPPropExchange * | m_pContainer
Parent section of enumerator.
CString | m_strSectionName
Enumerator section name.
DWORD | m_nCount
Count of items to load.

Detailed Description

CXTPPropExchangeEnumerator is standalone class.

It used by CXTPPropExchange to enumerate child sections.

Example:

extern CXTPPropExchange* pPX;

CXTPPropExchangeEnumeratorPtr pEnumerator(pPX->GetEnumerator(_T("Icon")));
POSITION posEnum = pEnumerator->GetPosition();

while (posEnum)
{
   CXTPPropExchangeSection secIcon(pEnumerator->GetNext(posEnum));
}
See also
CXTPPropExchange, CXTPPropExchange::GetEnumerator

Constructor & Destructor Documentation

◆ CXTPPropExchangeEnumerator()

CXTPPropExchangeEnumerator | ( | CXTPPropExchange * | pContainer,
 |  | LPCTSTR | lpszSection )

Constructs a CXTPPropExchangeEnumerator object.

Parameters
pContainer | Parent section of enumerator
lpszSection | Enumerator section name

Member Function Documentation

◆ GetNext()

virtual CXTPPropExchange * GetNext ( POSITION & pos )
virtual

Call this method to get next enumerable section to load.

Parameters
pos A reference to a POSITION value returned by a previous GetNext, GetPosition, or other member function call.
Returns
Returns next enumerable section to load

◆ GetPosition()

virtual POSITION GetPosition | ( | DWORD | dwCount = 0,
 |  | BOOL | bCompactMode = TRUE )
 virtual

Call this method to init enumerable section.

Parameters
dwCount | Count of items to be stored.
bCompactMode | TRUE to use "compact mode" of XML nodes.
Returns
A POSITION value that can be used for iteration; NULL if the section is empty.
The documentation for this class was generated from the following file:
  • XTPPropExchangeEnumerator.h


Toolkit Pro: CXTPPropExchangeIniFile Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPPropExchangeIniFile Class Reference

CXTPPropExchangeIniFile is CXTPPropExchange derived class. More...

Inheritance diagram for CXTPPropExchangeIniFile:
[legend]

Public Member Functions

CXTPPropExchangeIniFile (BOOL bLoading, LPCTSTR lpszParentSection, LPCTSTR lpszSection)
Constructs CXTPPropExchangeIniFile a object.
~CXTPPropExchangeIniFile ()
Destroys a CXTPPropExchangeIniFile object, handles cleanup and deallocation.
virtual BOOL | ExchangeProp (LPCTSTR pszPropName, VARTYPE vtProp, void *pvProp, const void *pvDefault=NULL)
Exchanges a property between a storage medium and the control.
virtual CXTPPropExchange * | GetSection (LPCTSTR lpszSection)
This method creates new section for text base storages (CXTPPropExchangeXMLNode and CXTPPropExchangeRegistry)
virtual BOOL | OnBeforeExchange ()
This method is called before exchange properties.
void | SaveToFile (LPCTSTR strFileName)
Saves an ini file to the specified location.
BOOL | LoadFromFile (LPCTSTR lpszFileName)
Loads the contents of an existing ini file.
void | AssignFile (LPCTSTR lpszFileName)
Assign ini file to CXTPPropExchangeIniFile class.
virtual void | EmptySection ()
Call this method to free section information before storing.
- Public Member Functions inherited from CXTPPropExchange
CXTPPropExchange ()
Constructs a CXTPPropExchange object.
virtual | ~CXTPPropExchange ()
Destroys a CXTPPropExchange object, handles cleanup and de- allocation.
BOOL | IsLoading () const
This method determines whether properties are being loaded to the class or stored from it.
BOOL | IsStoring () const
This method determines whether properties are being loaded to the class or stored from it.
void | UseDefaultOnLoad (BOOL bUseDefaultOnLoad=TRUE)
Call this method to use default values specified in PX_* functions while load process.
void | UseDefaultOnSave (BOOL bUseDefaultOnSave=TRUE)
Call this method to use default values specified in PX_* functions while save process.
BOOL | IsRootSection () const
Determines if CXTPPropExchange is used as root section.
UINT | GetSchema () const
Gets schema version number associated with the data format being serialized/de-serialized.
void | SetSchema (UINT nSchemaVersion)
Sets schema version number associated with the data format being serialized/de-serialized.
virtual BOOL | ExchangeBlobProp (LPCTSTR pszPropName, BYTE *&pData, DWORD &nBytes)
This method serializes a property that stores binary large object (BLOB) data.
virtual BOOL | ExchangeRuntimeClass (LPCTSTR pszPropName, CRuntimeClass *&pClass, CRuntimeClass *pDefaultClass)
Exchanges a CRuntimeClass between a storage and the class.
virtual BOOL | ExchangeObjectInstance (CObject *&pObject, CRuntimeClass *pObjectRuntime)
Exchanges a class instance.
virtual CArchive * | GetArchive (LPCTSTR pszPropName)
This method create new Archive to serialize.
virtual void | ReleaseArchive (LPCTSTR pszPropName, CArchive *pArchive)
This method releases CArchive pointer.
void | ExchangeSchema ()
Call this function to serialize or initialize the state of a class's version information.
void | ExchangeLocale ()
Call this function to serialize or initialize the state of a user locale.
virtual void | WriteCount (DWORD dwCount)
Use this member function to Write DWORD number to storage.
virtual DWORD | ReadCount ()
Use this member function to read DWORD number from storage.
virtual void | Write (LPCTSTR pszPropName, const void *lpBuf, UINT nCount)
Writes a specified number of bytes.
virtual UINT | Read (LPCTSTR pszPropName, void *lpBuf, UINT nCount)
Reads a specified number of bytes.
virtual BOOL | IsAllowDefaultValues () const
Call this method to determine if storage supported default values.
virtual BOOL | IsAllowBlobValues () const
Call this method to determine if storage allows exchange plain blob values.
virtual CXTPPropExchangeEnumerator * | GetEnumerator (LPCTSTR lpszSection)
Call this method to enumerate child sections.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Attributes

CString | m_strSectionName
Section name.
CString | m_strFileName
Temporary file name.
BOOL | m_bTempFile
TRUE if temporary file was created.
- Protected Attributes inherited from CXTPPropExchange
BOOL | m_bLoading
TRUE if properties are being loaded to the class.
UINT | m_nSchema
Schema of object.
BOOL | m_bChildSection
TRUE if section is child.
BOOL | m_bEmptySection
TRUE if EmptySection method was called.
BOOL | m_bInitialized
TRUE if section was initialized.
BOOL | m_bUseDefaultOnLoad
TRUE if default values must be used in load process.
BOOL | m_bUseDefaultOnSave
TRUE if default values must be used in save process.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPPropExchange
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPPropExchange
DWORD_PTR | m_dwData
User-defined 32-bit value.
CObject * | m_pOwner
User-defined Owner value.
- Static Public Attributes inherited from CXTPPropExchange
static LCID | m_lcidDateTime
User regional language.
- Protected Member Functions inherited from CXTPPropExchange
void | InitSection (CXTPPropExchange *pRootSection)
This methods is called to copy internal data from root section.

Detailed Description

CXTPPropExchangeIniFile is CXTPPropExchange derived class.

The CXTPPropExchangeIniFile class allows you to save a complex network of objects in a ini file that persists after those objects are deleted. Later you can load the objects from persistent storage, reconstituting them in memory. This process of making data persistent is called 'serialization.'

Example:

CXTPPropExchangeIniFile px(TRUE, 0, _T("Settings"));
if (px.LoadFromFile(m_strIniFileName))
{
   m_wndTaskPanel.GetGroups()->DoPropExchange(&px);
}

Constructor & Destructor Documentation

◆ CXTPPropExchangeIniFile()

CXTPPropExchangeIniFile | ( | BOOL | bLoading,
 |  | LPCTSTR | lpszParentSection,
 |  | LPCTSTR | lpszSection )

Constructs CXTPPropExchangeIniFile a object.

Parameters
bLoading | A flag that specifies whether objects will be loaded from or stored.
lpszParentSection | Root section. Can be NULL.
lpszSection | Points to a null-terminated string that specifies the section containing the entry.

Member Function Documentation

◆ AssignFile()

void AssignFile ( LPCTSTR lpszFileName )

Assign ini file to CXTPPropExchangeIniFile class.

Parameters
lpszFileName A CString value that contains the name of a file to be loaded/saved

◆ ExchangeProp()

virtual BOOL ExchangeProp | ( | LPCTSTR | pszPropName,
 |  | VARTYPE | vtProp,
 |  | void * | pvProp,
 |  | const void * | pvDefault = NULL )
 virtual

Exchanges a property between a storage medium and the control.

Parameters
pszPropName | The name of the property being exchanged.
vtProp | A symbol specifying the type of the property being exchanged.
pvProp | A pointer to the property's value.
pvDefault | Pointer to a default value for the property.

Possible values of properties are:

Symbol         Property Type
-------------  -------------
VT_I2          short
VT_I4          long
VT_BOOL        BOOL
VT_BSTR        CString
VT_CY          CY
VT_R4          float
VT_R8          double
Returns
Nonzero if the exchange was successful; 0 if unsuccessful.

Implements CXTPPropExchange.

◆ GetSection()

virtual CXTPPropExchange * GetSection ( LPCTSTR lpszSection )
virtual

This method creates new section for text base storages (CXTPPropExchangeXMLNode and CXTPPropExchangeRegistry)

Parameters
lpszSection The name of the section.
Returns
CXTPPropExchange pointer to new section. You must delete this pointer or use CXTPPropExchangeSection to manage it.

Example:

CXTPPropExchangeSection pxTaskPanel(px.GetSection(_T("TaskPanel")));
m_wndTaskPanel.GetGroups()->DoPropExchange(&pxTaskPanel);

Implements CXTPPropExchange.

◆ LoadFromFile()

BOOL LoadFromFile ( LPCTSTR lpszFileName )

Loads the contents of an existing ini file.

Parameters
lpszFileName A CString value that contains the name of a file to be loaded
Returns
TRUE if successful; otherwise 0.

◆ OnBeforeExchange()

virtual BOOL OnBeforeExchange ( )
virtual

This method is called before exchange properties.

Returns
TRUE if storage ready to exchange properties.

Reimplemented from CXTPPropExchange.

◆ SaveToFile()

void SaveToFile ( LPCTSTR strFileName )

Saves an ini file to the specified location.

Parameters
strFileName Destination file name.
The documentation for this class was generated from the following file:
  • XTPPropExchangeIniFile.h


Toolkit Pro: CXTPPropExchangeRegistry Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPPropExchangeRegistry Class Reference

CXTPPropExchangeRegistry is CXTPPropExchange derived class. More...

Inheritance diagram for CXTPPropExchangeRegistry:
[legend]

Public Member Functions

CXTPPropExchangeRegistry (BOOL bLoading, HKEY hParentKey, LPCTSTR lpszSection)
Constructs CXTPPropExchangeRegistry a object.
~CXTPPropExchangeRegistry ()
Destroys a CXTPPropExchangeRegistry object, handles cleanup and deallocation.
virtual BOOL | ExchangeProp (LPCTSTR pszPropName, VARTYPE vtProp, void *pvProp, const void *pvDefault=NULL)
Exchanges a property between a storage medium and the control.
virtual BOOL | ExchangeBlobProp (LPCTSTR pszPropName, BYTE *&pData, DWORD &nBytes)
This method serializes a property that stores binary large object (BLOB) data.
BOOL | IsSectionExists (LPCTSTR lpszSection)
Call this method to check if section exists.
BOOL | IsPropertyExists (LPCTSTR pszPropName)
Call this method to check if property entry exists.
virtual CXTPPropExchange * | GetSection (LPCTSTR lpszSection)
This method creates new section for text base storages (CXTPPropExchangeXMLNode and CXTPPropExchangeRegistry)
virtual void | EmptySection ()
Call this method to free section information before storing.
virtual BOOL | OnBeforeExchange ()
This method is called before exchange properties.
virtual BOOL | IsAllowBlobValues () const
Call this method to determine if storage allows exchange plain blob values.
- Public Member Functions inherited from CXTPPropExchange
CXTPPropExchange ()
Constructs a CXTPPropExchange object.
virtual | ~CXTPPropExchange ()
Destroys a CXTPPropExchange object, handles cleanup and de- allocation.
BOOL | IsLoading () const
This method determines whether properties are being loaded to the class or stored from it.
BOOL | IsStoring () const
This method determines whether properties are being loaded to the class or stored from it.
void | UseDefaultOnLoad (BOOL bUseDefaultOnLoad=TRUE)
Call this method to use default values specified in PX_* functions while load process.
void | UseDefaultOnSave (BOOL bUseDefaultOnSave=TRUE)
Call this method to use default values specified in PX_* functions while save process.
BOOL | IsRootSection () const
Determines if CXTPPropExchange is used as root section.
UINT | GetSchema () const
Gets schema version number associated with the data format being serialized/de-serialized.
void | SetSchema (UINT nSchemaVersion)
Sets schema version number associated with the data format being serialized/de-serialized.
virtual BOOL | ExchangeRuntimeClass (LPCTSTR pszPropName, CRuntimeClass *&pClass, CRuntimeClass *pDefaultClass)
Exchanges a CRuntimeClass between a storage and the class.
virtual BOOL | ExchangeObjectInstance (CObject *&pObject, CRuntimeClass *pObjectRuntime)
Exchanges a class instance.
virtual CArchive * | GetArchive (LPCTSTR pszPropName)
This method create new Archive to serialize.
virtual void | ReleaseArchive (LPCTSTR pszPropName, CArchive *pArchive)
This method releases CArchive pointer.
void | ExchangeSchema ()
Call this function to serialize or initialize the state of a class's version information.
void | ExchangeLocale ()
Call this function to serialize or initialize the state of a user locale.
virtual void | WriteCount (DWORD dwCount)
Use this member function to Write DWORD number to storage.
virtual DWORD | ReadCount ()
Use this member function to read DWORD number from storage.
virtual void | Write (LPCTSTR pszPropName, const void *lpBuf, UINT nCount)
Writes a specified number of bytes.
virtual UINT | Read (LPCTSTR pszPropName, void *lpBuf, UINT nCount)
Reads a specified number of bytes.
virtual BOOL | IsAllowDefaultValues () const
Call this method to determine if storage supported default values.
virtual CXTPPropExchangeEnumerator * | GetEnumerator (LPCTSTR lpszSection)
Call this method to enumerate child sections.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Attributes

HKEY | m_hSectionKey
Current registry key.
HKEY | m_hParentKey
Parent registry key.
CString | m_strSectionName
Section name.
BOOL | m_bCloseParentKey
TRUE to automatically close parent key.
- Protected Attributes inherited from CXTPPropExchange
BOOL | m_bLoading
TRUE if properties are being loaded to the class.
UINT | m_nSchema
Schema of object.
BOOL | m_bChildSection
TRUE if section is child.
BOOL | m_bEmptySection
TRUE if EmptySection method was called.
BOOL | m_bInitialized
TRUE if section was initialized.
BOOL | m_bUseDefaultOnLoad
TRUE if default values must be used in load process.
BOOL | m_bUseDefaultOnSave
TRUE if default values must be used in save process.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPPropExchange
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPPropExchange
DWORD_PTR | m_dwData
User-defined 32-bit value.
CObject * | m_pOwner
User-defined Owner value.
- Static Public Attributes inherited from CXTPPropExchange
static LCID | m_lcidDateTime
User regional language.
- Protected Member Functions inherited from CXTPPropExchange
void | InitSection (CXTPPropExchange *pRootSection)
This methods is called to copy internal data from root section.

Detailed Description

CXTPPropExchangeRegistry is CXTPPropExchange derived class.

The CXTPPropExchangeRegistry class allows you to save a complex network of objects in a system registry that persists after those objects are deleted. Later you can load the objects from persistent storage, reconstituting them in memory. This process of making data persistent is called 'serialization.'

Example:

HKEY hKey = AfxGetApp()->GetAppRegistryKey();
CXTPPropExchangeRegistry px(FALSE, hKey, szSection);
DoPropExchange(&px);
RegCloseKey(hKey);

Constructor & Destructor Documentation

◆ CXTPPropExchangeRegistry()

CXTPPropExchangeRegistry | ( | BOOL | bLoading,
 |  | HKEY | hParentKey,
 |  | LPCTSTR | lpszSection )

Constructs CXTPPropExchangeRegistry a object.

Parameters
bLoading | A flag that specifies whether objects will be loaded from or stored.
hParentKey | Root HKEY
lpszSection | Points to a null-terminated string that specifies the section containing the entry.

Member Function Documentation

◆ ExchangeBlobProp()

virtual BOOL ExchangeBlobProp | ( | LPCTSTR | pszPropName,
 |  | BYTE *& | pData,
 |  | DWORD & | nBytes )
 virtual

This method serializes a property that stores binary large object (BLOB) data.

Parameters
pszPropName | The name of the property being exchanged.
pData | A pointer to a user-supplied buffer that contains the data to be serialized
nBytes | An integer that specifies the number of bytes to be read or written.
Returns
Nonzero if the exchange was successful; 0 if unsuccessful.

Reimplemented from CXTPPropExchange.

◆ ExchangeProp()

virtual BOOL ExchangeProp | ( | LPCTSTR | pszPropName,
 |  | VARTYPE | vtProp,
 |  | void * | pvProp,
 |  | const void * | pvDefault = NULL )
 virtual

Exchanges a property between a storage medium and the control.

Parameters
pszPropName | The name of the property being exchanged.
vtProp | A symbol specifying the type of the property being exchanged.
pvProp | A pointer to the property's value.
pvDefault | Pointer to a default value for the property.

Possible values of properties are:

Symbol         Property Type
-------------  -------------
VT_I2          short
VT_I4          long
VT_BOOL        BOOL
VT_BSTR        CString
VT_CY          CY
VT_R4          float
VT_R8          double
Returns
Nonzero if the exchange was successful; 0 if unsuccessful.

Implements CXTPPropExchange.

◆ GetSection()

virtual CXTPPropExchange * GetSection ( LPCTSTR lpszSection )
virtual

This method creates new section for text base storages (CXTPPropExchangeXMLNode and CXTPPropExchangeRegistry)

Parameters
lpszSection The name of the section.
Returns
CXTPPropExchange pointer to new section. You must delete this pointer or use CXTPPropExchangeSection to manage it.

Example:

CXTPPropExchangeSection pxTaskPanel(px.GetSection(_T("TaskPanel")));
m_wndTaskPanel.GetGroups()->DoPropExchange(&pxTaskPanel);

Implements CXTPPropExchange.

◆ IsAllowBlobValues()

AFX_INLINE BOOL IsAllowBlobValues ( ) const
virtual

Call this method to determine if storage allows exchange plain blob values.

Returns
TRUE if storage allows exchange plain blob values.

Reimplemented from CXTPPropExchange.

◆ IsPropertyExists()

BOOL IsPropertyExists ( LPCTSTR pszPropName )

Call this method to check if property entry exists.

Parameters
pszPropName The name of the property being checked.
Returns
True if section exists, false is not

◆ IsSectionExists()

BOOL IsSectionExists ( LPCTSTR lpszSection )

Call this method to check if section exists.

Parameters
lpszSection The name of the section being checked.
Returns
True if section exists, false is not

◆ OnBeforeExchange()

virtual BOOL OnBeforeExchange ( )
virtual

This method is called before exchange properties.

Returns
TRUE if storage ready to exchange properties.

Reimplemented from CXTPPropExchange.

The documentation for this class was generated from the following file:
  • XTPPropExchangeRegistry.h


Toolkit Pro: CXTPPropExchangeSection Class Reference

Public Member Functions | List of all members
CXTPPropExchangeSection Class Reference

CXTPPropExchangeSection is standalone class. More...

Public Member Functions

CXTPPropExchangeSection (CXTPPropExchange *pPX)
Constructs CXTPPropExchangeSection a object.
CXTPPropExchangeSection (BOOL bLoading, LPCTSTR lpszSection)
Constructs CXTPPropExchangeSection object and automatically assign m_pPX .
virtual ~CXTPPropExchangeSection ()
Destroys a CXTPPropExchangeSection object, handles cleanup and deallocation.

Detailed Description

CXTPPropExchangeSection is standalone class.

It is used to delete memory allocated by CXTPPropExchange::GetSection.

Example:

CXTPPropExchangeSection pxTaskPanel(px.GetSection(_T("TaskPanel")));

Constructor & Destructor Documentation

◆ CXTPPropExchangeSection() [1/2]

CXTPPropExchangeSection ( CXTPPropExchange * pPX )
explicit

Constructs CXTPPropExchangeSection a object.

Parameters
pPX pointer to the CXTPPropExchange object that is the ultimate source or destination of the persistent data.

◆ CXTPPropExchangeSection() [2/2]

CXTPPropExchangeSection | ( | BOOL | bLoading,
 |  | LPCTSTR | lpszSection )

Constructs CXTPPropExchangeSection object and automatically assign m_pPX .

Parameters
bLoading | TRUE to load
lpszSection | Section of registry
The documentation for this class was generated from the following file:
  • XTPPropExchangeSection.h


Toolkit Pro: CXTPPropExchangeXMLNode Class Reference

Public Member Functions | Static Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPPropExchangeXMLNode Class Reference

CXTPPropExchangeXMLNode is CXTPPropExchange derived class. More...

Inheritance diagram for CXTPPropExchangeXMLNode:
[legend]

Public Member Functions

CXTPPropExchangeXMLNode (BOOL bLoading, CXTPDOMNodePtr xmlParentNode, LPCTSTR lpszSection)
Constructs CXTPPropExchangeXMLNode a object.
virtual BOOL | ExchangeProp (LPCTSTR pszPropName, VARTYPE vtProp, void *pvProp, const void *pvDefault=NULL)
Exchanges a property between a storage medium and the control.
virtual CXTPPropExchange * | GetSection (LPCTSTR lpszSection)
This method creates new section for text base storages (CXTPPropExchangeXMLNode and CXTPPropExchangeRegistry)
virtual void | EmptySection ()
Call this method to free section information before storing.
virtual CXTPPropExchangeEnumerator * | GetEnumerator (LPCTSTR lpszSection)
Call this method to enumerate child sections.
BOOL | IsPropertyExists (LPCTSTR pszPropName)
Call this method to check if property entry exists.
BOOL | IsSectionExists (LPCTSTR lpszSection)
Call this method to check if section exists.
CString | GetSectionName ()
Retrieves section name of the XML node.
void | SetCompactMode (BOOL bCompactMode)
Call this method to store data in compact mode (To use node attributes instead nodes)
BOOL | LoadFromFile (LPCTSTR lpszFileName)
Loads the contents of an existing file into a XML.
BOOL | LoadFromString (LPCSTR lpszState)
Loads the contents of string to XML.
BOOL | LoadFromString (LPCWSTR lpszState)
Loads the contents of string to XML.
BOOL | LoadFromString (BSTR bstrState)
Loads the contents of string to XML.
BOOL | LoadFromEncodedString (LPCSTR lpszState)
Loads the contents of the encoded string to XML.
BOOL | LoadFromEncodedString (LPCWSTR lpszState)
Loads the contents of the encoded string to XML.
BOOL | LoadFromResource (HINSTANCE hInstance, LPCTSTR lpszResourceName, LPCTSTR lpszResourceType)
Loads the resource by the specified type.
CString | GetXML (BOOL bFormatted=FALSE)
Retrieves the XML representation of the node and all its descendants.
CString | GetEncodedXML (BOOL bFormatted=FALSE)
Retrieves the encoded XML representation of the node and all its descendants.
HRESULT | SaveToFile (LPCTSTR lpszFileName, BOOL bFormatted=TRUE)
Saves an XML document to the specified location.
virtual BOOL | OnBeforeExchange ()
This method is called before exchange properties.
void | SetLoading (BOOL bLoading)
Call this member to change loading flag.
BOOL | PutSection (CXTPPropExchangeXMLNode *pNode)
Call this member to append one section to another.
CXTPPropExchangeXMLNode * | Clone (BOOL bRecursive)
Creates cloned version of the section.
void | SetEncoding (LPCTSTR lpszEncoding)
Call this method to set encoding for XML output.
CXTPDOMNodePtr | GetSectionNode () const
Call this member to get access to dom xml node for current section.
CXTPPropExchangeXMLNode * | CreateSection (LPCTSTR pszSection)
Creates new XML node and put it as Child.
- Public Member Functions inherited from CXTPPropExchange
CXTPPropExchange ()
Constructs a CXTPPropExchange object.
virtual | ~CXTPPropExchange ()
Destroys a CXTPPropExchange object, handles cleanup and de- allocation.
BOOL | IsLoading () const
This method determines whether properties are being loaded to the class or stored from it.
BOOL | IsStoring () const
This method determines whether properties are being loaded to the class or stored from it.
void | UseDefaultOnLoad (BOOL bUseDefaultOnLoad=TRUE)
Call this method to use default values specified in PX_* functions while load process.
void | UseDefaultOnSave (BOOL bUseDefaultOnSave=TRUE)
Call this method to use default values specified in PX_* functions while save process.
BOOL | IsRootSection () const
Determines if CXTPPropExchange is used as root section.
UINT | GetSchema () const
Gets schema version number associated with the data format being serialized/de-serialized.
void | SetSchema (UINT nSchemaVersion)
Sets schema version number associated with the data format being serialized/de-serialized.
virtual BOOL | ExchangeBlobProp (LPCTSTR pszPropName, BYTE *&pData, DWORD &nBytes)
This method serializes a property that stores binary large object (BLOB) data.
virtual BOOL | ExchangeRuntimeClass (LPCTSTR pszPropName, CRuntimeClass *&pClass, CRuntimeClass *pDefaultClass)
Exchanges a CRuntimeClass between a storage and the class.
virtual BOOL | ExchangeObjectInstance (CObject *&pObject, CRuntimeClass *pObjectRuntime)
Exchanges a class instance.
virtual CArchive * | GetArchive (LPCTSTR pszPropName)
This method create new Archive to serialize.
virtual void | ReleaseArchive (LPCTSTR pszPropName, CArchive *pArchive)
This method releases CArchive pointer.
void | ExchangeSchema ()
Call this function to serialize or initialize the state of a class's version information.
void | ExchangeLocale ()
Call this function to serialize or initialize the state of a user locale.
virtual void | WriteCount (DWORD dwCount)
Use this member function to Write DWORD number to storage.
virtual DWORD | ReadCount ()
Use this member function to read DWORD number from storage.
virtual void | Write (LPCTSTR pszPropName, const void *lpBuf, UINT nCount)
Writes a specified number of bytes.
virtual UINT | Read (LPCTSTR pszPropName, void *lpBuf, UINT nCount)
Reads a specified number of bytes.
virtual BOOL | IsAllowDefaultValues () const
Call this method to determine if storage supported default values.
virtual BOOL | IsAllowBlobValues () const
Call this method to determine if storage allows exchange plain blob values.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Static Public Member Functions

static BOOL AFX_CDECL | IsXMLSupported ()
Determines if XML installed in System (IE 4.0)
- Static Public Member Functions inherited from CXTPPropExchange
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Protected Member Functions

CXTPDOMNodePtr | GetProfileNode (LPCTSTR lpszSection)
Retrieves profile node.
CXTPDOMNodePtr | GetEntryNode (LPCTSTR lpszEntry, BOOL bCreate)
Retrieves entry node which the value is to be written.
- Protected Member Functions inherited from CXTPPropExchange
void | InitSection (CXTPPropExchange *pRootSection)
This methods is called to copy internal data from root section.

Protected Attributes

CXTPDOMDocumentPtr | m_xmlDocPtr
XML Document pointer.
CXTPDOMNodePtr | m_xmlParentNode
XML Parent node pointer.
CXTPDOMNodePtr | m_xmlSectionNode
XML Section node pointer.
CString | m_strSectionName
Section name.
CString | m_strEncoding
XML encoding.
BOOL | m_bCompactMode
TRUE to use compact mode.
- Protected Attributes inherited from CXTPPropExchange
BOOL | m_bLoading
TRUE if properties are being loaded to the class.
UINT | m_nSchema
Schema of object.
BOOL | m_bChildSection
TRUE if section is child.
BOOL | m_bEmptySection
TRUE if EmptySection method was called.
BOOL | m_bInitialized
TRUE if section was initialized.
BOOL | m_bUseDefaultOnLoad
TRUE if default values must be used in load process.
BOOL | m_bUseDefaultOnSave
TRUE if default values must be used in save process.

Additional Inherited Members

- Public Attributes inherited from CXTPPropExchange
DWORD_PTR | m_dwData
User-defined 32-bit value.
CObject * | m_pOwner
User-defined Owner value.
- Static Public Attributes inherited from CXTPPropExchange
static LCID | m_lcidDateTime
User regional language.

Detailed Description

CXTPPropExchangeXMLNode is CXTPPropExchange derived class.

The CXTPPropExchangeXMLNode class allows you to save a complex network of objects in a XML file that persists after those objects are deleted. Later you can load the objects from persistent storage, reconstituting them in memory. This process of making data persistent is called 'serialization.'

Example:

CXTPPropExchangeXMLNode px(TRUE, 0, _T("Settings"));
if (px.LoadFromFile(m_strIniFileName))
{
   m_wndTaskPanel.GetGroups()->DoPropExchange(&px);
}

Constructor & Destructor Documentation

◆ CXTPPropExchangeXMLNode()

CXTPPropExchangeXMLNode | ( | BOOL | bLoading,
 |  | CXTPDOMNodePtr | xmlParentNode,
 |  | LPCTSTR | lpszSection )

Constructs CXTPPropExchangeXMLNode a object.

Parameters
bLoading | A flag that specifies whether objects will be loaded from or stored.
xmlParentNode | Parent node element. Can be NULL.
lpszSection | Points to a null-terminated string that specifies the section containing the entry.

Member Function Documentation

◆ Clone()

CXTPPropExchangeXMLNode * Clone ( BOOL bRecursive )

Creates cloned version of the section.

Parameters
bRecursive TRUE to clone recursively
Returns
TRUE if successful; otherwise FALSE.

◆ CreateSection()

CXTPPropExchangeXMLNode * CreateSection ( LPCTSTR pszSection )

Creates new XML node and put it as Child.

Parameters
pszSection New section name
Returns
A newly created XML node property excahge object pointer.

◆ ExchangeProp()

virtual BOOL ExchangeProp | ( | LPCTSTR | pszPropName,
 |  | VARTYPE | vtProp,
 |  | void * | pvProp,
 |  | const void * | pvDefault = NULL )
 virtual

Exchanges a property between a storage medium and the control.

Parameters
pszPropName | The name of the property being exchanged.
vtProp | A symbol specifying the type of the property being exchanged.
pvProp | A pointer to the property's value.
pvDefault | Pointer to a default value for the property.

Possible values of properties are:

Symbol         Property Type
-------------  -------------
VT_I2          short
VT_I4          long
VT_BOOL        BOOL
VT_BSTR        CString
VT_CY          CY
VT_R4          float
VT_R8          double
Returns
Nonzero if the exchange was successful; 0 if unsuccessful.

Implements CXTPPropExchange.

◆ GetEncodedXML()

CString GetEncodedXML ( BOOL bFormatted = FALSE )

Retrieves the encoded XML representation of the node and all its descendants.

Parameters
bFormatted TRUE to format XML/encoded XML output
Returns
XML/encoded XML representation of this node and all its descendants.

◆ GetEntryNode()

CXTPDOMNodePtr GetEntryNode | ( | LPCTSTR | lpszEntry,
 |  | BOOL | bCreate )
 protected

Retrieves entry node which the value is to be written.

Parameters
lpszEntry | Points to a null-terminated string that contains the entry into which the
bCreate | TRUE to create if doesn't exist.
Returns
Entry node to be used

◆ GetEnumerator()

virtual CXTPPropExchangeEnumerator * GetEnumerator ( LPCTSTR lpszSection )
virtual

Call this method to enumerate child sections.

Parameters
lpszSection child section name.
Returns
Returns an enumerator for child sections.

Example:

extern CXTPPropExchange* pPX;

CXTPPropExchangeEnumeratorPtr pEnumerator(pPX->GetEnumerator(_T("Icon")));
POSITION posEnum = pEnumerator->GetPosition();

while (posEnum)
{
   CXTPPropExchangeSection secIcon(pEnumerator->GetNext(posEnum));
}
See also
CXTPPropExchangeEnumerator

Reimplemented from CXTPPropExchange.

◆ GetProfileNode()

CXTPDOMNodePtr GetProfileNode ( LPCTSTR lpszSection )
protected

Retrieves profile node.

Parameters
lpszSection Section name of profile node
Returns
Profile node.to be used

◆ GetSection()

virtual CXTPPropExchange * GetSection ( LPCTSTR lpszSection )
virtual

This method creates new section for text base storages (CXTPPropExchangeXMLNode and CXTPPropExchangeRegistry)

Parameters
lpszSection The name of the section.
Returns
CXTPPropExchange pointer to new section. You must delete this pointer or use CXTPPropExchangeSection to manage it.

Example:

CXTPPropExchangeSection pxTaskPanel(px.GetSection(_T("TaskPanel")));
m_wndTaskPanel.GetGroups()->DoPropExchange(&pxTaskPanel);

Implements CXTPPropExchange.

◆ GetSectionName()

CString GetSectionName ( )

Retrieves section name of the XML node.

Returns
Name of the XML node.

◆ GetSectionNode()

CXTPDOMNodePtr GetSectionNode ( ) const
inline

Call this member to get access to dom xml node for current section.

Returns
Section XML DOM node pointer.

◆ GetXML()

CString GetXML ( BOOL bFormatted = FALSE )

Retrieves the XML representation of the node and all its descendants.

Parameters
bFormatted TRUE to format XML/encoded XML output
Returns
XML/encoded XML representation of this node and all its descendants.

◆ IsPropertyExists()

BOOL IsPropertyExists ( LPCTSTR pszPropName )

Call this method to check if property entry exists.

Parameters
pszPropName The name of the property being checked.
Returns
True of property entry exist

◆ IsSectionExists()

BOOL IsSectionExists ( LPCTSTR lpszSection )

Call this method to check if section exists.

Parameters
lpszSection The name of the section being checked.
Returns
True if section exist

◆ IsXMLSupported()

static BOOL AFX_CDECL IsXMLSupported ( )
static

Determines if XML installed in System (IE 4.0)

Returns
True if XML is installed in system, false is not

◆ LoadFromEncodedString() [1/2]

BOOL LoadFromEncodedString ( LPCSTR lpszState )

Loads the contents of the encoded string to XML.

Parameters
lpszState Buffer that contains XML nodes.
Returns
TRUE if successful; otherwise FALSE.

◆ LoadFromEncodedString() [2/2]

BOOL LoadFromEncodedString ( LPCWSTR lpszState )

Loads the contents of the encoded string to XML.

Parameters
lpszState Buffer that contains XML nodes.
Returns
TRUE if successful; otherwise FALSE.

◆ LoadFromFile()

BOOL LoadFromFile ( LPCTSTR lpszFileName )

Loads the contents of an existing file into a XML.

Parameters
lpszFileName A CString value that contains the name of a file to be loaded into the XML
Returns
TRUE if successful; otherwise FALSE.

◆ LoadFromResource()

BOOL LoadFromResource | ( | HINSTANCE | hInstance,
 |  | LPCTSTR | lpszResourceName,
 |  | LPCTSTR | lpszResourceType )

Loads the resource by the specified type.

Parameters
hInstance | Resource instance handle.
lpszResourceName | Resource name.
lpszResourceType | Resource type.
Returns
TRUE if successful; otherwise FALSE.

◆ LoadFromString() [1/3]

BOOL LoadFromString ( BSTR bstrState )

Loads the contents of string to XML.

Parameters
bstrState BSTR value that contains XML nodes
Returns
TRUE if successful; otherwise FALSE.

◆ LoadFromString() [2/3]

BOOL LoadFromString ( LPCSTR lpszState )

Loads the contents of string to XML.

Parameters
lpszState A pointer to a value that contains XML nodes
Returns
TRUE if successful; otherwise FALSE.

◆ LoadFromString() [3/3]

BOOL LoadFromString ( LPCWSTR lpszState )

Loads the contents of string to XML.

Parameters
lpszState A pointer to a value that contains XML nodes
Returns
TRUE if successful; otherwise FALSE.

◆ OnBeforeExchange()

virtual BOOL OnBeforeExchange ( )
virtual

This method is called before exchange properties.

Returns
TRUE if storage ready to exchange properties.

Reimplemented from CXTPPropExchange.

◆ PutSection()

BOOL PutSection ( CXTPPropExchangeXMLNode * pNode )

Call this member to append one section to another.

Parameters
pNode Section to be append.
Returns
True if successful

◆ SaveToFile()

HRESULT SaveToFile | ( | LPCTSTR | lpszFileName,
 |  | BOOL | bFormatted = TRUE )

Saves an XML document to the specified location.

Parameters
lpszFileName | Destination file name.
bFormatted | TRUE to format XML output
Returns
S_OK if successful, an error code otherwise.

◆ SetCompactMode()

void SetCompactMode ( BOOL bCompactMode )

Call this method to store data in compact mode (To use node attributes instead nodes)

Parameters
bCompactMode TRUE to use compact mode (default)

◆ SetEncoding()

void SetEncoding ( LPCTSTR lpszEncoding )

Call this method to set encoding for XML output.

Parameters
lpszEncoding encoding that will be used in XML file

Default encoding is UTF-8

Example:

px.SetEncoding(_T("windows-1251"));

◆ SetLoading()

void SetLoading ( BOOL bLoading )

Call this member to change loading flag.

Parameters
bLoading A flag that specifies whether objects will be loaded from or stored.
The documentation for this class was generated from the following file:
  • XTPPropExchangeXMLNode.h


Toolkit Pro: CXTPRadioButtonPart Class Reference

Public Member Functions | List of all members
CXTPRadioButtonPart Class Reference

This class implements Radio button part of the SwitchViewBar. More...

Inheritance diagram for CXTPRadioButtonPart:
[legend]

Public Member Functions

virtual void | AdjustLayout (CDC *pDC, const CRect &rcRect)
This member function is used to adjust the object's layout depending on the provided bounding rectangle.
virtual void | RefreshMetrics ()
Performs refreshing of graphical related parameters from system settings.
virtual void | Draw (CDC *pDC)
This member function is used to draw the part content utilizing the specified device context.
- Public Member Functions inherited from CXTPCalendarCaptionBarThemePart
CXTPCalendarCaptionBarThemePart (CXTPCalendarCaptionBarTheme *pTheme, int nPartID)
Default object constructor.
virtual | ~CXTPCalendarCaptionBarThemePart ()
Default object destructor.
virtual void | Redraw (BOOL bUpdateNow=FALSE)
This member function initiates the CalendarCaptionBar control's redrawing.
virtual BOOL | HitTest (const CPoint &pt) const
This member function is used to determine is the specified point over visible object rectangle.
virtual CXTPCalendarCaptionBarTheme * | GetTheme () const
This member function is used to obtain pointer to parent CXTPCalendarCaptionBarTheme object.
virtual XTPCalendarTheme | GetPaintTheme () const
This member function is used to obtain current paint theme.
virtual int | GetPartID () const
This member function is used to obtain an object identifier.
virtual CRect | GetRect () const
This member function is used to obtain an object rectangle.
virtual CString | GetText () const
This member function is used to obtain an object text.
virtual void | SetText (LPCTSTR pcszText)
This member function is used to set object text.
virtual BOOL | IsVisible () const
This member function is used to get is part object visible.
virtual void | SetVisible (BOOL bVisible)
This member function is used to set visible object's state.
virtual int | GetCheck () const
This member function is used to get checked state.
virtual void | SetCheck (int nCheck)
This member function is used to set checked state.
int | GetState () const
This member function is used to get object state (flags from CXTPCalendarCaptionBarThemePart::EStates enum).
virtual void | SetState (int nState)
This member function is used to set object state as set of flags from CXTPCalendarCaptionBarThemePart::EStates enum.
virtual COLORREF | GetTextColor ()
This member function is used to get object text color.
CXTPCalendarCaptionBarPaintManager * | GetPaintManager () const
Gets the paint manager.
virtual void | OnMouseMove (UINT nFlags, CPoint point)
This member function is used to processes mouse movement events.
virtual BOOL | OnLButtonDown (UINT nFlags, CPoint point)
This member function is used to process left mouse button down events.
virtual BOOL | OnLButtonUp (UINT nFlags, CPoint point)
This member function is used to process left mouse button up events.
- Public Member Functions inherited from CXTPCalendarWMHandler
CXTPCalendarWMHandler ()
Default object constructor.
virtual int | GetChildHandlersCount () const
This member function is used to obtain the number of CXTPCalendarWMHandler elements in the descendant handlers collection.
virtual CXTPCalendarWMHandler * | GetChildHandlerAt (int nIndex) const
Call this method to get a handler object at the specified numeric index.
virtual BOOL | OnLButtonDblClk (UINT nFlags, CPoint point)
This member function is used to process left mouse button double click events.
virtual void | OnChar (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process keyboard events.
virtual void | OnKeyDown (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process key-down keyboard events.
virtual void | OnKeyUp (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process key-up keyboard events.
virtual BOOL | OnSysKeyDown (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process key-up keyboard events.
virtual BOOL | OnTimer (UINT_PTR uTimerID)
The framework calls this member function after each interval specified in the SetTimer member function.
virtual BOOL | OnWndMsg (UINT message, WPARAM wParam, LPARAM lParam, LRESULT *pResult)
This method is called by framework after default message processing.
virtual void | OnPostAdjustLayout ()
This member function is used to perform additional adjustments in some kinds of views.
virtual void | OnBeforeDestroy ()
This member function is called by the framework before destroying the view.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPCalendarCaptionBarThemePart
CXTPPaintManagerColor | m_clrTextColor
Store the object's text color.
CRect | m_rcRect
Store a Part rectangle.
int | m_nState
Store a Part state.
CString | m_strText
Store a Part text.
- Protected Attributes inherited from CXTPCalendarCaptionBarThemePart
CXTPCalendarCaptionBarTheme * | m_pTheme
Store pointer to a parent theme object.
int | m_nPartID
Store a Part ID.
BOOL | m_bVisible
Store a Part visible state.

Detailed Description

This class implements Radio button part of the SwitchViewBar.

See also
CXTPCalendarCaptionBarThemePart

Member Function Documentation

◆ AdjustLayout()

virtual void AdjustLayout | ( | CDC * | pDC,
 |  | const CRect & | rcRect )
 virtual

This member function is used to adjust the object's layout depending on the provided bounding rectangle.

Parameters
pDC | Pointer to a valid device context (may be NULL).
rcRect | A CRect object containing the dimensions of the bounding rectangle for this part.

Reimplemented from CXTPCalendarCaptionBarThemePart.

◆ Draw()

virtual void Draw ( CDC * pDC )
virtual

This member function is used to draw the part content utilizing the specified device context.

Parameters
pDC Pointer to a valid device context.

Reimplemented from CXTPCalendarCaptionBarThemePart.

◆ RefreshMetrics()

virtual void RefreshMetrics ( )
virtual

Performs refreshing of graphical related parameters from system settings.

Base implementation do nothing.

Reimplemented from CXTPCalendarCaptionBarThemePart.

The documentation for this class was generated from the following file:
  • XTPCalendarCaptionBarThemePart.h


Toolkit Pro: CXTPReBar Class Reference

Public Member Functions | List of all members
CXTPReBar Class Reference

The CXTPReBar object extends the standard MFC CReBar class to provide extended functionality such as saving and restoring band layouts. More...

Public Member Functions

CXTPReBar ()
Constructs a CXTPReBar object.
virtual | ~CXTPReBar ()
Destroys a CXTPReBar object, handles cleanup and deallocation.
BOOL | AddToolBar (CXTPToolBar *pToolBar, DWORD dwStyle=RBBS_GRIPPERALWAYS)
Call this member to add a band to the rebar.
void | DeleteToolBar (CXTPToolBar *pToolBar)
Call this member to remove a toolbar within the rebar.
int | FindBand (CXTPToolBar *pToolBar)
Call this member to locate the band that contains a toolbar.
CXTPToolBar * | GetToolBar (int nBand)
Call this member to retrieve a pointer to the toolbar contained in the band with the specified ID.
void | LoadState (LPCTSTR lpszProfileName)
Retrieves state information from the registry.
void | SaveState (LPCTSTR lpszProfileName)
Saves state information to the registry.
BOOL | SetBandInfo (UINT uBand, REBARBANDINFO *prbbi)
This member function implements the behavior of the Win32 message RB_SETBANDINFO, as described in the Platform SDK.

Detailed Description

The CXTPReBar object extends the standard MFC CReBar class to provide extended functionality such as saving and restoring band layouts.

Member Function Documentation

◆ AddToolBar()

BOOL AddToolBar | ( | CXTPToolBar * | pToolBar,
 |  | DWORD | dwStyle = RBBS_GRIPPERALWAYS )

Call this member to add a band to the rebar.

The specified toolbar will be inserted into the band.

Parameters
pToolBar | Pointer to the Toolbar object that will be added to rebar band.
dwStyle | Contains styles that can be applied to the rebar. the only band in the rebar.

The ID of the band that contains the toolbar is assigned the same ID as the toolbar.

Returns
TRUE is the bar was added successfully, FALSE if the bar wasn't added.

◆ DeleteToolBar()

void DeleteToolBar ( CXTPToolBar * pToolBar )

Call this member to remove a toolbar within the rebar.

This will also remove the band that contained the toolbar.

Parameters
pToolBar Pointer to the toolbar that will be removed.

◆ FindBand()

int FindBand ( CXTPToolBar * pToolBar )

Call this member to locate the band that contains a toolbar.

Parameters
pToolBar Pointer to the toolbar you want to find.
Returns
If found on a band in the rebar, then the ID of the band that contains the toolbar will be returned. If not found, then a value of -1 will be returned.

◆ GetToolBar()

CXTPToolBar * GetToolBar ( int nBand )

Call this member to retrieve a pointer to the toolbar contained in the band with the specified ID.

Parameters
nBand ID of a band in the rebar.
Returns
A pointer to the toolbar contained in the specified band.

◆ LoadState()

void LoadState ( LPCTSTR lpszProfileName )

Retrieves state information from the registry.

Parameters
lpszProfileName Pointer to a NULL-teminated string that specifies the name of a key in the Windows registry where the state information is stored.

◆ SaveState()

void SaveState ( LPCTSTR lpszProfileName )

Saves state information to the registry.

Parameters
lpszProfileName Pointer to a NULL-teminated string that specifies the name of a key in the Windows registry where the state information should be stored.

◆ SetBandInfo()

AFX_INLINE BOOL SetBandInfo | ( | UINT | uBand,
 |  | REBARBANDINFO * | prbbi )

This member function implements the behavior of the Win32 message RB_SETBANDINFO, as described in the Platform SDK.

Parameters
uBand | Zero-based index of the band to receive the new settings.
prbbi | Pointer to a REBARBANDINFO structure that defines the band to be inserted. You must set the 'cbSize' member of this structure to sizeof(REBARBANDINFO) before sending this message.
Returns
Nonzero if successful, otherwise zero.

Example:

int nCount = m_wndReBar.GetReBarCtrl().GetBandCount();
CString strText = "Band #:";

int i;
for (i = 0; i<nCount; i++)
{
   LPREBARBANDINFO prbbi = (LPREBARBANDINFO)alloca(sizeof(REBARBANDINFO));
   prbbi->cbSize = sizeof(REBARBANDINFO);

   CString strText;
   strText.Format("Band #: %d", i);

   LPTSTR lpszText = strText.GetBuffer(strText.GetLength());
   prbbi->lpText = lpszText;
   prbbi->cch = strlen(lpszText) + 1;
   prbbi->fMask = RBBIM_TEXT;

   m_wndReBar.SetBandInfo(i, prbbi);

   strText.ReleaseBuffer();
}
The documentation for this class was generated from the following file:
  • XTPReBar.h


Toolkit Pro: CXTPReBarPaintManager< TBase > Class Template Reference

Public Member Functions | Protected Attributes | List of all members
CXTPReBarPaintManager< TBase > Class Template Reference

The CXTPReBarPaintManager template class is used to enable a ReBar theme for Command Bars. More...

Public Member Functions

CXTPReBarPaintManager ()
Constructs a CXTPReBarPaintManager object.
void | RefreshMetrics ()
This method is called to refresh the visual metrics of the manager.
void | FillCommandBarEntry (CDC *pDC, CXTPCommandBar *pBar)
This method is called to fill the command bar's face.

Protected Attributes

CXTPWinThemeWrapper m_themeRebar
ReBar theme helper.

Detailed Description

template<class TBase>
class CXTPReBarPaintManager< TBase >

The CXTPReBarPaintManager template class is used to enable a ReBar theme for Command Bars.

See also
CXTPPaintManager::SetTheme

Member Function Documentation

◆ FillCommandBarEntry()

template<class TBase >
AFX_INLINE void FillCommandBarEntry | ( | CDC * | pDC,
 |  | CXTPCommandBar * | pBar )

This method is called to fill the command bar's face.

Parameters
pDC | Pointer to a valid device context.
pBar | Pointer to a CXTPCommandBar object to draw.
The documentation for this class was generated from the following file:
  • XTPPaintManager.h


Toolkit Pro: CXTPRecentFileList Class Reference

Public Member Functions | Public Attributes | List of all members
CXTPRecentFileList Class Reference

CXTPRecentFileList is a CRecentFileList derived class. More...

Inheritance diagram for CXTPRecentFileList:
[legend]

Public Member Functions

CXTPRecentFileList (UINT nStart, LPCTSTR lpszSection, LPCTSTR lpszEntryFormat, int nSize, int nMaxDispLen=AFX_ABBREV_FILENAME_LEN)
Constructs a CXTPPinableRecentFileList object.
~CXTPRecentFileList ()
Destroys a CXTPPinableRecentFileList object, handles cleanup and deallocation.
virtual void | Remove (int nIndex)
Removes an item from the MRU.
virtual void | Add (LPCTSTR lpszPathName)
Adds an item to the MRU.
virtual void | ReadList ()
Reads from registry or ini file.
virtual void | WriteList ()
Writes to registry or ini file.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Public Attributes

BOOL m_bPinable
True if the MRU is a pinnable MRU (for ribbon).

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

CXTPRecentFileList is a CRecentFileList derived class.

This is used as a pinnable MRU for the ribbon.

Constructor & Destructor Documentation

◆ CXTPRecentFileList()

CXTPRecentFileList | ( | UINT | nStart,
 |  | LPCTSTR | lpszSection,
 |  | LPCTSTR | lpszEntryFormat,
 |  | int | nSize,
 |  | int | nMaxDispLen = AFX_ABBREV_FILENAME_LEN )

Constructs a CXTPPinableRecentFileList object.

Parameters
nStart | Index of the item to start pinned.
lpszSection | Section.
lpszEntryFormat | Format.
nSize | Initial list size.
nMaxDispLen | Maximum list size.

Member Function Documentation

◆ Add()

virtual void Add ( LPCTSTR lpszPathName )
virtual

Adds an item to the MRU.

Parameters
lpszPathName Path of the filename, including file name, to include in the MRU. Only the filename will be drawn in the MRU. The entire path will be displayed in a tooltip on mouseover.

◆ Remove()

virtual void Remove ( int nIndex )
virtual

Removes an item from the MRU.

Parameters
nIndex Index of the item to remove from the MRU.
The documentation for this class was generated from the following file:
  • XTPRecentFileList.h


Toolkit Pro: CXTPRectT< T > Class Template Reference

Public Member Functions | Static Public Member Functions | Public Attributes | List of all members
CXTPRectT< T > Class Template Reference

This class abstracts a rectangular entity and its operations. More...

Inheritance diagram for CXTPRectT< T >:
[legend]

Public Member Functions

CXTPRectT ()
Default constructor, creates a CXTPRectT object and initializes the values to zero.
CXTPRectT (const CXTPRectT &other)
Copies rectangle from another rectangle.
CXTPRectT (const CRect &rc)
Overloaded constructor, creates a CXTPRectT object from CRect type object and initializes the values.
CXTPRectT (T x, T y, T width, T height)
Overloaded constructor, creates a CXTPRectT object.
CXTPRectT (const CXTPPoint2T< T > &location, const CXTPSizeT< T > &size)
Overloaded constructor, creates a CXTPRectT object from point and a size objects.
CXTPRectT (const CXTPPoint2T< T > &ptTopLeft, const CXTPPoint2T< T > &ptBottomRight)
Overloaded constructor, creates a CXTPRectT object from top-left and bottom-right point objects.
void | SetRect (const CRect &rc)
Sets new rectangle data from from CRect type object and initializes the values.
void | SetRect (T x, T y, T width, T height)
Sets new rectangle data.
void | SetRect (const CXTPPoint2T< T > &location, const CXTPSizeT< T > &size)
Sets new rectangle data from from point and a size objects.
void | SetRect (const CXTPPoint2T< T > &ptTopLeft, const CXTPPoint2T< T > &ptBottomRight)
Sets new rectangle data from top-left and bottom-right point objects.
void | Normalize ()
Normalizes rectangle, i.e.
CXTPPoint2T< T > | GetLocation () const
Call this function to get the coordinate location of the rectangle.
CXTPSizeT< T > | GetSize () const
Call this function to get the size of the rectangle.
T | GetLeft () const
Call this function to get the starting x coordinate of the rectangle.
T | GetTop () const
Call this function to get the starting y coordinate of the rectangle.
T | GetRight () const
Call this function to get the ending x coordinate of the rectangle.
T | GetBottom () const
Call this function to get the ending y coordinate of the rectangle.
bool | IsEmptyArea () const
Call this function to check whether the rectangular area is epty.
void | SetEmpty () const
Call this function to empty rectangle.
bool | Equals (const CXTPRectT &rect) const
Call this function to check whether the current rectangle is equal to another.
bool | operator== (const CXTPRectT &rect) const
Compares to another rectangle.
bool | operator!= (const CXTPRectT &rect) const
Compares to another rectangle.
bool | Contains (T x, T y) const
Call this function to check whether a point is inside the rectangle or not.
bool | Contains (const CXTPPoint2T< T > &pt) const
Call this function to check whether a point is inside the rectangle or not.
bool | Contains (const CXTPRectT &rect) const
Call this function to check whether a rectangle is inside the rectangle or not.
void | Inflate (T dx, T dy)
Call this function to inflate the rectangle by an arbitrary value.
void | Inflate (const CXTPPoint2T< T > &point)
Call this function to inflate the rectangle by an arbitrary value denoted by a CXTPPoint2T object.
void | DeflateRect (T l, T t, T r, T b)
Call this function to deflate the rectangle by an arbitrary value denoted by top-left and bottom-right coordinates.
bool | Intersect (const CXTPRectT &rect)
Call check whether the current rectangle object shares some common area with another rectangle object.
bool | IntersectsWith (const CXTPRectT &rect) const
Call this function to check whether this object intersect with a given rectangle.
void | Offset (const CXTPPoint2T< T > &point)
Call this function to move the rectangle by an offset.
void | Offset (T dx, T dy)
Call this function to move the rectangle by an offset.
CXTPPoint2T< T > | GetCenter ()
Call this function to get the center point of the rectangle.
void | Round ()
Rounds rectangle components.

Static Public Member Functions

static bool AFX_CDECL | Intersect (CXTPRectT &c, const CXTPRectT &a, const CXTPRectT &b)
Call check whether two rectangle objects share common area and save the shared rectangle.
static bool AFX_CDECL | Union (CXTPRectT &c, const CXTPRectT &a, const CXTPRectT &b)
Call this static function to calculates the union of two source rectangles and places the coordinates of the union rectangle into the destination rectangle.

Public Attributes

T | X
The x coordinate(left).
T | Y
The y coordinate(top).
T | Width
The width of the rectangle.
T | Height
The height of the rectangle.

Detailed Description

template<class T>
class CXTPRectT< T >

This class abstracts a rectangular entity and its operations.

This object is composed of four of specified type T for x and y coordinates and width and height of a rectangle.

Parameters
T type of each rectangle component.

Constructor & Destructor Documentation

◆ CXTPRectT() [1/5]

template<class T >
CXTPRectT ( const CXTPRectT< T > & other )
inline

Copies rectangle from another rectangle.

Parameters
other a reference to a rectangle to copy from.

◆ CXTPRectT() [2/5]

template<class T >
CXTPRectT ( const CRect & rc )
inline

Overloaded constructor, creates a CXTPRectT object from CRect type object and initializes the values.

Parameters
rc A reference to a CRect.

◆ CXTPRectT() [3/5]

template<class T >
CXTPRectT | ( | T | x,
 |  | T | y,
 |  | T | width,
 |  | T | height )
 inline

Overloaded constructor, creates a CXTPRectT object.

Parameters
x | The x coordinate.
y | The y coordinate.
width | The width of the rectangle.
height | The height of the rectangle.

◆ CXTPRectT() [4/5]

template<class T >
CXTPRectT | ( | const CXTPPoint2T< T > & | location,
 |  | const CXTPSizeT< T > & | size )
 inline

Overloaded constructor, creates a CXTPRectT object from point and a size objects.

Parameters
location | The rectangle location.
size | The size of the rectangle.

◆ CXTPRectT() [5/5]

template<class T >
CXTPRectT | ( | const CXTPPoint2T< T > & | ptTopLeft,
 |  | const CXTPPoint2T< T > & | ptBottomRight )
 inline

Overloaded constructor, creates a CXTPRectT object from top-left and bottom-right point objects.

Parameters
ptTopLeft | The top-left rectangle coordinates.
ptBottomRight | The bottom-right rectangle coordinates.

Member Function Documentation

◆ Contains() [1/3]

template<class T >
bool Contains ( const CXTPPoint2T< T > & pt ) const
inline

Call this function to check whether a point is inside the rectangle or not.

Parameters
pt The point.
Returns
TRUE if the point is inside the rectangle and FALSE if the point is outside the rectangle.

◆ Contains() [2/3]

template<class T >
bool Contains ( const CXTPRectT< T > & rect ) const
inline

Call this function to check whether a rectangle is inside the rectangle or not.

Parameters
rect Reference to a rectangle.
Returns
TRUE if the second rectangle is inside the current rectangle and FALSE if the not.

◆ Contains() [3/3]

template<class T >
bool Contains | ( | T | x,
 |  | T | y ) const
 inline

Call this function to check whether a point is inside the rectangle or not.

Parameters
x | The x coordinate of the point.
y | The y coordinate of the point.
Returns
TRUE if the point is inside the rectangle and FALSE if the point is outside the rectangle.

◆ DeflateRect()

template<class T >
void DeflateRect | ( | T | l,
 |  | T | t,
 |  | T | r,
 |  | T | b )
 inline

Call this function to deflate the rectangle by an arbitrary value denoted by top-left and bottom-right coordinates.

Parameters
l | The top-left X coordinate.
t | The top-left Y coordinate.
r | The bottom-right X coordinate.
b | The bottom-right Y coordinate.

◆ Equals()

template<class T >
bool Equals ( const CXTPRectT< T > & rect ) const
inline

Call this function to check whether the current rectangle is equal to another.

Parameters
rect The rectangle which is to be compared with the current object for equality.
Returns
TRUE if the second rectangle is equal to the current object and FALSE they are unequal.

◆ GetBottom()

template<class T >
T GetBottom ( ) const
inline

Call this function to get the ending y coordinate of the rectangle.

Returns
A value denoting the bottom of the rectangle.

◆ GetCenter()

template<class T >
CXTPPoint2T< T > GetCenter ( )
inline

Call this function to get the center point of the rectangle.

Returns
A CXTPPoint2f object representing the center of the rectangle.

◆ GetLeft()

template<class T >
T GetLeft ( ) const
inline

Call this function to get the starting x coordinate of the rectangle.

Returns
A value denoting the left of the rectangle.

◆ GetLocation()

template<class T >
CXTPPoint2T< T > GetLocation ( ) const
inline

Call this function to get the coordinate location of the rectangle.

Returns
A CXTPPoint2f object denoting the current location of the rectangle in a plane.

◆ GetRight()

template<class T >
T GetRight ( ) const
inline

Call this function to get the ending x coordinate of the rectangle.

Returns
A value denoting the right of the rectangle.

◆ GetSize()

template<class T >
CXTPSizeT< T > GetSize ( ) const
inline

Call this function to get the size of the rectangle.

Returns
A CXTPSizeF object denoting size of the rectangle.

◆ GetTop()

template<class T >
T GetTop ( ) const
inline

Call this function to get the starting y coordinate of the rectangle.

Returns
A value denoting the top of the rectangle.

◆ Inflate() [1/2]

template<class T >
void Inflate ( const CXTPPoint2T< T > & point )
inline

Call this function to inflate the rectangle by an arbitrary value denoted by a CXTPPoint2T object.

Parameters
point The change value.

◆ Inflate() [2/2]

template<class T >
void Inflate | ( | T | dx,
 |  | T | dy )
 inline

Call this function to inflate the rectangle by an arbitrary value.

Parameters
dx | The change in x value.
dy | The change in y value.

◆ Intersect() [1/2]

template<class T >
bool Intersect ( const CXTPRectT< T > & rect )
inline

Call check whether the current rectangle object shares some common area with another rectangle object.

Parameters
rect The other rectangle.
Returns
TRUE if the operation succeed and FALSE if operation failed.

◆ Intersect() [2/2]

template<class T >
static bool AFX_CDECL Intersect | ( | CXTPRectT< T > & | c,
 |  | const CXTPRectT< T > & | a,
 |  | const CXTPRectT< T > & | b )
 inlinestatic

Call check whether two rectangle objects share common area and save the shared rectangle.

Parameters
c | The reference to destination rectangle.
a | The first source rectangle.
b | The second source rectangle.
Returns
TRUE if the operation succeed and FALSE if operation failed.

◆ IntersectsWith()

template<class T >
bool IntersectsWith ( const CXTPRectT< T > & rect ) const
inline

Call this function to check whether this object intersect with a given rectangle.

Parameters
rect The reference to the other rectangle.
Returns
TRUE if the rectangles intersect and FALSE if rectangles do not intersect.

◆ IsEmptyArea()

template<class T >
bool IsEmptyArea ( ) const
inline

Call this function to check whether the rectangular area is epty.

Returns
TRUE if the rectangle is of finite area and FALSE if it is empty.

◆ Normalize()

template<class T >
void Normalize ( )
inline

Normalizes rectangle, i.e.

if its width or height are negative the components will be adjusted so that both width and height are guaranteed positive while the size doesn't get changed.

◆ Offset() [1/2]

template<class T >
void Offset ( const CXTPPoint2T< T > & point )
inline

Call this function to move the rectangle by an offset.

Parameters
point The offset as a point.

◆ Offset() [2/2]

template<class T >
void Offset | ( | T | dx,
 |  | T | dy )
 inline

Call this function to move the rectangle by an offset.

Parameters
dx | The offset x value.
dy | The offset y value.

◆ operator!=()

template<class T >
bool operator!= ( const CXTPRectT< T > & rect ) const
inline

Compares to another rectangle.

Parameters
rect Another rectangle to compare to.
Returns
true if the two rectangles are not equal, false otherwise.

◆ operator==()

template<class T >
bool operator== ( const CXTPRectT< T > & rect ) const
inline

Compares to another rectangle.

Parameters
rect Another rectangle to compare to.
Returns
true if the two rectangles are equal, false otherwise.

◆ SetRect() [1/4]

template<class T >
void SetRect ( const CRect & rc )
inline

Sets new rectangle data from from CRect type object and initializes the values.

Parameters
rc A reference to a CRect.

◆ SetRect() [2/4]

template<class T >
void SetRect | ( | const CXTPPoint2T< T > & | location,
 |  | const CXTPSizeT< T > & | size )
 inline

Sets new rectangle data from from point and a size objects.

Parameters
location | The rectangle location.
size | The size of the rectangle.

◆ SetRect() [3/4]

template<class T >
void SetRect | ( | const CXTPPoint2T< T > & | ptTopLeft,
 |  | const CXTPPoint2T< T > & | ptBottomRight )
 inline

Sets new rectangle data from top-left and bottom-right point objects.

Parameters
ptTopLeft | The top-left rectangle coordinates.
ptBottomRight | The bottom-right rectangle coordinates.

◆ SetRect() [4/4]

template<class T >
void SetRect | ( | T | x,
 |  | T | y,
 |  | T | width,
 |  | T | height )
 inline

Sets new rectangle data.

Parameters
x | The x coordinate.
y | The y coordinate.
width | The width of the rectangle.
height | The height of the rectangle.

◆ Union()

template<class T >
static bool AFX_CDECL Union | ( | CXTPRectT< T > & | c,
 |  | const CXTPRectT< T > & | a,
 |  | const CXTPRectT< T > & | b )
 inlinestatic

Call this static function to calculates the union of two source rectangles and places the coordinates of the union rectangle into the destination rectangle.

Parameters
c | The reference to destination rectangle.
a | The first source rectangle.
b | The second source rectangle.
Returns
TRUE if the operation succeed and FALSE if operation failed.

The union is the smallest rectangle that contains both source rectangles.

The documentation for this class was generated from the following file:
  • XTPRect.h


Toolkit Pro: CXTPRegistryManager Class Reference

Public Member Functions | Static Public Member Functions | Protected Member Functions | Protected Attributes | Static Protected Attributes | List of all members
CXTPRegistryManager Class Reference

CXTPRegistryManager is a standalone registry management class. More...

Public Member Functions

CXTPRegistryManager (HKEY hKeyBase=HKEY_CURRENT_USER)
Constructs a CXTPRegistryManager object.
virtual | ~CXTPRegistryManager ()
Destroys a CXTPRegistryManager object, handles cleanup and deallocation.
void | SetRegistryKey (LPCTSTR lpszRegistryKey, LPCTSTR lpszProfileName)
This member function will set a registry key.
BOOL | WriteProfileInt (LPCTSTR lpszSection, LPCTSTR lpszEntry, int nValue)
Call this member function to write the specified int value into the specified section of the application's registry or .INI file.
BOOL | WriteProfileBinary (LPCTSTR lpszSection, LPCTSTR lpszEntry, LPBYTE pData, UINT nBytes)
Call this member function to write the specified binary value into the specified section of the application's registry or .INI file.
BOOL | WriteProfileString (LPCTSTR lpszSection, LPCTSTR lpszEntry, LPCTSTR lpszValue)
Call this member function to write the specified string value into the specified section of the application's registry or .INI file.
BOOL | WriteProfilePoint (LPCTSTR lpszSection, LPCTSTR lpszEntry, CPoint *pValue)
Call this member function to write the specified CPoint value into the specified section of the application's registry or .INI file.
BOOL | WriteProfileRect (LPCTSTR lpszSection, LPCTSTR lpszEntry, CRect *pValue)
Call this member function to write the specified CRect value into the specified section of the application's registry or .INI file.
BOOL | WriteProfileSize (LPCTSTR lpszSection, LPCTSTR lpszEntry, CSize *pValue)
Call this member function to write the specified CSize value into the specified section of the application's registry or .INI file.
BOOL | WriteProfileDouble (LPCTSTR lpszSection, LPCTSTR lpszEntry, double *pValue)
Call this member function to write the specified double/float value into the specified section of the application's registry or .INI file.
BOOL | WriteProfileDword (LPCTSTR lpszSection, LPCTSTR lpszEntry, DWORD *pValue)
Call this member function to write the specified DWORD value into the specified section of the application's registry or .INI file.
BOOL | WriteProfileColor (LPCTSTR lpszSection, LPCTSTR lpszEntry, COLORREF *pValue)
Call this member function to write the specified COLORREF value into the specified section of the application's registry or .INI file.
UINT | GetProfileInt (LPCTSTR lpszSection, LPCTSTR lpszEntry, int nDefault)
Call this member function to retrieve the value of an integer from an entry within a specified section of the application's registry or .INI file.
BOOL | GetProfileBinary (LPCTSTR lpszSection, LPCTSTR lpszEntry, BYTE **ppData, UINT *pBytes)
Call this member function to retrieve the binary value from an entry within a specified section of the application's registry or .INI file.
CString | GetProfileString (LPCTSTR lpszSection, LPCTSTR lpszEntry, LPCTSTR lpszDefault)
Call this member function to retrieve the string associated with an entry within the specified section in the application's registry or .INI file.
BOOL | GetProfilePoint (LPCTSTR lpszSection, LPCTSTR lpszEntry, CPoint *ptResult)
Call this member function to retrieve the value of a CPoint from an entry within a specified section of the application's registry or .INI file.
BOOL | GetProfileRect (LPCTSTR lpszSection, LPCTSTR lpszEntry, CRect *rcResult)
Call this member function to retrieve the value of a CRect from an entry within a specified section of the application's registry or .INI file.
BOOL | GetProfileSize (LPCTSTR lpszSection, LPCTSTR lpszEntry, CSize *rcResult)
Call this member function to retrieve the value of a CSize from an entry within a specified section of the application's registry or .INI file.
BOOL | GetProfileDouble (LPCTSTR lpszSection, LPCTSTR lpszEntry, double *rcResult)
Call this member function to retrieve the value of a double from an entry within a specified section of the application's registry or .INI file.
BOOL | GetProfileDword (LPCTSTR lpszSection, LPCTSTR lpszEntry, DWORD *rcResult)
Call this member function to retrieve the value of a DWORD from an entry within a specified section of the application's registry or .INI file.
BOOL | GetProfileColor (LPCTSTR lpszSection, LPCTSTR lpszEntry, COLORREF *rcResult)
Call this member function to retrieve the value of a COLORREF from an entry within a specified section of the application's registry or .INI file.
int | EnumValues (LPCTSTR lpszSection, CMap< CString, LPCTSTR, DWORD, DWORD & > *mapItems, CStringArray *arrayNames)
Call this function to fill a CMap (CString to DWORD) with the names and value types under a specific registry section.
int | EnumKeys (LPCTSTR lpszSection, CStringArray &arrayKeys)
Call this function to fill a CStringArray with the names of keys below the key specified.
bool | DeleteKey (LPCTSTR lpszSection, LPCTSTR lpszKey)
Call this function to delete a registry key and all of its contents.
bool | DeleteValue (LPCTSTR lpszSection, LPCTSTR lpszKey)
Call this function to delete a registry value.
LONG | GetErrorCode () const
Call this member function to retrieve that last error (if any) that was returned by Windows when accessing the system registry.
CString | GetErrorMessage () const
Call this member function to retrieve the description text for the last error (if any) that occurred while accessing the system registry.

Static Public Member Functions

static void AFX_CDECL | SetINIFileName (LPCTSTR strINIFileName)
This member function will set the .INI file name for the registry manager to use instead of the system registry.
static CString &AFX_CDECL | GetINIFileName ()
This member function will return the file name of the .INI file used by the registry manager.

Protected Member Functions

virtual HKEY | GetAppRegistryKey (REGSAM samDesired=KEY_WRITE|KEY_READ)
Called to get a handle to the CWinApp's registry key.
virtual HKEY | GetSectionKey (LPCTSTR lpszSection, REGSAM samDesired=KEY_WRITE|KEY_READ)
Called to get a handle to the specified section from the application's registry key.

Protected Attributes

HKEY | m_hKeyBase
Handle to the registry key to use.
CString | m_strRegistryKey
Used to determine the full registry key for storing application profile settings.
CString | m_strProfileName
The application's .INI filename.

Static Protected Attributes

static CString m_strINIFileName
Name of an .INI file for registry settings.

Detailed Description

CXTPRegistryManager is a standalone registry management class.

You can use it to read and write values from your system's registry or an .INI file. Use CXTPRegistryManager to read and write string, integer, and binary data to and from the registry. You can also specify an .INI file name, and have these values stored there instead.

Constructor & Destructor Documentation

◆ CXTPRegistryManager()

CXTPRegistryManager ( HKEY hKeyBase = HKEY_CURRENT_USER )

Constructs a CXTPRegistryManager object.

Parameters
hKeyBase Current key to be used in the registry. By default, this parameter is HKEY_CURRENT_USER.

Member Function Documentation

◆ DeleteKey()

bool DeleteKey | ( | LPCTSTR | lpszSection,
 |  | LPCTSTR | lpszKey )

Call this function to delete a registry key and all of its contents.

Parameters
lpszSection | Pointer to a NULL-terminated string that specifies the section containing the entry.
lpszKey | Pointer to a NULL-terminated string that specifies the subkey to delete.
Returns
true if successful, otherwise false.

◆ DeleteValue()

bool DeleteValue | ( | LPCTSTR | lpszSection,
 |  | LPCTSTR | lpszKey )

Call this function to delete a registry value.

Parameters
lpszSection | Pointer to a NULL-terminated string that specifies the section containing the entry.
lpszKey | Pointer to a NULL-terminated string that specifies the value to delete.
Returns
true if successful, otherwise false.

◆ EnumKeys()

int EnumKeys | ( | LPCTSTR | lpszSection,
 |  | CStringArray & | arrayKeys )

Call this function to fill a CStringArray with the names of keys below the key specified.

The return value indicates the number of keys found by the function, which can be used to check if any were found. CStringArray::GetSize will give the same result if needed, assuming the array is zeroed when it goes in. The function does not zero it, leaving the possibility of getting a list of subkeys of more than one key for whatever reason.

Parameters
lpszSection | Pointer to a NULL-terminated string that specifies the section containing the entry.
arrayKeys | A reference to a CStringArray, which will contain the keys in the registry under the above key.
Returns
A number of enumerated keys.

◆ EnumValues()

int EnumValues | ( | LPCTSTR | lpszSection,
 |  | CMap< CString, LPCTSTR, DWORD, DWORD & > * | mapItems,
 |  | CStringArray * | arrayNames )

Call this function to fill a CMap (CString to DWORD) with the names and value types under a specific registry section.

Parameters
lpszSection | Pointer to a NULL-terminated string that specifies the section containing the entry.
mapItems | A reference to a CMap, which will contain the items in the registry under this section. Can be NULL. Does not include subsection names.
arrayNames | A reference to a CStringArray which, if not NULL, will contain an array of names in the order they were read from the registry.

The function also takes a pointer to a CStringArray because CMap is a sorted container. Therefore, it is not possible to get the items in the order they appeared from it.

Pass NULL for the CStringArray* if you don't want to use it, and NULL into the CMap if you only require a list of the item names.

The DWORD values returned are as follows:

REG_BINARY: Binary data in any form. REG_DWORD: A 32-bit number. REG_DWORD_LITTLE_ENDIAN: A 32-bit number in little-endian format. This is equivalent to REG_DWORD. In little-endian format, a multi-byte value is stored in memory from the lowest byte (the "little end") to the highest byte. For example, the value 0x12345678 is stored as (0x78 0x56 0x34 0x12) in little-endian format. Windows NT/Windows 2000, Windows 95, and Windows 98 are designed to run on little-endian computer architectures. A user may connect to computers that have big-endian architectures, such as some UNIX systems. REG_DWORD_BIG_ENDIAN: A 32-bit number in big-endian format. In big-endian format, a multi-byte value is stored in memory from the highest byte (the "big end") to the lowest byte. For example, the value 0x12345678 is stored as (0x12 0x34 0x56 0x78) in big-endian format. REG_EXPAND_SZ: A NULL-terminated string that contains unexpanded references to environment variables (for example, "\%PATH\%"). It will be either a Unicode or ANSI string depending on whether you use the Unicode or ANSI functions. To expand the environment variable references, use the ExpandEnvironmentStrings function. REG_LINK: A Unicode symbolic link. Used internally. Applications should not use this type. REG_MULTI_SZ: An array of NULL-terminated strings, terminated by two null characters. REG_NONE: No defined value type. REG_QWORD: A 64-bit number. REG_QWORD_LITTLE_ENDIAN: A 64-bit number in little-endian format. This is equivalent to REG_QWORD. REG_RESOURCE_LIST: A device-driver resource list. REG_SZ: A NULL-terminated string. It will be either a Unicode or ANSI string, depending on whether or not you use the Unicode or ANSI functions.

Returns
Zero if the section is empty. Otherwise it returns the number of values present.

◆ GetAppRegistryKey()

virtual HKEY GetAppRegistryKey ( REGSAM samDesired = KEY_WRITE|KEY_READ )
protectedvirtual

Called to get a handle to the CWinApp's registry key.

Parameters
samDesired An access mask that specifies the desired access rights to the key.
Returns
An HKEY handle to the application's registry key.

◆ GetErrorCode()

LONG GetErrorCode ( ) const

Call this member function to retrieve that last error (if any) that was returned by Windows when accessing the system registry.

Returns
If the last operation was successful, then the return value is ERROR_SUCCESS. Otherwise a nonzero error code is returned as defined in Winerror.h. You can call GetErrorMessage() to get a generic description of the error.

◆ GetErrorMessage()

CString GetErrorMessage ( ) const

Call this member function to retrieve the description text for the last error (if any) that occurred while accessing the system registry.

Returns
A CString object that contains the error message that describes the last error that occurred while accessing the system registry.

◆ GetINIFileName()

static CString &AFX_CDECL GetINIFileName ( )
static

This member function will return the file name of the .INI file used by the registry manager.

Returns
A reference to the CString object that contains the .INI file path.

◆ GetProfileBinary()

BOOL GetProfileBinary | ( | LPCTSTR | lpszSection,
 |  | LPCTSTR | lpszEntry,
 |  | BYTE ** | ppData,
 |  | UINT * | pBytes )

Call this member function to retrieve the binary value from an entry within a specified section of the application's registry or .INI file.

Parameters
lpszSection | Pointer to a NULL-terminated string that specifies the section containing the entry.
lpszEntry | Pointer to a NULL-terminated string that contains the entry whose value is to be retrieved.
pBytes | Address of a UINT to receive the size of 'ppData'.
ppData Address of a LPBYTE data member to receive the value. It is the caller's responsibility to free the memory allocated for 'ppData'. Example: An example of this would be:
void CXTDockWindow::LoadBarSize(CString strSection)
{
   // restore the previous bar style.
   if (::IsWindow(m_hWnd))
   {
      UINT nSize = 0;
      LPBYTE pbtData = 0;
      CString string;
      string.LoadString(XTP_IDS_REG_BARPOS);

      CXTPRegistryManager regManager;
      if (regManager.GetProfileBinary(strSection,
         string, &pbtData, &nSize))
      {
         XT_BARPLACEMENT* pBP =
         reinterpret_cast<XT_BARPLACEMENT*>(pbtData);

         SetBarPlacement(pBP);
         delete [] pbtData;
      }
   }
}
Returns
Nonzero if successful, otherwise zero.

◆ GetProfileColor()

BOOL GetProfileColor | ( | LPCTSTR | lpszSection,
 |  | LPCTSTR | lpszEntry,
 |  | COLORREF * | rcResult )

Call this member function to retrieve the value of a COLORREF from an entry within a specified section of the application's registry or .INI file.

Retrieves the value that follows the specified entry if the function is successful.

Parameters
lpszSection | Pointer to a NULL-terminated string that specifies the section containing the entry.
lpszEntry | Pointer to a NULL-terminated string that contains the entry whose value is to be retrieved.
rcResult | Pointer to the variable to be filled from the registry.

Since COLORREF is a typedef for a DWORD, this function only calls GetProfileDword.

Returns
TRUE if successful, otherwise FALSE.

◆ GetProfileDouble()

BOOL GetProfileDouble | ( | LPCTSTR | lpszSection,
 |  | LPCTSTR | lpszEntry,
 |  | double * | rcResult )

Call this member function to retrieve the value of a double from an entry within a specified section of the application's registry or .INI file.

Retrieves the value that follows the specified entry if the function is successful.

Parameters
lpszSection | Pointer to a NULL-terminated string that specifies the section containing the entry.
lpszEntry | Pointer to a NULL-terminated string that contains the entry whose value is to be retrieved.
rcResult | Pointer to the variable to be filled from the registry.
Returns
TRUE if successful, otherwise FALSE.

◆ GetProfileDword()

BOOL GetProfileDword | ( | LPCTSTR | lpszSection,
 |  | LPCTSTR | lpszEntry,
 |  | DWORD * | rcResult )

Call this member function to retrieve the value of a DWORD from an entry within a specified section of the application's registry or .INI file.

Retrieves the value that follows the specified entry if the function is successful.

Parameters
lpszSection | Pointer to a NULL-terminated string that specifies the section containing the entry.
lpszEntry | Pointer to a NULL-terminated string that contains the entry whose value is to be retrieved.
rcResult | Pointer to the variable to be filled from the registry.

Since COLORREF is a typedef for a DWORD, GetProfileColor calls this function.

Returns
TRUE if successful, otherwise FALSE.

◆ GetProfileInt()

UINT GetProfileInt | ( | LPCTSTR | lpszSection,
 |  | LPCTSTR | lpszEntry,
 |  | int | nDefault )

Call this member function to retrieve the value of an integer from an entry within a specified section of the application's registry or .INI file.

Parameters
lpszSection | Pointer to a NULL-terminated string that specifies the section containing the entry.
lpszEntry | Pointer to a NULL-terminated string that contains the entry whose value is to be retrieved.
nDefault | Specifies the default value to return if the framework cannot find the entry. This value can be an unsigned value in the range 0 through 65, 535 or a signed value in the range -32, 768 through 32, 767.

This member function supports hexadecimal notation for the value in the .INI file. When you retrieve a signed integer, you should cast the value into an int.

Returns
The integer value of the string that follows the specified entry if the function is successful, the value of the 'nDefault' parameter if the function does not find the entry, or zero if the value that corresponds to the specified entry is not an integer.

◆ GetProfilePoint()

BOOL GetProfilePoint | ( | LPCTSTR | lpszSection,
 |  | LPCTSTR | lpszEntry,
 |  | CPoint * | ptResult )

Call this member function to retrieve the value of a CPoint from an entry within a specified section of the application's registry or .INI file.

Retrieves the CPoint value that follows the specified entry if the function is successful.

Parameters
lpszSection | Pointer to a NULL-terminated string that specifies the section containing the entry.
lpszEntry | Pointer to a NULL-terminated string that contains the entry whose value is to be retrieved.
ptResult | Pointer to the variable to be filled from the registry.
Returns
TRUE if successful, otherwise FALSE.

◆ GetProfileRect()

BOOL GetProfileRect | ( | LPCTSTR | lpszSection,
 |  | LPCTSTR | lpszEntry,
 |  | CRect * | rcResult )

Call this member function to retrieve the value of a CRect from an entry within a specified section of the application's registry or .INI file.

Retrieves the CRect value that follows the specified entry if the function is successful.

Parameters
lpszSection | Pointer to a NULL-terminated string that specifies the section containing the entry.
lpszEntry | Pointer to a NULL-terminated string that contains the entry whose value is to be retrieved.
rcResult | Pointer to the variable to be filled from the registry.
Returns
TRUE if successful, otherwise FALSE.

◆ GetProfileSize()

BOOL GetProfileSize | ( | LPCTSTR | lpszSection,
 |  | LPCTSTR | lpszEntry,
 |  | CSize * | rcResult )

Call this member function to retrieve the value of a CSize from an entry within a specified section of the application's registry or .INI file.

Retrieves the CSize value that follows the specified entry if the function is successful.

Parameters
lpszSection | Pointer to a NULL-terminated string that specifies the section containing the entry.
lpszEntry | Pointer to a NULL-terminated string that contains the entry whose value is to be retrieved.
rcResult | Pointer to the variable to be filled from the registry.
Returns
TRUE if successful, otherwise FALSE.

◆ GetProfileString()

CString GetProfileString | ( | LPCTSTR | lpszSection,
 |  | LPCTSTR | lpszEntry,
 |  | LPCTSTR | lpszDefault )

Call this member function to retrieve the string associated with an entry within the specified section in the application's registry or .INI file.

The return value is the string from the application's .INI file, or 'lpszDefault' if the string cannot be found. The maximum string length supported by the framework is _MAX_PATH. If 'lpszDefault' is NULL, then the return value is an empty string.

Parameters
lpszSection | Pointer to a NULL-terminated string that specifies the section containing the entry.
lpszEntry | Pointer to a NULL-terminated string that contains the entry whose value is to be retrieved.
lpszDefault | Pointer to the default string value for the given entry if the entry cannot be found in the initialization file.
Returns
The string associated with an entry within the specified section in the application's registry or .INI file. The return value is the string from the application's .INI file, or 'lpszDefault' if the string cannot be found.

◆ GetSectionKey()

virtual HKEY GetSectionKey | ( | LPCTSTR | lpszSection,
 |  | REGSAM | samDesired = KEY_WRITE|KEY_READ )
 protectedvirtual

Called to get a handle to the specified section from the application's registry key.

Parameters
lpszSection | Section to get the key for.
samDesired | An access mask that specifies the desired access rights to the key.
Returns
An HKEY handle to the specified section from the application's registry key.

◆ SetINIFileName()

static void AFX_CDECL SetINIFileName ( LPCTSTR strINIFileName )
static

This member function will set the .INI file name for the registry manager to use instead of the system registry.

Parameters
strINIFileName Full path to the .INI file.
Returns

◆ SetRegistryKey()

void SetRegistryKey | ( | LPCTSTR | lpszRegistryKey,
 |  | LPCTSTR | lpszProfileName )

This member function will set a registry key.

Parameters
lpszRegistryKey | Used to determine the full registry key for storing application profile settings.
lpszProfileName | The application's .INI filename.

Calling SetRegistryKey will initialize m_pszProfileName and m_pszRegistryKey for CWinApp.

◆ WriteProfileBinary()

BOOL WriteProfileBinary | ( | LPCTSTR | lpszSection,
 |  | LPCTSTR | lpszEntry,
 |  | LPBYTE | pData,
 |  | UINT | nBytes )

Call this member function to write the specified binary value into the specified section of the application's registry or .INI file.

Parameters
lpszSection | Pointer to a NULL-terminated string that specifies the section containing the entry. If the section does not exist, then it is created. The name of the section is case independent. The string may be any combination of uppercase and lowercase letters.
lpszEntry | Pointer to a NULL-terminated string that contains the entry into which the value is to be written. If the entry does not exist in the specified section, then it is created.
pData | Contains the value to be written.
nBytes | Contains the size of the value to be written.
Returns
Nonzero if successful, otherwise zero. If the user does not have access rights to modify the system registry, then this function will return -1.

◆ WriteProfileColor()

BOOL WriteProfileColor | ( | LPCTSTR | lpszSection,
 |  | LPCTSTR | lpszEntry,
 |  | COLORREF * | pValue )

Call this member function to write the specified COLORREF value into the specified section of the application's registry or .INI file.

Parameters
lpszSection | Pointer to a NULL-terminated string that specifies the section containing the entry. If the section does not exist, then it is created. The name of the section is case independent. The string may be any combination of uppercase and lowercase letters.
lpszEntry | Pointer to a NULL-terminated string that contains the entry into which the value is to be written. If the entry does not exist in the specified section, then it is created.
pValue | Contains the value to be written.

Since COLORREF is a typedef for a DWORD, this function only calls WriteProfileDword.

Returns
Nonzero if successful, otherwise zero. If the user does not have access rights to modify the system registry, then this function will return -1.

◆ WriteProfileDouble()

BOOL WriteProfileDouble | ( | LPCTSTR | lpszSection,
 |  | LPCTSTR | lpszEntry,
 |  | double * | pValue )

Call this member function to write the specified double/float value into the specified section of the application's registry or .INI file.

Parameters
lpszSection | Pointer to a NULL-terminated string that specifies the section containing the entry. If the section does not exist, then it is created. The name of the section is case independent. The string may be any combination of uppercase and lowercase letters.
lpszEntry | Pointer to a NULL-terminated string that contains the entry into which the value is to be written. If the entry does not exist in the specified section, then it is created.
pValue | Contains the value to be written.
Returns
Nonzero if successful, otherwise zero. If the user does not have access rights to modify the system registry, then this function will return -1.

◆ WriteProfileDword()

BOOL WriteProfileDword | ( | LPCTSTR | lpszSection,
 |  | LPCTSTR | lpszEntry,
 |  | DWORD * | pValue )

Call this member function to write the specified DWORD value into the specified section of the application's registry or .INI file.

Parameters
lpszSection | Pointer to a NULL-terminated string that specifies the section containing the entry. If the section does not exist, then it is created. The name of the section is case independent. The string may be any combination of uppercase and lowercase letters.
lpszEntry | Pointer to a NULL-terminated string that contains the entry into which the value is to be written. If the entry does not exist in the specified section, then it is created.
pValue | Contains the value to be written.

Since COLORREF is a typedef for a DWORD, WriteProfileColor calls this function.

Returns
Nonzero if successful, otherwise zero. If the user does not have access rights to modify the system registry, then this function will return -1.

◆ WriteProfileInt()

BOOL WriteProfileInt | ( | LPCTSTR | lpszSection,
 |  | LPCTSTR | lpszEntry,
 |  | int | nValue )

Call this member function to write the specified int value into the specified section of the application's registry or .INI file.

Parameters
lpszSection | Pointer to a NULL-terminated string that specifies the section containing the entry. If the section does not exist, then it is created. The name of the section is case independent. The string may be any combination of uppercase and lowercase letters.
lpszEntry | Pointer to a NULL-terminated string that contains the entry into which the value is to be written. If the entry does not exist in the specified section, then it is created.
nValue | Contains the value to be written.
Returns
Nonzero if successful, otherwise zero. If the user does not have access rights to modify the system registry, then this function will return -1.

◆ WriteProfilePoint()

BOOL WriteProfilePoint | ( | LPCTSTR | lpszSection,
 |  | LPCTSTR | lpszEntry,
 |  | CPoint * | pValue )

Call this member function to write the specified CPoint value into the specified section of the application's registry or .INI file.

Parameters
lpszSection | Pointer to a NULL-terminated string that specifies the section containing the entry. If the section does not exist, then it is created. The name of the section is case independent. The string may be any combination of uppercase and lowercase letters.
lpszEntry | Pointer to a NULL-terminated string that contains the entry into which the value is to be written. If the entry does not exist in the specified section, then it is created.
pValue | Contains the value to be written.
Returns
Nonzero if successful, otherwise zero. If the user does not have access rights to modify the system registry, then this function will return -1.

◆ WriteProfileRect()

BOOL WriteProfileRect | ( | LPCTSTR | lpszSection,
 |  | LPCTSTR | lpszEntry,
 |  | CRect * | pValue )

Call this member function to write the specified CRect value into the specified section of the application's registry or .INI file.

Parameters
lpszSection | Pointer to a NULL-terminated string that specifies the section containing the entry. If the section does not exist, then it is created. The name of the section is case independent. The string may be any combination of uppercase and lowercase letters.
lpszEntry | Pointer to a NULL-terminated string that contains the entry into which the value is to be written. If the entry does not exist in the specified section, then it is created.
pValue | Contains the value to be written.
Returns
Nonzero if successful, otherwise zero. If the user does not have access rights to modify the system registry, then this function will return -1.

◆ WriteProfileSize()

BOOL WriteProfileSize | ( | LPCTSTR | lpszSection,
 |  | LPCTSTR | lpszEntry,
 |  | CSize * | pValue )

Call this member function to write the specified CSize value into the specified section of the application's registry or .INI file.

Parameters
lpszSection | Pointer to a NULL-terminated string that specifies the section containing the entry. If the section does not exist, then it is created. The name of the section is case independent. The string may be any combination of uppercase and lowercase letters.
lpszEntry | Pointer to a NULL-terminated string that contains the entry into which the value is to be written. If the entry does not exist in the specified section, then it is created.
pValue | Contains the value to be written.
Returns
Nonzero if successful, otherwise zero. If the user does not have access rights to modify the system registry, then this function will return -1.

◆ WriteProfileString()

BOOL WriteProfileString | ( | LPCTSTR | lpszSection,
 |  | LPCTSTR | lpszEntry,
 |  | LPCTSTR | lpszValue )

Call this member function to write the specified string value into the specified section of the application's registry or .INI file.

Parameters
lpszSection | Pointer to a NULL-terminated string that specifies the section containing the entry. If the section does not exist, then it is created. The name of the section is case independent. The string may be any combination of uppercase and lowercase letters.
lpszEntry | Pointer to a NULL-terminated string that contains the entry into which the value is to be written. If the entry does not exist in the specified section, then it is created.
lpszValue | Contains the value to be written.
Returns
Nonzero if successful, otherwise zero. If the user does not have access rights to modify the system registry, then this function will return -1.

Member Data Documentation

◆ m_hKeyBase

HKEY m_hKeyBase
protected

Handle to the registry key to use.

The default is HKEY_CURRENT_USER.

The documentation for this class was generated from the following file:
  • XTPRegistryManager.h


Toolkit Pro: CXTPResize Class Reference

Public Member Functions | Protected Types | Protected Member Functions | Protected Attributes | List of all members
CXTPResize Class Reference

CXTPResize is a base class. More...

Inheritance diagram for CXTPResize:
[legend]

Public Member Functions

CXTPResize (CWnd *pWnd, const UINT nFlags=0)
Constructs a CXTPResize object.
virtual | ~CXTPResize ()
Destroys a CXTPResize object, handles cleanup and deallocation.
void | SetResize (UINT nID, XTP_RESIZE left, XTP_RESIZE top, XTP_RESIZE right, XTP_RESIZE bottom)
The SetResize function specifies how much each side of a control will move when the dialog is resized.
void | SetResize (UINT nID, const XTP_RESIZERECT &rrcSizing)
The SetResize function specifies how much each side of a control will move when the dialog is resized.
void | SetResize (UINT nID, HWND hWnd, const XTP_RESIZERECT &rrcSizing)
The SetResize function specifies how much each side of a control will move when the dialog is resized.
void | SetResize (UINT nID, HWND hWnd, const XTP_RESIZEPOINT &rpTopLeft, const XTP_RESIZEPOINT &rpBottomRight)
The SetResize function specifies how much each side of a control will move when the dialog is resized.
void | SetResize (UINT nID, const XTP_RESIZEPOINT &rpTopLeft, const XTP_RESIZEPOINT &rpBottomRight)
The SetResize function specifies how much each side of a control will move when the dialog is resized.
void | SetMinSize (CSize &sz)
This member function sets the minimum size explicitly.
void | SetMaxSize (CSize &sz)
This member function sets the maximum size.
BOOL | SavePlacement (LPCTSTR pszSection)
This member function saves the window placement to the registry.
BOOL | LoadPlacement (LPCTSTR pszSection)
This member function loads saved window placement information from the registry.
BOOL | AutoLoadPlacement (LPCTSTR pszSection)
This member function loads saved window placement information from the registry.

Protected Types

typedef CArray< CXTPResizeItem *, CXTPResizeItem *& > CResizeItemArray
Used by CXTPResize to maintain a list of children that are sizable.

Protected Member Functions

void | SetResize (CWnd *pWnd, const CXTPResizeRect &rrcSizing, CRect rcWindow)
The SetResize function specifies how much each side of a control will move when the dialog is resized.
BOOL | RemoveResize (UINT nID)
This member function is called to remove the specified dialog item from the list of items to be resized.
void | RemoveAllControls ()
This member function is called to purge the list that contains the dialog items to be sized.
virtual void | Init ()
This member function is called from OnInitDialog or OnInitialUpdate to initialize the resize manager.
virtual void | Size ()
This member function is called from OnSize to move and resize the dialog items that are managed.
void | Reset ()
This member function is called when a property sheet in wizard mode has changed pages to alert the resize manager that the property sheet (common control) has moved the page back to its original size/position on the sheet.
void | Offset (CPoint ptOffset)
Called to offset dialog items by the amount specified by ptOffset.
void | UpdateControlRect (CWnd *pWnd)
Call this method to reset m_rrcWindow for an item.
void | GetMinMaxInfo (MINMAXINFO *pMMI)
This member function is called from OnGetMinMaxInfo to get the maximized position or dimensions or the minimum or maximum tracking size.
virtual void | AdjustResizeRect (CSize &rcWindow)
This method is called in the Size method to adjust a window rectangle to fit real client size.
BOOL | HasFlag (XTPResize eFlag)
This member function is called to determine if the specified flag has been set for the resize manager.
void | SetFlag (XTPResize eFlag)
This member function is called to set a specific flag for the resize manager.
virtual BOOL | Defer (HDWP &hdwp, CXTPResizeItem *pItem, int dx, int dy)
Called by CXTPResize to resize a child window.

Protected Attributes

UINT | m_nFlagsXX
Flags passed from the constructor.
CWnd * | m_pWnd
The associative relation to the window to be resized.
CSize | m_szWindow
Last dialog size.
CSize | m_szInitWindow
Initial dialog size.
CSize | m_szMin
Smallest size allowed.
CSize | m_szMax
Largest size allowed.
CString | m_strSection
Section in registry where window placement information is saved.
CXTPSizeIcon | m_scSizeIcon
Size icon window.
CResizeItemArray | m_arrItems
Array of controls.

Detailed Description

CXTPResize is a base class.

It is used by resizing dialogs, property sheets, and form views. It acts as a manager to maintain the size and location of the dialog and dialog items.

Constructor & Destructor Documentation

◆ CXTPResize()

CXTPResize | ( | CWnd * | pWnd,
 |  | const UINT | nFlags = 0 )

Constructs a CXTPResize object.

Parameters
pWnd | Pointer to the parent or owner window object, of type CWnd, to which the resizing object belongs.
nFlags | Flags that are to be passed to CXTPResize that specify the attributes of the resizing property page. See the Remarks section for a list of flags.

Styles to be added or removed can be combined by using the bitwise OR (|) operator. It can be one or more of the following: xtpResizeNoSizeIcon: Do not add size icon. xtpResizeNoHorizontal: No horizontal resizing. xtpResizeNoVertical: No vertical resizing. xtpResizeNoMinsize: Do not require a minimum size. xtpResizeNoClipChildren: Do not set clip children style. xtpResizeNoTransparentGroup: Do not set transparent style for group boxes.

Member Function Documentation

◆ AdjustResizeRect()

virtual void AdjustResizeRect ( CSize & rcWindow )
protectedvirtual

This method is called in the Size method to adjust a window rectangle to fit real client size.

Parameters
rcWindow Window rectangle to change.

Reimplemented in CXTPResizeFormView.

◆ AutoLoadPlacement()

BOOL AutoLoadPlacement ( LPCTSTR pszSection )

This member function loads saved window placement information from the registry.

This version is the same as LoadPlacement but there is no need for calling SavePlacement when the window is destroyed. This will be called automatically.

Parameters
pszSection Name of a section in the initialization file or a key in the Windows registry where placement information is stored.
Returns
TRUE if the position was changed.

◆ Defer()

virtual BOOL Defer | ( | HDWP & | hdwp,
 |  | CXTPResizeItem * | pItem,
 |  | int | dx,
 |  | int | dy )
 protectedvirtual

Called by CXTPResize to resize a child window.

Parameters
hdwp | [in] Handle to a multiple-window position structure that contains size and position information for one or more windows. This structure is returned by BeginDeferWindowPos or by the most recent call to DeferWindowPos.
pItem | [in] Pointer to a CXTPResizeItem object that contains additional information about the window being sized.
dx | [in] Specifies the window's new width, in pixels.
dy | [in] Specifies the window's new height, in pixels.
Returns
TRUE if successful, otherwise FALSE.

◆ GetMinMaxInfo()

void GetMinMaxInfo ( MINMAXINFO * pMMI )
protected

This member function is called from OnGetMinMaxInfo to get the maximized position or dimensions or the minimum or maximum tracking size.

The maximized size is the size of the window when its borders are fully extended. The maximum tracking size of the window is the largest window size that can be achieved by using the borders to size the window. The minimum tracking size of the window is the smallest window size that can be achieved by using the borders to size the window.

Parameters
pMMI Pointer to a MINMAXINFO structure that contains information about a window's maximized size and position and its minimum and maximum tracking size. For more information about this structure, see the MINMAXINFO structure.

◆ HasFlag()

BOOL HasFlag ( XTPResize eFlag )
protected

This member function is called to determine if the specified flag has been set for the resize manager.

Parameters
eFlag Flag to check. It can be one of the values in the Remarks section.

Styles to be added can one of the following: xtpResizeNoSizeIcon: Do not add size icon. xtpResizeNoHorizontal: No horizontal resizing. xtpResizeNoVertical: No vertical resizing. xtpResizeNoMinsize: Do not require a minimum size. xtpResizeNoClipChildren: Do not set clip children style. xtpResizeNoTransparentGroup: Do not set transparent style for group boxes.

Returns
TRUE if the specified flag has been set, otherwise FALSE.

◆ LoadPlacement()

BOOL LoadPlacement ( LPCTSTR pszSection )

This member function loads saved window placement information from the registry.

Parameters
pszSection Name of a section in the initialization file or a key in the Windows registry where placement information is stored.
Returns
TRUE if the position was changed.

◆ Offset()

void Offset ( CPoint ptOffset )
protected

Called to offset dialog items by the amount specified by ptOffset.

Parameters
ptOffset CPoint determines the amount, in pixels, to offset dialog items.

◆ RemoveResize()

BOOL RemoveResize ( UINT nID )
protected

This member function is called to remove the specified dialog item from the list of items to be resized.

Parameters
nID Specifies the control's ID.
Returns
TRUE if successful, otherwise FALSE.

◆ SavePlacement()

BOOL SavePlacement ( LPCTSTR pszSection )

This member function saves the window placement to the registry.

Parameters
pszSection Name of a section in the initialization file or a key in the Windows registry where placement information is stored.
Returns
TRUE if successful.

◆ SetFlag()

void SetFlag ( XTPResize eFlag )
protected

This member function is called to set a specific flag for the resize manager.

Parameters
eFlag Flag to check. It can be one of the values in the Remarks section.

Styles to be added can one of the following:

xtpResizeNoSizeIcon: Do not add size icon. xtpResizeNoHorizontal: No horizontal resizing. xtpResizeNoVertical: No vertical resizing. xtpResizeNoMinsize: Do not require a minimum size. xtpResizeNoClipChildren: Do not set clip children style. xtpResizeNoTransparentGroup: Do not set transparent style for group boxes.

◆ SetMaxSize()

void SetMaxSize ( CSize & sz )

This member function sets the maximum size.

No maximum is the default.

Parameters
sz Specifies the maximum width and height the dialog can be sized to.

◆ SetMinSize()

void SetMinSize ( CSize & sz )

This member function sets the minimum size explicitly.

Initial size is the default.

Parameters
sz Specifies the minimum width and height the dialog can be sized to.

◆ SetResize() [1/6]

void SetResize | ( | CWnd * | pWnd,
 |  | const CXTPResizeRect & | rrcSizing,
 |  | CRect | rcWindow )
 protected

The SetResize function specifies how much each side of a control will move when the dialog is resized.

If a control should be repositioned (e.g. an OK button), then all four sides should move by the same amount of pixels, as the dialog is resized. If a control should be resized just as much as the dialog (e.g. the list control in the file dialog), then the left and top sides shouldn't move, and the right and bottom sides should move by the same amount of pixels as the dialog.

Parameters
pWnd | Pointer to the dialog item to be resized.
rrcSizing | How much the left, top, right, and bottom sides will move when the dialog is resized.
rcWindow | Initial size of the dialog item.

◆ SetResize() [2/6]

void SetResize | ( | UINT | nID,
 |  | const XTP_RESIZEPOINT & | rpTopLeft,
 |  | const XTP_RESIZEPOINT & | rpBottomRight )

The SetResize function specifies how much each side of a control will move when the dialog is resized.

If a control should be repositioned (e.g. an OK button), then all four sides should move by the same amount of pixels, as the dialog is resized. If a control should be resized just as much as the dialog (e.g. the list control in the file dialog), then the left and top sides shouldn't move, and the right and bottom sides should move by the same amount of pixels as the dialog.

Parameters
nID | Specifies the control's ID.
rpTopLeft | How much the top and left sides will move when the dialog is resized.
rpBottomRight | How much the bottom and right sides will move when the dialog is resized.

◆ SetResize() [3/6]

void SetResize | ( | UINT | nID,
 |  | const XTP_RESIZERECT & | rrcSizing )

The SetResize function specifies how much each side of a control will move when the dialog is resized.

If a control should be repositioned (e.g. an OK button), then all four sides should move by the same amount of pixels, as the dialog is resized. If a control should be resized just as much as the dialog (e.g. the list control in the file dialog), then the left and top sides shouldn't move, and the right and bottom sides should move by the same amount of pixels as the dialog.

Parameters
nID | Specifies the control's ID.
rrcSizing | How much the left, top, right, and bottom sides will move when the dialog is resized.

◆ SetResize() [4/6]

void SetResize | ( | UINT | nID,
 |  | HWND | hWnd,
 |  | const XTP_RESIZEPOINT & | rpTopLeft,
 |  | const XTP_RESIZEPOINT & | rpBottomRight )

The SetResize function specifies how much each side of a control will move when the dialog is resized.

If a control should be repositioned (e.g. an OK button), then all four sides should move by the same amount of pixels, as the dialog is resized. If a control should be resized just as much as the dialog (e.g. the list control in the file dialog), then the left and top sides shouldn't move, and the right and bottom sides should move by the same amount of pixels as the dialog.

Parameters
nID | Specifies the control's ID, or 0 to use control's handle value only.
hWnd | HWND of the dialog item to be sized.
rpTopLeft | How much the top and left sides will move when the dialog is resized.
rpBottomRight | How much the bottom and right sides will move when the dialog is resized.

◆ SetResize() [5/6]

void SetResize | ( | UINT | nID,
 |  | HWND | hWnd,
 |  | const XTP_RESIZERECT & | rrcSizing )

The SetResize function specifies how much each side of a control will move when the dialog is resized.

If a control should be repositioned (e.g. an OK button), then all four sides should move by the same amount of pixels, as the dialog is resized. If a control should be resized just as much as the dialog (e.g. the list control in the file dialog), then the left and top sides shouldn't move, and the right and bottom sides should move by the same amount of pixels as the dialog.

Parameters
nID | Specifies the control's ID, or 0 to use control's handle value only.
hWnd | HWND of the dialog item to be sized.
rrcSizing | How much the left, top, right, and bottom sides will move when the dialog is resized.

◆ SetResize() [6/6]

void SetResize | ( | UINT | nID,
 |  | XTP_RESIZE | left,
 |  | XTP_RESIZE | top,
 |  | XTP_RESIZE | right,
 |  | XTP_RESIZE | bottom )

The SetResize function specifies how much each side of a control will move when the dialog is resized.

If a control should be repositioned (e.g. an OK button), then all four sides should move by the same amount of pixels, as the dialog is resized. If a control should be resized just as much as the dialog (e.g. the list control in the file dialog), then the left and top sides shouldn't move, and the right and bottom sides should move by the same amount of pixels as the dialog.

Parameters
nID | Specifies the control's ID.
left | How much the left side will move when the dialog is resized.
top | How much the top side will move when the dialog is resized.
right | How much the right side will move when the dialog is resized.
bottom | How much the bottom side will move when the dialog is resized.

◆ UpdateControlRect()

void UpdateControlRect ( CWnd * pWnd )
protected

Call this method to reset m_rrcWindow for an item.

Parameters
pWnd Window to reset.
The documentation for this class was generated from the following file:
  • XTPResize.h


Toolkit Pro: CXTPResizeDialog Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPResizeDialog Class Reference

CXTPResizeDialog is a multiple inheritance class derived from CDialog and CXTPResize. More...

Inheritance diagram for CXTPResizeDialog:
[legend]

Public Member Functions

CXTPResizeDialog ()
Constructs a CXTPResizeDialog object.
CXTPResizeDialog (const UINT nID, CWnd *pParent=0, const UINT nFlags=0)
Constructs a CXTPResizeDialog object.
CXTPResizeDialog (LPCTSTR lpszTemplateName, CWnd *pParent=0, const UINT nFlags=0)
Constructs a CXTPResizeDialog object.
- Public Member Functions inherited from CXTPResize
CXTPResize (CWnd *pWnd, const UINT nFlags=0)
Constructs a CXTPResize object.
virtual | ~CXTPResize ()
Destroys a CXTPResize object, handles cleanup and deallocation.
void | SetResize (UINT nID, XTP_RESIZE left, XTP_RESIZE top, XTP_RESIZE right, XTP_RESIZE bottom)
The SetResize function specifies how much each side of a control will move when the dialog is resized.
void | SetResize (UINT nID, const XTP_RESIZERECT &rrcSizing)
The SetResize function specifies how much each side of a control will move when the dialog is resized.
void | SetResize (UINT nID, HWND hWnd, const XTP_RESIZERECT &rrcSizing)
The SetResize function specifies how much each side of a control will move when the dialog is resized.
void | SetResize (UINT nID, HWND hWnd, const XTP_RESIZEPOINT &rpTopLeft, const XTP_RESIZEPOINT &rpBottomRight)
The SetResize function specifies how much each side of a control will move when the dialog is resized.
void | SetResize (UINT nID, const XTP_RESIZEPOINT &rpTopLeft, const XTP_RESIZEPOINT &rpBottomRight)
The SetResize function specifies how much each side of a control will move when the dialog is resized.
void | SetMinSize (CSize &sz)
This member function sets the minimum size explicitly.
void | SetMaxSize (CSize &sz)
This member function sets the maximum size.
BOOL | SavePlacement (LPCTSTR pszSection)
This member function saves the window placement to the registry.
BOOL | LoadPlacement (LPCTSTR pszSection)
This member function loads saved window placement information from the registry.
BOOL | AutoLoadPlacement (LPCTSTR pszSection)
This member function loads saved window placement information from the registry.

Protected Attributes

UINT | m_nDialogID
Contains the ID number of a dialog box template resource.
- Protected Attributes inherited from CXTPResize
UINT | m_nFlagsXX
Flags passed from the constructor.
CWnd * | m_pWnd
The associative relation to the window to be resized.
CSize | m_szWindow
Last dialog size.
CSize | m_szInitWindow
Initial dialog size.
CSize | m_szMin
Smallest size allowed.
CSize | m_szMax
Largest size allowed.
CString | m_strSection
Section in registry where window placement information is saved.
CXTPSizeIcon | m_scSizeIcon
Size icon window.
CResizeItemArray | m_arrItems
Array of controls.

Additional Inherited Members

- Protected Types inherited from CXTPResize
typedef CArray< CXTPResizeItem *, CXTPResizeItem *& > | CResizeItemArray
Used by CXTPResize to maintain a list of children that are sizable.
- Protected Member Functions inherited from CXTPResize
void | SetResize (CWnd *pWnd, const CXTPResizeRect &rrcSizing, CRect rcWindow)
The SetResize function specifies how much each side of a control will move when the dialog is resized.
BOOL | RemoveResize (UINT nID)
This member function is called to remove the specified dialog item from the list of items to be resized.
void | RemoveAllControls ()
This member function is called to purge the list that contains the dialog items to be sized.
virtual void | Init ()
This member function is called from OnInitDialog or OnInitialUpdate to initialize the resize manager.
virtual void | Size ()
This member function is called from OnSize to move and resize the dialog items that are managed.
void | Reset ()
This member function is called when a property sheet in wizard mode has changed pages to alert the resize manager that the property sheet (common control) has moved the page back to its original size/position on the sheet.
void | Offset (CPoint ptOffset)
Called to offset dialog items by the amount specified by ptOffset.
void | UpdateControlRect (CWnd *pWnd)
Call this method to reset m_rrcWindow for an item.
void | GetMinMaxInfo (MINMAXINFO *pMMI)
This member function is called from OnGetMinMaxInfo to get the maximized position or dimensions or the minimum or maximum tracking size.
virtual void | AdjustResizeRect (CSize &rcWindow)
This method is called in the Size method to adjust a window rectangle to fit real client size.
BOOL | HasFlag (XTPResize eFlag)
This member function is called to determine if the specified flag has been set for the resize manager.
void | SetFlag (XTPResize eFlag)
This member function is called to set a specific flag for the resize manager.
virtual BOOL | Defer (HDWP &hdwp, CXTPResizeItem *pItem, int dx, int dy)
Called by CXTPResize to resize a child window.

Detailed Description

CXTPResizeDialog is a multiple inheritance class derived from CDialog and CXTPResize.

CXTPResizeDialog is used to create a resizable CDialog type object that allows its dialog items to be resized or moved dynamically.

Constructor & Destructor Documentation

◆ CXTPResizeDialog() [1/3]

CXTPResizeDialog ( )

Constructs a CXTPResizeDialog object.

Styles to be added or removed can be combined by using the bitwise OR (|) operator. It can be one or more of the following: xtpResizeNoSizeIcon: Do not add size icon. xtpResizeNoHorizontal: No horizontal resizing. xtpResizeNoVertical: No vertical resizing. xtpResizeNoMinsize: Do not require a minimum size. xtpResizeNoClipChildren: Do not set clip children style. xtpResizeNoTransparentGroup: Do not set transparent style for group boxes.

◆ CXTPResizeDialog() [2/3]

CXTPResizeDialog | ( | const UINT | nID,
 |  | CWnd * | pParent = 0,
 |  | const UINT | nFlags = 0 )

Constructs a CXTPResizeDialog object.

Parameters
nID | Contains the ID number of a dialog box template resource.
pParent | Pointer to the parent or owner window object of type CWnd, which the dialog object belongs to. If it is NULL, then the dialog object's parent window is set to the main application window.
nFlags | Flags that are to be passed to CXTPResize that specify the attributes of the resizing property page. They can be one or more of the values listed in the Remarks section.

Styles to be added or removed can be combined by using the bitwise OR (|) operator. It can be one or more of the following: xtpResizeNoSizeIcon: Do not add size icon. xtpResizeNoHorizontal: No horizontal resizing. xtpResizeNoVertical: No vertical resizing. xtpResizeNoMinsize: Do not require a minimum size. xtpResizeNoClipChildren: Do not set clip children style. xtpResizeNoTransparentGroup: Do not set transparent style for group boxes.

◆ CXTPResizeDialog() [3/3]

CXTPResizeDialog | ( | LPCTSTR | lpszTemplateName,
 |  | CWnd * | pParent = 0,
 |  | const UINT | nFlags = 0 )

Constructs a CXTPResizeDialog object.

Parameters
lpszTemplateName | Contains a NULL-terminated string that is the name of a dialog-box template resource.
pParent | Pointer to the parent or owner window object of type CWnd, which the dialog object belongs to. If it is NULL, then the dialog object's parent window is set to the main application window.
nFlags | Flags that are to be passed to CXTPResize that specify the attributes of the resizing property page. They can be one or more of the values listed in the Remarks section.

Styles to be added or removed can be combined by using the bitwise OR (|) operator. It can be one or more of the following: xtpResizeNoSizeIcon: Do not add size icon. xtpResizeNoHorizontal: No horizontal resizing. xtpResizeNoVertical: No vertical resizing. xtpResizeNoMinsize: Do not require a minimum size. xtpResizeNoClipChildren: Do not set clip children style. xtpResizeNoTransparentGroup: Do not set transparent style for group boxes.

The documentation for this class was generated from the following file:
  • XTPResizeDialog.h


Toolkit Pro: CXTPResizeFormView Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPResizeFormView Class Reference

CXTPResizeFormView is a multiple inheritance class derived from CFormView and CXTPResize. More...

Inheritance diagram for CXTPResizeFormView:
[legend]

Public Member Functions

CXTPResizeFormView (const UINT nID=0, const UINT nFlags=0)
Constructs a CXTPResizeFormView object.
- Public Member Functions inherited from CXTPResize
CXTPResize (CWnd *pWnd, const UINT nFlags=0)
Constructs a CXTPResize object.
virtual | ~CXTPResize ()
Destroys a CXTPResize object, handles cleanup and deallocation.
void | SetResize (UINT nID, XTP_RESIZE left, XTP_RESIZE top, XTP_RESIZE right, XTP_RESIZE bottom)
The SetResize function specifies how much each side of a control will move when the dialog is resized.
void | SetResize (UINT nID, const XTP_RESIZERECT &rrcSizing)
The SetResize function specifies how much each side of a control will move when the dialog is resized.
void | SetResize (UINT nID, HWND hWnd, const XTP_RESIZERECT &rrcSizing)
The SetResize function specifies how much each side of a control will move when the dialog is resized.
void | SetResize (UINT nID, HWND hWnd, const XTP_RESIZEPOINT &rpTopLeft, const XTP_RESIZEPOINT &rpBottomRight)
The SetResize function specifies how much each side of a control will move when the dialog is resized.
void | SetResize (UINT nID, const XTP_RESIZEPOINT &rpTopLeft, const XTP_RESIZEPOINT &rpBottomRight)
The SetResize function specifies how much each side of a control will move when the dialog is resized.
void | SetMinSize (CSize &sz)
This member function sets the minimum size explicitly.
void | SetMaxSize (CSize &sz)
This member function sets the maximum size.
BOOL | SavePlacement (LPCTSTR pszSection)
This member function saves the window placement to the registry.
BOOL | LoadPlacement (LPCTSTR pszSection)
This member function loads saved window placement information from the registry.
BOOL | AutoLoadPlacement (LPCTSTR pszSection)
This member function loads saved window placement information from the registry.

Protected Member Functions

virtual void | AdjustResizeRect (CSize &rcWindow)
This method called in the Size method to adjust a window rectangle to fit real client size.
- Protected Member Functions inherited from CXTPResize
void | SetResize (CWnd *pWnd, const CXTPResizeRect &rrcSizing, CRect rcWindow)
The SetResize function specifies how much each side of a control will move when the dialog is resized.
BOOL | RemoveResize (UINT nID)
This member function is called to remove the specified dialog item from the list of items to be resized.
void | RemoveAllControls ()
This member function is called to purge the list that contains the dialog items to be sized.
virtual void | Init ()
This member function is called from OnInitDialog or OnInitialUpdate to initialize the resize manager.
virtual void | Size ()
This member function is called from OnSize to move and resize the dialog items that are managed.
void | Reset ()
This member function is called when a property sheet in wizard mode has changed pages to alert the resize manager that the property sheet (common control) has moved the page back to its original size/position on the sheet.
void | Offset (CPoint ptOffset)
Called to offset dialog items by the amount specified by ptOffset.
void | UpdateControlRect (CWnd *pWnd)
Call this method to reset m_rrcWindow for an item.
void | GetMinMaxInfo (MINMAXINFO *pMMI)
This member function is called from OnGetMinMaxInfo to get the maximized position or dimensions or the minimum or maximum tracking size.
BOOL | HasFlag (XTPResize eFlag)
This member function is called to determine if the specified flag has been set for the resize manager.
void | SetFlag (XTPResize eFlag)
This member function is called to set a specific flag for the resize manager.
virtual BOOL | Defer (HDWP &hdwp, CXTPResizeItem *pItem, int dx, int dy)
Called by CXTPResize to resize a child window.

Additional Inherited Members

- Protected Types inherited from CXTPResize
typedef CArray< CXTPResizeItem *, CXTPResizeItem *& > | CResizeItemArray
Used by CXTPResize to maintain a list of children that are sizable.
- Protected Attributes inherited from CXTPResize
UINT | m_nFlagsXX
Flags passed from the constructor.
CWnd * | m_pWnd
The associative relation to the window to be resized.
CSize | m_szWindow
Last dialog size.
CSize | m_szInitWindow
Initial dialog size.
CSize | m_szMin
Smallest size allowed.
CSize | m_szMax
Largest size allowed.
CString | m_strSection
Section in registry where window placement information is saved.
CXTPSizeIcon | m_scSizeIcon
Size icon window.
CResizeItemArray | m_arrItems
Array of controls.

Detailed Description

CXTPResizeFormView is a multiple inheritance class derived from CFormView and CXTPResize.

CXTPResizeFormView is used to create a resizable CFormView type object that allows its form items to be resized or moved dynamically.

Constructor & Destructor Documentation

◆ CXTPResizeFormView()

CXTPResizeFormView | ( | const UINT | nID = 0,
 |  | const UINT | nFlags = 0 )

Constructs a CXTPResizeFormView object.

Parameters
nID | Contains the ID number of a dialog template resource.
nFlags | Flags that are to be passed to CXTPResize that specify the attributes of the resizing property page. They can be one or more of the values in the Remarks section:

Styles to be added or removed can be combined by using the bitwise OR (|) operator. It can be one or more of the following:

xtpResizeNoSizeIcon: Do not add size icon. xtpResizeNoHorizontal: No horizontal resizing. xtpResizeNoVertical: No vertical resizing. xtpResizeNoMinsize: Do not require a minimum size. xtpResizeNoClipChildren: Do not set clip children style. xtpResizeNoTransparentGroup: Do not set transparent style for group boxes.

Member Function Documentation

◆ AdjustResizeRect()

virtual void AdjustResizeRect ( CSize & rcWindow )
protectedvirtual

This method called in the Size method to adjust a window rectangle to fit real client size.

Parameters
rcWindow Window rectangle to change.

Reimplemented from CXTPResize.

The documentation for this class was generated from the following file:
  • XTPResizeFormView.h


Toolkit Pro: CXTPResizeGroupBox Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPResizeGroupBox Class Reference

CXTPResizeGroupBox is a CButton derived class that can be used to display a flicker free group box while resizing. More...

Inheritance diagram for CXTPResizeGroupBox:
[legend]

Public Member Functions

CXTPResizeGroupBox ()
Constructs a CXTPResizeGroupBox object.
virtual | ~CXTPResizeGroupBox ()
Destroys a CXTPResizeGroupBox object, handles cleanup and deallocation.
- Public Member Functions inherited from CXTPButton
CXTPButton ()
Constructs a CXTPButton object.
virtual | ~CXTPButton ()
Destroys a CXTPButton object, handles cleanup and deallocation.
BYTE | GetButtonStyle () const
Retrieves the button styles for this object.
virtual BOOL | IsPushed ()
Call this member function to determine if the the button is currently being pushed.
virtual BOOL | IsHighlighted ()
Call this member function to determine if the the button is currently being highlighted (mouse over).
virtual BOOL | GetChecked ()
Call this member function to determine if the checked state has been defined for the button control.
void | SetChecked (BOOL bChecked)
Sets the highlight state for the button control.
BOOL | GetFlatStyle () const
Gets the flat style appearance of the button control.
void | SetFlatStyle (BOOL bFlatStyle=TRUE)
Sets the flat style appearance of the button control.
BOOL | GetUseVisualStyle () const
Determines if the control is drawn using visual styles/SkinFramework, if supported.
void | SetUseVisualStyle (BOOL bUseVisualStyle=TRUE)
Enables Windows XP visual styles for the control.
long | GetBorderGap () const
Call this member function to retrieve the gap between the button's image and border.
void | SetBorderGap (int nBorderGap)
Call this member function to set the gap between the button's image and border.
XTPPushButtonStyle | GetPushButtonStyle () const
This function retrieves a flag from the XTPPushButtonStyle enumeration that specifies the current style of the button.
void | SetPushButtonStyle (XTPPushButtonStyle nPushButtonStyle)
This member function will set the display style for the button.
virtual int | GetTextAlignment () const
Gets the alignment of the text on the button control.
void | SetTextAlignment (DWORD dwAlignment)
Sets the alignment of the text on the button control.
virtual int | GetImageAlignment () const
Gets the alignment of the image on the button control.
void | SetImageAlignment (DWORD dwAlignment)
Sets the alignment of the image on the button control.
XTPButtonTextImageRelation | GetTextImageRelation () const
Gets the text and image relation in the button.
void | SetTextImageRelation (XTPButtonTextImageRelation relation)
Sets the text and image relation in the button.
long | GetImageGap () const
Call this member function to retrieve the gap between the button's text and image.
void | SetImageGap (int nImageGap)
Call this member function to set the gap between the button's text and image.
virtual CSize | GetImageSize ()
Call this member function to return the size of the image displayed for the button control.
virtual BOOL | IsDpiImageScalingEnabled () const
Call this member to check if DPI scaling of images is enabled.
virtual void | SetDpiImageScaling (BOOL bEnable)
Call this member to enable/disable DPI scaling of images.
CXTPImageManagerIcon * | GetIcon () const
Call this member function to return a pointer to the image manager for the button control.
virtual void | DrawImage (CDC *pDC, CRect rc)
This method is called to draw the image of the control.
XTPGroupBoxBorderStyle | GetBorderStyle () const
Gets the border style of the control.
void | SetBorderStyle (XTPGroupBoxBorderStyle style)
Sets the border style of the control.
BOOL | GetShowFocus () const
Gets whether a focus rectangle is drawn around the contents of a button when the button has focus.
void | SetShowFocus (BOOL bShowFocus)
Sets whether a focus rectangle is drawn around the contents of a button when the button has focus.
virtual BOOL | SetTheme (XTPControlTheme eTheme)
Call this member to switch the visual theme of the control.
virtual void | SetTheme (CXTPButtonTheme *pPaintManager)
Call this member to switch the visual theme of the control.
CXTPButtonTheme * GetTheme ()
Call this member function to get a pointer to the currently selected theme.
void | RedrawButton (BOOL bUpdateWindow=FALSE)
Redraws the button.
BOOL | IsDropDownStyle () const
This member function is called to determine if the buttons have a drop down arrow and if it is drop down style.
virtual CRect | GetButtonRect ()
This member function is called to determine the size and location of the button.
void | SetBuddy (CWnd *pWndBuddy, BOOL bMoveButton=TRUE)
Sets the control used as the buddy control.
void | SetTooltip (LPCTSTR lpszTooltip)
Associates tooltip text with the button.
CString | GetTooltip () const
Call this member to retrieve the button's tooltip.
CXTPToolTipContext * | GetToolTipContext () const
Call this method to get a pointer to the tooltip context.
virtual BOOL | SetIcon (CSize size, HICON hIcon, HICON hIconHot=NULL, BOOL bRedraw=TRUE)
This member function will set the normal and hot state icons for the push button.
virtual BOOL | SetIcon (CSize size, UINT nID, UINT nHotID=0, BOOL bRedraw=TRUE)
This member function will set the normal and hot state icons for the push button.
virtual BOOL | SetIcon (CSize size, LPCTSTR lpszID, LPCTSTR lpszHotID=NULL, BOOL bRedraw=TRUE)
This member function will set the normal and hot state icons for the push button.
BOOL | SetIcon (CSize size, CXTPImageManagerIcon *pIcon, BOOL bRedraw=TRUE)
This member function will set the normal and hot state icons for the push button.
virtual BOOL | SetIcon (CSize size, const CXTPImageManagerIconHandle &hIconHandle, const CXTPImageManagerIconHandle &hIconHotHandle, BOOL bRedraw=TRUE)
This member function will set the normal and hot state icons for the push button.
virtual BOOL | SetBitmap (CSize size, UINT nID, BOOL bRedraw=TRUE)
This member function will set the bitmap associated with the button.
virtual CString | GetButtonText ()
Call this member function to return the button's text minus the '&'.
CSize | GetGlyphSize (BOOL bCheckBox)
Retrieves the size of the check box glyph.
BOOL | IsPushButton () const
Determines if the button is a push button or a drop down button.
void | EnableMarkup (BOOL bEnableMarkup=TRUE)
Allows the use of a XAML snippet to be used for the text of panes in the control.
virtual COLORREF | GetButtonTextColor ()
Gets the button's text color.
virtual COLORREF | GetButtonBackColor ()
Gets the button's back color.
virtual void | InternalTextChanged ()
This member function is called when the text has changed.
CXTPMarkupContext * | GetMarkupContext () const
Retrieves a pointer to the markup context.
CXTPMarkupUIElement * GetMarkupUIElement ()
Call this method to get the markup element that renders the caption of the control.

Protected Member Functions

virtual void | Exclude (CDC *pDC, CRect &rcClient)
Called during paint operations to exclude the control windows that are grouped by this control.
- Protected Member Functions inherited from CXTPButton
virtual void | OnDropDown ()
Occurs when the drop down button is dropped down.
virtual void | OnDraw (CDC *pDC)
This member function performs all of the drawing logic of the calendar control window.
void | DoDropDown ()
Manually drops down a drop down button.
virtual void | RefreshMetrics ()
Call this member function to refresh theme colors and redraw the control.

Additional Inherited Members

- Public Attributes inherited from CXTPButton
BOOL | m_bPushed
TRUE if button was pressed.
BOOL | m_bHot
TRUE if mouse under button.
CXTPButtonTheme * | m_pTheme
Pointer to the current theme object.
BOOL | m_bChecked
TRUE if checked.
BOOL | m_bFlatStyle
TRUE to see the flat style.
BOOL | m_bUseVisualStyle
TRUE to use visual styles.
long | m_nImageAlignment
Image Alignment.
long | m_nBorderGap
Gap between the button edge and the image.
long | m_nPushButtonStyle
The style of the button.
BOOL | m_bEnableMarkup
TRUE to enable markup.
long | m_nImageGap
Gap between the button text and the image.
long | m_nTextImageRelation
Image and text orientation.
CXTPImageManagerIcon * | m_pIcon
Multiple state icon manager converts icon to different states.
CSize | m_szVectorIcon
Size of displayed image if vector icon is used.
long | m_nBorderStyle
Border style used.
BOOL | m_bShowFocus
TRUE to show the focus rectangle.
HWND | m_hWndBuddy
Handle to the buddy control.
CXTPToolTipContext * | m_pToolTipContext
TooltipContext.
CString | m_strTooltip
Tooltip of the item.
- Protected Attributes inherited from CXTPButton
CXTPMarkupContext * | m_pMarkupContext
Markup context.
CXTPMarkupUIElement * | m_pUIElement
Markup element pointer.
BOOL | m_bImageDPIScaling
TRUE if DPI scaling of images enabled.

Detailed Description

CXTPResizeGroupBox is a CButton derived class that can be used to display a flicker free group box while resizing.

This class is intended to only be used as a group box and only used on a CXTPResize window. You can subclass or create this object the way you would any CButton. Note: Do not use the transparent flag with this control, and make sure you call SetFlag(xtpResizeNoTransparentGroup); to disable the resize manager from setting this for you.

Member Function Documentation

◆ Exclude()

virtual void Exclude | ( | CDC * | pDC,
 |  | CRect & | rcClient )
 protectedvirtual

Called during paint operations to exclude the control windows that are grouped by this control.

Parameters
pDC | Pointer to a device context.
rcClient | Client area of group box.
The documentation for this class was generated from the following file:
  • XTPResizeGroupBox.h


Toolkit Pro: CXTPResizeItem Class Reference

Public Member Functions | Public Attributes | List of all members
CXTPResizeItem Class Reference

CXTPResizeItem is a standalone helper class. More...

Public Member Functions

CXTPResizeItem (CWnd *pWnd, const CXTPResizeRect &rrcSizing, CRect &rcWindow, BOOL bAutoDelete)
Constructs a CXTPResizeItem object.
virtual | ~CXTPResizeItem ()
Destroys a CXTPResizeItem object, handles cleanup and deallocation.
virtual bool | MakeTransparent (CXTPResize *pXTPResize)
Called by CXTPResize to make group box controls window style transparent.

Public Attributes

BOOL | m_bIsGroupBox
TRUE if the window is a group box.
BOOL | m_bAutoDelete
TRUE if the window is to be deleted.
BOOL | m_bInitialSize
Initial size/move has been completed.
CWnd * | m_pWnd
A pointer to the window to be sized or moved.
CXTPResizeRect | m_rrcSizing
Sizing option.
CXTPResizeRect | m_rrcWindow
Last control size.
CXTPResizeRect | m_rrcInitWindow
Initial control size.

Detailed Description

CXTPResizeItem is a standalone helper class.

It is used by CXTPResize to maintain information about each item to be sized or moved.

Constructor & Destructor Documentation

◆ CXTPResizeItem()

CXTPResizeItem | ( | CWnd * | pWnd,
 |  | const CXTPResizeRect & | rrcSizing,
 |  | CRect & | rcWindow,
 |  | BOOL | bAutoDelete )

Constructs a CXTPResizeItem object.

Parameters
pWnd | Pointer to the window to be sized or moved.
rrcSizing | Reference to a CXTPResizeRect object.
rcWindow | Reference to a CRect object.
bAutoDelete | TRUE if the window is to be deleted.

Member Function Documentation

◆ MakeTransparent()

virtual bool MakeTransparent ( CXTPResize * pXTPResize )
virtual

Called by CXTPResize to make group box controls window style transparent.

Parameters
pXTPResize Pointer to the resize manager.
Returns
true if the WS_EX_TRANSPARENT style was set for the window, otherwise false.
The documentation for this class was generated from the following file:
  • XTPResize.h


Toolkit Pro: CXTPResizePoint Class Reference

Public Member Functions | List of all members
CXTPResizePoint Class Reference

CXTPResizePoint is an XTP_RESIZEPOINT structure derived class. More...

Inheritance diagram for CXTPResizePoint:
[legend]

Public Member Functions

CXTPResizePoint ()
Constructs a CXTPResizePoint object.
CXTPResizePoint (XTP_RESIZE cx, XTP_RESIZE cy)
Constructs a CXTPResizePoint object.

Additional Inherited Members

- Public Attributes inherited from XTP_RESIZEPOINT
XTP_RESIZE | x
Specifies the x-coordinate of a point.
XTP_RESIZE | y
Specifies the y-coordinate of a point.

Detailed Description

CXTPResizePoint is an XTP_RESIZEPOINT structure derived class.

The CXTPResizePoint class is similar to the XTP_RESIZEPOINT structure. It also includes member functions to manipulate CXTPResizePoint and XTP_RESIZEPOINT structures. A CXTPResizePoint object can be used wherever an XTP_RESIZEPOINT structure is used.

Constructor & Destructor Documentation

◆ CXTPResizePoint()

CXTPResizePoint | ( | XTP_RESIZE | cx,
 |  | XTP_RESIZE | cy )

Constructs a CXTPResizePoint object.

Parameters
cx | Specifies the x-coordinate of a point.
cy | Specifies the y-coordinate of a point.
The documentation for this class was generated from the following file:
  • XTPResizePoint.h


Toolkit Pro: CXTPResizePropertyPage Class Reference

Public Member Functions | Public Attributes | List of all members
CXTPResizePropertyPage Class Reference

CXTPResizePropertyPage is a multiple inheritance class derived from CPropertyPage and CXTPResize. More...

Inheritance diagram for CXTPResizePropertyPage:
[legend]

Public Member Functions

CXTPResizePropertyPage (const UINT nTemplate=0, const UINT nCaption=0, const UINT nFlags=0)
Constructs a CXTPResizePropertyPage object.
- Public Member Functions inherited from CXTPResize
CXTPResize (CWnd *pWnd, const UINT nFlags=0)
Constructs a CXTPResize object.
virtual | ~CXTPResize ()
Destroys a CXTPResize object, handles cleanup and deallocation.
void | SetResize (UINT nID, XTP_RESIZE left, XTP_RESIZE top, XTP_RESIZE right, XTP_RESIZE bottom)
The SetResize function specifies how much each side of a control will move when the dialog is resized.
void | SetResize (UINT nID, const XTP_RESIZERECT &rrcSizing)
The SetResize function specifies how much each side of a control will move when the dialog is resized.
void | SetResize (UINT nID, HWND hWnd, const XTP_RESIZERECT &rrcSizing)
The SetResize function specifies how much each side of a control will move when the dialog is resized.
void | SetResize (UINT nID, HWND hWnd, const XTP_RESIZEPOINT &rpTopLeft, const XTP_RESIZEPOINT &rpBottomRight)
The SetResize function specifies how much each side of a control will move when the dialog is resized.
void | SetResize (UINT nID, const XTP_RESIZEPOINT &rpTopLeft, const XTP_RESIZEPOINT &rpBottomRight)
The SetResize function specifies how much each side of a control will move when the dialog is resized.
void | SetMinSize (CSize &sz)
This member function sets the minimum size explicitly.
void | SetMaxSize (CSize &sz)
This member function sets the maximum size.
BOOL | SavePlacement (LPCTSTR pszSection)
This member function saves the window placement to the registry.
BOOL | LoadPlacement (LPCTSTR pszSection)
This member function loads saved window placement information from the registry.
BOOL | AutoLoadPlacement (LPCTSTR pszSection)
This member function loads saved window placement information from the registry.

Public Attributes

DWORD m_nDialogID
ID of the template used for this page.

Additional Inherited Members

- Protected Types inherited from CXTPResize
typedef CArray< CXTPResizeItem *, CXTPResizeItem *& > | CResizeItemArray
Used by CXTPResize to maintain a list of children that are sizable.
- Protected Member Functions inherited from CXTPResize
void | SetResize (CWnd *pWnd, const CXTPResizeRect &rrcSizing, CRect rcWindow)
The SetResize function specifies how much each side of a control will move when the dialog is resized.
BOOL | RemoveResize (UINT nID)
This member function is called to remove the specified dialog item from the list of items to be resized.
void | RemoveAllControls ()
This member function is called to purge the list that contains the dialog items to be sized.
virtual void | Init ()
This member function is called from OnInitDialog or OnInitialUpdate to initialize the resize manager.
virtual void | Size ()
This member function is called from OnSize to move and resize the dialog items that are managed.
void | Reset ()
This member function is called when a property sheet in wizard mode has changed pages to alert the resize manager that the property sheet (common control) has moved the page back to its original size/position on the sheet.
void | Offset (CPoint ptOffset)
Called to offset dialog items by the amount specified by ptOffset.
void | UpdateControlRect (CWnd *pWnd)
Call this method to reset m_rrcWindow for an item.
void | GetMinMaxInfo (MINMAXINFO *pMMI)
This member function is called from OnGetMinMaxInfo to get the maximized position or dimensions or the minimum or maximum tracking size.
virtual void | AdjustResizeRect (CSize &rcWindow)
This method is called in the Size method to adjust a window rectangle to fit real client size.
BOOL | HasFlag (XTPResize eFlag)
This member function is called to determine if the specified flag has been set for the resize manager.
void | SetFlag (XTPResize eFlag)
This member function is called to set a specific flag for the resize manager.
virtual BOOL | Defer (HDWP &hdwp, CXTPResizeItem *pItem, int dx, int dy)
Called by CXTPResize to resize a child window.
- Protected Attributes inherited from CXTPResize
UINT | m_nFlagsXX
Flags passed from the constructor.
CWnd * | m_pWnd
The associative relation to the window to be resized.
CSize | m_szWindow
Last dialog size.
CSize | m_szInitWindow
Initial dialog size.
CSize | m_szMin
Smallest size allowed.
CSize | m_szMax
Largest size allowed.
CString | m_strSection
Section in registry where window placement information is saved.
CXTPSizeIcon | m_scSizeIcon
Size icon window.
CResizeItemArray | m_arrItems
Array of controls.

Detailed Description

CXTPResizePropertyPage is a multiple inheritance class derived from CPropertyPage and CXTPResize.

CXTPResizePropertyPage is used to create a resizable CPropertyPage type object that allows its dialog items to be resized or moved dynamically.

Constructor & Destructor Documentation

◆ CXTPResizePropertyPage()

CXTPResizePropertyPage | ( | const UINT | nTemplate = 0,
 |  | const UINT | nCaption = 0,
 |  | const UINT | nFlags = 0 )

Constructs a CXTPResizePropertyPage object.

Parameters
nTemplate | ID of the template used for this page.
nCaption | ID of the name to be placed in the tab for this page. If 0, then the name will be taken from the dialog template for this page.
nFlags | Flags that are to be passed to CXTPResize that specify the attributes of the resizing property page. They can be one or more of the values in the Remarks section.

Styles to be added or removed can be combined by using the bitwise OR (|) operator. It can be one or more of the following:

xtpResizeNoSizeIcon: Do not add size icon. xtpResizeNoHorizontal: No horizontal resizing. xtpResizeNoVertical: No vertical resizing. xtpResizeNoMinsize: Do not require a minimum size. xtpResizeNoClipChildren: Do not set clip children style. xtpResizeNoTransparentGroup: Do not set transparent style for group boxes.

The documentation for this class was generated from the following file:
  • XTPResizePropertyPage.h


Toolkit Pro: CXTPResizePropertySheet Class Reference

Public Member Functions | Public Attributes | Protected Member Functions | List of all members
CXTPResizePropertySheet Class Reference

CXTPResizePropertySheet is a multiple inheritance class derived from CPropertySheet and CXTPResize. More...

Inheritance diagram for CXTPResizePropertySheet:
[legend]

Public Member Functions

CXTPResizePropertySheet ()
Constructs a CXTPResizePropertySheet object.
CXTPResizePropertySheet (const UINT nCaption, CWnd *pParent=0, const UINT nSelectPage=0, const UINT nFlags=0)
Constructs a CXTPResizePropertySheet object.
CXTPResizePropertySheet (LPCTSTR pszCaption, CWnd *pParent=0, const UINT nSelectPage=0, const UINT nFlags=0)
Constructs a CXTPResizePropertySheet object.
- Public Member Functions inherited from CXTPResize
CXTPResize (CWnd *pWnd, const UINT nFlags=0)
Constructs a CXTPResize object.
virtual | ~CXTPResize ()
Destroys a CXTPResize object, handles cleanup and deallocation.
void | SetResize (UINT nID, XTP_RESIZE left, XTP_RESIZE top, XTP_RESIZE right, XTP_RESIZE bottom)
The SetResize function specifies how much each side of a control will move when the dialog is resized.
void | SetResize (UINT nID, const XTP_RESIZERECT &rrcSizing)
The SetResize function specifies how much each side of a control will move when the dialog is resized.
void | SetResize (UINT nID, HWND hWnd, const XTP_RESIZERECT &rrcSizing)
The SetResize function specifies how much each side of a control will move when the dialog is resized.
void | SetResize (UINT nID, HWND hWnd, const XTP_RESIZEPOINT &rpTopLeft, const XTP_RESIZEPOINT &rpBottomRight)
The SetResize function specifies how much each side of a control will move when the dialog is resized.
void | SetResize (UINT nID, const XTP_RESIZEPOINT &rpTopLeft, const XTP_RESIZEPOINT &rpBottomRight)
The SetResize function specifies how much each side of a control will move when the dialog is resized.
void | SetMinSize (CSize &sz)
This member function sets the minimum size explicitly.
void | SetMaxSize (CSize &sz)
This member function sets the maximum size.
BOOL | SavePlacement (LPCTSTR pszSection)
This member function saves the window placement to the registry.
BOOL | LoadPlacement (LPCTSTR pszSection)
This member function loads saved window placement information from the registry.
BOOL | AutoLoadPlacement (LPCTSTR pszSection)
This member function loads saved window placement information from the registry.

Public Attributes

CXTPNoFlickerWnd< CTabCtrl > m_tabCtrl
Tab control.

Protected Member Functions

BOOL | IsWizard ()
This member function determines if the property sheet is in wizard mode.
- Protected Member Functions inherited from CXTPResize
void | SetResize (CWnd *pWnd, const CXTPResizeRect &rrcSizing, CRect rcWindow)
The SetResize function specifies how much each side of a control will move when the dialog is resized.
BOOL | RemoveResize (UINT nID)
This member function is called to remove the specified dialog item from the list of items to be resized.
void | RemoveAllControls ()
This member function is called to purge the list that contains the dialog items to be sized.
virtual void | Init ()
This member function is called from OnInitDialog or OnInitialUpdate to initialize the resize manager.
virtual void | Size ()
This member function is called from OnSize to move and resize the dialog items that are managed.
void | Reset ()
This member function is called when a property sheet in wizard mode has changed pages to alert the resize manager that the property sheet (common control) has moved the page back to its original size/position on the sheet.
void | Offset (CPoint ptOffset)
Called to offset dialog items by the amount specified by ptOffset.
void | UpdateControlRect (CWnd *pWnd)
Call this method to reset m_rrcWindow for an item.
void | GetMinMaxInfo (MINMAXINFO *pMMI)
This member function is called from OnGetMinMaxInfo to get the maximized position or dimensions or the minimum or maximum tracking size.
virtual void | AdjustResizeRect (CSize &rcWindow)
This method is called in the Size method to adjust a window rectangle to fit real client size.
BOOL | HasFlag (XTPResize eFlag)
This member function is called to determine if the specified flag has been set for the resize manager.
void | SetFlag (XTPResize eFlag)
This member function is called to set a specific flag for the resize manager.
virtual BOOL | Defer (HDWP &hdwp, CXTPResizeItem *pItem, int dx, int dy)
Called by CXTPResize to resize a child window.

Additional Inherited Members

- Protected Types inherited from CXTPResize
typedef CArray< CXTPResizeItem *, CXTPResizeItem *& > | CResizeItemArray
Used by CXTPResize to maintain a list of children that are sizable.
- Protected Attributes inherited from CXTPResize
UINT | m_nFlagsXX
Flags passed from the constructor.
CWnd * | m_pWnd
The associative relation to the window to be resized.
CSize | m_szWindow
Last dialog size.
CSize | m_szInitWindow
Initial dialog size.
CSize | m_szMin
Smallest size allowed.
CSize | m_szMax
Largest size allowed.
CString | m_strSection
Section in registry where window placement information is saved.
CXTPSizeIcon | m_scSizeIcon
Size icon window.
CResizeItemArray | m_arrItems
Array of controls.

Detailed Description

CXTPResizePropertySheet is a multiple inheritance class derived from CPropertySheet and CXTPResize.

CXTPResizePropertySheet is used to create a resizable CPropertySheet type object that allows its dialog items to be resized or moved dynamically.

Constructor & Destructor Documentation

◆ CXTPResizePropertySheet() [1/3]

CXTPResizePropertySheet ( )

Constructs a CXTPResizePropertySheet object.

Styles to be added or removed can be combined by using the bitwise OR (|) operator. It can be one or more of the following:

xtpResizeNoSizeIcon: Do not add size icon. xtpResizeNoHorizontal: No horizontal resizing. xtpResizeNoVertical: No vertical resizing. xtpResizeNoMinsize: Do not require a minimum size. xtpResizeNoClipChildren: Do not set clip children style. xtpResizeNoTransparentGroup: Do not set transparent style for group boxes.

◆ CXTPResizePropertySheet() [2/3]

CXTPResizePropertySheet | ( | const UINT | nCaption,
 |  | CWnd * | pParent = 0,
 |  | const UINT | nSelectPage = 0,
 |  | const UINT | nFlags = 0 )

Constructs a CXTPResizePropertySheet object.

Parameters
nCaption | ID of the caption to be used for the property sheet.
pParent | Pointer to the parent window of the property sheet. If NULL, then the parent window will be the main window of the application.
nSelectPage | The index of the page that will initially be on top. Default is the first page added to the sheet.
nFlags | Flags that are to be passed to CXTPResize that specify the attributes of the resizing property page. They can be one or more of the values in the Remarks section.

Styles to be added or removed can be combined by using the bitwise OR (|) operator. It can be one or more of the following:

xtpResizeNoSizeIcon: Do not add size icon. xtpResizeNoHorizontal: No horizontal resizing. xtpResizeNoVertical: No vertical resizing. xtpResizeNoMinsize: Do not require a minimum size. xtpResizeNoClipChildren: Do not set clip children style. xtpResizeNoTransparentGroup: Do not set transparent style for group boxes.

◆ CXTPResizePropertySheet() [3/3]

CXTPResizePropertySheet | ( | LPCTSTR | pszCaption,
 |  | CWnd * | pParent = 0,
 |  | const UINT | nSelectPage = 0,
 |  | const UINT | nFlags = 0 )

Constructs a CXTPResizePropertySheet object.

Parameters
pszCaption | Pointer to a string containing the caption to be used for the property sheet. It cannot be NULL.
pParent | Pointer to the parent window of the property sheet. If NULL, then the parent window will be the main window of the application.
nSelectPage | The index of the page that will initially be on top. Default is the first page added to the sheet.
nFlags | Flags that are to be passed to CXTPResize that specify the attributes of the resizing property page. They can be one or more of the values in the Remarks section.

Styles to be added or removed can be combined by using the bitwise OR (|) operator. It can be one or more of the following:

xtpResizeNoSizeIcon: Do not add size icon. xtpResizeNoHorizontal: No horizontal resizing. xtpResizeNoVertical: No vertical resizing. xtpResizeNoMinsize: Do not require a minimum size. xtpResizeNoClipChildren: Do not set clip children style. xtpResizeNoTransparentGroup: Do not set transparent style for group boxes.

Member Function Documentation

◆ IsWizard()

BOOL IsWizard ( )
protected

This member function determines if the property sheet is in wizard mode.

Returns
TRUE if the property sheet is in wizard mode, otherwise FALSE.
The documentation for this class was generated from the following file:
  • XTPResizePropertySheet.h


Toolkit Pro: CXTPResizeRect Class Reference

Public Member Functions | List of all members
CXTPResizeRect Class Reference

CXTPResizeRect is an XTP_RESIZERECT structure derived class. More...

Inheritance diagram for CXTPResizeRect:
[legend]

Public Member Functions

CXTPResizeRect ()
Constructs a CXTPResizeRect object.
CXTPResizeRect (const RECT &rc)
Constructs a CXTPResizeRect object.
CXTPResizeRect (const XTP_RESIZERECT &rrc)
Constructs a CXTPResizeRect object.
CXTPResizeRect (XTP_RESIZE l, XTP_RESIZE t, XTP_RESIZE r, XTP_RESIZE b)
Constructs a CXTPResizeRect object.
CXTPResizeRect & | operator= (const RECT &rc)
This operator copies the dimensions of a rectangle to CXTPResizeRect.
CXTPResizeRect & | operator= (const XTP_RESIZERECT &rrc)
This operator copies the dimensions of a rectangle to CXTPResizeRect.
CXTPResizeRect & | operator+= (const XTP_RESIZERECT &rrc)
This operator adds the specified offsets to CXTPResizeRect or inflates CXTPResizeRect.
CXTPResizeRect | operator+ (const XTP_RESIZERECT &rrc)
This operator adds the given offsets to CRect or inflates CRect.
CXTPResizeRect | operator& (const XTP_RESIZERECT &rrc)
This operator creates the intersection of CXTPResizeRect and a rectangle, and returns the resulting CXTPResizeRect.
bool | operator== (const XTP_RESIZERECT &rrc)
This operator determines whether CXTPResizeRect is equal to a rectangle.
bool | operator!= (const XTP_RESIZERECT &rrc)
This operator determines whether CXTPResizeRect is not equal to a rectangle.
operator CRect ()
This operator converts a CXTPResizeRect to a CRect.
bool | IsNormalized ()
This member function determines if CXTPResizeRect is normalized.
XTP_RESIZE Width ()
This member function calculates the width of a CXTPResizeRect by subtracting the left value from the right value.
XTP_RESIZE Height ()
This member function calculates the height of a CXTPResizeRect by subtracting the top value from the bottom value.

Additional Inherited Members

- Public Attributes inherited from XTP_RESIZERECT
XTP_RESIZE | left
Specifies the x-coordinate of the upper-left corner of a rectangle.
XTP_RESIZE | top
Specifies the y-coordinate of the upper-left corner of a rectangle.
XTP_RESIZE | right
Specifies the x-coordinate of the lower-right corner of a rectangle.
XTP_RESIZE | bottom
Specifies the y-coordinate of the lower-right corner of a rectangle.

Detailed Description

CXTPResizeRect is an XTP_RESIZERECT structure derived class.

The CXTPResizeRect class is similar to an XTP_RESIZERECT structure. CXTPResizeRect also includes member functions to manipulate CXTPResizeRect objects and XTP_RESIZERECT structures.

See also
XTP_RESIZERECT, CXTPResizePoint, XTP_RESIZEPOINT, XTP_RESIZE

Constructor & Destructor Documentation

◆ CXTPResizeRect() [1/3]

CXTPResizeRect ( const RECT & rc )

Constructs a CXTPResizeRect object.

Parameters
rc Refers to the RECT structure with the coordinates for CXTPResizeRect.

◆ CXTPResizeRect() [2/3]

CXTPResizeRect ( const XTP_RESIZERECT & rrc )

Constructs a CXTPResizeRect object.

Parameters
rrc Refers to the XTP_RESIZERECT structure with the coordinates for CXTPResizeRect.

◆ CXTPResizeRect() [3/3]

CXTPResizeRect | ( | XTP_RESIZE | l,
 |  | XTP_RESIZE | t,
 |  | XTP_RESIZE | r,
 |  | XTP_RESIZE | b )

Constructs a CXTPResizeRect object.

Parameters
l | Specifies the left position of CXTPResizeRect.
t | Specifies the top of CXTPResizeRect.
r | Specifies the right position of CXTPResizeRect.
b | Specifies the bottom of CXTPResizeRect.

Member Function Documentation

◆ Height()

XTP_RESIZE Height ( )

This member function calculates the height of a CXTPResizeRect by subtracting the top value from the bottom value.

The resulting value can be negative.

Returns
The height of a CXTPResizeRect.

◆ IsNormalized()

bool IsNormalized ( )

This member function determines if CXTPResizeRect is normalized.

Returns
true if normalized, otherwise false.

◆ operator CRect()

operator CRect ( )

This operator converts a CXTPResizeRect to a CRect.

When you use this function, you do not need the address-of (&) operator. This operator will be automatically used when you pass a CXTPResizeRect object to a function that expects a CRect.

◆ operator!=()

bool operator!= ( const XTP_RESIZERECT & rrc )

This operator determines whether CXTPResizeRect is not equal to a rectangle.

Parameters
rrc Refers to a source rectangle. It can be an XTP_RESIZERECT or a CXTPResizeRect.
Returns
true if not equal, otherwise false.

◆ operator&()

CXTPResizeRect operator& ( const XTP_RESIZERECT & rrc )

This operator creates the intersection of CXTPResizeRect and a rectangle, and returns the resulting CXTPResizeRect.

Parameters
rrc Contains an XTP_RESIZERECT or a CXTPResizeRect.
Returns
A CXTPResizeRect that is the intersection of CXTPResizeRect and 'rrc'. The intersection is the largest rectangle that is contained in both rectangles.

◆ operator+()

CXTPResizeRect operator+ ( const XTP_RESIZERECT & rrc )

This operator adds the given offsets to CRect or inflates CRect.

Parameters
rrc Pointer to an XTP_RESIZERECT structure or a CXTPResizeRect object that contains the number of units to inflate each side of the return value.
Returns
The resulting CXTPResizeRect object.

◆ operator+=()

CXTPResizeRect & operator+= ( const XTP_RESIZERECT & rrc )

This operator adds the specified offsets to CXTPResizeRect or inflates CXTPResizeRect.

Parameters
rrc Pointer to an XTP_RESIZERECT structure or a CXTPResizeRect object that contains the number of units to inflate each side of CXTPResizeRect.
Returns
A reference to a CXTPResizeRect object.

◆ operator=() [1/2]

CXTPResizeRect & operator= ( const RECT & rc )

This operator copies the dimensions of a rectangle to CXTPResizeRect.

Parameters
rc Refers to a source rectangle. It can be a RECT or CRect.
Returns
A reference to a CXTPResizeRect object.

◆ operator=() [2/2]

CXTPResizeRect & operator= ( const XTP_RESIZERECT & rrc )

This operator copies the dimensions of a rectangle to CXTPResizeRect.

Parameters
rrc Refers to a source rectangle. It can be a XTP_RESIZERECT or CXTPResizeRect.
Returns
A reference to a CXTPResizeRect object.

◆ operator==()

bool operator== ( const XTP_RESIZERECT & rrc )

This operator determines whether CXTPResizeRect is equal to a rectangle.

Parameters
rrc Refers to a source rectangle. It can be an XTP_RESIZERECT or a CXTPResizeRect.
Returns
true if equal, otherwise false.

◆ Width()

XTP_RESIZE Width ( )

This member function calculates the width of a CXTPResizeRect by subtracting the left value from the right value.

The resulting value can be negative.

Returns
The width of a CXTPResizeRect.
The documentation for this class was generated from the following file:
  • XTPResizeRect.h


Toolkit Pro: CXTPResourceImage Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPResourceImage Class Reference

Represent a resource image and provides basic images functions. More...

Inheritance diagram for CXTPResourceImage:
[legend]

Public Member Functions

CXTPResourceImage (CXTPResourceImages *pImages)
Constructs resource image which is a part of image collection.
virtual | ~CXTPResourceImage ()
Handles resource image deallocation.
BOOL | LoadFile (HMODULE hModule, LPCTSTR lpszBitmapFileName)
Loads image from the resource specified.
void | SetBitmap (HBITMAP hBitmap, BOOL bAlpha=FALSE)
Loads image bits from the bitmap provided.
void | DrawImage (CDC *pDC, const CRect &rcDest, CRect rcSrc)
Draws an image to the device context provided.
void | DrawImage (CDC *pDC, const CRect &rcDest, CRect rcSrc, CRect rcSizingMargins)
Draws an image to the device context provided.
void | DrawImage (CDC *pDC, const CRect &rcDest, CRect rcSrc, const CRect &rcSizingMargins, COLORREF clrTransparent)
Draws an image to the device context provided.
void | DrawImage (CDC *pDC, const CRect &rcDest, CRect rcSrc, const CRect &rcSizingMargins, COLORREF clrTransparent, DWORD dwFlags)
Draws an image to the device context provided.
int | GetHeight () const
Determine image dimensions.
int | GetWidth () const
Determine image dimensions.
CSize | GetExtent () const
Determine image dimensions.
BOOL | IsAlphaImage () const
Determines whether the image is a 32-bit image with alpha channel.
void | PreserveOrientation ()
Enables preserved image orientation for RTL contexts and inverted drawing.
CRect | GetSource (int nState=0, int nCount=1) const
Obtains a source rectable for an image in image list.
BOOL | GetBitmapPixel (CPoint pt, COLORREF &clrPixel)
Obtains pixel color value at the point specified.
void | Premultiply ()
Pre-multiplies alpha image bits.
void | DrawImageFlipped (BOOL bFlip)
Enables/disables image flipping.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

BOOL | DrawImagePart (CDC *pDCDest, CRect rcDest, CDC *pDCSrc, CRect rcSrc) const
Draws image part.
BOOL | InvertBitmap ()
Inverts image bits.
BOOL | ConvertToBits (HBITMAP hBitmap)
Obtains bitmap bits and uses them as image bits for the current image.

Protected Attributes

LPVOID | m_pBits
Image bits.
BOOL | m_bAlpha
TRUE for 32-bit alpha images.
BOOL | m_bMultiply
TRUE if an alpha image bits were multiplied.
BOOL | m_bImageOrientaionPreserved
TRUE if image orientation is to be preserved for RTL or flipped drawing.
BOOL | m_bInvert
TRUE indicates the images bits are currently inverted.
CSize | m_szExtent
Image size.
BOOL | m_bFlipped
TRUE m_bFlipped the image bits are currently flipped.
CXTPResourceImages * | m_pImages
Parent image list pointer.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

Represent a resource image and provides basic images functions.

See also
CXTPResourceImages

Constructor & Destructor Documentation

◆ CXTPResourceImage()

CXTPResourceImage ( CXTPResourceImages * pImages )

Constructs resource image which is a part of image collection.

Parameters
pImages A valid pointer to image collection the image belongs to.

Member Function Documentation

◆ ConvertToBits()

BOOL ConvertToBits ( HBITMAP hBitmap )
protected

Obtains bitmap bits and uses them as image bits for the current image.

Parameters
hBitmap Source bitmap handle.
Returns
TRUE if successfully converted, FALSE otherwise.

◆ DrawImage() [1/4]

void DrawImage | ( | CDC * | pDC,
 |  | const CRect & | rcDest,
 |  | CRect | rcSrc )

Draws an image to the device context provided.

Parameters
pDC | A valid pointer to the target device context.
rcDest | Destination rectangle.
rcSrc | Source rectangle.

◆ DrawImage() [2/4]

void DrawImage | ( | CDC * | pDC,
 |  | const CRect & | rcDest,
 |  | CRect | rcSrc,
 |  | const CRect & | rcSizingMargins,
 |  | COLORREF | clrTransparent )

Draws an image to the device context provided.

Parameters
pDC | A valid pointer to the target device context.
rcDest | Destination rectangle.
rcSrc | Source rectangle.
rcSizingMargins | Sizing margins.
clrTransparent | A color key to be treated as transparent color.

◆ DrawImage() [3/4]

void DrawImage | ( | CDC * | pDC,
 |  | const CRect & | rcDest,
 |  | CRect | rcSrc,
 |  | const CRect & | rcSizingMargins,
 |  | COLORREF | clrTransparent,
 |  | DWORD | dwFlags )

Draws an image to the device context provided.

Parameters
pDC | A valid pointer to the target device context.
rcDest | Destination rectangle.
rcSrc | Source rectangle.
rcSizingMargins | Sizing margins.
clrTransparent | A color key to be treated as transparent color.
dwFlags | If contains XTP_DI_COMPOSITE bit, the image will be drawn as composited.

◆ DrawImage() [4/4]

void DrawImage | ( | CDC * | pDC,
 |  | const CRect & | rcDest,
 |  | CRect | rcSrc,
 |  | CRect | rcSizingMargins )

Draws an image to the device context provided.

Parameters
pDC | A valid pointer to the target device context.
rcDest | Destination rectangle.
rcSrc | Source rectangle.
rcSizingMargins | Sizing margins.

◆ DrawImageFlipped()

void DrawImageFlipped ( BOOL bFlip )

Enables/disables image flipping.

Parameters
bFlip TRUE inverts the image, FALSE restores original image.

◆ DrawImagePart()

BOOL DrawImagePart | ( | CDC * | pDCDest,
 |  | CRect | rcDest,
 |  | CDC * | pDCSrc,
 |  | CRect | rcSrc ) const
 protected

Draws image part.

Parameters
pDCDest | A valid pointer to the target device context.
rcDest | Target rectangle.
pDCSrc | A valid pointer to the source device context.
rcSrc | Source rectangle.
Returns
TRUE if drawing is successful, FALSE otherwise.

◆ GetBitmapPixel()

BOOL GetBitmapPixel | ( | CPoint | pt,
 |  | COLORREF & | clrPixel )

Obtains pixel color value at the point specified.

Parameters
pt | Pixel coordinates.
clrPixel | The output pixel color value.
Returns
TRUE if the color is successfully determined, FALSE otherwise.

◆ GetExtent()

CSize GetExtent ( ) const

Determine image dimensions.

Returns
The width and height size of the image.

◆ GetHeight()

int GetHeight ( ) const

Determine image dimensions.

Returns
The height of the image.

◆ GetSource()

CRect GetSource | ( | int | nState = 0,
 |  | int | nCount = 1 ) const

Obtains a source rectable for an image in image list.

Parameters
nState | Stage/image index in the image list.
nCount | Total number of images in the image list.
Returns
The computed image rectangle.

◆ GetWidth()

int GetWidth ( ) const

Determine image dimensions.

Returns
The width of the image.

◆ InvertBitmap()

BOOL InvertBitmap ( )
protected

Inverts image bits.

Returns
TRUE if bits inversion is successful, FALSE otherwise.

◆ IsAlphaImage()

BOOL IsAlphaImage ( ) const

Determines whether the image is a 32-bit image with alpha channel.

Returns
TRUE if the image is a 32-bit image with alpha channel.

◆ LoadFile()

BOOL LoadFile | ( | HMODULE | hModule,
 |  | LPCTSTR | lpszBitmapFileName )

Loads image from the resource specified.

Parameters
hModule | Resource module handle.
lpszBitmapFileName | PNG or bitmap resource identifier to load from "PNG" or RT_BITMAP resource directories respectively.
Returns
TRUE if an image is load, FALSE otherwise.
See also
SetBitmap

◆ PreserveOrientation()

void PreserveOrientation ( )

Enables preserved image orientation for RTL contexts and inverted drawing.

See also
DrawImageFlipped, CXTPDrawHelpers::IsContextRTL

◆ SetBitmap()

void SetBitmap | ( | HBITMAP | hBitmap,
 |  | BOOL | bAlpha = FALSE )

Loads image bits from the bitmap provided.

The bitmap handle is destroyed upon successful completion.

Parameters
hBitmap | Bitmap handle to load image bits from.
bAlpha | TRUE causes the bitmap to be processed as a 32-bit image with alpha channel.
See also
LoadFile
The documentation for this class was generated from the following file:
  • XTPResourceImage.h


Toolkit Pro: CXTPResourceImages Class Reference

Public Member Functions | Public Attributes | Protected Member Functions | Protected Attributes | List of all members
CXTPResourceImages Class Reference

Implements resource image collection and its operations. More...

Inheritance diagram for CXTPResourceImages:
[legend]

Public Member Functions

CXTPResourceImages ()
Construct an empty resource image collection.
virtual | ~CXTPResourceImages ()
Handles resource image list deallocation.
void | Reset ()
Removes all loaded images and clears all loaded properties.
void | RemoveAll ()
Removes all loaded images only.
CXTPResourceImage * | LoadFile (LPCTSTR lpszImageFile)
Loads image from resources and adds it to the collection.
CXTPResourceImage * | LoadImage (LPCTSTR lpszImageFile)
Loads image from resource.
HMODULE | GetHandle () const
Obtains resource handle value.
BOOL | SetHandle (LPCTSTR lpszDllFileName, LPCTSTR lpszIniFileName=NULL)
Sets image collection resource handle.
BOOL | SetHandle (HMODULE hResource, LPCTSTR lpszIniFileName=NULL, BOOL bFreeOnRelease=FALSE)
Sets image collection resource handle.
BOOL | SetHandle (HMODULE hResource, LPCTSTR lpszThemeFileName, LPCTSTR lpszAppFileName, BOOL bFreeOnRelease=FALSE)
Sets image collection resource handle.
void | SetIniData (LPCSTR lpIniData)
Loads INI file properties from the provided input.
BOOL | InitResourceHandle (LPCTSTR lpszTestImageFile, LPCTSTR lpResType=RT_BITMAP)
Searches for a module that contains the resource specified and uses it as a resource module.
COLORREF | GetImageColor (LPCTSTR lpszSectionName, LPCTSTR lpszKeyName, COLORREF clrDefault=(COLORREF) -1) const
Obtains color value from the specific key of the currently loaded INI file.
int | GetImageInt (LPCTSTR lpszSectionName, LPCTSTR lpszKeyName, int nDefault=-1) const
Obtains integer value from the specific key of the currently loaded INI file.
CRect | GetImageRect (LPCTSTR lpszSectionName, LPCTSTR lpszKeyName, CRect rcDefault=CRect(0, 0, 0, 0)) const
Obtains rectangle value from the specific key of the currently loaded INI file.
CSize | GetImageSize (LPCTSTR lpszSectionName, LPCTSTR lpszKeyName, CSize szDefault=CSize(0, 0)) const
Obtains size value from the specific key of the currently loaded INI file.
CString | GetImageString (LPCTSTR lpszSectionName, LPCTSTR lpszKeyName, LPCTSTR lpszDef=NULL) const
Obtains string value from the specific key of the currently loaded INI file.
CString | GetImageValue (LPCTSTR lpszSectionName, LPCTSTR lpszKeyName) const
Obtains string value from the specific key of any type of the currently loaded INI file.
BOOL | IsValid () const
Determines if image collection state is valid, i.e.
BOOL | LoadBitmap (CBitmap *pBitmap, LPCTSTR lpszResourceName)
Loads a bitmap from the currently assigned resource module.
CXTPNotifyConnection * GetConnection ()
Return connection object pointer that can be used for subscribing to collection events.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Public Attributes

CString | m_strDllFileName
Loaded DLL file name.
CString | m_strIniFileName
Loaded INI file name.

Protected Member Functions

CString | _ImageNameToResourceName (LPCTSTR strImageFile)
Converts file name to resource file name, Symbols '.
void | ClearProperties ()
Clears all loaded INI properties.
void | LoadProperties (LPSTR lpTextFile, LPSTR lpTextFileEnd, BOOL bAllowOverwrite)
Loads INI properties from the INI text range.

Protected Attributes

HMODULE | m_hResource
Associated resource module handle.
BOOL | m_bFreeOnRelease
If TRUE, the module determined by m_hResource will be unloaded upon release.
CRITICAL_SECTION | m_cs
Shared access critical section.
BOOL | m_bPremultiplyImages
If TRUE, the bits of alpha images are to be pre-multiplied.
CXTPBitmapDC * | m_pdc
An off-screen device context pointer used for internal image processing.
HBITMAP | m_hbmLayer
Bitmap layer handle.
LPDWORD | m_pLayerBits
Bitmap layer bits pointer.
CXTPNotifyConnection * | m_pConnection
Connection sink object pointer.
CMap< UINT, UINT, CString, CString > | m_mapPropeties
Loaded INI properties.
CMapStringToPtr | m_mapImages
Loaded image collection.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

Implements resource image collection and its operations.

See also
CXTPResourceImage

Member Function Documentation

◆ _ImageNameToResourceName()

CString _ImageNameToResourceName ( LPCTSTR strImageFile )
protected

Converts file name to resource file name, Symbols '.

' and '\' get replaced with '_'.

Parameters
strImageFile File name pointer to convert.
Returns
Converted resource file name value.

◆ GetConnection()

CXTPNotifyConnection * GetConnection ( )

Return connection object pointer that can be used for subscribing to collection events.

Returns
Return connection object pointer.

◆ GetHandle()

HMODULE GetHandle ( ) const

Obtains resource handle value.

Returns
Resource handle value.
See also
SetHandle

◆ GetImageColor()

COLORREF GetImageColor | ( | LPCTSTR | lpszSectionName,
 |  | LPCTSTR | lpszKeyName,
 |  | COLORREF | clrDefault = (COLORREF) -1 ) const

Obtains color value from the specific key of the currently loaded INI file.

Parameters
lpszSectionName | INI section name.
lpszKeyName | INI key name that contains color value.
clrDefault | Default color value to be used.
Returns
The obtained or default color value.
See also
GetImageInt, GetImageRect, GetImageSize, GetImageString, GetImageValue

◆ GetImageInt()

int GetImageInt | ( | LPCTSTR | lpszSectionName,
 |  | LPCTSTR | lpszKeyName,
 |  | int | nDefault = -1 ) const

Obtains integer value from the specific key of the currently loaded INI file.

Parameters
lpszSectionName | INI section name.
lpszKeyName | INI key name that contains integer value.
nDefault | Default integer value to be used.
Returns
The obtained or default integer value.
See also
GetImageColor, GetImageRect, GetImageSize, GetImageString, GetImageValue

◆ GetImageRect()

CRect GetImageRect | ( | LPCTSTR | lpszSectionName,
 |  | LPCTSTR | lpszKeyName,
 |  | CRect | rcDefault = CRect(0, 0, 0, 0) ) const

Obtains rectangle value from the specific key of the currently loaded INI file.

Parameters
lpszSectionName | INI section name.
lpszKeyName | INI key name that contains rectangle value.
rcDefault | Default rectangle value to be used.
Returns
The obtained or default rectangle value.
See also
GetImageColor, GetImageInt, GetImageSize, GetImageString, GetImageValue

◆ GetImageSize()

CSize GetImageSize | ( | LPCTSTR | lpszSectionName,
 |  | LPCTSTR | lpszKeyName,
 |  | CSize | szDefault = CSize(0, 0) ) const

Obtains size value from the specific key of the currently loaded INI file.

Parameters
lpszSectionName | INI section name.
lpszKeyName | INI key name that contains size value.
szDefault | Default size value to be used.
Returns
The obtained or default size value.
See also
GetImageColor, GetImageInt, GetImageRect, GetImageString, GetImageValue

◆ GetImageString()

CString GetImageString | ( | LPCTSTR | lpszSectionName,
 |  | LPCTSTR | lpszKeyName,
 |  | LPCTSTR | lpszDef = NULL ) const

Obtains string value from the specific key of the currently loaded INI file.

Parameters
lpszSectionName | INI section name.
lpszKeyName | INI key name that contains string value.
lpszDef | Default string value to be used.
Returns
The obtained or default string value.
See also
GetImageColor, GetImageInt, GetImageRect, GetImageSize, GetImageValue

◆ GetImageValue()

CString GetImageValue | ( | LPCTSTR | lpszSectionName,
 |  | LPCTSTR | lpszKeyName ) const

Obtains string value from the specific key of any type of the currently loaded INI file.

Parameters
lpszSectionName | INI section name.
lpszKeyName | INI key name that contains string value.
Returns
The obtained or default string value.
See also
GetImageColor, GetImageInt, GetImageRect, GetImageString, GetImageSize

◆ InitResourceHandle()

BOOL InitResourceHandle | ( | LPCTSTR | lpszTestImageFile,
 |  | LPCTSTR | lpResType = RT_BITMAP )

Searches for a module that contains the resource specified and uses it as a resource module.

Parameters
lpszTestImageFile | Test image resource identifier.
lpResType | Test image resource type.
Returns
TRUE if the resource specified is found and its module is used.
See also
SetIniData, SetHandle

◆ IsValid()

BOOL IsValid ( ) const

Determines if image collection state is valid, i.e.

a resource module is used and all properties loaded.

Returns
TRUE if collection is in a valid state.
See also
SetHandle

◆ LoadBitmap()

BOOL LoadBitmap | ( | CBitmap * | pBitmap,
 |  | LPCTSTR | lpszResourceName )

Loads a bitmap from the currently assigned resource module.

Parameters
pBitmap | A valid pointer to the bitmap object that will be loaded upon successful completion.
lpszResourceName | Bitmap resource identifier to load.
Returns
TRUE if loaded successfully, FALSE otherwise.

◆ LoadFile()

CXTPResourceImage * LoadFile ( LPCTSTR lpszImageFile )

Loads image from resources and adds it to the collection.

Parameters
lpszImageFile Image file name as used in resources. Symbols '.' and '\' get replaced with '_'.
Returns
A loaded image pointer or NULL if unble to load an image.
See also
LoadImage

◆ LoadImage()

CXTPResourceImage * LoadImage ( LPCTSTR lpszImageFile )

Loads image from resource.

Parameters
lpszImageFile Image file name as used in resources. Symbols '.' and '\' get replaced with '_'.
Returns
A loaded image pointer or NULL if unble to load an image.
See also
LoadFile

◆ LoadProperties()

void LoadProperties | ( | LPSTR | lpTextFile,
 |  | LPSTR | lpTextFileEnd,
 |  | BOOL | bAllowOverwrite )
 protected

Loads INI properties from the INI text range.

Parameters
lpTextFile | INI data start pointer.
lpTextFileEnd | INI data end pointer.
bAllowOverwrite | TRUE if it is allowed to overwrite existing properties.

◆ RemoveAll()

void RemoveAll ( )

Removes all loaded images only.

Loaded properties remain valid.

See also
Reset

◆ Reset()

void Reset ( )

Removes all loaded images and clears all loaded properties.

See also
RemoveAll

◆ SetHandle() [1/3]

BOOL SetHandle | ( | HMODULE | hResource,
 |  | LPCTSTR | lpszIniFileName = NULL,
 |  | BOOL | bFreeOnRelease = FALSE )

Sets image collection resource handle.

Parameters
hResource | Module handle to be used for resources.
lpszIniFileName | Optional INI resource file name from TEXTFILE resource directory to be used for loading file specific properties.
bFreeOnRelease | If TRUE, the module specified by hResource handle will be unloaded on releasing.
Returns
TRUE if resource handle is successfully set and resource loaded.
See also
SetIniData

◆ SetHandle() [2/3]

BOOL SetHandle | ( | HMODULE | hResource,
 |  | LPCTSTR | lpszThemeFileName,
 |  | LPCTSTR | lpszAppFileName,
 |  | BOOL | bFreeOnRelease = FALSE )

Sets image collection resource handle.

Parameters
hResource | Module handle to be used for resources.
lpszThemeFileName | Optional INI resource file name from TEXTFILE resource directory to be used for loading file specific properties.
lpszAppFileName | Name of initialization file of the application
bFreeOnRelease | If TRUE, the module specified by hResource handle will be unloaded on releasing.
Returns
TRUE if resource handle is successfully set and resource loaded.
See also
SetIniData

◆ SetHandle() [3/3]

BOOL SetHandle | ( | LPCTSTR | lpszDllFileName,
 |  | LPCTSTR | lpszIniFileName = NULL )

Sets image collection resource handle.

Parameters
lpszDllFileName | DLL file name.
lpszIniFileName | Optional INI resource file name from TEXTFILE resource directory to be used for loading file specific properties.
Returns
TRUE if resource handle is successfully set and resource loaded.
See also
SetIniData

◆ SetIniData()

void SetIniData ( LPCSTR lpIniData )

Loads INI file properties from the provided input.

Parameters
lpIniData INI file contents to load.
See also
SetHandle
The documentation for this class was generated from the following file:
  • XTPResourceImage.h


Toolkit Pro: CXTPResourceManager Class Reference

Classes | Public Member Functions | Static Public Member Functions | Static Public Attributes | Protected Member Functions | Protected Attributes | Static Protected Attributes | List of all members
CXTPResourceManager Class Reference

Standalone class used to managed toolkit resources. More...

Inheritance diagram for CXTPResourceManager:
[legend]

Classes

class CManageState
CManageState is used internally by the toolkit to switch module states. More...

Public Member Functions

CXTPResourceManager ()
Constructs a CXTPResourceManager object.
~CXTPResourceManager ()
Destroys a CXTPResourceManagerXML object, handles cleanup and de- allocation.
void | SetResourceFile (const CString &strResourceFile)
Call this member to set resource file to be used (dll or xml)
void | SetResourceHandle (HMODULE hModRes)
Call this member to set the resource handle for the calling module.
HMODULE | GetResourceHandle () const
Call this member function to return the library resource handle.
HRSRC | FindResource (HMODULE &hModule, LPCTSTR lpName, LPCTSTR lpType)
The FindResource function tries to locate the resource in the library resources first.
virtual BOOL | LoadString (CString *pString, UINT nIDResource)
Reads a Windows string resource, identified by nID, into an existing CString object.
virtual CString | LoadString (UINT nIDResource, BOOL *pbError=NULL)
Reads a Windows string resource, identified by nID.
virtual BOOL | LoadMenu (CMenu *lpMenu, UINT nIDResource)
Reads a Windows menu resource, identified by nID, into an existing CMenu object.
virtual BOOL | LoadToolBar (CToolBar *pToolBar, UINT nIDResource)
Call this member function to load the toolbar specified by CToolBar and nIDResource.
virtual BOOL | LoadBitmap (CBitmap *pBitmap, UINT nIDResource)
Reads a Windows bitmap resource, identified by nID, into an existing CBitmap object.
virtual BOOL | LoadBitmap (CBitmap *pBitmap, LPCTSTR lpszResource)
Reads a Windows bitmap resource, identified by nID, into an existing CBitmap object.
virtual HCURSOR | LoadCursor (UINT nIDResource)
Reads a Windows cursor resource, identified by nID, into an existing cursor object.
virtual LPCDLGTEMPLATE | LoadDialogTemplate (UINT nIDResource)
Reads a Windows dialog resource, identified by pszResource.
virtual HGLOBAL | LoadDialogTemplate2 (LPCTSTR pszTemplate)
Reads a Windows dialog template identified by pszResource into the memory.
virtual BOOL | LoadHTML (CString *pText, UINT nIDResource)
Reads a Windows HTML resource, identified by nIDResource, into an existing CString object.
virtual BOOL | LoadHTML (CString *pText, LPCTSTR pszResource)
Reads a Windows HTML resource, identified by pszResource, into an existing CString object.
virtual HICON | LoadIcon (LPCTSTR lpszID, CSize iconSize)
The LoadIcon function loads an icon by locating its resource handle.
virtual HICON | LoadIcon (int nID, CSize iconSize)
The LoadIcon function loads an icon by locating its resource handle.
virtual BOOL | LoadXAML (CString &xaml, UINT nIDResource)
Reads a Windows RT_XAML resource, identified by pszResource, into an existing CString object.
virtual BOOL | LoadSVG (CString &svg, UINT nIDResource)
Reads a Windows RT_SVG resource, identified by pszResource, into an existing CString object.
virtual HICON | CreateIconFromResource (HMODULE hModule, LPCTSTR lpszID, CSize iconSize)
The CreateIconFromResource function creates a new icon from the specified modules icon resource.
int | ShowMessageBox (UINT nIDPrompt, UINT nType=MB_OK)
Displays a message box on the screen.
int | ShowMessageBox (LPCTSTR lpszText, UINT nType=MB_OK)
Displays a message box on the screen.
virtual void | Close ()
This method free used resource.
BOOL | SetResourceManager (CXTPResourceManager *pResourceManager)
Call this method to set application defined Resource manager.
virtual WORD | GetResourcesLangID ()
Get current resource language ID.
LCID | GetActiveLCID ()
Get current LCID.
void | SetResourceFontCharset (BOOL bResourceCharset=TRUE)
Call this member to use the default font charset defined in resource files.
BYTE | GetFontCharset () const
Call this member to get the default charset for a LOGFONT structure.
void | SetFontCharset (BYTE nFontCharset)
Call this member to set the default font charset.

Static Public Member Functions

static WORD AFX_CDECL | GetResourceLanguage (HMODULE hResModule)
Call this static method to determine what language has resources.
static BOOL AFX_CDECL | IsIntResource (LPCTSTR lpName, BOOL bTryParse=FALSE)
Checks if the resource name is an INT-resource.
static WORD AFX_CDECL | MakeIntResource (LPCTSTR lpName)
Makes a resource identifier from a provided INT-resource name.

Static Public Attributes

static CProcessLocal< CXTPResourceManager > m_managerInstance
Manager instance.

Protected Member Functions

virtual void | UpdateResourcesLangID ()
This method checks the resource identifier of loaded resources.
BOOL | OnLoadingFailed ()
This method is called to notify the developer that resource load failed.

Protected Attributes

BOOL | m_bValid
TRUE if Resource manager is valid.
HMODULE | m_hResourceFile
Resource file handle.
XTP_RESOURCEMANAGER_LANGINFO * | m_pLanguageInfo
Resource language.

Static Protected Attributes

static HMODULE m_hModXTResource
Handle to toolkit resource.

Detailed Description

Standalone class used to managed toolkit resources.

Member Function Documentation

◆ Close()

virtual void Close ( )
virtual

This method free used resource.

Call it in ExitInstance of your application if you use external resource file.

See also
SetResourceFile

Reimplemented in CXTPResourceManagerXML.

◆ CreateIconFromResource()

virtual HICON CreateIconFromResource | ( | HMODULE | hModule,
 |  | LPCTSTR | lpszID,
 |  | CSize | iconSize )
 virtual

The CreateIconFromResource function creates a new icon from the specified modules icon resource.

Parameters
hModule | [in] Handle to the module whose executable file contains the icon resource.
lpszID | [in] Specifies the name of the icon to load.
iconSize | [in] Specifies the width and height in pixels of the icon.
Returns
If the function succeeds, the return value is a handle to the icon or cursor. If the function fails, the return value is NULL. To get extended error information, call GetLastError.

◆ FindResource()

HRSRC FindResource | ( | HMODULE & | hModule,
 |  | LPCTSTR | lpName,
 |  | LPCTSTR | lpType )

The FindResource function tries to locate the resource in the library resources first.

If not found it continues to search for the resource by walking the resource chain until a handle to the module containing the resource if found.

Parameters
hModule | A reference to a HMODULE reference that receives a handle to the module whose executable file contains the resource.
lpName | Specifies the name of the resource.
lpType | Specifies the type of the resource.
Returns
If the function succeeds, the return value is a handle to the specified resource's information block. To obtain a handle to the resource, pass this handle to the LoadResource function. If the function fails, the return value is NULL. To get extended error information, call GetLastError.

◆ GetActiveLCID()

LCID GetActiveLCID ( )

Get current LCID.

Returns
Current resource LCID.

◆ GetFontCharset()

BYTE GetFontCharset ( ) const

Call this member to get the default charset for a LOGFONT structure.

Returns
The default charset for a LOGFONT structure.

◆ GetResourceHandle()

HMODULE GetResourceHandle ( ) const

Call this member function to return the library resource handle.

Returns
Returns the resource handle defined for the library.

◆ GetResourceLanguage()

static WORD AFX_CDECL GetResourceLanguage ( HMODULE hResModule )
static

Call this static method to determine what language has resources.

Parameters
hResModule Resource instance
Returns
Returns the language identifier value for the specified module as described in https://docs.microsoft.com/en-us/windows/win32/intl/language-identifiers.

◆ GetResourcesLangID()

virtual WORD GetResourcesLangID ( )
virtual

Get current resource language ID.

Value for default resource is (LANG_ENGLISH, SUBLANG_ENGLISH_US)

Returns
Current resource language ID.

◆ IsIntResource()

static BOOL AFX_CDECL IsIntResource | ( | LPCTSTR | lpName,
 |  | BOOL | bTryParse = FALSE )
 static

Checks if the resource name is an INT-resource.

Parameters
lpName | Resource name pointer.
bTryParse | If TRUE, the function will try to parse a string representation of the INT-resource, e.g.: '#123'.
Returns
TRUE if the resource name is an INT-resource.

◆ LoadBitmap() [1/2]

virtual BOOL LoadBitmap | ( | CBitmap * | pBitmap,
 |  | LPCTSTR | lpszResource )
 virtual

Reads a Windows bitmap resource, identified by nID, into an existing CBitmap object.

Parameters
pBitmap | Result CBitmap pointer
lpszResource | A Windows bitmap resource name.
Returns
Nonzero if resource load was successful; otherwise 0.

◆ LoadBitmap() [2/2]

virtual BOOL LoadBitmap | ( | CBitmap * | pBitmap,
 |  | UINT | nIDResource )
 virtual

Reads a Windows bitmap resource, identified by nID, into an existing CBitmap object.

Parameters
pBitmap | Result CBitmap pointer
nIDResource | A Windows bitmap resource ID.
Returns
Nonzero if resource load was successful; otherwise 0.

◆ LoadCursor()

virtual HCURSOR LoadCursor ( UINT nIDResource )
virtual

Reads a Windows cursor resource, identified by nID, into an existing cursor object.

Parameters
nIDResource A Windows cursor resource ID.
Returns
Nonzero if resource load was successful; otherwise 0.

◆ LoadDialogTemplate()

virtual LPCDLGTEMPLATE LoadDialogTemplate ( UINT nIDResource )
virtual

Reads a Windows dialog resource, identified by pszResource.

Parameters
nIDResource A Windows dialog resource ID.
Returns
LPCDLGTEMPLATE pointer if resource load was successful; otherwise 0.

Reimplemented in CXTPResourceManagerXML.

◆ LoadDialogTemplate2()

virtual HGLOBAL LoadDialogTemplate2 ( LPCTSTR pszTemplate )
virtual

Reads a Windows dialog template identified by pszResource into the memory.

Parameters
pszTemplate A Windows dialog resource ID.
Returns
HGLOBAL handle if resource load was successful; otherwise 0.

Can be useful to load custom templates for common dialogs. To access dialog template data use LockResource() API function.

See also
LoadDialogTemplate()

◆ LoadHTML() [1/2]

virtual BOOL LoadHTML | ( | CString * | pText,
 |  | LPCTSTR | pszResource )
 virtual

Reads a Windows HTML resource, identified by pszResource, into an existing CString object.

Parameters
pText | Output string pointer
pszResource | A string specifying resource name.
Returns
Nonzero if resource load was successful; otherwise 0.

◆ LoadHTML() [2/2]

virtual BOOL LoadHTML | ( | CString * | pText,
 |  | UINT | nIDResource )
 virtual

Reads a Windows HTML resource, identified by nIDResource, into an existing CString object.

Parameters
pText | Output string pointer
nIDResource | A Windows bitmap resource ID.
Returns
Nonzero if resource load was successful; otherwise 0.

◆ LoadIcon() [1/2]

virtual HICON LoadIcon | ( | int | nID,
 |  | CSize | iconSize )
 virtual

The LoadIcon function loads an icon by locating its resource handle.

Parameters
nID | [in] Specifies the resource id of the icon to load.
iconSize | [in] Specifies the width and height in pixels of the icon.
Returns
If the function succeeds, the return value is the handle of the newly loaded icon. If the function fails, the return value is NULL. To get extended error information, call GetLastError.

◆ LoadIcon() [2/2]

virtual HICON LoadIcon | ( | LPCTSTR | lpszID,
 |  | CSize | iconSize )
 virtual

The LoadIcon function loads an icon by locating its resource handle.

Parameters
lpszID | [in] Specifies the name of the icon to load.
iconSize | [in] Specifies the width and height in pixels of the icon.
Returns
If the function succeeds, the return value is the handle of the newly loaded icon. If the function fails, the return value is NULL. To get extended error information, call GetLastError.

◆ LoadMenu()

virtual BOOL LoadMenu | ( | CMenu * | lpMenu,
 |  | UINT | nIDResource )
 virtual

Reads a Windows menu resource, identified by nID, into an existing CMenu object.

Parameters
lpMenu | Output menu pointer
nIDResource | A Windows menu resource ID.
Returns
Nonzero if resource load was successful; otherwise 0.

Reimplemented in CXTPResourceManagerXML.

◆ LoadString() [1/2]

virtual BOOL LoadString | ( | CString * | pString,
 |  | UINT | nIDResource )
 virtual

Reads a Windows string resource, identified by nID, into an existing CString object.

Parameters
pString | Output string pointer
nIDResource | A Windows string resource ID.
Returns
Nonzero if resource load was successful; otherwise 0.

Reimplemented in CXTPResourceManagerXML.

◆ LoadString() [2/2]

virtual CString LoadString | ( | UINT | nIDResource,
 |  | BOOL * | pbError = NULL )
 virtual

Reads a Windows string resource, identified by nID.

Parameters
nIDResource | A Windows string resource ID.
pbError | Pointer to a BOOL variable to report was resource load successful or not. (Optional).
Returns
Loaded string or empty string if such string ID does not find in resource.

Reimplemented in CXTPResourceManagerXML.

◆ LoadSVG()

virtual BOOL LoadSVG | ( | CString & | svg,
 |  | UINT | nIDResource )
 virtual

Reads a Windows RT_SVG resource, identified by pszResource, into an existing CString object.

Parameters
svg | Output string
nIDResource | Resource identifier.
Returns
Nonzero if resource load was successful; otherwise 0.

◆ LoadToolBar()

virtual BOOL LoadToolBar | ( | CToolBar * | pToolBar,
 |  | UINT | nIDResource )
 virtual

Call this member function to load the toolbar specified by CToolBar and nIDResource.

Parameters
pToolBar | Result CToolBar pointer
nIDResource | Resource ID of the toolbar to be loaded.
Returns
Nonzero if resource load was successful; otherwise 0.

◆ LoadXAML()

virtual BOOL LoadXAML | ( | CString & | xaml,
 |  | UINT | nIDResource )
 virtual

Reads a Windows RT_XAML resource, identified by pszResource, into an existing CString object.

Parameters
xaml | Output string
nIDResource | Resource identifier.
Returns
Nonzero if resource load was successful; otherwise 0.

◆ MakeIntResource()

static WORD AFX_CDECL MakeIntResource ( LPCTSTR lpName )
static

Makes a resource identifier from a provided INT-resource name.

Parameters
lpName Resource name pointer. Can be either an INT-resource or a pointer string representation of an INT-resource, e.g.: '#123'.
Returns
A resource identifier value, or 0 if the INT-resource name is invalid.

◆ OnLoadingFailed()

BOOL OnLoadingFailed ( )
protected

This method is called to notify the developer that resource load failed.

Returns
TRUE if loading has failed, otherwise FALSE.

◆ SetFontCharset()

void SetFontCharset ( BYTE nFontCharset )

Call this member to set the default font charset.

Parameters
nFontCharset Default font charset that will be used in the whole library.

◆ SetResourceFile()

void SetResourceFile ( const CString & strResourceFile )

Call this member to set resource file to be used (dll or xml)

Parameters
strResourceFile Resource file to be used.

Call Close method in ExitInstance of your application to free resources.

See also
Close, SetResourceHandle

◆ SetResourceFontCharset()

void SetResourceFontCharset ( BOOL bResourceCharset = TRUE )

Call this member to use the default font charset defined in resource files.

Parameters
bResourceCharset TRUE to use the font charset defined in translated .dll and .xml files.

◆ SetResourceHandle()

void SetResourceHandle ( HMODULE hModRes )

Call this member to set the resource handle for the calling module.

Parameters
hModRes Handle to modules resource.

◆ SetResourceManager()

BOOL SetResourceManager ( CXTPResourceManager * pResourceManager )

Call this method to set application defined Resource manager.

Parameters
pResourceManager Application defined Resource manager
Returns
TRUE if successful; otherwise 0.

◆ ShowMessageBox() [1/2]

int ShowMessageBox | ( | LPCTSTR | lpszText,
 |  | UINT | nType = MB_OK )

Displays a message box on the screen.

Parameters
lpszText | Message string to display.
nType | The style of the message box.
Returns
See AfxMessageBox return values list

◆ ShowMessageBox() [2/2]

int ShowMessageBox | ( | UINT | nIDPrompt,
 |  | UINT | nType = MB_OK )

Displays a message box on the screen.

Parameters
nIDPrompt | A unique ID used to reference a string in the string table.
nType | The style of the message box.
Returns
See AfxMessageBox return values list
The documentation for this class was generated from the following file:
  • XTPResourceManager.h


Toolkit Pro: CXTPResourceManager::CManageState Class Reference

  • CXTPResourceManager
  • CManageState
Public Member Functions | Protected Attributes | List of all members
CXTPResourceManager::CManageState Class Reference

CManageState is used internally by the toolkit to switch module states. More...

Public Member Functions

CManageState ()
Constructs a CManageState object.
~CManageState ()
Destroys a CManageState object, handles cleanup and deallocation.
void | Undo ()
Call this member function to UNDO managed state.
void | Redo ()
Call this member function to REDO managed state.

Protected Attributes

bool | m_bSet
true to set
HMODULE | m_hModOldResource
Handle to previous resource.

Detailed Description

CManageState is used internally by the toolkit to switch module states.

Specifically, the class enables the toolkit to read its own .dll resources, and not that of the host application (or .dll). Future versions of the class may handle other such details

The documentation for this class was generated from the following file:
  • XTPResourceManager.h


Toolkit Pro: CXTPResourceManagerXML Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPResourceManagerXML Class Reference

Class used to managed toolkit resources from an XML file. More...

Inheritance diagram for CXTPResourceManagerXML:
[legend]

Public Member Functions

CXTPResourceManagerXML (LPCTSTR lpszFileName)
Constructs a CXTPResourceManagerXML object.
CXTPResourceManagerXML (CXTPPropExchangeXMLNode *pResourceRoot)
Constructs a CXTPResourceManagerXML object.
~CXTPResourceManagerXML ()
Destroys a CXTPResourceManagerXML object, handles cleanup and deallocation.
virtual BOOL | LoadString (CString *pString, UINT nIDResource)
Reads a Windows string resource, specified by nID, into an existing CString object.
virtual BOOL | LoadMenu (CMenu *lpMenu, UINT nIDResource)
Reads a Windows menu resource, specified by nID, into an existing CMenu object.
virtual LPCDLGTEMPLATE | LoadDialogTemplate (UINT nIDResource)
Reads a Windows dialog resource, specified by pszResource.
virtual void | Close ()
This method frees used resources.
virtual CString | LoadString (UINT nIDResource, BOOL *pbError=NULL)
Reads a Windows string resource, identified by nID.
- Public Member Functions inherited from CXTPResourceManager
CXTPResourceManager ()
Constructs a CXTPResourceManager object.
~CXTPResourceManager ()
Destroys a CXTPResourceManagerXML object, handles cleanup and de- allocation.
void | SetResourceFile (const CString &strResourceFile)
Call this member to set resource file to be used (dll or xml)
void | SetResourceHandle (HMODULE hModRes)
Call this member to set the resource handle for the calling module.
HMODULE | GetResourceHandle () const
Call this member function to return the library resource handle.
HRSRC | FindResource (HMODULE &hModule, LPCTSTR lpName, LPCTSTR lpType)
The FindResource function tries to locate the resource in the library resources first.
virtual BOOL | LoadToolBar (CToolBar *pToolBar, UINT nIDResource)
Call this member function to load the toolbar specified by CToolBar and nIDResource.
virtual BOOL | LoadBitmap (CBitmap *pBitmap, UINT nIDResource)
Reads a Windows bitmap resource, identified by nID, into an existing CBitmap object.
virtual BOOL | LoadBitmap (CBitmap *pBitmap, LPCTSTR lpszResource)
Reads a Windows bitmap resource, identified by nID, into an existing CBitmap object.
virtual HCURSOR | LoadCursor (UINT nIDResource)
Reads a Windows cursor resource, identified by nID, into an existing cursor object.
virtual HGLOBAL | LoadDialogTemplate2 (LPCTSTR pszTemplate)
Reads a Windows dialog template identified by pszResource into the memory.
virtual BOOL | LoadHTML (CString *pText, UINT nIDResource)
Reads a Windows HTML resource, identified by nIDResource, into an existing CString object.
virtual BOOL | LoadHTML (CString *pText, LPCTSTR pszResource)
Reads a Windows HTML resource, identified by pszResource, into an existing CString object.
virtual HICON | LoadIcon (LPCTSTR lpszID, CSize iconSize)
The LoadIcon function loads an icon by locating its resource handle.
virtual HICON | LoadIcon (int nID, CSize iconSize)
The LoadIcon function loads an icon by locating its resource handle.
virtual BOOL | LoadXAML (CString &xaml, UINT nIDResource)
Reads a Windows RT_XAML resource, identified by pszResource, into an existing CString object.
virtual BOOL | LoadSVG (CString &svg, UINT nIDResource)
Reads a Windows RT_SVG resource, identified by pszResource, into an existing CString object.
virtual HICON | CreateIconFromResource (HMODULE hModule, LPCTSTR lpszID, CSize iconSize)
The CreateIconFromResource function creates a new icon from the specified modules icon resource.
int | ShowMessageBox (UINT nIDPrompt, UINT nType=MB_OK)
Displays a message box on the screen.
int | ShowMessageBox (LPCTSTR lpszText, UINT nType=MB_OK)
Displays a message box on the screen.
BOOL | SetResourceManager (CXTPResourceManager *pResourceManager)
Call this method to set application defined Resource manager.
virtual WORD | GetResourcesLangID ()
Get current resource language ID.
LCID | GetActiveLCID ()
Get current LCID.
void | SetResourceFontCharset (BOOL bResourceCharset=TRUE)
Call this member to use the default font charset defined in resource files.
BYTE | GetFontCharset () const
Call this member to get the default charset for a LOGFONT structure.
void | SetFontCharset (BYTE nFontCharset)
Call this member to set the default font charset.

Protected Member Functions

virtual void | UpdateResourcesLangID ()
This method checks the resource identifier of loaded resources.
- Protected Member Functions inherited from CXTPResourceManager
BOOL | OnLoadingFailed ()
This method is called to notify the developer that resource load failed.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPResourceManager
static WORD AFX_CDECL | GetResourceLanguage (HMODULE hResModule)
Call this static method to determine what language has resources.
static BOOL AFX_CDECL | IsIntResource (LPCTSTR lpName, BOOL bTryParse=FALSE)
Checks if the resource name is an INT-resource.
static WORD AFX_CDECL | MakeIntResource (LPCTSTR lpName)
Makes a resource identifier from a provided INT-resource name.
- Static Public Attributes inherited from CXTPResourceManager
static CProcessLocal< CXTPResourceManager > | m_managerInstance
Manager instance.
- Protected Attributes inherited from CXTPResourceManager
BOOL | m_bValid
TRUE if Resource manager is valid.
HMODULE | m_hResourceFile
Resource file handle.
XTP_RESOURCEMANAGER_LANGINFO * | m_pLanguageInfo
Resource language.
- Static Protected Attributes inherited from CXTPResourceManager
static HMODULE | m_hModXTResource
Handle to toolkit resource.

Detailed Description

Class used to managed toolkit resources from an XML file.

Constructor & Destructor Documentation

◆ CXTPResourceManagerXML() [1/2]

CXTPResourceManagerXML ( LPCTSTR lpszFileName )

Constructs a CXTPResourceManagerXML object.

Parameters
lpszFileName .XML file path.

◆ CXTPResourceManagerXML() [2/2]

CXTPResourceManagerXML ( CXTPPropExchangeXMLNode * pResourceRoot )

Constructs a CXTPResourceManagerXML object.

Parameters
pResourceRoot Base XML Node.

Member Function Documentation

◆ Close()

virtual void Close ( )
virtual

This method frees used resources.

Call it within ExitInstance in your application if you use an external resource file.

See also
SetResourceFile

Reimplemented from CXTPResourceManager.

◆ LoadDialogTemplate()

virtual LPCDLGTEMPLATE LoadDialogTemplate ( UINT nIDResource )
virtual

Reads a Windows dialog resource, specified by pszResource.

Parameters
nIDResource A Windows dialog resource ID.
Returns
LPCDLGTEMPLATE pointer if resource load was successful, otherwise 0.

Reimplemented from CXTPResourceManager.

◆ LoadMenu()

virtual BOOL LoadMenu | ( | CMenu * | lpMenu,
 |  | UINT | nIDResource )
 virtual

Reads a Windows menu resource, specified by nID, into an existing CMenu object.

Parameters
lpMenu | Output menu pointer.
nIDResource | A Windows menu resource ID.
Returns
TRUE if successful, otherwise FALSE.

Reimplemented from CXTPResourceManager.

◆ LoadString() [1/2]

virtual BOOL LoadString | ( | CString * | pString,
 |  | UINT | nIDResource )
 virtual

Reads a Windows string resource, specified by nID, into an existing CString object.

Parameters
pString | Output string pointer.
nIDResource | A Windows string resource ID.
Returns
TRUE if successful, otherwise FALSE.

Reimplemented from CXTPResourceManager.

◆ LoadString() [2/2]

virtual CString LoadString | ( | UINT | nIDResource,
 |  | BOOL * | pbError = NULL )
 virtual

Reads a Windows string resource, identified by nID.

Parameters
nIDResource | A Windows string resource ID.
pbError | Pointer to a BOOL variable to report was resource load successful or not. (Optional).
Returns
Loaded string or empty string if such string ID does not find in resource.

Reimplemented from CXTPResourceManager.

The documentation for this class was generated from the following file:
  • XTPResourceManager.h


Toolkit Pro: CXTPResourceTheme Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPResourceTheme Class Reference

The CXTPResourceTheme class is used to enable a resource style theme for Command Bars. More...

Inheritance diagram for CXTPResourceTheme:
[legend]

Public Member Functions

CXTPResourceTheme ()
Constructs a CXTPResourceTheme object.
virtual | ~CXTPResourceTheme ()
Destroys a CXTPResourceTheme object, handles cleanup and deallocation.
CXTPResourceImage * | LoadImage (LPCTSTR lpszFileName)
Loads a bitmap image from the specified path.
void | SetImageHandle (HMODULE hResource, LPCTSTR lpszIniFileName)
Specifies the resource that contains the bitmaps to be loaded for the theme.
virtual BOOL | RequiresResourceImages ()
Used by the paint manager to determine if the theme requires a resource DLL to load image and color information.
CXTPResourceImages * | GetImages () const
This method is called to get the CXTPResourceImages pointer.
void | SetImages (CXTPResourceImages *pImages)
Call this method to set images for the theme.
virtual COLORREF | GetRectangleTextColor (BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition)
This method retrieves a button's text color.
virtual void | FillWorkspace (CDC *pDC, CRect rc, CRect rcExclude)
Draws workspace space.
virtual CXTPFramePaintManager * | GetFramePaintManager ()
Returns the paint manager used to draw frames.
virtual CXTPRibbonPaintManager * | GetRibbonPaintManager ()
Retrieves the ribbon paint manager.
- Public Member Functions inherited from CXTPCommandBarsOffice2003Theme
CXTPCommandBarsOffice2003Theme ()
Constructs a CXTPCommandBarsOffice2003Theme object.
virtual | ~CXTPCommandBarsOffice2003Theme ()
Destroys a CXTPCommandBarsOffice2003Theme object, handles cleanup and deallocation.
void | ExcludeCorners (CDC *pDC, CRect rc)
This method creates a new clipping region that consists of the existing clipping region minus the corners rectangles.
- Public Member Functions inherited from CXTPCommandBarsOfficeXPTheme
CXTPCommandBarsOfficeXPTheme ()
Constructs a CXTPCommandBarsOfficeXPTheme object.
virtual CSize | DrawListBoxControl (CDC *pDC, CXTPControl *pButton, CRect rc, BOOL bSelected, BOOL bDraw, CXTPCommandBars *pCommandBars=0)
This method is called to draw the control placed on the ListBox.
virtual void | AdjustExcludeRect (CRect &rc, CXTPControl *pControl, BOOL bVertical)
This method is called to determine the offset of a pop-up bar.
virtual void | DrawPopupResizeGripper (CDC *pDC, CRect rcGripper, int nFlags)
This method is called to draw a resize gripper of a pop-up bar.
- Public Member Functions inherited from CXTPPaintManager
CSize | DrawControl (CDC *pDC, CXTPControl *pButton, BOOL bDraw=TRUE)
This method is called to draw the control.
virtual CSize | DrawControlToolBarParent (CDC *pDC, CXTPControl *pButton, BOOL bDraw)
This method is called to draw the control placed on the toolbar.
virtual COLORREF | GetControlEditBackColor (CXTPControl *pControl)
This method returns the edit control back color to draw.
virtual void | DrawControlEntry (CDC *pDC, CXTPControl *pButton)
This method is called to fill the control's face.
virtual COLORREF | GetControlTextColor (CXTPControl *pButton)
Call this method to get the control text color to draw.
virtual COLORREF | GetControlBackColor (CXTPControl *pButton)
Call this method to get the control back color to draw.
virtual void | DrawGalleryItemBack (CDC *pDC, CRect rcItem, BOOL bEnabled, BOOL bSelected, BOOL bPressed, BOOL bChecked, XTPBarType barType)
This method is called to draw the background for a gallery menu item.
virtual void | DrawCommandBarGroupSeparator (CDC *pDC, CXTPCommandBar *pBar, CXTPControl *pLeftControl, CXTPControl *pRightControl, BOOL bDraw=TRUE)
This method is called to draw a command bar's group separator.
int | GetShadowOptions () const
Determines the kind of shadow to use.
virtual void | DrawExpandGlyph (CDC *pDC, CXTPControl *pButton, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clr)
Draw expand or hidden glyphs for a button.
virtual void | DrawExpandGlyph (CDC *pDC, CXTPControl *pButton, COLORREF clr, BOOL bVertical)
Draw expand or hidden glyphs for a button.
virtual void | DrawHiddenGlyph (CDC *pDC, CXTPControl *pButton, COLORREF clr, BOOL bVertical)
Draw expand or hidden glyphs for a button.
virtual CRect | GetSplitButtonCommandRect (CXTPControl *pButton)
Determines split button command rectangle.
virtual void | SetCommandBarRegion (CXTPCommandBar *pCommandBar)
Call this method to set the bounding region of a pop-up bar.
XTPPaintTheme GetCurrentTheme ()
Call this member to get the current visual theme.
virtual CFont * | GetControlFont (CXTPControl *pControl)
Call this member to retrieve the font of the command bar control.
virtual CFont * | GetCommandBarFont (CXTPCommandBar *pCommandBar)
Call this member to retrieve the font of the command bar.
virtual XTPBarTextOrientation | GetControlTextOrientation (CXTPControl *pControl)
Call this member to determine how to draw text.
virtual void | UpdateFonts ()
Refreshes the fonts to use.
virtual void | UpdateColors ()
Refreshes the standard colors to use.
void | SetCommandBarsFontIndirect (LOGFONT *pLogFont, BOOL bUseStandardFont=FALSE)
Call this member to set command bar's font.
CFont * | GetRegularFont ()
Returns the general font.
CFont * | GetRegularBoldFont ()
Returns the general bold font.
CFont * | GetIconFont ()
Returns the icon font.
CFont * | GetSmCaptionFont ()
Call this method to retrieve the caption of a floating mini frame.
void | UseOfficeFont (bool bUseOfficeFont)
Call this method to use Tahoma font despite system metrics.
int | GetControlHeight () const
This method returns the common controls height.
virtual CSize | GetDefaultCommandBarSize (CXTPCommandBar *pBar)
Computes default command bar size taking into account command bar font.
void | Rectangle (CDC *pDC, LPCRECT rc, int nPen, const int nBrush)
Draws a rectangle.
void | Rectangle (CDC *pDC, LPCRECT rc, COLORREF clrPen, COLORREF clrBrush)
Draws a rectangle.
void | RoundRect (CDC *pDC, LPCRECT rc, COLORREF clrPen, COLORREF clrBrush)
Draws a rectangle.
void | Draw3dRect (CDC *pDC, LPCRECT rc, int nTopLeft, int nBottomRight)
Call this member function to draw a three-dimensional rectangle.
void | Draw3dRect (CDC *pDC, LPCRECT rc, int frameThickness, COLORREF clrPen, COLORREF clrBrush)
Call this member function to draw a rectangle with predetermined thickness.
virtual void | DrawPopupBarCheckMark (CDC *pDC, CRect rcCheck, BOOL bEnabled, COLORREF clr)
Call this member function to draw a check mark.
void | DrawCheckMark (CDC *pDC, CRect rcCheck, COLORREF clr=0)
Call this member function to draw a check mark.
virtual void | DrawPopupBarRadioMark (CDC *pDC, CRect rcCheck, BOOL bEnabled, COLORREF clr)
Call this member function to draw a radio button.
virtual void | DrawComboExpandMark (CDC *pDC, CRect rc, COLORREF clr)
Call this member function to draw a combobox expand symbol.
virtual void | DrawControlMDIButton (CDC *pDC, CXTPControlButton *pButton)
Call this member function to draw menu MDI buttons.
void | Line (CDC *pDC, CPoint p0, CPoint p1)
Draws a line.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1, const int nPen)
Draws a line.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1, COLORREF clrPen)
Draws a line.
void | HorizontalLine (CDC *pDC, int x0, int y0, int x1, COLORREF clrPen)
Call this member function to draw a horizontal line using the specified coordinages and RGB color value.
void | VerticalLine (CDC *pDC, int x0, int y0, int y1, COLORREF clrPen)
Call this member function to draw a vertical line using the specified coordinages and RGB color value.
virtual void | DrawDropDownGlyph (CDC *pDC, CXTPControl *pControl, CPoint pt, BOOL bSelected, BOOL bPopuped, BOOL bEnabled, BOOL bVert)
This member function is called to draw a split button expand symbol.
void | Pixel (CDC *pDC, int xPos, int yPos, int nPen)
Sets the pixel at the point.
void | GradientFill (CDC *pDC, LPRECT lpRect, COLORREF crFrom, COLORREF crTo, BOOL bHorz, LPCRECT lpRectClip=NULL)
Gradient fills the rectangle.
XTP_COMMANDBARS_ICONSINFO * GetIconsInfo ()
virtual void | Animate (CDC *pDestDC, CDC *pSrcDC, CRect rc, XTPAnimationType animationType)
This method is called to animate the pop-up bar.
virtual void | AnimateExpanding (CXTPCommandBar *pCommandBar, CDC *pDestDC, CDC *pSrcDC, BOOL bExpandDown)
This method is called to animate the expanding process.
void | SetAnimationDelay (int nAnimationSteps, int nAnimationTime)
Call this method to set animation delay.
COLORREF | GetXtremeColor (UINT nIndex)
This function retrieves the current color of the specified XP display element.
void | SetColors (int cElements, CONST INT *lpaElements, CONST COLORREF *lpaRgbValues)
Call this member to set the colors for each element to the color in the specified color array.
CSize | DrawControlText (CDC *pDC, CXTPControl *pControl, CRect rcText, BOOL bDraw, BOOL bVert, BOOL bCentered, BOOL bTriangled)
This method is called to draw control text.
virtual void | UpdateRTLCaption (CString &strCaption)
This method is called to prepare a caption for Right-To-Left draw.
XTPCurrentSystemTheme GetCurrentSystemTheme ()
Call this member function to determine the current Windows XP theme in use.
void | SetLunaTheme (XTPCurrentSystemTheme systemTheme)
Call this method to force system theme.
virtual int | GetPopupBarGripperWidth (CXTPCommandBar *pBar)
Calculates the gripper of a pop-up bar.
virtual CXTPControlGalleryPaintManager * | GetGalleryPaintManager () const
Retrieves paint manager used to draw galleries.
virtual CXTPScrollBarPaintManager * | GetScrollBarPaintManager () const
Retrieves paint manager used to draw scrollbars.
virtual CXTPSliderPaintManager * | GetSliderPaintManager () const
Retrieves paint manager used to draw slider panes.
virtual CXTPProgressPaintManager * | GetProgressPaintManager () const
Retrieves paint manager used to draw progress bars.
virtual CXTPStatusBarPaintManager * | GetStatusBarPaintManager ()
Retrieves paint manager used to draw the status bar.
virtual CXTPMessageBarPaintManager * | GetMessageBarPaintManager ()
Retrieves paint manager used to draw message bars.
CXTPShadowManager * | GetShadowManager () const
Retrieves shadow manager used to draw shadows.
BOOL | IsUseSystemAccentColorEnabled () const
Determines whether xtpApplicationUseSystemAccentColor application ambient property is set.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.
- Public Member Functions inherited from CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents >
void | Subscribe (IXTPPaintManagerEvents *pObserver, CXTPSubscriptionList< CXTPPaintManager, IXTPPaintManagerEvents > *pSubcriptionList=NULL)
Subscribes a unique observer for events.
void | Unsubscribe (IXTPPaintManagerEvents *pObserver)
Unsubscribes an observer from events.
void | Notify (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *))
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *))
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.

Protected Member Functions

virtual void | RefreshMetrics ()
This method is called to refresh the visual metrics of the manager.
virtual XTPPaintTheme | BaseTheme ()
Retrieves the base theme of the manager.
BOOL | IsImagesAvailable ()
Determines if images are available.
- Protected Member Functions inherited from CXTPCommandBarsOffice2003Theme
virtual void | DrawPopupBarGripper (CDC *pDC, int xPos, int yPos, int cx, int cy, BOOL bExpanded=FALSE)
This method is called to draw a pop-up bar's right gripper.
virtual void | FillDockBar (CDC *pDC, CXTPDockBar *pBar)
This method is called to fill a dockbar.
virtual void | FillCommandBarEntry (CDC *pDC, CXTPCommandBar *pBar)
This method is called to fill the command bar's face.
virtual CSize | DrawCommandBarSeparator (CDC *pDC, CXTPCommandBar *pBar, CXTPControl *pControl, BOOL bDraw=TRUE)
This method is called to draw a command bar's separator.
virtual CSize | DrawCommandBarGripper (CDC *pDC, CXTPCommandBar *pBar, BOOL bDraw=TRUE)
This method is called to draw the command bar's gripper.
virtual void | DrawRectangle (CDC *pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition)
This method is called to fill the control's face.
virtual void | DrawRectangle (CDC *pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition, int nID)
This method is called to fill the control's face.
virtual BOOL | DrawRectangle (CDC *pDC, CXTPControl *pButton)
This method is called to fill the control's face.
virtual CSize | DrawSpecialControl (CDC *pDC, XTPSpecialControl controlType, CXTPControl *pButton, CXTPCommandBar *pBar, BOOL bDraw, LPVOID lpParam)
This method is called to draw the specified controls.
virtual CRect | GetCommandBarBorders (CXTPCommandBar *pBar)
This method is called to retrieve the command bar's borders.
virtual CSize | DrawTearOffGripper (CDC *pDC, CRect rcGripper, BOOL bSelected, BOOL bDraw)
This method is called to draw the tear-off gripper of a pop-up bar.
virtual CSize | DrawDialogBarGripper (CDC *pDC, CXTPDialogBar *pBar, BOOL bDraw)
Call this member to draw the gripper of a dialog bar.
void | CreateGradientCircle ()
Generates an expanded bitmap used for CXTPPopupBar.
virtual BOOL | HasFloatingBarGradientEntry (CXTPCommandBar *pBar)
Returns TRUE if a floating toolbar is drawn with a gradient background.
- Protected Member Functions inherited from CXTPCommandBarsOfficeXPTheme
virtual CSize | DrawControlPopupParent (CDC *pDC, CXTPControl *pButton, BOOL bDraw)
This method is called to draw the control placed on the pop-up bar.
virtual void | DrawImage (CDC *pDC, CPoint pt, CSize sz, CXTPImageManagerIcon *pImage, BOOL bSelected, BOOL bPressed, BOOL bEnabled=TRUE, BOOL bChecked=FALSE, BOOL bPopuped=FALSE, BOOL bToolBarImage=TRUE)
This method is called to draw the image of the control.
virtual CSize | DrawControlComboBox (CDC *pDC, CXTPControlComboBox *pComboBox, BOOL bDraw)
This method is called to draw the control.
virtual CSize | DrawControlEdit (CDC *pDC, CXTPControlEdit *pEdit, BOOL bDraw)
This method is called to draw the control.
void | FillIntersectRect (CDC *pDC, CXTPPopupBar *pPopupBar, COLORREF clr)
Draws intersect rectangle of a pop-up bar and its control.
virtual void | DrawSplitButtonFrame (CDC *pDC, CXTPControl *pButton, CRect rc)
This method is called to draw the frame for the SplitButton control.
virtual CSize | DrawControlCheckBoxMark (CDC *pDC, CRect rc, BOOL bDraw, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled)
This method is called to draw a check box mark area.
virtual CSize | DrawControlCheckBoxMark (CDC *pDC, CXTPControl *pButton, CRect rc, BOOL bDraw)
This method is called to draw a check box mark area.
virtual CSize | DrawControlRadioButtonMark (CDC *pDC, CRect rc, BOOL bDraw, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled)
This method is called to draw a radio button mark area.
- Protected Member Functions inherited from CXTPPaintManager
CXTPPaintManager ()
Constructs a CXTPPaintManager object.
virtual | ~CXTPPaintManager ()
Destroys a CXTPPaintManager object, handles cleanup and deallocation.
- Protected Member Functions inherited from CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents >
CXTPObservable ()
Constructs an observable object.
~CXTPObservable ()
Handles observable object destruction.

Protected Attributes

int | m_nRibbonCaptionHeight
Ribbon caption height.
- Protected Attributes inherited from CXTPPaintManager
CXTPFont | m_xtpFontRegular
Regular font.
CXTPFont | m_xtpFontRegularBold
Regular bold font.
CXTPFont | m_xtpFontVert
Vertical font.
CXTPFont | m_xtpFontVertBold
Vertical font.
int | m_nEditHeight
Edit text height.
int | m_nFontHeight
Custom font height (optional).
BOOL | m_bUseStandardFont
TRUE to use system font.
BOOL | m_bEmbossedDisabledText
TRUE to draw disabled text embossed.
CXTPWinThemeWrapper * | m_themeStatusBar
StatusBar theme helper.
CXTPWinThemeWrapper * | m_themeButton
Buttons theme helper.
XTPPaintTheme | m_themeCurrent
Current theme.
XTP_COMMANDBARS_ICONSINFO | m_iconsInfo
Specific icons options.
int | m_nAnimationSteps
Steps of the animation.
int | m_nAnimationTime
Time of the animation.
BOOL | m_bShowKeyboardCues
TRUE to show keyboard cues - deprecated.
CXTPPaintManagerColor | m_arrColor [XPCOLOR_LAST+1]
Self colors array.
XTPCurrentSystemTheme | m_systemTheme
Current system theme.
CXTPShadowManager * | m_pShadowManager
Shadow manager.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCommandBarsOffice2003Theme
static HBITMAP AFX_CDECL | GetModernBitmap (UINT nIDResource)
Loads bitmap specified by nIDResource and converts its colors.
static BOOL AFX_CDECL | LoadModernToolbarIcons (UINT nIDResource)
Loads bitmap specified by nIDResource and adds it to ImageManager.
static BOOL AFX_CDECL | LoadModernToolbarIcons (UINT nIDResource, UINT *pCommands, int nCount, CSize szIcon=CSize(16, 15))
Loads bitmap specified by nIDResource and adds it to ImageManager.
- Static Public Member Functions inherited from CXTPPaintManager
static CXTPPaintManager *AFX_CDECL | GetInstanceAddRef ()
Obtains a pointer to a global paint manager object and increments its reference counter.
static void AFX_CDECL | ReleaseInstance ()
Decrements global paint manager's reference counter and deletes its instance when the reference counter reaches 0.
static CXTPPaintManager *AFX_CDECL | CreateTheme (XTPPaintTheme paintTheme)
Creates a new CXTPPaintManager object.
static void AFX_CDECL | SetTheme (XTPPaintTheme paintTheme)
Call this member to switch the visual theme of the Command Bars.
static void AFX_CDECL | SetCustomTheme (CXTPPaintManager *pTheme)
Call this member to set a custom theme.
static void AFX_CDECL | Triangle (CDC *pDC, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clr)
Draws a triangle.
static BOOL AFX_CDECL | FontExists (LPCTSTR lpszFaceName)
Determines if a specified font exists in the system.
static void AFX_CDECL | StripMnemonics (CString &strClear)
This member function will search a string, strip off the mnemonic '&', and reformat the string.
static CXTPPaintManager *AFX_CDECL | GetGlobalPaintManager ()
Call this method to get the pointer to the global paint manager.
static void AFX_CDECL | SetGlobalPaintManager (CXTPPaintManager *pPaintManager)
Call this method to set the pointer to the global paint manager.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPCommandBarsOffice2003Theme
CXTPPaintManagerColorGradient | m_clrDockBar
Color of dockbar face.
CXTPPaintManagerColorGradient | m_clrCommandBar
Color of commandbar face.
CXTPPaintManagerColorGradient | m_clrToolbarExpand
Toolbar Expand button color.
CXTPPaintManagerColorGradient | m_clrMenuExpand
MenuBar Expand button color.
CXTPPaintManagerColorGradient | m_clrMenuExpandedGripper
Color of pop-up bar gripper.
CXTPPaintManagerColorGradient | m_clrMenuGripper
Color of the pop-up menu gripper.
CXTPPaintManagerColorGradient | m_clrPopupControl
color of pop-up control
CXTPPaintManagerColor | m_clrToolbarShadow
Toolbar bottom shadow color.
CXTPPaintManagerColor | m_clrTearOffGripper
TearOff gripper color.
BOOL | m_bLunaTheme
TRUE if luna theme is active.
BOOL | m_bPlainSeparators
TRUE to draw plain separators.
CImageList | m_ilGradientCircle
Gradient circle holder.
CXTPPaintManagerColorGradient | m_grcLunaChecked
Background color of checked button.
CXTPPaintManagerColorGradient | m_grcLunaPushed
Background color of pushed button.
CXTPPaintManagerColorGradient | m_grcLunaSelected
Background color of selected button.
- Public Attributes inherited from CXTPPaintManager
COLORREF | m_clrMessageBarText
Message bar text color.
CRect | m_rcMessageBarMargin
Margin of the message bar.
CXTPFramePaintManager * | m_pFramePaintManager
Frame paint manager.
CXTPStatusBarPaintManager * | m_pStatusBarPaintManager
Paint manager of the status bar.
CXTPRibbonPaintManager * | m_pRibbonPaintManager
Ribbon paint Manager.
CXTPControlGalleryPaintManager * | m_pGalleryPaintManager
Gallery paint manager.
CXTPProgressPaintManager * | m_pProgressPaintManager
Progress bar paint manager.
CXTPSliderPaintManager * | m_pSliderPaintManager
Slider pane paint manager.
CXTPScrollBarPaintManager * | m_pScrollBarPaintManager
Scrollbar paint manager.
CXTPPaintManagerColorGradient | m_clrDisabledIcon
Disabled icons color.
CXTPPaintManagerColor | m_clrFloatingGripper
Gripper color of floating toolbar.
CXTPPaintManagerColor | m_clrFloatingGripperText
Gripper text color of floating toolbar.
BOOL | m_bThickCheckMark
TRUE to draw thick check mark.
BOOL | m_bShowShadow
TRUE to show shadow.
BOOL | m_bThemedStatusBar
TRUE to draw status bar using WinXP theme.
BOOL | m_bThemedCheckBox
TRUE to draw check box using WinXP theme.
BOOL | m_bClearTypeTextQuality
TRUE to enable ClearType text for the font.
BOOL | m_bFlatToolBar
TRUE to draw toolbars flat.
BOOL | m_bFlatMenuBar
TRUE to draw menubar flat.
int | m_nPopupBarTextPadding
Distance between gripper and control text.
BOOL | m_bSelectImageInPopupBar
TRUE to select image as in explorer theme.
BOOL | m_bEnableAnimation
TRUE to enable animation for all toolbars.
BOOL | m_bOffice2007Padding
TRUE if Office2007 metrics used.
BOOL | m_bOffsetPopupLabelText
TRUE if labels in pop-ups drawn with offset.
BOOL | m_bWrapCaptionBelowText
Wrap text for xtpButtonIconAndCaptionBelow buttons.
CXTPPaintManagerFont | m_fontSmCaption
Small caption font.
CXTPPaintManagerFont | m_fontIcon
Icon font.
CXTPPaintManagerFont | m_fontIconBold
Icon bold font.
CXTPPaintManagerFont | m_fontToolTip
Tooltip font.
int | m_nSplitButtonDropDownWidth
Split button drop down width in toolbars.
int | m_nSplitButtonDropDownHeight
Split button drop down height in toolbars.
int | m_nSplitButtonPopupWidth
Split button drop down width in pop-ups.
BOOL | m_bAutoResizeIcons
TRUE to automatically resize icons using current DPI.
int | m_nStatusBarMinHeight
Minimum height for the status bar.
PVOID | m_pfnSetLayeredWindowAttributes
point to Transparency proc in USER32.dll module.
CRect | m_rcStatusBarBorder
Bounding rectangle of the status bar border.
BOOL | m_bUseOfficeFont
TRUE to use Tahoma font.
CString | m_strOfficeFont
Office font.
int | m_nTextHeight
Regular text field height (not font height).

Detailed Description

The CXTPResourceTheme class is used to enable a resource style theme for Command Bars.

See also
CXTPPaintManager::SetTheme

Member Function Documentation

◆ BaseTheme()

virtual XTPPaintTheme BaseTheme ( )
inlineprotectedvirtual

Retrieves the base theme of the manager.

Returns
Returns the base theme.

Reimplemented from CXTPCommandBarsOffice2003Theme.

Reimplemented in CXTPRibbonTheme.

◆ FillWorkspace()

virtual void FillWorkspace | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | CRect | rcExclude )
 virtual

Draws workspace space.

Parameters
pDC | Pointer to device context.
rc | Bounding rectangle.
rcExclude | Excluded rectangle.

Reimplemented from CXTPPaintManager.

◆ GetFramePaintManager()

virtual CXTPFramePaintManager * GetFramePaintManager ( )
virtual

Returns the paint manager used to draw frames.

Returns
Paint manager used to draw frames.

Reimplemented from CXTPPaintManager.

◆ GetImages()

CXTPResourceImages * GetImages ( ) const

This method is called to get the CXTPResourceImages pointer.

Returns
Pointer to the image collection of the class.

◆ GetRectangleTextColor()

virtual COLORREF GetRectangleTextColor | ( | BOOL | bSelected,
 |  | BOOL | bPressed,
 |  | BOOL | bEnabled,
 |  | BOOL | bChecked,
 |  | BOOL | bPopuped,
 |  | XTPBarType | barType,
 |  | XTPBarPosition | barPosition )
 virtual

This method retrieves a button's text color.

Parameters
bSelected | TRUE if the control is selected.
bPressed | TRUE if the control is pushed.
bChecked | TRUE if the control is checked.
bEnabled | TRUE if the control is enabled.
bPopuped | TRUE if the control is pop-up'ed.
barType | Parent's bar type.
barPosition | Parent's bar position.
Returns
Button's text color.

Reimplemented from CXTPCommandBarsOfficeXPTheme.

Reimplemented in CXTPRibbonTheme.

◆ GetRibbonPaintManager()

virtual CXTPRibbonPaintManager * GetRibbonPaintManager ( )
virtual

Retrieves the ribbon paint manager.

Returns
A pointer to a CXTPRibbonPaintManager object.

Reimplemented from CXTPPaintManager.

◆ IsImagesAvailable()

BOOL IsImagesAvailable ( )
protected

Determines if images are available.

Returns
TRUE if images exist in the application, FALSE otherwise.

◆ LoadImage()

CXTPResourceImage * LoadImage ( LPCTSTR lpszFileName )

Loads a bitmap image from the specified path.

Parameters
lpszFileName The name of the file that contains the bitmaps to load.

The images are the bitmaps that represent all the visual components of the Ribbon Bar. For example tab buttons, group buttons, menu buttons, toolbar buttons, option button, toolbar dropdown, etc. The images are loaded using LoadImage and are stored in the m_pImages image collection. Images for the Office 2007 theme can be found in the /Source/Ribbon/Res folder.

Returns
New CXTPResourceImage containing the loaded bitmap.
See also
SetImageHandle, m_pImages

◆ RequiresResourceImages()

AFX_INLINE BOOL RequiresResourceImages ( )
virtual

Used by the paint manager to determine if the theme requires a resource DLL to load image and color information.

Returns
Returns TRUE if the theme requires a resource DLL, otherwise FALSE.

Reimplemented from CXTPPaintManager.

◆ SetImageHandle()

void SetImageHandle | ( | HMODULE | hResource,
 |  | LPCTSTR | lpszIniFileName )
 virtual

Specifies the resource that contains the bitmaps to be loaded for the theme.

This allows images to be loaded from something other than bitmap files.

Parameters
hResource | Handle to a visual style dll file handle. Or some other resource that contains the images to load for the theme.
lpszIniFileName | String identifier of ini file with color specifications.

The images are the bitmaps that represent all the visual components of the Ribbon Bar. For example tab buttons, group buttons, menu buttons, toolbar buttons, option button, toolbar dropdown, etc. The images are loaded using LoadImage and are stored in the m_pImages image collection. Images for the Office 2007 theme can be found in the /Source/Ribbon/Res folder.

Example:

((CXTPResourceTheme*)XTPPaintManager())->SetImageHandle(XTPSkinManager()->GetResourceFile()->GetModuleHandle());
See also
LoadImage, m_pImages

Reimplemented from CXTPPaintManager.

◆ SetImages()

void SetImages ( CXTPResourceImages * pImages )

Call this method to set images for the theme.

Parameters
pImages new CXTPResourceImages to be set.
See also
GetImages
The documentation for this class was generated from the following file:
  • XTPCommandBarsResourceTheme.h


Toolkit Pro: CXTPRibbonBackstageView Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPRibbonBackstageView Class Reference

CXTPRibbonBackstageView is a CDialog derived class used for a Backstage parent frame. More...

Inheritance diagram for CXTPRibbonBackstageView:
[legend]

Public Member Functions

CXTPRibbonBackstageTab * | GetActiveTab () const
Retrieves the currently active tab.
void | SetActiveTab (CXTPRibbonBackstageTab *pTab)
Sets the active tab.
CXTPControl * | GetFocusedControl () const
Retrieves the currently focused control.
void | SetFocusedControl (CXTPControl *pFocusedControl)
Sets the focused control.
CXTPControl * | GetHighlightedControl () const
Retrieves the currently highlighted control.
BOOL | IsCommand (CXTPControl *pControl) const
Determines if a specified control is a backstage command.
BOOL | IsMenuSeparator (CXTPControl *pControl) const
Determines if a specified control is a backstage separator.
BOOL | IsActiveTab (CXTPControl *pControl) const
Determines if a specified control is the active tab of the backstage view.
BOOL | IsFocusedControl (CXTPControl *pControl) const
Determines if a specified contral is the control with the focus input.
BOOL | IsHighlightedControl (CXTPControl *pControl) const
Determines if the mouse is hovering over a specified control.
CXTPImageManager * | GetImageManager () const
Retrieves Image manager associated with the backstage.
CXTPControl * | HitTest (CPoint point) const
This member function determines which control, if any, is at a specified point.
int | IndexOf (CXTPControl *pControl) const
Retrieves the index of a specified control from the array of controls in backstage view.
void | OnExecute (CXTPControl *pControl)
Executes the action defined by a specified control.
CWnd * | GetActiveControlPane () const
Retrieves a pointer to the pane window of the currently active tab.
int | GetMenuWidth () const
Retrieves the width of the menu bar of the backstage view.
void | SetTheme (XTPPaintTheme theme)
Sets the theme of the backstage view.
void | SetBackstageStyle (XTPRibbonBackstageStyle style=xtpRibbonBackstageOffice2016Style)
Sets the style of the backstage view.
XTPRibbonBackstageStyle | GetBackstageStyle () const
Gets the style of the backstage view.
COLORREF | GetKeyboardTipsBackColor ()
Gets the color of the rectangle in which the keyboard tip symbol (or symbols) is (or are) drawn.
CFont * | GetKeyboardTipsFont ()
Gets the font for drawing keyboard tips.
BOOL | ProcessKeyboardInput (UINT keyMessage, BOOL altPressed, UINT key, int repeat)
Defines what should be done for the current keyboard input depending on the current state of the keyboard tips engine.
BOOL | IsDpiIconsScalingEnabled () const
Determines if DPI scaling is enabled for icons.
virtual CScrollBar * | GetScrollBarCtrl (int nBar)
Overrides the CWnd::GetScrollBarCtrl virtual method.
virtual CScrollBar * | GetScrollBarCtrl (int nBar) const
Overrides the CWnd::GetScrollBarCtrl virtual method.
- Public Member Functions inherited from CXTPCommandBar
int | IsTrackingMode () const
Call this member to get the tracking state.
CXTPControls * | GetControls () const
Call this member to get the controls collection.
void | SetControls (CXTPControls *pControls)
Call this member to set the controls collection of the command bar.
XTPBarType | GetType () const
Call this member to get the type of the command bar.
void | SetTextOrientation (XTPBarTextOrientation nTextOrientation)
Call this member to change text orientation.
XTPBarTextOrientation | GetTextOrientation () const
Call this member to get the text orientation.
XTPBarPosition | GetPosition () const
Call this member to get the position of the command bar.
void | DelayLayout ()
Call this member to recalculate the layout.
virtual void | DelayRedraw ()
Call this member to redraw the command bar.
virtual BOOL | LoadMenu (CMenu *pMenu, BOOL bRemoveControls=TRUE)
Call this member to convert menu items to command bar controls.
CXTPControl * | GetControl (int nIndex) const
Call this member to return the control at the specified index.
int | GetControlCount () const
Call this member to get the count of the controls.
virtual BOOL | SetSelected (int nSelected, BOOL bKeyboard=FALSE)
Call this member to select the specified control.
CXTPControl * | GetSelected () const
Call this member to get the currently selected control.
BOOL | SetPopuped (int nPopuped, BOOL bKeyboard=FALSE)
Call this member to pop-up the specified control.
void | SetTitle (LPCTSTR lpszTitle)
Call this member to set a title for this command bar.
CString | GetTitle () const
Call this member to get a title for this command bar.
CXTPCommandBars * | GetCommandBars () const
Call this member to get the command bar's object.
void | SetCommandBars (CXTPCommandBars *pCommandBars)
Call this member to set the command bar's object.
CWnd * | GetSite () const
Call this member to get the command bar's site.
CFrameWnd * | GetFrameSite () const
Call this member to get the command bar's site as CFrameWnd.
void | SetFlags (DWORD dwFlagsAdd, DWORD dwFlagsRemove=0)
Call this member to set the command bar's flags.
BOOL | SetButtons (UINT *pButtons, int nCount)
Call this member to set the controls from the button array.
virtual BOOL | LoadToolBar (UINT nIDResource, BOOL bLoadIcons=TRUE)
Call this member function to load the toolbar specified by nIDResource.
void | SetIconSize (CSize size)
Call this function to set the size of the actual bitmapped images to be added to a toolbar.
virtual CSize | GetIconSize () const
Call this member function to get the size of the toolbar icon.
CSize | GetLargeIconSize (BOOL bAutoSize) const
Call this method to get the large icon size of the toolbar.
void | SetButtonSize (CSize size)
Sets the size of the buttons in the command bar.
virtual CSize | GetButtonSize () const
Call this function to get the size of the command bar button.
void | ShowTextBelowIcons (BOOL bTextBelow=TRUE)
Call this member to show the caption below control's icon.
BOOL | IsTextBelowIcons () const
Checks whether the caption is below the control's icon.
HWND | GetTrackFocus () const
Call this method to retrieve the current focused control.
void | SetTrackFocus (HWND hwnd)
Call this method to set focus to the window.
virtual void | SetVisible (BOOL bVisible)
Call this method to set the visibility state of the control.
virtual BOOL | IsVisible () const
Returns a Boolean value indicating if the command bar is visible.
virtual BOOL | SetPosition (XTPBarPosition barPosition)
Call this member function to set the position of the command bar.
int | FindAccel (TCHAR chAccel) const
Call this method to get the index of the control with the specified accelerator character.
int | FindAccelEx (UINT chAccel, BOOL &bSelectOnly) const
Call this method to get the index of the control with the specified accelerator character.
BOOL | IsCustomizeMode () const
Call this method to check if the command bars are in customize mode.
virtual DROPEFFECT | OnCustomizeDragEnter (CXTPControl *pDataObject, CPoint point)
This member is called when a control is entered into the command bar.
virtual void | OnCustomizeDragLeave ()
This method is called when a control leaves the command bar.
virtual DROPEFFECT | OnCustomizeDragOver (CXTPControl *pDataObject, CPoint point)
This member is called when control is over the command bar.
virtual void | OnCustomizeDrop (CXTPControl *pDataObject, DROPEFFECT &dropEffect, CPoint ptDrop, CPoint ptDrag)
This method is called when a control is dropped to the command bar.
virtual BOOL | IsCustomizable () const
Call this method to check if the command bar is customizable.
BOOL | IsCustomizeDialogPresent () const
Call this method to check if the command bar is present in Customize dialog.
void | EnableCustomization (BOOL bEnable=TRUE)
Call this method to enable/disable customization of the command bar.
virtual void | OnRecalcLayout ()
This method is called to recalculate the command bar layout.
virtual void | OnTrackLost ()
Call this method to remove the tracking state of the command bar.
virtual void | OnTrackEnter ()
Call this method to track the command bar.
CWnd * | GetOwnerSite () const
Call this method to retrieve the owner window of the command bar.
void | InvalidateParents ()
Call this method to redraw all parent command bars.
DWORD | GetFlags () const
Call this method to retrieve the current behavior modification flags of the command bar.
UINT | GetBarID () const
Call this method to retrieve the identifier of the command bar.
void | SetBarID (UINT nID)
Call this method to set the identifier of the command bar.
virtual void | OnControlSelected (BOOL bSelected, CXTPControl *pControl)
This method is called when a child control becomes selected.
BOOL | SetStatusText (const CString &strDescription)
This method is called to set the description context.
void | SetCommandBarData (DWORD_PTR dwData)
This method sets the 32-bit value associated with the command bar.
DWORD_PTR | GetCommandBarData () const
This method retrieves the application-supplied, 32-bit value associated with the command bar.
virtual CXTPCommandBar * | GetParentCommandBar () const
This method retrieves the parent command bar.
CXTPCommandBar * | GetRootParent () const
Call this method to retrieve the top-level parent command bar.
CXTPPaintManager * | GetPaintManager () const
Call this method to retrieve the paint manager.
CXTPImageManager * | GetImageManager () const
Call this method to retrieve the image manager.
void | SetWidth (int nWidth)
Call this member to set the width of the floated or pop-up toolbar.
int | GetWidth () const
Call this member to get the width of the floated or pop-up toolbar.
void | SetPaintManager (CXTPPaintManager *pPaintManager)
Call this member to set the specified paint manager.
void | SetImageManager (CXTPImageManager *pImageManager)
Call this member to set the specified image manager.
BOOL | IsLayoutRTL () const
Call this member function to determine if the command bar layout is Right-to-Left (RTL).
virtual BOOL | IsDialogBar () const
Call this member function to determine if the command bar is a CXTPDialogBar.
virtual BOOL | IsRibbonBar () const
Call this member function to determine if the command bar is a CXTPRibbonBar.
virtual BOOL | IsMenuTitleBar () const
Call this member function to determine if the command bar is a CXTPMenuTitleBar.
virtual BOOL | IsPopupBar () const
Call this member function to determine if the command bar is a CXTPPopupBar.
virtual void | DoPropExchange (CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
virtual BOOL | IsKeyboardCuesVisible () const
Determines if underlines are visible in the command bar control.
void | SetGrabFocus (BOOL bGrabFocus)
This method is called internally to prevent the command bar from grabbing edit focus.
virtual void | Redraw (LPCRECT lpRect=0, BOOL bAnimate=TRUE)
The framework calls this member function to redraw the command bar.
virtual void | DrawCommandBar (CDC *pDC, CRect rcClipBox)
This method is called to draw the command bar in the given context.
void | EnableAnimation (BOOL bEnable=TRUE)
Call this method to enable animation for the command bar.
void | EnableDoubleBuffer (BOOL bEnable=TRUE)
Call this method to enable double buffer for toolbar drawing.
BOOL | IsAnimationEnabled () const
Determines if animation is enabled for the specified command bar.
virtual void | EnsureVisible (CXTPControl *pControl)
Call this method to ensure that a specified control is visible on the toolbar.
XTPButtonStyle | GetDefaultButtonStyle () const
Call this method to retrieve the default button style of the command bar.
void | SetDefaultButtonStyle (XTPButtonStyle buttonStyle)
Call this method to set the default button style of the command bar.
void | LockRedraw ()
Call this method to freeze redrawing until UnlockRedraw is called.
void | UnlockRedraw ()
Call this method to unfreeze redrawing.
void | SetShowGripper (BOOL bShow)
Call this method to set the visibility of the command bar's gripper.
BOOL | GetShowGripper () const
Call this method to check if the command bar's gripper is visible.
virtual CRect | GetBorders ()
This method is called to get the border margins of the command bar.
virtual void | FillCommandBarEntry (CDC *pDC)
This method is called to draw the background of the command bar.
virtual BOOL | IsResizable () const
Specifies whether the pop-up gallery can be resized by the user.
BOOL | IsKeyboardTipsVisible () const
Call this method to check if keyboard tips are visible for the command bar.
virtual void | CreateKeyboardTips ()
This method is called to create a keyboard tips collection for the command bar.
void | OnKeyboardTipChar (UINT chAccel)
This method is called when the user presses a key while keyboard tips are visible.
virtual void | OnKeyboardTip (CXTPCommandBarKeyboardTip *pTip)
This method is called when a keyboard tip is found for the command bar.
void | HideKeyboardTips ()
Call this method to hide keyboard tips.
void | LockMouseMove (CXTPControl *pControl)
Locks the mouse cursor for a specified control.
void | UnlockMouseMove ()
Unlocks the mouse cursor.
- Public Member Functions inherited from CXTPHookManagerHookAble
CXTPHookManagerHookAble ()
Constructs a CXTPHookManagerHookAble object.
virtual | ~CXTPHookManagerHookAble ()
Destroys a CXTPHookManagerHookAble object, handles cleanup and deallocation.
virtual int | OnPostHookMessage (HWND hWnd, UINT nMessage, WPARAM &wParam, LPARAM &lParam, LRESULT &lResult)
This member function is called after a message has been processed by default window procedure.
virtual void | OnHookAttached (HWND hWnd)
This member function is called right after a hook is attached to the window.
virtual void | OnHookDetached ()
This member function is called right before a hook is to be detached from the window.

Protected Member Functions

BOOL | Popup (CXTPControlPopup *pControlPopup, BOOL bSelectFirst=FALSE)
This method is called to pop-up the command bar.
virtual BOOL | SetTrackingMode (int bMode, BOOL bSelectFirst=TRUE, BOOL bKeyboard=FALSE)
Call this member to change the tracking state.
void | CheckKeyboardTips ()
Guarantees that keyboard tips are set for all menu items in the backstage.
void | CheckTabsKeyboardTips ()
Guarantees that keyboard tips are set for all buttons in all tab panes in the backstage view.
XTPRibbonBackstageKeyboardTipResult | TranslateKeyboardTip (UINT key, int &nControlIndex)
This method determines which control in the backstage corresponds to the pressed keyboard key (according to the keyboard key) and which action corresponds to both this key and the current SHOW KEYBOARD TIPS level.
virtual int | OnHookMessage (HWND hWnd, UINT nMessage, WPARAM &wParam, LPARAM &lParam, LRESULT &lResult)
This member function is called by WindowProc, or is called during message reflection.
void | UpdateScrollInfo ()
Updates scrollbar information.
void | SetScrollPos (int nScrollPos)
Sets the position of the vertical scrollbar.
- Protected Member Functions inherited from CXTPCommandBar
CXTPCommandBar ()
Constructs a CXTPCommandBar object.
virtual | ~CXTPCommandBar ()
Destroys a CXTPCommandBar object, handles cleanup and deallocation.
virtual BOOL | OnHookKeyDown (UINT nChar, LPARAM lParam)
The framework calls this member function when a non-system key is pressed.
virtual CSize | CalcDynamicLayout (int nLength, DWORD dwMode)
This method is called to get the size of the command bar.
virtual BOOL | ProcessSpecialKey (XTPSpecialKey key)
This method is called to process special keys.
virtual void | OnControlsChanged ()
This method is called when the controls array is changed.
virtual void | Copy (CXTPCommandBar *pCommandBar, BOOL bRecursive=FALSE)
This method makes a copy of the command bar.
virtual int | OnMouseHitTest (CPoint pt)
This method is called to determine mouse hit code.
virtual void | UpdateShortcuts ()
Updates the control's shortcuts.
UINT | GetActiveDocTemplate () const
Retrieves the active MDI document template.
virtual void | GenerateCommandBarList (DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam)
This method is called to assign self identifiers for the serialization process.
virtual void | RestoreCommandBarList (CXTPCommandBarList *pCommandBarList)
This method is called in the serialization process to restore pop-ups from a list of command bars.
BOOL | IsHelpMode () const
Determines if the parent frame is in help mode.
virtual void | OnRemoved ()
This method is called when a toolbar is removed from the command bars collection.

Protected Attributes

XTPRibbonBackstageKeyboardTipLevel | m_nKeyboardTipsLevel
See XTPRibbonBackstageKeyboardTipLevel definition.
TCHAR | m_chSecondLevelCurrentChar
It is used when keyboard tips with 2 letters are shown (m_nKeyboardTipsLevel == xtpSecondLevel).
- Protected Attributes inherited from CXTPCommandBar
BOOL | m_bGrabFocus
TRUE to grab current focus.
int | m_nMRUWidth
Recent width.
int | m_nSelected
Selected control index.
int | m_nPopuped
Pop-up'ed control index.
HWND | m_hwndFocus
The handle of the window that currently has focus.
UINT | m_nBarID
Command bar's identifier.
BOOL | m_bTracking
TRUE if the command bar is in tracking mode.
CWnd * | m_pSite
Command bar's site.
DWORD | m_nIdleFlags
Idle flags.
DWORD | m_dwFlags
Command bar's flags.
DWORD | m_dwStyle
Command bar's styles.
CString | m_strTitle
Command bar's caption.
XTPBarType | m_barType
Type of the command bar.
CXTPControls * | m_pControls
A pointer to controls collection.
XTPBarPosition | m_barPosition
Position of the command bar.
CXTPCommandBars * | m_pCommandBars
parent command bars class.
CWnd * | m_pOwner
Owner window.
CSize | m_szIcons
Size of the command bar's icons.
CSize | m_szButtons
Size of the command bar's buttons.
BOOL | m_bTextBelow
TRUE if text is shown below the CommandBar buttons.
BOOL | m_bExecOnRButton
TRUE if the control button is executed on a right-click.
BOOL | m_bIgnoreUpdateHandler
TRUE to skip update handler for all child controls.
BOOL | m_bRecursePopup
TRUE if pop-up bar was opened recursively.
BOOL | m_bKeyboardSelect
TRUE if last item was selected by keyboard.
BOOL | m_bCloseable
TRUE if the CommandBar can be closed and-or Hidden.
BOOL | m_bCustomizable
TRUE if command bar is customizable.
CRect | m_rcMarker
Marker position.
BOOL | m_bVerticalMarker
TRUE to draw marker vertically.
DWORD_PTR | m_dwData
The 32-bit value associated with the command bar.
UINT * | m_pReturnCmd
Return command holder.
BOOL | m_bCustomizeDialogPresent
TRUE if the command bar is present in Customize dialog.
BOOL | m_bAnimatePopup
TRUE to animate pop-up bar.
BOOL | m_nLockRedraw
TRUE if all drawing routines skipped.
CXTPPaintManager * | m_pPaintManager
Selected paint manager for command bar.
CXTPImageManager * | m_pImageManager
Selected image manager for command bar.
BOOL | m_bMultiLine
True if multi line commandbar.
XTPButtonStyle | m_buttonStyle
Default button Style.
XTPBarTextOrientation | m_nTextOrientation
Commandbar text orientation.
CXTPToolTipContext * | m_pToolTipContext
Tool tip Context.
CXTPCommandBarAnimation * | m_pAnimation
Animation context.
CSize | m_szButtonSpacing
Spacing used between toolbar buttons.

Additional Inherited Members

- Public Attributes inherited from CXTPCommandBar
int | m_nStateFlags
State of the command bars.
BOOL | m_bComboBar
TRUE if it is combobox list.
BOOL | m_bTrackOnHover
TRUE to select item if mouse stay over control.
- Public Attributes inherited from CXTPHookManagerHookAble
BOOL | m_bAutoDestroy
TRUE to automatically delete hook.
- Static Public Attributes inherited from CXTPCommandBar
static int | s_nHoverDelay
Hover delay time.
static int | s_nExpandDelay
Expand delay time.
static int | s_nExpandHoverDelay
Expand hover delay.

Detailed Description

CXTPRibbonBackstageView is a CDialog derived class used for a Backstage parent frame.

Member Function Documentation

◆ CheckKeyboardTips()

void CheckKeyboardTips ( )
protected

Guarantees that keyboard tips are set for all menu items in the backstage.

It also checks that keyboard tips do not conflict with each other.

◆ GetActiveControlPane()

CWnd * GetActiveControlPane ( ) const

Retrieves a pointer to the pane window of the currently active tab.

Returns
A pointer to the pane window of the currently active tab.

◆ GetActiveTab()

CXTPRibbonBackstageTab * GetActiveTab ( ) const

Retrieves the currently active tab.

Returns
The currently active tab.

◆ GetBackstageStyle()

AFX_INLINE XTPRibbonBackstageStyle GetBackstageStyle ( ) const

Gets the style of the backstage view.

Returns
The style of the backstage view; one of the values defined by the XTPRibbonBackstageStyle enumeration.
See also
XTPRibbonBackstageStyle

◆ GetFocusedControl()

CXTPControl * GetFocusedControl ( ) const

Retrieves the currently focused control.

Returns
The currently focused control.

◆ GetHighlightedControl()

CXTPControl * GetHighlightedControl ( ) const

Retrieves the currently highlighted control.

Returns
The currently highlighted control.

◆ GetImageManager()

AFX_INLINE CXTPImageManager * GetImageManager ( ) const

Retrieves Image manager associated with the backstage.

Returns
Pointer to the image manager object that stores the images used in the backstage.

◆ GetKeyboardTipsBackColor()

COLORREF GetKeyboardTipsBackColor ( )

Gets the color of the rectangle in which the keyboard tip symbol (or symbols) is (or are) drawn.

Returns
The color of the rectangle in which the keyboard tip symbol (or symbols) is (or are) drawn.

◆ GetKeyboardTipsFont()

CFont * GetKeyboardTipsFont ( )

Gets the font for drawing keyboard tips.

Returns
The font for drawing keyboard tips.

◆ GetMenuWidth()

AFX_INLINE int GetMenuWidth ( ) const

Retrieves the width of the menu bar of the backstage view.

Returns
The width of the menu bar of the backstage view.

◆ GetScrollBarCtrl() [1/2]

virtual CScrollBar * GetScrollBarCtrl ( int nBar )
virtual

Overrides the CWnd::GetScrollBarCtrl virtual method.

Parameters
nBar Specifies the type of scroll bar.
Returns
Requested scroll bar object pointer or NULL.

◆ GetScrollBarCtrl() [2/2]

virtual CScrollBar * GetScrollBarCtrl ( int nBar ) const
virtual

Overrides the CWnd::GetScrollBarCtrl virtual method.

Parameters
nBar Specifies the type of scroll bar.
Returns
Requested scroll bar object pointer or NULL.

◆ HitTest()

CXTPControl * HitTest ( CPoint point ) const

This member function determines which control, if any, is at a specified point.

Parameters
point Point to be tested.
Returns
A pointer to the control at the position specified by 'point', otherwise NULL.

◆ IndexOf()

int IndexOf ( CXTPControl * pControl ) const

Retrieves the index of a specified control from the array of controls in backstage view.

Parameters
pControl Control whose index must be retrieved.
Returns
The index of the specified control if successful, otherwise -1.

◆ IsActiveTab()

BOOL IsActiveTab ( CXTPControl * pControl ) const

Determines if a specified control is the active tab of the backstage view.

Parameters
pControl Control to check.
Returns
TRUE if the specified control is the active tab of the backstage view.

◆ IsCommand()

BOOL IsCommand ( CXTPControl * pControl ) const

Determines if a specified control is a backstage command.

Parameters
pControl Control to check.
Returns
TRUE if the specified control is a backstage command.

◆ IsDpiIconsScalingEnabled()

BOOL IsDpiIconsScalingEnabled ( ) const

Determines if DPI scaling is enabled for icons.

Returns
TRUE is enabled, FALSE otherwise.

◆ IsFocusedControl()

BOOL IsFocusedControl ( CXTPControl * pControl ) const

Determines if a specified contral is the control with the focus input.

Parameters
pControl Control to check.
Returns
TRUE if the specified control is the control with the focus input.

◆ IsHighlightedControl()

BOOL IsHighlightedControl ( CXTPControl * pControl ) const

Determines if the mouse is hovering over a specified control.

Parameters
pControl Control to check.
Returns
TRUE if the mouse if hovering over the specified control.

◆ IsMenuSeparator()

BOOL IsMenuSeparator ( CXTPControl * pControl ) const

Determines if a specified control is a backstage separator.

Parameters
pControl Control to check.
Returns
TRUE if the specified control is a backstage separator.

◆ OnExecute()

void OnExecute ( CXTPControl * pControl )

Executes the action defined by a specified control.

Parameters
pControl Pointer to a CXTPControl object.

◆ OnHookMessage()

virtual int OnHookMessage | ( | HWND | hWnd,
 |  | UINT | nMessage,
 |  | WPARAM & | wParam,
 |  | LPARAM & | lParam,
 |  | LRESULT & | lResult )
 protectedvirtual

This member function is called by WindowProc, or is called during message reflection.

Parameters
hWnd | Window handle message belongs to.
nMessage | Specifies the message to be sent.
wParam | Specifies additional message-dependent information.
lParam | Specifies additional message-dependent information.
lResult | The return value of WindowProc. Depends on the message; may be NULL.
Returns
A non-zero value if a hooked message is processed, 0 otherwise.

Reimplemented from CXTPCommandBar.

◆ Popup()

BOOL Popup | ( | CXTPControlPopup * | pControlPopup,
 |  | BOOL | bSelectFirst = FALSE )
 protectedvirtual

This method is called to pop-up the command bar.

Parameters
pControlPopup | Points to a CXTPControlPopup object.
bSelectFirst | TRUE to select the first item.
Returns
TRUE if successful, otherwise FALSE.

Reimplemented from CXTPCommandBar.

◆ ProcessKeyboardInput()

BOOL ProcessKeyboardInput | ( | UINT | keyMessage,
 |  | BOOL | altPressed,
 |  | UINT | key,
 |  | int | repeat )

Defines what should be done for the current keyboard input depending on the current state of the keyboard tips engine.

Parameters
keyMessage | Code of the Windows keyboard message.
altPressed | TRUE if the Alt key was pressed.
key | Virtual code of the pressed key.
repeat | Count of repeated key presses.
Returns
TRUE if the keyboard input does not require further processing. It defines whether keyboard tip engine should be activated and what should be done for pressed keys.

◆ SetActiveTab()

void SetActiveTab ( CXTPRibbonBackstageTab * pTab )

Sets the active tab.

Parameters
pTab New tab to be set.

◆ SetBackstageStyle()

void SetBackstageStyle ( XTPRibbonBackstageStyle style = xtpRibbonBackstageOffice2016Style )

Sets the style of the backstage view.

Parameters
style New style to be set; must be one of the values defined by the XTPRibbonBackstageStyle enumeration.
See also
XTPRibbonBackstageStyle

◆ SetFocusedControl()

void SetFocusedControl ( CXTPControl * pFocusedControl )

Sets the focused control.

Parameters
pFocusedControl New control to be set.

◆ SetScrollPos()

void SetScrollPos ( int nScrollPos )
protected

Sets the position of the vertical scrollbar.

Parameters
nScrollPos New scrollbar position to be set.

◆ SetTheme()

void SetTheme ( XTPPaintTheme theme )

Sets the theme of the backstage view.

Parameters
theme New theme to be set.

◆ SetTrackingMode()

virtual BOOL SetTrackingMode | ( | int | bMode,
 |  | BOOL | bSelectFirst = TRUE,
 |  | BOOL | bKeyboard = FALSE )
 protectedvirtual

Call this member to change the tracking state.

Parameters
bMode | TRUE to set the tracking mode; otherwise FALSE.
bSelectFirst | TRUE to select the first item.
bKeyboard | TRUE if the item is popped by the keyboard.
Returns
TRUE if the method was successful, otherwise FALSE.
See also
IsTrackingMode.

Reimplemented from CXTPCommandBar.

◆ TranslateKeyboardTip()

XTPRibbonBackstageKeyboardTipResult TranslateKeyboardTip | ( | UINT | key,
 |  | int & | nControlIndex )
 protected

This method determines which control in the backstage corresponds to the pressed keyboard key (according to the keyboard key) and which action corresponds to both this key and the current SHOW KEYBOARD TIPS level.

Parameters
key | Virtual code of the pressed key.
nControlIndex | Receives the index of the control corresponding to the pressed key in the array of controls in the backstage.
Returns
An XTPRibbonBackstageKeyboardTipResult enumeration value defining the action that corresponds to both the pressed key and the current SHOW KEYBOARD TIPS level.
See also
XTPRibbonBackstageKeyboardTipResult, XTPRibbonBackstageKeyboardTipLevel

Member Data Documentation

◆ m_chSecondLevelCurrentChar

TCHAR m_chSecondLevelCurrentChar
protected

It is used when keyboard tips with 2 letters are shown (m_nKeyboardTipsLevel == xtpSecondLevel).

It defines the first character in such tips.

The documentation for this class was generated from the following file:
  • XTPRibbonBackstageView.h


Toolkit Pro: CXTPRibbonBar Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPRibbonBar Class Reference

CXTPRibbonBar is a CXTPMenuBar derived class. More...

Inheritance diagram for CXTPRibbonBar:
[legend]

Public Member Functions

CXTPRibbonBar ()
Constructs a CXTPRibbonBar object.
virtual | ~CXTPRibbonBar ()
Destroys a CXTPRibbonBar object, handles cleanup and deallocation.
CXTPRibbonTab * | AddTab (LPCTSTR lpszCaption)
Call this method to add a new tab to the ribbon bar.
CXTPRibbonTab * | AddTab (int nID)
Call this method to add a new tab to the ribbon bar.
CXTPRibbonTab * | InsertTab (int nItem, int nID)
Call this method to insert a new tab to the ribbon bar at a specified position.
CXTPRibbonTab * | InsertTab (int nItem, LPCTSTR lpszCaption, int nID=0)
Call this method to insert a new tab to the ribbon bar at a specified position.
CXTPRibbonTab * | InsertTab (int nItem, CXTPRibbonTab *pTab)
Call this method to insert a new tab to the ribbon bar at a specified position.
CXTPRibbonTab * | GetSelectedTab () const
Call this method to get the currently selected tab.
CXTPRibbonTab * | GetTab (int nIndex) const
Call this method to retrieve the tab at a specified position.
CXTPRibbonTab * | FindTab (int nId) const
Call this method to find a tab with a specified identifier.
CXTPRibbonGroup * | FindGroup (int nId) const
Call this method to find a group with a specified identifier.
int | GetTabCount () const
Retrieves the number of tabs in the ribbon bar.
CXTPRibbonPaintManager * | GetRibbonPaintManager () const
Retrieves the ribbon paint manager.
void | SetCurSel (int nIndex)
Call this method to set the currently selected tab.
CSize | GetButtonSize () const
Call this function to get the size of the command bar button.
int | GetCurSel () const
Call this method to get the index of the currently selected tab.
CXTPTabPaintManager * | GetTabPaintManager () const
Call this member to get a pointer to the tab paint manager.
CXTPRibbonGroup * | GetHighlightedGroup () const
Call this method to get the highlighted group.
BOOL | IsActive () const
Determines if the Ribbon state is active/inactive.
BOOL | IsGroupsVisible () const
Determines if the groups part of the ribbon bar is visible.
BOOL | IsTabsVisible () const
Determines if the tabs part of the ribbon bar is visible.
BOOL | IsRibbonBarVisible () const
Determines if the ribbon bar is visible.
virtual void | SetVisible (BOOL bVisible)
Call this member function to show/hide the ribbon.
void | SetGroupsVisible (BOOL bVisible)
Call this method to show/hide the groups part of the ribbon bar.
void | SetTabsVisible (BOOL bVisible)
Call this method to show/hide the tabs part of the ribbon bar.
CXTPRibbonControlTab * | GetControlTab () const
Call this method to get the CXTPRibbonControlTab object that represents ribbon tabs.
void | SetMinimumVisibleWidth (int nMinVisibleWidth)
Call this method to set the minimum width/height before the ribbon bar disappears.
void | SetMinimumVisibleSize (int nMinVisibleWidth, int nMinVisibleHeight)
Call this method to set the minimum width/height before the ribbon bar disappears.
int | GetMinimumVisibleWidth () const
Call this method to get the minimum width before the ribbon bar disappears.
CXTPRibbonQuickAccessControls * | GetQuickAccessControls () const
Retrieves the collection of Quick Access controls.
CXTPControlPopup * | AddSystemButton (int nID=0)
Call this method to add the Ribbon top-left system button.
CXTPRibbonControlSystemButton * | GetSystemButton () const
Call this method to get the Ribbon top-left system button.
virtual BOOL | IsRibbonBar () const
Call this member function to determine if the command bar is a CXTPRibbonBar.
void | RemoveAllTabs ()
Call this member to remove all tabs.
void | RemoveTab (int nIndex)
Call this member to remove a single tab.
virtual void | EnsureVisible (CXTPControl *pControl)
Call this method to make sure that a control is visible on the ribbon bar.
void | EnableFrameTheme (BOOL bEnable=TRUE)
Call this method to enable/disable Office 2007 frame.
BOOL | IsFrameThemeEnabled () const
Determines if Office 2007 frame is enabled/disabled.
void | ShowQuickAccessBelowRibbon (BOOL bBelow=TRUE)
Call this method to show Quick Access controls below/above the ribbon bar.
BOOL | IsQuickAccessBelowRibbon () const
Determines if Quick Access controls are shown below/above the ribbon bar.
void | ShowQuickAccess (BOOL bShow=TRUE)
Call this method to show/hide Quick Access.
BOOL | IsQuickAccessVisible () const
Determines if Quick Access is visible.
void | AllowQuickAccessDuplicates (BOOL bAllow)
Call this method to allow for duplicate controls for Quick Access.
void | AllowQuickAccessCustomization (BOOL bAllow)
Call this method to allow for customization of Quick Access.
BOOL | IsAllowQuickAccessDuplicates () const
Determines if duplicate controls are allowed for Quick Access.
void | SelectNextTab (BOOL bNext)
Call this method to select the next/previous tab.
virtual void | SetRibbonMinimized (BOOL bMinimized)
Call this method to minimize the ribbon bar.
BOOL | IsRibbonMinimized () const
Determines if the ribon bar is minimized.
void | AllowMinimize (BOOL bAllow)
Call this method to allow/disallow the minimize feature of the ribbon bar.
void | RebuildControls (CXTPRibbonTab *pSelected)
When switching tabs, RebuildControls first deletes all of the controls from the old tab groups.
CRect | GetTabControlRect () const
Gets the bounding rectangle of the ribbon tabs.
CRect | GetCaptionRect () const
Gets the bounding rectangle of the ribbon caption.
CRect | GetCaptionTextRect () const
Gets the bounding rectangle of the ribbon caption text.
CRect | GetQuickAccessRect () const
Gets the bounding rectangle of the ribbon Quick Access controls.
CXTPRibbonGroup * | HitTestGroup (CPoint point) const
This member function determines which ribbon group, if any, is at a specified position.
virtual int | GetTabsHeight () const
Gets the tabs area height.
int | GetQuickAccessHeight () const
Gets the Quick Access area height.
int | CalcQuickAccessHeight ()
Calculates the Quick Access area height.
virtual int | GetGroupsHeight ()
Gets the group area height.
virtual int | CalcClientHeight ()
Gets the group client area height.
CRect | GetGroupsRect () const
Gets the ribbon groups bounding rectangle.
virtual int | CalcGroupsHeight ()
Calculates the ribbon groups height using the GetLargeIconSize method and the height of the captions.
void | SetGroupsHeight (int nHeight)
Sets the height of the ribbon groups.
int | GetCaptionHeight () const
Gets the caption height of the ribbon bar, in pixels.
CXTPRibbonTabContextHeaders * | GetContextHeaders () const
Retrieves the collection of context headers.
BOOL | IsQuickAccessControl (CXTPControl *pControl) const
Determines if a control belongs to Quick Access controls.
virtual BOOL | IsAllowQuickAccessControl (CXTPControl *pControl)
Determines if a control can be added to Quick Access controls.
virtual void | DrawCommandBar (CDC *pDC, CRect rcClipBox)
This method is called to draw the command bar in the given context.
CXTPCommandBarsFrameHook * | GetFrameHook () const
Retrieves the CXTPCommandBarsFrameHook object used to skin the frame.
BOOL | IsDwmEnabled () const
Determines if Vista Glass effect is enabled for the ribbon bar.
void | SetFontHeight (int nFontHeight)
Sets the font height for the ribbon bar.
int | GetFontHeight () const
Gets the font height of the ribbon bar.
BOOL | IsCaptionVisible () const
Determines if the caption part of the ribbon is visible.
void | ShowCaptionAlways (BOOL bShowCaption)
Call this method to show/hide the caption if the frame theme is not enabled.
BOOL | GetShowCaptionAlways () const
Determines if the caption is shown/hidden if the frame theme is not enabled.
virtual CSize | GetIconSize () const
Call this member function to get the size of the toolbar icon.
CXTPControl * | GetControlQuickAccess () const
Call this method to get a pointer to the Quick Access button.
BOOL | IsKeyboardCuesVisible () const
Call this method to determine if keyboard cues are visible.
void | Reset (BOOL bShowWarningMessage)
Resets the ribbon/Quick Access toolbar.
BOOL | IsBackstageViewVisible () const
Determines if backstage view is visible.
void | SetQuickAccessEmptyIconId (int nIconId)
Call this method to set the icon ID that will be used if the user adds a new control to Quick Access without an icon.
BOOL | PassKeyboardInputToBackstageView (UINT message, WPARAM wParam, LPARAM lParam)
Call this method to allow the backstage view to process keyboard input if it is active.
- Public Member Functions inherited from CXTPMenuBar
CXTPMenuBar ()
Constructs a CXTPMenuBar object.
~CXTPMenuBar ()
Destroys a CXTPMenuBar object, handles cleanup and deallocation.
virtual BOOL | LoadMenuBar (UINT nIDResource)
Loads a menu from the resource.
void | FreeMDIMenus ()
Destroy all MDI menus.
void | RefreshMenu ()
This member function will refresh the menus.
UINT | GetCurrentMenuResource () const
Call this method to retrieve the identifier of the currently visible menu.
UINT | GetDefaultMenuResource () const
Call this method to retrieve the identifier of the default menu.
CXTPMenuBarMDIMenus * | GetMDIMenus () const
Retrieves the collection of application MDI menus.
virtual void | SwitchMDIMenu (UINT nIDMenu, CMenu *pMenu=NULL)
This method is called to switch to an MDI menu from the MDI menus collection.
CXTPMenuBarMDIMenuInfo * | AddMDIMenu (UINT nIDResource)
Call this method to manually load an MDI menu in application initialization.
void | SwitchActiveMenu ()
Call this method to switch the menu to the active document menu.
- Public Member Functions inherited from CXTPToolBar
CXTPToolBar ()
Constructs a CXTPToolBar object.
~CXTPToolBar ()
Destroys a CXTPToolBar object, handles cleanup and deallocation.
virtual BOOL | IsVisible () const
Call this member to check the visibility of the toolbar.
BOOL | SetPosition (XTPBarPosition barPosition)
Call this member to set the position of the toolbar.
BOOL | LoadToolBar (UINT nIDResource, BOOL bLoadIcons=TRUE)
Call this member function to load the toolbar specified by nIDResource.
BOOL | CreateToolBar (DWORD dwStyle, CWnd *pParentWnd, UINT nID=AFX_IDW_TOOLBAR)
This method creates the ToolBar control.
void | GetBarInfo (CToolBarInfo *pInfo)
Retrieves bar information for serialization routines.
void | SetBarInfo (CToolBarInfo *pInfo)
Sets bar information.
virtual CSize | CalcDockingLayout (int nLength, DWORD dwMode, int nWidth=0)
This method calculates the dimensions of a toolbar.
virtual CSize | CalcDynamicLayout (int nLength, DWORD dwMode)
This method calculates the dimensions of a toolbar.
void | EnableDocking (DWORD dwFlags=xtpFlagAlignAny|xtpFlagFloating|xtpFlagHideWrap)
Call this method to set docking flags.
BOOL | IsBuiltIn () const
Determines if the toolbar is built-in.
CXTPDockBar * | GetDockBar () const
Retrieves the parent dock bar.
void | OnSetPreviewMode (BOOL bPreview)
Call this method to show/hide toolbars in preview mode.
BOOL | OnHookKeyDown (UINT nChar, LPARAM lParam)
The framework calls this member function when a non-system key is pressed.
void | SetContextMenuPresent (BOOL bPresent)
Call this method to show/hide the toolbar in a context menu.
BOOL | IsContextMenuPresent () const
Call this member to determine if this toolbar is included in the right-click context menu.
void | SetCustomizeDialogPresent (BOOL bPresent)
Call this method to show/hide the toolbar in a customize dialog.
BOOL | IsCustomizeDialogPresent () const
Call this member to determine if this toolbar is included in the customize dialog.
void | ModifyBarStyle (DWORD dwRemove, DWORD dwAdd)
Modifies the styles of the toolbar.
void | SetCloseable (BOOL bCloseable)
Call this method to enable/disable the closeable property of the command bar.
BOOL | IsCloseable () const
Call this method to retrieve the closeable property of the command bar.
BOOL | IsTemporary () const
Call this method to determine if the control is temporary.
void | SetTemporary (BOOL bTemporary)
Call this method to set the control to temporary.
void | ShowExpandButton (BOOL bShowExpandButton)
Call this method to show/hide the expand button of the toolbar.
void | OnRecalcLayout ()
This method recalculates the position of the toolbar.
BOOL | IsWindowVisible () const
Determines if the toolbar is visible on the screen.
- Public Member Functions inherited from CXTPCommandBar
int | IsTrackingMode () const
Call this member to get the tracking state.
CXTPControls * | GetControls () const
Call this member to get the controls collection.
void | SetControls (CXTPControls *pControls)
Call this member to set the controls collection of the command bar.
XTPBarType | GetType () const
Call this member to get the type of the command bar.
void | SetTextOrientation (XTPBarTextOrientation nTextOrientation)
Call this member to change text orientation.
XTPBarTextOrientation | GetTextOrientation () const
Call this member to get the text orientation.
XTPBarPosition | GetPosition () const
Call this member to get the position of the command bar.
void | DelayLayout ()
Call this member to recalculate the layout.
virtual void | DelayRedraw ()
Call this member to redraw the command bar.
virtual BOOL | SetTrackingMode (int bMode, BOOL bSelectFirst=TRUE, BOOL bKeyboard=FALSE)
Call this member to change the tracking state.
virtual BOOL | LoadMenu (CMenu *pMenu, BOOL bRemoveControls=TRUE)
Call this member to convert menu items to command bar controls.
CXTPControl * | GetControl (int nIndex) const
Call this member to return the control at the specified index.
int | GetControlCount () const
Call this member to get the count of the controls.
virtual BOOL | SetSelected (int nSelected, BOOL bKeyboard=FALSE)
Call this member to select the specified control.
CXTPControl * | GetSelected () const
Call this member to get the currently selected control.
BOOL | SetPopuped (int nPopuped, BOOL bKeyboard=FALSE)
Call this member to pop-up the specified control.
void | SetTitle (LPCTSTR lpszTitle)
Call this member to set a title for this command bar.
CString | GetTitle () const
Call this member to get a title for this command bar.
CXTPCommandBars * | GetCommandBars () const
Call this member to get the command bar's object.
void | SetCommandBars (CXTPCommandBars *pCommandBars)
Call this member to set the command bar's object.
CWnd * | GetSite () const
Call this member to get the command bar's site.
CFrameWnd * | GetFrameSite () const
Call this member to get the command bar's site as CFrameWnd.
void | SetFlags (DWORD dwFlagsAdd, DWORD dwFlagsRemove=0)
Call this member to set the command bar's flags.
BOOL | SetButtons (UINT *pButtons, int nCount)
Call this member to set the controls from the button array.
void | SetIconSize (CSize size)
Call this function to set the size of the actual bitmapped images to be added to a toolbar.
CSize | GetLargeIconSize (BOOL bAutoSize) const
Call this method to get the large icon size of the toolbar.
void | SetButtonSize (CSize size)
Sets the size of the buttons in the command bar.
void | ShowTextBelowIcons (BOOL bTextBelow=TRUE)
Call this member to show the caption below control's icon.
BOOL | IsTextBelowIcons () const
Checks whether the caption is below the control's icon.
virtual BOOL | Popup (CXTPControlPopup *pControlPopup, BOOL bSelectFirst=FALSE)
This method is called to pop-up the command bar.
HWND | GetTrackFocus () const
Call this method to retrieve the current focused control.
void | SetTrackFocus (HWND hwnd)
Call this method to set focus to the window.
int | FindAccel (TCHAR chAccel) const
Call this method to get the index of the control with the specified accelerator character.
int | FindAccelEx (UINT chAccel, BOOL &bSelectOnly) const
Call this method to get the index of the control with the specified accelerator character.
BOOL | IsCustomizeMode () const
Call this method to check if the command bars are in customize mode.
virtual DROPEFFECT | OnCustomizeDragEnter (CXTPControl *pDataObject, CPoint point)
This member is called when a control is entered into the command bar.
virtual void | OnCustomizeDragLeave ()
This method is called when a control leaves the command bar.
virtual DROPEFFECT | OnCustomizeDragOver (CXTPControl *pDataObject, CPoint point)
This member is called when control is over the command bar.
virtual void | OnCustomizeDrop (CXTPControl *pDataObject, DROPEFFECT &dropEffect, CPoint ptDrop, CPoint ptDrag)
This method is called when a control is dropped to the command bar.
virtual BOOL | IsCustomizable () const
Call this method to check if the command bar is customizable.
BOOL | IsCustomizeDialogPresent () const
Call this method to check if the command bar is present in Customize dialog.
void | EnableCustomization (BOOL bEnable=TRUE)
Call this method to enable/disable customization of the command bar.
virtual void | OnTrackLost ()
Call this method to remove the tracking state of the command bar.
virtual void | OnTrackEnter ()
Call this method to track the command bar.
CWnd * | GetOwnerSite () const
Call this method to retrieve the owner window of the command bar.
void | InvalidateParents ()
Call this method to redraw all parent command bars.
DWORD | GetFlags () const
Call this method to retrieve the current behavior modification flags of the command bar.
UINT | GetBarID () const
Call this method to retrieve the identifier of the command bar.
void | SetBarID (UINT nID)
Call this method to set the identifier of the command bar.
virtual void | OnControlSelected (BOOL bSelected, CXTPControl *pControl)
This method is called when a child control becomes selected.
BOOL | SetStatusText (const CString &strDescription)
This method is called to set the description context.
void | SetCommandBarData (DWORD_PTR dwData)
This method sets the 32-bit value associated with the command bar.
DWORD_PTR | GetCommandBarData () const
This method retrieves the application-supplied, 32-bit value associated with the command bar.
virtual CXTPCommandBar * | GetParentCommandBar () const
This method retrieves the parent command bar.
CXTPCommandBar * | GetRootParent () const
Call this method to retrieve the top-level parent command bar.
CXTPPaintManager * | GetPaintManager () const
Call this method to retrieve the paint manager.
CXTPImageManager * | GetImageManager () const
Call this method to retrieve the image manager.
void | SetWidth (int nWidth)
Call this member to set the width of the floated or pop-up toolbar.
int | GetWidth () const
Call this member to get the width of the floated or pop-up toolbar.
void | SetPaintManager (CXTPPaintManager *pPaintManager)
Call this member to set the specified paint manager.
void | SetImageManager (CXTPImageManager *pImageManager)
Call this member to set the specified image manager.
BOOL | IsLayoutRTL () const
Call this member function to determine if the command bar layout is Right-to-Left (RTL).
virtual BOOL | IsDialogBar () const
Call this member function to determine if the command bar is a CXTPDialogBar.
virtual BOOL | IsMenuTitleBar () const
Call this member function to determine if the command bar is a CXTPMenuTitleBar.
virtual BOOL | IsPopupBar () const
Call this member function to determine if the command bar is a CXTPPopupBar.
void | SetGrabFocus (BOOL bGrabFocus)
This method is called internally to prevent the command bar from grabbing edit focus.
virtual void | Redraw (LPCRECT lpRect=0, BOOL bAnimate=TRUE)
The framework calls this member function to redraw the command bar.
void | EnableAnimation (BOOL bEnable=TRUE)
Call this method to enable animation for the command bar.
void | EnableDoubleBuffer (BOOL bEnable=TRUE)
Call this method to enable double buffer for toolbar drawing.
BOOL | IsAnimationEnabled () const
Determines if animation is enabled for the specified command bar.
XTPButtonStyle | GetDefaultButtonStyle () const
Call this method to retrieve the default button style of the command bar.
void | SetDefaultButtonStyle (XTPButtonStyle buttonStyle)
Call this method to set the default button style of the command bar.
void | LockRedraw ()
Call this method to freeze redrawing until UnlockRedraw is called.
void | UnlockRedraw ()
Call this method to unfreeze redrawing.
void | SetShowGripper (BOOL bShow)
Call this method to set the visibility of the command bar's gripper.
BOOL | GetShowGripper () const
Call this method to check if the command bar's gripper is visible.
virtual void | FillCommandBarEntry (CDC *pDC)
This method is called to draw the background of the command bar.
virtual BOOL | IsResizable () const
Specifies whether the pop-up gallery can be resized by the user.
BOOL | IsKeyboardTipsVisible () const
Call this method to check if keyboard tips are visible for the command bar.
virtual void | CreateKeyboardTips ()
This method is called to create a keyboard tips collection for the command bar.
void | OnKeyboardTipChar (UINT chAccel)
This method is called when the user presses a key while keyboard tips are visible.
virtual void | OnKeyboardTip (CXTPCommandBarKeyboardTip *pTip)
This method is called when a keyboard tip is found for the command bar.
void | HideKeyboardTips ()
Call this method to hide keyboard tips.
void | LockMouseMove (CXTPControl *pControl)
Locks the mouse cursor for a specified control.
void | UnlockMouseMove ()
Unlocks the mouse cursor.
- Public Member Functions inherited from CXTPHookManagerHookAble
CXTPHookManagerHookAble ()
Constructs a CXTPHookManagerHookAble object.
virtual | ~CXTPHookManagerHookAble ()
Destroys a CXTPHookManagerHookAble object, handles cleanup and deallocation.
virtual int | OnPostHookMessage (HWND hWnd, UINT nMessage, WPARAM &wParam, LPARAM &lParam, LRESULT &lResult)
This member function is called after a message has been processed by default window procedure.
virtual void | OnHookAttached (HWND hWnd)
This member function is called right after a hook is attached to the window.
virtual void | OnHookDetached ()
This member function is called right before a hook is to be detached from the window.

Protected Member Functions

virtual BOOL | OnTabChanging (CXTPRibbonTab *pTab)
This virtual method is called when the current tab is about to be changed.
virtual void | OnTabChanged (CXTPRibbonTab *pTab)
This virtual method called when the current tab is changed.
virtual int | CalcGroupsHeight (int nClientHeight)
Calculates the ribbon groups height using the GetLargeIconSize method and the height of the captions.
virtual CXTPRibbonTabPopupToolBar * | CreateTabPopupToolBar (CXTPRibbonTab *pTab)
Creates a new pop-up toolbar object for a provided tab.
BOOL | IsControlEnabled (const CXTPControl *pControl) const
Determines whether a control is enabled.
- Protected Member Functions inherited from CXTPMenuBar
int | OnHookMessage (HWND hWnd, UINT nMessage, WPARAM &wParam, LPARAM &lParam, LRESULT &lResult)
This member function is called by WindowProc, or is called during message reflection.
void | DoPropExchange (CXTPPropExchange *pPX)
Either reads this object from or writes this object to an archive.
virtual void | Copy (CXTPCommandBar *pCommandBar, BOOL bRecursive=FALSE)
This method makes a copy of the command bar.
void | SetupHook ()
This method is called to create hooks for the main window.
void | SetupMenu ()
This method is called to create the menu for the main window.
HWND | GetActiveMdiChildWnd (BOOL *bMaximized=NULL)
Call this method to get the handle to the active MDI child window.
void | SyncActiveMdiChild ()
Call this method to update the active MDI window hooks.
virtual void | RefreshSysButtons ()
Call this method to update the system buttons of the menu bar.
void | SwitchMDIMenu (HMENU hMenu)
Call this method to switch the current MDI menu.
void | GenerateCommandBarList (DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam)
Call this method to assign self-identifiers for the serialization process.
void | RestoreCommandBarList (CXTPCommandBarList *pCommandBarList)
Call this method during the serialization process to restore pop-ups from a list of command bars.
BOOL | ShouldSerializeBar ()
Call this method to check if the toolbar has changed and must be saved.
- Protected Member Functions inherited from CXTPToolBar
virtual BOOL | Create (CWnd *pParentWnd, BOOL bFloat)
Creates a toolbar.
virtual CRect | GetBorders ()
This method retrieves the borders of the toolbar.
virtual void | OnPaintManagerChanged ()
This method is called when the paint manager is changed.
virtual void | MergeToolBar (CXTPCommandBar *pCommandBar, BOOL bSilent)
This method is called to restore a toolbar to a previous state.
virtual void | MergeToolBar (CXTPCommandBar *pCommandBar, BOOL bSilent, int nDefaultConfirmationChoice)
This method is called to restore a toolbar to a previous state.
- Protected Member Functions inherited from CXTPCommandBar
CXTPCommandBar ()
Constructs a CXTPCommandBar object.
virtual | ~CXTPCommandBar ()
Destroys a CXTPCommandBar object, handles cleanup and deallocation.
virtual BOOL | ProcessSpecialKey (XTPSpecialKey key)
This method is called to process special keys.
virtual void | OnControlsChanged ()
This method is called when the controls array is changed.
virtual int | OnMouseHitTest (CPoint pt)
This method is called to determine mouse hit code.
virtual void | UpdateShortcuts ()
Updates the control's shortcuts.
UINT | GetActiveDocTemplate () const
Retrieves the active MDI document template.
BOOL | IsHelpMode () const
Determines if the parent frame is in help mode.
virtual void | OnRemoved ()
This method is called when a toolbar is removed from the command bars collection.

Protected Attributes

CRect | m_rcTabControl
Bounding rectangle of tabs.
CRect | m_rcGroups
Groups bounding rectangle.
CRect | m_rcCaption
Caption bounding rectangle.
CRect | m_rcCaptionText
Caption text bounding rectangle.
CRect | m_rcHeader
Header bounding rectangle.
CRect | m_rcQuickAccess
Quick Access bounding rectangle.
BOOL | m_bRibbonBarVisible
TRUE if the ribbon bar is visible.
BOOL | m_bGroupsVisible
TRUE if groups is visible.
BOOL | m_bTabsVisible
TRUE if tabs are visible.
BOOL | m_bShowQuickAccessBelow
TRUE to show Quick Access controls below the ribbon bar.
BOOL | m_bShowQuickAccess
TRUE to show Quick Access.
BOOL | m_bAllowQuickAccessDuplicates
TRUE to allow Quick Access duplicates.
BOOL | m_bAllowQuickAccessCustomization
TRUE to allow Quick Access customization.
BOOL | m_bGroupReducedChanged
Some group appear in resize handler.
int | m_nQuickAccessHeight
Quick Access height.
BOOL | m_bAllowMinimize
TRUE to allow minimize ribbon.
CXTPRibbonQuickAccessControls * | m_pQuickAccessControls
Quick Access controls (not used now).
CXTPRibbonControlTab * | m_pControlTab
Control tab pointer.
CXTPControl * | m_pControlQuickAccess
Quick Access menu control.
CXTPControl * | m_pControlQuickAccessMore
Quick Access more control.
CXTPRibbonControlSystemButton * | m_pControlSystemButton
System button control.
BOOL | m_bMinimizeOnDblClick
TRUE to allow the ribbon to be minimized/maximized when double clicked.
int | m_nMinVisibleWidth
Minimum width before ribbon bar disappears.
int | m_nMinVisibleHeight
Minimum height before ribbon bar disappears.
CXTPRibbonTabContextHeaders * | m_pContextHeaders
Context header collection.
int | m_nCustomGroupsHeight
Custom groups height.
int | m_nCustomClientHeight
Custom client height.
BOOL | m_bMinimized
TRUE if the Ribbon is currently minimized.
BOOL | m_bShowCaptionAlways
TRUE to show caption even if EnableFrameTheme was not called.
CString | m_strCaptionText
Caption text.
BOOL | m_bIsCaptionBarInBackstageMode
Is backstage active.
int | m_nBackstageMenuWidth
The width of the panel with commands and tabs in the backstage.
int | m_nBackstageSysButtonTop
The top of the sysbutton on the backstage.
int | m_nBackstageSysButtonBottom
The buttom of the sysbutton on the backstage.
- Protected Attributes inherited from CXTPMenuBar
BOOL | m_bMdiApp
TRUE if parent frame is CMDIFrameWnd derived.
HWND | m_hWndActiveChild
Active MDI window handle.
HMENU | m_hMenuDefault
Default menu handle.
UINT | m_nIDResource
Resource of default menu.
UINT | m_nIDResourceCurrent
Currently active menu.
CXTPMenuBarMDIMenus * | m_pMDIMenus
MDI menus.
- Protected Attributes inherited from CXTPToolBar
CXTPDockBar * | m_pDockBar
Parent dock bar.
CXTPDockContext * | m_pDockContext
Docking context.
BOOL | m_bBuiltIn
TRUE if toolbar is built-in.
BOOL | m_bTearOff
TRUE if toolbar is tear-offed.
BOOL | m_bPreviewVisible
TRUE if Toolbar was visible in preview mode.
BOOL | m_bPreviewMode
TRUE if Toolbar was visible in preview mode.
BOOL | m_bTemporary
TRUE if Toolbar is temporary (If it will be saved when the CommandBar layout is saved.)
BOOL | m_bShowExpandButton
TRUE to show expand button of toolbar.
BOOL | m_bContextMenuPresent
TRUE if the command bar is present in context menu.
BOOL | m_bInRecalcLayout
TRUE if RecalcLayout method is called.
BOOL | m_bVisible
TRUE if the command bar is visible.
- Protected Attributes inherited from CXTPCommandBar
BOOL | m_bGrabFocus
TRUE to grab current focus.
int | m_nMRUWidth
Recent width.
int | m_nSelected
Selected control index.
int | m_nPopuped
Pop-up'ed control index.
HWND | m_hwndFocus
The handle of the window that currently has focus.
UINT | m_nBarID
Command bar's identifier.
BOOL | m_bTracking
TRUE if the command bar is in tracking mode.
CWnd * | m_pSite
Command bar's site.
DWORD | m_nIdleFlags
Idle flags.
DWORD | m_dwFlags
Command bar's flags.
DWORD | m_dwStyle
Command bar's styles.
CString | m_strTitle
Command bar's caption.
XTPBarType | m_barType
Type of the command bar.
CXTPControls * | m_pControls
A pointer to controls collection.
XTPBarPosition | m_barPosition
Position of the command bar.
CXTPCommandBars * | m_pCommandBars
parent command bars class.
CWnd * | m_pOwner
Owner window.
CSize | m_szIcons
Size of the command bar's icons.
CSize | m_szButtons
Size of the command bar's buttons.
BOOL | m_bTextBelow
TRUE if text is shown below the CommandBar buttons.
BOOL | m_bExecOnRButton
TRUE if the control button is executed on a right-click.
BOOL | m_bIgnoreUpdateHandler
TRUE to skip update handler for all child controls.
BOOL | m_bRecursePopup
TRUE if pop-up bar was opened recursively.
BOOL | m_bKeyboardSelect
TRUE if last item was selected by keyboard.
BOOL | m_bCloseable
TRUE if the CommandBar can be closed and-or Hidden.
BOOL | m_bCustomizable
TRUE if command bar is customizable.
CRect | m_rcMarker
Marker position.
BOOL | m_bVerticalMarker
TRUE to draw marker vertically.
DWORD_PTR | m_dwData
The 32-bit value associated with the command bar.
UINT * | m_pReturnCmd
Return command holder.
BOOL | m_bCustomizeDialogPresent
TRUE if the command bar is present in Customize dialog.
BOOL | m_bAnimatePopup
TRUE to animate pop-up bar.
BOOL | m_nLockRedraw
TRUE if all drawing routines skipped.
CXTPPaintManager * | m_pPaintManager
Selected paint manager for command bar.
CXTPImageManager * | m_pImageManager
Selected image manager for command bar.
BOOL | m_bMultiLine
True if multi line commandbar.
XTPButtonStyle | m_buttonStyle
Default button Style.
XTPBarTextOrientation | m_nTextOrientation
Commandbar text orientation.
CXTPToolTipContext * | m_pToolTipContext
Tool tip Context.
CXTPCommandBarAnimation * | m_pAnimation
Animation context.
CSize | m_szButtonSpacing
Spacing used between toolbar buttons.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPToolBar
static BOOL AFX_CDECL | DoUpdateCustomizeMenuControl (CXTPControl *pControl, CCmdTarget *pTarget)
Tries to update a Customize menu control.
- Public Attributes inherited from CXTPCommandBar
int | m_nStateFlags
State of the command bars.
BOOL | m_bComboBar
TRUE if it is combobox list.
BOOL | m_bTrackOnHover
TRUE to select item if mouse stay over control.
- Public Attributes inherited from CXTPHookManagerHookAble
BOOL | m_bAutoDestroy
TRUE to automatically delete hook.
- Static Public Attributes inherited from CXTPCommandBar
static int | s_nHoverDelay
Hover delay time.
static int | s_nExpandDelay
Expand delay time.
static int | s_nExpandHoverDelay
Expand hover delay.

Detailed Description

CXTPRibbonBar is a CXTPMenuBar derived class.

It represents a Ribbon control from Office 2007.

Example: The following code sample demonstrates how to create a CXTPRibbonBar:

CXTPRibbonBar* pRibbonBar = (CXTPRibbonBar*)pCommandBars->Add(_T("The Ribbon"), xtpBarTop,
RUNTIME_CLASS(CXTPRibbonBar));

Member Function Documentation

◆ AddSystemButton()

CXTPControlPopup * AddSystemButton ( int nID = 0 )

Call this method to add the Ribbon top-left system button.

Parameters
nID Identifier of the system button.
Returns
Adds the Ribbon top-left system button
See also
GetSystemButton

◆ AddTab() [1/2]

CXTPRibbonTab * AddTab ( int nID )

Call this method to add a new tab to the ribbon bar.

Parameters
nID Identifier of the tab to be added.
Returns
A pointer to a new CXTPRibbonTab object.
See also
InsertTab

◆ AddTab() [2/2]

CXTPRibbonTab * AddTab ( LPCTSTR lpszCaption )

Call this method to add a new tab to the ribbon bar.

Parameters
lpszCaption Caption of the tab to be added.
Returns
A pointer to a new CXTPRibbonTab object.
See also
InsertTab

◆ AllowMinimize()

AFX_INLINE void AllowMinimize ( BOOL bAllow )

Call this method to allow/disallow the minimize feature of the ribbon bar.

Parameters
bAllow TRUE to allow the minimize feature of the ribbon bar, FALSE to disallow.

◆ AllowQuickAccessCustomization()

AFX_INLINE void AllowQuickAccessCustomization ( BOOL bAllow )

Call this method to allow for customization of Quick Access.

Parameters
bAllow TRUE to allow for customization of Quick Access.
See also
IsAllowQuickAccessDuplicates, ShowQuickAccessBelowRibbon

◆ AllowQuickAccessDuplicates()

AFX_INLINE void AllowQuickAccessDuplicates ( BOOL bAllow )

Call this method to allow for duplicate controls for Quick Access.

Parameters
bAllow TRUE to allow for duplicate controls for Quick Access.
See also
IsAllowQuickAccessDuplicates, ShowQuickAccessBelowRibbon

◆ CalcClientHeight()

virtual int CalcClientHeight ( )
virtual

Gets the group client area height.

Returns
The group client area height.
See also
GetGroupsHeight, GetTabsHeight

◆ CalcGroupsHeight() [1/2]

virtual int CalcGroupsHeight ( )
virtual

Calculates the ribbon groups height using the GetLargeIconSize method and the height of the captions.

Returns
The ribbon groups height.
See also
GetGroupsHeight

◆ CalcGroupsHeight() [2/2]

virtual int CalcGroupsHeight ( int nClientHeight )
protectedvirtual

Calculates the ribbon groups height using the GetLargeIconSize method and the height of the captions.

Parameters
nClientHeight Client height for which the ribbon groups height is to be computed.
Returns
The ribbon groups height.
See also
GetGroupsHeight

◆ CalcQuickAccessHeight()

int CalcQuickAccessHeight ( )

Calculates the Quick Access area height.

Returns
The Quick Access area height.

◆ CreateTabPopupToolBar()

virtual CXTPRibbonTabPopupToolBar * CreateTabPopupToolBar ( CXTPRibbonTab * pTab )
protectedvirtual

Creates a new pop-up toolbar object for a provided tab.

Parameters
pTab Pointer to the tab for which a new pop-up toolbar must be created.
Returns
A pointer to the newly allocated pop-up toolbar object. The caller is responsible for releasing resources.

◆ DrawCommandBar()

virtual void DrawCommandBar | ( | CDC * | pDC,
 |  | CRect | rcClipBox )
 virtual

This method is called to draw the command bar in the given context.

Parameters
pDC | Pointer to a valid device context.
rcClipBox | The rectangular area of the control that is invalid.

Reimplemented from CXTPCommandBar.

◆ EnableFrameTheme()

void EnableFrameTheme ( BOOL bEnable = TRUE )

Call this method to enable/disable Office 2007 frame.

Parameters
bEnable TRUE to enable Office 2007 frame, FALSE to disable.
See also
IsFrameThemeEnabled

◆ EnsureVisible()

virtual void EnsureVisible ( CXTPControl * pControl )
virtual

Call this method to make sure that a control is visible on the ribbon bar.

Parameters
pControl Pointer to the CXTPControl child whose visibility must be checked.

Reimplemented from CXTPCommandBar.

◆ FindGroup()

CXTPRibbonGroup * FindGroup ( int nId ) const

Call this method to find a group with a specified identifier.

Parameters
nId Identifier of the group to be found.
Returns
A pointer to the CXTPRibbonGroup object with the specified identifier.
See also
FindTab

◆ FindTab()

CXTPRibbonTab * FindTab ( int nId ) const

Call this method to find a tab with a specified identifier.

Parameters
nId Identifier of the tab to be found.
Returns
A pointer to the CXTPRibbonTab object with the specified identifier.
See also
FindGroup

◆ GetButtonSize()

CSize GetButtonSize ( ) const
virtual

Call this function to get the size of the command bar button.

Returns
The width and height values of the command bar button.

Reimplemented from CXTPCommandBar.

◆ GetCaptionHeight()

int GetCaptionHeight ( ) const

Gets the caption height of the ribbon bar, in pixels.

Returns
The caption height of the ribbon bar, in pixels.
See also
CalcGroupsHeight

◆ GetCaptionRect()

AFX_INLINE CRect GetCaptionRect ( ) const

Gets the bounding rectangle of the ribbon caption.

Returns
A CRect object containing the bounding rectangle of the ribbon caption.
See also
GetCaptionTextRect, GetQuickAccessRect, GetTabControlRect

◆ GetCaptionTextRect()

AFX_INLINE CRect GetCaptionTextRect ( ) const

Gets the bounding rectangle of the ribbon caption text.

Returns
A CRect object containing the bounding rectangle of the ribbon caption text.
See also
GetCaptionRect, GetQuickAccessRect, GetTabControlRect

◆ GetContextHeaders()

AFX_INLINE CXTPRibbonTabContextHeaders * GetContextHeaders ( ) const

Retrieves the collection of context headers.

Returns
A pointer to the CXTPRinnobTabContextHeaders object that represents the collection of context headers.
See also
CXTPRibbonTabContextHeader

◆ GetControlQuickAccess()

AFX_INLINE CXTPControl * GetControlQuickAccess ( ) const

Call this method to get a pointer to the Quick Access button.

Returns
A pointer to the Quick Access button.

◆ GetControlTab()

AFX_INLINE CXTPRibbonControlTab * GetControlTab ( ) const

Call this method to get the CXTPRibbonControlTab object that represents ribbon tabs.

Returns
A pointer to the CXTPRibbonControlTab object that represents ribbon tabs.

◆ GetCurSel()

int GetCurSel ( ) const

Call this method to get the index of the currently selected tab.

Returns
The index of the currently selected tab.
See also
SetCurSel

◆ GetFontHeight()

int GetFontHeight ( ) const

Gets the font height of the ribbon bar.

Returns
The font height of the ribbon bar.

◆ GetFrameHook()

CXTPCommandBarsFrameHook * GetFrameHook ( ) const

Retrieves the CXTPCommandBarsFrameHook object used to skin the frame.

Returns
A pointer to the CXTPCommandBarsFrameHook object used to skin the frame.
See also
EnableFrameTheme

◆ GetGroupsHeight()

virtual int GetGroupsHeight ( )
virtual

Gets the group area height.

Returns
The group area height.
See also
GetTabsHeight

◆ GetGroupsRect()

AFX_INLINE CRect GetGroupsRect ( ) const

Gets the ribbon groups bounding rectangle.

Returns
A CRect object containing the groups bounding rectangle.

◆ GetHighlightedGroup()

AFX_INLINE CXTPRibbonGroup * GetHighlightedGroup ( ) const

Call this method to get the highlighted group.

Returns
A pointer to the CXTPRibbonGroup object under the mouse cursor.
See also
CXTPRibbonGroup

◆ GetIconSize()

virtual CSize GetIconSize ( ) const
virtual

Call this member function to get the size of the toolbar icon.

Returns
The size of the toolbar icon.
See also
GetLargeIconSize

Reimplemented from CXTPCommandBar.

◆ GetMinimumVisibleWidth()

AFX_INLINE int GetMinimumVisibleWidth ( ) const

Call this method to get the minimum width before the ribbon bar disappears.

Returns
The minimum width before the ribbon bar disappears.
See also
SetMinimumVisibleWidth

◆ GetQuickAccessControls()

AFX_INLINE CXTPRibbonQuickAccessControls * GetQuickAccessControls ( ) const

Retrieves the collection of Quick Access controls.

Returns
A pointer to the CXTPRibbonQuickAccessControls object that represents the collection of Quick Access controls.

◆ GetQuickAccessHeight()

int GetQuickAccessHeight ( ) const

Gets the Quick Access area height.

Returns
The Quick Access area height.
See also
GetGroupsHeight, GetTabsHeight

◆ GetQuickAccessRect()

AFX_INLINE CRect GetQuickAccessRect ( ) const

Gets the bounding rectangle of the ribbon Quick Access controls.

Returns
A CRect object containing the bounding rectangle of the ribbon Quick Access Controls.
See also
GetCaptionRect, GetCaptionTextRect, GetTabControlRect

◆ GetRibbonPaintManager()

CXTPRibbonPaintManager * GetRibbonPaintManager ( ) const

Retrieves the ribbon paint manager.

Returns
A pointer to a CXTPRibbonPaintManager object.
See also
AddTab

◆ GetSelectedTab()

CXTPRibbonTab * GetSelectedTab ( ) const

Call this method to get the currently selected tab.

Returns
A pointer to the currently selected CXTPRibbonTab object.
See also
SetCurSel

◆ GetShowCaptionAlways()

AFX_INLINE BOOL GetShowCaptionAlways ( ) const

Determines if the caption is shown/hidden if the frame theme is not enabled.

Returns
TRUE if the caption is shown if the frame theme is not enabled, FALSE if the caption is hidden if the frame theme is not enabled.

◆ GetSystemButton()

AFX_INLINE CXTPRibbonControlSystemButton * GetSystemButton ( ) const

Call this method to get the Ribbon top-left system button.

Returns
The Ribbon top-left system button.
See also
AddSystemButton

◆ GetTab()

CXTPRibbonTab * GetTab ( int nIndex ) const

Call this method to retrieve the tab at a specified position.

Parameters
nIndex Index of the tab to retrieve.
Returns
A pointer to the CXTPRibbonTab object at the specified position.
See also
GetTabCount

◆ GetTabControlRect()

AFX_INLINE CRect GetTabControlRect ( ) const

Gets the bounding rectangle of the ribbon tabs.

Returns
A CRect object containing the bounding rectangle of the ribbon tabs.
See also
CXTPRibbonThemeOffice2007Theme::FillRibbonBar

◆ GetTabCount()

int GetTabCount ( ) const

Retrieves the number of tabs in the ribbon bar.

Returns
The number of tabs in the ribbon bar.
See also
GetTab

◆ GetTabPaintManager()

CXTPTabPaintManager * GetTabPaintManager ( ) const

Call this member to get a pointer to the tab paint manager.

The tab paint manager is used to customize the appearance of CXTPTabManagerItem objects and the tab manager (i.e. tab colors, styles, etc.). This member must be overridden in derived classes.

Returns
A pointer to the CXTPTabPaintManager that contains the visual elements of the tabs.

◆ GetTabsHeight()

virtual int GetTabsHeight ( ) const
virtual

Gets the tabs area height.

Returns
The tabs area height.
See also
GetGroupsHeight

◆ HitTestGroup()

CXTPRibbonGroup * HitTestGroup ( CPoint point ) const

This member function determines which ribbon group, if any, is at a specified position.

Parameters
point Point to test.
Returns
A pointer to the CXTPRibbonGroup at the specified position, if any, otherwise NULL.

◆ InsertTab() [1/3]

CXTPRibbonTab * InsertTab | ( | int | nItem,
 |  | CXTPRibbonTab * | pTab )

Call this method to insert a new tab to the ribbon bar at a specified position.

Parameters
nItem | Position to insert the new tab.
pTab | Pointer to a CXTPRibbonTab object.
Returns
A pointer to a new CXTPRibbonTab object.
See also
AddTab

◆ InsertTab() [2/3]

CXTPRibbonTab * InsertTab | ( | int | nItem,
 |  | int | nID )

Call this method to insert a new tab to the ribbon bar at a specified position.

Parameters
nItem | Position to insert the new tab.
nID | Identifier of the tab to be added.
Returns
A pointer to a new CXTPRibbonTab object.
See also
AddTab

◆ InsertTab() [3/3]

CXTPRibbonTab * InsertTab | ( | int | nItem,
 |  | LPCTSTR | lpszCaption,
 |  | int | nID = 0 )

Call this method to insert a new tab to the ribbon bar at a specified position.

Parameters
nItem | Position to insert the new tab.
nID | Identifier of the tab to be added.
lpszCaption | Caption of the tab to be added.
Returns
A pointer to a new CXTPRibbonTab object.
See also
AddTab

◆ IsActive()

BOOL IsActive ( ) const

Determines if the Ribbon state is active/inactive.

Returns
TRUE if the Ribbon state is active, FALSE if the Ribbon state is inactive.

◆ IsAllowQuickAccessControl()

virtual BOOL IsAllowQuickAccessControl ( CXTPControl * pControl )
virtual

Determines if a control can be added to Quick Access controls.

Parameters
pControl Control to check.
Returns
TRUE if the control can be added to the Quick Access area.

◆ IsAllowQuickAccessDuplicates()

AFX_INLINE BOOL IsAllowQuickAccessDuplicates ( ) const

Determines if duplicate controls are allowed for Quick Access.

Returns
TRUE if duplicate controls are allowed for Quick Acess.
See also
AllowQuickAccessDuplicates

◆ IsBackstageViewVisible()

BOOL IsBackstageViewVisible ( ) const

Determines if backstage view is visible.

Returns
TRUE if backstage view is visible, otherwise FALSE.

◆ IsCaptionVisible()

BOOL IsCaptionVisible ( ) const

Determines if the caption part of the ribbon is visible.

Returns
TRUE if the caption part of the ribbon is visible.

◆ IsControlEnabled()

BOOL IsControlEnabled ( const CXTPControl * pControl ) const
protectedvirtual

Determines whether a control is enabled.

Parameters
pControl Pointer to the control to check.
Returns
TRUE if the control is enabled, otherwise FALSE.

Reimplemented from CXTPCommandBar.

◆ IsDwmEnabled()

BOOL IsDwmEnabled ( ) const

Determines if Vista Glass effect is enabled for the ribbon bar.

Returns
TRUE if Vista Glass effect is enabled for the ribbon bar.

◆ IsFrameThemeEnabled()

BOOL IsFrameThemeEnabled ( ) const

Determines if Office 2007 frame is enabled/disabled.

Returns
TRUE if enabled, FALSE if disabled.
See also
EnableFrameTheme

◆ IsGroupsVisible()

BOOL IsGroupsVisible ( ) const

Determines if the groups part of the ribbon bar is visible.

Returns
TRUE if the groups part of the ribbon bar is visible.
See also
SetGroupsVisible

◆ IsKeyboardCuesVisible()

BOOL IsKeyboardCuesVisible ( ) const
virtual

Call this method to determine if keyboard cues are visible.

Returns
TRUE if keyboard cues are visible, otherwise FALSE.

Reimplemented from CXTPCommandBar.

◆ IsQuickAccessBelowRibbon()

BOOL IsQuickAccessBelowRibbon ( ) const

Determines if Quick Access controls are shown below/above the ribbon bar.

Returns
TRUE if Quick Access controls are shown below the ribbon bar, FALSE if Quick Access controls are shown above the ribbon bar.
See also
ShowQuickAccessBelowRibbon

◆ IsQuickAccessControl()

BOOL IsQuickAccessControl ( CXTPControl * pControl ) const

Determines if a control belongs to Quick Access controls.

Parameters
pControl Control to check.
Returns
TRUE if the control is located in the Quick Access area.

◆ IsQuickAccessVisible()

AFX_INLINE BOOL IsQuickAccessVisible ( ) const

Determines if Quick Access is visible.

Returns
TRUE if Quick Access is visible, otherwise FALSE.
See also
ShowQuickAccess

◆ IsRibbonBar()

AFX_INLINE BOOL IsRibbonBar ( ) const
virtual

Call this member function to determine if the command bar is a CXTPRibbonBar.

Returns
TRUE if the command bar is a CXTPRibbonBar, otherwise FALSE.
See also
CXTPCommandBar, CXTPRibbonBar

Reimplemented from CXTPCommandBar.

◆ IsRibbonBarVisible()

AFX_INLINE BOOL IsRibbonBarVisible ( ) const

Determines if the ribbon bar is visible.

Returns
TRUE if the ribbon bar is visible.

◆ IsRibbonMinimized()

BOOL IsRibbonMinimized ( ) const

Determines if the ribon bar is minimized.

Returns
TRUE if the ribbon bar is minimized.

◆ IsTabsVisible()

BOOL IsTabsVisible ( ) const

Determines if the tabs part of the ribbon bar is visible.

Returns
TRUE if the tabs part of the ribbon bar is visible.
See also
SetTabsVisible

◆ OnTabChanged()

virtual void OnTabChanged ( CXTPRibbonTab * pTab )
protectedvirtual

This virtual method called when the current tab is changed.

Parameters
pTab New selected tab.

◆ OnTabChanging()

virtual BOOL OnTabChanging ( CXTPRibbonTab * pTab )
protectedvirtual

This virtual method is called when the current tab is about to be changed.

Parameters
pTab New tab to be selected.
Returns
TRUE to cancel tab changing, FALSE to allow.

◆ PassKeyboardInputToBackstageView()

BOOL PassKeyboardInputToBackstageView | ( | UINT | message,
 |  | WPARAM | wParam,
 |  | LPARAM | lParam )

Call this method to allow the backstage view to process keyboard input if it is active.

Parameters
message | Code of the Window message (like WM_KEYDOWN).
wParam | WPARAM of Window message.
lParam | LPARAM of Window message.
Returns
True to allow backstage view, False otherwise

◆ RebuildControls()

void RebuildControls ( CXTPRibbonTab * pSelected )

When switching tabs, RebuildControls first deletes all of the controls from the old tab groups.

Then controls are added to the tab groups of the tab to be selected. Finally, the new tab is selected.

Parameters
pSelected New tab to be selected.
See also
CXTPRibbonControlTab::SetSelectedItem, CXTPRibbonTab::GetGroups

◆ RemoveAllTabs()

void RemoveAllTabs ( )

Call this member to remove all tabs.

See also
RemoveTab

◆ RemoveTab()

void RemoveTab ( int nIndex )

Call this member to remove a single tab.

Parameters
nIndex Index of the tab to remove.
See also
RemoveTab

◆ Reset()

void Reset ( BOOL bShowWarningMessage )
virtual

Resets the ribbon/Quick Access toolbar.

Parameters
bShowWarningMessage TRUE to show a warning message box to the user.

Reimplemented from CXTPMenuBar.

◆ SelectNextTab()

void SelectNextTab ( BOOL bNext )

Call this method to select the next/previous tab.

Parameters
bNext TRUE to select next, FALSE to select previous.

◆ SetCurSel()

void SetCurSel ( int nIndex )

Call this method to set the currently selected tab.

Parameters
nIndex Index of the tab to be set.
See also
GetSelectedTab

◆ SetFontHeight()

void SetFontHeight ( int nFontHeight )

Sets the font height for the ribbon bar.

Parameters
nFontHeight New font height to set.

◆ SetGroupsHeight()

AFX_INLINE void SetGroupsHeight ( int nHeight )

Sets the height of the ribbon groups.

Parameters
nHeight New height to be set.
See also
GetTabsHeight

◆ SetGroupsVisible()

void SetGroupsVisible ( BOOL bVisible )

Call this method to show/hide the groups part of the ribbon bar.

Parameters
bVisible TRUE to show the groups part of the ribbon bar.
See also
IsGroupsVisible

◆ SetMinimumVisibleSize()

AFX_INLINE void SetMinimumVisibleSize | ( | int | nMinVisibleWidth,
 |  | int | nMinVisibleHeight )

Call this method to set the minimum width/height before the ribbon bar disappears.

Parameters
nMinVisibleWidth | New minimum width.
nMinVisibleHeight | New minimum height.

Default value is 250 pixels.

See also
GetMinimumVisibleWidth

◆ SetMinimumVisibleWidth()

AFX_INLINE void SetMinimumVisibleWidth ( int nMinVisibleWidth )

Call this method to set the minimum width/height before the ribbon bar disappears.

Parameters
nMinVisibleWidth New minimum width.

Default value is 250 pixels.

See also
GetMinimumVisibleWidth

◆ SetQuickAccessEmptyIconId()

AFX_INLINE void SetQuickAccessEmptyIconId ( int nIconId )

Call this method to set the icon ID that will be used if the user adds a new control to Quick Access without an icon.

Parameters
nIconId Icon to be associated with the new Quick Access control.

◆ SetRibbonMinimized()

virtual void SetRibbonMinimized ( BOOL bMinimized )
virtual

Call this method to minimize the ribbon bar.

Parameters
bMinimized TRUE to minimize the ribbon bar.

◆ SetTabsVisible()

void SetTabsVisible ( BOOL bVisible )

Call this method to show/hide the tabs part of the ribbon bar.

Parameters
bVisible TRUE to show the tabs part of the ribbon bar.
See also
IsTabsVisible

◆ SetVisible()

virtual void SetVisible ( BOOL bVisible )
virtual

Call this member function to show/hide the ribbon.

Parameters
bVisible TRUE to show the ribbon, FALSE to hide.

Reimplemented from CXTPToolBar.

◆ ShowCaptionAlways()

AFX_INLINE void ShowCaptionAlways ( BOOL bShowCaption )

Call this method to show/hide the caption if the frame theme is not enabled.

Parameters
bShowCaption TRUE to show the caption if the frame theme is not enabled, FALSE to hide the caption if the frame theme is not enabled.

◆ ShowQuickAccess()

AFX_INLINE void ShowQuickAccess ( BOOL bShow = TRUE )

Call this method to show/hide Quick Access.

Parameters
bShow TRUE to show Quick Access, FALSE to hide.
See also
IsQuickAccessVisible, ShowQuickAccessBelowRibbon

◆ ShowQuickAccessBelowRibbon()

void ShowQuickAccessBelowRibbon ( BOOL bBelow = TRUE )

Call this method to show Quick Access controls below/above the ribbon bar.

Parameters
bBelow TRUE to show Quick Access controls below the ribbon bar, FALSE to show Quick Access controls above the ribbon bar.
See also
IsQuickAccessBelowRibbon
The documentation for this class was generated from the following file:
  • XTPRibbonBar.h


Toolkit Pro: CXTPRibbonControls Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPRibbonControls Class Reference

CXTPRibbonControls is a CXTPControls derived class. More...

Inheritance diagram for CXTPRibbonControls:
[legend]

Public Member Functions

CXTPRibbonControls ()
Constructs a CXTPRibbonControls object.
- Public Member Functions inherited from CXTPControls
CXTPControls ()
Internal helper structure.
virtual | ~CXTPControls ()
Destroys a CXTPControls object, handles cleanup and deallocation.
CXTPControl * | GetAt (int nIndex) const
Call this member to return the control at the specified index.
int | CommandToIndex (int nIDFind) const
This member function returns the index of the first control, starting at position 0, whose command ID matches nIDFind.
CXTPControl * | Add (CXTPControl *pControl, int nId, LPCTSTR lpszParameter=NULL, int nBefore=-1, BOOL bTemporary=FALSE)
Call this member to add a new control.
CXTPControl * | Add (XTPControlType controlType, int nId, LPCTSTR lpszParameter=NULL, int nBefore=-1, BOOL bTemporary=FALSE)
Call this member to add a new control.
CXTPControl * | Add (CXTPControl *pControl)
Call this member to add a new control.
CXTPControl * | InsertAt (CXTPControl *pControl, int nBefore)
Call this member to insert a new control.
CXTPControl * | AddMenuItem (CMenu *pMenu, int nIndex)
Call this member to add a new control.
virtual void | Remove (CXTPControl *pControl)
Call this member to remove a control.
void | Remove (int nIndex)
Call this member to remove a control.
void | RemoveAll ()
Call this member to remove all controls.
int | GetCount () const
Call this member to get the count of the controls.
CXTPControl * | FindControl (int nId) const
Call this member to find the specified control.
CXTPControl * | FindControl (XTPControlType type, int nId, BOOL bVisible, BOOL bRecursive) const
Call this member to find the specified control.
BOOL | LoadMenu (CMenu *pMenu)
Call this member to convert menu items to command bar controls.
CXTPControl * | GetFirst () const
Call this member to retrieve the first control.
void | GetNext (CXTPControl *&pControl) const
Finds the next control in the given direction.
long | GetNext (long nIndex, int nDirection=+1, BOOL bKeyboard=TRUE, BOOL bSkipTemporary=FALSE, BOOL bSkipCollapsed=TRUE) const
Finds the next control in the given direction.
CXTPControl * | HitTest (CPoint point) const
This member function determines which control, if any, is at a specified point.
CXTPControl * | SetControlType (CXTPControl *pControl, XTPControlType type)
Call this member to change the type of the control.
CXTPControl * | SetControlType (int nIndex, XTPControlType type)
Call this member to change the type of the control.
CXTPControl * | AddClone (CXTPControl *pClone, int nBefore=-1, BOOL bRecursive=FALSE)
Call this member to add a copy of a control.
CSize | CalcDynamicSize (CDC *pDC, int nLength, DWORD dwMode, const CRect &rcBorder, int nWidth=0)
This method is called internally to reposition controls and determine their size.
CSize | CalcPopupSize (CDC *pDC, int nLength, int nWidth, const CRect &rcBorder)
This method is called internally to reposition controls and determine their size for a pop-up bar.
int | GetVisibleCount (BOOL bIgnoreWrap=FALSE) const
Call this member to get the number of visible controls.
CXTPControl * | GetVisibleAt (int nIndex, BOOL bIgnoreWraps=FALSE) const
Finds a specified control by its ID.
void | SetCommandBars (CXTPCommandBars *pCommandBars)
Call this member to attach the specified command bars object.
CXTPControls * | Duplicate (BOOL bRecursive=FALSE)
Makes a copy of all controls.
CXTPCommandBars * | GetCommandBars () const
Retrieves the parent command bars object.
void | MoveBefore (CXTPControl *pControl, int nBefore)
Moves the control to a specified position.
void | SetParent (CXTPCommandBar *pParent)
Attaches the parent command bar.
void | CreateOriginalControls ()
Creates the original controls set.
void | ClearOriginalControls ()
Removes the original controls set.
CXTPOriginalControls * | GetOriginalControls () const
Retrieves the original controls set.
void | SetOriginalControls (CXTPOriginalControls *pControls)
Call this method to assign original controls.
BOOL | Compare (const CXTPControls *pControls)
Call this member to compare the controls.
BOOL | IsChanged () const
Returns the changed status flag of the control.
virtual void | DoPropExchange (CXTPPropExchange *pPX)
Either reads this object from or writes this object to an archive.
CXTPCommandBar * | GetParent () const
Call this member to get the parent command bar.
BOOL | IsOriginalControls () const
Determines if all controls in the collection are original (i.e.
void | Sort ()
Sorts the commands list.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

virtual void | OnControlRemoved (CXTPControl *pControl)
This method is called when a control is removed from the collection.
virtual BOOL | OnControlRemoving (CXTPControl *pControl)
This method is called when a control is about to be removed from the collection.
virtual BOOL | ShouldSerializeControl (CXTPControl *pControl)
This method is called to check if a control has changed and must be saved.
virtual void | Copy (CXTPControls *pControls, BOOL bRecursive=FALSE)
This method is called to copy controls.
- Protected Member Functions inherited from CXTPControls
virtual void | OnControlAdded (CXTPControl *pControl)
This method is called when a control is added to the collection.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Attributes inherited from CXTPControls
CXTPCommandBar * | m_pParent
Parent Command Bar.
CArray< CXTPControl *, CXTPControl * > | m_arrControls
Collection of controls.
CXTPCommandBars * | m_pCommandBars
Parent Command Bars.
CXTPOriginalControls * | m_pOriginalControls
Original controls collection.
BOOL | m_bOriginalControls
TRUE if all controls are original and unmodified.

Detailed Description

CXTPRibbonControls is a CXTPControls derived class.

It represents a collection of controls for a Ribbon Bar.

Member Function Documentation

◆ Copy()

virtual void Copy | ( | CXTPControls * | pControls,
 |  | BOOL | bRecursive = FALSE )
 protectedvirtual

This method is called to copy controls.

Parameters
pControls | Controls to be copied.
bRecursive | TRUE to copy recursively.

Reimplemented from CXTPControls.

◆ OnControlRemoved()

virtual void OnControlRemoved ( CXTPControl * pControl )
protectedvirtual

This method is called when a control is removed from the collection.

Parameters
pControl Control that was removed from the collection.

Reimplemented from CXTPControls.

◆ OnControlRemoving()

virtual BOOL OnControlRemoving ( CXTPControl * pControl )
protectedvirtual

This method is called when a control is about to be removed from the collection.

Parameters
pControl Control that is about to be removed from the collection.
Returns
TRUE to cancel the removal of the control.

Reimplemented from CXTPControls.

◆ ShouldSerializeControl()

virtual BOOL ShouldSerializeControl ( CXTPControl * pControl )
protectedvirtual

This method is called to check if a control has changed and must be saved.

Parameters
pControl Control to check.
Returns
TRUE if the control must be saved.

Reimplemented from CXTPControls.

The documentation for this class was generated from the following file:
  • XTPRibbonQuickAccessControls.h


Toolkit Pro: CXTPRibbonControlSystemButton Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPRibbonControlSystemButton Class Reference

CXTPRibbonControlSystemButton is a CXTPControlPopup derived class used as a system button for a Ribbon Bar. More...

Inheritance diagram for CXTPRibbonControlSystemButton:
[legend]

Public Member Functions

CXTPRibbonControlSystemButton ()
Constructs a CXTPRibbonControlSystemButton object.
void | Draw (CDC *pDC)
This method is called to draw the control.
BOOL | IsSimpleButton () const
This method is called to determine if this system button is a normal button or the Office 2007 style system button.
virtual CSize | GetSize (CDC *pDC)
This method is called to determine the size of the control.
virtual CString | GetCaption () const
Call this member to get the caption of the control.
- Public Member Functions inherited from CXTPControlPopup
CXTPControlPopup ()
Constructs a CXTPControlPopup object.
virtual | ~CXTPControlPopup ()
Destroys a CXTPControlPopup object, handles cleanup and deallocation.
void | SetCommandBar (CMenu *pMenu)
Call this member to set the child command bar.
void | SetCommandBar (CXTPCommandBar *pBar)
Call this member to set the child command bar.
CXTPCommandBar * | GetCommandBar () const
Call this member to get the child command bar.
BOOL | GetPopuped () const
Call this member to get the control's pop-up state.
void | DoPropExchange (CXTPPropExchange *pPX)
Either reads this object from or writes this object to an archive.
void | Copy (CXTPControl *pControl, BOOL bRecursive=FALSE)
This method is called to copy the control.
virtual void | OnUnderlineActivate ()
This method is called when the user activates a control using its underline.
- Public Member Functions inherited from CXTPControlButton
CXTPControlButton ()
Constructs a CXTPControlButton object.
virtual | ~CXTPControlButton ()
Destroys a CXTPControlButton object, handles cleanup and deallocation.
void | SetStyleEx (XTPButtonStyle buttonStyle)
Call this member to set the style of the button containing vector icon.
XTPButtonStyle | GetStyleEx () const
Call this member to get the button's style containing vector icon.
- Public Member Functions inherited from CXTPControl
void | SetStyle (XTPButtonStyle buttonStyle)
Call this member to set the style of the control.
XTPButtonStyle | GetStyle () const
Call this member to get the control's style.
void | SetCaption (LPCTSTR lpszCaption)
Call this member to set the caption of the control.
void | SetCaption (UINT nIDCaption)
Call this member to set the caption of the control.
void | SetShortcutText (LPCTSTR lpszShortcutText)
Call this member to set the shortcut string to the control.
CString | GetShortcutText () const
Call this member to get the control's shortcut.
void | SetDescription (LPCTSTR lpszDescription)
Call this member to set the description of the control.
virtual CString | GetDescription () const
Call this member to get the control's description.
void | SetTooltip (LPCTSTR lpszTooltip)
Call this member to set the tooltip of the control.
virtual CString | GetTooltip () const
Call this member to get the control's tooltip.
void | SetKeyboardTip (LPCTSTR lpszKeyboardTip)
Call this member to set the keyboard tip to the control.
CString | GetKeyboardTip () const
Call this member to get the keyboard tip.
void | SetCustomShortcutText (LPCTSTR lpszCustomShortcutText)
Call this member to set the text displayed for the shortcut in a pop-up menu.
CString | GetCustomShortcutText () const
Call this member to get the control's text displayed for the shortcut in a pop-up menu.
void | SetParameter (LPCTSTR lpszParameter)
Call this member to set the parameter of the control.
CString | GetParameter () const
Call this member to get the control's parameter.
void | SetID (int nId)
Call this member to set the identifier of the control.
int | GetID () const
Call this member to get the control's identifier.
long | GetIndex () const
Call this member to get the index of the control.
void | SetIconId (int nId)
Call this member to set the control icon's identifier.
int | GetIconId () const
Call this member to get the icon's identifier.
void | SetHelpId (int nId)
Call this member to set the control help identifier.
int | GetHelpId () const
Call this member to get the help identifier.
virtual void | SetBeginGroup (BOOL bBeginGroup)
Call this member to begin a new group using a separator.
BOOL | GetBeginGroup () const
Call this member to determine if the control has a separator.
virtual void | SetEnabled (BOOL bEnabled)
Call this member to enable/disable the control.
BOOL | GetEnabled () const
Call this member to check if the control is enabled.
virtual void | OnEnabledChanged ()
This method is called when a control's enabled state is changed.
virtual void | SetChecked (BOOL bChecked)
Call this member to set the checked state of the control.
BOOL | GetChecked () const
Call this member to get the checked state of the control.
virtual int | GetSelected () const
Call this member to check if the control is selected.
void | SetOnQuickAccess (BOOL bOnQuicAccess=FALSE)
Call this member to set whether a control should be a part of the Quick Access panel.
BOOL | IsOnQuickAccess () const
Call this member to check if a control is a part of the Quick Access panel.
virtual void | SetFocused (BOOL bFocused)
Call this member to set the focused state of the control.
virtual BOOL | IsFocused () const
Call this member to check the focused state of the control.
void | SetPressed (BOOL bPressed)
Call this member to set the pressed state of the control.
virtual BOOL | GetPressed () const
Call this member to check the pressed state of the control.
virtual void | SetRect (CRect rcControl)
This member is called to set the bounding rectangle of the control.
CRect | GetRect () const
Call this member to get the bounding rectangle of the control.
CXTPCommandBar * | GetParent () const
Call this member to get the parent command bar.
virtual BOOL | IsVisible (DWORD dwSkipFlags=0) const
Call this member to determine if the control is visible.
virtual BOOL | IsCaptionVisible () const
Call this member to determine if the caption of the control is visible.
void | SetVisible (BOOL bVisible)
Call this member to set the visibility of the control.
CXTPControls * | GetControls () const
Call this member to get the parent controls collection.
XTPControlType | GetType () const
Call this member to get the control's type.
void | SetFlags (DWORD dwFlags)
Call this member to set the flags of the control.
DWORD | GetFlags () const
Call this member to retrieve control special flags.
void | SetTag (DWORD_PTR dwTag)
This method sets the 32-bit value associated with the control.
DWORD_PTR | GetTag () const
This method retrieves the application-supplied, 32-bit value associated with the control.
void | SetCloseSubMenuOnClick (BOOL bCloseOnClick)
Call this member function to enable/disable the closing of sub-menus when a control is clicked in the menu.
BOOL | GetCloseSubMenuOnClick () const
Call this member function to check if sub-menus will close as soon as a control is clicked.
void | SetExecuteOnPressInterval (int nExecuteOnPressInterval)
Call this method to set the delay (in milliseconds) between WM_COMMAND messages while a button is pressed by the user.
int | GetExecuteOnPressInterval () const
Call this method to get the delay (in milliseconds) between WM_COMMAND messages while a button is pressed by the user.
CXTPRibbonGroup * | GetRibbonGroup () const
Returns the ribbon group that the control belongs to.
virtual BOOL | IsTransparent () const
Determines if the control needs to draw its background.
void | SetHideWrap (BOOL bHide)
This method is called to hide the control.
virtual void | SetHideFlags (DWORD dwFlags)
This method is called to hide the control.
BOOL | SetHideFlag (XTPControlHideFlags dwFlag, BOOL bSet)
Call this member to set/remove hide flags.
DWORD | GetHideFlags () const
Call this method to retrieve hidden flags.
CRect | GetRowRect () const
Call this method to retrieve the position of the control's row.
BOOL | GetWrap () const
Call this method to check if the control is wrapped.
void | SetRowRect (CRect rcRow)
Call this method to set the row of the control.
void | SetWrap (BOOL bWrap)
Call this member to set the control to wrapped.
BOOL | GetExpanded () const
Call this member to check if the control is expanded.
BOOL | IsCursorOver () const
Call this member to determine if the mouse pointer is over the control.
virtual void | OnExecute ()
This method is called when the control is executed.
virtual void | OnCalcDynamicSize (DWORD dwMode)
This method is called before recalculating the parent command bar size to calculate the dimensions of the control.
void | DelayRedrawParent ()
Call this method to redraw the parent command bar.
void | DelayLayoutParent ()
Call this method to recalculate the parent command bar size.
void | SetCategory (LPCTSTR lpszCategory)
Call this method to set the category of the control.
CString | GetCategory () const
Call this method to retrieve the category of the control.
CXTPImageManager * | GetImageManager () const
Call this method to retrieve the image manager.
CXTPPaintManager * | GetPaintManager () const
Call this method to retrieve the paint manager.
virtual CXTPImageManagerIcon * | GetImage (int nWidth=16) const
Call this method to retrieve the image of the control.
void | AssignDocTemplate (UINT nIDResource)
Call this method to assign a document template to the control.
void | ExcludeDocTemplate (UINT nIDResource)
Call this method to exclude the document template from control.
BOOL | IsItemDefault () const
Call this method to check if a control is a default menu item.
void | SetItemDefault (BOOL bDefault)
Call this method to set a control to be a default menu item.
BOOL | IsTemporary () const
Call this method to determine if a control is temporary.
void | Reset ()
Call this member to reset the icon and caption of a control to its default settings before it was customized by the user.
void | SetPrompt (LPCTSTR lpszPrompt)
Call this member to load a string from a STRINGTABLE resource to set the tooltip and description of a control.
void | SetCustomIcon (HICON hIcon)
Call this member to set a custom icon to this control.
void | RedrawParent (BOOL bAnimate=TRUE)
This method is called to redraw the parent command bar.
LRESULT | NotifySite (UINT code)
This method is called to send message code to the parent site window.
LRESULT | NotifySite (UINT code, NMXTPCONTROL *pNM)
This method is called to send message code to the parent site window.
LRESULT | NotifySite (CWnd *pSite, UINT code, NMXTPCONTROL *pNM)
This method is called to send message code to the parent site window.
virtual void | SetAction (CXTPControlAction *pAction)
Call this method to manually assign an action for control.
CXTPControlAction * | GetAction () const
Call this method to retrieve an action associated with control.
virtual void | OnThemeChanged ()
This method is called when the paint manager theme is changed.
virtual void | SetWidth (int nWidth)
Call this member to set the width of the control.
virtual void | SetHeight (int nHeight)
Call this member to set the height of the control.
int | GetWidth () const
Call this member to get the width of the control.
int | GetHeight () const
Call this member to get the height of the control.
BOOL | HasDwmCompositedRect () const
This method is called to determine if control has a Vista DWM transparent area.
virtual CSize | GetButtonSize () const
Call this function to get the size of the command bar button.
virtual CSize | GetIconSize () const
Call this member function to get the size of a toolbar icon.
void | SetIconSize (CSize szIcon)
Call this member function to set the size of an icon for an individual control.
virtual BOOL | IsCustomizeMovable () const
This method is called to determine if control can be repositioned in customize mode.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

virtual BOOL | OnLButtonDblClk (CPoint point)
This member is called when the user double-clicks the left mouse button.
void | AdjustExcludeRect (CRect &rc, BOOL bVertical)
Updates rectangle to set the position where a child pop-up bar becomes visible.
- Protected Member Functions inherited from CXTPControlPopup
BOOL | ContainsPopup (CXTPControlPopup *pControlPopup)
This method is called to check if pControlPopup contains in the control recursively.
void | ExpandCommandBar ()
Call this member to expand the parent pop-up bar.
BOOL | OnSetSelected (int bSelected)
This method is called when the control becomes selected.
void | OnClick (BOOL bKeyboard=FALSE, CPoint pt=CPoint(0, 0))
This method is called when the user clicks the control.
void | OnMouseHover ()
This method is called after the mouse hovers over the control.
virtual void | OnMouseMove (CPoint point)
This member is called when the mouse cursor moves.
virtual BOOL | OnSetPopup (BOOL bPopup)
This method is called to pop-up the control.
virtual void | OnLButtonUp (CPoint point)
This member is called when the user releases the left mouse button.
void | OnCustomizeDragOver (CXTPControl *pDataObject, CPoint point, DROPEFFECT &dropEffect)
This method is called when the user moves the mouse over the control.
virtual BOOL | DoCustomDragOver (CXTPCommandBar *pCommandBar, CPoint point, DROPEFFECT &dropEffect)
The implementation may implement a custom drag over handling logic in this method.
virtual BOOL | Compare (CXTPControl *pOther)
Call this member to compare controls.
virtual void | UpdateShadow ()
Call this member to update the shadow of the control.
virtual void | RestoreCommandBarList (CXTPCommandBarList *pCommandBarList)
This method is called from LoadCommandBars to restore controls and its child command bars.
- Protected Member Functions inherited from CXTPControlButton
- Protected Member Functions inherited from CXTPControl
CXTPControl ()
Constructs a CXTPControl object.
virtual | ~CXTPControl ()
Destroys a CXTPControl object, handles cleanup and deallocation.
virtual BOOL | IsFocusable () const
This method is called to check if the control can accept focus.
void | SetIndex (int nIndex)
This method is called to assign the order of the control in the controls list.
void | SetExpanded (BOOL bExpanded)
This method is called to set the control's expanded state.
virtual BOOL | OnHookKeyDown (UINT nChar, LPARAM lParam)
This method is called when a non-system key is pressed.
virtual BOOL | OnHookMouseWheel (UINT nFlags, short zDelta, CPoint point)
This method is called when the user rotates the mouse wheel.
virtual void | SetParent (CXTPCommandBar *pParent)
This method is called to assign a parent command bar object.
void | ScreenToClient (CPoint *point)
The ScreenToClient function converts the screen coordinates of a specified point on the screen.
void | ClickToolBarButton (CRect rcActiveRect=CRect(0, 0, 0, 0))
This helper method is called when the user clicks the toolbar's button.
virtual void | OnLButtonDown (CPoint point)
This member is called when the user presses the left mouse button down.
virtual BOOL | OnRButtonDown (CPoint point)
This member is called when the user press the right mouse button.
virtual BOOL | OnRButtonUp (CPoint point)
This member is called when the user releases the right mouse button.
BOOL | IsCustomizeMode () const
Call this method to determine if command bars is in customize mode.
virtual void | CustomizeStartDrag (CPoint point)
This member is called when the user starts to drag the control in customize mode.
virtual BOOL | CustomizeStartResize (CPoint point)
This method is called when user starts to resize control in customize mode.
virtual BOOL | IsCustomizeResizeAllow () const
This member checks if the user can resize the control.
virtual int | GetCustomizeMinWidth () const
Retrieves the available minimum width of control.
virtual int | GetCustomizeMinHeight () const
Retrieves available minimum height of the control.
void | OnCustomizeMouseMove (CPoint point)
This member is called when the mouse cursor moves in customized mode.
virtual void | OnIdleUpdate ()
This virtual method is called in idle-time processing.
virtual void | OnRemoved ()
This method is called when a control is removed from the parent controls collection.
virtual INT_PTR | OnToolHitTest (CPoint point, TOOLINFO *pTI) const
The framework calls this member function to determine whether a point is in the bounding rectangle of the specified tool.
virtual void | GenerateCommandBarList (DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam)
This method is called from SaveCommandBars to save all child command bars.
virtual void | OnActionChanged (int nProperty)
This method is called when an action property is changed.
virtual void | OnActionChanging (int nProperty)
This method is called when an action property is about to be changed.
virtual void | OnCaptionChanged ()
This method is called when the control's caption is changed.
BOOL | IsLayoutRTL () const
Determines if right-to-left (RTL) mode is set.
BOOL | IsLayoutChanged ()
Call this member to determine if the layout has changed (RTL to LTR or LTR to RLT).

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlPopup
static CXTPControlPopup *AFX_CDECL | CreateControlPopup (XTPControlType controlType)
Creates a CXTPControlPopup object with the specified type.
- Static Public Member Functions inherited from CXTPControl
static CXTPControl *AFX_CDECL | FromUI (CCmdUI *pCmdUI)
Call this member to retrieve CXTPControl from a CCmdUI structure.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Attributes inherited from CXTPControlPopup
BOOL | m_bPopup
TRUE if pop-up'ed.
CXTPCommandBar * | m_pCommandBar
Child pop-up bar.
DWORD | m_dwCommandBarID
Child pop-up ID.
BOOL | m_bShowShadow
TRUE to show shadow.
- Protected Attributes inherited from CXTPControlButton
XTPButtonStyle | m_buttonStyleEx
User-defined style of button containing vector icon.
- Protected Attributes inherited from CXTPControl
DWORD_PTR | m_nTag
Control tag.
int | m_nIndex
Index of the control.
int | m_nId
Identifier of the control.
int | m_nIconId
Identifier of the control's image.
int | m_nHelpId
Help identifier.
int | m_nCustomIconId
Identifier of the control's custom image.
BOOL | m_bWrap
TRUE if the control is wrapped.
BOOL | m_bBeginGroup
TRUE if the control starts new group.
BOOL | m_bEnabled
TRUE if the control is enabled.
BOOL | m_bChecked
TRUE if the control is checked.
BOOL | m_bSelected
TRUE if the control is selected.
BOOL | m_bPressed
TRUE if the control is pushed.
BOOL | m_bTemporary
TRUE if the control is temporary.
BOOL | m_bOnQuickAccess
TRUE if the control is a part of Quick Access panel.
CRect | m_rcRow
Bounding rectangle of the control's row.
CRect | m_rcControl
Bounding rectangle of the control.
DWORD | m_dwHideFlags
Hidden flags.
DWORD | m_dwFlags
Flags of the control.
CString | m_strCaption
Caption of the control.
CString | m_strCustomCaption
User-defined caption.
CString | m_strShortcutText
Shortcut text.
CString | m_strShortcutTextAuto
Shortcut text.
CString | m_strTooltipText
Tooltip text.
CString | m_strDescriptionText
Description text.
CString | m_strParameter
Parameter text.
CString | m_strKeyboardTip
Keyboard tip.
CXTPControls * | m_pControls
Parent control collection.
XTPControlType | m_controlType
Type of the control.
CXTPCommandBar * | m_pParent
The Parent command bar.
BOOL | m_bExpanded
TRUE if the control is expanded.
CString | m_strCategory
Category of the control.
BOOL | m_bDefaultItem
TRUE if the item is default pop-up item.
CDocTemplateMap | m_mapDocTemplatesAssigned
Assigned templates.
CDocTemplateMap | m_mapDocTemplatesExcluded
Excluded templates.
XTPButtonStyle | m_buttonStyle
Button Style.
XTPButtonStyle | m_buttonCustomStyle
User-defined style of button.
XTPButtonStyle | m_buttonRibbonStyle
User-defined style of button.
BOOL | m_bCloseSubMenuOnClick
TRUE is sub-menus are closed as soon as a control is clicked.
CXTPRibbonGroup * | m_pRibbonGroup
Ribbon group of control.
CXTPControlAction * | m_pAction
Action of the control.
int | m_nWidth
Width of the control.
int | m_nHeight
Height of the control.
int | m_nExecuteOnPressInterval
Delay between each message when control is pressed.
CSize | m_szIcon
The size of the icon used for the control.
BOOL | m_bLayoutRTL
Indicate does last layout is RTL.

Detailed Description

CXTPRibbonControlSystemButton is a CXTPControlPopup derived class used as a system button for a Ribbon Bar.

Member Function Documentation

◆ AdjustExcludeRect()

void AdjustExcludeRect | ( | CRect & | rc,
 |  | BOOL | bVertical )
 protectedvirtual

Updates rectangle to set the position where a child pop-up bar becomes visible.

Parameters
rc | CRect object specifying size of area.
bVertical | TRUE if vertical, FALSE otherwise.

Reimplemented from CXTPControlPopup.

◆ Draw()

void Draw ( CDC * pDC )
virtual

This method is called to draw the control.

Parameters
pDC Pointer to a valid device context.

Reimplemented from CXTPControl.

◆ GetCaption()

virtual CString GetCaption ( ) const
virtual

Call this member to get the caption of the control.

Returns
The caption of the control.

Reimplemented from CXTPControlPopup.

◆ GetSize()

virtual CSize GetSize ( CDC * pDC )
virtual

This method is called to determine the size of the control.

Parameters
pDC Pointer to a valid device context.
Returns
The size of the control.

Reimplemented from CXTPControl.

◆ IsSimpleButton()

BOOL IsSimpleButton ( ) const

This method is called to determine if this system button is a normal button or the Office 2007 style system button.

Returns
TRUE if this system button is a normal button, FALSE if this system button is an Office 2007 style system button.

◆ OnLButtonDblClk()

virtual BOOL OnLButtonDblClk ( CPoint point )
protectedvirtual

This member is called when the user double-clicks the left mouse button.

Parameters
point Specifies the x- and y- coordinates of the cursor.
Returns
TRUE if successful, otherwise FALSE.

Reimplemented from CXTPControlPopup.

The documentation for this class was generated from the following file:
  • XTPRibbonSystemButton.h


Toolkit Pro: CXTPRibbonControlSystemPopupBarButton Class Reference

Public Member Functions | List of all members
CXTPRibbonControlSystemPopupBarButton Class Reference

CXTPRibbonControlSystemPopupBarButton is a CXTPControlButton derived class used in a system pop-up bar for bottom option buttons. More...

Inheritance diagram for CXTPRibbonControlSystemPopupBarButton:
[legend]

Public Member Functions

CXTPRibbonControlSystemPopupBarButton ()
Constructs a CXTPRibbonControlSystemPopupBarButton object.
virtual CSize | GetSize (CDC *pDC)
This method is called to determine the size of the control.
virtual void | Draw (CDC *pDC)
This method is called to draw the control.
BOOL | IsTransparent () const
Determines if the control needs to draw its background.
virtual CSize | GetButtonSize () const
Call this function to get the size of the command bar button.
virtual CSize | GetIconSize () const
Call this member function to get the size of the toolbar icon.
- Public Member Functions inherited from CXTPControlButton
CXTPControlButton ()
Constructs a CXTPControlButton object.
virtual | ~CXTPControlButton ()
Destroys a CXTPControlButton object, handles cleanup and deallocation.
void | SetStyleEx (XTPButtonStyle buttonStyle)
Call this member to set the style of the button containing vector icon.
XTPButtonStyle | GetStyleEx () const
Call this member to get the button's style containing vector icon.
void | DoPropExchange (CXTPPropExchange *pPX)
Either reads this object from or writes this object to an archive.
- Public Member Functions inherited from CXTPControl
void | SetStyle (XTPButtonStyle buttonStyle)
Call this member to set the style of the control.
XTPButtonStyle | GetStyle () const
Call this member to get the control's style.
void | SetCaption (LPCTSTR lpszCaption)
Call this member to set the caption of the control.
void | SetCaption (UINT nIDCaption)
Call this member to set the caption of the control.
virtual CString | GetCaption () const
Call this member to get the control's caption.
void | SetShortcutText (LPCTSTR lpszShortcutText)
Call this member to set the shortcut string to the control.
CString | GetShortcutText () const
Call this member to get the control's shortcut.
void | SetDescription (LPCTSTR lpszDescription)
Call this member to set the description of the control.
virtual CString | GetDescription () const
Call this member to get the control's description.
void | SetTooltip (LPCTSTR lpszTooltip)
Call this member to set the tooltip of the control.
virtual CString | GetTooltip () const
Call this member to get the control's tooltip.
void | SetKeyboardTip (LPCTSTR lpszKeyboardTip)
Call this member to set the keyboard tip to the control.
CString | GetKeyboardTip () const
Call this member to get the keyboard tip.
void | SetCustomShortcutText (LPCTSTR lpszCustomShortcutText)
Call this member to set the text displayed for the shortcut in a pop-up menu.
CString | GetCustomShortcutText () const
Call this member to get the control's text displayed for the shortcut in a pop-up menu.
void | SetParameter (LPCTSTR lpszParameter)
Call this member to set the parameter of the control.
CString | GetParameter () const
Call this member to get the control's parameter.
void | SetID (int nId)
Call this member to set the identifier of the control.
int | GetID () const
Call this member to get the control's identifier.
long | GetIndex () const
Call this member to get the index of the control.
void | SetIconId (int nId)
Call this member to set the control icon's identifier.
int | GetIconId () const
Call this member to get the icon's identifier.
void | SetHelpId (int nId)
Call this member to set the control help identifier.
int | GetHelpId () const
Call this member to get the help identifier.
virtual void | SetBeginGroup (BOOL bBeginGroup)
Call this member to begin a new group using a separator.
BOOL | GetBeginGroup () const
Call this member to determine if the control has a separator.
virtual void | SetEnabled (BOOL bEnabled)
Call this member to enable/disable the control.
BOOL | GetEnabled () const
Call this member to check if the control is enabled.
virtual void | OnEnabledChanged ()
This method is called when a control's enabled state is changed.
virtual void | SetChecked (BOOL bChecked)
Call this member to set the checked state of the control.
BOOL | GetChecked () const
Call this member to get the checked state of the control.
virtual int | GetSelected () const
Call this member to check if the control is selected.
void | SetOnQuickAccess (BOOL bOnQuicAccess=FALSE)
Call this member to set whether a control should be a part of the Quick Access panel.
BOOL | IsOnQuickAccess () const
Call this member to check if a control is a part of the Quick Access panel.
virtual void | SetFocused (BOOL bFocused)
Call this member to set the focused state of the control.
virtual BOOL | IsFocused () const
Call this member to check the focused state of the control.
void | SetPressed (BOOL bPressed)
Call this member to set the pressed state of the control.
virtual BOOL | GetPressed () const
Call this member to check the pressed state of the control.
virtual void | SetRect (CRect rcControl)
This member is called to set the bounding rectangle of the control.
CRect | GetRect () const
Call this member to get the bounding rectangle of the control.
CXTPCommandBar * | GetParent () const
Call this member to get the parent command bar.
virtual BOOL | IsVisible (DWORD dwSkipFlags=0) const
Call this member to determine if the control is visible.
virtual BOOL | IsCaptionVisible () const
Call this member to determine if the caption of the control is visible.
void | SetVisible (BOOL bVisible)
Call this member to set the visibility of the control.
CXTPControls * | GetControls () const
Call this member to get the parent controls collection.
XTPControlType | GetType () const
Call this member to get the control's type.
void | SetFlags (DWORD dwFlags)
Call this member to set the flags of the control.
DWORD | GetFlags () const
Call this member to retrieve control special flags.
void | SetTag (DWORD_PTR dwTag)
This method sets the 32-bit value associated with the control.
DWORD_PTR | GetTag () const
This method retrieves the application-supplied, 32-bit value associated with the control.
virtual BOOL | Compare (CXTPControl *pOther)
Call this member to compare controls.
virtual CXTPCommandBar * | GetCommandBar () const
Call this member to get the child command bar.
void | SetCloseSubMenuOnClick (BOOL bCloseOnClick)
Call this member function to enable/disable the closing of sub-menus when a control is clicked in the menu.
BOOL | GetCloseSubMenuOnClick () const
Call this member function to check if sub-menus will close as soon as a control is clicked.
void | SetExecuteOnPressInterval (int nExecuteOnPressInterval)
Call this method to set the delay (in milliseconds) between WM_COMMAND messages while a button is pressed by the user.
int | GetExecuteOnPressInterval () const
Call this method to get the delay (in milliseconds) between WM_COMMAND messages while a button is pressed by the user.
CXTPRibbonGroup * | GetRibbonGroup () const
Returns the ribbon group that the control belongs to.
void | SetHideWrap (BOOL bHide)
This method is called to hide the control.
virtual void | SetHideFlags (DWORD dwFlags)
This method is called to hide the control.
BOOL | SetHideFlag (XTPControlHideFlags dwFlag, BOOL bSet)
Call this member to set/remove hide flags.
DWORD | GetHideFlags () const
Call this method to retrieve hidden flags.
CRect | GetRowRect () const
Call this method to retrieve the position of the control's row.
BOOL | GetWrap () const
Call this method to check if the control is wrapped.
void | SetRowRect (CRect rcRow)
Call this method to set the row of the control.
void | SetWrap (BOOL bWrap)
Call this member to set the control to wrapped.
BOOL | GetExpanded () const
Call this member to check if the control is expanded.
BOOL | IsCursorOver () const
Call this member to determine if the mouse pointer is over the control.
virtual void | OnExecute ()
This method is called when the control is executed.
virtual void | OnCalcDynamicSize (DWORD dwMode)
This method is called before recalculating the parent command bar size to calculate the dimensions of the control.
void | DelayRedrawParent ()
Call this method to redraw the parent command bar.
void | DelayLayoutParent ()
Call this method to recalculate the parent command bar size.
void | SetCategory (LPCTSTR lpszCategory)
Call this method to set the category of the control.
CString | GetCategory () const
Call this method to retrieve the category of the control.
CXTPImageManager * | GetImageManager () const
Call this method to retrieve the image manager.
CXTPPaintManager * | GetPaintManager () const
Call this method to retrieve the paint manager.
virtual CXTPImageManagerIcon * | GetImage (int nWidth=16) const
Call this method to retrieve the image of the control.
void | AssignDocTemplate (UINT nIDResource)
Call this method to assign a document template to the control.
void | ExcludeDocTemplate (UINT nIDResource)
Call this method to exclude the document template from control.
BOOL | IsItemDefault () const
Call this method to check if a control is a default menu item.
void | SetItemDefault (BOOL bDefault)
Call this method to set a control to be a default menu item.
BOOL | IsTemporary () const
Call this method to determine if a control is temporary.
void | Reset ()
Call this member to reset the icon and caption of a control to its default settings before it was customized by the user.
void | SetPrompt (LPCTSTR lpszPrompt)
Call this member to load a string from a STRINGTABLE resource to set the tooltip and description of a control.
void | SetCustomIcon (HICON hIcon)
Call this member to set a custom icon to this control.
virtual void | OnUnderlineActivate ()
This method is called when the user activates the control using its underline.
virtual BOOL | GetPopuped () const
Call this member to get the control's pop-up state.
void | RedrawParent (BOOL bAnimate=TRUE)
This method is called to redraw the parent command bar.
LRESULT | NotifySite (UINT code)
This method is called to send message code to the parent site window.
LRESULT | NotifySite (UINT code, NMXTPCONTROL *pNM)
This method is called to send message code to the parent site window.
LRESULT | NotifySite (CWnd *pSite, UINT code, NMXTPCONTROL *pNM)
This method is called to send message code to the parent site window.
virtual void | SetAction (CXTPControlAction *pAction)
Call this method to manually assign an action for control.
CXTPControlAction * | GetAction () const
Call this method to retrieve an action associated with control.
virtual void | OnThemeChanged ()
This method is called when the paint manager theme is changed.
virtual void | SetWidth (int nWidth)
Call this member to set the width of the control.
virtual void | SetHeight (int nHeight)
Call this member to set the height of the control.
int | GetWidth () const
Call this member to get the width of the control.
int | GetHeight () const
Call this member to get the height of the control.
BOOL | HasDwmCompositedRect () const
This method is called to determine if control has a Vista DWM transparent area.
void | SetIconSize (CSize szIcon)
Call this member function to set the size of an icon for an individual control.
virtual BOOL | IsCustomizeMovable () const
This method is called to determine if control can be repositioned in customize mode.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControl
static CXTPControl *AFX_CDECL | FromUI (CCmdUI *pCmdUI)
Call this member to retrieve CXTPControl from a CCmdUI structure.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Member Functions inherited from CXTPControlButton
virtual void | OnClick (BOOL bKeyboard=FALSE, CPoint pt=CPoint(0, 0))
This method is called when the user clicks the control.
virtual void | OnLButtonUp (CPoint point)
This member is called when the user releases the left mouse button.
virtual void | Copy (CXTPControl *pControl, BOOL bRecursive=FALSE)
This method is called to copy the control.
- Protected Member Functions inherited from CXTPControl
CXTPControl ()
Constructs a CXTPControl object.
virtual | ~CXTPControl ()
Destroys a CXTPControl object, handles cleanup and deallocation.
virtual BOOL | IsFocusable () const
This method is called to check if the control can accept focus.
void | SetIndex (int nIndex)
This method is called to assign the order of the control in the controls list.
void | SetExpanded (BOOL bExpanded)
This method is called to set the control's expanded state.
virtual BOOL | OnHookKeyDown (UINT nChar, LPARAM lParam)
This method is called when a non-system key is pressed.
virtual BOOL | OnHookMouseWheel (UINT nFlags, short zDelta, CPoint point)
This method is called when the user rotates the mouse wheel.
virtual void | SetParent (CXTPCommandBar *pParent)
This method is called to assign a parent command bar object.
void | ScreenToClient (CPoint *point)
The ScreenToClient function converts the screen coordinates of a specified point on the screen.
void | ClickToolBarButton (CRect rcActiveRect=CRect(0, 0, 0, 0))
This helper method is called when the user clicks the toolbar's button.
virtual BOOL | OnSetPopup (BOOL bPopup)
This method is called to pop-up the control.
virtual void | OnLButtonDown (CPoint point)
This member is called when the user presses the left mouse button down.
virtual BOOL | OnRButtonDown (CPoint point)
This member is called when the user press the right mouse button.
virtual BOOL | OnRButtonUp (CPoint point)
This member is called when the user releases the right mouse button.
virtual BOOL | OnLButtonDblClk (CPoint point)
This member is called when the user double-clicks the left mouse button.
virtual void | OnMouseMove (CPoint point)
This member is called when the mouse cursor moves.
virtual void | OnMouseHover ()
Called after the mouse hovers over the control.
virtual BOOL | OnSetSelected (int bSelected)
This method is called when the control becomes selected.
BOOL | IsCustomizeMode () const
Call this method to determine if command bars is in customize mode.
virtual void | CustomizeStartDrag (CPoint point)
This member is called when the user starts to drag the control in customize mode.
virtual BOOL | CustomizeStartResize (CPoint point)
This method is called when user starts to resize control in customize mode.
virtual void | OnCustomizeDragOver (CXTPControl *pDataObject, CPoint point, DROPEFFECT &dropEffect)
This member is called when the user moves the mouse over the control.
virtual BOOL | DoCustomDragOver (CXTPCommandBar *pCommandBar, CPoint point, DROPEFFECT &dropEffect)
The implementation may implement a custom drag over handling logic in this method.
virtual BOOL | IsCustomizeResizeAllow () const
This member checks if the user can resize the control.
virtual int | GetCustomizeMinWidth () const
Retrieves the available minimum width of control.
virtual int | GetCustomizeMinHeight () const
Retrieves available minimum height of the control.
void | OnCustomizeMouseMove (CPoint point)
This member is called when the mouse cursor moves in customized mode.
virtual void | OnIdleUpdate ()
This virtual method is called in idle-time processing.
virtual void | OnRemoved ()
This method is called when a control is removed from the parent controls collection.
virtual INT_PTR | OnToolHitTest (CPoint point, TOOLINFO *pTI) const
The framework calls this member function to determine whether a point is in the bounding rectangle of the specified tool.
virtual void | RestoreCommandBarList (CXTPCommandBarList *pCommandBarList)
This method is called from LoadCommandBars to restore controls and its child command bars.
virtual void | GenerateCommandBarList (DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam)
This method is called from SaveCommandBars to save all child command bars.
virtual void | OnActionChanged (int nProperty)
This method is called when an action property is changed.
virtual void | OnActionChanging (int nProperty)
This method is called when an action property is about to be changed.
virtual void | OnCaptionChanged ()
This method is called when the control's caption is changed.
BOOL | IsLayoutRTL () const
Determines if right-to-left (RTL) mode is set.
BOOL | IsLayoutChanged ()
Call this member to determine if the layout has changed (RTL to LTR or LTR to RLT).
- Protected Attributes inherited from CXTPControlButton
XTPButtonStyle | m_buttonStyleEx
User-defined style of button containing vector icon.
- Protected Attributes inherited from CXTPControl
DWORD_PTR | m_nTag
Control tag.
int | m_nIndex
Index of the control.
int | m_nId
Identifier of the control.
int | m_nIconId
Identifier of the control's image.
int | m_nHelpId
Help identifier.
int | m_nCustomIconId
Identifier of the control's custom image.
BOOL | m_bWrap
TRUE if the control is wrapped.
BOOL | m_bBeginGroup
TRUE if the control starts new group.
BOOL | m_bEnabled
TRUE if the control is enabled.
BOOL | m_bChecked
TRUE if the control is checked.
BOOL | m_bSelected
TRUE if the control is selected.
BOOL | m_bPressed
TRUE if the control is pushed.
BOOL | m_bTemporary
TRUE if the control is temporary.
BOOL | m_bOnQuickAccess
TRUE if the control is a part of Quick Access panel.
CRect | m_rcRow
Bounding rectangle of the control's row.
CRect | m_rcControl
Bounding rectangle of the control.
DWORD | m_dwHideFlags
Hidden flags.
DWORD | m_dwFlags
Flags of the control.
CString | m_strCaption
Caption of the control.
CString | m_strCustomCaption
User-defined caption.
CString | m_strShortcutText
Shortcut text.
CString | m_strShortcutTextAuto
Shortcut text.
CString | m_strTooltipText
Tooltip text.
CString | m_strDescriptionText
Description text.
CString | m_strParameter
Parameter text.
CString | m_strKeyboardTip
Keyboard tip.
CXTPControls * | m_pControls
Parent control collection.
XTPControlType | m_controlType
Type of the control.
CXTPCommandBar * | m_pParent
The Parent command bar.
BOOL | m_bExpanded
TRUE if the control is expanded.
CString | m_strCategory
Category of the control.
BOOL | m_bDefaultItem
TRUE if the item is default pop-up item.
CDocTemplateMap | m_mapDocTemplatesAssigned
Assigned templates.
CDocTemplateMap | m_mapDocTemplatesExcluded
Excluded templates.
XTPButtonStyle | m_buttonStyle
Button Style.
XTPButtonStyle | m_buttonCustomStyle
User-defined style of button.
XTPButtonStyle | m_buttonRibbonStyle
User-defined style of button.
BOOL | m_bCloseSubMenuOnClick
TRUE is sub-menus are closed as soon as a control is clicked.
CXTPRibbonGroup * | m_pRibbonGroup
Ribbon group of control.
CXTPControlAction * | m_pAction
Action of the control.
int | m_nWidth
Width of the control.
int | m_nHeight
Height of the control.
int | m_nExecuteOnPressInterval
Delay between each message when control is pressed.
CSize | m_szIcon
The size of the icon used for the control.
BOOL | m_bLayoutRTL
Indicate does last layout is RTL.

Detailed Description

CXTPRibbonControlSystemPopupBarButton is a CXTPControlButton derived class used in a system pop-up bar for bottom option buttons.

Member Function Documentation

◆ Draw()

virtual void Draw ( CDC * pDC )
virtual

This method is called to draw the control.

Parameters
pDC Pointer to a valid device context.

Reimplemented from CXTPControl.

◆ GetButtonSize()

virtual CSize GetButtonSize ( ) const
virtual

Call this function to get the size of the command bar button.

Returns
The width and height values of the command bar button.

Reimplemented from CXTPControl.

◆ GetIconSize()

virtual CSize GetIconSize ( ) const
virtual

Call this member function to get the size of the toolbar icon.

Returns
The size of the toolbar icon.
See also
GetButtonSize

Reimplemented from CXTPControl.

◆ GetSize()

virtual CSize GetSize ( CDC * pDC )
virtual

This method is called to determine the size of the control.

Parameters
pDC Pointer to a valid device context.
Returns
The size of the control.

Reimplemented from CXTPControl.

◆ IsTransparent()

BOOL IsTransparent ( ) const
virtual

Determines if the control needs to draw its background.

Returns
TRUE if the paint manager must skip filling the background of the control.

Reimplemented from CXTPControl.

The documentation for this class was generated from the following file:
  • XTPRibbonSystemButton.h


Toolkit Pro: CXTPRibbonControlSystemPopupBarListCaption Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPRibbonControlSystemPopupBarListCaption Class Reference

CXTPRibbonControlSystemPopupBarListCaption is a CXTPControl derived class used in a Ribbon system pop-up to draw captions of enumerable controls. More...

Inheritance diagram for CXTPRibbonControlSystemPopupBarListCaption:
[legend]

Public Member Functions

CXTPRibbonControlSystemPopupBarListCaption ()
Constructs a CXTPRibbonControlSystemPopupBarListCaption object.
- Public Member Functions inherited from CXTPControl
void | SetStyle (XTPButtonStyle buttonStyle)
Call this member to set the style of the control.
XTPButtonStyle | GetStyle () const
Call this member to get the control's style.
void | SetCaption (LPCTSTR lpszCaption)
Call this member to set the caption of the control.
void | SetCaption (UINT nIDCaption)
Call this member to set the caption of the control.
virtual CString | GetCaption () const
Call this member to get the control's caption.
void | SetShortcutText (LPCTSTR lpszShortcutText)
Call this member to set the shortcut string to the control.
CString | GetShortcutText () const
Call this member to get the control's shortcut.
void | SetDescription (LPCTSTR lpszDescription)
Call this member to set the description of the control.
virtual CString | GetDescription () const
Call this member to get the control's description.
void | SetTooltip (LPCTSTR lpszTooltip)
Call this member to set the tooltip of the control.
virtual CString | GetTooltip () const
Call this member to get the control's tooltip.
void | SetKeyboardTip (LPCTSTR lpszKeyboardTip)
Call this member to set the keyboard tip to the control.
CString | GetKeyboardTip () const
Call this member to get the keyboard tip.
void | SetCustomShortcutText (LPCTSTR lpszCustomShortcutText)
Call this member to set the text displayed for the shortcut in a pop-up menu.
CString | GetCustomShortcutText () const
Call this member to get the control's text displayed for the shortcut in a pop-up menu.
void | SetParameter (LPCTSTR lpszParameter)
Call this member to set the parameter of the control.
CString | GetParameter () const
Call this member to get the control's parameter.
void | SetID (int nId)
Call this member to set the identifier of the control.
int | GetID () const
Call this member to get the control's identifier.
long | GetIndex () const
Call this member to get the index of the control.
void | SetIconId (int nId)
Call this member to set the control icon's identifier.
int | GetIconId () const
Call this member to get the icon's identifier.
void | SetHelpId (int nId)
Call this member to set the control help identifier.
int | GetHelpId () const
Call this member to get the help identifier.
virtual void | SetBeginGroup (BOOL bBeginGroup)
Call this member to begin a new group using a separator.
BOOL | GetBeginGroup () const
Call this member to determine if the control has a separator.
virtual void | SetEnabled (BOOL bEnabled)
Call this member to enable/disable the control.
BOOL | GetEnabled () const
Call this member to check if the control is enabled.
virtual void | OnEnabledChanged ()
This method is called when a control's enabled state is changed.
virtual void | SetChecked (BOOL bChecked)
Call this member to set the checked state of the control.
BOOL | GetChecked () const
Call this member to get the checked state of the control.
virtual int | GetSelected () const
Call this member to check if the control is selected.
void | SetOnQuickAccess (BOOL bOnQuicAccess=FALSE)
Call this member to set whether a control should be a part of the Quick Access panel.
BOOL | IsOnQuickAccess () const
Call this member to check if a control is a part of the Quick Access panel.
virtual void | SetFocused (BOOL bFocused)
Call this member to set the focused state of the control.
virtual BOOL | IsFocused () const
Call this member to check the focused state of the control.
void | SetPressed (BOOL bPressed)
Call this member to set the pressed state of the control.
virtual BOOL | GetPressed () const
Call this member to check the pressed state of the control.
virtual void | SetRect (CRect rcControl)
This member is called to set the bounding rectangle of the control.
CRect | GetRect () const
Call this member to get the bounding rectangle of the control.
CXTPCommandBar * | GetParent () const
Call this member to get the parent command bar.
virtual BOOL | IsVisible (DWORD dwSkipFlags=0) const
Call this member to determine if the control is visible.
virtual BOOL | IsCaptionVisible () const
Call this member to determine if the caption of the control is visible.
void | SetVisible (BOOL bVisible)
Call this member to set the visibility of the control.
CXTPControls * | GetControls () const
Call this member to get the parent controls collection.
XTPControlType | GetType () const
Call this member to get the control's type.
void | SetFlags (DWORD dwFlags)
Call this member to set the flags of the control.
DWORD | GetFlags () const
Call this member to retrieve control special flags.
void | SetTag (DWORD_PTR dwTag)
This method sets the 32-bit value associated with the control.
DWORD_PTR | GetTag () const
This method retrieves the application-supplied, 32-bit value associated with the control.
virtual BOOL | Compare (CXTPControl *pOther)
Call this member to compare controls.
virtual CXTPCommandBar * | GetCommandBar () const
Call this member to get the child command bar.
void | SetCloseSubMenuOnClick (BOOL bCloseOnClick)
Call this member function to enable/disable the closing of sub-menus when a control is clicked in the menu.
BOOL | GetCloseSubMenuOnClick () const
Call this member function to check if sub-menus will close as soon as a control is clicked.
void | SetExecuteOnPressInterval (int nExecuteOnPressInterval)
Call this method to set the delay (in milliseconds) between WM_COMMAND messages while a button is pressed by the user.
int | GetExecuteOnPressInterval () const
Call this method to get the delay (in milliseconds) between WM_COMMAND messages while a button is pressed by the user.
CXTPRibbonGroup * | GetRibbonGroup () const
Returns the ribbon group that the control belongs to.
virtual BOOL | IsTransparent () const
Determines if the control needs to draw its background.
void | SetHideWrap (BOOL bHide)
This method is called to hide the control.
virtual void | SetHideFlags (DWORD dwFlags)
This method is called to hide the control.
BOOL | SetHideFlag (XTPControlHideFlags dwFlag, BOOL bSet)
Call this member to set/remove hide flags.
DWORD | GetHideFlags () const
Call this method to retrieve hidden flags.
CRect | GetRowRect () const
Call this method to retrieve the position of the control's row.
BOOL | GetWrap () const
Call this method to check if the control is wrapped.
void | SetRowRect (CRect rcRow)
Call this method to set the row of the control.
void | SetWrap (BOOL bWrap)
Call this member to set the control to wrapped.
BOOL | GetExpanded () const
Call this member to check if the control is expanded.
BOOL | IsCursorOver () const
Call this member to determine if the mouse pointer is over the control.
virtual void | OnExecute ()
This method is called when the control is executed.
virtual void | OnCalcDynamicSize (DWORD dwMode)
This method is called before recalculating the parent command bar size to calculate the dimensions of the control.
void | DelayRedrawParent ()
Call this method to redraw the parent command bar.
void | DelayLayoutParent ()
Call this method to recalculate the parent command bar size.
void | SetCategory (LPCTSTR lpszCategory)
Call this method to set the category of the control.
CString | GetCategory () const
Call this method to retrieve the category of the control.
CXTPImageManager * | GetImageManager () const
Call this method to retrieve the image manager.
CXTPPaintManager * | GetPaintManager () const
Call this method to retrieve the paint manager.
virtual CXTPImageManagerIcon * | GetImage (int nWidth=16) const
Call this method to retrieve the image of the control.
void | AssignDocTemplate (UINT nIDResource)
Call this method to assign a document template to the control.
void | ExcludeDocTemplate (UINT nIDResource)
Call this method to exclude the document template from control.
BOOL | IsItemDefault () const
Call this method to check if a control is a default menu item.
void | SetItemDefault (BOOL bDefault)
Call this method to set a control to be a default menu item.
BOOL | IsTemporary () const
Call this method to determine if a control is temporary.
void | Reset ()
Call this member to reset the icon and caption of a control to its default settings before it was customized by the user.
void | SetPrompt (LPCTSTR lpszPrompt)
Call this member to load a string from a STRINGTABLE resource to set the tooltip and description of a control.
void | SetCustomIcon (HICON hIcon)
Call this member to set a custom icon to this control.
virtual void | DoPropExchange (CXTPPropExchange *pPX)
Either reads this object from or writes this object to an archive.
virtual void | OnUnderlineActivate ()
This method is called when the user activates the control using its underline.
virtual BOOL | GetPopuped () const
Call this member to get the control's pop-up state.
void | RedrawParent (BOOL bAnimate=TRUE)
This method is called to redraw the parent command bar.
LRESULT | NotifySite (UINT code)
This method is called to send message code to the parent site window.
LRESULT | NotifySite (UINT code, NMXTPCONTROL *pNM)
This method is called to send message code to the parent site window.
LRESULT | NotifySite (CWnd *pSite, UINT code, NMXTPCONTROL *pNM)
This method is called to send message code to the parent site window.
virtual void | SetAction (CXTPControlAction *pAction)
Call this method to manually assign an action for control.
CXTPControlAction * | GetAction () const
Call this method to retrieve an action associated with control.
virtual void | OnThemeChanged ()
This method is called when the paint manager theme is changed.
virtual void | SetWidth (int nWidth)
Call this member to set the width of the control.
virtual void | SetHeight (int nHeight)
Call this member to set the height of the control.
int | GetWidth () const
Call this member to get the width of the control.
int | GetHeight () const
Call this member to get the height of the control.
BOOL | HasDwmCompositedRect () const
This method is called to determine if control has a Vista DWM transparent area.
virtual CSize | GetButtonSize () const
Call this function to get the size of the command bar button.
virtual CSize | GetIconSize () const
Call this member function to get the size of a toolbar icon.
void | SetIconSize (CSize szIcon)
Call this member function to set the size of an icon for an individual control.
virtual void | Copy (CXTPControl *pControl, BOOL bRecursive=FALSE)
This method is called to copy the control.
virtual void | OnClick (BOOL bKeyboard=FALSE, CPoint pt=CPoint(0, 0))
This method is called when the user clicks the control.
virtual BOOL | IsCustomizeMovable () const
This method is called to determine if control can be repositioned in customize mode.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

virtual CSize | GetSize (CDC *pDC)
This method is called to determine the size of the control.
virtual void | Draw (CDC *pDC)
This method is called to draw the control.
- Protected Member Functions inherited from CXTPControl
CXTPControl ()
Constructs a CXTPControl object.
virtual | ~CXTPControl ()
Destroys a CXTPControl object, handles cleanup and deallocation.
virtual BOOL | IsFocusable () const
This method is called to check if the control can accept focus.
void | SetIndex (int nIndex)
This method is called to assign the order of the control in the controls list.
void | SetExpanded (BOOL bExpanded)
This method is called to set the control's expanded state.
virtual BOOL | OnHookKeyDown (UINT nChar, LPARAM lParam)
This method is called when a non-system key is pressed.
virtual BOOL | OnHookMouseWheel (UINT nFlags, short zDelta, CPoint point)
This method is called when the user rotates the mouse wheel.
virtual void | SetParent (CXTPCommandBar *pParent)
This method is called to assign a parent command bar object.
void | ScreenToClient (CPoint *point)
The ScreenToClient function converts the screen coordinates of a specified point on the screen.
void | ClickToolBarButton (CRect rcActiveRect=CRect(0, 0, 0, 0))
This helper method is called when the user clicks the toolbar's button.
virtual BOOL | OnSetPopup (BOOL bPopup)
This method is called to pop-up the control.
virtual void | OnLButtonUp (CPoint point)
This member is called when the user releases the left mouse button.
virtual void | OnLButtonDown (CPoint point)
This member is called when the user presses the left mouse button down.
virtual BOOL | OnRButtonDown (CPoint point)
This member is called when the user press the right mouse button.
virtual BOOL | OnRButtonUp (CPoint point)
This member is called when the user releases the right mouse button.
virtual BOOL | OnLButtonDblClk (CPoint point)
This member is called when the user double-clicks the left mouse button.
virtual void | OnMouseMove (CPoint point)
This member is called when the mouse cursor moves.
virtual void | OnMouseHover ()
Called after the mouse hovers over the control.
virtual BOOL | OnSetSelected (int bSelected)
This method is called when the control becomes selected.
BOOL | IsCustomizeMode () const
Call this method to determine if command bars is in customize mode.
virtual void | CustomizeStartDrag (CPoint point)
This member is called when the user starts to drag the control in customize mode.
virtual BOOL | CustomizeStartResize (CPoint point)
This method is called when user starts to resize control in customize mode.
virtual void | OnCustomizeDragOver (CXTPControl *pDataObject, CPoint point, DROPEFFECT &dropEffect)
This member is called when the user moves the mouse over the control.
virtual BOOL | DoCustomDragOver (CXTPCommandBar *pCommandBar, CPoint point, DROPEFFECT &dropEffect)
The implementation may implement a custom drag over handling logic in this method.
virtual BOOL | IsCustomizeResizeAllow () const
This member checks if the user can resize the control.
virtual int | GetCustomizeMinWidth () const
Retrieves the available minimum width of control.
virtual int | GetCustomizeMinHeight () const
Retrieves available minimum height of the control.
void | OnCustomizeMouseMove (CPoint point)
This member is called when the mouse cursor moves in customized mode.
virtual void | OnIdleUpdate ()
This virtual method is called in idle-time processing.
virtual void | OnRemoved ()
This method is called when a control is removed from the parent controls collection.
virtual INT_PTR | OnToolHitTest (CPoint point, TOOLINFO *pTI) const
The framework calls this member function to determine whether a point is in the bounding rectangle of the specified tool.
virtual void | RestoreCommandBarList (CXTPCommandBarList *pCommandBarList)
This method is called from LoadCommandBars to restore controls and its child command bars.
virtual void | GenerateCommandBarList (DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam)
This method is called from SaveCommandBars to save all child command bars.
virtual void | OnActionChanged (int nProperty)
This method is called when an action property is changed.
virtual void | OnActionChanging (int nProperty)
This method is called when an action property is about to be changed.
virtual void | OnCaptionChanged ()
This method is called when the control's caption is changed.
BOOL | IsLayoutRTL () const
Determines if right-to-left (RTL) mode is set.
BOOL | IsLayoutChanged ()
Call this member to determine if the layout has changed (RTL to LTR or LTR to RLT).

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControl
static CXTPControl *AFX_CDECL | FromUI (CCmdUI *pCmdUI)
Call this member to retrieve CXTPControl from a CCmdUI structure.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Attributes inherited from CXTPControl
DWORD_PTR | m_nTag
Control tag.
int | m_nIndex
Index of the control.
int | m_nId
Identifier of the control.
int | m_nIconId
Identifier of the control's image.
int | m_nHelpId
Help identifier.
int | m_nCustomIconId
Identifier of the control's custom image.
BOOL | m_bWrap
TRUE if the control is wrapped.
BOOL | m_bBeginGroup
TRUE if the control starts new group.
BOOL | m_bEnabled
TRUE if the control is enabled.
BOOL | m_bChecked
TRUE if the control is checked.
BOOL | m_bSelected
TRUE if the control is selected.
BOOL | m_bPressed
TRUE if the control is pushed.
BOOL | m_bTemporary
TRUE if the control is temporary.
BOOL | m_bOnQuickAccess
TRUE if the control is a part of Quick Access panel.
CRect | m_rcRow
Bounding rectangle of the control's row.
CRect | m_rcControl
Bounding rectangle of the control.
DWORD | m_dwHideFlags
Hidden flags.
DWORD | m_dwFlags
Flags of the control.
CString | m_strCaption
Caption of the control.
CString | m_strCustomCaption
User-defined caption.
CString | m_strShortcutText
Shortcut text.
CString | m_strShortcutTextAuto
Shortcut text.
CString | m_strTooltipText
Tooltip text.
CString | m_strDescriptionText
Description text.
CString | m_strParameter
Parameter text.
CString | m_strKeyboardTip
Keyboard tip.
CXTPControls * | m_pControls
Parent control collection.
XTPControlType | m_controlType
Type of the control.
CXTPCommandBar * | m_pParent
The Parent command bar.
BOOL | m_bExpanded
TRUE if the control is expanded.
CString | m_strCategory
Category of the control.
BOOL | m_bDefaultItem
TRUE if the item is default pop-up item.
CDocTemplateMap | m_mapDocTemplatesAssigned
Assigned templates.
CDocTemplateMap | m_mapDocTemplatesExcluded
Excluded templates.
XTPButtonStyle | m_buttonStyle
Button Style.
XTPButtonStyle | m_buttonCustomStyle
User-defined style of button.
XTPButtonStyle | m_buttonRibbonStyle
User-defined style of button.
BOOL | m_bCloseSubMenuOnClick
TRUE is sub-menus are closed as soon as a control is clicked.
CXTPRibbonGroup * | m_pRibbonGroup
Ribbon group of control.
CXTPControlAction * | m_pAction
Action of the control.
int | m_nWidth
Width of the control.
int | m_nHeight
Height of the control.
int | m_nExecuteOnPressInterval
Delay between each message when control is pressed.
CSize | m_szIcon
The size of the icon used for the control.
BOOL | m_bLayoutRTL
Indicate does last layout is RTL.

Detailed Description

CXTPRibbonControlSystemPopupBarListCaption is a CXTPControl derived class used in a Ribbon system pop-up to draw captions of enumerable controls.

Member Function Documentation

◆ Draw()

virtual void Draw ( CDC * pDC )
protectedvirtual

This method is called to draw the control.

Parameters
pDC Pointer to a valid device context.

Reimplemented from CXTPControl.

◆ GetSize()

virtual CSize GetSize ( CDC * pDC )
protectedvirtual

This method is called to determine the size of the control.

Parameters
pDC Pointer to a valid device context.
Returns
The size of the control.

Reimplemented from CXTPControl.

The documentation for this class was generated from the following file:
  • XTPRibbonSystemButton.h


Toolkit Pro: CXTPRibbonControlSystemPopupBarListItem Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPRibbonControlSystemPopupBarListItem Class Reference

CXTPRibbonControlSystemPopupBarListItem is a CXTPControlButton derived class used in a Ribbon system pop-up to draw buttons of enumerable controls. More...

Inheritance diagram for CXTPRibbonControlSystemPopupBarListItem:
[legend]

Public Member Functions

CXTPRibbonControlSystemPopupBarListItem ()
Constructs a CXTPRibbonControlSystemPopupBarListItem object.
virtual CSize | GetSize (CDC *pDC)
This method is called to determine the size of the control.
virtual void | Draw (CDC *pDC)
This method is called to draw the control.
- Public Member Functions inherited from CXTPControlButton
CXTPControlButton ()
Constructs a CXTPControlButton object.
virtual | ~CXTPControlButton ()
Destroys a CXTPControlButton object, handles cleanup and deallocation.
void | SetStyleEx (XTPButtonStyle buttonStyle)
Call this member to set the style of the button containing vector icon.
XTPButtonStyle | GetStyleEx () const
Call this member to get the button's style containing vector icon.
void | DoPropExchange (CXTPPropExchange *pPX)
Either reads this object from or writes this object to an archive.
- Public Member Functions inherited from CXTPControl
void | SetStyle (XTPButtonStyle buttonStyle)
Call this member to set the style of the control.
XTPButtonStyle | GetStyle () const
Call this member to get the control's style.
void | SetCaption (LPCTSTR lpszCaption)
Call this member to set the caption of the control.
void | SetCaption (UINT nIDCaption)
Call this member to set the caption of the control.
virtual CString | GetCaption () const
Call this member to get the control's caption.
void | SetShortcutText (LPCTSTR lpszShortcutText)
Call this member to set the shortcut string to the control.
CString | GetShortcutText () const
Call this member to get the control's shortcut.
void | SetDescription (LPCTSTR lpszDescription)
Call this member to set the description of the control.
virtual CString | GetDescription () const
Call this member to get the control's description.
void | SetTooltip (LPCTSTR lpszTooltip)
Call this member to set the tooltip of the control.
virtual CString | GetTooltip () const
Call this member to get the control's tooltip.
void | SetKeyboardTip (LPCTSTR lpszKeyboardTip)
Call this member to set the keyboard tip to the control.
CString | GetKeyboardTip () const
Call this member to get the keyboard tip.
void | SetCustomShortcutText (LPCTSTR lpszCustomShortcutText)
Call this member to set the text displayed for the shortcut in a pop-up menu.
CString | GetCustomShortcutText () const
Call this member to get the control's text displayed for the shortcut in a pop-up menu.
void | SetParameter (LPCTSTR lpszParameter)
Call this member to set the parameter of the control.
CString | GetParameter () const
Call this member to get the control's parameter.
void | SetID (int nId)
Call this member to set the identifier of the control.
int | GetID () const
Call this member to get the control's identifier.
long | GetIndex () const
Call this member to get the index of the control.
void | SetIconId (int nId)
Call this member to set the control icon's identifier.
int | GetIconId () const
Call this member to get the icon's identifier.
void | SetHelpId (int nId)
Call this member to set the control help identifier.
int | GetHelpId () const
Call this member to get the help identifier.
virtual void | SetBeginGroup (BOOL bBeginGroup)
Call this member to begin a new group using a separator.
BOOL | GetBeginGroup () const
Call this member to determine if the control has a separator.
virtual void | SetEnabled (BOOL bEnabled)
Call this member to enable/disable the control.
BOOL | GetEnabled () const
Call this member to check if the control is enabled.
virtual void | OnEnabledChanged ()
This method is called when a control's enabled state is changed.
virtual void | SetChecked (BOOL bChecked)
Call this member to set the checked state of the control.
BOOL | GetChecked () const
Call this member to get the checked state of the control.
virtual int | GetSelected () const
Call this member to check if the control is selected.
void | SetOnQuickAccess (BOOL bOnQuicAccess=FALSE)
Call this member to set whether a control should be a part of the Quick Access panel.
BOOL | IsOnQuickAccess () const
Call this member to check if a control is a part of the Quick Access panel.
virtual void | SetFocused (BOOL bFocused)
Call this member to set the focused state of the control.
virtual BOOL | IsFocused () const
Call this member to check the focused state of the control.
void | SetPressed (BOOL bPressed)
Call this member to set the pressed state of the control.
virtual BOOL | GetPressed () const
Call this member to check the pressed state of the control.
virtual void | SetRect (CRect rcControl)
This member is called to set the bounding rectangle of the control.
CRect | GetRect () const
Call this member to get the bounding rectangle of the control.
CXTPCommandBar * | GetParent () const
Call this member to get the parent command bar.
virtual BOOL | IsVisible (DWORD dwSkipFlags=0) const
Call this member to determine if the control is visible.
virtual BOOL | IsCaptionVisible () const
Call this member to determine if the caption of the control is visible.
void | SetVisible (BOOL bVisible)
Call this member to set the visibility of the control.
CXTPControls * | GetControls () const
Call this member to get the parent controls collection.
XTPControlType | GetType () const
Call this member to get the control's type.
void | SetFlags (DWORD dwFlags)
Call this member to set the flags of the control.
DWORD | GetFlags () const
Call this member to retrieve control special flags.
void | SetTag (DWORD_PTR dwTag)
This method sets the 32-bit value associated with the control.
DWORD_PTR | GetTag () const
This method retrieves the application-supplied, 32-bit value associated with the control.
virtual BOOL | Compare (CXTPControl *pOther)
Call this member to compare controls.
virtual CXTPCommandBar * | GetCommandBar () const
Call this member to get the child command bar.
void | SetCloseSubMenuOnClick (BOOL bCloseOnClick)
Call this member function to enable/disable the closing of sub-menus when a control is clicked in the menu.
BOOL | GetCloseSubMenuOnClick () const
Call this member function to check if sub-menus will close as soon as a control is clicked.
void | SetExecuteOnPressInterval (int nExecuteOnPressInterval)
Call this method to set the delay (in milliseconds) between WM_COMMAND messages while a button is pressed by the user.
int | GetExecuteOnPressInterval () const
Call this method to get the delay (in milliseconds) between WM_COMMAND messages while a button is pressed by the user.
CXTPRibbonGroup * | GetRibbonGroup () const
Returns the ribbon group that the control belongs to.
virtual BOOL | IsTransparent () const
Determines if the control needs to draw its background.
void | SetHideWrap (BOOL bHide)
This method is called to hide the control.
virtual void | SetHideFlags (DWORD dwFlags)
This method is called to hide the control.
BOOL | SetHideFlag (XTPControlHideFlags dwFlag, BOOL bSet)
Call this member to set/remove hide flags.
DWORD | GetHideFlags () const
Call this method to retrieve hidden flags.
CRect | GetRowRect () const
Call this method to retrieve the position of the control's row.
BOOL | GetWrap () const
Call this method to check if the control is wrapped.
void | SetRowRect (CRect rcRow)
Call this method to set the row of the control.
void | SetWrap (BOOL bWrap)
Call this member to set the control to wrapped.
BOOL | GetExpanded () const
Call this member to check if the control is expanded.
BOOL | IsCursorOver () const
Call this member to determine if the mouse pointer is over the control.
virtual void | OnExecute ()
This method is called when the control is executed.
virtual void | OnCalcDynamicSize (DWORD dwMode)
This method is called before recalculating the parent command bar size to calculate the dimensions of the control.
void | DelayRedrawParent ()
Call this method to redraw the parent command bar.
void | DelayLayoutParent ()
Call this method to recalculate the parent command bar size.
void | SetCategory (LPCTSTR lpszCategory)
Call this method to set the category of the control.
CString | GetCategory () const
Call this method to retrieve the category of the control.
CXTPImageManager * | GetImageManager () const
Call this method to retrieve the image manager.
CXTPPaintManager * | GetPaintManager () const
Call this method to retrieve the paint manager.
virtual CXTPImageManagerIcon * | GetImage (int nWidth=16) const
Call this method to retrieve the image of the control.
void | AssignDocTemplate (UINT nIDResource)
Call this method to assign a document template to the control.
void | ExcludeDocTemplate (UINT nIDResource)
Call this method to exclude the document template from control.
BOOL | IsItemDefault () const
Call this method to check if a control is a default menu item.
void | SetItemDefault (BOOL bDefault)
Call this method to set a control to be a default menu item.
BOOL | IsTemporary () const
Call this method to determine if a control is temporary.
void | Reset ()
Call this member to reset the icon and caption of a control to its default settings before it was customized by the user.
void | SetPrompt (LPCTSTR lpszPrompt)
Call this member to load a string from a STRINGTABLE resource to set the tooltip and description of a control.
void | SetCustomIcon (HICON hIcon)
Call this member to set a custom icon to this control.
virtual void | OnUnderlineActivate ()
This method is called when the user activates the control using its underline.
virtual BOOL | GetPopuped () const
Call this member to get the control's pop-up state.
void | RedrawParent (BOOL bAnimate=TRUE)
This method is called to redraw the parent command bar.
LRESULT | NotifySite (UINT code)
This method is called to send message code to the parent site window.
LRESULT | NotifySite (UINT code, NMXTPCONTROL *pNM)
This method is called to send message code to the parent site window.
LRESULT | NotifySite (CWnd *pSite, UINT code, NMXTPCONTROL *pNM)
This method is called to send message code to the parent site window.
virtual void | SetAction (CXTPControlAction *pAction)
Call this method to manually assign an action for control.
CXTPControlAction * | GetAction () const
Call this method to retrieve an action associated with control.
virtual void | OnThemeChanged ()
This method is called when the paint manager theme is changed.
virtual void | SetWidth (int nWidth)
Call this member to set the width of the control.
virtual void | SetHeight (int nHeight)
Call this member to set the height of the control.
int | GetWidth () const
Call this member to get the width of the control.
int | GetHeight () const
Call this member to get the height of the control.
BOOL | HasDwmCompositedRect () const
This method is called to determine if control has a Vista DWM transparent area.
virtual CSize | GetButtonSize () const
Call this function to get the size of the command bar button.
virtual CSize | GetIconSize () const
Call this member function to get the size of a toolbar icon.
void | SetIconSize (CSize szIcon)
Call this member function to set the size of an icon for an individual control.
virtual BOOL | IsCustomizeMovable () const
This method is called to determine if control can be repositioned in customize mode.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Attributes

BOOL | m_bAlignShortcut
Alignment of the shortcut in the list.
- Protected Attributes inherited from CXTPControlButton
XTPButtonStyle | m_buttonStyleEx
User-defined style of button containing vector icon.
- Protected Attributes inherited from CXTPControl
DWORD_PTR | m_nTag
Control tag.
int | m_nIndex
Index of the control.
int | m_nId
Identifier of the control.
int | m_nIconId
Identifier of the control's image.
int | m_nHelpId
Help identifier.
int | m_nCustomIconId
Identifier of the control's custom image.
BOOL | m_bWrap
TRUE if the control is wrapped.
BOOL | m_bBeginGroup
TRUE if the control starts new group.
BOOL | m_bEnabled
TRUE if the control is enabled.
BOOL | m_bChecked
TRUE if the control is checked.
BOOL | m_bSelected
TRUE if the control is selected.
BOOL | m_bPressed
TRUE if the control is pushed.
BOOL | m_bTemporary
TRUE if the control is temporary.
BOOL | m_bOnQuickAccess
TRUE if the control is a part of Quick Access panel.
CRect | m_rcRow
Bounding rectangle of the control's row.
CRect | m_rcControl
Bounding rectangle of the control.
DWORD | m_dwHideFlags
Hidden flags.
DWORD | m_dwFlags
Flags of the control.
CString | m_strCaption
Caption of the control.
CString | m_strCustomCaption
User-defined caption.
CString | m_strShortcutText
Shortcut text.
CString | m_strShortcutTextAuto
Shortcut text.
CString | m_strTooltipText
Tooltip text.
CString | m_strDescriptionText
Description text.
CString | m_strParameter
Parameter text.
CString | m_strKeyboardTip
Keyboard tip.
CXTPControls * | m_pControls
Parent control collection.
XTPControlType | m_controlType
Type of the control.
CXTPCommandBar * | m_pParent
The Parent command bar.
BOOL | m_bExpanded
TRUE if the control is expanded.
CString | m_strCategory
Category of the control.
BOOL | m_bDefaultItem
TRUE if the item is default pop-up item.
CDocTemplateMap | m_mapDocTemplatesAssigned
Assigned templates.
CDocTemplateMap | m_mapDocTemplatesExcluded
Excluded templates.
XTPButtonStyle | m_buttonStyle
Button Style.
XTPButtonStyle | m_buttonCustomStyle
User-defined style of button.
XTPButtonStyle | m_buttonRibbonStyle
User-defined style of button.
BOOL | m_bCloseSubMenuOnClick
TRUE is sub-menus are closed as soon as a control is clicked.
CXTPRibbonGroup * | m_pRibbonGroup
Ribbon group of control.
CXTPControlAction * | m_pAction
Action of the control.
int | m_nWidth
Width of the control.
int | m_nHeight
Height of the control.
int | m_nExecuteOnPressInterval
Delay between each message when control is pressed.
CSize | m_szIcon
The size of the icon used for the control.
BOOL | m_bLayoutRTL
Indicate does last layout is RTL.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControl
static CXTPControl *AFX_CDECL | FromUI (CCmdUI *pCmdUI)
Call this member to retrieve CXTPControl from a CCmdUI structure.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Member Functions inherited from CXTPControlButton
virtual void | OnClick (BOOL bKeyboard=FALSE, CPoint pt=CPoint(0, 0))
This method is called when the user clicks the control.
virtual void | OnLButtonUp (CPoint point)
This member is called when the user releases the left mouse button.
virtual void | Copy (CXTPControl *pControl, BOOL bRecursive=FALSE)
This method is called to copy the control.
- Protected Member Functions inherited from CXTPControl
CXTPControl ()
Constructs a CXTPControl object.
virtual | ~CXTPControl ()
Destroys a CXTPControl object, handles cleanup and deallocation.
virtual BOOL | IsFocusable () const
This method is called to check if the control can accept focus.
void | SetIndex (int nIndex)
This method is called to assign the order of the control in the controls list.
void | SetExpanded (BOOL bExpanded)
This method is called to set the control's expanded state.
virtual BOOL | OnHookKeyDown (UINT nChar, LPARAM lParam)
This method is called when a non-system key is pressed.
virtual BOOL | OnHookMouseWheel (UINT nFlags, short zDelta, CPoint point)
This method is called when the user rotates the mouse wheel.
virtual void | SetParent (CXTPCommandBar *pParent)
This method is called to assign a parent command bar object.
void | ScreenToClient (CPoint *point)
The ScreenToClient function converts the screen coordinates of a specified point on the screen.
void | ClickToolBarButton (CRect rcActiveRect=CRect(0, 0, 0, 0))
This helper method is called when the user clicks the toolbar's button.
virtual BOOL | OnSetPopup (BOOL bPopup)
This method is called to pop-up the control.
virtual void | OnLButtonDown (CPoint point)
This member is called when the user presses the left mouse button down.
virtual BOOL | OnRButtonDown (CPoint point)
This member is called when the user press the right mouse button.
virtual BOOL | OnRButtonUp (CPoint point)
This member is called when the user releases the right mouse button.
virtual BOOL | OnLButtonDblClk (CPoint point)
This member is called when the user double-clicks the left mouse button.
virtual void | OnMouseMove (CPoint point)
This member is called when the mouse cursor moves.
virtual void | OnMouseHover ()
Called after the mouse hovers over the control.
virtual BOOL | OnSetSelected (int bSelected)
This method is called when the control becomes selected.
BOOL | IsCustomizeMode () const
Call this method to determine if command bars is in customize mode.
virtual void | CustomizeStartDrag (CPoint point)
This member is called when the user starts to drag the control in customize mode.
virtual BOOL | CustomizeStartResize (CPoint point)
This method is called when user starts to resize control in customize mode.
virtual void | OnCustomizeDragOver (CXTPControl *pDataObject, CPoint point, DROPEFFECT &dropEffect)
This member is called when the user moves the mouse over the control.
virtual BOOL | DoCustomDragOver (CXTPCommandBar *pCommandBar, CPoint point, DROPEFFECT &dropEffect)
The implementation may implement a custom drag over handling logic in this method.
virtual BOOL | IsCustomizeResizeAllow () const
This member checks if the user can resize the control.
virtual int | GetCustomizeMinWidth () const
Retrieves the available minimum width of control.
virtual int | GetCustomizeMinHeight () const
Retrieves available minimum height of the control.
void | OnCustomizeMouseMove (CPoint point)
This member is called when the mouse cursor moves in customized mode.
virtual void | OnIdleUpdate ()
This virtual method is called in idle-time processing.
virtual void | OnRemoved ()
This method is called when a control is removed from the parent controls collection.
virtual INT_PTR | OnToolHitTest (CPoint point, TOOLINFO *pTI) const
The framework calls this member function to determine whether a point is in the bounding rectangle of the specified tool.
virtual void | RestoreCommandBarList (CXTPCommandBarList *pCommandBarList)
This method is called from LoadCommandBars to restore controls and its child command bars.
virtual void | GenerateCommandBarList (DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam)
This method is called from SaveCommandBars to save all child command bars.
virtual void | OnActionChanged (int nProperty)
This method is called when an action property is changed.
virtual void | OnActionChanging (int nProperty)
This method is called when an action property is about to be changed.
virtual void | OnCaptionChanged ()
This method is called when the control's caption is changed.
BOOL | IsLayoutRTL () const
Determines if right-to-left (RTL) mode is set.
BOOL | IsLayoutChanged ()
Call this member to determine if the layout has changed (RTL to LTR or LTR to RLT).

Detailed Description

CXTPRibbonControlSystemPopupBarListItem is a CXTPControlButton derived class used in a Ribbon system pop-up to draw buttons of enumerable controls.

Member Function Documentation

◆ Draw()

virtual void Draw ( CDC * pDC )
virtual

This method is called to draw the control.

Parameters
pDC Pointer to a valid device context.

Reimplemented from CXTPControl.

Reimplemented in CXTPRibbonControlSystemPopupBarPinableListItem.

◆ GetSize()

virtual CSize GetSize ( CDC * pDC )
virtual

This method is called to determine the size of the control.

Parameters
pDC Pointer to a valid device context.
Returns
The size of the control.

Reimplemented from CXTPControl.

The documentation for this class was generated from the following file:
  • XTPRibbonSystemButton.h


Toolkit Pro: CXTPRibbonControlSystemPopupBarPinableListItem Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPRibbonControlSystemPopupBarPinableListItem Class Reference

CXTPRibbonControlSystemPopupBarPinableListItem is a CXTPRibbonControlSystemPopupBarListItem derived class used in a Ribbon system pop-up to draw recent file list items. More...

Inheritance diagram for CXTPRibbonControlSystemPopupBarPinableListItem:
[legend]

Public Member Functions

CXTPRibbonControlSystemPopupBarPinableListItem ()
Constructs a CXTPRibbonControlSystemPopupBarListItem object.
~CXTPRibbonControlSystemPopupBarPinableListItem ()
Destroys a CXTPRibbonControlSystemPopupBarPinableListItem object, handles cleanup and deallocation.
- Public Member Functions inherited from CXTPRibbonControlSystemPopupBarListItem
CXTPRibbonControlSystemPopupBarListItem ()
Constructs a CXTPRibbonControlSystemPopupBarListItem object.
virtual CSize | GetSize (CDC *pDC)
This method is called to determine the size of the control.
- Public Member Functions inherited from CXTPControlButton
CXTPControlButton ()
Constructs a CXTPControlButton object.
virtual | ~CXTPControlButton ()
Destroys a CXTPControlButton object, handles cleanup and deallocation.
void | SetStyleEx (XTPButtonStyle buttonStyle)
Call this member to set the style of the button containing vector icon.
XTPButtonStyle | GetStyleEx () const
Call this member to get the button's style containing vector icon.
void | DoPropExchange (CXTPPropExchange *pPX)
Either reads this object from or writes this object to an archive.
- Public Member Functions inherited from CXTPControl
void | SetStyle (XTPButtonStyle buttonStyle)
Call this member to set the style of the control.
XTPButtonStyle | GetStyle () const
Call this member to get the control's style.
void | SetCaption (LPCTSTR lpszCaption)
Call this member to set the caption of the control.
void | SetCaption (UINT nIDCaption)
Call this member to set the caption of the control.
virtual CString | GetCaption () const
Call this member to get the control's caption.
void | SetShortcutText (LPCTSTR lpszShortcutText)
Call this member to set the shortcut string to the control.
CString | GetShortcutText () const
Call this member to get the control's shortcut.
void | SetDescription (LPCTSTR lpszDescription)
Call this member to set the description of the control.
virtual CString | GetDescription () const
Call this member to get the control's description.
void | SetTooltip (LPCTSTR lpszTooltip)
Call this member to set the tooltip of the control.
virtual CString | GetTooltip () const
Call this member to get the control's tooltip.
void | SetKeyboardTip (LPCTSTR lpszKeyboardTip)
Call this member to set the keyboard tip to the control.
CString | GetKeyboardTip () const
Call this member to get the keyboard tip.
void | SetCustomShortcutText (LPCTSTR lpszCustomShortcutText)
Call this member to set the text displayed for the shortcut in a pop-up menu.
CString | GetCustomShortcutText () const
Call this member to get the control's text displayed for the shortcut in a pop-up menu.
void | SetParameter (LPCTSTR lpszParameter)
Call this member to set the parameter of the control.
CString | GetParameter () const
Call this member to get the control's parameter.
void | SetID (int nId)
Call this member to set the identifier of the control.
int | GetID () const
Call this member to get the control's identifier.
long | GetIndex () const
Call this member to get the index of the control.
void | SetIconId (int nId)
Call this member to set the control icon's identifier.
int | GetIconId () const
Call this member to get the icon's identifier.
void | SetHelpId (int nId)
Call this member to set the control help identifier.
int | GetHelpId () const
Call this member to get the help identifier.
virtual void | SetBeginGroup (BOOL bBeginGroup)
Call this member to begin a new group using a separator.
BOOL | GetBeginGroup () const
Call this member to determine if the control has a separator.
virtual void | SetEnabled (BOOL bEnabled)
Call this member to enable/disable the control.
BOOL | GetEnabled () const
Call this member to check if the control is enabled.
virtual void | OnEnabledChanged ()
This method is called when a control's enabled state is changed.
virtual void | SetChecked (BOOL bChecked)
Call this member to set the checked state of the control.
BOOL | GetChecked () const
Call this member to get the checked state of the control.
virtual int | GetSelected () const
Call this member to check if the control is selected.
void | SetOnQuickAccess (BOOL bOnQuicAccess=FALSE)
Call this member to set whether a control should be a part of the Quick Access panel.
BOOL | IsOnQuickAccess () const
Call this member to check if a control is a part of the Quick Access panel.
virtual void | SetFocused (BOOL bFocused)
Call this member to set the focused state of the control.
virtual BOOL | IsFocused () const
Call this member to check the focused state of the control.
void | SetPressed (BOOL bPressed)
Call this member to set the pressed state of the control.
virtual BOOL | GetPressed () const
Call this member to check the pressed state of the control.
virtual void | SetRect (CRect rcControl)
This member is called to set the bounding rectangle of the control.
CRect | GetRect () const
Call this member to get the bounding rectangle of the control.
CXTPCommandBar * | GetParent () const
Call this member to get the parent command bar.
virtual BOOL | IsVisible (DWORD dwSkipFlags=0) const
Call this member to determine if the control is visible.
virtual BOOL | IsCaptionVisible () const
Call this member to determine if the caption of the control is visible.
void | SetVisible (BOOL bVisible)
Call this member to set the visibility of the control.
CXTPControls * | GetControls () const
Call this member to get the parent controls collection.
XTPControlType | GetType () const
Call this member to get the control's type.
void | SetFlags (DWORD dwFlags)
Call this member to set the flags of the control.
DWORD | GetFlags () const
Call this member to retrieve control special flags.
void | SetTag (DWORD_PTR dwTag)
This method sets the 32-bit value associated with the control.
DWORD_PTR | GetTag () const
This method retrieves the application-supplied, 32-bit value associated with the control.
virtual BOOL | Compare (CXTPControl *pOther)
Call this member to compare controls.
virtual CXTPCommandBar * | GetCommandBar () const
Call this member to get the child command bar.
void | SetCloseSubMenuOnClick (BOOL bCloseOnClick)
Call this member function to enable/disable the closing of sub-menus when a control is clicked in the menu.
BOOL | GetCloseSubMenuOnClick () const
Call this member function to check if sub-menus will close as soon as a control is clicked.
void | SetExecuteOnPressInterval (int nExecuteOnPressInterval)
Call this method to set the delay (in milliseconds) between WM_COMMAND messages while a button is pressed by the user.
int | GetExecuteOnPressInterval () const
Call this method to get the delay (in milliseconds) between WM_COMMAND messages while a button is pressed by the user.
CXTPRibbonGroup * | GetRibbonGroup () const
Returns the ribbon group that the control belongs to.
virtual BOOL | IsTransparent () const
Determines if the control needs to draw its background.
void | SetHideWrap (BOOL bHide)
This method is called to hide the control.
virtual void | SetHideFlags (DWORD dwFlags)
This method is called to hide the control.
BOOL | SetHideFlag (XTPControlHideFlags dwFlag, BOOL bSet)
Call this member to set/remove hide flags.
DWORD | GetHideFlags () const
Call this method to retrieve hidden flags.
CRect | GetRowRect () const
Call this method to retrieve the position of the control's row.
BOOL | GetWrap () const
Call this method to check if the control is wrapped.
void | SetRowRect (CRect rcRow)
Call this method to set the row of the control.
void | SetWrap (BOOL bWrap)
Call this member to set the control to wrapped.
BOOL | GetExpanded () const
Call this member to check if the control is expanded.
BOOL | IsCursorOver () const
Call this member to determine if the mouse pointer is over the control.
virtual void | OnExecute ()
This method is called when the control is executed.
virtual void | OnCalcDynamicSize (DWORD dwMode)
This method is called before recalculating the parent command bar size to calculate the dimensions of the control.
void | DelayRedrawParent ()
Call this method to redraw the parent command bar.
void | DelayLayoutParent ()
Call this method to recalculate the parent command bar size.
void | SetCategory (LPCTSTR lpszCategory)
Call this method to set the category of the control.
CString | GetCategory () const
Call this method to retrieve the category of the control.
CXTPImageManager * | GetImageManager () const
Call this method to retrieve the image manager.
CXTPPaintManager * | GetPaintManager () const
Call this method to retrieve the paint manager.
virtual CXTPImageManagerIcon * | GetImage (int nWidth=16) const
Call this method to retrieve the image of the control.
void | AssignDocTemplate (UINT nIDResource)
Call this method to assign a document template to the control.
void | ExcludeDocTemplate (UINT nIDResource)
Call this method to exclude the document template from control.
BOOL | IsItemDefault () const
Call this method to check if a control is a default menu item.
void | SetItemDefault (BOOL bDefault)
Call this method to set a control to be a default menu item.
BOOL | IsTemporary () const
Call this method to determine if a control is temporary.
void | Reset ()
Call this member to reset the icon and caption of a control to its default settings before it was customized by the user.
void | SetPrompt (LPCTSTR lpszPrompt)
Call this member to load a string from a STRINGTABLE resource to set the tooltip and description of a control.
void | SetCustomIcon (HICON hIcon)
Call this member to set a custom icon to this control.
virtual void | OnUnderlineActivate ()
This method is called when the user activates the control using its underline.
virtual BOOL | GetPopuped () const
Call this member to get the control's pop-up state.
void | RedrawParent (BOOL bAnimate=TRUE)
This method is called to redraw the parent command bar.
LRESULT | NotifySite (UINT code)
This method is called to send message code to the parent site window.
LRESULT | NotifySite (UINT code, NMXTPCONTROL *pNM)
This method is called to send message code to the parent site window.
LRESULT | NotifySite (CWnd *pSite, UINT code, NMXTPCONTROL *pNM)
This method is called to send message code to the parent site window.
virtual void | SetAction (CXTPControlAction *pAction)
Call this method to manually assign an action for control.
CXTPControlAction * | GetAction () const
Call this method to retrieve an action associated with control.
virtual void | OnThemeChanged ()
This method is called when the paint manager theme is changed.
virtual void | SetWidth (int nWidth)
Call this member to set the width of the control.
virtual void | SetHeight (int nHeight)
Call this member to set the height of the control.
int | GetWidth () const
Call this member to get the width of the control.
int | GetHeight () const
Call this member to get the height of the control.
BOOL | HasDwmCompositedRect () const
This method is called to determine if control has a Vista DWM transparent area.
virtual CSize | GetButtonSize () const
Call this function to get the size of the command bar button.
virtual CSize | GetIconSize () const
Call this member function to get the size of a toolbar icon.
void | SetIconSize (CSize szIcon)
Call this member function to set the size of an icon for an individual control.
virtual BOOL | IsCustomizeMovable () const
This method is called to determine if control can be repositioned in customize mode.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

virtual void | Draw (CDC *pDC)
This method is called to draw the control.
virtual void | OnMouseMove (CPoint point)
This member is called when the mouse cursor moves.
virtual void | OnLButtonUp (CPoint point)
This member is called when the user releases the left mouse button.
virtual BOOL | OnSetSelected (int bSelected)
This method is called when the MRU item becomes selected.
- Protected Member Functions inherited from CXTPControlButton
virtual void | OnClick (BOOL bKeyboard=FALSE, CPoint pt=CPoint(0, 0))
This method is called when the user clicks the control.
virtual void | Copy (CXTPControl *pControl, BOOL bRecursive=FALSE)
This method is called to copy the control.
- Protected Member Functions inherited from CXTPControl
CXTPControl ()
Constructs a CXTPControl object.
virtual | ~CXTPControl ()
Destroys a CXTPControl object, handles cleanup and deallocation.
virtual BOOL | IsFocusable () const
This method is called to check if the control can accept focus.
void | SetIndex (int nIndex)
This method is called to assign the order of the control in the controls list.
void | SetExpanded (BOOL bExpanded)
This method is called to set the control's expanded state.
virtual BOOL | OnHookKeyDown (UINT nChar, LPARAM lParam)
This method is called when a non-system key is pressed.
virtual BOOL | OnHookMouseWheel (UINT nFlags, short zDelta, CPoint point)
This method is called when the user rotates the mouse wheel.
virtual void | SetParent (CXTPCommandBar *pParent)
This method is called to assign a parent command bar object.
void | ScreenToClient (CPoint *point)
The ScreenToClient function converts the screen coordinates of a specified point on the screen.
void | ClickToolBarButton (CRect rcActiveRect=CRect(0, 0, 0, 0))
This helper method is called when the user clicks the toolbar's button.
virtual BOOL | OnSetPopup (BOOL bPopup)
This method is called to pop-up the control.
virtual void | OnLButtonDown (CPoint point)
This member is called when the user presses the left mouse button down.
virtual BOOL | OnRButtonDown (CPoint point)
This member is called when the user press the right mouse button.
virtual BOOL | OnRButtonUp (CPoint point)
This member is called when the user releases the right mouse button.
virtual BOOL | OnLButtonDblClk (CPoint point)
This member is called when the user double-clicks the left mouse button.
virtual void | OnMouseHover ()
Called after the mouse hovers over the control.
BOOL | IsCustomizeMode () const
Call this method to determine if command bars is in customize mode.
virtual void | CustomizeStartDrag (CPoint point)
This member is called when the user starts to drag the control in customize mode.
virtual BOOL | CustomizeStartResize (CPoint point)
This method is called when user starts to resize control in customize mode.
virtual void | OnCustomizeDragOver (CXTPControl *pDataObject, CPoint point, DROPEFFECT &dropEffect)
This member is called when the user moves the mouse over the control.
virtual BOOL | DoCustomDragOver (CXTPCommandBar *pCommandBar, CPoint point, DROPEFFECT &dropEffect)
The implementation may implement a custom drag over handling logic in this method.
virtual BOOL | IsCustomizeResizeAllow () const
This member checks if the user can resize the control.
virtual int | GetCustomizeMinWidth () const
Retrieves the available minimum width of control.
virtual int | GetCustomizeMinHeight () const
Retrieves available minimum height of the control.
void | OnCustomizeMouseMove (CPoint point)
This member is called when the mouse cursor moves in customized mode.
virtual void | OnIdleUpdate ()
This virtual method is called in idle-time processing.
virtual void | OnRemoved ()
This method is called when a control is removed from the parent controls collection.
virtual INT_PTR | OnToolHitTest (CPoint point, TOOLINFO *pTI) const
The framework calls this member function to determine whether a point is in the bounding rectangle of the specified tool.
virtual void | RestoreCommandBarList (CXTPCommandBarList *pCommandBarList)
This method is called from LoadCommandBars to restore controls and its child command bars.
virtual void | GenerateCommandBarList (DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam)
This method is called from SaveCommandBars to save all child command bars.
virtual void | OnActionChanged (int nProperty)
This method is called when an action property is changed.
virtual void | OnActionChanging (int nProperty)
This method is called when an action property is about to be changed.
virtual void | OnCaptionChanged ()
This method is called when the control's caption is changed.
BOOL | IsLayoutRTL () const
Determines if right-to-left (RTL) mode is set.
BOOL | IsLayoutChanged ()
Call this member to determine if the layout has changed (RTL to LTR or LTR to RLT).

Protected Attributes

CXTPImageManager * | m_pIcons
Icons used for the MRU item.
- Protected Attributes inherited from CXTPRibbonControlSystemPopupBarListItem
BOOL | m_bAlignShortcut
Alignment of the shortcut in the list.
- Protected Attributes inherited from CXTPControlButton
XTPButtonStyle | m_buttonStyleEx
User-defined style of button containing vector icon.
- Protected Attributes inherited from CXTPControl
DWORD_PTR | m_nTag
Control tag.
int | m_nIndex
Index of the control.
int | m_nId
Identifier of the control.
int | m_nIconId
Identifier of the control's image.
int | m_nHelpId
Help identifier.
int | m_nCustomIconId
Identifier of the control's custom image.
BOOL | m_bWrap
TRUE if the control is wrapped.
BOOL | m_bBeginGroup
TRUE if the control starts new group.
BOOL | m_bEnabled
TRUE if the control is enabled.
BOOL | m_bChecked
TRUE if the control is checked.
BOOL | m_bSelected
TRUE if the control is selected.
BOOL | m_bPressed
TRUE if the control is pushed.
BOOL | m_bTemporary
TRUE if the control is temporary.
BOOL | m_bOnQuickAccess
TRUE if the control is a part of Quick Access panel.
CRect | m_rcRow
Bounding rectangle of the control's row.
CRect | m_rcControl
Bounding rectangle of the control.
DWORD | m_dwHideFlags
Hidden flags.
DWORD | m_dwFlags
Flags of the control.
CString | m_strCaption
Caption of the control.
CString | m_strCustomCaption
User-defined caption.
CString | m_strShortcutText
Shortcut text.
CString | m_strShortcutTextAuto
Shortcut text.
CString | m_strTooltipText
Tooltip text.
CString | m_strDescriptionText
Description text.
CString | m_strParameter
Parameter text.
CString | m_strKeyboardTip
Keyboard tip.
CXTPControls * | m_pControls
Parent control collection.
XTPControlType | m_controlType
Type of the control.
CXTPCommandBar * | m_pParent
The Parent command bar.
BOOL | m_bExpanded
TRUE if the control is expanded.
CString | m_strCategory
Category of the control.
BOOL | m_bDefaultItem
TRUE if the item is default pop-up item.
CDocTemplateMap | m_mapDocTemplatesAssigned
Assigned templates.
CDocTemplateMap | m_mapDocTemplatesExcluded
Excluded templates.
XTPButtonStyle | m_buttonStyle
Button Style.
XTPButtonStyle | m_buttonCustomStyle
User-defined style of button.
XTPButtonStyle | m_buttonRibbonStyle
User-defined style of button.
BOOL | m_bCloseSubMenuOnClick
TRUE is sub-menus are closed as soon as a control is clicked.
CXTPRibbonGroup * | m_pRibbonGroup
Ribbon group of control.
CXTPControlAction * | m_pAction
Action of the control.
int | m_nWidth
Width of the control.
int | m_nHeight
Height of the control.
int | m_nExecuteOnPressInterval
Delay between each message when control is pressed.
CSize | m_szIcon
The size of the icon used for the control.
BOOL | m_bLayoutRTL
Indicate does last layout is RTL.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControl
static CXTPControl *AFX_CDECL | FromUI (CCmdUI *pCmdUI)
Call this member to retrieve CXTPControl from a CCmdUI structure.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

CXTPRibbonControlSystemPopupBarPinableListItem is a CXTPRibbonControlSystemPopupBarListItem derived class used in a Ribbon system pop-up to draw recent file list items.

Member Function Documentation

◆ Draw()

virtual void Draw ( CDC * pDC )
protectedvirtual

This method is called to draw the control.

Parameters
pDC Pointer to a valid device context.

Reimplemented from CXTPRibbonControlSystemPopupBarListItem.

◆ OnLButtonUp()

virtual void OnLButtonUp ( CPoint point )
protectedvirtual

This member is called when the user releases the left mouse button.

Parameters
point Specifies the x- and y-coordinate of the cursor.

Reimplemented from CXTPControlButton.

◆ OnMouseMove()

virtual void OnMouseMove ( CPoint point )
protectedvirtual

This member is called when the mouse cursor moves.

Parameters
point Specifies the x- and y-coordinate of the cursor.

Reimplemented from CXTPControl.

◆ OnSetSelected()

virtual BOOL OnSetSelected ( int bSelected )
protectedvirtual

This method is called when the MRU item becomes selected.

Parameters
bSelected TRUE if the MRU item becomes selected.
Returns
TRUE if successful, otherwise FALSE.

Reimplemented from CXTPControl.

The documentation for this class was generated from the following file:
  • XTPRibbonSystemButton.h


Toolkit Pro: CXTPRibbonControlSystemRecentFileList Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPRibbonControlSystemRecentFileList Class Reference

CXTPRibbonControlSystemRecentFileList is a CXTPRibbonControlSystemPopupBarListCaption derived class used in a Ribbon system pop-up to draw recent file list controls. More...

Inheritance diagram for CXTPRibbonControlSystemRecentFileList:
[legend]

Public Member Functions

CXTPRibbonControlSystemRecentFileList ()
Constructs a CXTPRibbonControlSystemRecentFileList object.
- Public Member Functions inherited from CXTPRibbonControlSystemPopupBarListCaption
CXTPRibbonControlSystemPopupBarListCaption ()
Constructs a CXTPRibbonControlSystemPopupBarListCaption object.
- Public Member Functions inherited from CXTPControl
void | SetStyle (XTPButtonStyle buttonStyle)
Call this member to set the style of the control.
XTPButtonStyle | GetStyle () const
Call this member to get the control's style.
void | SetCaption (LPCTSTR lpszCaption)
Call this member to set the caption of the control.
void | SetCaption (UINT nIDCaption)
Call this member to set the caption of the control.
virtual CString | GetCaption () const
Call this member to get the control's caption.
void | SetShortcutText (LPCTSTR lpszShortcutText)
Call this member to set the shortcut string to the control.
CString | GetShortcutText () const
Call this member to get the control's shortcut.
void | SetDescription (LPCTSTR lpszDescription)
Call this member to set the description of the control.
virtual CString | GetDescription () const
Call this member to get the control's description.
void | SetTooltip (LPCTSTR lpszTooltip)
Call this member to set the tooltip of the control.
virtual CString | GetTooltip () const
Call this member to get the control's tooltip.
void | SetKeyboardTip (LPCTSTR lpszKeyboardTip)
Call this member to set the keyboard tip to the control.
CString | GetKeyboardTip () const
Call this member to get the keyboard tip.
void | SetCustomShortcutText (LPCTSTR lpszCustomShortcutText)
Call this member to set the text displayed for the shortcut in a pop-up menu.
CString | GetCustomShortcutText () const
Call this member to get the control's text displayed for the shortcut in a pop-up menu.
void | SetParameter (LPCTSTR lpszParameter)
Call this member to set the parameter of the control.
CString | GetParameter () const
Call this member to get the control's parameter.
void | SetID (int nId)
Call this member to set the identifier of the control.
int | GetID () const
Call this member to get the control's identifier.
long | GetIndex () const
Call this member to get the index of the control.
void | SetIconId (int nId)
Call this member to set the control icon's identifier.
int | GetIconId () const
Call this member to get the icon's identifier.
void | SetHelpId (int nId)
Call this member to set the control help identifier.
int | GetHelpId () const
Call this member to get the help identifier.
virtual void | SetBeginGroup (BOOL bBeginGroup)
Call this member to begin a new group using a separator.
BOOL | GetBeginGroup () const
Call this member to determine if the control has a separator.
virtual void | SetEnabled (BOOL bEnabled)
Call this member to enable/disable the control.
BOOL | GetEnabled () const
Call this member to check if the control is enabled.
virtual void | OnEnabledChanged ()
This method is called when a control's enabled state is changed.
virtual void | SetChecked (BOOL bChecked)
Call this member to set the checked state of the control.
BOOL | GetChecked () const
Call this member to get the checked state of the control.
virtual int | GetSelected () const
Call this member to check if the control is selected.
void | SetOnQuickAccess (BOOL bOnQuicAccess=FALSE)
Call this member to set whether a control should be a part of the Quick Access panel.
BOOL | IsOnQuickAccess () const
Call this member to check if a control is a part of the Quick Access panel.
virtual void | SetFocused (BOOL bFocused)
Call this member to set the focused state of the control.
virtual BOOL | IsFocused () const
Call this member to check the focused state of the control.
void | SetPressed (BOOL bPressed)
Call this member to set the pressed state of the control.
virtual BOOL | GetPressed () const
Call this member to check the pressed state of the control.
virtual void | SetRect (CRect rcControl)
This member is called to set the bounding rectangle of the control.
CRect | GetRect () const
Call this member to get the bounding rectangle of the control.
CXTPCommandBar * | GetParent () const
Call this member to get the parent command bar.
virtual BOOL | IsVisible (DWORD dwSkipFlags=0) const
Call this member to determine if the control is visible.
virtual BOOL | IsCaptionVisible () const
Call this member to determine if the caption of the control is visible.
void | SetVisible (BOOL bVisible)
Call this member to set the visibility of the control.
CXTPControls * | GetControls () const
Call this member to get the parent controls collection.
XTPControlType | GetType () const
Call this member to get the control's type.
void | SetFlags (DWORD dwFlags)
Call this member to set the flags of the control.
DWORD | GetFlags () const
Call this member to retrieve control special flags.
void | SetTag (DWORD_PTR dwTag)
This method sets the 32-bit value associated with the control.
DWORD_PTR | GetTag () const
This method retrieves the application-supplied, 32-bit value associated with the control.
virtual BOOL | Compare (CXTPControl *pOther)
Call this member to compare controls.
virtual CXTPCommandBar * | GetCommandBar () const
Call this member to get the child command bar.
void | SetCloseSubMenuOnClick (BOOL bCloseOnClick)
Call this member function to enable/disable the closing of sub-menus when a control is clicked in the menu.
BOOL | GetCloseSubMenuOnClick () const
Call this member function to check if sub-menus will close as soon as a control is clicked.
void | SetExecuteOnPressInterval (int nExecuteOnPressInterval)
Call this method to set the delay (in milliseconds) between WM_COMMAND messages while a button is pressed by the user.
int | GetExecuteOnPressInterval () const
Call this method to get the delay (in milliseconds) between WM_COMMAND messages while a button is pressed by the user.
CXTPRibbonGroup * | GetRibbonGroup () const
Returns the ribbon group that the control belongs to.
virtual BOOL | IsTransparent () const
Determines if the control needs to draw its background.
void | SetHideWrap (BOOL bHide)
This method is called to hide the control.
virtual void | SetHideFlags (DWORD dwFlags)
This method is called to hide the control.
BOOL | SetHideFlag (XTPControlHideFlags dwFlag, BOOL bSet)
Call this member to set/remove hide flags.
DWORD | GetHideFlags () const
Call this method to retrieve hidden flags.
CRect | GetRowRect () const
Call this method to retrieve the position of the control's row.
BOOL | GetWrap () const
Call this method to check if the control is wrapped.
void | SetRowRect (CRect rcRow)
Call this method to set the row of the control.
void | SetWrap (BOOL bWrap)
Call this member to set the control to wrapped.
BOOL | GetExpanded () const
Call this member to check if the control is expanded.
BOOL | IsCursorOver () const
Call this member to determine if the mouse pointer is over the control.
virtual void | OnExecute ()
This method is called when the control is executed.
void | DelayRedrawParent ()
Call this method to redraw the parent command bar.
void | DelayLayoutParent ()
Call this method to recalculate the parent command bar size.
void | SetCategory (LPCTSTR lpszCategory)
Call this method to set the category of the control.
CString | GetCategory () const
Call this method to retrieve the category of the control.
CXTPImageManager * | GetImageManager () const
Call this method to retrieve the image manager.
CXTPPaintManager * | GetPaintManager () const
Call this method to retrieve the paint manager.
virtual CXTPImageManagerIcon * | GetImage (int nWidth=16) const
Call this method to retrieve the image of the control.
void | AssignDocTemplate (UINT nIDResource)
Call this method to assign a document template to the control.
void | ExcludeDocTemplate (UINT nIDResource)
Call this method to exclude the document template from control.
BOOL | IsItemDefault () const
Call this method to check if a control is a default menu item.
void | SetItemDefault (BOOL bDefault)
Call this method to set a control to be a default menu item.
BOOL | IsTemporary () const
Call this method to determine if a control is temporary.
void | Reset ()
Call this member to reset the icon and caption of a control to its default settings before it was customized by the user.
void | SetPrompt (LPCTSTR lpszPrompt)
Call this member to load a string from a STRINGTABLE resource to set the tooltip and description of a control.
void | SetCustomIcon (HICON hIcon)
Call this member to set a custom icon to this control.
virtual void | DoPropExchange (CXTPPropExchange *pPX)
Either reads this object from or writes this object to an archive.
virtual void | OnUnderlineActivate ()
This method is called when the user activates the control using its underline.
virtual BOOL | GetPopuped () const
Call this member to get the control's pop-up state.
void | RedrawParent (BOOL bAnimate=TRUE)
This method is called to redraw the parent command bar.
LRESULT | NotifySite (UINT code)
This method is called to send message code to the parent site window.
LRESULT | NotifySite (UINT code, NMXTPCONTROL *pNM)
This method is called to send message code to the parent site window.
LRESULT | NotifySite (CWnd *pSite, UINT code, NMXTPCONTROL *pNM)
This method is called to send message code to the parent site window.
virtual void | SetAction (CXTPControlAction *pAction)
Call this method to manually assign an action for control.
CXTPControlAction * | GetAction () const
Call this method to retrieve an action associated with control.
virtual void | OnThemeChanged ()
This method is called when the paint manager theme is changed.
virtual void | SetWidth (int nWidth)
Call this member to set the width of the control.
virtual void | SetHeight (int nHeight)
Call this member to set the height of the control.
int | GetWidth () const
Call this member to get the width of the control.
int | GetHeight () const
Call this member to get the height of the control.
BOOL | HasDwmCompositedRect () const
This method is called to determine if control has a Vista DWM transparent area.
virtual CSize | GetButtonSize () const
Call this function to get the size of the command bar button.
virtual CSize | GetIconSize () const
Call this member function to get the size of a toolbar icon.
void | SetIconSize (CSize szIcon)
Call this member function to set the size of an icon for an individual control.
virtual void | Copy (CXTPControl *pControl, BOOL bRecursive=FALSE)
This method is called to copy the control.
virtual void | OnClick (BOOL bKeyboard=FALSE, CPoint pt=CPoint(0, 0))
This method is called when the user clicks the control.
virtual BOOL | IsCustomizeMovable () const
This method is called to determine if control can be repositioned in customize mode.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

virtual void | OnCalcDynamicSize (DWORD dwMode)
This method is called before recalculating the parent command bar size to calculate the dimensions of the control.
virtual BOOL | DoCustomDragOver (CXTPCommandBar *pCommandBar, CPoint point, DROPEFFECT &dropEffect)
The implementation may implement a custom drag over handling logic in this method.
virtual CRecentFileList * | GetRecentFileList ()
Retrieves a pointer to the recent file list collection.
virtual int | GetFirstMruID ()
Retrieves ID_FILE_MRU_FILE1.
- Protected Member Functions inherited from CXTPRibbonControlSystemPopupBarListCaption
virtual CSize | GetSize (CDC *pDC)
This method is called to determine the size of the control.
virtual void | Draw (CDC *pDC)
This method is called to draw the control.
- Protected Member Functions inherited from CXTPControl
CXTPControl ()
Constructs a CXTPControl object.
virtual | ~CXTPControl ()
Destroys a CXTPControl object, handles cleanup and deallocation.
virtual BOOL | IsFocusable () const
This method is called to check if the control can accept focus.
void | SetIndex (int nIndex)
This method is called to assign the order of the control in the controls list.
void | SetExpanded (BOOL bExpanded)
This method is called to set the control's expanded state.
virtual BOOL | OnHookKeyDown (UINT nChar, LPARAM lParam)
This method is called when a non-system key is pressed.
virtual BOOL | OnHookMouseWheel (UINT nFlags, short zDelta, CPoint point)
This method is called when the user rotates the mouse wheel.
virtual void | SetParent (CXTPCommandBar *pParent)
This method is called to assign a parent command bar object.
void | ScreenToClient (CPoint *point)
The ScreenToClient function converts the screen coordinates of a specified point on the screen.
void | ClickToolBarButton (CRect rcActiveRect=CRect(0, 0, 0, 0))
This helper method is called when the user clicks the toolbar's button.
virtual BOOL | OnSetPopup (BOOL bPopup)
This method is called to pop-up the control.
virtual void | OnLButtonUp (CPoint point)
This member is called when the user releases the left mouse button.
virtual void | OnLButtonDown (CPoint point)
This member is called when the user presses the left mouse button down.
virtual BOOL | OnRButtonDown (CPoint point)
This member is called when the user press the right mouse button.
virtual BOOL | OnRButtonUp (CPoint point)
This member is called when the user releases the right mouse button.
virtual BOOL | OnLButtonDblClk (CPoint point)
This member is called when the user double-clicks the left mouse button.
virtual void | OnMouseMove (CPoint point)
This member is called when the mouse cursor moves.
virtual void | OnMouseHover ()
Called after the mouse hovers over the control.
virtual BOOL | OnSetSelected (int bSelected)
This method is called when the control becomes selected.
BOOL | IsCustomizeMode () const
Call this method to determine if command bars is in customize mode.
virtual void | CustomizeStartDrag (CPoint point)
This member is called when the user starts to drag the control in customize mode.
virtual BOOL | CustomizeStartResize (CPoint point)
This method is called when user starts to resize control in customize mode.
virtual void | OnCustomizeDragOver (CXTPControl *pDataObject, CPoint point, DROPEFFECT &dropEffect)
This member is called when the user moves the mouse over the control.
virtual BOOL | IsCustomizeResizeAllow () const
This member checks if the user can resize the control.
virtual int | GetCustomizeMinWidth () const
Retrieves the available minimum width of control.
virtual int | GetCustomizeMinHeight () const
Retrieves available minimum height of the control.
void | OnCustomizeMouseMove (CPoint point)
This member is called when the mouse cursor moves in customized mode.
virtual void | OnIdleUpdate ()
This virtual method is called in idle-time processing.
virtual void | OnRemoved ()
This method is called when a control is removed from the parent controls collection.
virtual INT_PTR | OnToolHitTest (CPoint point, TOOLINFO *pTI) const
The framework calls this member function to determine whether a point is in the bounding rectangle of the specified tool.
virtual void | RestoreCommandBarList (CXTPCommandBarList *pCommandBarList)
This method is called from LoadCommandBars to restore controls and its child command bars.
virtual void | GenerateCommandBarList (DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam)
This method is called from SaveCommandBars to save all child command bars.
virtual void | OnActionChanged (int nProperty)
This method is called when an action property is changed.
virtual void | OnActionChanging (int nProperty)
This method is called when an action property is about to be changed.
virtual void | OnCaptionChanged ()
This method is called when the control's caption is changed.
BOOL | IsLayoutRTL () const
Determines if right-to-left (RTL) mode is set.
BOOL | IsLayoutChanged ()
Call this member to determine if the layout has changed (RTL to LTR or LTR to RLT).

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControl
static CXTPControl *AFX_CDECL | FromUI (CCmdUI *pCmdUI)
Call this member to retrieve CXTPControl from a CCmdUI structure.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Attributes inherited from CXTPControl
DWORD_PTR | m_nTag
Control tag.
int | m_nIndex
Index of the control.
int | m_nId
Identifier of the control.
int | m_nIconId
Identifier of the control's image.
int | m_nHelpId
Help identifier.
int | m_nCustomIconId
Identifier of the control's custom image.
BOOL | m_bWrap
TRUE if the control is wrapped.
BOOL | m_bBeginGroup
TRUE if the control starts new group.
BOOL | m_bEnabled
TRUE if the control is enabled.
BOOL | m_bChecked
TRUE if the control is checked.
BOOL | m_bSelected
TRUE if the control is selected.
BOOL | m_bPressed
TRUE if the control is pushed.
BOOL | m_bTemporary
TRUE if the control is temporary.
BOOL | m_bOnQuickAccess
TRUE if the control is a part of Quick Access panel.
CRect | m_rcRow
Bounding rectangle of the control's row.
CRect | m_rcControl
Bounding rectangle of the control.
DWORD | m_dwHideFlags
Hidden flags.
DWORD | m_dwFlags
Flags of the control.
CString | m_strCaption
Caption of the control.
CString | m_strCustomCaption
User-defined caption.
CString | m_strShortcutText
Shortcut text.
CString | m_strShortcutTextAuto
Shortcut text.
CString | m_strTooltipText
Tooltip text.
CString | m_strDescriptionText
Description text.
CString | m_strParameter
Parameter text.
CString | m_strKeyboardTip
Keyboard tip.
CXTPControls * | m_pControls
Parent control collection.
XTPControlType | m_controlType
Type of the control.
CXTPCommandBar * | m_pParent
The Parent command bar.
BOOL | m_bExpanded
TRUE if the control is expanded.
CString | m_strCategory
Category of the control.
BOOL | m_bDefaultItem
TRUE if the item is default pop-up item.
CDocTemplateMap | m_mapDocTemplatesAssigned
Assigned templates.
CDocTemplateMap | m_mapDocTemplatesExcluded
Excluded templates.
XTPButtonStyle | m_buttonStyle
Button Style.
XTPButtonStyle | m_buttonCustomStyle
User-defined style of button.
XTPButtonStyle | m_buttonRibbonStyle
User-defined style of button.
BOOL | m_bCloseSubMenuOnClick
TRUE is sub-menus are closed as soon as a control is clicked.
CXTPRibbonGroup * | m_pRibbonGroup
Ribbon group of control.
CXTPControlAction * | m_pAction
Action of the control.
int | m_nWidth
Width of the control.
int | m_nHeight
Height of the control.
int | m_nExecuteOnPressInterval
Delay between each message when control is pressed.
CSize | m_szIcon
The size of the icon used for the control.
BOOL | m_bLayoutRTL
Indicate does last layout is RTL.

Detailed Description

CXTPRibbonControlSystemRecentFileList is a CXTPRibbonControlSystemPopupBarListCaption derived class used in a Ribbon system pop-up to draw recent file list controls.

Member Function Documentation

◆ DoCustomDragOver()

virtual BOOL DoCustomDragOver | ( | CXTPCommandBar * | pCommandBar,
 |  | CPoint | point,
 |  | DROPEFFECT & | dropEffect )
 protectedvirtual

The implementation may implement a custom drag over handling logic in this method.

Parameters
pCommandBar | Pointer to a CXTPCommandBar object.
point | Mouse position.
dropEffect | DROPEFFECT enumerator.
Returns
TRUE if custom implementation handles drag over, otherwise FALSE.

Reimplemented from CXTPControl.

◆ GetFirstMruID()

virtual int GetFirstMruID ( )
protectedvirtual

Retrieves ID_FILE_MRU_FILE1.

Returns
ID_FILE_MRU_FILE1.

◆ GetRecentFileList()

virtual CRecentFileList * GetRecentFileList ( )
protectedvirtual

Retrieves a pointer to the recent file list collection.

Returns
A pointer to the recent file list collection.

◆ OnCalcDynamicSize()

virtual void OnCalcDynamicSize ( DWORD dwMode )
protectedvirtual

This method is called before recalculating the parent command bar size to calculate the dimensions of the control.

Parameters
dwMode Flags used to determine the height and width of the dynamic command bar. See Remarks section for a list of values.

The following predefined flags are used to determine the height and width of the dynamic command bar. Use the bitwise-OR (|) operator to combine the flags.

LM_STRETCH: Indicates whether the command bar should be stretched to the size of the frame. Set if the bar is not a docking bar (not available for docking). Not set when the bar is docked or floating (available for docking). If set, LM_STRETCH returns dimensions based on LM_HORZ state. LM_STRETCH works similarly to the bStretch parameter used in CalcFixedLayout; see that member function for more information about the relationship between stretching and orientation. LM_HORZ: Indicates that the bar is horizontally or vertically oriented. Set if the bar is horizontally oriented, and if it is vertically oriented, it is not set. LM_HORZ works similarly to the the bHorz parameter used in CalcFixedLayout; see that member function for more information about the relationship between stretching and orientation. LM_MRUWIDTH: Most Recently Used Dynamic Width. Uses the remembered most recently used width. LM_HORZDOCK: Horizontal Docked Dimensions. Returns the dynamic size with the largest width. LM_VERTDOCK: Vertical Docked Dimensions. Returns the dynamic size with the largest height. LM_COMMIT: Resets LM_MRUWIDTH to the current width of the floating command bar.

Reimplemented from CXTPControl.

The documentation for this class was generated from the following file:
  • XTPRibbonSystemButton.h


Toolkit Pro: CXTPRibbonControlTab Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPRibbonControlTab Class Reference

CXTPRibbonControlTab is a CXTPTabManager derived class. More...

Inheritance diagram for CXTPRibbonControlTab:
[legend]

Public Member Functions

CXTPRibbonControlTab ()
Constructs a CXTPRibbonControlTab object.
virtual | ~CXTPRibbonControlTab ()
Destroys a CXTPRibbonControlTab object, handles cleanup and deallocation.
virtual CXTPTabPaintManager * | GetPaintManager () const
Call this member to get a pointer to the tab paint manager.
CXTPRibbonBar * | GetRibbonBar () const
Retrieves the parent CXTPRibbonBar object.
CXTPRibbonTab * | FindTab (int nId) const
Call this method to find a tab with a specified identifier.
CXTPRibbonTab * | GetTab (int nIndex) const
Call this method to retrieve the tab at a specified position.
void | SetSelectedItem (CXTPTabManagerItem *pItem)
Call this member to select an item in the ribbon bar.
- Public Member Functions inherited from CXTPControlPopup
CXTPControlPopup ()
Constructs a CXTPControlPopup object.
virtual | ~CXTPControlPopup ()
Destroys a CXTPControlPopup object, handles cleanup and deallocation.
void | SetCommandBar (CMenu *pMenu)
Call this member to set the child command bar.
void | SetCommandBar (CXTPCommandBar *pBar)
Call this member to set the child command bar.
CXTPCommandBar * | GetCommandBar () const
Call this member to get the child command bar.
BOOL | GetPopuped () const
Call this member to get the control's pop-up state.
virtual CString | GetCaption () const
Call this member to get the control's caption.
virtual void | AdjustExcludeRect (CRect &rc, BOOL bVertical)
Updates rectangle to set the position where the child pop-up bar becomes visible.
- Public Member Functions inherited from CXTPControlButton
CXTPControlButton ()
Constructs a CXTPControlButton object.
virtual | ~CXTPControlButton ()
Destroys a CXTPControlButton object, handles cleanup and deallocation.
void | SetStyleEx (XTPButtonStyle buttonStyle)
Call this member to set the style of the button containing vector icon.
XTPButtonStyle | GetStyleEx () const
Call this member to get the button's style containing vector icon.
- Public Member Functions inherited from CXTPControl
void | SetStyle (XTPButtonStyle buttonStyle)
Call this member to set the style of the control.
XTPButtonStyle | GetStyle () const
Call this member to get the control's style.
void | SetCaption (LPCTSTR lpszCaption)
Call this member to set the caption of the control.
void | SetCaption (UINT nIDCaption)
Call this member to set the caption of the control.
void | SetShortcutText (LPCTSTR lpszShortcutText)
Call this member to set the shortcut string to the control.
CString | GetShortcutText () const
Call this member to get the control's shortcut.
void | SetDescription (LPCTSTR lpszDescription)
Call this member to set the description of the control.
virtual CString | GetDescription () const
Call this member to get the control's description.
void | SetTooltip (LPCTSTR lpszTooltip)
Call this member to set the tooltip of the control.
virtual CString | GetTooltip () const
Call this member to get the control's tooltip.
void | SetKeyboardTip (LPCTSTR lpszKeyboardTip)
Call this member to set the keyboard tip to the control.
CString | GetKeyboardTip () const
Call this member to get the keyboard tip.
void | SetCustomShortcutText (LPCTSTR lpszCustomShortcutText)
Call this member to set the text displayed for the shortcut in a pop-up menu.
CString | GetCustomShortcutText () const
Call this member to get the control's text displayed for the shortcut in a pop-up menu.
void | SetParameter (LPCTSTR lpszParameter)
Call this member to set the parameter of the control.
CString | GetParameter () const
Call this member to get the control's parameter.
void | SetID (int nId)
Call this member to set the identifier of the control.
int | GetID () const
Call this member to get the control's identifier.
long | GetIndex () const
Call this member to get the index of the control.
void | SetIconId (int nId)
Call this member to set the control icon's identifier.
int | GetIconId () const
Call this member to get the icon's identifier.
void | SetHelpId (int nId)
Call this member to set the control help identifier.
int | GetHelpId () const
Call this member to get the help identifier.
virtual void | SetBeginGroup (BOOL bBeginGroup)
Call this member to begin a new group using a separator.
BOOL | GetBeginGroup () const
Call this member to determine if the control has a separator.
virtual void | SetEnabled (BOOL bEnabled)
Call this member to enable/disable the control.
BOOL | GetEnabled () const
Call this member to check if the control is enabled.
virtual void | OnEnabledChanged ()
This method is called when a control's enabled state is changed.
virtual void | SetChecked (BOOL bChecked)
Call this member to set the checked state of the control.
BOOL | GetChecked () const
Call this member to get the checked state of the control.
virtual int | GetSelected () const
Call this member to check if the control is selected.
void | SetOnQuickAccess (BOOL bOnQuicAccess=FALSE)
Call this member to set whether a control should be a part of the Quick Access panel.
BOOL | IsOnQuickAccess () const
Call this member to check if a control is a part of the Quick Access panel.
void | SetPressed (BOOL bPressed)
Call this member to set the pressed state of the control.
virtual BOOL | GetPressed () const
Call this member to check the pressed state of the control.
virtual void | SetRect (CRect rcControl)
This member is called to set the bounding rectangle of the control.
CRect | GetRect () const
Call this member to get the bounding rectangle of the control.
CXTPCommandBar * | GetParent () const
Call this member to get the parent command bar.
virtual BOOL | IsVisible (DWORD dwSkipFlags=0) const
Call this member to determine if the control is visible.
virtual BOOL | IsCaptionVisible () const
Call this member to determine if the caption of the control is visible.
void | SetVisible (BOOL bVisible)
Call this member to set the visibility of the control.
CXTPControls * | GetControls () const
Call this member to get the parent controls collection.
XTPControlType | GetType () const
Call this member to get the control's type.
void | SetFlags (DWORD dwFlags)
Call this member to set the flags of the control.
DWORD | GetFlags () const
Call this member to retrieve control special flags.
void | SetTag (DWORD_PTR dwTag)
This method sets the 32-bit value associated with the control.
DWORD_PTR | GetTag () const
This method retrieves the application-supplied, 32-bit value associated with the control.
void | SetCloseSubMenuOnClick (BOOL bCloseOnClick)
Call this member function to enable/disable the closing of sub-menus when a control is clicked in the menu.
BOOL | GetCloseSubMenuOnClick () const
Call this member function to check if sub-menus will close as soon as a control is clicked.
void | SetExecuteOnPressInterval (int nExecuteOnPressInterval)
Call this method to set the delay (in milliseconds) between WM_COMMAND messages while a button is pressed by the user.
int | GetExecuteOnPressInterval () const
Call this method to get the delay (in milliseconds) between WM_COMMAND messages while a button is pressed by the user.
CXTPRibbonGroup * | GetRibbonGroup () const
Returns the ribbon group that the control belongs to.
virtual BOOL | IsTransparent () const
Determines if the control needs to draw its background.
void | SetHideWrap (BOOL bHide)
This method is called to hide the control.
virtual void | SetHideFlags (DWORD dwFlags)
This method is called to hide the control.
BOOL | SetHideFlag (XTPControlHideFlags dwFlag, BOOL bSet)
Call this member to set/remove hide flags.
DWORD | GetHideFlags () const
Call this method to retrieve hidden flags.
CRect | GetRowRect () const
Call this method to retrieve the position of the control's row.
BOOL | GetWrap () const
Call this method to check if the control is wrapped.
void | SetRowRect (CRect rcRow)
Call this method to set the row of the control.
void | SetWrap (BOOL bWrap)
Call this member to set the control to wrapped.
BOOL | GetExpanded () const
Call this member to check if the control is expanded.
BOOL | IsCursorOver () const
Call this member to determine if the mouse pointer is over the control.
virtual void | OnExecute ()
This method is called when the control is executed.
virtual CSize | GetSize (CDC *pDC)
This method is called to determine the size of the control.
virtual void | OnCalcDynamicSize (DWORD dwMode)
This method is called before recalculating the parent command bar size to calculate the dimensions of the control.
void | DelayRedrawParent ()
Call this method to redraw the parent command bar.
void | DelayLayoutParent ()
Call this method to recalculate the parent command bar size.
void | SetCategory (LPCTSTR lpszCategory)
Call this method to set the category of the control.
CString | GetCategory () const
Call this method to retrieve the category of the control.
CXTPImageManager * | GetImageManager () const
Call this method to retrieve the image manager.
CXTPPaintManager * | GetPaintManager () const
Call this method to retrieve the paint manager.
virtual CXTPImageManagerIcon * | GetImage (int nWidth=16) const
Call this method to retrieve the image of the control.
void | AssignDocTemplate (UINT nIDResource)
Call this method to assign a document template to the control.
void | ExcludeDocTemplate (UINT nIDResource)
Call this method to exclude the document template from control.
BOOL | IsItemDefault () const
Call this method to check if a control is a default menu item.
void | SetItemDefault (BOOL bDefault)
Call this method to set a control to be a default menu item.
BOOL | IsTemporary () const
Call this method to determine if a control is temporary.
void | Reset ()
Call this member to reset the icon and caption of a control to its default settings before it was customized by the user.
void | SetPrompt (LPCTSTR lpszPrompt)
Call this member to load a string from a STRINGTABLE resource to set the tooltip and description of a control.
void | SetCustomIcon (HICON hIcon)
Call this member to set a custom icon to this control.
void | RedrawParent (BOOL bAnimate=TRUE)
This method is called to redraw the parent command bar.
LRESULT | NotifySite (UINT code)
This method is called to send message code to the parent site window.
LRESULT | NotifySite (UINT code, NMXTPCONTROL *pNM)
This method is called to send message code to the parent site window.
LRESULT | NotifySite (CWnd *pSite, UINT code, NMXTPCONTROL *pNM)
This method is called to send message code to the parent site window.
virtual void | SetAction (CXTPControlAction *pAction)
Call this method to manually assign an action for control.
CXTPControlAction * | GetAction () const
Call this method to retrieve an action associated with control.
virtual void | OnThemeChanged ()
This method is called when the paint manager theme is changed.
virtual void | SetWidth (int nWidth)
Call this member to set the width of the control.
virtual void | SetHeight (int nHeight)
Call this member to set the height of the control.
int | GetWidth () const
Call this member to get the width of the control.
int | GetHeight () const
Call this member to get the height of the control.
BOOL | HasDwmCompositedRect () const
This method is called to determine if control has a Vista DWM transparent area.
virtual CSize | GetButtonSize () const
Call this function to get the size of the command bar button.
virtual CSize | GetIconSize () const
Call this member function to get the size of a toolbar icon.
void | SetIconSize (CSize szIcon)
Call this member function to set the size of an icon for an individual control.
virtual BOOL | IsCustomizeMovable () const
This method is called to determine if control can be repositioned in customize mode.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.
- Public Member Functions inherited from CXTPTabManager
CXTPTabManager ()
Constructs a CXTPTabManager object.
virtual | ~CXTPTabManager ()
Destroys a CXTPTabManager object, handles cleanup and deallocation.
CXTPTabManagerItem * | GetItem (int nIndex) const
Retrieves a tab item by its index.
BOOL | DeleteItem (int nItem)
Deletes a tab item by its index.
void | DeleteAllItems ()
Deletes all tab items from the tab manager.
int | GetItemCount () const
Gets the number of tab items in the tab manager.
virtual CString | GetItemCaption (const CXTPTabManagerItem *pItem) const
Retrieves the caption text of a specified tab item.
virtual HICON | GetItemIcon (const CXTPTabManagerItem *pItem) const
Retrieves the icon of a specified tab item.
virtual COLORREF | GetItemColor (const CXTPTabManagerItem *pItem) const
Retrieves the tab button color of a specified tab item.
virtual CString | GetItemTooltip (const CXTPTabManagerItem *pItem) const
Retrieves the tooltip of a specified tab item.
virtual void | OnItemsChanged ()
This method is called when tab items are changed (i.e.
void | SetCurSel (int nIndex)
Sets the index for the currently selected tab item within the collection of tab items.
int | GetCurSel () const
Gets the index of the currently selected tab item within the collection of tab items.
virtual void | SetFocusedItem (CXTPTabManagerItem *pItem)
Sets the focused tab item.
CXTPTabManagerItem * | GetSelectedItem () const
Gets the currently selected tab item.
CXTPTabManagerItem * | HitTest (CPoint point) const
Determines which tab is at a specified point, if any.
CXTPTabManagerNavigateButton * | HitTestNavigateButton (CPoint point, BOOL bHeaderOnly, int *pnIndex=NULL) const
Determines which navigation button is at a specified point, if any.
virtual void | GetItemMetrics (CSize *szNormal, CSize *szMin=NULL, CSize *szMax=NULL) const
Gets the minimum, maximum, and normal lengths of tab buttons.
void | SetItemMetrics (CSize szNormal, CSize szMin=CSize(0, 0), CSize szMax=CSize(0, 0))
Sets the minimum, maximum, and normal lengths for tab buttons.
void | MoveItem (CXTPTabManagerItem *pItem, int nIndex)
Sets the position of a specified tab item.
void | ShowCloseItemButton (XTPTabNavigateButtonFlags bCloseItemButton=xtpTabNavigateButtonAlways)
Call this member to show close button for each tab.
virtual int | GetItemsLength () const
Gets the total width of all of the tab buttons.
int | GetRectLength (CRect rc) const
Gets the length of the bounding rectangle of the tab client header area.
CXTPTabManagerNavigateButton * | FindNavigateButton (UINT nID) const
Retrieves a specified tab navigation button (i.e.
BOOL | IsHorizontalPosition () const
Determines if the tabs are positioned horizontally.
int | GetHeaderOffset () const
Gets the scroll offset of the tabs in the tab header.
void | SetHeaderOffset (int nOffset)
Sets the scroll offset for the tabs in the tab header.
void | EnsureVisible (CXTPTabManagerItem *pItem)
Ensures that a specified tab is visible.
virtual void | SetPaintManager (CXTPTabPaintManager *pPaintManager)
Sets the tab paint manager.
virtual BOOL | IsAllowReorder () const
Determines if tabs are allowed to be reordered.
virtual void | SetAllowReorder (BOOL bAllowReorder)
Specifies if tabs should be allowed to be reordered.
virtual BOOL | IsDrawStaticFrame () const
Determines if a static frame is used.
void | EnableTabThemeTexture (HWND hWnd, BOOL bEnable=TRUE)
Enables/disables Windows XP themed back color.
CXTPTabPaintManagerColorSet * | SetColor (XTPTabColorStyle tabColor)
Applies one of the "built-in" color sets for the tabs.
CXTPTabPaintManagerColorSet * | SetColorSet (CXTPTabPaintManagerColorSet *pColorSet)
Applies a custom color set for the tabs.
CXTPTabPaintManagerTheme * | SetAppearance (XTPTabAppearanceStyle tabAppearance)
Applies one of the "built-in" appearance sets for the tabs.
CXTPTabPaintManagerTheme * | SetAppearanceSet (CXTPTabPaintManagerTheme *pAppearanceSet)
Applies a custom appearance set for the tabs.
CXTPTabPaintManagerTheme * | GetAppearanceSet () const
Gets the currently applied custom appearance set.
CXTPTabPaintManagerColorSet * | GetColorSet () const
Gets the currently applied custom color set.
XTPTabAppearanceStyle | GetAppearance () const
Gets the currently applied "built-in appearance set.
XTPTabColorStyle | GetColor () const
Gets the currently applied "built-in" color set.
void | SetPosition (XTPTabPosition tabPosition)
Sets the tab position.
void | SetLayoutStyle (XTPTabLayoutStyle tabLayout)
Sets the tab layout style.
virtual XTPTabPosition | GetPosition () const
Gets the tab position.
XTPTabLayoutStyle | GetLayout () const
Gets the tab layout style.
void | ShowIcons (BOOL bShowIcons)
Shows/hides tab icons.
void | SetActive (BOOL bActive)
Specifies if this tab group should be active/inactive.
BOOL | IsActive () const
Determines if this tab group is active/inactive.
CRect | GetControlRect () const
Gets the bounding rectangle of the tab manager control area.
CRect | GetClientRect () const
Gets the bounding rectangle of the tab client area.
CRect | GetHeaderRect () const
Gets the bounding rectangle of the tab client header area.
int | GetRowCount () const
Gets the number of rows of tabs in the tab control.
virtual void | OnScrollHeader (BOOL bRight)
This method is called when the user presses either the left or right navigation buttons.
CXTPTabManagerNavigateButtons * GetNavigateButtons ()
Gets the collection of navigation buttons.
CXTPTabManagerItem * | FindNextFocusable (int nIndex, int nDirection) const
Retrieves the next/previous focusable tab item from a specified index.
void | PerformMouseMove (HWND hWnd, CPoint pt)
This method is called when the mouse cursor moves.
BOOL | PerformClick (HWND hWnd, CPoint pt, BOOL bNoItemClick=FALSE)
This method is called when the user presses the left mouse button.
virtual INT_PTR | PerformToolHitTest (HWND hWnd, CPoint point, TOOLINFO *pTI) const
Determines which tab is beneath the mouse cursor, if any, and stores the tooltip information of the tab within a TOOLINFO structure.
virtual BOOL | PerformKeyDown (HWND hWnd, UINT nChar)
This method is called to process a WM_KEYDOWN event for the tab manager.
virtual BOOL | DrawParentBackground (CDC *pDC, CRect rc)
Draws the parent background under the tab control.
int | GetNavigateButtonCount () const
Gets the total number of tab navigation buttons within the collection of tab navigation buttons.
CXTPTabManagerNavigateButton * | GetNavigateButton (int nIndex) const
Retrieves the tab navigation button at a specified index within the collection of tab navigation buttons.
void | EnableMarkup (BOOL bEnable=TRUE)
Enables/disables markup for the tab captions.
virtual CXTPMarkupContext * | GetMarkupContext () const
Gets the markup context.
- Public Member Functions inherited from CXTPTabManagerAtom
virtual void | OnPropertyChanged ()
This method is called when a property of the tab paint manager is changed.

Protected Member Functions

void | Reposition ()
This method is called to update the position of the tab manager.
virtual BOOL | HeaderHasFocus () const
The implementation should return TRUE if the header has focus or FALSE otherwise.
virtual void | SetFocused (BOOL bFocused)
Call this member to set focus to the control.
virtual BOOL | IsFocused () const
Determines if the control has focus.
void | OnUnderlineActivate ()
This method is called when the user actives the control using its underline.
virtual BOOL | IsFocusable () const
This method is called to check if the control can accept focus.
BOOL | OnSetSelected (int bSelected)
This method is called when the control becomes selected.
BOOL | OnHookKeyDown (UINT nChar, LPARAM lParam)
This method is called when a non-system key is pressed.
void | OnItemClick (CXTPTabManagerItem *pItem)
This method is called when an item (tab button) is clicked.
BOOL | DrawIcon (CDC *pDC, CPoint pt, CXTPTabManagerItem *pItem, BOOL bDraw, CSize &szIcon) const
This member is called when the icon of the ribbon tab needs to be drawn.
void | RedrawControl (LPCRECT lpRect, BOOL bAnimate)
Initiates redrawing of the ribbon bar control.
BOOL | IsMouseLocked () const
Checks to see if the mouse is locked.
void | Draw (CDC *pDC)
This method is called to draw the control.
void | DoPropExchange (CXTPPropExchange *pPX)
Call this member function to store/load a properties collection using the specified data object.
void | Copy (CXTPControl *pControl, BOOL bRecursive=FALSE)
This method is called to copy the control.
BOOL | IsPopupBarTracking () const
Call this member to get the tracking state.
- Protected Member Functions inherited from CXTPControlPopup
BOOL | ContainsPopup (CXTPControlPopup *pControlPopup)
This method is called to check if pControlPopup contains in the control recursively.
void | ExpandCommandBar ()
Call this member to expand the parent pop-up bar.
void | OnClick (BOOL bKeyboard=FALSE, CPoint pt=CPoint(0, 0))
This method is called when the user clicks the control.
void | OnMouseHover ()
This method is called after the mouse hovers over the control.
virtual void | OnMouseMove (CPoint point)
This member is called when the mouse cursor moves.
virtual BOOL | OnSetPopup (BOOL bPopup)
This method is called to pop-up the control.
virtual void | OnLButtonUp (CPoint point)
This member is called when the user releases the left mouse button.
virtual BOOL | OnLButtonDblClk (CPoint point)
This member is called when the user double-clicks the left mouse button.
void | OnCustomizeDragOver (CXTPControl *pDataObject, CPoint point, DROPEFFECT &dropEffect)
This method is called when the user moves the mouse over the control.
virtual BOOL | DoCustomDragOver (CXTPCommandBar *pCommandBar, CPoint point, DROPEFFECT &dropEffect)
The implementation may implement a custom drag over handling logic in this method.
virtual BOOL | Compare (CXTPControl *pOther)
Call this member to compare controls.
virtual void | UpdateShadow ()
Call this member to update the shadow of the control.
virtual void | RestoreCommandBarList (CXTPCommandBarList *pCommandBarList)
This method is called from LoadCommandBars to restore controls and its child command bars.
- Protected Member Functions inherited from CXTPControlButton
- Protected Member Functions inherited from CXTPControl
CXTPControl ()
Constructs a CXTPControl object.
virtual | ~CXTPControl ()
Destroys a CXTPControl object, handles cleanup and deallocation.
void | SetIndex (int nIndex)
This method is called to assign the order of the control in the controls list.
void | SetExpanded (BOOL bExpanded)
This method is called to set the control's expanded state.
virtual BOOL | OnHookMouseWheel (UINT nFlags, short zDelta, CPoint point)
This method is called when the user rotates the mouse wheel.
virtual void | SetParent (CXTPCommandBar *pParent)
This method is called to assign a parent command bar object.
void | ScreenToClient (CPoint *point)
The ScreenToClient function converts the screen coordinates of a specified point on the screen.
void | ClickToolBarButton (CRect rcActiveRect=CRect(0, 0, 0, 0))
This helper method is called when the user clicks the toolbar's button.
virtual void | OnLButtonDown (CPoint point)
This member is called when the user presses the left mouse button down.
virtual BOOL | OnRButtonDown (CPoint point)
This member is called when the user press the right mouse button.
virtual BOOL | OnRButtonUp (CPoint point)
This member is called when the user releases the right mouse button.
BOOL | IsCustomizeMode () const
Call this method to determine if command bars is in customize mode.
virtual void | CustomizeStartDrag (CPoint point)
This member is called when the user starts to drag the control in customize mode.
virtual BOOL | CustomizeStartResize (CPoint point)
This method is called when user starts to resize control in customize mode.
virtual BOOL | IsCustomizeResizeAllow () const
This member checks if the user can resize the control.
virtual int | GetCustomizeMinWidth () const
Retrieves the available minimum width of control.
virtual int | GetCustomizeMinHeight () const
Retrieves available minimum height of the control.
void | OnCustomizeMouseMove (CPoint point)
This member is called when the mouse cursor moves in customized mode.
virtual void | OnIdleUpdate ()
This virtual method is called in idle-time processing.
virtual void | OnRemoved ()
This method is called when a control is removed from the parent controls collection.
virtual INT_PTR | OnToolHitTest (CPoint point, TOOLINFO *pTI) const
The framework calls this member function to determine whether a point is in the bounding rectangle of the specified tool.
virtual void | GenerateCommandBarList (DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam)
This method is called from SaveCommandBars to save all child command bars.
virtual void | OnActionChanged (int nProperty)
This method is called when an action property is changed.
virtual void | OnActionChanging (int nProperty)
This method is called when an action property is about to be changed.
virtual void | OnCaptionChanged ()
This method is called when the control's caption is changed.
BOOL | IsLayoutRTL () const
Determines if right-to-left (RTL) mode is set.
BOOL | IsLayoutChanged ()
Call this member to determine if the layout has changed (RTL to LTR or LTR to RLT).
- Protected Member Functions inherited from CXTPTabManager
virtual BOOL | IsNavigateButtonAutomaticVisible (CXTPTabManagerNavigateButton *pButton)
Determines if a specified tab navigation button is automatically displayed.
virtual BOOL | IsNavigateButtonVisible (CXTPTabManagerNavigateButton *pButton)
Determines if a specified tab navigation button is visible.
virtual BOOL | OnBeforeItemClick (CXTPTabManagerItem *pItem)
This method is called before a tab item is clicked.
virtual void | ReOrder (HWND hWnd, CPoint pt, CXTPTabManagerItem *pItem)
This method is called when a tab item is clicked and dragged within the tab header.
virtual void | OnSwitchItem (CXTPTabManagerItem *pItem1, CXTPTabManagerItem *pItem2)
This method is called by ReOrder when two tab items are switched.
virtual void | OnItemOrderChanged (CXTPTabManagerItem *pItem, int nOldIndex, int nNewIndex)
This method is called by ReOrder when a tab item's position is changed.
virtual void | OnNavigateButtonClick (CXTPTabManagerNavigateButton *pButton)
This method is called when a tab navigation button is clicked.
virtual void | OnNavigateButtonClick (UINT nID)
This method is called when a tab navigation button is clicked.
CXTPTabManagerItem * | AddItem (int nItem, CXTPTabManagerItem *pItem=NULL)
Adds a specified tab item to the collection of tab items.
void | TrackClick (HWND hWnd, CPoint pt, CXTPTabManagerItem *pItem)
Activates and tracks a specified tab item on mouse click.
virtual void | OnItemHandleChanged (CXTPTabManagerItem *pItem, HWND hwndOld, HWND hwndNew)
This method is called when the handle of a tab item is changed.
- Protected Member Functions inherited from CXTPTabManagerAtom
virtual | ~CXTPTabManagerAtom ()
Destroys a CXTPTabManagerAtom object, handles cleanup and deallocation.

Protected Attributes

BOOL | m_bFocused
TRUE if groups is focused.
- Protected Attributes inherited from CXTPControlPopup
BOOL | m_bPopup
TRUE if pop-up'ed.
CXTPCommandBar * | m_pCommandBar
Child pop-up bar.
DWORD | m_dwCommandBarID
Child pop-up ID.
BOOL | m_bShowShadow
TRUE to show shadow.
- Protected Attributes inherited from CXTPControlButton
XTPButtonStyle | m_buttonStyleEx
User-defined style of button containing vector icon.
- Protected Attributes inherited from CXTPControl
DWORD_PTR | m_nTag
Control tag.
int | m_nIndex
Index of the control.
int | m_nId
Identifier of the control.
int | m_nIconId
Identifier of the control's image.
int | m_nHelpId
Help identifier.
int | m_nCustomIconId
Identifier of the control's custom image.
BOOL | m_bWrap
TRUE if the control is wrapped.
BOOL | m_bBeginGroup
TRUE if the control starts new group.
BOOL | m_bEnabled
TRUE if the control is enabled.
BOOL | m_bChecked
TRUE if the control is checked.
BOOL | m_bSelected
TRUE if the control is selected.
BOOL | m_bPressed
TRUE if the control is pushed.
BOOL | m_bTemporary
TRUE if the control is temporary.
BOOL | m_bOnQuickAccess
TRUE if the control is a part of Quick Access panel.
CRect | m_rcRow
Bounding rectangle of the control's row.
CRect | m_rcControl
Bounding rectangle of the control.
DWORD | m_dwHideFlags
Hidden flags.
DWORD | m_dwFlags
Flags of the control.
CString | m_strCaption
Caption of the control.
CString | m_strCustomCaption
User-defined caption.
CString | m_strShortcutText
Shortcut text.
CString | m_strShortcutTextAuto
Shortcut text.
CString | m_strTooltipText
Tooltip text.
CString | m_strDescriptionText
Description text.
CString | m_strParameter
Parameter text.
CString | m_strKeyboardTip
Keyboard tip.
CXTPControls * | m_pControls
Parent control collection.
XTPControlType | m_controlType
Type of the control.
CXTPCommandBar * | m_pParent
The Parent command bar.
BOOL | m_bExpanded
TRUE if the control is expanded.
CString | m_strCategory
Category of the control.
BOOL | m_bDefaultItem
TRUE if the item is default pop-up item.
CDocTemplateMap | m_mapDocTemplatesAssigned
Assigned templates.
CDocTemplateMap | m_mapDocTemplatesExcluded
Excluded templates.
XTPButtonStyle | m_buttonStyle
Button Style.
XTPButtonStyle | m_buttonCustomStyle
User-defined style of button.
XTPButtonStyle | m_buttonRibbonStyle
User-defined style of button.
BOOL | m_bCloseSubMenuOnClick
TRUE is sub-menus are closed as soon as a control is clicked.
CXTPRibbonGroup * | m_pRibbonGroup
Ribbon group of control.
CXTPControlAction * | m_pAction
Action of the control.
int | m_nWidth
Width of the control.
int | m_nHeight
Height of the control.
int | m_nExecuteOnPressInterval
Delay between each message when control is pressed.
CSize | m_szIcon
The size of the icon used for the control.
BOOL | m_bLayoutRTL
Indicate does last layout is RTL.
- Protected Attributes inherited from CXTPTabManager
CXTPTabManagerItem * m_pSelected
Tab currently selected (i.e.
CXTPTabManagerItem * m_pHighlighted
Tab currently highlighted (i.e.
CXTPTabManagerItem * | m_pPressed
Pointer to the currently pressed tab.
CXTPTabManagerNavigateButton * | m_pHighlightedNavigateButton
Pointer to highlighted navigate button.
int | m_nHeaderOffset
Scroll offset, this is how much the tabs in the tab header have been scrolled using the left and right tab navigation buttons.
BOOL | m_bAllowReorder
TRUE to allow tabs to be reordered.
BOOL | m_bActive
TRUE if the MDITabClient tab group is active.
XTPTabNavigateButtonFlags | m_bCloseItemButton
TRUE to show the close button for tabs.
CRect | m_rcHeaderRect
Bounding rectangle of the tab header area.
CRect | m_rcControl
Bounding rectangle of the tab manager control.
CArray< CXTPTabManagerItem *, CXTPTabManagerItem * > | m_arrItems
Bounding rectangle of the tab client area.
CXTPTabManagerNavigateButtons | m_arrNavigateButtons
Collection of tab navigation buttons for this tab manager.
CRowIndexer * | m_pRowIndexer
Row indexer.
int | m_nScrollDelta
Scroll header delta.
CXTPMarkupContext * | m_pMarkupContext
Markup context of the tab manager.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlPopup
static CXTPControlPopup *AFX_CDECL | CreateControlPopup (XTPControlType controlType)
Creates a CXTPControlPopup object with the specified type.
- Static Public Member Functions inherited from CXTPControl
static CXTPControl *AFX_CDECL | FromUI (CCmdUI *pCmdUI)
Call this member to retrieve CXTPControl from a CCmdUI structure.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

CXTPRibbonControlTab is a CXTPTabManager derived class.

It represents tabs of the Ribbon Bar.

Member Function Documentation

◆ Copy()

void Copy | ( | CXTPControl * | pControl,
 |  | BOOL | bRecursive = FALSE )
 protectedvirtual

This method is called to copy the control.

Parameters
pControl | Pointer to a source CXTPControl object.
bRecursive | TRUE to copy recursively.

Reimplemented from CXTPControlPopup.

◆ DoPropExchange()

void DoPropExchange ( CXTPPropExchange * pPX )
protectedvirtual

Call this member function to store/load a properties collection using the specified data object.

Parameters
pPX Source/destination CXTPPropExchange data object reference.

This member function is used to store/load properties collection data to/form storage.

Reimplemented from CXTPControlPopup.

◆ Draw()

void Draw ( CDC * pDC )
protectedvirtual

This method is called to draw the control.

Parameters
pDC Pointer to a valid device context.

Reimplemented from CXTPControl.

◆ DrawIcon()

BOOL DrawIcon | ( | CDC * | pDC,
 |  | CPoint | pt,
 |  | CXTPTabManagerItem * | pItem,
 |  | BOOL | bDraw,
 |  | CSize & | szIcon ) const
 protectedvirtual

This member is called when the icon of the ribbon tab needs to be drawn.

Parameters
pDC | Pointer to the destination device context.
pt | Specifies the location of the image.
pItem | CXTPTabManagerItem object to draw icon on.
bDraw | TRUE if the icon needs to be drawn (e.g. the icon size changed), FALSE if the icon does not need to be drawn or redrawn.
szIcon | Size of the tab icon.

This member is overridden by its descendants. This member must be overridden in derived classes.

Returns
TRUE if the icon was successfully drawn, FALSE if the icon was not drawn.

Implements CXTPTabManager.

◆ FindTab()

CXTPRibbonTab * FindTab ( int nId ) const

Call this method to find a tab with a specified identifier.

Parameters
nId Identifier of the tab to be found.
Returns
A pointer to the CXTPRibbonTab object with the specified identifier.
See also
FindGroup

◆ GetPaintManager()

virtual CXTPTabPaintManager * GetPaintManager ( ) const
virtual

Call this member to get a pointer to the tab paint manager.

The tab paint manager is used to customize the appearance of CXTPTabManagerItem objects and the tab manager (i.e. tab colors, styles, etc.). This member must be overridden in derived classes.

Returns
A pointer to the CXTPTabPaintManager that contains the visual elements of the tabs.

Implements CXTPTabManager.

◆ GetRibbonBar()

AFX_INLINE CXTPRibbonBar * GetRibbonBar ( ) const

Retrieves the parent CXTPRibbonBar object.

Returns
A pointer to the parent CXTPRibbonBar object.

◆ GetTab()

CXTPRibbonTab * GetTab ( int nIndex ) const

Call this method to retrieve the tab at a specified position.

Parameters
nIndex Index of the tab to retrieve.
Returns
A pointer to the CXTPRibbonTab object at the specified position.
See also
GetTabCount

◆ HeaderHasFocus()

virtual BOOL HeaderHasFocus ( ) const
protectedvirtual

The implementation should return TRUE if the header has focus or FALSE otherwise.

Returns
TRUE if the header has focus, otherwise FALSE.

Reimplemented from CXTPTabManager.

◆ IsFocusable()

virtual BOOL IsFocusable ( ) const
protectedvirtual

This method is called to check if the control can accept focus.

Returns
TRUE if the control can accept focus, otherwise FALSE.
See also
SetFocused

Reimplemented from CXTPControl.

◆ IsFocused()

virtual BOOL IsFocused ( ) const
protectedvirtual

Determines if the control has focus.

Returns
TRUE if the control has focus, otherwise FALSE.

Reimplemented from CXTPControl.

◆ IsMouseLocked()

BOOL IsMouseLocked ( ) const
protectedvirtual

Checks to see if the mouse is locked.

The mouse is locked when a CXTPCommandBarsPopup is currently visible.

Returns
TRUE if the mouse is locked, otherwise FALSE.

Reimplemented from CXTPTabManager.

◆ IsPopupBarTracking()

BOOL IsPopupBarTracking ( ) const
protected

Call this member to get the tracking state.

Returns
TRUE if the ribbon is in tracking mode.

◆ OnHookKeyDown()

BOOL OnHookKeyDown | ( | UINT | nChar,
 |  | LPARAM | lParam )
 protectedvirtual

This method is called when a non-system key is pressed.

Parameters
nChar | Specifies the virtual key code of the given key.
lParam | Specifies additional message-dependent information.
Returns
TRUE if the key was handled, otherwise FALSE.

Reimplemented from CXTPControl.

◆ OnItemClick()

void OnItemClick ( CXTPTabManagerItem * pItem )
protectedvirtual

This method is called when an item (tab button) is clicked.

Parameters
pItem Item that was clicked.

Reimplemented from CXTPTabManager.

◆ OnSetSelected()

BOOL OnSetSelected ( int bSelected )
protectedvirtual

This method is called when the control becomes selected.

Parameters
bSelected TRUE if the control becomes selected.
Returns
TRUE if successful, otherwise FALSE.

Reimplemented from CXTPControlPopup.

◆ RedrawControl()

void RedrawControl | ( | LPCRECT | lpRect,
 |  | BOOL | bAnimate )
 protectedvirtual

Initiates redrawing of the ribbon bar control.

Call this member function if you want to initialize redrawing of the control. The control will be redrawn taking into account its latest state.

Parameters
lpRect | The rectangular area of the window that is invalid.
bAnimate | TRUE to animate changes in the bounding rectangle.

Implements CXTPTabManager.

◆ SetFocused()

virtual void SetFocused ( BOOL bFocused )
protectedvirtual

Call this member to set focus to the control.

Parameters
bFocused TRUE to set focus to the control.

Reimplemented from CXTPControl.

◆ SetSelectedItem()

void SetSelectedItem ( CXTPTabManagerItem * pItem )
virtual

Call this member to select an item in the ribbon bar.

Parameters
pItem Pointer to the CXTPTabManagerItem object to be selected.

Reimplemented from CXTPTabManager.

The documentation for this class was generated from the following file:
  • XTPRibbonControlTab.h


Toolkit Pro: CXTPRibbonCustomizePage Class Reference

Public Member Functions | Public Attributes | Protected Member Functions | Protected Attributes | List of all members
CXTPRibbonCustomizePage Class Reference

CXTPRibbonCustomizePage is a CPropertyPage derived class. More...

Inheritance diagram for CXTPRibbonCustomizePage:
[legend]

Public Member Functions

CXTPRibbonCustomizePage (CXTPCustomizeSheet *pSheet)
Constructs a CXTPRibbonCustomizePage object.
CXTPRibbonCustomizePage (CXTPCommandBars *pCommandBars)
Constructs a CXTPRibbonCustomizePage object.
virtual | ~CXTPRibbonCustomizePage ()
Destroys a CXTPCustomizeCommandsPage object, handles cleanup and deallocation.
CXTPRibbonBar * GetRibbonBar ()
Gets the ribbon bar to customize.
BOOL | AddCategories (UINT nIDResource, BOOL bListSubItems=FALSE)
Adds a categories branch from a menu resource.
BOOL | AddCategories (CXTPControls *pControls)
Adds a categories branch from Controls.
BOOL | AddCategory (LPCTSTR strCategory, CMenu *pMenu, BOOL bListSubItems=FALSE)
Adds a new category from a CMenu object.
CXTPControls * | InsertCategory (LPCTSTR strCategory, int nIndex=-1)
Adds a new empty category at a specified index.
CXTPControls * | GetControls (LPCTSTR strCategory)
Retrieves the control list for a specified category.
- Public Member Functions inherited from CXTPPropertyPage
CXTPPropertyPage ()
Constructs a CXTPPropertyPage object.
CXTPPropertyPage (UINT nIDTemplate, UINT nIDCaption=0)
Constructs a CXTPPropertyPage object.
CXTPPropertyPage (LPCTSTR lpszTemplateName, UINT nIDCaption=0)
Constructs a CXTPPropertyPage object.
~CXTPPropertyPage ()
Destroys a CXTPPropertyPage object, handles cleanup and deallocation.
CString | GetCaption () const
Retrieves the caption text used for property sheet tabs.
void | SetCaption (LPCTSTR lpszCaption)
Sets the caption text used to draw property sheet tabs.
virtual void | UpdatePage (void)
Forces a page to update its internal data as this data is supposed to be changed from outside the page.
- Public Member Functions inherited from CXTPResize
CXTPResize (CWnd *pWnd, const UINT nFlags=0)
Constructs a CXTPResize object.
virtual | ~CXTPResize ()
Destroys a CXTPResize object, handles cleanup and deallocation.
void | SetResize (UINT nID, XTP_RESIZE left, XTP_RESIZE top, XTP_RESIZE right, XTP_RESIZE bottom)
The SetResize function specifies how much each side of a control will move when the dialog is resized.
void | SetResize (UINT nID, const XTP_RESIZERECT &rrcSizing)
The SetResize function specifies how much each side of a control will move when the dialog is resized.
void | SetResize (UINT nID, HWND hWnd, const XTP_RESIZERECT &rrcSizing)
The SetResize function specifies how much each side of a control will move when the dialog is resized.
void | SetResize (UINT nID, HWND hWnd, const XTP_RESIZEPOINT &rpTopLeft, const XTP_RESIZEPOINT &rpBottomRight)
The SetResize function specifies how much each side of a control will move when the dialog is resized.
void | SetResize (UINT nID, const XTP_RESIZEPOINT &rpTopLeft, const XTP_RESIZEPOINT &rpBottomRight)
The SetResize function specifies how much each side of a control will move when the dialog is resized.
void | SetMinSize (CSize &sz)
This member function sets the minimum size explicitly.
void | SetMaxSize (CSize &sz)
This member function sets the maximum size.
BOOL | SavePlacement (LPCTSTR pszSection)
This member function saves the window placement to the registry.
BOOL | LoadPlacement (LPCTSTR pszSection)
This member function loads saved window placement information from the registry.
BOOL | AutoLoadPlacement (LPCTSTR pszSection)
This member function loads saved window placement information from the registry.

Public Attributes

CXTPComboBox | m_cmbCategories
Categories list.
CXTPComboBox | m_cmbTabGroup
Categories list.
CXTPRibbonCustomizeTreeCtrl | m_treeRibbon
Ribbon list.
CXTPRibbonCustomizeTreeCtrl | m_treeCommands
Ribbon list.
- Public Attributes inherited from CXTPPropertyPage
DWORD_PTR | m_dwData
Page specific 32-bit value.

Protected Member Functions

void | RefreshRibbonList ()
Refills the list of Quick Access controls.
- Protected Member Functions inherited from CXTPResize
void | SetResize (CWnd *pWnd, const CXTPResizeRect &rrcSizing, CRect rcWindow)
The SetResize function specifies how much each side of a control will move when the dialog is resized.
BOOL | RemoveResize (UINT nID)
This member function is called to remove the specified dialog item from the list of items to be resized.
void | RemoveAllControls ()
This member function is called to purge the list that contains the dialog items to be sized.
virtual void | Init ()
This member function is called from OnInitDialog or OnInitialUpdate to initialize the resize manager.
virtual void | Size ()
This member function is called from OnSize to move and resize the dialog items that are managed.
void | Reset ()
This member function is called when a property sheet in wizard mode has changed pages to alert the resize manager that the property sheet (common control) has moved the page back to its original size/position on the sheet.
void | Offset (CPoint ptOffset)
Called to offset dialog items by the amount specified by ptOffset.
void | UpdateControlRect (CWnd *pWnd)
Call this method to reset m_rrcWindow for an item.
void | GetMinMaxInfo (MINMAXINFO *pMMI)
This member function is called from OnGetMinMaxInfo to get the maximized position or dimensions or the minimum or maximum tracking size.
virtual void | AdjustResizeRect (CSize &rcWindow)
This method is called in the Size method to adjust a window rectangle to fit real client size.
BOOL | HasFlag (XTPResize eFlag)
This member function is called to determine if the specified flag has been set for the resize manager.
void | SetFlag (XTPResize eFlag)
This member function is called to set a specific flag for the resize manager.
virtual BOOL | Defer (HDWP &hdwp, CXTPResizeItem *pItem, int dx, int dy)
Called by CXTPResize to resize a child window.

Protected Attributes

CXTPCustomizeSheet * | m_pSheet
Parent Sheet window.
CXTPCommandBars * | m_pCommandBars
Parent CommandBars object.
CXTPCommandBarsCategoryArray | m_arrCategories
Array of categories.
- Protected Attributes inherited from CXTPPropertyPage
CXTPPropertySheet * | m_pSheet
Parent CXTPPropertySheet object.
BOOL | m_bModified
TRUE to indicate that the property page settings have been modified.
- Protected Attributes inherited from CXTPResize
UINT | m_nFlagsXX
Flags passed from the constructor.
CWnd * | m_pWnd
The associative relation to the window to be resized.
CSize | m_szWindow
Last dialog size.
CSize | m_szInitWindow
Initial dialog size.
CSize | m_szMin
Smallest size allowed.
CSize | m_szMax
Largest size allowed.
CString | m_strSection
Section in registry where window placement information is saved.
CXTPSizeIcon | m_scSizeIcon
Size icon window.
CResizeItemArray | m_arrItems
Array of controls.

Additional Inherited Members

- Protected Types inherited from CXTPResize
typedef CArray< CXTPResizeItem *, CXTPResizeItem *& > CResizeItemArray
Used by CXTPResize to maintain a list of children that are sizable.

Detailed Description

CXTPRibbonCustomizePage is a CPropertyPage derived class.

It represents the Quick Access page of the Customize dialog.

Constructor & Destructor Documentation

◆ CXTPRibbonCustomizePage() [1/2]

CXTPRibbonCustomizePage ( CXTPCustomizeSheet * pSheet )

Constructs a CXTPRibbonCustomizePage object.

Parameters
pSheet Pointer to a CXTPCustomizeSheet object.

◆ CXTPRibbonCustomizePage() [2/2]

CXTPRibbonCustomizePage ( CXTPCommandBars * pCommandBars )

Constructs a CXTPRibbonCustomizePage object.

Parameters
pCommandBars Pointer to a CXTPCommandBars object.

Member Function Documentation

◆ AddCategories() [1/2]

BOOL AddCategories ( CXTPControls * pControls )

Adds a categories branch from Controls.

Parameters
pControls Pointer to a CXTPControls object
Returns
TRUE if successful, otherwise FALSE.

◆ AddCategories() [2/2]

BOOL AddCategories | ( | UINT | nIDResource,
 |  | BOOL | bListSubItems = FALSE )

Adds a categories branch from a menu resource.

Parameters
nIDResource | Menu resource from which categories will be built.
bListSubItems | TRUE to add sub-menus to categories.
Returns
TRUE if successful, otherwise FALSE.

◆ AddCategory()

BOOL AddCategory | ( | LPCTSTR | strCategory,
 |  | CMenu * | pMenu,
 |  | BOOL | bListSubItems = FALSE )

Adds a new category from a CMenu object.

Parameters
strCategory | Category to be added.
pMenu | Pointer to a CMenu object.
bListSubItems | TRUE to add sub-menus to the category.
Returns
TRUE if successful, otherwise FALSE.

◆ GetControls()

CXTPControls * GetControls ( LPCTSTR strCategory )

Retrieves the control list for a specified category.

Parameters
strCategory Category with the control list to retrieve.
Returns
A pointer to a CXTPControls object.

◆ GetRibbonBar()

CXTPRibbonBar * GetRibbonBar ( )

Gets the ribbon bar to customize.

Returns
A pointer to the ribbon bar to customize.

◆ InsertCategory()

CXTPControls * InsertCategory | ( | LPCTSTR | strCategory,
 |  | int | nIndex = -1 )

Adds a new empty category at a specified index.

Parameters
strCategory | Category to be added.
nIndex | Index to insert at.
Returns
A pointer to a CXTPControls object.
The documentation for this class was generated from the following file:
  • XTPRibbonCustomizePage.h


Toolkit Pro: CXTPRibbonCustomizeQuickAccessPage Class Reference

Public Member Functions | Public Attributes | Protected Member Functions | Protected Attributes | List of all members
CXTPRibbonCustomizeQuickAccessPage Class Reference

CXTPRibbonCustomizeQuickAccessPage is a CPropertyPage derived class. More...

Inheritance diagram for CXTPRibbonCustomizeQuickAccessPage:
[legend]

Public Member Functions

CXTPRibbonCustomizeQuickAccessPage (CXTPCustomizeSheet *pSheet, UINT nIDTemplate=(UINT) -1)
Constructs a CXTPRibbonCustomizeQuickAccessPage object.
CXTPRibbonCustomizeQuickAccessPage (CXTPCommandBars *pCommandBars)
Constructs a CXTPRibbonCustomizeQuickAccessPage object.
~CXTPRibbonCustomizeQuickAccessPage ()
Destroys a CXTPRibbonCustomizeQuickAccessPage object, handles cleanup and deallocation.
CXTPRibbonBar * GetRibbonBar ()
Gets the ribbon bar to customize.
BOOL | AddCategories (UINT nIDResource, BOOL bListSubItems=FALSE)
Adds a categories branch from a menu resource.
BOOL | AddCategories (CXTPControls *pControls)
Adds a categories branch from Controls.
BOOL | AddCategory (LPCTSTR strCategory, CMenu *pMenu, BOOL bListSubItems=FALSE)
Adds a new category from a CMenu object.
CXTPControls * | InsertCategory (LPCTSTR strCategory, int nIndex=-1)
Adds a new empty category at a specified index.
CXTPControls * | GetControls (LPCTSTR strCategory)
Retrieves the control list for a specified category.
virtual void | UpdatePage (void)
Forces a page to update its internal data as this data is supposed to be changed from outside the page.
- Public Member Functions inherited from CXTPPropertyPage
CXTPPropertyPage ()
Constructs a CXTPPropertyPage object.
CXTPPropertyPage (UINT nIDTemplate, UINT nIDCaption=0)
Constructs a CXTPPropertyPage object.
CXTPPropertyPage (LPCTSTR lpszTemplateName, UINT nIDCaption=0)
Constructs a CXTPPropertyPage object.
~CXTPPropertyPage ()
Destroys a CXTPPropertyPage object, handles cleanup and deallocation.
CString | GetCaption () const
Retrieves the caption text used for property sheet tabs.
void | SetCaption (LPCTSTR lpszCaption)
Sets the caption text used to draw property sheet tabs.
- Public Member Functions inherited from CXTPResize
CXTPResize (CWnd *pWnd, const UINT nFlags=0)
Constructs a CXTPResize object.
virtual | ~CXTPResize ()
Destroys a CXTPResize object, handles cleanup and deallocation.
void | SetResize (UINT nID, XTP_RESIZE left, XTP_RESIZE top, XTP_RESIZE right, XTP_RESIZE bottom)
The SetResize function specifies how much each side of a control will move when the dialog is resized.
void | SetResize (UINT nID, const XTP_RESIZERECT &rrcSizing)
The SetResize function specifies how much each side of a control will move when the dialog is resized.
void | SetResize (UINT nID, HWND hWnd, const XTP_RESIZERECT &rrcSizing)
The SetResize function specifies how much each side of a control will move when the dialog is resized.
void | SetResize (UINT nID, HWND hWnd, const XTP_RESIZEPOINT &rpTopLeft, const XTP_RESIZEPOINT &rpBottomRight)
The SetResize function specifies how much each side of a control will move when the dialog is resized.
void | SetResize (UINT nID, const XTP_RESIZEPOINT &rpTopLeft, const XTP_RESIZEPOINT &rpBottomRight)
The SetResize function specifies how much each side of a control will move when the dialog is resized.
void | SetMinSize (CSize &sz)
This member function sets the minimum size explicitly.
void | SetMaxSize (CSize &sz)
This member function sets the maximum size.
BOOL | SavePlacement (LPCTSTR pszSection)
This member function saves the window placement to the registry.
BOOL | LoadPlacement (LPCTSTR pszSection)
This member function loads saved window placement information from the registry.
BOOL | AutoLoadPlacement (LPCTSTR pszSection)
This member function loads saved window placement information from the registry.

Public Attributes

CComboBox | m_lstCategories
Categories list.
CXTPCustomizeCommandsListBox | m_lstQuickAccess
Quick Access list.
CXTPCustomizeCommandsListBox | m_lstCommands
Commands list.
BOOL | m_bShowQuickAccessBelow
TRUE to show Quick Access below ribbon.
- Public Attributes inherited from CXTPPropertyPage
DWORD_PTR | m_dwData
Page specific 32-bit value.

Protected Member Functions

void | RefreshQuickAccessList ()
Refills the list of Quick Access controls.
- Protected Member Functions inherited from CXTPResize
void | SetResize (CWnd *pWnd, const CXTPResizeRect &rrcSizing, CRect rcWindow)
The SetResize function specifies how much each side of a control will move when the dialog is resized.
BOOL | RemoveResize (UINT nID)
This member function is called to remove the specified dialog item from the list of items to be resized.
void | RemoveAllControls ()
This member function is called to purge the list that contains the dialog items to be sized.
virtual void | Init ()
This member function is called from OnInitDialog or OnInitialUpdate to initialize the resize manager.
virtual void | Size ()
This member function is called from OnSize to move and resize the dialog items that are managed.
void | Reset ()
This member function is called when a property sheet in wizard mode has changed pages to alert the resize manager that the property sheet (common control) has moved the page back to its original size/position on the sheet.
void | Offset (CPoint ptOffset)
Called to offset dialog items by the amount specified by ptOffset.
void | UpdateControlRect (CWnd *pWnd)
Call this method to reset m_rrcWindow for an item.
void | GetMinMaxInfo (MINMAXINFO *pMMI)
This member function is called from OnGetMinMaxInfo to get the maximized position or dimensions or the minimum or maximum tracking size.
virtual void | AdjustResizeRect (CSize &rcWindow)
This method is called in the Size method to adjust a window rectangle to fit real client size.
BOOL | HasFlag (XTPResize eFlag)
This member function is called to determine if the specified flag has been set for the resize manager.
void | SetFlag (XTPResize eFlag)
This member function is called to set a specific flag for the resize manager.
virtual BOOL | Defer (HDWP &hdwp, CXTPResizeItem *pItem, int dx, int dy)
Called by CXTPResize to resize a child window.

Protected Attributes

CXTPCustomizeSheet * | m_pSheet
Parent Sheet window.
CXTPCommandBars * | m_pCommandBars
Parent CommandBars object.
CXTPCommandBarsCategoryArray | m_arrCategories
Array of categories.
- Protected Attributes inherited from CXTPPropertyPage
CXTPPropertySheet * | m_pSheet
Parent CXTPPropertySheet object.
BOOL | m_bModified
TRUE to indicate that the property page settings have been modified.
- Protected Attributes inherited from CXTPResize
UINT | m_nFlagsXX
Flags passed from the constructor.
CWnd * | m_pWnd
The associative relation to the window to be resized.
CSize | m_szWindow
Last dialog size.
CSize | m_szInitWindow
Initial dialog size.
CSize | m_szMin
Smallest size allowed.
CSize | m_szMax
Largest size allowed.
CString | m_strSection
Section in registry where window placement information is saved.
CXTPSizeIcon | m_scSizeIcon
Size icon window.
CResizeItemArray | m_arrItems
Array of controls.

Additional Inherited Members

- Protected Types inherited from CXTPResize
typedef CArray< CXTPResizeItem *, CXTPResizeItem *& > CResizeItemArray
Used by CXTPResize to maintain a list of children that are sizable.

Detailed Description

CXTPRibbonCustomizeQuickAccessPage is a CPropertyPage derived class.

It represents the Quick Access page of the Customize dialog.

Constructor & Destructor Documentation

◆ CXTPRibbonCustomizeQuickAccessPage() [1/2]

CXTPRibbonCustomizeQuickAccessPage | ( | CXTPCustomizeSheet * | pSheet,
 |  | UINT | nIDTemplate = (UINT) -1 )

Constructs a CXTPRibbonCustomizeQuickAccessPage object.

Parameters
pSheet | Pointer to a CXTPCustomizeSheet object.
nIDTemplate | Identifier of the dialog resource to be used as the page in the Customize dialog.

◆ CXTPRibbonCustomizeQuickAccessPage() [2/2]

CXTPRibbonCustomizeQuickAccessPage ( CXTPCommandBars * pCommandBars )

Constructs a CXTPRibbonCustomizeQuickAccessPage object.

Parameters
pCommandBars Pointer to a CXTPCommandBars object.

Member Function Documentation

◆ AddCategories() [1/2]

BOOL AddCategories ( CXTPControls * pControls )

Adds a categories branch from Controls.

Parameters
pControls Pointer to a CXTPControls object
Returns
TRUE if successful, otherwise FALSE.

◆ AddCategories() [2/2]

BOOL AddCategories | ( | UINT | nIDResource,
 |  | BOOL | bListSubItems = FALSE )

Adds a categories branch from a menu resource.

Parameters
nIDResource | Menu resource from which categories will be built.
bListSubItems | TRUE to add sub-menus to categories.
Returns
TRUE if successful, otherwise FALSE.

◆ AddCategory()

BOOL AddCategory | ( | LPCTSTR | strCategory,
 |  | CMenu * | pMenu,
 |  | BOOL | bListSubItems = FALSE )

Adds a new category from a CMenu object.

Parameters
strCategory | Category to be added.
pMenu | Pointer to a CMenu object.
bListSubItems | TRUE to add sub-menus to the category.
Returns
TRUE if successful, otherwise FALSE.

◆ GetControls()

CXTPControls * GetControls ( LPCTSTR strCategory )

Retrieves the control list for a specified category.

Parameters
strCategory Category with the control list to retrieve.
Returns
A pointer to a CXTPControls object.

◆ GetRibbonBar()

CXTPRibbonBar * GetRibbonBar ( )

Gets the ribbon bar to customize.

Returns
A pointer to the ribbon bar to customize.

◆ InsertCategory()

CXTPControls * InsertCategory | ( | LPCTSTR | strCategory,
 |  | int | nIndex = -1 )

Adds a new empty category at a specified index.

Parameters
strCategory | Category to be added.
nIndex | Index to insert at.
Returns
A pointer to a CXTPControls object.
The documentation for this class was generated from the following file:
  • XTPRibbonCustomizeQuickAccessPage.h


Toolkit Pro: CXTPRibbonGroup Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPRibbonGroup Class Reference

Represents a single group that is added to a CXTPRibbonTab. More...

Inheritance diagram for CXTPRibbonGroup:
[legend]

Public Member Functions

CXTPRibbonGroup ()
Constructs a CXTPRibbonGroup object.
virtual | ~CXTPRibbonGroup ()
Destroys a CXTPRibbonGroup object, handles cleanup and deallocation.
void | SetCaption (LPCTSTR lpszCaption)
Sets the text to display in the group title bar.
CString | GetCaption () const
Gets the text displayed in the group title bar.
CXTPCommandBar * | GetParent () const
Call this member to get the parent command bar.
virtual void | SetRect (CRect rc)
Sets the bounding rectangle for the group.
CRect | GetRect () const
Gets the bounding rectangle of the group.
CRect | GetCaptionRect () const
Gets the bounding rectangle of the group caption.
CXTPRibbonBar * | GetRibbonBar () const
Gets the CXTPRibbonBar object that the CXTPRibbonGroup belongs to.
CXTPRibbonTab * | GetParentTab () const
Gets the CXTPRibbonTab object that the CXTPRibbonGroup belongs to.
BOOL | IsHighlighted () const
Gets whether the group is currently highlighted.
int | IndexOf (CXTPControl *pControl) const
Retrieves the index of a specified CXTPControl object in the CXTPRibbonGroup.
int | GetCount () const
Gets the total number of CXTPControl objects that have been added to the CXTPRibbonGroup.
CXTPControl * | Add (XTPControlType controlType, int nId, LPCTSTR lpszParameter=NULL, int nBefore=-1, BOOL bTemporary=FALSE)
Adds a CXTPControl to the ribbon group.
CXTPControl * | Add (CXTPControl *pControl, int nId, LPCTSTR lpszParameter=NULL, int nBefore=-1, BOOL bTemporary=FALSE)
Adds a CXTPControl to the ribbon group.
CXTPControl * | AddClone (CXTPControl *pControl, int nBefore, BOOL bRecursive=FALSE)
Adds a CXTPControl to the ribbon group.
CXTPControl * | InsertAt (CXTPControl *pControl, int nBefore=-1)
Adds a CXTPControl to the ribbon group.
CXTPControl * | GetAt (int nIndex) const
Gets the CXTPControl object that has been added to the CXTPRibbonGroup at the specified index.
void | RemoveAt (int nIndex)
Removes the item at a specified index from the group's collection of items.
void | Remove (CXTPControl *pControl)
Removes a specified item from the group's collection of items.
void | RemoveAll ()
Removes all items from the group.
BOOL | IsReduced () const
Determines if the CXTPRibbonGroup is currently displayed as a group button.
void | SetIconId (int nId)
Call this member to set the group icon's identifier.
int | GetIconId () const
Call this member to get the group icon's identifier.
void | ShowOptionButton (BOOL bShowOptionButton=TRUE)
Specifies whether to display an option button in the group's caption.
BOOL | IsOptionButtonVisible () const
Determines if the option button is visible.
BOOL | IsVisible () const
Determines if the group is visible.
void | SetVisible (BOOL bVisible)
Call this method to show/hide the group.
int | GetIndex () const
Retrieves the group's own index within the parent group collection.
virtual void | Copy (CXTPRibbonGroup *pGroup)
Copies a parameter from one group to another.
CXTPControl * | SetControlType (CXTPControl *pControl, XTPControlType type)
Call this member to change the type of the control.
CXTPControl * | FindControl (int nId) const
Call this member to find the specified control.
CXTPControl * | FindControl (XTPControlType type, int nId, BOOL bVisible, BOOL bRecursive) const
Call this member to find the specified control.
int | GetID () const
Gets the group's ID.
void | SetID (int nId)
Sets the group's ID.
BOOL | IsControlsGrouping () const
Determines if controls grouping is used.
void | SetControlsGrouping (BOOL bControlsGrouping=TRUE)
Specifies if controls grouping should be used.
void | SetControlsCentering (BOOL bControlsCentering=TRUE)
Specifies if controls should be automatically centered in the group.
BOOL | IsControlsCentering () const
Determines if controls are automatically centered in the group.
virtual void | Draw (CDC *pDC, CRect rcClipBox)
Draws the group and all of the controls in the group.
virtual void | DoPropExchange (CXTPPropExchange *pPX)
Reads/writes this object from/to an archive.
void | AllowReduce (int nAllowReduceLevel=0)
Sets the ribbon group reduction level.
int | GetAllowReduceLevel () const
Gets the ribbon group reduction level.
void | SetArrangeEditCaption (BOOL bArrangeEditCaption)
Call this method to specify whether the group will automatically align caption/edit parts.
CXTPControl * | GetControlGroupOption () const
Retrieves the CXTPControl that represents the group's OptionButton (used to set tooltip and status bar text).
CXTPControlPopup * | GetControlGroupPopup () const
Retrieves the CXTPControlPopup used to display controls that are not currently visible in the group.
BOOL | LoadToolBar (UINT nIDResource, BOOL bLoadIcons=TRUE)
Loads the toolbar specified by nIDResource.
BOOL | SetButtons (UINT *pButtons, int nCount)
Sets the controls from the button array.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

virtual void | RepositionControls (CDC *pDC)
Called automatically to reposition all controls in the group.
virtual void | OnGroupAdded ()
This method is called when the group is added.
virtual void | OnGroupRemoved ()
This method is called when the group is removed.
virtual int | GetMinimumWidth (CDC *pDC)
Calculates the minimum width of the ribbon group.
virtual void | OnBeforeCalcSize (CDC *pDC)
This method is called before the size of the ribbon group is calculated.
virtual void | OnAfterCalcSize ()
This method is called after the size of the ribbon group is calculated.
virtual int | OnCalcDynamicSize (CDC *pDC)
This method is called to retrieve the width of the ribbon group.
virtual BOOL | OnReduceSize (int nLevel, int nWidthAvail)
This method is called to reduce the size of the ribbon group.
virtual BOOL | OnExtendSize (int nWidthAvail)
This method is called to extend the size of the ribbon group.

Protected Attributes

BOOL | m_bControlsCentering
TRUE to center controls inside groups.
BOOL | m_bControlsGrouping
TRUE to group controls.
CString | m_strCaption
Caption of the group.
int | m_nIndex
Index of the group.
CXTPRibbonGroups * | m_pGroups
Parent groups collection.
CRect | m_rcGroup
Bounding rectangle of the group.
CArray< CXTPControl *, CXTPControl * > | m_arrControls
Collection of group's controls.
CXTPCommandBar * | m_pParent
Parent ribbon bar.
CXTPRibbonBar * | m_pRibbonBar
Parent ribbon bar.
int | m_nId
Identifier of the group.
int | m_nIconId
Icon index of the group.
CXTPControl * | m_pControlGroupOption
Group option control.
CXTPControlPopup * | m_pControlGroupPopup
Group popup control.
BOOL | m_bReduced
TRUE if group was reduced.
BOOL | m_bShowOptionButton
TRUE to show option button.
BOOL | m_bVisible
TRUE if group is visible.
int | m_nAllowReduce
Ribbon group reduction level.
int | m_nRowCount
Total rows number of items.
BOOL | m_bAutoArrangeEditCaption
Specifies whether the group will automatically align caption/edit parts.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

Represents a single group that is added to a CXTPRibbonTab.

Each CXTPRibbonTab can contain one or more CXTPRibbonGroup objects that are used to hold CXTPControl objects. The caption of a CXTPRibbonGroup is a title bar that visually "groups" the CXTPControl objects that have been added to the RibbonGroup Items Collection (CXTPRibbonGroup::GetAt).

Groups are added to the CXTPRibbonTab Groups Collection using the CXTPRibbonGroups::AddGroup and CXTPRibbonGroups::InsertAt methods. Items are added to a group using the CXTPRibbonGroup::Add method.

See also
CXTPRibbonGroup::GetAt

Member Function Documentation

◆ Add() [1/2]

CXTPControl * Add | ( | CXTPControl * | pControl,
 |  | int | nId,
 |  | LPCTSTR | lpszParameter = NULL,
 |  | int | nBefore = -1,
 |  | BOOL | bTemporary = FALSE )

Adds a CXTPControl to the ribbon group.

Parameters
nId | Identifier of the CXTPControl to be added.
lpszParameter | The caption of the CXTPControl to be added.
nBefore | Index of an existing control that the new control will be inserted before.
bTemporary | Boolean value indicating whether the control is temporary. Temporary controls will not be saved to the system registry when the application is closed, and they will not be restored when the application is opened.
pControl | Pointer to a CXTPControl to add to the ribbon group.

The Add method allows CXTPControl objects to be added to the ribbon group.

Returns
A pointer to the CXTPControl object that was added to the ribbon group.
See also
CXTPControl, GetAt, GetCount, RemoveAt, RemoveAll

◆ Add() [2/2]

CXTPControl * Add | ( | XTPControlType | controlType,
 |  | int | nId,
 |  | LPCTSTR | lpszParameter = NULL,
 |  | int | nBefore = -1,
 |  | BOOL | bTemporary = FALSE )

Adds a CXTPControl to the ribbon group.

Parameters
controlType | Type of control to add to the ribbon group.
nId | Identifier of the CXTPControl to be added.
lpszParameter | The caption of the CXTPControl to be added.
nBefore | Index of an existing control that the new control will be inserted before.
bTemporary | Boolean value indicating whether the control is temporary. Temporary controls will not be saved to the system registry when the application is closed, and they will not be restored when the application is opened.

The Add method allows CXTPControl objects to be added to the ribbon group.

Returns
A pointer to the CXTPControl object that was added to the ribbon group.
See also
CXTPControl, GetAt, GetCount, RemoveAt, RemoveAll

◆ AddClone()

CXTPControl * AddClone | ( | CXTPControl * | pControl,
 |  | int | nBefore,
 |  | BOOL | bRecursive = FALSE )

Adds a CXTPControl to the ribbon group.

Parameters
bRecursive | TRUE to find the control in the nested command bars.
nBefore | Index of an existing control that the new control will be inserted before.
pControl | Pointer to a CXTPControl to add to the ribbon group.

The Add method allows CXTPControl objects to be added to the ribbon group.

Returns
A pointer to the CXTPControl object that was added to the ribbon group.
See also
CXTPControl, GetAt, GetCount, RemoveAt, RemoveAll

◆ AllowReduce()

AFX_INLINE void AllowReduce ( int nAllowReduceLevel = 0 )

Sets the ribbon group reduction level.

Parameters
nAllowReduceLevel Ribbon group reduction level to be set; must be one of the values defined by the XTPRibbonGroupReductionLevels enumeration.
See also
XTPRibbonGroupReductionLevels

◆ Copy()

virtual void Copy ( CXTPRibbonGroup * pGroup )
virtual

Copies a parameter from one group to another.

Parameters
pGroup Group with the parameter to be copied.

◆ DoPropExchange()

virtual void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Reads/writes this object from/to an archive.

Parameters
pPX Pointer to a CXTPPropExchange object to serialize to/from.

◆ Draw()

virtual void Draw | ( | CDC * | pDC,
 |  | CRect | rcClipBox )
 virtual

Draws the group and all of the controls in the group.

Parameters
pDC | Pointer to the device context in which to draw the group.
rcClipBox | The rectangular area of the window that is invalid.

◆ FindControl() [1/2]

CXTPControl * FindControl ( int nId ) const

Call this member to find the specified control.

Parameters
nId Control's identifier.
Returns
A pointer to the CXTPControl object if successful, otherwise NULL.

◆ FindControl() [2/2]

CXTPControl * FindControl | ( | XTPControlType | type,
 |  | int | nId,
 |  | BOOL | bVisible,
 |  | BOOL | bRecursive ) const

Call this member to find the specified control.

Parameters
type | Type of the control to find.
nId | Control's identifier.
bVisible | TRUE if the control is visible.
bRecursive | TRUE to find the control in the nested command bars.
Returns
A pointer to the CXTPControl object if successful, otherwise NULL.

◆ GetAllowReduceLevel()

AFX_INLINE int GetAllowReduceLevel ( ) const

Gets the ribbon group reduction level.

Returns
The ribbon group reduction level; one of the values defined by the XTPRibbonGroupReductionLevels enumeration.
See also
XTPRibbonGroupReductionLevels

◆ GetAt()

AFX_INLINE CXTPControl * GetAt ( int nIndex ) const

Gets the CXTPControl object that has been added to the CXTPRibbonGroup at the specified index.

Parameters
nIndex Index of the item to retrieve within the group's collection of controls.

GetAt retrieves the CXTPControl from the m_arrControls items collection that contains all of the CXTPControl objects that have been added to the CXTPRibbonGroup.

Returns
A pointer to the CXTPControl object at the specified index.
See also
m_arrControls, Add, RemoveAt, RemoveAll

◆ GetCaption()

AFX_INLINE CString GetCaption ( ) const

Gets the text displayed in the group title bar.

The caption is the text string that is displayed in the group's title bar. The caption of the group is initially set when it is added or inserted.

Returns
The text displayed in the group title bar.
See also
SetCaption, CXTPRibbonGroups::AddGroup, CXTPRibbonGroups::InsertAt

◆ GetCaptionRect()

CRect GetCaptionRect ( ) const

Gets the bounding rectangle of the group caption.

The rectangle is the size of the group caption.

Returns
A CRect containing the bounding rectangle of the group caption.
See also
SetRect

◆ GetControlGroupOption()

AFX_INLINE CXTPControl * GetControlGroupOption ( ) const

Retrieves the CXTPControl that represents the group's OptionButton (used to set tooltip and status bar text).

GetControlGroupOption is only used to set the tooltip text and description text for the OptionButton. No other properties/methods of the CXTPControl are used.

Returns
A pointer to the CXTPControl that represents the group's OptionButton.
See also
CXTPRibbonPaintManager::DrawControlGroupOption

◆ GetControlGroupPopup()

AFX_INLINE CXTPControlPopup * GetControlGroupPopup ( ) const

Retrieves the CXTPControlPopup used to display controls that are not currently visible in the group.

A single group button will be displayed if there is not enough room to display the items in the group. A group pop-up is displayed when the button is clicked. The pop-up contains all the items in the group. When a group button is clicked, a CXTPControlPopup is displayed that contains the items of the group.

Returns
A pointer to the CXTPControlPopup used to display controls that are not currently visible in the group.
See also
IsReduced, CXTPRibbonPaintManager::DrawControlGroupPopup

◆ GetCount()

AFX_INLINE int GetCount ( ) const

Gets the total number of CXTPControl objects that have been added to the CXTPRibbonGroup.

Returns
The total number of CXTPControl objects that have been added to the CXTPRibbonGroup.

A CXTPRibbonGroup is used to hold one or more CXTPControl objects. The total number of items can be found by using GetCount.

See also
CXTPRibbonGroup

◆ GetIconId()

AFX_INLINE int GetIconId ( ) const

Call this member to get the group icon's identifier.

This is the ID of the image to use for the group button that is displayed when there is not enough room to display the items in the group.

The m_nIconId specifies the ID of the image to use for the group button that is displayed when there is not enough room to display the items in the group. When a group button is clicked, a CXTPControlPopup is displayed that contains the items of the group. No image will be displayed for the group button if m_nIconId is not set.

Returns
The group icon's identifier.
See also
IsReduced, SetIconId, GetControlGroupPopup

◆ GetID()

AFX_INLINE int GetID ( ) const

Gets the group's ID.

The ID is used to identify the group.

Returns
The group's ID.
See also
GetControlGroupPopup, GetControlGroupOption

◆ GetIndex()

AFX_INLINE int GetIndex ( ) const

Retrieves the group's own index within the parent group collection.

Returns
The group's own index within the parent group collection.

◆ GetMinimumWidth()

virtual int GetMinimumWidth ( CDC * pDC )
protectedvirtual

Calculates the minimum width of the ribbon group.

Parameters
pDC Pointer to the device context used to draw the ribbon group.
Returns
The minimum width of the ribbon group.
See also
Draw

◆ GetParent()

AFX_INLINE CXTPCommandBar * GetParent ( ) const

Call this member to get the parent command bar.

Returns
A pointer to the parent command bar object.

◆ GetParentTab()

CXTPRibbonTab * GetParentTab ( ) const

Gets the CXTPRibbonTab object that the CXTPRibbonGroup belongs to.

Returns
A pointer to the CXTPRibbonTab object that the CXTPRibbonGroup belongs to. This is the tab that the group is displayed in.
See also
CXTPRibbonTab

◆ GetRect()

AFX_INLINE CRect GetRect ( ) const

Gets the bounding rectangle of the group.

The rectangle is the size of the entire group, including the group caption and group pop-up if present.

Returns
A CRect containing the bounding rectangle of the group.
See also
SetRect

◆ GetRibbonBar()

AFX_INLINE CXTPRibbonBar * GetRibbonBar ( ) const

Gets the CXTPRibbonBar object that the CXTPRibbonGroup belongs to.

Returns
A pointer to the CXTPRibbonBar object that the CXTPRibbonGroup belongs to. This is the ribbon bar that the group is displayed in.
See also
CXTPRibbonBar

◆ IndexOf()

int IndexOf ( CXTPControl * pControl ) const

Retrieves the index of a specified CXTPControl object in the CXTPRibbonGroup.

Parameters
pControl Control whose index must be retrieved.

This member function is used to get the zero-based index of items in the group. If the item is not found, it returns a value of -1.

Returns
The index of the specified control if successful, otherwise -1.

◆ InsertAt()

CXTPControl * InsertAt | ( | CXTPControl * | pControl,
 |  | int | nBefore = -1 )

Adds a CXTPControl to the ribbon group.

Parameters
pControl | Control to add.
nBefore | Index of an existing control that the new control will be inserted before.
Returns
A pointer to the CXTPControl object that was added to the ribbon group.
See also
Add

◆ IsControlsCentering()

AFX_INLINE BOOL IsControlsCentering ( ) const

Determines if controls are automatically centered in the group.

Returns
TRUE if controls are automatically centered in the group, otherwise FALSE.

◆ IsControlsGrouping()

AFX_INLINE BOOL IsControlsGrouping ( ) const

Determines if controls grouping is used.

This is for controls grouping within a ribbon group. When you set begin group to TRUE, it starts a new group of controls. SetControlsGrouping will group controls like in MS Word within the ribbon group. If you pass FALSE, it groups them like in a regular toolbar (divider line).

Returns
TRUE if controls grouping is used, otherwise FALSE.
See also
SetControlsGrouping

◆ IsHighlighted()

BOOL IsHighlighted ( ) const

Gets whether the group is currently highlighted.

A group becomes highlighted when the mouse cursor is positioned over the group or any items in the group.

Returns
TRUE if the group is currently highlighted, otherwise FALSE.
See also
CXTPRibbonBar::GetHighlightedGroup

◆ IsOptionButtonVisible()

BOOL IsOptionButtonVisible ( ) const

Determines if the option button is visible.

Returns
TRUE if the option button is visible.
See also
ShowOptionButton

◆ IsReduced()

AFX_INLINE BOOL IsReduced ( ) const

Determines if the CXTPRibbonGroup is currently displayed as a group button.

A single group button will be displayed if there is not enough room to display the items in the group. A group pop-up is displayed when the button is clicked. The pop-up contains all the items in the group. When a group button is clicked, a CXTPControlPopup is displayed that contains the items of the group.

The m_nIconId specifies the ID of the image to use for the group button that is displayed when there is not enough room to display the items in the group. No image will be displayed for the group button if m_nIconId is not set with SetIconId.

Returns
TRUE if the group is displayed as a single group button, FALSE if the group is displayed normally.
See also
SetIconId, GetIconId, GetControlGroupPopup

◆ IsVisible()

BOOL IsVisible ( ) const

Determines if the group is visible.

Returns
TRUE if the group is visible.
See also
SetVisible

◆ LoadToolBar()

BOOL LoadToolBar | ( | UINT | nIDResource,
 |  | BOOL | bLoadIcons = TRUE )

Loads the toolbar specified by nIDResource.

Parameters
nIDResource | Resource ID of the toolbar to be loaded.
bLoadIcons | TRUE to load icons from application resources.
Returns
Nonzero if successful, otherwise 0.

◆ OnAfterCalcSize()

virtual void OnAfterCalcSize ( )
protectedvirtual

This method is called after the size of the ribbon group is calculated.

See also
OnBeforeCalcSize

◆ OnBeforeCalcSize()

virtual void OnBeforeCalcSize ( CDC * pDC )
protectedvirtual

This method is called before the size of the ribbon group is calculated.

Parameters
pDC Pointer to the device context used to draw the ribbon group.
See also
OnAfterCalcSize

◆ OnCalcDynamicSize()

virtual int OnCalcDynamicSize ( CDC * pDC )
protectedvirtual

This method is called to retrieve the width of the ribbon group.

Parameters
pDC Pointer to the device context used to draw the ribbon group.
Returns
The width of the ribbon group.
See also
OnBeforeCalcSize, OnAfterCalcSize, GetMinimumWidth

◆ OnExtendSize()

virtual BOOL OnExtendSize ( int nWidthAvail )
protectedvirtual

This method is called to extend the size of the ribbon group.

Parameters
nWidthAvail Total pixels to extend the size of the ribbon group by.
Returns
TRUE if the size of the ribbon group was extended.

◆ OnGroupAdded()

virtual void OnGroupAdded ( )
protectedvirtual

This method is called when the group is added.

See also
OnGroupRemoved

◆ OnGroupRemoved()

virtual void OnGroupRemoved ( )
protectedvirtual

This method is called when the group is removed.

See also
OnGroupAdded

◆ OnReduceSize()

virtual BOOL OnReduceSize | ( | int | nLevel,
 |  | int | nWidthAvail )
 protectedvirtual

This method is called to reduce the size of the ribbon group.

Parameters
nLevel | Reduce level; must be one of the values defined by the XTPRibbonGroupReductionLevels enumeration.
nWidthAvail | Total pixels to reduce the size of the ribbon group by.
Returns
TRUE if the size of the ribbon group was reduced.
See also
XTPRibbonGroupReductionLevels

◆ Remove()

void Remove ( CXTPControl * pControl )

Removes a specified item from the group's collection of items.

Parameters
pControl Item to remove from the group's collection of items.
See also
RemoveAt, Add, GetAt, RemoveAll

◆ RemoveAll()

void RemoveAll ( )

Removes all items from the group.

See also
m_arrControls, Add, GetAt, RemoveAt

◆ RemoveAt()

void RemoveAt ( int nIndex )

Removes the item at a specified index from the group's collection of items.

Parameters
nIndex Index of the item to remove from the group's collection of items.

Removes an item by its index from the group's collection of items.

See also
m_arrControls, Add, GetAt, RemoveAll

◆ RepositionControls()

virtual void RepositionControls ( CDC * pDC )
protectedvirtual

Called automatically to reposition all controls in the group.

(e.g. when the position/size of the ribbon bar changes).

Parameters
pDC Pointer to the device context in which to draw the group.

◆ SetArrangeEditCaption()

AFX_INLINE void SetArrangeEditCaption ( BOOL bArrangeEditCaption )

Call this method to specify whether the group will automatically align caption/edit parts.

Parameters
bArrangeEditCaption TRUE to automatically align caption/edit parts.

◆ SetButtons()

BOOL SetButtons | ( | UINT * | pButtons,
 |  | int | nCount )

Sets the controls from the button array.

Parameters
pButtons | Pointer to an array of command IDs. It cannot be NULL.
nCount | Number of elements in the array pointed to by pButtons.
Returns
Nonzero if successful, otherwise 0.
See also
LoadToolBar

◆ SetCaption()

void SetCaption ( LPCTSTR lpszCaption )

Sets the text to display in the group title bar.

Parameters
lpszCaption Text to display in the group title bar.

The caption is the text string that is displayed in the group's title bar. The caption of the group is initially set when it is added or inserted.

See also
GetCaption, CXTPRibbonGroups::AddGroup, CXTPRibbonGroups::InsertAt

◆ SetControlsCentering()

AFX_INLINE void SetControlsCentering ( BOOL bControlsCentering = TRUE )

Specifies if controls should be automatically centered in the group.

Parameters
bControlsCentering TRUE to automatically center controls in the group.

◆ SetControlsGrouping()

AFX_INLINE void SetControlsGrouping ( BOOL bControlsGrouping = TRUE )

Specifies if controls grouping should be used.

Parameters
bControlsGrouping TRUE to use controls grouping.

This is for controls grouping within a ribbon group. When you set begin group to TRUE, it starts a new group of controls. SetControlsGrouping will group controls like in MS Word within the ribbon group. If you pass FALSE, it groups them like in a regular toolbar (divider line).

See also
IsControlsGrouping

◆ SetControlType()

CXTPControl * SetControlType | ( | CXTPControl * | pControl,
 |  | XTPControlType | type )

Call this member to change the type of the control.

Parameters
pControl | Pointer to a CXTPControl object.
type | New control type; one of the values defined by the XTPControlType enumeration.
Returns
A pointer to a CXTPControl object.

◆ SetIconId()

AFX_INLINE void SetIconId ( int nId )

Call this member to set the group icon's identifier.

This is the ID of the image to use for the group button that is displayed when there is not enough room to display the items in the group.

Parameters
nId Group icon identifier to be set.

The m_nIconId specifies the ID of the image to use for the group button that is displayed when there is not enough room to display the items in the group. When a group button is clicked, a CXTPControlPopup is displayed that contains the items of the group. No image will be displayed for the group button if m_nIconId is not set.

See also
IsReduced, GetIconId, GetControlGroupPopup

◆ SetID()

void SetID ( int nId )

Sets the group's ID.

Parameters
nId New ID to be set.
See also
GetID

◆ SetRect()

virtual void SetRect ( CRect rc )
virtual

Sets the bounding rectangle for the group.

Parameters
rc CRect object containing the bounding rectangle for the group.

The rectangle is the size of the entire group, including the group caption and group pop-up if present.

See also
GetRect

◆ SetVisible()

void SetVisible ( BOOL bVisible )

Call this method to show/hide the group.

Parameters
bVisible TRUE to show the group, FALSE to hide.
See also
IsVisible

◆ ShowOptionButton()

AFX_INLINE void ShowOptionButton ( BOOL bShowOptionButton = TRUE )

Specifies whether to display an option button in the group's caption.

Parameters
bShowOptionButton TRUE to show an option button in the group's caption, FALSE to hide the option button if one was visible.

The option button is typically used to launch a dialog associated with the group. The Group ID (GetID) is used to identify which groups' option button was clicked.

See also
m_bShowOptionButton, GetID, CXTPRibbonPaintManager::DrawControlGroupOption
The documentation for this class was generated from the following file:
  • XTPRibbonGroup.h


Toolkit Pro: CXTPRibbonGroups Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPRibbonGroups Class Reference

Represents a collection of CXTPRibbonGroup objects. More...

Inheritance diagram for CXTPRibbonGroups:
[legend]

Public Member Functions

CXTPRibbonGroups ()
Constructs a CXTPRibbonGroups object.
virtual | ~CXTPRibbonGroups ()
Destroys a CXTPRibbonGroups object, handles cleanup and deallocation.
void | Copy (CXTPRibbonGroups *pGroups)
Copies all groups from a CXTPRibbonGroups object.
void | RemoveAll ()
Removes all groups.
void | Remove (int nIndex)
Removes a specified group.
void | Remove (CXTPRibbonGroup *pGroup)
Removes a specified group.
CXTPRibbonGroup * | InsertAt (int nIndex, LPCTSTR lpszCaption, int nId=-1)
Adds a CXTPRibbonGroup to a CXTPRibbonTab at a specific location.
CXTPRibbonGroup * | InsertAt (int nIndex, CXTPRibbonGroup *pGroup)
Adds a CXTPRibbonGroup to a CXTPRibbonTab at a specific location.
CXTPRibbonGroup * | Add (LPCTSTR lpszCaption, int nId=-1)
Adds a CXTPRibbonGroup to a CXTPRibbonTab.
int | GetCount () const
Retrieves the total number of CXTPRibbonGroup objects that have been added to the CXTPRibbonTab.
CXTPRibbonGroup * | GetAt (int nIndex) const
Gets the CXTPRibbonGroup object that has been added to the CXTPRibbonTab at a specified index.
CXTPRibbonGroup * | HitTest (CPoint point) const
This member function determines which ribbon group, if any, is at a specified position.
CXTPRibbonBar * | GetRibbonBar () const
Gets the CXTPRibbonBar object that the CXTPRibbonGroup belongs to.
CXTPRibbonTab * | GetParentTab () const
Gets the CXTPRibbonTab object that the CXTPRibbonGroup belongs to.
void | CalcDynamicSize (CDC *pDC, int nLength, DWORD dwMode, const CRect &rcBorder)
This method is called internally to reposition groups and controls.
virtual void | DoPropExchange (CXTPPropExchange *pPX)
Reads/writes this object from/to an archive.
int | GetScrollPos () const
Gets the group scroll position.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Attributes

CArray< CXTPRibbonGroup *, CXTPRibbonGroup * > | m_arrGroups
Collection of groups.
CXTPRibbonTab * m_pParentTab
A pointer to the CXTPRibbonTab object the CXTPRibbonGroup belongs to.
int | m_nGroupsScrollPos
Group scroll position.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

Represents a collection of CXTPRibbonGroup objects.

A CXTPRibbonTab uses the CXTPRibbonGroups object for its groups collection to store all of the RibbonGroup objects that have been added to the RibbonTab. A CXTPRibbonGroup is used to hold items such as buttons, pop-ups, edit controls, etc.

Groups are added to the groups collection using the Add and InsertAt methods.

See also
Add, InsertAt

Member Function Documentation

◆ Add()

CXTPRibbonGroup * Add | ( | LPCTSTR | lpszCaption,
 |  | int | nId = -1 )

Adds a CXTPRibbonGroup to a CXTPRibbonTab.

Parameters
lpszCaption | Text to display in the group title bar. This is the group's caption.
nId | Identifier of new group.

Tabs in the ribbon bar contain one or more CXTPRibbonGroup objects. Buttons, pop-ups, etc. can then be added to the groups.

Returns
A pointer to the CXTPRibbonGroup object added to the CXTPRibbonTab groups collection.
See also
InsertAt, Remove, GetCount, GetAt, RemoveAll

◆ CalcDynamicSize()

void CalcDynamicSize | ( | CDC * | pDC,
 |  | int | nLength,
 |  | DWORD | dwMode,
 |  | const CRect & | rcBorder )

This method is called internally to reposition groups and controls.

Parameters
pDC | Pointer to a valid device context.
nLength | Length of the parent bar.
dwMode | Mode of the parent bar.
rcBorder | Border to be set.
See also
CXTPRibbonBar::RepositionGroups

◆ Copy()

void Copy ( CXTPRibbonGroups * pGroups )

Copies all groups from a CXTPRibbonGroups object.

Parameters
pGroups Pointer to a CXTPRibbonGroups object to copy from.

◆ DoPropExchange()

virtual void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Reads/writes this object from/to an archive.

Parameters
pPX Pointer to a CXTPPropExchange object to serialize to/from.

◆ GetAt()

AFX_INLINE CXTPRibbonGroup * GetAt ( int nIndex ) const

Gets the CXTPRibbonGroup object that has been added to the CXTPRibbonTab at a specified index.

Parameters
nIndex Index of the group to retrieve within the groups collection.

GetAt retrieves the CXTPRibbonGroup from the m_arrGroups groups collection that contains all of the CXTPRibbonGroup objects that have been added to the CXTPRibbonTab.

Returns
The CXTPRibbonGroup at the specified index.
See also
InsertAt, Remove, GetCount, Add, RemoveAll

◆ GetCount()

AFX_INLINE int GetCount ( ) const

Retrieves the total number of CXTPRibbonGroup objects that have been added to the CXTPRibbonTab.

Returns
The total number of CXTPRibbonGroup objects that have been added to the CXTPRibbonTab.
See also
InsertAt, Remove, Add, GetAt, RemoveAll

◆ GetParentTab()

AFX_INLINE CXTPRibbonTab * GetParentTab ( ) const

Gets the CXTPRibbonTab object that the CXTPRibbonGroup belongs to.

Returns
A pointer to the CXTPRibbonTab object that the CXTPRibbonGroup belongs to. This is the tab that the group is displayed in.
See also
CXTPRibbonTab

◆ GetRibbonBar()

CXTPRibbonBar * GetRibbonBar ( ) const

Gets the CXTPRibbonBar object that the CXTPRibbonGroup belongs to.

Returns
A pointer to the CXTPRibbonBar object that the CXTPRibbonGroup belongs to. This is the ribbon bar that the group is displayed in.
See also
CXTPRibbonBar

◆ GetScrollPos()

AFX_INLINE int GetScrollPos ( ) const

Gets the group scroll position.

Returns
The group scroll position.

◆ HitTest()

CXTPRibbonGroup * HitTest ( CPoint point ) const

This member function determines which ribbon group, if any, is at a specified position.

Parameters
point Point to test.
Returns
The CXTPRibbonGroup at the specified position, if any, otherwise NULL.

◆ InsertAt() [1/2]

CXTPRibbonGroup * InsertAt | ( | int | nIndex,
 |  | CXTPRibbonGroup * | pGroup )

Adds a CXTPRibbonGroup to a CXTPRibbonTab at a specific location.

Parameters
nIndex | Position within the tab's groups collection to insert the new CXTPRibbonGroup.
pGroup | New group to insert.

InsertAt adds a group at a specific location within the tab's groups collection. Groups will be displayed in the order they are added. This means the group with an index of zero (0) will be displayed first to the far left, then to the immediate right will be the group with an index of one (1), and so on.

Returns
A pointer to the CXTPRibbonGroup object added to the CXTPRibbonTab groups collection.
See also
Add, Remove, GetCount, GetAt, RemoveAll

◆ InsertAt() [2/2]

CXTPRibbonGroup * InsertAt | ( | int | nIndex,
 |  | LPCTSTR | lpszCaption,
 |  | int | nId = -1 )

Adds a CXTPRibbonGroup to a CXTPRibbonTab at a specific location.

Parameters
nIndex | Position within the tab's groups collection to insert the new CXTPRibbonGroup.
lpszCaption | Text to display in the group title bar. This is the group's caption.
nId | Identifier of the new group.

InsertAt adds a group at a specific location within the tab's groups collection. Groups will be displayed in the order they are added. This means the group with an index of zero (0) will be displayed first to the far left, then to the immediate right will be the group with an index of one (1), and so on.

Returns
A pointer to the CXTPRibbonGroup object added to the CXTPRibbonTab groups collection.
See also
Add, Remove, GetCount, GetAt, RemoveAll

◆ Remove() [1/2]

void Remove ( CXTPRibbonGroup * pGroup )

Removes a specified group.

Parameters
pGroup Pointer to the group to be removed.
See also
InsertAt, Add, GetCount, GetAt, RemoveAll

◆ Remove() [2/2]

void Remove ( int nIndex )

Removes a specified group.

Parameters
nIndex Index of the group to be removed.
See also
InsertAt, Add, GetCount, GetAt, RemoveAll

◆ RemoveAll()

void RemoveAll ( )

Removes all groups.

See also
InsertAt, Remove, GetCount, GetAt, Add

Member Data Documentation

◆ m_pParentTab

CXTPRibbonTab* m_pParentTab
protected

A pointer to the CXTPRibbonTab object the CXTPRibbonGroup belongs to.

This is the tab that the group is displayed in.

The documentation for this class was generated from the following file:
  • XTPRibbonGroups.h


Toolkit Pro: CXTPRibbonMarkupFrameTheme Class Reference

Public Member Functions | Protected Types | Protected Member Functions | Protected Attributes | List of all members
CXTPRibbonMarkupFrameTheme Class Referenceabstract

The CXTPRibbonMarkupFrameTheme class is used to enable a system style theme for Command Bars. More...

Inheritance diagram for CXTPRibbonMarkupFrameTheme:
[legend]

Public Member Functions

CXTPRibbonMarkupFrameTheme (CXTPPaintManager *pPaintManager)
Constructs a CXTPRibbonMarkupFrameTheme object.
virtual | ~CXTPRibbonMarkupFrameTheme ()
Destroys a CXTPRibbonMarkupFrameTheme object, handles cleanup and deallocation.
virtual void | DrawFrame (CDC *pDC, CXTPCommandBarsFrameHook *pFrameHook)
This method is called to draw the frame if the Ribbon was found.
virtual void | DrawFrameBorder (CDC *pDC, CXTPCommandBarsFrameHook *pFrameHook)
This method is called to draw the frame border.
void | ReloadMarkupParts (HZIP hZip, CXTPMarkupContext *pMarkupContext)
Re-loads markup parts from the specified ZIP source.
- Public Member Functions inherited from CXTPFramePaintManager
CXTPFramePaintManager (CXTPPaintManager *pPaintManager)
Constructs a CXTPFramePaintManager object.
virtual | ~CXTPFramePaintManager ()
Destroys a CXTPFramePaintManager object, handles cleanup and deallocation.
void | SetIcon (HICON hIcon, CSize szIcon)
Sets the frame icon.
virtual CRect | CalcFrameCaption (const CXTPCommandBarsFrameHook *pFrameHook) const
Calculates the frame caption rect.
virtual CRect | CalcFrameBorder (const CXTPCommandBarsFrameHook *pFrameHook) const
Calculates the frame border sizes.
virtual HRGN | CalcFrameRegion (CXTPCommandBarsFrameHook *pFrameHook, CSize sz) const =0
This method is called to create the window region.
virtual void | DrawFrameCaptionButton (CDC *pDC, CRect rc, int nId, BOOL bSelected, BOOL bPressed, BOOL bActive)=0
This method is called to draw the caption button.
virtual void | DrawFrameCaptionButton (CDC *pDC, CRect rc, int nId, BOOL bSelected, BOOL bPressed, BOOL bActive, CXTPRibbonBar *pRibbonBar)=0
This method is called to draw the caption button.
virtual COLORREF | GetFrameCaptionAccentTextColor (BOOL bActive) const
Obtains frame caption accent color.
BOOL | IsUseSystemAccentColorEnabled () const
Determines whether xtpApplicationUseSystemAccentColor application ambient property is set.
virtual int | GetFrameCaptionHeight () const
Retrieves the frame caption's height.
virtual void | RefreshMetrics ()
This method is called to refresh the visual metrics of the manager.
CXTPResourceImages * | GetImages () const
This method is called to get a pointer to the CXTPResourceImages object.
virtual void | DrawCaptionText (CDC *pDC, CRect rcCaptionText, CWnd *pSite, BOOL bActive)
This method is called to draw the frame caption text.
virtual void | DrawCaptionText (CDC *pDC, CRect rcCaptionText, CWnd *pSite, BOOL bActive, CXTPRibbonBar *pRibbonBar)
This method is called to draw the frame caption text.
virtual void | DrawCaptionBar (CDC *pDC, CRect rcCaptionBar, CWnd *pSite, BOOL bActive)
This method is called to draw the frame caption bar.
CXTPResourceImage * | LoadImage (LPCTSTR lpszFileName)
Loads a bitmap image from the specified path.
HICON | GetFrameSmallIcon (CWnd *pFrame)
Retrieves frame small icon.
HICON | GetFrameLargeIcon (CWnd *pFrame)
Retrieves frame large icon.
virtual CXTPFrameShadow * | CreateShadow (CWnd *pFrame)
Creates frame shadow if supported by theme.
virtual void | OnShadowedFrameActiveStateChanged (BOOL bActive, CWnd *pFrame, CXTPFrameShadow *pShadow)
An implementation can override this method in order to change frame appearance when a window gets activated or deactivated.
const CXTPPaintManagerColor & | GetFrameCaptionActiveColor () const
Obtains theme specific active frame caption color value.

Protected Types

enum XTPBorderPart {
xtpBorderPartTop , xtpBorderPartLeft , xtpBorderPartLeftCaption , xtpBorderPartRight ,
xtpBorderPartRightCaption , xtpBorderPartBottom , xtpBorderPartCount
}
Defines border parts. More...

Protected Member Functions

virtual CXTPMarkupThemePart * | GetFrameBorder (int nId, BOOL bActive)=0
This method is called to get the frame border part.
virtual void | LoadParts (HZIP hZip, CXTPMarkupContext *pMarkupContext)=0
Loads markup parts from the specified ZIP source.
virtual void | LoadParts (BOOL bReload=FALSE)=0
Loads markup parts.

Protected Attributes

BOOL | m_bMarkupPartsLoaded
TRUE if markup parts have been loaded.
- Protected Attributes inherited from CXTPFramePaintManager
HICON | m_hIcon
Icon handle.
CSize | m_szIcon
Icon size.
CRect | m_rcIconMargin
Icon margin.
CXTPPaintManagerColor | m_clrFrameCaptionActive
Caption color (active)
CXTPPaintManagerColor | m_clrFrameCaptionInactive
Caption color (inactive)
CXTPPaintManagerColor | m_clrFrameCaptionTextActive
Caption text color.
CXTPPaintManagerColor | m_clrFrameCaptionTextInactive
Caption text color.
CXTPPaintManagerColor | m_clrFrameCaptionTextActiveTitle
Caption text color.
CXTPPaintManagerColor | m_clrFrameCaptionTextActiveBSMode
Caption text color.
CXTPPaintManagerColor | m_clrFrameCaptionTextInactiveBSMode
Caption text color.
CXTPPaintManagerColor | m_clrFrameCaptionTextActiveTitleBSMode
Caption text color.

Additional Inherited Members

- Public Attributes inherited from CXTPFramePaintManager
BOOL | m_bFrameStatusBar
TRUE if status bar used to draw.
CXTPPaintManagerFont | m_fntFrameCaption
Font used to draw text in the frame caption.
int | m_nFrameCaptionHeight
Frame caption.
CXTPPaintManager * | m_pPaintManager
Parent Paint Manager.
BOOL | m_bFlatFrame
TRUE to use a flat frame, FALSE otherwise.
BOOL | m_bCaptionCenterAligned
If TRUE, caption title will be center aligned.

Detailed Description

The CXTPRibbonMarkupFrameTheme class is used to enable a system style theme for Command Bars.

See also
CXTPPaintManager::SetTheme

Member Enumeration Documentation

◆ XTPBorderPart

enum XTPBorderPart
protected

Defines border parts.

Enumerator
xtpBorderPartTop | Specifies a top border part.
xtpBorderPartLeft | Specifies a left border part.
xtpBorderPartLeftCaption | Specifies a left caption border part.
xtpBorderPartRight | Specifies a right border part.
xtpBorderPartRightCaption | Specifies a right caption border part.
xtpBorderPartBottom | Specifies a bottom border part.
xtpBorderPartCount | The number of border parts.

Constructor & Destructor Documentation

◆ CXTPRibbonMarkupFrameTheme()

CXTPRibbonMarkupFrameTheme ( CXTPPaintManager * pPaintManager )

Constructs a CXTPRibbonMarkupFrameTheme object.

Parameters
pPaintManager Pointer to a CXTPPaintManager object.

Member Function Documentation

◆ DrawFrame()

virtual void DrawFrame | ( | CDC * | pDC,
 |  | CXTPCommandBarsFrameHook * | pFrameHook )
 virtual

This method is called to draw the frame if the Ribbon was found.

Parameters
pDC | Pointer to a valid device context.
pFrameHook | Pointer to a CXTPCommandBarsFrameHook hook object.

Implements CXTPFramePaintManager.

◆ DrawFrameBorder()

virtual void DrawFrameBorder | ( | CDC * | pDC,
 |  | CXTPCommandBarsFrameHook * | pFrameHook )
 virtual

This method is called to draw the frame border.

Parameters
pDC | Pointer to a valid device context.
pFrameHook | Pointer to a CXTPCommandBarsFrameHook hook object.

◆ GetFrameBorder()

virtual CXTPMarkupThemePart * GetFrameBorder | ( | int | nId,
 |  | BOOL | bActive )
 protectedpure virtual

This method is called to get the frame border part.

Parameters
nId | Identifier of the frame border; can be one of the values defined by the CXTPRibbonMarkupFrameTheme::XTPBorderPart enumeration.
bActive | TRUE if the frame border is active.
Returns
Gets the frame border part

Implemented in CXTPFrameThemeOffice2007System.

◆ LoadParts() [1/2]

virtual void LoadParts ( BOOL bReload = FALSE )
protectedpure virtual

Loads markup parts.

Parameters
bReload Re-loads previously loaded parts if TRUE.

Implemented in CXTPFrameThemeOffice2007System.

◆ LoadParts() [2/2]

virtual void LoadParts | ( | HZIP | hZip,
 |  | CXTPMarkupContext * | pMarkupContext )
 protectedpure virtual

Loads markup parts from the specified ZIP source.

Parameters
hZip | ZIP source to load markup parts from.
pMarkupContext | Associated markup context.

Implemented in CXTPFrameThemeOffice2007System.

◆ ReloadMarkupParts()

void ReloadMarkupParts | ( | HZIP | hZip,
 |  | CXTPMarkupContext * | pMarkupContext )

Re-loads markup parts from the specified ZIP source.

Parameters
hZip | ZIP source to load markup parts from.
pMarkupContext | Associated markup context.
The documentation for this class was generated from the following file:
  • XTPRibbonMarkupFrameTheme.h


Toolkit Pro: CXTPRibbonMarkupTheme Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPRibbonMarkupTheme Class Referenceabstract

CXTPRibbonMarkupTheme class. More...

Inheritance diagram for CXTPRibbonMarkupTheme:
[legend]

Public Member Functions

CXTPRibbonMarkupTheme (CXTPPaintManager *pPaintManager)
Constructs a CXTPRibbonMarkupTheme object.
virtual | ~CXTPRibbonMarkupTheme ()
Destroys a CXTPRibbonMarkupTheme object, handles cleanup and deallocation.
void | LoadParts (HZIP hZip, CXTPMarkupContext *pMarkupContext=NULL)
Loads markup parts from the specified ZIP source.
virtual void | LoadParts (BOOL bReload=FALSE)=0
Loads markup parts.
void | FillRibbonBar (CDC *pDC, CXTPRibbonBar *pRibbonBar)
This method is called to fill the background of a ribbon bar control.
virtual void | RefreshMetrics ()
This method is called to refresh the visual metrics of the manager.
void | FillGroupRect (CDC *pDC, CXTPRibbonTab *pActiveTab, CRect rcGroups)
This method is called to fill the background of a CXTPRibbonGroup.
void | DrawGroup (CDC *pDC, CXTPRibbonGroup *pGroup)
Draws the specified CXTPRibbonGroup.
void | RenderMarkup (CDC *pDC, CRect rc, LPCTSTR lpszText)
Renders a Markup string in the Ribbon.
void | RenderMarkup (CDC *pDC, CRect rc, XTPRibbonThemePart part)
Renders a Markup string in the Ribbon.
CSize | DrawControlGroupOption (CDC *pDC, CXTPControl *pControlGroupOption, BOOL bDraw)
Draws the group option button.
CSize | GetControlGroupOptionSize () const
Calculates the ribbon group option size.
CSize | DrawControlGroupPopup (CDC *pDC, CXTPControlPopup *pControlGroupPopup, BOOL bDraw)
Draws the group pop-up button.
void | FillGroupPopupToolBar (CDC *pDC, CXTPRibbonGroup *pGroup, CXTPCommandBar *pCommandBar)
This method is called to draw the pop-up toolbar of a reduced group.
virtual void | DrawRibbonQuickAccessButton (CDC *pDC, CXTPControlPopup *pControl)
This method is called to draw the Quick Access customize button.
void | DrawRibbonQuickAccessMoreButton (CDC *pDC, CXTPControlPopup *pControl)
This method is called to draw the Quick Access more button.
void | FillMorePopupToolBarEntry (CDC *pDC, CXTPCommandBar *pBar)
This method is called to draw the pop-up bar of the more button.
virtual void | DrawRibbonTab (CDC *pDC, CXTPRibbonTab *pItem)
This method is called to draw a single tab of the ribbon bar.
void | FillSystemPopupBarEntry (CDC *pDC, CXTPPopupBar *pBar)
This method is called to draw the pop-up bar of the system button.
void | DrawSystemPopupBarButton (CDC *pDC, CXTPControl *pButton)
This method is called to draw a pop-up bar button.
void | DrawRibbonScrollButton (CDC *pDC, CXTPControl *pControl, BOOL bScrollLeft)
This method is called to draw scroll group buttons.
void | DrawRibbonFrameSystemButton (CDC *pDC, CXTPRibbonControlSystemButton *pControl, CRect rc)
Draws the top-left system button.
BOOL | DrawRibbonGroupControlEntry (CDC *pDC, CXTPControl *pButton)
This method is called to draw the ribbon group when the group is minimized and only a button is displayed.
void | DrawRibbonGroupPopupToolBar (CDC *pDC, CXTPRibbonGroup *pRibbonGroup)
This method is called to draw the ribbon group pop-up toolbar.
virtual void | DrawRibbonFrameCaptionBar (CDC *pDC, CXTPRibbonBar *pRibbonBar, BOOL bActive)
This method is called to draw the ribbon caption if EnableFrameTheme was not called.
virtual void | DrawRibbonFrameCaption (CDC *pDC, CXTPRibbonBar *pRibbonBar, BOOL bActive)
This method is called to draw the Ribbon caption.
virtual void | DrawRibbonQuickAccessControls (CDC *pDC, CXTPRibbonBar *pRibbonBar)
This method is called to draw ribbon Quick Access controls.
virtual void | DrawRibbonFrameContextHeaders (CDC *pDC, CXTPRibbonBar *pRibbonBar, CXTPRibbonTabContextHeaders *pContextHeaders)
This method is called to draw ribbon context headers.
virtual void | FillRibbonTabControl (CDC *pDC, CXTPRibbonBar *pRibbonBar, CRect rcControl)
This member fills in the tab header and tab client area.
- Public Member Functions inherited from CXTPRibbonPaintManager
CXTPRibbonPaintManager (CXTPPaintManager *pPaintManager)
Constructs a CXTPRibbonPaintManager object.
virtual | ~CXTPRibbonPaintManager ()
Destroys a CXTPRibbonPaintManager object, handles cleanup and deallocation.
virtual void | DrawQuickAccessControl (CDC *pDC, CXTPRibbonBar *pRibbon, CXTPControl *pControl)
Draws the specified control which is a part of the Quick Access panel.
virtual void | FillTabPopupToolBar (CDC *pDC, CXTPPopupToolBar *pPopupToolBar)
This method is called to draw the background of a minimized pop-up bar.
virtual void | DrawRibbonFramePart (CDC *pDC, CXTPRibbonBar *pRibbonBar)
This method is called to draw the ribbon frame if EnableFrameTheme was not called.
int | GetEditHeight () const
Gets the edit control height.
void | SetFontHeight (int nFontHeight)
Sets the font height used for Ribbon.
int | GetFontHeight () const
Gets the font height used for Ribbon.
virtual int | GetRibbonCaptionHeight (const CXTPRibbonBar *pRibbonBar) const =0
Calculates the ribbon caption height.
int | GetGroupCaptionHeight () const
Gets the height of the group caption bar.
CXTPResourceImage * | LoadImage (LPCTSTR lpszFileName)
Loads a bitmap image from the specified path.
CXTPResourceImages * | GetImages () const
This method is called to get a pointer to the CXTPResourceImages object.
CXTPTabPaintManager * | GetTabPaintManager () const
Call this member to get a pointer to the tab paint manager.
CXTPFramePaintManager * | GetFramePaintManager () const
Call this member to get a pointer to the frame paint manager.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Attributes

COLORREF | m_clrBackstageSysButtonBack2013Normal
The color of "back" button in backstage if the button is not selected.
COLORREF | m_clrBackstageSysButtonBack2013Highlighted
The color of "back" button in backstage if the button is selected.
CString | m_strHighlightedPrefix
The prefix of the file name for the backstage "back" button image used for the selected button.
CString | m_strNormalPrefix
The prefix of the file name for the backstage "back" button image used for the not selected button.
CXTPMarkupContext * | m_pMarkupContext
Store pointer to a CXTPMarkupContext object.
- Protected Attributes inherited from CXTPRibbonPaintManager
COLORREF | m_clrRibbonFace
Ribbon face color.
COLORREF | m_clrRibbonBorder
Ribbon border color.
COLORREF | m_clrRibbonGroupCaptionText
Ribbon group captions color.
COLORREF | m_clrRibbonInactiveFace
Color of the ribbon when it is inactive.
COLORREF | m_clrFileButtonText
Text caption to display when the system button is displayed as a tab button (Windows 7 style).
COLORREF | m_clrMinimizedFrameEdgeHighLight
Minimized bottom edge.
COLORREF | m_clrMinimizedFrameEdgeShadow
Minimized bottom edge shadow.
CXTPPaintManager * | m_pPaintManager
Paint manager used for the ribbon.
CXTPTabPaintManager * | m_pTabPaintManager
Tab paint manager.
CRect | m_rcFileButtonMargin
Margins of the system button when it is displayed as a tab button (Windows 7 style).

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPRibbonPaintManager
BOOL | m_bHotTrackingGroups
TRUE to highlight the group under the cursor.
BOOL | m_bFlatFrame
TRUE to draw a flat frame.
CXTPPaintManagerFont | m_fontGroupCaption
Font used to draw text in the group caption.
COLORREF | m_clrRecentFileListEdgeShadow
Color of the File List edge shadow.
COLORREF | m_clrRecentFileListEdgeHighLight
Color of the File List edge highlight.
int | m_nTabsHeight
Tabs heights.
int | m_nGroupSpacing
Group spacing.
int | m_nGroupCaptionHeight
Group caption bar height.
- Protected Member Functions inherited from CXTPRibbonPaintManager
virtual CXTPTabPaintManager * | CreateTabPaintManager ()
Creates a CXTPTabPaintManager object used to store the color and appearance information of the tabs in the ribbon bar.
void | DrawRibbonApplicationIcon (CDC *pDC, CXTPRibbonBar *pRibbonBar, CRect rc, HICON hIcon)
This method is called to draw a ribbon bar application icon.
void | DrawDwmCaptionText (CDC *pDC, CRect rcCaptionText, CString strText, CWnd *pSite, BOOL bActive)
This method is called to draw caption text for an aero-transparent caption.

Detailed Description

CXTPRibbonMarkupTheme class.

Constructor & Destructor Documentation

◆ CXTPRibbonMarkupTheme()

CXTPRibbonMarkupTheme ( CXTPPaintManager * pPaintManager )

Constructs a CXTPRibbonMarkupTheme object.

Parameters
pPaintManager Pointer to a CXTPPaintManager object.

Member Function Documentation

◆ DrawControlGroupOption()

CSize DrawControlGroupOption | ( | CDC * | pDC,
 |  | CXTPControl * | pControlGroupOption,
 |  | BOOL | bDraw )
 virtual

Draws the group option button.

Parameters
pDC | Pointer to a valid device context.
pControlGroupOption | Pointer to a CXTPControl object.
bDraw | TRUE to draw option button, FALSE to retrieve the size of the control.

The option button is typically used to launch a dialog associated with the group. It is drawn on the right side of the group caption.

Returns
If bDraw is FALSE, then the size of the option button control will be returned.
See also
CXTPRibbonGroup::ShowOptionButton, CXTPRibbonGroup::GetControlGroupOption

Implements CXTPRibbonPaintManager.

◆ DrawControlGroupPopup()

CSize DrawControlGroupPopup | ( | CDC * | pDC,
 |  | CXTPControlPopup * | pControlGroupPopup,
 |  | BOOL | bDraw )
 virtual

Draws the group pop-up button.

Parameters
pDC | Pointer to a valid device context
pControlGroupPopup | Pointer to a CXTPControlPopup object.
bDraw | TRUE to draw the group pop-up button, FALSE to retrieve the size of the control.

A single group button will be displayed if there is not enough room to display the items in the group. A group pop-up is displayed when the button is clicked. The pop-up contains all the items in the group. When a group button is clicked, a CXTPControlPopup is displayed that contains the items of the group.

Returns
If bDraw is FALSE, then the size of the group pop-up button control will be returned.
See also
CXTPRibbonGroup::GetControlGroupPopup

Implements CXTPRibbonPaintManager.

◆ DrawGroup()

void DrawGroup | ( | CDC * | pDC,
 |  | CXTPRibbonGroup * | pGroup )
 virtual

Draws the specified CXTPRibbonGroup.

Parameters
pDC | Pointer to a valid device context.
pGroup | Pointer to the CXTPRibbonGroup to be drawn.

Draws the entire group including background, caption, and text. This will not draw the option button or the group pop-up.

See also
GROUP_COLOR, FillRibbonBar, FillGroupRect, RefreshMetrics

Implements CXTPRibbonPaintManager.

◆ DrawRibbonFrameCaption()

virtual void DrawRibbonFrameCaption | ( | CDC * | pDC,
 |  | CXTPRibbonBar * | pRibbonBar,
 |  | BOOL | bActive )
 virtual

This method is called to draw the Ribbon caption.

Parameters
pDC | Pointer to a valid device context.
pRibbonBar | Pointer to the ribbon bar to draw the caption for.
bActive | TRUE if the ribbon frame is active.

Implements CXTPRibbonPaintManager.

Reimplemented in CXTPRibbonOffice2013Theme.

◆ DrawRibbonFrameCaptionBar()

virtual void DrawRibbonFrameCaptionBar | ( | CDC * | pDC,
 |  | CXTPRibbonBar * | pRibbonBar,
 |  | BOOL | bActive )
 virtual

This method is called to draw the ribbon caption if EnableFrameTheme was not called.

Parameters
pDC | Pointer to a valid device context.
pRibbonBar | Pointer to the ribbon bar to draw the caption for.
bActive | TRUE if the ribbon frame is active.

Implements CXTPRibbonPaintManager.

Reimplemented in CXTPRibbonOffice2013Theme.

◆ DrawRibbonFrameContextHeaders()

virtual void DrawRibbonFrameContextHeaders | ( | CDC * | pDC,
 |  | CXTPRibbonBar * | pRibbonBar,
 |  | CXTPRibbonTabContextHeaders * | pContextHeaders )
 virtual

This method is called to draw ribbon context headers.

Parameters
pDC | Pointer to a valid device context.
pContextHeaders | Collection of context headers.
pRibbonBar | Pointer to the parent ribbon bar.

Implements CXTPRibbonPaintManager.

Reimplemented in CXTPRibbonOffice2013Theme, CXTPRibbonThemeNativeWindows10, and CXTPRibbonThemeNativeWindows11.

◆ DrawRibbonFrameSystemButton()

void DrawRibbonFrameSystemButton | ( | CDC * | pDC,
 |  | CXTPRibbonControlSystemButton * | pControl,
 |  | CRect | rc )
 virtual

Draws the top-left system button.

Parameters
pDC | Pointer to a valid device context.
pControl | System button control.
rc | Bounding rectangle of the control.

Implements CXTPRibbonPaintManager.

Reimplemented in CXTPRibbonOffice2013Theme.

◆ DrawRibbonGroupControlEntry()

BOOL DrawRibbonGroupControlEntry | ( | CDC * | pDC,
 |  | CXTPControl * | pButton )
 virtual

This method is called to draw the ribbon group when the group is minimized and only a button is displayed.

When the button is pressed, the group is displayed as a pop-up.

Parameters
pDC | Pointer to a valid device context.
pButton | Button to draw.
Returns
TRUE if successful, FALSE otherwise.

Implements CXTPRibbonPaintManager.

◆ DrawRibbonGroupPopupToolBar()

void DrawRibbonGroupPopupToolBar | ( | CDC * | pDC,
 |  | CXTPRibbonGroup * | pRibbonGroup )
 virtual

This method is called to draw the ribbon group pop-up toolbar.

Parameters
pDC | Pointer to a valid device context.
pRibbonGroup | Group to draw.

Reimplemented from CXTPRibbonPaintManager.

◆ DrawRibbonQuickAccessButton()

virtual void DrawRibbonQuickAccessButton | ( | CDC * | pDC,
 |  | CXTPControlPopup * | pControl )
 virtual

This method is called to draw the Quick Access customize button.

Parameters
pDC | Pointer to a valid device context.
pControl | Pointer to the Quick Access customize button.
See also
DrawRibbonQuickAccessMoreButton

Implements CXTPRibbonPaintManager.

Reimplemented in CXTPRibbonThemeOffice2007System.

◆ DrawRibbonQuickAccessControls()

virtual void DrawRibbonQuickAccessControls | ( | CDC * | pDC,
 |  | CXTPRibbonBar * | pRibbonBar )
 virtual

This method is called to draw ribbon Quick Access controls.

Parameters
pDC | Pointer to a valid device context.
pRibbonBar | Pointer to the parent ribbon bar.

Reimplemented in CXTPRibbonThemeOffice2007System.

◆ DrawRibbonQuickAccessMoreButton()

void DrawRibbonQuickAccessMoreButton | ( | CDC * | pDC,
 |  | CXTPControlPopup * | pControl )
 virtual

This method is called to draw the Quick Access more button.

Parameters
pDC | Pointer to a valid device context.
pControl | Pointer to the Quick Access more button.
See also
DrawRibbonQuickAccessButton

Implements CXTPRibbonPaintManager.

◆ DrawRibbonScrollButton()

void DrawRibbonScrollButton | ( | CDC * | pDC,
 |  | CXTPControl * | pControl,
 |  | BOOL | bScrollLeft )
 virtual

This method is called to draw scroll group buttons.

Parameters
pDC | Pointer to a valid device context.
pControl | Scroll button to draw.
bScrollLeft | TRUE to draw the left button, FALSE to draw the right.

Implements CXTPRibbonPaintManager.

◆ DrawRibbonTab()

virtual void DrawRibbonTab | ( | CDC * | pDC,
 |  | CXTPRibbonTab * | pItem )
 virtual

This method is called to draw a single tab of the ribbon bar.

Parameters
pDC | Pointer to a valid device context.
pItem | Ribbon tab to draw.

Implements CXTPRibbonPaintManager.

Reimplemented in CXTPRibbonOffice2013Theme, CXTPRibbonThemeNativeWindows10, and CXTPRibbonThemeNativeWindows11.

◆ DrawSystemPopupBarButton()

void DrawSystemPopupBarButton | ( | CDC * | pDC,
 |  | CXTPControl * | pButton )
 virtual

This method is called to draw a pop-up bar button.

Parameters
pDC | Pointer to a valid device context.
pButton | Pop-up bar button to draw.

Implements CXTPRibbonPaintManager.

◆ FillGroupPopupToolBar()

void FillGroupPopupToolBar | ( | CDC * | pDC,
 |  | CXTPRibbonGroup * | pGroup,
 |  | CXTPCommandBar * | pCommandBar )
 virtual

This method is called to draw the pop-up toolbar of a reduced group.

Parameters
pDC | Pointer to a valid device context.
pGroup | Parent group of pop-up'ed toolbar.
pCommandBar | Pop-up toolbar to draw.

Implements CXTPRibbonPaintManager.

◆ FillGroupRect()

void FillGroupRect | ( | CDC * | pDC,
 |  | CXTPRibbonTab * | pActiveTab,
 |  | CRect | rcGroups )
 virtual

This method is called to fill the background of a CXTPRibbonGroup.

Parameters
pDC | Pointer to a valid device context.
pActiveTab | Pointer to the tab that is currently active.
rcGroups | Bounding rectangle of the group.

Performs a gradient fill using the GROUP_COLOR::clrBackground for the main group background and GROUP_COLOR::clrCaption to fill the group caption rectangle.

See also
CXTPRibbonGroup::GetRect, GROUP_COLOR

Implements CXTPRibbonPaintManager.

Reimplemented in CXTPRibbonThemeNativeWindows10, and CXTPRibbonThemeNativeWindows11.

◆ FillMorePopupToolBarEntry()

void FillMorePopupToolBarEntry | ( | CDC * | pDC,
 |  | CXTPCommandBar * | pBar )
 virtual

This method is called to draw the pop-up bar of the more button.

Parameters
pDC | Pointer to a valid device context.
pBar | Toolbar to fill.

Implements CXTPRibbonPaintManager.

◆ FillRibbonBar()

void FillRibbonBar | ( | CDC * | pDC,
 |  | CXTPRibbonBar * | pRibbonBar )
 virtual

This method is called to fill the background of a ribbon bar control.

Parameters
pDC | Pointer to a valid device context
pRibbonBar | Pointer to the parent ribbon bar.

Implements CXTPRibbonPaintManager.

Reimplemented in CXTPRibbonOffice2013Theme.

◆ FillRibbonTabControl()

virtual void FillRibbonTabControl | ( | CDC * | pDC,
 |  | CXTPRibbonBar * | pRibbonBar,
 |  | CRect | rcControl )
 virtual

This member fills in the tab header and tab client area.

It will then draw tab client frame.

Parameters
pRibbonBar | Pointer to the ribbon bar to draw the tab control for.
pDC | Pointer to a valid device context.
rcControl | Bounding rectangle of the tab control.

Implements CXTPRibbonPaintManager.

◆ FillSystemPopupBarEntry()

void FillSystemPopupBarEntry | ( | CDC * | pDC,
 |  | CXTPPopupBar * | pBar )
 virtual

This method is called to draw the pop-up bar of the system button.

Parameters
pDC | Pointer to a valid device context.
pBar | Toolbar to fill.

Implements CXTPRibbonPaintManager.

◆ GetControlGroupOptionSize()

CSize GetControlGroupOptionSize ( ) const
virtual

Calculates the ribbon group option size.

Returns
The ribbon group option size.

Implements CXTPRibbonPaintManager.

◆ LoadParts() [1/2]

virtual void LoadParts ( BOOL bReload = FALSE )
pure virtual

Loads markup parts.

Parameters
bReload Re-loads previously loaded parts if TRUE.

Implemented in CXTPRibbonOffice2013Theme, and CXTPRibbonThemeOffice2007System.

◆ LoadParts() [2/2]

void LoadParts | ( | HZIP | hZip,
 |  | CXTPMarkupContext * | pMarkupContext = NULL )

Loads markup parts from the specified ZIP source.

Parameters
hZip | ZIP source to load markup parts from.
pMarkupContext | Associated markup context.

◆ RefreshMetrics()

virtual void RefreshMetrics ( )
virtual

This method is called to refresh the visual metrics of the manager.

Refreshes all of the colors in the ribbon bar. Many of the colors used are set with the GROUP_COLOR structure.

See also
GROUP_COLOR

Reimplemented from CXTPRibbonPaintManager.

Reimplemented in CXTPRibbonOffice2013Theme, CXTPRibbonThemeNativeWindows10, CXTPRibbonThemeNativeWindows11, and CXTPRibbonThemeOffice2007System.

◆ RenderMarkup() [1/2]

void RenderMarkup | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | LPCTSTR | lpszText )

Renders a Markup string in the Ribbon.

Parameters
pDC | Pointer to a valid device context.
rc | Bounding rectangle for the Markup.
lpszText | Markup string to render.

◆ RenderMarkup() [2/2]

void RenderMarkup | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | XTPRibbonThemePart | part )

Renders a Markup string in the Ribbon.

Parameters
pDC | Pointer to a valid device context.
rc | Bounding rectangle for the Markup.
part | XTPRibbonThemePart object
The documentation for this class was generated from the following file:
  • XTPRibbonMarkupTheme.h


Toolkit Pro: CXTPRibbonOffice2013Theme Class Reference

Classes | Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPRibbonOffice2013Theme Class Reference

CXTPRibbonOffice2013Theme is a CXTPRibbonMarkupTheme derived class used to represent an Office 2013 ribbon theme. More...

Inheritance diagram for CXTPRibbonOffice2013Theme:
[legend]

Classes

class CThemeStaticExtension
Helper class used to define variables to be used by XAML Markup code. More...

Public Member Functions

CXTPRibbonOffice2013Theme (CXTPPaintManager *pPaintManager)
Constructs a CXTPRibbonOffice2013Theme object.
virtual | ~CXTPRibbonOffice2013Theme ()
Destroys a CXTPRibbonOffice2013Theme object, handles cleanup and deallocation.
virtual void | RefreshMetrics ()
This method is called to refresh the visual metrics of the manager.
virtual int | GetRibbonCaptionHeight (const CXTPRibbonBar *pRibbonBar) const
Calculates the ribbon caption height.
virtual void | DrawQuickAccessControl (CDC *pDC, CXTPRibbonBar *pRibbon, CXTPControl *pControl)
Draws the specified control which is a part of the Quick Access panel.
virtual void | DrawRibbonTab (CDC *pDC, CXTPRibbonTab *pItem)
This method is called to draw a single tab of the ribbon bar.
virtual void | DrawRibbonFrameContextHeaders (CDC *pDC, CXTPRibbonBar *pRibbonBar, CXTPRibbonTabContextHeaders *pContextHeaders)
This method is called to draw ribbon context headers.
virtual void | FillRibbonBar (CDC *pDC, CXTPRibbonBar *pRibbonBar)
This method is called to fill the background of a ribbon bar control.
virtual void | DrawRibbonFrameCaptionBar (CDC *pDC, CXTPRibbonBar *pRibbonBar, BOOL bActive)
This method is called to draw the ribbon caption if EnableFrameTheme was not called.
virtual void | DrawRibbonFrameCaption (CDC *pDC, CXTPRibbonBar *pRibbonBar, BOOL bActive)
This method is called to draw the Ribbon caption.
virtual void | SetBackImage (int nImage)
This member function will set the background image for the Office ribbon bar.
virtual void | DrawRibbonFrameSystemButton (CDC *pDC, CXTPRibbonControlSystemButton *pControl, CRect rc)
Draws the top-left system button.
- Public Member Functions inherited from CXTPRibbonMarkupTheme
CXTPRibbonMarkupTheme (CXTPPaintManager *pPaintManager)
Constructs a CXTPRibbonMarkupTheme object.
virtual | ~CXTPRibbonMarkupTheme ()
Destroys a CXTPRibbonMarkupTheme object, handles cleanup and deallocation.
void | LoadParts (HZIP hZip, CXTPMarkupContext *pMarkupContext=NULL)
Loads markup parts from the specified ZIP source.
void | FillGroupRect (CDC *pDC, CXTPRibbonTab *pActiveTab, CRect rcGroups)
This method is called to fill the background of a CXTPRibbonGroup.
void | DrawGroup (CDC *pDC, CXTPRibbonGroup *pGroup)
Draws the specified CXTPRibbonGroup.
void | RenderMarkup (CDC *pDC, CRect rc, LPCTSTR lpszText)
Renders a Markup string in the Ribbon.
void | RenderMarkup (CDC *pDC, CRect rc, XTPRibbonThemePart part)
Renders a Markup string in the Ribbon.
CSize | DrawControlGroupOption (CDC *pDC, CXTPControl *pControlGroupOption, BOOL bDraw)
Draws the group option button.
CSize | GetControlGroupOptionSize () const
Calculates the ribbon group option size.
CSize | DrawControlGroupPopup (CDC *pDC, CXTPControlPopup *pControlGroupPopup, BOOL bDraw)
Draws the group pop-up button.
void | FillGroupPopupToolBar (CDC *pDC, CXTPRibbonGroup *pGroup, CXTPCommandBar *pCommandBar)
This method is called to draw the pop-up toolbar of a reduced group.
virtual void | DrawRibbonQuickAccessButton (CDC *pDC, CXTPControlPopup *pControl)
This method is called to draw the Quick Access customize button.
void | DrawRibbonQuickAccessMoreButton (CDC *pDC, CXTPControlPopup *pControl)
This method is called to draw the Quick Access more button.
void | FillMorePopupToolBarEntry (CDC *pDC, CXTPCommandBar *pBar)
This method is called to draw the pop-up bar of the more button.
void | FillSystemPopupBarEntry (CDC *pDC, CXTPPopupBar *pBar)
This method is called to draw the pop-up bar of the system button.
void | DrawSystemPopupBarButton (CDC *pDC, CXTPControl *pButton)
This method is called to draw a pop-up bar button.
void | DrawRibbonScrollButton (CDC *pDC, CXTPControl *pControl, BOOL bScrollLeft)
This method is called to draw scroll group buttons.
BOOL | DrawRibbonGroupControlEntry (CDC *pDC, CXTPControl *pButton)
This method is called to draw the ribbon group when the group is minimized and only a button is displayed.
void | DrawRibbonGroupPopupToolBar (CDC *pDC, CXTPRibbonGroup *pRibbonGroup)
This method is called to draw the ribbon group pop-up toolbar.
virtual void | DrawRibbonQuickAccessControls (CDC *pDC, CXTPRibbonBar *pRibbonBar)
This method is called to draw ribbon Quick Access controls.
virtual void | FillRibbonTabControl (CDC *pDC, CXTPRibbonBar *pRibbonBar, CRect rcControl)
This member fills in the tab header and tab client area.
- Public Member Functions inherited from CXTPRibbonPaintManager
CXTPRibbonPaintManager (CXTPPaintManager *pPaintManager)
Constructs a CXTPRibbonPaintManager object.
virtual | ~CXTPRibbonPaintManager ()
Destroys a CXTPRibbonPaintManager object, handles cleanup and deallocation.
virtual void | FillTabPopupToolBar (CDC *pDC, CXTPPopupToolBar *pPopupToolBar)
This method is called to draw the background of a minimized pop-up bar.
virtual void | DrawRibbonFramePart (CDC *pDC, CXTPRibbonBar *pRibbonBar)
This method is called to draw the ribbon frame if EnableFrameTheme was not called.
int | GetEditHeight () const
Gets the edit control height.
void | SetFontHeight (int nFontHeight)
Sets the font height used for Ribbon.
int | GetFontHeight () const
Gets the font height used for Ribbon.
int | GetGroupCaptionHeight () const
Gets the height of the group caption bar.
CXTPResourceImage * | LoadImage (LPCTSTR lpszFileName)
Loads a bitmap image from the specified path.
CXTPResourceImages * | GetImages () const
This method is called to get a pointer to the CXTPResourceImages object.
CXTPTabPaintManager * | GetTabPaintManager () const
Call this member to get a pointer to the tab paint manager.
CXTPFramePaintManager * | GetFramePaintManager () const
Call this member to get a pointer to the frame paint manager.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

virtual CString | GetBackImageName ()
This member function is used to get the name of the background image located in the Office 2013 resource .DLL.
virtual void | DrawBackImage (CDC *pDC, CXTPRibbonBar *pRibbonBar)
Used by the theme to draw the background image for the ribbon bar.
virtual void | LoadParts (BOOL bReload=FALSE)
Loads markup parts.
- Protected Member Functions inherited from CXTPRibbonMarkupTheme
- Protected Member Functions inherited from CXTPRibbonPaintManager
virtual CXTPTabPaintManager * | CreateTabPaintManager ()
Creates a CXTPTabPaintManager object used to store the color and appearance information of the tabs in the ribbon bar.
void | DrawRibbonApplicationIcon (CDC *pDC, CXTPRibbonBar *pRibbonBar, CRect rc, HICON hIcon)
This method is called to draw a ribbon bar application icon.
void | DrawDwmCaptionText (CDC *pDC, CRect rcCaptionText, CString strText, CWnd *pSite, BOOL bActive)
This method is called to draw caption text for an aero-transparent caption.

Protected Attributes

XTPRIBBON_HEADER_COLOR | m_clrHeader [24]
Array of color values used for rendering the Ribbon's.
COLORREF | m_clrRibbonInactiveFaceState
context tabs.
COLORREF | m_clrTabBackInactiveState
Color of the ribbon tab when the application is inactive.
COLORREF | m_clrTabBackackstageLeft
Color of left part of the ribbon tab when new backstage is.
COLORREF | m_clrTabBackackstageRight
pop-up.
COLORREF | m_clrRibbonTabDelimeter
is pop-up.
- Protected Attributes inherited from CXTPRibbonMarkupTheme
COLORREF | m_clrBackstageSysButtonBack2013Normal
The color of "back" button in backstage if the button is not selected.
COLORREF | m_clrBackstageSysButtonBack2013Highlighted
The color of "back" button in backstage if the button is selected.
CString | m_strHighlightedPrefix
The prefix of the file name for the backstage "back" button image used for the selected button.
CString | m_strNormalPrefix
The prefix of the file name for the backstage "back" button image used for the not selected button.
CXTPMarkupContext * | m_pMarkupContext
Store pointer to a CXTPMarkupContext object.
- Protected Attributes inherited from CXTPRibbonPaintManager
COLORREF | m_clrRibbonFace
Ribbon face color.
COLORREF | m_clrRibbonBorder
Ribbon border color.
COLORREF | m_clrRibbonGroupCaptionText
Ribbon group captions color.
COLORREF | m_clrRibbonInactiveFace
Color of the ribbon when it is inactive.
COLORREF | m_clrFileButtonText
Text caption to display when the system button is displayed as a tab button (Windows 7 style).
COLORREF | m_clrMinimizedFrameEdgeHighLight
Minimized bottom edge.
COLORREF | m_clrMinimizedFrameEdgeShadow
Minimized bottom edge shadow.
CXTPPaintManager * | m_pPaintManager
Paint manager used for the ribbon.
CXTPTabPaintManager * | m_pTabPaintManager
Tab paint manager.
CRect | m_rcFileButtonMargin
Margins of the system button when it is displayed as a tab button (Windows 7 style).

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPRibbonPaintManager
BOOL | m_bHotTrackingGroups
TRUE to highlight the group under the cursor.
BOOL | m_bFlatFrame
TRUE to draw a flat frame.
CXTPPaintManagerFont | m_fontGroupCaption
Font used to draw text in the group caption.
COLORREF | m_clrRecentFileListEdgeShadow
Color of the File List edge shadow.
COLORREF | m_clrRecentFileListEdgeHighLight
Color of the File List edge highlight.
int | m_nTabsHeight
Tabs heights.
int | m_nGroupSpacing
Group spacing.
int | m_nGroupCaptionHeight
Group caption bar height.

Detailed Description

CXTPRibbonOffice2013Theme is a CXTPRibbonMarkupTheme derived class used to represent an Office 2013 ribbon theme.

Constructor & Destructor Documentation

◆ CXTPRibbonOffice2013Theme()

CXTPRibbonOffice2013Theme ( CXTPPaintManager * pPaintManager )

Constructs a CXTPRibbonOffice2013Theme object.

Parameters
pPaintManager A CXTPPaintManager object.

Member Function Documentation

◆ DrawBackImage()

virtual void DrawBackImage | ( | CDC * | pDC,
 |  | CXTPRibbonBar * | pRibbonBar )
 protectedvirtual

Used by the theme to draw the background image for the ribbon bar.

Parameters
pDC | Pointer to a valid device context.
pRibbonBar | Pointer to the ribbon bar to draw the background image for.

◆ DrawQuickAccessControl()

virtual void DrawQuickAccessControl | ( | CDC * | pDC,
 |  | CXTPRibbonBar * | pRibbon,
 |  | CXTPControl * | pControl )
 virtual

Draws the specified control which is a part of the Quick Access panel.

Parameters
pDC | Pointer to a valid device context
pControl | Control to draw.
pRibbon | Pointer to the ribbon bar to draw the caption for.

Reimplemented from CXTPRibbonPaintManager.

◆ DrawRibbonFrameCaption()

virtual void DrawRibbonFrameCaption | ( | CDC * | pDC,
 |  | CXTPRibbonBar * | pRibbonBar,
 |  | BOOL | bActive )
 virtual

This method is called to draw the Ribbon caption.

Parameters
pDC | Pointer to a valid device context.
pRibbonBar | Pointer to the ribbon bar to draw the caption for.
bActive | TRUE if the ribbon frame is active.

Reimplemented from CXTPRibbonMarkupTheme.

◆ DrawRibbonFrameCaptionBar()

virtual void DrawRibbonFrameCaptionBar | ( | CDC * | pDC,
 |  | CXTPRibbonBar * | pRibbonBar,
 |  | BOOL | bActive )
 virtual

This method is called to draw the ribbon caption if EnableFrameTheme was not called.

Parameters
pDC | Pointer to a valid device context.
pRibbonBar | Pointer to the ribbon bar to draw the caption for.
bActive | TRUE if the ribbon frame is active.

Reimplemented from CXTPRibbonMarkupTheme.

◆ DrawRibbonFrameContextHeaders()

virtual void DrawRibbonFrameContextHeaders | ( | CDC * | pDC,
 |  | CXTPRibbonBar * | pRibbonBar,
 |  | CXTPRibbonTabContextHeaders * | pContextHeaders )
 virtual

This method is called to draw ribbon context headers.

Parameters
pDC | Pointer to a valid device context.
pContextHeaders | Collection of context headers.
pRibbonBar | Pointer to the parent ribbon bar.

Reimplemented from CXTPRibbonMarkupTheme.

Reimplemented in CXTPRibbonThemeNativeWindows10, and CXTPRibbonThemeNativeWindows11.

◆ DrawRibbonFrameSystemButton()

virtual void DrawRibbonFrameSystemButton | ( | CDC * | pDC,
 |  | CXTPRibbonControlSystemButton * | pControl,
 |  | CRect | rc )
 virtual

Draws the top-left system button.

Parameters
pDC | Pointer to a valid device context.
pControl | System button control.
rc | Bounding rectangle of the control.

Reimplemented from CXTPRibbonMarkupTheme.

◆ DrawRibbonTab()

virtual void DrawRibbonTab | ( | CDC * | pDC,
 |  | CXTPRibbonTab * | pItem )
 virtual

This method is called to draw a single tab of the ribbon bar.

Parameters
pDC | Pointer to a valid device context.
pItem | Ribbon tab to draw.

Reimplemented from CXTPRibbonMarkupTheme.

Reimplemented in CXTPRibbonThemeNativeWindows10, and CXTPRibbonThemeNativeWindows11.

◆ FillRibbonBar()

virtual void FillRibbonBar | ( | CDC * | pDC,
 |  | CXTPRibbonBar * | pRibbonBar )
 virtual

This method is called to fill the background of a ribbon bar control.

Parameters
pDC | Pointer to a valid device context
pRibbonBar | Pointer to the parent ribbon bar.

Reimplemented from CXTPRibbonMarkupTheme.

◆ GetBackImageName()

virtual CString GetBackImageName ( )
protectedvirtual

This member function is used to get the name of the background image located in the Office 2013 resource .DLL.

Returns
A string representing the name of the background image located in the Office 2013 resource .DLL.
See also
SetBackImage

◆ GetRibbonCaptionHeight()

virtual int GetRibbonCaptionHeight ( const CXTPRibbonBar * pRibbonBar ) const
virtual

Calculates the ribbon caption height.

Parameters
pRibbonBar Pointer to the parent ribbon bar.
Returns
The ribbon caption height.

Implements CXTPRibbonPaintManager.

◆ LoadParts()

virtual void LoadParts ( BOOL bReload = FALSE )
protectedvirtual

Loads markup parts.

Parameters
bReload Re-loads previously loaded parts if TRUE.

Implements CXTPRibbonMarkupTheme.

◆ RefreshMetrics()

virtual void RefreshMetrics ( )
virtual

This method is called to refresh the visual metrics of the manager.

Refreshes all of the colors in the ribbon bar. Many of the colors used are set with the GROUP_COLOR structure.

See also
GROUP_COLOR

Reimplemented from CXTPRibbonMarkupTheme.

Reimplemented in CXTPRibbonThemeNativeWindows10, and CXTPRibbonThemeNativeWindows11.

◆ SetBackImage()

virtual void SetBackImage ( int nImage )
virtual

This member function will set the background image for the Office ribbon bar.

Parameters
nImage Identifies the background image to set, can be one of the following IDs:
  XTPNone
  XTPCalligraphy
  XTPCirclesAndStripes
  XTPCircuit
  XTPClouds
  XTPDoodleCircles
  XTPDoodleDiamonds
  XTPGeometry
  XTPLunchBox
  XTPSchoolSupplies
  XTPSpring
  XTPStars
  XTPStraws
  XTPTreeRings
  XTPUnderWater
*
See also
GetBackImageName
The documentation for this class was generated from the following file:
  • XTPRibbonThemeOffice2013.h


Toolkit Pro: CXTPRibbonOffice2013Theme::CThemeStaticExtension Class Reference

  • CXTPRibbonOffice2013Theme
  • CThemeStaticExtension
Public Member Functions | List of all members
CXTPRibbonOffice2013Theme::CThemeStaticExtension Class Reference

Helper class used to define variables to be used by XAML Markup code. More...

Inheritance diagram for CXTPRibbonOffice2013Theme::CThemeStaticExtension:
[legend]

Public Member Functions

CThemeStaticExtension ()
Default constructor, initializes CXTPMarkupStaticExtension variables.
- Public Member Functions inherited from CXTPMarkupStaticExtension
CXTPMarkupStaticExtension (LPCWSTR lpzName)
Constructs a composite CXTPMarkupStaticExtension instance.
virtual | ~CXTPMarkupStaticExtension ()
Destroys a CXTPMarkupStaticExtension object, handles cleanup and deallocation.
LPCWSTR | GetName () const
Gets the name of the current extension.
BOOL | IsProperty () const
Determines if the current extension is a property extension.
void | Extend (CXTPMarkupStaticExtension *pExtension, BOOL bReplace=FALSE)
Extends the current extension object with another sub-extension.
CXTPMarkupStaticExtension * | FindExtension (LPCWSTR lpzName) const
Tries to find an extension by its name or relative path.
virtual CXTPMarkupObject * | ProvideValue (LPCWSTR lpzValue)
Provides the value of a composite extension object.
virtual CXTPMarkupObject * | ProvideValue ()
Provides the value of a property extension object.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPMarkupStaticExtension
static BOOL AFX_CDECL | Parse (LPCWSTR lpzValue, LPCWSTR &lpzSubValue)
Parses a static extension expression of form Name.Value[.Value[...]].
- Protected Member Functions inherited from CXTPMarkupStaticExtension
CXTPMarkupStaticExtension (LPCWSTR lpzName, BOOL bProperty)
Constructs a composite or property CXTPMarkupStaticExtension instance.
virtual void | OnPrepareValue ()
A derived implementation can override this method for preparing a property value.

Detailed Description

Helper class used to define variables to be used by XAML Markup code.

The documentation for this class was generated from the following file:
  • XTPRibbonThemeOffice2013.h


Toolkit Pro: CXTPRibbonPaintManager Class Reference

Public Member Functions | Public Attributes | Protected Member Functions | Protected Attributes | List of all members
CXTPRibbonPaintManager Class Referenceabstract

Standalone class used by CXTPRibbonBar as a paint manager. More...

Inheritance diagram for CXTPRibbonPaintManager:
[legend]

Public Member Functions

CXTPRibbonPaintManager (CXTPPaintManager *pPaintManager)
Constructs a CXTPRibbonPaintManager object.
virtual | ~CXTPRibbonPaintManager ()
Destroys a CXTPRibbonPaintManager object, handles cleanup and deallocation.
virtual void | RefreshMetrics ()
This method is called to refresh the visual metrics of the manager.
virtual void | DrawGroup (CDC *pDC, CXTPRibbonGroup *pGroup)=0
Draws the specified CXTPRibbonGroup.
virtual void | DrawQuickAccessControl (CDC *pDC, CXTPRibbonBar *pRibbon, CXTPControl *pControl)
Draws the specified control which is a part of the Quick Access panel.
virtual void | FillGroupRect (CDC *pDC, CXTPRibbonTab *pActiveTab, CRect rcGroups)=0
This method is called to fill the background of a CXTPRibbonGroup.
virtual CSize | DrawControlGroupPopup (CDC *pDC, CXTPControlPopup *pControlGroupPopup, BOOL bDraw)=0
Draws the group pop-up button.
virtual void | FillRibbonBar (CDC *pDC, CXTPRibbonBar *pRibbonBar)=0
This method is called to fill the background of a ribbon bar control.
virtual CSize | DrawControlGroupOption (CDC *pDC, CXTPControl *pControlGroupOption, BOOL bDraw)=0
Draws the group option button.
virtual void | DrawRibbonFrameContextHeaders (CDC *pDC, CXTPRibbonBar *pRibbonBar, CXTPRibbonTabContextHeaders *pContextHeaders)=0
This method is called to draw ribbon context headers.
virtual void | DrawRibbonTab (CDC *pDC, CXTPRibbonTab *pItem)=0
This method is called to draw a single tab of the ribbon bar.
virtual void | FillRibbonTabControl (CDC *pDC, CXTPRibbonBar *pRibbonBar, CRect rcControl)=0
This member fills in the tab header and tab client area.
virtual void | FillGroupPopupToolBar (CDC *pDC, CXTPRibbonGroup *pGroup, CXTPCommandBar *pCommandBar)=0
This method is called to draw the pop-up toolbar of a reduced group.
virtual void | DrawRibbonFrameCaptionBar (CDC *pDC, CXTPRibbonBar *pRibbonBar, BOOL bActive)=0
This method is called to draw the ribbon caption if EnableFrameTheme was not called.
virtual void | DrawRibbonFrameCaption (CDC *pDC, CXTPRibbonBar *pRibbonBar, BOOL bActive)=0
This method is called to draw the Ribbon caption.
virtual void | DrawRibbonQuickAccessButton (CDC *pDC, CXTPControlPopup *pControl)=0
This method is called to draw the Quick Access customize button.
virtual void | DrawRibbonQuickAccessMoreButton (CDC *pDC, CXTPControlPopup *pControl)=0
This method is called to draw the Quick Access more button.
virtual void | DrawRibbonFrameSystemButton (CDC *pDC, CXTPRibbonControlSystemButton *pControl, CRect rc)=0
Draws the top-left system button.
virtual void | DrawRibbonScrollButton (CDC *pDC, CXTPControl *pControl, BOOL bScrollLeft)=0
This method is called to draw scroll group buttons.
virtual void | FillTabPopupToolBar (CDC *pDC, CXTPPopupToolBar *pPopupToolBar)
This method is called to draw the background of a minimized pop-up bar.
virtual void | DrawRibbonFramePart (CDC *pDC, CXTPRibbonBar *pRibbonBar)
This method is called to draw the ribbon frame if EnableFrameTheme was not called.
virtual void | FillMorePopupToolBarEntry (CDC *pDC, CXTPCommandBar *pBar)=0
This method is called to draw the pop-up bar of the more button.
virtual void | FillSystemPopupBarEntry (CDC *pDC, CXTPPopupBar *pBar)=0
This method is called to draw the pop-up bar of the system button.
virtual void | DrawSystemPopupBarButton (CDC *pDC, CXTPControl *pButton)=0
This method is called to draw a pop-up bar button.
virtual BOOL | DrawRibbonGroupControlEntry (CDC *pDC, CXTPControl *pButton)=0
This method is called to draw the ribbon group when the group is minimized and only a button is displayed.
virtual void | DrawRibbonGroupPopupToolBar (CDC *pDC, CXTPRibbonGroup *pRibbonGroup)
This method is called to draw the ribbon group pop-up toolbar.
int | GetEditHeight () const
Gets the edit control height.
void | SetFontHeight (int nFontHeight)
Sets the font height used for Ribbon.
int | GetFontHeight () const
Gets the font height used for Ribbon.
virtual int | GetRibbonCaptionHeight (const CXTPRibbonBar *pRibbonBar) const =0
Calculates the ribbon caption height.
virtual CSize | GetControlGroupOptionSize () const =0
Calculates the ribbon group option size.
int | GetGroupCaptionHeight () const
Gets the height of the group caption bar.
CXTPResourceImage * | LoadImage (LPCTSTR lpszFileName)
Loads a bitmap image from the specified path.
CXTPResourceImages * | GetImages () const
This method is called to get a pointer to the CXTPResourceImages object.
CXTPTabPaintManager * | GetTabPaintManager () const
Call this member to get a pointer to the tab paint manager.
CXTPFramePaintManager * | GetFramePaintManager () const
Call this member to get a pointer to the frame paint manager.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Public Attributes

BOOL | m_bHotTrackingGroups
TRUE to highlight the group under the cursor.
BOOL | m_bFlatFrame
TRUE to draw a flat frame.
CXTPPaintManagerFont | m_fontGroupCaption
Font used to draw text in the group caption.
COLORREF | m_clrRecentFileListEdgeShadow
Color of the File List edge shadow.
COLORREF | m_clrRecentFileListEdgeHighLight
Color of the File List edge highlight.
int | m_nTabsHeight
Tabs heights.
int | m_nGroupSpacing
Group spacing.
int | m_nGroupCaptionHeight
Group caption bar height.

Protected Member Functions

virtual CXTPTabPaintManager * | CreateTabPaintManager ()
Creates a CXTPTabPaintManager object used to store the color and appearance information of the tabs in the ribbon bar.
void | DrawRibbonApplicationIcon (CDC *pDC, CXTPRibbonBar *pRibbonBar, CRect rc, HICON hIcon)
This method is called to draw a ribbon bar application icon.
void | DrawDwmCaptionText (CDC *pDC, CRect rcCaptionText, CString strText, CWnd *pSite, BOOL bActive)
This method is called to draw caption text for an aero-transparent caption.

Protected Attributes

COLORREF | m_clrRibbonFace
Ribbon face color.
COLORREF | m_clrRibbonBorder
Ribbon border color.
COLORREF | m_clrRibbonGroupCaptionText
Ribbon group captions color.
COLORREF | m_clrRibbonInactiveFace
Color of the ribbon when it is inactive.
COLORREF | m_clrFileButtonText
Text caption to display when the system button is displayed as a tab button (Windows 7 style).
COLORREF | m_clrMinimizedFrameEdgeHighLight
Minimized bottom edge.
COLORREF | m_clrMinimizedFrameEdgeShadow
Minimized bottom edge shadow.
CXTPPaintManager * | m_pPaintManager
Paint manager used for the ribbon.
CXTPTabPaintManager * | m_pTabPaintManager
Tab paint manager.
CRect | m_rcFileButtonMargin
Margins of the system button when it is displayed as a tab button (Windows 7 style).

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

Standalone class used by CXTPRibbonBar as a paint manager.

Constructor & Destructor Documentation

◆ CXTPRibbonPaintManager()

CXTPRibbonPaintManager ( CXTPPaintManager * pPaintManager )

Constructs a CXTPRibbonPaintManager object.

Parameters
pPaintManager Pointer to a CXTPPaintManager object.

Member Function Documentation

◆ CreateTabPaintManager()

virtual CXTPTabPaintManager * CreateTabPaintManager ( )
protectedvirtual

Creates a CXTPTabPaintManager object used to store the color and appearance information of the tabs in the ribbon bar.

Returns
A pointer to the newly created CXTPTabPaintManager object.

◆ DrawControlGroupOption()

virtual CSize DrawControlGroupOption | ( | CDC * | pDC,
 |  | CXTPControl * | pControlGroupOption,
 |  | BOOL | bDraw )
 pure virtual

Draws the group option button.

Parameters
pDC | Pointer to a valid device context.
pControlGroupOption | Pointer to a CXTPControl object.
bDraw | TRUE to draw option button, FALSE to retrieve the size of the control.

The option button is typically used to launch a dialog associated with the group. It is drawn on the right side of the group caption.

Returns
If bDraw is FALSE, then the size of the option button control will be returned.
See also
CXTPRibbonGroup::ShowOptionButton, CXTPRibbonGroup::GetControlGroupOption

Implemented in CXTPRibbonMarkupTheme, and CXTPRibbonThemeResource.

◆ DrawControlGroupPopup()

virtual CSize DrawControlGroupPopup | ( | CDC * | pDC,
 |  | CXTPControlPopup * | pControlGroupPopup,
 |  | BOOL | bDraw )
 pure virtual

Draws the group pop-up button.

Parameters
pDC | Pointer to a valid device context
pControlGroupPopup | Pointer to a CXTPControlPopup object.
bDraw | TRUE to draw the group pop-up button, FALSE to retrieve the size of the control.

A single group button will be displayed if there is not enough room to display the items in the group. A group pop-up is displayed when the button is clicked. The pop-up contains all the items in the group. When a group button is clicked, a CXTPControlPopup is displayed that contains the items of the group.

Returns
If bDraw is FALSE, then the size of the group pop-up button control will be returned.
See also
CXTPRibbonGroup::GetControlGroupPopup

Implemented in CXTPRibbonMarkupTheme, and CXTPRibbonThemeResource.

◆ DrawDwmCaptionText()

void DrawDwmCaptionText | ( | CDC * | pDC,
 |  | CRect | rcCaptionText,
 |  | CString | strText,
 |  | CWnd * | pSite,
 |  | BOOL | bActive )
 protected

This method is called to draw caption text for an aero-transparent caption.

Parameters
pDC | Pointer to a valid device context.
rcCaptionText | Caption text rectangle.
strText | Caption text.
pSite | Frame to draw.
bActive | TRUE if the frame is active.

◆ DrawGroup()

virtual void DrawGroup | ( | CDC * | pDC,
 |  | CXTPRibbonGroup * | pGroup )
 pure virtual

Draws the specified CXTPRibbonGroup.

Parameters
pDC | Pointer to a valid device context.
pGroup | Pointer to the CXTPRibbonGroup to be drawn.

Draws the entire group including background, caption, and text. This will not draw the option button or the group pop-up.

See also
GROUP_COLOR, FillRibbonBar, FillGroupRect, RefreshMetrics

Implemented in CXTPRibbonMarkupTheme, and CXTPRibbonThemeResource.

◆ DrawQuickAccessControl()

virtual void DrawQuickAccessControl | ( | CDC * | pDC,
 |  | CXTPRibbonBar * | pRibbon,
 |  | CXTPControl * | pControl )
 virtual

Draws the specified control which is a part of the Quick Access panel.

Parameters
pDC | Pointer to a valid device context
pControl | Control to draw.
pRibbon | Pointer to the ribbon bar to draw the caption for.

Reimplemented in CXTPRibbonOffice2013Theme.

◆ DrawRibbonApplicationIcon()

void DrawRibbonApplicationIcon | ( | CDC * | pDC,
 |  | CXTPRibbonBar * | pRibbonBar,
 |  | CRect | rc,
 |  | HICON | hIcon )
 protected

This method is called to draw a ribbon bar application icon.

Parameters
pDC | Pointer to a valid device context.
pRibbonBar | Pointer to the ribbon bar to draw the application icon for.
rc | Bounding rectangle of the icon.
hIcon | Pointer to the application icon to use.

◆ DrawRibbonFrameCaption()

virtual void DrawRibbonFrameCaption | ( | CDC * | pDC,
 |  | CXTPRibbonBar * | pRibbonBar,
 |  | BOOL | bActive )
 pure virtual

This method is called to draw the Ribbon caption.

Parameters
pDC | Pointer to a valid device context.
pRibbonBar | Pointer to the ribbon bar to draw the caption for.
bActive | TRUE if the ribbon frame is active.

Implemented in CXTPRibbonMarkupTheme, CXTPRibbonOffice2013Theme, and CXTPRibbonThemeResource.

◆ DrawRibbonFrameCaptionBar()

virtual void DrawRibbonFrameCaptionBar | ( | CDC * | pDC,
 |  | CXTPRibbonBar * | pRibbonBar,
 |  | BOOL | bActive )
 pure virtual

This method is called to draw the ribbon caption if EnableFrameTheme was not called.

Parameters
pDC | Pointer to a valid device context.
pRibbonBar | Pointer to the ribbon bar to draw the caption for.
bActive | TRUE if the ribbon frame is active.

Implemented in CXTPRibbonMarkupTheme, CXTPRibbonOffice2013Theme, and CXTPRibbonThemeResource.

◆ DrawRibbonFrameContextHeaders()

virtual void DrawRibbonFrameContextHeaders | ( | CDC * | pDC,
 |  | CXTPRibbonBar * | pRibbonBar,
 |  | CXTPRibbonTabContextHeaders * | pContextHeaders )
 pure virtual

This method is called to draw ribbon context headers.

Parameters
pDC | Pointer to a valid device context.
pContextHeaders | Collection of context headers.
pRibbonBar | Pointer to the parent ribbon bar.

Implemented in CXTPRibbonMarkupTheme, CXTPRibbonOffice2013Theme, CXTPRibbonThemeNativeWindows10, CXTPRibbonThemeNativeWindows11, and CXTPRibbonThemeResource.

◆ DrawRibbonFramePart()

virtual void DrawRibbonFramePart | ( | CDC * | pDC,
 |  | CXTPRibbonBar * | pRibbonBar )
 virtual

This method is called to draw the ribbon frame if EnableFrameTheme was not called.

Parameters
pDC | Pointer to a valid device context.
pRibbonBar | Ribbon bar to draw.

◆ DrawRibbonFrameSystemButton()

virtual void DrawRibbonFrameSystemButton | ( | CDC * | pDC,
 |  | CXTPRibbonControlSystemButton * | pControl,
 |  | CRect | rc )
 pure virtual

Draws the top-left system button.

Parameters
pDC | Pointer to a valid device context.
pControl | System button control.
rc | Bounding rectangle of the control.

Implemented in CXTPRibbonMarkupTheme, CXTPRibbonOffice2013Theme, and CXTPRibbonThemeResource.

◆ DrawRibbonGroupControlEntry()

virtual BOOL DrawRibbonGroupControlEntry | ( | CDC * | pDC,
 |  | CXTPControl * | pButton )
 pure virtual

This method is called to draw the ribbon group when the group is minimized and only a button is displayed.

When the button is pressed, the group is displayed as a pop-up.

Parameters
pDC | Pointer to a valid device context.
pButton | Button to draw.
Returns
TRUE if successful, FALSE otherwise.

Implemented in CXTPRibbonMarkupTheme, and CXTPRibbonThemeResource.

◆ DrawRibbonGroupPopupToolBar()

virtual void DrawRibbonGroupPopupToolBar | ( | CDC * | pDC,
 |  | CXTPRibbonGroup * | pRibbonGroup )
 virtual

This method is called to draw the ribbon group pop-up toolbar.

Parameters
pDC | Pointer to a valid device context.
pRibbonGroup | Group to draw.

Reimplemented in CXTPRibbonMarkupTheme.

◆ DrawRibbonQuickAccessButton()

virtual void DrawRibbonQuickAccessButton | ( | CDC * | pDC,
 |  | CXTPControlPopup * | pControl )
 pure virtual

This method is called to draw the Quick Access customize button.

Parameters
pDC | Pointer to a valid device context.
pControl | Pointer to the Quick Access customize button.
See also
DrawRibbonQuickAccessMoreButton

Implemented in CXTPRibbonMarkupTheme, CXTPRibbonThemeOffice2007System, and CXTPRibbonThemeResource.

◆ DrawRibbonQuickAccessMoreButton()

virtual void DrawRibbonQuickAccessMoreButton | ( | CDC * | pDC,
 |  | CXTPControlPopup * | pControl )
 pure virtual

This method is called to draw the Quick Access more button.

Parameters
pDC | Pointer to a valid device context.
pControl | Pointer to the Quick Access more button.
See also
DrawRibbonQuickAccessButton

Implemented in CXTPRibbonMarkupTheme, and CXTPRibbonThemeResource.

◆ DrawRibbonScrollButton()

virtual void DrawRibbonScrollButton | ( | CDC * | pDC,
 |  | CXTPControl * | pControl,
 |  | BOOL | bScrollLeft )
 pure virtual

This method is called to draw scroll group buttons.

Parameters
pDC | Pointer to a valid device context.
pControl | Scroll button to draw.
bScrollLeft | TRUE to draw the left button, FALSE to draw the right.

Implemented in CXTPRibbonMarkupTheme, and CXTPRibbonThemeResource.

◆ DrawRibbonTab()

virtual void DrawRibbonTab | ( | CDC * | pDC,
 |  | CXTPRibbonTab * | pItem )
 pure virtual

This method is called to draw a single tab of the ribbon bar.

Parameters
pDC | Pointer to a valid device context.
pItem | Ribbon tab to draw.

Implemented in CXTPRibbonMarkupTheme, CXTPRibbonOffice2013Theme, CXTPRibbonThemeNativeWindows10, CXTPRibbonThemeNativeWindows11, and CXTPRibbonThemeResource.

◆ DrawSystemPopupBarButton()

virtual void DrawSystemPopupBarButton | ( | CDC * | pDC,
 |  | CXTPControl * | pButton )
 pure virtual

This method is called to draw a pop-up bar button.

Parameters
pDC | Pointer to a valid device context.
pButton | Pop-up bar button to draw.

Implemented in CXTPRibbonMarkupTheme, and CXTPRibbonThemeResource.

◆ FillGroupPopupToolBar()

virtual void FillGroupPopupToolBar | ( | CDC * | pDC,
 |  | CXTPRibbonGroup * | pGroup,
 |  | CXTPCommandBar * | pCommandBar )
 pure virtual

This method is called to draw the pop-up toolbar of a reduced group.

Parameters
pDC | Pointer to a valid device context.
pGroup | Parent group of pop-up'ed toolbar.
pCommandBar | Pop-up toolbar to draw.

Implemented in CXTPRibbonMarkupTheme, and CXTPRibbonThemeResource.

◆ FillGroupRect()

virtual void FillGroupRect | ( | CDC * | pDC,
 |  | CXTPRibbonTab * | pActiveTab,
 |  | CRect | rcGroups )
 pure virtual

This method is called to fill the background of a CXTPRibbonGroup.

Parameters
pDC | Pointer to a valid device context.
pActiveTab | Pointer to the tab that is currently active.
rcGroups | Bounding rectangle of the group.

Performs a gradient fill using the GROUP_COLOR::clrBackground for the main group background and GROUP_COLOR::clrCaption to fill the group caption rectangle.

See also
CXTPRibbonGroup::GetRect, GROUP_COLOR

Implemented in CXTPRibbonMarkupTheme, CXTPRibbonThemeNativeWindows10, CXTPRibbonThemeNativeWindows11, and CXTPRibbonThemeResource.

◆ FillMorePopupToolBarEntry()

virtual void FillMorePopupToolBarEntry | ( | CDC * | pDC,
 |  | CXTPCommandBar * | pBar )
 pure virtual

This method is called to draw the pop-up bar of the more button.

Parameters
pDC | Pointer to a valid device context.
pBar | Toolbar to fill.

Implemented in CXTPRibbonMarkupTheme, and CXTPRibbonThemeResource.

◆ FillRibbonBar()

virtual void FillRibbonBar | ( | CDC * | pDC,
 |  | CXTPRibbonBar * | pRibbonBar )
 pure virtual

This method is called to fill the background of a ribbon bar control.

Parameters
pDC | Pointer to a valid device context
pRibbonBar | Pointer to the parent ribbon bar.

Implemented in CXTPRibbonMarkupTheme, CXTPRibbonOffice2013Theme, and CXTPRibbonThemeResource.

◆ FillRibbonTabControl()

virtual void FillRibbonTabControl | ( | CDC * | pDC,
 |  | CXTPRibbonBar * | pRibbonBar,
 |  | CRect | rcControl )
 pure virtual

This member fills in the tab header and tab client area.

It will then draw tab client frame.

Parameters
pRibbonBar | Pointer to the ribbon bar to draw the tab control for.
pDC | Pointer to a valid device context.
rcControl | Bounding rectangle of the tab control.

Implemented in CXTPRibbonMarkupTheme, and CXTPRibbonThemeResource.

◆ FillSystemPopupBarEntry()

virtual void FillSystemPopupBarEntry | ( | CDC * | pDC,
 |  | CXTPPopupBar * | pBar )
 pure virtual

This method is called to draw the pop-up bar of the system button.

Parameters
pDC | Pointer to a valid device context.
pBar | Toolbar to fill.

Implemented in CXTPRibbonMarkupTheme, and CXTPRibbonThemeResource.

◆ FillTabPopupToolBar()

virtual void FillTabPopupToolBar | ( | CDC * | pDC,
 |  | CXTPPopupToolBar * | pPopupToolBar )
 virtual

This method is called to draw the background of a minimized pop-up bar.

Parameters
pDC | Pointer to a valid device context.
pPopupToolBar | Pointer to a pop-up toolbar.

◆ GetControlGroupOptionSize()

virtual CSize GetControlGroupOptionSize ( ) const
pure virtual

Calculates the ribbon group option size.

Returns
The ribbon group option size.

Implemented in CXTPRibbonMarkupTheme, and CXTPRibbonThemeResource.

◆ GetEditHeight()

int GetEditHeight ( ) const

Gets the edit control height.

Returns
The edit control height.

◆ GetFontHeight()

int GetFontHeight ( ) const

Gets the font height used for Ribbon.

Returns
The font height used for Ribbon.
See also
SetFontHeight

◆ GetFramePaintManager()

AFX_INLINE CXTPFramePaintManager * GetFramePaintManager ( ) const

Call this member to get a pointer to the frame paint manager.

Returns
A pointer to the frame paint manager.

◆ GetGroupCaptionHeight()

AFX_INLINE int GetGroupCaptionHeight ( ) const

Gets the height of the group caption bar.

Returns
The height of the group caption bar.
See also
CXTPRibbonGroup::RepositionControls, CXTPRibbonGroup::SetRect

◆ GetImages()

CXTPResourceImages * GetImages ( ) const

This method is called to get a pointer to the CXTPResourceImages object.

Returns
A pointer to the CXTPResourceImages object.

◆ GetRibbonCaptionHeight()

virtual int GetRibbonCaptionHeight ( const CXTPRibbonBar * pRibbonBar ) const
pure virtual

Calculates the ribbon caption height.

Parameters
pRibbonBar Pointer to the parent ribbon bar.
Returns
The ribbon caption height.

Implemented in CXTPRibbonOffice2013Theme, CXTPRibbonThemeOffice2007System, and CXTPRibbonThemeResource.

◆ GetTabPaintManager()

AFX_INLINE CXTPTabPaintManager * GetTabPaintManager ( ) const

Call this member to get a pointer to the tab paint manager.

The tab paint manager is used to customize the appearance of CXTPTabManagerItem objects and the tab manager (i.e. tab colors, styles, etc.). This member must be overridden in derived classes.

Returns
A pointer to the CXTPTabPaintManager that contains the visual elements of the tabs.

◆ LoadImage()

CXTPResourceImage * LoadImage ( LPCTSTR lpszFileName )

Loads a bitmap image from the specified path.

Parameters
lpszFileName The name of the file that contains the bitmaps to load.

The images are the bitmaps that represent all the visual components of the Ribbon Bar. For example tab buttons, group buttons, menu buttons, toolbar buttons, option button, toolbar dropdown, etc. The images are loaded using LoadImage and are stored in the m_pImages image collection. Images for the Office 2007 theme can be found in the \Source\Ribbon\Res folder.

Returns
New CXTPResourceImage containing the loaded bitmap.
See also
SetImageHandle, m_pImages

◆ RefreshMetrics()

virtual void RefreshMetrics ( )
virtual

This method is called to refresh the visual metrics of the manager.

Refreshes all of the colors in the ribbon bar. Many of the colors used are set with the GROUP_COLOR structure.

See also
GROUP_COLOR

Reimplemented in CXTPRibbonMarkupTheme, CXTPRibbonOffice2013Theme, CXTPRibbonThemeNativeWindows10, CXTPRibbonThemeNativeWindows11, CXTPRibbonThemeOffice2007System, and CXTPRibbonThemeResource.

◆ SetFontHeight()

void SetFontHeight ( int nFontHeight )

Sets the font height used for Ribbon.

Parameters
nFontHeight New font height.
See also
GetFontHeight

Member Data Documentation

◆ m_clrFileButtonText

COLORREF m_clrFileButtonText
protected

Text caption to display when the system button is displayed as a tab button (Windows 7 style).

Button style must be button caption.

The documentation for this class was generated from the following file:
  • XTPRibbonPaintManager.h


Toolkit Pro: CXTPRibbonQuickAccessControls Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPRibbonQuickAccessControls Class Reference

CXTPRibbonQuickAccessControls is a CXTPControls derived class. More...

Inheritance diagram for CXTPRibbonQuickAccessControls:
[legend]

Public Member Functions

CXTPRibbonQuickAccessControls ()
Constructs a CXTPRibbonQuickAccessControls object.
virtual | ~CXTPRibbonQuickAccessControls ()
Destroys a CXTPRibbonQuickAccessControls object, handles cleanup and deallocation.
void | Remove (CXTPControl *pControl)
Call this member to remove a control.
void | Reset ()
Call this method to reset Quick Access controls.
CXTPControl * | FindDuplicate (CXTPControl *pControl)
Call this method to find a duplicate of a control.
int | IndexOf (CXTPControl *pControl) const
Retrieves the index of a specified control from the Quick Access bar.
- Public Member Functions inherited from CXTPControls
CXTPControls ()
Internal helper structure.
virtual | ~CXTPControls ()
Destroys a CXTPControls object, handles cleanup and deallocation.
CXTPControl * | GetAt (int nIndex) const
Call this member to return the control at the specified index.
int | CommandToIndex (int nIDFind) const
This member function returns the index of the first control, starting at position 0, whose command ID matches nIDFind.
CXTPControl * | Add (CXTPControl *pControl, int nId, LPCTSTR lpszParameter=NULL, int nBefore=-1, BOOL bTemporary=FALSE)
Call this member to add a new control.
CXTPControl * | Add (XTPControlType controlType, int nId, LPCTSTR lpszParameter=NULL, int nBefore=-1, BOOL bTemporary=FALSE)
Call this member to add a new control.
CXTPControl * | Add (CXTPControl *pControl)
Call this member to add a new control.
CXTPControl * | InsertAt (CXTPControl *pControl, int nBefore)
Call this member to insert a new control.
CXTPControl * | AddMenuItem (CMenu *pMenu, int nIndex)
Call this member to add a new control.
void | Remove (int nIndex)
Call this member to remove a control.
void | RemoveAll ()
Call this member to remove all controls.
int | GetCount () const
Call this member to get the count of the controls.
CXTPControl * | FindControl (int nId) const
Call this member to find the specified control.
CXTPControl * | FindControl (XTPControlType type, int nId, BOOL bVisible, BOOL bRecursive) const
Call this member to find the specified control.
BOOL | LoadMenu (CMenu *pMenu)
Call this member to convert menu items to command bar controls.
CXTPControl * | GetFirst () const
Call this member to retrieve the first control.
void | GetNext (CXTPControl *&pControl) const
Finds the next control in the given direction.
long | GetNext (long nIndex, int nDirection=+1, BOOL bKeyboard=TRUE, BOOL bSkipTemporary=FALSE, BOOL bSkipCollapsed=TRUE) const
Finds the next control in the given direction.
CXTPControl * | HitTest (CPoint point) const
This member function determines which control, if any, is at a specified point.
CXTPControl * | SetControlType (CXTPControl *pControl, XTPControlType type)
Call this member to change the type of the control.
CXTPControl * | SetControlType (int nIndex, XTPControlType type)
Call this member to change the type of the control.
CXTPControl * | AddClone (CXTPControl *pClone, int nBefore=-1, BOOL bRecursive=FALSE)
Call this member to add a copy of a control.
CSize | CalcDynamicSize (CDC *pDC, int nLength, DWORD dwMode, const CRect &rcBorder, int nWidth=0)
This method is called internally to reposition controls and determine their size.
CSize | CalcPopupSize (CDC *pDC, int nLength, int nWidth, const CRect &rcBorder)
This method is called internally to reposition controls and determine their size for a pop-up bar.
int | GetVisibleCount (BOOL bIgnoreWrap=FALSE) const
Call this member to get the number of visible controls.
CXTPControl * | GetVisibleAt (int nIndex, BOOL bIgnoreWraps=FALSE) const
Finds a specified control by its ID.
void | SetCommandBars (CXTPCommandBars *pCommandBars)
Call this member to attach the specified command bars object.
CXTPControls * | Duplicate (BOOL bRecursive=FALSE)
Makes a copy of all controls.
virtual void | Copy (CXTPControls *pControls, BOOL bRecursive=FALSE)
This method is called to copy the control.
CXTPCommandBars * | GetCommandBars () const
Retrieves the parent command bars object.
void | MoveBefore (CXTPControl *pControl, int nBefore)
Moves the control to a specified position.
void | SetParent (CXTPCommandBar *pParent)
Attaches the parent command bar.
void | CreateOriginalControls ()
Creates the original controls set.
void | ClearOriginalControls ()
Removes the original controls set.
CXTPOriginalControls * | GetOriginalControls () const
Retrieves the original controls set.
void | SetOriginalControls (CXTPOriginalControls *pControls)
Call this method to assign original controls.
BOOL | Compare (const CXTPControls *pControls)
Call this member to compare the controls.
BOOL | IsChanged () const
Returns the changed status flag of the control.
virtual void | DoPropExchange (CXTPPropExchange *pPX)
Either reads this object from or writes this object to an archive.
virtual BOOL | ShouldSerializeControl (CXTPControl *pControl)
Call this method to check if the control has been changed and must be saved.
CXTPCommandBar * | GetParent () const
Call this member to get the parent command bar.
BOOL | IsOriginalControls () const
Determines if all controls in the collection are original (i.e.
void | Sort ()
Sorts the commands list.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

virtual void | OnControlAdded (CXTPControl *pControl)
This method is called when a control is added to the collection.
virtual void | OnControlRemoved (CXTPControl *pControl)
This method is called when a control is removed from the collection.
- Protected Member Functions inherited from CXTPControls
virtual BOOL | OnControlRemoving (CXTPControl *pControl)
This method is called when a control is about to be removed from the collection.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Attributes inherited from CXTPControls
CXTPCommandBar * | m_pParent
Parent Command Bar.
CArray< CXTPControl *, CXTPControl * > | m_arrControls
Collection of controls.
CXTPCommandBars * | m_pCommandBars
Parent Command Bars.
CXTPOriginalControls * | m_pOriginalControls
Original controls collection.
BOOL | m_bOriginalControls
TRUE if all controls are original and unmodified.

Detailed Description

CXTPRibbonQuickAccessControls is a CXTPControls derived class.

It represents a collection of Quick Access controls for a Ribbon Bar.

Member Function Documentation

◆ FindDuplicate()

CXTPControl * FindDuplicate ( CXTPControl * pControl )

Call this method to find a duplicate of a control.

Parameters
pControl Control with a duplicate to find.
Returns
A pointer to a duplicate of the control if successful, otherwise NULL.

◆ IndexOf()

int IndexOf ( CXTPControl * pControl ) const

Retrieves the index of a specified control from the Quick Access bar.

Parameters
pControl Control whose index must be retrieved.
Returns
The index of the specified control if successful, otherwise -1.

◆ OnControlAdded()

virtual void OnControlAdded ( CXTPControl * pControl )
protectedvirtual

This method is called when a control is added to the collection.

Parameters
pControl Control that was added to the collection.

Reimplemented from CXTPControls.

◆ OnControlRemoved()

virtual void OnControlRemoved ( CXTPControl * pControl )
protectedvirtual

This method is called when a control is removed from the collection.

Parameters
pControl Control that was removed from the collection.

Reimplemented from CXTPControls.

◆ Remove()

void Remove ( CXTPControl * pControl )
virtual

Call this member to remove a control.

Parameters
pControl Control to be removed.

Reimplemented from CXTPControls.

The documentation for this class was generated from the following file:
  • XTPRibbonQuickAccessControls.h


Toolkit Pro: CXTPRibbonSystemPopupBar Class Reference

Public Member Functions | List of all members
CXTPRibbonSystemPopupBar Class Reference

CXTPRibbonSystemPopupBar is a CXTPPopupBar derived class used as a system pop-up bar for a Ribbon Bar. More...

Inheritance diagram for CXTPRibbonSystemPopupBar:
[legend]

Public Member Functions

CXTPRibbonSystemPopupBar ()
Constructs a CXTPRibbonSystemPopupBar object.
virtual CRect | GetBorders ()
This method is called to get the border margins of the command bar.
virtual void | FillCommandBarEntry (CDC *pDC)
This method is called to draw the background of the command bar.
virtual CSize | CalcDynamicLayout (int nLength, DWORD dwMode)
This method is called to get the size of the command bar.
- Public Member Functions inherited from CXTPPopupBar
void | SetTearOffPopup (LPCTSTR lpszCaption, UINT nID, int nWidth=400)
This method adds the tear-off state to the pop-up bar.
BOOL | IsTearOffPopup (CString &strCaption, UINT &nID, int &nWidth)
Determines if the pop-up bar has the tear-off state.
virtual BOOL | IsVisible () const
Call this member to determine if the pop-up menu is visible/displayed.
BOOL | Popup (int xPos, int yPos, LPCRECT rcExclude)
This method opens the pop-up bar.
BOOL | Popup (CXTPControlPopup *pControlPopup, BOOL bSelectFirst=FALSE)
This method opens the pop-up bar.
CXTPControlPopup * | GetControlPopup () const
Call this member to retrieve the control's pop-up.
void | ExpandBar ()
This method expands the bar.
BOOL | DestroyWindow ()
Call this member to destroy the window.
void | SetPopupToolBar (BOOL bToolBarType)
Call this method to make the pop-up bar look like a pop-up toolbar.
void | SetDefaultItem (UINT uItem, BOOL fByPos=FALSE)
Sets the default menu item for the specified pop-up bar.
UINT | GetDefaultItem (UINT gmdiFlags, BOOL fByPos=FALSE)
Determines the default menu item on the specified pop-up bar.
BOOL | IsDoubleGripper () const
Call this method to determine if the pop-up bar has a double gripper.
void | SetDoubleGripper (BOOL bDoubleGripper=TRUE)
Call this member to set a double gripper for the pop-up bar.
virtual BOOL | IsPopupBar () const
Call this member function to determine if the command bar is a CXTPPopupBar.
BOOL | IsContextMenu () const
Determines if the pop-up bar is a context menu.
void | PumpMessage ()
Translates all messages in the message queue.
virtual BOOL | Create ()
Creates the pop-up bar.
virtual CRect | CalculatePopupRect (CPoint ptPopup, CSize sz)
This method is called to calculate the destination rectangle of the pop-up bar.
void | SetPopupFlags (DWORD dwPopupFlags)
Call this method to set the pop-up direction.
virtual BOOL | SetTrackingMode (int bMode, BOOL bSelectFirst=TRUE, BOOL bKeyboard=FALSE)
Call this member to change the tracking state.
void | SetBorders (CRect rcBorders)
Sets the toolbar's borders.
void | DisableShadow ()
Disables shadow use.
BOOL | IsResizable () const
Determines if the control can be resized by the user.
- Public Member Functions inherited from CXTPCommandBar
int | IsTrackingMode () const
Call this member to get the tracking state.
CXTPControls * | GetControls () const
Call this member to get the controls collection.
void | SetControls (CXTPControls *pControls)
Call this member to set the controls collection of the command bar.
XTPBarType | GetType () const
Call this member to get the type of the command bar.
void | SetTextOrientation (XTPBarTextOrientation nTextOrientation)
Call this member to change text orientation.
XTPBarTextOrientation | GetTextOrientation () const
Call this member to get the text orientation.
XTPBarPosition | GetPosition () const
Call this member to get the position of the command bar.
void | DelayLayout ()
Call this member to recalculate the layout.
virtual BOOL | LoadMenu (CMenu *pMenu, BOOL bRemoveControls=TRUE)
Call this member to convert menu items to command bar controls.
CXTPControl * | GetControl (int nIndex) const
Call this member to return the control at the specified index.
int | GetControlCount () const
Call this member to get the count of the controls.
CXTPControl * | GetSelected () const
Call this member to get the currently selected control.
BOOL | SetPopuped (int nPopuped, BOOL bKeyboard=FALSE)
Call this member to pop-up the specified control.
void | SetTitle (LPCTSTR lpszTitle)
Call this member to set a title for this command bar.
CString | GetTitle () const
Call this member to get a title for this command bar.
CXTPCommandBars * | GetCommandBars () const
Call this member to get the command bar's object.
void | SetCommandBars (CXTPCommandBars *pCommandBars)
Call this member to set the command bar's object.
CWnd * | GetSite () const
Call this member to get the command bar's site.
CFrameWnd * | GetFrameSite () const
Call this member to get the command bar's site as CFrameWnd.
void | SetFlags (DWORD dwFlagsAdd, DWORD dwFlagsRemove=0)
Call this member to set the command bar's flags.
BOOL | SetButtons (UINT *pButtons, int nCount)
Call this member to set the controls from the button array.
virtual BOOL | LoadToolBar (UINT nIDResource, BOOL bLoadIcons=TRUE)
Call this member function to load the toolbar specified by nIDResource.
void | SetIconSize (CSize size)
Call this function to set the size of the actual bitmapped images to be added to a toolbar.
virtual CSize | GetIconSize () const
Call this member function to get the size of the toolbar icon.
CSize | GetLargeIconSize (BOOL bAutoSize) const
Call this method to get the large icon size of the toolbar.
void | SetButtonSize (CSize size)
Sets the size of the buttons in the command bar.
virtual CSize | GetButtonSize () const
Call this function to get the size of the command bar button.
void | ShowTextBelowIcons (BOOL bTextBelow=TRUE)
Call this member to show the caption below control's icon.
BOOL | IsTextBelowIcons () const
Checks whether the caption is below the control's icon.
HWND | GetTrackFocus () const
Call this method to retrieve the current focused control.
void | SetTrackFocus (HWND hwnd)
Call this method to set focus to the window.
virtual void | SetVisible (BOOL bVisible)
Call this method to set the visibility state of the control.
virtual BOOL | SetPosition (XTPBarPosition barPosition)
Call this member function to set the position of the command bar.
int | FindAccel (TCHAR chAccel) const
Call this method to get the index of the control with the specified accelerator character.
int | FindAccelEx (UINT chAccel, BOOL &bSelectOnly) const
Call this method to get the index of the control with the specified accelerator character.
BOOL | IsCustomizeMode () const
Call this method to check if the command bars are in customize mode.
virtual DROPEFFECT | OnCustomizeDragEnter (CXTPControl *pDataObject, CPoint point)
This member is called when a control is entered into the command bar.
virtual void | OnCustomizeDragLeave ()
This method is called when a control leaves the command bar.
virtual DROPEFFECT | OnCustomizeDragOver (CXTPControl *pDataObject, CPoint point)
This member is called when control is over the command bar.
virtual void | OnCustomizeDrop (CXTPControl *pDataObject, DROPEFFECT &dropEffect, CPoint ptDrop, CPoint ptDrag)
This method is called when a control is dropped to the command bar.
virtual BOOL | IsCustomizable () const
Call this method to check if the command bar is customizable.
BOOL | IsCustomizeDialogPresent () const
Call this method to check if the command bar is present in Customize dialog.
void | EnableCustomization (BOOL bEnable=TRUE)
Call this method to enable/disable customization of the command bar.
virtual void | OnTrackLost ()
Call this method to remove the tracking state of the command bar.
virtual void | OnTrackEnter ()
Call this method to track the command bar.
CWnd * | GetOwnerSite () const
Call this method to retrieve the owner window of the command bar.
void | InvalidateParents ()
Call this method to redraw all parent command bars.
DWORD | GetFlags () const
Call this method to retrieve the current behavior modification flags of the command bar.
UINT | GetBarID () const
Call this method to retrieve the identifier of the command bar.
void | SetBarID (UINT nID)
Call this method to set the identifier of the command bar.
virtual void | OnControlSelected (BOOL bSelected, CXTPControl *pControl)
This method is called when a child control becomes selected.
BOOL | SetStatusText (const CString &strDescription)
This method is called to set the description context.
void | SetCommandBarData (DWORD_PTR dwData)
This method sets the 32-bit value associated with the command bar.
DWORD_PTR | GetCommandBarData () const
This method retrieves the application-supplied, 32-bit value associated with the command bar.
CXTPCommandBar * | GetRootParent () const
Call this method to retrieve the top-level parent command bar.
CXTPPaintManager * | GetPaintManager () const
Call this method to retrieve the paint manager.
CXTPImageManager * | GetImageManager () const
Call this method to retrieve the image manager.
void | SetWidth (int nWidth)
Call this member to set the width of the floated or pop-up toolbar.
int | GetWidth () const
Call this member to get the width of the floated or pop-up toolbar.
void | SetPaintManager (CXTPPaintManager *pPaintManager)
Call this member to set the specified paint manager.
void | SetImageManager (CXTPImageManager *pImageManager)
Call this member to set the specified image manager.
BOOL | IsLayoutRTL () const
Call this member function to determine if the command bar layout is Right-to-Left (RTL).
virtual BOOL | IsDialogBar () const
Call this member function to determine if the command bar is a CXTPDialogBar.
virtual BOOL | IsRibbonBar () const
Call this member function to determine if the command bar is a CXTPRibbonBar.
virtual BOOL | IsMenuTitleBar () const
Call this member function to determine if the command bar is a CXTPMenuTitleBar.
virtual BOOL | IsKeyboardCuesVisible () const
Determines if underlines are visible in the command bar control.
void | SetGrabFocus (BOOL bGrabFocus)
This method is called internally to prevent the command bar from grabbing edit focus.
virtual void | Redraw (LPCRECT lpRect=0, BOOL bAnimate=TRUE)
The framework calls this member function to redraw the command bar.
void | EnableAnimation (BOOL bEnable=TRUE)
Call this method to enable animation for the command bar.
void | EnableDoubleBuffer (BOOL bEnable=TRUE)
Call this method to enable double buffer for toolbar drawing.
BOOL | IsAnimationEnabled () const
Determines if animation is enabled for the specified command bar.
virtual int | OnHookMessage (HWND hWnd, UINT nMessage, WPARAM &wParam, LPARAM &lParam, LRESULT &lResult)
This member function is called by WindowProc, or is called during message reflection.
virtual void | EnsureVisible (CXTPControl *pControl)
Call this method to ensure that a specified control is visible on the toolbar.
XTPButtonStyle | GetDefaultButtonStyle () const
Call this method to retrieve the default button style of the command bar.
void | SetDefaultButtonStyle (XTPButtonStyle buttonStyle)
Call this method to set the default button style of the command bar.
void | LockRedraw ()
Call this method to freeze redrawing until UnlockRedraw is called.
void | UnlockRedraw ()
Call this method to unfreeze redrawing.
void | SetShowGripper (BOOL bShow)
Call this method to set the visibility of the command bar's gripper.
BOOL | GetShowGripper () const
Call this method to check if the command bar's gripper is visible.
BOOL | IsKeyboardTipsVisible () const
Call this method to check if keyboard tips are visible for the command bar.
virtual void | CreateKeyboardTips ()
This method is called to create a keyboard tips collection for the command bar.
void | OnKeyboardTipChar (UINT chAccel)
This method is called when the user presses a key while keyboard tips are visible.
virtual void | OnKeyboardTip (CXTPCommandBarKeyboardTip *pTip)
This method is called when a keyboard tip is found for the command bar.
void | HideKeyboardTips ()
Call this method to hide keyboard tips.
void | LockMouseMove (CXTPControl *pControl)
Locks the mouse cursor for a specified control.
void | UnlockMouseMove ()
Unlocks the mouse cursor.
- Public Member Functions inherited from CXTPHookManagerHookAble
CXTPHookManagerHookAble ()
Constructs a CXTPHookManagerHookAble object.
virtual | ~CXTPHookManagerHookAble ()
Destroys a CXTPHookManagerHookAble object, handles cleanup and deallocation.
virtual int | OnPostHookMessage (HWND hWnd, UINT nMessage, WPARAM &wParam, LPARAM &lParam, LRESULT &lResult)
This member function is called after a message has been processed by default window procedure.
virtual void | OnHookAttached (HWND hWnd)
This member function is called right after a hook is attached to the window.
virtual void | OnHookDetached ()
This member function is called right before a hook is to be detached from the window.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPPopupBar
static CXTPPopupBar *AFX_CDECL | CreatePopupBar (CXTPCommandBars *pCommandBars)
Creates a pop-up bar object.
- Public Attributes inherited from CXTPCommandBar
int | m_nStateFlags
State of the command bars.
BOOL | m_bComboBar
TRUE if it is combobox list.
BOOL | m_bTrackOnHover
TRUE to select item if mouse stay over control.
- Public Attributes inherited from CXTPHookManagerHookAble
BOOL | m_bAutoDestroy
TRUE to automatically delete hook.
- Static Public Attributes inherited from CXTPPopupBar
static double | m_dMaxWidthDivisor
Maximum available width of pop-up.
- Static Public Attributes inherited from CXTPCommandBar
static int | s_nHoverDelay
Hover delay time.
static int | s_nExpandDelay
Expand delay time.
static int | s_nExpandHoverDelay
Expand hover delay.
- Protected Member Functions inherited from CXTPPopupBar
CXTPPopupBar ()
Constructs a CXTPPopupBar object.
virtual | ~CXTPPopupBar ()
Destroys a CXTPPopupBar object, handles cleanup and deallocation.
virtual void | DelayRedraw ()
Redraw the pop-up bar.
virtual BOOL | SetSelected (int nSelected, BOOL bKeyboard=FALSE)
Call this member to select the specified control.
void | UpdateLocation (CSize sz)
This method sets the pop-up bar's position.
virtual void | UpdateFlags ()
Update flags.
void | UpdateExpandingState ()
Update expanding state.
virtual void | DrawCommandBar (CDC *pDC, CRect rcClipBox)
This method is called to draw the command bar in the given context.
virtual void | OnControlsChanged ()
This method is called when the controls array is changed.
virtual void | OnRecalcLayout ()
This method is called to recalculate the command bar layout.
CXTPCommandBar * | GetParentCommandBar () const
Call this member to retrieve the parent command bar.
virtual void | DoPropExchange (CXTPPropExchange *pPX)
Either reads this object from or writes this object to an archive.
virtual void | Copy (CXTPCommandBar *pCommandBar, BOOL bRecursive=FALSE)
Call this method make a copy of the command bar.
virtual BOOL | OnHookKeyDown (UINT nChar, LPARAM lParam)
The framework calls this member function when a non-system key is pressed.
virtual void | AdjustExcludeRect (CRect &rc, BOOL bVertical)
Updates rectangle to set the position where the child pop-up bar becomes visible.
virtual void | Animate ()
Animates pop-up window.
- Protected Member Functions inherited from CXTPCommandBar
CXTPCommandBar ()
Constructs a CXTPCommandBar object.
virtual | ~CXTPCommandBar ()
Destroys a CXTPCommandBar object, handles cleanup and deallocation.
virtual BOOL | ProcessSpecialKey (XTPSpecialKey key)
This method is called to process special keys.
virtual int | OnMouseHitTest (CPoint pt)
This method is called to determine mouse hit code.
virtual void | UpdateShortcuts ()
Updates the control's shortcuts.
UINT | GetActiveDocTemplate () const
Retrieves the active MDI document template.
virtual void | GenerateCommandBarList (DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam)
This method is called to assign self identifiers for the serialization process.
virtual void | RestoreCommandBarList (CXTPCommandBarList *pCommandBarList)
This method is called in the serialization process to restore pop-ups from a list of command bars.
BOOL | IsHelpMode () const
Determines if the parent frame is in help mode.
virtual void | OnRemoved ()
This method is called when a toolbar is removed from the command bars collection.
- Protected Attributes inherited from CXTPPopupBar
CXTPControlPopup * | m_pControlPopup
Control that pop-up'ed the bar.
CPoint | m_ptPopup
Position of the bar.
CRect | m_rcExclude
Excluded area.
DWORD | m_popupFlags
Flags of the bar.
BOOL | m_bDynamicLayout
TRUE if DynamicLayout routine executed.
BOOL | m_bCollapsed
TRUE if pop-up bar is collapsed.
BOOL | m_bExpanded
TRUE if pop-up bar is expanded.
BOOL | m_bExpanding
TRUE if pop-up bar is expanding.
BOOL | m_bTearOffPopup
TRUE if pop-up bar has tear-off option.
CRect | m_rcTearOffGripper
Tear-off gripper position.
CRect | m_rcResizeGripper
Resizable gripper position.
BOOL | m_bResizable
TRUE to allow resize.
BOOL | m_bTearOffSelected
TRUE if gripper selected.
UINT_PTR | m_nTearOffTimer
Tear-off timer.
BOOL | m_bTearOffTracking
Tear-off tracking mode.
CSize | m_szTearOffBar
Size of the bar.
CXTPToolBar * | m_pTearOffBar
Tear-off toolbar pointer.
CString | m_strTearOffCaption
Caption of the Tear-off toolbar.
UINT | m_nTearOffID
ID of the Tear-off toolbar.
int | m_nTearOffWidth
Width of the Tear-off toolbar.
BOOL | m_bShowShadow
TRUE to show the shadow.
CRect | m_rcBorders
Borders of the bar.
BOOL | m_bDoubleGripper
TRUE if pop-up is state pop-up type.
BOOL | m_bContextMenu
TRUE if pop-up bar is context menu.
int | m_nMaxHeight
Maximum height the pop-up bar can become.
- Protected Attributes inherited from CXTPCommandBar
BOOL | m_bGrabFocus
TRUE to grab current focus.
int | m_nMRUWidth
Recent width.
int | m_nSelected
Selected control index.
int | m_nPopuped
Pop-up'ed control index.
HWND | m_hwndFocus
The handle of the window that currently has focus.
UINT | m_nBarID
Command bar's identifier.
BOOL | m_bTracking
TRUE if the command bar is in tracking mode.
CWnd * | m_pSite
Command bar's site.
DWORD | m_nIdleFlags
Idle flags.
DWORD | m_dwFlags
Command bar's flags.
DWORD | m_dwStyle
Command bar's styles.
CString | m_strTitle
Command bar's caption.
XTPBarType | m_barType
Type of the command bar.
CXTPControls * | m_pControls
A pointer to controls collection.
XTPBarPosition | m_barPosition
Position of the command bar.
CXTPCommandBars * | m_pCommandBars
parent command bars class.
CWnd * | m_pOwner
Owner window.
CSize | m_szIcons
Size of the command bar's icons.
CSize | m_szButtons
Size of the command bar's buttons.
BOOL | m_bTextBelow
TRUE if text is shown below the CommandBar buttons.
BOOL | m_bExecOnRButton
TRUE if the control button is executed on a right-click.
BOOL | m_bIgnoreUpdateHandler
TRUE to skip update handler for all child controls.
BOOL | m_bRecursePopup
TRUE if pop-up bar was opened recursively.
BOOL | m_bKeyboardSelect
TRUE if last item was selected by keyboard.
BOOL | m_bCloseable
TRUE if the CommandBar can be closed and-or Hidden.
BOOL | m_bCustomizable
TRUE if command bar is customizable.
CRect | m_rcMarker
Marker position.
BOOL | m_bVerticalMarker
TRUE to draw marker vertically.
DWORD_PTR | m_dwData
The 32-bit value associated with the command bar.
UINT * | m_pReturnCmd
Return command holder.
BOOL | m_bCustomizeDialogPresent
TRUE if the command bar is present in Customize dialog.
BOOL | m_bAnimatePopup
TRUE to animate pop-up bar.
BOOL | m_nLockRedraw
TRUE if all drawing routines skipped.
CXTPPaintManager * | m_pPaintManager
Selected paint manager for command bar.
CXTPImageManager * | m_pImageManager
Selected image manager for command bar.
BOOL | m_bMultiLine
True if multi line commandbar.
XTPButtonStyle | m_buttonStyle
Default button Style.
XTPBarTextOrientation | m_nTextOrientation
Commandbar text orientation.
CXTPToolTipContext * | m_pToolTipContext
Tool tip Context.
CXTPCommandBarAnimation * | m_pAnimation
Animation context.
CSize | m_szButtonSpacing
Spacing used between toolbar buttons.

Detailed Description

CXTPRibbonSystemPopupBar is a CXTPPopupBar derived class used as a system pop-up bar for a Ribbon Bar.

Member Function Documentation

◆ CalcDynamicLayout()

virtual CSize CalcDynamicLayout | ( | int | nLength,
 |  | DWORD | dwMode )
 virtual

This method is called to get the size of the command bar.

Parameters
nLength | The requested dimension of the control bar, either horizontal or vertical depending on dwMode.
dwMode | See CControlBar::CalcDynamicLayout for the list of supported flags.
Returns
The size of the command bar.

Reimplemented from CXTPPopupBar.

◆ FillCommandBarEntry()

virtual void FillCommandBarEntry ( CDC * pDC )
virtual

This method is called to draw the background of the command bar.

Parameters
pDC Pointer to the device context to draw.
See also
DrawCommandBar

Reimplemented from CXTPCommandBar.

◆ GetBorders()

virtual CRect GetBorders ( )
virtual

This method is called to get the border margins of the command bar.

Returns
A CRect object containing the border margins of the command bar.

Reimplemented from CXTPPopupBar.

The documentation for this class was generated from the following file:
  • XTPRibbonSystemButton.h


Toolkit Pro: CXTPRibbonSystemPopupBarPage Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPRibbonSystemPopupBarPage Class Reference

CXTPRibbonSystemPopupBarPage is a CXTPPopupBar derived class used as a system pop-up bar page of a Ribbon Bar. More...

Inheritance diagram for CXTPRibbonSystemPopupBarPage:
[legend]

Public Member Functions

CXTPRibbonSystemPopupBarPage ()
Constructs a CXTPRibbonSystemPopupBarPage object.
- Public Member Functions inherited from CXTPPopupBar
void | SetTearOffPopup (LPCTSTR lpszCaption, UINT nID, int nWidth=400)
This method adds the tear-off state to the pop-up bar.
BOOL | IsTearOffPopup (CString &strCaption, UINT &nID, int &nWidth)
Determines if the pop-up bar has the tear-off state.
virtual BOOL | IsVisible () const
Call this member to determine if the pop-up menu is visible/displayed.
BOOL | Popup (int xPos, int yPos, LPCRECT rcExclude)
This method opens the pop-up bar.
BOOL | Popup (CXTPControlPopup *pControlPopup, BOOL bSelectFirst=FALSE)
This method opens the pop-up bar.
CXTPControlPopup * | GetControlPopup () const
Call this member to retrieve the control's pop-up.
void | ExpandBar ()
This method expands the bar.
BOOL | DestroyWindow ()
Call this member to destroy the window.
void | SetPopupToolBar (BOOL bToolBarType)
Call this method to make the pop-up bar look like a pop-up toolbar.
void | SetDefaultItem (UINT uItem, BOOL fByPos=FALSE)
Sets the default menu item for the specified pop-up bar.
UINT | GetDefaultItem (UINT gmdiFlags, BOOL fByPos=FALSE)
Determines the default menu item on the specified pop-up bar.
BOOL | IsDoubleGripper () const
Call this method to determine if the pop-up bar has a double gripper.
void | SetDoubleGripper (BOOL bDoubleGripper=TRUE)
Call this member to set a double gripper for the pop-up bar.
virtual BOOL | IsPopupBar () const
Call this member function to determine if the command bar is a CXTPPopupBar.
BOOL | IsContextMenu () const
Determines if the pop-up bar is a context menu.
void | PumpMessage ()
Translates all messages in the message queue.
virtual BOOL | Create ()
Creates the pop-up bar.
virtual CRect | CalculatePopupRect (CPoint ptPopup, CSize sz)
This method is called to calculate the destination rectangle of the pop-up bar.
void | SetPopupFlags (DWORD dwPopupFlags)
Call this method to set the pop-up direction.
virtual BOOL | SetTrackingMode (int bMode, BOOL bSelectFirst=TRUE, BOOL bKeyboard=FALSE)
Call this member to change the tracking state.
void | SetBorders (CRect rcBorders)
Sets the toolbar's borders.
void | DisableShadow ()
Disables shadow use.
BOOL | IsResizable () const
Determines if the control can be resized by the user.
virtual CRect | GetBorders ()
Call this method to get the border margins of the command bar.
- Public Member Functions inherited from CXTPCommandBar
int | IsTrackingMode () const
Call this member to get the tracking state.
CXTPControls * | GetControls () const
Call this member to get the controls collection.
void | SetControls (CXTPControls *pControls)
Call this member to set the controls collection of the command bar.
XTPBarType | GetType () const
Call this member to get the type of the command bar.
void | SetTextOrientation (XTPBarTextOrientation nTextOrientation)
Call this member to change text orientation.
XTPBarTextOrientation | GetTextOrientation () const
Call this member to get the text orientation.
XTPBarPosition | GetPosition () const
Call this member to get the position of the command bar.
void | DelayLayout ()
Call this member to recalculate the layout.
virtual BOOL | LoadMenu (CMenu *pMenu, BOOL bRemoveControls=TRUE)
Call this member to convert menu items to command bar controls.
CXTPControl * | GetControl (int nIndex) const
Call this member to return the control at the specified index.
int | GetControlCount () const
Call this member to get the count of the controls.
CXTPControl * | GetSelected () const
Call this member to get the currently selected control.
BOOL | SetPopuped (int nPopuped, BOOL bKeyboard=FALSE)
Call this member to pop-up the specified control.
void | SetTitle (LPCTSTR lpszTitle)
Call this member to set a title for this command bar.
CString | GetTitle () const
Call this member to get a title for this command bar.
CXTPCommandBars * | GetCommandBars () const
Call this member to get the command bar's object.
void | SetCommandBars (CXTPCommandBars *pCommandBars)
Call this member to set the command bar's object.
CWnd * | GetSite () const
Call this member to get the command bar's site.
CFrameWnd * | GetFrameSite () const
Call this member to get the command bar's site as CFrameWnd.
void | SetFlags (DWORD dwFlagsAdd, DWORD dwFlagsRemove=0)
Call this member to set the command bar's flags.
BOOL | SetButtons (UINT *pButtons, int nCount)
Call this member to set the controls from the button array.
virtual BOOL | LoadToolBar (UINT nIDResource, BOOL bLoadIcons=TRUE)
Call this member function to load the toolbar specified by nIDResource.
void | SetIconSize (CSize size)
Call this function to set the size of the actual bitmapped images to be added to a toolbar.
virtual CSize | GetIconSize () const
Call this member function to get the size of the toolbar icon.
CSize | GetLargeIconSize (BOOL bAutoSize) const
Call this method to get the large icon size of the toolbar.
void | SetButtonSize (CSize size)
Sets the size of the buttons in the command bar.
virtual CSize | GetButtonSize () const
Call this function to get the size of the command bar button.
void | ShowTextBelowIcons (BOOL bTextBelow=TRUE)
Call this member to show the caption below control's icon.
BOOL | IsTextBelowIcons () const
Checks whether the caption is below the control's icon.
HWND | GetTrackFocus () const
Call this method to retrieve the current focused control.
void | SetTrackFocus (HWND hwnd)
Call this method to set focus to the window.
virtual void | SetVisible (BOOL bVisible)
Call this method to set the visibility state of the control.
virtual BOOL | SetPosition (XTPBarPosition barPosition)
Call this member function to set the position of the command bar.
int | FindAccel (TCHAR chAccel) const
Call this method to get the index of the control with the specified accelerator character.
int | FindAccelEx (UINT chAccel, BOOL &bSelectOnly) const
Call this method to get the index of the control with the specified accelerator character.
BOOL | IsCustomizeMode () const
Call this method to check if the command bars are in customize mode.
virtual DROPEFFECT | OnCustomizeDragEnter (CXTPControl *pDataObject, CPoint point)
This member is called when a control is entered into the command bar.
virtual void | OnCustomizeDragLeave ()
This method is called when a control leaves the command bar.
virtual DROPEFFECT | OnCustomizeDragOver (CXTPControl *pDataObject, CPoint point)
This member is called when control is over the command bar.
virtual void | OnCustomizeDrop (CXTPControl *pDataObject, DROPEFFECT &dropEffect, CPoint ptDrop, CPoint ptDrag)
This method is called when a control is dropped to the command bar.
virtual BOOL | IsCustomizable () const
Call this method to check if the command bar is customizable.
BOOL | IsCustomizeDialogPresent () const
Call this method to check if the command bar is present in Customize dialog.
void | EnableCustomization (BOOL bEnable=TRUE)
Call this method to enable/disable customization of the command bar.
virtual void | OnTrackLost ()
Call this method to remove the tracking state of the command bar.
virtual void | OnTrackEnter ()
Call this method to track the command bar.
CWnd * | GetOwnerSite () const
Call this method to retrieve the owner window of the command bar.
void | InvalidateParents ()
Call this method to redraw all parent command bars.
DWORD | GetFlags () const
Call this method to retrieve the current behavior modification flags of the command bar.
UINT | GetBarID () const
Call this method to retrieve the identifier of the command bar.
void | SetBarID (UINT nID)
Call this method to set the identifier of the command bar.
virtual void | OnControlSelected (BOOL bSelected, CXTPControl *pControl)
This method is called when a child control becomes selected.
BOOL | SetStatusText (const CString &strDescription)
This method is called to set the description context.
void | SetCommandBarData (DWORD_PTR dwData)
This method sets the 32-bit value associated with the command bar.
DWORD_PTR | GetCommandBarData () const
This method retrieves the application-supplied, 32-bit value associated with the command bar.
CXTPCommandBar * | GetRootParent () const
Call this method to retrieve the top-level parent command bar.
CXTPPaintManager * | GetPaintManager () const
Call this method to retrieve the paint manager.
CXTPImageManager * | GetImageManager () const
Call this method to retrieve the image manager.
void | SetWidth (int nWidth)
Call this member to set the width of the floated or pop-up toolbar.
int | GetWidth () const
Call this member to get the width of the floated or pop-up toolbar.
void | SetPaintManager (CXTPPaintManager *pPaintManager)
Call this member to set the specified paint manager.
void | SetImageManager (CXTPImageManager *pImageManager)
Call this member to set the specified image manager.
BOOL | IsLayoutRTL () const
Call this member function to determine if the command bar layout is Right-to-Left (RTL).
virtual BOOL | IsDialogBar () const
Call this member function to determine if the command bar is a CXTPDialogBar.
virtual BOOL | IsRibbonBar () const
Call this member function to determine if the command bar is a CXTPRibbonBar.
virtual BOOL | IsMenuTitleBar () const
Call this member function to determine if the command bar is a CXTPMenuTitleBar.
virtual BOOL | IsKeyboardCuesVisible () const
Determines if underlines are visible in the command bar control.
void | SetGrabFocus (BOOL bGrabFocus)
This method is called internally to prevent the command bar from grabbing edit focus.
virtual void | Redraw (LPCRECT lpRect=0, BOOL bAnimate=TRUE)
The framework calls this member function to redraw the command bar.
void | EnableAnimation (BOOL bEnable=TRUE)
Call this method to enable animation for the command bar.
void | EnableDoubleBuffer (BOOL bEnable=TRUE)
Call this method to enable double buffer for toolbar drawing.
BOOL | IsAnimationEnabled () const
Determines if animation is enabled for the specified command bar.
virtual int | OnHookMessage (HWND hWnd, UINT nMessage, WPARAM &wParam, LPARAM &lParam, LRESULT &lResult)
This member function is called by WindowProc, or is called during message reflection.
virtual void | EnsureVisible (CXTPControl *pControl)
Call this method to ensure that a specified control is visible on the toolbar.
XTPButtonStyle | GetDefaultButtonStyle () const
Call this method to retrieve the default button style of the command bar.
void | SetDefaultButtonStyle (XTPButtonStyle buttonStyle)
Call this method to set the default button style of the command bar.
void | LockRedraw ()
Call this method to freeze redrawing until UnlockRedraw is called.
void | UnlockRedraw ()
Call this method to unfreeze redrawing.
void | SetShowGripper (BOOL bShow)
Call this method to set the visibility of the command bar's gripper.
BOOL | GetShowGripper () const
Call this method to check if the command bar's gripper is visible.
virtual void | FillCommandBarEntry (CDC *pDC)
This method is called to draw the background of the command bar.
BOOL | IsKeyboardTipsVisible () const
Call this method to check if keyboard tips are visible for the command bar.
virtual void | CreateKeyboardTips ()
This method is called to create a keyboard tips collection for the command bar.
void | OnKeyboardTipChar (UINT chAccel)
This method is called when the user presses a key while keyboard tips are visible.
virtual void | OnKeyboardTip (CXTPCommandBarKeyboardTip *pTip)
This method is called when a keyboard tip is found for the command bar.
void | HideKeyboardTips ()
Call this method to hide keyboard tips.
void | LockMouseMove (CXTPControl *pControl)
Locks the mouse cursor for a specified control.
void | UnlockMouseMove ()
Unlocks the mouse cursor.
- Public Member Functions inherited from CXTPHookManagerHookAble
CXTPHookManagerHookAble ()
Constructs a CXTPHookManagerHookAble object.
virtual | ~CXTPHookManagerHookAble ()
Destroys a CXTPHookManagerHookAble object, handles cleanup and deallocation.
virtual int | OnPostHookMessage (HWND hWnd, UINT nMessage, WPARAM &wParam, LPARAM &lParam, LRESULT &lResult)
This member function is called after a message has been processed by default window procedure.
virtual void | OnHookAttached (HWND hWnd)
This member function is called right after a hook is attached to the window.
virtual void | OnHookDetached ()
This member function is called right before a hook is to be detached from the window.

Protected Member Functions

virtual CSize | CalcDynamicLayout (int nLength, DWORD dwMode)
This method is called to get the size of the command bar.
virtual void | AdjustExcludeRect (CRect &rc, BOOL bVertical)
Updates rectangle to set the position where the pop-up bar becomes visible.
- Protected Member Functions inherited from CXTPPopupBar
CXTPPopupBar ()
Constructs a CXTPPopupBar object.
virtual | ~CXTPPopupBar ()
Destroys a CXTPPopupBar object, handles cleanup and deallocation.
virtual void | DelayRedraw ()
Redraw the pop-up bar.
virtual BOOL | SetSelected (int nSelected, BOOL bKeyboard=FALSE)
Call this member to select the specified control.
void | UpdateLocation (CSize sz)
This method sets the pop-up bar's position.
virtual void | UpdateFlags ()
Update flags.
void | UpdateExpandingState ()
Update expanding state.
virtual void | DrawCommandBar (CDC *pDC, CRect rcClipBox)
This method is called to draw the command bar in the given context.
virtual void | OnControlsChanged ()
This method is called when the controls array is changed.
virtual void | OnRecalcLayout ()
This method is called to recalculate the command bar layout.
CXTPCommandBar * | GetParentCommandBar () const
Call this member to retrieve the parent command bar.
virtual void | DoPropExchange (CXTPPropExchange *pPX)
Either reads this object from or writes this object to an archive.
virtual void | Copy (CXTPCommandBar *pCommandBar, BOOL bRecursive=FALSE)
Call this method make a copy of the command bar.
virtual BOOL | OnHookKeyDown (UINT nChar, LPARAM lParam)
The framework calls this member function when a non-system key is pressed.
virtual void | Animate ()
Animates pop-up window.
- Protected Member Functions inherited from CXTPCommandBar
CXTPCommandBar ()
Constructs a CXTPCommandBar object.
virtual | ~CXTPCommandBar ()
Destroys a CXTPCommandBar object, handles cleanup and deallocation.
virtual BOOL | ProcessSpecialKey (XTPSpecialKey key)
This method is called to process special keys.
virtual int | OnMouseHitTest (CPoint pt)
This method is called to determine mouse hit code.
virtual void | UpdateShortcuts ()
Updates the control's shortcuts.
UINT | GetActiveDocTemplate () const
Retrieves the active MDI document template.
virtual void | GenerateCommandBarList (DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam)
This method is called to assign self identifiers for the serialization process.
virtual void | RestoreCommandBarList (CXTPCommandBarList *pCommandBarList)
This method is called in the serialization process to restore pop-ups from a list of command bars.
BOOL | IsHelpMode () const
Determines if the parent frame is in help mode.
virtual void | OnRemoved ()
This method is called when a toolbar is removed from the command bars collection.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPPopupBar
static CXTPPopupBar *AFX_CDECL | CreatePopupBar (CXTPCommandBars *pCommandBars)
Creates a pop-up bar object.
- Public Attributes inherited from CXTPCommandBar
int | m_nStateFlags
State of the command bars.
BOOL | m_bComboBar
TRUE if it is combobox list.
BOOL | m_bTrackOnHover
TRUE to select item if mouse stay over control.
- Public Attributes inherited from CXTPHookManagerHookAble
BOOL | m_bAutoDestroy
TRUE to automatically delete hook.
- Static Public Attributes inherited from CXTPPopupBar
static double | m_dMaxWidthDivisor
Maximum available width of pop-up.
- Static Public Attributes inherited from CXTPCommandBar
static int | s_nHoverDelay
Hover delay time.
static int | s_nExpandDelay
Expand delay time.
static int | s_nExpandHoverDelay
Expand hover delay.
- Protected Attributes inherited from CXTPPopupBar
CXTPControlPopup * | m_pControlPopup
Control that pop-up'ed the bar.
CPoint | m_ptPopup
Position of the bar.
CRect | m_rcExclude
Excluded area.
DWORD | m_popupFlags
Flags of the bar.
BOOL | m_bDynamicLayout
TRUE if DynamicLayout routine executed.
BOOL | m_bCollapsed
TRUE if pop-up bar is collapsed.
BOOL | m_bExpanded
TRUE if pop-up bar is expanded.
BOOL | m_bExpanding
TRUE if pop-up bar is expanding.
BOOL | m_bTearOffPopup
TRUE if pop-up bar has tear-off option.
CRect | m_rcTearOffGripper
Tear-off gripper position.
CRect | m_rcResizeGripper
Resizable gripper position.
BOOL | m_bResizable
TRUE to allow resize.
BOOL | m_bTearOffSelected
TRUE if gripper selected.
UINT_PTR | m_nTearOffTimer
Tear-off timer.
BOOL | m_bTearOffTracking
Tear-off tracking mode.
CSize | m_szTearOffBar
Size of the bar.
CXTPToolBar * | m_pTearOffBar
Tear-off toolbar pointer.
CString | m_strTearOffCaption
Caption of the Tear-off toolbar.
UINT | m_nTearOffID
ID of the Tear-off toolbar.
int | m_nTearOffWidth
Width of the Tear-off toolbar.
BOOL | m_bShowShadow
TRUE to show the shadow.
CRect | m_rcBorders
Borders of the bar.
BOOL | m_bDoubleGripper
TRUE if pop-up is state pop-up type.
BOOL | m_bContextMenu
TRUE if pop-up bar is context menu.
int | m_nMaxHeight
Maximum height the pop-up bar can become.
- Protected Attributes inherited from CXTPCommandBar
BOOL | m_bGrabFocus
TRUE to grab current focus.
int | m_nMRUWidth
Recent width.
int | m_nSelected
Selected control index.
int | m_nPopuped
Pop-up'ed control index.
HWND | m_hwndFocus
The handle of the window that currently has focus.
UINT | m_nBarID
Command bar's identifier.
BOOL | m_bTracking
TRUE if the command bar is in tracking mode.
CWnd * | m_pSite
Command bar's site.
DWORD | m_nIdleFlags
Idle flags.
DWORD | m_dwFlags
Command bar's flags.
DWORD | m_dwStyle
Command bar's styles.
CString | m_strTitle
Command bar's caption.
XTPBarType | m_barType
Type of the command bar.
CXTPControls * | m_pControls
A pointer to controls collection.
XTPBarPosition | m_barPosition
Position of the command bar.
CXTPCommandBars * | m_pCommandBars
parent command bars class.
CWnd * | m_pOwner
Owner window.
CSize | m_szIcons
Size of the command bar's icons.
CSize | m_szButtons
Size of the command bar's buttons.
BOOL | m_bTextBelow
TRUE if text is shown below the CommandBar buttons.
BOOL | m_bExecOnRButton
TRUE if the control button is executed on a right-click.
BOOL | m_bIgnoreUpdateHandler
TRUE to skip update handler for all child controls.
BOOL | m_bRecursePopup
TRUE if pop-up bar was opened recursively.
BOOL | m_bKeyboardSelect
TRUE if last item was selected by keyboard.
BOOL | m_bCloseable
TRUE if the CommandBar can be closed and-or Hidden.
BOOL | m_bCustomizable
TRUE if command bar is customizable.
CRect | m_rcMarker
Marker position.
BOOL | m_bVerticalMarker
TRUE to draw marker vertically.
DWORD_PTR | m_dwData
The 32-bit value associated with the command bar.
UINT * | m_pReturnCmd
Return command holder.
BOOL | m_bCustomizeDialogPresent
TRUE if the command bar is present in Customize dialog.
BOOL | m_bAnimatePopup
TRUE to animate pop-up bar.
BOOL | m_nLockRedraw
TRUE if all drawing routines skipped.
CXTPPaintManager * | m_pPaintManager
Selected paint manager for command bar.
CXTPImageManager * | m_pImageManager
Selected image manager for command bar.
BOOL | m_bMultiLine
True if multi line commandbar.
XTPButtonStyle | m_buttonStyle
Default button Style.
XTPBarTextOrientation | m_nTextOrientation
Commandbar text orientation.
CXTPToolTipContext * | m_pToolTipContext
Tool tip Context.
CXTPCommandBarAnimation * | m_pAnimation
Animation context.
CSize | m_szButtonSpacing
Spacing used between toolbar buttons.

Detailed Description

CXTPRibbonSystemPopupBarPage is a CXTPPopupBar derived class used as a system pop-up bar page of a Ribbon Bar.

Member Function Documentation

◆ AdjustExcludeRect()

virtual void AdjustExcludeRect | ( | CRect & | rc,
 |  | BOOL | bVertical )
 protectedvirtual

Updates rectangle to set the position where the pop-up bar becomes visible.

Parameters
rc | CRect object specifying the size of the area.
bVertical | TRUE if vertical, FALSE otherwise.

Reimplemented from CXTPPopupBar.

◆ CalcDynamicLayout()

virtual CSize CalcDynamicLayout | ( | int | nLength,
 |  | DWORD | dwMode )
 protectedvirtual

This method is called to get the size of the command bar.

Parameters
nLength | The requested dimension of the control bar, either horizontal or vertical depending on dwMode.
dwMode | See CControlBar::CalcDynamicLayout for the list of supported flags.
Returns
The size of the command bar.

Reimplemented from CXTPPopupBar.

The documentation for this class was generated from the following file:
  • XTPRibbonSystemButton.h


Toolkit Pro: CXTPRibbonTab Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPRibbonTab Class Reference

Represents a tab in the Ribbon Bar. More...

Inheritance diagram for CXTPRibbonTab:
[legend]

Public Member Functions

CXTPRibbonTab ()
Constructs a CXTPRibbonTab object.
virtual | ~CXTPRibbonTab ()
Destroys a CXTPRibbonTab object, handles cleanup and deallocation.
CXTPRibbonGroups * | GetGroups () const
Gets the collection of CXTPRibbonGroup objects that have been added to the CXTPRibbonTab.
CXTPRibbonBar * | GetRibbonBar () const
Gets the CXTPRibbonBar object that the CXTPRibbonTab belongs to.
CXTPCommandBar * | GetParent () const
Gets the parent command bar.
virtual CString | GetCaption () const
Gets the text caption of the tab.
virtual void | Copy (CXTPRibbonTab *pRibbonTab)
Copies the tab.
CXTPRibbonGroup * | AddGroup (LPCTSTR lpszCaption)
Adds a CXTPRibbonGroup to a CXTPRibbonTab.
CXTPRibbonGroup * | AddGroup (int nID)
Adds a CXTPRibbonGroup to a CXTPRibbonTab.
CXTPRibbonGroup * | FindGroup (int nId) const
Retrieves a group by its identifier.
XTPRibbonTabContextColor | GetContextColor () const
Gets the tab color.
void | SetContextColor (XTPRibbonTabContextColor color)
Sets the tab color.
CString | GetContextCaption () const
Gets the context tab header text.
void | SetContextCaption (LPCTSTR lpszContextCaption)
Sets the context tab header text.
CString | GetCustomizeCaption () const
Gets the customize dialog specific tab text.
void | SetCustomizeCaption (LPCTSTR lpszCustomizeCaption)
Sets the customize dialog specific tab text.
void | SetCustomizeCaption (UINT nCustomizeCaption)
Sets the customize dialog specific tab text.
void | SetContextTab (XTPRibbonTabContextColor color, int nContextID)
Sets the context tab color and text.
void | SetContextTab (XTPRibbonTabContextColor color, LPCTSTR lpszContextCaption=NULL)
Sets the context tab color and text.
int | GetID () const
Gets the tab's ID.
void | SetID (int nId)
Sets the tab's ID.
CXTPRibbonTabContextHeader * | GetContextHeader () const
Gets the CXTPRibbonTabContextHeader associated with the tab.
virtual void | SetVisible (BOOL bVisible)
Call this member to show/hide the tab.
virtual void | DoPropExchange (CXTPPropExchange *pPX)
Reads/writes this object from/to an archive.
void | SetKeyboardTip (LPCTSTR lpszKeyboardTip)
Sets the keyboard tip for the control.
CString | GetKeyboardTip () const
Gets the keyboard tip of the control.
- Public Member Functions inherited from CXTPTabManagerItem
void | SetCaption (LPCTSTR lpszCaption)
Sets the text caption for this tab.
void | SetTooltip (LPCTSTR lpszTooltip)
Sets the tooltip for this tab.
CString | GetTooltip () const
Gets the tooltip of this tab.
COLORREF | GetColor ()
Gets the color of the tab button.
void | SetColor (COLORREF clr)
Sets the color for the tab button.
CRect | GetRect () const
Gets the bounding rectangle of the tab button.
int | GetButtonLength () const
Gets the width of the tab button.
int | GetContentLength () const
Gets the width of the content of the tab button.
int | GetIndex () const
Gets the index of this tab within the collection of tabs.
int | GetImageIndex () const
Gets the index of the image displayed in the tab button.
void | SetImageIndex (int nImage)
Sets the index for the image displayed in the tab button.
DWORD_PTR | GetData () const
Gets the application-supplied, 32-bit value associated with the tab item.
void | SetData (DWORD_PTR dwData)
Sets the 32-bit value associated with the tab item.
void | SetHandle (HWND hWnd)
Sets the handle for the object displayed in the tab client area when this tab is selected.
HWND | GetHandle () const
Gets the handle of the object displayed in the tab client area when this tab is selected.
void | SetRect (CRect rcItem)
Sets the bounding rectangle for this tab.
BOOL | IsVisible () const
Determines if this tab is shown/hidden.
BOOL | IsEnabled () const
Determines if this tab is enabled/disabled.
void | SetEnabled (BOOL bEnabled)
Enables/disables this tab.
int | GetItemRow () const
Gets the row of this item.
BOOL | IsItemShrinked () const
Determines if this item has shrinked.
CXTPTabManagerNavigateButtons * GetNavigateButtons ()
Gets the collection of navigate buttons.
BOOL | IsSelected () const
Determines the selected state of this tab (i.e.
BOOL | IsFocused () const
Determines the focused state of this tab.
BOOL | IsHighlighted () const
Determines the highlighted state of this tab.
BOOL | IsPressed () const
Determines the pressed state of this tab.
void | Remove ()
Deletes this tab.
void | Select ()
Selects this tab.
void | Move (int nIndex)
Sets the position for this item.
BOOL | IsClosable () const
Determines if this tab is closable.
void | SetClosable (BOOL bClosable)
Specifies if this tab should be closable.
CXTPMarkupUIElement * | GetMarkupUIElement () const
Gets the Markup element used to render the caption of this tab.
BOOL | IsNewWindowTab ()
Determines if this tab is new window.
void | SetNewWindowTab ()
Specifies if this tab is new window.
CXTPTabManager * | GetTabManager () const
Gets the tab manager.
void | DrawImage (CDC *pDC, CRect rcIcon, CXTPImageManagerIcon *pImage)
Draws the icon of a tab.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

void | OnRemoved ()
This method is called before removing a tab from the ribbon tabs collection.
BOOL | OnCmdMsg (UINT nID, int nCode, void *pExtra, AFX_CMDHANDLERINFO *pHandlerInfo)
Called by the framework to route and dispatch command messages and to handle the update of command user-interface objects.
- Protected Member Functions inherited from CXTPTabManagerItem
CXTPTabManagerItem ()
Constructs a CXTPTabManagerItem object.
virtual | ~CXTPTabManagerItem ()
Destroys a CXTPTabManagerItem object, handles cleanup and deallocation.
void | Reposition ()
Updates the position of the tab manager.

Protected Attributes

CXTPRibbonGroups * | m_pGroups
Collection of CXTPRibbonGroup objects that have been added to the CXTPRibbonTab.
CXTPRibbonBar * | m_pRibbonBar
The CXTPRibbonBar object the CXTPRibbonTab belongs to.
CXTPCommandBar * | m_pParent
This is the ribbon bar that the tab is displayed in.
int | m_nId
Identifier of the tab.
XTPRibbonTabContextColor | m_nContextColor
Context color.
CString | m_strContextCaption
Context caption.
CString | m_strCustomizeCaption
Caption used by Customize dialog.
CXTPRibbonTabContextHeader * | m_pContextHeader
Context header.
CString | m_strKeyboardTip
Keyboard tip.
- Protected Attributes inherited from CXTPTabManagerItem
int | m_nButtonLength
Width of the tab button.
int | m_nContentLength
Width of the content of the tab button.
int | m_nImage
Image index; this is the index of the image within a CXTPImageManger or CImageList object.
int | m_nIndex
Index of this tab within the collection of tabs.
BOOL | m_bEnabled
TRUE if this tab is enabled.
BOOL | m_bVisible
TRUE if this tab is visible.
HWND | m_hWnd
CWnd pointer to the window associated with this tab.
HICON | m_hIcon
Icon associated with this tab.
DWORD_PTR | m_dwData
Developer specific data.
CRect | m_rcItem
Rectangle of this tab.
CString | m_strCaption
User specified label for this tab.
CString | m_strToolTip
Tooltip text for this tab.
COLORREF | m_clrItem
Color of the tab button.
CXTPTabManager * | m_pTabManager
Pointer to the parent item.
int | m_nItemRow
Row of this item.
BOOL | m_bClosable
TRUE if this item can be closed.
BOOL | m_bNewWindowTab
TRUE if this item is new window tab.
CXTPTabManagerNavigateButtons | m_arrNavigateButtons
Array of navigate buttons.
CXTPMarkupUIElement * | m_pMarkupUIElement
Markup element pointer.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

Represents a tab in the Ribbon Bar.

Tabs in the ribbon bar are used to display different groups of items. The CXTPRibbonBar.InsertTab method adds a new CXTPRibbonTab object to the tabs collection of the ribbon bar.

Tabs in the ribbon bar contain one or more CXTPRibbonGroup objects. Buttons, pop-ups, etc. can then be added to the groups.

The CXTPRibbonBar::GetTabCount property can be used to determine the total number of tabs that have been added.

See also
CXTPRibbonBar.InsertTab, CXTPRibbonBar::GetTabCount, CXTPRibbonBar::GetTab

Member Function Documentation

◆ AddGroup() [1/2]

CXTPRibbonGroup * AddGroup ( int nID )

Adds a CXTPRibbonGroup to a CXTPRibbonTab.

Parameters
nID Identifier of the group.
Returns
A pointer to the CXTPRibbonGroup object added to the CXTPRibbonTab's groups collection (CXTPRibbonTab::GetGroups).
See also
CXTPRibbonGroup::SetCaption, CXTPRibbonGroup::SetCaption, CXTPRibbonTab, CXTPRibbonTab::GetGroups

◆ AddGroup() [2/2]

CXTPRibbonGroup * AddGroup ( LPCTSTR lpszCaption )

Adds a CXTPRibbonGroup to a CXTPRibbonTab.

Parameters
lpszCaption Text to display in the group's title bar. This is the group's caption.
Returns
A pointer to the CXTPRibbonGroup object added to the CXTPRibbonTab's groups collection (CXTPRibbonTab::GetGroups).
See also
CXTPRibbonGroup::SetCaption, CXTPRibbonGroup::SetCaption, CXTPRibbonTab, CXTPRibbonTab::GetGroups

◆ Copy()

virtual void Copy ( CXTPRibbonTab * pRibbonTab )
virtual

Copies the tab.

Parameters
pRibbonTab Pointer to a source CXTPRibbonTab object.

◆ DoPropExchange()

virtual void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Reads/writes this object from/to an archive.

Parameters
pPX Pointer to a CXTPPropExchange object to serialize to/from.

◆ FindGroup()

CXTPRibbonGroup * FindGroup ( int nId ) const

Retrieves a group by its identifier.

Parameters
nId Identifier of the group to be retrieved.
Returns
A pointer to the CXTPRibbonGroup object with the specified identifier.
See also
FindTab

◆ GetCaption()

virtual CString GetCaption ( ) const
virtual

Gets the text caption of the tab.

Returns
The text caption of the tab. This is the text displayed in the tab button.
See also
SetCaption

Reimplemented from CXTPTabManagerItem.

◆ GetContextCaption()

AFX_INLINE CString GetContextCaption ( ) const

Gets the context tab header text.

Returns
The context tab header text.
See also
SetContextCaption, SetContextColor

◆ GetContextColor()

AFX_INLINE XTPRibbonTabContextColor GetContextColor ( ) const

Gets the tab color.

Returns
The tab color; one of the values defined by the XTPRibbonTabContextColor enumeration.
See also
XTPRibbonTabContextColor

◆ GetContextHeader()

AFX_INLINE CXTPRibbonTabContextHeader * GetContextHeader ( ) const

Gets the CXTPRibbonTabContextHeader associated with the tab.

Returns
A pointer to the CXTPRibbonTabContextHeader associated with the tab.

◆ GetCustomizeCaption()

AFX_INLINE CString GetCustomizeCaption ( ) const

Gets the customize dialog specific tab text.

Returns
The customize dialog specific tab text.
See also
GetCaption, SetCaption

◆ GetGroups()

AFX_INLINE CXTPRibbonGroups * GetGroups ( ) const

Gets the collection of CXTPRibbonGroup objects that have been added to the CXTPRibbonTab.

A CXTPRibbonGroup is used to hold buttons, pop-ups, edit controls, combo box controls, etc. The group organizes the different types of controls in a CXTPRibbonTab so it is easy to see what functionality the controls should perform. Groups are added to the group collection using the AddGroup and InsertGroup methods. Groups will be displayed in the order they are added. This means the group with an index of zero (0) will be displayed first to the far left, then to the immediate right will be the group with an index of one (1), and so on.

Returns
A pointer to the collection of CXTPRibbonGroup objects that have been added to the CXTPRibbonTab.
See also
CXTPRibbonGroups::GetAt, CXTPRibbonGroups::InsertAt, CXTPRibbonGroups::Add, CXTPRibbonGroups.GetCount

◆ GetID()

AFX_INLINE int GetID ( ) const

Gets the tab's ID.

The ID is used to identify the tab.

Returns
The tab's ID.
See also
SetID

◆ GetKeyboardTip()

AFX_INLINE CString GetKeyboardTip ( ) const

Gets the keyboard tip of the control.

Returns
The keyboard tip of the control.

◆ GetParent()

AFX_INLINE CXTPCommandBar * GetParent ( ) const

Gets the parent command bar.

Returns
A pointer to the parent CXTPCommandBar object.

◆ GetRibbonBar()

CXTPRibbonBar * GetRibbonBar ( ) const

Gets the CXTPRibbonBar object that the CXTPRibbonTab belongs to.

Returns
A pointer to the CXTPRibbonBar object that the CXTPRibbonTab belongs to. This is the RibbonBar that the tab is displayed in.
See also
CXTPRibbonBar

◆ OnCmdMsg()

BOOL OnCmdMsg | ( | UINT | nID,
 |  | int | nCode,
 |  | void * | pExtra,
 |  | AFX_CMDHANDLERINFO * | pHandlerInfo )
 protected

Called by the framework to route and dispatch command messages and to handle the update of command user-interface objects.

Parameters
nID | Command ID.
nCode | Command notification code.
pExtra | Used according to the value of nCode.
pHandlerInfo | If not NULL, then OnCmdMsg fills in the pTarget and pmf members of the pHandlerInfo structure instead of dispatching the command. Typically, this parameter should be NULL.
Returns
Nonzero if the message is handled, otherwise 0.

◆ SetContextCaption()

AFX_INLINE void SetContextCaption ( LPCTSTR lpszContextCaption )

Sets the context tab header text.

Parameters
lpszContextCaption New text to be set.
See also
GetContextCaption

◆ SetContextColor()

AFX_INLINE void SetContextColor ( XTPRibbonTabContextColor color )

Sets the tab color.

Parameters
color New tab color; must be one of the values defined by the XTPRibbonTabContextColor enumeration.
See also
XTPRibbonTabContextColor

◆ SetContextTab() [1/2]

void SetContextTab | ( | XTPRibbonTabContextColor | color,
 |  | int | nContextID )

Sets the context tab color and text.

Parameters
color | New color to be set.
nContextID | Resource ID of the new text to be set.
See also
GetContextCaption, GetContextColor

◆ SetContextTab() [2/2]

AFX_INLINE void SetContextTab | ( | XTPRibbonTabContextColor | color,
 |  | LPCTSTR | lpszContextCaption = NULL )

Sets the context tab color and text.

Parameters
color | New color to be set.
lpszContextCaption | New text to be set.
See also
GetContextCaption, GetContextColor

◆ SetCustomizeCaption() [1/2]

AFX_INLINE void SetCustomizeCaption ( LPCTSTR lpszCustomizeCaption )

Sets the customize dialog specific tab text.

Parameters
lpszCustomizeCaption New text to be set.
See also
GetCaption, SetCaption

◆ SetCustomizeCaption() [2/2]

void SetCustomizeCaption ( UINT nCustomizeCaption )

Sets the customize dialog specific tab text.

Parameters
nCustomizeCaption Resource ID of the new text to be set.
See also
GetCaption, SetCaption

◆ SetID()

AFX_INLINE void SetID ( int nId )

Sets the tab's ID.

Parameters
nId New ID to be set.
See also
GetID

◆ SetKeyboardTip()

AFX_INLINE void SetKeyboardTip ( LPCTSTR lpszKeyboardTip )

Sets the keyboard tip for the control.

Parameters
lpszKeyboardTip New keyboard tip to be set.

◆ SetVisible()

virtual void SetVisible ( BOOL bVisible )
virtual

Call this member to show/hide the tab.

Parameters
bVisible TRUE to show the tab, FALSE to hide the tab.
See also
IsVisible

Reimplemented from CXTPTabManagerItem.

Member Data Documentation

◆ m_strCustomizeCaption

CString m_strCustomizeCaption
protected

Caption used by Customize dialog.

If empty, a default caption is displayed.

The documentation for this class was generated from the following file:
  • XTPRibbonTab.h


Toolkit Pro: CXTPRibbonTabPopupToolBar Class Reference

Public Member Functions | Public Attributes | Protected Member Functions | List of all members
CXTPRibbonTabPopupToolBar Class Reference

Implements a pop-up when the Ribbon is in minimzed mode. More...

Inheritance diagram for CXTPRibbonTabPopupToolBar:
[legend]

Public Member Functions

CXTPRibbonTabPopupToolBar (CXTPRibbonTab *pRibbonTab)
Constructs a CXTPRibbonTabPopupToolBar object.
~CXTPRibbonTabPopupToolBar ()
Destroys a CXTPRibbonTabPopupToolBar object, handles cleanup and deallocation.
CRect | GetGroupsRect () const
Retrieves the groups bounding rectangle.
void | OnGroupsScroll (BOOL bScrollLeft)
The framework calls this member function when the group pop-up is scrolled.
void | EnsureVisible (CXTPControl *pControl)
Call this method to make sure that a control is visible on the ribbon bar.
void | CreateKeyboardTips ()
This method is called to create a keyboard tips collection for the ribbon.
CSize | CalcDynamicLayout (int nLength, DWORD nMode)
This method is called to get the size of the command bar.
void | DrawCommandBar (CDC *pDC, CRect rcClipBox)
This method is called to draw the command bar in the given context.
virtual CSize | GetButtonSize () const
Call this function to get the size of the command bar button.
virtual CSize | GetIconSize () const
Call this member function to get the size of the icon for a minimized group.
virtual CRect | CalculatePopupRect (CPoint ptPopup, CSize sz)
This method is called to calculate the destination rectangle of the pop-up bar.
CXTPRibbonGroup * | HitTestGroup (CPoint point) const
This member function determines which ribbon group, if any, is at a specified position.
virtual BOOL | SetTrackingMode (int bMode, BOOL bSelectFirst=TRUE, BOOL bKeyboard=FALSE)
Call this member to change the tracking state.
void | OnKeyboardTip (CXTPCommandBarKeyboardTip *pTip)
This method is called when a keyboard tip is found for the command bar.
BOOL | IsKeyboardCuesVisible () const
Call this method to determine if keyboard cues are visible.
INT_PTR | OnToolHitTest (CPoint point, TOOLINFO *pTI) const
The framework calls this member function to determine whether a point is in the bounding rectangle of the specified tool.
- Public Member Functions inherited from CXTPPopupBar
void | SetTearOffPopup (LPCTSTR lpszCaption, UINT nID, int nWidth=400)
This method adds the tear-off state to the pop-up bar.
BOOL | IsTearOffPopup (CString &strCaption, UINT &nID, int &nWidth)
Determines if the pop-up bar has the tear-off state.
virtual BOOL | IsVisible () const
Call this member to determine if the pop-up menu is visible/displayed.
BOOL | Popup (int xPos, int yPos, LPCRECT rcExclude)
This method opens the pop-up bar.
BOOL | Popup (CXTPControlPopup *pControlPopup, BOOL bSelectFirst=FALSE)
This method opens the pop-up bar.
CXTPControlPopup * | GetControlPopup () const
Call this member to retrieve the control's pop-up.
void | ExpandBar ()
This method expands the bar.
BOOL | DestroyWindow ()
Call this member to destroy the window.
void | SetPopupToolBar (BOOL bToolBarType)
Call this method to make the pop-up bar look like a pop-up toolbar.
void | SetDefaultItem (UINT uItem, BOOL fByPos=FALSE)
Sets the default menu item for the specified pop-up bar.
UINT | GetDefaultItem (UINT gmdiFlags, BOOL fByPos=FALSE)
Determines the default menu item on the specified pop-up bar.
BOOL | IsDoubleGripper () const
Call this method to determine if the pop-up bar has a double gripper.
void | SetDoubleGripper (BOOL bDoubleGripper=TRUE)
Call this member to set a double gripper for the pop-up bar.
virtual BOOL | IsPopupBar () const
Call this member function to determine if the command bar is a CXTPPopupBar.
BOOL | IsContextMenu () const
Determines if the pop-up bar is a context menu.
void | PumpMessage ()
Translates all messages in the message queue.
virtual BOOL | Create ()
Creates the pop-up bar.
void | SetPopupFlags (DWORD dwPopupFlags)
Call this method to set the pop-up direction.
void | SetBorders (CRect rcBorders)
Sets the toolbar's borders.
void | DisableShadow ()
Disables shadow use.
BOOL | IsResizable () const
Determines if the control can be resized by the user.
virtual CRect | GetBorders ()
Call this method to get the border margins of the command bar.
- Public Member Functions inherited from CXTPCommandBar
int | IsTrackingMode () const
Call this member to get the tracking state.
CXTPControls * | GetControls () const
Call this member to get the controls collection.
void | SetControls (CXTPControls *pControls)
Call this member to set the controls collection of the command bar.
XTPBarType | GetType () const
Call this member to get the type of the command bar.
void | SetTextOrientation (XTPBarTextOrientation nTextOrientation)
Call this member to change text orientation.
XTPBarTextOrientation | GetTextOrientation () const
Call this member to get the text orientation.
XTPBarPosition | GetPosition () const
Call this member to get the position of the command bar.
void | DelayLayout ()
Call this member to recalculate the layout.
virtual BOOL | LoadMenu (CMenu *pMenu, BOOL bRemoveControls=TRUE)
Call this member to convert menu items to command bar controls.
CXTPControl * | GetControl (int nIndex) const
Call this member to return the control at the specified index.
int | GetControlCount () const
Call this member to get the count of the controls.
CXTPControl * | GetSelected () const
Call this member to get the currently selected control.
BOOL | SetPopuped (int nPopuped, BOOL bKeyboard=FALSE)
Call this member to pop-up the specified control.
void | SetTitle (LPCTSTR lpszTitle)
Call this member to set a title for this command bar.
CString | GetTitle () const
Call this member to get a title for this command bar.
CXTPCommandBars * | GetCommandBars () const
Call this member to get the command bar's object.
void | SetCommandBars (CXTPCommandBars *pCommandBars)
Call this member to set the command bar's object.
CWnd * | GetSite () const
Call this member to get the command bar's site.
CFrameWnd * | GetFrameSite () const
Call this member to get the command bar's site as CFrameWnd.
void | SetFlags (DWORD dwFlagsAdd, DWORD dwFlagsRemove=0)
Call this member to set the command bar's flags.
BOOL | SetButtons (UINT *pButtons, int nCount)
Call this member to set the controls from the button array.
virtual BOOL | LoadToolBar (UINT nIDResource, BOOL bLoadIcons=TRUE)
Call this member function to load the toolbar specified by nIDResource.
void | SetIconSize (CSize size)
Call this function to set the size of the actual bitmapped images to be added to a toolbar.
CSize | GetLargeIconSize (BOOL bAutoSize) const
Call this method to get the large icon size of the toolbar.
void | SetButtonSize (CSize size)
Sets the size of the buttons in the command bar.
void | ShowTextBelowIcons (BOOL bTextBelow=TRUE)
Call this member to show the caption below control's icon.
BOOL | IsTextBelowIcons () const
Checks whether the caption is below the control's icon.
HWND | GetTrackFocus () const
Call this method to retrieve the current focused control.
void | SetTrackFocus (HWND hwnd)
Call this method to set focus to the window.
virtual void | SetVisible (BOOL bVisible)
Call this method to set the visibility state of the control.
virtual BOOL | SetPosition (XTPBarPosition barPosition)
Call this member function to set the position of the command bar.
int | FindAccel (TCHAR chAccel) const
Call this method to get the index of the control with the specified accelerator character.
int | FindAccelEx (UINT chAccel, BOOL &bSelectOnly) const
Call this method to get the index of the control with the specified accelerator character.
BOOL | IsCustomizeMode () const
Call this method to check if the command bars are in customize mode.
virtual DROPEFFECT | OnCustomizeDragEnter (CXTPControl *pDataObject, CPoint point)
This member is called when a control is entered into the command bar.
virtual void | OnCustomizeDragLeave ()
This method is called when a control leaves the command bar.
virtual DROPEFFECT | OnCustomizeDragOver (CXTPControl *pDataObject, CPoint point)
This member is called when control is over the command bar.
virtual void | OnCustomizeDrop (CXTPControl *pDataObject, DROPEFFECT &dropEffect, CPoint ptDrop, CPoint ptDrag)
This method is called when a control is dropped to the command bar.
virtual BOOL | IsCustomizable () const
Call this method to check if the command bar is customizable.
BOOL | IsCustomizeDialogPresent () const
Call this method to check if the command bar is present in Customize dialog.
void | EnableCustomization (BOOL bEnable=TRUE)
Call this method to enable/disable customization of the command bar.
virtual void | OnTrackLost ()
Call this method to remove the tracking state of the command bar.
virtual void | OnTrackEnter ()
Call this method to track the command bar.
CWnd * | GetOwnerSite () const
Call this method to retrieve the owner window of the command bar.
void | InvalidateParents ()
Call this method to redraw all parent command bars.
DWORD | GetFlags () const
Call this method to retrieve the current behavior modification flags of the command bar.
UINT | GetBarID () const
Call this method to retrieve the identifier of the command bar.
void | SetBarID (UINT nID)
Call this method to set the identifier of the command bar.
virtual void | OnControlSelected (BOOL bSelected, CXTPControl *pControl)
This method is called when a child control becomes selected.
BOOL | SetStatusText (const CString &strDescription)
This method is called to set the description context.
void | SetCommandBarData (DWORD_PTR dwData)
This method sets the 32-bit value associated with the command bar.
DWORD_PTR | GetCommandBarData () const
This method retrieves the application-supplied, 32-bit value associated with the command bar.
CXTPCommandBar * | GetRootParent () const
Call this method to retrieve the top-level parent command bar.
CXTPPaintManager * | GetPaintManager () const
Call this method to retrieve the paint manager.
CXTPImageManager * | GetImageManager () const
Call this method to retrieve the image manager.
void | SetWidth (int nWidth)
Call this member to set the width of the floated or pop-up toolbar.
int | GetWidth () const
Call this member to get the width of the floated or pop-up toolbar.
void | SetPaintManager (CXTPPaintManager *pPaintManager)
Call this member to set the specified paint manager.
void | SetImageManager (CXTPImageManager *pImageManager)
Call this member to set the specified image manager.
BOOL | IsLayoutRTL () const
Call this member function to determine if the command bar layout is Right-to-Left (RTL).
virtual BOOL | IsDialogBar () const
Call this member function to determine if the command bar is a CXTPDialogBar.
virtual BOOL | IsRibbonBar () const
Call this member function to determine if the command bar is a CXTPRibbonBar.
virtual BOOL | IsMenuTitleBar () const
Call this member function to determine if the command bar is a CXTPMenuTitleBar.
void | SetGrabFocus (BOOL bGrabFocus)
This method is called internally to prevent the command bar from grabbing edit focus.
virtual void | Redraw (LPCRECT lpRect=0, BOOL bAnimate=TRUE)
The framework calls this member function to redraw the command bar.
void | EnableAnimation (BOOL bEnable=TRUE)
Call this method to enable animation for the command bar.
void | EnableDoubleBuffer (BOOL bEnable=TRUE)
Call this method to enable double buffer for toolbar drawing.
BOOL | IsAnimationEnabled () const
Determines if animation is enabled for the specified command bar.
virtual int | OnHookMessage (HWND hWnd, UINT nMessage, WPARAM &wParam, LPARAM &lParam, LRESULT &lResult)
This member function is called by WindowProc, or is called during message reflection.
XTPButtonStyle | GetDefaultButtonStyle () const
Call this method to retrieve the default button style of the command bar.
void | SetDefaultButtonStyle (XTPButtonStyle buttonStyle)
Call this method to set the default button style of the command bar.
void | LockRedraw ()
Call this method to freeze redrawing until UnlockRedraw is called.
void | UnlockRedraw ()
Call this method to unfreeze redrawing.
void | SetShowGripper (BOOL bShow)
Call this method to set the visibility of the command bar's gripper.
BOOL | GetShowGripper () const
Call this method to check if the command bar's gripper is visible.
virtual void | FillCommandBarEntry (CDC *pDC)
This method is called to draw the background of the command bar.
BOOL | IsKeyboardTipsVisible () const
Call this method to check if keyboard tips are visible for the command bar.
void | OnKeyboardTipChar (UINT chAccel)
This method is called when the user presses a key while keyboard tips are visible.
void | HideKeyboardTips ()
Call this method to hide keyboard tips.
void | LockMouseMove (CXTPControl *pControl)
Locks the mouse cursor for a specified control.
void | UnlockMouseMove ()
Unlocks the mouse cursor.
- Public Member Functions inherited from CXTPHookManagerHookAble
CXTPHookManagerHookAble ()
Constructs a CXTPHookManagerHookAble object.
virtual | ~CXTPHookManagerHookAble ()
Destroys a CXTPHookManagerHookAble object, handles cleanup and deallocation.
virtual int | OnPostHookMessage (HWND hWnd, UINT nMessage, WPARAM &wParam, LPARAM &lParam, LRESULT &lResult)
This member function is called after a message has been processed by default window procedure.
virtual void | OnHookAttached (HWND hWnd)
This member function is called right after a hook is attached to the window.
virtual void | OnHookDetached ()
This member function is called right before a hook is to be detached from the window.

Public Attributes

CXTPRibbonTab * | m_pRibbonTab
Ribbon bar tab that the group belongs to.
CXTPRibbonBar * | m_pRibbonBar
The CXTPRibbonBar object that the CXTPRibbonTab belongs to.
CRect | m_rcGroups
Groups bounding rectangle.
- Public Attributes inherited from CXTPCommandBar
int | m_nStateFlags
State of the command bars.
BOOL | m_bComboBar
TRUE if it is combobox list.
BOOL | m_bTrackOnHover
TRUE to select item if mouse stay over control.
- Public Attributes inherited from CXTPHookManagerHookAble
BOOL | m_bAutoDestroy
TRUE to automatically delete hook.

Protected Member Functions

virtual BOOL | ProcessSpecialKey (XTPSpecialKey key)
This method is called to process special keys.
- Protected Member Functions inherited from CXTPPopupToolBar
- Protected Member Functions inherited from CXTPPopupBar
CXTPPopupBar ()
Constructs a CXTPPopupBar object.
virtual | ~CXTPPopupBar ()
Destroys a CXTPPopupBar object, handles cleanup and deallocation.
virtual void | DelayRedraw ()
Redraw the pop-up bar.
virtual BOOL | SetSelected (int nSelected, BOOL bKeyboard=FALSE)
Call this member to select the specified control.
void | UpdateLocation (CSize sz)
This method sets the pop-up bar's position.
virtual void | UpdateFlags ()
Update flags.
void | UpdateExpandingState ()
Update expanding state.
virtual void | OnControlsChanged ()
This method is called when the controls array is changed.
virtual void | OnRecalcLayout ()
This method is called to recalculate the command bar layout.
CXTPCommandBar * | GetParentCommandBar () const
Call this member to retrieve the parent command bar.
virtual void | DoPropExchange (CXTPPropExchange *pPX)
Either reads this object from or writes this object to an archive.
virtual void | Copy (CXTPCommandBar *pCommandBar, BOOL bRecursive=FALSE)
Call this method make a copy of the command bar.
virtual BOOL | OnHookKeyDown (UINT nChar, LPARAM lParam)
The framework calls this member function when a non-system key is pressed.
virtual void | AdjustExcludeRect (CRect &rc, BOOL bVertical)
Updates rectangle to set the position where the child pop-up bar becomes visible.
virtual void | Animate ()
Animates pop-up window.
- Protected Member Functions inherited from CXTPCommandBar
CXTPCommandBar ()
Constructs a CXTPCommandBar object.
virtual | ~CXTPCommandBar ()
Destroys a CXTPCommandBar object, handles cleanup and deallocation.
virtual int | OnMouseHitTest (CPoint pt)
This method is called to determine mouse hit code.
virtual void | UpdateShortcuts ()
Updates the control's shortcuts.
UINT | GetActiveDocTemplate () const
Retrieves the active MDI document template.
virtual void | GenerateCommandBarList (DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam)
This method is called to assign self identifiers for the serialization process.
virtual void | RestoreCommandBarList (CXTPCommandBarList *pCommandBarList)
This method is called in the serialization process to restore pop-ups from a list of command bars.
BOOL | IsHelpMode () const
Determines if the parent frame is in help mode.
virtual void | OnRemoved ()
This method is called when a toolbar is removed from the command bars collection.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPPopupToolBar
static CXTPPopupToolBar *AFX_CDECL | CreatePopupToolBar (CXTPCommandBars *pCommandBars)
Creates a pop-up toolbar object.
- Static Public Member Functions inherited from CXTPPopupBar
static CXTPPopupBar *AFX_CDECL | CreatePopupBar (CXTPCommandBars *pCommandBars)
Creates a pop-up bar object.
- Static Public Attributes inherited from CXTPPopupBar
static double | m_dMaxWidthDivisor
Maximum available width of pop-up.
- Static Public Attributes inherited from CXTPCommandBar
static int | s_nHoverDelay
Hover delay time.
static int | s_nExpandDelay
Expand delay time.
static int | s_nExpandHoverDelay
Expand hover delay.
- Protected Attributes inherited from CXTPPopupBar
CXTPControlPopup * | m_pControlPopup
Control that pop-up'ed the bar.
CPoint | m_ptPopup
Position of the bar.
CRect | m_rcExclude
Excluded area.
DWORD | m_popupFlags
Flags of the bar.
BOOL | m_bDynamicLayout
TRUE if DynamicLayout routine executed.
BOOL | m_bCollapsed
TRUE if pop-up bar is collapsed.
BOOL | m_bExpanded
TRUE if pop-up bar is expanded.
BOOL | m_bExpanding
TRUE if pop-up bar is expanding.
BOOL | m_bTearOffPopup
TRUE if pop-up bar has tear-off option.
CRect | m_rcTearOffGripper
Tear-off gripper position.
CRect | m_rcResizeGripper
Resizable gripper position.
BOOL | m_bResizable
TRUE to allow resize.
BOOL | m_bTearOffSelected
TRUE if gripper selected.
UINT_PTR | m_nTearOffTimer
Tear-off timer.
BOOL | m_bTearOffTracking
Tear-off tracking mode.
CSize | m_szTearOffBar
Size of the bar.
CXTPToolBar * | m_pTearOffBar
Tear-off toolbar pointer.
CString | m_strTearOffCaption
Caption of the Tear-off toolbar.
UINT | m_nTearOffID
ID of the Tear-off toolbar.
int | m_nTearOffWidth
Width of the Tear-off toolbar.
BOOL | m_bShowShadow
TRUE to show the shadow.
CRect | m_rcBorders
Borders of the bar.
BOOL | m_bDoubleGripper
TRUE if pop-up is state pop-up type.
BOOL | m_bContextMenu
TRUE if pop-up bar is context menu.
int | m_nMaxHeight
Maximum height the pop-up bar can become.
- Protected Attributes inherited from CXTPCommandBar
BOOL | m_bGrabFocus
TRUE to grab current focus.
int | m_nMRUWidth
Recent width.
int | m_nSelected
Selected control index.
int | m_nPopuped
Pop-up'ed control index.
HWND | m_hwndFocus
The handle of the window that currently has focus.
UINT | m_nBarID
Command bar's identifier.
BOOL | m_bTracking
TRUE if the command bar is in tracking mode.
CWnd * | m_pSite
Command bar's site.
DWORD | m_nIdleFlags
Idle flags.
DWORD | m_dwFlags
Command bar's flags.
DWORD | m_dwStyle
Command bar's styles.
CString | m_strTitle
Command bar's caption.
XTPBarType | m_barType
Type of the command bar.
CXTPControls * | m_pControls
A pointer to controls collection.
XTPBarPosition | m_barPosition
Position of the command bar.
CXTPCommandBars * | m_pCommandBars
parent command bars class.
CWnd * | m_pOwner
Owner window.
CSize | m_szIcons
Size of the command bar's icons.
CSize | m_szButtons
Size of the command bar's buttons.
BOOL | m_bTextBelow
TRUE if text is shown below the CommandBar buttons.
BOOL | m_bExecOnRButton
TRUE if the control button is executed on a right-click.
BOOL | m_bIgnoreUpdateHandler
TRUE to skip update handler for all child controls.
BOOL | m_bRecursePopup
TRUE if pop-up bar was opened recursively.
BOOL | m_bKeyboardSelect
TRUE if last item was selected by keyboard.
BOOL | m_bCloseable
TRUE if the CommandBar can be closed and-or Hidden.
BOOL | m_bCustomizable
TRUE if command bar is customizable.
CRect | m_rcMarker
Marker position.
BOOL | m_bVerticalMarker
TRUE to draw marker vertically.
DWORD_PTR | m_dwData
The 32-bit value associated with the command bar.
UINT * | m_pReturnCmd
Return command holder.
BOOL | m_bCustomizeDialogPresent
TRUE if the command bar is present in Customize dialog.
BOOL | m_bAnimatePopup
TRUE to animate pop-up bar.
BOOL | m_nLockRedraw
TRUE if all drawing routines skipped.
CXTPPaintManager * | m_pPaintManager
Selected paint manager for command bar.
CXTPImageManager * | m_pImageManager
Selected image manager for command bar.
BOOL | m_bMultiLine
True if multi line commandbar.
XTPButtonStyle | m_buttonStyle
Default button Style.
XTPBarTextOrientation | m_nTextOrientation
Commandbar text orientation.
CXTPToolTipContext * | m_pToolTipContext
Tool tip Context.
CXTPCommandBarAnimation * | m_pAnimation
Animation context.
CSize | m_szButtonSpacing
Spacing used between toolbar buttons.

Detailed Description

Implements a pop-up when the Ribbon is in minimzed mode.

Constructor & Destructor Documentation

◆ CXTPRibbonTabPopupToolBar()

CXTPRibbonTabPopupToolBar ( CXTPRibbonTab * pRibbonTab )

Constructs a CXTPRibbonTabPopupToolBar object.

Parameters
pRibbonTab Ribbon tab that the pop-up toolbar belongs to.

Member Function Documentation

◆ CalcDynamicLayout()

CSize CalcDynamicLayout | ( | int | nLength,
 |  | DWORD | nMode )
 virtual

This method is called to get the size of the command bar.

Parameters
nLength | The requested dimension of the control bar, either horizontal or vertical depending on nMode.
nMode | See CControlBar::CalcDynamicLayout for the list of supported flags.
Returns
The size of the command bar.

Reimplemented from CXTPPopupToolBar.

◆ CalculatePopupRect()

virtual CRect CalculatePopupRect | ( | CPoint | ptPopup,
 |  | CSize | sz )
 virtual

This method is called to calculate the destination rectangle of the pop-up bar.

Parameters
ptPopup | Point to display the pop-up bar.
sz | Size of the pop-up bar.
Returns
Rectangle where the pop-up bar will be located.

Reimplemented from CXTPPopupBar.

◆ DrawCommandBar()

void DrawCommandBar | ( | CDC * | pDC,
 |  | CRect | rcClipBox )
 virtual

This method is called to draw the command bar in the given context.

Parameters
pDC | Pointer to a valid device context.
rcClipBox | The rectangular area of the control that is invalid.

Reimplemented from CXTPPopupBar.

◆ EnsureVisible()

void EnsureVisible ( CXTPControl * pControl )
virtual

Call this method to make sure that a control is visible on the ribbon bar.

Parameters
pControl Pointer to the CXTPControl child whose visibility must be checked.

Reimplemented from CXTPCommandBar.

◆ GetButtonSize()

virtual CSize GetButtonSize ( ) const
virtual

Call this function to get the size of the command bar button.

Returns
The width and height values of the command bar button.

Reimplemented from CXTPCommandBar.

◆ GetGroupsRect()

CRect GetGroupsRect ( ) const

Retrieves the groups bounding rectangle.

Returns
A CRect object containing the groups bounding rectangle.

◆ GetIconSize()

virtual CSize GetIconSize ( ) const
virtual

Call this member function to get the size of the icon for a minimized group.

Returns
The size of the icon for a minimized group
See also
GetLargeIconSize

Reimplemented from CXTPCommandBar.

◆ HitTestGroup()

CXTPRibbonGroup * HitTestGroup ( CPoint point ) const

This member function determines which ribbon group, if any, is at a specified position.

Parameters
point Point to test.
Returns
A pointer to the CXTPRibbonGroup at the specified position, if any, otherwise NULL.

◆ IsKeyboardCuesVisible()

BOOL IsKeyboardCuesVisible ( ) const
virtual

Call this method to determine if keyboard cues are visible.

Returns
TRUE if keyboard cues are visible, otherwise FALSE.

Reimplemented from CXTPCommandBar.

◆ OnGroupsScroll()

void OnGroupsScroll ( BOOL bScrollLeft )

The framework calls this member function when the group pop-up is scrolled.

Parameters
bScrollLeft TRUE when scrolling left, FALSE when scrolling right.

◆ OnKeyboardTip()

void OnKeyboardTip ( CXTPCommandBarKeyboardTip * pTip )
virtual

This method is called when a keyboard tip is found for the command bar.

Parameters
pTip Keyboard tip that was found for the command bar.

Reimplemented from CXTPCommandBar.

◆ OnToolHitTest()

INT_PTR OnToolHitTest | ( | CPoint | point,
 |  | TOOLINFO * | pTI ) const

The framework calls this member function to determine whether a point is in the bounding rectangle of the specified tool.

Parameters
point | Specifies the x- and y- coordinates of the cursor. These coordinates are always relative to the upper-left corner of the window.
pTI | A pointer to a TOOLINFO structure.
Returns
If the tooltip control was found, then the window control ID is returned. If the tooltip control was not found, then a value of -1 is returned.

◆ ProcessSpecialKey()

virtual BOOL ProcessSpecialKey ( XTPSpecialKey key )
protectedvirtual

This method is called to process special keys.

Parameters
key Special keys enumerator. Can be any of the values listed in the Remarks section.

CXTPCommandBar maps key passed as parameter of OnKeyDown to XTPSpecialKey enumerator and call ProcessSpecialKey.

The key parameter can be one of the following: xtpKeyNext: Indicates that the RIGHT or DOWN key was pressed. Next control must be selected. xtpKeyPrev: Indicates that the LEFT or UP key was pressed. Previous control must be selected. xtpKeyBack: Indicates that the LEFT key was pressed for pop-up bar. Current sub-menu must be closed. xtpKeyPopup: Indicates that the RIGHT key was pressed for pop-up bar. Sub-menu must be opened. xtpKeyEscape: Indicates that the ESCAPE key was pressed. xtpKeyReturn: Indicates that the RETURN key was pressed. xtpKeyHome: Indicates that the HOME key was pressed. First control must be selected. xtpKeyEnd: Indicates that the END key was pressed. Last control must be selected.

Returns
TRUE if the key was handled, otherwise FALSE.

Reimplemented from CXTPCommandBar.

◆ SetTrackingMode()

virtual BOOL SetTrackingMode | ( | int | bMode,
 |  | BOOL | bSelectFirst = TRUE,
 |  | BOOL | bKeyboard = FALSE )
 virtual

Call this member to change the tracking state.

Parameters
bMode | TRUE to set the tracking mode; otherwise FALSE.
bSelectFirst | TRUE to select the first item.
bKeyboard | TRUE if the item is pop-up'ed by the keyboard.
Returns
TRUE if the method was successful.

Reimplemented from CXTPPopupBar.

The documentation for this class was generated from the following file:
  • XTPRibbonPopups.h


Toolkit Pro: CXTPRibbonTheme Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPRibbonTheme Class Reference

The CXTPRibbonTheme class is used to enable a Ribbon style theme for Command Bars. More...

Inheritance diagram for CXTPRibbonTheme:
[legend]

Public Member Functions

CXTPRibbonTheme ()
Constructs a CXTPRibbonTheme object.
virtual | ~CXTPRibbonTheme ()
Destroys a CXTPRibbonTheme object, handles cleanup and deallocation.
virtual void | RefreshMetrics ()
This method is called to refresh the visual metrics of the manager.
void | SetRibbonPaintManager (CXTPRibbonPaintManager *pRibbonPaintManager)
Call this member function to set the current ribbon paint manager.
- Public Member Functions inherited from CXTPResourceTheme
CXTPResourceTheme ()
Constructs a CXTPResourceTheme object.
virtual | ~CXTPResourceTheme ()
Destroys a CXTPResourceTheme object, handles cleanup and deallocation.
CXTPResourceImage * | LoadImage (LPCTSTR lpszFileName)
Loads a bitmap image from the specified path.
void | SetImageHandle (HMODULE hResource, LPCTSTR lpszIniFileName)
Specifies the resource that contains the bitmaps to be loaded for the theme.
virtual BOOL | RequiresResourceImages ()
Used by the paint manager to determine if the theme requires a resource DLL to load image and color information.
CXTPResourceImages * | GetImages () const
This method is called to get the CXTPResourceImages pointer.
void | SetImages (CXTPResourceImages *pImages)
Call this method to set images for the theme.
virtual void | FillWorkspace (CDC *pDC, CRect rc, CRect rcExclude)
Draws workspace space.
virtual CXTPFramePaintManager * | GetFramePaintManager ()
Returns the paint manager used to draw frames.
virtual CXTPRibbonPaintManager * | GetRibbonPaintManager ()
Retrieves the ribbon paint manager.
- Public Member Functions inherited from CXTPCommandBarsOffice2003Theme
CXTPCommandBarsOffice2003Theme ()
Constructs a CXTPCommandBarsOffice2003Theme object.
virtual | ~CXTPCommandBarsOffice2003Theme ()
Destroys a CXTPCommandBarsOffice2003Theme object, handles cleanup and deallocation.
void | ExcludeCorners (CDC *pDC, CRect rc)
This method creates a new clipping region that consists of the existing clipping region minus the corners rectangles.
- Public Member Functions inherited from CXTPCommandBarsOfficeXPTheme
CXTPCommandBarsOfficeXPTheme ()
Constructs a CXTPCommandBarsOfficeXPTheme object.
virtual CSize | DrawListBoxControl (CDC *pDC, CXTPControl *pButton, CRect rc, BOOL bSelected, BOOL bDraw, CXTPCommandBars *pCommandBars=0)
This method is called to draw the control placed on the ListBox.
- Public Member Functions inherited from CXTPPaintManager
CSize | DrawControl (CDC *pDC, CXTPControl *pButton, BOOL bDraw=TRUE)
This method is called to draw the control.
virtual CSize | DrawControlToolBarParent (CDC *pDC, CXTPControl *pButton, BOOL bDraw)
This method is called to draw the control placed on the toolbar.
virtual COLORREF | GetControlBackColor (CXTPControl *pButton)
Call this method to get the control back color to draw.
virtual void | DrawGalleryItemBack (CDC *pDC, CRect rcItem, BOOL bEnabled, BOOL bSelected, BOOL bPressed, BOOL bChecked, XTPBarType barType)
This method is called to draw the background for a gallery menu item.
virtual void | DrawCommandBarGroupSeparator (CDC *pDC, CXTPCommandBar *pBar, CXTPControl *pLeftControl, CXTPControl *pRightControl, BOOL bDraw=TRUE)
This method is called to draw a command bar's group separator.
int | GetShadowOptions () const
Determines the kind of shadow to use.
virtual void | DrawExpandGlyph (CDC *pDC, CXTPControl *pButton, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clr)
Draw expand or hidden glyphs for a button.
virtual void | DrawExpandGlyph (CDC *pDC, CXTPControl *pButton, COLORREF clr, BOOL bVertical)
Draw expand or hidden glyphs for a button.
virtual void | DrawHiddenGlyph (CDC *pDC, CXTPControl *pButton, COLORREF clr, BOOL bVertical)
Draw expand or hidden glyphs for a button.
virtual CRect | GetSplitButtonCommandRect (CXTPControl *pButton)
Determines split button command rectangle.
XTPPaintTheme GetCurrentTheme ()
Call this member to get the current visual theme.
virtual CFont * | GetControlFont (CXTPControl *pControl)
Call this member to retrieve the font of the command bar control.
virtual CFont * | GetCommandBarFont (CXTPCommandBar *pCommandBar)
Call this member to retrieve the font of the command bar.
virtual XTPBarTextOrientation | GetControlTextOrientation (CXTPControl *pControl)
Call this member to determine how to draw text.
virtual void | UpdateFonts ()
Refreshes the fonts to use.
virtual void | UpdateColors ()
Refreshes the standard colors to use.
void | SetCommandBarsFontIndirect (LOGFONT *pLogFont, BOOL bUseStandardFont=FALSE)
Call this member to set command bar's font.
CFont * | GetRegularFont ()
Returns the general font.
CFont * | GetRegularBoldFont ()
Returns the general bold font.
CFont * | GetIconFont ()
Returns the icon font.
CFont * | GetSmCaptionFont ()
Call this method to retrieve the caption of a floating mini frame.
void | UseOfficeFont (bool bUseOfficeFont)
Call this method to use Tahoma font despite system metrics.
int | GetControlHeight () const
This method returns the common controls height.
virtual CSize | GetDefaultCommandBarSize (CXTPCommandBar *pBar)
Computes default command bar size taking into account command bar font.
void | Rectangle (CDC *pDC, LPCRECT rc, int nPen, const int nBrush)
Draws a rectangle.
void | Rectangle (CDC *pDC, LPCRECT rc, COLORREF clrPen, COLORREF clrBrush)
Draws a rectangle.
void | RoundRect (CDC *pDC, LPCRECT rc, COLORREF clrPen, COLORREF clrBrush)
Draws a rectangle.
void | Draw3dRect (CDC *pDC, LPCRECT rc, int nTopLeft, int nBottomRight)
Call this member function to draw a three-dimensional rectangle.
void | Draw3dRect (CDC *pDC, LPCRECT rc, int frameThickness, COLORREF clrPen, COLORREF clrBrush)
Call this member function to draw a rectangle with predetermined thickness.
void | DrawCheckMark (CDC *pDC, CRect rcCheck, COLORREF clr=0)
Call this member function to draw a check mark.
virtual void | DrawComboExpandMark (CDC *pDC, CRect rc, COLORREF clr)
Call this member function to draw a combobox expand symbol.
virtual void | DrawControlMDIButton (CDC *pDC, CXTPControlButton *pButton)
Call this member function to draw menu MDI buttons.
void | Line (CDC *pDC, CPoint p0, CPoint p1)
Draws a line.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1, const int nPen)
Draws a line.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1, COLORREF clrPen)
Draws a line.
void | HorizontalLine (CDC *pDC, int x0, int y0, int x1, COLORREF clrPen)
Call this member function to draw a horizontal line using the specified coordinages and RGB color value.
void | VerticalLine (CDC *pDC, int x0, int y0, int y1, COLORREF clrPen)
Call this member function to draw a vertical line using the specified coordinages and RGB color value.
virtual void | DrawDropDownGlyph (CDC *pDC, CXTPControl *pControl, CPoint pt, BOOL bSelected, BOOL bPopuped, BOOL bEnabled, BOOL bVert)
This member function is called to draw a split button expand symbol.
void | Pixel (CDC *pDC, int xPos, int yPos, int nPen)
Sets the pixel at the point.
void | GradientFill (CDC *pDC, LPRECT lpRect, COLORREF crFrom, COLORREF crTo, BOOL bHorz, LPCRECT lpRectClip=NULL)
Gradient fills the rectangle.
XTP_COMMANDBARS_ICONSINFO * GetIconsInfo ()
virtual void | Animate (CDC *pDestDC, CDC *pSrcDC, CRect rc, XTPAnimationType animationType)
This method is called to animate the pop-up bar.
virtual void | AnimateExpanding (CXTPCommandBar *pCommandBar, CDC *pDestDC, CDC *pSrcDC, BOOL bExpandDown)
This method is called to animate the expanding process.
void | SetAnimationDelay (int nAnimationSteps, int nAnimationTime)
Call this method to set animation delay.
COLORREF | GetXtremeColor (UINT nIndex)
This function retrieves the current color of the specified XP display element.
void | SetColors (int cElements, CONST INT *lpaElements, CONST COLORREF *lpaRgbValues)
Call this member to set the colors for each element to the color in the specified color array.
CSize | DrawControlText (CDC *pDC, CXTPControl *pControl, CRect rcText, BOOL bDraw, BOOL bVert, BOOL bCentered, BOOL bTriangled)
This method is called to draw control text.
virtual void | UpdateRTLCaption (CString &strCaption)
This method is called to prepare a caption for Right-To-Left draw.
XTPCurrentSystemTheme GetCurrentSystemTheme ()
Call this member function to determine the current Windows XP theme in use.
void | SetLunaTheme (XTPCurrentSystemTheme systemTheme)
Call this method to force system theme.
virtual int | GetPopupBarGripperWidth (CXTPCommandBar *pBar)
Calculates the gripper of a pop-up bar.
virtual CXTPControlGalleryPaintManager * | GetGalleryPaintManager () const
Retrieves paint manager used to draw galleries.
virtual CXTPScrollBarPaintManager * | GetScrollBarPaintManager () const
Retrieves paint manager used to draw scrollbars.
virtual CXTPSliderPaintManager * | GetSliderPaintManager () const
Retrieves paint manager used to draw slider panes.
virtual CXTPProgressPaintManager * | GetProgressPaintManager () const
Retrieves paint manager used to draw progress bars.
virtual CXTPStatusBarPaintManager * | GetStatusBarPaintManager ()
Retrieves paint manager used to draw the status bar.
virtual CXTPMessageBarPaintManager * | GetMessageBarPaintManager ()
Retrieves paint manager used to draw message bars.
CXTPShadowManager * | GetShadowManager () const
Retrieves shadow manager used to draw shadows.
BOOL | IsUseSystemAccentColorEnabled () const
Determines whether xtpApplicationUseSystemAccentColor application ambient property is set.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.
- Public Member Functions inherited from CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents >
void | Subscribe (IXTPPaintManagerEvents *pObserver, CXTPSubscriptionList< CXTPPaintManager, IXTPPaintManagerEvents > *pSubcriptionList=NULL)
Subscribes a unique observer for events.
void | Unsubscribe (IXTPPaintManagerEvents *pObserver)
Unsubscribes an observer from events.
void | Notify (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *))
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *))
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.

Protected Member Functions

virtual void | DrawControlEntry (CDC *pDC, CXTPControl *pButton)
This method is called to fill the control's face.
virtual void | AdjustExcludeRect (CRect &rc, CXTPControl *pControl, BOOL bVertical)
This method is called to determine the offset of a pop-up bar.
virtual void | DrawSplitButtonFrame (CDC *pDC, CXTPControl *pButton, CRect rc)
This method is called to draw the frame for the SplitButton control.
virtual void | DrawPopupBarGripper (CDC *pDC, int xPos, int yPos, int cx, int cy, BOOL bExpanded=FALSE)
This method is called to draw a pop-up bar's right gripper.
virtual void | FillCommandBarEntry (CDC *pDC, CXTPCommandBar *pBar)
This method is called to fill the command bar's face.
virtual void | DrawRectangle (CDC *pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition)
This method is called to fill the control's face.
virtual void | DrawRectangle (CDC *pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition, int nID)
This method is called to fill the control's face.
virtual BOOL | DrawRectangle (CDC *pDC, CXTPControl *pButton)
This method is called to fill the control's face.
virtual CSize | DrawCommandBarSeparator (CDC *pDC, CXTPCommandBar *pBar, CXTPControl *pControl, BOOL bDraw)
This method is called to draw a command bar's separator.
virtual CSize | DrawCommandBarGripper (CDC *pDC, CXTPCommandBar *pBar, BOOL bDraw=TRUE)
This method is called to draw the command bar's gripper.
virtual void | FillStatusBar (CDC *pDC, CXTPStatusBar *pBar)
This method is called to fill a status bar.
virtual void | DrawStatusBarGripper (CDC *pDC, CRect rcClient)
This method is called to draw the status bar's gripper.
virtual void | DrawStatusBarPaneBorder (CDC *pDC, CRect rc, CXTPStatusBarPane *pPane, BOOL bGripperPane)
This method is called to draw the frame of a single cell of the status bar.
virtual void | DrawStatusBarPaneSeparator (CDC *pDC, CRect rc, CXTPStatusBarPane *pPane)
This method is called to draw the pane separator of status bar panes.
virtual int | DrawStatusBarSwitchPane (CDC *pDC, CRect rcItem, CXTPStatusBarSwitchPane *pPane)
This method is called to draw the status bar switch pane.
virtual COLORREF | GetRectangleTextColor (BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition)
This method retrieves a buttons text color.
virtual COLORREF | GetControlTextColor (CXTPControl *pButton)
This method returns a control text color to draw.
CSize | DrawControlEdit (CDC *pDC, CXTPControlEdit *pControlEdit, BOOL bDraw)
This method is called to draw the control.
CSize | DrawControlComboBox (CDC *pDC, CXTPControlComboBox *pComboBox, BOOL bDraw)
This method is called to draw the control.
virtual COLORREF | GetControlEditBackColor (CXTPControl *pControl)
This method returns the edit control back color to draw.
virtual XTPPaintTheme | BaseTheme ()
Retrieves the base theme of the manager.
virtual void | SetCommandBarRegion (CXTPCommandBar *pCommandBar)
This method is called to set the bounding region for a pop-up bar.
virtual void | DrawSplitButtonPopup (CDC *pDC, CXTPControl *pButton)
This method is called to draw a menu split button dropdown rect.
virtual void | DrawControlPopupGlyph (CDC *pDC, CXTPControl *pButton)
This method is called to a draw menu pop-up glyph.
virtual void | FillPopupLabelEntry (CDC *pDC, CRect rc)
This method is called to draw a menu label background.
void | SetRoundRectRegion (CWnd *pWnd)
This method is called to set a rounded rectangle region for a window.
virtual void | DrawKeyboardTip (CDC *pDC, CXTPCommandBarKeyboardTip *pWnd, BOOL bSetRegion)
This method is called to draw a ribbon keyboard tip.
virtual CSize | DrawSpecialControl (CDC *pDC, XTPSpecialControl controlType, CXTPControl *pButton, CXTPCommandBar *pBar, BOOL bDraw, LPVOID lpParam)
This method is called to draw the specified controls.
void | DrawPopupResizeGripper (CDC *pDC, CRect rcGripper, int nFlags)
This method is called to draw the resize gripper for the pop-up window.
virtual void | DrawPopupBarCheckMark (CDC *pDC, CRect rcCheck, BOOL bEnabled, COLORREF clr)
Call this member function to draw a check mark.
virtual void | DrawPopupBarRadioMark (CDC *pDC, CRect rcCheck, BOOL bEnabled, COLORREF clr)
Call this member function to draw a radio button.
BOOL | IsImagesAvailable ()
Determines if images are available.
- Protected Member Functions inherited from CXTPResourceTheme
BOOL | IsImagesAvailable ()
Determines if images are available.
- Protected Member Functions inherited from CXTPCommandBarsOffice2003Theme
virtual void | FillDockBar (CDC *pDC, CXTPDockBar *pBar)
This method is called to fill a dockbar.
virtual CRect | GetCommandBarBorders (CXTPCommandBar *pBar)
This method is called to retrieve the command bar's borders.
virtual CSize | DrawTearOffGripper (CDC *pDC, CRect rcGripper, BOOL bSelected, BOOL bDraw)
This method is called to draw the tear-off gripper of a pop-up bar.
virtual CSize | DrawDialogBarGripper (CDC *pDC, CXTPDialogBar *pBar, BOOL bDraw)
Call this member to draw the gripper of a dialog bar.
void | CreateGradientCircle ()
Generates an expanded bitmap used for CXTPPopupBar.
virtual BOOL | HasFloatingBarGradientEntry (CXTPCommandBar *pBar)
Returns TRUE if a floating toolbar is drawn with a gradient background.
- Protected Member Functions inherited from CXTPCommandBarsOfficeXPTheme
virtual CSize | DrawControlPopupParent (CDC *pDC, CXTPControl *pButton, BOOL bDraw)
This method is called to draw the control placed on the pop-up bar.
virtual void | DrawImage (CDC *pDC, CPoint pt, CSize sz, CXTPImageManagerIcon *pImage, BOOL bSelected, BOOL bPressed, BOOL bEnabled=TRUE, BOOL bChecked=FALSE, BOOL bPopuped=FALSE, BOOL bToolBarImage=TRUE)
This method is called to draw the image of the control.
void | FillIntersectRect (CDC *pDC, CXTPPopupBar *pPopupBar, COLORREF clr)
Draws intersect rectangle of a pop-up bar and its control.
virtual CSize | DrawControlCheckBoxMark (CDC *pDC, CRect rc, BOOL bDraw, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled)
This method is called to draw a check box mark area.
virtual CSize | DrawControlCheckBoxMark (CDC *pDC, CXTPControl *pButton, CRect rc, BOOL bDraw)
This method is called to draw a check box mark area.
virtual CSize | DrawControlRadioButtonMark (CDC *pDC, CRect rc, BOOL bDraw, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled)
This method is called to draw a radio button mark area.
- Protected Member Functions inherited from CXTPPaintManager
CXTPPaintManager ()
Constructs a CXTPPaintManager object.
virtual | ~CXTPPaintManager ()
Destroys a CXTPPaintManager object, handles cleanup and deallocation.
- Protected Member Functions inherited from CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents >
CXTPObservable ()
Constructs an observable object.
~CXTPObservable ()
Handles observable object destruction.

Protected Attributes

COLORREF | m_clrControlEditNormal
Edit control color.
COLORREF | m_clrControlEditSelected
Edit control selected color.
COLORREF | m_clrControlEditDisabledBorder
Edit disabled border.
COLORREF | m_clrRibbonText
Ribbon text color.
COLORREF | m_clrRibbonGrayText
Gray text of the ribbon.
COLORREF | m_clrMenuPopupSeparator
Pop-up separator color.
COLORREF | m_clrMenuPopupGripperShadow
Pop-up gripper shadow color.
- Protected Attributes inherited from CXTPResourceTheme
int | m_nRibbonCaptionHeight
Ribbon caption height.
- Protected Attributes inherited from CXTPPaintManager
CXTPFont | m_xtpFontRegular
Regular font.
CXTPFont | m_xtpFontRegularBold
Regular bold font.
CXTPFont | m_xtpFontVert
Vertical font.
CXTPFont | m_xtpFontVertBold
Vertical font.
int | m_nEditHeight
Edit text height.
int | m_nFontHeight
Custom font height (optional).
BOOL | m_bUseStandardFont
TRUE to use system font.
BOOL | m_bEmbossedDisabledText
TRUE to draw disabled text embossed.
CXTPWinThemeWrapper * | m_themeStatusBar
StatusBar theme helper.
CXTPWinThemeWrapper * | m_themeButton
Buttons theme helper.
XTPPaintTheme | m_themeCurrent
Current theme.
XTP_COMMANDBARS_ICONSINFO | m_iconsInfo
Specific icons options.
int | m_nAnimationSteps
Steps of the animation.
int | m_nAnimationTime
Time of the animation.
BOOL | m_bShowKeyboardCues
TRUE to show keyboard cues - deprecated.
CXTPPaintManagerColor | m_arrColor [XPCOLOR_LAST+1]
Self colors array.
XTPCurrentSystemTheme | m_systemTheme
Current system theme.
CXTPShadowManager * | m_pShadowManager
Shadow manager.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCommandBarsOffice2003Theme
static HBITMAP AFX_CDECL | GetModernBitmap (UINT nIDResource)
Loads bitmap specified by nIDResource and converts its colors.
static BOOL AFX_CDECL | LoadModernToolbarIcons (UINT nIDResource)
Loads bitmap specified by nIDResource and adds it to ImageManager.
static BOOL AFX_CDECL | LoadModernToolbarIcons (UINT nIDResource, UINT *pCommands, int nCount, CSize szIcon=CSize(16, 15))
Loads bitmap specified by nIDResource and adds it to ImageManager.
- Static Public Member Functions inherited from CXTPPaintManager
static CXTPPaintManager *AFX_CDECL | GetInstanceAddRef ()
Obtains a pointer to a global paint manager object and increments its reference counter.
static void AFX_CDECL | ReleaseInstance ()
Decrements global paint manager's reference counter and deletes its instance when the reference counter reaches 0.
static CXTPPaintManager *AFX_CDECL | CreateTheme (XTPPaintTheme paintTheme)
Creates a new CXTPPaintManager object.
static void AFX_CDECL | SetTheme (XTPPaintTheme paintTheme)
Call this member to switch the visual theme of the Command Bars.
static void AFX_CDECL | SetCustomTheme (CXTPPaintManager *pTheme)
Call this member to set a custom theme.
static void AFX_CDECL | Triangle (CDC *pDC, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clr)
Draws a triangle.
static BOOL AFX_CDECL | FontExists (LPCTSTR lpszFaceName)
Determines if a specified font exists in the system.
static void AFX_CDECL | StripMnemonics (CString &strClear)
This member function will search a string, strip off the mnemonic '&', and reformat the string.
static CXTPPaintManager *AFX_CDECL | GetGlobalPaintManager ()
Call this method to get the pointer to the global paint manager.
static void AFX_CDECL | SetGlobalPaintManager (CXTPPaintManager *pPaintManager)
Call this method to set the pointer to the global paint manager.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPCommandBarsOffice2003Theme
CXTPPaintManagerColorGradient | m_clrDockBar
Color of dockbar face.
CXTPPaintManagerColorGradient | m_clrCommandBar
Color of commandbar face.
CXTPPaintManagerColorGradient | m_clrToolbarExpand
Toolbar Expand button color.
CXTPPaintManagerColorGradient | m_clrMenuExpand
MenuBar Expand button color.
CXTPPaintManagerColorGradient | m_clrMenuExpandedGripper
Color of pop-up bar gripper.
CXTPPaintManagerColorGradient | m_clrMenuGripper
Color of the pop-up menu gripper.
CXTPPaintManagerColorGradient | m_clrPopupControl
color of pop-up control
CXTPPaintManagerColor | m_clrToolbarShadow
Toolbar bottom shadow color.
CXTPPaintManagerColor | m_clrTearOffGripper
TearOff gripper color.
BOOL | m_bLunaTheme
TRUE if luna theme is active.
BOOL | m_bPlainSeparators
TRUE to draw plain separators.
CImageList | m_ilGradientCircle
Gradient circle holder.
CXTPPaintManagerColorGradient | m_grcLunaChecked
Background color of checked button.
CXTPPaintManagerColorGradient | m_grcLunaPushed
Background color of pushed button.
CXTPPaintManagerColorGradient | m_grcLunaSelected
Background color of selected button.
- Public Attributes inherited from CXTPPaintManager
COLORREF | m_clrMessageBarText
Message bar text color.
CRect | m_rcMessageBarMargin
Margin of the message bar.
CXTPFramePaintManager * | m_pFramePaintManager
Frame paint manager.
CXTPStatusBarPaintManager * | m_pStatusBarPaintManager
Paint manager of the status bar.
CXTPRibbonPaintManager * | m_pRibbonPaintManager
Ribbon paint Manager.
CXTPControlGalleryPaintManager * | m_pGalleryPaintManager
Gallery paint manager.
CXTPProgressPaintManager * | m_pProgressPaintManager
Progress bar paint manager.
CXTPSliderPaintManager * | m_pSliderPaintManager
Slider pane paint manager.
CXTPScrollBarPaintManager * | m_pScrollBarPaintManager
Scrollbar paint manager.
CXTPPaintManagerColorGradient | m_clrDisabledIcon
Disabled icons color.
CXTPPaintManagerColor | m_clrFloatingGripper
Gripper color of floating toolbar.
CXTPPaintManagerColor | m_clrFloatingGripperText
Gripper text color of floating toolbar.
BOOL | m_bThickCheckMark
TRUE to draw thick check mark.
BOOL | m_bShowShadow
TRUE to show shadow.
BOOL | m_bThemedStatusBar
TRUE to draw status bar using WinXP theme.
BOOL | m_bThemedCheckBox
TRUE to draw check box using WinXP theme.
BOOL | m_bClearTypeTextQuality
TRUE to enable ClearType text for the font.
BOOL | m_bFlatToolBar
TRUE to draw toolbars flat.
BOOL | m_bFlatMenuBar
TRUE to draw menubar flat.
int | m_nPopupBarTextPadding
Distance between gripper and control text.
BOOL | m_bSelectImageInPopupBar
TRUE to select image as in explorer theme.
BOOL | m_bEnableAnimation
TRUE to enable animation for all toolbars.
BOOL | m_bOffice2007Padding
TRUE if Office2007 metrics used.
BOOL | m_bOffsetPopupLabelText
TRUE if labels in pop-ups drawn with offset.
BOOL | m_bWrapCaptionBelowText
Wrap text for xtpButtonIconAndCaptionBelow buttons.
CXTPPaintManagerFont | m_fontSmCaption
Small caption font.
CXTPPaintManagerFont | m_fontIcon
Icon font.
CXTPPaintManagerFont | m_fontIconBold
Icon bold font.
CXTPPaintManagerFont | m_fontToolTip
Tooltip font.
int | m_nSplitButtonDropDownWidth
Split button drop down width in toolbars.
int | m_nSplitButtonDropDownHeight
Split button drop down height in toolbars.
int | m_nSplitButtonPopupWidth
Split button drop down width in pop-ups.
BOOL | m_bAutoResizeIcons
TRUE to automatically resize icons using current DPI.
int | m_nStatusBarMinHeight
Minimum height for the status bar.
PVOID | m_pfnSetLayeredWindowAttributes
point to Transparency proc in USER32.dll module.
CRect | m_rcStatusBarBorder
Bounding rectangle of the status bar border.
BOOL | m_bUseOfficeFont
TRUE to use Tahoma font.
CString | m_strOfficeFont
Office font.
int | m_nTextHeight
Regular text field height (not font height).

Detailed Description

The CXTPRibbonTheme class is used to enable a Ribbon style theme for Command Bars.

See also
CXTPPaintManager::SetTheme

Member Function Documentation

◆ AdjustExcludeRect()

virtual void AdjustExcludeRect | ( | CRect & | rc,
 |  | CXTPControl * | pControl,
 |  | BOOL | bVertical )
 protectedvirtual

This method is called to determine the offset of a pop-up bar.

Parameters
rc | Control's bounding rectangle.
pControl | Pointer to a CXTPControl object.
bVertical | TRUE if the control is docked vertically.

Reimplemented from CXTPCommandBarsOfficeXPTheme.

◆ BaseTheme()

virtual XTPPaintTheme BaseTheme ( )
inlineprotectedvirtual

Retrieves the base theme of the manager.

Returns
Returns the base theme.

Reimplemented from CXTPResourceTheme.

◆ DrawCommandBarGripper()

virtual CSize DrawCommandBarGripper | ( | CDC * | pDC,
 |  | CXTPCommandBar * | pBar,
 |  | BOOL | bDraw = TRUE )
 protectedvirtual

This method is called to draw the command bar's gripper.

Parameters
pDC | Pointer to a valid device context.
pBar | Pointer to a CXTPCommandBar object.
bDraw | TRUE to draw; FALSE to retrieve the size of the gripper.
Returns
Size of the gripper.

Reimplemented from CXTPCommandBarsOffice2003Theme.

◆ DrawCommandBarSeparator()

virtual CSize DrawCommandBarSeparator | ( | CDC * | pDC,
 |  | CXTPCommandBar * | pBar,
 |  | CXTPControl * | pControl,
 |  | BOOL | bDraw )
 protectedvirtual

This method is called to draw a command bar's separator.

Parameters
pDC | Pointer to a valid device context.
pBar | Pointer to a CXTPCommandBar object.
pControl | Pointer to a CXTPControl object.
bDraw | TRUE to draw; FALSE to retrieve the size of the separator.
Returns
Size of the separator.

Reimplemented from CXTPCommandBarsOffice2003Theme.

◆ DrawControlComboBox()

CSize DrawControlComboBox | ( | CDC * | pDC,
 |  | CXTPControlComboBox * | pComboBox,
 |  | BOOL | bDraw )
 protectedvirtual

This method is called to draw the control.

Parameters
pDC | Pointer to a valid device context.
pComboBox | ComboBox to draw.
bDraw | TRUE to draw; FALSE to retrieve the size of the control.
Returns
Size of the control.

Reimplemented from CXTPCommandBarsOfficeXPTheme.

◆ DrawControlEdit()

CSize DrawControlEdit | ( | CDC * | pDC,
 |  | CXTPControlEdit * | pControlEdit,
 |  | BOOL | bDraw )
 protectedvirtual

This method is called to draw the control.

Parameters
pDC | Pointer to a valid device context.
bDraw | TRUE to draw; FALSE to retrieve the size of the control.
pControlEdit | Edit control to draw.
Returns
Size of the control.

Reimplemented from CXTPCommandBarsOfficeXPTheme.

◆ DrawControlEntry()

virtual void DrawControlEntry | ( | CDC * | pDC,
 |  | CXTPControl * | pButton )
 protectedvirtual

This method is called to fill the control's face.

Parameters
pDC | Pointer to a valid device context.
pButton | Pointer to a CXTPControl object to draw.

Reimplemented from CXTPPaintManager.

◆ DrawControlPopupGlyph()

virtual void DrawControlPopupGlyph | ( | CDC * | pDC,
 |  | CXTPControl * | pButton )
 protectedvirtual

This method is called to a draw menu pop-up glyph.

Parameters
pDC | Pointer to a valid device context.
pButton | Pop-up button to draw the glyph.

◆ DrawKeyboardTip()

virtual void DrawKeyboardTip | ( | CDC * | pDC,
 |  | CXTPCommandBarKeyboardTip * | pWnd,
 |  | BOOL | bSetRegion )
 protectedvirtual

This method is called to draw a ribbon keyboard tip.

Parameters
pDC | Pointer to a valid device context.
pWnd | Keyboard tip window.
bSetRegion | TRUE to set region.

◆ DrawPopupBarCheckMark()

virtual void DrawPopupBarCheckMark | ( | CDC * | pDC,
 |  | CRect | rcCheck,
 |  | BOOL | bEnabled,
 |  | COLORREF | clr )
 protectedvirtual

Call this member function to draw a check mark.

Parameters
pDC | Pointer to a valid device context
rcCheck | Specifies the rectangle in logical units.
clr | Color to fill.
bEnabled | Specifies whether the checkmark will be drawn enabled or disabled.

Reimplemented from CXTPPaintManager.

◆ DrawPopupBarGripper()

virtual void DrawPopupBarGripper | ( | CDC * | pDC,
 |  | int | xPos,
 |  | int | yPos,
 |  | int | cx,
 |  | int | cy,
 |  | BOOL | bExpanded = FALSE )
 protectedvirtual

This method is called to draw a pop-up bar's right gripper.

Parameters
pDC | Pointer to a valid device context.
xPos | Specifies the logical x-coordinate of the upper-left corner of the rectangle.
yPos | Specifies the logical y-coordinate of the upper-left corner of the destination rectangle.
cx | Specifies the width of the rectangle.
cy | Specifies the height of the rectangle.
bExpanded | TRUE if expanded.

Reimplemented from CXTPCommandBarsOffice2003Theme.

◆ DrawPopupBarRadioMark()

virtual void DrawPopupBarRadioMark | ( | CDC * | pDC,
 |  | CRect | rcCheck,
 |  | BOOL | bEnabled,
 |  | COLORREF | clr )
 protectedvirtual

Call this member function to draw a radio button.

Parameters
pDC | Pointer to a valid device context.
rcCheck | Specifies the rectangle in logical units.
clr | Color to fill.
bEnabled | TRUE to enable, FALSE to disable the button.

Reimplemented from CXTPPaintManager.

◆ DrawPopupResizeGripper()

void DrawPopupResizeGripper | ( | CDC * | pDC,
 |  | CRect | rcGripper,
 |  | int | nFlags )
 protectedvirtual

This method is called to draw the resize gripper for the pop-up window.

Parameters
pDC | Pointer to a valid device context.
rcGripper | CRect object specifying the size of the area.
nFlags | Options for gripper.

Reimplemented from CXTPCommandBarsOfficeXPTheme.

◆ DrawRectangle() [1/3]

virtual void DrawRectangle | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | BOOL | bSelected,
 |  | BOOL | bPressed,
 |  | BOOL | bEnabled,
 |  | BOOL | bChecked,
 |  | BOOL | bPopuped,
 |  | XTPBarType | barType,
 |  | XTPBarPosition | barPosition )
 protectedvirtual

This method is called to fill the control's face.

Parameters
pDC | Pointer to a valid device context.
rc | Rectangle to draw.
bSelected | TRUE if the control is selected.
bPressed | TRUE if the control is pushed.
bEnabled | TRUE if the control is enabled.
bChecked | TRUE if the control is checked.
bPopuped | TRUE if the control is pop-up'ed.
barType | Parent's bar type.
barPosition | Parent's bar position.

Reimplemented from CXTPCommandBarsOffice2003Theme.

◆ DrawRectangle() [2/3]

virtual void DrawRectangle | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | BOOL | bSelected,
 |  | BOOL | bPressed,
 |  | BOOL | bEnabled,
 |  | BOOL | bChecked,
 |  | BOOL | bPopuped,
 |  | XTPBarType | barType,
 |  | XTPBarPosition | barPosition,
 |  | int | nID )
 protectedvirtual

This method is called to fill the control's face.

Parameters
pDC | Pointer to a valid device context.
rc | Rectangle to draw.
bSelected | TRUE if the control is selected.
bPressed | TRUE if the control is pushed.
bEnabled | TRUE if the control is enabled.
bChecked | TRUE if the control is checked.
bPopuped | TRUE if the control is pop-up'ed.
barType | Parent's bar type.
barPosition | Parent's bar position.
nID | Bar's control ID.

Reimplemented from CXTPCommandBarsOffice2003Theme.

◆ DrawRectangle() [3/3]

virtual BOOL DrawRectangle | ( | CDC * | pDC,
 |  | CXTPControl * | pButton )
 protectedvirtual

This method is called to fill the control's face.

Parameters
pDC | Pointer to a valid device context.
pButton | pointer to a button
Returns
TRUE if the rectange was drawn, otherwise FALSE.

Reimplemented from CXTPCommandBarsOffice2003Theme.

◆ DrawSpecialControl()

virtual CSize DrawSpecialControl | ( | CDC * | pDC,
 |  | XTPSpecialControl | controlType,
 |  | CXTPControl * | pButton,
 |  | CXTPCommandBar * | pBar,
 |  | BOOL | bDraw,
 |  | LPVOID | lpParam )
 protectedvirtual

This method is called to draw the specified controls.

Parameters
pDC | Pointer to a valid device context.
controlType | Special control enumerator.
pButton | Pointer to a CXTPControl object to draw.
pBar | Parent CXTPCommandBar object.
bDraw | TRUE to draw; FALSE to retrieve the size of the control.
lpParam | Specified parameter.
Returns
Size of the control.

Reimplemented from CXTPCommandBarsOffice2003Theme.

◆ DrawSplitButtonFrame()

virtual void DrawSplitButtonFrame | ( | CDC * | pDC,
 |  | CXTPControl * | pButton,
 |  | CRect | rc )
 protectedvirtual

This method is called to draw the frame for the SplitButton control.

Parameters
pDC | Pointer to a valid device context.
pButton | Pointer to a CXTPControl object.
rc | Bounding rectangle to draw.

Reimplemented from CXTPCommandBarsOfficeXPTheme.

◆ DrawSplitButtonPopup()

virtual void DrawSplitButtonPopup | ( | CDC * | pDC,
 |  | CXTPControl * | pButton )
 protectedvirtual

This method is called to draw a menu split button dropdown rect.

Parameters
pDC | Pointer to a valid device context.
pButton | Split button to draw.

◆ DrawStatusBarGripper()

virtual void DrawStatusBarGripper | ( | CDC * | pDC,
 |  | CRect | rcClient )
 protectedvirtual

This method is called to draw the status bar's gripper.

Parameters
pDC | Pointer to a valid device context.
rcClient | Client rectangle of the status bar.

◆ DrawStatusBarPaneBorder()

virtual void DrawStatusBarPaneBorder | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | CXTPStatusBarPane * | pPane,
 |  | BOOL | bGripperPane )
 protectedvirtual

This method is called to draw the frame of a single cell of the status bar.

Parameters
pDC | Pointer to a valid device context.
rc | CRect object specifying the size of the area.
pPane | The status bar pane to draw.
bGripperPane | TRUE if the pane is the last cell of the status bar.

◆ DrawStatusBarPaneSeparator()

virtual void DrawStatusBarPaneSeparator | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | CXTPStatusBarPane * | pPane )
 protectedvirtual

This method is called to draw the pane separator of status bar panes.

Parameters
pDC | Pointer to a valid device context.
rc | CRect object specifying the size of the area.
pPane | The status bar pane to draw the separator by.

◆ DrawStatusBarSwitchPane()

virtual int DrawStatusBarSwitchPane | ( | CDC * | pDC,
 |  | CRect | rcItem,
 |  | CXTPStatusBarSwitchPane * | pPane )
 protectedvirtual

This method is called to draw the status bar switch pane.

Parameters
pDC | Pointer to a valid device context.
rcItem | CRect object specifying the size of the area.
pPane | The status bar switch pane to draw.
Returns
Pane width value.

◆ FillCommandBarEntry()

virtual void FillCommandBarEntry | ( | CDC * | pDC,
 |  | CXTPCommandBar * | pBar )
 protectedvirtual

This method is called to fill the command bar's face.

Parameters
pDC | Pointer to a valid device context.
pBar | Pointer to a CXTPCommandBar object to draw.

Reimplemented from CXTPCommandBarsOffice2003Theme.

◆ FillPopupLabelEntry()

virtual void FillPopupLabelEntry | ( | CDC * | pDC,
 |  | CRect | rc )
 protectedvirtual

This method is called to draw a menu label background.

Parameters
pDC | Pointer to a valid device context.
rc | Bounding rectangle of the button.

◆ FillStatusBar()

virtual void FillStatusBar | ( | CDC * | pDC,
 |  | CXTPStatusBar * | pBar )
 protectedvirtual

This method is called to fill a status bar.

Parameters
pDC | Pointer to a valid device context.
pBar | Pointer to a CXTPStatusBar object.

◆ GetControlEditBackColor()

virtual COLORREF GetControlEditBackColor ( CXTPControl * pControl )
protectedvirtual

This method returns the edit control back color to draw.

Parameters
pControl Points to a CXTPControl object to get the back color from.
Returns
Edit control back color.

Reimplemented from CXTPPaintManager.

◆ GetControlTextColor()

virtual COLORREF GetControlTextColor ( CXTPControl * pButton )
protectedvirtual

This method returns a control text color to draw.

Parameters
pButton Pointer to a CXTPControl object to draw.
Returns
Button text color.

Reimplemented from CXTPPaintManager.

◆ GetRectangleTextColor()

virtual COLORREF GetRectangleTextColor | ( | BOOL | bSelected,
 |  | BOOL | bPressed,
 |  | BOOL | bEnabled,
 |  | BOOL | bChecked,
 |  | BOOL | bPopuped,
 |  | XTPBarType | barType,
 |  | XTPBarPosition | barPosition )
 protectedvirtual

This method retrieves a buttons text color.

Parameters
bSelected | TRUE if the control is selected.
bPressed | TRUE if the control is pushed.
bEnabled | TRUE if the control is enabled.
bChecked | TRUE if the control is checked.
bPopuped | TRUE if the control is pop-up'ed.
barType | Parent's bar type.
barPosition | Parent's bar position.
Returns
Returns buttons text color

Reimplemented from CXTPResourceTheme.

◆ IsImagesAvailable()

BOOL IsImagesAvailable ( )
protected

Determines if images are available.

Returns
TRUE if images exist in the application.

◆ SetCommandBarRegion()

virtual void SetCommandBarRegion ( CXTPCommandBar * pCommandBar )
protectedvirtual

This method is called to set the bounding region for a pop-up bar.

Parameters
pCommandBar Pointer to the pop-up bar in which the bounding region must be set.

Reimplemented from CXTPPaintManager.

◆ SetRibbonPaintManager()

void SetRibbonPaintManager ( CXTPRibbonPaintManager * pRibbonPaintManager )

Call this member function to set the current ribbon paint manager.

Parameters
pRibbonPaintManager Pointer to a valid ribbon paint manager.

◆ SetRoundRectRegion()

void SetRoundRectRegion ( CWnd * pWnd )
protected

This method is called to set a rounded rectangle region for a window.

Parameters
pWnd Window to set region to.
The documentation for this class was generated from the following file:
  • XTPCommandBarsThemeRibbon.h


Toolkit Pro: CXTPRibbonThemeNativeWindows10 Class Reference

Public Member Functions | List of all members
CXTPRibbonThemeNativeWindows10 Class Reference

CXTPRibbonThemeNativeWindows10 is a CXTPRibbonOffice2013Theme derived class used to represent a Native Windows 10 ribbon theme. More...

Inheritance diagram for CXTPRibbonThemeNativeWindows10:
[legend]

Public Member Functions

CXTPRibbonThemeNativeWindows10 (CXTPPaintManager *pPaintManager)
Constructs a CXTPRibbonThemeNativeWindows10 object.
virtual | ~CXTPRibbonThemeNativeWindows10 ()
Destroys a CXTPRibbonThemeNativeWindows10 object, handles cleanup and deallocation.
virtual void | RefreshMetrics ()
This method is called to refresh the visual metrics of the manager.
void | FillGroupRect (CDC *pDC, CXTPRibbonTab *pActiveTab, CRect rcGroups)
This method is called to fill the background of a CXTPRibbonGroup.
virtual void | DrawRibbonTab (CDC *pDC, CXTPRibbonTab *pItem)
This method is called to draw a single tab of the ribbon bar.
virtual void | DrawRibbonFrameContextHeaders (CDC *pDC, CXTPRibbonBar *pRibbonBar, CXTPRibbonTabContextHeaders *pContextHeaders)
This method is called to draw ribbon context headers.
- Public Member Functions inherited from CXTPRibbonOffice2013Theme
CXTPRibbonOffice2013Theme (CXTPPaintManager *pPaintManager)
Constructs a CXTPRibbonOffice2013Theme object.
virtual | ~CXTPRibbonOffice2013Theme ()
Destroys a CXTPRibbonOffice2013Theme object, handles cleanup and deallocation.
virtual int | GetRibbonCaptionHeight (const CXTPRibbonBar *pRibbonBar) const
Calculates the ribbon caption height.
virtual void | DrawQuickAccessControl (CDC *pDC, CXTPRibbonBar *pRibbon, CXTPControl *pControl)
Draws the specified control which is a part of the Quick Access panel.
virtual void | FillRibbonBar (CDC *pDC, CXTPRibbonBar *pRibbonBar)
This method is called to fill the background of a ribbon bar control.
virtual void | DrawRibbonFrameCaptionBar (CDC *pDC, CXTPRibbonBar *pRibbonBar, BOOL bActive)
This method is called to draw the ribbon caption if EnableFrameTheme was not called.
virtual void | DrawRibbonFrameCaption (CDC *pDC, CXTPRibbonBar *pRibbonBar, BOOL bActive)
This method is called to draw the Ribbon caption.
virtual void | SetBackImage (int nImage)
This member function will set the background image for the Office ribbon bar.
virtual void | DrawRibbonFrameSystemButton (CDC *pDC, CXTPRibbonControlSystemButton *pControl, CRect rc)
Draws the top-left system button.
- Public Member Functions inherited from CXTPRibbonMarkupTheme
CXTPRibbonMarkupTheme (CXTPPaintManager *pPaintManager)
Constructs a CXTPRibbonMarkupTheme object.
virtual | ~CXTPRibbonMarkupTheme ()
Destroys a CXTPRibbonMarkupTheme object, handles cleanup and deallocation.
void | LoadParts (HZIP hZip, CXTPMarkupContext *pMarkupContext=NULL)
Loads markup parts from the specified ZIP source.
void | DrawGroup (CDC *pDC, CXTPRibbonGroup *pGroup)
Draws the specified CXTPRibbonGroup.
void | RenderMarkup (CDC *pDC, CRect rc, LPCTSTR lpszText)
Renders a Markup string in the Ribbon.
void | RenderMarkup (CDC *pDC, CRect rc, XTPRibbonThemePart part)
Renders a Markup string in the Ribbon.
CSize | DrawControlGroupOption (CDC *pDC, CXTPControl *pControlGroupOption, BOOL bDraw)
Draws the group option button.
CSize | GetControlGroupOptionSize () const
Calculates the ribbon group option size.
CSize | DrawControlGroupPopup (CDC *pDC, CXTPControlPopup *pControlGroupPopup, BOOL bDraw)
Draws the group pop-up button.
void | FillGroupPopupToolBar (CDC *pDC, CXTPRibbonGroup *pGroup, CXTPCommandBar *pCommandBar)
This method is called to draw the pop-up toolbar of a reduced group.
virtual void | DrawRibbonQuickAccessButton (CDC *pDC, CXTPControlPopup *pControl)
This method is called to draw the Quick Access customize button.
void | DrawRibbonQuickAccessMoreButton (CDC *pDC, CXTPControlPopup *pControl)
This method is called to draw the Quick Access more button.
void | FillMorePopupToolBarEntry (CDC *pDC, CXTPCommandBar *pBar)
This method is called to draw the pop-up bar of the more button.
void | FillSystemPopupBarEntry (CDC *pDC, CXTPPopupBar *pBar)
This method is called to draw the pop-up bar of the system button.
void | DrawSystemPopupBarButton (CDC *pDC, CXTPControl *pButton)
This method is called to draw a pop-up bar button.
void | DrawRibbonScrollButton (CDC *pDC, CXTPControl *pControl, BOOL bScrollLeft)
This method is called to draw scroll group buttons.
BOOL | DrawRibbonGroupControlEntry (CDC *pDC, CXTPControl *pButton)
This method is called to draw the ribbon group when the group is minimized and only a button is displayed.
void | DrawRibbonGroupPopupToolBar (CDC *pDC, CXTPRibbonGroup *pRibbonGroup)
This method is called to draw the ribbon group pop-up toolbar.
virtual void | DrawRibbonQuickAccessControls (CDC *pDC, CXTPRibbonBar *pRibbonBar)
This method is called to draw ribbon Quick Access controls.
virtual void | FillRibbonTabControl (CDC *pDC, CXTPRibbonBar *pRibbonBar, CRect rcControl)
This member fills in the tab header and tab client area.
- Public Member Functions inherited from CXTPRibbonPaintManager
CXTPRibbonPaintManager (CXTPPaintManager *pPaintManager)
Constructs a CXTPRibbonPaintManager object.
virtual | ~CXTPRibbonPaintManager ()
Destroys a CXTPRibbonPaintManager object, handles cleanup and deallocation.
virtual void | FillTabPopupToolBar (CDC *pDC, CXTPPopupToolBar *pPopupToolBar)
This method is called to draw the background of a minimized pop-up bar.
virtual void | DrawRibbonFramePart (CDC *pDC, CXTPRibbonBar *pRibbonBar)
This method is called to draw the ribbon frame if EnableFrameTheme was not called.
int | GetEditHeight () const
Gets the edit control height.
void | SetFontHeight (int nFontHeight)
Sets the font height used for Ribbon.
int | GetFontHeight () const
Gets the font height used for Ribbon.
int | GetGroupCaptionHeight () const
Gets the height of the group caption bar.
CXTPResourceImage * | LoadImage (LPCTSTR lpszFileName)
Loads a bitmap image from the specified path.
CXTPResourceImages * | GetImages () const
This method is called to get a pointer to the CXTPResourceImages object.
CXTPTabPaintManager * | GetTabPaintManager () const
Call this member to get a pointer to the tab paint manager.
CXTPFramePaintManager * | GetFramePaintManager () const
Call this member to get a pointer to the frame paint manager.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPRibbonPaintManager
BOOL | m_bHotTrackingGroups
TRUE to highlight the group under the cursor.
BOOL | m_bFlatFrame
TRUE to draw a flat frame.
CXTPPaintManagerFont | m_fontGroupCaption
Font used to draw text in the group caption.
COLORREF | m_clrRecentFileListEdgeShadow
Color of the File List edge shadow.
COLORREF | m_clrRecentFileListEdgeHighLight
Color of the File List edge highlight.
int | m_nTabsHeight
Tabs heights.
int | m_nGroupSpacing
Group spacing.
int | m_nGroupCaptionHeight
Group caption bar height.
- Protected Member Functions inherited from CXTPRibbonOffice2013Theme
virtual CString | GetBackImageName ()
This member function is used to get the name of the background image located in the Office 2013 resource .DLL.
virtual void | DrawBackImage (CDC *pDC, CXTPRibbonBar *pRibbonBar)
Used by the theme to draw the background image for the ribbon bar.
virtual void | LoadParts (BOOL bReload=FALSE)
Loads markup parts.
- Protected Member Functions inherited from CXTPRibbonMarkupTheme
- Protected Member Functions inherited from CXTPRibbonPaintManager
virtual CXTPTabPaintManager * | CreateTabPaintManager ()
Creates a CXTPTabPaintManager object used to store the color and appearance information of the tabs in the ribbon bar.
void | DrawRibbonApplicationIcon (CDC *pDC, CXTPRibbonBar *pRibbonBar, CRect rc, HICON hIcon)
This method is called to draw a ribbon bar application icon.
void | DrawDwmCaptionText (CDC *pDC, CRect rcCaptionText, CString strText, CWnd *pSite, BOOL bActive)
This method is called to draw caption text for an aero-transparent caption.
- Protected Attributes inherited from CXTPRibbonOffice2013Theme
XTPRIBBON_HEADER_COLOR | m_clrHeader [24]
Array of color values used for rendering the Ribbon's.
COLORREF | m_clrRibbonInactiveFaceState
context tabs.
COLORREF | m_clrTabBackInactiveState
Color of the ribbon tab when the application is inactive.
COLORREF | m_clrTabBackackstageLeft
Color of left part of the ribbon tab when new backstage is.
COLORREF | m_clrTabBackackstageRight
pop-up.
COLORREF | m_clrRibbonTabDelimeter
is pop-up.
- Protected Attributes inherited from CXTPRibbonMarkupTheme
COLORREF | m_clrBackstageSysButtonBack2013Normal
The color of "back" button in backstage if the button is not selected.
COLORREF | m_clrBackstageSysButtonBack2013Highlighted
The color of "back" button in backstage if the button is selected.
CString | m_strHighlightedPrefix
The prefix of the file name for the backstage "back" button image used for the selected button.
CString | m_strNormalPrefix
The prefix of the file name for the backstage "back" button image used for the not selected button.
CXTPMarkupContext * | m_pMarkupContext
Store pointer to a CXTPMarkupContext object.
- Protected Attributes inherited from CXTPRibbonPaintManager
COLORREF | m_clrRibbonFace
Ribbon face color.
COLORREF | m_clrRibbonBorder
Ribbon border color.
COLORREF | m_clrRibbonGroupCaptionText
Ribbon group captions color.
COLORREF | m_clrRibbonInactiveFace
Color of the ribbon when it is inactive.
COLORREF | m_clrFileButtonText
Text caption to display when the system button is displayed as a tab button (Windows 7 style).
COLORREF | m_clrMinimizedFrameEdgeHighLight
Minimized bottom edge.
COLORREF | m_clrMinimizedFrameEdgeShadow
Minimized bottom edge shadow.
CXTPPaintManager * | m_pPaintManager
Paint manager used for the ribbon.
CXTPTabPaintManager * | m_pTabPaintManager
Tab paint manager.
CRect | m_rcFileButtonMargin
Margins of the system button when it is displayed as a tab button (Windows 7 style).

Detailed Description

CXTPRibbonThemeNativeWindows10 is a CXTPRibbonOffice2013Theme derived class used to represent a Native Windows 10 ribbon theme.

Constructor & Destructor Documentation

◆ CXTPRibbonThemeNativeWindows10()

CXTPRibbonThemeNativeWindows10 ( CXTPPaintManager * pPaintManager )

Constructs a CXTPRibbonThemeNativeWindows10 object.

Parameters
pPaintManager A CXTPPaintManager object.

Member Function Documentation

◆ DrawRibbonFrameContextHeaders()

virtual void DrawRibbonFrameContextHeaders | ( | CDC * | pDC,
 |  | CXTPRibbonBar * | pRibbonBar,
 |  | CXTPRibbonTabContextHeaders * | pContextHeaders )
 virtual

This method is called to draw ribbon context headers.

Parameters
pDC | Pointer to a valid device context.
pContextHeaders | Collection of context headers.
pRibbonBar | Pointer to the parent ribbon bar.

Reimplemented from CXTPRibbonOffice2013Theme.

◆ DrawRibbonTab()

virtual void DrawRibbonTab | ( | CDC * | pDC,
 |  | CXTPRibbonTab * | pItem )
 virtual

This method is called to draw a single tab of the ribbon bar.

Parameters
pDC | Pointer to a valid device context.
pItem | Ribbon tab to draw.

Reimplemented from CXTPRibbonOffice2013Theme.

◆ FillGroupRect()

void FillGroupRect | ( | CDC * | pDC,
 |  | CXTPRibbonTab * | pActiveTab,
 |  | CRect | rcGroups )
 virtual

This method is called to fill the background of a CXTPRibbonGroup.

Parameters
pDC | Pointer to a valid device context.
pActiveTab | Pointer to the tab that is currently active.
rcGroups | Bounding rectangle of the group.

Performs a gradient fill using the GROUP_COLOR::clrBackground for the main group background and GROUP_COLOR::clrCaption to fill the group caption rectangle.

See also
CXTPRibbonGroup::GetRect, GROUP_COLOR

Reimplemented from CXTPRibbonMarkupTheme.

◆ RefreshMetrics()

virtual void RefreshMetrics ( )
virtual

This method is called to refresh the visual metrics of the manager.

Refreshes all of the colors in the ribbon bar. Many of the colors used are set with the GROUP_COLOR structure.

See also
GROUP_COLOR

Reimplemented from CXTPRibbonOffice2013Theme.

The documentation for this class was generated from the following file:
  • XTPRibbonThemeNativeWindows10.h


Toolkit Pro: CXTPRibbonThemeNativeWindows11 Class Reference

Public Member Functions | List of all members
CXTPRibbonThemeNativeWindows11 Class Reference

CXTPRibbonThemeNativeWindows11 is a CXTPRibbonOffice2013Theme derived class used to represent a Native Windows 10 ribbon theme. More...

Inheritance diagram for CXTPRibbonThemeNativeWindows11:
[legend]

Public Member Functions

CXTPRibbonThemeNativeWindows11 (CXTPPaintManager *pPaintManager)
Constructs a CXTPRibbonThemeNativeWindows11 object.
virtual | ~CXTPRibbonThemeNativeWindows11 ()
Destroys a CXTPRibbonThemeNativeWindows11 object, handles cleanup and deallocation.
virtual void | RefreshMetrics ()
This method is called to refresh the visual metrics of the manager.
void | FillGroupRect (CDC *pDC, CXTPRibbonTab *pActiveTab, CRect rcGroups)
This method is called to fill the background of a CXTPRibbonGroup.
virtual void | DrawRibbonTab (CDC *pDC, CXTPRibbonTab *pItem)
This method is called to draw a single tab of the ribbon bar.
virtual void | DrawRibbonFrameContextHeaders (CDC *pDC, CXTPRibbonBar *pRibbonBar, CXTPRibbonTabContextHeaders *pContextHeaders)
This method is called to draw ribbon context headers.
- Public Member Functions inherited from CXTPRibbonOffice2013Theme
CXTPRibbonOffice2013Theme (CXTPPaintManager *pPaintManager)
Constructs a CXTPRibbonOffice2013Theme object.
virtual | ~CXTPRibbonOffice2013Theme ()
Destroys a CXTPRibbonOffice2013Theme object, handles cleanup and deallocation.
virtual int | GetRibbonCaptionHeight (const CXTPRibbonBar *pRibbonBar) const
Calculates the ribbon caption height.
virtual void | DrawQuickAccessControl (CDC *pDC, CXTPRibbonBar *pRibbon, CXTPControl *pControl)
Draws the specified control which is a part of the Quick Access panel.
virtual void | FillRibbonBar (CDC *pDC, CXTPRibbonBar *pRibbonBar)
This method is called to fill the background of a ribbon bar control.
virtual void | DrawRibbonFrameCaptionBar (CDC *pDC, CXTPRibbonBar *pRibbonBar, BOOL bActive)
This method is called to draw the ribbon caption if EnableFrameTheme was not called.
virtual void | DrawRibbonFrameCaption (CDC *pDC, CXTPRibbonBar *pRibbonBar, BOOL bActive)
This method is called to draw the Ribbon caption.
virtual void | SetBackImage (int nImage)
This member function will set the background image for the Office ribbon bar.
virtual void | DrawRibbonFrameSystemButton (CDC *pDC, CXTPRibbonControlSystemButton *pControl, CRect rc)
Draws the top-left system button.
- Public Member Functions inherited from CXTPRibbonMarkupTheme
CXTPRibbonMarkupTheme (CXTPPaintManager *pPaintManager)
Constructs a CXTPRibbonMarkupTheme object.
virtual | ~CXTPRibbonMarkupTheme ()
Destroys a CXTPRibbonMarkupTheme object, handles cleanup and deallocation.
void | LoadParts (HZIP hZip, CXTPMarkupContext *pMarkupContext=NULL)
Loads markup parts from the specified ZIP source.
void | DrawGroup (CDC *pDC, CXTPRibbonGroup *pGroup)
Draws the specified CXTPRibbonGroup.
void | RenderMarkup (CDC *pDC, CRect rc, LPCTSTR lpszText)
Renders a Markup string in the Ribbon.
void | RenderMarkup (CDC *pDC, CRect rc, XTPRibbonThemePart part)
Renders a Markup string in the Ribbon.
CSize | DrawControlGroupOption (CDC *pDC, CXTPControl *pControlGroupOption, BOOL bDraw)
Draws the group option button.
CSize | GetControlGroupOptionSize () const
Calculates the ribbon group option size.
CSize | DrawControlGroupPopup (CDC *pDC, CXTPControlPopup *pControlGroupPopup, BOOL bDraw)
Draws the group pop-up button.
void | FillGroupPopupToolBar (CDC *pDC, CXTPRibbonGroup *pGroup, CXTPCommandBar *pCommandBar)
This method is called to draw the pop-up toolbar of a reduced group.
virtual void | DrawRibbonQuickAccessButton (CDC *pDC, CXTPControlPopup *pControl)
This method is called to draw the Quick Access customize button.
void | DrawRibbonQuickAccessMoreButton (CDC *pDC, CXTPControlPopup *pControl)
This method is called to draw the Quick Access more button.
void | FillMorePopupToolBarEntry (CDC *pDC, CXTPCommandBar *pBar)
This method is called to draw the pop-up bar of the more button.
void | FillSystemPopupBarEntry (CDC *pDC, CXTPPopupBar *pBar)
This method is called to draw the pop-up bar of the system button.
void | DrawSystemPopupBarButton (CDC *pDC, CXTPControl *pButton)
This method is called to draw a pop-up bar button.
void | DrawRibbonScrollButton (CDC *pDC, CXTPControl *pControl, BOOL bScrollLeft)
This method is called to draw scroll group buttons.
BOOL | DrawRibbonGroupControlEntry (CDC *pDC, CXTPControl *pButton)
This method is called to draw the ribbon group when the group is minimized and only a button is displayed.
void | DrawRibbonGroupPopupToolBar (CDC *pDC, CXTPRibbonGroup *pRibbonGroup)
This method is called to draw the ribbon group pop-up toolbar.
virtual void | DrawRibbonQuickAccessControls (CDC *pDC, CXTPRibbonBar *pRibbonBar)
This method is called to draw ribbon Quick Access controls.
virtual void | FillRibbonTabControl (CDC *pDC, CXTPRibbonBar *pRibbonBar, CRect rcControl)
This member fills in the tab header and tab client area.
- Public Member Functions inherited from CXTPRibbonPaintManager
CXTPRibbonPaintManager (CXTPPaintManager *pPaintManager)
Constructs a CXTPRibbonPaintManager object.
virtual | ~CXTPRibbonPaintManager ()
Destroys a CXTPRibbonPaintManager object, handles cleanup and deallocation.
virtual void | FillTabPopupToolBar (CDC *pDC, CXTPPopupToolBar *pPopupToolBar)
This method is called to draw the background of a minimized pop-up bar.
virtual void | DrawRibbonFramePart (CDC *pDC, CXTPRibbonBar *pRibbonBar)
This method is called to draw the ribbon frame if EnableFrameTheme was not called.
int | GetEditHeight () const
Gets the edit control height.
void | SetFontHeight (int nFontHeight)
Sets the font height used for Ribbon.
int | GetFontHeight () const
Gets the font height used for Ribbon.
int | GetGroupCaptionHeight () const
Gets the height of the group caption bar.
CXTPResourceImage * | LoadImage (LPCTSTR lpszFileName)
Loads a bitmap image from the specified path.
CXTPResourceImages * | GetImages () const
This method is called to get a pointer to the CXTPResourceImages object.
CXTPTabPaintManager * | GetTabPaintManager () const
Call this member to get a pointer to the tab paint manager.
CXTPFramePaintManager * | GetFramePaintManager () const
Call this member to get a pointer to the frame paint manager.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPRibbonPaintManager
BOOL | m_bHotTrackingGroups
TRUE to highlight the group under the cursor.
BOOL | m_bFlatFrame
TRUE to draw a flat frame.
CXTPPaintManagerFont | m_fontGroupCaption
Font used to draw text in the group caption.
COLORREF | m_clrRecentFileListEdgeShadow
Color of the File List edge shadow.
COLORREF | m_clrRecentFileListEdgeHighLight
Color of the File List edge highlight.
int | m_nTabsHeight
Tabs heights.
int | m_nGroupSpacing
Group spacing.
int | m_nGroupCaptionHeight
Group caption bar height.
- Protected Member Functions inherited from CXTPRibbonOffice2013Theme
virtual CString | GetBackImageName ()
This member function is used to get the name of the background image located in the Office 2013 resource .DLL.
virtual void | DrawBackImage (CDC *pDC, CXTPRibbonBar *pRibbonBar)
Used by the theme to draw the background image for the ribbon bar.
virtual void | LoadParts (BOOL bReload=FALSE)
Loads markup parts.
- Protected Member Functions inherited from CXTPRibbonMarkupTheme
- Protected Member Functions inherited from CXTPRibbonPaintManager
virtual CXTPTabPaintManager * | CreateTabPaintManager ()
Creates a CXTPTabPaintManager object used to store the color and appearance information of the tabs in the ribbon bar.
void | DrawRibbonApplicationIcon (CDC *pDC, CXTPRibbonBar *pRibbonBar, CRect rc, HICON hIcon)
This method is called to draw a ribbon bar application icon.
void | DrawDwmCaptionText (CDC *pDC, CRect rcCaptionText, CString strText, CWnd *pSite, BOOL bActive)
This method is called to draw caption text for an aero-transparent caption.
- Protected Attributes inherited from CXTPRibbonOffice2013Theme
XTPRIBBON_HEADER_COLOR | m_clrHeader [24]
Array of color values used for rendering the Ribbon's.
COLORREF | m_clrRibbonInactiveFaceState
context tabs.
COLORREF | m_clrTabBackInactiveState
Color of the ribbon tab when the application is inactive.
COLORREF | m_clrTabBackackstageLeft
Color of left part of the ribbon tab when new backstage is.
COLORREF | m_clrTabBackackstageRight
pop-up.
COLORREF | m_clrRibbonTabDelimeter
is pop-up.
- Protected Attributes inherited from CXTPRibbonMarkupTheme
COLORREF | m_clrBackstageSysButtonBack2013Normal
The color of "back" button in backstage if the button is not selected.
COLORREF | m_clrBackstageSysButtonBack2013Highlighted
The color of "back" button in backstage if the button is selected.
CString | m_strHighlightedPrefix
The prefix of the file name for the backstage "back" button image used for the selected button.
CString | m_strNormalPrefix
The prefix of the file name for the backstage "back" button image used for the not selected button.
CXTPMarkupContext * | m_pMarkupContext
Store pointer to a CXTPMarkupContext object.
- Protected Attributes inherited from CXTPRibbonPaintManager
COLORREF | m_clrRibbonFace
Ribbon face color.
COLORREF | m_clrRibbonBorder
Ribbon border color.
COLORREF | m_clrRibbonGroupCaptionText
Ribbon group captions color.
COLORREF | m_clrRibbonInactiveFace
Color of the ribbon when it is inactive.
COLORREF | m_clrFileButtonText
Text caption to display when the system button is displayed as a tab button (Windows 7 style).
COLORREF | m_clrMinimizedFrameEdgeHighLight
Minimized bottom edge.
COLORREF | m_clrMinimizedFrameEdgeShadow
Minimized bottom edge shadow.
CXTPPaintManager * | m_pPaintManager
Paint manager used for the ribbon.
CXTPTabPaintManager * | m_pTabPaintManager
Tab paint manager.
CRect | m_rcFileButtonMargin
Margins of the system button when it is displayed as a tab button (Windows 7 style).

Detailed Description

CXTPRibbonThemeNativeWindows11 is a CXTPRibbonOffice2013Theme derived class used to represent a Native Windows 10 ribbon theme.

Constructor & Destructor Documentation

◆ CXTPRibbonThemeNativeWindows11()

CXTPRibbonThemeNativeWindows11 ( CXTPPaintManager * pPaintManager )

Constructs a CXTPRibbonThemeNativeWindows11 object.

Parameters
pPaintManager A CXTPPaintManager object.

Member Function Documentation

◆ DrawRibbonFrameContextHeaders()

virtual void DrawRibbonFrameContextHeaders | ( | CDC * | pDC,
 |  | CXTPRibbonBar * | pRibbonBar,
 |  | CXTPRibbonTabContextHeaders * | pContextHeaders )
 virtual

This method is called to draw ribbon context headers.

Parameters
pDC | Pointer to a valid device context.
pContextHeaders | Collection of context headers.
pRibbonBar | Pointer to the parent ribbon bar.

Reimplemented from CXTPRibbonOffice2013Theme.

◆ DrawRibbonTab()

virtual void DrawRibbonTab | ( | CDC * | pDC,
 |  | CXTPRibbonTab * | pItem )
 virtual

This method is called to draw a single tab of the ribbon bar.

Parameters
pDC | Pointer to a valid device context.
pItem | Ribbon tab to draw.

Reimplemented from CXTPRibbonOffice2013Theme.

◆ FillGroupRect()

void FillGroupRect | ( | CDC * | pDC,
 |  | CXTPRibbonTab * | pActiveTab,
 |  | CRect | rcGroups )
 virtual

This method is called to fill the background of a CXTPRibbonGroup.

Parameters
pDC | Pointer to a valid device context.
pActiveTab | Pointer to the tab that is currently active.
rcGroups | Bounding rectangle of the group.

Performs a gradient fill using the GROUP_COLOR::clrBackground for the main group background and GROUP_COLOR::clrCaption to fill the group caption rectangle.

See also
CXTPRibbonGroup::GetRect, GROUP_COLOR

Reimplemented from CXTPRibbonMarkupTheme.

◆ RefreshMetrics()

virtual void RefreshMetrics ( )
virtual

This method is called to refresh the visual metrics of the manager.

Refreshes all of the colors in the ribbon bar. Many of the colors used are set with the GROUP_COLOR structure.

See also
GROUP_COLOR

Reimplemented from CXTPRibbonOffice2013Theme.

The documentation for this class was generated from the following file:
  • XTPRibbonThemeNativeWindows11.h


Toolkit Pro: CXTPRibbonThemeOffice2007System Class Reference

Public Member Functions | List of all members
CXTPRibbonThemeOffice2007System Class Reference

CXTPRibbonThemeOffice2007System is a CXTPRibbonMarkupTheme derived class used to represent an Office 2007 ribbon theme. More...

Inheritance diagram for CXTPRibbonThemeOffice2007System:
[legend]

Public Member Functions

CXTPRibbonThemeOffice2007System (CXTPPaintManager *pPaintManager)
Constructs a CXTPRibbonThemeOffice2007System object.
virtual | ~CXTPRibbonThemeOffice2007System ()
Destroys a CXTPRibbonThemeOffice2007System object, handles cleanup and deallocation.
virtual void | RefreshMetrics ()
This method is called to refresh the visual metrics of the manager.
virtual void | DrawRibbonQuickAccessControls (CDC *pDC, CXTPRibbonBar *pRibbonBar)
This method is called to draw ribbon Quick Access controls.
virtual int | GetRibbonCaptionHeight (const CXTPRibbonBar *pRibbonBar) const
Calculates the ribbon caption height.
virtual void | DrawRibbonQuickAccessButton (CDC *pDC, CXTPControlPopup *pControl)
This method is called to draw the Quick Access customize button.
virtual void | LoadParts (BOOL bReload=FALSE)
Loads markup parts.
- Public Member Functions inherited from CXTPRibbonMarkupTheme
CXTPRibbonMarkupTheme (CXTPPaintManager *pPaintManager)
Constructs a CXTPRibbonMarkupTheme object.
virtual | ~CXTPRibbonMarkupTheme ()
Destroys a CXTPRibbonMarkupTheme object, handles cleanup and deallocation.
void | LoadParts (HZIP hZip, CXTPMarkupContext *pMarkupContext=NULL)
Loads markup parts from the specified ZIP source.
void | FillRibbonBar (CDC *pDC, CXTPRibbonBar *pRibbonBar)
This method is called to fill the background of a ribbon bar control.
void | FillGroupRect (CDC *pDC, CXTPRibbonTab *pActiveTab, CRect rcGroups)
This method is called to fill the background of a CXTPRibbonGroup.
void | DrawGroup (CDC *pDC, CXTPRibbonGroup *pGroup)
Draws the specified CXTPRibbonGroup.
void | RenderMarkup (CDC *pDC, CRect rc, LPCTSTR lpszText)
Renders a Markup string in the Ribbon.
void | RenderMarkup (CDC *pDC, CRect rc, XTPRibbonThemePart part)
Renders a Markup string in the Ribbon.
CSize | DrawControlGroupOption (CDC *pDC, CXTPControl *pControlGroupOption, BOOL bDraw)
Draws the group option button.
CSize | GetControlGroupOptionSize () const
Calculates the ribbon group option size.
CSize | DrawControlGroupPopup (CDC *pDC, CXTPControlPopup *pControlGroupPopup, BOOL bDraw)
Draws the group pop-up button.
void | FillGroupPopupToolBar (CDC *pDC, CXTPRibbonGroup *pGroup, CXTPCommandBar *pCommandBar)
This method is called to draw the pop-up toolbar of a reduced group.
void | DrawRibbonQuickAccessMoreButton (CDC *pDC, CXTPControlPopup *pControl)
This method is called to draw the Quick Access more button.
void | FillMorePopupToolBarEntry (CDC *pDC, CXTPCommandBar *pBar)
This method is called to draw the pop-up bar of the more button.
virtual void | DrawRibbonTab (CDC *pDC, CXTPRibbonTab *pItem)
This method is called to draw a single tab of the ribbon bar.
void | FillSystemPopupBarEntry (CDC *pDC, CXTPPopupBar *pBar)
This method is called to draw the pop-up bar of the system button.
void | DrawSystemPopupBarButton (CDC *pDC, CXTPControl *pButton)
This method is called to draw a pop-up bar button.
void | DrawRibbonScrollButton (CDC *pDC, CXTPControl *pControl, BOOL bScrollLeft)
This method is called to draw scroll group buttons.
void | DrawRibbonFrameSystemButton (CDC *pDC, CXTPRibbonControlSystemButton *pControl, CRect rc)
Draws the top-left system button.
BOOL | DrawRibbonGroupControlEntry (CDC *pDC, CXTPControl *pButton)
This method is called to draw the ribbon group when the group is minimized and only a button is displayed.
void | DrawRibbonGroupPopupToolBar (CDC *pDC, CXTPRibbonGroup *pRibbonGroup)
This method is called to draw the ribbon group pop-up toolbar.
virtual void | DrawRibbonFrameCaptionBar (CDC *pDC, CXTPRibbonBar *pRibbonBar, BOOL bActive)
This method is called to draw the ribbon caption if EnableFrameTheme was not called.
virtual void | DrawRibbonFrameCaption (CDC *pDC, CXTPRibbonBar *pRibbonBar, BOOL bActive)
This method is called to draw the Ribbon caption.
virtual void | DrawRibbonFrameContextHeaders (CDC *pDC, CXTPRibbonBar *pRibbonBar, CXTPRibbonTabContextHeaders *pContextHeaders)
This method is called to draw ribbon context headers.
virtual void | FillRibbonTabControl (CDC *pDC, CXTPRibbonBar *pRibbonBar, CRect rcControl)
This member fills in the tab header and tab client area.
- Public Member Functions inherited from CXTPRibbonPaintManager
CXTPRibbonPaintManager (CXTPPaintManager *pPaintManager)
Constructs a CXTPRibbonPaintManager object.
virtual | ~CXTPRibbonPaintManager ()
Destroys a CXTPRibbonPaintManager object, handles cleanup and deallocation.
virtual void | DrawQuickAccessControl (CDC *pDC, CXTPRibbonBar *pRibbon, CXTPControl *pControl)
Draws the specified control which is a part of the Quick Access panel.
virtual void | FillTabPopupToolBar (CDC *pDC, CXTPPopupToolBar *pPopupToolBar)
This method is called to draw the background of a minimized pop-up bar.
virtual void | DrawRibbonFramePart (CDC *pDC, CXTPRibbonBar *pRibbonBar)
This method is called to draw the ribbon frame if EnableFrameTheme was not called.
int | GetEditHeight () const
Gets the edit control height.
void | SetFontHeight (int nFontHeight)
Sets the font height used for Ribbon.
int | GetFontHeight () const
Gets the font height used for Ribbon.
int | GetGroupCaptionHeight () const
Gets the height of the group caption bar.
CXTPResourceImage * | LoadImage (LPCTSTR lpszFileName)
Loads a bitmap image from the specified path.
CXTPResourceImages * | GetImages () const
This method is called to get a pointer to the CXTPResourceImages object.
CXTPTabPaintManager * | GetTabPaintManager () const
Call this member to get a pointer to the tab paint manager.
CXTPFramePaintManager * | GetFramePaintManager () const
Call this member to get a pointer to the frame paint manager.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPRibbonPaintManager
BOOL | m_bHotTrackingGroups
TRUE to highlight the group under the cursor.
BOOL | m_bFlatFrame
TRUE to draw a flat frame.
CXTPPaintManagerFont | m_fontGroupCaption
Font used to draw text in the group caption.
COLORREF | m_clrRecentFileListEdgeShadow
Color of the File List edge shadow.
COLORREF | m_clrRecentFileListEdgeHighLight
Color of the File List edge highlight.
int | m_nTabsHeight
Tabs heights.
int | m_nGroupSpacing
Group spacing.
int | m_nGroupCaptionHeight
Group caption bar height.
- Protected Member Functions inherited from CXTPRibbonMarkupTheme
- Protected Member Functions inherited from CXTPRibbonPaintManager
virtual CXTPTabPaintManager * | CreateTabPaintManager ()
Creates a CXTPTabPaintManager object used to store the color and appearance information of the tabs in the ribbon bar.
void | DrawRibbonApplicationIcon (CDC *pDC, CXTPRibbonBar *pRibbonBar, CRect rc, HICON hIcon)
This method is called to draw a ribbon bar application icon.
void | DrawDwmCaptionText (CDC *pDC, CRect rcCaptionText, CString strText, CWnd *pSite, BOOL bActive)
This method is called to draw caption text for an aero-transparent caption.
- Protected Attributes inherited from CXTPRibbonMarkupTheme
COLORREF | m_clrBackstageSysButtonBack2013Normal
The color of "back" button in backstage if the button is not selected.
COLORREF | m_clrBackstageSysButtonBack2013Highlighted
The color of "back" button in backstage if the button is selected.
CString | m_strHighlightedPrefix
The prefix of the file name for the backstage "back" button image used for the selected button.
CString | m_strNormalPrefix
The prefix of the file name for the backstage "back" button image used for the not selected button.
CXTPMarkupContext * | m_pMarkupContext
Store pointer to a CXTPMarkupContext object.
- Protected Attributes inherited from CXTPRibbonPaintManager
COLORREF | m_clrRibbonFace
Ribbon face color.
COLORREF | m_clrRibbonBorder
Ribbon border color.
COLORREF | m_clrRibbonGroupCaptionText
Ribbon group captions color.
COLORREF | m_clrRibbonInactiveFace
Color of the ribbon when it is inactive.
COLORREF | m_clrFileButtonText
Text caption to display when the system button is displayed as a tab button (Windows 7 style).
COLORREF | m_clrMinimizedFrameEdgeHighLight
Minimized bottom edge.
COLORREF | m_clrMinimizedFrameEdgeShadow
Minimized bottom edge shadow.
CXTPPaintManager * | m_pPaintManager
Paint manager used for the ribbon.
CXTPTabPaintManager * | m_pTabPaintManager
Tab paint manager.
CRect | m_rcFileButtonMargin
Margins of the system button when it is displayed as a tab button (Windows 7 style).

Detailed Description

CXTPRibbonThemeOffice2007System is a CXTPRibbonMarkupTheme derived class used to represent an Office 2007 ribbon theme.

Constructor & Destructor Documentation

◆ CXTPRibbonThemeOffice2007System()

CXTPRibbonThemeOffice2007System ( CXTPPaintManager * pPaintManager )

Constructs a CXTPRibbonThemeOffice2007System object.

Parameters
pPaintManager A CXTPPaintManager object.

Member Function Documentation

◆ DrawRibbonQuickAccessButton()

virtual void DrawRibbonQuickAccessButton | ( | CDC * | pDC,
 |  | CXTPControlPopup * | pControl )
 virtual

This method is called to draw the Quick Access customize button.

Parameters
pDC | Pointer to a valid device context.
pControl | Pointer to the Quick Access customize button.
See also
DrawRibbonQuickAccessMoreButton

Reimplemented from CXTPRibbonMarkupTheme.

◆ DrawRibbonQuickAccessControls()

virtual void DrawRibbonQuickAccessControls | ( | CDC * | pDC,
 |  | CXTPRibbonBar * | pRibbonBar )
 virtual

This method is called to draw ribbon Quick Access controls.

Parameters
pDC | Pointer to a valid device context.
pRibbonBar | Pointer to the parent ribbon bar.

Reimplemented from CXTPRibbonMarkupTheme.

◆ GetRibbonCaptionHeight()

virtual int GetRibbonCaptionHeight ( const CXTPRibbonBar * pRibbonBar ) const
virtual

Calculates the ribbon caption height.

Parameters
pRibbonBar Pointer to the parent ribbon bar.
Returns
The ribbon caption height.

Implements CXTPRibbonPaintManager.

◆ LoadParts()

virtual void LoadParts ( BOOL bReload = FALSE )
virtual

Loads markup parts.

Parameters
bReload Re-loads previously loaded parts if TRUE.

Implements CXTPRibbonMarkupTheme.

◆ RefreshMetrics()

virtual void RefreshMetrics ( )
virtual

This method is called to refresh the visual metrics of the manager.

Refreshes all of the colors in the ribbon bar. Many of the colors used are set with the GROUP_COLOR structure.

See also
GROUP_COLOR

Reimplemented from CXTPRibbonMarkupTheme.

The documentation for this class was generated from the following file:
  • XTPRibbonThemeOffice2007System.h


Toolkit Pro: CXTPRibbonThemeResource Class Reference

Public Member Functions | List of all members
CXTPRibbonThemeResource Class Reference

CXTPRibbonThemeResource is a CXTPRibbonPaintManager derived class used to represent a Resource .DLL ribbon theme. More...

Inheritance diagram for CXTPRibbonThemeResource:
[legend]

Public Member Functions

CXTPRibbonThemeResource (CXTPPaintManager *pPaintManager)
Constructs a CXTPRibbonThemeResource object.
virtual | ~CXTPRibbonThemeResource ()
Destroys a CXTPRibbonThemeResource object, handles cleanup and deallocation.
virtual void | RefreshMetrics ()
This method is called to refresh the visual metrics of the manager.
virtual void | DrawGroup (CDC *pDC, CXTPRibbonGroup *pGroup)
Draws the specified CXTPRibbonGroup.
virtual void | FillGroupRect (CDC *pDC, CXTPRibbonTab *pActiveTab, CRect rcGroups)
This method is called to fill the background of a CXTPRibbonGroup.
virtual CSize | DrawControlGroupPopup (CDC *pDC, CXTPControlPopup *pControlGroupPopup, BOOL bDraw)
Draws the group pop-up button.
virtual void | FillGroupPopupToolBar (CDC *pDC, CXTPRibbonGroup *pGroup, CXTPCommandBar *pCommandBar)
This method is called to draw the pop-up toolbar of a reduced group.
virtual void | FillRibbonBar (CDC *pDC, CXTPRibbonBar *pRibbonBar)
This method is called to fill the background of a ribbon bar control.
virtual CSize | DrawControlGroupOption (CDC *pDC, CXTPControl *pControlGroupOption, BOOL bDraw)
Draws the group option button.
virtual void | DrawRibbonFrameContextHeaders (CDC *pDC, CXTPRibbonBar *pRibbonBar, CXTPRibbonTabContextHeaders *pContextHeaders)
This method is called to draw ribbon context headers.
virtual void | FillRibbonTabControl (CDC *pDC, CXTPRibbonBar *pRibbonBar, CRect rcControl)
This member fills in the tab header and tab client area.
virtual void | DrawRibbonTab (CDC *pDC, CXTPRibbonTab *pItem)
This method is called to draw a single tab of the ribbon bar.
virtual void | DrawRibbonFrameCaptionBar (CDC *pDC, CXTPRibbonBar *pRibbonBar, BOOL bActive)
This method is called to draw the ribbon caption if EnableFrameTheme was not called.
virtual void | DrawRibbonFrameCaption (CDC *pDC, CXTPRibbonBar *pRibbonBar, BOOL bActive)
This method is called to draw the Ribbon caption.
virtual void | DrawRibbonQuickAccessControls (CDC *pDC, CXTPRibbonBar *pRibbonBar)
This method is called to draw ribbon Quick Access controls.
virtual void | DrawRibbonQuickAccessButton (CDC *pDC, CXTPControlPopup *pControl)
This method is called to draw the Quick Access customize button.
virtual void | DrawRibbonQuickAccessMoreButton (CDC *pDC, CXTPControlPopup *pControl)
This method is called to draw the Quick Access more button.
virtual void | DrawRibbonFrameSystemButton (CDC *pDC, CXTPRibbonControlSystemButton *pControl, CRect rc)
Draws the top-left system button.
virtual void | DrawRibbonScrollButton (CDC *pDC, CXTPControl *pControl, BOOL bScrollLeft)
This method is called to draw scroll group buttons.
virtual void | FillMorePopupToolBarEntry (CDC *pDC, CXTPCommandBar *pBar)
This method is called to draw the pop-up bar of the more button.
virtual void | FillSystemPopupBarEntry (CDC *pDC, CXTPPopupBar *pBar)
This method is called to draw the pop-up bar of the system button.
virtual void | DrawSystemPopupBarButton (CDC *pDC, CXTPControl *pButton)
This method is called to draw a pop-up bar button.
virtual BOOL | DrawRibbonGroupControlEntry (CDC *pDC, CXTPControl *pButton)
This method is called to draw the ribbon group when the group is minimized and only a button is displayed.
virtual int | GetRibbonCaptionHeight (const CXTPRibbonBar *pRibbonBar) const
Calculates the ribbon caption height.
virtual CSize | GetControlGroupOptionSize () const
Calculates the ribbon group option size.
- Public Member Functions inherited from CXTPRibbonPaintManager
CXTPRibbonPaintManager (CXTPPaintManager *pPaintManager)
Constructs a CXTPRibbonPaintManager object.
virtual | ~CXTPRibbonPaintManager ()
Destroys a CXTPRibbonPaintManager object, handles cleanup and deallocation.
virtual void | DrawQuickAccessControl (CDC *pDC, CXTPRibbonBar *pRibbon, CXTPControl *pControl)
Draws the specified control which is a part of the Quick Access panel.
virtual void | FillTabPopupToolBar (CDC *pDC, CXTPPopupToolBar *pPopupToolBar)
This method is called to draw the background of a minimized pop-up bar.
virtual void | DrawRibbonFramePart (CDC *pDC, CXTPRibbonBar *pRibbonBar)
This method is called to draw the ribbon frame if EnableFrameTheme was not called.
virtual void | DrawRibbonGroupPopupToolBar (CDC *pDC, CXTPRibbonGroup *pRibbonGroup)
This method is called to draw the ribbon group pop-up toolbar.
int | GetEditHeight () const
Gets the edit control height.
void | SetFontHeight (int nFontHeight)
Sets the font height used for Ribbon.
int | GetFontHeight () const
Gets the font height used for Ribbon.
int | GetGroupCaptionHeight () const
Gets the height of the group caption bar.
CXTPResourceImage * | LoadImage (LPCTSTR lpszFileName)
Loads a bitmap image from the specified path.
CXTPResourceImages * | GetImages () const
This method is called to get a pointer to the CXTPResourceImages object.
CXTPTabPaintManager * | GetTabPaintManager () const
Call this member to get a pointer to the tab paint manager.
CXTPFramePaintManager * | GetFramePaintManager () const
Call this member to get a pointer to the frame paint manager.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPRibbonPaintManager
BOOL | m_bHotTrackingGroups
TRUE to highlight the group under the cursor.
BOOL | m_bFlatFrame
TRUE to draw a flat frame.
CXTPPaintManagerFont | m_fontGroupCaption
Font used to draw text in the group caption.
COLORREF | m_clrRecentFileListEdgeShadow
Color of the File List edge shadow.
COLORREF | m_clrRecentFileListEdgeHighLight
Color of the File List edge highlight.
int | m_nTabsHeight
Tabs heights.
int | m_nGroupSpacing
Group spacing.
int | m_nGroupCaptionHeight
Group caption bar height.
- Protected Member Functions inherited from CXTPRibbonPaintManager
virtual CXTPTabPaintManager * | CreateTabPaintManager ()
Creates a CXTPTabPaintManager object used to store the color and appearance information of the tabs in the ribbon bar.
void | DrawRibbonApplicationIcon (CDC *pDC, CXTPRibbonBar *pRibbonBar, CRect rc, HICON hIcon)
This method is called to draw a ribbon bar application icon.
void | DrawDwmCaptionText (CDC *pDC, CRect rcCaptionText, CString strText, CWnd *pSite, BOOL bActive)
This method is called to draw caption text for an aero-transparent caption.
- Protected Attributes inherited from CXTPRibbonPaintManager
COLORREF | m_clrRibbonFace
Ribbon face color.
COLORREF | m_clrRibbonBorder
Ribbon border color.
COLORREF | m_clrRibbonGroupCaptionText
Ribbon group captions color.
COLORREF | m_clrRibbonInactiveFace
Color of the ribbon when it is inactive.
COLORREF | m_clrFileButtonText
Text caption to display when the system button is displayed as a tab button (Windows 7 style).
COLORREF | m_clrMinimizedFrameEdgeHighLight
Minimized bottom edge.
COLORREF | m_clrMinimizedFrameEdgeShadow
Minimized bottom edge shadow.
CXTPPaintManager * | m_pPaintManager
Paint manager used for the ribbon.
CXTPTabPaintManager * | m_pTabPaintManager
Tab paint manager.
CRect | m_rcFileButtonMargin
Margins of the system button when it is displayed as a tab button (Windows 7 style).

Detailed Description

CXTPRibbonThemeResource is a CXTPRibbonPaintManager derived class used to represent a Resource .DLL ribbon theme.

Constructor & Destructor Documentation

◆ CXTPRibbonThemeResource()

CXTPRibbonThemeResource ( CXTPPaintManager * pPaintManager )

Constructs a CXTPRibbonThemeResource object.

Parameters
pPaintManager A CXTPPaintManager object.

Member Function Documentation

◆ DrawControlGroupOption()

virtual CSize DrawControlGroupOption | ( | CDC * | pDC,
 |  | CXTPControl * | pControlGroupOption,
 |  | BOOL | bDraw )
 virtual

Draws the group option button.

Parameters
pDC | Pointer to a valid device context.
pControlGroupOption | Pointer to a CXTPControl object.
bDraw | TRUE to draw option button, FALSE to retrieve the size of the control.

The option button is typically used to launch a dialog associated with the group. It is drawn on the right side of the group caption.

Returns
If bDraw is FALSE, then the size of the option button control will be returned.
See also
CXTPRibbonGroup::ShowOptionButton, CXTPRibbonGroup::GetControlGroupOption

Implements CXTPRibbonPaintManager.

◆ DrawControlGroupPopup()

virtual CSize DrawControlGroupPopup | ( | CDC * | pDC,
 |  | CXTPControlPopup * | pControlGroupPopup,
 |  | BOOL | bDraw )
 virtual

Draws the group pop-up button.

Parameters
pDC | Pointer to a valid device context
pControlGroupPopup | Pointer to a CXTPControlPopup object.
bDraw | TRUE to draw the group pop-up button, FALSE to retrieve the size of the control.

A single group button will be displayed if there is not enough room to display the items in the group. A group pop-up is displayed when the button is clicked. The pop-up contains all the items in the group. When a group button is clicked, a CXTPControlPopup is displayed that contains the items of the group.

Returns
If bDraw is FALSE, then the size of the group pop-up button control will be returned.
See also
CXTPRibbonGroup::GetControlGroupPopup

Implements CXTPRibbonPaintManager.

◆ DrawGroup()

virtual void DrawGroup | ( | CDC * | pDC,
 |  | CXTPRibbonGroup * | pGroup )
 virtual

Draws the specified CXTPRibbonGroup.

Parameters
pDC | Pointer to a valid device context.
pGroup | Pointer to the CXTPRibbonGroup to be drawn.

Draws the entire group including background, caption, and text. This will not draw the option button or the group pop-up.

See also
GROUP_COLOR, FillRibbonBar, FillGroupRect, RefreshMetrics

Implements CXTPRibbonPaintManager.

◆ DrawRibbonFrameCaption()

virtual void DrawRibbonFrameCaption | ( | CDC * | pDC,
 |  | CXTPRibbonBar * | pRibbonBar,
 |  | BOOL | bActive )
 virtual

This method is called to draw the Ribbon caption.

Parameters
pDC | Pointer to a valid device context.
pRibbonBar | Pointer to the ribbon bar to draw the caption for.
bActive | TRUE if the ribbon frame is active.

Implements CXTPRibbonPaintManager.

◆ DrawRibbonFrameCaptionBar()

virtual void DrawRibbonFrameCaptionBar | ( | CDC * | pDC,
 |  | CXTPRibbonBar * | pRibbonBar,
 |  | BOOL | bActive )
 virtual

This method is called to draw the ribbon caption if EnableFrameTheme was not called.

Parameters
pDC | Pointer to a valid device context.
pRibbonBar | Pointer to the ribbon bar to draw the caption for.
bActive | TRUE if the ribbon frame is active.

Implements CXTPRibbonPaintManager.

◆ DrawRibbonFrameContextHeaders()

virtual void DrawRibbonFrameContextHeaders | ( | CDC * | pDC,
 |  | CXTPRibbonBar * | pRibbonBar,
 |  | CXTPRibbonTabContextHeaders * | pContextHeaders )
 virtual

This method is called to draw ribbon context headers.

Parameters
pDC | Pointer to a valid device context.
pContextHeaders | Collection of context headers.
pRibbonBar | Pointer to the parent ribbon bar.

Implements CXTPRibbonPaintManager.

◆ DrawRibbonFrameSystemButton()

virtual void DrawRibbonFrameSystemButton | ( | CDC * | pDC,
 |  | CXTPRibbonControlSystemButton * | pControl,
 |  | CRect | rc )
 virtual

Draws the top-left system button.

Parameters
pDC | Pointer to a valid device context.
pControl | System button control.
rc | Bounding rectangle of the control.

Implements CXTPRibbonPaintManager.

◆ DrawRibbonGroupControlEntry()

virtual BOOL DrawRibbonGroupControlEntry | ( | CDC * | pDC,
 |  | CXTPControl * | pButton )
 virtual

This method is called to draw the ribbon group when the group is minimized and only a button is displayed.

When the button is pressed, the group is displayed as a pop-up.

Parameters
pDC | Pointer to a valid device context.
pButton | Button to draw.
Returns
TRUE if successful, FALSE otherwise.

Implements CXTPRibbonPaintManager.

◆ DrawRibbonQuickAccessButton()

virtual void DrawRibbonQuickAccessButton | ( | CDC * | pDC,
 |  | CXTPControlPopup * | pControl )
 virtual

This method is called to draw the Quick Access customize button.

Parameters
pDC | Pointer to a valid device context.
pControl | Pointer to the Quick Access customize button.
See also
DrawRibbonQuickAccessMoreButton

Implements CXTPRibbonPaintManager.

◆ DrawRibbonQuickAccessControls()

virtual void DrawRibbonQuickAccessControls | ( | CDC * | pDC,
 |  | CXTPRibbonBar * | pRibbonBar )
 virtual

This method is called to draw ribbon Quick Access controls.

Parameters
pDC | Pointer to a valid device context.
pRibbonBar | Pointer to the parent ribbon bar.

◆ DrawRibbonQuickAccessMoreButton()

virtual void DrawRibbonQuickAccessMoreButton | ( | CDC * | pDC,
 |  | CXTPControlPopup * | pControl )
 virtual

This method is called to draw the Quick Access more button.

Parameters
pDC | Pointer to a valid device context.
pControl | Pointer to the Quick Access more button.
See also
DrawRibbonQuickAccessButton

Implements CXTPRibbonPaintManager.

◆ DrawRibbonScrollButton()

virtual void DrawRibbonScrollButton | ( | CDC * | pDC,
 |  | CXTPControl * | pControl,
 |  | BOOL | bScrollLeft )
 virtual

This method is called to draw scroll group buttons.

Parameters
pDC | Pointer to a valid device context.
pControl | Scroll button to draw.
bScrollLeft | TRUE to draw the left button, FALSE to draw the right.

Implements CXTPRibbonPaintManager.

◆ DrawRibbonTab()

virtual void DrawRibbonTab | ( | CDC * | pDC,
 |  | CXTPRibbonTab * | pItem )
 virtual

This method is called to draw a single tab of the ribbon bar.

Parameters
pDC | Pointer to a valid device context.
pItem | Ribbon tab to draw.

Implements CXTPRibbonPaintManager.

◆ DrawSystemPopupBarButton()

virtual void DrawSystemPopupBarButton | ( | CDC * | pDC,
 |  | CXTPControl * | pButton )
 virtual

This method is called to draw a pop-up bar button.

Parameters
pDC | Pointer to a valid device context.
pButton | Pop-up bar button to draw.

Implements CXTPRibbonPaintManager.

◆ FillGroupPopupToolBar()

virtual void FillGroupPopupToolBar | ( | CDC * | pDC,
 |  | CXTPRibbonGroup * | pGroup,
 |  | CXTPCommandBar * | pCommandBar )
 virtual

This method is called to draw the pop-up toolbar of a reduced group.

Parameters
pDC | Pointer to a valid device context.
pGroup | Parent group of pop-up'ed toolbar.
pCommandBar | Pop-up toolbar to draw.

Implements CXTPRibbonPaintManager.

◆ FillGroupRect()

virtual void FillGroupRect | ( | CDC * | pDC,
 |  | CXTPRibbonTab * | pActiveTab,
 |  | CRect | rcGroups )
 virtual

This method is called to fill the background of a CXTPRibbonGroup.

Parameters
pDC | Pointer to a valid device context.
pActiveTab | Pointer to the tab that is currently active.
rcGroups | Bounding rectangle of the group.

Performs a gradient fill using the GROUP_COLOR::clrBackground for the main group background and GROUP_COLOR::clrCaption to fill the group caption rectangle.

See also
CXTPRibbonGroup::GetRect, GROUP_COLOR

Implements CXTPRibbonPaintManager.

◆ FillMorePopupToolBarEntry()

virtual void FillMorePopupToolBarEntry | ( | CDC * | pDC,
 |  | CXTPCommandBar * | pBar )
 virtual

This method is called to draw the pop-up bar of the more button.

Parameters
pDC | Pointer to a valid device context.
pBar | Toolbar to fill.

Implements CXTPRibbonPaintManager.

◆ FillRibbonBar()

virtual void FillRibbonBar | ( | CDC * | pDC,
 |  | CXTPRibbonBar * | pRibbonBar )
 virtual

This method is called to fill the background of a ribbon bar control.

Parameters
pDC | Pointer to a valid device context
pRibbonBar | Pointer to the parent ribbon bar.

Implements CXTPRibbonPaintManager.

◆ FillRibbonTabControl()

virtual void FillRibbonTabControl | ( | CDC * | pDC,
 |  | CXTPRibbonBar * | pRibbonBar,
 |  | CRect | rcControl )
 virtual

This member fills in the tab header and tab client area.

It will then draw tab client frame.

Parameters
pRibbonBar | Pointer to the ribbon bar to draw the tab control for.
pDC | Pointer to a valid device context.
rcControl | Bounding rectangle of the tab control.

Implements CXTPRibbonPaintManager.

◆ FillSystemPopupBarEntry()

virtual void FillSystemPopupBarEntry | ( | CDC * | pDC,
 |  | CXTPPopupBar * | pBar )
 virtual

This method is called to draw the pop-up bar of the system button.

Parameters
pDC | Pointer to a valid device context.
pBar | Toolbar to fill.

Implements CXTPRibbonPaintManager.

◆ GetControlGroupOptionSize()

virtual CSize GetControlGroupOptionSize ( ) const
virtual

Calculates the ribbon group option size.

Returns
The ribbon group option size.

Implements CXTPRibbonPaintManager.

◆ GetRibbonCaptionHeight()

virtual int GetRibbonCaptionHeight ( const CXTPRibbonBar * pRibbonBar ) const
virtual

Calculates the ribbon caption height.

Parameters
pRibbonBar Pointer to the parent ribbon bar.
Returns
The ribbon caption height.

Implements CXTPRibbonPaintManager.

◆ RefreshMetrics()

virtual void RefreshMetrics ( )
virtual

This method is called to refresh the visual metrics of the manager.

Refreshes all of the colors in the ribbon bar. Many of the colors used are set with the GROUP_COLOR structure.

See also
GROUP_COLOR

Reimplemented from CXTPRibbonPaintManager.

The documentation for this class was generated from the following file:
  • XTPRibbonThemeResource.h


Toolkit Pro: CXTPRibbonThemeVisualStudio2015 Class Reference

Public Member Functions | List of all members
CXTPRibbonThemeVisualStudio2015 Class Reference

CXTPRibbonThemeVisualStudio2015 is a CXTPRibbonOffice2013Theme derived class used to represent a Visual Studio 2015 ribbon theme. More...

Inheritance diagram for CXTPRibbonThemeVisualStudio2015:
[legend]

Public Member Functions

CXTPRibbonThemeVisualStudio2015 (CXTPPaintManager *pPaintManager)
Constructs a CXTPRibbonThemeVisualStudio2015 object.
virtual | ~CXTPRibbonThemeVisualStudio2015 ()
Destroys a CXTPRibbonThemeVisualStudio2015 object, handles cleanup and deallocation.
- Public Member Functions inherited from CXTPRibbonOffice2013Theme
CXTPRibbonOffice2013Theme (CXTPPaintManager *pPaintManager)
Constructs a CXTPRibbonOffice2013Theme object.
virtual | ~CXTPRibbonOffice2013Theme ()
Destroys a CXTPRibbonOffice2013Theme object, handles cleanup and deallocation.
virtual void | RefreshMetrics ()
This method is called to refresh the visual metrics of the manager.
virtual int | GetRibbonCaptionHeight (const CXTPRibbonBar *pRibbonBar) const
Calculates the ribbon caption height.
virtual void | DrawQuickAccessControl (CDC *pDC, CXTPRibbonBar *pRibbon, CXTPControl *pControl)
Draws the specified control which is a part of the Quick Access panel.
virtual void | DrawRibbonTab (CDC *pDC, CXTPRibbonTab *pItem)
This method is called to draw a single tab of the ribbon bar.
virtual void | DrawRibbonFrameContextHeaders (CDC *pDC, CXTPRibbonBar *pRibbonBar, CXTPRibbonTabContextHeaders *pContextHeaders)
This method is called to draw ribbon context headers.
virtual void | FillRibbonBar (CDC *pDC, CXTPRibbonBar *pRibbonBar)
This method is called to fill the background of a ribbon bar control.
virtual void | DrawRibbonFrameCaptionBar (CDC *pDC, CXTPRibbonBar *pRibbonBar, BOOL bActive)
This method is called to draw the ribbon caption if EnableFrameTheme was not called.
virtual void | DrawRibbonFrameCaption (CDC *pDC, CXTPRibbonBar *pRibbonBar, BOOL bActive)
This method is called to draw the Ribbon caption.
virtual void | SetBackImage (int nImage)
This member function will set the background image for the Office ribbon bar.
virtual void | DrawRibbonFrameSystemButton (CDC *pDC, CXTPRibbonControlSystemButton *pControl, CRect rc)
Draws the top-left system button.
- Public Member Functions inherited from CXTPRibbonMarkupTheme
CXTPRibbonMarkupTheme (CXTPPaintManager *pPaintManager)
Constructs a CXTPRibbonMarkupTheme object.
virtual | ~CXTPRibbonMarkupTheme ()
Destroys a CXTPRibbonMarkupTheme object, handles cleanup and deallocation.
void | LoadParts (HZIP hZip, CXTPMarkupContext *pMarkupContext=NULL)
Loads markup parts from the specified ZIP source.
void | FillGroupRect (CDC *pDC, CXTPRibbonTab *pActiveTab, CRect rcGroups)
This method is called to fill the background of a CXTPRibbonGroup.
void | DrawGroup (CDC *pDC, CXTPRibbonGroup *pGroup)
Draws the specified CXTPRibbonGroup.
void | RenderMarkup (CDC *pDC, CRect rc, LPCTSTR lpszText)
Renders a Markup string in the Ribbon.
void | RenderMarkup (CDC *pDC, CRect rc, XTPRibbonThemePart part)
Renders a Markup string in the Ribbon.
CSize | DrawControlGroupOption (CDC *pDC, CXTPControl *pControlGroupOption, BOOL bDraw)
Draws the group option button.
CSize | GetControlGroupOptionSize () const
Calculates the ribbon group option size.
CSize | DrawControlGroupPopup (CDC *pDC, CXTPControlPopup *pControlGroupPopup, BOOL bDraw)
Draws the group pop-up button.
void | FillGroupPopupToolBar (CDC *pDC, CXTPRibbonGroup *pGroup, CXTPCommandBar *pCommandBar)
This method is called to draw the pop-up toolbar of a reduced group.
virtual void | DrawRibbonQuickAccessButton (CDC *pDC, CXTPControlPopup *pControl)
This method is called to draw the Quick Access customize button.
void | DrawRibbonQuickAccessMoreButton (CDC *pDC, CXTPControlPopup *pControl)
This method is called to draw the Quick Access more button.
void | FillMorePopupToolBarEntry (CDC *pDC, CXTPCommandBar *pBar)
This method is called to draw the pop-up bar of the more button.
void | FillSystemPopupBarEntry (CDC *pDC, CXTPPopupBar *pBar)
This method is called to draw the pop-up bar of the system button.
void | DrawSystemPopupBarButton (CDC *pDC, CXTPControl *pButton)
This method is called to draw a pop-up bar button.
void | DrawRibbonScrollButton (CDC *pDC, CXTPControl *pControl, BOOL bScrollLeft)
This method is called to draw scroll group buttons.
BOOL | DrawRibbonGroupControlEntry (CDC *pDC, CXTPControl *pButton)
This method is called to draw the ribbon group when the group is minimized and only a button is displayed.
void | DrawRibbonGroupPopupToolBar (CDC *pDC, CXTPRibbonGroup *pRibbonGroup)
This method is called to draw the ribbon group pop-up toolbar.
virtual void | DrawRibbonQuickAccessControls (CDC *pDC, CXTPRibbonBar *pRibbonBar)
This method is called to draw ribbon Quick Access controls.
virtual void | FillRibbonTabControl (CDC *pDC, CXTPRibbonBar *pRibbonBar, CRect rcControl)
This member fills in the tab header and tab client area.
- Public Member Functions inherited from CXTPRibbonPaintManager
CXTPRibbonPaintManager (CXTPPaintManager *pPaintManager)
Constructs a CXTPRibbonPaintManager object.
virtual | ~CXTPRibbonPaintManager ()
Destroys a CXTPRibbonPaintManager object, handles cleanup and deallocation.
virtual void | FillTabPopupToolBar (CDC *pDC, CXTPPopupToolBar *pPopupToolBar)
This method is called to draw the background of a minimized pop-up bar.
virtual void | DrawRibbonFramePart (CDC *pDC, CXTPRibbonBar *pRibbonBar)
This method is called to draw the ribbon frame if EnableFrameTheme was not called.
int | GetEditHeight () const
Gets the edit control height.
void | SetFontHeight (int nFontHeight)
Sets the font height used for Ribbon.
int | GetFontHeight () const
Gets the font height used for Ribbon.
int | GetGroupCaptionHeight () const
Gets the height of the group caption bar.
CXTPResourceImage * | LoadImage (LPCTSTR lpszFileName)
Loads a bitmap image from the specified path.
CXTPResourceImages * | GetImages () const
This method is called to get a pointer to the CXTPResourceImages object.
CXTPTabPaintManager * | GetTabPaintManager () const
Call this member to get a pointer to the tab paint manager.
CXTPFramePaintManager * | GetFramePaintManager () const
Call this member to get a pointer to the frame paint manager.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPRibbonPaintManager
BOOL | m_bHotTrackingGroups
TRUE to highlight the group under the cursor.
BOOL | m_bFlatFrame
TRUE to draw a flat frame.
CXTPPaintManagerFont | m_fontGroupCaption
Font used to draw text in the group caption.
COLORREF | m_clrRecentFileListEdgeShadow
Color of the File List edge shadow.
COLORREF | m_clrRecentFileListEdgeHighLight
Color of the File List edge highlight.
int | m_nTabsHeight
Tabs heights.
int | m_nGroupSpacing
Group spacing.
int | m_nGroupCaptionHeight
Group caption bar height.
- Protected Member Functions inherited from CXTPRibbonOffice2013Theme
virtual CString | GetBackImageName ()
This member function is used to get the name of the background image located in the Office 2013 resource .DLL.
virtual void | DrawBackImage (CDC *pDC, CXTPRibbonBar *pRibbonBar)
Used by the theme to draw the background image for the ribbon bar.
virtual void | LoadParts (BOOL bReload=FALSE)
Loads markup parts.
- Protected Member Functions inherited from CXTPRibbonMarkupTheme
- Protected Member Functions inherited from CXTPRibbonPaintManager
virtual CXTPTabPaintManager * | CreateTabPaintManager ()
Creates a CXTPTabPaintManager object used to store the color and appearance information of the tabs in the ribbon bar.
void | DrawRibbonApplicationIcon (CDC *pDC, CXTPRibbonBar *pRibbonBar, CRect rc, HICON hIcon)
This method is called to draw a ribbon bar application icon.
void | DrawDwmCaptionText (CDC *pDC, CRect rcCaptionText, CString strText, CWnd *pSite, BOOL bActive)
This method is called to draw caption text for an aero-transparent caption.
- Protected Attributes inherited from CXTPRibbonOffice2013Theme
XTPRIBBON_HEADER_COLOR | m_clrHeader [24]
Array of color values used for rendering the Ribbon's.
COLORREF | m_clrRibbonInactiveFaceState
context tabs.
COLORREF | m_clrTabBackInactiveState
Color of the ribbon tab when the application is inactive.
COLORREF | m_clrTabBackackstageLeft
Color of left part of the ribbon tab when new backstage is.
COLORREF | m_clrTabBackackstageRight
pop-up.
COLORREF | m_clrRibbonTabDelimeter
is pop-up.
- Protected Attributes inherited from CXTPRibbonMarkupTheme
COLORREF | m_clrBackstageSysButtonBack2013Normal
The color of "back" button in backstage if the button is not selected.
COLORREF | m_clrBackstageSysButtonBack2013Highlighted
The color of "back" button in backstage if the button is selected.
CString | m_strHighlightedPrefix
The prefix of the file name for the backstage "back" button image used for the selected button.
CString | m_strNormalPrefix
The prefix of the file name for the backstage "back" button image used for the not selected button.
CXTPMarkupContext * | m_pMarkupContext
Store pointer to a CXTPMarkupContext object.
- Protected Attributes inherited from CXTPRibbonPaintManager
COLORREF | m_clrRibbonFace
Ribbon face color.
COLORREF | m_clrRibbonBorder
Ribbon border color.
COLORREF | m_clrRibbonGroupCaptionText
Ribbon group captions color.
COLORREF | m_clrRibbonInactiveFace
Color of the ribbon when it is inactive.
COLORREF | m_clrFileButtonText
Text caption to display when the system button is displayed as a tab button (Windows 7 style).
COLORREF | m_clrMinimizedFrameEdgeHighLight
Minimized bottom edge.
COLORREF | m_clrMinimizedFrameEdgeShadow
Minimized bottom edge shadow.
CXTPPaintManager * | m_pPaintManager
Paint manager used for the ribbon.
CXTPTabPaintManager * | m_pTabPaintManager
Tab paint manager.
CRect | m_rcFileButtonMargin
Margins of the system button when it is displayed as a tab button (Windows 7 style).

Detailed Description

CXTPRibbonThemeVisualStudio2015 is a CXTPRibbonOffice2013Theme derived class used to represent a Visual Studio 2015 ribbon theme.

Constructor & Destructor Documentation

◆ CXTPRibbonThemeVisualStudio2015()

CXTPRibbonThemeVisualStudio2015 ( CXTPPaintManager * pPaintManager )

Constructs a CXTPRibbonThemeVisualStudio2015 object.

Parameters
pPaintManager A CXTPPaintManager object.
The documentation for this class was generated from the following file:
  • XTPRibbonThemeVisualStudio2015.h


Toolkit Pro: CXTPRibbonThemeVisualStudio2017 Class Reference

Public Member Functions | List of all members
CXTPRibbonThemeVisualStudio2017 Class Reference

CXTPRibbonThemeVisualStudio2017 is a CXTPRibbonOffice2013Theme derived class used to represent a Visual Studio 2017 ribbon theme. More...

Inheritance diagram for CXTPRibbonThemeVisualStudio2017:
[legend]

Public Member Functions

CXTPRibbonThemeVisualStudio2017 (CXTPPaintManager *pPaintManager)
Constructs a CXTPRibbonThemeVisualStudio2017 object.
virtual | ~CXTPRibbonThemeVisualStudio2017 ()
Destroys a CXTPRibbonThemeVisualStudio2017 object, handles cleanup and deallocation.
- Public Member Functions inherited from CXTPRibbonOffice2013Theme
CXTPRibbonOffice2013Theme (CXTPPaintManager *pPaintManager)
Constructs a CXTPRibbonOffice2013Theme object.
virtual | ~CXTPRibbonOffice2013Theme ()
Destroys a CXTPRibbonOffice2013Theme object, handles cleanup and deallocation.
virtual void | RefreshMetrics ()
This method is called to refresh the visual metrics of the manager.
virtual int | GetRibbonCaptionHeight (const CXTPRibbonBar *pRibbonBar) const
Calculates the ribbon caption height.
virtual void | DrawQuickAccessControl (CDC *pDC, CXTPRibbonBar *pRibbon, CXTPControl *pControl)
Draws the specified control which is a part of the Quick Access panel.
virtual void | DrawRibbonTab (CDC *pDC, CXTPRibbonTab *pItem)
This method is called to draw a single tab of the ribbon bar.
virtual void | DrawRibbonFrameContextHeaders (CDC *pDC, CXTPRibbonBar *pRibbonBar, CXTPRibbonTabContextHeaders *pContextHeaders)
This method is called to draw ribbon context headers.
virtual void | FillRibbonBar (CDC *pDC, CXTPRibbonBar *pRibbonBar)
This method is called to fill the background of a ribbon bar control.
virtual void | DrawRibbonFrameCaptionBar (CDC *pDC, CXTPRibbonBar *pRibbonBar, BOOL bActive)
This method is called to draw the ribbon caption if EnableFrameTheme was not called.
virtual void | DrawRibbonFrameCaption (CDC *pDC, CXTPRibbonBar *pRibbonBar, BOOL bActive)
This method is called to draw the Ribbon caption.
virtual void | SetBackImage (int nImage)
This member function will set the background image for the Office ribbon bar.
virtual void | DrawRibbonFrameSystemButton (CDC *pDC, CXTPRibbonControlSystemButton *pControl, CRect rc)
Draws the top-left system button.
- Public Member Functions inherited from CXTPRibbonMarkupTheme
CXTPRibbonMarkupTheme (CXTPPaintManager *pPaintManager)
Constructs a CXTPRibbonMarkupTheme object.
virtual | ~CXTPRibbonMarkupTheme ()
Destroys a CXTPRibbonMarkupTheme object, handles cleanup and deallocation.
void | LoadParts (HZIP hZip, CXTPMarkupContext *pMarkupContext=NULL)
Loads markup parts from the specified ZIP source.
void | FillGroupRect (CDC *pDC, CXTPRibbonTab *pActiveTab, CRect rcGroups)
This method is called to fill the background of a CXTPRibbonGroup.
void | DrawGroup (CDC *pDC, CXTPRibbonGroup *pGroup)
Draws the specified CXTPRibbonGroup.
void | RenderMarkup (CDC *pDC, CRect rc, LPCTSTR lpszText)
Renders a Markup string in the Ribbon.
void | RenderMarkup (CDC *pDC, CRect rc, XTPRibbonThemePart part)
Renders a Markup string in the Ribbon.
CSize | DrawControlGroupOption (CDC *pDC, CXTPControl *pControlGroupOption, BOOL bDraw)
Draws the group option button.
CSize | GetControlGroupOptionSize () const
Calculates the ribbon group option size.
CSize | DrawControlGroupPopup (CDC *pDC, CXTPControlPopup *pControlGroupPopup, BOOL bDraw)
Draws the group pop-up button.
void | FillGroupPopupToolBar (CDC *pDC, CXTPRibbonGroup *pGroup, CXTPCommandBar *pCommandBar)
This method is called to draw the pop-up toolbar of a reduced group.
virtual void | DrawRibbonQuickAccessButton (CDC *pDC, CXTPControlPopup *pControl)
This method is called to draw the Quick Access customize button.
void | DrawRibbonQuickAccessMoreButton (CDC *pDC, CXTPControlPopup *pControl)
This method is called to draw the Quick Access more button.
void | FillMorePopupToolBarEntry (CDC *pDC, CXTPCommandBar *pBar)
This method is called to draw the pop-up bar of the more button.
void | FillSystemPopupBarEntry (CDC *pDC, CXTPPopupBar *pBar)
This method is called to draw the pop-up bar of the system button.
void | DrawSystemPopupBarButton (CDC *pDC, CXTPControl *pButton)
This method is called to draw a pop-up bar button.
void | DrawRibbonScrollButton (CDC *pDC, CXTPControl *pControl, BOOL bScrollLeft)
This method is called to draw scroll group buttons.
BOOL | DrawRibbonGroupControlEntry (CDC *pDC, CXTPControl *pButton)
This method is called to draw the ribbon group when the group is minimized and only a button is displayed.
void | DrawRibbonGroupPopupToolBar (CDC *pDC, CXTPRibbonGroup *pRibbonGroup)
This method is called to draw the ribbon group pop-up toolbar.
virtual void | DrawRibbonQuickAccessControls (CDC *pDC, CXTPRibbonBar *pRibbonBar)
This method is called to draw ribbon Quick Access controls.
virtual void | FillRibbonTabControl (CDC *pDC, CXTPRibbonBar *pRibbonBar, CRect rcControl)
This member fills in the tab header and tab client area.
- Public Member Functions inherited from CXTPRibbonPaintManager
CXTPRibbonPaintManager (CXTPPaintManager *pPaintManager)
Constructs a CXTPRibbonPaintManager object.
virtual | ~CXTPRibbonPaintManager ()
Destroys a CXTPRibbonPaintManager object, handles cleanup and deallocation.
virtual void | FillTabPopupToolBar (CDC *pDC, CXTPPopupToolBar *pPopupToolBar)
This method is called to draw the background of a minimized pop-up bar.
virtual void | DrawRibbonFramePart (CDC *pDC, CXTPRibbonBar *pRibbonBar)
This method is called to draw the ribbon frame if EnableFrameTheme was not called.
int | GetEditHeight () const
Gets the edit control height.
void | SetFontHeight (int nFontHeight)
Sets the font height used for Ribbon.
int | GetFontHeight () const
Gets the font height used for Ribbon.
int | GetGroupCaptionHeight () const
Gets the height of the group caption bar.
CXTPResourceImage * | LoadImage (LPCTSTR lpszFileName)
Loads a bitmap image from the specified path.
CXTPResourceImages * | GetImages () const
This method is called to get a pointer to the CXTPResourceImages object.
CXTPTabPaintManager * | GetTabPaintManager () const
Call this member to get a pointer to the tab paint manager.
CXTPFramePaintManager * | GetFramePaintManager () const
Call this member to get a pointer to the frame paint manager.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPRibbonPaintManager
BOOL | m_bHotTrackingGroups
TRUE to highlight the group under the cursor.
BOOL | m_bFlatFrame
TRUE to draw a flat frame.
CXTPPaintManagerFont | m_fontGroupCaption
Font used to draw text in the group caption.
COLORREF | m_clrRecentFileListEdgeShadow
Color of the File List edge shadow.
COLORREF | m_clrRecentFileListEdgeHighLight
Color of the File List edge highlight.
int | m_nTabsHeight
Tabs heights.
int | m_nGroupSpacing
Group spacing.
int | m_nGroupCaptionHeight
Group caption bar height.
- Protected Member Functions inherited from CXTPRibbonOffice2013Theme
virtual CString | GetBackImageName ()
This member function is used to get the name of the background image located in the Office 2013 resource .DLL.
virtual void | DrawBackImage (CDC *pDC, CXTPRibbonBar *pRibbonBar)
Used by the theme to draw the background image for the ribbon bar.
virtual void | LoadParts (BOOL bReload=FALSE)
Loads markup parts.
- Protected Member Functions inherited from CXTPRibbonMarkupTheme
- Protected Member Functions inherited from CXTPRibbonPaintManager
virtual CXTPTabPaintManager * | CreateTabPaintManager ()
Creates a CXTPTabPaintManager object used to store the color and appearance information of the tabs in the ribbon bar.
void | DrawRibbonApplicationIcon (CDC *pDC, CXTPRibbonBar *pRibbonBar, CRect rc, HICON hIcon)
This method is called to draw a ribbon bar application icon.
void | DrawDwmCaptionText (CDC *pDC, CRect rcCaptionText, CString strText, CWnd *pSite, BOOL bActive)
This method is called to draw caption text for an aero-transparent caption.
- Protected Attributes inherited from CXTPRibbonOffice2013Theme
XTPRIBBON_HEADER_COLOR | m_clrHeader [24]
Array of color values used for rendering the Ribbon's.
COLORREF | m_clrRibbonInactiveFaceState
context tabs.
COLORREF | m_clrTabBackInactiveState
Color of the ribbon tab when the application is inactive.
COLORREF | m_clrTabBackackstageLeft
Color of left part of the ribbon tab when new backstage is.
COLORREF | m_clrTabBackackstageRight
pop-up.
COLORREF | m_clrRibbonTabDelimeter
is pop-up.
- Protected Attributes inherited from CXTPRibbonMarkupTheme
COLORREF | m_clrBackstageSysButtonBack2013Normal
The color of "back" button in backstage if the button is not selected.
COLORREF | m_clrBackstageSysButtonBack2013Highlighted
The color of "back" button in backstage if the button is selected.
CString | m_strHighlightedPrefix
The prefix of the file name for the backstage "back" button image used for the selected button.
CString | m_strNormalPrefix
The prefix of the file name for the backstage "back" button image used for the not selected button.
CXTPMarkupContext * | m_pMarkupContext
Store pointer to a CXTPMarkupContext object.
- Protected Attributes inherited from CXTPRibbonPaintManager
COLORREF | m_clrRibbonFace
Ribbon face color.
COLORREF | m_clrRibbonBorder
Ribbon border color.
COLORREF | m_clrRibbonGroupCaptionText
Ribbon group captions color.
COLORREF | m_clrRibbonInactiveFace
Color of the ribbon when it is inactive.
COLORREF | m_clrFileButtonText
Text caption to display when the system button is displayed as a tab button (Windows 7 style).
COLORREF | m_clrMinimizedFrameEdgeHighLight
Minimized bottom edge.
COLORREF | m_clrMinimizedFrameEdgeShadow
Minimized bottom edge shadow.
CXTPPaintManager * | m_pPaintManager
Paint manager used for the ribbon.
CXTPTabPaintManager * | m_pTabPaintManager
Tab paint manager.
CRect | m_rcFileButtonMargin
Margins of the system button when it is displayed as a tab button (Windows 7 style).

Detailed Description

CXTPRibbonThemeVisualStudio2017 is a CXTPRibbonOffice2013Theme derived class used to represent a Visual Studio 2017 ribbon theme.

Constructor & Destructor Documentation

◆ CXTPRibbonThemeVisualStudio2017()

CXTPRibbonThemeVisualStudio2017 ( CXTPPaintManager * pPaintManager )

Constructs a CXTPRibbonThemeVisualStudio2017 object.

Parameters
pPaintManager A CXTPPaintManager object.
The documentation for this class was generated from the following file:
  • XTPRibbonThemeVisualStudio2017.h


Toolkit Pro: CXTPRibbonThemeVisualStudio2019 Class Reference

Public Member Functions | List of all members
CXTPRibbonThemeVisualStudio2019 Class Reference

CXTPRibbonThemeVisualStudio2019 is a CXTPRibbonOffice2013Theme derived class used to represent a Visual Studio 2019 ribbon theme. More...

Inheritance diagram for CXTPRibbonThemeVisualStudio2019:
[legend]

Public Member Functions

CXTPRibbonThemeVisualStudio2019 (CXTPPaintManager *pPaintManager)
Constructs a CXTPRibbonThemeVisualStudio2019 object.
virtual | ~CXTPRibbonThemeVisualStudio2019 ()
Destroys a CXTPRibbonThemeVisualStudio2019 object, handles cleanup and deallocation.
- Public Member Functions inherited from CXTPRibbonOffice2013Theme
CXTPRibbonOffice2013Theme (CXTPPaintManager *pPaintManager)
Constructs a CXTPRibbonOffice2013Theme object.
virtual | ~CXTPRibbonOffice2013Theme ()
Destroys a CXTPRibbonOffice2013Theme object, handles cleanup and deallocation.
virtual void | RefreshMetrics ()
This method is called to refresh the visual metrics of the manager.
virtual int | GetRibbonCaptionHeight (const CXTPRibbonBar *pRibbonBar) const
Calculates the ribbon caption height.
virtual void | DrawQuickAccessControl (CDC *pDC, CXTPRibbonBar *pRibbon, CXTPControl *pControl)
Draws the specified control which is a part of the Quick Access panel.
virtual void | DrawRibbonTab (CDC *pDC, CXTPRibbonTab *pItem)
This method is called to draw a single tab of the ribbon bar.
virtual void | DrawRibbonFrameContextHeaders (CDC *pDC, CXTPRibbonBar *pRibbonBar, CXTPRibbonTabContextHeaders *pContextHeaders)
This method is called to draw ribbon context headers.
virtual void | FillRibbonBar (CDC *pDC, CXTPRibbonBar *pRibbonBar)
This method is called to fill the background of a ribbon bar control.
virtual void | DrawRibbonFrameCaptionBar (CDC *pDC, CXTPRibbonBar *pRibbonBar, BOOL bActive)
This method is called to draw the ribbon caption if EnableFrameTheme was not called.
virtual void | DrawRibbonFrameCaption (CDC *pDC, CXTPRibbonBar *pRibbonBar, BOOL bActive)
This method is called to draw the Ribbon caption.
virtual void | SetBackImage (int nImage)
This member function will set the background image for the Office ribbon bar.
virtual void | DrawRibbonFrameSystemButton (CDC *pDC, CXTPRibbonControlSystemButton *pControl, CRect rc)
Draws the top-left system button.
- Public Member Functions inherited from CXTPRibbonMarkupTheme
CXTPRibbonMarkupTheme (CXTPPaintManager *pPaintManager)
Constructs a CXTPRibbonMarkupTheme object.
virtual | ~CXTPRibbonMarkupTheme ()
Destroys a CXTPRibbonMarkupTheme object, handles cleanup and deallocation.
void | LoadParts (HZIP hZip, CXTPMarkupContext *pMarkupContext=NULL)
Loads markup parts from the specified ZIP source.
void | FillGroupRect (CDC *pDC, CXTPRibbonTab *pActiveTab, CRect rcGroups)
This method is called to fill the background of a CXTPRibbonGroup.
void | DrawGroup (CDC *pDC, CXTPRibbonGroup *pGroup)
Draws the specified CXTPRibbonGroup.
void | RenderMarkup (CDC *pDC, CRect rc, LPCTSTR lpszText)
Renders a Markup string in the Ribbon.
void | RenderMarkup (CDC *pDC, CRect rc, XTPRibbonThemePart part)
Renders a Markup string in the Ribbon.
CSize | DrawControlGroupOption (CDC *pDC, CXTPControl *pControlGroupOption, BOOL bDraw)
Draws the group option button.
CSize | GetControlGroupOptionSize () const
Calculates the ribbon group option size.
CSize | DrawControlGroupPopup (CDC *pDC, CXTPControlPopup *pControlGroupPopup, BOOL bDraw)
Draws the group pop-up button.
void | FillGroupPopupToolBar (CDC *pDC, CXTPRibbonGroup *pGroup, CXTPCommandBar *pCommandBar)
This method is called to draw the pop-up toolbar of a reduced group.
virtual void | DrawRibbonQuickAccessButton (CDC *pDC, CXTPControlPopup *pControl)
This method is called to draw the Quick Access customize button.
void | DrawRibbonQuickAccessMoreButton (CDC *pDC, CXTPControlPopup *pControl)
This method is called to draw the Quick Access more button.
void | FillMorePopupToolBarEntry (CDC *pDC, CXTPCommandBar *pBar)
This method is called to draw the pop-up bar of the more button.
void | FillSystemPopupBarEntry (CDC *pDC, CXTPPopupBar *pBar)
This method is called to draw the pop-up bar of the system button.
void | DrawSystemPopupBarButton (CDC *pDC, CXTPControl *pButton)
This method is called to draw a pop-up bar button.
void | DrawRibbonScrollButton (CDC *pDC, CXTPControl *pControl, BOOL bScrollLeft)
This method is called to draw scroll group buttons.
BOOL | DrawRibbonGroupControlEntry (CDC *pDC, CXTPControl *pButton)
This method is called to draw the ribbon group when the group is minimized and only a button is displayed.
void | DrawRibbonGroupPopupToolBar (CDC *pDC, CXTPRibbonGroup *pRibbonGroup)
This method is called to draw the ribbon group pop-up toolbar.
virtual void | DrawRibbonQuickAccessControls (CDC *pDC, CXTPRibbonBar *pRibbonBar)
This method is called to draw ribbon Quick Access controls.
virtual void | FillRibbonTabControl (CDC *pDC, CXTPRibbonBar *pRibbonBar, CRect rcControl)
This member fills in the tab header and tab client area.
- Public Member Functions inherited from CXTPRibbonPaintManager
CXTPRibbonPaintManager (CXTPPaintManager *pPaintManager)
Constructs a CXTPRibbonPaintManager object.
virtual | ~CXTPRibbonPaintManager ()
Destroys a CXTPRibbonPaintManager object, handles cleanup and deallocation.
virtual void | FillTabPopupToolBar (CDC *pDC, CXTPPopupToolBar *pPopupToolBar)
This method is called to draw the background of a minimized pop-up bar.
virtual void | DrawRibbonFramePart (CDC *pDC, CXTPRibbonBar *pRibbonBar)
This method is called to draw the ribbon frame if EnableFrameTheme was not called.
int | GetEditHeight () const
Gets the edit control height.
void | SetFontHeight (int nFontHeight)
Sets the font height used for Ribbon.
int | GetFontHeight () const
Gets the font height used for Ribbon.
int | GetGroupCaptionHeight () const
Gets the height of the group caption bar.
CXTPResourceImage * | LoadImage (LPCTSTR lpszFileName)
Loads a bitmap image from the specified path.
CXTPResourceImages * | GetImages () const
This method is called to get a pointer to the CXTPResourceImages object.
CXTPTabPaintManager * | GetTabPaintManager () const
Call this member to get a pointer to the tab paint manager.
CXTPFramePaintManager * | GetFramePaintManager () const
Call this member to get a pointer to the frame paint manager.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPRibbonPaintManager
BOOL | m_bHotTrackingGroups
TRUE to highlight the group under the cursor.
BOOL | m_bFlatFrame
TRUE to draw a flat frame.
CXTPPaintManagerFont | m_fontGroupCaption
Font used to draw text in the group caption.
COLORREF | m_clrRecentFileListEdgeShadow
Color of the File List edge shadow.
COLORREF | m_clrRecentFileListEdgeHighLight
Color of the File List edge highlight.
int | m_nTabsHeight
Tabs heights.
int | m_nGroupSpacing
Group spacing.
int | m_nGroupCaptionHeight
Group caption bar height.
- Protected Member Functions inherited from CXTPRibbonOffice2013Theme
virtual CString | GetBackImageName ()
This member function is used to get the name of the background image located in the Office 2013 resource .DLL.
virtual void | DrawBackImage (CDC *pDC, CXTPRibbonBar *pRibbonBar)
Used by the theme to draw the background image for the ribbon bar.
virtual void | LoadParts (BOOL bReload=FALSE)
Loads markup parts.
- Protected Member Functions inherited from CXTPRibbonMarkupTheme
- Protected Member Functions inherited from CXTPRibbonPaintManager
virtual CXTPTabPaintManager * | CreateTabPaintManager ()
Creates a CXTPTabPaintManager object used to store the color and appearance information of the tabs in the ribbon bar.
void | DrawRibbonApplicationIcon (CDC *pDC, CXTPRibbonBar *pRibbonBar, CRect rc, HICON hIcon)
This method is called to draw a ribbon bar application icon.
void | DrawDwmCaptionText (CDC *pDC, CRect rcCaptionText, CString strText, CWnd *pSite, BOOL bActive)
This method is called to draw caption text for an aero-transparent caption.
- Protected Attributes inherited from CXTPRibbonOffice2013Theme
XTPRIBBON_HEADER_COLOR | m_clrHeader [24]
Array of color values used for rendering the Ribbon's.
COLORREF | m_clrRibbonInactiveFaceState
context tabs.
COLORREF | m_clrTabBackInactiveState
Color of the ribbon tab when the application is inactive.
COLORREF | m_clrTabBackackstageLeft
Color of left part of the ribbon tab when new backstage is.
COLORREF | m_clrTabBackackstageRight
pop-up.
COLORREF | m_clrRibbonTabDelimeter
is pop-up.
- Protected Attributes inherited from CXTPRibbonMarkupTheme
COLORREF | m_clrBackstageSysButtonBack2013Normal
The color of "back" button in backstage if the button is not selected.
COLORREF | m_clrBackstageSysButtonBack2013Highlighted
The color of "back" button in backstage if the button is selected.
CString | m_strHighlightedPrefix
The prefix of the file name for the backstage "back" button image used for the selected button.
CString | m_strNormalPrefix
The prefix of the file name for the backstage "back" button image used for the not selected button.
CXTPMarkupContext * | m_pMarkupContext
Store pointer to a CXTPMarkupContext object.
- Protected Attributes inherited from CXTPRibbonPaintManager
COLORREF | m_clrRibbonFace
Ribbon face color.
COLORREF | m_clrRibbonBorder
Ribbon border color.
COLORREF | m_clrRibbonGroupCaptionText
Ribbon group captions color.
COLORREF | m_clrRibbonInactiveFace
Color of the ribbon when it is inactive.
COLORREF | m_clrFileButtonText
Text caption to display when the system button is displayed as a tab button (Windows 7 style).
COLORREF | m_clrMinimizedFrameEdgeHighLight
Minimized bottom edge.
COLORREF | m_clrMinimizedFrameEdgeShadow
Minimized bottom edge shadow.
CXTPPaintManager * | m_pPaintManager
Paint manager used for the ribbon.
CXTPTabPaintManager * | m_pTabPaintManager
Tab paint manager.
CRect | m_rcFileButtonMargin
Margins of the system button when it is displayed as a tab button (Windows 7 style).

Detailed Description

CXTPRibbonThemeVisualStudio2019 is a CXTPRibbonOffice2013Theme derived class used to represent a Visual Studio 2019 ribbon theme.

Constructor & Destructor Documentation

◆ CXTPRibbonThemeVisualStudio2019()

CXTPRibbonThemeVisualStudio2019 ( CXTPPaintManager * pPaintManager )

Constructs a CXTPRibbonThemeVisualStudio2019 object.

Parameters
pPaintManager A CXTPPaintManager object.
The documentation for this class was generated from the following file:
  • XTPRibbonThemeVisualStudio2019.h


Toolkit Pro: CXTPRibbonThemeVisualStudio2022 Class Reference

Public Member Functions | List of all members
CXTPRibbonThemeVisualStudio2022 Class Reference

CXTPRibbonThemeVisualStudio2022 is a CXTPRibbonOffice2013Theme derived class used to represent a Visual Studio 2022 ribbon theme. More...

Inheritance diagram for CXTPRibbonThemeVisualStudio2022:
[legend]

Public Member Functions

CXTPRibbonThemeVisualStudio2022 (CXTPPaintManager *pPaintManager)
Constructs a CXTPRibbonThemeVisualStudio2022 object.
virtual | ~CXTPRibbonThemeVisualStudio2022 ()
Destroys a CXTPRibbonThemeVisualStudio2022 object, handles cleanup and deallocation.
- Public Member Functions inherited from CXTPRibbonOffice2013Theme
CXTPRibbonOffice2013Theme (CXTPPaintManager *pPaintManager)
Constructs a CXTPRibbonOffice2013Theme object.
virtual | ~CXTPRibbonOffice2013Theme ()
Destroys a CXTPRibbonOffice2013Theme object, handles cleanup and deallocation.
virtual void | RefreshMetrics ()
This method is called to refresh the visual metrics of the manager.
virtual int | GetRibbonCaptionHeight (const CXTPRibbonBar *pRibbonBar) const
Calculates the ribbon caption height.
virtual void | DrawQuickAccessControl (CDC *pDC, CXTPRibbonBar *pRibbon, CXTPControl *pControl)
Draws the specified control which is a part of the Quick Access panel.
virtual void | DrawRibbonTab (CDC *pDC, CXTPRibbonTab *pItem)
This method is called to draw a single tab of the ribbon bar.
virtual void | DrawRibbonFrameContextHeaders (CDC *pDC, CXTPRibbonBar *pRibbonBar, CXTPRibbonTabContextHeaders *pContextHeaders)
This method is called to draw ribbon context headers.
virtual void | FillRibbonBar (CDC *pDC, CXTPRibbonBar *pRibbonBar)
This method is called to fill the background of a ribbon bar control.
virtual void | DrawRibbonFrameCaptionBar (CDC *pDC, CXTPRibbonBar *pRibbonBar, BOOL bActive)
This method is called to draw the ribbon caption if EnableFrameTheme was not called.
virtual void | DrawRibbonFrameCaption (CDC *pDC, CXTPRibbonBar *pRibbonBar, BOOL bActive)
This method is called to draw the Ribbon caption.
virtual void | SetBackImage (int nImage)
This member function will set the background image for the Office ribbon bar.
virtual void | DrawRibbonFrameSystemButton (CDC *pDC, CXTPRibbonControlSystemButton *pControl, CRect rc)
Draws the top-left system button.
- Public Member Functions inherited from CXTPRibbonMarkupTheme
CXTPRibbonMarkupTheme (CXTPPaintManager *pPaintManager)
Constructs a CXTPRibbonMarkupTheme object.
virtual | ~CXTPRibbonMarkupTheme ()
Destroys a CXTPRibbonMarkupTheme object, handles cleanup and deallocation.
void | LoadParts (HZIP hZip, CXTPMarkupContext *pMarkupContext=NULL)
Loads markup parts from the specified ZIP source.
void | FillGroupRect (CDC *pDC, CXTPRibbonTab *pActiveTab, CRect rcGroups)
This method is called to fill the background of a CXTPRibbonGroup.
void | DrawGroup (CDC *pDC, CXTPRibbonGroup *pGroup)
Draws the specified CXTPRibbonGroup.
void | RenderMarkup (CDC *pDC, CRect rc, LPCTSTR lpszText)
Renders a Markup string in the Ribbon.
void | RenderMarkup (CDC *pDC, CRect rc, XTPRibbonThemePart part)
Renders a Markup string in the Ribbon.
CSize | DrawControlGroupOption (CDC *pDC, CXTPControl *pControlGroupOption, BOOL bDraw)
Draws the group option button.
CSize | GetControlGroupOptionSize () const
Calculates the ribbon group option size.
CSize | DrawControlGroupPopup (CDC *pDC, CXTPControlPopup *pControlGroupPopup, BOOL bDraw)
Draws the group pop-up button.
void | FillGroupPopupToolBar (CDC *pDC, CXTPRibbonGroup *pGroup, CXTPCommandBar *pCommandBar)
This method is called to draw the pop-up toolbar of a reduced group.
virtual void | DrawRibbonQuickAccessButton (CDC *pDC, CXTPControlPopup *pControl)
This method is called to draw the Quick Access customize button.
void | DrawRibbonQuickAccessMoreButton (CDC *pDC, CXTPControlPopup *pControl)
This method is called to draw the Quick Access more button.
void | FillMorePopupToolBarEntry (CDC *pDC, CXTPCommandBar *pBar)
This method is called to draw the pop-up bar of the more button.
void | FillSystemPopupBarEntry (CDC *pDC, CXTPPopupBar *pBar)
This method is called to draw the pop-up bar of the system button.
void | DrawSystemPopupBarButton (CDC *pDC, CXTPControl *pButton)
This method is called to draw a pop-up bar button.
void | DrawRibbonScrollButton (CDC *pDC, CXTPControl *pControl, BOOL bScrollLeft)
This method is called to draw scroll group buttons.
BOOL | DrawRibbonGroupControlEntry (CDC *pDC, CXTPControl *pButton)
This method is called to draw the ribbon group when the group is minimized and only a button is displayed.
void | DrawRibbonGroupPopupToolBar (CDC *pDC, CXTPRibbonGroup *pRibbonGroup)
This method is called to draw the ribbon group pop-up toolbar.
virtual void | DrawRibbonQuickAccessControls (CDC *pDC, CXTPRibbonBar *pRibbonBar)
This method is called to draw ribbon Quick Access controls.
virtual void | FillRibbonTabControl (CDC *pDC, CXTPRibbonBar *pRibbonBar, CRect rcControl)
This member fills in the tab header and tab client area.
- Public Member Functions inherited from CXTPRibbonPaintManager
CXTPRibbonPaintManager (CXTPPaintManager *pPaintManager)
Constructs a CXTPRibbonPaintManager object.
virtual | ~CXTPRibbonPaintManager ()
Destroys a CXTPRibbonPaintManager object, handles cleanup and deallocation.
virtual void | FillTabPopupToolBar (CDC *pDC, CXTPPopupToolBar *pPopupToolBar)
This method is called to draw the background of a minimized pop-up bar.
virtual void | DrawRibbonFramePart (CDC *pDC, CXTPRibbonBar *pRibbonBar)
This method is called to draw the ribbon frame if EnableFrameTheme was not called.
int | GetEditHeight () const
Gets the edit control height.
void | SetFontHeight (int nFontHeight)
Sets the font height used for Ribbon.
int | GetFontHeight () const
Gets the font height used for Ribbon.
int | GetGroupCaptionHeight () const
Gets the height of the group caption bar.
CXTPResourceImage * | LoadImage (LPCTSTR lpszFileName)
Loads a bitmap image from the specified path.
CXTPResourceImages * | GetImages () const
This method is called to get a pointer to the CXTPResourceImages object.
CXTPTabPaintManager * | GetTabPaintManager () const
Call this member to get a pointer to the tab paint manager.
CXTPFramePaintManager * | GetFramePaintManager () const
Call this member to get a pointer to the frame paint manager.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPRibbonPaintManager
BOOL | m_bHotTrackingGroups
TRUE to highlight the group under the cursor.
BOOL | m_bFlatFrame
TRUE to draw a flat frame.
CXTPPaintManagerFont | m_fontGroupCaption
Font used to draw text in the group caption.
COLORREF | m_clrRecentFileListEdgeShadow
Color of the File List edge shadow.
COLORREF | m_clrRecentFileListEdgeHighLight
Color of the File List edge highlight.
int | m_nTabsHeight
Tabs heights.
int | m_nGroupSpacing
Group spacing.
int | m_nGroupCaptionHeight
Group caption bar height.
- Protected Member Functions inherited from CXTPRibbonOffice2013Theme
virtual CString | GetBackImageName ()
This member function is used to get the name of the background image located in the Office 2013 resource .DLL.
virtual void | DrawBackImage (CDC *pDC, CXTPRibbonBar *pRibbonBar)
Used by the theme to draw the background image for the ribbon bar.
virtual void | LoadParts (BOOL bReload=FALSE)
Loads markup parts.
- Protected Member Functions inherited from CXTPRibbonMarkupTheme
- Protected Member Functions inherited from CXTPRibbonPaintManager
virtual CXTPTabPaintManager * | CreateTabPaintManager ()
Creates a CXTPTabPaintManager object used to store the color and appearance information of the tabs in the ribbon bar.
void | DrawRibbonApplicationIcon (CDC *pDC, CXTPRibbonBar *pRibbonBar, CRect rc, HICON hIcon)
This method is called to draw a ribbon bar application icon.
void | DrawDwmCaptionText (CDC *pDC, CRect rcCaptionText, CString strText, CWnd *pSite, BOOL bActive)
This method is called to draw caption text for an aero-transparent caption.
- Protected Attributes inherited from CXTPRibbonOffice2013Theme
XTPRIBBON_HEADER_COLOR | m_clrHeader [24]
Array of color values used for rendering the Ribbon's.
COLORREF | m_clrRibbonInactiveFaceState
context tabs.
COLORREF | m_clrTabBackInactiveState
Color of the ribbon tab when the application is inactive.
COLORREF | m_clrTabBackackstageLeft
Color of left part of the ribbon tab when new backstage is.
COLORREF | m_clrTabBackackstageRight
pop-up.
COLORREF | m_clrRibbonTabDelimeter
is pop-up.
- Protected Attributes inherited from CXTPRibbonMarkupTheme
COLORREF | m_clrBackstageSysButtonBack2013Normal
The color of "back" button in backstage if the button is not selected.
COLORREF | m_clrBackstageSysButtonBack2013Highlighted
The color of "back" button in backstage if the button is selected.
CString | m_strHighlightedPrefix
The prefix of the file name for the backstage "back" button image used for the selected button.
CString | m_strNormalPrefix
The prefix of the file name for the backstage "back" button image used for the not selected button.
CXTPMarkupContext * | m_pMarkupContext
Store pointer to a CXTPMarkupContext object.
- Protected Attributes inherited from CXTPRibbonPaintManager
COLORREF | m_clrRibbonFace
Ribbon face color.
COLORREF | m_clrRibbonBorder
Ribbon border color.
COLORREF | m_clrRibbonGroupCaptionText
Ribbon group captions color.
COLORREF | m_clrRibbonInactiveFace
Color of the ribbon when it is inactive.
COLORREF | m_clrFileButtonText
Text caption to display when the system button is displayed as a tab button (Windows 7 style).
COLORREF | m_clrMinimizedFrameEdgeHighLight
Minimized bottom edge.
COLORREF | m_clrMinimizedFrameEdgeShadow
Minimized bottom edge shadow.
CXTPPaintManager * | m_pPaintManager
Paint manager used for the ribbon.
CXTPTabPaintManager * | m_pTabPaintManager
Tab paint manager.
CRect | m_rcFileButtonMargin
Margins of the system button when it is displayed as a tab button (Windows 7 style).

Detailed Description

CXTPRibbonThemeVisualStudio2022 is a CXTPRibbonOffice2013Theme derived class used to represent a Visual Studio 2022 ribbon theme.

Constructor & Destructor Documentation

◆ CXTPRibbonThemeVisualStudio2022()

CXTPRibbonThemeVisualStudio2022 ( CXTPPaintManager * pPaintManager )

Constructs a CXTPRibbonThemeVisualStudio2022 object.

Parameters
pPaintManager A CXTPPaintManager object.
The documentation for this class was generated from the following file:
  • XTPRibbonThemeVisualStudio2022.h


Toolkit Pro: CXTPRWCriticalSection Class Reference

Classes | Public Member Functions | List of all members
CXTPRWCriticalSection Class Reference

Implements recursive read-write lock synchronization pattern. More...

Classes

class | CExclusiveLock
A convenience class for obtaining exclusive lock for a scope. More...
class | CSharedLock
A convenience class for obtaining shared lock for a scope. More...

Public Member Functions

CXTPRWCriticalSection ()
Constructs read-write lock critical section.
~CXTPRWCriticalSection ()
Handles read-write lock critical section.
BOOL | IsLockedSharedly () const volatile
Determines if critical section is currently locked in shared mode.
BOOL | IsLockedExclusively () const volatile
Determines if critical section is currently locked exclusively.
void | LockShared ()
Enters shared lock mode.
void | UnlockShared ()
Leaves shared lock mode.
void | LockExclusive ()
Enters exclusive lock mode.
void | UnlockExclusive ()
Leaves exclusive lock mode.

Detailed Description

Implements recursive read-write lock synchronization pattern.

Constructor & Destructor Documentation

◆ ~CXTPRWCriticalSection()

~CXTPRWCriticalSection ( )

Handles read-write lock critical section.

destruction.

Member Function Documentation

◆ IsLockedExclusively()

BOOL IsLockedExclusively ( ) const volatile

Determines if critical section is currently locked exclusively.

Returns
TRUE if critical section is locked in exclusive mode, otherwise FALSE.

◆ IsLockedSharedly()

BOOL IsLockedSharedly ( ) const volatile

Determines if critical section is currently locked in shared mode.

Returns
TRUE if critical section is locked in shared mode, otherwise FALSE. FALSE is also returned if critical section has been previously locked exclusively in the same thread, regardless whether shared mode lock has been obtained later or not.

◆ LockExclusive()

void LockExclusive ( )

Enters exclusive lock mode.

If the critical section is currently locked sharedly in another thread, the call will be blocked until all shared lock are released. If the critical section is currently locked sharedly in the current thread this state is cached and then exclusive lock gets acquired. Once exclusive lock is released, the cached shared lock state for the current thread is restored.

◆ LockShared()

void LockShared ( )

Enters shared lock mode.

If the critical section is currently locked exclusively in another thread, the call will be blocked until exclusive lock is released. If the critical section is currently locked exclusively in the current thread the function returns immediately without acquiring shared lock.

The documentation for this class was generated from the following file:
  • XTPSynchro.h


Toolkit Pro: CXTPRWCriticalSection::CExclusiveLock Class Reference

  • CXTPRWCriticalSection
  • CExclusiveLock
Public Member Functions | List of all members
CXTPRWCriticalSection::CExclusiveLock Class Reference

A convenience class for obtaining exclusive lock for a scope. More...

Public Member Functions

CExclusiveLock (CXTPRWCriticalSection &cs)
Constructs exclusive lock instance, obtains exclusive lock on critical section provided.
~CExclusiveLock ()
Destructs exclusive lock instance, releases exclusive lock on critical section provided during construction.

Detailed Description

A convenience class for obtaining exclusive lock for a scope.

Constructor & Destructor Documentation

◆ CExclusiveLock()

CExclusiveLock ( CXTPRWCriticalSection & cs )
inlineexplicit

Constructs exclusive lock instance, obtains exclusive lock on critical section provided.

Parameters
cs Critical section for which to obtain exclusive lock.
The documentation for this class was generated from the following file:
  • XTPSynchro.h


Toolkit Pro: CXTPRWCriticalSection::CSharedLock Class Reference

  • CXTPRWCriticalSection
  • CSharedLock
Public Member Functions | List of all members
CXTPRWCriticalSection::CSharedLock Class Reference

A convenience class for obtaining shared lock for a scope. More...

Public Member Functions

CSharedLock (CXTPRWCriticalSection &cs)
Constructs shared lock instance, obtains shared lock on critical section provided.
~CSharedLock ()
Destructs shared lock instance, releases shared lock on critical section provided during construction.

Detailed Description

A convenience class for obtaining shared lock for a scope.

Constructor & Destructor Documentation

◆ CSharedLock()

CSharedLock ( CXTPRWCriticalSection & cs )
inlineexplicit

Constructs shared lock instance, obtains shared lock on critical section provided.

Parameters
cs Critical section for which to obtain shared lock.
The documentation for this class was generated from the following file:
  • XTPSynchro.h


Toolkit Pro: CXTPScrollable< Base > Class Template Reference

Public Member Functions | List of all members
CXTPScrollable< Base > Class Template Reference

The adaptor class for a scrollable control for which standard scroll bars have to be overriden. More...

Inheritance diagram for CXTPScrollable< Base >:
[legend]

Public Member Functions

CXTPScrollable ()
Initializes a scrollable object instance.
virtual BOOL | Create (LPCTSTR lpszClassName, LPCTSTR lpszWindowName, DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID, CCreateContext *pContext=NULL)
Creates a scrollable control window.
virtual BOOL | CreateEx (DWORD dwExStyle, LPCTSTR lpszClassName, LPCTSTR lpszWindowName, DWORD dwStyle, int x, int y, int nWidth, int nHeight, HWND hWndParent, HMENU nIDorHMenu, LPVOID lpParam=NULL)
Creates a scrollable control window.
virtual BOOL | CreateEx (DWORD dwExStyle, LPCTSTR lpszClassName, LPCTSTR lpszWindowName, DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID, LPVOID lpParam=NULL)
Creates a scrollable control window.
BOOL | InitScrollBars ()
Performs one time custom scroll bars intitialization.
void | SetScrollBarTheme (XTPScrollBarTheme nTheme)
Sets custom scroll bars theme.
void | EnableDefaultBorderDrawing (BOOL bEnable=TRUE)
Enables or disables default border drawing for a host control.
- Public Member Functions inherited from IXTPScrollable
virtual | ~IXTPScrollable ()
Handles object destruction.

Detailed Description

template<class Base>
class CXTPScrollable< Base >

The adaptor class for a scrollable control for which standard scroll bars have to be overriden.

Parameters
Base Class name of the base control class.
See also
IXTPScrollable

Member Function Documentation

◆ Create()

template<class Base >
virtual BOOL Create | ( | LPCTSTR | lpszClassName,
 |  | LPCTSTR | lpszWindowName,
 |  | DWORD | dwStyle,
 |  | const RECT & | rect,
 |  | CWnd * | pParentWnd,
 |  | UINT | nID,
 |  | CCreateContext * | pContext = NULL )
 virtual

Creates a scrollable control window.

Parameters
lpszClassName | Pointer to a null-terminated string that contains the name of a registered system window class; or the name of a predefined system window class.
lpszWindowName | Pointer to a null-terminated string that contains the window display name; otherwise NULL for no window display name.
dwStyle | Bitwise combination (OR) of window styles. The WS_POPUP option is not a valid style.
rect | The size and location of the window relative to the top-left corner of the parent window.
pParentWnd | Pointer to the parent window.
nID | ID of the window.
pContext | Pointer to a CCreateContext structure that is used to customize the document-view architecture for the application.
Returns
TRUE if the window is successfully created, otherwise the return value is FALSE.

◆ CreateEx() [1/2]

template<class Base >
virtual BOOL CreateEx | ( | DWORD | dwExStyle,
 |  | LPCTSTR | lpszClassName,
 |  | LPCTSTR | lpszWindowName,
 |  | DWORD | dwStyle,
 |  | const RECT & | rect,
 |  | CWnd * | pParentWnd,
 |  | UINT | nID,
 |  | LPVOID | lpParam = NULL )
 virtual

Creates a scrollable control window.

Parameters
dwExStyle | Bitwise combination(OR) of extended window styles; otherwise NULL for the default extended window style.
lpszClassName | Pointer to a null-terminated string that contains the name of a registered system window class; or the name of a predefined system window class.
lpszWindowName | Pointer to a null-terminated string that contains the window display name; otherwise NULL for no window display name.
dwStyle | Bitwise combination (OR) of window styles. The WS_POPUP option is not a valid style.
rect | The size and location of the window relative to the top-left corner of the parent window.
pParentWnd | Pointer to the parent window.
nID | ID of the window.
lpParam | Points to the data referenced by the lpCreateParams field of the CREATESTRUCT structure.
Returns
TRUE if the window is successfully created, otherwise the return value is FALSE.

◆ CreateEx() [2/2]

template<class Base >
virtual BOOL CreateEx | ( | DWORD | dwExStyle,
 |  | LPCTSTR | lpszClassName,
 |  | LPCTSTR | lpszWindowName,
 |  | DWORD | dwStyle,
 |  | int | x,
 |  | int | y,
 |  | int | nWidth,
 |  | int | nHeight,
 |  | HWND | hWndParent,
 |  | HMENU | nIDorHMenu,
 |  | LPVOID | lpParam = NULL )
 virtual

Creates a scrollable control window.

Parameters
dwExStyle | Bitwise combination(OR) of extended window styles; otherwise NULL for the default extended window style.
lpszClassName | Pointer to a null-terminated string that contains the name of a registered system window class; or the name of a predefined system window class.
lpszWindowName | Pointer to a null-terminated string that contains the window display name; otherwise NULL for no window display name.
dwStyle | Bitwise combination (OR) of window styles. The WS_POPUP option is not a valid style.
x | The initial horizontal distance of the window from the left side of the screen or the parent window.
y | The initial vertical distance of the window from the top of the screen or the parent window.
nWidth | The width, in pixels, of the window.
nHeight | The height, in pixels, of the window.
hWndParent | Handle to the parent window.
nIDorHMenu | ID or menu handle for the window.
lpParam | Points to the data referenced by the lpCreateParams field of the CREATESTRUCT structure.
Returns
TRUE if the window is successfully created, otherwise the return value is FALSE.

◆ EnableDefaultBorderDrawing()

template<class Base >
void EnableDefaultBorderDrawing ( BOOL bEnable = TRUE )

Enables or disables default border drawing for a host control.

Enabled by default.

Parameters
bEnable TRUE to enable default border drawing, FALSE to disable it.

◆ InitScrollBars()

template<class Base >
BOOL InitScrollBars ( )

Performs one time custom scroll bars intitialization.

In most common use cases there is no need to call it manually as intitialization is performed automatically on window creation or DDX binding.

Returns
TRUE if scroll bars are initialized successfully.

◆ SetScrollBarTheme()

template<class Base >
void SetScrollBarTheme ( XTPScrollBarTheme nTheme )

Sets custom scroll bars theme.

Parameters
nTheme scroll bar theme identifier.
The documentation for this class was generated from the following file:
  • XTPScrollable.h


Toolkit Pro: CXTPScrollableEditT< EditBase > Class Template Reference

Public Member Functions | List of all members
CXTPScrollableEditT< EditBase > Class Template Reference

An adaptor for any CEdit derived control that overrides standard scrollbars with custom scrollbars. More...

Inheritance diagram for CXTPScrollableEditT< EditBase >:
[legend]

Public Member Functions

CXTPScrollableEditT ()
Initializes scrollable control instance.
- Public Member Functions inherited from CXTPScrollable< EditBase >
CXTPScrollable ()
Initializes a scrollable object instance.
virtual BOOL | Create (LPCTSTR lpszClassName, LPCTSTR lpszWindowName, DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID, CCreateContext *pContext=NULL)
Creates a scrollable control window.
virtual BOOL | CreateEx (DWORD dwExStyle, LPCTSTR lpszClassName, LPCTSTR lpszWindowName, DWORD dwStyle, int x, int y, int nWidth, int nHeight, HWND hWndParent, HMENU nIDorHMenu, LPVOID lpParam=NULL)
Creates a scrollable control window.
virtual BOOL | CreateEx (DWORD dwExStyle, LPCTSTR lpszClassName, LPCTSTR lpszWindowName, DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID, LPVOID lpParam=NULL)
Creates a scrollable control window.
BOOL | InitScrollBars ()
Performs one time custom scroll bars intitialization.
void | SetScrollBarTheme (XTPScrollBarTheme nTheme)
Sets custom scroll bars theme.
void | EnableDefaultBorderDrawing (BOOL bEnable=TRUE)
Enables or disables default border drawing for a host control.
- Public Member Functions inherited from IXTPScrollable
virtual | ~IXTPScrollable ()
Handles object destruction.

Detailed Description

template<class EditBase>
class CXTPScrollableEditT< EditBase >

An adaptor for any CEdit derived control that overrides standard scrollbars with custom scrollbars.

Parameters
EditBase Base CEdit derived class name.
See also
CXTPScrollable
The documentation for this class was generated from the following file:
  • XTPEdit.h


Toolkit Pro: CXTPScrollableListBoxT< ListBoxBase > Class Template Reference

Public Member Functions | List of all members
CXTPScrollableListBoxT< ListBoxBase > Class Template Reference

An adaptor for any CListBox derived control that overrides standard scrollbars with custom scrollbars. More...

Inheritance diagram for CXTPScrollableListBoxT< ListBoxBase >:
[legend]

Public Member Functions

CXTPScrollableListBoxT ()
Initializes scrollable control instance.
- Public Member Functions inherited from CXTPScrollable< ListBoxBase >
CXTPScrollable ()
Initializes a scrollable object instance.
virtual BOOL | Create (LPCTSTR lpszClassName, LPCTSTR lpszWindowName, DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID, CCreateContext *pContext=NULL)
Creates a scrollable control window.
virtual BOOL | CreateEx (DWORD dwExStyle, LPCTSTR lpszClassName, LPCTSTR lpszWindowName, DWORD dwStyle, int x, int y, int nWidth, int nHeight, HWND hWndParent, HMENU nIDorHMenu, LPVOID lpParam=NULL)
Creates a scrollable control window.
virtual BOOL | CreateEx (DWORD dwExStyle, LPCTSTR lpszClassName, LPCTSTR lpszWindowName, DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID, LPVOID lpParam=NULL)
Creates a scrollable control window.
BOOL | InitScrollBars ()
Performs one time custom scroll bars intitialization.
void | SetScrollBarTheme (XTPScrollBarTheme nTheme)
Sets custom scroll bars theme.
void | EnableDefaultBorderDrawing (BOOL bEnable=TRUE)
Enables or disables default border drawing for a host control.
- Public Member Functions inherited from IXTPScrollable
virtual | ~IXTPScrollable ()
Handles object destruction.

Detailed Description

template<class ListBoxBase>
class CXTPScrollableListBoxT< ListBoxBase >

An adaptor for any CListBox derived control that overrides standard scrollbars with custom scrollbars.

Parameters
ListBoxBase Base CListBox derived class name.
See also
CXTPScrollable
The documentation for this class was generated from the following file:
  • XTPListBox.h


Toolkit Pro: CXTPScrollableListCtrlT< ListBase > Class Template Reference

Public Member Functions | List of all members
CXTPScrollableListCtrlT< ListBase > Class Template Reference

An adaptor for any CListCtrl derived control that overrides standard scrollbars with custom scrollbars. More...

Inheritance diagram for CXTPScrollableListCtrlT< ListBase >:
[legend]

Public Member Functions

CXTPScrollableListCtrlT ()
Initializes a scrollable control instance.
- Public Member Functions inherited from CXTPScrollable< ListBase >
CXTPScrollable ()
Initializes a scrollable object instance.
virtual BOOL | Create (LPCTSTR lpszClassName, LPCTSTR lpszWindowName, DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID, CCreateContext *pContext=NULL)
Creates a scrollable control window.
virtual BOOL | CreateEx (DWORD dwExStyle, LPCTSTR lpszClassName, LPCTSTR lpszWindowName, DWORD dwStyle, int x, int y, int nWidth, int nHeight, HWND hWndParent, HMENU nIDorHMenu, LPVOID lpParam=NULL)
Creates a scrollable control window.
virtual BOOL | CreateEx (DWORD dwExStyle, LPCTSTR lpszClassName, LPCTSTR lpszWindowName, DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID, LPVOID lpParam=NULL)
Creates a scrollable control window.
BOOL | InitScrollBars ()
Performs one time custom scroll bars intitialization.
void | SetScrollBarTheme (XTPScrollBarTheme nTheme)
Sets custom scroll bars theme.
void | EnableDefaultBorderDrawing (BOOL bEnable=TRUE)
Enables or disables default border drawing for a host control.
- Public Member Functions inherited from IXTPScrollable
virtual | ~IXTPScrollable ()
Handles object destruction.

Detailed Description

template<class ListBase>
class CXTPScrollableListCtrlT< ListBase >

An adaptor for any CListCtrl derived control that overrides standard scrollbars with custom scrollbars.

Parameters
ListBase Base CListCtrl derived class name.
See also
CXTPScrollable
The documentation for this class was generated from the following file:
  • XTPListCtrlView.h


Toolkit Pro: CXTPScrollableTreeCtrlT< TreeBase > Class Template Reference

Public Member Functions | List of all members
CXTPScrollableTreeCtrlT< TreeBase > Class Template Reference

An adaptor for any CTreeCtrl derived control that overrides standard scrollbars with custom scrollbars. More...

Inheritance diagram for CXTPScrollableTreeCtrlT< TreeBase >:
[legend]

Public Member Functions

CXTPScrollableTreeCtrlT ()
Initializes a scrollable control instance.
- Public Member Functions inherited from CXTPScrollable< TreeBase >
CXTPScrollable ()
Initializes a scrollable object instance.
virtual BOOL | Create (LPCTSTR lpszClassName, LPCTSTR lpszWindowName, DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID, CCreateContext *pContext=NULL)
Creates a scrollable control window.
virtual BOOL | CreateEx (DWORD dwExStyle, LPCTSTR lpszClassName, LPCTSTR lpszWindowName, DWORD dwStyle, int x, int y, int nWidth, int nHeight, HWND hWndParent, HMENU nIDorHMenu, LPVOID lpParam=NULL)
Creates a scrollable control window.
virtual BOOL | CreateEx (DWORD dwExStyle, LPCTSTR lpszClassName, LPCTSTR lpszWindowName, DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID, LPVOID lpParam=NULL)
Creates a scrollable control window.
BOOL | InitScrollBars ()
Performs one time custom scroll bars intitialization.
void | SetScrollBarTheme (XTPScrollBarTheme nTheme)
Sets custom scroll bars theme.
void | EnableDefaultBorderDrawing (BOOL bEnable=TRUE)
Enables or disables default border drawing for a host control.
- Public Member Functions inherited from IXTPScrollable
virtual | ~IXTPScrollable ()
Handles object destruction.

Detailed Description

template<class TreeBase>
class CXTPScrollableTreeCtrlT< TreeBase >

An adaptor for any CTreeCtrl derived control that overrides standard scrollbars with custom scrollbars.

Parameters
TreeBase Base CTreeCtrl derived class name.
See also
CXTPScrollable
The documentation for this class was generated from the following file:
  • XTPTreeCtrlView.h


Toolkit Pro: CXTPScrollBar Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPScrollBar Class Reference

Scrollbar control. More...

Inheritance diagram for CXTPScrollBar:
[legend]

Public Member Functions

CXTPScrollBar ()
Constructs a CXTPScrollBar object.
virtual | ~CXTPScrollBar ()
Destroys a CXTPScrollBar object, handles cleanup and deallocation.
void | SetTheme (XTPControlTheme nTheme)
Call this member to switch the visual theme of the control.
BOOL | GetUseVisualStyle () const
Determines if the control is drawn using visual styles/SkinFramework, if supported.
void | SetUseVisualStyle (BOOL bUseVisualStyle=TRUE)
Enables Windows XP visual styles for the control.
- Public Member Functions inherited from CXTPScrollBarCtrl
CXTPScrollBarCtrl ()
Constructs a CXTPScrollBarCtrl object.
virtual | ~CXTPScrollBarCtrl ()
Destroys a CXTPScrollBarCtrl object, handles cleanup and deallocation.
void | SetTheme (XTPScrollBarTheme theme)
Sets the scrollbar theme.
virtual void | RefreshMetrics ()
This member is called to update color, text and other visual elements of the control.
virtual CXTPScrollBarPaintManager * | GetScrollBarPaintManager () const
Obtains a pointer to the associated scrollbar paint manager.
virtual void | GetScrollInfo (SCROLLINFO *psi)
The GetScrollInfo function retrieves the parameters of a scroll bar, including the minimum and maximum scrolling positions, the page size, and the position of the scroll box (thumb)
- Public Member Functions inherited from CXTPScrollBase
CXTPScrollBase ()
Constructs a CXTPScrollBase object.
virtual | ~CXTPScrollBase ()
Destroys a CXTPScrollBase object, handles cleanup and deallocation.
void | SetScrollBarStyle (XTPScrollBarStyle scrollStyle)
Call this method to set the style of the scrollbar.
XTPScrollBarStyle | GetScrollBarStyle () const
Call this method to get the style of the scrollbar.
XTP_SCROLLBAR_TRACKINFO * | GetScrollBarTrackInfo () const
Call this method to get XTP_SCROLLBAR_TRACKINFO information.
XTP_SCROLLBAR_POSINFO * GetScrollBarPosInfo ()
Call this method to get XTP_SCROLLBAR_POSINFO information.
virtual CWnd * | GetParentWindow () const =0
Retrieves parent window of scrollbar.
int | HitTestScrollBar (POINT pt) const
Call this method to check ScrollBar part under pointer.
CRect | GetScrollBarPartRect (int nPart) const
Gets the bounding rectangle of a specified part of the scrollbar.
void | PerformTrackInit (HWND hWnd, CPoint point, XTP_SCROLLBAR_POSINFO *pSBInfo, BOOL bDirect)
Call this method to start scrollbar tracking.
XTP_SLIDERTICKS * | GetTicks () const
Gets the ticks in the slider.
void | SetTicks (double *pTicks, int nCount)
Call this method to set ticks for the slider.
HBRUSH | GetCltColor (CDC *pDC) const
Call this method to get the scroll bar control color.
BOOL | IsSlider () const
Call this member function to determine if the scrollbar is a slider control.
virtual BOOL | IsScrollBarEnabled () const =0
Determines if the scrollbar is enabled.
virtual CRect | GetScrollBarRect ()=0
Obtains the rectangle occupied by the scrollbar in client coordinates.
virtual void | RedrawScrollBar ()=0
Forces the scrollbar to redraw itself.

Protected Attributes

XTPControlTheme | m_nTheme
Scrollbar theme.
BOOL | m_bUseVisualStyle
TRUE to use Visual Styles.
- Protected Attributes inherited from CXTPScrollBarCtrl
BOOL | m_bPreSubclassInit
TRUE is sub-classed.
- Protected Attributes inherited from CXTPScrollBase
XTP_SCROLLBAR_POSINFO | m_spi
ScrollBar position.
XTP_SCROLLBAR_TRACKINFO * | m_pSBTrack
ScrollBar tracking.
XTP_SLIDERTICKS * | m_pTicks
Slider Ticks.
XTPScrollBarStyle | m_scrollBarStyle
ScrollBar style.
BOOL | m_bAnimation
TRUE if animation enabled.
int | m_nTimerElapse
Scroll delay.

Additional Inherited Members

- Protected Member Functions inherited from CXTPScrollBarCtrl
void Init ()
This member function is called from OnInitDialog or OnInitialUpdate to initialize the control.
XTP_SCROLLBAR_TRACKINFO * GetScrollBarTrackInfo ()
Call this method to get XTP_SCROLLBAR_TRACKINFO information.
XTP_SCROLLBAR_POSINFO * GetScrollBarPosInfo ()
Call this method to get XTP_SCROLLBAR_POSINFO information.

Detailed Description

Scrollbar control.

Scrollbars provide easy navigation through a long list of items or a large amount of information. They can also provide an analog representation of current position. You can use a scrollbar as an input device or as an indicator of speed or quantity. For example, to control the volume of a computer game or to view the time elapsed in a timed process.

Member Function Documentation

◆ GetUseVisualStyle()

BOOL GetUseVisualStyle ( ) const

Determines if the control is drawn using visual styles/SkinFramework, if supported.

This method enables Windows XP visual styles for the control. This Control will draw using visual styles if both the control and the operating system support it. Visual styles and SkinFramework skins are specifications for the appearance of controls. GetUseVisualStyle determines whether to use the currently set Windows XP visual style. If using SkinFramework, then it determines whether to use the currently set style of the SkinFramework.

Returns
TRUE if the currently set Windows XP visual style will be used to theme the control. If using SkinFramework, then the currently set style of the SkinFramework will be used to skin the control. FALSE if the currently set appearance/style in the OS will be used.

◆ SetTheme()

void SetTheme ( XTPControlTheme nTheme )

Call this member to switch the visual theme of the control.

Parameters
nTheme New visual theme. Can be any of the values listed in the Remarks section.

nStyle can be one of the following: xtpControlThemeDefault: Standard appearance style. xtpControlThemeFlat: Flat appearance style. xtpControlThemeUltraFlat: Ultra flat appearance style. xtpControlThemeOffice2000: Office 2000 appearance style. xtpControlThemeOfficeXP: Office XP appearance style. xtpControlThemeOffice2003: Office 2003 appearance style. xtpControlThemeResource: Office 2007 appearance style. xtpControlThemeVisualStudio2012Light: VS 2012 Light style theme. xtpControlThemeVisualStudio2012Dark: VS 2012 Dark style theme.

◆ SetUseVisualStyle()

void SetUseVisualStyle ( BOOL bUseVisualStyle = TRUE )

Enables Windows XP visual styles for the control.

This method enables Windows XP visual styles for the control. This Control will draw using visual styles if both the control and the operating system support it. Visual styles and SkinFramework skins are specifications for the appearance of controls. GetUseVisualStyle determines whether to use the currently set Windows XP visual style. If using SkinFramework, then it determines whether to use the currently set style of the SkinFramework.

Parameters
bUseVisualStyle TRUE if the currently set Windows XP visual style will be used to theme the control. If using SkinFramework, then the currently set style of the SkinFramework will be used to skin the control. FALSE if the currently set appearance/style in the OS will be used.
The documentation for this class was generated from the following file:
  • XTPScrollBar.h


Toolkit Pro: CXTPScrollBarContainer< Parent > Class Template Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPScrollBarContainer< Parent > Class Template Reference

CXTPScrollBarContainer class adds XTP scroll bars to a class derived from CWnd. More...

Inheritance diagram for CXTPScrollBarContainer< Parent >:
[legend]

Public Member Functions

void | SetScrollBarTheme (XTPScrollBarTheme theme)
Sets scroll bar theme.
BOOL | CreateScrollBarCtrl (DWORD dwStyle, UINT nID)
Creates a scroll bar control with ID and style specied.
virtual CScrollBar * | GetScrollBarCtrl (int nBar) const
Call this member function to obtain a pointer to the specified sibling scroll bar or splitter window.
void | ShowScrollBar (UINT nBar, BOOL bShow=TRUE)
Shows or hides a scroll bar.
BOOL | EnableScrollBar (int nSBFlags, UINT nArrowFlags=ESB_ENABLE_BOTH)
Enables or disables one or both arrows of a scroll bar.
void | RefreshScrollBarMetrics ()
Triggers update of color and size information for themed scroll bars.
void | OptimizeChildrenClipping ()
Applies WS_CLIPCHILDREN and WS_CLIPSIBLINGS styles the the container owner and all its immediate children windows in order prevent possible overlapping of children controls with scroll bars.
void | SetScrollBarClass (CRuntimeClass *pClass=NULL)
Sets a scroll bar class to be used for creating scroll bars.

Protected Member Functions

CXTPScrollBarContainer ()
Constructs a CXTPScrollBarContainer object.

Detailed Description

template<class Parent = CWnd>
class CXTPScrollBarContainer< Parent >

CXTPScrollBarContainer class adds XTP scroll bars to a class derived from CWnd.

Constructor & Destructor Documentation

◆ CXTPScrollBarContainer()

template<class Parent = CWnd>
CXTPScrollBarContainer ( )
inlineprotected

Constructs a CXTPScrollBarContainer object.

Forces the class to be inherited only, not instantiated.

Member Function Documentation

◆ CreateScrollBarCtrl()

template<class Parent = CWnd>
BOOL CreateScrollBarCtrl | ( | DWORD | dwStyle,
 |  | UINT | nID )
 inline

Creates a scroll bar control with ID and style specied.

Parameters
dwStyle | scroll bar style.
nID | scroll bar control ID.
Returns
TRUE if succeeded.

◆ EnableScrollBar()

template<class Parent = CWnd>
BOOL EnableScrollBar | ( | int | nSBFlags,
 |  | UINT | nArrowFlags = ESB_ENABLE_BOTH )
 inline

Enables or disables one or both arrows of a scroll bar.

Parameters
nSBFlags | Specifies the scroll-bar type.
nArrowFlags | Specifies whether the scroll-bar arrows are enabled or disabled and which arrows are enabled or disabled.
Returns
True = enable, False = disable

◆ GetScrollBarCtrl()

template<class Parent = CWnd>
virtual CScrollBar * GetScrollBarCtrl ( int nBar ) const
inlinevirtual

Call this member function to obtain a pointer to the specified sibling scroll bar or splitter window.

Parameters
nBar Specifies the type of scroll bar.
Returns
Returns a pointer to the specified sibling

◆ SetScrollBarClass()

template<class Parent = CWnd>
void SetScrollBarClass ( CRuntimeClass * pClass = NULL )
inline

Sets a scroll bar class to be used for creating scroll bars.

Parameters
pClass A scroll bar class pointer. The class must be derived from CXTPScrollBarCtrl. NULL indicates CXTPScrollBarCtrl to be used by default.

◆ SetScrollBarTheme()

template<class Parent = CWnd>
void SetScrollBarTheme ( XTPScrollBarTheme theme )
inline

Sets scroll bar theme.

Parameters
theme scroll bar theme identifier.

◆ ShowScrollBar()

template<class Parent = CWnd>
void ShowScrollBar | ( | UINT | nBar,
 |  | BOOL | bShow = TRUE )
 inline

Shows or hides a scroll bar.

Parameters
nBar | Specifies the type of scroll bar.
bShow | Specifies whether Windows shows or hides the scroll bar.
The documentation for this class was generated from the following file:
  • XTPScrollBarContainer.h


Toolkit Pro: CXTPScrollBarCtrl Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPScrollBarCtrl Class Reference

Scrollbar control. More...

Inheritance diagram for CXTPScrollBarCtrl:
[legend]

Public Member Functions

CXTPScrollBarCtrl ()
Constructs a CXTPScrollBarCtrl object.
virtual | ~CXTPScrollBarCtrl ()
Destroys a CXTPScrollBarCtrl object, handles cleanup and deallocation.
void | SetTheme (XTPScrollBarTheme theme)
Sets the scrollbar theme.
virtual void | RefreshMetrics ()
This member is called to update color, text and other visual elements of the control.
virtual CXTPScrollBarPaintManager * | GetScrollBarPaintManager () const
Obtains a pointer to the associated scrollbar paint manager.
virtual void | GetScrollInfo (SCROLLINFO *psi)
The GetScrollInfo function retrieves the parameters of a scroll bar, including the minimum and maximum scrolling positions, the page size, and the position of the scroll box (thumb)
- Public Member Functions inherited from CXTPScrollBase
CXTPScrollBase ()
Constructs a CXTPScrollBase object.
virtual | ~CXTPScrollBase ()
Destroys a CXTPScrollBase object, handles cleanup and deallocation.
void | SetScrollBarStyle (XTPScrollBarStyle scrollStyle)
Call this method to set the style of the scrollbar.
XTPScrollBarStyle | GetScrollBarStyle () const
Call this method to get the style of the scrollbar.
XTP_SCROLLBAR_TRACKINFO * | GetScrollBarTrackInfo () const
Call this method to get XTP_SCROLLBAR_TRACKINFO information.
XTP_SCROLLBAR_POSINFO * GetScrollBarPosInfo ()
Call this method to get XTP_SCROLLBAR_POSINFO information.
virtual CWnd * | GetParentWindow () const =0
Retrieves parent window of scrollbar.
int | HitTestScrollBar (POINT pt) const
Call this method to check ScrollBar part under pointer.
CRect | GetScrollBarPartRect (int nPart) const
Gets the bounding rectangle of a specified part of the scrollbar.
void | PerformTrackInit (HWND hWnd, CPoint point, XTP_SCROLLBAR_POSINFO *pSBInfo, BOOL bDirect)
Call this method to start scrollbar tracking.
XTP_SLIDERTICKS * | GetTicks () const
Gets the ticks in the slider.
void | SetTicks (double *pTicks, int nCount)
Call this method to set ticks for the slider.
HBRUSH | GetCltColor (CDC *pDC) const
Call this method to get the scroll bar control color.
BOOL | IsSlider () const
Call this member function to determine if the scrollbar is a slider control.
virtual BOOL | IsScrollBarEnabled () const =0
Determines if the scrollbar is enabled.
virtual CRect | GetScrollBarRect ()=0
Obtains the rectangle occupied by the scrollbar in client coordinates.
virtual void | RedrawScrollBar ()=0
Forces the scrollbar to redraw itself.

Protected Member Functions

void Init ()
This member function is called from OnInitDialog or OnInitialUpdate to initialize the control.
XTP_SCROLLBAR_TRACKINFO * GetScrollBarTrackInfo ()
Call this method to get XTP_SCROLLBAR_TRACKINFO information.
XTP_SCROLLBAR_POSINFO * GetScrollBarPosInfo ()
Call this method to get XTP_SCROLLBAR_POSINFO information.

Protected Attributes

BOOL | m_bPreSubclassInit
TRUE is sub-classed.
- Protected Attributes inherited from CXTPScrollBase
XTP_SCROLLBAR_POSINFO | m_spi
ScrollBar position.
XTP_SCROLLBAR_TRACKINFO * | m_pSBTrack
ScrollBar tracking.
XTP_SLIDERTICKS * | m_pTicks
Slider Ticks.
XTPScrollBarStyle | m_scrollBarStyle
ScrollBar style.
BOOL | m_bAnimation
TRUE if animation enabled.
int | m_nTimerElapse
Scroll delay.

Detailed Description

Scrollbar control.

Scroll bars provide easy navigation through a long list of items or a large amount of information. They can also provide an analog representation of current position. You can use a scroll bar as an input device or indicator of speed or quantity.for example, to control the volume of a computer game or to view the time elapsed in a timed process.

Member Function Documentation

◆ GetScrollBarPaintManager()

virtual CXTPScrollBarPaintManager * GetScrollBarPaintManager ( ) const
virtual

Obtains a pointer to the associated scrollbar paint manager.

Returns
A pointer to the associated scrollbar paint manager

Implements CXTPScrollBase.

Reimplemented in CXTPCommandBarScrollBarCtrl.

◆ GetScrollBarPosInfo()

XTP_SCROLLBAR_POSINFO * GetScrollBarPosInfo ( )
protected

Call this method to get XTP_SCROLLBAR_POSINFO information.

Returns
A pointer to XTP_SCROLLBAR_POSINFO information
See also
GetScrollBarTrackInfo

◆ GetScrollBarTrackInfo()

XTP_SCROLLBAR_TRACKINFO * GetScrollBarTrackInfo ( )
protected

Call this method to get XTP_SCROLLBAR_TRACKINFO information.

Returns
A pointer to XTP_SCROLLBAR_TRACKINFO information
See also
GetScrollBarPosInfo

◆ GetScrollInfo()

virtual void GetScrollInfo ( SCROLLINFO * psi )
virtual

The GetScrollInfo function retrieves the parameters of a scroll bar, including the minimum and maximum scrolling positions, the page size, and the position of the scroll box (thumb)

Parameters
psi Pointer to a SCROLLINFO structure. Before calling GetScrollInfo, set the cbSize member to sizeof(SCROLLINFO), and set the fMask member to specify the scroll bar parameters to retrieve. Before returning, the function copies the specified parameters to the appropriate members of the structure. Refer to MSDN documentation for more details on SCROLLINFO fields.

Implements CXTPScrollBase.

◆ SetTheme()

void SetTheme ( XTPScrollBarTheme theme )

Sets the scrollbar theme.

Parameters
theme Scrollbar theme to be set; must be one of the values defined by the XTPScrollBarTheme enumeration.
The documentation for this class was generated from the following file:
  • XTPScrollBarCtrl.h


Toolkit Pro: CXTPScrollBarPaintManager Class Reference

Public Member Functions | Public Attributes | Protected Member Functions | Static Protected Member Functions | List of all members
CXTPScrollBarPaintManager Class Reference

CXTPScrollBarPaintManager is standalone class used to draw CXTPCommandBarScrollBarCtrl object. More...

Inheritance diagram for CXTPScrollBarPaintManager:
[legend]

Public Member Functions

CXTPScrollBarPaintManager ()
Constructs a CXTPScrollBarPaintManager object.
virtual void | DrawScrollBar (CDC *pDC, CXTPScrollBase *pScrollBar)
This method is called to draw all scrollbar parts.
virtual void | RefreshMetrics ()
Recalculates scrollbar metrics.

Public Attributes

int | m_cxHScroll
Width, in pixels, of the arrow bitmap on a horizontal scroll bar.
int | m_cyHScroll
Height, in pixels, of a horizontal scroll bar.
int | m_cxVScroll
Width, in pixels, of a vertical scroll bar;.
int | m_cyVScroll
Height, in pixels, of the arrow bitmap on a vertical scroll bar.
int | m_cThumb
Width of thumb button.
COLORREF | m_crBackPushed
Color when pushed.
COLORREF | m_crBackHilite
Color when border.
COLORREF | m_crBorderHilite
Color of border when highlighted.
COLORREF | m_crBorder
Color of border.
COLORREF | m_crBack
Color of background.

Protected Member Functions

virtual void | DrawBackground (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws verical scrollbar background only.
virtual void | DrawButtons (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws vertical scrollbar buttons only.
virtual void | DrawArrows (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws vertical scrollbar button arrows only.
virtual void | DrawTracker (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws vertical scrollbar trackers only.
virtual void | DrawThumbButton (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws vertical scrollbar thumb button only.
virtual void | DrawBackground (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar background only.
virtual void | DrawButtons (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar buttons only.
virtual void | DrawArrows (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar button arrows only.
virtual void | DrawTracker (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar trackers only.
virtual void | DrawThumbButton (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar thumb button only.
virtual void | DrawGripper (CDC *pDC, CXTPScrollBase *pScroll)
Draws scrollbar gripper only.
void | DrawArrowGlyph (CDC *pDC, CRect rcArrow, XTPArrowGlyph glyph, BOOL bEnabled, COLORREF clrText=COLORREF_NULL)
Draws scrollbar button arrow glyph.

Static Protected Member Functions

static void AFX_CDECL | CalcVScroll (CXTPScrollBase *pScroll, XTPScrollMetricsV *pVScroll)
Computes vertical scrollbar mertics.
static void AFX_CDECL | CalcHScroll (CXTPScrollBase *pScroll, XTPScrollMetricsH *pHScroll)
Computes horizontal scrollbar mertics.

Detailed Description

CXTPScrollBarPaintManager is standalone class used to draw CXTPCommandBarScrollBarCtrl object.

Member Function Documentation

◆ CalcHScroll()

static void AFX_CDECL CalcHScroll | ( | CXTPScrollBase * | pScroll,
 |  | XTPScrollMetricsH * | pHScroll )
 staticprotected

Computes horizontal scrollbar mertics.

Parameters
pScroll | Scroll bar object pointer
pHScroll | Pointer to the output metrics information
Returns

◆ CalcVScroll()

static void AFX_CDECL CalcVScroll | ( | CXTPScrollBase * | pScroll,
 |  | XTPScrollMetricsV * | pVScroll )
 staticprotected

Computes vertical scrollbar mertics.

Parameters
pScroll | Scroll bar object pointer
pVScroll | Pointer to the output metrics information
Returns

◆ DrawArrowGlyph()

void DrawArrowGlyph | ( | CDC * | pDC,
 |  | CRect | rcArrow,
 |  | XTPArrowGlyph | glyph,
 |  | BOOL | bEnabled,
 |  | COLORREF | clrText = COLORREF_NULL )
 protected

Draws scrollbar button arrow glyph.

Parameters
pDC | Target device context pointer.
rcArrow | Target rectangle.
glyph | Arrow glyph code, one of XTPArrowGlyph.
bEnabled | Determines whether an enabled glyph should be drawn.
clrText | Glyph color. If default COLORREF_NULL is used the enalbed glyph will be drawn in black color and disabled glyph will be drawn in COLOR_3DSHADOW.

◆ DrawArrows() [1/2]

virtual void DrawArrows | ( | CDC * | pDC,
 |  | CXTPScrollBase * | pScroll,
 |  | XTPScrollMetricsH * | pMetrics )
 protectedvirtual

Draws horizontal scrollbar button arrows only.

Parameters
pDC | Target device context pointer
pScroll | Scroll bar object pointer
pMetrics | Precomputed scrollbar metrics

Reimplemented in CXTPScrollBarThemeFlat, CXTPScrollBarThemeOffice2000, CXTPScrollBarThemeOffice2013, CXTPScrollBarThemeResource, and CXTPScrollBarThemeVisualStudio2012.

◆ DrawArrows() [2/2]

virtual void DrawArrows | ( | CDC * | pDC,
 |  | CXTPScrollBase * | pScroll,
 |  | XTPScrollMetricsV * | pMetrics )
 protectedvirtual

Draws vertical scrollbar button arrows only.

Parameters
pDC | Target device context pointer
pScroll | Scroll bar object pointer
pMetrics | Precomputed scrollbar metrics

Reimplemented in CXTPScrollBarThemeFlat, CXTPScrollBarThemeOffice2000, CXTPScrollBarThemeOffice2013, CXTPScrollBarThemeResource, and CXTPScrollBarThemeVisualStudio2012.

◆ DrawBackground() [1/2]

virtual void DrawBackground | ( | CDC * | pDC,
 |  | CXTPScrollBase * | pScroll,
 |  | XTPScrollMetricsH * | pMetrics )
 protectedvirtual

Draws horizontal scrollbar background only.

Parameters
pDC | Target device context pointer
pScroll | Scroll bar object pointer
pMetrics | Precomputed scrollbar metrics

Reimplemented in CXTPScrollBarThemeOffice2013, CXTPScrollBarThemeResource, and CXTPScrollBarThemeVisualStudio2012.

◆ DrawBackground() [2/2]

virtual void DrawBackground | ( | CDC * | pDC,
 |  | CXTPScrollBase * | pScroll,
 |  | XTPScrollMetricsV * | pMetrics )
 protectedvirtual

Draws verical scrollbar background only.

Parameters
pDC | Target device context pointer
pScroll | Scroll bar object pointer
pMetrics | Precomputed scrollbar metrics

Reimplemented in CXTPScrollBarThemeOffice2013, CXTPScrollBarThemeResource, and CXTPScrollBarThemeVisualStudio2012.

◆ DrawButtons() [1/2]

virtual void DrawButtons | ( | CDC * | pDC,
 |  | CXTPScrollBase * | pScroll,
 |  | XTPScrollMetricsH * | pMetrics )
 protectedvirtual

Draws horizontal scrollbar buttons only.

Parameters
pDC | Target device context pointer
pScroll | Scroll bar object pointer
pMetrics | Precomputed scrollbar metrics

Reimplemented in CXTPScrollBarThemeFlat, CXTPScrollBarThemeOffice2000, CXTPScrollBarThemeOffice2013, CXTPScrollBarThemeResource, CXTPScrollBarThemeVisualStudio2012, CXTPScrollBarThemeWindowsClassic, and CXTPScrollBarThemeWindowsUx.

◆ DrawButtons() [2/2]

virtual void DrawButtons | ( | CDC * | pDC,
 |  | CXTPScrollBase * | pScroll,
 |  | XTPScrollMetricsV * | pMetrics )
 protectedvirtual

Draws vertical scrollbar buttons only.

Parameters
pDC | Target device context pointer
pScroll | Scroll bar object pointer
pMetrics | Precomputed scrollbar metrics

Reimplemented in CXTPScrollBarThemeFlat, CXTPScrollBarThemeOffice2000, CXTPScrollBarThemeOffice2013, CXTPScrollBarThemeResource, CXTPScrollBarThemeVisualStudio2012, CXTPScrollBarThemeWindowsClassic, and CXTPScrollBarThemeWindowsUx.

◆ DrawGripper()

virtual void DrawGripper | ( | CDC * | pDC,
 |  | CXTPScrollBase * | pScroll )
 protectedvirtual

Draws scrollbar gripper only.

Parameters
pDC | Target device context pointer
pScroll | Scroll bar object pointer

Reimplemented in CXTPScrollBarThemeFlat, CXTPScrollBarThemeOffice2013, CXTPScrollBarThemeResource, CXTPScrollBarThemeVisualStudio2012, CXTPScrollBarThemeWindowsClassic, and CXTPScrollBarThemeWindowsUx.

◆ DrawScrollBar()

virtual void DrawScrollBar | ( | CDC * | pDC,
 |  | CXTPScrollBase * | pScrollBar )
 virtual

This method is called to draw all scrollbar parts.

Parameters
pDC | Pointer to device context
pScrollBar | ScrollBar to draw

Reimplemented in CXTPScrollBarThemeOffice2013, CXTPScrollBarThemeResource, CXTPScrollBarThemeVisualStudio2012, CXTPScrollBarThemeVisualStudio2015, CXTPScrollBarThemeVisualStudio2017, CXTPScrollBarThemeVisualStudio2019, CXTPScrollBarThemeVisualStudio2022, and CXTPSliderPaintManager.

◆ DrawThumbButton() [1/2]

virtual void DrawThumbButton | ( | CDC * | pDC,
 |  | CXTPScrollBase * | pScroll,
 |  | XTPScrollMetricsH * | pMetrics )
 protectedvirtual

Draws horizontal scrollbar thumb button only.

Parameters
pDC | Target device context pointer
pScroll | Scroll bar object pointer
pMetrics | Precomputed scrollbar metrics

Reimplemented in CXTPScrollBarThemeFlat, CXTPScrollBarThemeOffice2013, CXTPScrollBarThemeResource, CXTPScrollBarThemeVisualStudio2012, and CXTPScrollBarThemeWindowsUx.

◆ DrawThumbButton() [2/2]

virtual void DrawThumbButton | ( | CDC * | pDC,
 |  | CXTPScrollBase * | pScroll,
 |  | XTPScrollMetricsV * | pMetrics )
 protectedvirtual

Draws vertical scrollbar thumb button only.

Parameters
pDC | Target device context pointer
pScroll | Scroll bar object pointer
pMetrics | Precomputed scrollbar metrics

Reimplemented in CXTPScrollBarThemeFlat, CXTPScrollBarThemeOffice2013, CXTPScrollBarThemeResource, CXTPScrollBarThemeVisualStudio2012, and CXTPScrollBarThemeWindowsUx.

◆ DrawTracker() [1/2]

virtual void DrawTracker | ( | CDC * | pDC,
 |  | CXTPScrollBase * | pScroll,
 |  | XTPScrollMetricsH * | pMetrics )
 protectedvirtual

Draws horizontal scrollbar trackers only.

Parameters
pDC | Target device context pointer
pScroll | Scroll bar object pointer
pMetrics | Precomputed scrollbar metrics

Reimplemented in CXTPScrollBarThemeFlat, CXTPScrollBarThemeResource, CXTPScrollBarThemeWindowsClassic, and CXTPScrollBarThemeWindowsUx.

◆ DrawTracker() [2/2]

virtual void DrawTracker | ( | CDC * | pDC,
 |  | CXTPScrollBase * | pScroll,
 |  | XTPScrollMetricsV * | pMetrics )
 protectedvirtual

Draws vertical scrollbar trackers only.

Parameters
pDC | Target device context pointer
pScroll | Scroll bar object pointer
pMetrics | Precomputed scrollbar metrics

Reimplemented in CXTPScrollBarThemeFlat, CXTPScrollBarThemeResource, CXTPScrollBarThemeWindowsClassic, and CXTPScrollBarThemeWindowsUx.

The documentation for this class was generated from the following file:
  • XTPScrollBarPaintManager.h


Toolkit Pro: CXTPScrollBarThemeFlat Class Reference

Protected Member Functions | List of all members
CXTPScrollBarThemeFlat Class Reference

Scrollbar paint manager used to draw flat scrollbars. More...

Inheritance diagram for CXTPScrollBarThemeFlat:
[legend]

Protected Member Functions

virtual void | RefreshMetrics ()
Recalculates scrollbar metrics.
virtual void | DrawButtons (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws vertical scrollbar buttons only.
virtual void | DrawArrows (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws vertical scrollbar button arrows only.
virtual void | DrawTracker (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws vertical scrollbar trackers only.
virtual void | DrawThumbButton (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws vertical scrollbar thumb button only.
virtual void | DrawButtons (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar buttons only.
virtual void | DrawArrows (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar button arrows only.
virtual void | DrawTracker (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar trackers only.
virtual void | DrawThumbButton (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar thumb button only.
virtual void | DrawGripper (CDC *pDC, CXTPScrollBase *pScroll)
Draws scrollbar gripper only.
- Protected Member Functions inherited from CXTPScrollBarThemeWindowsUx
- Protected Member Functions inherited from CXTPScrollBarThemeWindowsClassic
- Protected Member Functions inherited from CXTPScrollBarPaintManager
virtual void | DrawBackground (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws verical scrollbar background only.
virtual void | DrawBackground (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar background only.
void | DrawArrowGlyph (CDC *pDC, CRect rcArrow, XTPArrowGlyph glyph, BOOL bEnabled, COLORREF clrText=COLORREF_NULL)
Draws scrollbar button arrow glyph.

Additional Inherited Members

- Public Member Functions inherited from CXTPScrollBarThemeWindowsUx
CXTPScrollBarThemeWindowsUx ()
Constructs a CXTPScrollBarThemeWindowsUx object.
virtual | ~CXTPScrollBarThemeWindowsUx ()
Destroys a CXTPScrollBarThemeWindowsUx object, handles cleanup and deallocation.
- Public Member Functions inherited from CXTPScrollBarPaintManager
CXTPScrollBarPaintManager ()
Constructs a CXTPScrollBarPaintManager object.
virtual void | DrawScrollBar (CDC *pDC, CXTPScrollBase *pScrollBar)
This method is called to draw all scrollbar parts.
- Public Attributes inherited from CXTPScrollBarPaintManager
int | m_cxHScroll
Width, in pixels, of the arrow bitmap on a horizontal scroll bar.
int | m_cyHScroll
Height, in pixels, of a horizontal scroll bar.
int | m_cxVScroll
Width, in pixels, of a vertical scroll bar;.
int | m_cyVScroll
Height, in pixels, of the arrow bitmap on a vertical scroll bar.
int | m_cThumb
Width of thumb button.
COLORREF | m_crBackPushed
Color when pushed.
COLORREF | m_crBackHilite
Color when border.
COLORREF | m_crBorderHilite
Color of border when highlighted.
COLORREF | m_crBorder
Color of border.
COLORREF | m_crBack
Color of background.
- Protected Types inherited from CXTPScrollBarPaintManager
- Static Protected Member Functions inherited from CXTPScrollBarPaintManager
static void AFX_CDECL | CalcVScroll (CXTPScrollBase *pScroll, XTPScrollMetricsV *pVScroll)
Computes vertical scrollbar mertics.
static void AFX_CDECL | CalcHScroll (CXTPScrollBase *pScroll, XTPScrollMetricsH *pHScroll)
Computes horizontal scrollbar mertics.

Detailed Description

Scrollbar paint manager used to draw flat scrollbars.

See also
CXTPPaintManager::SetTheme

Member Function Documentation

◆ DrawArrows() [1/2]

virtual void DrawArrows | ( | CDC * | pDC,
 |  | CXTPScrollBase * | pScroll,
 |  | XTPScrollMetricsH * | pMetrics )
 protectedvirtual

Draws horizontal scrollbar button arrows only.

Parameters
pDC | Target device context pointer
pScroll | Scroll bar object pointer
pMetrics | Precomputed scrollbar metrics

Reimplemented from CXTPScrollBarPaintManager.

◆ DrawArrows() [2/2]

virtual void DrawArrows | ( | CDC * | pDC,
 |  | CXTPScrollBase * | pScroll,
 |  | XTPScrollMetricsV * | pMetrics )
 protectedvirtual

Draws vertical scrollbar button arrows only.

Parameters
pDC | Target device context pointer
pScroll | Scroll bar object pointer
pMetrics | Precomputed scrollbar metrics

Reimplemented from CXTPScrollBarPaintManager.

◆ DrawButtons() [1/2]

virtual void DrawButtons | ( | CDC * | pDC,
 |  | CXTPScrollBase * | pScroll,
 |  | XTPScrollMetricsH * | pMetrics )
 protectedvirtual

Draws horizontal scrollbar buttons only.

Parameters
pDC | Target device context pointer
pScroll | Scroll bar object pointer
pMetrics | Precomputed scrollbar metrics

Reimplemented from CXTPScrollBarThemeWindowsUx.

◆ DrawButtons() [2/2]

virtual void DrawButtons | ( | CDC * | pDC,
 |  | CXTPScrollBase * | pScroll,
 |  | XTPScrollMetricsV * | pMetrics )
 protectedvirtual

Draws vertical scrollbar buttons only.

Parameters
pDC | Target device context pointer
pScroll | Scroll bar object pointer
pMetrics | Precomputed scrollbar metrics

Reimplemented from CXTPScrollBarThemeWindowsUx.

◆ DrawGripper()

virtual void DrawGripper | ( | CDC * | pDC,
 |  | CXTPScrollBase * | pScroll )
 protectedvirtual

Draws scrollbar gripper only.

Parameters
pDC | Target device context pointer
pScroll | Scroll bar object pointer

Reimplemented from CXTPScrollBarThemeWindowsUx.

◆ DrawThumbButton() [1/2]

virtual void DrawThumbButton | ( | CDC * | pDC,
 |  | CXTPScrollBase * | pScroll,
 |  | XTPScrollMetricsH * | pMetrics )
 protectedvirtual

Draws horizontal scrollbar thumb button only.

Parameters
pDC | Target device context pointer
pScroll | Scroll bar object pointer
pMetrics | Precomputed scrollbar metrics

Reimplemented from CXTPScrollBarThemeWindowsUx.

◆ DrawThumbButton() [2/2]

virtual void DrawThumbButton | ( | CDC * | pDC,
 |  | CXTPScrollBase * | pScroll,
 |  | XTPScrollMetricsV * | pMetrics )
 protectedvirtual

Draws vertical scrollbar thumb button only.

Parameters
pDC | Target device context pointer
pScroll | Scroll bar object pointer
pMetrics | Precomputed scrollbar metrics

Reimplemented from CXTPScrollBarThemeWindowsUx.

◆ DrawTracker() [1/2]

virtual void DrawTracker | ( | CDC * | pDC,
 |  | CXTPScrollBase * | pScroll,
 |  | XTPScrollMetricsH * | pMetrics )
 protectedvirtual

Draws horizontal scrollbar trackers only.

Parameters
pDC | Target device context pointer
pScroll | Scroll bar object pointer
pMetrics | Precomputed scrollbar metrics

Reimplemented from CXTPScrollBarThemeWindowsUx.

◆ DrawTracker() [2/2]

virtual void DrawTracker | ( | CDC * | pDC,
 |  | CXTPScrollBase * | pScroll,
 |  | XTPScrollMetricsV * | pMetrics )
 protectedvirtual

Draws vertical scrollbar trackers only.

Parameters
pDC | Target device context pointer
pScroll | Scroll bar object pointer
pMetrics | Precomputed scrollbar metrics

Reimplemented from CXTPScrollBarThemeWindowsUx.

The documentation for this class was generated from the following file:
  • XTPScrollBarThemeFlat.h


Toolkit Pro: CXTPScrollBarThemeNativeWindows10 Class Reference

List of all members
CXTPScrollBarThemeNativeWindows10 Class Reference

Scrollbar paint manager used to draw Native Windows 10 like scrollbars. More...

Inheritance diagram for CXTPScrollBarThemeNativeWindows10:
[legend]

Additional Inherited Members

- Public Member Functions inherited from CXTPScrollBarThemeOffice2013
CXTPScrollBarThemeOffice2013 ()
Constructs a CXTPScrollBarThemeOffice2013 object.
virtual | ~CXTPScrollBarThemeOffice2013 ()
Destructor, handles any cleanup / deallocation necessary.
virtual void | GetScrollBarColors (XTP_SCROLLBARDRAWCOLORS &sbc, int nHitSelected, int nHitPressed, BOOL bEnabled)
Used by the paint manager to retreive state colors used when drawing the scrollbar.
- Public Member Functions inherited from CXTPScrollBarPaintManager
CXTPScrollBarPaintManager ()
Constructs a CXTPScrollBarPaintManager object.
- Public Attributes inherited from CXTPScrollBarPaintManager
int | m_cxHScroll
Width, in pixels, of the arrow bitmap on a horizontal scroll bar.
int | m_cyHScroll
Height, in pixels, of a horizontal scroll bar.
int | m_cxVScroll
Width, in pixels, of a vertical scroll bar;.
int | m_cyVScroll
Height, in pixels, of the arrow bitmap on a vertical scroll bar.
int | m_cThumb
Width of thumb button.
COLORREF | m_crBackPushed
Color when pushed.
COLORREF | m_crBackHilite
Color when border.
COLORREF | m_crBorderHilite
Color of border when highlighted.
COLORREF | m_crBorder
Color of border.
COLORREF | m_crBack
Color of background.
- Protected Types inherited from CXTPScrollBarPaintManager
- Protected Member Functions inherited from CXTPScrollBarThemeOffice2013
virtual void | DrawScrollBar (CDC *pDC, CXTPScrollBase *pGallery)
This method is called to draw all scrollbar parts.
virtual void | RefreshMetrics ()
Recalculates scrollbar metrics.
virtual void | DrawBackground (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws verical scrollbar background only.
virtual void | DrawButtons (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws vertical scrollbar buttons only.
virtual void | DrawArrows (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws vertical scrollbar button arrows only.
virtual void | DrawThumbButton (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws vertical scrollbar thumb button only.
virtual void | DrawBackground (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar background only.
virtual void | DrawButtons (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar buttons only.
virtual void | DrawArrows (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar button arrows only.
virtual void | DrawThumbButton (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar thumb button only.
virtual void | DrawGripper (CDC *pDC, CXTPScrollBase *pScroll)
Draws scrollbar gripper only.
- Protected Member Functions inherited from CXTPScrollBarPaintManager
virtual void | DrawTracker (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws vertical scrollbar trackers only.
virtual void | DrawTracker (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar trackers only.
void | DrawArrowGlyph (CDC *pDC, CRect rcArrow, XTPArrowGlyph glyph, BOOL bEnabled, COLORREF clrText=COLORREF_NULL)
Draws scrollbar button arrow glyph.
- Static Protected Member Functions inherited from CXTPScrollBarPaintManager
static void AFX_CDECL | CalcVScroll (CXTPScrollBase *pScroll, XTPScrollMetricsV *pVScroll)
Computes vertical scrollbar mertics.
static void AFX_CDECL | CalcHScroll (CXTPScrollBase *pScroll, XTPScrollMetricsH *pHScroll)
Computes horizontal scrollbar mertics.
- Protected Attributes inherited from CXTPScrollBarThemeOffice2013
XTP_SCROLLBARINICOLORS | m_clrNormal
Holds scrollbar default state colors.
XTP_SCROLLBARINICOLORS | m_clrPressed
Holds scrollbar pressed state colors.
XTP_SCROLLBARINICOLORS | m_clrSelected
Holds scrollbar selected state colors.
XTP_SCROLLBARINICOLORS | m_clrDisabled
Holds scrollbar disabled state colors.
XTP_SCROLLBARDRAWCOLORS | m_clrCurrent
Holds currently selected scrollbar colors.

Detailed Description

Scrollbar paint manager used to draw Native Windows 10 like scrollbars.

See also
CXTPPaintManager::SetTheme
The documentation for this class was generated from the following file:
  • XTPScrollBarThemeNativeWindows10.h


Toolkit Pro: CXTPScrollBarThemeNativeWindows11 Class Reference

List of all members
CXTPScrollBarThemeNativeWindows11 Class Reference

Scrollbar paint manager used to draw Native Windows 10 like scrollbars. More...

Inheritance diagram for CXTPScrollBarThemeNativeWindows11:
[legend]

Additional Inherited Members

- Public Member Functions inherited from CXTPScrollBarThemeOffice2013
CXTPScrollBarThemeOffice2013 ()
Constructs a CXTPScrollBarThemeOffice2013 object.
virtual | ~CXTPScrollBarThemeOffice2013 ()
Destructor, handles any cleanup / deallocation necessary.
virtual void | GetScrollBarColors (XTP_SCROLLBARDRAWCOLORS &sbc, int nHitSelected, int nHitPressed, BOOL bEnabled)
Used by the paint manager to retreive state colors used when drawing the scrollbar.
- Public Member Functions inherited from CXTPScrollBarPaintManager
CXTPScrollBarPaintManager ()
Constructs a CXTPScrollBarPaintManager object.
- Public Attributes inherited from CXTPScrollBarPaintManager
int | m_cxHScroll
Width, in pixels, of the arrow bitmap on a horizontal scroll bar.
int | m_cyHScroll
Height, in pixels, of a horizontal scroll bar.
int | m_cxVScroll
Width, in pixels, of a vertical scroll bar;.
int | m_cyVScroll
Height, in pixels, of the arrow bitmap on a vertical scroll bar.
int | m_cThumb
Width of thumb button.
COLORREF | m_crBackPushed
Color when pushed.
COLORREF | m_crBackHilite
Color when border.
COLORREF | m_crBorderHilite
Color of border when highlighted.
COLORREF | m_crBorder
Color of border.
COLORREF | m_crBack
Color of background.
- Protected Types inherited from CXTPScrollBarPaintManager
- Protected Member Functions inherited from CXTPScrollBarThemeOffice2013
virtual void | DrawScrollBar (CDC *pDC, CXTPScrollBase *pGallery)
This method is called to draw all scrollbar parts.
virtual void | RefreshMetrics ()
Recalculates scrollbar metrics.
virtual void | DrawBackground (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws verical scrollbar background only.
virtual void | DrawButtons (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws vertical scrollbar buttons only.
virtual void | DrawArrows (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws vertical scrollbar button arrows only.
virtual void | DrawThumbButton (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws vertical scrollbar thumb button only.
virtual void | DrawBackground (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar background only.
virtual void | DrawButtons (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar buttons only.
virtual void | DrawArrows (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar button arrows only.
virtual void | DrawThumbButton (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar thumb button only.
virtual void | DrawGripper (CDC *pDC, CXTPScrollBase *pScroll)
Draws scrollbar gripper only.
- Protected Member Functions inherited from CXTPScrollBarPaintManager
virtual void | DrawTracker (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws vertical scrollbar trackers only.
virtual void | DrawTracker (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar trackers only.
void | DrawArrowGlyph (CDC *pDC, CRect rcArrow, XTPArrowGlyph glyph, BOOL bEnabled, COLORREF clrText=COLORREF_NULL)
Draws scrollbar button arrow glyph.
- Static Protected Member Functions inherited from CXTPScrollBarPaintManager
static void AFX_CDECL | CalcVScroll (CXTPScrollBase *pScroll, XTPScrollMetricsV *pVScroll)
Computes vertical scrollbar mertics.
static void AFX_CDECL | CalcHScroll (CXTPScrollBase *pScroll, XTPScrollMetricsH *pHScroll)
Computes horizontal scrollbar mertics.
- Protected Attributes inherited from CXTPScrollBarThemeOffice2013
XTP_SCROLLBARINICOLORS | m_clrNormal
Holds scrollbar default state colors.
XTP_SCROLLBARINICOLORS | m_clrPressed
Holds scrollbar pressed state colors.
XTP_SCROLLBARINICOLORS | m_clrSelected
Holds scrollbar selected state colors.
XTP_SCROLLBARINICOLORS | m_clrDisabled
Holds scrollbar disabled state colors.
XTP_SCROLLBARDRAWCOLORS | m_clrCurrent
Holds currently selected scrollbar colors.

Detailed Description

Scrollbar paint manager used to draw Native Windows 10 like scrollbars.

See also
CXTPPaintManager::SetTheme
The documentation for this class was generated from the following file:
  • XTPScrollBarThemeNativeWindows11.h


Toolkit Pro: CXTPScrollBarThemeOffice2000 Class Reference

Protected Member Functions | List of all members
CXTPScrollBarThemeOffice2000 Class Reference

Scrollbar paint manager used to draw Office 200 like scrollbars. More...

Inheritance diagram for CXTPScrollBarThemeOffice2000:
[legend]

Protected Member Functions

virtual void | DrawButtons (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws vertical scrollbar buttons only.
virtual void | DrawArrows (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws vertical scrollbar button arrows only.
virtual void | DrawButtons (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar buttons only.
virtual void | DrawArrows (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar button arrows only.
- Protected Member Functions inherited from CXTPScrollBarThemeWindowsUx
virtual void | RefreshMetrics ()
Recalculates scrollbar metrics.
virtual void | DrawTracker (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws vertical scrollbar trackers only.
virtual void | DrawThumbButton (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws vertical scrollbar thumb button only.
virtual void | DrawTracker (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar trackers only.
virtual void | DrawThumbButton (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar thumb button only.
virtual void | DrawGripper (CDC *pDC, CXTPScrollBase *pScroll)
Draws scrollbar gripper only.
- Protected Member Functions inherited from CXTPScrollBarThemeWindowsClassic
- Protected Member Functions inherited from CXTPScrollBarPaintManager
virtual void | DrawBackground (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws verical scrollbar background only.
virtual void | DrawBackground (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar background only.
void | DrawArrowGlyph (CDC *pDC, CRect rcArrow, XTPArrowGlyph glyph, BOOL bEnabled, COLORREF clrText=COLORREF_NULL)
Draws scrollbar button arrow glyph.

Additional Inherited Members

- Public Member Functions inherited from CXTPScrollBarThemeWindowsUx
CXTPScrollBarThemeWindowsUx ()
Constructs a CXTPScrollBarThemeWindowsUx object.
virtual | ~CXTPScrollBarThemeWindowsUx ()
Destroys a CXTPScrollBarThemeWindowsUx object, handles cleanup and deallocation.
- Public Member Functions inherited from CXTPScrollBarPaintManager
CXTPScrollBarPaintManager ()
Constructs a CXTPScrollBarPaintManager object.
virtual void | DrawScrollBar (CDC *pDC, CXTPScrollBase *pScrollBar)
This method is called to draw all scrollbar parts.
- Public Attributes inherited from CXTPScrollBarPaintManager
int | m_cxHScroll
Width, in pixels, of the arrow bitmap on a horizontal scroll bar.
int | m_cyHScroll
Height, in pixels, of a horizontal scroll bar.
int | m_cxVScroll
Width, in pixels, of a vertical scroll bar;.
int | m_cyVScroll
Height, in pixels, of the arrow bitmap on a vertical scroll bar.
int | m_cThumb
Width of thumb button.
COLORREF | m_crBackPushed
Color when pushed.
COLORREF | m_crBackHilite
Color when border.
COLORREF | m_crBorderHilite
Color of border when highlighted.
COLORREF | m_crBorder
Color of border.
COLORREF | m_crBack
Color of background.
- Protected Types inherited from CXTPScrollBarPaintManager
- Static Protected Member Functions inherited from CXTPScrollBarPaintManager
static void AFX_CDECL | CalcVScroll (CXTPScrollBase *pScroll, XTPScrollMetricsV *pVScroll)
Computes vertical scrollbar mertics.
static void AFX_CDECL | CalcHScroll (CXTPScrollBase *pScroll, XTPScrollMetricsH *pHScroll)
Computes horizontal scrollbar mertics.

Detailed Description

Scrollbar paint manager used to draw Office 200 like scrollbars.

See also
CXTPPaintManager::SetTheme

Member Function Documentation

◆ DrawArrows() [1/2]

virtual void DrawArrows | ( | CDC * | pDC,
 |  | CXTPScrollBase * | pScroll,
 |  | XTPScrollMetricsH * | pMetrics )
 protectedvirtual

Draws horizontal scrollbar button arrows only.

Parameters
pDC | Target device context pointer
pScroll | Scroll bar object pointer
pMetrics | Precomputed scrollbar metrics

Reimplemented from CXTPScrollBarPaintManager.

◆ DrawArrows() [2/2]

virtual void DrawArrows | ( | CDC * | pDC,
 |  | CXTPScrollBase * | pScroll,
 |  | XTPScrollMetricsV * | pMetrics )
 protectedvirtual

Draws vertical scrollbar button arrows only.

Parameters
pDC | Target device context pointer
pScroll | Scroll bar object pointer
pMetrics | Precomputed scrollbar metrics

Reimplemented from CXTPScrollBarPaintManager.

◆ DrawButtons() [1/2]

virtual void DrawButtons | ( | CDC * | pDC,
 |  | CXTPScrollBase * | pScroll,
 |  | XTPScrollMetricsH * | pMetrics )
 protectedvirtual

Draws horizontal scrollbar buttons only.

Parameters
pDC | Target device context pointer
pScroll | Scroll bar object pointer
pMetrics | Precomputed scrollbar metrics

Reimplemented from CXTPScrollBarThemeWindowsUx.

◆ DrawButtons() [2/2]

virtual void DrawButtons | ( | CDC * | pDC,
 |  | CXTPScrollBase * | pScroll,
 |  | XTPScrollMetricsV * | pMetrics )
 protectedvirtual

Draws vertical scrollbar buttons only.

Parameters
pDC | Target device context pointer
pScroll | Scroll bar object pointer
pMetrics | Precomputed scrollbar metrics

Reimplemented from CXTPScrollBarThemeWindowsUx.

The documentation for this class was generated from the following file:
  • XTPScrollBarThemeOffice2000.h


Toolkit Pro: CXTPScrollBarThemeOffice2003 Class Reference

Protected Member Functions | List of all members
CXTPScrollBarThemeOffice2003 Class Reference

Scrollbar paint manager used to draw Office 2003 like scrollbars. More...

Inheritance diagram for CXTPScrollBarThemeOffice2003:
[legend]

Protected Member Functions

virtual void | RefreshMetrics ()
Recalculates scrollbar metrics.
- Protected Member Functions inherited from CXTPScrollBarThemeWindowsUx
virtual void | DrawButtons (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws vertical scrollbar buttons only.
virtual void | DrawTracker (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws vertical scrollbar trackers only.
virtual void | DrawThumbButton (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws vertical scrollbar thumb button only.
virtual void | DrawButtons (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar buttons only.
virtual void | DrawTracker (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar trackers only.
virtual void | DrawThumbButton (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar thumb button only.
virtual void | DrawGripper (CDC *pDC, CXTPScrollBase *pScroll)
Draws scrollbar gripper only.
- Protected Member Functions inherited from CXTPScrollBarThemeWindowsClassic
- Protected Member Functions inherited from CXTPScrollBarPaintManager
virtual void | DrawBackground (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws verical scrollbar background only.
virtual void | DrawArrows (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws vertical scrollbar button arrows only.
virtual void | DrawBackground (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar background only.
virtual void | DrawArrows (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar button arrows only.
void | DrawArrowGlyph (CDC *pDC, CRect rcArrow, XTPArrowGlyph glyph, BOOL bEnabled, COLORREF clrText=COLORREF_NULL)
Draws scrollbar button arrow glyph.

Additional Inherited Members

- Public Member Functions inherited from CXTPScrollBarThemeWindowsUx
CXTPScrollBarThemeWindowsUx ()
Constructs a CXTPScrollBarThemeWindowsUx object.
virtual | ~CXTPScrollBarThemeWindowsUx ()
Destroys a CXTPScrollBarThemeWindowsUx object, handles cleanup and deallocation.
- Public Member Functions inherited from CXTPScrollBarPaintManager
CXTPScrollBarPaintManager ()
Constructs a CXTPScrollBarPaintManager object.
virtual void | DrawScrollBar (CDC *pDC, CXTPScrollBase *pScrollBar)
This method is called to draw all scrollbar parts.
- Public Attributes inherited from CXTPScrollBarPaintManager
int | m_cxHScroll
Width, in pixels, of the arrow bitmap on a horizontal scroll bar.
int | m_cyHScroll
Height, in pixels, of a horizontal scroll bar.
int | m_cxVScroll
Width, in pixels, of a vertical scroll bar;.
int | m_cyVScroll
Height, in pixels, of the arrow bitmap on a vertical scroll bar.
int | m_cThumb
Width of thumb button.
COLORREF | m_crBackPushed
Color when pushed.
COLORREF | m_crBackHilite
Color when border.
COLORREF | m_crBorderHilite
Color of border when highlighted.
COLORREF | m_crBorder
Color of border.
COLORREF | m_crBack
Color of background.
- Protected Types inherited from CXTPScrollBarPaintManager
- Static Protected Member Functions inherited from CXTPScrollBarPaintManager
static void AFX_CDECL | CalcVScroll (CXTPScrollBase *pScroll, XTPScrollMetricsV *pVScroll)
Computes vertical scrollbar mertics.
static void AFX_CDECL | CalcHScroll (CXTPScrollBase *pScroll, XTPScrollMetricsH *pHScroll)
Computes horizontal scrollbar mertics.

Detailed Description

Scrollbar paint manager used to draw Office 2003 like scrollbars.

See also
CXTPPaintManager::SetTheme
The documentation for this class was generated from the following file:
  • XTPScrollBarThemeOffice2003.h


Toolkit Pro: CXTPScrollBarThemeOffice2013 Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPScrollBarThemeOffice2013 Class Reference

The CXTPScrollBarThemeOffice2013 class is used to enable a Gallery Office 2013 style theme for Command Bars. More...

Inheritance diagram for CXTPScrollBarThemeOffice2013:
[legend]

Public Member Functions

CXTPScrollBarThemeOffice2013 ()
Constructs a CXTPScrollBarThemeOffice2013 object.
virtual | ~CXTPScrollBarThemeOffice2013 ()
Destructor, handles any cleanup / deallocation necessary.
virtual void | GetScrollBarColors (XTP_SCROLLBARDRAWCOLORS &sbc, int nHitSelected, int nHitPressed, BOOL bEnabled)
Used by the paint manager to retreive state colors used when drawing the scrollbar.
- Public Member Functions inherited from CXTPScrollBarPaintManager
CXTPScrollBarPaintManager ()
Constructs a CXTPScrollBarPaintManager object.

Protected Member Functions

virtual void | DrawScrollBar (CDC *pDC, CXTPScrollBase *pGallery)
This method is called to draw all scrollbar parts.
virtual void | RefreshMetrics ()
Recalculates scrollbar metrics.
virtual void | DrawBackground (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws verical scrollbar background only.
virtual void | DrawButtons (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws vertical scrollbar buttons only.
virtual void | DrawArrows (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws vertical scrollbar button arrows only.
virtual void | DrawThumbButton (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws vertical scrollbar thumb button only.
virtual void | DrawBackground (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar background only.
virtual void | DrawButtons (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar buttons only.
virtual void | DrawArrows (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar button arrows only.
virtual void | DrawThumbButton (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar thumb button only.
virtual void | DrawGripper (CDC *pDC, CXTPScrollBase *pScroll)
Draws scrollbar gripper only.
- Protected Member Functions inherited from CXTPScrollBarPaintManager
virtual void | DrawTracker (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws vertical scrollbar trackers only.
virtual void | DrawTracker (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar trackers only.
void | DrawArrowGlyph (CDC *pDC, CRect rcArrow, XTPArrowGlyph glyph, BOOL bEnabled, COLORREF clrText=COLORREF_NULL)
Draws scrollbar button arrow glyph.

Protected Attributes

XTP_SCROLLBARINICOLORS | m_clrNormal
Holds scrollbar default state colors.
XTP_SCROLLBARINICOLORS | m_clrPressed
Holds scrollbar pressed state colors.
XTP_SCROLLBARINICOLORS | m_clrSelected
Holds scrollbar selected state colors.
XTP_SCROLLBARINICOLORS | m_clrDisabled
Holds scrollbar disabled state colors.
XTP_SCROLLBARDRAWCOLORS | m_clrCurrent
Holds currently selected scrollbar colors.

Additional Inherited Members

- Public Attributes inherited from CXTPScrollBarPaintManager
int | m_cxHScroll
Width, in pixels, of the arrow bitmap on a horizontal scroll bar.
int | m_cyHScroll
Height, in pixels, of a horizontal scroll bar.
int | m_cxVScroll
Width, in pixels, of a vertical scroll bar;.
int | m_cyVScroll
Height, in pixels, of the arrow bitmap on a vertical scroll bar.
int | m_cThumb
Width of thumb button.
COLORREF | m_crBackPushed
Color when pushed.
COLORREF | m_crBackHilite
Color when border.
COLORREF | m_crBorderHilite
Color of border when highlighted.
COLORREF | m_crBorder
Color of border.
COLORREF | m_crBack
Color of background.
- Protected Types inherited from CXTPScrollBarPaintManager
- Static Protected Member Functions inherited from CXTPScrollBarPaintManager
static void AFX_CDECL | CalcVScroll (CXTPScrollBase *pScroll, XTPScrollMetricsV *pVScroll)
Computes vertical scrollbar mertics.
static void AFX_CDECL | CalcHScroll (CXTPScrollBase *pScroll, XTPScrollMetricsH *pHScroll)
Computes horizontal scrollbar mertics.

Detailed Description

The CXTPScrollBarThemeOffice2013 class is used to enable a Gallery Office 2013 style theme for Command Bars.

See also
CXTPPaintManager::SetTheme

Member Function Documentation

◆ DrawArrows() [1/2]

virtual void DrawArrows | ( | CDC * | pDC,
 |  | CXTPScrollBase * | pScroll,
 |  | XTPScrollMetricsH * | pMetrics )
 protectedvirtual

Draws horizontal scrollbar button arrows only.

Parameters
pDC | Target device context pointer
pScroll | Scroll bar object pointer
pMetrics | Precomputed scrollbar metrics

Reimplemented from CXTPScrollBarPaintManager.

◆ DrawArrows() [2/2]

virtual void DrawArrows | ( | CDC * | pDC,
 |  | CXTPScrollBase * | pScroll,
 |  | XTPScrollMetricsV * | pMetrics )
 protectedvirtual

Draws vertical scrollbar button arrows only.

Parameters
pDC | Target device context pointer
pScroll | Scroll bar object pointer
pMetrics | Precomputed scrollbar metrics

Reimplemented from CXTPScrollBarPaintManager.

◆ DrawBackground() [1/2]

virtual void DrawBackground | ( | CDC * | pDC,
 |  | CXTPScrollBase * | pScroll,
 |  | XTPScrollMetricsH * | pMetrics )
 protectedvirtual

Draws horizontal scrollbar background only.

Parameters
pDC | Target device context pointer
pScroll | Scroll bar object pointer
pMetrics | Precomputed scrollbar metrics

Reimplemented from CXTPScrollBarPaintManager.

◆ DrawBackground() [2/2]

virtual void DrawBackground | ( | CDC * | pDC,
 |  | CXTPScrollBase * | pScroll,
 |  | XTPScrollMetricsV * | pMetrics )
 protectedvirtual

Draws verical scrollbar background only.

Parameters
pDC | Target device context pointer
pScroll | Scroll bar object pointer
pMetrics | Precomputed scrollbar metrics

Reimplemented from CXTPScrollBarPaintManager.

◆ DrawButtons() [1/2]

virtual void DrawButtons | ( | CDC * | pDC,
 |  | CXTPScrollBase * | pScroll,
 |  | XTPScrollMetricsH * | pMetrics )
 protectedvirtual

Draws horizontal scrollbar buttons only.

Parameters
pDC | Target device context pointer
pScroll | Scroll bar object pointer
pMetrics | Precomputed scrollbar metrics

Reimplemented from CXTPScrollBarPaintManager.

◆ DrawButtons() [2/2]

virtual void DrawButtons | ( | CDC * | pDC,
 |  | CXTPScrollBase * | pScroll,
 |  | XTPScrollMetricsV * | pMetrics )
 protectedvirtual

Draws vertical scrollbar buttons only.

Parameters
pDC | Target device context pointer
pScroll | Scroll bar object pointer
pMetrics | Precomputed scrollbar metrics

Reimplemented from CXTPScrollBarPaintManager.

◆ DrawGripper()

virtual void DrawGripper | ( | CDC * | pDC,
 |  | CXTPScrollBase * | pScroll )
 protectedvirtual

Draws scrollbar gripper only.

Parameters
pDC | Target device context pointer
pScroll | Scroll bar object pointer

Reimplemented from CXTPScrollBarPaintManager.

◆ DrawScrollBar()

virtual void DrawScrollBar | ( | CDC * | pDC,
 |  | CXTPScrollBase * | pGallery )
 protectedvirtual

This method is called to draw all scrollbar parts.

Parameters
pDC | Pointer to device context
pGallery | ScrollBar to draw

Reimplemented from CXTPScrollBarPaintManager.

◆ DrawThumbButton() [1/2]

virtual void DrawThumbButton | ( | CDC * | pDC,
 |  | CXTPScrollBase * | pScroll,
 |  | XTPScrollMetricsH * | pMetrics )
 protectedvirtual

Draws horizontal scrollbar thumb button only.

Parameters
pDC | Target device context pointer
pScroll | Scroll bar object pointer
pMetrics | Precomputed scrollbar metrics

Reimplemented from CXTPScrollBarPaintManager.

◆ DrawThumbButton() [2/2]

virtual void DrawThumbButton | ( | CDC * | pDC,
 |  | CXTPScrollBase * | pScroll,
 |  | XTPScrollMetricsV * | pMetrics )
 protectedvirtual

Draws vertical scrollbar thumb button only.

Parameters
pDC | Target device context pointer
pScroll | Scroll bar object pointer
pMetrics | Precomputed scrollbar metrics

Reimplemented from CXTPScrollBarPaintManager.

◆ GetScrollBarColors()

virtual void GetScrollBarColors | ( | XTP_SCROLLBARDRAWCOLORS & | sbc,
 |  | int | nHitSelected,
 |  | int | nHitPressed,
 |  | BOOL | bEnabled )
 virtual

Used by the paint manager to retreive state colors used when drawing the scrollbar.

Parameters
sbc | Reference to a XTP_SCROLLBARDRAWCOLORS that recives state color values.
nHitSelected | Contains selected hit test index value, see remarks for more details.
nHitPressed | Contains pressed hit test index value, see remarks for more details.
bEnabled | TRUE if the scrollbar is enabled, otherwise FALSE.

The nHitSelected and nHitPressed values contain an index id which identifies the scroll button and thumb track state. Possible values are XTP_HTSCROLLUP, XTP_HTSCROLLLEFT, XTP_HTSCROLLDOWN, XTP_HTSCROLLRIGHT and XTP_HTSCROLLTHUMB. So for example if nHitPressed equals XTP_HTSCROLLDOWN, that would indicate the down scroll arrow has been pressed.

See also
XTP_SCROLLBARDRAWCOLORS
The documentation for this class was generated from the following file:
  • XTPScrollBarThemeOffice2013.h


Toolkit Pro: CXTPScrollBarThemeOfficeXP Class Reference

Protected Member Functions | List of all members
CXTPScrollBarThemeOfficeXP Class Reference

Scrollbar paint manager used to draw Office XP like scrollbars. More...

Inheritance diagram for CXTPScrollBarThemeOfficeXP:
[legend]

Protected Member Functions

virtual void | RefreshMetrics ()
Recalculates scrollbar metrics.
- Protected Member Functions inherited from CXTPScrollBarThemeWindowsUx
virtual void | DrawButtons (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws vertical scrollbar buttons only.
virtual void | DrawTracker (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws vertical scrollbar trackers only.
virtual void | DrawThumbButton (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws vertical scrollbar thumb button only.
virtual void | DrawButtons (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar buttons only.
virtual void | DrawTracker (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar trackers only.
virtual void | DrawThumbButton (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar thumb button only.
virtual void | DrawGripper (CDC *pDC, CXTPScrollBase *pScroll)
Draws scrollbar gripper only.
- Protected Member Functions inherited from CXTPScrollBarThemeWindowsClassic
- Protected Member Functions inherited from CXTPScrollBarPaintManager
virtual void | DrawBackground (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws verical scrollbar background only.
virtual void | DrawArrows (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws vertical scrollbar button arrows only.
virtual void | DrawBackground (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar background only.
virtual void | DrawArrows (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar button arrows only.
void | DrawArrowGlyph (CDC *pDC, CRect rcArrow, XTPArrowGlyph glyph, BOOL bEnabled, COLORREF clrText=COLORREF_NULL)
Draws scrollbar button arrow glyph.

Additional Inherited Members

- Public Member Functions inherited from CXTPScrollBarThemeWindowsUx
CXTPScrollBarThemeWindowsUx ()
Constructs a CXTPScrollBarThemeWindowsUx object.
virtual | ~CXTPScrollBarThemeWindowsUx ()
Destroys a CXTPScrollBarThemeWindowsUx object, handles cleanup and deallocation.
- Public Member Functions inherited from CXTPScrollBarPaintManager
CXTPScrollBarPaintManager ()
Constructs a CXTPScrollBarPaintManager object.
virtual void | DrawScrollBar (CDC *pDC, CXTPScrollBase *pScrollBar)
This method is called to draw all scrollbar parts.
- Public Attributes inherited from CXTPScrollBarPaintManager
int | m_cxHScroll
Width, in pixels, of the arrow bitmap on a horizontal scroll bar.
int | m_cyHScroll
Height, in pixels, of a horizontal scroll bar.
int | m_cxVScroll
Width, in pixels, of a vertical scroll bar;.
int | m_cyVScroll
Height, in pixels, of the arrow bitmap on a vertical scroll bar.
int | m_cThumb
Width of thumb button.
COLORREF | m_crBackPushed
Color when pushed.
COLORREF | m_crBackHilite
Color when border.
COLORREF | m_crBorderHilite
Color of border when highlighted.
COLORREF | m_crBorder
Color of border.
COLORREF | m_crBack
Color of background.
- Protected Types inherited from CXTPScrollBarPaintManager
- Static Protected Member Functions inherited from CXTPScrollBarPaintManager
static void AFX_CDECL | CalcVScroll (CXTPScrollBase *pScroll, XTPScrollMetricsV *pVScroll)
Computes vertical scrollbar mertics.
static void AFX_CDECL | CalcHScroll (CXTPScrollBase *pScroll, XTPScrollMetricsH *pHScroll)
Computes horizontal scrollbar mertics.

Detailed Description

Scrollbar paint manager used to draw Office XP like scrollbars.

See also
CXTPPaintManager::SetTheme
The documentation for this class was generated from the following file:
  • XTPScrollBarThemeOfficeXP.h


Toolkit Pro: CXTPScrollBarThemeResource Class Reference

Protected Member Functions | List of all members
CXTPScrollBarThemeResource Class Reference

Scrollbar paint manager used to draw scrollbars from the currently loaded resource image data. More...

Inheritance diagram for CXTPScrollBarThemeResource:
[legend]

Protected Member Functions

virtual void | DrawScrollBar (CDC *pDC, CXTPScrollBase *pScrollBar)
This method is called to draw all scrollbar parts.
virtual void | DrawBackground (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws verical scrollbar background only.
virtual void | DrawButtons (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws vertical scrollbar buttons only.
virtual void | DrawArrows (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws vertical scrollbar button arrows only.
virtual void | DrawTracker (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws vertical scrollbar trackers only.
virtual void | DrawThumbButton (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws vertical scrollbar thumb button only.
virtual void | DrawBackground (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar background only.
virtual void | DrawButtons (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar buttons only.
virtual void | DrawArrows (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar button arrows only.
virtual void | DrawTracker (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar trackers only.
virtual void | DrawThumbButton (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar thumb button only.
virtual void | DrawGripper (CDC *pDC, CXTPScrollBase *pScroll)
Draws scrollbar gripper only.
CXTPResourceImage * | LoadImage (LPCTSTR lpszImageFile)
Loads image resource by its name.
- Protected Member Functions inherited from CXTPScrollBarPaintManager
void | DrawArrowGlyph (CDC *pDC, CRect rcArrow, XTPArrowGlyph glyph, BOOL bEnabled, COLORREF clrText=COLORREF_NULL)
Draws scrollbar button arrow glyph.

Additional Inherited Members

- Public Member Functions inherited from CXTPScrollBarPaintManager
CXTPScrollBarPaintManager ()
Constructs a CXTPScrollBarPaintManager object.
virtual void | RefreshMetrics ()
Recalculates scrollbar metrics.
- Public Attributes inherited from CXTPScrollBarPaintManager
int | m_cxHScroll
Width, in pixels, of the arrow bitmap on a horizontal scroll bar.
int | m_cyHScroll
Height, in pixels, of a horizontal scroll bar.
int | m_cxVScroll
Width, in pixels, of a vertical scroll bar;.
int | m_cyVScroll
Height, in pixels, of the arrow bitmap on a vertical scroll bar.
int | m_cThumb
Width of thumb button.
COLORREF | m_crBackPushed
Color when pushed.
COLORREF | m_crBackHilite
Color when border.
COLORREF | m_crBorderHilite
Color of border when highlighted.
COLORREF | m_crBorder
Color of border.
COLORREF | m_crBack
Color of background.
- Protected Types inherited from CXTPScrollBarPaintManager
- Static Protected Member Functions inherited from CXTPScrollBarPaintManager
static void AFX_CDECL | CalcVScroll (CXTPScrollBase *pScroll, XTPScrollMetricsV *pVScroll)
Computes vertical scrollbar mertics.
static void AFX_CDECL | CalcHScroll (CXTPScrollBase *pScroll, XTPScrollMetricsH *pHScroll)
Computes horizontal scrollbar mertics.

Detailed Description

Scrollbar paint manager used to draw scrollbars from the currently loaded resource image data.

See also
CXTPPaintManager::SetTheme

Member Function Documentation

◆ DrawArrows() [1/2]

virtual void DrawArrows | ( | CDC * | pDC,
 |  | CXTPScrollBase * | pScroll,
 |  | XTPScrollMetricsH * | pMetrics )
 protectedvirtual

Draws horizontal scrollbar button arrows only.

Parameters
pDC | Target device context pointer
pScroll | Scroll bar object pointer
pMetrics | Precomputed scrollbar metrics

Reimplemented from CXTPScrollBarPaintManager.

◆ DrawArrows() [2/2]

virtual void DrawArrows | ( | CDC * | pDC,
 |  | CXTPScrollBase * | pScroll,
 |  | XTPScrollMetricsV * | pMetrics )
 protectedvirtual

Draws vertical scrollbar button arrows only.

Parameters
pDC | Target device context pointer
pScroll | Scroll bar object pointer
pMetrics | Precomputed scrollbar metrics

Reimplemented from CXTPScrollBarPaintManager.

◆ DrawBackground() [1/2]

virtual void DrawBackground | ( | CDC * | pDC,
 |  | CXTPScrollBase * | pScroll,
 |  | XTPScrollMetricsH * | pMetrics )
 protectedvirtual

Draws horizontal scrollbar background only.

Parameters
pDC | Target device context pointer
pScroll | Scroll bar object pointer
pMetrics | Precomputed scrollbar metrics

Reimplemented from CXTPScrollBarPaintManager.

◆ DrawBackground() [2/2]

virtual void DrawBackground | ( | CDC * | pDC,
 |  | CXTPScrollBase * | pScroll,
 |  | XTPScrollMetricsV * | pMetrics )
 protectedvirtual

Draws verical scrollbar background only.

Parameters
pDC | Target device context pointer
pScroll | Scroll bar object pointer
pMetrics | Precomputed scrollbar metrics

Reimplemented from CXTPScrollBarPaintManager.

◆ DrawButtons() [1/2]

virtual void DrawButtons | ( | CDC * | pDC,
 |  | CXTPScrollBase * | pScroll,
 |  | XTPScrollMetricsH * | pMetrics )
 protectedvirtual

Draws horizontal scrollbar buttons only.

Parameters
pDC | Target device context pointer
pScroll | Scroll bar object pointer
pMetrics | Precomputed scrollbar metrics

Reimplemented from CXTPScrollBarPaintManager.

◆ DrawButtons() [2/2]

virtual void DrawButtons | ( | CDC * | pDC,
 |  | CXTPScrollBase * | pScroll,
 |  | XTPScrollMetricsV * | pMetrics )
 protectedvirtual

Draws vertical scrollbar buttons only.

Parameters
pDC | Target device context pointer
pScroll | Scroll bar object pointer
pMetrics | Precomputed scrollbar metrics

Reimplemented from CXTPScrollBarPaintManager.

◆ DrawGripper()

virtual void DrawGripper | ( | CDC * | pDC,
 |  | CXTPScrollBase * | pScroll )
 protectedvirtual

Draws scrollbar gripper only.

Parameters
pDC | Target device context pointer
pScroll | Scroll bar object pointer

Reimplemented from CXTPScrollBarPaintManager.

◆ DrawScrollBar()

virtual void DrawScrollBar | ( | CDC * | pDC,
 |  | CXTPScrollBase * | pScrollBar )
 protectedvirtual

This method is called to draw all scrollbar parts.

Parameters
pDC | Pointer to device context
pScrollBar | ScrollBar to draw

Reimplemented from CXTPScrollBarPaintManager.

◆ DrawThumbButton() [1/2]

virtual void DrawThumbButton | ( | CDC * | pDC,
 |  | CXTPScrollBase * | pScroll,
 |  | XTPScrollMetricsH * | pMetrics )
 protectedvirtual

Draws horizontal scrollbar thumb button only.

Parameters
pDC | Target device context pointer
pScroll | Scroll bar object pointer
pMetrics | Precomputed scrollbar metrics

Reimplemented from CXTPScrollBarPaintManager.

◆ DrawThumbButton() [2/2]

virtual void DrawThumbButton | ( | CDC * | pDC,
 |  | CXTPScrollBase * | pScroll,
 |  | XTPScrollMetricsV * | pMetrics )
 protectedvirtual

Draws vertical scrollbar thumb button only.

Parameters
pDC | Target device context pointer
pScroll | Scroll bar object pointer
pMetrics | Precomputed scrollbar metrics

Reimplemented from CXTPScrollBarPaintManager.

◆ DrawTracker() [1/2]

virtual void DrawTracker | ( | CDC * | pDC,
 |  | CXTPScrollBase * | pScroll,
 |  | XTPScrollMetricsH * | pMetrics )
 protectedvirtual

Draws horizontal scrollbar trackers only.

Parameters
pDC | Target device context pointer
pScroll | Scroll bar object pointer
pMetrics | Precomputed scrollbar metrics

Reimplemented from CXTPScrollBarPaintManager.

◆ DrawTracker() [2/2]

virtual void DrawTracker | ( | CDC * | pDC,
 |  | CXTPScrollBase * | pScroll,
 |  | XTPScrollMetricsV * | pMetrics )
 protectedvirtual

Draws vertical scrollbar trackers only.

Parameters
pDC | Target device context pointer
pScroll | Scroll bar object pointer
pMetrics | Precomputed scrollbar metrics

Reimplemented from CXTPScrollBarPaintManager.

◆ LoadImage()

CXTPResourceImage * LoadImage ( LPCTSTR lpszImageFile )
protected

Loads image resource by its name.

Parameters
lpszImageFile Image resource name to load.
Returns
A pointer to a loaded resource image or NULL if it's not found.
The documentation for this class was generated from the following file:
  • XTPScrollBarThemeResource.h


Toolkit Pro: CXTPScrollBarThemeUltraFlat Class Reference

Protected Member Functions | List of all members
CXTPScrollBarThemeUltraFlat Class Reference

Scrollbar paint manager used to draw ultra flat scrollbars. More...

Inheritance diagram for CXTPScrollBarThemeUltraFlat:
[legend]

Protected Member Functions

virtual void | RefreshMetrics ()
Recalculates scrollbar metrics.
- Protected Member Functions inherited from CXTPScrollBarThemeFlat
virtual void | DrawButtons (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws vertical scrollbar buttons only.
virtual void | DrawArrows (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws vertical scrollbar button arrows only.
virtual void | DrawTracker (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws vertical scrollbar trackers only.
virtual void | DrawThumbButton (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws vertical scrollbar thumb button only.
virtual void | DrawButtons (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar buttons only.
virtual void | DrawArrows (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar button arrows only.
virtual void | DrawTracker (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar trackers only.
virtual void | DrawThumbButton (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar thumb button only.
virtual void | DrawGripper (CDC *pDC, CXTPScrollBase *pScroll)
Draws scrollbar gripper only.
- Protected Member Functions inherited from CXTPScrollBarThemeWindowsUx
- Protected Member Functions inherited from CXTPScrollBarThemeWindowsClassic
- Protected Member Functions inherited from CXTPScrollBarPaintManager
virtual void | DrawBackground (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws verical scrollbar background only.
virtual void | DrawBackground (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar background only.
void | DrawArrowGlyph (CDC *pDC, CRect rcArrow, XTPArrowGlyph glyph, BOOL bEnabled, COLORREF clrText=COLORREF_NULL)
Draws scrollbar button arrow glyph.

Additional Inherited Members

- Public Member Functions inherited from CXTPScrollBarThemeWindowsUx
CXTPScrollBarThemeWindowsUx ()
Constructs a CXTPScrollBarThemeWindowsUx object.
virtual | ~CXTPScrollBarThemeWindowsUx ()
Destroys a CXTPScrollBarThemeWindowsUx object, handles cleanup and deallocation.
- Public Member Functions inherited from CXTPScrollBarPaintManager
CXTPScrollBarPaintManager ()
Constructs a CXTPScrollBarPaintManager object.
virtual void | DrawScrollBar (CDC *pDC, CXTPScrollBase *pScrollBar)
This method is called to draw all scrollbar parts.
- Public Attributes inherited from CXTPScrollBarPaintManager
int | m_cxHScroll
Width, in pixels, of the arrow bitmap on a horizontal scroll bar.
int | m_cyHScroll
Height, in pixels, of a horizontal scroll bar.
int | m_cxVScroll
Width, in pixels, of a vertical scroll bar;.
int | m_cyVScroll
Height, in pixels, of the arrow bitmap on a vertical scroll bar.
int | m_cThumb
Width of thumb button.
COLORREF | m_crBackPushed
Color when pushed.
COLORREF | m_crBackHilite
Color when border.
COLORREF | m_crBorderHilite
Color of border when highlighted.
COLORREF | m_crBorder
Color of border.
COLORREF | m_crBack
Color of background.
- Protected Types inherited from CXTPScrollBarPaintManager
- Static Protected Member Functions inherited from CXTPScrollBarPaintManager
static void AFX_CDECL | CalcVScroll (CXTPScrollBase *pScroll, XTPScrollMetricsV *pVScroll)
Computes vertical scrollbar mertics.
static void AFX_CDECL | CalcHScroll (CXTPScrollBase *pScroll, XTPScrollMetricsH *pHScroll)
Computes horizontal scrollbar mertics.

Detailed Description

Scrollbar paint manager used to draw ultra flat scrollbars.

See also
CXTPPaintManager::SetTheme
The documentation for this class was generated from the following file:
  • XTPScrollBarThemeUltraFlat.h


Toolkit Pro: CXTPScrollBarThemeVisualStudio2012 Class Reference

Protected Member Functions | List of all members
CXTPScrollBarThemeVisualStudio2012 Class Reference

Scrollbar paint manager used to draw Visual Studio 2012 like scrollbars. More...

Inheritance diagram for CXTPScrollBarThemeVisualStudio2012:
[legend]

Protected Member Functions

virtual void | DrawScrollBar (CDC *pDC, CXTPScrollBase *pScrollBar)
This method is called to draw all scrollbar parts.
virtual void | DrawBackground (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws verical scrollbar background only.
virtual void | DrawButtons (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws vertical scrollbar buttons only.
virtual void | DrawArrows (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws vertical scrollbar button arrows only.
virtual void | DrawThumbButton (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws vertical scrollbar thumb button only.
virtual void | DrawBackground (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar background only.
virtual void | DrawButtons (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar buttons only.
virtual void | DrawArrows (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar button arrows only.
virtual void | DrawThumbButton (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar thumb button only.
virtual void | DrawGripper (CDC *pDC, CXTPScrollBase *pScroll)
Draws scrollbar gripper only.
- Protected Member Functions inherited from CXTPScrollBarPaintManager
virtual void | DrawTracker (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws vertical scrollbar trackers only.
virtual void | DrawTracker (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar trackers only.
void | DrawArrowGlyph (CDC *pDC, CRect rcArrow, XTPArrowGlyph glyph, BOOL bEnabled, COLORREF clrText=COLORREF_NULL)
Draws scrollbar button arrow glyph.

Additional Inherited Members

- Public Member Functions inherited from CXTPScrollBarPaintManager
CXTPScrollBarPaintManager ()
Constructs a CXTPScrollBarPaintManager object.
virtual void | RefreshMetrics ()
Recalculates scrollbar metrics.
- Public Attributes inherited from CXTPScrollBarPaintManager
int | m_cxHScroll
Width, in pixels, of the arrow bitmap on a horizontal scroll bar.
int | m_cyHScroll
Height, in pixels, of a horizontal scroll bar.
int | m_cxVScroll
Width, in pixels, of a vertical scroll bar;.
int | m_cyVScroll
Height, in pixels, of the arrow bitmap on a vertical scroll bar.
int | m_cThumb
Width of thumb button.
COLORREF | m_crBackPushed
Color when pushed.
COLORREF | m_crBackHilite
Color when border.
COLORREF | m_crBorderHilite
Color of border when highlighted.
COLORREF | m_crBorder
Color of border.
COLORREF | m_crBack
Color of background.
- Protected Types inherited from CXTPScrollBarPaintManager
- Static Protected Member Functions inherited from CXTPScrollBarPaintManager
static void AFX_CDECL | CalcVScroll (CXTPScrollBase *pScroll, XTPScrollMetricsV *pVScroll)
Computes vertical scrollbar mertics.
static void AFX_CDECL | CalcHScroll (CXTPScrollBase *pScroll, XTPScrollMetricsH *pHScroll)
Computes horizontal scrollbar mertics.

Detailed Description

Scrollbar paint manager used to draw Visual Studio 2012 like scrollbars.

See also
CXTPPaintManager::SetTheme

Member Function Documentation

◆ DrawArrows() [1/2]

virtual void DrawArrows | ( | CDC * | pDC,
 |  | CXTPScrollBase * | pScroll,
 |  | XTPScrollMetricsH * | pMetrics )
 protectedvirtual

Draws horizontal scrollbar button arrows only.

Parameters
pDC | Target device context pointer
pScroll | Scroll bar object pointer
pMetrics | Precomputed scrollbar metrics

Reimplemented from CXTPScrollBarPaintManager.

◆ DrawArrows() [2/2]

virtual void DrawArrows | ( | CDC * | pDC,
 |  | CXTPScrollBase * | pScroll,
 |  | XTPScrollMetricsV * | pMetrics )
 protectedvirtual

Draws vertical scrollbar button arrows only.

Parameters
pDC | Target device context pointer
pScroll | Scroll bar object pointer
pMetrics | Precomputed scrollbar metrics

Reimplemented from CXTPScrollBarPaintManager.

◆ DrawBackground() [1/2]

virtual void DrawBackground | ( | CDC * | pDC,
 |  | CXTPScrollBase * | pScroll,
 |  | XTPScrollMetricsH * | pMetrics )
 protectedvirtual

Draws horizontal scrollbar background only.

Parameters
pDC | Target device context pointer
pScroll | Scroll bar object pointer
pMetrics | Precomputed scrollbar metrics

Reimplemented from CXTPScrollBarPaintManager.

◆ DrawBackground() [2/2]

virtual void DrawBackground | ( | CDC * | pDC,
 |  | CXTPScrollBase * | pScroll,
 |  | XTPScrollMetricsV * | pMetrics )
 protectedvirtual

Draws verical scrollbar background only.

Parameters
pDC | Target device context pointer
pScroll | Scroll bar object pointer
pMetrics | Precomputed scrollbar metrics

Reimplemented from CXTPScrollBarPaintManager.

◆ DrawButtons() [1/2]

virtual void DrawButtons | ( | CDC * | pDC,
 |  | CXTPScrollBase * | pScroll,
 |  | XTPScrollMetricsH * | pMetrics )
 protectedvirtual

Draws horizontal scrollbar buttons only.

Parameters
pDC | Target device context pointer
pScroll | Scroll bar object pointer
pMetrics | Precomputed scrollbar metrics

Reimplemented from CXTPScrollBarPaintManager.

◆ DrawButtons() [2/2]

virtual void DrawButtons | ( | CDC * | pDC,
 |  | CXTPScrollBase * | pScroll,
 |  | XTPScrollMetricsV * | pMetrics )
 protectedvirtual

Draws vertical scrollbar buttons only.

Parameters
pDC | Target device context pointer
pScroll | Scroll bar object pointer
pMetrics | Precomputed scrollbar metrics

Reimplemented from CXTPScrollBarPaintManager.

◆ DrawGripper()

virtual void DrawGripper | ( | CDC * | pDC,
 |  | CXTPScrollBase * | pScroll )
 protectedvirtual

Draws scrollbar gripper only.

Parameters
pDC | Target device context pointer
pScroll | Scroll bar object pointer

Reimplemented from CXTPScrollBarPaintManager.

◆ DrawScrollBar()

virtual void DrawScrollBar | ( | CDC * | pDC,
 |  | CXTPScrollBase * | pScrollBar )
 protectedvirtual

This method is called to draw all scrollbar parts.

Parameters
pDC | Pointer to device context
pScrollBar | ScrollBar to draw

Reimplemented from CXTPScrollBarPaintManager.

Reimplemented in CXTPScrollBarThemeVisualStudio2015, CXTPScrollBarThemeVisualStudio2017, CXTPScrollBarThemeVisualStudio2019, and CXTPScrollBarThemeVisualStudio2022.

◆ DrawThumbButton() [1/2]

virtual void DrawThumbButton | ( | CDC * | pDC,
 |  | CXTPScrollBase * | pScroll,
 |  | XTPScrollMetricsH * | pMetrics )
 protectedvirtual

Draws horizontal scrollbar thumb button only.

Parameters
pDC | Target device context pointer
pScroll | Scroll bar object pointer
pMetrics | Precomputed scrollbar metrics

Reimplemented from CXTPScrollBarPaintManager.

◆ DrawThumbButton() [2/2]

virtual void DrawThumbButton | ( | CDC * | pDC,
 |  | CXTPScrollBase * | pScroll,
 |  | XTPScrollMetricsV * | pMetrics )
 protectedvirtual

Draws vertical scrollbar thumb button only.

Parameters
pDC | Target device context pointer
pScroll | Scroll bar object pointer
pMetrics | Precomputed scrollbar metrics

Reimplemented from CXTPScrollBarPaintManager.

The documentation for this class was generated from the following file:
  • XTPScrollBarThemeVisualStudio2012.h


Toolkit Pro: CXTPScrollBarThemeVisualStudio2015 Class Reference

Protected Member Functions | List of all members
CXTPScrollBarThemeVisualStudio2015 Class Reference

Scrollbar paint manager used to draw Visual Studio 2015 like scrollbars. More...

Inheritance diagram for CXTPScrollBarThemeVisualStudio2015:
[legend]

Protected Member Functions

virtual void | DrawScrollBar (CDC *pDC, CXTPScrollBase *pScrollBar)
This method is called to draw all scrollbar parts.
- Protected Member Functions inherited from CXTPScrollBarThemeVisualStudio2012
virtual void | DrawBackground (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws verical scrollbar background only.
virtual void | DrawButtons (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws vertical scrollbar buttons only.
virtual void | DrawArrows (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws vertical scrollbar button arrows only.
virtual void | DrawThumbButton (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws vertical scrollbar thumb button only.
virtual void | DrawBackground (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar background only.
virtual void | DrawButtons (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar buttons only.
virtual void | DrawArrows (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar button arrows only.
virtual void | DrawThumbButton (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar thumb button only.
virtual void | DrawGripper (CDC *pDC, CXTPScrollBase *pScroll)
Draws scrollbar gripper only.
- Protected Member Functions inherited from CXTPScrollBarPaintManager
virtual void | DrawTracker (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws vertical scrollbar trackers only.
virtual void | DrawTracker (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar trackers only.
void | DrawArrowGlyph (CDC *pDC, CRect rcArrow, XTPArrowGlyph glyph, BOOL bEnabled, COLORREF clrText=COLORREF_NULL)
Draws scrollbar button arrow glyph.

Additional Inherited Members

- Public Member Functions inherited from CXTPScrollBarPaintManager
CXTPScrollBarPaintManager ()
Constructs a CXTPScrollBarPaintManager object.
virtual void | RefreshMetrics ()
Recalculates scrollbar metrics.
- Public Attributes inherited from CXTPScrollBarPaintManager
int | m_cxHScroll
Width, in pixels, of the arrow bitmap on a horizontal scroll bar.
int | m_cyHScroll
Height, in pixels, of a horizontal scroll bar.
int | m_cxVScroll
Width, in pixels, of a vertical scroll bar;.
int | m_cyVScroll
Height, in pixels, of the arrow bitmap on a vertical scroll bar.
int | m_cThumb
Width of thumb button.
COLORREF | m_crBackPushed
Color when pushed.
COLORREF | m_crBackHilite
Color when border.
COLORREF | m_crBorderHilite
Color of border when highlighted.
COLORREF | m_crBorder
Color of border.
COLORREF | m_crBack
Color of background.
- Protected Types inherited from CXTPScrollBarPaintManager
- Static Protected Member Functions inherited from CXTPScrollBarPaintManager
static void AFX_CDECL | CalcVScroll (CXTPScrollBase *pScroll, XTPScrollMetricsV *pVScroll)
Computes vertical scrollbar mertics.
static void AFX_CDECL | CalcHScroll (CXTPScrollBase *pScroll, XTPScrollMetricsH *pHScroll)
Computes horizontal scrollbar mertics.
- Protected Attributes inherited from CXTPScrollBarThemeVisualStudio2012

Detailed Description

Scrollbar paint manager used to draw Visual Studio 2015 like scrollbars.

See also
CXTPPaintManager::SetTheme

Member Function Documentation

◆ DrawScrollBar()

virtual void DrawScrollBar | ( | CDC * | pDC,
 |  | CXTPScrollBase * | pScrollBar )
 protectedvirtual

This method is called to draw all scrollbar parts.

Parameters
pDC | Pointer to device context
pScrollBar | ScrollBar to draw

Reimplemented from CXTPScrollBarThemeVisualStudio2012.

The documentation for this class was generated from the following file:
  • XTPScrollBarThemeVisualStudio2015.h


Toolkit Pro: CXTPScrollBarThemeVisualStudio2017 Class Reference

Protected Member Functions | List of all members
CXTPScrollBarThemeVisualStudio2017 Class Reference

Scrollbar paint manager used to draw Visual Studio 2017 like scrollbars. More...

Inheritance diagram for CXTPScrollBarThemeVisualStudio2017:
[legend]

Protected Member Functions

virtual void | DrawScrollBar (CDC *pDC, CXTPScrollBase *pScrollBar)
This method is called to draw all scrollbar parts.
- Protected Member Functions inherited from CXTPScrollBarThemeVisualStudio2012
virtual void | DrawBackground (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws verical scrollbar background only.
virtual void | DrawButtons (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws vertical scrollbar buttons only.
virtual void | DrawArrows (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws vertical scrollbar button arrows only.
virtual void | DrawThumbButton (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws vertical scrollbar thumb button only.
virtual void | DrawBackground (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar background only.
virtual void | DrawButtons (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar buttons only.
virtual void | DrawArrows (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar button arrows only.
virtual void | DrawThumbButton (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar thumb button only.
virtual void | DrawGripper (CDC *pDC, CXTPScrollBase *pScroll)
Draws scrollbar gripper only.
- Protected Member Functions inherited from CXTPScrollBarPaintManager
virtual void | DrawTracker (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws vertical scrollbar trackers only.
virtual void | DrawTracker (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar trackers only.
void | DrawArrowGlyph (CDC *pDC, CRect rcArrow, XTPArrowGlyph glyph, BOOL bEnabled, COLORREF clrText=COLORREF_NULL)
Draws scrollbar button arrow glyph.

Additional Inherited Members

- Public Member Functions inherited from CXTPScrollBarPaintManager
CXTPScrollBarPaintManager ()
Constructs a CXTPScrollBarPaintManager object.
virtual void | RefreshMetrics ()
Recalculates scrollbar metrics.
- Public Attributes inherited from CXTPScrollBarPaintManager
int | m_cxHScroll
Width, in pixels, of the arrow bitmap on a horizontal scroll bar.
int | m_cyHScroll
Height, in pixels, of a horizontal scroll bar.
int | m_cxVScroll
Width, in pixels, of a vertical scroll bar;.
int | m_cyVScroll
Height, in pixels, of the arrow bitmap on a vertical scroll bar.
int | m_cThumb
Width of thumb button.
COLORREF | m_crBackPushed
Color when pushed.
COLORREF | m_crBackHilite
Color when border.
COLORREF | m_crBorderHilite
Color of border when highlighted.
COLORREF | m_crBorder
Color of border.
COLORREF | m_crBack
Color of background.
- Protected Types inherited from CXTPScrollBarPaintManager
- Static Protected Member Functions inherited from CXTPScrollBarPaintManager
static void AFX_CDECL | CalcVScroll (CXTPScrollBase *pScroll, XTPScrollMetricsV *pVScroll)
Computes vertical scrollbar mertics.
static void AFX_CDECL | CalcHScroll (CXTPScrollBase *pScroll, XTPScrollMetricsH *pHScroll)
Computes horizontal scrollbar mertics.
- Protected Attributes inherited from CXTPScrollBarThemeVisualStudio2012

Detailed Description

Scrollbar paint manager used to draw Visual Studio 2017 like scrollbars.

See also
CXTPPaintManager::SetTheme

Member Function Documentation

◆ DrawScrollBar()

virtual void DrawScrollBar | ( | CDC * | pDC,
 |  | CXTPScrollBase * | pScrollBar )
 protectedvirtual

This method is called to draw all scrollbar parts.

Parameters
pDC | Pointer to device context
pScrollBar | ScrollBar to draw

Reimplemented from CXTPScrollBarThemeVisualStudio2012.

The documentation for this class was generated from the following file:
  • XTPScrollBarThemeVisualStudio2017.h


Toolkit Pro: CXTPScrollBarThemeVisualStudio2019 Class Reference

Protected Member Functions | List of all members
CXTPScrollBarThemeVisualStudio2019 Class Reference

Scrollbar paint manager used to draw Visual Studio 2019 like scrollbars. More...

Inheritance diagram for CXTPScrollBarThemeVisualStudio2019:
[legend]

Protected Member Functions

virtual void | DrawScrollBar (CDC *pDC, CXTPScrollBase *pScrollBar)
This method is called to draw all scrollbar parts.
- Protected Member Functions inherited from CXTPScrollBarThemeVisualStudio2012
virtual void | DrawBackground (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws verical scrollbar background only.
virtual void | DrawButtons (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws vertical scrollbar buttons only.
virtual void | DrawArrows (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws vertical scrollbar button arrows only.
virtual void | DrawThumbButton (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws vertical scrollbar thumb button only.
virtual void | DrawBackground (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar background only.
virtual void | DrawButtons (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar buttons only.
virtual void | DrawArrows (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar button arrows only.
virtual void | DrawThumbButton (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar thumb button only.
virtual void | DrawGripper (CDC *pDC, CXTPScrollBase *pScroll)
Draws scrollbar gripper only.
- Protected Member Functions inherited from CXTPScrollBarPaintManager
virtual void | DrawTracker (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws vertical scrollbar trackers only.
virtual void | DrawTracker (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar trackers only.
void | DrawArrowGlyph (CDC *pDC, CRect rcArrow, XTPArrowGlyph glyph, BOOL bEnabled, COLORREF clrText=COLORREF_NULL)
Draws scrollbar button arrow glyph.

Additional Inherited Members

- Public Member Functions inherited from CXTPScrollBarPaintManager
CXTPScrollBarPaintManager ()
Constructs a CXTPScrollBarPaintManager object.
virtual void | RefreshMetrics ()
Recalculates scrollbar metrics.
- Public Attributes inherited from CXTPScrollBarPaintManager
int | m_cxHScroll
Width, in pixels, of the arrow bitmap on a horizontal scroll bar.
int | m_cyHScroll
Height, in pixels, of a horizontal scroll bar.
int | m_cxVScroll
Width, in pixels, of a vertical scroll bar;.
int | m_cyVScroll
Height, in pixels, of the arrow bitmap on a vertical scroll bar.
int | m_cThumb
Width of thumb button.
COLORREF | m_crBackPushed
Color when pushed.
COLORREF | m_crBackHilite
Color when border.
COLORREF | m_crBorderHilite
Color of border when highlighted.
COLORREF | m_crBorder
Color of border.
COLORREF | m_crBack
Color of background.
- Protected Types inherited from CXTPScrollBarPaintManager
- Static Protected Member Functions inherited from CXTPScrollBarPaintManager
static void AFX_CDECL | CalcVScroll (CXTPScrollBase *pScroll, XTPScrollMetricsV *pVScroll)
Computes vertical scrollbar mertics.
static void AFX_CDECL | CalcHScroll (CXTPScrollBase *pScroll, XTPScrollMetricsH *pHScroll)
Computes horizontal scrollbar mertics.
- Protected Attributes inherited from CXTPScrollBarThemeVisualStudio2012

Detailed Description

Scrollbar paint manager used to draw Visual Studio 2019 like scrollbars.

See also
CXTPPaintManager::SetTheme

Member Function Documentation

◆ DrawScrollBar()

virtual void DrawScrollBar | ( | CDC * | pDC,
 |  | CXTPScrollBase * | pScrollBar )
 protectedvirtual

This method is called to draw all scrollbar parts.

Parameters
pDC | Pointer to device context
pScrollBar | ScrollBar to draw

Reimplemented from CXTPScrollBarThemeVisualStudio2012.

The documentation for this class was generated from the following file:
  • XTPScrollBarThemeVisualStudio2019.h


Toolkit Pro: CXTPScrollBarThemeVisualStudio2022 Class Reference

Protected Member Functions | List of all members
CXTPScrollBarThemeVisualStudio2022 Class Reference

Scrollbar paint manager used to draw Visual Studio 2022 like scrollbars. More...

Inheritance diagram for CXTPScrollBarThemeVisualStudio2022:
[legend]

Protected Member Functions

virtual void | DrawScrollBar (CDC *pDC, CXTPScrollBase *pScrollBar)
This method is called to draw all scrollbar parts.
- Protected Member Functions inherited from CXTPScrollBarThemeVisualStudio2012
virtual void | DrawBackground (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws verical scrollbar background only.
virtual void | DrawButtons (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws vertical scrollbar buttons only.
virtual void | DrawArrows (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws vertical scrollbar button arrows only.
virtual void | DrawThumbButton (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws vertical scrollbar thumb button only.
virtual void | DrawBackground (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar background only.
virtual void | DrawButtons (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar buttons only.
virtual void | DrawArrows (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar button arrows only.
virtual void | DrawThumbButton (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar thumb button only.
virtual void | DrawGripper (CDC *pDC, CXTPScrollBase *pScroll)
Draws scrollbar gripper only.
- Protected Member Functions inherited from CXTPScrollBarPaintManager
virtual void | DrawTracker (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws vertical scrollbar trackers only.
virtual void | DrawTracker (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar trackers only.
void | DrawArrowGlyph (CDC *pDC, CRect rcArrow, XTPArrowGlyph glyph, BOOL bEnabled, COLORREF clrText=COLORREF_NULL)
Draws scrollbar button arrow glyph.

Additional Inherited Members

- Public Member Functions inherited from CXTPScrollBarPaintManager
CXTPScrollBarPaintManager ()
Constructs a CXTPScrollBarPaintManager object.
virtual void | RefreshMetrics ()
Recalculates scrollbar metrics.
- Public Attributes inherited from CXTPScrollBarPaintManager
int | m_cxHScroll
Width, in pixels, of the arrow bitmap on a horizontal scroll bar.
int | m_cyHScroll
Height, in pixels, of a horizontal scroll bar.
int | m_cxVScroll
Width, in pixels, of a vertical scroll bar;.
int | m_cyVScroll
Height, in pixels, of the arrow bitmap on a vertical scroll bar.
int | m_cThumb
Width of thumb button.
COLORREF | m_crBackPushed
Color when pushed.
COLORREF | m_crBackHilite
Color when border.
COLORREF | m_crBorderHilite
Color of border when highlighted.
COLORREF | m_crBorder
Color of border.
COLORREF | m_crBack
Color of background.
- Protected Types inherited from CXTPScrollBarPaintManager
- Static Protected Member Functions inherited from CXTPScrollBarPaintManager
static void AFX_CDECL | CalcVScroll (CXTPScrollBase *pScroll, XTPScrollMetricsV *pVScroll)
Computes vertical scrollbar mertics.
static void AFX_CDECL | CalcHScroll (CXTPScrollBase *pScroll, XTPScrollMetricsH *pHScroll)
Computes horizontal scrollbar mertics.
- Protected Attributes inherited from CXTPScrollBarThemeVisualStudio2012

Detailed Description

Scrollbar paint manager used to draw Visual Studio 2022 like scrollbars.

See also
CXTPPaintManager::SetTheme

Member Function Documentation

◆ DrawScrollBar()

virtual void DrawScrollBar | ( | CDC * | pDC,
 |  | CXTPScrollBase * | pScrollBar )
 protectedvirtual

This method is called to draw all scrollbar parts.

Parameters
pDC | Pointer to device context
pScrollBar | ScrollBar to draw

Reimplemented from CXTPScrollBarThemeVisualStudio2012.

The documentation for this class was generated from the following file:
  • XTPScrollBarThemeVisualStudio2022.h


Toolkit Pro: CXTPScrollBarThemeWindowsClassic Class Reference

Protected Member Functions | List of all members
CXTPScrollBarThemeWindowsClassic Class Reference

Scrollbar paint manager used to draw classic Windows scrollbars. More...

Inheritance diagram for CXTPScrollBarThemeWindowsClassic:
[legend]

Protected Member Functions

virtual void | DrawButtons (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws vertical scrollbar buttons only.
virtual void | DrawTracker (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws vertical scrollbar trackers only.
virtual void | DrawButtons (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar buttons only.
virtual void | DrawTracker (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar trackers only.
virtual void | DrawGripper (CDC *pDC, CXTPScrollBase *pScroll)
Draws scrollbar gripper only.
- Protected Member Functions inherited from CXTPScrollBarPaintManager
virtual void | DrawBackground (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws verical scrollbar background only.
virtual void | DrawArrows (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws vertical scrollbar button arrows only.
virtual void | DrawThumbButton (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws vertical scrollbar thumb button only.
virtual void | DrawBackground (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar background only.
virtual void | DrawArrows (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar button arrows only.
virtual void | DrawThumbButton (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar thumb button only.
void | DrawArrowGlyph (CDC *pDC, CRect rcArrow, XTPArrowGlyph glyph, BOOL bEnabled, COLORREF clrText=COLORREF_NULL)
Draws scrollbar button arrow glyph.

Additional Inherited Members

- Public Member Functions inherited from CXTPScrollBarPaintManager
CXTPScrollBarPaintManager ()
Constructs a CXTPScrollBarPaintManager object.
virtual void | DrawScrollBar (CDC *pDC, CXTPScrollBase *pScrollBar)
This method is called to draw all scrollbar parts.
virtual void | RefreshMetrics ()
Recalculates scrollbar metrics.
- Public Attributes inherited from CXTPScrollBarPaintManager
int | m_cxHScroll
Width, in pixels, of the arrow bitmap on a horizontal scroll bar.
int | m_cyHScroll
Height, in pixels, of a horizontal scroll bar.
int | m_cxVScroll
Width, in pixels, of a vertical scroll bar;.
int | m_cyVScroll
Height, in pixels, of the arrow bitmap on a vertical scroll bar.
int | m_cThumb
Width of thumb button.
COLORREF | m_crBackPushed
Color when pushed.
COLORREF | m_crBackHilite
Color when border.
COLORREF | m_crBorderHilite
Color of border when highlighted.
COLORREF | m_crBorder
Color of border.
COLORREF | m_crBack
Color of background.
- Protected Types inherited from CXTPScrollBarPaintManager
- Static Protected Member Functions inherited from CXTPScrollBarPaintManager
static void AFX_CDECL | CalcVScroll (CXTPScrollBase *pScroll, XTPScrollMetricsV *pVScroll)
Computes vertical scrollbar mertics.
static void AFX_CDECL | CalcHScroll (CXTPScrollBase *pScroll, XTPScrollMetricsH *pHScroll)
Computes horizontal scrollbar mertics.

Detailed Description

Scrollbar paint manager used to draw classic Windows scrollbars.

See also
CXTPPaintManager::SetTheme

Member Function Documentation

◆ DrawButtons() [1/2]

virtual void DrawButtons | ( | CDC * | pDC,
 |  | CXTPScrollBase * | pScroll,
 |  | XTPScrollMetricsH * | pMetrics )
 protectedvirtual

Draws horizontal scrollbar buttons only.

Parameters
pDC | Target device context pointer
pScroll | Scroll bar object pointer
pMetrics | Precomputed scrollbar metrics

Reimplemented from CXTPScrollBarPaintManager.

Reimplemented in CXTPScrollBarThemeFlat, CXTPScrollBarThemeOffice2000, and CXTPScrollBarThemeWindowsUx.

◆ DrawButtons() [2/2]

virtual void DrawButtons | ( | CDC * | pDC,
 |  | CXTPScrollBase * | pScroll,
 |  | XTPScrollMetricsV * | pMetrics )
 protectedvirtual

Draws vertical scrollbar buttons only.

Parameters
pDC | Target device context pointer
pScroll | Scroll bar object pointer
pMetrics | Precomputed scrollbar metrics

Reimplemented from CXTPScrollBarPaintManager.

Reimplemented in CXTPScrollBarThemeFlat, CXTPScrollBarThemeOffice2000, and CXTPScrollBarThemeWindowsUx.

◆ DrawGripper()

virtual void DrawGripper | ( | CDC * | pDC,
 |  | CXTPScrollBase * | pScroll )
 protectedvirtual

Draws scrollbar gripper only.

Parameters
pDC | Target device context pointer
pScroll | Scroll bar object pointer

Reimplemented from CXTPScrollBarPaintManager.

Reimplemented in CXTPScrollBarThemeFlat, and CXTPScrollBarThemeWindowsUx.

◆ DrawTracker() [1/2]

virtual void DrawTracker | ( | CDC * | pDC,
 |  | CXTPScrollBase * | pScroll,
 |  | XTPScrollMetricsH * | pMetrics )
 protectedvirtual

Draws horizontal scrollbar trackers only.

Parameters
pDC | Target device context pointer
pScroll | Scroll bar object pointer
pMetrics | Precomputed scrollbar metrics

Reimplemented from CXTPScrollBarPaintManager.

Reimplemented in CXTPScrollBarThemeFlat, and CXTPScrollBarThemeWindowsUx.

◆ DrawTracker() [2/2]

virtual void DrawTracker | ( | CDC * | pDC,
 |  | CXTPScrollBase * | pScroll,
 |  | XTPScrollMetricsV * | pMetrics )
 protectedvirtual

Draws vertical scrollbar trackers only.

Parameters
pDC | Target device context pointer
pScroll | Scroll bar object pointer
pMetrics | Precomputed scrollbar metrics

Reimplemented from CXTPScrollBarPaintManager.

Reimplemented in CXTPScrollBarThemeFlat, and CXTPScrollBarThemeWindowsUx.

The documentation for this class was generated from the following file:
  • XTPScrollBarThemeWindowsClassic.h


Toolkit Pro: CXTPScrollBarThemeWindowsUx Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPScrollBarThemeWindowsUx Class Reference

Scrollbar paint manager used to draw scrollbars that use current Windows theme. More...

Inheritance diagram for CXTPScrollBarThemeWindowsUx:
[legend]

Public Member Functions

CXTPScrollBarThemeWindowsUx ()
Constructs a CXTPScrollBarThemeWindowsUx object.
virtual | ~CXTPScrollBarThemeWindowsUx ()
Destroys a CXTPScrollBarThemeWindowsUx object, handles cleanup and deallocation.
- Public Member Functions inherited from CXTPScrollBarPaintManager
CXTPScrollBarPaintManager ()
Constructs a CXTPScrollBarPaintManager object.
virtual void | DrawScrollBar (CDC *pDC, CXTPScrollBase *pScrollBar)
This method is called to draw all scrollbar parts.

Protected Member Functions

virtual void | RefreshMetrics ()
Recalculates scrollbar metrics.
virtual void | DrawButtons (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws vertical scrollbar buttons only.
virtual void | DrawTracker (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws vertical scrollbar trackers only.
virtual void | DrawThumbButton (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws vertical scrollbar thumb button only.
virtual void | DrawButtons (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar buttons only.
virtual void | DrawTracker (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar trackers only.
virtual void | DrawThumbButton (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar thumb button only.
virtual void | DrawGripper (CDC *pDC, CXTPScrollBase *pScroll)
Draws scrollbar gripper only.
- Protected Member Functions inherited from CXTPScrollBarThemeWindowsClassic
- Protected Member Functions inherited from CXTPScrollBarPaintManager
virtual void | DrawBackground (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws verical scrollbar background only.
virtual void | DrawArrows (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws vertical scrollbar button arrows only.
virtual void | DrawBackground (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar background only.
virtual void | DrawArrows (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar button arrows only.
void | DrawArrowGlyph (CDC *pDC, CRect rcArrow, XTPArrowGlyph glyph, BOOL bEnabled, COLORREF clrText=COLORREF_NULL)
Draws scrollbar button arrow glyph.

Additional Inherited Members

- Public Attributes inherited from CXTPScrollBarPaintManager
int | m_cxHScroll
Width, in pixels, of the arrow bitmap on a horizontal scroll bar.
int | m_cyHScroll
Height, in pixels, of a horizontal scroll bar.
int | m_cxVScroll
Width, in pixels, of a vertical scroll bar;.
int | m_cyVScroll
Height, in pixels, of the arrow bitmap on a vertical scroll bar.
int | m_cThumb
Width of thumb button.
COLORREF | m_crBackPushed
Color when pushed.
COLORREF | m_crBackHilite
Color when border.
COLORREF | m_crBorderHilite
Color of border when highlighted.
COLORREF | m_crBorder
Color of border.
COLORREF | m_crBack
Color of background.
- Protected Types inherited from CXTPScrollBarPaintManager
- Static Protected Member Functions inherited from CXTPScrollBarPaintManager
static void AFX_CDECL | CalcVScroll (CXTPScrollBase *pScroll, XTPScrollMetricsV *pVScroll)
Computes vertical scrollbar mertics.
static void AFX_CDECL | CalcHScroll (CXTPScrollBase *pScroll, XTPScrollMetricsH *pHScroll)
Computes horizontal scrollbar mertics.

Detailed Description

Scrollbar paint manager used to draw scrollbars that use current Windows theme.

See also
CXTPPaintManager::SetTheme

Member Function Documentation

◆ DrawButtons() [1/2]

virtual void DrawButtons | ( | CDC * | pDC,
 |  | CXTPScrollBase * | pScroll,
 |  | XTPScrollMetricsH * | pMetrics )
 protectedvirtual

Draws horizontal scrollbar buttons only.

Parameters
pDC | Target device context pointer
pScroll | Scroll bar object pointer
pMetrics | Precomputed scrollbar metrics

Reimplemented from CXTPScrollBarThemeWindowsClassic.

Reimplemented in CXTPScrollBarThemeFlat, and CXTPScrollBarThemeOffice2000.

◆ DrawButtons() [2/2]

virtual void DrawButtons | ( | CDC * | pDC,
 |  | CXTPScrollBase * | pScroll,
 |  | XTPScrollMetricsV * | pMetrics )
 protectedvirtual

Draws vertical scrollbar buttons only.

Parameters
pDC | Target device context pointer
pScroll | Scroll bar object pointer
pMetrics | Precomputed scrollbar metrics

Reimplemented from CXTPScrollBarThemeWindowsClassic.

Reimplemented in CXTPScrollBarThemeFlat, and CXTPScrollBarThemeOffice2000.

◆ DrawGripper()

virtual void DrawGripper | ( | CDC * | pDC,
 |  | CXTPScrollBase * | pScroll )
 protectedvirtual

Draws scrollbar gripper only.

Parameters
pDC | Target device context pointer
pScroll | Scroll bar object pointer

Reimplemented from CXTPScrollBarThemeWindowsClassic.

Reimplemented in CXTPScrollBarThemeFlat.

◆ DrawThumbButton() [1/2]

virtual void DrawThumbButton | ( | CDC * | pDC,
 |  | CXTPScrollBase * | pScroll,
 |  | XTPScrollMetricsH * | pMetrics )
 protectedvirtual

Draws horizontal scrollbar thumb button only.

Parameters
pDC | Target device context pointer
pScroll | Scroll bar object pointer
pMetrics | Precomputed scrollbar metrics

Reimplemented from CXTPScrollBarPaintManager.

Reimplemented in CXTPScrollBarThemeFlat.

◆ DrawThumbButton() [2/2]

virtual void DrawThumbButton | ( | CDC * | pDC,
 |  | CXTPScrollBase * | pScroll,
 |  | XTPScrollMetricsV * | pMetrics )
 protectedvirtual

Draws vertical scrollbar thumb button only.

Parameters
pDC | Target device context pointer
pScroll | Scroll bar object pointer
pMetrics | Precomputed scrollbar metrics

Reimplemented from CXTPScrollBarPaintManager.

Reimplemented in CXTPScrollBarThemeFlat.

◆ DrawTracker() [1/2]

virtual void DrawTracker | ( | CDC * | pDC,
 |  | CXTPScrollBase * | pScroll,
 |  | XTPScrollMetricsH * | pMetrics )
 protectedvirtual

Draws horizontal scrollbar trackers only.

Parameters
pDC | Target device context pointer
pScroll | Scroll bar object pointer
pMetrics | Precomputed scrollbar metrics

Reimplemented from CXTPScrollBarThemeWindowsClassic.

Reimplemented in CXTPScrollBarThemeFlat.

◆ DrawTracker() [2/2]

virtual void DrawTracker | ( | CDC * | pDC,
 |  | CXTPScrollBase * | pScroll,
 |  | XTPScrollMetricsV * | pMetrics )
 protectedvirtual

Draws vertical scrollbar trackers only.

Parameters
pDC | Target device context pointer
pScroll | Scroll bar object pointer
pMetrics | Precomputed scrollbar metrics

Reimplemented from CXTPScrollBarThemeWindowsClassic.

Reimplemented in CXTPScrollBarThemeFlat.

The documentation for this class was generated from the following file:
  • XTPScrollBarThemeWindowsUx.h


Toolkit Pro: CXTPScrollBase Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPScrollBase Class Referenceabstract

CXTPScrollBase is the base class for all scrollable objects. More...

Inheritance diagram for CXTPScrollBase:
[legend]

Public Member Functions

CXTPScrollBase ()
Constructs a CXTPScrollBase object.
virtual | ~CXTPScrollBase ()
Destroys a CXTPScrollBase object, handles cleanup and deallocation.
void | SetScrollBarStyle (XTPScrollBarStyle scrollStyle)
Call this method to set the style of the scrollbar.
XTPScrollBarStyle | GetScrollBarStyle () const
Call this method to get the style of the scrollbar.
XTP_SCROLLBAR_TRACKINFO * | GetScrollBarTrackInfo () const
Call this method to get XTP_SCROLLBAR_TRACKINFO information.
XTP_SCROLLBAR_POSINFO * GetScrollBarPosInfo ()
Call this method to get XTP_SCROLLBAR_POSINFO information.
virtual CWnd * | GetParentWindow () const =0
Retrieves parent window of scrollbar.
int | HitTestScrollBar (POINT pt) const
Call this method to check ScrollBar part under pointer.
CRect | GetScrollBarPartRect (int nPart) const
Gets the bounding rectangle of a specified part of the scrollbar.
void | PerformTrackInit (HWND hWnd, CPoint point, XTP_SCROLLBAR_POSINFO *pSBInfo, BOOL bDirect)
Call this method to start scrollbar tracking.
XTP_SLIDERTICKS * | GetTicks () const
Gets the ticks in the slider.
void | SetTicks (double *pTicks, int nCount)
Call this method to set ticks for the slider.
HBRUSH | GetCltColor (CDC *pDC) const
Call this method to get the scroll bar control color.
BOOL | IsSlider () const
Call this member function to determine if the scrollbar is a slider control.
virtual BOOL | IsScrollBarEnabled () const =0
Determines if the scrollbar is enabled.
virtual CXTPScrollBarPaintManager * | GetScrollBarPaintManager () const =0
Obtains a pointer to the associated scrollbar paint manager.
virtual CRect | GetScrollBarRect ()=0
Obtains the rectangle occupied by the scrollbar in client coordinates.
virtual void | GetScrollInfo (SCROLLINFO *psi)=0
The GetScrollInfo function retrieves the parameters of a scroll bar, including the minimum and maximum scrolling positions, the page size, and the position of the scroll box(thumb)
virtual void | RedrawScrollBar ()=0
Forces the scrollbar to redraw itself.

Protected Attributes

XTP_SCROLLBAR_POSINFO | m_spi
ScrollBar position.
XTP_SCROLLBAR_TRACKINFO * | m_pSBTrack
ScrollBar tracking.
XTP_SLIDERTICKS * | m_pTicks
Slider Ticks.
XTPScrollBarStyle | m_scrollBarStyle
ScrollBar style.
BOOL | m_bAnimation
TRUE if animation enabled.
int | m_nTimerElapse
Scroll delay.

Detailed Description

CXTPScrollBase is the base class for all scrollable objects.

Member Function Documentation

◆ GetCltColor()

HBRUSH GetCltColor ( CDC * pDC ) const

Call this method to get the scroll bar control color.

Parameters
pDC Pointer to device context.
Returns
An RGB value representing the scroll bar control color.

◆ GetParentWindow()

virtual CWnd * GetParentWindow ( ) const
pure virtual

Retrieves parent window of scrollbar.

Returns
Pointer to parent window

◆ GetScrollBarPaintManager()

virtual CXTPScrollBarPaintManager * GetScrollBarPaintManager ( ) const
pure virtual

Obtains a pointer to the associated scrollbar paint manager.

Returns
A pointer to the associated scrollbar paint manager.

Implemented in CXTPCommandBarScrollBarCtrl, CXTPControlGallery, CXTPScrollBarCtrl, and CXTPStatusBarSliderPane.

◆ GetScrollBarPartRect()

CRect GetScrollBarPartRect ( int nPart ) const

Gets the bounding rectangle of a specified part of the scrollbar.

Parameters
nPart Part of the scrollbar to get bounding rectangle of.
Returns
The bounding rectangle of the specified part of the scroll bar.

◆ GetScrollBarPosInfo()

XTP_SCROLLBAR_POSINFO * GetScrollBarPosInfo ( )

Call this method to get XTP_SCROLLBAR_POSINFO information.

Returns
A pointer to XTP_SCROLLBAR_POSINFO information
See also
GetScrollBarTrackInfo

◆ GetScrollBarRect()

virtual CRect GetScrollBarRect ( )
pure virtual

Obtains the rectangle occupied by the scrollbar in client coordinates.

Returns
The rectangle occupied by the scrollbar in client coordinates.

◆ GetScrollBarStyle()

XTPScrollBarStyle GetScrollBarStyle ( ) const

Call this method to get the style of the scrollbar.

Returns
Style of the scrollbar; one of the values defined by the XTPScrollBarStyle enumeration.
See also
SetScrollBarStyle

◆ GetScrollBarTrackInfo()

XTP_SCROLLBAR_TRACKINFO * GetScrollBarTrackInfo ( ) const

Call this method to get XTP_SCROLLBAR_TRACKINFO information.

Returns
A pointer to XTP_SCROLLBAR_TRACKINFO information
See also
GetScrollBarPosInfo

◆ GetScrollInfo()

virtual void GetScrollInfo ( SCROLLINFO * psi )
pure virtual

The GetScrollInfo function retrieves the parameters of a scroll bar, including the minimum and maximum scrolling positions, the page size, and the position of the scroll box(thumb)

Parameters
psi Pointer to a SCROLLINFO structure. Before calling GetScrollInfo, set the cbSize member to sizeof(SCROLLINFO), and set the fMask member to specify the scroll bar parameters to retrieve. Before returning, the function copies the specified parameters to the appropriate members of the structure. Refer to MSDN documentation for more details on SCROLLINFO fields.

Implemented in CXTPScrollBarCtrl.

◆ GetTicks()

XTP_SLIDERTICKS * GetTicks ( ) const

Gets the ticks in the slider.

Returns
An XTP_SLIDERTICKS object.

◆ HitTestScrollBar()

int HitTestScrollBar ( POINT pt ) const

Call this method to check ScrollBar part under pointer.

Parameters
pt Mouse pointer to test
Returns
Hit test code that is on of:
HTNOWHERE            - No hit
XTP_HTSCROLLUP       - Up arrow hit
XTP_HTSCROLLPOPUP    - Popup hit
XTP_HTSCROLLDOWN     - Down arrow hit
XTP_HTSCROLLUPPAGE   - Scroll up page hit
XTP_HTSCROLLDOWNPAGE - Scroll down page hit
XTP_HTSCROLLTHUMB    - Scroll thumb hit

◆ IsScrollBarEnabled()

virtual BOOL IsScrollBarEnabled ( ) const
pure virtual

Determines if the scrollbar is enabled.

Returns
TRUE if the scrollbar is enabled.

Implemented in CXTPControlGallery.

◆ IsSlider()

BOOL IsSlider ( ) const

Call this member function to determine if the scrollbar is a slider control.

Returns
TRUE if the scrollbar is a slider control

◆ PerformTrackInit()

void PerformTrackInit | ( | HWND | hWnd,
 |  | CPoint | point,
 |  | XTP_SCROLLBAR_POSINFO * | pSBInfo,
 |  | BOOL | bDirect )

Call this method to start scrollbar tracking.

Parameters
hWnd | Parent Window handle
point | Starting cursor position
pSBInfo | Scrollbar information
bDirect | TRUE to scroll to specified position

◆ SetScrollBarStyle()

void SetScrollBarStyle ( XTPScrollBarStyle scrollStyle )

Call this method to set the style of the scrollbar.

Parameters
scrollStyle Style to be set; must be one of the values defined by the XTPScrollBarStyle enumeration.
See also
GetScrollBarStyle

◆ SetTicks()

void SetTicks | ( | double * | pTicks,
 |  | int | nCount )

Call this method to set ticks for the slider.

Parameters
pTicks | Pointer to double array of ticks.
nCount | Count of elements in array.
The documentation for this class was generated from the following file:
  • XTPScrollBase.h


Toolkit Pro: CXTPScrollDateButtonPart Class Reference

Public Member Functions | List of all members
CXTPScrollDateButtonPart Class Reference

This class implements Scroll Date button part of the ScrollDateBar. More...

Inheritance diagram for CXTPScrollDateButtonPart:
[legend]

Public Member Functions

virtual void | Draw (CDC *pDC)
This member function is used to draw the part content utilizing the specified device context.
virtual void | AdjustLayout (CDC *pDC, const CRect &rcRect)
This member function is used to adjust the object's layout depending on the provided bounding rectangle.
virtual BOOL | OnLButtonDown (UINT nFlags, CPoint point)
This member function is used to process left mouse button down events.
virtual void | OnKeyDown (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process key-down keyboard events.
virtual void | OnKeyUp (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process key-up keyboard events.
- Public Member Functions inherited from CXTPCalendarCaptionBarThemePart
CXTPCalendarCaptionBarThemePart (CXTPCalendarCaptionBarTheme *pTheme, int nPartID)
Default object constructor.
virtual | ~CXTPCalendarCaptionBarThemePart ()
Default object destructor.
virtual void | RefreshMetrics ()
Performs refreshing of graphical related parameters from system settings.
virtual void | Redraw (BOOL bUpdateNow=FALSE)
This member function initiates the CalendarCaptionBar control's redrawing.
virtual BOOL | HitTest (const CPoint &pt) const
This member function is used to determine is the specified point over visible object rectangle.
virtual CXTPCalendarCaptionBarTheme * | GetTheme () const
This member function is used to obtain pointer to parent CXTPCalendarCaptionBarTheme object.
virtual XTPCalendarTheme | GetPaintTheme () const
This member function is used to obtain current paint theme.
virtual int | GetPartID () const
This member function is used to obtain an object identifier.
virtual CRect | GetRect () const
This member function is used to obtain an object rectangle.
virtual CString | GetText () const
This member function is used to obtain an object text.
virtual void | SetText (LPCTSTR pcszText)
This member function is used to set object text.
virtual BOOL | IsVisible () const
This member function is used to get is part object visible.
virtual void | SetVisible (BOOL bVisible)
This member function is used to set visible object's state.
virtual int | GetCheck () const
This member function is used to get checked state.
virtual void | SetCheck (int nCheck)
This member function is used to set checked state.
int | GetState () const
This member function is used to get object state (flags from CXTPCalendarCaptionBarThemePart::EStates enum).
virtual void | SetState (int nState)
This member function is used to set object state as set of flags from CXTPCalendarCaptionBarThemePart::EStates enum.
virtual COLORREF | GetTextColor ()
This member function is used to get object text color.
CXTPCalendarCaptionBarPaintManager * | GetPaintManager () const
Gets the paint manager.
virtual void | OnMouseMove (UINT nFlags, CPoint point)
This member function is used to processes mouse movement events.
virtual BOOL | OnLButtonUp (UINT nFlags, CPoint point)
This member function is used to process left mouse button up events.
- Public Member Functions inherited from CXTPCalendarWMHandler
CXTPCalendarWMHandler ()
Default object constructor.
virtual int | GetChildHandlersCount () const
This member function is used to obtain the number of CXTPCalendarWMHandler elements in the descendant handlers collection.
virtual CXTPCalendarWMHandler * | GetChildHandlerAt (int nIndex) const
Call this method to get a handler object at the specified numeric index.
virtual BOOL | OnLButtonDblClk (UINT nFlags, CPoint point)
This member function is used to process left mouse button double click events.
virtual void | OnChar (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process keyboard events.
virtual BOOL | OnSysKeyDown (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process key-up keyboard events.
virtual BOOL | OnTimer (UINT_PTR uTimerID)
The framework calls this member function after each interval specified in the SetTimer member function.
virtual BOOL | OnWndMsg (UINT message, WPARAM wParam, LPARAM lParam, LRESULT *pResult)
This method is called by framework after default message processing.
virtual void | OnPostAdjustLayout ()
This member function is used to perform additional adjustments in some kinds of views.
virtual void | OnBeforeDestroy ()
This member function is called by the framework before destroying the view.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPCalendarCaptionBarThemePart
CXTPPaintManagerColor | m_clrTextColor
Store the object's text color.
CRect | m_rcRect
Store a Part rectangle.
int | m_nState
Store a Part state.
CString | m_strText
Store a Part text.
- Protected Attributes inherited from CXTPCalendarCaptionBarThemePart
CXTPCalendarCaptionBarTheme * | m_pTheme
Store pointer to a parent theme object.
int | m_nPartID
Store a Part ID.
BOOL | m_bVisible
Store a Part visible state.

Detailed Description

This class implements Scroll Date button part of the ScrollDateBar.

See also
CXTPCalendarCaptionBarThemePart

Member Function Documentation

◆ AdjustLayout()

virtual void AdjustLayout | ( | CDC * | pDC,
 |  | const CRect & | rcRect )
 virtual

This member function is used to adjust the object's layout depending on the provided bounding rectangle.

Parameters
pDC | Pointer to a valid device context (may be NULL).
rcRect | A CRect object containing the dimensions of the bounding rectangle for this part.

Reimplemented from CXTPCalendarCaptionBarThemePart.

◆ Draw()

virtual void Draw ( CDC * pDC )
virtual

This member function is used to draw the part content utilizing the specified device context.

Parameters
pDC Pointer to a valid device context.

Reimplemented from CXTPCalendarCaptionBarThemePart.

◆ OnKeyDown()

virtual void OnKeyDown | ( | UINT | nChar,
 |  | UINT | nRepCnt,
 |  | UINT | nFlags )
 virtual

This member function is used to process key-down keyboard events.

Parameters
nChar | A UINT that specifies the virtual key code of the given key.
nRepCnt | A UINT that specifies the number of times the keystroke is repeated as a result of the user holding down the key.
nFlags | A UINT that specifies the scan code, key-transition code, previous key state, and the context code.

This method is called by the CalendarView when the user presses keys on the keyboard.

Reimplemented from CXTPCalendarWMHandler.

◆ OnKeyUp()

virtual void OnKeyUp | ( | UINT | nChar,
 |  | UINT | nRepCnt,
 |  | UINT | nFlags )
 virtual

This member function is used to process key-up keyboard events.

Parameters
nChar | A UINT that specifies the virtual key code of the given key.
nRepCnt | A UINT that specifies the number of times the keystroke is repeated as a result of the user holding down the key.
nFlags | A UINT that specifies the scan code, key-transition code, previous key state, and the context code.

This method is called by the CalendarView when the user releases keys on the keyboard.

Reimplemented from CXTPCalendarWMHandler.

◆ OnLButtonDown()

virtual BOOL OnLButtonDown | ( | UINT | nFlags,
 |  | CPoint | point )
 virtual

This member function is used to process left mouse button down events.

Parameters
nFlags | An int that indicates whether various virtual keys are down.
point | A CPoint object that specifies the x- and y- coordinates of the cursor. These coordinates are always relative to the upper-left corner of the window.
Returns
TRUE if the message is handled successfully, FALSE else.

This method is called by the parent object when the user presses the left mouse button.

Reimplemented from CXTPCalendarCaptionBarThemePart.

The documentation for this class was generated from the following file:
  • XTPCalendarCaptionBarThemePart.h


Toolkit Pro: CXTPSearchOptionsCtrl Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPSearchOptionsCtrl Class Reference

CXTPSearchOptionsCtrl is a CStatic derived class. More...

Public Member Functions

CXTPSearchOptionsCtrl ()
Constructs a CXTPSearchOptionsCtrl object.
virtual | ~CXTPSearchOptionsCtrl ()
Destroys a CXTPSearchOptionsCtrl object, handles cleanup and deallocation.
bool | IsExpanded () const
Call this member function to determine if the search options control has been expanded.
void | AddControl (CWnd *pWndCtrl)
Call this member function to add a control to the list of controls that are displayed when the hide item control is expanded.
void | MoveControl (CWnd *pWndCtrl)
Call this member function to add a control to the list of controls that are moved when the hide item control is either expanded or contracted.
void | SetLabelText (LPCTSTR lpszExpand, LPCTSTR lpszContract)
Call this member function to set the text that is displayed when the hide item control is either expanded or contracted.
void | Expand ()
Call this member function to expand the hide item control and display CWnd objects contained in the hide item list.
void | Contract ()
Call this member function to contract the hide item control and hide CWnd objects contained in the hide item list.
int | GetMinSize ()
Call this member function to return the minimum height of the hide item control.
int | GetMaxSize ()
Call this member function to return the maximum height of the hide item control.
int | GetOffsetSize ()
Call this member function to return the offset size for the CXTPSearchOptionsCtrl object.

Protected Member Functions

virtual bool Init ()
This member function is called by the CXTPSearchOptionsCtrl class to perform initialization when the window is created or sub-classed.

Protected Attributes

int | m_iMinSize
Height of the control when contracted.
int | m_iMaxSize
Height of the control when expanded.
bool | m_bExpanded
true when the control is expanded.
bool | m_bPreSubclassInit
true for initialization.
CRect | m_rcLabel
Size of the label that is displayed.
CString | m_strExpandLabel
Label to display when the control is expanded.
CString | m_strContractLabel
Label to display when the control is contracted.
CPtrArray | m_arHideCtrls
List of controls to show or hide.
CPtrArray | m_arMoveCtrls
List of controls to move when expanded or contracted.

Detailed Description

CXTPSearchOptionsCtrl is a CStatic derived class.

CXTPSearchOptionsCtrl is used to create a control similar to the Search Options item found in the search pane of Windows Explorer as it is seen in Windows 2000 and later. This class allows you to associate a group of controls to be hidden or shown when the item is expanded and contracted and a set of controls that need to move depending on the CXTPSearchOptionsCtrl state.

Use with the CXTPSearchOptionsView form view class to create a pane similar to the Windows Explorer search pane. To use the control, define a set of controls that are to be hidden and moved depending on the CXTPSearchOptionsCtrl state.

Example: The following example demonstrates how to use CXTPSearchOptionsCtrl.

void CExpandTestView::OnInitialUpdate()
{
   CXTPSearchOptionsView::OnInitialUpdate();

   m_expand.AddControl(&m_check1);
   m_expand.AddControl(&m_check2);
   m_expand.AddControl(&m_edit1);
   m_expand.AddControl(&m_edit2);

   m_expand.MoveControl(&m_button1);
   m_expand.MoveControl(&m_button2);
   m_expand.MoveControl(&m_combo1);

   m_expand.SetLabelText(
   _T("Search Options <<"), _T("Search Options >>"));
}

See the "SearchOptions" demo for a complete example.

Member Function Documentation

◆ AddControl()

void AddControl ( CWnd * pWndCtrl )

Call this member function to add a control to the list of controls that are displayed when the hide item control is expanded.

Parameters
pWndCtrl Pointer to a valid CWnd object.

◆ Contract()

void Contract ( )

Call this member function to contract the hide item control and hide CWnd objects contained in the hide item list.

Called by the control whenever the user clicks on the contract label.

◆ Expand()

void Expand ( )

Call this member function to expand the hide item control and display CWnd objects contained in the hide item list.

Called by the control whenever the user clicks on the expand label.

◆ GetMaxSize()

int GetMaxSize ( )

Call this member function to return the maximum height of the hide item control.

Returns
An integer value that represents the height of the hide item control when it is expanded.

◆ GetMinSize()

int GetMinSize ( )

Call this member function to return the minimum height of the hide item control.

Returns
An integer value that represents the height of the hide item control when it is contracted.

◆ GetOffsetSize()

int GetOffsetSize ( )

Call this member function to return the offset size for the CXTPSearchOptionsCtrl object.

This is the distance that the controls will be moved to accommodate for the expansion and contraction of the control. Also used by CXTPSearchOptionsView for adjusting scroll sizes.

Returns
An integer value that represents the distance that the controls will be moved.

◆ Init()

virtual bool Init ( )
protectedvirtual

This member function is called by the CXTPSearchOptionsCtrl class to perform initialization when the window is created or sub-classed.

Returns
TRUE if the window was successfully initialized, otherwise FALSE.

◆ IsExpanded()

bool IsExpanded ( ) const

Call this member function to determine if the search options control has been expanded.

Returns
true if expanded, otherwise false.

◆ MoveControl()

void MoveControl ( CWnd * pWndCtrl )

Call this member function to add a control to the list of controls that are moved when the hide item control is either expanded or contracted.

Parameters
pWndCtrl Pointer to a valid CWnd object.

◆ SetLabelText()

void SetLabelText | ( | LPCTSTR | lpszExpand,
 |  | LPCTSTR | lpszContract )

Call this member function to set the text that is displayed when the hide item control is either expanded or contracted.

Parameters
lpszExpand | A NULL-terminated string that represents the text displayed when the control is expanded.
lpszContract | A NULL-terminated string that represents the text displayed when the control is contracted.
The documentation for this class was generated from the following file:
  • XTPSearchOptionsCtrl.h


Toolkit Pro: CXTPSearchOptionsView Class Reference

Protected Member Functions | Protected Attributes | List of all members
CXTPSearchOptionsView Class Reference

CXTPSearchOptionsView is a CFormView derived class. More...

Protected Member Functions

CXTPSearchOptionsView (UINT nIDTemplate)
When you create an object of a type derived from CXTPSearchOptionsView, invoke one of the constructors to create the view object and identify the dialog resource on which the view is based.
CXTPSearchOptionsView (LPCTSTR lpszTemplateName)
When you create an object of a type derived from CXTPSearchOptionsView, invoke one of the constructors to create the view object and identify the dialog resource on which the view is based.
virtual | ~CXTPSearchOptionsView ()
Destroys a CXTPSearchOptionsView object, handles cleanup and deallocation.
void | SetResize (int nID, const XTP_RESIZEPOINT &ptTopLeft, const XTP_RESIZEPOINT &ptTopRight)
The SetResize function specifies how much each side of a control will move when the dialog is resized.
void | AdjustScrollSizes (CXTPSearchOptionsCtrl *pSOCtrl, bool bAdd)
Call this member function to adjust the scroll sizes for the form view.

Protected Attributes

CXTPBrush | m_xtpBrush
Handle to the current background brush.
CRect | m_rcWindow
Original size of the window.
CResizeWndArray | m_arResizeWnd
Array of children to move or resize.

Detailed Description

CXTPSearchOptionsView is a CFormView derived class.

It is to be used with a CXTPSearchOptionsCtrl object to paint the background and control background color white. It is also used for resizing and moving children of the form automatically.

Constructor & Destructor Documentation

◆ CXTPSearchOptionsView() [1/2]

CXTPSearchOptionsView ( UINT nIDTemplate )
protected

When you create an object of a type derived from CXTPSearchOptionsView, invoke one of the constructors to create the view object and identify the dialog resource on which the view is based.

You can identify the resource either by name (pass a string as the argument to the constructor) or by its ID (pass an unsigned integer as the argument).

Parameters
nIDTemplate Contains the ID number of a dialog-template resource.

The form-view window and child controls are not created until CWnd::Create is called. CWnd::Create is called by the framework as part of the document and view creation process, which is driven by the document template.

◆ CXTPSearchOptionsView() [2/2]

CXTPSearchOptionsView ( LPCTSTR lpszTemplateName )
protected

When you create an object of a type derived from CXTPSearchOptionsView, invoke one of the constructors to create the view object and identify the dialog resource on which the view is based.

You can identify the resource either by name (pass a string as the argument to the constructor) or by its ID (pass an unsigned integer as the argument).

Parameters
lpszTemplateName Contains a NULL-terminated string that is the name of a dialog-template resource.

The form-view window and child controls are not created until CWnd::Create is called. CWnd::Create is called by the framework as part of the document and view creation process, which is driven by the document template.

Member Function Documentation

◆ AdjustScrollSizes()

void AdjustScrollSizes | ( | CXTPSearchOptionsCtrl * | pSOCtrl,
 |  | bool | bAdd )
 protected

Call this member function to adjust the scroll sizes for the form view.

Parameters
pSOCtrl | Pointer to the CXTPSearchOpetionsCtrl object to adjust the scroll sizes for.
bAdd | true to add the size, false to subtract the size.

◆ SetResize()

void SetResize | ( | int | nID,
 |  | const XTP_RESIZEPOINT & | ptTopLeft,
 |  | const XTP_RESIZEPOINT & | ptTopRight )
 protected

The SetResize function specifies how much each side of a control will move when the dialog is resized.

If a control should be repositioned (e.g. an OK button), then all four sides should move by the same amount of pixels as the dialog is resized. If a control should be resized just as much as the dialog (e.g. the list control in the file dialog), then the left and top sides should not move, and the right and bottom sides should move by the same amount of pixels as the dialog.

Parameters
nID | Specifies the control's ID.
ptTopLeft | How much the top and left sides will move when the dialog is resized.
ptTopRight | How much the bottom and right sides will move when the dialog is resized.
The documentation for this class was generated from the following file:
  • XTPSearchOptionsCtrl.h


Toolkit Pro: CXTPShadowManager Class Reference

Public Member Functions | Public Attributes | List of all members
CXTPShadowManager Class Reference

CXTPShadowManager is standalone class used to manage CommandBars' shadows. More...

Inheritance diagram for CXTPShadowManager:
[legend]

Public Member Functions

CXTPShadowManager ()
Constructs a CXTPShadowManager object.
~CXTPShadowManager ()
Destroys a CXTPShadowManager object, handles cleanup and deallocation.
BOOL | IsAlphaShadow ()
Check the system alpha shadow ability.
void | SetShadow (CRect rcWindow, CWnd *pShadowOwner)
Sets the command bar shadow.
void | SetShadow (CWnd *pShadowOwner, const CRect &rcExclude=CRect(0, 0, 0, 0), int nLevel=0)
Sets the command bar shadow.
void | RemoveShadow (CWnd *pShadowOwner)
Removes shadows for the command bar.
void | OffsetShadow (CWnd *pShadowOwner, CSize szOffset)
Call this method to move shadow to specified offset.
POSITION | GetHeadPosition (CWnd *pShadowOwner) const
This method used to enumerate all shadows of specific parent window.
CWnd * | GetNext (POSITION &pos) const
This method used to enumerate all shadows of specific parent window.
int | GetShadowOptions () const
Returns combination of XTPShadowOptions flags for shadows.
void | SetShadowOptions (int nOptions)
Call this method to set shadow options.
void | SetShadowColor (COLORREF clrShadow)
Call this method to set specific color for shadows.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Public Attributes

BOOL m_bUseSystemSaveBitsStyle
If this flag is set CS_SAVEBITS style will be used for shadow windows.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

CXTPShadowManager is standalone class used to manage CommandBars' shadows.

It should not be confused with a frame shadow (read more about CXTPFrameShadowManager).

Member Function Documentation

◆ GetHeadPosition()

POSITION GetHeadPosition ( CWnd * pShadowOwner ) const

This method used to enumerate all shadows of specific parent window.

Parameters
pShadowOwner Point to parent owner of shadows
Returns
Position to first element in list of shadows. Use GetNext method to retrieve it.

◆ GetNext()

CWnd * GetNext ( POSITION & pos ) const

This method used to enumerate all shadows of specific parent window.

Call GetHeadPosition to get position of first shadow

Parameters
pos Current position of shadow in the list
Returns
Pointer to Shadow corresponded to pos position.

◆ GetShadowOptions()

int GetShadowOptions ( ) const

Returns combination of XTPShadowOptions flags for shadows.

Returns
Combination of XTPShadowOptions flags

◆ IsAlphaShadow()

BOOL IsAlphaShadow ( )

Check the system alpha shadow ability.

Returns
TRUE if alpha shadow available; otherwise returns FALSE

◆ OffsetShadow()

void OffsetShadow | ( | CWnd * | pShadowOwner,
 |  | CSize | szOffset )

Call this method to move shadow to specified offset.

Parameters
pShadowOwner | Shadow to move
szOffset | Window move offset

◆ RemoveShadow()

void RemoveShadow ( CWnd * pShadowOwner )

Removes shadows for the command bar.

Parameters
pShadowOwner Points to a CXTPCommandBar object

◆ SetShadow() [1/2]

void SetShadow | ( | CRect | rcWindow,
 |  | CWnd * | pShadowOwner )

Sets the command bar shadow.

Parameters
rcWindow | Bounding rectangle of parent window
pShadowOwner | Points to a parent windows

◆ SetShadow() [2/2]

void SetShadow | ( | CWnd * | pShadowOwner,
 |  | const CRect & | rcExclude = CRect(0, 0, 0, 0),
 |  | int | nLevel = 0 )

Sets the command bar shadow.

Parameters
pShadowOwner | Points to a parent windows
rcExclude | Excluded rectangle.
nLevel | Recursive level of the parent window

◆ SetShadowColor()

void SetShadowColor ( COLORREF clrShadow )

Call this method to set specific color for shadows.

Parameters
clrShadow New color to set

◆ SetShadowOptions()

void SetShadowOptions ( int nOptions )

Call this method to set shadow options.

Parameters
nOptions Combination of XTPShadowOptions flags to set. It can be the following values: xtpShadowOfficeAlpha: Office alpha shadow. xtpShadowShowPopupControl: Draw shadow for pop-up controls.
The documentation for this class was generated from the following file:
  • XTPHookManager.h


Toolkit Pro: CXTPShellExplorerProvider Class Reference

Public Types | Public Member Functions | List of all members
CXTPShellExplorerProvider Class Reference

Implements ShellExplorer WebBrowser provider and gives access to ShellExplorer specific functionality. More...

Inheritance diagram for CXTPShellExplorerProvider:
[legend]

Public Types

enum ScrollBarStyle { xtpScrollBarStandard , xtpScrollBarFlat , xtpScrollBarNone }
Defines ShellExplorer scrollbar styles. More...

Public Member Functions

CXTPShellExplorerProvider (IXTPWebBrowserHost &host)
Constructs provider object.
~CXTPShellExplorerProvider ()
Handles provider destruction.
BOOL | GetRegisterAsDropTarget () const
Gets a flag value that enables registration of the WebBrowser control as drop target.
void | SetRegisterAsDropTarget (BOOL bRegisterAsDropTarget=TRUE)
Sets a flag value that enables registration of the WebBrowser control as drop target.
BOOL | GetContextMenuEnabled () const
Gets a flag value that enables WebBrowser control context menu.
void | SetContextMenuEnabled (BOOL bContextMenuEnabled=TRUE)
Sets a flag value that enables WebBrowser control context menu.
ScrollBarStyle | GetScrollBarStyle () const
Gets WebBrowser control scrollbar style.
void | SetScrollBarStyle (ScrollBarStyle nScrollBarStyle)
Sets WebBrowser control scrollbar style.
BOOL | GetScriptErrorsSuppressed () const
Gets a flag that suppresses script errors on a loaded web page.
void | SetScriptErrorsSuppressed (BOOL bScriptErrorsSuppressed=TRUE)
Sets a flag that suppresses script errors on a loaded web page.
BOOL | GetStaticText () const
Gets a flag that enables selection of the text in the form.
void | SetStaticText (BOOL bStaticText=TRUE)
Sets a flag that enables selection of the text in the form.
HRESULT | Navigate2 (VARIANT *pvtURL, VARIANT *pvtFlags=NULL, VARIANT *pvtTargetFrameName=NULL, VARIANT *pvtPostData=NULL, VARIANT *pvtHeaders=NULL)
Navigates to the specified URL and provides additional parameters for the browser to use and customize navigation.
virtual HRESULT | ExecuteScript (LPCWSTR pText, CComVariant *pvtResult=NULL)
Executes a JavaScript code.
- Public Member Functions inherited from CXTPWebBrowserProvider
virtual | ~CXTPWebBrowserProvider ()
Handles provider destruction.
IUnknown * | GetBrowserObject () const
Obtains the native WebBrowser provider object or NULL if no provider is activated or the current provider does not provide access to its core object via IUnknown.
IUnknown * | GetClientInterface (REFIID riid) const
Gets the client interface.
void | SetClientInterface (REFIID riid, IUnknown *pUnk)
Sets the client interface.
void | RemoveClientInterface (REFIID riid)
Removes the client interface.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Member Functions inherited from CXTPWebBrowserProvider
CXTPWebBrowserProvider (IXTPWebBrowserHost &host)
Handles provider construction.
- Protected Attributes inherited from CXTPWebBrowserProvider
IXTPWebBrowserHost & | m_Host
The host control interface.

Detailed Description

Implements ShellExplorer WebBrowser provider and gives access to ShellExplorer specific functionality.

Member Enumeration Documentation

◆ ScrollBarStyle

enum ScrollBarStyle

Defines ShellExplorer scrollbar styles.

Enumerator
xtpScrollBarStandard | Normal scrollbars.
xtpScrollBarFlat | Flat scrollbars.
xtpScrollBarNone | Scrollbars are turned off.

Constructor & Destructor Documentation

◆ CXTPShellExplorerProvider()

CXTPShellExplorerProvider ( IXTPWebBrowserHost & host )

Constructs provider object.

Parameters
host The host control interface.

Member Function Documentation

◆ ExecuteScript()

virtual HRESULT ExecuteScript | ( | LPCWSTR | pText,
 |  | CComVariant * | pvtResult = NULL )
 virtual

Executes a JavaScript code.

Parameters
pText | Script code text.
pvtResult | The optional pointer to the variant object that is supposed to receive the result of the executed script.
Returns
S_OK if script execution or its attempt are successful or an error code otherwise.

Implements CXTPWebBrowserProvider.

◆ GetContextMenuEnabled()

BOOL GetContextMenuEnabled ( ) const

Gets a flag value that enables WebBrowser control context menu.

Returns
The current flag value.

◆ GetRegisterAsDropTarget()

BOOL GetRegisterAsDropTarget ( ) const

Gets a flag value that enables registration of the WebBrowser control as drop target.

Returns
The current flag value.

◆ GetScriptErrorsSuppressed()

BOOL GetScriptErrorsSuppressed ( ) const

Gets a flag that suppresses script errors on a loaded web page.

Returns
The current flag value.

◆ GetScrollBarStyle()

ScrollBarStyle GetScrollBarStyle ( ) const

Gets WebBrowser control scrollbar style.

Returns
The current scrollbar style.

◆ GetStaticText()

BOOL GetStaticText ( ) const

Gets a flag that enables selection of the text in the form.

Returns
The current flag value.

◆ Navigate2()

HRESULT Navigate2 | ( | VARIANT * | pvtURL,
 |  | VARIANT * | pvtFlags = NULL,
 |  | VARIANT * | pvtTargetFrameName = NULL,
 |  | VARIANT * | pvtPostData = NULL,
 |  | VARIANT * | pvtHeaders = NULL )

Navigates to the specified URL and provides additional parameters for the browser to use and customize navigation.

Parameters
pvtURL | A pointer to a VARIANT that evaluates to the URL of the resource to display, the full path to the file location, or a PIDL that represents a folder in the Shell namespace.
pvtFlags | A pointer to a VARIANT of type VT_I4 or VT_I2 that specifies a combination of the values defined by the BrowserNavConstants enumeration from the Windows SDK.
pvtTargetFrameName | A pointer to a case-sensitive string that contains the name of the frame in which to display the resource ("_blank", "_parent", "_self", "_top" or a named HTML frame).
pvtPostData | A pointer to a VARIANT of type VT_ARRAY|VT_UI1 that is sent to the server as part of a HTTP POST transaction. A POST transaction typically is used to send data collected by an HTML form. If this parameter does not specify any POST data, this method issues an HTTP GET transaction. This parameter is ignored if URL is not an HTTP (or HTTPS) URL.
pvtHeaders | A pointer to a VARIANT of type VT_BSTR that contains additional HTTP headers to send to the server. These headers are added to the default Windows Internet Explorer headers. For example, headers can specify the action required of the server, the type of data being passed to the server, or a status code. This parameter is ignored if the URL is not an HTTP (or HTTPS) URL.
Returns
S_OK if navigation is successul or an error code otherwise.

◆ SetContextMenuEnabled()

void SetContextMenuEnabled ( BOOL bContextMenuEnabled = TRUE )

Sets a flag value that enables WebBrowser control context menu.

Parameters
bContextMenuEnabled The new flag value.

◆ SetRegisterAsDropTarget()

void SetRegisterAsDropTarget ( BOOL bRegisterAsDropTarget = TRUE )

Sets a flag value that enables registration of the WebBrowser control as drop target.

Parameters
bRegisterAsDropTarget The new flag value.

◆ SetScriptErrorsSuppressed()

void SetScriptErrorsSuppressed ( BOOL bScriptErrorsSuppressed = TRUE )

Sets a flag that suppresses script errors on a loaded web page.

Parameters
bScriptErrorsSuppressed The new flag value.

◆ SetScrollBarStyle()

void SetScrollBarStyle ( ScrollBarStyle nScrollBarStyle )

Sets WebBrowser control scrollbar style.

Parameters
nScrollBarStyle The new scrollbar style.

◆ SetStaticText()

void SetStaticText ( BOOL bStaticText = TRUE )

Sets a flag that enables selection of the text in the form.

Parameters
bStaticText The new flag value.
The documentation for this class was generated from the following file:
  • XTPShellExplorerProvider.h


Toolkit Pro: CXTPShellListBase Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPShellListBase Class Reference

CXTPShellListBase is a multiple inheritance class derived from CXTPListView and CXTPShellPidl. More...

Inheritance diagram for CXTPShellListBase:
[legend]

Public Member Functions

CXTPShellListBase ()
Constructs a CXTPShellListBase object.
virtual | ~CXTPShellListBase ()
Destroys a CXTPShellListBase object, handles cleanup and deallocation.
virtual void | EnableContextMenu (BOOL bEnable)
Call this member function to enable/disable the display of the shell context menu on the right click of the item.
virtual void | SetEnumFlags (UINT uFlags)
Call this member function to determine the type of items included in the shell enumeration.
virtual BOOL | InitSystemImageLists ()
This member function associates the system image list with the list control.
virtual BOOL | PopulateListView (XTP_TVITEMDATA *lptvid, LPSHELLFOLDER lpsf)
This member function populates the list view control.
virtual int | GetDoubleClickedItem ()
This member function returns the index of the list view item that was double clicked on.
virtual void | ShowShellContextMenu (CPoint pos)
This member function displays the system pop-up menu for the selected item or folder.
virtual bool | ShellOpenItem (int iItem)
This member function executes the item clicked on in the list control via the Shell.
virtual bool | ShellOpenItem (XTP_LVITEMDATA *lplvid)
This member function executes the item clicked on in the list control via the Shell.
virtual BOOL | GetItemPath (int iItem, CString &strItemPath)
This member function retrieves the path for the specified list view item.
virtual void | BuildDefaultColumns ()
This member function creates default columns for the list view.
virtual bool | SortList (int nCol, bool bAscending)
Override this member function in your derived class to perform custom sort routines.
virtual void | OnDragDrop (NM_LISTVIEW *pNMListView)
Used by the shell list control to handle a drag drop event.
virtual TCHAR * | InsertCommas (LONGLONG value, TCHAR *szBuffer, UINT nSize)
Called by the shell list control to insert commas into the specified numeric value.
virtual void | SetIncludeExtensions (LPCTSTR lpszFilters=NULL)
Call this member function to define a file filter for the files displayed.
BOOL | RefreshRowColors ()
Call this member function to refresh the values for the shell settings and compressed colors that are used by the list control.
void | SetExplorerStyle ()
Call this member function to enable explorer style for the list.
- Public Member Functions inherited from CXTPListBase
CXTPListBase ()
Constructs a CXTPListBase object.
virtual | ~CXTPListBase ()
Destroys a CXTPListBase object, handles cleanup and deallocation.
CXTPHeaderCtrl * | XTPGetHeaderCtrl () const
Call this member function to get a pointer to the flat header control.
virtual int | SetSortImage (int nCol, BOOL bAsc)
This member function will set the sort image for the specified column.
virtual int | GetStoredWidth (int nCol)
This member function will return the column width stored in the registry.
virtual void | SetStoredWidth (int nCol)
This member function will set the column width from the registry settings.
virtual void | LoadColumnWidths ()
This member function loads the column widths from the registry.
virtual void | SaveColumnWidths ()
This member function saves the column widths to the registry.
virtual void | AutoSizeColumn (int nCol=-1)
Automatically sizes a specified column.
virtual void | AutoSizeColumn (int nCol, BOOL bUseHeader)
Automatically sizes a specified column.
virtual void | AutoSaveColumns (LPCTSTR lpszSection=NULL, LPCTSTR lpszEntry=NULL, LPCTSTR lpszDefault=NULL)
Initializes the auto save feature.
virtual bool | SubclassHeader (bool bBoldFont=false)
Call this member function to subclass the flat header control.
virtual void | SetExtendedStyle (DWORD dwExStyle)
This member function is called to set extended styles for the list control, ie: LVS_EX_FULLROWSELECT, LVS_EX_GRIDLINES, etc.
virtual DWORD | GetExtendedStyle ()
This member function is called to retrieve the list control extended style.
virtual void | DisableColumnSizing (bool bDisable)
Call this member function to disable/enable column sizing.
void | SetMinimumColSize (int nSize)
Call this member function to set a minimum column size.
int | GetMinimumColSize ()
Call this member function to get the minimum column size for the list control.
int | GetMaximumColSize ()
Call this member function to get the maximum column size for the list control.
virtual int | HitTestEx (CPoint &point, int *col) const
Call this member function to determine the row index and column index for a 'point'.
virtual int | AddColumn (LPCTSTR lpszColHeading, int nWidth=-1, int nFormat=LVCFMT_LEFT)
Call this member function to add a column after the right most column.
virtual bool | BuildColumns (int nCols, int *nWidth, int *nColString)
This member function will build the columns for the list control.
virtual bool | BuildColumns (int nCols, int *nWidth, CString *strColString)
This member function will build the columns for the list control.
virtual int | GetColumnCount ()
This member function gets the number of columns in the list.
virtual int | CopyRow (int nFrom, int nTo)
This member function copies a row to a new location.
virtual bool | MoveRow (int nFrom, int nTo)
This member function moves a row to a new location.
CHeaderCtrl * | _xtGetHeaderCtrl () const
This member function is a utility function to retrieve the associated header control.
void | SetRowColors (COLORREF clrText, COLORREF clrTextBk)
This member function sets the row, text, and background colors for the list control.
void | SetRowColor (ROWCOLOR *lpRowColor, BOOL bRedraw=TRUE)
This member function sets the text and background colors for the specified row in the list control.
void | SetRowColor (int iRow, COLORREF crText, COLORREF crBack, BOOL bRedraw=TRUE)
This member function sets the text and background colors for the specified row in the list control.
void | RemoveRowColors ()
Call this member function to remove all user-defined row colors from the list control.
virtual ROWCOLOR * | Lookup (int iRow)
Call this member function to determine if the specified row contains user-defined color attributes.
virtual BOOL | ModifyExtendedStyle (DWORD dwRemove, DWORD dwAdd)
Call this member function to modify the extended style for the list control.
COLORREF | GetListBackColor () const
Call this member function to retrieve the RGB color value used for the column background color.
void | SetListBackColor (COLORREF crListBack)
Call this member function to set the RGB color value used for the list background color.
COLORREF | GetListTextColor () const
Call this member function to retrieve the RGB color value used for the column text color.
void | SetListTextColor (COLORREF crListText)
Call this member function to set the RGB color value used for the list text color.
COLORREF | GetSortBackColor () const
Call this member function to retrieve the RGB color value used for the sorted column background color.
void | SetSortBackColor (COLORREF crSortBack)
Call this member function to set the RGB color value used for the sorted column background color.
COLORREF | GetSortTextColor () const
Call this member function to retrieve the RGB color value used for the sorted column text color.
void | SetSortTextColor (COLORREF crSortText)
Call this member function to set the RGB color value used for the sorted column text color.
void | EnableUserSortColor (bool bEnable)
Call this member function to enable/disable sorted column colors.
bool | IsUserSortColor () const
Call this member function to determine if sorted column colors are enabled.
void | EnableUserListColor (bool bEnable)
Call this member function to enable/disable user-defined colors.
bool | IsUserListColor () const
Call this member function to determine if user-defined colors are enabled.
void | EnableUserRowColor (bool bEnable)
Call this member function to enable/disable user-defined row colors.
bool | IsUserRowColor () const
Call this member function to determine if user-defined row colors are enabled.
void | SetAutoFont (bool bAutoFont)
Call this member function to automatically set the font for the list control when the control is initialized to use the toolkit default font.
- Public Member Functions inherited from CXTPShellPidl
CXTPShellPidl ()
Constructs a CXTPShellPidl object.
virtual | ~CXTPShellPidl ()
Destroys a CXTPShellPidl object, handles cleanup and deallocation.
LPITEMIDLIST | IDLFromPath (LPCTSTR path)
This member function gets the fully qualified PIDL for the path string.
LPITEMIDLIST | OneUpPIDL (LPITEMIDLIST pidlPath)
This member function performs the OneUp or back function.
CString | OneUpPATH (const CString &path)
This member function gets the parent folder using PIDLs.
LPITEMIDLIST | GetLastITEM (LPITEMIDLIST pidl)
This member function walks an ITEMIDLIST and points to the last one.
LPITEMIDLIST | CopyIDList (LPITEMIDLIST pidl)
This member function copies a whole ITEMIDLIST.
LPITEMIDLIST | ConcatPidls (LPCITEMIDLIST pidl1, LPCITEMIDLIST pidl2)
This member function concatenates two PIDLs.
LPITEMIDLIST | ConcatPidls (LPMALLOC lpMalloc, LPCITEMIDLIST pidl1, LPCITEMIDLIST pidl2)
This member function concatenates two PIDLs.
LPITEMIDLIST | GetFullyQualPidl (LPSHELLFOLDER lpsf, LPITEMIDLIST lpi)
This member function gets the fully qualified PIDLs for the specified folder.
LPITEMIDLIST | DuplicateItem (LPMALLOC lpMalloc, LPITEMIDLIST lpi)
This member function copies the ITEMID.
BOOL | GetName (LPSHELLFOLDER lpsf, LPITEMIDLIST lpi, DWORD dwFlags, CString &lpFriendlyName)
This member function gets the friendly name for the folder or file.
LPITEMIDLIST | CreatePidl (LPMALLOC lpMalloc, UINT cbSize)
This member function allocates a PIDL.
UINT | GetPidlItemCount (LPCITEMIDLIST pidl)
This member function calculates the number of item IDs in an item ID list.
LPITEMIDLIST | GetNextPidlItem (LPCITEMIDLIST pidl)
This member function retrieves the next PIDL in the list.
BOOL | ShowContextMenu (HWND hwnd, LPSHELLFOLDER lpsfParent, LPITEMIDLIST lpi, LPPOINT lppt)
This member function displays a pop-up context menu if given a parent shell folder, relative item ID, and screen location.
BOOL | ShowContextMenu (HWND hwnd, LPSHELLFOLDER lpsfParent, LPCITEMIDLIST *lppi, int nCount, LPPOINT lppt)
This member function displays a pop-up context menu if given a parent shell folder, relative item ID, and screen location.
int | GetItemIcon (LPITEMIDLIST lpi, UINT uFlags) const
This member function gets the index for the current icon.
HIMAGELIST | GetSystemImageList (UINT uFlags) const
Call this member function to retrieve a string that describes the type of file specified by lpi from the Windows Shell.
ULONG | GetAttributes (LPSHELLFOLDER lpsf, LPITEMIDLIST lpi, ULONG uFlags) const
Retrieves the attributes of one or more file objects or subfolders.
HRESULT | GetSHContextMenu (LPSHELLFOLDER psfFolder, LPCITEMIDLIST *localPidl, int nCount, void **ppCM, int *pcmType)
This member function retrieves the IContextMenu, IContextMenu2 or IContextMenu3 interface.
void | ShowShellLinkIcons (BOOL bShowLinkIcons=TRUE)
Call this member function to override the shortcut link display for each item.
UINT | GetPidlCount (LPCITEMIDLIST pidl)
Calculates the number of item IDs in the list.
void | FreePidl (LPITEMIDLIST pidl)
This member function frees memory allocated for a PIDL.
LPITEMIDLIST | CopyPidlItem (LPITEMIDLIST pidl, UINT nItem)
This member function copies a single PIDL out of a list.
BOOL | ComparePidls (LPCITEMIDLIST pidl1, LPCITEMIDLIST pidl2, LPSHELLFOLDER pShellFolder=NULL)
This member function compares two PIDLs to determine if they match.

Protected Member Functions

virtual bool | Init ()
This member function is called by the CXTPShellListBase class to perform initialization when the window is created or sub-classed.
virtual BOOL | InitListViewItems (XTP_TVITEMDATA *lptvid, LPSHELLFOLDER lpsf)
This member function adds items to the list view.
virtual void | GetNormalAndSelectedIcons (LPITEMIDLIST lpifq, LPTV_ITEM lptvitem)
This member function gets the index for the normal and selected icons of the current item.
virtual void | SetAttributes (int iItem, DWORD dwAttributes)
This member function sets the shell attribute flags for the specified list item.
virtual BOOL | IsItemFiltered (LPCTSTR lpszItemName, ULONG ulItemAttrs)
This member function determines if an item is filtered.
- Protected Member Functions inherited from CXTPListBase
void | ImplAttach (CListCtrl *pListCtrl)
Sets the list control pointer.
virtual BOOL | OnNotify (WPARAM wParam, LPARAM lParam, LRESULT *pResult)
Called from the derived class OnNotify method.
void | RefreshMetrics ()
Updates colors and size values.
- Protected Member Functions inherited from CXTPShellPidl
virtual void | OnShowContextMenu (int idCmd, CMINVOKECOMMANDINFO &cmi)
This method is called when an item of a context menu is executed.
virtual void | MapShellFlagsToItemAttributes (CListCtrl *pListCtrl, int iItem, DWORD dwAttributes)
This function translates shell attributes into a tree item state.
virtual void | MapShellFlagsToItemAttributes (CTreeCtrl *pTreeCtrl, HTREEITEM hItem, DWORD dwAttributes)
This function translates shell attributes into a tree item state.

Protected Attributes

int | m_nNameColumnWidth
Size in pixels for the name column width.
UINT | m_uFlags
Flags indicating which items to include in the enumeration.
BOOL | m_bContextMenu
TRUE to display the shell context menu on right item click.
LPITEMIDLIST | m_pidlINet
Pointer to the CSIDL_INTERNET folder location.
CString | m_csIncludeEXT
Comma delimited string of extensions to include in file display.
CXTPDirWatcher * | m_pDirThread
Thread used to monitor directory activity.
CXTPShellSettings | m_shSettings
Contains SHELLFLAGSTATE info.
LPSHELLFOLDER | m_lpsfFolder
Represents the parent IShellFolder interface.
- Protected Attributes inherited from CXTPListBase
int | m_nMinColWidth
Minimum width for columns.
int | m_nMaxColWidth
Maximum width for columns.
int | m_nSortedCol
Index of the currently selected column.
bool | m_bAutoFont
If true, then the font will automatically be set for the control.
bool | m_bAutoSave
true if saving the column widths.
bool | m_bListColor
true if user-defined colors are used for background and text.
bool | m_bRowColor
true if rows are drawn with user-defined colors.
bool | m_bSortColor
true if the sorted column is drawn in color.
bool | m_bAscending
Flag to determine the sorting order.
bool | m_bNoColSizing
If true, then column sizing is disabled.
CString | m_strSection
Registry section name.
CString | m_strEntry
Registry entry name.
CString | m_strDefault
Registry default value.
COLORREF | m_crListText
RGB value representing the row text color.
COLORREF | m_crListBack
RGB value representing the row text background color.
COLORREF | m_crSortText
RGB value for sort column text color.
COLORREF | m_crSortBack
RGB value for sort column background color.
CRowColorList | m_arRowColor
List of user-defined text and background row colors.
CXTPHeaderCtrl | m_wndHeader
Subclassed flat header control.
CListCtrl_Friendly * | m_pListCtrl
List control instance.
- Protected Attributes inherited from CXTPShellPidl
ULONG | m_ulSFGAOFlags
SFGAO flags used to retrieve shell item attributes.
BOOL | m_bShowShellLinkIcons
Set to FALSE to override shortcut link display.

Additional Inherited Members

- Public Types inherited from CXTPListBase
typedef CList< ROWCOLOR, ROWCOLOR & > | CRowColorList
List for maintaining ROWCOLOR structures.
- Static Public Member Functions inherited from CXTPShellPidl
static int CALLBACK | TreeViewCompareProc (LPARAM lparam1, LPARAM lparam2, LPARAM lparamSort)
CXTPShellTreeCtrl callback sort function.
static int CALLBACK | ListViewCompareProc (LPARAM lparam1, LPARAM lparam2, LPARAM lparamSort)
CXTPShellListCtrl callback sort function.

Detailed Description

CXTPShellListBase is a multiple inheritance class derived from CXTPListView and CXTPShellPidl.

It is used to create a CXTPShellListBase class object.

Member Function Documentation

◆ EnableContextMenu()

virtual void EnableContextMenu ( BOOL bEnable )
virtual

Call this member function to enable/disable the display of the shell context menu on the right click of the item.

Parameters
bEnable TRUE to enable the display of the shell context menu.

◆ GetDoubleClickedItem()

virtual int GetDoubleClickedItem ( )
virtual

This member function returns the index of the list view item that was double clicked on.

Returns
The index of the item that was double clicked, or -1 if the item was not found.

◆ GetItemPath()

virtual BOOL GetItemPath | ( | int | iItem,
 |  | CString & | strItemPath )
 virtual

This member function retrieves the path for the specified list view item.

Parameters
iItem | Index of the list view item to get the path of.
strItemPath | Reference to a CString object that receives the path string.
Returns
TRUE if successful, otherwise FALSE.

◆ GetNormalAndSelectedIcons()

virtual void GetNormalAndSelectedIcons | ( | LPITEMIDLIST | lpifq,
 |  | LPTV_ITEM | lptvitem )
 protectedvirtual

This member function gets the index for the normal and selected icons of the current item.

Parameters
lpifq | Fully qualified item ID list for the current item.
lptvitem | Pointer to the tree view item that is about to be added to the tree.

◆ Init()

virtual bool Init ( )
protectedvirtual

This member function is called by the CXTPShellListBase class to perform initialization when the window is created or sub-classed.

Returns
TRUE if the window was successfully initialized, otherwise FALSE.

Reimplemented from CXTPListBase.

◆ InitListViewItems()

virtual BOOL InitListViewItems | ( | XTP_TVITEMDATA * | lptvid,
 |  | LPSHELLFOLDER | lpsf )
 protectedvirtual

This member function adds items to the list view.

Parameters
lptvid | Pointer to tree view item data.
lpsf | Pointer to the parent shell folder.
Returns
TRUE if successful, otherwise FALSE.

◆ InitSystemImageLists()

virtual BOOL InitSystemImageLists ( )
virtual

This member function associates the system image list with the list control.

Returns
TRUE if successful, otherwise FALSE.

◆ InsertCommas()

virtual TCHAR * InsertCommas | ( | LONGLONG | value,
 |  | TCHAR * | szBuffer,
 |  | UINT | nSize )
 virtual

Called by the shell list control to insert commas into the specified numeric value.

The result is then returned in the szBufferOut item. An example of this would be to format a file size 1,024 KB.

Parameters
value | [in] Numeric value to insert commas.
szBuffer | [out] String buffer to receive the formatted string.
nSize | [in] Size of the string specified by szBuffer.
Returns
A string representing a comma separated numeric value.

◆ IsItemFiltered()

virtual BOOL IsItemFiltered | ( | LPCTSTR | lpszItemName,
 |  | ULONG | ulItemAttrs )
 protectedvirtual

This member function determines if an item is filtered.

You can override it in your class.

Parameters
lpszItemName | Friendly name for the folder or file.
ulItemAttrs | Attributes of the item.
Returns
TRUE if the item is filtered, otherwise FALSE.

◆ OnDragDrop()

virtual void OnDragDrop ( NM_LISTVIEW * pNMListView )
virtual

Used by the shell list control to handle a drag drop event.

Parameters
pNMListView Pointer to a NM_LISTVIEW structure.

◆ PopulateListView()

virtual BOOL PopulateListView | ( | XTP_TVITEMDATA * | lptvid,
 |  | LPSHELLFOLDER | lpsf )
 virtual

This member function populates the list view control.

Parameters
lptvid | Pointer to TreeView item data.
lpsf | Pointer to the parent shell folder.
Returns
TRUE if successful, otherwise FALSE.

◆ RefreshRowColors()

BOOL RefreshRowColors ( )

Call this member function to refresh the values for the shell settings and compressed colors that are used by the list control.

Returns
TRUE if shell compressed color display is enabled, otherwise FALSE.

◆ SetAttributes()

virtual void SetAttributes | ( | int | iItem,
 |  | DWORD | dwAttributes )
 protectedvirtual

This member function sets the shell attribute flags for the specified list item.

Parameters
iItem | Index of the item to set the attributes for.
dwAttributes | Flags retrieved from SHELLFOLDER::GetAttributesOf.

◆ SetEnumFlags()

virtual void SetEnumFlags ( UINT uFlags )
virtual

Call this member function to determine the type of items included in the shell enumeration.

The default is SHCONTF_FOLDERS | SHCONTF_NONFOLDERS.

Parameters
uFlags Determines the type of items included in an enumeration and can be one or more of the flags listed in the Remarks section.

Styles to be added or removed can be combined by using the bitwise OR (|) operator. It can be one or more of the following:

SHCONTF_FOLDERS: Include items that are folders in the enumeration. SHCONTF_NONFOLDERS: Include items that are not folders in the enumeration. SHCONTF_INCLUDEHIDDEN: Include hidden items in the enumeration. SHCONTF_INIT_ON_FIRST_NEXT: IShellFolder::EnumObjects can return without validating the enumeration object. Validation can be postponed until the first call to IEnumIDList::Next. This flag is intended to be used when a user interface may be displayed prior to the first IEnumIDList::Next call. For a user interface to be presented, 'hwndOwner' must be set to a valid window handle. SHCONTF_NETPRINTERSRCH: The caller is looking for printer objects.

◆ SetIncludeExtensions()

virtual void SetIncludeExtensions ( LPCTSTR lpszFilters = NULL )
virtual

Call this member function to define a file filter for the files displayed.

Only the files specified by pFilters will be displayed in the shell list. File extensions are separated by a semi-colon. Call SetIncludeExtensions(NULL); to restore normal file display.

Parameters
lpszFilters NULL-terminated string representing files to be displayed in the shell list control. Example:
SetIncludeExtensions(_T("*.wav;*.mp3;*.aif;*.wmv"));

◆ ShellOpenItem() [1/2]

virtual bool ShellOpenItem ( int iItem )
virtual

This member function executes the item clicked on in the list control via the Shell.

Parameters
iItem Index of the list view item clicked on.
Returns
true if successful, otherwise false.

◆ ShellOpenItem() [2/2]

virtual bool ShellOpenItem ( XTP_LVITEMDATA * lplvid )
virtual

This member function executes the item clicked on in the list control via the Shell.

Parameters
lplvid Pointer to the list view item data.
Returns
true if successful, otherwise false.

◆ ShowShellContextMenu()

virtual void ShowShellContextMenu ( CPoint pos )
virtual

This member function displays the system pop-up menu for the selected item or folder.

Parameters
pos Position to show.

◆ SortList()

virtual bool SortList | ( | int | nCol,
 |  | bool | bAscending )
 virtual

Override this member function in your derived class to perform custom sort routines.

Parameters
nCol | Passed in from the control. The index of the column clicked.
bAscending | Passed in from the control. true if the sort order should be ascending.
Returns
true if successful, otherwise false.

Reimplemented from CXTPListBase.

The documentation for this class was generated from the following file:
  • XTPShellListBase.h


Toolkit Pro: CXTPShellListCtrl Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPShellListCtrl Class Reference

CXTPShellListCtrl is a multiple inheritance class derived from CXTPListCtrl and CXTPShellPidl. More...

Inheritance diagram for CXTPShellListCtrl:
[legend]

Public Member Functions

CXTPShellListCtrl ()
Constructs a CXTPShellListCtrl object.
virtual | ~CXTPShellListCtrl ()
Destroys a CXTPShellListCtrl object, handles cleanup and deallocation.
virtual void | AssociateTree (CWnd *pWnd)
Call this member function to associate the tree control with the list.

Protected Attributes

CWnd * | m_pTreeCtrl
Window that receives update notification, usually a CXTPShellTreeCtrl.
bool | m_bInitControl
true if the control has not been initialized.

Detailed Description

CXTPShellListCtrl is a multiple inheritance class derived from CXTPListCtrl and CXTPShellPidl.

It is used to create a CXTPShellListCtrl window.

Member Function Documentation

◆ AssociateTree()

virtual void AssociateTree ( CWnd * pWnd )
virtual

Call this member function to associate the tree control with the list.

Parameters
pWnd Pointer to the tree control that is associated with the list.
The documentation for this class was generated from the following file:
  • XTPShellListCtrlView.h


Toolkit Pro: CXTPShellListCtrlEx Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPShellListCtrlEx Class Reference

CXTPShellListCtrlEx is a CXTPShellListCtrl derived class. More...

Inheritance diagram for CXTPShellListCtrlEx:
[legend]

Public Member Functions

CXTPShellListCtrlEx ()
Constructs a CXTPShellListCtrlEx object.
virtual | ~CXTPShellListCtrlEx ()
Destroys a CXTPShellListCtrlEx object, handles cleanup and deallocation.
bool | BrowseToFolder (LPCTSTR lpszPath)
This member function is called to browse to a particular file folder.
void | SetSyncWnd (CWnd *pSyncWnd)
This member function will associate a CWnd object with the shell list control.
- Public Member Functions inherited from CXTPShellListCtrl
CXTPShellListCtrl ()
Constructs a CXTPShellListCtrl object.
virtual | ~CXTPShellListCtrl ()
Destroys a CXTPShellListCtrl object, handles cleanup and deallocation.
virtual void | AssociateTree (CWnd *pWnd)
Call this member function to associate the tree control with the list.

Protected Attributes

CWnd * | m_pSyncWnd
Pointer to the window to synchronize with the shell list control.
CString | m_strItemPath
A NULL-terminated string that represents the currently selected folder.
- Protected Attributes inherited from CXTPShellListCtrl
CWnd * | m_pTreeCtrl
Window that receives update notification, usually a CXTPShellTreeCtrl.
bool | m_bInitControl
true if the control has not been initialized.

Detailed Description

CXTPShellListCtrlEx is a CXTPShellListCtrl derived class.

It is used to create a standalone shell list control that is not dependent on a CXTPShellTreeCtrl for initialization. It is used to create a CXTPShellListCtrlEx window for displaying the contents of file folders.

Member Function Documentation

◆ BrowseToFolder()

bool BrowseToFolder ( LPCTSTR lpszPath )

This member function is called to browse to a particular file folder.

Parameters
lpszPath A NULL-terminated string that represents the folder to select.
Returns
true if successful, otherwise false.

◆ SetSyncWnd()

void SetSyncWnd ( CWnd * pSyncWnd )

This member function will associate a CWnd object with the shell list control.

This window is usually a CEdit control, but can be any CWnd object. This window will have its window text updated whenever the selected folder is changed.

Parameters
pSyncWnd Pointer to a valid CWnd object.
The documentation for this class was generated from the following file:
  • XTPShellListCtrlView.h


Toolkit Pro: CXTPShellListView Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPShellListView Class Reference

CXTPShellListView is a multiple inheritance class derived from CXTPListView and CXTPShellPidl. More...

Public Member Functions

CXTPShellListView ()
Constructs a CXTPShellListView object.
virtual ~CXTPShellListView ()
Destroys a CXTPShellListView object, handles cleanup and deallocation.

Protected Member Functions

void OnDblclk (NMHDR *pNMHDR, LRESULT *pResult)
Occurs when the user double clicks on the list control.

Detailed Description

CXTPShellListView is a multiple inheritance class derived from CXTPListView and CXTPShellPidl.

It is used to create a CXTPShellListView class object.

Member Function Documentation

◆ OnDblclk()

void OnDblclk | ( | NMHDR * | pNMHDR,
 |  | LRESULT * | pResult )
 protected

Occurs when the user double clicks on the list control.

Parameters
pNMHDR | Address of an NMHDR structure that contains the notification code and additional information. For some notification messages, this parameter points to a larger structure that has the NMHDR structure as its first member.
pResult | Pointer to an LRESULT variable in which to store the result code if the message is handled.
The documentation for this class was generated from the following file:
  • XTPShellListCtrlView.h


Toolkit Pro: CXTPShellPidl Class Reference

Classes | Public Member Functions | Static Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPShellPidl Class Reference

CXTPShellPidl is a standalone base class. More...

Inheritance diagram for CXTPShellPidl:
[legend]

Classes

class | CShellMalloc
CXTPShellPidl::CShellMalloc is a helper class that is used by CXTPShellPidl to initialize a pointer to the Shell's IMalloc interface used for allocating memory blocks. More...
class | CShellSpecialFolder
CXTPShellPidl::CShellSpecialFolder is a helper class that is used by CXTPShellPidl to initialize a pointer to an ITEMIDLIST structure of a special folder. More...

Public Member Functions

CXTPShellPidl ()
Constructs a CXTPShellPidl object.
virtual | ~CXTPShellPidl ()
Destroys a CXTPShellPidl object, handles cleanup and deallocation.
LPITEMIDLIST | IDLFromPath (LPCTSTR path)
This member function gets the fully qualified PIDL for the path string.
LPITEMIDLIST | OneUpPIDL (LPITEMIDLIST pidlPath)
This member function performs the OneUp or back function.
CString | OneUpPATH (const CString &path)
This member function gets the parent folder using PIDLs.
LPITEMIDLIST | GetLastITEM (LPITEMIDLIST pidl)
This member function walks an ITEMIDLIST and points to the last one.
LPITEMIDLIST | CopyIDList (LPITEMIDLIST pidl)
This member function copies a whole ITEMIDLIST.
LPITEMIDLIST | ConcatPidls (LPCITEMIDLIST pidl1, LPCITEMIDLIST pidl2)
This member function concatenates two PIDLs.
LPITEMIDLIST | ConcatPidls (LPMALLOC lpMalloc, LPCITEMIDLIST pidl1, LPCITEMIDLIST pidl2)
This member function concatenates two PIDLs.
LPITEMIDLIST | GetFullyQualPidl (LPSHELLFOLDER lpsf, LPITEMIDLIST lpi)
This member function gets the fully qualified PIDLs for the specified folder.
LPITEMIDLIST | DuplicateItem (LPMALLOC lpMalloc, LPITEMIDLIST lpi)
This member function copies the ITEMID.
BOOL | GetName (LPSHELLFOLDER lpsf, LPITEMIDLIST lpi, DWORD dwFlags, CString &lpFriendlyName)
This member function gets the friendly name for the folder or file.
LPITEMIDLIST | CreatePidl (LPMALLOC lpMalloc, UINT cbSize)
This member function allocates a PIDL.
UINT | GetPidlItemCount (LPCITEMIDLIST pidl)
This member function calculates the number of item IDs in an item ID list.
LPITEMIDLIST | GetNextPidlItem (LPCITEMIDLIST pidl)
This member function retrieves the next PIDL in the list.
BOOL | ShowContextMenu (HWND hwnd, LPSHELLFOLDER lpsfParent, LPITEMIDLIST lpi, LPPOINT lppt)
This member function displays a pop-up context menu if given a parent shell folder, relative item ID, and screen location.
BOOL | ShowContextMenu (HWND hwnd, LPSHELLFOLDER lpsfParent, LPCITEMIDLIST *lppi, int nCount, LPPOINT lppt)
This member function displays a pop-up context menu if given a parent shell folder, relative item ID, and screen location.
int | GetItemIcon (LPITEMIDLIST lpi, UINT uFlags) const
This member function gets the index for the current icon.
HIMAGELIST | GetSystemImageList (UINT uFlags) const
Call this member function to retrieve a string that describes the type of file specified by lpi from the Windows Shell.
ULONG | GetAttributes (LPSHELLFOLDER lpsf, LPITEMIDLIST lpi, ULONG uFlags) const
Retrieves the attributes of one or more file objects or subfolders.
HRESULT | GetSHContextMenu (LPSHELLFOLDER psfFolder, LPCITEMIDLIST *localPidl, int nCount, void **ppCM, int *pcmType)
This member function retrieves the IContextMenu, IContextMenu2 or IContextMenu3 interface.
void | ShowShellLinkIcons (BOOL bShowLinkIcons=TRUE)
Call this member function to override the shortcut link display for each item.
UINT | GetPidlCount (LPCITEMIDLIST pidl)
Calculates the number of item IDs in the list.
void | FreePidl (LPITEMIDLIST pidl)
This member function frees memory allocated for a PIDL.
LPITEMIDLIST | CopyPidlItem (LPITEMIDLIST pidl, UINT nItem)
This member function copies a single PIDL out of a list.
BOOL | ComparePidls (LPCITEMIDLIST pidl1, LPCITEMIDLIST pidl2, LPSHELLFOLDER pShellFolder=NULL)
This member function compares two PIDLs to determine if they match.

Static Public Member Functions

static int CALLBACK | TreeViewCompareProc (LPARAM lparam1, LPARAM lparam2, LPARAM lparamSort)
CXTPShellTreeCtrl callback sort function.
static int CALLBACK | ListViewCompareProc (LPARAM lparam1, LPARAM lparam2, LPARAM lparamSort)
CXTPShellListCtrl callback sort function.

Protected Member Functions

virtual void | OnShowContextMenu (int idCmd, CMINVOKECOMMANDINFO &cmi)
This method is called when an item of a context menu is executed.
virtual void | MapShellFlagsToItemAttributes (CListCtrl *pListCtrl, int iItem, DWORD dwAttributes)
This function translates shell attributes into a tree item state.
virtual void | MapShellFlagsToItemAttributes (CTreeCtrl *pTreeCtrl, HTREEITEM hItem, DWORD dwAttributes)
This function translates shell attributes into a tree item state.

Protected Attributes

ULONG | m_ulSFGAOFlags
SFGAO flags used to retrieve shell item attributes.
BOOL | m_bShowShellLinkIcons
Set to FALSE to override shortcut link display.

Detailed Description

CXTPShellPidl is a standalone base class.

This class is used by the shell tree and list controls to handle PIDL creation and management.

Member Function Documentation

◆ ComparePidls()

BOOL ComparePidls | ( | LPCITEMIDLIST | pidl1,
 |  | LPCITEMIDLIST | pidl2,
 |  | LPSHELLFOLDER | pShellFolder = NULL )

This member function compares two PIDLs to determine if they match.

Parameters
pidl1 | Pointer to an item ID list.
pidl2 | Pointer to an item ID list.
pShellFolder | Pointer to the shell folder to use for the comparison (default Desktop).
Returns
TRUE if successful, otherwise FALSE.

◆ ConcatPidls() [1/2]

LPITEMIDLIST ConcatPidls | ( | LPCITEMIDLIST | pidl1,
 |  | LPCITEMIDLIST | pidl2 )

This member function concatenates two PIDLs.

Parameters
pidl1 | Pointer to an item ID list.
pidl2 | Pointer to an item ID list.
Returns
A pointer to an item ID list.

◆ ConcatPidls() [2/2]

LPITEMIDLIST ConcatPidls | ( | LPMALLOC | lpMalloc,
 |  | LPCITEMIDLIST | pidl1,
 |  | LPCITEMIDLIST | pidl2 )

This member function concatenates two PIDLs.

Parameters
lpMalloc | Pointer to the shell's IMalloc interface.
pidl1 | Pointer to an item ID list.
pidl2 | Pointer to an item ID list.
Returns
A pointer to an item ID list.

◆ CopyIDList()

LPITEMIDLIST CopyIDList ( LPITEMIDLIST pidl )

This member function copies a whole ITEMIDLIST.

Remember to Free() the old one if it is no longer needed.

Parameters
pidl Pointer to an ITEMIDLIST.
Returns
A new pointer to a copy of the PIDL.

◆ CopyPidlItem()

LPITEMIDLIST CopyPidlItem | ( | LPITEMIDLIST | pidl,
 |  | UINT | nItem )

This member function copies a single PIDL out of a list.

Remember to Free() the old one if it is no longer needed.

Parameters
pidl | Pointer to an ITEMIDLIST.
nItem | PIDL in the list to copy.
Returns
A new pointer to a copy of the PIDL with the single item.

◆ CreatePidl()

LPITEMIDLIST CreatePidl | ( | LPMALLOC | lpMalloc,
 |  | UINT | cbSize )

This member function allocates a PIDL.

Parameters
lpMalloc | Pointer to the shell's IMalloc interface.
cbSize | Initial size of the PIDL.
Returns
A pointer to an item ID list.

◆ DuplicateItem()

LPITEMIDLIST DuplicateItem | ( | LPMALLOC | lpMalloc,
 |  | LPITEMIDLIST | lpi )

This member function copies the ITEMID.

Parameters
lpMalloc | Pointer to the shell's IMalloc interface.
lpi | Pointer to the item ID that is to be copied.
Returns
A pointer to an item ID list.

◆ FreePidl()

void FreePidl ( LPITEMIDLIST pidl )

This member function frees memory allocated for a PIDL.

Parameters
pidl Pointer to an item ID list.

◆ GetAttributes()

ULONG GetAttributes | ( | LPSHELLFOLDER | lpsf,
 |  | LPITEMIDLIST | lpi,
 |  | ULONG | uFlags ) const

Retrieves the attributes of one or more file objects or subfolders.

Parameters
lpsf | Pointer to the parent shell folder.
lpi | Fully qualified item ID list for the current item.
uFlags | Single ULONG value that contains the attributes that the caller is requesting.
Returns
Requested attributes that are common to all of the specified objects.

◆ GetFullyQualPidl()

LPITEMIDLIST GetFullyQualPidl | ( | LPSHELLFOLDER | lpsf,
 |  | LPITEMIDLIST | lpi )

This member function gets the fully qualified PIDLs for the specified folder.

Parameters
lpsf | Pointer to the parent shell folder.
lpi | Pointer to the item ID that is relative to 'lpsf'.
Returns
A pointer to an item ID list.

◆ GetItemIcon()

int GetItemIcon | ( | LPITEMIDLIST | lpi,
 |  | UINT | uFlags ) const

This member function gets the index for the current icon.

The index is the index into the system image list.

Parameters
lpi | Fully qualified item ID list for the current item.
uFlags | Flags that specify what the image list retrieves. Can be a combination of the following values:

SHGFI_SMALLICON: Return the index of small icon from the system image list. SHGFI_LARGEICON: Return the index of large icon from the system image list. SHGFI_OPENICON: Return the index of selected icon from the system image list.

Returns
An icon index for the current item.

◆ GetLastITEM()

LPITEMIDLIST GetLastITEM ( LPITEMIDLIST pidl )

This member function walks an ITEMIDLIST and points to the last one.

Parameters
pidl PIDL list.
Returns
A pointer to the last IDL in the list.

◆ GetName()

BOOL GetName | ( | LPSHELLFOLDER | lpsf,
 |  | LPITEMIDLIST | lpi,
 |  | DWORD | dwFlags,
 |  | CString & | lpFriendlyName )

This member function gets the friendly name for the folder or file.

Parameters
lpsf | Pointer to the parent shell folder.
lpi | Pointer to the item ID that is relative to 'lpsf'.
dwFlags | Flags to determine which value to return. See SHGNO for more details.
lpFriendlyName | Buffer to receive the friendly name of the folder.
Returns
TRUE if successful, otherwise FALSE.

◆ GetNextPidlItem()

LPITEMIDLIST GetNextPidlItem ( LPCITEMIDLIST pidl )

This member function retrieves the next PIDL in the list.

Parameters
pidl Pointer to an item ID list.
Returns
A pointer to the next PIDL item in the list.

◆ GetPidlCount()

UINT GetPidlCount ( LPCITEMIDLIST pidl )

Calculates the number of item IDs in the list.

Parameters
pidl Pointer to an item ID list.
Returns
The number of item IDs in the list.

◆ GetPidlItemCount()

UINT GetPidlItemCount ( LPCITEMIDLIST pidl )

This member function calculates the number of item IDs in an item ID list.

Parameters
pidl Pointer to an item ID list.
Returns
The number of item IDs in the list.

◆ GetSHContextMenu()

HRESULT GetSHContextMenu | ( | LPSHELLFOLDER | psfFolder,
 |  | LPCITEMIDLIST * | localPidl,
 |  | int | nCount,
 |  | void ** | ppCM,
 |  | int * | pcmType )

This member function retrieves the IContextMenu, IContextMenu2 or IContextMenu3 interface.

Parameters
psfFolder | A pointer to a valid IShellFolder data type.
localPidl | A pointer to a valid _ITEMIDLIST structure.
nCount | Number of items in the context menu.
ppCM | Long pointer to a CONTEXTMENU struct.
pcmType | A pointer to a valid int data type that represents the version number of the context menu.
Returns
A HRESULT value.

◆ GetSystemImageList()

HIMAGELIST GetSystemImageList ( UINT uFlags ) const

Call this member function to retrieve a string that describes the type of file specified by lpi from the Windows Shell.

Parameters
uFlags Flags that specify what the image list retrieves. Can be a combination of the following values:

SHGFI_SMALLICON: Return the handle to the system image list that contains small icon images. SHGFI_LARGEICON: Return the handle to the system image list that contains large icon images.

Returns
A handle to the system image list that contains the specified icon images.

◆ IDLFromPath()

LPITEMIDLIST IDLFromPath ( LPCTSTR path )

This member function gets the fully qualified PIDL for the path string.

Parameters
path File system path string.
Returns
A pointer to an item ID list if successful, otherwise NULL.

◆ ListViewCompareProc()

static int CALLBACK ListViewCompareProc | ( | LPARAM | lparam1,
 |  | LPARAM | lparam2,
 |  | LPARAM | lparamSort )
 static

CXTPShellListCtrl callback sort function.

Parameters
lparam1 | Corresponds to the lParam member of the LV_ITEM structure for the two items being compared.
lparam2 | Corresponds to the lParam member of the LV_ITEM structure for the two items being compared.
lparamSort | Corresponds to the lParam member of LV_SORTCB.

This member function is a callback function used by CXTPShellListCtrl and CXTPShellListView, and is called during a sort operation each time the relative order of two list items needs to be compared.

Returns
A negative value if the first item should precede the second, a positive value if the first item should follow the second, or zero if the two items are equivalent.

◆ MapShellFlagsToItemAttributes() [1/2]

virtual void MapShellFlagsToItemAttributes | ( | CListCtrl * | pListCtrl,
 |  | int | iItem,
 |  | DWORD | dwAttributes )
 protectedvirtual

This function translates shell attributes into a tree item state.

Parameters
pListCtrl | List Control that owns an item.
iItem | Index to identify the item, passed verbatim to SetItemState().
dwAttributes | Shell attributes to translate.

◆ MapShellFlagsToItemAttributes() [2/2]

virtual void MapShellFlagsToItemAttributes | ( | CTreeCtrl * | pTreeCtrl,
 |  | HTREEITEM | hItem,
 |  | DWORD | dwAttributes )
 protectedvirtual

This function translates shell attributes into a tree item state.

Parameters
pTreeCtrl | Tree Control that owns an item.
hItem | Handle to identify the item, passed verbatim to SetItemState().
dwAttributes | Shell attributes to translate.

◆ OneUpPATH()

CString OneUpPATH ( const CString & path )

This member function gets the parent folder using PIDLs.

Parameters
path Path string.
Returns
A path string to the parent.

◆ OneUpPIDL()

LPITEMIDLIST OneUpPIDL ( LPITEMIDLIST pidlPath )

This member function performs the OneUp or back function.

Parameters
pidlPath Fully qualified PIDL.
Returns
A fully qualified parent PIDL.

◆ OnShowContextMenu()

virtual void OnShowContextMenu | ( | int | idCmd,
 |  | CMINVOKECOMMANDINFO & | cmi )
 protectedvirtual

This method is called when an item of a context menu is executed.

Parameters
idCmd | Identifier of the item that was executed.
cmi | A CMINVOKECOMMANDINFO structure reference containing additional information about the item that was executed.

◆ ShowContextMenu() [1/2]

BOOL ShowContextMenu | ( | HWND | hwnd,
 |  | LPSHELLFOLDER | lpsfParent,
 |  | LPCITEMIDLIST * | lppi,
 |  | int | nCount,
 |  | LPPOINT | lppt )

This member function displays a pop-up context menu if given a parent shell folder, relative item ID, and screen location.

Parameters
hwnd | Context menu owner.
lpsfParent | Pointer to the parent shell folder.
lppi | Pointer to the item ID that is relative to 'lpsfParent'.
nCount | Number of PIDLs.
lppt | Screen location of where to pop-up the menu.
Returns
TRUE if successful, otherwise FALSE.

◆ ShowContextMenu() [2/2]

BOOL ShowContextMenu | ( | HWND | hwnd,
 |  | LPSHELLFOLDER | lpsfParent,
 |  | LPITEMIDLIST | lpi,
 |  | LPPOINT | lppt )

This member function displays a pop-up context menu if given a parent shell folder, relative item ID, and screen location.

Parameters
hwnd | Context menu owner.
lpsfParent | Pointer to the parent shell folder.
lpi | Pointer to the item ID that is relative to 'lpsfParent'.
lppt | Screen location of where to pop-up the menu.
Returns
TRUE if successful, otherwise FALSE.

◆ ShowShellLinkIcons()

void ShowShellLinkIcons ( BOOL bShowLinkIcons = TRUE )

Call this member function to override the shortcut link display for each item.

Parameters
bShowLinkIcons TRUE to enable shortcut link display, FALSE to disable.

◆ TreeViewCompareProc()

static int CALLBACK TreeViewCompareProc | ( | LPARAM | lparam1,
 |  | LPARAM | lparam2,
 |  | LPARAM | lparamSort )
 static

CXTPShellTreeCtrl callback sort function.

Parameters
lparam1 | Corresponds to the lParam member of the TV_ITEM structure for the two items being compared.
lparam2 | Corresponds to the lParam member of the TV_ITEM structure for the two items being compared.
lparamSort | Corresponds to the lParam member of TV_SORTCB.

This member function is a callback function used by CXTPShellTreeCtrl and CXTPShellTreeView, and is called during a sort operation each time the relative order of two list items needs to be compared.

Returns
A negative value if the first item should precede the second, a positive value if the first item should follow the second, or zero if the two items are equivalent.
The documentation for this class was generated from the following file:
  • XTPShellPidl.h


Toolkit Pro: CXTPShellPidl::CShellMalloc Class Reference

  • CXTPShellPidl
  • CShellMalloc
Public Member Functions | Protected Attributes | List of all members
CXTPShellPidl::CShellMalloc Class Reference

CXTPShellPidl::CShellMalloc is a helper class that is used by CXTPShellPidl to initialize a pointer to the Shell's IMalloc interface used for allocating memory blocks. More...

Public Member Functions

CShellMalloc ()
Constructs a CXTPShellPidl::CShellMalloc object and initializes a pointer to the Shell's IMalloc interface.
virtual | ~CShellMalloc ()
Destroys a CXTPShellPidl::CShellMalloc object, handles cleanup and deallocation.
void * | Alloc (DWORD nBytes)
Call this member function to allocate a block of memory.
void | Free (void *lpMem)
Call this member function to free a block of previously allocated memory.
operator LPMALLOC ()
Retrieves a pointer to Shell's IMalloc interface for this object.

Protected Attributes

LPMALLOC m_lpMalloc
Pointer to Shell's IMalloc interface for this object.

Detailed Description

CXTPShellPidl::CShellMalloc is a helper class that is used by CXTPShellPidl to initialize a pointer to the Shell's IMalloc interface used for allocating memory blocks.

Member Function Documentation

◆ Alloc()

void * Alloc ( DWORD nBytes )
inline

Call this member function to allocate a block of memory.

Parameters
nBytes Size, in bytes, of the memory block to be allocated.
Returns
If successful, then Alloc returns a pointer to the allocated memory block. If insufficient memory is available, then Alloc returns NULL.

◆ Free()

void Free ( void * lpMem )
inline

Call this member function to free a block of previously allocated memory.

Parameters
lpMem Pointer to the memory block to be freed.

◆ operator LPMALLOC()

operator LPMALLOC ( )
inline

Retrieves a pointer to Shell's IMalloc interface for this object.

Returns
A pointer to Shell's IMalloc interface for this object.
The documentation for this class was generated from the following file:
  • XTPShellPidl.h


Toolkit Pro: CXTPShellPidl::CShellSpecialFolder Class Reference

  • CXTPShellPidl
  • CShellSpecialFolder
Public Member Functions | Protected Attributes | List of all members
CXTPShellPidl::CShellSpecialFolder Class Reference

CXTPShellPidl::CShellSpecialFolder is a helper class that is used by CXTPShellPidl to initialize a pointer to an ITEMIDLIST structure of a special folder. More...

Public Member Functions

CShellSpecialFolder (int nFolder=CSIDL_DESKTOP)
Constructs a CXTPShellPidl::CShellSpecialFolder object and initializes a pointer to the ITEMIDLIST structure of the special folder specified by nFolder.
virtual ~CShellSpecialFolder ()
Destroys a CXTPShellPidl::CShellSpecialFolder object, handles cleanup and deallocation.
operator LPSHELLFOLDER ()
Retrieves a pointer to the interface for the desktop folder, which is the root of the Shell's namespace.

Protected Attributes

LPSHELLFOLDER m_lpFolder
Pointer to the interface for the desktop folder.

Detailed Description

CXTPShellPidl::CShellSpecialFolder is a helper class that is used by CXTPShellPidl to initialize a pointer to an ITEMIDLIST structure of a special folder.

Constructor & Destructor Documentation

◆ CShellSpecialFolder()

CShellSpecialFolder ( int nFolder = CSIDL_DESKTOP )

Constructs a CXTPShellPidl::CShellSpecialFolder object and initializes a pointer to the ITEMIDLIST structure of the special folder specified by nFolder.

Parameters
nFolder A value that identifies the folder of interest. See CSIDL in MSDN documentation for a list of constants that represent special folder locations.

Member Function Documentation

◆ operator LPSHELLFOLDER()

operator LPSHELLFOLDER ( )
inline

Retrieves a pointer to the interface for the desktop folder, which is the root of the Shell's namespace.

Returns
A pointer to the interface for the desktop folder.
The documentation for this class was generated from the following file:
  • XTPShellPidl.h


Toolkit Pro: CXTPShellSettings Class Reference

Public Member Functions | Public Attributes | List of all members
CXTPShellSettings Class Reference

CXTPShellSettings is a SHELLFLAGSTATE struct derived class. More...

Public Member Functions

CXTPShellSettings ()
Constructs a CXTPShellSettings object.
~CXTPShellSettings ()
Destroys a CXTPShellSettings object, handles cleanup and deallocation.
bool | ShowAllFiles ()
This member function checks whether or not the Show All Files option is enabled.
bool | ShowExtensions ()
This member function checks whether or not the Hide File Extensions for Known File Types option is enabled.
bool | NoConfirmRecycle ()
This member function checks to see if the Display Delete Confirmation Dialog box in the Recycle Bin is enabled.
bool | ShowSysFiles ()
This member function checks whether or not the Do Not Show Hidden Files option is selected.
bool | ShowCompColor ()
This member function checks whether or not the Display Compressed Files and Folders with Alternate Color option is enabled.
bool | DoubleClickOpen ()
This member function checks whether or not the Double-Click to Open an Item option is enabled.
bool | HTMLDesktop ()
This member function checks whether or not the Active Desktop - View as Web Page option is enabled.
bool | Win95Classic ()
This member function checks whether or not the Classic Style option is enabled.
bool | AllowUpperCase ()
This member function checks whether or not the Allow All Uppercase Names option is enabled.
bool | ShowAttributes ()
This member function checks whether or not the Show File Attributes in Detail View option is enabled.
bool | ShowMapNetworkDrive ()
This member function checks whether or not the Show Map Network Drive Button in Toolbar option is enabled.
bool | ShowInfoTips ()
This member function checks whether or not the Show Info Tips for Items in Folders & Desktop option is enabled.
void | RefreshSettings ()
Call this member function to update the SHELLFLAGSTATE values for this object.

Public Attributes

COLORREF | m_crCompColor
An RGB color value that represents the system alternate compressed color.
COLORREF | m_crEncrColor
An RGB color value that represents the system alternate encrypted color.

Detailed Description

CXTPShellSettings is a SHELLFLAGSTATE struct derived class.

CXTPShellSettings extends the SHELLFLAGSTATE struct for easy access to the shell flag state settings.

Member Function Documentation

◆ AllowUpperCase()

bool AllowUpperCase ( )

This member function checks whether or not the Allow All Uppercase Names option is enabled.

Returns
true if enabled, otherwise false.

◆ DoubleClickOpen()

bool DoubleClickOpen ( )

This member function checks whether or not the Double-Click to Open an Item option is enabled.

Returns
true if enabled, otherwise false.

◆ HTMLDesktop()

bool HTMLDesktop ( )

This member function checks whether or not the Active Desktop - View as Web Page option is enabled.

Returns
true if enabled, otherwise false.

◆ NoConfirmRecycle()

bool NoConfirmRecycle ( )

This member function checks to see if the Display Delete Confirmation Dialog box in the Recycle Bin is enabled.

Returns
true if enabled, otherwise false.

◆ ShowAllFiles()

bool ShowAllFiles ( )

This member function checks whether or not the Show All Files option is enabled.

Returns
true if enabled, otherwise false.

◆ ShowAttributes()

bool ShowAttributes ( )

This member function checks whether or not the Show File Attributes in Detail View option is enabled.

Returns
true if enabled, otherwise false.

◆ ShowCompColor()

bool ShowCompColor ( )

This member function checks whether or not the Display Compressed Files and Folders with Alternate Color option is enabled.

Returns
true if enabled, otherwise false.

◆ ShowExtensions()

bool ShowExtensions ( )

This member function checks whether or not the Hide File Extensions for Known File Types option is enabled.

Returns
true if enabled, otherwise false.

◆ ShowInfoTips()

bool ShowInfoTips ( )

This member function checks whether or not the Show Info Tips for Items in Folders & Desktop option is enabled.

Returns
true if enabled, otherwise false.

◆ ShowMapNetworkDrive()

bool ShowMapNetworkDrive ( )

This member function checks whether or not the Show Map Network Drive Button in Toolbar option is enabled.

Returns
true if enabled, otherwise false.

◆ ShowSysFiles()

bool ShowSysFiles ( )

This member function checks whether or not the Do Not Show Hidden Files option is selected.

Returns
true if selected, otherwise false.

◆ Win95Classic()

bool Win95Classic ( )

This member function checks whether or not the Classic Style option is enabled.

Returns
true if enabled, otherwise false.
The documentation for this class was generated from the following file:
  • XTPShellSettings.h


Toolkit Pro: CXTPShellTreeBase Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPShellTreeBase Class Reference

CXTPShellTreeBase is a multiple inheritance class derived from CXTPTreeView and CXTPShellPidl. More...

Inheritance diagram for CXTPShellTreeBase:
[legend]

Public Member Functions

CXTPShellTreeBase ()
Constructs a CXTPShellTreeBase object.
virtual | ~CXTPShellTreeBase ()
Destroys a CXTPShellTreeBase object, handles cleanup and deallocation.
void | EnableContextMenu (BOOL bEnable)
Call this member function to enable/disable the display of the shell context menu on right item click.
void | SetRootFolder (int nRootFolder=CSIDL_DESKTOP)
Call this member to set the root CSIDL folder.
void | ShowFiles (BOOL bShowFiles=TRUE)
Call this member to show all files instead of only folders.
void | SetEnumFlags (UINT uFlags)
Call this member function to determine the type of items included in the shell enumeration.
virtual BOOL | InitSystemImageLists ()
This member function obtains a handle to the system image list and attaches it to the tree control.
virtual void | PopulateTreeView ()
This member function adds items to the tree view.
virtual void | OnFolderExpanding (NM_TREEVIEW *pNMTreeView)
This member function responds to a TVN_ITEMEXPANDING message in order to fill up sub-directories.
virtual HTREEITEM | GetContextMenu ()
This member function displays the shell context menu for the selected item or folder.
virtual BOOL | OnFolderSelected (NM_TREEVIEW *pNMTreeView, CString &strFolderPath)
This member function responds to a TVN_SELCHANGED message to retrieve the specified folder path.
virtual BOOL | GetSelectedFolderPath (CString &strFolderPath)
This member function retrieves the path of the currently selected tree item.
virtual BOOL | FindTreeItem (HTREEITEM hItem, XTP_LVITEMDATA *lplvid, BOOL bRecursively=TRUE)
This member function recursively searches the tree control beginning at 'hItem' to find the item specified by 'lplvid'.
virtual void | AssociateCombo (CWnd *pWnd)
This member function is used to associate a CComboBox object with the control.
virtual void | InitTreeNode (HTREEITEM hItem, XTP_TVITEMDATA *lptvid)
This member function is called to initialize a branch of the shell tree.
virtual HTREEITEM | SearchTree (HTREEITEM hItem, LPCITEMIDLIST pABSPidl)
This member function searches the tree for a specified folder.
virtual BOOL | TunnelTree (CString strFindPath)
This member function will "tunnel" the tree to find the specified path.
virtual BOOL | GetFolderItemPath (HTREEITEM hItem, CString &strFolderPath)
This member function retrieves the path of a folder item, which does not have to be selected.
virtual void | PopulateTree (LPCTSTR lpszPath)
This member function populates a tree based upon a path.
virtual BOOL | InitializeTree (DWORD dwStyle=TVS_HASBUTTONS|TVS_HASLINES|TVS_LINESATROOT)
Call this member function to initialize the shell tree control prior to calling PopulateTree.
virtual void | BeginDrag (NM_TREEVIEW *pNMTreeView)
Used by the shell list control to handle a drag event.
virtual HTREEITEM | InsertDesktopItem (int nFolder=CSIDL_DESKTOP)
This member function is called to insert the desktop as the root item in the shell tree control.
virtual void | SelectionChanged (HTREEITEM hItem, CString strFolderPath)
Called after a user makes a new tree selection.
void | SetExplorerStyle ()
Call this method to enable auto-hidden triangles for Windows Vista and Windows 7.
- Public Member Functions inherited from CXTPTreeBase
virtual HTREEITEM | GetNextItem (HTREEITEM hItem) const
This member function will retrieve the tree view item that has the specified relationship, indicated by the 'nCode' parameter, to 'hItem'.
virtual HTREEITEM | GetNextItem (HTREEITEM hItem, UINT nCode) const
This member function will retrieve the tree view item that has the specified relationship, indicated by the 'nCode' parameter, to 'hItem'.
virtual HTREEITEM | GetPrevItem (HTREEITEM hItem) const
This member function gets the previous item as if the outline was completely expanded.
virtual HTREEITEM | GetLastItem (HTREEITEM hItem) const
This member function retrieves the last item in the branch.
virtual HTREEITEM | FindItem (LPCTSTR lpszSearch, BOOL bCaseSensitive=FALSE, BOOL bDownDir=TRUE, BOOL bWholeWord=FALSE, HTREEITEM hItem=NULL)
This member function searches the entire tree for an item label that contains the search string.
virtual HTREEITEM | FindItemExact (LPCTSTR lpszSearch, BOOL bCaseSensitive=FALSE, BOOL bDownDir=TRUE, HTREEITEM hItem=NULL)
This member function searches the entire tree for an item label that contains exactly the same text as search string.
virtual HTREEITEM | FindItemInBranch (LPCTSTR lpszSearch, BOOL bCaseSensitive, BOOL bWholeWord, HTREEITEM htiItem)
This member function searches the entire branch specified by 'htiItem' for an item label that contains the search string.
virtual void | SetItemFont (HTREEITEM hItem, LOGFONT &logfont)
This member function sets the font for the reference tree item.
virtual BOOL | GetItemFont (HTREEITEM hItem, LOGFONT *plogfont)
This member function retrieves the current LOGFONT font used by the tree item.
virtual void | SetItemBold (HTREEITEM hItem, BOOL bBold=TRUE)
This member function sets the reference tree item font to bold.
virtual BOOL | GetItemBold (HTREEITEM hItem)
This member function checks whether or not a tree item has a bold font.
virtual void | SetItemColor (HTREEITEM hItem, COLORREF color)
This member function sets the tree item text color.
virtual void | SetItemBackColor (HTREEITEM hItem, COLORREF color)
This member function sets the tree item background color.
virtual COLORREF | GetItemColor (HTREEITEM hItem)
This member function returns the RGB value for the specified tree item text color, or (COLORREF)-1 if the color was not set.
virtual COLORREF | GetItemBackColor (HTREEITEM hItem)
This member function returns the RGB value for the specified tree item background color, or (COLORREF)-1 if the color was not set.
virtual BOOL | EnableMultiSelect (BOOL bMultiSelect=TRUE)
This member function enables/disables multi-selection for the tree control.
virtual HTREEITEM | GetPrevSelectedItem (HTREEITEM hItem) const
This member function retrieves the previously selected tree item in a multi-selection tree control.
virtual HTREEITEM | GetNextSelectedItem (HTREEITEM hItem) const
This member function retrieves the next selected item in a multi-selection tree control.
virtual HTREEITEM | GetFirstSelectedItem () const
This member function retrieves the first selected item in a multi-selection tree control.
virtual UINT | GetSelectedCount () const
This member function retrieves the number of tree items that are selected.
BOOL | SetItemState (HTREEITEM hItem, UINT nState, UINT nStateMask)
This member function is a replacement for the base class function of the same name, to handle TVIS_FOCUSED in a multi-selection tree control.
UINT | GetItemState (HTREEITEM hItem, UINT nStateMask) const
This member function is a replacement for the base class function of the same name, to handle TVIS_FOCUSED in a multi-selection tree control.
BOOL | SelectItem (HTREEITEM hItem)
This member function is a replacement for the base class function of the same name, to handle TVIS_FOCUSED in a multi-select tree control.
HTREEITEM | GetFocusedItem () const
This member function retrieves the handle to the tree item that currently has focus.
BOOL | FocusItem (HTREEITEM hItem)
This member function will set the focus for the tree item specified by 'hItem'.
virtual void | SelectAll (BOOL bSelect=TRUE, HTREEITEM htItem=NULL)
Call this member function to clear, or select, all of the visible items in the tree control.
virtual void | SelectItems (HTREEITEM hItemFrom, HTREEITEM hItemTo, BOOL bOnly=TRUE)
This member function selects items from 'hItemFrom' to 'hItemTo' in a multi-selection tree control.
virtual BOOL | IsSelected (HTREEITEM hItem) const
This member function checks whether or not the specified item is selected.
BOOL | SelectChildren (HTREEITEM hParent, BOOL bSelect=TRUE, BOOL bRecurse=TRUE)
This member function will cause all of the children of the specified tree item to be selected or deselected.
void | GetSelectedList (CTypedPtrList< CPtrList, HTREEITEM > &list) const
This member function will retrieve a reference to the typed pointer array that contains the items selected in the tree control.
BOOL | IsMultiSelect () const
This member function checks to see if the tree control is a multi-selection tree.
BOOL | IsExplorerTheme () const
This member function checks to see if the tree control has Explorer theme applied.
void | SetExplorerTheme (BOOL bSet)
This member function sets the Explorer theme applied (Vista+).
BOOL | SetBandingHit (BOOL bLabel)
This member function sets the banding mode for a multi-selection tree control.
BOOL | IsDefaultItemDrawingEnabled () const
This member function checks if the tree control uses default (system specific) item drawing method.
void | EnableDefaultItemDrawing (BOOL bEnable=TRUE)
Enables/disables default item drawing method.
int | SetIconIndent (int iconIndent)
Sets the indent between the icon/text/expander.
int | GetIconIndent () const
Gets the current indent between the icon/text/expander.
- Public Member Functions inherited from CXTPShellPidl
CXTPShellPidl ()
Constructs a CXTPShellPidl object.
virtual | ~CXTPShellPidl ()
Destroys a CXTPShellPidl object, handles cleanup and deallocation.
LPITEMIDLIST | IDLFromPath (LPCTSTR path)
This member function gets the fully qualified PIDL for the path string.
LPITEMIDLIST | OneUpPIDL (LPITEMIDLIST pidlPath)
This member function performs the OneUp or back function.
CString | OneUpPATH (const CString &path)
This member function gets the parent folder using PIDLs.
LPITEMIDLIST | GetLastITEM (LPITEMIDLIST pidl)
This member function walks an ITEMIDLIST and points to the last one.
LPITEMIDLIST | CopyIDList (LPITEMIDLIST pidl)
This member function copies a whole ITEMIDLIST.
LPITEMIDLIST | ConcatPidls (LPCITEMIDLIST pidl1, LPCITEMIDLIST pidl2)
This member function concatenates two PIDLs.
LPITEMIDLIST | ConcatPidls (LPMALLOC lpMalloc, LPCITEMIDLIST pidl1, LPCITEMIDLIST pidl2)
This member function concatenates two PIDLs.
LPITEMIDLIST | GetFullyQualPidl (LPSHELLFOLDER lpsf, LPITEMIDLIST lpi)
This member function gets the fully qualified PIDLs for the specified folder.
LPITEMIDLIST | DuplicateItem (LPMALLOC lpMalloc, LPITEMIDLIST lpi)
This member function copies the ITEMID.
BOOL | GetName (LPSHELLFOLDER lpsf, LPITEMIDLIST lpi, DWORD dwFlags, CString &lpFriendlyName)
This member function gets the friendly name for the folder or file.
LPITEMIDLIST | CreatePidl (LPMALLOC lpMalloc, UINT cbSize)
This member function allocates a PIDL.
UINT | GetPidlItemCount (LPCITEMIDLIST pidl)
This member function calculates the number of item IDs in an item ID list.
LPITEMIDLIST | GetNextPidlItem (LPCITEMIDLIST pidl)
This member function retrieves the next PIDL in the list.
BOOL | ShowContextMenu (HWND hwnd, LPSHELLFOLDER lpsfParent, LPITEMIDLIST lpi, LPPOINT lppt)
This member function displays a pop-up context menu if given a parent shell folder, relative item ID, and screen location.
BOOL | ShowContextMenu (HWND hwnd, LPSHELLFOLDER lpsfParent, LPCITEMIDLIST *lppi, int nCount, LPPOINT lppt)
This member function displays a pop-up context menu if given a parent shell folder, relative item ID, and screen location.
int | GetItemIcon (LPITEMIDLIST lpi, UINT uFlags) const
This member function gets the index for the current icon.
HIMAGELIST | GetSystemImageList (UINT uFlags) const
Call this member function to retrieve a string that describes the type of file specified by lpi from the Windows Shell.
ULONG | GetAttributes (LPSHELLFOLDER lpsf, LPITEMIDLIST lpi, ULONG uFlags) const
Retrieves the attributes of one or more file objects or subfolders.
HRESULT | GetSHContextMenu (LPSHELLFOLDER psfFolder, LPCITEMIDLIST *localPidl, int nCount, void **ppCM, int *pcmType)
This member function retrieves the IContextMenu, IContextMenu2 or IContextMenu3 interface.
void | ShowShellLinkIcons (BOOL bShowLinkIcons=TRUE)
Call this member function to override the shortcut link display for each item.
UINT | GetPidlCount (LPCITEMIDLIST pidl)
Calculates the number of item IDs in the list.
void | FreePidl (LPITEMIDLIST pidl)
This member function frees memory allocated for a PIDL.
LPITEMIDLIST | CopyPidlItem (LPITEMIDLIST pidl, UINT nItem)
This member function copies a single PIDL out of a list.
BOOL | ComparePidls (LPCITEMIDLIST pidl1, LPCITEMIDLIST pidl2, LPSHELLFOLDER pShellFolder=NULL)
This member function compares two PIDLs to determine if they match.

Protected Member Functions

virtual BOOL | InitTreeViewItems (LPSHELLFOLDER lpsf, LPITEMIDLIST lpifq, HTREEITEM hParent)
This member function fills a branch of the TreeView control.
virtual void | GetNormalAndSelectedIcons (LPITEMIDLIST lpifq, LPTV_ITEM lptvitem)
This member function gets the index for the normal and selected icons for the current item.
void | SetAttributes (HTREEITEM hItem, DWORD dwAttributes)
This member function sets the shell attribute flags for the specified tree item.
CString | PathFindNextComponent (const CString &pszPath)
Parses a path for the next path component.
virtual void | SortChildren (HTREEITEM hParent)
Sorts items in the control using the provided callback function.
- Protected Member Functions inherited from CXTPTreeBase
CXTPTreeBase ()
Protected constructor used by dynamic creation.
virtual | ~CXTPTreeBase ()
Destroys a CXTPTreeBase object, handles cleanup and deallocation.
virtual bool | Init ()
This member function is called by the CXTPTreeBase class to perform initialization when the window is created or sub-classed.
virtual LRESULT | SendNotify (LPNMHDR pNMHDR)
Sends a WM_NOTIFY message to the tree control owner window.
virtual void | SelectAllIgnore (BOOL bSelect, HTREEITEM hIgnore)
Toggles selection for all items in a multi-selection tree control.
virtual BOOL | OnButtonDown (BOOL bLeft, UINT nFlags, CPoint point)
Called when a mouse button click event occurs.
virtual void | DoPreSelection (HTREEITEM hItem, BOOL bLeft, UINT nFlags)
Called during item selection in a multi-selection tree control.
virtual void | DoAction (HTREEITEM hItem, BOOL bLeft, UINT nFlags, CPoint point)
Called during item selection in a multi-selection tree control.
virtual void | DoBanding (UINT nFlags, CPoint point)
Draws a selection rectangle during item selection.
virtual void | UpdateSelectionForRect (LPCRECT pRect, UINT nFlags, CTypedPtrList< CPtrList, HTREEITEM > &list)
Updates tree item selection.
virtual BOOL | IsFindValid (HTREEITEM hti)
Member override to determine if a tree item is valid.
virtual void | DoPaint (CDC &dc, BOOL bInternal=TRUE)
Called to render the tree control.
virtual COLORREF | GetTreeBackColor () const
Retrieves the tree control's background color.
virtual COLORREF | GetTreeTextColor () const
Retrieves the tree control's text color.
virtual CRect | GetItemIconRect (HTREEITEM hItem) const
Computes an item icon rectangle.
virtual CRect | GetItemStateIconRect (HTREEITEM hItem, const CRect &rcIcon) const
Computes an item state icon rectangle.
virtual CRect | GetItemExpanderRect (HTREEITEM hItem, CDC *pDC, const CRect &rcIcon, const CRect &rcStateIcon) const
Computes an item expander rectangle.
void | DrawItem (CDC *pDC, HTREEITEM hItem, const COLORREF crBack)
Custom drawing of an item along with its icon and lines if necessary.
void | DrawDarkThemeExpander (CDC *pDC, COLORREF crBack, CRect rcItem, CRect rcExpander, int nPart, int nState) const
Draws expander with explorer style when using a dark theme.
virtual COLORREF | GetItemBackColor (UINT uState, bool bTreeHasFocus, DWORD dwStyle, COLORREF crBack) const
Retrieves a tree item's background color.
virtual COLORREF | GetItemTextColor (UINT uState, bool bTreeHasFocus, DWORD dwStyle, COLORREF crText) const
Retrieves a tree item's text color.
bool | HasEditLabels () const
Determines if the tree control has edit labels.
virtual HTREEITEM | FindItemImpl (LPCTSTR lpszSearch, BOOL bCaseSensitive=FALSE, BOOL bDownDir=TRUE, BOOL bWholeWord=FALSE, HTREEITEM hItem=NULL, BOOL bExactlySameStr=FALSE)
This member function searches the entire tree for an item label that contains the search string.
virtual BOOL | IsFullRowSelectionEnabled ()
Checks if full row selection is enabled.
BOOL | SetInsertMark (HTREEITEM hItem, BOOL fAfter)
Sets the insertion mark in a tree view control.
COLORREF | GetInsertMarkColor () const
Retrieves the color used to draw the insertion mark for the tree view.
COLORREF | SetInsertMarkColor (COLORREF clrNew)
Sets the color used to draw the insertion mark for the tree view.
- Protected Member Functions inherited from CXTPShellPidl
virtual void | OnShowContextMenu (int idCmd, CMINVOKECOMMANDINFO &cmi)
This method is called when an item of a context menu is executed.
virtual void | MapShellFlagsToItemAttributes (CListCtrl *pListCtrl, int iItem, DWORD dwAttributes)
This function translates shell attributes into a tree item state.
virtual void | MapShellFlagsToItemAttributes (CTreeCtrl *pTreeCtrl, HTREEITEM hItem, DWORD dwAttributes)
This function translates shell attributes into a tree item state.

Protected Attributes

UINT | m_uFlags
Flags indicating which items to include in the enumeration.
bool | m_bTunneling
true if the tree is currently traversing.
BOOL | m_bContextMenu
TRUE to display the shell context menu on right item click.
CWnd * | m_pComboBox
CComboBox that is associated with this control.
CXTPShellSettings | m_shSettings
Contains SHELLFLAGSTATE info.
int | m_nRootFolder
Root Folder CSIDL.
BOOL | m_bShowFiles
FALSE to only show directories.
BOOL | m_bExplorerStyle
Explorer Style.
- Protected Attributes inherited from CXTPTreeBase
BOOL | m_bMultiSelect
TRUE for a multi-selection tree control.
BOOL | m_bBandLabel
TRUE to include the label when selecting tree items.
BOOL | m_bExplorerTheme
TRUE if Explorer theme is On for tree control (Windows Vista+)
HTREEITEM | m_hSelect
For shift selection.
HTREEITEM | m_htiEdit
Tree item that is currently edited.
HTREEITEM | m_htiLast
Tree item that last had the mouse over.
CColorFontMap | m_mapColorFont
Maps HTREEITEM handles with CLRFONT structures that contains the color and logfont information for the tree item.
int | m_nTheme
Self tree pointer.
BOOL | m_bDoDefaultItemDrawing
FALSE by default, which means an item will be drawn by the framework.
int | m_iconIndent
Indent between icon/text/expander.
HTREEITEM | m_hInsertMark
Tree item the insertion mark will be placed.
BOOL | m_InsertMarkAfter
Insertion mark is placed before or after.
COLORREF | m_InsertMarkColor
Insertion mark color.
- Protected Attributes inherited from CXTPShellPidl
ULONG | m_ulSFGAOFlags
SFGAO flags used to retrieve shell item attributes.
BOOL | m_bShowShellLinkIcons
Set to FALSE to override shortcut link display.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPShellPidl
static int CALLBACK | TreeViewCompareProc (LPARAM lparam1, LPARAM lparam2, LPARAM lparamSort)
CXTPShellTreeCtrl callback sort function.
static int CALLBACK | ListViewCompareProc (LPARAM lparam1, LPARAM lparam2, LPARAM lparamSort)
CXTPShellListCtrl callback sort function.
- Protected Types inherited from CXTPTreeBase
typedef CMap< void *, void *, CLRFONT, CLRFONT & > | CColorFontMap
Map for maintaining HTREEITEM to CLRFONT structure relationships.

Detailed Description

CXTPShellTreeBase is a multiple inheritance class derived from CXTPTreeView and CXTPShellPidl.

It is used to create a CXTPShellTreeBase class object.

Member Function Documentation

◆ AssociateCombo()

virtual void AssociateCombo ( CWnd * pWnd )
virtual

This member function is used to associate a CComboBox object with the control.

Whenever the path changes, the combo is updated.

Parameters
pWnd Pointer to the combobox that is associated with the tree.

◆ BeginDrag()

virtual void BeginDrag ( NM_TREEVIEW * pNMTreeView )
virtual

Used by the shell list control to handle a drag event.

Parameters
pNMTreeView Pointer to a NM_TREEVIEW structure.

◆ EnableContextMenu()

void EnableContextMenu ( BOOL bEnable )

Call this member function to enable/disable the display of the shell context menu on right item click.

Parameters
bEnable TRUE to enable the display of the shell context menu.

◆ FindTreeItem()

virtual BOOL FindTreeItem | ( | HTREEITEM | hItem,
 |  | XTP_LVITEMDATA * | lplvid,
 |  | BOOL | bRecursively = TRUE )
 virtual

This member function recursively searches the tree control beginning at 'hItem' to find the item specified by 'lplvid'.

This is typically used when the user double clicks an item in the list view.

Parameters
hItem | Handle to the tree item to search from.
lplvid | Pointer to the list view item data.
bRecursively | TRUE to recursively search.
Returns
TRUE if successful, otherwise FALSE.

◆ GetContextMenu()

virtual HTREEITEM GetContextMenu ( )
virtual

This member function displays the shell context menu for the selected item or folder.

Returns
A handle to the currently selected HTREEITEM.

◆ GetFolderItemPath()

virtual BOOL GetFolderItemPath | ( | HTREEITEM | hItem,
 |  | CString & | strFolderPath )
 virtual

This member function retrieves the path of a folder item, which does not have to be selected.

Pass a CString object that will hold the folder path.

Parameters
hItem | Tree item to get the path for.
strFolderPath | Reference to a CString object to contain the folder path.
Returns
TRUE if the path is not in the file system (e.g. MyComputer); if none is selected, it returns FALSE.

◆ GetNormalAndSelectedIcons()

virtual void GetNormalAndSelectedIcons | ( | LPITEMIDLIST | lpifq,
 |  | LPTV_ITEM | lptvitem )
 protectedvirtual

This member function gets the index for the normal and selected icons for the current item.

Parameters
lpifq | Fully qualified item ID list for the current item.
lptvitem | Pointer to the tree view item being added to the tree.

◆ GetSelectedFolderPath()

virtual BOOL GetSelectedFolderPath ( CString & strFolderPath )
virtual

This member function retrieves the path of the currently selected tree item.

Parameters
strFolderPath Address of a CString object to receive the file system path.
Returns
TRUE if successful, otherwise FALSE.

◆ InitializeTree()

virtual BOOL InitializeTree ( DWORD dwStyle = TVS_HASBUTTONS|TVS_HASLINES|TVS_LINESATROOT )
virtual

Call this member function to initialize the shell tree control prior to calling PopulateTree.

Parameters
dwStyle TVS_ style flags for tree control.
Returns
TRUE if successful, otherwise FALSE.
See also
PopulateTree()

◆ InitSystemImageLists()

virtual BOOL InitSystemImageLists ( )
virtual

This member function obtains a handle to the system image list and attaches it to the tree control.

Returns
TRUE if successful, otherwise FALSE.

◆ InitTreeNode()

virtual void InitTreeNode | ( | HTREEITEM | hItem,
 |  | XTP_TVITEMDATA * | lptvid )
 virtual

This member function is called to initialize a branch of the shell tree.

Parameters
hItem | Handle to a tree node.
lptvid | Pointer to the list view item data.

◆ InitTreeViewItems()

virtual BOOL InitTreeViewItems | ( | LPSHELLFOLDER | lpsf,
 |  | LPITEMIDLIST | lpifq,
 |  | HTREEITEM | hParent )
 protectedvirtual

This member function fills a branch of the TreeView control.

Given the shell folder, it enumerates the sub-items of this folder and adds the appropriate items to the tree.

Parameters
lpsf | Pointer to the parent shell folder.
lpifq | Fully qualified item ID list to the item having items enumerated. This is the PIDL to the item identified by the 'lpsf' parameter.
hParent | Parent tree node.
Returns
TRUE if successful, otherwise FALSE.

◆ InsertDesktopItem()

virtual HTREEITEM InsertDesktopItem ( int nFolder = CSIDL_DESKTOP )
virtual

This member function is called to insert the desktop as the root item in the shell tree control.

Parameters
nFolder Root folder CSIDL to insert.
Returns
A handle to the desktop tree item if successful, otherwise NULL.

◆ OnFolderExpanding()

virtual void OnFolderExpanding ( NM_TREEVIEW * pNMTreeView )
virtual

This member function responds to a TVN_ITEMEXPANDING message in order to fill up sub-directories.

Parameters
pNMTreeView Address of an NM_TREEVIEW struct.

◆ OnFolderSelected()

virtual BOOL OnFolderSelected | ( | NM_TREEVIEW * | pNMTreeView,
 |  | CString & | strFolderPath )
 virtual

This member function responds to a TVN_SELCHANGED message to retrieve the specified folder path.

Parameters
pNMTreeView | Address of an NM_TREEVIEW struct.
strFolderPath | Address of a CString object to receive the file system path.
Returns
TRUE if the folder path was found, otherwise FALSE.

◆ PathFindNextComponent()

CString PathFindNextComponent ( const CString & pszPath )
protected

Parses a path for the next path component.

Parameters
pszPath Pointer to a NULL-terminated string with the path. Paths are delimited by backslashes or by the NULL at the end of the path.

This member function parses a path for the next path component, not dependent on shell32.dll, and is a replacement for the Windows API PathFindNextComponent.

Returns
A pointer to a NULL-terminated string with the next path component if successful, otherwise FALSE. Example: The following example demonstrates using the XTFuncPathFindNextComponent function:
// Path to find the next part.
char buffer_1[ ] = "c:\\\\path1\\\\path2\\\\test";
char *lpStr1;
lpStr1 = buffer_1;

cout << "Search a path for the next path component "
     << "after the root " << lpStr1 << endl;
cout << "Return the next path component: \\""
     <<  XTFuncPathFindNextComponent(lpStr1) << "\\"" << endl;

cout << "\\nSearch a path for the next path component "
     << "after the root \\"c:\\\\path1\\\\path2\\"" << endl;
cout << "Return the next path component: \\""
     <<  XTFuncPathFindNextComponent("c:\\\\path1\\\\path2") << "\\"" << endl;

cout << "\\nSearch a path for the next path component "
     << "after the root \\"c:\\\\path1\\"" << endl;
cout << "Return the next path component: \\""
     <<  XTFuncPathFindNextComponent("c:\\\\path1") << "\\"" << endl;

OUTPUT:
Search a path for the next path component after the root c:\path1\path2\test
Return the next path component: "path1\\path2\\test"

Search a path for the next path component after the root "c:\\path1\\path2"
Return the next path component: "path1\\path2"

Search a path for the next path component after the root "c:\\path1"
Return the next path component: "path1"

◆ PopulateTree()

virtual void PopulateTree ( LPCTSTR lpszPath )
virtual

This member function populates a tree based upon a path.

You must call InitializeTree() before populating the tree for the first time.

Parameters
lpszPath Path to populate.
See also
InitializeTree()

◆ SearchTree()

virtual HTREEITEM SearchTree | ( | HTREEITEM | hItem,
 |  | LPCITEMIDLIST | pABSPidl )
 virtual

This member function searches the tree for a specified folder.

Parameters
hItem | Tree item to begin the search from.
pABSPidl | pidl to match.
Returns
HTREEITEM of node in tree that resulted in a match.

◆ SelectionChanged()

virtual void SelectionChanged | ( | HTREEITEM | hItem,
 |  | CString | strFolderPath )
 virtual

Called after a user makes a new tree selection.

This member function is called whenever a user makes a selection within the tree control to synchronize any shell list or shell comboboxes associated with the tree. You can override this member to provide additional functionality.

Parameters
hItem | Handle to the newly selected tree item.
strFolderPath | A NULL-terminated string representing the fully qualified path to the selected tree item.

◆ SetAttributes()

void SetAttributes | ( | HTREEITEM | hItem,
 |  | DWORD | dwAttributes )
 protected

This member function sets the shell attribute flags for the specified tree item.

Parameters
hItem | Handle to a HTREEITEM node.
dwAttributes | Flags retrieved from SHELLFOLDER::GetAttributesOf.

◆ SetEnumFlags()

void SetEnumFlags ( UINT uFlags )

Call this member function to determine the type of items included in the shell enumeration.

The default is SHCONTF_FOLDERS | SHCONTF_NONFOLDERS.

Parameters
uFlags Determines the type of items included in an enumeration. It can be one or more of the values listed in the Remarks section.

Styles to be added or removed can be combined by using the bitwise OR (|) operator. It can be one or more of the following:

SHCONTF_FOLDERS: Include items that are folders in the enumeration. SHCONTF_NONFOLDERS: Include items that are not folders in the enumeration. SHCONTF_INCLUDEHIDDEN: Include hidden items in the enumeration. SHCONTF_INIT_ON_FIRST_NEXT: IShellFolder::EnumObjects can return without validating the enumeration object. Validation can be postponed until the first call to IEnumIDList::Next. This flag is intended to be used when a user interface may be displayed prior to the first IEnumIDList::Next call. For a user interface to be presented, 'hwndOwner' must be set to a valid window handle. SHCONTF_NETPRINTERSRCH: The caller is looking for printer objects.

◆ SetRootFolder()

void SetRootFolder ( int nRootFolder = CSIDL_DESKTOP )

Call this member to set the root CSIDL folder.

Parameters
nRootFolder Root folder of tree view.

◆ ShowFiles()

void ShowFiles ( BOOL bShowFiles = TRUE )

Call this member to show all files instead of only folders.

Parameters
bShowFiles TRUE to show folder's files.

◆ SortChildren()

virtual void SortChildren ( HTREEITEM hParent )
protectedvirtual

Sorts items in the control using the provided callback function.

Parameters
hParent Parent item to sort.

◆ TunnelTree()

virtual BOOL TunnelTree ( CString strFindPath )
virtual

This member function will "tunnel" the tree to find the specified path.

This will work only when the PopulateTreeView() method is used to populate the tree.

Parameters
strFindPath Path to find.
Returns
TRUE if successful, FALSE otherwise.

Member Data Documentation

◆ m_pComboBox

CWnd* m_pComboBox
protected

CComboBox that is associated with this control.

See AssociateCombo(...).

The documentation for this class was generated from the following file:
  • XTPShellTreeBase.h


Toolkit Pro: CXTPShellTreeCtrl Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPShellTreeCtrl Class Reference

CXTPShellTreeCtrl is a multiple inheritance class derived from CXTPTreeCtrl and CXTPShellPidl. More...

Public Member Functions

CXTPShellTreeCtrl ()
Constructs a CXTPShellTreeCtrl object.
virtual | ~CXTPShellTreeCtrl ()
Destroys a CXTPShellTreeCtrl object, handles cleanup and deallocation.
virtual bool | Init ()
This member function is called by the CInitialize class to perform initialization when the window is created or sub-classed.
void | EnableAutoInit (BOOL bEnable)
Call this member function to enable/disable auto-initialization of the shell tree control.
virtual void | AssociateList (CWnd *pWnd)
Call this member function to associate a list control with the tree.
virtual void | AssociateCombo (CWnd *pWnd)
This member function is used to associate a CComboBox object with the control.

Protected Member Functions

virtual void SelectionChanged (HTREEITEM hItem, CString strFolderPath)
Called after a user makes a new tree selection.

Protected Attributes

BOOL | m_bAutoInit
TRUE if the tree control is to automatically initialize when created.
CWnd * | m_pListCtrl
Window that receives the update notification, usually a CXTPShellListCtrl.

Detailed Description

CXTPShellTreeCtrl is a multiple inheritance class derived from CXTPTreeCtrl and CXTPShellPidl.

CXTPShellTreeCtrl is used to create a tree control that displays an explorer style tree, and can be associated with a combobox and list control.

Member Function Documentation

◆ AssociateCombo()

virtual void AssociateCombo ( CWnd * pWnd )
virtual

This member function is used to associate a CComboBox object with the control.

Whenever the path changes, the combo is updated.

Parameters
pWnd Pointer to the combobox to be associated with the tree.

◆ AssociateList()

virtual void AssociateList ( CWnd * pWnd )
virtual

Call this member function to associate a list control with the tree.

Parameters
pWnd Pointer to the list control to be associated with the tree.

◆ EnableAutoInit()

void EnableAutoInit ( BOOL bEnable )

Call this member function to enable/disable auto-initialization of the shell tree control.

Parameters
bEnable TRUE to enable auto-initialization of the shell tree control.

◆ Init()

virtual bool Init ( )
virtual

This member function is called by the CInitialize class to perform initialization when the window is created or sub-classed.

Returns
TRUE if the window was successfully initialized, otherwise FALSE.

◆ SelectionChanged()

virtual void SelectionChanged | ( | HTREEITEM | hItem,
 |  | CString | strFolderPath )
 protectedvirtual

Called after a user makes a new tree selection.

This member function is called whenever a user makes a selection within the tree control to synchronize any shell list or shell comboboxes associated with the tree. You can override this member to provide additional functionality.

Parameters
hItem | Handle to the newly selected tree item.
strFolderPath | A NULL-terminated string representing the fully qualified path to the selected tree item.
The documentation for this class was generated from the following file:
  • XTPShellTreeCtrlView.h


Toolkit Pro: CXTPShellTreeView Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPShellTreeView Class Reference

CXTPShellTreeView is a multiple inheritance class derived from CXTPTreeView and CXTPShellPidl. More...

Public Member Functions

CXTPShellTreeView ()
Constructs a CXTPShellTreeView object.
virtual ~CXTPShellTreeView ()
Destroys a CXTPShellTreeView object, handles cleanup and deallocation.

Protected Member Functions

virtual void SelectionChanged (HTREEITEM hItem, CString strFolderPath)
Called after a user makes a new tree selection.

Detailed Description

CXTPShellTreeView is a multiple inheritance class derived from CXTPTreeView and CXTPShellPidl.

It is used to create a CXTPShellTreeView class object.

Member Function Documentation

◆ SelectionChanged()

virtual void SelectionChanged | ( | HTREEITEM | hItem,
 |  | CString | strFolderPath )
 protectedvirtual

Called after a user makes a new tree selection.

This member function is called whenever a user makes a selection within the tree control to synchronize any shell list or shell comboboxes associated with the tree. You can override this member to provide additional functionality.

Parameters
hItem | Handle to the newly selected tree item.
strFolderPath | A NULL-terminated string representing the fully qualified path to the selected tree item.
The documentation for this class was generated from the following file:
  • XTPShellTreeCtrlView.h


Toolkit Pro: CXTPShortcutBar Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPShortcutBar Class Reference

CXTPShortcutBar is a CWnd derived class used to implement an Outlook 2003 shortcut bar control style. More...

Public Member Functions

CXTPShortcutBar ()
Constructs a CXTPShortcutBar object.
virtual | ~CXTPShortcutBar ()
Destroys a CXTPShortcutBar object, handles cleanup and deallocation.
BOOL | Create (DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID)
Creates the CXTPShortcutBar control.
BOOL | RegisterWindowClass (HINSTANCE hInstance=NULL)
Registers the window class if it has not already been registered.
void | LoadState (LPCTSTR lpszProfileName)
Retrieves state information from the registry or .INI file.
void | SaveState (LPCTSTR lpszProfileName)
Saves state information to the registry or .INI file.
CXTPShortcutBarItem * | AddItem (UINT nID, CWnd *pWnd=NULL)
Adds a specified item.
CXTPShortcutBarItem * | FindItem (int nID) const
Retrieves the item with a specified identifier.
void | SelectItem (CXTPShortcutBarItem *pItem)
Selects a specified item.
void | ShowExpandButton (BOOL bShow)
Shows/hides the expand button.
BOOL | IsExpandButtonVisible () const
Determines if the expand button is shown/hidden.
void | RemoveItem (int nID)
Removes the item with a specified identifier.
void | RemoveAllItems ()
Removes all items.
CXTPShortcutBarItem * | GetItem (int nIndex) const
Retrieves the item at a specified index.
CXTPShortcutBarItem * | HitTest (CPoint pt) const
Determines which item, if any, is located at a specified point.
void | SetMinimumClientHeight (int nMinHeight)
Sets the minimum height for the client area.
CRect | GetGripperRect () const
Gets the bounding rectangle of the gripper.
CSize | GetItemSize () const
Gets the size of items.
void | SetItemSize (CSize szItem)
Sets the size for items.
int | GetExpandedLinesCount () const
Gets the number of visible lines in the shortcut bar control.
int | GetExpandedLinesHeight () const
Gets the height of visible lines in the shortcut bar control.
void | SetExpandedLinesCount (int nCount)
Sets the number of visible lines in the shortcut bar control.
void | SetExpandedLinesHeight (int nHeight)
Sets the height for visible lines in the shortcut bar control.
void | AllowGripperResize (BOOL bAllowResize)
Allows/disallows resizing the client area.
CXTPShortcutBarItem * | GetHotItem () const
Gets the hot item in the shortcut bar control.
CXTPShortcutBarItem * | GetSelectedItem () const
Gets the selected item in the shortcut bar control.
void | SetSingleSelection (BOOL bSingleSelection=TRUE)
Enables/disables single selection.
BOOL | IsSingleSelection () const
Determines if single selection is enabled/disabled.
void | ShowActiveItemOnTop (BOOL bActiveItemOnTop)
Specifies if the active item should be shown on top of controls.
BOOL | IsShowActiveItemOnTop () const
Determines if the active item is shown on top of controls.
void | AllowFreeResize (BOOL bAllowFreeResize)
Allows/disallows resizing the gripper by pixel.
BOOL | IsAllowFreeResize () const
Determines if resizing the gripper by pixel is allowed/disallowed.
void | AllowCollapse (BOOL bAllowCollapse)
Call this method to allow collapse items.
void | ShowGripper (BOOL bShowGripper)
Shows/hides the gripper.
CXTPShortcutBarItem * | GetPressedItem () const
Gets the pressed item in the shortcut bar control.
BOOL | IsClientPaneVisible () const
Determines if the client pane is shown/hidden.
void | SetClientPaneVisible (BOOL bVisible)
Shows/hides the client pane.
void | SetImageManager (CXTPImageManager *pImageManager)
Sets the image manager for the shortcut bar control.
CXTPImageManager * | GetImageManager () const
Gets the image manager of the shortcut bar control.
int | GetItemCount () const
Gets the number of items in the shortcut bar control.
void | SetLayoutRTL (BOOL bRightToLeft)
Sets right-to-left (RTL) mode.
CRect | GetClientPaneRect () const
Gets the bounding rectangle of the shortcut bar client.
void | SetTheme (XTPShortcutBarPaintTheme paintTheme)
Sets the theme for the shortcut bar control.
void | SetCustomTheme (CXTPShortcutBarPaintManager *pPaintManager)
Sets a custom theme for the shortcut bar control.
CXTPShortcutBarPaintManager * | GetPaintManager () const
Gets the paint manager.
XTPShortcutBarPaintTheme | GetCurrentTheme () const
Gets the theme of the shortcut bar control.
void | RedrawControl (LPCRECT lpRect=NULL, BOOL bAnimate=FALSE)
Redraws the shortcut bar control.
CXTPToolTipContext * | GetToolTipContext () const
Gets the tooltip context.
int | GetVisibleItemsCount () const
Gets the number of visible items.
int | GetCollapsedItemsCount () const
Gets the number of collapsed items.
virtual void | Reposition ()
Repositions items.
virtual void | OnDraw (CDC *pDC, CRect rcClipBox)
This method is called by the framework to draw the shortcut bar control using the specified device context.
void | EnableAnimation (BOOL bEnable=TRUE)
Enables/disables animation for the shortcut bar control.
BOOL | IsShortcutBarMinimized () const
Determines if the shortcut bar control is minimized.
void | AllowMinimize (BOOL bAllowMinimize=TRUE, int nMinimizedWidth=0)
Allows/disallows minimizing the shortcut bar control.
void | ShowMinimizeButton (BOOL bShowMinimizeButton)
Shows/hides the minimize button contained in the caption of the pane.
BOOL | IsMinimizeButtonVisible () const
Determines if the minimize button contained in the caption of the pane is shown/hidden.
BOOL | IsAllowMinimize () const
Determines if minimizing the shortcut bar control is allowed/disallowed.

Protected Member Functions

virtual void | OnRepositionDone ()
This method is called when reposition is done.
virtual void | OnExpandButtonDown (CXTPShortcutBarItem *pExpandButton)
This method is called when the expand button is pressed.
void | OnNavigateButtonDown (CXTPShortcutBarItem *pNavigateButton)
This method is called when the navigate button is pressed.
void | SetHotItem (CXTPShortcutBarItem *pItem)
Sets the hot item.

Protected Attributes

CXTPShortcutBarPaintManager * | m_pPaintManager
Current paint manager.
CXTPImageManager * | m_pImageManager
Current image manager.
int | m_nExpandedLines
Number of lines currently visible.
int | m_nDesiredExpandedLinesHeight
Desired visible lines height.
int | m_nMinClientHeight
The height of the client area.
BOOL | m_bAllowResize
TRUE to allow resize.
XTPShortcutBarPaintTheme | m_paintTheme
Current theme.
CShortcutArray | m_arrItems
Array of items.
CSize | m_szItem
Size of items.
CRect | m_rcClient
Client's rectangle.
CRect | m_rcGripper
Gripper's rectangle.
HWND | m_hwndClient
Client window handle.
HCURSOR | m_hSizeCursor
Handle to the cursor displayed for the size icon.
BOOL | m_bTrackingSize
TRUE if the control is in tracking mode.
BOOL | m_bShowActiveItemOnTop
TRUE to show the active item on top.
BOOL | m_bAllowFreeResize
TRUE to allow resize gripper by pixel.
BOOL | m_bAllowCollapse
TRUE to allow collapse items.
BOOL | m_bShowGripper
TRUE to show the gripper.
CXTPShortcutBarItem * | m_pHotItem
Pointer to the hot item.
CXTPShortcutBarItem * | m_pSelectedItem
Pointer to the selected item.
CXTPShortcutBarItem * | m_pPressedItem
Pointer to the pressed item.
BOOL | m_bClientPaneVisible
TRUE if the client pane in the shortcut bar is visible.
HCURSOR | m_hHandCursor
Hand cursor that is displayed when the cursor is positioned over a shortcut bar item.
BOOL | m_bSingleSelection
TRUE to only allow a single selected item.
CXTPToolTipContext * | m_pToolTipContext
Tooltip context.
BOOL | m_bPreSubclassWindow
True if PreSubclassWindow was called.
CXTPShortcutBarAnimation * | m_pAnimation
Animation helper.

Detailed Description

CXTPShortcutBar is a CWnd derived class used to implement an Outlook 2003 shortcut bar control style.

Member Function Documentation

◆ AddItem()

CXTPShortcutBarItem * AddItem | ( | UINT | nID,
 |  | CWnd * | pWnd = NULL )

Adds a specified item.

Parameters
nID | Identifier of the item to be added.
pWnd | Pointer to the associated child window of the item.
Returns
A pointer to the newly added CXTPShortcutBarItem object.

◆ AllowCollapse()

AFX_INLINE void AllowCollapse ( BOOL bAllowCollapse )

Call this method to allow collapse items.

Parameters
bAllowCollapse TRUE to allow collapse items

◆ AllowFreeResize()

AFX_INLINE void AllowFreeResize ( BOOL bAllowFreeResize )

Allows/disallows resizing the gripper by pixel.

Parameters
bAllowFreeResize TRUE to allow resizing the gripper by pixel, FALSE to disallow resizing the gripper by pixel.
See also
IsShowActiveItemOnTop

◆ AllowGripperResize()

AFX_INLINE void AllowGripperResize ( BOOL bAllowResize )

Allows/disallows resizing the client area.

Parameters
bAllowResize TRUE to allow resizing the client area, FALSE to disallow resizing the client area.
See also
SetExpandedLinesCount

◆ AllowMinimize()

void AllowMinimize | ( | BOOL | bAllowMinimize = TRUE,
 |  | int | nMinimizedWidth = 0 )

Allows/disallows minimizing the shortcut bar control.

Parameters
bAllowMinimize | TRUE to allow minimizing the shortcut bar control, FALSE to disallow minimizing the shortcut bar control.
nMinimizedWidth | Width to be set for the shortcut bar control when it is minimized. Set the value of this parameter to 0 to use the default width of 32.

◆ Create()

BOOL Create | ( | DWORD | dwStyle,
 |  | const RECT & | rect,
 |  | CWnd * | pParentWnd,
 |  | UINT | nID )

Creates the CXTPShortcutBar control.

Parameters
dwStyle | Style of the shortcut bar control.
rect | Reference to the size and position of the shortcut bar control.
pParentWnd | Pointer to the parent window of the shortcut bar control.
nID | Identifier of the shortcut bar control.
Returns
TRUE if successful, otherwise FALSE.

◆ EnableAnimation()

void EnableAnimation ( BOOL bEnable = TRUE )

Enables/disables animation for the shortcut bar control.

Parameters
bEnable TRUE to enable animation, FALSE to disable animation.

◆ FindItem()

CXTPShortcutBarItem * FindItem ( int nID ) const

Retrieves the item with a specified identifier.

Parameters
nID Identifier of the item to retrieve.
Returns
A pointer to a CXTPShortcutBarItem object if successful, otherwise NULL.

◆ GetClientPaneRect()

AFX_INLINE CRect GetClientPaneRect ( ) const

Gets the bounding rectangle of the shortcut bar client.

Returns
The bounding rectangle of the shortcut bar client.

◆ GetCollapsedItemsCount()

int GetCollapsedItemsCount ( ) const

Gets the number of collapsed items.

Returns
The number of collapsed items.

◆ GetCurrentTheme()

AFX_INLINE XTPShortcutBarPaintTheme GetCurrentTheme ( ) const

Gets the theme of the shortcut bar control.

Returns
The theme of the shortcut bar control; one of the values defined by the XTPShortcutBarPaintTheme enumeration.
See also
SetTheme, SetCustomTheme, XTPShortcutBarPaintTheme

◆ GetExpandedLinesCount()

AFX_INLINE int GetExpandedLinesCount ( ) const

Gets the number of visible lines in the shortcut bar control.

Returns
The number of visible lines in the shortcut bar control.
See also
SetExpandedLinesCount

◆ GetExpandedLinesHeight()

AFX_INLINE int GetExpandedLinesHeight ( ) const

Gets the height of visible lines in the shortcut bar control.

Returns
The height of visible lines in the shortcut bar control.
See also
SetExpandedLinesHeight

◆ GetGripperRect()

AFX_INLINE CRect GetGripperRect ( ) const

Gets the bounding rectangle of the gripper.

Returns
The bounding rectangle of the gripper.

◆ GetHotItem()

AFX_INLINE CXTPShortcutBarItem * GetHotItem ( ) const

Gets the hot item in the shortcut bar control.

Returns
A pointer to the hot item in the shortcut bar control.

◆ GetImageManager()

CXTPImageManager * GetImageManager ( ) const

Gets the image manager of the shortcut bar control.

The image manager is used to hold all of the icons displayed in the shortcut bar control.

Returns
A pointer to the image manager of the shortcut bar control.
See also
SetImageManager

◆ GetItem()

CXTPShortcutBarItem * GetItem ( int nIndex ) const

Retrieves the item at a specified index.

Parameters
nIndex Zero-based index of the item to retrieve.
Returns
A pointer to a CXTPShortcutBarItem object if successul, otherwise NULL.

◆ GetItemCount()

int GetItemCount ( ) const

Gets the number of items in the shortcut bar control.

Returns
The number of items in the shortcut bar control.

◆ GetItemSize()

AFX_INLINE CSize GetItemSize ( ) const

Gets the size of items.

Returns
The size of items.

◆ GetPaintManager()

AFX_INLINE CXTPShortcutBarPaintManager * GetPaintManager ( ) const

Gets the paint manager.

Returns
A pointer to the paint manager.

◆ GetPressedItem()

AFX_INLINE CXTPShortcutBarItem * GetPressedItem ( ) const

Gets the pressed item in the shortcut bar control.

Returns
A pointer to the pressed item in the shortcut bar control.

◆ GetSelectedItem()

AFX_INLINE CXTPShortcutBarItem * GetSelectedItem ( ) const

Gets the selected item in the shortcut bar control.

Returns
A pointer to the selected item in the shortcut bar control.

◆ GetToolTipContext()

CXTPToolTipContext * GetToolTipContext ( ) const

Gets the tooltip context.

Returns
A pointer to the tooltip context.

◆ GetVisibleItemsCount()

int GetVisibleItemsCount ( ) const

Gets the number of visible items.

Returns
The number of visible items.

◆ HitTest()

CXTPShortcutBarItem * HitTest ( CPoint pt ) const

Determines which item, if any, is located at a specified point.

Parameters
pt Point to be tested.
Returns
A pointer to the CXTPShortcutBarItem object at the specified point, if any, otherwise NULL.

◆ IsAllowFreeResize()

AFX_INLINE BOOL IsAllowFreeResize ( ) const

Determines if resizing the gripper by pixel is allowed/disallowed.

Returns
TRUE if resizing the gripper by pixel is allowed, FALSE if resizing the gripper by pixel is disallowed.
See also
ShowActiveItemOnTop

◆ IsAllowMinimize()

AFX_INLINE BOOL IsAllowMinimize ( ) const

Determines if minimizing the shortcut bar control is allowed/disallowed.

Returns
TRUE if minimizing the shortcut bar control is allowed, FALSE if minimizing the shortcut bar control is disallowed.

◆ IsClientPaneVisible()

AFX_INLINE BOOL IsClientPaneVisible ( ) const

Determines if the client pane is shown/hidden.

Returns
TRUE if the client pane is shown, FALSE if the client pane is hidden.

◆ IsExpandButtonVisible()

BOOL IsExpandButtonVisible ( ) const

Determines if the expand button is shown/hidden.

Returns
TRUE if the expand button is shown, FALSE if the expand button is hidden.

◆ IsMinimizeButtonVisible()

AFX_INLINE BOOL IsMinimizeButtonVisible ( ) const

Determines if the minimize button contained in the caption of the pane is shown/hidden.

Returns
TRUE if the minimize button is shown, FALSE if the minimize button is hidden.

◆ IsShortcutBarMinimized()

BOOL IsShortcutBarMinimized ( ) const

Determines if the shortcut bar control is minimized.

Returns
TRUE if the shortcut bar control is mimimized, otherwise FALSE.
See also
AllowMinimize

◆ IsShowActiveItemOnTop()

AFX_INLINE BOOL IsShowActiveItemOnTop ( ) const

Determines if the active item is shown on top of controls.

Returns
TRUE if the active item is shown on top of controls, otherwise FALSE.
See also
ShowActiveItemOnTop

◆ IsSingleSelection()

AFX_INLINE BOOL IsSingleSelection ( ) const

Determines if single selection is enabled/disabled.

Returns
TRUE if single selection is enabled, FALSE if single selection is disabled.
See also
SetSingleSelection, SetSelectItemOnFocus

◆ LoadState()

void LoadState ( LPCTSTR lpszProfileName )

Retrieves state information from the registry or .INI file.

Parameters
lpszProfileName Pointer to a NULL-terminated string that specifies the name of a section in the initialization file or a key in the Windows registry where state information is stored.

◆ OnDraw()

virtual void OnDraw | ( | CDC * | pDC,
 |  | CRect | rcClipBox )
 virtual

This method is called by the framework to draw the shortcut bar control using the specified device context.

Parameters
pDC | Pointer to a valid device context.
rcClipBox | Rectangular area of the control that is invalid.

◆ OnExpandButtonDown()

virtual void OnExpandButtonDown ( CXTPShortcutBarItem * pExpandButton )
protectedvirtual

This method is called when the expand button is pressed.

Parameters
pExpandButton Pointer to the expand button.

◆ OnNavigateButtonDown()

void OnNavigateButtonDown ( CXTPShortcutBarItem * pNavigateButton )
protected

This method is called when the navigate button is pressed.

Parameters
pNavigateButton Pointer to the navigate button.

◆ RedrawControl()

void RedrawControl | ( | LPCRECT | lpRect = NULL,
 |  | BOOL | bAnimate = FALSE )

Redraws the shortcut bar control.

Parameters
lpRect | Rectangular area of the control that is invalid.
bAnimate | TRUE to animate changes in the bounding rectangle.

◆ RegisterWindowClass()

BOOL RegisterWindowClass ( HINSTANCE hInstance = NULL )

Registers the window class if it has not already been registered.

Parameters
hInstance Instance of the resource where the control is located.
Returns
TRUE if the window class was successfully registered.

◆ RemoveItem()

void RemoveItem ( int nID )

Removes the item with a specified identifier.

Parameters
nID Identifier of the item to remove.

◆ SaveState()

void SaveState ( LPCTSTR lpszProfileName )

Saves state information to the registry or .INI file.

Parameters
lpszProfileName Pointer to a NULL-terminated string that specifies the name of a section in the initialization file or a key in the Windows registry where state information is stored.

◆ SelectItem()

void SelectItem ( CXTPShortcutBarItem * pItem )

Selects a specified item.

Parameters
pItem Pointer to the item to be selected.

◆ SetClientPaneVisible()

AFX_INLINE void SetClientPaneVisible ( BOOL bVisible )

Shows/hides the client pane.

Parameters
bVisible TRUE to show the client pane, FALSE to hide the client pane.

◆ SetCustomTheme()

void SetCustomTheme ( CXTPShortcutBarPaintManager * pPaintManager )

Sets a custom theme for the shortcut bar control.

Parameters
pPaintManager Pointer to a CXTPShortcutBarPaintManager object.
See also
GetCurrentTheme, SetTheme, XTPShortcutBarPaintTheme

◆ SetExpandedLinesCount()

void SetExpandedLinesCount ( int nCount )

Sets the number of visible lines in the shortcut bar control.

Parameters
nCount Number to be set.
See also
GetExpandedLinesCount

◆ SetExpandedLinesHeight()

void SetExpandedLinesHeight ( int nHeight )

Sets the height for visible lines in the shortcut bar control.

Parameters
nHeight Height to be set.
See also
SetExpandedLinesCount, GetExpandedLinesCount

◆ SetHotItem()

void SetHotItem ( CXTPShortcutBarItem * pItem )
protected

Sets the hot item.

Parameters
pItem Pointer to the item to be set.

◆ SetImageManager()

void SetImageManager ( CXTPImageManager * pImageManager )

Sets the image manager for the shortcut bar control.

Parameters
pImageManager Pointer to the image manager to be set.

The image manager is used to hold all of the icons displayed in the shortcut bar control.

Example:

CXTPImageManager* pImageManager = new CXTPImageManager();
pImageManager->SetIcons(IDR_MAINFRAME);
m_wndShortcutBar.SetImageManager(pImageManager);
See also
GetImageManager

◆ SetItemSize()

AFX_INLINE void SetItemSize ( CSize szItem )

Sets the size for items.

Parameters
szItem Size to be set.

◆ SetLayoutRTL()

void SetLayoutRTL ( BOOL bRightToLeft )

Sets right-to-left (RTL) mode.

Parameters
bRightToLeft TRUE to set right-to-left (RTL) reading-order properties.

◆ SetMinimumClientHeight()

AFX_INLINE void SetMinimumClientHeight ( int nMinHeight )

Sets the minimum height for the client area.

Parameters
nMinHeight Minimum height, in pixels, to be set.

The default minimum height for the client area is 200 pixels.

◆ SetSingleSelection()

AFX_INLINE void SetSingleSelection ( BOOL bSingleSelection = TRUE )

Enables/disables single selection.

Parameters
bSingleSelection TRUE to enable single selection, FALSE to disable single selection.

If single selection is enabled, then only one item can be selected in the shortcut bar control at a given time. If single selection is disabled, then multiple items can be selected in the shortcut bar control at a given time.

See also
IsSingleSelection, SetSelectItemOnFocus

◆ SetTheme()

void SetTheme ( XTPShortcutBarPaintTheme paintTheme )

Sets the theme for the shortcut bar control.

Parameters
paintTheme Theme to be set; can be any of the values listed in the Remarks section.

paintTheme can be one of the following: xtpShortcutThemeOffice2000: Enables Office 2000 style theme. xtpShortcutThemeOfficeXP: Enables Office XP style theme. xtpShortcutThemeOffice2003: Enables Office 2003 style theme. xtpTaskPanelThemeShortcutBarOffice2007: Enables Office 2007 style theme.

See also
GetCurrentTheme, SetCustomTheme, XTPShortcutBarPaintTheme

◆ ShowActiveItemOnTop()

AFX_INLINE void ShowActiveItemOnTop ( BOOL bActiveItemOnTop )

Specifies if the active item should be shown on top of controls.

Parameters
bActiveItemOnTop TRUE to show the active item on top of controls, FALSE otherwise.
See also
IsShowActiveItemOnTop

◆ ShowExpandButton()

void ShowExpandButton ( BOOL bShow )

Shows/hides the expand button.

Parameters
bShow TRUE to show the expand button, FALSE to hide the expand button.

◆ ShowGripper()

AFX_INLINE void ShowGripper ( BOOL bShowGripper )

Shows/hides the gripper.

Parameters
bShowGripper TRUE to show the gripper, FALSE to hide the gripper.

◆ ShowMinimizeButton()

AFX_INLINE void ShowMinimizeButton ( BOOL bShowMinimizeButton )

Shows/hides the minimize button contained in the caption of the pane.

Parameters
bShowMinimizeButton TRUE to show the minimize button, FALSE to hide the minimize button.
The documentation for this class was generated from the following file:
  • XTPShortcutBar.h


Toolkit Pro: CXTPShortcutBarItem Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPShortcutBarItem Class Reference

CXTPShortcutBarItem is a base class that represents an item for a shortcut bar control. More...

Inheritance diagram for CXTPShortcutBarItem:
[legend]

Public Member Functions

void | SetID (int nID)
Sets the identifier for the item.
int | GetID () const
Gets the identifier of the item.
void | SetIconId (int nId)
Sets the identifier for the icon.
int | GetIconId () const
Gets the identifier of the icon.
void | SetCaption (LPCTSTR strCaption)
Sets the caption for the item.
CString | GetCaption () const
Gets the caption of the item.
void | SetVisible (BOOL bVisible)
Specifies the visible state of the item.
BOOL | IsVisible () const
Determines the visible state of the item.
void | SetTooltip (LPCTSTR strTooltip)
Sets the tooltip text for the item.
CString | GetTooltip () const
Gets the tooltip text of the item.
BOOL | IsExpanded () const
Gets the expanded state of the item.
BOOL | IsItemExpandButton () const
Determines if the item is an expand button.
CXTPShortcutBar * | GetShortcutBar () const
Gets the parent shortcut bar.
CRect | GetItemRect () const
Gets the bounding rectangle of the item.
void | SetItemData (DWORD_PTR dwData)
Sets the 32-bit value associated with the item.
DWORD_PTR | GetItemData () const
Gets the application-supplied, 32-bit value associated with the item.
CXTPImageManagerIcon * | GetImage (int nWidth) const
Retrieves the image of the item.
BOOL | IsHidden () const
Gets the hidden state of the item.
BOOL | IsSelected () const
Gets the selected state of the item.
void | SetSelected (BOOL bSelected)
Sets the selected state for the item.
CWnd * | GetClientWindow () const
Gets the child window of the item.
void | SetClientWindow (CWnd *pWnd)
Sets the child window for the item.
BOOL | IsEnabled () const
Gets the enabled state of the item.
void | SetEnabled (BOOL bEnabled)
Sets the enabled state for the item.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

CXTPShortcutBarItem (CXTPShortcutBar *pShortcutBar, int nID, CWnd *pWnd)
Constructs a CXTPShortcutBarItem object.

Protected Attributes

CString | m_strCaption
Caption of the item.
CString | m_strTooltip
Tooltip of the item.
int | m_nID
Item's identifier.
CRect | m_rcItem
Bounding rectangle of the item.
BOOL | m_bVisible
TRUE if the item is visible.
BOOL | m_bExpanded
TRUE if the item is expanded.
BOOL | m_bHidden
TRUE if the item is hidden.
HWND | m_hwndChild
Child window associated with the item.
BOOL | m_bExpandButton
TRUE if the item is an expand button.
BOOL | m_bNavigateButton
TRUE if the item is a navigate button.
DWORD_PTR | m_dwData
The 32-bit value associated with the item.
CXTPShortcutBar * | m_pShortcutBar
Parent CXTPShortcutBar class.
BOOL | m_bSelected
TRUE if the item is selected.
int | m_nIconId
Identifier of the item's image.
BOOL | m_bEnabled
TRUE if the item is enabled.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

CXTPShortcutBarItem is a base class that represents an item for a shortcut bar control.

Constructor & Destructor Documentation

◆ CXTPShortcutBarItem()

CXTPShortcutBarItem | ( | CXTPShortcutBar * | pShortcutBar,
 |  | int | nID,
 |  | CWnd * | pWnd )
 protected

Constructs a CXTPShortcutBarItem object.

Parameters
pShortcutBar | Pointer to the parent CXTPShortcutBar object.
nID | Identifier of the item.
pWnd | Pointer to the client window of the item.

Member Function Documentation

◆ GetCaption()

AFX_INLINE CString GetCaption ( ) const

Gets the caption of the item.

Returns
The caption of the item.

◆ GetClientWindow()

AFX_INLINE CWnd * GetClientWindow ( ) const

Gets the child window of the item.

The child window of the item is visible in the client part of the shortcut bar when the item is selected.

Returns
A pointer to the child window of the item.

◆ GetIconId()

int GetIconId ( ) const

Gets the identifier of the icon.

Returns
The identifier of the icon.

◆ GetID()

int GetID ( ) const

Gets the identifier of the item.

Returns
The identifier of the item.

◆ GetImage()

CXTPImageManagerIcon * GetImage ( int nWidth ) const

Retrieves the image of the item.

Parameters
nWidth Width of the icon to be retrieved (e.g. pass in a value of 16 to retrieve a 16x16 image).

CXTPImageManagerIcon can have multiple image sizes for the same item. For example, the shortcut bar uses both 24x24 and 16x16 images depending on if the item is displayed in the extended shortcut list or not.

Returns
A pointer to the image of the item.

◆ GetItemData()

AFX_INLINE DWORD_PTR GetItemData ( ) const

Gets the application-supplied, 32-bit value associated with the item.

Returns
The 32-bit value associated with the item.

◆ GetItemRect()

AFX_INLINE CRect GetItemRect ( ) const

Gets the bounding rectangle of the item.

Returns
The bounding rectangle of the item.

◆ GetShortcutBar()

AFX_INLINE CXTPShortcutBar * GetShortcutBar ( ) const

Gets the parent shortcut bar.

Returns
A pointer to the parent shortcut bar.

◆ GetTooltip()

AFX_INLINE CString GetTooltip ( ) const

Gets the tooltip text of the item.

Returns
The tooltip text of the item.

◆ IsEnabled()

BOOL IsEnabled ( ) const

Gets the enabled state of the item.

Returns
TRUE if the item is enabled, otherwise FALSE.

◆ IsExpanded()

AFX_INLINE BOOL IsExpanded ( ) const

Gets the expanded state of the item.

Returns
TRUE if the item is expanded, otherwise FALSE.

◆ IsHidden()

BOOL IsHidden ( ) const

Gets the hidden state of the item.

An item is hidden when there are more items than can be displayed in the shortcut bar. As such, items that were hidden can become visible when the shortcut bar is expanded.

Returns
TRUE if the item is hidden, otherwise FALSE.

◆ IsItemExpandButton()

AFX_INLINE BOOL IsItemExpandButton ( ) const

Determines if the item is an expand button.

Returns
TRUE if the item is an expand button, otherwise FALSE.

◆ IsSelected()

BOOL IsSelected ( ) const

Gets the selected state of the item.

If CXTPShortcutBar::m_bSingleSelection is set to FALSE, then multiple items can be selected at a given time. However, only a single item can have focus.

Returns
TRUE if the item is selected, otherwise FALSE.

◆ IsVisible()

BOOL IsVisible ( ) const

Determines the visible state of the item.

Returns
TRUE if the item is visible, otherwise FALSE.

◆ SetCaption()

void SetCaption ( LPCTSTR strCaption )

Sets the caption for the item.

Parameters
strCaption Caption to be set.

◆ SetClientWindow()

void SetClientWindow ( CWnd * pWnd )

Sets the child window for the item.

Parameters
pWnd Pointer to the child window to be set.

The child window of the item is visible in the client part of the shortcut bar when the item is selected.

◆ SetEnabled()

void SetEnabled ( BOOL bEnabled )

Sets the enabled state for the item.

Parameters
bEnabled TRUE to set the item to enabled, otherwise FALSE.

◆ SetIconId()

void SetIconId ( int nId )

Sets the identifier for the icon.

Parameters
nId Identifier to be set.

◆ SetID()

void SetID ( int nID )

Sets the identifier for the item.

Parameters
nID Identifier to be set.

◆ SetItemData()

AFX_INLINE void SetItemData ( DWORD_PTR dwData )

Sets the 32-bit value associated with the item.

Parameters
dwData 32-bit value to associate with the item.

◆ SetSelected()

void SetSelected ( BOOL bSelected )

Sets the selected state for the item.

Parameters
bSelected TRUE to set the item to selected, FALSE otherwise.

If CXTPShortcutBar::m_bSingleSelection is set to FALSE, then multiple items can be selected at a given time. However, only a single item can have focus.

◆ SetTooltip()

void SetTooltip ( LPCTSTR strTooltip )

Sets the tooltip text for the item.

Parameters
strTooltip Tooltip text to be set.

The tooltip text is displayed when the mouse cursor is over the item.

◆ SetVisible()

void SetVisible ( BOOL bVisible )

Specifies the visible state of the item.

Parameters
bVisible TRUE to set the item to visible, FALSE otherwise.
The documentation for this class was generated from the following file:
  • XTPShortcutBar.h


Toolkit Pro: CXTPShortcutBarNativeWindows10Theme Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPShortcutBarNativeWindows10Theme Class Reference

CXTPShortcutBarNativeWindows10Theme is a CXTPShortcutBarOffice2013Theme derived class that represents a Native Windows 10 shortcut bar theme. More...

Inheritance diagram for CXTPShortcutBarNativeWindows10Theme:
[legend]

Public Member Functions

CXTPShortcutBarNativeWindows10Theme ()
Constructs a CXTPShortcutBarNativeWindows10Theme object.
virtual | ~CXTPShortcutBarNativeWindows10Theme ()
Destroys a CXTPShortcutBarNativeWindows10Theme object, handles cleanup and deallocation.
virtual void | RefreshMetrics ()
Refreshes the visual metrics of the shortcut bar paint manager.
virtual int | DrawPaneItemCaption (CDC *pDC, CXTPShortcutBarPaneItem *pItem, BOOL bDraw)
Draws the caption for a specified shortcut bar pane item.
virtual void | FillShortcutItemEntry (CDC *pDC, CXTPShortcutBarItem *pItem)
Fills a specified item for the shortcut bar control.
virtual void | FillNavigationItemEntry (CDC *pDC, CXTPShortcutBarItem *pItem)
Fills a specified navigation item for the minimized shortcut bar control.
- Public Member Functions inherited from CXTPShortcutBarOffice2013Theme
CXTPShortcutBarOffice2013Theme ()
Constructs a CXTPShortcutBarOffice2013Theme object.
virtual | ~CXTPShortcutBarOffice2013Theme ()
Destroys a CXTPShortcutBarOffice2013Theme object, handles cleanup and deallocation.
virtual void | DrawExpandButton (CDC *pDC, CRect rc)
Draws the expand button.
virtual int | DrawGripper (CDC *pDC, CXTPShortcutBar *pShortcutBar, BOOL bDraw)
Draws the gripper for the shortcut bar control.
void | FillShortcutItemEntry (CDC *pDC, CXTPShortcutBarItem *pItem)
Fills a specified item for the shortcut bar control.
virtual void | FillShortcutBar (CDC *pDC, CXTPShortcutBar *pShortcutBar)
Fills the client area of the shortcut bar control.
- Public Member Functions inherited from CXTPShortcutBarResourceTheme
CXTPShortcutBarResourceTheme ()
Constructs a CXTPShortcutBarResourceTheme object.
void | FillShortcutItemEntry (CDC *pDC, CXTPShortcutBarItem *pItem)
Fills a specified item for the shortcut bar control.
void | FillShortcutBar (CDC *pDC, CXTPShortcutBar *pShortcutBar)
Fills the client area of the shortcut bar control.
virtual int | DrawPaneCaption (CDC *pDC, CXTPShortcutBarPane *pPane, BOOL bDraw)
Draws the caption for a specified shortcut bar pane.
- Public Member Functions inherited from CXTPShortcutBarOffice2003Theme
CXTPShortcutBarOffice2003Theme ()
Constructs a CXTPShortcutBarOffice2003Theme object.
void | DrawShortcutBarFrame (CDC *pDC, CXTPShortcutBar *pShortcutBar)
Draws the frame for the shortcut bar control.
void | DrawImage (CDC *pDC, CPoint pt, CSize sz, CXTPImageManagerIcon *pImage, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled)
Draws the image of a shortcut bar item.
- Public Member Functions inherited from CXTPShortcutBarPaintManager
CXTPShortcutBarPaintManager ()
Constructs a CXTPShortcutBarPaintManager object.
virtual | ~CXTPShortcutBarPaintManager ()
Destroys a CXTPShortcutBarPaintManager object, handles cleanup and deallocation.
virtual void | DrawShortcutItem (CDC *pDC, CXTPShortcutBarItem *pItem)
Draws a specified item for the shortcut bar control.
virtual void | DrawNavigationItem (CDC *pDC, CXTPShortcutBarItem *pItem)
Draws a specified navigation item for the minimized shortcut bar control.
void | Rectangle (CDC *pDC, CRect rc, int nPen, int nBrush)
Draws the rectangle to be used to draw the shortcut bar items.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1, int nPen)
Draws the "gripper" lines in the gripper.
BOOL | IsShortcutItemTruncated (CDC *pDC, CXTPShortcutBarItem *pItem)
Determines if the caption text of a specified expanded shortcut bar item has been truncated.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Attributes

BOOL | m_bHiliteBorders
TRUE to draw borders around highlighted items.
CXTPPaintManagerColor | m_clrBorderHilite
Highlighted border color.
CXTPPaintManagerColor | m_clrBackHiliteSelected
Selected highlighted background color.
- Protected Attributes inherited from CXTPShortcutBarOffice2013Theme
CXTPPaintManagerColor | m_clrGlyph
Normal glyph color.
CXTPPaintManagerColor | m_clrGlyphFill
Expanded glyph fill color.
CXTPPaintManagerColor | m_clrGlyphExpanded
Expanded glyph border color.
CXTPPaintManagerColor | m_clrGlyphPushed
Pushed glyph color.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPShortcutBarResourceTheme
- Public Attributes inherited from CXTPShortcutBarOffice2003Theme
CXTPPaintManagerColorGradient | m_grcCaption
Caption color.
CXTPPaintManagerColorGradient | m_grcItemCaption
Items color.
CXTPPaintManagerColorGradient | m_grcItemHotCaption
Items color.
CXTPPaintManagerColor | m_clrItemCaptionShadow
Color of sub-caption shadow.
CXTPPaintManagerColor | m_clrItemCaptionTop
Color under sub-caption rectangle.
CXTPPaintManagerColor | m_clrCaptionText
Color of items text.
CXTPPaintManagerColor | m_clrItemCaptionText
Color of sub-caption text.
BOOL | m_bShowTopLeftCaptionShadow
TRUE to draw rectangle around items.
- Public Attributes inherited from CXTPShortcutBarPaintManager
CXTPFont | m_xtpFontText
Text font.
CXTPFont | m_xtpFontPaneCaption
Caption font.
CXTPFont | m_xtpFontPaneItemCaption
Sub-caption font.
CXTPFont | m_xtpFontVerticalText
Navigation button text font.
int | m_nPaneItemHeight
Height of sub-pane caption.
CXTPImageManagerIcon * | m_pExpandIcon
Pointer to expand icon.
BOOL | m_bNavigationButton
TRUE if navigation button small.
int | m_nNormalIconWidth
Width of the icons.
int | m_nExpandedIconWidth
Width of the expanded icons.
BOOL | m_bBoldItemCaptionFont
TRUE to draw item with bold font.
BOOL | m_bClearTypeTextQuality
TRUE to use ClearType font.
BOOL | m_bUseStandardFont
TRUE to use standard font.
CRect | m_rcCaptionPadding
Padding of pane caption.
CRect | m_rcItemCaptionPadding
Padding of item caption.
CString | m_strOfficeFont
TRUE to use Office Tahoma font.
CXTPPaintManagerColor | m_clrPushedText
Color of caption text when an CXTPShortcutBarItem is pressed.
CXTPPaintManagerColor | m_clrSelectedText
Color of caption text when an CXTPShortcutBarItem is selected (this happens after the item is clicked).
CXTPPaintManagerColor | m_clrHotText
Color of caption text when the mouse cursor is positioned over an CXTPShortcutBarItem.
CXTPPaintManagerColor | m_clrNormalText
Color of caption text when an CXTPShortcutBarItem is displayed normally.
CXTPPaintManagerColor | m_clrDisabledText
Color of caption text when an CXTPShortcutBarItem is disabled.
CXTPPaintManagerColorGradient | m_grcSelected
Color gradient of currently selected item.
CXTPPaintManagerColorGradient m_grcHot
Color gradient of "hot" items.
CXTPPaintManagerColorGradient m_grcPushed
Color gradient of item when clicked on.
CXTPPaintManagerColorGradient | m_grcShortcutItem
Color gradient of shortcut bar items.
CXTPPaintManagerColor | m_clrShortcutItemShadow
Color of line border that goes around each item.
CXTPPaintManagerColorGradient | m_grcShortcutBarGripper
Color gradient used to draw the shortcut bar gripper.

Detailed Description

CXTPShortcutBarNativeWindows10Theme is a CXTPShortcutBarOffice2013Theme derived class that represents a Native Windows 10 shortcut bar theme.

Member Function Documentation

◆ DrawPaneItemCaption()

virtual int DrawPaneItemCaption | ( | CDC * | pDC,
 |  | CXTPShortcutBarPaneItem * | pItem,
 |  | BOOL | bDraw )
 virtual

Draws the caption for a specified shortcut bar pane item.

Parameters
pDC | Pointer to the client device context.
pItem | Pointer to the CXTPShortcutBarPaneItem object to be drawn.
bDraw | TRUE to draw the shortcut bar pane item caption, FALSE to only retrieve the size of the shortcut bar pane item caption.

Panes of the shortcut bar are displayed in the shortcut bar's client area. Each pane consists of a caption and one or more sub-panes. Each sub-pane has its own caption and is drawn by the DrawPaneItemCaption method.

The caption of the shortcut bar pane item is set when the pane item is created by the CXTPShortcutBarPane::AddItem method.

The sub-items of a shortcut bar pane can be retrieved by using the CXTPShortcutBarPane::GetItem method.

Returns
The size of the shortcut pane item caption.

Reimplemented from CXTPShortcutBarOffice2013Theme.

◆ FillNavigationItemEntry()

virtual void FillNavigationItemEntry | ( | CDC * | pDC,
 |  | CXTPShortcutBarItem * | pItem )
 virtual

Fills a specified navigation item for the minimized shortcut bar control.

Parameters
pDC | Pointer to the client device context.
pItem | Pointer to the CXTPShortcutBarItem object to be filled.

Reimplemented from CXTPShortcutBarOffice2013Theme.

◆ FillShortcutItemEntry()

virtual void FillShortcutItemEntry | ( | CDC * | pDC,
 |  | CXTPShortcutBarItem * | pItem )
 virtual

Fills a specified item for the shortcut bar control.

Parameters
pDC | Pointer to the client device context.
pItem | Pointer to the CXTPShortcutBarItem object to be filled.

Implements CXTPShortcutBarPaintManager.

◆ RefreshMetrics()

virtual void RefreshMetrics ( )
virtual

Refreshes the visual metrics of the shortcut bar paint manager.

This method refreshes all of the visual metrics of the shortcut bar (pane caption color, pane font, pane caption height, etc.).

Reimplemented from CXTPShortcutBarOffice2013Theme.

The documentation for this class was generated from the following file:
  • XTPShortcutBarNativeWindows10Theme.h


Toolkit Pro: CXTPShortcutBarNativeWindows11Theme Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPShortcutBarNativeWindows11Theme Class Reference

CXTPShortcutBarNativeWindows11Theme is a CXTPShortcutBarOffice2013Theme derived class that represents a Native Windows 10 shortcut bar theme. More...

Inheritance diagram for CXTPShortcutBarNativeWindows11Theme:
[legend]

Public Member Functions

CXTPShortcutBarNativeWindows11Theme ()
Constructs a CXTPShortcutBarNativeWindows11Theme object.
virtual | ~CXTPShortcutBarNativeWindows11Theme ()
Destroys a CXTPShortcutBarNativeWindows11Theme object, handles cleanup and deallocation.
virtual void | RefreshMetrics ()
Refreshes the visual metrics of the shortcut bar paint manager.
virtual int | DrawPaneItemCaption (CDC *pDC, CXTPShortcutBarPaneItem *pItem, BOOL bDraw)
Draws the caption for a specified shortcut bar pane item.
virtual void | FillShortcutItemEntry (CDC *pDC, CXTPShortcutBarItem *pItem)
Fills a specified item for the shortcut bar control.
virtual void | FillNavigationItemEntry (CDC *pDC, CXTPShortcutBarItem *pItem)
Fills a specified navigation item for the minimized shortcut bar control.
- Public Member Functions inherited from CXTPShortcutBarOffice2013Theme
CXTPShortcutBarOffice2013Theme ()
Constructs a CXTPShortcutBarOffice2013Theme object.
virtual | ~CXTPShortcutBarOffice2013Theme ()
Destroys a CXTPShortcutBarOffice2013Theme object, handles cleanup and deallocation.
virtual void | DrawExpandButton (CDC *pDC, CRect rc)
Draws the expand button.
virtual int | DrawGripper (CDC *pDC, CXTPShortcutBar *pShortcutBar, BOOL bDraw)
Draws the gripper for the shortcut bar control.
void | FillShortcutItemEntry (CDC *pDC, CXTPShortcutBarItem *pItem)
Fills a specified item for the shortcut bar control.
virtual void | FillShortcutBar (CDC *pDC, CXTPShortcutBar *pShortcutBar)
Fills the client area of the shortcut bar control.
- Public Member Functions inherited from CXTPShortcutBarResourceTheme
CXTPShortcutBarResourceTheme ()
Constructs a CXTPShortcutBarResourceTheme object.
void | FillShortcutItemEntry (CDC *pDC, CXTPShortcutBarItem *pItem)
Fills a specified item for the shortcut bar control.
void | FillShortcutBar (CDC *pDC, CXTPShortcutBar *pShortcutBar)
Fills the client area of the shortcut bar control.
virtual int | DrawPaneCaption (CDC *pDC, CXTPShortcutBarPane *pPane, BOOL bDraw)
Draws the caption for a specified shortcut bar pane.
- Public Member Functions inherited from CXTPShortcutBarOffice2003Theme
CXTPShortcutBarOffice2003Theme ()
Constructs a CXTPShortcutBarOffice2003Theme object.
void | DrawShortcutBarFrame (CDC *pDC, CXTPShortcutBar *pShortcutBar)
Draws the frame for the shortcut bar control.
void | DrawImage (CDC *pDC, CPoint pt, CSize sz, CXTPImageManagerIcon *pImage, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled)
Draws the image of a shortcut bar item.
- Public Member Functions inherited from CXTPShortcutBarPaintManager
CXTPShortcutBarPaintManager ()
Constructs a CXTPShortcutBarPaintManager object.
virtual | ~CXTPShortcutBarPaintManager ()
Destroys a CXTPShortcutBarPaintManager object, handles cleanup and deallocation.
virtual void | DrawShortcutItem (CDC *pDC, CXTPShortcutBarItem *pItem)
Draws a specified item for the shortcut bar control.
virtual void | DrawNavigationItem (CDC *pDC, CXTPShortcutBarItem *pItem)
Draws a specified navigation item for the minimized shortcut bar control.
void | Rectangle (CDC *pDC, CRect rc, int nPen, int nBrush)
Draws the rectangle to be used to draw the shortcut bar items.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1, int nPen)
Draws the "gripper" lines in the gripper.
BOOL | IsShortcutItemTruncated (CDC *pDC, CXTPShortcutBarItem *pItem)
Determines if the caption text of a specified expanded shortcut bar item has been truncated.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Attributes

BOOL | m_bHiliteBorders
TRUE to draw borders around highlighted items.
CXTPPaintManagerColor | m_clrBorderHilite
Highlighted border color.
CXTPPaintManagerColor | m_clrBackHiliteSelected
Selected highlighted background color.
- Protected Attributes inherited from CXTPShortcutBarOffice2013Theme
CXTPPaintManagerColor | m_clrGlyph
Normal glyph color.
CXTPPaintManagerColor | m_clrGlyphFill
Expanded glyph fill color.
CXTPPaintManagerColor | m_clrGlyphExpanded
Expanded glyph border color.
CXTPPaintManagerColor | m_clrGlyphPushed
Pushed glyph color.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPShortcutBarResourceTheme
- Public Attributes inherited from CXTPShortcutBarOffice2003Theme
CXTPPaintManagerColorGradient | m_grcCaption
Caption color.
CXTPPaintManagerColorGradient | m_grcItemCaption
Items color.
CXTPPaintManagerColorGradient | m_grcItemHotCaption
Items color.
CXTPPaintManagerColor | m_clrItemCaptionShadow
Color of sub-caption shadow.
CXTPPaintManagerColor | m_clrItemCaptionTop
Color under sub-caption rectangle.
CXTPPaintManagerColor | m_clrCaptionText
Color of items text.
CXTPPaintManagerColor | m_clrItemCaptionText
Color of sub-caption text.
BOOL | m_bShowTopLeftCaptionShadow
TRUE to draw rectangle around items.
- Public Attributes inherited from CXTPShortcutBarPaintManager
CXTPFont | m_xtpFontText
Text font.
CXTPFont | m_xtpFontPaneCaption
Caption font.
CXTPFont | m_xtpFontPaneItemCaption
Sub-caption font.
CXTPFont | m_xtpFontVerticalText
Navigation button text font.
int | m_nPaneItemHeight
Height of sub-pane caption.
CXTPImageManagerIcon * | m_pExpandIcon
Pointer to expand icon.
BOOL | m_bNavigationButton
TRUE if navigation button small.
int | m_nNormalIconWidth
Width of the icons.
int | m_nExpandedIconWidth
Width of the expanded icons.
BOOL | m_bBoldItemCaptionFont
TRUE to draw item with bold font.
BOOL | m_bClearTypeTextQuality
TRUE to use ClearType font.
BOOL | m_bUseStandardFont
TRUE to use standard font.
CRect | m_rcCaptionPadding
Padding of pane caption.
CRect | m_rcItemCaptionPadding
Padding of item caption.
CString | m_strOfficeFont
TRUE to use Office Tahoma font.
CXTPPaintManagerColor | m_clrPushedText
Color of caption text when an CXTPShortcutBarItem is pressed.
CXTPPaintManagerColor | m_clrSelectedText
Color of caption text when an CXTPShortcutBarItem is selected (this happens after the item is clicked).
CXTPPaintManagerColor | m_clrHotText
Color of caption text when the mouse cursor is positioned over an CXTPShortcutBarItem.
CXTPPaintManagerColor | m_clrNormalText
Color of caption text when an CXTPShortcutBarItem is displayed normally.
CXTPPaintManagerColor | m_clrDisabledText
Color of caption text when an CXTPShortcutBarItem is disabled.
CXTPPaintManagerColorGradient | m_grcSelected
Color gradient of currently selected item.
CXTPPaintManagerColorGradient m_grcHot
Color gradient of "hot" items.
CXTPPaintManagerColorGradient m_grcPushed
Color gradient of item when clicked on.
CXTPPaintManagerColorGradient | m_grcShortcutItem
Color gradient of shortcut bar items.
CXTPPaintManagerColor | m_clrShortcutItemShadow
Color of line border that goes around each item.
CXTPPaintManagerColorGradient | m_grcShortcutBarGripper
Color gradient used to draw the shortcut bar gripper.

Detailed Description

CXTPShortcutBarNativeWindows11Theme is a CXTPShortcutBarOffice2013Theme derived class that represents a Native Windows 10 shortcut bar theme.

Member Function Documentation

◆ DrawPaneItemCaption()

virtual int DrawPaneItemCaption | ( | CDC * | pDC,
 |  | CXTPShortcutBarPaneItem * | pItem,
 |  | BOOL | bDraw )
 virtual

Draws the caption for a specified shortcut bar pane item.

Parameters
pDC | Pointer to the client device context.
pItem | Pointer to the CXTPShortcutBarPaneItem object to be drawn.
bDraw | TRUE to draw the shortcut bar pane item caption, FALSE to only retrieve the size of the shortcut bar pane item caption.

Panes of the shortcut bar are displayed in the shortcut bar's client area. Each pane consists of a caption and one or more sub-panes. Each sub-pane has its own caption and is drawn by the DrawPaneItemCaption method.

The caption of the shortcut bar pane item is set when the pane item is created by the CXTPShortcutBarPane::AddItem method.

The sub-items of a shortcut bar pane can be retrieved by using the CXTPShortcutBarPane::GetItem method.

Returns
The size of the shortcut pane item caption.

Reimplemented from CXTPShortcutBarOffice2013Theme.

◆ FillNavigationItemEntry()

virtual void FillNavigationItemEntry | ( | CDC * | pDC,
 |  | CXTPShortcutBarItem * | pItem )
 virtual

Fills a specified navigation item for the minimized shortcut bar control.

Parameters
pDC | Pointer to the client device context.
pItem | Pointer to the CXTPShortcutBarItem object to be filled.

Reimplemented from CXTPShortcutBarOffice2013Theme.

◆ FillShortcutItemEntry()

virtual void FillShortcutItemEntry | ( | CDC * | pDC,
 |  | CXTPShortcutBarItem * | pItem )
 virtual

Fills a specified item for the shortcut bar control.

Parameters
pDC | Pointer to the client device context.
pItem | Pointer to the CXTPShortcutBarItem object to be filled.

Implements CXTPShortcutBarPaintManager.

◆ RefreshMetrics()

virtual void RefreshMetrics ( )
virtual

Refreshes the visual metrics of the shortcut bar paint manager.

This method refreshes all of the visual metrics of the shortcut bar (pane caption color, pane font, pane caption height, etc.).

Reimplemented from CXTPShortcutBarOffice2013Theme.

The documentation for this class was generated from the following file:
  • XTPShortcutBarNativeWindows11Theme.h


Toolkit Pro: CXTPShortcutBarNativeWinXPTheme Class Reference

Public Member Functions | List of all members
CXTPShortcutBarNativeWinXPTheme Class Reference

CXTPShortcutBarNativeWinXPTheme is a CXTPShortcutBarOffice2003Theme derived class that represents a Native Windows XP shortcut bar theme. More...

Inheritance diagram for CXTPShortcutBarNativeWinXPTheme:
[legend]

Public Member Functions

CXTPShortcutBarNativeWinXPTheme ()
Constructs a CXTPShortcutBarNativeWinXPTheme object.
~CXTPShortcutBarNativeWinXPTheme ()
Destroys a CXTPShortcutBarNativeWinXPTheme object, handles cleanup and deallocation.
void | RefreshMetrics ()
Refreshes the visual metrics of the shortcut bar paint manager.
void | FillShortcutBar (CDC *pDC, CXTPShortcutBar *pShortcutBar)
Fills the client area of the shortcut bar control.
void | FillShortcutItemEntry (CDC *pDC, CXTPShortcutBarItem *pItem)
Fills a specified item for the shortcut bar control.
- Public Member Functions inherited from CXTPShortcutBarOffice2003Theme
CXTPShortcutBarOffice2003Theme ()
Constructs a CXTPShortcutBarOffice2003Theme object.
void | DrawShortcutBarFrame (CDC *pDC, CXTPShortcutBar *pShortcutBar)
Draws the frame for the shortcut bar control.
void | FillShortcutItemEntry (CDC *pDC, CXTPShortcutBarItem *pItem)
Fills a specified item for the shortcut bar control.
int | DrawGripper (CDC *pDC, CXTPShortcutBar *pShortcutBar, BOOL bDraw)
Draws the gripper for the shortcut bar control.
int | DrawPaneCaption (CDC *pDC, CXTPShortcutBarPane *pPane, BOOL bDraw)
Draws the caption for a specified shortcut bar pane.
int | DrawPaneItemCaption (CDC *pDC, CXTPShortcutBarPaneItem *pItem, BOOL bDraw)
Draws the caption for a specified shortcut bar pane item.
void | RefreshMetrics ()
Refreshes the visual metrics of the shortcut bar paint manager.
void | DrawImage (CDC *pDC, CPoint pt, CSize sz, CXTPImageManagerIcon *pImage, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled)
Draws the image of a shortcut bar item.
void | FillNavigationItemEntry (CDC *pDC, CXTPShortcutBarItem *pItem)
Fills a specified navigation item for the minimized shortcut bar control.
- Public Member Functions inherited from CXTPShortcutBarPaintManager
CXTPShortcutBarPaintManager ()
Constructs a CXTPShortcutBarPaintManager object.
virtual | ~CXTPShortcutBarPaintManager ()
Destroys a CXTPShortcutBarPaintManager object, handles cleanup and deallocation.
virtual void | DrawShortcutItem (CDC *pDC, CXTPShortcutBarItem *pItem)
Draws a specified item for the shortcut bar control.
virtual void | DrawNavigationItem (CDC *pDC, CXTPShortcutBarItem *pItem)
Draws a specified navigation item for the minimized shortcut bar control.
virtual void | DrawExpandButton (CDC *pDC, CRect rc)
Draws the expand button.
void | Rectangle (CDC *pDC, CRect rc, int nPen, int nBrush)
Draws the rectangle to be used to draw the shortcut bar items.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1, int nPen)
Draws the "gripper" lines in the gripper.
BOOL | IsShortcutItemTruncated (CDC *pDC, CXTPShortcutBarItem *pItem)
Determines if the caption text of a specified expanded shortcut bar item has been truncated.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPShortcutBarOffice2003Theme
CXTPPaintManagerColorGradient | m_grcCaption
Caption color.
CXTPPaintManagerColorGradient | m_grcItemCaption
Items color.
CXTPPaintManagerColorGradient | m_grcItemHotCaption
Items color.
CXTPPaintManagerColor | m_clrItemCaptionShadow
Color of sub-caption shadow.
CXTPPaintManagerColor | m_clrItemCaptionTop
Color under sub-caption rectangle.
CXTPPaintManagerColor | m_clrCaptionText
Color of items text.
CXTPPaintManagerColor | m_clrItemCaptionText
Color of sub-caption text.
BOOL | m_bShowTopLeftCaptionShadow
TRUE to draw rectangle around items.
- Public Attributes inherited from CXTPShortcutBarPaintManager
CXTPFont | m_xtpFontText
Text font.
CXTPFont | m_xtpFontPaneCaption
Caption font.
CXTPFont | m_xtpFontPaneItemCaption
Sub-caption font.
CXTPFont | m_xtpFontVerticalText
Navigation button text font.
int | m_nPaneItemHeight
Height of sub-pane caption.
CXTPImageManagerIcon * | m_pExpandIcon
Pointer to expand icon.
BOOL | m_bNavigationButton
TRUE if navigation button small.
int | m_nNormalIconWidth
Width of the icons.
int | m_nExpandedIconWidth
Width of the expanded icons.
BOOL | m_bBoldItemCaptionFont
TRUE to draw item with bold font.
BOOL | m_bClearTypeTextQuality
TRUE to use ClearType font.
BOOL | m_bUseStandardFont
TRUE to use standard font.
CRect | m_rcCaptionPadding
Padding of pane caption.
CRect | m_rcItemCaptionPadding
Padding of item caption.
CString | m_strOfficeFont
TRUE to use Office Tahoma font.
CXTPPaintManagerColor | m_clrPushedText
Color of caption text when an CXTPShortcutBarItem is pressed.
CXTPPaintManagerColor | m_clrSelectedText
Color of caption text when an CXTPShortcutBarItem is selected (this happens after the item is clicked).
CXTPPaintManagerColor | m_clrHotText
Color of caption text when the mouse cursor is positioned over an CXTPShortcutBarItem.
CXTPPaintManagerColor | m_clrNormalText
Color of caption text when an CXTPShortcutBarItem is displayed normally.
CXTPPaintManagerColor | m_clrDisabledText
Color of caption text when an CXTPShortcutBarItem is disabled.
CXTPPaintManagerColorGradient | m_grcSelected
Color gradient of currently selected item.
CXTPPaintManagerColorGradient m_grcHot
Color gradient of "hot" items.
CXTPPaintManagerColorGradient m_grcPushed
Color gradient of item when clicked on.
CXTPPaintManagerColorGradient | m_grcShortcutItem
Color gradient of shortcut bar items.
CXTPPaintManagerColor | m_clrShortcutItemShadow
Color of line border that goes around each item.
CXTPPaintManagerColorGradient | m_grcShortcutBarGripper
Color gradient used to draw the shortcut bar gripper.

Detailed Description

CXTPShortcutBarNativeWinXPTheme is a CXTPShortcutBarOffice2003Theme derived class that represents a Native Windows XP shortcut bar theme.

Member Function Documentation

◆ FillShortcutBar()

void FillShortcutBar | ( | CDC * | pDC,
 |  | CXTPShortcutBar * | pShortcutBar )
 virtual

Fills the client area of the shortcut bar control.

Parameters
pDC | Pointer to the client device context.
pShortcutBar | Pointer to the shortcut bar control.

Reimplemented from CXTPShortcutBarOffice2003Theme.

◆ FillShortcutItemEntry()

void FillShortcutItemEntry | ( | CDC * | pDC,
 |  | CXTPShortcutBarItem * | pItem )
 virtual

Fills a specified item for the shortcut bar control.

Parameters
pDC | Pointer to the client device context.
pItem | Pointer to the CXTPShortcutBarItem object to be filled.

Implements CXTPShortcutBarPaintManager.

◆ RefreshMetrics()

void RefreshMetrics ( )
virtual

Refreshes the visual metrics of the shortcut bar paint manager.

This method refreshes all of the visual metrics of the shortcut bar (pane caption color, pane font, pane caption height, etc.).

Reimplemented from CXTPShortcutBarPaintManager.

The documentation for this class was generated from the following file:
  • XTPShortcutBarNativeWinXPTheme.h


Toolkit Pro: CXTPShortcutBarOffice2000Theme Class Reference

Public Member Functions | List of all members
CXTPShortcutBarOffice2000Theme Class Reference

CXTPShortcutBarOffice2000Theme is a CXTPShortcutBarPaintManager derived class that represents an Office 2000 shortcut bar theme. More...

Inheritance diagram for CXTPShortcutBarOffice2000Theme:
[legend]

Public Member Functions

void | FillShortcutBar (CDC *pDC, CXTPShortcutBar *pShortcutBar)
Fills the client area of the shortcut bar control.
void | DrawShortcutBarFrame (CDC *pDC, CXTPShortcutBar *pShortcutBar)
Draws the frame for the shortcut bar control.
void | FillShortcutItemEntry (CDC *pDC, CXTPShortcutBarItem *pItem)
Fills a specified item for the shortcut bar control.
int | DrawGripper (CDC *pDC, CXTPShortcutBar *pShortcutBar, BOOL bDraw)
Draws the gripper for the shortcut bar control.
void | Rectangle (CDC *pDC, CRect rc, int nPen, int nBrush)
Draws the rectangle to be used to draw the shortcut bar items.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1, int nPen)
Draws the "gripper" lines in the gripper.
void | DrawImage (CDC *pDC, CPoint pt, CSize sz, CXTPImageManagerIcon *pImage, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled)
Draws the image of a shortcut bar item.
- Public Member Functions inherited from CXTPShortcutBarPaintManager
CXTPShortcutBarPaintManager ()
Constructs a CXTPShortcutBarPaintManager object.
virtual | ~CXTPShortcutBarPaintManager ()
Destroys a CXTPShortcutBarPaintManager object, handles cleanup and deallocation.
virtual void | RefreshMetrics ()
Refreshes the visual metrics of the shortcut bar paint manager.
virtual void | DrawShortcutItem (CDC *pDC, CXTPShortcutBarItem *pItem)
Draws a specified item for the shortcut bar control.
virtual int | DrawPaneCaption (CDC *pDC, CXTPShortcutBarPane *pPane, BOOL bDraw)
Draws the caption for a specified shortcut bar pane.
virtual int | DrawPaneItemCaption (CDC *pDC, CXTPShortcutBarPaneItem *pItem, BOOL bDraw)
Draws the caption for a specified shortcut bar pane item.
virtual void | DrawNavigationItem (CDC *pDC, CXTPShortcutBarItem *pItem)
Draws a specified navigation item for the minimized shortcut bar control.
virtual void | FillNavigationItemEntry (CDC *pDC, CXTPShortcutBarItem *pItem)
Fills a specified navigation item for the minimized shortcut bar control.
virtual void | DrawExpandButton (CDC *pDC, CRect rc)
Draws the expand button.
void | Rectangle (CDC *pDC, CRect rc, int nPen, int nBrush)
Draws the rectangle to be used to draw the shortcut bar items.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1, int nPen)
Draws the "gripper" lines in the gripper.
BOOL | IsShortcutItemTruncated (CDC *pDC, CXTPShortcutBarItem *pItem)
Determines if the caption text of a specified expanded shortcut bar item has been truncated.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPShortcutBarPaintManager
CXTPFont | m_xtpFontText
Text font.
CXTPFont | m_xtpFontPaneCaption
Caption font.
CXTPFont | m_xtpFontPaneItemCaption
Sub-caption font.
CXTPFont | m_xtpFontVerticalText
Navigation button text font.
int | m_nPaneItemHeight
Height of sub-pane caption.
CXTPImageManagerIcon * | m_pExpandIcon
Pointer to expand icon.
BOOL | m_bNavigationButton
TRUE if navigation button small.
int | m_nNormalIconWidth
Width of the icons.
int | m_nExpandedIconWidth
Width of the expanded icons.
BOOL | m_bBoldItemCaptionFont
TRUE to draw item with bold font.
BOOL | m_bClearTypeTextQuality
TRUE to use ClearType font.
BOOL | m_bUseStandardFont
TRUE to use standard font.
CRect | m_rcCaptionPadding
Padding of pane caption.
CRect | m_rcItemCaptionPadding
Padding of item caption.
CString | m_strOfficeFont
TRUE to use Office Tahoma font.
CXTPPaintManagerColor | m_clrPushedText
Color of caption text when an CXTPShortcutBarItem is pressed.
CXTPPaintManagerColor | m_clrSelectedText
Color of caption text when an CXTPShortcutBarItem is selected (this happens after the item is clicked).
CXTPPaintManagerColor | m_clrHotText
Color of caption text when the mouse cursor is positioned over an CXTPShortcutBarItem.
CXTPPaintManagerColor | m_clrNormalText
Color of caption text when an CXTPShortcutBarItem is displayed normally.
CXTPPaintManagerColor | m_clrDisabledText
Color of caption text when an CXTPShortcutBarItem is disabled.
CXTPPaintManagerColorGradient | m_grcSelected
Color gradient of currently selected item.
CXTPPaintManagerColorGradient m_grcHot
Color gradient of "hot" items.
CXTPPaintManagerColorGradient m_grcPushed
Color gradient of item when clicked on.
CXTPPaintManagerColorGradient | m_grcShortcutItem
Color gradient of shortcut bar items.
CXTPPaintManagerColor | m_clrShortcutItemShadow
Color of line border that goes around each item.
CXTPPaintManagerColorGradient | m_grcShortcutBarGripper
Color gradient used to draw the shortcut bar gripper.

Detailed Description

CXTPShortcutBarOffice2000Theme is a CXTPShortcutBarPaintManager derived class that represents an Office 2000 shortcut bar theme.

Member Function Documentation

◆ DrawGripper()

int DrawGripper | ( | CDC * | pDC,
 |  | CXTPShortcutBar * | pShortcutBar,
 |  | BOOL | bDraw )
 virtual

Draws the gripper for the shortcut bar control.

Parameters
pDC | Pointer to the client device context.
pShortcutBar | Pointer to the shortcut bar control.
bDraw | TRUE to draw the gripper, FALSE to only retrieve the size of the gripper.
Returns
The size of the gripper (i.e. 5 pixels for Office 2000 theme).

Implements CXTPShortcutBarPaintManager.

◆ DrawImage()

void DrawImage | ( | CDC * | pDC,
 |  | CPoint | pt,
 |  | CSize | sz,
 |  | CXTPImageManagerIcon * | pImage,
 |  | BOOL | bSelected,
 |  | BOOL | bPressed,
 |  | BOOL | bChecked,
 |  | BOOL | bEnabled )
 virtual

Draws the image of a shortcut bar item.

Parameters
pDC | Pointer to the client device context.
pt | Location at which to draw the image within the specified device context.
sz | Size of the image.
pImage | Pointer to a CXTPImageManagerIcon object.
bSelected | TRUE if the shortcut bar item is selected/has focus (i.e. when the user clicks on the item).
bPressed | TRUE if the shortcut bar item is currently pressed (i.e. when the user is clicking on the item).
bChecked | TRUE if the shortcut bar item is checked (i.e. toggle buttons).
bEnabled | TRUE to draw the item as enabled, FALSE to draw the item as disabled.

The DrawShortcutItem method uses this method to draw shortcut bar images.

Implements CXTPShortcutBarPaintManager.

◆ DrawShortcutBarFrame()

void DrawShortcutBarFrame | ( | CDC * | pDC,
 |  | CXTPShortcutBar * | pShortcutBar )
 virtual

Draws the frame for the shortcut bar control.

Parameters
pDC | Pointer to the client device context.
pShortcutBar | Pointer to the shortcut bar control.

The frame is the border drawn around the entire shortcut bar.

Implements CXTPShortcutBarPaintManager.

◆ FillShortcutBar()

void FillShortcutBar | ( | CDC * | pDC,
 |  | CXTPShortcutBar * | pShortcutBar )
 virtual

Fills the client area of the shortcut bar control.

Parameters
pDC | Pointer to the client device context.
pShortcutBar | Pointer to the shortcut bar control.

Implements CXTPShortcutBarPaintManager.

◆ FillShortcutItemEntry()

void FillShortcutItemEntry | ( | CDC * | pDC,
 |  | CXTPShortcutBarItem * | pItem )
 virtual

Fills a specified item for the shortcut bar control.

Parameters
pDC | Pointer to the client device context.
pItem | Pointer to the CXTPShortcutBarItem object to be filled.

Implements CXTPShortcutBarPaintManager.

◆ Line()

void Line | ( | CDC * | pDC,
 |  | int | x0,
 |  | int | y0,
 |  | int | x1,
 |  | int | y1,
 |  | int | nPen )

Draws the "gripper" lines in the gripper.

Parameters
pDC | Pointer to the client device context.
x0 | Specifies the logical x- coordinate of the start position of the line.
y0 | Specifies the logical y- coordinate of the start position of the line.
x1 | Specifies the logical x- coordinate of the end position of the line.
y1 | Specifies the logical y- coordinate of the end position of the line.
nPen | Specifies the color used to paint the line.

◆ Rectangle()

void Rectangle | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | int | nPen,
 |  | int | nBrush )

Draws the rectangle to be used to draw the shortcut bar items.

Parameters
pDC | Pointer to a valid device context.
rc | Specifies the rectangle in logical units.
nPen | Specifies the color used to paint the rectangle.
nBrush | Specifies the color used to fill the rectangle.

Rectangle is used to draw the rectangle of the shortcut bar items in the Office XP theme. This will draw the normal, pressed, and hot versions of the items.

The documentation for this class was generated from the following file:
  • XTPShortcutBarOffice2000Theme.h


Toolkit Pro: CXTPShortcutBarOffice2003Theme Class Reference

Public Member Functions | Public Attributes | List of all members
CXTPShortcutBarOffice2003Theme Class Reference

CXTPShortcutBarOffice2003Theme is a CXTPShortcutBarPaintManager derived class that represents an Office 2003 shortcut bar theme. More...

Inheritance diagram for CXTPShortcutBarOffice2003Theme:
[legend]

Public Member Functions

CXTPShortcutBarOffice2003Theme ()
Constructs a CXTPShortcutBarOffice2003Theme object.
virtual void | FillShortcutBar (CDC *pDC, CXTPShortcutBar *pShortcutBar)
Fills the client area of the shortcut bar control.
void | DrawShortcutBarFrame (CDC *pDC, CXTPShortcutBar *pShortcutBar)
Draws the frame for the shortcut bar control.
void | FillShortcutItemEntry (CDC *pDC, CXTPShortcutBarItem *pItem)
Fills a specified item for the shortcut bar control.
int | DrawGripper (CDC *pDC, CXTPShortcutBar *pShortcutBar, BOOL bDraw)
Draws the gripper for the shortcut bar control.
int | DrawPaneCaption (CDC *pDC, CXTPShortcutBarPane *pPane, BOOL bDraw)
Draws the caption for a specified shortcut bar pane.
int | DrawPaneItemCaption (CDC *pDC, CXTPShortcutBarPaneItem *pItem, BOOL bDraw)
Draws the caption for a specified shortcut bar pane item.
void | RefreshMetrics ()
Refreshes the visual metrics of the shortcut bar paint manager.
void | DrawImage (CDC *pDC, CPoint pt, CSize sz, CXTPImageManagerIcon *pImage, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled)
Draws the image of a shortcut bar item.
void | FillNavigationItemEntry (CDC *pDC, CXTPShortcutBarItem *pItem)
Fills a specified navigation item for the minimized shortcut bar control.
- Public Member Functions inherited from CXTPShortcutBarPaintManager
CXTPShortcutBarPaintManager ()
Constructs a CXTPShortcutBarPaintManager object.
virtual | ~CXTPShortcutBarPaintManager ()
Destroys a CXTPShortcutBarPaintManager object, handles cleanup and deallocation.
virtual void | DrawShortcutItem (CDC *pDC, CXTPShortcutBarItem *pItem)
Draws a specified item for the shortcut bar control.
virtual void | DrawNavigationItem (CDC *pDC, CXTPShortcutBarItem *pItem)
Draws a specified navigation item for the minimized shortcut bar control.
virtual void | DrawExpandButton (CDC *pDC, CRect rc)
Draws the expand button.
void | Rectangle (CDC *pDC, CRect rc, int nPen, int nBrush)
Draws the rectangle to be used to draw the shortcut bar items.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1, int nPen)
Draws the "gripper" lines in the gripper.
BOOL | IsShortcutItemTruncated (CDC *pDC, CXTPShortcutBarItem *pItem)
Determines if the caption text of a specified expanded shortcut bar item has been truncated.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Public Attributes

CXTPPaintManagerColorGradient | m_grcCaption
Caption color.
CXTPPaintManagerColorGradient | m_grcItemCaption
Items color.
CXTPPaintManagerColorGradient | m_grcItemHotCaption
Items color.
CXTPPaintManagerColor | m_clrItemCaptionShadow
Color of sub-caption shadow.
CXTPPaintManagerColor | m_clrItemCaptionTop
Color under sub-caption rectangle.
CXTPPaintManagerColor | m_clrCaptionText
Color of items text.
CXTPPaintManagerColor | m_clrItemCaptionText
Color of sub-caption text.
BOOL | m_bShowTopLeftCaptionShadow
TRUE to draw rectangle around items.
- Public Attributes inherited from CXTPShortcutBarPaintManager
CXTPFont | m_xtpFontText
Text font.
CXTPFont | m_xtpFontPaneCaption
Caption font.
CXTPFont | m_xtpFontPaneItemCaption
Sub-caption font.
CXTPFont | m_xtpFontVerticalText
Navigation button text font.
int | m_nPaneItemHeight
Height of sub-pane caption.
CXTPImageManagerIcon * | m_pExpandIcon
Pointer to expand icon.
BOOL | m_bNavigationButton
TRUE if navigation button small.
int | m_nNormalIconWidth
Width of the icons.
int | m_nExpandedIconWidth
Width of the expanded icons.
BOOL | m_bBoldItemCaptionFont
TRUE to draw item with bold font.
BOOL | m_bClearTypeTextQuality
TRUE to use ClearType font.
BOOL | m_bUseStandardFont
TRUE to use standard font.
CRect | m_rcCaptionPadding
Padding of pane caption.
CRect | m_rcItemCaptionPadding
Padding of item caption.
CString | m_strOfficeFont
TRUE to use Office Tahoma font.
CXTPPaintManagerColor | m_clrPushedText
Color of caption text when an CXTPShortcutBarItem is pressed.
CXTPPaintManagerColor | m_clrSelectedText
Color of caption text when an CXTPShortcutBarItem is selected (this happens after the item is clicked).
CXTPPaintManagerColor | m_clrHotText
Color of caption text when the mouse cursor is positioned over an CXTPShortcutBarItem.
CXTPPaintManagerColor | m_clrNormalText
Color of caption text when an CXTPShortcutBarItem is displayed normally.
CXTPPaintManagerColor | m_clrDisabledText
Color of caption text when an CXTPShortcutBarItem is disabled.
CXTPPaintManagerColorGradient | m_grcSelected
Color gradient of currently selected item.
CXTPPaintManagerColorGradient m_grcHot
Color gradient of "hot" items.
CXTPPaintManagerColorGradient m_grcPushed
Color gradient of item when clicked on.
CXTPPaintManagerColorGradient | m_grcShortcutItem
Color gradient of shortcut bar items.
CXTPPaintManagerColor | m_clrShortcutItemShadow
Color of line border that goes around each item.
CXTPPaintManagerColorGradient | m_grcShortcutBarGripper
Color gradient used to draw the shortcut bar gripper.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

CXTPShortcutBarOffice2003Theme is a CXTPShortcutBarPaintManager derived class that represents an Office 2003 shortcut bar theme.

Member Function Documentation

◆ DrawGripper()

int DrawGripper | ( | CDC * | pDC,
 |  | CXTPShortcutBar * | pShortcutBar,
 |  | BOOL | bDraw )
 virtual

Draws the gripper for the shortcut bar control.

Parameters
pDC | Pointer to the client device context.
pShortcutBar | Pointer to the shortcut bar control.
bDraw | TRUE to draw the gripper, FALSE to only retrieve the size of the gripper.
Returns
The size of the gripper (i.e. 7 pixels for Office 2003 theme).

Implements CXTPShortcutBarPaintManager.

Reimplemented in CXTPShortcutBarOffice2013Theme, and CXTPShortcutBarResourceTheme.

◆ DrawImage()

void DrawImage | ( | CDC * | pDC,
 |  | CPoint | pt,
 |  | CSize | sz,
 |  | CXTPImageManagerIcon * | pImage,
 |  | BOOL | bSelected,
 |  | BOOL | bPressed,
 |  | BOOL | bChecked,
 |  | BOOL | bEnabled )
 virtual

Draws the image of a shortcut bar item.

Parameters
pDC | Pointer to the client device context.
pt | Location at which to draw the image within the specified device context.
sz | Size of the image.
pImage | Pointer to a CXTPImageManagerIcon object.
bSelected | TRUE if the shortcut bar item is selected/has focus (i.e. when the user clicks on the item).
bPressed | TRUE if the shortcut bar item is currently pressed (i.e. when the user is clicking on the item).
bChecked | TRUE if the shortcut bar item is checked (i.e. toggle buttons).
bEnabled | TRUE to draw the item as enabled, FALSE to draw the item as disabled.

The DrawShortcutItem method uses this method to draw shortcut bar images.

Implements CXTPShortcutBarPaintManager.

◆ DrawPaneCaption()

int DrawPaneCaption | ( | CDC * | pDC,
 |  | CXTPShortcutBarPane * | pPane,
 |  | BOOL | bDraw )
 virtual

Draws the caption for a specified shortcut bar pane.

Parameters
pDC | Pointer to the client device context.
pPane | Pointer to the CXTPShortcutBarPane object to be drawn.
bDraw | TRUE to draw the shortcut bar pane caption, FALSE to only retrieve the size of the shortcut bar pane caption.

Panes of the shortcut bar are displayed in the shortcut bar's client area. Each pane consists of a caption and one or more sub-panes. Each sub-pane has its own caption and is drawn by the DrawPaneItemCaption method.

The caption of the shortcut bar pane is the bar on the top the pane. The caption of the shortcut bar pane is set when the pane is created by the CXTPShortcutBarPane::Create method.

The caption of the shortcut bar pane can be retrieved by using the CXTPShortcutBarPane::GetCaption method.

Shortcut bar panes have sub-items which also have captions that are drawn by the DrawPaneItemCaption method.

Returns
The size of the shortcut pane caption (i.e. 24 pixels).

Reimplemented from CXTPShortcutBarPaintManager.

Reimplemented in CXTPShortcutBarResourceTheme.

◆ DrawPaneItemCaption()

int DrawPaneItemCaption | ( | CDC * | pDC,
 |  | CXTPShortcutBarPaneItem * | pItem,
 |  | BOOL | bDraw )
 virtual

Draws the caption for a specified shortcut bar pane item.

Parameters
pDC | Pointer to the client device context.
pItem | Pointer to the CXTPShortcutBarPaneItem object to be drawn.
bDraw | TRUE to draw the shortcut bar pane item caption, FALSE to only retrieve the size of the shortcut bar pane item caption.

Panes of the shortcut bar are displayed in the shortcut bar's client area. Each pane consists of a caption and one or more sub-panes. Each sub-pane has its own caption and is drawn by the DrawPaneItemCaption method.

The caption of the shortcut bar pane item is set when the pane item is created by the CXTPShortcutBarPane::AddItem method.

The sub-items of a shortcut bar pane can be retrieved by using the CXTPShortcutBarPane::GetItem method.

Returns
The size of the shortcut pane item caption.

Reimplemented from CXTPShortcutBarPaintManager.

Reimplemented in CXTPShortcutBarOffice2013Theme, CXTPShortcutBarResourceTheme, CXTPShortcutBarVisualStudio2015Theme, CXTPShortcutBarVisualStudio2017Theme, CXTPShortcutBarVisualStudio2019Theme, and CXTPShortcutBarVisualStudio2022Theme.

◆ DrawShortcutBarFrame()

void DrawShortcutBarFrame | ( | CDC * | pDC,
 |  | CXTPShortcutBar * | pShortcutBar )
 virtual

Draws the frame for the shortcut bar control.

Parameters
pDC | Pointer to the client device context.
pShortcutBar | Pointer to the shortcut bar control.

The frame is the border drawn around the entire shortcut bar.

Implements CXTPShortcutBarPaintManager.

◆ FillNavigationItemEntry()

void FillNavigationItemEntry | ( | CDC * | pDC,
 |  | CXTPShortcutBarItem * | pItem )
 virtual

Fills a specified navigation item for the minimized shortcut bar control.

Parameters
pDC | Pointer to the client device context.
pItem | Pointer to the CXTPShortcutBarItem object to be filled.

Reimplemented from CXTPShortcutBarPaintManager.

Reimplemented in CXTPShortcutBarOffice2013Theme, CXTPShortcutBarResourceTheme, CXTPShortcutBarVisualStudio2015Theme, CXTPShortcutBarVisualStudio2017Theme, CXTPShortcutBarVisualStudio2019Theme, and CXTPShortcutBarVisualStudio2022Theme.

◆ FillShortcutBar()

virtual void FillShortcutBar | ( | CDC * | pDC,
 |  | CXTPShortcutBar * | pShortcutBar )
 virtual

Fills the client area of the shortcut bar control.

Parameters
pDC | Pointer to the client device context.
pShortcutBar | Pointer to the shortcut bar control.

Implements CXTPShortcutBarPaintManager.

Reimplemented in CXTPShortcutBarNativeWinXPTheme, CXTPShortcutBarOffice2013Theme, and CXTPShortcutBarResourceTheme.

◆ FillShortcutItemEntry()

void FillShortcutItemEntry | ( | CDC * | pDC,
 |  | CXTPShortcutBarItem * | pItem )
 virtual

Fills a specified item for the shortcut bar control.

Parameters
pDC | Pointer to the client device context.
pItem | Pointer to the CXTPShortcutBarItem object to be filled.

Implements CXTPShortcutBarPaintManager.

Reimplemented in CXTPShortcutBarOffice2013Theme, CXTPShortcutBarResourceTheme, CXTPShortcutBarVisualStudio2015Theme, CXTPShortcutBarVisualStudio2017Theme, CXTPShortcutBarVisualStudio2019Theme, and CXTPShortcutBarVisualStudio2022Theme.

◆ RefreshMetrics()

void RefreshMetrics ( )
virtual

Refreshes the visual metrics of the shortcut bar paint manager.

This method refreshes all of the visual metrics of the shortcut bar (pane caption color, pane font, pane caption height, etc.).

If luna colors are enabled, then the shortcut bar will be colored to match the current system theme if the XTPCurrentSystemTheme is xtpSystemThemeBlue, xtpSystemThemeSilver, or xtpSystemThemeOlive.

Reimplemented from CXTPShortcutBarPaintManager.

Reimplemented in CXTPShortcutBarOffice2013Theme, CXTPShortcutBarResourceTheme, CXTPShortcutBarVisualStudio2015Theme, CXTPShortcutBarVisualStudio2017Theme, CXTPShortcutBarVisualStudio2019Theme, and CXTPShortcutBarVisualStudio2022Theme.

The documentation for this class was generated from the following file:
  • XTPShortcutBarOffice2003Theme.h


Toolkit Pro: CXTPShortcutBarOffice2013Theme Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPShortcutBarOffice2013Theme Class Reference

CXTPShortcutBarOffice2013Theme is a CXTPShortcutBarResourceTheme derived class that represents an Office 2013 shortcut bar theme. More...

Inheritance diagram for CXTPShortcutBarOffice2013Theme:
[legend]

Public Member Functions

CXTPShortcutBarOffice2013Theme ()
Constructs a CXTPShortcutBarOffice2013Theme object.
virtual | ~CXTPShortcutBarOffice2013Theme ()
Destroys a CXTPShortcutBarOffice2013Theme object, handles cleanup and deallocation.
virtual void | RefreshMetrics ()
Refreshes the visual metrics of the shortcut bar paint manager.
virtual int | DrawPaneItemCaption (CDC *pDC, CXTPShortcutBarPaneItem *pItem, BOOL bDraw)
Draws the caption for a specified shortcut bar pane item.
virtual void | DrawExpandButton (CDC *pDC, CRect rc)
Draws the expand button.
virtual int | DrawGripper (CDC *pDC, CXTPShortcutBar *pShortcutBar, BOOL bDraw)
Draws the gripper for the shortcut bar control.
void | FillShortcutItemEntry (CDC *pDC, CXTPShortcutBarItem *pItem)
Fills a specified item for the shortcut bar control.
virtual void | FillNavigationItemEntry (CDC *pDC, CXTPShortcutBarItem *pItem)
Fills a specified navigation item for the minimized shortcut bar control.
virtual void | FillShortcutBar (CDC *pDC, CXTPShortcutBar *pShortcutBar)
Fills the client area of the shortcut bar control.
- Public Member Functions inherited from CXTPShortcutBarResourceTheme
CXTPShortcutBarResourceTheme ()
Constructs a CXTPShortcutBarResourceTheme object.
void | FillShortcutItemEntry (CDC *pDC, CXTPShortcutBarItem *pItem)
Fills a specified item for the shortcut bar control.
void | FillShortcutBar (CDC *pDC, CXTPShortcutBar *pShortcutBar)
Fills the client area of the shortcut bar control.
virtual int | DrawPaneCaption (CDC *pDC, CXTPShortcutBarPane *pPane, BOOL bDraw)
Draws the caption for a specified shortcut bar pane.
- Public Member Functions inherited from CXTPShortcutBarOffice2003Theme
CXTPShortcutBarOffice2003Theme ()
Constructs a CXTPShortcutBarOffice2003Theme object.
void | DrawShortcutBarFrame (CDC *pDC, CXTPShortcutBar *pShortcutBar)
Draws the frame for the shortcut bar control.
void | DrawImage (CDC *pDC, CPoint pt, CSize sz, CXTPImageManagerIcon *pImage, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled)
Draws the image of a shortcut bar item.
- Public Member Functions inherited from CXTPShortcutBarPaintManager
CXTPShortcutBarPaintManager ()
Constructs a CXTPShortcutBarPaintManager object.
virtual | ~CXTPShortcutBarPaintManager ()
Destroys a CXTPShortcutBarPaintManager object, handles cleanup and deallocation.
virtual void | DrawShortcutItem (CDC *pDC, CXTPShortcutBarItem *pItem)
Draws a specified item for the shortcut bar control.
virtual void | DrawNavigationItem (CDC *pDC, CXTPShortcutBarItem *pItem)
Draws a specified navigation item for the minimized shortcut bar control.
void | Rectangle (CDC *pDC, CRect rc, int nPen, int nBrush)
Draws the rectangle to be used to draw the shortcut bar items.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1, int nPen)
Draws the "gripper" lines in the gripper.
BOOL | IsShortcutItemTruncated (CDC *pDC, CXTPShortcutBarItem *pItem)
Determines if the caption text of a specified expanded shortcut bar item has been truncated.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Attributes

CXTPPaintManagerColor | m_clrGlyph
Normal glyph color.
CXTPPaintManagerColor | m_clrGlyphFill
Expanded glyph fill color.
CXTPPaintManagerColor | m_clrGlyphExpanded
Expanded glyph border color.
CXTPPaintManagerColor | m_clrGlyphPushed
Pushed glyph color.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPShortcutBarResourceTheme
- Public Attributes inherited from CXTPShortcutBarOffice2003Theme
CXTPPaintManagerColorGradient | m_grcCaption
Caption color.
CXTPPaintManagerColorGradient | m_grcItemCaption
Items color.
CXTPPaintManagerColorGradient | m_grcItemHotCaption
Items color.
CXTPPaintManagerColor | m_clrItemCaptionShadow
Color of sub-caption shadow.
CXTPPaintManagerColor | m_clrItemCaptionTop
Color under sub-caption rectangle.
CXTPPaintManagerColor | m_clrCaptionText
Color of items text.
CXTPPaintManagerColor | m_clrItemCaptionText
Color of sub-caption text.
BOOL | m_bShowTopLeftCaptionShadow
TRUE to draw rectangle around items.
- Public Attributes inherited from CXTPShortcutBarPaintManager
CXTPFont | m_xtpFontText
Text font.
CXTPFont | m_xtpFontPaneCaption
Caption font.
CXTPFont | m_xtpFontPaneItemCaption
Sub-caption font.
CXTPFont | m_xtpFontVerticalText
Navigation button text font.
int | m_nPaneItemHeight
Height of sub-pane caption.
CXTPImageManagerIcon * | m_pExpandIcon
Pointer to expand icon.
BOOL | m_bNavigationButton
TRUE if navigation button small.
int | m_nNormalIconWidth
Width of the icons.
int | m_nExpandedIconWidth
Width of the expanded icons.
BOOL | m_bBoldItemCaptionFont
TRUE to draw item with bold font.
BOOL | m_bClearTypeTextQuality
TRUE to use ClearType font.
BOOL | m_bUseStandardFont
TRUE to use standard font.
CRect | m_rcCaptionPadding
Padding of pane caption.
CRect | m_rcItemCaptionPadding
Padding of item caption.
CString | m_strOfficeFont
TRUE to use Office Tahoma font.
CXTPPaintManagerColor | m_clrPushedText
Color of caption text when an CXTPShortcutBarItem is pressed.
CXTPPaintManagerColor | m_clrSelectedText
Color of caption text when an CXTPShortcutBarItem is selected (this happens after the item is clicked).
CXTPPaintManagerColor | m_clrHotText
Color of caption text when the mouse cursor is positioned over an CXTPShortcutBarItem.
CXTPPaintManagerColor | m_clrNormalText
Color of caption text when an CXTPShortcutBarItem is displayed normally.
CXTPPaintManagerColor | m_clrDisabledText
Color of caption text when an CXTPShortcutBarItem is disabled.
CXTPPaintManagerColorGradient | m_grcSelected
Color gradient of currently selected item.
CXTPPaintManagerColorGradient m_grcHot
Color gradient of "hot" items.
CXTPPaintManagerColorGradient m_grcPushed
Color gradient of item when clicked on.
CXTPPaintManagerColorGradient | m_grcShortcutItem
Color gradient of shortcut bar items.
CXTPPaintManagerColor | m_clrShortcutItemShadow
Color of line border that goes around each item.
CXTPPaintManagerColorGradient | m_grcShortcutBarGripper
Color gradient used to draw the shortcut bar gripper.

Detailed Description

CXTPShortcutBarOffice2013Theme is a CXTPShortcutBarResourceTheme derived class that represents an Office 2013 shortcut bar theme.

Member Function Documentation

◆ DrawExpandButton()

virtual void DrawExpandButton | ( | CDC * | pDC,
 |  | CRect | rc )
 virtual

Draws the expand button.

Parameters
pDC | Pointer to the client device context.
rc | Client rectangle of the expand button.

Reimplemented from CXTPShortcutBarResourceTheme.

◆ DrawGripper()

virtual int DrawGripper | ( | CDC * | pDC,
 |  | CXTPShortcutBar * | pShortcutBar,
 |  | BOOL | bDraw )
 virtual

Draws the gripper for the shortcut bar control.

Parameters
pDC | Pointer to the client device context.
pShortcutBar | Pointer to the shortcut bar control.
bDraw | TRUE to draw the gripper, FALSE to only retrieve the size of the gripper.
Returns
The size of the gripper (i.e. 7 pixels for Office 2013 theme).

Reimplemented from CXTPShortcutBarResourceTheme.

◆ DrawPaneItemCaption()

virtual int DrawPaneItemCaption | ( | CDC * | pDC,
 |  | CXTPShortcutBarPaneItem * | pItem,
 |  | BOOL | bDraw )
 virtual

Draws the caption for a specified shortcut bar pane item.

Parameters
pDC | Pointer to the client device context.
pItem | Pointer to the CXTPShortcutBarPaneItem object to be drawn.
bDraw | TRUE to draw the shortcut bar pane item caption, FALSE to only retrieve the size of the shortcut bar pane item caption.

Panes of the shortcut bar are displayed in the shortcut bar's client area. Each pane consists of a caption and one or more sub-panes. Each sub-pane has its own caption and is drawn by the DrawPaneItemCaption method.

The caption of the shortcut bar pane item is set when the pane item is created by the CXTPShortcutBarPane::AddItem method.

The sub-items of a shortcut bar pane can be retrieved by using the CXTPShortcutBarPane::GetItem method.

Returns
The size of the shortcut pane item caption.

Reimplemented from CXTPShortcutBarResourceTheme.

Reimplemented in CXTPShortcutBarNativeWindows10Theme, CXTPShortcutBarNativeWindows11Theme, CXTPShortcutBarVisualStudio2015Theme, CXTPShortcutBarVisualStudio2017Theme, CXTPShortcutBarVisualStudio2019Theme, and CXTPShortcutBarVisualStudio2022Theme.

◆ FillNavigationItemEntry()

virtual void FillNavigationItemEntry | ( | CDC * | pDC,
 |  | CXTPShortcutBarItem * | pItem )
 virtual

Fills a specified navigation item for the minimized shortcut bar control.

Parameters
pDC | Pointer to the client device context.
pItem | Pointer to the CXTPShortcutBarItem object to be filled.

Reimplemented from CXTPShortcutBarResourceTheme.

Reimplemented in CXTPShortcutBarNativeWindows10Theme, CXTPShortcutBarNativeWindows11Theme, CXTPShortcutBarVisualStudio2015Theme, CXTPShortcutBarVisualStudio2017Theme, CXTPShortcutBarVisualStudio2019Theme, and CXTPShortcutBarVisualStudio2022Theme.

◆ FillShortcutBar()

virtual void FillShortcutBar | ( | CDC * | pDC,
 |  | CXTPShortcutBar * | pShortcutBar )
 virtual

Fills the client area of the shortcut bar control.

Parameters
pDC | Pointer to the client device context.
pShortcutBar | Pointer to the shortcut bar control.

Reimplemented from CXTPShortcutBarOffice2003Theme.

◆ FillShortcutItemEntry()

void FillShortcutItemEntry | ( | CDC * | pDC,
 |  | CXTPShortcutBarItem * | pItem )
 virtual

Fills a specified item for the shortcut bar control.

Parameters
pDC | Pointer to the client device context.
pItem | Pointer to the CXTPShortcutBarItem object to be filled.

Reimplemented from CXTPShortcutBarOffice2003Theme.

Reimplemented in CXTPShortcutBarVisualStudio2015Theme, CXTPShortcutBarVisualStudio2017Theme, CXTPShortcutBarVisualStudio2019Theme, and CXTPShortcutBarVisualStudio2022Theme.

◆ RefreshMetrics()

virtual void RefreshMetrics ( )
virtual

Refreshes the visual metrics of the shortcut bar paint manager.

This method refreshes all of the visual metrics of the shortcut bar (pane caption color, pane font, pane caption height, etc.).

Reimplemented from CXTPShortcutBarResourceTheme.

Reimplemented in CXTPShortcutBarNativeWindows10Theme, CXTPShortcutBarNativeWindows11Theme, CXTPShortcutBarVisualStudio2015Theme, CXTPShortcutBarVisualStudio2017Theme, CXTPShortcutBarVisualStudio2019Theme, and CXTPShortcutBarVisualStudio2022Theme.

The documentation for this class was generated from the following file:
  • XTPShortcutBarOffice2013Theme.h


Toolkit Pro: CXTPShortcutBarOfficeXPTheme Class Reference

Public Member Functions | List of all members
CXTPShortcutBarOfficeXPTheme Class Reference

CXTPShortcutBarOfficeXPTheme is a CXTPShortcutBarPaintManager derived class that represents an Office XP shortcut bar theme. More...

Inheritance diagram for CXTPShortcutBarOfficeXPTheme:
[legend]

Public Member Functions

void | FillShortcutBar (CDC *pDC, CXTPShortcutBar *pShortcutBar)
Fills the client area of the shortcut bar control.
void | DrawShortcutBarFrame (CDC *pDC, CXTPShortcutBar *pShortcutBar)
Draws the frame for the shortcut bar control.
void | FillShortcutItemEntry (CDC *pDC, CXTPShortcutBarItem *pItem)
Fills a specified item for the shortcut bar control.
int | DrawGripper (CDC *pDC, CXTPShortcutBar *pShortcutBar, BOOL bDraw)
Draws the gripper for the shortcut bar control.
void | DrawImage (CDC *pDC, CPoint pt, CSize sz, CXTPImageManagerIcon *pImage, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled)
Draws the image of a shortcut bar item.
- Public Member Functions inherited from CXTPShortcutBarPaintManager
CXTPShortcutBarPaintManager ()
Constructs a CXTPShortcutBarPaintManager object.
virtual | ~CXTPShortcutBarPaintManager ()
Destroys a CXTPShortcutBarPaintManager object, handles cleanup and deallocation.
virtual void | RefreshMetrics ()
Refreshes the visual metrics of the shortcut bar paint manager.
virtual void | DrawShortcutItem (CDC *pDC, CXTPShortcutBarItem *pItem)
Draws a specified item for the shortcut bar control.
virtual int | DrawPaneCaption (CDC *pDC, CXTPShortcutBarPane *pPane, BOOL bDraw)
Draws the caption for a specified shortcut bar pane.
virtual int | DrawPaneItemCaption (CDC *pDC, CXTPShortcutBarPaneItem *pItem, BOOL bDraw)
Draws the caption for a specified shortcut bar pane item.
virtual void | DrawNavigationItem (CDC *pDC, CXTPShortcutBarItem *pItem)
Draws a specified navigation item for the minimized shortcut bar control.
virtual void | FillNavigationItemEntry (CDC *pDC, CXTPShortcutBarItem *pItem)
Fills a specified navigation item for the minimized shortcut bar control.
virtual void | DrawExpandButton (CDC *pDC, CRect rc)
Draws the expand button.
void | Rectangle (CDC *pDC, CRect rc, int nPen, int nBrush)
Draws the rectangle to be used to draw the shortcut bar items.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1, int nPen)
Draws the "gripper" lines in the gripper.
BOOL | IsShortcutItemTruncated (CDC *pDC, CXTPShortcutBarItem *pItem)
Determines if the caption text of a specified expanded shortcut bar item has been truncated.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPShortcutBarPaintManager
CXTPFont | m_xtpFontText
Text font.
CXTPFont | m_xtpFontPaneCaption
Caption font.
CXTPFont | m_xtpFontPaneItemCaption
Sub-caption font.
CXTPFont | m_xtpFontVerticalText
Navigation button text font.
int | m_nPaneItemHeight
Height of sub-pane caption.
CXTPImageManagerIcon * | m_pExpandIcon
Pointer to expand icon.
BOOL | m_bNavigationButton
TRUE if navigation button small.
int | m_nNormalIconWidth
Width of the icons.
int | m_nExpandedIconWidth
Width of the expanded icons.
BOOL | m_bBoldItemCaptionFont
TRUE to draw item with bold font.
BOOL | m_bClearTypeTextQuality
TRUE to use ClearType font.
BOOL | m_bUseStandardFont
TRUE to use standard font.
CRect | m_rcCaptionPadding
Padding of pane caption.
CRect | m_rcItemCaptionPadding
Padding of item caption.
CString | m_strOfficeFont
TRUE to use Office Tahoma font.
CXTPPaintManagerColor | m_clrPushedText
Color of caption text when an CXTPShortcutBarItem is pressed.
CXTPPaintManagerColor | m_clrSelectedText
Color of caption text when an CXTPShortcutBarItem is selected (this happens after the item is clicked).
CXTPPaintManagerColor | m_clrHotText
Color of caption text when the mouse cursor is positioned over an CXTPShortcutBarItem.
CXTPPaintManagerColor | m_clrNormalText
Color of caption text when an CXTPShortcutBarItem is displayed normally.
CXTPPaintManagerColor | m_clrDisabledText
Color of caption text when an CXTPShortcutBarItem is disabled.
CXTPPaintManagerColorGradient | m_grcSelected
Color gradient of currently selected item.
CXTPPaintManagerColorGradient m_grcHot
Color gradient of "hot" items.
CXTPPaintManagerColorGradient m_grcPushed
Color gradient of item when clicked on.
CXTPPaintManagerColorGradient | m_grcShortcutItem
Color gradient of shortcut bar items.
CXTPPaintManagerColor | m_clrShortcutItemShadow
Color of line border that goes around each item.
CXTPPaintManagerColorGradient | m_grcShortcutBarGripper
Color gradient used to draw the shortcut bar gripper.

Detailed Description

CXTPShortcutBarOfficeXPTheme is a CXTPShortcutBarPaintManager derived class that represents an Office XP shortcut bar theme.

Member Function Documentation

◆ DrawGripper()

int DrawGripper | ( | CDC * | pDC,
 |  | CXTPShortcutBar * | pShortcutBar,
 |  | BOOL | bDraw )
 virtual

Draws the gripper for the shortcut bar control.

Parameters
pDC | Pointer to the client device context.
pShortcutBar | Pointer to the shortcut bar control.
bDraw | TRUE to draw the gripper, FALSE to only retrieve the size of the gripper.
Returns
The size of the gripper (i.e. 8 pixels for Office XP theme).

Implements CXTPShortcutBarPaintManager.

◆ DrawImage()

void DrawImage | ( | CDC * | pDC,
 |  | CPoint | pt,
 |  | CSize | sz,
 |  | CXTPImageManagerIcon * | pImage,
 |  | BOOL | bSelected,
 |  | BOOL | bPressed,
 |  | BOOL | bChecked,
 |  | BOOL | bEnabled )
 virtual

Draws the image of a shortcut bar item.

Parameters
pDC | Pointer to the client device context.
pt | Location at which to draw the image within the specified device context.
sz | Size of the image.
pImage | Pointer to a CXTPImageManagerIcon object.
bSelected | TRUE if the shortcut bar item is selected/has focus (i.e. when the user clicks on the item).
bPressed | TRUE if the shortcut bar item is currently pressed (i.e. when the user is clicking on the item).
bChecked | TRUE if the shortcut bar item is checked (i.e. toggle buttons).
bEnabled | TRUE to draw the item as enabled, FALSE to draw the item as disabled.

The DrawShortcutItem method uses this method to draw shortcut bar images.

Implements CXTPShortcutBarPaintManager.

◆ DrawShortcutBarFrame()

void DrawShortcutBarFrame | ( | CDC * | pDC,
 |  | CXTPShortcutBar * | pShortcutBar )
 virtual

Draws the frame for the shortcut bar control.

Parameters
pDC | Pointer to the client device context.
pShortcutBar | Pointer to the shortcut bar control.

The frame is the border drawn around the entire shortcut bar.

Implements CXTPShortcutBarPaintManager.

◆ FillShortcutBar()

void FillShortcutBar | ( | CDC * | pDC,
 |  | CXTPShortcutBar * | pShortcutBar )
 virtual

Fills the client area of the shortcut bar control.

Parameters
pDC | Pointer to the client device context.
pShortcutBar | Pointer to the shortcut bar control.

Implements CXTPShortcutBarPaintManager.

◆ FillShortcutItemEntry()

void FillShortcutItemEntry | ( | CDC * | pDC,
 |  | CXTPShortcutBarItem * | pItem )
 virtual

Fills a specified item for the shortcut bar control.

Parameters
pDC | Pointer to the client device context.
pItem | Pointer to the CXTPShortcutBarItem object to be filled.

Implements CXTPShortcutBarPaintManager.

The documentation for this class was generated from the following file:
  • XTPShortcutBarOfficeXPTheme.h


Toolkit Pro: CXTPShortcutBarPaintManager Class Reference

Public Member Functions | Public Attributes | List of all members
CXTPShortcutBarPaintManager Class Referenceabstract

CXTPShortcutBarPaintManager is a standalone class used as a paint manager for a shortcut bar control. More...

Inheritance diagram for CXTPShortcutBarPaintManager:
[legend]

Public Member Functions

CXTPShortcutBarPaintManager ()
Constructs a CXTPShortcutBarPaintManager object.
virtual | ~CXTPShortcutBarPaintManager ()
Destroys a CXTPShortcutBarPaintManager object, handles cleanup and deallocation.
virtual void | RefreshMetrics ()
Refreshes the visual metrics of the shortcut bar paint manager.
virtual void | DrawShortcutItem (CDC *pDC, CXTPShortcutBarItem *pItem)
Draws a specified item for the shortcut bar control.
virtual void | FillShortcutBar (CDC *pDC, CXTPShortcutBar *pShortcutBar)=0
Fills the client area of the shortcut bar control.
virtual void | DrawShortcutBarFrame (CDC *pDC, CXTPShortcutBar *pShortcutBar)=0
Draws the frame for the shortcut bar control.
virtual void | FillShortcutItemEntry (CDC *pDC, CXTPShortcutBarItem *pItem)=0
Fills a specified item for the shortcut bar control.
virtual int | DrawGripper (CDC *pDC, CXTPShortcutBar *pShortcutBar, BOOL bDraw)=0
Draws the gripper for the shortcut bar control.
virtual int | DrawPaneCaption (CDC *pDC, CXTPShortcutBarPane *pPane, BOOL bDraw)
Draws the caption for a specified shortcut bar pane.
virtual int | DrawPaneItemCaption (CDC *pDC, CXTPShortcutBarPaneItem *pItem, BOOL bDraw)
Draws the caption for a specified shortcut bar pane item.
virtual void | DrawNavigationItem (CDC *pDC, CXTPShortcutBarItem *pItem)
Draws a specified navigation item for the minimized shortcut bar control.
virtual void | FillNavigationItemEntry (CDC *pDC, CXTPShortcutBarItem *pItem)
Fills a specified navigation item for the minimized shortcut bar control.
virtual void | DrawExpandButton (CDC *pDC, CRect rc)
Draws the expand button.
virtual void | DrawImage (CDC *pDC, CPoint pt, CSize sz, CXTPImageManagerIcon *pImage, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled)=0
Draws the image of a shortcut bar item.
void | Rectangle (CDC *pDC, CRect rc, int nPen, int nBrush)
Draws the rectangle to be used to draw the shortcut bar items.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1, int nPen)
Draws the "gripper" lines in the gripper.
BOOL | IsShortcutItemTruncated (CDC *pDC, CXTPShortcutBarItem *pItem)
Determines if the caption text of a specified expanded shortcut bar item has been truncated.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Public Attributes

CXTPFont | m_xtpFontText
Text font.
CXTPFont | m_xtpFontPaneCaption
Caption font.
CXTPFont | m_xtpFontPaneItemCaption
Sub-caption font.
CXTPFont | m_xtpFontVerticalText
Navigation button text font.
int | m_nPaneItemHeight
Height of sub-pane caption.
CXTPImageManagerIcon * | m_pExpandIcon
Pointer to expand icon.
BOOL | m_bNavigationButton
TRUE if navigation button small.
int | m_nNormalIconWidth
Width of the icons.
int | m_nExpandedIconWidth
Width of the expanded icons.
BOOL | m_bBoldItemCaptionFont
TRUE to draw item with bold font.
BOOL | m_bClearTypeTextQuality
TRUE to use ClearType font.
BOOL | m_bUseStandardFont
TRUE to use standard font.
CRect | m_rcCaptionPadding
Padding of pane caption.
CRect | m_rcItemCaptionPadding
Padding of item caption.
CString | m_strOfficeFont
TRUE to use Office Tahoma font.
CXTPPaintManagerColor | m_clrPushedText
Color of caption text when an CXTPShortcutBarItem is pressed.
CXTPPaintManagerColor | m_clrSelectedText
Color of caption text when an CXTPShortcutBarItem is selected (this happens after the item is clicked).
CXTPPaintManagerColor | m_clrHotText
Color of caption text when the mouse cursor is positioned over an CXTPShortcutBarItem.
CXTPPaintManagerColor | m_clrNormalText
Color of caption text when an CXTPShortcutBarItem is displayed normally.
CXTPPaintManagerColor | m_clrDisabledText
Color of caption text when an CXTPShortcutBarItem is disabled.
CXTPPaintManagerColorGradient | m_grcSelected
Color gradient of currently selected item.
CXTPPaintManagerColorGradient m_grcHot
Color gradient of "hot" items.
CXTPPaintManagerColorGradient m_grcPushed
Color gradient of item when clicked on.
CXTPPaintManagerColorGradient | m_grcShortcutItem
Color gradient of shortcut bar items.
CXTPPaintManagerColor | m_clrShortcutItemShadow
Color of line border that goes around each item.
CXTPPaintManagerColorGradient | m_grcShortcutBarGripper
Color gradient used to draw the shortcut bar gripper.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

CXTPShortcutBarPaintManager is a standalone class used as a paint manager for a shortcut bar control.

Member Function Documentation

◆ DrawExpandButton()

virtual void DrawExpandButton | ( | CDC * | pDC,
 |  | CRect | rc )
 virtual

Draws the expand button.

Parameters
pDC | Pointer to the client device context.
rc | Client rectangle of the expand button.

Reimplemented in CXTPShortcutBarOffice2013Theme, and CXTPShortcutBarResourceTheme.

◆ DrawGripper()

virtual int DrawGripper | ( | CDC * | pDC,
 |  | CXTPShortcutBar * | pShortcutBar,
 |  | BOOL | bDraw )
 pure virtual

Draws the gripper for the shortcut bar control.

Parameters
pDC | Pointer to the client device context.
pShortcutBar | Pointer to the shortcut bar control.
bDraw | TRUE to draw the gripper, FALSE to only retrieve the size of the gripper.
Returns
The size of the gripper.

Implemented in CXTPShortcutBarOffice2000Theme, CXTPShortcutBarOffice2003Theme, CXTPShortcutBarOffice2013Theme, CXTPShortcutBarOfficeXPTheme, and CXTPShortcutBarResourceTheme.

◆ DrawImage()

virtual void DrawImage | ( | CDC * | pDC,
 |  | CPoint | pt,
 |  | CSize | sz,
 |  | CXTPImageManagerIcon * | pImage,
 |  | BOOL | bSelected,
 |  | BOOL | bPressed,
 |  | BOOL | bChecked,
 |  | BOOL | bEnabled )
 pure virtual

Draws the image of a shortcut bar item.

Parameters
pDC | Pointer to the client device context.
pt | Location at which to draw the image within the specified device context.
sz | Size of the image.
pImage | Pointer to a CXTPImageManagerIcon object.
bSelected | TRUE if the shortcut bar item is selected/has focus (i.e. when the user clicks on the item).
bPressed | TRUE if the shortcut bar item is currently pressed (i.e. when the user is clicking on the item).
bChecked | TRUE if the shortcut bar item is checked (i.e. toggle buttons).
bEnabled | TRUE to draw the item as enabled, FALSE to draw the item as disabled.

The DrawShortcutItem method uses this method to draw shortcut bar images.

Implemented in CXTPShortcutBarOffice2000Theme, CXTPShortcutBarOffice2003Theme, and CXTPShortcutBarOfficeXPTheme.

◆ DrawNavigationItem()

virtual void DrawNavigationItem | ( | CDC * | pDC,
 |  | CXTPShortcutBarItem * | pItem )
 virtual

Draws a specified navigation item for the minimized shortcut bar control.

Parameters
pDC | Pointer to the client device context.
pItem | Pointer to the CXTPShortcutBarItem object to be drawn.

◆ DrawPaneCaption()

virtual int DrawPaneCaption | ( | CDC * | pDC,
 |  | CXTPShortcutBarPane * | pPane,
 |  | BOOL | bDraw )
 virtual

Draws the caption for a specified shortcut bar pane.

Parameters
pDC | Pointer to the client device context.
pPane | Pointer to the CXTPShortcutBarPane object to be drawn.
bDraw | TRUE to draw the shortcut bar pane caption, FALSE to only retrieve the size of the shortcut bar pane caption.

Panes of the shortcut bar are displayed in the shortcut bar's client area. Each pane consists of a caption and one or more sub-panes. Each sub-pane has its own caption and is drawn by the DrawPaneItemCaption method.

The caption of the shortcut bar pane is the bar on the top the pane. The caption of the shortcut bar pane is set when the pane is created by the CXTPShortcutBarPane::Create method.

The caption of the shortcut bar pane can be retrieved by using the CXTPShortcutBarPane::GetCaption method.

Shortcut bar panes have sub-items which also have captions that are drawn by the DrawPaneItemCaption method.

Returns
The size of the shortcut pane caption (i.e. 24 pixels).

Reimplemented in CXTPShortcutBarOffice2003Theme, and CXTPShortcutBarResourceTheme.

◆ DrawPaneItemCaption()

virtual int DrawPaneItemCaption | ( | CDC * | pDC,
 |  | CXTPShortcutBarPaneItem * | pItem,
 |  | BOOL | bDraw )
 virtual

Draws the caption for a specified shortcut bar pane item.

Parameters
pDC | Pointer to the client device context.
pItem | Pointer to the CXTPShortcutBarPaneItem object to be drawn.
bDraw | TRUE to draw the shortcut bar pane item caption, FALSE to only retrieve the size of the shortcut bar pane item caption.

Panes of the shortcut bar are displayed in the shortcut bar's client area. Each pane consists of a caption and one or more sub-panes. Each sub-pane has its own caption and is drawn by the DrawPaneItemCaption method.

The caption of the shortcut bar pane item is set when the pane item is created by the CXTPShortcutBarPane::AddItem method.

The sub-items of a shortcut bar pane can be retrieved by using the CXTPShortcutBarPane::GetItem method.

Returns
The size of the shortcut pane item caption.

Reimplemented in CXTPShortcutBarNativeWindows10Theme, CXTPShortcutBarNativeWindows11Theme, CXTPShortcutBarOffice2003Theme, CXTPShortcutBarOffice2013Theme, CXTPShortcutBarResourceTheme, CXTPShortcutBarVisualStudio2015Theme, CXTPShortcutBarVisualStudio2017Theme, CXTPShortcutBarVisualStudio2019Theme, and CXTPShortcutBarVisualStudio2022Theme.

◆ DrawShortcutBarFrame()

virtual void DrawShortcutBarFrame | ( | CDC * | pDC,
 |  | CXTPShortcutBar * | pShortcutBar )
 pure virtual

Draws the frame for the shortcut bar control.

Parameters
pDC | Pointer to the client device context.
pShortcutBar | Pointer to the shortcut bar control.

The frame is the border drawn around the entire shortcut bar.

Implemented in CXTPShortcutBarOffice2000Theme, CXTPShortcutBarOffice2003Theme, and CXTPShortcutBarOfficeXPTheme.

◆ DrawShortcutItem()

virtual void DrawShortcutItem | ( | CDC * | pDC,
 |  | CXTPShortcutBarItem * | pItem )
 virtual

Draws a specified item for the shortcut bar control.

Parameters
pDC | Pointer to the client device context.
pItem | Pointer to the CXTPShortcutBarItem object to be drawn.

◆ FillNavigationItemEntry()

virtual void FillNavigationItemEntry | ( | CDC * | pDC,
 |  | CXTPShortcutBarItem * | pItem )
 virtual

Fills a specified navigation item for the minimized shortcut bar control.

Parameters
pDC | Pointer to the client device context.
pItem | Pointer to the CXTPShortcutBarItem object to be filled.

Reimplemented in CXTPShortcutBarNativeWindows10Theme, CXTPShortcutBarNativeWindows11Theme, CXTPShortcutBarOffice2003Theme, CXTPShortcutBarOffice2013Theme, CXTPShortcutBarResourceTheme, CXTPShortcutBarVisualStudio2015Theme, CXTPShortcutBarVisualStudio2017Theme, CXTPShortcutBarVisualStudio2019Theme, and CXTPShortcutBarVisualStudio2022Theme.

◆ FillShortcutBar()

virtual void FillShortcutBar | ( | CDC * | pDC,
 |  | CXTPShortcutBar * | pShortcutBar )
 pure virtual

Fills the client area of the shortcut bar control.

Parameters
pDC | Pointer to the client device context.
pShortcutBar | Pointer to the shortcut bar control.

Implemented in CXTPShortcutBarNativeWinXPTheme, CXTPShortcutBarOffice2000Theme, CXTPShortcutBarOffice2003Theme, CXTPShortcutBarOffice2013Theme, CXTPShortcutBarOfficeXPTheme, and CXTPShortcutBarResourceTheme.

◆ FillShortcutItemEntry()

virtual void FillShortcutItemEntry | ( | CDC * | pDC,
 |  | CXTPShortcutBarItem * | pItem )
 pure virtual

Fills a specified item for the shortcut bar control.

Parameters
pDC | Pointer to the client device context.
pItem | Pointer to the CXTPShortcutBarItem object to be filled.

Implemented in CXTPShortcutBarNativeWindows10Theme, CXTPShortcutBarNativeWindows11Theme, CXTPShortcutBarNativeWinXPTheme, CXTPShortcutBarOffice2000Theme, CXTPShortcutBarOffice2003Theme, CXTPShortcutBarOffice2013Theme, CXTPShortcutBarOfficeXPTheme, CXTPShortcutBarResourceTheme, CXTPShortcutBarVisualStudio2015Theme, CXTPShortcutBarVisualStudio2017Theme, CXTPShortcutBarVisualStudio2019Theme, and CXTPShortcutBarVisualStudio2022Theme.

◆ IsShortcutItemTruncated()

BOOL IsShortcutItemTruncated | ( | CDC * | pDC,
 |  | CXTPShortcutBarItem * | pItem )

Determines if the caption text of a specified expanded shortcut bar item has been truncated.

Parameters
pDC | Pointer to the client device context.
pItem | Pointer to the CXTPShortcutBarItem object to check.

The caption text of an expanded shortcut bar item is truncated if the shortcut bar item is not wide enough to display the entirety of the caption text.

Returns
TRUE if the specified shortcut bar item is both expanded and its caption text has been truncated, FALSE if the specified shortcut bar item is either not expanded or its caption text has not been truncated.

◆ Line()

void Line | ( | CDC * | pDC,
 |  | int | x0,
 |  | int | y0,
 |  | int | x1,
 |  | int | y1,
 |  | int | nPen )

Draws the "gripper" lines in the gripper.

Parameters
pDC | Pointer to the client device context.
x0 | Specifies the logical x- coordinate of the start position of the line.
y0 | Specifies the logical y- coordinate of the start position of the line.
x1 | Specifies the logical x- coordinate of the end position of the line.
y1 | Specifies the logical y- coordinate of the end position of the line.
nPen | Specifies the color used to paint the line.

◆ Rectangle()

void Rectangle | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | int | nPen,
 |  | int | nBrush )

Draws the rectangle to be used to draw the shortcut bar items.

Parameters
pDC | Pointer to a valid device context.
rc | Specifies the rectangle in logical units.
nPen | Specifies the color used to paint the rectangle.
nBrush | Specifies the color used to fill the rectangle.

Rectangle is used to draw the rectangle of the shortcut bar items in the Office XP theme.

◆ RefreshMetrics()

virtual void RefreshMetrics ( )
virtual

Refreshes the visual metrics of the shortcut bar paint manager.

This method refreshes all of the visual metrics of the shortcut bar (pane caption color, pane font, pane caption height, etc.).

Reimplemented in CXTPShortcutBarNativeWindows10Theme, CXTPShortcutBarNativeWindows11Theme, CXTPShortcutBarNativeWinXPTheme, CXTPShortcutBarOffice2003Theme, CXTPShortcutBarOffice2013Theme, CXTPShortcutBarResourceTheme, CXTPShortcutBarVisualStudio2015Theme, CXTPShortcutBarVisualStudio2017Theme, CXTPShortcutBarVisualStudio2019Theme, and CXTPShortcutBarVisualStudio2022Theme.

Member Data Documentation

◆ m_grcHot

CXTPPaintManagerColorGradient m_grcHot

Color gradient of "hot" items.

An item is hot when the mouse cursor is positioned over the item.

◆ m_grcPushed

CXTPPaintManagerColorGradient m_grcPushed

Color gradient of item when clicked on.

This color is also used to color the currently selected item on mouse over (i.e. when the selected item is "hot").

The documentation for this class was generated from the following file:
  • XTPShortcutBarPaintManager.h


Toolkit Pro: CXTPShortcutBarPane Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPShortcutBarPane Class Reference

CXTPShortcutBarPane is a CWnd derived class used as a client area for a shortcut bar control. More...

Public Member Functions

CXTPShortcutBarPane ()
Constructs a CXTPShortcutBarPane object.
virtual | ~CXTPShortcutBarPane ()
Destroys a CXTPShortcutBarPane object, handles cleanup and deallocation.
BOOL | Create (LPCTSTR lpszCaption, CXTPShortcutBar *pParent)
Creates the CXTPShortcutBarPane control.
CString | GetCaption () const
Gets the caption of the pane.
void | SetCaption (LPCTSTR lpszCaption)
Sets the caption for the pane.
CXTPShortcutBarPaneItem * | AddItem (LPCTSTR lpszCaption, CWnd *pWnd, int nHeight)
Adds a specified item to the pane.
CXTPShortcutBarPaneItem * | GetItem (int nIndex) const
Gets the item at the specified index.
void | SetIndent (int left, int top, int right, int bottom)
Sets the indent placed around the client area of the shortcut bar.
void | ShowCaption (BOOL bShowCaption)
Shows/hides the caption.
void | SetMinimumClientHeight (int nMinHeight)
Sets the minimum height for the client area.
virtual int | GetMinimumClientHeight () const
Gets the minimum height of the client area.
CXTPShortcutBarPaneItem * | HitTest (CPoint point) const
Determines which item, if any, is located at a specified point.
void | RecalcLayout ()
Recalculates the layout of the pane.

Protected Attributes

CXTPShortcutBar * | m_pShortcutBar
Parent CXTPShortcutBar class.
CString | m_strCaption
Caption of the pane.
CArray< CXTPShortcutBarPaneItem *, CXTPShortcutBarPaneItem * > | m_arrItems
Array of items.
CRect | m_rcIndent
Indentation/padding around the client pane.
BOOL | m_bShowCaption
TRUE to show caption.
int | m_nMinClientHeight
The minimum height of the client area.
CXTPShortcutBarPaneItem * | m_pHighlighted
Highlighted shortcut item.
HCURSOR | m_hHandCursor
Hand cursor.

Detailed Description

CXTPShortcutBarPane is a CWnd derived class used as a client area for a shortcut bar control.

Member Function Documentation

◆ AddItem()

CXTPShortcutBarPaneItem * AddItem | ( | LPCTSTR | lpszCaption,
 |  | CWnd * | pWnd,
 |  | int | nHeight )

Adds a specified item to the pane.

Parameters
lpszCaption | Caption of the item.
pWnd | Pointer to the associated child window of the item.
nHeight | Height of the item.
Returns
A pointer to the newly added CXTPShortcutBarPaneItem object.

◆ Create()

BOOL Create | ( | LPCTSTR | lpszCaption,
 |  | CXTPShortcutBar * | pParent )

Creates the CXTPShortcutBarPane control.

Parameters
lpszCaption | Caption of the pane.
pParent | Pointer to the parent CXTPShortcutBar object.
Returns
TRUE if successful, FALSE otherwise.

◆ GetCaption()

AFX_INLINE CString GetCaption ( ) const

Gets the caption of the pane.

Returns
The caption of the pane.

◆ GetItem()

CXTPShortcutBarPaneItem * GetItem ( int nIndex ) const

Gets the item at the specified index.

Parameters
nIndex Zero-based index of the item to retrieve.
Returns
A pointer to the item at the specified index.

◆ GetMinimumClientHeight()

AFX_INLINE int GetMinimumClientHeight ( ) const
virtual

Gets the minimum height of the client area.

Returns
The minimum height, in pixels, of the client area.

◆ HitTest()

CXTPShortcutBarPaneItem * HitTest ( CPoint point ) const

Determines which item, if any, is located at a specified point.

Parameters
point Point to be tested.
Returns
A pointer to the CXTPShortcutBarPaneItem object at the specified point, if any, otherwise NULL.

◆ SetCaption()

void SetCaption ( LPCTSTR lpszCaption )

Sets the caption for the pane.

Parameters
lpszCaption Caption to be set.

◆ SetIndent()

AFX_INLINE void SetIndent | ( | int | left,
 |  | int | top,
 |  | int | right,
 |  | int | bottom )

Sets the indent placed around the client area of the shortcut bar.

Parameters
left | Amount of space to be placed between the left client border and the left border of the shortcut bar client area.
top | Amount of space to be placed between the top client border and the top border of the shortcut bar client area.
right | Amount of space to be placed between the right client border and the right border of the shortcut bar client area.
bottom | Amount of space to be placed between the bottom client border and the bottom border of the shortcut bar client area.

The indent will be placed around the corresponding CXTPShortcutBarPaneItem when displayed.

◆ SetMinimumClientHeight()

AFX_INLINE void SetMinimumClientHeight ( int nMinHeight )

Sets the minimum height for the client area.

Parameters
nMinHeight Minimum height, in pixels, to be set.

◆ ShowCaption()

AFX_INLINE void ShowCaption ( BOOL bShowCaption )

Shows/hides the caption.

Parameters
bShowCaption TRUE to show the caption, FALSE to hide the caption.
The documentation for this class was generated from the following file:
  • XTPShortcutBarPane.h


Toolkit Pro: CXTPShortcutBarPaneItem Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPShortcutBarPaneItem Class Reference

CXTPShortcutBarPaneItem is a base class that represents an item for a shortcut bar pane. More...

Public Member Functions

CRect | GetCaptionRect () const
Gets the rectangle of the caption.
CString | GetCaption () const
Gets the caption of the item.
void | SetCaption (LPCTSTR lpszCaption)
Sets the caption for the item.
void | SetHeight (int nHeight)
Sets the height for the item.
int | GetHeight () const
Gets the height of the item.
void | ShowCaption (BOOL bShowCaption)
Shows/hides the caption.
BOOL | IsHighlighted () const
Gets the highlighted state of the item.
BOOL | IsExpandable () const
Determines if the item is expandable.
BOOL | IsExpanded () const
Gets the expanded state of the item.
void | SetExpandable (BOOL bExpandable)
Specifies if the item should be expandable.
void | SetExpanded (BOOL bExpanded)
Sets the expanded state of the item.

Protected Member Functions

CXTPShortcutBarPaneItem (LPCTSTR lpszCaption, CWnd *pWnd, int nHeight)
Constructs a CXTPShortcutBarPaneItem object.

Protected Attributes

CString | m_strCaption
Caption of the item.
CRect | m_rcCaption
Rectangle of the caption.
CRect | m_rcClient
Bounding rectangle of the client area.
CWnd * | m_pWndClient
Associated child window.
int | m_nHeight
Height of the item.
BOOL | m_bShowCaption
TRUE to show the caption.
CXTPShortcutBarPane * | m_pPane
Parent pane object.
BOOL | m_bExpandable
TRUE if the pane is expandable.
BOOL | m_bExpanded
TRUE if the pane is expanded.

Detailed Description

CXTPShortcutBarPaneItem is a base class that represents an item for a shortcut bar pane.

Constructor & Destructor Documentation

◆ CXTPShortcutBarPaneItem()

CXTPShortcutBarPaneItem | ( | LPCTSTR | lpszCaption,
 |  | CWnd * | pWnd,
 |  | int | nHeight )
 protected

Constructs a CXTPShortcutBarPaneItem object.

Parameters
lpszCaption | Caption of the item.
pWnd | Pointer to the associated child window of the item.
nHeight | Height of the item.

Member Function Documentation

◆ GetCaption()

AFX_INLINE CString GetCaption ( ) const

Gets the caption of the item.

Returns
The caption of the item.

◆ GetCaptionRect()

AFX_INLINE CRect GetCaptionRect ( ) const

Gets the rectangle of the caption.

Returns
The rectangle of the caption.

◆ GetHeight()

AFX_INLINE int GetHeight ( ) const

Gets the height of the item.

Returns
The height of the item.

◆ IsExpandable()

AFX_INLINE BOOL IsExpandable ( ) const

Determines if the item is expandable.

Returns
TRUE if the item is expandable, otherwise FALSE.

◆ IsExpanded()

AFX_INLINE BOOL IsExpanded ( ) const

Gets the expanded state of the item.

Returns
TRUE if the item is expanded, otherwise FALSE.

◆ IsHighlighted()

AFX_INLINE BOOL IsHighlighted ( ) const

Gets the highlighted state of the item.

Returns
TRUE if the item is highlighted, otherwise FALSE.

◆ SetCaption()

void SetCaption ( LPCTSTR lpszCaption )

Sets the caption for the item.

Parameters
lpszCaption Caption to be set.

◆ SetExpandable()

AFX_INLINE void SetExpandable ( BOOL bExpandable )

Specifies if the item should be expandable.

Parameters
bExpandable TRUE to set the item to be expandable, FALSE otherwise.

◆ SetExpanded()

AFX_INLINE void SetExpanded ( BOOL bExpanded )

Sets the expanded state of the item.

Parameters
bExpanded TRUE to expand the item, FALSE to collapse the item.

◆ SetHeight()

void SetHeight ( int nHeight )

Sets the height for the item.

Parameters
nHeight Height to be set.

◆ ShowCaption()

AFX_INLINE void ShowCaption ( BOOL bShowCaption )

Shows/hides the caption.

Parameters
bShowCaption TRUE to show the caption, FALSE to hide the caption.
The documentation for this class was generated from the following file:
  • XTPShortcutBarPane.h


Toolkit Pro: CXTPShortcutBarResourceTheme Class Reference

Public Member Functions | List of all members
CXTPShortcutBarResourceTheme Class Reference

CXTPShortcutBarResourceTheme is a CXTPShortcutBarOffice2003Theme derived class that represents the Office 2007, 2010 and 2012 shortcut bar themes. More...

Inheritance diagram for CXTPShortcutBarResourceTheme:
[legend]

Public Member Functions

CXTPShortcutBarResourceTheme ()
Constructs a CXTPShortcutBarResourceTheme object.
virtual void | RefreshMetrics ()
Refreshes the visual metrics of the shortcut bar paint manager.
virtual int | DrawGripper (CDC *pDC, CXTPShortcutBar *pShortcutBar, BOOL bDraw)
Draws the gripper for the shortcut bar control.
void | FillShortcutItemEntry (CDC *pDC, CXTPShortcutBarItem *pItem)
Fills a specified item for the shortcut bar control.
void | FillShortcutBar (CDC *pDC, CXTPShortcutBar *pShortcutBar)
Fills the client area of the shortcut bar control.
virtual int | DrawPaneItemCaption (CDC *pDC, CXTPShortcutBarPaneItem *pItem, BOOL bDraw)
Draws the caption for a specified shortcut bar pane item.
virtual int | DrawPaneCaption (CDC *pDC, CXTPShortcutBarPane *pPane, BOOL bDraw)
Draws the caption for a specified shortcut bar pane.
virtual void | DrawExpandButton (CDC *pDC, CRect rc)
Draws the expand button.
virtual void | FillNavigationItemEntry (CDC *pDC, CXTPShortcutBarItem *pItem)
Fills a specified navigation item for the minimized shortcut bar control.
- Public Member Functions inherited from CXTPShortcutBarOffice2003Theme
CXTPShortcutBarOffice2003Theme ()
Constructs a CXTPShortcutBarOffice2003Theme object.
void | DrawShortcutBarFrame (CDC *pDC, CXTPShortcutBar *pShortcutBar)
Draws the frame for the shortcut bar control.
void | DrawImage (CDC *pDC, CPoint pt, CSize sz, CXTPImageManagerIcon *pImage, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled)
Draws the image of a shortcut bar item.
- Public Member Functions inherited from CXTPShortcutBarPaintManager
CXTPShortcutBarPaintManager ()
Constructs a CXTPShortcutBarPaintManager object.
virtual | ~CXTPShortcutBarPaintManager ()
Destroys a CXTPShortcutBarPaintManager object, handles cleanup and deallocation.
virtual void | DrawShortcutItem (CDC *pDC, CXTPShortcutBarItem *pItem)
Draws a specified item for the shortcut bar control.
virtual void | DrawNavigationItem (CDC *pDC, CXTPShortcutBarItem *pItem)
Draws a specified navigation item for the minimized shortcut bar control.
void | Rectangle (CDC *pDC, CRect rc, int nPen, int nBrush)
Draws the rectangle to be used to draw the shortcut bar items.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1, int nPen)
Draws the "gripper" lines in the gripper.
BOOL | IsShortcutItemTruncated (CDC *pDC, CXTPShortcutBarItem *pItem)
Determines if the caption text of a specified expanded shortcut bar item has been truncated.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPShortcutBarOffice2003Theme
CXTPPaintManagerColorGradient | m_grcCaption
Caption color.
CXTPPaintManagerColorGradient | m_grcItemCaption
Items color.
CXTPPaintManagerColorGradient | m_grcItemHotCaption
Items color.
CXTPPaintManagerColor | m_clrItemCaptionShadow
Color of sub-caption shadow.
CXTPPaintManagerColor | m_clrItemCaptionTop
Color under sub-caption rectangle.
CXTPPaintManagerColor | m_clrCaptionText
Color of items text.
CXTPPaintManagerColor | m_clrItemCaptionText
Color of sub-caption text.
BOOL | m_bShowTopLeftCaptionShadow
TRUE to draw rectangle around items.
- Public Attributes inherited from CXTPShortcutBarPaintManager
CXTPFont | m_xtpFontText
Text font.
CXTPFont | m_xtpFontPaneCaption
Caption font.
CXTPFont | m_xtpFontPaneItemCaption
Sub-caption font.
CXTPFont | m_xtpFontVerticalText
Navigation button text font.
int | m_nPaneItemHeight
Height of sub-pane caption.
CXTPImageManagerIcon * | m_pExpandIcon
Pointer to expand icon.
BOOL | m_bNavigationButton
TRUE if navigation button small.
int | m_nNormalIconWidth
Width of the icons.
int | m_nExpandedIconWidth
Width of the expanded icons.
BOOL | m_bBoldItemCaptionFont
TRUE to draw item with bold font.
BOOL | m_bClearTypeTextQuality
TRUE to use ClearType font.
BOOL | m_bUseStandardFont
TRUE to use standard font.
CRect | m_rcCaptionPadding
Padding of pane caption.
CRect | m_rcItemCaptionPadding
Padding of item caption.
CString | m_strOfficeFont
TRUE to use Office Tahoma font.
CXTPPaintManagerColor | m_clrPushedText
Color of caption text when an CXTPShortcutBarItem is pressed.
CXTPPaintManagerColor | m_clrSelectedText
Color of caption text when an CXTPShortcutBarItem is selected (this happens after the item is clicked).
CXTPPaintManagerColor | m_clrHotText
Color of caption text when the mouse cursor is positioned over an CXTPShortcutBarItem.
CXTPPaintManagerColor | m_clrNormalText
Color of caption text when an CXTPShortcutBarItem is displayed normally.
CXTPPaintManagerColor | m_clrDisabledText
Color of caption text when an CXTPShortcutBarItem is disabled.
CXTPPaintManagerColorGradient | m_grcSelected
Color gradient of currently selected item.
CXTPPaintManagerColorGradient m_grcHot
Color gradient of "hot" items.
CXTPPaintManagerColorGradient m_grcPushed
Color gradient of item when clicked on.
CXTPPaintManagerColorGradient | m_grcShortcutItem
Color gradient of shortcut bar items.
CXTPPaintManagerColor | m_clrShortcutItemShadow
Color of line border that goes around each item.
CXTPPaintManagerColorGradient | m_grcShortcutBarGripper
Color gradient used to draw the shortcut bar gripper.

Detailed Description

CXTPShortcutBarResourceTheme is a CXTPShortcutBarOffice2003Theme derived class that represents the Office 2007, 2010 and 2012 shortcut bar themes.

Member Function Documentation

◆ DrawExpandButton()

virtual void DrawExpandButton | ( | CDC * | pDC,
 |  | CRect | rc )
 virtual

Draws the expand button.

Parameters
pDC | Pointer to the client device context.
rc | Client rectangle of the expand button.

Reimplemented from CXTPShortcutBarPaintManager.

Reimplemented in CXTPShortcutBarOffice2013Theme.

◆ DrawGripper()

virtual int DrawGripper | ( | CDC * | pDC,
 |  | CXTPShortcutBar * | pShortcutBar,
 |  | BOOL | bDraw )
 virtual

Draws the gripper for the shortcut bar control.

Parameters
pDC | Pointer to the client device context.
pShortcutBar | Pointer to the shortcut bar control.
bDraw | TRUE to draw the gripper, FALSE to only retrieve the size of the gripper.
Returns
The size of the gripper (i.e. 7 pixels for flat style, 9 pixels otherwise).

Reimplemented from CXTPShortcutBarOffice2003Theme.

Reimplemented in CXTPShortcutBarOffice2013Theme.

◆ DrawPaneCaption()

virtual int DrawPaneCaption | ( | CDC * | pDC,
 |  | CXTPShortcutBarPane * | pPane,
 |  | BOOL | bDraw )
 virtual

Draws the caption for a specified shortcut bar pane.

Parameters
pDC | Pointer to the client device context.
pPane | Pointer to the CXTPShortcutBarPane object to be drawn.
bDraw | TRUE to draw the shortcut bar pane caption, FALSE to only retrieve the size of the shortcut bar pane caption.

Panes of the shortcut bar are displayed in the shortcut bar's client area. Each pane consists of a caption and one or more sub-panes. Each sub-pane has its own caption and is drawn by the DrawPaneItemCaption method.

The caption of the shortcut bar pane is the bar on the top the pane. The caption of the shortcut bar pane is set when the pane is created by the CXTPShortcutBarPane::Create method.

The caption of the shortcut bar pane can be retrieved by using the CXTPShortcutBarPane::GetCaption method.

Shortcut bar panes have sub-items which also have captions that are drawn by the DrawPaneItemCaption method.

Returns
The size of the shortcut pane caption (i.e. 24 pixels).

Reimplemented from CXTPShortcutBarOffice2003Theme.

◆ DrawPaneItemCaption()

virtual int DrawPaneItemCaption | ( | CDC * | pDC,
 |  | CXTPShortcutBarPaneItem * | pItem,
 |  | BOOL | bDraw )
 virtual

Draws the caption for a specified shortcut bar pane item.

Parameters
pDC | Pointer to the client device context.
pItem | Pointer to the CXTPShortcutBarPaneItem object to be drawn.
bDraw | TRUE to draw the shortcut bar pane item caption, FALSE to only retrieve the size of the shortcut bar pane item caption.

Panes of the shortcut bar are displayed in the shortcut bar's client area. Each pane consists of a caption and one or more sub-panes. Each sub-pane has its own caption and is drawn by the DrawPaneItemCaption method.

The caption of the shortcut bar pane item is set when the pane item is created by the CXTPShortcutBarPane::AddItem method.

The sub-items of a shortcut bar pane can be retrieved by using the CXTPShortcutBarPane::GetItem method.

Returns
The size of the shortcut pane item caption.

Reimplemented from CXTPShortcutBarOffice2003Theme.

Reimplemented in CXTPShortcutBarNativeWindows10Theme, CXTPShortcutBarNativeWindows11Theme, CXTPShortcutBarOffice2013Theme, CXTPShortcutBarVisualStudio2015Theme, CXTPShortcutBarVisualStudio2017Theme, CXTPShortcutBarVisualStudio2019Theme, and CXTPShortcutBarVisualStudio2022Theme.

◆ FillNavigationItemEntry()

virtual void FillNavigationItemEntry | ( | CDC * | pDC,
 |  | CXTPShortcutBarItem * | pItem )
 virtual

Fills a specified navigation item for the minimized shortcut bar control.

Parameters
pDC | Pointer to the client device context.
pItem | Pointer to the CXTPShortcutBarItem object to be filled.

Reimplemented from CXTPShortcutBarOffice2003Theme.

Reimplemented in CXTPShortcutBarNativeWindows10Theme, CXTPShortcutBarNativeWindows11Theme, CXTPShortcutBarOffice2013Theme, CXTPShortcutBarVisualStudio2015Theme, CXTPShortcutBarVisualStudio2017Theme, CXTPShortcutBarVisualStudio2019Theme, and CXTPShortcutBarVisualStudio2022Theme.

◆ FillShortcutBar()

void FillShortcutBar | ( | CDC * | pDC,
 |  | CXTPShortcutBar * | pShortcutBar )
 virtual

Fills the client area of the shortcut bar control.

Parameters
pDC | Pointer to the client device context.
pShortcutBar | Pointer to the shortcut bar control.

Reimplemented from CXTPShortcutBarOffice2003Theme.

◆ FillShortcutItemEntry()

void FillShortcutItemEntry | ( | CDC * | pDC,
 |  | CXTPShortcutBarItem * | pItem )
 virtual

Fills a specified item for the shortcut bar control.

Parameters
pDC | Pointer to the client device context.
pItem | Pointer to the CXTPShortcutBarItem object to be filled.

Reimplemented from CXTPShortcutBarOffice2003Theme.

Reimplemented in CXTPShortcutBarVisualStudio2015Theme, CXTPShortcutBarVisualStudio2017Theme, CXTPShortcutBarVisualStudio2019Theme, and CXTPShortcutBarVisualStudio2022Theme.

◆ RefreshMetrics()

virtual void RefreshMetrics ( )
virtual

Refreshes the visual metrics of the shortcut bar paint manager.

This method refreshes all of the visual metrics of the shortcut bar (pane caption color, pane font, pane caption height, etc.).

Reimplemented from CXTPShortcutBarOffice2003Theme.

Reimplemented in CXTPShortcutBarNativeWindows10Theme, CXTPShortcutBarNativeWindows11Theme, CXTPShortcutBarOffice2013Theme, CXTPShortcutBarVisualStudio2015Theme, CXTPShortcutBarVisualStudio2017Theme, CXTPShortcutBarVisualStudio2019Theme, and CXTPShortcutBarVisualStudio2022Theme.

The documentation for this class was generated from the following file:
  • XTPShortcutBarResourceTheme.h


Toolkit Pro: CXTPShortcutBarVisualStudio2015Theme Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPShortcutBarVisualStudio2015Theme Class Reference

CXTPShortcutBarVisualStudio2015Theme is a CXTPShortcutBarOffice2013Theme derived class that represents a Visual Studio 2015 shortcut bar theme. More...

Inheritance diagram for CXTPShortcutBarVisualStudio2015Theme:
[legend]

Public Member Functions

CXTPShortcutBarVisualStudio2015Theme ()
Constructs a CXTPShortcutBarVisualStudio2015Theme object.
virtual | ~CXTPShortcutBarVisualStudio2015Theme ()
Destroys a CXTPShortcutBarVisualStudio2015Theme object, handles cleanup and deallocation.
virtual void | RefreshMetrics ()
Refreshes the visual metrics of the shortcut bar paint manager.
virtual int | DrawPaneItemCaption (CDC *pDC, CXTPShortcutBarPaneItem *pItem, BOOL bDraw)
Draws the caption for a specified shortcut bar pane item.
virtual void | FillShortcutItemEntry (CDC *pDC, CXTPShortcutBarItem *pItem)
Fills a specified item for the shortcut bar control.
virtual void | FillNavigationItemEntry (CDC *pDC, CXTPShortcutBarItem *pItem)
Fills a specified navigation item for the minimized shortcut bar control.
- Public Member Functions inherited from CXTPShortcutBarOffice2013Theme
CXTPShortcutBarOffice2013Theme ()
Constructs a CXTPShortcutBarOffice2013Theme object.
virtual | ~CXTPShortcutBarOffice2013Theme ()
Destroys a CXTPShortcutBarOffice2013Theme object, handles cleanup and deallocation.
virtual void | DrawExpandButton (CDC *pDC, CRect rc)
Draws the expand button.
virtual int | DrawGripper (CDC *pDC, CXTPShortcutBar *pShortcutBar, BOOL bDraw)
Draws the gripper for the shortcut bar control.
virtual void | FillShortcutBar (CDC *pDC, CXTPShortcutBar *pShortcutBar)
Fills the client area of the shortcut bar control.
- Public Member Functions inherited from CXTPShortcutBarResourceTheme
CXTPShortcutBarResourceTheme ()
Constructs a CXTPShortcutBarResourceTheme object.
void | FillShortcutBar (CDC *pDC, CXTPShortcutBar *pShortcutBar)
Fills the client area of the shortcut bar control.
virtual int | DrawPaneCaption (CDC *pDC, CXTPShortcutBarPane *pPane, BOOL bDraw)
Draws the caption for a specified shortcut bar pane.
- Public Member Functions inherited from CXTPShortcutBarOffice2003Theme
CXTPShortcutBarOffice2003Theme ()
Constructs a CXTPShortcutBarOffice2003Theme object.
void | DrawShortcutBarFrame (CDC *pDC, CXTPShortcutBar *pShortcutBar)
Draws the frame for the shortcut bar control.
void | DrawImage (CDC *pDC, CPoint pt, CSize sz, CXTPImageManagerIcon *pImage, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled)
Draws the image of a shortcut bar item.
- Public Member Functions inherited from CXTPShortcutBarPaintManager
CXTPShortcutBarPaintManager ()
Constructs a CXTPShortcutBarPaintManager object.
virtual | ~CXTPShortcutBarPaintManager ()
Destroys a CXTPShortcutBarPaintManager object, handles cleanup and deallocation.
virtual void | DrawShortcutItem (CDC *pDC, CXTPShortcutBarItem *pItem)
Draws a specified item for the shortcut bar control.
virtual void | DrawNavigationItem (CDC *pDC, CXTPShortcutBarItem *pItem)
Draws a specified navigation item for the minimized shortcut bar control.
void | Rectangle (CDC *pDC, CRect rc, int nPen, int nBrush)
Draws the rectangle to be used to draw the shortcut bar items.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1, int nPen)
Draws the "gripper" lines in the gripper.
BOOL | IsShortcutItemTruncated (CDC *pDC, CXTPShortcutBarItem *pItem)
Determines if the caption text of a specified expanded shortcut bar item has been truncated.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Attributes

BOOL | m_bHiliteBorders
TRUE to draw borders around highlighted items.
CXTPPaintManagerColor | m_clrBorderHilite
Highlighted border color.
CXTPPaintManagerColor | m_clrBackHiliteSelected
Selected highlighted background color.
- Protected Attributes inherited from CXTPShortcutBarOffice2013Theme
CXTPPaintManagerColor | m_clrGlyph
Normal glyph color.
CXTPPaintManagerColor | m_clrGlyphFill
Expanded glyph fill color.
CXTPPaintManagerColor | m_clrGlyphExpanded
Expanded glyph border color.
CXTPPaintManagerColor | m_clrGlyphPushed
Pushed glyph color.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPShortcutBarResourceTheme
- Public Attributes inherited from CXTPShortcutBarOffice2003Theme
CXTPPaintManagerColorGradient | m_grcCaption
Caption color.
CXTPPaintManagerColorGradient | m_grcItemCaption
Items color.
CXTPPaintManagerColorGradient | m_grcItemHotCaption
Items color.
CXTPPaintManagerColor | m_clrItemCaptionShadow
Color of sub-caption shadow.
CXTPPaintManagerColor | m_clrItemCaptionTop
Color under sub-caption rectangle.
CXTPPaintManagerColor | m_clrCaptionText
Color of items text.
CXTPPaintManagerColor | m_clrItemCaptionText
Color of sub-caption text.
BOOL | m_bShowTopLeftCaptionShadow
TRUE to draw rectangle around items.
- Public Attributes inherited from CXTPShortcutBarPaintManager
CXTPFont | m_xtpFontText
Text font.
CXTPFont | m_xtpFontPaneCaption
Caption font.
CXTPFont | m_xtpFontPaneItemCaption
Sub-caption font.
CXTPFont | m_xtpFontVerticalText
Navigation button text font.
int | m_nPaneItemHeight
Height of sub-pane caption.
CXTPImageManagerIcon * | m_pExpandIcon
Pointer to expand icon.
BOOL | m_bNavigationButton
TRUE if navigation button small.
int | m_nNormalIconWidth
Width of the icons.
int | m_nExpandedIconWidth
Width of the expanded icons.
BOOL | m_bBoldItemCaptionFont
TRUE to draw item with bold font.
BOOL | m_bClearTypeTextQuality
TRUE to use ClearType font.
BOOL | m_bUseStandardFont
TRUE to use standard font.
CRect | m_rcCaptionPadding
Padding of pane caption.
CRect | m_rcItemCaptionPadding
Padding of item caption.
CString | m_strOfficeFont
TRUE to use Office Tahoma font.
CXTPPaintManagerColor | m_clrPushedText
Color of caption text when an CXTPShortcutBarItem is pressed.
CXTPPaintManagerColor | m_clrSelectedText
Color of caption text when an CXTPShortcutBarItem is selected (this happens after the item is clicked).
CXTPPaintManagerColor | m_clrHotText
Color of caption text when the mouse cursor is positioned over an CXTPShortcutBarItem.
CXTPPaintManagerColor | m_clrNormalText
Color of caption text when an CXTPShortcutBarItem is displayed normally.
CXTPPaintManagerColor | m_clrDisabledText
Color of caption text when an CXTPShortcutBarItem is disabled.
CXTPPaintManagerColorGradient | m_grcSelected
Color gradient of currently selected item.
CXTPPaintManagerColorGradient m_grcHot
Color gradient of "hot" items.
CXTPPaintManagerColorGradient m_grcPushed
Color gradient of item when clicked on.
CXTPPaintManagerColorGradient | m_grcShortcutItem
Color gradient of shortcut bar items.
CXTPPaintManagerColor | m_clrShortcutItemShadow
Color of line border that goes around each item.
CXTPPaintManagerColorGradient | m_grcShortcutBarGripper
Color gradient used to draw the shortcut bar gripper.

Detailed Description

CXTPShortcutBarVisualStudio2015Theme is a CXTPShortcutBarOffice2013Theme derived class that represents a Visual Studio 2015 shortcut bar theme.

Member Function Documentation

◆ DrawPaneItemCaption()

virtual int DrawPaneItemCaption | ( | CDC * | pDC,
 |  | CXTPShortcutBarPaneItem * | pItem,
 |  | BOOL | bDraw )
 virtual

Draws the caption for a specified shortcut bar pane item.

Parameters
pDC | Pointer to the client device context.
pItem | Pointer to the CXTPShortcutBarPaneItem object to be drawn.
bDraw | TRUE to draw the shortcut bar pane item caption, FALSE to only retrieve the size of the shortcut bar pane item caption.

Panes of the shortcut bar are displayed in the shortcut bar's client area. Each pane consists of a caption and one or more sub-panes. Each sub-pane has its own caption and is drawn by the DrawPaneItemCaption method.

The caption of the shortcut bar pane item is set when the pane item is created by the CXTPShortcutBarPane::AddItem method.

The sub-items of a shortcut bar pane can be retrieved by using the CXTPShortcutBarPane::GetItem method.

Returns
The size of the shortcut pane item caption.

Reimplemented from CXTPShortcutBarOffice2013Theme.

◆ FillNavigationItemEntry()

virtual void FillNavigationItemEntry | ( | CDC * | pDC,
 |  | CXTPShortcutBarItem * | pItem )
 virtual

Fills a specified navigation item for the minimized shortcut bar control.

Parameters
pDC | Pointer to the client device context.
pItem | Pointer to the CXTPShortcutBarItem object to be filled.

Reimplemented from CXTPShortcutBarOffice2013Theme.

◆ FillShortcutItemEntry()

virtual void FillShortcutItemEntry | ( | CDC * | pDC,
 |  | CXTPShortcutBarItem * | pItem )
 virtual

Fills a specified item for the shortcut bar control.

Parameters
pDC | Pointer to the client device context.
pItem | Pointer to the CXTPShortcutBarItem object to be filled.

Reimplemented from CXTPShortcutBarOffice2013Theme.

◆ RefreshMetrics()

virtual void RefreshMetrics ( )
virtual

Refreshes the visual metrics of the shortcut bar paint manager.

This method refreshes all of the visual metrics of the shortcut bar (pane caption color, pane font, pane caption height, etc.).

Reimplemented from CXTPShortcutBarOffice2013Theme.

The documentation for this class was generated from the following file:
  • XTPShortcutBarVisualStudio2015Theme.h


Toolkit Pro: CXTPShortcutBarVisualStudio2017Theme Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPShortcutBarVisualStudio2017Theme Class Reference

CXTPShortcutBarVisualStudio2017Theme is a CXTPShortcutBarOffice2013Theme derived class that represents a Visual Studio 2017 shortcut bar theme. More...

Inheritance diagram for CXTPShortcutBarVisualStudio2017Theme:
[legend]

Public Member Functions

CXTPShortcutBarVisualStudio2017Theme ()
Constructs a CXTPShortcutBarVisualStudio2017Theme object.
virtual | ~CXTPShortcutBarVisualStudio2017Theme ()
Destroys a CXTPShortcutBarVisualStudio2017Theme object, handles cleanup and deallocation.
virtual void | RefreshMetrics ()
Refreshes the visual metrics of the shortcut bar paint manager.
virtual int | DrawPaneItemCaption (CDC *pDC, CXTPShortcutBarPaneItem *pItem, BOOL bDraw)
Draws the caption for a specified shortcut bar pane item.
virtual void | FillShortcutItemEntry (CDC *pDC, CXTPShortcutBarItem *pItem)
Fills a specified item for the shortcut bar control.
virtual void | FillNavigationItemEntry (CDC *pDC, CXTPShortcutBarItem *pItem)
Fills a specified navigation item for the minimized shortcut bar control.
- Public Member Functions inherited from CXTPShortcutBarOffice2013Theme
CXTPShortcutBarOffice2013Theme ()
Constructs a CXTPShortcutBarOffice2013Theme object.
virtual | ~CXTPShortcutBarOffice2013Theme ()
Destroys a CXTPShortcutBarOffice2013Theme object, handles cleanup and deallocation.
virtual void | DrawExpandButton (CDC *pDC, CRect rc)
Draws the expand button.
virtual int | DrawGripper (CDC *pDC, CXTPShortcutBar *pShortcutBar, BOOL bDraw)
Draws the gripper for the shortcut bar control.
virtual void | FillShortcutBar (CDC *pDC, CXTPShortcutBar *pShortcutBar)
Fills the client area of the shortcut bar control.
- Public Member Functions inherited from CXTPShortcutBarResourceTheme
CXTPShortcutBarResourceTheme ()
Constructs a CXTPShortcutBarResourceTheme object.
void | FillShortcutBar (CDC *pDC, CXTPShortcutBar *pShortcutBar)
Fills the client area of the shortcut bar control.
virtual int | DrawPaneCaption (CDC *pDC, CXTPShortcutBarPane *pPane, BOOL bDraw)
Draws the caption for a specified shortcut bar pane.
- Public Member Functions inherited from CXTPShortcutBarOffice2003Theme
CXTPShortcutBarOffice2003Theme ()
Constructs a CXTPShortcutBarOffice2003Theme object.
void | DrawShortcutBarFrame (CDC *pDC, CXTPShortcutBar *pShortcutBar)
Draws the frame for the shortcut bar control.
void | DrawImage (CDC *pDC, CPoint pt, CSize sz, CXTPImageManagerIcon *pImage, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled)
Draws the image of a shortcut bar item.
- Public Member Functions inherited from CXTPShortcutBarPaintManager
CXTPShortcutBarPaintManager ()
Constructs a CXTPShortcutBarPaintManager object.
virtual | ~CXTPShortcutBarPaintManager ()
Destroys a CXTPShortcutBarPaintManager object, handles cleanup and deallocation.
virtual void | DrawShortcutItem (CDC *pDC, CXTPShortcutBarItem *pItem)
Draws a specified item for the shortcut bar control.
virtual void | DrawNavigationItem (CDC *pDC, CXTPShortcutBarItem *pItem)
Draws a specified navigation item for the minimized shortcut bar control.
void | Rectangle (CDC *pDC, CRect rc, int nPen, int nBrush)
Draws the rectangle to be used to draw the shortcut bar items.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1, int nPen)
Draws the "gripper" lines in the gripper.
BOOL | IsShortcutItemTruncated (CDC *pDC, CXTPShortcutBarItem *pItem)
Determines if the caption text of a specified expanded shortcut bar item has been truncated.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Attributes

BOOL | m_bHiliteBorders
TRUE to draw borders around highlighted items.
CXTPPaintManagerColor | m_clrBorderHilite
Highlighted border color.
CXTPPaintManagerColor | m_clrBackHiliteSelected
Selected highlighted background color.
- Protected Attributes inherited from CXTPShortcutBarOffice2013Theme
CXTPPaintManagerColor | m_clrGlyph
Normal glyph color.
CXTPPaintManagerColor | m_clrGlyphFill
Expanded glyph fill color.
CXTPPaintManagerColor | m_clrGlyphExpanded
Expanded glyph border color.
CXTPPaintManagerColor | m_clrGlyphPushed
Pushed glyph color.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPShortcutBarResourceTheme
- Public Attributes inherited from CXTPShortcutBarOffice2003Theme
CXTPPaintManagerColorGradient | m_grcCaption
Caption color.
CXTPPaintManagerColorGradient | m_grcItemCaption
Items color.
CXTPPaintManagerColorGradient | m_grcItemHotCaption
Items color.
CXTPPaintManagerColor | m_clrItemCaptionShadow
Color of sub-caption shadow.
CXTPPaintManagerColor | m_clrItemCaptionTop
Color under sub-caption rectangle.
CXTPPaintManagerColor | m_clrCaptionText
Color of items text.
CXTPPaintManagerColor | m_clrItemCaptionText
Color of sub-caption text.
BOOL | m_bShowTopLeftCaptionShadow
TRUE to draw rectangle around items.
- Public Attributes inherited from CXTPShortcutBarPaintManager
CXTPFont | m_xtpFontText
Text font.
CXTPFont | m_xtpFontPaneCaption
Caption font.
CXTPFont | m_xtpFontPaneItemCaption
Sub-caption font.
CXTPFont | m_xtpFontVerticalText
Navigation button text font.
int | m_nPaneItemHeight
Height of sub-pane caption.
CXTPImageManagerIcon * | m_pExpandIcon
Pointer to expand icon.
BOOL | m_bNavigationButton
TRUE if navigation button small.
int | m_nNormalIconWidth
Width of the icons.
int | m_nExpandedIconWidth
Width of the expanded icons.
BOOL | m_bBoldItemCaptionFont
TRUE to draw item with bold font.
BOOL | m_bClearTypeTextQuality
TRUE to use ClearType font.
BOOL | m_bUseStandardFont
TRUE to use standard font.
CRect | m_rcCaptionPadding
Padding of pane caption.
CRect | m_rcItemCaptionPadding
Padding of item caption.
CString | m_strOfficeFont
TRUE to use Office Tahoma font.
CXTPPaintManagerColor | m_clrPushedText
Color of caption text when an CXTPShortcutBarItem is pressed.
CXTPPaintManagerColor | m_clrSelectedText
Color of caption text when an CXTPShortcutBarItem is selected (this happens after the item is clicked).
CXTPPaintManagerColor | m_clrHotText
Color of caption text when the mouse cursor is positioned over an CXTPShortcutBarItem.
CXTPPaintManagerColor | m_clrNormalText
Color of caption text when an CXTPShortcutBarItem is displayed normally.
CXTPPaintManagerColor | m_clrDisabledText
Color of caption text when an CXTPShortcutBarItem is disabled.
CXTPPaintManagerColorGradient | m_grcSelected
Color gradient of currently selected item.
CXTPPaintManagerColorGradient m_grcHot
Color gradient of "hot" items.
CXTPPaintManagerColorGradient m_grcPushed
Color gradient of item when clicked on.
CXTPPaintManagerColorGradient | m_grcShortcutItem
Color gradient of shortcut bar items.
CXTPPaintManagerColor | m_clrShortcutItemShadow
Color of line border that goes around each item.
CXTPPaintManagerColorGradient | m_grcShortcutBarGripper
Color gradient used to draw the shortcut bar gripper.

Detailed Description

CXTPShortcutBarVisualStudio2017Theme is a CXTPShortcutBarOffice2013Theme derived class that represents a Visual Studio 2017 shortcut bar theme.

Member Function Documentation

◆ DrawPaneItemCaption()

virtual int DrawPaneItemCaption | ( | CDC * | pDC,
 |  | CXTPShortcutBarPaneItem * | pItem,
 |  | BOOL | bDraw )
 virtual

Draws the caption for a specified shortcut bar pane item.

Parameters
pDC | Pointer to the client device context.
pItem | Pointer to the CXTPShortcutBarPaneItem object to be drawn.
bDraw | TRUE to draw the shortcut bar pane item caption, FALSE to only retrieve the size of the shortcut bar pane item caption.

Panes of the shortcut bar are displayed in the shortcut bar's client area. Each pane consists of a caption and one or more sub-panes. Each sub-pane has its own caption and is drawn by the DrawPaneItemCaption method.

The caption of the shortcut bar pane item is set when the pane item is created by the CXTPShortcutBarPane::AddItem method.

The sub-items of a shortcut bar pane can be retrieved by using the CXTPShortcutBarPane::GetItem method.

Returns
The size of the shortcut pane item caption.

Reimplemented from CXTPShortcutBarOffice2013Theme.

◆ FillNavigationItemEntry()

virtual void FillNavigationItemEntry | ( | CDC * | pDC,
 |  | CXTPShortcutBarItem * | pItem )
 virtual

Fills a specified navigation item for the minimized shortcut bar control.

Parameters
pDC | Pointer to the client device context.
pItem | Pointer to the CXTPShortcutBarItem object to be filled.

Reimplemented from CXTPShortcutBarOffice2013Theme.

◆ FillShortcutItemEntry()

virtual void FillShortcutItemEntry | ( | CDC * | pDC,
 |  | CXTPShortcutBarItem * | pItem )
 virtual

Fills a specified item for the shortcut bar control.

Parameters
pDC | Pointer to the client device context.
pItem | Pointer to the CXTPShortcutBarItem object to be filled.

Reimplemented from CXTPShortcutBarOffice2013Theme.

◆ RefreshMetrics()

virtual void RefreshMetrics ( )
virtual

Refreshes the visual metrics of the shortcut bar paint manager.

This method refreshes all of the visual metrics of the shortcut bar (pane caption color, pane font, pane caption height, etc.).

Reimplemented from CXTPShortcutBarOffice2013Theme.

The documentation for this class was generated from the following file:
  • XTPShortcutBarVisualStudio2017Theme.h


Toolkit Pro: CXTPShortcutBarVisualStudio2019Theme Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPShortcutBarVisualStudio2019Theme Class Reference

CXTPShortcutBarVisualStudio2019Theme is a CXTPShortcutBarOffice2013Theme derived class that represents a Visual Studio 2019 shortcut bar theme. More...

Inheritance diagram for CXTPShortcutBarVisualStudio2019Theme:
[legend]

Public Member Functions

CXTPShortcutBarVisualStudio2019Theme ()
Constructs a CXTPShortcutBarVisualStudio2019Theme object.
virtual | ~CXTPShortcutBarVisualStudio2019Theme ()
Destroys a CXTPShortcutBarVisualStudio2019Theme object, handles cleanup and deallocation.
virtual void | RefreshMetrics ()
Refreshes the visual metrics of the shortcut bar paint manager.
virtual int | DrawPaneItemCaption (CDC *pDC, CXTPShortcutBarPaneItem *pItem, BOOL bDraw)
Draws the caption for a specified shortcut bar pane item.
virtual void | FillShortcutItemEntry (CDC *pDC, CXTPShortcutBarItem *pItem)
Fills a specified item for the shortcut bar control.
virtual void | FillNavigationItemEntry (CDC *pDC, CXTPShortcutBarItem *pItem)
Fills a specified navigation item for the minimized shortcut bar control.
- Public Member Functions inherited from CXTPShortcutBarOffice2013Theme
CXTPShortcutBarOffice2013Theme ()
Constructs a CXTPShortcutBarOffice2013Theme object.
virtual | ~CXTPShortcutBarOffice2013Theme ()
Destroys a CXTPShortcutBarOffice2013Theme object, handles cleanup and deallocation.
virtual void | DrawExpandButton (CDC *pDC, CRect rc)
Draws the expand button.
virtual int | DrawGripper (CDC *pDC, CXTPShortcutBar *pShortcutBar, BOOL bDraw)
Draws the gripper for the shortcut bar control.
virtual void | FillShortcutBar (CDC *pDC, CXTPShortcutBar *pShortcutBar)
Fills the client area of the shortcut bar control.
- Public Member Functions inherited from CXTPShortcutBarResourceTheme
CXTPShortcutBarResourceTheme ()
Constructs a CXTPShortcutBarResourceTheme object.
void | FillShortcutBar (CDC *pDC, CXTPShortcutBar *pShortcutBar)
Fills the client area of the shortcut bar control.
virtual int | DrawPaneCaption (CDC *pDC, CXTPShortcutBarPane *pPane, BOOL bDraw)
Draws the caption for a specified shortcut bar pane.
- Public Member Functions inherited from CXTPShortcutBarOffice2003Theme
CXTPShortcutBarOffice2003Theme ()
Constructs a CXTPShortcutBarOffice2003Theme object.
void | DrawShortcutBarFrame (CDC *pDC, CXTPShortcutBar *pShortcutBar)
Draws the frame for the shortcut bar control.
void | DrawImage (CDC *pDC, CPoint pt, CSize sz, CXTPImageManagerIcon *pImage, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled)
Draws the image of a shortcut bar item.
- Public Member Functions inherited from CXTPShortcutBarPaintManager
CXTPShortcutBarPaintManager ()
Constructs a CXTPShortcutBarPaintManager object.
virtual | ~CXTPShortcutBarPaintManager ()
Destroys a CXTPShortcutBarPaintManager object, handles cleanup and deallocation.
virtual void | DrawShortcutItem (CDC *pDC, CXTPShortcutBarItem *pItem)
Draws a specified item for the shortcut bar control.
virtual void | DrawNavigationItem (CDC *pDC, CXTPShortcutBarItem *pItem)
Draws a specified navigation item for the minimized shortcut bar control.
void | Rectangle (CDC *pDC, CRect rc, int nPen, int nBrush)
Draws the rectangle to be used to draw the shortcut bar items.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1, int nPen)
Draws the "gripper" lines in the gripper.
BOOL | IsShortcutItemTruncated (CDC *pDC, CXTPShortcutBarItem *pItem)
Determines if the caption text of a specified expanded shortcut bar item has been truncated.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Attributes

BOOL | m_bHiliteBorders
TRUE to draw borders around highlighted items.
CXTPPaintManagerColor | m_clrBorderHilite
Highlighted border color.
CXTPPaintManagerColor | m_clrBackHiliteSelected
Selected highlighted background color.
- Protected Attributes inherited from CXTPShortcutBarOffice2013Theme
CXTPPaintManagerColor | m_clrGlyph
Normal glyph color.
CXTPPaintManagerColor | m_clrGlyphFill
Expanded glyph fill color.
CXTPPaintManagerColor | m_clrGlyphExpanded
Expanded glyph border color.
CXTPPaintManagerColor | m_clrGlyphPushed
Pushed glyph color.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPShortcutBarResourceTheme
- Public Attributes inherited from CXTPShortcutBarOffice2003Theme
CXTPPaintManagerColorGradient | m_grcCaption
Caption color.
CXTPPaintManagerColorGradient | m_grcItemCaption
Items color.
CXTPPaintManagerColorGradient | m_grcItemHotCaption
Items color.
CXTPPaintManagerColor | m_clrItemCaptionShadow
Color of sub-caption shadow.
CXTPPaintManagerColor | m_clrItemCaptionTop
Color under sub-caption rectangle.
CXTPPaintManagerColor | m_clrCaptionText
Color of items text.
CXTPPaintManagerColor | m_clrItemCaptionText
Color of sub-caption text.
BOOL | m_bShowTopLeftCaptionShadow
TRUE to draw rectangle around items.
- Public Attributes inherited from CXTPShortcutBarPaintManager
CXTPFont | m_xtpFontText
Text font.
CXTPFont | m_xtpFontPaneCaption
Caption font.
CXTPFont | m_xtpFontPaneItemCaption
Sub-caption font.
CXTPFont | m_xtpFontVerticalText
Navigation button text font.
int | m_nPaneItemHeight
Height of sub-pane caption.
CXTPImageManagerIcon * | m_pExpandIcon
Pointer to expand icon.
BOOL | m_bNavigationButton
TRUE if navigation button small.
int | m_nNormalIconWidth
Width of the icons.
int | m_nExpandedIconWidth
Width of the expanded icons.
BOOL | m_bBoldItemCaptionFont
TRUE to draw item with bold font.
BOOL | m_bClearTypeTextQuality
TRUE to use ClearType font.
BOOL | m_bUseStandardFont
TRUE to use standard font.
CRect | m_rcCaptionPadding
Padding of pane caption.
CRect | m_rcItemCaptionPadding
Padding of item caption.
CString | m_strOfficeFont
TRUE to use Office Tahoma font.
CXTPPaintManagerColor | m_clrPushedText
Color of caption text when an CXTPShortcutBarItem is pressed.
CXTPPaintManagerColor | m_clrSelectedText
Color of caption text when an CXTPShortcutBarItem is selected (this happens after the item is clicked).
CXTPPaintManagerColor | m_clrHotText
Color of caption text when the mouse cursor is positioned over an CXTPShortcutBarItem.
CXTPPaintManagerColor | m_clrNormalText
Color of caption text when an CXTPShortcutBarItem is displayed normally.
CXTPPaintManagerColor | m_clrDisabledText
Color of caption text when an CXTPShortcutBarItem is disabled.
CXTPPaintManagerColorGradient | m_grcSelected
Color gradient of currently selected item.
CXTPPaintManagerColorGradient m_grcHot
Color gradient of "hot" items.
CXTPPaintManagerColorGradient m_grcPushed
Color gradient of item when clicked on.
CXTPPaintManagerColorGradient | m_grcShortcutItem
Color gradient of shortcut bar items.
CXTPPaintManagerColor | m_clrShortcutItemShadow
Color of line border that goes around each item.
CXTPPaintManagerColorGradient | m_grcShortcutBarGripper
Color gradient used to draw the shortcut bar gripper.

Detailed Description

CXTPShortcutBarVisualStudio2019Theme is a CXTPShortcutBarOffice2013Theme derived class that represents a Visual Studio 2019 shortcut bar theme.

Member Function Documentation

◆ DrawPaneItemCaption()

virtual int DrawPaneItemCaption | ( | CDC * | pDC,
 |  | CXTPShortcutBarPaneItem * | pItem,
 |  | BOOL | bDraw )
 virtual

Draws the caption for a specified shortcut bar pane item.

Parameters
pDC | Pointer to the client device context.
pItem | Pointer to the CXTPShortcutBarPaneItem object to be drawn.
bDraw | TRUE to draw the shortcut bar pane item caption, FALSE to only retrieve the size of the shortcut bar pane item caption.

Panes of the shortcut bar are displayed in the shortcut bar's client area. Each pane consists of a caption and one or more sub-panes. Each sub-pane has its own caption and is drawn by the DrawPaneItemCaption method.

The caption of the shortcut bar pane item is set when the pane item is created by the CXTPShortcutBarPane::AddItem method.

The sub-items of a shortcut bar pane can be retrieved by using the CXTPShortcutBarPane::GetItem method.

Returns
The size of the shortcut pane item caption.

Reimplemented from CXTPShortcutBarOffice2013Theme.

◆ FillNavigationItemEntry()

virtual void FillNavigationItemEntry | ( | CDC * | pDC,
 |  | CXTPShortcutBarItem * | pItem )
 virtual

Fills a specified navigation item for the minimized shortcut bar control.

Parameters
pDC | Pointer to the client device context.
pItem | Pointer to the CXTPShortcutBarItem object to be filled.

Reimplemented from CXTPShortcutBarOffice2013Theme.

◆ FillShortcutItemEntry()

virtual void FillShortcutItemEntry | ( | CDC * | pDC,
 |  | CXTPShortcutBarItem * | pItem )
 virtual

Fills a specified item for the shortcut bar control.

Parameters
pDC | Pointer to the client device context.
pItem | Pointer to the CXTPShortcutBarItem object to be filled.

Reimplemented from CXTPShortcutBarOffice2013Theme.

◆ RefreshMetrics()

virtual void RefreshMetrics ( )
virtual

Refreshes the visual metrics of the shortcut bar paint manager.

This method refreshes all of the visual metrics of the shortcut bar (pane caption color, pane font, pane caption height, etc.).

Reimplemented from CXTPShortcutBarOffice2013Theme.

The documentation for this class was generated from the following file:
  • XTPShortcutBarVisualStudio2019Theme.h


Toolkit Pro: CXTPShortcutBarVisualStudio2022Theme Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPShortcutBarVisualStudio2022Theme Class Reference

CXTPShortcutBarVisualStudio2022Theme is a CXTPShortcutBarOffice2013Theme derived class that represents a Visual Studio 2022 shortcut bar theme. More...

Inheritance diagram for CXTPShortcutBarVisualStudio2022Theme:
[legend]

Public Member Functions

CXTPShortcutBarVisualStudio2022Theme ()
Constructs a CXTPShortcutBarVisualStudio2022Theme object.
virtual | ~CXTPShortcutBarVisualStudio2022Theme ()
Destroys a CXTPShortcutBarVisualStudio2022Theme object, handles cleanup and deallocation.
virtual void | RefreshMetrics ()
Refreshes the visual metrics of the shortcut bar paint manager.
virtual int | DrawPaneItemCaption (CDC *pDC, CXTPShortcutBarPaneItem *pItem, BOOL bDraw)
Draws the caption for a specified shortcut bar pane item.
virtual void | FillShortcutItemEntry (CDC *pDC, CXTPShortcutBarItem *pItem)
Fills a specified item for the shortcut bar control.
virtual void | FillNavigationItemEntry (CDC *pDC, CXTPShortcutBarItem *pItem)
Fills a specified navigation item for the minimized shortcut bar control.
- Public Member Functions inherited from CXTPShortcutBarOffice2013Theme
CXTPShortcutBarOffice2013Theme ()
Constructs a CXTPShortcutBarOffice2013Theme object.
virtual | ~CXTPShortcutBarOffice2013Theme ()
Destroys a CXTPShortcutBarOffice2013Theme object, handles cleanup and deallocation.
virtual void | DrawExpandButton (CDC *pDC, CRect rc)
Draws the expand button.
virtual int | DrawGripper (CDC *pDC, CXTPShortcutBar *pShortcutBar, BOOL bDraw)
Draws the gripper for the shortcut bar control.
virtual void | FillShortcutBar (CDC *pDC, CXTPShortcutBar *pShortcutBar)
Fills the client area of the shortcut bar control.
- Public Member Functions inherited from CXTPShortcutBarResourceTheme
CXTPShortcutBarResourceTheme ()
Constructs a CXTPShortcutBarResourceTheme object.
void | FillShortcutBar (CDC *pDC, CXTPShortcutBar *pShortcutBar)
Fills the client area of the shortcut bar control.
virtual int | DrawPaneCaption (CDC *pDC, CXTPShortcutBarPane *pPane, BOOL bDraw)
Draws the caption for a specified shortcut bar pane.
- Public Member Functions inherited from CXTPShortcutBarOffice2003Theme
CXTPShortcutBarOffice2003Theme ()
Constructs a CXTPShortcutBarOffice2003Theme object.
void | DrawShortcutBarFrame (CDC *pDC, CXTPShortcutBar *pShortcutBar)
Draws the frame for the shortcut bar control.
void | DrawImage (CDC *pDC, CPoint pt, CSize sz, CXTPImageManagerIcon *pImage, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled)
Draws the image of a shortcut bar item.
- Public Member Functions inherited from CXTPShortcutBarPaintManager
CXTPShortcutBarPaintManager ()
Constructs a CXTPShortcutBarPaintManager object.
virtual | ~CXTPShortcutBarPaintManager ()
Destroys a CXTPShortcutBarPaintManager object, handles cleanup and deallocation.
virtual void | DrawShortcutItem (CDC *pDC, CXTPShortcutBarItem *pItem)
Draws a specified item for the shortcut bar control.
virtual void | DrawNavigationItem (CDC *pDC, CXTPShortcutBarItem *pItem)
Draws a specified navigation item for the minimized shortcut bar control.
void | Rectangle (CDC *pDC, CRect rc, int nPen, int nBrush)
Draws the rectangle to be used to draw the shortcut bar items.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1, int nPen)
Draws the "gripper" lines in the gripper.
BOOL | IsShortcutItemTruncated (CDC *pDC, CXTPShortcutBarItem *pItem)
Determines if the caption text of a specified expanded shortcut bar item has been truncated.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Attributes

BOOL | m_bHiliteBorders
TRUE to draw borders around highlighted items.
CXTPPaintManagerColor | m_clrBorderHilite
Highlighted border color.
CXTPPaintManagerColor | m_clrBackHiliteSelected
Selected highlighted background color.
- Protected Attributes inherited from CXTPShortcutBarOffice2013Theme
CXTPPaintManagerColor | m_clrGlyph
Normal glyph color.
CXTPPaintManagerColor | m_clrGlyphFill
Expanded glyph fill color.
CXTPPaintManagerColor | m_clrGlyphExpanded
Expanded glyph border color.
CXTPPaintManagerColor | m_clrGlyphPushed
Pushed glyph color.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPShortcutBarResourceTheme
- Public Attributes inherited from CXTPShortcutBarOffice2003Theme
CXTPPaintManagerColorGradient | m_grcCaption
Caption color.
CXTPPaintManagerColorGradient | m_grcItemCaption
Items color.
CXTPPaintManagerColorGradient | m_grcItemHotCaption
Items color.
CXTPPaintManagerColor | m_clrItemCaptionShadow
Color of sub-caption shadow.
CXTPPaintManagerColor | m_clrItemCaptionTop
Color under sub-caption rectangle.
CXTPPaintManagerColor | m_clrCaptionText
Color of items text.
CXTPPaintManagerColor | m_clrItemCaptionText
Color of sub-caption text.
BOOL | m_bShowTopLeftCaptionShadow
TRUE to draw rectangle around items.
- Public Attributes inherited from CXTPShortcutBarPaintManager
CXTPFont | m_xtpFontText
Text font.
CXTPFont | m_xtpFontPaneCaption
Caption font.
CXTPFont | m_xtpFontPaneItemCaption
Sub-caption font.
CXTPFont | m_xtpFontVerticalText
Navigation button text font.
int | m_nPaneItemHeight
Height of sub-pane caption.
CXTPImageManagerIcon * | m_pExpandIcon
Pointer to expand icon.
BOOL | m_bNavigationButton
TRUE if navigation button small.
int | m_nNormalIconWidth
Width of the icons.
int | m_nExpandedIconWidth
Width of the expanded icons.
BOOL | m_bBoldItemCaptionFont
TRUE to draw item with bold font.
BOOL | m_bClearTypeTextQuality
TRUE to use ClearType font.
BOOL | m_bUseStandardFont
TRUE to use standard font.
CRect | m_rcCaptionPadding
Padding of pane caption.
CRect | m_rcItemCaptionPadding
Padding of item caption.
CString | m_strOfficeFont
TRUE to use Office Tahoma font.
CXTPPaintManagerColor | m_clrPushedText
Color of caption text when an CXTPShortcutBarItem is pressed.
CXTPPaintManagerColor | m_clrSelectedText
Color of caption text when an CXTPShortcutBarItem is selected (this happens after the item is clicked).
CXTPPaintManagerColor | m_clrHotText
Color of caption text when the mouse cursor is positioned over an CXTPShortcutBarItem.
CXTPPaintManagerColor | m_clrNormalText
Color of caption text when an CXTPShortcutBarItem is displayed normally.
CXTPPaintManagerColor | m_clrDisabledText
Color of caption text when an CXTPShortcutBarItem is disabled.
CXTPPaintManagerColorGradient | m_grcSelected
Color gradient of currently selected item.
CXTPPaintManagerColorGradient m_grcHot
Color gradient of "hot" items.
CXTPPaintManagerColorGradient m_grcPushed
Color gradient of item when clicked on.
CXTPPaintManagerColorGradient | m_grcShortcutItem
Color gradient of shortcut bar items.
CXTPPaintManagerColor | m_clrShortcutItemShadow
Color of line border that goes around each item.
CXTPPaintManagerColorGradient | m_grcShortcutBarGripper
Color gradient used to draw the shortcut bar gripper.

Detailed Description

CXTPShortcutBarVisualStudio2022Theme is a CXTPShortcutBarOffice2013Theme derived class that represents a Visual Studio 2022 shortcut bar theme.

Member Function Documentation

◆ DrawPaneItemCaption()

virtual int DrawPaneItemCaption | ( | CDC * | pDC,
 |  | CXTPShortcutBarPaneItem * | pItem,
 |  | BOOL | bDraw )
 virtual

Draws the caption for a specified shortcut bar pane item.

Parameters
pDC | Pointer to the client device context.
pItem | Pointer to the CXTPShortcutBarPaneItem object to be drawn.
bDraw | TRUE to draw the shortcut bar pane item caption, FALSE to only retrieve the size of the shortcut bar pane item caption.

Panes of the shortcut bar are displayed in the shortcut bar's client area. Each pane consists of a caption and one or more sub-panes. Each sub-pane has its own caption and is drawn by the DrawPaneItemCaption method.

The caption of the shortcut bar pane item is set when the pane item is created by the CXTPShortcutBarPane::AddItem method.

The sub-items of a shortcut bar pane can be retrieved by using the CXTPShortcutBarPane::GetItem method.

Returns
The size of the shortcut pane item caption.

Reimplemented from CXTPShortcutBarOffice2013Theme.

◆ FillNavigationItemEntry()

virtual void FillNavigationItemEntry | ( | CDC * | pDC,
 |  | CXTPShortcutBarItem * | pItem )
 virtual

Fills a specified navigation item for the minimized shortcut bar control.

Parameters
pDC | Pointer to the client device context.
pItem | Pointer to the CXTPShortcutBarItem object to be filled.

Reimplemented from CXTPShortcutBarOffice2013Theme.

◆ FillShortcutItemEntry()

virtual void FillShortcutItemEntry | ( | CDC * | pDC,
 |  | CXTPShortcutBarItem * | pItem )
 virtual

Fills a specified item for the shortcut bar control.

Parameters
pDC | Pointer to the client device context.
pItem | Pointer to the CXTPShortcutBarItem object to be filled.

Reimplemented from CXTPShortcutBarOffice2013Theme.

◆ RefreshMetrics()

virtual void RefreshMetrics ( )
virtual

Refreshes the visual metrics of the shortcut bar paint manager.

This method refreshes all of the visual metrics of the shortcut bar (pane caption color, pane font, pane caption height, etc.).

Reimplemented from CXTPShortcutBarOffice2013Theme.

The documentation for this class was generated from the following file:
  • XTPShortcutBarVisualStudio2022Theme.h


Toolkit Pro: CXTPShortcutListBox Class Reference

Classes | Public Types | Public Member Functions | Public Attributes | Protected Member Functions | Protected Attributes | List of all members
CXTPShortcutListBox Class Reference

CCXTPShortcutListBox is a CListBox derived class. More...

Classes

struct CONTENT_ITEM
CONTENT_ITEM structure is used by the CXTPShortcutListBox class to maintain information about a particular menu item. More...

Public Types

typedef CList< CONTENT_ITEM *, CONTENT_ITEM * > CContentItemList
List for maintaining CONTENT_ITEM structures.

Public Member Functions

CXTPShortcutListBox ()
Constructs a CXTPShortcutListBox object.
virtual | ~CXTPShortcutListBox ()
Destroys a CXTPShortcutListBox object, handles cleanup and deallocation.
BOOL | SetTheme (XTPControlTheme eTheme)
Call this member to switch the visual theme of the control.
CXTPShortcutListBoxTheme * GetTheme ()
Call this member function to get a pointer to the currently selected theme.
virtual BOOL | Create (DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID)
This member function creates an Outlook Bar control.
void | SetColors (COLORREF clrText, COLORREF clrBack, COLORREF clrBackDark=COLORREF_NULL)
Call this member function to set the text and background colors for the Outlook bar.
int | InsertMenuItem (int iIndex, UINT nIconID, LPCTSTR lpszText, BOOL bEnabled=TRUE)
This member function inserts a menu item into the Outlook bar.
int | AddMenuItem (UINT nIconID, LPCTSTR lpszText, BOOL bEnabled=TRUE)
Call this member function to add a menu item to an Outlook bar.
BOOL | EnableMenuItem (int iItem, BOOL bEnabled)
Call this member function to enable/disable the menu item specified by iItem.
CONTENT_ITEM * | GetMenuItem (int iItem)
Call this member function to retrieve a CONTENT_ITEM object that represents the menu item specified by 'iItem'.
void | SetHighlightCursor (UINT nIDCursor, bool bNoBorder=false, bool bNoUnderline=false)
Call this member function to set the cursor, text, and border attributes for a highlighted item.
int | GetTextHeight (LPCTSTR lspzItem) const
This member function is called by the outlook bar to determine the string height for a multi-line text item.

Public Attributes

bool | m_bNoBorder
true to disable a border drawn around highlighted items.
bool | m_bNoUnderline
true if the text is not drawn with a underline when no highlight border is displayed.

Protected Member Functions

virtual void RefreshMetrics ()
Call this member function to refresh theme colors and redraw the control.

Protected Attributes

int | m_nPrevIndex
Previously selected menu index.
int | m_bHilightItemID
Index of the currently highlighted item, set to -1 if no selection.
bool | m_bHilight
true when the menu item is selected.
bool | m_bTimerActive
true if the redraw timer is active.
CPoint | m_point
Holds the cursor position.
CContentItemList | m_arContentItems
Array of CONTENT_ITEM structs that represent each item in the Outlook bar.
HCURSOR | m_hCursor
Cursor display when item is hovered over.
CXTPShortcutListBoxTheme * | m_pTheme
Pointer to the current theme object.

Detailed Description

CCXTPShortcutListBox is a CListBox derived class.

It is used to implement an Outlook bar style control. It can only be used with the LBS_OWNERDRAWVARIABLE style bit set. This is a simpler version of CXTOutBarCtrl and does not allow for shortcut folders.

Member Typedef Documentation

◆ CContentItemList

CList<CONTENT_ITEM*, CONTENT_ITEM*> CContentItemList

List for maintaining CONTENT_ITEM structures.

CList definition used by the CXTPShortcutListBox class to maintain a list of CONTENT_ITEM structures representing each menu item defined for the menu list box control.

See also
CXTPShortcutListBox, CXTPShortcutListBox::InsertMenuItem, CONTENT_ITEM

Member Function Documentation

◆ AddMenuItem()

int AddMenuItem | ( | UINT | nIconID,
 |  | LPCTSTR | lpszText,
 |  | BOOL | bEnabled = TRUE )

Call this member function to add a menu item to an Outlook bar.

If the Outlook bar was not created with the LBS_SORT style, then the menu item is added to the end of the Outlook bar. Otherwise, the menu item is inserted into the Outlook bar, and the Outlook bar is sorted. If the Outlook bar was created with the LBS_SORT style but not the LBS_HASSTRINGS style, then the framework sorts the Outlook bar by one or more calls to the CompareItem member function. Use InsertMenuItem to insert a menu item into a specific location within the Outlook bar.

Parameters
nIconID | Resource ID of the icon associated with this menu item.
lpszText | Pointer to the NULL-terminated string for the menu item.
bEnabled | TRUE if the menu item is enabled.
Returns
The zero-based index to the menu item in the Outlook bar. The return value is LB_ERR if an error occurs. The return value is LB_ERRSPACE if insufficient space is available to store the new menu item.

◆ Create()

virtual BOOL Create | ( | DWORD | dwStyle,
 |  | const RECT & | rect,
 |  | CWnd * | pParentWnd,
 |  | UINT | nID )
 virtual

This member function creates an Outlook Bar control.

Parameters
dwStyle | Window style.
rect | The size and position of the window, in client coordinates of 'pParentWnd'.
pParentWnd | The parent window.
nID | The ID of the child window.
Returns
Nonzero if successful, otherwise zero.

◆ EnableMenuItem()

BOOL EnableMenuItem | ( | int | iItem,
 |  | BOOL | bEnabled )

Call this member function to enable/disable the menu item specified by iItem.

Parameters
iItem | Index of the menu item to enable or disable.
bEnabled | TRUE to enable the menu item, FALSE to disable.
Returns
TRUE if the menu item's enabled state was successfully updated, otherwise FALSE.

◆ GetMenuItem()

CONTENT_ITEM * GetMenuItem ( int iItem )

Call this member function to retrieve a CONTENT_ITEM object that represents the menu item specified by 'iItem'.

Parameters
iItem Specifies the zero-based index of the menu item to retrieve.
Returns
A CONTENT_ITEM pointer.

◆ GetTextHeight()

int GetTextHeight ( LPCTSTR lspzItem ) const

This member function is called by the outlook bar to determine the string height for a multi-line text item.

Parameters
lspzItem A NULL-terminated string.
Returns
The height, in pixels, of the specified string.

◆ GetTheme()

CXTPShortcutListBoxTheme * GetTheme ( )

Call this member function to get a pointer to the currently selected theme.

Returns
A pointer to a CXTPShortcutListBoxTheme object representing the currently selected theme.

◆ InsertMenuItem()

int InsertMenuItem | ( | int | iIndex,
 |  | UINT | nIconID,
 |  | LPCTSTR | lpszText,
 |  | BOOL | bEnabled = TRUE )

This member function inserts a menu item into the Outlook bar.

Unlike the AddMenuItem member function, InsertMenuItem does not cause an Outlook bar with the LBS_SORT style to be sorted.

Parameters
iIndex | Specifies the zero-based index of the position to insert the menu item. If this parameter is -1, the menu item is added to the end of the list.
nIconID | Resource ID of the icon associated with this menu item.
lpszText | Pointer to the NULL-terminated string for the menu item.
bEnabled | TRUE if the menu item is enabled.
Returns
The zero-based index of the position at which the menu item was inserted. The return value is LB_ERR if an error occurs. The return value is LB_ERRSPACE if insufficient space is available to store the new menu item.

◆ SetColors()

void SetColors | ( | COLORREF | clrText,
 |  | COLORREF | clrBack,
 |  | COLORREF | clrBackDark = COLORREF_NULL )

Call this member function to set the text and background colors for the Outlook bar.

Parameters
clrText | An RGB value representing the text color.
clrBack | An RGB value representing the background color.
clrBackDark | An RGB value representing the dark background color. If defined, then the background will be drawn with a gradient effect from crBack to crBackDark.

◆ SetHighlightCursor()

void SetHighlightCursor | ( | UINT | nIDCursor,
 |  | bool | bNoBorder = false,
 |  | bool | bNoUnderline = false )

Call this member function to set the cursor, text, and border attributes for a highlighted item.

Parameters
nIDCursor | Resource ID of the highlight cursor.
bNoBorder | True if not border is displayed when item is highlighted.
bNoUnderline | True if text is not underlined when item is highlighted.

◆ SetTheme()

BOOL SetTheme ( XTPControlTheme eTheme )

Call this member to switch the visual theme of the control.

Parameters
eTheme New visual theme. Can be any of the values listed in the Remarks section.

eTheme can be one of the following: xtpControlThemeDefault: Use default theme. xtpControlThemeOfficeXP: Use Office XP theme. xtpControlThemeOffice2003: Use Office 2003 theme.

Returns
TRUE if successful; otherwise FALSE.
The documentation for this class was generated from the following file:
  • XTPShortcutListBox.h


Toolkit Pro: CXTPShortcutListBox::CONTENT_ITEM Struct Reference

  • CXTPShortcutListBox
  • CONTENT_ITEM
Public Attributes | List of all members
CXTPShortcutListBox::CONTENT_ITEM Struct Reference

CONTENT_ITEM structure is used by the CXTPShortcutListBox class to maintain information about a particular menu item. More...

Public Attributes

int | m_nIndex
Zero-based index for the menu item.
BOOL | m_bEnabled
TRUE if the menu item is enabled.
CString | m_strText
Text label for the menu item.
CXTPImageManagerIcon * | m_pIcon
Icon handle for the menu item.

Detailed Description

CONTENT_ITEM structure is used by the CXTPShortcutListBox class to maintain information about a particular menu item.

See also
CXTPShortcutListBox
The documentation for this struct was generated from the following file:
  • XTPShortcutListBox.h


Toolkit Pro: CXTPShortcutListBoxTheme Class Reference

Public Member Functions | Public Attributes | Protected Member Functions | List of all members
CXTPShortcutListBoxTheme Class Reference

CXTPShortcutListBoxTheme is used to draw the CXTPShortcutListBox object. More...

Inheritance diagram for CXTPShortcutListBoxTheme:
[legend]

Public Member Functions

CXTPShortcutListBoxTheme ()
Constructs a CXTPShortcutListBoxTheme object.
virtual | ~CXTPShortcutListBoxTheme ()
Destroys a CXTPShortcutListBoxTheme object, handles cleanup and deallocation.
virtual void | RefreshMetrics (CXTPShortcutListBox *pList)
Call this function to refresh the colors for the list box control.
virtual void | DrawItem (CXTPShortcutListBox *pMenuListBox, LPDRAWITEMSTRUCT lpDIS)
Call this function to draw an item in the menu list box.
COLORREF | GetBackColor ()
Call this function to get the background color of the menu list box.
COLORREF | GetTextColor ()
Call this function to get the color of the text used in the menu list box.
- Public Member Functions inherited from CXTPControlTheme
CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme | GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Public Attributes

CXTPPaintManagerColor | m_crItemText
Item text color.
CXTPPaintManagerColor | m_crItemTextDisabled
Disabled item text color.
CXTPPaintManagerColorGradient | m_crgBack
Background color.
CXTPPaintManagerColorGradient | m_crgItemBorder
Item border color.
CXTPPaintManagerColorGradient | m_crgItemBackHot
Selected Item color.
CXTPPaintManagerColorGradient | m_crgItemBackPressed
Pressed Item color.
int | m_cyEdge
Height in pixels of the space between the icon and text.
int | m_cxIcon
Width of the menu icon.
int | m_cyIcon
Height of the menu icon.

Protected Member Functions

virtual void | DrawImage (CDC *pDC, CRect &rcIcon, CXTPImageManagerIcon *pImage, BOOL bEnabled, BOOL bSelected, BOOL bPressed)
This method is called to draw an image of the item.
virtual void | DrawText (CDC *pDC, CRect &rcText, CXTPShortcutListBox::CONTENT_ITEM *pCI)
This method is called to draw the text of the item.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlTheme
static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Attributes inherited from CXTPControlTheme
XTPControlTheme | m_nTheme
Currently selected theme style index.

Detailed Description

CXTPShortcutListBoxTheme is used to draw the CXTPShortcutListBox object.

All themes used for CXTPButton should inherit from this base class. Note: A Menu List box is similar in appearance to an Outlook bar.

Member Function Documentation

◆ DrawImage()

virtual void DrawImage | ( | CDC * | pDC,
 |  | CRect & | rcIcon,
 |  | CXTPImageManagerIcon * | pImage,
 |  | BOOL | bEnabled,
 |  | BOOL | bSelected,
 |  | BOOL | bPressed )
 protectedvirtual

This method is called to draw an image of the item.

Parameters
pDC | Pointer to a valid device context.
rcIcon | Bounding rectangle.
pImage | Pointer to the image to draw.
bEnabled | TRUE to draw the enabled state of the image.
bSelected | TRUE to draw the selected state of the image.
bPressed | TRUE to draw the pressed state of the image.

Reimplemented in CXTPShortcutListBoxThemeOffice2003, and CXTPShortcutListBoxThemeOfficeXP.

◆ DrawItem()

virtual void DrawItem | ( | CXTPShortcutListBox * | pMenuListBox,
 |  | LPDRAWITEMSTRUCT | lpDIS )
 virtual

Call this function to draw an item in the menu list box.

Parameters
pMenuListBox | A pointer to a CXTPShortcutListBox object.
lpDIS | A LPDRAWITEMSTRUCT struct that contains information about how the list box should be drawn.

◆ DrawText()

virtual void DrawText | ( | CDC * | pDC,
 |  | CRect & | rcText,
 |  | CXTPShortcutListBox::CONTENT_ITEM * | pCI )
 protectedvirtual

This method is called to draw the text of the item.

Parameters
pDC | Pointer to a valid device context.
rcText | Bounding rectangle.
pCI | Pointer to the CONTENT_ITEM to draw.

Reimplemented in CXTPShortcutListBoxThemeOfficeXP.

◆ GetBackColor()

COLORREF GetBackColor ( )

Call this function to get the background color of the menu list box.

Returns
A COLORREF value corresponding to the background color.

◆ GetTextColor()

COLORREF GetTextColor ( )

Call this function to get the color of the text used in the menu list box.

Returns
A COLORREF value corresponding to the text color.

◆ RefreshMetrics()

virtual void RefreshMetrics ( CXTPShortcutListBox * pList )
virtual

Call this function to refresh the colors for the list box control.

Also, this function gets the system default size for icons, and the default dimensions of a 3D border. Lastly, this function sets the default color values for the different parts of buttons. i.e button pressed style, button highlight, button top left color, and button bottom right color.

Parameters
pList Pointer to the CXTPShortcutListBox object.

Reimplemented in CXTPShortcutListBoxThemeOffice2003, and CXTPShortcutListBoxThemeOfficeXP.

The documentation for this class was generated from the following file:
  • XTPShortcutListBoxTheme.h


Toolkit Pro: CXTPShortcutListBoxThemeOffice2003 Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPShortcutListBoxThemeOffice2003 Class Reference

Class CXTPShortcutListBoxThemeOffice2003 is derived from CXTPShortcutListBoxThemeXP. More...

Inheritance diagram for CXTPShortcutListBoxThemeOffice2003:
[legend]

Public Member Functions

CXTPShortcutListBoxThemeOffice2003 ()
Constructs a CXTPShortcutListBoxThemeOffice2003 object.
void | RefreshMetrics (CXTPShortcutListBox *pList)
Call this function to refresh the colors for the list box control.
- Public Member Functions inherited from CXTPShortcutListBoxThemeOfficeXP
CXTPShortcutListBoxThemeOfficeXP ()
Constructs a CXTPShortcutListBoxThemeOfficeXP object.
void | RefreshMetrics (CXTPShortcutListBox *pList)
Call this function to refresh the colors for the list box control.
- Public Member Functions inherited from CXTPShortcutListBoxTheme
CXTPShortcutListBoxTheme ()
Constructs a CXTPShortcutListBoxTheme object.
virtual | ~CXTPShortcutListBoxTheme ()
Destroys a CXTPShortcutListBoxTheme object, handles cleanup and deallocation.
virtual void | DrawItem (CXTPShortcutListBox *pMenuListBox, LPDRAWITEMSTRUCT lpDIS)
Call this function to draw an item in the menu list box.
COLORREF | GetBackColor ()
Call this function to get the background color of the menu list box.
COLORREF | GetTextColor ()
Call this function to get the color of the text used in the menu list box.
- Public Member Functions inherited from CXTPControlTheme
CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme | GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

virtual void | DrawImage (CDC *pDC, CRect &rcIcon, CXTPImageManagerIcon *pImage, BOOL bEnabled, BOOL bSelected, BOOL bPressed)
This method is called to draw an image of the item.
- Protected Member Functions inherited from CXTPShortcutListBoxThemeOfficeXP
virtual void | DrawText (CDC *pDC, CRect &rcText, CXTPShortcutListBox::CONTENT_ITEM *pCI)
This method is called to draw the text of the item.
- Protected Member Functions inherited from CXTPShortcutListBoxTheme

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlTheme
static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPShortcutListBoxTheme
CXTPPaintManagerColor | m_crItemText
Item text color.
CXTPPaintManagerColor | m_crItemTextDisabled
Disabled item text color.
CXTPPaintManagerColorGradient | m_crgBack
Background color.
CXTPPaintManagerColorGradient | m_crgItemBorder
Item border color.
CXTPPaintManagerColorGradient | m_crgItemBackHot
Selected Item color.
CXTPPaintManagerColorGradient | m_crgItemBackPressed
Pressed Item color.
int | m_cyEdge
Height in pixels of the space between the icon and text.
int | m_cxIcon
Width of the menu icon.
int | m_cyIcon
Height of the menu icon.
- Protected Attributes inherited from CXTPControlTheme
XTPControlTheme | m_nTheme
Currently selected theme style index.

Detailed Description

Class CXTPShortcutListBoxThemeOffice2003 is derived from CXTPShortcutListBoxThemeXP.

This class is used to implement the Office 2003 theme for Menu List Boxes.

Member Function Documentation

◆ DrawImage()

virtual void DrawImage | ( | CDC * | pDC,
 |  | CRect & | rcIcon,
 |  | CXTPImageManagerIcon * | pImage,
 |  | BOOL | bEnabled,
 |  | BOOL | bSelected,
 |  | BOOL | bPressed )
 protectedvirtual

This method is called to draw an image of the item.

Parameters
pDC | Pointer to a valid device context.
rcIcon | Bounding rectangle.
pImage | Pointer to the image to draw.
bEnabled | TRUE to draw the enabled state of the image.
bSelected | TRUE to draw the selected state of the image.
bPressed | TRUE to draw the pressed state of the image.

Reimplemented from CXTPShortcutListBoxThemeOfficeXP.

◆ RefreshMetrics()

void RefreshMetrics ( CXTPShortcutListBox * pList )
virtual

Call this function to refresh the colors for the list box control.

Also, this function gets the system default size for icons, and the default dimensions of a 3D border. Lastly, this function sets the default color values for the different parts of buttons. i.e button pressed style, button highlight, button top left color, and button bottom right color.

Parameters
pList Pointer to the CXTPShortcutListBox object.

Reimplemented from CXTPShortcutListBoxTheme.

The documentation for this class was generated from the following file:
  • XTPShortcutListBoxTheme.h


Toolkit Pro: CXTPShortcutListBoxThemeOfficeXP Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPShortcutListBoxThemeOfficeXP Class Reference

Class CXTPShortcutListBoxThemeOfficeXP is derived from CXTPShortcutListBoxTheme. More...

Inheritance diagram for CXTPShortcutListBoxThemeOfficeXP:
[legend]

Public Member Functions

CXTPShortcutListBoxThemeOfficeXP ()
Constructs a CXTPShortcutListBoxThemeOfficeXP object.
void | RefreshMetrics (CXTPShortcutListBox *pList)
Call this function to refresh the colors for the list box control.
- Public Member Functions inherited from CXTPShortcutListBoxTheme
CXTPShortcutListBoxTheme ()
Constructs a CXTPShortcutListBoxTheme object.
virtual | ~CXTPShortcutListBoxTheme ()
Destroys a CXTPShortcutListBoxTheme object, handles cleanup and deallocation.
virtual void | DrawItem (CXTPShortcutListBox *pMenuListBox, LPDRAWITEMSTRUCT lpDIS)
Call this function to draw an item in the menu list box.
COLORREF | GetBackColor ()
Call this function to get the background color of the menu list box.
COLORREF | GetTextColor ()
Call this function to get the color of the text used in the menu list box.
- Public Member Functions inherited from CXTPControlTheme
CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme | GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

virtual void | DrawImage (CDC *pDC, CRect &rcIcon, CXTPImageManagerIcon *pImage, BOOL bEnabled, BOOL bSelected, BOOL bPressed)
This method is called to draw an image of the item.
virtual void | DrawText (CDC *pDC, CRect &rcText, CXTPShortcutListBox::CONTENT_ITEM *pCI)
This method is called to draw the text of the item.
- Protected Member Functions inherited from CXTPShortcutListBoxTheme

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlTheme
static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPShortcutListBoxTheme
CXTPPaintManagerColor | m_crItemText
Item text color.
CXTPPaintManagerColor | m_crItemTextDisabled
Disabled item text color.
CXTPPaintManagerColorGradient | m_crgBack
Background color.
CXTPPaintManagerColorGradient | m_crgItemBorder
Item border color.
CXTPPaintManagerColorGradient | m_crgItemBackHot
Selected Item color.
CXTPPaintManagerColorGradient | m_crgItemBackPressed
Pressed Item color.
int | m_cyEdge
Height in pixels of the space between the icon and text.
int | m_cxIcon
Width of the menu icon.
int | m_cyIcon
Height of the menu icon.
- Protected Attributes inherited from CXTPControlTheme
XTPControlTheme | m_nTheme
Currently selected theme style index.

Detailed Description

Class CXTPShortcutListBoxThemeOfficeXP is derived from CXTPShortcutListBoxTheme.

This class is used to implement the Office XP theme for Menu List Boxes.

Member Function Documentation

◆ DrawImage()

virtual void DrawImage | ( | CDC * | pDC,
 |  | CRect & | rcIcon,
 |  | CXTPImageManagerIcon * | pImage,
 |  | BOOL | bEnabled,
 |  | BOOL | bSelected,
 |  | BOOL | bPressed )
 protectedvirtual

This method is called to draw an image of the item.

Parameters
pDC | Pointer to a valid device context.
rcIcon | Bounding rectangle.
pImage | Pointer to the image to draw.
bEnabled | TRUE to draw the enabled state of the image.
bSelected | TRUE to draw the selected state of the image.
bPressed | TRUE to draw the pressed state of the image.

Reimplemented from CXTPShortcutListBoxTheme.

Reimplemented in CXTPShortcutListBoxThemeOffice2003.

◆ DrawText()

virtual void DrawText | ( | CDC * | pDC,
 |  | CRect & | rcText,
 |  | CXTPShortcutListBox::CONTENT_ITEM * | pCI )
 protectedvirtual

This method is called to draw the text of the item.

Parameters
pDC | Pointer to a valid device context.
rcText | Bounding rectangle.
pCI | Pointer to the CONTENT_ITEM to draw.

Reimplemented from CXTPShortcutListBoxTheme.

◆ RefreshMetrics()

void RefreshMetrics ( CXTPShortcutListBox * pList )
virtual

Call this function to refresh the colors for the list box control.

Also, this function gets the system default size for icons, and the default dimensions of a 3D border. Lastly, this function sets the default color values for the different parts of buttons. i.e button pressed style, button highlight, button top left color, and button bottom right color.

Parameters
pList Pointer to the CXTPShortcutListBox object.

Reimplemented from CXTPShortcutListBoxTheme.

The documentation for this class was generated from the following file:
  • XTPShortcutListBoxTheme.h


Toolkit Pro: CXTPShortcutManager Class Reference

Public Member Functions | Public Attributes | Protected Attributes | List of all members
CXTPShortcutManager Class Reference

CXTPShortcutManager is a standalone class used to manipulate accelerators of a frame. More...

Inheritance diagram for CXTPShortcutManager:
[legend]

Public Member Functions

CXTPShortcutManager (CXTPCommandBars *pCommandBars)
Constructs a CXTPShortcutManager object.
~CXTPShortcutManager ()
Destroys a CXTPShortcutManager object, handles cleanup and deallocation.
virtual BOOL | FindDefaultAccelerator (int nCmd, CString &strShortcut)
Retrieves the shortcut text for a specified command.
BOOL | FindDefaultFrameAccelerator (int nCmd, CString &strShortcut)
Retrieves the default shortcut for a specified command.
virtual CString | Format (CXTPShortcutManagerAccel *lpAccel, int *pPriority)
This method is called to retrieve a text presentation of ACCEL.
virtual CString | GetKeyNameText (UINT uiVirtKey)
This function retrieves a CString object that represents the name of a key.
virtual BOOL | OnPreviewEditKey (CXTPShortcutManagerAccel *pAccel)
The OnPreviewEditKey function is called to determine if a user-defined shortcut is allowed.
virtual BOOL | OnBeforeAdd (CXTPShortcutManagerAccel *pAccel)
This method is called before the user adds a new shortcut.
virtual BOOL | OnBeforeRemove (CXTPShortcutManagerAccel *pAccel)
This method is called before the user removes a shortcut.
void | SetKeyNameText (UINT uiVirtKey, LPCTSTR lpszKeyNameText)
Call this member to localize the name text of a shortcut key.
void | UseSystemKeyNameText (BOOL bSystemKey)
Call this member to use system localized shortcuts.
virtual void | DisableShortcuts (BOOL bDisable)
This method is called to disable/enable shortcuts usage.
virtual BOOL | TranslateAccelerator (LPMSG lpMsg)
The TranslateAccelerator function processes accelerator keys for menu commands.
void | SaveShortcuts (LPCTSTR lpszProfileName)
Call this function to save the accelerators to the registry or .INI file.
void | LoadShortcuts (LPCTSTR lpszProfileName)
Call this function to retrieve accelerators from the registry or .INI file.
virtual void | DoPropExchange (CXTPPropExchange *pPX)
Either reads this object from or writes this object to an archive.
void | SetAccelerators (UINT nIDResource)
Call this member to create original accelerators.
void | SetDefaultAccelerator (HACCEL hAccelTable)
Call this member to set the accelerator table.
virtual CXTPShortcutManagerAccelTable * | GetDefaultAccelerator () const
Call this member to get the accelerator table.
CXTPShortcutManagerAccelTable * | GetOriginalAccelerator () const
Call this member to get original accelerators.
virtual void | Reset ()
Call this member to reset shortcuts.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Public Attributes

BOOL | m_bAllowEscapeShortcut
TRUE to allow escape to be used as a shortcut.
BOOL | m_bUseSystemKeyNameText
TRUE to use localized shortcuts.
BOOL | m_bAllowDoubleKeyShortcuts
TRUE to allow double key shortcuts(ex: Ctrl+K, Ctrl+V).
int | m_nDisableShortcuts
Number of shortcuts that have been disabled.
BOOL | m_bDisableOnCapture
Specifies whether the commandbars will process keybindings while another control is capturing input.
BOOL | m_nEnableCustomShortcutText
TRUE to allow adding custom text to be displayed as a shortcut.

Protected Attributes

CXTPShortcutManagerAccelTable * | m_pAccelTable
Accelerator table.
CXTPShortcutManagerAccelTable * | m_pOriginalAccelTable
Original accelerator table.
CXTPCommandBars * | m_pCommandBars
Parent CommandBars pointer.
CKeyNameText * | m_pKeyNameText
KeyNameText map.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

CXTPShortcutManager is a standalone class used to manipulate accelerators of a frame.

Constructor & Destructor Documentation

◆ CXTPShortcutManager()

CXTPShortcutManager ( CXTPCommandBars * pCommandBars )

Constructs a CXTPShortcutManager object.

Parameters
pCommandBars Owner CommandBars object.

Member Function Documentation

◆ DisableShortcuts()

virtual void DisableShortcuts ( BOOL bDisable )
virtual

This method is called to disable/enable shortcuts usage.

Parameters
bDisable TRUE to disable shortcuts, FALSE to enable shortcuts.

◆ DoPropExchange()

virtual void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Either reads this object from or writes this object to an archive.

Parameters
pPX A CXTPPropExchange object to serialize to or from.

◆ FindDefaultAccelerator()

virtual BOOL FindDefaultAccelerator | ( | int | nCmd,
 |  | CString & | strShortcut )
 virtual

Retrieves the shortcut text for a specified command.

Parameters
nCmd | Command with the shortcut text to retrieve.
strShortcut | Shortcut text reference.
Returns
TRUE if the shortcut was found.

◆ FindDefaultFrameAccelerator()

BOOL FindDefaultFrameAccelerator | ( | int | nCmd,
 |  | CString & | strShortcut )

Retrieves the default shortcut for a specified command.

Parameters
nCmd | Command with the accel to retrieve.
strShortcut | Shortcut text reference.
Returns
TRUE if the command was found.

◆ Format()

virtual CString Format | ( | CXTPShortcutManagerAccel * | lpAccel,
 |  | int * | pPriority )
 virtual

This method is called to retrieve a text presentation of ACCEL.

You can override this method.

Parameters
lpAccel | Accelerator to format.
pPriority | Returns the priority of the accelerator to be used to determine what accelerator is used as the default.
Returns
Retrieves a text presentation of ACCEL

◆ GetDefaultAccelerator()

AFX_INLINE CXTPShortcutManagerAccelTable * GetDefaultAccelerator ( ) const
virtual

Call this member to get the accelerator table.

Returns
Accelerator table handle.

◆ GetKeyNameText()

virtual CString GetKeyNameText ( UINT uiVirtKey )
virtual

This function retrieves a CString object that represents the name of a key.

Override this member function to provide additional functionality.

Parameters
uiVirtKey Virtual-key of accelerator.
Returns
A CString object that represents the name of a key.

◆ GetOriginalAccelerator()

AFX_INLINE CXTPShortcutManagerAccelTable * GetOriginalAccelerator ( ) const

Call this member to get original accelerators.

Accelerator table handle.

Returns
Returns original accelerators

◆ LoadShortcuts()

void LoadShortcuts ( LPCTSTR lpszProfileName )

Call this function to retrieve accelerators from the registry or .INI file.

Parameters
lpszProfileName Pointer to a null-terminated string that specifies the name of a section in the initialization file or a key in the Windows registry where state information is stored.

◆ OnBeforeAdd()

virtual BOOL OnBeforeAdd ( CXTPShortcutManagerAccel * pAccel )
virtual

This method is called before the user adds a new shortcut.

Parameters
pAccel New shortcut to add.
Returns
TRUE if handling has been cancelled, FALSE otherwise.
See also
OnBeforeRemove

◆ OnBeforeRemove()

virtual BOOL OnBeforeRemove ( CXTPShortcutManagerAccel * pAccel )
virtual

This method is called before the user removes a shortcut.

Parameters
pAccel Shortcut to be removed.
Returns
TRUE if handling has been cancelled, FALSE otherwise.
See also
OnBeforeAdd

◆ OnPreviewEditKey()

virtual BOOL OnPreviewEditKey ( CXTPShortcutManagerAccel * pAccel )
virtual

The OnPreviewEditKey function is called to determine if a user-defined shortcut is allowed.

Parameters
pAccel User pressed key.
Returns
TRUE if the key is allowed.

◆ SaveShortcuts()

void SaveShortcuts ( LPCTSTR lpszProfileName )

Call this function to save the accelerators to the registry or .INI file.

Parameters
lpszProfileName Pointer to a null-terminated string that specifies the name of a section in the initialization file or a key in the Windows registry where state information is stored.

◆ SetAccelerators()

void SetAccelerators ( UINT nIDResource )

Call this member to create original accelerators.

Parameters
nIDResource Resource identifier of Accelerator table.

◆ SetDefaultAccelerator()

void SetDefaultAccelerator ( HACCEL hAccelTable )

Call this member to set the accelerator table.

Parameters
hAccelTable New accelerators to be set.

◆ SetKeyNameText()

void SetKeyNameText | ( | UINT | uiVirtKey,
 |  | LPCTSTR | lpszKeyNameText )

Call this member to localize the name text of a shortcut key.

Parameters
uiVirtKey | Virtual-key of accelerator.
lpszKeyNameText | New text that will be associated with the virtual-key.

Example:

pCommandBars->GetShortcutManager()->SetKeyNameText(VK_CONTROL, _T("Strg"));

◆ TranslateAccelerator()

virtual BOOL TranslateAccelerator ( LPMSG lpMsg )
virtual

The TranslateAccelerator function processes accelerator keys for menu commands.

Parameters
lpMsg Pointer to an MSG structure that contains message information.
Returns
Nonzero if the function is successful. FALSE if the function fails.

◆ UseSystemKeyNameText()

AFX_INLINE void UseSystemKeyNameText ( BOOL bSystemKey )

Call this member to use system localized shortcuts.

Parameters
bSystemKey TRUE to allow the system to localize shortcuts instead of using a predefined shortcuts table.

Example:

pCommandBars->GetShortcutManager()->UseSystemKeyNameText(TRUE);
The documentation for this class was generated from the following file:
  • XTPShortcutManager.h


Toolkit Pro: CXTPShortcutManagerAccel Class Reference

Public Member Functions | List of all members
CXTPShortcutManagerAccel Class Reference

CXTPShortcutManagerAccel represents an accelerator key used in an accelerator table. More...

Inheritance diagram for CXTPShortcutManagerAccel:
[legend]

Public Member Functions

CXTPShortcutManagerAccel ()
Constructs a CXTPShortcutManagerAccel object.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

CXTPShortcutManagerAccel represents an accelerator key used in an accelerator table.

The documentation for this class was generated from the following file:
  • XTPShortcutManager.h


Toolkit Pro: CXTPShortcutManagerAccelTable Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPShortcutManagerAccelTable Class Reference

CXTPShortcutManagerAccelTable represents an accelerator table for the CXTPShortcutManager class. More...

Public Member Functions

CXTPShortcutManagerAccelTable (CXTPShortcutManager *pManager)
Constructs a CXTPShortcutManagerAccelTable object.
~CXTPShortcutManagerAccelTable ()
Destroys a CXTPShortcutManagerAccelTable object, handles cleanup and deallocation.
int | GetCount () const
Determines the count of accels in the table.
CXTPShortcutManagerAccel * | GetAt (int nIndex) const
Retrieves an accel by its index.
void | Add (const XTP_SHORTCUTMANAGER_ACCEL &accel)
Adds a new accelerator to the table.
XTP_SHORTCUTMANAGER_ACCEL * | CopyAccels () const
Call this method to create an array of all the elements in the table.
void | CopyAccelTable (HACCEL hAccelTable)
Call this method to copy accels.
void | CopyAccelTable (CXTPShortcutManagerAccelTable *pAccelTable)
Call this method to copy accels.
void | CopyAccelTable (LPACCEL lpAccel, int nSize)
Call this method to copy accels.
void | RemoveAll ()
Removes all elements in the table.
void | RemoveAt (int nIndex)
Call this method to remove an accel by its index.

Protected Attributes

CArray< CXTPShortcutManagerAccel *, CXTPShortcutManagerAccel * > | m_arrAccels
Array of accels.
CXTPShortcutManager * | m_pManager
Parent manager.

Detailed Description

CXTPShortcutManagerAccelTable represents an accelerator table for the CXTPShortcutManager class.

Constructor & Destructor Documentation

◆ CXTPShortcutManagerAccelTable()

CXTPShortcutManagerAccelTable ( CXTPShortcutManager * pManager )

Constructs a CXTPShortcutManagerAccelTable object.

Parameters
pManager Shortcut manager pointer

Member Function Documentation

◆ Add()

void Add ( const XTP_SHORTCUTMANAGER_ACCEL & accel )

Adds a new accelerator to the table.

Parameters
accel Pointer to the accel to add.

◆ CopyAccels()

XTP_SHORTCUTMANAGER_ACCEL * CopyAccels ( ) const

Call this method to create an array of all the elements in the table.

Returns
Pointer to a XTP_SHORTCUTMANAGER_ACCEL array.

◆ CopyAccelTable() [1/3]

void CopyAccelTable ( CXTPShortcutManagerAccelTable * pAccelTable )

Call this method to copy accels.

Parameters
pAccelTable Another accel table to copy from.

◆ CopyAccelTable() [2/3]

void CopyAccelTable ( HACCEL hAccelTable )

Call this method to copy accels.

Parameters
hAccelTable Windows HACCEL structure.

◆ CopyAccelTable() [3/3]

void CopyAccelTable | ( | LPACCEL | lpAccel,
 |  | int | nSize )

Call this method to copy accels.

Parameters
lpAccel | Array of ACCEL structure.
nSize | Count of elements in lpAccel.

◆ GetAt()

CXTPShortcutManagerAccel * GetAt ( int nIndex ) const

Retrieves an accel by its index.

Parameters
nIndex Index of the accel to retrieve.
Returns
Pointer to a CXTPShortcutManagerAccel object.

◆ GetCount()

int GetCount ( ) const

Determines the count of accels in the table.

Returns
Number of accels in the table.

◆ RemoveAt()

void RemoveAt ( int nIndex )

Call this method to remove an accel by its index.

Parameters
nIndex Index of the accel to remove.
The documentation for this class was generated from the following file:
  • XTPShortcutManager.h


Toolkit Pro: CXTPSimpleCriticalSection Class Reference

Classes | Public Member Functions | List of all members
CXTPSimpleCriticalSection Class Reference

Implements simple and lightweight synchronization critical section primitive. More...

Classes

class CLock
A helper class for locking a scope or providing exception safe locking. More...

Public Member Functions

CXTPSimpleCriticalSection ()
Construct critical section.
~CXTPSimpleCriticalSection ()
Handles critical section destruction.
void | Enter ()
Enters critical section.
void | Leave ()
Releases the critical section.

Detailed Description

Implements simple and lightweight synchronization critical section primitive.

Multi-core and multi-CPU safe.

Member Function Documentation

◆ Enter()

void Enter ( )

Enters critical section.

If another thread has already entered the same critical section, the calling thread will be suspended until the critical section is fully released by another thread. Enterring a critical section more then one time on the same thread only increases recusion counter.

◆ Leave()

void Leave ( )

Releases the critical section.

In case of re-entry on the same thread the internal recusion counter is decreased without releasing the critical section.

The documentation for this class was generated from the following file:
  • XTPSynchro.h


Toolkit Pro: CXTPSimpleCriticalSection::CLock Class Reference

  • CXTPSimpleCriticalSection
  • CLock
Public Member Functions | List of all members
CXTPSimpleCriticalSection::CLock Class Reference

A helper class for locking a scope or providing exception safe locking. More...

Public Member Functions

CLock (CXTPSimpleCriticalSection &cs)
Locks a critical section passed.
~CLock ()
Unlocks the previously locked critical.

Detailed Description

A helper class for locking a scope or providing exception safe locking.

Constructor & Destructor Documentation

◆ CLock()

CLock ( CXTPSimpleCriticalSection & cs )
inlineexplicit

Locks a critical section passed.

Parameters
cs A reference of critical section to lock.
The documentation for this class was generated from the following file:
  • XTPSynchro.h


Toolkit Pro: CXTPSimpleEvent Class Reference

Public Member Functions | List of all members
CXTPSimpleEvent Class Reference

Implements no-named simple and lightweight synchronization event primitive. More...

Public Member Functions

CXTPSimpleEvent (BOOL bInitialState)
Constructs an event object.
void | Reset ()
Resets an event to non-signaled state.
void | Set ()
Sets an event to signaled state.
BOOL | IsSignaled () const
Determines if an event is in signaled state.
void | Wait ()
Waits infinitely for an event to enter signaled states.

Detailed Description

Implements no-named simple and lightweight synchronization event primitive.

Constructor & Destructor Documentation

◆ CXTPSimpleEvent()

CXTPSimpleEvent ( BOOL bInitialState )
explicit

Constructs an event object.

Parameters
bInitialState TRUE to construct an event in signaled state. FALSE to construct an event in non-signaled state.

Member Function Documentation

◆ IsSignaled()

BOOL IsSignaled ( ) const

Determines if an event is in signaled state.

Returns
TRUE if an event is in signaled state, FALSE otherwise.
The documentation for this class was generated from the following file:
  • XTPSynchro.h


Toolkit Pro: CXTPSingleton< T, Dependencies > Class Template Reference

Static Public Member Functions | List of all members
CXTPSingleton< T, Dependencies > Class Template Reference

Implements Singleton design pattern. More...

Inheritance diagram for CXTPSingleton< T, Dependencies >:
[legend]

Static Public Member Functions

static T &AFX_CDECL Instance ()
Obtains encapsulated singleton instance reference.

Detailed Description

template<class T, class Dependencies>
class CXTPSingleton< T, Dependencies >

Implements Singleton design pattern.

Can be used both as an adaptor or a base class for a class the is not derived from any other class. Respects thread safety for instance allocation.

Parameters
T | Type name of singleton instance.
Dependencies | Optional list of singleton types listed as CXTPSingletonDependencies template arguments on which the current signleton type depends. If not initialized any of the listed dependencies will be initialized in the order of appearance in the list before this singleton instance is created.

Member Function Documentation

◆ Instance()

template<class T , class Dependencies >
static T &AFX_CDECL Instance ( )
inlinestatic

Obtains encapsulated singleton instance reference.

The instance is allocated and created during the first call.

Returns
A reference to singleton instance.
The documentation for this class was generated from the following file:
  • XTPSingleton.h


Toolkit Pro: CXTPSingletonBase< Derived, Parent > Class Template Reference

Protected Member Functions | List of all members
CXTPSingletonBase< Derived, Parent > Class Template Reference

Implements Singleton design pattern for a derived class with possibility of providing a parent class. More...

Inheritance diagram for CXTPSingletonBase< Derived, Parent >:
[legend]

Protected Member Functions

CXTPSingletonBase ()
Handles object construction.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPSingleton< Derived >
static Derived &AFX_CDECL Instance ()
Obtains encapsulated singleton instance reference.

Detailed Description

template<class Derived, class Parent>
class CXTPSingletonBase< Derived, Parent >

Implements Singleton design pattern for a derived class with possibility of providing a parent class.

Parameters
Derived | Type name of singleton instance.
Parent | Type of a parent class, can be 'void' which means no parent class is used.
The documentation for this class was generated from the following file:
  • XTPSingleton.h


Toolkit Pro: CXTPSingletonDependencies< Singleton1, Singleton2, Singleton3, Singleton4, Singleton5, Singleton6, Singleton7, Singleton8, Singleton9, Singleton10 > Class Template Reference

CXTPSingletonDependencies< Singleton1, Singleton2, Singleton3, Singleton4, Singleton5, Singleton6, Singleton7, Singleton8, Singleton9, Singleton10 > Class Template Reference

Describes the list of up to 10 optional singleton dependencies. More...

Detailed Description

template<class Singleton1, class Singleton2, class Singleton3, class Singleton4, class Singleton5, class Singleton6, class Singleton7, class Singleton8, class Singleton9, class Singleton10>
class CXTPSingletonDependencies< Singleton1, Singleton2, Singleton3, Singleton4, Singleton5, Singleton6, Singleton7, Singleton8, Singleton9, Singleton10 >

Describes the list of up to 10 optional singleton dependencies.

If specified, the dependencies gets initialized prior to the singleton instance initialization in the order of listing.

Parameters
Singleton1 | Optional 1st dependency.
Singleton2 | Optional 2nd dependency.
Singleton3 | Optional 3rd dependency.
Singleton4 | Optional 4th dependency.
Singleton5 | Optional 5th dependency.
Singleton6 | Optional 6th dependency.
Singleton7 | Optional 7th dependency.
Singleton8 | Optional 8th dependency.
Singleton9 | Optional 9th dependency.
Singleton10 | Optional 10th dependency.
See also
CXTPSingleton
The documentation for this class was generated from the following file:
  • XTPSingleton.h


Toolkit Pro: CXTPSingletonPointer Class Reference

Public Types | Public Member Functions | List of all members
CXTPSingletonPointer Class Reference

Implements Singleton design pattern for a pointer of unspecified type that is to be allocated, created and destroyed by a client. More...

Inheritance diagram for CXTPSingletonPointer:
[legend]

Public Types

typedef BOOL(AFX_CDECL *) | Creator(void *)
Creator callback type.
typedef void(AFX_CDECL *) | Destroyer(void *)
Destroyer callback type.
typedef void(AFX_CDECL *) | Initializer()
Initializer callback type.

Public Member Functions

CXTPSingletonPointer (SIZE_T cbObjectSize, Creator pfnCreator, Destroyer pfnDestroyer, Initializer pfnInitializer=NULL)
Handles object construction.
virtual | ~CXTPSingletonPointer ()
Handles object destruction.
void * | GetInstance ()
Obtains encapsulated singleton instance pointer.
void | Destroy ()
Destroys a previously created and allocated instance and invalidate the instance pointer.
::CRITICAL_SECTION & | GetAccess () const
Obtains reference to singleton access critical secton.

Detailed Description

Implements Singleton design pattern for a pointer of unspecified type that is to be allocated, created and destroyed by a client.

Respects thread safety for instance allocation.

Constructor & Destructor Documentation

◆ CXTPSingletonPointer()

CXTPSingletonPointer | ( | SIZE_T | cbObjectSize,
 |  | Creator | pfnCreator,
 |  | Destroyer | pfnDestroyer,
 |  | Initializer | pfnInitializer = NULL )

Handles object construction.

Parameters
cbObjectSize | Singleton object size in bytes.
pfnCreator | Creater callback function pointer.
pfnDestroyer | Destroyer callback function pointer.
pfnInitializer | Initializer callback function pointer.

Member Function Documentation

◆ GetAccess()

::CRITICAL_SECTION & GetAccess ( ) const
inline

Obtains reference to singleton access critical secton.

Returns
A reference to singleton access critical secton.

◆ GetInstance()

void * GetInstance ( )

Obtains encapsulated singleton instance pointer.

The instance is allocated and created during the first call. The function guaranties returning a valid pointer value. If it cannot return it an exception will be issued.

Returns
A pointer to singleton instance.
The documentation for this class was generated from the following file:
  • XTPSingleton.h


Toolkit Pro: CXTPSizeIcon Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPSizeIcon Class Reference

The CXTPSizeIcon class is a CStatic derived helper class. More...

Public Member Functions

CXTPSizeIcon ()
Constructs a CXTPSizeIcon object.
virtual ~CXTPSizeIcon ()
Destroys a CXTPSizeIcon object, handles cleanup and deallocation.

Protected Attributes

HCURSOR m_hCursor
Handle to the cursor displayed for the size icon.

Detailed Description

The CXTPSizeIcon class is a CStatic derived helper class.

It is used by CXTPResize to display the sizing grip in the lower right corner of a sizing window.

The documentation for this class was generated from the following file:
  • XTPResize.h


Toolkit Pro: CXTPSizeT< T > Class Template Reference

Public Member Functions | Public Attributes | List of all members
CXTPSizeT< T > Class Template Reference

This class incapsulates size data. More...

Public Member Functions

CXTPSizeT ()
Constructs an empty CXTPSizeT object with all components equal to 0.
CXTPSizeT (T width, T height)
Constructs a CXTPSizeT object.
CXTPSizeT (const CXTPSizeT &other)
Constructs a CXTPSizeT object from another CXTPSizeT object.
CXTPSizeT | operator+ (const CXTPSizeT &other) const
Performs addition of two size objects.
CXTPSizeT | operator- (const CXTPSizeT &other) const
Performs subtraction of two size objects.
bool | operator== (const CXTPSizeT &other) const
Compares two sizes.
bool | operator!= (const CXTPSizeT &other) const
Compares two sizes.
bool | IsEmpty () const
Determines if the size object is empty.

Public Attributes

T | Width
The Width component.
T | Height
The Height component.

Detailed Description

template<class T>
class CXTPSizeT< T >

This class incapsulates size data.

Parameters
T type of a single size coordinate component. Must be an integral type.

Constructor & Destructor Documentation

◆ CXTPSizeT() [1/2]

template<class T >
CXTPSizeT | ( | T | width,
 |  | T | height )
 inline

Constructs a CXTPSizeT object.

Parameters
width | The Width component.
height | The Height component.

◆ CXTPSizeT() [2/2]

template<class T >
CXTPSizeT ( const CXTPSizeT< T > & other )
inline

Constructs a CXTPSizeT object from another CXTPSizeT object.

conversion is performed.

Parameters
other A reference to a source size object.

Member Function Documentation

◆ IsEmpty()

template<class T >
bool IsEmpty ( ) const
inline

Determines if the size object is empty.

Returns
true if the size object is empty, i.e. each component is equal to 0. false otherwise.

◆ operator!=()

template<class T >
bool operator!= ( const CXTPSizeT< T > & other ) const
inline

Compares two sizes.

Parameters
other size object reference to compare to.
Returns
true if sizes are not equal, otherwise the return value is false.

◆ operator+()

template<class T >
CXTPSizeT operator+ ( const CXTPSizeT< T > & other ) const
inline

Performs addition of two size objects.

Parameters
other A reference to a size object to add to the current size object.
Returns
A new size object width added size components.

◆ operator-()

template<class T >
CXTPSizeT operator- ( const CXTPSizeT< T > & other ) const
inline

Performs subtraction of two size objects.

Parameters
other A reference to a size object to subtract from the current size object.
Returns
A new size object width size components after subtraction.

◆ operator==()

template<class T >
bool operator== ( const CXTPSizeT< T > & other ) const
inline

Compares two sizes.

Parameters
other size object reference to compare to.
Returns
true if sizes are equal, otherwise the return value is false.
The documentation for this class was generated from the following file:
  • XTPSize.h


Toolkit Pro: CXTPSkinImage Class Reference

Public Member Functions | Public Attributes | Protected Attributes | List of all members
CXTPSkinImage Class Reference

The CXTPSkinImage class represents a simple bitmap holder and draw operations for Skin Framework. More...

Inheritance diagram for CXTPSkinImage:
[legend]

Public Member Functions

CXTPSkinImage ()
Constructs a CXTPSkinImage object.
virtual | ~CXTPSkinImage ()
Destroys a CXTPSkinImage object, handles cleanup and deallocation.
BOOL | LoadFile (LPCTSTR lpszFileName)
Loads a specified bitmap from a .dll using its name identifier.
BOOL | LoadFile (HMODULE hModule, LPCTSTR lpszBitmapFileName)
Loads a specified bitmap from a .dll using its name identifier.
void | SetBitmap (HBITMAP hBitmap, BOOL bAlpha=FALSE)
Assigns a bitmap handle to the CXTPSkinImage class.
void | DrawImage (CDC *pDC, const CRect &rcDest, const CRect &rcSrc, const CRect &rcSizingMargins, int nSizingType, BOOL bBorderOnly)
Draws the image in a specified location.
void | DrawImage (CDC *pDC, const CRect &rcDest, const CRect &rcSrc, const CRect &rcSizingMargins, COLORREF clrTransparent, int nSizingType, BOOL bBorderOnly)
Draws the image in a specified location.
DWORD | GetHeight () const
Gets the height of the bitmap.
DWORD | GetWidth () const
Gets the width of the bitmap.
CSize | GetExtent () const
Gets the extent of the bitmap.
BOOL | IsAlphaImage () const
Determines if the bitmap has alpha pixels.
CRect | GetSource (int nState=0, int nCount=1) const
Calculates the position of a specified image.
void | CreateSolidRectArray (int nBitmaps, BOOL bHorizontalImage, const CRect &rcSizingMargins)
Helper method that splits an image into solid rectangles for faster drawing.
- Public Member Functions inherited from CXTPSynchronized
CXTPRWCriticalSection & | GetAccessCriticalSection () const
Accesses a synchronized object's critical section.

Public Attributes

BOOL m_bMirrorImage
TRUE to invert image in RTL mode.

Protected Attributes

HBITMAP | m_hBitmap
Bitmap handle.
BOOL | m_bAlpha
TRUE if the bitmap has alpha pixels.
BOOL | m_bFiltered
TRUE if the image is filtered.
BOOL | m_bInvert
TRUE if the image is inverted for RTL mode.
BOOL | m_bOptimized
TRUE if the image is split into solid rectangles.
CSize | m_szBitmap
Bitmap size of the image.
CArray< SOLIDRECT, SOLIDRECT & > | m_arrSolidRects
Solid rectangles of the image.

Detailed Description

The CXTPSkinImage class represents a simple bitmap holder and draw operations for Skin Framework.

Member Function Documentation

◆ CreateSolidRectArray()

void CreateSolidRectArray | ( | int | nBitmaps,
 |  | BOOL | bHorizontalImage,
 |  | const CRect & | rcSizingMargins )

Helper method that splits an image into solid rectangles for faster drawing.

Parameters
nBitmaps | Image identifier.
bHorizontalImage | TRUE if the images are arranged horizontally.
rcSizingMargins | Reference to sizing margins.

◆ DrawImage() [1/2]

void DrawImage | ( | CDC * | pDC,
 |  | const CRect & | rcDest,
 |  | const CRect & | rcSrc,
 |  | const CRect & | rcSizingMargins,
 |  | COLORREF | clrTransparent,
 |  | int | nSizingType,
 |  | BOOL | bBorderOnly )

Draws the image in a specified location.

Parameters
pDC | Destination device context.
rcDest | Reference to the location of the destination rectangle.
rcSrc | Reference to the location of the source rectangle.
rcSizingMargins | Reference to sizing margins.
nSizingType | Stretch type.
bBorderOnly | TRUE to only draw borders.
clrTransparent | Transparent color.

◆ DrawImage() [2/2]

void DrawImage | ( | CDC * | pDC,
 |  | const CRect & | rcDest,
 |  | const CRect & | rcSrc,
 |  | const CRect & | rcSizingMargins,
 |  | int | nSizingType,
 |  | BOOL | bBorderOnly )

Draws the image in a specified location.

Parameters
pDC | Destination device context.
rcDest | Reference to the location of the destination rectangle.
rcSrc | Reference to the location of the source rectangle.
rcSizingMargins | Reference to sizing margins.
nSizingType | Stretch type.
bBorderOnly | TRUE to only draw borders.

◆ GetExtent()

CSize GetExtent ( ) const

Gets the extent of the bitmap.

Returns
The extent of the bitmap.

◆ GetHeight()

DWORD GetHeight ( ) const

Gets the height of the bitmap.

Returns
The height of the bitmap.

◆ GetSource()

CRect GetSource | ( | int | nState = 0,
 |  | int | nCount = 1 ) const

Calculates the position of a specified image.

Parameters
nState | Index of the image.
nCount | Total image count.
Returns
The position of the specified image.

◆ GetWidth()

DWORD GetWidth ( ) const

Gets the width of the bitmap.

Returns
The width of the bitmap.

◆ IsAlphaImage()

BOOL IsAlphaImage ( ) const

Determines if the bitmap has alpha pixels.

Returns
TRUE if the bitmap has alpha pixels, otherwise FALSE.

◆ LoadFile() [1/2]

BOOL LoadFile | ( | HMODULE | hModule,
 |  | LPCTSTR | lpszBitmapFileName )

Loads a specified bitmap from a .dll using its name identifier.

Parameters
hModule | Module handle.
lpszBitmapFileName | Bitmap file name.
Returns
TRUE if successful, otherwise FALSE.

◆ LoadFile() [2/2]

BOOL LoadFile ( LPCTSTR lpszFileName )

Loads a specified bitmap from a .dll using its name identifier.

Parameters
lpszFileName File name on disk to load.
Returns
TRUE if successful, otherwise FALSE.

◆ SetBitmap()

void SetBitmap | ( | HBITMAP | hBitmap,
 |  | BOOL | bAlpha = FALSE )

Assigns a bitmap handle to the CXTPSkinImage class.

Parameters
hBitmap | Bitmap handle.
bAlpha | TRUE if the bitmap contains alpha pixels.
The documentation for this class was generated from the following file:
  • XTPSkinImage.h


Toolkit Pro: CXTPSkinImages Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPSkinImages Class Reference

CXTPSkinImages represents a cached collection of CXTPSkinImage classes. More...

Inheritance diagram for CXTPSkinImages:
[legend]

Public Member Functions

CXTPSkinImages ()
Constructs a CXTPSkinImages object.
~CXTPSkinImages ()
Destroys a CXTPSkinImages object, handles cleanup and deallocation.
void | RemoveAll ()
Removes all images from the collection.
CXTPSkinImage * | LoadFile (CXTPSkinManagerResourceFile *pResourceFile, LPCTSTR lpszImageFile)
Loads a specified image from a resource file.
CSize | GetExtent (CXTPSkinManagerResourceFile *pResourceFile, LPCTSTR lpszImageFile)
Gets the extent of a specified image located within a resource file.
- Public Member Functions inherited from CXTPSynchronized
CXTPRWCriticalSection & | GetAccessCriticalSection () const
Accesses a synchronized object's critical section.

Protected Attributes

CMapStringToPtr m_mapImages
Collection of images.

Detailed Description

CXTPSkinImages represents a cached collection of CXTPSkinImage classes.

Member Function Documentation

◆ GetExtent()

CSize GetExtent | ( | CXTPSkinManagerResourceFile * | pResourceFile,
 |  | LPCTSTR | lpszImageFile )

Gets the extent of a specified image located within a resource file.

Parameters
pResourceFile | Pointer to the resource file.
lpszImageFile | Path to the image.
Returns
The extent of the image.

◆ LoadFile()

CXTPSkinImage * LoadFile | ( | CXTPSkinManagerResourceFile * | pResourceFile,
 |  | LPCTSTR | lpszImageFile )

Loads a specified image from a resource file.

Parameters
pResourceFile | Pointer to the resource file.
lpszImageFile | Path to the image.
Returns
A pointer to the newly loaded CXTPSkinImage object if successful, otherwise NULL.
The documentation for this class was generated from the following file:
  • XTPSkinImage.h


Toolkit Pro: CXTPSkinManager Class Reference

Public Member Functions | Static Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPSkinManager Class Reference

CXTPSkinManager is a standalone class that represents a global object that manages skins. More...

Inheritance diagram for CXTPSkinManager:
[legend]

Public Member Functions

virtual | ~CXTPSkinManager ()
Destroys a CXTPSkinManager object, handles cleanup and deallocation.
BOOL | LoadSkin (LPCTSTR lpszResourcePath, LPCTSTR lpszIniFileName=NULL)
Loads a skin from a cjstyles or msstyles file.
CXTPSkinManagerSchema * | CreateSchema (LPCTSTR lpszResourcePath, LPCTSTR lpszIniFileName=NULL)
Creates a new schema instance from a provided resource.
DWORD | GetApplyOptions () const
Determines which parts of the application skin are applied.
BOOL | HasApplyOptions (DWORD dwOptions) const
Determines which parts of the application skin are applied.
void | SetApplyOptions (DWORD dwOptions)
Specifies which parts of the application skin should be applied.
void | ModifyApplyOptions (DWORD dwAdd, DWORD dwRemove)
Modifies skinning options defined by the XTPSkinApplyOptions enumeration.
void | ApplyWindow (HWND hWnd)
Call this method to manually set the window whose appearance must be skinned.
void | ApplyWindow (HWND hWnd, BOOL bApplyChildren)
Call this method to manually set the window whose appearance must be skinned.
void | SetWindowTheme (HWND hWnd, CXTPSkinManagerSchema *pSchema)
Sets the window theme.
void | SetAutoApplyNewWindows (BOOL bAutoApply)
Specifies if new windows should be automatically skinned.
BOOL | GetAutoApplyNewWindows () const
Determines if new windows are automatically skinned.
void | ExcludeModule (LPCTSTR lpszModule)
Excludes a specified .dll file from API hooking.
virtual CXTPSkinManagerClass * | GetSkinClass (const CXTPSkinObject *pObject, CString strClassList)
Gets a specified skin class by its name.
CXTPSkinObject * | Lookup (HWND hWnd)
Gets the skin object used to draw a specified window.
CXTPSkinObject * | Lookup (HDC hDC)
Gets the skin object used to draw a specified window.
CXTPSkinManagerMetrics * | GetMetrics () const
Gets the skin metrics.
BOOL | IsEnabled () const
Determines if skinning is enabled/disabled.
void | Suspend ()
Suspends skinning for all new created windows and threads.
void | Resume ()
Resumes skinning for all new created windows and threads.
BOOL | IsSuspended () const
Determines if skinning is suspended for all new windows and threads.
CXTPSkinManagerSchema * | GetSchema () const
Gets the skin schema.
CXTPSkinManagerResourceFile * | GetResourceFile () const
Gets the resource file.
void | SetResourceFile (CXTPSkinManagerResourceFile *pResourceFile)
Sets the resource file.
HRESULT | EnableThemeDialogTexture (HWND hWnd, DWORD dwFlags)
Enables/disables dialog background theme.
COLORREF | GetThemeSysColor (int iColorId)
Gets the value of a specified system color.
HRESULT | GetThemeSysFont (int iFontId, LOGFONT *plf)
Gets the value of a specified system font.
int | GetThemeSysSize (int iSizeId)
Gets the size value of a specified system metric.
BOOL | GetThemeSysBool (int iBoolId)
Gets the BOOL value of a specified system metric.
void | GetCurrentThemeName (CString &strThemeFileName, CString &strColorBuff)
Gets the name of the current theme.
CXTPSkinManagerClass * | FromHandle (HTHEME hTheme)
Gets the CXTPSkinManagerClass class from a specified HTHEME handle.
BOOL | IsComCtlV6 () const
Determines if ComCtl32.dll is of version 6.0 or above.
BOOL | IsWin9x () const
Determines if the operating system is of the Windows 9x family and if it is Windows 95 or a later version.
void | RedrawAllControls ()
Redraws all controls with the current skin.
void | EnableCurrentThread ()
Enables skin framework for the current thread.
void | SetAutoApplyNewThreads (BOOL bAutoApply)
Specifies if new threads should be automatically skinned.
BOOL | GetAutoApplyNewThreads () const
Determines if new threads are automatically skinned.
CXTPSkinObjectClassMap * | GetClassMap () const
Gets the class map object whose purpose is to map window classes to skin framework classes.
void | Remove (HWND hWnd)
Removes the hook from a specified window.
void | RemoveAll (BOOL bDetach=TRUE)
Removes all hooks.
BOOL | IsColorFilterExists () const
Determines if any color filter is installed.
void | ApplyColorFilter (COLORREF &clr)
This method is called internally to transform a specified color using installed color filters.
void | AddColorFilter (CXTPSkinManagerColorFilter *pFilter)
Adds a color filter.
void | RemoveColorFilters ()
Destroys all added color filters.
virtual void | OnSkinChanged (BOOL bPrevState, BOOL bNewState)
This method is called when the skin is changed.
BOOL | IsPersistentModule (HMODULE hModule)
Determines if a specified module is persistent.
void | SetWindowFilter (IXTPSkinManagerWindowFilter *pFilter)
Sets the window filter implementation.
- Public Member Functions inherited from CXTPSynchronized
CXTPRWCriticalSection & | GetAccessCriticalSection () const
Accesses a synchronized object's critical section.

Static Public Member Functions

static CXTPSkinManager *AFX_CDECL SetSkinManager (CXTPSkinManager *pSkinManager, BOOL bDelete=TRUE)
Sets the skin manager.

Protected Member Functions

CXTPSkinManager ()
Constructs a CXTPSkinManager object.
BOOL | ReadSkinData (LPCTSTR lpszResourcePath, LPCTSTR lpszIniFileName)
Parses a visual styles .ini file.
void | FreeSkinData ()
Frees skin resources.
virtual CXTPSkinObject * | SetHook (HWND hWnd, LPCTSTR lpszClassName, LPCREATESTRUCT lpcs, BOOL bAuto)
Creates a hook class for a specified window.
virtual void | OnBeforeApplicationShutdown (CXTPApplication *pApplication)
This method is called by the framework before an application shuts down.

Protected Attributes

DWORD | m_dwComCtrl
Version of ComCtl.dll.
BOOL | m_bWin9x
TRUE if OS is Win9x.
BOOL | m_bEnabled
TRIE if skinning is enabled.
BOOL | m_bAutoApplyWindows
TRUE to auto-skin all new windows.
BOOL | m_bAutoApplyThreads
TRUE to auto-skin all new threads.
CXTPSkinManagerSchema * | m_pSchema
Current schema.
CXTPSkinManagerResourceFile * | m_pResourceFile
Resource file.
DWORD | m_dwApplyOptions
Apply options.
HWINEVENTHOOK | m_hWinEventHook
HWINEVENTHOOK value that identifies event hook instance.
CMap< HWND, HWND, CXTPSkinObject *, CXTPSkinObject * > | m_mapObjects
Collection of CXTPSkinObject classes.
CRITICAL_SECTION | m_csObjects
Helper critical section object.
LPFNSETWINEVENTHOOK | m_pSetWinEventHook
Pointer to SetWinEventHook API.
LPFNUNHOOKWINEVENT | m_pUnhookWinEvent
Pointer to UnhookWinEvent API.
LPSETWINDOWTHEME | m_pSetWindowTheme
Pointer to SetWindowTheme API.
CArray< CXTPSkinManagerColorFilter *, CXTPSkinManagerColorFilter * > | m_arrFilters
Array of filters to apply.
CXTPSkinObjectClassMap * | m_pClassMap
Class map helper.
IXTPSkinManagerWindowFilter * | m_pWindowFilter
Custom provided window filter implementation.
CArray< PERSISTENT_IMPORT_INFO, PERSISTENT_IMPORT_INFO & > | m_arPersistentModuleCache
Persistent module info cache.

Detailed Description

CXTPSkinManager is a standalone class that represents a global object that manages skins.

Member Function Documentation

◆ AddColorFilter()

void AddColorFilter ( CXTPSkinManagerColorFilter * pFilter )

Adds a color filter.

Parameters
pFilter Pointer to the color filter to add.

◆ ApplyColorFilter()

void ApplyColorFilter ( COLORREF & clr )

This method is called internally to transform a specified color using installed color filters.

Parameters
clr Reference to the color to transform.

◆ ApplyWindow() [1/2]

void ApplyWindow ( HWND hWnd )

Call this method to manually set the window whose appearance must be skinned.

Parameters
hWnd Handle of the window whose appearance must be skinned.

◆ ApplyWindow() [2/2]

void ApplyWindow | ( | HWND | hWnd,
 |  | BOOL | bApplyChildren )

Call this method to manually set the window whose appearance must be skinned.

Parameters
hWnd | Handle of the window whose appearance must be skinned.
bApplyChildren | TRUE to skin all child windows of the specified window recursively, FALSE to only skin the specified window.

◆ CreateSchema()

CXTPSkinManagerSchema * CreateSchema | ( | LPCTSTR | lpszResourcePath,
 |  | LPCTSTR | lpszIniFileName = NULL )

Creates a new schema instance from a provided resource.

Parameters
lpszResourcePath | Path to the styles file to load the schema from.
lpszIniFileName | Optional embedded .ini file name to use from the styles file.
Returns
A pointer to the newly created schema, otherwise NULL in the case of an error.

◆ EnableCurrentThread()

void EnableCurrentThread ( )

Enables skin framework for the current thread.

This method can be called for each thread in a multi-threaded application to enable skin framework for all threads.

◆ EnableThemeDialogTexture()

HRESULT EnableThemeDialogTexture | ( | HWND | hWnd,
 |  | DWORD | dwFlags )

Enables/disables dialog background theme.

Parameters
hWnd | Window handle of the target dialog.
dwFlags | One of the following: ETDT_ENABLE: Enables theme-defined dialog background texturing. ETDT_DISABLE: Disables background texturing. ETDT_ENABLETAB: Enables theme-defined background texturing using the tab texture.

This method can be used to tailor dialog compatibility with child windows and controls that may or may not coordinate the rendering of their client area backgrounds with that of their parent dialog in a manner that supports seamless background texturing.

Returns
S_OK if successful.

◆ ExcludeModule()

void ExcludeModule ( LPCTSTR lpszModule )

Excludes a specified .dll file from API hooking.

Parameters
lpszModule Name of the .dll file to exclude.

◆ FreeSkinData()

void FreeSkinData ( )
protected

Frees skin resources.

See also
ReadSkinData

◆ FromHandle()

CXTPSkinManagerClass * FromHandle ( HTHEME hTheme )

Gets the CXTPSkinManagerClass class from a specified HTHEME handle.

Parameters
hTheme HTHEME handle.
Returns
A pointer to the CXTPSkinManagerClass class.

◆ GetApplyOptions()

AFX_INLINE DWORD GetApplyOptions ( ) const

Determines which parts of the application skin are applied.

Returns
One or more XTPSkinApplyOptions values.
See also
XTPSkinApplyOptions, SetApplyOptions, ModifyApplyOptions

◆ GetAutoApplyNewThreads()

AFX_INLINE BOOL GetAutoApplyNewThreads ( ) const

Determines if new threads are automatically skinned.

Returns
TRUE if new threads are automatically skinned, otherwise FALSE.

◆ GetAutoApplyNewWindows()

AFX_INLINE BOOL GetAutoApplyNewWindows ( ) const

Determines if new windows are automatically skinned.

The current skin is used if new windows are automatically skinned.

Returns
TRUE if new windows are automatically skinned, otherwise FALSE.

◆ GetClassMap()

AFX_INLINE CXTPSkinObjectClassMap * GetClassMap ( ) const

Gets the class map object whose purpose is to map window classes to skin framework classes.

Returns
A pointer to the class map object.

◆ GetCurrentThemeName()

void GetCurrentThemeName | ( | CString & | strThemeFileName,
 |  | CString & | strColorBuff )

Gets the name of the current theme.

Parameters
strThemeFileName | Reference to a string to receive the theme path and file name.
strColorBuff | Reference to a string to receive the canonical color scheme name.

◆ GetMetrics()

CXTPSkinManagerMetrics * GetMetrics ( ) const

Gets the skin metrics.

Returns
A pointer to the CXTPSkinManagerMetrics object containing the skin metrics.

◆ GetResourceFile()

AFX_INLINE CXTPSkinManagerResourceFile * GetResourceFile ( ) const

Gets the resource file.

Returns
A pointer to the CXTPSkinManagerResouceFile used to manage skin resources.
See also
SetResourceFile

◆ GetSchema()

AFX_INLINE CXTPSkinManagerSchema * GetSchema ( ) const

Gets the skin schema.

Returns
A pointer to the CXTPSkinManagerSchema object used to draw window parts.

◆ GetSkinClass()

virtual CXTPSkinManagerClass * GetSkinClass | ( | const CXTPSkinObject * | pObject,
 |  | CString | strClassList )
 virtual

Gets a specified skin class by its name.

Parameters
strClassList | Name of the skin class.
pObject | Reference to the skin object to apply the skin.
Returns
A pointer to the specified CXTPSkinManagerClass object.

◆ GetThemeSysBool()

BOOL GetThemeSysBool ( int iBoolId )

Gets the BOOL value of a specified system metric.

Parameters
iBoolId TMT_XXX BOOL number (first BOOL is TMT_FLATMENUS).
Returns
The BOOL value of the specified system metric.

◆ GetThemeSysColor()

COLORREF GetThemeSysColor ( int iColorId )

Gets the value of a specified system color.

Parameters
iColorId System color index (defined in winuser.h).
Returns
The value of the specified system color.

◆ GetThemeSysFont()

HRESULT GetThemeSysFont | ( | int | iFontId,
 |  | LOGFONT * | plf )

Gets the value of a specified system font.

Parameters
iFontId | TMT_XXX font number (first font is TMT_CAPTIONFONT).
plf | Pointer to a LOGFONT to receive the value of the specified system font (scaled for the current logical screen dpi).
Returns
S_OK if successful.

◆ GetThemeSysSize()

int GetThemeSysSize ( int iSizeId )

Gets the size value of a specified system metric.

Parameters
iSizeId TMT_XXX size value.
Returns
The size value of the specified system metric (scaled for the current logical screen dpi).

◆ HasApplyOptions()

AFX_INLINE BOOL HasApplyOptions ( DWORD dwOptions ) const

Determines which parts of the application skin are applied.

Parameters
dwOptions A set of XTPSkinApplyOptions bits to check
Returns
TRUE if all options specified by dwOptions are set.
See also
XTPSkinApplyOptions, SetApplyOptions

◆ IsColorFilterExists()

BOOL IsColorFilterExists ( ) const

Determines if any color filter is installed.

Returns
TRUE if any color filter is installed, otherwise FALSE.

◆ IsComCtlV6()

AFX_INLINE BOOL IsComCtlV6 ( ) const

Determines if ComCtl32.dll is of version 6.0 or above.

Returns
TRUE if ComCtl32.dll is of version 6.0 or above.
See also
IsWin9x

◆ IsEnabled()

AFX_INLINE BOOL IsEnabled ( ) const

Determines if skinning is enabled/disabled.

Returns
TRUE if skinning is enabled, FALSE if skinning is disabled.

◆ IsPersistentModule()

BOOL IsPersistentModule ( HMODULE hModule )

Determines if a specified module is persistent.

Parameters
hModule Handle of the module to check.

A module is persistent if it will remain loaded into the process address space for the entire lifetime of the skin manager and cannot be unloaded. The current and/or executable modules are always considered persistent.

Returns
TRUE if the specified module is persistent, otherwise FALSE.

◆ IsSuspended()

AFX_INLINE BOOL IsSuspended ( ) const

Determines if skinning is suspended for all new windows and threads.

Returns
TRUE if skinning is suspended, FALSE otherwise.

◆ IsWin9x()

AFX_INLINE BOOL IsWin9x ( ) const

Determines if the operating system is of the Windows 9x family and if it is Windows 95 or a later version.

Returns
TRUE if the operating system is of the Windows 9x family and if it is Windows 95 or a later version, otherwise FALSE.
See also
IsComCtlV6

◆ LoadSkin()

BOOL LoadSkin | ( | LPCTSTR | lpszResourcePath,
 |  | LPCTSTR | lpszIniFileName = NULL )

Loads a skin from a cjstyles or msstyles file.

Parameters
lpszResourcePath | Path to the skin file.
lpszIniFileName | .ini file of the skin to load.
Returns
TRUE if successful, otherwise FALSE.

◆ Lookup() [1/2]

CXTPSkinObject * Lookup ( HDC hDC )

Gets the skin object used to draw a specified window.

Parameters
hDC Device context of the skinned window.
Returns
A pointer to the CXTPSkinObject used to draw the window.

◆ Lookup() [2/2]

CXTPSkinObject * Lookup ( HWND hWnd )

Gets the skin object used to draw a specified window.

Parameters
hWnd Handle of the skinned window.
Returns
A pointer to the CXTPSkinObject used to draw the window.

◆ ModifyApplyOptions()

void ModifyApplyOptions | ( | DWORD | dwAdd,
 |  | DWORD | dwRemove )

Modifies skinning options defined by the XTPSkinApplyOptions enumeration.

Parameters
dwAdd | Skinning options flags to be added to the current flags.
dwRemove | Skinning options flags to be removed from the current flags.
See also
XTPSkinApplyOptions, GetApplyOptions, SetApplyOptions, HasApplyOptions

◆ OnBeforeApplicationShutdown()

virtual void OnBeforeApplicationShutdown ( CXTPApplication * pApplication )
protectedvirtual

This method is called by the framework before an application shuts down.

Parameters
pApplication Pointer to the application that will be shut down.

Reimplemented from IXTPApplicationEvents.

◆ OnSkinChanged()

virtual void OnSkinChanged | ( | BOOL | bPrevState,
 |  | BOOL | bNewState )
 virtual

This method is called when the skin is changed.

Parameters
bPrevState | TRUE if the previous skin was installed.
bNewState | TRUE if the current skin is installed.

◆ ReadSkinData()

BOOL ReadSkinData | ( | LPCTSTR | lpszResourcePath,
 |  | LPCTSTR | lpszIniFileName )
 protected

Parses a visual styles .ini file.

Parameters
lpszResourcePath | Path to the resource file.
lpszIniFileName | .ini file name.
Returns
TRUE if successful, otherwise FALSE.
See also
FreeSkinData

◆ Remove()

void Remove ( HWND hWnd )

Removes the hook from a specified window.

Parameters
hWnd Handle of the window.
See also
RemoveAll

◆ RemoveAll()

void RemoveAll ( BOOL bDetach = TRUE )

Removes all hooks.

Parameters
bDetach TRUE to detach hooks before they are removed.
See also
Remove

◆ SetApplyOptions()

void SetApplyOptions ( DWORD dwOptions )

Specifies which parts of the application skin should be applied.

Parameters
dwOptions A set of XTPSkinApplyOptions bits to set
See also
XTPSkinApplyOptions, GetApplyOptions

◆ SetAutoApplyNewThreads()

AFX_INLINE void SetAutoApplyNewThreads ( BOOL bAutoApply )

Specifies if new threads should be automatically skinned.

Parameters
bAutoApply TRUE to automatically skin new threads, otherwise FALSE.

◆ SetAutoApplyNewWindows()

AFX_INLINE void SetAutoApplyNewWindows ( BOOL bAutoApply )

Specifies if new windows should be automatically skinned.

Parameters
bAutoApply TRUE to automatically skin new windows, FALSE otherwise.

The current skin is used if new windows are automatically skinned.

◆ SetHook()

virtual CXTPSkinObject * SetHook | ( | HWND | hWnd,
 |  | LPCTSTR | lpszClassName,
 |  | LPCREATESTRUCT | lpcs,
 |  | BOOL | bAuto )
 protectedvirtual

Creates a hook class for a specified window.

Parameters
hWnd | Handle to the window to hook.
lpszClassName | Class name of the specified window.
lpcs | Pointer to a CREATESTRUCT structure containing information about the CWnd object being created.
bAuto | TRUE if the window was automatically skinned when it was created, FALSE if the window was manually skinned.
Returns
A pointer to the CXTPSkinObject hooked to the specified window.
See also
CXTPSkinObject

◆ SetResourceFile()

void SetResourceFile ( CXTPSkinManagerResourceFile * pResourceFile )

Sets the resource file.

Parameters
pResourceFile Pointer to a CXTPSkinManagerResouceFile object.
See also
GetResourceFile

Example:

XTPSkinManager()->SetResourceFile(new CMySkinManagerResourceFile);

◆ SetSkinManager()

static CXTPSkinManager *AFX_CDECL SetSkinManager | ( | CXTPSkinManager * | pSkinManager,
 |  | BOOL | bDelete = TRUE )
 static

Sets the skin manager.

Parameters
pSkinManager | New skin manager to be set.
bDelete | TRUE to delete the previous skin manager.
Returns
If the bDelete parameter is set to TRUE, then a NULL value will be returned. If the bDelete parameter is set to FALSE, then a pointer to the previous skin manager will be returned.

Example:

CXTPSkinManager::SetSkinManager(new CMySkinManager());

◆ SetWindowFilter()

AFX_INLINE void SetWindowFilter ( IXTPSkinManagerWindowFilter * pFilter )

Sets the window filter implementation.

Parameters
pFilter Pointer to the window filter implementation, or NULL to disable any previously set window filter implementation.
See also
IXTPSkinManagerWindowFilter

◆ SetWindowTheme()

void SetWindowTheme | ( | HWND | hWnd,
 |  | CXTPSkinManagerSchema * | pSchema )

Sets the window theme.

Parameters
hWnd | Valid window handle for which a new theme is to be set.
pSchema | Valid pointer to a schema describing the theme to be set.
See also
CreateSchema
The documentation for this class was generated from the following file:
  • XTPSkinManager.h


Toolkit Pro: CXTPSkinManagerClass Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPSkinManagerClass Class Reference

CXTPSkinManagerClass is a standalone class that represents a single visual class of the skin manager. More...

Inheritance diagram for CXTPSkinManagerClass:
[legend]

Public Member Functions

CXTPSkinManagerClass (CXTPSkinManagerSchema *pSchema, CString pszClassList, int nClassCode)
Constructs a CXTPSkinManagerClass object.
virtual | ~CXTPSkinManagerClass ()
Destroys a CXTPSkinManagerClass object, handles cleanup and deallocation.
CString | GetThemeString (int iPartId, int iStateId, int iPropId, LPCTSTR lpszDefault=NULL)
Gets the value of a specified string property.
CRect | GetThemeRect (int iPartId, int iStateId, int iPropId, CRect rcDefault=CRect(0, 0, 0, 0))
Gets the value of a specified RECT property.
int | GetThemeInt (int iPartId, int iStateId, int iPropId, int nDefault=0)
Gets the value of a specified int property.
CSize | GetThemeSize (int iPartId, int iStateId, int iPropId, CSize szDefault=CSize(0))
Gets the value of a specified size property.
BOOL | GetThemeBool (int iPartId, int iStateId, int iPropId, BOOL bDefault=FALSE)
Gets the value of a specified BOOL property.
COLORREF | GetThemeColor (int iPartId, int iStateId, int iPropId, COLORREF clrDefault=(COLORREF) -1)
Gets the value of a specified color property.
int | GetThemeEnumValue (int iPartId, int iStateId, int iPropId, int nDefault=0)
Gets the value of a specified enum property.
BOOL | GetThemePartSize (int iPartId, int iStateId, RECT *pRect, int eSize, SIZE *pSize)
Gets the size of a specified theme part.
BOOL | DrawThemeBackground (CDC *pDC, int iPartId, int iStateId, const RECT *pRect)
Draws the background image defined by the visual style for a specified control part.
BOOL | DrawThemeText (CDC *pDC, int iPartId, int iStateId, const CString &strText, DWORD dwFormat, const RECT *pRect)
Draws text using the color and font defined by the visual style.
CXTPSkinImages * | GetImages () const
Gets the image collection of the class.
int | GetClassCode () const
Gets the hash value of the class name.
CString | GetClassName () const
Gets the class name.
CXTPSkinManagerSchemaProperty * | GetProperty (XTPSkinManagerProperty propType, int iPartId, int iStateId, int iPropId)
Gets the property value of a specified part and state.
- Public Member Functions inherited from CXTPSynchronized
CXTPRWCriticalSection & | GetAccessCriticalSection () const
Accesses a synchronized object's critical section.

Protected Attributes

CXTPSkinManagerSchema * | m_pSchema
Parent CXTPSkinManager object.
CString | m_strClass
Class name.
UINT | m_nClassCode
Hashed value of the class name.
CXTPSkinImages * | m_pImages
Image collection.
CMap< UINT, UINT, CXTPSkinManagerSchemaProperty *, CXTPSkinManagerSchemaProperty * > | m_mapCachedProperties
Cached collection of class properties.

Detailed Description

CXTPSkinManagerClass is a standalone class that represents a single visual class of the skin manager.

Constructor & Destructor Documentation

◆ CXTPSkinManagerClass()

CXTPSkinManagerClass | ( | CXTPSkinManagerSchema * | pSchema,
 |  | CString | pszClassList,
 |  | int | nClassCode )

Constructs a CXTPSkinManagerClass object.

Parameters
pSchema | Pointer to the parent skin manager class.
pszClassList | Class name.
nClassCode | Hash value of the class name.

Member Function Documentation

◆ DrawThemeBackground()

BOOL DrawThemeBackground | ( | CDC * | pDC,
 |  | int | iPartId,
 |  | int | iStateId,
 |  | const RECT * | pRect )

Draws the background image defined by the visual style for a specified control part.

Parameters
pDC | Pointer to a valid device context.
iPartId | Specifies the part to draw.
iStateId | Specifies the state of the part to draw.
pRect | Pointer to a RECT structure that contains the rectangle, in logical coordinates, in which the background image is to be drawn.
Returns
TRUE if successful, otherwise FALSE.

◆ DrawThemeText()

BOOL DrawThemeText | ( | CDC * | pDC,
 |  | int | iPartId,
 |  | int | iStateId,
 |  | const CString & | strText,
 |  | DWORD | dwFormat,
 |  | const RECT * | pRect )

Draws text using the color and font defined by the visual style.

Parameters
pDC | Pointer to a valid device context.
iPartId | Specifies the part that contains the text.
iStateId | Specifies the state of the part to draw.
strText | Reference to a string that contains the text to draw.
dwFormat | One or more values that specify the string's formatting.
pRect | Pointer to a RECT structure that contains the rectangle, in logical coordinates, in which the text is to be drawn.
Returns
TRUE if successful, otherwise FALSE.

◆ GetClassCode()

AFX_INLINE int GetClassCode ( ) const

Gets the hash value of the class name.

Returns
The hash value of the class name.

◆ GetClassName()

AFX_INLINE CString GetClassName ( ) const

Gets the class name.

Returns
The class name.

◆ GetImages()

AFX_INLINE CXTPSkinImages * GetImages ( ) const

Gets the image collection of the class.

Returns
A pointer to the image collection of the class.

◆ GetProperty()

CXTPSkinManagerSchemaProperty * GetProperty | ( | XTPSkinManagerProperty | propType,
 |  | int | iPartId,
 |  | int | iStateId,
 |  | int | iPropId )

Gets the property value of a specified part and state.

Parameters
propType | Property type.
iPartId | Part number.
iStateId | State number of the part.
iPropId | Property number to get the value of.
Returns
A pointer to the CXTPSkinManagerSchemaPropertyClass containing the value of the property.
See also
XTPSkinManagerProperty, CXTPSkinManagerSchemaProperty

◆ GetThemeBool()

BOOL GetThemeBool | ( | int | iPartId,
 |  | int | iStateId,
 |  | int | iPropId,
 |  | BOOL | bDefault = FALSE )

Gets the value of a specified BOOL property.

Parameters
iPartId | Part number.
iStateId | State number of the part.
iPropId | Property number to get the value of.
bDefault | Default value.
Returns
The value of the specified BOOL property.

◆ GetThemeColor()

COLORREF GetThemeColor | ( | int | iPartId,
 |  | int | iStateId,
 |  | int | iPropId,
 |  | COLORREF | clrDefault = (COLORREF) -1 )

Gets the value of a specified color property.

Parameters
iPartId | Part number.
iStateId | State number of the part.
iPropId | Property number to get the value of.
clrDefault | Default value.
Returns
The value of the specified color property.

◆ GetThemeEnumValue()

int GetThemeEnumValue | ( | int | iPartId,
 |  | int | iStateId,
 |  | int | iPropId,
 |  | int | nDefault = 0 )

Gets the value of a specified enum property.

Parameters
iPartId | Part number.
iStateId | State number of the part.
iPropId | Property number to get the value of.
nDefault | Default value.
Returns
The value of the specified enum property.

◆ GetThemeInt()

int GetThemeInt | ( | int | iPartId,
 |  | int | iStateId,
 |  | int | iPropId,
 |  | int | nDefault = 0 )

Gets the value of a specified int property.

Parameters
iPartId | Part number.
iStateId | State number of the part.
iPropId | Property number to get the value of.
nDefault | Default value.
Returns
The value of the specified int property.

◆ GetThemePartSize()

BOOL GetThemePartSize | ( | int | iPartId,
 |  | int | iStateId,
 |  | RECT * | pRect,
 |  | int | eSize,
 |  | SIZE * | pSize )

Gets the size of a specified theme part.

Parameters
iPartId | Part number.
iStateId | State number of the part.
pRect | Pointer to a RECT for the part drawing destination.
eSize | Type of size to be retrieved.
pSize | Pointer to a SIZE that receives the size of the part.
Returns
TRUE if successful, otherwise FALSE.

◆ GetThemeRect()

CRect GetThemeRect | ( | int | iPartId,
 |  | int | iStateId,
 |  | int | iPropId,
 |  | CRect | rcDefault = CRect(0, 0, 0, 0) )

Gets the value of a specified RECT property.

Parameters
iPartId | Part number.
iStateId | State number of the part.
iPropId | Property number to get the value of.
rcDefault | Default value.
Returns
The value of the specified RECT property.

◆ GetThemeSize()

CSize GetThemeSize | ( | int | iPartId,
 |  | int | iStateId,
 |  | int | iPropId,
 |  | CSize | szDefault = CSize(0) )

Gets the value of a specified size property.

Parameters
iPartId | Part number.
iStateId | State number of the part.
iPropId | Property number to get the value of.
szDefault | Default value.
Returns
The value of the specified size property.

◆ GetThemeString()

CString GetThemeString | ( | int | iPartId,
 |  | int | iStateId,
 |  | int | iPropId,
 |  | LPCTSTR | lpszDefault = NULL )

Gets the value of a specified string property.

Parameters
iPartId | Part number.
iStateId | State number of the part.
iPropId | Property number to get the value of.
lpszDefault | Default value.
Returns
The value of the specified string property.
The documentation for this class was generated from the following file:
  • XTPSkinManager.h


Toolkit Pro: CXTPSkinManagerColorFilter Class Reference

Public Member Functions | List of all members
CXTPSkinManagerColorFilter Class Referenceabstract

CXTPSkinManagerColorFilter represents the parent class for all color filters of skin manager. More...

Public Member Functions

virtual | ~CXTPSkinManagerColorFilter ()
Handles color filter object destruction.
virtual void | ApplyColorFilter (COLORREF &clr)=0
Modifies the color of the skin manager before drawing the skin.

Detailed Description

CXTPSkinManagerColorFilter represents the parent class for all color filters of skin manager.

Skin manager calls the ApplyColorFilter method for all filters of each color and image used to draw.

Member Function Documentation

◆ ApplyColorFilter()

virtual void ApplyColorFilter ( COLORREF & clr )
pure virtual

Modifies the color of the skin manager before drawing the skin.

Parameters
clr Reference to the color to filter.
The documentation for this class was generated from the following file:
  • XTPSkinManagerColorFilter.h


Toolkit Pro: CXTPSkinManagerMetrics Class Reference

Public Member Functions | Public Attributes | List of all members
CXTPSkinManagerMetrics Class Reference

CXTPSkinManagerMetrics is a standalone class that represents a collection of metrics of the current skin. More...

Inheritance diagram for CXTPSkinManagerMetrics:
[legend]

Public Member Functions

CXTPSkinManagerMetrics (CXTPSkinManagerSchema *pSchema)
Constructs a CXTPSkinManagerMetrics object.
virtual | ~CXTPSkinManagerMetrics ()
Destroys a CXTPSkinManagerMetrics object, handles cleanup and deallocation.
virtual void | RefreshMetrics ()
Refreshes visual metrics.
BOOL | IsMetricObject (HGDIOBJ hObject) const
Determines if a specified handle belongs to metrics.
void | DestroyMetrics ()
Destroys all GDI objects of metrics.
COLORREF | GetColor (int nIndex) const
Retrieves the skinned color of a specified index.
HBRUSH | GetBrush (int nIndex) const
Retrieves the skinned brush of a specified index.
BOOL | CreateTabControlBrush (CBitmap *pBitmap)
Creates a tab control brush.
- Public Member Functions inherited from CXTPSynchronized
CXTPRWCriticalSection & | GetAccessCriticalSection () const
Accesses a synchronized object's critical section.

Public Attributes

CXTPFont | m_xtpFontCaption
Caption font.
CXTPFont | m_xtpFontMenu
Menu font.
CXTPFont | m_xtpFontSmCaption
Small caption font.
CXTPSkinManagerSchema * | m_pSchema
Parent CXTPSkinManager object.
CXTPBrush | m_xtpBrushDialog
Dialog brush.
CXTPBrush | m_xtpBrushTabControl
Tab control brush.
CXTPBrush | m_xtpBrushWindow
Window brush.
COLORREF | m_clrEdgeLight
Light edge color.
COLORREF | m_clrEdgeHighLight
HighLight edge color.
COLORREF | m_clrEdgeShadow
Shadow edge color.
COLORREF | m_clrEdgeDkShadow
Dark shadow edge color.
COLORREF | m_clrTheme [XTP_SKINMETRICS_COLORTABLESIZE]
Colors of the theme.
HBRUSH | m_brTheme [XTP_SKINMETRICS_COLORTABLESIZE]
Brushes of the theme.
int | m_nBorderSize
Border size.
int | m_cxBorder
SM_CXBORDER system metric.
int | m_cyBorder
SM_CYBORDER system metric.
int | m_cxEdge
SM_CXEDGE system metric.
int | m_cyEdge
SM_CYEDGE system metric.
int | m_cxHScroll
SM_CXHSCROLL system metric.
int | m_cyHScroll
SM_CYHSCROLL system metric.
int | m_cxVScroll
SM_CXVSCROLL system metric.
int | m_cyVScroll
SM_CYVSCROLL system metric.
int | m_cyCaption
Height of captions.
int | m_cySmallCaption
Height of small captions.
int | m_cyOsCaption
System caption height.
int | m_cyOsSmallCaption
System small caption height.
int | m_cxOsVScroll
System SM_CXVSCROLL metric.
BOOL | m_bRefreshMetrics
TRUE if refresh metrics is currently executed.

Detailed Description

CXTPSkinManagerMetrics is a standalone class that represents a collection of metrics of the current skin.

Constructor & Destructor Documentation

◆ CXTPSkinManagerMetrics()

CXTPSkinManagerMetrics ( CXTPSkinManagerSchema * pSchema )

Constructs a CXTPSkinManagerMetrics object.

Parameters
pSchema Pointer to the parent skin manager class.

Member Function Documentation

◆ CreateTabControlBrush()

BOOL CreateTabControlBrush ( CBitmap * pBitmap )

Creates a tab control brush.

Parameters
pBitmap Pointer to the bitmap to be used as the tab control brush pattern.
Returns
TRUE if the tab control brush was successfully created.

◆ GetBrush()

HBRUSH GetBrush ( int nIndex ) const

Retrieves the skinned brush of a specified index.

Parameters
nIndex Index of the skinned brush to retrieve.
Returns
The skinned brush of the specified index, otherwise NULL.

◆ GetColor()

COLORREF GetColor ( int nIndex ) const

Retrieves the skinned color of a specified index.

Parameters
nIndex Index of the skinned color to retrieve.
Returns
The skinned color of the specified index, otherwise COLORREF_NULL.

◆ IsMetricObject()

BOOL IsMetricObject ( HGDIOBJ hObject ) const

Determines if a specified handle belongs to metrics.

Parameters
hObject Handle to be tested.
Returns
TRUE if the specified handle belongs to metrics, otherwise FALSE.
The documentation for this class was generated from the following file:
  • XTPSkinManager.h


Toolkit Pro: CXTPSkinManagerResourceFile Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPSkinManagerResourceFile Class Reference

CXTPSkinManagerResourceFile is a standalone class that represents a manager of visual style resources. More...

Inheritance diagram for CXTPSkinManagerResourceFile:
[legend]

Public Member Functions

CXTPSkinManagerResourceFile (CXTPSkinManager *pSkinManager=NULL)
Constructs a CXTPSkinManagerResourceFile object.
virtual | ~CXTPSkinManagerResourceFile ()
Destroys a CXTPSkinManagerResourceFile object, handles cleanup and deallocation.
virtual BOOL | Open (LPCTSTR lpszResourcePath, LPCTSTR lpszIniFileName)
Opens the visual style file.
virtual BOOL | ReadString (CString &str)
Reads the .ini file.
virtual void | Close ()
Closes the visual style file.
virtual CXTPSkinImage * | LoadImage (CString strImageFile)
Loads a specified image from a resource file.
virtual CXTPSkinManagerSchema * | CreateSchema ()
Creates the CXTPSkinManagerSchema class associated with loaded resources.
CString | GetResourcePath () const
Gets the resource path.
CString | GetIniFileName () const
Gets the .ini file name.
HMODULE | GetModuleHandle () const
Gets the handle of the skin module.
void | SetModuleHandle (HMODULE hModule)
Sets the handle of the skin module.
CXTPSkinManager * | GetSkinManager () const
Gets the owner skin manager object.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.
- Public Member Functions inherited from CXTPSynchronized
CXTPRWCriticalSection & | GetAccessCriticalSection () const
Accesses a synchronized object's critical section.

Protected Attributes

LPWSTR | m_lpTextFile
Pointer to the next string.
LPWSTR | m_lpTextFileEnd
Pointer to end of the file.
HMODULE | m_hModule
Handle of the visual style.
HMODULE | m_hInstance
Handle of the visual style.
CString | m_strResourcePath
Resource path.
CString | m_strIniFileName
.ini file name.
CXTPSkinManager * | m_pManager
Parent manager class.
CStdioFile * | m_pIniFile
Pointer to the .ini file on disk.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

CXTPSkinManagerResourceFile is a standalone class that represents a manager of visual style resources.

Constructor & Destructor Documentation

◆ CXTPSkinManagerResourceFile()

CXTPSkinManagerResourceFile ( CXTPSkinManager * pSkinManager = NULL )

Constructs a CXTPSkinManagerResourceFile object.

Parameters
pSkinManager Pointer to the parent SkinFramework manager.

Member Function Documentation

◆ CreateSchema()

virtual CXTPSkinManagerSchema * CreateSchema ( )
virtual

Creates the CXTPSkinManagerSchema class associated with loaded resources.

Returns
A pointer to the newly created CXTPSkinManagerSchema class that will be used to read resources.
See also
CXTPSkinManagerSchema

◆ GetIniFileName()

AFX_INLINE CString GetIniFileName ( ) const

Gets the .ini file name.

Returns
The .ini file name.

◆ GetModuleHandle()

AFX_INLINE HMODULE GetModuleHandle ( ) const

Gets the handle of the skin module.

Returns
The handle of the skin module.

◆ GetResourcePath()

AFX_INLINE CString GetResourcePath ( ) const

Gets the resource path.

Returns
The resource path.

◆ GetSkinManager()

AFX_INLINE CXTPSkinManager * GetSkinManager ( ) const

Gets the owner skin manager object.

Returns
A pointer to the owner skin manager object.

◆ LoadImage()

virtual CXTPSkinImage * LoadImage ( CString strImageFile )
virtual

Loads a specified image from a resource file.

Parameters
strImageFile Path to the specified image.
Returns
A pointer to the newly loaded CXTPSkinImage object containing the loaded bitmap.

◆ Open()

virtual BOOL Open | ( | LPCTSTR | lpszResourcePath,
 |  | LPCTSTR | lpszIniFileName )
 virtual

Opens the visual style file.

Parameters
lpszResourcePath | Path to the specified visual style.
lpszIniFileName | Name of the .ini file to load.
Returns
TRUE if successful, FALSE otherwise.

◆ ReadString()

virtual BOOL ReadString ( CString & str )
virtual

Reads the .ini file.

Parameters
str Reference to the string used to load the next line from the resource file.
Returns
TRUE if successful, FALSE otherwise.

◆ SetModuleHandle()

AFX_INLINE void SetModuleHandle ( HMODULE hModule )

Sets the handle of the skin module.

Parameters
hModule Handle to be set.
The documentation for this class was generated from the following file:
  • XTPSkinManagerResource.h


Toolkit Pro: CXTPSkinManagerSchema Class Reference

Public Member Functions | Static Public Member Functions | Protected Attributes | List of all members
CXTPSkinManagerSchema Class Reference

CXTPSkinManagerSchema is a standalone class used to read a visual styles schema file. More...

Inheritance diagram for CXTPSkinManagerSchema:
[legend]

Public Member Functions

CXTPSkinManagerSchema (CXTPSkinManagerResourceFile *pResourceFile)
Constructs a CXTPSkinManagerSchema object.
virtual | ~CXTPSkinManagerSchema ()
Destroys a CXTPSkinManagerSchema object, handles cleanup and deallocation.
HRESULT | ReadProperties ()
Reads all properties from a specified resource file.
HRESULT | GetStringProperty (UINT iClassId, int iPartId, int iStateId, int iPropId, CString &strVal)
Gets the value of a specified string property.
HRESULT | GetRectProperty (UINT iClassId, int iPartId, int iStateId, int iPropId, CRect &rcVal)
Gets the value of a specified RECT property.
HRESULT | GetIntProperty (UINT iClassId, int iPartId, int iStateId, int iPropId, int &iVal)
Gets the value of a specified int property.
HRESULT | GetBoolProperty (UINT iClassId, int iPartId, int iStateId, int iPropId, BOOL &bVal)
Gets the value of a specified BOOL property.
HRESULT | GetColorProperty (UINT iClassId, int iPartId, int iStateId, int iPropId, COLORREF &clrVal)
Gets the value of a specified COLORREF property.
HRESULT | GetEnumProperty (UINT iClassId, int iPartId, int iStateId, int iPropId, int &nVal)
Gets the value of a specified enum property.
HRESULT | GetFontProperty (UINT iClassId, int iPartId, int iStateId, int iPropId, LOGFONT &lfVal)
Gets the value of a specified LOGFONT property.
HRESULT | GetSizeProperty (UINT iClassId, int iPartId, int iStateId, int iPropId, CSize &szVal)
Gets the value of a specified CSize property.
CString | GetSchemaName () const
Gets the schema name.
CXTPSkinManager * | GetSkinManager () const
Gets the parent skin manager object.
CXTPSkinManagerResourceFile * | GetResourceFile () const
Gets the resource file object.
CXTPSkinManagerMetrics * | GetMetrics () const
Gets the metrics object.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.
- Public Member Functions inherited from CXTPSynchronized
CXTPRWCriticalSection & | GetAccessCriticalSection () const
Accesses a synchronized object's critical section.

Static Public Member Functions

static UINT AFX_CDECL | GetClassCode (LPCTSTR strClass)
Gets the hash code of a specified class.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Protected Attributes

CMap< UINT, UINT, CXTPSkinManagerSchemaProperty *, CXTPSkinManagerSchemaProperty * > | m_mapProperties
Properties collection.
CXTPSkinManager * | m_pManager
Parent CXTPSkinManager class.
CXTPSkinManagerResourceFile * | m_pResourceFile
Resources.
CXTPSkinManagerMetrics * | m_pMetrics
Skin metrics.
CString | m_strSchemaName
Schema name.
CArray< FRAMEREGION *, FRAMEREGION * > | m_arrFrameRegions
Frame region.
CMapStringToPtr | m_mapClasses
Classes collection.

Detailed Description

CXTPSkinManagerSchema is a standalone class used to read a visual styles schema file.

Constructor & Destructor Documentation

◆ CXTPSkinManagerSchema()

CXTPSkinManagerSchema ( CXTPSkinManagerResourceFile * pResourceFile )

Constructs a CXTPSkinManagerSchema object.

Parameters
pResourceFile Resource file to read.

Member Function Documentation

◆ GetBoolProperty()

HRESULT GetBoolProperty | ( | UINT | iClassId,
 |  | int | iPartId,
 |  | int | iStateId,
 |  | int | iPropId,
 |  | BOOL & | bVal )

Gets the value of a specified BOOL property.

Parameters
iClassId | Class hash code.
iPartId | Part number.
iStateId | State number of the part.
iPropId | Property number to get the value of.
bVal | Reference to a BOOL to receive the value of the specified BOOL property.
Returns
S_OK if successful.

◆ GetClassCode()

static UINT AFX_CDECL GetClassCode ( LPCTSTR strClass )
static

Gets the hash code of a specified class.

Parameters
strClass Class name.
Returns
The hash code of the specified class.

◆ GetColorProperty()

HRESULT GetColorProperty | ( | UINT | iClassId,
 |  | int | iPartId,
 |  | int | iStateId,
 |  | int | iPropId,
 |  | COLORREF & | clrVal )

Gets the value of a specified COLORREF property.

Parameters
iClassId | Class hash code.
iPartId | Part number.
iStateId | State number of the part.
iPropId | Property number to get the value of.
clrVal | Reference to a COLORREF to receive the value of the specified COLORREF property.
Returns
S_OK if successful.

◆ GetEnumProperty()

HRESULT GetEnumProperty | ( | UINT | iClassId,
 |  | int | iPartId,
 |  | int | iStateId,
 |  | int | iPropId,
 |  | int & | nVal )

Gets the value of a specified enum property.

Parameters
iClassId | Class hash code.
iPartId | Part number.
iStateId | State number of the part.
iPropId | Property number to get the value of.
nVal | Reference to an int to receive the value of the specified enum property.
Returns
S_OK if successful.

◆ GetFontProperty()

HRESULT GetFontProperty | ( | UINT | iClassId,
 |  | int | iPartId,
 |  | int | iStateId,
 |  | int | iPropId,
 |  | LOGFONT & | lfVal )

Gets the value of a specified LOGFONT property.

Parameters
iClassId | Class hash code.
iPartId | Part number.
iStateId | State number of the part.
iPropId | Property number to get the value of.
lfVal | Reference to a LOGFONT to receive the value of the specified LOGFONT property.
Returns
S_OK if successful.

◆ GetIntProperty()

HRESULT GetIntProperty | ( | UINT | iClassId,
 |  | int | iPartId,
 |  | int | iStateId,
 |  | int | iPropId,
 |  | int & | iVal )

Gets the value of a specified int property.

Parameters
iClassId | Class hash code.
iPartId | Part number.
iStateId | State number of the part.
iPropId | Property number to get the value of.
iVal | Reference to an int to receive the value of the specified int property.
Returns
S_OK if successful.

◆ GetMetrics()

AFX_INLINE CXTPSkinManagerMetrics * GetMetrics ( ) const

Gets the metrics object.

Returns
A pointer to the metrics object.

◆ GetRectProperty()

HRESULT GetRectProperty | ( | UINT | iClassId,
 |  | int | iPartId,
 |  | int | iStateId,
 |  | int | iPropId,
 |  | CRect & | rcVal )

Gets the value of a specified RECT property.

Parameters
iClassId | Class hash code.
iPartId | Part number.
iStateId | State number of the part.
iPropId | Property number to get the value of.
rcVal | Reference to a CRect object to receive the value of the specified RECT property.
Returns
S_OK if successful.

◆ GetResourceFile()

AFX_INLINE CXTPSkinManagerResourceFile * GetResourceFile ( ) const

Gets the resource file object.

Returns
A pointer to the resource file object.

◆ GetSchemaName()

AFX_INLINE CString GetSchemaName ( ) const

Gets the schema name.

Returns
The schema name.

◆ GetSizeProperty()

HRESULT GetSizeProperty | ( | UINT | iClassId,
 |  | int | iPartId,
 |  | int | iStateId,
 |  | int | iPropId,
 |  | CSize & | szVal )

Gets the value of a specified CSize property.

Parameters
iClassId | Class hash code.
iPartId | Part number.
iStateId | State number of the part.
iPropId | Property number to get the value of.
szVal | Reference to a CSize to receive the value of the specified CSize property value.
Returns
S_OK if successful.

◆ GetSkinManager()

AFX_INLINE CXTPSkinManager * GetSkinManager ( ) const

Gets the parent skin manager object.

Returns
A pointer to the parent skin manager object.

◆ GetStringProperty()

HRESULT GetStringProperty | ( | UINT | iClassId,
 |  | int | iPartId,
 |  | int | iStateId,
 |  | int | iPropId,
 |  | CString & | strVal )

Gets the value of a specified string property.

Parameters
iClassId | Class hash code.
iPartId | Part number.
iStateId | State number of the part.
iPropId | Property number to get the value of.
strVal | Reference to a string to receive the value of the specified string property.
Returns
S_OK if successful.

◆ ReadProperties()

HRESULT ReadProperties ( )

Reads all properties from a specified resource file.

Returns
S_OK if successful.
The documentation for this class was generated from the following file:
  • XTPSkinManagerSchema.h


Toolkit Pro: CXTPSkinManagerSchemaProperty Class Reference

Public Member Functions | Public Attributes | List of all members
CXTPSkinManagerSchemaProperty Class Reference

CXTPSkinManagerSchemaProperty is a standalone class representing a single property of a visual styles .ini file. More...

Inheritance diagram for CXTPSkinManagerSchemaProperty:
[legend]

Public Member Functions

CXTPSkinManagerSchemaProperty ()
Constructs a CXTPSkinManagerSchemaProperty object.
~CXTPSkinManagerSchemaProperty ()
Destroys a CXTPSkinManagerSchemaProperty object, handles cleanup and deallocation.
void | SetPropertyColor (LPCTSTR lpszValue)
Sets the color value of the property.
void | SetPropertyString (LPCTSTR lpszValue)
Sets the string value of the property.
void | SetPropertyBool (LPCTSTR lpszValue)
Sets the BOOL value of the property.
void | SetPropertyInt (LPCTSTR lpszValue)
Sets the int value of the property.
void | SetPropertyEnum (int nEnumValue)
Sets the enum value of the property.
void | SetPropertySize (LPCTSTR lpszValue)
Sets the size value of the property.
void | SetPropertyRect (LPCTSTR lpszValue)
Sets the RECT value of the property.
void | SetPropertyFont (LPCTSTR lpszValue)
Sets the LOGFONT value of the property.
void | ClearProperty ()
Clears the property value.
- Public Member Functions inherited from CXTPSynchronized
CXTPRWCriticalSection & | GetAccessCriticalSection () const
Accesses a synchronized object's critical section.

Public Attributes

XTPSkinManagerProperty | propType
Property type.
int | nPropertyCode
Property code.

Detailed Description

CXTPSkinManagerSchemaProperty is a standalone class representing a single property of a visual styles .ini file.

Member Function Documentation

◆ SetPropertyBool()

void SetPropertyBool ( LPCTSTR lpszValue )

Sets the BOOL value of the property.

This method converts a string to a BOOL value.

Parameters
lpszValue String to be converted.

◆ SetPropertyColor()

void SetPropertyColor ( LPCTSTR lpszValue )

Sets the color value of the property.

This method converts a string to a color value.

Parameters
lpszValue String to be converted.

◆ SetPropertyEnum()

void SetPropertyEnum ( int nEnumValue )

Sets the enum value of the property.

Parameters
nEnumValue Enum value to be set.

◆ SetPropertyFont()

void SetPropertyFont ( LPCTSTR lpszValue )

Sets the LOGFONT value of the property.

This method converts a string to a LOGFONT value.

Parameters
lpszValue String to be converted.

◆ SetPropertyInt()

void SetPropertyInt ( LPCTSTR lpszValue )

Sets the int value of the property.

This method converts a string to an int value.

Parameters
lpszValue String to be converted.

◆ SetPropertyRect()

void SetPropertyRect ( LPCTSTR lpszValue )

Sets the RECT value of the property.

This method converts a string to a RECT value.

Parameters
lpszValue String to be converted.

◆ SetPropertySize()

void SetPropertySize ( LPCTSTR lpszValue )

Sets the size value of the property.

This method converts a string to a size value.

Parameters
lpszValue String to be converted.

◆ SetPropertyString()

void SetPropertyString ( LPCTSTR lpszValue )

Sets the string value of the property.

Parameters
lpszValue String to be set.
The documentation for this class was generated from the following file:
  • XTPSkinManagerSchema.h


Toolkit Pro: CXTPSkinObject Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPSkinObject Class Reference

CXTPSkinObject is a CWnd derived class. More...

Inheritance diagram for CXTPSkinObject:
[legend]

Public Member Functions

CXTPSkinManager * | GetSkinManager () const
Gets the parent CXTPSkinManager object.
CString | GetClassName () const
Gets own class name.
CXTPSkinManagerClass * | GetSkinClass () const
Gets the CXTPSkinManagerClass object associated with own class name.
CXTPSkinManagerMetrics * | GetMetrics () const
Gets the skin metrics.
COLORREF | GetColor (int nIndex) const
Retrieves the specified system color.
- Public Member Functions inherited from CXTPSynchronized
CXTPRWCriticalSection & | GetAccessCriticalSection () const
Accesses a synchronized object's critical section.

Protected Member Functions

CXTPSkinObject ()
Constructs a CXTPSkinObject object.
~CXTPSkinObject ()
Destroys a CXTPSkinObject object, handles cleanup and deallocation.
virtual void | OnSkinChanged (BOOL bPrevState, BOOL bNewState)
This method is called when the skin is changed.
virtual void | RefreshMetrics ()
This method is called when visual metrics are changed.
virtual void | OnHookAttached (LPCREATESTRUCT lpcs, BOOL bAuto)
This method is called when the hook is attached.
virtual void | OnHookDetached (BOOL bAuto)
This method is called when the hook is detached.

Protected Attributes

WNDPROC | m_pOldWndProc
Old window window handler.
CXTPSkinManager * | m_pManager
Parent CXTPSkinManager object.
CString | m_strClassName
Own class name.
BOOL | m_bActiveX
TRUE if ActiveX controls.
BOOL | m_bWindowsForms
TRUE if .NET controls.

Detailed Description

CXTPSkinObject is a CWnd derived class.

It represents the base class for all skinable windows.

Member Function Documentation

◆ GetClassName()

AFX_INLINE CString GetClassName ( ) const

Gets own class name.

Returns
Own class name.
See also
GetSkinClass

◆ GetColor()

COLORREF GetColor ( int nIndex ) const

Retrieves the specified system color.

Parameters
nIndex Index of the system color to retrieve, as described in the GetSysColor function documentation from the Windows SDK.
Returns
The specified system color.

◆ GetMetrics()

CXTPSkinManagerMetrics * GetMetrics ( ) const

Gets the skin metrics.

Returns
A pointer to the CXTPSkinManagerMetrics class containing the skin metrics.

◆ GetSkinClass()

CXTPSkinManagerClass * GetSkinClass ( ) const

Gets the CXTPSkinManagerClass object associated with own class name.

Returns
A pointer to the CXTPSkinManagerClass object associated with own class name.
See also
GetClassName

◆ GetSkinManager()

AFX_INLINE CXTPSkinManager * GetSkinManager ( ) const

Gets the parent CXTPSkinManager object.

Returns
A pointer to the parent CXTPSkinManager object.

◆ OnHookAttached()

virtual void OnHookAttached | ( | LPCREATESTRUCT | lpcs,
 |  | BOOL | bAuto )
 protectedvirtual

This method is called when the hook is attached.

Parameters
lpcs | Pointer to a LPCREATESTRUCT structure that contains information about the CWnd object being created.
bAuto | TRUE to automatically skin the window when a new window is created or when the user manually skins the existing window.

Reimplemented in CXTPSkinObjectFrame.

◆ OnHookDetached()

virtual void OnHookDetached ( BOOL bAuto )
protectedvirtual

This method is called when the hook is detached.

Parameters
bAuto TRUE to automatically skin the window when a new window is created or when the user manually skins the existing window.

Reimplemented in CXTPSkinObjectFrame.

◆ OnSkinChanged()

virtual void OnSkinChanged | ( | BOOL | bPrevState,
 |  | BOOL | bNewState )
 protectedvirtual

This method is called when the skin is changed.

Parameters
bPrevState | TRUE if the previous skin was installed.
bNewState | TRUE if the current skin is installed.

Reimplemented in CXTPSkinObjectDateTime, and CXTPSkinObjectFrame.

The documentation for this class was generated from the following file:
  • XTPSkinObject.h


Toolkit Pro: CXTPSkinObjectButton Class Reference

Public Member Functions | Public Attributes | Protected Attributes | List of all members
CXTPSkinObjectButton Class Reference

CXTPSkinObjectButton is a CXTPSkinObjectFrame derived class. More...

Inheritance diagram for CXTPSkinObjectButton:
[legend]

Public Member Functions

CXTPSkinObjectButton ()
Constructs a CXTPSkinObjectButton object.
virtual | ~CXTPSkinObjectButton ()
Destroys a CXTPSkinObjectButton object, handles cleanup and deallocation.
- Public Member Functions inherited from CXTPSkinObjectFrame
CXTPSkinObjectFrame ()
Constructs a CXTPSkinObjectFrame object.
virtual | ~CXTPSkinObjectFrame ()
Destroys a CXTPSkinObjectFrame object, handles cleanup and deallocation.
void | RedrawScrollBar (int nBar)
Redraws the scrollbar of the frame.
CRect | GetBorders () const
Gets the borders of the window.
BOOL | IsActive () const
Determines if the caption is active.
CCaptionButtons * | GetCaptionButtons ()
Gets the collection of caption buttons.
virtual HBRUSH | GetClientBrush (CDC *pDC)
Gets the client brush.
- Public Member Functions inherited from CXTPSkinObject
CXTPSkinManager * | GetSkinManager () const
Gets the parent CXTPSkinManager object.
CString | GetClassName () const
Gets own class name.
CXTPSkinManagerClass * | GetSkinClass () const
Gets the CXTPSkinManagerClass object associated with own class name.
CXTPSkinManagerMetrics * | GetMetrics () const
Gets the skin metrics.
COLORREF | GetColor (int nIndex) const
Retrieves the specified system color.
- Public Member Functions inherited from CXTPSynchronized
CXTPRWCriticalSection & | GetAccessCriticalSection () const
Accesses a synchronized object's critical section.

Public Attributes

BYTE | m_bStyle
Custom style of button.
- Public Attributes inherited from CXTPSkinObjectFrame
BOOL | m_bLockFrameDraw
TRUE to lock draw.
DWORD | m_dwDialogTexture
Dialog texture.

Protected Attributes

BOOL | m_bHot
TRUE if mouse under button.
BOOL | m_bPushed
TRUE if button was pressed.
- Protected Attributes inherited from CXTPSkinObjectFrame
CCaptionButtons | m_arrButtons
Caption buttons.
CRect | m_rcBorders
Frame borders.
CCaptionButton * | m_pButtonHot
Hot caption button.
CCaptionButton * | m_pButtonPressed
Pressed caption button.
BOOL | m_bRegionChanged
TRUE if region was changed.
XTP_SKINSCROLLBAR_TRACKINFO * | m_pSBTrack
Track info of scrollbars.
XTP_SKINSCROLLBAR_POSINFO | m_spi [2]
Scrollbar position info.
CSize | m_szFrameRegion
Previous frame region.
BOOL | m_bMDIClient
TRUE if the frame is a MDI client.
BOOL | m_bActive
TRUE if the caption is active.
DWORD | m_dwStyle
Styles of window.
DWORD | m_dwExStyle
ExStyles of window.
- Protected Attributes inherited from CXTPSkinObject
WNDPROC | m_pOldWndProc
Old window window handler.
CXTPSkinManager * | m_pManager
Parent CXTPSkinManager object.
CString | m_strClassName
Own class name.
BOOL | m_bActiveX
TRUE if ActiveX controls.
BOOL | m_bWindowsForms
TRUE if .NET controls.

Additional Inherited Members

- Public Types inherited from CXTPSkinObjectFrame
- Static Public Attributes inherited from CXTPSkinObject
- Protected Member Functions inherited from CXTPSkinObjectFrame
virtual void | OnSkinChanged (BOOL bPrevState, BOOL bNewState)
This method is called when the skin is changed.
virtual void | RefreshMetrics ()
This method is called when visual metrics are changed.
virtual void | OnHookAttached (LPCREATESTRUCT lpcs, BOOL bAuto)
This method is called when the hook is attached.
void | OnHookDetached (BOOL bAuto)
This method is called when the hook is detached.
- Protected Member Functions inherited from CXTPSkinObject
CXTPSkinObject ()
Constructs a CXTPSkinObject object.
~CXTPSkinObject ()
Destroys a CXTPSkinObject object, handles cleanup and deallocation.
- Static Protected Attributes inherited from CXTPSkinObjectFrame

Detailed Description

CXTPSkinObjectButton is a CXTPSkinObjectFrame derived class.

It implements standard buttons.

The documentation for this class was generated from the following file:
  • XTPSkinObjectButton.h


Toolkit Pro: CXTPSkinObjectClassMap Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPSkinObjectClassMap Class Reference

CXTPSkinObjectClassMap is a standalone class that helps map windows controls to skin framework classes. More...

Inheritance diagram for CXTPSkinObjectClassMap:
[legend]

Public Member Functions

CXTPSkinObjectClassMap ()
Constructs a CXTPSkinObjectClassMap object.
~CXTPSkinObjectClassMap ()
Destroys a CXTPSkinObjectClassMap object, handles cleanup and deallocation.
void | AddStandardClasses ()
This method is called by the framework to add all standard window classes.
CXTPSkinObjectClassInfo * | AddClass (LPCTSTR lpszClassName, CXTPSkinObjectClassInfo *pInfo)
Maps a window class name to a skin framework class.
void | AddSynonymClass (LPCTSTR lpszClassNameSynonym, LPCTSTR lpszClassName)
Maps a window class name to another window class name.
void | RemoveClass (LPCTSTR lpszClassName)
Removes a window class.
void | RemoveClass (CXTPSkinObjectClassInfo *pInfo)
Removes a skin framework class.
void | RemoveAll ()
Removes all classes.
CXTPSkinObjectClassInfo * | Lookup (LPCTSTR lpszClassName)
Searches for a Skin Object Class Information object by a specified name.
- Public Member Functions inherited from CXTPSynchronized
CXTPRWCriticalSection & | GetAccessCriticalSection () const
Accesses a synchronized object's critical section.

Protected Attributes

CMapStringToPtr m_mapInfo
General map.

Detailed Description

CXTPSkinObjectClassMap is a standalone class that helps map windows controls to skin framework classes.

CXTPSkinManager uses this class to find what skin framework class needs to apply to a new window in order to skin it properly. For example, if a new window were to be created with the class name of "BUTTON", then CXTPSkinObjectClassMap::Lookup would retrieve the runtime class of CXTPSkinObjectButton to apply it to the new window and skin it.

See also
CXTPSkinManager, CXTPSkinObject, CXTPSkinManager::GetClassMap

Member Function Documentation

◆ AddClass()

CXTPSkinObjectClassInfo * AddClass | ( | LPCTSTR | lpszClassName,
 |  | CXTPSkinObjectClassInfo * | pInfo )

Maps a window class name to a skin framework class.

Parameters
lpszClassName | Window class name.
pInfo | Pointer to the skin framework class.

Example:

pClassMap->AddClass(_T("ListBox"), new
CXTPSkinObjectClassInfo(RUNTIME_CLASS(CXTPSkinObjectListBox)));
Returns
A requested skin object class information object pointer, or NULL if failed.
See also
AddSynonymClass, AddStandardClasses

◆ AddStandardClasses()

void AddStandardClasses ( )

This method is called by the framework to add all standard window classes.

CXTPSkinManager calls this method to add standard window classes such as "BUTTON", "LISTBOX", and "SCROLLBAR".

◆ AddSynonymClass()

void AddSynonymClass | ( | LPCTSTR | lpszClassNameSynonym,
 |  | LPCTSTR | lpszClassName )

Maps a window class name to another window class name.

Parameters
lpszClassNameSynonym | New window class name.
lpszClassName | Standard window class name.

Example:

pClassMap->AddSynonymClass(_T("SysDateTimePick32"), _T("Edit"));
See also
AddClass

◆ Lookup()

CXTPSkinObjectClassInfo * Lookup ( LPCTSTR lpszClassName )

Searches for a Skin Object Class Information object by a specified name.

Parameters
lpszClassName Name of the class to lookup.
Returns
A pointer to the CXTPSkinObjectClassInfo object if found, otherwise NULL.

◆ RemoveAll()

void RemoveAll ( )

Removes all classes.

See also
AddClass

◆ RemoveClass() [1/2]

void RemoveClass ( CXTPSkinObjectClassInfo * pInfo )

Removes a skin framework class.

Parameters
pInfo Pointer to the skin framework class.
See also
AddClass

◆ RemoveClass() [2/2]

void RemoveClass ( LPCTSTR lpszClassName )

Removes a window class.

Parameters
lpszClassName Window class name to remove.
See also
AddClass
The documentation for this class was generated from the following file:
  • XTPSkinObject.h


Toolkit Pro: CXTPSkinObjectComboBox Class Reference

Public Member Functions | List of all members
CXTPSkinObjectComboBox Class Reference

CXTPSkinObjectComboBox is a CXTPSkinObjectFrame derived class. More...

Inheritance diagram for CXTPSkinObjectComboBox:
[legend]

Public Member Functions

CXTPSkinObjectComboBox ()
Constructs a CXTPSkinObjectComboBox object.
virtual | ~CXTPSkinObjectComboBox ()
Destroys a CXTPSkinObjectComboBox object, handles cleanup and deallocation.
virtual void | OnDraw (CDC *pDC)
Performs all drawing logic.
- Public Member Functions inherited from CXTPSkinObjectFrame
CXTPSkinObjectFrame ()
Constructs a CXTPSkinObjectFrame object.
virtual | ~CXTPSkinObjectFrame ()
Destroys a CXTPSkinObjectFrame object, handles cleanup and deallocation.
void | RedrawScrollBar (int nBar)
Redraws the scrollbar of the frame.
CRect | GetBorders () const
Gets the borders of the window.
BOOL | IsActive () const
Determines if the caption is active.
CCaptionButtons * | GetCaptionButtons ()
Gets the collection of caption buttons.
virtual HBRUSH | GetClientBrush (CDC *pDC)
Gets the client brush.
- Public Member Functions inherited from CXTPSkinObject
CXTPSkinManager * | GetSkinManager () const
Gets the parent CXTPSkinManager object.
CString | GetClassName () const
Gets own class name.
CXTPSkinManagerClass * | GetSkinClass () const
Gets the CXTPSkinManagerClass object associated with own class name.
CXTPSkinManagerMetrics * | GetMetrics () const
Gets the skin metrics.
COLORREF | GetColor (int nIndex) const
Retrieves the specified system color.
- Public Member Functions inherited from CXTPSynchronized
CXTPRWCriticalSection & | GetAccessCriticalSection () const
Accesses a synchronized object's critical section.

Additional Inherited Members

- Public Types inherited from CXTPSkinObjectFrame
- Public Attributes inherited from CXTPSkinObjectFrame
BOOL | m_bLockFrameDraw
TRUE to lock draw.
DWORD | m_dwDialogTexture
Dialog texture.
- Static Public Attributes inherited from CXTPSkinObject
- Protected Member Functions inherited from CXTPSkinObjectFrame
virtual void | OnSkinChanged (BOOL bPrevState, BOOL bNewState)
This method is called when the skin is changed.
virtual void | RefreshMetrics ()
This method is called when visual metrics are changed.
virtual void | OnHookAttached (LPCREATESTRUCT lpcs, BOOL bAuto)
This method is called when the hook is attached.
void | OnHookDetached (BOOL bAuto)
This method is called when the hook is detached.
- Protected Member Functions inherited from CXTPSkinObject
CXTPSkinObject ()
Constructs a CXTPSkinObject object.
~CXTPSkinObject ()
Destroys a CXTPSkinObject object, handles cleanup and deallocation.
- Protected Attributes inherited from CXTPSkinObjectFrame
CCaptionButtons | m_arrButtons
Caption buttons.
CRect | m_rcBorders
Frame borders.
CCaptionButton * | m_pButtonHot
Hot caption button.
CCaptionButton * | m_pButtonPressed
Pressed caption button.
BOOL | m_bRegionChanged
TRUE if region was changed.
XTP_SKINSCROLLBAR_TRACKINFO * | m_pSBTrack
Track info of scrollbars.
XTP_SKINSCROLLBAR_POSINFO | m_spi [2]
Scrollbar position info.
CSize | m_szFrameRegion
Previous frame region.
BOOL | m_bMDIClient
TRUE if the frame is a MDI client.
BOOL | m_bActive
TRUE if the caption is active.
DWORD | m_dwStyle
Styles of window.
DWORD | m_dwExStyle
ExStyles of window.
- Protected Attributes inherited from CXTPSkinObject
WNDPROC | m_pOldWndProc
Old window window handler.
CXTPSkinManager * | m_pManager
Parent CXTPSkinManager object.
CString | m_strClassName
Own class name.
BOOL | m_bActiveX
TRUE if ActiveX controls.
BOOL | m_bWindowsForms
TRUE if .NET controls.
- Static Protected Attributes inherited from CXTPSkinObjectFrame

Detailed Description

CXTPSkinObjectComboBox is a CXTPSkinObjectFrame derived class.

It implements standard comboboxes.

Member Function Documentation

◆ OnDraw()

virtual void OnDraw ( CDC * pDC )
virtual

Performs all drawing logic.

Parameters
pDC Pointer to the device context to draw the control image with.
The documentation for this class was generated from the following file:
  • XTPSkinObjectComboBox.h


Toolkit Pro: CXTPSkinObjectComCtl32Control Class Reference

Protected Member Functions | List of all members
CXTPSkinObjectComCtl32Control Class Reference

CXTPSkinObjectComCtl32Control is a CXTPSkinObjectUser32Control derived class. More...

Inheritance diagram for CXTPSkinObjectComCtl32Control:
[legend]

Protected Member Functions

CXTPSkinObjectComCtl32Control ()
Constructs a CXTPSkinObjectComCtl32Control object.
virtual void | CheckScrollBarsDraw ()
Determines if the scrollbar position was changed.
- Protected Member Functions inherited from CXTPSkinObjectUser32Control
CXTPSkinObjectUser32Control ()
Constructs a CXTPSkinObjectUser32Control object.
- Protected Member Functions inherited from CXTPSkinObjectFrame
virtual void | OnSkinChanged (BOOL bPrevState, BOOL bNewState)
This method is called when the skin is changed.
virtual void | RefreshMetrics ()
This method is called when visual metrics are changed.
virtual void | OnHookAttached (LPCREATESTRUCT lpcs, BOOL bAuto)
This method is called when the hook is attached.
void | OnHookDetached (BOOL bAuto)
This method is called when the hook is detached.
- Protected Member Functions inherited from CXTPSkinObject
CXTPSkinObject ()
Constructs a CXTPSkinObject object.
~CXTPSkinObject ()
Destroys a CXTPSkinObject object, handles cleanup and deallocation.

Additional Inherited Members

- Public Types inherited from CXTPSkinObjectFrame
- Public Member Functions inherited from CXTPSkinObjectFrame
CXTPSkinObjectFrame ()
Constructs a CXTPSkinObjectFrame object.
virtual | ~CXTPSkinObjectFrame ()
Destroys a CXTPSkinObjectFrame object, handles cleanup and deallocation.
void | RedrawScrollBar (int nBar)
Redraws the scrollbar of the frame.
CRect | GetBorders () const
Gets the borders of the window.
BOOL | IsActive () const
Determines if the caption is active.
CCaptionButtons * | GetCaptionButtons ()
Gets the collection of caption buttons.
virtual HBRUSH | GetClientBrush (CDC *pDC)
Gets the client brush.
- Public Member Functions inherited from CXTPSkinObject
CXTPSkinManager * | GetSkinManager () const
Gets the parent CXTPSkinManager object.
CString | GetClassName () const
Gets own class name.
CXTPSkinManagerClass * | GetSkinClass () const
Gets the CXTPSkinManagerClass object associated with own class name.
CXTPSkinManagerMetrics * | GetMetrics () const
Gets the skin metrics.
COLORREF | GetColor (int nIndex) const
Retrieves the specified system color.
- Public Member Functions inherited from CXTPSynchronized
CXTPRWCriticalSection & | GetAccessCriticalSection () const
Accesses a synchronized object's critical section.
- Public Attributes inherited from CXTPSkinObjectFrame
BOOL | m_bLockFrameDraw
TRUE to lock draw.
DWORD | m_dwDialogTexture
Dialog texture.
- Static Public Attributes inherited from CXTPSkinObject
- Protected Attributes inherited from CXTPSkinObjectFrame
CCaptionButtons | m_arrButtons
Caption buttons.
CRect | m_rcBorders
Frame borders.
CCaptionButton * | m_pButtonHot
Hot caption button.
CCaptionButton * | m_pButtonPressed
Pressed caption button.
BOOL | m_bRegionChanged
TRUE if region was changed.
XTP_SKINSCROLLBAR_TRACKINFO * | m_pSBTrack
Track info of scrollbars.
XTP_SKINSCROLLBAR_POSINFO | m_spi [2]
Scrollbar position info.
CSize | m_szFrameRegion
Previous frame region.
BOOL | m_bMDIClient
TRUE if the frame is a MDI client.
BOOL | m_bActive
TRUE if the caption is active.
DWORD | m_dwStyle
Styles of window.
DWORD | m_dwExStyle
ExStyles of window.
- Protected Attributes inherited from CXTPSkinObject
WNDPROC | m_pOldWndProc
Old window window handler.
CXTPSkinManager * | m_pManager
Parent CXTPSkinManager object.
CString | m_strClassName
Own class name.
BOOL | m_bActiveX
TRUE if ActiveX controls.
BOOL | m_bWindowsForms
TRUE if .NET controls.
- Static Protected Attributes inherited from CXTPSkinObjectFrame

Detailed Description

CXTPSkinObjectComCtl32Control is a CXTPSkinObjectUser32Control derived class.

It is the base class for all ComCtl32 defined controls.

The documentation for this class was generated from the following file:
  • XTPSkinObjectFrame.h


Toolkit Pro: CXTPSkinObjectDateTime Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPSkinObjectDateTime Class Reference

CXTPSkinObjectDateTime is a CXTPSkinObjectComboBox derived class. More...

Inheritance diagram for CXTPSkinObjectDateTime:
[legend]

Public Member Functions

CXTPSkinObjectDateTime ()
Constructs a CXTPSkinObjectDateTime object.
CRect | GetButtonRect ()
Gets the size and location of the caption button.
void | RefreshMetrics ()
This method is called when visual metrics are changed.
- Public Member Functions inherited from CXTPSkinObjectComboBox
CXTPSkinObjectComboBox ()
Constructs a CXTPSkinObjectComboBox object.
virtual | ~CXTPSkinObjectComboBox ()
Destroys a CXTPSkinObjectComboBox object, handles cleanup and deallocation.
virtual void | OnDraw (CDC *pDC)
Performs all drawing logic.
- Public Member Functions inherited from CXTPSkinObjectFrame
CXTPSkinObjectFrame ()
Constructs a CXTPSkinObjectFrame object.
virtual | ~CXTPSkinObjectFrame ()
Destroys a CXTPSkinObjectFrame object, handles cleanup and deallocation.
void | RedrawScrollBar (int nBar)
Redraws the scrollbar of the frame.
CRect | GetBorders () const
Gets the borders of the window.
BOOL | IsActive () const
Determines if the caption is active.
CCaptionButtons * | GetCaptionButtons ()
Gets the collection of caption buttons.
virtual HBRUSH | GetClientBrush (CDC *pDC)
Gets the client brush.
- Public Member Functions inherited from CXTPSkinObject
CXTPSkinManager * | GetSkinManager () const
Gets the parent CXTPSkinManager object.
CString | GetClassName () const
Gets own class name.
CXTPSkinManagerClass * | GetSkinClass () const
Gets the CXTPSkinManagerClass object associated with own class name.
CXTPSkinManagerMetrics * | GetMetrics () const
Gets the skin metrics.
COLORREF | GetColor (int nIndex) const
Retrieves the specified system color.
- Public Member Functions inherited from CXTPSynchronized
CXTPRWCriticalSection & | GetAccessCriticalSection () const
Accesses a synchronized object's critical section.

Protected Member Functions

void | OnSkinChanged (BOOL bPrevState, BOOL bNewState)
This method is called when the skin is changed.
- Protected Member Functions inherited from CXTPSkinObjectFrame
virtual void | OnHookAttached (LPCREATESTRUCT lpcs, BOOL bAuto)
This method is called when the hook is attached.
void | OnHookDetached (BOOL bAuto)
This method is called when the hook is detached.
- Protected Member Functions inherited from CXTPSkinObject
CXTPSkinObject ()
Constructs a CXTPSkinObject object.
~CXTPSkinObject ()
Destroys a CXTPSkinObject object, handles cleanup and deallocation.

Additional Inherited Members

- Public Types inherited from CXTPSkinObjectFrame
- Static Public Member Functions inherited from CXTPSkinObjectComboBox
- Public Attributes inherited from CXTPSkinObjectFrame
BOOL | m_bLockFrameDraw
TRUE to lock draw.
DWORD | m_dwDialogTexture
Dialog texture.
- Static Public Attributes inherited from CXTPSkinObject
- Protected Attributes inherited from CXTPSkinObjectFrame
CCaptionButtons | m_arrButtons
Caption buttons.
CRect | m_rcBorders
Frame borders.
CCaptionButton * | m_pButtonHot
Hot caption button.
CCaptionButton * | m_pButtonPressed
Pressed caption button.
BOOL | m_bRegionChanged
TRUE if region was changed.
XTP_SKINSCROLLBAR_TRACKINFO * | m_pSBTrack
Track info of scrollbars.
XTP_SKINSCROLLBAR_POSINFO | m_spi [2]
Scrollbar position info.
CSize | m_szFrameRegion
Previous frame region.
BOOL | m_bMDIClient
TRUE if the frame is a MDI client.
BOOL | m_bActive
TRUE if the caption is active.
DWORD | m_dwStyle
Styles of window.
DWORD | m_dwExStyle
ExStyles of window.
- Protected Attributes inherited from CXTPSkinObject
WNDPROC | m_pOldWndProc
Old window window handler.
CXTPSkinManager * | m_pManager
Parent CXTPSkinManager object.
CString | m_strClassName
Own class name.
BOOL | m_bActiveX
TRUE if ActiveX controls.
BOOL | m_bWindowsForms
TRUE if .NET controls.
- Static Protected Attributes inherited from CXTPSkinObjectFrame

Detailed Description

CXTPSkinObjectDateTime is a CXTPSkinObjectComboBox derived class.

It implements a date time control.

Member Function Documentation

◆ GetButtonRect()

CRect GetButtonRect ( )

Gets the size and location of the caption button.

Returns
The size and location of the caption button, or an empty rectangle if no button is defined.

◆ OnSkinChanged()

void OnSkinChanged | ( | BOOL | bPrevState,
 |  | BOOL | bNewState )
 protectedvirtual

This method is called when the skin is changed.

Parameters
bPrevState | TRUE if the previous skin was installed.
bNewState | TRUE if the current skin is installed.

Reimplemented from CXTPSkinObjectFrame.

The documentation for this class was generated from the following file:
  • XTPSkinObjectComboBox.h


Toolkit Pro: CXTPSkinObjectEdit Class Reference

Public Member Functions | List of all members
CXTPSkinObjectEdit Class Reference

CXTPSkinObjectEdit is a CXTPSkinObjectUser32Control derived class. More...

Inheritance diagram for CXTPSkinObjectEdit:
[legend]

Public Member Functions

CXTPSkinObjectEdit ()
Constructs a CXTPSkinObjectEdit object.
virtual | ~CXTPSkinObjectEdit ()
Destroys a CXTPSkinObjectEdit object, handles cleanup and deallocation.
- Public Member Functions inherited from CXTPSkinObjectFrame
CXTPSkinObjectFrame ()
Constructs a CXTPSkinObjectFrame object.
virtual | ~CXTPSkinObjectFrame ()
Destroys a CXTPSkinObjectFrame object, handles cleanup and deallocation.
void | RedrawScrollBar (int nBar)
Redraws the scrollbar of the frame.
CRect | GetBorders () const
Gets the borders of the window.
BOOL | IsActive () const
Determines if the caption is active.
CCaptionButtons * | GetCaptionButtons ()
Gets the collection of caption buttons.
virtual HBRUSH | GetClientBrush (CDC *pDC)
Gets the client brush.
- Public Member Functions inherited from CXTPSkinObject
CXTPSkinManager * | GetSkinManager () const
Gets the parent CXTPSkinManager object.
CString | GetClassName () const
Gets own class name.
CXTPSkinManagerClass * | GetSkinClass () const
Gets the CXTPSkinManagerClass object associated with own class name.
CXTPSkinManagerMetrics * | GetMetrics () const
Gets the skin metrics.
COLORREF | GetColor (int nIndex) const
Retrieves the specified system color.
- Public Member Functions inherited from CXTPSynchronized
CXTPRWCriticalSection & | GetAccessCriticalSection () const
Accesses a synchronized object's critical section.

Additional Inherited Members

- Public Types inherited from CXTPSkinObjectFrame
- Public Attributes inherited from CXTPSkinObjectFrame
BOOL | m_bLockFrameDraw
TRUE to lock draw.
DWORD | m_dwDialogTexture
Dialog texture.
- Static Public Attributes inherited from CXTPSkinObject
- Protected Member Functions inherited from CXTPSkinObjectUser32Control
CXTPSkinObjectUser32Control ()
Constructs a CXTPSkinObjectUser32Control object.
virtual void | CheckScrollBarsDraw ()
Determines if the scrollbar position was changed.
- Protected Member Functions inherited from CXTPSkinObjectFrame
virtual void | OnSkinChanged (BOOL bPrevState, BOOL bNewState)
This method is called when the skin is changed.
virtual void | RefreshMetrics ()
This method is called when visual metrics are changed.
virtual void | OnHookAttached (LPCREATESTRUCT lpcs, BOOL bAuto)
This method is called when the hook is attached.
void | OnHookDetached (BOOL bAuto)
This method is called when the hook is detached.
- Protected Member Functions inherited from CXTPSkinObject
CXTPSkinObject ()
Constructs a CXTPSkinObject object.
~CXTPSkinObject ()
Destroys a CXTPSkinObject object, handles cleanup and deallocation.
- Protected Attributes inherited from CXTPSkinObjectFrame
CCaptionButtons | m_arrButtons
Caption buttons.
CRect | m_rcBorders
Frame borders.
CCaptionButton * | m_pButtonHot
Hot caption button.
CCaptionButton * | m_pButtonPressed
Pressed caption button.
BOOL | m_bRegionChanged
TRUE if region was changed.
XTP_SKINSCROLLBAR_TRACKINFO * | m_pSBTrack
Track info of scrollbars.
XTP_SKINSCROLLBAR_POSINFO | m_spi [2]
Scrollbar position info.
CSize | m_szFrameRegion
Previous frame region.
BOOL | m_bMDIClient
TRUE if the frame is a MDI client.
BOOL | m_bActive
TRUE if the caption is active.
DWORD | m_dwStyle
Styles of window.
DWORD | m_dwExStyle
ExStyles of window.
- Protected Attributes inherited from CXTPSkinObject
WNDPROC | m_pOldWndProc
Old window window handler.
CXTPSkinManager * | m_pManager
Parent CXTPSkinManager object.
CString | m_strClassName
Own class name.
BOOL | m_bActiveX
TRUE if ActiveX controls.
BOOL | m_bWindowsForms
TRUE if .NET controls.
- Static Protected Attributes inherited from CXTPSkinObjectFrame

Detailed Description

CXTPSkinObjectEdit is a CXTPSkinObjectUser32Control derived class.

It implements a standard edit control.

The documentation for this class was generated from the following file:
  • XTPSkinObjectEdit.h


Toolkit Pro: CXTPSkinObjectFrame Class Reference

Classes | Public Member Functions | Public Attributes | Protected Member Functions | Protected Attributes | List of all members
CXTPSkinObjectFrame Class Reference

CXTPSkinObjectFrame is a CXTPSkinObject derived class. More...

Inheritance diagram for CXTPSkinObjectFrame:
[legend]

Classes

class CCaptionButton
Caption button class. More...

Public Member Functions

CXTPSkinObjectFrame ()
Constructs a CXTPSkinObjectFrame object.
virtual | ~CXTPSkinObjectFrame ()
Destroys a CXTPSkinObjectFrame object, handles cleanup and deallocation.
void | RedrawScrollBar (int nBar)
Redraws the scrollbar of the frame.
CRect | GetBorders () const
Gets the borders of the window.
BOOL | IsActive () const
Determines if the caption is active.
CCaptionButtons * | GetCaptionButtons ()
Gets the collection of caption buttons.
virtual HBRUSH | GetClientBrush (CDC *pDC)
Gets the client brush.
- Public Member Functions inherited from CXTPSkinObject
CXTPSkinManager * | GetSkinManager () const
Gets the parent CXTPSkinManager object.
CString | GetClassName () const
Gets own class name.
CXTPSkinManagerClass * | GetSkinClass () const
Gets the CXTPSkinManagerClass object associated with own class name.
CXTPSkinManagerMetrics * | GetMetrics () const
Gets the skin metrics.
COLORREF | GetColor (int nIndex) const
Retrieves the specified system color.
- Public Member Functions inherited from CXTPSynchronized
CXTPRWCriticalSection & | GetAccessCriticalSection () const
Accesses a synchronized object's critical section.

Public Attributes

BOOL | m_bLockFrameDraw
TRUE to lock draw.
DWORD | m_dwDialogTexture
Dialog texture.

Protected Member Functions

virtual void | OnSkinChanged (BOOL bPrevState, BOOL bNewState)
This method is called when the skin is changed.
virtual void | RefreshMetrics ()
This method is called when visual metrics are changed.
virtual void | OnHookAttached (LPCREATESTRUCT lpcs, BOOL bAuto)
This method is called when the hook is attached.
void | OnHookDetached (BOOL bAuto)
This method is called when the hook is detached.
- Protected Member Functions inherited from CXTPSkinObject
CXTPSkinObject ()
Constructs a CXTPSkinObject object.
~CXTPSkinObject ()
Destroys a CXTPSkinObject object, handles cleanup and deallocation.

Protected Attributes

CCaptionButtons | m_arrButtons
Caption buttons.
CRect | m_rcBorders
Frame borders.
CCaptionButton * | m_pButtonHot
Hot caption button.
CCaptionButton * | m_pButtonPressed
Pressed caption button.
BOOL | m_bRegionChanged
TRUE if region was changed.
XTP_SKINSCROLLBAR_TRACKINFO * | m_pSBTrack
Track info of scrollbars.
XTP_SKINSCROLLBAR_POSINFO | m_spi [2]
Scrollbar position info.
CSize | m_szFrameRegion
Previous frame region.
BOOL | m_bMDIClient
TRUE if the frame is a MDI client.
BOOL | m_bActive
TRUE if the caption is active.
DWORD | m_dwStyle
Styles of window.
DWORD | m_dwExStyle
ExStyles of window.
- Protected Attributes inherited from CXTPSkinObject
WNDPROC | m_pOldWndProc
Old window window handler.
CXTPSkinManager * | m_pManager
Parent CXTPSkinManager object.
CString | m_strClassName
Own class name.
BOOL | m_bActiveX
TRUE if ActiveX controls.
BOOL | m_bWindowsForms
TRUE if .NET controls.

Detailed Description

CXTPSkinObjectFrame is a CXTPSkinObject derived class.

It is the parent control for all implementations that have borders or scrollbars.

Member Function Documentation

◆ GetBorders()

AFX_INLINE CRect GetBorders ( ) const

Gets the borders of the window.

Returns
The borders of the window.

◆ GetCaptionButtons()

AFX_INLINE CXTPSkinObjectFrame::CCaptionButtons * GetCaptionButtons ( )

Gets the collection of caption buttons.

Returns
A pointer to the collection of caption buttons.

◆ GetClientBrush()

virtual HBRUSH GetClientBrush ( CDC * pDC )
virtual

Gets the client brush.

Parameters
pDC Pointer to the device context.
Returns
The client brush.

◆ IsActive()

AFX_INLINE BOOL IsActive ( ) const

Determines if the caption is active.

Returns
TRUE if the caption is active, otherwise FALSE.

◆ OnHookAttached()

virtual void OnHookAttached | ( | LPCREATESTRUCT | lpcs,
 |  | BOOL | bAuto )
 protectedvirtual

This method is called when the hook is attached.

Parameters
lpcs | Pointer to a LPCREATESTRUCT structure that contains information about the CWnd object being created.
bAuto | TRUE to automatically skin the window when a new window is created or when the user manually skins the existing window.

Reimplemented from CXTPSkinObject.

◆ OnHookDetached()

void OnHookDetached ( BOOL bAuto )
protectedvirtual

This method is called when the hook is detached.

Parameters
bAuto TRUE to automatically skin the window when a new window is created or when the user manually skins the existing window.

Reimplemented from CXTPSkinObject.

◆ OnSkinChanged()

virtual void OnSkinChanged | ( | BOOL | bPrevState,
 |  | BOOL | bNewState )
 protectedvirtual

This method is called when the skin is changed.

Parameters
bPrevState | TRUE if the previous skin was installed.
bNewState | TRUE if the current skin is installed.

Reimplemented from CXTPSkinObject.

Reimplemented in CXTPSkinObjectDateTime.

◆ RedrawScrollBar()

void RedrawScrollBar ( int nBar )

Redraws the scrollbar of the frame.

Parameters
nBar Orientation of the scrollbar; 1 for vertical, 0 for horizontal.
The documentation for this class was generated from the following file:
  • XTPSkinObjectFrame.h


Toolkit Pro: CXTPSkinObjectFrame::CCaptionButton Class Reference

  • CXTPSkinObjectFrame
  • CCaptionButton
Public Member Functions | Public Attributes | List of all members
CXTPSkinObjectFrame::CCaptionButton Class Reference

Caption button class. More...

Public Member Functions

CCaptionButton (int nCommand, CXTPSkinObjectFrame *pFrame, UINT nHTCode, int m_nClassPart)
Constructs a CCaptionButton object.
virtual | ~CCaptionButton ()
Destroys a CCaptionButton object.
void | Draw (CDC *pDC, BOOL bFrameActive)
This method is called to draw the caption button.
BOOL | IsPressed () const
Determines the pressed state of the button.
BOOL | IsHighlighted () const
Determines the highlighted state of the button.

Public Attributes

UINT | m_nHTCode
Hit test code.
CRect | m_rcButton
Button bounding rectangle.
int | m_nClassPart
Class part.
CXTPSkinObjectFrame * | m_pFrame
Parent frame object.
int | m_nCommand
Button Command.

Detailed Description

Caption button class.

Constructor & Destructor Documentation

◆ CCaptionButton()

CCaptionButton | ( | int | nCommand,
 |  | CXTPSkinObjectFrame * | pFrame,
 |  | UINT | nHTCode,
 |  | int | m_nClassPart )

Constructs a CCaptionButton object.

Parameters
nCommand | Command ID of the button.
pFrame | Pointer to the parent frame object.
nHTCode | Hit test code of the button.
m_nClassPart | Class part.

Member Function Documentation

◆ Draw()

void Draw | ( | CDC * | pDC,
 |  | BOOL | bFrameActive )

This method is called to draw the caption button.

Parameters
pDC | Pointer to the device context.
bFrameActive | TRUE to set the frame to active.

◆ IsHighlighted()

BOOL IsHighlighted ( ) const

Determines the highlighted state of the button.

Returns
TRUE if the button is highlighted, otherwise FALSE.

◆ IsPressed()

BOOL IsPressed ( ) const

Determines the pressed state of the button.

Returns
TRUE if the button is pressed, otherwise FALSE.
The documentation for this class was generated from the following file:
  • XTPSkinObjectFrame.h


Toolkit Pro: CXTPSkinObjectHeader Class Reference

Public Member Functions | List of all members
CXTPSkinObjectHeader Class Reference

CXTPSkinObjectHeader is a CXTPSkinObjectFrame derived class. More...

Inheritance diagram for CXTPSkinObjectHeader:
[legend]

Public Member Functions

CXTPSkinObjectHeader ()
Constructs a CXTPSkinObjectHeader object.
virtual | ~CXTPSkinObjectHeader ()
Destroys a CXTPSkinObjectHeader object, handles cleanup and deallocation.
- Public Member Functions inherited from CXTPSkinObjectFrame
CXTPSkinObjectFrame ()
Constructs a CXTPSkinObjectFrame object.
virtual | ~CXTPSkinObjectFrame ()
Destroys a CXTPSkinObjectFrame object, handles cleanup and deallocation.
void | RedrawScrollBar (int nBar)
Redraws the scrollbar of the frame.
CRect | GetBorders () const
Gets the borders of the window.
BOOL | IsActive () const
Determines if the caption is active.
CCaptionButtons * | GetCaptionButtons ()
Gets the collection of caption buttons.
virtual HBRUSH | GetClientBrush (CDC *pDC)
Gets the client brush.
- Public Member Functions inherited from CXTPSkinObject
CXTPSkinManager * | GetSkinManager () const
Gets the parent CXTPSkinManager object.
CString | GetClassName () const
Gets own class name.
CXTPSkinManagerClass * | GetSkinClass () const
Gets the CXTPSkinManagerClass object associated with own class name.
CXTPSkinManagerMetrics * | GetMetrics () const
Gets the skin metrics.
COLORREF | GetColor (int nIndex) const
Retrieves the specified system color.
- Public Member Functions inherited from CXTPSynchronized
CXTPRWCriticalSection & | GetAccessCriticalSection () const
Accesses a synchronized object's critical section.

Additional Inherited Members

- Public Types inherited from CXTPSkinObjectFrame
- Public Attributes inherited from CXTPSkinObjectFrame
BOOL | m_bLockFrameDraw
TRUE to lock draw.
DWORD | m_dwDialogTexture
Dialog texture.
- Static Public Attributes inherited from CXTPSkinObject
- Protected Member Functions inherited from CXTPSkinObjectFrame
virtual void | OnSkinChanged (BOOL bPrevState, BOOL bNewState)
This method is called when the skin is changed.
virtual void | RefreshMetrics ()
This method is called when visual metrics are changed.
virtual void | OnHookAttached (LPCREATESTRUCT lpcs, BOOL bAuto)
This method is called when the hook is attached.
void | OnHookDetached (BOOL bAuto)
This method is called when the hook is detached.
- Protected Member Functions inherited from CXTPSkinObject
CXTPSkinObject ()
Constructs a CXTPSkinObject object.
~CXTPSkinObject ()
Destroys a CXTPSkinObject object, handles cleanup and deallocation.
- Protected Attributes inherited from CXTPSkinObjectFrame
CCaptionButtons | m_arrButtons
Caption buttons.
CRect | m_rcBorders
Frame borders.
CCaptionButton * | m_pButtonHot
Hot caption button.
CCaptionButton * | m_pButtonPressed
Pressed caption button.
BOOL | m_bRegionChanged
TRUE if region was changed.
XTP_SKINSCROLLBAR_TRACKINFO * | m_pSBTrack
Track info of scrollbars.
XTP_SKINSCROLLBAR_POSINFO | m_spi [2]
Scrollbar position info.
CSize | m_szFrameRegion
Previous frame region.
BOOL | m_bMDIClient
TRUE if the frame is a MDI client.
BOOL | m_bActive
TRUE if the caption is active.
DWORD | m_dwStyle
Styles of window.
DWORD | m_dwExStyle
ExStyles of window.
- Protected Attributes inherited from CXTPSkinObject
WNDPROC | m_pOldWndProc
Old window window handler.
CXTPSkinManager * | m_pManager
Parent CXTPSkinManager object.
CString | m_strClassName
Own class name.
BOOL | m_bActiveX
TRUE if ActiveX controls.
BOOL | m_bWindowsForms
TRUE if .NET controls.
- Static Protected Attributes inherited from CXTPSkinObjectFrame

Detailed Description

CXTPSkinObjectHeader is a CXTPSkinObjectFrame derived class.

It implements a standard list header control.

The documentation for this class was generated from the following file:
  • XTPSkinObjectHeader.h


Toolkit Pro: CXTPSkinObjectListBox Class Reference

Public Member Functions | List of all members
CXTPSkinObjectListBox Class Reference

CXTPSkinObjectListBox is a CXTPSkinObjectUser32Control derived class. More...

Inheritance diagram for CXTPSkinObjectListBox:
[legend]

Public Member Functions

CXTPSkinObjectListBox ()
Constructs a CXTPSkinObjectListBox object.
virtual | ~CXTPSkinObjectListBox ()
Destroys a CXTPSkinObjectListBox object, handles cleanup and deallocation.
- Public Member Functions inherited from CXTPSkinObjectFrame
CXTPSkinObjectFrame ()
Constructs a CXTPSkinObjectFrame object.
virtual | ~CXTPSkinObjectFrame ()
Destroys a CXTPSkinObjectFrame object, handles cleanup and deallocation.
void | RedrawScrollBar (int nBar)
Redraws the scrollbar of the frame.
CRect | GetBorders () const
Gets the borders of the window.
BOOL | IsActive () const
Determines if the caption is active.
CCaptionButtons * | GetCaptionButtons ()
Gets the collection of caption buttons.
virtual HBRUSH | GetClientBrush (CDC *pDC)
Gets the client brush.
- Public Member Functions inherited from CXTPSkinObject
CXTPSkinManager * | GetSkinManager () const
Gets the parent CXTPSkinManager object.
CString | GetClassName () const
Gets own class name.
CXTPSkinManagerClass * | GetSkinClass () const
Gets the CXTPSkinManagerClass object associated with own class name.
CXTPSkinManagerMetrics * | GetMetrics () const
Gets the skin metrics.
COLORREF | GetColor (int nIndex) const
Retrieves the specified system color.
- Public Member Functions inherited from CXTPSynchronized
CXTPRWCriticalSection & | GetAccessCriticalSection () const
Accesses a synchronized object's critical section.

Additional Inherited Members

- Public Types inherited from CXTPSkinObjectFrame
- Public Attributes inherited from CXTPSkinObjectFrame
BOOL | m_bLockFrameDraw
TRUE to lock draw.
DWORD | m_dwDialogTexture
Dialog texture.
- Static Public Attributes inherited from CXTPSkinObject
- Protected Member Functions inherited from CXTPSkinObjectUser32Control
CXTPSkinObjectUser32Control ()
Constructs a CXTPSkinObjectUser32Control object.
virtual void | CheckScrollBarsDraw ()
Determines if the scrollbar position was changed.
- Protected Member Functions inherited from CXTPSkinObjectFrame
virtual void | OnSkinChanged (BOOL bPrevState, BOOL bNewState)
This method is called when the skin is changed.
virtual void | RefreshMetrics ()
This method is called when visual metrics are changed.
virtual void | OnHookAttached (LPCREATESTRUCT lpcs, BOOL bAuto)
This method is called when the hook is attached.
void | OnHookDetached (BOOL bAuto)
This method is called when the hook is detached.
- Protected Member Functions inherited from CXTPSkinObject
CXTPSkinObject ()
Constructs a CXTPSkinObject object.
~CXTPSkinObject ()
Destroys a CXTPSkinObject object, handles cleanup and deallocation.
- Protected Attributes inherited from CXTPSkinObjectFrame
CCaptionButtons | m_arrButtons
Caption buttons.
CRect | m_rcBorders
Frame borders.
CCaptionButton * | m_pButtonHot
Hot caption button.
CCaptionButton * | m_pButtonPressed
Pressed caption button.
BOOL | m_bRegionChanged
TRUE if region was changed.
XTP_SKINSCROLLBAR_TRACKINFO * | m_pSBTrack
Track info of scrollbars.
XTP_SKINSCROLLBAR_POSINFO | m_spi [2]
Scrollbar position info.
CSize | m_szFrameRegion
Previous frame region.
BOOL | m_bMDIClient
TRUE if the frame is a MDI client.
BOOL | m_bActive
TRUE if the caption is active.
DWORD | m_dwStyle
Styles of window.
DWORD | m_dwExStyle
ExStyles of window.
- Protected Attributes inherited from CXTPSkinObject
WNDPROC | m_pOldWndProc
Old window window handler.
CXTPSkinManager * | m_pManager
Parent CXTPSkinManager object.
CString | m_strClassName
Own class name.
BOOL | m_bActiveX
TRUE if ActiveX controls.
BOOL | m_bWindowsForms
TRUE if .NET controls.
- Static Protected Attributes inherited from CXTPSkinObjectFrame

Detailed Description

CXTPSkinObjectListBox is a CXTPSkinObjectUser32Control derived class.

It implements a standard list box control.

The documentation for this class was generated from the following file:
  • XTPSkinObjectListBox.h


Toolkit Pro: CXTPSkinObjectListView Class Reference

Public Member Functions | List of all members
CXTPSkinObjectListView Class Reference

CXTPSkinObjectListView is a CXTPSkinObjectComCtl32Control derived class. More...

Inheritance diagram for CXTPSkinObjectListView:
[legend]

Public Member Functions

CXTPSkinObjectListView ()
Constructs a CXTPSkinObjectListView object.
virtual | ~CXTPSkinObjectListView ()
Destroys a CXTPSkinObjectListView object, handles cleanup and deallocation.
- Public Member Functions inherited from CXTPSkinObjectFrame
CXTPSkinObjectFrame ()
Constructs a CXTPSkinObjectFrame object.
virtual | ~CXTPSkinObjectFrame ()
Destroys a CXTPSkinObjectFrame object, handles cleanup and deallocation.
void | RedrawScrollBar (int nBar)
Redraws the scrollbar of the frame.
CRect | GetBorders () const
Gets the borders of the window.
BOOL | IsActive () const
Determines if the caption is active.
CCaptionButtons * | GetCaptionButtons ()
Gets the collection of caption buttons.
virtual HBRUSH | GetClientBrush (CDC *pDC)
Gets the client brush.
- Public Member Functions inherited from CXTPSkinObject
CXTPSkinManager * | GetSkinManager () const
Gets the parent CXTPSkinManager object.
CString | GetClassName () const
Gets own class name.
CXTPSkinManagerClass * | GetSkinClass () const
Gets the CXTPSkinManagerClass object associated with own class name.
CXTPSkinManagerMetrics * | GetMetrics () const
Gets the skin metrics.
COLORREF | GetColor (int nIndex) const
Retrieves the specified system color.
- Public Member Functions inherited from CXTPSynchronized
CXTPRWCriticalSection & | GetAccessCriticalSection () const
Accesses a synchronized object's critical section.

Additional Inherited Members

- Public Types inherited from CXTPSkinObjectFrame
- Public Attributes inherited from CXTPSkinObjectFrame
BOOL | m_bLockFrameDraw
TRUE to lock draw.
DWORD | m_dwDialogTexture
Dialog texture.
- Static Public Attributes inherited from CXTPSkinObject
- Protected Member Functions inherited from CXTPSkinObjectComCtl32Control
CXTPSkinObjectComCtl32Control ()
Constructs a CXTPSkinObjectComCtl32Control object.
virtual void | CheckScrollBarsDraw ()
Determines if the scrollbar position was changed.
- Protected Member Functions inherited from CXTPSkinObjectUser32Control
CXTPSkinObjectUser32Control ()
Constructs a CXTPSkinObjectUser32Control object.
- Protected Member Functions inherited from CXTPSkinObjectFrame
virtual void | OnSkinChanged (BOOL bPrevState, BOOL bNewState)
This method is called when the skin is changed.
virtual void | RefreshMetrics ()
This method is called when visual metrics are changed.
virtual void | OnHookAttached (LPCREATESTRUCT lpcs, BOOL bAuto)
This method is called when the hook is attached.
void | OnHookDetached (BOOL bAuto)
This method is called when the hook is detached.
- Protected Member Functions inherited from CXTPSkinObject
CXTPSkinObject ()
Constructs a CXTPSkinObject object.
~CXTPSkinObject ()
Destroys a CXTPSkinObject object, handles cleanup and deallocation.
- Protected Attributes inherited from CXTPSkinObjectFrame
CCaptionButtons | m_arrButtons
Caption buttons.
CRect | m_rcBorders
Frame borders.
CCaptionButton * | m_pButtonHot
Hot caption button.
CCaptionButton * | m_pButtonPressed
Pressed caption button.
BOOL | m_bRegionChanged
TRUE if region was changed.
XTP_SKINSCROLLBAR_TRACKINFO * | m_pSBTrack
Track info of scrollbars.
XTP_SKINSCROLLBAR_POSINFO | m_spi [2]
Scrollbar position info.
CSize | m_szFrameRegion
Previous frame region.
BOOL | m_bMDIClient
TRUE if the frame is a MDI client.
BOOL | m_bActive
TRUE if the caption is active.
DWORD | m_dwStyle
Styles of window.
DWORD | m_dwExStyle
ExStyles of window.
- Protected Attributes inherited from CXTPSkinObject
WNDPROC | m_pOldWndProc
Old window window handler.
CXTPSkinManager * | m_pManager
Parent CXTPSkinManager object.
CString | m_strClassName
Own class name.
BOOL | m_bActiveX
TRUE if ActiveX controls.
BOOL | m_bWindowsForms
TRUE if .NET controls.
- Static Protected Attributes inherited from CXTPSkinObjectFrame

Detailed Description

CXTPSkinObjectListView is a CXTPSkinObjectComCtl32Control derived class.

It implements a standard list view control.

The documentation for this class was generated from the following file:
  • XTPSkinObjectListView.h


Toolkit Pro: CXTPSkinObjectMonthCal Class Reference

Public Member Functions | List of all members
CXTPSkinObjectMonthCal Class Reference

CXTPSkinObjectMonthCal is a CXTPSkinObjectFrame derived class. More...

Inheritance diagram for CXTPSkinObjectMonthCal:
[legend]

Public Member Functions

CXTPSkinObjectMonthCal ()
Constructs a CXTPSkinObjectMonthCal object.
void | RefreshMetrics ()
This method is called when visual metrics are changed.
- Public Member Functions inherited from CXTPSkinObjectFrame
CXTPSkinObjectFrame ()
Constructs a CXTPSkinObjectFrame object.
virtual | ~CXTPSkinObjectFrame ()
Destroys a CXTPSkinObjectFrame object, handles cleanup and deallocation.
void | RedrawScrollBar (int nBar)
Redraws the scrollbar of the frame.
CRect | GetBorders () const
Gets the borders of the window.
BOOL | IsActive () const
Determines if the caption is active.
CCaptionButtons * | GetCaptionButtons ()
Gets the collection of caption buttons.
virtual HBRUSH | GetClientBrush (CDC *pDC)
Gets the client brush.
- Public Member Functions inherited from CXTPSkinObject
CXTPSkinManager * | GetSkinManager () const
Gets the parent CXTPSkinManager object.
CString | GetClassName () const
Gets own class name.
CXTPSkinManagerClass * | GetSkinClass () const
Gets the CXTPSkinManagerClass object associated with own class name.
CXTPSkinManagerMetrics * | GetMetrics () const
Gets the skin metrics.
COLORREF | GetColor (int nIndex) const
Retrieves the specified system color.
- Public Member Functions inherited from CXTPSynchronized
CXTPRWCriticalSection & | GetAccessCriticalSection () const
Accesses a synchronized object's critical section.

Additional Inherited Members

- Public Types inherited from CXTPSkinObjectFrame
- Public Attributes inherited from CXTPSkinObjectFrame
BOOL | m_bLockFrameDraw
TRUE to lock draw.
DWORD | m_dwDialogTexture
Dialog texture.
- Static Public Attributes inherited from CXTPSkinObject
- Protected Member Functions inherited from CXTPSkinObjectFrame
virtual void | OnSkinChanged (BOOL bPrevState, BOOL bNewState)
This method is called when the skin is changed.
virtual void | OnHookAttached (LPCREATESTRUCT lpcs, BOOL bAuto)
This method is called when the hook is attached.
void | OnHookDetached (BOOL bAuto)
This method is called when the hook is detached.
- Protected Member Functions inherited from CXTPSkinObject
CXTPSkinObject ()
Constructs a CXTPSkinObject object.
~CXTPSkinObject ()
Destroys a CXTPSkinObject object, handles cleanup and deallocation.
- Protected Attributes inherited from CXTPSkinObjectFrame
CCaptionButtons | m_arrButtons
Caption buttons.
CRect | m_rcBorders
Frame borders.
CCaptionButton * | m_pButtonHot
Hot caption button.
CCaptionButton * | m_pButtonPressed
Pressed caption button.
BOOL | m_bRegionChanged
TRUE if region was changed.
XTP_SKINSCROLLBAR_TRACKINFO * | m_pSBTrack
Track info of scrollbars.
XTP_SKINSCROLLBAR_POSINFO | m_spi [2]
Scrollbar position info.
CSize | m_szFrameRegion
Previous frame region.
BOOL | m_bMDIClient
TRUE if the frame is a MDI client.
BOOL | m_bActive
TRUE if the caption is active.
DWORD | m_dwStyle
Styles of window.
DWORD | m_dwExStyle
ExStyles of window.
- Protected Attributes inherited from CXTPSkinObject
WNDPROC | m_pOldWndProc
Old window window handler.
CXTPSkinManager * | m_pManager
Parent CXTPSkinManager object.
CString | m_strClassName
Own class name.
BOOL | m_bActiveX
TRUE if ActiveX controls.
BOOL | m_bWindowsForms
TRUE if .NET controls.
- Static Protected Attributes inherited from CXTPSkinObjectFrame

Detailed Description

CXTPSkinObjectMonthCal is a CXTPSkinObjectFrame derived class.

It implements a month calendar.

The documentation for this class was generated from the following file:
  • XTPSkinObjectComboBox.h


Toolkit Pro: CXTPSkinObjectProgress Class Reference

Public Member Functions | List of all members
CXTPSkinObjectProgress Class Reference

CXTPSkinObjectProgress is a CXTPSkinObjectFrame derived class. More...

Inheritance diagram for CXTPSkinObjectProgress:
[legend]

Public Member Functions

CXTPSkinObjectProgress ()
Constructs a CXTPSkinObjectProgress object.
virtual | ~CXTPSkinObjectProgress ()
Destroys a CXTPSkinObjectProgress object, handles cleanup and deallocation.
- Public Member Functions inherited from CXTPSkinObjectFrame
CXTPSkinObjectFrame ()
Constructs a CXTPSkinObjectFrame object.
virtual | ~CXTPSkinObjectFrame ()
Destroys a CXTPSkinObjectFrame object, handles cleanup and deallocation.
void | RedrawScrollBar (int nBar)
Redraws the scrollbar of the frame.
CRect | GetBorders () const
Gets the borders of the window.
BOOL | IsActive () const
Determines if the caption is active.
CCaptionButtons * | GetCaptionButtons ()
Gets the collection of caption buttons.
virtual HBRUSH | GetClientBrush (CDC *pDC)
Gets the client brush.
- Public Member Functions inherited from CXTPSkinObject
CXTPSkinManager * | GetSkinManager () const
Gets the parent CXTPSkinManager object.
CString | GetClassName () const
Gets own class name.
CXTPSkinManagerClass * | GetSkinClass () const
Gets the CXTPSkinManagerClass object associated with own class name.
CXTPSkinManagerMetrics * | GetMetrics () const
Gets the skin metrics.
COLORREF | GetColor (int nIndex) const
Retrieves the specified system color.
- Public Member Functions inherited from CXTPSynchronized
CXTPRWCriticalSection & | GetAccessCriticalSection () const
Accesses a synchronized object's critical section.

Additional Inherited Members

- Public Types inherited from CXTPSkinObjectFrame
- Public Attributes inherited from CXTPSkinObjectFrame
BOOL | m_bLockFrameDraw
TRUE to lock draw.
DWORD | m_dwDialogTexture
Dialog texture.
- Static Public Attributes inherited from CXTPSkinObject
- Protected Member Functions inherited from CXTPSkinObjectFrame
virtual void | OnSkinChanged (BOOL bPrevState, BOOL bNewState)
This method is called when the skin is changed.
virtual void | RefreshMetrics ()
This method is called when visual metrics are changed.
virtual void | OnHookAttached (LPCREATESTRUCT lpcs, BOOL bAuto)
This method is called when the hook is attached.
void | OnHookDetached (BOOL bAuto)
This method is called when the hook is detached.
- Protected Member Functions inherited from CXTPSkinObject
CXTPSkinObject ()
Constructs a CXTPSkinObject object.
~CXTPSkinObject ()
Destroys a CXTPSkinObject object, handles cleanup and deallocation.
- Protected Attributes inherited from CXTPSkinObjectFrame
CCaptionButtons | m_arrButtons
Caption buttons.
CRect | m_rcBorders
Frame borders.
CCaptionButton * | m_pButtonHot
Hot caption button.
CCaptionButton * | m_pButtonPressed
Pressed caption button.
BOOL | m_bRegionChanged
TRUE if region was changed.
XTP_SKINSCROLLBAR_TRACKINFO * | m_pSBTrack
Track info of scrollbars.
XTP_SKINSCROLLBAR_POSINFO | m_spi [2]
Scrollbar position info.
CSize | m_szFrameRegion
Previous frame region.
BOOL | m_bMDIClient
TRUE if the frame is a MDI client.
BOOL | m_bActive
TRUE if the caption is active.
DWORD | m_dwStyle
Styles of window.
DWORD | m_dwExStyle
ExStyles of window.
- Protected Attributes inherited from CXTPSkinObject
WNDPROC | m_pOldWndProc
Old window window handler.
CXTPSkinManager * | m_pManager
Parent CXTPSkinManager object.
CString | m_strClassName
Own class name.
BOOL | m_bActiveX
TRUE if ActiveX controls.
BOOL | m_bWindowsForms
TRUE if .NET controls.
- Static Protected Attributes inherited from CXTPSkinObjectFrame

Detailed Description

CXTPSkinObjectProgress is a CXTPSkinObjectFrame derived class.

It implements a standard progress control.

The documentation for this class was generated from the following file:
  • XTPSkinObjectProgress.h


Toolkit Pro: CXTPSkinObjectReBar Class Reference

Public Member Functions | List of all members
CXTPSkinObjectReBar Class Reference

CXTPSkinObjectReBar is a CXTPSkinObjectFrame derived class. More...

Inheritance diagram for CXTPSkinObjectReBar:
[legend]

Public Member Functions

CXTPSkinObjectReBar ()
Constructs a CXTPSkinObjectReBar object.
virtual | ~CXTPSkinObjectReBar ()
Destroys a CXTPSkinObjectReBar object, handles cleanup and deallocation.
- Public Member Functions inherited from CXTPSkinObjectFrame
CXTPSkinObjectFrame ()
Constructs a CXTPSkinObjectFrame object.
virtual | ~CXTPSkinObjectFrame ()
Destroys a CXTPSkinObjectFrame object, handles cleanup and deallocation.
void | RedrawScrollBar (int nBar)
Redraws the scrollbar of the frame.
CRect | GetBorders () const
Gets the borders of the window.
BOOL | IsActive () const
Determines if the caption is active.
CCaptionButtons * | GetCaptionButtons ()
Gets the collection of caption buttons.
virtual HBRUSH | GetClientBrush (CDC *pDC)
Gets the client brush.
- Public Member Functions inherited from CXTPSkinObject
CXTPSkinManager * | GetSkinManager () const
Gets the parent CXTPSkinManager object.
CString | GetClassName () const
Gets own class name.
CXTPSkinManagerClass * | GetSkinClass () const
Gets the CXTPSkinManagerClass object associated with own class name.
CXTPSkinManagerMetrics * | GetMetrics () const
Gets the skin metrics.
COLORREF | GetColor (int nIndex) const
Retrieves the specified system color.
- Public Member Functions inherited from CXTPSynchronized
CXTPRWCriticalSection & | GetAccessCriticalSection () const
Accesses a synchronized object's critical section.

Additional Inherited Members

- Public Types inherited from CXTPSkinObjectFrame
- Public Attributes inherited from CXTPSkinObjectFrame
BOOL | m_bLockFrameDraw
TRUE to lock draw.
DWORD | m_dwDialogTexture
Dialog texture.
- Static Public Attributes inherited from CXTPSkinObject
- Protected Member Functions inherited from CXTPSkinObjectFrame
virtual void | OnSkinChanged (BOOL bPrevState, BOOL bNewState)
This method is called when the skin is changed.
virtual void | RefreshMetrics ()
This method is called when visual metrics are changed.
virtual void | OnHookAttached (LPCREATESTRUCT lpcs, BOOL bAuto)
This method is called when the hook is attached.
void | OnHookDetached (BOOL bAuto)
This method is called when the hook is detached.
- Protected Member Functions inherited from CXTPSkinObject
CXTPSkinObject ()
Constructs a CXTPSkinObject object.
~CXTPSkinObject ()
Destroys a CXTPSkinObject object, handles cleanup and deallocation.
- Protected Attributes inherited from CXTPSkinObjectFrame
CCaptionButtons | m_arrButtons
Caption buttons.
CRect | m_rcBorders
Frame borders.
CCaptionButton * | m_pButtonHot
Hot caption button.
CCaptionButton * | m_pButtonPressed
Pressed caption button.
BOOL | m_bRegionChanged
TRUE if region was changed.
XTP_SKINSCROLLBAR_TRACKINFO * | m_pSBTrack
Track info of scrollbars.
XTP_SKINSCROLLBAR_POSINFO | m_spi [2]
Scrollbar position info.
CSize | m_szFrameRegion
Previous frame region.
BOOL | m_bMDIClient
TRUE if the frame is a MDI client.
BOOL | m_bActive
TRUE if the caption is active.
DWORD | m_dwStyle
Styles of window.
DWORD | m_dwExStyle
ExStyles of window.
- Protected Attributes inherited from CXTPSkinObject
WNDPROC | m_pOldWndProc
Old window window handler.
CXTPSkinManager * | m_pManager
Parent CXTPSkinManager object.
CString | m_strClassName
Own class name.
BOOL | m_bActiveX
TRUE if ActiveX controls.
BOOL | m_bWindowsForms
TRUE if .NET controls.
- Static Protected Attributes inherited from CXTPSkinObjectFrame

Detailed Description

CXTPSkinObjectReBar is a CXTPSkinObjectFrame derived class.

It implements a standard ReBar control.

The documentation for this class was generated from the following file:
  • XTPSkinObjectReBar.h


Toolkit Pro: CXTPSkinObjectScrollBar Class Reference

Public Member Functions | List of all members
CXTPSkinObjectScrollBar Class Reference

CXTPSkinObjectScrollBar is a CXTPSkinObjectFrame derived class. More...

Inheritance diagram for CXTPSkinObjectScrollBar:
[legend]

Public Member Functions

CXTPSkinObjectScrollBar ()
Constructs a CXTPSkinObjectScrollBar object.
virtual | ~CXTPSkinObjectScrollBar ()
Destroys a CXTPSkinObjectScrollBar object, handles cleanup and deallocation.
- Public Member Functions inherited from CXTPSkinObjectFrame
CXTPSkinObjectFrame ()
Constructs a CXTPSkinObjectFrame object.
virtual | ~CXTPSkinObjectFrame ()
Destroys a CXTPSkinObjectFrame object, handles cleanup and deallocation.
void | RedrawScrollBar (int nBar)
Redraws the scrollbar of the frame.
CRect | GetBorders () const
Gets the borders of the window.
BOOL | IsActive () const
Determines if the caption is active.
CCaptionButtons * | GetCaptionButtons ()
Gets the collection of caption buttons.
virtual HBRUSH | GetClientBrush (CDC *pDC)
Gets the client brush.
- Public Member Functions inherited from CXTPSkinObject
CXTPSkinManager * | GetSkinManager () const
Gets the parent CXTPSkinManager object.
CString | GetClassName () const
Gets own class name.
CXTPSkinManagerClass * | GetSkinClass () const
Gets the CXTPSkinManagerClass object associated with own class name.
CXTPSkinManagerMetrics * | GetMetrics () const
Gets the skin metrics.
COLORREF | GetColor (int nIndex) const
Retrieves the specified system color.
- Public Member Functions inherited from CXTPSynchronized
CXTPRWCriticalSection & | GetAccessCriticalSection () const
Accesses a synchronized object's critical section.

Additional Inherited Members

- Public Types inherited from CXTPSkinObjectFrame
- Public Attributes inherited from CXTPSkinObjectFrame
BOOL | m_bLockFrameDraw
TRUE to lock draw.
DWORD | m_dwDialogTexture
Dialog texture.
- Static Public Attributes inherited from CXTPSkinObject
- Protected Member Functions inherited from CXTPSkinObjectFrame
virtual void | OnSkinChanged (BOOL bPrevState, BOOL bNewState)
This method is called when the skin is changed.
virtual void | RefreshMetrics ()
This method is called when visual metrics are changed.
virtual void | OnHookAttached (LPCREATESTRUCT lpcs, BOOL bAuto)
This method is called when the hook is attached.
void | OnHookDetached (BOOL bAuto)
This method is called when the hook is detached.
- Protected Member Functions inherited from CXTPSkinObject
CXTPSkinObject ()
Constructs a CXTPSkinObject object.
~CXTPSkinObject ()
Destroys a CXTPSkinObject object, handles cleanup and deallocation.
- Protected Attributes inherited from CXTPSkinObjectFrame
CCaptionButtons | m_arrButtons
Caption buttons.
CRect | m_rcBorders
Frame borders.
CCaptionButton * | m_pButtonHot
Hot caption button.
CCaptionButton * | m_pButtonPressed
Pressed caption button.
BOOL | m_bRegionChanged
TRUE if region was changed.
XTP_SKINSCROLLBAR_TRACKINFO * | m_pSBTrack
Track info of scrollbars.
XTP_SKINSCROLLBAR_POSINFO | m_spi [2]
Scrollbar position info.
CSize | m_szFrameRegion
Previous frame region.
BOOL | m_bMDIClient
TRUE if the frame is a MDI client.
BOOL | m_bActive
TRUE if the caption is active.
DWORD | m_dwStyle
Styles of window.
DWORD | m_dwExStyle
ExStyles of window.
- Protected Attributes inherited from CXTPSkinObject
WNDPROC | m_pOldWndProc
Old window window handler.
CXTPSkinManager * | m_pManager
Parent CXTPSkinManager object.
CString | m_strClassName
Own class name.
BOOL | m_bActiveX
TRUE if ActiveX controls.
BOOL | m_bWindowsForms
TRUE if .NET controls.
- Static Protected Attributes inherited from CXTPSkinObjectFrame

Detailed Description

CXTPSkinObjectScrollBar is a CXTPSkinObjectFrame derived class.

It implements a standard scrollbar control.

The documentation for this class was generated from the following file:
  • XTPSkinObjectScrollBar.h


Toolkit Pro: CXTPSkinObjectSolidFilled Class Reference

Public Member Functions | List of all members
CXTPSkinObjectSolidFilled Class Reference

CXTPSkinObjectSolidFilled is a CXTPSkinObjectFrame derived class. More...

Inheritance diagram for CXTPSkinObjectSolidFilled:
[legend]

Public Member Functions

CXTPSkinObjectSolidFilled (COLORREF crFill)
Constructs a CXTPSkinObjectSolidFilled object.
CXTPSkinObjectSolidFilled (HBRUSH hbrFill)
Constructs a CXTPSkinObjectSolidFilled object.
- Public Member Functions inherited from CXTPSkinObjectFrame
CXTPSkinObjectFrame ()
Constructs a CXTPSkinObjectFrame object.
virtual | ~CXTPSkinObjectFrame ()
Destroys a CXTPSkinObjectFrame object, handles cleanup and deallocation.
void | RedrawScrollBar (int nBar)
Redraws the scrollbar of the frame.
CRect | GetBorders () const
Gets the borders of the window.
BOOL | IsActive () const
Determines if the caption is active.
CCaptionButtons * | GetCaptionButtons ()
Gets the collection of caption buttons.
virtual HBRUSH | GetClientBrush (CDC *pDC)
Gets the client brush.
- Public Member Functions inherited from CXTPSkinObject
CXTPSkinManager * | GetSkinManager () const
Gets the parent CXTPSkinManager object.
CString | GetClassName () const
Gets own class name.
CXTPSkinManagerClass * | GetSkinClass () const
Gets the CXTPSkinManagerClass object associated with own class name.
CXTPSkinManagerMetrics * | GetMetrics () const
Gets the skin metrics.
COLORREF | GetColor (int nIndex) const
Retrieves the specified system color.
- Public Member Functions inherited from CXTPSynchronized
CXTPRWCriticalSection & | GetAccessCriticalSection () const
Accesses a synchronized object's critical section.

Additional Inherited Members

- Public Types inherited from CXTPSkinObjectFrame
- Public Attributes inherited from CXTPSkinObjectFrame
BOOL | m_bLockFrameDraw
TRUE to lock draw.
DWORD | m_dwDialogTexture
Dialog texture.
- Static Public Attributes inherited from CXTPSkinObject
- Protected Member Functions inherited from CXTPSkinObjectFrame
virtual void | OnSkinChanged (BOOL bPrevState, BOOL bNewState)
This method is called when the skin is changed.
virtual void | RefreshMetrics ()
This method is called when visual metrics are changed.
virtual void | OnHookAttached (LPCREATESTRUCT lpcs, BOOL bAuto)
This method is called when the hook is attached.
void | OnHookDetached (BOOL bAuto)
This method is called when the hook is detached.
- Protected Member Functions inherited from CXTPSkinObject
CXTPSkinObject ()
Constructs a CXTPSkinObject object.
~CXTPSkinObject ()
Destroys a CXTPSkinObject object, handles cleanup and deallocation.
- Protected Attributes inherited from CXTPSkinObjectFrame
CCaptionButtons | m_arrButtons
Caption buttons.
CRect | m_rcBorders
Frame borders.
CCaptionButton * | m_pButtonHot
Hot caption button.
CCaptionButton * | m_pButtonPressed
Pressed caption button.
BOOL | m_bRegionChanged
TRUE if region was changed.
XTP_SKINSCROLLBAR_TRACKINFO * | m_pSBTrack
Track info of scrollbars.
XTP_SKINSCROLLBAR_POSINFO | m_spi [2]
Scrollbar position info.
CSize | m_szFrameRegion
Previous frame region.
BOOL | m_bMDIClient
TRUE if the frame is a MDI client.
BOOL | m_bActive
TRUE if the caption is active.
DWORD | m_dwStyle
Styles of window.
DWORD | m_dwExStyle
ExStyles of window.
- Protected Attributes inherited from CXTPSkinObject
WNDPROC | m_pOldWndProc
Old window window handler.
CXTPSkinManager * | m_pManager
Parent CXTPSkinManager object.
CString | m_strClassName
Own class name.
BOOL | m_bActiveX
TRUE if ActiveX controls.
BOOL | m_bWindowsForms
TRUE if .NET controls.
- Static Protected Attributes inherited from CXTPSkinObjectFrame

Detailed Description

CXTPSkinObjectSolidFilled is a CXTPSkinObjectFrame derived class.

It is a helper class for unknown window classes that must be filled with a solid color or brush.

Constructor & Destructor Documentation

◆ CXTPSkinObjectSolidFilled() [1/2]

CXTPSkinObjectSolidFilled ( COLORREF crFill )
explicit

Constructs a CXTPSkinObjectSolidFilled object.

Parameters
crFill Color to fill the window background with.

◆ CXTPSkinObjectSolidFilled() [2/2]

CXTPSkinObjectSolidFilled ( HBRUSH hbrFill )
explicit

Constructs a CXTPSkinObjectSolidFilled object.

Parameters
hbrFill Handle of a brush to fill the window background with.
The documentation for this class was generated from the following file:
  • XTPSkinObjectFrame.h


Toolkit Pro: CXTPSkinObjectSpin Class Reference

Public Member Functions | List of all members
CXTPSkinObjectSpin Class Reference

CXTPSkinObjectSpin is a CXTPSkinObjectFrame derived class. More...

Inheritance diagram for CXTPSkinObjectSpin:
[legend]

Public Member Functions

CXTPSkinObjectSpin ()
Constructs a CXTPSkinObjectSpin object.
virtual | ~CXTPSkinObjectSpin ()
Destroys a CXTPSkinObjectSpin object, handles cleanup and deallocation.
- Public Member Functions inherited from CXTPSkinObjectFrame
CXTPSkinObjectFrame ()
Constructs a CXTPSkinObjectFrame object.
virtual | ~CXTPSkinObjectFrame ()
Destroys a CXTPSkinObjectFrame object, handles cleanup and deallocation.
void | RedrawScrollBar (int nBar)
Redraws the scrollbar of the frame.
CRect | GetBorders () const
Gets the borders of the window.
BOOL | IsActive () const
Determines if the caption is active.
CCaptionButtons * | GetCaptionButtons ()
Gets the collection of caption buttons.
virtual HBRUSH | GetClientBrush (CDC *pDC)
Gets the client brush.
- Public Member Functions inherited from CXTPSkinObject
CXTPSkinManager * | GetSkinManager () const
Gets the parent CXTPSkinManager object.
CString | GetClassName () const
Gets own class name.
CXTPSkinManagerClass * | GetSkinClass () const
Gets the CXTPSkinManagerClass object associated with own class name.
CXTPSkinManagerMetrics * | GetMetrics () const
Gets the skin metrics.
COLORREF | GetColor (int nIndex) const
Retrieves the specified system color.
- Public Member Functions inherited from CXTPSynchronized
CXTPRWCriticalSection & | GetAccessCriticalSection () const
Accesses a synchronized object's critical section.

Additional Inherited Members

- Public Types inherited from CXTPSkinObjectFrame
- Public Attributes inherited from CXTPSkinObjectFrame
BOOL | m_bLockFrameDraw
TRUE to lock draw.
DWORD | m_dwDialogTexture
Dialog texture.
- Static Public Attributes inherited from CXTPSkinObject
- Protected Member Functions inherited from CXTPSkinObjectFrame
virtual void | OnSkinChanged (BOOL bPrevState, BOOL bNewState)
This method is called when the skin is changed.
virtual void | RefreshMetrics ()
This method is called when visual metrics are changed.
virtual void | OnHookAttached (LPCREATESTRUCT lpcs, BOOL bAuto)
This method is called when the hook is attached.
void | OnHookDetached (BOOL bAuto)
This method is called when the hook is detached.
- Protected Member Functions inherited from CXTPSkinObject
CXTPSkinObject ()
Constructs a CXTPSkinObject object.
~CXTPSkinObject ()
Destroys a CXTPSkinObject object, handles cleanup and deallocation.
- Protected Attributes inherited from CXTPSkinObjectFrame
CCaptionButtons | m_arrButtons
Caption buttons.
CRect | m_rcBorders
Frame borders.
CCaptionButton * | m_pButtonHot
Hot caption button.
CCaptionButton * | m_pButtonPressed
Pressed caption button.
BOOL | m_bRegionChanged
TRUE if region was changed.
XTP_SKINSCROLLBAR_TRACKINFO * | m_pSBTrack
Track info of scrollbars.
XTP_SKINSCROLLBAR_POSINFO | m_spi [2]
Scrollbar position info.
CSize | m_szFrameRegion
Previous frame region.
BOOL | m_bMDIClient
TRUE if the frame is a MDI client.
BOOL | m_bActive
TRUE if the caption is active.
DWORD | m_dwStyle
Styles of window.
DWORD | m_dwExStyle
ExStyles of window.
- Protected Attributes inherited from CXTPSkinObject
WNDPROC | m_pOldWndProc
Old window window handler.
CXTPSkinManager * | m_pManager
Parent CXTPSkinManager object.
CString | m_strClassName
Own class name.
BOOL | m_bActiveX
TRUE if ActiveX controls.
BOOL | m_bWindowsForms
TRUE if .NET controls.
- Static Protected Attributes inherited from CXTPSkinObjectFrame

Detailed Description

CXTPSkinObjectSpin is a CXTPSkinObjectFrame derived class.

It implements a standard spin control.

The documentation for this class was generated from the following file:
  • XTPSkinObjectSpin.h


Toolkit Pro: CXTPSkinObjectStatusBar Class Reference

Public Member Functions | List of all members
CXTPSkinObjectStatusBar Class Reference

CXTPSkinObjectStatusBar is a CXTPSkinObjectFrame derived class. More...

Inheritance diagram for CXTPSkinObjectStatusBar:
[legend]

Public Member Functions

CXTPSkinObjectStatusBar ()
Constructs a CXTPSkinObjectStatusBar object.
virtual | ~CXTPSkinObjectStatusBar ()
Destroys a CXTPSkinObjectStatusBar object, handles cleanup and deallocation.
- Public Member Functions inherited from CXTPSkinObjectFrame
CXTPSkinObjectFrame ()
Constructs a CXTPSkinObjectFrame object.
virtual | ~CXTPSkinObjectFrame ()
Destroys a CXTPSkinObjectFrame object, handles cleanup and deallocation.
void | RedrawScrollBar (int nBar)
Redraws the scrollbar of the frame.
CRect | GetBorders () const
Gets the borders of the window.
BOOL | IsActive () const
Determines if the caption is active.
CCaptionButtons * | GetCaptionButtons ()
Gets the collection of caption buttons.
virtual HBRUSH | GetClientBrush (CDC *pDC)
Gets the client brush.
- Public Member Functions inherited from CXTPSkinObject
CXTPSkinManager * | GetSkinManager () const
Gets the parent CXTPSkinManager object.
CString | GetClassName () const
Gets own class name.
CXTPSkinManagerClass * | GetSkinClass () const
Gets the CXTPSkinManagerClass object associated with own class name.
CXTPSkinManagerMetrics * | GetMetrics () const
Gets the skin metrics.
COLORREF | GetColor (int nIndex) const
Retrieves the specified system color.
- Public Member Functions inherited from CXTPSynchronized
CXTPRWCriticalSection & | GetAccessCriticalSection () const
Accesses a synchronized object's critical section.

Additional Inherited Members

- Public Types inherited from CXTPSkinObjectFrame
- Public Attributes inherited from CXTPSkinObjectFrame
BOOL | m_bLockFrameDraw
TRUE to lock draw.
DWORD | m_dwDialogTexture
Dialog texture.
- Static Public Attributes inherited from CXTPSkinObject
- Protected Member Functions inherited from CXTPSkinObjectFrame
virtual void | OnSkinChanged (BOOL bPrevState, BOOL bNewState)
This method is called when the skin is changed.
virtual void | RefreshMetrics ()
This method is called when visual metrics are changed.
virtual void | OnHookAttached (LPCREATESTRUCT lpcs, BOOL bAuto)
This method is called when the hook is attached.
void | OnHookDetached (BOOL bAuto)
This method is called when the hook is detached.
- Protected Member Functions inherited from CXTPSkinObject
CXTPSkinObject ()
Constructs a CXTPSkinObject object.
~CXTPSkinObject ()
Destroys a CXTPSkinObject object, handles cleanup and deallocation.
- Protected Attributes inherited from CXTPSkinObjectFrame
CCaptionButtons | m_arrButtons
Caption buttons.
CRect | m_rcBorders
Frame borders.
CCaptionButton * | m_pButtonHot
Hot caption button.
CCaptionButton * | m_pButtonPressed
Pressed caption button.
BOOL | m_bRegionChanged
TRUE if region was changed.
XTP_SKINSCROLLBAR_TRACKINFO * | m_pSBTrack
Track info of scrollbars.
XTP_SKINSCROLLBAR_POSINFO | m_spi [2]
Scrollbar position info.
CSize | m_szFrameRegion
Previous frame region.
BOOL | m_bMDIClient
TRUE if the frame is a MDI client.
BOOL | m_bActive
TRUE if the caption is active.
DWORD | m_dwStyle
Styles of window.
DWORD | m_dwExStyle
ExStyles of window.
- Protected Attributes inherited from CXTPSkinObject
WNDPROC | m_pOldWndProc
Old window window handler.
CXTPSkinManager * | m_pManager
Parent CXTPSkinManager object.
CString | m_strClassName
Own class name.
BOOL | m_bActiveX
TRUE if ActiveX controls.
BOOL | m_bWindowsForms
TRUE if .NET controls.
- Static Protected Attributes inherited from CXTPSkinObjectFrame

Detailed Description

CXTPSkinObjectStatusBar is a CXTPSkinObjectFrame derived class.

It implements a standard status bar control.

The documentation for this class was generated from the following file:
  • XTPSkinObjectStatusBar.h


Toolkit Pro: CXTPSkinObjectTab Class Reference

Public Member Functions | List of all members
CXTPSkinObjectTab Class Reference

CXTPSkinObjectTab is a CXTPSkinObjectFrame derived class. More...

Inheritance diagram for CXTPSkinObjectTab:
[legend]

Public Member Functions

CXTPSkinObjectTab ()
Constructs a CXTPSkinObjectTab object.
virtual | ~CXTPSkinObjectTab ()
Destroys a CXTPSkinObjectTab object, handles cleanup and deallocation.
- Public Member Functions inherited from CXTPSkinObjectFrame
CXTPSkinObjectFrame ()
Constructs a CXTPSkinObjectFrame object.
virtual | ~CXTPSkinObjectFrame ()
Destroys a CXTPSkinObjectFrame object, handles cleanup and deallocation.
void | RedrawScrollBar (int nBar)
Redraws the scrollbar of the frame.
CRect | GetBorders () const
Gets the borders of the window.
BOOL | IsActive () const
Determines if the caption is active.
CCaptionButtons * | GetCaptionButtons ()
Gets the collection of caption buttons.
virtual HBRUSH | GetClientBrush (CDC *pDC)
Gets the client brush.
- Public Member Functions inherited from CXTPSkinObject
CXTPSkinManager * | GetSkinManager () const
Gets the parent CXTPSkinManager object.
CString | GetClassName () const
Gets own class name.
CXTPSkinManagerClass * | GetSkinClass () const
Gets the CXTPSkinManagerClass object associated with own class name.
CXTPSkinManagerMetrics * | GetMetrics () const
Gets the skin metrics.
COLORREF | GetColor (int nIndex) const
Retrieves the specified system color.
- Public Member Functions inherited from CXTPSynchronized
CXTPRWCriticalSection & | GetAccessCriticalSection () const
Accesses a synchronized object's critical section.

Additional Inherited Members

- Public Types inherited from CXTPSkinObjectFrame
- Public Attributes inherited from CXTPSkinObjectFrame
BOOL | m_bLockFrameDraw
TRUE to lock draw.
DWORD | m_dwDialogTexture
Dialog texture.
- Static Public Attributes inherited from CXTPSkinObject
- Protected Member Functions inherited from CXTPSkinObjectFrame
virtual void | OnSkinChanged (BOOL bPrevState, BOOL bNewState)
This method is called when the skin is changed.
virtual void | RefreshMetrics ()
This method is called when visual metrics are changed.
virtual void | OnHookAttached (LPCREATESTRUCT lpcs, BOOL bAuto)
This method is called when the hook is attached.
void | OnHookDetached (BOOL bAuto)
This method is called when the hook is detached.
- Protected Member Functions inherited from CXTPSkinObject
CXTPSkinObject ()
Constructs a CXTPSkinObject object.
~CXTPSkinObject ()
Destroys a CXTPSkinObject object, handles cleanup and deallocation.
- Protected Attributes inherited from CXTPSkinObjectFrame
CCaptionButtons | m_arrButtons
Caption buttons.
CRect | m_rcBorders
Frame borders.
CCaptionButton * | m_pButtonHot
Hot caption button.
CCaptionButton * | m_pButtonPressed
Pressed caption button.
BOOL | m_bRegionChanged
TRUE if region was changed.
XTP_SKINSCROLLBAR_TRACKINFO * | m_pSBTrack
Track info of scrollbars.
XTP_SKINSCROLLBAR_POSINFO | m_spi [2]
Scrollbar position info.
CSize | m_szFrameRegion
Previous frame region.
BOOL | m_bMDIClient
TRUE if the frame is a MDI client.
BOOL | m_bActive
TRUE if the caption is active.
DWORD | m_dwStyle
Styles of window.
DWORD | m_dwExStyle
ExStyles of window.
- Protected Attributes inherited from CXTPSkinObject
WNDPROC | m_pOldWndProc
Old window window handler.
CXTPSkinManager * | m_pManager
Parent CXTPSkinManager object.
CString | m_strClassName
Own class name.
BOOL | m_bActiveX
TRUE if ActiveX controls.
BOOL | m_bWindowsForms
TRUE if .NET controls.
- Static Protected Attributes inherited from CXTPSkinObjectFrame

Detailed Description

CXTPSkinObjectTab is a CXTPSkinObjectFrame derived class.

It implements a standard tab control.

The documentation for this class was generated from the following file:
  • XTPSkinObjectTab.h


Toolkit Pro: CXTPSkinObjectToolBar Class Reference

Public Member Functions | List of all members
CXTPSkinObjectToolBar Class Reference

CXTPSkinObjectToolBar is a CXTPSkinObjectFrame derived class. More...

Inheritance diagram for CXTPSkinObjectToolBar:
[legend]

Public Member Functions

CXTPSkinObjectToolBar ()
Constructs a CXTPSkinObjectToolBar object.
virtual | ~CXTPSkinObjectToolBar ()
Destroys a CXTPSkinObjectToolBar object, handles cleanup and deallocation.
- Public Member Functions inherited from CXTPSkinObjectFrame
CXTPSkinObjectFrame ()
Constructs a CXTPSkinObjectFrame object.
virtual | ~CXTPSkinObjectFrame ()
Destroys a CXTPSkinObjectFrame object, handles cleanup and deallocation.
void | RedrawScrollBar (int nBar)
Redraws the scrollbar of the frame.
CRect | GetBorders () const
Gets the borders of the window.
BOOL | IsActive () const
Determines if the caption is active.
CCaptionButtons * | GetCaptionButtons ()
Gets the collection of caption buttons.
virtual HBRUSH | GetClientBrush (CDC *pDC)
Gets the client brush.
- Public Member Functions inherited from CXTPSkinObject
CXTPSkinManager * | GetSkinManager () const
Gets the parent CXTPSkinManager object.
CString | GetClassName () const
Gets own class name.
CXTPSkinManagerClass * | GetSkinClass () const
Gets the CXTPSkinManagerClass object associated with own class name.
CXTPSkinManagerMetrics * | GetMetrics () const
Gets the skin metrics.
COLORREF | GetColor (int nIndex) const
Retrieves the specified system color.
- Public Member Functions inherited from CXTPSynchronized
CXTPRWCriticalSection & | GetAccessCriticalSection () const
Accesses a synchronized object's critical section.

Additional Inherited Members

- Public Types inherited from CXTPSkinObjectFrame
- Public Attributes inherited from CXTPSkinObjectFrame
BOOL | m_bLockFrameDraw
TRUE to lock draw.
DWORD | m_dwDialogTexture
Dialog texture.
- Static Public Attributes inherited from CXTPSkinObject
- Protected Member Functions inherited from CXTPSkinObjectFrame
virtual void | OnSkinChanged (BOOL bPrevState, BOOL bNewState)
This method is called when the skin is changed.
virtual void | RefreshMetrics ()
This method is called when visual metrics are changed.
virtual void | OnHookAttached (LPCREATESTRUCT lpcs, BOOL bAuto)
This method is called when the hook is attached.
void | OnHookDetached (BOOL bAuto)
This method is called when the hook is detached.
- Protected Member Functions inherited from CXTPSkinObject
CXTPSkinObject ()
Constructs a CXTPSkinObject object.
~CXTPSkinObject ()
Destroys a CXTPSkinObject object, handles cleanup and deallocation.
- Protected Attributes inherited from CXTPSkinObjectFrame
CCaptionButtons | m_arrButtons
Caption buttons.
CRect | m_rcBorders
Frame borders.
CCaptionButton * | m_pButtonHot
Hot caption button.
CCaptionButton * | m_pButtonPressed
Pressed caption button.
BOOL | m_bRegionChanged
TRUE if region was changed.
XTP_SKINSCROLLBAR_TRACKINFO * | m_pSBTrack
Track info of scrollbars.
XTP_SKINSCROLLBAR_POSINFO | m_spi [2]
Scrollbar position info.
CSize | m_szFrameRegion
Previous frame region.
BOOL | m_bMDIClient
TRUE if the frame is a MDI client.
BOOL | m_bActive
TRUE if the caption is active.
DWORD | m_dwStyle
Styles of window.
DWORD | m_dwExStyle
ExStyles of window.
- Protected Attributes inherited from CXTPSkinObject
WNDPROC | m_pOldWndProc
Old window window handler.
CXTPSkinManager * | m_pManager
Parent CXTPSkinManager object.
CString | m_strClassName
Own class name.
BOOL | m_bActiveX
TRUE if ActiveX controls.
BOOL | m_bWindowsForms
TRUE if .NET controls.
- Static Protected Attributes inherited from CXTPSkinObjectFrame

Detailed Description

CXTPSkinObjectToolBar is a CXTPSkinObjectFrame derived class.

It implements a standard toolbar control.

The documentation for this class was generated from the following file:
  • XTPSkinObjectToolBar.h


Toolkit Pro: CXTPSkinObjectTrackBar Class Reference

Public Member Functions | List of all members
CXTPSkinObjectTrackBar Class Reference

CXTPSkinObjectTrackBar is a CXTPSkinObjectFrame derived class. More...

Inheritance diagram for CXTPSkinObjectTrackBar:
[legend]

Public Member Functions

CXTPSkinObjectTrackBar ()
Constructs a CXTPSkinObjectTrackBar object.
virtual | ~CXTPSkinObjectTrackBar ()
Destroys a CXTPSkinObjectTrackBar object, handles cleanup and deallocation.
- Public Member Functions inherited from CXTPSkinObjectFrame
CXTPSkinObjectFrame ()
Constructs a CXTPSkinObjectFrame object.
virtual | ~CXTPSkinObjectFrame ()
Destroys a CXTPSkinObjectFrame object, handles cleanup and deallocation.
void | RedrawScrollBar (int nBar)
Redraws the scrollbar of the frame.
CRect | GetBorders () const
Gets the borders of the window.
BOOL | IsActive () const
Determines if the caption is active.
CCaptionButtons * | GetCaptionButtons ()
Gets the collection of caption buttons.
virtual HBRUSH | GetClientBrush (CDC *pDC)
Gets the client brush.
- Public Member Functions inherited from CXTPSkinObject
CXTPSkinManager * | GetSkinManager () const
Gets the parent CXTPSkinManager object.
CString | GetClassName () const
Gets own class name.
CXTPSkinManagerClass * | GetSkinClass () const
Gets the CXTPSkinManagerClass object associated with own class name.
CXTPSkinManagerMetrics * | GetMetrics () const
Gets the skin metrics.
COLORREF | GetColor (int nIndex) const
Retrieves the specified system color.
- Public Member Functions inherited from CXTPSynchronized
CXTPRWCriticalSection & | GetAccessCriticalSection () const
Accesses a synchronized object's critical section.

Additional Inherited Members

- Public Types inherited from CXTPSkinObjectFrame
- Public Attributes inherited from CXTPSkinObjectFrame
BOOL | m_bLockFrameDraw
TRUE to lock draw.
DWORD | m_dwDialogTexture
Dialog texture.
- Static Public Attributes inherited from CXTPSkinObject
- Protected Member Functions inherited from CXTPSkinObjectFrame
virtual void | OnSkinChanged (BOOL bPrevState, BOOL bNewState)
This method is called when the skin is changed.
virtual void | RefreshMetrics ()
This method is called when visual metrics are changed.
virtual void | OnHookAttached (LPCREATESTRUCT lpcs, BOOL bAuto)
This method is called when the hook is attached.
void | OnHookDetached (BOOL bAuto)
This method is called when the hook is detached.
- Protected Member Functions inherited from CXTPSkinObject
CXTPSkinObject ()
Constructs a CXTPSkinObject object.
~CXTPSkinObject ()
Destroys a CXTPSkinObject object, handles cleanup and deallocation.
- Protected Attributes inherited from CXTPSkinObjectFrame
CCaptionButtons | m_arrButtons
Caption buttons.
CRect | m_rcBorders
Frame borders.
CCaptionButton * | m_pButtonHot
Hot caption button.
CCaptionButton * | m_pButtonPressed
Pressed caption button.
BOOL | m_bRegionChanged
TRUE if region was changed.
XTP_SKINSCROLLBAR_TRACKINFO * | m_pSBTrack
Track info of scrollbars.
XTP_SKINSCROLLBAR_POSINFO | m_spi [2]
Scrollbar position info.
CSize | m_szFrameRegion
Previous frame region.
BOOL | m_bMDIClient
TRUE if the frame is a MDI client.
BOOL | m_bActive
TRUE if the caption is active.
DWORD | m_dwStyle
Styles of window.
DWORD | m_dwExStyle
ExStyles of window.
- Protected Attributes inherited from CXTPSkinObject
WNDPROC | m_pOldWndProc
Old window window handler.
CXTPSkinManager * | m_pManager
Parent CXTPSkinManager object.
CString | m_strClassName
Own class name.
BOOL | m_bActiveX
TRUE if ActiveX controls.
BOOL | m_bWindowsForms
TRUE if .NET controls.
- Static Protected Attributes inherited from CXTPSkinObjectFrame

Detailed Description

CXTPSkinObjectTrackBar is a CXTPSkinObjectFrame derived class.

It implements a standard track bar control.

The documentation for this class was generated from the following file:
  • XTPSkinObjectTrackBar.h


Toolkit Pro: CXTPSkinObjectTreeView Class Reference

Public Member Functions | List of all members
CXTPSkinObjectTreeView Class Reference

CXTPSkinObjectTreeView is a CXTPSkinObjectComCtl32Control derived class. More...

Inheritance diagram for CXTPSkinObjectTreeView:
[legend]

Public Member Functions

CXTPSkinObjectTreeView ()
Constructs a CXTPSkinObjectTreeView object.
virtual | ~CXTPSkinObjectTreeView ()
Destroys a CXTPSkinObjectTreeView object, handles cleanup and deallocation.
- Public Member Functions inherited from CXTPSkinObjectFrame
CXTPSkinObjectFrame ()
Constructs a CXTPSkinObjectFrame object.
virtual | ~CXTPSkinObjectFrame ()
Destroys a CXTPSkinObjectFrame object, handles cleanup and deallocation.
void | RedrawScrollBar (int nBar)
Redraws the scrollbar of the frame.
CRect | GetBorders () const
Gets the borders of the window.
BOOL | IsActive () const
Determines if the caption is active.
CCaptionButtons * | GetCaptionButtons ()
Gets the collection of caption buttons.
virtual HBRUSH | GetClientBrush (CDC *pDC)
Gets the client brush.
- Public Member Functions inherited from CXTPSkinObject
CXTPSkinManager * | GetSkinManager () const
Gets the parent CXTPSkinManager object.
CString | GetClassName () const
Gets own class name.
CXTPSkinManagerClass * | GetSkinClass () const
Gets the CXTPSkinManagerClass object associated with own class name.
CXTPSkinManagerMetrics * | GetMetrics () const
Gets the skin metrics.
COLORREF | GetColor (int nIndex) const
Retrieves the specified system color.
- Public Member Functions inherited from CXTPSynchronized
CXTPRWCriticalSection & | GetAccessCriticalSection () const
Accesses a synchronized object's critical section.

Additional Inherited Members

- Public Types inherited from CXTPSkinObjectFrame
- Public Attributes inherited from CXTPSkinObjectFrame
BOOL | m_bLockFrameDraw
TRUE to lock draw.
DWORD | m_dwDialogTexture
Dialog texture.
- Static Public Attributes inherited from CXTPSkinObject
- Protected Member Functions inherited from CXTPSkinObjectComCtl32Control
CXTPSkinObjectComCtl32Control ()
Constructs a CXTPSkinObjectComCtl32Control object.
virtual void | CheckScrollBarsDraw ()
Determines if the scrollbar position was changed.
- Protected Member Functions inherited from CXTPSkinObjectUser32Control
CXTPSkinObjectUser32Control ()
Constructs a CXTPSkinObjectUser32Control object.
- Protected Member Functions inherited from CXTPSkinObjectFrame
virtual void | OnSkinChanged (BOOL bPrevState, BOOL bNewState)
This method is called when the skin is changed.
virtual void | RefreshMetrics ()
This method is called when visual metrics are changed.
virtual void | OnHookAttached (LPCREATESTRUCT lpcs, BOOL bAuto)
This method is called when the hook is attached.
void | OnHookDetached (BOOL bAuto)
This method is called when the hook is detached.
- Protected Member Functions inherited from CXTPSkinObject
CXTPSkinObject ()
Constructs a CXTPSkinObject object.
~CXTPSkinObject ()
Destroys a CXTPSkinObject object, handles cleanup and deallocation.
- Protected Attributes inherited from CXTPSkinObjectFrame
CCaptionButtons | m_arrButtons
Caption buttons.
CRect | m_rcBorders
Frame borders.
CCaptionButton * | m_pButtonHot
Hot caption button.
CCaptionButton * | m_pButtonPressed
Pressed caption button.
BOOL | m_bRegionChanged
TRUE if region was changed.
XTP_SKINSCROLLBAR_TRACKINFO * | m_pSBTrack
Track info of scrollbars.
XTP_SKINSCROLLBAR_POSINFO | m_spi [2]
Scrollbar position info.
CSize | m_szFrameRegion
Previous frame region.
BOOL | m_bMDIClient
TRUE if the frame is a MDI client.
BOOL | m_bActive
TRUE if the caption is active.
DWORD | m_dwStyle
Styles of window.
DWORD | m_dwExStyle
ExStyles of window.
- Protected Attributes inherited from CXTPSkinObject
WNDPROC | m_pOldWndProc
Old window window handler.
CXTPSkinManager * | m_pManager
Parent CXTPSkinManager object.
CString | m_strClassName
Own class name.
BOOL | m_bActiveX
TRUE if ActiveX controls.
BOOL | m_bWindowsForms
TRUE if .NET controls.
- Static Protected Attributes inherited from CXTPSkinObjectFrame

Detailed Description

CXTPSkinObjectTreeView is a CXTPSkinObjectComCtl32Control derived class.

It implements a standard tree view control.

The documentation for this class was generated from the following file:
  • XTPSkinObjectTreeView.h


Toolkit Pro: CXTPSkinObjectUser32Control Class Reference

Protected Member Functions | List of all members
CXTPSkinObjectUser32Control Class Reference

CXTPSkinObjectUser32Control is a CXTPSkinObjectFrame derived class. More...

Inheritance diagram for CXTPSkinObjectUser32Control:
[legend]

Protected Member Functions

CXTPSkinObjectUser32Control ()
Constructs a CXTPSkinObjectUser32Control object.
virtual void | CheckScrollBarsDraw ()
Determines if the scrollbar position was changed.
- Protected Member Functions inherited from CXTPSkinObjectFrame
virtual void | OnSkinChanged (BOOL bPrevState, BOOL bNewState)
This method is called when the skin is changed.
virtual void | RefreshMetrics ()
This method is called when visual metrics are changed.
virtual void | OnHookAttached (LPCREATESTRUCT lpcs, BOOL bAuto)
This method is called when the hook is attached.
void | OnHookDetached (BOOL bAuto)
This method is called when the hook is detached.
- Protected Member Functions inherited from CXTPSkinObject
CXTPSkinObject ()
Constructs a CXTPSkinObject object.
~CXTPSkinObject ()
Destroys a CXTPSkinObject object, handles cleanup and deallocation.

Additional Inherited Members

- Public Types inherited from CXTPSkinObjectFrame
- Public Member Functions inherited from CXTPSkinObjectFrame
CXTPSkinObjectFrame ()
Constructs a CXTPSkinObjectFrame object.
virtual | ~CXTPSkinObjectFrame ()
Destroys a CXTPSkinObjectFrame object, handles cleanup and deallocation.
void | RedrawScrollBar (int nBar)
Redraws the scrollbar of the frame.
CRect | GetBorders () const
Gets the borders of the window.
BOOL | IsActive () const
Determines if the caption is active.
CCaptionButtons * | GetCaptionButtons ()
Gets the collection of caption buttons.
virtual HBRUSH | GetClientBrush (CDC *pDC)
Gets the client brush.
- Public Member Functions inherited from CXTPSkinObject
CXTPSkinManager * | GetSkinManager () const
Gets the parent CXTPSkinManager object.
CString | GetClassName () const
Gets own class name.
CXTPSkinManagerClass * | GetSkinClass () const
Gets the CXTPSkinManagerClass object associated with own class name.
CXTPSkinManagerMetrics * | GetMetrics () const
Gets the skin metrics.
COLORREF | GetColor (int nIndex) const
Retrieves the specified system color.
- Public Member Functions inherited from CXTPSynchronized
CXTPRWCriticalSection & | GetAccessCriticalSection () const
Accesses a synchronized object's critical section.
- Public Attributes inherited from CXTPSkinObjectFrame
BOOL | m_bLockFrameDraw
TRUE to lock draw.
DWORD | m_dwDialogTexture
Dialog texture.
- Static Public Attributes inherited from CXTPSkinObject
- Protected Attributes inherited from CXTPSkinObjectFrame
CCaptionButtons | m_arrButtons
Caption buttons.
CRect | m_rcBorders
Frame borders.
CCaptionButton * | m_pButtonHot
Hot caption button.
CCaptionButton * | m_pButtonPressed
Pressed caption button.
BOOL | m_bRegionChanged
TRUE if region was changed.
XTP_SKINSCROLLBAR_TRACKINFO * | m_pSBTrack
Track info of scrollbars.
XTP_SKINSCROLLBAR_POSINFO | m_spi [2]
Scrollbar position info.
CSize | m_szFrameRegion
Previous frame region.
BOOL | m_bMDIClient
TRUE if the frame is a MDI client.
BOOL | m_bActive
TRUE if the caption is active.
DWORD | m_dwStyle
Styles of window.
DWORD | m_dwExStyle
ExStyles of window.
- Protected Attributes inherited from CXTPSkinObject
WNDPROC | m_pOldWndProc
Old window window handler.
CXTPSkinManager * | m_pManager
Parent CXTPSkinManager object.
CString | m_strClassName
Own class name.
BOOL | m_bActiveX
TRUE if ActiveX controls.
BOOL | m_bWindowsForms
TRUE if .NET controls.
- Static Protected Attributes inherited from CXTPSkinObjectFrame

Detailed Description

CXTPSkinObjectUser32Control is a CXTPSkinObjectFrame derived class.

It is the base class for all User32 defined controls.

The documentation for this class was generated from the following file:
  • XTPSkinObjectFrame.h


Toolkit Pro: CXTPSliderPaintManager Class Reference

Public Member Functions | List of all members
CXTPSliderPaintManager Class Reference

Paint manager for the slider control. More...

Inheritance diagram for CXTPSliderPaintManager:
[legend]

Public Member Functions

CXTPSliderPaintManager (CXTPPaintManager *pPaintManager)
Constructs a CXTPSliderPaintManager object.
virtual void | DrawScrollBar (CDC *pDC, CXTPScrollBase *pScrollBar)
This method is called to draw the scrollbar of the slider.
virtual void | RefreshMetrics ()
Recalculates gallery metrics.
- Public Member Functions inherited from CXTPScrollBarPaintManager
CXTPScrollBarPaintManager ()
Constructs a CXTPScrollBarPaintManager object.

Additional Inherited Members

- Public Attributes inherited from CXTPScrollBarPaintManager
int | m_cxHScroll
Width, in pixels, of the arrow bitmap on a horizontal scroll bar.
int | m_cyHScroll
Height, in pixels, of a horizontal scroll bar.
int | m_cxVScroll
Width, in pixels, of a vertical scroll bar;.
int | m_cyVScroll
Height, in pixels, of the arrow bitmap on a vertical scroll bar.
int | m_cThumb
Width of thumb button.
COLORREF | m_crBackPushed
Color when pushed.
COLORREF | m_crBackHilite
Color when border.
COLORREF | m_crBorderHilite
Color of border when highlighted.
COLORREF | m_crBorder
Color of border.
COLORREF | m_crBack
Color of background.
- Protected Types inherited from CXTPScrollBarPaintManager
- Protected Member Functions inherited from CXTPScrollBarPaintManager
virtual void | DrawBackground (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws verical scrollbar background only.
virtual void | DrawButtons (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws vertical scrollbar buttons only.
virtual void | DrawArrows (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws vertical scrollbar button arrows only.
virtual void | DrawTracker (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws vertical scrollbar trackers only.
virtual void | DrawThumbButton (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws vertical scrollbar thumb button only.
virtual void | DrawBackground (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar background only.
virtual void | DrawButtons (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar buttons only.
virtual void | DrawArrows (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar button arrows only.
virtual void | DrawTracker (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar trackers only.
virtual void | DrawThumbButton (CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar thumb button only.
virtual void | DrawGripper (CDC *pDC, CXTPScrollBase *pScroll)
Draws scrollbar gripper only.
void | DrawArrowGlyph (CDC *pDC, CRect rcArrow, XTPArrowGlyph glyph, BOOL bEnabled, COLORREF clrText=COLORREF_NULL)
Draws scrollbar button arrow glyph.
- Static Protected Member Functions inherited from CXTPScrollBarPaintManager
static void AFX_CDECL | CalcVScroll (CXTPScrollBase *pScroll, XTPScrollMetricsV *pVScroll)
Computes vertical scrollbar mertics.
static void AFX_CDECL | CalcHScroll (CXTPScrollBase *pScroll, XTPScrollMetricsH *pHScroll)
Computes horizontal scrollbar mertics.

Detailed Description

Paint manager for the slider control.

Constructor & Destructor Documentation

◆ CXTPSliderPaintManager()

CXTPSliderPaintManager ( CXTPPaintManager * pPaintManager )

Constructs a CXTPSliderPaintManager object.

Parameters
pPaintManager PaintManager of CommandBars.

Member Function Documentation

◆ DrawScrollBar()

virtual void DrawScrollBar | ( | CDC * | pDC,
 |  | CXTPScrollBase * | pScrollBar )
 virtual

This method is called to draw the scrollbar of the slider.

Parameters
pDC | Pointer to device context.
pScrollBar | Scrollbar to draw.

Reimplemented from CXTPScrollBarPaintManager.

The documentation for this class was generated from the following file:
  • XTPSliderPaintManager.h


Toolkit Pro: CXTPSmartPtrInternalT< _TObject > Class Template Reference

Public Member Functions | Protected Types | Protected Attributes | List of all members
CXTPSmartPtrInternalT< _TObject > Class Template Reference
Inheritance diagram for CXTPSmartPtrInternalT< _TObject >:
[legend]

Public Member Functions

CXTPSmartPtrInternalT (_TObject *pObject=NULL, BOOL bCallInternalAddRef=FALSE)
Default class constructor.
CXTPSmartPtrInternalT (const Tthis &rSrc)
Copy class constructor.
virtual | ~CXTPSmartPtrInternalT ()
Default class destructor.
void | SetPtr (_TObject *pObject, BOOL bCallInternalAddRef=FALSE)
Set new handled object.
_TObject * | Detach ()
Get a handled object and set internal object member to NULL without call InternalRelease().
_TObject * | GetInterface (BOOL bWithAddRef=TRUE)
Get a handled object and set internal object member to NULL without call InternalRelease().
_TObject * | operator= (_TObject *pNewObj)
Set new handled object.
const Tthis & | operator= (const Tthis &rSrc)
Set new handled object.
_TObject * | operator-> () const
Get a handled object.
_TObject & | operator* () const
Get a handled object.
operator _TObject * () const
Get a handled object.
bool | operator! () const
Checks is handled object equal NULL.
operator bool () const
Checks is handled object equal or not equal to NULL.
bool | operator== (const Tthis &ptr2) const
Equal-to operator.
bool | operator!= (const Tthis &ptr2) const
Not-equal-to operator.

Protected Types

typedef CXTPSmartPtrInternalT< _TObject > Tthis

Protected Attributes

_TObject * m_pObject
A pointer to a handled object.

Detailed Description

template<class _TObject>
class CXTPSmartPtrInternalT< _TObject >

This internal class is used for semi-automatic incrementing and decrementing reference to any object derived from CXTPCmdTarget or other class, which has InternalAddRef(), InternalRelease() methods.

See also
macro XTP_DEFINE_SMART_PTR_INTERNAL(_TClassName)

Member Typedef Documentation

◆ Tthis

template<class _TObject >
CXTPSmartPtrInternalT<_TObject> Tthis
protected

This class type definition

Constructor & Destructor Documentation

◆ CXTPSmartPtrInternalT() [1/2]

template<class _TObject >
CXTPSmartPtrInternalT | ( | _TObject * | pObject = NULL,
 |  | BOOL | bCallInternalAddRef = FALSE )
 inline

Default class constructor.

Parameters
pObject | Pointer to the handled object.
bCallInternalAddRef | If this parameter is TRUE pObject->InternalAddRef() will be called in constructor. By default this parameter is FALSE.
See also
~CXTPSmartPtrInternalT()

◆ CXTPSmartPtrInternalT() [2/2]

template<class _TObject >
CXTPSmartPtrInternalT ( const Tthis & rSrc )
inline

Copy class constructor.

Parameters
rSrc The source object reference.
See also
CXTPSmartPtrInternalT(_TObject* pObject, BOOL bCallInternalAddRef)

◆ ~CXTPSmartPtrInternalT()

template<class _TObject >
virtual ~CXTPSmartPtrInternalT ( )
inlinevirtual

Default class destructor.

Call InternalRelease() for the not NULL handled object.

See also
CXTPSmartPtrInternalT constructors

Member Function Documentation

◆ Detach()

template<class _TObject >
_TObject * Detach ( )
inline

Get a handled object and set internal object member to NULL without call InternalRelease().

Returns
Pointer to the handled object.

◆ GetInterface()

template<class _TObject >
_TObject * GetInterface ( BOOL bWithAddRef = TRUE )
inline

Get a handled object and set internal object member to NULL without call InternalRelease().

Parameters
bWithAddRef [in] If TRUE InternalAddRef() is called before
Returns
Pointer to the handled object.

◆ operator _TObject *()

template<class _TObject >
operator _TObject * ( ) const
inline

Get a handled object.

Returns
Pointer to the handled object.

◆ operator bool()

template<class _TObject >
operator bool ( ) const
inline

Checks is handled object equal or not equal to NULL.

Returns
true if handled object not equal NULL, otherwise false.

◆ operator!()

template<class _TObject >
bool operator! ( ) const
inline

Checks is handled object equal NULL.

Returns
TRUE if handled object equal NULL, otherwise FALSE.

◆ operator!=()

template<class _TObject >
bool operator!= ( const Tthis & ptr2 ) const
inline

Not-equal-to operator.

Parameters
ptr2 [in] Smart pointer to the other object.

This operator compare internal stored pointer and specified pointer.

Returns
TRUE if pointer are not equal, otherwise FALSE.

◆ operator*()

template<class _TObject >
_TObject & operator* ( ) const
inline

Get a handled object.

Returns
Reference to the handled object.

◆ operator->()

template<class _TObject >
_TObject * operator-> ( ) const
inline

Get a handled object.

Returns
Pointer to the handled object.

◆ operator=() [1/2]

template<class _TObject >
_TObject * operator= ( _TObject * pNewObj )
inline

Set new handled object.

Parameters
pNewObj Pointer to the new handled object.

InternalRelease() for the previous not NULL handled object will be called.

Returns
Pointer to the new handled object.

◆ operator=() [2/2]

template<class _TObject >
const Tthis & operator= ( const Tthis & rSrc )
inline

Set new handled object.

Parameters
rSrc Reference to the new handled object.

InternalRelease() for the previous not NULL handled object will be called. InternalAddRef() for the new not NULL handled object will be called.

Returns
Reference to this class instance.

◆ operator==()

template<class _TObject >
bool operator== ( const Tthis & ptr2 ) const
inline

Equal-to operator.

Parameters
ptr2 [in] Pointer to the other object.

This operator compare internal stored pointer and specified pointer.

Returns
TRUE if pointer are equal, otherwise FALSE.

◆ SetPtr()

template<class _TObject >
void SetPtr | ( | _TObject * | pObject,
 |  | BOOL | bCallInternalAddRef = FALSE )
 inline

Set new handled object.

Parameters
pObject | Pointer to the new handled object.
bCallInternalAddRef | If this parameter is TRUE pObject->InternalAddRef() will be called in constructor. By default this parameter is FALSE.

InternalRelease() for the previous not NULL handled object will be called. InternalAddRef() for the new not NULL handled object will be called.

See also
operator=
The documentation for this class was generated from the following file:
  • XTPSmartPtrInternalT.h


Toolkit Pro: CXTPSortClass Class Reference

Classes | Public Member Functions | Static Public Member Functions | Protected Attributes | List of all members
CXTPSortClass Class Reference

CXTPSortClass is a standalone class. More...

Classes

struct ITEMDATA
This structure is used by the CXTPSortClass for storing a temporary item data pointer that contains each list item's name (used for sorting) and original item data (if any). More...

Public Member Functions

CXTPSortClass (CListCtrl *pListCtrl, const int nCol, PFNLVCOMPARE pfnCompare=NULL)
Constructs a CXTPSortClass object.
virtual | ~CXTPSortClass ()
Destroys a CXTPSortClass object, handles cleanup and deallocation.
virtual void | Sort (bool bAsc, int iType)
This member function is called to perform the actual sort procedure.

Static Public Member Functions

static int CALLBACK | Compare (LPARAM lParam1, LPARAM lParam2, LPARAM lParamSort)
This callback member function is called to compare two data items during sorting operations.
static int AFX_CDECL | RemoveNonNumeric (CString &strSource)
This member function is called by the sort class to remove non-numeric characters from the specified source string.
static int AFX_CDECL | SortInt (LPCTSTR lpszItem1, LPCTSTR lpszItem2, const short sOrder)
This member function is called by the application defined comparison function to perform integer sorting.
static int AFX_CDECL | SortString (LPCTSTR lpszItem1, LPCTSTR lpszItem2, const short sOrder)
This member function is called by the application defined comparison function to perform string sorting.
static int AFX_CDECL | SortDateTime (LPCTSTR lpszItem1, LPCTSTR lpszItem2, const short sOrder)
This member function is called by the application defined comparison function to perform date/time sorting.
static int AFX_CDECL | SortDecimal (LPCTSTR lpszItem1, LPCTSTR lpszItem2, const short sOrder)
This member function is called by the application defined comparison function to perform decimal sorting.

Protected Attributes

CListCtrl * | m_pListCtrl
Pointer to the CListCtrl object to perform the sort on.
PFNLVCOMPARE | m_pfnCompare
Address of the application-defined comparison function.

Detailed Description

CXTPSortClass is a standalone class.

This class will sort a list control by a column of text, integer, float or date/time type. It could be easily extended for other data types. To use this class, instantiate a CXTPSortClass object, passing in a pointer to the list control as the first argument and the column index as the second argument.

Example: The following example demonstrates how to use CXTPSortClass:

CXTPSortClass sortClass(pListCtrl, 0);

Then call the sort method setting ascending as the first argument, either TRUE or FALSE, and the type of sort to perform in the second argument.

The following example demonstrates how to use the sortClass Sort member function:

sortClass.Sort(TRUE, xtpSortString);

Constructor & Destructor Documentation

◆ CXTPSortClass()

CXTPSortClass | ( | CListCtrl * | pListCtrl,
 |  | const int | nCol,
 |  | PFNLVCOMPARE | pfnCompare = NULL )

Constructs a CXTPSortClass object.

Parameters
pListCtrl | Pointer to a valid CListCtrl object.
nCol | Index of the column to be sorted.
pfnCompare | Address of the application-defined comparison function. See CListCtrl::SortItems for more details.

Member Function Documentation

◆ Compare()

static int CALLBACK Compare | ( | LPARAM | lParam1,
 |  | LPARAM | lParam2,
 |  | LPARAM | lParamSort )
 static

This callback member function is called to compare two data items during sorting operations.

Parameters
lParam1 | Specifies the item data for the first of the two items being compared.
lParam2 | Specifies the item data for the second of the two items being compared.
lParamSort | Specifies the application defined value that is passed to the comparison function.
Returns
The comparison function must return a negative value if the first item should precede the second, a positive value if the first item should follow the second, or zero if the two items are equivalent.

◆ RemoveNonNumeric()

static int AFX_CDECL RemoveNonNumeric ( CString & strSource )
static

This member function is called by the sort class to remove non-numeric characters from the specified source string.

Parameters
strSource String to remove non-numeric characters from.
Returns
The length of the specified string after non-numeric characters have been removed.

◆ Sort()

virtual void Sort | ( | bool | bAsc,
 |  | int | iType )
 virtual

This member function is called to perform the actual sort procedure.

Parameters
bAsc | true to sort ascending.
iType | The type of sort to perform can be one of the values listed in the Remarks section.

Sort type can be one of the following:

xtpSortInt: Sort type int. xtpSortString: Sort type string. xtpSortDateTime: Sort type date/time. xtpSortDecimal: Sort type decimal. xtpSortCustom: Sort type user-defined.

◆ SortDateTime()

static int AFX_CDECL SortDateTime | ( | LPCTSTR | lpszItem1,
 |  | LPCTSTR | lpszItem2,
 |  | const short | sOrder )
 static

This member function is called by the application defined comparison function to perform date/time sorting.

Parameters
lpszItem1 | NULL-terminated string representing the first date/time being compared.
lpszItem2 | NULL-terminated string representing the second date/time being compared.
sOrder | Represents the sort order; set to 1 for ascending, or -1 for descending.
Returns
A negative value if the first item should precede the second, a positive value if the first item should follow the second, or zero if the two items are equivalent.
See also
SortInt, SortString, SortDecimal

◆ SortDecimal()

static int AFX_CDECL SortDecimal | ( | LPCTSTR | lpszItem1,
 |  | LPCTSTR | lpszItem2,
 |  | const short | sOrder )
 static

This member function is called by the application defined comparison function to perform decimal sorting.

Parameters
lpszItem1 | NULL-terminated string representing the first decimal being compared.
lpszItem2 | NULL-terminated string representing the second decimal being compared.
sOrder | Represents the sort order; set to 1 for ascending, or -1 for descending.
Returns
A negative value if the first item should precede the second, a positive value if the first item should follow the second, or zero if the two items are equivalent.
See also
SortInt, SortString, SortDateTime

◆ SortInt()

static int AFX_CDECL SortInt | ( | LPCTSTR | lpszItem1,
 |  | LPCTSTR | lpszItem2,
 |  | const short | sOrder )
 static

This member function is called by the application defined comparison function to perform integer sorting.

Parameters
lpszItem1 | NULL-terminated string representing the first int being compared.
lpszItem2 | NULL-terminated string representing the second int being compared.
sOrder | Represents the sort order; set to 1 for ascending, or -1 for descending.
Returns
A negative value if the first item should precede the second, a positive value if the first item should follow the second, or zero if the two items are equivalent.
See also
SortString, SortDateTime, SortDecimal

◆ SortString()

static int AFX_CDECL SortString | ( | LPCTSTR | lpszItem1,
 |  | LPCTSTR | lpszItem2,
 |  | const short | sOrder )
 static

This member function is called by the application defined comparison function to perform string sorting.

Parameters
lpszItem1 | NULL-terminated string representing the first string being compared.
lpszItem2 | NULL-terminated string representing the second string being compared.
sOrder | Represents the sort order; set to 1 for ascending, or -1 for descending.
Returns
A negative value if the first item should precede the second, a positive value if the first item should follow the second, or zero if the two items are equivalent.
See also
SortInt, SortDateTime, SortDecimal

Member Data Documentation

◆ m_pfnCompare

PFNLVCOMPARE m_pfnCompare
protected

Address of the application-defined comparison function.

See

The documentation for this class was generated from the following file:
  • XTPSortClass.h


Toolkit Pro: CXTPSortClass::ITEMDATA Struct Reference

  • CXTPSortClass
  • ITEMDATA
Public Attributes | List of all members
CXTPSortClass::ITEMDATA Struct Reference

This structure is used by the CXTPSortClass for storing a temporary item data pointer that contains each list item's name (used for sorting) and original item data (if any). More...

Public Attributes

CString | strItem
NULL-terminated string that represents the list item's text.
DWORD_PTR | dwData
List item's application defined value (if any).

Detailed Description

This structure is used by the CXTPSortClass for storing a temporary item data pointer that contains each list item's name (used for sorting) and original item data (if any).

The documentation for this struct was generated from the following file:
  • XTPSortClass.h


Toolkit Pro: CXTPSoundManager Class Reference

Public Member Functions | Public Attributes | List of all members
CXTPSoundManager Class Reference

CXTPSoundManager is a standalone class. More...

Public Member Functions

~CXTPSoundManager ()
Destroys a CXTPSoundManager object, handles cleanup and deallocation.
void | PlaySystemSound (XTPSoundManagerState state)
Call this method to play system sound.
void | EnableSystemSounds (BOOL bEnable)
Call this method to disable all system sounds for application.
void | StopThread ()
This method is called to stop all sounds and terminate sound thread.

Public Attributes

BOOL m_bSoundAvailable
FALSE to disable sound.

Detailed Description

CXTPSoundManager is a standalone class.

It used to play system sound.

See also
XTPSoundManagerState, XTPSoundManager

Member Function Documentation

◆ EnableSystemSounds()

void EnableSystemSounds ( BOOL bEnable )

Call this method to disable all system sounds for application.

Parameters
bEnable FALSE to disable system sounds.

Call this method to force system settings and disable all sounds.

◆ PlaySystemSound()

void PlaySystemSound ( XTPSoundManagerState state )

Call this method to play system sound.

Parameters
state System sound to play. Can be any of the values listed in the remarks section.

State parameter can be one of the following: xtpSoundMenuCommand: Play menu command system sound. xtpSoundMenuPopup: Play menu pop-up system sound.

Member Data Documentation

◆ m_bSoundAvailable

BOOL m_bSoundAvailable

FALSE to disable sound.

you can use "m_bSoundAvailable = waveOutGetNumDevs()"

The documentation for this class was generated from the following file:
  • XTPSystemHelpers.h


Toolkit Pro: CXTPSpinButtonCtrl Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPSpinButtonCtrl Class Reference

The CXTPSpinButtonCtrl class provides the functionality of a themed Windows spin button control. More...

Public Member Functions

CXTPSpinButtonCtrl ()
Constructs a CXTPSpinButtonCtrl object.
~CXTPSpinButtonCtrl ()
Destroys a CXTPSpinButtonCtrl object, handles cleanup and deallocation.
void | SetTheme (XTPControlTheme nTheme)
Call this member to switch the visual theme of the control.
BOOL | GetUseVisualStyle () const
Determines if the control is drawn using visual styles/SkinFramework, if supported.
void | SetUseVisualStyle (BOOL bUseVisualStyle=TRUE)
Enables Windows XP visual styles for the control.

Protected Member Functions

UINT | HitTest (CPoint pt)
Determines which spin button, if any, is at a specified position.
void | OnDraw (CDC *pDC)
Called by the framework to render the spin button control.
void | RefreshMetrics ()
This member is called to update color, text, and other visual elements of the control.
BOOL | HasSharedBorder () const
Called to determine if the border is shared with a buddy.
CXTPEdit * | GetEditBuddy () const
Called to retrieve a pointer to the CXTPEdit buddy window.
void | DrawVisualStyle (CDC *pDC)
Called by the framework to render Windows themes for the spin button control.
void | DrawOffice2007 (CDC *pDC)
Called by the framework to render resource driven themes.
void | DrawFlat (CDC *pDC)
Called by the framework to render flat style spin button themes.
void | DrawFlatButton (CDC *pDC, UINT nButton)
Called by the framework to render the button portion of the spin button control for flat style themes.
void | DrawArrowGlyph (CDC *pDC, CRect rcArrow, BOOL bHorz, BOOL bUpArrow, COLORREF clrArrow)
Called by the framework to render the up and down arrows for the spin button control.
void | DrawStandard (CDC *pDC)
Draw spin button using native Windows theme.
BOOL | IsVertical () const
Called by the framework to determine if the spin button control is vertically orientated.
CRect | GetButtonRect (int nButton)
Called by the spin button control to determine the size of the spin button specified by nButton.
void | Init ()
This member function is called from OnInitDialog or OnInitialUpdate to initialize the control.

Protected Attributes

UINT | m_nHotButton
ID for the currently highlighted button, can be either UD_HITNOWHERE, UD_HITDOWN or UD_HITUP.
UINT | m_nPressedButton
ID for the currently pressed button, can be either UD_HITNOWHERE, UD_HITDOWN or UD_HITUP.
BOOL | m_bUseVisualStyle
TRUE to use Windows themes.
BOOL | m_bPreSubclassInit
TRUE if the control has been subclassed.
COLORREF | m_crBack
Spin button background color.
COLORREF | m_crBackHilite
Spin button background highlight color.
COLORREF | m_crBackPushed
Spin button background pushed color.
COLORREF | m_crBackDisabled
Spin button disabled color.
COLORREF | m_crBorder
Border color.
COLORREF | m_crBorderHilite
Border highlight color.
COLORREF | m_crBorderPushed
Border pushed color.
COLORREF | m_crBorderDisabled
Border disabled color.
COLORREF | m_crArrowEnabled
Spin button arrow color.
COLORREF | m_crArrowHilite
Spin button arrow highlight color.
COLORREF | m_crArrowPushed
Spin button arrow pushed color.
COLORREF | m_crArrowDisabled
Spin button arrow disabled color.
XTPControlTheme | m_nTheme
Currently active theme ID.
CXTPWinThemeWrapper * | m_themeSpin
Windows theme API wrapper pointer.

Detailed Description

The CXTPSpinButtonCtrl class provides the functionality of a themed Windows spin button control.

Member Function Documentation

◆ DrawArrowGlyph()

void DrawArrowGlyph | ( | CDC * | pDC,
 |  | CRect | rcArrow,
 |  | BOOL | bHorz,
 |  | BOOL | bUpArrow,
 |  | COLORREF | clrArrow )
 protected

Called by the framework to render the up and down arrows for the spin button control.

Parameters
pDC | Pointer to a valid device context.
rcArrow | Size of the arrow to draw.
bHorz | TRUE if the arrow is horizontal.
bUpArrow | TRUE if the arrow is pointing up.
clrArrow | An RGB value representing the color of the arrow to draw.

◆ DrawFlat()

void DrawFlat ( CDC * pDC )
protected

Called by the framework to render flat style spin button themes.

Parameters
pDC Pointer to a valid device context.

◆ DrawFlatButton()

void DrawFlatButton | ( | CDC * | pDC,
 |  | UINT | nButton )
 protected

Called by the framework to render the button portion of the spin button control for flat style themes.

Parameters
pDC | Pointer to a valid device context.
nButton | Button control ID.

◆ DrawOffice2007()

void DrawOffice2007 ( CDC * pDC )
protected

Called by the framework to render resource driven themes.

Parameters
pDC Pointer to a valid device context.

◆ DrawStandard()

void DrawStandard ( CDC * pDC )
protected

Draw spin button using native Windows theme.

Parameters
pDC Pointer to a valid device context.

◆ DrawVisualStyle()

void DrawVisualStyle ( CDC * pDC )
protected

Called by the framework to render Windows themes for the spin button control.

Parameters
pDC Pointer to a valid device context.

◆ GetButtonRect()

CRect GetButtonRect ( int nButton )
protected

Called by the spin button control to determine the size of the spin button specified by nButton.

Parameters
nButton ID of the button to retrieve the size information for, can be either UD_HITUP or UD_HITDOWN.
Returns
A CRect value representing the size for the specified button.

◆ GetEditBuddy()

CXTPEdit * GetEditBuddy ( ) const
protected

Called to retrieve a pointer to the CXTPEdit buddy window.

Returns
A pointer to a CXTPEdit object if a buddy is available, otherwise NULL.

◆ GetUseVisualStyle()

BOOL GetUseVisualStyle ( ) const

Determines if the control is drawn using visual styles/SkinFramework, if supported.

This method enables Windows XP visual styles for the control. This Control will draw using visual styles if both the control and the operating system support it. Visual styles and SkinFramework skins are specifications for the appearance of controls. GetUseVisualStyle determines whether to use the currently set Windows XP visual style. If using SkinFramework, then it determines whether to use the currently set style of the SkinFramework.

Returns
TRUE if the currently set Windows XP visual style will be used to theme the control. If using SkinFramework, then the currently set style of the SkinFramework will be used to skin the control. FALSE if the currently set appearance/style in the OS will be used.

◆ HasSharedBorder()

BOOL HasSharedBorder ( ) const
protected

Called to determine if the border is shared with a buddy.

Returns
TRUE if the borders are shared.

◆ HitTest()

UINT HitTest ( CPoint pt )
protected

Determines which spin button, if any, is at a specified position.

Parameters
pt Point to be tested.
Returns
The ID of the spin button at the position specified by pt, can be either UD_HITNOWHERE, UD_HITDOWN, or UD_HITUP.

◆ IsVertical()

BOOL IsVertical ( ) const
protected

Called by the framework to determine if the spin button control is vertically orientated.

Returns
TRUE if the spin button control orientation is vertical.

◆ OnDraw()

void OnDraw ( CDC * pDC )
protected

Called by the framework to render the spin button control.

Parameters
pDC Pointer to a valid device context.

◆ SetTheme()

void SetTheme ( XTPControlTheme nTheme )

Call this member to switch the visual theme of the control.

Parameters
nTheme New visual theme. Can be any of the values listed in the Remarks section.

nStyle can be one of the following: xtpControlThemeDefault: Standard appearance style. xtpControlThemeFlat: Flat appearance style. xtpControlThemeUltraFlat: Ultra flat appearance style. xtpControlThemeOffice2000: Office 2000 appearance style. xtpControlThemeOfficeXP: Office XP appearance style. xtpControlThemeOffice2003: Office 2003 appearance style. xtpControlThemeResource: Office 2007 appearance style.

◆ SetUseVisualStyle()

void SetUseVisualStyle ( BOOL bUseVisualStyle = TRUE )

Enables Windows XP visual styles for the control.

This method enables Windows XP visual styles for the control. This Control will draw using visual styles if both the control and the operating system support it. Visual styles and SkinFramework skins are specifications for the appearance of controls. GetUseVisualStyle determines whether to use the currently set Windows XP visual style. If using SkinFramework, then it determines whether to use the currently set style of the SkinFramework.

Parameters
bUseVisualStyle TRUE if the currently set Windows XP visual style will be used to theme the control. If using SkinFramework, then the currently set style of the SkinFramework will be used to skin the control. FALSE if the currently set appearance/style in the OS will be used.
The documentation for this class was generated from the following file:
  • XTPSpinButtonCtrl.h


Toolkit Pro: CXTPSplitPath Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPSplitPath Class Reference

CXTPSplitPath conveniently wraps the _splitpath API for easier access to path components such as file name and extension. More...

Public Member Functions

CXTPSplitPath (LPCTSTR lpszPathBuffer=NULL)
Constructs a CXTPSplitPath object and breaks a path into its four components.
virtual | ~CXTPSplitPath ()
Destroys a CXTPSplitPath object, handles cleanup and deallocation.
void | SplitPath (LPCTSTR lpszPathBuffer)
Call SplitPath to break a path into its four components.
CString | GetDrive () const
Call GetDrive() to retrieve the drive letter, followed by a colon (:) for the path split.
CString | GetDir () const
Call GetDir() to retrieve the directory path, including trailing slash.
CString | GetFName () const
Call GetFName() to retrieve the base filename without the filename extension.
CString | GetExt () const
Call GetExt() to retrieve the filename extension, including the leading period (.)
CString | GetFullPath () const
Call GetFullPath() to retrieve the full path that was split.
CString | GetFullName () const
Call GetFullName() to retrieve the filename plus the filename extension only for the path that was split.

Protected Attributes

TCHAR | m_szDrive [_MAX_DRIVE]
Optional drive letter, followed by a colon (:).
TCHAR | m_szDir [_MAX_DIR]
Optional directory path, including trailing slash.
TCHAR | m_szFName [_MAX_FNAME]
Base filename (no extension).
TCHAR | m_szExt [_MAX_EXT]
Optional filename extension, including leading period (.).

Detailed Description

CXTPSplitPath conveniently wraps the _splitpath API for easier access to path components such as file name and extension.

Constructor & Destructor Documentation

◆ CXTPSplitPath()

CXTPSplitPath ( LPCTSTR lpszPathBuffer = NULL )

Constructs a CXTPSplitPath object and breaks a path into its four components.

Parameters
lpszPathBuffer A NULL-terminated string that represents the path to split.

Member Function Documentation

◆ GetDir()

CString GetDir ( ) const

Call GetDir() to retrieve the directory path, including trailing slash.

Forward slashes (/), backslashes (\), or both may be used.

Returns
A NULL-terminated string.

◆ GetDrive()

CString GetDrive ( ) const

Call GetDrive() to retrieve the drive letter, followed by a colon (:) for the path split.

Returns
A NULL-terminated string.

◆ GetExt()

CString GetExt ( ) const

Call GetExt() to retrieve the filename extension, including the leading period (.)

Returns
A NULL-terminated string.

◆ GetFName()

CString GetFName ( ) const

Call GetFName() to retrieve the base filename without the filename extension.

Returns
A NULL-terminated string.

◆ GetFullName()

CString GetFullName ( ) const

Call GetFullName() to retrieve the filename plus the filename extension only for the path that was split.

Returns
A NULL-terminated string.

◆ GetFullPath()

CString GetFullPath ( ) const

Call GetFullPath() to retrieve the full path that was split.

Returns
A NULL-terminated string.

◆ SplitPath()

void SplitPath ( LPCTSTR lpszPathBuffer )

Call SplitPath to break a path into its four components.

Parameters
lpszPathBuffer A NULL-terminated string that represents the path to split.

Member Data Documentation

◆ m_szDir

TCHAR m_szDir[_MAX_DIR]
protected

Optional directory path, including trailing slash.

Forward slashes (/), backslashes (\), or both may be used.

The documentation for this class was generated from the following file:
  • XTPUtil.h


Toolkit Pro: CXTPSplitterWnd Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPSplitterWnd Class Reference

CXTPSplitterWnd is a CSplitterWnd derived class. More...

Inheritance diagram for CXTPSplitterWnd:
[legend]

Public Member Functions

CXTPSplitterWnd ()
Constructs a CXTPSplitterWnd object.
virtual | ~CXTPSplitterWnd ()
Destroys a CXTPSplitterWnd object, handles cleanup and deallocation.
BOOL | SetTheme (XTPControlTheme eTheme)
Call this member to switch the visual theme of the control.
BOOL | SetTheme (CXTPSplitterWndTheme *pTheme)
Call this member to switch the visual theme of the control.
CXTPSplitterWndTheme * | GetTheme () const
Call this member function to get a pointer to the currently selected theme.
virtual void | ShowColumn ()
This member function is called to show the column that was previously hidden.
virtual void | HideColumn (int nColHide)
This member function will hide a column based upon its index.
virtual void | ShowRow ()
This member function is called to show the row that was previously hidden.
virtual void | HideRow (int nRowHide)
This member function will hide a row based upon its index.
virtual BOOL | SwitchView (int nRow, int nCol, CView *pNewView)
This member function is called to switch (or swap) a splitter view with another.
virtual CView * | ReplaceView (int nRow, int nCol, CView *pNewView)
This member function is called to replace an existing splitter view with another.
virtual CView * | ReplaceView (int nRow, int nCol, CRuntimeClass *pViewClass)
This member function is called to replace an existing splitter view with another.
void | EnableFullDrag (int nFullDrag)
Call this method to enable full drag windows.
void | EnableDotTracker (BOOL bEnable)
Call this member function to enable dotted tracker display rather than the default.
void | EnableBorder (BOOL bBorder)
Call this member function to show/hide the borders for the splitter client area.
BOOL | IsBorderVisible () const
Call this member function to determine the visibility of borders for the splitter client area.
void | EnableNoSize (BOOL bEnable)
Call this member function to disable resizing splitter pane windows.
int | GetHiddenColIndex () const
Call this member function to retrieve the index of the column that is currently hidden.
int | GetHiddenRowIndex () const
Call this member function to return the index of the row that is currently hidden.
virtual void | SetActivePane (int row, int col, CWnd *pWnd=NULL)
Sets a pane to be the active one in the frame.
BOOL | FullDragWindows () const
Call this member function to check if full window dragging is enabled.
- Public Member Functions inherited from CXTPScrollBarContainer< CSplitterWnd >
void | SetScrollBarTheme (XTPScrollBarTheme theme)
Sets scroll bar theme.
BOOL | CreateScrollBarCtrl (DWORD dwStyle, UINT nID)
Creates a scroll bar control with ID and style specied.
virtual CScrollBar * | GetScrollBarCtrl (int nBar) const
Call this member function to obtain a pointer to the specified sibling scroll bar or splitter window.
void | ShowScrollBar (UINT nBar, BOOL bShow=TRUE)
Shows or hides a scroll bar.
BOOL | EnableScrollBar (int nSBFlags, UINT nArrowFlags=ESB_ENABLE_BOTH)
Enables or disables one or both arrows of a scroll bar.
void | RefreshScrollBarMetrics ()
Triggers update of color and size information for themed scroll bars.
void | OptimizeChildrenClipping ()
Applies WS_CLIPCHILDREN and WS_CLIPSIBLINGS styles the the container owner and all its immediate children windows in order prevent possible overlapping of children controls with scroll bars.
void | SetScrollBarClass (CRuntimeClass *pClass=NULL)
Sets a scroll bar class to be used for creating scroll bars.

Protected Member Functions

virtual void | RefreshMetrics ()
Call this member function to refresh theme colors and redraw the control.
void | PrintClient (CDC *pDC)
Called by the framework to draw the client area in the specified device context, most commonly in a printer device context.
- Protected Member Functions inherited from CXTPScrollBarContainer< CSplitterWnd >
CXTPScrollBarContainer ()
Constructs a CXTPScrollBarContainer object.

Protected Attributes

int | m_nHiddenCol
Index of the hidden column.
int | m_nHiddenRow
Index of the hidden row.
int | m_nFullDrag
1 to enable full drag, 0 to disable, or -1 to use system settings for full drag.
BOOL | m_bFullDrag
TRUE if full window dragging is enabled for the operating system.
BOOL | m_bDotTracker
TRUE to enable dotted tracker display.
BOOL | m_bNoSize
TRUE to disable splitter resizing.
BOOL | m_bShowBorder
TRUE to show a border around the client area.
BOOL | m_bClipStyles
Clip styles before dragging.
BOOL | m_bSubclassed
TRUE if the window was sub-classed.
CPoint | m_point
Previous cursor position.
CXTPSplitterWndTheme * | m_pTheme
Pointer to the current theme object.

Detailed Description

CXTPSplitterWnd is a CSplitterWnd derived class.

It adds the ability to hide and show splitter panes based upon its index.

Member Function Documentation

◆ EnableBorder()

void EnableBorder ( BOOL bBorder )

Call this member function to show/hide the borders for the splitter client area.

Parameters
bBorder TRUE to show borders, FALSE to hide.

◆ EnableDotTracker()

void EnableDotTracker ( BOOL bEnable )

Call this member function to enable dotted tracker display rather than the default.

Parameters
bEnable TRUE to enable dotted tracker display.

◆ EnableFullDrag()

void EnableFullDrag ( int nFullDrag )

Call this method to enable full drag windows.

Parameters
nFullDrag 1 to enable full drag, 0 to disable, or -1 to use system settings for full drag.

This member function will enable/disable the display of windows contents for each child pane while the splitter is resized if nFullDrag is set to 1.

◆ EnableNoSize()

void EnableNoSize ( BOOL bEnable )

Call this member function to disable resizing splitter pane windows.

Parameters
bEnable TRUE to disable splitter resizing.

◆ FullDragWindows()

BOOL FullDragWindows ( ) const

Call this member function to check if full window dragging is enabled.

Returns
TRUE if full window dragging is enabled, otherwise FALSE.

◆ GetHiddenColIndex()

int GetHiddenColIndex ( ) const

Call this member function to retrieve the index of the column that is currently hidden.

Returns
The index of the hidden column, or -1 if no columns are hidden.
See also
GetHiddenRowIndex

◆ GetHiddenRowIndex()

int GetHiddenRowIndex ( ) const

Call this member function to return the index of the row that is currently hidden.

Returns
The index of the hidden row, or -1 if no rows are hidden.
See also
GetHiddenColIndex

◆ GetTheme()

CXTPSplitterWndTheme * GetTheme ( ) const

Call this member function to get a pointer to the currently selected theme.

Returns
A pointer to a CXTPSplitterWndTheme object representing the currently selected theme.

◆ HideColumn()

virtual void HideColumn ( int nColHide )
virtual

This member function will hide a column based upon its index.

Parameters
nColHide Index of the column to hide.
See also
ShowColumn

◆ HideRow()

virtual void HideRow ( int nRowHide )
virtual

This member function will hide a row based upon its index.

Parameters
nRowHide Index of the row to hide.
See also
ShowRow

◆ IsBorderVisible()

BOOL IsBorderVisible ( ) const

Call this member function to determine the visibility of borders for the splitter client area.

Returns
TRUE if borders are shown, FALSE if borders are hidden.

◆ PrintClient()

void PrintClient ( CDC * pDC )
protected

Called by the framework to draw the client area in the specified device context, most commonly in a printer device context.

Parameters
pDC A pointer to the device context to draw in.

◆ ReplaceView() [1/2]

virtual CView * ReplaceView | ( | int | nRow,
 |  | int | nCol,
 |  | CRuntimeClass * | pViewClass )
 virtual

This member function is called to replace an existing splitter view with another.

Parameters
nRow | Specifies a row.
nCol | Specifies a column.
pViewClass | Specifies the runtime class to replace the specified pane with.
Returns
A CView pointer to the view that was replaced, otherwise NULL.
See also
SwitchView

◆ ReplaceView() [2/2]

virtual CView * ReplaceView | ( | int | nRow,
 |  | int | nCol,
 |  | CView * | pNewView )
 virtual

This member function is called to replace an existing splitter view with another.

Parameters
nRow | Specifies a row.
nCol | Specifies a column.
pNewView | Pointer to an already existing view.
Returns
A CView pointer to the view that was replaced, otherwise NULL.
See also
SwitchView

◆ SetActivePane()

virtual void SetActivePane | ( | int | row,
 |  | int | col,
 |  | CWnd * | pWnd = NULL )
 virtual

Sets a pane to be the active one in the frame.

This member function is called by the framework to set a pane as active when the user changes the focus to a pane within the frame window. You may explicitly call SetActivePane to change the focus to the specified view.

Specify the pane by providing either a row and column, or by providing pWnd.

Parameters
row | If pWnd is NULL, specifies the row in the pane that will be active.
col | If pWnd is NULL, specifies the column in the pane that will be active.
pWnd | A pointer to a CWnd object. If NULL, the pane specified by row and col is set active. If not NULL, specifies the pane that is set active.
See also
CSplitterWnd::GetActivePane, CSplitterWnd::GetPane, CFrameWnd::SetActiveView

◆ SetTheme() [1/2]

BOOL SetTheme ( CXTPSplitterWndTheme * pTheme )

Call this member to switch the visual theme of the control.

Parameters
pTheme New visual theme pointer.
Returns
TRUE if successful; otherwise FALSE.

◆ SetTheme() [2/2]

BOOL SetTheme ( XTPControlTheme eTheme )

Call this member to switch the visual theme of the control.

Parameters
eTheme New visual theme. Can be any of the values listed in the Remarks section.

eTheme can be one of the following: xtpControlThemeDefault: Use default theme. xtpControlThemeOfficeXP: Use Office XP theme. xtpControlThemeOffice2003: Use Office 2003 theme.

Returns
TRUE if successful; otherwise FALSE.

◆ ShowColumn()

virtual void ShowColumn ( )
virtual

This member function is called to show the column that was previously hidden.

See also
HideColumn

◆ ShowRow()

virtual void ShowRow ( )
virtual

This member function is called to show the row that was previously hidden.

See also
HideRow

◆ SwitchView()

virtual BOOL SwitchView | ( | int | nRow,
 |  | int | nCol,
 |  | CView * | pNewView )
 virtual

This member function is called to switch (or swap) a splitter view with another.

Parameters
nRow | Specifies a row.
nCol | Specifies a column.
pNewView | Specifies the view to switch the specified pane with.
Returns
TRUE if successful, otherwise FALSE.
See also
ReplaceView
The documentation for this class was generated from the following file:
  • XTPSplitterWnd.h


Toolkit Pro: CXTPSplitterWndEx Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPSplitterWndEx Class Reference

CXTPSplitterWndEx is a CXTPSplitterWnd derived class. More...

Inheritance diagram for CXTPSplitterWndEx:
[legend]

Public Member Functions

CXTPSplitterWndEx ()
Constructs a CXTPSplitterWndEx object.
virtual | ~CXTPSplitterWndEx ()
Destroys a CXTPSplitterWndEx object, handles cleanup and deallocation.
virtual void | ShowTopBorder (bool bShowTopBorder=true, int cyTopBorderGap=7)
Call this member function to show a top border for the splitter window, similar to Outlook.
virtual void | RecalcLayout ()
Call this member function to correctly redisplay the splitter window after you have adjusted row and column sizes with the SetRowInfo and SetColumnInfo member functions.
virtual void | OnDrawSplitter (CDC *pDC, ESplitType nType, const CRect &rectArg)
Renders an image of a split window.
- Public Member Functions inherited from CXTPSplitterWnd
CXTPSplitterWnd ()
Constructs a CXTPSplitterWnd object.
virtual | ~CXTPSplitterWnd ()
Destroys a CXTPSplitterWnd object, handles cleanup and deallocation.
BOOL | SetTheme (XTPControlTheme eTheme)
Call this member to switch the visual theme of the control.
BOOL | SetTheme (CXTPSplitterWndTheme *pTheme)
Call this member to switch the visual theme of the control.
CXTPSplitterWndTheme * | GetTheme () const
Call this member function to get a pointer to the currently selected theme.
virtual void | ShowColumn ()
This member function is called to show the column that was previously hidden.
virtual void | HideColumn (int nColHide)
This member function will hide a column based upon its index.
virtual void | ShowRow ()
This member function is called to show the row that was previously hidden.
virtual void | HideRow (int nRowHide)
This member function will hide a row based upon its index.
virtual BOOL | SwitchView (int nRow, int nCol, CView *pNewView)
This member function is called to switch (or swap) a splitter view with another.
virtual CView * | ReplaceView (int nRow, int nCol, CView *pNewView)
This member function is called to replace an existing splitter view with another.
virtual CView * | ReplaceView (int nRow, int nCol, CRuntimeClass *pViewClass)
This member function is called to replace an existing splitter view with another.
void | EnableFullDrag (int nFullDrag)
Call this method to enable full drag windows.
void | EnableDotTracker (BOOL bEnable)
Call this member function to enable dotted tracker display rather than the default.
void | EnableBorder (BOOL bBorder)
Call this member function to show/hide the borders for the splitter client area.
BOOL | IsBorderVisible () const
Call this member function to determine the visibility of borders for the splitter client area.
void | EnableNoSize (BOOL bEnable)
Call this member function to disable resizing splitter pane windows.
int | GetHiddenColIndex () const
Call this member function to retrieve the index of the column that is currently hidden.
int | GetHiddenRowIndex () const
Call this member function to return the index of the row that is currently hidden.
virtual void | SetActivePane (int row, int col, CWnd *pWnd=NULL)
Sets a pane to be the active one in the frame.
BOOL | FullDragWindows () const
Call this member function to check if full window dragging is enabled.
- Public Member Functions inherited from CXTPScrollBarContainer< CSplitterWnd >
void | SetScrollBarTheme (XTPScrollBarTheme theme)
Sets scroll bar theme.
BOOL | CreateScrollBarCtrl (DWORD dwStyle, UINT nID)
Creates a scroll bar control with ID and style specied.
virtual CScrollBar * | GetScrollBarCtrl (int nBar) const
Call this member function to obtain a pointer to the specified sibling scroll bar or splitter window.
void | ShowScrollBar (UINT nBar, BOOL bShow=TRUE)
Shows or hides a scroll bar.
BOOL | EnableScrollBar (int nSBFlags, UINT nArrowFlags=ESB_ENABLE_BOTH)
Enables or disables one or both arrows of a scroll bar.
void | RefreshScrollBarMetrics ()
Triggers update of color and size information for themed scroll bars.
void | OptimizeChildrenClipping ()
Applies WS_CLIPCHILDREN and WS_CLIPSIBLINGS styles the the container owner and all its immediate children windows in order prevent possible overlapping of children controls with scroll bars.
void | SetScrollBarClass (CRuntimeClass *pClass=NULL)
Sets a scroll bar class to be used for creating scroll bars.

Protected Member Functions

virtual void | GetInsideRect (CRect &rect) const
Called to retrieve the client area excluding the inside 3D borders.
- Protected Member Functions inherited from CXTPSplitterWnd
virtual void | RefreshMetrics ()
Call this member function to refresh theme colors and redraw the control.
void | PrintClient (CDC *pDC)
Called by the framework to draw the client area in the specified device context, most commonly in a printer device context.
- Protected Member Functions inherited from CXTPScrollBarContainer< CSplitterWnd >
CXTPScrollBarContainer ()
Constructs a CXTPScrollBarContainer object.

Protected Attributes

int | m_cyTopBorderGap
Size, in pixels, of the top border.
bool | m_bShowTopBorder
true to draw a top border line.
- Protected Attributes inherited from CXTPSplitterWnd
int | m_nHiddenCol
Index of the hidden column.
int | m_nHiddenRow
Index of the hidden row.
int | m_nFullDrag
1 to enable full drag, 0 to disable, or -1 to use system settings for full drag.
BOOL | m_bFullDrag
TRUE if full window dragging is enabled for the operating system.
BOOL | m_bDotTracker
TRUE to enable dotted tracker display.
BOOL | m_bNoSize
TRUE to disable splitter resizing.
BOOL | m_bShowBorder
TRUE to show a border around the client area.
BOOL | m_bClipStyles
Clip styles before dragging.
BOOL | m_bSubclassed
TRUE if the window was sub-classed.
CPoint | m_point
Previous cursor position.
CXTPSplitterWndTheme * | m_pTheme
Pointer to the current theme object.

Detailed Description

CXTPSplitterWndEx is a CXTPSplitterWnd derived class.

It can be used with the CXTPShortcutListBox to display a gap between the top of the splitter and the toolbar area.

Member Function Documentation

◆ GetInsideRect()

virtual void GetInsideRect ( CRect & rect ) const
protectedvirtual

Called to retrieve the client area excluding the inside 3D borders.

This member function is called by the splitter window to retrieve the size of the client area excluding any 3D borders.

Parameters
rect A reference to a CRect object to receive the size of the client area excluding borders.

◆ OnDrawSplitter()

virtual void OnDrawSplitter | ( | CDC * | pDC,
 |  | ESplitType | nType,
 |  | const CRect & | rectArg )
 virtual

Renders an image of a split window.

Parameters
pDC | A pointer to the device context in which to draw. If pDC is NULL, then CWnd::RedrawWindow is called by the framework and no split window is drawn.
nType | A value of the enum ESplitType. See the remarks section for a list of values.
rectArg | A reference to a CRect object specifying the size and shape of the split windows.

nType can be one of the following values:

splitBox: The splitter drag box. splitBar: The bar that appears between the two split windows. splitIntersection: The intersection of the split windows. This element will not be called when running on Windows 95. splitBorder: The split window borders.

This member function is called by the framework to draw and specify the exact characteristics of a splitter window.

Override OnDrawSplitter for advanced customization of the imagery for the various graphical components of a splitter window. The default imagery is similar to the splitter in Microsoft Works for Windows or Microsoft Windows 95, in that the intersections of the splitter bars are blended together.

For more on dynamic splitter windows, see "Splitter Windows" in the article Multiple Document Types, Views, and Frame Windows in Visual C++ Programmer's Guide, Technical Note 29, and the CSplitterWnd class overview.

See also
CSplitterWnd::OnInvertTracker

◆ RecalcLayout()

virtual void RecalcLayout ( )
virtual

Call this member function to correctly redisplay the splitter window after you have adjusted row and column sizes with the SetRowInfo and SetColumnInfo member functions.

If you change row and column sizes as a part of the creation process before the splitter window is visible, then it is not necessary to call this member function.

The framework calls this member function whenever the user resizes the splitter window or moves a split. Example: See the example for CSplitterWnd::SetColumnInfo.

◆ ShowTopBorder()

virtual void ShowTopBorder | ( | bool | bShowTopBorder = true,
 |  | int | cyTopBorderGap = 7 )
 virtual

Call this member function to show a top border for the splitter window, similar to Outlook.

Enabled by default.

Parameters
bShowTopBorder | true to show a top border for the splitter window, similar to Outlook. By default, this parameter is true.
cyTopBorderGap | The size, in pixels, for the top border. By default, this parameter is 7.
The documentation for this class was generated from the following file:
  • XTPSplitterWnd.h


Toolkit Pro: CXTPSplitterWndTheme Class Reference

Public Member Functions | Public Attributes | List of all members
CXTPSplitterWndTheme Class Reference

Class CXTPSplitterWndTheme is derived from CXTPControlTheme. More...

Inheritance diagram for CXTPSplitterWndTheme:
[legend]

Public Member Functions

CXTPSplitterWndTheme ()
Constructs a CXTPSplitterWndTheme object.
virtual void | RefreshMetrics ()
Call this function to set the splitter windows face and the borders to the system default colors.
virtual void | DrawSplitter (CDC *pDC, CXTPSplitterWnd *pSplitter, int nType, const CRect &rectArg)
Call this member function to draw the splitter window using the specified theme.
void | EnableTabColors (BOOL bEnable=TRUE)
Call this member function to use tab background color from resource.
virtual CBrush * | GetTrackBrush ()
Call this function to retrieve a pointer to the brush used by the split tracker.
- Public Member Functions inherited from CXTPControlTheme
CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme | GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Public Attributes

BOOL | m_bTabColors
TRUE to use tab background color from resource.
CXTPPaintManagerColorGradient | m_crBack
Splitter window background color.
CXTPPaintManagerColorGradient | m_crBoxBack
Splitter box window background color.
CXTPPaintManagerColorGradient | m_crOuterBorder
Splitter window outer border color.
CXTPPaintManagerColorGradient | m_crOuterBoxBorder
Splitter box window outer border color.
CXTPPaintManagerColorGradient | m_crInnerBorder
Splitter window inner border color.
CXTPPaintManagerColorGradient | m_crInnerBoxBorder
Splitter box window inner border color.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlTheme
static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Attributes inherited from CXTPControlTheme
XTPControlTheme | m_nTheme
Currently selected theme style index.

Detailed Description

Class CXTPSplitterWndTheme is derived from CXTPControlTheme.

This class is used to apply a theme to splitter windows.

Member Function Documentation

◆ DrawSplitter()

virtual void DrawSplitter | ( | CDC * | pDC,
 |  | CXTPSplitterWnd * | pSplitter,
 |  | int | nType,
 |  | const CRect & | rectArg )
 virtual

Call this member function to draw the splitter window using the specified theme.

Parameters
pDC | Pointer to the device context to draw to.
pSplitter | Pointer to the owner splitter window.
nType | Index value representing the splitter type; splitBox (0), splitBar (1), splitIntersection (2), or splitBorder (3).
rectArg | Size of the splitter area to draw.

Reimplemented in CXTPSplitterWndThemeOffice2003, and CXTPSplitterWndThemeVisualStudio2010.

◆ EnableTabColors()

void EnableTabColors ( BOOL bEnable = TRUE )

Call this member function to use tab background color from resource.

Parameters
bEnable TRUE to enable tab background color for splitter window.

◆ GetTrackBrush()

virtual CBrush * GetTrackBrush ( )
virtual

Call this function to retrieve a pointer to the brush used by the split tracker.

Returns
A pointer to a CBrush object representing the split tracker.

Reimplemented in CXTPSplitterWndThemeOfficeXP.

The documentation for this class was generated from the following file:
  • XTPSplitterWndTheme.h


Toolkit Pro: CXTPSplitterWndThemeOffice2003 Class Reference

Public Member Functions | List of all members
CXTPSplitterWndThemeOffice2003 Class Reference

Class CXTPSplitterWndThemeOffice2003 is derived from CXTPSplitterWndTheme. More...

Inheritance diagram for CXTPSplitterWndThemeOffice2003:
[legend]

Public Member Functions

CXTPSplitterWndThemeOffice2003 ()
Constructs a CXTPSplitterWndThemeOffice2003 object.
virtual void | RefreshMetrics ()
Call this function to set the splitter windows face and the borders to the system default colors.
virtual void | DrawSplitter (CDC *pDC, CXTPSplitterWnd *pSplitter, int nType, const CRect &rectArg)
Call this member function to draw the splitter window using the specified theme.
- Public Member Functions inherited from CXTPSplitterWndThemeOfficeXP
CXTPSplitterWndThemeOfficeXP ()
Constructs a CXTPSplitterWndThemeOfficeXP object.
virtual CBrush * | GetTrackBrush ()
Call this function to retrieve a pointer to the brush used by the split tracker.
- Public Member Functions inherited from CXTPSplitterWndTheme
CXTPSplitterWndTheme ()
Constructs a CXTPSplitterWndTheme object.
void | EnableTabColors (BOOL bEnable=TRUE)
Call this member function to use tab background color from resource.
- Public Member Functions inherited from CXTPControlTheme
CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme | GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlTheme
static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPSplitterWndTheme
BOOL | m_bTabColors
TRUE to use tab background color from resource.
CXTPPaintManagerColorGradient | m_crBack
Splitter window background color.
CXTPPaintManagerColorGradient | m_crBoxBack
Splitter box window background color.
CXTPPaintManagerColorGradient | m_crOuterBorder
Splitter window outer border color.
CXTPPaintManagerColorGradient | m_crOuterBoxBorder
Splitter box window outer border color.
CXTPPaintManagerColorGradient | m_crInnerBorder
Splitter window inner border color.
CXTPPaintManagerColorGradient | m_crInnerBoxBorder
Splitter box window inner border color.
- Protected Attributes inherited from CXTPControlTheme
XTPControlTheme | m_nTheme
Currently selected theme style index.

Detailed Description

Class CXTPSplitterWndThemeOffice2003 is derived from CXTPSplitterWndTheme.

This class is used to implement the Office 2003 theme for splitter windows.

Member Function Documentation

◆ DrawSplitter()

virtual void DrawSplitter | ( | CDC * | pDC,
 |  | CXTPSplitterWnd * | pSplitter,
 |  | int | nType,
 |  | const CRect & | rectArg )
 virtual

Call this member function to draw the splitter window using the specified theme.

Parameters
pDC | Pointer to the device context to draw to.
pSplitter | Pointer to the owner splitter window.
nType | Index value representing the splitter type; splitBox (0), splitBar (1), splitIntersection (2), or splitBorder (3).
rectArg | Size of the splitter area to draw.

Reimplemented from CXTPSplitterWndTheme.

Reimplemented in CXTPSplitterWndThemeVisualStudio2010.

The documentation for this class was generated from the following file:
  • XTPSplitterWndTheme.h


Toolkit Pro: CXTPSplitterWndThemeOffice2013 Class Reference

Public Member Functions | List of all members
CXTPSplitterWndThemeOffice2013 Class Reference

Class CXTPSplitterWndThemeOffice2013 is derived from CXTPSplitterWndThemeOfficeXP. More...

Inheritance diagram for CXTPSplitterWndThemeOffice2013:
[legend]

Public Member Functions

CXTPSplitterWndThemeOffice2013 ()
Constructs a CXTPSplitterWndThemeOffice2013 object.
virtual void | RefreshMetrics ()
Call this function to set the splitter windows face and the borders to the system default colors.
- Public Member Functions inherited from CXTPSplitterWndThemeOfficeXP
CXTPSplitterWndThemeOfficeXP ()
Constructs a CXTPSplitterWndThemeOfficeXP object.
virtual CBrush * | GetTrackBrush ()
Call this function to retrieve a pointer to the brush used by the split tracker.
- Public Member Functions inherited from CXTPSplitterWndTheme
CXTPSplitterWndTheme ()
Constructs a CXTPSplitterWndTheme object.
virtual void | DrawSplitter (CDC *pDC, CXTPSplitterWnd *pSplitter, int nType, const CRect &rectArg)
Call this member function to draw the splitter window using the specified theme.
void | EnableTabColors (BOOL bEnable=TRUE)
Call this member function to use tab background color from resource.
- Public Member Functions inherited from CXTPControlTheme
CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme | GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlTheme
static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPSplitterWndTheme
BOOL | m_bTabColors
TRUE to use tab background color from resource.
CXTPPaintManagerColorGradient | m_crBack
Splitter window background color.
CXTPPaintManagerColorGradient | m_crBoxBack
Splitter box window background color.
CXTPPaintManagerColorGradient | m_crOuterBorder
Splitter window outer border color.
CXTPPaintManagerColorGradient | m_crOuterBoxBorder
Splitter box window outer border color.
CXTPPaintManagerColorGradient | m_crInnerBorder
Splitter window inner border color.
CXTPPaintManagerColorGradient | m_crInnerBoxBorder
Splitter box window inner border color.
- Protected Attributes inherited from CXTPControlTheme
XTPControlTheme | m_nTheme
Currently selected theme style index.

Detailed Description

Class CXTPSplitterWndThemeOffice2013 is derived from CXTPSplitterWndThemeOfficeXP.

This class is used to implement the Office 2013 theme for splitter windows.

The documentation for this class was generated from the following file:
  • XTPSplitterWndTheme.h


Toolkit Pro: CXTPSplitterWndThemeOfficeXP Class Reference

Public Member Functions | List of all members
CXTPSplitterWndThemeOfficeXP Class Reference

Class CXTPSplitterWndThemeOfficeXP is derived from CXTPSplitterWndTheme. More...

Inheritance diagram for CXTPSplitterWndThemeOfficeXP:
[legend]

Public Member Functions

CXTPSplitterWndThemeOfficeXP ()
Constructs a CXTPSplitterWndThemeOfficeXP object.
virtual void | RefreshMetrics ()
Call this function to set the splitter windows face and the borders to the system default colors.
virtual CBrush * | GetTrackBrush ()
Call this function to retrieve a pointer to the brush used by the split tracker.
- Public Member Functions inherited from CXTPSplitterWndTheme
CXTPSplitterWndTheme ()
Constructs a CXTPSplitterWndTheme object.
virtual void | DrawSplitter (CDC *pDC, CXTPSplitterWnd *pSplitter, int nType, const CRect &rectArg)
Call this member function to draw the splitter window using the specified theme.
void | EnableTabColors (BOOL bEnable=TRUE)
Call this member function to use tab background color from resource.
- Public Member Functions inherited from CXTPControlTheme
CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme | GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlTheme
static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPSplitterWndTheme
BOOL | m_bTabColors
TRUE to use tab background color from resource.
CXTPPaintManagerColorGradient | m_crBack
Splitter window background color.
CXTPPaintManagerColorGradient | m_crBoxBack
Splitter box window background color.
CXTPPaintManagerColorGradient | m_crOuterBorder
Splitter window outer border color.
CXTPPaintManagerColorGradient | m_crOuterBoxBorder
Splitter box window outer border color.
CXTPPaintManagerColorGradient | m_crInnerBorder
Splitter window inner border color.
CXTPPaintManagerColorGradient | m_crInnerBoxBorder
Splitter box window inner border color.
- Protected Attributes inherited from CXTPControlTheme
XTPControlTheme | m_nTheme
Currently selected theme style index.

Detailed Description

Class CXTPSplitterWndThemeOfficeXP is derived from CXTPSplitterWndTheme.

This class is used to implement the Office XP theme for splitter windows.

Member Function Documentation

◆ GetTrackBrush()

virtual CBrush * GetTrackBrush ( )
virtual

Call this function to retrieve a pointer to the brush used by the split tracker.

Returns
A pointer to a CBrush object representing the split tracker.

Reimplemented from CXTPSplitterWndTheme.

The documentation for this class was generated from the following file:
  • XTPSplitterWndTheme.h


Toolkit Pro: CXTPSplitterWndThemeResource Class Reference

Public Member Functions | List of all members
CXTPSplitterWndThemeResource Class Reference

Class CXTPSplitterWndThemeResource is derived from CXTPSplitterWndTheme. More...

Inheritance diagram for CXTPSplitterWndThemeResource:
[legend]

Public Member Functions

CXTPSplitterWndThemeResource ()
Constructs a CXTPSplitterWndThemeResource object.
virtual void | RefreshMetrics ()
Call this function to set the splitter windows face and the borders to the system default colors.
- Public Member Functions inherited from CXTPSplitterWndThemeOffice2003
CXTPSplitterWndThemeOffice2003 ()
Constructs a CXTPSplitterWndThemeOffice2003 object.
virtual void | DrawSplitter (CDC *pDC, CXTPSplitterWnd *pSplitter, int nType, const CRect &rectArg)
Call this member function to draw the splitter window using the specified theme.
- Public Member Functions inherited from CXTPSplitterWndThemeOfficeXP
CXTPSplitterWndThemeOfficeXP ()
Constructs a CXTPSplitterWndThemeOfficeXP object.
virtual CBrush * | GetTrackBrush ()
Call this function to retrieve a pointer to the brush used by the split tracker.
- Public Member Functions inherited from CXTPSplitterWndTheme
CXTPSplitterWndTheme ()
Constructs a CXTPSplitterWndTheme object.
void | EnableTabColors (BOOL bEnable=TRUE)
Call this member function to use tab background color from resource.
- Public Member Functions inherited from CXTPControlTheme
CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme | GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlTheme
static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPSplitterWndTheme
BOOL | m_bTabColors
TRUE to use tab background color from resource.
CXTPPaintManagerColorGradient | m_crBack
Splitter window background color.
CXTPPaintManagerColorGradient | m_crBoxBack
Splitter box window background color.
CXTPPaintManagerColorGradient | m_crOuterBorder
Splitter window outer border color.
CXTPPaintManagerColorGradient | m_crOuterBoxBorder
Splitter box window outer border color.
CXTPPaintManagerColorGradient | m_crInnerBorder
Splitter window inner border color.
CXTPPaintManagerColorGradient | m_crInnerBoxBorder
Splitter box window inner border color.
- Protected Attributes inherited from CXTPControlTheme
XTPControlTheme | m_nTheme
Currently selected theme style index.

Detailed Description

Class CXTPSplitterWndThemeResource is derived from CXTPSplitterWndTheme.

This class is used to implement the Office 2007/2010 theme for splitter windows.

The documentation for this class was generated from the following file:
  • XTPSplitterWndTheme.h


Toolkit Pro: CXTPSplitterWndThemeVisualStudio2010 Class Reference

Public Member Functions | List of all members
CXTPSplitterWndThemeVisualStudio2010 Class Reference

Class CXTPSplitterWndThemeVisualStudio2010 is derived from CXTPSplitterWndTheme. More...

Inheritance diagram for CXTPSplitterWndThemeVisualStudio2010:
[legend]

Public Member Functions

CXTPSplitterWndThemeVisualStudio2010 ()
Constructs a CXTPSplitterWndThemeVisualStudio2010 object.
virtual void | RefreshMetrics ()
Call this function to set the splitter windows face and the borders to the system default colors.
virtual void | DrawSplitter (CDC *pDC, CXTPSplitterWnd *pSplitter, int nType, const CRect &rectArg)
Call this member function to draw the splitter window using the specified theme.
- Public Member Functions inherited from CXTPSplitterWndThemeOffice2003
CXTPSplitterWndThemeOffice2003 ()
Constructs a CXTPSplitterWndThemeOffice2003 object.
- Public Member Functions inherited from CXTPSplitterWndThemeOfficeXP
CXTPSplitterWndThemeOfficeXP ()
Constructs a CXTPSplitterWndThemeOfficeXP object.
virtual CBrush * | GetTrackBrush ()
Call this function to retrieve a pointer to the brush used by the split tracker.
- Public Member Functions inherited from CXTPSplitterWndTheme
CXTPSplitterWndTheme ()
Constructs a CXTPSplitterWndTheme object.
void | EnableTabColors (BOOL bEnable=TRUE)
Call this member function to use tab background color from resource.
- Public Member Functions inherited from CXTPControlTheme
CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme | GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlTheme
static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPSplitterWndTheme
BOOL | m_bTabColors
TRUE to use tab background color from resource.
CXTPPaintManagerColorGradient | m_crBack
Splitter window background color.
CXTPPaintManagerColorGradient | m_crBoxBack
Splitter box window background color.
CXTPPaintManagerColorGradient | m_crOuterBorder
Splitter window outer border color.
CXTPPaintManagerColorGradient | m_crOuterBoxBorder
Splitter box window outer border color.
CXTPPaintManagerColorGradient | m_crInnerBorder
Splitter window inner border color.
CXTPPaintManagerColorGradient | m_crInnerBoxBorder
Splitter box window inner border color.
- Protected Attributes inherited from CXTPControlTheme
XTPControlTheme | m_nTheme
Currently selected theme style index.

Detailed Description

Class CXTPSplitterWndThemeVisualStudio2010 is derived from CXTPSplitterWndTheme.

This class is used to implement the Visual Studio 2010 theme for splitter windows.

Member Function Documentation

◆ DrawSplitter()

virtual void DrawSplitter | ( | CDC * | pDC,
 |  | CXTPSplitterWnd * | pSplitter,
 |  | int | nType,
 |  | const CRect & | rectArg )
 virtual

Call this member function to draw the splitter window using the specified theme.

Parameters
pDC | Pointer to the device context to draw to.
pSplitter | Pointer to the owner splitter window.
nType | Index value representing the splitter type; splitBox (0), splitBar (1), splitIntersection (2), or splitBorder (3).
rectArg | Size of the splitter area to draw.

Reimplemented from CXTPSplitterWndThemeOffice2003.

The documentation for this class was generated from the following file:
  • XTPSplitterWndTheme.h


Toolkit Pro: CXTPSplitterWndThemeVisualStudio2015 Class Reference

Public Member Functions | List of all members
CXTPSplitterWndThemeVisualStudio2015 Class Reference

Class CXTPSplitterWndThemeVisualStudio2015 is derived from CXTPSplitterWndThemeOffice2013. More...

Inheritance diagram for CXTPSplitterWndThemeVisualStudio2015:
[legend]

Public Member Functions

CXTPSplitterWndThemeVisualStudio2015 ()
Constructs a CXTPSplitterWndThemeVisualStudio2015 object.
- Public Member Functions inherited from CXTPSplitterWndThemeOffice2013
CXTPSplitterWndThemeOffice2013 ()
Constructs a CXTPSplitterWndThemeOffice2013 object.
virtual void | RefreshMetrics ()
Call this function to set the splitter windows face and the borders to the system default colors.
- Public Member Functions inherited from CXTPSplitterWndThemeOfficeXP
CXTPSplitterWndThemeOfficeXP ()
Constructs a CXTPSplitterWndThemeOfficeXP object.
virtual CBrush * | GetTrackBrush ()
Call this function to retrieve a pointer to the brush used by the split tracker.
- Public Member Functions inherited from CXTPSplitterWndTheme
CXTPSplitterWndTheme ()
Constructs a CXTPSplitterWndTheme object.
virtual void | DrawSplitter (CDC *pDC, CXTPSplitterWnd *pSplitter, int nType, const CRect &rectArg)
Call this member function to draw the splitter window using the specified theme.
void | EnableTabColors (BOOL bEnable=TRUE)
Call this member function to use tab background color from resource.
- Public Member Functions inherited from CXTPControlTheme
CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme | GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlTheme
static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPSplitterWndTheme
BOOL | m_bTabColors
TRUE to use tab background color from resource.
CXTPPaintManagerColorGradient | m_crBack
Splitter window background color.
CXTPPaintManagerColorGradient | m_crBoxBack
Splitter box window background color.
CXTPPaintManagerColorGradient | m_crOuterBorder
Splitter window outer border color.
CXTPPaintManagerColorGradient | m_crOuterBoxBorder
Splitter box window outer border color.
CXTPPaintManagerColorGradient | m_crInnerBorder
Splitter window inner border color.
CXTPPaintManagerColorGradient | m_crInnerBoxBorder
Splitter box window inner border color.
- Protected Attributes inherited from CXTPControlTheme
XTPControlTheme | m_nTheme
Currently selected theme style index.

Detailed Description

Class CXTPSplitterWndThemeVisualStudio2015 is derived from CXTPSplitterWndThemeOffice2013.

This class is used to implement the Visual Studio 2015 theme for splitter windows.

The documentation for this class was generated from the following file:
  • XTPSplitterWndTheme.h


Toolkit Pro: CXTPSplitterWndThemeVisualStudio2017 Class Reference

Public Member Functions | List of all members
CXTPSplitterWndThemeVisualStudio2017 Class Reference

Class CXTPSplitterWndThemeVisualStudio2017 is derived from CXTPSplitterWndThemeOffice2013. More...

Inheritance diagram for CXTPSplitterWndThemeVisualStudio2017:
[legend]

Public Member Functions

CXTPSplitterWndThemeVisualStudio2017 ()
Constructs a CXTPSplitterWndThemeVisualStudio2017 object.
- Public Member Functions inherited from CXTPSplitterWndThemeOffice2013
CXTPSplitterWndThemeOffice2013 ()
Constructs a CXTPSplitterWndThemeOffice2013 object.
virtual void | RefreshMetrics ()
Call this function to set the splitter windows face and the borders to the system default colors.
- Public Member Functions inherited from CXTPSplitterWndThemeOfficeXP
CXTPSplitterWndThemeOfficeXP ()
Constructs a CXTPSplitterWndThemeOfficeXP object.
virtual CBrush * | GetTrackBrush ()
Call this function to retrieve a pointer to the brush used by the split tracker.
- Public Member Functions inherited from CXTPSplitterWndTheme
CXTPSplitterWndTheme ()
Constructs a CXTPSplitterWndTheme object.
virtual void | DrawSplitter (CDC *pDC, CXTPSplitterWnd *pSplitter, int nType, const CRect &rectArg)
Call this member function to draw the splitter window using the specified theme.
void | EnableTabColors (BOOL bEnable=TRUE)
Call this member function to use tab background color from resource.
- Public Member Functions inherited from CXTPControlTheme
CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme | GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlTheme
static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPSplitterWndTheme
BOOL | m_bTabColors
TRUE to use tab background color from resource.
CXTPPaintManagerColorGradient | m_crBack
Splitter window background color.
CXTPPaintManagerColorGradient | m_crBoxBack
Splitter box window background color.
CXTPPaintManagerColorGradient | m_crOuterBorder
Splitter window outer border color.
CXTPPaintManagerColorGradient | m_crOuterBoxBorder
Splitter box window outer border color.
CXTPPaintManagerColorGradient | m_crInnerBorder
Splitter window inner border color.
CXTPPaintManagerColorGradient | m_crInnerBoxBorder
Splitter box window inner border color.
- Protected Attributes inherited from CXTPControlTheme
XTPControlTheme | m_nTheme
Currently selected theme style index.

Detailed Description

Class CXTPSplitterWndThemeVisualStudio2017 is derived from CXTPSplitterWndThemeOffice2013.

This class is used to implement the Visual Studio 2017 theme for splitter windows.

The documentation for this class was generated from the following file:
  • XTPSplitterWndTheme.h


Toolkit Pro: CXTPSplitterWndThemeVisualStudio2019 Class Reference

Public Member Functions | List of all members
CXTPSplitterWndThemeVisualStudio2019 Class Reference

Class CXTPSplitterWndThemeVisualStudio2019 is derived from CXTPSplitterWndThemeOffice2013. More...

Inheritance diagram for CXTPSplitterWndThemeVisualStudio2019:
[legend]

Public Member Functions

CXTPSplitterWndThemeVisualStudio2019 ()
Constructs a CXTPSplitterWndThemeVisualStudio2019 object.
- Public Member Functions inherited from CXTPSplitterWndThemeOffice2013
CXTPSplitterWndThemeOffice2013 ()
Constructs a CXTPSplitterWndThemeOffice2013 object.
virtual void | RefreshMetrics ()
Call this function to set the splitter windows face and the borders to the system default colors.
- Public Member Functions inherited from CXTPSplitterWndThemeOfficeXP
CXTPSplitterWndThemeOfficeXP ()
Constructs a CXTPSplitterWndThemeOfficeXP object.
virtual CBrush * | GetTrackBrush ()
Call this function to retrieve a pointer to the brush used by the split tracker.
- Public Member Functions inherited from CXTPSplitterWndTheme
CXTPSplitterWndTheme ()
Constructs a CXTPSplitterWndTheme object.
virtual void | DrawSplitter (CDC *pDC, CXTPSplitterWnd *pSplitter, int nType, const CRect &rectArg)
Call this member function to draw the splitter window using the specified theme.
void | EnableTabColors (BOOL bEnable=TRUE)
Call this member function to use tab background color from resource.
- Public Member Functions inherited from CXTPControlTheme
CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme | GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlTheme
static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPSplitterWndTheme
BOOL | m_bTabColors
TRUE to use tab background color from resource.
CXTPPaintManagerColorGradient | m_crBack
Splitter window background color.
CXTPPaintManagerColorGradient | m_crBoxBack
Splitter box window background color.
CXTPPaintManagerColorGradient | m_crOuterBorder
Splitter window outer border color.
CXTPPaintManagerColorGradient | m_crOuterBoxBorder
Splitter box window outer border color.
CXTPPaintManagerColorGradient | m_crInnerBorder
Splitter window inner border color.
CXTPPaintManagerColorGradient | m_crInnerBoxBorder
Splitter box window inner border color.
- Protected Attributes inherited from CXTPControlTheme
XTPControlTheme | m_nTheme
Currently selected theme style index.

Detailed Description

Class CXTPSplitterWndThemeVisualStudio2019 is derived from CXTPSplitterWndThemeOffice2013.

This class is used to implement the Visual Studio 2019 theme for splitter windows.

The documentation for this class was generated from the following file:
  • XTPSplitterWndTheme.h


Toolkit Pro: CXTPSplitterWndThemeVisualStudio2022 Class Reference

Public Member Functions | List of all members
CXTPSplitterWndThemeVisualStudio2022 Class Reference

Class CXTPSplitterWndThemeVisualStudio2022 is derived from CXTPSplitterWndThemeOffice2013. More...

Inheritance diagram for CXTPSplitterWndThemeVisualStudio2022:
[legend]

Public Member Functions

CXTPSplitterWndThemeVisualStudio2022 ()
Constructs a CXTPSplitterWndThemeVisualStudio2022 object.
- Public Member Functions inherited from CXTPSplitterWndThemeOffice2013
CXTPSplitterWndThemeOffice2013 ()
Constructs a CXTPSplitterWndThemeOffice2013 object.
virtual void | RefreshMetrics ()
Call this function to set the splitter windows face and the borders to the system default colors.
- Public Member Functions inherited from CXTPSplitterWndThemeOfficeXP
CXTPSplitterWndThemeOfficeXP ()
Constructs a CXTPSplitterWndThemeOfficeXP object.
virtual CBrush * | GetTrackBrush ()
Call this function to retrieve a pointer to the brush used by the split tracker.
- Public Member Functions inherited from CXTPSplitterWndTheme
CXTPSplitterWndTheme ()
Constructs a CXTPSplitterWndTheme object.
virtual void | DrawSplitter (CDC *pDC, CXTPSplitterWnd *pSplitter, int nType, const CRect &rectArg)
Call this member function to draw the splitter window using the specified theme.
void | EnableTabColors (BOOL bEnable=TRUE)
Call this member function to use tab background color from resource.
- Public Member Functions inherited from CXTPControlTheme
CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme | GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlTheme
static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPSplitterWndTheme
BOOL | m_bTabColors
TRUE to use tab background color from resource.
CXTPPaintManagerColorGradient | m_crBack
Splitter window background color.
CXTPPaintManagerColorGradient | m_crBoxBack
Splitter box window background color.
CXTPPaintManagerColorGradient | m_crOuterBorder
Splitter window outer border color.
CXTPPaintManagerColorGradient | m_crOuterBoxBorder
Splitter box window outer border color.
CXTPPaintManagerColorGradient | m_crInnerBorder
Splitter window inner border color.
CXTPPaintManagerColorGradient | m_crInnerBoxBorder
Splitter box window inner border color.
- Protected Attributes inherited from CXTPControlTheme
XTPControlTheme | m_nTheme
Currently selected theme style index.

Detailed Description

Class CXTPSplitterWndThemeVisualStudio2022 is derived from CXTPSplitterWndThemeOffice2013.

This class is used to implement the Visual Studio 2022 theme for splitter windows.

The documentation for this class was generated from the following file:
  • XTPSplitterWndTheme.h


Toolkit Pro: CXTPStatusBar Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPStatusBar Class Reference

CXTPStatusBar is a CControlBar derived class. More...

Public Member Functions

CXTPStatusBar ()
Constructs a CXTPStatusBar object.
virtual | ~CXTPStatusBar ()
Destroys a CXTPStatusBar object, handles cleanup and deallocation.
BOOL | Create (CWnd *pParentWnd, DWORD dwStyle=WS_CHILD|WS_VISIBLE|CBRS_BOTTOM|WS_CLIPCHILDREN|WS_CLIPSIBLINGS, UINT nID=AFX_IDW_STATUS_BAR)
Creates a status bar (a child window) and associates it with the CStatusBar object.
BOOL | SetIndicators (const UINT *lpIDArray, int nIDCount)
Sets each indicator's ID to the value specified by the corresponding element of the array lpIDArray, loads the string resource specified by each ID, and sets the indicator's text to the string.
void | SetCommandBars (CXTPCommandBars *pCommandBars)
Call this member to set the command bar's object.
CXTPPaintManager * | GetPaintManager () const
Retrieves the paint manager.
CXTPStatusBarPaintManager * | GetStatusBarPaintManager () const
Retrieves the status bar paint manager.
void | PositionControls ()
This member function is called by the status bar to reposition pane item controls.
BOOL | AddControl (CWnd *pWnd, UINT nID, BOOL bAutoDelete=TRUE)
Call this member function to add a control to an indicator pane.
void | SetPaneWidth (int nIndex, int cxText)
Call this member function to set the width for an indicator pane.
CXTPStatusBarPane * | AddIndicator (UINT nID, int nIndex=-1)
Call this member function to add an indicator pane to the status bar.
CXTPStatusBarPane * | AddIndicator (CXTPStatusBarPane *pPane, UINT nID, int nIndex=-1)
Call this member function to add an indicator pane to the status bar.
BOOL | RemoveIndicator (UINT nID)
Call this member function to remove an indicator pane from the status bar.
int | GetPaneCount () const
Call this member function to return the number of panes that are created for the status bar.
int | GetVisiblePaneCount () const
Calculates the total number of visible panes.
CXTPStatusBarPane * | GetPane (int nIndex) const
Call this member function to get the pane information for the given index.
CXTPStatusBarPane * | FindPane (UINT nID) const
Call this member function to find the pane for the given identifier.
void | RemoveAll ()
Call this member function to remove all indicators.
BOOL | RemoveAt (int nIndex)
Call this member function to remove an indicator pane from the status bar.
CXTPImageManager * | GetImageManager () const
Call this member to retrieve the image manager of the image manager.
CXTPStatusBarPane * | HitTest (CPoint pt, CRect *lpRect=NULL) const
Determines which pane, if any, is at a specified screen position.
void | EnableCustomization (BOOL bEnable=TRUE)
Call this method to enable/disable customization of the status bar.
void | LoadState (LPCTSTR lpszProfileName)
Retrieves state information from the registry or .INI file.
void | SaveState (LPCTSTR lpszProfileName)
Saves state information to the registry or .INI file.
virtual void | DoPropExchange (CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
void | SetDrawDisabledText (BOOL bDraw)
Call this member function to set the paint manager to draw disabled text.
BOOL | GetDrawDisabledText () const
Call this member function to check if the paint manager will draw disabled text.
CXTPToolTipContext * | GetToolTipContext () const
Call this method to get a pointer to the tooltip context.
virtual void | DrawPaneEntry (CDC *pDC, int nIndex, CRect rcItem)
This method is called to draw a single pane of the status bar.
BOOL | CreateEx (CWnd *pParentWnd, DWORD dwCtrlStyle=0, DWORD dwStyle=WS_CHILD|WS_VISIBLE|CBRS_BOTTOM, UINT nID=AFX_IDW_STATUS_BAR)
Call this function to create a status bar.
int | CommandToIndex (UINT nIDFind) const
Gets the indicator index for a given ID.
UINT | GetItemID (int nIndex) const
Returns the ID of the indicator specified by nIndex.
void | GetItemRect (int nIndex, LPRECT lpRect) const
Copies the coordinates of the indicator specified by nIndex into the structure pointed to by lpRect.
CString | GetPaneText (int nIndex) const
Call this member function to retrieve the text that appears in a status bar pane.
void | GetPaneText (int nIndex, CString &rString) const
Call this member function to retrieve the text that appears in a status bar pane.
BOOL | SetPaneText (int nIndex, LPCTSTR lpszNewText)
Sets the pane text to the string pointed to by lpszNewText.
void | GetPaneInfo (int nIndex, UINT &nID, UINT &nStyle, int &cxWidth) const
Sets nID, nStyle, and cxWidth to the ID, style, and width of the indicator pane at the location specified by nIndex.
void | SetPaneInfo (int nIndex, UINT nID, UINT nStyle, int cxWidth)
Sets the specified indicator pane to a new ID, style, and width.
UINT | GetPaneStyle (int nIndex) const
Call this member function to retrieve the style of a status bar's pane.
void | SetPaneStyle (int nIndex, UINT nStyle)
Call this member function to set the style of a status bar's pane.
CStatusBarCtrl & | GetStatusBarCtrl () const
This member function allows direct access to the underlying common control.
void | SetFont (CFont *pFont, BOOL bRedraw=TRUE)
Call this method to set the font for the status bar.
CFont * | GetFont ()
Call this method to get the font for the status bar.
void | SetRibbonDividerIndex (int nIndex)
Sets the position of the ribbon divider index.
int | GetRibbonDividerIndex () const
Gets the position of the ribbon divider index.
void | EnableMarkup (BOOL bEnableMarkup=TRUE)
Allows the use of a XAML snippet to be used for the text of panes in the status Bar.
CXTPMarkupContext * | GetMarkupContext () const
Retrieves a pointer to the markup context.
virtual void | RecalcLayout ()
Call this method to reposition all panes.

Protected Member Functions

virtual void DrawStretch (CDC *pDC, CRect &rcClient)
Draws the stretch gripper of the status bar.

Protected Attributes

CArray< CXTPStatusBarPane *, CXTPStatusBarPane * > | m_arrPanes
Array of panes.
int | m_nMinHeight
Minimum client height.
CXTPFont | m_xtpFontStatus
Font of status bar.
BOOL | m_bShowSizeGripper
TRUE to show size gripper.
BOOL | m_bDrawDisabledText
TRUE to draw disabled text.
CXTPStatusBarPane * | m_pHighlightedPane
Pane currently highlighted.
int | m_nRibbonDividerIndex
Position of dark part for Ribbon Theme.
CXTPMarkupContext * | m_pMarkupContext
Markup Context.
int | m_cxPaneSpacing
Gap between panes.
int | m_bCustomizable
TRUE to allow customize status bar.

Detailed Description

CXTPStatusBar is a CControlBar derived class.

Member Function Documentation

◆ AddControl()

BOOL AddControl | ( | CWnd * | pWnd,
 |  | UINT | nID,
 |  | BOOL | bAutoDelete = TRUE )

Call this member function to add a control to an indicator pane.

Parameters
pWnd | Pointer to a control window.
nID | ID of the indicator pane.
bAutoDelete | TRUE if the control is to be deleted when destroyed.
Returns
TRUE if successful, otherwise FALSE.

◆ AddIndicator() [1/2]

CXTPStatusBarPane * AddIndicator | ( | CXTPStatusBarPane * | pPane,
 |  | UINT | nID,
 |  | int | nIndex = -1 )

Call this member function to add an indicator pane to the status bar.

Parameters
nID | ID of the indicator pane.
nIndex | Index of the indicator pane.
pPane | New CXTPStatusBarPane object.
Returns
CXTPStatusBarPane pointer if successful, otherwise NULL.

◆ AddIndicator() [2/2]

CXTPStatusBarPane * AddIndicator | ( | UINT | nID,
 |  | int | nIndex = -1 )

Call this member function to add an indicator pane to the status bar.

Parameters
nID | ID of the indicator pane.
nIndex | Index of the indicator pane.
Returns
CXTPStatusBarPane pointer if successful, otherwise NULL.

◆ CommandToIndex()

int CommandToIndex ( UINT nIDFind ) const

Gets the indicator index for a given ID.

The index of the first indicator is 0.

Parameters
nIDFind String ID of the indicator whose index is to be retrieved.
Returns
The index of the indicator if successful; -1 if not successful.
See also
GetItemID

◆ Create()

BOOL Create | ( | CWnd * | pParentWnd,
 |  | DWORD | dwStyle = WS_CHILD|WS_VISIBLE|CBRS_BOTTOM|WS_CLIPCHILDREN|WS_CLIPSIBLINGS,
 |  | UINT | nID = AFX_IDW_STATUS_BAR )

Creates a status bar (a child window) and associates it with the CStatusBar object.

Also sets the initial font and sets the status bar's height to a default value.

Parameters
pParentWnd | Pointer to the CWnd object whose Windows window is the parent of the status bar.
dwStyle | The status bar window style's bits.
nID | The toolbar's child-window ID.
Returns
Nonzero if successful; otherwise 0.

◆ CreateEx()

BOOL CreateEx | ( | CWnd * | pParentWnd,
 |  | DWORD | dwCtrlStyle = 0,
 |  | DWORD | dwStyle = WS_CHILD|WS_VISIBLE|CBRS_BOTTOM,
 |  | UINT | nID = AFX_IDW_STATUS_BAR )

Call this function to create a status bar.

Parameters
pParentWnd | Pointer to the CWnd object whose Windows window is the parent of the status bar.
dwCtrlStyle | Additional styles for the creation of the embedded CStatusBarCtrl object.
dwStyle | The status bar style.
nID | The status bar's child-window ID.
Returns
Nonzero if successful; otherwise 0.

◆ DoPropExchange()

virtual void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Reads this object from or writes this object to an archive.

Parameters
pPX A CXTPPropExchange object to serialize to or from.

◆ DrawPaneEntry()

virtual void DrawPaneEntry | ( | CDC * | pDC,
 |  | int | nIndex,
 |  | CRect | rcItem )
 virtual

This method is called to draw a single pane of the status bar.

Parameters
pDC | Pointer to a valid device context.
nIndex | Index of the pane to draw.
rcItem | Bounding rectangle of the pane.

◆ DrawStretch()

virtual void DrawStretch | ( | CDC * | pDC,
 |  | CRect & | rcClient )
 protectedvirtual

Draws the stretch gripper of the status bar.

Parameters
pDC | Pointer to a valid device context.
rcClient | Client rectangle.

◆ EnableCustomization()

void EnableCustomization ( BOOL bEnable = TRUE )

Call this method to enable/disable customization of the status bar.

Parameters
bEnable TRUE to enable customization, FALSE to disable customization.

◆ EnableMarkup()

void EnableMarkup ( BOOL bEnableMarkup = TRUE )

Allows the use of a XAML snippet to be used for the text of panes in the status Bar.

Parameters
bEnableMarkup TRUE to enable markup, FALSE to disable markup.

◆ FindPane()

CXTPStatusBarPane * FindPane ( UINT nID ) const

Call this member function to find the pane for the given identifier.

Parameters
nID Identifier of the indicator pane.
Returns
A pointer to a CXTPStatusBarPane class.

◆ GetDrawDisabledText()

AFX_INLINE BOOL GetDrawDisabledText ( ) const

Call this member function to check if the paint manager will draw disabled text.

Returns
TRUE if the paint manager will draw disabled text, otherwise FALSE.

◆ GetFont()

CFont * GetFont ( )

Call this method to get the font for the status bar.

Returns
Font used for the status bar.

◆ GetImageManager()

CXTPImageManager * GetImageManager ( ) const

Call this member to retrieve the image manager of the image manager.

Returns
A pointer to a CXTPImageManager object

◆ GetItemID()

UINT GetItemID ( int nIndex ) const

Returns the ID of the indicator specified by nIndex.

Parameters
nIndex Index of the indicator whose ID is to be retrieved.
Returns
The ID of the indicator specified by nIndex.
See also
CommandToIndex

◆ GetItemRect()

void GetItemRect | ( | int | nIndex,
 |  | LPRECT | lpRect ) const

Copies the coordinates of the indicator specified by nIndex into the structure pointed to by lpRect.

Coordinates are in pixels relative to the upper-left corner of the status bar.

Parameters
nIndex | Index of the indicator whose rectangle coordinates are to be retrieved.
lpRect | Pointer to a RECT structure or a CRect object that will receive the coordinates of the indicator specified by nIndex.
See also
GetPaneInfo, CommandToIndex

◆ GetMarkupContext()

AFX_INLINE CXTPMarkupContext * GetMarkupContext ( ) const

Retrieves a pointer to the markup context.

Returns
A pointer to a CXTPMarkupContext object.

◆ GetPaintManager()

CXTPPaintManager * GetPaintManager ( ) const

Retrieves the paint manager.

Returns
A pointer to a CXTPPaintManager object.

◆ GetPane()

CXTPStatusBarPane * GetPane ( int nIndex ) const

Call this member function to get the pane information for the given index.

Parameters
nIndex Index of the indicator pane.
Returns
A pointer to a CXTPStatusBarPane class.

◆ GetPaneCount()

AFX_INLINE int GetPaneCount ( ) const

Call this member function to return the number of panes that are created for the status bar.

Returns
An integer value that represents the number of panes for the status bar.

◆ GetPaneInfo()

void GetPaneInfo | ( | int | nIndex,
 |  | UINT & | nID,
 |  | UINT & | nStyle,
 |  | int & | cxWidth ) const

Sets nID, nStyle, and cxWidth to the ID, style, and width of the indicator pane at the location specified by nIndex.

Parameters
nIndex | Index of the pane whose information is to be retrieved.
nID | Reference to a UINT that is set to the ID of the pane.
nStyle | Reference to a UINT that is set to the style of the pane.
cxWidth | Reference to an integer that is set to the width of the pane.
See also
SetPaneInfo, GetItemRect

◆ GetPaneStyle()

UINT GetPaneStyle ( int nIndex ) const

Call this member function to retrieve the style of a status bar's pane.

A pane's style determines how the pane appears.

Parameters
nIndex Index of the pane whose style is to be retrieved.
Returns
The style of the status bar pane specified by nIndex.
See also
SetPaneStyle

◆ GetPaneText() [1/2]

CString GetPaneText ( int nIndex ) const

Call this member function to retrieve the text that appears in a status bar pane.

The second form of this member function fills a CString object with the string text.

Parameters
nIndex Index of the pane whose text is to be retrieved.
Returns
Returns the text that appears in a status bar pane
See also
SetPaneText

◆ GetPaneText() [2/2]

void GetPaneText | ( | int | nIndex,
 |  | CString & | rString ) const

Call this member function to retrieve the text that appears in a status bar pane.

The second form of this member function fills a CString object with the string text.

Parameters
nIndex | Index of the pane whose text is to be retrieved.
rString | A reference to a CString object that contains the text to be retrieved.
See also
SetPaneText

◆ GetRibbonDividerIndex()

AFX_INLINE int GetRibbonDividerIndex ( ) const

Gets the position of the ribbon divider index.

Returns
Position of the ribbon bar divider.

◆ GetStatusBarCtrl()

AFX_INLINE CStatusBarCtrl & GetStatusBarCtrl ( ) const

This member function allows direct access to the underlying common control.

Returns
Contains a reference to a CStatusBarCtrl object.

◆ GetStatusBarPaintManager()

CXTPStatusBarPaintManager * GetStatusBarPaintManager ( ) const

Retrieves the status bar paint manager.

Returns
A pointer to a CXTPStatusBarPaintManager object.

◆ GetToolTipContext()

AFX_INLINE CXTPToolTipContext * GetToolTipContext ( ) const

Call this method to get a pointer to the tooltip context.

Returns
A pointer to the tooltip context.

◆ GetVisiblePaneCount()

int GetVisiblePaneCount ( ) const

Calculates the total number of visible panes.

Returns
Total number of panes currently visible.

◆ HitTest()

CXTPStatusBarPane * HitTest | ( | CPoint | pt,
 |  | CRect * | lpRect = NULL ) const

Determines which pane, if any, is at a specified screen position.

Parameters
pt | Point to be tested.
lpRect | Pointer to a CRect object to receive the item at point pt.
Returns
A pointer to the CXTPStatusBarPane object at the specified point, if any, or NULL otherwise.

◆ LoadState()

void LoadState ( LPCTSTR lpszProfileName )

Retrieves state information from the registry or .INI file.

Parameters
lpszProfileName Pointer to a NULL-terminated string that specifies the name of a section in the initialization file or a key in the Windows registry where state information is stored.

◆ RemoveAt()

BOOL RemoveAt ( int nIndex )

Call this member function to remove an indicator pane from the status bar.

Parameters
nIndex Index of the indicator pane.
Returns
TRUE if successful, otherwise FALSE.

◆ RemoveIndicator()

BOOL RemoveIndicator ( UINT nID )

Call this member function to remove an indicator pane from the status bar.

Parameters
nID ID of the indicator pane.
Returns
TRUE if successful, otherwise FALSE.

◆ SaveState()

void SaveState ( LPCTSTR lpszProfileName )

Saves state information to the registry or .INI file.

Parameters
lpszProfileName Pointer to a NULL-terminated string that specifies the name of a section in the initialization file or a key in the Windows registry where state information is stored.

◆ SetCommandBars()

AFX_INLINE void SetCommandBars ( CXTPCommandBars * pCommandBars )

Call this member to set the command bar's object.

Parameters
pCommandBars CXTPCommandBars to be set.

◆ SetDrawDisabledText()

AFX_INLINE void SetDrawDisabledText ( BOOL bDraw )

Call this member function to set the paint manager to draw disabled text.

Parameters
bDraw TRUE to draw disabled text, otherwise FALSE.

◆ SetFont()

void SetFont | ( | CFont * | pFont,
 |  | BOOL | bRedraw = TRUE )

Call this method to set the font for the status bar.

Parameters
pFont | Font to set.
bRedraw | TRUE to redraw status bar.

◆ SetIndicators()

BOOL SetIndicators | ( | const UINT * | lpIDArray,
 |  | int | nIDCount )

Sets each indicator's ID to the value specified by the corresponding element of the array lpIDArray, loads the string resource specified by each ID, and sets the indicator's text to the string.

Parameters
lpIDArray | Pointer to an array of IDs.
nIDCount | Number of elements in the array pointed to by lpIDArray.
Returns
TRUE if successful; otherwise FALSE.

◆ SetPaneInfo()

void SetPaneInfo | ( | int | nIndex,
 |  | UINT | nID,
 |  | UINT | nStyle,
 |  | int | cxWidth )

Sets the specified indicator pane to a new ID, style, and width.

Parameters
nIndex | Index of the indicator pane whose style is to be set.
nID | New ID for the indicator pane.
nStyle | New style for the indicator pane.
cxWidth | New width for the indicator pane.
See also
GetPaneInfo

◆ SetPaneStyle()

void SetPaneStyle | ( | int | nIndex,
 |  | UINT | nStyle )

Call this member function to set the style of a status bar's pane.

A pane's style determines how the pane appears.

Parameters
nIndex | Index of the pane whose style is to be set.
nStyle | Style of the pane whose style is to be set.
See also
GetPaneStyle

◆ SetPaneText()

BOOL SetPaneText | ( | int | nIndex,
 |  | LPCTSTR | lpszNewText )

Sets the pane text to the string pointed to by lpszNewText.

Parameters
nIndex | Index of the pane whose text is to be set.
lpszNewText | Pointer to the new pane text.
Returns
Nonzero if successful; otherwise 0.
See also
GetPaneText

◆ SetPaneWidth()

void SetPaneWidth | ( | int | nIndex,
 |  | int | cxText )

Call this member function to set the width for an indicator pane.

Parameters
nIndex | Index of the indicator pane.
cxText | New width for the indicator pane.

◆ SetRibbonDividerIndex()

AFX_INLINE void SetRibbonDividerIndex ( int nIndex )

Sets the position of the ribbon divider index.

This specifies the panes that get the second color for the ribbon theme.

Parameters
nIndex Position of the ribbon bar divider.

RibbonDividerIndex is a zero-based index and specifies the panes that get the second color for the ribbon theme. All panes with an index larger than the divider index will get the second ribbon color applied.

The documentation for this class was generated from the following file:
  • XTPStatusBar.h


Toolkit Pro: CXTPStatusBarPane Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPStatusBarPane Class Reference

CXTPStatusBarPane is a CXTPCmdTarget derived class. More...

Inheritance diagram for CXTPStatusBarPane:
[legend]

Public Member Functions

CXTPStatusBarPane ()
Constructs a CXTPStatusBarPane object.
virtual | ~CXTPStatusBarPane ()
Destroys a CXTPStatusBarPane object, handles cleanup and deallocation.
void | SetText (LPCTSTR lpszText)
Call this member to set the text caption that is displayed in this pane.
void | SetCaption (LPCTSTR lpszCaption)
Sets the text that is displayed for the pane in the status bar customization window.
CString | GetCaption () const
Gets the text that is displayed for the pane in the status bar customization window.
void | SetValue (LPCTSTR lpszValue)
Sets the value of the pane.
CString | GetValue () const
Gets the value of the pane.
CString | GetText () const
Call this member to get the text caption of the pane.
void | SetWidth (int nWidth)
Call this member to set the width of this pane.
virtual int | GetWidth ()
Call this member to get the width of the pane.
void | SetStyle (UINT nStyle)
Call this member function to set the style of a status bar's pane.
UINT | GetStyle () const
Call this member function to get the style of a status bar's pane.
UINT | GetID () const
Call this member function to get the ID of a status bar's pane.
int | GetIndex () const
Call this member function to get the index of a status bar's pane.
void | Remove ()
Call this member function to remove the pane.
BOOL | IsVisible () const
Call this member to determine if the pane is visible.
void | SetVisible (BOOL bVisible, BOOL bRecalcLayout=TRUE)
Call this member to set the visibility of the pane.
void | SetTextColor (COLORREF clrText)
Call this member function to set the color of an item text.
void | SetTextGrayColor (COLORREF clrText)
Call this member function to set the disabled color of an item text.
COLORREF | GetTextColor () const
Call this member function to get the color of an item text.
COLORREF | GetTextGrayColor () const
Call this member function to get the disabled color of an item text.
void | SetBackgroundColor (COLORREF clrBackground)
Call this member function to set the color of an item background.
COLORREF | GetBackgroundColor () const
Call this member to get the background color of an item.
void | SetTextFont (CFont *pFntText)
Call this member function to set the font of an item text.
void | SetTextFont (PLOGFONT pLogfText)
Call this member function to set the font of an item text.
virtual CFont * | GetTextFont ()
Call this member function to set the font of an item text.
int | GetIconIndex () const
Retrieves icon index.
void | SetIconIndex (int nIconIndex)
Call this method to set the icon index of an item.
void | SetTextAlignment (int nAlign)
Call this member function to set the alignment of an item text.
int | GetTextAlignment () const
Call this member function to get the alignment of an item text.
void | SetTooltip (LPCTSTR lpszTooltip)
Call this member to set the tooltip for this pane.
CString | GetTooltip () const
Call this member to get the tooltip displayed when the mouse pointer is positioned over the pane.
void | BestFit ()
Fits the width of the pane to its text width.
int | GetBestFit ()
Gets the best fit width which fits the width of the pane to the its text width.
void | SetBeginGroup (BOOL bBeginGroup=TRUE)
Call this method to add a separator before the pane.
BOOL | GetBeginGroup () const
Gets a boolean value indicating whether the pane has a separator placed before it and thus begins a new group.
CXTPStatusBar * | GetStatusBar () const
Call this member function to get the parent status bar object.
virtual CXTPImageManagerIcon * | GetImage () const
This method is called to get an image of the pane.
CRect | GetMargins () const
CRect | GetPadding () const
Gets the padding placed around the Text of a pane.
void | SetMargins (int nLeft, int nTop, int nRight, int nBottom)
Call this method to set margins for the pane.
void | SetPadding (int nLeft, int nTop, int nRight, int nBottom)
Sets the padding placed around the text of a pane in pixels.
void | SetButton (BOOL bButton=TRUE)
Specifies whether the pane will also act as a button.
BOOL | IsButton () const
Specifies whether the pane will also act as a button.
BOOL | IsEnabled () const
Gets a boolean value indicating whether the switch pane is enabled.
void | SetEnabled (BOOL bEnabled)
Specifies whether the switch pane is enabled or disabled.
BOOL | IsHighlighted () const
This member is called to determine if the pane button is currently highlighted.
BOOL | IsPressed () const
Call this method to determine if the pane button is pressed.
void | SetCustomizationVisible (BOOL bVisible)
Enables or disables status bar customization.
BOOL | GetCustomizationVisible () const
Gets whether customization is enabled.
BOOL | IsChecked () const
Call this member function to determine if the pane button state is checked.
void | SetChecked (BOOL bChecked)
Call this member to set the checked state of a pane.
BOOL | HasBorders () const
Call this member function to determine if the pane has borders enabled.
void | ShowBorders (BOOL bShowBorders)
Call this member function to show the pane borders.
void | Redraw () const
Call this member function to redraw the pane.
CRect | GetRect () const
Call this member to get the bounding rectangle for the pane.
CXTPMarkupUIElement * | GetMarkupUIElement () const
This member function is used to get the stored CXTPMarkupUIElement object.
void | SetDark (BOOL bDark=TRUE)
Some themes may display status bar panes as dark.
BOOL | IsDark () const
Determines if a pane is to be drawn as dark in some themes.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

virtual void | OnDraw (CDC *pDC, CRect rcItem)
This method is called to draw a pane item.
virtual void | OnLButtonDown (CPoint point)
This member function is used to process left mouse button events.
virtual void | OnMouseMove (CPoint point)
This member is called when the mouse cursor moves.
virtual INT_PTR | OnToolHitTest (CPoint point, TOOLINFO *pTI) const
The framework calls this member function to determine whether a point is in the bounding rectangle of the specified tool.

Protected Attributes

UINT | m_nID
IDC of indicator: 0 => normal text area.
int | m_cxText
Width of the string area in pixels.
UINT | m_nStyle
Style flags (SBPS_*).
CString | m_strText
Text in the pane.
DWORD | m_dwHideFlags
TRUE if pane is visible.
COLORREF | m_clrText
Text color.
COLORREF | m_clrTextGray
Disabled text color.
COLORREF | m_clrBackground
Background color.
CString | m_strToolTip
Tooltip text for the item.
CRect | m_rcPane
Bounding rectangle for the pane.
HWND | m_hWndPane
Child handle.
BOOL | m_bAutoDeleteWnd
TRUE to auto delete child.
int | m_nAlignment
Alignment of the item.
CXTPStatusBar * | m_pStatusBar
Parent StatusBar object.
int | m_nIndex
Index of the item.
CXTPFont | m_xtpFontText
Font of an item text.
int | m_nIconIndex
Icon index of the pane.
CRect | m_rcPadding
Margins of the pane.
CRect | m_rcMargins
Margins of the pane.
BOOL | m_bButton
TRUE if pane is clickable button.
BOOL | m_bPressed
TRUE if button was pressed.
CXTPMarkupUIElement * | m_pMarkupUIElement
Markup Context.
BOOL | m_bBeginGroup
TRUE if the pane begins a group.
CString | m_strCaption
The text that is displayed for the pane in the status bar customization window.
CString | m_strValue
The value of the pane.
int | m_nBestFit
Width for the pane to have the best fit.
BOOL | m_bCustomizable
True to enable customization, False to disable customization.
BOOL | m_bIsDark
True if a pane should be dark in some themes.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

CXTPStatusBarPane is a CXTPCmdTarget derived class.

It represents a single pane of a status bar.

Member Function Documentation

◆ GetBackgroundColor()

COLORREF GetBackgroundColor ( ) const

Call this member to get the background color of an item.

Returns
The background color of an item.

◆ GetBeginGroup()

AFX_INLINE BOOL GetBeginGroup ( ) const

Gets a boolean value indicating whether the pane has a separator placed before it and thus begins a new group.

Returns
TRUE if the pane begins a group, FALSE otherwise.

◆ GetBestFit()

int GetBestFit ( )

Gets the best fit width which fits the width of the pane to the its text width.

Returns
Best fit width.

◆ GetCaption()

AFX_INLINE CString GetCaption ( ) const

Gets the text that is displayed for the pane in the status bar customization window.

Returns
Text caption.

◆ GetCustomizationVisible()

BOOL GetCustomizationVisible ( ) const

Gets whether customization is enabled.

Returns
TRUE if customization is enabled, FALSE otherwise.

◆ GetIconIndex()

int GetIconIndex ( ) const

Retrieves icon index.

Returns
Icon index.
See also
SetIconIndex

◆ GetID()

UINT GetID ( ) const

Call this member function to get the ID of a status bar's pane.

Returns
ID of the indicator pane.

◆ GetImage()

virtual CXTPImageManagerIcon * GetImage ( ) const
virtual

This method is called to get an image of the pane.

Returns
CXTPImageManagerIcon pointer to be drawn.

◆ GetIndex()

int GetIndex ( ) const

Call this member function to get the index of a status bar's pane.

Returns
Index of the indicator pane.

◆ GetMargins()

CRect GetMargins ( ) const
Returns
Returns margins for pane entry
See also
SetMargins

◆ GetMarkupUIElement()

AFX_INLINE CXTPMarkupUIElement * GetMarkupUIElement ( ) const

This member function is used to get the stored CXTPMarkupUIElement object.

Returns
A pointer to the CXTPMarkupUIElement object.

◆ GetPadding()

CRect GetPadding ( ) const

Gets the padding placed around the Text of a pane.

Returns
Padding placed around the Text of a pane.

◆ GetRect()

CRect GetRect ( ) const

Call this member to get the bounding rectangle for the pane.

Returns
A CRect object.

◆ GetStatusBar()

CXTPStatusBar * GetStatusBar ( ) const

Call this member function to get the parent status bar object.

Returns
Pointer to the parent status bar object.

◆ GetStyle()

UINT GetStyle ( ) const

Call this member function to get the style of a status bar's pane.

Returns
Style of the indicator pane.

◆ GetText()

CString GetText ( ) const

Call this member to get the text caption of the pane.

Returns
Text caption of pane. This is the text displayed in the pane.
See also
SetText

◆ GetTextAlignment()

int GetTextAlignment ( ) const

Call this member function to get the alignment of an item text.

Returns
The alignment style of an item text.

◆ GetTextColor()

COLORREF GetTextColor ( ) const

Call this member function to get the color of an item text.

Returns
A COLORREF object that represents the color of an item text.

◆ GetTextFont()

virtual CFont * GetTextFont ( )
virtual

Call this member function to set the font of an item text.

Returns
Pointer to CFont object.

◆ GetTextGrayColor()

COLORREF GetTextGrayColor ( ) const

Call this member function to get the disabled color of an item text.

Returns
A COLORREF object that represents the disabled color of an item text.

◆ GetTooltip()

CString GetTooltip ( ) const

Call this member to get the tooltip displayed when the mouse pointer is positioned over the pane.

Returns
The tooltip displayed when the mouse if over the pane.
See also
SetTooltip

◆ GetValue()

AFX_INLINE CString GetValue ( ) const

Gets the value of the pane.

This is displayed in the status bar customization window.

Returns
The value of the status bar pane.

◆ GetWidth()

virtual int GetWidth ( )
virtual

Call this member to get the width of the pane.

Returns
Current width of the pane.
See also
SetWidth

Reimplemented in CXTPStatusBarSwitchPane.

◆ HasBorders()

AFX_INLINE BOOL HasBorders ( ) const

Call this member function to determine if the pane has borders enabled.

Returns
TRUE if the pane has borders enabled, otherwise FALSE.

If the pane is a button, the return value is always FALSE since buttons will handle drawing their own borders.

See also
IsButton

◆ IsButton()

BOOL IsButton ( ) const

Specifies whether the pane will also act as a button.

Returns
TRUE if the pane acts as a button, FALSE otherwise.

◆ IsChecked()

BOOL IsChecked ( ) const

Call this member function to determine if the pane button state is checked.

Returns
TRUE if the pane button is checked, otherwise FALSE.

◆ IsDark()

AFX_INLINE BOOL IsDark ( ) const

Determines if a pane is to be drawn as dark in some themes.

Returns
TRUE if the pane is dark, otherwise FALSE.

◆ IsEnabled()

BOOL IsEnabled ( ) const

Gets a boolean value indicating whether the switch pane is enabled.

Returns
TRUE if enabled, FALSE if disabled.

◆ IsHighlighted()

AFX_INLINE BOOL IsHighlighted ( ) const

This member is called to determine if the pane button is currently highlighted.

This occurs when the mouse cursor is positioned over the pane button.

Returns
TRUE if the pane button is currently highlighted.

◆ IsPressed()

AFX_INLINE BOOL IsPressed ( ) const

Call this method to determine if the pane button is pressed.

Returns
TRUE if the pane button is pressed, otherwise FALSE.

◆ IsVisible()

BOOL IsVisible ( ) const

Call this member to determine if the pane is visible.

Returns
TRUE if the tab is visible, FALSE otherwise.
See also
SetVisible

◆ OnDraw()

virtual void OnDraw | ( | CDC * | pDC,
 |  | CRect | rcItem )
 protectedvirtual

This method is called to draw a pane item.

Override it to draw a custom pane.

Parameters
pDC | Pointer to a valid device context.
rcItem | Item rectangle.

Reimplemented in CXTPStatusBarProgressPane, and CXTPStatusBarSwitchPane.

◆ OnLButtonDown()

virtual void OnLButtonDown ( CPoint point )
protectedvirtual

This member function is used to process left mouse button events.

Parameters
point A CPoint that specifies the x- and y- coordinates of the cursor. These coordinates are always relative to the upper-left corner of the window.

Reimplemented in CXTPStatusBarSwitchPane.

◆ OnMouseMove()

virtual void OnMouseMove ( CPoint point )
protectedvirtual

This member is called when the mouse cursor moves.

Parameters
point Specifies the x- and y- coordinates of the cursor.

Reimplemented in CXTPStatusBarSwitchPane.

◆ OnToolHitTest()

virtual INT_PTR OnToolHitTest | ( | CPoint | point,
 |  | TOOLINFO * | pTI ) const
 protectedvirtual

The framework calls this member function to determine whether a point is in the bounding rectangle of the specified tool.

Parameters
point | Specifies the x- and y- coordinates of the cursor. These coordinates are always relative to the upper-left corner of the window.
pTI | Pointer to a TOOLINFO structure.
Returns
If the tooltip control was found, then the window control ID is returned. If the tooltip control was not found, then a value of -1 is returned.

Reimplemented in CXTPStatusBarSwitchPane.

◆ SetBackgroundColor()

void SetBackgroundColor ( COLORREF clrBackground )

Call this member function to set the color of an item background.

Parameters
clrBackground COLORREF object that represents the background color of an item text.

◆ SetBeginGroup()

AFX_INLINE void SetBeginGroup ( BOOL bBeginGroup = TRUE )

Call this method to add a separator before the pane.

Parameters
bBeginGroup TRUE to start a new group.

◆ SetButton()

void SetButton ( BOOL bButton = TRUE )

Specifies whether the pane will also act as a button.

Parameters
bButton TRUE if the pane will act as a button.

Button panes will look and act like a button on mouse over and when clicked. On mouse over, the button pane will become "hot" giving a visual que that it is a button and can be clicked. When clicked, the button pane will change to a "pressed" state.

◆ SetCaption()

AFX_INLINE void SetCaption ( LPCTSTR lpszCaption )

Sets the text that is displayed for the pane in the status bar customization window.

Parameters
lpszCaption The caption is the text that is displayed for the pane in the status bar customization window.

◆ SetChecked()

void SetChecked ( BOOL bChecked )

Call this member to set the checked state of a pane.

Parameters
bChecked TRUE to set the pane to checked, FALSE to set the pane to unchecked.

◆ SetCustomizationVisible()

void SetCustomizationVisible ( BOOL bVisible )

Enables or disables status bar customization.

Parameters
bVisible TRUE to enable customization, FALSE to disable customization.

SetCustomizationVisible will enable a status bar customization window to appear when the status bar is right-clicked on. The customization window allows all the panes in the statusbar to be hidden or displayed (if already hidden). All panes will be displayed in the window with the exception of the pane with an ID equal to 0. The items displayed in the window are the caption of the pane and the value of the pane. Also indicated is the visibility of the pane.

◆ SetDark()

AFX_INLINE void SetDark ( BOOL bDark = TRUE )

Some themes may display status bar panes as dark.

This method turns this effect on/off.

Parameters
bDark Sets status bar panes as dark. True by default, set false to turn off

◆ SetEnabled()

void SetEnabled ( BOOL bEnabled )

Specifies whether the switch pane is enabled or disabled.

Parameters
bEnabled TRUE to enable the pane, FALSE to disable the pane.

◆ SetIconIndex()

void SetIconIndex ( int nIconIndex )

Call this method to set the icon index of an item.

Parameters
nIconIndex Icon index to be set.
See also
GetIconIndex

◆ SetMargins()

void SetMargins | ( | int | nLeft,
 |  | int | nTop,
 |  | int | nRight,
 |  | int | nBottom )

Call this method to set margins for the pane.

Parameters
nLeft | Left margin.
nTop | Top margin.
nRight | Right margin.
nBottom | Bottom margin.
See also
GetMargins

◆ SetPadding()

void SetPadding | ( | int | nLeft,
 |  | int | nTop,
 |  | int | nRight,
 |  | int | nBottom )

Sets the padding placed around the text of a pane in pixels.

Parameters
nLeft | Padding placed on the left side of the text of a pane.
nTop | Padding placed on the top of the text of a pane.
nRight | Padding placed on the right side of the text of a pane.
nBottom | Padding placed on the bottom of the text of a pane.

◆ SetStyle()

void SetStyle ( UINT nStyle )

Call this member function to set the style of a status bar's pane.

A pane's style determines how the pane appears.

Parameters
nStyle Style of the pane whose style is to be set.

◆ SetText()

void SetText ( LPCTSTR lpszText )

Call this member to set the text caption that is displayed in this pane.

Parameters
lpszText Text caption of the pane.
See also
GetText

◆ SetTextAlignment()

void SetTextAlignment ( int nAlign )

Call this member function to set the alignment of an item text.

Parameters
nAlign The alignment style of an item text.

◆ SetTextColor()

void SetTextColor ( COLORREF clrText )

Call this member function to set the color of an item text.

Parameters
clrText COLORREF object that represents the color of an item text.

◆ SetTextFont() [1/2]

void SetTextFont ( CFont * pFntText )

Call this member function to set the font of an item text.

Parameters
pFntText pointer to a CFont object.

◆ SetTextFont() [2/2]

void SetTextFont ( PLOGFONT pLogfText )

Call this member function to set the font of an item text.

Parameters
pLogfText pointer to a LOGFONT structure.

◆ SetTextGrayColor()

void SetTextGrayColor ( COLORREF clrText )

Call this member function to set the disabled color of an item text.

Parameters
clrText COLORREF object that represents the disabled color of an item text.

◆ SetTooltip()

void SetTooltip ( LPCTSTR lpszTooltip )

Call this member to set the tooltip for this pane.

This is the text that will be displayed when the mouse pointer is positioned over the pane.

Parameters
lpszTooltip Tooltip to set for this tab.
See also
GetTooltip

◆ SetValue()

AFX_INLINE void SetValue ( LPCTSTR lpszValue )

Sets the value of the pane.

This is displayed in the status bar customization window.

Parameters
lpszValue The value of the pane can be any string value and can be used to store extra data if customization is disabled. If customization is enabled, then the Value is the text that is displayed for the pane in the status bar customization window.

◆ SetVisible()

void SetVisible | ( | BOOL | bVisible,
 |  | BOOL | bRecalcLayout = TRUE )

Call this member to set the visibility of the pane.

Parameters
bVisible | TRUE to show the tab, FALSE to hide the tab.
bRecalcLayout | TRUE to recalculate layout after.
See also
IsVisible

◆ SetWidth()

void SetWidth ( int nWidth )

Call this member to set the width of this pane.

Parameters
nWidth new width to be set.
See also
GetWidth

◆ ShowBorders()

AFX_INLINE void ShowBorders ( BOOL bShowBorders )

Call this member function to show the pane borders.

Parameters
bShowBorders TRUE to show the pane borders, FALSE to hide them.

If the pane is a button, then this has no effect.

Member Data Documentation

◆ m_cxText

int m_cxText
protected

Width of the string area in pixels.

On both sides there is a 3 pixel gap and a 1 pixel border, making a pane 6 pixels wider.

◆ m_strValue

CString m_strValue
protected

The value of the pane.

This is displayed in the status bar customization window

The documentation for this class was generated from the following file:
  • XTPStatusBarPane.h


Toolkit Pro: CXTPStatusBarProgressPane Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPStatusBarProgressPane Class Reference

CXTPStatusBarProgressPane is a CXTPStatusBarPane derived class. More...

Inheritance diagram for CXTPStatusBarProgressPane:
[legend]

Public Member Functions

CXTPStatusBarProgressPane ()
Constructs a CXTPStatusBarProgressPane object.
~CXTPStatusBarProgressPane ()
Destroys a CXTPStatusBarProgressPane object, handles cleanup and deallocation.
- Public Member Functions inherited from CXTPStatusBarPane
CXTPStatusBarPane ()
Constructs a CXTPStatusBarPane object.
virtual | ~CXTPStatusBarPane ()
Destroys a CXTPStatusBarPane object, handles cleanup and deallocation.
void | SetText (LPCTSTR lpszText)
Call this member to set the text caption that is displayed in this pane.
void | SetCaption (LPCTSTR lpszCaption)
Sets the text that is displayed for the pane in the status bar customization window.
CString | GetCaption () const
Gets the text that is displayed for the pane in the status bar customization window.
void | SetValue (LPCTSTR lpszValue)
Sets the value of the pane.
CString | GetValue () const
Gets the value of the pane.
CString | GetText () const
Call this member to get the text caption of the pane.
void | SetWidth (int nWidth)
Call this member to set the width of this pane.
virtual int | GetWidth ()
Call this member to get the width of the pane.
void | SetStyle (UINT nStyle)
Call this member function to set the style of a status bar's pane.
UINT | GetStyle () const
Call this member function to get the style of a status bar's pane.
UINT | GetID () const
Call this member function to get the ID of a status bar's pane.
int | GetIndex () const
Call this member function to get the index of a status bar's pane.
void | Remove ()
Call this member function to remove the pane.
BOOL | IsVisible () const
Call this member to determine if the pane is visible.
void | SetVisible (BOOL bVisible, BOOL bRecalcLayout=TRUE)
Call this member to set the visibility of the pane.
void | SetTextColor (COLORREF clrText)
Call this member function to set the color of an item text.
void | SetTextGrayColor (COLORREF clrText)
Call this member function to set the disabled color of an item text.
COLORREF | GetTextColor () const
Call this member function to get the color of an item text.
COLORREF | GetTextGrayColor () const
Call this member function to get the disabled color of an item text.
void | SetBackgroundColor (COLORREF clrBackground)
Call this member function to set the color of an item background.
COLORREF | GetBackgroundColor () const
Call this member to get the background color of an item.
void | SetTextFont (CFont *pFntText)
Call this member function to set the font of an item text.
void | SetTextFont (PLOGFONT pLogfText)
Call this member function to set the font of an item text.
virtual CFont * | GetTextFont ()
Call this member function to set the font of an item text.
int | GetIconIndex () const
Retrieves icon index.
void | SetIconIndex (int nIconIndex)
Call this method to set the icon index of an item.
void | SetTextAlignment (int nAlign)
Call this member function to set the alignment of an item text.
int | GetTextAlignment () const
Call this member function to get the alignment of an item text.
void | SetTooltip (LPCTSTR lpszTooltip)
Call this member to set the tooltip for this pane.
CString | GetTooltip () const
Call this member to get the tooltip displayed when the mouse pointer is positioned over the pane.
void | BestFit ()
Fits the width of the pane to its text width.
int | GetBestFit ()
Gets the best fit width which fits the width of the pane to the its text width.
void | SetBeginGroup (BOOL bBeginGroup=TRUE)
Call this method to add a separator before the pane.
BOOL | GetBeginGroup () const
Gets a boolean value indicating whether the pane has a separator placed before it and thus begins a new group.
CXTPStatusBar * | GetStatusBar () const
Call this member function to get the parent status bar object.
virtual CXTPImageManagerIcon * | GetImage () const
This method is called to get an image of the pane.
CRect | GetMargins () const
CRect | GetPadding () const
Gets the padding placed around the Text of a pane.
void | SetMargins (int nLeft, int nTop, int nRight, int nBottom)
Call this method to set margins for the pane.
void | SetPadding (int nLeft, int nTop, int nRight, int nBottom)
Sets the padding placed around the text of a pane in pixels.
void | SetButton (BOOL bButton=TRUE)
Specifies whether the pane will also act as a button.
BOOL | IsButton () const
Specifies whether the pane will also act as a button.
BOOL | IsEnabled () const
Gets a boolean value indicating whether the switch pane is enabled.
void | SetEnabled (BOOL bEnabled)
Specifies whether the switch pane is enabled or disabled.
BOOL | IsHighlighted () const
This member is called to determine if the pane button is currently highlighted.
BOOL | IsPressed () const
Call this method to determine if the pane button is pressed.
void | SetCustomizationVisible (BOOL bVisible)
Enables or disables status bar customization.
BOOL | GetCustomizationVisible () const
Gets whether customization is enabled.
BOOL | IsChecked () const
Call this member function to determine if the pane button state is checked.
void | SetChecked (BOOL bChecked)
Call this member to set the checked state of a pane.
BOOL | HasBorders () const
Call this member function to determine if the pane has borders enabled.
void | ShowBorders (BOOL bShowBorders)
Call this member function to show the pane borders.
void | Redraw () const
Call this member function to redraw the pane.
CRect | GetRect () const
Call this member to get the bounding rectangle for the pane.
CXTPMarkupUIElement * | GetMarkupUIElement () const
This member function is used to get the stored CXTPMarkupUIElement object.
void | SetDark (BOOL bDark=TRUE)
Some themes may display status bar panes as dark.
BOOL | IsDark () const
Determines if a pane is to be drawn as dark in some themes.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.
- Public Member Functions inherited from CXTPProgressBase
CXTPProgressBase ()
Constructs a CXTPProgressBase object.
virtual | ~CXTPProgressBase ()
Destroys a CXTPProgressBase object, handles cleanup and deallocation.
void | SetRange (int nLower, int nUpper)
Sets the upper and lower limits of the progress bar control's range.
void | GetRange (int &nLower, int &nUpper) const
Gets the upper and lower limits of the progress bar control's range.
int | GetPos () const
Gets the current position of the progress bar, whose return value is always between the values for the Max and Min properties, inclusive.
void | SetPos (int nPos)
Sets the current position of the progress bar, whose return value is always between the values for the Max and Min properties, inclusive.

Protected Member Functions

virtual void | RedrawProgress ()
This method is called to redraw the progress bar.
virtual CXTPProgressPaintManager * | GetProgressPaintManager () const
This method is called to retrieve a pointer to CXTPProgressPaintManager.
virtual CRect | GetProgressRect ()
This method is called to get the bounding rectangle of the progressbar.
virtual void | OnDraw (CDC *pDC, CRect rcItem)
This method is called to draw a pane item.
- Protected Member Functions inherited from CXTPStatusBarPane
virtual void | OnLButtonDown (CPoint point)
This member function is used to process left mouse button events.
virtual void | OnMouseMove (CPoint point)
This member is called when the mouse cursor moves.
virtual INT_PTR | OnToolHitTest (CPoint point, TOOLINFO *pTI) const
The framework calls this member function to determine whether a point is in the bounding rectangle of the specified tool.
- Protected Member Functions inherited from CXTPProgressBase

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Attributes inherited from CXTPStatusBarPane
UINT | m_nID
IDC of indicator: 0 => normal text area.
int | m_cxText
Width of the string area in pixels.
UINT | m_nStyle
Style flags (SBPS_*).
CString | m_strText
Text in the pane.
DWORD | m_dwHideFlags
TRUE if pane is visible.
COLORREF | m_clrText
Text color.
COLORREF | m_clrTextGray
Disabled text color.
COLORREF | m_clrBackground
Background color.
CString | m_strToolTip
Tooltip text for the item.
CRect | m_rcPane
Bounding rectangle for the pane.
HWND | m_hWndPane
Child handle.
BOOL | m_bAutoDeleteWnd
TRUE to auto delete child.
int | m_nAlignment
Alignment of the item.
CXTPStatusBar * | m_pStatusBar
Parent StatusBar object.
int | m_nIndex
Index of the item.
CXTPFont | m_xtpFontText
Font of an item text.
int | m_nIconIndex
Icon index of the pane.
CRect | m_rcPadding
Margins of the pane.
CRect | m_rcMargins
Margins of the pane.
BOOL | m_bButton
TRUE if pane is clickable button.
BOOL | m_bPressed
TRUE if button was pressed.
CXTPMarkupUIElement * | m_pMarkupUIElement
Markup Context.
BOOL | m_bBeginGroup
TRUE if the pane begins a group.
CString | m_strCaption
The text that is displayed for the pane in the status bar customization window.
CString | m_strValue
The value of the pane.
int | m_nBestFit
Width for the pane to have the best fit.
BOOL | m_bCustomizable
True to enable customization, False to disable customization.
BOOL | m_bIsDark
True if a pane should be dark in some themes.
- Protected Attributes inherited from CXTPProgressBase
int | m_nMin
Minimum.
int | m_nMax
Maximum.
int | m_nPos
Current position.

Detailed Description

CXTPStatusBarProgressPane is a CXTPStatusBarPane derived class.

CXTPStatusBarProgressPane works with CXTStatusBar and allows you to create a progress bar in your status bar area.

Member Function Documentation

◆ GetProgressPaintManager()

virtual CXTPProgressPaintManager * GetProgressPaintManager ( ) const
protectedvirtual

This method is called to retrieve a pointer to CXTPProgressPaintManager.

Returns
Returns a pointer to CXTPProgressPaintManager

Implements CXTPProgressBase.

◆ GetProgressRect()

virtual CRect GetProgressRect ( )
protectedvirtual

This method is called to get the bounding rectangle of the progressbar.

Returns
Returns the bounding rectangle of the progressbar

Implements CXTPProgressBase.

◆ OnDraw()

virtual void OnDraw | ( | CDC * | pDC,
 |  | CRect | rcItem )
 protectedvirtual

This method is called to draw a pane item.

Override it to draw a custom pane.

Parameters
pDC | Pointer to a valid device context.
rcItem | Item rectangle.

Reimplemented from CXTPStatusBarPane.

The documentation for this class was generated from the following file:
  • XTPStatusBarPaneProgress.h


Toolkit Pro: CXTPStatusBarScrollBarPane Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPStatusBarScrollBarPane Class Reference

CXTPStatusBarScrollBarPane is a CXTPStatusBarPane derived class. More...

Inheritance diagram for CXTPStatusBarScrollBarPane:
[legend]

Public Member Functions

CXTPStatusBarScrollBarPane ()
Constructs a CXTPStatusBarScrollBarPane object.
virtual | ~CXTPStatusBarScrollBarPane ()
Destroys a CXTPStatusBarScrollBarPane object, handles cleanup and deallocation.
void | SetPos (int nValue)
Call this method to set the position of the scrollbar.
void | SetRange (int nMin, int nMax)
Sets the rangle of the scroll bar.
int | GetPos () const
Gets the current position of the scroll bar, whose return value is always between the values for the Max and Min properties, inclusive.
void | SetTooltipPart (int nPart, LPCTSTR lpszTooltip)
Call this method to set a tooltip for the scroll part of scrollbar.
- Public Member Functions inherited from CXTPStatusBarPane
CXTPStatusBarPane ()
Constructs a CXTPStatusBarPane object.
virtual | ~CXTPStatusBarPane ()
Destroys a CXTPStatusBarPane object, handles cleanup and deallocation.
void | SetText (LPCTSTR lpszText)
Call this member to set the text caption that is displayed in this pane.
void | SetCaption (LPCTSTR lpszCaption)
Sets the text that is displayed for the pane in the status bar customization window.
CString | GetCaption () const
Gets the text that is displayed for the pane in the status bar customization window.
void | SetValue (LPCTSTR lpszValue)
Sets the value of the pane.
CString | GetValue () const
Gets the value of the pane.
CString | GetText () const
Call this member to get the text caption of the pane.
void | SetWidth (int nWidth)
Call this member to set the width of this pane.
virtual int | GetWidth ()
Call this member to get the width of the pane.
void | SetStyle (UINT nStyle)
Call this member function to set the style of a status bar's pane.
UINT | GetStyle () const
Call this member function to get the style of a status bar's pane.
UINT | GetID () const
Call this member function to get the ID of a status bar's pane.
int | GetIndex () const
Call this member function to get the index of a status bar's pane.
void | Remove ()
Call this member function to remove the pane.
BOOL | IsVisible () const
Call this member to determine if the pane is visible.
void | SetVisible (BOOL bVisible, BOOL bRecalcLayout=TRUE)
Call this member to set the visibility of the pane.
void | SetTextColor (COLORREF clrText)
Call this member function to set the color of an item text.
void | SetTextGrayColor (COLORREF clrText)
Call this member function to set the disabled color of an item text.
COLORREF | GetTextColor () const
Call this member function to get the color of an item text.
COLORREF | GetTextGrayColor () const
Call this member function to get the disabled color of an item text.
void | SetBackgroundColor (COLORREF clrBackground)
Call this member function to set the color of an item background.
COLORREF | GetBackgroundColor () const
Call this member to get the background color of an item.
void | SetTextFont (CFont *pFntText)
Call this member function to set the font of an item text.
void | SetTextFont (PLOGFONT pLogfText)
Call this member function to set the font of an item text.
virtual CFont * | GetTextFont ()
Call this member function to set the font of an item text.
int | GetIconIndex () const
Retrieves icon index.
void | SetIconIndex (int nIconIndex)
Call this method to set the icon index of an item.
void | SetTextAlignment (int nAlign)
Call this member function to set the alignment of an item text.
int | GetTextAlignment () const
Call this member function to get the alignment of an item text.
void | SetTooltip (LPCTSTR lpszTooltip)
Call this member to set the tooltip for this pane.
CString | GetTooltip () const
Call this member to get the tooltip displayed when the mouse pointer is positioned over the pane.
void | BestFit ()
Fits the width of the pane to its text width.
int | GetBestFit ()
Gets the best fit width which fits the width of the pane to the its text width.
void | SetBeginGroup (BOOL bBeginGroup=TRUE)
Call this method to add a separator before the pane.
BOOL | GetBeginGroup () const
Gets a boolean value indicating whether the pane has a separator placed before it and thus begins a new group.
CXTPStatusBar * | GetStatusBar () const
Call this member function to get the parent status bar object.
virtual CXTPImageManagerIcon * | GetImage () const
This method is called to get an image of the pane.
CRect | GetMargins () const
CRect | GetPadding () const
Gets the padding placed around the Text of a pane.
void | SetMargins (int nLeft, int nTop, int nRight, int nBottom)
Call this method to set margins for the pane.
void | SetPadding (int nLeft, int nTop, int nRight, int nBottom)
Sets the padding placed around the text of a pane in pixels.
void | SetButton (BOOL bButton=TRUE)
Specifies whether the pane will also act as a button.
BOOL | IsButton () const
Specifies whether the pane will also act as a button.
BOOL | IsEnabled () const
Gets a boolean value indicating whether the switch pane is enabled.
void | SetEnabled (BOOL bEnabled)
Specifies whether the switch pane is enabled or disabled.
BOOL | IsHighlighted () const
This member is called to determine if the pane button is currently highlighted.
BOOL | IsPressed () const
Call this method to determine if the pane button is pressed.
void | SetCustomizationVisible (BOOL bVisible)
Enables or disables status bar customization.
BOOL | GetCustomizationVisible () const
Gets whether customization is enabled.
BOOL | IsChecked () const
Call this member function to determine if the pane button state is checked.
void | SetChecked (BOOL bChecked)
Call this member to set the checked state of a pane.
BOOL | HasBorders () const
Call this member function to determine if the pane has borders enabled.
void | ShowBorders (BOOL bShowBorders)
Call this member function to show the pane borders.
void | Redraw () const
Call this member function to redraw the pane.
CRect | GetRect () const
Call this member to get the bounding rectangle for the pane.
CXTPMarkupUIElement * | GetMarkupUIElement () const
This member function is used to get the stored CXTPMarkupUIElement object.
void | SetDark (BOOL bDark=TRUE)
Some themes may display status bar panes as dark.
BOOL | IsDark () const
Determines if a pane is to be drawn as dark in some themes.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.
- Public Member Functions inherited from CXTPScrollBase
CXTPScrollBase ()
Constructs a CXTPScrollBase object.
virtual | ~CXTPScrollBase ()
Destroys a CXTPScrollBase object, handles cleanup and deallocation.
void | SetScrollBarStyle (XTPScrollBarStyle scrollStyle)
Call this method to set the style of the scrollbar.
XTPScrollBarStyle | GetScrollBarStyle () const
Call this method to get the style of the scrollbar.
XTP_SCROLLBAR_TRACKINFO * | GetScrollBarTrackInfo () const
Call this method to get XTP_SCROLLBAR_TRACKINFO information.
XTP_SCROLLBAR_POSINFO * GetScrollBarPosInfo ()
Call this method to get XTP_SCROLLBAR_POSINFO information.
virtual CWnd * | GetParentWindow () const =0
Retrieves parent window of scrollbar.
int | HitTestScrollBar (POINT pt) const
Call this method to check ScrollBar part under pointer.
CRect | GetScrollBarPartRect (int nPart) const
Gets the bounding rectangle of a specified part of the scrollbar.
void | PerformTrackInit (HWND hWnd, CPoint point, XTP_SCROLLBAR_POSINFO *pSBInfo, BOOL bDirect)
Call this method to start scrollbar tracking.
XTP_SLIDERTICKS * | GetTicks () const
Gets the ticks in the slider.
void | SetTicks (double *pTicks, int nCount)
Call this method to set ticks for the slider.
HBRUSH | GetCltColor (CDC *pDC) const
Call this method to get the scroll bar control color.
BOOL | IsSlider () const
Call this member function to determine if the scrollbar is a slider control.
virtual BOOL | IsScrollBarEnabled () const =0
Determines if the scrollbar is enabled.
virtual CXTPScrollBarPaintManager * | GetScrollBarPaintManager () const =0
Obtains a pointer to the associated scrollbar paint manager.
virtual CRect | GetScrollBarRect ()=0
Obtains the rectangle occupied by the scrollbar in client coordinates.
virtual void | GetScrollInfo (SCROLLINFO *psi)=0
The GetScrollInfo function retrieves the parameters of a scroll bar, including the minimum and maximum scrolling positions, the page size, and the position of the scroll box(thumb)
virtual void | RedrawScrollBar ()=0
Forces the scrollbar to redraw itself.

Protected Attributes

int | m_nMin
Lower limit of the scrollbar control's range.
int | m_nMax
Upper limit of the scrollbar control's range.
int | m_nValue
Scrollbar position.
int | m_nPage
Scrollbar Page.
CString | m_strToolTipPart [5]
Text of tooltip.
- Protected Attributes inherited from CXTPStatusBarPane
UINT | m_nID
IDC of indicator: 0 => normal text area.
int | m_cxText
Width of the string area in pixels.
UINT | m_nStyle
Style flags (SBPS_*).
CString | m_strText
Text in the pane.
DWORD | m_dwHideFlags
TRUE if pane is visible.
COLORREF | m_clrText
Text color.
COLORREF | m_clrTextGray
Disabled text color.
COLORREF | m_clrBackground
Background color.
CString | m_strToolTip
Tooltip text for the item.
CRect | m_rcPane
Bounding rectangle for the pane.
HWND | m_hWndPane
Child handle.
BOOL | m_bAutoDeleteWnd
TRUE to auto delete child.
int | m_nAlignment
Alignment of the item.
CXTPStatusBar * | m_pStatusBar
Parent StatusBar object.
int | m_nIndex
Index of the item.
CXTPFont | m_xtpFontText
Font of an item text.
int | m_nIconIndex
Icon index of the pane.
CRect | m_rcPadding
Margins of the pane.
CRect | m_rcMargins
Margins of the pane.
BOOL | m_bButton
TRUE if pane is clickable button.
BOOL | m_bPressed
TRUE if button was pressed.
CXTPMarkupUIElement * | m_pMarkupUIElement
Markup Context.
BOOL | m_bBeginGroup
TRUE if the pane begins a group.
CString | m_strCaption
The text that is displayed for the pane in the status bar customization window.
CString | m_strValue
The value of the pane.
int | m_nBestFit
Width for the pane to have the best fit.
BOOL | m_bCustomizable
True to enable customization, False to disable customization.
BOOL | m_bIsDark
True if a pane should be dark in some themes.
- Protected Attributes inherited from CXTPScrollBase
XTP_SCROLLBAR_POSINFO | m_spi
ScrollBar position.
XTP_SCROLLBAR_TRACKINFO * | m_pSBTrack
ScrollBar tracking.
XTP_SLIDERTICKS * | m_pTicks
Slider Ticks.
XTPScrollBarStyle | m_scrollBarStyle
ScrollBar style.
BOOL | m_bAnimation
TRUE if animation enabled.
int | m_nTimerElapse
Scroll delay.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Member Functions inherited from CXTPStatusBarPane
virtual void | OnDraw (CDC *pDC, CRect rcItem)
This method is called to draw a pane item.
virtual void | OnLButtonDown (CPoint point)
This member function is used to process left mouse button events.
virtual void | OnMouseMove (CPoint point)
This member is called when the mouse cursor moves.
virtual INT_PTR | OnToolHitTest (CPoint point, TOOLINFO *pTI) const
The framework calls this member function to determine whether a point is in the bounding rectangle of the specified tool.

Detailed Description

CXTPStatusBarScrollBarPane is a CXTPStatusBarPane derived class.

CXTPStatusBarScrollBarPane works with CXTStatusBar and allows you to create a themed ScrollBar in your status bar area.

Member Function Documentation

◆ GetPos()

int GetPos ( ) const

Gets the current position of the scroll bar, whose return value is always between the values for the Max and Min properties, inclusive.

Returns
Current position of the scroll bar.

◆ SetPos()

void SetPos ( int nValue )

Call this method to set the position of the scrollbar.

Parameters
nValue Scrollbar position to be set.

◆ SetRange()

void SetRange | ( | int | nMin,
 |  | int | nMax )

Sets the rangle of the scroll bar.

Parameters
nMin | Lower limit of the scrollbar control's range.
nMax | Upper limit of the scrollbar control's range.

◆ SetTooltipPart()

void SetTooltipPart | ( | int | nPart,
 |  | LPCTSTR | lpszTooltip )

Call this method to set a tooltip for the scroll part of scrollbar.

Parameters
nPart | Part of the scrollbar to set the tooltip. Can be XTP_HTSCROLLUP, XTP_HTSCROLLDOWN, XTP_HTSCROLLUPPAGE, XTP_HTSCROLLDOWNPAGE, XTP_HTSCROLLTHUMB.
lpszTooltip | Text of the tooltip to be set.
The documentation for this class was generated from the following file:
  • XTPStatusBarPaneScrollBar.h


Toolkit Pro: CXTPStatusBarSliderPane Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPStatusBarSliderPane Class Reference

CXTPStatusBarSliderPane is a CXTPStatusBarPane derived class. More...

Inheritance diagram for CXTPStatusBarSliderPane:
[legend]

Public Member Functions

CXTPStatusBarSliderPane ()
Constructs a CXTPStatusBarSliderPane object.
~CXTPStatusBarSliderPane ()
Destroys a CXTPStatusBarSliderPane object, handles cleanup and deallocation.
void | SetTicks (double *pTicks, int nCount)
Call this method to set ticks for the slider.
- Public Member Functions inherited from CXTPStatusBarScrollBarPane
CXTPStatusBarScrollBarPane ()
Constructs a CXTPStatusBarScrollBarPane object.
virtual | ~CXTPStatusBarScrollBarPane ()
Destroys a CXTPStatusBarScrollBarPane object, handles cleanup and deallocation.
void | SetPos (int nValue)
Call this method to set the position of the scrollbar.
void | SetRange (int nMin, int nMax)
Sets the rangle of the scroll bar.
int | GetPos () const
Gets the current position of the scroll bar, whose return value is always between the values for the Max and Min properties, inclusive.
void | SetTooltipPart (int nPart, LPCTSTR lpszTooltip)
Call this method to set a tooltip for the scroll part of scrollbar.
- Public Member Functions inherited from CXTPStatusBarPane
CXTPStatusBarPane ()
Constructs a CXTPStatusBarPane object.
virtual | ~CXTPStatusBarPane ()
Destroys a CXTPStatusBarPane object, handles cleanup and deallocation.
void | SetText (LPCTSTR lpszText)
Call this member to set the text caption that is displayed in this pane.
void | SetCaption (LPCTSTR lpszCaption)
Sets the text that is displayed for the pane in the status bar customization window.
CString | GetCaption () const
Gets the text that is displayed for the pane in the status bar customization window.
void | SetValue (LPCTSTR lpszValue)
Sets the value of the pane.
CString | GetValue () const
Gets the value of the pane.
CString | GetText () const
Call this member to get the text caption of the pane.
void | SetWidth (int nWidth)
Call this member to set the width of this pane.
virtual int | GetWidth ()
Call this member to get the width of the pane.
void | SetStyle (UINT nStyle)
Call this member function to set the style of a status bar's pane.
UINT | GetStyle () const
Call this member function to get the style of a status bar's pane.
UINT | GetID () const
Call this member function to get the ID of a status bar's pane.
int | GetIndex () const
Call this member function to get the index of a status bar's pane.
void | Remove ()
Call this member function to remove the pane.
BOOL | IsVisible () const
Call this member to determine if the pane is visible.
void | SetVisible (BOOL bVisible, BOOL bRecalcLayout=TRUE)
Call this member to set the visibility of the pane.
void | SetTextColor (COLORREF clrText)
Call this member function to set the color of an item text.
void | SetTextGrayColor (COLORREF clrText)
Call this member function to set the disabled color of an item text.
COLORREF | GetTextColor () const
Call this member function to get the color of an item text.
COLORREF | GetTextGrayColor () const
Call this member function to get the disabled color of an item text.
void | SetBackgroundColor (COLORREF clrBackground)
Call this member function to set the color of an item background.
COLORREF | GetBackgroundColor () const
Call this member to get the background color of an item.
void | SetTextFont (CFont *pFntText)
Call this member function to set the font of an item text.
void | SetTextFont (PLOGFONT pLogfText)
Call this member function to set the font of an item text.
virtual CFont * | GetTextFont ()
Call this member function to set the font of an item text.
int | GetIconIndex () const
Retrieves icon index.
void | SetIconIndex (int nIconIndex)
Call this method to set the icon index of an item.
void | SetTextAlignment (int nAlign)
Call this member function to set the alignment of an item text.
int | GetTextAlignment () const
Call this member function to get the alignment of an item text.
void | SetTooltip (LPCTSTR lpszTooltip)
Call this member to set the tooltip for this pane.
CString | GetTooltip () const
Call this member to get the tooltip displayed when the mouse pointer is positioned over the pane.
void | BestFit ()
Fits the width of the pane to its text width.
int | GetBestFit ()
Gets the best fit width which fits the width of the pane to the its text width.
void | SetBeginGroup (BOOL bBeginGroup=TRUE)
Call this method to add a separator before the pane.
BOOL | GetBeginGroup () const
Gets a boolean value indicating whether the pane has a separator placed before it and thus begins a new group.
CXTPStatusBar * | GetStatusBar () const
Call this member function to get the parent status bar object.
virtual CXTPImageManagerIcon * | GetImage () const
This method is called to get an image of the pane.
CRect | GetMargins () const
CRect | GetPadding () const
Gets the padding placed around the Text of a pane.
void | SetMargins (int nLeft, int nTop, int nRight, int nBottom)
Call this method to set margins for the pane.
void | SetPadding (int nLeft, int nTop, int nRight, int nBottom)
Sets the padding placed around the text of a pane in pixels.
void | SetButton (BOOL bButton=TRUE)
Specifies whether the pane will also act as a button.
BOOL | IsButton () const
Specifies whether the pane will also act as a button.
BOOL | IsEnabled () const
Gets a boolean value indicating whether the switch pane is enabled.
void | SetEnabled (BOOL bEnabled)
Specifies whether the switch pane is enabled or disabled.
BOOL | IsHighlighted () const
This member is called to determine if the pane button is currently highlighted.
BOOL | IsPressed () const
Call this method to determine if the pane button is pressed.
void | SetCustomizationVisible (BOOL bVisible)
Enables or disables status bar customization.
BOOL | GetCustomizationVisible () const
Gets whether customization is enabled.
BOOL | IsChecked () const
Call this member function to determine if the pane button state is checked.
void | SetChecked (BOOL bChecked)
Call this member to set the checked state of a pane.
BOOL | HasBorders () const
Call this member function to determine if the pane has borders enabled.
void | ShowBorders (BOOL bShowBorders)
Call this member function to show the pane borders.
void | Redraw () const
Call this member function to redraw the pane.
CRect | GetRect () const
Call this member to get the bounding rectangle for the pane.
CXTPMarkupUIElement * | GetMarkupUIElement () const
This member function is used to get the stored CXTPMarkupUIElement object.
void | SetDark (BOOL bDark=TRUE)
Some themes may display status bar panes as dark.
BOOL | IsDark () const
Determines if a pane is to be drawn as dark in some themes.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.
- Public Member Functions inherited from CXTPScrollBase
CXTPScrollBase ()
Constructs a CXTPScrollBase object.
virtual | ~CXTPScrollBase ()
Destroys a CXTPScrollBase object, handles cleanup and deallocation.
void | SetScrollBarStyle (XTPScrollBarStyle scrollStyle)
Call this method to set the style of the scrollbar.
XTPScrollBarStyle | GetScrollBarStyle () const
Call this method to get the style of the scrollbar.
XTP_SCROLLBAR_TRACKINFO * | GetScrollBarTrackInfo () const
Call this method to get XTP_SCROLLBAR_TRACKINFO information.
XTP_SCROLLBAR_POSINFO * GetScrollBarPosInfo ()
Call this method to get XTP_SCROLLBAR_POSINFO information.
virtual CWnd * | GetParentWindow () const =0
Retrieves parent window of scrollbar.
int | HitTestScrollBar (POINT pt) const
Call this method to check ScrollBar part under pointer.
CRect | GetScrollBarPartRect (int nPart) const
Gets the bounding rectangle of a specified part of the scrollbar.
void | PerformTrackInit (HWND hWnd, CPoint point, XTP_SCROLLBAR_POSINFO *pSBInfo, BOOL bDirect)
Call this method to start scrollbar tracking.
XTP_SLIDERTICKS * | GetTicks () const
Gets the ticks in the slider.
void | SetTicks (double *pTicks, int nCount)
Call this method to set ticks for the slider.
HBRUSH | GetCltColor (CDC *pDC) const
Call this method to get the scroll bar control color.
BOOL | IsSlider () const
Call this member function to determine if the scrollbar is a slider control.
virtual BOOL | IsScrollBarEnabled () const =0
Determines if the scrollbar is enabled.
virtual CRect | GetScrollBarRect ()=0
Obtains the rectangle occupied by the scrollbar in client coordinates.
virtual void | GetScrollInfo (SCROLLINFO *psi)=0
The GetScrollInfo function retrieves the parameters of a scroll bar, including the minimum and maximum scrolling positions, the page size, and the position of the scroll box(thumb)
virtual void | RedrawScrollBar ()=0
Forces the scrollbar to redraw itself.

Protected Member Functions

virtual CXTPScrollBarPaintManager * | GetScrollBarPaintManager () const
This method is called to retrieve a pointer to CXTPScrollBarPaintManager.
- Protected Member Functions inherited from CXTPStatusBarPane
virtual void | OnDraw (CDC *pDC, CRect rcItem)
This method is called to draw a pane item.
virtual void | OnLButtonDown (CPoint point)
This member function is used to process left mouse button events.
virtual void | OnMouseMove (CPoint point)
This member is called when the mouse cursor moves.
virtual INT_PTR | OnToolHitTest (CPoint point, TOOLINFO *pTI) const
The framework calls this member function to determine whether a point is in the bounding rectangle of the specified tool.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Attributes inherited from CXTPStatusBarScrollBarPane
int | m_nMin
Lower limit of the scrollbar control's range.
int | m_nMax
Upper limit of the scrollbar control's range.
int | m_nValue
Scrollbar position.
int | m_nPage
Scrollbar Page.
CString | m_strToolTipPart [5]
Text of tooltip.
- Protected Attributes inherited from CXTPStatusBarPane
UINT | m_nID
IDC of indicator: 0 => normal text area.
int | m_cxText
Width of the string area in pixels.
UINT | m_nStyle
Style flags (SBPS_*).
CString | m_strText
Text in the pane.
DWORD | m_dwHideFlags
TRUE if pane is visible.
COLORREF | m_clrText
Text color.
COLORREF | m_clrTextGray
Disabled text color.
COLORREF | m_clrBackground
Background color.
CString | m_strToolTip
Tooltip text for the item.
CRect | m_rcPane
Bounding rectangle for the pane.
HWND | m_hWndPane
Child handle.
BOOL | m_bAutoDeleteWnd
TRUE to auto delete child.
int | m_nAlignment
Alignment of the item.
CXTPStatusBar * | m_pStatusBar
Parent StatusBar object.
int | m_nIndex
Index of the item.
CXTPFont | m_xtpFontText
Font of an item text.
int | m_nIconIndex
Icon index of the pane.
CRect | m_rcPadding
Margins of the pane.
CRect | m_rcMargins
Margins of the pane.
BOOL | m_bButton
TRUE if pane is clickable button.
BOOL | m_bPressed
TRUE if button was pressed.
CXTPMarkupUIElement * | m_pMarkupUIElement
Markup Context.
BOOL | m_bBeginGroup
TRUE if the pane begins a group.
CString | m_strCaption
The text that is displayed for the pane in the status bar customization window.
CString | m_strValue
The value of the pane.
int | m_nBestFit
Width for the pane to have the best fit.
BOOL | m_bCustomizable
True to enable customization, False to disable customization.
BOOL | m_bIsDark
True if a pane should be dark in some themes.
- Protected Attributes inherited from CXTPScrollBase
XTP_SCROLLBAR_POSINFO | m_spi
ScrollBar position.
XTP_SCROLLBAR_TRACKINFO * | m_pSBTrack
ScrollBar tracking.
XTP_SLIDERTICKS * | m_pTicks
Slider Ticks.
XTPScrollBarStyle | m_scrollBarStyle
ScrollBar style.
BOOL | m_bAnimation
TRUE if animation enabled.
int | m_nTimerElapse
Scroll delay.

Detailed Description

CXTPStatusBarSliderPane is a CXTPStatusBarPane derived class.

CXTPStatusBarSliderPane works with CXTStatusBar and allows you to create a themed slider in your status bar area.

Member Function Documentation

◆ GetScrollBarPaintManager()

virtual CXTPScrollBarPaintManager * GetScrollBarPaintManager ( ) const
protectedvirtual

This method is called to retrieve a pointer to CXTPScrollBarPaintManager.

Returns
Returns a pointer to CXTPScrollBarPaintManager

Implements CXTPScrollBase.

◆ SetTicks()

void SetTicks | ( | double * | pTicks,
 |  | int | nCount )

Call this method to set ticks for the slider.

Parameters
pTicks | Pointer to a double array of ticks.
nCount | Count of elements in the array.
The documentation for this class was generated from the following file:
  • XTPStatusBarPaneSlider.h


Toolkit Pro: CXTPStatusBarSwitchPane Class Reference

Classes | Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPStatusBarSwitchPane Class Reference

CXTPStatusBarSwitchPane is a CXTPStatusBarPane derived class. More...

Inheritance diagram for CXTPStatusBarSwitchPane:
[legend]

Classes

struct SWITCH
Holds status bar pane switch properties. More...

Public Member Functions

CXTPStatusBarSwitchPane ()
Constructs a CXTPStatusBarSwitchPane object.
~CXTPStatusBarSwitchPane ()
Destroys a CXTPStatusBarSwitchPane object, handles cleanup and deallocation.
BOOL | SetSwitches (const UINT *lpIDArray, int nIDCount)
Call this method to set switches.
SWITCH * | AddSwitch (UINT nID)
Adds a switch to the Switch Pane.
SWITCH * | AddSwitch (UINT nID, LPCTSTR lpszToolTip)
Adds a switch to the Switch Pane.
SWITCH * | GetSwitch (int nIndex) const
Retrieves a switch by its index/identifier.
SWITCH * | FindSwitch (UINT nID) const
Retrieves a switch by its index/identifier.
int | GetSwitchCount () const
Gets the total number of switches in the switch pane.
void | RemoveAll ()
Removes all switches from the switch pane.
void | RemoveSwitch (UINT nID)
Removes a switch from the switch pane.
void | EnableSwitch (UINT nID, BOOL bEnabled)
Specifies whether the switch pane is enabled.
void | SetChecked (UINT nID)
Sets the ID of the switch that is currently checked.
virtual int | GetWidth ()
Gets the width of the switch pane.
SWITCH * | HitTest (CPoint point, CRect &rcItem) const
Call this method to determine which pane, if any, is at the specified screen position.
- Public Member Functions inherited from CXTPStatusBarPane
CXTPStatusBarPane ()
Constructs a CXTPStatusBarPane object.
virtual | ~CXTPStatusBarPane ()
Destroys a CXTPStatusBarPane object, handles cleanup and deallocation.
void | SetText (LPCTSTR lpszText)
Call this member to set the text caption that is displayed in this pane.
void | SetCaption (LPCTSTR lpszCaption)
Sets the text that is displayed for the pane in the status bar customization window.
CString | GetCaption () const
Gets the text that is displayed for the pane in the status bar customization window.
void | SetValue (LPCTSTR lpszValue)
Sets the value of the pane.
CString | GetValue () const
Gets the value of the pane.
CString | GetText () const
Call this member to get the text caption of the pane.
void | SetWidth (int nWidth)
Call this member to set the width of this pane.
void | SetStyle (UINT nStyle)
Call this member function to set the style of a status bar's pane.
UINT | GetStyle () const
Call this member function to get the style of a status bar's pane.
UINT | GetID () const
Call this member function to get the ID of a status bar's pane.
int | GetIndex () const
Call this member function to get the index of a status bar's pane.
void | Remove ()
Call this member function to remove the pane.
BOOL | IsVisible () const
Call this member to determine if the pane is visible.
void | SetVisible (BOOL bVisible, BOOL bRecalcLayout=TRUE)
Call this member to set the visibility of the pane.
void | SetTextColor (COLORREF clrText)
Call this member function to set the color of an item text.
void | SetTextGrayColor (COLORREF clrText)
Call this member function to set the disabled color of an item text.
COLORREF | GetTextColor () const
Call this member function to get the color of an item text.
COLORREF | GetTextGrayColor () const
Call this member function to get the disabled color of an item text.
void | SetBackgroundColor (COLORREF clrBackground)
Call this member function to set the color of an item background.
COLORREF | GetBackgroundColor () const
Call this member to get the background color of an item.
void | SetTextFont (CFont *pFntText)
Call this member function to set the font of an item text.
void | SetTextFont (PLOGFONT pLogfText)
Call this member function to set the font of an item text.
virtual CFont * | GetTextFont ()
Call this member function to set the font of an item text.
int | GetIconIndex () const
Retrieves icon index.
void | SetIconIndex (int nIconIndex)
Call this method to set the icon index of an item.
void | SetTextAlignment (int nAlign)
Call this member function to set the alignment of an item text.
int | GetTextAlignment () const
Call this member function to get the alignment of an item text.
void | SetTooltip (LPCTSTR lpszTooltip)
Call this member to set the tooltip for this pane.
CString | GetTooltip () const
Call this member to get the tooltip displayed when the mouse pointer is positioned over the pane.
void | BestFit ()
Fits the width of the pane to its text width.
int | GetBestFit ()
Gets the best fit width which fits the width of the pane to the its text width.
void | SetBeginGroup (BOOL bBeginGroup=TRUE)
Call this method to add a separator before the pane.
BOOL | GetBeginGroup () const
Gets a boolean value indicating whether the pane has a separator placed before it and thus begins a new group.
CXTPStatusBar * | GetStatusBar () const
Call this member function to get the parent status bar object.
virtual CXTPImageManagerIcon * | GetImage () const
This method is called to get an image of the pane.
CRect | GetMargins () const
CRect | GetPadding () const
Gets the padding placed around the Text of a pane.
void | SetMargins (int nLeft, int nTop, int nRight, int nBottom)
Call this method to set margins for the pane.
void | SetPadding (int nLeft, int nTop, int nRight, int nBottom)
Sets the padding placed around the text of a pane in pixels.
void | SetButton (BOOL bButton=TRUE)
Specifies whether the pane will also act as a button.
BOOL | IsButton () const
Specifies whether the pane will also act as a button.
BOOL | IsEnabled () const
Gets a boolean value indicating whether the switch pane is enabled.
void | SetEnabled (BOOL bEnabled)
Specifies whether the switch pane is enabled or disabled.
BOOL | IsHighlighted () const
This member is called to determine if the pane button is currently highlighted.
BOOL | IsPressed () const
Call this method to determine if the pane button is pressed.
void | SetCustomizationVisible (BOOL bVisible)
Enables or disables status bar customization.
BOOL | GetCustomizationVisible () const
Gets whether customization is enabled.
BOOL | IsChecked () const
Call this member function to determine if the pane button state is checked.
void | SetChecked (BOOL bChecked)
Call this member to set the checked state of a pane.
BOOL | HasBorders () const
Call this member function to determine if the pane has borders enabled.
void | ShowBorders (BOOL bShowBorders)
Call this member function to show the pane borders.
void | Redraw () const
Call this member function to redraw the pane.
CRect | GetRect () const
Call this member to get the bounding rectangle for the pane.
CXTPMarkupUIElement * | GetMarkupUIElement () const
This member function is used to get the stored CXTPMarkupUIElement object.
void | SetDark (BOOL bDark=TRUE)
Some themes may display status bar panes as dark.
BOOL | IsDark () const
Determines if a pane is to be drawn as dark in some themes.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

virtual void | OnLButtonDown (CPoint point)
This member function is used to process left mouse button events.
virtual void | OnDraw (CDC *pDC, CRect rcItem)
This method is called to draw a pane switch item.
virtual void | OnMouseMove (CPoint point)
This member is called when the mouse cursor moves.
virtual INT_PTR | OnToolHitTest (CPoint point, TOOLINFO *pTI) const
The framework calls this member function to determine whether a point is in the bounding rectangle of the specified tool.
- Protected Member Functions inherited from CXTPStatusBarPane

Protected Attributes

CArray< SWITCH *, SWITCH * > | m_arrSwitches
Collection of switces in the switch pane.
SWITCH * | m_pHighlighted
TRUE if the switch is currently highlighted.
- Protected Attributes inherited from CXTPStatusBarPane
UINT | m_nID
IDC of indicator: 0 => normal text area.
int | m_cxText
Width of the string area in pixels.
UINT | m_nStyle
Style flags (SBPS_*).
CString | m_strText
Text in the pane.
DWORD | m_dwHideFlags
TRUE if pane is visible.
COLORREF | m_clrText
Text color.
COLORREF | m_clrTextGray
Disabled text color.
COLORREF | m_clrBackground
Background color.
CString | m_strToolTip
Tooltip text for the item.
CRect | m_rcPane
Bounding rectangle for the pane.
HWND | m_hWndPane
Child handle.
BOOL | m_bAutoDeleteWnd
TRUE to auto delete child.
int | m_nAlignment
Alignment of the item.
CXTPStatusBar * | m_pStatusBar
Parent StatusBar object.
int | m_nIndex
Index of the item.
CXTPFont | m_xtpFontText
Font of an item text.
int | m_nIconIndex
Icon index of the pane.
CRect | m_rcPadding
Margins of the pane.
CRect | m_rcMargins
Margins of the pane.
BOOL | m_bButton
TRUE if pane is clickable button.
BOOL | m_bPressed
TRUE if button was pressed.
CXTPMarkupUIElement * | m_pMarkupUIElement
Markup Context.
BOOL | m_bBeginGroup
TRUE if the pane begins a group.
CString | m_strCaption
The text that is displayed for the pane in the status bar customization window.
CString | m_strValue
The value of the pane.
int | m_nBestFit
Width for the pane to have the best fit.
BOOL | m_bCustomizable
True to enable customization, False to disable customization.
BOOL | m_bIsDark
True if a pane should be dark in some themes.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

CXTPStatusBarSwitchPane is a CXTPStatusBarPane derived class.

CXTPStatusBarSwitchPane works with CXTStatusBar and allows you to create switches in your status bar area.

Member Function Documentation

◆ AddSwitch() [1/2]

SWITCH * AddSwitch ( UINT nID )

Adds a switch to the Switch Pane.

Parameters
nID ID of the switch.
Returns
Reference to a SWITCH object.

◆ AddSwitch() [2/2]

SWITCH * AddSwitch | ( | UINT | nID,
 |  | LPCTSTR | lpszToolTip )

Adds a switch to the Switch Pane.

Parameters
nID | ID of the switch.
lpszToolTip | Tooltip of the switch.
Returns
Reference to a SWITCH object.

◆ EnableSwitch()

void EnableSwitch | ( | UINT | nID,
 |  | BOOL | bEnabled )

Specifies whether the switch pane is enabled.

Parameters
nID | ID of the switch to enable/disable.
bEnabled | TRUE to enable the switch pane, FALSE to disable the swith pane.

◆ FindSwitch()

SWITCH * FindSwitch ( UINT nID ) const

Retrieves a switch by its index/identifier.

Returns a switch by its position.

Parameters
nID Identifier of the switch to retrieve.
Returns
Pointer to the SWITCH.

◆ GetSwitch()

SWITCH * GetSwitch ( int nIndex ) const

Retrieves a switch by its index/identifier.

Returns a switch by its position.

Parameters
nIndex Index of the switch to retrieve.
Returns
Pointer to the SWITCH.

◆ GetSwitchCount()

int GetSwitchCount ( ) const

Gets the total number of switches in the switch pane.

Returns
Total number of switches in the switch pane.

◆ GetWidth()

virtual int GetWidth ( )
virtual

Gets the width of the switch pane.

Returns
Width of the switch pane.

Reimplemented from CXTPStatusBarPane.

◆ HitTest()

SWITCH * HitTest | ( | CPoint | point,
 |  | CRect & | rcItem ) const

Call this method to determine which pane, if any, is at the specified screen position.

Parameters
point | Point to test.
rcItem | Retrieves the bounding rectangle of the item.
Returns
A SWITCH object containing the data of the pane at the specified point.

◆ OnDraw()

virtual void OnDraw | ( | CDC * | pDC,
 |  | CRect | rcItem )
 protectedvirtual

This method is called to draw a pane switch item.

Override it to draw a custom switch.

Parameters
pDC | Pointer to a valid device context.
rcItem | Item rectangle.

Reimplemented from CXTPStatusBarPane.

◆ OnLButtonDown()

virtual void OnLButtonDown ( CPoint point )
protectedvirtual

This member function is used to process left mouse button events.

Parameters
point A CPoint that specifies the x- and y- coordinates of the cursor. These coordinates are always relative to the upper-left corner of the window.

Reimplemented from CXTPStatusBarPane.

◆ OnMouseMove()

virtual void OnMouseMove ( CPoint point )
protectedvirtual

This member is called when the mouse cursor moves.

Parameters
point Specifies the x- and y- coordinates of the cursor.

Reimplemented from CXTPStatusBarPane.

◆ OnToolHitTest()

virtual INT_PTR OnToolHitTest | ( | CPoint | point,
 |  | TOOLINFO * | pTI ) const
 protectedvirtual

The framework calls this member function to determine whether a point is in the bounding rectangle of the specified tool.

Parameters
point | Specifies the x- and y- coordinates of the cursor. These coordinates are always relative to the upper-left corner of the window.
pTI | A pointer to a TOOLINFO structure.
Returns
If the tooltip control was found, then the window control ID is returned. If the tooltip control was not found, then a value of -1 is returned.

Reimplemented from CXTPStatusBarPane.

◆ RemoveSwitch()

void RemoveSwitch ( UINT nID )

Removes a switch from the switch pane.

Parameters
nID ID of the switch to remove.

◆ SetChecked()

void SetChecked ( UINT nID )

Sets the ID of the switch that is currently checked.

Parameters
nID ID of the switch to be checked.

Checked is used to get/set the currently selected/checked switch in the switch pane.

◆ SetSwitches()

BOOL SetSwitches | ( | const UINT * | lpIDArray,
 |  | int | nIDCount )

Call this method to set switches.

Parameters
lpIDArray | Pointer to an array with identifiers.
nIDCount | Count of elements in the array.
Returns
TRUE if successful, otherwise FALSE.
The documentation for this class was generated from the following file:
  • XTPStatusBarPaneSwitch.h


Toolkit Pro: CXTPStatusBarSwitchPane::SWITCH Struct Reference

  • CXTPStatusBarSwitchPane
  • SWITCH
Public Attributes | List of all members
CXTPStatusBarSwitchPane::SWITCH Struct Reference

Holds status bar pane switch properties. More...

Public Attributes

CString | strToolTip
Tooltip of the switch.
UINT | nID
Id of the switch.
int | nWidth
Width of the switch.
BOOL | bChecked
TRUE to "check" the switch.
BOOL | bHighlighted
TRUE if the switch is highlighted.
BOOL | bPressed
TRUE if the switch is pressed.
BOOL | bEnabled
TRUE if enabled.

Detailed Description

Holds status bar pane switch properties.

The documentation for this struct was generated from the following file:
  • XTPStatusBarPaneSwitch.h


Toolkit Pro: CXTPStatusBarThemeNativeWindows10 Class Reference

Public Member Functions | List of all members
CXTPStatusBarThemeNativeWindows10 Class Reference

The CXTPStatusBarThemeNativeWindows10 class is used to enable the Native Windows 10 style theme for the status bar. More...

Inheritance diagram for CXTPStatusBarThemeNativeWindows10:
[legend]

Public Member Functions

CXTPStatusBarThemeNativeWindows10 (CXTPPaintManager *pPaintManager)
Constructs a CXTPStatusBarThemeNativeWindows10 object.
virtual void | DrawStatusBarGripper (CDC *pDC, CRect rcClient)
This method is called to draw the status bar's gripper.
virtual void | RefreshMetrics ()
This method is called to refresh colors and other theme specific metrics for the paint manager.
virtual void | SetStateColor (COLORREF clrState)
Call this member function to set the application state color for the status bar.
virtual COLORREF | GetStateColor () const
Call this member function to get the application state color for the status bar.
- Public Member Functions inherited from CXTPStatusBarThemeOffice2013
CXTPStatusBarThemeOffice2013 (CXTPPaintManager *pPaintManager)
Constructs a CXTPStatusBarThemeOffice2013 object.
virtual void | FillStatusBar (CDC *pDC, CXTPStatusBar *pBar)
This method is called to fill a status bar.
virtual void | DrawStatusBarPaneBorder (CDC *pDC, CRect rc, CXTPStatusBarPane *pPane, BOOL bGripperPane)
This method is called to draw a frame for a single cell of the status bar.
virtual void | DrawStatusBarPaneSeparator (CDC *pDC, CRect rc, CXTPStatusBarPane *pPane)
This method is called to draw a status bar switch pane separator.
virtual void | DrawStatusBarPaneEntry (CDC *pDC, CRect rcItem, CXTPStatusBarPane *pPane)
This method is called to draw text for a single pane of the status bar.
virtual void | DrawStatusBarButtonFace (CDC *pDC, CRect rcItem, CXTPStatusBarPane *pPane)
This method is called to draw a status bar button.
virtual int | DrawStatusBarSwitchPane (CDC *pDC, CRect rcItem, CXTPStatusBarSwitchPane *pPane)
This method is called to draw a status bar switch pane.
virtual COLORREF | GetTextColor (CXTPStatusBarPane *pPane)
This method is called to retrieve the text color for the pane specified by pPane.

Additional Inherited Members

- Protected Attributes inherited from CXTPStatusBarThemeOffice2013
CXTPPaintManagerColor | m_clrButtonBack
Status bar button background color.
CXTPPaintManagerColor | m_clrButtonBackChecked
Status bar button checked background color.
CXTPPaintManagerColor | m_clrButtonBackHighlight
Status bar button highlight background color.
CXTPPaintManagerColor | m_clrButtonBackPushed
Status bar button pushed background color.
CXTPPaintManagerColor | m_clrButtonTextChecked
Status bar button checked text color.
CXTPPaintManagerColor | m_clrButtonTextHighlight
Status bar button highlight text color.
CXTPPaintManagerColor | m_clrButtonTextPushed
Status bar button pushed text color.

Detailed Description

The CXTPStatusBarThemeNativeWindows10 class is used to enable the Native Windows 10 style theme for the status bar.

Constructor & Destructor Documentation

◆ CXTPStatusBarThemeNativeWindows10()

CXTPStatusBarThemeNativeWindows10 ( CXTPPaintManager * pPaintManager )

Constructs a CXTPStatusBarThemeNativeWindows10 object.

Parameters
pPaintManager Pointer to the parent CXTPPaintManager object.

Member Function Documentation

◆ DrawStatusBarGripper()

virtual void DrawStatusBarGripper | ( | CDC * | pDC,
 |  | CRect | rcClient )
 virtual

This method is called to draw the status bar's gripper.

Parameters
pDC | Pointer to a valid device context
rcClient | Client rectangle of the status bar.

Reimplemented from CXTPStatusBarThemeOffice2013.

◆ GetStateColor()

virtual COLORREF GetStateColor ( ) const
virtual

Call this member function to get the application state color for the status bar.

Returns
Returns the application state color for the status bar

◆ SetStateColor()

virtual void SetStateColor ( COLORREF clrState )
virtual

Call this member function to set the application state color for the status bar.

Parameters
clrState COLORREF value representing the application state color. Use COLORREF_NULL to reset back to the default color.
The documentation for this class was generated from the following file:
  • XTPStatusBarThemeNativeWindows10.h


Toolkit Pro: CXTPStatusBarThemeNativeWindows11 Class Reference

Public Member Functions | List of all members
CXTPStatusBarThemeNativeWindows11 Class Reference

The CXTPStatusBarThemeNativeWindows11 class is used to enable the Native Windows 10 style theme for the status bar. More...

Inheritance diagram for CXTPStatusBarThemeNativeWindows11:
[legend]

Public Member Functions

CXTPStatusBarThemeNativeWindows11 (CXTPPaintManager *pPaintManager)
Constructs a CXTPStatusBarThemeNativeWindows11 object.
virtual void | DrawStatusBarGripper (CDC *pDC, CRect rcClient)
This method is called to draw the status bar's gripper.
virtual void | RefreshMetrics ()
This method is called to refresh colors and other theme specific metrics for the paint manager.
virtual void | SetStateColor (COLORREF clrState)
Call this member function to set the application state color for the status bar.
virtual COLORREF | GetStateColor () const
Call this member function to get the application state color for the status bar.
- Public Member Functions inherited from CXTPStatusBarThemeOffice2013
CXTPStatusBarThemeOffice2013 (CXTPPaintManager *pPaintManager)
Constructs a CXTPStatusBarThemeOffice2013 object.
virtual void | FillStatusBar (CDC *pDC, CXTPStatusBar *pBar)
This method is called to fill a status bar.
virtual void | DrawStatusBarPaneBorder (CDC *pDC, CRect rc, CXTPStatusBarPane *pPane, BOOL bGripperPane)
This method is called to draw a frame for a single cell of the status bar.
virtual void | DrawStatusBarPaneSeparator (CDC *pDC, CRect rc, CXTPStatusBarPane *pPane)
This method is called to draw a status bar switch pane separator.
virtual void | DrawStatusBarPaneEntry (CDC *pDC, CRect rcItem, CXTPStatusBarPane *pPane)
This method is called to draw text for a single pane of the status bar.
virtual void | DrawStatusBarButtonFace (CDC *pDC, CRect rcItem, CXTPStatusBarPane *pPane)
This method is called to draw a status bar button.
virtual int | DrawStatusBarSwitchPane (CDC *pDC, CRect rcItem, CXTPStatusBarSwitchPane *pPane)
This method is called to draw a status bar switch pane.
virtual COLORREF | GetTextColor (CXTPStatusBarPane *pPane)
This method is called to retrieve the text color for the pane specified by pPane.

Additional Inherited Members

- Protected Attributes inherited from CXTPStatusBarThemeOffice2013
CXTPPaintManagerColor | m_clrButtonBack
Status bar button background color.
CXTPPaintManagerColor | m_clrButtonBackChecked
Status bar button checked background color.
CXTPPaintManagerColor | m_clrButtonBackHighlight
Status bar button highlight background color.
CXTPPaintManagerColor | m_clrButtonBackPushed
Status bar button pushed background color.
CXTPPaintManagerColor | m_clrButtonTextChecked
Status bar button checked text color.
CXTPPaintManagerColor | m_clrButtonTextHighlight
Status bar button highlight text color.
CXTPPaintManagerColor | m_clrButtonTextPushed
Status bar button pushed text color.

Detailed Description

The CXTPStatusBarThemeNativeWindows11 class is used to enable the Native Windows 10 style theme for the status bar.

Constructor & Destructor Documentation

◆ CXTPStatusBarThemeNativeWindows11()

CXTPStatusBarThemeNativeWindows11 ( CXTPPaintManager * pPaintManager )

Constructs a CXTPStatusBarThemeNativeWindows11 object.

Parameters
pPaintManager Pointer to the parent CXTPPaintManager object.

Member Function Documentation

◆ DrawStatusBarGripper()

virtual void DrawStatusBarGripper | ( | CDC * | pDC,
 |  | CRect | rcClient )
 virtual

This method is called to draw the status bar's gripper.

Parameters
pDC | Pointer to a valid device context
rcClient | Client rectangle of the status bar.

Reimplemented from CXTPStatusBarThemeOffice2013.

◆ GetStateColor()

virtual COLORREF GetStateColor ( ) const
virtual

Call this member function to get the application state color for the status bar.

Returns
Returns the application state color for the status bar

◆ SetStateColor()

virtual void SetStateColor ( COLORREF clrState )
virtual

Call this member function to set the application state color for the status bar.

Parameters
clrState COLORREF value representing the application state color. Use COLORREF_NULL to reset back to the default color.
The documentation for this class was generated from the following file:
  • XTPStatusBarThemeNativeWindows11.h


Toolkit Pro: CXTPStatusBarThemeOffice2013 Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPStatusBarThemeOffice2013 Class Reference

The CXTPStatusBarThemeVisualStudio2015 class is used to enable the Office 2013 style theme for the status bar. More...

Inheritance diagram for CXTPStatusBarThemeOffice2013:
[legend]

Public Member Functions

CXTPStatusBarThemeOffice2013 (CXTPPaintManager *pPaintManager)
Constructs a CXTPStatusBarThemeOffice2013 object.
virtual void | FillStatusBar (CDC *pDC, CXTPStatusBar *pBar)
This method is called to fill a status bar.
virtual void | DrawStatusBarGripper (CDC *pDC, CRect rcClient)
This method is called to draw the status bar's gripper.
virtual void | DrawStatusBarPaneBorder (CDC *pDC, CRect rc, CXTPStatusBarPane *pPane, BOOL bGripperPane)
This method is called to draw a frame for a single cell of the status bar.
virtual void | DrawStatusBarPaneSeparator (CDC *pDC, CRect rc, CXTPStatusBarPane *pPane)
This method is called to draw a status bar switch pane separator.
virtual void | DrawStatusBarPaneEntry (CDC *pDC, CRect rcItem, CXTPStatusBarPane *pPane)
This method is called to draw text for a single pane of the status bar.
virtual void | DrawStatusBarButtonFace (CDC *pDC, CRect rcItem, CXTPStatusBarPane *pPane)
This method is called to draw a status bar button.
virtual int | DrawStatusBarSwitchPane (CDC *pDC, CRect rcItem, CXTPStatusBarSwitchPane *pPane)
This method is called to draw a status bar switch pane.
virtual void | RefreshMetrics ()
This method is called to refresh colors and other theme specific metrics for the paint manager.
virtual COLORREF | GetTextColor (CXTPStatusBarPane *pPane)
This method is called to retrieve the text color for the pane specified by pPane.

Protected Attributes

CXTPPaintManagerColor | m_clrButtonBack
Status bar button background color.
CXTPPaintManagerColor | m_clrButtonBackChecked
Status bar button checked background color.
CXTPPaintManagerColor | m_clrButtonBackHighlight
Status bar button highlight background color.
CXTPPaintManagerColor | m_clrButtonBackPushed
Status bar button pushed background color.
CXTPPaintManagerColor | m_clrButtonTextChecked
Status bar button checked text color.
CXTPPaintManagerColor | m_clrButtonTextHighlight
Status bar button highlight text color.
CXTPPaintManagerColor | m_clrButtonTextPushed
Status bar button pushed text color.

Detailed Description

The CXTPStatusBarThemeVisualStudio2015 class is used to enable the Office 2013 style theme for the status bar.

Constructor & Destructor Documentation

◆ CXTPStatusBarThemeOffice2013()

CXTPStatusBarThemeOffice2013 ( CXTPPaintManager * pPaintManager )

Constructs a CXTPStatusBarThemeOffice2013 object.

Parameters
pPaintManager Pointer to the parent CXTPPaintManager object.

Member Function Documentation

◆ DrawStatusBarButtonFace()

virtual void DrawStatusBarButtonFace | ( | CDC * | pDC,
 |  | CRect | rcItem,
 |  | CXTPStatusBarPane * | pPane )
 virtual

This method is called to draw a status bar button.

Parameters
pDC | Pointer to a valid device context.
rcItem | Item rectangle.
pPane | The status bar pane to draw.

◆ DrawStatusBarGripper()

virtual void DrawStatusBarGripper | ( | CDC * | pDC,
 |  | CRect | rcClient )
 virtual

This method is called to draw the status bar's gripper.

Parameters
pDC | Pointer to a valid device context.
rcClient | Client rectangle of the status bar.

Reimplemented in CXTPStatusBarThemeNativeWindows10, CXTPStatusBarThemeNativeWindows11, CXTPStatusBarThemeVisualStudio2015, CXTPStatusBarThemeVisualStudio2017, CXTPStatusBarThemeVisualStudio2019, and CXTPStatusBarThemeVisualStudio2022.

◆ DrawStatusBarPaneBorder()

virtual void DrawStatusBarPaneBorder | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | CXTPStatusBarPane * | pPane,
 |  | BOOL | bGripperPane )
 virtual

This method is called to draw a frame for a single cell of the status bar.

Parameters
pDC | Pointer to a valid device context.
rc | CRect object specifying the size of the area.
pPane | The status bar pane to draw.
bGripperPane | TRUE if the pane is the last cell of the status bar.

◆ DrawStatusBarPaneEntry()

virtual void DrawStatusBarPaneEntry | ( | CDC * | pDC,
 |  | CRect | rcItem,
 |  | CXTPStatusBarPane * | pPane )
 virtual

This method is called to draw text for a single pane of the status bar.

Parameters
pDC | Pointer to a valid device context.
pPane | The status bar pane to draw.
rcItem | Item rectangle.

◆ DrawStatusBarPaneSeparator()

virtual void DrawStatusBarPaneSeparator | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | CXTPStatusBarPane * | pPane )
 virtual

This method is called to draw a status bar switch pane separator.

Parameters
pDC | Pointer to a valid device context.
rc | CRect object specifying size of area.
pPane | The status bar pane need to draw.

◆ DrawStatusBarSwitchPane()

virtual int DrawStatusBarSwitchPane | ( | CDC * | pDC,
 |  | CRect | rcItem,
 |  | CXTPStatusBarSwitchPane * | pPane )
 virtual

This method is called to draw a status bar switch pane.

Parameters
pDC | Pointer to a valid device context.
rcItem | Item rectangle.
pPane | The status bar pane to draw.
Returns
Returns the width of the switch pane.

◆ FillStatusBar()

virtual void FillStatusBar | ( | CDC * | pDC,
 |  | CXTPStatusBar * | pBar )
 virtual

This method is called to fill a status bar.

Parameters
pDC | Pointer to a valid device context.
pBar | Pointer to a CXTPStatusBar object.

◆ GetTextColor()

virtual COLORREF GetTextColor ( CXTPStatusBarPane * pPane )
virtual

This method is called to retrieve the text color for the pane specified by pPane.

Parameters
pPane Pointer to the CXTPStatusBarPane object to retrieve the color for.
Returns
Returns the text color for the pane specified by pPane
The documentation for this class was generated from the following file:
  • XTPStatusBarThemeOffice2013.h


Toolkit Pro: CXTPStatusBarThemeVisualStudio2015 Class Reference

Public Member Functions | List of all members
CXTPStatusBarThemeVisualStudio2015 Class Reference

The CXTPStatusBarThemeVisualStudio2015 class is used to enable the Visual Studio 2015 style theme for the status bar. More...

Inheritance diagram for CXTPStatusBarThemeVisualStudio2015:
[legend]

Public Member Functions

CXTPStatusBarThemeVisualStudio2015 (CXTPPaintManager *pPaintManager)
Constructs a CXTPStatusBarThemeVisualStudio2015 object.
~CXTPStatusBarThemeVisualStudio2015 ()
Handles object destruction.
virtual void | DrawStatusBarGripper (CDC *pDC, CRect rcClient)
This method is called to draw the status bar's gripper.
virtual void | RefreshMetrics ()
This method is called to refresh colors and other theme specific metrics for the paint manager.
virtual void | SetStateColor (COLORREF clrState)
Call this member function to sets the application state color for the status bar.
virtual COLORREF | GetStateColor () const
Call this member function to gets the application state color for the status bar.
- Public Member Functions inherited from CXTPStatusBarThemeOffice2013
CXTPStatusBarThemeOffice2013 (CXTPPaintManager *pPaintManager)
Constructs a CXTPStatusBarThemeOffice2013 object.
virtual void | FillStatusBar (CDC *pDC, CXTPStatusBar *pBar)
This method is called to fill a status bar.
virtual void | DrawStatusBarPaneBorder (CDC *pDC, CRect rc, CXTPStatusBarPane *pPane, BOOL bGripperPane)
This method is called to draw a frame for a single cell of the status bar.
virtual void | DrawStatusBarPaneSeparator (CDC *pDC, CRect rc, CXTPStatusBarPane *pPane)
This method is called to draw a status bar switch pane separator.
virtual void | DrawStatusBarPaneEntry (CDC *pDC, CRect rcItem, CXTPStatusBarPane *pPane)
This method is called to draw text for a single pane of the status bar.
virtual void | DrawStatusBarButtonFace (CDC *pDC, CRect rcItem, CXTPStatusBarPane *pPane)
This method is called to draw a status bar button.
virtual int | DrawStatusBarSwitchPane (CDC *pDC, CRect rcItem, CXTPStatusBarSwitchPane *pPane)
This method is called to draw a status bar switch pane.
virtual COLORREF | GetTextColor (CXTPStatusBarPane *pPane)
This method is called to retrieve the text color for the pane specified by pPane.

Additional Inherited Members

- Protected Attributes inherited from CXTPStatusBarThemeOffice2013
CXTPPaintManagerColor | m_clrButtonBack
Status bar button background color.
CXTPPaintManagerColor | m_clrButtonBackChecked
Status bar button checked background color.
CXTPPaintManagerColor | m_clrButtonBackHighlight
Status bar button highlight background color.
CXTPPaintManagerColor | m_clrButtonBackPushed
Status bar button pushed background color.
CXTPPaintManagerColor | m_clrButtonTextChecked
Status bar button checked text color.
CXTPPaintManagerColor | m_clrButtonTextHighlight
Status bar button highlight text color.
CXTPPaintManagerColor | m_clrButtonTextPushed
Status bar button pushed text color.

Detailed Description

The CXTPStatusBarThemeVisualStudio2015 class is used to enable the Visual Studio 2015 style theme for the status bar.

Constructor & Destructor Documentation

◆ CXTPStatusBarThemeVisualStudio2015()

CXTPStatusBarThemeVisualStudio2015 ( CXTPPaintManager * pPaintManager )

Constructs a CXTPStatusBarThemeVisualStudio2015 object.

Parameters
pPaintManager Pointer to the parent CXTPPaintManager object.

Member Function Documentation

◆ DrawStatusBarGripper()

virtual void DrawStatusBarGripper | ( | CDC * | pDC,
 |  | CRect | rcClient )
 virtual

This method is called to draw the status bar's gripper.

Parameters
pDC | Pointer to a valid device context
rcClient | Client rectangle of the status bar.

Reimplemented from CXTPStatusBarThemeOffice2013.

◆ GetStateColor()

virtual COLORREF GetStateColor ( ) const
virtual

Call this member function to gets the application state color for the status bar.

Returns
Returns the application state color for the status bar

◆ SetStateColor()

virtual void SetStateColor ( COLORREF clrState )
virtual

Call this member function to sets the application state color for the status bar.

Parameters
clrState COLORREF value representing the application state color. Use COLORREF_NULL to reset back to default color.
The documentation for this class was generated from the following file:
  • XTPStatusBarThemeVisualStudio2015.h


Toolkit Pro: CXTPStatusBarThemeVisualStudio2017 Class Reference

Public Member Functions | List of all members
CXTPStatusBarThemeVisualStudio2017 Class Reference

The CXTPStatusBarThemeVisualStudio2017 class is used to enable the Visual Studio 2017 style theme for the status bar. More...

Inheritance diagram for CXTPStatusBarThemeVisualStudio2017:
[legend]

Public Member Functions

CXTPStatusBarThemeVisualStudio2017 (CXTPPaintManager *pPaintManager)
Constructs a CXTPStatusBarThemeVisualStudio2017 object.
~CXTPStatusBarThemeVisualStudio2017 ()
Handles object destruction.
virtual void | DrawStatusBarGripper (CDC *pDC, CRect rcClient)
This method is called to draw the status bar's gripper.
virtual void | RefreshMetrics ()
This method is called to refresh colors and other theme specific metrics for the paint manager.
virtual void | SetStateColor (COLORREF clrState)
Call this member function to set the application state color for the status bar.
virtual COLORREF | GetStateColor () const
Call this member function to get the application state color for the status bar.
- Public Member Functions inherited from CXTPStatusBarThemeOffice2013
CXTPStatusBarThemeOffice2013 (CXTPPaintManager *pPaintManager)
Constructs a CXTPStatusBarThemeOffice2013 object.
virtual void | FillStatusBar (CDC *pDC, CXTPStatusBar *pBar)
This method is called to fill a status bar.
virtual void | DrawStatusBarPaneBorder (CDC *pDC, CRect rc, CXTPStatusBarPane *pPane, BOOL bGripperPane)
This method is called to draw a frame for a single cell of the status bar.
virtual void | DrawStatusBarPaneSeparator (CDC *pDC, CRect rc, CXTPStatusBarPane *pPane)
This method is called to draw a status bar switch pane separator.
virtual void | DrawStatusBarPaneEntry (CDC *pDC, CRect rcItem, CXTPStatusBarPane *pPane)
This method is called to draw text for a single pane of the status bar.
virtual void | DrawStatusBarButtonFace (CDC *pDC, CRect rcItem, CXTPStatusBarPane *pPane)
This method is called to draw a status bar button.
virtual int | DrawStatusBarSwitchPane (CDC *pDC, CRect rcItem, CXTPStatusBarSwitchPane *pPane)
This method is called to draw a status bar switch pane.
virtual COLORREF | GetTextColor (CXTPStatusBarPane *pPane)
This method is called to retrieve the text color for the pane specified by pPane.

Additional Inherited Members

- Protected Attributes inherited from CXTPStatusBarThemeOffice2013
CXTPPaintManagerColor | m_clrButtonBack
Status bar button background color.
CXTPPaintManagerColor | m_clrButtonBackChecked
Status bar button checked background color.
CXTPPaintManagerColor | m_clrButtonBackHighlight
Status bar button highlight background color.
CXTPPaintManagerColor | m_clrButtonBackPushed
Status bar button pushed background color.
CXTPPaintManagerColor | m_clrButtonTextChecked
Status bar button checked text color.
CXTPPaintManagerColor | m_clrButtonTextHighlight
Status bar button highlight text color.
CXTPPaintManagerColor | m_clrButtonTextPushed
Status bar button pushed text color.

Detailed Description

The CXTPStatusBarThemeVisualStudio2017 class is used to enable the Visual Studio 2017 style theme for the status bar.

Constructor & Destructor Documentation

◆ CXTPStatusBarThemeVisualStudio2017()

CXTPStatusBarThemeVisualStudio2017 ( CXTPPaintManager * pPaintManager )

Constructs a CXTPStatusBarThemeVisualStudio2017 object.

Parameters
pPaintManager Pointer to the parent CXTPPaintManager object.

Member Function Documentation

◆ DrawStatusBarGripper()

virtual void DrawStatusBarGripper | ( | CDC * | pDC,
 |  | CRect | rcClient )
 virtual

This method is called to draw the status bar's gripper.

Parameters
pDC | Pointer to a valid device context
rcClient | Client rectangle of the status bar.

Reimplemented from CXTPStatusBarThemeOffice2013.

◆ GetStateColor()

virtual COLORREF GetStateColor ( ) const
virtual

Call this member function to get the application state color for the status bar.

Returns
Returns the application state color for the status bar

◆ SetStateColor()

virtual void SetStateColor ( COLORREF clrState )
virtual

Call this member function to set the application state color for the status bar.

Parameters
clrState COLORREF value representing the application state color. Use COLORREF_NULL to reset back to default color.
The documentation for this class was generated from the following file:
  • XTPStatusBarThemeVisualStudio2017.h


Toolkit Pro: CXTPStatusBarThemeVisualStudio2019 Class Reference

Public Member Functions | List of all members
CXTPStatusBarThemeVisualStudio2019 Class Reference

The CXTPStatusBarThemeVisualStudio2019 class is used to enable the Visual Studio 2019 style theme for the status bar. More...

Inheritance diagram for CXTPStatusBarThemeVisualStudio2019:
[legend]

Public Member Functions

CXTPStatusBarThemeVisualStudio2019 (CXTPPaintManager *pPaintManager)
Constructs a CXTPStatusBarThemeVisualStudio2019 object.
~CXTPStatusBarThemeVisualStudio2019 ()
Handles object destruction.
virtual void | DrawStatusBarGripper (CDC *pDC, CRect rcClient)
This method is called to draw the status bar's gripper.
virtual void | RefreshMetrics ()
This method is called to refresh colors and other theme specific metrics for the paint manager.
virtual void | SetStateColor (COLORREF clrState)
Call this member function to set the application state color for the status bar.
virtual COLORREF | GetStateColor () const
Call this member function to get the application state color for the status bar.
- Public Member Functions inherited from CXTPStatusBarThemeOffice2013
CXTPStatusBarThemeOffice2013 (CXTPPaintManager *pPaintManager)
Constructs a CXTPStatusBarThemeOffice2013 object.
virtual void | FillStatusBar (CDC *pDC, CXTPStatusBar *pBar)
This method is called to fill a status bar.
virtual void | DrawStatusBarPaneBorder (CDC *pDC, CRect rc, CXTPStatusBarPane *pPane, BOOL bGripperPane)
This method is called to draw a frame for a single cell of the status bar.
virtual void | DrawStatusBarPaneSeparator (CDC *pDC, CRect rc, CXTPStatusBarPane *pPane)
This method is called to draw a status bar switch pane separator.
virtual void | DrawStatusBarPaneEntry (CDC *pDC, CRect rcItem, CXTPStatusBarPane *pPane)
This method is called to draw text for a single pane of the status bar.
virtual void | DrawStatusBarButtonFace (CDC *pDC, CRect rcItem, CXTPStatusBarPane *pPane)
This method is called to draw a status bar button.
virtual int | DrawStatusBarSwitchPane (CDC *pDC, CRect rcItem, CXTPStatusBarSwitchPane *pPane)
This method is called to draw a status bar switch pane.
virtual COLORREF | GetTextColor (CXTPStatusBarPane *pPane)
This method is called to retrieve the text color for the pane specified by pPane.

Additional Inherited Members

- Protected Attributes inherited from CXTPStatusBarThemeOffice2013
CXTPPaintManagerColor | m_clrButtonBack
Status bar button background color.
CXTPPaintManagerColor | m_clrButtonBackChecked
Status bar button checked background color.
CXTPPaintManagerColor | m_clrButtonBackHighlight
Status bar button highlight background color.
CXTPPaintManagerColor | m_clrButtonBackPushed
Status bar button pushed background color.
CXTPPaintManagerColor | m_clrButtonTextChecked
Status bar button checked text color.
CXTPPaintManagerColor | m_clrButtonTextHighlight
Status bar button highlight text color.
CXTPPaintManagerColor | m_clrButtonTextPushed
Status bar button pushed text color.

Detailed Description

The CXTPStatusBarThemeVisualStudio2019 class is used to enable the Visual Studio 2019 style theme for the status bar.

Constructor & Destructor Documentation

◆ CXTPStatusBarThemeVisualStudio2019()

CXTPStatusBarThemeVisualStudio2019 ( CXTPPaintManager * pPaintManager )

Constructs a CXTPStatusBarThemeVisualStudio2019 object.

Parameters
pPaintManager Pointer to the parent CXTPPaintManager object.

Member Function Documentation

◆ DrawStatusBarGripper()

virtual void DrawStatusBarGripper | ( | CDC * | pDC,
 |  | CRect | rcClient )
 virtual

This method is called to draw the status bar's gripper.

Parameters
pDC | Pointer to a valid device context
rcClient | Client rectangle of the status bar.

Reimplemented from CXTPStatusBarThemeOffice2013.

◆ GetStateColor()

virtual COLORREF GetStateColor ( ) const
virtual

Call this member function to get the application state color for the status bar.

Returns
Returns the application state color for the status bar

◆ SetStateColor()

virtual void SetStateColor ( COLORREF clrState )
virtual

Call this member function to set the application state color for the status bar.

Parameters
clrState COLORREF value representing the application state color. Use COLORREF_NULL to reset back to default color.
The documentation for this class was generated from the following file:
  • XTPStatusBarThemeVisualStudio2019.h


Toolkit Pro: CXTPStatusBarThemeVisualStudio2022 Class Reference

Public Member Functions | List of all members
CXTPStatusBarThemeVisualStudio2022 Class Reference

The CXTPStatusBarThemeVisualStudio2022 class is used to enable the Visual Studio 2022 style theme for the status bar. More...

Inheritance diagram for CXTPStatusBarThemeVisualStudio2022:
[legend]

Public Member Functions

CXTPStatusBarThemeVisualStudio2022 (CXTPPaintManager *pPaintManager)
Constructs a CXTPStatusBarThemeVisualStudio2022 object.
~CXTPStatusBarThemeVisualStudio2022 ()
Handles object destruction.
virtual void | DrawStatusBarGripper (CDC *pDC, CRect rcClient)
This method is called to draw the status bar's gripper.
virtual void | RefreshMetrics ()
This method is called to refresh colors and other theme specific metrics for the paint manager.
virtual void | SetStateColor (COLORREF clrState)
Call this member function to set the application state color for the status bar.
virtual COLORREF | GetStateColor () const
Call this member function to get the application state color for the status bar.
- Public Member Functions inherited from CXTPStatusBarThemeOffice2013
CXTPStatusBarThemeOffice2013 (CXTPPaintManager *pPaintManager)
Constructs a CXTPStatusBarThemeOffice2013 object.
virtual void | FillStatusBar (CDC *pDC, CXTPStatusBar *pBar)
This method is called to fill a status bar.
virtual void | DrawStatusBarPaneBorder (CDC *pDC, CRect rc, CXTPStatusBarPane *pPane, BOOL bGripperPane)
This method is called to draw a frame for a single cell of the status bar.
virtual void | DrawStatusBarPaneSeparator (CDC *pDC, CRect rc, CXTPStatusBarPane *pPane)
This method is called to draw a status bar switch pane separator.
virtual void | DrawStatusBarPaneEntry (CDC *pDC, CRect rcItem, CXTPStatusBarPane *pPane)
This method is called to draw text for a single pane of the status bar.
virtual void | DrawStatusBarButtonFace (CDC *pDC, CRect rcItem, CXTPStatusBarPane *pPane)
This method is called to draw a status bar button.
virtual int | DrawStatusBarSwitchPane (CDC *pDC, CRect rcItem, CXTPStatusBarSwitchPane *pPane)
This method is called to draw a status bar switch pane.
virtual COLORREF | GetTextColor (CXTPStatusBarPane *pPane)
This method is called to retrieve the text color for the pane specified by pPane.

Additional Inherited Members

- Protected Attributes inherited from CXTPStatusBarThemeOffice2013
CXTPPaintManagerColor | m_clrButtonBack
Status bar button background color.
CXTPPaintManagerColor | m_clrButtonBackChecked
Status bar button checked background color.
CXTPPaintManagerColor | m_clrButtonBackHighlight
Status bar button highlight background color.
CXTPPaintManagerColor | m_clrButtonBackPushed
Status bar button pushed background color.
CXTPPaintManagerColor | m_clrButtonTextChecked
Status bar button checked text color.
CXTPPaintManagerColor | m_clrButtonTextHighlight
Status bar button highlight text color.
CXTPPaintManagerColor | m_clrButtonTextPushed
Status bar button pushed text color.

Detailed Description

The CXTPStatusBarThemeVisualStudio2022 class is used to enable the Visual Studio 2022 style theme for the status bar.

Constructor & Destructor Documentation

◆ CXTPStatusBarThemeVisualStudio2022()

CXTPStatusBarThemeVisualStudio2022 ( CXTPPaintManager * pPaintManager )

Constructs a CXTPStatusBarThemeVisualStudio2022 object.

Parameters
pPaintManager Pointer to the parent CXTPPaintManager object.

Member Function Documentation

◆ DrawStatusBarGripper()

virtual void DrawStatusBarGripper | ( | CDC * | pDC,
 |  | CRect | rcClient )
 virtual

This method is called to draw the status bar's gripper.

Parameters
pDC | Pointer to a valid device context
rcClient | Client rectangle of the status bar.

Reimplemented from CXTPStatusBarThemeOffice2013.

◆ GetStateColor()

virtual COLORREF GetStateColor ( ) const
virtual

Call this member function to get the application state color for the status bar.

Returns
Returns the application state color for the status bar

◆ SetStateColor()

virtual void SetStateColor ( COLORREF clrState )
virtual

Call this member function to set the application state color for the status bar.

Parameters
clrState COLORREF value representing the application state color. Use COLORREF_NULL to reset back to default color.
The documentation for this class was generated from the following file:
  • XTPStatusBarThemeVisualStudio2022.h


Toolkit Pro: CXTPStickerBase Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPStickerBase Class Referenceabstract

A sticker base control. More...

Inheritance diagram for CXTPStickerBase:
[legend]

Public Member Functions

CXTPStickerBase ()
Construct a sticker object.
virtual | ~CXTPStickerBase ()
Handles resource cleanup.
BOOL | Create ()
Creates a sticker control.

Protected Attributes

int m_stickers
Allowed stickers for tab client.

Detailed Description

A sticker base control.

Member Function Documentation

◆ Create()

BOOL Create ( )

Creates a sticker control.

Returns
TRUE if the control is successfully create, FALSE otherwise.
The documentation for this class was generated from the following file:
  • XTPTabClientSticker.h


Toolkit Pro: CXTPSubscriptionList< Observable, Observer > Class Template Reference

Public Member Functions | List of all members
CXTPSubscriptionList< Observable, Observer > Class Template Reference

Holds a list of observable objects to which an oberser is subscribed. More...

Inheritance diagram for CXTPSubscriptionList< Observable, Observer >:
[legend]

Public Member Functions

CXTPSubscriptionList (Observer &observer)
Constructs a subscription list for the provided observer.
~CXTPSubscriptionList ()
Handles subscription list destruction.
UINT GetSubscriptionCount () const
Obtains the number of registered subscriptions for the observer.

Detailed Description

template<class Observable, class Observer>
class CXTPSubscriptionList< Observable, Observer >

Holds a list of observable objects to which an oberser is subscribed.

When a list is destructed, it unsubscribes the observer from all subscribed observable objects.

Parameters
Observable | Type of the observable object.
Observer | Type of the observer object.
See also
CXTPObservable

Constructor & Destructor Documentation

◆ CXTPSubscriptionList()

template<class Observable , class Observer >
AFX_INLINE CXTPSubscriptionList ( Observer & observer )
explicit

Constructs a subscription list for the provided observer.

Parameters
observer Observer reference.

Member Function Documentation

◆ GetSubscriptionCount()

template<class Observable , class Observer >
AFX_INLINE UINT GetSubscriptionCount ( ) const

Obtains the number of registered subscriptions for the observer.

Returns
The number of registered subscriptions for the observer.
The documentation for this class was generated from the following file:
  • XTPSystemHelpers.h


Toolkit Pro: CXTPSvgImage Class Reference

Public Types | Public Member Functions | List of all members
CXTPSvgImage Class Reference

Implements basic SVG image format support. More...

Public Types

enum Units {
unitPX , unitPT , unitPC , unitMM ,
unitCM , unitIN , unitPercent , unitEM ,
unitEX
}
Defines image units. More...

Public Member Functions

CXTPSvgImage ()
Constructs an uninitialized SVG image.
~CXTPSvgImage ()
Handles object desctruction.
BOOL | Load (const void *pData, SIZE_T cbSize, Units nUnits=unitPX)
Loads SVG data from the specified memory location.
BOOL | Load (IStream *pStream, Units nUnits=unitPX)
Loads SVG data from the specified stream.
BOOL | Load (CFile *pFile, Units nUnits=unitPX)
Loads SVG data from the specified file.
BOOL | Load (LPCTSTR lpFilePath, Units nUnits=unitPX)
Loads SVG data from the specified file.
BOOL | Load (HMODULE hModule, HRSRC hRes, Units nUnits=unitPX)
Loads SVG data from the specified resource.
BOOL | IsLoaded () const
Determines if SVG data has been successfuly loaded.
BOOL | IsAlpha () const
Determines if the loaded .SVG file has alpha layer.
const CBitmap * | GetBitmap () const
Obtains bitmap object that contains a rasterized SVG image.
CSize | GetSize () const
Gets rasterized SVG image size.
void | SetSize (CSize size)
Sets rasterized SVG image size.
void | Draw (HDC hDC, CPoint pt, BOOL bPreserveAlpha=TRUE)
Draws a loaded SVG image to the target device context.
void | Draw (CDC *pDC, CPoint pt, BOOL bPreserveAlpha=TRUE)
Draws a loaded SVG image to the target device context.
void | Draw (HDC hDC, CRect rc, BOOL bPreserveAlpha=TRUE)
Draws a loaded SVG image to the target device context.
void | Draw (CDC *pDC, CRect rc, BOOL bPreserveAlpha=TRUE)
Draws a loaded SVG image to the target device context.
SIZE_T | DirectDraw (PVOID pBits, SIZE_T cbSize, CRect rc)
Draws rasterized image bits directly into the specified memoby buffer.

Detailed Description

Implements basic SVG image format support.

Member Enumeration Documentation

◆ Units

enum Units

Defines image units.

Enumerator
unitPX | Pixel units.
unitPT | Point units.
unitPC | Picas units.
unitMM | Millimeter units.
unitCM | Centimeter units.
unitIN | Inch units.
unitPercent | Persent units.
unitEM | Relative to the font size of the current element.
unitEX | Relative to the x-height of Helvetica font.

Member Function Documentation

◆ DirectDraw()

SIZE_T DirectDraw | ( | PVOID | pBits,
 |  | SIZE_T | cbSize,
 |  | CRect | rc )

Draws rasterized image bits directly into the specified memoby buffer.

Parameters
pBits | Memory buffer pointer that is at least of szIcon.cx * szIcon.cy * 4 bytes length.
cbSize | Size of memory buffer.
rc | Size of area to draw.
Returns
The number of bytes written to the specified memory buffer or 0 if no image data has been drawn.

Image data consists of Width * Height DWORD color entries where each DWORD color entry has the following color format: AlphaMask = 0xff000000, RedMask = 0x00ff0000, GreenMask = 0x0000ff00, BlueMask = 0x000000ff.

See also
IsDirectDrawSupported

◆ Draw() [1/4]

void Draw | ( | CDC * | pDC,
 |  | CPoint | pt,
 |  | BOOL | bPreserveAlpha = TRUE )

Draws a loaded SVG image to the target device context.

Parameters
pDC | Target device context object pointer.
pt | Target position of the drawn SVG image of its current size. from the current SVG size then the current SVG size will be updated and image re-rasterized.
bPreserveAlpha | If the loaded SVG image contains alpha channel then setting bPreserveAlpha tp FALSE will force to draw it opaque.

The first call after changing SVG size or loading a new SVG image results in an expensive rasterization procedure.

◆ Draw() [2/4]

void Draw | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | BOOL | bPreserveAlpha = TRUE )

Draws a loaded SVG image to the target device context.

Parameters
pDC | Target device context object pointer.
rc | Target rectangle of the drawn SVG image. If rectangle size is different from the current SVG size then the current SVG size will be updated and image re-rasterized.
bPreserveAlpha | If the loaded SVG image contains alpha channel then setting bPreserveAlpha tp FALSE will force to draw it opaque.

The first call after changing SVG size or loading a new SVG image results in an expensive rasterization procedure.

◆ Draw() [3/4]

void Draw | ( | HDC | hDC,
 |  | CPoint | pt,
 |  | BOOL | bPreserveAlpha = TRUE )

Draws a loaded SVG image to the target device context.

Parameters
hDC | Target device context handle.
pt | Target position of the drawn SVG image of its current size.
bPreserveAlpha | If the loaded SVG image contains alpha channel then setting bPreserveAlpha tp FALSE will force to draw it opaque.

The first call after changing SVG size or loading a new SVG image results in an expensive rasterization procedure.

◆ Draw() [4/4]

void Draw | ( | HDC | hDC,
 |  | CRect | rc,
 |  | BOOL | bPreserveAlpha = TRUE )

Draws a loaded SVG image to the target device context.

Parameters
hDC | Target device context handle.
rc | Target rectangle of the drawn SVG image. If rectangle size is different from the current SVG size then the current SVG size will be updated and image re-rasterized.
bPreserveAlpha | If the loaded SVG image contains alpha channel then setting bPreserveAlpha tp FALSE will force to draw it opaque.

The first call after changing SVG size or loading a new SVG image results in an expensive rasterization procedure.

◆ GetBitmap()

const CBitmap * GetBitmap ( ) const

Obtains bitmap object that contains a rasterized SVG image.

Returns
A bitmap object pointer or NULL if an error occurrs.

The first call after changing SVG size or loading a new SVG image results in an expensive rasterization procedure.

◆ GetSize()

CSize GetSize ( ) const

Gets rasterized SVG image size.

Returns
The current rasterized image size.

Changing rasterized image size resets the cached rasterized bitmap bitmap which we'll cause an expesive image rasterization procedure the next time when image data is required.

◆ IsAlpha()

BOOL IsAlpha ( ) const

Determines if the loaded .SVG file has alpha layer.

Returns
TRUE if the .SVG file has alpha layer.

◆ IsLoaded()

BOOL IsLoaded ( ) const

Determines if SVG data has been successfuly loaded.

Returns
TRUE if SVG data has been loaded and available, FALSE otherwise.

◆ Load() [1/5]

BOOL Load | ( | CFile * | pFile,
 |  | Units | nUnits = unitPX )

Loads SVG data from the specified file.

Parameters
pFile | Pointer to a file object to load SVG data from. The data will be loaded from the current file read position. nUnits Image units to be used by default.
nUnits | Image units to be used by default.
Returns
TRUE if successful, otherwise FALSE.

◆ Load() [2/5]

BOOL Load | ( | const void * | pData,
 |  | SIZE_T | cbSize,
 |  | Units | nUnits = unitPX )

Loads SVG data from the specified memory location.

Parameters
pData | Pointer to SVG memory buffer start.
cbSize | Size of SVG memory buffer.
nUnits | Image units to be used by default.
Returns
TRUE if successful, otherwise FALSE.

◆ Load() [3/5]

BOOL Load | ( | HMODULE | hModule,
 |  | HRSRC | hRes,
 |  | Units | nUnits = unitPX )

Loads SVG data from the specified resource.

Parameters
hModule | Source module handle.
hRes | Source resource handle.
nUnits | Image units to be used by default.
Returns
TRUE if successful, otherwise FALSE.

◆ Load() [4/5]

BOOL Load | ( | IStream * | pStream,
 |  | Units | nUnits = unitPX )

Loads SVG data from the specified stream.

Parameters
pStream | Pointer to a stream object to load SVG data from. The data will be loaded from the current stream read position. nUnits Image units to be used by default.
nUnits | Image units to be used by default.
Returns
TRUE if successful, otherwise FALSE.

◆ Load() [5/5]

BOOL Load | ( | LPCTSTR | lpFilePath,
 |  | Units | nUnits = unitPX )

Loads SVG data from the specified file.

Parameters
lpFilePath | File path string.
nUnits | Image units to be used by default.
Returns
TRUE if successful, otherwise FALSE.

◆ SetSize()

void SetSize ( CSize size )

Sets rasterized SVG image size.

Parameters
size New rasterized image size.

Changing rasterized image size resets the cached rasterized bitmap bitmap which we'll cause an expesive image rasterization procedure the next time when image data is required.

The documentation for this class was generated from the following file:
  • XTPSvgImage.h


Toolkit Pro: CXTPSvgPreviewProvider Class Reference

List of all members
CXTPSvgPreviewProvider Class Reference

Provides a preview handler for XAML files that uses Markup components for rendering file contents. More...

Inheritance diagram for CXTPSvgPreviewProvider:
[legend]

Additional Inherited Members

- Public Member Functions inherited from IXTPPreviewProvider
virtual | ~IXTPPreviewProvider ()
Handles object destruction.
- Protected Member Functions inherited from CXTPPreviewProviderBase
CXTPPreviewProviderBase ()
Handles object construction.
void | BindHost (IXTPPreviewHost &host)
The method is called by the host preview control when the provider is initially bound to the host.
IXTPPreviewHost & | GetHost () const
Obtains the preview host interface that the provider is bound to.

Detailed Description

Provides a preview handler for XAML files that uses Markup components for rendering file contents.

See also
CXTPSystemPreviewProvider, CXTPCommonPicturePreviewProvider, CXTPGifPreviewProvider, CXTPMsgPreviewProvider, CXTPTextPreviewProvider
The documentation for this class was generated from the following file:
  • XTPSvgPreviewProvider.h


Toolkit Pro: CXTPSwitchViewButtonPart Class Reference

Public Member Functions | List of all members
CXTPSwitchViewButtonPart Class Reference

This class implements SwitchView button part of the SwitchViewBar. More...

Inheritance diagram for CXTPSwitchViewButtonPart:
[legend]

Public Member Functions

virtual void | RefreshMetrics ()
Performs refreshing of graphical related parameters from system settings.
virtual void | AdjustLayout (CDC *pDC, const CRect &rcRect)
This member function is used to adjust the object's layout depending on the provided bounding rectangle.
virtual void | Draw (CDC *pDC)
This member function is used to draw the part content utilizing the specified device context.
- Public Member Functions inherited from CXTPCalendarCaptionBarThemePart
CXTPCalendarCaptionBarThemePart (CXTPCalendarCaptionBarTheme *pTheme, int nPartID)
Default object constructor.
virtual | ~CXTPCalendarCaptionBarThemePart ()
Default object destructor.
virtual void | Redraw (BOOL bUpdateNow=FALSE)
This member function initiates the CalendarCaptionBar control's redrawing.
virtual BOOL | HitTest (const CPoint &pt) const
This member function is used to determine is the specified point over visible object rectangle.
virtual CXTPCalendarCaptionBarTheme * | GetTheme () const
This member function is used to obtain pointer to parent CXTPCalendarCaptionBarTheme object.
virtual XTPCalendarTheme | GetPaintTheme () const
This member function is used to obtain current paint theme.
virtual int | GetPartID () const
This member function is used to obtain an object identifier.
virtual CRect | GetRect () const
This member function is used to obtain an object rectangle.
virtual CString | GetText () const
This member function is used to obtain an object text.
virtual void | SetText (LPCTSTR pcszText)
This member function is used to set object text.
virtual BOOL | IsVisible () const
This member function is used to get is part object visible.
virtual void | SetVisible (BOOL bVisible)
This member function is used to set visible object's state.
virtual int | GetCheck () const
This member function is used to get checked state.
virtual void | SetCheck (int nCheck)
This member function is used to set checked state.
int | GetState () const
This member function is used to get object state (flags from CXTPCalendarCaptionBarThemePart::EStates enum).
virtual void | SetState (int nState)
This member function is used to set object state as set of flags from CXTPCalendarCaptionBarThemePart::EStates enum.
virtual COLORREF | GetTextColor ()
This member function is used to get object text color.
CXTPCalendarCaptionBarPaintManager * | GetPaintManager () const
Gets the paint manager.
virtual void | OnMouseMove (UINT nFlags, CPoint point)
This member function is used to processes mouse movement events.
virtual BOOL | OnLButtonDown (UINT nFlags, CPoint point)
This member function is used to process left mouse button down events.
virtual BOOL | OnLButtonUp (UINT nFlags, CPoint point)
This member function is used to process left mouse button up events.
- Public Member Functions inherited from CXTPCalendarWMHandler
CXTPCalendarWMHandler ()
Default object constructor.
virtual int | GetChildHandlersCount () const
This member function is used to obtain the number of CXTPCalendarWMHandler elements in the descendant handlers collection.
virtual CXTPCalendarWMHandler * | GetChildHandlerAt (int nIndex) const
Call this method to get a handler object at the specified numeric index.
virtual BOOL | OnLButtonDblClk (UINT nFlags, CPoint point)
This member function is used to process left mouse button double click events.
virtual void | OnChar (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process keyboard events.
virtual void | OnKeyDown (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process key-down keyboard events.
virtual void | OnKeyUp (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process key-up keyboard events.
virtual BOOL | OnSysKeyDown (UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process key-up keyboard events.
virtual BOOL | OnTimer (UINT_PTR uTimerID)
The framework calls this member function after each interval specified in the SetTimer member function.
virtual BOOL | OnWndMsg (UINT message, WPARAM wParam, LPARAM lParam, LRESULT *pResult)
This method is called by framework after default message processing.
virtual void | OnPostAdjustLayout ()
This member function is used to perform additional adjustments in some kinds of views.
virtual void | OnBeforeDestroy ()
This member function is called by the framework before destroying the view.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPCalendarCaptionBarThemePart
CXTPPaintManagerColor | m_clrTextColor
Store the object's text color.
CRect | m_rcRect
Store a Part rectangle.
int | m_nState
Store a Part state.
CString | m_strText
Store a Part text.
- Protected Attributes inherited from CXTPCalendarCaptionBarThemePart
CXTPCalendarCaptionBarTheme * | m_pTheme
Store pointer to a parent theme object.
int | m_nPartID
Store a Part ID.
BOOL | m_bVisible
Store a Part visible state.

Detailed Description

This class implements SwitchView button part of the SwitchViewBar.

See also
CXTPCalendarCaptionBarThemePart

Member Function Documentation

◆ AdjustLayout()

virtual void AdjustLayout | ( | CDC * | pDC,
 |  | const CRect & | rcRect )
 virtual

This member function is used to adjust the object's layout depending on the provided bounding rectangle.

Parameters
pDC | Pointer to a valid device context (may be NULL).
rcRect | A CRect object containing the dimensions of the bounding rectangle for this part.

Reimplemented from CXTPCalendarCaptionBarThemePart.

◆ Draw()

virtual void Draw ( CDC * pDC )
virtual

This member function is used to draw the part content utilizing the specified device context.

Parameters
pDC Pointer to a valid device context.

Reimplemented from CXTPCalendarCaptionBarThemePart.

◆ RefreshMetrics()

virtual void RefreshMetrics ( )
virtual

Performs refreshing of graphical related parameters from system settings.

Base implementation do nothing.

Reimplemented from CXTPCalendarCaptionBarThemePart.

The documentation for this class was generated from the following file:
  • XTPCalendarCaptionBarThemePart.h


Toolkit Pro: CXTPSynchronized Class Reference

Public Member Functions | List of all members
CXTPSynchronized Class Reference

A base class for a synchronized object. More...

Inheritance diagram for CXTPSynchronized:
[legend]

Public Member Functions

CXTPRWCriticalSection & GetAccessCriticalSection () const
Accesses a synchronized object's critical section.

Detailed Description

A base class for a synchronized object.

Member Function Documentation

◆ GetAccessCriticalSection()

CXTPRWCriticalSection & GetAccessCriticalSection ( ) const
inline

Accesses a synchronized object's critical section.

Returns
Synchronized object's critical section.
The documentation for this class was generated from the following file:
  • XTPSynchro.h


Toolkit Pro: CXTPSyntaxEditAutoCompleteWnd Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPSyntaxEditAutoCompleteWnd Class Reference

This class implements the auto-complete window. More...

Public Member Functions

CXTPSyntaxEditAutoCompleteWnd ()
Default class constructor.
virtual | ~CXTPSyntaxEditAutoCompleteWnd ()
Destroys a CXTPSyntaxEditAutoCompleteWnd object, handles cleanup and de-allocation.
virtual BOOL | Create (CWnd *pParentWnd)
Creates an auto-complete window and sets its predefined properties.
virtual void | SetList (CXTPSyntaxEditACDataArray &parrData)
Sets the list of data to be displayed in the auto-complete window.
virtual void | SetOpenTags (CString strOpenTags)
Sets the list of open tags for the auto-complete window.
BOOL | IsOpenTag (CString strToTest)
Determines if a specified string contains open tags.
virtual void | SetCloseTags (CString strCloseTags)
Sets the list of close tags for the auto-complete window.
BOOL | IsCloseTag (CString strToTest)
Determines if a specified string contains close tags.
virtual void | Show (CPoint pt, CString strSearch=_T(""))
Shows the auto-complete window.
virtual void | Hide ()
Hides the auto-complete window.
BOOL | IsActive () const
Determines if the auto-complete window is visible and active.
virtual void | RefreshMetrics ()
Updates display settings from system settings.
virtual BOOL | RegisterWindowClass (HINSTANCE hInstance=NULL)
Registers the window class if it has not already been registered.
int | GetWndWidth () const
Gets the width of the auto-complete window.
void | SetWndWidth (int nWidth)
Sets the width for the auto-complete window.
CXTPImageManager * | GetImageManager () const
Retrieves the image manager for the items.
void | SetDelimiters (CString strDelims)
Sets the char list that are tag delimiters.
CString | GetDelimiters ()
Retrieves the char list that are tag delimiters.

Protected Member Functions

int HitTest (CPoint ptTest) const
Gets the integer identfier of the text line at a specified point.

Protected Attributes

CString | m_strSearch
Temporarily stores chain of characters from user input to perform an incremental search.
CString | m_strCloseTags
Stores set of close tags divided by the "~" sign (input close tags lead to close the auto-complete window).
CString | m_strTmpCloseTag
Temporarily stores chain of characters from user input to recognize close tags.
CString | m_strOpenTags
Stores open tags.
CString | m_strTmpOpenTag
Temporarily stores chain of characters from user input to recognize open tags.
CXTPSyntaxEditCtrl * | m_pParentWnd
Pointer to the parent window.
CXTPFont | m_xtpFontBasic
Font to display text.
COLORREF | m_clrWindow
Standard window color.
COLORREF | m_clrHighLight
Standard window highlight color.
COLORREF | m_clrWindowText
Standard windows text color.
COLORREF | m_clrHighLightText
Standard windows highlight text color.
CXTPSyntaxEditACDataArray | m_arrACData
Stores list of choices (line of text and image).
CXTPSyntaxEditACDataArray | m_arrACDataFiltered
Stores filtered list of choices (line of text and image).
CXTPSyntaxEditACGrid | m_arrGrid
Stores list of rectangle areas which were displayed text/image strings from m_arrACData.
int | m_nBordersHeight
Stores summary thickness of vertical window borders.
int | m_nLineHeight
Line height.
int | m_nLines
Number of visible lines.
int | m_nWndHeight
Height of the window.
int | m_nWndWidth
Width of the window.
int | m_nHighLightLine
Current highlight line identifier.
int | m_nFirstDisplayedStr
Current first visible (upper) line.
BOOL | m_bFixedBottom
Stores auto-complete window position (i.e.
BOOL | m_bActive
Active flag.
BOOL | m_bFilteredMode
Flag to identify the current mode (filtered/full).
BOOL | m_bHighLight
This flag determines if the selected string is highlighted.
int | m_nStartReplacePos
Position of the first char in the Edit Control which will be replaced by the chosen text.
int | m_nEndReplacePos
Position of the last char in the Edit Control which will be replaced by the chosen text.
CXTPImageManager * | m_pImageManager
Images for auto-complete list.
CString | m_strDelims
Stores char list that are tag delimiters.

Detailed Description

This class implements the auto-complete window.

It provides facilities to display predefined strings of data in the sorted order. Then the user can navigate over the list of strings and choose desired text to complete their input. The auto-complete window provides some ways to navigate by using vertical scroll bar, up/down keys, and mouse. If the user types alphanumeric keys after the auto-complete window has appeared, it will use the user input as search criteria and try to find text from its predefined strings of data that are like user input.

Member Function Documentation

◆ Create()

virtual BOOL Create ( CWnd * pParentWnd )
virtual

Creates an auto-complete window and sets its predefined properties.

Parameters
pParentWnd [in] Pointer to the parent window.

Before creating an auto-complete window, you should construct a CXTPSyntaxEditAutoCompleteWnd object by calling its constructor.

Returns
TRUE if successful, otherwise FALSE.

◆ GetDelimiters()

AFX_INLINE CString GetDelimiters ( )

Retrieves the char list that are tag delimiters.

Returns
Char list that are tag delimiters.

◆ GetImageManager()

AFX_INLINE CXTPImageManager * GetImageManager ( ) const

Retrieves the image manager for the items.

Returns
The image manager for the items.

◆ GetWndWidth()

AFX_INLINE int GetWndWidth ( ) const

Gets the width of the auto-complete window.

Returns
The width, in pixels, of the auto-complete window.

◆ HitTest()

int HitTest ( CPoint ptTest ) const
protected

Gets the integer identfier of the text line at a specified point.

Parameters
ptTest [in] Point to be tested.
Returns
The integer identifier of the text line at the specified point.

◆ IsActive()

AFX_INLINE BOOL IsActive ( ) const

Determines if the auto-complete window is visible and active.

Returns
TRUE if the auto-complete window is visible and active, otherwise FALSE.

◆ IsCloseTag()

BOOL IsCloseTag ( CString strToTest )

Determines if a specified string contains close tags.

Parameters
strToTest [in] String to be tested.
Returns
TRUE if the specified string contains close tags, otherwise FALSE.

◆ IsOpenTag()

BOOL IsOpenTag ( CString strToTest )

Determines if a specified string contains open tags.

Parameters
strToTest [in] String to be tested.
Returns
TRUE if the specified string contains open tags, otherwise FALSE.

◆ RegisterWindowClass()

virtual BOOL RegisterWindowClass ( HINSTANCE hInstance = NULL )
virtual

Registers the window class if it has not already been registered.

Parameters
hInstance Instance of the resource where the control is located.
Returns
TRUE if the window class was successfully registered, otherwise FALSE.

◆ SetCloseTags()

virtual void SetCloseTags ( CString strCloseTags )
virtual

Sets the list of close tags for the auto-complete window.

Parameters
strCloseTags [in] String containing close tags.

Close tags are treated as commands to be displayed and activated by the auto-complete window.

Each tag may consist of one or more symbols.

Tags must be separated by the "~" sign.

If the auto-complete window already has a list of tags, then the existing list will be replaced by the new one.

◆ SetDelimiters()

AFX_INLINE void SetDelimiters ( CString strDelims )

Sets the char list that are tag delimiters.

Parameters
strDelims char list that are tag delimiters.

◆ SetList()

virtual void SetList ( CXTPSyntaxEditACDataArray & parrData )
virtual

Sets the list of data to be displayed in the auto-complete window.

Parameters
parrData [in] Reference to an array of data.

The auto-complete window displays a list of data for the user to choose from.

If the auto-complete window already has a list of displayed data, then the existing list will be replaced by the new one.

New data will be sorted before being added to the auto-complete window.

See also
CXTPSyntaxEditACDataArray

◆ SetOpenTags()

virtual void SetOpenTags ( CString strOpenTags )
virtual

Sets the list of open tags for the auto-complete window.

Parameters
strOpenTags [in] String containing open tags.

Open tags are treated as commands to be displayed and activated by the auto-complete window.

Each tag may consist of one or more symbols.

Tags must be separated by the "~" sign.

If the auto-complete window already has a list of tags, then the existing list will be replaced by the new one.

◆ SetWndWidth()

void SetWndWidth ( int nWidth )

Sets the width for the auto-complete window.

Parameters
nWidth Width, in pixels, to be set.

◆ Show()

virtual void Show | ( | CPoint | pt,
 |  | CString | strSearch = _T("") )
 virtual

Shows the auto-complete window.

Parameters
pt | [in] Point where the upper left corner of the auto-complete window should appear.
strSearch | [in] Search string.

Shows auto-complete window at specified point and try to filter dataset by previously typed piece of word and highlighted line according search string.

Member Data Documentation

◆ m_bFixedBottom

BOOL m_bFixedBottom
protected

Stores auto-complete window position (i.e.

above or below at the cursor).

The documentation for this class was generated from the following file:
  • XTPSyntaxEditAutoCompleteWnd.h


Toolkit Pro: CXTPSyntaxEditBatchCommand Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPSyntaxEditBatchCommand Class Reference

This class represents a pack of commands in one. More...

Inheritance diagram for CXTPSyntaxEditBatchCommand:
[legend]

Public Member Functions

~CXTPSyntaxEditBatchCommand ()
A default command destructor.
virtual int | Execute (XTP_EDIT_LINECOL &lcFrom, XTP_EDIT_LINECOL &lcTo, CXTPSyntaxEditCtrl *pEditCtrl)
Executes the batch command by successively executing all stored commands.
virtual int | UnExecute (XTP_EDIT_LINECOL &lcFrom, XTP_EDIT_LINECOL &lcTo, CXTPSyntaxEditCtrl *pEditCtrl)
Unexecutes the batch command by successively undoing all stored commands.
POSITION | AddCommand (CXTPSyntaxEditCommand *pCommand)
Adds a command to the batch command buffer.
int | GetCommandsCount ()
Gets the number of individual command items inside the batch command buffer.
virtual int | GetDataSize () const
Gets the undo command data size (in bytes).
- Public Member Functions inherited from CXTPSyntaxEditCommand
virtual | ~CXTPSyntaxEditCommand ()
A default command destructor.
virtual LPCTSTR | GetCommandText () const
Gets command text.
virtual void | SetCommandText (LPCTSTR szText)
Sets command text.

Protected Member Functions

void Clear ()
Clears the batch command buffer and deletes all commands.
- Protected Member Functions inherited from CXTPSyntaxEditCommand
CXTPSyntaxEditCommand ()
Protected constructor because this class could not be instantiated itself, only by its descendants.

Protected Attributes

CPtrList | m_CommandList
Commands buffer storage.
- Protected Attributes inherited from CXTPSyntaxEditCommand
CString | m_strCommandText
Text description of the command.

Additional Inherited Members

- Static Protected Member Functions inherited from CXTPSyntaxEditCommand
static void AFX_CDECL SetPositionInternally (CXTPSyntaxEditCtrl *pEditCtrl, const XTP_EDIT_LINECOL &lcPos)
Sets the line and column position for the specified control using internal fast methods.

Detailed Description

This class represents a pack of commands in one.

It stores commands in the list, and implements standard command execution interfaces on command (un)execution.

See also
CXTPSyntaxEditCommand

Constructor & Destructor Documentation

◆ ~CXTPSyntaxEditBatchCommand()

~CXTPSyntaxEditBatchCommand ( )

A default command destructor.

Destroys the command object with all sub-commands, handles its cleanup and de-allocation.

Member Function Documentation

◆ AddCommand()

POSITION AddCommand ( CXTPSyntaxEditCommand * pCommand )

Adds a command to the batch command buffer.

Parameters
pCommand [in] Pointer to the command to be added.
Returns
The position of the newly added command inside the internal list.

Example: pBatchCmd->AddCommand(new CXTPSyntaxEditDeleteStringCommand(...));

◆ Execute()

virtual int Execute | ( | XTP_EDIT_LINECOL & | lcFrom,
 |  | XTP_EDIT_LINECOL & | lcTo,
 |  | CXTPSyntaxEditCtrl * | pEditCtrl )
 virtual

Executes the batch command by successively executing all stored commands.

Parameters
lcFrom | [out] Start text position affected by the command chain.
lcTo | [out] End text position affected by the command chain.
pEditCtrl | [in] Pointer to the edit control.
Returns
A bitwise combination of the edit actions that occurred: XTP_EDIT_EDITACTION_MODIFYROW, XTP_EDIT_EDITACTION_DELETEROW, XTP_EDIT_EDITACTION_INSERTROW
See also
UnExecute

Implements CXTPSyntaxEditCommand.

◆ GetCommandsCount()

int GetCommandsCount ( )

Gets the number of individual command items inside the batch command buffer.

Returns
The number of individual command items inside the batch command buffer.

◆ GetDataSize()

virtual int GetDataSize ( ) const
virtual

Gets the undo command data size (in bytes).

Returns
The undo command data size (in bytes).

Reimplemented from CXTPSyntaxEditCommand.

◆ UnExecute()

virtual int UnExecute | ( | XTP_EDIT_LINECOL & | lcFrom,
 |  | XTP_EDIT_LINECOL & | lcTo,
 |  | CXTPSyntaxEditCtrl * | pEditCtrl )
 virtual

Unexecutes the batch command by successively undoing all stored commands.

Parameters
lcFrom | [out] Start text position affected by the command chain.
lcTo | [out] End text position affected by the command chain.
pEditCtrl | [in] Pointer to the edit control.
Returns
A bitwise combination of the edit actions that occurred: XTP_EDIT_EDITACTION_MODIFYROW, XTP_EDIT_EDITACTION_DELETEROW, XTP_EDIT_EDITACTION_INSERTROW
See also
Execute

Implements CXTPSyntaxEditCommand.

The documentation for this class was generated from the following file:
  • XTPSyntaxEditUndoManager.h


Toolkit Pro: CXTPSyntaxEditBufferCommand Class Reference

Classes | Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPSyntaxEditBufferCommand Class Reference

The base class for all edit commands related to CXTPSyntaxEditBufferManager. More...

Inheritance diagram for CXTPSyntaxEditBufferCommand:
[legend]

Classes

class CXTPSyntaxEditBufferKeepOverwriteSettings
Keeps the buffer overwrite flag for the specified buffer manager from class construction until destruction, and resets this flag to FALSE during class lifetime. More...

Public Member Functions

virtual | ~CXTPSyntaxEditBufferCommand ()
A default command destructor.
- Public Member Functions inherited from CXTPSyntaxEditCommand
virtual | ~CXTPSyntaxEditCommand ()
A default command destructor.
virtual int | Execute (XTP_EDIT_LINECOL &lcFrom, XTP_EDIT_LINECOL &lcTo, CXTPSyntaxEditCtrl *pEditCtrl)=0
This is an interface function for operation execution.
virtual int | UnExecute (XTP_EDIT_LINECOL &lcFrom, XTP_EDIT_LINECOL &lcTo, CXTPSyntaxEditCtrl *pEditCtrl)=0
This is an interface function for operation undoing.
virtual LPCTSTR | GetCommandText () const
Gets command text.
virtual void | SetCommandText (LPCTSTR szText)
Sets command text.

Protected Member Functions

CXTPSyntaxEditBufferCommand (CXTPSyntaxEditBufferManager *pMgr, LPCTSTR szText, const XTP_EDIT_LINECOL &lcFrom, const XTP_EDIT_LINECOL &lcTo)
Creates the buffer command object, initializes its members.
int | DoInsertText (XTP_EDIT_LINECOL &lcFrom, XTP_EDIT_LINECOL &lcTo, CXTPSyntaxEditCtrl *pEditCtrl)
Inserts the stored text at the stored positions and returns the start and final affected text positions.
int | DoDeleteText (XTP_EDIT_LINECOL &lcFrom, XTP_EDIT_LINECOL &lcTo, CXTPSyntaxEditCtrl *pEditCtrl)
Deletes the text at the stored positions and returns the start and final affected text positions.
virtual int | GetDataSize () const
Gets the undo command data size (in bytes).
- Protected Member Functions inherited from CXTPSyntaxEditCommand
CXTPSyntaxEditCommand ()
Protected constructor because this class could not be instantiated itself, only by its descendants.

Protected Attributes

CXTPSyntaxEditBufferManager * | m_pBufferMgr
Pointer to the associated text buffer.
CString | m_strText
Changed text.
XTP_EDIT_LINECOL | m_lcFrom
Start edit position.
XTP_EDIT_LINECOL | m_lcTo
End edit position.
- Protected Attributes inherited from CXTPSyntaxEditCommand
CString | m_strCommandText
Text description of the command.

Additional Inherited Members

- Static Protected Member Functions inherited from CXTPSyntaxEditCommand
static void AFX_CDECL SetPositionInternally (CXTPSyntaxEditCtrl *pEditCtrl, const XTP_EDIT_LINECOL &lcPos)
Sets the line and column position for the specified control using internal fast methods.

Detailed Description

The base class for all edit commands related to CXTPSyntaxEditBufferManager.

It stores the handle of the buffer manager and provides implementation of common buffer operations such as text insertion and deletion.

See also
CXTPSyntaxEditCommand, CXTPSyntaxEditInsertStringCommand, CXTPSyntaxEditDeleteStringCommand

Constructor & Destructor Documentation

◆ ~CXTPSyntaxEditBufferCommand()

virtual ~CXTPSyntaxEditBufferCommand ( )
virtual

A default command destructor.

Destroys the command object, handles its cleanup and de-allocation.

◆ CXTPSyntaxEditBufferCommand()

CXTPSyntaxEditBufferCommand | ( | CXTPSyntaxEditBufferManager * | pMgr,
 |  | LPCTSTR | szText,
 |  | const XTP_EDIT_LINECOL & | lcFrom,
 |  | const XTP_EDIT_LINECOL & | lcTo )
 protected

Creates the buffer command object, initializes its members.

Parameters
pMgr | [in] Pointer to the associated buffer manager object.
szText | [in] Text which was changed during the buffer operation. It will be used for insert/remove text operations.
lcFrom | [in] Start text position affected by the command.
lcTo | [in] End text position affected by the command.

Member Function Documentation

◆ DoDeleteText()

int DoDeleteText | ( | XTP_EDIT_LINECOL & | lcFrom,
 |  | XTP_EDIT_LINECOL & | lcTo,
 |  | CXTPSyntaxEditCtrl * | pEditCtrl )
 protected

Deletes the text at the stored positions and returns the start and final affected text positions.

Parameters
lcFrom | [out] Start text position affected by the command.
lcTo | [out] End text position affected by the command.
pEditCtrl | [in] Pointer to the edit control.
Returns
A bitwise combination of the edit actions that occurred: XTP_EDIT_EDITACTION_MODIFYROW, XTP_EDIT_EDITACTION_DELETEROW, XTP_EDIT_EDITACTION_INSERTROW
See also
DoInsertText

◆ DoInsertText()

int DoInsertText | ( | XTP_EDIT_LINECOL & | lcFrom,
 |  | XTP_EDIT_LINECOL & | lcTo,
 |  | CXTPSyntaxEditCtrl * | pEditCtrl )
 protected

Inserts the stored text at the stored positions and returns the start and final affected text positions.

Parameters
lcFrom | [out] Start text position affected by the command.
lcTo | [out] End text position affected by the command.
pEditCtrl | [in] Pointer to the edit control.
Returns
A bitwise combination of the edit actions that occurred: XTP_EDIT_EDITACTION_MODIFYROW, XTP_EDIT_EDITACTION_DELETEROW, XTP_EDIT_EDITACTION_INSERTROW
See also
DoDeleteText

◆ GetDataSize()

virtual int GetDataSize ( ) const
protectedvirtual

Gets the undo command data size (in bytes).

Returns
The undo command data size (in bytes).

Reimplemented from CXTPSyntaxEditCommand.

Reimplemented in CXTPSyntaxEditReplaceStringCommand.

The documentation for this class was generated from the following file:
  • XTPSyntaxEditUndoManager.h


Toolkit Pro: CXTPSyntaxEditBufferCommand::CXTPSyntaxEditBufferKeepOverwriteSettings Class Reference

  • CXTPSyntaxEditBufferCommand
  • CXTPSyntaxEditBufferKeepOverwriteSettings
Public Member Functions | List of all members
CXTPSyntaxEditBufferCommand::CXTPSyntaxEditBufferKeepOverwriteSettings Class Reference

Keeps the buffer overwrite flag for the specified buffer manager from class construction until destruction, and resets this flag to FALSE during class lifetime. More...

Public Member Functions

CXTPSyntaxEditBufferKeepOverwriteSettings (CXTPSyntaxEditBufferManager *pBufferMgr)
Creates the object and stores buffer overwrite settings.
virtual ~CXTPSyntaxEditBufferKeepOverwriteSettings ()
Destroys the object and restores buffer overwrite settings.

Detailed Description

Keeps the buffer overwrite flag for the specified buffer manager from class construction until destruction, and resets this flag to FALSE during class lifetime.

Example: void DoSomething() { CXTPSyntaxEditBufferKeepOverwriteSettings bufOwr(m_pBufferMgr); ... }

Constructor & Destructor Documentation

◆ CXTPSyntaxEditBufferKeepOverwriteSettings()

CXTPSyntaxEditBufferKeepOverwriteSettings ( CXTPSyntaxEditBufferManager * pBufferMgr )

Creates the object and stores buffer overwrite settings.

Parameters
pBufferMgr [in] Pointer to the associated buffer manager object.
The documentation for this class was generated from the following file:
  • XTPSyntaxEditUndoManager.h


Toolkit Pro: CXTPSyntaxEditBufferManager Class Reference

Classes | Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPSyntaxEditBufferManager Class Reference

This class is the main class for buffer management. More...

Inheritance diagram for CXTPSyntaxEditBufferManager:
[legend]

Classes

class CXTPSyntaxEditStringsManager
This is helper class designed to manage a set of strings. More...

Public Member Functions

CXTPSyntaxEditBufferManager ()
Default object constructor.
~CXTPSyntaxEditBufferManager ()
Destroys a CXTPSyntaxEditBufferManager object, handles cleanup and de-allocation.
BOOL | IsModified () const
Determines if the file has been modified.
UINT | GetCodePage () const
Gets the CodePage for text conversion.
int | GetTabSize () const
Gets the tab size.
BOOL | SetTabSize (int nTabSize, BOOL bUpdateReg=FALSE)
Sets the tab size (must be between 1-64).
BOOL | GetOverwriteFlag () const
Gets the status of the overwrite flag.
void | SetOverwriteFlag (BOOL bOverwrite)
Sets the status for the overwrite flag.
BOOL | IsParserEnabled () const
Determines if the parser is enabled/disabled.
void | EnableParser (BOOL bEnable)
Enables/disables the parser.
int | GetCurCRLFType () const
Gets the CRLF style of the current document.
void | SetCRLFStyle (int nStyle)
Sets the CRLF style for the current document.
CString | GetCurCRLF () const
Gets the CRLF text of the current document.
BOOL | IsTextCRLF (LPCTSTR szCompText, BOOL bMatchReverse=FALSE) const
Determines if specified text is a CRLF.
int | GetRowCount () const
Gets the number of rows in the document.
CXTPSyntaxEditUndoRedoManager * | GetUndoRedoManager () const
Gets the associated Undo/Redo manager.
CXTPSyntaxEditLineMarksManager * | GetLineMarksManager () const
Gets the associated line marks manager.
XTPSyntaxEditLexAnalyser::CXTPSyntaxEditLexParser * | GetLexParser () const
Gets the associated lexical parser.
CXTPSyntaxEditConfigurationManager * | GetLexConfigurationManager () const
Gets the associated configuration manager.
void | SetLexConfigurationManager (CXTPSyntaxEditConfigurationManager *pMan)
Sets the associated configuration manager.
CXTPNotifyConnection * | GetConnection () const
Gets the events connection object.
void | Close ()
Cleans up all internal objects.
virtual void | Serialize (CArchive &ar)
Serializes actual data.
virtual void | SerializeEx (CArchive &ar, BOOL bUnicode=-1, BOOL bWriteUnicodeFilePrefix=TRUE, UINT nCodePage=(UINT) -1, LPCTSTR pcszFileExt=NULL, int nDataSizeLimit=-1)
Serializes actual data.
void | Load (CFile *pFile, LPCTSTR pcszFileExt=NULL)
Set the file pointer for the buffer.
void | SetFileExt (const CString &strExt)
Sets the file extension.
CString | GetFileExt () const
Gets the file extension.
void | GetLineText (int iLine, CString &strText, BOOL bAddCRLF=FALSE, int iCRLFStyle=-1)
Retrieves a line of text from either a file or buffer.
CString | GetLineText (int iLine, BOOL bAddCRLF=FALSE, int iCRLFStyle=-1) const
Retrieves a line of text from either a file or buffer.
int | GetLineTextLength (int iLine, BOOL bAddCRLF=FALSE, int iCRLFStyle=-1) const
Gets the length of a line of text in TCHARs/characters.
int | GetLineTextLengthC (int iLine, BOOL bAddCRLF=FALSE, int iCRLFStyle=-1) const
Gets the length of a line of text in TCHARs/characters.
int | GetMaxLineTextLength () const
Gets the maximum allowed length for a line of text.
int | CalcMaxLineTextLength (int nLineFrom=-1, int nLineTo=-1, BOOL bExpandTabs=FALSE) const
Gets the length of a line of text from either a file or buffer.
BOOL | GetBuffer (int row1, int col1, int row2, int col2, CMemFile &file, BOOL bColumnSelection=FALSE, BOOL bForceDOSStyleCRLF=FALSE)
Retrieves the text from the buffer bounded between either the row1/col1 and row2/col2 or the lcStart and lcEnd text coordinates.
BOOL | GetBuffer (const XTP_EDIT_LINECOL &lcStart, const XTP_EDIT_LINECOL &lcEnd, CMemFile &file, BOOL bColumnSelection=FALSE, BOOL bForceDOSStyleCRLF=FALSE)
Retrieves the text from the buffer bounded between either the row1/col1 and row2/col2 or the lcStart and lcEnd text coordinates.
BOOL | InsertText (LPCTSTR szText, int iRow, int iCol, BOOL bCanUndo=TRUE, XTP_EDIT_LINECOL *pFinalLC=NULL)
Inserts either text or a text block.
BOOL | InsertTextBlock (LPCTSTR szText, int nRow, int nCol, BOOL bCanUndo=TRUE, XTP_EDIT_LINECOL *pFinalLC=NULL)
Inserts either text or a text block.
BOOL | DeleteText (int iRowFrom, int iColFrom, int iRowTo, int iColTo, BOOL bCanUndo=TRUE, BOOL bDispCol=FALSE)
Deletes a specified range of text.
BOOL | RemoveLine (int nRow, BOOL bCanUndo=TRUE, int nRowsCount=1)
Deletes a specified number of rows.
CString | GetConfigFile () const
Gets the name of the main configuration file.
BOOL | SetConfigFile (LPCTSTR szPath)
Sets the the path to the main configuration file.
CXTPSyntaxEditTextSchema * | GetMasterTextSchema (const CString &strExt) const
Gets the master text schema.
void | ChangeCase (int nRow, int nDispFrom, int nDispTo, BOOL bUpper, BOOL bCanUndo=TRUE)
Changes the case of a specified character range in a specified row.
void | ChangeTabification (int nRow, int nDispFrom, int nDispTo, BOOL bTabify, BOOL bCanUndo=TRUE)
Changes the tabification of a specified character range in a specified row.
virtual int | ColToStrPos (int nLine, int nDispCol) const
Converts the column coordinates of text to string position.
virtual int | StrPosToCol (int nLine, int nStrPos) const
Converts the string position of text to column coordinates.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

void | CleanUp ()
Cleans up the buffer and all other allocated memories.
virtual UINT | CalcAveDataSize (int nRowStart, int nRowEnd)
Calculates the average data size based on the average row length.

Protected Attributes

int | m_nAverageLineLen
Average line length.
CXTPNotifyConnection * | m_pConnection
Connection object to send notifications.
int | m_nTabSize
Tab size.
int | m_iCRLFStyle
CRLF style 0 - DOS, 1 - UNIX, 2 - MAC.
UINT | m_nCodePage
CodePage for text conversion.
BOOL | m_bUnicodeFileFormat
Determine is file format Unicode or ASCII.
BOOL | m_bOverwrite
Overwrite mode status.
CXTPSyntaxEditUndoRedoManager * | m_pUndoRedoManager
Pointer to the undo / redo manager.
CXTPSyntaxEditLineMarksManager * | m_pLineMarksManager
Pointer to the line marks manager.
XTPSyntaxEditLexAnalyser::CXTPSyntaxEditLexParser * | m_pLexParser
Pointer to the lexical parser.
CXTPSyntaxEditConfigurationManagerPtr | m_ptrLexConfigurationManager
Pointer to the Lexical configuration manager.
CXTPSyntaxEditConfigurationManagerPtr | m_ptrDefaultLexConfigurationManager
Default Configuration Manager instance.
CString | m_strFileExt
File extension.
BOOL | m_bIsParserEnabled
TRUE if the parser is enabled, FALSE if the parser is disabled.
CXTPSyntaxEditStringsManager | m_Strings
Strings manager helper object.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

This class is the main class for buffer management.

One instance of this class is attached with a CXTPSyntaxEditCtrl object. This class contains a list of CBufferIndex classes which, in turn, contains a position in the file (in case of un-modified index) or a CEditBuffer pointer.

Member Function Documentation

◆ CalcAveDataSize()

virtual UINT CalcAveDataSize | ( | int | nRowStart,
 |  | int | nRowEnd )
 protectedvirtual

Calculates the average data size based on the average row length.

Parameters
nRowStart | [in] Start row identifier.
nRowEnd | [in] End row identifier.
Returns
The average data size.

◆ CalcMaxLineTextLength()

int CalcMaxLineTextLength | ( | int | nLineFrom = -1,
 |  | int | nLineTo = -1,
 |  | BOOL | bExpandTabs = FALSE ) const

Gets the length of a line of text from either a file or buffer.

Parameters
nLineFrom | [in] Start line identifier.
nLineTo | [in] End line identifier.
bExpandTabs | [in] TRUE to expand tab characters, FALSE otherwise.
Returns
The length of the line of text.

◆ ChangeCase()

void ChangeCase | ( | int | nRow,
 |  | int | nDispFrom,
 |  | int | nDispTo,
 |  | BOOL | bUpper,
 |  | BOOL | bCanUndo = TRUE )

Changes the case of a specified character range in a specified row.

Parameters
nRow | [in] Row to change case in.
nDispFrom | [in] Start visible position to change case from.
nDispTo | [in] End visible position to change case to.
bUpper | [in] TRUE to change case to upper, FALSE to change case to lower.
bCanUndo | [in] TRUE if this operation can be undone, FALSE otherwise.

Configuration will be reloaded.

◆ ChangeTabification()

void ChangeTabification | ( | int | nRow,
 |  | int | nDispFrom,
 |  | int | nDispTo,
 |  | BOOL | bTabify,
 |  | BOOL | bCanUndo = TRUE )

Changes the tabification of a specified character range in a specified row.

Parameters
nRow | [in] Row to change tabification in.
nDispFrom | [in] Start visible position to change tabification from.
nDispTo | [in] End visible position to change tabification to.
bTabify | [in] TRUE to change spaces to tabs, FALSE to change tabs to spaces.
bCanUndo | [in] TRUE if this operation can be undone, FALSE otherwise.

Configuration will be reloaded.

◆ ColToStrPos()

virtual int ColToStrPos | ( | int | nLine,
 |  | int | nDispCol ) const
 virtual

Converts the column coordinates of text to string position.

Parameters
nLine | [in] Text line identifier.
nDispCol | [in] Column coordinates.
Returns
The converted string position.
See also
StrPosToCol

◆ DeleteText()

BOOL DeleteText | ( | int | iRowFrom,
 |  | int | iColFrom,
 |  | int | iRowTo,
 |  | int | iColTo,
 |  | BOOL | bCanUndo = TRUE,
 |  | BOOL | bDispCol = FALSE )

Deletes a specified range of text.

Parameters
iRowFrom | [in] Start row for delete.
iColFrom | [in] Start column for delete.
iRowTo | [in] End row for delete.
iColTo | [in] End column for delete.
bCanUndo | [in] TRUE if this operation can be undone, FALSE otherwise.
bDispCol | [in] TRUE if iColFrom and iColTo are display columns, FALSE if iColFrom and iColTo are string columns.
Returns
TRUE if successful, otherwise FALSE.

◆ EnableParser()

void EnableParser ( BOOL bEnable )

Enables/disables the parser.

Parameters
bEnable [in] TRUE to enable the parser, FALSE to disable the parser.

◆ GetBuffer() [1/2]

AFX_INLINE BOOL GetBuffer | ( | const XTP_EDIT_LINECOL & | lcStart,
 |  | const XTP_EDIT_LINECOL & | lcEnd,
 |  | CMemFile & | file,
 |  | BOOL | bColumnSelection = FALSE,
 |  | BOOL | bForceDOSStyleCRLF = FALSE )

Retrieves the text from the buffer bounded between either the row1/col1 and row2/col2 or the lcStart and lcEnd text coordinates.

Parameters
lcStart | [in] Start text position.
lcEnd | [in] End text position.
file | [out] Reference to a CMemFile object to receive the text.
bColumnSelection | [in] TRUE to copy the text block starting from col1/lcStart and ending with col2/lcEnd for each line between row1/lcStart and row2/lcEnd, FALSE to copy the full text between row1/lcStart and row2/lcEnd.
bForceDOSStyleCRLF | [in] TRUE to use DOS Style carriage return chars to end each line, FALSE to use the current carriage return style.
Returns
TRUE if successful, otherwise FALSE.

◆ GetBuffer() [2/2]

BOOL GetBuffer | ( | int | row1,
 |  | int | col1,
 |  | int | row2,
 |  | int | col2,
 |  | CMemFile & | file,
 |  | BOOL | bColumnSelection = FALSE,
 |  | BOOL | bForceDOSStyleCRLF = FALSE )

Retrieves the text from the buffer bounded between either the row1/col1 and row2/col2 or the lcStart and lcEnd text coordinates.

Parameters
row1 | [in] Start line number.
col1 | [in] Start column number.
row2 | [in] End line number.
col2 | [in] End column number.
file | [out] Reference to a CMemFile object to receive the text.
bColumnSelection | [in] TRUE to copy the text block starting from col1/lcStart and ending with col2/lcEnd for each line between row1/lcStart and row2/lcEnd, FALSE to copy the full text between row1/lcStart and row2/lcEnd.
bForceDOSStyleCRLF | [in] TRUE to use DOS Style carriage return chars to end each line, FALSE to use the current carriage return style.
Returns
TRUE if successful, otherwise FALSE.

◆ GetCodePage()

AFX_INLINE UINT GetCodePage ( ) const

Gets the CodePage for text conversion.

Returns
The CodePage for text conversion.

◆ GetConfigFile()

CString GetConfigFile ( ) const

Gets the name of the main configuration file.

Returns
The name of the main configuration file.
See also
CXTPSyntaxEditBufferManager::SetConfigFile

◆ GetConnection()

AFX_INLINE CXTPNotifyConnection * GetConnection ( ) const

Gets the events connection object.

Returns
A pointer to the events connection object.

◆ GetCurCRLF()

CString GetCurCRLF ( ) const

Gets the CRLF text of the current document.

Returns
The CRLF text of the current document.

◆ GetCurCRLFType()

AFX_INLINE int GetCurCRLFType ( ) const

Gets the CRLF style of the current document.

Returns
The CRLF style of the current document.

◆ GetFileExt()

AFX_INLINE CString GetFileExt ( ) const

Gets the file extension.

Returns
The file extension.
See also
void SetFileExt(const CString& strExt);

◆ GetLexConfigurationManager()

AFX_INLINE CXTPSyntaxEditConfigurationManager * GetLexConfigurationManager ( ) const

Gets the associated configuration manager.

Returns
A pointer to the associated configuration manager.

◆ GetLexParser()

AFX_INLINE XTPSyntaxEditLexAnalyser::CXTPSyntaxEditLexParser * GetLexParser ( ) const

Gets the associated lexical parser.

Returns
A pointer to the associated lexical parser.

◆ GetLineMarksManager()

AFX_INLINE CXTPSyntaxEditLineMarksManager * GetLineMarksManager ( ) const

Gets the associated line marks manager.

Returns
A pointer to the associated line marks manager.

◆ GetLineText() [1/2]

CString GetLineText | ( | int | iLine,
 |  | BOOL | bAddCRLF = FALSE,
 |  | int | iCRLFStyle = -1 ) const

Retrieves a line of text from either a file or buffer.

Parameters
iLine | [in] Line for which to get the text.
bAddCRLF | [in] TRUE to add CRLF (if it exists), FALSE otherwise.
iCRLFStyle | [in] CRLF style.
Returns
The line of text.

◆ GetLineText() [2/2]

void GetLineText | ( | int | iLine,
 |  | CString & | strText,
 |  | BOOL | bAddCRLF = FALSE,
 |  | int | iCRLFStyle = -1 )

Retrieves a line of text from either a file or buffer.

Parameters
iLine | [in] Line for which to get the text.
strText | [out] Reference to a CString object to receive the line of text.
bAddCRLF | [in] TRUE to add CRLF (if it exists), FALSE otherwise.
iCRLFStyle | [in] CRLF style.

◆ GetLineTextLength()

int GetLineTextLength | ( | int | iLine,
 |  | BOOL | bAddCRLF = FALSE,
 |  | int | iCRLFStyle = -1 ) const

Gets the length of a line of text in TCHARs/characters.

Parameters
iLine | [in] Line for which to get the text.
bAddCRLF | [in] TRUE to add CRLF (if it exists), FALSE otherwise.
iCRLFStyle | [in] CRLF style.
Returns
The length of the line of text in TCHARs/characters.

◆ GetLineTextLengthC()

int GetLineTextLengthC | ( | int | iLine,
 |  | BOOL | bAddCRLF = FALSE,
 |  | int | iCRLFStyle = -1 ) const

Gets the length of a line of text in TCHARs/characters.

Parameters
iLine | [in] Line for which to get the text.
bAddCRLF | [in] TRUE to add CRLF (if it exists), FALSE otherwise.
iCRLFStyle | [in] CRLF style.
Returns
The length of the line of text in TCHARs/characters.

◆ GetMasterTextSchema()

CXTPSyntaxEditTextSchema * GetMasterTextSchema ( const CString & strExt ) const

Gets the master text schema.

Parameters
strExt [in] Reference to the file extension to the schema definition file.
Returns
A pointer to the master text schema.

◆ GetMaxLineTextLength()

int GetMaxLineTextLength ( ) const

Gets the maximum allowed length for a line of text.

Returns
The maximum allowed length for a line of text.

◆ GetOverwriteFlag()

AFX_INLINE BOOL GetOverwriteFlag ( ) const

Gets the status of the overwrite flag.

Returns
TRUE if OVR is set, otherwise FALSE.

◆ GetRowCount()

int GetRowCount ( ) const

Gets the number of rows in the document.

Returns
The number of rows in the document.

◆ GetTabSize()

AFX_INLINE int GetTabSize ( ) const

Gets the tab size.

Returns
The tab size.

◆ GetUndoRedoManager()

AFX_INLINE CXTPSyntaxEditUndoRedoManager * GetUndoRedoManager ( ) const

Gets the associated Undo/Redo manager.

Returns
A pointer to the associated Undo/Redo manager.

◆ InsertText()

BOOL InsertText | ( | LPCTSTR | szText,
 |  | int | iRow,
 |  | int | iCol,
 |  | BOOL | bCanUndo = TRUE,
 |  | XTP_EDIT_LINECOL * | pFinalLC = NULL )

Inserts either text or a text block.

Parameters
szText | [in] Text to be inserted.
iRow | [in] Start row for delete.
iCol | [in] Start column for delete.
bCanUndo | [in] TRUE if this operation can be undone, FALSE otherwise.
pFinalLC | [out] Pointer to an XTP_EDIT_LINECOL variable to receive the operation final position in the text (to set caret).
Returns
TRUE if successful, otherwise FALSE.

◆ InsertTextBlock()

BOOL InsertTextBlock | ( | LPCTSTR | szText,
 |  | int | nRow,
 |  | int | nCol,
 |  | BOOL | bCanUndo = TRUE,
 |  | XTP_EDIT_LINECOL * | pFinalLC = NULL )

Inserts either text or a text block.

Parameters
szText | [in] Text to be inserted.
nRow | [in] Start row for delete.
nCol | [in] Start column for delete.
bCanUndo | [in] TRUE if this operation can be undone, FALSE otherwise.
pFinalLC | [out] Pointer to an XTP_EDIT_LINECOL variable to receive the operation final position in the text (to set caret).
Returns
TRUE if successful, otherwise FALSE.

◆ IsModified()

BOOL IsModified ( ) const

Determines if the file has been modified.

Returns
TRUE if the file has been modified, otherwise FALSE.

◆ IsParserEnabled()

AFX_INLINE BOOL IsParserEnabled ( ) const

Determines if the parser is enabled/disabled.

Returns
TRUE if the parser is enabled, FALSE if the parser is disabled.

◆ IsTextCRLF()

BOOL IsTextCRLF | ( | LPCTSTR | szCompText,
 |  | BOOL | bMatchReverse = FALSE ) const

Determines if specified text is a CRLF.

Parameters
szCompText | [in] Text to be checked.
bMatchReverse | [in] TRUE to match reverse, FALSE otherwise.
Returns
TRUE if the specified text is a CRLF, otherwise FALSE.

◆ Load()

void Load | ( | CFile * | pFile,
 |  | LPCTSTR | pcszFileExt = NULL )

Set the file pointer for the buffer.

Parameters
pFile | [in] File pointer to be set.
pcszFileExt | [in] Number of lines (Not used).
See also
SetFileExt()

◆ RemoveLine()

BOOL RemoveLine | ( | int | nRow,
 |  | BOOL | bCanUndo = TRUE,
 |  | int | nRowsCount = 1 )

Deletes a specified number of rows.

Parameters
nRow | [in] Start row for delete.
bCanUndo | [in] TRUE if this operation can be undone, FALSE otherwise.
nRowsCount | [in] Number of rows to delete.
Returns
TRUE if successful, otherwise FALSE.

◆ Serialize()

virtual void Serialize ( CArchive & ar )
virtual

Serializes actual data.

Parameters
ar [in, out] Reference to the archive to save/load text.

◆ SerializeEx()

virtual void SerializeEx | ( | CArchive & | ar,
 |  | BOOL | bUnicode = -1,
 |  | BOOL | bWriteUnicodeFilePrefix = TRUE,
 |  | UINT | nCodePage = (UINT) -1,
 |  | LPCTSTR | pcszFileExt = NULL,
 |  | int | nDataSizeLimit = -1 )
 virtual

Serializes actual data.

Parameters
ar | [in, out] Reference to the archive to save/load text.
bUnicode | [in] TRUE to use UNICODE format for text in the archive.
bWriteUnicodeFilePrefix | [in] TRUE to write Unicode File Prefix.
nCodePage | [in] Text code page (or -1 to use default).
pcszFileExt | [in] File extension to select appropriate parser schema.
nDataSizeLimit | [in] The number of bytes to stop storing text to archive (or -1 to store all).

◆ SetConfigFile()

BOOL SetConfigFile ( LPCTSTR szPath )

Sets the the path to the main configuration file.

Parameters
szPath [in] Path to be set.

The configuration will be reloaded.

Returns
TRUE if the path was found, otherwise FALSE.
See also
CXTPSyntaxEditBufferManager::GetConfigFile

◆ SetCRLFStyle()

void SetCRLFStyle ( int nStyle )

Sets the CRLF style for the current document.

Parameters
nStyle [in] CRLF style to be set.

◆ SetFileExt()

void SetFileExt ( const CString & strExt )

Sets the file extension.

Parameters
strExt [in] Reference to the file extension to be set.
See also
CString GetFileExt()

◆ SetLexConfigurationManager()

void SetLexConfigurationManager ( CXTPSyntaxEditConfigurationManager * pMan )

Sets the associated configuration manager.

Parameters
pMan [in] Pointer to the configuration manager to be set.

◆ SetOverwriteFlag()

void SetOverwriteFlag ( BOOL bOverwrite )

Sets the status for the overwrite flag.

Parameters
bOverwrite [in] TRUE to set OVR, FALSE to set INS.

◆ SetTabSize()

BOOL SetTabSize | ( | int | nTabSize,
 |  | BOOL | bUpdateReg = FALSE )

Sets the tab size (must be between 1-64).

Parameters
nTabSize | [in] Tab size to set.
bUpdateReg | [in] TRUE to update this setting in the registry, FALSE otherwise. By default, this parameter is FALSE.
Returns
TRUE if the operation was successful, otherwise FALSE.

◆ StrPosToCol()

virtual int StrPosToCol | ( | int | nLine,
 |  | int | nStrPos ) const
 virtual

Converts the string position of text to column coordinates.

Parameters
nLine | [in] Text line identifier.
nStrPos | [in] String position.
Returns
The converted column coordinates.
See also
ColToStrPos
The documentation for this class was generated from the following file:
  • XTPSyntaxEditBufferManager.h


Toolkit Pro: CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager Class Reference

  • CXTPSyntaxEditBufferManager
  • CXTPSyntaxEditStringsManager
Classes | Public Member Functions | Public Attributes | List of all members
CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager Class Reference

This is helper class designed to manage a set of strings. More...

Classes

class CStringPtrArray
Internal class, implements a collection of strings. More...

Public Member Functions

CXTPSyntaxEditStringsManager ()
Default object constructor.
virtual | ~CXTPSyntaxEditStringsManager ()
Default object destructor.
int | GetCount () const
Gets the number of managed strings.
CString | GetStr (int nRow) const
Retrieves the string at a specified index.
int | GetStrLen (int nRow) const
Retrieves the length of the string at a specified index in TCHARs/characters.
int | GetStrLenC (int nRow) const
Retrieves the length of the string at a specified index in TCHARs/characters.
void | SetAtGrowStr (int nRow, const CString &strText)
Sets the string at a specified index.
void | SetAtGrowStr (int nRow, LPCTSTR pcszText)
Sets the string at a specified index.
void | InsertStr (int nRow, const CString &strText)
Adds a specified string.
BOOL | RemoveStr (int nRow)
Removes the string at a specified index.
void | RemoveAllStrs ()
Removes all strings from the collection.
BOOL | InsertText (int nRow, int nPos, LPCTSTR pcszText, BOOL bGrowArrayIfNeed=FALSE, TCHAR chLeftSpaceFiller=_T(' '))
Inserts text to the string at a specified index.
BOOL | DeleteText (int nRow, int nPos, int nCount)
Deletes text from the string at a specified index.
CString * | GetStrData (int nRow, BOOL bGrowArrayIfNeed=TRUE)
Retrieves the string at a specified index.
CString * | GetStrDataC (int nRow) const
Retrieves the string at a specified index.

Public Attributes

CStringPtrArray m_arStrings
String collection.

Detailed Description

This is helper class designed to manage a set of strings.

Constructor & Destructor Documentation

◆ ~CXTPSyntaxEditStringsManager()

virtual ~CXTPSyntaxEditStringsManager ( )
virtual

Default object destructor.

Handles cleanup and deallocation

Member Function Documentation

◆ DeleteText()

BOOL DeleteText | ( | int | nRow,
 |  | int | nPos,
 |  | int | nCount )

Deletes text from the string at a specified index.

Parameters
nRow | [in] Index of the string to delete text from.
nPos | [in] Start position in the string.
nCount | [in] Number of characters to remove.
Returns
TRUE if the text was successfully deleted, otherwise FALSE.
See also
InsertText

◆ GetCount()

int GetCount ( ) const

Gets the number of managed strings.

Returns
The number of managed strings.

◆ GetStr()

CString GetStr ( int nRow ) const

Retrieves the string at a specified index.

Parameters
nRow [in] Index of the string to retrieve.
Returns
The string at the specified index.

◆ GetStrData()

CString * GetStrData | ( | int | nRow,
 |  | BOOL | bGrowArrayIfNeed = TRUE )

Retrieves the string at a specified index.

Parameters
nRow | [in] Index of the string to be retrieved.
bGrowArrayIfNeed | [in] TRUE to grow the array of strings, FALSE otherwise. The default value of this parameter is TRUE.
Returns
A pointer to the string at the specified index.

◆ GetStrDataC()

CString * GetStrDataC ( int nRow ) const

Retrieves the string at a specified index.

Parameters
nRow [in] Index of the string to be retrieved.
Returns
A pointer to the string at the specified index.

◆ GetStrLen()

int GetStrLen ( int nRow ) const

Retrieves the length of the string at a specified index in TCHARs/characters.

Parameters
nRow [in] Index of the string to retrieve the length of.
Returns
The length of the string at the specified index in TCHARs/characters.

◆ GetStrLenC()

int GetStrLenC ( int nRow ) const

Retrieves the length of the string at a specified index in TCHARs/characters.

Parameters
nRow [in] Index of the string to retrieve the length of.
Returns
The length of the string at the specified index in TCHARs/characters.

◆ InsertStr()

void InsertStr | ( | int | nRow,
 |  | const CString & | strText )

Adds a specified string.

Parameters
nRow | [in] String identifier.
strText | [in] Reference to the string to be added.

If an existing identifier is used, then its string value will be updated.

See also
SetAtGrowStr

◆ InsertText()

BOOL InsertText | ( | int | nRow,
 |  | int | nPos,
 |  | LPCTSTR | pcszText,
 |  | BOOL | bGrowArrayIfNeed = FALSE,
 |  | TCHAR | chLeftSpaceFiller = _T(' ') )

Inserts text to the string at a specified index.

Parameters
nRow | [in] Index of the string to insert text to.
nPos | [in] Start position in the string.
pcszText | [in] Text to be inserted.
bGrowArrayIfNeed | [in] TRUE to grow the strings array if nRow is greater than the strings count, FALSE to have this function do nothing and return FALSE in this instance.
chLeftSpaceFiller | [in] Character to be added to the left side of the string to insert text to if nPos is greater than the length of the string. In this case, this character will be added until the length of the string is equal to nPos.
Returns
TRUE if the text was successfully inserted, otherwise FALSE.
See also
DeleteText

◆ RemoveStr()

BOOL RemoveStr ( int nRow )

Removes the string at a specified index.

Parameters
nRow [in] Index of the string to be removed.
Returns
TRUE if successful, FALSE if a string did not exist at the specified index.

◆ SetAtGrowStr() [1/2]

void SetAtGrowStr | ( | int | nRow,
 |  | const CString & | strText )

Sets the string at a specified index.

Parameters
nRow | [in] Index.
strText | [in] Reference to the string to be set.

If the specified index does not exist within the collection, then this method will do nothing.

◆ SetAtGrowStr() [2/2]

void SetAtGrowStr | ( | int | nRow,
 |  | LPCTSTR | pcszText )

Sets the string at a specified index.

Parameters
nRow | [in] Index.
pcszText | [in] Pointer to the NULL-terminated string to be set.

If the specified index does not exist within the collection, then this method will do nothing.

The documentation for this class was generated from the following file:
  • XTPSyntaxEditBufferManager.h


Toolkit Pro: CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager::CStringPtrArray Class Reference

  • CXTPSyntaxEditBufferManager
  • CXTPSyntaxEditStringsManager
  • CStringPtrArray
Public Member Functions | List of all members
CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager::CStringPtrArray Class Reference

Internal class, implements a collection of strings. More...

Public Member Functions

CStringPtrArray ()
Default object constructor.
virtual | ~CStringPtrArray ()
Default object destructor.
void | RemoveAll ()
Deletes all string objects and removes them from the array.

Detailed Description

Internal class, implements a collection of strings.

Constructor & Destructor Documentation

◆ ~CStringPtrArray()

virtual ~CStringPtrArray ( )
virtual

Default object destructor.

Handles cleanup and deallocation

The documentation for this class was generated from the following file:
  • XTPSyntaxEditBufferManager.h


Toolkit Pro: CXTPSyntaxEditColorComboBox Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPSyntaxEditColorComboBox Class Reference

This class allows for colors to be edited by using a combobox control. More...

Public Member Functions

CXTPSyntaxEditColorComboBox ()
Standard object constructor.
virtual | ~CXTPSyntaxEditColorComboBox ()
Standard object destructor.
COLORREF | GetSelColor ()
Gets the selected color.
int | SetSelColor (COLORREF crColor)
Sets the selected color.
int | DeleteColor (COLORREF crColor)
Removes a specified color.
int | FindColor (COLORREF crColor)
Retrieves the index of a specified color.
int | SetUserColor (COLORREF crColor, LPCTSTR lpszUserText=NULL)
Sets the user color value and user color name.
COLORREF | GetUserColor () const
Gets the user color value.
int | SetAutoColor (COLORREF crColor, LPCTSTR lpszAutoText=NULL)
Sets the auto color value and auto color name.
COLORREF | GetAutoColor () const
Gets the auto color value.
int | SelectUserColor ()
Selects the user color.
virtual bool | Init ()
Adds the default set of colors.

Protected Member Functions

virtual int | AddColor (COLORREF crColor, UINT nID)
Adds a new color.
virtual void | NotifyOwner (UINT nCode)
Sends a WM_COMMAND message to the owner window.
virtual int | GetLBCurSel () const
Gets the index of the currently selected listbox item (works for dropped state only).

Detailed Description

This class allows for colors to be edited by using a combobox control.

It displays the color name and draws a rectangle for each item using the item color.

Member Function Documentation

◆ AddColor()

virtual int AddColor | ( | COLORREF | crColor,
 |  | UINT | nID )
 protectedvirtual

Adds a new color.

Parameters
crColor | Color to be added.
nID | Resource ID of the color name string.
Returns
The index of the newly added color if successful, otherwise CB_ERR.

◆ DeleteColor()

int DeleteColor ( COLORREF crColor )

Removes a specified color.

Parameters
crColor Color to be removed.
Returns
The index of the deleted color if successful, otherwise CB_ERR.

◆ FindColor()

int FindColor ( COLORREF crColor )

Retrieves the index of a specified color.

Parameters
crColor Color to retrieve the index of.
Returns
The index of the specified color if successful, otherwise CB_ERR.

◆ GetAutoColor()

AFX_INLINE COLORREF GetAutoColor ( ) const

Gets the auto color value.

Returns
The auto color value.

◆ GetLBCurSel()

virtual int GetLBCurSel ( ) const
protectedvirtual

Gets the index of the currently selected listbox item (works for dropped state only).

Returns
The index of the currently selected listbox item if successful, otherwise LB_ERR.

◆ GetSelColor()

COLORREF GetSelColor ( )

Gets the selected color.

Returns
The selected color, or COLORREF_NULL if no color is selected.

◆ GetUserColor()

AFX_INLINE COLORREF GetUserColor ( ) const

Gets the user color value.

Returns
The user color value.

◆ Init()

virtual bool Init ( )
virtual

Adds the default set of colors.

Returns
true if successful, otherwise false.

◆ NotifyOwner()

virtual void NotifyOwner ( UINT nCode )
protectedvirtual

Sends a WM_COMMAND message to the owner window.

Default implementation sends the following notifications: CBN_SELENDCANCEL, CBN_SELENDOK

Parameters
nCode Notification code.

◆ SelectUserColor()

int SelectUserColor ( )

Selects the user color.

Returns
The index of the selected user color if successful, otherwise CB_ERR.

◆ SetAutoColor()

int SetAutoColor | ( | COLORREF | crColor,
 |  | LPCTSTR | lpszAutoText = NULL )

Sets the auto color value and auto color name.

Parameters
crColor | Auto color value to be set.
lpszAutoText | Auto color name to be set or NULL to use the default.
Returns
The index of the auto color value if successful, otherwise CB_ERR.

◆ SetSelColor()

int SetSelColor ( COLORREF crColor )

Sets the selected color.

Parameters
crColor Color to be set.
Returns
The index of the newly selected color.

◆ SetUserColor()

int SetUserColor | ( | COLORREF | crColor,
 |  | LPCTSTR | lpszUserText = NULL )

Sets the user color value and user color name.

Parameters
crColor | User color value to be set.
lpszUserText | User color name to be set or NULL to use the default.
Returns
The index of the user color value if successful, otherwise CB_ERR.
The documentation for this class was generated from the following file:
  • XTPSyntaxEditColorComboBox.h


Toolkit Pro: CXTPSyntaxEditColorInfo Class Reference

Public Member Functions | List of all members
CXTPSyntaxEditColorInfo Class Reference

This storage class is designed to contain information from the color settings file section. More...

Public Member Functions

CXTPSyntaxEditColorInfo (CXTPSyntaxEditColorTheme *pTheme)
Object constructor.
CXTPSyntaxEditColorInfo (const CString &strClassName, CXTPSyntaxEditColorTheme *pTheme)
Object constructor.
virtual | ~CXTPSyntaxEditColorInfo ()
Destroys a CXTPSyntaxEditColorTheme() object, handles cleanup and de-allocation.
void | AddParam (const CString &strName, const CString &strValue)
Adds a parameter.
const CString | GetParam (const CString &strName, BOOL bDynamic=TRUE)
Retrieves the value of a parameter with a specified name.
DWORD | GetHexParam (const CString &strName, BOOL bDynamic=TRUE)
Retrieves the hexadecimal value of a parameter with a specified name.
POSITION | GetFirstParamNamePosition ()
Gets the first parameter name position.
const CString | GetNextParamName (POSITION &pos)
Gets the next parameter name.
const CString | GetClassName () const
Gets the lex class name.

Detailed Description

This storage class is designed to contain information from the color settings file section.

It helps to easily retrieve color information.

Constructor & Destructor Documentation

◆ CXTPSyntaxEditColorInfo() [1/2]

CXTPSyntaxEditColorInfo ( CXTPSyntaxEditColorTheme * pTheme )

Object constructor.

Parameters
pTheme [in] Pointer to a CXTPSyntaxEditColorTheme object (theme that this color information belongs to).

◆ CXTPSyntaxEditColorInfo() [2/2]

CXTPSyntaxEditColorInfo | ( | const CString & | strClassName,
 |  | CXTPSyntaxEditColorTheme * | pTheme )

Object constructor.

Parameters
pTheme | [in] Pointer to a CXTPSyntaxEditColorTheme object (theme that this color information belongs to).
strClassName | [in] Reference to the lex class name.

Member Function Documentation

◆ AddParam()

void AddParam | ( | const CString & | strName,
 |  | const CString & | strValue )

Adds a parameter.

Parameters
strName | [in] Reference to the parameter name.
strValue | [in] Reference to the parameter value.

◆ GetClassName()

AFX_INLINE const CString GetClassName ( ) const

Gets the lex class name.

Returns
The lex class name.

◆ GetFirstParamNamePosition()

POSITION GetFirstParamNamePosition ( )

Gets the first parameter name position.

Returns
The first parameter name position.

◆ GetHexParam()

DWORD GetHexParam | ( | const CString & | strName,
 |  | BOOL | bDynamic = TRUE )

Retrieves the hexadecimal value of a parameter with a specified name.

Parameters
strName | [in] Name of the parameter to retrieve the value of.
bDynamic | [in] TRUE to search for the value of the parameter within parent themes (dynamically), FALSE to only search for the value of the parameter within the current theme.
Returns
The hexadecimal value of the parameter with the specified name.

◆ GetNextParamName()

const CString GetNextParamName ( POSITION & pos )

Gets the next parameter name.

Parameters
pos [in] Reference to a POSITION value.
Returns
The next parameter name.

◆ GetParam()

const CString GetParam | ( | const CString & | strName,
 |  | BOOL | bDynamic = TRUE )

Retrieves the value of a parameter with a specified name.

Parameters
strName | [in] Name of the parameter to retrieve the value of.
bDynamic | [in] TRUE to search for the value of the parameter within parent themes (dynamically), FALSE to only search for the value of the parameter within the current theme.
Returns
The value of the parameter with the specified name.
The documentation for this class was generated from the following file:
  • XTPSyntaxEditLexColorFileReader.h


Toolkit Pro: CXTPSyntaxEditColorInfoArray Class Reference

Public Member Functions | List of all members
CXTPSyntaxEditColorInfoArray Class Reference

This collection class stores the color info objects. More...

Public Member Functions

CXTPSyntaxEditColorInfoArray ()
Constructor, creates and initializes the object.
virtual | ~CXTPSyntaxEditColorInfoArray ()
Destructor, do the cleaups and destroys the object.
void | RemoveAll ()
Removes all of the color info objects.

Detailed Description

This collection class stores the color info objects.

The documentation for this class was generated from the following file:
  • XTPSyntaxEditLexColorFileReader.h


Toolkit Pro: CXTPSyntaxEditColorSampleText Class Reference

Public Member Functions | List of all members
CXTPSyntaxEditColorSampleText Class Reference

This class, derived from CStatic, is used to display a sample of colored text. More...

Public Member Functions

CXTPSyntaxEditColorSampleText ()
Default object constructor.
virtual | ~CXTPSyntaxEditColorSampleText ()
Default object destructor.
void | SetTextColor (COLORREF crText)
Sets the text color.
COLORREF | GetTextColor () const
Gets the text color.
void | SetBackColor (COLORREF crBack)
Sets the background color.
COLORREF | GetBackColor () const
Gets the background color.
void | SetBorderColor (COLORREF crBorder)
Sets the border color.
COLORREF | GetBorderColor () const
Gets the border color.
void | Refresh ()
Redraws the control.

Detailed Description

This class, derived from CStatic, is used to display a sample of colored text.

Member Function Documentation

◆ GetBackColor()

COLORREF GetBackColor ( ) const

Gets the background color.

Returns
The background color.

◆ GetBorderColor()

COLORREF GetBorderColor ( ) const

Gets the border color.

Returns
The border color.

◆ GetTextColor()

COLORREF GetTextColor ( ) const

Gets the text color.

Returns
The text color.

◆ SetBackColor()

void SetBackColor ( COLORREF crBack )

Sets the background color.

Parameters
crBack Background color to be set.

◆ SetBorderColor()

void SetBorderColor ( COLORREF crBorder )

Sets the border color.

Parameters
crBorder Border color to be set.

◆ SetTextColor()

void SetTextColor ( COLORREF crText )

Sets the text color.

Parameters
crText Text color to be set.
The documentation for this class was generated from the following file:
  • XTPSyntaxEditColorSampleText.h


Toolkit Pro: CXTPSyntaxEditColorTheme Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPSyntaxEditColorTheme Class Reference

This class provides the functionality to read configuration information from configuration files with a predefined structure. More...

Public Member Functions

CXTPSyntaxEditColorTheme (CXTPSyntaxEditColorThemesManager *pThemesManager)
Default object constructor.
virtual | ~CXTPSyntaxEditColorTheme ()
Destroys a CXTPSyntaxEditColorTheme() object, handles cleanup and de-allocation.
virtual void | Load (const CString &csFileName)
Parses the associated color schema file and fills internal color information structures.
virtual void | LoadFromString (CStringArray &arPassedString)
Loads a color scheme.
const CString | GetParentThemeName ()
Gets the name of the parent schema.
CXTPSyntaxEditColorTheme * GetParentTheme ()
Gets the parent schema.
CXTPSyntaxEditColorInfo * | GetColorInfo (const CString &strLexClass, const CString &strThemeFilename, BOOL bDynamic=TRUE)
Gets the color information.
CString | GetFileName ()
Gets the configuration file name.
BOOL | WriteCfgFile (CString strParentThemeName, CXTPSyntaxEditColorInfoArray *pColorInfoArray_new)
Saves colors to the configuration file.

Protected Member Functions

void | Cleanup ()
Cleans up the collection.
CXTPSyntaxEditColorInfo * | ParseSection (const CString &csSection)
Parses a single section of the configuration file and creates a CXTPSyntaxEditColorInfo object from it.
CXTPSyntaxEditColorInfo * | ParseSectionFromString (const CString &csSection, CStringArray &arPassedString)
Parses a single section of the configuration file and creates a CXTPSyntaxEditColorInfo object from it.

Detailed Description

This class provides the functionality to read configuration information from configuration files with a predefined structure.

Its information describes the color settings for the corresponding lexical items of a given language. You construct an instance of CXTPSyntaxEditColorTheme by calling its constructor. Then you should call the Load member function to read data from persistent storage.

Constructor & Destructor Documentation

◆ CXTPSyntaxEditColorTheme()

CXTPSyntaxEditColorTheme ( CXTPSyntaxEditColorThemesManager * pThemesManager )

Default object constructor.

Parameters
pThemesManager [in] Pointer to the parent themes manager.

Member Function Documentation

◆ GetColorInfo()

CXTPSyntaxEditColorInfo * GetColorInfo | ( | const CString & | strLexClass,
 |  | const CString & | strThemeFilename,
 |  | BOOL | bDynamic = TRUE )

Gets the color information.

Parameters
strLexClass | [in] Reference to the lex class name.
strThemeFilename | [in] Reference to the configuration file name.
bDynamic | [in] TRUE to search for the color information within parent themes (dynamically), FALSE to only search for the color information within the current theme.

strThemeFilename is required in order to avoid calling recursion.

Returns
A pointer to the color information.

◆ GetFileName()

AFX_INLINE CString GetFileName ( )

Gets the configuration file name.

Returns
The configuration file name.

◆ GetParentTheme()

CXTPSyntaxEditColorTheme * GetParentTheme ( )

Gets the parent schema.

Returns
A pointer to the parent schema if it exists, otherwise NULL.

◆ GetParentThemeName()

const CString GetParentThemeName ( )

Gets the name of the parent schema.

Returns
The name of the parent schema.

◆ Load()

virtual void Load ( const CString & csFileName )
virtual

Parses the associated color schema file and fills internal color information structures.

Parameters
csFileName [in] Reference to the configuration file name.

◆ LoadFromString()

virtual void LoadFromString ( CStringArray & arPassedString )
virtual

Loads a color scheme.

Parameters
arPassedString [in] Reference to an array of color scheme attributes.

◆ ParseSection()

CXTPSyntaxEditColorInfo * ParseSection ( const CString & csSection )
protected

Parses a single section of the configuration file and creates a CXTPSyntaxEditColorInfo object from it.

Parameters
csSection [in] Reference to the section name (in the configuration file).
Returns
A pointer to the newly created CXTPSyntaxEditColorInfo object.

◆ ParseSectionFromString()

CXTPSyntaxEditColorInfo * ParseSectionFromString | ( | const CString & | csSection,
 |  | CStringArray & | arPassedString )
 protected

Parses a single section of the configuration file and creates a CXTPSyntaxEditColorInfo object from it.

Parameters
csSection | [in] Reference to the section name (in the configuration file).
arPassedString | [in] Reference to a CStringArray object.
Returns
A pointer to the newly created CXTPSyntaxEditColorInfo object.

◆ WriteCfgFile()

BOOL WriteCfgFile | ( | CString | strParentThemeName,
 |  | CXTPSyntaxEditColorInfoArray * | pColorInfoArray_new )

Saves colors to the configuration file.

Parameters
strParentThemeName | Parent theme name.
pColorInfoArray_new | Pointer to the colors information array.
Returns
TRUE if successful, otherwise FALSE.
See also
GetFileName
The documentation for this class was generated from the following file:
  • XTPSyntaxEditLexColorFileReader.h


Toolkit Pro: CXTPSyntaxEditColorThemesManager Class Reference

Public Member Functions | List of all members
CXTPSyntaxEditColorThemesManager Class Reference

This class provides the functionality to store the set of all color themes that would be written from configuration files. More...

Public Member Functions

CXTPSyntaxEditColorThemesManager ()
Default object constructor.
virtual | ~CXTPSyntaxEditColorThemesManager ()
Destroys a CXTPSyntaxEditColorThemesManager() object, handles cleanup and de-allocation.
void | LoadTheme (const CString &strThemeName, const CString &strThemeFilename)
Loads a theme.
void | LoadThemeFromString (const CString &strThemeName, CStringArray &arPassedString)
Loads a theme.
void | AddThemeInfo (const CString &strThemeName, const CString &strThemeFilename)
Adds a new entity to the "theme name - configuration file" map.
CXTPSyntaxEditColorTheme * | GetTheme (const CString &strThemeName)
Gets the color theme with a specified name.
CStringArray & | GetThemes ()
Gets all theme names.
CString | ReloadFile (const CString &csFileName, int nCfgFlags=0)
Reloads configuration settings from a specified configuration file.
void | RemoveAll ()
Removes all loaded data.

Detailed Description

This class provides the functionality to store the set of all color themes that would be written from configuration files.

Member Function Documentation

◆ AddThemeInfo()

void AddThemeInfo | ( | const CString & | strThemeName,
 |  | const CString & | strThemeFilename )

Adds a new entity to the "theme name - configuration file" map.

Parameters
strThemeName | [in] Reference to the theme name.
strThemeFilename | [in] Reference to the configuration file name.

◆ GetTheme()

CXTPSyntaxEditColorTheme * GetTheme ( const CString & strThemeName )

Gets the color theme with a specified name.

Parameters
strThemeName [in] Reference to the theme name.
Returns
A pointer to the color theme with the specified name.
See also
CXTPSyntaxEditColorTheme

◆ GetThemes()

CStringArray & GetThemes ( )

Gets all theme names.

Returns
A reference to the CStringArray object containing all themes names.

◆ LoadTheme()

void LoadTheme | ( | const CString & | strThemeName,
 |  | const CString & | strThemeFilename )

Loads a theme.

Parameters
strThemeName | [in] Reference to the theme name.
strThemeFilename | [in] Reference to the configuration file name.

◆ LoadThemeFromString()

void LoadThemeFromString | ( | const CString & | strThemeName,
 |  | CStringArray & | arPassedString )

Loads a theme.

Parameters
strThemeName | [in] Reference to the theme name.
arPassedString | [in] Reference to an array of attribute strings.

◆ ReloadFile()

CString ReloadFile | ( | const CString & | csFileName,
 |  | int | nCfgFlags = 0 )

Reloads configuration settings from a specified configuration file.

Parameters
csFileName | [in] Reference to the configuration file name.
nCfgFlags | [in] Action flags.
Returns
The reloaded theme name if found, otherwise an empty string.

Does nothing if the specified file is not found in the collection of files from the main configuration file.

See also
XTPSyntaxEditCfgFileRemove
The documentation for this class was generated from the following file:
  • XTPSyntaxEditLexColorFileReader.h


Toolkit Pro: CXTPSyntaxEditCommand Class Reference

Public Member Functions | Protected Member Functions | Static Protected Member Functions | Protected Attributes | List of all members
CXTPSyntaxEditCommand Class Referenceabstract

This class represents an abstract Edit Control command interface. More...

Inheritance diagram for CXTPSyntaxEditCommand:
[legend]

Public Member Functions

virtual | ~CXTPSyntaxEditCommand ()
A default command destructor.
virtual int | Execute (XTP_EDIT_LINECOL &lcFrom, XTP_EDIT_LINECOL &lcTo, CXTPSyntaxEditCtrl *pEditCtrl)=0
This is an interface function for operation execution.
virtual int | UnExecute (XTP_EDIT_LINECOL &lcFrom, XTP_EDIT_LINECOL &lcTo, CXTPSyntaxEditCtrl *pEditCtrl)=0
This is an interface function for operation undoing.
virtual LPCTSTR | GetCommandText () const
Gets command text.
virtual void | SetCommandText (LPCTSTR szText)
Sets command text.
virtual int | GetDataSize () const
Gets the undo command data size (in bytes).

Protected Member Functions

CXTPSyntaxEditCommand ()
Protected constructor because this class could not be instantiated itself, only by its descendants.

Static Protected Member Functions

static void AFX_CDECL SetPositionInternally (CXTPSyntaxEditCtrl *pEditCtrl, const XTP_EDIT_LINECOL &lcPos)
Sets the line and column position for the specified control using internal fast methods.

Protected Attributes

CString m_strCommandText
Text description of the command.

Detailed Description

This class represents an abstract Edit Control command interface.

Its descendants must implement custom Execute and UnExecute functionality depending on a command type.

This class is used internally by the library only.

See also
CXTPSyntaxEditUndoRedoManager, CXTPSyntaxEditBatchCommand, CXTPSyntaxEditBufferCommand

Constructor & Destructor Documentation

◆ ~CXTPSyntaxEditCommand()

virtual ~CXTPSyntaxEditCommand ( )
virtual

A default command destructor.

Destroys the command object, handles its cleanup and de-allocation.

Member Function Documentation

◆ Execute()

virtual int Execute | ( | XTP_EDIT_LINECOL & | lcFrom,
 |  | XTP_EDIT_LINECOL & | lcTo,
 |  | CXTPSyntaxEditCtrl * | pEditCtrl )
 pure virtual

This is an interface function for operation execution.

Parameters
lcFrom | [out] Start text position affected by the action.
lcTo | [out] End text position affected by the action.
pEditCtrl | [in] Pointer to the edit control.
Returns
A bitwise combination of the following edit actions: XTP_EDIT_EDITACTION_MODIFYROW, XTP_EDIT_EDITACTION_DELETEROW, XTP_EDIT_EDITACTION_INSERTROW
See also
UnExecute

Implemented in CXTPSyntaxEditBatchCommand, CXTPSyntaxEditDeleteStringCommand, CXTPSyntaxEditInsertStringCommand, and CXTPSyntaxEditReplaceStringCommand.

◆ GetCommandText()

AFX_INLINE LPCTSTR GetCommandText ( ) const
virtual

Gets command text.

Each command has a string describing contained changes. (e.g. "Typing: something", "Delete", "Paste", etc.). This string is referred to as command text.

This function allows for a command to overwrite its own command text retrieval.

Returns
Command text.
See also
SetCommandText

◆ GetDataSize()

AFX_INLINE int GetDataSize ( ) const
virtual

Gets the undo command data size (in bytes).

Returns
The undo command data size (in bytes).

Reimplemented in CXTPSyntaxEditBatchCommand, CXTPSyntaxEditBufferCommand, and CXTPSyntaxEditReplaceStringCommand.

◆ SetCommandText()

AFX_INLINE void SetCommandText ( LPCTSTR szText )
virtual

Sets command text.

Parameters
szText [in] Command text to be set.

Each command has a string describing contained changes. (e.g. "Typing: something", "Delete", "Paste", etc.). This string is referred to as command text.

This function allows for a command to overwrite its own command text.

See also
GetCommandText

◆ SetPositionInternally()

static void AFX_CDECL SetPositionInternally | ( | CXTPSyntaxEditCtrl * | pEditCtrl,
 |  | const XTP_EDIT_LINECOL & | lcPos )
 staticprotected

Sets the line and column position for the specified control using internal fast methods.

Parameters
pEditCtrl | [in] Pointer to the edit control.
lcPos | [in] Reference to the text position to be set to the edit control.
Returns

◆ UnExecute()

virtual int UnExecute | ( | XTP_EDIT_LINECOL & | lcFrom,
 |  | XTP_EDIT_LINECOL & | lcTo,
 |  | CXTPSyntaxEditCtrl * | pEditCtrl )
 pure virtual

This is an interface function for operation undoing.

Parameters
lcFrom | [out] Start text position affected by the action.
lcTo | [out] End text position affected by the action.
pEditCtrl | [in] Pointer to the edit control.
Returns
A bitwise combination of the following edit actions: XTP_EDIT_EDITACTION_MODIFYROW, XTP_EDIT_EDITACTION_DELETEROW, XTP_EDIT_EDITACTION_INSERTROW
See also
Execute

Implemented in CXTPSyntaxEditBatchCommand, CXTPSyntaxEditDeleteStringCommand, CXTPSyntaxEditInsertStringCommand, and CXTPSyntaxEditReplaceStringCommand.

The documentation for this class was generated from the following file:
  • XTPSyntaxEditUndoManager.h


Toolkit Pro: CXTPSyntaxEditConfigurationManager Class Reference

Public Types | Public Member Functions | Public Attributes | List of all members
CXTPSyntaxEditConfigurationManager Class Reference

This class manages all configuration parameters of the control. More...

Inheritance diagram for CXTPSyntaxEditConfigurationManager:
[legend]

Public Types

enum XTPSyntaxEditCfgObjects { xtpEditCfgObjSchMan = 0x0001 , xtpEditCfgObjThemeMan = 0x0002 , xtpEditCfgObjMainConfig = 0x0004 }
Configuration manager sub-objects. More...

Public Member Functions

CXTPSyntaxEditConfigurationManager ()
Default object constructor.
virtual | ~CXTPSyntaxEditConfigurationManager ()
Destroys a CXTPSyntaxEditConfigurationManager() object, handles cleanup and de-allocation.
void | ReloadConfig (const CString &strConfigFilePath)
Reloads settings from a specified file.
void | ReloadConfig ()
Reloads configuration settings from the stored main configuration file.
void | ReloadConfigAsync (int nAsyncThreadPriority=THREAD_PRIORITY_NORMAL)
Asynchronously reloads configuration settings from the stored main configuration file.
CString | GetConfigFile () const
Gets the name of the main configuration file.
void | ReloadFile (CString csFileName, DWORD dwOwnerFlags, int nCfgFlags=0)
Reloads configuration settings from a specified configuration file.
CXTPSyntaxEditColorThemesManager & GetThemeManager ()
Gets the color theme manager.
CXTPSyntaxEditTextSchemesManager & GetTextSchemesManager ()
Gets the text scheme manager.
void | SetTheme (const CString &strThemeName, CXTPSyntaxEditTextSchema *pActiveSch=NULL)
Sets the current theme name.
void | Close ()
Closes the configuration monitor session.
CString | GetCurrentTheme () const
Gets the current theme name.
CXTPNotifyConnection * | GetConnection () const
Gets the notification connection.
void | SetSyntaxAndColorScheme (CString *pSyntaxScheme, CString *pColorScheme)
Sets the syntax and color scheme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Public Attributes

BOOL | m_bUseMonitor
TRUE if the control uses a special thread to synchronize syntax rules with files with Syntax and Color schemes, FALSE if the control works "off-line".
BOOL | m_bConfigFileMode
TRUE if the control reads Config file with links to detailed setting (Syntax and Color schemes), FALSE if Syntax and Color schemes are passed as strings using special functions.
CString | m_sIniSet
The ini file settings.
CString * | p_sSyntaxScheme
Pointer to the syntax scheme.
CString * | p_sColorScheme
Pointer to the color scheme.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

This class manages all configuration parameters of the control.

It worries about read configuration files from the disk when the Edit control is starting, stores it in internal structures and refreshes parameters in case the configuration files are changed after the control was started.

See also
CXTPSyntaxEditFileChangesMonitor, CXTPSyntaxEditColorThemesManager

Member Enumeration Documentation

◆ XTPSyntaxEditCfgObjects

enum XTPSyntaxEditCfgObjects

Configuration manager sub-objects.

Enumerator
xtpEditCfgObjSchMan | Schemes manager.
xtpEditCfgObjThemeMan | Themes manager.
xtpEditCfgObjMainConfig | Main configuration file.

Member Function Documentation

◆ GetConfigFile()

CString GetConfigFile ( ) const

Gets the name of the main configuration file.

Returns
The name of the main configuration file.
See also
CXTPSyntaxEditConfigurationManager::ReloadConfig

◆ GetConnection()

CXTPNotifyConnection * GetConnection ( ) const

Gets the notification connection.

Returns
A pointer to the notification connection.

◆ GetCurrentTheme()

AFX_INLINE CString GetCurrentTheme ( ) const

Gets the current theme name.

Returns
The current theme name.

◆ GetTextSchemesManager()

AFX_INLINE CXTPSyntaxEditTextSchemesManager & GetTextSchemesManager ( )

Gets the text scheme manager.

Returns
A reference to the text scheme manager.

◆ GetThemeManager()

AFX_INLINE CXTPSyntaxEditColorThemesManager & GetThemeManager ( )

Gets the color theme manager.

Returns
A reference to the color theme manager.

◆ ReloadConfig()

void ReloadConfig ( const CString & strConfigFilePath )

Reloads settings from a specified file.

Parameters
strConfigFilePath Reference to the string of the file's full path.

Reloads configuration settings from the specified new configuration file.

◆ ReloadConfigAsync()

void ReloadConfigAsync ( int nAsyncThreadPriority = THREAD_PRIORITY_NORMAL )

Asynchronously reloads configuration settings from the stored main configuration file.

Parameters
nAsyncThreadPriority Priority for the working thread which reloads the configuration.

◆ ReloadFile()

void ReloadFile | ( | CString | csFileName,
 |  | DWORD | dwOwnerFlags,
 |  | int | nCfgFlags = 0 )

Reloads configuration settings from a specified configuration file.

Parameters
csFileName | [in] Reference to the configuration file name.
dwOwnerFlags | [in] Owner flags.
nCfgFlags | [in] Action flags.

Does nothing if the specified file is not found in the collection of files from the main configuration file.

See also
XTPSyntaxEditCfgFileRemove

◆ SetSyntaxAndColorScheme()

void SetSyntaxAndColorScheme | ( | CString * | pSyntaxScheme,
 |  | CString * | pColorScheme )
 inline

Sets the syntax and color scheme.

Parameters
pSyntaxScheme | Syntax scheme.
pColorScheme | Color scheme.

◆ SetTheme()

void SetTheme | ( | const CString & | strThemeName,
 |  | CXTPSyntaxEditTextSchema * | pActiveSch = NULL )

Sets the current theme name.

Parameters
strThemeName | [in] Reference to the theme name.
pActiveSch | [in] Pointer to the active schema to apply the current theme.
The documentation for this class was generated from the following file:
  • XTPSyntaxEditLexColorFileReader.h


Toolkit Pro: CXTPSyntaxEditCtrl Class Reference

Classes | Public Member Functions | Static Public Member Functions | Public Attributes | Protected Types | Protected Member Functions | Protected Attributes | List of all members
CXTPSyntaxEditCtrl Class Reference

This class is the main CWnd-based editor class. More...

Classes

class CAverageVal
CXTPSyntaxEditCtrl::CAverageVal. More...

Public Member Functions

CXTPSyntaxEditCtrl ()
Default object constructor.
virtual | ~CXTPSyntaxEditCtrl ()
Destroys a CXTPSyntaxEditCtrl object, handles cleanup and de-allocation.
BOOL | GetLineNumbers () const
Determines if line numbering is enabled/disabled.
BOOL | SetLineNumbers (BOOL bLineNumbers, BOOL bUpdateReg=FALSE)
Enables/disables line numbering.
BOOL | GetCollapsibleNodes () const
Determines if the collapsible nodes area is enabled/disabled.
void | SetCollapsibleNodes (BOOL bDrawNodes, BOOL bUpdateReg=FALSE)
Enables/disables the collapsible nodes area.
BOOL | UnTabifySelection ()
Replaces all tabs with blank spaces.
BOOL | TabifySelection ()
Replaces all blank spaces with tabs.
BOOL | LowercaseSelection ()
Converts the selected text to lowercase.
BOOL | UppercaseSelection ()
Converts the selected text to uppercase.
CXTPSyntaxEditSelection & GetSelection ()
Gets the current selection.
CXTPSyntaxEditAutoCompleteWnd * | GetAutoCompleteWnd () const
Gets the auto-complete pop-up window.
int | GetRowPerPage () const
Gets the number of rows that can be printed per page when using the current settings.
BOOL | IsRowVisible (int iRow) const
Determines if a specified row is visible.
void | SetRightButtonDrag (BOOL bRightButtonDrag=TRUE)
Sets right mouse button for dragging.
BOOL | SetScrollBars (BOOL bHorzSBar, BOOL bVertSBar, BOOL bUpdateReg=FALSE)
Enables/disables scrollbars.
BOOL | GetHorzScrollBar () const
Determines if the horizontal scrollbar is enabled/disabled.
BOOL | GetVertScrollBar () const
Determines if the vertical scrollbar is enabled/disabled.
BOOL | SetSelMargin (BOOL bSelMargin, BOOL bUpdateReg=FALSE)
Enables/disables the gutter.
BOOL | GetSelMargin () const
Determines if the gutter is enabled/disabled.
BOOL | SetSyntaxColor (BOOL bSyntaxColor, BOOL bUpdateReg=FALSE)
Enables/disables syntax colorization.
BOOL | GetSyntaxColor () const
Determines if syntax colorization is enabled/disabled.
BOOL | SetAutoIndent (BOOL bAutoIndent, BOOL bUpdateReg=FALSE)
Enables/disables auto-indentation.
BOOL | GetAutoIndent () const
Determines if auto-indentation is enabled/disabled.
BOOL | SetTabSize (int nTabSize, BOOL bUpdateReg=FALSE)
Sets the tab size.
int | GetTabSize () const
Gets the tab size.
BOOL | GetTabWithSpace () const
Determines if replacing tabs with spaces is enabled/disabled.
BOOL | SetTabWithSpace (BOOL bTabWithSpace, BOOL bUpdateReg=FALSE)
Enables/disables replacing tabs with spaces.
void | SetRowColor (int nRow, COLORREF clrFront)
Sets the text color foreground for a specified row in the colors cache.
virtual COLORREF | GetRowColor (int nRow) const
Gets the text color foreground of a specified row in the colors cache.
void | SetRowBkColor (int nRow, COLORREF crBack)
Sets the background color of a specified row in the colors cache.
virtual COLORREF | GetRowBkColor (int nRow) const
Gets the background color of a specified row in the colors cache.
BOOL | IsEnabledWhiteSpace () const
Determines if showing white space is enabled/disabled.
void | EnableWhiteSpace (BOOL bShow=TRUE)
Enables/disables showing white space.
BOOL | IsEnabledVirtualSpace () const
Determines if virtual space mode is enabled/disabled.
void | EnableVirtualSpace (BOOL bEnable, BOOL bUpdateReg=FALSE)
Enables/disables virtual space mode.
BOOL | IsRightButtonDrag () const
Determines if mouse right button drag is enabled/disabled.
void | CancelRightButtonDrag ()
Disables mouse right button drag.
void | ShowDefaultContextMenu ()
Displays the default context menu.
void | HandleDrop (BOOL bCopy)
Handles the drop operation within the same edit buffer.
void | GoToRow (int iRow, BOOL bSelectRow=FALSE)
Moves to a specified row.
BOOL | ReplaceSel (LPCTSTR szNewText)
Replaces the selected text with specified text.
int | ReplaceAll (LPCTSTR szFindText, LPCTSTR szReplaceText, BOOL bMatchWholeWord, BOOL bMatchCase)
Replaces all occurrences of szFindText with szReplaceText.
int | GetSelectionText (CString &strText)
Gets the selected text.
void | SetDropPos (int iRow, int iCol)
Sets the drop position.
int | GetCurAbsCol () const
Gets the absolute column position.
HGLOBAL | GetSelectionBuffer (UINT nFormat)
Gets the handle of the selection buffer in global memory for a specified clipboard format (either CF_TEXT or CF_UNICODETEXT).
void | EnableOleDrag (BOOL bEnableDrag=TRUE)
Enables/disables OLE drag drop mode.
void | ValidateCol (const int nRow, int &nCol, int &nAbsCol)
Validates and sets the row column to a valid one.
BOOL | RowColFromPoint (CPoint pt, int *pRow, int *pCol, int *pDispRow=NULL, int *pDispCol=NULL, BOOL bVirtualSpace=-1)
Gets the row and column (not validated) at a specified point.
BOOL | DecreaseIndent ()
Deletes a tab from the front of the selection.
BOOL | IncreaseIndent ()
Inserts a tab to the front of the selection.
void | DeleteSelectedLines (int iForceDeleteRow)
Either deletes all lines in the selection or a specified line in the case that no selection exists.
void | ShowHScrollBar (BOOL bShow=TRUE)
Shows/hides the horizontal scrollbar.
void | CopyOrMoveText (BOOL bCopy)
Copies or moves text after dragging.
BOOL | Find (LPCTSTR szText, BOOL bMatchWholeWord, BOOL bMatchCase, BOOL bSearchDown, BOOL bRedraw=TRUE, int nStartRow=-1, int nStartCol=-1)
Finds specified text.
BOOL | Select (int nRow1, int nDispCol1, int nRow2, int nDispCol2, BOOL bRedraw=TRUE)
Selects the text bounded by a specified rectangle area.
void | Unselect ()
Deselects the previously selected rectangle area.
const CXTPSyntaxEditCtrl & | operator= (const CXTPSyntaxEditCtrl &src)
Copies the control settings from a specified control.
void | RestoreCursor ()
Restores the cursor.
void | SetOverwriteMode (BOOL bOverwriteMode)
Enables/disables overwrite mode.
BOOL | SetWideCaret (BOOL bWideCaret, BOOL bUpdateReg=FALSE)
Sets the caret for overwrite mode.
BOOL | GetWideCaret () const
Determines if thin caret is set for overwrite mode.
BOOL | IsHideCaret () const
Determines if the caret is hidden/visible.
void | SetHideCaret (BOOL bHide)
Hides/shows the caret.
void | SelectWord (CPoint point)
Selects the word at a specified point.
void | SetCurCaretPos (int nTextRow, int nDispCol, BOOL bRowColNotify=TRUE, BOOL bEnsureVisible=TRUE)
Sets the current caret position to a specified row and column.
CXTPSyntaxEditBufferManager * | GetEditBuffer () const
Gets the buffer manager of the smart edit control.
CXTPSyntaxEditConfigurationManager * | GetLexConfigurationManager () const
Gets the associated configuration manager.
CXTPSyntaxEditPaintManager * | GetPaintManager () const
Gets the associated paint manager.
virtual void | SetPaintManager (CXTPSyntaxEditPaintManager *pPaintManager)
Sets the associated paint manager.
CXTPSyntaxEditDrawTextProcessor & GetDrawTextProcessor ()
Gets the draw text processor.
void | InsertString (LPCTSTR szText, int iRow, int iCol, BOOL bDeleteSelection=TRUE)
Inserts either a string or a vertical text block at a specified row and column.
void | InsertTextBlock (LPCTSTR szText, int iRow, int iCol, BOOL bDeleteSelection=TRUE)
Inserts either a string or a vertical text block at a specified row and column.
CString | GetConfigFile () const
Gets the name of the main configuration file.
BOOL | SetConfigFile (LPCTSTR szPath, BOOL bConfigFileMode=TRUE)
Sets the the path to the main configuration file.
void | SetFontIndirect (LPLOGFONT pLogfont, BOOL bUpdateReg=FALSE)
Sets the font for the edit control.
void | SetCurPos (int nTextRow, int nDispCol, BOOL bRemainSelected=FALSE, BOOL bForceVisible=TRUE)
Sets the current cursor position to a specified row and column.
int | GetCurCol () const
Gets the current column.
int | GetCurRow () const
Gets the current row.
int | GetRowCount () const
Gets the number of rows in the current document.
void | SelectAll ()
Selects all text.
virtual void | Draw (CDC *pDC, const CRect &rcRect)
Draws the edit control client area.
virtual int | PrintPage (CDC *pDC, const CRect &rcRect, int nFlags=0)
Prints the edit control page.
virtual CRect | CalcEditRects (CRect *prcBookMarks=NULL, CRect *prcLineNum=NULL, CRect *prcNodes=NULL, CRect *prcText=NULL, const CRect *prcClient=NULL) const
Calculates the rectangles of the edit control regions.
BOOL | IsSelectionExist () const
Determines if the selection exists.
void | Paste ()
Pastes from the clipboard to the document.
void | Copy ()
Copies the selected text to the clipboard.
void | Cut ()
Copies the selected text to the clipboard and deletes the selected text from the document.
BOOL | CanRedo () const
Determines if it is possible to perform the redo action.
BOOL | CanUndo () const
Determines if it is possible to perform the undo action.
BOOL | Redo (int nActionsCount=1)
Performs a redo operation.
BOOL | Undo (int nActionsCount=1)
Performs a undo operation.
const CStringList & | GetUndoTextList ()
Gets the list of text for undo operations.
const CStringList & | GetRedoTextList ()
Gets the list of text for redo operations.
BOOL | DeleteChar (int iRow, int iCol, XTPSyntaxEditDeletePos pos)
Deletes the character at a specified location.
BOOL | DeleteBuffer (int iRowFrom, int iColFrom, int iRowTo, int iColTo, int nFlags=0)
Deletes a specified range of text.
BOOL | DeleteSelection ()
Deletes the currently selected text.
CString | GetText (int nMaxLen=-1) const
Gets the editor text.
BOOL | GetText (CMemFile &memFile, int nMaxLen=-1) const
Gets the editor text.
void | SetText (LPCTSTR pcszText)
Sets the editor text.
void | SetTopRow (int iRow)
Sets the top row of the visible window.
int | GetTopRow () const
Gets the identifier of the top row of the visible window.
void | RecalcScrollBars ()
Recalculates and sets the scroll bars and other related areas depending on the text size and current position.
void | RepositionBars (UINT nIDFirst, UINT nIDLast, UINT nIDLeftOver, UINT nFlag=CWnd::reposDefault, LPRECT lpRectParam=NULL, LPCRECT lpRectClient=NULL, BOOL bStretch=TRUE)
Repositions and resizes control bars in the client area of a window.
virtual CScrollBar * | GetScrollBarCtrl (int nBar) const
Retrieves a pointer to a specified sibling scroll bar.
void | EnableScrollBarCtrl (int nBar, BOOL bEnable=TRUE)
Enables/disables the scroll bar.
void | ShowScrollBar (UINT nBar, BOOL bShow=TRUE)
Shows/hides a specified scroll bar.
void | SetScrollRange (int nBar, int nMinPos, int nMaxPos, BOOL bRedraw=TRUE)
Sets the minimum and maximum position values for a specified scroll bar.
int | SetScrollPos (int nBar, int nPos, BOOL bRedraw=TRUE)
Sets the current position of a specified scroll box and, if requested, redraws the scroll bar to reflect the new position of the scroll box.
BOOL | SetScrollInfo (int nBar, LPSCROLLINFO lpScrollInfo, BOOL bRedraw=TRUE)
Sets the information that the SCROLLINFO structure maintains about a specified scroll bar.
int | GetScrollLimit (int nBar)
Retrieves the scroll limit of a specified scroll bar.
BOOL | GetScrollInfo (int nBar, LPSCROLLINFO lpScrollInfo, UINT nMask=SIF_ALL)
Retrieves the information of a specified scroll bar.
int | ScrollWindowEx (int dx, int dy, LPCRECT lpRectScroll, LPCRECT lpRectClip, CRgn *prgnUpdate, LPRECT lpRectUpdate, UINT flags)
Scrolls the specified client area with additional features.
void | ScrollWindow (int xAmount, int yAmount, LPCRECT lpRect=NULL, LPCRECT lpClipRect=NULL)
Scrolls the specified client area.
void | GetScrollRange (int nBar, LPINT lpMinPos, LPINT lpMaxPos) const
Gets the range of a specified scroll bar.
int | GetScrollPos (int nBar) const
Gets the position of a specified scroll box.
void | Scroll (int xPos, int yPos)
Scrolls the window by the specified offsets along the x- and y- axes.
BOOL | EnsureVisibleRow (int nTextRow)
Ensures the visibility of a specified row.
BOOL | EnsureVisibleCol (int nDispRow, int nDispCol)
Ensures the visibility of a specified location.
BOOL | Create (CWnd *pParent, BOOL bHorzScroll, BOOL bVertScroll, CXTPSyntaxEditBufferManager *pBuffer=NULL, CCreateContext *lpCS=NULL, UINT nID=0)
Creates the window.
void | AddRemoveBreakPoint (int nRow)
Adds/removes a breakpoint to/from a specified row.
void | AddRemoveBookmark (int nRow)
Adds/removes a bookmark to/from a specified row.
void | CollapseExpandBlock (int nRow)
Expands/collapses the block at a specified row.
void | DeleteBreakpoint (int nRow)
Removes the breakpoint from a specified row.
void | DeleteBookmark (int nRow)
Removes the bookmark from a specified row.
void | PrevBookmark ()
Moves the current position to the previous bookmark.
void | NextBookmark ()
Moves the current position to the next bookmark.
BOOL | HasBreakpoints () const
Determines if the current document has breakpoints.
BOOL | HasBookmarks () const
Determines if the current document has bookmarks.
BOOL | HasRowMark (int nRow, const XTP_EDIT_LINEMARKTYPE &lmType, XTP_EDIT_LMPARAM *pParam=NULL) const
Determines if a specified row has a specified mark.
void | CollapseAll ()
Collapses all expanded collapsible nodes.
void | ExpandAll ()
Expands all collapsed nodes.
CStringArray & | GetThemes ()
Gets the array of available theme names.
void | ApplyTheme (CString strTheme)
Applies a theme with a specified name to the editor.
CString | GetCurrentTheme () const
Gets the current theme name.
virtual void | RefreshColors ()
Refreshes the colors for the current document.
void | InvalidateRow (int nRow)
Invalidates a specified row.
void | InvalidateRows (int nRowFrom=-1, int nRowTo=-1)
Invalidates a specified set of rows.
BOOL | IsRowValid (int nDispRow) const
Determines if a specified row is valid.
void | SetRowValid (int nDispRow)
Validates a specified row.
BOOL | IsActive () const
Determines if the edit control is actived/deactivated.
virtual void | SetActive (BOOL bIsActive)
Activates/deactives the edit control.
BOOL | IsCreateScrollbarOnParent () const
Determines if scroll bars are created in the parent window.
void | SetCreateScrollbarOnParent (BOOL nSet)
Sets if scroll bars should be created in the parent window.
virtual BOOL | CanEditDoc () const
Determines if the document can be edited.
BOOL | IsReadOnly () const
Gets if the editor is in read-only mode.
virtual void | SetReadOnly (BOOL bReadOnly=TRUE)
Sets if the editor should be in read-only mode.
BOOL | IsViewOnly () const
Gets if the editor is in view-only mode.
void | SetViewOnly (BOOL bViewOnly)
Sets if the editor should be in view-only mode.
BOOL | IsEnabledEditAccelerators () const
Determines if editor accelerators are enabled/disabled.
void | EnableEditAccelerators (BOOL bEnable)
Enables/disables editor accelerators.
void | GetLineNodeRect (int nDispRow, CRect &rcNode, CRect *prcNodeFull=NULL) const
Calculates the rectangle(s) for a collapsible node icon.
void | CalculateEditbarLength (CDC *pDC=NULL)
Calculates the edit bar length.
void | _RecalcScrollBars ()
Recalculates the scroll bars depending on the text size and current position.
void | _RecalcHScrollMaxWidth ()
Recalculates the maximum width of the horizontal scrollbar depending on the visible text size.
void | _UpdateIMEStatus ()
Updates the IME status.
void | FillTabs (CString &rstrTextToIns, int nDispCol)
Adds tabs and spaces to specified text until it reaches a specified display column.
BOOL | CreateInsertText (LPTSTR szText, CString &strTextToIns, int &iNewRow, int &iNewCol, int &iNewDispCol, int &iEditRowFrom, int &iEditRowTo, int &iChainActionCount)
Fills and/or calculates number of tabs or blank spaces required.
void | NotifyEditChanged (int iRowFrom, int iRowTo, UINT nActions)
Sends an XTP_EDIT_NM_EDITCHANGED notification with specified parameters.
void | NotifyCurRowCol (int nRow, int nCol) const
Sends a notification when the current text position is changed.
virtual LRESULT | NotifyParent (UINT uCode) const
Sends any notifications to the parent.
virtual LRESULT | NotifyMouseEvent (UINT uCode, UINT nFlags, const CPoint &point) const
Sends any mouse notifications to the parent.
virtual BOOL | NotifyMarginLBtnClick (int nRow, int nDispRow) const
Notifies the parent that the user clicked in the bookmark area.
virtual void | NotifySelInit () const
Initializes the selection of all sibling views.
void | RecalcHorzScrollPos ()
Recalculates the horizontal scroll bar.
void | RecalcVertScrollPos ()
Recalculates the vertical scroll bar.
void | FindWord (UINT nFindWhat)
Searches for the next/previous word position.
BOOL | FindWordEx (UINT nFindWhat, int nTextRow, int nCol, XTP_EDIT_LINECOL &rlcWordStart, XTP_EDIT_LINECOL &rlcWordEnd, BOOL &rbOverSpace)
Searches for the next/previous word position.
BOOL | FindWordEx_str (UINT nFindWhat, XTP_EDIT_LINECOL lcPos_str, XTP_EDIT_LINECOL &rlcWordStart, XTP_EDIT_LINECOL &rlcWordEnd, BOOL &rbOverSpace)
Searches for the next/previous word position.
BOOL | MatchText (int nRow, LPCTSTR szLineText, LPCTSTR szMatchText, int nStartPos, BOOL bMatchWholeWord, BOOL bMatchCase, BOOL bSearchForward, BOOL bRedraw=TRUE)
Attempts to match text using the specified parameters.
CWnd * | GetEffectiveParent () const
Gets the effective parent window.
int | CalcValidDispCol (LPCTSTR szText, int iCol) const
Calculate and returns the display column for another display column specified in the iCol parameter.
int | CalcAbsCol (LPCTSTR szText, int nDispCol) const
Calculates the absolute column for a specified display column.
int | CalcDispCol (LPCTSTR szText, int nActualCol) const
Calculates the display column for a specified absolute column.
int | CalcAbsCol (int nTextRow, int nDispCol) const
Calculates the absolute column for a specified display column.
int | CalcDispCol (int nTextRow, int nActualCol) const
Calculates the display column for a specified absolute column.
CXTPSyntaxEditLineMarksManager * | GetLineMarksManager () const
Gets a pointer to the line marks manager associated with the current text buffer.
void | SetRowText (int nRow, LPCTSTR pcszText, BOOL bCanUndo)
Sets the text value for a specified row.
void | InsertRow (int nRow, LPCTSTR pcszText, BOOL bCanUndo)
Inserts a new row.
void | RemoveRow (int nRow, BOOL bCanUndo)
Removes a specified row.
virtual void | GetRowColors (int nTextRow, int nColFrom, int nColTo, const XTP_EDIT_COLORVALUES &clrDefault, CXTPSyntaxEditTextBlockList *rBlocks)
Gets the text colors of a specified row.
virtual void | GetCollapsableBlocksInfo (int nTextRow, CXTPSyntaxEditRowsBlockArray &rArBlocks) const
Gets the collapsable text blocks of a specified row.
CString | GetLineText (int nRow, BOOL bAddCRLF=FALSE, int iCRLFStyle=-1) const
Gets the text of a specified line.
void | GetLineText (int nRow, CString &strBuffer, BOOL bAddCRLF=FALSE, int iCRLFStyle=-1) const
Gets the text of a specified line.
BOOL | IsConfigFileMode ()
Gets the config file mode.
CString | GetSyntaxScheme ()
Gets the syntax scheme.
CString | GetColorScheme ()
Gets the color scheme.
void | SetPassedIniSet (CString sPassedIniSet)
Sets the passed ini set.
void | SetSyntaxAndColorScheme (CString sSyntaxScheme, CString sColorScheme, BOOL bScheme=FALSE, BOOL bColors=FALSE)
Sets the syntax and color schemes.
void | ReloadSyntaxStringMode ()
Reloads the syntax string mode.
void | ReloadSyntaxConfigFileMode ()
Reloads the syntax config file mode.

Static Public Member Functions

static CString AFX_CDECL GetModulePath ()
Gets the path of the executable file module.

Public Attributes

BOOL | m_bDisableRedraw
If TRUE - control window is not redraw, it is draw last window content (draw cached bitmap).
BOOL | m_bUseMonitor
TRUE if control use special thread to synchronize syntax rules with files with Syntax and Color schemes FALSE if control works "off-line".

Protected Types

enum XTPScrolDirection { xtpLeft = 0x0001 , xtpRight = 0x0010 , xtpTop = 0x0100 , xtpBottom = 0x1000 }
This enum defines flags for auto-scroll direction. More...

Protected Member Functions

int | ExpandChars (CDC *pDC, LPCTSTR pszChars, int nCurPos, CString &strBufer)
Expands the character set by putting spaces in the position of tabs.
void | ProcessCollapsedText (CDC *pDC, XTP_EDIT_COLLAPSEDBLOCK *pCoDrawBlk, CRect &rcCoBlk)
Calculates the collapsed text sign rectangle (like for [..]).
BOOL | ProcessCollapsedTextEx (CDC *pDC, XTP_EDIT_COLLAPSEDBLOCK *pCoDrawBlk, const XTP_EDIT_TEXTBLOCK &txtBlk, CRect &rcCoBlk)
Performs the same functionality as ProcessCollapsedText, but has additional checks for input parameters.
CString | GetCollapsedText (XTP_EDIT_COLLAPSEDBLOCK *pCoDrawBlk, int nMaxLinesCount=150) const
Gets the collapsed text of a specified collapsed block.
XTP_EDIT_COLLAPSEDBLOCK * | GetBlockFromPt (const CPoint &ptMouse) const
Gets the collapsed block, if any, at a specified point.
void | ShowCollapsedToolTip (const CPoint &ptMouse)
Shows a tooltip with the collapsed text of the collapsed block at a specified point.
int | ProcessCollapsedBlockDblClick (const CPoint &ptMouse)
Expands a collapsed block if it is double clicked.
void | UpdateScrollPos (DWORD dwUpdate=XTP_EDIT_UPDATE_ALL)
Updates sibling views while in split mode.
void | SetDocModified (BOOL bModified=TRUE)
Sets the modification flag for the currently opened document.
int | CalcMaximumWidth (LPCTSTR szText)
Calculates the maximum width of specified text.
CString | GetDefaultCfgFilePath ()
Gets the default configuration file path.
void | OnBeforeEditChanged (int nRow, int nCol)
Internal editing event handler.
void | OnEditChanged (int nRowFrom, int nColFrom, int nRowTo, int nColTo, int eEditAction)
Internal editing event handler.
void | OnEditChanged (const XTP_EDIT_LINECOL &LCFrom, const XTP_EDIT_LINECOL &LCTo, int eEditAction)
Internal editing event handler.
void | OnParseEvent (XTP_NOTIFY_CODE code, WPARAM wParam, LPARAM lParam)
Internal editing event handler.
BOOL | NotifyParseEvent (XTP_NOTIFY_CODE code, WPARAM wParam, LPARAM lParam)
Sends a WM_NOTIFY message with an XTP_EDIT_NM_PARSEEVENT code to the parent window.
void | OnLexCfgWasChanged (XTP_NOTIFY_CODE code, WPARAM wParam, LPARAM lParam)
Internal editing event handler.
int | GetCurrentDocumentRow () const
Gets the current document row.
void | SetCurrentDocumentRow (int nRow)
Sets the current document row.
int | GetCurrentVisibleRow ()
Gets the current visible row.
int | GetDocumentRow (int nVisibleRow)
Calculates document row basing in visible row.
int | CalculateDocumentRow (int nStartDocumentRow, int nRowDelta)
Calculates document row basing in global visible row.
int | GetVisibleRow (int nDocumentRow)
Calculates visible row basing in document row.
int | CalculateVisibleRow (int nStartDocumentRow, int nDocumentRow)
Calculates global visible row basing in document row.
int | CalculateVisibleRow_ (int nStartDocumentRow, int nDocumentRow)
Calculates global visible row basing in document row.
int | GetVisibleRowsCount (int nMaxDocRow=-1)
Gets the maximum number of visible rows.
int | MoveCurrentVisibleRowUp (int nCount)
Moves the current row up a specified number of rows.
int | MoveCurrentVisibleRowDown (int nCount)
Moves the current row down a specified number of rows.
BOOL | ShiftCurrentVisibleRowUp (int nCount, BOOL bChangeCaret=FALSE)
Shifts the current row up a specified number of rows.
BOOL | ShiftCurrentVisibleRowDown (int nCount, BOOL bChangeCaret=FALSE)
Shifts the current row down a specified number of rows.
BOOL | GetCollapsedBlockLen (int nStartRow, int &rnLen) const
Gets the length of a collapsed block.
BOOL | GetRowNodes (int nRow, DWORD &dwType) const
Gets the row node type.
virtual void | SetAutoCompleteList ()
Loads data into an auto-complete list.
virtual void | RefreshLineMarks (XTP_EDIT_NMHDR_EDITCHANGED *pEditChanged)
Refreshes line marks depending on the change type.
virtual void | RedrawLineMarks ()
Redraws line marks.
BOOL | DoUndoRedo (int nActionsCount, BOOL bUndoRedo)
Performs undo/redo operations and common control properties adjustment.
BOOL | DoChangeSelectionCase (BOOL bUpper)
Changes the case of the selection.
BOOL | DoChangeSelectionTabify (BOOL bTabify)
Changes the tabification of the selection.
BOOL | GetRegValues ()
Reads options from the registry.
void | UpdateRowInfoInternally (int nTextRow)
Internally updates drawing information (e.g.
virtual DWORD | GetAutoscrollDirection (int *pnCols=NULL, int *pnRows=NULL)
Determines the scroll direction for automatic scrolling (when selecting by mouse).
XTP_EDIT_LINECOL | _SubtractSelSizeFromPos (XTP_EDIT_LINECOL lcDispPos)
Subtracts the selection size from a specified position.
virtual void | DoAutoIndentIfNeed (int nBaseDocRow, int nDispCol_prev)
Sets variables for auto-indent.
virtual void | _EnableScrollBarNotify (DWORD dwScrollBar, DWORD dwState)
Notifies the parent window that the scroll bar state has changed.
XTPSyntaxEditLexAnalyser::CXTPSyntaxEditLexTextBlock * | GetOnScreenSch (int nForRow)
Gets the screen schema cache.
void | ClearOnScreenSchCache (int nRowFrom)
Clears the screen schema cache.
virtual UINT | CalcAveDataSize (int nRowStart, int nRowEnd)
Calculates the average line length between specified starting and ending rows.
BOOL | RegisterWindowClass (HINSTANCE hInstance=NULL)
Registers the window class if it has not already been registered.

Protected Attributes

CXTPSyntaxEditRowColorMap | m_mapInternalRowBkColor
Map for row back colors.
CXTPSyntaxEditRowColorMap | m_mapInternalRowForeColor
Map for row colors.
BOOL | m_bVertScrollBar
TRUE if vertical scrollbar is enabled.
BOOL | m_bHorzScrollBar
TRUE if horizontal scrollbar is enabled.
BOOL | m_bScrolling
TRUE if scrolling by mouse wheel.
BOOL | m_bCaseSensitive
TRUE if case sensitive.
BOOL | m_bEnableOleDrag
TRUE if OLE drag drop is enabled.
BOOL | m_bIsSmartIndent
TRUE if smart indentation is enabled.
BOOL | m_bRightButtonDrag
TRUE if the user is dragging through right button.
BOOL | m_bIsScrollingEndRow
Maintains an internal logic to draw the last row which is partly visible.
BOOL | m_bTokensLoaded
TRUE if if tokens are loaded.
BOOL | m_bDroppable
TRUE if the current position is droppable.
BOOL | m_bDragging
TRUE if in dragging mode.
BOOL | m_bIsDragging
TRUE if dragging, FALSE otherwise.
BOOL | m_bPageDirty
TRUE if the whole page is dirty.
BOOL | m_bIsActive
TRUE if the application is active.
BOOL | m_bFocused
TRUE if focused.
BOOL | m_bCreateScrollbarOnParent
TRUE if parent window scroll bars are used, otherwise FALSE.
BOOL | m_bActivateOnFocus
Flag to activate control on focus set (like CXTPSyntaxEditView do).
int | m_nTopCalculatedRow
Top row of the last range of rows that have scrollbars properly calculated.
int | m_nBottomCalculatedRow
Bottom row of the last range of rows that have scrollbars properly calculated.
int | m_nEditbarLength
Edit bar length including gutter and line number.
int | m_nMarginLength
Margin length.
int | m_nLineNumLength
Line numbers length.
int | m_nNodesWidth
The width of the nodes signs.
int | m_nInsertTabCount
Temporarily stores the number of tabs to be inserted for auto-indentation.
int | m_nInsertSpaceCount
Temporarily stores the number of spaces to be inserted for auto-indentation.
int | m_nAutoIndentCol
Contains the column for auto-indentation.
int | m_nTopRow
Top row for display.
int | m_nCurrentDocumentRow
Current row in the document.
int | m_nCurrentCol
Current absolute column.
int | m_nDispCol
Current display column.
int | m_nWheelScroll
Lines to scroll on mouse wheel.
int | m_nAverageLineLen
Average length of line.
int | m_nCollapsedTextRowsCount
The total amount of collapsed blocks in the document.
DWORD | m_dwInsertPos
Current insert position.
DWORD | m_dwLastRedrawTime
Stores last redrawing time.
BYTE | m_chPrevLeadByte
For non-UNICODE version, IME sends double byte chars as 2 messages.
CPoint | m_ptDropPos
Drop position.
CPoint | m_ptPrevMouse
Mouse position of the previous tip showing.
CBitmap | m_bmpCache
Current view cached picture.
CXTPSyntaxEditSelection * | m_pSelection
Current selection.
DWORD | m_dwAutoScrollDirection
Active auto-scroll direction.
CXTPSyntaxEditBufferManager * | m_pBuffer
The buffer manager.
CXTPSyntaxEditPaintManager * | m_pPaintManeger
The paint manager.
CWnd * | m_pParentWnd
Pointer to the parent window.
CUIntArray | m_arCollapsedTextRows
The array of rows with beginning of collapsed blocks.
CXTPSyntaxEditToolTipCtrl * | m_pToolTip
Tooltip window for collapsed blocks text.
CXTPSyntaxEditAutoCompleteWnd * | m_pAutoComplete
Auto-complete pop-up window.
CString | m_strDefaultCfgFilePath
Configuration file full name.
CString | m_strSyntaxScheme
The syntax scheme.
CString | m_strColorScheme
The color scheme.
int | m_nHScrollMaxWidth
Maximum horizontal scrollbar position.
BOOL | m_bWndCreateInProgress
Internal flag to indicate that window creation is in progress.
CTextSearchCache * | m_fcCollapsable
Collapsible rows cache.
CTextSearchCache * | m_fcRowColors
Row colors cache.
CScreenSearchCache * | m_arOnScreenSchCache
On-screen schema cache for this control.
CByteArray | m_arValidDispRows
Array with indexes of valid displayed rows.
CAverageVal | m_aveRedrawScreenTime
Redraw screen time.
CXTPSyntaxEditDrawTextProcessor * | m_pDrawTextProcessor
Pointer to the draw text processor.
CImmWrapper * | m_pImmWrapper
Imm wrapper.
BOOL | m_bIMEsupported
TRUE if IME is supported, FALSE otherwise.
CString | m_sIniSet
String with default or passed type of rules, e.g.
BOOL | m_bConfigFileMode
TRUE if control read Config file with links to detailed setting (Syntax and Color schemes) FALSE if Syntax and Color schemes passed as strings using special functions.
CString | m_sPassedIniSet
String with passed type of rules, e.g.

Detailed Description

This class is the main CWnd-based editor class.

It is a rectangular child window in which the user can enter and edit text.

The control is also capable of enhancing text coloring for a number of specific input file types (e.g. C/C++ source files, HTML files, etc.). The user can create and customize their own text files schemes (they are independent of source files). The control contains the main configuration file, which can contain references to specific configuration files. By default, this file is placed in the same folder as the application executable and is called EditControl.ini. The main configuration file contains 2 blocks with references to input file lexicographic schemes in a specific format (see below) and color themes for the editor, which could be applied to the control editing any file type. The format of the main configuration file is as follows:

[Schemas]
FileType1=SchemaFileName1.schclass
FileType2=SchemaFileName2.schclass
...

[Themes]
ThemeName1=ThemeFileName1.ini
ThemeName2=ThemeFileName2.ini
...

Member Enumeration Documentation

◆ XTPScrolDirection

enum XTPScrolDirection
protected

This enum defines flags for auto-scroll direction.

Enumerator
xtpLeft | Defines left direction.
xtpRight | Defines right direction.
xtpTop | Defines top direction.
xtpBottom | Defines bottom direction.

Member Function Documentation

◆ _EnableScrollBarNotify()

virtual void _EnableScrollBarNotify | ( | DWORD | dwScrollBar,
 |  | DWORD | dwState )
 protectedvirtual

Notifies the parent window that the scroll bar state has changed.

Parameters
dwScrollBar | [in] Defines the scroll bar(s) to change state as WS_HSCROLL and WS_VSCROLL flags.
dwState | [in] Defines the scroll bar(s) state as WS_HSCROLL and WS_VSCROLL flags.

The default implementation sends an XTP_EDIT_NM_ENABLESCROLLBAR notification to the parent.

◆ _SubtractSelSizeFromPos()

XTP_EDIT_LINECOL _SubtractSelSizeFromPos ( XTP_EDIT_LINECOL lcDispPos )
protected

Subtracts the selection size from a specified position.

Parameters
lcDispPos Position.
Returns
The subtracted position.

◆ AddRemoveBookmark()

void AddRemoveBookmark ( int nRow )

Adds/removes a bookmark to/from a specified row.

Parameters
nRow [in] Row identifier in document coordinates.

If the row does not have a bookmark, then a bookmark will be added. If the row does have a bookmark, then a bookmark will be removed.

◆ AddRemoveBreakPoint()

void AddRemoveBreakPoint ( int nRow )

Adds/removes a breakpoint to/from a specified row.

Parameters
nRow [in] Row identifier in document coordinates.

If the row does not have a breakpoint, then a breakpoint will be added. If the row does have a breakpoint, then the breakpoint will be removed.

◆ ApplyTheme()

void ApplyTheme ( CString strTheme )

Applies a theme with a specified name to the editor.

Parameters
strTheme [in] Name of the theme to be applied.

◆ CalcAbsCol() [1/2]

int CalcAbsCol | ( | int | nTextRow,
 |  | int | nDispCol ) const

Calculates the absolute column for a specified display column.

Parameters
nTextRow | [in] Row identifier.
nDispCol | [in] Display column position.
Returns
The calculated absolute column.

◆ CalcAbsCol() [2/2]

int CalcAbsCol | ( | LPCTSTR | szText,
 |  | int | nDispCol ) const

Calculates the absolute column for a specified display column.

Parameters
szText | [in] Text for calculation.
nDispCol | [in] Display column position.
Returns
The calculated absolute column.

◆ CalcAveDataSize()

virtual UINT CalcAveDataSize | ( | int | nRowStart,
 |  | int | nRowEnd )
 protectedvirtual

Calculates the average line length between specified starting and ending rows.

Parameters
nRowStart | [in] Row index to calculate from.
nRowEnd | [in] Row index to calculate to.
Returns
The average line length between the specified starting and ending rows.

◆ CalcDispCol() [1/2]

int CalcDispCol | ( | int | nTextRow,
 |  | int | nActualCol ) const

Calculates the display column for a specified absolute column.

Parameters
nTextRow | [in] Row identifier.
nActualCol | [in] Absolute column position.
Returns
The calculated display column.

◆ CalcDispCol() [2/2]

int CalcDispCol | ( | LPCTSTR | szText,
 |  | int | nActualCol ) const

Calculates the display column for a specified absolute column.

Parameters
szText | [in] Text for calculation.
nActualCol | [in] Absolute column position.
Returns
The calculated display column.

◆ CalcEditRects()

virtual CRect CalcEditRects | ( | CRect * | prcBookMarks = NULL,
 |  | CRect * | prcLineNum = NULL,
 |  | CRect * | prcNodes = NULL,
 |  | CRect * | prcText = NULL,
 |  | const CRect * | prcClient = NULL ) const
 virtual

Calculates the rectangles of the edit control regions.

Parameters
prcBookMarks | [out] Pointer to a CRect object to receive the bookmarks area rectangle. The value of this parameter may be NULL.
prcLineNum | [out] Pointer to a CRect object to receive the line numbers area rectangle. The value of this parameter may be NULL.
prcNodes | [out] Pointer to a CRect object to receive the line nodes area rectangle. The value of this parameter may be NULL.
prcText | [out] Pointer to a CRect object to receive the text area rectangle. The value of this parameter may be NULL.
prcClient | [in] Pointer to a CRect object containing the base edit control rectangle to be used to calculate the other rectangles. Set the value of this parameter to NULL to use the edit control's window client rectangle.

Empty rectangles will be returned for invisible/disabled regions.

Returns
The rectangle used to calculate the other rectangles.

◆ CalcMaximumWidth()

int CalcMaximumWidth ( LPCTSTR szText )
protected

Calculates the maximum width of specified text.

Parameters
szText [in] Text for calculation.
Returns
The maximum width of the specified text.

◆ CalculateDocumentRow()

int CalculateDocumentRow | ( | int | nStartDocumentRow,
 |  | int | nRowDelta )
 protected

Calculates document row basing in global visible row.

Parameters
nStartDocumentRow | [in] Start document row.
nRowDelta | [in] Visible rows count.
Returns
Integer value of document row.

◆ CalculateEditbarLength()

void CalculateEditbarLength ( CDC * pDC = NULL )

Calculates the edit bar length.

Parameters
pDC [in] Pointer to a device context.

◆ CalculateVisibleRow()

int CalculateVisibleRow | ( | int | nStartDocumentRow,
 |  | int | nDocumentRow )
 protected

Calculates global visible row basing in document row.

Parameters
nStartDocumentRow | [in] Start row.
nDocumentRow | [in] Count of document rows.
Returns
Integer value of global visible row. Returns 1 if value less than 1.
See also
CalculateVisibleRow_

◆ CalculateVisibleRow_()

int CalculateVisibleRow_ | ( | int | nStartDocumentRow,
 |  | int | nDocumentRow )
 protected

Calculates global visible row basing in document row.

Parameters
nStartDocumentRow | [in] Start row.
nDocumentRow | [in] Count of document rows.
Returns
Integer value of global visible row. Can return values less than 1 if nStartDocumentRow bigger than nDocumentRow.
See also
CalculateVisibleRow

◆ CalcValidDispCol()

int CalcValidDispCol | ( | LPCTSTR | szText,
 |  | int | iCol ) const

Calculate and returns the display column for another display column specified in the iCol parameter.

Parameters
szText | [in] The text on which the calculation should be made.
iCol | [in] The display column for which calculation is needed.
Returns
The display column as integer value.

◆ CancelRightButtonDrag()

AFX_INLINE void CancelRightButtonDrag ( )

Disables mouse right button drag.

See also
SetRightButtonDrag, IsRightButtonDrag, CXTPSyntaxEditView

◆ CanEditDoc()

virtual BOOL CanEditDoc ( ) const
virtual

Determines if the document can be edited.

Returns
TRUE if the document can be edited, otherwise FALSE.

◆ CanRedo()

BOOL CanRedo ( ) const

Determines if it is possible to perform the redo action.

Returns
TRUE if it is possible to perform the redo action, otherwise FALSE.
See also
Redo

◆ CanUndo()

BOOL CanUndo ( ) const

Determines if it is possible to perform the undo action.

Returns
TRUE if it is possible to perform the undo action, otherwise FALSE.
See also
Undo

◆ ClearOnScreenSchCache()

void ClearOnScreenSchCache ( int nRowFrom )
protected

Clears the screen schema cache.

Parameters
nRowFrom [in] Row index to clear the cache from.

◆ CollapseAll()

void CollapseAll ( )

Collapses all expanded collapsible nodes.

See also
ExpandAll

◆ CollapseExpandBlock()

void CollapseExpandBlock ( int nRow )

Expands/collapses the block at a specified row.

Parameters
nRow [in] Row identifier in document coordinates.

If the block at the specified row is expanded, then it will be collapsed. If the block at the specified row is collapsed, then it will be expanded.

◆ CopyOrMoveText()

void CopyOrMoveText ( BOOL bCopy )

Copies or moves text after dragging.

Parameters
bCopy [in] TRUE to copy text, FALSE to move text.

◆ Create()

BOOL Create | ( | CWnd * | pParent,
 |  | BOOL | bHorzScroll,
 |  | BOOL | bVertScroll,
 |  | CXTPSyntaxEditBufferManager * | pBuffer = NULL,
 |  | CCreateContext * | lpCS = NULL,
 |  | UINT | nID = 0 )

Creates the window.

Parameters
pParent | [in] Pointer to the parent window (must not be NULL).
bHorzScroll | [in] TRUE to use a horizontal scroll bar, FALSE otherwise.
bVertScroll | [in] TRUE to use a vertical scroll bar, FALSE otherwise.
pBuffer | [in] Pointer to the buffer for the control (used by splitter).
lpCS | [in] Pointer to the create context of the window.
nID | [in] Control identifier.
Returns
TRUE if the window was created successfully, otherwise FALSE.

◆ CreateInsertText()

BOOL CreateInsertText | ( | LPTSTR | szText,
 |  | CString & | strTextToIns,
 |  | int & | iNewRow,
 |  | int & | iNewCol,
 |  | int & | iNewDispCol,
 |  | int & | iEditRowFrom,
 |  | int & | iEditRowTo,
 |  | int & | iChainActionCount )

Fills and/or calculates number of tabs or blank spaces required.

Parameters
szText | [in] Text to be inserted.
strTextToIns | [out] Return string with all the indentation.
iNewRow | [out] New row.
iNewCol | [out] New absolute column.
iNewDispCol | [out] New display column.
iEditRowFrom | [out] Start row for XTP_EDIT_NM_EDITCHANGED.
iEditRowTo | [out] End row for XTP_EDIT_NM_EDITCHANGED.
iChainActionCount | [out] Chain action count for undo.
Returns
TRUE if successful, otherwise FALSE.

◆ DecreaseIndent()

BOOL DecreaseIndent ( )

Deletes a tab from the front of the selection.

Returns
TRUE if successful, otherwise FALSE.

◆ DeleteBookmark()

void DeleteBookmark ( int nRow )

Removes the bookmark from a specified row.

Parameters
nRow [in] Row identifier in document coordinates.

◆ DeleteBreakpoint()

void DeleteBreakpoint ( int nRow )

Removes the breakpoint from a specified row.

Parameters
nRow [in] Row identifier in document coordinates.

◆ DeleteBuffer()

BOOL DeleteBuffer | ( | int | iRowFrom,
 |  | int | iColFrom,
 |  | int | iRowTo,
 |  | int | iColTo,
 |  | int | nFlags = 0 )

Deletes a specified range of text.

Parameters
iRowFrom | [in] Start row in document coordinates.
iColFrom | [in] Start column in document coordinates.
iRowTo | [in] End row in document coordinates.
iColTo | [in] End column in document coordinates.
nFlags | [in] Mode flag. Possible values are: smfRedraw, smfForceRedraw, smfTextAsBlock.
Returns
TRUE if successful, otherwise FALSE.
See also
XTPSyntaxEditFlags

◆ DeleteChar()

BOOL DeleteChar | ( | int | iRow,
 |  | int | iCol,
 |  | XTPSyntaxEditDeletePos | pos )

Deletes the character at a specified location.

Parameters
iRow | [in] Row identifier in document coordinates.
iCol | [in] Column identifier in document coordinates.
pos | [in] Position qualifier.
Returns
TRUE if successful, otherwise FALSE.
See also
XTPSyntaxEditDeletePos enum.

◆ DeleteSelectedLines()

void DeleteSelectedLines ( int iForceDeleteRow )

Either deletes all lines in the selection or a specified line in the case that no selection exists.

Parameters
iForceDeleteRow [in] Line to delete in the case that no selection exists.

◆ DeleteSelection()

BOOL DeleteSelection ( )

Deletes the currently selected text.

Returns
TRUE if successful, otherwise FALSE.

◆ DoAutoIndentIfNeed()

virtual void DoAutoIndentIfNeed | ( | int | nBaseDocRow,
 |  | int | nDispCol_prev )
 protectedvirtual

Sets variables for auto-indent.

Parameters
nBaseDocRow | [in] Text row to calculate auto-indent start.
nDispCol_prev | [in] Previous display column (before enter pressed).

◆ DoChangeSelectionCase()

BOOL DoChangeSelectionCase ( BOOL bUpper )
protected

Changes the case of the selection.

Parameters
bUpper [in] TRUE to change the selection case to upper, FALSE to change the selection case to lower.
Returns
TRUE if successful, otherwise FALSE.

◆ DoChangeSelectionTabify()

BOOL DoChangeSelectionTabify ( BOOL bTabify )
protected

Changes the tabification of the selection.

Parameters
bTabify [in] TRUE to change spaces to tabs, FALSE to change tabs to spaces.
Returns
TRUE if successful, otherwise FALSE.

◆ DoUndoRedo()

BOOL DoUndoRedo | ( | int | nActionsCount,
 |  | BOOL | bUndoRedo )
 protected

Performs undo/redo operations and common control properties adjustment.

Parameters
nActionsCount | [in] Number of actions to undo/redo.
bUndoRedo | [in] TRUE to perform undo operations, FALSE to perform redo operations.
Returns
TRUE if successful, otherwise FALSE.

◆ Draw()

virtual void Draw | ( | CDC * | pDC,
 |  | const CRect & | rcRect )
 virtual

Draws the edit control client area.

Parameters
pDC | [in] Pointer to a CDC object.
rcRect | [in] Reference to a CRect object.
See also
PrintPage

◆ EnableEditAccelerators()

AFX_INLINE void EnableEditAccelerators ( BOOL bEnable )

Enables/disables editor accelerators.

Parameters
bEnable TRUE to enable editor accelerators, FALSE to disable editor accelerators.

By default, this feature is disabled.

◆ EnableOleDrag()

void EnableOleDrag ( BOOL bEnableDrag = TRUE )

Enables/disables OLE drag drop mode.

Parameters
bEnableDrag [in] TRUE to enable OLE drag drop mode, FALSE to disable OLE drag drop mode.

◆ EnableScrollBarCtrl()

void EnableScrollBarCtrl | ( | int | nBar,
 |  | BOOL | bEnable = TRUE )

Enables/disables the scroll bar.

Parameters
nBar | [in] Scroll bar identifier.
bEnable | [in] TRUE to enable the scroll bar, FALSE to disable the scroll bar.

If the window has a sibling scroll bar control, then that scroll bar is used, otherwise the window's own scroll bar is used.

See also
ShowScrollBar

◆ EnableVirtualSpace()

void EnableVirtualSpace | ( | BOOL | bEnable,
 |  | BOOL | bUpdateReg = FALSE )

Enables/disables virtual space mode.

Parameters
bEnable | [in] TRUE to enable virtual space mode, FALSE to disable virtual space mode.
bUpdateReg | [in] TRUE to update this setting in the registry, FALSE otherwise. By default, this parameter is FALSE.
See also
IsEnabledWhiteSpace

◆ EnableWhiteSpace()

void EnableWhiteSpace ( BOOL bShow = TRUE )

Enables/disables showing white space.

Parameters
bShow [in] TRUE to enable showing white space, FALSE to disable showing white space.
See also
IsEnabledWhiteSpace

◆ EnsureVisibleCol()

BOOL EnsureVisibleCol | ( | int | nDispRow,
 |  | int | nDispCol )

Ensures the visibility of a specified location.

Parameters
nDispRow | [in] Row identifier in display coordinates.
nDispCol | [in] Column identifier in display coordinates.
Returns
TRUE if successful, otherwise FALSE.

◆ EnsureVisibleRow()

BOOL EnsureVisibleRow ( int nTextRow )

Ensures the visibility of a specified row.

Parameters
nTextRow [in] Row identifier in document coordinates.
Returns
TRUE if successful, otherwise FALSE.

◆ ExpandAll()

void ExpandAll ( )

Expands all collapsed nodes.

See also
CollapseAll

◆ ExpandChars()

int ExpandChars | ( | CDC * | pDC,
 |  | LPCTSTR | pszChars,
 |  | int | nCurPos,
 |  | CString & | strBufer )
 protected

Expands the character set by putting spaces in the position of tabs.

Parameters
pDC | [in] Pointer to a CDC object.
pszChars | [in] Text to be processed.
nCurPos | [in] Current position in the line.
strBufer | [in] Reference to the buffer for text to be created after expansion.
Returns
The length of the processed text after expansion.

◆ FillTabs()

void FillTabs | ( | CString & | rstrTextToIns,
 |  | int | nDispCol )

Adds tabs and spaces to specified text until it reaches a specified display column.

Parameters
rstrTextToIns | [in, out] Reference to the text to be added to.
nDispCol | [in] Identifier of the display column to reach.

◆ Find()

BOOL Find | ( | LPCTSTR | szText,
 |  | BOOL | bMatchWholeWord,
 |  | BOOL | bMatchCase,
 |  | BOOL | bSearchDown,
 |  | BOOL | bRedraw = TRUE,
 |  | int | nStartRow = -1,
 |  | int | nStartCol = -1 )

Finds specified text.

Parameters
szText | [in] Pointer to the text to be found.
bMatchWholeWord | [in] TRUE to find text matching the whole word, FALSE otherwise.
bMatchCase | [in] TRUE to find text matching the case, FALSE otherwise.
bSearchDown | [in] TRUE to search downward, FALSE otherwise.
bRedraw | [in] TRUE to redraw the control, FALSE otherwise. The default value of this parameter is TRUE.
nStartRow | [in] Row number to start search. Set this parameter to -1 to start from the current row.
nStartCol | [in] Column number to start search. Set this parameter to -1 to start from the current column.
Returns
TRUE if the text was found, otherwise FALSE.

◆ FindWord()

void FindWord ( UINT nFindWhat )

Searches for the next/previous word position.

Parameters
nFindWhat [in] XTP_EDIT_FINDWORD_NEXT to find the next word, XTP_EDIT_FINDWORD_PREV to find the previous word.

◆ FindWordEx()

BOOL FindWordEx | ( | UINT | nFindWhat,
 |  | int | nTextRow,
 |  | int | nCol,
 |  | XTP_EDIT_LINECOL & | rlcWordStart,
 |  | XTP_EDIT_LINECOL & | rlcWordEnd,
 |  | BOOL & | rbOverSpace )

Searches for the next/previous word position.

Parameters
nFindWhat | [in] XTP_EDIT_FINDWORD_NEXT to find the next word, XTP_EDIT_FINDWORD_PREV to find the previous word.
nTextRow | [in] Row identifier.
nCol | [in] Column identifier (column is one-based).
rlcWordStart | [out] Reference to an XTP_EDIT_LINECOL object to receive the word start position.
rlcWordEnd | [out] Reference to an XTP_EDIT_LINECOL object to receive the word end position.
rbOverSpace | [out] Reference to a BOOL to receive a value of TRUE if the search began on a space character or FALSE if the search began on a tab character.
Returns
TRUE if the word was found, otherwise FALSE.

◆ FindWordEx_str()

BOOL FindWordEx_str | ( | UINT | nFindWhat,
 |  | XTP_EDIT_LINECOL | lcPos_str,
 |  | XTP_EDIT_LINECOL & | rlcWordStart,
 |  | XTP_EDIT_LINECOL & | rlcWordEnd,
 |  | BOOL & | rbOverSpace )

Searches for the next/previous word position.

Parameters
nFindWhat | [in] XTP_EDIT_FINDWORD_NEXT to find the next word, XTP_EDIT_FINDWORD_PREV to find the previous word.
lcPos_str | [in] Text position (column is zero-based).
rlcWordStart | [out] Reference to an XTP_EDIT_LINECOL object to receive the word start position.
rlcWordEnd | [out] Reference to an XTP_EDIT_LINECOL object to receive the word end position.
rbOverSpace | [out] Reference to a BOOL to receive a value of TRUE if the search began on a space character or FALSE if the search began on a tab character.
Returns
TRUE if the word was found, otherwise FALSE.

◆ GetAutoCompleteWnd()

AFX_INLINE CXTPSyntaxEditAutoCompleteWnd * GetAutoCompleteWnd ( ) const

Gets the auto-complete pop-up window.

Returns
A pointer to the auto-complete pop-up window.
See also
CXTPSyntaxEditAutoCompleteWnd

◆ GetAutoIndent()

AFX_INLINE BOOL GetAutoIndent ( ) const

Determines if auto-indentation is enabled/disabled.

Returns
TRUE if auto-indentation is enabled, FALSE if auto-indentation is disabled.
See also
SetAutoIndent

◆ GetAutoscrollDirection()

virtual DWORD GetAutoscrollDirection | ( | int * | pnCols = NULL,
 |  | int * | pnRows = NULL )
 protectedvirtual

Determines the scroll direction for automatic scrolling (when selecting by mouse).

Parameters
pnCols | [out] Pointer to an int to receive the columns count to scroll. May be NULL.
pnRows | [out] Pointer to an int to receive the rows count to scroll. May be NULL.
Returns
Flags from the CXTPSyntaxEditCtrl::XTPScrolDirection enumeration.

◆ GetBlockFromPt()

XTP_EDIT_COLLAPSEDBLOCK * GetBlockFromPt ( const CPoint & ptMouse ) const
protected

Gets the collapsed block, if any, at a specified point.

Parameters
ptMouse [in] Reference to the mouse coordinates to check for a collapsed block.
Returns
A pointer to the XTP_EDIT_COLLAPSEDBLOCK structure, if any, at the specified point, otherwise NULL.
See also
XTP_EDIT_COLLAPSEDBLOCK

◆ GetCollapsableBlocksInfo()

virtual void GetCollapsableBlocksInfo | ( | int | nTextRow,
 |  | CXTPSyntaxEditRowsBlockArray & | rArBlocks ) const
 virtual

Gets the collapsable text blocks of a specified row.

Parameters
nTextRow | [in] Row identifier.
rArBlocks | [out] Reference to a CXTPSyntaxEditRowsBlockArray object to receive the collapsable text blocks.

The default implementation calls CXTPSyntaxEditLexTextSchema::GetCollapsableBlocksInfo. You may override this method and create your own fast implementation.

◆ GetCollapsedBlockLen()

BOOL GetCollapsedBlockLen | ( | int | nStartRow,
 |  | int & | rnLen ) const
 protected

Gets the length of a collapsed block.

Parameters
nStartRow | [in] Start row of the collapsed block.
rnLen | [out] Reference to an int to receive the length of the collapsed block.
Returns
TRUE if successful, otherwise FALSE.

◆ GetCollapsedText()

CString GetCollapsedText | ( | XTP_EDIT_COLLAPSEDBLOCK * | pCoDrawBlk,
 |  | int | nMaxLinesCount = 150 ) const
 protected

Gets the collapsed text of a specified collapsed block.

Parameters
pCoDrawBlk | [in] Pointer to an XTP_EDIT_COLLAPSEDBLOCK structure.
nMaxLinesCount | [in] Maximum lines of text. The default value of this parameter is 150.
Returns
The collapsed text of the specified collapsed block.
See also
XTP_EDIT_COLLAPSEDBLOCK

◆ GetCollapsibleNodes()

AFX_INLINE BOOL GetCollapsibleNodes ( ) const

Determines if the collapsible nodes area is enabled/disabled.

Returns
TRUE if the collapsible nodes area is enabled, FALSE if the collapsible nodes area is disabled.

◆ GetColorScheme()

CString GetColorScheme ( )
inline

Gets the color scheme.

Returns
A string containing the color scheme.

◆ GetConfigFile()

CString GetConfigFile ( ) const

Gets the name of the main configuration file.

Returns
The name of the main configuration file.
See also
CXTPSyntaxEditCtrl::SetConfigFile

◆ GetCurAbsCol()

AFX_INLINE int GetCurAbsCol ( ) const

Gets the absolute column position.

Returns
The absolute column position.

◆ GetCurCol()

AFX_INLINE int GetCurCol ( ) const

Gets the current column.

Returns
The identifier of the current column.

◆ GetCurrentDocumentRow()

int GetCurrentDocumentRow ( ) const
protected

Gets the current document row.

Returns
The identifier of the current document row.
See also
SetCurrentDocumentRow

◆ GetCurrentTheme()

CString GetCurrentTheme ( ) const

Gets the current theme name.

Returns
The current theme name.

◆ GetCurrentVisibleRow()

int GetCurrentVisibleRow ( )
protected

Gets the current visible row.

Returns
The identifier of the current visible row.

◆ GetCurRow()

int GetCurRow ( ) const

Gets the current row.

Returns
The identifier of the current row.

◆ GetDefaultCfgFilePath()

CString GetDefaultCfgFilePath ( )
protected

Gets the default configuration file path.

Returns
The default configuration file path.

◆ GetDocumentRow()

int GetDocumentRow ( int nVisibleRow )
protected

Calculates document row basing in visible row.

Parameters
nVisibleRow [in] Visible row.
Returns
Integer value of document row.
See also
GetCurrentVisibleRow

◆ GetDrawTextProcessor()

CXTPSyntaxEditDrawTextProcessor & GetDrawTextProcessor ( )

Gets the draw text processor.

Returns
A pointer to the draw text processor.

◆ GetEditBuffer()

AFX_INLINE CXTPSyntaxEditBufferManager * GetEditBuffer ( ) const

Gets the buffer manager of the smart edit control.

Returns
A pointer to the buffer manager of the smart edit control.

◆ GetEffectiveParent()

CWnd * GetEffectiveParent ( ) const

Gets the effective parent window.

Returns
A pointer to the effective parent window.

◆ GetHorzScrollBar()

AFX_INLINE BOOL GetHorzScrollBar ( ) const

Determines if the horizontal scrollbar is enabled/disabled.

Returns
TRUE if the horizontal scrollbar is enabled, FALSE if the horizontal scrollbar is disabled.

◆ GetLexConfigurationManager()

CXTPSyntaxEditConfigurationManager * GetLexConfigurationManager ( ) const

Gets the associated configuration manager.

Returns
A pointer to the associated configuration manager.

◆ GetLineMarksManager()

CXTPSyntaxEditLineMarksManager * GetLineMarksManager ( ) const

Gets a pointer to the line marks manager associated with the current text buffer.

Returns
A pointer to the line marks manager associated with the current text buffer.

◆ GetLineNodeRect()

void GetLineNodeRect | ( | int | nDispRow,
 |  | CRect & | rcNode,
 |  | CRect * | prcNodeFull = NULL ) const

Calculates the rectangle(s) for a collapsible node icon.

Parameters
nDispRow | [in] Window row identifier for which to print.
rcNode | [out] Reference to a CRect object to receive the node icon rectangle.
prcNodeFull | [out] Pointer to a CRect object to receive the full node area rectangle.

◆ GetLineNumbers()

AFX_INLINE BOOL GetLineNumbers ( ) const

Determines if line numbering is enabled/disabled.

Returns
TRUE if line numbering is enabled, FALSE if line numbering is disabled.

◆ GetLineText() [1/2]

CString GetLineText | ( | int | nRow,
 |  | BOOL | bAddCRLF = FALSE,
 |  | int | iCRLFStyle = -1 ) const

Gets the text of a specified line.

Parameters
nRow | [in] Row identifier.
bAddCRLF | [in] Specifies how to process the end of text lines. The default value of this parameter is FALSE.
iCRLFStyle | [in] Style of the end of text lines. The default value of this parameter is -1.
Returns
The text of the specified line.

◆ GetLineText() [2/2]

void GetLineText | ( | int | nRow,
 |  | CString & | strBuffer,
 |  | BOOL | bAddCRLF = FALSE,
 |  | int | iCRLFStyle = -1 ) const

Gets the text of a specified line.

Parameters
bAddCRLF | [in] Specifies how to process the end of text lines. The default value of this parameter is FALSE.
iCRLFStyle | [in] Style of the end of text lines. The default value of this parameter is -1.
strBuffer | [out] Reference to the text buffer to receive the text of the specified line.
nRow | [in] Row identifier.

◆ GetModulePath()

static CString AFX_CDECL GetModulePath ( )
static

Gets the path of the executable file module.

Returns
The path of the executable file module.

◆ GetOnScreenSch()

XTPSyntaxEditLexAnalyser::CXTPSyntaxEditLexTextBlock * GetOnScreenSch ( int nForRow )
protected

Gets the screen schema cache.

Parameters
nForRow Row index.
Returns
A pointer to the screen schema cache.

◆ GetPaintManager()

AFX_INLINE CXTPSyntaxEditPaintManager * GetPaintManager ( ) const

Gets the associated paint manager.

Returns
A pointer to the associated paint manager.

◆ GetRedoTextList()

const CStringList & GetRedoTextList ( )

Gets the list of text for redo operations.

Returns
A reference to the list of text for redo operations.

◆ GetRegValues()

BOOL GetRegValues ( )
protected

Reads options from the registry.

Returns
TRUE if successful, otherwise FALSE.

◆ GetRowBkColor()

virtual COLORREF GetRowBkColor ( int nRow ) const
virtual

Gets the background color of a specified row in the colors cache.

Parameters
nRow [in] Row identifier.
Returns
The background color of the specified row in the colors cache.
See also
SetRowBkColor

◆ GetRowColor()

virtual COLORREF GetRowColor ( int nRow ) const
virtual

Gets the text color foreground of a specified row in the colors cache.

Parameters
nRow [in] Row identifier.
Returns
The text color foreground of the specified row in the colors cache.
See also
SetRowColor

◆ GetRowColors()

virtual void GetRowColors | ( | int | nTextRow,
 |  | int | nColFrom,
 |  | int | nColTo,
 |  | const XTP_EDIT_COLORVALUES & | clrDefault,
 |  | CXTPSyntaxEditTextBlockList * | rBlocks )
 virtual

Gets the text colors of a specified row.

Parameters
nTextRow | [in] Row identifier.
nColFrom | [in] Zero-based start column number.
nColTo | [in] Zero-based end column number. A value of -1 indicates the line end.
clrDefault | [in] Constant reference to an XTP_EDIT_COLORVALUES structure containing the default text colors. By default, CXTPSyntaxEditPaintManager::m_clrValues is passed.
rBlocks | [out] Pointer to a CXTPSyntaxEditTextBlockList object to receive the text colors.

The default implementation calls CXTPSyntaxEditLexTextSchema::GetRowColors. You may override this method and create your own fast implementation for the simple colors schemas.

◆ GetRowCount()

int GetRowCount ( ) const

Gets the number of rows in the current document.

Returns
The number of rows in the current document.

◆ GetRowNodes()

BOOL GetRowNodes | ( | int | nRow,
 |  | DWORD & | dwType ) const
 protected

Gets the row node type.

Parameters
nRow | [in] Row identifier.
dwType | [out] Reference to a DWORD to receive the row node type.
Returns
TRUE if successful, otherwise FALSE.

◆ GetRowPerPage()

int GetRowPerPage ( ) const

Gets the number of rows that can be printed per page when using the current settings.

Returns
The number of rows that can be printed per page when using the current settings.

◆ GetScrollBarCtrl()

virtual CScrollBar * GetScrollBarCtrl ( int nBar ) const
virtual

Retrieves a pointer to a specified sibling scroll bar.

Parameters
nBar [in] Type of scrollbar to be retrieved. This parameter can be one of the following values: SB_HORZ: Horizontal scroll bar. SB_VERT: Vertical scrollbar.

This member function does not operate on scroll bars created when the WS_HSCROLL or WS_VSTROLL bits are set during the creation of a window.

The CWnd implementation of this method simply returns NULL.

Derived classes, such as CView, implement the described functionality.

Returns
A pointer to the specified sibling scroll bar, otherwise NULL.

◆ GetScrollInfo()

BOOL GetScrollInfo | ( | int | nBar,
 |  | LPSCROLLINFO | lpScrollInfo,
 |  | UINT | nMask = SIF_ALL )

Retrieves the information of a specified scroll bar.

Parameters
nBar | [in] Specifies if the scroll bar is a control or a part of a window's non-client area. If the scroll bar is a part of the non-client area, then the value of this parameter also indicates if the scroll bar is positioned horizontally, vertically, or both. The value of this parameter must be one of the following: SB_CTL: Contains the parameters for a scroll bar control. The m_hWnd data member must be the handle of the scroll bar control. SB_HORZ: Specifies that the window is a horizontal scroll bar. SB_VERT: Specifies that the window is a vertical scroll bar.
lpScrollInfo | [out] Pointer to a SCROLLINFO structure. See the Platform SDK for more information about this structure.
nMask | [in] Specifies the scroll bar parameters to retrieve. The default specifies a combination of SIF_PAGE, SIF_POS, SIF_TRACKPOS, and SIF_RANGE. See SCROLLINFO for more information on the nMask values.

Call this member function to retrieve the information that the SCROLLINFO structure maintains about a scroll bar. GetScrollInfo enables applications to use 32-bit scroll positions.

The SCROLLINFO structure contains information about a scroll bar, including the minimum and maximum scrolling positions, the page size, and the position of the scroll box (the thumb). See the SCROLLINFO structure topic in the Platform SDK for more information about changing the structure defaults.

The MFC Windows message handlers that indicate scroll-bar position, CWnd::OnHScroll and CWnd::OnVScroll, provide only 16 bits of position data. GetScrollInfo and SetScrollInfo provide 32 bits of scroll-bar position data. Thus, an application can call GetScrollInfo while processing either CWnd::OnHScroll or CWnd::OnVScroll to obtain 32-bit scroll-bar position data.

Returns
TRUE if the message retrieved any values, otherwise FALSE.
See also
SetScrollInfo

◆ GetScrollLimit()

int GetScrollLimit ( int nBar )

Retrieves the scroll limit of a specified scroll bar.

Parameters
nBar [in] Specified the type of scroll bar. The value of this parameter must be one of the following: SB_HORZ: Retrieves the scroll limit of the horizontal scroll bar. SB_VERT: Retrieves the scroll limit of the vertical scroll bar.
Returns
The scroll limit of the specified scrollbar.

◆ GetScrollPos()

int GetScrollPos ( int nBar ) const

Gets the position of a specified scroll box.

Parameters
nBar [in] Specifies the scrollbar to examine. The value of this parameter must be one of the following:

SB_HORZ Retrieves the position of the horizontal scroll bar.

SB_VERT Retrieves the position of the vertical scroll bar.

Returns
The position of the scroll box in the specified scroll bar if successful, otherwise 0.

◆ GetScrollRange()

void GetScrollRange | ( | int | nBar,
 |  | LPINT | lpMinPos,
 |  | LPINT | lpMaxPos ) const

Gets the range of a specified scroll bar.

Parameters
nBar [in] Specifies the scrollbar to examine. The value of this parameter must be one of the following:

SB_HORZ Retrieves the position of the horizontal scroll bar.

SB_VERT Retrieves the position of the vertical scroll bar.

Parameters
lpMinPos | [in] Pointer to an int to receive the minimum position.
lpMaxPos | [in] Pointer to an int to receive the maximum position.

◆ GetSelection()

CXTPSyntaxEditSelection & GetSelection ( )

Gets the current selection.

Returns
A reference to the current selection.
See also
CXTPSyntaxEditSelection

◆ GetSelectionBuffer()

HGLOBAL GetSelectionBuffer ( UINT nFormat )

Gets the handle of the selection buffer in global memory for a specified clipboard format (either CF_TEXT or CF_UNICODETEXT).

Parameters
nFormat [in] Clipboard format (either CF_TEXT or CF_UNICODETEXT).

This method is used mainly in OLE drag drop operations.

Returns
The handle of the selection buffer in global memory for the specified clipboard format (either CF_TEXT or CF_UNICODETEXT).

◆ GetSelectionText()

int GetSelectionText ( CString & strText )

Gets the selected text.

Parameters
strText [out] Reference to a CString object to receive the selected text.
Returns
The number of characters in the selected text.

◆ GetSelMargin()

AFX_INLINE BOOL GetSelMargin ( ) const

Determines if the gutter is enabled/disabled.

Returns
TRUE if the gutter is enabled, FALSE if the gutter is disabled.
See also
SetSelMargin

◆ GetSyntaxColor()

AFX_INLINE BOOL GetSyntaxColor ( ) const

Determines if syntax colorization is enabled/disabled.

Returns
TRUE if syntax colorization is enabled, otherwise FALSE.
See also
SetSyntaxColor

◆ GetSyntaxScheme()

CString GetSyntaxScheme ( )
inline

Gets the syntax scheme.

Returns
A string containing the syntax scheme.

◆ GetTabSize()

int GetTabSize ( ) const

Gets the tab size.

Returns
The tab size.
See also
SetTabSize

◆ GetTabWithSpace()

AFX_INLINE BOOL GetTabWithSpace ( ) const

Determines if replacing tabs with spaces is enabled/disabled.

Returns
TRUE if replacing tabs with spaces is enabled, FALSE if replacing tabs with spaces is disabled.
See also
SetTabWithSpace

◆ GetText() [1/2]

BOOL GetText | ( | CMemFile & | memFile,
 |  | int | nMaxLen = -1 ) const

Gets the editor text.

Parameters
nMaxLen | [in] Maximum text length to get (in TCHARs). Set this parameter to -1 to get all text. The default value for this parameter is -1.
memFile | [out] Reference to a CMemFile object to receive the text.

CWnd::GetWindowText can also be used to get the editor text.

Returns
The first function returns the editor text if successful, otherwise an empty string. The second function returns TRUE if successful, otherwise FALSE.
See also
SetText, CWnd::SetWindowText

◆ GetText() [2/2]

CString GetText ( int nMaxLen = -1 ) const

Gets the editor text.

Parameters
nMaxLen [in] Maximum text length to get (in TCHARs). Set this parameter to -1 to get all text. The default value for this parameter is -1.

CWnd::GetWindowText can also be used to get the editor text.

Returns
The first function returns the editor text if successful, otherwise an empty string. The second function returns TRUE if successful, otherwise FALSE.
See also
SetText, CWnd::SetWindowText

◆ GetThemes()

CStringArray & GetThemes ( )

Gets the array of available theme names.

Returns
A reference to the array of available theme names.

◆ GetTopRow()

AFX_INLINE int GetTopRow ( ) const

Gets the identifier of the top row of the visible window.

Returns
The identifier of the top row of the visible window.
See also
SetTopRow

◆ GetUndoTextList()

const CStringList & GetUndoTextList ( )

Gets the list of text for undo operations.

Returns
A reference to the list of text for undo operations.

◆ GetVertScrollBar()

AFX_INLINE BOOL GetVertScrollBar ( ) const

Determines if the vertical scrollbar is enabled/disabled.

Returns
TRUE if the vertical scrollbar is enabled, FALSE if the vertical scrollbar is disabled.

◆ GetVisibleRow()

int GetVisibleRow ( int nDocumentRow )
protected

Calculates visible row basing in document row.

Parameters
nDocumentRow [in] Document row.
Returns
Integer value of visible row.

◆ GetVisibleRowsCount()

int GetVisibleRowsCount ( int nMaxDocRow = -1 )
protected

Gets the maximum number of visible rows.

Parameters
nMaxDocRow [in] Maximum document row up to which to calculate the visible rows. If a value of -1 is passed, then the visible rows will be calculated until the end of the document. The default value of this parameter is -1.
Returns
The maximum number of visible rows.

◆ GetWideCaret()

BOOL GetWideCaret ( ) const

Determines if thin caret is set for overwrite mode.

Returns
TRUE if thin caret is set for overwrite mode, FALSE if wide caret is set for overwrite mode.

◆ GoToRow()

void GoToRow | ( | int | iRow,
 |  | BOOL | bSelectRow = FALSE )

Moves to a specified row.

Parameters
iRow | [in] Row index.
bSelectRow | [in] TRUE to select row, FALSE otherwise.

◆ HandleDrop()

void HandleDrop ( BOOL bCopy )

Handles the drop operation within the same edit buffer.

Parameters
bCopy [in] TRUE if drag is to copy, FALSE to specify a move.

◆ HasBookmarks()

BOOL HasBookmarks ( ) const

Determines if the current document has bookmarks.

Returns
TRUE if the current document has bookmarks, otherwise FALSE.

◆ HasBreakpoints()

BOOL HasBreakpoints ( ) const

Determines if the current document has breakpoints.

Returns
TRUE if the current document has breakpoints, otherwise FALSE.

◆ HasRowMark()

BOOL HasRowMark | ( | int | nRow,
 |  | const XTP_EDIT_LINEMARKTYPE & | lmType,
 |  | XTP_EDIT_LMPARAM * | pParam = NULL ) const

Determines if a specified row has a specified mark.

Parameters
nRow | [in] Row identifier in document coordinates.
lmType | [in] Mark type identifier.
pParam | [in] Pointer to XTP_EDIT_LMPARAM. The default value for this parameter is NULL.
Returns
TRUE if the specified row has the specified mark, otherwise FALSE.
See also
XTP_EDIT_LINEMARKTYPE, XTP_EDIT_LMPARAM

◆ IncreaseIndent()

BOOL IncreaseIndent ( )

Inserts a tab to the front of the selection.

Returns
TRUE if successful, otherwise FALSE.

◆ InsertRow()

void InsertRow | ( | int | nRow,
 |  | LPCTSTR | pcszText,
 |  | BOOL | bCanUndo )

Inserts a new row.

Parameters
nRow | [in] Row identifier to insert at.
pcszText | [in] New row text.
bCanUndo | [in] TRUE if this can be undone, FALSE otherwise.

The parser is notified to reparse the changed text.

◆ InsertString()

void InsertString | ( | LPCTSTR | szText,
 |  | int | iRow,
 |  | int | iCol,
 |  | BOOL | bDeleteSelection = TRUE )

Inserts either a string or a vertical text block at a specified row and column.

Parameters
szText | [in] Pointer to the string to be inserted.
iRow | [in] Row identifier.
iCol | [in] Column identifier.
bDeleteSelection | [in] TRUE to delete the selected text at insertion, FALSE otherwise. The default value for this parameter is TRUE.

◆ InsertTextBlock()

void InsertTextBlock | ( | LPCTSTR | szText,
 |  | int | iRow,
 |  | int | iCol,
 |  | BOOL | bDeleteSelection = TRUE )

Inserts either a string or a vertical text block at a specified row and column.

Parameters
szText | [in] Pointer to the string to be inserted.
iRow | [in] Row identifier.
iCol | [in] Column identifier.
bDeleteSelection | [in] TRUE to delete the selected text at insertion, FALSE otherwise. The default value for this parameter is TRUE.

◆ InvalidateRow()

AFX_INLINE void InvalidateRow ( int nRow )

Invalidates a specified row.

Parameters
nRow [in] Row identifier in document coordinates.

◆ InvalidateRows()

void InvalidateRows | ( | int | nRowFrom = -1,
 |  | int | nRowTo = -1 )

Invalidates a specified set of rows.

Parameters
nRowFrom | [in] First row identifier in document coordinates.
nRowTo | [in] Last row identifier in document coordinates.

◆ IsActive()

AFX_INLINE BOOL IsActive ( ) const

Determines if the edit control is actived/deactivated.

Returns
TRUE if the edit control is actived, FALSE if the edit control is deactivated.

◆ IsConfigFileMode()

BOOL IsConfigFileMode ( )
inline

Gets the config file mode.

Returns
A boolean value that specifies the current config file mode.

◆ IsCreateScrollbarOnParent()

AFX_INLINE BOOL IsCreateScrollbarOnParent ( ) const

Determines if scroll bars are created in the parent window.

Returns
TRUE if scroll bars are created in the parent window, otherwise FALSE.

◆ IsEnabledEditAccelerators()

AFX_INLINE BOOL IsEnabledEditAccelerators ( ) const

Determines if editor accelerators are enabled/disabled.

Standard editor accelerators include: Ctrl+C, Ctrl+V, Ctrl+X, Ctrl+Y, Ctrl+Z, Ctrl+Shift+Z, Ctrl+A, Ctrl+Ins, Shift+Ins, Alt+Backspace.

You can support any of these editing operations externally by calling member functions.

By default, this feature is disabled.

Returns
TRUE if editor accelerators are enabled, FALSE if editor accelerators are disabled.

◆ IsEnabledVirtualSpace()

AFX_INLINE BOOL IsEnabledVirtualSpace ( ) const

Determines if virtual space mode is enabled/disabled.

Returns
TRUE if virtual space mode is enabled, FALSE if virtual space mode is disabled.
See also
EnableVirtualSpace

◆ IsEnabledWhiteSpace()

AFX_INLINE BOOL IsEnabledWhiteSpace ( ) const

Determines if showing white space is enabled/disabled.

Returns
TRUE if showing white space is enabled, FALSE if showing white space is disabled.
See also
EnableWhiteSpace

◆ IsHideCaret()

AFX_INLINE BOOL IsHideCaret ( ) const

Determines if the caret is hidden/visible.

Returns
TRUE if the caret is hidden, FALSE if the caret is visible.

◆ IsReadOnly()

AFX_INLINE BOOL IsReadOnly ( ) const

Gets if the editor is in read-only mode.

Returns
TRUE if the editor is in read-only mode, otherwise FALSE.

◆ IsRightButtonDrag()

AFX_INLINE BOOL IsRightButtonDrag ( ) const

Determines if mouse right button drag is enabled/disabled.

Returns
TRUE if mouse right button drag is enabled, FALSE if mouse right button drag is disabled.
See also
SetRightButtonDrag, CancelRightButtonDrag

◆ IsRowValid()

BOOL IsRowValid ( int nDispRow ) const

Determines if a specified row is valid.

Parameters
nDispRow [in] Row identifier in document coordinates.
Returns
TRUE if the specified row is valid, otherwise FALSE.
See also
SetRowValid

◆ IsRowVisible()

BOOL IsRowVisible ( int iRow ) const

Determines if a specified row is visible.

Parameters
iRow [in] Document row number to be tested.
Returns
TRUE if the specified row is visible, otherwise FALSE.

◆ IsSelectionExist()

BOOL IsSelectionExist ( ) const

Determines if the selection exists.

Returns
TRUE if the selection exists, otherwise FALSE.

◆ IsViewOnly()

AFX_INLINE BOOL IsViewOnly ( ) const

Gets if the editor is in view-only mode.

View-only mode is the same as read-only except with a normal background, no cursor (caret), no selectable text, and no copy/paste.

Returns
TRUE if the edit is in view-only mode, otherwise FALSE.

◆ LowercaseSelection()

BOOL LowercaseSelection ( )

Converts the selected text to lowercase.

Returns
TRUE if successful, otherwise FALSE.

◆ MatchText()

BOOL MatchText | ( | int | nRow,
 |  | LPCTSTR | szLineText,
 |  | LPCTSTR | szMatchText,
 |  | int | nStartPos,
 |  | BOOL | bMatchWholeWord,
 |  | BOOL | bMatchCase,
 |  | BOOL | bSearchForward,
 |  | BOOL | bRedraw = TRUE )

Attempts to match text using the specified parameters.

Parameters
nRow | [in] Row to match for.
szLineText | [in] Line text.
szMatchText | [in] Text to be matched.
nStartPos | [in] Start position.
bMatchWholeWord | [in] TRUE to match whole words, FALSE otherwise.
bMatchCase | [in] TRUE to match case, FALSE otherwise.
bSearchForward | [in] TRUE to search forward, FALSE otherwise.
bRedraw | [in] TRUE to redraw the control after the search, FALSE otherwise.
Returns
TRUE if successful, otherwise FALSE.

◆ MoveCurrentVisibleRowDown()

int MoveCurrentVisibleRowDown ( int nCount )
protected

Moves the current row down a specified number of rows.

Parameters
nCount [in] Number of rows.
Returns
The identifier of the current visible row.

◆ MoveCurrentVisibleRowUp()

int MoveCurrentVisibleRowUp ( int nCount )
protected

Moves the current row up a specified number of rows.

Parameters
nCount [in] Number of rows.
Returns
The identifier of the current visible row.

◆ NotifyCurRowCol()

void NotifyCurRowCol | ( | int | nRow,
 |  | int | nCol ) const

Sends a notification when the current text position is changed.

Parameters
nRow | [in] Row to be notified (in document coordinates).
nCol | [in] Column to be notified.

◆ NotifyEditChanged()

void NotifyEditChanged | ( | int | iRowFrom,
 |  | int | iRowTo,
 |  | UINT | nActions )

Sends an XTP_EDIT_NM_EDITCHANGED notification with specified parameters.

Parameters
iRowFrom | [in] Start row identifier.
iRowTo | [in] End row identifier.
nActions | [in] Action mask.

◆ NotifyMarginLBtnClick()

virtual BOOL NotifyMarginLBtnClick | ( | int | nRow,
 |  | int | nDispRow ) const
 virtual

Notifies the parent that the user clicked in the bookmark area.

Parameters
nRow | [in] Document row.
nDispRow | [in] Visible row.
Returns
TRUE if the action was handled, otherwise FALSE.

◆ NotifyMouseEvent()

virtual LRESULT NotifyMouseEvent | ( | UINT | uCode,
 |  | UINT | nFlags,
 |  | const CPoint & | point ) const
 virtual

Sends any mouse notifications to the parent.

Parameters
uCode | [in] Mouse notification code (e.g. XTP_EDIT_NM_LBUTTONDOWN).
nFlags | [in] Mouse event flags.
point | [in] Reference to the mouse event cursor position.
Returns
The LRESULT value returned by the parent notification handler.
See also
XTP_EDIT_NM_LBUTTONDOWN, XTP_EDIT_NM_LBUTTONDBLCLICK, XTP_EDIT_NM_LBUTTONUP, XTP_EDIT_NM_RBUTTONDOWN, XTP_EDIT_NM_RBUTTONUP, XTP_EDIT_NM_MOUSEMOVE.

◆ NotifyParent()

virtual LRESULT NotifyParent ( UINT uCode ) const
virtual

Sends any notifications to the parent.

Parameters
uCode [in] Notification code.
Returns
The LRESULT value returned by the parent notification handler.

◆ NotifyParseEvent()

BOOL NotifyParseEvent | ( | XTP_NOTIFY_CODE | code,
 |  | WPARAM | wParam,
 |  | LPARAM | lParam )
 protected

Sends a WM_NOTIFY message with an XTP_EDIT_NM_PARSEEVENT code to the parent window.

Parameters
code | [in] Event code from the XTPSyntaxEditOnParseEvent enumeration.
wParam | [in] Event parameter 1.
lParam | [in] Event parameter 2.
Returns
TRUE if the operation was successful, otherwise FALSE.
See also
XTPSyntaxEditOnParseEvent

◆ OnBeforeEditChanged()

void OnBeforeEditChanged | ( | int | nRow,
 |  | int | nCol )
 protected

Internal editing event handler.

Parameters
nRow | [in] Row identifier.
nCol | [in] Column identifier.

◆ OnEditChanged() [1/2]

void OnEditChanged | ( | const XTP_EDIT_LINECOL & | LCFrom,
 |  | const XTP_EDIT_LINECOL & | LCTo,
 |  | int | eEditAction )
 protected

Internal editing event handler.

Parameters
LCFrom | [in] Start coordinates.
LCTo | [in] End coordinates.
eEditAction | [in] Action identifier.
See also
XTP_EDIT_LINECOL

◆ OnEditChanged() [2/2]

void OnEditChanged | ( | int | nRowFrom,
 |  | int | nColFrom,
 |  | int | nRowTo,
 |  | int | nColTo,
 |  | int | eEditAction )
 protected

Internal editing event handler.

Parameters
nRowFrom | [in] Start row identifier.
nColFrom | [in] Start column identifier.
nRowTo | [in] End row identifier.
nColTo | [in] End column identifier.
eEditAction | [in] Action identifier.

◆ OnLexCfgWasChanged()

void OnLexCfgWasChanged | ( | XTP_NOTIFY_CODE | code,
 |  | WPARAM | wParam,
 |  | LPARAM | lParam )
 protected

Internal editing event handler.

Parameters
code | [in] Event code from the XTPSyntaxEditOnCfgChangedEvent enumeration.
wParam | [in] Event parameter 1.
lParam | [in] Event parameter 2.
See also
XTPSyntaxEditOnCfgChangedEvent

◆ OnParseEvent()

void OnParseEvent | ( | XTP_NOTIFY_CODE | code,
 |  | WPARAM | wParam,
 |  | LPARAM | lParam )
 protected

Internal editing event handler.

Parameters
code | [in] Event code.
wParam | [in] Event parameter 1.
lParam | [in] Event parameter 2.
See also
XTP_NOTIFY_CODE

◆ operator=()

const CXTPSyntaxEditCtrl & operator= ( const CXTPSyntaxEditCtrl & src )

Copies the control settings from a specified control.

Parameters
src Reference to a CXTPSyntaxEditCtrl object to copy from.
Returns
A reference to this CXTPSyntaxEditCtrl object.

◆ PrintPage()

virtual int PrintPage | ( | CDC * | pDC,
 |  | const CRect & | rcRect,
 |  | int | nFlags = 0 )
 virtual

Prints the edit control page.

Parameters
pDC | [in] Pointer to a CDC object.
rcRect | [in] Reference to a CRect object.
nFlags | [in] Additional printing options. The following are supported: DT_CALCRECT, DT_SINGLELINE, DT_WORDBREAK

The top row is used as the first page line.

Returns
The number of printed rows.
See also
Draw

◆ ProcessCollapsedBlockDblClick()

int ProcessCollapsedBlockDblClick ( const CPoint & ptMouse )
protected

Expands a collapsed block if it is double clicked.

Parameters
ptMouse [in] Reference to the mouse coordinates to check for a collapsed block.
Returns
The number of rows that the collapsed block was expanded, otherwise 0 if the collapsed block was not expanded.
See also
CXTPSyntaxEditToolTipCtrl

◆ ProcessCollapsedText()

void ProcessCollapsedText | ( | CDC * | pDC,
 |  | XTP_EDIT_COLLAPSEDBLOCK * | pCoDrawBlk,
 |  | CRect & | rcCoBlk )
 protected

Calculates the collapsed text sign rectangle (like for [..]).

Parameters
pDC | [in] Pointer to a CDC object.
pCoDrawBlk | [in] Pointer to an XTP_EDIT_COLLAPSEDBLOCK structure.
rcCoBlk | [in, out] Reference to a rectangle with a collapsed block text area. The right border is updated by this function.
See also
XTP_EDIT_COLLAPSEDBLOCK

◆ ProcessCollapsedTextEx()

BOOL ProcessCollapsedTextEx | ( | CDC * | pDC,
 |  | XTP_EDIT_COLLAPSEDBLOCK * | pCoDrawBlk,
 |  | const XTP_EDIT_TEXTBLOCK & | txtBlk,
 |  | CRect & | rcCoBlk )
 protected

Performs the same functionality as ProcessCollapsedText, but has additional checks for input parameters.

Parameters
pDC | [in] Pointer to a CDC object.
pCoDrawBlk | [in] Pointer to an XTP_EDIT_COLLAPSEDBLOCK structure.
txtBlk | [in] Pointer to an XTP_EDIT_TEXTBLOCK structure.
rcCoBlk | [in, out] Reference to a rectangle with a collapsed block text area. The right border is updated by this function.
Returns
TRUE if the operation was successful, otherwise FALSE.
See also
XTP_EDIT_COLLAPSEDBLOCK, XTP_EDIT_TEXTBLOCK

◆ Redo()

BOOL Redo ( int nActionsCount = 1 )

Performs a redo operation.

Parameters
nActionsCount [in] Number of actions to redo simultaneously.
Returns
TRUE if successful, otherwise FALSE.
See also
CanRedo

◆ RefreshColors()

virtual void RefreshColors ( )
virtual

Refreshes the colors for the current document.

Refreshing colors causes configuration files to be reread and the current document to be reparsed.

◆ RefreshLineMarks()

virtual void RefreshLineMarks ( XTP_EDIT_NMHDR_EDITCHANGED * pEditChanged )
protectedvirtual

Refreshes line marks depending on the change type.

Parameters
pEditChanged [in] Pointer to an XTP_EDIT_NMHDR_EDITCHANGED structure.
See also
LPXTP_EDIT_NMHDR_EDITCHANGED

◆ RegisterWindowClass()

BOOL RegisterWindowClass ( HINSTANCE hInstance = NULL )
protected

Registers the window class if it has not already been registered.

Parameters
hInstance Instance of the resource where the control is located.
Returns
TRUE if the window class was successfully registered, otherwise FALSE.

◆ RemoveRow()

void RemoveRow | ( | int | nRow,
 |  | BOOL | bCanUndo )

Removes a specified row.

Parameters
nRow | [in] Row identifier.
bCanUndo | [in] TRUE if this can be undone, otherwise FALSE.

The parser is notified to reparse the changed text.

◆ ReplaceAll()

int ReplaceAll | ( | LPCTSTR | szFindText,
 |  | LPCTSTR | szReplaceText,
 |  | BOOL | bMatchWholeWord,
 |  | BOOL | bMatchCase )

Replaces all occurrences of szFindText with szReplaceText.

Parameters
szFindText | [in] Pointer to the text to find.
szReplaceText | [in] Pointer to the text to be replaced.
bMatchWholeWord | [in] TRUE to match whole word, FALSE otherwise.
bMatchCase | [in] TRUE to match case, FALSE otherwise.
Returns
The number of found matches.

◆ ReplaceSel()

BOOL ReplaceSel ( LPCTSTR szNewText )

Replaces the selected text with specified text.

Parameters
szNewText [in] Text to be used to replace the selected text.
Returns
TRUE if the selected text was replaced, otherwise FALSE.

◆ RepositionBars()

void RepositionBars | ( | UINT | nIDFirst,
 |  | UINT | nIDLast,
 |  | UINT | nIDLeftOver,
 |  | UINT | nFlag = CWnd::reposDefault,
 |  | LPRECT | lpRectParam = NULL,
 |  | LPCRECT | lpRectClient = NULL,
 |  | BOOL | bStretch = TRUE )

Repositions and resizes control bars in the client area of a window.

Parameters
nIDFirst | [in] Indentifer of the first in a range of control bars to reposition and resize.
nIDLast | [in] Identifier of the last in a range of control bars to reposition and resize.
nIDLeftOver | [in] Identifier of the pane to fill the rest of the client area.
nFlag | [in] This parameter can be one of the following values: CWnd::reposDefault: Performs the layout of the control bars. lpRectParam is not used and can be NULL. CWnd::reposQuery: The layout of the control bars is not done. Instead, lpRectParam is initialized with the size of the client area as if the layout had actually been done. CWnd::reposExtra: Adds the values of lpRectParam to the client area of nIDLast and also performs the layout.
lpRectParam | [in] Pointer to a RECT structure. The usage of this structure depends on the value of nFlag.
lpRectClient | [in] Pointer to a RECT structure containing the available client area. If NULL, then the window's client area will be used.
bStretch | [in] TRUE to stretch the bar to the size of the frame, FALSE otherwise.

The nIDFirst and nIDLast parameters define a range of control bar identifiers to be repositioned in the client area.

The nIDLeftOver parameter specifies the identifier of the child window (normally the view) which is repositioned and resized to fill the rest of the client area that is not filled by control bars.

◆ RestoreCursor()

void RestoreCursor ( )

Restores the cursor.

This method is mainly used when changing the font.

◆ RowColFromPoint()

BOOL RowColFromPoint | ( | CPoint | pt,
 |  | int * | pRow,
 |  | int * | pCol,
 |  | int * | pDispRow = NULL,
 |  | int * | pDispCol = NULL,
 |  | BOOL | bVirtualSpace = -1 )

Gets the row and column (not validated) at a specified point.

Use CalcValidDispCol for validation.

Parameters
pt | [in] Point in client coordinates.
pRow | [out] Pointer to an int to receive the calculated row.
pCol | [out] Pointer to an int to receive the calculated column.
pDispRow | [out] Pointer to an int to receive the visible row.
pDispCol | [out] Pointer to an int to receive the visible column.
bVirtualSpace | [in] TRUE if virtual space is enabled, otherwise FALSE.
Returns
TRUE if successful, otherwise FALSE.

◆ Scroll()

void Scroll | ( | int | xPos,
 |  | int | yPos )

Scrolls the window by the specified offsets along the x- and y- axes.

Parameters
yPos | [in] Scroll vertically in rows.
xPos | [in] Scroll Horizontally in columns.

◆ ScrollWindow()

void ScrollWindow | ( | int | xAmount,
 |  | int | yAmount,
 |  | LPCRECT | lpRect = NULL,
 |  | LPCRECT | lpClipRect = NULL )

Scrolls the specified client area.

Parameters
xAmount | [in] Specifies the amount, in device units, of horizontal scrolling. This parameter must be a negative value to scroll to the left.
yAmount | [in] Specifies the amount, in device units, of vertical scrolling. This parameter must be a negative value to scroll up.
lpRect | [in] Points to a CRect object or RECT structure that specifies the portion of the client area to be scrolled. If lpRect is NULL, the entire client area is scrolled. The caret is repositioned if the cursor rectangle intersects the scroll rectangle.
lpClipRect | [in] Points to a CRect object or RECT structure that specifies the clipping rectangle to scroll. Only bits inside this rectangle are scrolled. Bits outside this rectangle are not affected even if they are in the lpRect rectangle. If lpClipRect is NULL, no clipping is performed on the scroll rectangle.

◆ ScrollWindowEx()

int ScrollWindowEx | ( | int | dx,
 |  | int | dy,
 |  | LPCRECT | lpRectScroll,
 |  | LPCRECT | lpRectClip,
 |  | CRgn * | prgnUpdate,
 |  | LPRECT | lpRectUpdate,
 |  | UINT | flags )

Scrolls the specified client area with additional features.

Parameters
dx | [in] Specifies the amount, in device units, of horizontal scrolling. This parameter must have a negative value to scroll to the left.
dy | [in] Specifies the amount, in device units, of vertical scrolling. This parameter must have a negative value to scroll up.
lpRectScroll | [in] Points to a RECT structure that specifies the portion of the client area to be scrolled. If this parameter is NULL, the entire client area is scrolled.
lpRectClip | [in] Points to a RECT structure that specifies the clipping rectangle to scroll. This structure takes precedence over the rectangle pointed to by lpRectScroll. Only bits inside this rectangle are scrolled. Bits outside this rectangle are not affected even if they are in the lpRectScroll rectangle. If this parameter is NULL, no clipping is performed on the scroll rectangle.
prgnUpdate | [in] Identifies the region that is modified to hold the region invalidated by scrolling. This parameter may be NULL.
lpRectUpdate | [out] Points to a RECT structure that will receive the boundaries of the rectangle invalidated by scrolling. This parameter may be NULL.
flags | [in] Can have one of the following values: SW_ERASE: When specified with SW_INVALIDATE, erases the newly invalidated region by sending a WM_ERASEBKGND message to the window. SW_INVALIDATE: Invalidates the region identified by prgnUpdate after scrolling. SW_SCROLLCHILDREN: Scrolls all child windows that intersect the rectangle pointed to by lpRectScroll by the number of pixels specified in dx and dy. Windows sends a WM_MOVE message to all child windows that intersect lpRectScroll, even if they do not move. The caret is repositioned when a child window is scrolled and the cursor rectangle intersects the scroll rectangle.
Returns
If the function succeeds, then the return value is SIMPLEREGION (rectangular invalidated region), COMPLEXREGION (nonrectangular invalidated region; overlapping rectangles), or NULLREGION (no invalidated region).

If the function fails, then the return value is ERROR. To get extended error information, call GetLastError.

◆ Select()

BOOL Select | ( | int | nRow1,
 |  | int | nDispCol1,
 |  | int | nRow2,
 |  | int | nDispCol2,
 |  | BOOL | bRedraw = TRUE )

Selects the text bounded by a specified rectangle area.

Parameters
nRow1 | Start row of the text.
nDispCol1 | Start visible column (character) of the text.
nRow2 | End row of the text.
nDispCol2 | End visible column (character) of the text.
bRedraw | TRUE to redraw the control, FALSE otherwise. The default value of this parameter is TRUE.
Returns
TRUE if the text was found, otherwise FALSE.

◆ SelectWord()

void SelectWord ( CPoint point )

Selects the word at a specified point.

Parameters
point [in] Point.

◆ SetActive()

virtual void SetActive ( BOOL bIsActive )
virtual

Activates/deactives the edit control.

Parameters
bIsActive TRUE to activate the edit control, FALSE to deactivate the edit control.

◆ SetAutoIndent()

BOOL SetAutoIndent | ( | BOOL | bAutoIndent,
 |  | BOOL | bUpdateReg = FALSE )

Enables/disables auto-indentation.

Parameters
bAutoIndent | [in] TRUE to enable auto-indentation, FALSE to disable auto-indentation.
bUpdateReg | [in] TRUE to update this setting in the registry, FALSE otherwise. By default, this parameter is FALSE.
Returns
TRUE if the operation was successful, otherwise FALSE.
See also
GetAutoIndent

◆ SetCollapsibleNodes()

void SetCollapsibleNodes | ( | BOOL | bDrawNodes,
 |  | BOOL | bUpdateReg = FALSE )

Enables/disables the collapsible nodes area.

Parameters
bDrawNodes | [in] TRUE to enable the collapsible nodes area, FALSE to disable the collapsible nodes area.
bUpdateReg | [in] TRUE to update this setting in the registry, FALSE otherwise. By default, this parameter is FALSE.

◆ SetConfigFile()

BOOL SetConfigFile | ( | LPCTSTR | szPath,
 |  | BOOL | bConfigFileMode = TRUE )

Sets the the path to the main configuration file.

Parameters
szPath | [in] Path to be set.
bConfigFileMode | [in] Flag for configuration file mode.

The configuration will be reloaded.

Returns
TRUE if the path was found, otherwise FALSE.
See also
CXTPSyntaxEditCtrl::GetConfigFile

◆ SetCreateScrollbarOnParent()

AFX_INLINE void SetCreateScrollbarOnParent ( BOOL nSet )

Sets if scroll bars should be created in the parent window.

Parameters
nSet TRUE to create scroll bars in the parent window, FALSE otherwise.

◆ SetCurCaretPos()

void SetCurCaretPos | ( | int | nTextRow,
 |  | int | nDispCol,
 |  | BOOL | bRowColNotify = TRUE,
 |  | BOOL | bEnsureVisible = TRUE )

Sets the current caret position to a specified row and column.

Parameters
nTextRow | [in] Row number for the current caret position.
nDispCol | [in] Column number for the current caret position.
bRowColNotify | [in] TRUE to send an XTP_EDIT_NM_ROWCOLCHANGED notification, FALSE otherwise.
bEnsureVisible | [in] TRUE to ensure the visibility of the specified row and column, FALSE otherwise.

◆ SetCurPos()

void SetCurPos | ( | int | nTextRow,
 |  | int | nDispCol,
 |  | BOOL | bRemainSelected = FALSE,
 |  | BOOL | bForceVisible = TRUE )

Sets the current cursor position to a specified row and column.

Parameters
nTextRow | [in] Row to be set in document coordinates.
nDispCol | [in] Column to be set in document coordinates.
bRemainSelected | [in] TRUE for the selected text to remain selected, FALSE for the selected text to be deselected.
bForceVisible | [in] TRUE to ensure the visibility of the specified row and column, FALSE otherwise.
See also
GetCurCol, GetCurRow

◆ SetCurrentDocumentRow()

void SetCurrentDocumentRow ( int nRow )
protected

Sets the current document row.

Parameters
nRow [in] Row identifier.
See also
GetCurrentDocumentRow

◆ SetDocModified()

void SetDocModified ( BOOL bModified = TRUE )
protected

Sets the modification flag for the currently opened document.

Parameters
bModified [in] TRUE to set the modification flag to modified, FALSE otherwise. The default value of this parameter is TRUE.

◆ SetDropPos()

void SetDropPos | ( | int | iRow,
 |  | int | iCol )

Sets the drop position.

Parameters
iRow | [in] Row of the drop position.
iCol | [in] Column of the drop position.
See also
CXTPSyntaxEditView

◆ SetFontIndirect()

void SetFontIndirect | ( | LPLOGFONT | pLogfont,
 |  | BOOL | bUpdateReg = FALSE )

Sets the font for the edit control.

Parameters
pLogfont | [in] Pointer to a LOGFONT structure.
bUpdateReg | [in] TRUE to update this setting in the registry, FALSE otherwise. By default, this parameter is FALSE.

◆ SetHideCaret()

AFX_INLINE void SetHideCaret ( BOOL bHide )

Hides/shows the caret.

Parameters
bHide TRUE to hide the caret, FALSE to show the caret.

It may be useful to hide the caret in read-only mode.

◆ SetLineNumbers()

BOOL SetLineNumbers | ( | BOOL | bLineNumbers,
 |  | BOOL | bUpdateReg = FALSE )

Enables/disables line numbering.

Parameters
bLineNumbers | [in] TRUE to enable line numbering, FALSE to disable line numbering.
bUpdateReg | [in] TRUE to update this setting in the registry, FALSE otherwise. By default, this parameter is FALSE.
Returns
True to enable line numbering, False to disable

◆ SetOverwriteMode()

void SetOverwriteMode ( BOOL bOverwriteMode )

Enables/disables overwrite mode.

Parameters
bOverwriteMode [in] TRUE to enable overwrite mode, FALSE to disable overwrite mode.

◆ SetPaintManager()

virtual void SetPaintManager ( CXTPSyntaxEditPaintManager * pPaintManager )
virtual

Sets the associated paint manager.

Parameters
pPaintManager [in] Pointer to a CXTPSyntaxEditPaintManager object.

◆ SetPassedIniSet()

void SetPassedIniSet ( CString sPassedIniSet )
inline

Sets the passed ini set.

Parameters
sPassedIniSet Passed ini set to be set.

◆ SetReadOnly()

AFX_INLINE void SetReadOnly ( BOOL bReadOnly = TRUE )
virtual

Sets if the editor should be in read-only mode.

Parameters
bReadOnly TRUE to set the editor to read-only mode, FALSE otherwise.

◆ SetRightButtonDrag()

AFX_INLINE void SetRightButtonDrag ( BOOL bRightButtonDrag = TRUE )

Sets right mouse button for dragging.

Parameters
bRightButtonDrag [in] Boolean state flag of right button drag mode.

Mainly used by CXTPSyntaxEditView for setting right button drag mode. If parameter is TRUE function sets right button for dragging, otherwise dragging mode is disabled for right mouse button.

See also
void CancelRightButtonDrag(), BOOL IsRightButtonDrag()

◆ SetRowBkColor()

void SetRowBkColor | ( | int | nRow,
 |  | COLORREF | crBack )

Sets the background color of a specified row in the colors cache.

Parameters
nRow | [in] Row identifier.
crBack | [in] Background color to be set.
See also
GetRowBkColor

◆ SetRowColor()

void SetRowColor | ( | int | nRow,
 |  | COLORREF | clrFront )

Sets the text color foreground for a specified row in the colors cache.

Parameters
nRow | [in] Row identifier.
clrFront | [in] Text color foreground to be set.
See also
GetRowColor

◆ SetRowText()

void SetRowText | ( | int | nRow,
 |  | LPCTSTR | pcszText,
 |  | BOOL | bCanUndo )

Sets the text value for a specified row.

Parameters
nRow | [in] Row identifier.
pcszText | [in] New row text.
bCanUndo | [in] TRUE if this can be undone, FALSE otherwise.

The parser is notified to reparse the changed text.

◆ SetRowValid()

void SetRowValid ( int nDispRow )

Validates a specified row.

Parameters
nDispRow [in] Row identifier in document coordinates.
See also
IsRowValid

◆ SetScrollBars()

BOOL SetScrollBars | ( | BOOL | bHorzSBar,
 |  | BOOL | bVertSBar,
 |  | BOOL | bUpdateReg = FALSE )

Enables/disables scrollbars.

Parameters
bHorzSBar | [in] TRUE to enable the horizontal scrollbar, FALSE to disable the horizontal scrollbar.
bVertSBar | [in] TRUE to enable the vertical scrollbar, FALSE to disable the vertical scrollbar.
bUpdateReg | [in] TRUE to update this setting in the registry, FALSE otherwise. By default, this parameter is FALSE.
Returns
TRUE if the scrollbars were updated, otherwise FALSE.

◆ SetScrollInfo()

BOOL SetScrollInfo | ( | int | nBar,
 |  | LPSCROLLINFO | lpScrollInfo,
 |  | BOOL | bRedraw = TRUE )

Sets the information that the SCROLLINFO structure maintains about a specified scroll bar.

Parameters
nBar | [in] Specifies the scroll bar to be set. The value of this parameter must be one of the following: SB_HORZ: Sets the position of the scroll box in the horizontal scroll bar of the window. SB_VERT: Sets the position of the scroll box in the vertical scroll bar of the window.
lpScrollInfo | [in] Pointer to a SCROLLINFO structure.
bRedraw | [in] TRUE to redraw the scroll bar, FALSE otherwise.

You must provide the values required by the SCROLLINFO structure parameters, including the flag values.

The SCROLLINFO structure contains information about a scroll bar, including the minimum and maximum scrolling positions, the page size, and the position of the scroll box (the thumb). See the SCROLLINFO structure topic in the Platform SDK for more information about changing the structure defaults.

Returns
TRUE if successful, otherwise FALSE.
See also
GetScrollInfo, GetScrollLimit

◆ SetScrollPos()

int SetScrollPos | ( | int | nBar,
 |  | int | nPos,
 |  | BOOL | bRedraw = TRUE )

Sets the current position of a specified scroll box and, if requested, redraws the scroll bar to reflect the new position of the scroll box.

Parameters
nBar | [in] Specifies the scroll bar to be set. The value of this parameter must be one of the following: SB_HORZ: Sets the position of the scroll box in the horizontal scroll bar of the window. SB_VERT: Sets the position of the scroll box in the vertical scroll bar of the window.
nPos | [in] Specifies the new position of the scroll box. The value of this parameter must be within the scrolling range.
bRedraw | [in] TRUE to redraw the scroll bar, FALSE otherwise.

Setting bRedraw to FALSE is useful whenever the scroll bar will be redrawn by a subsequent call to another function.

Returns
The previous position of the scroll box.

◆ SetScrollRange()

void SetScrollRange | ( | int | nBar,
 |  | int | nMinPos,
 |  | int | nMaxPos,
 |  | BOOL | bRedraw = TRUE )

Sets the minimum and maximum position values for a specified scroll bar.

Parameters
nBar | [in] Specifies the scrollbar to be set. The value of this parameter must be one of the following: SB_HORZ: Sets the range of the horizontal scroll bar of the window. SB_VERT: Sets the range of the vertical scroll bar of the window.
nMinPos | [in] Specifies the minimum scrolling position.
nMaxPos | [in] Specifies the maximum scrolling position.
bRedraw | [in] TRUE to redraw the scrollbar, FALSE otherwise.

This method can also be used to hide or show standard scroll bars.

An application should not call this function to hide a scroll bar while processing a scroll-bar notification message.

If the call to SetScrollRange immediately follows a call to the SetScrollPos member function, the bRedraw parameter in the SetScrollPos member function should be set to 0 to prevent the scroll bar from being drawn twice.

The default range for a standard scroll bar is 0 through 100. The default range for a scroll bar control is empty (both the nMinPos and nMaxPos values are 0).

The difference between the values specified by nMinPos and nMaxPos must not be greater than INT_MAX.

◆ SetSelMargin()

BOOL SetSelMargin | ( | BOOL | bSelMargin,
 |  | BOOL | bUpdateReg = FALSE )

Enables/disables the gutter.

Parameters
bSelMargin | [in] TRUE to enable the gutter, FALSE to disable the gutter.
bUpdateReg | [in] TRUE to update this setting in the registry, FALSE otherwise. By default, this parameter is FALSE.

The gutter is not visible if it is disabled.

Returns
TRUE if the operation was successful, otherwise FALSE.
See also
GetSelMargin

◆ SetSyntaxAndColorScheme()

void SetSyntaxAndColorScheme | ( | CString | sSyntaxScheme,
 |  | CString | sColorScheme,
 |  | BOOL | bScheme = FALSE,
 |  | BOOL | bColors = FALSE )

Sets the syntax and color schemes.

Parameters
sSyntaxScheme | String containing the syntax scheme.
sColorScheme | String containing the color scheme.
bScheme | Additional flag to call in-place editor.
bColors | Additional flag to call in-place editor.

◆ SetSyntaxColor()

BOOL SetSyntaxColor | ( | BOOL | bSyntaxColor,
 |  | BOOL | bUpdateReg = FALSE )

Enables/disables syntax colorization.

Parameters
bSyntaxColor | [in] TRUE to enable syntax colorization, FALSE to disable syntax colorization.
bUpdateReg | [in] TRUE to update this setting in the registry, FALSE otherwise. By default, this parameter is FALSE.
Returns
TRUE if the operation was successful, otherwise FALSE.
See also
GetSyntaxColor

◆ SetTabSize()

BOOL SetTabSize | ( | int | nTabSize,
 |  | BOOL | bUpdateReg = FALSE )

Sets the tab size.

Parameters
nTabSize | [in] Tab size to be set (should be between 2 to 10).
bUpdateReg | [in] TRUE to update this setting in the registry, FALSE otherwise. By default, this parameter is FALSE.
Returns
TRUE if the operation was successful, otherwise FALSE.
See also
GetTabSize

◆ SetTabWithSpace()

BOOL SetTabWithSpace | ( | BOOL | bTabWithSpace,
 |  | BOOL | bUpdateReg = FALSE )

Enables/disables replacing tabs with spaces.

Parameters
bTabWithSpace | [in] TRUE to enable replacing tabs with spaces, FALSE to disable replacing tabs with spaces.
bUpdateReg | [in] TRUE to update this setting in the registry, FALSE otherwise. By default, this parameter is FALSE.
Returns
TRUE if the operation was successful, otherwise FALSE.
See also
GetTabWithSpace

◆ SetText()

void SetText ( LPCTSTR pcszText )

Sets the editor text.

Parameters
pcszText [in] Pointer to the editor text to be set.

CWnd::SetWindowText can also be used to set the editor text.

See also
GetText, CWnd::GetWindowText

◆ SetTopRow()

void SetTopRow ( int iRow )

Sets the top row of the visible window.

Parameters
iRow [in] Identifier of the row to be set.
See also
GetTopRow

◆ SetViewOnly()

AFX_INLINE void SetViewOnly ( BOOL bViewOnly )

Sets if the editor should be in view-only mode.

Parameters
bViewOnly TRUE to set the editor to view-only mode, FALSE otherwise.

View-only mode is the same as read-only except with a normal background, no cursor (caret), no selectable text, and no copy/paste.

◆ SetWideCaret()

BOOL SetWideCaret | ( | BOOL | bWideCaret,
 |  | BOOL | bUpdateReg = FALSE )

Sets the caret for overwrite mode.

Parameters
bWideCaret | [in] TRUE to set thin caret for overwrite mode, FALSE to set wide caret for overwrite mode.
bUpdateReg | [in] TRUE to update this setting in the registry, FALSE otherwise. By default, this parameter is FALSE.
Returns
TRUE if the operation was successful, otherwise FALSE.

◆ ShiftCurrentVisibleRowDown()

BOOL ShiftCurrentVisibleRowDown | ( | int | nCount,
 |  | BOOL | bChangeCaret = FALSE )
 protected

Shifts the current row down a specified number of rows.

Parameters
nCount | [in] Number of rows.
bChangeCaret | [in] Caret movement flag. The default value of this parameter is FALSE.
Returns
TRUE if the screen was changed, otherwise FALSE.

◆ ShiftCurrentVisibleRowUp()

BOOL ShiftCurrentVisibleRowUp | ( | int | nCount,
 |  | BOOL | bChangeCaret = FALSE )
 protected

Shifts the current row up a specified number of rows.

Parameters
nCount | [in] Number of rows.
bChangeCaret | [in] Caret movement flag. The default value of this parameter is FALSE.
Returns
TRUE if the screen was changed, otherwise FALSE.

◆ ShowCollapsedToolTip()

void ShowCollapsedToolTip ( const CPoint & ptMouse )
protected

Shows a tooltip with the collapsed text of the collapsed block at a specified point.

Parameters
ptMouse [in] Reference to the mouse coordinates to check for a collapsed block.
See also
CXTPSyntaxEditToolTipCtrl, m_wndToolTip

◆ ShowDefaultContextMenu()

void ShowDefaultContextMenu ( )

Displays the default context menu.

This member function calls OnContextMenu.

See also
OnContextMenu

◆ ShowHScrollBar()

void ShowHScrollBar ( BOOL bShow = TRUE )

Shows/hides the horizontal scrollbar.

Parameters
bShow [in] TRUE to show the horizontal scrollbar, FALSE to hide the horizontal scrollbar. The default value for this parameter is TRUE.

◆ ShowScrollBar()

void ShowScrollBar | ( | UINT | nBar,
 |  | BOOL | bShow = TRUE )

Shows/hides a specified scroll bar.

Parameters
nBar | [in] Specifies if the scroll bar is a control or a part of a window's non-client area. If the scroll bar is a part of the non-client area, then the value of this parameter also indicates if the scroll bar is positioned horizontally, vertically, or both. The value of this parameter must be one of the following: SB_BOTH: Specifies the horizontal and vertical scroll bars of the window. SB_HORZ: Specifies that the window is a horizontal scroll bar. SB_VERT: Specifies that the window is a vertical scroll bar.
bShow | [in] TRUE to show the scroll bar, FALSE to hide the scroll bar.

An application should not call ShowScrollBar to hide a scroll bar while processing a scroll bar notification message.

See also
EnableScrollBarCtrl

◆ TabifySelection()

BOOL TabifySelection ( )

Replaces all blank spaces with tabs.

Returns
TRUE if successful, otherwise FALSE.

◆ Undo()

BOOL Undo ( int nActionsCount = 1 )

Performs a undo operation.

Parameters
nActionsCount [in] Number of actions to undo simultaneously.
Returns
TRUE if successful, otherwise FALSE.
See also
CanUndo

◆ Unselect()

void Unselect ( )

Deselects the previously selected rectangle area.

See also
SetCurSel

◆ UnTabifySelection()

BOOL UnTabifySelection ( )

Replaces all tabs with blank spaces.

Returns
TRUE if successful, otherwise FALSE.

◆ UpdateRowInfoInternally()

void UpdateRowInfoInternally ( int nTextRow )
protected

Internally updates drawing information (e.g.

each character position) in the draw text processor.

Parameters
nTextRow Row identifier.

This method draws the specified row on the memory device context.

◆ UpdateScrollPos()

void UpdateScrollPos ( DWORD dwUpdate = XTP_EDIT_UPDATE_ALL )
protected

Updates sibling views while in split mode.

Parameters
dwUpdate [in] View update flags.

◆ UppercaseSelection()

BOOL UppercaseSelection ( )

Converts the selected text to uppercase.

Returns
TRUE if successful, otherwise FALSE.

◆ ValidateCol()

void ValidateCol | ( | const int | nRow,
 |  | int & | nCol,
 |  | int & | nAbsCol )

Validates and sets the row column to a valid one.

Parameters
nRow | [in] Document row to be validated.
nCol | [in, out] Column to be validated.
nAbsCol | [in, out] Absolute column to be validated.

Member Data Documentation

◆ m_bDisableRedraw

BOOL m_bDisableRedraw

If TRUE - control window is not redraw, it is draw last window content (draw cached bitmap).

FALSE by default.

◆ m_chPrevLeadByte

BYTE m_chPrevLeadByte
protected

For non-UNICODE version, IME sends double byte chars as 2 messages.

This member keeps a lead byte until second byte receive to process them together.

◆ m_sIniSet

CString m_sIniSet
protected

String with default or passed type of rules, e.g.

_T("[Schemes]\r\nCPP\r\n[Themes]\r\nDefault\r\nAlternative\r\n")

◆ m_sPassedIniSet

CString m_sPassedIniSet
protected

String with passed type of rules, e.g.

_T("[Schemes]\r\nVBS\r\n[Themes]\r\nDefault\r\nAlternative\r\n")

The documentation for this class was generated from the following file:
  • XTPSyntaxEditCtrl.h


Toolkit Pro: CXTPSyntaxEditCtrl::CAverageVal Class Reference

  • CXTPSyntaxEditCtrl
  • CAverageVal
Public Member Functions | Protected Attributes | List of all members
CXTPSyntaxEditCtrl::CAverageVal Class Reference

CXTPSyntaxEditCtrl::CAverageVal. More...

Public Member Functions

CAverageVal (int nDataSize=100)
Constructs a CAverageVal object.
void | AddValue (UINT uVal)
Adds a value to the data collection.
UINT | GetAverageValue (UINT uDefaultIfNoData=0)
Gets the average value the data in this object.

Protected Attributes

int | m_nDataSize
Data size.
int | m_nNextIndex
Next index.
CUIntArray | m_arData
Data collection.

Detailed Description

CXTPSyntaxEditCtrl::CAverageVal.

Constructor & Destructor Documentation

◆ CAverageVal()

CAverageVal ( int nDataSize = 100 )

Constructs a CAverageVal object.

Parameters
nDataSize Data size.

Member Function Documentation

◆ AddValue()

void AddValue ( UINT uVal )

Adds a value to the data collection.

Parameters
uVal Value to be added.

◆ GetAverageValue()

UINT GetAverageValue ( UINT uDefaultIfNoData = 0 )

Gets the average value the data in this object.

Parameters
uDefaultIfNoData Default value.
Returns
The average value of the data in this object.
The documentation for this class was generated from the following file:
  • XTPSyntaxEditCtrl.h


Toolkit Pro: CXTPSyntaxEditDeleteStringCommand Class Reference

Public Member Functions | List of all members
CXTPSyntaxEditDeleteStringCommand Class Reference

This class represents the delete string command. More...

Inheritance diagram for CXTPSyntaxEditDeleteStringCommand:
[legend]

Public Member Functions

CXTPSyntaxEditDeleteStringCommand (CXTPSyntaxEditBufferManager *pMgr, LPCTSTR szText, const XTP_EDIT_LINECOL &lcFrom, const XTP_EDIT_LINECOL &lcTo)
Creates the delete string command object, initializes its members.
virtual | ~CXTPSyntaxEditDeleteStringCommand ()
A default command destructor.
virtual int | Execute (XTP_EDIT_LINECOL &lcFrom, XTP_EDIT_LINECOL &lcTo, CXTPSyntaxEditCtrl *pEditCtrl)
Executes the delete string command.
virtual int | UnExecute (XTP_EDIT_LINECOL &lcFrom, XTP_EDIT_LINECOL &lcTo, CXTPSyntaxEditCtrl *pEditCtrl)
Unexecutes the delete string command (i.e.
- Public Member Functions inherited from CXTPSyntaxEditBufferCommand
virtual | ~CXTPSyntaxEditBufferCommand ()
A default command destructor.
- Public Member Functions inherited from CXTPSyntaxEditCommand
virtual | ~CXTPSyntaxEditCommand ()
A default command destructor.
virtual LPCTSTR | GetCommandText () const
Gets command text.
virtual void | SetCommandText (LPCTSTR szText)
Sets command text.

Additional Inherited Members

- Protected Member Functions inherited from CXTPSyntaxEditBufferCommand
CXTPSyntaxEditBufferCommand (CXTPSyntaxEditBufferManager *pMgr, LPCTSTR szText, const XTP_EDIT_LINECOL &lcFrom, const XTP_EDIT_LINECOL &lcTo)
Creates the buffer command object, initializes its members.
int | DoInsertText (XTP_EDIT_LINECOL &lcFrom, XTP_EDIT_LINECOL &lcTo, CXTPSyntaxEditCtrl *pEditCtrl)
Inserts the stored text at the stored positions and returns the start and final affected text positions.
int | DoDeleteText (XTP_EDIT_LINECOL &lcFrom, XTP_EDIT_LINECOL &lcTo, CXTPSyntaxEditCtrl *pEditCtrl)
Deletes the text at the stored positions and returns the start and final affected text positions.
virtual int | GetDataSize () const
Gets the undo command data size (in bytes).
- Protected Member Functions inherited from CXTPSyntaxEditCommand
CXTPSyntaxEditCommand ()
Protected constructor because this class could not be instantiated itself, only by its descendants.
- Static Protected Member Functions inherited from CXTPSyntaxEditCommand
static void AFX_CDECL | SetPositionInternally (CXTPSyntaxEditCtrl *pEditCtrl, const XTP_EDIT_LINECOL &lcPos)
Sets the line and column position for the specified control using internal fast methods.
- Protected Attributes inherited from CXTPSyntaxEditBufferCommand
CXTPSyntaxEditBufferManager * | m_pBufferMgr
Pointer to the associated text buffer.
CString | m_strText
Changed text.
XTP_EDIT_LINECOL | m_lcFrom
Start edit position.
XTP_EDIT_LINECOL | m_lcTo
End edit position.
- Protected Attributes inherited from CXTPSyntaxEditCommand
CString | m_strCommandText
Text description of the command.

Detailed Description

This class represents the delete string command.

Command execution will delete the text from the buffer between the specified text positions and un-execution will insert this text into the buffer.

See also
CXTPSyntaxEditBufferCommand, CXTPSyntaxEditInsertStringCommand

Constructor & Destructor Documentation

◆ CXTPSyntaxEditDeleteStringCommand()

CXTPSyntaxEditDeleteStringCommand | ( | CXTPSyntaxEditBufferManager * | pMgr,
 |  | LPCTSTR | szText,
 |  | const XTP_EDIT_LINECOL & | lcFrom,
 |  | const XTP_EDIT_LINECOL & | lcTo )

Creates the delete string command object, initializes its members.

Parameters
pMgr | [in] Pointer to the associated buffer manager object.
szText | [in] Text which was changed during the buffer operation. It will be used for insert/remove text operations.
lcFrom | [in] Start text position affected by the command.
lcTo | [in] End text position affected by the command.

◆ ~CXTPSyntaxEditDeleteStringCommand()

virtual ~CXTPSyntaxEditDeleteStringCommand ( )
virtual

A default command destructor.

Destroys the command object, handles its cleanup and de-allocation.

Member Function Documentation

◆ Execute()

virtual int Execute | ( | XTP_EDIT_LINECOL & | lcFrom,
 |  | XTP_EDIT_LINECOL & | lcTo,
 |  | CXTPSyntaxEditCtrl * | pEditCtrl )
 virtual

Executes the delete string command.

Parameters
lcFrom | [out] Start text position affected by the command.
lcTo | [out] End text position affected by the command.
pEditCtrl | [in] Pointer to the edit control.
Returns
A bitwise combination of the edit actions that occurred: XTP_EDIT_EDITACTION_MODIFYROW, XTP_EDIT_EDITACTION_DELETEROW
See also
UnExecute

Implements CXTPSyntaxEditCommand.

◆ UnExecute()

virtual int UnExecute | ( | XTP_EDIT_LINECOL & | lcFrom,
 |  | XTP_EDIT_LINECOL & | lcTo,
 |  | CXTPSyntaxEditCtrl * | pEditCtrl )
 virtual

Unexecutes the delete string command (i.e.

inserts the string).

Parameters
lcFrom | [out] Start text position affected by the command.
lcTo | [out] End text position affected by the command.
pEditCtrl | [in] Pointer to the edit control.
Returns
A bitwise combination of the edit actions that occurred: XTP_EDIT_EDITACTION_MODIFYROW, XTP_EDIT_EDITACTION_INSERTROW
See also
Execute

Implements CXTPSyntaxEditCommand.

The documentation for this class was generated from the following file:
  • XTPSyntaxEditUndoManager.h


Toolkit Pro: CXTPSyntaxEditDoc Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPSyntaxEditDoc Class Reference

This class represents the Document portion of an Edit control. More...

Public Member Functions

BOOL | ReOpen ()
Re-opens an opened file.
void | SetDataManager (CXTPSyntaxEditBufferManager *pBuffer)
Sets the edit buffer manager.
CXTPSyntaxEditBufferManager * | GetDataManager () const
Gets the edit buffer manager.
void | SetConfigFile (LPCTSTR szPath)
Sets the the path to the main configuration file.
BOOL | GetAutoReload () const
Determines if auto-reload for external files is enabled/disabled.
BOOL | SetAutoReload (BOOL bAutoReload, BOOL bUpdateReg=FALSE)
Enables/disables auto-reload for external files.
BOOL | CheckFileModified (LPCTSTR lpszPathName)
Determines if the current file has been externally modified and prompts the user to reload it.
BOOL | IsReadonly ()
Determines if the current file is read-only.
CXTPSyntaxEditView * GetFirstView ()
Gets a first view for the document object.

Protected Member Functions

CXTPSyntaxEditDoc ()
Protected object constructor.
virtual ~CXTPSyntaxEditDoc ()
Destroys a CXTPSyntaxEditDoc object, handles cleanup and de-allocation.

Protected Attributes

CXTPSyntaxEditBufferManager * | m_ptrDataMan
Data manager pointer.
BOOL | m_bAutoReload
TRUE if auto-reload for externally modified files is enabled, FALSE otherwise.
BOOL | m_bOpened
TRUE if opened, FALSE otherwise.
BOOL | m_bNewFile
TRUE if either a new file is created or a file is opened, FALSE otherwise.
BOOL | m_bDocCreated
TRUE if a document is created, FALSE otherwise.
BOOL | m_bReloading
TRUE if the document is being reloaded, FALSE otherwise.
int | m_iTopRow
Identifier of top row.
int | m_iHScrollPos
Scrolling position.

Detailed Description

This class represents the Document portion of an Edit control.

It extends the functionality provided by the CDocument class from MFC's document-view model implementation. The CXTPSyntaxEditDoc class works together with CXTPSyntaxEditView and provides storage facilities for it.

See also
CXTPSyntaxEditView

Constructor & Destructor Documentation

◆ CXTPSyntaxEditDoc()

CXTPSyntaxEditDoc ( )
protected

Protected object constructor.

Used by dynamic creation

Member Function Documentation

◆ CheckFileModified()

BOOL CheckFileModified ( LPCTSTR lpszPathName )

Determines if the current file has been externally modified and prompts the user to reload it.

Parameters
lpszPathName Full file name.

This method only works when auto-reload is enabled.

Returns
TRUE if the file was externally modified and reloaded, otherwise FALSE.
See also
GetAutoReload, SetAutoReload

◆ GetAutoReload()

AFX_INLINE BOOL GetAutoReload ( ) const

Determines if auto-reload for external files is enabled/disabled.

Returns
TRUE if auto-reload for external files is enabled, FALSE if auto-reload for external files is disabled.

◆ GetDataManager()

AFX_INLINE CXTPSyntaxEditBufferManager * GetDataManager ( ) const

Gets the edit buffer manager.

Returns
A pointer to the edit buffer manager.
See also
CXTPSyntaxEditBufferManager

◆ GetFirstView()

CXTPSyntaxEditView * GetFirstView ( )

Gets a first view for the document object.

Returns
A pointer to a CXTPSyntaxEditView object.
See also
CDocument::GetFirstViewPosition, CDocument::GetNextView

◆ IsReadonly()

BOOL IsReadonly ( )

Determines if the current file is read-only.

Returns
TRUE if the current file is read-only, otherwise FALSE.

◆ ReOpen()

BOOL ReOpen ( )

Re-opens an opened file.

Returns
TRUE if the file was re-opened successfully, otherwise FALSE.

◆ SetAutoReload()

BOOL SetAutoReload | ( | BOOL | bAutoReload,
 |  | BOOL | bUpdateReg = FALSE )

Enables/disables auto-reload for external files.

Parameters
bAutoReload | [in] TRUE to enable auto-reload for external files, FALSE to disable auto-reload for external files.
bUpdateReg | [in] TRUE to update this setting in the registry, FALSE otherwise. By default, this parameter is FALSE.
Returns
TRUE if successful, otherwise FALSE.

◆ SetConfigFile()

void SetConfigFile ( LPCTSTR szPath )

Sets the the path to the main configuration file.

Parameters
szPath [in] Path to be set.

The configuration will be reloaded.

See also
CXTPSyntaxEditCtrl::GetConfigFile

◆ SetDataManager()

void SetDataManager ( CXTPSyntaxEditBufferManager * pBuffer )

Sets the edit buffer manager.

Parameters
pBuffer [in] Pointer to the buffer manager to be set.
See also
CXTPSyntaxEditBufferManager
The documentation for this class was generated from the following file:
  • XTPSyntaxEditDoc.h


Toolkit Pro: CXTPSyntaxEditDrawTextProcessor Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPSyntaxEditDrawTextProcessor Class Reference

This helper class is used by CXTPSyntaxEditCtrl as the Draw Text Processor. More...

Public Member Functions

CXTPSyntaxEditDrawTextProcessor ()
Default object constructor.
CRect | GetTextRect () const
Gets the text rectangle.
void | SetTextRect (const CRect &rcRect)
Sets the text rectangle.
int | GetRowHeight () const
Gets the height of a single row.
int | RecalcRowHeight (CDC *pDC, CFont *pFont)
Recalculates the height of a single row.
int | GetRowsCount (BOOL bWithPartlyVisible) const
Gets the number of visible rows for the text rectangle.
int | GetTabSize () const
Gets the tab size.
void | SetTabSize (int nTabSize)
Sets the tab size.
int | GetScrollXOffset () const
Gets the scroll offset for the x- coordinate.
void | SetScrollXOffset (int nOffsetX)
Sets the scroll offset for the x- coordinate.
const TEXTMETRIC & | GetTextMetrics () const
Gets the current text metrics.
int | GetSpaceWidth () const
Gets the space character width, in pixels.
int | AlignColIdxToTabs (int nRow, int nCol, BOOL bVirtualSpace=FALSE)
Aligns a specified column index to tab borders.
int | GetColPosX (int nRow, int nCol, int *pnCharWidth=NULL, BOOL bVirtualSpace=FALSE) const
Gets the starting x- position of a specified column.
BOOL | ColFromXPos (int nRow, int nX, int &rnCol, BOOL bVirtualSpace=FALSE) const
Gets the column at a specified x- position.
int | GetRowWidth (int nRow) const
Retrieves the width (in pixels) of a specified row.
int | GetRowsMaxWidth () const
Gets the maximum width (in pixels) of all visible rows.
BOOL | HitTest (const CPoint &pt, int &rnRow, int &rnCol, BOOL bVirtualSpace=FALSE) const
Gets the row and column, if any, at a specified point.
BOOL | HitTestRow (int nY, int &rnRow) const
Gets the row, if any, at a specified y- position.
void | ResetRowInfo (int nRow)
Clears the cached row information of a specified row.
int | DrawRowPart (CDC *pDC, int nRow, LPCTSTR pcszText, int nchCount=-1)
Draws the row part and stores character positions.
int | PrintRowPart (CDC *pDC, int nRow, int nPosY, UINT nFlags, LPCTSTR pcszText, int nchCount=-1, int *pnPrintedTextLen=NULL)
Use this member function to draw row part and store characters positions.
int | ExpandChars (LPCTSTR pszChars, CString &strBuffer, int nDispPos=0, BOOL bEnableWhiteSpace=FALSE)
Expands the character set by putting spaces in the position of tabs.
void | SetRowTabPositions (int nRow, LPCTSTR pcszOrigRowText)
Sets the tab positions for a specified row.
int | DispPosToStrPos (int nRow, int nDispPos, BOOL bVirtualSpace) const
Converts display position to string position.
int | StrPosToDispPos (int nRow, int nStrPos, BOOL bVirtualSpace=FALSE) const
Converts string position to display position.
CPoint | SetCaretPos (CWnd *pWnd, const CSize &szSize, int nRow, int &rnCol, BOOL bHideCaret=FALSE, BOOL bVirtualSpace=FALSE)
Sets the caret position.
CPoint | SetCaretByPoint (CWnd *pWnd, const CPoint &pt, const CSize &szSize, int &rnRow, int &rnCol, BOOL bVirtualSpace=FALSE)
Sets the caret position.

Protected Attributes

int | m_nTabSize
Tab size.
TEXTMETRIC | m_tmText
Text metrics.
int | m_nSpaceWidth
Space character width.
CRect | m_rcTextRect
Text rectangle.
int | m_nRowHeight
Row height.
int | m_nScrollXOffset
Scroll offset for the x- coordinate.
int | m_nDrawingRow
Currently drawing row.
int | m_nNextRowPosX
x- offset to draw the next row part.
int | m_nPrintingRow
Currently printing row.
CPoint | m_ptNextPrintPos
x- and y- offset to print the next row part.
BOOL | m_bUseOutputDC
TRUE to use the output DC for calculations.

Detailed Description

This helper class is used by CXTPSyntaxEditCtrl as the Draw Text Processor.

It is responsible for both drawing chars and remembering each char position and other text properties.

Member Function Documentation

◆ AlignColIdxToTabs()

int AlignColIdxToTabs | ( | int | nRow,
 |  | int | nCol,
 |  | BOOL | bVirtualSpace = FALSE )

Aligns a specified column index to tab borders.

Parameters
nRow | Zero-based row index.
nCol | Zero-based column index.
bVirtualSpace | TRUE if virtual space is enabled, otherwise FALSE.
Returns
The aligned column index.
See also
SetTabSize, GetTabSize

◆ ColFromXPos()

BOOL ColFromXPos | ( | int | nRow,
 |  | int | nX,
 |  | int & | rnCol,
 |  | BOOL | bVirtualSpace = FALSE ) const

Gets the column at a specified x- position.

Parameters
nRow | [in] Zero-based row index.
nX | [in] x- position (in pixels).
rnCol | [out] Reference to an integer to receive the index of the column at the specified x- position.
bVirtualSpace | [in] TRUE if virtual space is enabled, otherwise FALSE.
Returns
TRUE if successful, otherwise FALSE.
See also
GetColPosX, AlignColIdxToTabs

◆ DispPosToStrPos()

int DispPosToStrPos | ( | int | nRow,
 |  | int | nDispPos,
 |  | BOOL | bVirtualSpace ) const

Converts display position to string position.

Parameters
nRow | Zero-based row index.
nDispPos | Zero-based display column index.
bVirtualSpace | TRUE if virtual space is enabled, otherwise FALSE.
Returns
The converted string position.

◆ DrawRowPart()

int DrawRowPart | ( | CDC * | pDC,
 |  | int | nRow,
 |  | LPCTSTR | pcszText,
 |  | int | nchCount = -1 )

Draws the row part and stores character positions.

Parameters
pDC | [in] Pointer to a valid device context.
nRow | [in] Zero-based row index (or a value of -1 to switch to finishing the current row drawing).
pcszText | [in] String to draw.
nchCount | [in] Character count to draw.
Returns
The x- offset of the next row part.
See also
PrintRowPart

◆ ExpandChars()

int ExpandChars | ( | LPCTSTR | pszChars,
 |  | CString & | strBuffer,
 |  | int | nDispPos = 0,
 |  | BOOL | bEnableWhiteSpace = FALSE )

Expands the character set by putting spaces in the position of tabs.

Parameters
pszChars | [in] Text to be processed.
strBuffer | [out] Buffer for text to be created after expansion.
nDispPos | [in] Start display position.
bEnableWhiteSpace | [in] TRUE to show white space, FALSE otherwise.
Returns
The end display position after expansion.

◆ GetColPosX()

int GetColPosX | ( | int | nRow,
 |  | int | nCol,
 |  | int * | pnCharWidth = NULL,
 |  | BOOL | bVirtualSpace = FALSE ) const

Gets the starting x- position of a specified column.

Parameters
nRow | [in] Zero-based row index.
nCol | [in] Zero-based column index.
pnCharWidth | [out] Pointer to an integer to receive the character width of the column (in pixels). The value of this parameter may be NULL.
bVirtualSpace | [in] TRUE if virtual space is enabled, otherwise FALSE.
Returns
The starting x-position (in pixels) of the specified column.
See also
ColFromXPos

◆ GetRowHeight()

AFX_INLINE int GetRowHeight ( ) const

Gets the height of a single row.

Returns
The height of a single row.
See also
RecalcRowHeight

◆ GetRowsCount()

AFX_INLINE int GetRowsCount ( BOOL bWithPartlyVisible ) const

Gets the number of visible rows for the text rectangle.

Parameters
bWithPartlyVisible TRUE to count both partly and fully visible rows, FALSE to only count fully visible rows.
Returns
The number of visible rows for the text rectangle.
See also
SetTextRect

◆ GetRowsMaxWidth()

int GetRowsMaxWidth ( ) const

Gets the maximum width (in pixels) of all visible rows.

Returns
The maximum width (in pixels) of all visible rows.
See also
GetRowsWidth

◆ GetRowWidth()

int GetRowWidth ( int nRow ) const

Retrieves the width (in pixels) of a specified row.

Parameters
nRow Zero-based index of the row with the width to retrieve.
Returns
The width (in pixels) of the specified row.
See also
GetRowsMaxWidth

◆ GetScrollXOffset()

AFX_INLINE int GetScrollXOffset ( ) const

Gets the scroll offset for the x- coordinate.

Returns
The scroll offset for the x- coordinate.
See also
SetScrollXOffset

◆ GetSpaceWidth()

AFX_INLINE int GetSpaceWidth ( ) const

Gets the space character width, in pixels.

Returns
The space character width, in pixels.
See also
RecalcRowHeight

◆ GetTabSize()

AFX_INLINE int GetTabSize ( ) const

Gets the tab size.

Returns
The tab size.
See also
SetTabSize

◆ GetTextMetrics()

AFX_INLINE const TEXTMETRIC & GetTextMetrics ( ) const

Gets the current text metrics.

Returns
A reference to the current text metrics.
See also
RecalcRowHeight

◆ GetTextRect()

AFX_INLINE CRect GetTextRect ( ) const

Gets the text rectangle.

Returns
The text rectangle.
See also
SetTextRect

◆ HitTest()

BOOL HitTest | ( | const CPoint & | pt,
 |  | int & | rnRow,
 |  | int & | rnCol,
 |  | BOOL | bVirtualSpace = FALSE ) const

Gets the row and column, if any, at a specified point.

Parameters
pt | [in] Point to be tested.
rnRow | [out] Reference to an integer to receive the index of the row at the specified point.
rnCol | [out] Reference to an integer to receive the index of the column at the specified point.
bVirtualSpace | [in] TRUE if virtual space is enabled, otherwise FALSE.
Returns
TRUE if successful, otherwise FALSE.
See also
GetColPosX, HitTestRow.

◆ HitTestRow()

BOOL HitTestRow | ( | int | nY,
 |  | int & | rnRow ) const

Gets the row, if any, at a specified y- position.

Parameters
nY | [in] y- position (in pixels).
rnRow | [out] Reference to an integer to receive the index of the row at the specified y- position.
Returns
TRUE if successful, otherwise FALSE.
See also
GetColPosX, HitTest.

◆ PrintRowPart()

int PrintRowPart | ( | CDC * | pDC,
 |  | int | nRow,
 |  | int | nPosY,
 |  | UINT | nFlags,
 |  | LPCTSTR | pcszText,
 |  | int | nchCount = -1,
 |  | int * | pnPrintedTextLen = NULL )

Use this member function to draw row part and store characters positions.

Parameters
pDC | [in] Pointer to a valid device context.
nRow | [in] Zero-based row index (or a value of -1 to switch to finishing the current row drawing).
nPosY | [in] y- offset to print the specified row.
nFlags | [in] Additional printing options. The following values are supported: DT_CALCRECT, DT_SINGLELINE, DT_WORDBREAK
pcszText | [in] String to draw.
nchCount | [in] Character count to draw.
pnPrintedTextLen | [out] Pointer to an integer to receive the printed text length.
Returns
The printed row height.
See also
DrawRowPart

◆ RecalcRowHeight()

int RecalcRowHeight | ( | CDC * | pDC,
 |  | CFont * | pFont )

Recalculates the height of a single row.

Parameters
pDC | [in] Pointer to the device context.
pFont | [in] Pointer to the font to calculate.
Returns
The height of a single row.
See also
GetRowHeight

◆ ResetRowInfo()

void ResetRowInfo ( int nRow )

Clears the cached row information of a specified row.

Parameters
nRow Zero-based row index.
See also
DrawRowPart, PrintRowPart.

◆ SetCaretByPoint()

CPoint SetCaretByPoint | ( | CWnd * | pWnd,
 |  | const CPoint & | pt,
 |  | const CSize & | szSize,
 |  | int & | rnRow,
 |  | int & | rnCol,
 |  | BOOL | bVirtualSpace = FALSE )

Sets the caret position.

Parameters
pWnd | [in] Pointer to the caret owner window.
pt | [in] Reference to the point to set the caret.
szSize | [in] Reference to the caret size.
rnRow | [in, out] Reference to the zero-based row index.
rnCol | [in, out] Reference to the zero-based column index.
bVirtualSpace | [in] TRUE if virtual space is enabled, otherwise FALSE.

The [in, out] parameters rnCol and rnRow may be adjusted to valid values.

Returns
The point of the caret position.

◆ SetCaretPos()

CPoint SetCaretPos | ( | CWnd * | pWnd,
 |  | const CSize & | szSize,
 |  | int | nRow,
 |  | int & | rnCol,
 |  | BOOL | bHideCaret = FALSE,
 |  | BOOL | bVirtualSpace = FALSE )

Sets the caret position.

Parameters
pWnd | [in] Pointer to the caret owner window.
szSize | [in] Reference to the caret size.
nRow | [in] Zero-based row index.
rnCol | [in, out] Reference to the zero-based column index.
bHideCaret | [in] TRUE to hide the caret, FALSE to show the caret.
bVirtualSpace | [in] TRUE if virtual space is enabled, otherwise FALSE.

The [in, out] parameters rnCol and rnRow may be adjusted to valid values.

Returns
The point of the caret position.

◆ SetRowTabPositions()

void SetRowTabPositions | ( | int | nRow,
 |  | LPCTSTR | pcszOrigRowText )

Sets the tab positions for a specified row.

Parameters
nRow | [in] Zero-based row index.
pcszOrigRowText | [in] Row text (not expanded).

◆ SetScrollXOffset()

void SetScrollXOffset ( int nOffsetX )

Sets the scroll offset for the x- coordinate.

Parameters
nOffsetX [in] Scroll offset to be set.
See also
GetScrollXOffset

◆ SetTabSize()

AFX_INLINE void SetTabSize ( int nTabSize )

Sets the tab size.

Parameters
nTabSize [in] Tab size to be set.

Size is measured in space characters and should be between 2 to 10.

See also
GetTabSize

◆ SetTextRect()

AFX_INLINE void SetTextRect ( const CRect & rcRect )

Sets the text rectangle.

Parameters
rcRect [in] Rectangle to be set.
See also
GetTextRect

◆ StrPosToDispPos()

int StrPosToDispPos | ( | int | nRow,
 |  | int | nStrPos,
 |  | BOOL | bVirtualSpace = FALSE ) const

Converts string position to display position.

Parameters
nRow | Zero-based row index.
nStrPos | Zero-based string position.
bVirtualSpace | TRUE if virtual space is enabled, otherwise FALSE.
Returns
The converted display position.
The documentation for this class was generated from the following file:
  • XTPSyntaxEditDrawTextProcessor.h


Toolkit Pro: CXTPSyntaxEditFileChangesMonitor Class Reference

Public Member Functions | List of all members
CXTPSyntaxEditFileChangesMonitor Class Reference

this class monitors files changes More...

Public Member Functions

CXTPSyntaxEditFileChangesMonitor ()
Default object constructor.
virtual | ~CXTPSyntaxEditFileChangesMonitor ()
Destroys a CXTPSyntaxEditFileChangesMonitor() object, handles cleanup and de-allocation.
void | SetDefaultFolder (const CString &strPath)
Sets the default monitoring folder.
void | SetConfigurationManager (CXTPSyntaxEditConfigurationManager *pConfigMgr)
Sets the associated configuration manager.
BOOL | AddMonitorFile (CString &strFilename, DWORD dwOwnerFlags)
Adds a file to be monitored.
void | StartMonitoring ()
Starts the thread which will be monitoring folder changes.
void | StopMonitoring ()
Stops the thread which is monitoring folder changes.
void | RefreshFiles ()
Refreshes the contents of the folder, update file's status and re-reads changed configuration files.

Detailed Description

this class monitors files changes

Constructor & Destructor Documentation

◆ ~CXTPSyntaxEditFileChangesMonitor()

virtual ~CXTPSyntaxEditFileChangesMonitor ( )
virtual

Destroys a CXTPSyntaxEditFileChangesMonitor() object, handles cleanup and de-allocation.

Stops monitoring if it has not stopped already.

Member Function Documentation

◆ AddMonitorFile()

BOOL AddMonitorFile | ( | CString & | strFilename,
 |  | DWORD | dwOwnerFlags )

Adds a file to be monitored.

Parameters
strFilename | [in] Reference to the file name string.
dwOwnerFlags | [in] Additional flags (from enum XTPSyntaxEditCfgObjects).
Returns
TRUE if the operation was successful, otherwise FALSE.

Adds a file to the bunch of files to monitor changes at. First, tries to check the file by the provided file name string, then tries the file in the default folder. Bad file names are ignored.

See also
CXTPSyntaxEditConfigurationManager

◆ SetConfigurationManager()

AFX_INLINE void SetConfigurationManager ( CXTPSyntaxEditConfigurationManager * pConfigMgr )

Sets the associated configuration manager.

Parameters
pConfigMgr [in] Pointer to the configuration manager to be set.
See also
CXTPSyntaxEditConfigurationManager

◆ SetDefaultFolder()

void SetDefaultFolder ( const CString & strPath )

Sets the default monitoring folder.

Parameters
strPath [in] Reference to the path string.
The documentation for this class was generated from the following file:
  • XTPSyntaxEditLexCfgFileReader.h


Toolkit Pro: CXTPSyntaxEditFindReplaceDlg Class Reference

Public Member Functions | Public Attributes | Protected Member Functions | Protected Attributes | List of all members
CXTPSyntaxEditFindReplaceDlg Class Reference

This class implements the "Find and Replace" and "Find" dialogs for a SyntaxEdit control. More...

Public Member Functions

CXTPSyntaxEditFindReplaceDlg (CWnd *pParentWnd=NULL)
Default object constructor.
BOOL | ShowDialog (CXTPSyntaxEditCtrl *pEditCtrl, BOOL bReplaceDlg=FALSE)
Shows either a "Find and Replace" or "Find" dialog.
CXTPSyntaxEditCtrl * | GetEdirControl () const
Gets the attached edit control.
BOOL | IsReplaceDialog () const
Determines the type of dialog that was created.
int | GetSearchHistoryCountMax () const
Gets the maximum allowed number of search strings for find and replace comboboxes.
void | SetSearchHistoryCountMax (int nMaxCount)
Sets the maximum allowed number of search strings for find and replace comboboxes.

Public Attributes

int | m_nSearchDirection
Search Direction: 0-up, 1-down.
BOOL | m_bMatchWholeWord
Match Whole Words option.
BOOL | m_bMatchCase
Match Case option.
CString | m_csFindText
Text to find.
CString | m_csReplaceText
Text to replace.
int | m_nSearchHistoryCountMax
Maximum number of search strings.

Protected Member Functions

void | UpdateHistoryCombo (const CString &csText, CStringArray &arHistory)
Moves or adds a string to the top of history items (i.e.
void | UpdateHistoryCombo (const CString &csText, CStringArray &arHistory, CComboBox &wndCombo)
Moves or adds a string to the top of history items (i.e.
void | UpdateHistoryCombo (const CString &csText, CComboBox &wndCombo)
Moves or adds a string to the top of history items (i.e.
void | InitHistoryCombo (CStringArray &arHistory, CComboBox &wndCombo)
Initializes a combobox from an array of strings.
BOOL | LoadHistory ()
Loads from application profile history for find and replace comboboxes and state for other dialog controls.
BOOL | SaveHistory ()
Saves to application profile history for find and replace comboboxes and state for other dialog controls.
void | EnableControls ()
Updates the control state (i.e.

Protected Attributes

BOOL | m_bReplaceDlg
Dialog type.
CPoint | m_ptWndPos
Window position.
CXTPSyntaxEditCtrl * | m_pEditCtrl
Pointer to the attached view.

Detailed Description

This class implements the "Find and Replace" and "Find" dialogs for a SyntaxEdit control.

Constructor & Destructor Documentation

◆ CXTPSyntaxEditFindReplaceDlg()

CXTPSyntaxEditFindReplaceDlg ( CWnd * pParentWnd = NULL )

Default object constructor.

Parameters
pParentWnd Pointer to a parent window.

Member Function Documentation

◆ EnableControls()

void EnableControls ( )
protected

Updates the control state (i.e.

enable/disable) for the "Find", "Replace", and "Replace All" buttons.

◆ GetEdirControl()

AFX_INLINE CXTPSyntaxEditCtrl * GetEdirControl ( ) const

Gets the attached edit control.

Returns
A pointer to the attached edit control.
See also
ShowDialog

◆ GetSearchHistoryCountMax()

AFX_INLINE int GetSearchHistoryCountMax ( ) const

Gets the maximum allowed number of search strings for find and replace comboboxes.

Returns
The maximum allowed number of search strings for find and replace comboboxes.
See also
SetSearchHistoryCountMax, LoadHistory, SaveHistory

◆ InitHistoryCombo()

void InitHistoryCombo | ( | CStringArray & | arHistory,
 |  | CComboBox & | wndCombo )
 protected

Initializes a combobox from an array of strings.

Parameters
arHistory | Reference to an array of strings.
wndCombo | Reference to a CComboBox object.
See also
LoadHistory

◆ IsReplaceDialog()

AFX_INLINE BOOL IsReplaceDialog ( ) const

Determines the type of dialog that was created.

Returns
TRUE if a "Find and Replace" dialog was created, FALSE if a "Find" dialog was created.
See also
ShowDialog

◆ LoadHistory()

BOOL LoadHistory ( )
protected

Loads from application profile history for find and replace comboboxes and state for other dialog controls.

Returns
TRUE if successful, otherwise FALSE.
See also
SaveHistory

◆ SaveHistory()

BOOL SaveHistory ( )
protected

Saves to application profile history for find and replace comboboxes and state for other dialog controls.

Returns
TRUE if successful, otherwise FALSE.
See also
LoadHistory

◆ SetSearchHistoryCountMax()

AFX_INLINE void SetSearchHistoryCountMax ( int nMaxCount )

Sets the maximum allowed number of search strings for find and replace comboboxes.

Parameters
nMaxCount Maximum allowed number of search strings to be set for find and replace comboboxes.
See also
GetSearchHistoryCountMax, LoadHistory, SaveHistory

◆ ShowDialog()

BOOL ShowDialog | ( | CXTPSyntaxEditCtrl * | pEditCtrl,
 |  | BOOL | bReplaceDlg = FALSE )

Shows either a "Find and Replace" or "Find" dialog.

If a window has not been created, then this method will load a dialog template from resources and create a modeless dialog.

Parameters
pEditCtrl | Pointer to a CXTPSyntaxEditControl object.
bReplaceDlg | TRUE to create a "Find and Replace" dialog, FALSE to create a "Find" dialog.
Returns
TRUE if successful, otherwise FALSE.
See also
ShowWindow

◆ UpdateHistoryCombo() [1/3]

void UpdateHistoryCombo | ( | const CString & | csText,
 |  | CComboBox & | wndCombo )
 protected

Moves or adds a string to the top of history items (i.e.

item 0).

Parameters
csText | Reference to the string to move or add.
wndCombo | Reference to the history combobox.

◆ UpdateHistoryCombo() [2/3]

void UpdateHistoryCombo | ( | const CString & | csText,
 |  | CStringArray & | arHistory )
 protected

Moves or adds a string to the top of history items (i.e.

item 0).

Parameters
csText | Reference to the string to move or add.
arHistory | Reference to the history array.

◆ UpdateHistoryCombo() [3/3]

void UpdateHistoryCombo | ( | const CString & | csText,
 |  | CStringArray & | arHistory,
 |  | CComboBox & | wndCombo )
 protected

Moves or adds a string to the top of history items (i.e.

item 0).

Parameters
csText | Reference to the string to move or add.
arHistory | Reference to the history array.
wndCombo | Reference to the history combobox.
The documentation for this class was generated from the following file:
  • XTPSyntaxEditFindReplaceDlg.h


Toolkit Pro: CXTPSyntaxEditGoToLineDlg Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPSyntaxEditGoToLineDlg Class Reference

This class implements the "GoToLine" dialog for a SyntaxEdit control. More...

Public Member Functions

CXTPSyntaxEditGoToLineDlg (CWnd *pParent=NULL)
Default object constructor.
BOOL ShowDialog (CXTPSyntaxEditCtrl *pEditCtrl, BOOL bSelectLine=FALSE, BOOL bHideOnFind=FALSE)
Shows the "GoToLine" dialog.

Protected Member Functions

virtual BOOL | LoadPos ()
Loads window position from the application profile.
virtual BOOL | SavePos ()
Saves window position to the application profile.

Protected Attributes

int | m_iMaxLineNo
Maximum line number.
BOOL | m_bHideOnFind
Hide On Find option.
BOOL | m_bSelectLine
Select Line option.
CPoint | m_ptWndPos
Window position.
CXTPSyntaxEditCtrl * | m_pEditCtrl
Pointer to the attached edit control.

Detailed Description

This class implements the "GoToLine" dialog for a SyntaxEdit control.

Constructor & Destructor Documentation

◆ CXTPSyntaxEditGoToLineDlg()

CXTPSyntaxEditGoToLineDlg ( CWnd * pParent = NULL )

Default object constructor.

Parameters
pParent Pointer to a parent window.

Member Function Documentation

◆ LoadPos()

virtual BOOL LoadPos ( )
protectedvirtual

Loads window position from the application profile.

Returns
TRUE if successful, otherwise FALSE.

◆ SavePos()

virtual BOOL SavePos ( )
protectedvirtual

Saves window position to the application profile.

Returns
TRUE if successful, otherwise FALSE.

◆ ShowDialog()

BOOL ShowDialog | ( | CXTPSyntaxEditCtrl * | pEditCtrl,
 |  | BOOL | bSelectLine = FALSE,
 |  | BOOL | bHideOnFind = FALSE )

Shows the "GoToLine" dialog.

If a window has not been created, then this method will load a dialog template from resources and create a modeless dialog.

Parameters
pEditCtrl | Pointer to a CXTPSyntaxEditCtrl object.
bSelectLine | Select Line option.
bHideOnFind | Hide On Find option.
Returns
TRUE if successful, otherwise FALSE.
See also
ShowWindow
The documentation for this class was generated from the following file:
  • XTPSyntaxEditGoToLineDlg.h


Toolkit Pro: CXTPSyntaxEditInsertStringCommand Class Reference

Public Member Functions | List of all members
CXTPSyntaxEditInsertStringCommand Class Reference

This class represents the insert string command. More...

Inheritance diagram for CXTPSyntaxEditInsertStringCommand:
[legend]

Public Member Functions

CXTPSyntaxEditInsertStringCommand (CXTPSyntaxEditBufferManager *pMgr, LPCTSTR szText, const XTP_EDIT_LINECOL &lcFrom, const XTP_EDIT_LINECOL &lcTo)
Creates the insert string command object, initializes its members.
virtual | ~CXTPSyntaxEditInsertStringCommand ()
A default command destructor.
virtual int | Execute (XTP_EDIT_LINECOL &lcFrom, XTP_EDIT_LINECOL &lcTo, CXTPSyntaxEditCtrl *pEditCtrl)
Executes the insert string command.
virtual int | UnExecute (XTP_EDIT_LINECOL &lcFrom, XTP_EDIT_LINECOL &lcTo, CXTPSyntaxEditCtrl *pEditCtrl)
Unexecutes the insert string command (i.e.
- Public Member Functions inherited from CXTPSyntaxEditBufferCommand
virtual | ~CXTPSyntaxEditBufferCommand ()
A default command destructor.
- Public Member Functions inherited from CXTPSyntaxEditCommand
virtual | ~CXTPSyntaxEditCommand ()
A default command destructor.
virtual LPCTSTR | GetCommandText () const
Gets command text.
virtual void | SetCommandText (LPCTSTR szText)
Sets command text.

Additional Inherited Members

- Protected Member Functions inherited from CXTPSyntaxEditBufferCommand
CXTPSyntaxEditBufferCommand (CXTPSyntaxEditBufferManager *pMgr, LPCTSTR szText, const XTP_EDIT_LINECOL &lcFrom, const XTP_EDIT_LINECOL &lcTo)
Creates the buffer command object, initializes its members.
int | DoInsertText (XTP_EDIT_LINECOL &lcFrom, XTP_EDIT_LINECOL &lcTo, CXTPSyntaxEditCtrl *pEditCtrl)
Inserts the stored text at the stored positions and returns the start and final affected text positions.
int | DoDeleteText (XTP_EDIT_LINECOL &lcFrom, XTP_EDIT_LINECOL &lcTo, CXTPSyntaxEditCtrl *pEditCtrl)
Deletes the text at the stored positions and returns the start and final affected text positions.
virtual int | GetDataSize () const
Gets the undo command data size (in bytes).
- Protected Member Functions inherited from CXTPSyntaxEditCommand
CXTPSyntaxEditCommand ()
Protected constructor because this class could not be instantiated itself, only by its descendants.
- Static Protected Member Functions inherited from CXTPSyntaxEditCommand
static void AFX_CDECL | SetPositionInternally (CXTPSyntaxEditCtrl *pEditCtrl, const XTP_EDIT_LINECOL &lcPos)
Sets the line and column position for the specified control using internal fast methods.
- Protected Attributes inherited from CXTPSyntaxEditBufferCommand
CXTPSyntaxEditBufferManager * | m_pBufferMgr
Pointer to the associated text buffer.
CString | m_strText
Changed text.
XTP_EDIT_LINECOL | m_lcFrom
Start edit position.
XTP_EDIT_LINECOL | m_lcTo
End edit position.
- Protected Attributes inherited from CXTPSyntaxEditCommand
CString | m_strCommandText
Text description of the command.

Detailed Description

This class represents the insert string command.

Command execution will insert specified text in the buffer and un-execution will delete this text from the buffer.

See also
CXTPSyntaxEditBufferCommand, CXTPSyntaxEditDeleteStringCommand

Constructor & Destructor Documentation

◆ CXTPSyntaxEditInsertStringCommand()

CXTPSyntaxEditInsertStringCommand | ( | CXTPSyntaxEditBufferManager * | pMgr,
 |  | LPCTSTR | szText,
 |  | const XTP_EDIT_LINECOL & | lcFrom,
 |  | const XTP_EDIT_LINECOL & | lcTo )

Creates the insert string command object, initializes its members.

Parameters
pMgr | [in] Pointer to the associated buffer manager object.
szText | [in] Text which was changed during the buffer operation. It will be used for insert/remove text operations.
lcFrom | [in] Start text position affected by the command.
lcTo | [in] End text position affected by the command.

◆ ~CXTPSyntaxEditInsertStringCommand()

virtual ~CXTPSyntaxEditInsertStringCommand ( )
virtual

A default command destructor.

Destroys the command object, handles its cleanup and de-allocation.

Member Function Documentation

◆ Execute()

virtual int Execute | ( | XTP_EDIT_LINECOL & | lcFrom,
 |  | XTP_EDIT_LINECOL & | lcTo,
 |  | CXTPSyntaxEditCtrl * | pEditCtrl )
 virtual

Executes the insert string command.

Parameters
lcFrom | [out] Start text position affected by the command.
lcTo | [out] End text position affected by the command.
pEditCtrl | [in] Pointer to the edit control.
Returns
A bitwise combination of the edit actions that occurred: XTP_EDIT_EDITACTION_MODIFYROW, XTP_EDIT_EDITACTION_INSERTROW
See also
UnExecute

Implements CXTPSyntaxEditCommand.

◆ UnExecute()

virtual int UnExecute | ( | XTP_EDIT_LINECOL & | lcFrom,
 |  | XTP_EDIT_LINECOL & | lcTo,
 |  | CXTPSyntaxEditCtrl * | pEditCtrl )
 virtual

Unexecutes the insert string command (i.e.

deletes the string).

Parameters
lcFrom | [out] Start text position affected by the command.
lcTo | [out] End text position affected by the command.
pEditCtrl | [in] Pointer to the edit control.
Returns
A bitwise combination of the edit actions that occurred: XTP_EDIT_EDITACTION_MODIFYROW, XTP_EDIT_EDITACTION_DELETEROW
See also
Execute

Implements CXTPSyntaxEditCommand.

The documentation for this class was generated from the following file:
  • XTPSyntaxEditUndoManager.h


Toolkit Pro: CXTPSyntaxEditLexClass Class Reference

Public Types | Public Member Functions | Static Public Member Functions | Public Attributes | Protected Member Functions | List of all members
CXTPSyntaxEditLexClass Class Reference

CXTPSyntaxEditLexClass class is used to represent lexical block of text definition and to parse text. More...

Inheritance diagram for CXTPSyntaxEditLexClass:
[legend]

Public Types

typedef CXTPSyntaxEditLexObj_SpecCollT< CXTPSyntaxEditLexObj_Previous, CXTPSyntaxEditLexObj_Start, CXTPSyntaxEditLexObj_End, CXTPSyntaxEditLexObj_Token, CXTPSyntaxEditLexObj_Skip, CXTPSyntaxEditLexObj_ActiveTags > TBase
CXTPSyntaxEditLexClass::TBase is the base collection type for CXTPSyntaxEditLexClass.

Public Member Functions

CXTPSyntaxEditLexClass ()
Default object constructor.
virtual | ~CXTPSyntaxEditLexClass ()
Default object destructor.
virtual CXTPSyntaxEditLexVariantPtr | PropV (LPCTSTR pcszPropName)
Get object property by property name.
virtual CString | GetClassName () const
Get Lex Class name.
virtual BOOL | IsCaseSensitive ()
Is Lex Class case sensitive.
virtual int | IsCollapsable ()
Is Lex Class Collapsable.
virtual void | GetTextAttributes (XTP_EDIT_TEXTBLOCK &rTB)
Is Lex Class Collapsable.
virtual void | Close ()
Close Lex Class.
virtual CXTPSyntaxEditLexVariantPtr | GetAttribute (LPCTSTR strName, BOOL bDyn) const
Get Lex Class attribute by attribute name.
virtual BOOL | GetAttribute_BOOL (LPCTSTR strName, BOOL bDyn, BOOL bDefault=FALSE) const
Get Lex Class attribute by attribute name.
virtual int | GetAttribute_int (LPCTSTR strName, BOOL bDyn, int nDefault=0) const
Get Lex Class attribute by attribute name.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Static Public Member Functions

static void AFX_CDECL | CloseClasses (CXTPSyntaxEditLexClassPtrArray *pArClasses)
Close specified Lex Classes.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Public Attributes

int m_nActiv_EndTags_Offset
First index of end active tags set in the Active Tags collection (m_ActiveTags member).

Protected Member Functions

virtual void | SetAttribute (CString strName, const CXTPSyntaxEditLexVariant &rVal)
Sets Lex Class attribute.
virtual CXTPSyntaxEditLexClassPtrArray * | GetChildren ()
Get specified children for the Lex Class.
virtual CXTPSyntaxEditLexClassPtrArray * | GetChildrenDyn ()
Get specified children for the Lex Class.
virtual CXTPSyntaxEditLexClassPtrArray * | GetChildrenSelfRef ()
Get specified children for the Lex Class.
virtual CXTPSyntaxEditLexObj_ActiveTags * | GetActiveTags ()
Get active tags for the Lex Class.
virtual int | RunParse (CTextIter *pTxtIter, CXTPSyntaxEditLexTextSchema *pTxtSch, CXTPSyntaxEditLexTextBlockPtr &rPtrTxtBlock, CXTPSyntaxEditLexOnScreenParseCnt *pOnScreenRunCnt=NULL)
This function does the parsing.

Detailed Description

CXTPSyntaxEditLexClass class is used to represent lexical block of text definition and to parse text.

See also
CXTPSyntaxEditLexClassSchema, CXTPSyntaxEditLexObj_SpecCollT.

Member Typedef Documentation

◆ TBase

CXTPSyntaxEditLexObj_SpecCollT< CXTPSyntaxEditLexObj_Previous, CXTPSyntaxEditLexObj_Start, CXTPSyntaxEditLexObj_End, CXTPSyntaxEditLexObj_Token, CXTPSyntaxEditLexObj_Skip, CXTPSyntaxEditLexObj_ActiveTags> TBase

CXTPSyntaxEditLexClass::TBase is the base collection type for CXTPSyntaxEditLexClass.

It is used to access base members and types.

See also
CXTPSyntaxEditLexClassSchema, CXTPSyntaxEditLexObj_SpecCollT.

Member Function Documentation

◆ Close()

virtual void Close ( )
virtual

Close Lex Class.

Kill All relations between this class and parent and children. Close children classes. Clear internal collections. Close() must be called as first step in destroy object procedure. The second step is InternalRelease() call.

See also
CXTPSyntaxEditLexClass::CloseClasses()

◆ CloseClasses()

static void AFX_CDECL CloseClasses ( CXTPSyntaxEditLexClassPtrArray * pArClasses )
static

Close specified Lex Classes.

Parameters
pArClasses [in] Pointer to the classes array.

Call Close() method for every Lex Class in the specified array. Remove all objects from the array.

Returns
See also
CXTPSyntaxEditLexClass::Close()

◆ GetActiveTags()

AFX_INLINE CXTPSyntaxEditLexObj_ActiveTags * GetActiveTags ( )
protectedvirtual

Get active tags for the Lex Class.

Returns
A pointer to lex object active tags object.

◆ GetAttribute()

virtual CXTPSyntaxEditLexVariantPtr GetAttribute | ( | LPCTSTR | strName,
 |  | BOOL | bDyn ) const
 virtual

Get Lex Class attribute by attribute name.

Parameters
strName | [in] Attribute name.
bDyn | [in] If FALSE attribute value is searched only in this class attribute collection; If TRUE attribute value is searched in this class attribute collection at the first and, if value is not finded, it is searched in parent(s) class(es) attribute collection(s).
Returns
Attribute value or NULL or default value.

Call this method to access Lex Classes attributes, like "txt:colorFG", ...

See also
XTPLEX_ATTR_*, SetAttribute(), Classes schema syntax.

◆ GetAttribute_BOOL()

AFX_INLINE BOOL GetAttribute_BOOL | ( | LPCTSTR | strName,
 |  | BOOL | bDyn,
 |  | BOOL | bDefault = FALSE ) const
 virtual

Get Lex Class attribute by attribute name.

Parameters
strName | [in] Attribute name.
bDyn | [in] If FALSE attribute value is searched only in this class attribute collection; If TRUE attribute value is searched in this class attribute collection at the first and, if value is not finded, it is searched in parent(s) class(es) attribute collection(s).
bDefault | [in] Default BOOL value.
Returns
Attribute value or NULL or default value.

Call this method to access Lex Classes attributes, like "txt:colorFG", ...

See also
XTPLEX_ATTR_*, SetAttribute(), Classes schema syntax.

◆ GetAttribute_int()

AFX_INLINE int GetAttribute_int | ( | LPCTSTR | strName,
 |  | BOOL | bDyn,
 |  | int | nDefault = 0 ) const
 virtual

Get Lex Class attribute by attribute name.

Parameters
strName | [in] Attribute name.
bDyn | [in] If FALSE attribute value is searched only in this class attribute collection; If TRUE attribute value is searched in this class attribute collection at the first and, if value is not finded, it is searched in parent(s) class(es) attribute collection(s).
nDefault | [in] Default int value.
Returns
Attribute value or NULL or default value.

Call this method to access Lex Classes attributes, like "txt:colorFG", ...

See also
XTPLEX_ATTR_*, SetAttribute(), Classes schema syntax.

◆ GetChildren()

virtual CXTPSyntaxEditLexClassPtrArray * GetChildren ( )
protectedvirtual

Get specified children for the Lex Class.

Returns
A pointer to lex class pointer array.

Call this method(s) to get pointer to the array which contains children classes.

See also
GetChildren(), GetChildrenDyn(), GetChildrenSelfRef().

◆ GetChildrenDyn()

virtual CXTPSyntaxEditLexClassPtrArray * GetChildrenDyn ( )
protectedvirtual

Get specified children for the Lex Class.

Returns
A pointer to lex class pointer array.

Call this method(s) to get pointer to the array which contains children classes.

See also
GetChildren(), GetChildrenDyn(), GetChildrenSelfRef().

◆ GetChildrenSelfRef()

virtual CXTPSyntaxEditLexClassPtrArray * GetChildrenSelfRef ( )
protectedvirtual

Get specified children for the Lex Class.

Returns
A pointer to lex class pointer array.

Call this method(s) to get pointer to the array which contains children classes.

See also
GetChildren(), GetChildrenDyn(), GetChildrenSelfRef().

◆ GetClassName()

AFX_INLINE CString GetClassName ( ) const
virtual

Get Lex Class name.

Returns
Lex Class name.

Lex Class name is specified in classes schema file by 'name' property.

See also
Classes schema syntax.

◆ GetTextAttributes()

virtual void GetTextAttributes ( XTP_EDIT_TEXTBLOCK & rTB )
virtual

Is Lex Class Collapsable.

Parameters
rTB [out] Pointer to the classes array.

Use this method instead of GetAttribute() to fast access "Collapsable" attribute value.

See also
GetAttribute(), XTPLEX_ATTR_COLLAPSABLE, Classes schema syntax.

◆ IsCaseSensitive()

virtual BOOL IsCaseSensitive ( )
virtual

Is Lex Class case sensitive.

Returns
"CaseSensitive" attribute value..

Use this method instead of GetAttribute() to fast access "CaseSensitive" attribute value.

See also
GetAttribute(), XTPLEX_ATTR_CASESENSITIVE, Classes schema syntax.

◆ IsCollapsable()

virtual int IsCollapsable ( )
virtual

Is Lex Class Collapsable.

Returns
"Collapsable" attribute value..

Use this method instead of GetAttribute() to fast access "Collapsable" attribute value.

See also
GetAttribute(), XTPLEX_ATTR_COLLAPSABLE, Classes schema syntax.

◆ PropV()

virtual CXTPSyntaxEditLexVariantPtr PropV ( LPCTSTR pcszPropName )
virtual

Get object property by property name.

Parameters
pcszPropName [in] Property name.
Returns
Smart pointer to CXTPSyntaxEditLexVariant object with type xtpEditLVT_LVArrayPtr.

Property names are parent collection (TBase) sub-objects names; like "start:tag", "token:start:separators", ... For details see Classes schema syntax and CXTPSyntaxEditLexClass::TBase.

See also
CXTPSyntaxEditLexClass::TBase, Classes schema syntax.

◆ RunParse()

virtual int RunParse | ( | CTextIter * | pTxtIter,
 |  | CXTPSyntaxEditLexTextSchema * | pTxtSch,
 |  | CXTPSyntaxEditLexTextBlockPtr & | rPtrTxtBlock,
 |  | CXTPSyntaxEditLexOnScreenParseCnt * | pOnScreenRunCnt = NULL )
 protectedvirtual

This function does the parsing.

Parameters
pTxtIter | The text iterator.
pTxtSch | The text schema.
rPtrTxtBlock | The text block.
pOnScreenRunCnt | On screen parse context.
Returns
A XTPSyntaxEditLexParseResult value.

◆ SetAttribute()

virtual void SetAttribute | ( | CString | strName,
 |  | const CXTPSyntaxEditLexVariant & | rVal )
 protectedvirtual

Sets Lex Class attribute.

Parameters
strName | [in] Attribute name.
rVal | [in] Attribute value.

Call this method to set Lex Class attributes, like "txt:colorFG", ...

See also
XTPLEX_ATTR_*, GetAttribute(), Classes schema syntax.
The documentation for this class was generated from the following file:
  • XTPSyntaxEditLexClass.h


Toolkit Pro: CXTPSyntaxEditLexOnScreenParseCnt Class Reference

Public Member Functions | Public Attributes | List of all members
CXTPSyntaxEditLexOnScreenParseCnt Class Reference

CXTPSyntaxEditLexOnScreenParseCnt provides context data storage for OnScreen iterated parsing process. More...

Public Member Functions

CXTPSyntaxEditLexOnScreenParseCnt ()
Default object constructor.
virtual ~CXTPSyntaxEditLexOnScreenParseCnt ()
Default object destructor.

Public Attributes

int | m_nRowStart
Start row for parse.
int | m_nRowEnd
End row for parse.
CXTPSyntaxEditLexTextBlockPtr | m_ptrTBLast
Latest found text block.

Detailed Description

CXTPSyntaxEditLexOnScreenParseCnt provides context data storage for OnScreen iterated parsing process.

See also
CXTPSyntaxEditLexClass, CXTPSyntaxEditLexTextSchema
The documentation for this class was generated from the following file:
  • XTPSyntaxEditLexClass.h


Toolkit Pro: CXTPSyntaxEditLexParser Class Reference

Public Member Functions | List of all members
CXTPSyntaxEditLexParser Class Reference

This class used to 'run' lex schema parsing in a separate thread. More...

Inheritance diagram for CXTPSyntaxEditLexParser:
[legend]

Public Member Functions

CXTPSyntaxEditLexParser ()
Default object constructor.
virtual | ~CXTPSyntaxEditLexParser ()
Object destructor.
virtual void | Close ()
Stops parsing, destroys the working thread, and unadvises from all events.
virtual void | CloseParseThread ()
Stops parsing and destroys the working thread.
virtual void | StartParseInThread (CXTPSyntaxEditBufferManager *pBuffer, const XTP_EDIT_LINECOL *pLCStart=NULL, const XTP_EDIT_LINECOL *pLCEnd=NULL, int eEditAction=0, BOOL bRunWithoutWait=FALSE)
Starts parsing a specified text range in a separate (working) thread.
virtual void | StopParseInThread ()
Stops parsing in thread.
virtual void | OnBeforeEditChanged ()
Stops parsing in thread before a call to OnEditChanged.
virtual void | OnEditChanged (const XTP_EDIT_LINECOL &posFrom, const XTP_EDIT_LINECOL &posTo, int eEditAction, CXTPSyntaxEditBufferManager *pBuffer)
Reparses text after editing.
virtual CXTPSyntaxEditLexTextSchema * | GetTextSchema ()
Gets the active text schema.
virtual void | SetTextSchema (CXTPSyntaxEditLexTextSchema *pTextSchema)
Sets the active text schema.
virtual const CXTPSyntaxEditLexParserSchemaOptions * | GetSchemaOptions (const CString &strExt)
Gets the schema options.
virtual int | GetParseThreadPriority ()
Gets the priority of the working thread.
virtual BOOL | SetParseThreadPriority (int nPriority)
Sets the priority for the working thread.
virtual BOOL | GetTokensForAutoCompleate (CXTPSyntaxEditLexTokensDefArray &rArTokens, BOOL bAppend)
Gets the auto-complete words of the active text schema.
virtual CXTPNotifyConnection * | GetConnection ()
Gets the notification connection.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

This class used to 'run' lex schema parsing in a separate thread.

It also controls this working thread and provides inter-thread interaction.

Constructor & Destructor Documentation

◆ ~CXTPSyntaxEditLexParser()

virtual ~CXTPSyntaxEditLexParser ( )
virtual

Object destructor.

Handles clean up and deallocations.

Member Function Documentation

◆ Close()

virtual void Close ( )
virtual

Stops parsing, destroys the working thread, and unadvises from all events.

See also
CloseParseThread, StopParseInThread

◆ CloseParseThread()

virtual void CloseParseThread ( )
virtual

Stops parsing and destroys the working thread.

See also
Close, StopParseInThread

◆ GetConnection()

virtual CXTPNotifyConnection * GetConnection ( )
virtual

Gets the notification connection.

Returns
A pointer to the notification connection.

◆ GetParseThreadPriority()

virtual int GetParseThreadPriority ( )
virtual

Gets the priority of the working thread.

Returns
The priority of the working thread.
See also
SetParseThreadPriority, CWinThread::GetThreadPriority

◆ GetSchemaOptions()

virtual const CXTPSyntaxEditLexParserSchemaOptions * GetSchemaOptions ( const CString & strExt )
virtual

Gets the schema options.

Parameters
strExt Reference to a file extension to lookup schema.
Returns
A pointer to the schema options.

◆ GetTextSchema()

virtual CXTPSyntaxEditLexTextSchema * GetTextSchema ( )
virtual

Gets the active text schema.

Returns
A pointer to the active text schema.
See also
SetTextSchema

◆ GetTokensForAutoCompleate()

virtual BOOL GetTokensForAutoCompleate | ( | CXTPSyntaxEditLexTokensDefArray & | rArTokens,
 |  | BOOL | bAppend )
 virtual

Gets the auto-complete words of the active text schema.

Parameters
rArTokens | Reference to an array to receive the auto-complete words of the active text schema.
bAppend | TRUE to append to the contents of the specified array, FALSE to replace the contents of the specified array.
Returns
TRUE if successful, otherwise FALSE.

◆ OnBeforeEditChanged()

virtual void OnBeforeEditChanged ( )
virtual

Stops parsing in thread before a call to OnEditChanged.

See also
OnEditChanged

◆ OnEditChanged()

virtual void OnEditChanged | ( | const XTP_EDIT_LINECOL & | posFrom,
 |  | const XTP_EDIT_LINECOL & | posTo,
 |  | int | eEditAction,
 |  | CXTPSyntaxEditBufferManager * | pBuffer )
 virtual

Reparses text after editing.

Parameters
posFrom | Reference to the start position for the edit action.
posTo | Reference to the end position for the edit action.
eEditAction | Edit action; must be one of the values defined by the XTPSyntaxEditEditAction enumeration.
pBuffer | Pointer to a CXTPSyntaxEditBufferManager object.
See also
OnBeforeEditChanged

◆ SetParseThreadPriority()

virtual BOOL SetParseThreadPriority ( int nPriority )
virtual

Sets the priority for the working thread.

Parameters
nPriority Priority to be set.
Returns
TRUE if successful, otherwise FALSE.
See also
GetParseThreadPriority, CWinThread::GetThreadPriority

◆ SetTextSchema()

virtual void SetTextSchema ( CXTPSyntaxEditLexTextSchema * pTextSchema )
virtual

Sets the active text schema.

Parameters
pTextSchema Pointer to a text schema to be set.
See also
GetTextSchema

◆ StartParseInThread()

virtual void StartParseInThread | ( | CXTPSyntaxEditBufferManager * | pBuffer,
 |  | const XTP_EDIT_LINECOL * | pLCStart = NULL,
 |  | const XTP_EDIT_LINECOL * | pLCEnd = NULL,
 |  | int | eEditAction = 0,
 |  | BOOL | bRunWithoutWait = FALSE )
 virtual

Starts parsing a specified text range in a separate (working) thread.

Parameters
pBuffer | Pointer to a CXTPSyntaxEditBufferManager object.
pLCStart | Pointer to the start text position. Set to NULL to parse from the beginning.
pLCEnd | Pointer to the end text position. Set to NULL to parse until the end.
eEditAction | Edit action; must be either 0 or one of the values defined by the XTPSyntaxEditEditAction enumeration.
bRunWithoutWait | TRUE to start parsing immediately, FALSE to wait until the timeout specified in global schema options.

If the parser is already running and parsing another text range, then the specified text range will be added to a queue.

See also
StopParseInThread, CloseParseThread

◆ StopParseInThread()

virtual void StopParseInThread ( )
virtual

Stops parsing in thread.

See also
Close, StartParseInThread
The documentation for this class was generated from the following file:
  • XTPSyntaxEditLexParser.h


Toolkit Pro: CXTPSyntaxEditLexParserSchemaOptions Class Reference

Public Member Functions | Public Attributes | List of all members
CXTPSyntaxEditLexParserSchemaOptions Class Reference

This class is designed to easily manipulate parser options. More...

Inheritance diagram for CXTPSyntaxEditLexParserSchemaOptions:
[legend]

Public Member Functions

CXTPSyntaxEditLexParserSchemaOptions ()
Default object constructor.
CXTPSyntaxEditLexParserSchemaOptions (const CXTPSyntaxEditLexParserSchemaOptions &rSrc)
Object constructor.
const CXTPSyntaxEditLexParserSchemaOptions & operator= (const CXTPSyntaxEditLexParserSchemaOptions &rSrc)
Overloaded equals operator.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Public Attributes

BOOL | m_bFirstParseInSeparateThread
{0,1} default=1
BOOL | m_bEditReparceInSeparateThread
{0,1} default=1
BOOL | m_bConfigChangedReparceInSeparateThread
{0,1} default=1
DWORD | m_dwMaxBackParseOffset
default=100; maximum back buffer size.
DWORD | m_dwEditReparceTimeout_ms
default=500 ms; time out for start reparse after last key was pressed.
DWORD | m_dwOnScreenSchCacheLifeTime_sec
default=180 sec; time out for on screen parsed pices of text.
DWORD | m_dwParserThreadIdleLifeTime_ms
default=60 sec; time out for existing of parser thread when parser idle (no parse requests).

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

This class is designed to easily manipulate parser options.

Constructor & Destructor Documentation

◆ CXTPSyntaxEditLexParserSchemaOptions()

CXTPSyntaxEditLexParserSchemaOptions ( const CXTPSyntaxEditLexParserSchemaOptions & rSrc )

Object constructor.

Parameters
rSrc [in] Reference to source CXTPSyntaxEditLexParserSchemaOptions object.

Member Function Documentation

◆ operator=()

const CXTPSyntaxEditLexParserSchemaOptions & operator= ( const CXTPSyntaxEditLexParserSchemaOptions & rSrc )

Overloaded equals operator.

Parameters
rSrc [in] Reference to source CXTPSyntaxEditLexParserSchemaOptions object.

Member Data Documentation

◆ m_dwMaxBackParseOffset

DWORD m_dwMaxBackParseOffset

default=100; maximum back buffer size.

Some times parser look back for the text from current position.

◆ m_dwOnScreenSchCacheLifeTime_sec

DWORD m_dwOnScreenSchCacheLifeTime_sec

default=180 sec; time out for on screen parsed pices of text.

for memory using optimization.

The documentation for this class was generated from the following file:
  • XTPSyntaxEditLexParser.h


Toolkit Pro: CXTPSyntaxEditLexTextBlock Class Reference

Public Member Functions | Public Attributes | Protected Attributes | List of all members
CXTPSyntaxEditLexTextBlock Class Reference

The CXTPSyntaxEditLexTextBlock class represents a block of text which corresponds to a lex class in a text schema. More...

Inheritance diagram for CXTPSyntaxEditLexTextBlock:
[legend]

Public Member Functions

CXTPSyntaxEditLexTextBlock ()
Default object constructor.
virtual | ~CXTPSyntaxEditLexTextBlock ()
Object destructor.
XTP_EDIT_LINECOL | GetPosEndLC (BOOL bMaxIfInvalid=TRUE)
Gets the text block end position.
DWORD | GetStartTagEndXLC ()
Gets the text block start tag end position in the text.
DWORD | GetEndTagBeginXLC ()
Gets the text block end tag begin position in the text.
DWORD | GetEndTagEndXLC ()
Gets the text block end tag end position in the text.
virtual void | Close ()
Releases references to other objects.
virtual BOOL | IsEqualLexClasses (CXTPSyntaxEditLexTextBlock *pTB2) const
Determines if the lex class name of a specified text block is equal to the lex class name of the current text block.
virtual BOOL | IsInclude (CXTPSyntaxEditLexTextBlock *pTB2) const
Determines if a specified text block is included within the current text block.
virtual BOOL | IsLookLikeClosed () const
Determines if the current text block appears to be partly closed or closed.
virtual int | EndChildren (CXTPSyntaxEditLexTextSchema *pTxtSch=NULL, BOOL bEndByParent=TRUE)
Sets the end position to not ended children blocks.
virtual CXTPSyntaxEditLexTextBlock * | GetPrevChild (CXTPSyntaxEditLexTextBlock *pChild, BOOL bWithAddRef)
Gets the previous child block from a specified child block.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Public Attributes

CXTPSyntaxEditLexClassPtr | m_ptrLexClass
Pointer to the LexClass object.
CXTPSyntaxEditLexTextBlockPtr | m_ptrParent
Pointer to the parent block object.
CXTPSyntaxEditLexTextBlockPtr | m_ptrPrev
Pointer to the previous block.
CXTPSyntaxEditLexTextBlockPtr | m_ptrNext
Pointer to the next block.
XTP_EDIT_LINECOL | m_PosStartLC
Text block start position.
XTP_EDIT_LINECOL | m_PosEndLC
Text block start position.
BOOL | m_bEndByParent
Text block ended when the parent block ended.

Protected Attributes

int | m_nStartTagLen
Start tag length.
int | m_nEndTagXLCLen
End tag length in XLC form.
CXTPSyntaxEditLexTextBlockPtr m_ptrLastChild
For internal use only.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

The CXTPSyntaxEditLexTextBlock class represents a block of text which corresponds to a lex class in a text schema.

It stores the start position, end position, and pointer to the lex class object in a class schema along with some other information. Text blocks are organized as a bidirectional list and as a tree structure.

Constructor & Destructor Documentation

◆ ~CXTPSyntaxEditLexTextBlock()

virtual ~CXTPSyntaxEditLexTextBlock ( )
virtual

Object destructor.

Handles clean up and deallocations.

Member Function Documentation

◆ Close()

virtual void Close ( )
virtual

Releases references to other objects.

This method is used in text schema destruction process.

See also
CXTPSyntaxEditLexTextSchema::Close().

◆ EndChildren()

virtual int EndChildren | ( | CXTPSyntaxEditLexTextSchema * | pTxtSch = NULL,
 |  | BOOL | bEndByParent = TRUE )
 virtual

Sets the end position to not ended children blocks.

Parameters
pTxtSch | [in] Text schema pointer to send notifications.
bEndByParent | [in] BOOL flag
Returns
Ended children blocks count.

◆ GetEndTagBeginXLC()

DWORD GetEndTagBeginXLC ( )

Gets the text block end tag begin position in the text.

Returns
The text block end tag begin position in XLC form.
See also
XTP_EDIT_LINECOL::GetXLC(), XTP_EDIT_XLC() macros.

◆ GetEndTagEndXLC()

DWORD GetEndTagEndXLC ( )

Gets the text block end tag end position in the text.

Returns
The text block end tag end position in XLC form.
See also
XTP_EDIT_LINECOL::GetXLC(), XTP_EDIT_XLC() macros.

◆ GetPosEndLC()

XTP_EDIT_LINECOL GetPosEndLC ( BOOL bMaxIfInvalid = TRUE )

Gets the text block end position.

Parameters
bMaxIfInvalid [in] TRUE to get the maximum value if the text block end position is invalid, FALSE to get the minimum value if the text block end position is invalid.
Returns
The text block end position if it is valid. Otherwise the maximum or minimum value depending on bMaxIfInvalid.
See also
XTP_EDIT_LINECOL, m_PosEndLC, m_PosStartLC.

◆ GetPrevChild()

virtual CXTPSyntaxEditLexTextBlock * GetPrevChild | ( | CXTPSyntaxEditLexTextBlock * | pChild,
 |  | BOOL | bWithAddRef )
 virtual

Gets the previous child block from a specified child block.

Parameters
pChild | [in] Pointer to the child block to get the previous child block from.
bWithAddRef | [in] TRUE to call InternalAddRef, FALSE otherwise.

The current text block is the parent block to the two child blocks.

Returns
A pointer to the previous child block if successful, otherwise NULL.

◆ GetStartTagEndXLC()

DWORD GetStartTagEndXLC ( )

Gets the text block start tag end position in the text.

Returns
The text block start tag end position in XLC form.
See also
XTP_EDIT_LINECOL::GetXLC(), XTP_EDIT_XLC() macros.

◆ IsEqualLexClasses()

virtual BOOL IsEqualLexClasses ( CXTPSyntaxEditLexTextBlock * pTB2 ) const
virtual

Determines if the lex class name of a specified text block is equal to the lex class name of the current text block.

Parameters
pTB2 [in] Pointer to a CXTPSyntaxEditLexTextBlock object.
Returns
TRUE if the lex class name of the specified text block is equal to the lex class name of the current text block, otherwise FALSE.

◆ IsInclude()

virtual BOOL IsInclude ( CXTPSyntaxEditLexTextBlock * pTB2 ) const
virtual

Determines if a specified text block is included within the current text block.

Parameters
pTB2 [in] Pointer to a CXTPSyntaxEditLexTextBlock object.
Returns
TRUE if the specified text block is included within the current textblock, otherwise FALSE.

◆ IsLookLikeClosed()

virtual BOOL IsLookLikeClosed ( ) const
virtual

Determines if the current text block appears to be partly closed or closed.

Returns
TRUE if some or all references to other objects are NULL, FALSE otherwise.

Member Data Documentation

◆ m_ptrLastChild

CXTPSyntaxEditLexTextBlockPtr m_ptrLastChild
protected

For internal use only.

This variable does not always contain the correct value.

The documentation for this class was generated from the following file:
  • XTPSyntaxEditLexParser.h


Toolkit Pro: CXTPSyntaxEditLexTextSchema Class Reference

Public Member Functions | Static Public Member Functions | Protected Types | Protected Member Functions | List of all members
CXTPSyntaxEditLexTextSchema Class Reference

The CXTPSyntaxEditLexTextSchema class is used to store data which is necessary to parse a text and parsing results. More...

Inheritance diagram for CXTPSyntaxEditLexTextSchema:
[legend]

Public Member Functions

CXTPSyntaxEditLexTextSchema (LPCTSTR pcszSchName)
Default object constructor.
virtual | ~CXTPSyntaxEditLexTextSchema ()
Object destructor.
virtual CString | GetSchName () const
Gets the text schema name.
virtual void | Close ()
Destroys all interlocked object references and frees all stored objects.
virtual void | RemoveAll ()
Removes all text blocks from the schema.
virtual CXTPSyntaxEditLexTextSchema * | Clone ()
Creates a new text schema object and initializes its internal infrastructure from the current schema.
virtual CXTPNotifyConnection * | GetConnection ()
Gets the notification connection.
virtual int | RunParseUpdate (BOOL bShort, CTextIter *pTxtIter, const XTP_EDIT_LINECOL *pLCStart=NULL, const XTP_EDIT_LINECOL *pLCEnd=NULL, BOOL bSendProgressEvents=FALSE)
Runs parse for the text.
virtual const CXTPSyntaxEditTextRegion & | GetUpdatedTextRegion () const
Gets the text region for which the schema was updated during the last parse/reparse operation.
virtual BOOL | RunParseOnScreen (CTextIter *pTxtIter, int nRowStart, int nRowEnd, CXTPSyntaxEditLexTextBlockPtr &rPtrScreenSchFirstTB)
Runs parse for the text on screen.
virtual void | GetRowColors (CTextIter *pTxtIter, int nRow, int nColFrom, int nColTo, const XTP_EDIT_COLORVALUES &clrDefault, CXTPSyntaxEditTextBlockList *rBlocks, CXTPSyntaxEditLexTextBlockPtr *pptrTBStartCache=NULL, CXTPSyntaxEditLexTextBlock *pFirstSchTB=NULL)
Gets a specified row as a list of blocks with different colors to draw.
virtual void | GetCollapsableBlocksInfo (int nRow, CXTPSyntaxEditRowsBlockArray &rArBlocks, CXTPSyntaxEditLexTextBlockPtr *pptrTBStartCache=NULL)
Gets a specified row as a list of collapsible blocks.
virtual void | GetTextAttributes (XTP_EDIT_TEXTBLOCK &rTB, CXTPSyntaxEditLexTextBlock *pTextBlock)
Gets the text attributes from the lex class of a specified text block.
virtual void | ApplyTheme (CXTPSyntaxEditColorTheme *pTheme)
Applies a specified color theme to this text schema.
BOOL | LoadClassSchema (CXTPSyntaxEditLexClassInfoArray *arClassInfo)
Loads a specified class schema.
BOOL | IsFileExtSupported (const CString &strExt)
Determines if this schema supports a specified file extension.
void | BuildIfNeed ()
Builds the schema if necessary, otherwise does nothing.
CXTPSyntaxEditLexClass * | GetTopClassForFileExt (const CString &strExt)
Gets the top lex class for a specified file extension.
virtual CXTPSyntaxEditLexTextBlock * | GetLastParsedBlock (WPARAM dwID=0)
Retrieves a specified text block by its identifier.
CXTPSyntaxEditLexTextBlock * GetBlocks ()
Gets the first text schema block.
CMutex * | GetDataLoker ()
Gets the critical section object to lock schema data (i.e.
CMutex * | GetClassSchLoker ()
Gets the critical section object to lock class schema.
CEvent * | GetBreakParsingEvent ()
Gets the event object to break the parsing process.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Static Public Member Functions

static void AFX_CDECL | Close (CXTPSyntaxEditLexTextBlock *pFirst)
Destroys the text blocks list.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Protected Types

enum XTPSyntaxEditUpdateTBRes { xtpEditUTBNothing = 0 , xtpEditUTBError = 0x0001 , xtpEditUTBReparse = 0x0002 , xtpEditUTBNearestUpdated = 0x0100 }
This enum describes the set of UpdateTextBlocks return results. More...

Protected Member Functions

CXTPSyntaxEditLexClassSchema * | GetClassSchema ()
Gets the class schema of this text schema.
virtual void | ApplyThemeRecursive (CXTPSyntaxEditColorTheme *pTheme, CXTPSyntaxEditLexClassPtrArray *ptrClasses)
Applies a specified color theme to a specified lex class array.
int | UpdateTextBlocks (XTP_EDIT_LINECOL posFrom, XTP_EDIT_LINECOL posTo, int eEditAction)
Updates text schema positions after an editing action.

Detailed Description

The CXTPSyntaxEditLexTextSchema class is used to store data which is necessary to parse a text and parsing results.

It also contains methods to run lex classes from a class schema, to update text schema when text is edited, to reparse text, to get information which is necessary to draw colorized text, and other helper methods.

Member Enumeration Documentation

◆ XTPSyntaxEditUpdateTBRes

enum XTPSyntaxEditUpdateTBRes
protected

This enum describes the set of UpdateTextBlocks return results.

Enumerator
xtpEditUTBNothing | Void result.
xtpEditUTBError | Error result.
xtpEditUTBReparse | One or few global blocks changed and a reparse is needed.
xtpEditUTBNearestUpdated | This flag is returned from UpdateTBNearest only.

Constructor & Destructor Documentation

◆ CXTPSyntaxEditLexTextSchema()

CXTPSyntaxEditLexTextSchema ( LPCTSTR pcszSchName )

Default object constructor.

Parameters
pcszSchName [in] Text schema name.

◆ ~CXTPSyntaxEditLexTextSchema()

virtual ~CXTPSyntaxEditLexTextSchema ( )
virtual

Object destructor.

Handles clean up and deallocations.

Member Function Documentation

◆ ApplyTheme()

virtual void ApplyTheme ( CXTPSyntaxEditColorTheme * pTheme )
virtual

Applies a specified color theme to this text schema.

Parameters
pTheme [in] Pointer to the color theme to apply.

◆ ApplyThemeRecursive()

virtual void ApplyThemeRecursive | ( | CXTPSyntaxEditColorTheme * | pTheme,
 |  | CXTPSyntaxEditLexClassPtrArray * | ptrClasses )
 protectedvirtual

Applies a specified color theme to a specified lex class array.

Parameters
pTheme | [in] Pointer to the color theme to apply.
ptrClasses | [in] Pointer to a lex class array.
See also
ApplyTheme

◆ BuildIfNeed()

void BuildIfNeed ( )

Builds the schema if necessary, otherwise does nothing.

Call this member function before using a schema object.

In order to make edit control startup faster, schemas are not built during loading. This member function will build the schema if necessary or do nothing otherwise.

◆ Clone()

virtual CXTPSyntaxEditLexTextSchema * Clone ( )
virtual

Creates a new text schema object and initializes its internal infrastructure from the current schema.

This method copies the class schema, but does not copy the text blocks.

Returns
A pointer to the newly created and initialized text schema object.

◆ Close() [1/2]

virtual void Close ( )
virtual

Destroys all interlocked object references and frees all stored objects.

This method deletes the schema object.

See also
RemoveAll, CXTPSyntaxEditLexClassSchema::Close

◆ Close() [2/2]

static void AFX_CDECL Close ( CXTPSyntaxEditLexTextBlock * pFirst )
static

Destroys the text blocks list.

Parameters
pFirst Pointer to the first element in the list to destroy.
See also
CXTPSyntaxEditLexTextBlock::Close

◆ GetBlocks()

CXTPSyntaxEditLexTextBlock * GetBlocks ( )

Gets the first text schema block.

InternalAddRef is called for the returned object.

Returns
A pointer to the first text schema block if successful, otherwise NULL.

◆ GetBreakParsingEvent()

CEvent * GetBreakParsingEvent ( )

Gets the event object to break the parsing process.

Returns
A pointer to the event object.

◆ GetClassSchema()

CXTPSyntaxEditLexClassSchema * GetClassSchema ( )
protected

Gets the class schema of this text schema.

InternalAddRef is called for the returned object.

Returns
A pointer to the class schema of this text schema.

◆ GetClassSchLoker()

CMutex * GetClassSchLoker ( )

Gets the critical section object to lock class schema.

Returns
A pointer to the critical section object.

◆ GetCollapsableBlocksInfo()

virtual void GetCollapsableBlocksInfo | ( | int | nRow,
 |  | CXTPSyntaxEditRowsBlockArray & | rArBlocks,
 |  | CXTPSyntaxEditLexTextBlockPtr * | pptrTBStartCache = NULL )
 virtual

Gets a specified row as a list of collapsible blocks.

Parameters
nRow | [in] Row identifier. Passing a negative value will return the blocks for all rows.
rArBlocks | [out] Reference to a CXTPSyntaxEditRowsBlockArray object to receive the list of collapsable blocks.
pptrTBStartCache | [in, out] Reference to a cached text block to start the search. The value of this parameter may be NULL.

◆ GetConnection()

virtual CXTPNotifyConnection * GetConnection ( )
virtual

Gets the notification connection.

Returns
A pointer to the notification connection.

◆ GetDataLoker()

CMutex * GetDataLoker ( )

Gets the critical section object to lock schema data (i.e.

text blocks and others).

Returns
A pointer to the critical section object.

◆ GetLastParsedBlock()

virtual CXTPSyntaxEditLexTextBlock * GetLastParsedBlock ( WPARAM dwID = 0 )
virtual

Retrieves a specified text block by its identifier.

Parameters
dwID [in] Identifier of the text block to retrieve (obtained from an xtpEditOnTextBlockParsed notification).

This method should be used together with an xtpEditOnTextBlockParsed notification.

InternalAddRef is called for the returned object.

Returns
A pointer to the text block if successful, otherwise NULL.

◆ GetRowColors()

virtual void GetRowColors | ( | CTextIter * | pTxtIter,
 |  | int | nRow,
 |  | int | nColFrom,
 |  | int | nColTo,
 |  | const XTP_EDIT_COLORVALUES & | clrDefault,
 |  | CXTPSyntaxEditTextBlockList * | rBlocks,
 |  | CXTPSyntaxEditLexTextBlockPtr * | pptrTBStartCache = NULL,
 |  | CXTPSyntaxEditLexTextBlock * | pFirstSchTB = NULL )
 virtual

Gets a specified row as a list of blocks with different colors to draw.

Parameters
pTxtIter | [in] Pointer to a CTextIter object.
nRow | [in] Row identifier.
nColFrom | [in] Start column.
nColTo | [in] End column.
clrDefault | [in] Reference to an XTP_EDIT_COLORVALUES structure containing the default colors.
rBlocks | [out] Pointer to a CXTPSyntaxEditTextBlockList object to receive the list of color blocks.
pptrTBStartCache | [in, out] Reference to a cached text block to start the search. The value of this parameter may be NULL.
pFirstSchTB | [in] Reference to the first block of the external text schema or NULL. This parameter is used for OnScreen schemas.

◆ GetSchName()

virtual CString GetSchName ( ) const
virtual

Gets the text schema name.

Returns
The text schema name.

◆ GetTextAttributes()

virtual void GetTextAttributes | ( | XTP_EDIT_TEXTBLOCK & | rTB,
 |  | CXTPSyntaxEditLexTextBlock * | pTextBlock )
 virtual

Gets the text attributes from the lex class of a specified text block.

Parameters
rTB | [out] Reference to an XTP_EDIT_TEXTBLOCK structure to receive the text attributes.
pTextBlock | [in] Pointer to a CXTPSyntaxEditLexTextBlock object.

◆ GetTopClassForFileExt()

CXTPSyntaxEditLexClass * GetTopClassForFileExt ( const CString & strExt )

Gets the top lex class for a specified file extension.

Parameters
strExt [in] Reference to the file extension.

Extension string format: ".ext" For example: ".cpp" InternalAddRef is called for the returned object.

Returns
A pointer to the lex class if successful, otherwise NULL.

◆ GetUpdatedTextRegion()

virtual const CXTPSyntaxEditTextRegion & GetUpdatedTextRegion ( ) const
virtual

Gets the text region for which the schema was updated during the last parse/reparse operation.

Returns
A reference to a CXTPSyntaxEditTextRegion object.

◆ IsFileExtSupported()

BOOL IsFileExtSupported ( const CString & strExt )

Determines if this schema supports a specified file extension.

Parameters
strExt [in] Reference to the file extension.

Extension string format: ".ext" For example: ".cpp"

Returns
TRUE if the specified file extension is supported, otherwise FALSE.

◆ LoadClassSchema()

BOOL LoadClassSchema ( CXTPSyntaxEditLexClassInfoArray * arClassInfo )

Loads a specified class schema.

Parameters
arClassInfo [in] Reference to a CXTPSyntaxEditLexClassInfoArray object.
Returns
TRUE if successful, otherwise FALSE.

◆ RemoveAll()

virtual void RemoveAll ( )
virtual

Removes all text blocks from the schema.

This method does not destroy the schema object. It only removes the text blocks.

See also
RemoveAll, CXTPSyntaxEditLexClassSchema::Close

◆ RunParseOnScreen()

virtual BOOL RunParseOnScreen | ( | CTextIter * | pTxtIter,
 |  | int | nRowStart,
 |  | int | nRowEnd,
 |  | CXTPSyntaxEditLexTextBlockPtr & | rPtrScreenSchFirstTB )
 virtual

Runs parse for the text on screen.

Parameters
pTxtIter | [in] Pointer to a CTextIter object.
nRowStart | [in] Start row for parse.
nRowEnd | [in] End row for parse.
rPtrScreenSchFirstTB | [out] Reference to a CXTPSyntaxEditLexTextBlockPtr object to receive the first text block of the built text schema.
Returns
TRUE if successful, otherwise FALSE.

◆ RunParseUpdate()

virtual int RunParseUpdate | ( | BOOL | bShort,
 |  | CTextIter * | pTxtIter,
 |  | const XTP_EDIT_LINECOL * | pLCStart = NULL,
 |  | const XTP_EDIT_LINECOL * | pLCEnd = NULL,
 |  | BOOL | bSendProgressEvents = FALSE )
 virtual

Runs parse for the text.

Parameters
bShort | [in] TRUE to use the short (global blocks only) class schema, FALSE to use the full (global and onscreen blocks) class schema.
pTxtIter | [in] Pointer to a CTextIter object.
nRowStart | [in] Start text position for parse/reparse.
nRowEnd | [in] End text position for parse/reparse.
bSendProgressEvents | [in] TRUE to send progress parsing events using the connection object, FALSE otherwise.

Special parameters values: pLCStart = NULL and pLCEnd = NULL to parse from the last parsed block to the end of the text.

pLCStart = XTP_EDIT_LINECOL::Pos1 and pLCEnd = NULL to parse/reparse all text from the beginning.

Returns
The parse result; one of the values defined by the XTPSyntaxEditLexParseResult enumeration.

◆ UpdateTextBlocks()

int UpdateTextBlocks | ( | XTP_EDIT_LINECOL | posFrom,
 |  | XTP_EDIT_LINECOL | posTo,
 |  | int | eEditAction )
 protected

Updates text schema positions after an editing action.

Parameters
posFrom | [in] Start editing position.
posTo | [in] End editing position.
eEditAction | [in] Edit action. Must be one of the values defined by the XTPSyntaxEditEditAction enumeration.
Returns
The update result. One of the values defined by the XTPSyntaxEditUpdateTBRes enumeration.
The documentation for this class was generated from the following file:
  • XTPSyntaxEditLexParser.h


Toolkit Pro: CXTPSyntaxEditLexTokensDef Class Reference

Public Member Functions | Public Attributes | List of all members
CXTPSyntaxEditLexTokensDef Class Reference

This class stores tokens definition: a list of tokens and corresponding lists of start and end tokens separators. More...

Public Member Functions

CXTPSyntaxEditLexTokensDef ()
Default object constructor.
CXTPSyntaxEditLexTokensDef (const CXTPSyntaxEditLexTokensDef &rSrc)
Copy object constructor.
virtual | ~CXTPSyntaxEditLexTokensDef ()
Object destructor.
const CXTPSyntaxEditLexTokensDef & | operator= (const CXTPSyntaxEditLexTokensDef &rSrc)
Assignment operator for class.

Public Attributes

CStringArray | m_arTokens
List of tokens.
CStringArray | m_arStartSeps
List of start separators.
CStringArray | m_arEndSeps
List of end separators.

Detailed Description

This class stores tokens definition: a list of tokens and corresponding lists of start and end tokens separators.

Constructor & Destructor Documentation

◆ CXTPSyntaxEditLexTokensDef()

CXTPSyntaxEditLexTokensDef ( const CXTPSyntaxEditLexTokensDef & rSrc )

Copy object constructor.

Parameters
rSrc [in] Reference to source CXTPSyntaxEditLexTokensDef object.

◆ ~CXTPSyntaxEditLexTokensDef()

virtual ~CXTPSyntaxEditLexTokensDef ( )
virtual

Object destructor.

Handles clean up and deallocations.

Member Function Documentation

◆ operator=()

const CXTPSyntaxEditLexTokensDef & operator= ( const CXTPSyntaxEditLexTokensDef & rSrc )

Assignment operator for class.

Parameters
rSrc [in] Reference to source CXTPSyntaxEditLexTokensDef object.
Returns
A reference to a CXTPSyntaxEditLexTokensDef object.
The documentation for this class was generated from the following file:
  • XTPSyntaxEditLexParser.h


Toolkit Pro: CXTPSyntaxEditLexVariable Class Reference

Public Types | Public Member Functions | Static Public Member Functions | Public Attributes | Static Protected Member Functions | Static Protected Attributes | List of all members
CXTPSyntaxEditLexVariable Class Reference

XTPSyntaxEditLexAnalyser namespace is used group text parser classes, separate them from others and to make class names shorter without risk to be duplicated. More...

Public Types

enum XTPSyntaxEditLexVarID {
xtpEditVarID_Unknown = 0 , xtpEditVarID_alpha = 1 , xtpEditVarID_digit = 2 , xtpEditVarID_HexDigit = 3 ,
xtpEditVarID_specs = 4 , xtpEditVarID_EOL = 5
}
XTPSyntaxEditLexVarID type defines the constants used to identify standard lexical variables: @alpha, @digit, @HexDigit, @specs, @EOL. More...
enum XTPSyntaxEditLexVarFlags { xtpEditVarfNot = 0x001 }
XTPSyntaxEditLexVarFlags type defines the constants used to specify additional lex variable properties. More...

Public Member Functions

CXTPSyntaxEditLexVariable ()
Default object constructor.
virtual | ~CXTPSyntaxEditLexVariable ()
Default object destructor.
const CXTPSyntaxEditLexVariable & | operator= (const CXTPSyntaxEditLexVariable &rSrc)
Copy operator.
virtual BOOL | SetVariable (LPCTSTR pcszVarName)
Set object members using string lex variable representation.
BOOL | operator== (const CXTPSyntaxEditLexVariable &rSrc) const
Equal-to operator.

Static Public Member Functions

static int AFX_CDECL | GetVarID (LPCTSTR pcszVarName)
Determine standard lex variable ID using string lex variable representation.
static BOOL AFX_CDECL | GetVariableData (int nVarID, CStringArray &rarVarData)
This method is used to get lex variable chars.

Public Attributes

int | m_nVarID
Lex variable identifier.
CString | m_strVar
Lex variable.
int | m_nVarFlags
Additional lex variable properties (flags).

Static Protected Member Functions

static void AFX_CDECL InitStandartVarsIfNeed ()
Initialize internal Lex variable name to ID map.

Static Protected Attributes

static CMapStringToPtr | s_mapVar2ID
Lex variable name to ID map.
static BOOL | s_bVarMapInitialized
Is initialized state of the lex variable name to ID map.

Detailed Description

XTPSyntaxEditLexAnalyser namespace is used group text parser classes, separate them from others and to make class names shorter without risk to be duplicated.

CXTPSyntaxEditLexVariable class is used to represent lexical variables. In the class schema variables begins from symbol @. Standard variables are: @alpha, @digit, @HexDigit, @specs, @EOL.

See also
Classes schema syntax.

Member Enumeration Documentation

◆ XTPSyntaxEditLexVarFlags

enum XTPSyntaxEditLexVarFlags

XTPSyntaxEditLexVarFlags type defines the constants used to specify additional lex variable properties.

values from 0 to 0xFFFF are reserved. for custom flags please use values bigger than 0xFFFF

See also
CXTPSyntaxEditLexVariable::m_nVarFlags.
Enumerator
xtpEditVarfNot

specify NOT operation for the lex variable.

◆ XTPSyntaxEditLexVarID

enum XTPSyntaxEditLexVarID

XTPSyntaxEditLexVarID type defines the constants used to identify standard lexical variables: @alpha, @digit, @HexDigit, @specs, @EOL.

values from 0 to 100 are reserved. for custom variables IDs please use values bigger than 100

See also
CXTPSyntaxEditLexVariable::m_nVarID
Enumerator
xtpEditVarID_Unknown | Undefined value.
xtpEditVarID_alpha | ID for lex variable - @alpha
xtpEditVarID_digit | ID for lex variable - @digit
xtpEditVarID_HexDigit | ID for lex variable - @HexDigit.
xtpEditVarID_specs | ID for lex variable - @specs
xtpEditVarID_EOL | ID for lex variable - @EOL

Member Function Documentation

◆ GetVariableData()

static BOOL AFX_CDECL GetVariableData | ( | int | nVarID,
 |  | CStringArray & | rarVarData )
 static

This method is used to get lex variable chars.

Parameters
nVarID | [in] A value from CXTPSyntaxEditLexVariable::XTPSyntaxEditLexVarID enum.
rarVarData | [out] A reference to CStringArray to get data.
Returns
TRUE if successful, otherwise FALSE.
See also
CXTPSyntaxEditLexVariable::XTPSyntaxEditLexVarID

◆ GetVarID()

static int AFX_CDECL GetVarID ( LPCTSTR pcszVarName )
static

Determine standard lex variable ID using string lex variable representation.

Parameters
pcszVarName [in] string lex variable representation (without flags). Like "@alpha" or "@digit".
Returns
xtpEditVarID_Unknown if fails, otherwise, if successful, other value from enum XTPSyntaxEditLexVarID.

This method determine standard lex variable ID using specified string.

See also
CXTPSyntaxEditLexVariable::XTPSyntaxEditLexVarID type, CXTPSyntaxEditLexVariable::SetVariable()

◆ InitStandartVarsIfNeed()

static void AFX_CDECL InitStandartVarsIfNeed ( )
staticprotected

Initialize internal Lex variable name to ID map.

This method initialize internal Lex variable name to ID map if it is not yet initialized.

Returns
See also
CXTPSyntaxEditLexVariable::s_mapVar2ID, CXTPSyntaxEditLexVariable::s_bVarMapInitialized()

◆ operator=()

const CXTPSyntaxEditLexVariable & operator= ( const CXTPSyntaxEditLexVariable & rSrc )

Copy operator.

Parameters
rSrc [in] Constant reference to the source object.
Returns
Constant reference to the destination object.

This operator fill object members using source object values.

See also
Operator copy (=) in C++.

◆ operator==()

BOOL operator== ( const CXTPSyntaxEditLexVariable & rSrc ) const

Equal-to operator.

Parameters
rSrc [in] Constant reference to the other object.
Returns
It returns TRUE if both operands have the same value; otherwise, it returns FALSE.

This operator determine are objects equal.

See also
Equality Operators in C++.

◆ SetVariable()

virtual BOOL SetVariable ( LPCTSTR pcszVarName )
virtual

Set object members using string lex variable representation.

Parameters
pcszVarName [in] string lex variable representation (with flags). Like "@alpha" or "@digit:not".
Returns
TRUE if successful, otherwise FALSE.

This method parse specified string and determine standard lex variable ID and additional flags.

See also
CXTPSyntaxEditLexVariable::GetVarID()
The documentation for this class was generated from the following file:
  • XTPSyntaxEditLexClass.h


Toolkit Pro: CXTPSyntaxEditLexVariant Class Reference

Public Member Functions | Public Attributes | List of all members
CXTPSyntaxEditLexVariant Class Reference

CXTPSyntaxEditLexVariant provides functionality to manipulate Lexical Analyzer's related variant type. More...

Inheritance diagram for CXTPSyntaxEditLexVariant:
[legend]

Public Member Functions

CXTPSyntaxEditLexVariant ()
Object constructor.
CXTPSyntaxEditLexVariant (const CXTPSyntaxEditLexVariant &rSrc)
Object constructor.
CXTPSyntaxEditLexVariant (CXTPSyntaxEditLexClass *pClass)
Object constructor.
CXTPSyntaxEditLexVariant (CXTPSyntaxEditLexVariantPtrArray *pLVArray)
Object constructor.
CXTPSyntaxEditLexVariant (const CXTPSyntaxEditLexVariable &rSrcVar)
Object constructor.
CXTPSyntaxEditLexVariant (LPCTSTR pcszStr, int eType=xtpEditLVT_valStr)
Object constructor.
CXTPSyntaxEditLexVariant (const CStringArray *pArStrVals)
Object constructor.
CXTPSyntaxEditLexVariant (int nValue)
Object constructor.
virtual | ~CXTPSyntaxEditLexVariant ()
Default object destructor.
const CXTPSyntaxEditLexVariant & | operator= (const CXTPSyntaxEditLexVariant &rSrc)
Copy operator.
const CXTPSyntaxEditLexVariant & | operator= (int nVal)
Copy operator.
const CXTPSyntaxEditLexVariant & | operator= (const CXTPSyntaxEditLexVariable &rSrcVar)
Copy operator.
BOOL | operator== (const CXTPSyntaxEditLexVariant &rSrc) const
Equal-to operator.
virtual BOOL | SetVariable (LPCTSTR pcszVarName)
Set object members using string lex variable representation.
virtual BOOL | IsStrType () const
Is variant object contains string(s).
virtual LPCTSTR | GetStr () const
Get string for the string type variant object.
virtual CXTPSyntaxEditLexVariant * | Clone () const
Clone variant object.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Public Attributes

int | m_nObjType
Object type value from XTPSyntaxEditLexVariantType.
CXTPSyntaxEditLexClassPtr | m_ptrClass
Value storage for type xtpEditLVT_classPtr
CXTPSyntaxEditLexVariantPtrArray * | m_ptrLVArrayPtr
Value storage for type xtpEditLVT_LVArrayPtr
int | m_nValue
Value storage for type xtpEditLVT_valInt
CStringArray | m_arStrVals
Value storage for types xtpEditLVT_className , xtpEditLVT_valStr
CXTPSyntaxEditLexVariable | m_Variable
Value storage for type xtpEditLVT_valVar

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

CXTPSyntaxEditLexVariant provides functionality to manipulate Lexical Analyzer's related variant type.

See also
XTPSyntaxEditLexVariantType, CXTPSyntaxEditLexClass, CXTPSyntaxEditLexVariable, CXTPSyntaxEditLexVariantPtrArray

Constructor & Destructor Documentation

◆ CXTPSyntaxEditLexVariant() [1/8]

CXTPSyntaxEditLexVariant ( )

Object constructor.

Construct an empty object, or initialize it using specified parameters.

See also
XTPSyntaxEditLexVariantType, CXTPSyntaxEditLexClass, CXTPSyntaxEditLexVariable, CXTPSyntaxEditLexVariantPtrArray

◆ CXTPSyntaxEditLexVariant() [2/8]

CXTPSyntaxEditLexVariant ( const CXTPSyntaxEditLexVariant & rSrc )

Object constructor.

Parameters
rSrc [in] Initialize new object using other LexVariant object.

Construct an empty object, or initialize it using specified parameters.

See also
XTPSyntaxEditLexVariantType, CXTPSyntaxEditLexClass, CXTPSyntaxEditLexVariable, CXTPSyntaxEditLexVariantPtrArray

◆ CXTPSyntaxEditLexVariant() [3/8]

CXTPSyntaxEditLexVariant ( CXTPSyntaxEditLexClass * pClass )

Object constructor.

Parameters
pClass [in] Set new object type to xtpEditLVT_classPtr , and initialize m_ptrClass member using specified pointer. InternalAddRef() is called for the pClass object. InternalRelease() will be called in the destructor.

Construct an empty object, or initialize it using specified parameters.

See also
XTPSyntaxEditLexVariantType, CXTPSyntaxEditLexClass, CXTPSyntaxEditLexVariable, CXTPSyntaxEditLexVariantPtrArray

◆ CXTPSyntaxEditLexVariant() [4/8]

CXTPSyntaxEditLexVariant ( CXTPSyntaxEditLexVariantPtrArray * pLVArray )

Object constructor.

Parameters
pLVArray [in] Set new object type to xtpEditLVT_LVArrayPtr , and initialize m_ptrLVArrayPtr member using specified pointer. If bWithAddRef parameter value is TRUE InternalAddRef() is called for the pLVArray object.

Construct an empty object, or initialize it using specified parameters.

See also
XTPSyntaxEditLexVariantType, CXTPSyntaxEditLexClass, CXTPSyntaxEditLexVariable, CXTPSyntaxEditLexVariantPtrArray

◆ CXTPSyntaxEditLexVariant() [5/8]

CXTPSyntaxEditLexVariant ( const CXTPSyntaxEditLexVariable & rSrcVar )

Object constructor.

Parameters
rSrcVar [in] Set new object type to xtpEditLVT_valVar , and initialize m_Variable member using specified object.

Construct an empty object, or initialize it using specified parameters.

See also
XTPSyntaxEditLexVariantType, CXTPSyntaxEditLexClass, CXTPSyntaxEditLexVariable, CXTPSyntaxEditLexVariantPtrArray

◆ CXTPSyntaxEditLexVariant() [6/8]

CXTPSyntaxEditLexVariant | ( | LPCTSTR | pcszStr,
 |  | int | eType = xtpEditLVT_valStr )

Object constructor.

Parameters
pcszStr | [in] Set new object type to eType parameter value, and initialize m_arStrVals[0] member using specified string. eType parameter value should be a string type: xtpEditLVT_valStr , xtpEditLVT_className .
eType | : [in] Object type value from XTPSyntaxEditLexVariantType.

Construct an empty object, or initialize it using specified parameters.

See also
XTPSyntaxEditLexVariantType, CXTPSyntaxEditLexClass, CXTPSyntaxEditLexVariable, CXTPSyntaxEditLexVariantPtrArray

◆ CXTPSyntaxEditLexVariant() [7/8]

CXTPSyntaxEditLexVariant ( const CStringArray * pArStrVals )

Object constructor.

Parameters
pArStrVals [in] Set new object type to xtpEditLVT_valStr , and initialize m_arStrVals member using specified pointer.

Construct an empty object, or initialize it using specified parameters.

See also
XTPSyntaxEditLexVariantType, CXTPSyntaxEditLexClass, CXTPSyntaxEditLexVariable, CXTPSyntaxEditLexVariantPtrArray

◆ CXTPSyntaxEditLexVariant() [8/8]

CXTPSyntaxEditLexVariant ( int nValue )

Object constructor.

Parameters
nValue [in] Set new object type to xtpEditLVT_valInt , and initialize m_nValue member using specified value.

Construct an empty object, or initialize it using specified parameters.

See also
XTPSyntaxEditLexVariantType, CXTPSyntaxEditLexClass, CXTPSyntaxEditLexVariable, CXTPSyntaxEditLexVariantPtrArray

Member Function Documentation

◆ Clone()

virtual CXTPSyntaxEditLexVariant * Clone ( ) const
virtual

Clone variant object.

Returns
Pointer to the new object.

Create a new CXTPSyntaxEditLexVariant object using new operator and initialize it using this object. New object reference counter is initialized by 1. InternalRelease() should be called to delete unused object.

◆ GetStr()

virtual LPCTSTR GetStr ( ) const
virtual

Get string for the string type variant object.

Returns
Value of m_arStrVals[0] if object is string type, otherwise - empty string.

Call this method to get first string stored in the object ( m_arStrVals[0] member value).

See also
CXTPSyntaxEditLexVariant::IsStrType(), XTPSyntaxEditLexVariantType, CXTPSyntaxEditLexVariant::m_arStrVals.

◆ IsStrType()

virtual BOOL IsStrType ( ) const
virtual

Is variant object contains string(s).

Returns
TRUE if object is string type: xtpEditLVT_valStr , xtpEditLVT_className , otherwise - FALSE.

Call this method to determine is object has a string type. In this case m_arStrVals member is used to access data.

See also
XTPSyntaxEditLexVariantType, CXTPSyntaxEditLexVariant::m_arStrVals.

◆ operator=() [1/3]

const CXTPSyntaxEditLexVariant & operator= ( const CXTPSyntaxEditLexVariable & rSrcVar )

Copy operator.

Parameters
rSrcVar [in] Value to be stored in the lex variant object.
Returns
Constant reference to the destination object.

This operator sets the object type to xtpEditLVT_valVar , and initialize m_Variable member using specified object.

See also
Operator copy (=) in C++.

◆ operator=() [2/3]

const CXTPSyntaxEditLexVariant & operator= ( const CXTPSyntaxEditLexVariant & rSrc )

Copy operator.

Parameters
rSrc [in] Constant reference to the source object.
Returns
Constant reference to the destination object.

This operator fill object members using source object values.

See also
Operator copy (=) in C++.

◆ operator=() [3/3]

const CXTPSyntaxEditLexVariant & operator= ( int nVal )

Copy operator.

Parameters
nVal [in] Value to be stored in the lex variant object.
Returns
Constant reference to the destination object.

This operator sets the object type to xtpEditLVT_valInt , and initialize m_nValue member using specified value.

See also
Operator copy (=) in C++.

◆ operator==()

BOOL operator== ( const CXTPSyntaxEditLexVariant & rSrc ) const

Equal-to operator.

Parameters
rSrc [in] Constant reference to the other object.
Returns
It returns TRUE if both operands have the same value; otherwise, it returns FALSE.

This operator determine are objects equal.

See also
Equality Operators in C++.

◆ SetVariable()

virtual BOOL SetVariable ( LPCTSTR pcszVarName )
virtual

Set object members using string lex variable representation.

Parameters
pcszVarName [in] string lex variable representation (with flags). Like "@alpha" or "@digit:not".
Returns
TRUE if successful, otherwise FALSE.

This method sets the object type to xtpEditLVT_valVar , and initialize m_Variable member using specified string lex variable representation.

See also
CXTPSyntaxEditLexVariable::SetVariable()
The documentation for this class was generated from the following file:
  • XTPSyntaxEditLexClass.h


Toolkit Pro: CXTPSyntaxEditLineMarksManager Class Reference

Public Types | Public Member Functions | List of all members
CXTPSyntaxEditLineMarksManager Class Reference

The CXTPSyntaxEditLineMarksManager class provides functionality to manipulate marks on text lines. More...

Inheritance diagram for CXTPSyntaxEditLineMarksManager:
[legend]

Public Types

typedef CXTPSmartPtrInternalT< CLineMarksList > CLineMarksListPtr
SmartPointer for the class.

Public Member Functions

CXTPSyntaxEditLineMarksManager ()
Default object constructor.
virtual | ~CXTPSyntaxEditLineMarksManager ()
Destroys a CXTPSyntaxEditLineMarksManager object, handles cleanup and de-allocation.
void | AddRemoveLineMark (int nRow, const XTP_EDIT_LINEMARKTYPE lmType, XTP_EDIT_LMPARAM *pParam=NULL)
Adds/removes a specified mark to/from a specified row.
void | SetLineMark (int nRow, const XTP_EDIT_LINEMARKTYPE lmType, XTP_EDIT_LMPARAM *pParam=NULL)
Adds a specified mark to a specified row.
void | DeleteLineMark (int nRow, const XTP_EDIT_LINEMARKTYPE lmType)
Removes a specified mark from a specified row.
BOOL | HasRowMark (int nRow, const XTP_EDIT_LINEMARKTYPE &lmType, XTP_EDIT_LMPARAM *pParam=NULL) const
Determines if a specified row has a specified mark.
POSITION | FindPrevLineMark (int &nRow, const XTP_EDIT_LINEMARKTYPE lmType) const
Gets the position of the row with a specified mark type that precedes a specified row.
POSITION | FindNextLineMark (int &nRow, const XTP_EDIT_LINEMARKTYPE lmType) const
Gets the position of the row with a specified mark type that follows a specified row.
POSITION | GetLastLineMark (const XTP_EDIT_LINEMARKTYPE lmType) const
Gets the position of the last row with a specified mark type.
POSITION | GetFirstLineMark (const XTP_EDIT_LINEMARKTYPE lmType) const
Gets the position of the first row with a specified mark type.
XTP_EDIT_LMDATA * | GetNextLineMark (POSITION &pos, const XTP_EDIT_LINEMARKTYPE lmType) const
Gets the identifier of the row with a specified mark type that follows a specified position.
XTP_EDIT_LMDATA * | GetLineMarkAt (const POSITION pos, const XTP_EDIT_LINEMARKTYPE lmType) const
Gets the identifier of the row with a specified mark type at a specified position.
virtual void | RefreshLineMarks (int nRowFrom, int nRowTo, int nRefreshType)
Refreshes the line marks for a specified range of rows.
void | RemoveAll (const XTP_EDIT_LINEMARKTYPE lmType)
Removes all line marks of a specified type.
int | GetCount (const XTP_EDIT_LINEMARKTYPE lmType) const
Gets the number of line marks of a specified type.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

The CXTPSyntaxEditLineMarksManager class provides functionality to manipulate marks on text lines.

Used internally by the Smart Edit control.

Member Function Documentation

◆ AddRemoveLineMark()

void AddRemoveLineMark | ( | int | nRow,
 |  | const XTP_EDIT_LINEMARKTYPE | lmType,
 |  | XTP_EDIT_LMPARAM * | pParam = NULL )

Adds/removes a specified mark to/from a specified row.

Parameters
nRow | [in] Row number.
lmType | [in] Mark type identifier.
pParam | [in] Pointer to XTP_EDIT_LMPARAM. The default value for this parameter is NULL.

If the row does not have the specified mark, then the mark will be added. If the row does have the specified mark, then the mark will be deleted.

See also
XTP_EDIT_LMPARAM

◆ DeleteLineMark()

void DeleteLineMark | ( | int | nRow,
 |  | const XTP_EDIT_LINEMARKTYPE | lmType )

Removes a specified mark from a specified row.

Parameters
nRow | [in] Row number.
lmType | [in] Mark type identifier.

◆ FindNextLineMark()

POSITION FindNextLineMark | ( | int & | nRow,
 |  | const XTP_EDIT_LINEMARKTYPE | lmType ) const

Gets the position of the row with a specified mark type that follows a specified row.

Parameters
nRow | [in] Row number.
lmType | [in] Mark type identifier.
Returns
The POSITION of the row with the specified mark type that follows the specified row.

◆ FindPrevLineMark()

POSITION FindPrevLineMark | ( | int & | nRow,
 |  | const XTP_EDIT_LINEMARKTYPE | lmType ) const

Gets the position of the row with a specified mark type that precedes a specified row.

Parameters
nRow | [in] Row number.
lmType | [in] Mark type identifier.
Returns
The POSITION of the row with the specified mark type that precedes the specified row.

◆ GetCount()

int GetCount ( const XTP_EDIT_LINEMARKTYPE lmType ) const

Gets the number of line marks of a specified type.

Parameters
lmType [in] Mark type identifier.
Returns
The number of line marks of the specified type.

◆ GetFirstLineMark()

POSITION GetFirstLineMark ( const XTP_EDIT_LINEMARKTYPE lmType ) const

Gets the position of the first row with a specified mark type.

Parameters
lmType [in] Mark type identifier.
Returns
The POSITION of the first row with the specified mark type.

◆ GetLastLineMark()

POSITION GetLastLineMark ( const XTP_EDIT_LINEMARKTYPE lmType ) const

Gets the position of the last row with a specified mark type.

Parameters
lmType [in] Mark type identifier.
Returns
The POSITION of the last row with the specified mark type.

◆ GetLineMarkAt()

XTP_EDIT_LMDATA * GetLineMarkAt | ( | const POSITION | pos,
 |  | const XTP_EDIT_LINEMARKTYPE | lmType ) const

Gets the identifier of the row with a specified mark type at a specified position.

Parameters
pos | [in] POSITION value.
lmType | [in] Mark type identifier.
Returns
A pointer to an XTP_EDIT_LMDATA structure that contains the identifier of the row with the specified mark type at the specified position.
See also
XTP_EDIT_LMDATA

◆ GetNextLineMark()

XTP_EDIT_LMDATA * GetNextLineMark | ( | POSITION & | pos,
 |  | const XTP_EDIT_LINEMARKTYPE | lmType ) const

Gets the identifier of the row with a specified mark type that follows a specified position.

Parameters
pos | [in] Reference to a POSITION value.
lmType | [in] Mark type identifier.
Returns
A pointer to an XTP_EDIT_LMDATA structure that contains the identifier of the row with the specified mark type that follows the specified position.
See also
XTP_EDIT_LMDATA

◆ HasRowMark()

BOOL HasRowMark | ( | int | nRow,
 |  | const XTP_EDIT_LINEMARKTYPE & | lmType,
 |  | XTP_EDIT_LMPARAM * | pParam = NULL ) const

Determines if a specified row has a specified mark.

Parameters
nRow | [in] Row number.
lmType | [in] Mark type identifier.
pParam | [in] Pointer to XTP_EDIT_LMPARAM. The default value for this parameter is NULL.
Returns
TRUE if the specified row has the specified mark, otherwise FALSE.

◆ RefreshLineMarks()

virtual void RefreshLineMarks | ( | int | nRowFrom,
 |  | int | nRowTo,
 |  | int | nRefreshType )
 virtual

Refreshes the line marks for a specified range of rows.

Parameters
nRowFrom | [in] Start row.
nRowTo | [in] End row.
nRefreshType | [in] Refresh type; must be one of the values defined by the XTPSyntaxEditLineMarksRefreshType enumeration.
See also
XTPSyntaxEditLineMarksRefreshType.

◆ RemoveAll()

void RemoveAll ( const XTP_EDIT_LINEMARKTYPE lmType )

Removes all line marks of a specified type.

Parameters
lmType [in] Mark type identifier.

◆ SetLineMark()

void SetLineMark | ( | int | nRow,
 |  | const XTP_EDIT_LINEMARKTYPE | lmType,
 |  | XTP_EDIT_LMPARAM * | pParam = NULL )

Adds a specified mark to a specified row.

Parameters
nRow | [in] Row number.
lmType | [in] Mark type identifier.
pParam | [in] Pointer to XTP_EDIT_LMPARAM. The default value for this parameter is NULL.
See also
XTP_EDIT_LMPARAM
The documentation for this class was generated from the following file:
  • XTPSyntaxEditLineMarksManager.h


Toolkit Pro: CXTPSyntaxEditOptions Class Reference

Protected Attributes | List of all members
CXTPSyntaxEditOptions Class Reference

Shared Options of SyntaxEdit. More...

Inheritance diagram for CXTPSyntaxEditOptions:
[legend]

Protected Attributes

BOOL | m_bSyntaxColor
TRUE if syntax colorization is enabled, FALSE if disabled.
BOOL | m_bAutoIndent
TRUE if auto-indentation is enabled, FALSE if disabled.
BOOL | m_bSelMargin
TRUE if selection margin is enabled, FALSE if disabled.
BOOL | m_bLineNumbers
TRUE if line numbers are to be printed, FALSE otherwise.
BOOL | m_bWideCaret
Stored Overwrite Caret Style: Thin or Thick.
BOOL | m_bTabWithSpace
TRUE if tabs are replaced with spaces, FALSE otherwise.
BOOL | m_bVirtualSpace
TRUE if virtual space is enabled (i.e.
BOOL | m_bDrawNodes
TRUE if collapsible nodes signs are printed, otherwise FALSE.
BOOL | m_bEnableWhiteSpace
TRUE if white space is shown, otherwise FALSE.
BOOL | m_bReadOnly
TRUE if in read-only mode, otherwise FALSE.
BOOL | m_bViewOnly
TRUE if in view-only mode, otherwise FALSE.
BOOL | m_bHideCaret
TRUE if the caret is hidden, otherwise FALSE.
BOOL | m_bEnableEditAccelerators
TRUE if the accelerators for the Cut, Copy, Paste, Undo, Redo, and Select All operations are enabled, FALSE if disabled.
CXTPSyntaxEditRowColorMap | m_mapRowBkColor
Map for row back colors.
CXTPSyntaxEditRowColorMap | m_mapRowForeColor
Map for row colors.

Additional Inherited Members

- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

Shared Options of SyntaxEdit.

Member Data Documentation

◆ m_bVirtualSpace

BOOL m_bVirtualSpace
protected

TRUE if virtual space is enabled (i.e.

the cursor can be placed anywhere after the line end), otherwise FALSE.

The documentation for this class was generated from the following file:
  • XTPSyntaxEditCtrl.h


Toolkit Pro: CXTPSyntaxEditPaintManager Class Reference

Public Member Functions | Public Attributes | Protected Member Functions | Protected Attributes | List of all members
CXTPSyntaxEditPaintManager Class Reference

This class is used by CXTPSyntaxEditCtrl as the paint manager. More...

Inheritance diagram for CXTPSyntaxEditPaintManager:
[legend]

Public Member Functions

CXTPSyntaxEditPaintManager ()
Default object constructor.
virtual | ~CXTPSyntaxEditPaintManager ()
Destroys a CXTPSyntaxEditPaintManager object, handles cleanup and deallocation.
virtual void | InitBitmaps ()
Initializes default paint manager bitmaps, should be called after creating the control window.
virtual void | RefreshMetrics ()
Refreshes the visual metrics of the manager.
virtual BOOL | UpdateTextFont (CXTPSyntaxEditCtrl *pEditCtrl, const XTP_EDIT_FONTOPTIONS &lf)
Updates the edit control text font.
virtual void | DrawLineNumber (CDC *pDC, const CRect &rcRect, int nTextRow, CXTPSyntaxEditCtrl *pEditCtrl)
Draws a line number.
virtual void | DrawLineNode (CDC *pDC, const CRect &rcNode, const CRect &rcNodeFull, DWORD dwType, int nTextRow, CXTPSyntaxEditCtrl *pEditCtrl)
Draws the line collapsible node icon.
virtual void | DrawLineNodeBackground (CDC *pDC, const CRect &rcNodeFull, DWORD dwType, int nTextRow, CXTPSyntaxEditCtrl *pEditCtrl)
Draws the line node background.
virtual void | DrawCollapsedTextMarks (CXTPSyntaxEditCtrl *pEditCtrl, CDC *pDC)
Draws frames around collapsed text blocks.
virtual void | DrawLineMarks (CDC *pDC, const CRect &rcRect, int nTextRow, CXTPSyntaxEditCtrl *pEditCtrl)
Draws line marks.
virtual int | DrawLineTextEx (CDC *pDC, const CRect &rcTextLine, int nTextRow, int nLine, CXTPSyntaxEditCtrl *pEditCtrl)
Draws row text.
virtual int | PrintLineTextEx (CDC *pDC, const CRect &rcTextLine, int nTextRow, int nLine, CXTPSyntaxEditCtrl *pEditCtrl, int nFlags=0)
Prints row text.
virtual void | DrawLineCalcSel (const XTP_EDIT_TEXTBLOCK &txtBlk, int nSelStartX, int nSelEndX, XTP_EDIT_TEXTBLOCK(&arTxtBlk)[4], BOOL(&bUseBlk)[4])
Draws the editor text line and calculates the selection position.
HCURSOR | SetLineSelCursor (HCURSOR hCurLine)
Sets the line selection cursor.
HCURSOR | SetCopyCursor (HCURSOR hCurCopy)
Sets the cursor shape for "copy" cursor.
HCURSOR | SetMoveCursor (HCURSOR hCurMove)
Sets the cursor shape for "move" cursor.
COLORREF | GetTextColor () const
Gets the text color.
COLORREF | GetBackColor () const
Gets the background color.
COLORREF | GetBackColorEx (CXTPSyntaxEditCtrl *pEditCtrl)
Gets the corresponding background color for either the edit or read-only mode of a specified CXTPSyntaxEditCtrl object.
COLORREF | GetHiliteTextColor () const
Gets the selected text color.
COLORREF | GetHiliteBackColor () const
Gets the selected background color.
COLORREF | GetInactiveHiliteTextColor () const
Gets the selected text color for when the control does not have focus.
COLORREF | GetInactiveHiliteBackColor () const
Gets the selected background color for when the control does not have focus.
COLORREF | GetLineNumberTextColor () const
Gets the line numbers text color.
COLORREF | GetLineNumberBackColor () const
Gets the line numbers background color.
COLORREF | GetBreakpointTextColor () const
Gets the breakpoint text color.
COLORREF | GetBreakpointBackColor () const
Gets the breakpoint background color.
BOOL | SetTextColor (COLORREF crText, BOOL bUpdateReg=FALSE)
Sets the text color.
BOOL | SetBackColor (COLORREF crBack, BOOL bUpdateReg=FALSE)
Sets the background color.
BOOL | SetReadOnlyBackColor (COLORREF crBack, BOOL bUpdateReg=FALSE)
Sets the background color for read-only mode.
BOOL | SetHiliteTextColor (COLORREF color, BOOL bUpdateReg=FALSE)
Sets the selected text color.
BOOL | SetHiliteBackColor (COLORREF color, BOOL bUpdateReg=FALSE)
Sets the selected background color.
BOOL | SetInactiveHiliteTextColor (COLORREF color, BOOL bUpdateReg=FALSE)
Sets the selected text color for when the control does not have focus.
BOOL | SetInactiveHiliteBackColor (COLORREF color, BOOL bUpdateReg=FALSE)
Sets the selected background color for when the control does not have focus.
BOOL | SetLineNumberTextColor (COLORREF color, BOOL bUpdateReg=FALSE)
Sets the line numbers text color.
BOOL | SetLineNumberBackColor (COLORREF color, BOOL bUpdateReg=FALSE)
Sets the line numbers background color.
BOOL | SetBreakpointTextColor (COLORREF color, BOOL bUpdateReg=FALSE)
Sets the breakpoint text color.
BOOL | SetBreakpointBackColor (COLORREF color, BOOL bUpdateReg=FALSE)
Sets the breakpoint background color.
CFont * | GetFont ()
Gets the common font.
CFont * | GetFontText ()
Gets the editor text font.
CFont * | GetFontLineNumber ()
Gets the line numbers font.
CFont * | GetFontToolTip ()
Gets the tooltip font.
BOOL | SetFont (LPLOGFONT pLogfont)
Set the common font.
BOOL | SetFontText (LPLOGFONT pLogfont)
Sets the editor text font.
BOOL | SetFontLineNumber (LPLOGFONT pLogfont)
Sets the line numbers font.
BOOL | SetFontToolTip (LPLOGFONT pLogfont)
Sets the tooltip font.
BOOL | CreateFontIndirect (LPLOGFONT pLogfont, BOOL bUpdateReg=FALSE)
Sets all editor fonts.
HCURSOR | GetCurLine ()
Gets the cursor to show on the line selection area.
HCURSOR | GetCurMove ()
Gets the cursor for moving text.
HCURSOR | GetCurCopy ()
Gets the cursor for copying text.
HCURSOR | GetCurNO ()
Gets the standard NO cursor.
HCURSOR | GetCurIBeam ()
Gets the standard IBEAM cursor.
HCURSOR | GetCurArrow ()
Gets the standard ARROW cursor.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Public Attributes

CString m_sLineNumberFormat
String to customize Line Number format (e.g.

Protected Member Functions

virtual void | DrawLineMark (CXTPSyntaxEditCtrl *pEditCtrl, XTP_EDIT_SENMBOOKMARK *pBookmark)
Draws a line mark.
virtual void | DrawLineNumbersBorder (CDC *pDC, const CRect &rcLineNum, const COLORREF clrBorder)
Draws the line numbers border.
virtual CXTPImageManager * | GetBookmarks ()
Gets the bookmarks image manager.

Protected Attributes

CXTPFont | m_xtpFont
Default font for normal text.
CXTPFont | m_xtpFontText
Current text font.
CXTPFont | m_xtpFontLineNumber
Font for line numbering.
CXTPFont | m_xtpFontToolTip
Font for tooltip text.
HCURSOR | m_hCurLine
Cursor to show on the line selection area.
HCURSOR | m_hCurMove
Cursor for moving text.
HCURSOR | m_hCurCopy
Cursor for copying text.
HCURSOR | m_hCurNO
Standard NO cursor.
HCURSOR | m_hCurIBeam
Standard IBEAM cursor.
HCURSOR | m_hCurArrow
Standard ARROW cursor.
CPen | m_penGray
Standard common gray pen.
XTP_EDIT_COLORVALUES | m_clrValues
Default color.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

This class is used by CXTPSyntaxEditCtrl as the paint manager.

Member Function Documentation

◆ CreateFontIndirect()

BOOL CreateFontIndirect | ( | LPLOGFONT | pLogfont,
 |  | BOOL | bUpdateReg = FALSE )

Sets all editor fonts.

Parameters
pLogfont | Pointer to a LPLOGFONT structure.
bUpdateReg | TRUE to update this setting in the registry, FALSE otherwise. By default, this parameter is FALSE.
Returns
TRUE if successful, otherwise FALSE.
See also
SetFont, SetFontText, SetFontLineNumber, SetFontToolTip

◆ DrawCollapsedTextMarks()

virtual void DrawCollapsedTextMarks | ( | CXTPSyntaxEditCtrl * | pEditCtrl,
 |  | CDC * | pDC )
 virtual

Draws frames around collapsed text blocks.

Parameters
pEditCtrl | [in] Pointer to the edit control.
pDC | [in] Pointer to the device context.

◆ DrawLineCalcSel()

virtual void DrawLineCalcSel | ( | const XTP_EDIT_TEXTBLOCK & | txtBlk,
 |  | int | nSelStartX,
 |  | int | nSelEndX,
 |  | XTP_EDIT_TEXTBLOCK(&) | arTxtBlk[4],
 |  | BOOL(&) | bUseBlk[4] )
 virtual

Draws the editor text line and calculates the selection position.

Parameters
txtBlk | [in] Reference to an XTP_EDIT_TEXTBLOCK structure.
nSelStartX | [in] Start coordinate.
nSelEndX | [in] End coordinate.
arTxtBlk | [in] Array of references to XTP_EDIT_TEXTBLOCK structures.
bUseBlk | [in] Array of references to BOOL values.
See also
XTP_EDIT_TEXTBLOCK

◆ DrawLineMark()

virtual void DrawLineMark | ( | CXTPSyntaxEditCtrl * | pEditCtrl,
 |  | XTP_EDIT_SENMBOOKMARK * | pBookmark )
 protectedvirtual

Draws a line mark.

Parameters
pEditCtrl | [in] Pointer to the edit control.
pBookmark | [in] Pointer to the structure containing mark parameters.
See also
LPXTP_EDIT_SENMBOOKMARK

◆ DrawLineMarks()

virtual void DrawLineMarks | ( | CDC * | pDC,
 |  | const CRect & | rcRect,
 |  | int | nTextRow,
 |  | CXTPSyntaxEditCtrl * | pEditCtrl )
 virtual

Draws line marks.

Parameters
pDC | [in] Pointer to the device context to draw to.
rcRect | [in] Reference to the rectangle to draw.
nTextRow | [in] Text row number for which to draw.
pEditCtrl | [in] Pointer to the edit control.

◆ DrawLineNode()

virtual void DrawLineNode | ( | CDC * | pDC,
 |  | const CRect & | rcNode,
 |  | const CRect & | rcNodeFull,
 |  | DWORD | dwType,
 |  | int | nTextRow,
 |  | CXTPSyntaxEditCtrl * | pEditCtrl )
 virtual

Draws the line collapsible node icon.

Parameters
pDC | [in] Pointer to the device context to draw to.
rcNode | [in] Reference to the node rectangle to draw.
rcNodeFull | [in] Reference to the full node area rectangle.
dwType | [in] Line node type flags.
nTextRow | [in] Text row number for which to draw.
pEditCtrl | [in] Pointer to the edit control.

◆ DrawLineNodeBackground()

virtual void DrawLineNodeBackground | ( | CDC * | pDC,
 |  | const CRect & | rcNodeFull,
 |  | DWORD | dwType,
 |  | int | nTextRow,
 |  | CXTPSyntaxEditCtrl * | pEditCtrl )
 virtual

Draws the line node background.

Parameters
pDC | [in] Pointer to the device context to draw to.
rcNodeFull | [in] Reference to the full node area rectangle.
dwType | [in] Line node type flags.
nTextRow | [in] Text row number for which to draw.
pEditCtrl | [in] Pointer to the edit control.

◆ DrawLineNumber()

virtual void DrawLineNumber | ( | CDC * | pDC,
 |  | const CRect & | rcRect,
 |  | int | nTextRow,
 |  | CXTPSyntaxEditCtrl * | pEditCtrl )
 virtual

Draws a line number.

Parameters
pDC | [in] Pointer to the device context to draw to.
rcRect | [in] Reference to the rectangle to draw.
nTextRow | [in] Text row number for which to draw.
pEditCtrl | [in] Pointer to the edit control.

◆ DrawLineNumbersBorder()

virtual void DrawLineNumbersBorder | ( | CDC * | pDC,
 |  | const CRect & | rcLineNum,
 |  | const COLORREF | clrBorder )
 protectedvirtual

Draws the line numbers border.

Parameters
pDC | [in] Pointer to the device context to draw to.
rcLineNum | [in] Reference to the line number rectangle.
clrBorder | [in] Border color.

◆ DrawLineTextEx()

virtual int DrawLineTextEx | ( | CDC * | pDC,
 |  | const CRect & | rcTextLine,
 |  | int | nTextRow,
 |  | int | nLine,
 |  | CXTPSyntaxEditCtrl * | pEditCtrl )
 virtual

Draws row text.

Parameters
pDC | [in] Pointer to the device context to draw to.
rcTextLine | [in] Reference to the rectangle to draw.
nTextRow | [in] Text row number for which to draw.
nLine | [in] Screen (page) line number.
pEditCtrl | [in] Pointer to the edit control.
Returns
The height to draw row text.

◆ GetBackColor()

AFX_INLINE COLORREF GetBackColor ( ) const

Gets the background color.

Returns
The background color.
See also
SetBackColor

◆ GetBackColorEx()

AFX_INLINE COLORREF GetBackColorEx ( CXTPSyntaxEditCtrl * pEditCtrl )

Gets the corresponding background color for either the edit or read-only mode of a specified CXTPSyntaxEditCtrl object.

Parameters
pEditCtrl Pointer to a CXTPSyntaxEditCtrl object.
Returns
The corresponding background color.
See also
SetBackColor, GetBackColor

◆ GetBookmarks()

virtual CXTPImageManager * GetBookmarks ( )
protectedvirtual

Gets the bookmarks image manager.

Returns
A pointer to the bookmarks image manager.

◆ GetBreakpointBackColor()

AFX_INLINE COLORREF GetBreakpointBackColor ( ) const

Gets the breakpoint background color.

Returns
The breakpoint background color.
See also
SetBreakpointBackColor

◆ GetBreakpointTextColor()

AFX_INLINE COLORREF GetBreakpointTextColor ( ) const

Gets the breakpoint text color.

Returns
The breakpoint text color.
See also
SetBreakpointTextColor

◆ GetCurArrow()

HCURSOR GetCurArrow ( )

Gets the standard ARROW cursor.

Returns
The HCURSOR handle to the cursor.

◆ GetCurCopy()

HCURSOR GetCurCopy ( )

Gets the cursor for copying text.

Returns
The HCURSOR handle to the cursor.
See also
SetCopyCursor

◆ GetCurIBeam()

HCURSOR GetCurIBeam ( )

Gets the standard IBEAM cursor.

Returns
The HCURSOR handle to the cursor.

◆ GetCurLine()

HCURSOR GetCurLine ( )

Gets the cursor to show on the line selection area.

Returns
The HCURSOR handle to the cursor.
See also
SetLineSelCursor

◆ GetCurMove()

HCURSOR GetCurMove ( )

Gets the cursor for moving text.

Returns
The HCURSOR handle to the cursor.
See also
SetMoveCursor

◆ GetCurNO()

HCURSOR GetCurNO ( )

Gets the standard NO cursor.

Returns
The HCURSOR handle to the cursor.

◆ GetFont()

CFont * GetFont ( )

Gets the common font.

Returns
A pointer to a CFont object.
See also
SetFont

◆ GetFontLineNumber()

CFont * GetFontLineNumber ( )

Gets the line numbers font.

Returns
A pointer to a CFont object.
See also
SetFontLineNumber

◆ GetFontText()

CFont * GetFontText ( )

Gets the editor text font.

Returns
A pointer to a CFont object.
See also
SetFontText

◆ GetFontToolTip()

CFont * GetFontToolTip ( )

Gets the tooltip font.

Returns
A pointer to a CFont object.
See also
SetFontToolTip

◆ GetHiliteBackColor()

AFX_INLINE COLORREF GetHiliteBackColor ( ) const

Gets the selected background color.

Returns
The selected background color.
See also
SetHiliteBackColor

◆ GetHiliteTextColor()

AFX_INLINE COLORREF GetHiliteTextColor ( ) const

Gets the selected text color.

Returns
The selected text color.
See also
SetHiliteTextColor

◆ GetInactiveHiliteBackColor()

AFX_INLINE COLORREF GetInactiveHiliteBackColor ( ) const

Gets the selected background color for when the control does not have focus.

Returns
The selected background color for when the control does not have focus.
See also
SetInactiveHiliteBackColor

◆ GetInactiveHiliteTextColor()

AFX_INLINE COLORREF GetInactiveHiliteTextColor ( ) const

Gets the selected text color for when the control does not have focus.

Returns
The selected text color for when the control does not have focus.
See also
SetInactiveHiliteTextColor

◆ GetLineNumberBackColor()

AFX_INLINE COLORREF GetLineNumberBackColor ( ) const

Gets the line numbers background color.

Returns
The line numbers background color.
See also
SetLineNumberBackColor

◆ GetLineNumberTextColor()

AFX_INLINE COLORREF GetLineNumberTextColor ( ) const

Gets the line numbers text color.

Returns
The line numbers text color.
See also
SetLineNumberTextColor

◆ GetTextColor()

AFX_INLINE COLORREF GetTextColor ( ) const

Gets the text color.

Returns
The text color.
See also
SetTextColor

◆ PrintLineTextEx()

virtual int PrintLineTextEx | ( | CDC * | pDC,
 |  | const CRect & | rcTextLine,
 |  | int | nTextRow,
 |  | int | nLine,
 |  | CXTPSyntaxEditCtrl * | pEditCtrl,
 |  | int | nFlags = 0 )
 virtual

Prints row text.

Parameters
pDC | [in] Pointer to the device context to draw to.
rcTextLine | [in] Reference to the rectangle to draw.
nTextRow | [in] Text row number for which to draw.
nLine | [in] Screen (page) line number.
pEditCtrl | [in] Pointer to the edit control.
nFlags | [in] Additional printing options. The following options are supported: DT_CALCRECT, DT_SINGLELINE, DT_WORDBREAK
Returns
The height to print row text.

◆ SetBackColor()

BOOL SetBackColor | ( | COLORREF | crBack,
 |  | BOOL | bUpdateReg = FALSE )

Sets the background color.

Parameters
crBack | Color to be set.
bUpdateReg | TRUE to update this setting in the registry, FALSE otherwise. By default, this parameter is FALSE.
Returns
TRUE if successful, otherwise FALSE.
See also
GetBackColor

◆ SetBreakpointBackColor()

BOOL SetBreakpointBackColor | ( | COLORREF | color,
 |  | BOOL | bUpdateReg = FALSE )

Sets the breakpoint background color.

Parameters
color | Color to be set.
bUpdateReg | TRUE to update this setting in the registry, FALSE otherwise. By default, this parameter is FALSE.
Returns
TRUE if successful, otherwise FALSE.
See also
GetBreakpointBackColor

◆ SetBreakpointTextColor()

BOOL SetBreakpointTextColor | ( | COLORREF | color,
 |  | BOOL | bUpdateReg = FALSE )

Sets the breakpoint text color.

Parameters
color | Color to be set.
bUpdateReg | TRUE to update this setting in the registry, FALSE otherwise. By default, this parameter is FALSE.
Returns
TRUE if successful, otherwise FALSE.
See also
GetBreakpointTextColor

◆ SetCopyCursor()

HCURSOR SetCopyCursor ( HCURSOR hCurCopy )

Sets the cursor shape for "copy" cursor.

Parameters
hCurCopy [in] Handle to the cursor. The cursor must have been created by the CreateCursor function or loaded by the LoadCursor or LoadImage function.
Returns
The handle of the previous cursor.

◆ SetFont()

BOOL SetFont ( LPLOGFONT pLogfont )

Set the common font.

Parameters
pLogfont Pointer to a LPLOGFONT structure.
Returns
TRUE if successful, otherwise FALSE.
See also
GetFont

◆ SetFontLineNumber()

BOOL SetFontLineNumber ( LPLOGFONT pLogfont )

Sets the line numbers font.

Parameters
pLogfont Pointer to a LPLOGFONT structure.
Returns
TRUE if successful, otherwise FALSE.
See also
GetFontLineNumber

◆ SetFontText()

BOOL SetFontText ( LPLOGFONT pLogfont )

Sets the editor text font.

Parameters
pLogfont Pointer to a LPLOGFONT structure.
Returns
TRUE if successful, otherwise FALSE.
See also
GetFontText

◆ SetFontToolTip()

BOOL SetFontToolTip ( LPLOGFONT pLogfont )

Sets the tooltip font.

Parameters
pLogfont Pointer to a LPLOGFONT structure.
Returns
TRUE if successful, otherwise FALSE.
See also
GetFontToolTip

◆ SetHiliteBackColor()

BOOL SetHiliteBackColor | ( | COLORREF | color,
 |  | BOOL | bUpdateReg = FALSE )

Sets the selected background color.

Parameters
color | Color to be set.
bUpdateReg | TRUE to update this setting in the registry, FALSE otherwise. By default, this parameter is FALSE.
Returns
TRUE if successful, otherwise FALSE.
See also
GetHiliteBackColor

◆ SetHiliteTextColor()

BOOL SetHiliteTextColor | ( | COLORREF | color,
 |  | BOOL | bUpdateReg = FALSE )

Sets the selected text color.

Parameters
color | Color to be set.
bUpdateReg | TRUE to update this setting in the registry, FALSE otherwise. By default, this parameter is FALSE.
Returns
TRUE if successful, otherwise FALSE.
See also
GetHiliteTextColor

◆ SetInactiveHiliteBackColor()

BOOL SetInactiveHiliteBackColor | ( | COLORREF | color,
 |  | BOOL | bUpdateReg = FALSE )

Sets the selected background color for when the control does not have focus.

Parameters
color | Color to be set.
bUpdateReg | TRUE to update this setting in the registry, FALSE otherwise. By default, this parameter is FALSE.
Returns
TRUE if successful, otherwise FALSE.
See also
GetInactiveHiliteBackColor

◆ SetInactiveHiliteTextColor()

BOOL SetInactiveHiliteTextColor | ( | COLORREF | color,
 |  | BOOL | bUpdateReg = FALSE )

Sets the selected text color for when the control does not have focus.

Parameters
color | Color to be set.
bUpdateReg | TRUE to update this setting in the registry, FALSE otherwise. By default, this parameter is FALSE.
Returns
TRUE if successful, otherwise FALSE.
See also
GetInactiveHiliteTextColor

◆ SetLineNumberBackColor()

BOOL SetLineNumberBackColor | ( | COLORREF | color,
 |  | BOOL | bUpdateReg = FALSE )

Sets the line numbers background color.

Parameters
color | Color to be set.
bUpdateReg | TRUE to update this setting in the registry, FALSE otherwise. By default, this parameter is FALSE.
Returns
TRUE if successful, otherwise FALSE.
See also
GetLineNumberBackColor

◆ SetLineNumberTextColor()

BOOL SetLineNumberTextColor | ( | COLORREF | color,
 |  | BOOL | bUpdateReg = FALSE )

Sets the line numbers text color.

Parameters
color | Color to be set.
bUpdateReg | TRUE to update this setting in the registry, FALSE otherwise. By default, this parameter is FALSE.
Returns
TRUE if successful, otherwise FALSE.
See also
GetLineNumberTextColor

◆ SetLineSelCursor()

HCURSOR SetLineSelCursor ( HCURSOR hCurLine )

Sets the line selection cursor.

Parameters
hCurLine [in] Handle to the cursor. The cursor must have been created by the CreateCursor function or loaded by the LoadCursor or LoadImage function. Cursor appears in lines selection area.
Returns
The handle of the previous cursor.

◆ SetMoveCursor()

HCURSOR SetMoveCursor ( HCURSOR hCurMove )

Sets the cursor shape for "move" cursor.

Parameters
hCurMove [in] Handle to the cursor. The cursor must have been created by the CreateCursor function or loaded by the LoadCursor or LoadImage function.
Returns
The handle of the previous cursor.

◆ SetReadOnlyBackColor()

BOOL SetReadOnlyBackColor | ( | COLORREF | crBack,
 |  | BOOL | bUpdateReg = FALSE )

Sets the background color for read-only mode.

Parameters
crBack | Color to be set.
bUpdateReg | TRUE to update this setting in the registry, FALSE otherwise. By default, this parameter is FALSE.
Returns
TRUE if successful, otherwise FALSE.
See also
GetBackColor

◆ SetTextColor()

BOOL SetTextColor | ( | COLORREF | crText,
 |  | BOOL | bUpdateReg = FALSE )

Sets the text color.

Parameters
crText | Color to be set.
bUpdateReg | TRUE to update this setting in the registry, FALSE otherwise. By default, this parameter is FALSE.
Returns
TRUE if successful, otherwise FALSE.
See also
GetTextColor

◆ UpdateTextFont()

virtual BOOL UpdateTextFont | ( | CXTPSyntaxEditCtrl * | pEditCtrl,
 |  | const XTP_EDIT_FONTOPTIONS & | lf )
 virtual

Updates the edit control text font.

Parameters
pEditCtrl | [in] Pointer to the edit control.
lf | [in] Reference to an XTP_EDIT_FONTOPTIONS structure.
Returns
TRUE if the edit control text font was updated, otherwise FALSE.
See also
LOGFONT

Member Data Documentation

◆ m_sLineNumberFormat

CString m_sLineNumberFormat

String to customize Line Number format (e.g.

keep it fixed legnth like %04d) If empty - Control used default - variable legnth Line Numbers)

The documentation for this class was generated from the following file:
  • XTPSyntaxEditPaintManager.h


Toolkit Pro: CXTPSyntaxEditPropertiesDlg Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPSyntaxEditPropertiesDlg Class Reference

This class provides a default dialog to edit SyntaxEdit control settings. More...

Public Member Functions

CXTPSyntaxEditPropertiesDlg (CXTPSyntaxEditView *pEditView=NULL)
Default object constructor.
virtual ~CXTPSyntaxEditPropertiesDlg ()
Default object destructor.

Protected Member Functions

DECLARE_MESSAGE_MAP () CXTPSyntaxEditPropertiesPageEdit m_Page1
Property page for common edit options.

Protected Attributes

CXTPSyntaxEditPropertiesPageFont | m_Page2
Property page for font options.
CXTPSyntaxEditPropertiesPageColor | m_Page3
Property page for colors options.

Detailed Description

This class provides a default dialog to edit SyntaxEdit control settings.

Constructor & Destructor Documentation

◆ CXTPSyntaxEditPropertiesDlg()

CXTPSyntaxEditPropertiesDlg ( CXTPSyntaxEditView * pEditView = NULL )

Default object constructor.

Parameters
pEditView Pointer to a CXTPSyntaxEditView object.
The documentation for this class was generated from the following file:
  • XTPSyntaxEditPropertiesDlg.h


Toolkit Pro: CXTPSyntaxEditPropertiesPageColor Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPSyntaxEditPropertiesPageColor Class Reference

This class implements property page colors options. More...

Public Member Functions

CXTPSyntaxEditPropertiesPageColor (CXTPSyntaxEditView *pEditView=NULL)
Default object constructor.
virtual | ~CXTPSyntaxEditPropertiesPageColor ()
Default object destructor.
BOOL | WriteRegistryValues ()
Writes controls state (options) to the registry.
void | SetModified (BOOL bChanged=TRUE)
Sets the value of the modified flag.

Protected Member Functions

void | UpdateSampleColors ()
Updates the colors for a sample text control.
void | UpdateFont ()
Updates the font for a sample text control.
BOOL | InitSchemaClasses (XTP_EDIT_SCHEMAFILEINFO *pSchemaInfo)
Initializes dialog controls for a specified lex schema.
void | InitClassData (const XTPSyntaxEditLexAnalyser::XTP_EDIT_LEXCLASSINFO &infoClass)
Initializes dialog controls for a specified lex class.
BOOL | IsTopLevelClass (const XTPSyntaxEditLexAnalyser::XTP_EDIT_LEXCLASSINFO &infoClass)
Determines if a specified class is a top-level schema class.
void | EnableControls ()
Updates controls state (enabled/disabled).
CString | GetPropValue (const XTPSyntaxEditLexAnalyser::XTP_EDIT_LEXPROPINFO &infoProp) const
Gets a specified lex property as a comma-separated string.
void | SetDefaults ()
Sets defaults controls state.
int | PropExists (XTPSyntaxEditLexAnalyser::CXTPSyntaxEditLexPropInfoArray &arrProp, LPCTSTR lpszPropName)
Determines if a specified property data exists within a specified array.
BOOL | UpdateFontValue (BOOL &bValue, LPCTSTR lpszPropName)
Updates the font parameters for the currently selected lex class.
BOOL | UpdateColorValue (CXTPSyntaxEditColorComboBox &combo, COLORREF &color, LPCTSTR lpszPropName)
Updates the color parameters for currently selected lex class.
CString | GetDisplayName (const XTPSyntaxEditLexAnalyser::XTP_EDIT_LEXCLASSINFO &info) const
Gets the display name property value of a lex class.

Protected Attributes

BOOL | m_bModified
Modified flag.
CXTPSyntaxEditView * | m_pEditView
Pointer to a CXTPSyntaxEditView object.
CXTPSyntaxEditConfigurationManager * | m_ptrConfigMgr
Pointer to Configuration Manager.
CXTPSyntaxEditTextSchemesManager * | m_pTextSchemesMgr
Pointer to Schemes Manager.
CXTPFont | m_xtpFontEdit
Editor font.
CMapStringToPtr | m_mapLexClassInfo
Map lex schema name to schema classes array (CXTPSyntaxEditLexClassInfoArray*).
XTPSyntaxEditLexAnalyser::CXTPSyntaxEditLexClassInfoArray * | m_parLexClassInfo
selected schema classes.

Detailed Description

This class implements property page colors options.

Constructor & Destructor Documentation

◆ CXTPSyntaxEditPropertiesPageColor()

CXTPSyntaxEditPropertiesPageColor ( CXTPSyntaxEditView * pEditView = NULL )

Default object constructor.

Parameters
pEditView Pointer to a CXTPSyntaxEditView object.

Member Function Documentation

◆ GetDisplayName()

CString GetDisplayName ( const XTPSyntaxEditLexAnalyser::XTP_EDIT_LEXCLASSINFO & info ) const
protected

Gets the display name property value of a lex class.

Parameters
info Reference to an XTP_EDIT_LEXCLASSINFO object.
Returns
The display name property value of the lex class.

◆ GetPropValue()

CString GetPropValue ( const XTPSyntaxEditLexAnalyser::XTP_EDIT_LEXPROPINFO & infoProp ) const
protected

Gets a specified lex property as a comma-separated string.

Parameters
infoProp Reference to an XTP_EDIT_LEXPROPINFO object.
Returns
The specified lex property as a comma-separated string.
See also
XTP_EDIT_LEXPROPINFO

◆ InitClassData()

void InitClassData ( const XTPSyntaxEditLexAnalyser::XTP_EDIT_LEXCLASSINFO & infoClass )
protected

Initializes dialog controls for a specified lex class.

Parameters
infoClass Reference to an XTP_EDIT_LEXCLASSINFO object.

◆ InitSchemaClasses()

BOOL InitSchemaClasses ( XTP_EDIT_SCHEMAFILEINFO * pSchemaInfo )
protected

Initializes dialog controls for a specified lex schema.

Parameters
pSchemaInfo Pointer to an XTP_EDIT_SCHEMAFILEINFO object.
Returns
TRUE if successful, otherwise FALSE.

◆ IsTopLevelClass()

BOOL IsTopLevelClass ( const XTPSyntaxEditLexAnalyser::XTP_EDIT_LEXCLASSINFO & infoClass )
protected

Determines if a specified class is a top-level schema class.

Parameters
infoClass Reference to an XTP_EDIT_LEXCLASSINFO object.
Returns
TRUE if the specified class is a top-level schema class, otherwise FALSE.

◆ PropExists()

int PropExists | ( | XTPSyntaxEditLexAnalyser::CXTPSyntaxEditLexPropInfoArray & | arrProp,
 |  | LPCTSTR | lpszPropName )
 protected

Determines if a specified property data exists within a specified array.

Parameters
arrProp | Reference to the properties data array.
lpszPropName | Lex property name.
Returns
The index of the specified property data within the specified array if it exists, otherwise a value of -1.

◆ SetModified()

void SetModified ( BOOL bChanged = TRUE )

Sets the value of the modified flag.

Parameters
bChanged TRUE if options were modified, FALSE otherwise.
See also
CPropertyPage::SetModified

◆ UpdateColorValue()

BOOL UpdateColorValue | ( | CXTPSyntaxEditColorComboBox & | combo,
 |  | COLORREF & | color,
 |  | LPCTSTR | lpszPropName )
 protected

Updates the color parameters for currently selected lex class.

Parameters
combo | Reference to an edit color combo box.
color | Reference to the value to be set.
lpszPropName | Lex class property name (color attribute).
Returns
TRUE if successful, otherwise FALSE.
See also
UpdateFontValue

◆ UpdateFontValue()

BOOL UpdateFontValue | ( | BOOL & | bValue,
 |  | LPCTSTR | lpszPropName )
 protected

Updates the font parameters for the currently selected lex class.

Parameters
lpszPropName | Lex class property name (font attribute).
bValue | Reference to the value to be set.
Returns
TRUE if successful, otherwise FALSE.
See also
UpdateColorValue

◆ WriteRegistryValues()

BOOL WriteRegistryValues ( )

Writes controls state (options) to the registry.

Returns
TRUE if successful, otherwise FALSE.
The documentation for this class was generated from the following file:
  • XTPSyntaxEditPropertiesPage.h


Toolkit Pro: CXTPSyntaxEditPropertiesPageEdit Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPSyntaxEditPropertiesPageEdit Class Reference

This class implements a property page for common edit options. More...

Public Member Functions

CXTPSyntaxEditPropertiesPageEdit (CXTPSyntaxEditView *pEditView=NULL)
Default object constructor.
virtual ~CXTPSyntaxEditPropertiesPageEdit ()
Default object destructor.

Protected Member Functions

BOOL | ReadRegistryValues ()
Reads controls state (options) from the registry.
BOOL | WriteRegistryValues ()
Writes controls state (options) to the registry.
void | SetModified (BOOL bChanged=TRUE)
Sets the value of the modified flag.

Protected Attributes

BOOL | m_bModified
Modified flag.
CXTPSyntaxEditView * | m_pEditView
Pointer to a CXTPSyntaxEditView object.

Detailed Description

This class implements a property page for common edit options.

Constructor & Destructor Documentation

◆ CXTPSyntaxEditPropertiesPageEdit()

CXTPSyntaxEditPropertiesPageEdit ( CXTPSyntaxEditView * pEditView = NULL )

Default object constructor.

Parameters
pEditView Pointer to a CXTPSyntaxEditView object.

Member Function Documentation

◆ ReadRegistryValues()

BOOL ReadRegistryValues ( )
protected

Reads controls state (options) from the registry.

Returns
TRUE if successful, otherwise FALSE.
See also
WriteRegistryValues

◆ SetModified()

void SetModified ( BOOL bChanged = TRUE )
protected

Sets the value of the modified flag.

Parameters
bChanged TRUE if options were modified, FALSE otherwise.
See also
CPropertyPage::SetModified

◆ WriteRegistryValues()

BOOL WriteRegistryValues ( )
protected

Writes controls state (options) to the registry.

Returns
TRUE if successful, otherwise FALSE.
See also
ReadRegistryValues
The documentation for this class was generated from the following file:
  • XTPSyntaxEditPropertiesPage.h


Toolkit Pro: CXTPSyntaxEditPropertiesPageFont Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPSyntaxEditPropertiesPageFont Class Reference

This class implements property page font options. More...

Public Member Functions

CXTPSyntaxEditPropertiesPageFont (CXTPSyntaxEditView *pEditView=NULL)
Default object constructor.
virtual | ~CXTPSyntaxEditPropertiesPageFont ()
Default object destructor.
CFont & | GetEditFont ()
Gets the editor font.
BOOL | GetSafeLogFont (LOGFONT &lf)
Gets the LOGFONT data for the editor font object.
BOOL | CreateSafeFontIndirect (CFont &editFont, const LOGFONT &lf)
Sets the font for a specified CFont object.

Protected Member Functions

void | InitFontCombo ()
Initializes the font name combo box.
void | InitStyleCombo ()
Initializes the font style combo box.
void | InitSizeCombo ()
Initializes the font size combo box.
void | InitScriptCombo ()
Initializes the font script combo box.
void | InitColorComboxes ()
Initializes the color combo box.
void | UpdateSampleFont ()
Updates the font for a sample text control.
void | UpdateSampleColors ()
Updates the colors for a sample text control.
int | GetLBText (CComboBox &comboBox, CString &csItemText)
Gets the text of the selected list box item and updates the combo box.
BOOL | ReadRegistryValues ()
Reads controls state (options) from the registry.
BOOL | WriteRegistryValues ()
Writes controls state (options) to the registry.
void | SetModified (BOOL bChanged=TRUE)
Sets the value of the modified flag.
CXTPSyntaxEditPaintManager * GetPaintManager ()
Gets the edit control paint manager.

Protected Attributes

const UINT | m_uFaceSize
Face name maximum string size.
BYTE | m_iCharSet
Char set.
BOOL | m_bModified
Modified flag.
CXTPSyntaxEditView * | m_pEditView
Pointer to a CXTPSyntaxEditView object.
CXTPFont | m_xtpFontEdit
Editor font.

Detailed Description

This class implements property page font options.

Constructor & Destructor Documentation

◆ CXTPSyntaxEditPropertiesPageFont()

CXTPSyntaxEditPropertiesPageFont ( CXTPSyntaxEditView * pEditView = NULL )

Default object constructor.

Parameters
pEditView Pointer to a CXTPSyntaxEditView object.

Member Function Documentation

◆ CreateSafeFontIndirect()

BOOL CreateSafeFontIndirect | ( | CFont & | editFont,
 |  | const LOGFONT & | lf )

Sets the font for a specified CFont object.

Parameters
editFont | Reference to the CFont object to set the font of.
lf | Reference to a LOGFONT structure containing the font to be set.

The previous font will be deleted.

Returns
TRUE if successful, otherwise FALSE.
See also
CFont::CreateFontIndirect

◆ GetEditFont()

AFX_INLINE CFont & GetEditFont ( )

Gets the editor font.

Returns
A reference to the editor font.
See also
GetSafeLogFont

◆ GetLBText()

int GetLBText | ( | CComboBox & | comboBox,
 |  | CString & | csItemText )
 protected

Gets the text of the selected list box item and updates the combo box.

Parameters
comboBox | [in] Reference to a CComboBox object.
csItemText | [out] Reference to a CString to receive the text of the selected list box item.
Returns
The index of the selected list box item if successful, otherwise CB_ERR.
See also
CComboBox::GetLBText

◆ GetPaintManager()

CXTPSyntaxEditPaintManager * GetPaintManager ( )
protected

Gets the edit control paint manager.

Returns
A pointer to the edit control paint manager.

◆ GetSafeLogFont()

BOOL GetSafeLogFont ( LOGFONT & lf )

Gets the LOGFONT data for the editor font object.

Parameters
lf Reference to a LOGFONT structure to receive the font data.
Returns
TRUE if the font data was obtained, otherwise FALSE.
See also
GetEditFont

◆ ReadRegistryValues()

BOOL ReadRegistryValues ( )
protected

Reads controls state (options) from the registry.

Returns
TRUE if successful, otherwise FALSE.
See also
WriteRegistryValues

◆ SetModified()

void SetModified ( BOOL bChanged = TRUE )
protected

Sets the value of the modified flag.

Parameters
bChanged TRUE if options were modified, FALSE otherwise.
See also
CPropertyPage::SetModified

◆ WriteRegistryValues()

BOOL WriteRegistryValues ( )
protected

Writes controls state (options) to the registry.

Returns
TRUE if successful, otherwise FALSE.
See also
ReadRegistryValues
The documentation for this class was generated from the following file:
  • XTPSyntaxEditPropertiesPage.h


Toolkit Pro: CXTPSyntaxEditReplaceStringCommand Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPSyntaxEditReplaceStringCommand Class Reference

This class represents the replace string command. More...

Inheritance diagram for CXTPSyntaxEditReplaceStringCommand:
[legend]

Public Member Functions

CXTPSyntaxEditReplaceStringCommand (CXTPSyntaxEditBufferManager *pMgr, LPCTSTR szText, LPCTSTR szReplacedText, const XTP_EDIT_LINECOL &lcFrom, const XTP_EDIT_LINECOL &lcTo)
Creates the replace string command object, initializes its members.
virtual | ~CXTPSyntaxEditReplaceStringCommand ()
A default command destructor.
virtual int | Execute (XTP_EDIT_LINECOL &lcFrom, XTP_EDIT_LINECOL &lcTo, CXTPSyntaxEditCtrl *pEditCtrl)
Executes the delete string command.
virtual int | UnExecute (XTP_EDIT_LINECOL &lcFrom, XTP_EDIT_LINECOL &lcTo, CXTPSyntaxEditCtrl *pEditCtrl)
Unexecutes the delete string command (i.e.
virtual int | GetDataSize () const
Gets the undo command data size (in bytes).
- Public Member Functions inherited from CXTPSyntaxEditBufferCommand
virtual | ~CXTPSyntaxEditBufferCommand ()
A default command destructor.
- Public Member Functions inherited from CXTPSyntaxEditCommand
virtual | ~CXTPSyntaxEditCommand ()
A default command destructor.
virtual LPCTSTR | GetCommandText () const
Gets command text.
virtual void | SetCommandText (LPCTSTR szText)
Sets command text.

Protected Member Functions

int | DoReplaceText (LPCTSTR szText, XTP_EDIT_LINECOL &lcFrom, XTP_EDIT_LINECOL &lcTo, CXTPSyntaxEditCtrl *pEditCtrl)
Performs the replace text operation.
- Protected Member Functions inherited from CXTPSyntaxEditBufferCommand
CXTPSyntaxEditBufferCommand (CXTPSyntaxEditBufferManager *pMgr, LPCTSTR szText, const XTP_EDIT_LINECOL &lcFrom, const XTP_EDIT_LINECOL &lcTo)
Creates the buffer command object, initializes its members.
int | DoInsertText (XTP_EDIT_LINECOL &lcFrom, XTP_EDIT_LINECOL &lcTo, CXTPSyntaxEditCtrl *pEditCtrl)
Inserts the stored text at the stored positions and returns the start and final affected text positions.
int | DoDeleteText (XTP_EDIT_LINECOL &lcFrom, XTP_EDIT_LINECOL &lcTo, CXTPSyntaxEditCtrl *pEditCtrl)
Deletes the text at the stored positions and returns the start and final affected text positions.
- Protected Member Functions inherited from CXTPSyntaxEditCommand
CXTPSyntaxEditCommand ()
Protected constructor because this class could not be instantiated itself, only by its descendants.

Protected Attributes

CString | m_strReplacedText
Buffer which holds the replaced text.
- Protected Attributes inherited from CXTPSyntaxEditBufferCommand
CXTPSyntaxEditBufferManager * | m_pBufferMgr
Pointer to the associated text buffer.
CString | m_strText
Changed text.
XTP_EDIT_LINECOL | m_lcFrom
Start edit position.
XTP_EDIT_LINECOL | m_lcTo
End edit position.
- Protected Attributes inherited from CXTPSyntaxEditCommand
CString | m_strCommandText
Text description of the command.

Additional Inherited Members

- Static Protected Member Functions inherited from CXTPSyntaxEditCommand
static void AFX_CDECL SetPositionInternally (CXTPSyntaxEditCtrl *pEditCtrl, const XTP_EDIT_LINECOL &lcPos)
Sets the line and column position for the specified control using internal fast methods.

Detailed Description

This class represents the replace string command.

Command execution will replace the text from the buffer between the specified text positions and un-execution will do the contrary replacement.

See also
CXTPSyntaxEditBufferCommand

Constructor & Destructor Documentation

◆ CXTPSyntaxEditReplaceStringCommand()

CXTPSyntaxEditReplaceStringCommand | ( | CXTPSyntaxEditBufferManager * | pMgr,
 |  | LPCTSTR | szText,
 |  | LPCTSTR | szReplacedText,
 |  | const XTP_EDIT_LINECOL & | lcFrom,
 |  | const XTP_EDIT_LINECOL & | lcTo )

Creates the replace string command object, initializes its members.

Parameters
pMgr | [in] Pointer to the associated buffer manager object.
szText | [in] Text which was inserted during the buffer operation.
szReplacedText | [in] Text which was changed during the buffer operation.
lcFrom | [in] Start text position affected by the command.
lcTo | [in] End text position affected by the command.

◆ ~CXTPSyntaxEditReplaceStringCommand()

virtual ~CXTPSyntaxEditReplaceStringCommand ( )
virtual

A default command destructor.

Destroys the command object, handles its cleanup and de-allocation.

Member Function Documentation

◆ DoReplaceText()

int DoReplaceText | ( | LPCTSTR | szText,
 |  | XTP_EDIT_LINECOL & | lcFrom,
 |  | XTP_EDIT_LINECOL & | lcTo,
 |  | CXTPSyntaxEditCtrl * | pEditCtrl )
 protected

Performs the replace text operation.

Parameters
szText | [in] Text to replace to.
lcFrom | [out] Start text position affected by the command.
lcTo | [out] End text position affected by the command.
pEditCtrl | [in] Pointer to the edit control.
Returns
A bitwise combination of the edit actions that occurred: XTP_EDIT_EDITACTION_MODIFYROW, XTP_EDIT_EDITACTION_INSERTROW

◆ Execute()

virtual int Execute | ( | XTP_EDIT_LINECOL & | lcFrom,
 |  | XTP_EDIT_LINECOL & | lcTo,
 |  | CXTPSyntaxEditCtrl * | pEditCtrl )
 virtual

Executes the delete string command.

Parameters
lcFrom | [out] Start text position affected by the command.
lcTo | [out] End text position affected by the command.
pEditCtrl | [in] Pointer to the edit control.
Returns
A bitwise combination of the edit actions that occurred: XTP_EDIT_EDITACTION_MODIFYROW, XTP_EDIT_EDITACTION_DELETEROW
See also
UnExecute

Implements CXTPSyntaxEditCommand.

◆ GetDataSize()

virtual int GetDataSize ( ) const
virtual

Gets the undo command data size (in bytes).

Returns
The undo command data size (in bytes).

Reimplemented from CXTPSyntaxEditBufferCommand.

◆ UnExecute()

virtual int UnExecute | ( | XTP_EDIT_LINECOL & | lcFrom,
 |  | XTP_EDIT_LINECOL & | lcTo,
 |  | CXTPSyntaxEditCtrl * | pEditCtrl )
 virtual

Unexecutes the delete string command (i.e.

inserts the string).

Parameters
lcFrom | [out] Start text position affected by the command.
lcTo | [out] End text position affected by the command.
pEditCtrl | [in] Pointer to the edit control.
Returns
A bitwise combination of the edit actions that occurred: XTP_EDIT_EDITACTION_MODIFYROW, XTP_EDIT_EDITACTION_INSERTROW
See also
Execute

Implements CXTPSyntaxEditCommand.

The documentation for this class was generated from the following file:
  • XTPSyntaxEditUndoManager.h


Toolkit Pro: CXTPSyntaxEditSelection Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPSyntaxEditSelection Class Reference

This class is used to represent syntax edit text selection and allows for selection properties to be get and set in two measurements: string and display. More...

Inheritance diagram for CXTPSyntaxEditSelection:
[legend]

Public Member Functions

CXTPSyntaxEditSelection ()
Default object constructor.
CXTPSyntaxEditSelection (const CXTPSyntaxEditSelection &rSrc)
Copy constructor.
virtual | ~CXTPSyntaxEditSelection ()
Default object destructor.
const XTP_EDIT_LINECOL & | GetStart_str () const
Gets the selection start position where the column is a zero-based char index in the string.
const XTP_EDIT_LINECOL & | GetEnd_str () const
Gets the selection end position where the column is a zero-based char index in the string.
const XTP_EDIT_LINECOL & | GetStart_disp () const
Gets the selection start position where the column is a one-based column index on the screen.
const XTP_EDIT_LINECOL & | GetEnd_disp () const
Gets the selection end position where the column is a one-based column index on the screen.
XTP_EDIT_LINECOL | GetNormalStart_str () const
Gets the normalized selection start.
XTP_EDIT_LINECOL | GetNormalStart_disp () const
Gets the normalized selection start.
XTP_EDIT_LINECOL | GetNormalEnd_str () const
Gets the normalized selection end.
XTP_EDIT_LINECOL | GetNormalEnd_disp () const
Gets the normalized selection end.
void | SetStart_str (int nTextRow, int nStrPos)
Sets the selection start position.
void | SetStart_disp (int nTextRow, int nDispCol)
Sets the selection start position.
void | SetEnd_str (int nTextRow, int nStrPos)
Sets the selection end position.
void | SetEnd_disp (int nTextRow, int nDispCol)
Sets the selection end position.
void | Reset_str (int nTextRow, int nStrPos)
Sets the selection start and end positions.
void | Reset_disp (int nTextRow, int nDispCol)
Sets the selection start and end positions.
BOOL | IsWordSelectionMode () const
Determines if the selection mode is 'Word' (enabled by pressing and holding Ctrl before selecting).
BOOL | IsbBlockSelectionMode () const
Determines if the selection mode is 'Block' (enabled by pressing and holding Alt before selecting).
BOOL | IsSelExist () const
Determines if the selection exists (i.e.
BOOL | IsSelNormal () const
Determines if the selection is 'Normal' (i.e.
BOOL | IsInSel_str (int nTextRow, int nStrPos) const
Determines if a specified position is inside the selection.
BOOL | IsInSel_disp (int nTextRow, int nDispCol) const
Determines if a specified position is inside the selection.
BOOL | IsIntersectSel_str (int nTextRow, int nStrPos1, int nStrPos2) const
Determines if a specified text range intersects the selection.
BOOL | IsIntersectSel_disp (int nTextRow, int nDispCol1, int nDispCol2) const
Determines if a specified text range intersects the selection.
BOOL | operator== (const CXTPSyntaxEditSelection &rSrc) const
Equality operator.
BOOL | operator!= (const CXTPSyntaxEditSelection &rSrc) const
Non-Equality operator.
const CXTPSyntaxEditSelection & | operator= (const CXTPSyntaxEditSelection &rSrc)
Copy operator.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Attributes

BOOL | bSelectingRunning
Stores the 'SelectingRunning' mode.
BOOL | bWordSelectionMode
TRUE if the selection mode is 'Word', otherwise FALSE.
BOOL | bBlockSelectionMode
TRUE if the selection mode is 'Block', otherwise FALSE.
int | nSelStartTextRowFromLeftBar
Stores the start selection line for full line selecting (from the left bar).

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

This class is used to represent syntax edit text selection and allows for selection properties to be get and set in two measurements: string and display.

Also the selection may be 'Normal' if its start is less then its end or 'Reverse' if its end is less than its start.

Constructor & Destructor Documentation

◆ CXTPSyntaxEditSelection()

CXTPSyntaxEditSelection ( const CXTPSyntaxEditSelection & rSrc )

Copy constructor.

Parameters
rSrc [in] Reference to a source object.

Member Function Documentation

◆ GetEnd_disp()

AFX_INLINE const XTP_EDIT_LINECOL & GetEnd_disp ( ) const

Gets the selection end position where the column is a one-based column index on the screen.

Returns
A reference to an XTP_EDIT_LINECOL object containing the selection end.
See also
GetStart_str, GetEnd_str, GetStart_disp, GetNormalStart_str, GetNormalStart_disp, GetNormalEnd_str, GetNormalEnd_disp, SetStart_str, SetStart_disp, SetEnd_str, SetEnd_disp, Reset_str, Reset_disp

◆ GetEnd_str()

AFX_INLINE const XTP_EDIT_LINECOL & GetEnd_str ( ) const

Gets the selection end position where the column is a zero-based char index in the string.

Returns
A reference to an XTP_EDIT_LINECOL object containing the selection end.
See also
GetStart_str, GetStart_disp, GetEnd_disp, GetNormalStart_str, GetNormalStart_disp, GetNormalEnd_str, GetNormalEnd_disp, SetStart_str, SetStart_disp, SetEnd_str, SetEnd_disp, Reset_str, Reset_disp

◆ GetNormalEnd_disp()

AFX_INLINE XTP_EDIT_LINECOL GetNormalEnd_disp ( ) const

Gets the normalized selection end.

Returns
A reference to an XTP_EDIT_LINECOL object which contains the normalized selection end.
See also
GetStart_str, GetEnd_str, GetStart_disp, GetEnd_disp, GetNormalStart_str, GetNormalStart_disp, SetStart_str, SetStart_disp, SetEnd_str, SetEnd_disp, Reset_str, Reset_disp

◆ GetNormalEnd_str()

AFX_INLINE XTP_EDIT_LINECOL GetNormalEnd_str ( ) const

Gets the normalized selection end.

Returns
A reference to an XTP_EDIT_LINECOL object which contains the normalized selection end.
See also
GetStart_str, GetEnd_str, GetStart_disp, GetEnd_disp, GetNormalStart_str, GetNormalStart_disp, SetStart_str, SetStart_disp, SetEnd_str, SetEnd_disp, Reset_str, Reset_disp

◆ GetNormalStart_disp()

AFX_INLINE XTP_EDIT_LINECOL GetNormalStart_disp ( ) const

Gets the normalized selection start.

Returns
A reference to an XTP_EDIT_LINECOL object which contains the normalized selection start.
See also
GetStart_str, GetEnd_str, GetStart_disp, GetEnd_disp, GetNormalEnd_str, GetNormalEnd_disp, SetStart_str, SetStart_disp, SetEnd_str, SetEnd_disp, Reset_str, Reset_disp

◆ GetNormalStart_str()

AFX_INLINE XTP_EDIT_LINECOL GetNormalStart_str ( ) const

Gets the normalized selection start.

Returns
A reference to an XTP_EDIT_LINECOL object which contains the normalized selection start.
See also
GetStart_str, GetEnd_str, GetStart_disp, GetEnd_disp, GetNormalEnd_str, GetNormalEnd_disp, SetStart_str, SetStart_disp, SetEnd_str, SetEnd_disp, Reset_str, Reset_disp

◆ GetStart_disp()

AFX_INLINE const XTP_EDIT_LINECOL & GetStart_disp ( ) const

Gets the selection start position where the column is a one-based column index on the screen.

Returns
A reference to an XTP_EDIT_LINECOL object containing the selection start.
See also
GetStart_str, GetEnd_str, GetEnd_disp, GetNormalStart_str, GetNormalStart_disp, GetNormalEnd_str, GetNormalEnd_disp, SetStart_str, SetStart_disp, SetEnd_str, SetEnd_disp, Reset_str, Reset_disp

◆ GetStart_str()

AFX_INLINE const XTP_EDIT_LINECOL & GetStart_str ( ) const

Gets the selection start position where the column is a zero-based char index in the string.

Returns
A reference to an XTP_EDIT_LINECOL object containing the selection start.
See also
GetEnd_str, GetStart_disp, GetEnd_disp, GetNormalStart_str, GetNormalStart_disp, GetNormalEnd_str, GetNormalEnd_disp, SetStart_str, SetStart_disp, SetEnd_str, SetEnd_disp, Reset_str, Reset_disp

◆ IsbBlockSelectionMode()

AFX_INLINE BOOL IsbBlockSelectionMode ( ) const

Determines if the selection mode is 'Block' (enabled by pressing and holding Alt before selecting).

Returns
TRUE if the selection mode is 'Block', otherwise FALSE.

◆ IsInSel_disp()

AFX_INLINE BOOL IsInSel_disp | ( | int | nTextRow,
 |  | int | nDispCol ) const

Determines if a specified position is inside the selection.

Parameters
nTextRow | Text row number.
nDispCol | One-based column index on the screen.
Returns
TRUE if the specified position is inside the selection, otherwise FALSE.

◆ IsInSel_str()

AFX_INLINE BOOL IsInSel_str | ( | int | nTextRow,
 |  | int | nStrPos ) const

Determines if a specified position is inside the selection.

Parameters
nTextRow | Text row number.
nStrPos | Zero-based char index in the string.
Returns
TRUE if the specified position is inside the selection, otherwise FALSE.
See also
IsIntersectSel_str, IsIntersectSel_disp

◆ IsIntersectSel_disp()

AFX_INLINE BOOL IsIntersectSel_disp | ( | int | nTextRow,
 |  | int | nDispCol1,
 |  | int | nDispCol2 ) const

Determines if a specified text range intersects the selection.

Parameters
nTextRow | Text row number.
nDispCol1 | Text range start position (one-based column index on the screen).
nDispCol2 | Text range end position (one-based column index on the screen).
Returns
TRUE if the specified text range intersects the selection, otherwise FALSE.
See also
IsIntersectSel_str, IsIntersectSel_disp

◆ IsIntersectSel_str()

AFX_INLINE BOOL IsIntersectSel_str | ( | int | nTextRow,
 |  | int | nStrPos1,
 |  | int | nStrPos2 ) const

Determines if a specified text range intersects the selection.

Parameters
nTextRow | Text row number.
nStrPos1 | Text range start position (zero-based char index in the string).
nStrPos2 | Text range end position (zero-based char index in the string).
Returns
TRUE if the specified text range intersects the selection, otherwise FALSE.
See also
IsIntersectSel_str, IsIntersectSel_disp

◆ IsSelExist()

BOOL IsSelExist ( ) const

Determines if the selection exists (i.e.

start != end).

Returns
TRUE if the selection exists, otherwise FALSE.

◆ IsSelNormal()

AFX_INLINE BOOL IsSelNormal ( ) const

Determines if the selection is 'Normal' (i.e.

start < end).

Returns
TRUE if the selection is 'Normal', otherwise FALSE.

◆ IsWordSelectionMode()

AFX_INLINE BOOL IsWordSelectionMode ( ) const

Determines if the selection mode is 'Word' (enabled by pressing and holding Ctrl before selecting).

Returns
TRUE if the selection mode is 'Word', otherwise FALSE.

◆ operator!=()

BOOL operator!= ( const CXTPSyntaxEditSelection & rSrc ) const

Non-Equality operator.

Compares the current object to a specified object.

Parameters
rSrc Reference to a CXTPSyntaxEditSelection object to compare to.
Returns
TRUE if the current object and the specified object are not equal, otherwise FALSE.

◆ operator=()

const CXTPSyntaxEditSelection & operator= ( const CXTPSyntaxEditSelection & rSrc )

Copy operator.

Initializes members from a specified object.

Parameters
rSrc Reference to a CXTPSyntaxEditSelection object to copy from.
Returns
A reference to the current object.

◆ operator==()

BOOL operator== ( const CXTPSyntaxEditSelection & rSrc ) const

Equality operator.

Compares the current object to a specified object.

Parameters
rSrc Reference to a CXTPSyntaxEditSelection object to compare to.
Returns
TRUE if the current object and the specified object are equal, otherwise FALSE.

◆ Reset_disp()

void Reset_disp | ( | int | nTextRow,
 |  | int | nDispCol )

Sets the selection start and end positions.

The selection is empty in this case.

Parameters
nTextRow | Text row number.
nDispCol | One-based column index on the screen.
See also
SetStart_str, SetStart_disp, GetStart_str, GetEnd_str, GetStart_disp, GetEnd_disp, GetNormalStart_str, GetNormalStart_disp, GetNormalEnd_str, GetNormalEnd_disp

◆ Reset_str()

void Reset_str | ( | int | nTextRow,
 |  | int | nStrPos )

Sets the selection start and end positions.

The selection is empty in this case.

Parameters
nTextRow | Text row number.
nStrPos | Zero-based char index in the string.
See also
SetStart_str, SetStart_disp, GetStart_str, GetEnd_str, GetStart_disp, GetEnd_disp, GetNormalStart_str, GetNormalStart_disp, GetNormalEnd_str, GetNormalEnd_disp

◆ SetEnd_disp()

void SetEnd_disp | ( | int | nTextRow,
 |  | int | nDispCol )

Sets the selection end position.

Parameters
nTextRow | Text row number.
nDispCol | One-based column index on the screen.
See also
SetStart_str, SetStart_disp, GetStart_str, GetEnd_str, GetStart_disp, GetNormalStart_str, GetNormalStart_disp, GetNormalEnd_str, GetNormalEnd_disp, Reset_str, Reset_disp

◆ SetEnd_str()

void SetEnd_str | ( | int | nTextRow,
 |  | int | nStrPos )

Sets the selection end position.

Parameters
nTextRow | Text row number.
nStrPos | Zero-based char index in the string.
See also
SetStart_str, SetStart_disp, GetStart_str, GetEnd_str, GetStart_disp, GetNormalStart_str, GetNormalStart_disp, GetNormalEnd_str, GetNormalEnd_disp, Reset_str, Reset_disp

◆ SetStart_disp()

void SetStart_disp | ( | int | nTextRow,
 |  | int | nDispCol )

Sets the selection start position.

Parameters
nTextRow | Text row number.
nDispCol | One-based column index on the screen.
See also
SetEnd_str, SetEnd_disp, GetStart_str, GetEnd_str, GetStart_disp, GetEnd_disp, GetNormalStart_str, GetNormalStart_disp, GetNormalEnd_str, GetNormalEnd_disp, Reset_str, Reset_disp

◆ SetStart_str()

void SetStart_str | ( | int | nTextRow,
 |  | int | nStrPos )

Sets the selection start position.

Parameters
nTextRow | Text row number.
nStrPos | Zero-based char index in the string.
See also
SetEnd_str, SetEnd_disp, GetStart_str, GetEnd_str, GetStart_disp, GetEnd_disp, GetNormalStart_str, GetNormalStart_disp, GetNormalEnd_str, GetNormalEnd_disp, Reset_str, Reset_disp
The documentation for this class was generated from the following file:
  • XTPSyntaxEditSelection.h


Toolkit Pro: CXTPSyntaxEditTextIterator Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPSyntaxEditTextIterator Class Reference

This class provides functionality to navigate text in the data buffer, seek forward/backward, retrieve text by lines, and determine control symbols like CRLF. More...

Inheritance diagram for CXTPSyntaxEditTextIterator:
[legend]

Public Member Functions

CXTPSyntaxEditTextIterator (CXTPSyntaxEditBufferManager *pData)
Default object constructor.
virtual | ~CXTPSyntaxEditTextIterator (void)
Destroys a CXTPSyntaxEditTextIterator object, handles cleanup and de-allocation.
virtual CString | GetEOL () const
Gets the current CRLF control symbol.
virtual void | SeekBegin ()
Repositions the "current position pointer" in the internal data buffer to the begin.
virtual BOOL | SeekPos (const XTP_EDIT_LINECOL &posLC, HANDLE hBreakEvent=NULL)
Repositions the "current position pointer" in the internal data buffer to the specified position.
virtual LPCTSTR | GetText (int nCharsBuf=512)
Returns text of required length.
virtual LPCTSTR | SeekNext (DWORD dwChars=1, int nCharsBuf=512)
Moves current position and return pointer to the text begin.
virtual LPCTSTR | SeekPrev ()
Moves current position back for 1 character, and return pointer to the text begin.
virtual BOOL | IsEOF () const
Determines if the end of data has been reached.
virtual XTP_EDIT_LINECOL | GetPosLC () const
Gets the current position.
virtual XTP_EDIT_LINECOL | GetPosLC_last (BOOL bWithEOL) const
Gets the last position.
virtual void | LCPosDec (XTP_EDIT_LINECOL &rLC) const
Decrements position.
virtual void | LCPosAdd (XTP_EDIT_LINECOL &rLC, int nCharsAdd) const
Increments position.
virtual int | GetLineLen (int nLine, BOOL bWithEOL=FALSE) const
Gets the length of a specified line.
virtual int | GetLineLenBytes (int nLine, BOOL bWithEOL) const
Gets the length (in bytes) of a specified line.
virtual void | SetTxtOffset (int nOffsetChars)
Sets the offset value.
virtual CString | GetFileExt () const
Gets the file name.
virtual int | GetMaxBackOffset () const
Gets the maximum buffer size (in characters) for back text offset.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

TCHAR * GetBuffer (int nOffsetB) const
Gets the buffer.

Protected Attributes

CXTPSyntaxEditBufferManager * | m_pData
Pointer to the used CXTPSyntaxEditBufferManager object.
XTP_EDIT_LINECOL | m_LCpos
Current position in the text.
BOOL | m_bEOF
End-Of-File flag.
CMap< DWORD, DWORD, int, int > | m_mapLine2Len
Map of line - length of line.
CArray< CHAR, CHAR > | m_arBuffer
Buffer of chars.
int | m_nBufSizeB
Buffer length.
int | m_nNextLine
Next line ID.
int | m_nBufOffsetB
Offset.
int | m_nBufOffsetB_normal
Offset.
int | m_nBufOffsetB_max
Offset.
int | m_nTmpOffsetC
Offset.
int | m_nTmpOffsetB
Offset.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

This class provides functionality to navigate text in the data buffer, seek forward/backward, retrieve text by lines, and determine control symbols like CRLF.

When you create an instance of the CXTPSyntaxEditTextIterator class, you should provide a pointer to data storage, represented by the CXTPSyntaxEditBufferManager class.

See also
CXTPSyntaxEditBufferManager.

Constructor & Destructor Documentation

◆ CXTPSyntaxEditTextIterator()

CXTPSyntaxEditTextIterator ( CXTPSyntaxEditBufferManager * pData )

Default object constructor.

Parameters
pData [in] Pointer to a CXTPSyntaxEditBufferManager object.
See also
CXTPSyntaxEditBufferManager.

Member Function Documentation

◆ GetBuffer()

AFX_INLINE TCHAR * GetBuffer ( int nOffsetB ) const
protected

Gets the buffer.

Parameters
nOffsetB [in] Offset (in bytes).
Returns
A pointer to the TCHAR buffer.

◆ GetEOL()

virtual CString GetEOL ( ) const
virtual

Gets the current CRLF control symbol.

Returns
The current CRLF control symbol.

Strings such as "\\r\\n", "\\n\\r", and "\\r" are recognized as CRLF control symbols.

◆ GetFileExt()

virtual CString GetFileExt ( ) const
virtual

Gets the file name.

Returns
The file name.

◆ GetLineLen()

virtual int GetLineLen | ( | int | nLine,
 |  | BOOL | bWithEOL = FALSE ) const
 virtual

Gets the length of a specified line.

Parameters
nLine | [in] Identifier of the line.
bWithEOL | [in] TRUE to include end-of-line characters, FALSE to ignore end-of-line characters.
Returns
The length of the specified line.

◆ GetLineLenBytes()

virtual int GetLineLenBytes | ( | int | nLine,
 |  | BOOL | bWithEOL ) const
 virtual

Gets the length (in bytes) of a specified line.

Parameters
nLine | [in] Identifier of the line.
bWithEOL | [in] TRUE to include end-of-line characters, FALSE to ignore end-of-line characters.
Returns
The length (in bytes) of the specified line.

◆ GetMaxBackOffset()

AFX_INLINE int GetMaxBackOffset ( ) const
virtual

Gets the maximum buffer size (in characters) for back text offset.

Returns
The maximum buffer size (in characters) for back text offset.
See also
SetTxtOffset

◆ GetPosLC()

virtual XTP_EDIT_LINECOL GetPosLC ( ) const
virtual

Gets the current position.

Returns
An XTP_EDIT_LINECOL structure containing the current position.
See also
XTP_EDIT_LINECOL

◆ GetPosLC_last()

virtual XTP_EDIT_LINECOL GetPosLC_last ( BOOL bWithEOL ) const
virtual

Gets the last position.

Parameters
bWithEOL TRUE to include EOL, FALSE otherwise.
Returns
An XTP_EDIT_LINECOL structure containing the last position.
See also
XTP_EDIT_LINECOL

◆ GetText()

virtual LPCTSTR GetText ( int nCharsBuf = 512 )
virtual

Returns text of required length.

Parameters
nCharsBuf [in] length of the text in bytes to be returned.

Call this member function to get text of required length. CRLF symbols are taken in account and don't remove from the returned string.

Returns
Pointer to the character string.

◆ IsEOF()

virtual BOOL IsEOF ( ) const
virtual

Determines if the end of data has been reached.

Returns
Nonzero if either the data buffer contains no records or if the user has scrolled beyond the last position, otherwise 0.

IsEOF can also be used to determine if the data buffer contains any data or is empty.

◆ LCPosAdd()

virtual void LCPosAdd | ( | XTP_EDIT_LINECOL & | rLC,
 |  | int | nCharsAdd ) const
 virtual

Increments position.

Parameters
rLC | [in] Reference to an XTP_EDIT_LINECOL structure.
nCharsAdd | [in] Number of characters to add.

◆ LCPosDec()

virtual void LCPosDec ( XTP_EDIT_LINECOL & rLC ) const
virtual

Decrements position.

Parameters
rLC [in] Reference to an XTP_EDIT_LINECOL structure.

◆ SeekBegin()

virtual void SeekBegin ( )
virtual

Repositions the "current position pointer" in the internal data buffer to the begin.

Call this member function to set the "current position pointer" in the internal data buffer to the begin. Besides it resets all others internal text counters.

See also
SeekPos()

◆ SeekNext()

virtual LPCTSTR SeekNext | ( | DWORD | dwChars = 1,
 |  | int | nCharsBuf = 512 )
 virtual

Moves current position and return pointer to the text begin.

Parameters
dwChars | [in] counts to move.
nCharsBuf | [in] length of the text in bytes to be returned.
Returns
Pointer to the character string.

◆ SeekPos()

virtual BOOL SeekPos | ( | const XTP_EDIT_LINECOL & | posLC,
 |  | HANDLE | hBreakEvent = NULL )
 virtual

Repositions the "current position pointer" in the internal data buffer to the specified position.

Parameters
posLC | [in] Position in the text to set as current.
hBreakEvent | [in] Handle to the break event to stop function execution.

Call this member function to set the "current position pointer" in the internal data buffer to the specified position. For big texts this operation may take a lot of time. hBreakEvent is used to to stop function execution without reaching the specified position.

Returns
TRUE if successful, otherwise FALSE.
See also
SeekBegin()

◆ SeekPrev()

virtual LPCTSTR SeekPrev ( )
virtual

Moves current position back for 1 character, and return pointer to the text begin.

Returns
Pointer to the character string or NULL if text begin is reached.

◆ SetTxtOffset()

virtual void SetTxtOffset ( int nOffsetChars )
virtual

Sets the offset value.

Parameters
nOffsetChars [in] Offset value to be set.
The documentation for this class was generated from the following file:
  • XTPSyntaxEditTextIterator.h


Toolkit Pro: CXTPSyntaxEditTextRegion Class Reference

Public Member Functions | Public Attributes | List of all members
CXTPSyntaxEditTextRegion Class Reference

This class is designed to store the coordinates of a text region. More...

Public Member Functions

void | Clear ()
Clears coordinates.
void | Set (const XTP_EDIT_LINECOL *pLCStart, const XTP_EDIT_LINECOL *pLCEnd)
Sets coordinates.

Public Attributes

XTP_EDIT_LINECOL | m_posStart
Start position in document coordinates.
XTP_EDIT_LINECOL | m_posEnd
End position in document coordinates.

Detailed Description

This class is designed to store the coordinates of a text region.

See also
XTP_EDIT_LINECOL

Member Function Documentation

◆ Set()

void Set | ( | const XTP_EDIT_LINECOL * | pLCStart,
 |  | const XTP_EDIT_LINECOL * | pLCEnd )

Sets coordinates.

Parameters
pLCStart | [in] Start position in document coordinates.
pLCEnd | [in] End position in document coordinates.
The documentation for this class was generated from the following file:
  • XTPSyntaxEditLexParser.h


Toolkit Pro: CXTPSyntaxEditTextSchemesManager Class Reference

Public Member Functions | List of all members
CXTPSyntaxEditTextSchemesManager Class Reference

This class provides the functionality to store the set of all text schemes that would be written from configuration files. More...

Public Member Functions

CXTPSyntaxEditTextSchemesManager ()
Default object constructor.
virtual | ~CXTPSyntaxEditTextSchemesManager ()
Destroys a CXTPSyntaxEditTextSchemesManager() object, handles cleanup and de-allocation.
void | AddTextSchemeInfo (XTP_EDIT_SCHEMAFILEINFO &info)
Adds text scheme information.
void | LoadTextScheme (XTP_EDIT_SCHEMAFILEINFO &info)
Implements common logic on creating new text scheme object and loading it from file or resources.
void | LoadTextStringScheme (XTP_EDIT_SCHEMAFILEINFO &info, CString *p_sSyntaxScheme)
Implements common logic on creating new text scheme object and loading it string - used for non-file configuration mode.
CXTPSyntaxEditTextSchemaPtr | GetSchema (const CString &strSchemeName)
Gets a schema by its name.
CString | GetSchemaName (const CString &csFileName) const
Gets a schema name by its file name.
CString | GetSchemaFileName (const CString &strSchemeName) const
Gets a file name by its schema name.
CStringArray & | GetSchemes ()
Gets all scheme names.
CXTPSyntaxEditSchemaFileInfoList * | GetSchemaList () const
Gets the schema list.
CXTPSyntaxEditTextSchemaPtr | FindSchema (const CString &strFileExt) const
Finds a schema by its file extension.
void | SetTheme (CXTPSyntaxEditColorTheme *pTheme)
Sets the theme for all text schemes.
BOOL | ReloadFile (const CString &csFileName, int nCfgFlags=0)
Reloads configuration settings from a specified configuration file.
void | RemoveAll ()
Removes all loaded data.

Detailed Description

This class provides the functionality to store the set of all text schemes that would be written from configuration files.

Member Function Documentation

◆ AddTextSchemeInfo()

void AddTextSchemeInfo ( XTP_EDIT_SCHEMAFILEINFO & info )

Adds text scheme information.

Parameters
info [in] Reference to the text scheme information.

◆ FindSchema()

CXTPSyntaxEditTextSchemaPtr FindSchema ( const CString & strFileExt ) const

Finds a schema by its file extension.

Parameters
strFileExt [in] Reference to the file extension string.
Returns
A CXTPSyntaxEditTextSchemaPtr object.
See also
CXTPSyntaxEditTextSchemaPtr

◆ GetSchema()

CXTPSyntaxEditTextSchemaPtr GetSchema ( const CString & strSchemeName )

Gets a schema by its name.

Parameters
strSchemeName [in] Reference to the schema name.
Returns
A CXTPSyntaxEditTextSchemaPtr object.
See also
CXTPSyntaxEditTextSchemaPtr

◆ GetSchemaFileName()

CString GetSchemaFileName ( const CString & strSchemeName ) const

Gets a file name by its schema name.

Parameters
strSchemeName [in] Reference to the schema name.
Returns
The file name.

◆ GetSchemaList()

AFX_INLINE CXTPSyntaxEditSchemaFileInfoList * GetSchemaList ( ) const

Gets the schema list.

Returns
A pointer to a CXTPSyntaxEditSchemaFileInfoList object.

◆ GetSchemaName()

CString GetSchemaName ( const CString & csFileName ) const

Gets a schema name by its file name.

Parameters
csFileName [in] Reference to the file name.
Returns
The schema name.

◆ GetSchemes()

AFX_INLINE CStringArray & GetSchemes ( )

Gets all scheme names.

Returns
A reference to the CStringArray object containing all scheme names.

◆ LoadTextScheme()

void LoadTextScheme ( XTP_EDIT_SCHEMAFILEINFO & info )

Implements common logic on creating new text scheme object and loading it from file or resources.

Parameters
info [in] Reference to schema information.

◆ LoadTextStringScheme()

void LoadTextStringScheme | ( | XTP_EDIT_SCHEMAFILEINFO & | info,
 |  | CString * | p_sSyntaxScheme )

Implements common logic on creating new text scheme object and loading it string - used for non-file configuration mode.

Parameters
info | [in] Reference to schema information.
p_sSyntaxScheme | Pointer to syntax scheme string.

◆ ReloadFile()

BOOL ReloadFile | ( | const CString & | csFileName,
 |  | int | nCfgFlags = 0 )

Reloads configuration settings from a specified configuration file.

Parameters
csFileName | [in] Reference to the configuration file name.
nCfgFlags | [in] Action flags.

Does nothing if the specified file is not found in the collection of files from the main configuration file.

Returns
TRUE if successful, FALSE otherwise.

◆ SetTheme()

void SetTheme ( CXTPSyntaxEditColorTheme * pTheme )

Sets the theme for all text schemes.

Parameters
pTheme [in] Pointer to the theme to be set.
See also
CXTPSyntaxEditColorTheme
The documentation for this class was generated from the following file:
  • XTPSyntaxEditLexColorFileReader.h


Toolkit Pro: CXTPSyntaxEditTipComboBox Class Reference

Public Member Functions | List of all members
CXTPSyntaxEditTipComboBox Class Reference

This class implements a combo box with a tooltip. More...

Public Member Functions

CXTPSyntaxEditTipListBox & GetListBox ()
Gets the attached list box.

Detailed Description

This class implements a combo box with a tooltip.

Member Function Documentation

◆ GetListBox()

AFX_INLINE CXTPSyntaxEditTipListBox & GetListBox ( )

Gets the attached list box.

Returns
A reference to the attached list box.
See also
CXTPSyntaxEditTipListBox
The documentation for this class was generated from the following file:
  • XTPSyntaxEditPropertiesPage.h


Toolkit Pro: CXTPSyntaxEditTipListBox Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPSyntaxEditTipListBox Class Reference

This class implements a list box with a tooltip. More...

Public Member Functions

CXTPSyntaxEditTipListBox ()
Default object constructor.
int | HitTest (LPPOINT pPoint=NULL) const
Determines which list box item, if any, is at a specified point.
int | HitTest (CPoint point, BOOL bIsClient=FALSE) const
Determines which list box item, if any, is at a specified point.
int | ShowTip (CPoint point, BOOL bIsClient=FALSE)
Shows the tooltip at a specified point, if any.
BOOL | SelChanged ()
Determines if the selection was changed by the user.

Protected Attributes

DWORD | m_dwIdx
Selection indexes: LOWORD - previous selection index, HIWORD - active selection index.
CXTPSyntaxEditTipWnd | m_wndInfoTip
Tooltip window.

Detailed Description

This class implements a list box with a tooltip.

Member Function Documentation

◆ HitTest() [1/2]

int HitTest | ( | CPoint | point,
 |  | BOOL | bIsClient = FALSE ) const

Determines which list box item, if any, is at a specified point.

Parameters
point | Point to be tested.
bIsClient | TRUE if the point contains client coordinates, FALSE if the point contains screen coordinates.
Returns
The list box item index at the specified point, if any, otherwise LB_ERR.

◆ HitTest() [2/2]

int HitTest ( LPPOINT pPoint = NULL ) const

Determines which list box item, if any, is at a specified point.

Parameters
pPoint Pointer to a POINT object or a NULL value. If the value of this parameter is NULL, then the current mouse coordinates are used.
Returns
The list box item index at the specified point, if any, otherwise LB_ERR.

◆ SelChanged()

BOOL SelChanged ( )

Determines if the selection was changed by the user.

Returns
TRUE if the selection was changed by the user, otherwise FALSE.

◆ ShowTip()

int ShowTip | ( | CPoint | point,
 |  | BOOL | bIsClient = FALSE )

Shows the tooltip at a specified point, if any.

Parameters
point | Point to be tested.
bIsClient | TRUE if the point contains client coordinates, FALSE if the point contains screen coordinates.
Returns
The list box item index at the specified point, if any, otherwise LB_ERR.
The documentation for this class was generated from the following file:
  • XTPSyntaxEditPropertiesPage.h


Toolkit Pro: CXTPSyntaxEditTipWnd Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPSyntaxEditTipWnd Class Reference

CXTPSyntaxEditTipWnd implements a tooltip window for the CXTPSyntaxEditTipListBox class. More...

Public Member Functions

CXTPSyntaxEditTipWnd ()
Default object constructor.
virtual | ~CXTPSyntaxEditTipWnd ()
Default object destructor.
virtual BOOL | Create (CListBox *pListBox)
Create a tooltip window.
virtual BOOL | IsOwnerDrawn ()
Determines if the attached list box has owner draw flags (LBS_OWNERDRAWFIXED or LBS_OWNERDRAWVARIABLE).
virtual BOOL | ShowTip (int iIndex)
Shows the tooltip for a specified list box item.
virtual BOOL | HideTip ()
Hides the tooltip.
virtual COLORREF | GetTextColor () const
Gets the tooltip text color.
virtual COLORREF | GetBackColor () const
Gets the tooltip background color.

Protected Member Functions

virtual BOOL | RegisterWindowClass (HINSTANCE hInstance=NULL)
Registers the window class if it has not already been registered.
virtual BOOL | OwnerDrawTip (CDC *pDC, CRect rClient)
Draws the tooltip for the owner drawn list box.
virtual BOOL | DrawTip (CDC *pDC, CRect rClient)
Draws the tooltip.
virtual BOOL | CalcItemRect (int iItem, CRect &rItem)
Gets the rectangle for a specified item.

Protected Attributes

int | m_iIndex
Current item index.
CRect | m_rWindow
Window rect.
CPoint | m_ptCursor
Cursor position.
CListBox * | m_pListBox
Pointer to the attached list box.

Detailed Description

CXTPSyntaxEditTipWnd implements a tooltip window for the CXTPSyntaxEditTipListBox class.

Member Function Documentation

◆ CalcItemRect()

virtual BOOL CalcItemRect | ( | int | iItem,
 |  | CRect & | rItem )
 protectedvirtual

Gets the rectangle for a specified item.

Parameters
iItem | [in] List box item index.
rItem | [out] Reference to a CRect object to receive the rectangle for the specified item.
Returns
TRUE if successful, otherwise FALSE.

◆ Create()

virtual BOOL Create ( CListBox * pListBox )
virtual

Create a tooltip window.

Parameters
pListBox Pointer to a CListBox to attach.
Returns
TRUE if successful, otherwise FALSE.
See also
ShowTip

◆ DrawTip()

virtual BOOL DrawTip | ( | CDC * | pDC,
 |  | CRect | rClient )
 protectedvirtual

Draws the tooltip.

Parameters
pDC | Pointer to a valid device context.
rClient | Tooltip rectangle (in client coordinates of this window).
Returns
TRUE if successful, otherwise FALSE.
See also
OwnerDrawTip

◆ GetBackColor()

virtual COLORREF GetBackColor ( ) const
virtual

Gets the tooltip background color.

Returns
The tooltip background color.
See also
GetTextColor

◆ GetTextColor()

virtual COLORREF GetTextColor ( ) const
virtual

Gets the tooltip text color.

Returns
The tooltip text color.
See also
GetBackColor

◆ HideTip()

virtual BOOL HideTip ( )
virtual

Hides the tooltip.

Returns
TRUE if the tooltip was visible prior to using this method and was successfully hidden by using this method, FALSE if the tooltip was hidden prior to using this method.
See also
ShowTip

◆ IsOwnerDrawn()

virtual BOOL IsOwnerDrawn ( )
virtual

Determines if the attached list box has owner draw flags (LBS_OWNERDRAWFIXED or LBS_OWNERDRAWVARIABLE).

Returns
TRUE if the attached list box is owner drawn, otherwise FALSE.
See also
CListBox, LBS_OWNERDRAWFIXED, LBS_OWNERDRAWVARIABLE

◆ OwnerDrawTip()

virtual BOOL OwnerDrawTip | ( | CDC * | pDC,
 |  | CRect | rClient )
 protectedvirtual

Draws the tooltip for the owner drawn list box.

Parameters
pDC | Pointer to a valid device context.
rClient | Tooltip rectangle (in client coordinates of this window).
Returns
TRUE if successful, otherwise FALSE.
See also
DrawTip

◆ RegisterWindowClass()

virtual BOOL RegisterWindowClass ( HINSTANCE hInstance = NULL )
protectedvirtual

Registers the window class if it has not already been registered.

Parameters
hInstance Instance of the resource where the control is located.
Returns
TRUE if the window class was successfully registered, otherwise FALSE.

◆ ShowTip()

virtual BOOL ShowTip ( int iIndex )
virtual

Shows the tooltip for a specified list box item.

Parameters
iIndex Index of the list box item to show the tooltip for.
Returns
TRUE if successful, otherwise FALSE.
See also
HideTip
The documentation for this class was generated from the following file:
  • XTPSyntaxEditPropertiesPage.h


Toolkit Pro: CXTPSyntaxEditToolTipCtrl Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPSyntaxEditToolTipCtrl Class Reference

The CXTPSyntaxEditToolTipCtrl class encapsulates the functionality of a "tip control," a small pop-up window that displays a single line of text describing the hidden text when hovering over an item on the report area. More...

Public Member Functions

CXTPSyntaxEditToolTipCtrl ()
Constructs a CXTPSyntaxEditToolTipCtrl object.
virtual | ~CXTPSyntaxEditToolTipCtrl ()
Destroys a CXTPSyntaxEditToolTipCtrl object, handles cleanup and de-allocation.
virtual BOOL | Create (CXTPSyntaxEditCtrl *pParentWnd)
Creates a smart edit tip window.
void | SetDelay (int nDelay)
Sets the display delay, in milliseconds, for the tooltip.
int | GetDelay () const
Gets the display delay, in milliseconds, of the tooltip.
void | Hide ()
Hides the tooltip window.
void | Activate (const CString &strText)
Activates the tooltip window.
void | SetHoverRect (CRect rc)
Sets the coordinates of the tooltip hover rectangle.

Protected Attributes

int | m_nDelayTime
Delay, in milliseconds, before showing the tooltip.
CXTPSyntaxEditCtrl * | m_pParentWnd
Pointer to the parent report window.
CRect | m_rcHover
Hover window coordinates.
CString | m_strToolTipText
Tooltip text.

Detailed Description

The CXTPSyntaxEditToolTipCtrl class encapsulates the functionality of a "tip control," a small pop-up window that displays a single line of text describing the hidden text when hovering over an item on the report area.

CXTPSyntaxEditToolTipCtrl provides the functionality to control the the tip text, the size of the tip window itself, and the text font of the tip.

This class is used by the Grid control internally.

See also
CXTPSyntaxEditCtrl

Constructor & Destructor Documentation

◆ CXTPSyntaxEditToolTipCtrl()

CXTPSyntaxEditToolTipCtrl ( )

Constructs a CXTPSyntaxEditToolTipCtrl object.

You construct a object object in two steps. First, call the constructor object and then call Create, which initializes the window and attaches it to the parent window.

Example: // Declare a local CXTPSyntaxEditToolTipCtrl object. CXTPSyntaxEditToolTipCtrl wndTip;

// Declare a dynamic CXTPSyntaxEditToolTipCtrl object. CXTPSyntaxEditToolTipCtrl* pTipWnd = new CXTPSyntaxEditToolTipCtrl;

See also
Create, Activate

Member Function Documentation

◆ Activate()

void Activate ( const CString & strText )

Activates the tooltip window.

Parameters
strText [in] Reference to the text to be shown within the tooltip window.

◆ Create()

virtual BOOL Create ( CXTPSyntaxEditCtrl * pParentWnd )
virtual

Creates a smart edit tip window.

Parameters
pParentWnd [in] Pointer to the parent Grid control window.
Returns
TRUE if the tip window was created successfully, otherwise FALSE.
See also
CXTPSyntaxEditCtrl::ShowCollapsedToolTip

◆ GetDelay()

AFX_INLINE int GetDelay ( ) const

Gets the display delay, in milliseconds, of the tooltip.

Returns
The display delay, in milliseconds, of the tooltip.
See also
void SetDelay(int nDelay);

◆ SetDelay()

AFX_INLINE void SetDelay ( int nDelay )

Sets the display delay, in milliseconds, for the tooltip.

Parameters
nDelay [in] Display delay, in milliseconds, to be set.
See also
int GetDelay();

◆ SetHoverRect()

AFX_INLINE void SetHoverRect ( CRect rc )

Sets the coordinates of the tooltip hover rectangle.

Parameters
rc [in] New tooltip hover rectangle in parent window coordinates.

This method should be called before activating the tooltip window.

See also
GetHoverRect()
The documentation for this class was generated from the following file:
  • XTPSyntaxEditToolTipCtrl.h


Toolkit Pro: CXTPSyntaxEditUndoRedoManager Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPSyntaxEditUndoRedoManager Class Reference

This class maintains the list of undo/redo commands. More...

Public Member Functions

CXTPSyntaxEditUndoRedoManager ()
Creates the undo/redo manager object, initializes its members.
virtual | ~CXTPSyntaxEditUndoRedoManager ()
Destroys the undo/redo manager object, handles its cleanup and de-allocation.
int | DoUndo (XTP_EDIT_LINECOL &lcFrom, XTP_EDIT_LINECOL &lcTo, CXTPSyntaxEditCtrl *pEditCtrl)
Performs a single undo operation (unexecutes the latest command).
int | DoRedo (XTP_EDIT_LINECOL &lcFrom, XTP_EDIT_LINECOL &lcTo, CXTPSyntaxEditCtrl *pEditCtrl)
Performs a single redo operation (executes the next command).
void | AddCommand (CXTPSyntaxEditCommand *pCommand)
Adds a command to the undo buffer.
void | Clear ()
Clears the undo manager buffer and deletes all commands.
BOOL | CanUndo () const
Determines if it is possible to perform the undo action.
BOOL | CanRedo () const
Determines if it is possible to perform the redo action.
void | MarkSaved ()
Marks the current command buffer position as last saved.
BOOL | IsModified () const
Determines if the document was modified by any command from the buffer since the document was last saved/loaded.
void | SetGroupInsertMode (BOOL bInsertInGroup=TRUE)
Enables/disables group insert mode.
void | ChainLastCommand ()
Merges the latest undo command into a batch command with the previous undo command.
void | SetLastCommandText (LPCTSTR szText)
Sets the text for the last undo command in the stack.
void | SetLastCommandText (UINT nTextId)
Sets the text for the last undo command in the stack.
const CStringList & | GetUndoTextList ()
Gets the list of text for undo operations.
const CStringList & | GetRedoTextList ()
Gets the list of text for redo operations.
virtual int | GetDataSize () const
Gets the undo buffer data size (in bytes).
virtual void | LimitDataSize (int nNewCommandData, int nDataSizeLimit)
Checks the undo buffer data size and removes old stored commands to clear memory if the data size limit has been reached.

Protected Attributes

CPtrList | m_CommandList
Commands buffer.
POSITION | m_posFirstUndo
Actual command position in the buffer.
POSITION | m_posSavedMark
Last saved command position in the buffer.
BOOL | m_bGroupInsertMode
TRUE if group insert mode is on, FALSE otherwise.
int | m_nDataSizeLimit
Memory limit for undo data.

Detailed Description

This class maintains the list of undo/redo commands.

It is managed by the CEditBufferManager class.

This class allows for adding new commands in the buffer (see AddCommand), undoing the last added operation (see DoUndo), and redoing operations following the latest unexecuted operation (see DoRedo).

This class also allows for checking if it is possible to perform undo/redo operations (see CanUndo / CanRedo).

This class also allows for marking the current position of the undo/redo operation queue as saved, and returns the "modified" flag if the queue position will be changed (see MarkSaved / IsModified).

Another piece of the functionality is commands grouping. The following methods are related to this: SetGroupInsertMode and ChainLastCommand. ChainLastCommand forces the latest added undo command to be merged into a group with the previous undo command. This method could be useful for group operations like moving a selected text by mouse. In this case, there would be 2 different commands added: remove selected text from its original position and insert it into the new position. By using ChainLastCommand, both of these operations would be merged into a single ooperation, which will be further done/undone together. SetGroupInsertMode forces the undo/redo manager to merge all added operations into a single chain. For example, this could be useful when the user is typing some text, which could be later done/undone as a single word, instead of individually by each character.

Also, one more piece of functionality is related to the command description text management. Related functions allow setting the new text description for the last undo command (SetLastCommandText). As an example, it could be used after the ChainLastCommand method for setting the new description for the merged command (e.g. 'Move' instead of 'Delete'+'Insert').

Another two functions allow for the retrieval of string description lists from the list of undo/redo commands (GetUndoTextList / GetRedoTextList).

However, this class is used internally by the library only.

See also
CXTPSyntaxEditCommand

Member Function Documentation

◆ AddCommand()

void AddCommand ( CXTPSyntaxEditCommand * pCommand )

Adds a command to the undo buffer.

Deletes all redo commands if they exist.

Parameters
pCommand [in] Pointer to the undo command to be added.

◆ CanRedo()

BOOL CanRedo ( ) const

Determines if it is possible to perform the redo action.

Returns
TRUE if it is possible to perform the redo action, otherwise FALSE.
See also
CanUndo

◆ CanUndo()

BOOL CanUndo ( ) const

Determines if it is possible to perform the undo action.

Returns
TRUE if it is possible to perform the undo action, otherwise FALSE.
See also
CanRedo

◆ ChainLastCommand()

void ChainLastCommand ( )

Merges the latest undo command into a batch command with the previous undo command.

See also
SetGroupInsertMode

◆ DoRedo()

int DoRedo | ( | XTP_EDIT_LINECOL & | lcFrom,
 |  | XTP_EDIT_LINECOL & | lcTo,
 |  | CXTPSyntaxEditCtrl * | pEditCtrl )

Performs a single redo operation (executes the next command).

Parameters
lcFrom | [out] Start text position affected by the command.
lcTo | [out] End text position affected by the command.
pEditCtrl | [in] Pointer to the edit control.
Returns
A bitwise combination of the edit actions that occurred: XTP_EDIT_EDITACTION_MODIFYROW, XTP_EDIT_EDITACTION_DELETEROW, XTP_EDIT_EDITACTION_INSERTROW
See also
DoUndo

◆ DoUndo()

int DoUndo | ( | XTP_EDIT_LINECOL & | lcFrom,
 |  | XTP_EDIT_LINECOL & | lcTo,
 |  | CXTPSyntaxEditCtrl * | pEditCtrl )

Performs a single undo operation (unexecutes the latest command).

Parameters
lcFrom | [out] Start text position affected by the command.
lcTo | [out] End text position affected by the command.
pEditCtrl | [in] Pointer to the edit control.
Returns
A bitwise combination of the edit actions that occurred: XTP_EDIT_EDITACTION_MODIFYROW, XTP_EDIT_EDITACTION_DELETEROW, XTP_EDIT_EDITACTION_INSERTROW
See also
DoRedo

◆ GetDataSize()

virtual int GetDataSize ( ) const
virtual

Gets the undo buffer data size (in bytes).

Returns
The undo buffer data size (in bytes).

◆ GetRedoTextList()

const CStringList & GetRedoTextList ( )

Gets the list of text for redo operations.

Returns
A reference to the list of text for redo operations.
See also
GetUndoTextList, SetLastCommandText

◆ GetUndoTextList()

const CStringList & GetUndoTextList ( )

Gets the list of text for undo operations.

Returns
A reference to the list of text for undo operations.
See also
GetRedoTextList, SetLastCommandText

◆ IsModified()

BOOL IsModified ( ) const

Determines if the document was modified by any command from the buffer since the document was last saved/loaded.

Returns
TRUE if the document was modified by any command from the buffer since the document was last saved/loaded, otherwise FALSE.
See also
MarkSaved

◆ LimitDataSize()

virtual void LimitDataSize | ( | int | nNewCommandData,
 |  | int | nDataSizeLimit )
 virtual

Checks the undo buffer data size and removes old stored commands to clear memory if the data size limit has been reached.

Parameters
nNewCommandData | Size (in bytes) of the undo command to be added.
nDataSizeLimit | Data size limit of the undo buffer.

◆ MarkSaved()

void MarkSaved ( )

Marks the current command buffer position as last saved.

This method is used for the further calculating of the modified flag.

See also
IsModified

◆ SetGroupInsertMode()

void SetGroupInsertMode ( BOOL bInsertInGroup = TRUE )

Enables/disables group insert mode.

Parameters
bInsertInGroup [in] TRUE to enable group insert mode, FALSE to disable group insert mode.

Group insert mode is required when a user is typing certain text in normal INS mode. When an undo/redo command occurs, a group of text will be undone/redone in a single shot. This setting is cleared when in overwrite mode or while the user presses SPACE, TAB, ENTER, etc.

See also
ChainLastCommand

◆ SetLastCommandText() [1/2]

void SetLastCommandText ( LPCTSTR szText )

Sets the text for the last undo command in the stack.

Parameters
szText [in] Text to be set.
See also
GetUndoTextList, GetRedoTextList

◆ SetLastCommandText() [2/2]

void SetLastCommandText ( UINT nTextId )

Sets the text for the last undo command in the stack.

Parameters
nTextId [in] Resource text identifier of the text string to be set.
See also
GetUndoTextList, GetRedoTextList
The documentation for this class was generated from the following file:
  • XTPSyntaxEditUndoManager.h


Toolkit Pro: CXTPSyntaxEditView Class Reference

Public Member Functions | Public Attributes | Protected Member Functions | Protected Attributes | Static Protected Attributes | List of all members
CXTPSyntaxEditView Class Reference

This class represents a View portion of the Edit Control. More...

Public Member Functions

void | SetFontIndirect (LOGFONT *pLogFont, BOOL bUpdateReg=FALSE)
Sets the font for the edit control.
void | SetLineNumbers (BOOL bEnable)
Enables/disables line numbering.
BOOL | GetHorzScrollBar () const
Determines if the horizontal scrollbar is enabled.
BOOL | GetVertScrollBar () const
Determines if the vertical scrollbar is enabled.
BOOL | SetScrollBars (BOOL bHorz, BOOL bVert, BOOL bUpdateReg=FALSE, BOOL bRecalcLayout=TRUE)
Enables/disables the horizontal and vertical scrollbars.
void | SetSelMargin (BOOL bEnable)
Enables/disables the gutter.
void | SetAutoIndent (BOOL bEnable)
Enables/disables auto-indent.
void | SetSyntaxColor (BOOL bEnable)
Enables/disables syntax colorization.
void | UpdateAllViews ()
Updates all active sibling views.
void | SetDirty ()
Sets the view ready for redraw.
CXTPSyntaxEditCtrl & GetEditCtrl ()
Gets the smart edit control.
virtual void | SetEditCtrl (CXTPSyntaxEditCtrl *pControl)
Sets the smart edit control.
CXTPSyntaxEditBufferManager * | GetEditBuffer () const
Gets the buffer manager of the smart edit control.
CXTPSyntaxEditConfigurationManager * | GetLexConfigurationManager () const
Gets the associated configuration manager.
void | Refresh ()
Refreshes the whole document and recalculates the scrollbar.
BOOL | SetTopRow (int iRow)
Sets the top row.
int | GetTopRow () const
Gets the top row.
void | UpdateScrollPos (CView *pSender, DWORD dwUpdate=XTP_EDIT_UPDATE_ALL)
Updates sibling views while in split mode.
CXTPSyntaxEditDoc * | GetDocument () const
Gets the document.
CXTPSyntaxEditBufferManager * | GetDataManager () const
Gets the edit buffer manager.
XTPSyntaxEditLexAnalyser::CXTPSyntaxEditLexParser * | GetLexParser () const
Gets the associated lexical parser.
virtual CXTPSyntaxEditFindReplaceDlg * | GetFindReplaceDlg ()
Gets the attached Find/Replace dialog.
virtual CString | GetPageTitle ()
Gets the document title.
CXTPSyntaxEditViewPrintOptions * | GetPrintOptions () const
Gets the print options of this view.

Public Attributes

BOOL | m_bPrintDirect
TRUE if the Print Dialog is bypassed.
BOOL | m_bResizeControlWithView
FALSE if the attached Calendar control will not be resized with the view.

Protected Member Functions

CXTPSyntaxEditView ()
Protected object constructor.
virtual | ~CXTPSyntaxEditView ()
Destroys a CXTPSyntaxEditView() object, handles cleanup and de-allocation.
virtual BOOL | OnEditChanging (NMHDR *pNMHDR, LRESULT *pResult)
This function is the default handler for the XTP_EDIT_NM_EDITCHANGING message which is sent before editing is applied.
virtual BOOL | OnEditChanged (NMHDR *pNMHDR, LRESULT *pResult)
This function is the default handler for the XTP_EDIT_NM_EDITCHANGED message which is sent when editing is applied.
virtual BOOL | OnSetDocModified (NMHDR *pNMHDR, LRESULT *pResult)
This function is the default handler for the XTP_EDIT_NM_SETDOCMODIFIED message which is sent when the modified state of the document (edit control) is changed.
virtual BOOL | OnDrawBookmark (NMHDR *pNMHDR, LRESULT *pResult)
This function is the default handler for the XTP_EDIT_NM_DRAWBOOKMARK message which is sent before the bookmark is drawn.
virtual BOOL | OnRowColChanged (NMHDR *pNMHDR, LRESULT *pResult)
This function is the default handler for the XTP_EDIT_NM_ROWCOLCHANGED message which is sent before the current row or column is changed.
virtual BOOL | OnUpdateScrollPos (NMHDR *pNMHDR, LRESULT *pResult)
This function is the default handler for the XTP_EDIT_NM_UPDATESCROLLPOS message which is sent before the scroll bar position is changed.
virtual BOOL | OnEnableScrollBar (NMHDR *pNMHDR, LRESULT *pResult)
This function is the default handler for the XTP_EDIT_NM_ENABLESCROLLBAR message which is sent before the scroll bar state is changed.
virtual BOOL | OnInsertKey (NMHDR *pNMHDR, LRESULT *pResult)
This function is the default handler for the XTP_EDIT_NM_INSERTKEY message which is sent when the 'Ins' (VK_INSERT) key is down (insert mode changed).
virtual BOOL | OnSelInit (NMHDR *pNMHDR, LRESULT *pResult)
This function is the default handler for the XTP_EDIT_NM_SELINIT message which is sent when the selection is reset.
virtual BOOL | OnStartOleDrag (NMHDR *pNMHDR, LRESULT *pResult)
This function is the default handler for the XTP_EDIT_NM_STARTOLEDRAG message which is sent when OLE dragging is started.
virtual BOOL | OnMarginClicked (NMHDR *pNMHDR, LRESULT *pResult)
This function is the default handler for the XTP_EDIT_NM_MARGINCLICKED message which is sent when the left mouse button is clicked on the bookmarks area.
virtual BOOL | OnParseEvent (NMHDR *pNMHDR, LRESULT *pResult)
This function is the default handler for the XTP_EDIT_NM_PARSEEVENT message which is sent when a parser event occurs.
virtual BOOL | CanChangeReadonlyFile ()
Overwrite this method to customize read-only file handling.
void | UpdateSiblings (XTP_EDIT_NMHDR_EDITCHANGED *pNMHDR_EC=NULL, BOOL bTextChanged=TRUE)
This method is called to apply an update to all sibling views.
void | UpdateSiblingScrollPos (CXTPSyntaxEditView *pSender, DWORD dwUpdate)
This method is called when a sibling view must be updated.
CXTPSyntaxEditView * | GetSplitterView (int nRow, int nCol)
Gets the view of a specified pane of the splitter.
void | StartOleDrag ()
Starts OLE drag.

Protected Attributes

LOGFONT | m_lfPrevFont
Temporarily stores editor font.
int | m_nPrevTopRow
Temporarily stores previous top row.
int | m_nParserThreadPriority_WhenActive
Parser priority (active state).
int | m_nParserThreadPriority_WhenInactive
Parser priority (inactive state).
BOOL | m_bDraggingOver
TRUE if dragover is going on, FALSE otherwise.
BOOL | m_bDraggingStartedHere
TRUE if dragging is started in this view, FALSE otherwise.
BOOL | m_bScrollBars
Whether to create control with own scrollbars, or let to manage scrolling for parent window.
BOOL | m_bOleDragging
TRUE if OLE dragging is enabled, FALSE otherwise.
BOOL | m_bFilesDragging
TRUE when dragging files, FALSE otherwise.
COleDropTarget | m_dropTarget
OLE drop target.
CSize | m_szPage
Page size for printing or preview.
int | m_iTopRow
Top row for display.
CXTPSyntaxEditCtrl * | m_pEditCtrl
Edit control instance.
BOOL | m_bOnSizeRunning
TRUE if the OnSize message handler is in progress, FALSE otherwise.
CXTPSyntaxEditViewPrintOptions * | m_pPrintOptions
Printing options.
CUIntArray | m_aPageStart
Printed page start row indexes.

Static Protected Attributes

static CXTPSyntaxEditView * | ms_pTargetView
Target view pointer to be filled in by drag-drop routine.
static BOOL | ms_bDroppedHere
TRUE if text is dropped in this view, FALSE otherwise.
static POINT | ms_ptDropPos
Drop mouse position.
static DWORD_PTR | ms_dwSignature
Signature used during drag-drop operation.
static CXTPSyntaxEditFindReplaceDlg * | m_pFindReplaceDlg
Pointer to find or replace dialog.

Detailed Description

This class represents a View portion of the Edit Control.

It extends the functionality provided by the CView class from MFC's document-view model implementation. The CXTPSyntaxEditView class works together with CXTPSyntaxEditDoc and provides facilities for it to be displayed on a screen or printed on a printer.

See also
CXTPSyntaxEditDoc

Constructor & Destructor Documentation

◆ CXTPSyntaxEditView()

CXTPSyntaxEditView ( )
protected

Protected object constructor.

Used by dynamic creation.

Member Function Documentation

◆ CanChangeReadonlyFile()

virtual BOOL CanChangeReadonlyFile ( )
protectedvirtual

Overwrite this method to customize read-only file handling.

Returns
TRUE if a read-only file can be changed, otherwise FALSE.

◆ GetDataManager()

CXTPSyntaxEditBufferManager * GetDataManager ( ) const

Gets the edit buffer manager.

Returns
A pointer to the edit buffer manager.
See also
CXTPSyntaxEditBufferManager

◆ GetDocument()

CXTPSyntaxEditDoc * GetDocument ( ) const

Gets the document.

Returns
A pointer to the document.

◆ GetEditBuffer()

AFX_INLINE CXTPSyntaxEditBufferManager * GetEditBuffer ( ) const

Gets the buffer manager of the smart edit control.

Returns
A pointer to the buffer manager of the smart edit control.

◆ GetEditCtrl()

CXTPSyntaxEditCtrl & GetEditCtrl ( )

Gets the smart edit control.

Returns
A reference to the smart edit control.

◆ GetFindReplaceDlg()

virtual CXTPSyntaxEditFindReplaceDlg * GetFindReplaceDlg ( )
virtual

Gets the attached Find/Replace dialog.

Returns
A pointer to the attached Find/Replace dialog.

◆ GetHorzScrollBar()

BOOL GetHorzScrollBar ( ) const

Determines if the horizontal scrollbar is enabled.

Returns
TRUE if the horizontal scrollbar is enabled, otherwise FALSE.

◆ GetLexConfigurationManager()

AFX_INLINE CXTPSyntaxEditConfigurationManager * GetLexConfigurationManager ( ) const

Gets the associated configuration manager.

Returns
A pointer to the associated configuration manager.

◆ GetLexParser()

XTPSyntaxEditLexAnalyser::CXTPSyntaxEditLexParser * GetLexParser ( ) const

Gets the associated lexical parser.

Returns
A pointer to the associated lexical parser.

◆ GetPageTitle()

virtual CString GetPageTitle ( )
virtual

Gets the document title.

Returns
The document title.

◆ GetPrintOptions()

AFX_INLINE CXTPSyntaxEditViewPrintOptions * GetPrintOptions ( ) const

Gets the print options of this view.

Returns
A pointer to the print options of this view.

◆ GetSplitterView()

CXTPSyntaxEditView * GetSplitterView | ( | int | nRow,
 |  | int | nCol )
 protected

Gets the view of a specified pane of the splitter.

Parameters
nRow | [in] Row of the splitter frame.
nCol | [in] Column of the splitter frame.
Returns
A pointer to the view of the specified pane of the splitter.
See also
CXTPSyntaxEditView

◆ GetTopRow()

int GetTopRow ( ) const

Gets the top row.

Returns
The identifier of the top row.

◆ GetVertScrollBar()

BOOL GetVertScrollBar ( ) const

Determines if the vertical scrollbar is enabled.

Returns
TRUE if the vertical scrollbar is enabled, otherwise FALSE.

◆ OnDrawBookmark()

virtual BOOL OnDrawBookmark | ( | NMHDR * | pNMHDR,
 |  | LRESULT * | pResult )
 protectedvirtual

This function is the default handler for the XTP_EDIT_NM_DRAWBOOKMARK message which is sent before the bookmark is drawn.

Parameters
pNMHDR | [in] Pointer to an XTP_EDIT_SENMBOOKMARK structure.
pResult | [out] Pointer to a LRESULT value. TRUE to cancel default processing (bookmark drawing), FALSE to allow default processing.
Returns
TRUE if the message was handled successfully, otherwise FALSE.
See also
XTP_EDIT_NM_DRAWBOOKMARK, XTP_EDIT_SENMBOOKMARK

◆ OnEditChanged()

virtual BOOL OnEditChanged | ( | NMHDR * | pNMHDR,
 |  | LRESULT * | pResult )
 protectedvirtual

This function is the default handler for the XTP_EDIT_NM_EDITCHANGED message which is sent when editing is applied.

Parameters
pNMHDR | [in] Pointer to an XTP_EDIT_NMHDR_EDITCHANGED structure.
pResult | This parameter is unused for this handler.
Returns
TRUE if the message was handled successfully, otherwise FALSE.
See also
XTP_EDIT_NM_EDITCHANGING, XTP_EDIT_NM_EDITCHANGED, XTP_EDIT_NMHDR_EDITCHANGED

◆ OnEditChanging()

virtual BOOL OnEditChanging | ( | NMHDR * | pNMHDR,
 |  | LRESULT * | pResult )
 protectedvirtual

This function is the default handler for the XTP_EDIT_NM_EDITCHANGING message which is sent before editing is applied.

Parameters
pNMHDR | [in] Pointer to a NMHDR structure.
pResult | [out] Pointer to a LRESULT value. TRUE to cancel editing, FALSE to allow editing.
Returns
TRUE if the message was handled successfully, otherwise FALSE.
See also
OnEditChanged, XTP_EDIT_NM_EDITCHANGING, XTP_EDIT_NM_EDITCHANGED

◆ OnEnableScrollBar()

virtual BOOL OnEnableScrollBar | ( | NMHDR * | pNMHDR,
 |  | LRESULT * | pResult )
 protectedvirtual

This function is the default handler for the XTP_EDIT_NM_ENABLESCROLLBAR message which is sent before the scroll bar state is changed.

Parameters
pNMHDR | [in] Pointer to an XTP_EDIT_NMHDR_ENABLESCROLLBAR structure.
pResult | This parameter is unused for this handler.
Returns
TRUE if the message was handled successfully, otherwise FALSE.
See also
XTP_EDIT_NM_ENABLESCROLLBAR

◆ OnInsertKey()

virtual BOOL OnInsertKey | ( | NMHDR * | pNMHDR,
 |  | LRESULT * | pResult )
 protectedvirtual

This function is the default handler for the XTP_EDIT_NM_INSERTKEY message which is sent when the 'Ins' (VK_INSERT) key is down (insert mode changed).

Parameters
pNMHDR | [in] Pointer to a NMHDR structure.
pResult | This parameter is unused for this handler.
Returns
TRUE if the message was handled successfully, otherwise FALSE.
See also
XTP_EDIT_NM_INSERTKEY

◆ OnMarginClicked()

virtual BOOL OnMarginClicked | ( | NMHDR * | pNMHDR,
 |  | LRESULT * | pResult )
 protectedvirtual

This function is the default handler for the XTP_EDIT_NM_MARGINCLICKED message which is sent when the left mouse button is clicked on the bookmarks area.

Parameters
pNMHDR | [in] Pointer to an XTP_EDIT_NMHDR_MARGINCLICKED structure.
pResult | [out] Pointer to a LRESULT value. TRUE to cancel default processing (breakpoint set/reset), FALSE to allow default processing.
Returns
TRUE if the message was handled successfully, otherwise FALSE.
See also
XTP_EDIT_NM_MARGINCLICKED, XTP_EDIT_NMHDR_MARGINCLICKED

◆ OnParseEvent()

virtual BOOL OnParseEvent | ( | NMHDR * | pNMHDR,
 |  | LRESULT * | pResult )
 protectedvirtual

This function is the default handler for the XTP_EDIT_NM_PARSEEVENT message which is sent when a parser event occurs.

Parameters
pNMHDR | [in] Pointer to an XTP_EDIT_NMHDR_PARSEEVENT structure.
pResult | This parameter is unused for this handler.
Returns
TRUE if the message was handled successfully, otherwise FALSE.
See also
XTP_EDIT_NM_PARSEEVENT, XTP_EDIT_NMHDR_PARSEEVENT

◆ OnRowColChanged()

virtual BOOL OnRowColChanged | ( | NMHDR * | pNMHDR,
 |  | LRESULT * | pResult )
 protectedvirtual

This function is the default handler for the XTP_EDIT_NM_ROWCOLCHANGED message which is sent before the current row or column is changed.

Parameters
pNMHDR | [in] Pointer to an XTP_EDIT_NMHDR_ROWCOLCHANGED structure.
pResult | This parameter is unused for this handler.
Returns
TRUE if the message was handled successfully, otherwise FALSE.
See also
XTP_EDIT_NM_ROWCOLCHANGED, XTP_EDIT_NMHDR_ROWCOLCHANGED

◆ OnSelInit()

virtual BOOL OnSelInit | ( | NMHDR * | pNMHDR,
 |  | LRESULT * | pResult )
 protectedvirtual

This function is the default handler for the XTP_EDIT_NM_SELINIT message which is sent when the selection is reset.

Parameters
pNMHDR | [in] Pointer to a NMHDR structure.
pResult | This parameter is unused for this handler.
Returns
TRUE if the message was handled successfully, otherwise FALSE.
See also
XTP_EDIT_NM_SELINIT

◆ OnSetDocModified()

virtual BOOL OnSetDocModified | ( | NMHDR * | pNMHDR,
 |  | LRESULT * | pResult )
 protectedvirtual

This function is the default handler for the XTP_EDIT_NM_SETDOCMODIFIED message which is sent when the modified state of the document (edit control) is changed.

Parameters
pNMHDR | [in] Pointer to an XTP_EDIT_NMHDR_DOCMODIFIED structure.
pResult | This parameter is unused for this handler.
Returns
TRUE if the message was handled successfully, otherwise FALSE.
See also
XTP_EDIT_NM_SETDOCMODIFIED, XTP_EDIT_NMHDR_DOCMODIFIED

◆ OnStartOleDrag()

virtual BOOL OnStartOleDrag | ( | NMHDR * | pNMHDR,
 |  | LRESULT * | pResult )
 protectedvirtual

This function is the default handler for the XTP_EDIT_NM_STARTOLEDRAG message which is sent when OLE dragging is started.

Parameters
pNMHDR | [in] Pointer to a NMHDR structure.
pResult | This parameter is unused for this handler.
Returns
TRUE if the message was handled successfully, otherwise FALSE.
See also
XTP_EDIT_NM_STARTOLEDRAG

◆ OnUpdateScrollPos()

virtual BOOL OnUpdateScrollPos | ( | NMHDR * | pNMHDR,
 |  | LRESULT * | pResult )
 protectedvirtual

This function is the default handler for the XTP_EDIT_NM_UPDATESCROLLPOS message which is sent before the scroll bar position is changed.

Parameters
pNMHDR | [in] Pointer to an XTP_EDIT_NM_UPDATESCROLLPOS structure.
pResult | This parameter is unused for this handler.
Returns
TRUE if the message was handled successfully, otherwise FALSE.
See also
XTP_EDIT_NM_UPDATESCROLLPOS

◆ SetAutoIndent()

void SetAutoIndent ( BOOL bEnable )

Enables/disables auto-indent.

Parameters
bEnable [in] TRUE to enable auto-indent, FALSE to disable auto-indent.

◆ SetEditCtrl()

virtual void SetEditCtrl ( CXTPSyntaxEditCtrl * pControl )
virtual

Sets the smart edit control.

Parameters
pControl Pointer to the smart edit control to be set.

The default edit control window will be destroyed. InternalRelease will be called for the external control object in the view object destructor.

See also
GetEditCtrl

◆ SetFontIndirect()

void SetFontIndirect | ( | LOGFONT * | pLogFont,
 |  | BOOL | bUpdateReg = FALSE )

Sets the font for the edit control.

Parameters
pLogFont | [in] Pointer to a LOGFONT structure.
bUpdateReg | [in] TRUE to update this setting in the registry, FALSE otherwise. By default, this parameter is FALSE.

◆ SetLineNumbers()

void SetLineNumbers ( BOOL bEnable )

Enables/disables line numbering.

Parameters
bEnable [in] TRUE to enable line numbering, FALSE to disable line numbering.

◆ SetScrollBars()

BOOL SetScrollBars | ( | BOOL | bHorz,
 |  | BOOL | bVert,
 |  | BOOL | bUpdateReg = FALSE,
 |  | BOOL | bRecalcLayout = TRUE )

Enables/disables the horizontal and vertical scrollbars.

Parameters
bHorz | [in] TRUE to enable the horizontal scrollbar, FALSE to disable the horizontal scrollbar.
bVert | [in] TRUE to enable the vertical scrollbar, FALSE to disable the vertical scrollbar.
bUpdateReg | [in] TRUE to update this setting in the registry, FALSE otherwise. By default, this parameter is FALSE.
bRecalcLayout | [in] TRUE to recalculate the layout, FALSE otherwise.
Returns
TRUE if the scrollbars were updated, otherwise FALSE.

◆ SetSelMargin()

void SetSelMargin ( BOOL bEnable )

Enables/disables the gutter.

Parameters
bEnable [in] TRUE to enable the gutter, FALSE to disable the gutter.

◆ SetSyntaxColor()

void SetSyntaxColor ( BOOL bEnable )

Enables/disables syntax colorization.

Parameters
bEnable [in] TRUE to enable syntax colorization, FALSE to disable syntax colorization.

◆ SetTopRow()

BOOL SetTopRow ( int iRow )

Sets the top row.

Parameters
iRow [in] Row to be set.
Returns
TRUE if successful, otherwise FALSE.

◆ UpdateScrollPos()

void UpdateScrollPos | ( | CView * | pSender,
 |  | DWORD | dwUpdate = XTP_EDIT_UPDATE_ALL )

Updates sibling views while in split mode.

Parameters
pSender | [in] Pointer to a sender object (or NULL).
dwUpdate | [in] View update flags.

◆ UpdateSiblings()

void UpdateSiblings | ( | XTP_EDIT_NMHDR_EDITCHANGED * | pNMHDR_EC = NULL,
 |  | BOOL | bTextChanged = TRUE )
 protected

This method is called to apply an update to all sibling views.

Parameters
pNMHDR_EC | [in] Pointer to the parameters header.
bTextChanged | [in] TRUE if document text was changed, FALSE otherwise.

◆ UpdateSiblingScrollPos()

void UpdateSiblingScrollPos | ( | CXTPSyntaxEditView * | pSender,
 |  | DWORD | dwUpdate )
 protected

This method is called when a sibling view must be updated.

Parameters
pSender | [in] Source to be updated from.
dwUpdate | [in] Type of update. Allowed values are: XTP_EDIT_UPDATE_HORZ, XTP_EDIT_UPDATE_VERT, XTP_EDIT_UPDATE_DIAG. See Also CXTPSyntaxEditView

Member Data Documentation

◆ m_bPrintDirect

BOOL m_bPrintDirect

TRUE if the Print Dialog is bypassed.

FALSE by default.

◆ m_bResizeControlWithView

BOOL m_bResizeControlWithView

FALSE if the attached Calendar control will not be resized with the view.

TRUE by default.

The documentation for this class was generated from the following file:
  • XTPSyntaxEditView.h


Toolkit Pro: CXTPSyntaxEditViewPrintOptions Class Reference

Public Member Functions | List of all members
CXTPSyntaxEditViewPrintOptions Class Reference

Describes printing options for the Calendar control. More...

Public Member Functions

CXTPSyntaxEditViewPrintOptions ()
Default constructor.

Detailed Description

Describes printing options for the Calendar control.

Use this class when you want to programmatically customize printing options for the Calendar control.

See each property description to examine which customization options are available.

See also
CXTPPrintOptions
The documentation for this class was generated from the following file:
  • XTPSyntaxEditView.h


Toolkit Pro: CXTPSystemMetrics Class Reference

Public Member Functions | Public Attributes | List of all members
CXTPSystemMetrics Class Reference

The CXTPSystemMetrics class is used to store and update sytem information. More...

Public Member Functions

CXTPSystemMetrics ()
Call this member to refresh the metrics for this class.
void RefreshMetrics ()
Call this member to refresh the metrics for this class.

Public Attributes

int | m_nBorderY
The height of a window border, in pixels.
int | m_nCaptionY
The height of a caption area, in pixels.
int | m_nSizeFrameY
The thickness of the sizing border around the perimeter of a window that can be resized, in pixels.
int | m_nSmallIconX
Small icon width, see SM_CXSMICON.
int | m_nSmallIconY
Small icon height, see SM_CYSMICON.
int | m_nIconX
Icon width see, SM_CXICON.
int | m_nIconY
Icon height see, SM_CYICON.

Detailed Description

The CXTPSystemMetrics class is used to store and update sytem information.

The documentation for this class was generated from the following file:
  • XTPSystemMetrics.h


Toolkit Pro: CXTPSystemPreviewProvider Class Reference

List of all members
CXTPSystemPreviewProvider Class Reference

Provides a preview handler that uses supported system means for previewing files. More...

Inheritance diagram for CXTPSystemPreviewProvider:
[legend]

Additional Inherited Members

- Public Member Functions inherited from IXTPPreviewProvider
virtual | ~IXTPPreviewProvider ()
Handles object destruction.
- Protected Member Functions inherited from CXTPPreviewProviderBase
CXTPPreviewProviderBase ()
Handles object construction.
void | BindHost (IXTPPreviewHost &host)
The method is called by the host preview control when the provider is initially bound to the host.
IXTPPreviewHost & | GetHost () const
Obtains the preview host interface that the provider is bound to.

Detailed Description

Provides a preview handler that uses supported system means for previewing files.

It is not bound to any specific file types as system preview handlers' availability depends on OS version and installed components and 3rd party software.

See also
CXTPCommonPicturePreviewProvider, CXTPGifPreviewProvider, CXTPMsgPreviewProvider, CXTPTextPreviewProvider, CXTPXamlPreviewProvider
The documentation for this class was generated from the following file:
  • XTPSystemPreviewProvider.h


Toolkit Pro: CXTPSystemVersion Class Reference

Public Member Functions | List of all members
CXTPSystemVersion Class Reference

CXTPSystemVersion is used to get the current Windows OS version. More...

Public Member Functions

bool | VerifyWinVer (BYTE dwConditionMask, DWORD dwMajorVersion, DWORD dwMinorVersion, DWORD dwPlatformId) const
Compares a set of operating system version requirements to the corresponding values for the currently running version of the system.
LRESULT | VerifyVersion (BYTE dwConditionMask, DWORD dwMajorVersion, DWORD dwMinorVersion, DWORD dwPlatformId) const
Compares a set of operating system version requirements to the corresponding values for the currently running version of the system.
LRESULT | GetVersion (BYTE dwConditionMask, DWORD dwMajorVersion, DWORD dwMinorVersion, DWORD dwPlatformId) const
Compares a set of operating system version requirements to the corresponding values for the currently running version of the system.
const OSVERSIONINFOEXW * | GetOSVersionInfo () const
Retrieves OS version information.
bool | IsWin31 () const
Call this member function to check whether or not the operating system is Windows 3.1.
bool | IsWin95 () const
Call this member function to check whether or not the operating system is Windows 95.
bool | IsWin98 () const
Call this member function to check whether or not the operating system is Windows 98.
bool | IsWinME () const
Call this member function to check whether or not the operating system is Windows ME.
bool | IsWinNT4 () const
Call this member function to check whether or not the operating system is Windows NT 4.
bool | IsWin2K () const
Call this member function to check whether or not the operating system is Windows 2000.
bool | IsWinXP () const
Call this member function to check whether or not the operating system is Windows XP.
bool | IsWin31OrGreater () const
Call this member function to check whether or not the operating system is greater than or equal to Windows 3.1.
bool | IsWin95OrGreater () const
Call this member function to check whether or not the operating system is of the Windows 9x family, and if it is Windows 95 or a later version.
bool | IsWin98OrGreater () const
Call this member function to check whether or not the operating system is of the Windows 9x family, and if it is Windows 98 or a later version.
bool | IsWinMEOrGreater () const
Call this member function to check whether or not the operating system is of the Windows 9x family, and if it is Windows ME or a later version.
bool | IsWin9x () const
Call this member function to check whether or not the operating system is of the Windows 9x family.
bool | IsWinNT4OrGreater () const
Call this member function to check whether or not the operating system is of the Windows NT family, and if it is Windows NT 4 or a later version.
bool | IsWin2KOrGreater () const
Call this member function to check whether or not the operating system is of the Windows NT family, and if it is Windows 2000 or a later version.
bool | IsWinXPOrGreater () const
Call this member function to check whether or not the operating system is of the Windows NT family, and if it is Windows XP or a later version.
bool | IsWinVistaOrGreater () const
Call this member function to check whether or not the operating system is of the Windows NT family, and if it is Windows Vista or a later version.
bool | IsWin7OrGreater () const
Call this member function to check whether or not the operating system is of the Windows NT family, and if it is Windows 7 or a later version.
bool | IsWin8OrGreater () const
Call this member function to check whether or not the operating system is of the Windows NT family, and if it is Windows 8 or a later version.
bool | IsWin81OrGreater () const
Call this member function to check whether or not the operating system is of the Windows NT family, and if it is Windows 8.1 or a later version.
bool | IsWin10OrGreater () const
Call this member function to check whether or not the operating system is of the Windows NT family, and if it is Windows 10 or a later version.
bool | IsWin11OrGreater () const
Call this member function to check whether or not the operating system is of the Windows NT family, and if it is Windows 11 or a later version.
DWORD | GetComCtlVersion () const
Use this member function to return the version number of the comctl32.dll.
BOOL | IsLayoutRTLSupported () const
Determines if right-to-left (RTL) formatting is supported by current OS.
BOOL | IsClearTypeTextQualitySupported () const
Determines if ClearType text is supported by current OS.
int | GetMaxCharSize () const
Obtains the maximum length, in bytes, of a character in an OEM code page.

Detailed Description

CXTPSystemVersion is used to get the current Windows OS version.

CXTPSystemVersion is a single instance, or "singleton" object, that is accessed with the Get() method.

Member Function Documentation

◆ GetComCtlVersion()

DWORD GetComCtlVersion ( ) const

Use this member function to return the version number of the comctl32.dll.

The high-order word of the return value represents the major version number and the low-order word of the returned value represents the minor version number.

Returns
A DWORD value if successful, otherwise 0L.

◆ GetMaxCharSize()

int GetMaxCharSize ( ) const

Obtains the maximum length, in bytes, of a character in an OEM code page.

Returns
The number of bytes per character.

◆ GetOSVersionInfo()

const OSVERSIONINFOEXW * GetOSVersionInfo ( ) const

Retrieves OS version information.

Returns
A pointer to the cached OS version information object or NULL if unable to get it.

◆ GetVersion()

LRESULT GetVersion | ( | BYTE | dwConditionMask,
 |  | DWORD | dwMajorVersion,
 |  | DWORD | dwMinorVersion,
 |  | DWORD | dwPlatformId ) const

Compares a set of operating system version requirements to the corresponding values for the currently running version of the system.

Uses GetVersionEx Windows API function for version data extraction.

Parameters
dwConditionMask | A variable to be passed as the condition mask, can be either VER_EQUAL or VER_GREATER_EQUAL.
dwMajorVersion | The major version number of the operating system.
dwMinorVersion | The minor version number of the operating system.
dwPlatformId | The operating system platform.
Returns
If the currently running operating system satisfies the specified requirements, the return value is S_OK, otherwise returns S_FALSE.

◆ IsClearTypeTextQualitySupported()

BOOL IsClearTypeTextQualitySupported ( ) const

Determines if ClearType text is supported by current OS.

Returns
TRUE if ClearType text is supported.

◆ IsLayoutRTLSupported()

BOOL IsLayoutRTLSupported ( ) const

Determines if right-to-left (RTL) formatting is supported by current OS.

Returns
TRUE if right-to-left (RTL) formatting is supported.

◆ IsWin10OrGreater()

bool IsWin10OrGreater ( ) const

Call this member function to check whether or not the operating system is of the Windows NT family, and if it is Windows 10 or a later version.

Returns
true if the OS is of the Windows NT family, and is Windows 10 or a later version, otherwise returns false.

◆ IsWin11OrGreater()

bool IsWin11OrGreater ( ) const

Call this member function to check whether or not the operating system is of the Windows NT family, and if it is Windows 11 or a later version.

Returns
true if the OS is of the Windows NT family, and is Windows 11 or a later version, otherwise returns false.

◆ IsWin2K()

bool IsWin2K ( ) const

Call this member function to check whether or not the operating system is Windows 2000.

Returns
true if the OS is Windows 2000, otherwise returns false.

◆ IsWin2KOrGreater()

bool IsWin2KOrGreater ( ) const

Call this member function to check whether or not the operating system is of the Windows NT family, and if it is Windows 2000 or a later version.

Returns
true if the OS is of the Windows NT family, and is Windows 2000 or a later version, otherwise returns false.

◆ IsWin31()

bool IsWin31 ( ) const

Call this member function to check whether or not the operating system is Windows 3.1.

Returns
true if the OS is Windows 3.1, otherwise returns false.

◆ IsWin31OrGreater()

bool IsWin31OrGreater ( ) const

Call this member function to check whether or not the operating system is greater than or equal to Windows 3.1.

Returns
true if the OS is greater than or equal to Windows 3.1, otherwise returns false.

◆ IsWin7OrGreater()

bool IsWin7OrGreater ( ) const

Call this member function to check whether or not the operating system is of the Windows NT family, and if it is Windows 7 or a later version.

Returns
true if the OS is of the Windows NT family, and is Windows 7 or a later version, otherwise returns false.

◆ IsWin81OrGreater()

bool IsWin81OrGreater ( ) const

Call this member function to check whether or not the operating system is of the Windows NT family, and if it is Windows 8.1 or a later version.

Returns
true if the OS is of the Windows NT family, and is Windows 8.1 or a later version, otherwise returns false.

◆ IsWin8OrGreater()

bool IsWin8OrGreater ( ) const

Call this member function to check whether or not the operating system is of the Windows NT family, and if it is Windows 8 or a later version.

Returns
true if the OS is of the Windows NT family, and is Windows 8 or a later version, otherwise returns false.

◆ IsWin95()

bool IsWin95 ( ) const

Call this member function to check whether or not the operating system is Windows 95.

Returns
true if the OS is Windows 95, otherwise returns false.

◆ IsWin95OrGreater()

bool IsWin95OrGreater ( ) const

Call this member function to check whether or not the operating system is of the Windows 9x family, and if it is Windows 95 or a later version.

Returns
true if the OS is of the Windows 9x family, and is Windows 95 or a later version, otherwise returns false.

◆ IsWin98()

bool IsWin98 ( ) const

Call this member function to check whether or not the operating system is Windows 98.

Returns
true if the OS is Windows 98, otherwise returns false.

◆ IsWin98OrGreater()

bool IsWin98OrGreater ( ) const

Call this member function to check whether or not the operating system is of the Windows 9x family, and if it is Windows 98 or a later version.

Returns
true if the OS is of the Windows 9x family, and is Windows 98 or a later version, otherwise returns false.

◆ IsWin9x()

bool IsWin9x ( ) const

Call this member function to check whether or not the operating system is of the Windows 9x family.

Returns
true if the OS is of the Windows 9x family

◆ IsWinME()

bool IsWinME ( ) const

Call this member function to check whether or not the operating system is Windows ME.

Returns
true if the OS is Windows ME, otherwise returns false.

◆ IsWinMEOrGreater()

bool IsWinMEOrGreater ( ) const

Call this member function to check whether or not the operating system is of the Windows 9x family, and if it is Windows ME or a later version.

Returns
true if the OS is of the Windows 9x family, and is Windows ME or a later version, otherwise returns false.

◆ IsWinNT4()

bool IsWinNT4 ( ) const

Call this member function to check whether or not the operating system is Windows NT 4.

Returns
true if the OS is Windows NT 4, otherwise returns false.

◆ IsWinNT4OrGreater()

bool IsWinNT4OrGreater ( ) const

Call this member function to check whether or not the operating system is of the Windows NT family, and if it is Windows NT 4 or a later version.

Returns
true if the OS is of the Windows NT family, and is Windows NT 4 or a later version, otherwise returns false.

◆ IsWinVistaOrGreater()

bool IsWinVistaOrGreater ( ) const

Call this member function to check whether or not the operating system is of the Windows NT family, and if it is Windows Vista or a later version.

Returns
true if the OS is of the Windows NT family, and is Windows Vista or a later version, otherwise returns false.

◆ IsWinXP()

bool IsWinXP ( ) const

Call this member function to check whether or not the operating system is Windows XP.

Returns
true if the OS is Windows XP, otherwise returns false.

◆ IsWinXPOrGreater()

bool IsWinXPOrGreater ( ) const

Call this member function to check whether or not the operating system is of the Windows NT family, and if it is Windows XP or a later version.

Returns
true if the OS is of the Windows NT family, and is Windows XP or a later version, otherwise returns false.

◆ VerifyVersion()

LRESULT VerifyVersion | ( | BYTE | dwConditionMask,
 |  | DWORD | dwMajorVersion,
 |  | DWORD | dwMinorVersion,
 |  | DWORD | dwPlatformId ) const

Compares a set of operating system version requirements to the corresponding values for the currently running version of the system.

Uses VerifyVersionInfo Windows API function if available.

Parameters
dwConditionMask | A variable to be passed as the condition mask, can be either VER_EQUAL or VER_GREATER_EQUAL.
dwMajorVersion | The major version number of the operating system.
dwMinorVersion | The minor version number of the operating system.
dwPlatformId | The operating system platform.
Returns
If the currently running operating system satisfies the specified requirements, the return value is S_OK, otherwise returns S_FALSE. If VerifyVersionInfo is not available then the return value is E_NOTIMPL.

◆ VerifyWinVer()

bool VerifyWinVer | ( | BYTE | dwConditionMask,
 |  | DWORD | dwMajorVersion,
 |  | DWORD | dwMinorVersion,
 |  | DWORD | dwPlatformId ) const

Compares a set of operating system version requirements to the corresponding values for the currently running version of the system.

Uses different available methods of version information extraction.

Parameters
dwConditionMask | A variable to be passed as the condition mask, can be either VER_EQUAL or VER_GREATER_EQUAL.
dwMajorVersion | The major version number of the operating system.
dwMinorVersion | The minor version number of the operating system.
dwPlatformId | The operating system platform.
Returns
If the currently running operating system satisfies the specified requirements, the return value is true, otherwise returns false.
The documentation for this class was generated from the following file:
  • XTPSystemHelpers.h


Toolkit Pro: CXTPTabBase Class Reference

Public Member Functions | Public Attributes | Protected Member Functions | Protected Attributes | List of all members
CXTPTabBase Class Reference

CXTPTabBase is a standalone base class. More...

Inheritance diagram for CXTPTabBase:
[legend]

Public Member Functions

CXTPTabBase ()
Constructs a CXTPTabBase object.
virtual | ~CXTPTabBase ()
Destroys a CXTPTabBase object, handles cleanup and deallocation.
CTabCtrl * | GetTabCtrlImpl ()
Retrieves a pointer to the associated tab control.
CXTPTabCtrlButtons * GetButtons ()
Retrieves a pointer to the tab control navigation button object.
virtual void | GetChildRect (CRect &rcChild) const
This member function copies the child coordinates of the CTabCtrl client area into the object referenced by 'rcChild'.
void | ShowNavButtons (DWORD dwFlags)
Call this member function to set the visibility of the navigation buttons.
BOOL | SetTheme (XTPControlTheme eTheme)
Call this member to switch the visual theme of the control.
CXTPTabBaseTheme * GetTheme ()
Call this member function to get a pointer to the currently selected theme.

Public Attributes

bool | m_bBoldFont
true to set the selected tab font to bold.
bool | m_bXPBorder
true to draw an XP border around the tab child window.
BOOL | m_bAutoCondensing
TRUE for auto-condensing tabs.

Protected Member Functions

virtual void | RefreshMetrics ()
Call this member function to refresh theme colors and redraw the control.
virtual BOOL | Init ()
This member function is called by the CXTPTabBase class to perform initialization when the window is created or sub-classed.
void | ImplAttach (CTabCtrl *pTabCtrl)
Call this member function to associate the tab control with this object.
virtual void | OnAddPadding (CString &strLabelText)
This member function is called by the tab control to add padding to a tab label for use with XP style tabs.

Protected Attributes

CTabCtrl * | m_pTabCtrl
Pointer to the tab control associated with this object.
CXTPTabCtrlButtons * | m_pNavBtns
Arrow buttons.
CXTPTabBaseTheme * | m_pTheme
Pointer to the current theme object.
BOOL | m_bSubclassed
TRUE if the window was sub-classed.

Detailed Description

CXTPTabBase is a standalone base class.

It is used to draw an XP style tab control.

Member Function Documentation

◆ GetButtons()

CXTPTabCtrlButtons * GetButtons ( )

Retrieves a pointer to the tab control navigation button object.

This member function is called to retrieve a pointer to the tab control buttons used for navigating and closing tab windows.

Returns
A pointer to a CXTPTabCtrlButtons object if successful, otherwise NULL.

◆ GetChildRect()

virtual void GetChildRect ( CRect & rcChild ) const
virtual

This member function copies the child coordinates of the CTabCtrl client area into the object referenced by 'rcChild'.

The client coordinates specify the upper-left and lower-right corners of the client area.

Parameters
rcChild A reference to a CRect object to receive the client coordinates.

◆ GetTabCtrlImpl()

CTabCtrl * GetTabCtrlImpl ( )

Retrieves a pointer to the associated tab control.

This member function is called by the base class to manage a pointer for the derived class CTabCtrl object.

Returns
A pointer to a CTabCtrl object if successful, otherwise NULL.

◆ GetTheme()

CXTPTabBaseTheme * GetTheme ( )

Call this member function to get a pointer to the currently selected theme.

Returns
A pointer to a CXTPTabBaseTheme object representing the currently selected theme.

◆ ImplAttach()

void ImplAttach ( CTabCtrl * pTabCtrl )
protected

Call this member function to associate the tab control with this object.

Parameters
pTabCtrl Pointer to a valid tab control object.

◆ Init()

virtual BOOL Init ( )
protectedvirtual

This member function is called by the CXTPTabBase class to perform initialization when the window is created or sub-classed.

Returns
TRUE if the window was successfully initialized, otherwise FALSE.

Reimplemented in CXTPTabExBase.

◆ OnAddPadding()

virtual void OnAddPadding ( CString & strLabelText )
protectedvirtual

This member function is called by the tab control to add padding to a tab label for use with XP style tabs.

Parameters
strLabelText Tab label to add padding to.

◆ SetTheme()

BOOL SetTheme ( XTPControlTheme eTheme )

Call this member to switch the visual theme of the control.

Parameters
eTheme New visual theme. Can be any of the values listed in the Remarks section.

eTheme can be one of the following: xtpControlThemeDefault: Use default theme. xtpControlThemeOfficeXP: Use Office XP theme. xtpControlThemeOffice2003: Use Office 2003 theme.

Returns
TRUE if successful; otherwise FALSE.

◆ ShowNavButtons()

void ShowNavButtons ( DWORD dwFlags )

Call this member function to set the visibility of the navigation buttons.

These buttons are used in place of the default forward and back buttons that are displayed when the tab control is not wide enough to display all tabs. You can also define a close button to be used to close the active tab. This will give the tab control a VS.NET style tabbed interface.

Parameters
dwFlags The value can be one or more of the values listed in the Remarks section.

Styles to be added or removed can be combined by using the bitwise OR (|) operator. It can be one or more of the following: xtpNavBtnArrows: To show arrow buttons. xtpNavBtnClose: To show close button. xtpNavBtnShowAll: To show arrow and close buttons.

The documentation for this class was generated from the following file:
  • XTPTabBase.h


Toolkit Pro: CXTPTabBaseTheme Class Reference

Public Member Functions | Public Attributes | Protected Member Functions | Protected Attributes | List of all members
CXTPTabBaseTheme Class Reference

CXTPTabBaseTheme is used to draw the CXTPTabBase object. More...

Inheritance diagram for CXTPTabBaseTheme:
[legend]

Public Member Functions

CXTPTabBaseTheme ()
Constructs a CXTPTabBaseTheme object.
virtual | ~CXTPTabBaseTheme ()
Destroys a CXTPTabBaseTheme object, handles cleanup and deallocation.
virtual void | RefreshMetrics (CTabCtrl *pTab)
Call this function to refresh the colors of the Tab control.
virtual void | DrawTabCtrl (CDC *pDC, CXTPTabBase *pTabCtrl)
This member function is called to render the tab control using the specified theme.
virtual CXTPPaintManagerColor | GetBackColor () const
Call this member function to get the current background color for the theme.
virtual void | AdjustBorders (CXTPTabBase *pTabCtrl, CXTPTcbItem *pMember)
Call this member function to redraw the borders for a particular tab.
virtual void | DrawButton (CDC *pDC, CXTPTabCtrlButton *pButton, COLORREF clrButton)
This member function is called to draw a single button of a tab control.
virtual COLORREF | FillButtons (CDC *pDC, CXTPTabCtrlButtons *pButtons)
This method is called to draw navigate buttons.
- Public Member Functions inherited from CXTPControlTheme
CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme | GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Public Attributes

BOOL | m_bSystemDrawing
TRUE to perform system drawing.
BOOL | m_bUseWinThemes
TRUE to use Windows XP themes when available.

Protected Member Functions

virtual void | DrawBorders (CDC *pDC, const CRect &rcClient)
This member function is called to draw the borders around the tab control.
virtual void | FillHeader (CDC *pDC, CXTPTabBase *pTabCtrlBase, CRect rcHeader)
This member function is called to draw the header for the tab control.
virtual void | FillTabFaceNativeWinXP (CDC *pDC, CTabCtrl *pTabCtrl, CRect rcItem, BOOL bSelected)
This member function is called to draw the tab face so that the tab appears with the Native Windows XP theme.
virtual void | FillTabFace (CDC *pDC, CTabCtrl *pTabCtrl, CRect rcItem, BOOL bSelected)
This member function is called to draw the tab face.
virtual void | DrawTab (CDC *pDC, CXTPTabBase *pTabCtrlBase, int iItem)
This member function is called to draw a tab on the tab control.
virtual void | DrawTabIcon (CDC *pDC, CTabCtrl *pTabCtrl, CRect &rcItem, int iItem)
This member function is called to draw the icon on the tab.
virtual void | DrawTabText (CDC *pDC, CTabCtrl *pTabCtrl, CRect &rcItem, int iItem, BOOL bSelected, BOOL bBoldFont)
This member function is called to draw text on the tab.
virtual CRect | GetHeaderRect (CXTPTabBase *pTabCtrlBase)
Call this member function to get the bounding rectangle of the tab header area.
virtual void | ShowButtons (CXTPTabBase *pTabCtrlBase)
Call this function to paint the Navigation buttons on the tab control.
virtual void | DrawBorder (CDC *pDC, const CRect &r)
This member function is called to draw a border around a tab child window.
DWORD | GetTabStyle (CTabCtrl *pTabCtrl) const
This member function is called to determine the tab style.
BOOL | IsLeft (DWORD dwStyle) const
This member function is called to determine if the tabs are drawn on the left side of the tab control.
BOOL | IsRight (DWORD dwStyle) const
This member function is called to determine if the tabs are drawn on the right side of the tab control.
BOOL | IsTop (DWORD dwStyle) const
This member function is called to determine if the tabs are drawn on the top of the tab control.
BOOL | IsBottom (DWORD dwStyle) const
This member function is called to determine if the tabs are drawn on the bottom of the tab control.
BOOL | IsVert (DWORD dwStyle) const
This member function is called to determine if the tabs are drawn vertically on the tab control.
BOOL | IsHorz (DWORD dwStyle) const
This member function is called to determine if the tabs are drawn horizontally on the tab control.
void | SwapColors (COLORREF &clrLight, COLORREF &clrDark)
This member function is called to swap the dark and the light colors.
void | VerticalLine (CDC *pDC, int xPos, int yPos, int nLength, COLORREF clr)
This member function is called to draw a vertical line.
void | HorizontalLine (CDC *pDC, int xPos, int yPos, int nLength, COLORREF clr)
This member function is called to draw a horizontal line.
void | Pixel (CDC *pDC, int xPos, int yPos, COLORREF clr)
This member function is called to draw a single pixel.

Protected Attributes

int | m_iEdge
The Y dimension of a 3D border.
CXTPWinThemeWrapper * | m_themeTab
Windows Theme wrapper.
CXTPPaintManagerColor m_clrNormalText
Color of text in a normal tab.
- Protected Attributes inherited from CXTPControlTheme
XTPControlTheme | m_nTheme
Currently selected theme style index.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlTheme
static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

CXTPTabBaseTheme is used to draw the CXTPTabBase object.

All themes used for CXTPTabBase should inherit from this base class.

Member Function Documentation

◆ AdjustBorders()

virtual void AdjustBorders | ( | CXTPTabBase * | pTabCtrl,
 |  | CXTPTcbItem * | pMember )
 virtual

Call this member function to redraw the borders for a particular tab.

Parameters
pTabCtrl | A pointer to a CXTPTabBase object.
pMember | A pointer to a CXTPTcbItem struct that contains information about the tab.
See also
CXTPTabBaseThemeOfficeXP::AdjustBorders

Reimplemented in CXTPTabBaseThemeOfficeXP.

◆ DrawBorder()

virtual void DrawBorder | ( | CDC * | pDC,
 |  | const CRect & | r )
 protectedvirtual

This member function is called to draw a border around a tab child window.

Parameters
pDC | A pointer to a valid device context.
r | A CRect object that contains the location and dimensions of the child window.
See also
CXTPTabBaseThemeOfficeXP::DrawBorder, CXTPTabBaseThemeOffice2003::DrawBorder

Reimplemented in CXTPTabBaseThemeOffice2003, and CXTPTabBaseThemeOfficeXP.

◆ DrawBorders()

virtual void DrawBorders | ( | CDC * | pDC,
 |  | const CRect & | rcClient )
 protectedvirtual

This member function is called to draw the borders around the tab control.

Parameters
pDC | A pointer to a valid device context.
rcClient | A CRect object that contains the location and dimensions of the tab control.
See also
CXTPTabBaseThemeOfficeXP::DrawBorders

Reimplemented in CXTPTabBaseThemeOfficeXP.

◆ DrawButton()

virtual void DrawButton | ( | CDC * | pDC,
 |  | CXTPTabCtrlButton * | pButton,
 |  | COLORREF | clrButton )
 virtual

This member function is called to draw a single button of a tab control.

Parameters
pDC | A CDC pointer that represents the current device context.
pButton | A pointer to a CXTPTabCtrlButton object.
clrButton | The color of the button. Note: This function ASSERTS if called. Must be overridden.

Reimplemented in CXTPTabBaseThemeOfficeXP.

◆ DrawTab()

virtual void DrawTab | ( | CDC * | pDC,
 |  | CXTPTabBase * | pTabCtrlBase,
 |  | int | iItem )
 protectedvirtual

This member function is called to draw a tab on the tab control.

Parameters
pDC | A pointer to a valid device context.
pTabCtrlBase | A pointer to a CXTPTabBase object. Contains information about the tab control.
iItem | An int that specifies the tab item to draw.
See also
CXTPTabBaseThemeOfficeXP::FillTabFace, CXTPTabBaseThemeOffice2003::FillTabFace, DrawTabIcon, DrawTabText, FillTabFaceNativeWinXP, CXTPExcelTabCtrlTheme::DrawTab, FillTabFace

◆ DrawTabCtrl()

virtual void DrawTabCtrl | ( | CDC * | pDC,
 |  | CXTPTabBase * | pTabCtrl )
 virtual

This member function is called to render the tab control using the specified theme.

Parameters
pDC | A CDC pointer that represents the current device context.
pTabCtrl | A pointer to a CXTPTabBase object.

◆ DrawTabIcon()

virtual void DrawTabIcon | ( | CDC * | pDC,
 |  | CTabCtrl * | pTabCtrl,
 |  | CRect & | rcItem,
 |  | int | iItem )
 protectedvirtual

This member function is called to draw the icon on the tab.

Parameters
pDC | A pointer to a valid device context.
pTabCtrl | A pointer to a CTabCtrl object.
rcItem | A CRect object that contains the location and dimensions of the tab.
iItem | An int that represents the tab item to draw the icon on.
See also
CXTPTabBaseThemeOfficeXP::FillTabFace, CXTPTabBaseThemeOffice2003::FillTabFace, DrawTab, DrawTabText, FillTabFace, FillTabFaceNativeWinXP, CXTPExcelTabCtrlTheme::DrawTab

Reimplemented in CXTPTabBaseThemeOfficeXP.

◆ DrawTabText()

virtual void DrawTabText | ( | CDC * | pDC,
 |  | CTabCtrl * | pTabCtrl,
 |  | CRect & | rcItem,
 |  | int | iItem,
 |  | BOOL | bSelected,
 |  | BOOL | bBoldFont )
 protectedvirtual

This member function is called to draw text on the tab.

Parameters
pDC | A pointer to a valid device context.
pTabCtrl | A pointer to a CTabCtrl object.
rcItem | A CRect object that contains the location and dimensions of the tab.
iItem | Index of the item to draw.
bSelected | TRUE if the tab is selected, FALSE otherwise.
bBoldFont | TRUE if the text is to be bold, FALSE otherwise.
See also
CXTPTabBaseThemeOfficeXP::FillTabFace, CXTPTabBaseThemeOffice2003::FillTabFace, DrawTabIcon, FillTabFace, FillTabFaceNativeWinXP, CXTPExcelTabCtrlTheme::DrawTab

◆ FillButtons()

virtual COLORREF FillButtons | ( | CDC * | pDC,
 |  | CXTPTabCtrlButtons * | pButtons )
 virtual

This method is called to draw navigate buttons.

Parameters
pDC | A CDC pointer that represents the current device context.
pButtons | A pointer to a collection of buttons to draw.
Returns
An RGB value that represents the background of the buttons.

Reimplemented in CXTPTabBaseThemeOffice2003, and CXTPTabBaseThemeOfficeXP.

◆ FillHeader()

virtual void FillHeader | ( | CDC * | pDC,
 |  | CXTPTabBase * | pTabCtrlBase,
 |  | CRect | rcHeader )
 protectedvirtual

This member function is called to draw the header for the tab control.

Parameters
pDC | A pointer to a valid device context.
pTabCtrlBase | A pointer to a CXTPTabBase object.
rcHeader | A CRect object that contains the location and dimensions of the header.
See also
CXTPTabBaseThemeOfficeXP::FillHeader, FillTabFaceNativeWinXP

Reimplemented in CXTPTabBaseThemeOffice2003, and CXTPTabBaseThemeOfficeXP.

◆ FillTabFace()

virtual void FillTabFace | ( | CDC * | pDC,
 |  | CTabCtrl * | pTabCtrl,
 |  | CRect | rcItem,
 |  | BOOL | bSelected )
 protectedvirtual

This member function is called to draw the tab face.

Parameters
pDC | A pointer to a valid device context.
pTabCtrl | A pointer to a CTabCtrl object.
rcItem | A CRect object that contains the location and dimensions of the tab.
bSelected | TRUE if the tab is selected, FALSE otherwise.
See also
CXTPTabBaseThemeOfficeXP::FillTabFace, CXTPTabBaseThemeOffice2003::FillTabFace, DrawTab, DrawTabIcon, DrawTabText, FillTabFaceNativeWinXP

Reimplemented in CXTPTabBaseThemeOffice2003, and CXTPTabBaseThemeOfficeXP.

◆ FillTabFaceNativeWinXP()

virtual void FillTabFaceNativeWinXP | ( | CDC * | pDC,
 |  | CTabCtrl * | pTabCtrl,
 |  | CRect | rcItem,
 |  | BOOL | bSelected )
 protectedvirtual

This member function is called to draw the tab face so that the tab appears with the Native Windows XP theme.

Parameters
pDC | A pointer to a valid device context.
pTabCtrl | A pointer to a CTabCtrl object. This is the associated TabControl object.
rcItem | A CRect object that contains the location and dimensions of the tab.
bSelected | TRUE if the tab is selected, FALSE otherwise.
See also
CXTPTabBaseThemeOfficeXP::FillTabFace, CXTPTabBaseThemeOffice2003::FillTabFace, FillTabFace, DrawTab, DrawTabIcon, DrawTabText

◆ GetBackColor()

virtual CXTPPaintManagerColor GetBackColor ( ) const
virtual

Call this member function to get the current background color for the theme.

Returns
A CXTPPaintManagerColor object that contains the value for the current background color.
See also
CXTPTabBaseThemeOffice2003::GetBackColor

Reimplemented in CXTPTabBaseThemeOffice2003.

◆ GetHeaderRect()

virtual CRect GetHeaderRect ( CXTPTabBase * pTabCtrlBase )
protectedvirtual

Call this member function to get the bounding rectangle of the tab header area.

Parameters
pTabCtrlBase A pointer to a CXTPTabBase object.
Returns
A CRect object that contains the bounding rectangle of the header area.
See also
FillHeader

◆ GetTabStyle()

DWORD GetTabStyle ( CTabCtrl * pTabCtrl ) const
inlineprotected

This member function is called to determine the tab style.

Parameters
pTabCtrl A pointer to a CTabCtrl object.
Returns
A DWORD representing the tab style.
See also
IsLeft, IsRight, IsTop, IsBottom, IsVert, IsHorz

◆ HorizontalLine()

void HorizontalLine | ( | CDC * | pDC,
 |  | int | xPos,
 |  | int | yPos,
 |  | int | nLength,
 |  | COLORREF | clr )
 protected

This member function is called to draw a horizontal line.

Parameters
pDC | A pointer to a valid device context.
xPos | An int that specifies the logical x-coordinate of the line.
yPos | An int that specifies the logical y-coordinate of the line.
nLength | Specifies the length of the line.
clr | An RGB value that specifies the color of the line.
See also
VerticalLine, Pixel, SwapColors

◆ IsBottom()

BOOL IsBottom ( DWORD dwStyle ) const
inlineprotected

This member function is called to determine if the tabs are drawn on the bottom of the tab control.

Parameters
dwStyle A DWORD value that represents the current tab style.
Returns
A BOOL. TRUE if the tabs are drawn on the bottom of the tab control, otherwise FALSE.
See also
GetTabStyle, IsLeft, IsRight, IsTop, IsVert, IsHorz

◆ IsHorz()

BOOL IsHorz ( DWORD dwStyle ) const
inlineprotected

This member function is called to determine if the tabs are drawn horizontally on the tab control.

Parameters
dwStyle A DWORD value that represents the current tab style.
Returns
A BOOL. TRUE if the tabs are drawn horizontally on the tab control, otherwise FALSE.
See also
GetTabStyle, IsLeft, IsRight, IsTop, IsVert, IsBottom

◆ IsLeft()

BOOL IsLeft ( DWORD dwStyle ) const
inlineprotected

This member function is called to determine if the tabs are drawn on the left side of the tab control.

Parameters
dwStyle A DWORD value that represents the current tab style.
Returns
A BOOL. TRUE if the tabs are drawn on the left side of the tab control, otherwise FALSE.
See also
GetTabStyle, IsRight, IsTop, IsBottom, IsVert, IsHorz

◆ IsRight()

BOOL IsRight ( DWORD dwStyle ) const
inlineprotected

This member function is called to determine if the tabs are drawn on the right side of the tab control.

Parameters
dwStyle A DWORD value that represents the current tab style.
Returns
A BOOL. TRUE if the tabs are drawn on the right side of the tab control, otherwise FALSE.
See also
GetTabStyle, IsLeft, IsTop, IsBottom, IsVert, IsHorz

◆ IsTop()

BOOL IsTop ( DWORD dwStyle ) const
inlineprotected

This member function is called to determine if the tabs are drawn on the top of the tab control.

Parameters
dwStyle A DWORD value that represents the current tab style.
Returns
A BOOL. TRUE if the tabs are drawn on the top of the tab control, otherwise FALSE.
See also
GetTabStyle, IsLeft, IsRight, IsBottom, IsVert, IsHorz

◆ IsVert()

BOOL IsVert ( DWORD dwStyle ) const
inlineprotected

This member function is called to determine if the tabs are drawn vertically on the tab control.

Parameters
dwStyle A DWORD value that represents the current tab style.
Returns
A BOOL. TRUE if the tabs are drawn vertically on the tab control, otherwise FALSE.
See also
GetTabStyle, IsLeft, IsRight, IsTop, IsBottom, IsHorz

◆ Pixel()

void Pixel | ( | CDC * | pDC,
 |  | int | xPos,
 |  | int | yPos,
 |  | COLORREF | clr )
 protected

This member function is called to draw a single pixel.

Parameters
pDC | A pointer to a valid device context.
xPos | An int that specifies the logical x-coordinate of the pixel.
yPos | An int that specifies the logical y-coordinate of the pixel.
clr | An RGB value that specifies the color of the pixel.
See also
VerticalLine, HorizontalLine, SwapColors

◆ RefreshMetrics()

virtual void RefreshMetrics ( CTabCtrl * pTab )
virtual

Call this function to refresh the colors of the Tab control.

Parameters
pTab Pointer to a CTabCtrl object.

Reimplemented in CXTPTabBaseThemeOffice2003, and CXTPTabBaseThemeOfficeXP.

◆ ShowButtons()

virtual void ShowButtons ( CXTPTabBase * pTabCtrlBase )
protectedvirtual

Call this function to paint the Navigation buttons on the tab control.

Parameters
pTabCtrlBase A pointer to a CXTPTabBase object. Contains information about the tab control.
See also
DrawButton

◆ SwapColors()

void SwapColors | ( | COLORREF & | clrLight,
 |  | COLORREF & | clrDark )
 protected

This member function is called to swap the dark and the light colors.

Parameters
clrLight | An RGB value that represents the light color.
clrDark | An RGB value that represents the dark color.
See also
VerticalLine, HorizontalLine, Pixel

◆ VerticalLine()

void VerticalLine | ( | CDC * | pDC,
 |  | int | xPos,
 |  | int | yPos,
 |  | int | nLength,
 |  | COLORREF | clr )
 protected

This member function is called to draw a vertical line.

Parameters
pDC | A pointer to a valid device context.
xPos | An int that specifies the logical x-coordinate of the line.
yPos | An int that specifies the logical y-coordinate of the line.
nLength | Specifies the length of the line.
clr | An RGB value that specifies the color of the line.
See also
HorizontalLine, Pixel, SwapColors

Member Data Documentation

◆ m_bSystemDrawing

BOOL m_bSystemDrawing

TRUE to perform system drawing.

FALSE otherwise.

◆ m_bUseWinThemes

BOOL m_bUseWinThemes

TRUE to use Windows XP themes when available.

FALSE otherwise.

◆ m_clrNormalText

CXTPPaintManagerColor m_clrNormalText
protected

Color of text in a normal tab.

Normal tabs are tabs that are not selected or disabled.

The documentation for this class was generated from the following file:
  • XTPTabBaseTheme.h


Toolkit Pro: CXTPTabBaseThemeOffice2003 Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPTabBaseThemeOffice2003 Class Reference

Class CXTPTabBaseThemeOffice2003 is derived from CXTPTabBaseThemeOfficeXP. More...

Inheritance diagram for CXTPTabBaseThemeOffice2003:
[legend]

Public Member Functions

CXTPTabBaseThemeOffice2003 ()
Constructs a CXTPTabBaseThemeOffice2003 object.
virtual void | RefreshMetrics (CTabCtrl *pTab)
This function calls the base class RefreshMetrics and then calls DeleteObject() for the CPen member variables m_penBlack, m_penWhite, m_penFace, and m_penText.
virtual CXTPPaintManagerColor | GetBackColor () const
This member function is called to get the background for the theme.
- Public Member Functions inherited from CXTPTabBaseThemeOfficeXP
CXTPTabBaseThemeOfficeXP ()
Constructs a CXTPTabBaseThemeOfficeXP object.
virtual void | AdjustBorders (CXTPTabBase *pTabCtrl, CXTPTcbItem *pMember)
Call this member function to redraw the borders for a particular tab.
virtual void | DrawButton (CDC *pDC, CXTPTabCtrlButton *pButton, COLORREF clrButton)
This member is called to draw a single button of a tab control.
- Public Member Functions inherited from CXTPTabBaseTheme
CXTPTabBaseTheme ()
Constructs a CXTPTabBaseTheme object.
virtual | ~CXTPTabBaseTheme ()
Destroys a CXTPTabBaseTheme object, handles cleanup and deallocation.
virtual void | DrawTabCtrl (CDC *pDC, CXTPTabBase *pTabCtrl)
This member function is called to render the tab control using the specified theme.
- Public Member Functions inherited from CXTPControlTheme
CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme | GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

virtual void | FillHeader (CDC *pDC, CXTPTabBase *pTabCtrlBase, CRect rcHeader)
This member function is called to draw the header for the tab Control.
virtual COLORREF | GradientFillTabFace (CDC *pDC, CTabCtrl *pTabCtrl, CRect rcItem, BOOL bSelected)
This member function is called to draw the tab face with a gradient fill.
virtual void | FillTabFace (CDC *pDC, CTabCtrl *pTabCtrl, CRect rcItem, BOOL bSelected)
This member function is called to draw the tab face.
virtual void | DrawBorder (CDC *pDC, const CRect &r)
This member function is called to draw a border around a tab child window.
virtual COLORREF | FillButtons (CDC *pDC, CXTPTabCtrlButtons *pButtons)
This method is called to draw navigate buttons.
- Protected Member Functions inherited from CXTPTabBaseThemeOfficeXP
virtual void | DrawTabIcon (CDC *pDC, CTabCtrl *pTabCtrl, CRect &rcItem, int iItem)
This member function is called to draw the icon on the tab.
virtual void | DrawBorders (CDC *pDC, const CRect &rcClient)
This member function is called to draw the borders around the tab control.
- Protected Member Functions inherited from CXTPTabBaseTheme
virtual void | FillTabFaceNativeWinXP (CDC *pDC, CTabCtrl *pTabCtrl, CRect rcItem, BOOL bSelected)
This member function is called to draw the tab face so that the tab appears with the Native Windows XP theme.
virtual void | DrawTab (CDC *pDC, CXTPTabBase *pTabCtrlBase, int iItem)
This member function is called to draw a tab on the tab control.
virtual void | DrawTabText (CDC *pDC, CTabCtrl *pTabCtrl, CRect &rcItem, int iItem, BOOL bSelected, BOOL bBoldFont)
This member function is called to draw text on the tab.
virtual CRect | GetHeaderRect (CXTPTabBase *pTabCtrlBase)
Call this member function to get the bounding rectangle of the tab header area.
virtual void | ShowButtons (CXTPTabBase *pTabCtrlBase)
Call this function to paint the Navigation buttons on the tab control.
DWORD | GetTabStyle (CTabCtrl *pTabCtrl) const
This member function is called to determine the tab style.
BOOL | IsLeft (DWORD dwStyle) const
This member function is called to determine if the tabs are drawn on the left side of the tab control.
BOOL | IsRight (DWORD dwStyle) const
This member function is called to determine if the tabs are drawn on the right side of the tab control.
BOOL | IsTop (DWORD dwStyle) const
This member function is called to determine if the tabs are drawn on the top of the tab control.
BOOL | IsBottom (DWORD dwStyle) const
This member function is called to determine if the tabs are drawn on the bottom of the tab control.
BOOL | IsVert (DWORD dwStyle) const
This member function is called to determine if the tabs are drawn vertically on the tab control.
BOOL | IsHorz (DWORD dwStyle) const
This member function is called to determine if the tabs are drawn horizontally on the tab control.
void | SwapColors (COLORREF &clrLight, COLORREF &clrDark)
This member function is called to swap the dark and the light colors.
void | VerticalLine (CDC *pDC, int xPos, int yPos, int nLength, COLORREF clr)
This member function is called to draw a vertical line.
void | HorizontalLine (CDC *pDC, int xPos, int yPos, int nLength, COLORREF clr)
This member function is called to draw a horizontal line.
void | Pixel (CDC *pDC, int xPos, int yPos, COLORREF clr)
This member function is called to draw a single pixel.

Protected Attributes

CXTPPaintManagerColorGradient | m_clrHeaderFace
Represents the gradient color of the header face.
CXTPPaintManagerColor | m_clrShadow
Represents the color used for shadows.
CXTPPaintManagerColor | m_clrHighlight
Represents the highlight color.
CXTPPaintManagerColor | m_clrDarkShadow
Represents the color used for dark shadows.
CXTPPaintManagerColor | m_clrButtonSelected
Represents the color used for selected buttons.
CXTPPaintManagerColor | m_clrButtonNormal
Represents the color used for normal buttons.
- Protected Attributes inherited from CXTPTabBaseTheme
int | m_iEdge
The Y dimension of a 3D border.
CXTPWinThemeWrapper * | m_themeTab
Windows Theme wrapper.
CXTPPaintManagerColor m_clrNormalText
Color of text in a normal tab.
- Protected Attributes inherited from CXTPControlTheme
XTPControlTheme | m_nTheme
Currently selected theme style index.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlTheme
static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPTabBaseTheme
BOOL | m_bSystemDrawing
TRUE to perform system drawing.
BOOL | m_bUseWinThemes
TRUE to use Windows XP themes when available.

Detailed Description

Class CXTPTabBaseThemeOffice2003 is derived from CXTPTabBaseThemeOfficeXP.

Member Function Documentation

◆ DrawBorder()

virtual void DrawBorder | ( | CDC * | pDC,
 |  | const CRect & | r )
 protectedvirtual

This member function is called to draw a border around a tab child window.

Parameters
pDC | A pointer to a valid device context.
r | A CRect object that contains the location and dimensions of the child window.
See also
CXTPTabBaseTheme::DrawBorder, CXTPTabBaseThemeOfficeXP::DrawBorder

Reimplemented from CXTPTabBaseThemeOfficeXP.

◆ FillButtons()

virtual COLORREF FillButtons | ( | CDC * | pDC,
 |  | CXTPTabCtrlButtons * | pButtons )
 protectedvirtual

This method is called to draw navigate buttons.

Parameters
pDC | A CDC pointer that represents the current device context.
pButtons | A pointer to a collection of buttons to draw.
Returns
An RGB value that represents the background of the buttons.

Reimplemented from CXTPTabBaseThemeOfficeXP.

◆ FillHeader()

virtual void FillHeader | ( | CDC * | pDC,
 |  | CXTPTabBase * | pTabCtrlBase,
 |  | CRect | rcHeader )
 protectedvirtual

This member function is called to draw the header for the tab Control.

Parameters
pDC | A pointer to a valid device context.
pTabCtrlBase | A pointer to a CXTPTabBase object.
rcHeader | A CRect object that contains the location and dimensions of the header.
See also
CXTPTabBaseTheme::FillHeader, CXTPTabBaseThemeOfficeXP::FillHeader

Reimplemented from CXTPTabBaseThemeOfficeXP.

◆ FillTabFace()

virtual void FillTabFace | ( | CDC * | pDC,
 |  | CTabCtrl * | pTabCtrl,
 |  | CRect | rcItem,
 |  | BOOL | bSelected )
 protectedvirtual

This member function is called to draw the tab face.

Parameters
pDC | A pointer to a valid device context.
pTabCtrl | A pointer to a CTabCtrl object.
rcItem | A CRect object that contains the location and dimensions of the tab.
bSelected | TRUE if the tab is selected, FALSE otherwise.
See also
CXTPTabBaseTheme::FillTabFace, CXTPTabBaseThemeOfficeXP::FillTabFace, GradientFillTabFace

Reimplemented from CXTPTabBaseThemeOfficeXP.

◆ GetBackColor()

virtual CXTPPaintManagerColor GetBackColor ( ) const
virtual

This member function is called to get the background for the theme.

Returns
A CXTPPaintManagerColor object that contains the value for the background color.
See also
CXTPTabBaseTheme::GetBackColor

Reimplemented from CXTPTabBaseTheme.

◆ GradientFillTabFace()

virtual COLORREF GradientFillTabFace | ( | CDC * | pDC,
 |  | CTabCtrl * | pTabCtrl,
 |  | CRect | rcItem,
 |  | BOOL | bSelected )
 protectedvirtual

This member function is called to draw the tab face with a gradient fill.

Parameters
pDC | A pointer to a valid device context.
pTabCtrl | A pointer to a CTabCtrl object.
rcItem | A CRect object that contains the location and dimensions of the tab.
bSelected | TRUE if the tab is selected, FALSE otherwise.
Returns
An RBG color that represents the dark color of the gradient fill for the tab.
See also
CXTPTabBaseThemeOfficeXP::FillTabFace, CXTPTabBaseThemeOffice2003::FillTabFace, FillTabFace, DrawTab, DrawTabIcon, DrawTabText

◆ RefreshMetrics()

virtual void RefreshMetrics ( CTabCtrl * pTab )
virtual

This function calls the base class RefreshMetrics and then calls DeleteObject() for the CPen member variables m_penBlack, m_penWhite, m_penFace, and m_penText.

Then, the CPen member variables are created with the system default colors for COLOR_BTNTEXT, COLOR_3DHIGHLIGHT, COLOR_3DFACE, and COLOR_3DSHADOW. Finally, the member variable m_iEdge is set to the SM_CYEDGE system value.

Parameters
pTab Pointer to a CTabCtrl object.

Reimplemented from CXTPTabBaseThemeOfficeXP.

The documentation for this class was generated from the following file:
  • XTPTabBaseTheme.h


Toolkit Pro: CXTPTabBaseThemeOfficeXP Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPTabBaseThemeOfficeXP Class Reference

Class CXTPTabBaseThemeOfficeXP is derived from CXTPTabBaseTheme. More...

Inheritance diagram for CXTPTabBaseThemeOfficeXP:
[legend]

Public Member Functions

CXTPTabBaseThemeOfficeXP ()
Constructs a CXTPTabBaseThemeOfficeXP object.
virtual void | RefreshMetrics (CTabCtrl *pTab)
This function calls the base class RefreshMetrics and then calls DeleteObject() for the CPen member variables m_penBlack, m_penWhite, m_penFace, and m_penText.
virtual void | AdjustBorders (CXTPTabBase *pTabCtrl, CXTPTcbItem *pMember)
Call this member function to redraw the borders for a particular tab.
virtual void | DrawButton (CDC *pDC, CXTPTabCtrlButton *pButton, COLORREF clrButton)
This member is called to draw a single button of a tab control.
virtual COLORREF | FillButtons (CDC *pDC, CXTPTabCtrlButtons *pButtons)
This method is called to draw navigate buttons.
- Public Member Functions inherited from CXTPTabBaseTheme
CXTPTabBaseTheme ()
Constructs a CXTPTabBaseTheme object.
virtual | ~CXTPTabBaseTheme ()
Destroys a CXTPTabBaseTheme object, handles cleanup and deallocation.
virtual void | DrawTabCtrl (CDC *pDC, CXTPTabBase *pTabCtrl)
This member function is called to render the tab control using the specified theme.
virtual CXTPPaintManagerColor | GetBackColor () const
Call this member function to get the current background color for the theme.
- Public Member Functions inherited from CXTPControlTheme
CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme | GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

virtual void | DrawTabIcon (CDC *pDC, CTabCtrl *pTabCtrl, CRect &rcItem, int iItem)
This member function is called to draw the icon on the tab.
virtual void | DrawBorders (CDC *pDC, const CRect &rcClient)
This member function is called to draw the borders around the tab control.
virtual void | FillHeader (CDC *pDC, CXTPTabBase *pTabCtrlBase, CRect rcHeader)
This member function is called to draw the header for the tab control.
virtual void | FillTabFace (CDC *pDC, CTabCtrl *pTabCtrl, CRect rcItem, BOOL bSelected)
This member function is called draw the tab face.
virtual void | DrawBorder (CDC *pDC, const CRect &r)
This member function is called to draw a border around a tab child window.
- Protected Member Functions inherited from CXTPTabBaseTheme
virtual void | FillTabFaceNativeWinXP (CDC *pDC, CTabCtrl *pTabCtrl, CRect rcItem, BOOL bSelected)
This member function is called to draw the tab face so that the tab appears with the Native Windows XP theme.
virtual void | DrawTab (CDC *pDC, CXTPTabBase *pTabCtrlBase, int iItem)
This member function is called to draw a tab on the tab control.
virtual void | DrawTabText (CDC *pDC, CTabCtrl *pTabCtrl, CRect &rcItem, int iItem, BOOL bSelected, BOOL bBoldFont)
This member function is called to draw text on the tab.
virtual CRect | GetHeaderRect (CXTPTabBase *pTabCtrlBase)
Call this member function to get the bounding rectangle of the tab header area.
virtual void | ShowButtons (CXTPTabBase *pTabCtrlBase)
Call this function to paint the Navigation buttons on the tab control.
DWORD | GetTabStyle (CTabCtrl *pTabCtrl) const
This member function is called to determine the tab style.
BOOL | IsLeft (DWORD dwStyle) const
This member function is called to determine if the tabs are drawn on the left side of the tab control.
BOOL | IsRight (DWORD dwStyle) const
This member function is called to determine if the tabs are drawn on the right side of the tab control.
BOOL | IsTop (DWORD dwStyle) const
This member function is called to determine if the tabs are drawn on the top of the tab control.
BOOL | IsBottom (DWORD dwStyle) const
This member function is called to determine if the tabs are drawn on the bottom of the tab control.
BOOL | IsVert (DWORD dwStyle) const
This member function is called to determine if the tabs are drawn vertically on the tab control.
BOOL | IsHorz (DWORD dwStyle) const
This member function is called to determine if the tabs are drawn horizontally on the tab control.
void | SwapColors (COLORREF &clrLight, COLORREF &clrDark)
This member function is called to swap the dark and the light colors.
void | VerticalLine (CDC *pDC, int xPos, int yPos, int nLength, COLORREF clr)
This member function is called to draw a vertical line.
void | HorizontalLine (CDC *pDC, int xPos, int yPos, int nLength, COLORREF clr)
This member function is called to draw a horizontal line.
void | Pixel (CDC *pDC, int xPos, int yPos, COLORREF clr)
This member function is called to draw a single pixel.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlTheme
static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPTabBaseTheme
BOOL | m_bSystemDrawing
TRUE to perform system drawing.
BOOL | m_bUseWinThemes
TRUE to use Windows XP themes when available.
- Protected Attributes inherited from CXTPTabBaseTheme
int | m_iEdge
The Y dimension of a 3D border.
CXTPWinThemeWrapper * | m_themeTab
Windows Theme wrapper.
CXTPPaintManagerColor m_clrNormalText
Color of text in a normal tab.
- Protected Attributes inherited from CXTPControlTheme
XTPControlTheme | m_nTheme
Currently selected theme style index.

Detailed Description

Class CXTPTabBaseThemeOfficeXP is derived from CXTPTabBaseTheme.

This class is used to implement an Office XP theme for the tab controls.

Member Function Documentation

◆ AdjustBorders()

virtual void AdjustBorders | ( | CXTPTabBase * | pTabCtrl,
 |  | CXTPTcbItem * | pMember )
 virtual

Call this member function to redraw the borders for a particular tab.

Parameters
pTabCtrl | A pointer to a CXTPTabBase object.
pMember | A pointer to a CXTPTcbItem struct that contains information about the tab.
See also
CXTPTabBaseTheme::AdjustBorders

Reimplemented from CXTPTabBaseTheme.

◆ DrawBorder()

virtual void DrawBorder | ( | CDC * | pDC,
 |  | const CRect & | r )
 protectedvirtual

This member function is called to draw a border around a tab child window.

Parameters
pDC | A pointer to a valid device context.
r | A CRect object that contains the location and dimensions of the child window.
See also
CXTPTabBaseTheme::DrawBorder, CXTPTabBaseThemeOffice2003::DrawBorder

Reimplemented from CXTPTabBaseTheme.

Reimplemented in CXTPTabBaseThemeOffice2003.

◆ DrawBorders()

virtual void DrawBorders | ( | CDC * | pDC,
 |  | const CRect & | rcClient )
 protectedvirtual

This member function is called to draw the borders around the tab control.

Parameters
pDC | A pointer to a valid device context.
rcClient | A CRect object that contains the location and dimensions of the tab control.
See also
CXTPTabBaseTheme::DrawBorders

Reimplemented from CXTPTabBaseTheme.

◆ DrawButton()

virtual void DrawButton | ( | CDC * | pDC,
 |  | CXTPTabCtrlButton * | pButton,
 |  | COLORREF | clrButton )
 virtual

This member is called to draw a single button of a tab control.

Parameters
pDC | A CDC pointer that represents the current device context.
pButton | A pointer to a CXTPTabCtrlButton object.
clrButton | The color of the button. Note: This function ASSERTS if called. Must be overridden.

Reimplemented from CXTPTabBaseTheme.

◆ DrawTabIcon()

virtual void DrawTabIcon | ( | CDC * | pDC,
 |  | CTabCtrl * | pTabCtrl,
 |  | CRect & | rcItem,
 |  | int | iItem )
 protectedvirtual

This member function is called to draw the icon on the tab.

Parameters
pDC | A pointer to a valid device context.
pTabCtrl | A pointer to a CTabCtrl object.
rcItem | A CRect object that contains the location and dimensions of the tab.
iItem | An int that represents the tab item to draw the icon on.
See also
CXTPTabBaseTheme::FillTabFace, CXTPTabBaseThemeOffice2003::FillTabFace, CXTPTabBaseTheme::DrawTabIcon, FillTabFace, CXTPTabBaseTheme::FillTabFaceNativeWinXP, CXTPExcelTabCtrlTheme::DrawTab

Reimplemented from CXTPTabBaseTheme.

◆ FillButtons()

virtual COLORREF FillButtons | ( | CDC * | pDC,
 |  | CXTPTabCtrlButtons * | pButtons )
 virtual

This method is called to draw navigate buttons.

Parameters
pDC | A CDC pointer that represents the current device context.
pButtons | A pointer to a collection of buttons to draw.
Returns
An RGB value that represents the background of the buttons.

Reimplemented from CXTPTabBaseTheme.

Reimplemented in CXTPTabBaseThemeOffice2003.

◆ FillHeader()

virtual void FillHeader | ( | CDC * | pDC,
 |  | CXTPTabBase * | pTabCtrlBase,
 |  | CRect | rcHeader )
 protectedvirtual

This member function is called to draw the header for the tab control.

Parameters
pDC | A pointer to a valid device context.
pTabCtrlBase | A pointer to a CXTPTabBase object.
rcHeader | A CRect object that contains the location and dimensions of the header.
See also
CXTPTabBaseTheme::FillHeader, CXTPTabBaseThemeOffice2003::FillHeader

Reimplemented from CXTPTabBaseTheme.

Reimplemented in CXTPTabBaseThemeOffice2003.

◆ FillTabFace()

virtual void FillTabFace | ( | CDC * | pDC,
 |  | CTabCtrl * | pTabCtrl,
 |  | CRect | rcItem,
 |  | BOOL | bSelected )
 protectedvirtual

This member function is called draw the tab face.

Parameters
pDC | A pointer to a valid device context.
pTabCtrl | A pointer to a CTabCtrl object.
rcItem | A CRect object that contains the location and dimensions of the tab.
bSelected | TRUE if the tab is selected, FALSE otherwise.
See also
CXTPTabBaseTheme::FillTabFace, CXTPTabBaseThemeOffice2003::FillTabFace, CXTPTabBaseThemeOffice2003::FillTabFace, DrawTabIcon, CXTPExcelTabCtrlTheme::DrawTab, CXTPTabBaseTheme::FillTabFaceNativeWinXP

Reimplemented from CXTPTabBaseTheme.

Reimplemented in CXTPTabBaseThemeOffice2003.

◆ RefreshMetrics()

virtual void RefreshMetrics ( CTabCtrl * pTab )
virtual

This function calls the base class RefreshMetrics and then calls DeleteObject() for the CPen member variables m_penBlack, m_penWhite, m_penFace, and m_penText.

Then, the CPen member variables are created with the system default colors for COLOR_BTNTEXT, COLOR_3DHIGHLIGHT, COLOR_3DFACE, and COLOR_3DSHADOW. Finally, the member variable m_iEdge is set to the SM_CYEDGE system value.

Parameters
pTab Pointer to a CTabCtrl object.

Reimplemented from CXTPTabBaseTheme.

Reimplemented in CXTPTabBaseThemeOffice2003.

The documentation for this class was generated from the following file:
  • XTPTabBaseTheme.h


Toolkit Pro: CXTPTabClientContext Class Reference

Public Member Functions | List of all members
CXTPTabClientContext Class Reference

CXTPTabClientContext is a standalone class. More...

Public Member Functions

CXTPTabClientContext ()
Constructs a CXTPTabClientContext object.
virtual | ~CXTPTabClientContext ()
Destroys a CXTPTabClientContext object, handles cleanup and deallocation.
CXTPTabClientWnd * | GetTabClient () const
Gets an associated tab client window pointer.
void | SetTabClient (CXTPTabClientWnd *pTabClientWnd)
Sets an associated tab client window pointer.
CXTPTabClientWnd * | FindTargetTabClient (POINT pt) const
Hit tests tab client window at the specific screen point.
BOOL | GetShowTabClientContextStickers () const
Gets a flag value that controls whether tab client stickers will be shown when needed.
void | SetShowTabClientContextStickers (BOOL value)
Sets a flag value that controls whether tab client stickers will be shown when needed.
BOOL | GetAlphaTabClientContext () const
Gets a flag that controls whether tab client context will be drawn as a semi-transparent rectangle.
void | SetAlphaTabClientContext (BOOL value)
Sets a flag that controls whether tab client context will be drawn as a semi-transparent rectangle.
BOOL | GetShowContentsWhileDragging () const
Gets a flag that controls whether tab floating frame contents will be shown while dragging.
void | SetShowContentsWhileDragging (BOOL value)
Sets a flag that controls whether tab floating frame contents will be shown while dragging.
BOOL | IsFloatingFrameThemeEnabled () const
Gets a flag that controls whether tab floating floating frame enables frame theme set for the primary tab client.
void | EnableFloatingFrameTheme (BOOL value)
Sets a flag that controls whether tab floating floating frame enables frame theme set for the primary tab client.
BOOL | EnableTabSticker ()
Enables tab stickers.
void | DisableTabSticker ()
Disables tab stickers.
BOOL | UpdateTabSticker ()
Updates tab stickers.
BOOL | EnableTabContextWindow ()
Enables tab context window.
void | DisableTabContextWindow ()
Disables context window.
BOOL | UpdateTabContextWindow ()
Updates tab context window.
void | EnableDraggingContents ()
Enables/disables dragging tab client context contents.
void | DisableDraggingContents ()
Enables/disables dragging tab client context contents.
void | UpdateDraggingContents ()
Updates tab client context contents while dragging.
void | EnableTabFocusRect ()
Enables/disables showing focus rectangle for a dragged tab client context contents.
void | DisableTabFocusRect ()
Enables/disables showing focus rectangle for a dragged tab client context contents.
void | UpdateTabFocusRect (CRect rcGroup)
Updates focus rectangle.
CXTPTabClientWnd * | GetLastTargetTabClient () const
Obtains the last target tab client window pointed by the mouse while dragging a frame.
int | GetLastWorkspace () const
Obtains the last pointed workspace index.
XTPTabClientStickerPart | GetLastSelectedTabClientSticker () const
Obtains the last pointed sticker identifier.
CXTPTabClientSticker * | GetSticker () const
Obtains the pointer to the last pointed sticker or NULL is there is no such.

Detailed Description

CXTPTabClientContext is a standalone class.

It is used internally for docking and sizing tabs.

Member Function Documentation

◆ DisableTabContextWindow()

void DisableTabContextWindow ( )

Disables context window.

See also
EnableTabContextWindow

◆ DisableTabSticker()

void DisableTabSticker ( )

Disables tab stickers.

See also
EnableTabSticker

◆ EnableFloatingFrameTheme()

AFX_INLINE void EnableFloatingFrameTheme ( BOOL value )

Sets a flag that controls whether tab floating floating frame enables frame theme set for the primary tab client.

Parameters
value TRUE if frame theme is enabled, FALSE otherwise.

◆ EnableTabContextWindow()

BOOL EnableTabContextWindow ( )

Enables tab context window.

Returns
TRUE if the context window is enabled.
See also
DisableTabContextWindow.

◆ EnableTabSticker()

BOOL EnableTabSticker ( )

Enables tab stickers.

Returns
TRUE if stickers are enabled, FALSE otherwise.
See also
DisableTabSticker

◆ FindTargetTabClient()

CXTPTabClientWnd * FindTargetTabClient ( POINT pt ) const

Hit tests tab client window at the specific screen point.

Parameters
pt Screen point at which a tab client window is to be tested.
Returns
A tab client window pointer at the specific screen point or NULL if no tab client window is detected.

◆ GetAlphaTabClientContext()

AFX_INLINE BOOL GetAlphaTabClientContext ( ) const

Gets a flag that controls whether tab client context will be drawn as a semi-transparent rectangle.

Returns
TRUE if tab client context is to be drawn semi-transparent, FALSE otherwise.

◆ GetLastSelectedTabClientSticker()

AFX_INLINE XTPTabClientStickerPart GetLastSelectedTabClientSticker ( ) const

Obtains the last pointed sticker identifier.

Returns
The last pointed sticker identifier.
See also
XTPTabClientStickerPart

◆ GetLastTargetTabClient()

AFX_INLINE CXTPTabClientWnd * GetLastTargetTabClient ( ) const

Obtains the last target tab client window pointed by the mouse while dragging a frame.

Returns
A pointer to the last pointed target tab client window or NULL is there is no such.

◆ GetLastWorkspace()

AFX_INLINE int GetLastWorkspace ( ) const

Obtains the last pointed workspace index.

Returns
The last pointed workspace index.

◆ GetShowContentsWhileDragging()

AFX_INLINE BOOL GetShowContentsWhileDragging ( ) const

Gets a flag that controls whether tab floating frame contents will be shown while dragging.

Returns
TRUE if contents is to be shown while dragging, FALSE otherwise.

◆ GetShowTabClientContextStickers()

AFX_INLINE BOOL GetShowTabClientContextStickers ( ) const

Gets a flag value that controls whether tab client stickers will be shown when needed.

Returns
TRUE if stickers will be shown when needed, or FALSE otherwise.

◆ GetSticker()

AFX_INLINE CXTPTabClientSticker * GetSticker ( ) const

Obtains the pointer to the last pointed sticker or NULL is there is no such.

Returns
The pointer to the last pointed sticker or NULL is there is no such.

◆ GetTabClient()

CXTPTabClientWnd * GetTabClient ( ) const

Gets an associated tab client window pointer.

Returns
An associated tab client window pointer.

◆ IsFloatingFrameThemeEnabled()

AFX_INLINE BOOL IsFloatingFrameThemeEnabled ( ) const

Gets a flag that controls whether tab floating floating frame enables frame theme set for the primary tab client.

Returns
TRUE if frame theme is enabled, FALSE otherwise.

◆ SetAlphaTabClientContext()

AFX_INLINE void SetAlphaTabClientContext ( BOOL value )

Sets a flag that controls whether tab client context will be drawn as a semi-transparent rectangle.

Parameters
value TRUE to enable semi-transparent rectangle drawing, FALSE otherwise.

◆ SetShowContentsWhileDragging()

AFX_INLINE void SetShowContentsWhileDragging ( BOOL value )

Sets a flag that controls whether tab floating frame contents will be shown while dragging.

Parameters
value TRUE to show contents while dragging, FALSE otherwise.

◆ SetShowTabClientContextStickers()

AFX_INLINE void SetShowTabClientContextStickers ( BOOL value )

Sets a flag value that controls whether tab client stickers will be shown when needed.

Parameters
value TRUE to show stickers, or FALSE otherwise.

◆ SetTabClient()

void SetTabClient ( CXTPTabClientWnd * pTabClientWnd )

Sets an associated tab client window pointer.

Parameters
pTabClientWnd a new associated tab client window pointer.

◆ UpdateTabContextWindow()

BOOL UpdateTabContextWindow ( )

Updates tab context window.

Returns
TRUE if context window is updated, FALSE otherwise.

◆ UpdateTabFocusRect()

void UpdateTabFocusRect ( CRect rcGroup )

Updates focus rectangle.

Parameters
rcGroup New focus rectangle value.

◆ UpdateTabSticker()

BOOL UpdateTabSticker ( )

Updates tab stickers.

Returns
TRUE if operation succeedes, FALSE otherwise.
The documentation for this class was generated from the following file:
  • XTPTabClientContext.h


Toolkit Pro: CXTPTabClientDraggingContents Class Reference

Public Member Functions | List of all members
CXTPTabClientDraggingContents Class Reference

Managers tab client dragging contents. More...

Public Member Functions

virtual | ~CXTPTabClientDraggingContents ()
Performs resource cleanup on object destruction.
BOOL | Create ()
Create the contents object.
int | GetHeight () const
Obtains contents height.
int | GetWidth () const
Obtains contents width.

Detailed Description

Managers tab client dragging contents.

Member Function Documentation

◆ Create()

BOOL Create ( )

Create the contents object.

Returns
TRUE if the contents object is successfully created, FALSE otherwise.

◆ GetHeight()

AFX_INLINE int GetHeight ( ) const

Obtains contents height.

Returns
Contents height value.
See also
GetWidth

◆ GetWidth()

AFX_INLINE int GetWidth ( ) const

Obtains contents width.

Returns
Contents width value.
See also
GetHeight
The documentation for this class was generated from the following file:
  • XTPTabClientDraggingContents.h


Toolkit Pro: CXTPTabClientSticker Class Reference

Public Member Functions | List of all members
CXTPTabClientSticker Class Reference

A tab client sticker control. More...

Inheritance diagram for CXTPTabClientSticker:
[legend]

Public Member Functions

CXTPTabClientSticker (CXTPTabClientWnd *pTabClientWnd, int nTabWorkspace)
Construct a sticker object.
virtual | ~CXTPTabClientSticker ()
Handles resource cleanup.
XTPTabClientStickerPart | HitTest (POINT pt) const
Determines which part of the sticker is under the specified point.
CXTPTabClientWnd * | GetTargetTabClientWnd () const
Gets the target tab client window pointer.
- Public Member Functions inherited from CXTPStickerBase
CXTPStickerBase ()
Construct a sticker object.
virtual | ~CXTPStickerBase ()
Handles resource cleanup.
BOOL | Create ()
Creates a sticker control.

Additional Inherited Members

- Protected Member Functions inherited from CXTPStickerBase
- Protected Attributes inherited from CXTPStickerBase
int m_stickers
Allowed stickers for tab client.

Detailed Description

A tab client sticker control.

Constructor & Destructor Documentation

◆ CXTPTabClientSticker()

CXTPTabClientSticker | ( | CXTPTabClientWnd * | pTabClientWnd,
 |  | int | nTabWorkspace )

Construct a sticker object.

Parameters
pTabClientWnd | A pointer to the associated tab client window.
nTabWorkspace | An index of the tab workspace.

Member Function Documentation

◆ GetTargetTabClientWnd()

CXTPTabClientWnd * GetTargetTabClientWnd ( ) const

Gets the target tab client window pointer.

Returns
Target tab client window pointer or NULL if no target is provided.

◆ HitTest()

XTPTabClientStickerPart HitTest ( POINT pt ) const

Determines which part of the sticker is under the specified point.

Parameters
pt A screen point to determine sticker part under.
Returns
Sticker part identifier.
See also
XTPTabClientStickerPart
The documentation for this class was generated from the following file:
  • XTPTabClientSticker.h


Toolkit Pro: CXTPTabClientWnd Class Reference

Public Member Functions | Public Attributes | Protected Member Functions | Protected Attributes | List of all members
CXTPTabClientWnd Class Reference

CXTPTabClientWnd is a CWnd derived class. More...

Inheritance diagram for CXTPTabClientWnd:
[legend]

Public Member Functions

CXTPTabClientWnd ()
Constructs a CXTPTabClientWnd object.
virtual | ~CXTPTabClientWnd ()
Destroys a CXTPTabClientWnd object, handles cleanup and deallocation.
BOOL | Attach (CXTPMDIFrameWnd *pParentFrame, BOOL bEnableGroups=FALSE)
Attaches the tabbed workspace.
BOOL | Attach (CXTPCommandBars *pCommandBars, CMDIFrameWnd *pParentFrame, BOOL bEnableGroups)
Attaches the tabbed workspace.
BOOL | Detach ()
Detaches the tabbed workspace.
BOOL | IsAttached () const
Determines if a tab workspace is attached.
CMDIFrameWnd * | GetParentFrame () const
Retrieves the parent frame of the control.
BOOL | IsLayoutRTL () const
Determines if right-to-left (RTL) mode is set.
void | SetLayoutRTL (BOOL bRightToLeft)
Specifies if right-to-left (RTL) mode should be set.
void | SetNewTabPosition (XTPWorkspaceNewTabPosition tabPosition)
Call this member to set where new tab must appear.
void | SetAfterCloseActiveTab (XTPWorkspaceActivateTab activeTab)
Call this member to set where new tab must appear.
XTPWorkspaceNewTabPosition | GetNewTabPositon () const
This method is called to determine where the new tab must appear.
void | SaveState ()
Saves Position state.
void | LoadState ()
Loads previous docking state.
virtual void | UpdateContents ()
Scan through all MDIChild windows and update the corresponding tab items if any changes happened (e.g.
virtual CWorkspace * | CreateWorkspace ()
This method is called to create a new CWorkspace class.
void | SetFlags (DWORD dwButtons)
Call this member to set the flags of the tab workspace.
DWORD | GetFlags () const
Call this member to determine which tab navigation buttons are currently displayed in the tab workspace.
void | EnableToolTips (XTPTabToolTipBehaviour behaviour=xtpTabToolTipAlways)
Call this member function to enable/disable tooltips show.
CXTPTabPaintManager * | GetPaintManager () const
Call this method to retrieve the paint manager.
void | SetPaintManager (CXTPTabPaintManager *pPaintManager)
Call this member to set the specified paint manager.
void | SetAutoTheme (BOOL bAutoTheme=FALSE)
Call this member to specify whether auto themes are used for the TabWorkspace.
BOOL | GetAutoTheme () const
Call this member to determine if auto themes are used to theme the TabWorkspace.
CXTPTabManagerItem * | FindItem (const HWND hWnd) const
Call this member to find the item that corresponds to the specified window.
CXTPTabManagerItem * | HitTest (CPoint pt) const
Call this function to determine which tab, if any, is at the specified screen position.
int | GetWorkspaceCount () const
Call this member to retrieve the current number of workspaces.
CWorkspace * | GetWorkspace (int nIndex) const
Call this member to return the workspace at the specified index.
BOOL | IsWorkspaceCommandEnabled (UINT nID, CXTPTabManagerItem **ppItem=NULL)
Returns the workspace command mode.
void | CreateNewVerticalGroup ()
Creates a new vertical group.
void | CreateNewHorizontalGroup ()
Creates a new horizontal group.
void | MoveToPreviousGroup ()
Moves an item to the previous group.
void | MoveToNextGroup ()
Moves an item to the next group.
void | Refresh (BOOL bRecalcLayout=TRUE)
Call this method to refresh all the items.
void | WorkspaceToScreen (LPPOINT lpPoint) const
Converts the workspace coordinates of a given point on the display to screen coordinates.
void | ScreenToWorkspace (LPPOINT lpPoint) const
Converts the screen coordinates of a given point or rectangle on the display to client coordinates.
void | ShowWorkspace (BOOL bShow)
Call this member function to show/hide the workspace.
void | SetTabWorkspace (CWorkspace *pWorkspace)
Call this method to set the custom workspace control.
BOOL | IsAllowReorder () const
Returns the current reordering allowance.
void | SetAllowReorder (BOOL bAllowReorder)
Call this member function to allow or disallow reordering.
virtual void | OnFillBackground (CDC *pDC, CRect rc)
This member is called when the background is filled.
virtual void | OnDraw (CDC *pDC, CRect rc)
This member is called when the client is drawn.
CXTPToolTipContext * | GetToolTipContext () const
Call this method to get a pointer to the tooltip context.
void | UseSplitterTracker (BOOL bSplitterTracker)
Call this member to use trackers.
BOOL | IsSplitterTrackerUsed () const
Call this member to determine if the splitter tracker is used.
virtual CXTPCommandBars * | GetCommandBars () const
Gets the command bars object.
void | SetCommandBars (CXTPCommandBars *pCommandBars)
Sets the command bars object.
void | MDITile (BOOL bHorizontal)
Call this member to tile child windows in the workspace (only if EnableGroups is enabled).
CXTPTabManagerItem * | GetItem (int nIndex) const
Returns an item by its index.
int | GetItemCount () const
Returns the number of items.
virtual void | Reposition ()
Call this method to reposition items.
void | EnableMarkup (BOOL bEnableMarkup)
This member function is used to enable/disable Markup functionality for the control.
void | ShowNewWindowTab (BOOL bShowNewWindowTab=TRUE, int nCommand=ID_FILE_NEW)
Call this method to add an Explorer 7 style new window tab button.
int | FindIndex (CXTPTabManager *pWorkspace) const
Call this member to find the specified index.
- Public Member Functions inherited from CXTPTabManagerAtom
virtual void | OnPropertyChanged ()
This method is called when a property of the tab paint manager is changed.

Public Attributes

BOOL | m_bDelayLock
TRUE to lock update with small delay.
BOOL | m_bLockUpdate
TRUE to lock update tabs.
BOOL | m_bForceToRecalc
TRUE to recalculate in next idle event.
BOOL | m_bLockReposition
TRUE to lock reposition.

Protected Member Functions

virtual void | CheckCommandBarsTheme ()
If m_bAutoTheme is FALSE, then it checks to see if the theme set for the TabWorkspace is different from the theme set for the CommandBars.
virtual CWnd * | MDIGetActive ()
Retrieves the current active MDI child window.
virtual void | MDIActivate (CWnd *pWnd)
Call this member function to activate an MDI child window independently of the MDI frame window.
virtual CString | GetItemText (const CWnd *pChildWnd) const
This member function retrieves the text of a specific tab.
virtual COLORREF | GetItemColor (const CXTPTabManagerItem *pItem) const
This member function returns the RGB value for the referenced item text, or (COLORREF)-1 if the color was not set.
virtual HICON | GetItemIcon (const CXTPTabManagerItem *pItem) const
This member function retrieves the icon of a specific tab.
virtual CString | GetItemTooltip (const CXTPTabManagerItem *pItem) const
Returns the tooltip associated with the specified item.
virtual CWorkspace * | AddWorkspace (int nIndex=-1)
Call this member function to add a workspace.
virtual CXTPTabManagerItem * | AddItem (CWnd *pChildWnd)
This member function adds a new tab item for the specified window.
void | SetActiveWorkspace (CWorkspace *pWorkspace)
This member function sets a workspace active.
void | ContextMenu (CPoint pt)
This method shows the context menu for toolbars.
virtual void | UpdateFlags (CWorkspace *pWorkspace)
This member function is called to update the status of the TabWorkspace navigation buttons.
CXTPTabManagerItem * | GetSelectedItem () const
Returns the selected item in the control.
- Protected Member Functions inherited from CXTPTabManagerAtom
virtual | ~CXTPTabManagerAtom ()
Destroys a CXTPTabManagerAtom object, handles cleanup and deallocation.

Protected Attributes

CArray< CWorkspace *, CWorkspace * > | m_arrWorkspace
Array of workspaces.
CWorkspace * | m_pTabWorkspace
Custom workspace.
BOOL | m_bUserWorkspace
TRUE if custom workspace used.
CMDIFrameWnd * | m_pParentFrame
Pointer to the corresponding parent MDIFrame window.
BOOL | m_bRefreshed
TRUE if Refresh currently executed.
CXTPTabPaintManager * | m_pPaintManager
Current paint manager.
XTPPaintTheme | m_themeCommandBars
Theme set for the TabWorkspace (Can be different from CommandBars if m_bAutoTheme is FALSE)
BOOL | m_bAutoTheme
TRUE to auto theme the TabWorkspace.
CWorkspace * | m_pActiveWorkspace
Active workspace.
BOOL | m_bHorizSplitting
TRUE if groups divided horizontally.
HCURSOR | m_hCursorHoriz
Horizontal split cursor handle.
HCURSOR | m_hCursorVert
Vertical split cursor handle.
HCURSOR | m_hCursorNew
New item cursor handle.
HCURSOR | m_hCursorDelete
Remove item cursor handle.
BOOL | m_bThemedBackColor
TRUE if a themed backcolor will be used.
BOOL | m_bEnableGroups
TRUE if TabWorkspace groups are enabled.
DWORD | m_dwFlags
Specifies which tab navigation buttons are displayed.
BOOL | m_bAllowReorder
TRUE to allow the user to reorder tabs.
BOOL | m_bShowWorkspace
TRUE to show the TabWorkspace, FALSE to hide the TabWorkspace.
BOOL | m_bUpdateContents
TRUE if UpdateContents executed.
CXTPToolTipContext * | m_pToolTipContext
Tooltip Context.
BOOL | m_bUseSplitterTracker
If TRUE, splitter trackers are used.
int | m_nSplitterSize
Splitter size.
XTPWorkspaceNewTabPosition | m_newTabPosition
New tab position.
XTPWorkspaceActivateTab | m_afterCloseTabPosition
Tab to make active after the currently active tab is closed.
BOOL | m_bAutoUpdateTabCaption
TRUE if the tab caption is to be updated automatically when changed, FALSE if it must manually be updated.
CXTPMarkupContext * | m_pMarkupContext
Markup Context.

Detailed Description

CXTPTabClientWnd is a CWnd derived class.

It represents a tabbed workspace.

Member Function Documentation

◆ AddItem()

virtual CXTPTabManagerItem * AddItem ( CWnd * pChildWnd )
protectedvirtual

This member function adds a new tab item for the specified window.

Parameters
pChildWnd A CWnd pointer that represents the child to be displayed when the window is activated.
Returns
A pointer to a CXTPTabManagerItem object.

◆ AddWorkspace()

virtual CWorkspace * AddWorkspace ( int nIndex = -1 )
protectedvirtual

Call this member function to add a workspace.

Parameters
nIndex Index of the workspace.
Returns
TRUE if successful, otherwise FALSE.

◆ Attach() [1/2]

BOOL Attach | ( | CXTPCommandBars * | pCommandBars,
 |  | CMDIFrameWnd * | pParentFrame,
 |  | BOOL | bEnableGroups )

Attaches the tabbed workspace.

Parameters
pParentFrame | Pointer to a CMDIFrameWnd object.
bEnableGroups | TRUE to enable groups.
pCommandBars | Pointer to a CXTPCommandBars object.
Returns
TRUE if successful, otherwise FALSE.

◆ Attach() [2/2]

BOOL Attach | ( | CXTPMDIFrameWnd * | pParentFrame,
 |  | BOOL | bEnableGroups = FALSE )

Attaches the tabbed workspace.

Parameters
pParentFrame | Pointer to a CMDIFrameWnd object.
bEnableGroups | TRUE to enable groups.
Returns
TRUE if successful, otherwise FALSE.

◆ CheckCommandBarsTheme()

virtual void CheckCommandBarsTheme ( )
protectedvirtual

If m_bAutoTheme is FALSE, then it checks to see if the theme set for the TabWorkspace is different from the theme set for the CommandBars.

If the themes are different, then the TabWorkSpace theme is set to the theme specified in m_themeCommandBars.

◆ ContextMenu()

void ContextMenu ( CPoint pt )
protected

This method shows the context menu for toolbars.

Parameters
pt Position of the menu to show.

◆ CreateWorkspace()

virtual CWorkspace * CreateWorkspace ( )
virtual

This method is called to create a new CWorkspace class.

You can override it for a custom Workskspace.

Returns
A newly created workspace object pointer.

◆ Detach()

BOOL Detach ( )

Detaches the tabbed workspace.

Returns
TRUE if successful, otherwise FALSE.

◆ EnableMarkup()

void EnableMarkup ( BOOL bEnableMarkup )

This member function is used to enable/disable Markup functionality for the control.

Parameters
bEnableMarkup A BOOL. Specifies whether Markup functionality should be enabled (TRUE) or disabled (FALSE).

◆ EnableToolTips()

void EnableToolTips ( XTPTabToolTipBehaviour behaviour = xtpTabToolTipAlways )

Call this member function to enable/disable tooltips show.

Parameters
behaviour Tooltips behaviour to be set. See remarks section for available flags.

behaviour parameter can be one of the following: xtpTabToolTipNever: Show tooltips for tabs always. xtpTabToolTipAlways: Doesn't show tooltips for tabs. xtpTabToolTipShrinkedOnly: Show tooltips only if tab was shrinked (see xtpTabLayoutSizeToFit layout).

◆ FindIndex()

int FindIndex ( CXTPTabManager * pWorkspace ) const

Call this member to find the specified index.

Parameters
pWorkspace Pointer to a CXTPTabManger object.
Returns
The index of the matching item.

◆ FindItem()

CXTPTabManagerItem * FindItem ( const HWND hWnd ) const

Call this member to find the item that corresponds to the specified window.

Parameters
hWnd Handle of the window.
Returns
A pointer to a CXTPTabManagerItem object.

◆ GetAutoTheme()

BOOL GetAutoTheme ( ) const

Call this member to determine if auto themes are used to theme the TabWorkspace.

Returns
TRUE if auto themes are used to theme the TabWorkspace, FALSE if auto themes are not used.

◆ GetCommandBars()

virtual CXTPCommandBars * GetCommandBars ( ) const
virtual

Gets the command bars object.

Returns
A pointer to the command bars object (can be NULL).

◆ GetFlags()

AFX_INLINE DWORD GetFlags ( ) const

Call this member to determine which tab navigation buttons are currently displayed in the tab workspace.

Returns
Retrieves the tab navigation flags of the tab workspace.
See also
SetFlags, XTPWorkspaceButtons

◆ GetItem()

CXTPTabManagerItem * GetItem ( int nIndex ) const

Returns an item by its index.

Parameters
nIndex Zero-based index of the item in the collection.

You use this member function to get an item from collection by item index. If the given index is less than 0 or greater than the value returned by GetItemCount(), GetItem() returns NULL.

Returns
Pointer to the found item, if any, or NULL otherwise.

◆ GetItemColor()

virtual COLORREF GetItemColor ( const CXTPTabManagerItem * pItem ) const
protectedvirtual

This member function returns the RGB value for the referenced item text, or (COLORREF)-1 if the color was not set.

Parameters
pItem A pointer to a CXTPTabManagerItem.
Returns
The RGB value for the referenced item text, or (COLORREF)-1 if the color was not set.

◆ GetItemCount()

int GetItemCount ( ) const

Returns the number of items.

Returns
The number of items.

◆ GetItemIcon()

virtual HICON GetItemIcon ( const CXTPTabManagerItem * pItem ) const
protectedvirtual

This member function retrieves the icon of a specific tab.

Parameters
pItem A pointer to a CXTPTabManagerItem.
Returns
The icon of a particular tab, or NULL if an error occurs.

◆ GetItemText()

virtual CString GetItemText ( const CWnd * pChildWnd ) const
protectedvirtual

This member function retrieves the text of a specific tab.

Parameters
pChildWnd A CWnd pointer that represents the child to be displayed when the window is activated.
Returns
The text of a particular tab, or NULL if an error occurs.

◆ GetItemTooltip()

virtual CString GetItemTooltip ( const CXTPTabManagerItem * pItem ) const
protectedvirtual

Returns the tooltip associated with the specified item.

Parameters
pItem Pointer to a CXTPTabManagerItem object.
Returns
Associated tooltip.

◆ GetNewTabPositon()

AFX_INLINE XTPWorkspaceNewTabPosition GetNewTabPositon ( ) const

This method is called to determine where the new tab must appear.

Returns
XTPWorkspaceNewTabPosition enumerator that shows where the new tab must appear.
See also
XTPWorkspaceNewTabPosition, SetNewTabPosition

◆ GetPaintManager()

CXTPTabPaintManager * GetPaintManager ( ) const

Call this method to retrieve the paint manager.

Returns
A pointer to a CXTPTabPaintManager object.

◆ GetParentFrame()

AFX_INLINE CMDIFrameWnd * GetParentFrame ( ) const

Retrieves the parent frame of the control.

Returns
Pointer to a CMDIFrameWnd object.

◆ GetSelectedItem()

CXTPTabManagerItem * GetSelectedItem ( ) const
protected

Returns the selected item in the control.

Returns
A pointer to a CXTPTabManagerItem object.

◆ GetToolTipContext()

AFX_INLINE CXTPToolTipContext * GetToolTipContext ( ) const

Call this method to get a pointer to the tooltip context.

Returns
A pointer to the tooltip context.

◆ GetWorkspace()

CWorkspace * GetWorkspace ( int nIndex ) const

Call this member to return the workspace at the specified index.

Parameters
nIndex An integer index starting at 0.
Returns
A pointer to the workspace currently at this index.

If tab groups are enabled, then there will be more than one workspace. If tab groups are disabled, then there is only 1 workspace with an index of 0.

See also
GetWorkspaceCount

◆ GetWorkspaceCount()

int GetWorkspaceCount ( ) const

Call this member to retrieve the current number of workspaces.

Returns
An integer value that represents the current number of workspaces.

If tab groups are enabled, then there will be more than one workspace. If tab groups are disabled, then there is only 1 workspace with an index of 0.

See also
GetWorkspace

◆ HitTest()

CXTPTabManagerItem * HitTest ( CPoint pt ) const

Call this function to determine which tab, if any, is at the specified screen position.

Parameters
pt Point to be tested.
Returns
The zero-based index of the tab, or returns -1 if no tab is at the specified position.

◆ IsAllowReorder()

BOOL IsAllowReorder ( ) const

Returns the current reordering allowance.

Returns
TRUE when reordering is allowed, FALSE when it is disallowed.

◆ IsAttached()

AFX_INLINE BOOL IsAttached ( ) const

Determines if a tab workspace is attached.

Returns
TRUE if attached, otherwise FALSE.

◆ IsLayoutRTL()

BOOL IsLayoutRTL ( ) const

Determines if right-to-left (RTL) mode is set.

Returns
TRUE if text is displayed using right-to-left (RTL) reading-order properties.

◆ IsSplitterTrackerUsed()

AFX_INLINE BOOL IsSplitterTrackerUsed ( ) const

Call this member to determine if the splitter tracker is used.

Returns
TRUE if the splitter tracker is used, otherwise FALSE.
See also
UseSplitterTracker

◆ IsWorkspaceCommandEnabled()

BOOL IsWorkspaceCommandEnabled | ( | UINT | nID,
 |  | CXTPTabManagerItem ** | ppItem = NULL )

Returns the workspace command mode.

Parameters
nID | Specifies the identifier of the workspace.
ppItem | MDI active item.

Call this member function if you want to determine whether or not workspace command is enabled.

Returns
TRUE when workspace command is enabled, FALSE when it is disabled.

◆ MDIActivate()

virtual void MDIActivate ( CWnd * pWnd )
protectedvirtual

Call this member function to activate an MDI child window independently of the MDI frame window.

Parameters
pWnd Pointer to a valid device context.

◆ MDIGetActive()

virtual CWnd * MDIGetActive ( )
protectedvirtual

Retrieves the current active MDI child window.

Returns
A pointer to the active MDI child window.

◆ MDITile()

void MDITile ( BOOL bHorizontal )

Call this member to tile child windows in the workspace (only if EnableGroups is enabled).

Parameters
bHorizontal TRUE to tile horizontally.

◆ OnDraw()

virtual void OnDraw | ( | CDC * | pDC,
 |  | CRect | rc )
 virtual

This member is called when the client is drawn.

Parameters
pDC | Pointer to a valid device context.
rc | Rectangle area to be drawn.

◆ OnFillBackground()

virtual void OnFillBackground | ( | CDC * | pDC,
 |  | CRect | rc )
 virtual

This member is called when the background is filled.

Parameters
pDC | Pointer to a valid device context.
rc | Rectangle area to be filled.

◆ Refresh()

void Refresh ( BOOL bRecalcLayout = TRUE )

Call this method to refresh all the items.

Parameters
bRecalcLayout TRUE to recalculate the layout of the frame.

◆ ScreenToWorkspace()

void ScreenToWorkspace ( LPPOINT lpPoint ) const

Converts the screen coordinates of a given point or rectangle on the display to client coordinates.

Parameters
lpPoint Pointer to a CPoint object or POINT structure that contains the screen coordinates to be converted.

◆ SetActiveWorkspace()

void SetActiveWorkspace ( CWorkspace * pWorkspace )
protected

This member function sets a workspace active.

Parameters
pWorkspace Pointer to a CWorkspace object.

◆ SetAfterCloseActiveTab()

AFX_INLINE void SetAfterCloseActiveTab ( XTPWorkspaceActivateTab activeTab )

Call this member to set where new tab must appear.

Parameters
activeTab Enumerator that determines which tab will be activated after closing another one. It can be one of the following: xtpWorkspaceActivateNextToClosed: Activate tab next to the closed tab. xtpWorkspaceActivateTopmost: Activate the top-most tab.
See also
XTPWorkspaceNewTabPosition, GetNewTabPositon, XTPWorkspaceActivateTab

◆ SetAllowReorder()

void SetAllowReorder ( BOOL bAllowReorder )

Call this member function to allow or disallow reordering.

Parameters
bAllowReorder TRUE for allowing reordering, FALSE for disallowing reordering.

◆ SetAutoTheme()

void SetAutoTheme ( BOOL bAutoTheme = FALSE )

Call this member to specify whether auto themes are used for the TabWorkspace.

Parameters
bAutoTheme TRUE to use auto themes.

By default, AutoTheme = TRUE. When AutoTheme = TRUE, the theme of the TabWorkspace will change when the theme of the CommandBars control is changed. Set AutoTheme = FALSE to keep the currently set theme even if the CommandBars theme is changed.

◆ SetCommandBars()

void SetCommandBars ( CXTPCommandBars * pCommandBars )

Sets the command bars object.

Parameters
pCommandBars A new command bars object point

◆ SetFlags()

void SetFlags ( DWORD dwButtons )

Call this member to set the flags of the tab workspace.

Parameters
dwButtons Buttons to hide. Can be any of the values listed in the remarks section.

dwButtons can be one of the following: xtpWorkspaceHideArrows: Hides the arrow buttons. xtpWorkspaceHideClose: Hides the close button. xtpWorkspaceHideAll: Hides the arrow and close buttons.

See also
GetFlags, XTPWorkspaceButtons

◆ SetLayoutRTL()

void SetLayoutRTL ( BOOL bRightToLeft )

Specifies if right-to-left (RTL) mode should be set.

Parameters
bRightToLeft TRUE to display text using right-to-left (RTL) reading-order properties.

◆ SetNewTabPosition()

AFX_INLINE void SetNewTabPosition ( XTPWorkspaceNewTabPosition tabPosition )

Call this member to set where new tab must appear.

Parameters
tabPosition Position of new tab regarding other tabs. It can be one of the following: xtpWorkspaceNewTabRightMost: New tab will be created after all tabs. xtpWorkspaceNewTabLeftMost: New tab will be created before all tabs. xtpWorkspaceNewTabNextToActive: New tab will be created after active tab.

◆ SetPaintManager()

void SetPaintManager ( CXTPTabPaintManager * pPaintManager )

Call this member to set the specified paint manager.

Parameters
pPaintManager Pointer to a CXTPTabPaintManager object.

◆ SetTabWorkspace()

void SetTabWorkspace ( CWorkspace * pWorkspace )

Call this method to set the custom workspace control.

Parameters
pWorkspace Custom workspace control.

◆ ShowNewWindowTab()

void ShowNewWindowTab | ( | BOOL | bShowNewWindowTab = TRUE,
 |  | int | nCommand = ID_FILE_NEW )

Call this method to add an Explorer 7 style new window tab button.

Parameters
bShowNewWindowTab | TRUE to show new window tab button.
nCommand | Command to execute.

◆ ShowWorkspace()

void ShowWorkspace ( BOOL bShow )

Call this member function to show/hide the workspace.

Parameters
bShow TRUE to show the workspace, FALSE to hide it.

◆ UpdateContents()

virtual void UpdateContents ( )
virtual

Scan through all MDIChild windows and update the corresponding tab items if any changes happened (e.g.

window text or active MDIChild).

◆ UpdateFlags()

virtual void UpdateFlags ( CWorkspace * pWorkspace )
protectedvirtual

This member function is called to update the status of the TabWorkspace navigation buttons.

Parameters
pWorkspace Pointer to a CWorkspace object. SeeAlso: SetFlags, GetFlags

◆ UseSplitterTracker()

AFX_INLINE void UseSplitterTracker ( BOOL bSplitterTracker )

Call this member to use trackers.

Parameters
bSplitterTracker TRUE to use trackers.

This member function will display the contents for child windows while the splitter is resized if bSplitterTracker is set to FALSE.

See also
IsSplitterTrackerUsed

◆ WorkspaceToScreen()

void WorkspaceToScreen ( LPPOINT lpPoint ) const

Converts the workspace coordinates of a given point on the display to screen coordinates.

Parameters
lpPoint Pointer to a POINT structure or CPoint object that contains the client coordinates to be converted.

Member Data Documentation

◆ m_bThemedBackColor

BOOL m_bThemedBackColor
protected

TRUE if a themed backcolor will be used.

If TRUE, then the backcolor of the MDIClient is calculated from the current theme, if FALSE, then the standard BackColor property will be used.

◆ m_bUseSplitterTracker

BOOL m_bUseSplitterTracker
protected

If TRUE, splitter trackers are used.

When resizing a workspace, an outline of the workspace is drawn as the splitter is dragged. If FALSE, then the workspace will be resized in "real-time."

The documentation for this class was generated from the following file:
  • XTPTabClientWnd.h


Toolkit Pro: CXTPTabColorSetDefault Class Reference

Public Member Functions | List of all members
CXTPTabColorSetDefault Class Reference

CXTPTabColorSetDefault implements a default tab color set. More...

Inheritance diagram for CXTPTabColorSetDefault:
[legend]

Public Member Functions

virtual void | RefreshMetrics ()
Refreshes the visual metrics of the tabs.
void | FillNavigateButton (CDC *pDC, CXTPTabManagerNavigateButton *pButton, CRect &rc)
Fills a specified tab navigation button.
- Public Member Functions inherited from CXTPTabPaintManagerColorSet
CXTPTabPaintManagerColorSet ()
Constructs a CXTPTabPaintManagerColorSet object.
virtual | ~CXTPTabPaintManagerColorSet ()
Destroys a CXTPTabPaintManagerColorSet object, handles cleanup and deallocation.
virtual void | SetTextColor (CDC *pDC, CXTPTabManagerItem *pItem)
Sets the text color for the tab.
virtual void | FillHeader (CDC *pDC, CRect rc, CXTPTabManager *pTabManager)
Fills the header of the tab client of a specified tab manager.
virtual COLORREF | FillClient (CDC *pDC, CRect rc, CXTPTabManager *pTabManager)
Fills the tab client area of a specified tab manager.
virtual COLORREF | GetClientColor (CXTPTabManager *pTabManager)
Obtains client background color.
virtual void | FillStateButton (CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem)
Fills a specified tab button when XTPTabAppearanceStyle is xtpTabAppearanceStateButtons.
virtual COLORREF | FillPropertyButton (CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem)
Fills a specified tab button.
virtual void | SelectClipRgn (CDC *pDC, CRect rcClient, CXTPTabManager *pTabManager)
Sets a clipping region for the specified tab client area.
virtual COLORREF | GetItemColor (CXTPTabManagerItem *pItem)
Retrieves the color of a specified tab.
void | GradientFill (CDC *pDC, CRect rc, COLORREF clrLight, COLORREF clrDark, XTPTabPosition position)
Performs a gradient fill of a rectangle with a color that smoothly fades from top to bottom.
virtual BOOL | IsAppThemed () const
Determines if Windows XP themes are enabled and if a Windows XP theme is currently used.

Additional Inherited Members

- Public Attributes inherited from CXTPTabPaintManagerColorSet
CXTPPaintManagerColorGradient | m_clrHeaderFace
Color set of the tab header background.
CXTPPaintManagerColorGradient m_clrAutoHideFace
Color set of the auto-hide panel background.
CXTPPaintManagerColor | m_clrFrameBorder
Color of the border placed around the tab buttons and the tab client.
CXTPPaintManagerColor m_clrControlFace
Color of the control foreground.
CXTPPaintManagerColor | m_clrPaneFace
Color of the control pane foreground.
CXTPPaintManagerColor | m_clrBorderHighlight
Color of the highlight border.
CXTPPaintManagerColor | m_clrTabClientBack
Background color for the tab client area.
CXTPPaintManagerColor | m_clrTabClientBorder
Border color for the tab client area.
CXTPPaintManagerColor m_clrButtonNormal
Color of normal tabs.
CXTPPaintManagerColor | m_clrButtonPressed
Tab pressed button color.
CXTPPaintManagerColor | m_clrButtonHighlighted
Tab button color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonHighlightedClose
Tab close button color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonBorderHighlighted
Tab button border color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonBorderTabContext1
Tab button border color with tab context.
CXTPPaintManagerColor | m_clrButtonBorderTabContext2
Tab button border color with tab context.
CXTPPaintManagerColor | m_clrButtonBorderKeyTips
Tab button border color when ALT button is pressed.
CXTPPaintManagerColor | m_clrButtonSelected
Color of the currently selected tab.
CXTPPaintManagerColor | m_clrButtonSelectedPressed
Color of the currently selected tab when pressed.
CXTPPaintManagerColor | m_clrButtonSelectedHighlighted
Color of the currently selected tab when highlighted.
CXTPPaintManagerColor | m_clrButtonBorder
Tab button border (edge) color.
CXTPPaintManagerColor | m_clrButtonBorderHot
Tab button highlight or pressed border (edge) color.
CXTPPaintManagerColor m_clrTextNormal
Color of text in a normal tab.
CXTPPaintManagerColor m_clrTextPressed
Color of text in a "pressed" tab button.
CXTPPaintManagerColor | m_clrTextHighlight
Color of text on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrTextHighlightClose
Color of close button text on mouse over when hot tracking is enabled.
CXTPPaintManagerColor m_clrTextSelected
Color of text in a "selected" tab button.
CXTPPaintManagerColor m_clrTextSelectedPressed
Color of text in a "pressed" tab button.
CXTPPaintManagerColor | m_clrTextSelectedHighlighted
Color of text for tabs in all non-active groups of tabs in MDITabClient.
CXTPPaintManagerColor m_clrTextDisabled
Color of text when a tab is disabled.
CXTPPaintManagerColor | m_clrActiveFilesGlyph
Color of navigation button.
CXTPPaintManagerColor | m_clrActiveFilesGlyphHighlighted
Color of highlighted navigation button.
CXTPPaintManagerColor | m_clrActiveFilesGlyphPressed
Color of selected navigation button.
CXTPPaintManagerColor | m_clrActiveFilesBack
Color of highlighted navigation button background.
CXTPPaintManagerColor | m_clrActiveFilesBackHighlighted
Color of navigation button background.
CXTPPaintManagerColor | m_clrActiveFilesBackPressed
Color of selected navigation button background.
COLORSET_TAB_STATEBUTTON | m_csStateButton
Color set of state button style tabs.
COLORSET_TAB_PROPERTYPAGE | m_csPropertyPage
Color set of visual studio style tabs.
COLORSET_TAB_PROPERTYPAGE2003 | m_csPropertyPage2003
Color set of Office 2003 style tabs.
COLORSET_TAB_EXCEL | m_csExcelSelected
Color set of selected (focused) Excel style tabs.
COLORSET_TAB_EXCEL | m_csExcelNormal
Color set of normal Excel style tabs.
- Protected Attributes inherited from CXTPTabPaintManagerColorSet
CXTPTabPaintManager * | m_pPaintManager
Self paint manager pointer.

Detailed Description

CXTPTabColorSetDefault implements a default tab color set.

To use the default color set, SetColor is used to apply the xtpTabColorDefault XTPTabColorStyle.

See also
XTPTabColorStyle, XTPTabAppearanceStyle, SetAppearance, GetAppearance, GetAppearanceSet, SetColor, GetColor, GetColorSet, SetColorSet, SetAppearanceSet

Member Function Documentation

◆ FillNavigateButton()

void FillNavigateButton | ( | CDC * | pDC,
 |  | CXTPTabManagerNavigateButton * | pButton,
 |  | CRect & | rc )
 virtual

Fills a specified tab navigation button.

Parameters
pDC | Pointer to a valid device context.
pButton | Pointer to the tab navigation button to fill.
rc | Reference to the bounding rectangle of the tab navigation button.

This method is used to fill the tab navigation buttons in the header of the tab client and is overridden by XTPTabColorStyle and CXTPTabPaintManagerColorSet to perform actions such as painting the highlighted, pressed, and normal versions of tab navigation buttons.

See also
CXTPTabManager::GetNavigateButton, CXTPTabManagerNavigateButton

Implements CXTPTabPaintManagerColorSet.

Reimplemented in CXTPTabColorSetOffice2003, CXTPTabColorSetOffice2007, and CXTPTabColorSetVisualStudio2010.

◆ RefreshMetrics()

virtual void RefreshMetrics ( )
virtual

Refreshes the visual metrics of the tabs.

Override this method to change the colors of the color members.

All of the color members are refreshed when this method is called.

Reimplemented from CXTPTabPaintManagerColorSet.

Reimplemented in CColorSetVisualStudio2003, CColorSetVisualStudio2005, CColorSetWinNative, CXTPDockingPaneTabColorSetOfficePanel, CXTPDockingPaneTabColorSetVisualStudio2003, CXTPDockingPaneTabColorSetVisualStudio2005, CXTPTabColorSetOffice2003, CXTPTabColorSetOffice2007, CXTPTabColorSetOffice2007Access, CXTPTabColorSetVisualStudio2008, and CXTPTabColorSetVisualStudio2010.

The documentation for this class was generated from the following file:
  • XTPTabColorSetDefault.h


Toolkit Pro: CXTPTabColorSetNativeWindows10 Class Reference

Public Member Functions | List of all members
CXTPTabColorSetNativeWindows10 Class Reference

CXTPTabColorSetNativeWindows10 implements a Native Windows 10 tab color set. More...

Inheritance diagram for CXTPTabColorSetNativeWindows10:
[legend]

Public Member Functions

virtual void | RefreshMetrics ()
Refreshes the visual metrics of the tabs.
- Public Member Functions inherited from CXTPTabColorSetVisualStudio2012
virtual COLORREF | GetItemColor (CXTPTabManagerItem *pItem)
Retrieves the color of a specified tab.
virtual void | FillNavigateButton (CDC *pDC, CXTPTabManagerNavigateButton *pButton, CRect &rc)
Fills a specified tab navigation button.
virtual COLORREF | GetClientColor (CXTPTabManager *pTabManager)
Obtains client background color.
- Public Member Functions inherited from CXTPTabPaintManagerColorSet
CXTPTabPaintManagerColorSet ()
Constructs a CXTPTabPaintManagerColorSet object.
virtual | ~CXTPTabPaintManagerColorSet ()
Destroys a CXTPTabPaintManagerColorSet object, handles cleanup and deallocation.
virtual void | SetTextColor (CDC *pDC, CXTPTabManagerItem *pItem)
Sets the text color for the tab.
virtual void | FillHeader (CDC *pDC, CRect rc, CXTPTabManager *pTabManager)
Fills the header of the tab client of a specified tab manager.
virtual COLORREF | FillClient (CDC *pDC, CRect rc, CXTPTabManager *pTabManager)
Fills the tab client area of a specified tab manager.
virtual void | FillStateButton (CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem)
Fills a specified tab button when XTPTabAppearanceStyle is xtpTabAppearanceStateButtons.
virtual COLORREF | FillPropertyButton (CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem)
Fills a specified tab button.
virtual void | SelectClipRgn (CDC *pDC, CRect rcClient, CXTPTabManager *pTabManager)
Sets a clipping region for the specified tab client area.
void | GradientFill (CDC *pDC, CRect rc, COLORREF clrLight, COLORREF clrDark, XTPTabPosition position)
Performs a gradient fill of a rectangle with a color that smoothly fades from top to bottom.
virtual BOOL | IsAppThemed () const
Determines if Windows XP themes are enabled and if a Windows XP theme is currently used.

Additional Inherited Members

- Public Attributes inherited from CXTPTabPaintManagerColorSet
CXTPPaintManagerColorGradient | m_clrHeaderFace
Color set of the tab header background.
CXTPPaintManagerColorGradient m_clrAutoHideFace
Color set of the auto-hide panel background.
CXTPPaintManagerColor | m_clrFrameBorder
Color of the border placed around the tab buttons and the tab client.
CXTPPaintManagerColor m_clrControlFace
Color of the control foreground.
CXTPPaintManagerColor | m_clrPaneFace
Color of the control pane foreground.
CXTPPaintManagerColor | m_clrBorderHighlight
Color of the highlight border.
CXTPPaintManagerColor | m_clrTabClientBack
Background color for the tab client area.
CXTPPaintManagerColor | m_clrTabClientBorder
Border color for the tab client area.
CXTPPaintManagerColor m_clrButtonNormal
Color of normal tabs.
CXTPPaintManagerColor | m_clrButtonPressed
Tab pressed button color.
CXTPPaintManagerColor | m_clrButtonHighlighted
Tab button color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonHighlightedClose
Tab close button color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonBorderHighlighted
Tab button border color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonBorderTabContext1
Tab button border color with tab context.
CXTPPaintManagerColor | m_clrButtonBorderTabContext2
Tab button border color with tab context.
CXTPPaintManagerColor | m_clrButtonBorderKeyTips
Tab button border color when ALT button is pressed.
CXTPPaintManagerColor | m_clrButtonSelected
Color of the currently selected tab.
CXTPPaintManagerColor | m_clrButtonSelectedPressed
Color of the currently selected tab when pressed.
CXTPPaintManagerColor | m_clrButtonSelectedHighlighted
Color of the currently selected tab when highlighted.
CXTPPaintManagerColor | m_clrButtonBorder
Tab button border (edge) color.
CXTPPaintManagerColor | m_clrButtonBorderHot
Tab button highlight or pressed border (edge) color.
CXTPPaintManagerColor m_clrTextNormal
Color of text in a normal tab.
CXTPPaintManagerColor m_clrTextPressed
Color of text in a "pressed" tab button.
CXTPPaintManagerColor | m_clrTextHighlight
Color of text on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrTextHighlightClose
Color of close button text on mouse over when hot tracking is enabled.
CXTPPaintManagerColor m_clrTextSelected
Color of text in a "selected" tab button.
CXTPPaintManagerColor m_clrTextSelectedPressed
Color of text in a "pressed" tab button.
CXTPPaintManagerColor | m_clrTextSelectedHighlighted
Color of text for tabs in all non-active groups of tabs in MDITabClient.
CXTPPaintManagerColor m_clrTextDisabled
Color of text when a tab is disabled.
CXTPPaintManagerColor | m_clrActiveFilesGlyph
Color of navigation button.
CXTPPaintManagerColor | m_clrActiveFilesGlyphHighlighted
Color of highlighted navigation button.
CXTPPaintManagerColor | m_clrActiveFilesGlyphPressed
Color of selected navigation button.
CXTPPaintManagerColor | m_clrActiveFilesBack
Color of highlighted navigation button background.
CXTPPaintManagerColor | m_clrActiveFilesBackHighlighted
Color of navigation button background.
CXTPPaintManagerColor | m_clrActiveFilesBackPressed
Color of selected navigation button background.
COLORSET_TAB_STATEBUTTON | m_csStateButton
Color set of state button style tabs.
COLORSET_TAB_PROPERTYPAGE | m_csPropertyPage
Color set of visual studio style tabs.
COLORSET_TAB_PROPERTYPAGE2003 | m_csPropertyPage2003
Color set of Office 2003 style tabs.
COLORSET_TAB_EXCEL | m_csExcelSelected
Color set of selected (focused) Excel style tabs.
COLORSET_TAB_EXCEL | m_csExcelNormal
Color set of normal Excel style tabs.
- Protected Attributes inherited from CXTPTabColorSetVisualStudio2012
- Protected Attributes inherited from CXTPTabPaintManagerColorSet
CXTPTabPaintManager * | m_pPaintManager
Self paint manager pointer.

Detailed Description

CXTPTabColorSetNativeWindows10 implements a Native Windows 10 tab color set.

Member Function Documentation

◆ RefreshMetrics()

virtual void RefreshMetrics ( )
virtual

Refreshes the visual metrics of the tabs.

Override this method to change the colors of the color members.

All of the color members are refreshed when this method is called.

Reimplemented from CXTPTabColorSetVisualStudio2012.

The documentation for this class was generated from the following file:
  • XTPTabColorSetNativeWindows10.h


Toolkit Pro: CXTPTabColorSetNativeWindows11 Class Reference

Public Member Functions | List of all members
CXTPTabColorSetNativeWindows11 Class Reference

CXTPTabColorSetNativeWindows11 implements a Native Windows 10 tab color set. More...

Inheritance diagram for CXTPTabColorSetNativeWindows11:
[legend]

Public Member Functions

virtual void | RefreshMetrics ()
Refreshes the visual metrics of the tabs.
- Public Member Functions inherited from CXTPTabColorSetVisualStudio2012
virtual COLORREF | GetItemColor (CXTPTabManagerItem *pItem)
Retrieves the color of a specified tab.
virtual void | FillNavigateButton (CDC *pDC, CXTPTabManagerNavigateButton *pButton, CRect &rc)
Fills a specified tab navigation button.
virtual COLORREF | GetClientColor (CXTPTabManager *pTabManager)
Obtains client background color.
- Public Member Functions inherited from CXTPTabPaintManagerColorSet
CXTPTabPaintManagerColorSet ()
Constructs a CXTPTabPaintManagerColorSet object.
virtual | ~CXTPTabPaintManagerColorSet ()
Destroys a CXTPTabPaintManagerColorSet object, handles cleanup and deallocation.
virtual void | SetTextColor (CDC *pDC, CXTPTabManagerItem *pItem)
Sets the text color for the tab.
virtual void | FillHeader (CDC *pDC, CRect rc, CXTPTabManager *pTabManager)
Fills the header of the tab client of a specified tab manager.
virtual COLORREF | FillClient (CDC *pDC, CRect rc, CXTPTabManager *pTabManager)
Fills the tab client area of a specified tab manager.
virtual void | FillStateButton (CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem)
Fills a specified tab button when XTPTabAppearanceStyle is xtpTabAppearanceStateButtons.
virtual COLORREF | FillPropertyButton (CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem)
Fills a specified tab button.
virtual void | SelectClipRgn (CDC *pDC, CRect rcClient, CXTPTabManager *pTabManager)
Sets a clipping region for the specified tab client area.
void | GradientFill (CDC *pDC, CRect rc, COLORREF clrLight, COLORREF clrDark, XTPTabPosition position)
Performs a gradient fill of a rectangle with a color that smoothly fades from top to bottom.
virtual BOOL | IsAppThemed () const
Determines if Windows XP themes are enabled and if a Windows XP theme is currently used.

Additional Inherited Members

- Public Attributes inherited from CXTPTabPaintManagerColorSet
CXTPPaintManagerColorGradient | m_clrHeaderFace
Color set of the tab header background.
CXTPPaintManagerColorGradient m_clrAutoHideFace
Color set of the auto-hide panel background.
CXTPPaintManagerColor | m_clrFrameBorder
Color of the border placed around the tab buttons and the tab client.
CXTPPaintManagerColor m_clrControlFace
Color of the control foreground.
CXTPPaintManagerColor | m_clrPaneFace
Color of the control pane foreground.
CXTPPaintManagerColor | m_clrBorderHighlight
Color of the highlight border.
CXTPPaintManagerColor | m_clrTabClientBack
Background color for the tab client area.
CXTPPaintManagerColor | m_clrTabClientBorder
Border color for the tab client area.
CXTPPaintManagerColor m_clrButtonNormal
Color of normal tabs.
CXTPPaintManagerColor | m_clrButtonPressed
Tab pressed button color.
CXTPPaintManagerColor | m_clrButtonHighlighted
Tab button color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonHighlightedClose
Tab close button color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonBorderHighlighted
Tab button border color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonBorderTabContext1
Tab button border color with tab context.
CXTPPaintManagerColor | m_clrButtonBorderTabContext2
Tab button border color with tab context.
CXTPPaintManagerColor | m_clrButtonBorderKeyTips
Tab button border color when ALT button is pressed.
CXTPPaintManagerColor | m_clrButtonSelected
Color of the currently selected tab.
CXTPPaintManagerColor | m_clrButtonSelectedPressed
Color of the currently selected tab when pressed.
CXTPPaintManagerColor | m_clrButtonSelectedHighlighted
Color of the currently selected tab when highlighted.
CXTPPaintManagerColor | m_clrButtonBorder
Tab button border (edge) color.
CXTPPaintManagerColor | m_clrButtonBorderHot
Tab button highlight or pressed border (edge) color.
CXTPPaintManagerColor m_clrTextNormal
Color of text in a normal tab.
CXTPPaintManagerColor m_clrTextPressed
Color of text in a "pressed" tab button.
CXTPPaintManagerColor | m_clrTextHighlight
Color of text on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrTextHighlightClose
Color of close button text on mouse over when hot tracking is enabled.
CXTPPaintManagerColor m_clrTextSelected
Color of text in a "selected" tab button.
CXTPPaintManagerColor m_clrTextSelectedPressed
Color of text in a "pressed" tab button.
CXTPPaintManagerColor | m_clrTextSelectedHighlighted
Color of text for tabs in all non-active groups of tabs in MDITabClient.
CXTPPaintManagerColor m_clrTextDisabled
Color of text when a tab is disabled.
CXTPPaintManagerColor | m_clrActiveFilesGlyph
Color of navigation button.
CXTPPaintManagerColor | m_clrActiveFilesGlyphHighlighted
Color of highlighted navigation button.
CXTPPaintManagerColor | m_clrActiveFilesGlyphPressed
Color of selected navigation button.
CXTPPaintManagerColor | m_clrActiveFilesBack
Color of highlighted navigation button background.
CXTPPaintManagerColor | m_clrActiveFilesBackHighlighted
Color of navigation button background.
CXTPPaintManagerColor | m_clrActiveFilesBackPressed
Color of selected navigation button background.
COLORSET_TAB_STATEBUTTON | m_csStateButton
Color set of state button style tabs.
COLORSET_TAB_PROPERTYPAGE | m_csPropertyPage
Color set of visual studio style tabs.
COLORSET_TAB_PROPERTYPAGE2003 | m_csPropertyPage2003
Color set of Office 2003 style tabs.
COLORSET_TAB_EXCEL | m_csExcelSelected
Color set of selected (focused) Excel style tabs.
COLORSET_TAB_EXCEL | m_csExcelNormal
Color set of normal Excel style tabs.
- Protected Attributes inherited from CXTPTabColorSetVisualStudio2012
- Protected Attributes inherited from CXTPTabPaintManagerColorSet
CXTPTabPaintManager * | m_pPaintManager
Self paint manager pointer.

Detailed Description

CXTPTabColorSetNativeWindows11 implements a Native Windows 10 tab color set.

Member Function Documentation

◆ RefreshMetrics()

virtual void RefreshMetrics ( )
virtual

Refreshes the visual metrics of the tabs.

Override this method to change the colors of the color members.

All of the color members are refreshed when this method is called.

Reimplemented from CXTPTabColorSetVisualStudio2012.

The documentation for this class was generated from the following file:
  • XTPTabColorSetNativeWindows11.h


Toolkit Pro: CXTPTabColorSetOffice2003 Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPTabColorSetOffice2003 Class Reference

CXTPTabColorSetOffice2003 implements an Office 2003 tab color set. More...

Inheritance diagram for CXTPTabColorSetOffice2003:
[legend]

Public Member Functions

virtual void | RefreshMetrics ()
Refreshes the visual metrics of the tabs.
virtual COLORREF | FillPropertyButton (CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem)
Fills a specified tab button.
virtual void | FillNavigateButton (CDC *pDC, CXTPTabManagerNavigateButton *pButton, CRect &rc)
Fills a specified tab navigation button.
void | Rectangle (CDC *pDC, CRect rc, int nPen, int nBrush)
Draws a rectangle with a border.
- Public Member Functions inherited from CXTPTabColorSetDefault
- Public Member Functions inherited from CXTPTabPaintManagerColorSet
CXTPTabPaintManagerColorSet ()
Constructs a CXTPTabPaintManagerColorSet object.
virtual | ~CXTPTabPaintManagerColorSet ()
Destroys a CXTPTabPaintManagerColorSet object, handles cleanup and deallocation.
virtual void | SetTextColor (CDC *pDC, CXTPTabManagerItem *pItem)
Sets the text color for the tab.
virtual void | FillHeader (CDC *pDC, CRect rc, CXTPTabManager *pTabManager)
Fills the header of the tab client of a specified tab manager.
virtual COLORREF | FillClient (CDC *pDC, CRect rc, CXTPTabManager *pTabManager)
Fills the tab client area of a specified tab manager.
virtual COLORREF | GetClientColor (CXTPTabManager *pTabManager)
Obtains client background color.
virtual void | FillStateButton (CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem)
Fills a specified tab button when XTPTabAppearanceStyle is xtpTabAppearanceStateButtons.
virtual void | SelectClipRgn (CDC *pDC, CRect rcClient, CXTPTabManager *pTabManager)
Sets a clipping region for the specified tab client area.
virtual COLORREF | GetItemColor (CXTPTabManagerItem *pItem)
Retrieves the color of a specified tab.
void | GradientFill (CDC *pDC, CRect rc, COLORREF clrLight, COLORREF clrDark, XTPTabPosition position)
Performs a gradient fill of a rectangle with a color that smoothly fades from top to bottom.
virtual BOOL | IsAppThemed () const
Determines if Windows XP themes are enabled and if a Windows XP theme is currently used.

Protected Attributes

CXTPPaintManagerColor | m_clrNavigateButtonBorder
Border color of tab navigation buttons on mouse over.
BOOL | m_bLunaTheme
TRUE if the current system theme is xtpSystemThemeSilver, xtpSystemThemeOlive or xtpSystemThemeOlive, otherwise FALSE.
- Protected Attributes inherited from CXTPTabPaintManagerColorSet
CXTPTabPaintManager * | m_pPaintManager
Self paint manager pointer.

Additional Inherited Members

- Public Attributes inherited from CXTPTabPaintManagerColorSet
CXTPPaintManagerColorGradient | m_clrHeaderFace
Color set of the tab header background.
CXTPPaintManagerColorGradient m_clrAutoHideFace
Color set of the auto-hide panel background.
CXTPPaintManagerColor | m_clrFrameBorder
Color of the border placed around the tab buttons and the tab client.
CXTPPaintManagerColor m_clrControlFace
Color of the control foreground.
CXTPPaintManagerColor | m_clrPaneFace
Color of the control pane foreground.
CXTPPaintManagerColor | m_clrBorderHighlight
Color of the highlight border.
CXTPPaintManagerColor | m_clrTabClientBack
Background color for the tab client area.
CXTPPaintManagerColor | m_clrTabClientBorder
Border color for the tab client area.
CXTPPaintManagerColor m_clrButtonNormal
Color of normal tabs.
CXTPPaintManagerColor | m_clrButtonPressed
Tab pressed button color.
CXTPPaintManagerColor | m_clrButtonHighlighted
Tab button color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonHighlightedClose
Tab close button color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonBorderHighlighted
Tab button border color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonBorderTabContext1
Tab button border color with tab context.
CXTPPaintManagerColor | m_clrButtonBorderTabContext2
Tab button border color with tab context.
CXTPPaintManagerColor | m_clrButtonBorderKeyTips
Tab button border color when ALT button is pressed.
CXTPPaintManagerColor | m_clrButtonSelected
Color of the currently selected tab.
CXTPPaintManagerColor | m_clrButtonSelectedPressed
Color of the currently selected tab when pressed.
CXTPPaintManagerColor | m_clrButtonSelectedHighlighted
Color of the currently selected tab when highlighted.
CXTPPaintManagerColor | m_clrButtonBorder
Tab button border (edge) color.
CXTPPaintManagerColor | m_clrButtonBorderHot
Tab button highlight or pressed border (edge) color.
CXTPPaintManagerColor m_clrTextNormal
Color of text in a normal tab.
CXTPPaintManagerColor m_clrTextPressed
Color of text in a "pressed" tab button.
CXTPPaintManagerColor | m_clrTextHighlight
Color of text on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrTextHighlightClose
Color of close button text on mouse over when hot tracking is enabled.
CXTPPaintManagerColor m_clrTextSelected
Color of text in a "selected" tab button.
CXTPPaintManagerColor m_clrTextSelectedPressed
Color of text in a "pressed" tab button.
CXTPPaintManagerColor | m_clrTextSelectedHighlighted
Color of text for tabs in all non-active groups of tabs in MDITabClient.
CXTPPaintManagerColor m_clrTextDisabled
Color of text when a tab is disabled.
CXTPPaintManagerColor | m_clrActiveFilesGlyph
Color of navigation button.
CXTPPaintManagerColor | m_clrActiveFilesGlyphHighlighted
Color of highlighted navigation button.
CXTPPaintManagerColor | m_clrActiveFilesGlyphPressed
Color of selected navigation button.
CXTPPaintManagerColor | m_clrActiveFilesBack
Color of highlighted navigation button background.
CXTPPaintManagerColor | m_clrActiveFilesBackHighlighted
Color of navigation button background.
CXTPPaintManagerColor | m_clrActiveFilesBackPressed
Color of selected navigation button background.
COLORSET_TAB_STATEBUTTON | m_csStateButton
Color set of state button style tabs.
COLORSET_TAB_PROPERTYPAGE | m_csPropertyPage
Color set of visual studio style tabs.
COLORSET_TAB_PROPERTYPAGE2003 | m_csPropertyPage2003
Color set of Office 2003 style tabs.
COLORSET_TAB_EXCEL | m_csExcelSelected
Color set of selected (focused) Excel style tabs.
COLORSET_TAB_EXCEL | m_csExcelNormal
Color set of normal Excel style tabs.

Detailed Description

CXTPTabColorSetOffice2003 implements an Office 2003 tab color set.

To use the Office 2003 color set, SetColor is used to apply the xtpTabColorOffice2003 XTPTabColorStyle.

See also
XTPTabColorStyle, XTPTabAppearanceStyle, SetAppearance, GetAppearance, GetAppearanceSet, SetColor, GetColor, GetColorSet, SetColorSet, SetAppearanceSet

Member Function Documentation

◆ FillNavigateButton()

virtual void FillNavigateButton | ( | CDC * | pDC,
 |  | CXTPTabManagerNavigateButton * | pButton,
 |  | CRect & | rc )
 virtual

Fills a specified tab navigation button.

Parameters
pDC | Pointer to a valid device context.
pButton | Pointer to the tab navigation button to fill.
rc | Reference to the bounding rectangle of the tab navigation button.

This method is used to fill the tab navigation buttons in the header of the tab client and is overridden by XTPTabColorStyle and CXTPTabPaintManagerColorSet to perform actions such as painting the highlighted, pressed, and normal versions of tab navigation buttons.

See also
CXTPTabManager::GetNavigateButton, CXTPTabManagerNavigateButton, Rectangle

Reimplemented from CXTPTabColorSetDefault.

Reimplemented in CXTPTabColorSetOffice2007, and CXTPTabColorSetVisualStudio2010.

◆ FillPropertyButton()

virtual COLORREF FillPropertyButton | ( | CDC * | pDC,
 |  | CRect | rcItem,
 |  | CXTPTabManagerItem * | pItem )
 virtual

Fills a specified tab button.

Parameters
pDC | Pointer to a valid device context.
rcItem | Bounding rectangle of the tab button to fill.
pItem | Pointer to the tab button to fill.
Returns
The color of the specified tab button.

This method is used to fill all tab buttons except when XTPTabAppearanceStyle is set to xtpTabAppearanceStateButtons. xtpTabAppearanceStateButtons requires the FillStateButton member.

Tab buttons use CXTPTabPaintManagerColorSet::GradientFill to fill themselves. The gradient will use the color of the tab item blended with RGB(255, 255, 255) to produce a "light color". The gradient will start with the "light color" and fill to the normal color of the tab item.

See also
FillStateButton

Reimplemented from CXTPTabPaintManagerColorSet.

Reimplemented in CColorSetVisualStudio2005, CXTPDockingPaneTabColorSetVisualStudio2003, CXTPTabColorSetVisualStudio2008, and CXTPTabColorSetVisualStudio2010.

◆ Rectangle()

void Rectangle | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | int | nPen,
 |  | int | nBrush )

Draws a rectangle with a border.

Parameters
pDC | Pointer to a valid device context.
rc | Specifies the rectangle in logical units.
nPen | Specifies the color used to paint the rectangle.
nBrush | Specifies the color used to fill the rectangle.

This method is called by FillNavigateButton to fill the tab navigation buttons when luna colors are disabled.

See also
FillNavigateButton

◆ RefreshMetrics()

virtual void RefreshMetrics ( )
virtual

Refreshes the visual metrics of the tabs.

Override this method to change the colors of the color members.

All of the color members are refreshed when this method is called. A different color set will be used for each luna color if used.

Reimplemented from CXTPTabColorSetDefault.

Reimplemented in CColorSetVisualStudio2005, CXTPDockingPaneTabColorSetOfficePanel, CXTPDockingPaneTabColorSetVisualStudio2003, CXTPDockingPaneTabColorSetVisualStudio2005, CXTPTabColorSetOffice2007, CXTPTabColorSetOffice2007Access, CXTPTabColorSetVisualStudio2008, and CXTPTabColorSetVisualStudio2010.

The documentation for this class was generated from the following file:
  • XTPTabColorSetOffice2003.h


Toolkit Pro: CXTPTabColorSetOffice2007 Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPTabColorSetOffice2007 Class Reference

CXTPTabColorSetOffice2007 implements an Office 2007 tab color set. More...

Inheritance diagram for CXTPTabColorSetOffice2007:
[legend]

Public Member Functions

virtual void | RefreshMetrics ()
Refreshes the visual metrics of the tabs.
void | FillNavigateButton (CDC *pDC, CXTPTabManagerNavigateButton *pButton, CRect &rc)
Fills a specified tab navigation button.
- Public Member Functions inherited from CXTPTabColorSetOffice2003
virtual COLORREF | FillPropertyButton (CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem)
Fills a specified tab button.
void | Rectangle (CDC *pDC, CRect rc, int nPen, int nBrush)
Draws a rectangle with a border.
- Public Member Functions inherited from CXTPTabColorSetDefault
- Public Member Functions inherited from CXTPTabPaintManagerColorSet
CXTPTabPaintManagerColorSet ()
Constructs a CXTPTabPaintManagerColorSet object.
virtual | ~CXTPTabPaintManagerColorSet ()
Destroys a CXTPTabPaintManagerColorSet object, handles cleanup and deallocation.
virtual void | SetTextColor (CDC *pDC, CXTPTabManagerItem *pItem)
Sets the text color for the tab.
virtual void | FillHeader (CDC *pDC, CRect rc, CXTPTabManager *pTabManager)
Fills the header of the tab client of a specified tab manager.
virtual COLORREF | FillClient (CDC *pDC, CRect rc, CXTPTabManager *pTabManager)
Fills the tab client area of a specified tab manager.
virtual COLORREF | GetClientColor (CXTPTabManager *pTabManager)
Obtains client background color.
virtual void | FillStateButton (CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem)
Fills a specified tab button when XTPTabAppearanceStyle is xtpTabAppearanceStateButtons.
virtual void | SelectClipRgn (CDC *pDC, CRect rcClient, CXTPTabManager *pTabManager)
Sets a clipping region for the specified tab client area.
virtual COLORREF | GetItemColor (CXTPTabManagerItem *pItem)
Retrieves the color of a specified tab.
void | GradientFill (CDC *pDC, CRect rc, COLORREF clrLight, COLORREF clrDark, XTPTabPosition position)
Performs a gradient fill of a rectangle with a color that smoothly fades from top to bottom.
virtual BOOL | IsAppThemed () const
Determines if Windows XP themes are enabled and if a Windows XP theme is currently used.

Protected Attributes

CXTPPaintManagerColor | m_clrButtonText
Text color.
- Protected Attributes inherited from CXTPTabColorSetOffice2003
CXTPPaintManagerColor | m_clrNavigateButtonBorder
Border color of tab navigation buttons on mouse over.
BOOL | m_bLunaTheme
TRUE if the current system theme is xtpSystemThemeSilver, xtpSystemThemeOlive or xtpSystemThemeOlive, otherwise FALSE.
- Protected Attributes inherited from CXTPTabPaintManagerColorSet
CXTPTabPaintManager * | m_pPaintManager
Self paint manager pointer.

Additional Inherited Members

- Public Attributes inherited from CXTPTabPaintManagerColorSet
CXTPPaintManagerColorGradient | m_clrHeaderFace
Color set of the tab header background.
CXTPPaintManagerColorGradient m_clrAutoHideFace
Color set of the auto-hide panel background.
CXTPPaintManagerColor | m_clrFrameBorder
Color of the border placed around the tab buttons and the tab client.
CXTPPaintManagerColor m_clrControlFace
Color of the control foreground.
CXTPPaintManagerColor | m_clrPaneFace
Color of the control pane foreground.
CXTPPaintManagerColor | m_clrBorderHighlight
Color of the highlight border.
CXTPPaintManagerColor | m_clrTabClientBack
Background color for the tab client area.
CXTPPaintManagerColor | m_clrTabClientBorder
Border color for the tab client area.
CXTPPaintManagerColor m_clrButtonNormal
Color of normal tabs.
CXTPPaintManagerColor | m_clrButtonPressed
Tab pressed button color.
CXTPPaintManagerColor | m_clrButtonHighlighted
Tab button color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonHighlightedClose
Tab close button color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonBorderHighlighted
Tab button border color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonBorderTabContext1
Tab button border color with tab context.
CXTPPaintManagerColor | m_clrButtonBorderTabContext2
Tab button border color with tab context.
CXTPPaintManagerColor | m_clrButtonBorderKeyTips
Tab button border color when ALT button is pressed.
CXTPPaintManagerColor | m_clrButtonSelected
Color of the currently selected tab.
CXTPPaintManagerColor | m_clrButtonSelectedPressed
Color of the currently selected tab when pressed.
CXTPPaintManagerColor | m_clrButtonSelectedHighlighted
Color of the currently selected tab when highlighted.
CXTPPaintManagerColor | m_clrButtonBorder
Tab button border (edge) color.
CXTPPaintManagerColor | m_clrButtonBorderHot
Tab button highlight or pressed border (edge) color.
CXTPPaintManagerColor m_clrTextNormal
Color of text in a normal tab.
CXTPPaintManagerColor m_clrTextPressed
Color of text in a "pressed" tab button.
CXTPPaintManagerColor | m_clrTextHighlight
Color of text on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrTextHighlightClose
Color of close button text on mouse over when hot tracking is enabled.
CXTPPaintManagerColor m_clrTextSelected
Color of text in a "selected" tab button.
CXTPPaintManagerColor m_clrTextSelectedPressed
Color of text in a "pressed" tab button.
CXTPPaintManagerColor | m_clrTextSelectedHighlighted
Color of text for tabs in all non-active groups of tabs in MDITabClient.
CXTPPaintManagerColor m_clrTextDisabled
Color of text when a tab is disabled.
CXTPPaintManagerColor | m_clrActiveFilesGlyph
Color of navigation button.
CXTPPaintManagerColor | m_clrActiveFilesGlyphHighlighted
Color of highlighted navigation button.
CXTPPaintManagerColor | m_clrActiveFilesGlyphPressed
Color of selected navigation button.
CXTPPaintManagerColor | m_clrActiveFilesBack
Color of highlighted navigation button background.
CXTPPaintManagerColor | m_clrActiveFilesBackHighlighted
Color of navigation button background.
CXTPPaintManagerColor | m_clrActiveFilesBackPressed
Color of selected navigation button background.
COLORSET_TAB_STATEBUTTON | m_csStateButton
Color set of state button style tabs.
COLORSET_TAB_PROPERTYPAGE | m_csPropertyPage
Color set of visual studio style tabs.
COLORSET_TAB_PROPERTYPAGE2003 | m_csPropertyPage2003
Color set of Office 2003 style tabs.
COLORSET_TAB_EXCEL | m_csExcelSelected
Color set of selected (focused) Excel style tabs.
COLORSET_TAB_EXCEL | m_csExcelNormal
Color set of normal Excel style tabs.

Detailed Description

CXTPTabColorSetOffice2007 implements an Office 2007 tab color set.

Member Function Documentation

◆ FillNavigateButton()

void FillNavigateButton | ( | CDC * | pDC,
 |  | CXTPTabManagerNavigateButton * | pButton,
 |  | CRect & | rc )
 virtual

Fills a specified tab navigation button.

Parameters
pDC | Pointer to a valid device context.
pButton | Pointer to the tab navigation button to fill.
rc | Reference to the bounding rectangle of the tab navigation button.

This method is used to fill the tab navigation buttons in the header of the tab client and is overridden by XTPTabColorStyle and CXTPTabPaintManagerColorSet to perform actions such as painting the highlighted, pressed, and normal versions of tab navigation buttons.

If IsAppThemed is FALSE, then CXTPTabColorSetDefault::FillNavigationButton is used.

See also
CXTPTabManager::GetNavigateButton, CXTPTabManagerNavigateButton

Reimplemented from CXTPTabColorSetOffice2003.

◆ RefreshMetrics()

virtual void RefreshMetrics ( )
virtual

Refreshes the visual metrics of the tabs.

Override this method to change the colors of the color members.

All of the color members are refreshed when this method is called.

Reimplemented from CXTPTabColorSetOffice2003.

Reimplemented in CXTPTabColorSetOffice2007Access.

The documentation for this class was generated from the following file:
  • XTPTabColorSetOffice2007.h


Toolkit Pro: CXTPTabColorSetOffice2007Access Class Reference

Public Member Functions | List of all members
CXTPTabColorSetOffice2007Access Class Reference

CXTPTabColorSetOffice2007Access implements an Office 2007 Access tab color set. More...

Inheritance diagram for CXTPTabColorSetOffice2007Access:
[legend]

Public Member Functions

virtual void | RefreshMetrics ()
Refreshes the visual metrics of the tabs.
- Public Member Functions inherited from CXTPTabColorSetOffice2007
void | FillNavigateButton (CDC *pDC, CXTPTabManagerNavigateButton *pButton, CRect &rc)
Fills a specified tab navigation button.
- Public Member Functions inherited from CXTPTabColorSetOffice2003
virtual COLORREF | FillPropertyButton (CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem)
Fills a specified tab button.
void | Rectangle (CDC *pDC, CRect rc, int nPen, int nBrush)
Draws a rectangle with a border.
- Public Member Functions inherited from CXTPTabColorSetDefault
- Public Member Functions inherited from CXTPTabPaintManagerColorSet
CXTPTabPaintManagerColorSet ()
Constructs a CXTPTabPaintManagerColorSet object.
virtual | ~CXTPTabPaintManagerColorSet ()
Destroys a CXTPTabPaintManagerColorSet object, handles cleanup and deallocation.
virtual void | SetTextColor (CDC *pDC, CXTPTabManagerItem *pItem)
Sets the text color for the tab.
virtual void | FillHeader (CDC *pDC, CRect rc, CXTPTabManager *pTabManager)
Fills the header of the tab client of a specified tab manager.
virtual COLORREF | FillClient (CDC *pDC, CRect rc, CXTPTabManager *pTabManager)
Fills the tab client area of a specified tab manager.
virtual COLORREF | GetClientColor (CXTPTabManager *pTabManager)
Obtains client background color.
virtual void | FillStateButton (CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem)
Fills a specified tab button when XTPTabAppearanceStyle is xtpTabAppearanceStateButtons.
virtual void | SelectClipRgn (CDC *pDC, CRect rcClient, CXTPTabManager *pTabManager)
Sets a clipping region for the specified tab client area.
virtual COLORREF | GetItemColor (CXTPTabManagerItem *pItem)
Retrieves the color of a specified tab.
void | GradientFill (CDC *pDC, CRect rc, COLORREF clrLight, COLORREF clrDark, XTPTabPosition position)
Performs a gradient fill of a rectangle with a color that smoothly fades from top to bottom.
virtual BOOL | IsAppThemed () const
Determines if Windows XP themes are enabled and if a Windows XP theme is currently used.

Additional Inherited Members

- Public Attributes inherited from CXTPTabPaintManagerColorSet
CXTPPaintManagerColorGradient | m_clrHeaderFace
Color set of the tab header background.
CXTPPaintManagerColorGradient m_clrAutoHideFace
Color set of the auto-hide panel background.
CXTPPaintManagerColor | m_clrFrameBorder
Color of the border placed around the tab buttons and the tab client.
CXTPPaintManagerColor m_clrControlFace
Color of the control foreground.
CXTPPaintManagerColor | m_clrPaneFace
Color of the control pane foreground.
CXTPPaintManagerColor | m_clrBorderHighlight
Color of the highlight border.
CXTPPaintManagerColor | m_clrTabClientBack
Background color for the tab client area.
CXTPPaintManagerColor | m_clrTabClientBorder
Border color for the tab client area.
CXTPPaintManagerColor m_clrButtonNormal
Color of normal tabs.
CXTPPaintManagerColor | m_clrButtonPressed
Tab pressed button color.
CXTPPaintManagerColor | m_clrButtonHighlighted
Tab button color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonHighlightedClose
Tab close button color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonBorderHighlighted
Tab button border color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonBorderTabContext1
Tab button border color with tab context.
CXTPPaintManagerColor | m_clrButtonBorderTabContext2
Tab button border color with tab context.
CXTPPaintManagerColor | m_clrButtonBorderKeyTips
Tab button border color when ALT button is pressed.
CXTPPaintManagerColor | m_clrButtonSelected
Color of the currently selected tab.
CXTPPaintManagerColor | m_clrButtonSelectedPressed
Color of the currently selected tab when pressed.
CXTPPaintManagerColor | m_clrButtonSelectedHighlighted
Color of the currently selected tab when highlighted.
CXTPPaintManagerColor | m_clrButtonBorder
Tab button border (edge) color.
CXTPPaintManagerColor | m_clrButtonBorderHot
Tab button highlight or pressed border (edge) color.
CXTPPaintManagerColor m_clrTextNormal
Color of text in a normal tab.
CXTPPaintManagerColor m_clrTextPressed
Color of text in a "pressed" tab button.
CXTPPaintManagerColor | m_clrTextHighlight
Color of text on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrTextHighlightClose
Color of close button text on mouse over when hot tracking is enabled.
CXTPPaintManagerColor m_clrTextSelected
Color of text in a "selected" tab button.
CXTPPaintManagerColor m_clrTextSelectedPressed
Color of text in a "pressed" tab button.
CXTPPaintManagerColor | m_clrTextSelectedHighlighted
Color of text for tabs in all non-active groups of tabs in MDITabClient.
CXTPPaintManagerColor m_clrTextDisabled
Color of text when a tab is disabled.
CXTPPaintManagerColor | m_clrActiveFilesGlyph
Color of navigation button.
CXTPPaintManagerColor | m_clrActiveFilesGlyphHighlighted
Color of highlighted navigation button.
CXTPPaintManagerColor | m_clrActiveFilesGlyphPressed
Color of selected navigation button.
CXTPPaintManagerColor | m_clrActiveFilesBack
Color of highlighted navigation button background.
CXTPPaintManagerColor | m_clrActiveFilesBackHighlighted
Color of navigation button background.
CXTPPaintManagerColor | m_clrActiveFilesBackPressed
Color of selected navigation button background.
COLORSET_TAB_STATEBUTTON | m_csStateButton
Color set of state button style tabs.
COLORSET_TAB_PROPERTYPAGE | m_csPropertyPage
Color set of visual studio style tabs.
COLORSET_TAB_PROPERTYPAGE2003 | m_csPropertyPage2003
Color set of Office 2003 style tabs.
COLORSET_TAB_EXCEL | m_csExcelSelected
Color set of selected (focused) Excel style tabs.
COLORSET_TAB_EXCEL | m_csExcelNormal
Color set of normal Excel style tabs.
- Protected Attributes inherited from CXTPTabColorSetOffice2007
CXTPPaintManagerColor | m_clrButtonText
Text color.
- Protected Attributes inherited from CXTPTabColorSetOffice2003
CXTPPaintManagerColor | m_clrNavigateButtonBorder
Border color of tab navigation buttons on mouse over.
BOOL | m_bLunaTheme
TRUE if the current system theme is xtpSystemThemeSilver, xtpSystemThemeOlive or xtpSystemThemeOlive, otherwise FALSE.
- Protected Attributes inherited from CXTPTabPaintManagerColorSet
CXTPTabPaintManager * | m_pPaintManager
Self paint manager pointer.

Detailed Description

CXTPTabColorSetOffice2007Access implements an Office 2007 Access tab color set.

Member Function Documentation

◆ RefreshMetrics()

virtual void RefreshMetrics ( )
virtual

Refreshes the visual metrics of the tabs.

Override this method to change the colors of the color members.

All of the color members are refreshed when this method is called.

Reimplemented from CXTPTabColorSetOffice2007.

The documentation for this class was generated from the following file:
  • XTPTabColorSetOffice2007Access.h


Toolkit Pro: CXTPTabColorSetOffice2013 Class Reference

Public Member Functions | List of all members
CXTPTabColorSetOffice2013 Class Reference

CXTPTabColorSetOffice2013 implements an Office 2013 tab color set. More...

Inheritance diagram for CXTPTabColorSetOffice2013:
[legend]

Public Member Functions

virtual void | RefreshMetrics ()
Refreshes the visual metrics of the tabs.
virtual void | SetTextColor (CDC *pDC, CXTPTabManagerItem *pItem)
Sets the text color for a specified tab.
virtual COLORREF | GetItemColor (CXTPTabManagerItem *pItem)
Retrieves the color of a specified tab.
virtual COLORREF | GetClientColor (CXTPTabManager *pTabManager)
Obtains client background color.
virtual COLORREF | FillPropertyButton (CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem)
Fills a specified tab button.
virtual void | FillNavigateButton (CDC *pDC, CXTPTabManagerNavigateButton *pButton, CRect &rc)
Fills a specified tab navigation button.
- Public Member Functions inherited from CXTPTabColorSetVisualStudio2012
- Public Member Functions inherited from CXTPTabPaintManagerColorSet
CXTPTabPaintManagerColorSet ()
Constructs a CXTPTabPaintManagerColorSet object.
virtual | ~CXTPTabPaintManagerColorSet ()
Destroys a CXTPTabPaintManagerColorSet object, handles cleanup and deallocation.
virtual void | FillHeader (CDC *pDC, CRect rc, CXTPTabManager *pTabManager)
Fills the header of the tab client of a specified tab manager.
virtual COLORREF | FillClient (CDC *pDC, CRect rc, CXTPTabManager *pTabManager)
Fills the tab client area of a specified tab manager.
virtual void | FillStateButton (CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem)
Fills a specified tab button when XTPTabAppearanceStyle is xtpTabAppearanceStateButtons.
virtual void | SelectClipRgn (CDC *pDC, CRect rcClient, CXTPTabManager *pTabManager)
Sets a clipping region for the specified tab client area.
void | GradientFill (CDC *pDC, CRect rc, COLORREF clrLight, COLORREF clrDark, XTPTabPosition position)
Performs a gradient fill of a rectangle with a color that smoothly fades from top to bottom.
virtual BOOL | IsAppThemed () const
Determines if Windows XP themes are enabled and if a Windows XP theme is currently used.

Additional Inherited Members

- Public Attributes inherited from CXTPTabPaintManagerColorSet
CXTPPaintManagerColorGradient | m_clrHeaderFace
Color set of the tab header background.
CXTPPaintManagerColorGradient m_clrAutoHideFace
Color set of the auto-hide panel background.
CXTPPaintManagerColor | m_clrFrameBorder
Color of the border placed around the tab buttons and the tab client.
CXTPPaintManagerColor m_clrControlFace
Color of the control foreground.
CXTPPaintManagerColor | m_clrPaneFace
Color of the control pane foreground.
CXTPPaintManagerColor | m_clrBorderHighlight
Color of the highlight border.
CXTPPaintManagerColor | m_clrTabClientBack
Background color for the tab client area.
CXTPPaintManagerColor | m_clrTabClientBorder
Border color for the tab client area.
CXTPPaintManagerColor m_clrButtonNormal
Color of normal tabs.
CXTPPaintManagerColor | m_clrButtonPressed
Tab pressed button color.
CXTPPaintManagerColor | m_clrButtonHighlighted
Tab button color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonHighlightedClose
Tab close button color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonBorderHighlighted
Tab button border color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonBorderTabContext1
Tab button border color with tab context.
CXTPPaintManagerColor | m_clrButtonBorderTabContext2
Tab button border color with tab context.
CXTPPaintManagerColor | m_clrButtonBorderKeyTips
Tab button border color when ALT button is pressed.
CXTPPaintManagerColor | m_clrButtonSelected
Color of the currently selected tab.
CXTPPaintManagerColor | m_clrButtonSelectedPressed
Color of the currently selected tab when pressed.
CXTPPaintManagerColor | m_clrButtonSelectedHighlighted
Color of the currently selected tab when highlighted.
CXTPPaintManagerColor | m_clrButtonBorder
Tab button border (edge) color.
CXTPPaintManagerColor | m_clrButtonBorderHot
Tab button highlight or pressed border (edge) color.
CXTPPaintManagerColor m_clrTextNormal
Color of text in a normal tab.
CXTPPaintManagerColor m_clrTextPressed
Color of text in a "pressed" tab button.
CXTPPaintManagerColor | m_clrTextHighlight
Color of text on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrTextHighlightClose
Color of close button text on mouse over when hot tracking is enabled.
CXTPPaintManagerColor m_clrTextSelected
Color of text in a "selected" tab button.
CXTPPaintManagerColor m_clrTextSelectedPressed
Color of text in a "pressed" tab button.
CXTPPaintManagerColor | m_clrTextSelectedHighlighted
Color of text for tabs in all non-active groups of tabs in MDITabClient.
CXTPPaintManagerColor m_clrTextDisabled
Color of text when a tab is disabled.
CXTPPaintManagerColor | m_clrActiveFilesGlyph
Color of navigation button.
CXTPPaintManagerColor | m_clrActiveFilesGlyphHighlighted
Color of highlighted navigation button.
CXTPPaintManagerColor | m_clrActiveFilesGlyphPressed
Color of selected navigation button.
CXTPPaintManagerColor | m_clrActiveFilesBack
Color of highlighted navigation button background.
CXTPPaintManagerColor | m_clrActiveFilesBackHighlighted
Color of navigation button background.
CXTPPaintManagerColor | m_clrActiveFilesBackPressed
Color of selected navigation button background.
COLORSET_TAB_STATEBUTTON | m_csStateButton
Color set of state button style tabs.
COLORSET_TAB_PROPERTYPAGE | m_csPropertyPage
Color set of visual studio style tabs.
COLORSET_TAB_PROPERTYPAGE2003 | m_csPropertyPage2003
Color set of Office 2003 style tabs.
COLORSET_TAB_EXCEL | m_csExcelSelected
Color set of selected (focused) Excel style tabs.
COLORSET_TAB_EXCEL | m_csExcelNormal
Color set of normal Excel style tabs.
- Protected Attributes inherited from CXTPTabColorSetVisualStudio2012
- Protected Attributes inherited from CXTPTabPaintManagerColorSet
CXTPTabPaintManager * | m_pPaintManager
Self paint manager pointer.

Detailed Description

CXTPTabColorSetOffice2013 implements an Office 2013 tab color set.

Member Function Documentation

◆ FillNavigateButton()

virtual void FillNavigateButton | ( | CDC * | pDC,
 |  | CXTPTabManagerNavigateButton * | pButton,
 |  | CRect & | rc )
 virtual

Fills a specified tab navigation button.

Parameters
pDC | Pointer to a valid device context.
pButton | Pointer to the tab navigation button to fill.
rc | Reference to the bounding rectangle of the tab navigation button.

This method is used to fill the tab navigation buttons in the header of the tab client and is overridden by XTPTabColorStyle and CXTPTabPaintManagerColorSet to perform actions such as painting the highlighted, pressed, and normal versions of tab navigation buttons.

This method must be overridden.

See also
CXTPTabManager::GetNavigateButton, CXTPTabManagerNavigateButton

Reimplemented from CXTPTabColorSetVisualStudio2012.

◆ FillPropertyButton()

virtual COLORREF FillPropertyButton | ( | CDC * | pDC,
 |  | CRect | rcItem,
 |  | CXTPTabManagerItem * | pItem )
 virtual

Fills a specified tab button.

Parameters
pDC | Pointer to a valid device context.
rcItem | Bounding rectangle of the tab button to fill.
pItem | Pointer to the tab button to fill.
Returns
The color of the specified tab button.

This method is used to fill all tab buttons except when XTPTabAppearanceStyle is set to xtpTabAppearanceStateButtons. xtpTabAppearanceStateButtons requires the FillStateButton member.

See also
FillStateButton

Reimplemented from CXTPTabPaintManagerColorSet.

◆ GetClientColor()

virtual COLORREF GetClientColor ( CXTPTabManager * pTabManager )
virtual

Obtains client background color.

Parameters
pTabManager Pointer to the tab manager with the tab client area to fill.
Returns
Client area background color value.

Reimplemented from CXTPTabColorSetVisualStudio2012.

◆ GetItemColor()

virtual COLORREF GetItemColor ( CXTPTabManagerItem * pItem )
virtual

Retrieves the color of a specified tab.

Parameters
pItem Pointer to the tab with the color to retrieve.
Returns
The color of the tab.

This method is used within many of CXTPTabPaintManagerColorSet's "fill" methods.

See also
CXTPTabManager::GetItemColor, XTPTabColorStyle, SetColor, GetColorSet, SetColorSet

Reimplemented from CXTPTabColorSetVisualStudio2012.

◆ RefreshMetrics()

virtual void RefreshMetrics ( )
virtual

Refreshes the visual metrics of the tabs.

Override this method to change the colors of the color members.

All of the color members are refreshed when this method is called.

Reimplemented from CXTPTabColorSetVisualStudio2012.

◆ SetTextColor()

virtual void SetTextColor | ( | CDC * | pDC,
 |  | CXTPTabManagerItem * | pItem )
 virtual

Sets the text color for a specified tab.

Parameters
pDC | Pointer to a valid device context.
pItem | Pointer to the tab with the text color to be set.

Reimplemented from CXTPTabPaintManagerColorSet.

The documentation for this class was generated from the following file:
  • XTPTabColorSetOffice2013.h


Toolkit Pro: CXTPTabColorSetVisualStudio2008 Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPTabColorSetVisualStudio2008 Class Reference

CXTPTabColorSetVisualStudio2008 implements a Visual Studio 2008 tab color set. More...

Inheritance diagram for CXTPTabColorSetVisualStudio2008:
[legend]

Public Member Functions

CXTPTabColorSetVisualStudio2008 ()
Constructs a CXTPTabColorSetVisualStudio2008 object.
void | RefreshMetrics ()
Refreshes the visual metrics of the tabs.
COLORREF | FillPropertyButton (CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem)
Fills a specified tab button.
- Public Member Functions inherited from CXTPTabColorSetOffice2003
virtual void | FillNavigateButton (CDC *pDC, CXTPTabManagerNavigateButton *pButton, CRect &rc)
Fills a specified tab navigation button.
void | Rectangle (CDC *pDC, CRect rc, int nPen, int nBrush)
Draws a rectangle with a border.
- Public Member Functions inherited from CXTPTabColorSetDefault
- Public Member Functions inherited from CXTPTabPaintManagerColorSet
CXTPTabPaintManagerColorSet ()
Constructs a CXTPTabPaintManagerColorSet object.
virtual | ~CXTPTabPaintManagerColorSet ()
Destroys a CXTPTabPaintManagerColorSet object, handles cleanup and deallocation.
virtual void | SetTextColor (CDC *pDC, CXTPTabManagerItem *pItem)
Sets the text color for the tab.
virtual void | FillHeader (CDC *pDC, CRect rc, CXTPTabManager *pTabManager)
Fills the header of the tab client of a specified tab manager.
virtual COLORREF | FillClient (CDC *pDC, CRect rc, CXTPTabManager *pTabManager)
Fills the tab client area of a specified tab manager.
virtual COLORREF | GetClientColor (CXTPTabManager *pTabManager)
Obtains client background color.
virtual void | FillStateButton (CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem)
Fills a specified tab button when XTPTabAppearanceStyle is xtpTabAppearanceStateButtons.
virtual void | SelectClipRgn (CDC *pDC, CRect rcClient, CXTPTabManager *pTabManager)
Sets a clipping region for the specified tab client area.
virtual COLORREF | GetItemColor (CXTPTabManagerItem *pItem)
Retrieves the color of a specified tab.
void | GradientFill (CDC *pDC, CRect rc, COLORREF clrLight, COLORREF clrDark, XTPTabPosition position)
Performs a gradient fill of a rectangle with a color that smoothly fades from top to bottom.
virtual BOOL | IsAppThemed () const
Determines if Windows XP themes are enabled and if a Windows XP theme is currently used.

Protected Attributes

BOOL | m_bGradientButton
TRUE if luna colors are enabled.
- Protected Attributes inherited from CXTPTabColorSetOffice2003
CXTPPaintManagerColor | m_clrNavigateButtonBorder
Border color of tab navigation buttons on mouse over.
BOOL | m_bLunaTheme
TRUE if the current system theme is xtpSystemThemeSilver, xtpSystemThemeOlive or xtpSystemThemeOlive, otherwise FALSE.
- Protected Attributes inherited from CXTPTabPaintManagerColorSet
CXTPTabPaintManager * | m_pPaintManager
Self paint manager pointer.

Additional Inherited Members

- Public Attributes inherited from CXTPTabPaintManagerColorSet
CXTPPaintManagerColorGradient | m_clrHeaderFace
Color set of the tab header background.
CXTPPaintManagerColorGradient m_clrAutoHideFace
Color set of the auto-hide panel background.
CXTPPaintManagerColor | m_clrFrameBorder
Color of the border placed around the tab buttons and the tab client.
CXTPPaintManagerColor m_clrControlFace
Color of the control foreground.
CXTPPaintManagerColor | m_clrPaneFace
Color of the control pane foreground.
CXTPPaintManagerColor | m_clrBorderHighlight
Color of the highlight border.
CXTPPaintManagerColor | m_clrTabClientBack
Background color for the tab client area.
CXTPPaintManagerColor | m_clrTabClientBorder
Border color for the tab client area.
CXTPPaintManagerColor m_clrButtonNormal
Color of normal tabs.
CXTPPaintManagerColor | m_clrButtonPressed
Tab pressed button color.
CXTPPaintManagerColor | m_clrButtonHighlighted
Tab button color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonHighlightedClose
Tab close button color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonBorderHighlighted
Tab button border color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonBorderTabContext1
Tab button border color with tab context.
CXTPPaintManagerColor | m_clrButtonBorderTabContext2
Tab button border color with tab context.
CXTPPaintManagerColor | m_clrButtonBorderKeyTips
Tab button border color when ALT button is pressed.
CXTPPaintManagerColor | m_clrButtonSelected
Color of the currently selected tab.
CXTPPaintManagerColor | m_clrButtonSelectedPressed
Color of the currently selected tab when pressed.
CXTPPaintManagerColor | m_clrButtonSelectedHighlighted
Color of the currently selected tab when highlighted.
CXTPPaintManagerColor | m_clrButtonBorder
Tab button border (edge) color.
CXTPPaintManagerColor | m_clrButtonBorderHot
Tab button highlight or pressed border (edge) color.
CXTPPaintManagerColor m_clrTextNormal
Color of text in a normal tab.
CXTPPaintManagerColor m_clrTextPressed
Color of text in a "pressed" tab button.
CXTPPaintManagerColor | m_clrTextHighlight
Color of text on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrTextHighlightClose
Color of close button text on mouse over when hot tracking is enabled.
CXTPPaintManagerColor m_clrTextSelected
Color of text in a "selected" tab button.
CXTPPaintManagerColor m_clrTextSelectedPressed
Color of text in a "pressed" tab button.
CXTPPaintManagerColor | m_clrTextSelectedHighlighted
Color of text for tabs in all non-active groups of tabs in MDITabClient.
CXTPPaintManagerColor m_clrTextDisabled
Color of text when a tab is disabled.
CXTPPaintManagerColor | m_clrActiveFilesGlyph
Color of navigation button.
CXTPPaintManagerColor | m_clrActiveFilesGlyphHighlighted
Color of highlighted navigation button.
CXTPPaintManagerColor | m_clrActiveFilesGlyphPressed
Color of selected navigation button.
CXTPPaintManagerColor | m_clrActiveFilesBack
Color of highlighted navigation button background.
CXTPPaintManagerColor | m_clrActiveFilesBackHighlighted
Color of navigation button background.
CXTPPaintManagerColor | m_clrActiveFilesBackPressed
Color of selected navigation button background.
COLORSET_TAB_STATEBUTTON | m_csStateButton
Color set of state button style tabs.
COLORSET_TAB_PROPERTYPAGE | m_csPropertyPage
Color set of visual studio style tabs.
COLORSET_TAB_PROPERTYPAGE2003 | m_csPropertyPage2003
Color set of Office 2003 style tabs.
COLORSET_TAB_EXCEL | m_csExcelSelected
Color set of selected (focused) Excel style tabs.
COLORSET_TAB_EXCEL | m_csExcelNormal
Color set of normal Excel style tabs.

Detailed Description

CXTPTabColorSetVisualStudio2008 implements a Visual Studio 2008 tab color set.

To use the Visual Studio 2008 color set, SetColor is used to apply the xtpTabColorVisualStudio2008 XTPTabColorStyle.

The following appearances (XTPTabAppearanceStyle) support CColorSetVisualStudio2008: xtpTabAppearancePropertyPage2003: Office 2003 appearance. xtpTabAppearanceStateButtons: State Button appearance.

See also
XTPTabColorStyle, XTPTabAppearanceStyle, SetAppearance, GetAppearance, GetAppearanceSet, SetColor, GetColor, GetColorSet, SetColorSet, SetAppearanceSet

Member Function Documentation

◆ FillPropertyButton()

COLORREF FillPropertyButton | ( | CDC * | pDC,
 |  | CRect | rcItem,
 |  | CXTPTabManagerItem * | pItem )
 virtual

Fills a specified tab button.

Parameters
pDC | Pointer to a valid device context.
rcItem | Bounding rectangle of the tab button to fill.
pItem | Pointer to the tab button to fill.
Returns
The color of the specified tab button.

This method is used to fill all tab buttons except when XTPTabAppearanceStyle is set to xtpTabAppearanceStateButtons. xtpTabAppearanceStateButtons requires the FillStateButton member.

See also
m_bGradientButton

Reimplemented from CXTPTabColorSetOffice2003.

Reimplemented in CXTPTabColorSetVisualStudio2010.

◆ RefreshMetrics()

void RefreshMetrics ( )
virtual

Refreshes the visual metrics of the tabs.

Override this method to change the colors of the color members.

All of the color members are refreshed when this method is called.

Reimplemented from CXTPTabColorSetOffice2003.

Reimplemented in CXTPTabColorSetVisualStudio2010.

Member Data Documentation

◆ m_bGradientButton

BOOL m_bGradientButton
protected

TRUE if luna colors are enabled.

This will be TRUE when using Windows XP and the current system theme is xtpSystemThemeSilver, xtpSystemThemeOlive or xtpSystemThemeOlive, otherwise FALSE.

The documentation for this class was generated from the following file:
  • XTPTabColorSetVisualStudio2008.h


Toolkit Pro: CXTPTabColorSetVisualStudio2010 Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPTabColorSetVisualStudio2010 Class Reference

CXTPTabColorSetVisualStudio2010 implements a Visual Studio 2010 tab color set. More...

Inheritance diagram for CXTPTabColorSetVisualStudio2010:
[legend]

Public Member Functions

CXTPTabColorSetVisualStudio2010 (BOOL bPaneColor=FALSE)
Constructs a CXTPTabColorSetVisualStudio2010 object.
void | RefreshMetrics ()
Refreshes the visual metrics of the tabs.
COLORREF | FillPropertyButton (CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem)
Fills a specified tab button.
void | FillNavigateButton (CDC *pDC, CXTPTabManagerNavigateButton *pButton, CRect &rc)
Fills a specified tab navigation button.
void | SetTextColor (CDC *pDC, CXTPTabManagerItem *pItem)
Sets the text color for a specified tab.
virtual void | FillHeader (CDC *pDC, CRect rc, CXTPTabManager *pTabManager)
Fills the header of the tab client of a specified tab manager.
- Public Member Functions inherited from CXTPTabColorSetVisualStudio2008
CXTPTabColorSetVisualStudio2008 ()
Constructs a CXTPTabColorSetVisualStudio2008 object.
- Public Member Functions inherited from CXTPTabColorSetOffice2003
void | Rectangle (CDC *pDC, CRect rc, int nPen, int nBrush)
Draws a rectangle with a border.
- Public Member Functions inherited from CXTPTabColorSetDefault
- Public Member Functions inherited from CXTPTabPaintManagerColorSet
CXTPTabPaintManagerColorSet ()
Constructs a CXTPTabPaintManagerColorSet object.
virtual | ~CXTPTabPaintManagerColorSet ()
Destroys a CXTPTabPaintManagerColorSet object, handles cleanup and deallocation.
virtual COLORREF | FillClient (CDC *pDC, CRect rc, CXTPTabManager *pTabManager)
Fills the tab client area of a specified tab manager.
virtual COLORREF | GetClientColor (CXTPTabManager *pTabManager)
Obtains client background color.
virtual void | FillStateButton (CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem)
Fills a specified tab button when XTPTabAppearanceStyle is xtpTabAppearanceStateButtons.
virtual void | SelectClipRgn (CDC *pDC, CRect rcClient, CXTPTabManager *pTabManager)
Sets a clipping region for the specified tab client area.
virtual COLORREF | GetItemColor (CXTPTabManagerItem *pItem)
Retrieves the color of a specified tab.
void | GradientFill (CDC *pDC, CRect rc, COLORREF clrLight, COLORREF clrDark, XTPTabPosition position)
Performs a gradient fill of a rectangle with a color that smoothly fades from top to bottom.
virtual BOOL | IsAppThemed () const
Determines if Windows XP themes are enabled and if a Windows XP theme is currently used.

Protected Attributes

BOOL | m_bGradientButton
TRUE if luna colors are enabled.
- Protected Attributes inherited from CXTPTabColorSetVisualStudio2008
BOOL | m_bGradientButton
TRUE if luna colors are enabled.
- Protected Attributes inherited from CXTPTabColorSetOffice2003
CXTPPaintManagerColor | m_clrNavigateButtonBorder
Border color of tab navigation buttons on mouse over.
BOOL | m_bLunaTheme
TRUE if the current system theme is xtpSystemThemeSilver, xtpSystemThemeOlive or xtpSystemThemeOlive, otherwise FALSE.
- Protected Attributes inherited from CXTPTabPaintManagerColorSet
CXTPTabPaintManager * | m_pPaintManager
Self paint manager pointer.

Additional Inherited Members

- Public Attributes inherited from CXTPTabPaintManagerColorSet
CXTPPaintManagerColorGradient | m_clrHeaderFace
Color set of the tab header background.
CXTPPaintManagerColorGradient m_clrAutoHideFace
Color set of the auto-hide panel background.
CXTPPaintManagerColor | m_clrFrameBorder
Color of the border placed around the tab buttons and the tab client.
CXTPPaintManagerColor m_clrControlFace
Color of the control foreground.
CXTPPaintManagerColor | m_clrPaneFace
Color of the control pane foreground.
CXTPPaintManagerColor | m_clrBorderHighlight
Color of the highlight border.
CXTPPaintManagerColor | m_clrTabClientBack
Background color for the tab client area.
CXTPPaintManagerColor | m_clrTabClientBorder
Border color for the tab client area.
CXTPPaintManagerColor m_clrButtonNormal
Color of normal tabs.
CXTPPaintManagerColor | m_clrButtonPressed
Tab pressed button color.
CXTPPaintManagerColor | m_clrButtonHighlighted
Tab button color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonHighlightedClose
Tab close button color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonBorderHighlighted
Tab button border color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonBorderTabContext1
Tab button border color with tab context.
CXTPPaintManagerColor | m_clrButtonBorderTabContext2
Tab button border color with tab context.
CXTPPaintManagerColor | m_clrButtonBorderKeyTips
Tab button border color when ALT button is pressed.
CXTPPaintManagerColor | m_clrButtonSelected
Color of the currently selected tab.
CXTPPaintManagerColor | m_clrButtonSelectedPressed
Color of the currently selected tab when pressed.
CXTPPaintManagerColor | m_clrButtonSelectedHighlighted
Color of the currently selected tab when highlighted.
CXTPPaintManagerColor | m_clrButtonBorder
Tab button border (edge) color.
CXTPPaintManagerColor | m_clrButtonBorderHot
Tab button highlight or pressed border (edge) color.
CXTPPaintManagerColor m_clrTextNormal
Color of text in a normal tab.
CXTPPaintManagerColor m_clrTextPressed
Color of text in a "pressed" tab button.
CXTPPaintManagerColor | m_clrTextHighlight
Color of text on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrTextHighlightClose
Color of close button text on mouse over when hot tracking is enabled.
CXTPPaintManagerColor m_clrTextSelected
Color of text in a "selected" tab button.
CXTPPaintManagerColor m_clrTextSelectedPressed
Color of text in a "pressed" tab button.
CXTPPaintManagerColor | m_clrTextSelectedHighlighted
Color of text for tabs in all non-active groups of tabs in MDITabClient.
CXTPPaintManagerColor m_clrTextDisabled
Color of text when a tab is disabled.
CXTPPaintManagerColor | m_clrActiveFilesGlyph
Color of navigation button.
CXTPPaintManagerColor | m_clrActiveFilesGlyphHighlighted
Color of highlighted navigation button.
CXTPPaintManagerColor | m_clrActiveFilesGlyphPressed
Color of selected navigation button.
CXTPPaintManagerColor | m_clrActiveFilesBack
Color of highlighted navigation button background.
CXTPPaintManagerColor | m_clrActiveFilesBackHighlighted
Color of navigation button background.
CXTPPaintManagerColor | m_clrActiveFilesBackPressed
Color of selected navigation button background.
COLORSET_TAB_STATEBUTTON | m_csStateButton
Color set of state button style tabs.
COLORSET_TAB_PROPERTYPAGE | m_csPropertyPage
Color set of visual studio style tabs.
COLORSET_TAB_PROPERTYPAGE2003 | m_csPropertyPage2003
Color set of Office 2003 style tabs.
COLORSET_TAB_EXCEL | m_csExcelSelected
Color set of selected (focused) Excel style tabs.
COLORSET_TAB_EXCEL | m_csExcelNormal
Color set of normal Excel style tabs.

Detailed Description

CXTPTabColorSetVisualStudio2010 implements a Visual Studio 2010 tab color set.

To use the Visual Studio 2010 color set, SetColor is used to apply the xtpTabColorVisualStudio2010 XTPTabColorStyle.

The following appearances (XTPTabAppearanceStyle) support CColorSetVisualStudio2010: xtpTabAppearancePropertyPage2003: Office 2003 appearance. xtpTabAppearanceStateButtons: State Button appearance.

See also
XTPTabColorStyle, XTPTabAppearanceStyle, SetAppearance, GetAppearance, GetAppearanceSet, SetColor, GetColor, GetColorSet, SetColorSet, SetAppearanceSet

Constructor & Destructor Documentation

◆ CXTPTabColorSetVisualStudio2010()

CXTPTabColorSetVisualStudio2010 ( BOOL bPaneColor = FALSE )

Constructs a CXTPTabColorSetVisualStudio2010 object.

Parameters
bPaneColor TRUE if color represents a pane color, FALSE otherwise.

Member Function Documentation

◆ FillHeader()

virtual void FillHeader | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | CXTPTabManager * | pTabManager )
 virtual

Fills the header of the tab client of a specified tab manager.

Parameters
pDC | Pointer to a valid device context.
rc | Bounding rectangle of the tab header.
pTabManager | Pointer to the tab manager with the header to fill.

The tab client header is the bounding rectangle containing the tab buttons. The bounding rectangle can be retrieved by using the CXTPTabPaintManagerTheme::GetHeaderRect and CXTPTabManager::GetHeaderRect methods.

See also
CXTPTabPaintManagerTheme::GetHeaderRect, CXTPTabManager::GetHeaderRect

Reimplemented from CXTPTabPaintManagerColorSet.

◆ FillNavigateButton()

void FillNavigateButton | ( | CDC * | pDC,
 |  | CXTPTabManagerNavigateButton * | pButton,
 |  | CRect & | rc )
 virtual

Fills a specified tab navigation button.

Parameters
pDC | Pointer to a valid device context.
pButton | Pointer to the tab navigation button to fill.
rc | Reference to the bounding rectangle of the tab navigation button.

This method is used to fill the tab navigation buttons in the header of the tab client and is overridden by XTPTabColorStyle and CXTPTabPaintManagerColorSet to perform actions such as painting the highlighted, pressed, and normal versions of tab navigation buttons.

This method must be overridden.

See also
CXTPTabManager::GetNavigateButton, CXTPTabManagerNavigateButton

Reimplemented from CXTPTabColorSetOffice2003.

◆ FillPropertyButton()

COLORREF FillPropertyButton | ( | CDC * | pDC,
 |  | CRect | rcItem,
 |  | CXTPTabManagerItem * | pItem )
 virtual

Fills a specified tab button.

Parameters
pDC | Pointer to a valid device context.
rcItem | Bounding rectangle of the tab button to fill.
pItem | Pointer to the tab button to fill.
Returns
The color of the specified tab button.

This method is used to fill all tab buttons except when XTPTabAppearanceStyle is set to xtpTabAppearanceStateButtons. xtpTabAppearanceStateButtons requires the FillStateButton member.

See also
m_bGradientButton

Reimplemented from CXTPTabColorSetVisualStudio2008.

◆ RefreshMetrics()

void RefreshMetrics ( )
virtual

Refreshes the visual metrics of the tabs.

Override this method to change the colors of the color members.

All of the color members are refreshed when this method is called.

Reimplemented from CXTPTabColorSetVisualStudio2008.

◆ SetTextColor()

void SetTextColor | ( | CDC * | pDC,
 |  | CXTPTabManagerItem * | pItem )
 virtual

Sets the text color for a specified tab.

Parameters
pDC | Pointer to a valid device context.
pItem | Pointer to the tab with the text color to be set.

Reimplemented from CXTPTabPaintManagerColorSet.

Member Data Documentation

◆ m_bGradientButton

BOOL m_bGradientButton
protected

TRUE if luna colors are enabled.

This will be TRUE when using Windows XP and the current system theme is xtpSystemThemeSilver, xtpSystemThemeOlive or xtpSystemThemeOlive, otherwise FALSE.

The documentation for this class was generated from the following file:
  • XTPTabColorSetVisualStudio2010.h


Toolkit Pro: CXTPTabColorSetVisualStudio2012 Class Reference

Public Member Functions | List of all members
CXTPTabColorSetVisualStudio2012 Class Reference

CXTPTabColorSetVisualStudio2012 implements a Visual Studio 2012 tab color set. More...

Inheritance diagram for CXTPTabColorSetVisualStudio2012:
[legend]

Public Member Functions

virtual void | RefreshMetrics ()
Refreshes the visual metrics of the tabs.
virtual COLORREF | GetItemColor (CXTPTabManagerItem *pItem)
Retrieves the color of a specified tab.
virtual void | FillNavigateButton (CDC *pDC, CXTPTabManagerNavigateButton *pButton, CRect &rc)
Fills a specified tab navigation button.
virtual COLORREF | GetClientColor (CXTPTabManager *pTabManager)
Obtains client background color.
- Public Member Functions inherited from CXTPTabPaintManagerColorSet
CXTPTabPaintManagerColorSet ()
Constructs a CXTPTabPaintManagerColorSet object.
virtual | ~CXTPTabPaintManagerColorSet ()
Destroys a CXTPTabPaintManagerColorSet object, handles cleanup and deallocation.
virtual void | SetTextColor (CDC *pDC, CXTPTabManagerItem *pItem)
Sets the text color for the tab.
virtual void | FillHeader (CDC *pDC, CRect rc, CXTPTabManager *pTabManager)
Fills the header of the tab client of a specified tab manager.
virtual COLORREF | FillClient (CDC *pDC, CRect rc, CXTPTabManager *pTabManager)
Fills the tab client area of a specified tab manager.
virtual void | FillStateButton (CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem)
Fills a specified tab button when XTPTabAppearanceStyle is xtpTabAppearanceStateButtons.
virtual COLORREF | FillPropertyButton (CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem)
Fills a specified tab button.
virtual void | SelectClipRgn (CDC *pDC, CRect rcClient, CXTPTabManager *pTabManager)
Sets a clipping region for the specified tab client area.
void | GradientFill (CDC *pDC, CRect rc, COLORREF clrLight, COLORREF clrDark, XTPTabPosition position)
Performs a gradient fill of a rectangle with a color that smoothly fades from top to bottom.
virtual BOOL | IsAppThemed () const
Determines if Windows XP themes are enabled and if a Windows XP theme is currently used.

Additional Inherited Members

- Public Attributes inherited from CXTPTabPaintManagerColorSet
CXTPPaintManagerColorGradient | m_clrHeaderFace
Color set of the tab header background.
CXTPPaintManagerColorGradient m_clrAutoHideFace
Color set of the auto-hide panel background.
CXTPPaintManagerColor | m_clrFrameBorder
Color of the border placed around the tab buttons and the tab client.
CXTPPaintManagerColor m_clrControlFace
Color of the control foreground.
CXTPPaintManagerColor | m_clrPaneFace
Color of the control pane foreground.
CXTPPaintManagerColor | m_clrBorderHighlight
Color of the highlight border.
CXTPPaintManagerColor | m_clrTabClientBack
Background color for the tab client area.
CXTPPaintManagerColor | m_clrTabClientBorder
Border color for the tab client area.
CXTPPaintManagerColor m_clrButtonNormal
Color of normal tabs.
CXTPPaintManagerColor | m_clrButtonPressed
Tab pressed button color.
CXTPPaintManagerColor | m_clrButtonHighlighted
Tab button color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonHighlightedClose
Tab close button color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonBorderHighlighted
Tab button border color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonBorderTabContext1
Tab button border color with tab context.
CXTPPaintManagerColor | m_clrButtonBorderTabContext2
Tab button border color with tab context.
CXTPPaintManagerColor | m_clrButtonBorderKeyTips
Tab button border color when ALT button is pressed.
CXTPPaintManagerColor | m_clrButtonSelected
Color of the currently selected tab.
CXTPPaintManagerColor | m_clrButtonSelectedPressed
Color of the currently selected tab when pressed.
CXTPPaintManagerColor | m_clrButtonSelectedHighlighted
Color of the currently selected tab when highlighted.
CXTPPaintManagerColor | m_clrButtonBorder
Tab button border (edge) color.
CXTPPaintManagerColor | m_clrButtonBorderHot
Tab button highlight or pressed border (edge) color.
CXTPPaintManagerColor m_clrTextNormal
Color of text in a normal tab.
CXTPPaintManagerColor m_clrTextPressed
Color of text in a "pressed" tab button.
CXTPPaintManagerColor | m_clrTextHighlight
Color of text on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrTextHighlightClose
Color of close button text on mouse over when hot tracking is enabled.
CXTPPaintManagerColor m_clrTextSelected
Color of text in a "selected" tab button.
CXTPPaintManagerColor m_clrTextSelectedPressed
Color of text in a "pressed" tab button.
CXTPPaintManagerColor | m_clrTextSelectedHighlighted
Color of text for tabs in all non-active groups of tabs in MDITabClient.
CXTPPaintManagerColor m_clrTextDisabled
Color of text when a tab is disabled.
CXTPPaintManagerColor | m_clrActiveFilesGlyph
Color of navigation button.
CXTPPaintManagerColor | m_clrActiveFilesGlyphHighlighted
Color of highlighted navigation button.
CXTPPaintManagerColor | m_clrActiveFilesGlyphPressed
Color of selected navigation button.
CXTPPaintManagerColor | m_clrActiveFilesBack
Color of highlighted navigation button background.
CXTPPaintManagerColor | m_clrActiveFilesBackHighlighted
Color of navigation button background.
CXTPPaintManagerColor | m_clrActiveFilesBackPressed
Color of selected navigation button background.
COLORSET_TAB_STATEBUTTON | m_csStateButton
Color set of state button style tabs.
COLORSET_TAB_PROPERTYPAGE | m_csPropertyPage
Color set of visual studio style tabs.
COLORSET_TAB_PROPERTYPAGE2003 | m_csPropertyPage2003
Color set of Office 2003 style tabs.
COLORSET_TAB_EXCEL | m_csExcelSelected
Color set of selected (focused) Excel style tabs.
COLORSET_TAB_EXCEL | m_csExcelNormal
Color set of normal Excel style tabs.
- Protected Attributes inherited from CXTPTabPaintManagerColorSet
CXTPTabPaintManager * | m_pPaintManager
Self paint manager pointer.

Detailed Description

CXTPTabColorSetVisualStudio2012 implements a Visual Studio 2012 tab color set.

Member Function Documentation

◆ FillNavigateButton()

virtual void FillNavigateButton | ( | CDC * | pDC,
 |  | CXTPTabManagerNavigateButton * | pButton,
 |  | CRect & | rc )
 virtual

Fills a specified tab navigation button.

Parameters
pDC | Pointer to a valid device context.
pButton | Pointer to the tab navigation button to fill.
rc | Reference to the bounding rectangle of the tab navigation button.

This method is used to fill the tab navigation buttons in the header of the tab client and is overridden by XTPTabColorStyle and CXTPTabPaintManagerColorSet to perform actions such as painting the highlighted, pressed, and normal versions of tab navigation buttons.

This method must be overridden.

See also
CXTPTabManager::GetNavigateButton, CXTPTabManagerNavigateButton

Implements CXTPTabPaintManagerColorSet.

Reimplemented in CXTPTabColorSetOffice2013.

◆ GetClientColor()

virtual COLORREF GetClientColor ( CXTPTabManager * pTabManager )
virtual

Obtains client background color.

Parameters
pTabManager Pointer to the tab manager with the tab client area to fill.
Returns
Client area background color value.

Reimplemented from CXTPTabPaintManagerColorSet.

Reimplemented in CXTPTabColorSetOffice2013.

◆ GetItemColor()

virtual COLORREF GetItemColor ( CXTPTabManagerItem * pItem )
virtual

Retrieves the color of a specified tab.

Parameters
pItem Pointer to the tab with the color to retrieve.
Returns
The color of the tab.

This method is used within many of CXTPTabPaintManagerColorSet's "fill" methods.

See also
CXTPTabManager::GetItemColor, XTPTabColorStyle, SetColor, GetColorSet, SetColorSet

Reimplemented from CXTPTabPaintManagerColorSet.

Reimplemented in CXTPTabColorSetOffice2013.

◆ RefreshMetrics()

virtual void RefreshMetrics ( )
virtual

Refreshes the visual metrics of the tabs.

Override this method to change the colors of the color members.

All of the color members are refreshed when this method is called.

Reimplemented from CXTPTabPaintManagerColorSet.

Reimplemented in CXTPTabColorSetNativeWindows10, CXTPTabColorSetNativeWindows11, CXTPTabColorSetOffice2013, and CXTPTabColorSetVisualStudio2012Dark.

The documentation for this class was generated from the following file:
  • XTPTabColorSetVisualStudio2012.h


Toolkit Pro: CXTPTabColorSetVisualStudio2012Dark Class Reference

Public Member Functions | List of all members
CXTPTabColorSetVisualStudio2012Dark Class Reference

CXTPTabColorSetVisualStudio2012Dark implements a Visual Studio 2012 Dark tab color set. More...

Inheritance diagram for CXTPTabColorSetVisualStudio2012Dark:
[legend]

Public Member Functions

virtual void | RefreshMetrics ()
Refreshes the visual metrics of the tabs.
- Public Member Functions inherited from CXTPTabColorSetVisualStudio2012
virtual COLORREF | GetItemColor (CXTPTabManagerItem *pItem)
Retrieves the color of a specified tab.
virtual void | FillNavigateButton (CDC *pDC, CXTPTabManagerNavigateButton *pButton, CRect &rc)
Fills a specified tab navigation button.
virtual COLORREF | GetClientColor (CXTPTabManager *pTabManager)
Obtains client background color.
- Public Member Functions inherited from CXTPTabPaintManagerColorSet
CXTPTabPaintManagerColorSet ()
Constructs a CXTPTabPaintManagerColorSet object.
virtual | ~CXTPTabPaintManagerColorSet ()
Destroys a CXTPTabPaintManagerColorSet object, handles cleanup and deallocation.
virtual void | SetTextColor (CDC *pDC, CXTPTabManagerItem *pItem)
Sets the text color for the tab.
virtual void | FillHeader (CDC *pDC, CRect rc, CXTPTabManager *pTabManager)
Fills the header of the tab client of a specified tab manager.
virtual COLORREF | FillClient (CDC *pDC, CRect rc, CXTPTabManager *pTabManager)
Fills the tab client area of a specified tab manager.
virtual void | FillStateButton (CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem)
Fills a specified tab button when XTPTabAppearanceStyle is xtpTabAppearanceStateButtons.
virtual COLORREF | FillPropertyButton (CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem)
Fills a specified tab button.
virtual void | SelectClipRgn (CDC *pDC, CRect rcClient, CXTPTabManager *pTabManager)
Sets a clipping region for the specified tab client area.
void | GradientFill (CDC *pDC, CRect rc, COLORREF clrLight, COLORREF clrDark, XTPTabPosition position)
Performs a gradient fill of a rectangle with a color that smoothly fades from top to bottom.
virtual BOOL | IsAppThemed () const
Determines if Windows XP themes are enabled and if a Windows XP theme is currently used.

Additional Inherited Members

- Public Attributes inherited from CXTPTabPaintManagerColorSet
CXTPPaintManagerColorGradient | m_clrHeaderFace
Color set of the tab header background.
CXTPPaintManagerColorGradient m_clrAutoHideFace
Color set of the auto-hide panel background.
CXTPPaintManagerColor | m_clrFrameBorder
Color of the border placed around the tab buttons and the tab client.
CXTPPaintManagerColor m_clrControlFace
Color of the control foreground.
CXTPPaintManagerColor | m_clrPaneFace
Color of the control pane foreground.
CXTPPaintManagerColor | m_clrBorderHighlight
Color of the highlight border.
CXTPPaintManagerColor | m_clrTabClientBack
Background color for the tab client area.
CXTPPaintManagerColor | m_clrTabClientBorder
Border color for the tab client area.
CXTPPaintManagerColor m_clrButtonNormal
Color of normal tabs.
CXTPPaintManagerColor | m_clrButtonPressed
Tab pressed button color.
CXTPPaintManagerColor | m_clrButtonHighlighted
Tab button color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonHighlightedClose
Tab close button color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonBorderHighlighted
Tab button border color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonBorderTabContext1
Tab button border color with tab context.
CXTPPaintManagerColor | m_clrButtonBorderTabContext2
Tab button border color with tab context.
CXTPPaintManagerColor | m_clrButtonBorderKeyTips
Tab button border color when ALT button is pressed.
CXTPPaintManagerColor | m_clrButtonSelected
Color of the currently selected tab.
CXTPPaintManagerColor | m_clrButtonSelectedPressed
Color of the currently selected tab when pressed.
CXTPPaintManagerColor | m_clrButtonSelectedHighlighted
Color of the currently selected tab when highlighted.
CXTPPaintManagerColor | m_clrButtonBorder
Tab button border (edge) color.
CXTPPaintManagerColor | m_clrButtonBorderHot
Tab button highlight or pressed border (edge) color.
CXTPPaintManagerColor m_clrTextNormal
Color of text in a normal tab.
CXTPPaintManagerColor m_clrTextPressed
Color of text in a "pressed" tab button.
CXTPPaintManagerColor | m_clrTextHighlight
Color of text on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrTextHighlightClose
Color of close button text on mouse over when hot tracking is enabled.
CXTPPaintManagerColor m_clrTextSelected
Color of text in a "selected" tab button.
CXTPPaintManagerColor m_clrTextSelectedPressed
Color of text in a "pressed" tab button.
CXTPPaintManagerColor | m_clrTextSelectedHighlighted
Color of text for tabs in all non-active groups of tabs in MDITabClient.
CXTPPaintManagerColor m_clrTextDisabled
Color of text when a tab is disabled.
CXTPPaintManagerColor | m_clrActiveFilesGlyph
Color of navigation button.
CXTPPaintManagerColor | m_clrActiveFilesGlyphHighlighted
Color of highlighted navigation button.
CXTPPaintManagerColor | m_clrActiveFilesGlyphPressed
Color of selected navigation button.
CXTPPaintManagerColor | m_clrActiveFilesBack
Color of highlighted navigation button background.
CXTPPaintManagerColor | m_clrActiveFilesBackHighlighted
Color of navigation button background.
CXTPPaintManagerColor | m_clrActiveFilesBackPressed
Color of selected navigation button background.
COLORSET_TAB_STATEBUTTON | m_csStateButton
Color set of state button style tabs.
COLORSET_TAB_PROPERTYPAGE | m_csPropertyPage
Color set of visual studio style tabs.
COLORSET_TAB_PROPERTYPAGE2003 | m_csPropertyPage2003
Color set of Office 2003 style tabs.
COLORSET_TAB_EXCEL | m_csExcelSelected
Color set of selected (focused) Excel style tabs.
COLORSET_TAB_EXCEL | m_csExcelNormal
Color set of normal Excel style tabs.
- Protected Attributes inherited from CXTPTabColorSetVisualStudio2012
- Protected Attributes inherited from CXTPTabPaintManagerColorSet
CXTPTabPaintManager * | m_pPaintManager
Self paint manager pointer.

Detailed Description

CXTPTabColorSetVisualStudio2012Dark implements a Visual Studio 2012 Dark tab color set.

Member Function Documentation

◆ RefreshMetrics()

virtual void RefreshMetrics ( )
virtual

Refreshes the visual metrics of the tabs.

Override this method to change the colors of the color members.

All of the color members are refreshed when this method is called.

Reimplemented from CXTPTabColorSetVisualStudio2012.

The documentation for this class was generated from the following file:
  • XTPTabColorSetVisualStudio2012Dark.h


Toolkit Pro: CXTPTabColorSetVisualStudio2015 Class Reference

Public Member Functions | List of all members
CXTPTabColorSetVisualStudio2015 Class Reference

CXTPTabColorSetVisualStudio2015 implements a Visual Studio 2015 tab color set. More...

Inheritance diagram for CXTPTabColorSetVisualStudio2015:
[legend]

Public Member Functions

virtual void | RefreshMetrics ()
Refreshes the visual metrics of the tabs.
virtual COLORREF | GetItemColor (CXTPTabManagerItem *pItem)
Retrieves the color of a specified tab.
virtual void | SetTextColor (CDC *pDC, CXTPTabManagerItem *pItem)
Sets the text color for the tab.
virtual COLORREF | GetClientColor (CXTPTabManager *pTabManager)
Obtains client background color.
virtual COLORREF | FillPropertyButton (CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem)
Fills a specified tab button.
virtual void | FillNavigateButton (CDC *pDC, CXTPTabManagerNavigateButton *pButton, CRect &rc)
Fills a specified tab naGroupOuterMarginvigation button.
- Public Member Functions inherited from CXTPTabPaintManagerColorSet
CXTPTabPaintManagerColorSet ()
Constructs a CXTPTabPaintManagerColorSet object.
virtual | ~CXTPTabPaintManagerColorSet ()
Destroys a CXTPTabPaintManagerColorSet object, handles cleanup and deallocation.
virtual void | FillHeader (CDC *pDC, CRect rc, CXTPTabManager *pTabManager)
Fills the header of the tab client of a specified tab manager.
virtual COLORREF | FillClient (CDC *pDC, CRect rc, CXTPTabManager *pTabManager)
Fills the tab client area of a specified tab manager.
virtual void | FillStateButton (CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem)
Fills a specified tab button when XTPTabAppearanceStyle is xtpTabAppearanceStateButtons.
virtual void | SelectClipRgn (CDC *pDC, CRect rcClient, CXTPTabManager *pTabManager)
Sets a clipping region for the specified tab client area.
void | GradientFill (CDC *pDC, CRect rc, COLORREF clrLight, COLORREF clrDark, XTPTabPosition position)
Performs a gradient fill of a rectangle with a color that smoothly fades from top to bottom.
virtual BOOL | IsAppThemed () const
Determines if Windows XP themes are enabled and if a Windows XP theme is currently used.

Additional Inherited Members

- Public Attributes inherited from CXTPTabPaintManagerColorSet
CXTPPaintManagerColorGradient | m_clrHeaderFace
Color set of the tab header background.
CXTPPaintManagerColorGradient m_clrAutoHideFace
Color set of the auto-hide panel background.
CXTPPaintManagerColor | m_clrFrameBorder
Color of the border placed around the tab buttons and the tab client.
CXTPPaintManagerColor m_clrControlFace
Color of the control foreground.
CXTPPaintManagerColor | m_clrPaneFace
Color of the control pane foreground.
CXTPPaintManagerColor | m_clrBorderHighlight
Color of the highlight border.
CXTPPaintManagerColor | m_clrTabClientBack
Background color for the tab client area.
CXTPPaintManagerColor | m_clrTabClientBorder
Border color for the tab client area.
CXTPPaintManagerColor m_clrButtonNormal
Color of normal tabs.
CXTPPaintManagerColor | m_clrButtonPressed
Tab pressed button color.
CXTPPaintManagerColor | m_clrButtonHighlighted
Tab button color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonHighlightedClose
Tab close button color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonBorderHighlighted
Tab button border color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonBorderTabContext1
Tab button border color with tab context.
CXTPPaintManagerColor | m_clrButtonBorderTabContext2
Tab button border color with tab context.
CXTPPaintManagerColor | m_clrButtonBorderKeyTips
Tab button border color when ALT button is pressed.
CXTPPaintManagerColor | m_clrButtonSelected
Color of the currently selected tab.
CXTPPaintManagerColor | m_clrButtonSelectedPressed
Color of the currently selected tab when pressed.
CXTPPaintManagerColor | m_clrButtonSelectedHighlighted
Color of the currently selected tab when highlighted.
CXTPPaintManagerColor | m_clrButtonBorder
Tab button border (edge) color.
CXTPPaintManagerColor | m_clrButtonBorderHot
Tab button highlight or pressed border (edge) color.
CXTPPaintManagerColor m_clrTextNormal
Color of text in a normal tab.
CXTPPaintManagerColor m_clrTextPressed
Color of text in a "pressed" tab button.
CXTPPaintManagerColor | m_clrTextHighlight
Color of text on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrTextHighlightClose
Color of close button text on mouse over when hot tracking is enabled.
CXTPPaintManagerColor m_clrTextSelected
Color of text in a "selected" tab button.
CXTPPaintManagerColor m_clrTextSelectedPressed
Color of text in a "pressed" tab button.
CXTPPaintManagerColor | m_clrTextSelectedHighlighted
Color of text for tabs in all non-active groups of tabs in MDITabClient.
CXTPPaintManagerColor m_clrTextDisabled
Color of text when a tab is disabled.
CXTPPaintManagerColor | m_clrActiveFilesGlyph
Color of navigation button.
CXTPPaintManagerColor | m_clrActiveFilesGlyphHighlighted
Color of highlighted navigation button.
CXTPPaintManagerColor | m_clrActiveFilesGlyphPressed
Color of selected navigation button.
CXTPPaintManagerColor | m_clrActiveFilesBack
Color of highlighted navigation button background.
CXTPPaintManagerColor | m_clrActiveFilesBackHighlighted
Color of navigation button background.
CXTPPaintManagerColor | m_clrActiveFilesBackPressed
Color of selected navigation button background.
COLORSET_TAB_STATEBUTTON | m_csStateButton
Color set of state button style tabs.
COLORSET_TAB_PROPERTYPAGE | m_csPropertyPage
Color set of visual studio style tabs.
COLORSET_TAB_PROPERTYPAGE2003 | m_csPropertyPage2003
Color set of Office 2003 style tabs.
COLORSET_TAB_EXCEL | m_csExcelSelected
Color set of selected (focused) Excel style tabs.
COLORSET_TAB_EXCEL | m_csExcelNormal
Color set of normal Excel style tabs.
- Protected Attributes inherited from CXTPTabPaintManagerColorSet
CXTPTabPaintManager * | m_pPaintManager
Self paint manager pointer.

Detailed Description

CXTPTabColorSetVisualStudio2015 implements a Visual Studio 2015 tab color set.

Member Function Documentation

◆ FillNavigateButton()

virtual void FillNavigateButton | ( | CDC * | pDC,
 |  | CXTPTabManagerNavigateButton * | pButton,
 |  | CRect & | rc )
 virtual

Fills a specified tab naGroupOuterMarginvigation button.

Parameters
pDC | Pointer to a valid device context.
pButton | Pointer to the tab navigation button to fill.
rc | Reference to the bounding rectangle of the tab navigation button.

This method is used to fill the tab navigation buttons in the header of the tab client and is overridden by XTPTabColorStyle and CXTPTabPaintManagerColorSet to perform actions such as painting the highlighted, pressed, and normal versions of tab navigation buttons.

This method must be overridden.

See also
CXTPTabManager::GetNavigateButton, CXTPTabManagerNavigateButton

Implements CXTPTabPaintManagerColorSet.

◆ FillPropertyButton()

virtual COLORREF FillPropertyButton | ( | CDC * | pDC,
 |  | CRect | rcItem,
 |  | CXTPTabManagerItem * | pItem )
 virtual

Fills a specified tab button.

Parameters
pDC | Pointer to a valid device context.
rcItem | Bounding rectangle of the tab button to fill.
pItem | Pointer to the tab button to fill.
Returns
The color of the specified tab button.

This method is used to fill all tab buttons except when XTPTabAppearanceStyle is set to xtpTabAppearanceStateButtons. xtpTabAppearanceStateButtons requires the FillStateButton member.

See also
FillStateButton

Reimplemented from CXTPTabPaintManagerColorSet.

◆ GetClientColor()

virtual COLORREF GetClientColor ( CXTPTabManager * pTabManager )
virtual

Obtains client background color.

Parameters
pTabManager Pointer to the tab manager with the tab client area to fill.
Returns
Client area background color value.

Reimplemented from CXTPTabPaintManagerColorSet.

◆ GetItemColor()

virtual COLORREF GetItemColor ( CXTPTabManagerItem * pItem )
virtual

Retrieves the color of a specified tab.

Parameters
pItem Pointer to the tab with the color to retrieve.
Returns
The color of the tab.

This method is used within many of CXTPTabPaintManagerColorSet's "fill" methods.

See also
CXTPTabManager::GetItemColor, XTPTabColorStyle, SetColor, GetColorSet, SetColorSet

Reimplemented from CXTPTabPaintManagerColorSet.

◆ RefreshMetrics()

virtual void RefreshMetrics ( )
virtual

Refreshes the visual metrics of the tabs.

Override this method to change the colors of the color members.

All of the color members are refreshed when this method is called.

Reimplemented from CXTPTabPaintManagerColorSet.

Reimplemented in CXTPTabColorSetVisualStudio2017, CXTPTabColorSetVisualStudio2019, and CXTPTabColorSetVisualStudio2022.

◆ SetTextColor()

virtual void SetTextColor | ( | CDC * | pDC,
 |  | CXTPTabManagerItem * | pItem )
 virtual

Sets the text color for the tab.

Parameters
pDC | Pointer to a valid device context.
pItem | Pointer to the tab to set the text color of.

Reimplemented from CXTPTabPaintManagerColorSet.

The documentation for this class was generated from the following file:
  • XTPTabColorSetVisualStudio2015.h


Toolkit Pro: CXTPTabColorSetVisualStudio2017 Class Reference

Public Member Functions | List of all members
CXTPTabColorSetVisualStudio2017 Class Reference

CXTPTabColorSetVisualStudio2017 implements a Visual Studio 2017 tab color set. More...

Inheritance diagram for CXTPTabColorSetVisualStudio2017:
[legend]

Public Member Functions

virtual void | RefreshMetrics ()
Refreshes the visual metrics of the tabs.
- Public Member Functions inherited from CXTPTabColorSetVisualStudio2015
virtual COLORREF | GetItemColor (CXTPTabManagerItem *pItem)
Retrieves the color of a specified tab.
virtual void | SetTextColor (CDC *pDC, CXTPTabManagerItem *pItem)
Sets the text color for the tab.
virtual COLORREF | GetClientColor (CXTPTabManager *pTabManager)
Obtains client background color.
virtual COLORREF | FillPropertyButton (CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem)
Fills a specified tab button.
virtual void | FillNavigateButton (CDC *pDC, CXTPTabManagerNavigateButton *pButton, CRect &rc)
Fills a specified tab naGroupOuterMarginvigation button.
- Public Member Functions inherited from CXTPTabPaintManagerColorSet
CXTPTabPaintManagerColorSet ()
Constructs a CXTPTabPaintManagerColorSet object.
virtual | ~CXTPTabPaintManagerColorSet ()
Destroys a CXTPTabPaintManagerColorSet object, handles cleanup and deallocation.
virtual void | FillHeader (CDC *pDC, CRect rc, CXTPTabManager *pTabManager)
Fills the header of the tab client of a specified tab manager.
virtual COLORREF | FillClient (CDC *pDC, CRect rc, CXTPTabManager *pTabManager)
Fills the tab client area of a specified tab manager.
virtual void | FillStateButton (CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem)
Fills a specified tab button when XTPTabAppearanceStyle is xtpTabAppearanceStateButtons.
virtual void | SelectClipRgn (CDC *pDC, CRect rcClient, CXTPTabManager *pTabManager)
Sets a clipping region for the specified tab client area.
void | GradientFill (CDC *pDC, CRect rc, COLORREF clrLight, COLORREF clrDark, XTPTabPosition position)
Performs a gradient fill of a rectangle with a color that smoothly fades from top to bottom.
virtual BOOL | IsAppThemed () const
Determines if Windows XP themes are enabled and if a Windows XP theme is currently used.

Additional Inherited Members

- Public Attributes inherited from CXTPTabPaintManagerColorSet
CXTPPaintManagerColorGradient | m_clrHeaderFace
Color set of the tab header background.
CXTPPaintManagerColorGradient m_clrAutoHideFace
Color set of the auto-hide panel background.
CXTPPaintManagerColor | m_clrFrameBorder
Color of the border placed around the tab buttons and the tab client.
CXTPPaintManagerColor m_clrControlFace
Color of the control foreground.
CXTPPaintManagerColor | m_clrPaneFace
Color of the control pane foreground.
CXTPPaintManagerColor | m_clrBorderHighlight
Color of the highlight border.
CXTPPaintManagerColor | m_clrTabClientBack
Background color for the tab client area.
CXTPPaintManagerColor | m_clrTabClientBorder
Border color for the tab client area.
CXTPPaintManagerColor m_clrButtonNormal
Color of normal tabs.
CXTPPaintManagerColor | m_clrButtonPressed
Tab pressed button color.
CXTPPaintManagerColor | m_clrButtonHighlighted
Tab button color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonHighlightedClose
Tab close button color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonBorderHighlighted
Tab button border color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonBorderTabContext1
Tab button border color with tab context.
CXTPPaintManagerColor | m_clrButtonBorderTabContext2
Tab button border color with tab context.
CXTPPaintManagerColor | m_clrButtonBorderKeyTips
Tab button border color when ALT button is pressed.
CXTPPaintManagerColor | m_clrButtonSelected
Color of the currently selected tab.
CXTPPaintManagerColor | m_clrButtonSelectedPressed
Color of the currently selected tab when pressed.
CXTPPaintManagerColor | m_clrButtonSelectedHighlighted
Color of the currently selected tab when highlighted.
CXTPPaintManagerColor | m_clrButtonBorder
Tab button border (edge) color.
CXTPPaintManagerColor | m_clrButtonBorderHot
Tab button highlight or pressed border (edge) color.
CXTPPaintManagerColor m_clrTextNormal
Color of text in a normal tab.
CXTPPaintManagerColor m_clrTextPressed
Color of text in a "pressed" tab button.
CXTPPaintManagerColor | m_clrTextHighlight
Color of text on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrTextHighlightClose
Color of close button text on mouse over when hot tracking is enabled.
CXTPPaintManagerColor m_clrTextSelected
Color of text in a "selected" tab button.
CXTPPaintManagerColor m_clrTextSelectedPressed
Color of text in a "pressed" tab button.
CXTPPaintManagerColor | m_clrTextSelectedHighlighted
Color of text for tabs in all non-active groups of tabs in MDITabClient.
CXTPPaintManagerColor m_clrTextDisabled
Color of text when a tab is disabled.
CXTPPaintManagerColor | m_clrActiveFilesGlyph
Color of navigation button.
CXTPPaintManagerColor | m_clrActiveFilesGlyphHighlighted
Color of highlighted navigation button.
CXTPPaintManagerColor | m_clrActiveFilesGlyphPressed
Color of selected navigation button.
CXTPPaintManagerColor | m_clrActiveFilesBack
Color of highlighted navigation button background.
CXTPPaintManagerColor | m_clrActiveFilesBackHighlighted
Color of navigation button background.
CXTPPaintManagerColor | m_clrActiveFilesBackPressed
Color of selected navigation button background.
COLORSET_TAB_STATEBUTTON | m_csStateButton
Color set of state button style tabs.
COLORSET_TAB_PROPERTYPAGE | m_csPropertyPage
Color set of visual studio style tabs.
COLORSET_TAB_PROPERTYPAGE2003 | m_csPropertyPage2003
Color set of Office 2003 style tabs.
COLORSET_TAB_EXCEL | m_csExcelSelected
Color set of selected (focused) Excel style tabs.
COLORSET_TAB_EXCEL | m_csExcelNormal
Color set of normal Excel style tabs.
- Protected Member Functions inherited from CXTPTabColorSetVisualStudio2015
- Protected Attributes inherited from CXTPTabColorSetVisualStudio2015
- Protected Attributes inherited from CXTPTabPaintManagerColorSet
CXTPTabPaintManager * | m_pPaintManager
Self paint manager pointer.

Detailed Description

CXTPTabColorSetVisualStudio2017 implements a Visual Studio 2017 tab color set.

Member Function Documentation

◆ RefreshMetrics()

virtual void RefreshMetrics ( )
virtual

Refreshes the visual metrics of the tabs.

Override this method to change the colors of the color members.

All of the color members are refreshed when this method is called.

Reimplemented from CXTPTabColorSetVisualStudio2015.

Reimplemented in CXTPTabColorSetVisualStudio2019, and CXTPTabColorSetVisualStudio2022.

The documentation for this class was generated from the following file:
  • XTPTabColorSetVisualStudio2017.h


Toolkit Pro: CXTPTabColorSetVisualStudio2019 Class Reference

Public Member Functions | List of all members
CXTPTabColorSetVisualStudio2019 Class Reference

CXTPTabColorSetVisualStudio2019 implements a Visual Studio 2019 tab color set. More...

Inheritance diagram for CXTPTabColorSetVisualStudio2019:
[legend]

Public Member Functions

virtual void | RefreshMetrics ()
Refreshes the visual metrics of the tabs.
- Public Member Functions inherited from CXTPTabColorSetVisualStudio2017
- Public Member Functions inherited from CXTPTabColorSetVisualStudio2015
virtual COLORREF | GetItemColor (CXTPTabManagerItem *pItem)
Retrieves the color of a specified tab.
virtual void | SetTextColor (CDC *pDC, CXTPTabManagerItem *pItem)
Sets the text color for the tab.
virtual COLORREF | GetClientColor (CXTPTabManager *pTabManager)
Obtains client background color.
virtual COLORREF | FillPropertyButton (CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem)
Fills a specified tab button.
virtual void | FillNavigateButton (CDC *pDC, CXTPTabManagerNavigateButton *pButton, CRect &rc)
Fills a specified tab naGroupOuterMarginvigation button.
- Public Member Functions inherited from CXTPTabPaintManagerColorSet
CXTPTabPaintManagerColorSet ()
Constructs a CXTPTabPaintManagerColorSet object.
virtual | ~CXTPTabPaintManagerColorSet ()
Destroys a CXTPTabPaintManagerColorSet object, handles cleanup and deallocation.
virtual void | FillHeader (CDC *pDC, CRect rc, CXTPTabManager *pTabManager)
Fills the header of the tab client of a specified tab manager.
virtual COLORREF | FillClient (CDC *pDC, CRect rc, CXTPTabManager *pTabManager)
Fills the tab client area of a specified tab manager.
virtual void | FillStateButton (CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem)
Fills a specified tab button when XTPTabAppearanceStyle is xtpTabAppearanceStateButtons.
virtual void | SelectClipRgn (CDC *pDC, CRect rcClient, CXTPTabManager *pTabManager)
Sets a clipping region for the specified tab client area.
void | GradientFill (CDC *pDC, CRect rc, COLORREF clrLight, COLORREF clrDark, XTPTabPosition position)
Performs a gradient fill of a rectangle with a color that smoothly fades from top to bottom.
virtual BOOL | IsAppThemed () const
Determines if Windows XP themes are enabled and if a Windows XP theme is currently used.

Additional Inherited Members

- Public Attributes inherited from CXTPTabPaintManagerColorSet
CXTPPaintManagerColorGradient | m_clrHeaderFace
Color set of the tab header background.
CXTPPaintManagerColorGradient m_clrAutoHideFace
Color set of the auto-hide panel background.
CXTPPaintManagerColor | m_clrFrameBorder
Color of the border placed around the tab buttons and the tab client.
CXTPPaintManagerColor m_clrControlFace
Color of the control foreground.
CXTPPaintManagerColor | m_clrPaneFace
Color of the control pane foreground.
CXTPPaintManagerColor | m_clrBorderHighlight
Color of the highlight border.
CXTPPaintManagerColor | m_clrTabClientBack
Background color for the tab client area.
CXTPPaintManagerColor | m_clrTabClientBorder
Border color for the tab client area.
CXTPPaintManagerColor m_clrButtonNormal
Color of normal tabs.
CXTPPaintManagerColor | m_clrButtonPressed
Tab pressed button color.
CXTPPaintManagerColor | m_clrButtonHighlighted
Tab button color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonHighlightedClose
Tab close button color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonBorderHighlighted
Tab button border color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonBorderTabContext1
Tab button border color with tab context.
CXTPPaintManagerColor | m_clrButtonBorderTabContext2
Tab button border color with tab context.
CXTPPaintManagerColor | m_clrButtonBorderKeyTips
Tab button border color when ALT button is pressed.
CXTPPaintManagerColor | m_clrButtonSelected
Color of the currently selected tab.
CXTPPaintManagerColor | m_clrButtonSelectedPressed
Color of the currently selected tab when pressed.
CXTPPaintManagerColor | m_clrButtonSelectedHighlighted
Color of the currently selected tab when highlighted.
CXTPPaintManagerColor | m_clrButtonBorder
Tab button border (edge) color.
CXTPPaintManagerColor | m_clrButtonBorderHot
Tab button highlight or pressed border (edge) color.
CXTPPaintManagerColor m_clrTextNormal
Color of text in a normal tab.
CXTPPaintManagerColor m_clrTextPressed
Color of text in a "pressed" tab button.
CXTPPaintManagerColor | m_clrTextHighlight
Color of text on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrTextHighlightClose
Color of close button text on mouse over when hot tracking is enabled.
CXTPPaintManagerColor m_clrTextSelected
Color of text in a "selected" tab button.
CXTPPaintManagerColor m_clrTextSelectedPressed
Color of text in a "pressed" tab button.
CXTPPaintManagerColor | m_clrTextSelectedHighlighted
Color of text for tabs in all non-active groups of tabs in MDITabClient.
CXTPPaintManagerColor m_clrTextDisabled
Color of text when a tab is disabled.
CXTPPaintManagerColor | m_clrActiveFilesGlyph
Color of navigation button.
CXTPPaintManagerColor | m_clrActiveFilesGlyphHighlighted
Color of highlighted navigation button.
CXTPPaintManagerColor | m_clrActiveFilesGlyphPressed
Color of selected navigation button.
CXTPPaintManagerColor | m_clrActiveFilesBack
Color of highlighted navigation button background.
CXTPPaintManagerColor | m_clrActiveFilesBackHighlighted
Color of navigation button background.
CXTPPaintManagerColor | m_clrActiveFilesBackPressed
Color of selected navigation button background.
COLORSET_TAB_STATEBUTTON | m_csStateButton
Color set of state button style tabs.
COLORSET_TAB_PROPERTYPAGE | m_csPropertyPage
Color set of visual studio style tabs.
COLORSET_TAB_PROPERTYPAGE2003 | m_csPropertyPage2003
Color set of Office 2003 style tabs.
COLORSET_TAB_EXCEL | m_csExcelSelected
Color set of selected (focused) Excel style tabs.
COLORSET_TAB_EXCEL | m_csExcelNormal
Color set of normal Excel style tabs.
- Protected Member Functions inherited from CXTPTabColorSetVisualStudio2015
- Protected Attributes inherited from CXTPTabColorSetVisualStudio2015
- Protected Attributes inherited from CXTPTabPaintManagerColorSet
CXTPTabPaintManager * | m_pPaintManager
Self paint manager pointer.

Detailed Description

CXTPTabColorSetVisualStudio2019 implements a Visual Studio 2019 tab color set.

Member Function Documentation

◆ RefreshMetrics()

virtual void RefreshMetrics ( )
virtual

Refreshes the visual metrics of the tabs.

Override this method to change the colors of the color members.

All of the color members are refreshed when this method is called.

Reimplemented from CXTPTabColorSetVisualStudio2017.

Reimplemented in CXTPTabColorSetVisualStudio2022.

The documentation for this class was generated from the following file:
  • XTPTabColorSetVisualStudio2019.h


Toolkit Pro: CXTPTabColorSetVisualStudio2022 Class Reference

Public Member Functions | List of all members
CXTPTabColorSetVisualStudio2022 Class Reference

CXTPTabColorSetVisualStudio2022 implements a Visual Studio 2022 tab color set. More...

Inheritance diagram for CXTPTabColorSetVisualStudio2022:
[legend]

Public Member Functions

virtual void | RefreshMetrics ()
Refreshes the visual metrics of the tabs.
- Public Member Functions inherited from CXTPTabColorSetVisualStudio2019
- Public Member Functions inherited from CXTPTabColorSetVisualStudio2017
- Public Member Functions inherited from CXTPTabColorSetVisualStudio2015
virtual COLORREF | GetItemColor (CXTPTabManagerItem *pItem)
Retrieves the color of a specified tab.
virtual void | SetTextColor (CDC *pDC, CXTPTabManagerItem *pItem)
Sets the text color for the tab.
virtual COLORREF | GetClientColor (CXTPTabManager *pTabManager)
Obtains client background color.
virtual COLORREF | FillPropertyButton (CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem)
Fills a specified tab button.
virtual void | FillNavigateButton (CDC *pDC, CXTPTabManagerNavigateButton *pButton, CRect &rc)
Fills a specified tab naGroupOuterMarginvigation button.
- Public Member Functions inherited from CXTPTabPaintManagerColorSet
CXTPTabPaintManagerColorSet ()
Constructs a CXTPTabPaintManagerColorSet object.
virtual | ~CXTPTabPaintManagerColorSet ()
Destroys a CXTPTabPaintManagerColorSet object, handles cleanup and deallocation.
virtual void | FillHeader (CDC *pDC, CRect rc, CXTPTabManager *pTabManager)
Fills the header of the tab client of a specified tab manager.
virtual COLORREF | FillClient (CDC *pDC, CRect rc, CXTPTabManager *pTabManager)
Fills the tab client area of a specified tab manager.
virtual void | FillStateButton (CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem)
Fills a specified tab button when XTPTabAppearanceStyle is xtpTabAppearanceStateButtons.
virtual void | SelectClipRgn (CDC *pDC, CRect rcClient, CXTPTabManager *pTabManager)
Sets a clipping region for the specified tab client area.
void | GradientFill (CDC *pDC, CRect rc, COLORREF clrLight, COLORREF clrDark, XTPTabPosition position)
Performs a gradient fill of a rectangle with a color that smoothly fades from top to bottom.
virtual BOOL | IsAppThemed () const
Determines if Windows XP themes are enabled and if a Windows XP theme is currently used.

Additional Inherited Members

- Public Attributes inherited from CXTPTabPaintManagerColorSet
CXTPPaintManagerColorGradient | m_clrHeaderFace
Color set of the tab header background.
CXTPPaintManagerColorGradient m_clrAutoHideFace
Color set of the auto-hide panel background.
CXTPPaintManagerColor | m_clrFrameBorder
Color of the border placed around the tab buttons and the tab client.
CXTPPaintManagerColor m_clrControlFace
Color of the control foreground.
CXTPPaintManagerColor | m_clrPaneFace
Color of the control pane foreground.
CXTPPaintManagerColor | m_clrBorderHighlight
Color of the highlight border.
CXTPPaintManagerColor | m_clrTabClientBack
Background color for the tab client area.
CXTPPaintManagerColor | m_clrTabClientBorder
Border color for the tab client area.
CXTPPaintManagerColor m_clrButtonNormal
Color of normal tabs.
CXTPPaintManagerColor | m_clrButtonPressed
Tab pressed button color.
CXTPPaintManagerColor | m_clrButtonHighlighted
Tab button color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonHighlightedClose
Tab close button color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonBorderHighlighted
Tab button border color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonBorderTabContext1
Tab button border color with tab context.
CXTPPaintManagerColor | m_clrButtonBorderTabContext2
Tab button border color with tab context.
CXTPPaintManagerColor | m_clrButtonBorderKeyTips
Tab button border color when ALT button is pressed.
CXTPPaintManagerColor | m_clrButtonSelected
Color of the currently selected tab.
CXTPPaintManagerColor | m_clrButtonSelectedPressed
Color of the currently selected tab when pressed.
CXTPPaintManagerColor | m_clrButtonSelectedHighlighted
Color of the currently selected tab when highlighted.
CXTPPaintManagerColor | m_clrButtonBorder
Tab button border (edge) color.
CXTPPaintManagerColor | m_clrButtonBorderHot
Tab button highlight or pressed border (edge) color.
CXTPPaintManagerColor m_clrTextNormal
Color of text in a normal tab.
CXTPPaintManagerColor m_clrTextPressed
Color of text in a "pressed" tab button.
CXTPPaintManagerColor | m_clrTextHighlight
Color of text on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrTextHighlightClose
Color of close button text on mouse over when hot tracking is enabled.
CXTPPaintManagerColor m_clrTextSelected
Color of text in a "selected" tab button.
CXTPPaintManagerColor m_clrTextSelectedPressed
Color of text in a "pressed" tab button.
CXTPPaintManagerColor | m_clrTextSelectedHighlighted
Color of text for tabs in all non-active groups of tabs in MDITabClient.
CXTPPaintManagerColor m_clrTextDisabled
Color of text when a tab is disabled.
CXTPPaintManagerColor | m_clrActiveFilesGlyph
Color of navigation button.
CXTPPaintManagerColor | m_clrActiveFilesGlyphHighlighted
Color of highlighted navigation button.
CXTPPaintManagerColor | m_clrActiveFilesGlyphPressed
Color of selected navigation button.
CXTPPaintManagerColor | m_clrActiveFilesBack
Color of highlighted navigation button background.
CXTPPaintManagerColor | m_clrActiveFilesBackHighlighted
Color of navigation button background.
CXTPPaintManagerColor | m_clrActiveFilesBackPressed
Color of selected navigation button background.
COLORSET_TAB_STATEBUTTON | m_csStateButton
Color set of state button style tabs.
COLORSET_TAB_PROPERTYPAGE | m_csPropertyPage
Color set of visual studio style tabs.
COLORSET_TAB_PROPERTYPAGE2003 | m_csPropertyPage2003
Color set of Office 2003 style tabs.
COLORSET_TAB_EXCEL | m_csExcelSelected
Color set of selected (focused) Excel style tabs.
COLORSET_TAB_EXCEL | m_csExcelNormal
Color set of normal Excel style tabs.
- Protected Member Functions inherited from CXTPTabColorSetVisualStudio2015
- Protected Attributes inherited from CXTPTabColorSetVisualStudio2015
- Protected Attributes inherited from CXTPTabPaintManagerColorSet
CXTPTabPaintManager * | m_pPaintManager
Self paint manager pointer.

Detailed Description

CXTPTabColorSetVisualStudio2022 implements a Visual Studio 2022 tab color set.

Member Function Documentation

◆ RefreshMetrics()

virtual void RefreshMetrics ( )
virtual

Refreshes the visual metrics of the tabs.

Override this method to change the colors of the color members.

All of the color members are refreshed when this method is called.

Reimplemented from CXTPTabColorSetVisualStudio2019.

The documentation for this class was generated from the following file:
  • XTPTabColorSetVisualStudio2022.h


Toolkit Pro: CXTPTabControl Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPTabControl Class Reference

CXTPTabControl is used to draw an enhanced tab control with Office 2003, Visual Studio, or Win XP tabs. More...

Inheritance diagram for CXTPTabControl:
[legend]

Public Member Functions

CXTPTabControl ()
Constructs a CXTPTabControl object.
virtual | ~CXTPTabControl ()
Destroys a CXTPTabControl object, handles cleanup and deallocation.
CXTPTabManagerItem * | InsertItem (int nItem, LPCTSTR lpszItem, HWND hwndChild=NULL, int nImage=-1, CXTPTabManagerItem *pAddItem=NULL)
Inserts a tab at a specified index.
BOOL | Create (DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID)
Creates the tab control.
virtual CXTPTabPaintManager * | GetPaintManager () const
Gets the tab paint manager.
virtual void | SetPaintManager (CXTPTabPaintManager *pPaintManager)
Sets the tab paint manager.
virtual void | Reposition ()
Recalculates the layout of the tab manager and then repositions itself.
virtual void | RedrawControl (LPCRECT lpRect, BOOL bAnimate)
This method is called when the visual properties of the tabs are changed (e.g.
virtual void | SetSelectedItem (CXTPTabManagerItem *pItem)
Selects a specified tab.
void | OnItemClick (CXTPTabManagerItem *pItem)
This method is called when a tab button is clicked to select the tab item that was clicked.
virtual BOOL | DrawIcon (CDC *pDC, CPoint pt, CXTPTabManagerItem *pItem, BOOL bDraw, CSize &szIcon) const
This method is called when the icon of a tab must be redrawn (e.g.
void | SetImageList (CImageList *pImageList)
Sets the icons of the tabs.
CXTPImageManager * | GetImageManager () const
Gets the image manager containing the icons of the tabs.
void | SetImageManager (CXTPImageManager *pImageManager)
Sets the image manager to contain the icons of the tabs.
CXTPToolTipContext * | GetToolTipContext () const
Gets the tooltip context.
void | EnableToolTips (XTPTabToolTipBehaviour behaviour=xtpTabToolTipAlways)
Sets the behaviour for tooltips.
void | AdjustRect (BOOL bLarger, LPRECT lpRect) const
This method will either calculate the window rectangle of a tab control when provided with a display rectangle or vice versa.
void | SetLockRedraw (BOOL bLockRedraw)
Locks/unlocks redrawing controls.
virtual void | SetFocusedItem (CXTPTabManagerItem *pItem)
Sets the focused item.
- Public Member Functions inherited from CXTPTabManager
CXTPTabManager ()
Constructs a CXTPTabManager object.
virtual | ~CXTPTabManager ()
Destroys a CXTPTabManager object, handles cleanup and deallocation.
CXTPTabManagerItem * | GetItem (int nIndex) const
Retrieves a tab item by its index.
BOOL | DeleteItem (int nItem)
Deletes a tab item by its index.
void | DeleteAllItems ()
Deletes all tab items from the tab manager.
int | GetItemCount () const
Gets the number of tab items in the tab manager.
virtual CString | GetItemCaption (const CXTPTabManagerItem *pItem) const
Retrieves the caption text of a specified tab item.
virtual HICON | GetItemIcon (const CXTPTabManagerItem *pItem) const
Retrieves the icon of a specified tab item.
virtual COLORREF | GetItemColor (const CXTPTabManagerItem *pItem) const
Retrieves the tab button color of a specified tab item.
virtual CString | GetItemTooltip (const CXTPTabManagerItem *pItem) const
Retrieves the tooltip of a specified tab item.
virtual void | OnItemsChanged ()
This method is called when tab items are changed (i.e.
void | SetCurSel (int nIndex)
Sets the index for the currently selected tab item within the collection of tab items.
int | GetCurSel () const
Gets the index of the currently selected tab item within the collection of tab items.
CXTPTabManagerItem * | GetSelectedItem () const
Gets the currently selected tab item.
CXTPTabManagerItem * | HitTest (CPoint point) const
Determines which tab is at a specified point, if any.
CXTPTabManagerNavigateButton * | HitTestNavigateButton (CPoint point, BOOL bHeaderOnly, int *pnIndex=NULL) const
Determines which navigation button is at a specified point, if any.
virtual void | GetItemMetrics (CSize *szNormal, CSize *szMin=NULL, CSize *szMax=NULL) const
Gets the minimum, maximum, and normal lengths of tab buttons.
void | SetItemMetrics (CSize szNormal, CSize szMin=CSize(0, 0), CSize szMax=CSize(0, 0))
Sets the minimum, maximum, and normal lengths for tab buttons.
void | MoveItem (CXTPTabManagerItem *pItem, int nIndex)
Sets the position of a specified tab item.
void | ShowCloseItemButton (XTPTabNavigateButtonFlags bCloseItemButton=xtpTabNavigateButtonAlways)
Call this member to show close button for each tab.
virtual int | GetItemsLength () const
Gets the total width of all of the tab buttons.
int | GetRectLength (CRect rc) const
Gets the length of the bounding rectangle of the tab client header area.
CXTPTabManagerNavigateButton * | FindNavigateButton (UINT nID) const
Retrieves a specified tab navigation button (i.e.
BOOL | IsHorizontalPosition () const
Determines if the tabs are positioned horizontally.
int | GetHeaderOffset () const
Gets the scroll offset of the tabs in the tab header.
void | SetHeaderOffset (int nOffset)
Sets the scroll offset for the tabs in the tab header.
void | EnsureVisible (CXTPTabManagerItem *pItem)
Ensures that a specified tab is visible.
virtual BOOL | IsAllowReorder () const
Determines if tabs are allowed to be reordered.
virtual void | SetAllowReorder (BOOL bAllowReorder)
Specifies if tabs should be allowed to be reordered.
virtual BOOL | IsDrawStaticFrame () const
Determines if a static frame is used.
void | EnableTabThemeTexture (HWND hWnd, BOOL bEnable=TRUE)
Enables/disables Windows XP themed back color.
CXTPTabPaintManagerColorSet * | SetColor (XTPTabColorStyle tabColor)
Applies one of the "built-in" color sets for the tabs.
CXTPTabPaintManagerColorSet * | SetColorSet (CXTPTabPaintManagerColorSet *pColorSet)
Applies a custom color set for the tabs.
CXTPTabPaintManagerTheme * | SetAppearance (XTPTabAppearanceStyle tabAppearance)
Applies one of the "built-in" appearance sets for the tabs.
CXTPTabPaintManagerTheme * | SetAppearanceSet (CXTPTabPaintManagerTheme *pAppearanceSet)
Applies a custom appearance set for the tabs.
CXTPTabPaintManagerTheme * | GetAppearanceSet () const
Gets the currently applied custom appearance set.
CXTPTabPaintManagerColorSet * | GetColorSet () const
Gets the currently applied custom color set.
XTPTabAppearanceStyle | GetAppearance () const
Gets the currently applied "built-in appearance set.
XTPTabColorStyle | GetColor () const
Gets the currently applied "built-in" color set.
void | SetPosition (XTPTabPosition tabPosition)
Sets the tab position.
void | SetLayoutStyle (XTPTabLayoutStyle tabLayout)
Sets the tab layout style.
virtual XTPTabPosition | GetPosition () const
Gets the tab position.
XTPTabLayoutStyle | GetLayout () const
Gets the tab layout style.
void | ShowIcons (BOOL bShowIcons)
Shows/hides tab icons.
void | SetActive (BOOL bActive)
Specifies if this tab group should be active/inactive.
BOOL | IsActive () const
Determines if this tab group is active/inactive.
CRect | GetControlRect () const
Gets the bounding rectangle of the tab manager control area.
CRect | GetClientRect () const
Gets the bounding rectangle of the tab client area.
CRect | GetHeaderRect () const
Gets the bounding rectangle of the tab client header area.
int | GetRowCount () const
Gets the number of rows of tabs in the tab control.
virtual void | OnScrollHeader (BOOL bRight)
This method is called when the user presses either the left or right navigation buttons.
CXTPTabManagerNavigateButtons * GetNavigateButtons ()
Gets the collection of navigation buttons.
CXTPTabManagerItem * | FindNextFocusable (int nIndex, int nDirection) const
Retrieves the next/previous focusable tab item from a specified index.
void | PerformMouseMove (HWND hWnd, CPoint pt)
This method is called when the mouse cursor moves.
BOOL | PerformClick (HWND hWnd, CPoint pt, BOOL bNoItemClick=FALSE)
This method is called when the user presses the left mouse button.
virtual INT_PTR | PerformToolHitTest (HWND hWnd, CPoint point, TOOLINFO *pTI) const
Determines which tab is beneath the mouse cursor, if any, and stores the tooltip information of the tab within a TOOLINFO structure.
virtual BOOL | PerformKeyDown (HWND hWnd, UINT nChar)
This method is called to process a WM_KEYDOWN event for the tab manager.
virtual BOOL | DrawParentBackground (CDC *pDC, CRect rc)
Draws the parent background under the tab control.
int | GetNavigateButtonCount () const
Gets the total number of tab navigation buttons within the collection of tab navigation buttons.
CXTPTabManagerNavigateButton * | GetNavigateButton (int nIndex) const
Retrieves the tab navigation button at a specified index within the collection of tab navigation buttons.
void | EnableMarkup (BOOL bEnable=TRUE)
Enables/disables markup for the tab captions.
virtual CXTPMarkupContext * | GetMarkupContext () const
Gets the markup context.
- Public Member Functions inherited from CXTPTabManagerAtom
virtual void | OnPropertyChanged ()
This method is called when a property of the tab paint manager is changed.

Protected Member Functions

void | OnNavigateButtonClick (CXTPTabManagerNavigateButton *pButton)
This method is called when a tab navigation button is clicked.
virtual BOOL | HeaderHasFocus () const
The implementation should return TRUE if the header has focus or FALSE otherwise.
virtual void | OnNavigateButtonClick (UINT nID)
This method is called when a tab navigation button is clicked.
- Protected Member Functions inherited from CXTPTabManager
virtual BOOL | IsNavigateButtonAutomaticVisible (CXTPTabManagerNavigateButton *pButton)
Determines if a specified tab navigation button is automatically displayed.
virtual BOOL | IsNavigateButtonVisible (CXTPTabManagerNavigateButton *pButton)
Determines if a specified tab navigation button is visible.
virtual BOOL | OnBeforeItemClick (CXTPTabManagerItem *pItem)
This method is called before a tab item is clicked.
virtual void | ReOrder (HWND hWnd, CPoint pt, CXTPTabManagerItem *pItem)
This method is called when a tab item is clicked and dragged within the tab header.
virtual void | OnSwitchItem (CXTPTabManagerItem *pItem1, CXTPTabManagerItem *pItem2)
This method is called by ReOrder when two tab items are switched.
virtual void | OnItemOrderChanged (CXTPTabManagerItem *pItem, int nOldIndex, int nNewIndex)
This method is called by ReOrder when a tab item's position is changed.
virtual BOOL | IsMouseLocked () const
Determines if the MouseMove event has been disabled.
CXTPTabManagerItem * | AddItem (int nItem, CXTPTabManagerItem *pItem=NULL)
Adds a specified tab item to the collection of tab items.
void | TrackClick (HWND hWnd, CPoint pt, CXTPTabManagerItem *pItem)
Activates and tracks a specified tab item on mouse click.
virtual void | OnItemHandleChanged (CXTPTabManagerItem *pItem, HWND hwndOld, HWND hwndNew)
This method is called when the handle of a tab item is changed.
- Protected Member Functions inherited from CXTPTabManagerAtom
virtual | ~CXTPTabManagerAtom ()
Destroys a CXTPTabManagerAtom object, handles cleanup and deallocation.

Additional Inherited Members

- Protected Attributes inherited from CXTPTabManager
CXTPTabManagerItem * m_pSelected
Tab currently selected (i.e.
CXTPTabManagerItem * m_pHighlighted
Tab currently highlighted (i.e.
CXTPTabManagerItem * | m_pPressed
Pointer to the currently pressed tab.
CXTPTabManagerNavigateButton * | m_pHighlightedNavigateButton
Pointer to highlighted navigate button.
int | m_nHeaderOffset
Scroll offset, this is how much the tabs in the tab header have been scrolled using the left and right tab navigation buttons.
BOOL | m_bAllowReorder
TRUE to allow tabs to be reordered.
BOOL | m_bActive
TRUE if the MDITabClient tab group is active.
XTPTabNavigateButtonFlags | m_bCloseItemButton
TRUE to show the close button for tabs.
CRect | m_rcHeaderRect
Bounding rectangle of the tab header area.
CRect | m_rcControl
Bounding rectangle of the tab manager control.
CArray< CXTPTabManagerItem *, CXTPTabManagerItem * > | m_arrItems
Bounding rectangle of the tab client area.
CXTPTabManagerNavigateButtons | m_arrNavigateButtons
Collection of tab navigation buttons for this tab manager.
CRowIndexer * | m_pRowIndexer
Row indexer.
int | m_nScrollDelta
Scroll header delta.
CXTPMarkupContext * | m_pMarkupContext
Markup context of the tab manager.

Detailed Description

CXTPTabControl is used to draw an enhanced tab control with Office 2003, Visual Studio, or Win XP tabs.

See also
Create, CXTPTabManager::SetColor, CXTPTabManager::SetAppearance

Member Function Documentation

◆ AdjustRect()

void AdjustRect | ( | BOOL | bLarger,
 |  | LPRECT | lpRect ) const

This method will either calculate the window rectangle of a tab control when provided with a display rectangle or vice versa.

Parameters
bLarger | Indicates which operation to perform. If the value of this parameter is TRUE, then lpRect specifies a display rectangle and receives the corresponding window rectangle. If the value of this parameter is FALSE, then lpRect specifies a window rectangle and receives the corresponding display rectangle.
lpRect | Pointer to a RECT structure that contains the given rectangle and receives the calculated rectangle.

◆ Create()

AFX_INLINE BOOL Create | ( | DWORD | dwStyle,
 |  | const RECT & | rect,
 |  | CWnd * | pParentWnd,
 |  | UINT | nID )

Creates the tab control.

Parameters
dwStyle | Style of the tab control.
rect | Reference to the size of the tab control.
pParentWnd | Pointer to the parent of the tab control.
nID | Identifier of the tab control.
Returns
TRUE if successful, otherwise FALSE.
See also
CXTPTabControl::CXTPTabControl, GetPaintManager, CXTPTabManager::SetPosition, CXTPTabManager::SetLayout, GetImageManager

◆ DrawIcon()

virtual BOOL DrawIcon | ( | CDC * | pDC,
 |  | CPoint | pt,
 |  | CXTPTabManagerItem * | pItem,
 |  | BOOL | bDraw,
 |  | CSize & | szIcon ) const
 virtual

This method is called when the icon of a tab must be redrawn (e.g.

on mouse-over).

Parameters
pDC | Pointer to the destination device context.
pt | Point that specifies the location of the image.
pItem | Pointer to a CXTPTabManagerItem object to draw the icon on.
bDraw | TRUE if the icon must be drawn/redrawn (i.e. the icon size changed), FALSE otherwise.
szIcon | Reference to the size of the tab icon.

This method is overridden by its descendants.

This method must be overridden in derived classes.

Returns
TRUE if the icon was drawn successfully, otherwise FALSE.

Implements CXTPTabManager.

◆ EnableToolTips()

void EnableToolTips ( XTPTabToolTipBehaviour behaviour = xtpTabToolTipAlways )

Sets the behaviour for tooltips.

Parameters
behaviour Tooltips behaviour to be set. See the Remarks section for available flags.

The behaviour parameter can be one of the following: xtpTabToolTipNever: Never show tooltips for tabs. xtpTabToolTipAlways: Always show tooltips for tabs. xtpTabToolTipShrinkedOnly: Only show tooltips if the tab was shrinked (see xtpTabLayoutSizeToFit layout).

◆ GetImageManager()

AFX_INLINE CXTPImageManager * GetImageManager ( ) const

Gets the image manager containing the icons of the tabs.

Returns
A pointer to the image manager containing the icons of the tabs.

Example:

m_wmdTabControl.GetImageManager()->SetIcons(IDR_MAINFRAME);

◆ GetPaintManager()

AFX_INLINE CXTPTabPaintManager * GetPaintManager ( ) const
virtual

Gets the tab paint manager.

The tab paint manager is used to customize the appearance of both CXTPTabManagerItem objects and the tab manager (i.e. tab colors, styles, etc.).

This method must be overridden in derived classes.

Returns
A pointer to the tab paint manager.

Implements CXTPTabManager.

◆ GetToolTipContext()

AFX_INLINE CXTPToolTipContext * GetToolTipContext ( ) const

Gets the tooltip context.

Returns
A pointer to the tooltip context.

◆ HeaderHasFocus()

virtual BOOL HeaderHasFocus ( ) const
protectedvirtual

The implementation should return TRUE if the header has focus or FALSE otherwise.

Returns
TRUE if the header has focus, otherwise FALSE.

Reimplemented from CXTPTabManager.

◆ InsertItem()

CXTPTabManagerItem * InsertItem | ( | int | nItem,
 |  | LPCTSTR | lpszItem,
 |  | HWND | hwndChild = NULL,
 |  | int | nImage = -1,
 |  | CXTPTabManagerItem * | pAddItem = NULL )

Inserts a tab at a specified index.

Parameters
nItem | Index of the new tab.
lpszItem | Caption of the new tab.
hwndChild | Handle of the object to be displayed in the tab (e.g. a dialog page).
nImage | Identifier of the image resource to display in the tab if icons are displayed.
pAddItem | Pointer to the item to insert, or NULL to create and add a default item.
Returns
A pointer to the newly inserted CXTPTabManagerItem object.

◆ OnItemClick()

void OnItemClick ( CXTPTabManagerItem * pItem )
virtual

This method is called when a tab button is clicked to select the tab item that was clicked.

Parameters
pItem Pointer to the tab item that was clicked.
See also
PerformClick

Reimplemented from CXTPTabManager.

◆ OnNavigateButtonClick() [1/2]

void OnNavigateButtonClick ( CXTPTabManagerNavigateButton * pButton )
protectedvirtual

This method is called when a tab navigation button is clicked.

Parameters
pButton Pointer to the tab navigation button that was clicked.

This method is overridden in CXTPTabClientWnd::CWorkspace and CXTPTabControl to capture when the tab navigation close "x" button is pressed and deletes the tab.

This member is called after CXTPTabManagerNavigateButton::PerformClick.

See also
CXTPTabManagerNavigateButton::PerformClick, XTPTabNavigateButton

Reimplemented from CXTPTabManager.

◆ OnNavigateButtonClick() [2/2]

AFX_INLINE void OnNavigateButtonClick ( UINT nID )
protectedvirtual

This method is called when a tab navigation button is clicked.

Parameters
nID Button identifier. Can be one of the values listed in the Remarks section.

Standard identifiers of buttons are listed below: xtpTabNavigateButtonLeft: Left tab navigation button. xtpTabNavigateButtonRight: Right tab navigation button. xtpTabNavigateButtonClose: Close tab navigation button.

This method is overridden in CXTPTabClientWnd::CWorkspace and CXTPTabControl to capture when the tab navigation close "x" button is pressed and deletes the tab.

This member is called after CXTPTabManagerNavigateButton::PerformClick.

See also
CXTPTabManagerNavigateButton::PerformClick, XTPTabNavigateButton

Reimplemented from CXTPTabManager.

◆ RedrawControl()

virtual void RedrawControl | ( | LPCRECT | lpRect,
 |  | BOOL | bAnimate )
 virtual

This method is called when the visual properties of the tabs are changed (e.g.

color, mouse-over, on-click).

Parameters
lpRect | Rectangular area of the window that is invalid.
bAnimate | TRUE to animate changes in the bounding rectangle.

This method must be overridden in derived classes.

Implements CXTPTabManager.

◆ Reposition()

virtual void Reposition ( )
virtual

Recalculates the layout of the tab manager and then repositions itself.

This method must be overridden in derived classes.

Implements CXTPTabManagerAtom.

◆ SetFocusedItem()

virtual void SetFocusedItem ( CXTPTabManagerItem * pItem )
virtual

Sets the focused item.

Parameters
pItem Pointer to the item to set.
See also
SetSelectedItem

Reimplemented from CXTPTabManager.

◆ SetImageList()

void SetImageList ( CImageList * pImageList )

Sets the icons of the tabs.

Parameters
pImageList Pointer to an image list containing the icons of the tabs.

It is recommended to use both the GetImageManager and CXTPImageManager::SetIcons methods to add icons.

◆ SetImageManager()

void SetImageManager ( CXTPImageManager * pImageManager )

Sets the image manager to contain the icons of the tabs.

Parameters
pImageManager Pointer to the image manager to be set.

◆ SetLockRedraw()

void SetLockRedraw ( BOOL bLockRedraw )

Locks/unlocks redrawing controls.

Parameters
bLockRedraw TRUE to lock redrawing controls, FALSE to unlock redrawing controls.

The bLockRedraw parameter should be set to TRUE when you want to add many items, but do not want CXTPTabControl::Reposition to be called each time an item is added.

◆ SetPaintManager()

virtual void SetPaintManager ( CXTPTabPaintManager * pPaintManager )
virtual

Sets the tab paint manager.

Parameters
pPaintManager Pointer to the tab paint manager to be set.

The tab paint manager is used to customize the appearance of both CXTPTabManagerItem objects and the tab manager (i.e. tab colors, styles, etc.).

Reimplemented from CXTPTabManager.

◆ SetSelectedItem()

virtual void SetSelectedItem ( CXTPTabManagerItem * pItem )
virtual

Selects a specified tab.

Parameters
pItem Pointer to the tab to be selected.

Reimplemented from CXTPTabManager.

The documentation for this class was generated from the following file:
  • XTPTabControl.h


Toolkit Pro: CXTPTabCtrl Class Reference

Public Member Functions | List of all members
CXTPTabCtrl Class Reference

CXTPTabCtrl is a multiple inheritance class derived from CTabCtrl and CXTPTabCtrlBase. More...

Public Member Functions

CXTPTabCtrl ()
Constructs a CXTPTabCtrl object.
virtual | ~CXTPTabCtrl ()
Destroys a CXTPTabCtrl object, handles cleanup and deallocation.
virtual BOOL | EnableToolTips (BOOL bEnable)
Call this member function to enable/disable tooltip usage.

Detailed Description

CXTPTabCtrl is a multiple inheritance class derived from CTabCtrl and CXTPTabCtrlBase.

It is used to create a CXTPTabCtrl class object. See CXTPTabCtrlBase for additional functionality.

Member Function Documentation

◆ EnableToolTips()

virtual BOOL EnableToolTips ( BOOL bEnable )
virtual

Call this member function to enable/disable tooltip usage.

Parameters
bEnable TRUE to enable tooltip usage, FALSE to disable.
Returns
TRUE if the tooltip control was found and updated, otherwise FALSE.
The documentation for this class was generated from the following file:
  • XTPTabCtrl.h


Toolkit Pro: CXTPTabCtrlButton Class Reference

List of all members
CXTPTabCtrlButton Class Reference

CXTPTabCtrlButton is a standalone structure class. More...

Detailed Description

CXTPTabCtrlButton is a standalone structure class.

It is used internally in the CXTPTabCtrlButtons class.

The documentation for this class was generated from the following file:
  • XTPTabCtrlButtons.h


Toolkit Pro: CXTPTabCtrlButtons Class Reference

List of all members
CXTPTabCtrlButtons Class Reference

CXTPTabCtrlButtons is a CWnd derived class. More...

Detailed Description

CXTPTabCtrlButtons is a CWnd derived class.

It is used internally in the CXTPTabBase class.

The documentation for this class was generated from the following file:
  • XTPTabCtrlButtons.h


Toolkit Pro: CXTPTabExBase Class Reference

Public Member Functions | Public Attributes | Protected Member Functions | Protected Attributes | List of all members
CXTPTabExBase Class Reference

CXTPTabExBase is a standalone base class. More...

Inheritance diagram for CXTPTabExBase:
[legend]

Public Member Functions

CXTPTabExBase ()
Constructs a CXTPTabExBase object.
virtual | ~CXTPTabExBase ()
Destroys a CXTPTabExBase object, handles cleanup and deallocation.
void | EnableRedraw (BOOL bRedraw)
Call this member function to enable/disable the control from being redrawn or updated.
virtual void | InitializeFont ()
This member function is called to initialize the font for the tab control associated with this view.
virtual CToolTipCtrl * | GetTips ()
This member function retrieves the handle of the tooltip control associated with the tab control.
virtual void | SetTips (CToolTipCtrl *pWndTip)
Call this function to assign a tooltip control to the tab control.
virtual void | AddToolTip (UINT nIDTab, LPCTSTR lpszText)
Call this function to register a tab with the tooltip control so that the information stored in the tooltip is displayed when the cursor is on the tab.
virtual void | UpdateToolTip (int nIDTab, LPCTSTR lpszText)
Call this function to update the tooltip text for the specified tab.
virtual void | UpdateToolTip (CRuntimeClass *pViewClass, LPCTSTR lpszText)
Call this function to update the tooltip text for the specified tab.
virtual void | ResetToolTips ()
This member function is called to reset the values for the tooltip control based upon the information stored for each tab.
virtual BOOL | EnableToolTipsEx (BOOL bEnable)
Call this member function to enable/disable tooltip usage.
virtual BOOL | AddView (LPCTSTR lpszLabel, CView *pView, int iIndex=-1, int iIconIndex=-1, LPARAM lParam=0)
Call this member function to add a view to the tab control associated with this view.
virtual BOOL | AddView (LPCTSTR lpszLabel, CRuntimeClass *pViewClass, CDocument *pDoc=NULL, CCreateContext *pContext=NULL, int iIndex=-1, int iIconIndex=-1, LPARAM lParam=0)
Call this member function to add a view to the tab control associated with this view.
virtual BOOL | AddControl (LPCTSTR lpszLabel, CWnd *pWnd, int iIndex=-1, int iIconIndex=-1, LPARAM lParam=0)
This member function is called to add a control to the tab control associated with this view.
virtual CWnd * | GetView (int nView)
This member function retrieves a pointer to a view from the specified runtime class.
virtual CWnd * | GetView (CRuntimeClass *pViewClass)
This member function retrieves a pointer to a view from the specified runtime class.
virtual CWnd * | GetActiveView ()
This member function retrieves a pointer to the active view associated with the selected tab.
virtual void | ActivateView (CWnd *pTabView)
This member function is called to activate the specified view and deactivate all remaining views.
virtual void | SetActiveView (int nActiveTab)
This member function will set a view active based on the specified runtime class.
virtual void | SetActiveView (CWnd *pTabView)
This member function will set a view active based on the specified runtime class.
virtual void | SetActiveView (CRuntimeClass *pViewClass)
This member function will set a view active based on the specified runtime class.
virtual void | DeleteView (int nView, BOOL bDestroyWnd=TRUE)
This member function will remove a view based on the specified tab index.
virtual void | DeleteView (CWnd *pView, BOOL bDestroyWnd=TRUE)
This member function will remove a view based on the specified tab index.
virtual void | DeleteView (CRuntimeClass *pViewClass, BOOL bDestroyWnd=TRUE)
This member function will remove a view based on the specified tab index.
virtual LPCTSTR | GetViewName (int nView)
This member function will return the name for a view based on the tab index.
virtual LPCTSTR | GetViewName (CRuntimeClass *pViewClass)
This member function will return the name for a view based on the tab index.
virtual void | RecalcLayout ()
This member function is called when the tab control is resized.
virtual BOOL | Defer (HDWP &hDWP, CWnd *pView)
Helper methods.
virtual void | ResizeTabView (CWnd *pView)
Call this member function to resize the tab view specified by 'pView'.
virtual void | RemoveListItem (POSITION pos, BOOL bDestroyWnd=TRUE)
This member function is used by the tab control bar to remove an item from the tab view list.
virtual BOOL | RemoveAllTabs (BOOL bDestroyWnd=TRUE)
Call this member function to remove all tabs, including all associated views.
virtual int | GetTabFromPoint (CPoint point)
Call this member function to retrieve the tab index from the current cursor position.
virtual BOOL | IsChildView (CWnd *pView)
Call this member function to see if the specified CWnd object is a child of the tab control.
BOOL | SetTabText (int nTab, LPCTSTR lpszLabel)
Call this member function to set the text for the specified tab.
BOOL | SetTabText (CWnd *pView, LPCTSTR lpszLabel)
Call this member function to set the text for the specified tab.
BOOL | SetTabText (CRuntimeClass *pViewClass, LPCTSTR lpszLabel)
Call this member function to set the text for the specified tab.
CWnd * | NextView ()
This member function is called to activate the next view in the tab control.
CWnd * | PrevView ()
This member function is called to activate the previous view in the tab control.
void | SetAutoCondense (BOOL bEnable)
Call this member function to enable/disable the tab auto-condensing mode.
BOOL | GetAutoCondense ()
This member function returns the state of the tab control's auto-condense mode.
virtual BOOL | ModifyTabStyle (DWORD dwRemove, DWORD dwAdd, UINT nFlags=0)
This member function will modify the style for the tab control associated with this view and set the appropriate font depending on the tab's orientation.
CView * | GetLastKnownChildView ()
This member function is used to get the last known view that belongs to the frame.
virtual void | SetMenuID (UINT popupMenuID, int nPos=0)
This member function is used to set the resource ID for the pop-up menu used by the tab control.
virtual UINT | GetMenuID ()
This member function returns the menu resource associated with the tab control.
virtual void | SendInitialUpdate (BOOL bInitialUpdate)
Call this member function to allow a WM_INITIALUPATE message to be sent to views after creation.
- Public Member Functions inherited from CXTPTabBase
CXTPTabBase ()
Constructs a CXTPTabBase object.
virtual | ~CXTPTabBase ()
Destroys a CXTPTabBase object, handles cleanup and deallocation.
CTabCtrl * | GetTabCtrlImpl ()
Retrieves a pointer to the associated tab control.
CXTPTabCtrlButtons * GetButtons ()
Retrieves a pointer to the tab control navigation button object.
virtual void | GetChildRect (CRect &rcChild) const
This member function copies the child coordinates of the CTabCtrl client area into the object referenced by 'rcChild'.
void | ShowNavButtons (DWORD dwFlags)
Call this member function to set the visibility of the navigation buttons.
BOOL | SetTheme (XTPControlTheme eTheme)
Call this member to switch the visual theme of the control.
CXTPTabBaseTheme * GetTheme ()
Call this member function to get a pointer to the currently selected theme.

Public Attributes

CList< CXTPTcbItem *, CXTPTcbItem * > | m_tcbItems
Template list containing tab information.
- Public Attributes inherited from CXTPTabBase
bool | m_bBoldFont
true to set the selected tab font to bold.
bool | m_bXPBorder
true to draw an XP border around the tab child window.
BOOL | m_bAutoCondensing
TRUE for auto-condensing tabs.

Protected Member Functions

virtual void | OnThemeChanged ()
This member function is called whenever the theme has changed.
virtual void | OnSelChanging ()
Override this member function to handle a TCN_SELCHANGING event in your derived class to provide additional functionality.
virtual void | OnSelChange ()
Override this member function to handle a TCN_SELCHANGE event in your derived class to provide additional functionality.
BOOL | UpdateTabLabel (int nTab, CXTPTcbItem *pMember, LPCTSTR lpszLabel)
This member function is called to set the tooltip and tab text for the specified tab.
virtual CWnd * | CreateTabView (CRuntimeClass *pViewClass, CDocument *pDocument, CCreateContext *pContext)
This member function creates the CWnd object that is associated with a tab control item.
int | CalculateTabWidth (CDC *pDC, CString &sLabel, bool bHasIcon)
This member function is used internally by the tab control to calculate the width of a tab based on its label text.
void | Condense ()
This member function is used internally by the tab control to shrink, or un-shrink, tabs based on the control's width and the state of the auto-condensation mode.
virtual BOOL | Init ()
This member function is called by the CXTPTabExBase class to perform initialization when the window is created or sub-classed.
- Protected Member Functions inherited from CXTPTabBase
virtual void | RefreshMetrics ()
Call this member function to refresh theme colors and redraw the control.
void | ImplAttach (CTabCtrl *pTabCtrl)
Call this member function to associate the tab control with this object.
virtual void | OnAddPadding (CString &strLabelText)
This member function is called by the tab control to add padding to a tab label for use with XP style tabs.

Protected Attributes

int | m_nPos
Index of the pop-up menu contained in the menu.
UINT | m_popupMenuID
Pop-up menu resource ID.
BOOL | m_bInitialUpdate
TRUE to send initial update to views when created.
CWnd * | m_pParentWnd
Pointer to the parent and will equal 'm_pParentFrame' in non-dialog applications.
CView * | m_pLastActiveView
Pointer to the last active view that belongs to the main frame window.
CFrameWnd * | m_pParentFrame
Pointer to the parent frame.
- Protected Attributes inherited from CXTPTabBase
CTabCtrl * | m_pTabCtrl
Pointer to the tab control associated with this object.
CXTPTabCtrlButtons * | m_pNavBtns
Arrow buttons.
CXTPTabBaseTheme * | m_pTheme
Pointer to the current theme object.
BOOL | m_bSubclassed
TRUE if the window was sub-classed.

Detailed Description

CXTPTabExBase is a standalone base class.

It is used to draw an XP style tab control.

Member Function Documentation

◆ ActivateView()

virtual void ActivateView ( CWnd * pTabView )
virtual

This member function is called to activate the specified view and deactivate all remaining views.

Parameters
pTabView CWnd object to make active.

◆ AddControl()

virtual BOOL AddControl | ( | LPCTSTR | lpszLabel,
 |  | CWnd * | pWnd,
 |  | int | iIndex = -1,
 |  | int | iIconIndex = -1,
 |  | LPARAM | lParam = 0 )
 virtual

This member function is called to add a control to the tab control associated with this view.

Parameters
lpszLabel | Pointer to the text for the tab associated with the view.
pWnd | CWnd object associated with the tab.
iIndex | Tab index of where to insert the new view. By default, this parameter is -1 to add to the end.
iIconIndex | Icon index for the tab. If -1, then 'iIndex' is used to determine the index.
lParam | Application defined parameter
Returns
TRUE if successful, otherwise FALSE.

◆ AddToolTip()

virtual void AddToolTip | ( | UINT | nIDTab,
 |  | LPCTSTR | lpszText )
 virtual

Call this function to register a tab with the tooltip control so that the information stored in the tooltip is displayed when the cursor is on the tab.

Parameters
nIDTab | Index of the tab.
lpszText | Pointer to the text for the tool.

◆ AddView() [1/2]

virtual BOOL AddView | ( | LPCTSTR | lpszLabel,
 |  | CRuntimeClass * | pViewClass,
 |  | CDocument * | pDoc = NULL,
 |  | CCreateContext * | pContext = NULL,
 |  | int | iIndex = -1,
 |  | int | iIconIndex = -1,
 |  | LPARAM | lParam = 0 )
 virtual

Call this member function to add a view to the tab control associated with this view.

Parameters
lpszLabel | Pointer to the text for the tab associated with the view.
pViewClass | CView runtime class associated with the tab.
pDoc | CDocument associated with the view.
pContext | Create context for the view.
iIndex | -1 to add to the end.
iIconIndex | Icon index for the tab. If -1, then 'iIndex' is used to determine the index.
lParam | Application defined parameter
Returns
TRUE if successful, otherwise FALSE.

◆ AddView() [2/2]

virtual BOOL AddView | ( | LPCTSTR | lpszLabel,
 |  | CView * | pView,
 |  | int | iIndex = -1,
 |  | int | iIconIndex = -1,
 |  | LPARAM | lParam = 0 )
 virtual

Call this member function to add a view to the tab control associated with this view.

Parameters
lpszLabel | Pointer to the text for the tab associated with the view.
pView | An existing view to be added to the tab control.
iIndex | -1 to add to the end.
iIconIndex | Icon index for the tab. If -1, then 'iIndex' is used to determine the index.
lParam | Application defined parameter
Returns
TRUE if successful, otherwise FALSE.

◆ CalculateTabWidth()

int CalculateTabWidth | ( | CDC * | pDC,
 |  | CString & | sLabel,
 |  | bool | bHasIcon )
 protected

This member function is used internally by the tab control to calculate the width of a tab based on its label text.

Parameters
pDC | Pointer to the current device context.
sLabel | Represents the tab label text.
bHasIcon | Set to true if the tab item has an icon.
Returns
An integer value that represents the width of a tab.

◆ Condense()

void Condense ( )
protected

This member function is used internally by the tab control to shrink, or un-shrink, tabs based on the control's width and the state of the auto-condensation mode.

See SetAutoCondense() for more information.

◆ CreateTabView()

virtual CWnd * CreateTabView | ( | CRuntimeClass * | pViewClass,
 |  | CDocument * | pDocument,
 |  | CCreateContext * | pContext )
 protectedvirtual

This member function creates the CWnd object that is associated with a tab control item.

Parameters
pViewClass | CView runtime class to be created.
pDocument | CDocument associated with view.
pContext | Create context for the view.
Returns
A pointer to the newly created CWnd object, otherwise NULL.

◆ Defer()

virtual BOOL Defer | ( | HDWP & | hDWP,
 |  | CWnd * | pView )
 virtual

Helper methods.

Parameters
hDWP | Handle to a multiple-window position structure that contains size and position information for one or more windows.
pView | A pointer to a CWnd object to be resized.
Returns
TRUE if successful, FALSE otherwise.

◆ DeleteView() [1/3]

virtual void DeleteView | ( | CRuntimeClass * | pViewClass,
 |  | BOOL | bDestroyWnd = TRUE )
 virtual

This member function will remove a view based on the specified tab index.

Parameters
pViewClass | CView runtime class associated with the tab.
bDestroyWnd | TRUE to destroy the list item.

◆ DeleteView() [2/3]

virtual void DeleteView | ( | CWnd * | pView,
 |  | BOOL | bDestroyWnd = TRUE )
 virtual

This member function will remove a view based on the specified tab index.

Parameters
pView | Pointer to the CWnd object associated with the tab.
bDestroyWnd | TRUE to destroy the list item.

◆ DeleteView() [3/3]

virtual void DeleteView | ( | int | nView,
 |  | BOOL | bDestroyWnd = TRUE )
 virtual

This member function will remove a view based on the specified tab index.

Parameters
nView | Tab index of the view.
bDestroyWnd | TRUE to destroy the list item.

◆ EnableRedraw()

void EnableRedraw ( BOOL bRedraw )

Call this member function to enable/disable the control from being redrawn or updated.

Parameters
bRedraw Specifies the state of the redraw flag. If this parameter is TRUE, then the redraw flag is set. If this parameter is FALSE, then the flag is cleared.

◆ EnableToolTipsEx()

virtual BOOL EnableToolTipsEx ( BOOL bEnable )
virtual

Call this member function to enable/disable tooltip usage.

Parameters
bEnable TRUE to enable tooltip usage.
Returns
TRUE if the tooltip control was found and updated, otherwise FALSE.

◆ GetActiveView()

virtual CWnd * GetActiveView ( )
virtual

This member function retrieves a pointer to the active view associated with the selected tab.

Returns
A pointer to the active view, otherwise NULL.

◆ GetAutoCondense()

BOOL GetAutoCondense ( )

This member function returns the state of the tab control's auto-condense mode.

See SetAutoCondense() for a full explanation of this mode.

Returns
TRUE if auto-condense is enabled, or FALSE if it is disabled.

◆ GetLastKnownChildView()

CView * GetLastKnownChildView ( )

This member function is used to get the last known view that belongs to the frame.

Returns
A CView pointer to the last known view.

◆ GetMenuID()

virtual UINT GetMenuID ( )
virtual

This member function returns the menu resource associated with the tab control.

Returns
The resource ID of the menu associated with the tab control.

◆ GetTabFromPoint()

virtual int GetTabFromPoint ( CPoint point )
virtual

Call this member function to retrieve the tab index from the current cursor position.

Parameters
point Pointer to a CPoint object that contains the cursor screen coordinates. Use default for the current cursor position.
Returns
An integer based index of the tab, or -1 if no tab is at the specified 'point'.

◆ GetTips()

virtual CToolTipCtrl * GetTips ( )
virtual

This member function retrieves the handle of the tooltip control associated with the tab control.

The tab control creates a tooltip control if it has the TCS_TOOLTIPS style. You can also assign a tooltip control to a tab control by using the SetToolTips member function.

Returns
The handle of the tooltip control if successful, otherwise NULL.

◆ GetView() [1/2]

virtual CWnd * GetView ( CRuntimeClass * pViewClass )
virtual

This member function retrieves a pointer to a view from the specified runtime class.

Parameters
pViewClass CView runtime class associated with the tab.
Returns
A pointer to a CView object, otherwise NULL.

◆ GetView() [2/2]

virtual CWnd * GetView ( int nView )
virtual

This member function retrieves a pointer to a view from the specified runtime class.

Parameters
nView Tab index.
Returns
A pointer to a CView object, otherwise NULL.

◆ GetViewName() [1/2]

virtual LPCTSTR GetViewName ( CRuntimeClass * pViewClass )
virtual

This member function will return the name for a view based on the tab index.

Parameters
pViewClass CView runtime class associated with the tab.
Returns
A NULL-terminated string that represents the tab item text.

◆ GetViewName() [2/2]

virtual LPCTSTR GetViewName ( int nView )
virtual

This member function will return the name for a view based on the tab index.

Parameters
nView Tab index of the view.
Returns
A NULL-terminated string that represents the tab item text.

◆ Init()

virtual BOOL Init ( )
protectedvirtual

This member function is called by the CXTPTabExBase class to perform initialization when the window is created or sub-classed.

Returns
TRUE if the window was successfully initialized, otherwise FALSE.

Reimplemented from CXTPTabBase.

◆ IsChildView()

virtual BOOL IsChildView ( CWnd * pView )
virtual

Call this member function to see if the specified CWnd object is a child of the tab control.

Parameters
pView A pointer to a CWnd object.
Returns
TRUE if the specified CWnd object is a child of the tab control, otherwise FALSE.

◆ ModifyTabStyle()

virtual BOOL ModifyTabStyle | ( | DWORD | dwRemove,
 |  | DWORD | dwAdd,
 |  | UINT | nFlags = 0 )
 virtual

This member function will modify the style for the tab control associated with this view and set the appropriate font depending on the tab's orientation.

Parameters
dwRemove | Specifies window styles to be removed during style modification.
dwAdd | Specifies window styles to be added during style modification.
nFlags | Flags to be passed to SetWindowPos, or zero if SetWindowPos should not be called. The default is zero. See CWnd::ModifyStyle for more details.
Returns
Nonzero if the style was successfully modified, otherwise zero.

◆ NextView()

CWnd * NextView ( )

This member function is called to activate the next view in the tab control.

Returns
A CWnd pointer to the newly activated view.

◆ OnSelChange()

virtual void OnSelChange ( )
protectedvirtual

Override this member function to handle a TCN_SELCHANGE event in your derived class to provide additional functionality.

See also
OnSelChanging, TCN_XTP_SELCHANGE, TCN_XTP_SELCHANGING

◆ OnSelChanging()

virtual void OnSelChanging ( )
protectedvirtual

Override this member function to handle a TCN_SELCHANGING event in your derived class to provide additional functionality.

See also
OnSelChange, TCN_XTP_SELCHANGE, TCN_XTP_SELCHANGING

◆ OnThemeChanged()

virtual void OnThemeChanged ( )
protectedvirtual

This member function is called whenever the theme has changed.

See also
CXTPControlThemeManagerStyleHost::OnThemeChanged(), CXTPHeaderCtrl::OnThemeChanged()

◆ PrevView()

CWnd * PrevView ( )

This member function is called to activate the previous view in the tab control.

Returns
A CWnd pointer to the newly activated view.

◆ RecalcLayout()

virtual void RecalcLayout ( )
virtual

This member function is called when the tab control is resized.

It is responsible for updating internal structures that are dependent on the control's size.

◆ RemoveAllTabs()

virtual BOOL RemoveAllTabs ( BOOL bDestroyWnd = TRUE )
virtual

Call this member function to remove all tabs, including all associated views.

Parameters
bDestroyWnd TRUE to destroy the window associated with the tab item.
Returns
TRUE if successful, otherwise FALSE.

◆ RemoveListItem()

virtual void RemoveListItem | ( | POSITION | pos,
 |  | BOOL | bDestroyWnd = TRUE )
 virtual

This member function is used by the tab control bar to remove an item from the tab view list.

Parameters
pos | The POSITION value of the item to be removed.
bDestroyWnd | TRUE to destroy the list item.

◆ ResizeTabView()

virtual void ResizeTabView ( CWnd * pView )
virtual

Call this member function to resize the tab view specified by 'pView'.

Parameters
pView A pointer to a CWnd object to be resized.

◆ SendInitialUpdate()

virtual void SendInitialUpdate ( BOOL bInitialUpdate )
virtual

Call this member function to allow a WM_INITIALUPATE message to be sent to views after creation.

Parameters
bInitialUpdate TRUE to send initial update message.

◆ SetActiveView() [1/3]

virtual void SetActiveView ( CRuntimeClass * pViewClass )
virtual

This member function will set a view active based on the specified runtime class.

Parameters
pViewClass CView runtime class associated with the tab.

◆ SetActiveView() [2/3]

virtual void SetActiveView ( CWnd * pTabView )
virtual

This member function will set a view active based on the specified runtime class.

Parameters
pTabView CWnd object to make active.

◆ SetActiveView() [3/3]

virtual void SetActiveView ( int nActiveTab )
virtual

This member function will set a view active based on the specified runtime class.

Parameters
nActiveTab Tab index.

◆ SetAutoCondense()

void SetAutoCondense ( BOOL bEnable )

Call this member function to enable/disable the tab auto-condensing mode.

Auto-condensing mode affects the tab control's behavior when there is not enough room to fit all tabs. Without auto-condensation, the CXTPTabCtrl control behaves like a standard tab control (i.e. it will display a slider control that allows the user to pan between tabs). With the auto-condensing mode enabled, CXTPTabCtrl attempts to fit all tabs in the available space by trimming the tab label text. This behavior is similar to the behavior displayed by Visual C++'s Workspace View. For instance, you can see the FileView tab shrink if you shrink the Workspace View.

Parameters
bEnable TRUE to enable auto-condense mode, FALSE to disable.

◆ SetMenuID()

virtual void SetMenuID | ( | UINT | popupMenuID,
 |  | int | nPos = 0 )
 virtual

This member function is used to set the resource ID for the pop-up menu used by the tab control.

Parameters
popupMenuID | ID for the tab control pop-up menu.
nPos | Index position in the menu resource.

◆ SetTabText() [1/3]

BOOL SetTabText | ( | CRuntimeClass * | pViewClass,
 |  | LPCTSTR | lpszLabel )

Call this member function to set the text for the specified tab.

Parameters
pViewClass | CRuntimeClass of the CWnd associated with the tab.
lpszLabel | New text for the tab label.
Returns
TRUE if successful, otherwise FALSE.

◆ SetTabText() [2/3]

BOOL SetTabText | ( | CWnd * | pView,
 |  | LPCTSTR | lpszLabel )

Call this member function to set the text for the specified tab.

Parameters
pView | CWnd object associated with the tab.
lpszLabel | New text for the tab label.
Returns
TRUE if successful, otherwise FALSE.

◆ SetTabText() [3/3]

BOOL SetTabText | ( | int | nTab,
 |  | LPCTSTR | lpszLabel )

Call this member function to set the text for the specified tab.

Parameters
nTab | Index of the tab.
lpszLabel | New text for the tab label.
Returns
TRUE if successful, otherwise FALSE.

◆ SetTips()

virtual void SetTips ( CToolTipCtrl * pWndTip )
virtual

Call this function to assign a tooltip control to the tab control.

You can associate the tooltip control with a tab control by making a call to GetToolTips.

Parameters
pWndTip Pointer to a tooltip control.

◆ UpdateTabLabel()

BOOL UpdateTabLabel | ( | int | nTab,
 |  | CXTPTcbItem * | pMember,
 |  | LPCTSTR | lpszLabel )
 protected

This member function is called to set the tooltip and tab text for the specified tab.

Parameters
nTab | Index of the tab.
pMember | Address of an CXTPTcbItem struct associated with the tab.
lpszLabel | A NULL-terminated string that represents the new tab label.
Returns
TRUE if successful, otherwise FALSE.

◆ UpdateToolTip() [1/2]

virtual void UpdateToolTip | ( | CRuntimeClass * | pViewClass,
 |  | LPCTSTR | lpszText )
 virtual

Call this function to update the tooltip text for the specified tab.

Parameters
pViewClass | CRuntimeClass associated with the tab.
lpszText | Pointer to the text for the tool.

◆ UpdateToolTip() [2/2]

virtual void UpdateToolTip | ( | int | nIDTab,
 |  | LPCTSTR | lpszText )
 virtual

Call this function to update the tooltip text for the specified tab.

Parameters
nIDTab | Index of the tab.
lpszText | Pointer to the text for the tool.
The documentation for this class was generated from the following file:
  • XTPTabBase.h


Toolkit Pro: CXTPTabManager Class Reference

Classes | Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPTabManager Class Referenceabstract

CXTPTabManager is the base class for docking pane tabs, tab control tabs, and MDI client tabs. More...

Inheritance diagram for CXTPTabManager:
[legend]

Classes

class | CRowIndexer
Helper class used to collect the indices of rows for a multi-row tab manager. More...
struct | ROW_ITEMS
Helper structure that contains the first and last item indices of rows of the tab manager. More...

Public Member Functions

CXTPTabManager ()
Constructs a CXTPTabManager object.
virtual | ~CXTPTabManager ()
Destroys a CXTPTabManager object, handles cleanup and deallocation.
CXTPTabManagerItem * | GetItem (int nIndex) const
Retrieves a tab item by its index.
BOOL | DeleteItem (int nItem)
Deletes a tab item by its index.
void | DeleteAllItems ()
Deletes all tab items from the tab manager.
int | GetItemCount () const
Gets the number of tab items in the tab manager.
virtual CString | GetItemCaption (const CXTPTabManagerItem *pItem) const
Retrieves the caption text of a specified tab item.
virtual HICON | GetItemIcon (const CXTPTabManagerItem *pItem) const
Retrieves the icon of a specified tab item.
virtual COLORREF | GetItemColor (const CXTPTabManagerItem *pItem) const
Retrieves the tab button color of a specified tab item.
virtual CString | GetItemTooltip (const CXTPTabManagerItem *pItem) const
Retrieves the tooltip of a specified tab item.
virtual void | OnItemsChanged ()
This method is called when tab items are changed (i.e.
void | SetCurSel (int nIndex)
Sets the index for the currently selected tab item within the collection of tab items.
int | GetCurSel () const
Gets the index of the currently selected tab item within the collection of tab items.
virtual void | SetSelectedItem (CXTPTabManagerItem *pItem)
Sets the currently selected tab item.
virtual void | SetFocusedItem (CXTPTabManagerItem *pItem)
Sets the focused tab item.
CXTPTabManagerItem * | GetSelectedItem () const
Gets the currently selected tab item.
CXTPTabManagerItem * | HitTest (CPoint point) const
Determines which tab is at a specified point, if any.
CXTPTabManagerNavigateButton * | HitTestNavigateButton (CPoint point, BOOL bHeaderOnly, int *pnIndex=NULL) const
Determines which navigation button is at a specified point, if any.
virtual void | GetItemMetrics (CSize *szNormal, CSize *szMin=NULL, CSize *szMax=NULL) const
Gets the minimum, maximum, and normal lengths of tab buttons.
void | SetItemMetrics (CSize szNormal, CSize szMin=CSize(0, 0), CSize szMax=CSize(0, 0))
Sets the minimum, maximum, and normal lengths for tab buttons.
void | MoveItem (CXTPTabManagerItem *pItem, int nIndex)
Sets the position of a specified tab item.
void | ShowCloseItemButton (XTPTabNavigateButtonFlags bCloseItemButton=xtpTabNavigateButtonAlways)
Call this member to show close button for each tab.
virtual int | GetItemsLength () const
Gets the total width of all of the tab buttons.
int | GetRectLength (CRect rc) const
Gets the length of the bounding rectangle of the tab client header area.
CXTPTabManagerNavigateButton * | FindNavigateButton (UINT nID) const
Retrieves a specified tab navigation button (i.e.
BOOL | IsHorizontalPosition () const
Determines if the tabs are positioned horizontally.
int | GetHeaderOffset () const
Gets the scroll offset of the tabs in the tab header.
void | SetHeaderOffset (int nOffset)
Sets the scroll offset for the tabs in the tab header.
void | EnsureVisible (CXTPTabManagerItem *pItem)
Ensures that a specified tab is visible.
virtual CXTPTabPaintManager * | GetPaintManager () const =0
Gets the tab paint manager.
virtual void | SetPaintManager (CXTPTabPaintManager *pPaintManager)
Sets the tab paint manager.
virtual void | RedrawControl (LPCRECT lpRect, BOOL bAnimate)=0
This method is called when the visual properties of the tabs are changed (e.g.
virtual BOOL | IsAllowReorder () const
Determines if tabs are allowed to be reordered.
virtual void | SetAllowReorder (BOOL bAllowReorder)
Specifies if tabs should be allowed to be reordered.
virtual BOOL | IsDrawStaticFrame () const
Determines if a static frame is used.
virtual BOOL | DrawIcon (CDC *pDC, CPoint pt, CXTPTabManagerItem *pItem, BOOL bDraw, CSize &szIcon) const =0
This method is called when the icon of a tab must be redrawn (e.g.
void | EnableTabThemeTexture (HWND hWnd, BOOL bEnable=TRUE)
Enables/disables Windows XP themed back color.
CXTPTabPaintManagerColorSet * | SetColor (XTPTabColorStyle tabColor)
Applies one of the "built-in" color sets for the tabs.
CXTPTabPaintManagerColorSet * | SetColorSet (CXTPTabPaintManagerColorSet *pColorSet)
Applies a custom color set for the tabs.
CXTPTabPaintManagerTheme * | SetAppearance (XTPTabAppearanceStyle tabAppearance)
Applies one of the "built-in" appearance sets for the tabs.
CXTPTabPaintManagerTheme * | SetAppearanceSet (CXTPTabPaintManagerTheme *pAppearanceSet)
Applies a custom appearance set for the tabs.
CXTPTabPaintManagerTheme * | GetAppearanceSet () const
Gets the currently applied custom appearance set.
CXTPTabPaintManagerColorSet * | GetColorSet () const
Gets the currently applied custom color set.
XTPTabAppearanceStyle | GetAppearance () const
Gets the currently applied "built-in appearance set.
XTPTabColorStyle | GetColor () const
Gets the currently applied "built-in" color set.
void | SetPosition (XTPTabPosition tabPosition)
Sets the tab position.
void | SetLayoutStyle (XTPTabLayoutStyle tabLayout)
Sets the tab layout style.
virtual XTPTabPosition | GetPosition () const
Gets the tab position.
XTPTabLayoutStyle | GetLayout () const
Gets the tab layout style.
void | ShowIcons (BOOL bShowIcons)
Shows/hides tab icons.
void | SetActive (BOOL bActive)
Specifies if this tab group should be active/inactive.
BOOL | IsActive () const
Determines if this tab group is active/inactive.
CRect | GetControlRect () const
Gets the bounding rectangle of the tab manager control area.
CRect | GetClientRect () const
Gets the bounding rectangle of the tab client area.
CRect | GetHeaderRect () const
Gets the bounding rectangle of the tab client header area.
int | GetRowCount () const
Gets the number of rows of tabs in the tab control.
virtual void | OnScrollHeader (BOOL bRight)
This method is called when the user presses either the left or right navigation buttons.
CXTPTabManagerNavigateButtons * GetNavigateButtons ()
Gets the collection of navigation buttons.
CXTPTabManagerItem * | FindNextFocusable (int nIndex, int nDirection) const
Retrieves the next/previous focusable tab item from a specified index.
void | PerformMouseMove (HWND hWnd, CPoint pt)
This method is called when the mouse cursor moves.
BOOL | PerformClick (HWND hWnd, CPoint pt, BOOL bNoItemClick=FALSE)
This method is called when the user presses the left mouse button.
virtual INT_PTR | PerformToolHitTest (HWND hWnd, CPoint point, TOOLINFO *pTI) const
Determines which tab is beneath the mouse cursor, if any, and stores the tooltip information of the tab within a TOOLINFO structure.
virtual BOOL | PerformKeyDown (HWND hWnd, UINT nChar)
This method is called to process a WM_KEYDOWN event for the tab manager.
virtual BOOL | DrawParentBackground (CDC *pDC, CRect rc)
Draws the parent background under the tab control.
int | GetNavigateButtonCount () const
Gets the total number of tab navigation buttons within the collection of tab navigation buttons.
CXTPTabManagerNavigateButton * | GetNavigateButton (int nIndex) const
Retrieves the tab navigation button at a specified index within the collection of tab navigation buttons.
void | EnableMarkup (BOOL bEnable=TRUE)
Enables/disables markup for the tab captions.
virtual CXTPMarkupContext * | GetMarkupContext () const
Gets the markup context.
- Public Member Functions inherited from CXTPTabManagerAtom
virtual void | OnPropertyChanged ()
This method is called when a property of the tab paint manager is changed.
virtual void | Reposition ()=0
Recalculates the layout of the tab manager and then repositions itself.

Protected Member Functions

virtual BOOL | IsNavigateButtonAutomaticVisible (CXTPTabManagerNavigateButton *pButton)
Determines if a specified tab navigation button is automatically displayed.
virtual BOOL | IsNavigateButtonVisible (CXTPTabManagerNavigateButton *pButton)
Determines if a specified tab navigation button is visible.
virtual void | OnItemClick (CXTPTabManagerItem *pItem)
This method is called when a tab button is clicked to select the tab item that was clicked.
virtual BOOL | OnBeforeItemClick (CXTPTabManagerItem *pItem)
This method is called before a tab item is clicked.
virtual void | ReOrder (HWND hWnd, CPoint pt, CXTPTabManagerItem *pItem)
This method is called when a tab item is clicked and dragged within the tab header.
virtual void | OnSwitchItem (CXTPTabManagerItem *pItem1, CXTPTabManagerItem *pItem2)
This method is called by ReOrder when two tab items are switched.
virtual void | OnItemOrderChanged (CXTPTabManagerItem *pItem, int nOldIndex, int nNewIndex)
This method is called by ReOrder when a tab item's position is changed.
virtual void | OnNavigateButtonClick (CXTPTabManagerNavigateButton *pButton)
This method is called when a tab navigation button is clicked.
virtual void | OnNavigateButtonClick (UINT nID)
This method is called when a tab navigation button is clicked.
virtual BOOL | IsMouseLocked () const
Determines if the MouseMove event has been disabled.
CXTPTabManagerItem * | AddItem (int nItem, CXTPTabManagerItem *pItem=NULL)
Adds a specified tab item to the collection of tab items.
virtual BOOL | HeaderHasFocus () const
The implementation should return TRUE if the header has focus or FALSE otherwise.
void | TrackClick (HWND hWnd, CPoint pt, CXTPTabManagerItem *pItem)
Activates and tracks a specified tab item on mouse click.
virtual void | OnItemHandleChanged (CXTPTabManagerItem *pItem, HWND hwndOld, HWND hwndNew)
This method is called when the handle of a tab item is changed.
- Protected Member Functions inherited from CXTPTabManagerAtom
virtual | ~CXTPTabManagerAtom ()
Destroys a CXTPTabManagerAtom object, handles cleanup and deallocation.

Protected Attributes

CXTPTabManagerItem * m_pSelected
Tab currently selected (i.e.
CXTPTabManagerItem * m_pHighlighted
Tab currently highlighted (i.e.
CXTPTabManagerItem * | m_pPressed
Pointer to the currently pressed tab.
CXTPTabManagerNavigateButton * | m_pHighlightedNavigateButton
Pointer to highlighted navigate button.
int | m_nHeaderOffset
Scroll offset, this is how much the tabs in the tab header have been scrolled using the left and right tab navigation buttons.
BOOL | m_bAllowReorder
TRUE to allow tabs to be reordered.
BOOL | m_bActive
TRUE if the MDITabClient tab group is active.
XTPTabNavigateButtonFlags | m_bCloseItemButton
TRUE to show the close button for tabs.
CRect | m_rcHeaderRect
Bounding rectangle of the tab header area.
CRect | m_rcControl
Bounding rectangle of the tab manager control.
CArray< CXTPTabManagerItem *, CXTPTabManagerItem * > | m_arrItems
Bounding rectangle of the tab client area.
CXTPTabManagerNavigateButtons | m_arrNavigateButtons
Collection of tab navigation buttons for this tab manager.
CRowIndexer * | m_pRowIndexer
Row indexer.
int | m_nScrollDelta
Scroll header delta.
CXTPMarkupContext * | m_pMarkupContext
Markup context of the tab manager.

Detailed Description

CXTPTabManager is the base class for docking pane tabs, tab control tabs, and MDI client tabs.

See also
CXTPTabClientWnd, CXTPDockingPaneTabbedContainer, CXTPTabControl

Member Function Documentation

◆ AddItem()

CXTPTabManagerItem * AddItem | ( | int | nItem,
 |  | CXTPTabManagerItem * | pItem = NULL )
 protected

Adds a specified tab item to the collection of tab items.

Parameters
nItem | Position in the collection of tab items to add the specified tab item. If the value of this parameter is less than 0 or greater than the number of tab items in the collection, then the specified tab item will be added to the end of the collection.
pItem | Pointer to the tab item to add, or NULL to create and add a default tab item.
Returns
A pointer to the newly added tab item.

This method is overridden in derived classes to provide additional functionality and then this base class method is called.

◆ DeleteItem()

BOOL DeleteItem ( int nItem )

Deletes a tab item by its index.

Parameters
nItem Zero-based index of the tab item to delete.
Returns
Nonzero if successful, otherwise 0.

◆ DrawIcon()

virtual BOOL DrawIcon | ( | CDC * | pDC,
 |  | CPoint | pt,
 |  | CXTPTabManagerItem * | pItem,
 |  | BOOL | bDraw,
 |  | CSize & | szIcon ) const
 pure virtual

This method is called when the icon of a tab must be redrawn (e.g.

on mouse-over).

Parameters
pDC | Pointer to the destination device context.
pt | Point that specifies the location of the image.
pItem | Pointer to a CXTPTabManagerItem object to draw the icon on.
bDraw | TRUE if the icon must be drawn/redrawn (i.e. the icon size changed), FALSE otherwise.
szIcon | Reference to the size of the tab icon.

This method is overridden by its descendants.

This method must be overridden in derived classes.

Returns
TRUE if the icon was drawn successfully, otherwise FALSE.

Implemented in CXTPDockingPaneAutoHidePanel, CXTPDockingPaneTabbedContainer, CXTPRibbonControlTab, CXTPTabControl, and CXTPTabToolBar.

◆ DrawParentBackground()

AFX_INLINE BOOL DrawParentBackground | ( | CDC * | pDC,
 |  | CRect | rc )
 virtual

Draws the parent background under the tab control.

Parameters
pDC | Pointer to valid device context.
rc | Bounding rectangle.
Returns
TRUE if the rectangle was filled.

◆ EnableMarkup()

void EnableMarkup ( BOOL bEnable = TRUE )

Enables/disables markup for the tab captions.

Parameters
bEnable TRUE to enable markup for the tab captions, FALSE to disable markup for the tab captions.

◆ EnableTabThemeTexture()

void EnableTabThemeTexture | ( | HWND | hWnd,
 |  | BOOL | bEnable = TRUE )

Enables/disables Windows XP themed back color.

Parameters
hWnd | Window handle of the target object or dialog.
bEnable | TRUE to enable Windows XP themed back color, FALSE to disable Windows XP themed back color.

This method should only be used when the tab color is set to xtpTabColorWinNative.

Example: This sample code illustrates how to apply a Windows XP themed back color to a tab control:

m_wndTabControl.GetPaintManager()->SetColor(xtpTabColorWinNative);
XTPTabColorStyle color = m_wndTabControl.GetPaintManager()->GetColor();
m_wndTabControl.EnableTabThemeTexture(m_wndTabControl.GetSafeHwnd(), color ==
xtpTabColorWinNative ? TRUE : FALSE); RedrawWindow();
See also
XTPTabColorStyle, GetColor, SetColor

◆ EnsureVisible()

void EnsureVisible ( CXTPTabManagerItem * pItem )

Ensures that a specified tab is visible.

Parameters
pItem Pointer to the tab to ensure the visibility of.
See also
SetHeaderOffset, GetHeaderOffset

◆ FindNavigateButton()

CXTPTabManagerNavigateButton * FindNavigateButton ( UINT nID ) const

Retrieves a specified tab navigation button (i.e.

either the left arrow, right arrow, or close button in the tab header area).

Parameters
nID Identifier of the button to retrieve. Can be one of the values listed in the Remarks section.

Standard IDs of buttons are listed below: xtpTabNavigateButtonLeft: Left tab navigation button. xtpTabNavigateButtonRight: Right tab navigation button. xtpTabNavigateButtonClose: Close tab navigation button.

Returns
A pointer to the specified tab navigation button.
See also
XTPTabNavigateButton

◆ FindNextFocusable()

CXTPTabManagerItem * FindNextFocusable | ( | int | nIndex,
 |  | int | nDirection ) const

Retrieves the next/previous focusable tab item from a specified index.

Parameters
nIndex | Index to begin search.
nDirection | Direction to search in (+1 for next, -1 for previous).
Returns
A pointer to the next/previous focusable tab item from the specified index.

A tab item is focusable if it is both visible and enabled.

See also
CXTPTabManagerItem

◆ GetAppearance()

XTPTabAppearanceStyle GetAppearance ( ) const

Gets the currently applied "built-in appearance set.

Returns
The currently applied "built-in" appearance set; one of the values defined by the XTPTabAppearanceStyle enumeration.

An appearance set specifies how tabs will look. This is the actual physical structure of the tab buttons. For example, tab buttons with an Excel appearance set will have a half-hexagon shape.

See also
XTPTabAppearanceStyle, GetAppearanceSet, SetAppearanceSet, SetAppearance

◆ GetAppearanceSet()

CXTPTabPaintManagerTheme * GetAppearanceSet ( ) const

Gets the currently applied custom appearance set.

Returns
A pointer to the currently applied custom appearance set.

An appearance set specifies how tabs will look. This is the actual physical structure of the tab buttons. For example, tab buttons with an Excel appearance set will have a half-hexagon shape.

SetColorSet is used to set custom colors.

See the GUI_Eclipse sample for an example of how to create a custom appearance set and apply it for the tabs.

See also
GetAppearanceSet, SetAppearanceSet, SetAppearance

◆ GetClientRect()

AFX_INLINE CRect GetClientRect ( ) const

Gets the bounding rectangle of the tab client area.

Returns
The bounding rectangle of the tab client area.
See also
GetHeaderRect, GetControlRect

◆ GetColor()

XTPTabColorStyle GetColor ( ) const

Gets the currently applied "built-in" color set.

Returns
The currently applied "built-in" color set.

Color sets are used to colorize the tabs. For example, applying the xtpTabColorWinNative color set will give the tabs a Windows XP colorization.

See also
XTPTabColorStyle, SetColor, GetColorSet, SetColorSet

◆ GetColorSet()

CXTPTabPaintManagerColorSet * GetColorSet ( ) const

Gets the currently applied custom color set.

Returns
A pointer to the currently applied custom color set.

Color sets are used to colorize the tabs. For example, applying the xtpTabColorWinNative color set will give the tabs a Windows XP colorization.

See also
XTPTabColorStyle, GetColor, SetColorSet, SetColor

◆ GetControlRect()

AFX_INLINE CRect GetControlRect ( ) const

Gets the bounding rectangle of the tab manager control area.

Returns
The bounding rectangle of the tab manager control area.
See also
GetHeaderRect, GetClientRect

◆ GetCurSel()

int GetCurSel ( ) const

Gets the index of the currently selected tab item within the collection of tab items.

The currently selected tab item is the currently active tab item. A tab item is selected when it has focus or is clicked.

The currently selected tab item can be retrieved by using GetSelectedItem.

Returns
The index of the currently selected tab item.
See also
CXTPTabManagerItem, SetSelectedItem, SetCurSel, GetSelectedItem

◆ GetHeaderOffset()

AFX_INLINE int GetHeaderOffset ( ) const

Gets the scroll offset of the tabs in the tab header.

Returns
The scroll offset of the tabs in the tab header.

The scroll offset is how much the tabs have been scrolled by pressing the left and right tab navigation buttons.

The scroll offset starts at zero and remains at zero until there are enough tabs to scroll. If the tabs are scrolled, then the offset will be a negative number indicating how much the tabs have been scrolled to the right.

NOTE: GetHeaderOffset and SetHeaderOffset are used when the left and right tab navigate buttons are pressed to scroll the tabs by 20 pixels to the left or right.

EnsureVisible uses GetHeaderOffset and SetHeaderOffset to ensure that a tab button is visible.

Example: This sample illustrates how to programmatically set the scroll offset of the tabs in the tab header of the CXTPTabClientWnd:

//Scroll the tabs in the tab header to the right by 100 pixels.
m_MTIClientWnd.GetWorkspace(0)->SetHeaderOffset((m_MTIClientWnd.GetWorkspace(0)->GetHeaderOffset())
- 100);

//Scroll the tabs in the tab header to the left by 100 pixels.//
m_MTIClientWnd.GetWorkspace(0)->SetHeaderOffset((m_MTIClientWnd.GetWorkspace(0)->GetHeaderOffset())
+ 100);
See also
SetHeaderOffset, CXTPTabManagerNavigateButton, EnsureVisible

◆ GetHeaderRect()

AFX_INLINE CRect GetHeaderRect ( ) const

Gets the bounding rectangle of the tab client header area.

Returns
The bounding rectangle of the tab client header area.
See also
GetClientRect, GetControlRect

◆ GetItem()

AFX_INLINE CXTPTabManagerItem * GetItem ( int nIndex ) const

Retrieves a tab item by its index.

Parameters
nIndex Zero-based index of the tab item to retrieve.
Returns
A pointer to the tab item if successful, otherwise FALSE.

◆ GetItemCaption()

virtual CString GetItemCaption ( const CXTPTabManagerItem * pItem ) const
virtual

Retrieves the caption text of a specified tab item.

Parameters
pItem Pointer to the tab item with the caption text to retrieve.
Returns
The caption text of the specified tab item.

◆ GetItemColor()

virtual COLORREF GetItemColor ( const CXTPTabManagerItem * pItem ) const
virtual

Retrieves the tab button color of a specified tab item.

Parameters
pItem Pointer to the tab item with the tab button color to retrieve.
Returns
The tab button color of the specified tab item.
See also
CXTPTabManagerItem::SetColor, CXTPTabManagerItem::GetColor

◆ GetItemCount()

AFX_INLINE int GetItemCount ( ) const

Gets the number of tab items in the tab manager.

Returns
The number of tab items in the tab manager.

◆ GetItemIcon()

virtual HICON GetItemIcon ( const CXTPTabManagerItem * pItem ) const
virtual

Retrieves the icon of a specified tab item.

Parameters
pItem Pointer to the tab item with the icon to retrieve.
Returns
The icon of the specified tab item.

◆ GetItemMetrics()

virtual void GetItemMetrics | ( | CSize * | szNormal,
 |  | CSize * | szMin = NULL,
 |  | CSize * | szMax = NULL ) const
 virtual

Gets the minimum, maximum, and normal lengths of tab buttons.

Parameters
szNormal | Pointer to a CSize object to receive the fixed length used for all tabs when the layout is xtpTabLayoutFixed.
szMin | Pointer to a CSize object to receive the minimum length used for tabs when the layout is not xtpTabLayoutFixed.
szMax | Pointer to a CSize object to receive the maximum length used for tabs when the layout is not xtpTabLayoutFixed.

The minimum, maximum, and normal lengths of tab buttons are used when calculating the lengths of tabs for each XTPTabLayoutStyle.

szNormal only applies when the layout is xtpTabLayoutFixed. When the layout is xtpTabLayoutFixed, every tab will have a fixed length of szNormal. Otherwise, szMin and szMax represent the lower and upper bounds for the length of individual tabs respectively.

See also
XTPTabLayoutStyle, SetItemMetrics, SetLayoutStyle

◆ GetItemsLength()

virtual int GetItemsLength ( ) const
virtual

Gets the total width of all of the tab buttons.

Returns
The total width of all of the tab buttons.

The width may change depending on both the tab layout and the position of the tabs.

See also
XTPTabLayoutStyle, XTPTabPosition

Reimplemented in CXTPDockingPaneAutoHidePanel.

◆ GetItemTooltip()

virtual CString GetItemTooltip ( const CXTPTabManagerItem * pItem ) const
virtual

Retrieves the tooltip of a specified tab item.

Parameters
pItem Pointer to the tab item with the tooltip to retrieve.

The tooltip is the text displayed when the mouse is positioned over the tab button.

Returns
The tooltip of the specified tab item.
See also
CXTPTabManagerItem::SetTooltip, CXTPTabManagerItem::GetTooltip

◆ GetLayout()

XTPTabLayoutStyle GetLayout ( ) const

Gets the tab layout style.

Returns
The tab layout style; one of the values defined by the XTPTabLayoutStyle enumeration.

The tab layout style refers to how the tab buttons are sized within the tab client header. The tab buttons can be in either a compressed, fixed, auto-size, or size-to-fit layout.

See also
XTPTabLayoutStyle, SetLayoutStyle

◆ GetMarkupContext()

AFX_INLINE CXTPMarkupContext * GetMarkupContext ( ) const
virtual

Gets the markup context.

Returns
A pointer to the markup context.

◆ GetNavigateButton()

AFX_INLINE CXTPTabManagerNavigateButton * GetNavigateButton ( int nIndex ) const

Retrieves the tab navigation button at a specified index within the collection of tab navigation buttons.

Parameters
nIndex Zero-based index of the tab navigation button to retrieve.
Returns
A pointer to the tab navigation button at the specified index within the collection of tab navigation buttons.
See also
GetNavigateButtonCount, CXTPTabManagerNavigateButton, OnNavigateButtonClick

◆ GetNavigateButtonCount()

AFX_INLINE int GetNavigateButtonCount ( ) const

Gets the total number of tab navigation buttons within the collection of tab navigation buttons.

Returns
The total number of tab navigation buttons within the collection of tab navigation buttons.
See also
GetNavigateButton, CXTPTabManagerNavigateButton, OnNavigateButtonClick

◆ GetNavigateButtons()

AFX_INLINE CXTPTabManagerNavigateButtons * GetNavigateButtons ( )

Gets the collection of navigation buttons.

Returns
A pointer to the collection of navigation buttons.
See also
CXTPTabManagerNavigateButtons, CXTPTabManagerNavigateButton

◆ GetPaintManager()

virtual CXTPTabPaintManager * GetPaintManager ( ) const
pure virtual

Gets the tab paint manager.

The tab paint manager is used to customize the appearance of both CXTPTabManagerItem objects and the tab manager (i.e. tab colors, styles, etc.).

This method must be overridden in derived classes.

Returns
A pointer to the tab paint manager.

Implemented in CXTPDockingPaneAutoHidePanel, CXTPDockingPaneTabbedContainer, CXTPRibbonControlTab, CXTPTabControl, and CXTPTabToolBar.

◆ GetPosition()

virtual XTPTabPosition GetPosition ( ) const
virtual

Gets the tab position.

Returns
The tab position; one of the values defined by the XTPTabPosition enumeration.

The tab position refers to where the tab buttons are located. The tab buttons can be positioned on either the top, bottom, left, or right side of the tab client area.

See also
XTPTabPosition, SetPosition

Reimplemented in CXTPDockingPaneAutoHidePanel.

◆ GetRectLength()

AFX_INLINE int GetRectLength ( CRect rc ) const

Gets the length of the bounding rectangle of the tab client header area.

Parameters
rc Bounding rectangle of tab client header area.
Returns
If tabs are horizontal, then the width of the tab client header area is returned. If tabs are vertical, then the height of the tab client header area is returned.

The tab client header area is the area that has all of the tab buttons.

See also
GetAppearanceSet, CXTPTabPaintManagerTheme::GetHeaderRect

◆ GetRowCount()

AFX_INLINE int GetRowCount ( ) const

Gets the number of rows of tabs in the tab control.

Returns
The number of rows of tabs in the tab control.

Only tab controls which have the xtpTabLayoutMultiRow layout can have multiple rows of tabs.

See also
SetLayoutStyle, CXTPTabManagerItem::GetItemRow

◆ GetSelectedItem()

AFX_INLINE CXTPTabManagerItem * GetSelectedItem ( ) const

Gets the currently selected tab item.

The currently selected tab item is the currently active tab item. A tab item is selected when it has focus or is clicked.

Returns
A pointer to the currently selected tab item.
See also
CXTPTabManagerItem, SetSelectedItem, SetCurSel, GetCurSel

◆ HeaderHasFocus()

AFX_INLINE BOOL HeaderHasFocus ( ) const
protectedvirtual

The implementation should return TRUE if the header has focus or FALSE otherwise.

Returns
TRUE if the header has focus, otherwise FALSE.

Reimplemented in CXTPRibbonControlTab, and CXTPTabControl.

◆ HitTest()

CXTPTabManagerItem * HitTest ( CPoint point ) const

Determines which tab is at a specified point, if any.

Parameters
point Point to be tested.
Returns
A pointer to the tab at the specified point, if any, otherwise NULL.

This method can be used to determine if the user clicked on a tab.

In order for a pointer to the tab at the specified point to be returned, the tab must be both visible and enabled. If the tab is not both visible and enabled, then NULL will be returned.

See also
PerformClick, PerformMouseMove

◆ HitTestNavigateButton()

CXTPTabManagerNavigateButton * HitTestNavigateButton | ( | CPoint | point,
 |  | BOOL | bHeaderOnly,
 |  | int * | pnIndex = NULL ) const

Determines which navigation button is at a specified point, if any.

Parameters
point | Point to be tested.
pnIndex | Pointer to an integer to receive the index of the navigation button at the specified point, if any.
bHeaderOnly | TRUE to only test buttons located in the header, FALSE to test all buttons.
Returns
A pointer to the navigation button at the specified point, if any, otherwise NULL.
See also
HitTest

◆ IsActive()

AFX_INLINE BOOL IsActive ( ) const

Determines if this tab group is active/inactive.

Returns
TRUE if this tab group is active, FALSE if this tab group is inactive.

This method only applies to tab groups in the MDITabClient (i.e. the tabs groups that appear in the CommandBars TabWorkspace) when grouping is enabled.

When grouping is enabled, each tab group has its own CXTPTabManager.

SetActive is used to activate/set focus to the tab group.

Only one tab group can be active at a given time.

See also
SetActive, CXTPTabClientWnd::Attach

◆ IsAllowReorder()

AFX_INLINE BOOL IsAllowReorder ( ) const
virtual

Determines if tabs are allowed to be reordered.

Returns
TRUE if tabs are allowed to be reordered, FALSE if tabs are not allowed to be reordered.
See also
SetAllowReorder

◆ IsDrawStaticFrame()

virtual BOOL IsDrawStaticFrame ( ) const
virtual

Determines if a static frame is used.

Returns
TRUE if a static frame is used, otherwise FALSE.

If a static frame is used, then it will be drawn around the entire tab manager control (i.e. around both the tab header and the tab client).

See also
CXTPTabPaintManager::m_bStaticFrame

◆ IsHorizontalPosition()

AFX_INLINE BOOL IsHorizontalPosition ( ) const

Determines if the tabs are positioned horizontally.

Returns
TRUE if the tabs are positioned horizontally (i.e. top or bottom), FALSE if the tabs are positioned vertically (i.e. left or right).
See also
GetPosition, XTPTabPosition

◆ IsMouseLocked()

AFX_INLINE BOOL IsMouseLocked ( ) const
protectedvirtual

Determines if the MouseMove event has been disabled.

Returns
Always returns FALSE in the base class implementation.

This method is overridden in CXTPTabClientWnd::CWorkspace.

The MouseMove event is disabled when a command bar pop-up becomes active/visible.

See also
CXTPTabClientWnd::CWorkspace::IsMouseLocked

Reimplemented in CXTPRibbonControlTab.

◆ IsNavigateButtonAutomaticVisible()

virtual BOOL IsNavigateButtonAutomaticVisible ( CXTPTabManagerNavigateButton * pButton )
protectedvirtual

Determines if a specified tab navigation button is automatically displayed.

Parameters
pButton Pointer to the tab navigation button to check.
Returns
TRUE if the specified tab navigation button is automatically displayed, otherwise FALSE.
See also
XTPTabNavigateButtonFlags

◆ IsNavigateButtonVisible()

virtual BOOL IsNavigateButtonVisible ( CXTPTabManagerNavigateButton * pButton )
protectedvirtual

Determines if a specified tab navigation button is visible.

Parameters
pButton Pointer to the tab navigation button to check.
Returns
TRUE if the specified tab navigation button is visible, otherwise FALSE.

◆ MoveItem()

void MoveItem | ( | CXTPTabManagerItem * | pItem,
 |  | int | nIndex )

Sets the position of a specified tab item.

Parameters
pItem | Pointer to the tab item whose position must be set.
nIndex | Position to be set.

◆ OnBeforeItemClick()

virtual BOOL OnBeforeItemClick ( CXTPTabManagerItem * pItem )
protectedvirtual

This method is called before a tab item is clicked.

Parameters
pItem Pointer to the tab item that is about to be clicked.
Returns
TRUE to cancel the process.

Reimplemented in CXTPTabToolBar.

◆ OnItemClick()

virtual void OnItemClick ( CXTPTabManagerItem * pItem )
protectedvirtual

This method is called when a tab button is clicked to select the tab item that was clicked.

Parameters
pItem Pointer to the tab item that was clicked.
See also
PerformClick

Reimplemented in CXTPRibbonControlTab, and CXTPTabControl.

◆ OnItemHandleChanged()

AFX_INLINE void OnItemHandleChanged | ( | CXTPTabManagerItem * | pItem,
 |  | HWND | hwndOld,
 |  | HWND | hwndNew )
 protectedvirtual

This method is called when the handle of a tab item is changed.

Parameters
pItem | Pointer to the tab item whose handle was changed.
hwndOld | Previous handle of the tab item.
hwndNew | New handle of the tab item.

◆ OnItemOrderChanged()

AFX_INLINE void OnItemOrderChanged | ( | CXTPTabManagerItem * | pItem,
 |  | int | nOldIndex,
 |  | int | nNewIndex )
 protectedvirtual

This method is called by ReOrder when a tab item's position is changed.

Parameters
pItem | Pointer to the tab item dragged by the user.
nOldIndex | Old item position.
nNewIndex | New item position.

◆ OnItemsChanged()

virtual void OnItemsChanged ( )
virtual

This method is called when tab items are changed (i.e.

after a tab item is added, deleted, or reordered).

This method will recalculate the index for all tab items and then call Reposition.

See also
CXTPTabManager::AddItem, CXTPTabManager::ReOrder, CXTPTabManager::DeleteItem, CXTPTabManager::DeleteAllItems

◆ OnNavigateButtonClick() [1/2]

AFX_INLINE void OnNavigateButtonClick ( CXTPTabManagerNavigateButton * pButton )
protectedvirtual

This method is called when a tab navigation button is clicked.

Parameters
pButton Pointer to the tab navigation button that was clicked. Can be one of the values listed in the Remarks section.

Standard identifiers of buttons are listed below: xtpTabNavigateButtonLeft: Left tab navigation button. xtpTabNavigateButtonRight: Right tab navigation button. xtpTabNavigateButtonClose: Close tab navigation button.

This method is overridden in CXTPTabClientWnd::CWorkspace and CXTPTabControl to capture when the tab navigation close "x" button is pressed and deletes the tab.

This member is called after CXTPTabManagerNavigateButton::PerformClick.

See also
CXTPTabManagerNavigateButton::PerformClick, XTPTabNavigateButton

Reimplemented in CXTPDockingPaneTabbedContainer, and CXTPTabControl.

◆ OnNavigateButtonClick() [2/2]

AFX_INLINE void OnNavigateButtonClick ( UINT nID )
protectedvirtual

This method is called when a tab navigation button is clicked.

Parameters
nID Button identifier. Can be one of the values listed in the Remarks section.

Standard identifiers of buttons are listed below: xtpTabNavigateButtonLeft: Left tab navigation button. xtpTabNavigateButtonRight: Right tab navigation button. xtpTabNavigateButtonClose: Close tab navigation button.

This method is overridden in CXTPTabClientWnd::CWorkspace and CXTPTabControl to capture when the tab navigation close "x" button is pressed and deletes the tab.

This member is called after CXTPTabManagerNavigateButton::PerformClick.

See also
CXTPTabManagerNavigateButton::PerformClick, XTPTabNavigateButton

Reimplemented in CXTPTabControl.

◆ OnScrollHeader()

virtual void OnScrollHeader ( BOOL bRight )
virtual

This method is called when the user presses either the left or right navigation buttons.

Parameters
bRight TRUE to scroll right, FALSE to scroll left.

◆ OnSwitchItem()

AFX_INLINE void OnSwitchItem | ( | CXTPTabManagerItem * | pItem1,
 |  | CXTPTabManagerItem * | pItem2 )
 protectedvirtual

This method is called by ReOrder when two tab items are switched.

Parameters
pItem1 | Pointer to the tab item dragged by the user.
pItem2 | Pointer to the other tab item that was switched.

◆ PerformClick()

BOOL PerformClick | ( | HWND | hWnd,
 |  | CPoint | pt,
 |  | BOOL | bNoItemClick = FALSE )

This method is called when the user presses the left mouse button.

Parameters
hWnd | Handle to the CWnd object beneath the mouse cursor.
pt | Specifies the x- and y- coordinates of the mouse cursor. These coordinates are always relative to the upper-left corner of the window.
bNoItemClick | TRUE to only test tab navigation buttons to determine if they were clicked, FALSE to test both tabs and tab navigation buttons to determine if they were clicked.

When the user clicks on a tab navigation button, this method will call the CXTPTabManagerNavigateButton::PerformClick member of the tab navigation button that was clicked.

When the user clicks on a tab, OnItemClick will be called to select the tab.

If IsAllowReorder is TRUE, then ReOrder will be called before OnItemClick. ReOrder will check if the tab is being moved and, if it is being moved, keep the tab selected so OnItemClick is not called. If the tab is not being moved, then OnItemClick will be called.

Returns
If bNoItemClick is TRUE, then this method will return either TRUE if a tab navigation button was clicked or FALSE if a tab navigation button was not clicked.

If bNoItemClick is FALSE, then this method will return either TRUE if a tab or tab navigation button was clicked or FALSE if a tab or tab navigation button was not clicked.

See also
OnItemClick, ReOrder, CXTPTabManager::OnNavigateButtonClick

◆ PerformKeyDown()

virtual BOOL PerformKeyDown | ( | HWND | hWnd,
 |  | UINT | nChar )
 virtual

This method is called to process a WM_KEYDOWN event for the tab manager.

Parameters
hWnd | Handle to the window that contains the tab.
nChar | Specifies the virtual-key code of the given key.
Returns
TRUE if the key was processed successfully, otherwise FALSE.

◆ PerformMouseMove()

void PerformMouseMove | ( | HWND | hWnd,
 |  | CPoint | pt )

This method is called when the mouse cursor moves.

Parameters
hWnd | Handle to the CWnd object beneath the mouse cursor.
pt | Specifies the x- and y- coordinates of the mouse cursor. These coordinates are always relative to the upper-left corner of the window.

When the mouse cursor is moved across a tab while hot tracking is enabled, PerformMouseMove will highlight and un-highlight the tabs and then call CXTPTabManagerNavigateButton::PerformMouseMove for each tab navigation button.

When the mouse cursor is moved across a tab navigation button, CXTPTabManagerNavigateButton::PerformMouseMove will be called to perform actions related to the mouse movement over the tab navigation buttons. This will highlight and un-highlight the tab navigation buttons.

See also
CXTPTabManagerNavigateButton::PerformMouseMove

◆ PerformToolHitTest()

virtual INT_PTR PerformToolHitTest | ( | HWND | hWnd,
 |  | CPoint | point,
 |  | TOOLINFO * | pTI ) const
 virtual

Determines which tab is beneath the mouse cursor, if any, and stores the tooltip information of the tab within a TOOLINFO structure.

Parameters
hWnd | Handle to the window that contains the tab.
point | Specifies the x- and y- coordinates of the mouse cursor.
pTI | Pointer to a TOOLINFO structure to receive the tooltip information of the tab beneath the mouse cursor, if any.
Returns
The identifier of the tab beneath the mouse cursor, if any, if a tooltip was found, otherwise a value of -1.

This member is called in the CXTPTabControl::OnToolHitTest, CXTPDockingPaneTabbedContainer::OnToolHitTest, and CXTPTabClientWnd::OnToolHitTest members.

◆ RedrawControl()

virtual void RedrawControl | ( | LPCRECT | lpRect,
 |  | BOOL | bAnimate )
 pure virtual

This method is called when the visual properties of the tabs are changed (e.g.

color, mouse-over, on-click).

Parameters
lpRect | Rectangular area of the window that is invalid.
bAnimate | TRUE to animate changes in the bounding rectangle.

This method must be overridden in derived classes.

Implemented in CXTPDockingPaneTabbedContainer, CXTPRibbonControlTab, CXTPTabControl, and CXTPTabToolBar.

◆ ReOrder()

virtual void ReOrder | ( | HWND | hWnd,
 |  | CPoint | pt,
 |  | CXTPTabManagerItem * | pItem )
 protectedvirtual

This method is called when a tab item is clicked and dragged within the tab header.

Parameters
hWnd | Handle to the CWnd object beneath the mouse cursor.
pt | Specifies the x- and y- coordinates of the mouse cursor. These coordinates are always relative to the upper-left corner of the window.
pItem | Pointer to the tab item that is about to be clicked and dragged.

This method will reorder the selected tab item to the location that it is dragged to.

See also
PerformClick

◆ SetActive()

void SetActive ( BOOL bActive )

Specifies if this tab group should be active/inactive.

Parameters
bActive TRUE to set this tab group to active, FALSE to set this tab group to inactive.

This method only applies to tab groups in the MDITabClient (i.e. the tabs groups that appear in the CommandBars TabWorkspace) when grouping is enabled.

When grouping is enabled, each tab group has its own CXTPTabManager.

SetActive is used to activate/set focus to the tab group.

Only one tab group can be active at a given time.

See also
IsActive, CXTPTabClientWnd::Attach

◆ SetAllowReorder()

AFX_INLINE void SetAllowReorder ( BOOL bAllowReorder )
virtual

Specifies if tabs should be allowed to be reordered.

Parameters
bAllowReorder TRUE to allow tabs to be reordered, FALSE to disallow tabs from being reordered.
See also
IsAllowReorder

◆ SetAppearance()

CXTPTabPaintManagerTheme * SetAppearance ( XTPTabAppearanceStyle tabAppearance )

Applies one of the "built-in" appearance sets for the tabs.

Parameters
tabAppearance "Built-in" appearance set to be applied; must be one of the values defined by the XTPTabAppearanceStyle enumeration.
Returns
A pointer to the newly applied "built-in" appearance set.

Use SetAppearance to apply a "built-in" appearance. Use SetAppearanceSet to apply a custom appearance.

An appearance set specifies how tabs will look. This is the actual physical structure of the tab buttons. For example, tab buttons with an Excel appearance set will have a half-hexagon shape.

See also
XTPTabAppearanceStyle, SetAppearanceSet, GetAppearance, GetAppearanceSet, SetColor, GetColor, GetColorSet, SetColorSet

◆ SetAppearanceSet()

CXTPTabPaintManagerTheme * SetAppearanceSet ( CXTPTabPaintManagerTheme * pAppearanceSet )

Applies a custom appearance set for the tabs.

Parameters
pAppearanceSet Pointer to the custom appearance set to be applied.

Use SetAppearance to apply a "built-in" appearance. Use SetAppearanceSet to apply a custom appearance.

An appearance set specifies how tabs will look. This is the actual physical structure of the tab buttons. For example, tab buttons with an Excel appearance set will have a half-hexagon shape.

SetColorSet is used to set custom colors.

See the GUI_Eclipse sample for an example of how to create a custom appearance set and apply it for the tabs.

Returns
A pointer to the newly applied custom appearance set.
See also
XTPTabAppearanceStyle, SetAppearance, GetAppearance, GetAppearanceSet, SetColor, GetColor, GetColorSet, SetColorSet

◆ SetColor()

CXTPTabPaintManagerColorSet * SetColor ( XTPTabColorStyle tabColor )

Applies one of the "built-in" color sets for the tabs.

Parameters
tabColor "Built-in" color set to be applied. Can be one of the values listed in the Remarks section.

Use SetColor to apply a "built-in" color set. Use SetColorSet to apply a custom color set.

Color sets are used to colorize the tabs. For example, applying the xtpTabColorWinNative color set will give the tabs a Windows XP colorization.

tabColor can be one of the following: xtpTabColorDefault: Tabs will use the default color style for the currently set Appearance. xtpTabColorVisualStudio2003: Tabs will use the Visual Studio color style for the currently set Appearance. xtpTabColorOffice2003: Tabs will use the Office 2003 color style for the currently set Appearance. xtpTabColorWinNative: Tabs will use the Windows XP color style for the currently set Appearance. xtpTabColorVisualStudio2005: Tabs will use the Visual Studio 2005 color style for the currently set Appearance.

Returns
A pointer to the newly applied "built-in" color set.
See also
XTPTabColorStyle, SetColorSet, GetColor, GetColorSet, XTPTabAppearanceStyle, SetAppearanceSet, SetAppearance, GetAppearance, GetAppearanceSet

◆ SetColorSet()

CXTPTabPaintManagerColorSet * SetColorSet ( CXTPTabPaintManagerColorSet * pColorSet )

Applies a custom color set for the tabs.

Parameters
pColorSet Pointer to the custom color set to be applied.
Returns
A pointer to the newly applied custom color set.

Use SetColor to apply a "built-in" color set. Use SetColorSet to apply a custom color set.

Color sets are used to colorize the tabs. For example, applying the xtpTabColorWinNative color set will give the tabs a Windows XP colorization.

See also
XTPTabColorStyle, SetColor, GetColor, GetColorSet, XTPTabAppearanceStyle, SetAppearanceSet, SetAppearance, GetAppearance, GetAppearanceSet

◆ SetCurSel()

void SetCurSel ( int nIndex )

Sets the index for the currently selected tab item within the collection of tab items.

Parameters
nIndex Index to be set.

The currently selected tab item is the currently active tab item. A tab item is selected when it has focus or is clicked.

This method calls GetItem to retrieve a pointer to the tab item at the specified index and then SetSelectedItem to select that tab item.

See also
CXTPTabManagerItem, GetCurSel, SetSelectedItem, GetSelectedItem

◆ SetFocusedItem()

virtual void SetFocusedItem ( CXTPTabManagerItem * pItem )
virtual

Sets the focused tab item.

Parameters
pItem Pointer to the tab item to be focused.
See also
SetSelectedItem

Reimplemented in CXTPTabControl.

◆ SetHeaderOffset()

void SetHeaderOffset ( int nOffset )

Sets the scroll offset for the tabs in the tab header.

Parameters
nOffset Scroll offset to be set. The value of this parameter must be <= 0. GetHeaderOffset should be used to get the current scroll offset and then add to or subtract from the current scroll offset to move left or right. If the value of this parameter is set to 0, then the tabs will be reset to there starting position.

The scroll offset is how much the tabs have been scrolled by pressing the left and right tab navigation buttons.

The scroll offset starts at zero and remains at zero until there are enough tabs to scroll. If the tabs are scrolled, then the offset will be a negative number indicating how much the tabs have been scrolled to the right.

NOTE: GetHeaderOffset and SetHeaderOffset are used when the left and right tab navigate buttons are pressed to scroll the tabs by 20 pixels to the left or right.

EnsureVisible uses GetHeaderOffset and SetHeaderOffset to ensure that a tab button is visible.

Example: This sample illustrates how to programmatically set the scroll offset of the tabs in the tab header of the CXTPTabClientWnd:

//Scroll the tabs in the tab header to the right by 100 pixels.
m_MTIClientWnd.GetWorkspace(0)->SetHeaderOffset((m_MTIClientWnd.GetWorkspace(0)->GetHeaderOffset())
- 100);

//Scroll the tabs in the tab header to the left by 100 pixels.//
m_MTIClientWnd.GetWorkspace(0)->SetHeaderOffset((m_MTIClientWnd.GetWorkspace(0)->GetHeaderOffset())
+ 100);
See also
GetHeaderOffset, CXTPTabManagerNavigateButton, EnsureVisible

◆ SetItemMetrics()

void SetItemMetrics | ( | CSize | szNormal,
 |  | CSize | szMin = CSize(0, 0),
 |  | CSize | szMax = CSize(0, 0) )

Sets the minimum, maximum, and normal lengths for tab buttons.

Parameters
szNormal | Fixed length to be used for all tabs when the layout is xtpTabLayoutFixed.
szMin | Minimum length to be used for tabs when the layout is not xtpTabLayoutFixed.
szMax | Maximum length to be used for tabs when the layout is not xtpTabLayoutFixed.

The minimum, maximum, and normal lengths of tab buttons are used when calculating the lengths of tabs for each XTPTabLayoutStyle.

szNormal only applies when the layout is xtpTabLayoutFixed. When the layout is xtpTabLayoutFixed, every tab will have a fixed length of szNormal. Otherwise, szMin and szMax represent the lower and upper bounds for the length of individual tabs respectively.

See also
XTPTabLayoutStyle, GetItemMetrics, SetLayoutStyle

◆ SetLayoutStyle()

void SetLayoutStyle ( XTPTabLayoutStyle tabLayout )

Sets the tab layout style.

Parameters
tabLayout Tab layout style to be set. Can be one of the values listed in the Remarks section.

The tab layout style refers to how the tab buttons are sized within the tab client header. The tab buttons can be in either a compressed, fixed, auto-size, or size-to-fit layout.

tabLayout can be one of the following: xtpTabLayoutAutoSize: Tabs will be automatically sized based on the caption and image size. With this flag set, tabs will appear in their normal size. xtpTabLayoutSizeToFit: Tabs are sized to fit within the tab panel. All tabs will be compressed and forced to fit into the tab panel. xtpTabLayoutFixed: All tabs will be set to a fixed size within the tab panel. xtpTabLayoutCompressed: Tabs will be compressed within the tab panel. This will compress the size of the tabs, but all tabs will not be forced into the tab panel. xtpTabLayoutMultiRow: Causes a tab control to display multiple rows of tabs.

See also
XTPTabLayoutStyle, GetLayout

◆ SetPaintManager()

AFX_INLINE void SetPaintManager ( CXTPTabPaintManager * pPaintManager )
virtual

Sets the tab paint manager.

Parameters
pPaintManager Pointer to the tab paint manager to be set.

The tab paint manager is used to customize the appearance of both CXTPTabManagerItem objects and the tab manager (i.e. tab colors, styles, etc.).

Reimplemented in CXTPDockingPaneTabbedContainer, and CXTPTabControl.

◆ SetPosition()

void SetPosition ( XTPTabPosition tabPosition )

Sets the tab position.

Parameters
tabPosition Tab position to be set. Can be one of the values listed in the Remarks section.

The tab position refers to where the tab buttons are located. The tab buttons can be positioned on either the top, bottom, left, or right side of the tab client area.

tabPosition can be one of the following: xtpTabPositionTop: Tabs will be drawn on the top. xtpTabPositionLeft: Tabs will be drawn on the left. xtpTabPositionBottom: Tabs will be drawn on the bottom. xtpTabPositionRight: Tabs will be drawn on the right.

See also
XTPTabPosition, GetPosition

◆ SetSelectedItem()

virtual void SetSelectedItem ( CXTPTabManagerItem * pItem )
virtual

Sets the currently selected tab item.

Parameters
pItem Pointer to the tab item to be selected.

The currently selected tab item is the currently active tab item. A tab item is selected when it has focus or is clicked.

The currently selected tab item can be set by its index within the collection of tab items by using SetCurSel.

See also
CXTPTabManagerItem, GetCurSel, SetCurSel, GetSelectedItem

Reimplemented in CXTPRibbonControlTab, CXTPTabControl, and CXTPTabToolBar.

◆ ShowCloseItemButton()

AFX_INLINE void ShowCloseItemButton ( XTPTabNavigateButtonFlags bCloseItemButton = xtpTabNavigateButtonAlways )

Call this member to show close button for each tab.

Parameters
bCloseItemButton XTPTabNavigateButtonFlags that specify if close button for each tab is visible

◆ ShowIcons()

void ShowIcons ( BOOL bShowIcons )

Shows/hides tab icons.

Parameters
bShowIcons TRUE to show tab icons, FALSE to hide tab icons.

◆ TrackClick()

void TrackClick | ( | HWND | hWnd,
 |  | CPoint | pt,
 |  | CXTPTabManagerItem * | pItem )
 protected

Activates and tracks a specified tab item on mouse click.

Parameters
hWnd | Handle to the CWnd object beneath the mouse cursor.
pt | Specifies the x- and y- coordinates of the mouse cursor. These coordinates are always relative to the upper-left corner of the window.
pItem | Pointer to the tab item to activate and track.

Member Data Documentation

◆ m_arrItems

CArray<CXTPTabManagerItem*, CXTPTabManagerItem*> m_arrItems
protected

Bounding rectangle of the tab client area.

Collection of tabs for this tab manager.

◆ m_bActive

BOOL m_bActive
protected

TRUE if the MDITabClient tab group is active.

This only applies to a TabWorkspace when grouping is enabled.

◆ m_nHeaderOffset

int m_nHeaderOffset
protected

Scroll offset, this is how much the tabs in the tab header have been scrolled using the left and right tab navigation buttons.

See: GetHeaderOffset, SetHeaderOffset.

◆ m_pHighlighted

CXTPTabManagerItem* m_pHighlighted
protected

Tab currently highlighted (i.e.

When the mouse cursor is over the tab button).

◆ m_pSelected

CXTPTabManagerItem* m_pSelected
protected

Tab currently selected (i.e.

when the tab is clicked).

◆ m_rcControl

CRect m_rcControl
protected

Bounding rectangle of the tab manager control.

This is the bounding rectangle for both the tab header and tab client.

The documentation for this class was generated from the following file:
  • XTPTabManager.h


Toolkit Pro: CXTPTabManager::CRowIndexer Class Reference

  • CXTPTabManager
  • CRowIndexer
Public Member Functions | List of all members
CXTPTabManager::CRowIndexer Class Reference

Helper class used to collect the indices of rows for a multi-row tab manager. More...

Public Member Functions

CRowIndexer (CXTPTabManager *pManager)
Constructs a CRowIndexer object.
~CRowIndexer ()
Destroys a CRowIndexer object, handles cleanup and deallocation.
ROW_ITEMS * | CreateIndexer (int nRowCount)
Creates the array of indices for the multi-row tab manager.
ROW_ITEMS * | GetRowItems () const
Gets the array of indices of the multi-row tab manager.

Detailed Description

Helper class used to collect the indices of rows for a multi-row tab manager.

Constructor & Destructor Documentation

◆ CRowIndexer()

CRowIndexer ( CXTPTabManager * pManager )

Constructs a CRowIndexer object.

Parameters
pManager Pointer to the owner tab manager.

Member Function Documentation

◆ CreateIndexer()

ROW_ITEMS * CreateIndexer ( int nRowCount )

Creates the array of indices for the multi-row tab manager.

Parameters
nRowCount Total number of rows in the tab manager.
Returns
A pointer to the array of indices of the multi-row tab manager.

◆ GetRowItems()

AFX_INLINE CXTPTabManager::ROW_ITEMS * GetRowItems ( ) const

Gets the array of indices of the multi-row tab manager.

Returns
A pointer to the array of indices of the multi-row tab manager.
The documentation for this class was generated from the following file:
  • XTPTabManager.h


Toolkit Pro: CXTPTabManager::ROW_ITEMS Struct Reference

  • CXTPTabManager
  • ROW_ITEMS
Public Attributes | List of all members
CXTPTabManager::ROW_ITEMS Struct Reference

Helper structure that contains the first and last item indices of rows of the tab manager. More...

Public Attributes

int | nFirstItem
First item index of row.
int | nLastItem
Last item index of row.

Detailed Description

Helper structure that contains the first and last item indices of rows of the tab manager.

The documentation for this struct was generated from the following file:
  • XTPTabManager.h


Toolkit Pro: CXTPTabManagerAtom Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPTabManagerAtom Class Referenceabstract

CXTPTabManagerAtom is a class that has only one purpose; to catch the event when a property of the PaintManager is changed. More...

Inheritance diagram for CXTPTabManagerAtom:
[legend]

Public Member Functions

virtual void | OnPropertyChanged ()
This method is called when a property of the tab paint manager is changed.
virtual void | Reposition ()=0
Recalculates the layout of the tab manager and then repositions itself.

Protected Member Functions

virtual ~CXTPTabManagerAtom ()
Destroys a CXTPTabManagerAtom object, handles cleanup and deallocation.

Detailed Description

CXTPTabManagerAtom is a class that has only one purpose; to catch the event when a property of the PaintManager is changed.

When a property of the PaintManager is changed, OnPropertyChanged is called. When OnPropertyChanged is caught, Reposition is called to recalculate self-layout.

This is the base class for CXTPTabManager. When a property of the CXTPTabPaintManager is changed, OnPropertyChanged is called to recalculate the layout. The paint manager can be accessed with the CXTPTabManager::GetPaintManager member.

See also
CXTPTabManager::GetPaintManager

Member Function Documentation

◆ OnPropertyChanged()

virtual void OnPropertyChanged ( )
inlinevirtual

This method is called when a property of the tab paint manager is changed.

See also
CXTPTabManager::GetPaintManager

◆ Reposition()

virtual void Reposition ( )
pure virtual

Recalculates the layout of the tab manager and then repositions itself.

This method must be overridden in derived classes.

Implemented in CXTPDockingPaneTabbedContainer, CXTPRibbonControlTab, CXTPTabClientWnd, CXTPTabControl, and CXTPTabToolBar.

The documentation for this class was generated from the following file:
  • XTPTabManagerAtom.h


Toolkit Pro: CXTPTabManagerItem Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPTabManagerItem Class Reference

CXTPTabManagerItem is the base class for the tabs that appear in the command bars tab workspace, docking panes, and tab control. More...

Inheritance diagram for CXTPTabManagerItem:
[legend]

Public Member Functions

void | SetCaption (LPCTSTR lpszCaption)
Sets the text caption for this tab.
virtual CString | GetCaption () const
Gets the text caption of this tab.
void | SetTooltip (LPCTSTR lpszTooltip)
Sets the tooltip for this tab.
CString | GetTooltip () const
Gets the tooltip of this tab.
COLORREF | GetColor ()
Gets the color of the tab button.
void | SetColor (COLORREF clr)
Sets the color for the tab button.
CRect | GetRect () const
Gets the bounding rectangle of the tab button.
int | GetButtonLength () const
Gets the width of the tab button.
int | GetContentLength () const
Gets the width of the content of the tab button.
int | GetIndex () const
Gets the index of this tab within the collection of tabs.
int | GetImageIndex () const
Gets the index of the image displayed in the tab button.
void | SetImageIndex (int nImage)
Sets the index for the image displayed in the tab button.
DWORD_PTR | GetData () const
Gets the application-supplied, 32-bit value associated with the tab item.
void | SetData (DWORD_PTR dwData)
Sets the 32-bit value associated with the tab item.
void | SetHandle (HWND hWnd)
Sets the handle for the object displayed in the tab client area when this tab is selected.
HWND | GetHandle () const
Gets the handle of the object displayed in the tab client area when this tab is selected.
void | SetRect (CRect rcItem)
Sets the bounding rectangle for this tab.
BOOL | IsVisible () const
Determines if this tab is shown/hidden.
virtual void | SetVisible (BOOL bVisible)
Shows/hides this tab.
BOOL | IsEnabled () const
Determines if this tab is enabled/disabled.
void | SetEnabled (BOOL bEnabled)
Enables/disables this tab.
int | GetItemRow () const
Gets the row of this item.
BOOL | IsItemShrinked () const
Determines if this item has shrinked.
CXTPTabManagerNavigateButtons * GetNavigateButtons ()
Gets the collection of navigate buttons.
BOOL | IsSelected () const
Determines the selected state of this tab (i.e.
BOOL | IsFocused () const
Determines the focused state of this tab.
BOOL | IsHighlighted () const
Determines the highlighted state of this tab.
BOOL | IsPressed () const
Determines the pressed state of this tab.
void | Remove ()
Deletes this tab.
void | Select ()
Selects this tab.
void | Move (int nIndex)
Sets the position for this item.
BOOL | IsClosable () const
Determines if this tab is closable.
void | SetClosable (BOOL bClosable)
Specifies if this tab should be closable.
CXTPMarkupUIElement * | GetMarkupUIElement () const
Gets the Markup element used to render the caption of this tab.
BOOL | IsNewWindowTab ()
Determines if this tab is new window.
void | SetNewWindowTab ()
Specifies if this tab is new window.
CXTPTabManager * | GetTabManager () const
Gets the tab manager.
void | DrawImage (CDC *pDC, CRect rcIcon, CXTPImageManagerIcon *pImage)
Draws the icon of a tab.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

CXTPTabManagerItem ()
Constructs a CXTPTabManagerItem object.
virtual | ~CXTPTabManagerItem ()
Destroys a CXTPTabManagerItem object, handles cleanup and deallocation.
void | Reposition ()
Updates the position of the tab manager.
virtual void | OnRemoved ()
This method is called when an item is removed from the tab manager collection.

Protected Attributes

int | m_nButtonLength
Width of the tab button.
int | m_nContentLength
Width of the content of the tab button.
int | m_nImage
Image index; this is the index of the image within a CXTPImageManger or CImageList object.
int | m_nIndex
Index of this tab within the collection of tabs.
BOOL | m_bEnabled
TRUE if this tab is enabled.
BOOL | m_bVisible
TRUE if this tab is visible.
HWND | m_hWnd
CWnd pointer to the window associated with this tab.
HICON | m_hIcon
Icon associated with this tab.
DWORD_PTR | m_dwData
Developer specific data.
CRect | m_rcItem
Rectangle of this tab.
CString | m_strCaption
User specified label for this tab.
CString | m_strToolTip
Tooltip text for this tab.
COLORREF | m_clrItem
Color of the tab button.
CXTPTabManager * | m_pTabManager
Pointer to the parent item.
int | m_nItemRow
Row of this item.
BOOL | m_bClosable
TRUE if this item can be closed.
BOOL | m_bNewWindowTab
TRUE if this item is new window tab.
CXTPTabManagerNavigateButtons | m_arrNavigateButtons
Array of navigate buttons.
CXTPMarkupUIElement * | m_pMarkupUIElement
Markup element pointer.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

CXTPTabManagerItem is the base class for the tabs that appear in the command bars tab workspace, docking panes, and tab control.

Member Function Documentation

◆ DrawImage()

void DrawImage | ( | CDC * | pDC,
 |  | CRect | rcIcon,
 |  | CXTPImageManagerIcon * | pImage )

Draws the icon of a tab.

Parameters
pDC | Pointer to device context to draw.
rcIcon | Bounding rectangle of the icon.
pImage | Pointer to the image associated with the tab.
See also
CXTPImageManagerIcon

◆ GetButtonLength()

AFX_INLINE int GetButtonLength ( ) const

Gets the width of the tab button.

Returns
The width of the tab button.

The width of the tab button may change depending on the layout and position of the tabs.

See also
XTPTabLayoutStyle, XTPTabPosition

◆ GetCaption()

virtual CString GetCaption ( ) const
virtual

Gets the text caption of this tab.

The text caption is the text displayed in the tab button.

Returns
The text caption of this tab.
See also
SetCaption

Reimplemented in CXTPRibbonTab.

◆ GetColor()

COLORREF GetColor ( )

Gets the color of the tab button.

Returns
The color of the tab button.
See also
SetColor, CXTPTabManager::GetItemColor

◆ GetContentLength()

AFX_INLINE int GetContentLength ( ) const

Gets the width of the content of the tab button.

Returns
The width of the content of the tab button.

The width of the content of the tab button may change depending on the layout and position of the tabs.

See also
XTPTabLayoutStyle, XTPTabPosition

◆ GetData()

AFX_INLINE DWORD_PTR GetData ( ) const

Gets the application-supplied, 32-bit value associated with the tab item.

This method returns the "extra" information, such as pointers and/or integers, that was associated with the tab item using the SetData function. Note: Do not use GetData when working with docking pane tabs. With docking panes, GetData returns a pointer to a CXTPDockingPane. Use CXTPDockingPane::GetPaneData when working with docking panes.

Returns
The 32-bit value associated with the tab item.
See also
SetData, CXTPDockingPane::SetPaneData, CXTPDockingPane::GetPaneData

◆ GetHandle()

HWND GetHandle ( ) const

Gets the handle of the object displayed in the tab client area when this tab is selected.

Returns
The handle of the object displayed in the tab client area when this tab is selected.
See also
SetHandle

◆ GetImageIndex()

AFX_INLINE int GetImageIndex ( ) const

Gets the index of the image displayed in the tab button.

Returns
The index of the image displayed in the tab button.

This is the index of the image within either a CXTPImageManager or CImageList object.

CXTPTabManager::ShowIcons is used to show/hide icons.

See also
SetImageIndex, CXTPTabControl::InsertItem, CXTPTabControl::GetImageManager, CXTPTabControl::SetImageList, CXTPTabManager::ShowIcons

◆ GetIndex()

AFX_INLINE int GetIndex ( ) const

Gets the index of this tab within the collection of tabs.

Returns
The index of this tab within the collection of tabs.
See also
CXTPTabManager::GetItem, CXTPTabManager

◆ GetItemRow()

AFX_INLINE int GetItemRow ( ) const

Gets the row of this item.

Returns
The row of this item.

◆ GetMarkupUIElement()

AFX_INLINE CXTPMarkupUIElement * GetMarkupUIElement ( ) const

Gets the Markup element used to render the caption of this tab.

Returns
A pointer to the Markup element used to render the caption of this tab.

◆ GetNavigateButtons()

AFX_INLINE CXTPTabManagerNavigateButtons * GetNavigateButtons ( )

Gets the collection of navigate buttons.

Returns
A pointer to the collection of navigate buttons.
See also
CXTPTabManagerNavigateButtons, CXTPTabManagerNavigateButton

◆ GetRect()

AFX_INLINE CRect GetRect ( ) const

Gets the bounding rectangle of the tab button.

Returns
The bounding rectangle of the tab button.
See also
SetRect

◆ GetTabManager()

AFX_INLINE CXTPTabManager * GetTabManager ( ) const

Gets the tab manager.

The tab manager is used to manage all CXTPTabManagerItem objects.

Returns
A pointer to the tab manager.

◆ GetTooltip()

CString GetTooltip ( ) const

Gets the tooltip of this tab.

The tooltip is the text displayed when the mouse is positioned over the tab button.

Returns
The tooltip of this tab.
See also
SetTooltip, CXTPTabManager::GetItemTooltip

◆ IsClosable()

AFX_INLINE BOOL IsClosable ( ) const

Determines if this tab is closable.

Returns
TRUE if this tab can be closed, otherwise FALSE.

◆ IsEnabled()

BOOL IsEnabled ( ) const

Determines if this tab is enabled/disabled.

Returns
TRUE if this tab is enabled, FALSE if this tab is disabled.
See also
SetEnabled

◆ IsFocused()

AFX_INLINE BOOL IsFocused ( ) const

Determines the focused state of this tab.

Returns
TRUE if this tab has focus, otherwise FALSE.

◆ IsHighlighted()

BOOL IsHighlighted ( ) const

Determines the highlighted state of this tab.

A tab is highlighted when CXTPTabPaintManager::m_bHotTracking is TRUE and either the mouse pointer is positioned over the tab button or the tab is being dragged (i.e. when reordering tabs).

Returns
TRUE if this tab is highlighted, otherwise FALSE.
See also
IsPressed, IsFocused

◆ IsItemShrinked()

AFX_INLINE BOOL IsItemShrinked ( ) const

Determines if this item has shrinked.

Returns
TRUE if this item has shrinked, otherwise FALSE.

◆ IsNewWindowTab()

AFX_INLINE BOOL IsNewWindowTab ( )

Determines if this tab is new window.

Returns
TRUE if this tab is new window, otherwise FALSE.

◆ IsPressed()

BOOL IsPressed ( ) const

Determines the pressed state of this tab.

Returns
TRUE if this tab is pressed, otherwise FALSE.
See also
IsHighlighted

◆ IsSelected()

BOOL IsSelected ( ) const

Determines the selected state of this tab (i.e.

if this tab is clicked).

Returns
TRUE if this tab is selected, otherwise FALSE.

◆ IsVisible()

BOOL IsVisible ( ) const

Determines if this tab is shown/hidden.

Returns
TRUE if this tab is shown, FALSE if this tab is hidden.

A tab may not be visible due to the tab layout.

See also
SetVisible

◆ Move()

void Move ( int nIndex )

Sets the position for this item.

Parameters
nIndex Position to be set.

◆ Select()

void Select ( )

Selects this tab.

This method calls OnItemClick.

A tab can also be selected by clicking on it.

◆ SetCaption()

void SetCaption ( LPCTSTR lpszCaption )

Sets the text caption for this tab.

Parameters
lpszCaption Text caption to be set.

The text caption is the text displayed in the tab button.

See also
GetCaption

◆ SetClosable()

void SetClosable ( BOOL bClosable )

Specifies if this tab should be closable.

Parameters
bClosable TRUE to allow this tab to be closed, FALSE to disallow this tab from being closed.

◆ SetColor()

void SetColor ( COLORREF clr )

Sets the color for the tab button.

Parameters
clr Color to be set.

This method calls CXTPTabManager::RedrawControl after the color is set.

See also
GetColor, CXTPTabManager::GetItemColor

◆ SetData()

AFX_INLINE void SetData ( DWORD_PTR dwData )

Sets the 32-bit value associated with the tab item.

Parameters
dwData Value to be set.

This method allows for "extra" information, such as pointers and/or integers to be associated with the tab item. Note: Do not use SetData when working with docking pane tabs. With docking panes, dwData stores a pointer to a CXTPDockingPane. Use CXTPDockingPane::SetPaneData when working with docking panes.

See also
SetData, CXTPDockingPane::SetPaneData

◆ SetEnabled()

void SetEnabled ( BOOL bEnabled )

Enables/disables this tab.

Parameters
bEnabled TRUE to enable this tab, FALSE to disable this tab.

If a tab is disabled, then it will appear "grayed out" and will be inaccessible to the user.

See also
IsEnabled

◆ SetHandle()

void SetHandle ( HWND hWnd )

Sets the handle for the object displayed in the tab client area when this tab is selected.

Parameters
hWnd Handle of the object to be set.
See also
GetHandle

◆ SetImageIndex()

void SetImageIndex ( int nImage )

Sets the index for the image displayed in the tab button.

Parameters
nImage Index to be set.

This is the index of the image within either a CXTPImageManager or CImageList object.

CXTPTabManager::ShowIcons is used to show/hide icons.

See also
GetImageIndex, CXTPTabControl::InsertItem, CXTPTabControl::GetImageManager, CXTPTabControl::SetImageList, CXTPTabManager::ShowIcons

◆ SetRect()

void SetRect ( CRect rcItem )

Sets the bounding rectangle for this tab.

Parameters
rcItem Bounding rectangle to be set.
See also
GetRect

◆ SetTooltip()

AFX_INLINE void SetTooltip ( LPCTSTR lpszTooltip )

Sets the tooltip for this tab.

Parameters
lpszTooltip Tooltip to be set.

The tooltip is the text displayed when the mouse is positioned over the tab button.

See also
GetTooltip, CXTPTabManager::GetItemTooltip

◆ SetVisible()

virtual void SetVisible ( BOOL bVisible )
virtual

Shows/hides this tab.

Parameters
bVisible TRUE to show this tab, FALSE to hide this tab.
See also
IsVisible

Reimplemented in CXTPRibbonTab.

The documentation for this class was generated from the following files:
  • XTPTabManagerItem.h
  • XTPTabManager.h


Toolkit Pro: CXTPTabManagerNavigateButton Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPTabManagerNavigateButton Class Referenceabstract

CXTPTabManagerNavigateButton is a class used to represent a tab navigation button. More...

Public Member Functions

CXTPTabManagerNavigateButton (CXTPTabManager *pManager, UINT nID, XTPTabNavigateButtonFlags dwFlags)
Constructs a CXTPTabManagerNavigateButton object.
virtual void | AdjustWidth (int &nWidth)
Adjusts the width of the tab header area.
void | SetFlags (XTPTabNavigateButtonFlags dwFlags)
Specifies when the navigation button is displayed.
XTPTabNavigateButtonFlags | GetFlags () const
Determines when the navigation button is displayed.
virtual CSize | GetSize () const
Gets the size of the navigation button.
CXTPTabManagerItem * | GetItem () const
Gets the parent item of the navigation button.
void | Draw (CDC *pDC)
Draws the navigation button in the tab header area.
virtual void | PerformClick (HWND hWnd, CPoint pt)
This method is called when the user presses the left mouse button.
BOOL | IsEnabled () const
Determines if the navigation button is enabled/disabled.
BOOL | IsPressed () const
Determines the pressed state of the navigation button.
BOOL | IsHighlighted () const
Determines the highlighted state of the navigation button.
BOOL | IsOwnerSelected () const
Determines the selected state of the owner tab button.
BOOL | IsOwnerHighlighted () const
Determines the highlighted state of the owner tab button.
BOOL | IsOwnerNull () const
Determines if the navigation button is either a common navigation item or owned by a tab item.
BOOL | IsOwnerActive () const
Determines if this tab group is active/inactive.
BOOL | IsVisible () const
Determines the visible state of the navigation button.
CRect | GetRect () const
Gets the bounding rectangle of the navigation button.
void | SetRect (CRect rcButton)
Sets the bounding rectangle for the navigation button.
UINT | GetID () const
Gets the identifier of the navigation button.
virtual void | Reposition (CRect &rcNavigateButtons)
Updates the position of the navigation button.
void | SetTooltip (LPCTSTR lpszTooltip)
Sets the tooltip for the navigation button.
CString | GetTooltip () const
Gets the tooltip of the navigation button.
virtual void | DrawEntry (CDC *pDC, CRect rc, COLORREF clr, BOOL bEnabled)=0
Draws a symbol in the navigation button (i.e.
virtual void | OnExecute (BOOL bTick)
This method is called when a navigation button is clicked.

Protected Member Functions

virtual ~CXTPTabManagerNavigateButton ()
Destroys a CXTPTabManagerNavigateButton object, handles cleanup and deallocation.

Protected Attributes

UINT | m_nID
ID of the navigation button.
XTPTabNavigateButtonFlags | m_dwFlags
Flag that indicates when the navigation button will be drawn.
CXTPTabManager * | m_pManager
Pointer to the tab manager the navigation buttons are drawn on.
CRect | m_rcButton
Bounding rectangle of the navigation button.
BOOL | m_bEnabled
TRUE if the navigation button is enabled.
BOOL | m_bPressed
TRUE if the navigation button is pressed/clicked.
CString | m_strToolTip
Tooltip for the button.
CXTPTabManagerItem * m_pItem
Owner item.

Detailed Description

CXTPTabManagerNavigateButton is a class used to represent a tab navigation button.

Navigation buttons are the buttons that appear in the tab header area. The buttons include the left arrow, right arrow, and close buttons. Any combination of these buttons can be shown. You can choose to never display then, always display them, or automatically display them. If you automatically display the buttons, they are only displayed when needed (e.g. when there are too many tabs to be displayed in the tab header, the arrow buttons will appear).

By default, all these buttons are displayed in the command bars tab workspace. You must add them to the tab control.

If the xtpTabNavigateButtonAutomatic flag is used, then buttons will only appear when needed (e.g. when there are too many tabs to be displayed in the tab header, the arrow buttons will appear).

Example: This example code illustrates how to specify when the tab navigation buttons are displayed:

//Finds the left navigation button and specifies that it is always displayed
m_wndTabControl.FindNavigateButton(xtpTabNavigateButtonLeft)->SetFlags(xtpTabNavigateButtonAlways);
//Finds the right navigation button and specifies that it is never displayed
m_wndTabControl.FindNavigateButton(xtpTabNavigateButtonRight)->SetFlags(xtpTabNavigateButtonNone);
//Finds the close navigation button and specifies that it is always displayed
m_wndTabControl.FindNavigateButton(xtpTabNavigateButtonClose)->SetFlags(xtpTabNavigateButtonAlways);

//Called to recalculate tab area and reposition components
Reposition();
See also
XTPTabNavigateButtonFlags, CXTPTabManager::FindNavigateButton

Constructor & Destructor Documentation

◆ CXTPTabManagerNavigateButton()

CXTPTabManagerNavigateButton | ( | CXTPTabManager * | pManager,
 |  | UINT | nID,
 |  | XTPTabNavigateButtonFlags | dwFlags )

Constructs a CXTPTabManagerNavigateButton object.

Parameters
pManager | CXTPTabManager object to draw the button on.
nID | ID of the button; can be one of the values listed in the Remarks section.
dwFlags | Indicates when to display the button.

Standard IDs of buttons are listed below: xtpTabNavigateButtonLeft: Left tab navigation button. xtpTabNavigateButtonRight: Right tab navigation button. xtpTabNavigateButtonClose: Close tab navigation button.

See also
CXTPTabManager::FindNavigateButton, XTPTabNavigateButtonFlags, XTPTabNavigateButton

Member Function Documentation

◆ AdjustWidth()

virtual void AdjustWidth ( int & nWidth )
virtual

Adjusts the width of the tab header area.

Parameters
nWidth Reference to the width of the tab header area.

If the tabs are horizontal, then the width of the tab header area is adjusted by subtracting the width of the navigation button from nWidth.

If the tabs are vertical, then the width of the tab header area is adjusted by subtracting the height of the navigation button from nWidth.

The width will only be adjusted if the xtpTabNavigateButtonAlways flag is set.

◆ Draw()

void Draw ( CDC * pDC )

Draws the navigation button in the tab header area.

Parameters
pDC Pointer to a valid device context.

◆ DrawEntry()

virtual void DrawEntry | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | COLORREF | clr,
 |  | BOOL | bEnabled )
 pure virtual

Draws a symbol in the navigation button (i.e.

either "left", "right" or "x").

Parameters
pDC | Pointer to a valid device context.
rc | Bounding rectangle of the navigation button.
clr | Button color.
bEnabled | TRUE if the button is enabled.

This method must be overridden in derived classes.

◆ GetFlags()

AFX_INLINE XTPTabNavigateButtonFlags GetFlags ( ) const

Determines when the navigation button is displayed.

Returns
Flags that indicate when the navigation button is displayed; one of the values defined by the XTPTabNavigateButtonFlags enumeration.
See also
XTPTabNavigateButtonFlags, CXTPTabManager::FindNavigateButton, SetFlags

◆ GetID()

AFX_INLINE UINT GetID ( ) const

Gets the identifier of the navigation button.

Returns
The identifier of the navigation button.

See XTPTabNavigateButton for the list of standard identifiers.

See also
XTPTabNavigateButton

◆ GetItem()

AFX_INLINE CXTPTabManagerItem * GetItem ( ) const

Gets the parent item of the navigation button.

Returns
A pointer to the parent item of the navigation button.

◆ GetRect()

AFX_INLINE CRect GetRect ( ) const

Gets the bounding rectangle of the navigation button.

Returns
The bounding rectangle of the navigation button.

◆ GetSize()

virtual CSize GetSize ( ) const
virtual

Gets the size of the navigation button.

Returns
The size of the navigation button.
See also
GetRect

◆ GetTooltip()

AFX_INLINE CString GetTooltip ( ) const

Gets the tooltip of the navigation button.

The tooltip is the text displayed when the mouse is positioned over the navigation button.

Returns
The tooltip of the navigation button.
See also
SetTooltip

◆ IsEnabled()

AFX_INLINE BOOL IsEnabled ( ) const

Determines if the navigation button is enabled/disabled.

Returns
TRUE if the navigation button is enabled, FALSE if the navigation button is disabled.

◆ IsHighlighted()

BOOL IsHighlighted ( ) const

Determines the highlighted state of the navigation button.

The navigation button becomes highlighted when the mouse cursor is positioned over it.

This method is used within both CXTPTabColorSetDefault::FillNavigateButton and all objects derived from CXTPTabColorSetDefault to determine how to colorize the navigation button.

Returns
TRUE if the navigation button is highlighted, otherwise FALSE.
See also
CXTPTabColorSetDefault::FillNavigateButton

◆ IsOwnerActive()

BOOL IsOwnerActive ( ) const

Determines if this tab group is active/inactive.

Returns
TRUE if this tab group is active, FALSE if this tab group is inactive.

This method only applies to tab groups in the MDITabClient (i.e. the tabs groups that appear in the CommandBars TabWorkspace) when grouping is enabled.

◆ IsOwnerHighlighted()

BOOL IsOwnerHighlighted ( ) const

Determines the highlighted state of the owner tab button.

Returns
TRUE if the owner tab button is highlighted, otherwise FALSE.

◆ IsOwnerNull()

BOOL IsOwnerNull ( ) const

Determines if the navigation button is either a common navigation item or owned by a tab item.

Returns
TRUE if the navigation button is a common navigation item, FALSE if the navigation button is owned by a tab item.

◆ IsOwnerSelected()

BOOL IsOwnerSelected ( ) const

Determines the selected state of the owner tab button.

Returns
TRUE if the owner tab button is selected, otherwise FALSE.

◆ IsPressed()

AFX_INLINE BOOL IsPressed ( ) const

Determines the pressed state of the navigation button.

Returns
TRUE if the navigation button is pressed, otherwise FALSE.

This method is used within both CXTPTabColorSetDefault::FillNavigateButton and all objects derived from CXTPTabColorSetDefault to determine how to colorize the navigation button.

See also
CXTPTabColorSetDefault::FillNavigateButton

◆ IsVisible()

AFX_INLINE BOOL IsVisible ( ) const

Determines the visible state of the navigation button.

Returns
TRUE if the navigation button is visible, otherwise FALSE.

◆ OnExecute()

virtual void OnExecute ( BOOL bTick )
virtual

This method is called when a navigation button is clicked.

Parameters
bTick If TRUE, then CXTPTabManager::OnNavigateButtonClick will be called to pass in the identifier of the navigation button that was clicked.

◆ PerformClick()

virtual void PerformClick | ( | HWND | hWnd,
 |  | CPoint | pt )
 virtual

This method is called when the user presses the left mouse button.

Parameters
hWnd | Handle to the CWnd object beneath the mouse cursor.
pt | Specifies the x- and y- coordinates of the mouse cursor. These coordinates are always relative to the upper-left corner of the window.

This method performs the common operations of when a button is clicked (e.g. drawing the "pressed" button and calling the OnExecute member of the clicked tab navigation button).

When the user clicks on a tab navigation button, this method will call the OnExecute member of the clicked tab navigation button. OnExecute will then call CXTPTabManager::OnNavigateButtonClick to pass in the indentifier of the tab navigation button that was pressed.

See also
CXTPTabManager::OnNavigateButtonClick

◆ Reposition()

virtual void Reposition ( CRect & rcNavigateButtons )
virtual

Updates the position of the navigation button.

Parameters
rcNavigateButtons Reference to the bounding rectangle of the navigation buttons.

◆ SetFlags()

AFX_INLINE void SetFlags ( XTPTabNavigateButtonFlags dwFlags )

Specifies when the navigation button is displayed.

Parameters
dwFlags Flags that indicate when the navigation button is displayed; must be one of the values defined by the XTPTabNavigateButtonFlags enumeration.
See also
XTPTabNavigateButtonFlags, CXTPTabManager::FindNavigateButton, GetFlags

◆ SetRect()

void SetRect ( CRect rcButton )

Sets the bounding rectangle for the navigation button.

Parameters
rcButton Bounding rectangle to be set.

◆ SetTooltip()

AFX_INLINE void SetTooltip ( LPCTSTR lpszTooltip )

Sets the tooltip for the navigation button.

Parameters
lpszTooltip Tooltip to be set.

The tooltip is the text displayed when the mouse is positioned over the navigation button.

See also
GetTooltip

Member Data Documentation

◆ m_pItem

CXTPTabManagerItem* m_pItem
protected

Owner item.

NULL if common.

The documentation for this class was generated from the following file:
  • XTPTabManagerNavigateButton.h


Toolkit Pro: CXTPTabManagerNavigateButtons Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPTabManagerNavigateButtons Class Reference

CXTPTabManagerNavigateButtons is a class used to represent a collection of tab navigation buttons. More...

Public Member Functions

CXTPTabManagerNavigateButtons ()
Constructs a CXTPTabManagerNavigateButtons object.
virtual | ~CXTPTabManagerNavigateButtons ()
Destroys a CXTPTabManagerNavigateButtons object, handles cleanup and deallocation.
CXTPTabManagerNavigateButton * | GetAt (int nIndex) const
Retrieves the tab navigation button at a specified index in the collection.
CXTPTabManagerNavigateButton * | operator[] (int nIndex) const
Retrieves the tab navigation button at a specified index in the collection.
int | Add (CXTPTabManagerNavigateButton *pButton)
Adds a specified tab navigation button to the collection.
void | InsertAt (int nIndex, CXTPTabManagerNavigateButton *pButton)
Inserts a specified tab navigation button to the collection.
void | RemoveAt (int nIndex)
Removes the tab navigation button at a specified index from the collection.
void | RemoveAll ()
Removes all tab navigation buttons from the collection.
int | GetSize () const
Gets the number of tab navigation buttons in the collection.

Protected Attributes

CArray< CXTPTabManagerNavigateButton *, CXTPTabManagerNavigateButton * > m_arrButtons
Collection of tab navigation buttons.

Detailed Description

CXTPTabManagerNavigateButtons is a class used to represent a collection of tab navigation buttons.

Member Function Documentation

◆ Add()

AFX_INLINE int Add ( CXTPTabManagerNavigateButton * pButton )

Adds a specified tab navigation button to the collection.

Parameters
pButton Pointer to the tab navigation button to be added.
Returns
The zero-based index of the newly added tab navigation button.

◆ GetAt()

AFX_INLINE CXTPTabManagerNavigateButton * GetAt ( int nIndex ) const

Retrieves the tab navigation button at a specified index in the collection.

Parameters
nIndex Zero-based index of the tab navigation button to retrieve.
Returns
A pointer to the tab naviation navigation button at the specified index in the collection if successful, otherwise NULL.

◆ GetSize()

AFX_INLINE int GetSize ( ) const

Gets the number of tab navigation buttons in the collection.

Returns
The number of tab navigation buttons in the collection.

◆ InsertAt()

AFX_INLINE void InsertAt | ( | int | nIndex,
 |  | CXTPTabManagerNavigateButton * | pButton )

Inserts a specified tab navigation button to the collection.

Parameters
nIndex | Zero-based index to insert the tab navigation button at.
pButton | Pointer to the tab navigation button to be inserted.

◆ operator[]()

AFX_INLINE CXTPTabManagerNavigateButton * operator[] ( int nIndex ) const

Retrieves the tab navigation button at a specified index in the collection.

Parameters
nIndex Zero-based index of the tab navigation button to retrieve.
Returns
A pointer to the tab naviation navigation button at the specified index in the collection if successful, otherwise NULL.

◆ RemoveAt()

void RemoveAt ( int nIndex )

Removes the tab navigation button at a specified index from the collection.

Parameters
nIndex Index of the tab navigation button to be removed.
The documentation for this class was generated from the following file:
  • XTPTabManagerNavigateButtons.h


Toolkit Pro: CXTPTabPaintManager Class Reference

Public Member Functions | Static Public Member Functions | Public Attributes | Static Public Attributes | Protected Member Functions | Protected Attributes | List of all members
CXTPTabPaintManager Class Reference

CXTPTabPaintManager is used to store the color and appearance information of the tabs in the tab manager. More...

Inheritance diagram for CXTPTabPaintManager:
[legend]

Public Member Functions

CXTPTabPaintManager (BOOL bPanelManager=FALSE)
Constructs a CXTPTabPaintManager object.
virtual | ~CXTPTabPaintManager ()
Destroys a CXTPTabPaintManager object, handles cleanup and deallocation.
virtual CXTPTabPaintManagerColorSet * | SetColor (XTPTabColorStyle tabColor)
Applies one of the "built-in" color sets for the tabs.
virtual CXTPTabPaintManagerColorSet * | SetColorSet (CXTPTabPaintManagerColorSet *pColorSet)
Applies a custom color set for the tabs.
virtual CXTPTabPaintManagerTheme * | SetAppearance (XTPTabAppearanceStyle tabAppearance)
Applies one of the "built-in" appearance sets for the tabs.
virtual CXTPTabPaintManagerTheme * | SetAppearanceSet (CXTPTabPaintManagerTheme *pAppearanceSet)
Applies a custom appearance set for the tabs.
CXTPTabPaintManagerTheme * | GetAppearanceSet () const
Gets the currently applied custom appearance set.
CXTPTabPaintManagerColorSet * | GetColorSet () const
Gets the currently applied custom color set.
XTPTabAppearanceStyle | GetAppearance () const
Gets the currently applied "built-in appearance set.
XTPTabColorStyle | GetColor () const
Gets the currently applied "built-in" color set.
BOOL | IsLunaColorsDisabled () const
Determines if luna colors are disabled/enabled.
void | DisableLunaColors (BOOL bDisableLunaColors)
Disables/enables luna colors.
void | SetOneNoteColors (BOOL bOneNoteColors)
Enables/disables OneNote colorization for the tabs.
void | SetPosition (XTPTabPosition tabPosition)
Sets the tab position.
void | SetLayout (XTPTabLayoutStyle tabLayout)
Sets the tab layout style.
XTPTabPosition | GetPosition () const
Gets the tab position.
XTPTabLayoutStyle | GetLayout () const
Gets the tab layout style.
void | SetFontIndirect (LOGFONT *pLogFont, BOOL bUseStandardFont=FALSE)
Sets the font for the tabs.
virtual void | DrawTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl)
Draws the tab control.
virtual void | AdjustClientRect (CXTPTabManager *pTabManager, CRect &rcClient)
Adjusts the tab client rectangle.
virtual void | RepositionTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl)
Moves the tab buttons of the tab control to their correct positions.
CRect | RepositionNavigateButtons (CXTPTabManager *pTabManager, CRect rcClient)
Repositions the tab navigation buttons.
void | FillNavigateButton (CDC *pDC, CXTPTabManagerNavigateButton *pButton, CRect &rc)
Fills a specified tab navigation button.
virtual void | DrawNavigateButton (CDC *pDC, CXTPTabManagerNavigateButton *pButton, CRect &rc)
Draws a specified tab navigation button.
virtual int | DrawSingleButtonIconAndText (CDC *pDC, CXTPTabManagerItem *pItem, CRect rcItem, BOOL bDraw)
Draws the text and icon of a specified tab button.
void | EnsureVisible (CXTPTabManager *pTabManager, CXTPTabManagerItem *pItem)
Ensures that a specified tab is visible.
virtual void | RefreshMetrics ()
Refreshes the visual metrics of the main tab manager.
void | AddObserver (CXTPTabManagerAtom *pObserver)
Adds a control to the list of controls that receives a notification when a property of the paint manager is changed.
void | EnableToolTips (XTPTabToolTipBehaviour behaviour=xtpTabToolTipAlways)
Sets the behaviour for tooltips.
CFont * | GetFont (BOOL bVertical=FALSE)
Gets the font used to display caption text in the tab buttons.
CFont * | GetBoldFont (BOOL bVertical=FALSE)
Gets the font used to display bold caption text in the tab buttons.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Static Public Member Functions

static COLORREF AFX_CDECL | GetOneNoteColor (XTPTabOneNoteColor tabColor)
Retrieves the RGB value of a specified OneNote color.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Public Attributes

BOOL | m_bHotTracking
If TRUE, then tab hot tracking will be enabled.
BOOL | m_bShowIcons
If TRUE, then tab icons will be drawn if icons were added.
BOOL | m_bBoldSelected
If TRUE, then the text of selected tabs will be displayed in bold font.
BOOL | m_bBoldNormal
If TRUE, then bold font will be used for all tabs regardless of whether they are selected or non-selected.
BOOL | m_bOneNoteColors
If FALSE, then tabs will not use luna colors * the current theme uses luna colors.
XTPTabClientFrame m_clientFrame
If TRUE, then tabs will use OneNote colorization.
BOOL | m_bStaticFrame
If TRUE, then a static frame will be drawn around the entire tab area.
CRect | m_rcClientMargin
Margin around the tab client area.
CRect | m_rcControlMargin
Margin around the entire tab control (i.e.
CRect | m_rcButtonMargin
Margin around the text in tab button.
CRect | m_rcButtonTextPadding
Margin around the text in tab button.
BOOL | m_bInvertGradient
If TRUE, then the colors passed into CXTPTabPaintManagerColorSet::GradientFill will be swapped before the rectangle is filled with the gradient.
BOOL | m_bFillBackground
If TRUE, then the tab client space is filled using CXTPTabPaintManager.CXTPTabPaintManagerColorSet.m_clrControlFace color.
CSize | m_szIcon
Size of the icon displayed in the tab button.
BOOL | m_bDrawTextPathEllipsis
If TRUE, when the size of a tab button is too small to display the caption, the middle of the caption will be replaced with an ellipse "...".
BOOL | m_bDrawTextEndEllipsis
If TRUE, when the size of a tab button is too small to display the caption, the end of the caption will be replaced with an ellipse "...".
BOOL | m_bDrawTextNoPrefix
If FALSE, then an ampersand '&' in the tab button caption will be ignored and a double ampersand '&&' will display a single ampersand '&'.
UINT | m_nDrawTextFormat
Text format for tabs (default - DT_LEFT | DT_VCENTER).
BOOL | m_bDrawTextHidePrefix
If FALSE, then an ampersand '&' in the tab button caption will be ignored and a double ampersand '&&' will display a single ampersand '&'.
BOOL | m_bMultiRowFixedSelection
FALSE to move row with selected item close to client pane.
BOOL | m_bMultiRowJustified
TRUE to stretch each row of tabs to fill the entire width of the control.
BOOL | m_bDrawFocusRect
TRUE to draw focus rect for focused item.
int | m_bSelectOnDragOver
1 - to activate tab when user drag files/text under it.
int | m_nButtonExtraLength
Additional padding of tabs.
BOOL | m_bSelectOnButtonDown
If TRUE, then tab selected on mouse button down.
BOOL | m_bClearTypeTextQuality
TRUE to enable ClearType text for the font.
BOOL | m_bRotateImageOnVerticalDraw
TRUE to rotate image when tab located left or right.
BOOL | m_bClipHeader
TRUE to select clip rectangle before draw tabs.
CSize | m_szNavigateButton
Navigate buttons size.
CSize | m_szTabCloseButton
Tab close button size.
BOOL | m_bShowTabs
TRUE to show tabs.
BOOL | m_bMultiRowTabsOptimization
TRUE if the tab manager will arrange tabs according to their widths.
int | m_nMinTabWidth
Minimum tabs width.
int | m_nMaxTabWidth
Maximum tabs width.
int | m_nFixedTabWidth
Tabs width for fixed layout.
XTPTabToolTipBehaviour | m_toolBehaviour
Tootips behaviour.
BOOL | m_bVerticalTextTopToBottom
Draw vertical text Top-to-Bottom or Bottom-to-Top.
BOOL | m_bPanelManager
TRUE indicates that this is a panel manager, FALSE for tab manager.

Static Public Attributes

static DWORD m_nSelectOnDragOverDelay
Delay before Select-on-Drag-Over (300 by default).

Protected Member Functions

void | SizeToFit (CXTPTabManager *pTabManager, int nWidth)
Changes the tab button size when XTPTabLayoutStyle is set to xtpTabLayoutSizeToFit.
void | DrawTabControlEx (CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl)
Draws the tab control.
void | RepositionTabControlEx (CXTPTabManager *pTabManager, CDC *pDC, CRect rcClient)
Moves the tab buttons of the tab control to their correct positions.
void | RepositionTabControlMultiRow (CXTPTabManager *pTabManager, CDC *pDC, CRect rcClient)
Moves the tab buttons of the multi-row tab control to their correct positions.
virtual void | OnPropertyChanged ()
This method is called when a property of the tab paint manager is changed.
int | _GetButtonLength (int nValue, int nMin, int nMax)
Gets the total button length of a tab button including the left and right button margins.
void | DrawTextPathEllipsis (CDC *pDC, CXTPTabManager *pManager, const CString &strItem, CRect rcItem, UINT uFormat)
Draws an ellipse "..." in the middle of a specified string.

Protected Attributes

CXTPTabPaintManagerTheme * | m_pAppearanceSet
Currently set CXTPTabPaintManagerTheme.
CXTPTabPaintManagerColorSet * | m_pColorSet
Currently used CXTPTabPaintManagerColorSet.
CArray< CXTPTabManagerAtom *, CXTPTabManagerAtom * > | m_arrObservers
List of controls that receive a notification when a property of the paint manager has changed.
XTPTabAppearanceStyle | m_tabAppearance
Currently set appearance style.
XTPTabColorStyle | m_tabColor
Currently used color style.
XTPTabPosition m_tabPosition
Currently set tab button position.
XTPTabLayoutStyle m_tabLayout
Currently set tab button layout.
CXTPFont | m_xtpFontNormal
Font used to display text in tab buttons.
CXTPFont m_xtpFontBold
Font used to display bold text in the tab buttons (i.e.
CXTPFont | m_xtpFontVerticalNormal
Font used to display tab button caption when the tab position is vertical.
CXTPFont m_xtpFontVerticalBold
Font used to display bold text in the tab buttons when the tab position is vertical (i.e.
BOOL | m_bUseStandardFont
TRUE to use standard system "icon" font (i.e.

Detailed Description

CXTPTabPaintManager is used to store the color and appearance information of the tabs in the tab manager.

Constructor & Destructor Documentation

◆ CXTPTabPaintManager()

CXTPTabPaintManager ( BOOL bPanelManager = FALSE )

Constructs a CXTPTabPaintManager object.

Parameters
bPanelManager TRUE indicates that this is a panel manager, FALSE for tab manager.

Member Function Documentation

◆ _GetButtonLength()

int _GetButtonLength | ( | int | nValue,
 |  | int | nMin,
 |  | int | nMax )
 protected

Gets the total button length of a tab button including the left and right button margins.

Parameters
nValue | Width of the tab button.
nMin | Minimum width of the tab button.
nMax | Maximum width of the tab button.
Returns
The total button length of a tab button including the left and right button margins.
See also
CXTPTabManager::GetItemMetrics

◆ AddObserver()

void AddObserver ( CXTPTabManagerAtom * pObserver )

Adds a control to the list of controls that receives a notification when a property of the paint manager is changed.

Parameters
pObserver Pointer to the control to be added to the list of controls.

This method is not used in the MFC version. This method is only used in the ActiveX version and does nothing in MFC.

◆ AdjustClientRect()

virtual void AdjustClientRect | ( | CXTPTabManager * | pTabManager,
 |  | CRect & | rcClient )
 virtual

Adjusts the tab client rectangle.

Parameters
pTabManager | Pointer to the tab manager to adjust the tab client rectangle.
rcClient | [out] Reference to a CRect object to receive the new tab client rectangle with margins included.

Both AdjustClientRect and RepositionTabControl are called when the window is resized. When DrawTabControl is called, the changes will be used when drawing the tab control.

This method will adjust the tab client rectangle of the entire tab manager if IsDrawStaticFrame is TRUE in order to make room to draw the static frame.

CXTPTabPaintManagerTheme::AdjustClientRect will be called if there is one or more tabs in the tab manager.

See also
CXTPTabPaintManagerTheme::AdjustClientRect

◆ DisableLunaColors()

void DisableLunaColors ( BOOL bDisableLunaColors )

Disables/enables luna colors.

Parameters
bDisableLunaColors TRUE to disable luna colors, FALSE to enable luna colors.

Luna colors are the Windows XP colors (Silver, Blue, Olive). CXTPDrawHelpers::GetCurrentSystemTheme can be called to get the currently used system theme.

See also
IsLunaColorsDisabled, XTPCurrentSystemTheme, CXTPDrawHelpers::GetCurrentSystemTheme

◆ DrawNavigateButton()

virtual void DrawNavigateButton | ( | CDC * | pDC,
 |  | CXTPTabManagerNavigateButton * | pButton,
 |  | CRect & | rc )
 virtual

Draws a specified tab navigation button.

Parameters
pDC | Pointer to a valid device context.
pButton | Pointer to the tab navigation button to draw.
rc | Reference to the bounding rectangle of the tab navigation button.
See also
CXTPTabPaintManagerColorSet::FillNavigateButton, CXTPTabManager::GetNavigateButton, CXTPTabManagerNavigateButton

◆ DrawSingleButtonIconAndText()

virtual int DrawSingleButtonIconAndText | ( | CDC * | pDC,
 |  | CXTPTabManagerItem * | pItem,
 |  | CRect | rcItem,
 |  | BOOL | bDraw )
 virtual

Draws the text and icon of a specified tab button.

Parameters
pDC | Pointer to a valid device context.
pItem | Pointer to the tab button to draw the text and icon of.
rcItem | Bounding rectangle of the tab.
bDraw | TRUE to draw the tab button's text and icon, FALSE to only calculate the button width (no drawing is performed).
Returns
If bDraw is TRUE, then a value of 0 is returned. If bDraw is FALSE, then the button width including both the left and right button margins is returned.

This method is only used to draw the text and icon of a tab button. This method does not draw the tab button.

CXTPTabPaintManagerTheme::DrawSingleButton calls CXTPTabPaintManager::DrawSingleButtonIconAndText after the button is drawn to draw the button's icon and text.

See also
CXTPTabPaintManager::DrawTabControlEx, CXTPTabPaintManagerTheme::DrawSingleButton

◆ DrawTabControl()

virtual void DrawTabControl | ( | CXTPTabManager * | pTabManager,
 |  | CDC * | pDC,
 |  | CRect | rcControl )
 virtual

Draws the tab control.

Parameters
pTabManager | Pointer to the tab manager to draw.
pDC | Pointer to a valid device context.
rcControl | Bounding rectangle of the client area.

This method is called during various Draw and Paint functions.

This method will call CXTPTabPaintManagerTheme::DrawTabControl for the currently set appearance. CXTPTabPaintManagerTheme::DrawTabControl will then call CXTPTabPaintManager::DrawTabControlEx.

◆ DrawTabControlEx()

void DrawTabControlEx | ( | CXTPTabManager * | pTabManager,
 |  | CDC * | pDC,
 |  | CRect | rcControl )
 protected

Draws the tab control.

Parameters
pTabManager | Pointer to the tab manager to draw.
pDC | Pointer to a valid device context.
rcControl | Bounding rectangle of the client area.

DrawTabControl calls CXTPTabPaintManagerTheme::DrawTabControl which will then call DrawTabControlEx if it has not been overridden.

See also
CXTPTabPaintManagerTheme::DrawTabControl

◆ DrawTextPathEllipsis()

void DrawTextPathEllipsis | ( | CDC * | pDC,
 |  | CXTPTabManager * | pManager,
 |  | const CString & | strItem,
 |  | CRect | rcItem,
 |  | UINT | uFormat )
 protected

Draws an ellipse "..." in the middle of a specified string.

Parameters
pDC | Pointer to a valid device context.
pManager | Pointer to the tab manager to draw.
strItem | Reference to the string item to draw the ellipse in.
rcItem | Bounding rectangle of the tab button. This is the rectangle (in logical coordinates) in which the text is to be formatted.
uFormat | See nFormat parameter of CDC DrawText.

◆ EnableToolTips()

AFX_INLINE void EnableToolTips ( XTPTabToolTipBehaviour behaviour = xtpTabToolTipAlways )

Sets the behaviour for tooltips.

Parameters
behaviour Tooltips behaviour to be set. See the Remarks section for available flags.

The behaviour parameter can be one of the following: xtpTabToolTipNever: Never show tooltips for tabs. xtpTabToolTipAlways: Always show tooltips for tabs. xtpTabToolTipShrinkedOnly: Only show tooltips if the tab was shrinked (see xtpTabLayoutSizeToFit layout).

◆ EnsureVisible()

void EnsureVisible | ( | CXTPTabManager * | pTabManager,
 |  | CXTPTabManagerItem * | pItem )

Ensures that a specified tab is visible.

Parameters
pTabManager | Pointer to the tab manager that the tab is on.
pItem | Pointer to the tab to ensure the visibility of.
See also
CXTPTabManager::SetHeaderOffset, CXTPTabManager::GetHeaderOffset

◆ FillNavigateButton()

void FillNavigateButton | ( | CDC * | pDC,
 |  | CXTPTabManagerNavigateButton * | pButton,
 |  | CRect & | rc )

Fills a specified tab navigation button.

Parameters
pDC | Pointer to a valid device context.
pButton | Pointer to the tab navigation button to fill.
rc | Reference to the bounding rectangle of the tab navigation button.

This method calls m_pColorSet->FillNavigateButton.

The XTPTabColorStyle CXTPTabPaintManagerColorSet classes override this method to perform actions such as painting the highlighted, pressed, and normal versions of tab navigation buttons.

See also
CXTPTabPaintManagerColorSet::FillNavigateButton, CXTPTabManager::GetNavigateButton, CXTPTabManagerNavigateButton

◆ GetAppearance()

XTPTabAppearanceStyle GetAppearance ( ) const

Gets the currently applied "built-in appearance set.

Returns
The currently applied "built-in" appearance set; one of the values defined by the XTPTabAppearanceStyle enumeration.

An appearance set specifies how tabs will look. This is the actual physical structure of the tab buttons. For example, tab buttons with an Excel appearance set will have a half-hexagon shape.

See also
XTPTabAppearanceStyle, GetAppearanceSet, SetAppearanceSet, SetAppearance

◆ GetAppearanceSet()

AFX_INLINE CXTPTabPaintManagerTheme * GetAppearanceSet ( ) const

Gets the currently applied custom appearance set.

Returns
A pointer to the currently applied custom appearance set.

An appearance set specifies how tabs will look. This is the actual physical structure of the tab buttons. For example, tab buttons with an Excel appearance set will have a half-hexagon shape.

SetColorSet is used to set custom colors.

See the GUI_Eclipse sample for an example of how to create a custom appearance set and apply it for the tabs.

See also
GetAppearanceSet, SetAppearanceSet, SetAppearance

◆ GetBoldFont()

AFX_INLINE CFont * GetBoldFont ( BOOL bVertical = FALSE )

Gets the font used to display bold caption text in the tab buttons.

Parameters
bVertical TRUE if XTPTabPosition is vertical, FALSE if XTPTabPosition is horizontal.
Returns
The font used to display bold caption text in the tab buttons.

Bold font is used to display caption text when a tab is selected and m_bBoldSelected = TRUE.

If m_bBoldNormal = TRUE, then tabs will use bold font even when they are not selected.

See also
m_bBoldNormal, m_bBoldSelected, GetFont

◆ GetColor()

XTPTabColorStyle GetColor ( ) const

Gets the currently applied "built-in" color set.

Returns
The currently applied "built-in" color set.

Color sets are used to colorize the tabs. For example, applying the xtpTabColorWinNative color set will give the tabs a Windows XP colorization.

See also
XTPTabColorStyle, SetColor, GetColorSet, SetColorSet

◆ GetColorSet()

AFX_INLINE CXTPTabPaintManagerColorSet * GetColorSet ( ) const

Gets the currently applied custom color set.

Returns
A pointer to the currently applied custom color set.

Color sets are used to colorize the tabs. For example, applying the xtpTabColorWinNative color set will give the tabs a Windows XP colorization.

See also
XTPTabColorStyle, GetColor, SetColorSet, SetColor

◆ GetFont()

AFX_INLINE CFont * GetFont ( BOOL bVertical = FALSE )

Gets the font used to display caption text in the tab buttons.

Parameters
bVertical TRUE if XTPTabPosition is vertical, FALSE if XTPTabPosition is horizontal.
Returns
The font used to display caption text in the tab buttons.
See also
GetBoldFont

◆ GetLayout()

XTPTabLayoutStyle GetLayout ( ) const

Gets the tab layout style.

Returns
The tab layout style; one of the values defined by the XTPTabLayoutStyle enumeration.

The tab layout style refers to how the tab buttons are sized within the tab client header. The tab buttons can be in either a compressed, fixed, auto-size, or size-to-fit layout.

See also
XTPTabLayoutStyle, SetLayoutStyle

◆ GetOneNoteColor()

static COLORREF AFX_CDECL GetOneNoteColor ( XTPTabOneNoteColor tabColor )
static

Retrieves the RGB value of a specified OneNote color.

Parameters
tabColor XTPTabOneNoteColor flag indicating which OneNote color to retrieve the RGB value of. See remarks section for available flags.

The tab manager calls this member function to retrieve the RGB color for the value specified by tabColor. tabColor can be one of the following values: xtpTabColorBlue: Blue tab color used when OneNote colors are enabled. xtpTabColorYellow: Yellow tab color used when OneNote colors are enabled. xtpTabColorGreen: Green tab color used when OneNote colors are enabled. xtpTabColorRed: Red tab color used when OneNote colors are enabled. xtpTabColorPurple: Purple tab color used when OneNote colors are enabled. xtpTabColorCyan: Cyan tab color used when OneNote colors are enabled. xtpTabColorOrange: Orange tab color used when OneNote colors are enabled. xtpTabColorMagenta: Magenta tab color used when OneNote colors are enabled.

Returns
The RGB value of the specified OneNote color.

Example: See WM_XTP_GETTABCOLOR for an example.

See also
XTPTabOneNoteColor

◆ GetPosition()

XTPTabPosition GetPosition ( ) const

Gets the tab position.

Returns
The tab position; one of the values defined by the XTPTabPosition enumeration.

The tab position refers to where the tab buttons are located. The tab buttons can be positioned on either the top, bottom, left, or right side of the tab client area.

See also
XTPTabPosition, SetPosition

◆ IsLunaColorsDisabled()

BOOL IsLunaColorsDisabled ( ) const

Determines if luna colors are disabled/enabled.

Returns
TRUE if luna colors are disabled, FALSE is luna colors are enabled.

Luna colors are the Windows XP colors (Silver, Blue, Olive). CXTPDrawHelpers::GetCurrentSystemTheme can be called to get the currently used system theme.

See also
DisableLunaColors, XTPCurrentSystemTheme, CXTPDrawHelpers::GetCurrentSystemTheme

◆ RefreshMetrics()

virtual void RefreshMetrics ( )
virtual

Refreshes the visual metrics of the main tab manager.

This method checks if m_bUseStandardFont is TRUE. If m_bUseStandardFont is TRUE, then this method updates the font with the standard system "icon" font (i.e. Tahoma 8pt).

This method calls RefreshMetrics for the currently used CXTPTabPaintManagerColorSet and CXTPTabPaintManagerTheme.

◆ RepositionNavigateButtons()

CRect RepositionNavigateButtons | ( | CXTPTabManager * | pTabManager,
 |  | CRect | rcClient )

Repositions the tab navigation buttons.

Parameters
pTabManager | Pointer to the tab manager that the tab navigation buttons are on.
rcClient | Client rectangle of the tab control.
Returns
The bounding rectangle of the tab header (including header margins).

CXTPTabPaintManager::RepositionTabControlEx calls this method to reposition the tab navigation buttons.

◆ RepositionTabControl()

virtual void RepositionTabControl | ( | CXTPTabManager * | pTabManager,
 |  | CDC * | pDC,
 |  | CRect | rcControl )
 virtual

Moves the tab buttons of the tab control to their correct positions.

Parameters
pTabManager | Pointer to the tab manager that the tab buttons are on.
pDC | Pointer to a valid device context.
rcControl | Client rectangle of the tab control.

Both AdjustClientRect and RepositionTabControl are called when the window is resized. When DrawTabControl is called, the changes will be used when drawing the tab control.

CXTPTabPaintManagerTheme::RepositionTabControl will be called for the currently set appearance.

◆ RepositionTabControlEx()

void RepositionTabControlEx | ( | CXTPTabManager * | pTabManager,
 |  | CDC * | pDC,
 |  | CRect | rcClient )
 protected

Moves the tab buttons of the tab control to their correct positions.

Parameters
pTabManager | Pointer to the tab manager that the tab buttons are on.
pDC | Pointer to a valid device context.
rcClient | Client rectangle of the tab control.

Both AdjustClientRect and RepositionTabControl are called when the window is resized. When DrawTabControl is called, the changes will be used when drawing the tab control.

RepositionTabControl calls CXTPTabPaintManagerTheme::RepositionTabControl which will then call RepositionTabControlEx if it has not been overridden.

See also
CXTPTabPaintManagerTheme::RepositionTabControl

◆ RepositionTabControlMultiRow()

void RepositionTabControlMultiRow | ( | CXTPTabManager * | pTabManager,
 |  | CDC * | pDC,
 |  | CRect | rcClient )
 protected

Moves the tab buttons of the multi-row tab control to their correct positions.

Parameters
pTabManager | Pointer to the tab manager that the tab buttons are on.
pDC | Pointer to a valid device context.
rcClient | Client rectangle of the tab control.

◆ SetAppearance()

virtual CXTPTabPaintManagerTheme * SetAppearance ( XTPTabAppearanceStyle tabAppearance )
virtual

Applies one of the "built-in" appearance sets for the tabs.

Parameters
tabAppearance "Built-in" appearance set to be applied; must be one of the values defined by the XTPTabAppearanceStyle enumeration.
Returns
A pointer to the newly applied "built-in" appearance set.

Use SetAppearance to apply a "built-in" appearance. Use SetAppearanceSet to apply a custom appearance.

An appearance set specifies how tabs will look. This is the actual physical structure of the tab buttons. For example, tab buttons with an Excel appearance set will have a half-hexagon shape.

See also
XTPTabAppearanceStyle, SetAppearanceSet, GetAppearance, GetAppearanceSet, SetColor, GetColor, GetColorSet, SetColorSet

Reimplemented in CXTPDockingPanePanelPaintManager, and CXTPDockingPaneTabPaintManager.

◆ SetAppearanceSet()

virtual CXTPTabPaintManagerTheme * SetAppearanceSet ( CXTPTabPaintManagerTheme * pAppearanceSet )
virtual

Applies a custom appearance set for the tabs.

Parameters
pAppearanceSet Pointer to the custom appearance set to be applied.

Use SetAppearance to apply a "built-in" appearance. Use SetAppearanceSet to apply a custom appearance.

An appearance set specifies how tabs will look. This is the actual physical structure of the tab buttons. For example, tab buttons with an Excel appearance set will have a half-hexagon shape.

SetColorSet is used to set custom colors.

See the GUI_Eclipse sample for an example of how to create a custom appearance set and apply it for the tabs.

Returns
A pointer to the newly applied custom appearance set.
See also
XTPTabAppearanceStyle, SetAppearance, GetAppearance, GetAppearanceSet, SetColor, GetColor, GetColorSet, SetColorSet

◆ SetColor()

virtual CXTPTabPaintManagerColorSet * SetColor ( XTPTabColorStyle tabColor )
virtual

Applies one of the "built-in" color sets for the tabs.

Parameters
tabColor "Built-in" color set to be applied; must be one of the values defined by the XTPTabColorStyle enumeration.
Returns
A pointer to the newly applied "built-in" color set.

Use SetColor to apply a "built-in" color set. Use SetColorSet to apply a custom color set.

Color sets are used to colorize the tabs. For example, applying the xtpTabColorWinNative color set will give the tabs a Windows XP colorization.

See also
XTPTabColorStyle, SetColorSet, GetColor, GetColorSet, XTPTabAppearanceStyle, SetAppearanceSet, SetAppearance, GetAppearance, GetAppearanceSet

Reimplemented in CXTPDockingPanePanelPaintManager, and CXTPDockingPaneTabPaintManager.

◆ SetColorSet()

virtual CXTPTabPaintManagerColorSet * SetColorSet ( CXTPTabPaintManagerColorSet * pColorSet )
virtual

Applies a custom color set for the tabs.

Parameters
pColorSet Pointer to the custom color set to be applied.
Returns
A pointer to the newly applied custom color set.

Use SetColor to apply a "built-in" color set. Use SetColorSet to apply a custom color set.

Color sets are used to colorize the tabs. For example, applying the xtpTabColorWinNative color set will give the tabs a Windows XP colorization.

See also
XTPTabColorStyle, SetColor, GetColor, GetColorSet, XTPTabAppearanceStyle, SetAppearanceSet, SetAppearance, GetAppearance, GetAppearanceSet

◆ SetFontIndirect()

void SetFontIndirect | ( | LOGFONT * | pLogFont,
 |  | BOOL | bUseStandardFont = FALSE )

Sets the font for the tabs.

Parameters
pLogFont | Font to be set.
bUseStandardFont | The value of this parameter should only be TRUE when this method is called internally. Otherwise the value of this parameter should always be FALSE to indicate that pLogFont should be used as the font for the tabs.

When bUseStandardFont is TRUE, the standard system "icon" font will be used (i.e. Tahoma 8pt).

◆ SetLayout()

void SetLayout ( XTPTabLayoutStyle tabLayout )

Sets the tab layout style.

Parameters
tabLayout Tab layout style to be set; must be one of the values defined by the XTPTabLayoutStyle enumeration.

The tab layout style refers to how the tab buttons are sized within the tab client header. The tab buttons can be in either a compressed, fixed, auto-size, or size-to-fit layout.

See also
XTPTabPosition, GetLayout

◆ SetOneNoteColors()

void SetOneNoteColors ( BOOL bOneNoteColors )

Enables/disables OneNote colorization for the tabs.

Parameters
bOneNoteColors TRUE to enable OneNote colorization, FALSE to disable OneNote colorization.

OneNote colors are similar to the tab colorization for tabs in Microsoft OneNote.

◆ SetPosition()

void SetPosition ( XTPTabPosition tabPosition )

Sets the tab position.

Parameters
tabPosition Tab position to be set; must be one of the values defined by the XTPTabPosition enumeration.

The tab position refers to where the tab buttons are located. The tab buttons can be positioned on either the top, bottom, left, or right side of the tab client area.

See also
XTPTabPosition, GetPosition

◆ SizeToFit()

void SizeToFit | ( | CXTPTabManager * | pTabManager,
 |  | int | nWidth )
 protected

Changes the tab button size when XTPTabLayoutStyle is set to xtpTabLayoutSizeToFit.

Parameters
pTabManager | Pointer to the tab manager.
nWidth | Total width that all tab buttons must fit within.

When calculating nWidth, the width of both the left and right rcHeaderMargin and the width of the tab navigation button should be subtracted from the width of the tab client.

See also
XTPTabLayoutStyle, SetLayout, GetLayout

Member Data Documentation

◆ m_bDrawTextEndEllipsis

BOOL m_bDrawTextEndEllipsis

If TRUE, when the size of a tab button is too small to display the caption, the end of the caption will be replaced with an ellipse "...".

If FALSE, then the end of the caption will be replaced with the ellipse.

◆ m_bDrawTextHidePrefix

BOOL m_bDrawTextHidePrefix

If FALSE, then an ampersand '&' in the tab button caption will be ignored and a double ampersand '&&' will display a single ampersand '&'.

If TRUE, then the caption will be hidden.

◆ m_bDrawTextNoPrefix

BOOL m_bDrawTextNoPrefix

If FALSE, then an ampersand '&' in the tab button caption will be ignored and a double ampersand '&&' will display a single ampersand '&'.

If TRUE, then the caption will be displayed unmodified.

◆ m_bDrawTextPathEllipsis

BOOL m_bDrawTextPathEllipsis

If TRUE, when the size of a tab button is too small to display the caption, the middle of the caption will be replaced with an ellipse "...".

If FALSE, then the end of the caption will be replaced with the ellipse.

◆ m_bFillBackground

BOOL m_bFillBackground

If TRUE, then the tab client space is filled using CXTPTabPaintManager.CXTPTabPaintManagerColorSet.m_clrControlFace color.

This is only FALSE when drawing docking pane panel auto-hide tabs because there is no client area to draw.

◆ m_bMultiRowTabsOptimization

BOOL m_bMultiRowTabsOptimization

TRUE if the tab manager will arrange tabs according to their widths.

TRUE by default. Otherwise plain ordering.

◆ m_bSelectOnDragOver

int m_bSelectOnDragOver

1 - to activate tab when user drag files/text under it.

2 - to activate with small delay.

◆ m_bUseStandardFont

BOOL m_bUseStandardFont
protected

TRUE to use standard system "icon" font (i.e.

Tahoma 8pt).

◆ m_clientFrame

XTPTabClientFrame m_clientFrame

If TRUE, then tabs will use OneNote colorization.

Frame style of the tab client area.

◆ m_rcControlMargin

CRect m_rcControlMargin

Margin around the entire tab control (i.e.

tab client header and tab client area).

◆ m_tabLayout

XTPTabLayoutStyle m_tabLayout
protected

Currently set tab button layout.

The layout refers to how the tab buttons are sized within the tab client header.

◆ m_tabPosition

XTPTabPosition m_tabPosition
protected

Currently set tab button position.

The position refers to where the tab buttons are located. The tab buttons can be positioned on the top, bottom, left, or right side of the tab client area.

◆ m_xtpFontBold

CXTPFont m_xtpFontBold
protected

Font used to display bold text in the tab buttons (i.e.

when a tab is selected and m_bBoldSelected = TRUE).

◆ m_xtpFontVerticalBold

CXTPFont m_xtpFontVerticalBold
protected

Font used to display bold text in the tab buttons when the tab position is vertical (i.e.

when a tab is selected and m_bBoldSelected = TRUE).

The documentation for this class was generated from the following file:
  • XTPTabPaintManager.h


Toolkit Pro: CXTPTabPaintManagerColorSet Class Reference

Classes | Public Member Functions | Public Attributes | Protected Attributes | List of all members
CXTPTabPaintManagerColorSet Class Referenceabstract

CXTPTabPaintManagerColorSet represents the colors for all of the components of the tab manager (e.g. More...

Inheritance diagram for CXTPTabPaintManagerColorSet:
[legend]

Classes

struct | COLORSET_TAB_EXCEL
Colors used for Excel tab button colorization. More...
struct | COLORSET_TAB_PROPERTYPAGE
Colors used for Office 2000 tab button colorization. More...
struct | COLORSET_TAB_PROPERTYPAGE2003
Colors used for Office 2003 tab button colorization. More...
struct | COLORSET_TAB_STATEBUTTON
Colors used for "State Button" tab button colorization. More...

Public Member Functions

CXTPTabPaintManagerColorSet ()
Constructs a CXTPTabPaintManagerColorSet object.
virtual | ~CXTPTabPaintManagerColorSet ()
Destroys a CXTPTabPaintManagerColorSet object, handles cleanup and deallocation.
virtual void | RefreshMetrics ()
Refreshes the visual metrics of the tabs.
virtual void | SetTextColor (CDC *pDC, CXTPTabManagerItem *pItem)
Sets the text color for the tab.
virtual void | FillHeader (CDC *pDC, CRect rc, CXTPTabManager *pTabManager)
Fills the header of the tab client of a specified tab manager.
virtual COLORREF | FillClient (CDC *pDC, CRect rc, CXTPTabManager *pTabManager)
Fills the tab client area of a specified tab manager.
virtual COLORREF | GetClientColor (CXTPTabManager *pTabManager)
Obtains client background color.
virtual void | FillStateButton (CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem)
Fills a specified tab button when XTPTabAppearanceStyle is xtpTabAppearanceStateButtons.
virtual COLORREF | FillPropertyButton (CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem)
Fills a specified tab button.
virtual void | SelectClipRgn (CDC *pDC, CRect rcClient, CXTPTabManager *pTabManager)
Sets a clipping region for the specified tab client area.
virtual void | FillNavigateButton (CDC *pDC, CXTPTabManagerNavigateButton *pButton, CRect &rc)=0
Fills a specified tab navigation button.
virtual COLORREF | GetItemColor (CXTPTabManagerItem *pItem)
Retrieves the color of a specified tab.
void | GradientFill (CDC *pDC, CRect rc, COLORREF clrLight, COLORREF clrDark, XTPTabPosition position)
Performs a gradient fill of a rectangle with a color that smoothly fades from top to bottom.
virtual BOOL | IsAppThemed () const
Determines if Windows XP themes are enabled and if a Windows XP theme is currently used.

Public Attributes

CXTPPaintManagerColorGradient | m_clrHeaderFace
Color set of the tab header background.
CXTPPaintManagerColorGradient m_clrAutoHideFace
Color set of the auto-hide panel background.
CXTPPaintManagerColor | m_clrFrameBorder
Color of the border placed around the tab buttons and the tab client.
CXTPPaintManagerColor m_clrControlFace
Color of the control foreground.
CXTPPaintManagerColor | m_clrPaneFace
Color of the control pane foreground.
CXTPPaintManagerColor | m_clrBorderHighlight
Color of the highlight border.
CXTPPaintManagerColor | m_clrTabClientBack
Background color for the tab client area.
CXTPPaintManagerColor | m_clrTabClientBorder
Border color for the tab client area.
CXTPPaintManagerColor m_clrButtonNormal
Color of normal tabs.
CXTPPaintManagerColor | m_clrButtonPressed
Tab pressed button color.
CXTPPaintManagerColor | m_clrButtonHighlighted
Tab button color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonHighlightedClose
Tab close button color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonBorderHighlighted
Tab button border color on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrButtonBorderTabContext1
Tab button border color with tab context.
CXTPPaintManagerColor | m_clrButtonBorderTabContext2
Tab button border color with tab context.
CXTPPaintManagerColor | m_clrButtonBorderKeyTips
Tab button border color when ALT button is pressed.
CXTPPaintManagerColor | m_clrButtonSelected
Color of the currently selected tab.
CXTPPaintManagerColor | m_clrButtonSelectedPressed
Color of the currently selected tab when pressed.
CXTPPaintManagerColor | m_clrButtonSelectedHighlighted
Color of the currently selected tab when highlighted.
CXTPPaintManagerColor | m_clrButtonBorder
Tab button border (edge) color.
CXTPPaintManagerColor | m_clrButtonBorderHot
Tab button highlight or pressed border (edge) color.
CXTPPaintManagerColor m_clrTextNormal
Color of text in a normal tab.
CXTPPaintManagerColor m_clrTextPressed
Color of text in a "pressed" tab button.
CXTPPaintManagerColor | m_clrTextHighlight
Color of text on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | m_clrTextHighlightClose
Color of close button text on mouse over when hot tracking is enabled.
CXTPPaintManagerColor m_clrTextSelected
Color of text in a "selected" tab button.
CXTPPaintManagerColor m_clrTextSelectedPressed
Color of text in a "pressed" tab button.
CXTPPaintManagerColor | m_clrTextSelectedHighlighted
Color of text for tabs in all non-active groups of tabs in MDITabClient.
CXTPPaintManagerColor m_clrTextDisabled
Color of text when a tab is disabled.
CXTPPaintManagerColor | m_clrActiveFilesGlyph
Color of navigation button.
CXTPPaintManagerColor | m_clrActiveFilesGlyphHighlighted
Color of highlighted navigation button.
CXTPPaintManagerColor | m_clrActiveFilesGlyphPressed
Color of selected navigation button.
CXTPPaintManagerColor | m_clrActiveFilesBack
Color of highlighted navigation button background.
CXTPPaintManagerColor | m_clrActiveFilesBackHighlighted
Color of navigation button background.
CXTPPaintManagerColor | m_clrActiveFilesBackPressed
Color of selected navigation button background.
COLORSET_TAB_STATEBUTTON | m_csStateButton
Color set of state button style tabs.
COLORSET_TAB_PROPERTYPAGE | m_csPropertyPage
Color set of visual studio style tabs.
COLORSET_TAB_PROPERTYPAGE2003 | m_csPropertyPage2003
Color set of Office 2003 style tabs.
COLORSET_TAB_EXCEL | m_csExcelSelected
Color set of selected (focused) Excel style tabs.
COLORSET_TAB_EXCEL | m_csExcelNormal
Color set of normal Excel style tabs.

Protected Attributes

CXTPTabPaintManager * m_pPaintManager
Self paint manager pointer.

Detailed Description

CXTPTabPaintManagerColorSet represents the colors for all of the components of the tab manager (e.g.

tab button, tab button border, etc.).

CXTPTabPaintManagerColorSet colorizes the different parts that make up a tab, tab header, tab client, and tab manager control.

Colors should be updated by using the RefreshMetrics method for each CXTPTabPaintManagerColorSet object.

Member Function Documentation

◆ FillClient()

virtual COLORREF FillClient | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | CXTPTabManager * | pTabManager )
 virtual

Fills the tab client area of a specified tab manager.

Parameters
pDC | Pointer to a valid device context.
rc | Bounding rectangle of the tab client area.
pTabManager | Pointer to the tab manager with the tab client area to fill.

The tab client bounding rectangle can be retrieved by using the CXTPTabPaintManagerTheme::GetClientRect and CXTPTabManager::GetClientRect members.

Returns
The fill color value.

Reimplemented in CColorSetWinNative.

◆ FillHeader()

virtual void FillHeader | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | CXTPTabManager * | pTabManager )
 virtual

Fills the header of the tab client of a specified tab manager.

Parameters
pDC | Pointer to a valid device context.
rc | Bounding rectangle of the tab header.
pTabManager | Pointer to the tab manager with the header to fill.

The tab client header is the bounding rectangle containing the tab buttons. The bounding rectangle can be retrieved by using the CXTPTabPaintManagerTheme::GetHeaderRect and CXTPTabManager::GetHeaderRect methods.

See also
CXTPTabPaintManagerTheme::GetHeaderRect, CXTPTabManager::GetHeaderRect

Reimplemented in CXTPDockingPaneTabColorSet2012, CXTPDockingPaneTabColorSet2013, CXTPDockingPaneTabColorSet2015, CXTPDockingPaneTabColorSet2017, CXTPDockingPaneTabColorSet2019, CXTPDockingPaneTabColorSet2022, CXTPDockingPaneTabColorSetNativeWindows10, CXTPDockingPaneTabColorSetNativeWindows11, CXTPDockingPaneTabColorSetVisualStudio2003, and CXTPTabColorSetVisualStudio2010.

◆ FillNavigateButton()

virtual void FillNavigateButton | ( | CDC * | pDC,
 |  | CXTPTabManagerNavigateButton * | pButton,
 |  | CRect & | rc )
 pure virtual

Fills a specified tab navigation button.

Parameters
pDC | Pointer to a valid device context.
pButton | Pointer to the tab navigation button to fill.
rc | Reference to the bounding rectangle of the tab navigation button.

This method is used to fill the tab navigation buttons in the header of the tab client and is overridden by XTPTabColorStyle and CXTPTabPaintManagerColorSet to perform actions such as painting the highlighted, pressed, and normal versions of tab navigation buttons.

This method must be overridden.

See also
CXTPTabManager::GetNavigateButton, CXTPTabManagerNavigateButton

Implemented in CColorSetVisualStudio2003, CColorSetWinNative, CXTPDockingPanePanelColorSet2012, CXTPDockingPaneTabColorSet2012, CXTPDockingPaneTabColorSet2013, CXTPTabColorSetDefault, CXTPTabColorSetOffice2003, CXTPTabColorSetOffice2007, CXTPTabColorSetOffice2013, CXTPTabColorSetVisualStudio2010, CXTPTabColorSetVisualStudio2012, and CXTPTabColorSetVisualStudio2015.

◆ FillPropertyButton()

virtual COLORREF FillPropertyButton | ( | CDC * | pDC,
 |  | CRect | rcItem,
 |  | CXTPTabManagerItem * | pItem )
 virtual

Fills a specified tab button.

Parameters
pDC | Pointer to a valid device context.
rcItem | Bounding rectangle of the tab button to fill.
pItem | Pointer to the tab button to fill.
Returns
The color of the specified tab button.

This method is used to fill all tab buttons except when XTPTabAppearanceStyle is set to xtpTabAppearanceStateButtons. xtpTabAppearanceStateButtons requires the FillStateButton member.

See also
FillStateButton

Reimplemented in CColorSetVisualStudio2005, CColorSetWinNative, CXTPDockingPaneTabColorSetVisualStudio2003, CXTPTabColorSetOffice2003, CXTPTabColorSetOffice2013, CXTPTabColorSetVisualStudio2008, CXTPTabColorSetVisualStudio2010, and CXTPTabColorSetVisualStudio2015.

◆ FillStateButton()

virtual void FillStateButton | ( | CDC * | pDC,
 |  | CRect | rcItem,
 |  | CXTPTabManagerItem * | pItem )
 virtual

Fills a specified tab button when XTPTabAppearanceStyle is xtpTabAppearanceStateButtons.

Parameters
pDC | Pointer to a valid device context.
rcItem | Bounding rectangle of the tab button to fill.
pItem | Pointer to the tab button to fill.

This method is only used to fill buttons when XTPTabAppearanceStyle is xtpTabAppearanceStateButtons. Otherwise, FillPropertyButton is used.

See also
FillPropertyButton

Reimplemented in CColorSetWinNative.

◆ GetClientColor()

virtual COLORREF GetClientColor ( CXTPTabManager * pTabManager )
virtual

Obtains client background color.

Parameters
pTabManager Pointer to the tab manager with the tab client area to fill.
Returns
Client area background color value.

Reimplemented in CXTPTabColorSetOffice2013, CXTPTabColorSetVisualStudio2012, and CXTPTabColorSetVisualStudio2015.

◆ GetItemColor()

virtual COLORREF GetItemColor ( CXTPTabManagerItem * pItem )
virtual

Retrieves the color of a specified tab.

Parameters
pItem Pointer to the tab with the color to retrieve.
Returns
The color of the tab.

This method is used within many of CXTPTabPaintManagerColorSet's "fill" methods.

See also
CXTPTabManager::GetItemColor, XTPTabColorStyle, SetColor, GetColorSet, SetColorSet

Reimplemented in CXTPDockingPanePanelColorSet2012, CXTPDockingPaneTabColorSet2012, CXTPDockingPaneTabColorSet2013, CXTPTabColorSetOffice2013, CXTPTabColorSetVisualStudio2012, and CXTPTabColorSetVisualStudio2015.

◆ GradientFill()

void GradientFill | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | COLORREF | clrLight,
 |  | COLORREF | clrDark,
 |  | XTPTabPosition | position )

Performs a gradient fill of a rectangle with a color that smoothly fades from top to bottom.

Parameters
pDC | Pointer to a valid device context.
rc | Rectangle to fill.
clrLight | COLORREF to start the gradient from.
clrDark | COLORREF to end the gradient with.
position | Position of the tab buttons; one of the values defined by the XTPTabPosition enumeration.

The color smoothly fades from clrLight at the top to clrDark at the bottom.

If clrLight is XTP_TABMANAGER_COLOR_SHADED, then the rectangle will be filled with a special "shaded" fill type and clrDark will be ignored. See the description of XTP_TABMANAGER_COLOR_SHADED for more information on this fill type.

See also
XTP_TABMANAGER_COLOR_SHADED

◆ IsAppThemed()

virtual BOOL IsAppThemed ( ) const
virtual

Determines if Windows XP themes are enabled and if a Windows XP theme is currently used.

Returns
Always returns FALSE in the base class implementation.

This method is overridden in CXTPTabPaintManager::CColorSetWinNative.

See also
CXTPTabPaintManager::CColorSetWinNative::IsAppThemed

Reimplemented in CColorSetWinNative.

◆ RefreshMetrics()

virtual void RefreshMetrics ( )
virtual

Refreshes the visual metrics of the tabs.

Override this method to change the colors of the color members.

All of the color members are refreshed when this method is called.

Reimplemented in CColorSetVisualStudio2003, CColorSetVisualStudio2005, CColorSetWinNative, CXTPDockingPanePanelColorSet2012, CXTPDockingPanePanelColorSet2013, CXTPDockingPanePanelColorSet2015, CXTPDockingPanePanelColorSet2017, CXTPDockingPanePanelColorSet2019, CXTPDockingPanePanelColorSet2022, CXTPDockingPanePanelColorSetNativeWindows10, CXTPDockingPanePanelColorSetNativeWindows11, CXTPDockingPaneTabColorSet2012, CXTPDockingPaneTabColorSet2013, CXTPDockingPaneTabColorSetOfficePanel, CXTPDockingPaneTabColorSetVisualStudio2003, CXTPDockingPaneTabColorSetVisualStudio2005, CXTPTabColorSetDefault, CXTPTabColorSetNativeWindows10, CXTPTabColorSetNativeWindows11, CXTPTabColorSetOffice2003, CXTPTabColorSetOffice2007, CXTPTabColorSetOffice2007Access, CXTPTabColorSetOffice2013, CXTPTabColorSetVisualStudio2008, CXTPTabColorSetVisualStudio2010, CXTPTabColorSetVisualStudio2012, CXTPTabColorSetVisualStudio2012Dark, CXTPTabColorSetVisualStudio2015, CXTPTabColorSetVisualStudio2017, CXTPTabColorSetVisualStudio2019, and CXTPTabColorSetVisualStudio2022.

◆ SelectClipRgn()

virtual void SelectClipRgn | ( | CDC * | pDC,
 |  | CRect | rcClient,
 |  | CXTPTabManager * | pTabManager )
 virtual

Sets a clipping region for the specified tab client area.

Parameters
pDC | Pointer to a valid device context.
rcClient | Bounding rectangle of the tab client area. This will be the clipping region for the device context.
pTabManager | Pointer to the tab manager.

Reimplemented in CColorSetWinNative.

◆ SetTextColor()

virtual void SetTextColor | ( | CDC * | pDC,
 |  | CXTPTabManagerItem * | pItem )
 virtual

Sets the text color for the tab.

Parameters
pDC | Pointer to a valid device context.
pItem | Pointer to the tab to set the text color of.

Reimplemented in CXTPTabColorSetOffice2013, CXTPTabColorSetVisualStudio2010, and CXTPTabColorSetVisualStudio2015.

Member Data Documentation

◆ m_clrAutoHideFace

CXTPPaintManagerColorGradient m_clrAutoHideFace

Color set of the auto-hide panel background.

This is the tab header for docking pane tabs when the pane is hidden.

◆ m_clrButtonNormal

CXTPPaintManagerColor m_clrButtonNormal

Color of normal tabs.

Normal tabs are tabs that are not selected or disabled.

◆ m_clrControlFace

CXTPPaintManagerColor m_clrControlFace

Color of the control foreground.

This is the area that the tab header and tab client are drawn on.

◆ m_clrTextDisabled

CXTPPaintManagerColor m_clrTextDisabled

Color of text when a tab is disabled.

A disabled tab cannot receive focus.

◆ m_clrTextNormal

CXTPPaintManagerColor m_clrTextNormal

Color of text in a normal tab.

Normal tabs are tabs that are not selected or disabled.

◆ m_clrTextPressed

CXTPPaintManagerColor m_clrTextPressed

Color of text in a "pressed" tab button.

The "pressed" tab button is the tab with focus (i.e. the tab becomes active when it is clicked).

◆ m_clrTextSelected

CXTPPaintManagerColor m_clrTextSelected

Color of text in a "selected" tab button.

The "selected" tab button is the tab with focus (i.e. the tab becomes active when it is clicked).

◆ m_clrTextSelectedPressed

CXTPPaintManagerColor m_clrTextSelectedPressed

Color of text in a "pressed" tab button.

The "pressed" tab button is the tab with focus (i.e. The tab becomes active when it is clicked).

The documentation for this class was generated from the following file:
  • XTPTabPaintManagerColorSet.h


Toolkit Pro: CXTPTabPaintManagerColorSet::COLORSET_TAB_EXCEL Struct Reference

  • CXTPTabPaintManagerColorSet
  • COLORSET_TAB_EXCEL
Public Attributes | List of all members
CXTPTabPaintManagerColorSet::COLORSET_TAB_EXCEL Struct Reference

Colors used for Excel tab button colorization. More...

Public Attributes

CXTPPaintManagerColor | clrLeftInnerBorder
Color of the left inner border of the tab button.
CXTPPaintManagerColor | clrTopInnerBorder
Color of the top inner border of the tab button.
CXTPPaintManagerColor | clrRightInnerBorder
Color of the right inner border of the tab button.
CXTPPaintManagerColor | clrLeftOuterBorder
Color of the left outer border of the tab button.
CXTPPaintManagerColor | clrRightOuterBorder
Color of the right outer border of the tab button.
CXTPPaintManagerColor | clrTopOuterBorder
Color of the top outer border of the tab button.

Detailed Description

Colors used for Excel tab button colorization.

Members of COLORSET_TAB_EXCEL are only used when the XTPTabAppearanceStyle is set to xtpTabAppearanceExcel2003.

Both the m_csExcelSelected and m_csExcelNormal color sets are used when the xtpTabAppearanceExcel2003 appearance is applied.

By default, the "selected" excel style tab will display clrLeftInnerBorder and clrTopInnerBorder in addition to the outer borders to indicate that the tab is selected.

The following color sets customize members of COLORSET_TAB_EXCEL in addition to the color members of CXTPTabPaintManagerColorSet: CXTPTabColorSetOffice2003: Office 2003 Color Set. CXTPTabColorSetDefault: Default Color Set.

See also
m_csExcelSelected, m_csExcelNormal
The documentation for this struct was generated from the following file:
  • XTPTabPaintManagerColorSet.h


Toolkit Pro: CXTPTabPaintManagerColorSet::COLORSET_TAB_PROPERTYPAGE Struct Reference

  • CXTPTabPaintManagerColorSet
  • COLORSET_TAB_PROPERTYPAGE
Public Attributes | List of all members
CXTPTabPaintManagerColorSet::COLORSET_TAB_PROPERTYPAGE Struct Reference

Colors used for Office 2000 tab button colorization. More...

Public Attributes

CXTPPaintManagerColor | clrHighlight
Color of tab button on mouse over when hot tracking is enabled.
CXTPPaintManagerColor | clrShadow
Color of the tab button's shadow.
CXTPPaintManagerColor | clrDarkShadow
Color of the tab button's dark shadow.

Detailed Description

Colors used for Office 2000 tab button colorization.

The tab buttons and the tab client area cast a shadow. The shadow consists of both a normal and a dark color. One or both of these colors can be used depending on the selected XTPTabAppearanceStyle.

Members of COLORSET_TAB_PROPERTYPAGE are only used when the XTPTabAppearanceStyle is set to either xtpTabAppearancePropertyPage, xtpTabAppearancePropertyPageFlat, xtpTabAppearancePropertyPageSelected, or xtpTabAppearancePropertyPage2003.

The following color sets customize members of COLORSET_TAB_PROPERTYPAGE in addition to the color members of CXTPTabPaintManagerColorSet: CXTPTabColorSetOffice2003: Office 2003 Color Set. CColorSetWinNative: Windows XP Color Set. CXTPTabColorSetDefault: Default Color Set.

See also
m_csPropertyPage
The documentation for this struct was generated from the following file:
  • XTPTabPaintManagerColorSet.h


Toolkit Pro: CXTPTabPaintManagerColorSet::COLORSET_TAB_PROPERTYPAGE2003 Struct Reference

  • CXTPTabPaintManagerColorSet
  • COLORSET_TAB_PROPERTYPAGE2003
Public Attributes | List of all members
CXTPTabPaintManagerColorSet::COLORSET_TAB_PROPERTYPAGE2003 Struct Reference

Colors used for Office 2003 tab button colorization. More...

Public Attributes

CXTPPaintManagerColor | clrDarkShadow
Color of the shadow of a tab button.
CXTPPaintManagerColor | clrFrameBorder
Color of the XTPTabClientFrame.
CXTPPaintManagerColor | clrBorderLeftHighlight
Color of the left border of a tab button.
CXTPPaintManagerColor | clrBorderTopHighlight
Color of the top border of a tab button.

Detailed Description

Colors used for Office 2003 tab button colorization.

Members of COLORSET_TAB_PROPERTYPAGE2003 are only used when the XTPTabAppearanceStyle is set to xtpTabAppearancePropertyPage2003.

The following color sets customize members of COLORSET_TAB_PROPERTYPAGE2003 in addition to the color members of CXTPTabPaintManagerColorSet: CXTPTabColorSetOffice2003: Office 2003 Color Set. CColorSetVisualStudio2005: Visual Studio 2005 Color Set. CXTPTabColorSetDefault: Default Color Set.

See also
m_csPropertyPage2003
The documentation for this struct was generated from the following file:
  • XTPTabPaintManagerColorSet.h


Toolkit Pro: CXTPTabPaintManagerColorSet::COLORSET_TAB_STATEBUTTON Struct Reference

  • CXTPTabPaintManagerColorSet
  • COLORSET_TAB_STATEBUTTON
Public Attributes | List of all members
CXTPTabPaintManagerColorSet::COLORSET_TAB_STATEBUTTON Struct Reference

Colors used for "State Button" tab button colorization. More...

Public Attributes

CXTPPaintManagerColorGradient | clrFace
Color of the currently selected tab button.
CXTPPaintManagerColorGradient | clrBorder
Border color of the currently selected tab button.

Detailed Description

Colors used for "State Button" tab button colorization.

Members of COLORSET_TAB_STATEBUTTON are only used when the XTPTabAppearanceStyle is set to xtpTabAppearanceStateButtons.

The following color sets customize members of COLORSET_TAB_STATEBUTTON in addition to the color members of CXTPTabPaintManagerColorSet: CXTPTabColorSetOffice2003: Office 2003 Color Set. CXTPTabColorSetDefault: Default Color Set.

See also
m_csStateButton
The documentation for this struct was generated from the following file:
  • XTPTabPaintManagerColorSet.h


Toolkit Pro: CXTPTabPaintManagerTheme Class Reference

Public Member Functions | Public Attributes | Protected Attributes | List of all members
CXTPTabPaintManagerTheme Class Reference

CXTPTabPaintManagerTheme is a class that represents the appearance of all components of the tab manager (e.g. More...

Inheritance diagram for CXTPTabPaintManagerTheme:
[legend]

Public Member Functions

CXTPTabPaintManagerTheme ()
Constructs a CXTPTabPaintManagerTheme object.
virtual | ~CXTPTabPaintManagerTheme ()
Destroys a CXTPTabPaintManagerTheme object, handles cleanup and deallocation.
virtual void | RefreshMetrics ()
Refreshes the appearance metrics.
CXTPTabPaintManagerColorSet * | GetColorSet () const
Gets the color set.
virtual CRect | GetHeaderRect (CRect rcControl, CXTPTabManager *pTabManager)
Gets the bounding rectangle of the tab header area.
virtual CRect | GetHeaderClipBox (CDC *pDC, CXTPTabManager *pTabManager)
Gets the clip box of the tab header area.
int | GetHeaderHeight (CXTPTabManager *pTabManager)
Gets the height of the tab header area.
virtual CRect | GetClientRect (CRect rcControl, CXTPTabManager *pTabManager)
Gets the bounding rectangle of the tab client area.
virtual CRect | GetHeaderMargin ()
Gets the top, left, right, and bottom margins of the tab header.
virtual CRect | GetClientMargin ()
Gets the top, left, right, and bottom margins of the tab client area.
virtual int | GetButtonLength (CDC *pDC, CXTPTabManagerItem *pItem)
Retrieves the total length of a specified tab button including the left and right button margins.
virtual int | GetButtonHeight (const CXTPTabManager *pTabManager)
Retrieves the total height of the tab buttons within a specified tab manager including the top and bottom margins and the icon.
virtual CRect | GetButtonDrawRect (const CXTPTabManagerItem *pItem)
Retrieves the bounding rectangle of a specified drawing item.
virtual void | DrawTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl)
Draws the tab control.
virtual CRect | FillTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl)
Fills both the tab header and the tab client area and then draws the tab client frame.
virtual void | RepositionTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcClient)
Moves the tab buttons of the tab control to their correct positions.
virtual void | AdjustClientRect (CXTPTabManager *pTabManager, CRect &rcClient)
Adjusts the tab client rectangle.
virtual void | DrawSingleButton (CDC *pDC, CXTPTabManagerItem *pItem)
Draws a single tab button in the tab client header area.
virtual void | DrawWorkspacePart (CDC *pDC, LPRECT lpRect, XTPTabWorkspacePart workspacePart)
Draws a specified TabMDIClient TabWorkspace part.
virtual int | GetSupportedColorSets ()
Gets the supported color sets for this theme.
virtual XTPTabColorStyle | GetDefaultColorSet ()
Gets the default value of the color set for this theme.
COLORREF | FillButton (CDC *pDC, CXTPTabManagerItem *pItem, LPPOINT pts, int nCount, XTPTabPosition tabPosition, BOOL bAbsolute=FALSE)
Draws a tab button within a specified polygon.
virtual void | DrawText (CDC *pDC, CXTPTabManager *pManager, const CString &str, LPRECT lpRect, UINT nFormat)
Draws the text of a specified item.

Public Attributes

CRect | m_rcHeaderMargin
CRect struct containing the left, top, right, and bottom.
int | m_nRowMargin
margins of the tab header.

Protected Attributes

int | m_nButtonHeight
Current tab button height (without margins).
CXTPTabPaintManager * | m_pPaintManager
Self paint manager pointer.
BOOL | m_bButtonsReverseZOrder
Draw buttons in right to left order.

Detailed Description

CXTPTabPaintManagerTheme is a class that represents the appearance of all components of the tab manager (e.g.

tab button, tab caption font, button size, tab margins, etc.).

CXTPTabPaintManagerTheme is the base class for all appearances. To create a custom appearance, a new class can be derived either from this class or any of the appearances.

The appearance should be updated in RefreshMetric's members for each CXTPTabPaintManagerTheme object.

See also
XTPTabAppearanceStyle, SetAppearance, SetAppearanceSet, GetAppearance, GetAppearanceSet, SetColor, GetColor, GetColorSet, SetColorSet, CXTPTabPaintManagerColorSet

Member Function Documentation

◆ AdjustClientRect()

virtual void AdjustClientRect | ( | CXTPTabManager * | pTabManager,
 |  | CRect & | rcClient )
 virtual

Adjusts the tab client rectangle.

Parameters
pTabManager | Pointer to the tab manager to adjust the tab client rectangle.
rcClient | [out] Reference to a CRect object to receive the new tab client rectangle with margins included.

Both CXTPTabPaintManager::AdjustClientRect and CXTPTabPaintManager::RepositionTabControl are called when the window is resized. When CXTPTabPaintManager::DrawTabControl is called, the changes will be used when drawing the tab control.

This method will adjust the tab client rectangle based on the currently set XTPTabClientFrame.

CXTPTabPaintManager::AdjustClientRect calls this method if there is one or more tabs in the tab manager.

See also
CXTPTabPaintManager::AdjustClientRect

Reimplemented in CAppearanceSetVisio.

◆ DrawSingleButton()

virtual void DrawSingleButton | ( | CDC * | pDC,
 |  | CXTPTabManagerItem * | pItem )
 virtual

Draws a single tab button in the tab client header area.

Parameters
pDC | Pointer to a valid device context.
pItem | Pointer to the tab button to draw.

This method is only used to draw the tab button. This method does not draw the button's icon or text.

DrawSingleButton calls CXTPTabPaintManager::DrawSingleButtonIconAndText after the button is drawn to draw the button's icon and text.

See also
CXTPTabPaintManager::DrawTabControlEx, CXTPTabPaintManager::DrawSingleButtonIconAndText

Reimplemented in CAppearanceSetPropertyPage2003, CAppearanceSetPropertyPage2007, CAppearanceSetPropertyPageAccess2007, CAppearanceSetPropertyPageFlat, CAppearanceSetPropertyPageSelected, CAppearanceSetStateButtons, CAppearanceSetVisio, CAppearanceSetVisualStudio2005, CXTPDockingPanePanelTheme2012, CXTPDockingPaneTabTheme2012, CXTPDockingPaneTabTheme2013, CXTPDockingPaneTabTheme2015, CXTPDockingPaneTabTheme2017, CXTPDockingPaneTabTheme2019, CXTPDockingPaneTabTheme2022, CXTPDockingPaneTabThemeNativeWindows10, CXTPDockingPaneTabThemeNativeWindows11, CXTPTabThemeExcel2003, CXTPTabThemeFlat, CXTPTabThemeOffice2000, CXTPTabThemeVisualStudio2003, CXTPTabThemeVisualStudio2010, and CXTPTabThemeVisualStudio2012.

◆ DrawTabControl()

virtual void DrawTabControl | ( | CXTPTabManager * | pTabManager,
 |  | CDC * | pDC,
 |  | CRect | rcControl )
 virtual

Draws the tab control.

Parameters
pTabManager | Pointer to the tab manager to draw.
pDC | Pointer to a valid device context.
rcControl | Bounding rectangle of the client area.

This method is called during various Draw and Paint functions.

Unless overridden, this method will just call CXTPTabPaintManager::DrawTabControlEx.

See also
CXTPTabPaintManager::DrawTabControlEx.

Reimplemented in CAppearanceSetVisio.

◆ DrawText()

virtual void DrawText | ( | CDC * | pDC,
 |  | CXTPTabManager * | pManager,
 |  | const CString & | str,
 |  | LPRECT | lpRect,
 |  | UINT | nFormat )
 virtual

Draws the text of a specified item.

Parameters
pDC | Pointer to a valid device context.
pManager | Pointer to a valid CXTPTabManager object.
str | Reference to the text to render.
lpRect | Size of the text to render.
nFormat | Drawing format flags.

Reimplemented in CXTPDockingPaneTabTheme2012.

◆ DrawWorkspacePart()

virtual void DrawWorkspacePart | ( | CDC * | pDC,
 |  | LPRECT | lpRect,
 |  | XTPTabWorkspacePart | workspacePart )
 virtual

Draws a specified TabMDIClient TabWorkspace part.

Parameters
pDC | Pointer to a valid device context.
lpRect | Size of the splitter.
workspacePart | TabWorkspace part to be drawn; one of the values defined by the XTPTabWorkspacePart enumeration.

This method is used when drawing the TabWorkspace of MDI tabs when tab grouping is enabled.

If workspacePart is XTPTabWorkspacePartHSplitter, then lpRect refers to the size of the splitter placed between horizontal tab groups.

If workspacePart is XTPTabWorkspacePartVSplitter, then lpRect refers to the size of the splitter placed between vertical tab groups.

If workspacePart is XTPTabWorkspacePartWidth, then this is the size of the splitter.

See also
XTPTabWorkspacePart

Reimplemented in CXTPTabThemeVisualStudio2012.

◆ FillButton()

COLORREF FillButton | ( | CDC * | pDC,
 |  | CXTPTabManagerItem * | pItem,
 |  | LPPOINT | pts,
 |  | int | nCount,
 |  | XTPTabPosition | tabPosition,
 |  | BOOL | bAbsolute = FALSE )

Draws a tab button within a specified polygon.

Parameters
pDC | Pointer to the device context to draw.
pItem | Pointer to the tab item to draw.
pts | Pointer to an array of points that determine the target polygon.
nCount | Number of points in the array of points of the target polygon.
tabPosition | Tab position; must be one of the values defined by the XTPTabPosition enumeration.
bAbsolute | Flag that specifies if points are in absolute coordinates.
Returns
The color of the tab that was filled

◆ FillTabControl()

virtual CRect FillTabControl | ( | CXTPTabManager * | pTabManager,
 |  | CDC * | pDC,
 |  | CRect | rcControl )
 virtual

Fills both the tab header and the tab client area and then draws the tab client frame.

Parameters
pTabManager | Pointer to the tab manager to fill.
pDC | Pointer to a valid device context.
rcControl | Bounding rectangle of the tab manager control. See CXTPTabManager::GetControlRect.
Returns
The bounding rectangle of the tab header.

If CXTPTabPaintManager::m_bFillBackground is TRUE, then the tab client space is filled using CXTPTabPaintManagerColorSet::m_clrControlFace. CXTPTabPaintManager::m_bFillBackground is only FALSE when drawing docking pane panel auto-hide tabs because there is no client area to draw.

See also
GetHeaderRect, CXTPTabPaintManager::m_bFillBackground, XTPTabClientFrame, CXTPTabPaintManager::m_clientFrame

Reimplemented in CAppearanceSetPropertyPage2003, CAppearanceSetPropertyPage2007, CAppearanceSetPropertyPageAccess2007, CAppearanceSetStateButtons, CXTPTabThemeFlat, CXTPTabThemeOffice2000, and CXTPTabThemeVisualStudio2003.

◆ GetButtonDrawRect()

virtual CRect GetButtonDrawRect ( const CXTPTabManagerItem * pItem )
virtual

Retrieves the bounding rectangle of a specified drawing item.

Parameters
pItem Pointer to the drawing item with the bounding rectangle to retrieve.
Returns
The bounding rectangle of the specified drawing item.
See also
CXTPTabManagerItem::GetRect

Reimplemented in CAppearanceSetPropertyPage2003, CAppearanceSetPropertyPageAccess2007, CAppearanceSetVisualStudio2005, CXTPTabThemeExcel2003, and CXTPTabThemeOffice2000.

◆ GetButtonHeight()

virtual int GetButtonHeight ( const CXTPTabManager * pTabManager )
virtual

Retrieves the total height of the tab buttons within a specified tab manager including the top and bottom margins and the icon.

Parameters
pTabManager Pointer to the tab manager to retrieve the total height of the tab buttons within.
Returns
The height of the tab buttons within the specified tab manager.

This method adds the size of the top and bottom margins and the size of the icon to the size of CXTPTabPaintManager.CXTPTabPaintManagerTheme.m_nButtonHeight which is the height of the tab buttons without the top or bottom margins or the icon.

See also
CXTPTabPaintManager.CXTPTabPaintManagerTheme.m_nButtonHeight, CXTPTabPaintManager::m_rcButtonMargin, GetClientMargin, GetHeaderMargin, CXTPTabPaintManager::DrawSingleButtonIconAndText, CXTPTabManager::GetItemMetrics, GetButtonLength

◆ GetButtonLength()

virtual int GetButtonLength | ( | CDC * | pDC,
 |  | CXTPTabManagerItem * | pItem )
 virtual

Retrieves the total length of a specified tab button including the left and right button margins.

Parameters
pDC | Pointer to a valid device context.
pItem | Pointer to the tab button with the length to be retrieved.
Returns
The total length of the specified tab button including the left and right button margins.

This method calls CXTPTabPaintManager::DrawSingleButtonIconAndText with bDraw = FALSE to get the total length of the specified tab button including the left and right button margins.

See also
CXTPTabPaintManager::m_rcButtonMargin, GetClientMargin, GetHeaderMargin, CXTPTabPaintManager::DrawSingleButtonIconAndText, CXTPTabManager::GetItemMetrics, GetButtonHeight

◆ GetClientMargin()

virtual CRect GetClientMargin ( )
virtual

Gets the top, left, right, and bottom margins of the tab client area.

Returns
The top, left, right, and bottom margins of the tab client area.

The margins of the tab client area are the space placed around the tab client area inside the tab control.

Example:

// Set the top, left, right, and bottom tab header margins to 5 pixels.  This will
// place a margin of 5 pixels around the tab buttons in the tab header.
m_wndTabControl.GetPaintManager()->GetAppearanceSet()->m_rcHeaderMargin.SetRect(5, 5, 5, 5);

// Set the top, left, right, and bottom tab control margins to 4 pixels.  This will
// place a margin of 4 pixels around the entire tab control (Includes tab header and tab
// client area).
m_wndTabControl.GetPaintManager()->m_rcControlMargin.SetRect(4, 4, 4, 4);

// Set the top, left, right, and bottom tab button margins to 2 pixels.  This will
// place a margin of 2 pixels around the text and icon in the tab buttons.
m_wndTabControl.GetPaintManager()->m_rcButtonMargin.SetRect(2, 2, 2, 2);

// Set the top, left, right, and bottom tab client margins to 10 pixels.  This will
// place a margin of 10 pixels around the tab client area.
m_wndTabControl.GetPaintManager()->m_rcClientMargin.SetRect(10, 10, 10, 10);
See also
CXTPTabPaintManager::m_rcClientMargin, GetClientRect

Reimplemented in CXTPTabThemeOffice2000.

◆ GetClientRect()

virtual CRect GetClientRect | ( | CRect | rcControl,
 |  | CXTPTabManager * | pTabManager )
 virtual

Gets the bounding rectangle of the tab client area.

Parameters
rcControl | Bounding rectangle of the tab manager control. See CXTPTabManager::GetControlRect.
pTabManager | Pointer to a CXTPTabManager object.
Returns
The bounding rectangle of the tab client area.
See also
GetHeaderRect, GetHeaderMargin, GetClientMargin, CXTPTabManager::GetControlRect

Reimplemented in CAppearanceSetVisio.

◆ GetColorSet()

CXTPTabPaintManagerColorSet * GetColorSet ( ) const

Gets the color set.

Returns
A pointer to the color set.
See also
XTPTabColorStyle, CXTPTabPaintManager::GetColor, CXTPTabPaintManager::SetColorSet, CXTPTabPaintManager::SetColor

◆ GetDefaultColorSet()

virtual XTPTabColorStyle GetDefaultColorSet ( )
inlinevirtual

Gets the default value of the color set for this theme.

Returns
The default value of the color set for this theme.
See also
GetSupportedColorSets

Reimplemented in CAppearanceSetPropertyPage2003, CAppearanceSetPropertyPage2007, CAppearanceSetPropertyPageAccess2007, CAppearanceSetPropertyPageFlat, CAppearanceSetStateButtons, CXTPTabThemeFlat, CXTPTabThemeNativeWindows10, CXTPTabThemeNativeWindows11, CXTPTabThemeOffice2000, CXTPTabThemeOffice2013, CXTPTabThemeVisualStudio2003, CXTPTabThemeVisualStudio2010, CXTPTabThemeVisualStudio2012, CXTPTabThemeVisualStudio2015, CXTPTabThemeVisualStudio2017, CXTPTabThemeVisualStudio2019, and CXTPTabThemeVisualStudio2022.

◆ GetHeaderClipBox()

virtual CRect GetHeaderClipBox | ( | CDC * | pDC,
 |  | CXTPTabManager * | pTabManager )
 virtual

Gets the clip box of the tab header area.

Parameters
pDC | Pointer to a CDC object.
pTabManager | Pointer to a CXTPTabManager object.
Returns
The clip box of the tab header area.

Reimplemented in CXTPTabThemeOffice2000.

◆ GetHeaderHeight()

int GetHeaderHeight ( CXTPTabManager * pTabManager )

Gets the height of the tab header area.

Parameters
pTabManager Pointer to a CXTPTabManager object.
Returns
The height of the tab header area.
See also
GetHeaderRect, GetClientRect, GetHeaderMargin, GetClientMargin, CXTPTabManager::GetControlRect

◆ GetHeaderMargin()

virtual CRect GetHeaderMargin ( )
virtual

Gets the top, left, right, and bottom margins of the tab header.

Returns
The top, left, right, and bottom margins of the tab header.

The margins of the tab header are the space placed around the tab buttons inside the tab header.

The margins of the tab header are not placed around each tab button. Instead, they are placed around all tab buttons.

Example:

// Set the top, left, right, and bottom tab header margins to 5 pixels.  This will
// place a margin of 5 pixels around the tab buttons in the tab header.
m_wndTabControl.GetPaintManager()->GetAppearanceSet()->m_rcHeaderMargin.SetRect(5, 5, 5, 5);

// Set the top, left, right, and bottom tab control margins to 4 pixels.  This will
// place a margin of 4 pixels around the entire tab control (Includes tab header and tab
// client area).
m_wndTabControl.GetPaintManager()->m_rcControlMargin.SetRect(4, 4, 4, 4);

// Set the top, left, right, and bottom tab button margins to 2 pixels.  This will
// place a margin of 2 pixels around the text and icon in the tab buttons.
m_wndTabControl.GetPaintManager()->m_rcButtonMargin.SetRect(2, 2, 2, 2);

// Set the top, left, right, and bottom tab client margins to 10 pixels.  This will
// place a margin of 10 pixels around the tab client area.
m_wndTabControl.GetPaintManager()->m_rcClientMargin.SetRect(10, 10, 10, 10);
See also
m_rcHeaderMargin, GetHeaderRect

Reimplemented in CAppearanceSetPropertyPage2003, CAppearanceSetPropertyPageAccess2007, CAppearanceSetVisualStudio2005, and CXTPTabThemeExcel2003.

◆ GetHeaderRect()

virtual CRect GetHeaderRect | ( | CRect | rcControl,
 |  | CXTPTabManager * | pTabManager )
 virtual

Gets the bounding rectangle of the tab header area.

Parameters
rcControl | Bounding rectangle of the tab header. See CXTPTabManager::GetControlRect.
pTabManager | Pointer to a CXTPTabManager object.
Returns
The bounding rectangle of the tab header area.
See also
GetClientRect, GetHeaderMargin, GetClientMargin, CXTPTabManager::GetControlRect

Reimplemented in CAppearanceSetVisio.

◆ GetSupportedColorSets()

virtual int GetSupportedColorSets ( )
inlinevirtual

Gets the supported color sets for this theme.

Returns
The supported color sets for this theme.
See also
GetDefaultColorSet

◆ RefreshMetrics()

virtual void RefreshMetrics ( )
virtual

Refreshes the appearance metrics.

Override this member to change the appearance metrics.

This method is used to refresh the appearance metrics such as font, button height, margin size, etc.

Reimplemented in CAppearanceSetPropertyPage2003, CAppearanceSetPropertyPage2007, CAppearanceSetPropertyPageAccess2007, CXTPDockingPanePanelTheme2012, CXTPDockingPaneTabTheme2012, CXTPDockingPaneTabTheme2013, CXTPTabThemeNativeWindows10, CXTPTabThemeNativeWindows11, CXTPTabThemeOffice2000, CXTPTabThemeOffice2013, CXTPTabThemeVisualStudio2012, CXTPTabThemeVisualStudio2015, CXTPTabThemeVisualStudio2017, CXTPTabThemeVisualStudio2019, and CXTPTabThemeVisualStudio2022.

◆ RepositionTabControl()

virtual void RepositionTabControl | ( | CXTPTabManager * | pTabManager,
 |  | CDC * | pDC,
 |  | CRect | rcClient )
 virtual

Moves the tab buttons of the tab control to their correct positions.

Parameters
pTabManager | Pointer to the tab manager that the tab buttons are on.
pDC | Pointer to a valid device context.
rcClient | Bounding rectangle of the tab client area.

Both CXTPTabPaintManager::AdjustClientRect and CXTPTabPaintManager::RepositionTabControl are called when the window is resized. When CXTPTabPaintManager::DrawTabControl is called, the changes will be used when drawing the tab control.

This method is called during CXTPTabPaintManager::RepositionTabControl.

Unless it is overridden, this method will only call CXTPTabPaintManager::RepositionTabControlEx.

Reimplemented in CAppearanceSetVisio.

Member Data Documentation

◆ m_nRowMargin

int m_nRowMargin

margins of the tab header.

This is the space placed around the tab buttons inside the tab header.

The documentation for this class was generated from the following file:
  • XTPTabPaintManagerTheme.h


Toolkit Pro: CXTPTabThemeExcel2003 Class Reference

Public Member Functions | List of all members
CXTPTabThemeExcel2003 Class Reference

CXTPTabThemeExcel2003 implements an Excel tab appearance. More...

Inheritance diagram for CXTPTabThemeExcel2003:
[legend]

Public Member Functions

CXTPTabThemeExcel2003 ()
Constructs a CXTPTabThemeExcel2003 object.
virtual CRect | GetHeaderMargin ()
Gets the top, left, right, and bottom margins of the tab header.
virtual void | DrawSingleButton (CDC *pDC, CXTPTabManagerItem *pItem)
Draws a single tab button in the tab client header area.
virtual CRect | GetButtonDrawRect (const CXTPTabManagerItem *pItem)
Retrieves the bounding rectangle of a specified drawing item.
- Public Member Functions inherited from CXTPTabThemeFlat
CXTPTabThemeFlat ()
Constructs a CXTPTabThemeFlat object.
virtual CRect | FillTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl)
Fills both the tab header and the tab client area and then draws the tab client frame.
virtual XTPTabColorStyle | GetDefaultColorSet ()
Gets the default value of the color set for this theme.
- Public Member Functions inherited from CXTPTabPaintManagerTheme
CXTPTabPaintManagerTheme ()
Constructs a CXTPTabPaintManagerTheme object.
virtual | ~CXTPTabPaintManagerTheme ()
Destroys a CXTPTabPaintManagerTheme object, handles cleanup and deallocation.
virtual void | RefreshMetrics ()
Refreshes the appearance metrics.
CXTPTabPaintManagerColorSet * | GetColorSet () const
Gets the color set.
virtual CRect | GetHeaderRect (CRect rcControl, CXTPTabManager *pTabManager)
Gets the bounding rectangle of the tab header area.
virtual CRect | GetHeaderClipBox (CDC *pDC, CXTPTabManager *pTabManager)
Gets the clip box of the tab header area.
int | GetHeaderHeight (CXTPTabManager *pTabManager)
Gets the height of the tab header area.
virtual CRect | GetClientRect (CRect rcControl, CXTPTabManager *pTabManager)
Gets the bounding rectangle of the tab client area.
virtual CRect | GetClientMargin ()
Gets the top, left, right, and bottom margins of the tab client area.
virtual int | GetButtonLength (CDC *pDC, CXTPTabManagerItem *pItem)
Retrieves the total length of a specified tab button including the left and right button margins.
virtual int | GetButtonHeight (const CXTPTabManager *pTabManager)
Retrieves the total height of the tab buttons within a specified tab manager including the top and bottom margins and the icon.
virtual void | DrawTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl)
Draws the tab control.
virtual void | RepositionTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcClient)
Moves the tab buttons of the tab control to their correct positions.
virtual void | AdjustClientRect (CXTPTabManager *pTabManager, CRect &rcClient)
Adjusts the tab client rectangle.
virtual void | DrawWorkspacePart (CDC *pDC, LPRECT lpRect, XTPTabWorkspacePart workspacePart)
Draws a specified TabMDIClient TabWorkspace part.
virtual int | GetSupportedColorSets ()
Gets the supported color sets for this theme.
COLORREF | FillButton (CDC *pDC, CXTPTabManagerItem *pItem, LPPOINT pts, int nCount, XTPTabPosition tabPosition, BOOL bAbsolute=FALSE)
Draws a tab button within a specified polygon.
virtual void | DrawText (CDC *pDC, CXTPTabManager *pManager, const CString &str, LPRECT lpRect, UINT nFormat)
Draws the text of a specified item.

Additional Inherited Members

- Public Attributes inherited from CXTPTabPaintManagerTheme
CRect | m_rcHeaderMargin
CRect struct containing the left, top, right, and bottom.
int | m_nRowMargin
margins of the tab header.
- Protected Attributes inherited from CXTPTabPaintManagerTheme
int | m_nButtonHeight
Current tab button height (without margins).
CXTPTabPaintManager * | m_pPaintManager
Self paint manager pointer.
BOOL | m_bButtonsReverseZOrder
Draw buttons in right to left order.

Detailed Description

CXTPTabThemeExcel2003 implements an Excel tab appearance.

To use the Excel appearance, SetAppearance is used to apply the xtpTabAppearanceExcel2003 XTPTabAppearanceStyle.

CXTPTabThemeExcel2003 supports the following XTPTabColorStyle: xtpTabColorDefault: Default color style. xtpTabColorVisualStudio2003: Visual Studio color style. xtpTabColorOffice2003: Office 2003 color style.

See also
XTPTabColorStyle, XTPTabAppearanceStyle, SetAppearance, GetAppearance, GetAppearanceSet, SetColor, GetColor, GetColorSet, SetColorSet, SetAppearanceSet

Member Function Documentation

◆ DrawSingleButton()

virtual void DrawSingleButton | ( | CDC * | pDC,
 |  | CXTPTabManagerItem * | pItem )
 virtual

Draws a single tab button in the tab client header area.

Parameters
pDC | Pointer to a valid device context.
pItem | Pointer to the tab button to draw.

This method is only used to draw the tab button. This method does not draw the button's icon or text.

DrawSingleButton calls CXTPTabPaintManager::DrawSingleButtonIconAndText after the button is drawn to draw the button's icon and text.

See also
CXTPTabPaintManager::DrawTabControlEx, CXTPTabPaintManager::DrawSingleButtonIconAndText

Reimplemented from CXTPTabThemeFlat.

◆ GetButtonDrawRect()

virtual CRect GetButtonDrawRect ( const CXTPTabManagerItem * pItem )
virtual

Retrieves the bounding rectangle of a specified drawing item.

Parameters
pItem Pointer to the drawing item with the bounding rectangle to retrieve.
Returns
The bounding rectangle of the specified drawing item.
See also
CXTPTabManagerItem::GetRect

Reimplemented from CXTPTabPaintManagerTheme.

◆ GetHeaderMargin()

virtual CRect GetHeaderMargin ( )
inlinevirtual

Gets the top, left, right, and bottom margins of the tab header.

Returns
The top, left, right, and bottom margins of the tab header.

The margins of the tab header are the space placed around the tab buttons inside the tab header.

See also
CXTPTabPaintManager::GetHeaderRect

Reimplemented from CXTPTabPaintManagerTheme.

The documentation for this class was generated from the following file:
  • XTPTabThemeExcel2003.h


Toolkit Pro: CXTPTabThemeFlat Class Reference

Public Member Functions | List of all members
CXTPTabThemeFlat Class Reference

CXTPTabThemeFlat implements a "Flat" tab appearance. More...

Inheritance diagram for CXTPTabThemeFlat:
[legend]

Public Member Functions

CXTPTabThemeFlat ()
Constructs a CXTPTabThemeFlat object.
virtual void | DrawSingleButton (CDC *pDC, CXTPTabManagerItem *pItem)
Draws a single tab button in the tab client header area.
virtual CRect | FillTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl)
Fills both the tab header and the tab client area and then draws the tab client frame.
virtual XTPTabColorStyle | GetDefaultColorSet ()
Gets the default value of the color set for this theme.
- Public Member Functions inherited from CXTPTabPaintManagerTheme
CXTPTabPaintManagerTheme ()
Constructs a CXTPTabPaintManagerTheme object.
virtual | ~CXTPTabPaintManagerTheme ()
Destroys a CXTPTabPaintManagerTheme object, handles cleanup and deallocation.
virtual void | RefreshMetrics ()
Refreshes the appearance metrics.
CXTPTabPaintManagerColorSet * | GetColorSet () const
Gets the color set.
virtual CRect | GetHeaderRect (CRect rcControl, CXTPTabManager *pTabManager)
Gets the bounding rectangle of the tab header area.
virtual CRect | GetHeaderClipBox (CDC *pDC, CXTPTabManager *pTabManager)
Gets the clip box of the tab header area.
int | GetHeaderHeight (CXTPTabManager *pTabManager)
Gets the height of the tab header area.
virtual CRect | GetClientRect (CRect rcControl, CXTPTabManager *pTabManager)
Gets the bounding rectangle of the tab client area.
virtual CRect | GetHeaderMargin ()
Gets the top, left, right, and bottom margins of the tab header.
virtual CRect | GetClientMargin ()
Gets the top, left, right, and bottom margins of the tab client area.
virtual int | GetButtonLength (CDC *pDC, CXTPTabManagerItem *pItem)
Retrieves the total length of a specified tab button including the left and right button margins.
virtual int | GetButtonHeight (const CXTPTabManager *pTabManager)
Retrieves the total height of the tab buttons within a specified tab manager including the top and bottom margins and the icon.
virtual CRect | GetButtonDrawRect (const CXTPTabManagerItem *pItem)
Retrieves the bounding rectangle of a specified drawing item.
virtual void | DrawTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl)
Draws the tab control.
virtual void | RepositionTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcClient)
Moves the tab buttons of the tab control to their correct positions.
virtual void | AdjustClientRect (CXTPTabManager *pTabManager, CRect &rcClient)
Adjusts the tab client rectangle.
virtual void | DrawWorkspacePart (CDC *pDC, LPRECT lpRect, XTPTabWorkspacePart workspacePart)
Draws a specified TabMDIClient TabWorkspace part.
virtual int | GetSupportedColorSets ()
Gets the supported color sets for this theme.
COLORREF | FillButton (CDC *pDC, CXTPTabManagerItem *pItem, LPPOINT pts, int nCount, XTPTabPosition tabPosition, BOOL bAbsolute=FALSE)
Draws a tab button within a specified polygon.
virtual void | DrawText (CDC *pDC, CXTPTabManager *pManager, const CString &str, LPRECT lpRect, UINT nFormat)
Draws the text of a specified item.

Additional Inherited Members

- Public Attributes inherited from CXTPTabPaintManagerTheme
CRect | m_rcHeaderMargin
CRect struct containing the left, top, right, and bottom.
int | m_nRowMargin
margins of the tab header.
- Protected Attributes inherited from CXTPTabPaintManagerTheme
int | m_nButtonHeight
Current tab button height (without margins).
CXTPTabPaintManager * | m_pPaintManager
Self paint manager pointer.
BOOL | m_bButtonsReverseZOrder
Draw buttons in right to left order.

Detailed Description

CXTPTabThemeFlat implements a "Flat" tab appearance.

To use the Flat appearance, SetAppearance is used to apply the xtpTabAppearanceFlat XTPTabAppearanceStyle.

CXTPTabThemeFlat supports the following XTPTabColorStyle: xtpTabColorDefault: Default color style. xtpTabColorVisualStudio2003: Visual Studio color style. xtpTabColorOffice2003: Office 2003 color style.

See also
XTPTabColorStyle, XTPTabAppearanceStyle, SetAppearance, GetAppearance, GetAppearanceSet, SetColor, GetColor, GetColorSet, SetColorSet, SetAppearanceSet

Member Function Documentation

◆ DrawSingleButton()

virtual void DrawSingleButton | ( | CDC * | pDC,
 |  | CXTPTabManagerItem * | pItem )
 virtual

Draws a single tab button in the tab client header area.

Parameters
pDC | Pointer to a valid device context.
pItem | Pointer to the tab button to draw.

This method is only used to draw the tab button. This method does not draw the button's icon or text.

DrawSingleButton calls CXTPTabPaintManager::DrawSingleButtonIconAndText after the button is drawn to draw the button's icon and text.

See also
CXTPTabPaintManager::DrawTabControlEx, CXTPTabPaintManager::DrawSingleButtonIconAndText

Reimplemented from CXTPTabPaintManagerTheme.

Reimplemented in CAppearanceSetPropertyPageFlat, CXTPDockingPanePanelTheme2012, CXTPDockingPaneTabTheme2012, CXTPDockingPaneTabTheme2013, CXTPDockingPaneTabTheme2015, CXTPDockingPaneTabTheme2017, CXTPDockingPaneTabTheme2019, CXTPDockingPaneTabTheme2022, CXTPDockingPaneTabThemeNativeWindows10, CXTPDockingPaneTabThemeNativeWindows11, CXTPTabThemeExcel2003, CXTPTabThemeVisualStudio2010, and CXTPTabThemeVisualStudio2012.

◆ FillTabControl()

virtual CRect FillTabControl | ( | CXTPTabManager * | pTabManager,
 |  | CDC * | pDC,
 |  | CRect | rcControl )
 virtual

Fills both the tab header and the tab client area and then draws the tab client frame.

Parameters
pTabManager | Pointer to the tab manager to fill.
pDC | Pointer to a valid device context.
rcControl | Bounding rectangle of the tab manager control. See CXTPTabManager::GetControlRect.
Returns
The bounding rectangle of the tab header.

If CXTPTabPaintManager::m_bFillBackground is TRUE, then the tab client space is filled using CXTPTabPaintManagerColorSet::m_clrControlFace. CXTPTabPaintManager::m_bFillBackground is only FALSE when drawing docking pane panel auto-hide tabs because there is no client area to draw.

See also
CXTPTabPaintManagerTheme::GetHeaderRect, CXTPTabPaintManager::m_bFillBackground, XTPTabClientFrame, CXTPTabPaintManager::m_clientFrame

Reimplemented from CXTPTabPaintManagerTheme.

◆ GetDefaultColorSet()

virtual XTPTabColorStyle GetDefaultColorSet ( )
inlinevirtual

Gets the default value of the color set for this theme.

Returns
The default value of the color set for this theme.
See also
GetSupportedColorSets

Reimplemented from CXTPTabPaintManagerTheme.

Reimplemented in CAppearanceSetPropertyPageFlat, CXTPTabThemeNativeWindows10, CXTPTabThemeNativeWindows11, CXTPTabThemeOffice2013, CXTPTabThemeVisualStudio2010, CXTPTabThemeVisualStudio2012, CXTPTabThemeVisualStudio2015, CXTPTabThemeVisualStudio2017, CXTPTabThemeVisualStudio2019, and CXTPTabThemeVisualStudio2022.

The documentation for this class was generated from the following file:
  • XTPTabThemeFlat.h


Toolkit Pro: CXTPTabThemeNativeWindows10 Class Reference

Public Member Functions | List of all members
CXTPTabThemeNativeWindows10 Class Reference

CXTPTabThemeNativeWindows10 implements a Native Windows 10 tab appearance. More...

Inheritance diagram for CXTPTabThemeNativeWindows10:
[legend]

Public Member Functions

CXTPTabThemeNativeWindows10 ()
Constructs a CXTPTabThemeNativeWindows10 object.
virtual void | RefreshMetrics ()
Refreshes the appearance metrics.
virtual XTPTabColorStyle | GetDefaultColorSet ()
Gets the default value of the color set for this theme.
- Public Member Functions inherited from CXTPTabThemeOffice2013
CXTPTabThemeOffice2013 ()
Constructs a CXTPTabThemeOffice2013 object.
- Public Member Functions inherited from CXTPTabThemeVisualStudio2012
virtual void | DrawSingleButton (CDC *pDC, CXTPTabManagerItem *pItem)
Draws a single tab button in the tab client header area.
virtual void | DrawWorkspacePart (CDC *pDC, LPRECT lpRect, XTPTabWorkspacePart workspacePart)
Draws a specified TabMDIClient TabWorkspace part.
- Public Member Functions inherited from CXTPTabThemeFlat
CXTPTabThemeFlat ()
Constructs a CXTPTabThemeFlat object.
virtual CRect | FillTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl)
Fills both the tab header and the tab client area and then draws the tab client frame.
- Public Member Functions inherited from CXTPTabPaintManagerTheme
CXTPTabPaintManagerTheme ()
Constructs a CXTPTabPaintManagerTheme object.
virtual | ~CXTPTabPaintManagerTheme ()
Destroys a CXTPTabPaintManagerTheme object, handles cleanup and deallocation.
CXTPTabPaintManagerColorSet * | GetColorSet () const
Gets the color set.
virtual CRect | GetHeaderRect (CRect rcControl, CXTPTabManager *pTabManager)
Gets the bounding rectangle of the tab header area.
virtual CRect | GetHeaderClipBox (CDC *pDC, CXTPTabManager *pTabManager)
Gets the clip box of the tab header area.
int | GetHeaderHeight (CXTPTabManager *pTabManager)
Gets the height of the tab header area.
virtual CRect | GetClientRect (CRect rcControl, CXTPTabManager *pTabManager)
Gets the bounding rectangle of the tab client area.
virtual CRect | GetHeaderMargin ()
Gets the top, left, right, and bottom margins of the tab header.
virtual CRect | GetClientMargin ()
Gets the top, left, right, and bottom margins of the tab client area.
virtual int | GetButtonLength (CDC *pDC, CXTPTabManagerItem *pItem)
Retrieves the total length of a specified tab button including the left and right button margins.
virtual int | GetButtonHeight (const CXTPTabManager *pTabManager)
Retrieves the total height of the tab buttons within a specified tab manager including the top and bottom margins and the icon.
virtual CRect | GetButtonDrawRect (const CXTPTabManagerItem *pItem)
Retrieves the bounding rectangle of a specified drawing item.
virtual void | DrawTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl)
Draws the tab control.
virtual void | RepositionTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcClient)
Moves the tab buttons of the tab control to their correct positions.
virtual void | AdjustClientRect (CXTPTabManager *pTabManager, CRect &rcClient)
Adjusts the tab client rectangle.
virtual int | GetSupportedColorSets ()
Gets the supported color sets for this theme.
COLORREF | FillButton (CDC *pDC, CXTPTabManagerItem *pItem, LPPOINT pts, int nCount, XTPTabPosition tabPosition, BOOL bAbsolute=FALSE)
Draws a tab button within a specified polygon.
virtual void | DrawText (CDC *pDC, CXTPTabManager *pManager, const CString &str, LPRECT lpRect, UINT nFormat)
Draws the text of a specified item.

Additional Inherited Members

- Public Attributes inherited from CXTPTabPaintManagerTheme
CRect | m_rcHeaderMargin
CRect struct containing the left, top, right, and bottom.
int | m_nRowMargin
margins of the tab header.
- Protected Attributes inherited from CXTPTabPaintManagerTheme
int | m_nButtonHeight
Current tab button height (without margins).
CXTPTabPaintManager * | m_pPaintManager
Self paint manager pointer.
BOOL | m_bButtonsReverseZOrder
Draw buttons in right to left order.

Detailed Description

CXTPTabThemeNativeWindows10 implements a Native Windows 10 tab appearance.

Member Function Documentation

◆ GetDefaultColorSet()

virtual XTPTabColorStyle GetDefaultColorSet ( )
inlinevirtual

Gets the default value of the color set for this theme.

Returns
The default value of the color set for this theme.
See also
GetSupportedColorSets

Reimplemented from CXTPTabThemeOffice2013.

◆ RefreshMetrics()

virtual void RefreshMetrics ( )
virtual

Refreshes the appearance metrics.

Override this member to change the appearance metrics.

This method is used to refresh the appearance metrics such as font, button height, margin size, etc.

Reimplemented from CXTPTabThemeOffice2013.

The documentation for this class was generated from the following file:
  • XTPTabThemeNativeWindows10.h


Toolkit Pro: CXTPTabThemeNativeWindows11 Class Reference

Public Member Functions | List of all members
CXTPTabThemeNativeWindows11 Class Reference

CXTPTabThemeNativeWindows11 implements a Native Windows 10 tab appearance. More...

Inheritance diagram for CXTPTabThemeNativeWindows11:
[legend]

Public Member Functions

CXTPTabThemeNativeWindows11 ()
Constructs a CXTPTabThemeNativeWindows11 object.
virtual void | RefreshMetrics ()
Refreshes the appearance metrics.
virtual XTPTabColorStyle | GetDefaultColorSet ()
Gets the default value of the color set for this theme.
- Public Member Functions inherited from CXTPTabThemeOffice2013
CXTPTabThemeOffice2013 ()
Constructs a CXTPTabThemeOffice2013 object.
- Public Member Functions inherited from CXTPTabThemeVisualStudio2012
virtual void | DrawSingleButton (CDC *pDC, CXTPTabManagerItem *pItem)
Draws a single tab button in the tab client header area.
virtual void | DrawWorkspacePart (CDC *pDC, LPRECT lpRect, XTPTabWorkspacePart workspacePart)
Draws a specified TabMDIClient TabWorkspace part.
- Public Member Functions inherited from CXTPTabThemeFlat
CXTPTabThemeFlat ()
Constructs a CXTPTabThemeFlat object.
virtual CRect | FillTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl)
Fills both the tab header and the tab client area and then draws the tab client frame.
- Public Member Functions inherited from CXTPTabPaintManagerTheme
CXTPTabPaintManagerTheme ()
Constructs a CXTPTabPaintManagerTheme object.
virtual | ~CXTPTabPaintManagerTheme ()
Destroys a CXTPTabPaintManagerTheme object, handles cleanup and deallocation.
CXTPTabPaintManagerColorSet * | GetColorSet () const
Gets the color set.
virtual CRect | GetHeaderRect (CRect rcControl, CXTPTabManager *pTabManager)
Gets the bounding rectangle of the tab header area.
virtual CRect | GetHeaderClipBox (CDC *pDC, CXTPTabManager *pTabManager)
Gets the clip box of the tab header area.
int | GetHeaderHeight (CXTPTabManager *pTabManager)
Gets the height of the tab header area.
virtual CRect | GetClientRect (CRect rcControl, CXTPTabManager *pTabManager)
Gets the bounding rectangle of the tab client area.
virtual CRect | GetHeaderMargin ()
Gets the top, left, right, and bottom margins of the tab header.
virtual CRect | GetClientMargin ()
Gets the top, left, right, and bottom margins of the tab client area.
virtual int | GetButtonLength (CDC *pDC, CXTPTabManagerItem *pItem)
Retrieves the total length of a specified tab button including the left and right button margins.
virtual int | GetButtonHeight (const CXTPTabManager *pTabManager)
Retrieves the total height of the tab buttons within a specified tab manager including the top and bottom margins and the icon.
virtual CRect | GetButtonDrawRect (const CXTPTabManagerItem *pItem)
Retrieves the bounding rectangle of a specified drawing item.
virtual void | DrawTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl)
Draws the tab control.
virtual void | RepositionTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcClient)
Moves the tab buttons of the tab control to their correct positions.
virtual void | AdjustClientRect (CXTPTabManager *pTabManager, CRect &rcClient)
Adjusts the tab client rectangle.
virtual int | GetSupportedColorSets ()
Gets the supported color sets for this theme.
COLORREF | FillButton (CDC *pDC, CXTPTabManagerItem *pItem, LPPOINT pts, int nCount, XTPTabPosition tabPosition, BOOL bAbsolute=FALSE)
Draws a tab button within a specified polygon.
virtual void | DrawText (CDC *pDC, CXTPTabManager *pManager, const CString &str, LPRECT lpRect, UINT nFormat)
Draws the text of a specified item.

Additional Inherited Members

- Public Attributes inherited from CXTPTabPaintManagerTheme
CRect | m_rcHeaderMargin
CRect struct containing the left, top, right, and bottom.
int | m_nRowMargin
margins of the tab header.
- Protected Attributes inherited from CXTPTabPaintManagerTheme
int | m_nButtonHeight
Current tab button height (without margins).
CXTPTabPaintManager * | m_pPaintManager
Self paint manager pointer.
BOOL | m_bButtonsReverseZOrder
Draw buttons in right to left order.

Detailed Description

CXTPTabThemeNativeWindows11 implements a Native Windows 10 tab appearance.

Member Function Documentation

◆ GetDefaultColorSet()

virtual XTPTabColorStyle GetDefaultColorSet ( )
inlinevirtual

Gets the default value of the color set for this theme.

Returns
The default value of the color set for this theme.
See also
GetSupportedColorSets

Reimplemented from CXTPTabThemeOffice2013.

◆ RefreshMetrics()

virtual void RefreshMetrics ( )
virtual

Refreshes the appearance metrics.

Override this member to change the appearance metrics.

This method is used to refresh the appearance metrics such as font, button height, margin size, etc.

Reimplemented from CXTPTabThemeOffice2013.

The documentation for this class was generated from the following file:
  • XTPTabThemeNativeWindows11.h


Toolkit Pro: CXTPTabThemeOffice2000 Class Reference

Public Member Functions | List of all members
CXTPTabThemeOffice2000 Class Reference

CXTPTabThemeOffice2000 implements an Office 2000 tab appearance. More...

Inheritance diagram for CXTPTabThemeOffice2000:
[legend]

Public Member Functions

CXTPTabThemeOffice2000 ()
Constructs a CXTPTabThemeOffice2000 object.
virtual void | RefreshMetrics ()
Refreshes the appearance metrics.
virtual void | DrawSingleButton (CDC *pDC, CXTPTabManagerItem *pItem)
Draws a single tab button in the tab client header area.
virtual CRect | FillTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl)
Fills both the tab header and the tab client area and then draws the tab client frame.
virtual XTPTabColorStyle | GetDefaultColorSet ()
Gets the default value of the color set for this theme.
virtual CRect | GetClientMargin ()
Gets the top, left, right, and bottom margins of the tab client area.
virtual CRect | GetButtonDrawRect (const CXTPTabManagerItem *pItem)
Retrieves the bounding rectangle of a specified drawing item.
virtual CRect | GetHeaderClipBox (CDC *pDC, CXTPTabManager *pTabManager)
Gets the clip box of the tab header area.
- Public Member Functions inherited from CXTPTabPaintManagerTheme
CXTPTabPaintManagerTheme ()
Constructs a CXTPTabPaintManagerTheme object.
virtual | ~CXTPTabPaintManagerTheme ()
Destroys a CXTPTabPaintManagerTheme object, handles cleanup and deallocation.
CXTPTabPaintManagerColorSet * | GetColorSet () const
Gets the color set.
virtual CRect | GetHeaderRect (CRect rcControl, CXTPTabManager *pTabManager)
Gets the bounding rectangle of the tab header area.
int | GetHeaderHeight (CXTPTabManager *pTabManager)
Gets the height of the tab header area.
virtual CRect | GetClientRect (CRect rcControl, CXTPTabManager *pTabManager)
Gets the bounding rectangle of the tab client area.
virtual CRect | GetHeaderMargin ()
Gets the top, left, right, and bottom margins of the tab header.
virtual int | GetButtonLength (CDC *pDC, CXTPTabManagerItem *pItem)
Retrieves the total length of a specified tab button including the left and right button margins.
virtual int | GetButtonHeight (const CXTPTabManager *pTabManager)
Retrieves the total height of the tab buttons within a specified tab manager including the top and bottom margins and the icon.
virtual void | DrawTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl)
Draws the tab control.
virtual void | RepositionTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcClient)
Moves the tab buttons of the tab control to their correct positions.
virtual void | AdjustClientRect (CXTPTabManager *pTabManager, CRect &rcClient)
Adjusts the tab client rectangle.
virtual void | DrawWorkspacePart (CDC *pDC, LPRECT lpRect, XTPTabWorkspacePart workspacePart)
Draws a specified TabMDIClient TabWorkspace part.
virtual int | GetSupportedColorSets ()
Gets the supported color sets for this theme.
COLORREF | FillButton (CDC *pDC, CXTPTabManagerItem *pItem, LPPOINT pts, int nCount, XTPTabPosition tabPosition, BOOL bAbsolute=FALSE)
Draws a tab button within a specified polygon.
virtual void | DrawText (CDC *pDC, CXTPTabManager *pManager, const CString &str, LPRECT lpRect, UINT nFormat)
Draws the text of a specified item.

Additional Inherited Members

- Public Attributes inherited from CXTPTabPaintManagerTheme
CRect | m_rcHeaderMargin
CRect struct containing the left, top, right, and bottom.
int | m_nRowMargin
margins of the tab header.
- Protected Attributes inherited from CXTPTabPaintManagerTheme
int | m_nButtonHeight
Current tab button height (without margins).
CXTPTabPaintManager * | m_pPaintManager
Self paint manager pointer.
BOOL | m_bButtonsReverseZOrder
Draw buttons in right to left order.

Detailed Description

CXTPTabThemeOffice2000 implements an Office 2000 tab appearance.

To use the Office 2000 appearance, SetAppearance is used to apply the xtpTabAppearancePropertyPage XTPTabAppearanceStyle.

CXTPTabThemeOffice2000 supports the following XTPTabColorStyle: xtpTabColorDefault: Default color style. xtpTabColorOffice2003: Office 2003 color style. xtpTabColorWinNative: Windows XP color style.

See also
XTPTabColorStyle, XTPTabAppearanceStyle, SetAppearance, GetAppearance, GetAppearanceSet, SetColor, GetColor, GetColorSet, SetColorSet, SetAppearanceSet

Member Function Documentation

◆ DrawSingleButton()

virtual void DrawSingleButton | ( | CDC * | pDC,
 |  | CXTPTabManagerItem * | pItem )
 virtual

Draws a single tab button in the tab client header area.

Parameters
pDC | Pointer to a valid device context.
pItem | Pointer to the tab button to draw.

This method is only used to draw the tab button. This method does not draw the button's icon or text.

DrawSingleButton calls CXTPTabPaintManager::DrawSingleButtonIconAndText after the button is drawn to draw the button's icon and text.

See also
CXTPTabPaintManager::DrawTabControlEx, CXTPTabPaintManager::DrawSingleButtonIconAndText

Reimplemented from CXTPTabPaintManagerTheme.

Reimplemented in CAppearanceSetPropertyPageSelected.

◆ FillTabControl()

virtual CRect FillTabControl | ( | CXTPTabManager * | pTabManager,
 |  | CDC * | pDC,
 |  | CRect | rcControl )
 virtual

Fills both the tab header and the tab client area and then draws the tab client frame.

Parameters
pTabManager | Pointer to the tab manager to fill.
pDC | Pointer to a valid device context.
rcControl | Bounding rectangle of the tab manager control. See CXTPTabManager::GetControlRect.
Returns
The bounding rectangle of the tab header.

If CXTPTabPaintManager::m_bFillBackground is TRUE, then the tab client space is filled using CXTPTabPaintManagerColorSet::m_clrControlFace. CXTPTabPaintManager::m_bFillBackground is only FALSE when drawing docking pane panel auto-hide tabs because there is no client area to draw.

See also
CXTPTabPaintManagerTheme::GetHeaderRect, CXTPTabPaintManager::m_bFillBackground, XTPTabClientFrame, CXTPTabPaintManager::m_clientFrame

Reimplemented from CXTPTabPaintManagerTheme.

◆ GetButtonDrawRect()

virtual CRect GetButtonDrawRect ( const CXTPTabManagerItem * pItem )
virtual

Retrieves the bounding rectangle of a specified drawing item.

Parameters
pItem Pointer to the drawing item with the bounding rectangle to retrieve.
Returns
The bounding rectangle of the specified drawing item.
See also
CXTPTabManagerItem::GetRect

Reimplemented from CXTPTabPaintManagerTheme.

◆ GetClientMargin()

virtual CRect GetClientMargin ( )
virtual

Gets the top, left, right, and bottom margins of the tab client area.

Returns
The top, left, right, and bottom margins of the tab client area.

The margins of the tab client area are the space placed around the tab client area in the tab control.

Example:

// Set the top, left, right, and bottom tab header margins to 5 pixels.  This will
// place a margin of 5 pixels around the tab buttons in the tab header.
m_wndTabControl.GetPaintManager()->GetAppearanceSet()->m_rcHeaderMargin.SetRect(5, 5, 5, 5);

// Set the top, left, right, and bottom tab control margins to 4 pixels.  This will
// place a margin of 4 pixels around the entire tab control (Includes tab header and tab
client area). m_wndTabControl.GetPaintManager()->m_rcControlMargin.SetRect(4, 4, 4, 4);

// Set the top, left, right, and bottom tab button margins to 2 pixels.  This will
// place a margin of 2 pixels around the text and icon in the tab buttons.
m_wndTabControl.GetPaintManager()->m_rcButtonMargin.SetRect(2, 2, 2, 2);

// Set the top, left, right, and bottom tab client margins to 10 pixels.  This will
// place a margin of 10 pixels around the tab client area.
m_wndTabControl.GetPaintManager()->m_rcClientMargin.SetRect(10, 10, 10, 10);
See also
CXTPTabPaintManagerTheme::GetHeaderMargin

Reimplemented from CXTPTabPaintManagerTheme.

◆ GetDefaultColorSet()

virtual XTPTabColorStyle GetDefaultColorSet ( )
inlinevirtual

Gets the default value of the color set for this theme.

Returns
The default value of the color set for this theme.
See also
GetSupportedColorSets

Reimplemented from CXTPTabPaintManagerTheme.

◆ GetHeaderClipBox()

virtual CRect GetHeaderClipBox | ( | CDC * | pDC,
 |  | CXTPTabManager * | pTabManager )
 virtual

Gets the clip box of the tab header area.

Parameters
pDC | Pointer to a CDC object.
pTabManager | Pointer to a CXTPTabManager object.
Returns
The clip box of the tab header area.

Reimplemented from CXTPTabPaintManagerTheme.

◆ RefreshMetrics()

virtual void RefreshMetrics ( )
virtual

Refreshes the appearance metrics.

Override this member to change the appearance metrics.

This method is used to refresh the appearance metrics such as font, button height, margin size, etc.

Reimplemented from CXTPTabPaintManagerTheme.

The documentation for this class was generated from the following file:
  • XTPTabThemeOffice2000.h


Toolkit Pro: CXTPTabThemeOffice2013 Class Reference

Public Member Functions | List of all members
CXTPTabThemeOffice2013 Class Reference

CXTPTabThemeOffice2013 implements an Office 2013 tab appearance. More...

Inheritance diagram for CXTPTabThemeOffice2013:
[legend]

Public Member Functions

CXTPTabThemeOffice2013 ()
Constructs a CXTPTabThemeOffice2013 object.
virtual void | RefreshMetrics ()
Refreshes the appearance metrics.
virtual XTPTabColorStyle | GetDefaultColorSet ()
Gets the default value of the color set for this theme.
- Public Member Functions inherited from CXTPTabThemeVisualStudio2012
virtual void | DrawSingleButton (CDC *pDC, CXTPTabManagerItem *pItem)
Draws a single tab button in the tab client header area.
virtual void | DrawWorkspacePart (CDC *pDC, LPRECT lpRect, XTPTabWorkspacePart workspacePart)
Draws a specified TabMDIClient TabWorkspace part.
- Public Member Functions inherited from CXTPTabThemeFlat
CXTPTabThemeFlat ()
Constructs a CXTPTabThemeFlat object.
virtual CRect | FillTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl)
Fills both the tab header and the tab client area and then draws the tab client frame.
- Public Member Functions inherited from CXTPTabPaintManagerTheme
CXTPTabPaintManagerTheme ()
Constructs a CXTPTabPaintManagerTheme object.
virtual | ~CXTPTabPaintManagerTheme ()
Destroys a CXTPTabPaintManagerTheme object, handles cleanup and deallocation.
CXTPTabPaintManagerColorSet * | GetColorSet () const
Gets the color set.
virtual CRect | GetHeaderRect (CRect rcControl, CXTPTabManager *pTabManager)
Gets the bounding rectangle of the tab header area.
virtual CRect | GetHeaderClipBox (CDC *pDC, CXTPTabManager *pTabManager)
Gets the clip box of the tab header area.
int | GetHeaderHeight (CXTPTabManager *pTabManager)
Gets the height of the tab header area.
virtual CRect | GetClientRect (CRect rcControl, CXTPTabManager *pTabManager)
Gets the bounding rectangle of the tab client area.
virtual CRect | GetHeaderMargin ()
Gets the top, left, right, and bottom margins of the tab header.
virtual CRect | GetClientMargin ()
Gets the top, left, right, and bottom margins of the tab client area.
virtual int | GetButtonLength (CDC *pDC, CXTPTabManagerItem *pItem)
Retrieves the total length of a specified tab button including the left and right button margins.
virtual int | GetButtonHeight (const CXTPTabManager *pTabManager)
Retrieves the total height of the tab buttons within a specified tab manager including the top and bottom margins and the icon.
virtual CRect | GetButtonDrawRect (const CXTPTabManagerItem *pItem)
Retrieves the bounding rectangle of a specified drawing item.
virtual void | DrawTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl)
Draws the tab control.
virtual void | RepositionTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcClient)
Moves the tab buttons of the tab control to their correct positions.
virtual void | AdjustClientRect (CXTPTabManager *pTabManager, CRect &rcClient)
Adjusts the tab client rectangle.
virtual int | GetSupportedColorSets ()
Gets the supported color sets for this theme.
COLORREF | FillButton (CDC *pDC, CXTPTabManagerItem *pItem, LPPOINT pts, int nCount, XTPTabPosition tabPosition, BOOL bAbsolute=FALSE)
Draws a tab button within a specified polygon.
virtual void | DrawText (CDC *pDC, CXTPTabManager *pManager, const CString &str, LPRECT lpRect, UINT nFormat)
Draws the text of a specified item.

Additional Inherited Members

- Public Attributes inherited from CXTPTabPaintManagerTheme
CRect | m_rcHeaderMargin
CRect struct containing the left, top, right, and bottom.
int | m_nRowMargin
margins of the tab header.
- Protected Attributes inherited from CXTPTabPaintManagerTheme
int | m_nButtonHeight
Current tab button height (without margins).
CXTPTabPaintManager * | m_pPaintManager
Self paint manager pointer.
BOOL | m_bButtonsReverseZOrder
Draw buttons in right to left order.

Detailed Description

CXTPTabThemeOffice2013 implements an Office 2013 tab appearance.

Member Function Documentation

◆ GetDefaultColorSet()

virtual XTPTabColorStyle GetDefaultColorSet ( )
inlinevirtual

Gets the default value of the color set for this theme.

Returns
The default value of the color set for this theme.
See also
GetSupportedColorSets

Reimplemented from CXTPTabThemeVisualStudio2012.

Reimplemented in CXTPTabThemeNativeWindows10, and CXTPTabThemeNativeWindows11.

◆ RefreshMetrics()

virtual void RefreshMetrics ( )
virtual

Refreshes the appearance metrics.

Override this member to change the appearance metrics.

This method is used to refresh the appearance metrics such as font, button height, margin size, etc.

Reimplemented from CXTPTabThemeVisualStudio2012.

Reimplemented in CXTPTabThemeNativeWindows10, and CXTPTabThemeNativeWindows11.

The documentation for this class was generated from the following file:
  • XTPTabThemeOffice2013.h


Toolkit Pro: CXTPTabThemeVisualStudio2003 Class Reference

Public Member Functions | List of all members
CXTPTabThemeVisualStudio2003 Class Reference

CXTPTabThemeVisualStudio2003 implements a Visual Studio 2003 tab appearance. More...

Inheritance diagram for CXTPTabThemeVisualStudio2003:
[legend]

Public Member Functions

CXTPTabThemeVisualStudio2003 ()
Constructs a CXTPTabThemeVisualStudio2003 object.
virtual void | DrawSingleButton (CDC *pDC, CXTPTabManagerItem *pItem)
Draws a single tab button in the tab client header area.
virtual CRect | FillTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl)
Fills both the tab header and the tab client area and then draws the tab client frame.
virtual XTPTabColorStyle | GetDefaultColorSet ()
Gets the default value of the color set for this theme.
- Public Member Functions inherited from CXTPTabPaintManagerTheme
CXTPTabPaintManagerTheme ()
Constructs a CXTPTabPaintManagerTheme object.
virtual | ~CXTPTabPaintManagerTheme ()
Destroys a CXTPTabPaintManagerTheme object, handles cleanup and deallocation.
virtual void | RefreshMetrics ()
Refreshes the appearance metrics.
CXTPTabPaintManagerColorSet * | GetColorSet () const
Gets the color set.
virtual CRect | GetHeaderRect (CRect rcControl, CXTPTabManager *pTabManager)
Gets the bounding rectangle of the tab header area.
virtual CRect | GetHeaderClipBox (CDC *pDC, CXTPTabManager *pTabManager)
Gets the clip box of the tab header area.
int | GetHeaderHeight (CXTPTabManager *pTabManager)
Gets the height of the tab header area.
virtual CRect | GetClientRect (CRect rcControl, CXTPTabManager *pTabManager)
Gets the bounding rectangle of the tab client area.
virtual CRect | GetHeaderMargin ()
Gets the top, left, right, and bottom margins of the tab header.
virtual CRect | GetClientMargin ()
Gets the top, left, right, and bottom margins of the tab client area.
virtual int | GetButtonLength (CDC *pDC, CXTPTabManagerItem *pItem)
Retrieves the total length of a specified tab button including the left and right button margins.
virtual int | GetButtonHeight (const CXTPTabManager *pTabManager)
Retrieves the total height of the tab buttons within a specified tab manager including the top and bottom margins and the icon.
virtual CRect | GetButtonDrawRect (const CXTPTabManagerItem *pItem)
Retrieves the bounding rectangle of a specified drawing item.
virtual void | DrawTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl)
Draws the tab control.
virtual void | RepositionTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcClient)
Moves the tab buttons of the tab control to their correct positions.
virtual void | AdjustClientRect (CXTPTabManager *pTabManager, CRect &rcClient)
Adjusts the tab client rectangle.
virtual void | DrawWorkspacePart (CDC *pDC, LPRECT lpRect, XTPTabWorkspacePart workspacePart)
Draws a specified TabMDIClient TabWorkspace part.
virtual int | GetSupportedColorSets ()
Gets the supported color sets for this theme.
COLORREF | FillButton (CDC *pDC, CXTPTabManagerItem *pItem, LPPOINT pts, int nCount, XTPTabPosition tabPosition, BOOL bAbsolute=FALSE)
Draws a tab button within a specified polygon.
virtual void | DrawText (CDC *pDC, CXTPTabManager *pManager, const CString &str, LPRECT lpRect, UINT nFormat)
Draws the text of a specified item.

Additional Inherited Members

- Public Attributes inherited from CXTPTabPaintManagerTheme
CRect | m_rcHeaderMargin
CRect struct containing the left, top, right, and bottom.
int | m_nRowMargin
margins of the tab header.
- Protected Attributes inherited from CXTPTabPaintManagerTheme
int | m_nButtonHeight
Current tab button height (without margins).
CXTPTabPaintManager * | m_pPaintManager
Self paint manager pointer.
BOOL | m_bButtonsReverseZOrder
Draw buttons in right to left order.

Detailed Description

CXTPTabThemeVisualStudio2003 implements a Visual Studio 2003 tab appearance.

To use the Visual Studio appearance, SetAppearance is used to apply the xtpTabAppearanceVisualStudio2003 XTPTabAppearanceStyle.

CXTPTabThemeVisualStudio2003 supports the following XTPTabColorStyle: xtpTabColorDefault: Default color style. xtpTabColorVisualStudio2003: Visual Studio color style. xtpTabColorOffice2003: Office 2003 color style. xtpTabColorWinNative: Windows XP color style. xtpTabColorVisualStudio2005: Visual Studio 2005 color style.

See also
XTPTabColorStyle, XTPTabAppearanceStyle, SetAppearance, GetAppearance, GetAppearanceSet, SetColor, GetColor, GetColorSet, SetColorSet, SetAppearanceSet

Member Function Documentation

◆ DrawSingleButton()

virtual void DrawSingleButton | ( | CDC * | pDC,
 |  | CXTPTabManagerItem * | pItem )
 virtual

Draws a single tab button in the tab client header area.

Parameters
pDC | Pointer to a valid device context.
pItem | Pointer to the tab button to draw.

This method is only used to draw the tab button. This method does not draw the button's icon or text.

DrawSingleButton calls CXTPTabPaintManager::DrawSingleButtonIconAndText after the button is drawn to draw the button's icon and text.

See also
CXTPTabPaintManager::DrawTabControlEx, CXTPTabPaintManager::DrawSingleButtonIconAndText

Reimplemented from CXTPTabPaintManagerTheme.

◆ FillTabControl()

virtual CRect FillTabControl | ( | CXTPTabManager * | pTabManager,
 |  | CDC * | pDC,
 |  | CRect | rcControl )
 virtual

Fills both the tab header and the tab client area and then draws the tab client frame.

Parameters
pTabManager | Pointer to the tab manager to fill.
pDC | Pointer to a valid device context.
rcControl | Bounding rectangle of the tab manager control. See CXTPTabManager::GetControlRect.
Returns
The bounding rectangle of the tab header.

If CXTPTabPaintManager::m_bFillBackground is TRUE, then the tab client space is filled using CXTPTabPaintManagerColorSet::m_clrControlFace. CXTPTabPaintManager::m_bFillBackground is only FALSE when drawing docking pane panel auto-hide tabs because there is no client area to draw.

See also
CXTPTabPaintManagerTheme::GetHeaderRect, CXTPTabPaintManager::m_bFillBackground, XTPTabClientFrame, CXTPTabPaintManager::m_clientFrame

Reimplemented from CXTPTabPaintManagerTheme.

◆ GetDefaultColorSet()

virtual XTPTabColorStyle GetDefaultColorSet ( )
inlinevirtual

Gets the default value of the color set for this theme.

Returns
The default value of the color set for this theme.
See also
GetSupportedColorSets

Reimplemented from CXTPTabPaintManagerTheme.

The documentation for this class was generated from the following file:
  • XTPTabThemeVisualStudio2003.h


Toolkit Pro: CXTPTabThemeVisualStudio2010 Class Reference

Public Member Functions | List of all members
CXTPTabThemeVisualStudio2010 Class Reference

CXTPTabThemeVisualStudio2010 implements a Visual Studio 2010 tab appearance. More...

Inheritance diagram for CXTPTabThemeVisualStudio2010:
[legend]

Public Member Functions

CXTPTabThemeVisualStudio2010 ()
Constructs a CXTPTabThemeVisualStudio2010 object.
virtual void | DrawSingleButton (CDC *pDC, CXTPTabManagerItem *pItem)
Draws a single tab button in the tab client header area.
virtual XTPTabColorStyle | GetDefaultColorSet ()
Gets the default value of the color set for this theme.
- Public Member Functions inherited from CAppearanceSetPropertyPageFlat
CAppearanceSetPropertyPageFlat ()
Constructs a CAppearanceSetPropertyPageFlat object.
- Public Member Functions inherited from CXTPTabThemeFlat
CXTPTabThemeFlat ()
Constructs a CXTPTabThemeFlat object.
virtual CRect | FillTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl)
Fills both the tab header and the tab client area and then draws the tab client frame.
- Public Member Functions inherited from CXTPTabPaintManagerTheme
CXTPTabPaintManagerTheme ()
Constructs a CXTPTabPaintManagerTheme object.
virtual | ~CXTPTabPaintManagerTheme ()
Destroys a CXTPTabPaintManagerTheme object, handles cleanup and deallocation.
virtual void | RefreshMetrics ()
Refreshes the appearance metrics.
CXTPTabPaintManagerColorSet * | GetColorSet () const
Gets the color set.
virtual CRect | GetHeaderRect (CRect rcControl, CXTPTabManager *pTabManager)
Gets the bounding rectangle of the tab header area.
virtual CRect | GetHeaderClipBox (CDC *pDC, CXTPTabManager *pTabManager)
Gets the clip box of the tab header area.
int | GetHeaderHeight (CXTPTabManager *pTabManager)
Gets the height of the tab header area.
virtual CRect | GetClientRect (CRect rcControl, CXTPTabManager *pTabManager)
Gets the bounding rectangle of the tab client area.
virtual CRect | GetHeaderMargin ()
Gets the top, left, right, and bottom margins of the tab header.
virtual CRect | GetClientMargin ()
Gets the top, left, right, and bottom margins of the tab client area.
virtual int | GetButtonLength (CDC *pDC, CXTPTabManagerItem *pItem)
Retrieves the total length of a specified tab button including the left and right button margins.
virtual int | GetButtonHeight (const CXTPTabManager *pTabManager)
Retrieves the total height of the tab buttons within a specified tab manager including the top and bottom margins and the icon.
virtual CRect | GetButtonDrawRect (const CXTPTabManagerItem *pItem)
Retrieves the bounding rectangle of a specified drawing item.
virtual void | DrawTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl)
Draws the tab control.
virtual void | RepositionTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcClient)
Moves the tab buttons of the tab control to their correct positions.
virtual void | AdjustClientRect (CXTPTabManager *pTabManager, CRect &rcClient)
Adjusts the tab client rectangle.
virtual void | DrawWorkspacePart (CDC *pDC, LPRECT lpRect, XTPTabWorkspacePart workspacePart)
Draws a specified TabMDIClient TabWorkspace part.
virtual int | GetSupportedColorSets ()
Gets the supported color sets for this theme.
COLORREF | FillButton (CDC *pDC, CXTPTabManagerItem *pItem, LPPOINT pts, int nCount, XTPTabPosition tabPosition, BOOL bAbsolute=FALSE)
Draws a tab button within a specified polygon.
virtual void | DrawText (CDC *pDC, CXTPTabManager *pManager, const CString &str, LPRECT lpRect, UINT nFormat)
Draws the text of a specified item.

Additional Inherited Members

- Public Attributes inherited from CAppearanceSetPropertyPageFlat
BOOL | m_bBlurPoints
TRUE to smooth corners of flat tabs.
BOOL | m_bVisualStudio2005Style
TRUE to draw with Visual Studio 2005 style.
- Public Attributes inherited from CXTPTabPaintManagerTheme
CRect | m_rcHeaderMargin
CRect struct containing the left, top, right, and bottom.
int | m_nRowMargin
margins of the tab header.
- Protected Attributes inherited from CXTPTabPaintManagerTheme
int | m_nButtonHeight
Current tab button height (without margins).
CXTPTabPaintManager * | m_pPaintManager
Self paint manager pointer.
BOOL | m_bButtonsReverseZOrder
Draw buttons in right to left order.

Detailed Description

CXTPTabThemeVisualStudio2010 implements a Visual Studio 2010 tab appearance.

Constructor & Destructor Documentation

◆ CXTPTabThemeVisualStudio2010()

CXTPTabThemeVisualStudio2010 ( )
inline

Constructs a CXTPTabThemeVisualStudio2010 object.

By default, m_bBlurPoints is TRUE to smooth tab corners.

Member Function Documentation

◆ DrawSingleButton()

virtual void DrawSingleButton | ( | CDC * | pDC,
 |  | CXTPTabManagerItem * | pItem )
 virtual

Draws a single tab button in the tab client header area.

Parameters
pDC | Pointer to a valid device context.
pItem | Pointer to the tab button to draw.

This method is only used to draw the tab button. This method does not draw the button's icon or text.

DrawSingleButton calls CXTPTabPaintManager::DrawSingleButtonIconAndText after the button is drawn to draw the button's icon and text.

If m_bBlurPoints is TRUE, then tab corners will be smoothed.

See also
CXTPTabPaintManager::DrawTabControlEx, CXTPTabPaintManager::DrawSingleButtonIconAndText, m_bBlurPoints

Reimplemented from CAppearanceSetPropertyPageFlat.

◆ GetDefaultColorSet()

virtual XTPTabColorStyle GetDefaultColorSet ( )
inlinevirtual

Gets the default value of the color set for this theme.

Returns
The default value of the color set for this theme.
See also
GetSupportedColorSets

Reimplemented from CAppearanceSetPropertyPageFlat.

The documentation for this class was generated from the following file:
  • XTPTabThemeVisualStudio2010.h


Toolkit Pro: CXTPTabThemeVisualStudio2012 Class Reference

Public Member Functions | List of all members
CXTPTabThemeVisualStudio2012 Class Reference

CXTPTabThemeVisualStudio2012 implements a Visual Studio 2012 tab appearance. More...

Inheritance diagram for CXTPTabThemeVisualStudio2012:
[legend]

Public Member Functions

virtual void | RefreshMetrics ()
Refreshes the appearance metrics.
virtual void | DrawSingleButton (CDC *pDC, CXTPTabManagerItem *pItem)
Draws a single tab button in the tab client header area.
virtual void | DrawWorkspacePart (CDC *pDC, LPRECT lpRect, XTPTabWorkspacePart workspacePart)
Draws a specified TabMDIClient TabWorkspace part.
virtual XTPTabColorStyle | GetDefaultColorSet ()
Gets the default value of the color set for this theme.
- Public Member Functions inherited from CXTPTabThemeFlat
CXTPTabThemeFlat ()
Constructs a CXTPTabThemeFlat object.
virtual CRect | FillTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl)
Fills both the tab header and the tab client area and then draws the tab client frame.
- Public Member Functions inherited from CXTPTabPaintManagerTheme
CXTPTabPaintManagerTheme ()
Constructs a CXTPTabPaintManagerTheme object.
virtual | ~CXTPTabPaintManagerTheme ()
Destroys a CXTPTabPaintManagerTheme object, handles cleanup and deallocation.
CXTPTabPaintManagerColorSet * | GetColorSet () const
Gets the color set.
virtual CRect | GetHeaderRect (CRect rcControl, CXTPTabManager *pTabManager)
Gets the bounding rectangle of the tab header area.
virtual CRect | GetHeaderClipBox (CDC *pDC, CXTPTabManager *pTabManager)
Gets the clip box of the tab header area.
int | GetHeaderHeight (CXTPTabManager *pTabManager)
Gets the height of the tab header area.
virtual CRect | GetClientRect (CRect rcControl, CXTPTabManager *pTabManager)
Gets the bounding rectangle of the tab client area.
virtual CRect | GetHeaderMargin ()
Gets the top, left, right, and bottom margins of the tab header.
virtual CRect | GetClientMargin ()
Gets the top, left, right, and bottom margins of the tab client area.
virtual int | GetButtonLength (CDC *pDC, CXTPTabManagerItem *pItem)
Retrieves the total length of a specified tab button including the left and right button margins.
virtual int | GetButtonHeight (const CXTPTabManager *pTabManager)
Retrieves the total height of the tab buttons within a specified tab manager including the top and bottom margins and the icon.
virtual CRect | GetButtonDrawRect (const CXTPTabManagerItem *pItem)
Retrieves the bounding rectangle of a specified drawing item.
virtual void | DrawTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl)
Draws the tab control.
virtual void | RepositionTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcClient)
Moves the tab buttons of the tab control to their correct positions.
virtual void | AdjustClientRect (CXTPTabManager *pTabManager, CRect &rcClient)
Adjusts the tab client rectangle.
virtual int | GetSupportedColorSets ()
Gets the supported color sets for this theme.
COLORREF | FillButton (CDC *pDC, CXTPTabManagerItem *pItem, LPPOINT pts, int nCount, XTPTabPosition tabPosition, BOOL bAbsolute=FALSE)
Draws a tab button within a specified polygon.
virtual void | DrawText (CDC *pDC, CXTPTabManager *pManager, const CString &str, LPRECT lpRect, UINT nFormat)
Draws the text of a specified item.

Additional Inherited Members

- Public Attributes inherited from CXTPTabPaintManagerTheme
CRect | m_rcHeaderMargin
CRect struct containing the left, top, right, and bottom.
int | m_nRowMargin
margins of the tab header.
- Protected Attributes inherited from CXTPTabPaintManagerTheme
int | m_nButtonHeight
Current tab button height (without margins).
CXTPTabPaintManager * | m_pPaintManager
Self paint manager pointer.
BOOL | m_bButtonsReverseZOrder
Draw buttons in right to left order.

Detailed Description

CXTPTabThemeVisualStudio2012 implements a Visual Studio 2012 tab appearance.

Member Function Documentation

◆ DrawSingleButton()

virtual void DrawSingleButton | ( | CDC * | pDC,
 |  | CXTPTabManagerItem * | pItem )
 virtual

Draws a single tab button in the tab client header area.

Parameters
pDC | Pointer to a valid device context.
pItem | Pointer to the tab button to draw.

This method is only used to draw the tab button. This method does not draw the button's icon or text.

DrawSingleButton calls CXTPTabPaintManager::DrawSingleButtonIconAndText after the button is drawn to draw the button's icon and text.

See also
CXTPTabPaintManager::DrawTabControlEx, CXTPTabPaintManager::DrawSingleButtonIconAndText

Reimplemented from CXTPTabThemeFlat.

◆ DrawWorkspacePart()

virtual void DrawWorkspacePart | ( | CDC * | pDC,
 |  | LPRECT | lpRect,
 |  | XTPTabWorkspacePart | workspacePart )
 virtual

Draws a specified TabMDIClient TabWorkspace part.

Parameters
pDC | Pointer to a valid device context.
lpRect | Size of the splitter.
workspacePart | TabWorkspace part to be drawn; one of the values defined by the XTPTabWorkspacePart enumeration.

This method is used when drawing the TabWorkspace of MDI tabs when tab grouping is enabled.

If workspacePart is XTPTabWorkspacePartHSplitter, then lpRect refers to the size of the splitter placed between horizontal tab groups.

If workspacePart is XTPTabWorkspacePartVSplitter, then lpRect refers to the size of the splitter placed between vertical tab groups.

If workspacePart is XTPTabWorkspacePartWidth, then this is the size of the splitter.

See also
XTPTabWorkspacePart

Reimplemented from CXTPTabPaintManagerTheme.

◆ GetDefaultColorSet()

virtual XTPTabColorStyle GetDefaultColorSet ( )
inlinevirtual

Gets the default value of the color set for this theme.

Returns
The default value of the color set for this theme.
See also
GetSupportedColorSets

Reimplemented from CXTPTabThemeFlat.

Reimplemented in CXTPTabThemeNativeWindows10, CXTPTabThemeNativeWindows11, CXTPTabThemeOffice2013, CXTPTabThemeVisualStudio2015, CXTPTabThemeVisualStudio2017, CXTPTabThemeVisualStudio2019, and CXTPTabThemeVisualStudio2022.

◆ RefreshMetrics()

virtual void RefreshMetrics ( )
virtual

Refreshes the appearance metrics.

Override this member to change the appearance metrics.

This method is used to refresh the appearance metrics such as font, button height, margin size, etc.

Reimplemented from CXTPTabPaintManagerTheme.

Reimplemented in CXTPTabThemeNativeWindows10, CXTPTabThemeNativeWindows11, CXTPTabThemeOffice2013, CXTPTabThemeVisualStudio2015, CXTPTabThemeVisualStudio2017, CXTPTabThemeVisualStudio2019, and CXTPTabThemeVisualStudio2022.

The documentation for this class was generated from the following file:
  • XTPTabThemeVisualStudio2012.h


Toolkit Pro: CXTPTabThemeVisualStudio2015 Class Reference

Public Member Functions | List of all members
CXTPTabThemeVisualStudio2015 Class Reference

CXTPTabThemeVisualStudio2015 implements a Visual Studio 2015 tab appearance. More...

Inheritance diagram for CXTPTabThemeVisualStudio2015:
[legend]

Public Member Functions

CXTPTabThemeVisualStudio2015 ()
Constructs a CXTPTabThemeVisualStudio2015 object.
virtual void | RefreshMetrics ()
Refreshes the appearance metrics.
virtual XTPTabColorStyle | GetDefaultColorSet ()
Gets the default value of the color set for this theme.
- Public Member Functions inherited from CXTPTabThemeVisualStudio2012
virtual void | DrawSingleButton (CDC *pDC, CXTPTabManagerItem *pItem)
Draws a single tab button in the tab client header area.
virtual void | DrawWorkspacePart (CDC *pDC, LPRECT lpRect, XTPTabWorkspacePart workspacePart)
Draws a specified TabMDIClient TabWorkspace part.
- Public Member Functions inherited from CXTPTabThemeFlat
CXTPTabThemeFlat ()
Constructs a CXTPTabThemeFlat object.
virtual CRect | FillTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl)
Fills both the tab header and the tab client area and then draws the tab client frame.
- Public Member Functions inherited from CXTPTabPaintManagerTheme
CXTPTabPaintManagerTheme ()
Constructs a CXTPTabPaintManagerTheme object.
virtual | ~CXTPTabPaintManagerTheme ()
Destroys a CXTPTabPaintManagerTheme object, handles cleanup and deallocation.
CXTPTabPaintManagerColorSet * | GetColorSet () const
Gets the color set.
virtual CRect | GetHeaderRect (CRect rcControl, CXTPTabManager *pTabManager)
Gets the bounding rectangle of the tab header area.
virtual CRect | GetHeaderClipBox (CDC *pDC, CXTPTabManager *pTabManager)
Gets the clip box of the tab header area.
int | GetHeaderHeight (CXTPTabManager *pTabManager)
Gets the height of the tab header area.
virtual CRect | GetClientRect (CRect rcControl, CXTPTabManager *pTabManager)
Gets the bounding rectangle of the tab client area.
virtual CRect | GetHeaderMargin ()
Gets the top, left, right, and bottom margins of the tab header.
virtual CRect | GetClientMargin ()
Gets the top, left, right, and bottom margins of the tab client area.
virtual int | GetButtonLength (CDC *pDC, CXTPTabManagerItem *pItem)
Retrieves the total length of a specified tab button including the left and right button margins.
virtual int | GetButtonHeight (const CXTPTabManager *pTabManager)
Retrieves the total height of the tab buttons within a specified tab manager including the top and bottom margins and the icon.
virtual CRect | GetButtonDrawRect (const CXTPTabManagerItem *pItem)
Retrieves the bounding rectangle of a specified drawing item.
virtual void | DrawTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl)
Draws the tab control.
virtual void | RepositionTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcClient)
Moves the tab buttons of the tab control to their correct positions.
virtual void | AdjustClientRect (CXTPTabManager *pTabManager, CRect &rcClient)
Adjusts the tab client rectangle.
virtual int | GetSupportedColorSets ()
Gets the supported color sets for this theme.
COLORREF | FillButton (CDC *pDC, CXTPTabManagerItem *pItem, LPPOINT pts, int nCount, XTPTabPosition tabPosition, BOOL bAbsolute=FALSE)
Draws a tab button within a specified polygon.
virtual void | DrawText (CDC *pDC, CXTPTabManager *pManager, const CString &str, LPRECT lpRect, UINT nFormat)
Draws the text of a specified item.

Additional Inherited Members

- Public Attributes inherited from CXTPTabPaintManagerTheme
CRect | m_rcHeaderMargin
CRect struct containing the left, top, right, and bottom.
int | m_nRowMargin
margins of the tab header.
- Protected Attributes inherited from CXTPTabPaintManagerTheme
int | m_nButtonHeight
Current tab button height (without margins).
CXTPTabPaintManager * | m_pPaintManager
Self paint manager pointer.
BOOL | m_bButtonsReverseZOrder
Draw buttons in right to left order.

Detailed Description

CXTPTabThemeVisualStudio2015 implements a Visual Studio 2015 tab appearance.

Member Function Documentation

◆ GetDefaultColorSet()

virtual XTPTabColorStyle GetDefaultColorSet ( )
inlinevirtual

Gets the default value of the color set for this theme.

Returns
The default value of the color set for this theme.
See also
GetSupportedColorSets

Reimplemented from CXTPTabThemeVisualStudio2012.

Reimplemented in CXTPTabThemeVisualStudio2017, CXTPTabThemeVisualStudio2019, and CXTPTabThemeVisualStudio2022.

◆ RefreshMetrics()

virtual void RefreshMetrics ( )
virtual

Refreshes the appearance metrics.

Override this member to change the appearance metrics.

This method is used to refresh the appearance metrics such as font, button height, margin size, etc.

Reimplemented from CXTPTabThemeVisualStudio2012.

Reimplemented in CXTPTabThemeVisualStudio2017, CXTPTabThemeVisualStudio2019, and CXTPTabThemeVisualStudio2022.

The documentation for this class was generated from the following file:
  • XTPTabThemeVisualStudio2015.h


Toolkit Pro: CXTPTabThemeVisualStudio2017 Class Reference

Public Member Functions | List of all members
CXTPTabThemeVisualStudio2017 Class Reference

CXTPTabThemeVisualStudio2017 implements a Visual Studio 2017 tab appearance. More...

Inheritance diagram for CXTPTabThemeVisualStudio2017:
[legend]

Public Member Functions

CXTPTabThemeVisualStudio2017 ()
Constructs a CXTPTabThemeVisualStudio2017 object.
virtual void | RefreshMetrics ()
Refreshes the appearance metrics.
virtual XTPTabColorStyle | GetDefaultColorSet ()
Gets the default value of the color set for this theme.
- Public Member Functions inherited from CXTPTabThemeVisualStudio2015
CXTPTabThemeVisualStudio2015 ()
Constructs a CXTPTabThemeVisualStudio2015 object.
- Public Member Functions inherited from CXTPTabThemeVisualStudio2012
virtual void | DrawSingleButton (CDC *pDC, CXTPTabManagerItem *pItem)
Draws a single tab button in the tab client header area.
virtual void | DrawWorkspacePart (CDC *pDC, LPRECT lpRect, XTPTabWorkspacePart workspacePart)
Draws a specified TabMDIClient TabWorkspace part.
- Public Member Functions inherited from CXTPTabThemeFlat
CXTPTabThemeFlat ()
Constructs a CXTPTabThemeFlat object.
virtual CRect | FillTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl)
Fills both the tab header and the tab client area and then draws the tab client frame.
- Public Member Functions inherited from CXTPTabPaintManagerTheme
CXTPTabPaintManagerTheme ()
Constructs a CXTPTabPaintManagerTheme object.
virtual | ~CXTPTabPaintManagerTheme ()
Destroys a CXTPTabPaintManagerTheme object, handles cleanup and deallocation.
CXTPTabPaintManagerColorSet * | GetColorSet () const
Gets the color set.
virtual CRect | GetHeaderRect (CRect rcControl, CXTPTabManager *pTabManager)
Gets the bounding rectangle of the tab header area.
virtual CRect | GetHeaderClipBox (CDC *pDC, CXTPTabManager *pTabManager)
Gets the clip box of the tab header area.
int | GetHeaderHeight (CXTPTabManager *pTabManager)
Gets the height of the tab header area.
virtual CRect | GetClientRect (CRect rcControl, CXTPTabManager *pTabManager)
Gets the bounding rectangle of the tab client area.
virtual CRect | GetHeaderMargin ()
Gets the top, left, right, and bottom margins of the tab header.
virtual CRect | GetClientMargin ()
Gets the top, left, right, and bottom margins of the tab client area.
virtual int | GetButtonLength (CDC *pDC, CXTPTabManagerItem *pItem)
Retrieves the total length of a specified tab button including the left and right button margins.
virtual int | GetButtonHeight (const CXTPTabManager *pTabManager)
Retrieves the total height of the tab buttons within a specified tab manager including the top and bottom margins and the icon.
virtual CRect | GetButtonDrawRect (const CXTPTabManagerItem *pItem)
Retrieves the bounding rectangle of a specified drawing item.
virtual void | DrawTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl)
Draws the tab control.
virtual void | RepositionTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcClient)
Moves the tab buttons of the tab control to their correct positions.
virtual void | AdjustClientRect (CXTPTabManager *pTabManager, CRect &rcClient)
Adjusts the tab client rectangle.
virtual int | GetSupportedColorSets ()
Gets the supported color sets for this theme.
COLORREF | FillButton (CDC *pDC, CXTPTabManagerItem *pItem, LPPOINT pts, int nCount, XTPTabPosition tabPosition, BOOL bAbsolute=FALSE)
Draws a tab button within a specified polygon.
virtual void | DrawText (CDC *pDC, CXTPTabManager *pManager, const CString &str, LPRECT lpRect, UINT nFormat)
Draws the text of a specified item.

Additional Inherited Members

- Public Attributes inherited from CXTPTabPaintManagerTheme
CRect | m_rcHeaderMargin
CRect struct containing the left, top, right, and bottom.
int | m_nRowMargin
margins of the tab header.
- Protected Attributes inherited from CXTPTabPaintManagerTheme
int | m_nButtonHeight
Current tab button height (without margins).
CXTPTabPaintManager * | m_pPaintManager
Self paint manager pointer.
BOOL | m_bButtonsReverseZOrder
Draw buttons in right to left order.

Detailed Description

CXTPTabThemeVisualStudio2017 implements a Visual Studio 2017 tab appearance.

Member Function Documentation

◆ GetDefaultColorSet()

virtual XTPTabColorStyle GetDefaultColorSet ( )
inlinevirtual

Gets the default value of the color set for this theme.

Returns
The default value of the color set for this theme.
See also
GetSupportedColorSets

Reimplemented from CXTPTabThemeVisualStudio2015.

Reimplemented in CXTPTabThemeVisualStudio2019, and CXTPTabThemeVisualStudio2022.

◆ RefreshMetrics()

virtual void RefreshMetrics ( )
virtual

Refreshes the appearance metrics.

Override this member to change the appearance metrics.

This method is used to refresh the appearance metrics such as font, button height, margin size, etc.

Reimplemented from CXTPTabThemeVisualStudio2015.

Reimplemented in CXTPTabThemeVisualStudio2019, and CXTPTabThemeVisualStudio2022.

The documentation for this class was generated from the following file:
  • XTPTabThemeVisualStudio2017.h


Toolkit Pro: CXTPTabThemeVisualStudio2019 Class Reference

Public Member Functions | List of all members
CXTPTabThemeVisualStudio2019 Class Reference

CXTPTabThemeVisualStudio2019 implements a Visual Studio 2019 tab appearance. More...

Inheritance diagram for CXTPTabThemeVisualStudio2019:
[legend]

Public Member Functions

CXTPTabThemeVisualStudio2019 ()
Constructs a CXTPTabThemeVisualStudio2019 object.
virtual void | RefreshMetrics ()
Refreshes the appearance metrics.
virtual XTPTabColorStyle | GetDefaultColorSet ()
Gets the default value of the color set for this theme.
- Public Member Functions inherited from CXTPTabThemeVisualStudio2017
CXTPTabThemeVisualStudio2017 ()
Constructs a CXTPTabThemeVisualStudio2017 object.
- Public Member Functions inherited from CXTPTabThemeVisualStudio2015
CXTPTabThemeVisualStudio2015 ()
Constructs a CXTPTabThemeVisualStudio2015 object.
- Public Member Functions inherited from CXTPTabThemeVisualStudio2012
virtual void | DrawSingleButton (CDC *pDC, CXTPTabManagerItem *pItem)
Draws a single tab button in the tab client header area.
virtual void | DrawWorkspacePart (CDC *pDC, LPRECT lpRect, XTPTabWorkspacePart workspacePart)
Draws a specified TabMDIClient TabWorkspace part.
- Public Member Functions inherited from CXTPTabThemeFlat
CXTPTabThemeFlat ()
Constructs a CXTPTabThemeFlat object.
virtual CRect | FillTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl)
Fills both the tab header and the tab client area and then draws the tab client frame.
- Public Member Functions inherited from CXTPTabPaintManagerTheme
CXTPTabPaintManagerTheme ()
Constructs a CXTPTabPaintManagerTheme object.
virtual | ~CXTPTabPaintManagerTheme ()
Destroys a CXTPTabPaintManagerTheme object, handles cleanup and deallocation.
CXTPTabPaintManagerColorSet * | GetColorSet () const
Gets the color set.
virtual CRect | GetHeaderRect (CRect rcControl, CXTPTabManager *pTabManager)
Gets the bounding rectangle of the tab header area.
virtual CRect | GetHeaderClipBox (CDC *pDC, CXTPTabManager *pTabManager)
Gets the clip box of the tab header area.
int | GetHeaderHeight (CXTPTabManager *pTabManager)
Gets the height of the tab header area.
virtual CRect | GetClientRect (CRect rcControl, CXTPTabManager *pTabManager)
Gets the bounding rectangle of the tab client area.
virtual CRect | GetHeaderMargin ()
Gets the top, left, right, and bottom margins of the tab header.
virtual CRect | GetClientMargin ()
Gets the top, left, right, and bottom margins of the tab client area.
virtual int | GetButtonLength (CDC *pDC, CXTPTabManagerItem *pItem)
Retrieves the total length of a specified tab button including the left and right button margins.
virtual int | GetButtonHeight (const CXTPTabManager *pTabManager)
Retrieves the total height of the tab buttons within a specified tab manager including the top and bottom margins and the icon.
virtual CRect | GetButtonDrawRect (const CXTPTabManagerItem *pItem)
Retrieves the bounding rectangle of a specified drawing item.
virtual void | DrawTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl)
Draws the tab control.
virtual void | RepositionTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcClient)
Moves the tab buttons of the tab control to their correct positions.
virtual void | AdjustClientRect (CXTPTabManager *pTabManager, CRect &rcClient)
Adjusts the tab client rectangle.
virtual int | GetSupportedColorSets ()
Gets the supported color sets for this theme.
COLORREF | FillButton (CDC *pDC, CXTPTabManagerItem *pItem, LPPOINT pts, int nCount, XTPTabPosition tabPosition, BOOL bAbsolute=FALSE)
Draws a tab button within a specified polygon.
virtual void | DrawText (CDC *pDC, CXTPTabManager *pManager, const CString &str, LPRECT lpRect, UINT nFormat)
Draws the text of a specified item.

Additional Inherited Members

- Public Attributes inherited from CXTPTabPaintManagerTheme
CRect | m_rcHeaderMargin
CRect struct containing the left, top, right, and bottom.
int | m_nRowMargin
margins of the tab header.
- Protected Attributes inherited from CXTPTabPaintManagerTheme
int | m_nButtonHeight
Current tab button height (without margins).
CXTPTabPaintManager * | m_pPaintManager
Self paint manager pointer.
BOOL | m_bButtonsReverseZOrder
Draw buttons in right to left order.

Detailed Description

CXTPTabThemeVisualStudio2019 implements a Visual Studio 2019 tab appearance.

Member Function Documentation

◆ GetDefaultColorSet()

virtual XTPTabColorStyle GetDefaultColorSet ( )
inlinevirtual

Gets the default value of the color set for this theme.

Returns
The default value of the color set for this theme.
See also
GetSupportedColorSets

Reimplemented from CXTPTabThemeVisualStudio2017.

Reimplemented in CXTPTabThemeVisualStudio2022.

◆ RefreshMetrics()

virtual void RefreshMetrics ( )
virtual

Refreshes the appearance metrics.

Override this member to change the appearance metrics.

This method is used to refresh the appearance metrics such as font, button height, margin size, etc.

Reimplemented from CXTPTabThemeVisualStudio2017.

Reimplemented in CXTPTabThemeVisualStudio2022.

The documentation for this class was generated from the following file:
  • XTPTabThemeVisualStudio2019.h


Toolkit Pro: CXTPTabThemeVisualStudio2022 Class Reference

Public Member Functions | List of all members
CXTPTabThemeVisualStudio2022 Class Reference

CXTPTabThemeVisualStudio2022 implements a Visual Studio 2022 tab appearance. More...

Inheritance diagram for CXTPTabThemeVisualStudio2022:
[legend]

Public Member Functions

CXTPTabThemeVisualStudio2022 ()
Constructs a CXTPTabThemeVisualStudio2022 object.
virtual void | RefreshMetrics ()
Refreshes the appearance metrics.
virtual XTPTabColorStyle | GetDefaultColorSet ()
Gets the default value of the color set for this theme.
- Public Member Functions inherited from CXTPTabThemeVisualStudio2019
CXTPTabThemeVisualStudio2019 ()
Constructs a CXTPTabThemeVisualStudio2019 object.
- Public Member Functions inherited from CXTPTabThemeVisualStudio2017
CXTPTabThemeVisualStudio2017 ()
Constructs a CXTPTabThemeVisualStudio2017 object.
- Public Member Functions inherited from CXTPTabThemeVisualStudio2015
CXTPTabThemeVisualStudio2015 ()
Constructs a CXTPTabThemeVisualStudio2015 object.
- Public Member Functions inherited from CXTPTabThemeVisualStudio2012
virtual void | DrawSingleButton (CDC *pDC, CXTPTabManagerItem *pItem)
Draws a single tab button in the tab client header area.
virtual void | DrawWorkspacePart (CDC *pDC, LPRECT lpRect, XTPTabWorkspacePart workspacePart)
Draws a specified TabMDIClient TabWorkspace part.
- Public Member Functions inherited from CXTPTabThemeFlat
CXTPTabThemeFlat ()
Constructs a CXTPTabThemeFlat object.
virtual CRect | FillTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl)
Fills both the tab header and the tab client area and then draws the tab client frame.
- Public Member Functions inherited from CXTPTabPaintManagerTheme
CXTPTabPaintManagerTheme ()
Constructs a CXTPTabPaintManagerTheme object.
virtual | ~CXTPTabPaintManagerTheme ()
Destroys a CXTPTabPaintManagerTheme object, handles cleanup and deallocation.
CXTPTabPaintManagerColorSet * | GetColorSet () const
Gets the color set.
virtual CRect | GetHeaderRect (CRect rcControl, CXTPTabManager *pTabManager)
Gets the bounding rectangle of the tab header area.
virtual CRect | GetHeaderClipBox (CDC *pDC, CXTPTabManager *pTabManager)
Gets the clip box of the tab header area.
int | GetHeaderHeight (CXTPTabManager *pTabManager)
Gets the height of the tab header area.
virtual CRect | GetClientRect (CRect rcControl, CXTPTabManager *pTabManager)
Gets the bounding rectangle of the tab client area.
virtual CRect | GetHeaderMargin ()
Gets the top, left, right, and bottom margins of the tab header.
virtual CRect | GetClientMargin ()
Gets the top, left, right, and bottom margins of the tab client area.
virtual int | GetButtonLength (CDC *pDC, CXTPTabManagerItem *pItem)
Retrieves the total length of a specified tab button including the left and right button margins.
virtual int | GetButtonHeight (const CXTPTabManager *pTabManager)
Retrieves the total height of the tab buttons within a specified tab manager including the top and bottom margins and the icon.
virtual CRect | GetButtonDrawRect (const CXTPTabManagerItem *pItem)
Retrieves the bounding rectangle of a specified drawing item.
virtual void | DrawTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl)
Draws the tab control.
virtual void | RepositionTabControl (CXTPTabManager *pTabManager, CDC *pDC, CRect rcClient)
Moves the tab buttons of the tab control to their correct positions.
virtual void | AdjustClientRect (CXTPTabManager *pTabManager, CRect &rcClient)
Adjusts the tab client rectangle.
virtual int | GetSupportedColorSets ()
Gets the supported color sets for this theme.
COLORREF | FillButton (CDC *pDC, CXTPTabManagerItem *pItem, LPPOINT pts, int nCount, XTPTabPosition tabPosition, BOOL bAbsolute=FALSE)
Draws a tab button within a specified polygon.
virtual void | DrawText (CDC *pDC, CXTPTabManager *pManager, const CString &str, LPRECT lpRect, UINT nFormat)
Draws the text of a specified item.

Additional Inherited Members

- Public Attributes inherited from CXTPTabPaintManagerTheme
CRect | m_rcHeaderMargin
CRect struct containing the left, top, right, and bottom.
int | m_nRowMargin
margins of the tab header.
- Protected Attributes inherited from CXTPTabPaintManagerTheme
int | m_nButtonHeight
Current tab button height (without margins).
CXTPTabPaintManager * | m_pPaintManager
Self paint manager pointer.
BOOL | m_bButtonsReverseZOrder
Draw buttons in right to left order.

Detailed Description

CXTPTabThemeVisualStudio2022 implements a Visual Studio 2022 tab appearance.

Member Function Documentation

◆ GetDefaultColorSet()

virtual XTPTabColorStyle GetDefaultColorSet ( )
inlinevirtual

Gets the default value of the color set for this theme.

Returns
The default value of the color set for this theme.
See also
GetSupportedColorSets

Reimplemented from CXTPTabThemeVisualStudio2019.

◆ RefreshMetrics()

virtual void RefreshMetrics ( )
virtual

Refreshes the appearance metrics.

Override this member to change the appearance metrics.

This method is used to refresh the appearance metrics such as font, button height, margin size, etc.

Reimplemented from CXTPTabThemeVisualStudio2019.

The documentation for this class was generated from the following file:
  • XTPTabThemeVisualStudio2022.h


Toolkit Pro: CXTPTabToolBar Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPTabToolBar Class Reference

CXTPTabToolBar is a CXTPToolBar derived class. More...

Inheritance diagram for CXTPTabToolBar:
[legend]

Public Member Functions

CXTPTabToolBar ()
Constructs a CXTPTabToolBar object.
virtual | ~CXTPTabToolBar ()
Destroys a CXTPTabToolBar object, handles cleanup and deallocation.
CXTPTabManagerItem * | InsertCategory (int nItem, LPCTSTR lpszItem, UINT *pItems, int nCount, BOOL bLoadIcons=TRUE)
Call this method to add a new tab to CXTPTabToolBar.
CXTPTabManagerItem * | InsertCategory (int nItem, LPCTSTR lpszItem, UINT nIDResource, BOOL bLoadIcons=TRUE)
Call this method to add a new tab to CXTPTabToolBar.
void | UpdateTabs (CXTPTabManagerItem *pItem=NULL)
Call this method to refresh controls on the selected tab.
virtual CXTPTabPaintManager * | GetPaintManager () const
Call this member to get a pointer to the tab paint manager.
void | SetMinimumWidth (int nMinWidth)
Call this method to set the minimum available width of the toolbar.
- Public Member Functions inherited from CXTPToolBar
CXTPToolBar ()
Constructs a CXTPToolBar object.
~CXTPToolBar ()
Destroys a CXTPToolBar object, handles cleanup and deallocation.
virtual void | SetVisible (BOOL bVisible)
Call this member to set the visibility of the toolbar.
virtual BOOL | IsVisible () const
Call this member to check the visibility of the toolbar.
BOOL | SetPosition (XTPBarPosition barPosition)
Call this member to set the position of the toolbar.
BOOL | LoadToolBar (UINT nIDResource, BOOL bLoadIcons=TRUE)
Call this member function to load the toolbar specified by nIDResource.
BOOL | CreateToolBar (DWORD dwStyle, CWnd *pParentWnd, UINT nID=AFX_IDW_TOOLBAR)
This method creates the ToolBar control.
void | GetBarInfo (CToolBarInfo *pInfo)
Retrieves bar information for serialization routines.
void | SetBarInfo (CToolBarInfo *pInfo)
Sets bar information.
void | EnableDocking (DWORD dwFlags=xtpFlagAlignAny|xtpFlagFloating|xtpFlagHideWrap)
Call this method to set docking flags.
BOOL | IsBuiltIn () const
Determines if the toolbar is built-in.
CXTPDockBar * | GetDockBar () const
Retrieves the parent dock bar.
void | OnSetPreviewMode (BOOL bPreview)
Call this method to show/hide toolbars in preview mode.
BOOL | OnHookKeyDown (UINT nChar, LPARAM lParam)
The framework calls this member function when a non-system key is pressed.
void | SetContextMenuPresent (BOOL bPresent)
Call this method to show/hide the toolbar in a context menu.
BOOL | IsContextMenuPresent () const
Call this member to determine if this toolbar is included in the right-click context menu.
void | SetCustomizeDialogPresent (BOOL bPresent)
Call this method to show/hide the toolbar in a customize dialog.
BOOL | IsCustomizeDialogPresent () const
Call this member to determine if this toolbar is included in the customize dialog.
void | ModifyBarStyle (DWORD dwRemove, DWORD dwAdd)
Modifies the styles of the toolbar.
void | SetCloseable (BOOL bCloseable)
Call this method to enable/disable the closeable property of the command bar.
BOOL | IsCloseable () const
Call this method to retrieve the closeable property of the command bar.
BOOL | IsTemporary () const
Call this method to determine if the control is temporary.
void | SetTemporary (BOOL bTemporary)
Call this method to set the control to temporary.
void | ShowExpandButton (BOOL bShowExpandButton)
Call this method to show/hide the expand button of the toolbar.
void | OnRecalcLayout ()
This method recalculates the position of the toolbar.
BOOL | IsWindowVisible () const
Determines if the toolbar is visible on the screen.
- Public Member Functions inherited from CXTPCommandBar
int | IsTrackingMode () const
Call this member to get the tracking state.
CXTPControls * | GetControls () const
Call this member to get the controls collection.
void | SetControls (CXTPControls *pControls)
Call this member to set the controls collection of the command bar.
XTPBarType | GetType () const
Call this member to get the type of the command bar.
void | SetTextOrientation (XTPBarTextOrientation nTextOrientation)
Call this member to change text orientation.
XTPBarTextOrientation | GetTextOrientation () const
Call this member to get the text orientation.
XTPBarPosition | GetPosition () const
Call this member to get the position of the command bar.
void | DelayLayout ()
Call this member to recalculate the layout.
virtual void | DelayRedraw ()
Call this member to redraw the command bar.
virtual BOOL | SetTrackingMode (int bMode, BOOL bSelectFirst=TRUE, BOOL bKeyboard=FALSE)
Call this member to change the tracking state.
virtual BOOL | LoadMenu (CMenu *pMenu, BOOL bRemoveControls=TRUE)
Call this member to convert menu items to command bar controls.
CXTPControl * | GetControl (int nIndex) const
Call this member to return the control at the specified index.
int | GetControlCount () const
Call this member to get the count of the controls.
virtual BOOL | SetSelected (int nSelected, BOOL bKeyboard=FALSE)
Call this member to select the specified control.
CXTPControl * | GetSelected () const
Call this member to get the currently selected control.
BOOL | SetPopuped (int nPopuped, BOOL bKeyboard=FALSE)
Call this member to pop-up the specified control.
void | SetTitle (LPCTSTR lpszTitle)
Call this member to set a title for this command bar.
CString | GetTitle () const
Call this member to get a title for this command bar.
CXTPCommandBars * | GetCommandBars () const
Call this member to get the command bar's object.
void | SetCommandBars (CXTPCommandBars *pCommandBars)
Call this member to set the command bar's object.
CWnd * | GetSite () const
Call this member to get the command bar's site.
CFrameWnd * | GetFrameSite () const
Call this member to get the command bar's site as CFrameWnd.
void | SetFlags (DWORD dwFlagsAdd, DWORD dwFlagsRemove=0)
Call this member to set the command bar's flags.
BOOL | SetButtons (UINT *pButtons, int nCount)
Call this member to set the controls from the button array.
void | SetIconSize (CSize size)
Call this function to set the size of the actual bitmapped images to be added to a toolbar.
virtual CSize | GetIconSize () const
Call this member function to get the size of the toolbar icon.
CSize | GetLargeIconSize (BOOL bAutoSize) const
Call this method to get the large icon size of the toolbar.
void | SetButtonSize (CSize size)
Sets the size of the buttons in the command bar.
virtual CSize | GetButtonSize () const
Call this function to get the size of the command bar button.
void | ShowTextBelowIcons (BOOL bTextBelow=TRUE)
Call this member to show the caption below control's icon.
BOOL | IsTextBelowIcons () const
Checks whether the caption is below the control's icon.
virtual BOOL | Popup (CXTPControlPopup *pControlPopup, BOOL bSelectFirst=FALSE)
This method is called to pop-up the command bar.
HWND | GetTrackFocus () const
Call this method to retrieve the current focused control.
void | SetTrackFocus (HWND hwnd)
Call this method to set focus to the window.
int | FindAccel (TCHAR chAccel) const
Call this method to get the index of the control with the specified accelerator character.
int | FindAccelEx (UINT chAccel, BOOL &bSelectOnly) const
Call this method to get the index of the control with the specified accelerator character.
BOOL | IsCustomizeMode () const
Call this method to check if the command bars are in customize mode.
virtual DROPEFFECT | OnCustomizeDragEnter (CXTPControl *pDataObject, CPoint point)
This member is called when a control is entered into the command bar.
virtual void | OnCustomizeDragLeave ()
This method is called when a control leaves the command bar.
virtual DROPEFFECT | OnCustomizeDragOver (CXTPControl *pDataObject, CPoint point)
This member is called when control is over the command bar.
virtual BOOL | IsCustomizable () const
Call this method to check if the command bar is customizable.
BOOL | IsCustomizeDialogPresent () const
Call this method to check if the command bar is present in Customize dialog.
void | EnableCustomization (BOOL bEnable=TRUE)
Call this method to enable/disable customization of the command bar.
virtual void | OnTrackLost ()
Call this method to remove the tracking state of the command bar.
virtual void | OnTrackEnter ()
Call this method to track the command bar.
CWnd * | GetOwnerSite () const
Call this method to retrieve the owner window of the command bar.
void | InvalidateParents ()
Call this method to redraw all parent command bars.
DWORD | GetFlags () const
Call this method to retrieve the current behavior modification flags of the command bar.
UINT | GetBarID () const
Call this method to retrieve the identifier of the command bar.
void | SetBarID (UINT nID)
Call this method to set the identifier of the command bar.
virtual void | OnControlSelected (BOOL bSelected, CXTPControl *pControl)
This method is called when a child control becomes selected.
BOOL | SetStatusText (const CString &strDescription)
This method is called to set the description context.
void | SetCommandBarData (DWORD_PTR dwData)
This method sets the 32-bit value associated with the command bar.
DWORD_PTR | GetCommandBarData () const
This method retrieves the application-supplied, 32-bit value associated with the command bar.
virtual CXTPCommandBar * | GetParentCommandBar () const
This method retrieves the parent command bar.
CXTPCommandBar * | GetRootParent () const
Call this method to retrieve the top-level parent command bar.
CXTPPaintManager * | GetPaintManager () const
Call this method to retrieve the paint manager.
CXTPImageManager * | GetImageManager () const
Call this method to retrieve the image manager.
void | SetWidth (int nWidth)
Call this member to set the width of the floated or pop-up toolbar.
int | GetWidth () const
Call this member to get the width of the floated or pop-up toolbar.
void | SetPaintManager (CXTPPaintManager *pPaintManager)
Call this member to set the specified paint manager.
void | SetImageManager (CXTPImageManager *pImageManager)
Call this member to set the specified image manager.
BOOL | IsLayoutRTL () const
Call this member function to determine if the command bar layout is Right-to-Left (RTL).
virtual BOOL | IsDialogBar () const
Call this member function to determine if the command bar is a CXTPDialogBar.
virtual BOOL | IsRibbonBar () const
Call this member function to determine if the command bar is a CXTPRibbonBar.
virtual BOOL | IsMenuTitleBar () const
Call this member function to determine if the command bar is a CXTPMenuTitleBar.
virtual BOOL | IsPopupBar () const
Call this member function to determine if the command bar is a CXTPPopupBar.
virtual BOOL | IsKeyboardCuesVisible () const
Determines if underlines are visible in the command bar control.
void | SetGrabFocus (BOOL bGrabFocus)
This method is called internally to prevent the command bar from grabbing edit focus.
virtual void | Redraw (LPCRECT lpRect=0, BOOL bAnimate=TRUE)
The framework calls this member function to redraw the command bar.
void | EnableAnimation (BOOL bEnable=TRUE)
Call this method to enable animation for the command bar.
void | EnableDoubleBuffer (BOOL bEnable=TRUE)
Call this method to enable double buffer for toolbar drawing.
BOOL | IsAnimationEnabled () const
Determines if animation is enabled for the specified command bar.
virtual int | OnHookMessage (HWND hWnd, UINT nMessage, WPARAM &wParam, LPARAM &lParam, LRESULT &lResult)
This member function is called by WindowProc, or is called during message reflection.
virtual void | EnsureVisible (CXTPControl *pControl)
Call this method to ensure that a specified control is visible on the toolbar.
XTPButtonStyle | GetDefaultButtonStyle () const
Call this method to retrieve the default button style of the command bar.
void | SetDefaultButtonStyle (XTPButtonStyle buttonStyle)
Call this method to set the default button style of the command bar.
void | LockRedraw ()
Call this method to freeze redrawing until UnlockRedraw is called.
void | UnlockRedraw ()
Call this method to unfreeze redrawing.
void | SetShowGripper (BOOL bShow)
Call this method to set the visibility of the command bar's gripper.
BOOL | GetShowGripper () const
Call this method to check if the command bar's gripper is visible.
virtual void | FillCommandBarEntry (CDC *pDC)
This method is called to draw the background of the command bar.
virtual BOOL | IsResizable () const
Specifies whether the pop-up gallery can be resized by the user.
BOOL | IsKeyboardTipsVisible () const
Call this method to check if keyboard tips are visible for the command bar.
virtual void | CreateKeyboardTips ()
This method is called to create a keyboard tips collection for the command bar.
void | OnKeyboardTipChar (UINT chAccel)
This method is called when the user presses a key while keyboard tips are visible.
virtual void | OnKeyboardTip (CXTPCommandBarKeyboardTip *pTip)
This method is called when a keyboard tip is found for the command bar.
void | HideKeyboardTips ()
Call this method to hide keyboard tips.
void | LockMouseMove (CXTPControl *pControl)
Locks the mouse cursor for a specified control.
void | UnlockMouseMove ()
Unlocks the mouse cursor.
- Public Member Functions inherited from CXTPHookManagerHookAble
CXTPHookManagerHookAble ()
Constructs a CXTPHookManagerHookAble object.
virtual | ~CXTPHookManagerHookAble ()
Destroys a CXTPHookManagerHookAble object, handles cleanup and deallocation.
virtual int | OnPostHookMessage (HWND hWnd, UINT nMessage, WPARAM &wParam, LPARAM &lParam, LRESULT &lResult)
This member function is called after a message has been processed by default window procedure.
virtual void | OnHookAttached (HWND hWnd)
This member function is called right after a hook is attached to the window.
virtual void | OnHookDetached ()
This member function is called right before a hook is to be detached from the window.
- Public Member Functions inherited from CXTPTabManager
CXTPTabManager ()
Constructs a CXTPTabManager object.
virtual | ~CXTPTabManager ()
Destroys a CXTPTabManager object, handles cleanup and deallocation.
CXTPTabManagerItem * | GetItem (int nIndex) const
Retrieves a tab item by its index.
BOOL | DeleteItem (int nItem)
Deletes a tab item by its index.
void | DeleteAllItems ()
Deletes all tab items from the tab manager.
int | GetItemCount () const
Gets the number of tab items in the tab manager.
virtual CString | GetItemCaption (const CXTPTabManagerItem *pItem) const
Retrieves the caption text of a specified tab item.
virtual HICON | GetItemIcon (const CXTPTabManagerItem *pItem) const
Retrieves the icon of a specified tab item.
virtual COLORREF | GetItemColor (const CXTPTabManagerItem *pItem) const
Retrieves the tab button color of a specified tab item.
virtual CString | GetItemTooltip (const CXTPTabManagerItem *pItem) const
Retrieves the tooltip of a specified tab item.
virtual void | OnItemsChanged ()
This method is called when tab items are changed (i.e.
void | SetCurSel (int nIndex)
Sets the index for the currently selected tab item within the collection of tab items.
int | GetCurSel () const
Gets the index of the currently selected tab item within the collection of tab items.
virtual void | SetFocusedItem (CXTPTabManagerItem *pItem)
Sets the focused tab item.
CXTPTabManagerItem * | GetSelectedItem () const
Gets the currently selected tab item.
CXTPTabManagerItem * | HitTest (CPoint point) const
Determines which tab is at a specified point, if any.
CXTPTabManagerNavigateButton * | HitTestNavigateButton (CPoint point, BOOL bHeaderOnly, int *pnIndex=NULL) const
Determines which navigation button is at a specified point, if any.
virtual void | GetItemMetrics (CSize *szNormal, CSize *szMin=NULL, CSize *szMax=NULL) const
Gets the minimum, maximum, and normal lengths of tab buttons.
void | SetItemMetrics (CSize szNormal, CSize szMin=CSize(0, 0), CSize szMax=CSize(0, 0))
Sets the minimum, maximum, and normal lengths for tab buttons.
void | MoveItem (CXTPTabManagerItem *pItem, int nIndex)
Sets the position of a specified tab item.
void | ShowCloseItemButton (XTPTabNavigateButtonFlags bCloseItemButton=xtpTabNavigateButtonAlways)
Call this member to show close button for each tab.
virtual int | GetItemsLength () const
Gets the total width of all of the tab buttons.
int | GetRectLength (CRect rc) const
Gets the length of the bounding rectangle of the tab client header area.
CXTPTabManagerNavigateButton * | FindNavigateButton (UINT nID) const
Retrieves a specified tab navigation button (i.e.
BOOL | IsHorizontalPosition () const
Determines if the tabs are positioned horizontally.
int | GetHeaderOffset () const
Gets the scroll offset of the tabs in the tab header.
void | SetHeaderOffset (int nOffset)
Sets the scroll offset for the tabs in the tab header.
void | EnsureVisible (CXTPTabManagerItem *pItem)
Ensures that a specified tab is visible.
virtual void | SetPaintManager (CXTPTabPaintManager *pPaintManager)
Sets the tab paint manager.
virtual BOOL | IsAllowReorder () const
Determines if tabs are allowed to be reordered.
virtual void | SetAllowReorder (BOOL bAllowReorder)
Specifies if tabs should be allowed to be reordered.
virtual BOOL | IsDrawStaticFrame () const
Determines if a static frame is used.
void | EnableTabThemeTexture (HWND hWnd, BOOL bEnable=TRUE)
Enables/disables Windows XP themed back color.
CXTPTabPaintManagerColorSet * | SetColor (XTPTabColorStyle tabColor)
Applies one of the "built-in" color sets for the tabs.
CXTPTabPaintManagerColorSet * | SetColorSet (CXTPTabPaintManagerColorSet *pColorSet)
Applies a custom color set for the tabs.
CXTPTabPaintManagerTheme * | SetAppearance (XTPTabAppearanceStyle tabAppearance)
Applies one of the "built-in" appearance sets for the tabs.
CXTPTabPaintManagerTheme * | SetAppearanceSet (CXTPTabPaintManagerTheme *pAppearanceSet)
Applies a custom appearance set for the tabs.
CXTPTabPaintManagerTheme * | GetAppearanceSet () const
Gets the currently applied custom appearance set.
CXTPTabPaintManagerColorSet * | GetColorSet () const
Gets the currently applied custom color set.
XTPTabAppearanceStyle | GetAppearance () const
Gets the currently applied "built-in appearance set.
XTPTabColorStyle | GetColor () const
Gets the currently applied "built-in" color set.
void | SetPosition (XTPTabPosition tabPosition)
Sets the tab position.
void | SetLayoutStyle (XTPTabLayoutStyle tabLayout)
Sets the tab layout style.
virtual XTPTabPosition | GetPosition () const
Gets the tab position.
XTPTabLayoutStyle | GetLayout () const
Gets the tab layout style.
void | ShowIcons (BOOL bShowIcons)
Shows/hides tab icons.
void | SetActive (BOOL bActive)
Specifies if this tab group should be active/inactive.
BOOL | IsActive () const
Determines if this tab group is active/inactive.
CRect | GetControlRect () const
Gets the bounding rectangle of the tab manager control area.
CRect | GetClientRect () const
Gets the bounding rectangle of the tab client area.
CRect | GetHeaderRect () const
Gets the bounding rectangle of the tab client header area.
int | GetRowCount () const
Gets the number of rows of tabs in the tab control.
virtual void | OnScrollHeader (BOOL bRight)
This method is called when the user presses either the left or right navigation buttons.
CXTPTabManagerNavigateButtons * GetNavigateButtons ()
Gets the collection of navigation buttons.
CXTPTabManagerItem * | FindNextFocusable (int nIndex, int nDirection) const
Retrieves the next/previous focusable tab item from a specified index.
void | PerformMouseMove (HWND hWnd, CPoint pt)
This method is called when the mouse cursor moves.
BOOL | PerformClick (HWND hWnd, CPoint pt, BOOL bNoItemClick=FALSE)
This method is called when the user presses the left mouse button.
virtual INT_PTR | PerformToolHitTest (HWND hWnd, CPoint point, TOOLINFO *pTI) const
Determines which tab is beneath the mouse cursor, if any, and stores the tooltip information of the tab within a TOOLINFO structure.
virtual BOOL | PerformKeyDown (HWND hWnd, UINT nChar)
This method is called to process a WM_KEYDOWN event for the tab manager.
virtual BOOL | DrawParentBackground (CDC *pDC, CRect rc)
Draws the parent background under the tab control.
int | GetNavigateButtonCount () const
Gets the total number of tab navigation buttons within the collection of tab navigation buttons.
CXTPTabManagerNavigateButton * | GetNavigateButton (int nIndex) const
Retrieves the tab navigation button at a specified index within the collection of tab navigation buttons.
void | EnableMarkup (BOOL bEnable=TRUE)
Enables/disables markup for the tab captions.
virtual CXTPMarkupContext * | GetMarkupContext () const
Gets the markup context.
- Public Member Functions inherited from CXTPTabManagerAtom
virtual void | OnPropertyChanged ()
This method is called when a property of the tab paint manager is changed.

Protected Member Functions

void | Reposition ()
This method is called to update the position of TabManager.
BOOL | DrawIcon (CDC *pDC, CPoint pt, CXTPTabManagerItem *pItem, BOOL bDraw, CSize &szIcon) const
This member is called when the icon of the tab needs to be drawn.
void | RedrawControl (LPCRECT lpRect, BOOL bAnimate)
This member is called when the visual properties of the tabs are changed (e.g.
void | SetSelectedItem (CXTPTabManagerItem *pItem)
Call this member to select a CXTPTabManagerItem tab.
BOOL | OnBeforeItemClick (CXTPTabManagerItem *pItem)
This method is called before an item click.
CRect | GetBorders ()
This method retrieves the borders of the toolbar.
void | DrawCommandBar (CDC *pDC, CRect rcClipBox)
This method is called to draw the command bar in the given context.
CSize | CalcDockingLayout (int nLength, DWORD dwMode, int nWidth)
This method calculates the dimensions of a toolbar.
CSize | CalcDynamicLayout (int nLength, DWORD dwMode)
This method calculates the dimensions of a toolbar.
void | Reset (BOOL bShowWarningMessage)
Resets the controls to their original state.
void | OnCustomizeDrop (CXTPControl *pDataObject, DROPEFFECT &dropEffect, CPoint ptDrop, CPoint ptDrag)
This method is called when a control is dropped to the command bar.
- Protected Member Functions inherited from CXTPToolBar
virtual BOOL | Create (CWnd *pParentWnd, BOOL bFloat)
Creates a toolbar.
virtual void | DoPropExchange (CXTPPropExchange *pPX)
Either reads this object from or writes this object to an archive.
virtual void | Copy (CXTPCommandBar *pCommandBar, BOOL bRecursive=FALSE)
This method makes a copy of the command bar.
virtual void | OnPaintManagerChanged ()
This method is called when the paint manager is changed.
virtual BOOL | ShouldSerializeBar ()
Call this method to check if the toolbar has changed and must be saved.
virtual void | MergeToolBar (CXTPCommandBar *pCommandBar, BOOL bSilent)
This method is called to restore a toolbar to a previous state.
virtual void | MergeToolBar (CXTPCommandBar *pCommandBar, BOOL bSilent, int nDefaultConfirmationChoice)
This method is called to restore a toolbar to a previous state.
- Protected Member Functions inherited from CXTPCommandBar
CXTPCommandBar ()
Constructs a CXTPCommandBar object.
virtual | ~CXTPCommandBar ()
Destroys a CXTPCommandBar object, handles cleanup and deallocation.
virtual BOOL | ProcessSpecialKey (XTPSpecialKey key)
This method is called to process special keys.
virtual void | OnControlsChanged ()
This method is called when the controls array is changed.
virtual int | OnMouseHitTest (CPoint pt)
This method is called to determine mouse hit code.
virtual void | UpdateShortcuts ()
Updates the control's shortcuts.
UINT | GetActiveDocTemplate () const
Retrieves the active MDI document template.
virtual void | GenerateCommandBarList (DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam)
This method is called to assign self identifiers for the serialization process.
virtual void | RestoreCommandBarList (CXTPCommandBarList *pCommandBarList)
This method is called in the serialization process to restore pop-ups from a list of command bars.
BOOL | IsHelpMode () const
Determines if the parent frame is in help mode.
virtual void | OnRemoved ()
This method is called when a toolbar is removed from the command bars collection.
- Protected Member Functions inherited from CXTPTabManager
virtual BOOL | IsNavigateButtonAutomaticVisible (CXTPTabManagerNavigateButton *pButton)
Determines if a specified tab navigation button is automatically displayed.
virtual BOOL | IsNavigateButtonVisible (CXTPTabManagerNavigateButton *pButton)
Determines if a specified tab navigation button is visible.
virtual void | OnItemClick (CXTPTabManagerItem *pItem)
This method is called when a tab button is clicked to select the tab item that was clicked.
virtual void | ReOrder (HWND hWnd, CPoint pt, CXTPTabManagerItem *pItem)
This method is called when a tab item is clicked and dragged within the tab header.
virtual void | OnSwitchItem (CXTPTabManagerItem *pItem1, CXTPTabManagerItem *pItem2)
This method is called by ReOrder when two tab items are switched.
virtual void | OnItemOrderChanged (CXTPTabManagerItem *pItem, int nOldIndex, int nNewIndex)
This method is called by ReOrder when a tab item's position is changed.
virtual void | OnNavigateButtonClick (CXTPTabManagerNavigateButton *pButton)
This method is called when a tab navigation button is clicked.
virtual void | OnNavigateButtonClick (UINT nID)
This method is called when a tab navigation button is clicked.
virtual BOOL | IsMouseLocked () const
Determines if the MouseMove event has been disabled.
CXTPTabManagerItem * | AddItem (int nItem, CXTPTabManagerItem *pItem=NULL)
Adds a specified tab item to the collection of tab items.
virtual BOOL | HeaderHasFocus () const
The implementation should return TRUE if the header has focus or FALSE otherwise.
void | TrackClick (HWND hWnd, CPoint pt, CXTPTabManagerItem *pItem)
Activates and tracks a specified tab item on mouse click.
virtual void | OnItemHandleChanged (CXTPTabManagerItem *pItem, HWND hwndOld, HWND hwndNew)
This method is called when the handle of a tab item is changed.
- Protected Member Functions inherited from CXTPTabManagerAtom
virtual | ~CXTPTabManagerAtom ()
Destroys a CXTPTabManagerAtom object, handles cleanup and deallocation.

Protected Attributes

CXTPTabPaintManager * | m_pTabPaintManager
Tab PaintManager.
CRect | m_rcTabControl
Bounding rectangle of Tabs.
int | m_nMinWidth
Minimum available width of toolbar.
- Protected Attributes inherited from CXTPToolBar
CXTPDockBar * | m_pDockBar
Parent dock bar.
CXTPDockContext * | m_pDockContext
Docking context.
BOOL | m_bBuiltIn
TRUE if toolbar is built-in.
BOOL | m_bTearOff
TRUE if toolbar is tear-offed.
BOOL | m_bPreviewVisible
TRUE if Toolbar was visible in preview mode.
BOOL | m_bPreviewMode
TRUE if Toolbar was visible in preview mode.
BOOL | m_bTemporary
TRUE if Toolbar is temporary (If it will be saved when the CommandBar layout is saved.)
BOOL | m_bShowExpandButton
TRUE to show expand button of toolbar.
BOOL | m_bContextMenuPresent
TRUE if the command bar is present in context menu.
BOOL | m_bInRecalcLayout
TRUE if RecalcLayout method is called.
BOOL | m_bVisible
TRUE if the command bar is visible.
- Protected Attributes inherited from CXTPCommandBar
BOOL | m_bGrabFocus
TRUE to grab current focus.
int | m_nMRUWidth
Recent width.
int | m_nSelected
Selected control index.
int | m_nPopuped
Pop-up'ed control index.
HWND | m_hwndFocus
The handle of the window that currently has focus.
UINT | m_nBarID
Command bar's identifier.
BOOL | m_bTracking
TRUE if the command bar is in tracking mode.
CWnd * | m_pSite
Command bar's site.
DWORD | m_nIdleFlags
Idle flags.
DWORD | m_dwFlags
Command bar's flags.
DWORD | m_dwStyle
Command bar's styles.
CString | m_strTitle
Command bar's caption.
XTPBarType | m_barType
Type of the command bar.
CXTPControls * | m_pControls
A pointer to controls collection.
XTPBarPosition | m_barPosition
Position of the command bar.
CXTPCommandBars * | m_pCommandBars
parent command bars class.
CWnd * | m_pOwner
Owner window.
CSize | m_szIcons
Size of the command bar's icons.
CSize | m_szButtons
Size of the command bar's buttons.
BOOL | m_bTextBelow
TRUE if text is shown below the CommandBar buttons.
BOOL | m_bExecOnRButton
TRUE if the control button is executed on a right-click.
BOOL | m_bIgnoreUpdateHandler
TRUE to skip update handler for all child controls.
BOOL | m_bRecursePopup
TRUE if pop-up bar was opened recursively.
BOOL | m_bKeyboardSelect
TRUE if last item was selected by keyboard.
BOOL | m_bCloseable
TRUE if the CommandBar can be closed and-or Hidden.
BOOL | m_bCustomizable
TRUE if command bar is customizable.
CRect | m_rcMarker
Marker position.
BOOL | m_bVerticalMarker
TRUE to draw marker vertically.
DWORD_PTR | m_dwData
The 32-bit value associated with the command bar.
UINT * | m_pReturnCmd
Return command holder.
BOOL | m_bCustomizeDialogPresent
TRUE if the command bar is present in Customize dialog.
BOOL | m_bAnimatePopup
TRUE to animate pop-up bar.
BOOL | m_nLockRedraw
TRUE if all drawing routines skipped.
CXTPPaintManager * | m_pPaintManager
Selected paint manager for command bar.
CXTPImageManager * | m_pImageManager
Selected image manager for command bar.
BOOL | m_bMultiLine
True if multi line commandbar.
XTPButtonStyle | m_buttonStyle
Default button Style.
XTPBarTextOrientation | m_nTextOrientation
Commandbar text orientation.
CXTPToolTipContext * | m_pToolTipContext
Tool tip Context.
CXTPCommandBarAnimation * | m_pAnimation
Animation context.
CSize | m_szButtonSpacing
Spacing used between toolbar buttons.
- Protected Attributes inherited from CXTPTabManager
CXTPTabManagerItem * m_pSelected
Tab currently selected (i.e.
CXTPTabManagerItem * m_pHighlighted
Tab currently highlighted (i.e.
CXTPTabManagerItem * | m_pPressed
Pointer to the currently pressed tab.
CXTPTabManagerNavigateButton * | m_pHighlightedNavigateButton
Pointer to highlighted navigate button.
int | m_nHeaderOffset
Scroll offset, this is how much the tabs in the tab header have been scrolled using the left and right tab navigation buttons.
BOOL | m_bAllowReorder
TRUE to allow tabs to be reordered.
BOOL | m_bActive
TRUE if the MDITabClient tab group is active.
XTPTabNavigateButtonFlags | m_bCloseItemButton
TRUE to show the close button for tabs.
CRect | m_rcHeaderRect
Bounding rectangle of the tab header area.
CRect | m_rcControl
Bounding rectangle of the tab manager control.
CArray< CXTPTabManagerItem *, CXTPTabManagerItem * > | m_arrItems
Bounding rectangle of the tab client area.
CXTPTabManagerNavigateButtons | m_arrNavigateButtons
Collection of tab navigation buttons for this tab manager.
CRowIndexer * | m_pRowIndexer
Row indexer.
int | m_nScrollDelta
Scroll header delta.
CXTPMarkupContext * | m_pMarkupContext
Markup context of the tab manager.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPToolBar
static BOOL AFX_CDECL | DoUpdateCustomizeMenuControl (CXTPControl *pControl, CCmdTarget *pTarget)
Tries to update a Customize menu control.
- Public Attributes inherited from CXTPCommandBar
int | m_nStateFlags
State of the command bars.
BOOL | m_bComboBar
TRUE if it is combobox list.
BOOL | m_bTrackOnHover
TRUE to select item if mouse stay over control.
- Public Attributes inherited from CXTPHookManagerHookAble
BOOL | m_bAutoDestroy
TRUE to automatically delete hook.
- Static Public Attributes inherited from CXTPCommandBar
static int | s_nHoverDelay
Hover delay time.
static int | s_nExpandDelay
Expand delay time.
static int | s_nExpandHoverDelay
Expand hover delay.

Detailed Description

CXTPTabToolBar is a CXTPToolBar derived class.

It represents a tabbable toolbar.

Member Function Documentation

◆ CalcDockingLayout()

CSize CalcDockingLayout | ( | int | nLength,
 |  | DWORD | dwMode,
 |  | int | nWidth )
 protectedvirtual

This method calculates the dimensions of a toolbar.

Parameters
nLength | Length of the bar.
dwMode | Mode to dock.
nWidth | Width of the bar.
Returns
Size of the docked toolbar.

Reimplemented from CXTPToolBar.

◆ CalcDynamicLayout()

CSize CalcDynamicLayout | ( | int | nLength,
 |  | DWORD | dwMode )
 protectedvirtual

This method calculates the dimensions of a toolbar.

Parameters
nLength | The requested dimension of the control bar, either horizontal or vertical, depending on dwMode.
dwMode | Mode to dock.
Returns
Size of the docked toolbar.

Reimplemented from CXTPToolBar.

◆ DrawCommandBar()

void DrawCommandBar | ( | CDC * | pDC,
 |  | CRect | rcClipBox )
 protectedvirtual

This method is called to draw the command bar in the given context.

Parameters
pDC | Pointer to a valid device context.
rcClipBox | The rectangular area of the control that is invalid.

Reimplemented from CXTPCommandBar.

◆ DrawIcon()

BOOL DrawIcon | ( | CDC * | pDC,
 |  | CPoint | pt,
 |  | CXTPTabManagerItem * | pItem,
 |  | BOOL | bDraw,
 |  | CSize & | szIcon ) const
 protectedvirtual

This member is called when the icon of the tab needs to be drawn.

Parameters
pDC | Pointer to the destination device context.
pt | Specifies the location of the image.
pItem | CXTPTabManagerItem object to draw icon on.
bDraw | TRUE if the icon needs to be drawn (e.g. the icon size changed), FALSE if the icon does not need to be drawn or redrawn.
szIcon | Size of the tab icon.

This member is overridden by its descendants. This member must be overridden in derived classes.

Returns
TRUE if the icon was successfully drawn, FALSE if the icon was not drawn.

Implements CXTPTabManager.

◆ GetBorders()

CRect GetBorders ( )
protectedvirtual

This method retrieves the borders of the toolbar.

Returns
A CRect object containing the borders of the toolbar.

Reimplemented from CXTPToolBar.

◆ GetPaintManager()

AFX_INLINE CXTPTabPaintManager * GetPaintManager ( ) const
virtual

Call this member to get a pointer to the tab paint manager.

The tab paint manager is used to customize the appearance of CXTPTabManagerItem objects and the tab manager (e.g. tab colors, styles, etc.).

This member must be overridden in derived classes.

Returns
Pointer to CXTPTabPaintManager that contains the visual elements of the tabs.

Implements CXTPTabManager.

◆ InsertCategory() [1/2]

CXTPTabManagerItem * InsertCategory | ( | int | nItem,
 |  | LPCTSTR | lpszItem,
 |  | UINT * | pItems,
 |  | int | nCount,
 |  | BOOL | bLoadIcons = TRUE )

Call this method to add a new tab to CXTPTabToolBar.

Parameters
nItem | Index to insert category to.
lpszItem | Caption of new tab.
pItems | Control items.
nCount | Control items count.
bLoadIcons | TRUE to load icons.
Returns
CXTPTabManagerItem class of new tab.

◆ InsertCategory() [2/2]

CXTPTabManagerItem * InsertCategory | ( | int | nItem,
 |  | LPCTSTR | lpszItem,
 |  | UINT | nIDResource,
 |  | BOOL | bLoadIcons = TRUE )

Call this method to add a new tab to CXTPTabToolBar.

Parameters
nItem | Index to insert category to.
lpszItem | Caption of new tab.
bLoadIcons | TRUE to load icons.
nIDResource | Toolbar resource identifier.
Returns
CXTPTabManagerItem class of new tab.

◆ OnBeforeItemClick()

BOOL OnBeforeItemClick ( CXTPTabManagerItem * pItem )
protectedvirtual

This method is called before an item click.

Parameters
pItem Pointer to the item that is about to be clicked.
Returns
TRUE if the process was canceled, otherwise FALSE.

Reimplemented from CXTPTabManager.

◆ OnCustomizeDrop()

void OnCustomizeDrop | ( | CXTPControl * | pDataObject,
 |  | DROPEFFECT & | dropEffect,
 |  | CPoint | ptDrop,
 |  | CPoint | ptDrag )
 protectedvirtual

This method is called when a control is dropped to the command bar.

Parameters
pDataObject | Pointer to a CXTPControl object.
dropEffect | DROPEFFECT enumerator.
ptDrop | Point where the user dropped the control.
ptDrag | Point where the user started dragging the control.

Reimplemented from CXTPCommandBar.

◆ RedrawControl()

void RedrawControl | ( | LPCRECT | lpRect,
 |  | BOOL | bAnimate )
 protectedvirtual

This member is called when the visual properties of the tabs are changed (e.g.

color, mouse-over, and on-click).

This member must be overridden in derived classes.

Parameters
lpRect | The rectangular area of the window that is invalid.
bAnimate | TRUE to animate changes in the bounding rectangle.

Implements CXTPTabManager.

◆ Reset()

void Reset ( BOOL bShowWarningMessage )
protectedvirtual

Resets the controls to their original state.

Parameters
bShowWarningMessage TRUE to show warning message.

Reimplemented from CXTPToolBar.

◆ SetMinimumWidth()

AFX_INLINE void SetMinimumWidth ( int nMinWidth )

Call this method to set the minimum available width of the toolbar.

Parameters
nMinWidth Minimum width of the toolbar.

◆ SetSelectedItem()

void SetSelectedItem ( CXTPTabManagerItem * pItem )
protectedvirtual

Call this member to select a CXTPTabManagerItem tab.

A selected tab is the currently active tab.

Parameters
pItem CXTPTabManagerItem tab to select.

This member will will select the specified CXTPTabManagerItem. SetCurSel will set the current CXTPTabManagerItem by its index within the collection of items. A tab is selected when it has focus or is clicked.

See also
CXTPTabManagerItem, GetCurSel, SetCurSel, GetSelectedItem

Reimplemented from CXTPTabManager.

◆ UpdateTabs()

void UpdateTabs ( CXTPTabManagerItem * pItem = NULL )

Call this method to refresh controls on the selected tab.

Parameters
pItem Selected item.
The documentation for this class was generated from the following file:
  • XTPTabToolBar.h


Toolkit Pro: CXTPTabView Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPTabView Class Reference

CXTPTabView is a multiple inheritance class derived from CCtrlView and CXTPTabCtrlBaseEx. More...

Public Member Functions

CXTPTabView ()
Constructs a CXTPTabView object.
virtual | ~CXTPTabView ()
Destroys a CXTPTabView object, handles cleanup and deallocation.
virtual CTabCtrl & | GetTabCtrl () const
Call this member function to retrieve a reference pointer to the CTabCtrl object associated with this view.
virtual CImageList * | SetTabImageList (CImageList *pImageList)
Call this function to assign an image list to the tab control associated with this view.
virtual CToolTipCtrl * | GetToolTips ()
This member function retrieves the handle of the tooltip control associated with the tab control.
virtual void | SetToolTips (CToolTipCtrl *pWndTip)
Call this function to assign a tooltip control to the tab control.
void | UpdateDocTitle ()
Call this member function to update the document name with the tab label.

Protected Member Functions

virtual BOOL Init ()
This member function is called by the CXTPTabView class to perform initialization when the window is created or sub-classed.

Detailed Description

CXTPTabView is a multiple inheritance class derived from CCtrlView and CXTPTabCtrlBaseEx.

CXTPTabView can be used to create a view that contains nested views displayed in a tab control. See CXTPTabCtrlBaseEx for additional functionality.

Member Function Documentation

◆ GetTabCtrl()

virtual CTabCtrl & GetTabCtrl ( ) const
virtual

Call this member function to retrieve a reference pointer to the CTabCtrl object associated with this view.

Returns
A CTabCtrl reference to the object associated with this view.

◆ GetToolTips()

virtual CToolTipCtrl * GetToolTips ( )
virtual

This member function retrieves the handle of the tooltip control associated with the tab control.

The tab control creates a tooltip control if it has the TCS_TOOLTIPS style. You can also assign a tooltip control to a tab control by using the SetToolTips member function.

Returns
The handle of the tooltip control if successful, otherwise NULL.

◆ Init()

virtual BOOL Init ( )
protectedvirtual

This member function is called by the CXTPTabView class to perform initialization when the window is created or sub-classed.

Returns
TRUE if the window was successfully initialized, otherwise FALSE.

◆ SetTabImageList()

virtual CImageList * SetTabImageList ( CImageList * pImageList )
virtual

Call this function to assign an image list to the tab control associated with this view.

Parameters
pImageList A pointer to the image list to be assigned to the tab control.
Returns
A pointer to the previous image list, or NULL if there is no previous image list.

◆ SetToolTips()

virtual void SetToolTips ( CToolTipCtrl * pWndTip )
virtual

Call this function to assign a tooltip control to the tab control.

You can associate the tooltip control with a tab control by making a call to GetToolTips.

Parameters
pWndTip A pointer to a tooltip control.
The documentation for this class was generated from the following file:
  • XTPTabView.h


Toolkit Pro: CXTPTagCloudCtrl Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPTagCloudCtrl Class Reference

The CXTPTagCloudCtrl class is used to create a tag cloud control representing a visual depiction of generated tags identified by color and font size to represent the prominence or frequency of the tags depicted. More...

Public Member Functions

CXTPTagCloudCtrl ()
Default constructor.
virtual | ~CXTPTagCloudCtrl ()
Destructor used to handle cleanup and deallocation.
virtual BOOL | Create (DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID)
Call this member function to create the CXTPTagCloudCtrl window.
void | AddTag (XTP_TAGCLOUDTAG *pTag)
Adds a new tag to the tag cloud control.
void | RemoveTag (XTP_TAGCLOUDTAG *pTag)
Removes a tag from the tag cloud control.
void | RemoveAll ()
Removes all tags from the XTP_TAGCLOUDTAG window.
XTP_TAGCLOUDTAG * | HitTest (const CPoint &point)
Retrieves the tag from the cursor position specified by point.
virtual void | RecalcLayout ()
Recalculates the size and position for all tags associated with the tag cloud control.
void | SetMargin (int nMargin)
Sets the margin for the client area of the tag cloud control.
int | GetMargin () const
Retrieves the client area margin for the tag cloud control.
void | SetPadding (int nPadding)
Sets the padding for each tag associated with the tag cloud control.
int | GetPadding () const
Retrieves the padding for each tag associated with the tag cloud control.
void | EnableTooltip (BOOL bTipEnabled)
Enables/disables tooltips for the tag cloud control.
BOOL | IsTipEnabled () const
Called to determine if tooltips are enabled for the tab cloud control.
void | EnableFocusRect (BOOL bFocusRect)
Enables/disables tag item focus rectangle display.
BOOL | IsFocusEnabled () const
Called to determine if tag item focus display is enabled for the tag cloud control.
void | SetSortOrder (XTPTagCloudSort nSortOrder, BOOL bAsc)
Sets the sort order for all tags associated with the tag cloud control.
XTPTagCloudSort | GetSortOrder () const
Called to determine the sort order for the tag cloud control; can be one of the following values: xtpTagCloudNone, xtpTagCloudAlpha or xtpTagCloudNumeric.
XTP_TAGCLOUDTAG * GetCurSel ()
Retrieves a pointer to the currently selected tag if any.
void | SetCurSel (XTP_TAGCLOUDTAG *pCurSel)
Sets the current selection for the tag cloud control and sends an event notification to the owner window.
void | SetBackColor (CXTPPaintManagerColorGradient clrBack, BOOL bHorz=FALSE)
Sets the background color for the tag cloud control.
CXTPPaintManagerColorGradient | GetBackColor () const
Retrieves the background color for the tag cloud control.
void | SetBorderColor (CXTPPaintManagerColor clrBorder)
Sets the border color for the tag cloud control.
CXTPPaintManagerColor | GetBorderColor () const
Retrieves the border color for the tag cloud control.
BOOL | IsFillHorz () const
Determines if the background gradient fill style is horizontal or vertical.
void | RestoreDefaults ()
Called to restore all default values for the tag cloud control.

Protected Member Functions

virtual CXTPTagCloudTagArray & | GetTagArray ()
Retrieves a reference to the CXTPTagCloudTagArray that contains all of the tags associated with the tag cloud control.
virtual BOOL | RegisterWindowClass (HINSTANCE hInstance=NULL)
Called by the tag cloud control to register the window class used to create the control.
virtual void | OnDraw (CDC *pDC, const CRect &rcClient)
Called by the tag cloud control to draw the client area of the control.
virtual CSize | CalcRowLayout (const CRect &rcClient, const CXTPTagCloudTagArray &arrRow)
Called by the OnDraw function to calculate the size and position for a tag in the row specified by arrRow.
virtual BOOL | PointInRect ()
Retrieves the cursor position in window coordinates and determines if the cursor is hovering over the tag cloud window.
virtual void | SetActive (BOOL bActive)
Called during mouse move events to set the active/inactive state for the tag cloud control.
virtual BOOL | OnNotify (XTP_TAGCLOUDTAG *pTag, UINT nEventCode)
Called by tag cloud control to send notification messages to the owner window when an event specified by nEventCode occurs.
void | RemoveAllInternal ()
Removes all tags from the XTP_TAGCLOUDTAG window.

Protected Attributes

int | m_nPadding
Size, in pixels, of the padding around each tag item.
int | m_nMargin
Size, in pixels, of the margin for the client area.
BOOL | m_bActive
TRUE if the tag cloud control is active.
BOOL | m_bTipEnabled
Set to FALSE to disable tooltips.
BOOL | m_bFocusRect
Set to FALSE to disable focus rect.
BOOL | m_bHorz
TRUE if the background gradient colors should be drawn horizontal, FALSE if vertical.
BOOL | m_bAsc
TRUE if sorting ascending, FALSE if sorting descending.
HCURSOR | m_hCursor
Handle to the mouse hover cursor.
CToolTipCtrl | m_wndToolTip
Tooltip to be displayed for the control.
XTPTagCloudSort | m_nSortOrder
Specifies the sort order for the tag cloud control.
XTP_TAGCLOUDTAG * | m_pHover
Pointer to the tag item that the mouse cursor is currently hovering over.
XTP_TAGCLOUDTAG * | m_pCurSel
Pointer to the tag item that is currently selected.
CXTPTagCloudTagArray | m_arrTags
Array of all tags associated with the tag cloud control.
CXTPTagCloudTagArray | m_arrTagsSorted
Array of sorted tags associated with the tag cloud control.
CXTPPaintManagerColor | m_clrBorder
Tag cloud control border color.
CXTPPaintManagerColorGradient | m_clrBack
Tag cloud control background colors.
CXTPWinThemeWrapper | m_themeWrapper
Determines if tag cloud control should use Windows themes.

Detailed Description

The CXTPTagCloudCtrl class is used to create a tag cloud control representing a visual depiction of generated tags identified by color and font size to represent the prominence or frequency of the tags depicted.

Member Function Documentation

◆ AddTag()

void AddTag ( XTP_TAGCLOUDTAG * pTag )

Adds a new tag to the tag cloud control.

Parameters
pTag A pointer to a valid XTP_TAGCLOUDTAG object to add.

◆ CalcRowLayout()

virtual CSize CalcRowLayout | ( | const CRect & | rcClient,
 |  | const CXTPTagCloudTagArray & | arrRow )
 protectedvirtual

Called by the OnDraw function to calculate the size and position for a tag in the row specified by arrRow.

Parameters
rcClient | Specifies the client area of the tag cloud excluding margins.
arrRow | Array of tags representing a single row in the tag cloud control.
Returns
A CSize object representing the max width and height for each tag in the row specified by arrRow.

◆ Create()

virtual BOOL Create | ( | DWORD | dwStyle,
 |  | const RECT & | rect,
 |  | CWnd * | pParentWnd,
 |  | UINT | nID )
 virtual

Call this member function to create the CXTPTagCloudCtrl window.

Parameters
dwStyle | Specifies the window style.
rect | Size of the tag cloud control.
pParentWnd | Parent window.
nID | Identifier for the tag cloud control.
Returns
TRUE if successful, otherwise FALSE.

◆ EnableFocusRect()

void EnableFocusRect ( BOOL bFocusRect )

Enables/disables tag item focus rectangle display.

Parameters
bFocusRect TRUE to enable tag item focus display.

◆ EnableTooltip()

void EnableTooltip ( BOOL bTipEnabled )

Enables/disables tooltips for the tag cloud control.

Parameters
bTipEnabled TRUE to enable tooltips, FALSE to disable.

◆ GetBackColor()

CXTPPaintManagerColorGradient GetBackColor ( ) const

Retrieves the background color for the tag cloud control.

Returns
A CXTPPaintManagerColorGradient representing the background color for the tag cloud control.

◆ GetBorderColor()

CXTPPaintManagerColor GetBorderColor ( ) const

Retrieves the border color for the tag cloud control.

Returns
A CXTPPaintManagerColor object representing the border color for the tag cloud control.

◆ GetCurSel()

XTP_TAGCLOUDTAG * GetCurSel ( )

Retrieves a pointer to the currently selected tag if any.

Returns
A pointer to the currently selected XTP_TAGCLOUDTAG object if a tag has been selected, otherwise NULL.

◆ GetMargin()

int GetMargin ( ) const

Retrieves the client area margin for the tag cloud control.

Returns
An integer representing the client area margin in pixels.

◆ GetPadding()

int GetPadding ( ) const

Retrieves the padding for each tag associated with the tag cloud control.

Returns
An integer representing the padding for each tag in pixels.

◆ GetSortOrder()

XTPTagCloudSort GetSortOrder ( ) const

Called to determine the sort order for the tag cloud control; can be one of the following values: xtpTagCloudNone, xtpTagCloudAlpha or xtpTagCloudNumeric.

Returns
A XTPTagCloudSort enumeration value representing the tag cloud control sort order.

◆ GetTagArray()

virtual CXTPTagCloudTagArray & GetTagArray ( )
protectedvirtual

Retrieves a reference to the CXTPTagCloudTagArray that contains all of the tags associated with the tag cloud control.

Returns
A reference to a CXTPTagCloudTagArray object.

◆ HitTest()

XTP_TAGCLOUDTAG * HitTest ( const CPoint & point )

Retrieves the tag from the cursor position specified by point.

Parameters
point Cursor position in client coordinates.
Returns
A pointer to an XTP_TAGCLOUDTAG if successful, otherwise NULL.

◆ IsFillHorz()

BOOL IsFillHorz ( ) const

Determines if the background gradient fill style is horizontal or vertical.

Returns
TRUE if the fill style is horizontal, FALSE if vertical.

◆ IsFocusEnabled()

BOOL IsFocusEnabled ( ) const

Called to determine if tag item focus display is enabled for the tag cloud control.

Returns
TRUE if tag item focus has been enabled, otherwise FALSE.

◆ IsTipEnabled()

BOOL IsTipEnabled ( ) const

Called to determine if tooltips are enabled for the tab cloud control.

Returns
TRUE if tooltips are enabled for the tag cloud control.

◆ OnDraw()

virtual void OnDraw | ( | CDC * | pDC,
 |  | const CRect & | rcClient )
 protectedvirtual

Called by the tag cloud control to draw the client area of the control.

Parameters
pDC | Pointer to a valid device context.
rcClient | Size of the client area to draw.

◆ OnNotify()

virtual BOOL OnNotify | ( | XTP_TAGCLOUDTAG * | pTag,
 |  | UINT | nEventCode )
 protectedvirtual

Called by tag cloud control to send notification messages to the owner window when an event specified by nEventCode occurs.

Parameters
pTag | Pointer to an XTP_TAGCLOUDTAG struct.
nEventCode | Event code identifier.
Returns
TRUE if notification was sent to the owner window, otherwise FALSE.

◆ PointInRect()

virtual BOOL PointInRect ( )
protectedvirtual

Retrieves the cursor position in window coordinates and determines if the cursor is hovering over the tag cloud window.

Returns
TRUE if the cursor is hovering over the tag cloud control, otherwise FALSE.

◆ RegisterWindowClass()

virtual BOOL RegisterWindowClass ( HINSTANCE hInstance = NULL )
protectedvirtual

Called by the tag cloud control to register the window class used to create the control.

Parameters
hInstance Handle to the instance that contains the window procedure for the class.
Returns
TRUE if successful, otherwise FALSE.

◆ RemoveTag()

void RemoveTag ( XTP_TAGCLOUDTAG * pTag )

Removes a tag from the tag cloud control.

Parameters
pTag A pointer to a valid XTP_TAGCLOUDTAG object to remove.

◆ SetActive()

virtual void SetActive ( BOOL bActive )
protectedvirtual

Called during mouse move events to set the active/inactive state for the tag cloud control.

Parameters
bActive TRUE if the tag cloud control is active, FALSE if inactive.

◆ SetBackColor()

void SetBackColor | ( | CXTPPaintManagerColorGradient | clrBack,
 |  | BOOL | bHorz = FALSE )

Sets the background color for the tag cloud control.

Parameters
clrBack | A CXTPPaintManagerColorGradient representing the background color for the tag cloud control. If dark and light colors are specified, then the background will be drawn gradient, otherwise drawn solid.
bHorz | TRUE if the gradient should be drawn horizontal, FALSE to draw vertical.

◆ SetBorderColor()

void SetBorderColor ( CXTPPaintManagerColor clrBorder )

Sets the border color for the tag cloud control.

Parameters
clrBorder Specifies the new border color.

◆ SetCurSel()

void SetCurSel ( XTP_TAGCLOUDTAG * pCurSel )

Sets the current selection for the tag cloud control and sends an event notification to the owner window.

Parameters
pCurSel A pointer to a valid XTP_TAGCLOUDTAG tag.

◆ SetMargin()

void SetMargin ( int nMargin )

Sets the margin for the client area of the tag cloud control.

Parameters
nMargin Size, in pixels, of the margin to set.

◆ SetPadding()

void SetPadding ( int nPadding )

Sets the padding for each tag associated with the tag cloud control.

Parameters
nPadding Size, in pixels, of the padding to set.

◆ SetSortOrder()

void SetSortOrder | ( | XTPTagCloudSort | nSortOrder,
 |  | BOOL | bAsc )

Sets the sort order for all tags associated with the tag cloud control.

Parameters
nSortOrder | Specifies the sort order for the tag items; can be one of the following values: xtpTagCloudNone, xtpTagCloudAlpha, or xtpTagCloudNumeric.
bAsc | TRUE to sort ascending, FALSE to sort descending.
The documentation for this class was generated from the following file:
  • XTPTagCloudCtrl.h


Toolkit Pro: CXTPTagCloudStyle Class Reference

Public Member Functions | Static Public Member Functions | Public Attributes | List of all members
CXTPTagCloudStyle Class Reference

CXTPTagCloudStyle is a helper class used by CXTPTagCloudStyleManager to manage styles for the CXTPTagCloudCtrl class. More...

Public Member Functions

CXTPTagCloudStyle ()
Default constructor.
CXTPTagCloudStyle (const CXTPTagCloudStyle &style)
Default constructor.
CXTPTagCloudStyle (int nScore, COLORREF clrText, COLORREF clrTextHover, COLORREF clrBorder, LOGFONT &lf)
Default constructor.
void | SetFont (LOGFONT &lf)
Sets the font for the style using the LOGFONT struct specified by lf.
CXTPTagCloudStyle & | operator= (const CXTPTagCloudStyle &style)
Overloaded operator initializes a CXTPTagCloudStyle class using the object specified by style.

Static Public Member Functions

static void AFX_CDECL Copy (const CXTPTagCloudStyle *pSource, CXTPTagCloudStyle *pDest)
Copies the contents from one CXTPTagCloudStyle object to another.

Public Attributes

int | m_nScore
Unique identifier used to specify the score or weight of the style.
CXTPFont | m_xtpFont
Font used by the style.
COLORREF | m_clrText
An RGB value representing the style text color.
COLORREF | m_clrTextHover
An RGB value representing the style text hover color.
COLORREF | m_clrBorder
An RGB value representing the style border color.

Detailed Description

CXTPTagCloudStyle is a helper class used by CXTPTagCloudStyleManager to manage styles for the CXTPTagCloudCtrl class.

Constructor & Destructor Documentation

◆ CXTPTagCloudStyle() [1/2]

CXTPTagCloudStyle ( const CXTPTagCloudStyle & style )

Default constructor.

Parameters
style Reference to a CXTPTagCloudStyle object.

◆ CXTPTagCloudStyle() [2/2]

CXTPTagCloudStyle | ( | int | nScore,
 |  | COLORREF | clrText,
 |  | COLORREF | clrTextHover,
 |  | COLORREF | clrBorder,
 |  | LOGFONT & | lf )

Default constructor.

Parameters
nScore | Unique ID for the style.
clrText | An RGB value representing the style text color.
clrTextHover | An RGB value representing the style text hover color.
clrBorder | An RGB value representing the style border color. Setting to COLORREF_NULL (-1) indicates no border.
lf | Reference to a LOGFONT struct used to create the font used by the style.

Member Function Documentation

◆ Copy()

static void AFX_CDECL Copy | ( | const CXTPTagCloudStyle * | pSource,
 |  | CXTPTagCloudStyle * | pDest )
 static

Copies the contents from one CXTPTagCloudStyle object to another.

Parameters
pSource | Pointer to the source CXTPTagCloudStyle object.
pDest | Pointer to the destination CXTPTagCloudStyle object.
Returns

◆ operator=()

CXTPTagCloudStyle & operator= ( const CXTPTagCloudStyle & style )

Overloaded operator initializes a CXTPTagCloudStyle class using the object specified by style.

Parameters
style Reference to a CXTPTagCloudStyle object used to initialize this class.
Returns
A reference to the CXTPTagCloudStyle object.

◆ SetFont()

void SetFont ( LOGFONT & lf )

Sets the font for the style using the LOGFONT struct specified by lf.

Parameters
lf Reference to a LOGFONT struct used to create the font used by the style.
The documentation for this class was generated from the following file:
  • XTPTagCloudCtrl.h


Toolkit Pro: CXTPTagCloudStyleManager Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPTagCloudStyleManager Class Reference

CXTPTagCloudStyleManager is a singleton class used to manage CXTPTagCloudStyle structs that identify each tag style used by CXTPTagCloudCtrl. More...

Inheritance diagram for CXTPTagCloudStyleManager:
[legend]

Public Member Functions

~CXTPTagCloudStyleManager ()
Destructor used to handle cleanup and deallocation.
void | InitDefaultStyles ()
Called by the CXTPTagCloudCtrl to initialize a default array of CXTPTagCloudStyle structs representing unique tag styles.
INT_PTR | AddStyle (int nScore, COLORREF clrText, COLORREF clrTextHover, COLORREF clrBorder, LOGFONT &lf)
Call this member function to add a new style to the style array.
INT_PTR | AddStyle (CXTPTagCloudStyle *pStyle)
Call this member function to add a new style to the style array.
BOOL | RemoveStyle (int nScore)
Call this member function to remove an existing style from the style array.
void | RemoveAll ()
Call this member function to remove all tag styles from the style array and free any allocated memory.
CXTPTagCloudStyle * | GetStyle (int nScore)
Call this member function to retrieve the style associated with the identifier specified by nScore.
BOOL | SetColors (int nScore, COLORREF clrText, COLORREF clrTextHover, COLORREF clrBorder=COLORREF_NULL)
Sets the color values for the style specified by nScore.
BOOL | SetFont (int nScore, LOGFONT &lf)
Sets the font for the style specified by nScore.
CXTPTagCloudStyleArray & GetCloudStyleArray ()
Call this member function to retrieve a reference to the CXTPTagCloudStyleArray managed by CXTPTagCloudStyleManager.
BOOL | ScoreExists (int nScore)
Call this member function to determine if the score specified by nScore already exists in the array.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Attributes

CXTPTagCloudStyleArray m_arrStyles
Array of CXTPTagCloudStyle structs managed by CXTPTagCloudStyleManager.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

CXTPTagCloudStyleManager is a singleton class used to manage CXTPTagCloudStyle structs that identify each tag style used by CXTPTagCloudCtrl.

Member Function Documentation

◆ AddStyle() [1/2]

INT_PTR AddStyle ( CXTPTagCloudStyle * pStyle )

Call this member function to add a new style to the style array.

Parameters
pStyle Pointer to a valid CXTPTagCloudStyle object.
Returns
The index of the added element.

◆ AddStyle() [2/2]

INT_PTR AddStyle | ( | int | nScore,
 |  | COLORREF | clrText,
 |  | COLORREF | clrTextHover,
 |  | COLORREF | clrBorder,
 |  | LOGFONT & | lf )

Call this member function to add a new style to the style array.

Parameters
nScore | Unique ID for the style.
clrText | An RGB value representing the style text color.
clrTextHover | An RGB value representing the style text hover color.
clrBorder | An RGB value representing the style border color. Setting to COLORREF_NULL (-1) indicates no border.
lf | Reference to a LOGFONT struct used to create the font used by the style.
Returns
The index of the added element.

◆ GetCloudStyleArray()

CXTPTagCloudStyleArray & GetCloudStyleArray ( )

Call this member function to retrieve a reference to the CXTPTagCloudStyleArray managed by CXTPTagCloudStyleManager.

Returns
A reference to a CXTPTagCloudStyleArray object.

◆ GetStyle()

CXTPTagCloudStyle * GetStyle ( int nScore )

Call this member function to retrieve the style associated with the identifier specified by nScore.

Parameters
nScore Unique identifier for the style to find.
Returns
A pointer to a CXTPTagCloudStyle object if successful, otherwise NULL.

◆ RemoveStyle()

BOOL RemoveStyle ( int nScore )

Call this member function to remove an existing style from the style array.

Parameters
nScore Identifier of the style to remove.
Returns
TRUE if successful, otherwise FALSE.

◆ ScoreExists()

BOOL ScoreExists ( int nScore )

Call this member function to determine if the score specified by nScore already exists in the array.

Parameters
nScore Score index to check.
Returns
TRUE if the score already exists, otherwise FALSE.

◆ SetColors()

BOOL SetColors | ( | int | nScore,
 |  | COLORREF | clrText,
 |  | COLORREF | clrTextHover,
 |  | COLORREF | clrBorder = COLORREF_NULL )

Sets the color values for the style specified by nScore.

Parameters
nScore | ID of the style to update.
clrText | An RGB value representing the style text color. If COLORREF_NULL, then this value is ignored.
clrTextHover | An RGB value representing the style text highlight color If COLORREF_NULL, then this value is ignored.
clrBorder | An RGB value representing the style border color. If COLORREF_NULL, then no border will be drawn.
Returns
TRUE if the style was found and updated, otherwise FALSE.

◆ SetFont()

BOOL SetFont | ( | int | nScore,
 |  | LOGFONT & | lf )

Sets the font for the style specified by nScore.

Parameters
nScore | ID of the style to update.
lf | Reference to a LOGFONT struct used to create the font used by the style.
Returns
TRUE if the style was found and updated, otherwise FALSE.
The documentation for this class was generated from the following file:
  • XTPTagCloudCtrl.h


Toolkit Pro: CXTPTagCloudTagArray Class Reference

Public Member Functions | List of all members
CXTPTagCloudTagArray Class Reference

CXTPTagCloudTagArray is a CArray derived class used to manage XTP_TAGCLOUDTAG objects for the CXTPTagCloudCtrl class. More...

Public Member Functions

void Sort (XTPTagCloudSort nSort, BOOL bAsc)
Call this member function to sort the tag item array by the style specified by nSort.

Detailed Description

CXTPTagCloudTagArray is a CArray derived class used to manage XTP_TAGCLOUDTAG objects for the CXTPTagCloudCtrl class.

Member Function Documentation

◆ Sort()

void Sort | ( | XTPTagCloudSort | nSort,
 |  | BOOL | bAsc )

Call this member function to sort the tag item array by the style specified by nSort.

Parameters
nSort | Specifies the sorting style; can be one of the following values: xtpTagCloudNone, xtpTagCloudAlpha, or xtpTagCloudNumeric.
bAsc | TRUE to sort ascending, FALSE to sort descending.
The documentation for this class was generated from the following file:
  • XTPTagCloudCtrl.h


Toolkit Pro: CXTPTaskButtonTheme Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPTaskButtonTheme Class Reference

CXTPTaskButtonTheme. More...

Inheritance diagram for CXTPTaskButtonTheme:
[legend]

Public Member Functions

virtual void | RefreshMetrics (CXTPButton *pButton)
This member function is called by the theme manager to refresh the visual styles used by each component's theme.
- Public Member Functions inherited from CXTPButtonTheme
CXTPButtonTheme ()
Constructs a CXTPButtonTheme object.
virtual | ~CXTPButtonTheme ()
Destroys a CXTPButtonTheme object, handles cleanup and deallocation.
virtual void | DrawButtonBackground (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the background for the button.
virtual void | DrawFocusRect (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the focus rectangle for the button.
virtual void | DrawButtonVisualStyleBackground (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the styled background for the button.
virtual void | DrawPushButtonText (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the text for the button.
virtual void | DrawPushButtonIcon (CDC *pDC, CXTPButton *pButton)
This member function draws the icon for the button, if one has been defined.
virtual void | DrawPushButtonDropDown (CDC *pDC, CXTPButton *pButton)
This member function draws the dropdown for the button, if one has been defined.
virtual void | DrawCheckBoxMark (CDC *pDC, CXTPButton *pButton)
This member function draws the check box mark for the button, if one has been defined.
virtual void | DrawRadioButtonMark (CDC *pDC, CXTPButton *pButton)
This member function draws the radio button mark for the button, if one has been defined.
void | DrawButtonText (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the text for the button.
virtual void | DrawGroupBox (CDC *pDC, CXTPButton *pButton)
This member function draws the group box for the button, if one has been defined.
- Public Member Functions inherited from CXTPControlTheme
CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme | GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

virtual COLORREF | GetTextColor (CXTPButton *pButton)
Call this member function to return the color used to draw the button text.
virtual void | DrawButton (CDC *pDC, CXTPButton *pButton)
This member function is called to the button.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlTheme
static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPButtonTheme
CXTPPaintManagerColor | m_crTextDisabled
RGB value for disabled text color.
CXTPPaintManagerColor | m_crBorderHilite
RGB value for border highlight color.
CXTPPaintManagerColor | m_crBorderShadow
RGB value for border shadow color.
CXTPPaintManagerColor | m_crBorder3DHilite
RGB value for 3D border highlight color.
CXTPPaintManagerColor | m_crBorder3DShadow
RGB value for 3D border shadow color.
CXTPPaintManagerColor | m_crBack
RGB value for background color.
CXTPPaintManagerColor | m_crText
RGB value for text color.
CXTPPaintManagerColor | m_crTextCheck
RGB value for checked text color.
- Protected Attributes inherited from CXTPControlTheme
XTPControlTheme | m_nTheme
Currently selected theme style index.

Detailed Description

CXTPTaskButtonTheme.

Member Function Documentation

◆ DrawButton()

virtual void DrawButton | ( | CDC * | pDC,
 |  | CXTPButton * | pButton )
 protectedvirtual

This member function is called to the button.

Parameters
pDC | A CDC pointer that represents the current device context.
pButton | Pointer to a CXTPButton object.

Reimplemented from CXTPButtonTheme.

◆ GetTextColor()

virtual COLORREF GetTextColor ( CXTPButton * pButton )
protectedvirtual

Call this member function to return the color used to draw the button text.

Parameters
pButton Pointer to a CXTPButton object.
Returns
An RGB value that represents the button text color.

Reimplemented from CXTPButtonTheme.

◆ RefreshMetrics()

virtual void RefreshMetrics ( CXTPButton * pButton )
virtual

This member function is called by the theme manager to refresh the visual styles used by each component's theme.

Parameters
pButton Pointer to a CXTPButton object.

Reimplemented from CXTPButtonTheme.

The documentation for this class was generated from the following file:
  • XTPTaskDialogControls.h


Toolkit Pro: CXTPTaskButtonThemeExpando Class Reference

Public Member Functions | List of all members
CXTPTaskButtonThemeExpando Class Reference

CXTPTaskButtonThemeExpando. More...

Inheritance diagram for CXTPTaskButtonThemeExpando:
[legend]

Public Member Functions

void | DrawButton (CDC *pDC, CXTPButton *pButton)
This member function is called to the button.
- Public Member Functions inherited from CXTPButtonTheme
CXTPButtonTheme ()
Constructs a CXTPButtonTheme object.
virtual | ~CXTPButtonTheme ()
Destroys a CXTPButtonTheme object, handles cleanup and deallocation.
virtual void | DrawButtonBackground (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the background for the button.
virtual void | DrawFocusRect (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the focus rectangle for the button.
virtual void | DrawButtonVisualStyleBackground (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the styled background for the button.
virtual void | RefreshMetrics (CXTPButton *pButton)
This member function is called by the theme manager to refresh the visual styles used by each component's theme.
virtual void | DrawPushButtonText (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the text for the button.
virtual void | DrawPushButtonIcon (CDC *pDC, CXTPButton *pButton)
This member function draws the icon for the button, if one has been defined.
virtual void | DrawPushButtonDropDown (CDC *pDC, CXTPButton *pButton)
This member function draws the dropdown for the button, if one has been defined.
virtual COLORREF | GetTextColor (CXTPButton *pButton)
Call this member function to return the color used to draw the button text.
virtual void | DrawCheckBoxMark (CDC *pDC, CXTPButton *pButton)
This member function draws the check box mark for the button, if one has been defined.
virtual void | DrawRadioButtonMark (CDC *pDC, CXTPButton *pButton)
This member function draws the radio button mark for the button, if one has been defined.
void | DrawButtonText (CDC *pDC, CXTPButton *pButton)
This member function is called to draw the text for the button.
virtual void | DrawGroupBox (CDC *pDC, CXTPButton *pButton)
This member function draws the group box for the button, if one has been defined.
- Public Member Functions inherited from CXTPControlTheme
CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme | GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlTheme
static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPButtonTheme
CXTPPaintManagerColor | m_crTextDisabled
RGB value for disabled text color.
CXTPPaintManagerColor | m_crBorderHilite
RGB value for border highlight color.
CXTPPaintManagerColor | m_crBorderShadow
RGB value for border shadow color.
CXTPPaintManagerColor | m_crBorder3DHilite
RGB value for 3D border highlight color.
CXTPPaintManagerColor | m_crBorder3DShadow
RGB value for 3D border shadow color.
CXTPPaintManagerColor | m_crBack
RGB value for background color.
CXTPPaintManagerColor | m_crText
RGB value for text color.
CXTPPaintManagerColor | m_crTextCheck
RGB value for checked text color.
- Protected Attributes inherited from CXTPControlTheme
XTPControlTheme | m_nTheme
Currently selected theme style index.

Detailed Description

CXTPTaskButtonThemeExpando.

Member Function Documentation

◆ DrawButton()

void DrawButton | ( | CDC * | pDC,
 |  | CXTPButton * | pButton )
 virtual

This member function is called to the button.

Parameters
pDC | A CDC pointer that represents the current device context.
pButton | Pointer to a CXTPButton object.

Reimplemented from CXTPButtonTheme.

The documentation for this class was generated from the following file:
  • XTPTaskDialogControls.h


Toolkit Pro: CXTPTaskDialog Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPTaskDialog Class Reference

The CXTPTaskDialog class creates, displays, and operates a task dialog. More...

Public Member Functions

CXTPTaskDialog (CWnd *pWndParent=NULL)
Constructs a CXTPTaskDialog object.
virtual | ~CXTPTaskDialog ()
Destroys a CXTPTaskDialog object, handles cleanup and deallocation.
void | SetWindowTitle (LPCTSTR pszText)
Call this member function to set the window title for the task dialog.
void | SetVerificationText (LPCTSTR pszText)
Call this member function to set the label for the verification checkbox to be displayed in the task dialog.
void | SetExpandedControlText (LPCTSTR pszText)
Call this member function to set the expanded control text for the task dialog.
void | SetCollapsedControlText (LPCTSTR pszText)
Call this member function to set the collapsed control text for the task dialog.
BOOL | SetMainInstruction (LPCTSTR pszText)
Call this member function to set the main instruction text for the task dialog.
BOOL | SetContent (LPCTSTR pszText)
Call this member function to set the content text for the task dialog.
BOOL | SetExpandedInformation (LPCTSTR pszText)
Call this member function to set the expanded information text for the task dialog.
BOOL | SetFooter (LPCTSTR pszText)
Call this member function to set the footer text for the task dialog.
BOOL | SetMainIcon (HICON hIcon)
Call this member function to set the icon for the Main Instruction area of the task dialog.
BOOL | SetMainIcon (LPCWSTR pszResource)
Call this member function to set the icon for the Main Instruction area of the task dialog.
void | SetUseSysIcons (BOOL bUseSysIcons=TRUE)
Call this member function to use system icons.
void | SetUseComCtl32 (BOOL bUseComCtl32=TRUE)
Call this member function to use ComCtl32.dll in Vista to show TaskDialog.
BOOL | SetFooterIcon (HICON hIcon)
Call this member function to set the icon for the Footer area of the task dialog.
BOOL | SetFooterIcon (LPCWSTR pszResource)
Call this member function to set the icon for the Footer area of the task dialog.
void | SetWidth (int cxWidth, BOOL bPixelToDLU=FALSE)
Call this member function to set the width of the task dialog's client area.
void | AddButton (LPCTSTR pszText, int nButtonID)
Call this member function to add a user-defined button to the task dialog's command area.
void | AddRadioButton (LPCTSTR pszText, int nButtonID)
Call this member function to add a user-defined radio button to the task dialog's command area.
void | AddInputBox ()
Call this member function to add a user input box to the task dialog's command area.
void | SetInputBoxText (LPCTSTR lpszInputBoxText)
Call this member function to set the default value for an input box field.
CString | GetInputBoxText () const
Call this member function to get the text entered by a user in an input box field.
void | EnableCommandLinks (BOOL bEnable=TRUE, BOOL bShowIcon=TRUE)
Call this member function to indicate that the buttons specified with AddButton should be displayed as command links (using a standard task dialog glyph) instead of push buttons.
void | EnableHyperlinks (BOOL bEnable=TRUE)
Enables hyperlink processing for the strings specified for the functions SetContent, SetExpandedInformation, and SetFooter.
void | EnableMarkup (BOOL bEnable=TRUE)
Call this method to enable markup for TaskDialog.
void | EnableCancellation (BOOL bEnable=TRUE)
Call this member function to allow dialog cancellation for the task dialog.
void | EnableRelativePosition (BOOL bEnable=TRUE)
Call this member function to position the task dialog relative to the parent window.
void | ShowProgressBar (BOOL bShow, BOOL bMarquee=FALSE)
Call this member function to display a progress bar for the task dialog.
void | EnableRtlLayout (BOOL bEnable=TRUE)
Call this member function to enable right-to-left (RTL) text display for the task dialog.
void | ExpandedByDefault (BOOL bExpanded=TRUE)
Call this member function to display the text specified by the SetExpandedInformation member function when the dialog is initially displayed.
void | ExpandFooterArea (BOOL bExpandFooter=TRUE)
Call this member to display expanded information at the bottom of the task dialog's footer.
void | SetDefaultButton (int nButtonID)
Call this member function to set the default button ID for the task dialog.
void | SetDefaultRadioButton (int nButtonID)
Call this member function to set the default radio button ID for the task dialog.
void | NoDefaultRadioButton (BOOL bNoDefault)
Call this member function to disable default radio button selection.
void | SetVerifyCheckState (BOOL bChecked=TRUE)
Call this member function to set the checked state for the verification checkbox when the dialog is initially displayed.
void | EnableCallbackTimer (BOOL bEnable=TRUE)
Call this member function to enable the callback timer.
void | EnableMinimize (BOOL bEnable)
Call this member function to enable the the task dialog to be minimized.
void | SetCommonButtons (TASKDIALOG_COMMON_BUTTON_FLAGS dwButtons)
Specifies the push buttons displayed in the task dialog.
void | SetCommonButtons (BOOL bOk, BOOL bYes, BOOL bNo, BOOL bCancel, BOOL bRetry, BOOL bClose)
Specifies the push buttons displayed in the task dialog.
virtual INT_PTR | DoModal ()
Call this member function to display the task dialog and return the selected button when done.
INT_PTR | DoModal (BOOL bUseComCtl32)
Call this member function to display the task dialog and return the selected button when done.
BOOL | Create (CWnd *pParentWnd=NULL)
Call this member function to create a modeless task dialog.
int | GetSelectedButtonId () const
Call this member function to retrieve the ID of the button used to close the task dialog.
int | GetSelectedRadioButtonId () const
Call this member function to retrieve the ID of the radio button that was selected when the task dialog was closed.
BOOL | IsVerificiationChecked () const
Call this member function to retrieve the checked state of the verification checkbox when the dialog was closed.
BOOL | ModifyTaskStyle (TASKDIALOG_FLAGS dwRemove, TASKDIALOG_FLAGS dwAdd)
Call this member function to modify the style for the task dialog.
void | ClickButton (int nButtonID)
Call this member function to simulate the action of a button click in the task dialog.
void | ClickRadioButton (int nButtonID)
Call this member function to simulate the action of a radio button click in the task dialog.
void | ClickVerification (BOOL bChecked, BOOL bSetKeyFocus)
Call this member function to simulate the action of clicking the verification checkbox in the task dialog.
void | EnableButton (int nButtonID, BOOL bEnable=TRUE)
Call this member function to enable/disable a push button in the task dialog.
void | EnableRadioButton (int nButtonID, BOOL bEnable=TRUE)
Call this member function to enable/disable a radio button in the task dialog.
void | SetMarqueeProgressBar (BOOL bMarquee=TRUE)
Call this member function to indicate whether the progress bar should be displayed in marquee mode or not.
void | SetProgressBarState (int nState)
Call this member function to set the current state of the progress bar.
void | SetProgressBarRange (WORD wMinRange=0, WORD wMaxRange=100)
Call this member function to set the minimum and maximum values for the progress bar.
void | SetProgressBarPos (int nPosition)
Call this member function to se the current position for the progress bar.
void | StartProgressBarMarquee (BOOL bStartMarquee, DWORD dwMilliSeconds)
Similar to SetMarqueeProgressBar; this member function is used to indicate whether the progress bar should be displayed in marquee mode or not with the ability to determine marquee speed as well.
void | SetButtonElevationRequired (int nButtonID, BOOL bRequired=TRUE)
Call this member function to designate whether a given Task Dialog button or command link should have a User Account Control (UAC) shield icon (whether the action invoked by the button requires elevation).
void | NavigatePage (CXTPTaskDialog &taskDlg)
This member function is used to simulate a wizard style task dialog.
void | ResetContent ()
Call this member function to reset the configuration attributes for the task dialog to the default state.
void | EnableMessageBoxStyle (BOOL bEnable=TRUE)
Enables/disables message box like style for the dialog.
BOOL | CreateFromResource (UINT nIDResource, LPCTSTR lpszDialog)
Call this method to create a dialog from an XML resource.
BOOL | CreateFromResource (HINSTANCE hInstance, UINT nIDResource, LPCTSTR lpszDialog)
Call this method to create a dialog from an XML resource.
BOOL | CreateFromResourceParam (HINSTANCE hInstance, UINT nIDResource, LPCTSTR lpszDialog, LPCTSTR const *rglpsz, int nString)
Call this method to create a dialog from an XML resource.
BOOL | CreateFromResourceParam (CXTPPropExchangeXMLNode *pPX, LPCTSTR const *rglpsz, int nString)
Call this method to create a dialog from an XML resource.

Protected Member Functions

virtual void | OnDialogConstructed ()
This notification is sent by the Task Dialog when the task dialog has been created and before it is displayed.
virtual void | OnDialogDestroyed ()
This notification is sent by the Task Dialog when the task dialog has been destroyed.
virtual void | OnHyperlinkClicked (LPCTSTR pszURL)
This notification is sent by the Task Dialog when a user clicks on a hyperlink in the Task Dialog's content.
virtual void | OnButtonClicked (int nButtonID, BOOL &bCloseDialog)
This notification is sent by the Task Dialog when a user selects a button or command link in the task dialog.
virtual void | OnRadioButtonClicked (int nButtonID)
This notification is sent by the Task Dialog when a user selects a radio button in the task dialog.
virtual void | OnVerificationClicked (BOOL bChecked)
This notification is sent by the Task Dialog when the user clicks on the task dialog's verification check box.
virtual void | OnHelp ()
This notification is sent by the Task Dialog when the user presses F1 on the keyboard while the dialog has focus.
virtual void | OnInputBoxChanged ()
This notification is sent by the Task Dialog when the value of the input box has changed.
virtual void | OnExpandoButtonClicked (BOOL bExpanded)
This notification is sent by the Task Dialog when the user clicks on an expando in the Task Dialog.
virtual void | OnTimer (DWORD dwMilliSeconds, BOOL &bReset)
This notification is sent by the Task Dialog approximately every 200 milliseconds when the EnableCallbackTimer member function has been called.
virtual void | OnNavigated ()
This notification is sent by the Task Dialog when a navigation has occurred.
virtual HRESULT | OnDialogNotify (UINT uNotification, WPARAM wParam, LPARAM lParam)
This virtual method is called when some notification is sent from TaskDialog.

Protected Attributes

int | m_nSelButtonID
ID of the button that was selected when the task dialog was closed.
HWND | m_hwndTaskDialog
Real window handle of TaskDialog.
TASKDIALOGCONFIG | m_config
Structure containing information used to display a task dialog.
CArray< TASKDIALOG_BUTTON, TASKDIALOG_BUTTON & > | m_arrButtons
Array of TASKDIALOG_BUTTON structures containing the definition of the custom buttons that are to be displayed in the dialog.
CArray< TASKDIALOG_BUTTON, TASKDIALOG_BUTTON & > | m_arrRadioButtons
Array of TASKDIALOG_BUTTON structures containing the definition of the custom radio buttons that are to be displayed in the dialog.
BOOL | m_bUseComCtl32
TRUE to use Vista ComCtl32.dll to show task dialog.

Detailed Description

The CXTPTaskDialog class creates, displays, and operates a task dialog.

A task dialog is similar to, while much more flexible than, a basic message box. The task dialog contains application-defined messages, title, verification check box, command links and push buttons, plus any combination of predefined icons and push buttons.

Constructor & Destructor Documentation

◆ CXTPTaskDialog()

CXTPTaskDialog ( CWnd * pWndParent = NULL )

Constructs a CXTPTaskDialog object.

Parameters
pWndParent Pointer to the parent or owner window object.

Member Function Documentation

◆ AddButton()

void AddButton | ( | LPCTSTR | pszText,
 |  | int | nButtonID )

Call this member function to add a user-defined button to the task dialog's command area.

Parameters
pszText | Pointer that references the string to be used to label the button.
nButtonID | Indicates the value to be returned when this button is selected.

The parameter pszText can be either a NULL-terminated string or an integer resource identifier passed to the MAKEINTRESOURCE macro. When using Command Links, you delineate the command from the note by placing a new line character in the string.

See also
OnButtonClicked, EnableCommandLinks, SetDefaultButton, SetCommonButtons, GetSelectedButtonId, ClickButton, EnableButton, SetButtonElevationRequired

◆ AddInputBox()

void AddInputBox ( )

Call this member function to add a user input box to the task dialog's command area.

Call SetInputBoxText to set the default value for an input box field.

See also
SetInputBoxText, GetInputBoxText

◆ AddRadioButton()

void AddRadioButton | ( | LPCTSTR | pszText,
 |  | int | nButtonID )

Call this member function to add a user-defined radio button to the task dialog's command area.

Parameters
pszText | Pointer that references the string to be used to label the radio button.
nButtonID | Indicates the value to be returned when this button is selected.

The parameter pszText can be either a NULL-terminated string or an integer resource identifier passed to the MAKEINTRESOURCE macro.

See also
OnRadioButtonClicked, SetDefaultRadioButton, NoDefaultRadioButton, GetSelectedRadioButtonId, ClickRadioButton, EnableRadioButton

◆ ClickButton()

void ClickButton ( int nButtonID )

Call this member function to simulate the action of a button click in the task dialog.

Parameters
nButtonID Indicates the button ID to be selected.

This member function should only be called from a derived class, and only after the task dialog has been initialized. Example:

class CSimulateClickDlg : public CXTPTaskDialog
{
protected:
   virtual void OnDialogConstructed()
   {
      BOOL bClick = TRUE;
      if (bClick)
      {
         ClickButton(IDCANCEL);
      }
   }
};
See also
AddButton, EnableCommandLinks, SetDefaultButton, SetCommonButtons, GetSelectedButtonId, OnButtonClicked, EnableButton, SetButtonElevationRequired

◆ ClickRadioButton()

void ClickRadioButton ( int nButtonID )

Call this member function to simulate the action of a radio button click in the task dialog.

Parameters
nButtonID Indicates the radio button ID to be selected.

This member function should only be called from a derived class, and only after the task dialog has been initialized. Example:

class CSimulateClickDlg : public CXTPTaskDialog
{
protected:
   virtual void OnDialogConstructed()
   {
      BOOL bClick = TRUE;
      if (bClick)
      {
         ClickRadioButton(100);
      }
   }
};
See also
AddRadioButton, SetDefaultRadioButton, NoDefaultRadioButton, GetSelectedRadioButtonId, OnRadioButtonClicked, EnableRadioButton

◆ ClickVerification()

void ClickVerification | ( | BOOL | bChecked,
 |  | BOOL | bSetKeyFocus )

Call this member function to simulate the action of clicking the verification checkbox in the task dialog.

Parameters
bChecked | TRUE to set the state of the checkbox to be checked, or FALSE to set it to be unchecked.
bSetKeyFocus | TRUE to set the keyboard focus to the checkbox, or FALSE otherwise.

This member function should only be called from a derived class, and only after the task dialog has been initialized. Example:

class CSimulateClickDlg : public CXTPTaskDialog
{
protected:
   virtual void OnDialogConstructed()
   {
      BOOL bClick = TRUE;
      if (bClick)
      {
         ClickVerification(TRUE, FALSE);
      }
   }
};
See also
SetVerificationText, SetVerifyCheckState, IsVerificiationChecked, OnVerificationClicked

◆ Create()

BOOL Create ( CWnd * pParentWnd = NULL )

Call this member function to create a modeless task dialog.

Parameters
pParentWnd Parent Window.
Returns
TRUE if successful, otherwise FALSE.

◆ CreateFromResource() [1/2]

BOOL CreateFromResource | ( | HINSTANCE | hInstance,
 |  | UINT | nIDResource,
 |  | LPCTSTR | lpszDialog )

Call this method to create a dialog from an XML resource.

Parameters
hInstance | Instance of resources.
nIDResource | Resource identifier.
lpszDialog | Dialog XML section.
Returns
TRUE if successful, otherwise FALSE.

◆ CreateFromResource() [2/2]

BOOL CreateFromResource | ( | UINT | nIDResource,
 |  | LPCTSTR | lpszDialog )

Call this method to create a dialog from an XML resource.

Parameters
nIDResource | Resource identifier.
lpszDialog | Dialog XML section.
Returns
TRUE if successful, otherwise FALSE.

◆ CreateFromResourceParam() [1/2]

BOOL CreateFromResourceParam | ( | CXTPPropExchangeXMLNode * | pPX,
 |  | LPCTSTR const * | rglpsz,
 |  | int | nString )

Call this method to create a dialog from an XML resource.

Parameters
pPX | CXTPPropExchangeXMLNode node.
rglpsz | Array of strings that will be replaced with XML strings.
nString | Number of parameter strings.
Returns
TRUE if successful, otherwise FALSE.

◆ CreateFromResourceParam() [2/2]

BOOL CreateFromResourceParam | ( | HINSTANCE | hInstance,
 |  | UINT | nIDResource,
 |  | LPCTSTR | lpszDialog,
 |  | LPCTSTR const * | rglpsz,
 |  | int | nString )

Call this method to create a dialog from an XML resource.

Parameters
hInstance | Instance of resources.
nIDResource | Resource identifier.
lpszDialog | Dialog XML section.
rglpsz | Array of strings that will be replaced with XML strings.
nString | Number of parameter strings.
Returns
TRUE if successful, otherwise FALSE.

◆ DoModal() [1/2]

virtual INT_PTR DoModal ( )
virtual

Call this member function to display the task dialog and return the selected button when done.

Returns
The return value is one of the button IDs specified in the AddButton member function or one of the following values:

0: Function call failed. IDCANCEL: Cancel button was selected, Alt-F4 was pressed, Escape was pressed, or the user clicked on the close window button. IDNO: No button was selected. IDOK: OK button was selected. IDRETRY: Retry button was selected. IDYES: Yes button was selected. Example:

CXTPTaskDialog taskDlg(this);
taskDlg.AddButton(_T("Change password"), IDOK);
taskDlg.SetCommonButtons(TDCBF_CANCEL_BUTTON);
taskDlg.SetMainIcon(TD_WARNING_ICON);
taskDlg.SetMainInstruction(_T("Change Password"));
taskDlg.SetContent(_T("Remember your changed password."));

int nRet = taskDlg.DoModal();
switch (nRet)
{
   case 0:
      AfxMessageBox(_T("Task Dialog could not be created!"));
      break;
   case IDOK:
      // the user pressed the OK button, change password.
      break;
   case IDCANCEL:
      // user canceled the dialog.
      break;
};

◆ DoModal() [2/2]

INT_PTR DoModal ( BOOL bUseComCtl32 )

Call this member function to display the task dialog and return the selected button when done.

Parameters
bUseComCtl32 TRUE to use the ComCtl32.dll version of Task Dialog. This parameter is ignored for operating systems older than Windows Vista.
Returns
The return value is one of the button IDs specified in the AddButton member function or one of the following values:

0: Function call failed. IDCANCEL: Cancel button was selected, Alt-F4 was pressed, Escape was pressed, or the user clicked on the close window button. IDNO: No button was selected. IDOK: OK button was selected. IDRETRY: Retry button was selected. IDYES: Yes button was selected. Example:

CXTPTaskDialog taskDlg(this);
taskDlg.AddButton(_T("Change password"), IDOK);
taskDlg.SetCommonButtons(TDCBF_CANCEL_BUTTON);
taskDlg.SetMainIcon(TD_WARNING_ICON);
taskDlg.SetMainInstruction(_T("Change Password"));
taskDlg.SetContent(_T("Remember your changed password."));

int nRet = taskDlg.DoModal();
switch (nRet)
{
   case 0:
      AfxMessageBox(_T("Task Dialog could not be created!"));
      break;
   case IDOK:
      // the user pressed the OK button, change password.
      break;
   case IDCANCEL:
      // user canceled the dialog.
      break;
};

◆ EnableButton()

void EnableButton | ( | int | nButtonID,
 |  | BOOL | bEnable = TRUE )

Call this member function to enable/disable a push button in the task dialog.

Parameters
nButtonID | Indicates the ID of the push button to be enabled/disabled.
bEnable | TRUE to enable the button, FALSE to disable the button.

This member function should only be called from a derived class, and only after the task dialog has been initialized. Example:

class CEnableButtonDlg : public CXTPTaskDialog
{
   protected:
      virtual void OnDialogConstructed()
      {
         EnableButton(IDOK, FALSE);
      }
};
See also
AddButton, EnableCommandLinks, SetDefaultButton, SetCommonButtons, GetSelectedButtonId, ClickButton, OnButtonClicked, SetButtonElevationRequired

◆ EnableCallbackTimer()

void EnableCallbackTimer ( BOOL bEnable = TRUE )

Call this member function to enable the callback timer.

Parameters
bEnable TRUE indicates that the task dialog's callback should be called approximately every 200 milliseconds.
See also
OnTimer, ModifyTaskStyle

◆ EnableCancellation()

void EnableCancellation ( BOOL bEnable = TRUE )

Call this member function to allow dialog cancellation for the task dialog.

Parameters
bEnable TRUE to allow dialog cancellation, otherwise FALSE.

When bAllow is TRUE, this indicates that the dialog should be able to be closed using Alt-F4, Escape, and the title bar's close button even if no cancel button is specified by the SetCommonButtons or AddButton member functions.

See also
SetWidth, SetWindowTitle, EnableRelativePosition, EnableRtlLayout, EnableMinimize, OnDialogConstructed

◆ EnableCommandLinks()

void EnableCommandLinks | ( | BOOL | bEnable = TRUE,
 |  | BOOL | bShowIcon = TRUE )

Call this member function to indicate that the buttons specified with AddButton should be displayed as command links (using a standard task dialog glyph) instead of push buttons.

This function is ignored if AddButton has not been called.

Parameters
bEnable | TRUE to enable command links, FALSE to disable.
bShowIcon | TRUE if the command links should display a glyph.

When using command links, all characters up to the first new line character in AddButton's pszText argument will be treated as the command link's main text, and the remainder will be treated as the command link's note.

See also
AddButton, OnButtonClicked, SetDefaultButton, SetCommonButtons, GetSelectedButtonId, ClickButton, EnableButton, SetButtonElevationRequired

◆ EnableHyperlinks()

void EnableHyperlinks ( BOOL bEnable = TRUE )

Enables hyperlink processing for the strings specified for the functions SetContent, SetExpandedInformation, and SetFooter.

Parameters
bEnable TRUE to enable hyperlinks, FALSE to disable.

When enabled, Content, Expanded Information, and Footer strings can contain hyperlinks in the form:

<a href="executablestring">Hyperlink Text</a>.
See also
SetContent, SetExpandedInformation, SetFooter, OnHyperlinkClicked

◆ EnableMarkup()

void EnableMarkup ( BOOL bEnable = TRUE )

Call this method to enable markup for TaskDialog.

Parameters
bEnable TRUE to enable markup.

◆ EnableMessageBoxStyle()

void EnableMessageBoxStyle ( BOOL bEnable = TRUE )

Enables/disables message box like style for the dialog.

If enabled, then the background, fonts, and buttons' appearance will match the system message box apperance.

Parameters
bEnable TRUE to enable the style, FALSE to disable.

◆ EnableMinimize()

void EnableMinimize ( BOOL bEnable )

Call this member function to enable the the task dialog to be minimized.

Parameters
bEnable TRUE indicates that the task dialog's title bar and system menu contain the minimize command.
See also
SetWidth, EnableCancellation, EnableRelativePosition, EnableRtlLayout, SetWindowTitle, OnDialogConstructed

◆ EnableRadioButton()

void EnableRadioButton | ( | int | nButtonID,
 |  | BOOL | bEnable = TRUE )

Call this member function to enable/disable a radio button in the task dialog.

Parameters
nButtonID | Indicates the ID of the radio button to be enabled/disabled.
bEnable | TRUE to enable the radio button, FALSE to disable the radio button.

This member function should only be called from a derived class, and only after the task dialog has been initialized. Example:

class CEnableRadioButtonDlg : public CXTPTaskDialog
{
   protected:
      virtual void OnDialogConstructed()
      {
         EnableRadioButton(100, FALSE);
      }
};
See also
AddRadioButton, SetDefaultRadioButton, NoDefaultRadioButton, GetSelectedRadioButtonId, ClickRadioButton, OnRadioButtonClicked

◆ EnableRelativePosition()

void EnableRelativePosition ( BOOL bEnable = TRUE )

Call this member function to position the task dialog relative to the parent window.

Parameters
bEnable TRUE to reposition the task dialog, otherwise FALSE.

When bEnable is TRUE, this indicates that the task dialog should be positioned (centered) relative to the window specified by the hWndParent argument in the DoModal member function. If bEnable is FALSE, or hWndParent is NULL, then the task dialog is positioned (centered) relative to the monitor.

See also
SetWidth, EnableCancellation, SetWindowTitle, EnableRtlLayout, EnableMinimize, OnDialogConstructed

◆ EnableRtlLayout()

void EnableRtlLayout ( BOOL bEnable = TRUE )

Call this member function to enable right-to-left (RTL) text display for the task dialog.

Parameters
bEnable TRUE indicates that text should be displayed reading right-to-left (RTL).
See also
SetWidth, EnableCancellation, EnableRelativePosition, SetWindowTitle, EnableMinimize, OnDialogConstructed

◆ ExpandedByDefault()

void ExpandedByDefault ( BOOL bExpanded = TRUE )

Call this member function to display the text specified by the SetExpandedInformation member function when the dialog is initially displayed.

This function is ignored if the SetExpandedInformation member function has not been called.

Parameters
bExpanded TRUE indicates that the string specified by the SetExpandedInformation member function should be displayed when the dialog is initially displayed.
See also
SetCollapsedControlText, SetExpandedInformation, SetExpandedControlText, ExpandFooterArea, OnExpandoButtonClicked

◆ ExpandFooterArea()

void ExpandFooterArea ( BOOL bExpandFooter = TRUE )

Call this member to display expanded information at the bottom of the task dialog's footer.

This function is ignored if the SetExpandedInformation member function has not been called.

Parameters
bExpandFooter TRUE indicates that the string specified by the SetExpandedInformation member should be displayed at the bottom of the dialog's footer area instead of immediately after the dialog's content.
See also
SetCollapsedControlText, SetExpandedInformation, ExpandedByDefault, SetExpandedControlText, OnExpandoButtonClicked

◆ GetInputBoxText()

CString GetInputBoxText ( ) const

Call this member function to get the text entered by a user in an input box field.

Call AddInputBox to add a user input box to the task dialog's command area.

Returns
Returns the text entered by a user in an input box field
See also
AddInputBox, SetInputBoxText

◆ GetSelectedButtonId()

int GetSelectedButtonId ( ) const

Call this member function to retrieve the ID of the button used to close the task dialog.

Returns
The return value is one of the button IDs specified in the AddButton member function or one of the following values:

0: Function call failed. IDCANCEL: Cancel button was selected, Alt-F4 was pressed, Escape was pressed, or the user clicked on the close window button. IDNO: No button was selected. IDOK: OK button was selected. IDRETRY: Retry button was selected. IDYES: Yes button was selected.

See also
AddButton, EnableCommandLinks, SetDefaultButton, SetCommonButtons, OnButtonClicked, ClickButton, EnableButton, SetButtonElevationRequired

◆ GetSelectedRadioButtonId()

int GetSelectedRadioButtonId ( ) const

Call this member function to retrieve the ID of the radio button that was selected when the task dialog was closed.

Returns
The return value is one of the button IDs specified in the AddRadioButton member function.
See also
AddRadioButton, SetDefaultRadioButton, NoDefaultRadioButton, OnRadioButtonClicked, ClickRadioButton, EnableRadioButton

◆ IsVerificiationChecked()

BOOL IsVerificiationChecked ( ) const

Call this member function to retrieve the checked state of the verification checkbox when the dialog was closed.

Returns
TRUE if the verification check box was checked when the task dialog was closed, otherwise FALSE.
See also
SetVerificationText, SetVerifyCheckState, OnVerificationClicked, ClickVerification

◆ ModifyTaskStyle()

BOOL ModifyTaskStyle | ( | TASKDIALOG_FLAGS | dwRemove,
 |  | TASKDIALOG_FLAGS | dwAdd )

Call this member function to modify the style for the task dialog.

Parameters
dwRemove | Specifies the styles to be removed.
dwAdd | Specifies the styles to be added.

Styles to be added or removed can be combined by using the bitwise OR (|) operator. The style can be any combination of the following values:

TDF_ENABLE_HYPERLINKS: See EnableHyperlinks. TDF_USE_HICON_MAIN: See SetMainIcon. TDF_USE_HICON_FOOTER: See SetFooterIcon. TDF_ALLOW_DIALOG_CANCELLATION: See EnableCancellation. TDF_USE_COMMAND_LINKS: See EnableCommandLinks. TDF_USE_COMMAND_LINKS_NO_ICON: See EnableCommandLinks. TDF_EXPAND_FOOTER_AREA: See ExpandFooterArea. TDF_EXPANDED_BY_DEFAULT: See ExpandedByDefault. TDF_VERIFICATION_FLAG_CHECKED: See SetVerifyCheckState. TDF_SHOW_PROGRESS_BAR: See ShowProgressBar. TDF_SHOW_MARQUEE_PROGRESS_BAR: See ShowProgressBar. TDF_CALLBACK_TIMER: See EnableCallbackTimer. TDF_POSITION_RELATIVE_TO_WINDOW: See EnableRelativePosition. TDF_RTL_LAYOUT: See EnableRtlLayout. TDF_NO_DEFAULT_RADIO_BUTTON: See NoDefaultRadioButton. TDF_CAN_BE_MINIMIZED: See EnableMinimize.

Returns
TRUE if style was successfully modified, otherwise FALSE.

◆ NavigatePage()

void NavigatePage ( CXTPTaskDialog & taskDlg )

This member function is used to simulate a wizard style task dialog.

By using multiple CXTPTaskDialog objects that define the aspects of each page, you can incorporate Back and Next buttons that can be used to update the appearance and behavior of the task dialog.

Parameters
taskDlg Reference to a CXTPTaskDialog object that contains attributes for the appearance and behavior of the new task page.

This member function should only be called from a derived class, and only after the task dialog has been initialized. Example:

class CNavigateDlg : public CXTPTaskDialog
{
   CXTPTaskDialog m_dlgBack;
   CXTPTaskDialog m_dlgNext;
   protected:
      void OnButtonClicked(int nButtonID, BOOL& bCloseDialog)
      {
         switch (nButtonID)
         {
         case IDBACK:
            NavigatePage(m_dlgBack);
            bCloseDialog = FALSE;
            break;
         case IDNEXT:
            NavigatePage(m_dlgNext);
            bCloseDialog = FALSE;
            break;
         }
      }
};
See also
OnNavigated

◆ NoDefaultRadioButton()

void NoDefaultRadioButton ( BOOL bNoDefault )

Call this member function to disable default radio button selection.

Parameters
bNoDefault TRUE indicates that no default item will be selected.
See also
AddRadioButton, SetDefaultRadioButton, OnRadioButtonClicked, GetSelectedRadioButtonId, ClickRadioButton, EnableRadioButton

◆ OnButtonClicked()

virtual void OnButtonClicked | ( | int | nButtonID,
 |  | BOOL & | bCloseDialog )
 protectedvirtual

This notification is sent by the Task Dialog when a user selects a button or command link in the task dialog.

Parameters
nButtonID | The ID corresponding to the button selected.
bCloseDialog | Set to TRUE if the task dialog should close.
See also
AddButton, EnableCommandLinks, SetDefaultButton, SetCommonButtons, GetSelectedButtonId, ClickButton, EnableButton, SetButtonElevationRequired

◆ OnDialogConstructed()

virtual void OnDialogConstructed ( )
protectedvirtual

This notification is sent by the Task Dialog when the task dialog has been created and before it is displayed.

See also
SetWidth, EnableCancellation, EnableRelativePosition, EnableRtlLayout, EnableMinimize, SetWindowTitle

◆ OnDialogDestroyed()

virtual void OnDialogDestroyed ( )
protectedvirtual

This notification is sent by the Task Dialog when the task dialog has been destroyed.

See also
OnDialogConstructed

◆ OnDialogNotify()

virtual HRESULT OnDialogNotify | ( | UINT | uNotification,
 |  | WPARAM | wParam,
 |  | LPARAM | lParam )
 protectedvirtual

This virtual method is called when some notification is sent from TaskDialog.

Parameters
uNotification | Notification identifier.
wParam | Extended parameter of notification.
lParam | Extended parameter of notification.
Returns
S_OK if successful.
See also
OnDialogConstructed, OnNavigated, OnButtonClicked, OnHyperlinkClicked, OnTimer, OnRadioButtonClicked, OnVerificationClicked, OnExpandoButtonClicked

◆ OnExpandoButtonClicked()

virtual void OnExpandoButtonClicked ( BOOL bExpanded )
protectedvirtual

This notification is sent by the Task Dialog when the user clicks on an expando in the Task Dialog.

Parameters
bExpanded TRUE if the dialog is expanded, otherwise FALSE.
See also
SetCollapsedControlText, SetExpandedInformation, ExpandedByDefault, ExpandFooterArea, SetExpandedControlText

◆ OnHyperlinkClicked()

virtual void OnHyperlinkClicked ( LPCTSTR pszURL )
protectedvirtual

This notification is sent by the Task Dialog when a user clicks on a hyperlink in the Task Dialog's content.

Parameters
pszURL Pointer to a wide-character string containing the URL of the hyperlink.
See also
SetContent, SetExpandedInformation, SetFooter, EnableHyperlinks

◆ OnNavigated()

virtual void OnNavigated ( )
protectedvirtual

This notification is sent by the Task Dialog when a navigation has occurred.

See also
NavigatePage

◆ OnRadioButtonClicked()

virtual void OnRadioButtonClicked ( int nButtonID )
protectedvirtual

This notification is sent by the Task Dialog when a user selects a radio button in the task dialog.

Parameters
nButtonID The ID corresponding to the radio button that was clicked.
See also
AddRadioButton, SetDefaultRadioButton, NoDefaultRadioButton, GetSelectedRadioButtonId, ClickRadioButton, EnableRadioButton

◆ OnTimer()

virtual void OnTimer | ( | DWORD | dwMilliSeconds,
 |  | BOOL & | bReset )
 protectedvirtual

This notification is sent by the Task Dialog approximately every 200 milliseconds when the EnableCallbackTimer member function has been called.

Parameters
dwMilliSeconds | Number of milliseconds since the dialog was created or bReset was set to TRUE.
bReset | TRUE to reset the tickcount, otherwise the tickcount will continue to increment.
See also
EnableCallbackTimer, ModifyTaskStyle

◆ OnVerificationClicked()

virtual void OnVerificationClicked ( BOOL bChecked )
protectedvirtual

This notification is sent by the Task Dialog when the user clicks on the task dialog's verification check box.

Parameters
bChecked TRUE if the verification checkbox is checked, otherwise FALSE.
See also
SetVerificationText, SetVerifyCheckState, IsVerificiationChecked, ClickVerification

◆ SetButtonElevationRequired()

void SetButtonElevationRequired | ( | int | nButtonID,
 |  | BOOL | bRequired = TRUE )

Call this member function to designate whether a given Task Dialog button or command link should have a User Account Control (UAC) shield icon (whether the action invoked by the button requires elevation).

Parameters
nButtonID | Indicates ID of the push button or command link to be updated.
bRequired | TRUE to designate that the action invoked by the button requires elevation, FALSE to designate that the action invoked by the button does not require elevation.

This member function should only be called from a derived class, and only after the task dialog has been initialized. Example:

class CElevationDlg : public CXTPTaskDialog
{
   protected:
   void OnButtonClicked(int nButtonID, BOOL& bCloseDialog)
   {
      switch (nButtonID)
      {
      case IDOK:
         SetButtonElevationRequired(nButtonID, TRUE);
         bCloseDialog = FALSE;
         break;
      case IDCANCEL:
         SetButtonElevationRequired(nButtonID, FALSE);
         bCloseDialog = TRUE;
         break;
      }
   }
};
See also
AddButton, EnableCommandLinks, SetDefaultButton, SetCommonButtons, GetSelectedButtonId, ClickButton, EnableButton, OnButtonClicked

◆ SetCollapsedControlText()

void SetCollapsedControlText ( LPCTSTR pszText )

Call this member function to set the collapsed control text for the task dialog.

This function is ignored unless SetExpandedInformation has been called.

Parameters
pszText Pointer that references the string to be used to label the button for expanding the expandable information.

The parameter pszText can be either a NULL-terminated string or an integer resource identifier passed to the MAKEINTRESOURCE macro. If this parameter is NULL, then the value set with SetExpandedControlText will be used for the collapsed control text as well.

See also
SetExpandedControlText, SetExpandedInformation, ExpandedByDefault, ExpandFooterArea, OnExpandoButtonClicked

◆ SetCommonButtons() [1/2]

void SetCommonButtons | ( | BOOL | bOk,
 |  | BOOL | bYes,
 |  | BOOL | bNo,
 |  | BOOL | bCancel,
 |  | BOOL | bRetry,
 |  | BOOL | bClose )

Specifies the push buttons displayed in the task dialog.

If no common buttons are specified and no custom buttons are specified using the AddButton member function, then the task dialog will contain the OK button by default.

Parameters
bOk | TRUE if the task dialog contains the OK push button.
bYes | TRUE if the task dialog contains the Yes push button.
bNo | TRUE if the task dialog contains the No push button.
bCancel | TRUE if the task dialog contains the Cancel push button.
bRetry | TRUE if the task dialog contains the Retry push button.
bClose | TRUE if the task dialog contains the Close push button.

Any of the following flags can be used with the dwButtons parameter:

TDCBF_OK_BUTTON: The task dialog contains the OK push button. TDCBF_YES_BUTTON: The task dialog contains the Yes push button. TDCBF_NO_BUTTON: The task dialog contains the No push button. TDCBF_CANCEL_BUTTON: The task dialog contains the Cancel push button. TDCBF_RETRY_BUTTON The task dialog contains the Retry push button. TDCBF_CLOSE_BUTTON: The task dialog contains the Close push button.

If the Cancel button is specified, then the task dialog will respond to typical cancel actions (Alt-F4 and Escape).

See also
AddButton, EnableCommandLinks, SetDefaultButton, OnButtonClicked, GetSelectedButtonId, ClickButton, EnableButton, SetButtonElevationRequired

◆ SetCommonButtons() [2/2]

void SetCommonButtons ( TASKDIALOG_COMMON_BUTTON_FLAGS dwButtons )

Specifies the push buttons displayed in the task dialog.

If no common buttons are specified and no custom buttons are specified using the AddButton member function, then the task dialog will contain the OK button by default.

Parameters
dwButtons Can be any combination of the flags listed in the remarks section.

Any of the following flags can be used with the dwButtons parameter:

TDCBF_OK_BUTTON: The task dialog contains the OK push button. TDCBF_YES_BUTTON: The task dialog contains the Yes push button. TDCBF_NO_BUTTON: The task dialog contains the No push button. TDCBF_CANCEL_BUTTON: The task dialog contains the Cancel push button. TDCBF_RETRY_BUTTON The task dialog contains the Retry push button. TDCBF_CLOSE_BUTTON: The task dialog contains the Close push button.

If the Cancel button is specified, then the task dialog will respond to typical cancel actions (Alt-F4 and Escape).

See also
AddButton, EnableCommandLinks, SetDefaultButton, OnButtonClicked, GetSelectedButtonId, ClickButton, EnableButton, SetButtonElevationRequired

◆ SetContent()

BOOL SetContent ( LPCTSTR pszText )

Call this member function to set the content text for the task dialog.

Parameters
pszText Pointer that references the string to be used for the dialog's primary content.

The parameter pszText can be either a NULL-terminated string or an integer resource identifier passed to the MAKEINTRESOURCE macro. If EnableHyperlinks has been called, then this string may contain hyperlinks in the form:

<a href="executablestring">Hyperlink Text</a>.
Returns
TRUE if successful, otherwise FALSE.
See also
OnHyperlinkClicked, SetExpandedInformation, SetFooter, EnableHyperlinks

◆ SetDefaultButton()

void SetDefaultButton ( int nButtonID )

Call this member function to set the default button ID for the task dialog.

Parameters
nButtonID Indicates the default button for the dialog.

nButtonID may be any of the values specified when calling the AddButton member function, or one of the IDs corresponding to the buttons specified in the SetCommonButtons member function:

IDCANCEL: Make the Cancel button the default. IDNO: Make the No button the default. IDOK: Make the OK button the default. IDRETRY: Make the Retry button the default. IDYES: Make the Yes button the default. IDCLOSE: Make the Close button the default.

If this member is zero or its value does not correspond to any button ID in the dialog, then the first button in the dialog will be the default.

See also
AddButton, EnableCommandLinks, OnButtonClicked, SetCommonButtons, GetSelectedButtonId, ClickButton, EnableButton, SetButtonElevationRequired

◆ SetDefaultRadioButton()

void SetDefaultRadioButton ( int nButtonID )

Call this member function to set the default radio button ID for the task dialog.

Parameters
nButtonID Indicates the default radio button for the dialog.

nButtonID may be any of the values specified when calling the AddRadioButton member function. If this member is zero or its value does not correspond to any radio button ID in the dialog, then the first button in the dialog will be the default.

See also
AddRadioButton, OnRadioButtonClicked, NoDefaultRadioButton, GetSelectedRadioButtonId, ClickRadioButton, EnableRadioButton

◆ SetExpandedControlText()

void SetExpandedControlText ( LPCTSTR pszText )

Call this member function to set the expanded control text for the task dialog.

This function is ignored unless SetExpandedInformation has been called.

Parameters
pszText Pointer that references the string to be used to label the button for collapsing the expandable information.

The parameter pszText can be either a NULL-terminated string or an integer resource identifier passed to the MAKEINTRESOURCE macro. If this parameter is NULL, then the value set with SetCollapsedControlText will be used for the expanded control text as well.

See also
SetCollapsedControlText, SetExpandedInformation, ExpandedByDefault, ExpandFooterArea, OnExpandoButtonClicked

◆ SetExpandedInformation()

BOOL SetExpandedInformation ( LPCTSTR pszText )

Call this member function to set the expanded information text for the task dialog.

Parameters
pszText Pointer that references the string to be used for displaying additional information.

The parameter pszText can be either a NULL-terminated string or an integer resource identifier passed to the MAKEINTRESOURCE macro. The additional information is displayed either immediately below the content or below the footer text depending on whether ExpandFooterArea has been calle d. If EnableHyperlinks has been called, then this string may contain hyperlinks in the form:

<a href="executablestring">Hyperlink Text</a>.
Returns
TRUE if successful, otherwise FALSE.
See also
SetCollapsedControlText, SetExpandedControlText, ExpandedByDefault, ExpandFooterArea, OnExpandoButtonClicked, SetContent, OnHyperlinkClicked, SetFooter, EnableHyperlinks

◆ SetFooter()

BOOL SetFooter ( LPCTSTR pszText )

Call this member function to set the footer text for the task dialog.

Parameters
pszText Pointer that references the string to be used in the footer area of the task dialog.

The parameter pszText can be either a NULL-terminated string or an integer resource identifier passed to the MAKEINTRESOURCE macro. If EnableHyperlinks has been called, then this string may contain hyperlinks in the form:

<a href="executablestring">Hyperlink Text</a>.
Returns
TRUE if successful, otherwise FALSE.
See also
SetContent, SetExpandedInformation, OnHyperlinkClicked, EnableHyperlinks

◆ SetFooterIcon() [1/2]

BOOL SetFooterIcon ( HICON hIcon )

Call this member function to set the icon for the Footer area of the task dialog.

Parameters
hIcon A handle to an Icon that is to be displayed in the task dialog footer area. If this member is NULL, then no icon will be displayed.

The parameter pszResource must be an integer resource identifier passed to the MAKEINTRESOURCE macro, or one of the following predefined values:

TD_ERROR_ICON: A stop-sign icon appears in the task dialog. TD_WARNING_ICON: An exclamation-point icon appears in the task dialog. TD_INFORMATION_ICON: An icon consisting of a lowercase letter i in a circle appears in the task dialog. TD_SHIELD_ICON: A shield icon appears in the task dialog.

Returns
TRUE if successful, otherwise FALSE.

◆ SetFooterIcon() [2/2]

BOOL SetFooterIcon ( LPCWSTR pszResource )

Call this member function to set the icon for the Footer area of the task dialog.

Parameters
pszResource Pointer that references the icon to be displayed in the task dialog footer area. If this parameter is NULL, then no icon will be displayed.

The parameter pszResource must be an integer resource identifier passed to the MAKEINTRESOURCE macro, or one of the following predefined values:

TD_ERROR_ICON: A stop-sign icon appears in the task dialog. TD_WARNING_ICON: An exclamation-point icon appears in the task dialog. TD_INFORMATION_ICON: An icon consisting of a lowercase letter i in a circle appears in the task dialog. TD_SHIELD_ICON: A shield icon appears in the task dialog.

Returns
TRUE if successful, otherwise FALSE.

◆ SetInputBoxText()

void SetInputBoxText ( LPCTSTR lpszInputBoxText )

Call this member function to set the default value for an input box field.

Parameters
lpszInputBoxText Text to display in the input box.

Call AddInputBox to add a user input box to the task dialog's command area.

See also
AddInputBox, GetInputBoxText

◆ SetMainIcon() [1/2]

BOOL SetMainIcon ( HICON hIcon )

Call this member function to set the icon for the Main Instruction area of the task dialog.

Parameters
hIcon A handle to an Icon that is to be displayed in the task dialog Main Instruction area. If this member is NULL, then no icon will be displayed.

The parameter pszResource must be an integer resource identifier passed to the MAKEINTRESOURCE macro, or one of the following predefined values:

TD_ERROR_ICON: A stop-sign icon appears in the task dialog. TD_WARNING_ICON: An exclamation-point icon appears in the task dialog. TD_INFORMATION_ICON: An icon consisting of a lowercase letter i in a circle appears in the task dialog. TD_SHIELD_ICON: A shield icon appears in the task dialog.

Returns
TRUE if successful, otherwise FALSE.

◆ SetMainIcon() [2/2]

BOOL SetMainIcon ( LPCWSTR pszResource )

Call this member function to set the icon for the Main Instruction area of the task dialog.

Parameters
pszResource Pointer that references the icon to be displayed in the task dialog footer area. If this parameter is NULL, then no icon will be displayed.

The parameter pszResource must be an integer resource identifier passed to the MAKEINTRESOURCE macro, or one of the following predefined values:

TD_ERROR_ICON: A stop-sign icon appears in the task dialog. TD_WARNING_ICON: An exclamation-point icon appears in the task dialog. TD_INFORMATION_ICON: An icon consisting of a lowercase letter i in a circle appears in the task dialog. TD_SHIELD_ICON: A shield icon appears in the task dialog.

Returns
TRUE if successful, otherwise FALSE.

◆ SetMainInstruction()

BOOL SetMainInstruction ( LPCTSTR pszText )

Call this member function to set the main instruction text for the task dialog.

Parameters
pszText Pointer that references the string to be used for the main instruction.

The parameter pszText can be either a NULL-terminated string or an integer resource identifier passed to the MAKEINTRESOURCE macro.

Returns
TRUE if successful, otherwise FALSE.

◆ SetMarqueeProgressBar()

void SetMarqueeProgressBar ( BOOL bMarquee = TRUE )

Call this member function to indicate whether the progress bar should be displayed in marquee mode or not.

Parameters
bMarquee Specifies whether the progress bar should be shown in Marquee mode. A value of TRUE turns on Marquee mode.

This member function should only be called from a derived class, and only after the task dialog has been initialized. Example:

class CProgressDlg : public CXTPTaskDialog
{
   protected:
      virtual void OnDialogConstructed()
      {
         SetMarqueeProgressBar(TRUE);
         SetProgressBarState(PBST_NORMAL);
      }
};
See also
ShowProgressBar, SetProgressBarState, SetProgressBarRange, SetProgressBarPos, StartProgressBarMarquee

◆ SetProgressBarPos()

void SetProgressBarPos ( int nPosition )

Call this member function to se the current position for the progress bar.

Parameters
nPosition Signed integer that becomes the new position.

This member function should only be called from a derived class, and only after the task dialog has been initialized. Example:

class CProgressDlg : public CXTPTaskDialog
{
   protected:
      virtual void OnDialogConstructed()
      {
         SetProgressBarPos(25);
         SetProgressBarRange(0, 100);
         SetProgressBarState(PBST_PAUSE);
      }
};
See also
SetMarqueeProgressBar, SetProgressBarState, SetProgressBarRange, ShowProgressBar, StartProgressBarMarquee

◆ SetProgressBarRange()

void SetProgressBarRange | ( | WORD | wMinRange = 0,
 |  | WORD | wMaxRange = 100 )

Call this member function to set the minimum and maximum values for the progress bar.

Parameters
wMinRange | Minimum range value. By default, the minimum value is zero.
wMaxRange | Maximum range value. By default, the maximum value is 100.

This member function should only be called from a derived class, and only after the task dialog has been initialized. Example:

class CProgressDlg : public CXTPTaskDialog
{
   protected:
      virtual void OnDialogConstructed()
      {
         SetProgressBarPos(25);
         SetProgressBarRange(0, 100);
         SetProgressBarState(PBST_PAUSE);
      }
};
See also
SetMarqueeProgressBar, SetProgressBarState, ShowProgressBar, SetProgressBarPos, StartProgressBarMarquee

◆ SetProgressBarState()

void SetProgressBarState ( int nState )

Call this member function to set the current state of the progress bar.

Parameters
nState Specifies the bar state. The parameter can be one of the following values:

PBST_NORMAL: Sets the progress bar to the normal state. PBST_PAUSE: Sets the progress bar to the paused state. PBST_ERROR: Set the progress bar to the error state.

This member function should only be called from a derived class, and only after the task dialog has been initialized. Example:

class CProgressDlg : public CXTPTaskDialog
{
   protected:
      virtual void OnDialogConstructed()
      {
         SetProgressBarPos(25);
         SetProgressBarRange(0, 100);
         SetProgressBarState(PBST_PAUSE);
      }
};
See also
SetMarqueeProgressBar, ShowProgressBar, SetProgressBarRange, SetProgressBarPos, StartProgressBarMarquee

◆ SetUseComCtl32()

void SetUseComCtl32 ( BOOL bUseComCtl32 = TRUE )

Call this member function to use ComCtl32.dll in Vista to show TaskDialog.

Parameters
bUseComCtl32 TRUE to use ComCtl32.dll in Vista to show TaskDialog.

◆ SetUseSysIcons()

void SetUseSysIcons ( BOOL bUseSysIcons = TRUE )

Call this member function to use system icons.

Parameters
bUseSysIcons TRUE to use system icons when available for TD_ERROR_ICON, TD_WARNING_ICON, TD_INFORMATION_ICON and TD_SHIELD_ICON instead of Codejock Software icons. This parameter is ignored when bUseComCtl32 is set to TRUE.

◆ SetVerificationText()

void SetVerificationText ( LPCTSTR pszText )

Call this member function to set the label for the verification checkbox to be displayed in the task dialog.

Parameters
pszText Pointer that references the string to be used to label the verification checkbox.

The parameter pszText can be either a NULL-terminated string or an integer resource identifier passed to the MAKEINTRESOURCE macro. If this parameter is NULL, then the verification checkbox is not displayed in the task dialog.

See also
OnVerificationClicked, SetVerifyCheckState, IsVerificiationChecked, ClickVerification

◆ SetVerifyCheckState()

void SetVerifyCheckState ( BOOL bChecked = TRUE )

Call this member function to set the checked state for the verification checkbox when the dialog is initially displayed.

This function is ignored if the SetVerificationText member function has not been called.

Parameters
bChecked TRUE indicates that the verification checkbox in the dialog should be checked when the dialog is initially displayed.
See also
OnVerificationClicked, OnVerificationClicked, IsVerificiationChecked, ClickVerification

◆ SetWidth()

void SetWidth | ( | int | cxWidth,
 |  | BOOL | bPixelToDLU = FALSE )

Call this member function to set the width of the task dialog's client area.

Parameters
cxWidth | Specifies the width of the task dialog's client area in dialog units. If 0, then task dialog will calculate the ideal width.
bPixelToDLU | TRUE indicates that the size specified by cxWidth are pixel units and need to be converted into dialog units (DLU).
See also
SetWindowTitle, EnableCancellation, EnableRelativePosition, EnableRtlLayout, EnableMinimize, OnDialogConstructed

◆ SetWindowTitle()

void SetWindowTitle ( LPCTSTR pszText )

Call this member function to set the window title for the task dialog.

Parameters
pszText Pointer that references the string to be used for the task dialog title.

The parameter pszText can be either a NULL-terminated string or an integer resource identifier passed to the MAKEINTRESOURCE macro. If this parameter is NULL, then the filename of the executable program is used.

See also
SetWidth, EnableCancellation, EnableRelativePosition, EnableRtlLayout, EnableMinimize, OnDialogConstructed

◆ ShowProgressBar()

void ShowProgressBar | ( | BOOL | bShow,
 |  | BOOL | bMarquee = FALSE )

Call this member function to display a progress bar for the task dialog.

Parameters
bShow | TRUE indicates that a progress bar should be displayed.
bMarquee | TRUE indicates the progress bar should be Marquee style.
See also
SetMarqueeProgressBar, SetProgressBarState, SetProgressBarRange, SetProgressBarPos, StartProgressBarMarquee

◆ StartProgressBarMarquee()

void StartProgressBarMarquee | ( | BOOL | bStartMarquee,
 |  | DWORD | dwMilliSeconds )

Similar to SetMarqueeProgressBar; this member function is used to indicate whether the progress bar should be displayed in marquee mode or not with the ability to determine marquee speed as well.

Parameters
bStartMarquee | Indicates whether to start marquee.
dwMilliSeconds | Indicates the speed of the marquee in milliseconds.

This member function should only be called from a derived class, and only after the task dialog has been initialized. Example:

class CProgressDlg : public CXTPTaskDialog
{
   protected:
      virtual void OnDialogConstructed()
      {
         StartProgressBarMarquee(TRUE, 10);
         SetProgressBarState(PBST_NORMAL);
      }
};
See also
SetMarqueeProgressBar, SetProgressBarState, SetProgressBarRange, SetProgressBarPos, ShowProgressBar
The documentation for this class was generated from the following file:
  • XTPTaskDialog.h


Toolkit Pro: CXTPTaskDialogClient Class Reference

Protected Member Functions | Protected Attributes | List of all members
CXTPTaskDialogClient Class Reference

CXTPTaskDialogClient window. More...

Protected Member Functions

BOOL | MoveButton (CButton *pButton, int xPos, int yPos, int cx, int cy, BOOL bRedraw=FALSE)
Moves a button to the desired location.
BOOL | MoveButton (CButton *pButton, const CRect &rect, BOOL bRedraw=FALSE)
Moves a button to the desired location.

Protected Attributes

int | m_nMaxClientWidth
Maximum client width.
int | m_nMinClientWidth
Minimum client width.
int | m_nPadding
Padding of elements.
BOOL | m_bExpanded
TRUE if Expanded area is is expanded.
BOOL | m_bVerification
TRUE if verification button is checked.
BOOL | m_bUseSysIcons
TRUE to use system icons.
BOOL | m_bThemeReady
TRUE if System theme used.
HICON | m_hIconFooter
Footer icon.
HICON | m_hIconMain
Main instruction icon.
COLORREF | m_crContent
Content background color.
COLORREF | m_crContentText
Content text color.
COLORREF | m_crFooter
Footer color.
COLORREF | m_crFooterText
Footer text color.
COLORREF | m_crMainText
Main instruction text color.
COLORREF | m_cr3DLight
3D Light color.
COLORREF | m_cr3DShadow
3D Shadow color.
COLORREF | m_cr3DHighLight
3D HighLight color.
CXTPFont | m_xtpFont
Content font.
CXTPFont | m_xtpFontLarge
Main instruction font.
CPoint | m_ptMargin
Margin of elements.
CPoint | m_ptPadding
Padding of elements.
CPoint | m_ptBtnSpacing
Space between buttons.
CPoint | m_ptBorder
Border space around dialog.
CSize | m_sizeIconFooter
Size of footer icon.
CSize | m_sizeIconMain
Size of main icon.
CSize | m_sizeCommandButton
Size of push buttons.
CRect | m_rcMainInstruction
Position of Main Instruction.
CRect | m_rcContent
Position of Content Text.
CRect | m_rcCommandButtons
Position of Push buttons.
CRect | m_rcExpandedInformation
Expanded Information.
CRect | m_rcFooter
Position of Footer.
CRect | m_rcRadioButtons
Position of Radio buttons.
CRect | m_rcLinkButtons
Position of Link Buttons.
CStringMarkup | m_strMainInstruction
Main instruction text.
CStringMarkup | m_strContent
Content text.
CStringMarkup | m_strFooter
Footer text.
CStringMarkup | m_strVerificationText
Verification text.
CStringMarkup | m_strExpandedInformation
Expanded text.
CStringMarkup | m_strExpandedControlText
Text for expanded button.
CStringMarkup | m_strCollapsedControlText
Text for collapsed button.
TASKDIALOGCONFIG * | m_pConfig
Pointer to TASKDIALOGCONFIG.
CXTPMarkupContext * | m_pMarkupContext
Markup context.
CButton * | m_pBtnVerify
Verify button pointer.
CXTPButton * | m_pBtnExpando
Expando button pointer.
CXTPTaskDialogLinkCtrl | m_wndContent
Content window.
CXTPTaskDialogLinkCtrl | m_wndExpandedInformation
ExpandedInformation window.
CXTPTaskDialogLinkCtrl | m_wndFooter
Footer window.
CXTPTaskDialogProgressCtrl | m_wndProgressBar
ProgressBar window.
CEdit | m_wndInputBox
InputBox window.
CArray< CButton *, CButton * > | m_arrCommandButtons
Array of push buttons.
CArray< CButton *, CButton * > | m_arrLinkButtons
Array of link buttons.
CArray< CButton *, CButton * > | m_arrRadioButtons
Array of radio buttons.
int | m_nSelRadioButtonID
ID of the radio button that was selected when the task dialog was closed.
CMap< CWnd *, CWnd *, SIZE, SIZE & > | m_mapWndSize
Size map.
BOOL | m_bMessageBoxStyle
TRUE to use extended style.
BOOL | m_bEnableMarkup
TRUE to enable markup.
BOOL | m_bShowInputBox
TRUE to show input box.
CString | m_strInputBoxText
Input box text.

Detailed Description

CXTPTaskDialogClient window.

Member Function Documentation

◆ MoveButton() [1/2]

BOOL MoveButton | ( | CButton * | pButton,
 |  | const CRect & | rect,
 |  | BOOL | bRedraw = FALSE )
 protected

Moves a button to the desired location.

Parameters
pButton | Button to move.
rect | New size/position of the button.
bRedraw | TRUE to redraw the button.
Returns
TRUE if successful, otherwise FALSE.

◆ MoveButton() [2/2]

BOOL MoveButton | ( | CButton * | pButton,
 |  | int | xPos,
 |  | int | yPos,
 |  | int | cx,
 |  | int | cy,
 |  | BOOL | bRedraw = FALSE )
 protected

Moves a button to the desired location.

Parameters
pButton | Button to move.
xPos | New size/position of the button.
yPos | New size/position of the button.
cx | New size/position of the button.
cy | New size/position of the button.
bRedraw | TRUE to redraw the button.
Returns
TRUE if successful, otherwise FALSE.
The documentation for this class was generated from the following file:
  • XTPTaskDialogClient.h


Toolkit Pro: CXTPTaskDialogLinkCtrl Class Reference

Classes | Public Member Functions | Protected Attributes | List of all members
CXTPTaskDialogLinkCtrl Class Reference

CXTPTaskDialogLinkCtrl is a CStatic derived class that is used to display a text block that contains clickable links. More...

Classes

struct LINKITEM
LINKITEM is used to set and retrieve information about a link item. More...

Public Member Functions

CXTPTaskDialogLinkCtrl ()
Constructs a CXTPTaskDialogLinkCtrl object.
virtual | ~CXTPTaskDialogLinkCtrl ()
Destroys a CXTPTaskDialogLinkCtrl object, handles cleanup and deallocation.
virtual BOOL | Create (const CRect &rect, CString &strBuffer, CFont *pFont, CWnd *pParentWnd)
Call this member function to create a CXTPTaskDialogLinkCtrl text control.
LINKITEM * | GetFocusedLink () const
Call this member function to return the focused link.
void | FocusItem (int iFocusItem)
Call this member function to set the focus to a specified link.
LINKITEM * | HitTest (CPoint pt) const
Call this member function to return the link information from the specified cursor position.
DWORD | GetLinkPos (CString strBuffer, int iPos=0)
This member function is called to retrieve the character index of the first link located after the index specified by iPos.
BOOL | ExtractLinks (CString &strBuffer)
This member function is called to extract link information from the specified string buffer and store it internally.
void | SetBackColor (COLORREF crBack)
Call this member function to set the background color for the link control.
COLORREF | GetBackColor () const
Call this member function to retrieve the link control's background color.
void | SetTextColor (COLORREF crText)
Call this member function to set the text color for the link control.
COLORREF | GetTextColor () const
Call this member function to retrieve the link control's text color.
void | SetTextLinkColor (COLORREF crTextLink)
Call this member function to set the text link color for the link control.
COLORREF | GetTextLinkColor () const
Call this member function to retrieve the link control's text link color.

Protected Attributes

int | m_nFocused
Index of the currently focus link.
CXTPFont | m_xtpFontUL
Font used to render link text.
CString | m_strBuffer
Text buffer to be displayed in the control.
HCURSOR | m_hcurHand
Handle to text link cursor.
COLORREF | m_crBack
RGB background color value.
COLORREF | m_crText
RGB text color value.
COLORREF | m_crTextLink
RGB link text color value.
CTaskLinkItemArray | m_arrLinks
Array of links for the display text.

Detailed Description

CXTPTaskDialogLinkCtrl is a CStatic derived class that is used to display a text block that contains clickable links.

Member Function Documentation

◆ Create()

virtual BOOL Create | ( | const CRect & | rect,
 |  | CString & | strBuffer,
 |  | CFont * | pFont,
 |  | CWnd * | pParentWnd )
 virtual

Call this member function to create a CXTPTaskDialogLinkCtrl text control.

The control is used by CXTPTaskDialog to display a static text block that contains clickable link text.

Parameters
rect | Specifies the edit control's size and position. Can be a CRect object or RECT structure.
strBuffer | NULL-terminated string that contains link text to be displayed.
pFont | Specifies the font to be used with the text control.
pParentWnd | Specifies the edit control's parent window (usually a CXTPTaskDialog). It must not be NULL.

When specified strBuffer can contain links in the form:

<CODE><A HREF="executablestring">Hyperlink Text.</A></CODE>
Returns
Nonzero if initialization is successful, otherwise 0.

◆ ExtractLinks()

BOOL ExtractLinks ( CString & strBuffer )

This member function is called to extract link information from the specified string buffer and store it internally.

The string is then reformatted to remove the link tag information.

Parameters
strBuffer NULL-terminated string to search for link text.
Returns
TRUE if link text was located, otherwise FALSE.

◆ FocusItem()

void FocusItem ( int iFocusItem )

Call this member function to set the focus to a specified link.

Parameters
iFocusItem The index of the focused item or -1 to indicate no focus.

◆ GetBackColor()

COLORREF GetBackColor ( ) const

Call this member function to retrieve the link control's background color.

Returns
An RGB value representing the link control's background color.

◆ GetFocusedLink()

LINKITEM * GetFocusedLink ( ) const

Call this member function to return the focused link.

Returns
The pointer of the currently focused link, otherwise NULL.

◆ GetLinkPos()

DWORD GetLinkPos | ( | CString | strBuffer,
 |  | int | iPos = 0 )

This member function is called to retrieve the character index of the first link located after the index specified by iPos.

Parameters
strBuffer | NULL-terminated string to search for link text.
iPos | Starting position to begin search from.
Returns
The LOWORD value contains the starting position of the first link text block found, the HIWORD value contains the number of characters in the link text.

◆ GetTextColor()

COLORREF GetTextColor ( ) const

Call this member function to retrieve the link control's text color.

Returns
An RGB value representing the link control's text color.

◆ GetTextLinkColor()

COLORREF GetTextLinkColor ( ) const

Call this member function to retrieve the link control's text link color.

Returns
An RGB value representing the link control's text link color.

◆ HitTest()

LINKITEM * HitTest ( CPoint pt ) const

Call this member function to return the link information from the specified cursor position.

Parameters
pt Client coordinates.
Returns
A LINKITEM pointer if successful, otherwise NULL.

◆ SetBackColor()

void SetBackColor ( COLORREF crBack )

Call this member function to set the background color for the link control.

Parameters
crBack An RGB value representing the link control's background color.

◆ SetTextColor()

void SetTextColor ( COLORREF crText )

Call this member function to set the text color for the link control.

Parameters
crText An RGB value representing the link control's text color.

◆ SetTextLinkColor()

void SetTextLinkColor ( COLORREF crTextLink )

Call this member function to set the text link color for the link control.

Parameters
crTextLink An RGB value representing the link control's text link color.
The documentation for this class was generated from the following file:
  • XTPTaskDialogControls.h


Toolkit Pro: CXTPTaskDialogLinkCtrl::LINKITEM Struct Reference

  • CXTPTaskDialogLinkCtrl
  • LINKITEM
Public Attributes | List of all members
CXTPTaskDialogLinkCtrl::LINKITEM Struct Reference

LINKITEM is used to set and retrieve information about a link item. More...

Public Attributes

DWORD | nStart
Starting character position.
int | nIndex
Character index of the character nearest the specified point.
CString | strLabel
Specifies the execute string for the link.
CString | strUrl
Specifies the display string for the link.

Detailed Description

LINKITEM is used to set and retrieve information about a link item.

See also
CXTPTaskDialogLinkCtrl::HitTest
The documentation for this struct was generated from the following file:
  • XTPTaskDialogControls.h


Toolkit Pro: CXTPTaskDialogProgressCtrl Class Reference

List of all members
CXTPTaskDialogProgressCtrl Class Reference

CXTPTaskDialogProgressCtrl. More...

Detailed Description

CXTPTaskDialogProgressCtrl.

The documentation for this class was generated from the following file:
  • XTPTaskDialogControls.h


Toolkit Pro: CXTPTaskPanel Class Reference

Classes | Public Member Functions | Static Public Member Functions | Protected Member Functions | Protected Attributes | Static Protected Attributes | List of all members
CXTPTaskPanel Class Reference

CXTPTaskPanel is used to implement an Explorer and Office-like Task Panel control. More...

Inheritance diagram for CXTPTaskPanel:
[legend]

Classes

class CRepositionContext
CRepositionContext is a helper class used to lock/unlock redraw for the Task Panel. More...

Public Member Functions

CXTPTaskPanel ()
Constructs a CXTPTaskPanel object.
virtual | ~CXTPTaskPanel ()
Destroys a CXTPTaskPanel object, handles cleanup and deallocation.
BOOL | Create (DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID)
Creates a Task Panel control.
CXTPTaskPanelItems * | GetGroups () const
Gets the collection of groups of this Task Panel control.
CXTPTaskPanelGroup * | AddGroup (UINT nID, int nImage=-1)
Adds a group to the collection of groups.
CXTPTaskPanelGroup * | FindGroup (UINT nID) const
Retrieves the group with a specified identifier.
CXTPTaskPanelGroupItem * | FindItem (UINT nID) const
Retrieves the group item with a specified identifier.
CXTPTaskPanelGroup * | GetAt (int nIndex) const
Retrieves the group at a specified index in the collection of groups.
int | GetGroupCount () const
Gets the number of groups in the collection of groups.
int | GetScrollOffset () const
Gets the scroll offset.
int | GetClientHeight () const
Gets the height of the client area.
void | Reposition (BOOL bRecalcOnly=TRUE)
Repositions the groups in the Task Panel control.
void | SetHotItem (CXTPTaskPanelItem *pItem)
Sets the "hot" item for the Task Panel control.
CXTPTaskPanelItem * | GetHotItem () const
Gets the "hot" item of the Task Panel control.
virtual void | SetFocusedItem (CXTPTaskPanelItem *pItem, BOOL bDrawFocusRect=FALSE, BOOL bSetFocus=TRUE)
Sets the focused item for the Task Panel control.
void | EnsureVisible (CXTPTaskPanelItem *pItem)
Ensures that a specified item is visible in the Task Panel.
CXTPTaskPanelItem * | GetFocusedItem () const
Gets the focused item of the Task Panel control.
BOOL | IsDrawFocusRect () const
Determines if a focus rectangle is drawn around an item when the Up and Down arrows are used to navigate through items in the Task Panel control.
CXTPTaskPanelGroup * | HitTestGroup (CPoint pt, BOOL *pbCaption=NULL) const
Determines which group, if any, is located at a specified point.
CXTPTaskPanelItem * | HitTestItem (CPoint pt, BOOL bClientAvail=FALSE) const
Determines which item, if any, is located at a specified point.
void | SetMargins (long nLeft, long nTop, long nRight, long nBottom, long nMiddle)
Sets the outer margins for the groups of the Task Panel control.
void | SetImageList (CImageList *pImageList, CSize szItemIcon=CSize(16, 16))
Sets the image list for the Task Panel control.
void | SetGroupImageList (CImageList *pImageList, CSize szGroupIcon=CSize(32, 32))
Sets the image list for the groups of the Task Panel control.
CXTPImageManager * | GetImageManager () const
Gets the image manager associated with the Task Panel control.
void | SetImageManager (CXTPImageManager *pImageManager)
Sets the image manager associated with the Task Panel control.
void | SetExpandable (BOOL bExpandable)
Sets the expandable state for groups.
BOOL | IsExpandable () const
Gets the expandable state of groups.
void | SetAnimation (XTPTaskPanelAnimation panelAnimation)
Sets the animation type for the Task Panel control.
XTPTaskPanelAnimation | GetAnimation () const
Gets the animation type of the Task Panel control.
void | SetLayoutRTL (BOOL bRightToLeft)
Sets right-to-left (RTL) mode.
void | SetLockRedraw (BOOL bLockRedraw)
Locks/unlocks redrawing controls.
CXTPTaskPanelItem * | GetNextItem (CXTPTaskPanelItem *pItem, int nDirection, BOOL bTab, BOOL bSkipRowItems=TRUE) const
Retrieves the next/previous item in the tab order from a specified item.
virtual void | OnClick (CXTPTaskPanelGroupItem *pItem)
This method is called when the user clicks on an item.
BOOL | IsDirty () const
Determines if the group position is "dirty" (i.e.
void | OnScrollChanged (int nCurPos)
This method is called when the scrollbar of the entire Task Panel control is scrolled (i.e.
BOOL | AnimateGroups (BOOL bCheckDirty=TRUE)
This method is called to animate the group(s) when animation is enabled.
CSize | GetItemIconSize () const
Gets the size of item icons in the Task Panel control.
CSize | GetGroupIconSize () const
Gets the size of group icons in the Task Panel control.
void | SetIconSize (CSize szIcon)
Sets the size for item icons in the Task Panel control.
void | SetGroupIconSize (CSize szIcon)
Sets the size for group icons in the Task Panel control.
void | NavigateItems (BOOL bTabItems)
Enables/disables item navigation by using the Tab key.
void | EnableAnimation (BOOL bEnable=TRUE)
Enables/disables animation for the Task Panel control.
void | SetTheme (XTPTaskPanelPaintTheme paintTheme)
Sets the theme for the Task Panel control.
void | SetCustomTheme (CXTPTaskPanelPaintManager *pPaintManager)
Sets a custom theme for the Task Panel control.
CXTPTaskPanelPaintManager * | GetPaintManager () const
Gets the paint manager.
XTPTaskPanelPaintTheme | GetCurrentTheme () const
Gets the theme of the Task Panel control.
CXTPToolTipContext * | GetToolTipContext () const
Gets the tooltip context.
virtual void | ExpandGroup (CXTPTaskPanelGroup *pGroup, BOOL bExpanded)
Expands/collapses a specified group.
BOOL | IsGroupExpanded (const CXTPTaskPanelGroup *pGroup) const
Determines if a specified group is expanded/collapsed.
void | SetHotTrackStyle (XTPTaskPanelHotTrackStyle hotTrackStyle)
Sets the hot tracking style.
XTPTaskPanelHotTrackStyle | GetHotTrackStyle () const
Gets the hot tracking style.
XTPTaskPanelItemLayout | GetItemLayout () const
Gets the item layout.
void | SetItemLayout (XTPTaskPanelItemLayout itemLayout)
Sets the item layout.
void | SetBehaviour (XTPTaskPanelBehaviour panelBehaviour)
Sets the behaviour for the Task Panel control.
XTPTaskPanelBehaviour | GetBehaviour () const
Gets the behaviour of the Task Panel control.
CXTPTaskPanelGroup * | GetActiveGroup () const
Gets the active group.
void | SetSelectItemOnFocus (BOOL bSelect)
Specifies if items should receive focus when they are clicked.
void | SetSingleSelection (BOOL bSingleSelection=TRUE)
Enables/disables single selection.
BOOL | IsSingleSelection () const
Determines if single selection is enabled/disabled.
void | DrawFocusRect (BOOL bAccept)
Draws a focus rectangle around an item/group item when the Up and Down arrows are used to navigate the items in the Task Panel control.
CRect | GetMargins () const
Gets the outer margins of groups in the Task Panel control.
void | AllowDrag (long nAllowDrag=xtpTaskItemAllowDragDefault)
Specifies the drag options for the Task Panel.
void | AllowDrop (BOOL bAllowDrop)
Specifies the drop options for the Task Panel.
void | RenameItem (CXTPTaskPanelItem *pItem)
Renames the caption of a specified item.
CXTPTaskPanelScrollButton * | GetScrollButton (BOOL bScrollUp) const
Retrieves a specified group scroll button.
CXTPTaskPanelScrollButton * | HitTestScrollButton (CPoint point) const
Determines which group scroll button, if any, is located at a specified point.
virtual void | OnDraw (CDC *pDC, CRect rcClipBox)
The framework calls this method to draw the Task Panel control using a specified device context.
void | Redraw (LPCRECT lpRect=NULL, BOOL bAnimate=FALSE)
The framework calls this method to redraw the Task Panel control.
virtual LRESULT | NotifyOwner (WPARAM wParam, LPARAM lParam)
Notifies the parent window that an event has occurred in the Task Panel control.
void | SetMultiColumn (BOOL bMultiColumn)
Enables/disables multi-column groups.
BOOL | IsMultiColumn () const
Determines if multi-column groups is enabled/disabled.
void | SetColumnWidth (int nColumnWidth)
Sets the width, in pixels, for columns in a multi-column Task Panel control.
int | GetColumnWidth () const
Gets the width, in pixels, of columns in a multi-column Task Panel control.
int | GetMinimumGroupClientHeight () const
Gets the minimum client height of all groups.
void | SetMinimumGroupClientHeight (int nMinClientHeight)
Sets the minimum client height for all groups.
BOOL | RegisterWindowClass (HINSTANCE hInstance=NULL)
Registers the window class if it has not already been registered.
void | EnableMarkup (BOOL bEnable=TRUE)
Enables/disables markup for tab captions.
CXTPMarkupContext * | GetMarkupContext () const
Gets the markup context.
- Public Member Functions inherited from CXTPScrollBarContainer< CWnd >
void | SetScrollBarTheme (XTPScrollBarTheme theme)
Sets scroll bar theme.
BOOL | CreateScrollBarCtrl (DWORD dwStyle, UINT nID)
Creates a scroll bar control with ID and style specied.
virtual CScrollBar * | GetScrollBarCtrl (int nBar) const
Call this member function to obtain a pointer to the specified sibling scroll bar or splitter window.
void | ShowScrollBar (UINT nBar, BOOL bShow=TRUE)
Shows or hides a scroll bar.
BOOL | EnableScrollBar (int nSBFlags, UINT nArrowFlags=ESB_ENABLE_BOTH)
Enables or disables one or both arrows of a scroll bar.
void | RefreshScrollBarMetrics ()
Triggers update of color and size information for themed scroll bars.
void | OptimizeChildrenClipping ()
Applies WS_CLIPCHILDREN and WS_CLIPSIBLINGS styles the the container owner and all its immediate children windows in order prevent possible overlapping of children controls with scroll bars.
void | SetScrollBarClass (CRuntimeClass *pClass=NULL)
Sets a scroll bar class to be used for creating scroll bars.

Static Public Member Functions

static CLIPFORMAT AFX_CDECL GetClipboardFormat ()
Gets the clipboard format.

Protected Member Functions

BOOL | IsExplorerBehaviour () const
Determines if the behaviour of the Task Panel control is Explorer behavior.
virtual void | OnStartItemDrag (CXTPTaskPanelGroupItem *pItem)
This method is called when a group item is starting to be dragged.
virtual void | OnStartGroupDrag (CXTPTaskPanelItem *pItem)
This method is called when a group is starting to be dragged.
virtual void | OnEndLabelEdit (CXTPTaskPanelItem *pItem, LPCTSTR str)
This method is called when the caption of an item is finished being edited/renamed.
virtual DROPEFFECT | OnDragOver (COleDataObject *pDataObject, DWORD dwKeyState, CPoint point)
This method is called when an item is dragged over the Task Panel control.
virtual BOOL | OnDrop (COleDataObject *pDataObject, DROPEFFECT dropEffect, CPoint point)
This method is called when an item is dropped into the Task Panel control.
void | RepositionScrollButtons ()
Repositions the group scroll buttons.
void | OnClickScrollButton (CXTPTaskPanelScrollButton *pScrollButton)
The member is called when a group scroll button is clicked.
void | UpdateScrollButtons ()
Updates the enabled/disabled state of the group scroll buttons.
void | CheckScrollButtonMouseOver (CPoint point)
Determines if the mouse cursor is positioned over a group scroll button.
virtual void | OnItemRemoved (CXTPTaskPanelItem *pItem)
This method is called when an item is removed from the Task Panel.
virtual void | UpdateScrollBar ()
Updates the scrollbar of the Task Panel.
virtual void | OnClientHeightChanged ()
This method is called when the client height is changed.
CXTPTaskPanelGroup * | GetNextVisibleGroup (int nIndex, int nDirection=+1) const
Retrieves the next/previous visible group from a specified index.
- Protected Member Functions inherited from CXTPScrollBarContainer< CWnd >
CXTPScrollBarContainer ()
Constructs a CXTPScrollBarContainer object.

Protected Attributes

CXTPTaskPanelGroups * | m_pGroups
Collection of groups.
CXTPTaskPanelAnimation * | m_pAnimation
Animation context.
CXTPTaskPanelPaintManager * | m_pPaintManager
Current Paint Manager.
XTPTaskPanelPaintTheme | m_paintTheme
Current theme.
BOOL | m_bPreSubclassWindow
TRUE when initialized from PreSubclassWindow.
BOOL | m_nLockRedraw
TRUE when control is locked.
int | m_nClientHeight
Group client height.
int | m_nOldClientHeight
Old group client height.
CRect | m_rcMargins
Outer margins of groups.
int | m_nGroupSpacing
Amount of space placed between groups.
BOOL | m_bScrollVisible
TRUE if the scroll bar is visible.
CXTPTaskPanelItem * | m_pItemHot
Currently hot item.
CXTPTaskPanelItem * | m_pItemFocused
Currently focused item.
CXTPTaskPanelItem * | m_pItemPressed
Currently pressed item.
CXTPTaskPanelItem * | m_pItemDragging
Pointer to item currently being dragged.
CXTPTaskPanelItem * m_pItemDragOver
Pointer to item under mouse cursor with dragged icon.
BOOL | m_bAnimation
TRUE if animation enabled.
XTPTaskPanelAnimation | m_eAnimation
Current animation state.
HCURSOR | m_hHandCursor
Hand cursor.
UINT_PTR | m_nAnimateTimer
Timer identifier for animation.
int | m_nAnimationStep
Current step of animation.
CXTPImageManager * m_pImageManager
Image manager of the Task Panel.
BOOL | m_bExpandable
TRUE if groups are expandable.
BOOL | m_bAcceptFocus
TRUE if control accept focus.
BOOL | m_bGrabbingFocus
TRUE if control move focus to itself.
BOOL | m_bDrawFocusRect
TRUE to draw focused rectangle drawn around the item when the Up and Down arrows are used to navigate the items in the Task Panel.
CSize | m_szItemIcon
Size of group item icons.
CSize | m_szGroupIcon
Size of icons displayed in group captions.
BOOL | m_bSelectItemOnFocus
TRUE if items receive focus when they are clicked.
CPoint | m_ptPressed
Point on Task Panel that was clicked.
long | m_nAllowDrag
TRUE to allow Task Panel group items to be dragged.
BOOL | m_bAllowDrop
TRUE to allow Task Panel group items to be dropped inside the Task Panel, FALSE to only allow Task Panel group items to be dropped outside the Task Panel.
XTPTaskPanelItemLayout | m_itemLayout
Currently set item layout.
BOOL | m_bMultiColumn
TRUE is multiple columns are used to display items in a group.
int | m_nColumnWidth
Width of task panel columns when m_bMultiColumn is TRUE.
XTPTaskPanelHotTrackStyle | m_hotTrackStyle
Currently set hot tracking style.
XTPTaskPanelBehaviour | m_panelBehaviour
Currently set Task Panel behavior.
CXTPTaskPanelGroup * | m_pActiveGroup
Pointer to the currently active group.
CPanelDropTarget * | m_pDropTarget
Internal drag'n'drop helper.
BOOL | m_bTimerGroupHover
TRUE if the timer for the Hover event is currently set.
CXTPTaskPanelScrollButton * | m_pScrollButton [2]
Scroll buttons of the task panel.
BOOL | m_bSingleSelection
TRUE to use focused item as selected.
CXTPToolTipContext * | m_pToolTipContext
Tooltip context.
BOOL | m_bInUpdateScrollBar
TRUE if the CXTPTaskPanel::UpdateScrollBar() method is currently in use (Scrollbar is currently being updated).
int | m_nGroupMinClientHeight
Group minimum client height.
long | m_nOLEDropMode
TRUE if ActiveX OLEDropMode used.
BOOL | m_bTabItems
TRUE to tab all items in group.
CXTPMarkupContext * | m_pMarkupContext
Markup context of the Task Panel.

Static Protected Attributes

static CLIPFORMAT m_cfItem
Clipboard format.

Detailed Description

CXTPTaskPanel is used to implement an Explorer and Office-like Task Panel control.

Member Function Documentation

◆ AddGroup()

CXTPTaskPanelGroup * AddGroup | ( | UINT | nID,
 |  | int | nImage = -1 )

Adds a group to the collection of groups.

Parameters
nID | Identifier of the group to be added.
nImage | Image index of the group to be added.
Returns
A pointer to the newly added group.
See also
SetGroupImageList

◆ AllowDrag()

void AllowDrag ( long nAllowDrag = xtpTaskItemAllowDragDefault )

Specifies the drag options for the Task Panel.

Parameters
nAllowDrag Drag options. See the Remarks section below for a list of available values.

The nAllowDrag parameter can be one or more of the following values: xtpTaskItemAllowDragCopyWithinGroup: To only allow the copy operation within the group. xtpTaskItemAllowDragCopyWithinControl: To only allow the copy operation within the task panel. xtpTaskItemAllowDragCopyOutsideControl: To only allow the copy operation outside the task panel. xtpTaskItemAllowDragCopy: To allow the copy operation. xtpTaskItemAllowDragMoveWithinGroup: To only allow the move operation within the group. xtpTaskItemAllowDragMoveWithinControl: To only allow the move operation within the task panel. xtpTaskItemAllowDragMoveOutsideControl: To only allow the move operation outside the task panel. xtpTaskItemAllowDragMove: To allow the move operation. xtpTaskItemAllowDragAll: To allow all drag operations.

See also
AllowDrop, XTPTaskPanelItemAllowDrag

◆ AllowDrop()

AFX_INLINE void AllowDrop ( BOOL bAllowDrop )

Specifies the drop options for the Task Panel.

Parameters
bAllowDrop TRUE to only allow items to be dropped inside the task panel, FALSE to only allow items to be dropped outside the task panel.
See also
AllowDrag

◆ AnimateGroups()

BOOL AnimateGroups ( BOOL bCheckDirty = TRUE )

This method is called to animate the group(s) when animation is enabled.

Parameters
bCheckDirty TRUE if the group(s) are dirty (i.e. have not reached their target location), FALSE if the group(s) are not dirty (i.e. have reached their target location).
Returns
TRUE if the groups are dirty (i.e. have not reached their target location), FALSE if the groups are not dirty (i.e. have reached their target location).

This method is called when the expand/collapse button is pressed within the group caption causing the group to expand/contract.

See also
SetAnimation, GetAnimation, CXTPTaskPanelGroup::OnAnimate, CXTPTaskPanelGroup::m_rcGroupTarget, CXTPTaskPanelGroup::m_rcGroupCurrent, CXTPTaskPanelGroup::IsExpanding, CXTPTaskPanelGroup::IsExpanded, CXTPTaskPanelGroup::SetExpanded

◆ CheckScrollButtonMouseOver()

void CheckScrollButtonMouseOver ( CPoint point )
protected

Determines if the mouse cursor is positioned over a group scroll button.

Parameters
point Mouse cursor position.

If the mouse cursor is positioned over a group scroll button and that group scroll button is enabled, then the appearance of the button will be changed to "hot". When the mouse cursor leaves the button, the appearance of the button will be returned to normal.

This method is called by OnMouseMove and OnMouseLeave to update the appearance of the group scroll buttons.

◆ Create()

BOOL Create | ( | DWORD | dwStyle,
 |  | const RECT & | rect,
 |  | CWnd * | pParentWnd,
 |  | UINT | nID )

Creates a Task Panel control.

Parameters
dwStyle | Style of the Task Panel control.
rect | Reference to a RECT structure specifying the size and position of the Task Panel control.
pParentWnd | Pointer to the parent window of the Task Panel control.
nID | Identifier of the Task Panel control.
Returns
TRUE if successful, otherwise FALSE.

◆ DrawFocusRect()

AFX_INLINE void DrawFocusRect ( BOOL bAccept )

Draws a focus rectangle around an item/group item when the Up and Down arrows are used to navigate the items in the Task Panel control.

Parameters
bAccept TRUE to draw the focus rectangle, FALSE otherwise.
See also
IsDrawFocusRect

◆ EnableAnimation()

void EnableAnimation ( BOOL bEnable = TRUE )

Enables/disables animation for the Task Panel control.

Parameters
bEnable TRUE to enable animation, FALSE to disable animation.

◆ EnableMarkup()

void EnableMarkup ( BOOL bEnable = TRUE )

Enables/disables markup for tab captions.

Parameters
bEnable TRUE to enable markup for tab captions, FALSE to disable markup for tab captions.

◆ EnsureVisible()

void EnsureVisible ( CXTPTaskPanelItem * pItem )

Ensures that a specified item is visible in the Task Panel.

Parameters
pItem Pointer to the item to ensure the visibility of.

This method will scroll the task panel and the group that the item is within until the item is visible.

◆ ExpandGroup()

virtual void ExpandGroup | ( | CXTPTaskPanelGroup * | pGroup,
 |  | BOOL | bExpanded )
 virtual

Expands/collapses a specified group.

Parameters
pGroup | Pointer to the group to be expanded/collapsed.
bExpanded | TRUE to expand the group, FALSE to collapse the group.
See also
CXTPTaskPanelGroup::SetExpandable, CXTPTaskPanelGroup::IsExpandable

◆ FindGroup()

CXTPTaskPanelGroup * FindGroup ( UINT nID ) const

Retrieves the group with a specified identifier.

Parameters
nID Identifier of the group to be retrieved.
Returns
A pointer to the group with the specified identifier if successful, otherwise NULL.

◆ FindItem()

CXTPTaskPanelGroupItem * FindItem ( UINT nID ) const

Retrieves the group item with a specified identifier.

Parameters
nID Identifier of the group item to be retrieved.
Returns
A pointer to the group item with the specified identifier if successful, otherwise NULL.

◆ GetActiveGroup()

AFX_INLINE CXTPTaskPanelGroup * GetActiveGroup ( ) const

Gets the active group.

Returns
A pointer to the active group.

◆ GetAnimation()

AFX_INLINE XTPTaskPanelAnimation GetAnimation ( ) const

Gets the animation type of the Task Panel control.

Returns
The animation type of the Task Panel control; one of the values defined by the XTPTaskPanelAnimation enumeration.
See also
CXTPTaskPanel::AnimateGroups, CXTPTaskPanel::SetAnimation, CXTPTaskPanelGroup::IsDirty, CXTPTaskPanelGroup::OnAnimate, XTPTaskPanelAnimation

◆ GetAt()

CXTPTaskPanelGroup * GetAt ( int nIndex ) const

Retrieves the group at a specified index in the collection of groups.

Parameters
nIndex Zero-based index of the group to retrieve.
Returns
A pointer to the group at the specified index.

◆ GetBehaviour()

XTPTaskPanelBehaviour GetBehaviour ( ) const

Gets the behaviour of the Task Panel control.

Returns
The behaviour of the Task Panel control; one of the values defined by the XTPTaskPanelBehaviour enumeration.

The Task Panel can behave like a ToolBox, List View, or Explorer.

◆ GetClientHeight()

int GetClientHeight ( ) const

Gets the height of the client area.

Returns
The height of the client area.

◆ GetClipboardFormat()

AFX_INLINE CLIPFORMAT AFX_CDECL GetClipboardFormat ( )
static

Gets the clipboard format.

Returns
The clipboard format.

◆ GetColumnWidth()

AFX_INLINE int GetColumnWidth ( ) const

Gets the width, in pixels, of columns in a multi-column Task Panel control.

Returns
The width, in pixels, of columns in a multi-column Task Panel control.
See also
SetMultiColumn, SetColumnWidth

◆ GetCurrentTheme()

AFX_INLINE XTPTaskPanelPaintTheme GetCurrentTheme ( ) const

Gets the theme of the Task Panel control.

Returns
The theme; one of the values defined by the XTPTaskPanelPaintTheme enumeration.
See also
CXTPTaskPanel::SetTheme

◆ GetFocusedItem()

CXTPTaskPanelItem * GetFocusedItem ( ) const

Gets the focused item of the Task Panel control.

Returns
A pointer to the focused item of the Task Panel control.

◆ GetGroupCount()

int GetGroupCount ( ) const

Gets the number of groups in the collection of groups.

Returns
The number of groups in the collection of groups.

◆ GetGroupIconSize()

AFX_INLINE CSize GetGroupIconSize ( ) const

Gets the size of group icons in the Task Panel control.

By default, the size of group icons is 32x32.

To change the size of group icons, use SetGroupIconSize.

Returns
The size of group icons in the Task Panel control.

◆ GetGroups()

AFX_INLINE CXTPTaskPanelItems * GetGroups ( ) const

Gets the collection of groups of this Task Panel control.

Returns
A pointer to the collection of groups of this Task Panel control.

◆ GetHotItem()

AFX_INLINE CXTPTaskPanelItem * GetHotItem ( ) const

Gets the "hot" item of the Task Panel control.

Returns
A pointer to the "hot" item of the Task Panel control.

◆ GetHotTrackStyle()

XTPTaskPanelHotTrackStyle GetHotTrackStyle ( ) const

Gets the hot tracking style.

Returns
The hot tracking style; one of the values defined by the XTPTaskPanelHotTrackStyle enumeration.

◆ GetImageManager()

CXTPImageManager * GetImageManager ( ) const

Gets the image manager associated with the Task Panel control.

Returns
A pointer to the image manager associated with the Task Panel control.

◆ GetItemIconSize()

AFX_INLINE CSize GetItemIconSize ( ) const

Gets the size of item icons in the Task Panel control.

By default, the size of item icons is 16x16.

To change the size of item icons, use SetIconSize.

Returns
The size of item icons in the Task Panel control.

◆ GetItemLayout()

XTPTaskPanelItemLayout GetItemLayout ( ) const

Gets the item layout.

Returns
The item layout; one of the values defined by the XTPTaskPanelItemLayout enumeration.

◆ GetMargins()

AFX_INLINE CRect GetMargins ( ) const

Gets the outer margins of groups in the Task Panel control.

Returns
The outer margins of groups in the Task Panel control.

◆ GetMarkupContext()

AFX_INLINE CXTPMarkupContext * GetMarkupContext ( ) const

Gets the markup context.

Returns
A pointer to the markup context.

◆ GetMinimumGroupClientHeight()

AFX_INLINE int GetMinimumGroupClientHeight ( ) const

Gets the minimum client height of all groups.

Returns
The minimum client height of all groups.

◆ GetNextItem()

CXTPTaskPanelItem * GetNextItem | ( | CXTPTaskPanelItem * | pItem,
 |  | int | nDirection,
 |  | BOOL | bTab,
 |  | BOOL | bSkipRowItems = TRUE ) const

Retrieves the next/previous item in the tab order from a specified item.

Parameters
pItem | Pointer to the item to search from.
nDirection | Direction to search in (+1 for next, -1 for previous).
bTab | TRUE to use tabulation, FALSE otherwise.
bSkipRowItems | TRUE to skip row items (i.e. get the next/previous item from the next/previous row), FALSE otherwise.
Returns
A pointer to the next/previous item in the tab order from the specified item.

◆ GetNextVisibleGroup()

CXTPTaskPanelGroup * GetNextVisibleGroup | ( | int | nIndex,
 |  | int | nDirection = +1 ) const
 protected

Retrieves the next/previous visible group from a specified index.

Parameters
nIndex | Index to begin search.
nDirection | Direction to search in (+1 for next, -1 for previous).
Returns
A pointer to the next/previous group from the specified index if successful, otherwise a value of -1.

◆ GetPaintManager()

AFX_INLINE CXTPTaskPanelPaintManager * GetPaintManager ( ) const

Gets the paint manager.

Returns
A pointer to the paint manager.
See also
CXTPTaskPanel::SetTheme

◆ GetScrollButton()

AFX_INLINE CXTPTaskPanelScrollButton * GetScrollButton ( BOOL bScrollUp ) const

Retrieves a specified group scroll button.

Parameters
bScrollUp TRUE to retrieve the Up scroll button, FALSE to retrieve the Down scroll button.
Returns
A pointer to the specified group scroll button.
See also
CXTPTaskPanelScrollButton, m_pScrollButton

◆ GetScrollOffset()

int GetScrollOffset ( ) const

Gets the scroll offset.

Returns
The scroll offset.

This method gets the scroll offset of the scrollbar displayed to scroll through the entire task panel. To get the scroll offset of the scrollbar of a task panel group, use CXTPTaskPanelGroup::GetOffsetItem and CXTPTaskPanelGroup::GetScrollOffsetPos.

See also
CXTPTaskPanelGroup::GetOffsetItem, CXTPTaskPanelGroup::GetScrollOffsetPos

◆ GetToolTipContext()

CXTPToolTipContext * GetToolTipContext ( ) const

Gets the tooltip context.

Returns
A pointer to the tooltip context.

◆ HitTestGroup()

CXTPTaskPanelGroup * HitTestGroup | ( | CPoint | pt,
 |  | BOOL * | pbCaption = NULL ) const

Determines which group, if any, is located at a specified point.

Parameters
pt | Point to be tested.
pbCaption | Pointer to a BOOL value to receive if the caption of the group is located at the specified point; TRUE if the caption of the group is located at the specified point, otherwise FALSE.
Returns
A pointer to the group at the specified point, if any, otherwise NULL.

◆ HitTestItem()

CXTPTaskPanelItem * HitTestItem | ( | CPoint | pt,
 |  | BOOL | bClientAvail = FALSE ) const

Determines which item, if any, is located at a specified point.

Parameters
pt | Point to be tested.
bClientAvail | BOOL value to receive if the client area of the item is located at the specified point; TRUE if the client area of the item is located at the specified point, otherwise FALSE.
Returns
A pointer to the item at the specified point, if any, otherwise NULL.

◆ HitTestScrollButton()

CXTPTaskPanelScrollButton * HitTestScrollButton ( CPoint point ) const

Determines which group scroll button, if any, is located at a specified point.

Parameters
point Point to be tested.
Returns
A pointer to the group scroll button at the specified point, if any, otherwise a value of 0.

◆ IsDirty()

BOOL IsDirty ( ) const

Determines if the group position is "dirty" (i.e.

moving during animation).

Returns
TRUE if the group position is "dirty", otherwise FALSE.
See also
AnimateGroups, SetAnimation, GetAnimation, CXTPTaskPanelGroup::OnAnimate, CXTPTaskPanelGroup::m_rcGroupTarget, CXTPTaskPanelGroup::m_rcGroupCurrent, CXTPTaskPanelGroup::IsExpanding, CXTPTaskPanelGroup::IsExpanded, CXTPTaskPanelGroup::SetExpanded

◆ IsDrawFocusRect()

BOOL IsDrawFocusRect ( ) const

Determines if a focus rectangle is drawn around an item when the Up and Down arrows are used to navigate through items in the Task Panel control.

Returns
TRUE if a focus rectangle is drawn, otherwise FALSE.
See also
DrawFocusRect

◆ IsExpandable()

AFX_INLINE BOOL IsExpandable ( ) const

Gets the expandable state of groups.

Returns
TRUE if groups are expandable, otherwise FALSE.

◆ IsExplorerBehaviour()

AFX_INLINE BOOL IsExplorerBehaviour ( ) const
protected

Determines if the behaviour of the Task Panel control is Explorer behavior.

Returns
TRUE if the behaviour of the Task Panel control is Explorer behavior, otherwise FALSE.
See also
SetBehaviour, GetBehaviour, XTPTaskPanelBehaviour

◆ IsGroupExpanded()

BOOL IsGroupExpanded ( const CXTPTaskPanelGroup * pGroup ) const

Determines if a specified group is expanded/collapsed.

Parameters
pGroup Pointer to the group to be tested.
Returns
TRUE if the specified group is expanded, FALSE if the specified group is collapsed.

◆ IsMultiColumn()

AFX_INLINE BOOL IsMultiColumn ( ) const

Determines if multi-column groups is enabled/disabled.

Returns
TRUE if multi-column groups is enabled, FALSE if multi-column groups is disabled.
See also
SetMultiColumn, SetColumnWidth

◆ IsSingleSelection()

AFX_INLINE BOOL IsSingleSelection ( ) const

Determines if single selection is enabled/disabled.

Returns
TRUE if single selection is enabled, FALSE if single selection is disabled.
See also
SetSingleSelection, SetSelectItemOnFocus

◆ NavigateItems()

AFX_INLINE void NavigateItems ( BOOL bTabItems )

Enables/disables item navigation by using the Tab key.

Parameters
bTabItems TRUE to enable item navigation by using the Tab key, FALSE to disable item navigation by using the Tab key.

◆ NotifyOwner()

virtual LRESULT NotifyOwner | ( | WPARAM | wParam,
 |  | LPARAM | lParam )
 virtual

Notifies the parent window that an event has occurred in the Task Panel control.

Parameters
wParam | Specifies which event has occurred.
lParam | Additional message-specific information.

wParam parameter can be one of the following values: XTP_TPN_CLICK Indicates the user clicked a TaskPanel item. XTP_TPN_RCLICK Indicates the user pressed the right mouse button on a TaskPanel item. XTP_TPN_STARTDRAG Indicates the user started to dragging an item. You can return XTP_ACTION_CANCEL to cancel the drag. XTP_TPN_ENDLABELEDIT Indicates the user starts to rename an item. XTP_TPN_ITEMDROP Indicates the user dropped item in task panel. XTP_TPN_GROUPEXPANDING Indicates the group is about to be expanded. lParam contains XTP_TPNGROUPEXPANDING pointer. You can return XTP_ACTION_CANCEL to ignore expanding. XTP_TPN_GROUPEXPANDED Indicates the user has expanded a group.

The following method in the task panel use NotifyOwner to send messages: CXTPTaskPanelGroup::OnAnimate CXTPTaskPanel::ExpandGroup lParam contains XTP_TPNGROUPEXPANDING pointer. You can return XTP_ACTION_CANCEL to ignore expanding. CXTPTaskPanel::OnDrop lParam contains item dropped. CXTPTaskPanel::OnStartItemDrag lParam contains item dragged. CXTPTaskPanel::OnRButtonDown lParam contains item right-clicked. CXTPTaskPanel::OnClick lParam contains item clicked. CXTPTaskPanel::OnEndLabelEdit lParam contains item who's caption is being renamed.

Returns
A returned message processing result.
See also
XTPWM_TASKPANEL_NOTIFY

◆ OnClick()

virtual void OnClick ( CXTPTaskPanelGroupItem * pItem )
virtual

This method is called when the user clicks on an item.

Parameters
pItem Pointer to the item that was clicked.

◆ OnClickScrollButton()

void OnClickScrollButton ( CXTPTaskPanelScrollButton * pScrollButton )
protected

The member is called when a group scroll button is clicked.

Parameters
pScrollButton Pointer to the group scroll button that was clicked.

This method is called by OnLButtonDown when a group scroll button is clicked.

See also
CXTPTaskPanelScrollButton, m_pScrollButton

◆ OnDragOver()

virtual DROPEFFECT OnDragOver | ( | COleDataObject * | pDataObject,
 |  | DWORD | dwKeyState,
 |  | CPoint | point )
 protectedvirtual

This method is called when an item is dragged over the Task Panel control.

Parameters
pDataObject | Pointer to the COleDataObject being dragged over the drop target.
dwKeyState | State of keys on the keyboard (including modifier keys). This is a combination of any number of the following: MK_CONTROL, MK_SHIFT, MK_ALT, MK_LBUTTON, MK_MBUTTON, and MK_RBUTTON.
point | Current mouse position relative to the Task Panel control.
Returns
A value from the DROPEFFECT enumerated type which indicates the type of drop that would occur if the user dropped the object at this position. The type of drop often depends on the current key state as indicated by dwKeyState. A standard mapping of key states to DROPEFFECT values is: DROPEFFECT_NONE: The data object cannot be dropped in this window. DROPEFFECT_COPY for MK_CONTROL: Creates a copy of the dropped object. DROPEFFECT_MOVE for MK_ALT: Creates a copy of the dropped object and deletes the original object. This is typically the default drop effect when the view can accept the data object.

◆ OnDraw()

virtual void OnDraw | ( | CDC * | pDC,
 |  | CRect | rcClipBox )
 virtual

The framework calls this method to draw the Task Panel control using a specified device context.

Parameters
pDC | Pointer to a valid device context.
rcClipBox | Rectangular area of the control that is invalid.

OnDraw calls CXTPTaskPanelGroup::OnPaint for each group in the Task Panel. OnPaint also calls CXTPTaskPanelPaintManager::FillTaskPanel and CXTPTaskPanelPaintManager::DrawScrollButton.

◆ OnDrop()

virtual BOOL OnDrop | ( | COleDataObject * | pDataObject,
 |  | DROPEFFECT | dropEffect,
 |  | CPoint | point )
 protectedvirtual

This method is called when an item is dropped into the Task Panel control.

Parameters
pDataObject | Pointer to the COleDataObject dropped into the drop target.
dropEffect | Drop effect requested by the user. Can be any of the values listed in the Remarks section.
point | Current mouse position relative to the Task Panel control.

The dropEffect parameter can be one of the following values: DROPEFFECT_COPY: Creates a copy of the data object being dropped. DROPEFFECT_MOVE: Moves the data object to the current mouse location.

Returns
TRUE if the drop was successful, otherwise FALSE.

◆ OnEndLabelEdit()

virtual void OnEndLabelEdit | ( | CXTPTaskPanelItem * | pItem,
 |  | LPCTSTR | str )
 protectedvirtual

This method is called when the caption of an item is finished being edited/renamed.

Parameters
pItem | Pointer to the item being edited.
str | New caption of the item.

This method is called after RenameItem.

See also
RenameItem

◆ OnItemRemoved()

virtual void OnItemRemoved ( CXTPTaskPanelItem * pItem )
protectedvirtual

This method is called when an item is removed from the Task Panel.

Parameters
pItem Pointer to the item that was removed.

This method is called by CXTPTaskPanelItems::Clear and CXTPTaskPanelItems::RemoveAt.

See also
CXTPTaskPanelItems::Clear, CXTPTaskPanelItems::RemoveAt

◆ OnScrollChanged()

void OnScrollChanged ( int nCurPos )

This method is called when the scrollbar of the entire Task Panel control is scrolled (i.e.

not the scrollbar of a Task Panel group).

Parameters
nCurPos Position of the scrollbar to scroll to.

◆ OnStartGroupDrag()

virtual void OnStartGroupDrag ( CXTPTaskPanelItem * pItem )
protectedvirtual

This method is called when a group is starting to be dragged.

Parameters
pItem Pointer to the group starting to be dragged.

This method is called by OnMouseMove if a group is dragged.

See also
OnStartItemDrag, OnMouseMove

◆ OnStartItemDrag()

virtual void OnStartItemDrag ( CXTPTaskPanelGroupItem * pItem )
protectedvirtual

This method is called when a group item is starting to be dragged.

Parameters
pItem Pointer to the group item starting to be dragged.

This method is called by OnMouseMove if a group item is dragged.

See also
OnStartGroupDrag, OnMouseMove

◆ Redraw()

void Redraw | ( | LPCRECT | lpRect = NULL,
 |  | BOOL | bAnimate = FALSE )

The framework calls this method to redraw the Task Panel control.

Parameters
lpRect | Rectangular area of the control that is invalid.
bAnimate | TRUE to animate changes in the bounding rectangle.

◆ RegisterWindowClass()

BOOL RegisterWindowClass ( HINSTANCE hInstance = NULL )

Registers the window class if it has not already been registered.

Parameters
hInstance Instance of the resource where the control is located.
Returns
TRUE if the window class was successfully registered.

◆ RenameItem()

void RenameItem ( CXTPTaskPanelItem * pItem )

Renames the caption of a specified item.

Parameters
pItem Pointer to the item with the caption to be renamed.

When this method is called, an edit box will appear on the caption allowing the user to type in a new name.

OnEndLabelEdit will be called when the user has finished editing the caption. This will cause NotifyOwner to send a message to the parent that the caption has finished being edited.

See also
OnEndLabelEdit

◆ Reposition()

void Reposition ( BOOL bRecalcOnly = TRUE )

Repositions the groups in the Task Panel control.

Parameters
bRecalcOnly TRUE to recalculate without repositioning.

◆ RepositionScrollButtons()

void RepositionScrollButtons ( )
protected

Repositions the group scroll buttons.

This method is called by Reposition and AnimateGroups when the groups in the task panel must be repositioned (i.e. during animation while the group is expanding or collapsing).

◆ SetAnimation()

void SetAnimation ( XTPTaskPanelAnimation panelAnimation )

Sets the animation type for the Task Panel control.

Parameters
panelAnimation Animation type to be set. Can be any of the values listed in the Remarks section.

The panelAnimation parameter can be one of the following: xtpTaskPanelAnimationYes: Enables animation (default value). xtpTaskPanelAnimationNo: Disables animation. xtpTaskPanelAnimationSystem: Use system settings to determine animation.

See also
CXTPTaskPanel::AnimateGroups, CXTPTaskPanel::GetAnimation, CXTPTaskPanelGroup::IsDirty, CXTPTaskPanelGroup::OnAnimate, XTPTaskPanelAnimation

◆ SetBehaviour()

void SetBehaviour ( XTPTaskPanelBehaviour panelBehaviour )

Sets the behaviour for the Task Panel control.

Parameters
panelBehaviour Behaviour to be set; must be one of the values defined by the XTPTaskPanelBehaviour enumeration.

The Task Panel can behave like a ToolBox, List View, or Explorer.

◆ SetColumnWidth()

AFX_INLINE void SetColumnWidth ( int nColumnWidth )

Sets the width, in pixels, for columns in a multi-column Task Panel control.

Parameters
nColumnWidth Width, in pixels, to be set.
See also
SetMultiColumn, GetColumnWidth

◆ SetCustomTheme()

void SetCustomTheme ( CXTPTaskPanelPaintManager * pPaintManager )

Sets a custom theme for the Task Panel control.

Parameters
pPaintManager Pointer to a CXTPTaskPanelPaintManager object.

◆ SetExpandable()

AFX_INLINE void SetExpandable ( BOOL bExpandable )

Sets the expandable state for groups.

Parameters
bExpandable TRUE to set groups to expandable, FALSE otherwise.

◆ SetFocusedItem()

virtual void SetFocusedItem | ( | CXTPTaskPanelItem * | pItem,
 |  | BOOL | bDrawFocusRect = FALSE,
 |  | BOOL | bSetFocus = TRUE )
 virtual

Sets the focused item for the Task Panel control.

Parameters
pItem | Pointer to the item to be set.
bDrawFocusRect | TRUE to draw a focus rectangle.
bSetFocus | TRUE to set focus to the item.

◆ SetGroupIconSize()

AFX_INLINE void SetGroupIconSize ( CSize szIcon )

Sets the size for group icons in the Task Panel control.

Parameters
szIcon Group icon size to be set.

◆ SetGroupImageList()

void SetGroupImageList | ( | CImageList * | pImageList,
 |  | CSize | szGroupIcon = CSize(32, 32) )

Sets the image list for the groups of the Task Panel control.

Parameters
pImageList | Pointer to the image list to be set; can be NULL to update the size of group icons.
szGroupIcon | Size of group icons to be set.
See also
SetImageList, GetImageManager

◆ SetHotItem()

void SetHotItem ( CXTPTaskPanelItem * pItem )

Sets the "hot" item for the Task Panel control.

Parameters
pItem Item to be set.

◆ SetHotTrackStyle()

void SetHotTrackStyle ( XTPTaskPanelHotTrackStyle hotTrackStyle )

Sets the hot tracking style.

Parameters
hotTrackStyle Hot tracking style to be set; must be one of the values defined by the XTPTaskPanelHotTrackStyle enumeration.

◆ SetIconSize()

AFX_INLINE void SetIconSize ( CSize szIcon )

Sets the size for item icons in the Task Panel control.

Parameters
szIcon Item icon size to be set.

◆ SetImageList()

void SetImageList | ( | CImageList * | pImageList,
 |  | CSize | szItemIcon = CSize(16, 16) )

Sets the image list for the Task Panel control.

Parameters
pImageList | Pointer to the image list to be set; can be NULL to update the size of item icons.
szItemIcon | Size of item icons to be set.
See also
SetGroupImageList, GetImageManager

◆ SetImageManager()

void SetImageManager ( CXTPImageManager * pImageManager )

Sets the image manager associated with the Task Panel control.

Parameters
pImageManager Pointer to the image manager to be set.

◆ SetItemLayout()

void SetItemLayout ( XTPTaskPanelItemLayout itemLayout )

Sets the item layout.

Parameters
itemLayout Item layout to be set; must be one of the values defined by the XTPTaskPanelItemLayout enumeration.

Item layouts include text only, image only, image and text, and image with text below the image.

This method applies to all groups unless the item layout for each group is set individually.

See also
CXTPTaskPanelGroup::SetItemLayout

◆ SetLayoutRTL()

void SetLayoutRTL ( BOOL bRightToLeft )

Sets right-to-left (RTL) mode.

Parameters
bRightToLeft TRUE to set right-to-left (RTL) reading-order properties.

◆ SetLockRedraw()

void SetLockRedraw ( BOOL bLockRedraw )

Locks/unlocks redrawing controls.

Parameters
bLockRedraw TRUE to lock redrawing controls, FALSE to unlock redrawing controls.

The bLockRedraw parameter should be set to TRUE when you want to add many items, but do not want CXTPTaskPanel::Reposition and CXTPTaskPanel::ReDraw to be called each time an item is added.

◆ SetMargins()

void SetMargins | ( | long | nLeft,
 |  | long | nTop,
 |  | long | nRight,
 |  | long | nBottom,
 |  | long | nMiddle )

Sets the outer margins for the groups of the Task Panel control.

Parameters
nLeft | Left margin.
nTop | Top margin.
nRight | Right margin.
nBottom | Bottom margin.
nMiddle | Margin between groups.

This method sets the default margins for all groups.

See also
GetMargins, CXTPTaskPanelPaintManager::GetGroupSpacing, CXTPTaskPanelPaintManager::GetGroupOuterMargins, CXTPTaskPanelPaintManager::GetGroupInnerMargins, CXTPTaskPanelPaintManager::GetControlMargins

◆ SetMinimumGroupClientHeight()

AFX_INLINE void SetMinimumGroupClientHeight ( int nMinClientHeight )

Sets the minimum client height for all groups.

Parameters
nMinClientHeight Minimum client height to be set.

◆ SetMultiColumn()

AFX_INLINE void SetMultiColumn ( BOOL bMultiColumn )

Enables/disables multi-column groups.

Parameters
bMultiColumn TRUE to enable multi-column groups, FALSE to disable multi-column groups.
See also
IsMultiColumn, SetColumnWidth

◆ SetSelectItemOnFocus()

AFX_INLINE void SetSelectItemOnFocus ( BOOL bSelect )

Specifies if items should receive focus when they are clicked.

Parameters
bSelect TRUE to set items to receive focus when they are clicked, FALSE otherwise.

If bSelect is TRUE, then an item will receive focus when it is clicked and the previously focused item will lose focus.

If bSelect is FALSE, then an item will not receive focus when it is clicked. bSelect should be set to FALSE to either use toggle buttons or to allow multiple items to have focus.

See also
SetFocusedItem, GetFocusedItem

◆ SetSingleSelection()

AFX_INLINE void SetSingleSelection ( BOOL bSingleSelection = TRUE )

Enables/disables single selection.

Parameters
bSingleSelection TRUE to enable single selection, FALSE to disable single selection.

If single selection is enabled, then only one item can be selected in the Task Panel control at a given time. If single selection is disabled, then multiple items can be selected in the Task Panel control at a given time.

See also
IsSingleSelection, SetSelectItemOnFocus

◆ SetTheme()

void SetTheme ( XTPTaskPanelPaintTheme paintTheme )

Sets the theme for the Task Panel control.

Parameters
paintTheme Theme to be set. Can be any of the values listed in the Remarks section.

The paintTheme parameter can be one of the following: xtpTaskPanelThemeOffice2000: Enables an Office 2000 style theme. xtpTaskPanelThemeOffice2003: Enables an Office 2003 style theme. xtpTaskPanelThemeNativeWinXP: Enables an Explorer style theme. xtpTaskPanelThemeOffice2000Plain: Enables a Classic Office 2000 style theme. xtpTaskPanelThemeOfficeXPPlain: Enables a Classic Office XP style theme. xtpTaskPanelThemeOffice2003Plain: Enables a Classic Office 2003 style theme. xtpTaskPanelThemeNativeWinXPPlain: Enables a Classic Explorer style theme. xtpTaskPanelThemeVisualStudio2003: Enables a VS 2003 style Toolbox theme. xtpTaskPanelThemeVisualStudio2005: Enables a VS 2005 style Toolbox theme. xtpTaskPanelThemeListView: Enables Standard a List View theme. xtpTaskPanelThemeListViewOfficeXP: Enables an Office XP List View theme. xtpTaskPanelThemeListViewOffice2003: Enables an Office 2003 List View theme. xtpTaskPanelThemeShortcutBarOffice2003: Enables a ShortcutBar Office 2003 theme. xtpTaskPanelThemeResource: Enables a ShortcutBar Office 2007/2010 theme. xtpTaskPanelThemeVisualStudio2010: Enables a VS 2010 style Toolbox theme. xtpTaskPanelThemeVisualStudio2012Light: Enables a VS 2012 Light style Toolbox theme. xtpTaskPanelThemeVisualStudio2012Dark: Enables a VS 2012 Dark style Toolbox theme. xtpTaskPanelThemeCustom: Enables a user-defined Custom theme.

See also
CXTPTaskPanel::GetCurrentTheme

◆ UpdateScrollBar()

virtual void UpdateScrollBar ( )
protectedvirtual

Updates the scrollbar of the Task Panel.

This method updates the scrollbar displayed to scroll through the entire task panel. To update the scrollbar of a task panel group, use UpdateScrollButtons.

See also
UpdateScrollButtons

◆ UpdateScrollButtons()

void UpdateScrollButtons ( )
protected

Updates the enabled/disabled state of the group scroll buttons.

This method is called by RepositionScrollButtons, CXTPTaskPanelGroup::Scroll, and CXTPTaskPanelGroup::EnsureVisible to update the state of the group scroll buttons.

Member Data Documentation

◆ m_bScrollVisible

BOOL m_bScrollVisible
protected

TRUE if the scroll bar is visible.

This refers to the scroll bar of the entire task panel.

◆ m_bTimerGroupHover

BOOL m_bTimerGroupHover
protected

TRUE if the timer for the Hover event is currently set.

The timer for the Hover event is set when the mouse is left in the same position for at least 500 milliseconds.

◆ m_nClientHeight

int m_nClientHeight
protected

Group client height.

This is the area displayed under the group caption.

◆ m_pImageManager

CXTPImageManager* m_pImageManager
protected

Image manager of the Task Panel.

This is the collection of images that are used for Task Panel group and group item icons.

◆ m_pItemDragOver

CXTPTaskPanelItem* m_pItemDragOver
protected

Pointer to item under mouse cursor with dragged icon.

This is the item that will appear directly under the dragged item if the item were dropped.

◆ m_pScrollButton

CXTPTaskPanelScrollButton* m_pScrollButton[2]
protected

Scroll buttons of the task panel.

The task panel uses these scroll buttons in CXTPTaskPanelGroup objects when there are more items in the group than can be viewed. Only the necessary buttons are displayed. If the items in the group cannot be scrolled anymore, then that button is removed. Scroll buttons are only visible when using the xtpTaskPanelBehaviourList and xtpTaskPanelBehaviourToolbox task panel behaviors.

The documentation for this class was generated from the following file:
  • XTPTaskPanel.h


Toolkit Pro: CXTPTaskPanel::CRepositionContext Class Reference

  • CXTPTaskPanel
  • CRepositionContext
Public Member Functions | Protected Attributes | List of all members
CXTPTaskPanel::CRepositionContext Class Reference

CRepositionContext is a helper class used to lock/unlock redraw for the Task Panel. More...

Public Member Functions

CRepositionContext (CXTPTaskPanel *pTaskPanel)
Constructs a CRepositionContext object.
~CRepositionContext ()
Destroys a CRepositionContext object, handles cleanup and deallocation.

Protected Attributes

CXTPTaskPanel * m_pTaskPanel
Parent Task Panel.

Detailed Description

CRepositionContext is a helper class used to lock/unlock redraw for the Task Panel.

Constructor & Destructor Documentation

◆ CRepositionContext()

CRepositionContext ( CXTPTaskPanel * pTaskPanel )

Constructs a CRepositionContext object.

Parameters
pTaskPanel Pointer to the parent Task Panel.
The documentation for this class was generated from the following file:
  • XTPTaskPanel.h


Toolkit Pro: CXTPTaskPanelExplorerTheme Class Reference

Public Member Functions | Public Attributes | List of all members
CXTPTaskPanelExplorerTheme Class Reference

CXTPTaskPanelExplorerTheme represents an Explorer style theme. More...

Inheritance diagram for CXTPTaskPanelExplorerTheme:
[legend]

Public Member Functions

CXTPTaskPanelExplorerTheme ()
Constructs a CXTPTaskPanelExplorerTheme object.
void | RefreshMetrics ()
Refreshes the visual metrics of the task panel.
- Public Member Functions inherited from CXTPTaskPanelPaintManager
CXTPTaskPanelPaintManager ()
Constructs a CXTPTaskPanelPaintManager object.
virtual | ~CXTPTaskPanelPaintManager ()
Destroys a CXTPTaskPanelPaintManager object, handles cleanup and deallocation.
virtual void | FillTaskPanel (CDC *pDC, CXTPTaskPanel *pTaskPanel)
Fills the background of a specified task panel.
virtual void | DrawGroupClient (CDC *pDC, CXTPTaskPanelGroup *pGroup)
Draws a specified group.
virtual int | DrawGroupCaption (CDC *pDC, CXTPTaskPanelGroup *pGroup, BOOL bDraw)
Draws the caption of a specified group.
virtual CRect | DrawGroupItem (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw)
Draws a specified group item.
XTP_TASKPANEL_GROUPCOLORS * | GetGroupColors (BOOL bSpecial)
Retrieves a specified group color set.
virtual XTP_TASKPANEL_GROUPCOLORS * | GetGroupColors (CXTPTaskPanelGroup *pGroup)
Retrieves a specified group color set.
virtual void | DrawGroupItemFrame (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc)
Draws a rectangle around a group item when it is selected, pressed or highlighted.
virtual CRect | GetItemOuterMargins (const CXTPTaskPanelGroupItem *pItem)
Retrieves the outer margins of a specified group item.
virtual CRect | GetItemInnerMargins (const CXTPTaskPanelGroupItem *pItem)
Retrieves the inner margins of a specified group item.
virtual CRect | GetGroupOuterMargins (const CXTPTaskPanelGroup *pGroup)
Retrieves the outer margins of a specified group.
virtual CRect | GetItemIconPadding (const CXTPTaskPanelItem *pItem)
Retrieves the icon padding of a specified item.
virtual CRect | GetGroupInnerMargins (const CXTPTaskPanelGroup *pGroup)
Retrieves the inner margins of a specified group.
virtual CRect | GetControlMargins (const CXTPTaskPanel *pPanel)
Gets the default margins used for all groups within a specified Task Panel control.
virtual int | GetGroupSpacing (const CXTPTaskPanel *pPanel)
Gets the spacing used between groups within a specified Task Panel control.
virtual void | DrawScrollButton (CDC *pDC, CXTPTaskPanelScrollButton *pScrollButton)
Draws a group scroll button.
void | SetTextFormat (int nTextFormat, BOOL bCaption=FALSE)
Sets the text format for captions/items.
void | SetItemsFontIndirect (LOGFONT *pLogFont, BOOL bUseStandardItemsFont=FALSE)
Sets the text font for items.
void | SetCaptionFontIndirect (LOGFONT *pLogFont, BOOL bUseStandardCaptionFont=FALSE)
Sets the text font for captions.
virtual CFont * | GetItemFont (CXTPTaskPanelItem *pItem)
Retrieves the text font of a specified item.
virtual void | FillGroupClientFace (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Fills the client face of a specified group.

Public Attributes

BOOL | m_bExplorerTheme
TRUE to use Explorer theme under WinXP and to use Office 2000 under older OSes.
- Public Attributes inherited from CXTPTaskPanelPaintManager
BOOL | m_bEmulateEplorerTheme
TRUE to use Explorer theme under WinXP and Office 2000 under older OS.
XTPTaskPanelGripper | m_eGripper
Gripper of the manager.
BOOL | m_bBoldCaption
TRUE to display caption text in bold font, FALSE to display caption text in normal type.
CRect | m_rcGroupOuterMargins
Outer margins of the group.
CRect | m_rcGroupInnerMargins
Inner margins of the group.
CRect | m_rcItemOuterMargins
Outer margins of the group items.
CRect | m_rcItemInnerMargins
Inner margins of the group items.
CRect | m_rcControlMargins
Default margins for all groups.
int | m_nGroupSpacing
Amount of space placed between groups in the task panel.
CRect | m_rcImageLayoutIconPadding
Padding around images for xtpTaskItemLayoutImages layout.
CRect | m_rcItemIconPadding
Padding around images for items.
CRect | m_rcGroupIconPadding
Padding around images for groups.
BOOL | m_bOfficeHighlight
TRUE to highlight group items and scroll buttons using the Office XP style (XPCOLOR_HIGHLIGHT, XPCOLOR_HIGHLIGHT_CHECKED, XPCOLOR_HIGHLIGHT_PUSHED).
BOOL | m_bInvertDragRect
Only used when the theme is set to xtpTaskPanelThemeVisualStudio2003.
BOOL | m_bCaptionScrollButton
TRUE if the group caption scroll button is visible, FALSE if the group caption scroll button is hidden.
BOOL | m_bEmbossedDisabledText
TRUE to draw disabled text embossed.

Additional Inherited Members

- Static Public Attributes inherited from CXTPTaskPanelPaintManager
static const CRect | rectDefault
System selected default margins.
- Protected Member Functions inherited from CXTPTaskPanelPaintManager
CRect | DrawGroupItemImageWithText (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw)
Draws the icon of a specified group item.
CRect | DrawGroupItemImageWithTextBelow (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw)
Draws the icon of a specified group item.
CRect | DrawGroupItemImage (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw)
Draws the icon of a specified group item.
virtual void | DrawGroupClientFace (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Draws the client face of a specified group.
virtual void | DrawGroupClientItems (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Draws the items of a specified group.
virtual CRect | DrawCaptionGripper (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Draws the caption gripper of a specified group.
virtual int | GetCaptionGripperWidth (CXTPTaskPanelGroup *pGroup, CRect rc)
Retrieves the width of the caption gripper of a specified group.
virtual void | DrawItemCaption (CDC *pDC, CXTPTaskPanelItem *pItem, CRect rcText, UINT nFormat)
Draws the text caption of a specified item.
virtual void | DrawItemImage (CDC *pDC, CXTPTaskPanelItem *pItem, CPoint ptIcon, CXTPImageManagerIcon *pImage, CSize szIcon)
Draws the icon of a specified item.
COLORREF | BlendColor (COLORREF clrFrom, COLORREF clrTo, int nAlpha)
Blends one color to another color by a specified amount.
CRect | DrawCaptionGripperBitmap (CDC *pDC, CXTPTaskPanelGroup *pGroup, BOOL bExpanded, BOOL bHot, CRect rc)
Draws the caption gripper bitmap.
void | DrawCaptionGripperSigns (CDC *pDC, CPoint pt, COLORREF clr, BOOL bExpanded)
Draws the ">>" and "<<" signs of the caption gripper when the theme of the Task Panel is set to Office 2000.
void | CreateGripperBitmaps ()
Loads the gripper bitmap when the theme of the Task Panel is set to either Windows XP or Classic Windows XP.
void | CreateGripperIcon (HICON &hIcon, UINT nIDResource, COLORREF clrGripperBack)
Creates the gripper bitmap icons when the theme of the Task Panel is set to either Windows XP or Classic Windows XP and either the operating system is not Windows XP or the operating system is Windows XP and Luna themes are used.
void | FreeBitmaps ()
Frees the memory used by the group caption bitmaps.
void | Rectangle (CDC *pDC, CRect rc, COLORREF clrPen, COLORREF clrBrush)
This method is only used when drawing hot, pressed, and selected group items and scroll buttons when m_bOfficeHighlight is TRUE.
virtual CPoint | GetHighlightOffset (CXTPTaskPanelGroupItem *pItem)
Retrieves the highlight offset of the text of a specified group item.
virtual void | DrawDragArrow (CDC *pDC, CXTPTaskPanelItem *pItem, CRect rc, BOOL bAfter=FALSE)
Draws the "drag arrow" of a specified item.
virtual void | DrawFocusRect (CDC *pDC, CRect rc)
Draws a rectangle around the focused item.
- Protected Attributes inherited from CXTPTaskPanelPaintManager
BOOL | m_bUseBitmapGrippers
TRUE to use alpha grippers.
HICON | m_hGripperNormal
Icon of normal group header gripper.
HICON | m_hGripperSpecial
Icon of special group header gripper.
HBITMAP | m_bmpGrippers [8]
Bitmaps of alpha grippers.
CXTPFont | m_xtpFontCaption
Caption font.
CXTPFont | m_xtpFontIcon
Normal items font.
CXTPFont | m_xtpFontIconBold
Bold items font.
CXTPFont | m_xtpFontIconHot
"Hot" items font.
CXTPFont | m_xtpFontIconHotBold
Bold items font.
CXTPPaintManagerColorGradient | m_clrBackground
Background color of the Task Panel.
XTP_TASKPANEL_GROUPCOLORS | m_groupNormal
Normal colors set.
XTP_TASKPANEL_GROUPCOLORS | m_groupSpecial
Special colors set.
CXTPPaintManagerColor | m_clrHighlightHot
Color of items when they are "hot." This is the color of the item on mouseover if hot tracking is enabled.
CXTPPaintManagerColor m_clrHighlightSelected
Color of items when they are selected.
CXTPPaintManagerColor m_clrHighlightPressed
Color of items when they are pressed.
CXTPPaintManagerColorGradient | m_clrHighlightBorder
Border color of items when they are "hot." This is the border color of the item on mouse over if hot tracking is enabled.
BOOL | m_bOfficeBorder
TRUE to use Office borders.
BOOL | m_bLeftRoundedCorner
TRUE to round left corner of the group caption.
BOOL | m_bRightRoundedCorner
TRUE to round right corner of the group caption.
int | m_nCaptionHeight
Caption height, in pixels.
BOOL | m_bUseStandardCaptionFont
TRUE to use system font for group caption text.
BOOL | m_bUseStandardItemsFont
TRUE to use system font for item caption text.
int | m_nItemTextFormat
Format flags of item text.
int | m_nCaptionTextFormat
Format flags of caption text.

Detailed Description

CXTPTaskPanelExplorerTheme represents an Explorer style theme.

See also
CXTPTaskPanel::SetTheme
The documentation for this class was generated from the following file:
  • XTPTaskPanelExplorerTheme.h


Toolkit Pro: CXTPTaskPanelExplorerThemePlain Class Reference

Public Member Functions | Public Attributes | List of all members
CXTPTaskPanelExplorerThemePlain Class Reference

CXTPTaskPanelExplorerThemePlain represents a classic Explorer style theme. More...

Inheritance diagram for CXTPTaskPanelExplorerThemePlain:
[legend]

Public Member Functions

CXTPTaskPanelExplorerThemePlain ()
Constructs a CXTPTaskPanelExplorerThemePlain object.
void | RefreshMetrics ()
Refreshes the visual metrics of the task panel.
CRect | DrawCaptionGripper (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Draws the caption gripper.
- Public Member Functions inherited from CXTPTaskPanelPaintManagerPlain
CXTPTaskPanelPaintManagerPlain ()
Constructs a CXTPTaskPanelPaintManagerPlain object.
void | RefreshMetrics ()
Refreshes the visual metrics of the task panel.
void | DrawGroupClientFace (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Draws the client face of a specified group.
void | FillGroupClientFace (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Fills the client face of a specified group.
void | FillTaskPanel (CDC *pDC, CXTPTaskPanel *pTaskPanel)
Fills the background of a specified task panel.
int | DrawGroupCaption (CDC *pDC, CXTPTaskPanelGroup *pGroup, BOOL bDraw)
Draws the caption of a specified group.
- Public Member Functions inherited from CXTPTaskPanelPaintManager
CXTPTaskPanelPaintManager ()
Constructs a CXTPTaskPanelPaintManager object.
virtual | ~CXTPTaskPanelPaintManager ()
Destroys a CXTPTaskPanelPaintManager object, handles cleanup and deallocation.
virtual void | DrawGroupClient (CDC *pDC, CXTPTaskPanelGroup *pGroup)
Draws a specified group.
virtual CRect | DrawGroupItem (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw)
Draws a specified group item.
XTP_TASKPANEL_GROUPCOLORS * | GetGroupColors (BOOL bSpecial)
Retrieves a specified group color set.
virtual XTP_TASKPANEL_GROUPCOLORS * | GetGroupColors (CXTPTaskPanelGroup *pGroup)
Retrieves a specified group color set.
virtual void | DrawGroupItemFrame (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc)
Draws a rectangle around a group item when it is selected, pressed or highlighted.
virtual CRect | GetItemOuterMargins (const CXTPTaskPanelGroupItem *pItem)
Retrieves the outer margins of a specified group item.
virtual CRect | GetItemInnerMargins (const CXTPTaskPanelGroupItem *pItem)
Retrieves the inner margins of a specified group item.
virtual CRect | GetGroupOuterMargins (const CXTPTaskPanelGroup *pGroup)
Retrieves the outer margins of a specified group.
virtual CRect | GetItemIconPadding (const CXTPTaskPanelItem *pItem)
Retrieves the icon padding of a specified item.
virtual CRect | GetGroupInnerMargins (const CXTPTaskPanelGroup *pGroup)
Retrieves the inner margins of a specified group.
virtual CRect | GetControlMargins (const CXTPTaskPanel *pPanel)
Gets the default margins used for all groups within a specified Task Panel control.
virtual int | GetGroupSpacing (const CXTPTaskPanel *pPanel)
Gets the spacing used between groups within a specified Task Panel control.
virtual void | DrawScrollButton (CDC *pDC, CXTPTaskPanelScrollButton *pScrollButton)
Draws a group scroll button.
void | SetTextFormat (int nTextFormat, BOOL bCaption=FALSE)
Sets the text format for captions/items.
void | SetItemsFontIndirect (LOGFONT *pLogFont, BOOL bUseStandardItemsFont=FALSE)
Sets the text font for items.
void | SetCaptionFontIndirect (LOGFONT *pLogFont, BOOL bUseStandardCaptionFont=FALSE)
Sets the text font for captions.
virtual CFont * | GetItemFont (CXTPTaskPanelItem *pItem)
Retrieves the text font of a specified item.

Public Attributes

BOOL | m_bExplorerTheme
TRUE to use Explorer theme under WinXP and to use Office 2000 under older OSes.
- Public Attributes inherited from CXTPTaskPanelPaintManager
BOOL | m_bEmulateEplorerTheme
TRUE to use Explorer theme under WinXP and Office 2000 under older OS.
XTPTaskPanelGripper | m_eGripper
Gripper of the manager.
BOOL | m_bBoldCaption
TRUE to display caption text in bold font, FALSE to display caption text in normal type.
CRect | m_rcGroupOuterMargins
Outer margins of the group.
CRect | m_rcGroupInnerMargins
Inner margins of the group.
CRect | m_rcItemOuterMargins
Outer margins of the group items.
CRect | m_rcItemInnerMargins
Inner margins of the group items.
CRect | m_rcControlMargins
Default margins for all groups.
int | m_nGroupSpacing
Amount of space placed between groups in the task panel.
CRect | m_rcImageLayoutIconPadding
Padding around images for xtpTaskItemLayoutImages layout.
CRect | m_rcItemIconPadding
Padding around images for items.
CRect | m_rcGroupIconPadding
Padding around images for groups.
BOOL | m_bOfficeHighlight
TRUE to highlight group items and scroll buttons using the Office XP style (XPCOLOR_HIGHLIGHT, XPCOLOR_HIGHLIGHT_CHECKED, XPCOLOR_HIGHLIGHT_PUSHED).
BOOL | m_bInvertDragRect
Only used when the theme is set to xtpTaskPanelThemeVisualStudio2003.
BOOL | m_bCaptionScrollButton
TRUE if the group caption scroll button is visible, FALSE if the group caption scroll button is hidden.
BOOL | m_bEmbossedDisabledText
TRUE to draw disabled text embossed.

Additional Inherited Members

- Static Public Attributes inherited from CXTPTaskPanelPaintManager
static const CRect | rectDefault
System selected default margins.
- Protected Member Functions inherited from CXTPTaskPanelPaintManager
CRect | DrawGroupItemImageWithText (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw)
Draws the icon of a specified group item.
CRect | DrawGroupItemImageWithTextBelow (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw)
Draws the icon of a specified group item.
CRect | DrawGroupItemImage (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw)
Draws the icon of a specified group item.
virtual void | DrawGroupClientItems (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Draws the items of a specified group.
virtual int | GetCaptionGripperWidth (CXTPTaskPanelGroup *pGroup, CRect rc)
Retrieves the width of the caption gripper of a specified group.
virtual void | DrawItemCaption (CDC *pDC, CXTPTaskPanelItem *pItem, CRect rcText, UINT nFormat)
Draws the text caption of a specified item.
virtual void | DrawItemImage (CDC *pDC, CXTPTaskPanelItem *pItem, CPoint ptIcon, CXTPImageManagerIcon *pImage, CSize szIcon)
Draws the icon of a specified item.
COLORREF | BlendColor (COLORREF clrFrom, COLORREF clrTo, int nAlpha)
Blends one color to another color by a specified amount.
CRect | DrawCaptionGripperBitmap (CDC *pDC, CXTPTaskPanelGroup *pGroup, BOOL bExpanded, BOOL bHot, CRect rc)
Draws the caption gripper bitmap.
void | DrawCaptionGripperSigns (CDC *pDC, CPoint pt, COLORREF clr, BOOL bExpanded)
Draws the ">>" and "<<" signs of the caption gripper when the theme of the Task Panel is set to Office 2000.
void | CreateGripperBitmaps ()
Loads the gripper bitmap when the theme of the Task Panel is set to either Windows XP or Classic Windows XP.
void | CreateGripperIcon (HICON &hIcon, UINT nIDResource, COLORREF clrGripperBack)
Creates the gripper bitmap icons when the theme of the Task Panel is set to either Windows XP or Classic Windows XP and either the operating system is not Windows XP or the operating system is Windows XP and Luna themes are used.
void | FreeBitmaps ()
Frees the memory used by the group caption bitmaps.
void | Rectangle (CDC *pDC, CRect rc, COLORREF clrPen, COLORREF clrBrush)
This method is only used when drawing hot, pressed, and selected group items and scroll buttons when m_bOfficeHighlight is TRUE.
virtual CPoint | GetHighlightOffset (CXTPTaskPanelGroupItem *pItem)
Retrieves the highlight offset of the text of a specified group item.
virtual void | DrawDragArrow (CDC *pDC, CXTPTaskPanelItem *pItem, CRect rc, BOOL bAfter=FALSE)
Draws the "drag arrow" of a specified item.
virtual void | DrawFocusRect (CDC *pDC, CRect rc)
Draws a rectangle around the focused item.
- Protected Attributes inherited from CXTPTaskPanelPaintManagerPlain
BOOL | m_bRoundedFrame
TRUE to draw a rounded frame around all of the groups in the task panel.
BOOL | m_bOfficeCaption
FALSE to draw a rounded rectangle around caption.
- Protected Attributes inherited from CXTPTaskPanelPaintManager
BOOL | m_bUseBitmapGrippers
TRUE to use alpha grippers.
HICON | m_hGripperNormal
Icon of normal group header gripper.
HICON | m_hGripperSpecial
Icon of special group header gripper.
HBITMAP | m_bmpGrippers [8]
Bitmaps of alpha grippers.
CXTPFont | m_xtpFontCaption
Caption font.
CXTPFont | m_xtpFontIcon
Normal items font.
CXTPFont | m_xtpFontIconBold
Bold items font.
CXTPFont | m_xtpFontIconHot
"Hot" items font.
CXTPFont | m_xtpFontIconHotBold
Bold items font.
CXTPPaintManagerColorGradient | m_clrBackground
Background color of the Task Panel.
XTP_TASKPANEL_GROUPCOLORS | m_groupNormal
Normal colors set.
XTP_TASKPANEL_GROUPCOLORS | m_groupSpecial
Special colors set.
CXTPPaintManagerColor | m_clrHighlightHot
Color of items when they are "hot." This is the color of the item on mouseover if hot tracking is enabled.
CXTPPaintManagerColor m_clrHighlightSelected
Color of items when they are selected.
CXTPPaintManagerColor m_clrHighlightPressed
Color of items when they are pressed.
CXTPPaintManagerColorGradient | m_clrHighlightBorder
Border color of items when they are "hot." This is the border color of the item on mouse over if hot tracking is enabled.
BOOL | m_bOfficeBorder
TRUE to use Office borders.
BOOL | m_bLeftRoundedCorner
TRUE to round left corner of the group caption.
BOOL | m_bRightRoundedCorner
TRUE to round right corner of the group caption.
int | m_nCaptionHeight
Caption height, in pixels.
BOOL | m_bUseStandardCaptionFont
TRUE to use system font for group caption text.
BOOL | m_bUseStandardItemsFont
TRUE to use system font for item caption text.
int | m_nItemTextFormat
Format flags of item text.
int | m_nCaptionTextFormat
Format flags of caption text.

Detailed Description

CXTPTaskPanelExplorerThemePlain represents a classic Explorer style theme.

See also
CXTPTaskPanel::SetTheme

Member Function Documentation

◆ DrawCaptionGripper()

CRect DrawCaptionGripper | ( | CDC * | pDC,
 |  | CXTPTaskPanelGroup * | pGroup,
 |  | CRect | rc )
 virtual

Draws the caption gripper.

Parameters
pDC | Pointer to a valid device context.
pGroup | Pointer to a CXTPTaskPanelGroup object.
rc | Rectangle of the group to be drawn.
Returns
The rectangle of the caption after drawing.

The caption gripper is the button that allows the group to be expanded and collapsed.

If the current operating system is Windows XP and the current theme is xtpSystemThemeBlue, xtpSystemThemeOlive, or xtpSystemThemeSilver, then the gripper bitmap is loaded from the operating system.

The WinXp gripper is created with CXTPTaskPanelPaintManager::CreateGripperBitmaps. For all other operating systems and themes, CXTPTaskPanelPaintManager::CreateGripperIcon is used to create an emulated version of the Windows XP gripper.

If m_bExplorerTheme is TRUE, then CXTPTaskPanelPaintManager::DrawCaptionGripperBitmap is used to draw the gripper. Therefore, a bitmap is loaded.

If m_bExplorerTheme is FALSE, then CXTPTaskPanelPaintManager::DrawCaptionGripper is used to draw the gripper. Therefore, no bitmap is loaded.

See also
CXTPTaskPanelPaintManager::DrawCaptionGripperBitmap, CXTPTaskPanelPaintManager::DrawCaptionGripperSigns

Reimplemented from CXTPTaskPanelPaintManager.

The documentation for this class was generated from the following file:
  • XTPTaskPanelExplorerThemePlain.h


Toolkit Pro: CXTPTaskPanelGroup Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPTaskPanelGroup Class Reference

CXTPTaskPanelGroup is used in a Task Panel control to represent a group. More...

Inheritance diagram for CXTPTaskPanelGroup:
[legend]

Public Member Functions

CXTPTaskPanelGroup (CXTPTaskPanel *pPanel=NULL)
Constructs a CXTPTaskPanelGroup object.
virtual | ~CXTPTaskPanelGroup ()
Destroys a CXTPTaskPanelGroup object, handles cleanup and deallocation.
CXTPTaskPanelItems * | GetItems () const
Gets the collection of group items.
CXTPTaskPanelGroupItem * | GetAt (int nIndex) const
Retrieves the group item at a specified index in the collection of group items.
CXTPTaskPanelGroupItem * | FindItem (int nID) const
Retrieves the group item with a specified identifier.
CXTPTaskPanelGroupItem * | AddLinkItem (UINT nID, int nImage=-1)
Adds a link item to the group.
CXTPTaskPanelGroupItem * | AddLinkItem (UINT nID, LPCTSTR lpCaption, LPCTSTR lpTooltip=NULL, int nImage=-1)
Adds a link item to the group.
CXTPTaskPanelGroupItem * | AddTextItem (LPCTSTR strText)
Adds a text item to the group.
CXTPTaskPanelGroupItem * | AddControlItem (HWND hWnd)
Adds a control item to the group.
CXTPTaskPanelGroupItem * | HitTest (CPoint pt, CRect *lpRect=0) const
Determines which group item, if any, is at a specified point.
CRect | OnReposition (CRect rc, BOOL bRecalcOnly=TRUE)
This method is called when the group is repositioned.
void | OnAnimate (int nStep)
This method is called when an animation step is executed.
void | OnPaint (CDC *pDC)
This method is called to draw the group.
CRect | GetCaptionRect () const
Gets the rectangle of the caption.
CRect | GetClientRect () const
Gets the rectangle of the client.
CRect | GetTargetClientRect () const
Gets the target rectangle of the client.
CRect | GetTargetCaptionRect () const
Gets the target rectangle of the caption.
void | SetSpecialGroup (BOOL bSpecial=TRUE)
Specifies if the group should be special.
BOOL | IsSpecialGroup () const
Determines if the group is special.
void | SetExpandable (BOOL bExpandable)
Sets the expandable state for the group.
BOOL | IsExpandable () const
Gets the expandable state of the group.
void | ShowCaption (BOOL bShow)
Shows/hides the caption of the group.
BOOL | IsCaptionVisible () const
Determines if the caption of the group is shown/hidden.
BOOL | IsExpanded () const
Determines if the group is expanded/collapsed.
BOOL | IsExpanding () const
Determines if the group is expanding.
int | GetExpandedClientHeight () const
Gets the client height of the expanded group.
void | SetExpanded (BOOL bExpanded)
Expands/collapses the group.
BOOL | IsDirty () const
Determines if the group position is "dirty" (i.e.
CRect & | GetOuterMargins ()
Gets the outer margins of the group.
CRect & | GetInnerMargins ()
Gets the inner margins of the group.
int | GetMinimumClientHeight () const
Gets the minimum client height of the group.
void | SetMinimumClientHeight (int nMinClientHeight)
Sets the minimum client height for the group.
BOOL | IsAcceptFocus () const
Determines if the group can accept focus.
void | SetClientBitmap (UINT nID, COLORREF clrTransparent, int nBackgroundAlignment=DT_RIGHT|DT_BOTTOM)
Sets the client bitmap for the group.
virtual void | OnFillClient (CDC *pDC, CRect rc)
This method is called when the Task Panel group client face is drawn.
XTPTaskPanelItemLayout | GetItemLayout () const
Gets the item layout of the group.
void | SetItemLayout (XTPTaskPanelItemLayout itemLayout)
Sets the item layout for the group.
void | SetSelectedItem (CXTPTaskPanelGroupItem *pItem)
Selects a specified group item.
BOOL | IsChildItemDragOver () const
Determines if the item currently being dragged over the group is a child item of the group.
int | GetItemCount () const
Gets the number of items in the group.
BOOL | IsScrollButtonEnabled (BOOL bScrollButtonUp) const
Determines if a specified group scroll button is enabled/disabled.
int | GetScrollOffsetPos () const
Gets the scroll offset of the first visible item in the group.
void | SetOffsetItem (int nScrollOffset, BOOL bUpdateScrollButtons=TRUE)
Sets the index for the first visible item in the group.
BOOL | IsItemVisible (CXTPTaskPanelGroupItem *pItem, BOOL bAllowPart) const
Determines if a specified item is visible in the group.
int | GetOffsetItem () const
Gets the index of the first visible item in the group.
void | Scroll (int nDelta)
Scrolls to the item at a specified scroll offset in the group when the group has scroll buttons.
void | EnsureVisible (CXTPTaskPanelGroupItem *pItem, BOOL bUpdateScrollButtons=TRUE)
Ensures that a specified group item is visible in the Task Panel.
int | GetItemsInRow () const
Gets the number of group items per row in the group.
virtual void | DoPropExchange (CXTPPropExchange *pPX)
Reads/writes this object from/to an archive.
virtual CRect | GetHitTestRect () const
Gets the rectangle of the "tooltip zone".
virtual CRect | GetInvalidateRect () const
Gets the rectangle of the "drawing zone".
int | GetCaptionHeight () const
Gets the height of the group caption.
CSize | GetItemIconSize () const
Gets the size of group item icons.
void | SetIconSize (CSize szItemIcon)
Sets the size for group item icons.
CXTPTaskPanelGroupItem * | GetNextVisibleItem (int nIndex, int nDirection=+1) const
Retrieves the index of the next/previous visible item in this group from a specified index.
- Public Member Functions inherited from CXTPTaskPanelItem
virtual | ~CXTPTaskPanelItem ()
Destroys a CXTPTaskPanelItem object, handles cleanup and deallocation.
CXTPTaskPanel * | GetTaskPanel () const
Gets the parent Task Panel control.
void | SetID (UINT nID)
Sets the identifier for the item.
void | SetID (UINT nID, LPCTSTR lpCaption, LPCTSTR lpTooltip=NULL)
Sets the identifier for the item.
UINT | GetID () const
Gets the identifier of the item.
BOOL | IsDroppedOff () const
Call this method to get the identifier of the item.
void | SetCaption (LPCTSTR lpszCaption)
Sets the caption for the item.
void | SetTooltip (LPCTSTR lpszTooltip)
Sets the tooltip text for the item.
XTPTaskPanelItemType | GetType () const
Gets the type of the item.
void | SetType (XTPTaskPanelItemType typeItem)
Sets the type for the item.
CString | GetCaption () const
Gets the caption of the item.
CString | GetTooltip () const
Gets the tooltip text of the item.
BOOL | GetEnabled () const
Determines if the item is enabled/disabled.
void | SetEnabled (BOOL bEnabled)
Enables/disables the item.
CXTPTaskPanelPaintManager * | GetPaintManager () const
Gets the paint manager.
BOOL | IsItemHot () const
Determines if the item is hot.
BOOL | IsItemPressed () const
Determines if the item is pressed.
BOOL | IsItemFocused () const
Determines if the item is focused.
BOOL | IsItemDragging () const
Determines if the item is being dragged.
BOOL | IsItemDragOver () const
Determines if another item is being dragged over this item.
BOOL | IsGroup () const
Determines if the item is a group.
void | RedrawPanel (BOOL bAnimate=FALSE) const
Redraws the parent Task Panel control.
void | SetIconIndex (int nIndex)
Sets the icon index for the item.
int | GetIconIndex () const
Gets the icon index of the item.
CXTPImageManagerIcon * | GetImage (int nWidth) const
Retrieves the image of the item.
HGLOBAL | CacheGlobalData ()
Stores information to HGLOBAL about the group item being dragged.
void | Remove ()
Removes this item from the array of items.
BOOL | IsVisible () const
Determines if the item is shown/hidden.
void | SetVisible (BOOL bVisible)
Shows/hides the item.
void | RepositionPanel () const
Repositions the groups in the Task Panel control.
CXTPTaskPanelItems * | GetParentItems () const
Gets the parent collection of items that this item belongs to.
virtual CXTPTaskPanelGroup * | GetItemGroup () const
Gets the group that this item belongs to.
int | GetIndex () const
Gets the index of this item within the parent collection of items.
BOOL | IsAllowDrop () const
Determines if dropping is enabled/disabled for this item.
void | AllowDrop (BOOL bAllowDrop)
Enables/disables dropping for this item.
void | AllowDrag (long nAllowDrag=xtpTaskItemAllowDragDefault)
Specifies the drag options for the item.
long | IsAllowDrag () const
Determines if this item can be dragged.
CFont * | GetItemFont () const
Gets the item font (i.e.
void | SetItemFont (LOGFONT *pLogFont)
Sets the item font (i.e.
void | SetTextRect (CDC *pDC, CRect rc, UINT nFormat)
Sets the bounding rectangle for the caption text of the item.
CRect | GetTextRect (UINT *pFormat=0) const
Gets the bounding rectangle of the caption text of the item.
DWORD_PTR | GetItemData () const
Gets the application-supplied, 32-bit value associated with the item.
void | SetItemData (DWORD_PTR dwData)
Sets the 32-bit value associated with the item.
CRect & | GetIconPadding ()
Retrieves the icon padding of the item.
CXTPMarkupUIElement * | GetMarkupUIElement () const
Gets the Markup element that renders the caption of the item.
virtual CSize | GetCaptionTextSize (CDC *pDC, CRect rc, UINT nFormat)
This method is called to calculate boundary rectangle to fit caption.
virtual void | DrawCaptionText (CDC *pDC, CRect rc, UINT nFormat)
This method is called to draw caption text.
void | CopyToClipboard ()
Copies this item to the clipboard.
void | EnsureVisible ()
Ensures that the item is visible in the Task Panel.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

int | CalcInsideHeight ()
Calculates the height, in pixels, of the available area that can be used to draw the active group if the behaviour of the Task Panel is not set to Windows Explorer.
virtual void | OnCalcClientHeight (CDC *pDC, CRect rc)
This method is called to calculate the group client area required to display all items.
void | OnRemoved ()
This method is called when the group is removed from the parent groups collection.
- Protected Member Functions inherited from CXTPTaskPanelItem
CXTPTaskPanelItem ()
Constructs a CXTPTaskPanelItem object.
virtual void | OnInserted ()
This method is called when an item is added to the parent items collection.

Protected Attributes

CRect | m_rcGroupTarget
Target rectangle of the group during animation.
CRect | m_rcGroupCurrent
Current rectangle of the group during animation.
CRect | m_rcMarginsOuter
Outer margins.
CRect | m_rcMarginsInner
Inner margins.
int | m_nCaptionHeight
Height of the caption.
BOOL | m_bSpecial
TRUE if the group is special.
BOOL | m_bExpandable
TRUE if the group is expandable.
BOOL | m_bExpanded
TRUE if the group is expanded.
BOOL | m_bExpanding
TRUE if the group is expanding.
int | m_nExpandedClientHeight
Expanded client height.
int | m_nMinClientHeight
Minimum client height.
BOOL | m_bCaptionVisible
TRUE if the caption is visible.
int | m_nScrollOffset
Scroll offset of the group.
int | m_nItemsInRow
Number of group items in a row when using the xtpTaskPanelBehaviourToolbox XTPTaskPanelBehaviour.
CSize | m_szItemIcon
Size of group item icons.
CXTPTaskPanelGroupItems * | m_pItems
Collection of items.
XTPTaskPanelItemLayout | m_itemLayout
Currently set layout for the group.
int | m_nBackgroundImage
Index of the background image for the group within the image manager.
int | m_nBackgroundAlignemnt
Alignment of the background image for the group.
- Protected Attributes inherited from CXTPTaskPanelItem
CXTPTaskPanel * | m_pPanel
Parent Task Panel.
CString | m_strCaption
Caption of the item.
CString | m_strTooltip
Tooltip of the item.
UINT | m_nID
Identifier of the item.
XTPTaskPanelItemType | m_typeItem
Type of the item.
CXTPTaskPanelItems * | m_pItems
Collection of child items.
int | m_nIconIndex
Icon index.
BOOL | m_bEnabled
TRUE if the item is enabled.
BOOL | m_bAllowDrop
TRUE if the item can be dragged.
long | m_nAllowDrag
TRUE if the item can be dropped.
CRect | m_rcText
Size and location of the caption text of the item.
UINT | m_nTextFormat
Format of the caption text of the item.
BOOL | m_bVisible
TRUE if the item is visible.
CRect | m_rcIconPadding
Padding/spacing placed around the item icon.
DWORD_PTR | m_dwData
The 32-bit value associated with the item.
CXTPFont | m_xtpFontItem
Font of the item.
CXTPMarkupUIElement * | m_pMarkupUIElement
Markup element that renders caption.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPTaskPanelItem
static CXTPTaskPanelItem *AFX_CDECL | CreateFromOleData (COleDataObject *pDataObject)
Restores a specified COleDataSource object.
static CXTPTaskPanelItem *AFX_CDECL | CreateFromOleFile (CFile *pDataObject)
Restores the COleDataSource object contained within a specified CFile object.
static CXTPTaskPanelItem *AFX_CDECL | PasteFromClipboard ()
Gets the last item placed in the clipboard.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

CXTPTaskPanelGroup is used in a Task Panel control to represent a group.

Constructor & Destructor Documentation

◆ CXTPTaskPanelGroup()

CXTPTaskPanelGroup ( CXTPTaskPanel * pPanel = NULL )

Constructs a CXTPTaskPanelGroup object.

Parameters
pPanel Pointer to the parent Task Panel.

Member Function Documentation

◆ AddControlItem()

CXTPTaskPanelGroupItem * AddControlItem ( HWND hWnd )

Adds a control item to the group.

Parameters
hWnd Window handle of the item.
Returns
A pointer to the newly added control item.

◆ AddLinkItem() [1/2]

CXTPTaskPanelGroupItem * AddLinkItem | ( | UINT | nID,
 |  | int | nImage = -1 )

Adds a link item to the group.

Parameters
nID | Identifier of the link item to be added.
nImage | Image index in the Task Panel image list.
Returns
A pointer to the newly added link item.

◆ AddLinkItem() [2/2]

CXTPTaskPanelGroupItem * AddLinkItem | ( | UINT | nID,
 |  | LPCTSTR | lpCaption,
 |  | LPCTSTR | lpTooltip = NULL,
 |  | int | nImage = -1 )

Adds a link item to the group.

Parameters
nID | Identifier of the link item to be added.
lpCaption | Caption of the item.
lpTooltip | Tooltip of the item.
nImage | Image index in the Task Panel image list.
Returns
A pointer to the newly added link item.

◆ AddTextItem()

CXTPTaskPanelGroupItem * AddTextItem ( LPCTSTR strText )

Adds a text item to the group.

Parameters
strText Text of the item.
Returns
A pointer to the newly added text item.

◆ CalcInsideHeight()

int CalcInsideHeight ( )
protected

Calculates the height, in pixels, of the available area that can be used to draw the active group if the behaviour of the Task Panel is not set to Windows Explorer.

Returns
The height, in pixels, of the available area that can be used to draw the active group.
See also
OnCalcClientHeight

◆ DoPropExchange()

virtual void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Reads/writes this object from/to an archive.

Parameters
pPX Pointer to a CXTPPropExchange object to serialize to/from.

Reimplemented from CXTPTaskPanelItem.

◆ EnsureVisible()

void EnsureVisible | ( | CXTPTaskPanelGroupItem * | pItem,
 |  | BOOL | bUpdateScrollButtons = TRUE )

Ensures that a specified group item is visible in the Task Panel.

Parameters
pItem | Pointer to the group item to ensure the visibility of.
bUpdateScrollButtons | TRUE to update scroll buttons, otherwise FALSE.

This method will scroll the task panel and the group that the item is within until the item is visible.

◆ FindItem()

CXTPTaskPanelGroupItem * FindItem ( int nID ) const

Retrieves the group item with a specified identifier.

Parameters
nID Identifier of the item to retrieve.
Returns
A pointer to the group item with the specified identifier if successful, otherwise NULL.

◆ GetAt()

CXTPTaskPanelGroupItem * GetAt ( int nIndex ) const

Retrieves the group item at a specified index in the collection of group items.

Parameters
nIndex Zero-based index of the group item to retrieve.
Returns
A pointer to the group item at the specified index in the collection of group items.

◆ GetCaptionHeight()

AFX_INLINE int GetCaptionHeight ( ) const

Gets the height of the group caption.

Returns
The height of the group caption.

◆ GetCaptionRect()

CRect GetCaptionRect ( ) const

Gets the rectangle of the caption.

Returns
The rectangle of the caption.

◆ GetClientRect()

CRect GetClientRect ( ) const

Gets the rectangle of the client.

Returns
The rectangle of the client.

◆ GetExpandedClientHeight()

AFX_INLINE int GetExpandedClientHeight ( ) const

Gets the client height of the expanded group.

Returns
The client height of the expanded group.

◆ GetHitTestRect()

virtual CRect GetHitTestRect ( ) const
virtual

Gets the rectangle of the "tooltip zone".

Returns
The rectangle of the "tooltip zone".

The "tooltip zone" is the area where the tooltip will be displayed when the mouse is positioned over the group caption.

See also
CXTPTaskPanelGroupItem::GetHitTestRect

Reimplemented from CXTPTaskPanelItem.

◆ GetInnerMargins()

AFX_INLINE CRect & GetInnerMargins ( )

Gets the inner margins of the group.

Returns
A reference to the inner margins of the group.

◆ GetInvalidateRect()

virtual CRect GetInvalidateRect ( ) const
virtual

Gets the rectangle of the "drawing zone".

Returns
The rectangle of the "drawing zone".
See also
CXTPTaskPanelGroupItem::GetHitTestRect

Reimplemented from CXTPTaskPanelItem.

◆ GetItemCount()

int GetItemCount ( ) const

Gets the number of items in the group.

Returns
The number of items in the group.

◆ GetItemIconSize()

CSize GetItemIconSize ( ) const

Gets the size of group item icons.

Returns
The size of group item icons.
See also
SetItemIconSize

◆ GetItemLayout()

XTPTaskPanelItemLayout GetItemLayout ( ) const

Gets the item layout of the group.

Returns
The item layout of the group; one of the values defined by the XTPTaskPanelItemLayout enumeration.

Item layouts include text only, image only, image and text, and image with text below the image.

◆ GetItems()

AFX_INLINE CXTPTaskPanelItems * GetItems ( ) const

Gets the collection of group items.

Returns
A pointer to the collection of group items.

◆ GetItemsInRow()

AFX_INLINE int GetItemsInRow ( ) const

Gets the number of group items per row in the group.

Returns
The number of group items per row in the group.
See also
If the Task Panel behaviour is set to xtpTaskPanelBehaviourExplorer or xtpTaskPanelBehaviourList, then the number of group items per row in the group will always be one unless the Task Panel layout is set to xtpTaskItemLayoutImages.

If the Task Panel behavior is set to xtpTaskPanelBehaviourToolbox, then there can be multiple group items per row in the group.

See also
XTPTaskPanelBehaviour, XTPTaskPanelItemLayout, Scroll

◆ GetMinimumClientHeight()

int GetMinimumClientHeight ( ) const

Gets the minimum client height of the group.

Returns
The minimum client height of the group.

◆ GetNextVisibleItem()

CXTPTaskPanelGroupItem * GetNextVisibleItem | ( | int | nIndex,
 |  | int | nDirection = +1 ) const

Retrieves the index of the next/previous visible item in this group from a specified index.

Parameters
nIndex | Index to begin search.
nDirection | Direction to search in (+1 for next, -1 for previous).
Returns
A pointer to the next/previous visible item in this group from the specified index if successful, otherwise NULL.

◆ GetOffsetItem()

int GetOffsetItem ( ) const

Gets the index of the first visible item in the group.

Returns
The index of the first visible item in the group.
See also
GetScrollOffsetPos, Scroll, GetItemCount, GetItemsInRow

◆ GetOuterMargins()

AFX_INLINE CRect & GetOuterMargins ( )

Gets the outer margins of the group.

Returns
A reference to the outer margins of the group.

◆ GetScrollOffsetPos()

int GetScrollOffsetPos ( ) const

Gets the scroll offset of the first visible item in the group.

Returns
The scroll offset of the first visible item in the group.

The scroll offset is the height, in pixels, that has been scrolled.

See also
Scroll, GetOffsetItem, GetItemCount, GetItemsInRow

◆ GetTargetCaptionRect()

CRect GetTargetCaptionRect ( ) const

Gets the target rectangle of the caption.

Returns
The target rectangle of the caption.

◆ GetTargetClientRect()

CRect GetTargetClientRect ( ) const

Gets the target rectangle of the client.

Returns
The target rectangle of the client.

◆ HitTest()

CXTPTaskPanelGroupItem * HitTest | ( | CPoint | pt,
 |  | CRect * | lpRect = 0 ) const

Determines which group item, if any, is at a specified point.

Parameters
pt | Point to be tested.
lpRect | Pointer to a CRect object to receive the bounding rectangle of the item. Can be NULL if the bounding rectangle does not need to be retrieved.
Returns
A pointer to the group item at the specified point, if any, otherwise NULL.

◆ IsAcceptFocus()

BOOL IsAcceptFocus ( ) const
virtual

Determines if the group can accept focus.

Returns
TRUE if the group can accept focus, otherwise FALSE.

Reimplemented from CXTPTaskPanelItem.

◆ IsCaptionVisible()

BOOL IsCaptionVisible ( ) const

Determines if the caption of the group is shown/hidden.

Returns
TRUE if the caption of the group is shown, FALSE if the caption of the group is hidden.
See also
ShowCaption

◆ IsChildItemDragOver()

BOOL IsChildItemDragOver ( ) const

Determines if the item currently being dragged over the group is a child item of the group.

Returns
TRUE if the item is a child item of the group, otherwise FALSE.

This method is used in the paint manager to determine if an inverted rectangle must be drawn for the item. An inverted rectangle is only drawn when the theme of the Task Panel control is Visual Studio 2003.

See also
XTPTaskPanelPaintTheme, CXTPTaskPanelToolboxTheme::DrawGroupCaption

◆ IsDirty()

BOOL IsDirty ( ) const

Determines if the group position is "dirty" (i.e.

moving during animation).

Returns
TRUE if the group position is "dirty", otherwise FALSE.
See also
CXTPTaskPanel::AnimateGroups, CXTPTaskPanel::SetAnimation, CXTPTaskPanel::GetAnimation, OnAnimate, m_rcGroupTarget, m_rcGroupCurrent

◆ IsExpandable()

BOOL IsExpandable ( ) const

Gets the expandable state of the group.

Returns
TRUE if the group is expandable, otherwise FALSE.

◆ IsExpanded()

BOOL IsExpanded ( ) const

Determines if the group is expanded/collapsed.

Returns
TRUE if the group is expanded, FALSE if the group is collapsed.
See also
SetExpanded, CXTPTaskPanel::AnimateGroups, CXTPTaskPanel::SetAnimation, CXTPTaskPanel::GetAnimation, IsDirty, IsExpanding

◆ IsExpanding()

BOOL IsExpanding ( ) const

Determines if the group is expanding.

Returns
TRUE is group is expanding, otherwise FALSE.
See also
SetExpanded, CXTPTaskPanel::AnimateGroups, CXTPTaskPanel::SetAnimation, CXTPTaskPanel::GetAnimation, IsDirty, IsExpanded

◆ IsItemVisible()

BOOL IsItemVisible | ( | CXTPTaskPanelGroupItem * | pItem,
 |  | BOOL | bAllowPart ) const

Determines if a specified item is visible in the group.

Parameters
pItem | Pointer to the group item to test.
bAllowPart | TRUE to allow the item to be partially visible, FALSE otherwise.
Returns
TRUE if the specified item is visible in the group, otherwise FALSE.

◆ IsScrollButtonEnabled()

BOOL IsScrollButtonEnabled ( BOOL bScrollButtonUp ) const

Determines if a specified group scroll button is enabled/disabled.

Parameters
bScrollButtonUp TRUE to check if the group Up scroll button is enabled, FALSE to check if the group Down scroll button is enabled.
Returns
TRUE if the specified group scroll button is enabled, FALSE if the specified group scroll button is disabled.

CXTPTaskPanel::UpdateScrollButtons uses this method to update the state of the scroll buttons.

◆ IsSpecialGroup()

BOOL IsSpecialGroup ( ) const

Determines if the group is special.

Returns
TRUE if the group is special, otherwise FALSE.

If a group is special, then it will be displayed in a different color than normal groups to draw the user's attention to that group. Setting a group to special is an excellent way to show the user the "default" or important items.

◆ OnAnimate()

void OnAnimate ( int nStep )

This method is called when an animation step is executed.

Parameters
nStep Animation step that was executed.

CXTPTaskPanel::AnimateGroups, CXTPTaskPanel::SetAnimation, CXTPTaskPanel::GetAnimation, IsDirty, OnReposition

◆ OnCalcClientHeight()

virtual void OnCalcClientHeight | ( | CDC * | pDC,
 |  | CRect | rc )
 protectedvirtual

This method is called to calculate the group client area required to display all items.

Parameters
pDC | Pointer to a valid device context.
rc | Bounding rectangle of the Task Panel group.
See also
CalcInsideHeight

◆ OnFillClient()

virtual void OnFillClient | ( | CDC * | pDC,
 |  | CRect | rc )
 virtual

This method is called when the Task Panel group client face is drawn.

Parameters
pDC | Pointer to a valid device context.
rc | CRect object specifying the size of the area.

This method is called by CXTPTaskPanelPaintManager::DrawGroupClientFace to fill the group client face.

This method determines if a bitmap should be drawn in the lower right corner of the group and will draw the bitmap if a bitmap was added. A bitmap can be added with SetClientBitmap.

See also
SetClientBitmap

◆ OnPaint()

void OnPaint ( CDC * pDC )

This method is called to draw the group.

Parameters
pDC Pointer to the client device context.

OnPaint calls CXTPTaskPanelPaintManager::DrawGroupCaption and CXTPTaskPanelPaintManager::DrawGroupClient.

◆ OnReposition()

CRect OnReposition | ( | CRect | rc,
 |  | BOOL | bRecalcOnly = TRUE )

This method is called when the group is repositioned.

Parameters
rc | New position of the group.
bRecalcOnly | TRUE to recalculate without repositioning.
Returns
The target location of the group.

Groups must be repositioned during animation. This method will retrieve the target location of the group.

CXTPTaskPanel::AnimateGroups, CXTPTaskPanel::SetAnimation, CXTPTaskPanel::GetAnimation, IsDirty, OnAnimate

◆ Scroll()

void Scroll ( int nDelta )

Scrolls to the item at a specified scroll offset in the group when the group has scroll buttons.

Parameters
nDelta Offset of the item to be scrolled to.

The scroll offset begins at zero and remains at zero until the view of the group is too small to display all items.

If the group is scrolled, then the offset will increment by one for each item that is scrolled from the top unless there is more than one item in a row. If there is more than one item in a row, then the offset will increment by GetItemsInRow instead.

GetItemCount and GetOffsetItem can be used to determine which item to scroll to.

Setting nDelta to 0 will scroll to the top of the group.

See also
GetScrollOffsetPos, GetOffsetItem, GetItemCount, GetItemsInRow

◆ SetClientBitmap()

void SetClientBitmap | ( | UINT | nID,
 |  | COLORREF | clrTransparent,
 |  | int | nBackgroundAlignment = DT_RIGHT|DT_BOTTOM )

Sets the client bitmap for the group.

Parameters
nID | Bitmap resource identifier.
clrTransparent | Color in the bitmap to make transparent.
nBackgroundAlignment | Alignment of the bitmap.

The bitmap will always be in the lower right corner of the group and will not move. The bitmap is drawn in the group by OnFillClient.

See also
OnFillClient

◆ SetExpandable()

void SetExpandable ( BOOL bExpandable )

Sets the expandable state for the group.

Parameters
bExpandable TRUE to set the group to expandable, FALSE otherwise.

◆ SetExpanded()

void SetExpanded ( BOOL bExpanded )

Expands/collapses the group.

Parameters
bExpanded TRUE to expand the group, FALSE to collapse the group.
See also
CXTPTaskPanel::AnimateGroups, CXTPTaskPanel::SetAnimation, CXTPTaskPanel::GetAnimation, IsDirty, IsExpanding, IsExpanded

◆ SetIconSize()

void SetIconSize ( CSize szItemIcon )

Sets the size for group item icons.

Parameters
szItemIcon Size to be set.
See also
GetItemIconSize

◆ SetItemLayout()

void SetItemLayout ( XTPTaskPanelItemLayout itemLayout )

Sets the item layout for the group.

Parameters
itemLayout Item layout to be set; must be one of the values defined by the XTPTaskPanelItemLayout enumeration.

Item layouts include text only, image only, image and text, and image with text below the image.

This method only applies to this group.

◆ SetMinimumClientHeight()

void SetMinimumClientHeight ( int nMinClientHeight )

Sets the minimum client height for the group.

Parameters
nMinClientHeight Minimum client height to be set.

◆ SetOffsetItem()

void SetOffsetItem | ( | int | nScrollOffset,
 |  | BOOL | bUpdateScrollButtons = TRUE )

Sets the index for the first visible item in the group.

Parameters
nScrollOffset | Index to be set.
bUpdateScrollButtons | TRUE to update scroll buttons, otherwise FALSE.

◆ SetSelectedItem()

void SetSelectedItem ( CXTPTaskPanelGroupItem * pItem )

Selects a specified group item.

Parameters
pItem Pointer to the group item to be selected.

Selected items will appear either "pressed" or "highlighted" depending on the selected theme.

Multiple items can have focus. See CXTPTaskPanel::SetSelectItemOnFocus for details.

See also
XTPTaskPanelGroupItem::IsItemSelected, XTPTaskPanelGroupItem::SetItemSelected, CXTPTaskPanel::SetSelectItemOnFocus

◆ SetSpecialGroup()

void SetSpecialGroup ( BOOL bSpecial = TRUE )

Specifies if the group should be special.

Parameters
bSpecial TRUE to set the group to special, FALSE otherwise.

If a group is special, then it will be displayed in a different color than normal groups to draw the user's attention to that group. Setting a group to special is an excellent way to show the user the "default" or important items.

◆ ShowCaption()

void ShowCaption ( BOOL bShow )

Shows/hides the caption of the group.

Parameters
bShow TRUE to show the caption of the group, FALSE to hide the caption of the group.

Member Data Documentation

◆ m_nItemsInRow

int m_nItemsInRow
protected

Number of group items in a row when using the xtpTaskPanelBehaviourToolbox XTPTaskPanelBehaviour.

For all other behaviors, it will only be 1 unless the layout is set to to xtpTaskPanelBehaviourExplorer or xtpTaskPanelBehaviourList.

◆ m_nScrollOffset

int m_nScrollOffset
protected

Scroll offset of the group.

Only applies if the task panel behavior is set to xtpTaskPanelBehaviourList or xtpTaskPanelBehaviourToolbox.

The documentation for this class was generated from the following file:
  • XTPTaskPanelGroup.h


Toolkit Pro: CXTPTaskPanelGroupItem Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPTaskPanelGroupItem Class Reference

CXTPTaskPanelGroupItem is used in a TaskPanel control to represent a single item of a group. More...

Inheritance diagram for CXTPTaskPanelGroupItem:
[legend]

Public Member Functions

CXTPTaskPanelGroupItem ()
Constructs a CXTPTaskPanelGroupItem object.
virtual | ~CXTPTaskPanelGroupItem ()
Destroys a CXTPTaskPanelGroupItem object, handles cleanup and deallocation.
virtual CRect | OnReposition (CRect rc)
This method is called when the group item must be repositioned.
virtual void | OnDrawItem (CDC *pDC, CRect rc)
This method is called to draw the group item.
CRect & | GetMargins ()
Gets the margins of the group item.
CRect | GetItemRect () const
Gets the bounding rectangle of the group item.
void | SetItemRect (LPCRECT lpRect)
Sets the bounding rectangle for the group item.
CXTPTaskPanelGroup * | GetItemGroup () const
Gets the parent group of the item.
void | SetBold (BOOL bBold=TRUE)
Enables/disables bold font for the group item.
BOOL | IsBold () const
Determines if bold font is enabled/disabled for the group item.
void | SetControlHandle (HWND hWnd)
Sets the window handle for the group item.
HWND | GetControlHandle () const
Gets the window handle of the group item.
void | OnAnimate (int nStep)
This method is called when an animation step is executed.
void | SetSize (CSize szItem, BOOL bAutoHeight=FALSE)
Sets the size of the group item.
COLORREF | GetBackColor () const
Gets the backcolor of the group item.
COLORREF | GetTextColor () const
Gets the text color of the group item.
void | SetTextColor (COLORREF clrText)
Sets the text color for the group item.
CRect | GetHitTestRect () const
Gets the rectangle of the "tooltip zone".
BOOL | IsItemSelected () const
Gets the selected state of the group item.
void | SetItemSelected (BOOL bSelected)
Sets the selected state of the group item.
virtual void | DoPropExchange (CXTPPropExchange *pPX)
Reads/writes this object from/to an archive.
void | SetDragText (LPCTSTR lpszDragText)
Sets the drag text for the group item.
virtual CString | GetDragText () const
Gets the drag text of the group item.
BOOL | PrepareDrag (COleDataSource &srcItem, BOOL bCacheTextData=TRUE)
Caches the COleDataSource object containing the group item being dragged.
CSize | GetSize () const
Gets the size of the group item.
BOOL | IsAutoHeight () const
Determines if auto-height is enabled/disabled for the group item.
- Public Member Functions inherited from CXTPTaskPanelItem
virtual | ~CXTPTaskPanelItem ()
Destroys a CXTPTaskPanelItem object, handles cleanup and deallocation.
CXTPTaskPanel * | GetTaskPanel () const
Gets the parent Task Panel control.
void | SetID (UINT nID)
Sets the identifier for the item.
void | SetID (UINT nID, LPCTSTR lpCaption, LPCTSTR lpTooltip=NULL)
Sets the identifier for the item.
UINT | GetID () const
Gets the identifier of the item.
BOOL | IsDroppedOff () const
Call this method to get the identifier of the item.
void | SetCaption (LPCTSTR lpszCaption)
Sets the caption for the item.
void | SetTooltip (LPCTSTR lpszTooltip)
Sets the tooltip text for the item.
XTPTaskPanelItemType | GetType () const
Gets the type of the item.
void | SetType (XTPTaskPanelItemType typeItem)
Sets the type for the item.
CString | GetCaption () const
Gets the caption of the item.
CString | GetTooltip () const
Gets the tooltip text of the item.
BOOL | GetEnabled () const
Determines if the item is enabled/disabled.
void | SetEnabled (BOOL bEnabled)
Enables/disables the item.
CXTPTaskPanelPaintManager * | GetPaintManager () const
Gets the paint manager.
BOOL | IsItemHot () const
Determines if the item is hot.
BOOL | IsItemPressed () const
Determines if the item is pressed.
BOOL | IsItemFocused () const
Determines if the item is focused.
BOOL | IsItemDragging () const
Determines if the item is being dragged.
BOOL | IsItemDragOver () const
Determines if another item is being dragged over this item.
BOOL | IsGroup () const
Determines if the item is a group.
void | RedrawPanel (BOOL bAnimate=FALSE) const
Redraws the parent Task Panel control.
void | SetIconIndex (int nIndex)
Sets the icon index for the item.
int | GetIconIndex () const
Gets the icon index of the item.
virtual BOOL | IsAcceptFocus () const
Determines if the item can be focused.
CXTPImageManagerIcon * | GetImage (int nWidth) const
Retrieves the image of the item.
HGLOBAL | CacheGlobalData ()
Stores information to HGLOBAL about the group item being dragged.
void | Remove ()
Removes this item from the array of items.
BOOL | IsVisible () const
Determines if the item is shown/hidden.
void | SetVisible (BOOL bVisible)
Shows/hides the item.
void | RepositionPanel () const
Repositions the groups in the Task Panel control.
CXTPTaskPanelItems * | GetParentItems () const
Gets the parent collection of items that this item belongs to.
int | GetIndex () const
Gets the index of this item within the parent collection of items.
BOOL | IsAllowDrop () const
Determines if dropping is enabled/disabled for this item.
void | AllowDrop (BOOL bAllowDrop)
Enables/disables dropping for this item.
void | AllowDrag (long nAllowDrag=xtpTaskItemAllowDragDefault)
Specifies the drag options for the item.
long | IsAllowDrag () const
Determines if this item can be dragged.
CFont * | GetItemFont () const
Gets the item font (i.e.
void | SetItemFont (LOGFONT *pLogFont)
Sets the item font (i.e.
void | SetTextRect (CDC *pDC, CRect rc, UINT nFormat)
Sets the bounding rectangle for the caption text of the item.
CRect | GetTextRect (UINT *pFormat=0) const
Gets the bounding rectangle of the caption text of the item.
virtual CRect | GetInvalidateRect () const
Gets the rectangle of the "drawing zone".
DWORD_PTR | GetItemData () const
Gets the application-supplied, 32-bit value associated with the item.
void | SetItemData (DWORD_PTR dwData)
Sets the 32-bit value associated with the item.
CRect & | GetIconPadding ()
Retrieves the icon padding of the item.
CXTPMarkupUIElement * | GetMarkupUIElement () const
Gets the Markup element that renders the caption of the item.
virtual CSize | GetCaptionTextSize (CDC *pDC, CRect rc, UINT nFormat)
This method is called to calculate boundary rectangle to fit caption.
virtual void | DrawCaptionText (CDC *pDC, CRect rc, UINT nFormat)
This method is called to draw caption text.
void | CopyToClipboard ()
Copies this item to the clipboard.
void | EnsureVisible ()
Ensures that the item is visible in the Task Panel.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Attributes

CRect | m_rcMargins
Item's margins.
CRect | m_rcItem
Rectangle of the item.
BOOL | m_bBold
TRUE to use bold font.
BOOL | m_bSelected
TRUE if the item is currently selected.
HWND | m_hWnd
Only used for items of type xtpTaskItemTypeControl; this is the control's child window.
CSize | m_szItem
Size of the item.
CBitmap | m_bmpPreview
Internally used.
CSize | m_szPreview
Last preview bitmap size.
CString | m_strDragText
Drag text of the item.
BOOL | m_bAutoHeight
TRUE if the item stretched inside its group.
COLORREF | m_clrText
Text color.
- Protected Attributes inherited from CXTPTaskPanelItem
CXTPTaskPanel * | m_pPanel
Parent Task Panel.
CString | m_strCaption
Caption of the item.
CString | m_strTooltip
Tooltip of the item.
UINT | m_nID
Identifier of the item.
XTPTaskPanelItemType | m_typeItem
Type of the item.
CXTPTaskPanelItems * | m_pItems
Collection of child items.
int | m_nIconIndex
Icon index.
BOOL | m_bEnabled
TRUE if the item is enabled.
BOOL | m_bAllowDrop
TRUE if the item can be dragged.
long | m_nAllowDrag
TRUE if the item can be dropped.
CRect | m_rcText
Size and location of the caption text of the item.
UINT | m_nTextFormat
Format of the caption text of the item.
BOOL | m_bVisible
TRUE if the item is visible.
CRect | m_rcIconPadding
Padding/spacing placed around the item icon.
DWORD_PTR | m_dwData
The 32-bit value associated with the item.
CXTPFont | m_xtpFontItem
Font of the item.
CXTPMarkupUIElement * | m_pMarkupUIElement
Markup element that renders caption.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPTaskPanelItem
static CXTPTaskPanelItem *AFX_CDECL | CreateFromOleData (COleDataObject *pDataObject)
Restores a specified COleDataSource object.
static CXTPTaskPanelItem *AFX_CDECL | CreateFromOleFile (CFile *pDataObject)
Restores the COleDataSource object contained within a specified CFile object.
static CXTPTaskPanelItem *AFX_CDECL | PasteFromClipboard ()
Gets the last item placed in the clipboard.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Member Functions inherited from CXTPTaskPanelItem
CXTPTaskPanelItem ()
Constructs a CXTPTaskPanelItem object.
virtual void | OnRemoved ()
This method is called when an item is removed from the parent items collection.
virtual void | OnInserted ()
This method is called when an item is added to the parent items collection.

Detailed Description

CXTPTaskPanelGroupItem is used in a TaskPanel control to represent a single item of a group.

Member Function Documentation

◆ DoPropExchange()

virtual void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Reads/writes this object from/to an archive.

Parameters
pPX Pointer to a CXTPPropExchange object to serialize to/from.

Reimplemented from CXTPTaskPanelItem.

◆ GetBackColor()

COLORREF GetBackColor ( ) const

Gets the backcolor of the group item.

Returns
The backcolor of the group item.

◆ GetControlHandle()

HWND GetControlHandle ( ) const

Gets the window handle of the group item.

Returns
The window handle of the group item.

◆ GetDragText()

virtual CString GetDragText ( ) const
virtual

Gets the drag text of the group item.

Returns
The drag text of the group item.

◆ GetHitTestRect()

CRect GetHitTestRect ( ) const
virtual

Gets the rectangle of the "tooltip zone".

Returns
The rectangle of the "tooltip zone".

The "tooltip zone" is the area where the tooltip will be displayed when the mouse is positioned over the group item.

See also
CXTPTaskPanelGroup::GetHitTestRect

Reimplemented from CXTPTaskPanelItem.

◆ GetItemGroup()

CXTPTaskPanelGroup * GetItemGroup ( ) const
virtual

Gets the parent group of the item.

Returns
A pointer to the parent group of the item.

Reimplemented from CXTPTaskPanelItem.

◆ GetItemRect()

AFX_INLINE CRect GetItemRect ( ) const

Gets the bounding rectangle of the group item.

Returns
The bounding rectangle of the group item.

◆ GetMargins()

AFX_INLINE CRect & GetMargins ( )

Gets the margins of the group item.

Returns
A reference to the margins of the group item.

◆ GetSize()

AFX_INLINE CSize GetSize ( ) const

Gets the size of the group item.

Returns
The size of the group item.
See also
SetSize

◆ GetTextColor()

AFX_INLINE COLORREF GetTextColor ( ) const

Gets the text color of the group item.

Returns
The text color of the group item.

◆ IsAutoHeight()

AFX_INLINE BOOL IsAutoHeight ( ) const

Determines if auto-height is enabled/disabled for the group item.

Returns
TRUE if auto-height is enabled, FALSE if auto-height is disabled.

If auto-height is enabled, then the height of the group item will be stretched to fill the entire height of the group. If auto-height is disabled, then the group item will use a defined height.

◆ IsBold()

BOOL IsBold ( ) const

Determines if bold font is enabled/disabled for the group item.

Returns
TRUE if bold font is enabled, FALSE if bold font is disabled.

◆ IsItemSelected()

BOOL IsItemSelected ( ) const

Gets the selected state of the group item.

Multiple group items can be selected at a given time. However, only one group item can have focus at a given time.

Returns
TRUE if the group item is selected, otherwise FALSE.

◆ OnAnimate()

void OnAnimate ( int nStep )

This method is called when an animation step is executed.

Parameters
nStep Animation step that was executed.

◆ OnDrawItem()

virtual void OnDrawItem | ( | CDC * | pDC,
 |  | CRect | rc )
 virtual

This method is called to draw the group item.

Parameters
pDC | Pointer to a valid device context.
rc | Rectangle of the group item to draw.

◆ OnReposition()

virtual CRect OnReposition ( CRect rc )
virtual

This method is called when the group item must be repositioned.

Parameters
rc Rectangle of the group item.
Returns
The updated item rectangle.

◆ PrepareDrag()

BOOL PrepareDrag | ( | COleDataSource & | srcItem,
 |  | BOOL | bCacheTextData = TRUE )

Caches the COleDataSource object containing the group item being dragged.

Parameters
srcItem | Reference to the COleDataSource object to cache.
bCacheTextData | TRUE to cache the text data of the object, FALSE otherwise.
Returns
TRUE if successful, FALSE if CacheGlobalData returns NULL.

This method places the item being dragged onto the clipboard.

See also
CreateFromOleData, CacheGlobalData, CopyToClipboard, PasteFromClipboard, PrepareDrag

◆ SetBold()

void SetBold ( BOOL bBold = TRUE )

Enables/disables bold font for the group item.

Parameters
bBold TRUE to enable bold font, FALSE to disable bold font.

◆ SetControlHandle()

void SetControlHandle ( HWND hWnd )

Sets the window handle for the group item.

Parameters
hWnd Window handle to be set.

◆ SetDragText()

void SetDragText ( LPCTSTR lpszDragText )

Sets the drag text for the group item.

Parameters
lpszDragText Drag text to be set.

◆ SetItemRect()

AFX_INLINE void SetItemRect ( LPCRECT lpRect )

Sets the bounding rectangle for the group item.

Parameters
lpRect Bounding rectangle to be set.

◆ SetItemSelected()

void SetItemSelected ( BOOL bSelected )

Sets the selected state of the group item.

Parameters
bSelected TRUE to set the group item to selected, FALSE otherwise.

Multiple items can have focus. See CXTPTaskPanel::SetSelectItemOnFocus for details.

See also
CXTPTaskPanel::SetSelectItemOnFocus

◆ SetSize()

void SetSize | ( | CSize | szItem,
 |  | BOOL | bAutoHeight = FALSE )

Sets the size of the group item.

Parameters
szItem | Group item size to be set.
bAutoHeight | TRUE to enable auto-height for the group item, FALSE to disable auto-height for the group item.

If auto-height is enabled, then the height of the group item will be stretched to fill the entire height of the group. If auto-height is disabled, then the group item will use a defined height.

See also
GetSize

◆ SetTextColor()

AFX_INLINE void SetTextColor ( COLORREF clrText )

Sets the text color for the group item.

Parameters
clrText Text color to be set.

Member Data Documentation

◆ m_bmpPreview

CBitmap m_bmpPreview
protected

Internally used.

This holds a screen shot of the attached Windows control when the item type is xtpTaskItemTypeControl. This screen shot is used during group animation. During animation, the Windows control is hidden and the screen shot of the control is used in place of the actual control during the animation process.

◆ m_szItem

CSize m_szItem
protected

Size of the item.

If the size is set to 0, then the size will be calculated by the Task Panel.

The documentation for this class was generated from the following file:
  • XTPTaskPanelGroupItem.h


Toolkit Pro: CXTPTaskPanelGroupItems Class Reference

Public Member Functions | List of all members
CXTPTaskPanelGroupItems Class Reference

CXTPTaskPanelGroupItems represents a collection of items in a group. More...

Inheritance diagram for CXTPTaskPanelGroupItems:
[legend]

Public Member Functions

CXTPTaskPanelGroupItems (CXTPTaskPanel *pPanel)
Constructs CXTPTaskPanelGroupItems object.
virtual CRuntimeClass * | GetDefaultItemClass () const
Gets the default runtime class of items in this collection.
- Public Member Functions inherited from CXTPTaskPanelItems
CXTPTaskPanelItems (CXTPTaskPanel *pPanel=NULL)
Constructs a CXTPTaskPanelItems object.
virtual | ~CXTPTaskPanelItems ()
Destroys a CXTPTaskPanelItems object, handles cleanup and deallocation.
CXTPTaskPanelItem * | Add (CXTPTaskPanelItem *pItem, UINT nID)
Adds an item to this collection.
CXTPTaskPanelItem * | Add (CXTPTaskPanelItem *pItem, UINT nID, LPCTSTR lpCaption, LPCTSTR lpTooltip=NULL)
Adds an item to this collection.
CXTPTaskPanelItem * | InsertAt (int nIndex, CXTPTaskPanelItem *pItem)
Inserts an item at a specified index in this collection.
CXTPTaskPanelItem * | GetAt (int nIndex) const
Retrieves the item at a specified index in this collection.
void | Clear (BOOL bReposition=TRUE)
Removes all items from this collection.
CXTPTaskPanelItem * | Find (UINT nID) const
Retrieves the item with a specified identifier.
void | Remove (CXTPTaskPanelItem *pItem)
Removes a specified item from this collection.
void | RemoveAt (int nIndex)
Removes the item at a specified index from this collection.
int | GetIndex (const CXTPTaskPanelItem *pItem) const
Retrieves the index of a specified item in this collection.
int | GetCount () const
Gets the number of items in this collection.
CCmdTarget * | GetOwner () const
Gets the owner.
void | Move (CXTPTaskPanelItem *pItem, int nIndex)
Moved a specified item to a specified index in this collection.
void | DoPropExchange (CXTPPropExchange *pPX)
Reads/writes this object from or/an archive.
int | GetNextVisibleIndex (int nIndex, int nDirection) const
Retrieves the index of the next/previous visible item in this collection from a specified index.
CXTPTaskPanelItem * | GetFirstVisibleItem () const
Gets the first visible item in this collection.
CXTPTaskPanelItem * | GetLastVisibleItem () const
Gets the last visible item in this collection.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Attributes inherited from CXTPTaskPanelItems
CXTPTaskPanel * | m_pPanel
Parent Task Panel control.
CArray< CXTPTaskPanelItem *, CXTPTaskPanelItem * > | m_arrItems
Array of items.
CCmdTarget * | m_pOwner
Owner of items.

Detailed Description

CXTPTaskPanelGroupItems represents a collection of items in a group.

Constructor & Destructor Documentation

◆ CXTPTaskPanelGroupItems()

CXTPTaskPanelGroupItems ( CXTPTaskPanel * pPanel )

Constructs CXTPTaskPanelGroupItems object.

Parameters
pPanel Pointer to the parent Task Panel.

Member Function Documentation

◆ GetDefaultItemClass()

virtual CRuntimeClass * GetDefaultItemClass ( ) const
virtual

Gets the default runtime class of items in this collection.

Returns
A pointer to the default runtime class of items in this collection.

Reimplemented from CXTPTaskPanelItems.

The documentation for this class was generated from the following file:
  • XTPTaskPanelItems.h


Toolkit Pro: CXTPTaskPanelGroups Class Reference

Public Member Functions | List of all members
CXTPTaskPanelGroups Class Reference

CXTPTaskPanelGroups represents a collection of groups in a Task Panel control. More...

Inheritance diagram for CXTPTaskPanelGroups:
[legend]

Public Member Functions

CXTPTaskPanelGroups (CXTPTaskPanel *pPanel)
Constructs a CXTPTaskPanelGroups object.
virtual CRuntimeClass * | GetDefaultItemClass () const
Gets the default runtime class of items in this collection.
- Public Member Functions inherited from CXTPTaskPanelItems
CXTPTaskPanelItems (CXTPTaskPanel *pPanel=NULL)
Constructs a CXTPTaskPanelItems object.
virtual | ~CXTPTaskPanelItems ()
Destroys a CXTPTaskPanelItems object, handles cleanup and deallocation.
CXTPTaskPanelItem * | Add (CXTPTaskPanelItem *pItem, UINT nID)
Adds an item to this collection.
CXTPTaskPanelItem * | Add (CXTPTaskPanelItem *pItem, UINT nID, LPCTSTR lpCaption, LPCTSTR lpTooltip=NULL)
Adds an item to this collection.
CXTPTaskPanelItem * | InsertAt (int nIndex, CXTPTaskPanelItem *pItem)
Inserts an item at a specified index in this collection.
CXTPTaskPanelItem * | GetAt (int nIndex) const
Retrieves the item at a specified index in this collection.
void | Clear (BOOL bReposition=TRUE)
Removes all items from this collection.
CXTPTaskPanelItem * | Find (UINT nID) const
Retrieves the item with a specified identifier.
void | Remove (CXTPTaskPanelItem *pItem)
Removes a specified item from this collection.
void | RemoveAt (int nIndex)
Removes the item at a specified index from this collection.
int | GetIndex (const CXTPTaskPanelItem *pItem) const
Retrieves the index of a specified item in this collection.
int | GetCount () const
Gets the number of items in this collection.
CCmdTarget * | GetOwner () const
Gets the owner.
void | Move (CXTPTaskPanelItem *pItem, int nIndex)
Moved a specified item to a specified index in this collection.
void | DoPropExchange (CXTPPropExchange *pPX)
Reads/writes this object from or/an archive.
int | GetNextVisibleIndex (int nIndex, int nDirection) const
Retrieves the index of the next/previous visible item in this collection from a specified index.
CXTPTaskPanelItem * | GetFirstVisibleItem () const
Gets the first visible item in this collection.
CXTPTaskPanelItem * | GetLastVisibleItem () const
Gets the last visible item in this collection.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Attributes inherited from CXTPTaskPanelItems
CXTPTaskPanel * | m_pPanel
Parent Task Panel control.
CArray< CXTPTaskPanelItem *, CXTPTaskPanelItem * > | m_arrItems
Array of items.
CCmdTarget * | m_pOwner
Owner of items.

Detailed Description

CXTPTaskPanelGroups represents a collection of groups in a Task Panel control.

Constructor & Destructor Documentation

◆ CXTPTaskPanelGroups()

CXTPTaskPanelGroups ( CXTPTaskPanel * pPanel )

Constructs a CXTPTaskPanelGroups object.

Parameters
pPanel Pointer to the parent Task Panel.

Member Function Documentation

◆ GetDefaultItemClass()

virtual CRuntimeClass * GetDefaultItemClass ( ) const
virtual

Gets the default runtime class of items in this collection.

Returns
A pointer to the default runtime class of items in this collection.

Reimplemented from CXTPTaskPanelItems.

The documentation for this class was generated from the following file:
  • XTPTaskPanelItems.h


Toolkit Pro: CXTPTaskPanelItem Class Reference

Public Member Functions | Static Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPTaskPanelItem Class Reference

CXTPTaskPanelItem is used in a Task Panel control to represent a single item. More...

Inheritance diagram for CXTPTaskPanelItem:
[legend]

Public Member Functions

virtual | ~CXTPTaskPanelItem ()
Destroys a CXTPTaskPanelItem object, handles cleanup and deallocation.
CXTPTaskPanel * | GetTaskPanel () const
Gets the parent Task Panel control.
void | SetID (UINT nID)
Sets the identifier for the item.
void | SetID (UINT nID, LPCTSTR lpCaption, LPCTSTR lpTooltip=NULL)
Sets the identifier for the item.
UINT | GetID () const
Gets the identifier of the item.
BOOL | IsDroppedOff () const
Call this method to get the identifier of the item.
void | SetCaption (LPCTSTR lpszCaption)
Sets the caption for the item.
void | SetTooltip (LPCTSTR lpszTooltip)
Sets the tooltip text for the item.
XTPTaskPanelItemType | GetType () const
Gets the type of the item.
void | SetType (XTPTaskPanelItemType typeItem)
Sets the type for the item.
CString | GetCaption () const
Gets the caption of the item.
CString | GetTooltip () const
Gets the tooltip text of the item.
BOOL | GetEnabled () const
Determines if the item is enabled/disabled.
void | SetEnabled (BOOL bEnabled)
Enables/disables the item.
CXTPTaskPanelPaintManager * | GetPaintManager () const
Gets the paint manager.
BOOL | IsItemHot () const
Determines if the item is hot.
BOOL | IsItemPressed () const
Determines if the item is pressed.
BOOL | IsItemFocused () const
Determines if the item is focused.
BOOL | IsItemDragging () const
Determines if the item is being dragged.
BOOL | IsItemDragOver () const
Determines if another item is being dragged over this item.
BOOL | IsGroup () const
Determines if the item is a group.
void | RedrawPanel (BOOL bAnimate=FALSE) const
Redraws the parent Task Panel control.
void | SetIconIndex (int nIndex)
Sets the icon index for the item.
int | GetIconIndex () const
Gets the icon index of the item.
virtual BOOL | IsAcceptFocus () const
Determines if the item can be focused.
CXTPImageManagerIcon * | GetImage (int nWidth) const
Retrieves the image of the item.
HGLOBAL | CacheGlobalData ()
Stores information to HGLOBAL about the group item being dragged.
void | Remove ()
Removes this item from the array of items.
BOOL | IsVisible () const
Determines if the item is shown/hidden.
void | SetVisible (BOOL bVisible)
Shows/hides the item.
void | RepositionPanel () const
Repositions the groups in the Task Panel control.
CXTPTaskPanelItems * | GetParentItems () const
Gets the parent collection of items that this item belongs to.
virtual CXTPTaskPanelGroup * | GetItemGroup () const
Gets the group that this item belongs to.
int | GetIndex () const
Gets the index of this item within the parent collection of items.
BOOL | IsAllowDrop () const
Determines if dropping is enabled/disabled for this item.
void | AllowDrop (BOOL bAllowDrop)
Enables/disables dropping for this item.
void | AllowDrag (long nAllowDrag=xtpTaskItemAllowDragDefault)
Specifies the drag options for the item.
long | IsAllowDrag () const
Determines if this item can be dragged.
CFont * | GetItemFont () const
Gets the item font (i.e.
void | SetItemFont (LOGFONT *pLogFont)
Sets the item font (i.e.
void | SetTextRect (CDC *pDC, CRect rc, UINT nFormat)
Sets the bounding rectangle for the caption text of the item.
CRect | GetTextRect (UINT *pFormat=0) const
Gets the bounding rectangle of the caption text of the item.
virtual CRect | GetHitTestRect () const
Gets the rectangle of the "tooltip zone".
virtual CRect | GetInvalidateRect () const
Gets the rectangle of the "drawing zone".
DWORD_PTR | GetItemData () const
Gets the application-supplied, 32-bit value associated with the item.
void | SetItemData (DWORD_PTR dwData)
Sets the 32-bit value associated with the item.
CRect & | GetIconPadding ()
Retrieves the icon padding of the item.
CXTPMarkupUIElement * | GetMarkupUIElement () const
Gets the Markup element that renders the caption of the item.
virtual CSize | GetCaptionTextSize (CDC *pDC, CRect rc, UINT nFormat)
This method is called to calculate boundary rectangle to fit caption.
virtual void | DrawCaptionText (CDC *pDC, CRect rc, UINT nFormat)
This method is called to draw caption text.
virtual void | DoPropExchange (CXTPPropExchange *pPX)
Reads/writes this object from/to an archive.
void | CopyToClipboard ()
Copies this item to the clipboard.
void | EnsureVisible ()
Ensures that the item is visible in the Task Panel.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Static Public Member Functions

static CXTPTaskPanelItem *AFX_CDECL | CreateFromOleData (COleDataObject *pDataObject)
Restores a specified COleDataSource object.
static CXTPTaskPanelItem *AFX_CDECL | CreateFromOleFile (CFile *pDataObject)
Restores the COleDataSource object contained within a specified CFile object.
static CXTPTaskPanelItem *AFX_CDECL | PasteFromClipboard ()
Gets the last item placed in the clipboard.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Protected Member Functions

CXTPTaskPanelItem ()
Constructs a CXTPTaskPanelItem object.
virtual void | OnRemoved ()
This method is called when an item is removed from the parent items collection.
virtual void | OnInserted ()
This method is called when an item is added to the parent items collection.

Protected Attributes

CXTPTaskPanel * | m_pPanel
Parent Task Panel.
CString | m_strCaption
Caption of the item.
CString | m_strTooltip
Tooltip of the item.
UINT | m_nID
Identifier of the item.
XTPTaskPanelItemType | m_typeItem
Type of the item.
CXTPTaskPanelItems * | m_pItems
Collection of child items.
int | m_nIconIndex
Icon index.
BOOL | m_bEnabled
TRUE if the item is enabled.
BOOL | m_bAllowDrop
TRUE if the item can be dragged.
long | m_nAllowDrag
TRUE if the item can be dropped.
CRect | m_rcText
Size and location of the caption text of the item.
UINT | m_nTextFormat
Format of the caption text of the item.
BOOL | m_bVisible
TRUE if the item is visible.
CRect | m_rcIconPadding
Padding/spacing placed around the item icon.
DWORD_PTR | m_dwData
The 32-bit value associated with the item.
CXTPFont | m_xtpFontItem
Font of the item.
CXTPMarkupUIElement * | m_pMarkupUIElement
Markup element that renders caption.

Detailed Description

CXTPTaskPanelItem is used in a Task Panel control to represent a single item.

Member Function Documentation

◆ AllowDrag()

void AllowDrag ( long nAllowDrag = xtpTaskItemAllowDragDefault )

Specifies the drag options for the item.

Parameters
nAllowDrag Drag options. See the Remarks section below for a list of available values.

The nAllowDrag parameter can be one or more of the following values: xtpTaskItemAllowDragCopyWithinGroup: To only allow the copy operation within the group. xtpTaskItemAllowDragCopyWithinControl: To only allow the copy operation within the task panel. xtpTaskItemAllowDragCopyOutsideControl: To only allow the copy operation outside the task panel. xtpTaskItemAllowDragCopy: To allow the copy operation. xtpTaskItemAllowDragMoveWithinGroup: To only allow the move operation within the group. xtpTaskItemAllowDragMoveWithinControl: To only allow the move operation within the task panel. xtpTaskItemAllowDragMoveOutsideControl: To only allow the move operation outside the task panel. xtpTaskItemAllowDragMove: To allow the move operation. xtpTaskItemAllowDragAll: To allow all drag operations.

See also
IsAllowDrag, XTPTaskPanelItemAllowDrag

◆ AllowDrop()

void AllowDrop ( BOOL bAllowDrop )

Enables/disables dropping for this item.

Parameters
bAllowDrop TRUE to enable dropping for this item, FALSE to disable dropping for this item.

◆ CacheGlobalData()

HGLOBAL CacheGlobalData ( )

Stores information to HGLOBAL about the group item being dragged.

Returns
An HGLOBAL object containing information about the group item being dragged if successful, NULL if an OLE or Archive exception was thrown while caching the data.
See also
PrepareDrag, CreateFromOleData, CopyToClipboard, PasteFromClipboard

◆ CopyToClipboard()

void CopyToClipboard ( )

Copies this item to the clipboard.

See also
PasteFromClipboard, CreateFromOleData, CacheGlobalData, PasteFromClipboard, PrepareDrag

◆ CreateFromOleData()

static CXTPTaskPanelItem *AFX_CDECL CreateFromOleData ( COleDataObject * pDataObject )
static

Restores a specified COleDataSource object.

Parameters
pDataObject Pointer to the COleDataSource object to restore.
Returns
A pointer to the item that was stored within the COleDataSource object.

This method will restore the item that was cached using the PrepareDrag method.

See also
PrepareDrag, CacheGlobalData, CopyToClipboard, PasteFromClipboard

◆ CreateFromOleFile()

static CXTPTaskPanelItem *AFX_CDECL CreateFromOleFile ( CFile * pDataObject )
static

Restores the COleDataSource object contained within a specified CFile object.

Parameters
pDataObject Pointer to the CFile object containing the COleDataSource object to restore.
Returns
A pointer to the item that was stored within the COleDataSource object.

This method will restore the item that was cached using the PrepareDrag method.

See also
PrepareDrag, CacheGlobalData, CopyToClipboard, PasteFromClipboard

◆ DoPropExchange()

virtual void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Reads/writes this object from/to an archive.

Parameters
pPX Pointer to a CXTPPropExchange object to serialize to/from.

Reimplemented in CXTPTaskPanelGroup, and CXTPTaskPanelGroupItem.

◆ DrawCaptionText()

virtual void DrawCaptionText | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | UINT | nFormat )
 virtual

This method is called to draw caption text.

Parameters
pDC | Pointer to valid device context
rc | Boundary rectangle to draw
nFormat | Format flags to draw

◆ EnsureVisible()

void EnsureVisible ( )

Ensures that the item is visible in the Task Panel.

This method will scroll the task panel and the group that the item is within until the item is visible.

◆ GetCaption()

AFX_INLINE CString GetCaption ( ) const

Gets the caption of the item.

Returns
The caption of the item.

◆ GetCaptionTextSize()

virtual CSize GetCaptionTextSize | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | UINT | nFormat )
 virtual

This method is called to calculate boundary rectangle to fit caption.

Parameters
pDC | Pointer to valid device context
rc | Boundary rectangle
nFormat | Format flags to draw
Returns
Size of caption

◆ GetEnabled()

BOOL GetEnabled ( ) const

Determines if the item is enabled/disabled.

Returns
TRUE if the item is enabled, FALSE if the item is disabled.

◆ GetHitTestRect()

virtual CRect GetHitTestRect ( ) const
virtual

Gets the rectangle of the "tooltip zone".

Returns
The base class implementation returns CRect(0, 0, 0, 0).

The CXTPTaskPanelGroupItem implementation returns the rectangle of the "tooltip zone".

The "tooltip zone" is the area where the tooltip will be displayed when the mouse is positioned over the group item.

The member is overridden in CXTPTaskPanelGroupItem.

See also
CXTPTaskPanelGroupItem::GetHitTestRect

Reimplemented in CXTPTaskPanelGroup, and CXTPTaskPanelGroupItem.

◆ GetIconIndex()

int GetIconIndex ( ) const

Gets the icon index of the item.

The icon index refers to the index of the icon within the image list of the parent Task Panel control.

Returns
The icon index of the item.

◆ GetIconPadding()

AFX_INLINE CRect & GetIconPadding ( )

Retrieves the icon padding of the item.

Returns
A reference to the icon padding of the item.

◆ GetID()

UINT GetID ( ) const

Gets the identifier of the item.

Returns
The identifier of the item.

◆ GetImage()

CXTPImageManagerIcon * GetImage ( int nWidth ) const

Retrieves the image of the item.

Parameters
nWidth Width of the icon to be retrieved (e.g. pass in a value of 16 to retrieve a 16x16 image).

CXTPImageManagerIcon can have multiple image sizes for the same item.

Returns
A pointer to the image of the item.

◆ GetIndex()

int GetIndex ( ) const

Gets the index of this item within the parent collection of items.

Returns
The index of this item within the parent collection of items.

◆ GetInvalidateRect()

virtual CRect GetInvalidateRect ( ) const
virtual

Gets the rectangle of the "drawing zone".

Returns
The rectangle of the "drawing zone".
See also
CXTPTaskPanelGroupItem::GetHitTestRect

Reimplemented in CXTPTaskPanelGroup.

◆ GetItemData()

AFX_INLINE DWORD_PTR GetItemData ( ) const

Gets the application-supplied, 32-bit value associated with the item.

Returns
The 32-bit value associated with the item.

◆ GetItemFont()

CFont * GetItemFont ( ) const

Gets the item font (i.e.

the font used to display task panel item text).

Returns
A pointer to the item font.

◆ GetItemGroup()

virtual CXTPTaskPanelGroup * GetItemGroup ( ) const
virtual

Gets the group that this item belongs to.

Returns
A pointer to the group that this item belongs to.

Reimplemented in CXTPTaskPanelGroupItem.

◆ GetMarkupUIElement()

AFX_INLINE CXTPMarkupUIElement * GetMarkupUIElement ( ) const

Gets the Markup element that renders the caption of the item.

Returns
A pointer to the Markup element that renders the caption of the item.

◆ GetPaintManager()

CXTPTaskPanelPaintManager * GetPaintManager ( ) const

Gets the paint manager.

Returns
A pointer to the paint manager.

◆ GetParentItems()

AFX_INLINE CXTPTaskPanelItems * GetParentItems ( ) const

Gets the parent collection of items that this item belongs to.

Returns
A pointer to the parent collection of items that this item belongs to.

This method allows you to access sibling groups and/or items and determine the total number of siblings.

◆ GetTaskPanel()

AFX_INLINE CXTPTaskPanel * GetTaskPanel ( ) const

Gets the parent Task Panel control.

Returns
A pointer to the parent Task Panel control.

◆ GetTextRect()

CRect GetTextRect ( UINT * pFormat = 0 ) const

Gets the bounding rectangle of the caption text of the item.

Parameters
pFormat Points to the format object. (i.e. DT_LEFT, DT_CENTER, DT_RIGHT, DT_VCENTER).
Returns
The bounding rectangle of the caption text of the item.

◆ GetTooltip()

AFX_INLINE CString GetTooltip ( ) const

Gets the tooltip text of the item.

The tooltip text is displayed when the mouse cursor is over the item.

Returns
The tooltip text of the item.

◆ GetType()

XTPTaskPanelItemType GetType ( ) const

Gets the type of the item.

Returns
The type of the item; one of the values defined by the XTPTaskPanelItemType enumeration.

◆ IsAcceptFocus()

virtual BOOL IsAcceptFocus ( ) const
virtual

Determines if the item can be focused.

Returns
TRUE if the item can be focused, otherwise FALSE.

Reimplemented in CXTPTaskPanelGroup.

◆ IsAllowDrag()

long IsAllowDrag ( ) const

Determines if this item can be dragged.

Returns
TRUE if this item can be dragged, otherwise FALSE.
See also
AllowDrag, XTPTaskPanelItemAllowDrag

◆ IsAllowDrop()

BOOL IsAllowDrop ( ) const

Determines if dropping is enabled/disabled for this item.

Returns
TRUE if dropping is enabled for this item, FALSE if dropping is disabled for this item.

◆ IsDroppedOff()

AFX_INLINE BOOL IsDroppedOff ( ) const

Call this method to get the identifier of the item.

Returns
Identifier of the item.

◆ IsGroup()

BOOL IsGroup ( ) const

Determines if the item is a group.

Returns
TRUE if the item is a group, otherwise FALSE.

◆ IsItemDragging()

BOOL IsItemDragging ( ) const

Determines if the item is being dragged.

Returns
TRUE if the item is being dragged, otherwise FALSE.
See also
IsItemDragOver

◆ IsItemDragOver()

BOOL IsItemDragOver ( ) const

Determines if another item is being dragged over this item.

Returns
TRUE if another item is being dragged over this item, otherwise FALSE.
See also
IsItemDragging

◆ IsItemFocused()

BOOL IsItemFocused ( ) const

Determines if the item is focused.

Returns
TRUE if the item is focused, otherwise FALSE.

◆ IsItemHot()

BOOL IsItemHot ( ) const

Determines if the item is hot.

Returns
TRUE if the item is hot, otherwise FALSE.

◆ IsItemPressed()

BOOL IsItemPressed ( ) const

Determines if the item is pressed.

Returns
TRUE if the item is pressed, otherwise FALSE.

◆ IsVisible()

BOOL IsVisible ( ) const

Determines if the item is shown/hidden.

Returns
TRUE if the item is shown, FALSE if the item is hidden.

◆ PasteFromClipboard()

static CXTPTaskPanelItem *AFX_CDECL PasteFromClipboard ( )
static

Gets the last item placed in the clipboard.

Returns
A pointer to the last item placed in the clipboard.
See also
CopyToClipboard, CreateFromOleData, CacheGlobalData, CopyToClipboard, PrepareDrag

◆ RedrawPanel()

void RedrawPanel ( BOOL bAnimate = FALSE ) const

Redraws the parent Task Panel control.

Parameters
bAnimate TRUE to animate changes.

◆ SetCaption()

void SetCaption ( LPCTSTR lpszCaption )

Sets the caption for the item.

Parameters
lpszCaption Caption to be set.

◆ SetEnabled()

void SetEnabled ( BOOL bEnabled )

Enables/disables the item.

Parameters
bEnabled TRUE to enable the item, FALSE to disable the item.

◆ SetIconIndex()

void SetIconIndex ( int nIndex )

Sets the icon index for the item.

Parameters
nIndex Icon index to be set.

The icon index refers to the index of the icon within the image list of the parent Task Panel control.

◆ SetID() [1/2]

void SetID ( UINT nID )

Sets the identifier for the item.

Parameters
nID Indentifier to be set.

◆ SetID() [2/2]

void SetID | ( | UINT | nID,
 |  | LPCTSTR | lpCaption,
 |  | LPCTSTR | lpTooltip = NULL )

Sets the identifier for the item.

Parameters
nID | Identifier to be set.
lpCaption | Caption to be set.
lpTooltip | Tooltip to be set.

◆ SetItemData()

AFX_INLINE void SetItemData ( DWORD_PTR dwData )

Sets the 32-bit value associated with the item.

Parameters
dwData 32-bit value to associate with the item.

◆ SetItemFont()

void SetItemFont ( LOGFONT * pLogFont )

Sets the item font (i.e.

the font used to display task panel item text).

Parameters
pLogFont Pointer to the item font to be set.

The item font can be a custom font or the standard item font.

◆ SetTextRect()

void SetTextRect | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | UINT | nFormat )

Sets the bounding rectangle for the caption text of the item.

Parameters
pDC | Pointer to a valid device context.
rc | Bounding rectangle to be set.
nFormat | Format of the caption text (i.e. DT_LEFT, DT_CENTER, DT_RIGHT, DT_VCENTER).

This method is called by XTPTaskPanelPaintManager::DrawItemCaption to set the bounding rectangle for the caption text of the item.

See also
CXTPTaskPanelPaintManager::DrawItemCaption

◆ SetTooltip()

void SetTooltip ( LPCTSTR lpszTooltip )

Sets the tooltip text for the item.

Parameters
lpszTooltip Tooltip text to be set.

The tooltip text is displayed when the mouse cursor is over the item.

◆ SetType()

void SetType ( XTPTaskPanelItemType typeItem )

Sets the type for the item.

Parameters
typeItem Type to be set; must be one of the values defined by the the XTPTaskPanelItemType enumeration.

◆ SetVisible()

void SetVisible ( BOOL bVisible )

Shows/hides the item.

Parameters
bVisible TRUE to show the item, FALSE to hide the item.
The documentation for this class was generated from the following file:
  • XTPTaskPanelItem.h


Toolkit Pro: CXTPTaskPanelItems Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPTaskPanelItems Class Reference

CXTPTaskPanelItems is used in a Task Panel control to represent a collection of items. More...

Inheritance diagram for CXTPTaskPanelItems:
[legend]

Public Member Functions

CXTPTaskPanelItems (CXTPTaskPanel *pPanel=NULL)
Constructs a CXTPTaskPanelItems object.
virtual | ~CXTPTaskPanelItems ()
Destroys a CXTPTaskPanelItems object, handles cleanup and deallocation.
CXTPTaskPanelItem * | Add (CXTPTaskPanelItem *pItem, UINT nID)
Adds an item to this collection.
CXTPTaskPanelItem * | Add (CXTPTaskPanelItem *pItem, UINT nID, LPCTSTR lpCaption, LPCTSTR lpTooltip=NULL)
Adds an item to this collection.
CXTPTaskPanelItem * | InsertAt (int nIndex, CXTPTaskPanelItem *pItem)
Inserts an item at a specified index in this collection.
CXTPTaskPanelItem * | GetAt (int nIndex) const
Retrieves the item at a specified index in this collection.
void | Clear (BOOL bReposition=TRUE)
Removes all items from this collection.
CXTPTaskPanelItem * | Find (UINT nID) const
Retrieves the item with a specified identifier.
void | Remove (CXTPTaskPanelItem *pItem)
Removes a specified item from this collection.
void | RemoveAt (int nIndex)
Removes the item at a specified index from this collection.
int | GetIndex (const CXTPTaskPanelItem *pItem) const
Retrieves the index of a specified item in this collection.
int | GetCount () const
Gets the number of items in this collection.
CCmdTarget * | GetOwner () const
Gets the owner.
void | Move (CXTPTaskPanelItem *pItem, int nIndex)
Moved a specified item to a specified index in this collection.
void | DoPropExchange (CXTPPropExchange *pPX)
Reads/writes this object from or/an archive.
virtual CRuntimeClass * | GetDefaultItemClass () const
Gets the default runtime class of items in this collection.
int | GetNextVisibleIndex (int nIndex, int nDirection) const
Retrieves the index of the next/previous visible item in this collection from a specified index.
CXTPTaskPanelItem * | GetFirstVisibleItem () const
Gets the first visible item in this collection.
CXTPTaskPanelItem * | GetLastVisibleItem () const
Gets the last visible item in this collection.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Attributes

CXTPTaskPanel * | m_pPanel
Parent Task Panel control.
CArray< CXTPTaskPanelItem *, CXTPTaskPanelItem * > | m_arrItems
Array of items.
CCmdTarget * | m_pOwner
Owner of items.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

CXTPTaskPanelItems is used in a Task Panel control to represent a collection of items.

Constructor & Destructor Documentation

◆ CXTPTaskPanelItems()

CXTPTaskPanelItems ( CXTPTaskPanel * pPanel = NULL )

Constructs a CXTPTaskPanelItems object.

Parameters
pPanel Pointer to the parent Task Panel.

Member Function Documentation

◆ Add() [1/2]

CXTPTaskPanelItem * Add | ( | CXTPTaskPanelItem * | pItem,
 |  | UINT | nID )

Adds an item to this collection.

Parameters
pItem | Pointer to the item to add.
nID | Identifier of the item.
Returns
A pointer to the newly added item.

◆ Add() [2/2]

CXTPTaskPanelItem * Add | ( | CXTPTaskPanelItem * | pItem,
 |  | UINT | nID,
 |  | LPCTSTR | lpCaption,
 |  | LPCTSTR | lpTooltip = NULL )

Adds an item to this collection.

Parameters
pItem | Pointer to the item to add.
nID | Identifier of the item.
lpCaption | Caption of the item.
lpTooltip | Tooltip of the item.
Returns
A pointer to the newly added item.

◆ Clear()

void Clear ( BOOL bReposition = TRUE )

Removes all items from this collection.

Parameters
bReposition TRUE to reposition items after the removal is complete, FALSE otherwise.
See also
CXTPTaskPanel::Reposition

◆ DoPropExchange()

void DoPropExchange ( CXTPPropExchange * pPX )

Reads/writes this object from or/an archive.

Parameters
pPX Pointer to a CXTPPropExchange object to serialize to/from.

◆ Find()

CXTPTaskPanelItem * Find ( UINT nID ) const

Retrieves the item with a specified identifier.

Parameters
nID Identifier of the item to be retrieved.
Returns
A pointer to the item with the specified identifier if successful, otherwise FALSE.

◆ GetAt()

AFX_INLINE CXTPTaskPanelItem * GetAt ( int nIndex ) const

Retrieves the item at a specified index in this collection.

Parameters
nIndex Zero-based index of the item to retrieve.
Returns
A pointer to the item at the specified index in this collection.

◆ GetCount()

AFX_INLINE int GetCount ( ) const

Gets the number of items in this collection.

Returns
The number of items in this collection.

◆ GetDefaultItemClass()

virtual CRuntimeClass * GetDefaultItemClass ( ) const
virtual

Gets the default runtime class of items in this collection.

Returns
A pointer to the default runtime class of items in this collection.

Reimplemented in CXTPTaskPanelGroupItems, and CXTPTaskPanelGroups.

◆ GetFirstVisibleItem()

CXTPTaskPanelItem * GetFirstVisibleItem ( ) const

Gets the first visible item in this collection.

Returns
A pointer to the first visible item in this collection.
See also
GetLastVisibleItem, GetNextVisibleIndex

◆ GetIndex()

int GetIndex ( const CXTPTaskPanelItem * pItem ) const

Retrieves the index of a specified item in this collection.

Parameters
pItem Pointer to the item with the index to be retrieved.
Returns
The index of the specified item in this collection.

◆ GetLastVisibleItem()

CXTPTaskPanelItem * GetLastVisibleItem ( ) const

Gets the last visible item in this collection.

Returns
A pointer to the last visible item in this collection.
See also
GetFirstVisibleItem, GetNextVisibleIndex

◆ GetNextVisibleIndex()

int GetNextVisibleIndex | ( | int | nIndex,
 |  | int | nDirection ) const

Retrieves the index of the next/previous visible item in this collection from a specified index.

Parameters
nIndex | Index to begin search.
nDirection | Direction to search in (+1 for next, -1 for previous).
Returns
The index of the next/previous visible item in this collection from the specified index if successful, otherwise a value of -1.
See also
GetFirstVisibleItem, GetLastVisibleItem

◆ GetOwner()

AFX_INLINE CCmdTarget * GetOwner ( ) const

Gets the owner.

Returns
A pointer to the owner.

◆ InsertAt()

CXTPTaskPanelItem * InsertAt | ( | int | nIndex,
 |  | CXTPTaskPanelItem * | pItem )

Inserts an item at a specified index in this collection.

Parameters
nIndex | Index to insert the item at.
pItem | Pointer to the item to insert.

To move an item, use the Move method.

Returns
A pointer to the newly inserted item.

◆ Move()

void Move | ( | CXTPTaskPanelItem * | pItem,
 |  | int | nIndex )

Moved a specified item to a specified index in this collection.

Parameters
pItem | Pointer to the item to be moved.
nIndex | Index to move the specified item to.

Items are stored in a zero based array and are displayed in the order that they are added to the array. This method allows for the order of items in the array to be changed.

◆ Remove()

void Remove ( CXTPTaskPanelItem * pItem )

Removes a specified item from this collection.

Parameters
pItem Pointer to the item to be removed.

◆ RemoveAt()

void RemoveAt ( int nIndex )

Removes the item at a specified index from this collection.

Parameters
nIndex Zero-based index of the item to be removed.

Member Data Documentation

◆ m_pOwner

CCmdTarget* m_pOwner
protected

Owner of items.

Can be Task Panel or Group.

The documentation for this class was generated from the following file:
  • XTPTaskPanelItems.h


Toolkit Pro: CXTPTaskPanelListViewOffice2003Theme Class Reference

Public Member Functions | Public Attributes | List of all members
CXTPTaskPanelListViewOffice2003Theme Class Reference

CXTPTaskPanelListViewOffice2003Theme represents a List View Office 2003 style theme. More...

Inheritance diagram for CXTPTaskPanelListViewOffice2003Theme:
[legend]

Public Member Functions

CXTPTaskPanelListViewOffice2003Theme ()
Constructs a CXTPTaskPanelListViewOffice2003Theme object.
void | RefreshMetrics ()
Refreshes the visual metrics of the task panel.
CRect | DrawGroupCaptionBackground (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Draws the background of a group caption.
- Public Member Functions inherited from CXTPTaskPanelListViewOfficeXPTheme
CXTPTaskPanelListViewOfficeXPTheme ()
Constructs a CXTPTaskPanelListViewOfficeXPTheme object.
void | RefreshMetrics ()
Refreshes the visual metrics of the task panel.
- Public Member Functions inherited from CXTPTaskPanelListViewTheme
CXTPTaskPanelListViewTheme ()
Constructs a CXTPTaskPanelListViewTheme object.
void | RefreshMetrics ()
Refreshes the visual metrics of the task panel.
- Public Member Functions inherited from CXTPTaskPanelToolboxTheme
CXTPTaskPanelToolboxTheme ()
Constructs a CXTPTaskPanelToolboxTheme object.
void | RefreshMetrics ()
Refreshes the visual metrics of the task panel.
int | DrawGroupCaption (CDC *pDC, CXTPTaskPanelGroup *pGroup, BOOL bDraw)
Draws the caption of a specified group.
- Public Member Functions inherited from CXTPTaskPanelPaintManagerPlain
CXTPTaskPanelPaintManagerPlain ()
Constructs a CXTPTaskPanelPaintManagerPlain object.
void | DrawGroupClientFace (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Draws the client face of a specified group.
void | FillGroupClientFace (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Fills the client face of a specified group.
void | FillTaskPanel (CDC *pDC, CXTPTaskPanel *pTaskPanel)
Fills the background of a specified task panel.
- Public Member Functions inherited from CXTPTaskPanelPaintManager
CXTPTaskPanelPaintManager ()
Constructs a CXTPTaskPanelPaintManager object.
virtual | ~CXTPTaskPanelPaintManager ()
Destroys a CXTPTaskPanelPaintManager object, handles cleanup and deallocation.
virtual void | DrawGroupClient (CDC *pDC, CXTPTaskPanelGroup *pGroup)
Draws a specified group.
virtual CRect | DrawGroupItem (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw)
Draws a specified group item.
XTP_TASKPANEL_GROUPCOLORS * | GetGroupColors (BOOL bSpecial)
Retrieves a specified group color set.
virtual XTP_TASKPANEL_GROUPCOLORS * | GetGroupColors (CXTPTaskPanelGroup *pGroup)
Retrieves a specified group color set.
virtual void | DrawGroupItemFrame (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc)
Draws a rectangle around a group item when it is selected, pressed or highlighted.
virtual CRect | GetItemOuterMargins (const CXTPTaskPanelGroupItem *pItem)
Retrieves the outer margins of a specified group item.
virtual CRect | GetItemInnerMargins (const CXTPTaskPanelGroupItem *pItem)
Retrieves the inner margins of a specified group item.
virtual CRect | GetGroupOuterMargins (const CXTPTaskPanelGroup *pGroup)
Retrieves the outer margins of a specified group.
virtual CRect | GetItemIconPadding (const CXTPTaskPanelItem *pItem)
Retrieves the icon padding of a specified item.
virtual CRect | GetGroupInnerMargins (const CXTPTaskPanelGroup *pGroup)
Retrieves the inner margins of a specified group.
virtual CRect | GetControlMargins (const CXTPTaskPanel *pPanel)
Gets the default margins used for all groups within a specified Task Panel control.
virtual int | GetGroupSpacing (const CXTPTaskPanel *pPanel)
Gets the spacing used between groups within a specified Task Panel control.
virtual void | DrawScrollButton (CDC *pDC, CXTPTaskPanelScrollButton *pScrollButton)
Draws a group scroll button.
void | SetTextFormat (int nTextFormat, BOOL bCaption=FALSE)
Sets the text format for captions/items.
void | SetItemsFontIndirect (LOGFONT *pLogFont, BOOL bUseStandardItemsFont=FALSE)
Sets the text font for items.
void | SetCaptionFontIndirect (LOGFONT *pLogFont, BOOL bUseStandardCaptionFont=FALSE)
Sets the text font for captions.
virtual CFont * | GetItemFont (CXTPTaskPanelItem *pItem)
Retrieves the text font of a specified item.

Public Attributes

CXTPPaintManagerColorGradient | m_grcHot
Color gradient used to colorize "hot" items for this theme.
CXTPPaintManagerColorGradient | m_grcPushed
Color gradient used to colorize "pushed" items for this theme.
- Public Attributes inherited from CXTPTaskPanelPaintManager
BOOL | m_bEmulateEplorerTheme
TRUE to use Explorer theme under WinXP and Office 2000 under older OS.
XTPTaskPanelGripper | m_eGripper
Gripper of the manager.
BOOL | m_bBoldCaption
TRUE to display caption text in bold font, FALSE to display caption text in normal type.
CRect | m_rcGroupOuterMargins
Outer margins of the group.
CRect | m_rcGroupInnerMargins
Inner margins of the group.
CRect | m_rcItemOuterMargins
Outer margins of the group items.
CRect | m_rcItemInnerMargins
Inner margins of the group items.
CRect | m_rcControlMargins
Default margins for all groups.
int | m_nGroupSpacing
Amount of space placed between groups in the task panel.
CRect | m_rcImageLayoutIconPadding
Padding around images for xtpTaskItemLayoutImages layout.
CRect | m_rcItemIconPadding
Padding around images for items.
CRect | m_rcGroupIconPadding
Padding around images for groups.
BOOL | m_bOfficeHighlight
TRUE to highlight group items and scroll buttons using the Office XP style (XPCOLOR_HIGHLIGHT, XPCOLOR_HIGHLIGHT_CHECKED, XPCOLOR_HIGHLIGHT_PUSHED).
BOOL | m_bInvertDragRect
Only used when the theme is set to xtpTaskPanelThemeVisualStudio2003.
BOOL | m_bCaptionScrollButton
TRUE if the group caption scroll button is visible, FALSE if the group caption scroll button is hidden.
BOOL | m_bEmbossedDisabledText
TRUE to draw disabled text embossed.

Additional Inherited Members

- Static Public Attributes inherited from CXTPTaskPanelPaintManager
static const CRect | rectDefault
System selected default margins.
- Protected Member Functions inherited from CXTPTaskPanelToolboxTheme
- Protected Member Functions inherited from CXTPTaskPanelPaintManager
CRect | DrawGroupItemImageWithText (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw)
Draws the icon of a specified group item.
CRect | DrawGroupItemImageWithTextBelow (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw)
Draws the icon of a specified group item.
CRect | DrawGroupItemImage (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw)
Draws the icon of a specified group item.
virtual void | DrawGroupClientItems (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Draws the items of a specified group.
virtual CRect | DrawCaptionGripper (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Draws the caption gripper of a specified group.
virtual int | GetCaptionGripperWidth (CXTPTaskPanelGroup *pGroup, CRect rc)
Retrieves the width of the caption gripper of a specified group.
virtual void | DrawItemCaption (CDC *pDC, CXTPTaskPanelItem *pItem, CRect rcText, UINT nFormat)
Draws the text caption of a specified item.
virtual void | DrawItemImage (CDC *pDC, CXTPTaskPanelItem *pItem, CPoint ptIcon, CXTPImageManagerIcon *pImage, CSize szIcon)
Draws the icon of a specified item.
COLORREF | BlendColor (COLORREF clrFrom, COLORREF clrTo, int nAlpha)
Blends one color to another color by a specified amount.
CRect | DrawCaptionGripperBitmap (CDC *pDC, CXTPTaskPanelGroup *pGroup, BOOL bExpanded, BOOL bHot, CRect rc)
Draws the caption gripper bitmap.
void | DrawCaptionGripperSigns (CDC *pDC, CPoint pt, COLORREF clr, BOOL bExpanded)
Draws the ">>" and "<<" signs of the caption gripper when the theme of the Task Panel is set to Office 2000.
void | CreateGripperBitmaps ()
Loads the gripper bitmap when the theme of the Task Panel is set to either Windows XP or Classic Windows XP.
void | CreateGripperIcon (HICON &hIcon, UINT nIDResource, COLORREF clrGripperBack)
Creates the gripper bitmap icons when the theme of the Task Panel is set to either Windows XP or Classic Windows XP and either the operating system is not Windows XP or the operating system is Windows XP and Luna themes are used.
void | FreeBitmaps ()
Frees the memory used by the group caption bitmaps.
void | Rectangle (CDC *pDC, CRect rc, COLORREF clrPen, COLORREF clrBrush)
This method is only used when drawing hot, pressed, and selected group items and scroll buttons when m_bOfficeHighlight is TRUE.
virtual CPoint | GetHighlightOffset (CXTPTaskPanelGroupItem *pItem)
Retrieves the highlight offset of the text of a specified group item.
virtual void | DrawDragArrow (CDC *pDC, CXTPTaskPanelItem *pItem, CRect rc, BOOL bAfter=FALSE)
Draws the "drag arrow" of a specified item.
virtual void | DrawFocusRect (CDC *pDC, CRect rc)
Draws a rectangle around the focused item.
- Protected Attributes inherited from CXTPTaskPanelPaintManagerPlain
BOOL | m_bRoundedFrame
TRUE to draw a rounded frame around all of the groups in the task panel.
BOOL | m_bOfficeCaption
FALSE to draw a rounded rectangle around caption.
- Protected Attributes inherited from CXTPTaskPanelPaintManager
BOOL | m_bUseBitmapGrippers
TRUE to use alpha grippers.
HICON | m_hGripperNormal
Icon of normal group header gripper.
HICON | m_hGripperSpecial
Icon of special group header gripper.
HBITMAP | m_bmpGrippers [8]
Bitmaps of alpha grippers.
CXTPFont | m_xtpFontCaption
Caption font.
CXTPFont | m_xtpFontIcon
Normal items font.
CXTPFont | m_xtpFontIconBold
Bold items font.
CXTPFont | m_xtpFontIconHot
"Hot" items font.
CXTPFont | m_xtpFontIconHotBold
Bold items font.
CXTPPaintManagerColorGradient | m_clrBackground
Background color of the Task Panel.
XTP_TASKPANEL_GROUPCOLORS | m_groupNormal
Normal colors set.
XTP_TASKPANEL_GROUPCOLORS | m_groupSpecial
Special colors set.
CXTPPaintManagerColor | m_clrHighlightHot
Color of items when they are "hot." This is the color of the item on mouseover if hot tracking is enabled.
CXTPPaintManagerColor m_clrHighlightSelected
Color of items when they are selected.
CXTPPaintManagerColor m_clrHighlightPressed
Color of items when they are pressed.
CXTPPaintManagerColorGradient | m_clrHighlightBorder
Border color of items when they are "hot." This is the border color of the item on mouse over if hot tracking is enabled.
BOOL | m_bOfficeBorder
TRUE to use Office borders.
BOOL | m_bLeftRoundedCorner
TRUE to round left corner of the group caption.
BOOL | m_bRightRoundedCorner
TRUE to round right corner of the group caption.
int | m_nCaptionHeight
Caption height, in pixels.
BOOL | m_bUseStandardCaptionFont
TRUE to use system font for group caption text.
BOOL | m_bUseStandardItemsFont
TRUE to use system font for item caption text.
int | m_nItemTextFormat
Format flags of item text.
int | m_nCaptionTextFormat
Format flags of caption text.

Detailed Description

CXTPTaskPanelListViewOffice2003Theme represents a List View Office 2003 style theme.

See also
CXTPTaskPanel::SetTheme

Member Function Documentation

◆ DrawGroupCaptionBackground()

CRect DrawGroupCaptionBackground | ( | CDC * | pDC,
 |  | CXTPTaskPanelGroup * | pGroup,
 |  | CRect | rc )
 virtual

Draws the background of a group caption.

Parameters
pDC | Pointer to a valid device context.
pGroup | Pointer to the group with the group caption to fill.
rc | Bounding rectangle of the group caption.
Returns
The bounding rectangle of the group caption.

This method will draw the normal, hot, and pressed backgrounds for the group caption. It will then fill the group caption with the Office 2003 color gradient.

Reimplemented from CXTPTaskPanelToolboxTheme.

Reimplemented in CXTPTaskPanelShortcutBarOffice2003Theme, and CXTPTaskPanelShortcutBarOffice2007Theme.

The documentation for this class was generated from the following file:
  • XTPTaskPanelListViewOffice2003Theme.h


Toolkit Pro: CXTPTaskPanelListViewOfficeXPTheme Class Reference

Public Member Functions | List of all members
CXTPTaskPanelListViewOfficeXPTheme Class Reference

CXTPTaskPanelListViewOfficeXPTheme represents a List View Office XP style theme. More...

Inheritance diagram for CXTPTaskPanelListViewOfficeXPTheme:
[legend]

Public Member Functions

CXTPTaskPanelListViewOfficeXPTheme ()
Constructs a CXTPTaskPanelListViewOfficeXPTheme object.
void | RefreshMetrics ()
Refreshes the visual metrics of the task panel.
- Public Member Functions inherited from CXTPTaskPanelListViewTheme
CXTPTaskPanelListViewTheme ()
Constructs a CXTPTaskPanelListViewTheme object.
void | RefreshMetrics ()
Refreshes the visual metrics of the task panel.
- Public Member Functions inherited from CXTPTaskPanelToolboxTheme
CXTPTaskPanelToolboxTheme ()
Constructs a CXTPTaskPanelToolboxTheme object.
void | RefreshMetrics ()
Refreshes the visual metrics of the task panel.
int | DrawGroupCaption (CDC *pDC, CXTPTaskPanelGroup *pGroup, BOOL bDraw)
Draws the caption of a specified group.
- Public Member Functions inherited from CXTPTaskPanelPaintManagerPlain
CXTPTaskPanelPaintManagerPlain ()
Constructs a CXTPTaskPanelPaintManagerPlain object.
void | DrawGroupClientFace (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Draws the client face of a specified group.
void | FillGroupClientFace (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Fills the client face of a specified group.
void | FillTaskPanel (CDC *pDC, CXTPTaskPanel *pTaskPanel)
Fills the background of a specified task panel.
- Public Member Functions inherited from CXTPTaskPanelPaintManager
CXTPTaskPanelPaintManager ()
Constructs a CXTPTaskPanelPaintManager object.
virtual | ~CXTPTaskPanelPaintManager ()
Destroys a CXTPTaskPanelPaintManager object, handles cleanup and deallocation.
virtual void | DrawGroupClient (CDC *pDC, CXTPTaskPanelGroup *pGroup)
Draws a specified group.
virtual CRect | DrawGroupItem (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw)
Draws a specified group item.
XTP_TASKPANEL_GROUPCOLORS * | GetGroupColors (BOOL bSpecial)
Retrieves a specified group color set.
virtual XTP_TASKPANEL_GROUPCOLORS * | GetGroupColors (CXTPTaskPanelGroup *pGroup)
Retrieves a specified group color set.
virtual void | DrawGroupItemFrame (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc)
Draws a rectangle around a group item when it is selected, pressed or highlighted.
virtual CRect | GetItemOuterMargins (const CXTPTaskPanelGroupItem *pItem)
Retrieves the outer margins of a specified group item.
virtual CRect | GetItemInnerMargins (const CXTPTaskPanelGroupItem *pItem)
Retrieves the inner margins of a specified group item.
virtual CRect | GetGroupOuterMargins (const CXTPTaskPanelGroup *pGroup)
Retrieves the outer margins of a specified group.
virtual CRect | GetItemIconPadding (const CXTPTaskPanelItem *pItem)
Retrieves the icon padding of a specified item.
virtual CRect | GetGroupInnerMargins (const CXTPTaskPanelGroup *pGroup)
Retrieves the inner margins of a specified group.
virtual CRect | GetControlMargins (const CXTPTaskPanel *pPanel)
Gets the default margins used for all groups within a specified Task Panel control.
virtual int | GetGroupSpacing (const CXTPTaskPanel *pPanel)
Gets the spacing used between groups within a specified Task Panel control.
virtual void | DrawScrollButton (CDC *pDC, CXTPTaskPanelScrollButton *pScrollButton)
Draws a group scroll button.
void | SetTextFormat (int nTextFormat, BOOL bCaption=FALSE)
Sets the text format for captions/items.
void | SetItemsFontIndirect (LOGFONT *pLogFont, BOOL bUseStandardItemsFont=FALSE)
Sets the text font for items.
void | SetCaptionFontIndirect (LOGFONT *pLogFont, BOOL bUseStandardCaptionFont=FALSE)
Sets the text font for captions.
virtual CFont * | GetItemFont (CXTPTaskPanelItem *pItem)
Retrieves the text font of a specified item.

Additional Inherited Members

- Public Attributes inherited from CXTPTaskPanelPaintManager
BOOL | m_bEmulateEplorerTheme
TRUE to use Explorer theme under WinXP and Office 2000 under older OS.
XTPTaskPanelGripper | m_eGripper
Gripper of the manager.
BOOL | m_bBoldCaption
TRUE to display caption text in bold font, FALSE to display caption text in normal type.
CRect | m_rcGroupOuterMargins
Outer margins of the group.
CRect | m_rcGroupInnerMargins
Inner margins of the group.
CRect | m_rcItemOuterMargins
Outer margins of the group items.
CRect | m_rcItemInnerMargins
Inner margins of the group items.
CRect | m_rcControlMargins
Default margins for all groups.
int | m_nGroupSpacing
Amount of space placed between groups in the task panel.
CRect | m_rcImageLayoutIconPadding
Padding around images for xtpTaskItemLayoutImages layout.
CRect | m_rcItemIconPadding
Padding around images for items.
CRect | m_rcGroupIconPadding
Padding around images for groups.
BOOL | m_bOfficeHighlight
TRUE to highlight group items and scroll buttons using the Office XP style (XPCOLOR_HIGHLIGHT, XPCOLOR_HIGHLIGHT_CHECKED, XPCOLOR_HIGHLIGHT_PUSHED).
BOOL | m_bInvertDragRect
Only used when the theme is set to xtpTaskPanelThemeVisualStudio2003.
BOOL | m_bCaptionScrollButton
TRUE if the group caption scroll button is visible, FALSE if the group caption scroll button is hidden.
BOOL | m_bEmbossedDisabledText
TRUE to draw disabled text embossed.
- Static Public Attributes inherited from CXTPTaskPanelPaintManager
static const CRect | rectDefault
System selected default margins.
- Protected Member Functions inherited from CXTPTaskPanelToolboxTheme
virtual CRect | DrawGroupCaptionBackground (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Draws the group caption background of a specified group.
- Protected Member Functions inherited from CXTPTaskPanelPaintManager
CRect | DrawGroupItemImageWithText (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw)
Draws the icon of a specified group item.
CRect | DrawGroupItemImageWithTextBelow (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw)
Draws the icon of a specified group item.
CRect | DrawGroupItemImage (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw)
Draws the icon of a specified group item.
virtual void | DrawGroupClientItems (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Draws the items of a specified group.
virtual CRect | DrawCaptionGripper (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Draws the caption gripper of a specified group.
virtual int | GetCaptionGripperWidth (CXTPTaskPanelGroup *pGroup, CRect rc)
Retrieves the width of the caption gripper of a specified group.
virtual void | DrawItemCaption (CDC *pDC, CXTPTaskPanelItem *pItem, CRect rcText, UINT nFormat)
Draws the text caption of a specified item.
virtual void | DrawItemImage (CDC *pDC, CXTPTaskPanelItem *pItem, CPoint ptIcon, CXTPImageManagerIcon *pImage, CSize szIcon)
Draws the icon of a specified item.
COLORREF | BlendColor (COLORREF clrFrom, COLORREF clrTo, int nAlpha)
Blends one color to another color by a specified amount.
CRect | DrawCaptionGripperBitmap (CDC *pDC, CXTPTaskPanelGroup *pGroup, BOOL bExpanded, BOOL bHot, CRect rc)
Draws the caption gripper bitmap.
void | DrawCaptionGripperSigns (CDC *pDC, CPoint pt, COLORREF clr, BOOL bExpanded)
Draws the ">>" and "<<" signs of the caption gripper when the theme of the Task Panel is set to Office 2000.
void | CreateGripperBitmaps ()
Loads the gripper bitmap when the theme of the Task Panel is set to either Windows XP or Classic Windows XP.
void | CreateGripperIcon (HICON &hIcon, UINT nIDResource, COLORREF clrGripperBack)
Creates the gripper bitmap icons when the theme of the Task Panel is set to either Windows XP or Classic Windows XP and either the operating system is not Windows XP or the operating system is Windows XP and Luna themes are used.
void | FreeBitmaps ()
Frees the memory used by the group caption bitmaps.
void | Rectangle (CDC *pDC, CRect rc, COLORREF clrPen, COLORREF clrBrush)
This method is only used when drawing hot, pressed, and selected group items and scroll buttons when m_bOfficeHighlight is TRUE.
virtual CPoint | GetHighlightOffset (CXTPTaskPanelGroupItem *pItem)
Retrieves the highlight offset of the text of a specified group item.
virtual void | DrawDragArrow (CDC *pDC, CXTPTaskPanelItem *pItem, CRect rc, BOOL bAfter=FALSE)
Draws the "drag arrow" of a specified item.
virtual void | DrawFocusRect (CDC *pDC, CRect rc)
Draws a rectangle around the focused item.
- Protected Attributes inherited from CXTPTaskPanelPaintManagerPlain
BOOL | m_bRoundedFrame
TRUE to draw a rounded frame around all of the groups in the task panel.
BOOL | m_bOfficeCaption
FALSE to draw a rounded rectangle around caption.
- Protected Attributes inherited from CXTPTaskPanelPaintManager
BOOL | m_bUseBitmapGrippers
TRUE to use alpha grippers.
HICON | m_hGripperNormal
Icon of normal group header gripper.
HICON | m_hGripperSpecial
Icon of special group header gripper.
HBITMAP | m_bmpGrippers [8]
Bitmaps of alpha grippers.
CXTPFont | m_xtpFontCaption
Caption font.
CXTPFont | m_xtpFontIcon
Normal items font.
CXTPFont | m_xtpFontIconBold
Bold items font.
CXTPFont | m_xtpFontIconHot
"Hot" items font.
CXTPFont | m_xtpFontIconHotBold
Bold items font.
CXTPPaintManagerColorGradient | m_clrBackground
Background color of the Task Panel.
XTP_TASKPANEL_GROUPCOLORS | m_groupNormal
Normal colors set.
XTP_TASKPANEL_GROUPCOLORS | m_groupSpecial
Special colors set.
CXTPPaintManagerColor | m_clrHighlightHot
Color of items when they are "hot." This is the color of the item on mouseover if hot tracking is enabled.
CXTPPaintManagerColor m_clrHighlightSelected
Color of items when they are selected.
CXTPPaintManagerColor m_clrHighlightPressed
Color of items when they are pressed.
CXTPPaintManagerColorGradient | m_clrHighlightBorder
Border color of items when they are "hot." This is the border color of the item on mouse over if hot tracking is enabled.
BOOL | m_bOfficeBorder
TRUE to use Office borders.
BOOL | m_bLeftRoundedCorner
TRUE to round left corner of the group caption.
BOOL | m_bRightRoundedCorner
TRUE to round right corner of the group caption.
int | m_nCaptionHeight
Caption height, in pixels.
BOOL | m_bUseStandardCaptionFont
TRUE to use system font for group caption text.
BOOL | m_bUseStandardItemsFont
TRUE to use system font for item caption text.
int | m_nItemTextFormat
Format flags of item text.
int | m_nCaptionTextFormat
Format flags of caption text.

Detailed Description

CXTPTaskPanelListViewOfficeXPTheme represents a List View Office XP style theme.

See also
CXTPTaskPanel::SetTheme
The documentation for this class was generated from the following file:
  • XTPTaskPanelListViewOfficeXPTheme.h


Toolkit Pro: CXTPTaskPanelListViewTheme Class Reference

Public Member Functions | List of all members
CXTPTaskPanelListViewTheme Class Reference

CXTPTaskPanelListViewTheme class represents a List View style theme. More...

Inheritance diagram for CXTPTaskPanelListViewTheme:
[legend]

Public Member Functions

CXTPTaskPanelListViewTheme ()
Constructs a CXTPTaskPanelListViewTheme object.
void | RefreshMetrics ()
Refreshes the visual metrics of the task panel.
- Public Member Functions inherited from CXTPTaskPanelToolboxTheme
CXTPTaskPanelToolboxTheme ()
Constructs a CXTPTaskPanelToolboxTheme object.
void | RefreshMetrics ()
Refreshes the visual metrics of the task panel.
int | DrawGroupCaption (CDC *pDC, CXTPTaskPanelGroup *pGroup, BOOL bDraw)
Draws the caption of a specified group.
- Public Member Functions inherited from CXTPTaskPanelPaintManagerPlain
CXTPTaskPanelPaintManagerPlain ()
Constructs a CXTPTaskPanelPaintManagerPlain object.
void | DrawGroupClientFace (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Draws the client face of a specified group.
void | FillGroupClientFace (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Fills the client face of a specified group.
void | FillTaskPanel (CDC *pDC, CXTPTaskPanel *pTaskPanel)
Fills the background of a specified task panel.
- Public Member Functions inherited from CXTPTaskPanelPaintManager
CXTPTaskPanelPaintManager ()
Constructs a CXTPTaskPanelPaintManager object.
virtual | ~CXTPTaskPanelPaintManager ()
Destroys a CXTPTaskPanelPaintManager object, handles cleanup and deallocation.
virtual void | DrawGroupClient (CDC *pDC, CXTPTaskPanelGroup *pGroup)
Draws a specified group.
virtual CRect | DrawGroupItem (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw)
Draws a specified group item.
XTP_TASKPANEL_GROUPCOLORS * | GetGroupColors (BOOL bSpecial)
Retrieves a specified group color set.
virtual XTP_TASKPANEL_GROUPCOLORS * | GetGroupColors (CXTPTaskPanelGroup *pGroup)
Retrieves a specified group color set.
virtual void | DrawGroupItemFrame (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc)
Draws a rectangle around a group item when it is selected, pressed or highlighted.
virtual CRect | GetItemOuterMargins (const CXTPTaskPanelGroupItem *pItem)
Retrieves the outer margins of a specified group item.
virtual CRect | GetItemInnerMargins (const CXTPTaskPanelGroupItem *pItem)
Retrieves the inner margins of a specified group item.
virtual CRect | GetGroupOuterMargins (const CXTPTaskPanelGroup *pGroup)
Retrieves the outer margins of a specified group.
virtual CRect | GetItemIconPadding (const CXTPTaskPanelItem *pItem)
Retrieves the icon padding of a specified item.
virtual CRect | GetGroupInnerMargins (const CXTPTaskPanelGroup *pGroup)
Retrieves the inner margins of a specified group.
virtual CRect | GetControlMargins (const CXTPTaskPanel *pPanel)
Gets the default margins used for all groups within a specified Task Panel control.
virtual int | GetGroupSpacing (const CXTPTaskPanel *pPanel)
Gets the spacing used between groups within a specified Task Panel control.
virtual void | DrawScrollButton (CDC *pDC, CXTPTaskPanelScrollButton *pScrollButton)
Draws a group scroll button.
void | SetTextFormat (int nTextFormat, BOOL bCaption=FALSE)
Sets the text format for captions/items.
void | SetItemsFontIndirect (LOGFONT *pLogFont, BOOL bUseStandardItemsFont=FALSE)
Sets the text font for items.
void | SetCaptionFontIndirect (LOGFONT *pLogFont, BOOL bUseStandardCaptionFont=FALSE)
Sets the text font for captions.
virtual CFont * | GetItemFont (CXTPTaskPanelItem *pItem)
Retrieves the text font of a specified item.

Additional Inherited Members

- Public Attributes inherited from CXTPTaskPanelPaintManager
BOOL | m_bEmulateEplorerTheme
TRUE to use Explorer theme under WinXP and Office 2000 under older OS.
XTPTaskPanelGripper | m_eGripper
Gripper of the manager.
BOOL | m_bBoldCaption
TRUE to display caption text in bold font, FALSE to display caption text in normal type.
CRect | m_rcGroupOuterMargins
Outer margins of the group.
CRect | m_rcGroupInnerMargins
Inner margins of the group.
CRect | m_rcItemOuterMargins
Outer margins of the group items.
CRect | m_rcItemInnerMargins
Inner margins of the group items.
CRect | m_rcControlMargins
Default margins for all groups.
int | m_nGroupSpacing
Amount of space placed between groups in the task panel.
CRect | m_rcImageLayoutIconPadding
Padding around images for xtpTaskItemLayoutImages layout.
CRect | m_rcItemIconPadding
Padding around images for items.
CRect | m_rcGroupIconPadding
Padding around images for groups.
BOOL | m_bOfficeHighlight
TRUE to highlight group items and scroll buttons using the Office XP style (XPCOLOR_HIGHLIGHT, XPCOLOR_HIGHLIGHT_CHECKED, XPCOLOR_HIGHLIGHT_PUSHED).
BOOL | m_bInvertDragRect
Only used when the theme is set to xtpTaskPanelThemeVisualStudio2003.
BOOL | m_bCaptionScrollButton
TRUE if the group caption scroll button is visible, FALSE if the group caption scroll button is hidden.
BOOL | m_bEmbossedDisabledText
TRUE to draw disabled text embossed.
- Static Public Attributes inherited from CXTPTaskPanelPaintManager
static const CRect | rectDefault
System selected default margins.
- Protected Member Functions inherited from CXTPTaskPanelToolboxTheme
virtual CRect | DrawGroupCaptionBackground (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Draws the group caption background of a specified group.
- Protected Member Functions inherited from CXTPTaskPanelPaintManager
CRect | DrawGroupItemImageWithText (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw)
Draws the icon of a specified group item.
CRect | DrawGroupItemImageWithTextBelow (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw)
Draws the icon of a specified group item.
CRect | DrawGroupItemImage (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw)
Draws the icon of a specified group item.
virtual void | DrawGroupClientItems (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Draws the items of a specified group.
virtual CRect | DrawCaptionGripper (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Draws the caption gripper of a specified group.
virtual int | GetCaptionGripperWidth (CXTPTaskPanelGroup *pGroup, CRect rc)
Retrieves the width of the caption gripper of a specified group.
virtual void | DrawItemCaption (CDC *pDC, CXTPTaskPanelItem *pItem, CRect rcText, UINT nFormat)
Draws the text caption of a specified item.
virtual void | DrawItemImage (CDC *pDC, CXTPTaskPanelItem *pItem, CPoint ptIcon, CXTPImageManagerIcon *pImage, CSize szIcon)
Draws the icon of a specified item.
COLORREF | BlendColor (COLORREF clrFrom, COLORREF clrTo, int nAlpha)
Blends one color to another color by a specified amount.
CRect | DrawCaptionGripperBitmap (CDC *pDC, CXTPTaskPanelGroup *pGroup, BOOL bExpanded, BOOL bHot, CRect rc)
Draws the caption gripper bitmap.
void | DrawCaptionGripperSigns (CDC *pDC, CPoint pt, COLORREF clr, BOOL bExpanded)
Draws the ">>" and "<<" signs of the caption gripper when the theme of the Task Panel is set to Office 2000.
void | CreateGripperBitmaps ()
Loads the gripper bitmap when the theme of the Task Panel is set to either Windows XP or Classic Windows XP.
void | CreateGripperIcon (HICON &hIcon, UINT nIDResource, COLORREF clrGripperBack)
Creates the gripper bitmap icons when the theme of the Task Panel is set to either Windows XP or Classic Windows XP and either the operating system is not Windows XP or the operating system is Windows XP and Luna themes are used.
void | FreeBitmaps ()
Frees the memory used by the group caption bitmaps.
void | Rectangle (CDC *pDC, CRect rc, COLORREF clrPen, COLORREF clrBrush)
This method is only used when drawing hot, pressed, and selected group items and scroll buttons when m_bOfficeHighlight is TRUE.
virtual CPoint | GetHighlightOffset (CXTPTaskPanelGroupItem *pItem)
Retrieves the highlight offset of the text of a specified group item.
virtual void | DrawDragArrow (CDC *pDC, CXTPTaskPanelItem *pItem, CRect rc, BOOL bAfter=FALSE)
Draws the "drag arrow" of a specified item.
virtual void | DrawFocusRect (CDC *pDC, CRect rc)
Draws a rectangle around the focused item.
- Protected Attributes inherited from CXTPTaskPanelPaintManagerPlain
BOOL | m_bRoundedFrame
TRUE to draw a rounded frame around all of the groups in the task panel.
BOOL | m_bOfficeCaption
FALSE to draw a rounded rectangle around caption.
- Protected Attributes inherited from CXTPTaskPanelPaintManager
BOOL | m_bUseBitmapGrippers
TRUE to use alpha grippers.
HICON | m_hGripperNormal
Icon of normal group header gripper.
HICON | m_hGripperSpecial
Icon of special group header gripper.
HBITMAP | m_bmpGrippers [8]
Bitmaps of alpha grippers.
CXTPFont | m_xtpFontCaption
Caption font.
CXTPFont | m_xtpFontIcon
Normal items font.
CXTPFont | m_xtpFontIconBold
Bold items font.
CXTPFont | m_xtpFontIconHot
"Hot" items font.
CXTPFont | m_xtpFontIconHotBold
Bold items font.
CXTPPaintManagerColorGradient | m_clrBackground
Background color of the Task Panel.
XTP_TASKPANEL_GROUPCOLORS | m_groupNormal
Normal colors set.
XTP_TASKPANEL_GROUPCOLORS | m_groupSpecial
Special colors set.
CXTPPaintManagerColor | m_clrHighlightHot
Color of items when they are "hot." This is the color of the item on mouseover if hot tracking is enabled.
CXTPPaintManagerColor m_clrHighlightSelected
Color of items when they are selected.
CXTPPaintManagerColor m_clrHighlightPressed
Color of items when they are pressed.
CXTPPaintManagerColorGradient | m_clrHighlightBorder
Border color of items when they are "hot." This is the border color of the item on mouse over if hot tracking is enabled.
BOOL | m_bOfficeBorder
TRUE to use Office borders.
BOOL | m_bLeftRoundedCorner
TRUE to round left corner of the group caption.
BOOL | m_bRightRoundedCorner
TRUE to round right corner of the group caption.
int | m_nCaptionHeight
Caption height, in pixels.
BOOL | m_bUseStandardCaptionFont
TRUE to use system font for group caption text.
BOOL | m_bUseStandardItemsFont
TRUE to use system font for item caption text.
int | m_nItemTextFormat
Format flags of item text.
int | m_nCaptionTextFormat
Format flags of caption text.

Detailed Description

CXTPTaskPanelListViewTheme class represents a List View style theme.

See also
CXTPTaskPanel::SetTheme
The documentation for this class was generated from the following file:
  • XTPTaskPanelListViewTheme.h


Toolkit Pro: CXTPTaskPanelNativeWindows10Theme Class Reference

Public Member Functions | List of all members
CXTPTaskPanelNativeWindows10Theme Class Reference

CXTPTaskPanelNativeWindows10Theme represents a Native Windows 10 style theme. More...

Inheritance diagram for CXTPTaskPanelNativeWindows10Theme:
[legend]

Public Member Functions

CXTPTaskPanelNativeWindows10Theme ()
Constructs a CXTPTaskPanelNativeWindows10Theme object.
virtual | ~CXTPTaskPanelNativeWindows10Theme ()
Destroys a CXTPTaskPanelNativeWindows10Theme object, handles cleanup and deallocation.
virtual void | RefreshMetrics ()
Refreshes the visual metrics of the task panel.
- Public Member Functions inherited from CXTPTaskPanelVisualStudio2012Theme
CXTPTaskPanelVisualStudio2012Theme (BOOL bLight=TRUE)
Constructs a CXTPTaskPanelVisualStudio2012Theme object.
virtual | ~CXTPTaskPanelVisualStudio2012Theme ()
Destroys a CXTPTaskPanelVisualStudio2012Theme object, handles cleanup and deallocation.
CRect | DrawGroupCaptionBackground (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Draws the group caption background of a specified group.
void | DrawGroupClientFace (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Draws the client face of a specified group.
virtual void | DrawGroupItemFrame (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc)
Draws a rectangle around a group item when it is selected, pressed or highlighted.
void | FillGroupClientFace (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Fills the client face of a specified group.
void | FillTaskPanel (CDC *pDC, CXTPTaskPanel *pTaskPanel)
Fills the background of a specified task panel.
virtual void | DrawItemCaption (CDC *pDC, CXTPTaskPanelItem *pItem, CRect rcText, UINT nFormat)
Draws the text caption of a specified item.
- Public Member Functions inherited from CXTPTaskPanelVisualStudio2005Theme
CXTPTaskPanelVisualStudio2005Theme ()
Constructs a CXTPTaskPanelVisualStudio2005Theme object.
- Public Member Functions inherited from CXTPTaskPanelToolboxTheme
CXTPTaskPanelToolboxTheme ()
Constructs a CXTPTaskPanelToolboxTheme object.
int | DrawGroupCaption (CDC *pDC, CXTPTaskPanelGroup *pGroup, BOOL bDraw)
Draws the caption of a specified group.
- Public Member Functions inherited from CXTPTaskPanelPaintManagerPlain
CXTPTaskPanelPaintManagerPlain ()
Constructs a CXTPTaskPanelPaintManagerPlain object.
- Public Member Functions inherited from CXTPTaskPanelPaintManager
CXTPTaskPanelPaintManager ()
Constructs a CXTPTaskPanelPaintManager object.
virtual | ~CXTPTaskPanelPaintManager ()
Destroys a CXTPTaskPanelPaintManager object, handles cleanup and deallocation.
virtual void | DrawGroupClient (CDC *pDC, CXTPTaskPanelGroup *pGroup)
Draws a specified group.
virtual CRect | DrawGroupItem (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw)
Draws a specified group item.
XTP_TASKPANEL_GROUPCOLORS * | GetGroupColors (BOOL bSpecial)
Retrieves a specified group color set.
virtual XTP_TASKPANEL_GROUPCOLORS * | GetGroupColors (CXTPTaskPanelGroup *pGroup)
Retrieves a specified group color set.
virtual CRect | GetItemOuterMargins (const CXTPTaskPanelGroupItem *pItem)
Retrieves the outer margins of a specified group item.
virtual CRect | GetItemInnerMargins (const CXTPTaskPanelGroupItem *pItem)
Retrieves the inner margins of a specified group item.
virtual CRect | GetGroupOuterMargins (const CXTPTaskPanelGroup *pGroup)
Retrieves the outer margins of a specified group.
virtual CRect | GetItemIconPadding (const CXTPTaskPanelItem *pItem)
Retrieves the icon padding of a specified item.
virtual CRect | GetGroupInnerMargins (const CXTPTaskPanelGroup *pGroup)
Retrieves the inner margins of a specified group.
virtual CRect | GetControlMargins (const CXTPTaskPanel *pPanel)
Gets the default margins used for all groups within a specified Task Panel control.
virtual int | GetGroupSpacing (const CXTPTaskPanel *pPanel)
Gets the spacing used between groups within a specified Task Panel control.
virtual void | DrawScrollButton (CDC *pDC, CXTPTaskPanelScrollButton *pScrollButton)
Draws a group scroll button.
void | SetTextFormat (int nTextFormat, BOOL bCaption=FALSE)
Sets the text format for captions/items.
void | SetItemsFontIndirect (LOGFONT *pLogFont, BOOL bUseStandardItemsFont=FALSE)
Sets the text font for items.
void | SetCaptionFontIndirect (LOGFONT *pLogFont, BOOL bUseStandardCaptionFont=FALSE)
Sets the text font for captions.
virtual CFont * | GetItemFont (CXTPTaskPanelItem *pItem)
Retrieves the text font of a specified item.

Additional Inherited Members

- Public Attributes inherited from CXTPTaskPanelPaintManager
BOOL | m_bEmulateEplorerTheme
TRUE to use Explorer theme under WinXP and Office 2000 under older OS.
XTPTaskPanelGripper | m_eGripper
Gripper of the manager.
BOOL | m_bBoldCaption
TRUE to display caption text in bold font, FALSE to display caption text in normal type.
CRect | m_rcGroupOuterMargins
Outer margins of the group.
CRect | m_rcGroupInnerMargins
Inner margins of the group.
CRect | m_rcItemOuterMargins
Outer margins of the group items.
CRect | m_rcItemInnerMargins
Inner margins of the group items.
CRect | m_rcControlMargins
Default margins for all groups.
int | m_nGroupSpacing
Amount of space placed between groups in the task panel.
CRect | m_rcImageLayoutIconPadding
Padding around images for xtpTaskItemLayoutImages layout.
CRect | m_rcItemIconPadding
Padding around images for items.
CRect | m_rcGroupIconPadding
Padding around images for groups.
BOOL | m_bOfficeHighlight
TRUE to highlight group items and scroll buttons using the Office XP style (XPCOLOR_HIGHLIGHT, XPCOLOR_HIGHLIGHT_CHECKED, XPCOLOR_HIGHLIGHT_PUSHED).
BOOL | m_bInvertDragRect
Only used when the theme is set to xtpTaskPanelThemeVisualStudio2003.
BOOL | m_bCaptionScrollButton
TRUE if the group caption scroll button is visible, FALSE if the group caption scroll button is hidden.
BOOL | m_bEmbossedDisabledText
TRUE to draw disabled text embossed.
- Static Public Attributes inherited from CXTPTaskPanelPaintManager
static const CRect | rectDefault
System selected default margins.
- Protected Member Functions inherited from CXTPTaskPanelVisualStudio2012Theme
- Protected Member Functions inherited from CXTPTaskPanelVisualStudio2005Theme
- Protected Member Functions inherited from CXTPTaskPanelToolboxTheme
- Protected Member Functions inherited from CXTPTaskPanelPaintManager
CRect | DrawGroupItemImageWithText (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw)
Draws the icon of a specified group item.
CRect | DrawGroupItemImageWithTextBelow (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw)
Draws the icon of a specified group item.
CRect | DrawGroupItemImage (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw)
Draws the icon of a specified group item.
virtual void | DrawGroupClientItems (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Draws the items of a specified group.
virtual CRect | DrawCaptionGripper (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Draws the caption gripper of a specified group.
virtual int | GetCaptionGripperWidth (CXTPTaskPanelGroup *pGroup, CRect rc)
Retrieves the width of the caption gripper of a specified group.
virtual void | DrawItemImage (CDC *pDC, CXTPTaskPanelItem *pItem, CPoint ptIcon, CXTPImageManagerIcon *pImage, CSize szIcon)
Draws the icon of a specified item.
COLORREF | BlendColor (COLORREF clrFrom, COLORREF clrTo, int nAlpha)
Blends one color to another color by a specified amount.
CRect | DrawCaptionGripperBitmap (CDC *pDC, CXTPTaskPanelGroup *pGroup, BOOL bExpanded, BOOL bHot, CRect rc)
Draws the caption gripper bitmap.
void | DrawCaptionGripperSigns (CDC *pDC, CPoint pt, COLORREF clr, BOOL bExpanded)
Draws the ">>" and "<<" signs of the caption gripper when the theme of the Task Panel is set to Office 2000.
void | CreateGripperBitmaps ()
Loads the gripper bitmap when the theme of the Task Panel is set to either Windows XP or Classic Windows XP.
void | CreateGripperIcon (HICON &hIcon, UINT nIDResource, COLORREF clrGripperBack)
Creates the gripper bitmap icons when the theme of the Task Panel is set to either Windows XP or Classic Windows XP and either the operating system is not Windows XP or the operating system is Windows XP and Luna themes are used.
void | FreeBitmaps ()
Frees the memory used by the group caption bitmaps.
void | Rectangle (CDC *pDC, CRect rc, COLORREF clrPen, COLORREF clrBrush)
This method is only used when drawing hot, pressed, and selected group items and scroll buttons when m_bOfficeHighlight is TRUE.
virtual CPoint | GetHighlightOffset (CXTPTaskPanelGroupItem *pItem)
Retrieves the highlight offset of the text of a specified group item.
virtual void | DrawDragArrow (CDC *pDC, CXTPTaskPanelItem *pItem, CRect rc, BOOL bAfter=FALSE)
Draws the "drag arrow" of a specified item.
virtual void | DrawFocusRect (CDC *pDC, CRect rc)
Draws a rectangle around the focused item.
- Protected Attributes inherited from CXTPTaskPanelVisualStudio2012Theme
CXTPPaintManagerColor | m_clrSelectedWithoutFocus
Color of the selected item when the Task Panel does not have focus.
CXTPPaintManagerColor | m_clrText
Normal text color.
CXTPPaintManagerColor | m_clrSelectedText
Text color of the selected item.
CXTPPaintManagerColor | m_clrSelectedTextWithoutFocus
Text color of the selected item when the Task Panel does not have focus.
- Protected Attributes inherited from CXTPTaskPanelPaintManagerPlain
BOOL | m_bRoundedFrame
TRUE to draw a rounded frame around all of the groups in the task panel.
BOOL | m_bOfficeCaption
FALSE to draw a rounded rectangle around caption.
- Protected Attributes inherited from CXTPTaskPanelPaintManager
BOOL | m_bUseBitmapGrippers
TRUE to use alpha grippers.
HICON | m_hGripperNormal
Icon of normal group header gripper.
HICON | m_hGripperSpecial
Icon of special group header gripper.
HBITMAP | m_bmpGrippers [8]
Bitmaps of alpha grippers.
CXTPFont | m_xtpFontCaption
Caption font.
CXTPFont | m_xtpFontIcon
Normal items font.
CXTPFont | m_xtpFontIconBold
Bold items font.
CXTPFont | m_xtpFontIconHot
"Hot" items font.
CXTPFont | m_xtpFontIconHotBold
Bold items font.
CXTPPaintManagerColorGradient | m_clrBackground
Background color of the Task Panel.
XTP_TASKPANEL_GROUPCOLORS | m_groupNormal
Normal colors set.
XTP_TASKPANEL_GROUPCOLORS | m_groupSpecial
Special colors set.
CXTPPaintManagerColor | m_clrHighlightHot
Color of items when they are "hot." This is the color of the item on mouseover if hot tracking is enabled.
CXTPPaintManagerColor m_clrHighlightSelected
Color of items when they are selected.
CXTPPaintManagerColor m_clrHighlightPressed
Color of items when they are pressed.
CXTPPaintManagerColorGradient | m_clrHighlightBorder
Border color of items when they are "hot." This is the border color of the item on mouse over if hot tracking is enabled.
BOOL | m_bOfficeBorder
TRUE to use Office borders.
BOOL | m_bLeftRoundedCorner
TRUE to round left corner of the group caption.
BOOL | m_bRightRoundedCorner
TRUE to round right corner of the group caption.
int | m_nCaptionHeight
Caption height, in pixels.
BOOL | m_bUseStandardCaptionFont
TRUE to use system font for group caption text.
BOOL | m_bUseStandardItemsFont
TRUE to use system font for item caption text.
int | m_nItemTextFormat
Format flags of item text.
int | m_nCaptionTextFormat
Format flags of caption text.

Detailed Description

CXTPTaskPanelNativeWindows10Theme represents a Native Windows 10 style theme.

See also
CXTPTaskPanel::SetTheme
The documentation for this class was generated from the following file:
  • XTPTaskPanelNativeWindows10Theme.h


Toolkit Pro: CXTPTaskPanelNativeWindows11Theme Class Reference

Public Member Functions | List of all members
CXTPTaskPanelNativeWindows11Theme Class Reference

CXTPTaskPanelNativeWindows11Theme represents a Native Windows 10 style theme. More...

Inheritance diagram for CXTPTaskPanelNativeWindows11Theme:
[legend]

Public Member Functions

CXTPTaskPanelNativeWindows11Theme ()
Constructs a CXTPTaskPanelNativeWindows11Theme object.
virtual | ~CXTPTaskPanelNativeWindows11Theme ()
Destroys a CXTPTaskPanelNativeWindows11Theme object, handles cleanup and deallocation.
virtual void | RefreshMetrics ()
Refreshes the visual metrics of the task panel.
- Public Member Functions inherited from CXTPTaskPanelVisualStudio2012Theme
CXTPTaskPanelVisualStudio2012Theme (BOOL bLight=TRUE)
Constructs a CXTPTaskPanelVisualStudio2012Theme object.
virtual | ~CXTPTaskPanelVisualStudio2012Theme ()
Destroys a CXTPTaskPanelVisualStudio2012Theme object, handles cleanup and deallocation.
CRect | DrawGroupCaptionBackground (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Draws the group caption background of a specified group.
void | DrawGroupClientFace (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Draws the client face of a specified group.
virtual void | DrawGroupItemFrame (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc)
Draws a rectangle around a group item when it is selected, pressed or highlighted.
void | FillGroupClientFace (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Fills the client face of a specified group.
void | FillTaskPanel (CDC *pDC, CXTPTaskPanel *pTaskPanel)
Fills the background of a specified task panel.
virtual void | DrawItemCaption (CDC *pDC, CXTPTaskPanelItem *pItem, CRect rcText, UINT nFormat)
Draws the text caption of a specified item.
- Public Member Functions inherited from CXTPTaskPanelVisualStudio2005Theme
CXTPTaskPanelVisualStudio2005Theme ()
Constructs a CXTPTaskPanelVisualStudio2005Theme object.
- Public Member Functions inherited from CXTPTaskPanelToolboxTheme
CXTPTaskPanelToolboxTheme ()
Constructs a CXTPTaskPanelToolboxTheme object.
int | DrawGroupCaption (CDC *pDC, CXTPTaskPanelGroup *pGroup, BOOL bDraw)
Draws the caption of a specified group.
- Public Member Functions inherited from CXTPTaskPanelPaintManagerPlain
CXTPTaskPanelPaintManagerPlain ()
Constructs a CXTPTaskPanelPaintManagerPlain object.
- Public Member Functions inherited from CXTPTaskPanelPaintManager
CXTPTaskPanelPaintManager ()
Constructs a CXTPTaskPanelPaintManager object.
virtual | ~CXTPTaskPanelPaintManager ()
Destroys a CXTPTaskPanelPaintManager object, handles cleanup and deallocation.
virtual void | DrawGroupClient (CDC *pDC, CXTPTaskPanelGroup *pGroup)
Draws a specified group.
virtual CRect | DrawGroupItem (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw)
Draws a specified group item.
XTP_TASKPANEL_GROUPCOLORS * | GetGroupColors (BOOL bSpecial)
Retrieves a specified group color set.
virtual XTP_TASKPANEL_GROUPCOLORS * | GetGroupColors (CXTPTaskPanelGroup *pGroup)
Retrieves a specified group color set.
virtual CRect | GetItemOuterMargins (const CXTPTaskPanelGroupItem *pItem)
Retrieves the outer margins of a specified group item.
virtual CRect | GetItemInnerMargins (const CXTPTaskPanelGroupItem *pItem)
Retrieves the inner margins of a specified group item.
virtual CRect | GetGroupOuterMargins (const CXTPTaskPanelGroup *pGroup)
Retrieves the outer margins of a specified group.
virtual CRect | GetItemIconPadding (const CXTPTaskPanelItem *pItem)
Retrieves the icon padding of a specified item.
virtual CRect | GetGroupInnerMargins (const CXTPTaskPanelGroup *pGroup)
Retrieves the inner margins of a specified group.
virtual CRect | GetControlMargins (const CXTPTaskPanel *pPanel)
Gets the default margins used for all groups within a specified Task Panel control.
virtual int | GetGroupSpacing (const CXTPTaskPanel *pPanel)
Gets the spacing used between groups within a specified Task Panel control.
virtual void | DrawScrollButton (CDC *pDC, CXTPTaskPanelScrollButton *pScrollButton)
Draws a group scroll button.
void | SetTextFormat (int nTextFormat, BOOL bCaption=FALSE)
Sets the text format for captions/items.
void | SetItemsFontIndirect (LOGFONT *pLogFont, BOOL bUseStandardItemsFont=FALSE)
Sets the text font for items.
void | SetCaptionFontIndirect (LOGFONT *pLogFont, BOOL bUseStandardCaptionFont=FALSE)
Sets the text font for captions.
virtual CFont * | GetItemFont (CXTPTaskPanelItem *pItem)
Retrieves the text font of a specified item.

Additional Inherited Members

- Public Attributes inherited from CXTPTaskPanelPaintManager
BOOL | m_bEmulateEplorerTheme
TRUE to use Explorer theme under WinXP and Office 2000 under older OS.
XTPTaskPanelGripper | m_eGripper
Gripper of the manager.
BOOL | m_bBoldCaption
TRUE to display caption text in bold font, FALSE to display caption text in normal type.
CRect | m_rcGroupOuterMargins
Outer margins of the group.
CRect | m_rcGroupInnerMargins
Inner margins of the group.
CRect | m_rcItemOuterMargins
Outer margins of the group items.
CRect | m_rcItemInnerMargins
Inner margins of the group items.
CRect | m_rcControlMargins
Default margins for all groups.
int | m_nGroupSpacing
Amount of space placed between groups in the task panel.
CRect | m_rcImageLayoutIconPadding
Padding around images for xtpTaskItemLayoutImages layout.
CRect | m_rcItemIconPadding
Padding around images for items.
CRect | m_rcGroupIconPadding
Padding around images for groups.
BOOL | m_bOfficeHighlight
TRUE to highlight group items and scroll buttons using the Office XP style (XPCOLOR_HIGHLIGHT, XPCOLOR_HIGHLIGHT_CHECKED, XPCOLOR_HIGHLIGHT_PUSHED).
BOOL | m_bInvertDragRect
Only used when the theme is set to xtpTaskPanelThemeVisualStudio2003.
BOOL | m_bCaptionScrollButton
TRUE if the group caption scroll button is visible, FALSE if the group caption scroll button is hidden.
BOOL | m_bEmbossedDisabledText
TRUE to draw disabled text embossed.
- Static Public Attributes inherited from CXTPTaskPanelPaintManager
static const CRect | rectDefault
System selected default margins.
- Protected Member Functions inherited from CXTPTaskPanelVisualStudio2012Theme
- Protected Member Functions inherited from CXTPTaskPanelVisualStudio2005Theme
- Protected Member Functions inherited from CXTPTaskPanelToolboxTheme
- Protected Member Functions inherited from CXTPTaskPanelPaintManager
CRect | DrawGroupItemImageWithText (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw)
Draws the icon of a specified group item.
CRect | DrawGroupItemImageWithTextBelow (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw)
Draws the icon of a specified group item.
CRect | DrawGroupItemImage (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw)
Draws the icon of a specified group item.
virtual void | DrawGroupClientItems (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Draws the items of a specified group.
virtual CRect | DrawCaptionGripper (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Draws the caption gripper of a specified group.
virtual int | GetCaptionGripperWidth (CXTPTaskPanelGroup *pGroup, CRect rc)
Retrieves the width of the caption gripper of a specified group.
virtual void | DrawItemImage (CDC *pDC, CXTPTaskPanelItem *pItem, CPoint ptIcon, CXTPImageManagerIcon *pImage, CSize szIcon)
Draws the icon of a specified item.
COLORREF | BlendColor (COLORREF clrFrom, COLORREF clrTo, int nAlpha)
Blends one color to another color by a specified amount.
CRect | DrawCaptionGripperBitmap (CDC *pDC, CXTPTaskPanelGroup *pGroup, BOOL bExpanded, BOOL bHot, CRect rc)
Draws the caption gripper bitmap.
void | DrawCaptionGripperSigns (CDC *pDC, CPoint pt, COLORREF clr, BOOL bExpanded)
Draws the ">>" and "<<" signs of the caption gripper when the theme of the Task Panel is set to Office 2000.
void | CreateGripperBitmaps ()
Loads the gripper bitmap when the theme of the Task Panel is set to either Windows XP or Classic Windows XP.
void | CreateGripperIcon (HICON &hIcon, UINT nIDResource, COLORREF clrGripperBack)
Creates the gripper bitmap icons when the theme of the Task Panel is set to either Windows XP or Classic Windows XP and either the operating system is not Windows XP or the operating system is Windows XP and Luna themes are used.
void | FreeBitmaps ()
Frees the memory used by the group caption bitmaps.
void | Rectangle (CDC *pDC, CRect rc, COLORREF clrPen, COLORREF clrBrush)
This method is only used when drawing hot, pressed, and selected group items and scroll buttons when m_bOfficeHighlight is TRUE.
virtual CPoint | GetHighlightOffset (CXTPTaskPanelGroupItem *pItem)
Retrieves the highlight offset of the text of a specified group item.
virtual void | DrawDragArrow (CDC *pDC, CXTPTaskPanelItem *pItem, CRect rc, BOOL bAfter=FALSE)
Draws the "drag arrow" of a specified item.
virtual void | DrawFocusRect (CDC *pDC, CRect rc)
Draws a rectangle around the focused item.
- Protected Attributes inherited from CXTPTaskPanelVisualStudio2012Theme
CXTPPaintManagerColor | m_clrSelectedWithoutFocus
Color of the selected item when the Task Panel does not have focus.
CXTPPaintManagerColor | m_clrText
Normal text color.
CXTPPaintManagerColor | m_clrSelectedText
Text color of the selected item.
CXTPPaintManagerColor | m_clrSelectedTextWithoutFocus
Text color of the selected item when the Task Panel does not have focus.
- Protected Attributes inherited from CXTPTaskPanelPaintManagerPlain
BOOL | m_bRoundedFrame
TRUE to draw a rounded frame around all of the groups in the task panel.
BOOL | m_bOfficeCaption
FALSE to draw a rounded rectangle around caption.
- Protected Attributes inherited from CXTPTaskPanelPaintManager
BOOL | m_bUseBitmapGrippers
TRUE to use alpha grippers.
HICON | m_hGripperNormal
Icon of normal group header gripper.
HICON | m_hGripperSpecial
Icon of special group header gripper.
HBITMAP | m_bmpGrippers [8]
Bitmaps of alpha grippers.
CXTPFont | m_xtpFontCaption
Caption font.
CXTPFont | m_xtpFontIcon
Normal items font.
CXTPFont | m_xtpFontIconBold
Bold items font.
CXTPFont | m_xtpFontIconHot
"Hot" items font.
CXTPFont | m_xtpFontIconHotBold
Bold items font.
CXTPPaintManagerColorGradient | m_clrBackground
Background color of the Task Panel.
XTP_TASKPANEL_GROUPCOLORS | m_groupNormal
Normal colors set.
XTP_TASKPANEL_GROUPCOLORS | m_groupSpecial
Special colors set.
CXTPPaintManagerColor | m_clrHighlightHot
Color of items when they are "hot." This is the color of the item on mouseover if hot tracking is enabled.
CXTPPaintManagerColor m_clrHighlightSelected
Color of items when they are selected.
CXTPPaintManagerColor m_clrHighlightPressed
Color of items when they are pressed.
CXTPPaintManagerColorGradient | m_clrHighlightBorder
Border color of items when they are "hot." This is the border color of the item on mouse over if hot tracking is enabled.
BOOL | m_bOfficeBorder
TRUE to use Office borders.
BOOL | m_bLeftRoundedCorner
TRUE to round left corner of the group caption.
BOOL | m_bRightRoundedCorner
TRUE to round right corner of the group caption.
int | m_nCaptionHeight
Caption height, in pixels.
BOOL | m_bUseStandardCaptionFont
TRUE to use system font for group caption text.
BOOL | m_bUseStandardItemsFont
TRUE to use system font for item caption text.
int | m_nItemTextFormat
Format flags of item text.
int | m_nCaptionTextFormat
Format flags of caption text.

Detailed Description

CXTPTaskPanelNativeWindows11Theme represents a Native Windows 10 style theme.

See also
CXTPTaskPanel::SetTheme
The documentation for this class was generated from the following file:
  • XTPTaskPanelNativeWindows11Theme.h


Toolkit Pro: CXTPTaskPanelOffice2003Theme Class Reference

Public Member Functions | List of all members
CXTPTaskPanelOffice2003Theme Class Reference

CXTPTaskPanelOffice2003Theme represents an Office 2003 style theme. More...

Inheritance diagram for CXTPTaskPanelOffice2003Theme:
[legend]

Public Member Functions

CXTPTaskPanelOffice2003Theme ()
Constructs a CXTPTaskPanelOffice2003Theme object.
void | RefreshMetrics ()
Refreshes the visual metrics of the task panel.
- Public Member Functions inherited from CXTPTaskPanelPaintManager
CXTPTaskPanelPaintManager ()
Constructs a CXTPTaskPanelPaintManager object.
virtual | ~CXTPTaskPanelPaintManager ()
Destroys a CXTPTaskPanelPaintManager object, handles cleanup and deallocation.
virtual void | FillTaskPanel (CDC *pDC, CXTPTaskPanel *pTaskPanel)
Fills the background of a specified task panel.
virtual void | DrawGroupClient (CDC *pDC, CXTPTaskPanelGroup *pGroup)
Draws a specified group.
virtual int | DrawGroupCaption (CDC *pDC, CXTPTaskPanelGroup *pGroup, BOOL bDraw)
Draws the caption of a specified group.
virtual CRect | DrawGroupItem (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw)
Draws a specified group item.
XTP_TASKPANEL_GROUPCOLORS * | GetGroupColors (BOOL bSpecial)
Retrieves a specified group color set.
virtual XTP_TASKPANEL_GROUPCOLORS * | GetGroupColors (CXTPTaskPanelGroup *pGroup)
Retrieves a specified group color set.
virtual void | DrawGroupItemFrame (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc)
Draws a rectangle around a group item when it is selected, pressed or highlighted.
virtual CRect | GetItemOuterMargins (const CXTPTaskPanelGroupItem *pItem)
Retrieves the outer margins of a specified group item.
virtual CRect | GetItemInnerMargins (const CXTPTaskPanelGroupItem *pItem)
Retrieves the inner margins of a specified group item.
virtual CRect | GetGroupOuterMargins (const CXTPTaskPanelGroup *pGroup)
Retrieves the outer margins of a specified group.
virtual CRect | GetItemIconPadding (const CXTPTaskPanelItem *pItem)
Retrieves the icon padding of a specified item.
virtual CRect | GetGroupInnerMargins (const CXTPTaskPanelGroup *pGroup)
Retrieves the inner margins of a specified group.
virtual CRect | GetControlMargins (const CXTPTaskPanel *pPanel)
Gets the default margins used for all groups within a specified Task Panel control.
virtual int | GetGroupSpacing (const CXTPTaskPanel *pPanel)
Gets the spacing used between groups within a specified Task Panel control.
virtual void | DrawScrollButton (CDC *pDC, CXTPTaskPanelScrollButton *pScrollButton)
Draws a group scroll button.
void | SetTextFormat (int nTextFormat, BOOL bCaption=FALSE)
Sets the text format for captions/items.
void | SetItemsFontIndirect (LOGFONT *pLogFont, BOOL bUseStandardItemsFont=FALSE)
Sets the text font for items.
void | SetCaptionFontIndirect (LOGFONT *pLogFont, BOOL bUseStandardCaptionFont=FALSE)
Sets the text font for captions.
virtual CFont * | GetItemFont (CXTPTaskPanelItem *pItem)
Retrieves the text font of a specified item.
virtual void | FillGroupClientFace (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Fills the client face of a specified group.

Additional Inherited Members

- Public Attributes inherited from CXTPTaskPanelPaintManager
BOOL | m_bEmulateEplorerTheme
TRUE to use Explorer theme under WinXP and Office 2000 under older OS.
XTPTaskPanelGripper | m_eGripper
Gripper of the manager.
BOOL | m_bBoldCaption
TRUE to display caption text in bold font, FALSE to display caption text in normal type.
CRect | m_rcGroupOuterMargins
Outer margins of the group.
CRect | m_rcGroupInnerMargins
Inner margins of the group.
CRect | m_rcItemOuterMargins
Outer margins of the group items.
CRect | m_rcItemInnerMargins
Inner margins of the group items.
CRect | m_rcControlMargins
Default margins for all groups.
int | m_nGroupSpacing
Amount of space placed between groups in the task panel.
CRect | m_rcImageLayoutIconPadding
Padding around images for xtpTaskItemLayoutImages layout.
CRect | m_rcItemIconPadding
Padding around images for items.
CRect | m_rcGroupIconPadding
Padding around images for groups.
BOOL | m_bOfficeHighlight
TRUE to highlight group items and scroll buttons using the Office XP style (XPCOLOR_HIGHLIGHT, XPCOLOR_HIGHLIGHT_CHECKED, XPCOLOR_HIGHLIGHT_PUSHED).
BOOL | m_bInvertDragRect
Only used when the theme is set to xtpTaskPanelThemeVisualStudio2003.
BOOL | m_bCaptionScrollButton
TRUE if the group caption scroll button is visible, FALSE if the group caption scroll button is hidden.
BOOL | m_bEmbossedDisabledText
TRUE to draw disabled text embossed.
- Static Public Attributes inherited from CXTPTaskPanelPaintManager
static const CRect | rectDefault
System selected default margins.
- Protected Member Functions inherited from CXTPTaskPanelPaintManager
CRect | DrawGroupItemImageWithText (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw)
Draws the icon of a specified group item.
CRect | DrawGroupItemImageWithTextBelow (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw)
Draws the icon of a specified group item.
CRect | DrawGroupItemImage (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw)
Draws the icon of a specified group item.
virtual void | DrawGroupClientFace (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Draws the client face of a specified group.
virtual void | DrawGroupClientItems (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Draws the items of a specified group.
virtual CRect | DrawCaptionGripper (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Draws the caption gripper of a specified group.
virtual int | GetCaptionGripperWidth (CXTPTaskPanelGroup *pGroup, CRect rc)
Retrieves the width of the caption gripper of a specified group.
virtual void | DrawItemCaption (CDC *pDC, CXTPTaskPanelItem *pItem, CRect rcText, UINT nFormat)
Draws the text caption of a specified item.
virtual void | DrawItemImage (CDC *pDC, CXTPTaskPanelItem *pItem, CPoint ptIcon, CXTPImageManagerIcon *pImage, CSize szIcon)
Draws the icon of a specified item.
COLORREF | BlendColor (COLORREF clrFrom, COLORREF clrTo, int nAlpha)
Blends one color to another color by a specified amount.
CRect | DrawCaptionGripperBitmap (CDC *pDC, CXTPTaskPanelGroup *pGroup, BOOL bExpanded, BOOL bHot, CRect rc)
Draws the caption gripper bitmap.
void | DrawCaptionGripperSigns (CDC *pDC, CPoint pt, COLORREF clr, BOOL bExpanded)
Draws the ">>" and "<<" signs of the caption gripper when the theme of the Task Panel is set to Office 2000.
void | CreateGripperBitmaps ()
Loads the gripper bitmap when the theme of the Task Panel is set to either Windows XP or Classic Windows XP.
void | CreateGripperIcon (HICON &hIcon, UINT nIDResource, COLORREF clrGripperBack)
Creates the gripper bitmap icons when the theme of the Task Panel is set to either Windows XP or Classic Windows XP and either the operating system is not Windows XP or the operating system is Windows XP and Luna themes are used.
void | FreeBitmaps ()
Frees the memory used by the group caption bitmaps.
void | Rectangle (CDC *pDC, CRect rc, COLORREF clrPen, COLORREF clrBrush)
This method is only used when drawing hot, pressed, and selected group items and scroll buttons when m_bOfficeHighlight is TRUE.
virtual CPoint | GetHighlightOffset (CXTPTaskPanelGroupItem *pItem)
Retrieves the highlight offset of the text of a specified group item.
virtual void | DrawDragArrow (CDC *pDC, CXTPTaskPanelItem *pItem, CRect rc, BOOL bAfter=FALSE)
Draws the "drag arrow" of a specified item.
virtual void | DrawFocusRect (CDC *pDC, CRect rc)
Draws a rectangle around the focused item.
- Protected Attributes inherited from CXTPTaskPanelPaintManager
BOOL | m_bUseBitmapGrippers
TRUE to use alpha grippers.
HICON | m_hGripperNormal
Icon of normal group header gripper.
HICON | m_hGripperSpecial
Icon of special group header gripper.
HBITMAP | m_bmpGrippers [8]
Bitmaps of alpha grippers.
CXTPFont | m_xtpFontCaption
Caption font.
CXTPFont | m_xtpFontIcon
Normal items font.
CXTPFont | m_xtpFontIconBold
Bold items font.
CXTPFont | m_xtpFontIconHot
"Hot" items font.
CXTPFont | m_xtpFontIconHotBold
Bold items font.
CXTPPaintManagerColorGradient | m_clrBackground
Background color of the Task Panel.
XTP_TASKPANEL_GROUPCOLORS | m_groupNormal
Normal colors set.
XTP_TASKPANEL_GROUPCOLORS | m_groupSpecial
Special colors set.
CXTPPaintManagerColor | m_clrHighlightHot
Color of items when they are "hot." This is the color of the item on mouseover if hot tracking is enabled.
CXTPPaintManagerColor m_clrHighlightSelected
Color of items when they are selected.
CXTPPaintManagerColor m_clrHighlightPressed
Color of items when they are pressed.
CXTPPaintManagerColorGradient | m_clrHighlightBorder
Border color of items when they are "hot." This is the border color of the item on mouse over if hot tracking is enabled.
BOOL | m_bOfficeBorder
TRUE to use Office borders.
BOOL | m_bLeftRoundedCorner
TRUE to round left corner of the group caption.
BOOL | m_bRightRoundedCorner
TRUE to round right corner of the group caption.
int | m_nCaptionHeight
Caption height, in pixels.
BOOL | m_bUseStandardCaptionFont
TRUE to use system font for group caption text.
BOOL | m_bUseStandardItemsFont
TRUE to use system font for item caption text.
int | m_nItemTextFormat
Format flags of item text.
int | m_nCaptionTextFormat
Format flags of caption text.

Detailed Description

CXTPTaskPanelOffice2003Theme represents an Office 2003 style theme.

See also
CXTPTaskPanel::SetTheme
The documentation for this class was generated from the following file:
  • XTPTaskPanelOffice2003Theme.h


Toolkit Pro: CXTPTaskPanelOffice2003ThemePlain Class Reference

Public Member Functions | List of all members
CXTPTaskPanelOffice2003ThemePlain Class Reference

CXTPTaskPanelOffice2003ThemePlain represents a classic Office 2003 style theme. More...

Inheritance diagram for CXTPTaskPanelOffice2003ThemePlain:
[legend]

Public Member Functions

CXTPTaskPanelOffice2003ThemePlain ()
Constructs a CXTPTaskPanelOffice2003ThemePlain object.
void | RefreshMetrics ()
Refreshes the visual metrics of the task panel.
- Public Member Functions inherited from CXTPTaskPanelOfficeXPThemePlain
CXTPTaskPanelOfficeXPThemePlain ()
Constructs a CXTPTaskPanelOfficeXPThemePlain object.
void | RefreshMetrics ()
Refreshes the visual metrics of the task panel.
- Public Member Functions inherited from CXTPTaskPanelPaintManagerPlain
CXTPTaskPanelPaintManagerPlain ()
Constructs a CXTPTaskPanelPaintManagerPlain object.
void | RefreshMetrics ()
Refreshes the visual metrics of the task panel.
void | DrawGroupClientFace (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Draws the client face of a specified group.
void | FillGroupClientFace (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Fills the client face of a specified group.
void | FillTaskPanel (CDC *pDC, CXTPTaskPanel *pTaskPanel)
Fills the background of a specified task panel.
int | DrawGroupCaption (CDC *pDC, CXTPTaskPanelGroup *pGroup, BOOL bDraw)
Draws the caption of a specified group.
- Public Member Functions inherited from CXTPTaskPanelPaintManager
CXTPTaskPanelPaintManager ()
Constructs a CXTPTaskPanelPaintManager object.
virtual | ~CXTPTaskPanelPaintManager ()
Destroys a CXTPTaskPanelPaintManager object, handles cleanup and deallocation.
virtual void | DrawGroupClient (CDC *pDC, CXTPTaskPanelGroup *pGroup)
Draws a specified group.
virtual CRect | DrawGroupItem (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw)
Draws a specified group item.
XTP_TASKPANEL_GROUPCOLORS * | GetGroupColors (BOOL bSpecial)
Retrieves a specified group color set.
virtual XTP_TASKPANEL_GROUPCOLORS * | GetGroupColors (CXTPTaskPanelGroup *pGroup)
Retrieves a specified group color set.
virtual void | DrawGroupItemFrame (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc)
Draws a rectangle around a group item when it is selected, pressed or highlighted.
virtual CRect | GetItemOuterMargins (const CXTPTaskPanelGroupItem *pItem)
Retrieves the outer margins of a specified group item.
virtual CRect | GetItemInnerMargins (const CXTPTaskPanelGroupItem *pItem)
Retrieves the inner margins of a specified group item.
virtual CRect | GetGroupOuterMargins (const CXTPTaskPanelGroup *pGroup)
Retrieves the outer margins of a specified group.
virtual CRect | GetItemIconPadding (const CXTPTaskPanelItem *pItem)
Retrieves the icon padding of a specified item.
virtual CRect | GetGroupInnerMargins (const CXTPTaskPanelGroup *pGroup)
Retrieves the inner margins of a specified group.
virtual CRect | GetControlMargins (const CXTPTaskPanel *pPanel)
Gets the default margins used for all groups within a specified Task Panel control.
virtual int | GetGroupSpacing (const CXTPTaskPanel *pPanel)
Gets the spacing used between groups within a specified Task Panel control.
virtual void | DrawScrollButton (CDC *pDC, CXTPTaskPanelScrollButton *pScrollButton)
Draws a group scroll button.
void | SetTextFormat (int nTextFormat, BOOL bCaption=FALSE)
Sets the text format for captions/items.
void | SetItemsFontIndirect (LOGFONT *pLogFont, BOOL bUseStandardItemsFont=FALSE)
Sets the text font for items.
void | SetCaptionFontIndirect (LOGFONT *pLogFont, BOOL bUseStandardCaptionFont=FALSE)
Sets the text font for captions.
virtual CFont * | GetItemFont (CXTPTaskPanelItem *pItem)
Retrieves the text font of a specified item.

Additional Inherited Members

- Public Attributes inherited from CXTPTaskPanelPaintManager
BOOL | m_bEmulateEplorerTheme
TRUE to use Explorer theme under WinXP and Office 2000 under older OS.
XTPTaskPanelGripper | m_eGripper
Gripper of the manager.
BOOL | m_bBoldCaption
TRUE to display caption text in bold font, FALSE to display caption text in normal type.
CRect | m_rcGroupOuterMargins
Outer margins of the group.
CRect | m_rcGroupInnerMargins
Inner margins of the group.
CRect | m_rcItemOuterMargins
Outer margins of the group items.
CRect | m_rcItemInnerMargins
Inner margins of the group items.
CRect | m_rcControlMargins
Default margins for all groups.
int | m_nGroupSpacing
Amount of space placed between groups in the task panel.
CRect | m_rcImageLayoutIconPadding
Padding around images for xtpTaskItemLayoutImages layout.
CRect | m_rcItemIconPadding
Padding around images for items.
CRect | m_rcGroupIconPadding
Padding around images for groups.
BOOL | m_bOfficeHighlight
TRUE to highlight group items and scroll buttons using the Office XP style (XPCOLOR_HIGHLIGHT, XPCOLOR_HIGHLIGHT_CHECKED, XPCOLOR_HIGHLIGHT_PUSHED).
BOOL | m_bInvertDragRect
Only used when the theme is set to xtpTaskPanelThemeVisualStudio2003.
BOOL | m_bCaptionScrollButton
TRUE if the group caption scroll button is visible, FALSE if the group caption scroll button is hidden.
BOOL | m_bEmbossedDisabledText
TRUE to draw disabled text embossed.
- Static Public Attributes inherited from CXTPTaskPanelPaintManager
static const CRect | rectDefault
System selected default margins.
- Protected Member Functions inherited from CXTPTaskPanelPaintManager
CRect | DrawGroupItemImageWithText (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw)
Draws the icon of a specified group item.
CRect | DrawGroupItemImageWithTextBelow (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw)
Draws the icon of a specified group item.
CRect | DrawGroupItemImage (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw)
Draws the icon of a specified group item.
virtual void | DrawGroupClientItems (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Draws the items of a specified group.
virtual CRect | DrawCaptionGripper (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Draws the caption gripper of a specified group.
virtual int | GetCaptionGripperWidth (CXTPTaskPanelGroup *pGroup, CRect rc)
Retrieves the width of the caption gripper of a specified group.
virtual void | DrawItemCaption (CDC *pDC, CXTPTaskPanelItem *pItem, CRect rcText, UINT nFormat)
Draws the text caption of a specified item.
virtual void | DrawItemImage (CDC *pDC, CXTPTaskPanelItem *pItem, CPoint ptIcon, CXTPImageManagerIcon *pImage, CSize szIcon)
Draws the icon of a specified item.
COLORREF | BlendColor (COLORREF clrFrom, COLORREF clrTo, int nAlpha)
Blends one color to another color by a specified amount.
CRect | DrawCaptionGripperBitmap (CDC *pDC, CXTPTaskPanelGroup *pGroup, BOOL bExpanded, BOOL bHot, CRect rc)
Draws the caption gripper bitmap.
void | DrawCaptionGripperSigns (CDC *pDC, CPoint pt, COLORREF clr, BOOL bExpanded)
Draws the ">>" and "<<" signs of the caption gripper when the theme of the Task Panel is set to Office 2000.
void | CreateGripperBitmaps ()
Loads the gripper bitmap when the theme of the Task Panel is set to either Windows XP or Classic Windows XP.
void | CreateGripperIcon (HICON &hIcon, UINT nIDResource, COLORREF clrGripperBack)
Creates the gripper bitmap icons when the theme of the Task Panel is set to either Windows XP or Classic Windows XP and either the operating system is not Windows XP or the operating system is Windows XP and Luna themes are used.
void | FreeBitmaps ()
Frees the memory used by the group caption bitmaps.
void | Rectangle (CDC *pDC, CRect rc, COLORREF clrPen, COLORREF clrBrush)
This method is only used when drawing hot, pressed, and selected group items and scroll buttons when m_bOfficeHighlight is TRUE.
virtual CPoint | GetHighlightOffset (CXTPTaskPanelGroupItem *pItem)
Retrieves the highlight offset of the text of a specified group item.
virtual void | DrawDragArrow (CDC *pDC, CXTPTaskPanelItem *pItem, CRect rc, BOOL bAfter=FALSE)
Draws the "drag arrow" of a specified item.
virtual void | DrawFocusRect (CDC *pDC, CRect rc)
Draws a rectangle around the focused item.
- Protected Attributes inherited from CXTPTaskPanelPaintManagerPlain
BOOL | m_bRoundedFrame
TRUE to draw a rounded frame around all of the groups in the task panel.
BOOL | m_bOfficeCaption
FALSE to draw a rounded rectangle around caption.
- Protected Attributes inherited from CXTPTaskPanelPaintManager
BOOL | m_bUseBitmapGrippers
TRUE to use alpha grippers.
HICON | m_hGripperNormal
Icon of normal group header gripper.
HICON | m_hGripperSpecial
Icon of special group header gripper.
HBITMAP | m_bmpGrippers [8]
Bitmaps of alpha grippers.
CXTPFont | m_xtpFontCaption
Caption font.
CXTPFont | m_xtpFontIcon
Normal items font.
CXTPFont | m_xtpFontIconBold
Bold items font.
CXTPFont | m_xtpFontIconHot
"Hot" items font.
CXTPFont | m_xtpFontIconHotBold
Bold items font.
CXTPPaintManagerColorGradient | m_clrBackground
Background color of the Task Panel.
XTP_TASKPANEL_GROUPCOLORS | m_groupNormal
Normal colors set.
XTP_TASKPANEL_GROUPCOLORS | m_groupSpecial
Special colors set.
CXTPPaintManagerColor | m_clrHighlightHot
Color of items when they are "hot." This is the color of the item on mouseover if hot tracking is enabled.
CXTPPaintManagerColor m_clrHighlightSelected
Color of items when they are selected.
CXTPPaintManagerColor m_clrHighlightPressed
Color of items when they are pressed.
CXTPPaintManagerColorGradient | m_clrHighlightBorder
Border color of items when they are "hot." This is the border color of the item on mouse over if hot tracking is enabled.
BOOL | m_bOfficeBorder
TRUE to use Office borders.
BOOL | m_bLeftRoundedCorner
TRUE to round left corner of the group caption.
BOOL | m_bRightRoundedCorner
TRUE to round right corner of the group caption.
int | m_nCaptionHeight
Caption height, in pixels.
BOOL | m_bUseStandardCaptionFont
TRUE to use system font for group caption text.
BOOL | m_bUseStandardItemsFont
TRUE to use system font for item caption text.
int | m_nItemTextFormat
Format flags of item text.
int | m_nCaptionTextFormat
Format flags of caption text.

Detailed Description

CXTPTaskPanelOffice2003ThemePlain represents a classic Office 2003 style theme.

See also
CXTPTaskPanel::SetTheme
The documentation for this class was generated from the following file:
  • XTPTaskPanelOffice2003ThemePlain.h


Toolkit Pro: CXTPTaskPanelOffice2013Theme Class Reference

Public Member Functions | List of all members
CXTPTaskPanelOffice2013Theme Class Reference

CXTPTaskPanelOffice2013Theme represents an Office 2013 style theme. More...

Inheritance diagram for CXTPTaskPanelOffice2013Theme:
[legend]

Public Member Functions

CXTPTaskPanelOffice2013Theme ()
Constructs a CXTPTaskPanelOffice2013Theme object.
virtual | ~CXTPTaskPanelOffice2013Theme ()
Destroys a CXTPTaskPanelOffice2013Theme object, handles cleanup and deallocation.
virtual void | RefreshMetrics ()
Refreshes the visual metrics of the task panel.
virtual void | FillTaskPanel (CDC *pDC, CXTPTaskPanel *pTaskPanel)
Fills the background of a specified task panel.
- Public Member Functions inherited from CXTPTaskPanelVisualStudio2012Theme
CXTPTaskPanelVisualStudio2012Theme (BOOL bLight=TRUE)
Constructs a CXTPTaskPanelVisualStudio2012Theme object.
virtual | ~CXTPTaskPanelVisualStudio2012Theme ()
Destroys a CXTPTaskPanelVisualStudio2012Theme object, handles cleanup and deallocation.
CRect | DrawGroupCaptionBackground (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Draws the group caption background of a specified group.
void | DrawGroupClientFace (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Draws the client face of a specified group.
virtual void | DrawGroupItemFrame (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc)
Draws a rectangle around a group item when it is selected, pressed or highlighted.
void | FillGroupClientFace (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Fills the client face of a specified group.
void | FillTaskPanel (CDC *pDC, CXTPTaskPanel *pTaskPanel)
Fills the background of a specified task panel.
virtual void | DrawItemCaption (CDC *pDC, CXTPTaskPanelItem *pItem, CRect rcText, UINT nFormat)
Draws the text caption of a specified item.
- Public Member Functions inherited from CXTPTaskPanelVisualStudio2005Theme
CXTPTaskPanelVisualStudio2005Theme ()
Constructs a CXTPTaskPanelVisualStudio2005Theme object.
- Public Member Functions inherited from CXTPTaskPanelToolboxTheme
CXTPTaskPanelToolboxTheme ()
Constructs a CXTPTaskPanelToolboxTheme object.
int | DrawGroupCaption (CDC *pDC, CXTPTaskPanelGroup *pGroup, BOOL bDraw)
Draws the caption of a specified group.
- Public Member Functions inherited from CXTPTaskPanelPaintManagerPlain
CXTPTaskPanelPaintManagerPlain ()
Constructs a CXTPTaskPanelPaintManagerPlain object.
- Public Member Functions inherited from CXTPTaskPanelPaintManager
CXTPTaskPanelPaintManager ()
Constructs a CXTPTaskPanelPaintManager object.
virtual | ~CXTPTaskPanelPaintManager ()
Destroys a CXTPTaskPanelPaintManager object, handles cleanup and deallocation.
virtual void | DrawGroupClient (CDC *pDC, CXTPTaskPanelGroup *pGroup)
Draws a specified group.
virtual CRect | DrawGroupItem (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw)
Draws a specified group item.
XTP_TASKPANEL_GROUPCOLORS * | GetGroupColors (BOOL bSpecial)
Retrieves a specified group color set.
virtual XTP_TASKPANEL_GROUPCOLORS * | GetGroupColors (CXTPTaskPanelGroup *pGroup)
Retrieves a specified group color set.
virtual CRect | GetItemOuterMargins (const CXTPTaskPanelGroupItem *pItem)
Retrieves the outer margins of a specified group item.
virtual CRect | GetItemInnerMargins (const CXTPTaskPanelGroupItem *pItem)
Retrieves the inner margins of a specified group item.
virtual CRect | GetGroupOuterMargins (const CXTPTaskPanelGroup *pGroup)
Retrieves the outer margins of a specified group.
virtual CRect | GetItemIconPadding (const CXTPTaskPanelItem *pItem)
Retrieves the icon padding of a specified item.
virtual CRect | GetGroupInnerMargins (const CXTPTaskPanelGroup *pGroup)
Retrieves the inner margins of a specified group.
virtual CRect | GetControlMargins (const CXTPTaskPanel *pPanel)
Gets the default margins used for all groups within a specified Task Panel control.
virtual int | GetGroupSpacing (const CXTPTaskPanel *pPanel)
Gets the spacing used between groups within a specified Task Panel control.
virtual void | DrawScrollButton (CDC *pDC, CXTPTaskPanelScrollButton *pScrollButton)
Draws a group scroll button.
void | SetTextFormat (int nTextFormat, BOOL bCaption=FALSE)
Sets the text format for captions/items.
void | SetItemsFontIndirect (LOGFONT *pLogFont, BOOL bUseStandardItemsFont=FALSE)
Sets the text font for items.
void | SetCaptionFontIndirect (LOGFONT *pLogFont, BOOL bUseStandardCaptionFont=FALSE)
Sets the text font for captions.
virtual CFont * | GetItemFont (CXTPTaskPanelItem *pItem)
Retrieves the text font of a specified item.

Additional Inherited Members

- Public Attributes inherited from CXTPTaskPanelPaintManager
BOOL | m_bEmulateEplorerTheme
TRUE to use Explorer theme under WinXP and Office 2000 under older OS.
XTPTaskPanelGripper | m_eGripper
Gripper of the manager.
BOOL | m_bBoldCaption
TRUE to display caption text in bold font, FALSE to display caption text in normal type.
CRect | m_rcGroupOuterMargins
Outer margins of the group.
CRect | m_rcGroupInnerMargins
Inner margins of the group.
CRect | m_rcItemOuterMargins
Outer margins of the group items.
CRect | m_rcItemInnerMargins
Inner margins of the group items.
CRect | m_rcControlMargins
Default margins for all groups.
int | m_nGroupSpacing
Amount of space placed between groups in the task panel.
CRect | m_rcImageLayoutIconPadding
Padding around images for xtpTaskItemLayoutImages layout.
CRect | m_rcItemIconPadding
Padding around images for items.
CRect | m_rcGroupIconPadding
Padding around images for groups.
BOOL | m_bOfficeHighlight
TRUE to highlight group items and scroll buttons using the Office XP style (XPCOLOR_HIGHLIGHT, XPCOLOR_HIGHLIGHT_CHECKED, XPCOLOR_HIGHLIGHT_PUSHED).
BOOL | m_bInvertDragRect
Only used when the theme is set to xtpTaskPanelThemeVisualStudio2003.
BOOL | m_bCaptionScrollButton
TRUE if the group caption scroll button is visible, FALSE if the group caption scroll button is hidden.
BOOL | m_bEmbossedDisabledText
TRUE to draw disabled text embossed.
- Static Public Attributes inherited from CXTPTaskPanelPaintManager
static const CRect | rectDefault
System selected default margins.
- Protected Member Functions inherited from CXTPTaskPanelVisualStudio2012Theme
- Protected Member Functions inherited from CXTPTaskPanelVisualStudio2005Theme
- Protected Member Functions inherited from CXTPTaskPanelToolboxTheme
- Protected Member Functions inherited from CXTPTaskPanelPaintManager
CRect | DrawGroupItemImageWithText (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw)
Draws the icon of a specified group item.
CRect | DrawGroupItemImageWithTextBelow (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw)
Draws the icon of a specified group item.
CRect | DrawGroupItemImage (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw)
Draws the icon of a specified group item.
virtual void | DrawGroupClientItems (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Draws the items of a specified group.
virtual CRect | DrawCaptionGripper (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Draws the caption gripper of a specified group.
virtual int | GetCaptionGripperWidth (CXTPTaskPanelGroup *pGroup, CRect rc)
Retrieves the width of the caption gripper of a specified group.
virtual void | DrawItemImage (CDC *pDC, CXTPTaskPanelItem *pItem, CPoint ptIcon, CXTPImageManagerIcon *pImage, CSize szIcon)
Draws the icon of a specified item.
COLORREF | BlendColor (COLORREF clrFrom, COLORREF clrTo, int nAlpha)
Blends one color to another color by a specified amount.
CRect | DrawCaptionGripperBitmap (CDC *pDC, CXTPTaskPanelGroup *pGroup, BOOL bExpanded, BOOL bHot, CRect rc)
Draws the caption gripper bitmap.
void | DrawCaptionGripperSigns (CDC *pDC, CPoint pt, COLORREF clr, BOOL bExpanded)
Draws the ">>" and "<<" signs of the caption gripper when the theme of the Task Panel is set to Office 2000.
void | CreateGripperBitmaps ()
Loads the gripper bitmap when the theme of the Task Panel is set to either Windows XP or Classic Windows XP.
void | CreateGripperIcon (HICON &hIcon, UINT nIDResource, COLORREF clrGripperBack)
Creates the gripper bitmap icons when the theme of the Task Panel is set to either Windows XP or Classic Windows XP and either the operating system is not Windows XP or the operating system is Windows XP and Luna themes are used.
void | FreeBitmaps ()
Frees the memory used by the group caption bitmaps.
void | Rectangle (CDC *pDC, CRect rc, COLORREF clrPen, COLORREF clrBrush)
This method is only used when drawing hot, pressed, and selected group items and scroll buttons when m_bOfficeHighlight is TRUE.
virtual CPoint | GetHighlightOffset (CXTPTaskPanelGroupItem *pItem)
Retrieves the highlight offset of the text of a specified group item.
virtual void | DrawDragArrow (CDC *pDC, CXTPTaskPanelItem *pItem, CRect rc, BOOL bAfter=FALSE)
Draws the "drag arrow" of a specified item.
virtual void | DrawFocusRect (CDC *pDC, CRect rc)
Draws a rectangle around the focused item.
- Protected Attributes inherited from CXTPTaskPanelVisualStudio2012Theme
CXTPPaintManagerColor | m_clrSelectedWithoutFocus
Color of the selected item when the Task Panel does not have focus.
CXTPPaintManagerColor | m_clrText
Normal text color.
CXTPPaintManagerColor | m_clrSelectedText
Text color of the selected item.
CXTPPaintManagerColor | m_clrSelectedTextWithoutFocus
Text color of the selected item when the Task Panel does not have focus.
- Protected Attributes inherited from CXTPTaskPanelPaintManagerPlain
BOOL | m_bRoundedFrame
TRUE to draw a rounded frame around all of the groups in the task panel.
BOOL | m_bOfficeCaption
FALSE to draw a rounded rectangle around caption.
- Protected Attributes inherited from CXTPTaskPanelPaintManager
BOOL | m_bUseBitmapGrippers
TRUE to use alpha grippers.
HICON | m_hGripperNormal
Icon of normal group header gripper.
HICON | m_hGripperSpecial
Icon of special group header gripper.
HBITMAP | m_bmpGrippers [8]
Bitmaps of alpha grippers.
CXTPFont | m_xtpFontCaption
Caption font.
CXTPFont | m_xtpFontIcon
Normal items font.
CXTPFont | m_xtpFontIconBold
Bold items font.
CXTPFont | m_xtpFontIconHot
"Hot" items font.
CXTPFont | m_xtpFontIconHotBold
Bold items font.
CXTPPaintManagerColorGradient | m_clrBackground
Background color of the Task Panel.
XTP_TASKPANEL_GROUPCOLORS | m_groupNormal
Normal colors set.
XTP_TASKPANEL_GROUPCOLORS | m_groupSpecial
Special colors set.
CXTPPaintManagerColor | m_clrHighlightHot
Color of items when they are "hot." This is the color of the item on mouseover if hot tracking is enabled.
CXTPPaintManagerColor m_clrHighlightSelected
Color of items when they are selected.
CXTPPaintManagerColor m_clrHighlightPressed
Color of items when they are pressed.
CXTPPaintManagerColorGradient | m_clrHighlightBorder
Border color of items when they are "hot." This is the border color of the item on mouse over if hot tracking is enabled.
BOOL | m_bOfficeBorder
TRUE to use Office borders.
BOOL | m_bLeftRoundedCorner
TRUE to round left corner of the group caption.
BOOL | m_bRightRoundedCorner
TRUE to round right corner of the group caption.
int | m_nCaptionHeight
Caption height, in pixels.
BOOL | m_bUseStandardCaptionFont
TRUE to use system font for group caption text.
BOOL | m_bUseStandardItemsFont
TRUE to use system font for item caption text.
int | m_nItemTextFormat
Format flags of item text.
int | m_nCaptionTextFormat
Format flags of caption text.

Detailed Description

CXTPTaskPanelOffice2013Theme represents an Office 2013 style theme.

See also
CXTPTaskPanel::SetTheme

Member Function Documentation

◆ FillTaskPanel()

virtual void FillTaskPanel | ( | CDC * | pDC,
 |  | CXTPTaskPanel * | pTaskPanel )
 virtual

Fills the background of a specified task panel.

Parameters
pDC | Pointer to a valid device context.
pTaskPanel | Pointer to the task panel to fill.

Reimplemented from CXTPTaskPanelPaintManager.

The documentation for this class was generated from the following file:
  • XTPTaskPanelOffice2013Theme.h


Toolkit Pro: CXTPTaskPanelOfficeXPThemePlain Class Reference

Public Member Functions | List of all members
CXTPTaskPanelOfficeXPThemePlain Class Reference

CXTPTaskPanelOfficeXPThemePlain represents a classic Office XP style theme. More...

Inheritance diagram for CXTPTaskPanelOfficeXPThemePlain:
[legend]

Public Member Functions

CXTPTaskPanelOfficeXPThemePlain ()
Constructs a CXTPTaskPanelOfficeXPThemePlain object.
void | RefreshMetrics ()
Refreshes the visual metrics of the task panel.
- Public Member Functions inherited from CXTPTaskPanelPaintManagerPlain
CXTPTaskPanelPaintManagerPlain ()
Constructs a CXTPTaskPanelPaintManagerPlain object.
void | RefreshMetrics ()
Refreshes the visual metrics of the task panel.
void | DrawGroupClientFace (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Draws the client face of a specified group.
void | FillGroupClientFace (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Fills the client face of a specified group.
void | FillTaskPanel (CDC *pDC, CXTPTaskPanel *pTaskPanel)
Fills the background of a specified task panel.
int | DrawGroupCaption (CDC *pDC, CXTPTaskPanelGroup *pGroup, BOOL bDraw)
Draws the caption of a specified group.
- Public Member Functions inherited from CXTPTaskPanelPaintManager
CXTPTaskPanelPaintManager ()
Constructs a CXTPTaskPanelPaintManager object.
virtual | ~CXTPTaskPanelPaintManager ()
Destroys a CXTPTaskPanelPaintManager object, handles cleanup and deallocation.
virtual void | DrawGroupClient (CDC *pDC, CXTPTaskPanelGroup *pGroup)
Draws a specified group.
virtual CRect | DrawGroupItem (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw)
Draws a specified group item.
XTP_TASKPANEL_GROUPCOLORS * | GetGroupColors (BOOL bSpecial)
Retrieves a specified group color set.
virtual XTP_TASKPANEL_GROUPCOLORS * | GetGroupColors (CXTPTaskPanelGroup *pGroup)
Retrieves a specified group color set.
virtual void | DrawGroupItemFrame (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc)
Draws a rectangle around a group item when it is selected, pressed or highlighted.
virtual CRect | GetItemOuterMargins (const CXTPTaskPanelGroupItem *pItem)
Retrieves the outer margins of a specified group item.
virtual CRect | GetItemInnerMargins (const CXTPTaskPanelGroupItem *pItem)
Retrieves the inner margins of a specified group item.
virtual CRect | GetGroupOuterMargins (const CXTPTaskPanelGroup *pGroup)
Retrieves the outer margins of a specified group.
virtual CRect | GetItemIconPadding (const CXTPTaskPanelItem *pItem)
Retrieves the icon padding of a specified item.
virtual CRect | GetGroupInnerMargins (const CXTPTaskPanelGroup *pGroup)
Retrieves the inner margins of a specified group.
virtual CRect | GetControlMargins (const CXTPTaskPanel *pPanel)
Gets the default margins used for all groups within a specified Task Panel control.
virtual int | GetGroupSpacing (const CXTPTaskPanel *pPanel)
Gets the spacing used between groups within a specified Task Panel control.
virtual void | DrawScrollButton (CDC *pDC, CXTPTaskPanelScrollButton *pScrollButton)
Draws a group scroll button.
void | SetTextFormat (int nTextFormat, BOOL bCaption=FALSE)
Sets the text format for captions/items.
void | SetItemsFontIndirect (LOGFONT *pLogFont, BOOL bUseStandardItemsFont=FALSE)
Sets the text font for items.
void | SetCaptionFontIndirect (LOGFONT *pLogFont, BOOL bUseStandardCaptionFont=FALSE)
Sets the text font for captions.
virtual CFont * | GetItemFont (CXTPTaskPanelItem *pItem)
Retrieves the text font of a specified item.

Additional Inherited Members

- Public Attributes inherited from CXTPTaskPanelPaintManager
BOOL | m_bEmulateEplorerTheme
TRUE to use Explorer theme under WinXP and Office 2000 under older OS.
XTPTaskPanelGripper | m_eGripper
Gripper of the manager.
BOOL | m_bBoldCaption
TRUE to display caption text in bold font, FALSE to display caption text in normal type.
CRect | m_rcGroupOuterMargins
Outer margins of the group.
CRect | m_rcGroupInnerMargins
Inner margins of the group.
CRect | m_rcItemOuterMargins
Outer margins of the group items.
CRect | m_rcItemInnerMargins
Inner margins of the group items.
CRect | m_rcControlMargins
Default margins for all groups.
int | m_nGroupSpacing
Amount of space placed between groups in the task panel.
CRect | m_rcImageLayoutIconPadding
Padding around images for xtpTaskItemLayoutImages layout.
CRect | m_rcItemIconPadding
Padding around images for items.
CRect | m_rcGroupIconPadding
Padding around images for groups.
BOOL | m_bOfficeHighlight
TRUE to highlight group items and scroll buttons using the Office XP style (XPCOLOR_HIGHLIGHT, XPCOLOR_HIGHLIGHT_CHECKED, XPCOLOR_HIGHLIGHT_PUSHED).
BOOL | m_bInvertDragRect
Only used when the theme is set to xtpTaskPanelThemeVisualStudio2003.
BOOL | m_bCaptionScrollButton
TRUE if the group caption scroll button is visible, FALSE if the group caption scroll button is hidden.
BOOL | m_bEmbossedDisabledText
TRUE to draw disabled text embossed.
- Static Public Attributes inherited from CXTPTaskPanelPaintManager
static const CRect | rectDefault
System selected default margins.
- Protected Member Functions inherited from CXTPTaskPanelPaintManager
CRect | DrawGroupItemImageWithText (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw)
Draws the icon of a specified group item.
CRect | DrawGroupItemImageWithTextBelow (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw)
Draws the icon of a specified group item.
CRect | DrawGroupItemImage (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw)
Draws the icon of a specified group item.
virtual void | DrawGroupClientItems (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Draws the items of a specified group.
virtual CRect | DrawCaptionGripper (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Draws the caption gripper of a specified group.
virtual int | GetCaptionGripperWidth (CXTPTaskPanelGroup *pGroup, CRect rc)
Retrieves the width of the caption gripper of a specified group.
virtual void | DrawItemCaption (CDC *pDC, CXTPTaskPanelItem *pItem, CRect rcText, UINT nFormat)
Draws the text caption of a specified item.
virtual void | DrawItemImage (CDC *pDC, CXTPTaskPanelItem *pItem, CPoint ptIcon, CXTPImageManagerIcon *pImage, CSize szIcon)
Draws the icon of a specified item.
COLORREF | BlendColor (COLORREF clrFrom, COLORREF clrTo, int nAlpha)
Blends one color to another color by a specified amount.
CRect | DrawCaptionGripperBitmap (CDC *pDC, CXTPTaskPanelGroup *pGroup, BOOL bExpanded, BOOL bHot, CRect rc)
Draws the caption gripper bitmap.
void | DrawCaptionGripperSigns (CDC *pDC, CPoint pt, COLORREF clr, BOOL bExpanded)
Draws the ">>" and "<<" signs of the caption gripper when the theme of the Task Panel is set to Office 2000.
void | CreateGripperBitmaps ()
Loads the gripper bitmap when the theme of the Task Panel is set to either Windows XP or Classic Windows XP.
void | CreateGripperIcon (HICON &hIcon, UINT nIDResource, COLORREF clrGripperBack)
Creates the gripper bitmap icons when the theme of the Task Panel is set to either Windows XP or Classic Windows XP and either the operating system is not Windows XP or the operating system is Windows XP and Luna themes are used.
void | FreeBitmaps ()
Frees the memory used by the group caption bitmaps.
void | Rectangle (CDC *pDC, CRect rc, COLORREF clrPen, COLORREF clrBrush)
This method is only used when drawing hot, pressed, and selected group items and scroll buttons when m_bOfficeHighlight is TRUE.
virtual CPoint | GetHighlightOffset (CXTPTaskPanelGroupItem *pItem)
Retrieves the highlight offset of the text of a specified group item.
virtual void | DrawDragArrow (CDC *pDC, CXTPTaskPanelItem *pItem, CRect rc, BOOL bAfter=FALSE)
Draws the "drag arrow" of a specified item.
virtual void | DrawFocusRect (CDC *pDC, CRect rc)
Draws a rectangle around the focused item.
- Protected Attributes inherited from CXTPTaskPanelPaintManagerPlain
BOOL | m_bRoundedFrame
TRUE to draw a rounded frame around all of the groups in the task panel.
BOOL | m_bOfficeCaption
FALSE to draw a rounded rectangle around caption.
- Protected Attributes inherited from CXTPTaskPanelPaintManager
BOOL | m_bUseBitmapGrippers
TRUE to use alpha grippers.
HICON | m_hGripperNormal
Icon of normal group header gripper.
HICON | m_hGripperSpecial
Icon of special group header gripper.
HBITMAP | m_bmpGrippers [8]
Bitmaps of alpha grippers.
CXTPFont | m_xtpFontCaption
Caption font.
CXTPFont | m_xtpFontIcon
Normal items font.
CXTPFont | m_xtpFontIconBold
Bold items font.
CXTPFont | m_xtpFontIconHot
"Hot" items font.
CXTPFont | m_xtpFontIconHotBold
Bold items font.
CXTPPaintManagerColorGradient | m_clrBackground
Background color of the Task Panel.
XTP_TASKPANEL_GROUPCOLORS | m_groupNormal
Normal colors set.
XTP_TASKPANEL_GROUPCOLORS | m_groupSpecial
Special colors set.
CXTPPaintManagerColor | m_clrHighlightHot
Color of items when they are "hot." This is the color of the item on mouseover if hot tracking is enabled.
CXTPPaintManagerColor m_clrHighlightSelected
Color of items when they are selected.
CXTPPaintManagerColor m_clrHighlightPressed
Color of items when they are pressed.
CXTPPaintManagerColorGradient | m_clrHighlightBorder
Border color of items when they are "hot." This is the border color of the item on mouse over if hot tracking is enabled.
BOOL | m_bOfficeBorder
TRUE to use Office borders.
BOOL | m_bLeftRoundedCorner
TRUE to round left corner of the group caption.
BOOL | m_bRightRoundedCorner
TRUE to round right corner of the group caption.
int | m_nCaptionHeight
Caption height, in pixels.
BOOL | m_bUseStandardCaptionFont
TRUE to use system font for group caption text.
BOOL | m_bUseStandardItemsFont
TRUE to use system font for item caption text.
int | m_nItemTextFormat
Format flags of item text.
int | m_nCaptionTextFormat
Format flags of caption text.

Detailed Description

CXTPTaskPanelOfficeXPThemePlain represents a classic Office XP style theme.

See also
CXTPTaskPanel::SetTheme
The documentation for this class was generated from the following file:
  • XTPTaskPanelOfficeXPThemePlain.h


Toolkit Pro: CXTPTaskPanelPaintManager Class Reference

Public Member Functions | Public Attributes | Static Public Attributes | Protected Member Functions | Protected Attributes | List of all members
CXTPTaskPanelPaintManager Class Reference

CXTPTaskPanelPaintManager is a standalone class used by CXTPTaskPanel as a paint manager. More...

Inheritance diagram for CXTPTaskPanelPaintManager:
[legend]

Public Member Functions

CXTPTaskPanelPaintManager ()
Constructs a CXTPTaskPanelPaintManager object.
virtual | ~CXTPTaskPanelPaintManager ()
Destroys a CXTPTaskPanelPaintManager object, handles cleanup and deallocation.
virtual void | FillTaskPanel (CDC *pDC, CXTPTaskPanel *pTaskPanel)
Fills the background of a specified task panel.
virtual void | DrawGroupClient (CDC *pDC, CXTPTaskPanelGroup *pGroup)
Draws a specified group.
virtual int | DrawGroupCaption (CDC *pDC, CXTPTaskPanelGroup *pGroup, BOOL bDraw)
Draws the caption of a specified group.
virtual CRect | DrawGroupItem (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw)
Draws a specified group item.
virtual void | RefreshMetrics ()
Refreshes the visual metrics of the paint manager.
XTP_TASKPANEL_GROUPCOLORS * | GetGroupColors (BOOL bSpecial)
Retrieves a specified group color set.
virtual XTP_TASKPANEL_GROUPCOLORS * | GetGroupColors (CXTPTaskPanelGroup *pGroup)
Retrieves a specified group color set.
virtual void | DrawGroupItemFrame (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc)
Draws a rectangle around a group item when it is selected, pressed or highlighted.
virtual CRect | GetItemOuterMargins (const CXTPTaskPanelGroupItem *pItem)
Retrieves the outer margins of a specified group item.
virtual CRect | GetItemInnerMargins (const CXTPTaskPanelGroupItem *pItem)
Retrieves the inner margins of a specified group item.
virtual CRect | GetGroupOuterMargins (const CXTPTaskPanelGroup *pGroup)
Retrieves the outer margins of a specified group.
virtual CRect | GetItemIconPadding (const CXTPTaskPanelItem *pItem)
Retrieves the icon padding of a specified item.
virtual CRect | GetGroupInnerMargins (const CXTPTaskPanelGroup *pGroup)
Retrieves the inner margins of a specified group.
virtual CRect | GetControlMargins (const CXTPTaskPanel *pPanel)
Gets the default margins used for all groups within a specified Task Panel control.
virtual int | GetGroupSpacing (const CXTPTaskPanel *pPanel)
Gets the spacing used between groups within a specified Task Panel control.
virtual void | DrawScrollButton (CDC *pDC, CXTPTaskPanelScrollButton *pScrollButton)
Draws a group scroll button.
void | SetTextFormat (int nTextFormat, BOOL bCaption=FALSE)
Sets the text format for captions/items.
void | SetItemsFontIndirect (LOGFONT *pLogFont, BOOL bUseStandardItemsFont=FALSE)
Sets the text font for items.
void | SetCaptionFontIndirect (LOGFONT *pLogFont, BOOL bUseStandardCaptionFont=FALSE)
Sets the text font for captions.
virtual CFont * | GetItemFont (CXTPTaskPanelItem *pItem)
Retrieves the text font of a specified item.
virtual void | FillGroupClientFace (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Fills the client face of a specified group.

Public Attributes

BOOL | m_bEmulateEplorerTheme
TRUE to use Explorer theme under WinXP and Office 2000 under older OS.
XTPTaskPanelGripper | m_eGripper
Gripper of the manager.
BOOL | m_bBoldCaption
TRUE to display caption text in bold font, FALSE to display caption text in normal type.
CRect | m_rcGroupOuterMargins
Outer margins of the group.
CRect | m_rcGroupInnerMargins
Inner margins of the group.
CRect | m_rcItemOuterMargins
Outer margins of the group items.
CRect | m_rcItemInnerMargins
Inner margins of the group items.
CRect | m_rcControlMargins
Default margins for all groups.
int | m_nGroupSpacing
Amount of space placed between groups in the task panel.
CRect | m_rcImageLayoutIconPadding
Padding around images for xtpTaskItemLayoutImages layout.
CRect | m_rcItemIconPadding
Padding around images for items.
CRect | m_rcGroupIconPadding
Padding around images for groups.
BOOL | m_bOfficeHighlight
TRUE to highlight group items and scroll buttons using the Office XP style (XPCOLOR_HIGHLIGHT, XPCOLOR_HIGHLIGHT_CHECKED, XPCOLOR_HIGHLIGHT_PUSHED).
BOOL | m_bInvertDragRect
Only used when the theme is set to xtpTaskPanelThemeVisualStudio2003.
BOOL | m_bCaptionScrollButton
TRUE if the group caption scroll button is visible, FALSE if the group caption scroll button is hidden.
BOOL | m_bEmbossedDisabledText
TRUE to draw disabled text embossed.

Static Public Attributes

static const CRect rectDefault
System selected default margins.

Protected Member Functions

CRect | DrawGroupItemImageWithText (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw)
Draws the icon of a specified group item.
CRect | DrawGroupItemImageWithTextBelow (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw)
Draws the icon of a specified group item.
CRect | DrawGroupItemImage (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw)
Draws the icon of a specified group item.
virtual void | DrawGroupClientFace (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Draws the client face of a specified group.
virtual void | DrawGroupClientItems (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Draws the items of a specified group.
virtual CRect | DrawCaptionGripper (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Draws the caption gripper of a specified group.
virtual int | GetCaptionGripperWidth (CXTPTaskPanelGroup *pGroup, CRect rc)
Retrieves the width of the caption gripper of a specified group.
virtual void | DrawItemCaption (CDC *pDC, CXTPTaskPanelItem *pItem, CRect rcText, UINT nFormat)
Draws the text caption of a specified item.
virtual void | DrawItemImage (CDC *pDC, CXTPTaskPanelItem *pItem, CPoint ptIcon, CXTPImageManagerIcon *pImage, CSize szIcon)
Draws the icon of a specified item.
COLORREF | BlendColor (COLORREF clrFrom, COLORREF clrTo, int nAlpha)
Blends one color to another color by a specified amount.
CRect | DrawCaptionGripperBitmap (CDC *pDC, CXTPTaskPanelGroup *pGroup, BOOL bExpanded, BOOL bHot, CRect rc)
Draws the caption gripper bitmap.
void | DrawCaptionGripperSigns (CDC *pDC, CPoint pt, COLORREF clr, BOOL bExpanded)
Draws the ">>" and "<<" signs of the caption gripper when the theme of the Task Panel is set to Office 2000.
void | CreateGripperBitmaps ()
Loads the gripper bitmap when the theme of the Task Panel is set to either Windows XP or Classic Windows XP.
void | CreateGripperIcon (HICON &hIcon, UINT nIDResource, COLORREF clrGripperBack)
Creates the gripper bitmap icons when the theme of the Task Panel is set to either Windows XP or Classic Windows XP and either the operating system is not Windows XP or the operating system is Windows XP and Luna themes are used.
void | FreeBitmaps ()
Frees the memory used by the group caption bitmaps.
void | Rectangle (CDC *pDC, CRect rc, COLORREF clrPen, COLORREF clrBrush)
This method is only used when drawing hot, pressed, and selected group items and scroll buttons when m_bOfficeHighlight is TRUE.
virtual CPoint | GetHighlightOffset (CXTPTaskPanelGroupItem *pItem)
Retrieves the highlight offset of the text of a specified group item.
virtual void | DrawDragArrow (CDC *pDC, CXTPTaskPanelItem *pItem, CRect rc, BOOL bAfter=FALSE)
Draws the "drag arrow" of a specified item.
virtual void | DrawFocusRect (CDC *pDC, CRect rc)
Draws a rectangle around the focused item.

Protected Attributes

BOOL | m_bUseBitmapGrippers
TRUE to use alpha grippers.
HICON | m_hGripperNormal
Icon of normal group header gripper.
HICON | m_hGripperSpecial
Icon of special group header gripper.
HBITMAP | m_bmpGrippers [8]
Bitmaps of alpha grippers.
CXTPFont | m_xtpFontCaption
Caption font.
CXTPFont | m_xtpFontIcon
Normal items font.
CXTPFont | m_xtpFontIconBold
Bold items font.
CXTPFont | m_xtpFontIconHot
"Hot" items font.
CXTPFont | m_xtpFontIconHotBold
Bold items font.
CXTPPaintManagerColorGradient | m_clrBackground
Background color of the Task Panel.
XTP_TASKPANEL_GROUPCOLORS | m_groupNormal
Normal colors set.
XTP_TASKPANEL_GROUPCOLORS | m_groupSpecial
Special colors set.
CXTPPaintManagerColor | m_clrHighlightHot
Color of items when they are "hot." This is the color of the item on mouseover if hot tracking is enabled.
CXTPPaintManagerColor m_clrHighlightSelected
Color of items when they are selected.
CXTPPaintManagerColor m_clrHighlightPressed
Color of items when they are pressed.
CXTPPaintManagerColorGradient | m_clrHighlightBorder
Border color of items when they are "hot." This is the border color of the item on mouse over if hot tracking is enabled.
BOOL | m_bOfficeBorder
TRUE to use Office borders.
BOOL | m_bLeftRoundedCorner
TRUE to round left corner of the group caption.
BOOL | m_bRightRoundedCorner
TRUE to round right corner of the group caption.
int | m_nCaptionHeight
Caption height, in pixels.
BOOL | m_bUseStandardCaptionFont
TRUE to use system font for group caption text.
BOOL | m_bUseStandardItemsFont
TRUE to use system font for item caption text.
int | m_nItemTextFormat
Format flags of item text.
int | m_nCaptionTextFormat
Format flags of caption text.

Detailed Description

CXTPTaskPanelPaintManager is a standalone class used by CXTPTaskPanel as a paint manager.

Member Function Documentation

◆ BlendColor()

COLORREF BlendColor | ( | COLORREF | clrFrom,
 |  | COLORREF | clrTo,
 |  | int | nAlpha )
 protected

Blends one color to another color by a specified amount.

Parameters
clrFrom | Color to start from.
clrTo | Color to blend to.
nAlpha | Amount of transparency.
Returns
The blended color.

This function takes a blended color intensity which is (clrFrom * nAlpha + clrTo * (255 nAlpha)) / 255

◆ CreateGripperBitmaps()

void CreateGripperBitmaps ( )
protected

Loads the gripper bitmap when the theme of the Task Panel is set to either Windows XP or Classic Windows XP.

If the current operating system is Windows XP and the current theme is set to either Luna Blue, Luna Olive or Luna Silver, then the gripper bitmap will be loaded from the operating system. For all other operating systems and themes, CreateGripperIcon will be used to create an emulated version of the Windows XP gripper.

See also
CreateGripperIcon

◆ CreateGripperIcon()

void CreateGripperIcon | ( | HICON & | hIcon,
 |  | UINT | nIDResource,
 |  | COLORREF | clrGripperBack )
 protected

Creates the gripper bitmap icons when the theme of the Task Panel is set to either Windows XP or Classic Windows XP and either the operating system is not Windows XP or the operating system is Windows XP and Luna themes are used.

Parameters
hIcon | Reference to the icon handle.
nIDResource | Icon resource identifier.
clrGripperBack | Background color of the gripper bitmap.
See also
CreateGripperBitmaps

◆ DrawCaptionGripper()

virtual CRect DrawCaptionGripper | ( | CDC * | pDC,
 |  | CXTPTaskPanelGroup * | pGroup,
 |  | CRect | rc )
 protectedvirtual

Draws the caption gripper of a specified group.

Parameters
pDC | Pointer to a valid device context.
pGroup | Pointer to the group to draw the caption gripper of.
rc | Rectangle of the group to draw the caption gripper of.
Returns
The rectangle of the caption after the drawing is complete.

The caption gripper is the button that allows the group to be expanded and collapsed.

See also
DrawCaptionGripperBitmap, DrawCaptionGripperSigns

Reimplemented in CXTPTaskPanelExplorerThemePlain.

◆ DrawCaptionGripperBitmap()

CRect DrawCaptionGripperBitmap | ( | CDC * | pDC,
 |  | CXTPTaskPanelGroup * | pGroup,
 |  | BOOL | bExpanded,
 |  | BOOL | bHot,
 |  | CRect | rc )
 protected

Draws the caption gripper bitmap.

Parameters
pDC | Pointer to a valid device context.
pGroup | Pointer to the group.
bExpanded | TRUE to draw the bitmap when the group is expanded.
bHot | TRUE to draw the bitmap when the group is "hot" (i.e. when the mouse cursor is positioned over the gripper).
rc | CRect object specifying the size of the area.
Returns
The bounding rectangle of the group caption excluding the width of the caption gripper bitmap.
See also
CXTPTaskPanelGroup::SetSpecialGroup, CXTPTaskPanelGroup::IsSpecialGroup

◆ DrawCaptionGripperSigns()

void DrawCaptionGripperSigns | ( | CDC * | pDC,
 |  | CPoint | pt,
 |  | COLORREF | clr,
 |  | BOOL | bExpanded )
 protected

Draws the ">>" and "<<" signs of the caption gripper when the theme of the Task Panel is set to Office 2000.

Parameters
pDC | Pointer to a valid device context.
pt | CPoint object specifying the x- and y- coordinates.
clr | COLORREF specifying the RGB color value.
bExpanded | TRUE to draw the expanded gripper ">>", FALSE to draw the retracted gripper "<<".

◆ DrawDragArrow()

virtual void DrawDragArrow | ( | CDC * | pDC,
 |  | CXTPTaskPanelItem * | pItem,
 |  | CRect | rc,
 |  | BOOL | bAfter = FALSE )
 protectedvirtual

Draws the "drag arrow" of a specified item.

Parameters
pDC | Pointer to a valid device context.
pItem | Pointer to the item to draw the drag arrow of.
rc | CRect object specifying the size of the area.
bAfter | TRUE to draw the drag arrow after the item, FALSE to draw the arrow before the item.

The "drag arrow" is the line that is placed above or below an item when it is dragged. The drag arrow is drawn for all themes except xtpTaskPanelThemeVisualStudio2003. The drag arrow will be drawn above the item if dragging up or below the item if dragging down.

See also
CXTPTaskPanelToolboxTheme::DrawGroupCaption

◆ DrawFocusRect()

virtual void DrawFocusRect | ( | CDC * | pDC,
 |  | CRect | rc )
 protectedvirtual

Draws a rectangle around the focused item.

Parameters
pDC | Pointer to a valid device context.
rc | Bounding rectangle.

◆ DrawGroupCaption()

virtual int DrawGroupCaption | ( | CDC * | pDC,
 |  | CXTPTaskPanelGroup * | pGroup,
 |  | BOOL | bDraw )
 virtual

Draws the caption of a specified group.

Parameters
pDC | Pointer to a valid device context.
pGroup | Pointer to the group to draw the caption of.
bDraw | TRUE to draw the caption of the specified group, FALSE to retrieve the height of the caption.
Returns
The height of the caption.

Reimplemented in CXTPTaskPanelPaintManagerPlain, and CXTPTaskPanelToolboxTheme.

◆ DrawGroupClient()

virtual void DrawGroupClient | ( | CDC * | pDC,
 |  | CXTPTaskPanelGroup * | pGroup )
 virtual

Draws a specified group.

Parameters
pDC | Pointer to a valid device context.
pGroup | Pointer to the group to draw.

◆ DrawGroupClientFace()

virtual void DrawGroupClientFace | ( | CDC * | pDC,
 |  | CXTPTaskPanelGroup * | pGroup,
 |  | CRect | rc )
 protectedvirtual

Draws the client face of a specified group.

Parameters
pDC | Pointer to a valid device context.
pGroup | Pointer to the group to draw the client face of.
rc | Rectangle of the group to draw the client face of.

Reimplemented in CXTPTaskPanelPaintManagerPlain, CXTPTaskPanelShortcutBarOffice2003Theme, CXTPTaskPanelShortcutBarOffice2007Theme, CXTPTaskPanelVisualStudio2005Theme, CXTPTaskPanelVisualStudio2010Theme, and CXTPTaskPanelVisualStudio2012Theme.

◆ DrawGroupClientItems()

virtual void DrawGroupClientItems | ( | CDC * | pDC,
 |  | CXTPTaskPanelGroup * | pGroup,
 |  | CRect | rc )
 protectedvirtual

Draws the items of a specified group.

Parameters
pDC | Pointer to a valid device context.
pGroup | Pointer to the group to draw the items of.
rc | Rectangle of the group to draw the client face of.

◆ DrawGroupItem()

virtual CRect DrawGroupItem | ( | CDC * | pDC,
 |  | CXTPTaskPanelGroupItem * | pItem,
 |  | CRect | rc,
 |  | BOOL | bDraw )
 virtual

Draws a specified group item.

Parameters
pDC | Pointer to a valid device context.
pItem | Pointer to the group item to draw.
rc | Rectangle of the group item to draw.
bDraw | TRUE to draw the group item, FALSE to retrieve the height of the group item.
Returns
The height of the group item.

◆ DrawGroupItemFrame()

virtual void DrawGroupItemFrame | ( | CDC * | pDC,
 |  | CXTPTaskPanelGroupItem * | pItem,
 |  | CRect | rc )
 virtual

Draws a rectangle around a group item when it is selected, pressed or highlighted.

Parameters
pDC | Pointer to a valid device context.
pItem | Pointer to the group item.
rc | Rectangle to be drawn.

Reimplemented in CXTPTaskPanelShortcutBarOffice2007Theme, and CXTPTaskPanelVisualStudio2012Theme.

◆ DrawGroupItemImage()

CRect DrawGroupItemImage | ( | CDC * | pDC,
 |  | CXTPTaskPanelGroupItem * | pItem,
 |  | CRect | rc,
 |  | BOOL | bDraw )
 protected

Draws the icon of a specified group item.

Parameters
pDC | Pointer to a valid device context.
pItem | Pointer to the group item to draw the icon of.
rc | Rectangle of the group item to draw the icon of.
bDraw | TRUE to draw the icon of the group item, FALSE to retrieve the bounding rectangle of the group item.
Returns
If bDraw is TRUE and the drawing is successful, then a value of 0 is returned.

If bDraw if FALSE, then the bounding rectangle of the group item is returned including the inner margins of the item (i.e. the left and right margins of the item will be the left and right margins of the item in addition to the left and right inner margins of the item).

See also
DrawGroupItem, DrawGroupItemImageWithText, DrawGroupItemImageWithTextBelow, GetItemInnerMargins

◆ DrawGroupItemImageWithText()

CRect DrawGroupItemImageWithText | ( | CDC * | pDC,
 |  | CXTPTaskPanelGroupItem * | pItem,
 |  | CRect | rc,
 |  | BOOL | bDraw )
 protected

Draws the icon of a specified group item.

Parameters
pDC | Pointer to a valid device context.
pItem | Pointer to the group item to draw the icon of.
rc | Rectangle of the group item to draw the icon of.
bDraw | TRUE to draw the icon of the group item, FALSE to retrieve the bounding rectangle of the group item.
Returns
If bDraw is TRUE and the drawing is successful, then a value of 0 is returned.

If bDraw if FALSE, then the bounding rectangle of the group item is returned including the inner margins of the item (i.e. the left and right margins of the item will be the left and right margins of the item in addition to the left and right inner margins of the item).

See also
DrawGroupItem, DrawGroupItemImageWithTextBelow, DrawGroupItemImage, GetItemInnerMargins

◆ DrawGroupItemImageWithTextBelow()

CRect DrawGroupItemImageWithTextBelow | ( | CDC * | pDC,
 |  | CXTPTaskPanelGroupItem * | pItem,
 |  | CRect | rc,
 |  | BOOL | bDraw )
 protected

Draws the icon of a specified group item.

Parameters
pDC | Pointer to a valid device context.
pItem | Pointer to the group item to draw the icon of.
rc | Rectangle of the group item to draw the icon of.
bDraw | TRUE to draw the icon of the group item, FALSE to retrieve the bounding rectangle of the group item.
Returns
If bDraw is TRUE and the drawing is successful, then a value of 0 is returned.

If bDraw if FALSE, then the bounding rectangle of the group item is returned including the inner margins of the item (i.e. the left and right margins of the item will be the left and right margins of the item in addition to the left and right inner margins of the item).

See also
DrawGroupItem, DrawGroupItemImageWithText, DrawGroupItemImage, GetItemInnerMargins

◆ DrawItemCaption()

virtual void DrawItemCaption | ( | CDC * | pDC,
 |  | CXTPTaskPanelItem * | pItem,
 |  | CRect | rcText,
 |  | UINT | nFormat )
 protectedvirtual

Draws the text caption of a specified item.

Parameters
pDC | Pointer to a valid device context.
pItem | Pointer to the item to draw the text caption of.
rcText | Rectangle of the item to draw the text caption of.
nFormat | Specifies the method of formatting the text. See the Remarks section below for a list of available values.

The nFormat parameter can be one or more of the following values: DT_BOTTOM: Justifies the text to the bottom of the rectangle. This value is used only with the DT_SINGLELINE value. DT_CALCRECT: Determines the width and height of the rectangle. DT_CENTER: Centers text horizontally in the DT_EDITCONTROL: rectangle. Duplicates the text-displaying characteristics of a multi-line edit control. Specifically, the average character width is calculated in the same manner as for an edit control, and the function does not display a partially visible last line. DT_END_ELLIPSIS: For displayed text, if the end of a string does not fit in the rectangle, it is truncated and ellipses are added. If a word that is not at the end of the string goes beyond the limits of the rectangle, it is truncated without ellipses. The string is not modified unless the DT_MODIFYSTRING flag is specified. DT_EXPANDTABS: Expands tab characters. The default number of characters per tab is eight. The DT_WORD_ELLIPSIS, DT_PATH_ELLIPSIS, and DT_END_ELLIPSIS values cannot be used with the DT_EXPANDTABS value. DT_EXTERNALLEADING: Includes the font external leading in-line height. Normally, external leading is not included in the height of a line of text. DT_HIDEPREFIX: Ignores the ampersand (&) prefix character in the text. The letter that follows will not be underlined, but other mnemonic-prefix characters are still processed. DT_INTERNAL: Uses the system font to calculate text metrics. DT_LEFT: Aligns text to the left. DT_MODIFYSTRING: Modifies the specified string to match the displayed text. This value has no effect unless DT_END_ELLIPSIS or DT_PATH_ELLIPSIS is specified. DT_NOCLIP: Draws without clipping. DT_NOFULLWIDTHCHARBREAK: Prevents a line break at a DBCS (i.e. a double-wide character string), so that the line breaking rule is equivalent to SBCS strings. For example, this can be used in Korean windows, for more readability of icon labels. This value has no effect unless DT_WORDBREAK is specified. DT_NOPREFIX: Turns off processing of prefix characters. DT_PATH_ELLIPSIS: For displayed text, replaces characters in the middle of the string with ellipses so that the result fits in the specified rectangle. If the string contains backslash (\) characters, DT_PATH_ELLIPSIS preserves as much as possible of the text after the last backslash. The string is not modified unless the DT_MODIFYSTRING flag is specified. DT_PREFIXONLY: Draws only an underline at the position of the character following the ampersand (&) prefix character. Does not draw any other characters in the string. DT_RIGHT: Aligns text to the right. DT_RTLREADING: Layout in right-to-left reading order for bi-directional text when the font selected into the hdc is a Hebrew or Arabic font. The default reading order for all text is left-to-right. DT_SINGLELINE: Displays text on a single line only. Carriage returns and line feeds do not break the line. DT_TABSTOP: Sets tab stops. Bits 158 (high-order byte of the low-order word) of the uFormat parameter specify the number of characters for each tab. The default number of characters per tab is eight. The DT_CALCRECT, DT_EXTERNALLEADING, DT_INTERNAL, DT_NOCLIP, and DT_NOPREFIX values cannot be used with the DT_TABSTOP value. DT_TOP: Justifies the text to the top of the rectangle. DT_VCENTER: Centers text vertically. This value is used only with the DT_SINGLELINE value. DT_WORDBREAK: Breaks words. Lines are automatically broken between words if a word would extend past the edge of the rectangle specified by the lpRect parameter. A carriage return-line feed sequence also breaks the line. If this is not specified, then output is on one line. DT_WORD_ELLIPSIS: Truncates any word that does not fit in the rectangle and adds ellipses.

DrawGroupCaption uses this method to draw the group caption with nFormat = DT_SINGLELINE | DT_LEFT | DT_END_ELLIPSIS | DT_VCENTER | DT_NOPREFIX

DrawGroupItemImageWithText and DrawGroupItemImageWithTextBelow both use this method to draw the group item caption.

Reimplemented in CXTPTaskPanelVisualStudio2012Theme.

◆ DrawItemImage()

virtual void DrawItemImage | ( | CDC * | pDC,
 |  | CXTPTaskPanelItem * | pItem,
 |  | CPoint | ptIcon,
 |  | CXTPImageManagerIcon * | pImage,
 |  | CSize | szIcon )
 protectedvirtual

Draws the icon of a specified item.

Parameters
pDC | Pointer to a valid device context.
pItem | Pointer to the item to draw the icon of.
ptIcon | Top left corner to start drawing the icon.
pImage | Pointer to the icon to draw.
szIcon | Size of the icon to draw.

◆ DrawScrollButton()

virtual void DrawScrollButton | ( | CDC * | pDC,
 |  | CXTPTaskPanelScrollButton * | pScrollButton )
 virtual

Draws a group scroll button.

Parameters
pDC | Pointer to a valid device context.
pScrollButton | Pointer to the group scroll button to draw.

DrawScrollButton only draws group scroll buttons (i.e. DrawScrollButton does not draw group caption scroll buttons). DrawCaptionGripper draws group caption scroll buttons.

See also
DrawCaptionGripper

◆ FillGroupClientFace()

virtual void FillGroupClientFace | ( | CDC * | pDC,
 |  | CXTPTaskPanelGroup * | pGroup,
 |  | CRect | rc )
 virtual

Fills the client face of a specified group.

Parameters
pDC | Pointer to a valid device context.
pGroup | Pointer to the group to fill the client face of.
rc | Rectangle of the group to fill the client face of.
See also
DrawGroupClientFace

Reimplemented in CXTPTaskPanelPaintManagerPlain, CXTPTaskPanelShortcutBarOffice2003Theme, CXTPTaskPanelShortcutBarOffice2007Theme, CXTPTaskPanelVisualStudio2005Theme, CXTPTaskPanelVisualStudio2010Theme, and CXTPTaskPanelVisualStudio2012Theme.

◆ FillTaskPanel()

virtual void FillTaskPanel | ( | CDC * | pDC,
 |  | CXTPTaskPanel * | pTaskPanel )
 virtual

Fills the background of a specified task panel.

Parameters
pDC | Pointer to a valid device context.
pTaskPanel | Pointer to the task panel to fill.

Reimplemented in CXTPTaskPanelOffice2013Theme, CXTPTaskPanelPaintManagerPlain, CXTPTaskPanelShortcutBarOffice2003Theme, CXTPTaskPanelShortcutBarOffice2007Theme, CXTPTaskPanelVisualStudio2005Theme, CXTPTaskPanelVisualStudio2010Theme, and CXTPTaskPanelVisualStudio2012Theme.

◆ GetCaptionGripperWidth()

virtual int GetCaptionGripperWidth | ( | CXTPTaskPanelGroup * | pGroup,
 |  | CRect | rc )
 protectedvirtual

Retrieves the width of the caption gripper of a specified group.

Parameters
pGroup | Pointer to the group with the caption gripper to retrieve the width of.
rc | Rectangle of the group with the caption gripper to retrieve the width of.
Returns
The width of the caption gripper of the specified group.

The caption gripper is the button that allows the group to be expanded and collapsed.

◆ GetControlMargins()

virtual CRect GetControlMargins ( const CXTPTaskPanel * pPanel )
virtual

Gets the default margins used for all groups within a specified Task Panel control.

Parameters
pPanel Pointer to a Task Panel control.
Returns
The default margins used for all groups within the specified Task Panel control.
See also
GetItemOuterMargins, GetItemInnerMargins, GetGroupOuterMargins, GetGroupInnerMargins

◆ GetGroupColors() [1/2]

AFX_INLINE XTP_TASKPANEL_GROUPCOLORS * GetGroupColors ( BOOL bSpecial )

Retrieves a specified group color set.

Parameters
bSpecial TRUE to retrieve the special group color set, FALSE to retrieve the normal group color set.

If a group is special, then it will be displayed in a different color than other groups in order to draw the user's attention to that group. This is an excellent way to show the user "default" or important items.

Returns
A pointer to the specified group color set.
See also
CXTPTaskPanelGroup::IsSpecialGroup, CXTPTaskPanelGroup::SetSpecialGroup

◆ GetGroupColors() [2/2]

virtual XTP_TASKPANEL_GROUPCOLORS * GetGroupColors ( CXTPTaskPanelGroup * pGroup )
virtual

Retrieves a specified group color set.

Parameters
pGroup Pointer to the group with the color set to be retrieved.

If a group is special, then it will be displayed in a different color than other groups in order to draw the user's attention to that group. This is an excellent way to show the user "default" or important items.

Returns
A pointer to the specified group color set.
See also
CXTPTaskPanelGroup::IsSpecialGroup, CXTPTaskPanelGroup::SetSpecialGroup

◆ GetGroupInnerMargins()

virtual CRect GetGroupInnerMargins ( const CXTPTaskPanelGroup * pGroup )
virtual

Retrieves the inner margins of a specified group.

Parameters
pGroup Pointer to the group with the inner margins to retrieve.
Returns
The inner margins of the specified group.
See also
GetItemOuterMargins, GetItemInnerMargins, GetGroupOuterMargins, GetControlMargins

◆ GetGroupOuterMargins()

virtual CRect GetGroupOuterMargins ( const CXTPTaskPanelGroup * pGroup )
virtual

Retrieves the outer margins of a specified group.

Parameters
pGroup Pointer to the group with the outer margins to retrieve.
Returns
The outer margins of the specified group.
See also
GetItemOuterMargins, GetItemInnerMargins, GetGroupInnerMargins, GetControlMargins

◆ GetGroupSpacing()

virtual int GetGroupSpacing ( const CXTPTaskPanel * pPanel )
virtual

Gets the spacing used between groups within a specified Task Panel control.

Parameters
pPanel Pointer to a Task Panel control.
Returns
The spacing used between groups within the specified Task Panel control.

◆ GetHighlightOffset()

virtual CPoint GetHighlightOffset ( CXTPTaskPanelGroupItem * pItem )
protectedvirtual

Retrieves the highlight offset of the text of a specified group item.

Parameters
pItem Pointer to the group item with the text to retrieve the highlight offset of.
Returns
If the group item is selected, then the highlight offset is (1, 1). If the group item is not selected, then the highlight offset is (0, 0).

◆ GetItemFont()

virtual CFont * GetItemFont ( CXTPTaskPanelItem * pItem )
virtual

Retrieves the text font of a specified item.

Parameters
pItem Pointer to the item with the text font to retrieve.
Returns
A pointer to the text font of the specified item.

◆ GetItemIconPadding()

virtual CRect GetItemIconPadding ( const CXTPTaskPanelItem * pItem )
virtual

Retrieves the icon padding of a specified item.

Parameters
pItem Pointer to the item with the icon padding to retrieve.
Returns
The icon padding of the specified item.
See also
GetItemOuterMargins, GetItemInnerMargins, GetGroupInnerMargins, GetControlMargins

◆ GetItemInnerMargins()

virtual CRect GetItemInnerMargins ( const CXTPTaskPanelGroupItem * pItem )
virtual

Retrieves the inner margins of a specified group item.

Parameters
pItem Pointer to the group item with the inner margins to retrieve.
Returns
The inner margins of the specified group item.
See also
GetItemOuterMargins, GetGroupOuterMargins, GetGroupInnerMargins, GetControlMargins

◆ GetItemOuterMargins()

virtual CRect GetItemOuterMargins ( const CXTPTaskPanelGroupItem * pItem )
virtual

Retrieves the outer margins of a specified group item.

Parameters
pItem Pointer to the group item with the outer margins to retrieve.
Returns
The outer margins of the specified group item.
See also
GetItemInnerMargins, GetGroupOuterMargins, GetGroupInnerMargins, GetControlMargins

◆ Rectangle()

void Rectangle | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | COLORREF | clrPen,
 |  | COLORREF | clrBrush )
 protected

This method is only used when drawing hot, pressed, and selected group items and scroll buttons when m_bOfficeHighlight is TRUE.

Parameters
pDC | Pointer to a valid device context.
rc | CRect object specifying the size of the area.
clrPen | COLORREF specifying the pen RGB color value.
clrBrush | COLORREF specifying the brush RGB color value.

◆ SetCaptionFontIndirect()

void SetCaptionFontIndirect | ( | LOGFONT * | pLogFont,
 |  | BOOL | bUseStandardCaptionFont = FALSE )

Sets the text font for captions.

Parameters
pLogFont | Pointer to the text font to be set.
bUseStandardCaptionFont | TRUE to use the standard text font, FALSE to use the text font specified by pLogFont.

◆ SetItemsFontIndirect()

void SetItemsFontIndirect | ( | LOGFONT * | pLogFont,
 |  | BOOL | bUseStandardItemsFont = FALSE )

Sets the text font for items.

Parameters
pLogFont | Pointer to the text font to be set.
bUseStandardItemsFont | TRUE to use the standard text font, FALSE to use the text font specified by pLogFont.

◆ SetTextFormat()

AFX_INLINE void SetTextFormat | ( | int | nTextFormat,
 |  | BOOL | bCaption = FALSE )

Sets the text format for captions/items.

Parameters
nTextFormat | Text format to be set.
bCaption | TRUE to set the text format for captions, FALSE to set the text format for items.

Example:

m_wndTaskPanel.GetPaintManager()->SetTextFormat(DT_SINGLELINE | DT_END_ELLIPSIS |
DT_VCENTER | DT_NOPREFIX);

Member Data Documentation

◆ m_clrHighlightPressed

CXTPPaintManagerColor m_clrHighlightPressed
protected

Color of items when they are pressed.

This is when the item is clicked on.

◆ m_clrHighlightSelected

CXTPPaintManagerColor m_clrHighlightSelected
protected

Color of items when they are selected.

This is when the item has focus or is clicked on.

◆ m_nCaptionTextFormat

int m_nCaptionTextFormat
protected

Format flags of caption text.

See CXTPTaskPanelPaintManager::DrawItemCaption for a list of format flags.

◆ m_nItemTextFormat

int m_nItemTextFormat
protected

Format flags of item text.

See CXTPTaskPanelPaintManager::DrawItemCaption for a list of format flags.

◆ rectDefault

const CRect rectDefault
static

System selected default margins.

All parameters of this CRECT are set to CW_USEDEFAULT, which tells the system to select the default position for the object (i.e. the upper-left corner ignoring the y parameter). This CRECT is used when calculating the margins of the task panel, group items margin, group outer margin, and group inner margin. If the margins have not been modified, then this CRECT is used to set the margins.

The documentation for this class was generated from the following file:
  • XTPTaskPanelPaintManager.h


Toolkit Pro: CXTPTaskPanelPaintManagerPlain Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPTaskPanelPaintManagerPlain Class Reference

Base class theme that all other themes are derived from. More...

Inheritance diagram for CXTPTaskPanelPaintManagerPlain:
[legend]

Public Member Functions

CXTPTaskPanelPaintManagerPlain ()
Constructs a CXTPTaskPanelPaintManagerPlain object.
void | RefreshMetrics ()
Refreshes the visual metrics of the task panel.
void | DrawGroupClientFace (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Draws the client face of a specified group.
void | FillGroupClientFace (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Fills the client face of a specified group.
void | FillTaskPanel (CDC *pDC, CXTPTaskPanel *pTaskPanel)
Fills the background of a specified task panel.
int | DrawGroupCaption (CDC *pDC, CXTPTaskPanelGroup *pGroup, BOOL bDraw)
Draws the caption of a specified group.
- Public Member Functions inherited from CXTPTaskPanelPaintManager
CXTPTaskPanelPaintManager ()
Constructs a CXTPTaskPanelPaintManager object.
virtual | ~CXTPTaskPanelPaintManager ()
Destroys a CXTPTaskPanelPaintManager object, handles cleanup and deallocation.
virtual void | DrawGroupClient (CDC *pDC, CXTPTaskPanelGroup *pGroup)
Draws a specified group.
virtual CRect | DrawGroupItem (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw)
Draws a specified group item.
XTP_TASKPANEL_GROUPCOLORS * | GetGroupColors (BOOL bSpecial)
Retrieves a specified group color set.
virtual XTP_TASKPANEL_GROUPCOLORS * | GetGroupColors (CXTPTaskPanelGroup *pGroup)
Retrieves a specified group color set.
virtual void | DrawGroupItemFrame (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc)
Draws a rectangle around a group item when it is selected, pressed or highlighted.
virtual CRect | GetItemOuterMargins (const CXTPTaskPanelGroupItem *pItem)
Retrieves the outer margins of a specified group item.
virtual CRect | GetItemInnerMargins (const CXTPTaskPanelGroupItem *pItem)
Retrieves the inner margins of a specified group item.
virtual CRect | GetGroupOuterMargins (const CXTPTaskPanelGroup *pGroup)
Retrieves the outer margins of a specified group.
virtual CRect | GetItemIconPadding (const CXTPTaskPanelItem *pItem)
Retrieves the icon padding of a specified item.
virtual CRect | GetGroupInnerMargins (const CXTPTaskPanelGroup *pGroup)
Retrieves the inner margins of a specified group.
virtual CRect | GetControlMargins (const CXTPTaskPanel *pPanel)
Gets the default margins used for all groups within a specified Task Panel control.
virtual int | GetGroupSpacing (const CXTPTaskPanel *pPanel)
Gets the spacing used between groups within a specified Task Panel control.
virtual void | DrawScrollButton (CDC *pDC, CXTPTaskPanelScrollButton *pScrollButton)
Draws a group scroll button.
void | SetTextFormat (int nTextFormat, BOOL bCaption=FALSE)
Sets the text format for captions/items.
void | SetItemsFontIndirect (LOGFONT *pLogFont, BOOL bUseStandardItemsFont=FALSE)
Sets the text font for items.
void | SetCaptionFontIndirect (LOGFONT *pLogFont, BOOL bUseStandardCaptionFont=FALSE)
Sets the text font for captions.
virtual CFont * | GetItemFont (CXTPTaskPanelItem *pItem)
Retrieves the text font of a specified item.

Protected Attributes

BOOL | m_bRoundedFrame
TRUE to draw a rounded frame around all of the groups in the task panel.
BOOL | m_bOfficeCaption
FALSE to draw a rounded rectangle around caption.
- Protected Attributes inherited from CXTPTaskPanelPaintManager
BOOL | m_bUseBitmapGrippers
TRUE to use alpha grippers.
HICON | m_hGripperNormal
Icon of normal group header gripper.
HICON | m_hGripperSpecial
Icon of special group header gripper.
HBITMAP | m_bmpGrippers [8]
Bitmaps of alpha grippers.
CXTPFont | m_xtpFontCaption
Caption font.
CXTPFont | m_xtpFontIcon
Normal items font.
CXTPFont | m_xtpFontIconBold
Bold items font.
CXTPFont | m_xtpFontIconHot
"Hot" items font.
CXTPFont | m_xtpFontIconHotBold
Bold items font.
CXTPPaintManagerColorGradient | m_clrBackground
Background color of the Task Panel.
XTP_TASKPANEL_GROUPCOLORS | m_groupNormal
Normal colors set.
XTP_TASKPANEL_GROUPCOLORS | m_groupSpecial
Special colors set.
CXTPPaintManagerColor | m_clrHighlightHot
Color of items when they are "hot." This is the color of the item on mouseover if hot tracking is enabled.
CXTPPaintManagerColor m_clrHighlightSelected
Color of items when they are selected.
CXTPPaintManagerColor m_clrHighlightPressed
Color of items when they are pressed.
CXTPPaintManagerColorGradient | m_clrHighlightBorder
Border color of items when they are "hot." This is the border color of the item on mouse over if hot tracking is enabled.
BOOL | m_bOfficeBorder
TRUE to use Office borders.
BOOL | m_bLeftRoundedCorner
TRUE to round left corner of the group caption.
BOOL | m_bRightRoundedCorner
TRUE to round right corner of the group caption.
int | m_nCaptionHeight
Caption height, in pixels.
BOOL | m_bUseStandardCaptionFont
TRUE to use system font for group caption text.
BOOL | m_bUseStandardItemsFont
TRUE to use system font for item caption text.
int | m_nItemTextFormat
Format flags of item text.
int | m_nCaptionTextFormat
Format flags of caption text.

Additional Inherited Members

- Public Attributes inherited from CXTPTaskPanelPaintManager
BOOL | m_bEmulateEplorerTheme
TRUE to use Explorer theme under WinXP and Office 2000 under older OS.
XTPTaskPanelGripper | m_eGripper
Gripper of the manager.
BOOL | m_bBoldCaption
TRUE to display caption text in bold font, FALSE to display caption text in normal type.
CRect | m_rcGroupOuterMargins
Outer margins of the group.
CRect | m_rcGroupInnerMargins
Inner margins of the group.
CRect | m_rcItemOuterMargins
Outer margins of the group items.
CRect | m_rcItemInnerMargins
Inner margins of the group items.
CRect | m_rcControlMargins
Default margins for all groups.
int | m_nGroupSpacing
Amount of space placed between groups in the task panel.
CRect | m_rcImageLayoutIconPadding
Padding around images for xtpTaskItemLayoutImages layout.
CRect | m_rcItemIconPadding
Padding around images for items.
CRect | m_rcGroupIconPadding
Padding around images for groups.
BOOL | m_bOfficeHighlight
TRUE to highlight group items and scroll buttons using the Office XP style (XPCOLOR_HIGHLIGHT, XPCOLOR_HIGHLIGHT_CHECKED, XPCOLOR_HIGHLIGHT_PUSHED).
BOOL | m_bInvertDragRect
Only used when the theme is set to xtpTaskPanelThemeVisualStudio2003.
BOOL | m_bCaptionScrollButton
TRUE if the group caption scroll button is visible, FALSE if the group caption scroll button is hidden.
BOOL | m_bEmbossedDisabledText
TRUE to draw disabled text embossed.
- Static Public Attributes inherited from CXTPTaskPanelPaintManager
static const CRect | rectDefault
System selected default margins.
- Protected Member Functions inherited from CXTPTaskPanelPaintManager
CRect | DrawGroupItemImageWithText (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw)
Draws the icon of a specified group item.
CRect | DrawGroupItemImageWithTextBelow (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw)
Draws the icon of a specified group item.
CRect | DrawGroupItemImage (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw)
Draws the icon of a specified group item.
virtual void | DrawGroupClientItems (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Draws the items of a specified group.
virtual CRect | DrawCaptionGripper (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Draws the caption gripper of a specified group.
virtual int | GetCaptionGripperWidth (CXTPTaskPanelGroup *pGroup, CRect rc)
Retrieves the width of the caption gripper of a specified group.
virtual void | DrawItemCaption (CDC *pDC, CXTPTaskPanelItem *pItem, CRect rcText, UINT nFormat)
Draws the text caption of a specified item.
virtual void | DrawItemImage (CDC *pDC, CXTPTaskPanelItem *pItem, CPoint ptIcon, CXTPImageManagerIcon *pImage, CSize szIcon)
Draws the icon of a specified item.
COLORREF | BlendColor (COLORREF clrFrom, COLORREF clrTo, int nAlpha)
Blends one color to another color by a specified amount.
CRect | DrawCaptionGripperBitmap (CDC *pDC, CXTPTaskPanelGroup *pGroup, BOOL bExpanded, BOOL bHot, CRect rc)
Draws the caption gripper bitmap.
void | DrawCaptionGripperSigns (CDC *pDC, CPoint pt, COLORREF clr, BOOL bExpanded)
Draws the ">>" and "<<" signs of the caption gripper when the theme of the Task Panel is set to Office 2000.
void | CreateGripperBitmaps ()
Loads the gripper bitmap when the theme of the Task Panel is set to either Windows XP or Classic Windows XP.
void | CreateGripperIcon (HICON &hIcon, UINT nIDResource, COLORREF clrGripperBack)
Creates the gripper bitmap icons when the theme of the Task Panel is set to either Windows XP or Classic Windows XP and either the operating system is not Windows XP or the operating system is Windows XP and Luna themes are used.
void | FreeBitmaps ()
Frees the memory used by the group caption bitmaps.
void | Rectangle (CDC *pDC, CRect rc, COLORREF clrPen, COLORREF clrBrush)
This method is only used when drawing hot, pressed, and selected group items and scroll buttons when m_bOfficeHighlight is TRUE.
virtual CPoint | GetHighlightOffset (CXTPTaskPanelGroupItem *pItem)
Retrieves the highlight offset of the text of a specified group item.
virtual void | DrawDragArrow (CDC *pDC, CXTPTaskPanelItem *pItem, CRect rc, BOOL bAfter=FALSE)
Draws the "drag arrow" of a specified item.
virtual void | DrawFocusRect (CDC *pDC, CRect rc)
Draws a rectangle around the focused item.

Detailed Description

Base class theme that all other themes are derived from.

Use this class when creating a custom theme.

See also
CXTPTaskPanel::SetTheme, CXTPTaskPanel::SetCustomTheme

Member Function Documentation

◆ DrawGroupCaption()

int DrawGroupCaption | ( | CDC * | pDC,
 |  | CXTPTaskPanelGroup * | pGroup,
 |  | BOOL | bDraw )
 virtual

Draws the caption of a specified group.

Parameters
pDC | Pointer to a valid device context.
pGroup | Pointer to the group to draw the caption of.
bDraw | TRUE to draw the caption of the specified group, FALSE to retrieve the height of the caption.
Returns
The height of the caption.

Reimplemented from CXTPTaskPanelPaintManager.

Reimplemented in CXTPTaskPanelToolboxTheme.

◆ DrawGroupClientFace()

void DrawGroupClientFace | ( | CDC * | pDC,
 |  | CXTPTaskPanelGroup * | pGroup,
 |  | CRect | rc )
 virtual

Draws the client face of a specified group.

Parameters
pDC | Pointer to a valid device context.
pGroup | Pointer to the group to draw the client face of.
rc | Rectangle of the group to draw the client face of.

Reimplemented from CXTPTaskPanelPaintManager.

Reimplemented in CXTPTaskPanelShortcutBarOffice2003Theme, CXTPTaskPanelShortcutBarOffice2007Theme, CXTPTaskPanelVisualStudio2005Theme, CXTPTaskPanelVisualStudio2010Theme, and CXTPTaskPanelVisualStudio2012Theme.

◆ FillGroupClientFace()

void FillGroupClientFace | ( | CDC * | pDC,
 |  | CXTPTaskPanelGroup * | pGroup,
 |  | CRect | rc )
 virtual

Fills the client face of a specified group.

Parameters
pDC | Pointer to a valid device context.
pGroup | Pointer to the group to fill the client face of.
rc | Rectangle of the group to fill the client face of.
See also
DrawGroupClientFace

Reimplemented from CXTPTaskPanelPaintManager.

Reimplemented in CXTPTaskPanelShortcutBarOffice2003Theme, CXTPTaskPanelShortcutBarOffice2007Theme, CXTPTaskPanelVisualStudio2005Theme, CXTPTaskPanelVisualStudio2010Theme, and CXTPTaskPanelVisualStudio2012Theme.

◆ FillTaskPanel()

void FillTaskPanel | ( | CDC * | pDC,
 |  | CXTPTaskPanel * | pTaskPanel )
 virtual

Fills the background of a specified task panel.

Parameters
pDC | Pointer to a valid device context.
pTaskPanel | Pointer to the task panel to fill.

Reimplemented from CXTPTaskPanelPaintManager.

Reimplemented in CXTPTaskPanelShortcutBarOffice2003Theme, CXTPTaskPanelShortcutBarOffice2007Theme, CXTPTaskPanelVisualStudio2005Theme, CXTPTaskPanelVisualStudio2010Theme, and CXTPTaskPanelVisualStudio2012Theme.

Member Data Documentation

◆ m_bOfficeCaption

BOOL m_bOfficeCaption
protected

FALSE to draw a rounded rectangle around caption.

TRUE to not draw a rectangle around caption, caption will not appear in a rectangle. Default is FALSE.

◆ m_bRoundedFrame

BOOL m_bRoundedFrame
protected

TRUE to draw a rounded frame around all of the groups in the task panel.

Can be seen in the Native WinXP theme. Default is TRUE.

The documentation for this class was generated from the following file:
  • XTPTaskPanelPaintManagerPlain.h


Toolkit Pro: CXTPTaskPanelScrollButton Class Reference

Public Member Functions | Public Attributes | List of all members
CXTPTaskPanelScrollButton Class Reference

CXTPTaskPanelScrollButton is a standalone class that represents a task panel scroll button. More...

Public Member Functions

CXTPTaskPanelScrollButton (BOOL bScrollUp)
Constructs a CXTPTaskPanelScrollButton object.
BOOL IsVisible () const
Determines if this scroll button is visible.

Public Attributes

BOOL | bScrollUp
If TRUE, then the button is a "scroll up" button.
BOOL | bEnabled
TRUE if the scroll button is enabled, FALSE if it is disabled.
BOOL | bPressed
TRUE if the scroll button is currently pressed, FALSE otherwise.
CRect | rcButton
Bounding rectangle of the scroll button.
BOOL | bHot
TRUE if the scroll button is "hot", FALSE otherwise.
CXTPTaskPanelGroup * | pGroupScroll
Pointer to the group that uses this group item scroll button.
CXTPTaskPanelGroup * | pGroupCaption
Pointer to the group that uses this group caption scroll button.

Detailed Description

CXTPTaskPanelScrollButton is a standalone class that represents a task panel scroll button.

The task panel uses a scroll button in the group caption to expand and retract the group if the group is expandable.

The task panel also uses scroll buttons in task panel group objects when there are more items in the group than can be viewed. Only necessary buttons are displayed. If the items in the group cannot be scrolled anymore, then that button is removed. Scroll buttons are only visible when using either the xtpTaskPanelBehaviourList or xtpTaskPanelBehaviourToolbox task panel behaviors. The group scroll buttons are stored in m_pScrollButton.

See also
m_pScrollButton

Constructor & Destructor Documentation

◆ CXTPTaskPanelScrollButton()

CXTPTaskPanelScrollButton ( BOOL bScrollUp )

Constructs a CXTPTaskPanelScrollButton object.

Parameters
bScrollUp TRUE to construct a "scroll up" button, FALSE to construct a "scroll down" button.

Member Function Documentation

◆ IsVisible()

BOOL IsVisible ( ) const

Determines if this scroll button is visible.

Returns
TRUE if this scroll button is visible, FALSE if this scroll button is not visible.

Member Data Documentation

◆ bHot

BOOL bHot

TRUE if the scroll button is "hot", FALSE otherwise.

A scroll button is hot when the mouse cursor is placed over the button.

◆ bScrollUp

BOOL bScrollUp

If TRUE, then the button is a "scroll up" button.

If FALSE, then the button is a "scroll down" button.

◆ rcButton

CRect rcButton

Bounding rectangle of the scroll button.

Will be empty if the button is not visible.

The documentation for this class was generated from the following file:
  • XTPTaskPanel.h


Toolkit Pro: CXTPTaskPanelShortcutBarOffice2003Theme Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPTaskPanelShortcutBarOffice2003Theme Class Reference

CXTPTaskPanelShortcutBarOffice2003Theme represents an Office 2003 ShortcutBar style theme. More...

Inheritance diagram for CXTPTaskPanelShortcutBarOffice2003Theme:
[legend]

Public Member Functions

CXTPTaskPanelShortcutBarOffice2003Theme ()
Constructs a CXTPTaskPanelShortcutBarOffice2003Theme object.
void | RefreshMetrics ()
Refreshes the visual metrics of the task panel.
- Public Member Functions inherited from CXTPTaskPanelListViewOffice2003Theme
CXTPTaskPanelListViewOffice2003Theme ()
Constructs a CXTPTaskPanelListViewOffice2003Theme object.
- Public Member Functions inherited from CXTPTaskPanelListViewOfficeXPTheme
CXTPTaskPanelListViewOfficeXPTheme ()
Constructs a CXTPTaskPanelListViewOfficeXPTheme object.
- Public Member Functions inherited from CXTPTaskPanelListViewTheme
CXTPTaskPanelListViewTheme ()
Constructs a CXTPTaskPanelListViewTheme object.
- Public Member Functions inherited from CXTPTaskPanelToolboxTheme
CXTPTaskPanelToolboxTheme ()
Constructs a CXTPTaskPanelToolboxTheme object.
void | RefreshMetrics ()
Refreshes the visual metrics of the task panel.
int | DrawGroupCaption (CDC *pDC, CXTPTaskPanelGroup *pGroup, BOOL bDraw)
Draws the caption of a specified group.
- Public Member Functions inherited from CXTPTaskPanelPaintManagerPlain
CXTPTaskPanelPaintManagerPlain ()
Constructs a CXTPTaskPanelPaintManagerPlain object.
- Public Member Functions inherited from CXTPTaskPanelPaintManager
CXTPTaskPanelPaintManager ()
Constructs a CXTPTaskPanelPaintManager object.
virtual | ~CXTPTaskPanelPaintManager ()
Destroys a CXTPTaskPanelPaintManager object, handles cleanup and deallocation.
virtual void | DrawGroupClient (CDC *pDC, CXTPTaskPanelGroup *pGroup)
Draws a specified group.
virtual CRect | DrawGroupItem (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw)
Draws a specified group item.
XTP_TASKPANEL_GROUPCOLORS * | GetGroupColors (BOOL bSpecial)
Retrieves a specified group color set.
virtual XTP_TASKPANEL_GROUPCOLORS * | GetGroupColors (CXTPTaskPanelGroup *pGroup)
Retrieves a specified group color set.
virtual void | DrawGroupItemFrame (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc)
Draws a rectangle around a group item when it is selected, pressed or highlighted.
virtual CRect | GetItemOuterMargins (const CXTPTaskPanelGroupItem *pItem)
Retrieves the outer margins of a specified group item.
virtual CRect | GetItemInnerMargins (const CXTPTaskPanelGroupItem *pItem)
Retrieves the inner margins of a specified group item.
virtual CRect | GetGroupOuterMargins (const CXTPTaskPanelGroup *pGroup)
Retrieves the outer margins of a specified group.
virtual CRect | GetItemIconPadding (const CXTPTaskPanelItem *pItem)
Retrieves the icon padding of a specified item.
virtual CRect | GetGroupInnerMargins (const CXTPTaskPanelGroup *pGroup)
Retrieves the inner margins of a specified group.
virtual CRect | GetControlMargins (const CXTPTaskPanel *pPanel)
Gets the default margins used for all groups within a specified Task Panel control.
virtual int | GetGroupSpacing (const CXTPTaskPanel *pPanel)
Gets the spacing used between groups within a specified Task Panel control.
virtual void | DrawScrollButton (CDC *pDC, CXTPTaskPanelScrollButton *pScrollButton)
Draws a group scroll button.
void | SetTextFormat (int nTextFormat, BOOL bCaption=FALSE)
Sets the text format for captions/items.
void | SetItemsFontIndirect (LOGFONT *pLogFont, BOOL bUseStandardItemsFont=FALSE)
Sets the text font for items.
void | SetCaptionFontIndirect (LOGFONT *pLogFont, BOOL bUseStandardCaptionFont=FALSE)
Sets the text font for captions.
virtual CFont * | GetItemFont (CXTPTaskPanelItem *pItem)
Retrieves the text font of a specified item.

Protected Member Functions

CRect | DrawGroupCaptionBackground (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Draws the group caption background of a specified group.
void | DrawGroupClientFace (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Draws the client face of a specified group.
void | FillGroupClientFace (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Fills the client face of a specified group.
void | FillTaskPanel (CDC *pDC, CXTPTaskPanel *pTaskPanel)
Fills the background of a specified task panel.
- Protected Member Functions inherited from CXTPTaskPanelToolboxTheme
- Protected Member Functions inherited from CXTPTaskPanelPaintManager
CRect | DrawGroupItemImageWithText (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw)
Draws the icon of a specified group item.
CRect | DrawGroupItemImageWithTextBelow (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw)
Draws the icon of a specified group item.
CRect | DrawGroupItemImage (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw)
Draws the icon of a specified group item.
virtual void | DrawGroupClientItems (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Draws the items of a specified group.
virtual CRect | DrawCaptionGripper (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Draws the caption gripper of a specified group.
virtual int | GetCaptionGripperWidth (CXTPTaskPanelGroup *pGroup, CRect rc)
Retrieves the width of the caption gripper of a specified group.
virtual void | DrawItemCaption (CDC *pDC, CXTPTaskPanelItem *pItem, CRect rcText, UINT nFormat)
Draws the text caption of a specified item.
virtual void | DrawItemImage (CDC *pDC, CXTPTaskPanelItem *pItem, CPoint ptIcon, CXTPImageManagerIcon *pImage, CSize szIcon)
Draws the icon of a specified item.
COLORREF | BlendColor (COLORREF clrFrom, COLORREF clrTo, int nAlpha)
Blends one color to another color by a specified amount.
CRect | DrawCaptionGripperBitmap (CDC *pDC, CXTPTaskPanelGroup *pGroup, BOOL bExpanded, BOOL bHot, CRect rc)
Draws the caption gripper bitmap.
void | DrawCaptionGripperSigns (CDC *pDC, CPoint pt, COLORREF clr, BOOL bExpanded)
Draws the ">>" and "<<" signs of the caption gripper when the theme of the Task Panel is set to Office 2000.
void | CreateGripperBitmaps ()
Loads the gripper bitmap when the theme of the Task Panel is set to either Windows XP or Classic Windows XP.
void | CreateGripperIcon (HICON &hIcon, UINT nIDResource, COLORREF clrGripperBack)
Creates the gripper bitmap icons when the theme of the Task Panel is set to either Windows XP or Classic Windows XP and either the operating system is not Windows XP or the operating system is Windows XP and Luna themes are used.
void | FreeBitmaps ()
Frees the memory used by the group caption bitmaps.
void | Rectangle (CDC *pDC, CRect rc, COLORREF clrPen, COLORREF clrBrush)
This method is only used when drawing hot, pressed, and selected group items and scroll buttons when m_bOfficeHighlight is TRUE.
virtual CPoint | GetHighlightOffset (CXTPTaskPanelGroupItem *pItem)
Retrieves the highlight offset of the text of a specified group item.
virtual void | DrawDragArrow (CDC *pDC, CXTPTaskPanelItem *pItem, CRect rc, BOOL bAfter=FALSE)
Draws the "drag arrow" of a specified item.
virtual void | DrawFocusRect (CDC *pDC, CRect rc)
Draws a rectangle around the focused item.

Additional Inherited Members

- Public Attributes inherited from CXTPTaskPanelListViewOffice2003Theme
CXTPPaintManagerColorGradient | m_grcHot
Color gradient used to colorize "hot" items for this theme.
CXTPPaintManagerColorGradient | m_grcPushed
Color gradient used to colorize "pushed" items for this theme.
- Public Attributes inherited from CXTPTaskPanelPaintManager
BOOL | m_bEmulateEplorerTheme
TRUE to use Explorer theme under WinXP and Office 2000 under older OS.
XTPTaskPanelGripper | m_eGripper
Gripper of the manager.
BOOL | m_bBoldCaption
TRUE to display caption text in bold font, FALSE to display caption text in normal type.
CRect | m_rcGroupOuterMargins
Outer margins of the group.
CRect | m_rcGroupInnerMargins
Inner margins of the group.
CRect | m_rcItemOuterMargins
Outer margins of the group items.
CRect | m_rcItemInnerMargins
Inner margins of the group items.
CRect | m_rcControlMargins
Default margins for all groups.
int | m_nGroupSpacing
Amount of space placed between groups in the task panel.
CRect | m_rcImageLayoutIconPadding
Padding around images for xtpTaskItemLayoutImages layout.
CRect | m_rcItemIconPadding
Padding around images for items.
CRect | m_rcGroupIconPadding
Padding around images for groups.
BOOL | m_bOfficeHighlight
TRUE to highlight group items and scroll buttons using the Office XP style (XPCOLOR_HIGHLIGHT, XPCOLOR_HIGHLIGHT_CHECKED, XPCOLOR_HIGHLIGHT_PUSHED).
BOOL | m_bInvertDragRect
Only used when the theme is set to xtpTaskPanelThemeVisualStudio2003.
BOOL | m_bCaptionScrollButton
TRUE if the group caption scroll button is visible, FALSE if the group caption scroll button is hidden.
BOOL | m_bEmbossedDisabledText
TRUE to draw disabled text embossed.
- Static Public Attributes inherited from CXTPTaskPanelPaintManager
static const CRect | rectDefault
System selected default margins.
- Protected Attributes inherited from CXTPTaskPanelPaintManagerPlain
BOOL | m_bRoundedFrame
TRUE to draw a rounded frame around all of the groups in the task panel.
BOOL | m_bOfficeCaption
FALSE to draw a rounded rectangle around caption.
- Protected Attributes inherited from CXTPTaskPanelPaintManager
BOOL | m_bUseBitmapGrippers
TRUE to use alpha grippers.
HICON | m_hGripperNormal
Icon of normal group header gripper.
HICON | m_hGripperSpecial
Icon of special group header gripper.
HBITMAP | m_bmpGrippers [8]
Bitmaps of alpha grippers.
CXTPFont | m_xtpFontCaption
Caption font.
CXTPFont | m_xtpFontIcon
Normal items font.
CXTPFont | m_xtpFontIconBold
Bold items font.
CXTPFont | m_xtpFontIconHot
"Hot" items font.
CXTPFont | m_xtpFontIconHotBold
Bold items font.
CXTPPaintManagerColorGradient | m_clrBackground
Background color of the Task Panel.
XTP_TASKPANEL_GROUPCOLORS | m_groupNormal
Normal colors set.
XTP_TASKPANEL_GROUPCOLORS | m_groupSpecial
Special colors set.
CXTPPaintManagerColor | m_clrHighlightHot
Color of items when they are "hot." This is the color of the item on mouseover if hot tracking is enabled.
CXTPPaintManagerColor m_clrHighlightSelected
Color of items when they are selected.
CXTPPaintManagerColor m_clrHighlightPressed
Color of items when they are pressed.
CXTPPaintManagerColorGradient | m_clrHighlightBorder
Border color of items when they are "hot." This is the border color of the item on mouse over if hot tracking is enabled.
BOOL | m_bOfficeBorder
TRUE to use Office borders.
BOOL | m_bLeftRoundedCorner
TRUE to round left corner of the group caption.
BOOL | m_bRightRoundedCorner
TRUE to round right corner of the group caption.
int | m_nCaptionHeight
Caption height, in pixels.
BOOL | m_bUseStandardCaptionFont
TRUE to use system font for group caption text.
BOOL | m_bUseStandardItemsFont
TRUE to use system font for item caption text.
int | m_nItemTextFormat
Format flags of item text.
int | m_nCaptionTextFormat
Format flags of caption text.

Detailed Description

CXTPTaskPanelShortcutBarOffice2003Theme represents an Office 2003 ShortcutBar style theme.

See also
CXTPTaskPanel::SetTheme

Member Function Documentation

◆ DrawGroupCaptionBackground()

CRect DrawGroupCaptionBackground | ( | CDC * | pDC,
 |  | CXTPTaskPanelGroup * | pGroup,
 |  | CRect | rc )
 protectedvirtual

Draws the group caption background of a specified group.

Parameters
pDC | Pointer to a valid device context.
pGroup | Pointer to the group to draw the group caption background of.
rc | Bounding rectangle of the group caption.
Returns
The bounding rectangle of the text within the group caption.

Reimplemented from CXTPTaskPanelListViewOffice2003Theme.

Reimplemented in CXTPTaskPanelShortcutBarOffice2007Theme.

◆ DrawGroupClientFace()

void DrawGroupClientFace | ( | CDC * | pDC,
 |  | CXTPTaskPanelGroup * | pGroup,
 |  | CRect | rc )
 protectedvirtual

Draws the client face of a specified group.

Parameters
pDC | Pointer to a valid device context.
pGroup | Pointer to the group to draw the client face of.
rc | Rectangle of the group to draw the client face of.

Reimplemented from CXTPTaskPanelPaintManagerPlain.

Reimplemented in CXTPTaskPanelShortcutBarOffice2007Theme.

◆ FillGroupClientFace()

void FillGroupClientFace | ( | CDC * | pDC,
 |  | CXTPTaskPanelGroup * | pGroup,
 |  | CRect | rc )
 protectedvirtual

Fills the client face of a specified group.

Parameters
pDC | Pointer to a valid device context.
pGroup | Pointer to the group to fill the client face of.
rc | Rectangle of the group to fill the client face of.
See also
DrawGroupClientFace

Reimplemented from CXTPTaskPanelPaintManagerPlain.

Reimplemented in CXTPTaskPanelShortcutBarOffice2007Theme.

◆ FillTaskPanel()

void FillTaskPanel | ( | CDC * | pDC,
 |  | CXTPTaskPanel * | pTaskPanel )
 protectedvirtual

Fills the background of a specified task panel.

Parameters
pDC | Pointer to a valid device context.
pTaskPanel | Pointer to the task panel to fill.

Reimplemented from CXTPTaskPanelPaintManagerPlain.

Reimplemented in CXTPTaskPanelShortcutBarOffice2007Theme.

The documentation for this class was generated from the following file:
  • XTPTaskPanelShortcutBarOffice2003Theme.h


Toolkit Pro: CXTPTaskPanelShortcutBarOffice2007Theme Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPTaskPanelShortcutBarOffice2007Theme Class Reference

CXTPTaskPanelShortcutBarOffice2007Theme represents an Office 2007 ShortcutBar style theme. More...

Inheritance diagram for CXTPTaskPanelShortcutBarOffice2007Theme:
[legend]

Public Member Functions

CXTPTaskPanelShortcutBarOffice2007Theme ()
Constructs a CXTPTaskPanelShortcutBarOffice2003Theme object.
void | RefreshMetrics ()
Refreshes the visual metrics of the task panel.
- Public Member Functions inherited from CXTPTaskPanelShortcutBarOffice2003Theme
CXTPTaskPanelShortcutBarOffice2003Theme ()
Constructs a CXTPTaskPanelShortcutBarOffice2003Theme object.
- Public Member Functions inherited from CXTPTaskPanelListViewOffice2003Theme
CXTPTaskPanelListViewOffice2003Theme ()
Constructs a CXTPTaskPanelListViewOffice2003Theme object.
- Public Member Functions inherited from CXTPTaskPanelListViewOfficeXPTheme
CXTPTaskPanelListViewOfficeXPTheme ()
Constructs a CXTPTaskPanelListViewOfficeXPTheme object.
- Public Member Functions inherited from CXTPTaskPanelListViewTheme
CXTPTaskPanelListViewTheme ()
Constructs a CXTPTaskPanelListViewTheme object.
- Public Member Functions inherited from CXTPTaskPanelToolboxTheme
CXTPTaskPanelToolboxTheme ()
Constructs a CXTPTaskPanelToolboxTheme object.
void | RefreshMetrics ()
Refreshes the visual metrics of the task panel.
int | DrawGroupCaption (CDC *pDC, CXTPTaskPanelGroup *pGroup, BOOL bDraw)
Draws the caption of a specified group.
- Public Member Functions inherited from CXTPTaskPanelPaintManagerPlain
CXTPTaskPanelPaintManagerPlain ()
Constructs a CXTPTaskPanelPaintManagerPlain object.
- Public Member Functions inherited from CXTPTaskPanelPaintManager
CXTPTaskPanelPaintManager ()
Constructs a CXTPTaskPanelPaintManager object.
virtual | ~CXTPTaskPanelPaintManager ()
Destroys a CXTPTaskPanelPaintManager object, handles cleanup and deallocation.
virtual void | DrawGroupClient (CDC *pDC, CXTPTaskPanelGroup *pGroup)
Draws a specified group.
virtual CRect | DrawGroupItem (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw)
Draws a specified group item.
XTP_TASKPANEL_GROUPCOLORS * | GetGroupColors (BOOL bSpecial)
Retrieves a specified group color set.
virtual XTP_TASKPANEL_GROUPCOLORS * | GetGroupColors (CXTPTaskPanelGroup *pGroup)
Retrieves a specified group color set.
virtual CRect | GetItemOuterMargins (const CXTPTaskPanelGroupItem *pItem)
Retrieves the outer margins of a specified group item.
virtual CRect | GetItemInnerMargins (const CXTPTaskPanelGroupItem *pItem)
Retrieves the inner margins of a specified group item.
virtual CRect | GetGroupOuterMargins (const CXTPTaskPanelGroup *pGroup)
Retrieves the outer margins of a specified group.
virtual CRect | GetItemIconPadding (const CXTPTaskPanelItem *pItem)
Retrieves the icon padding of a specified item.
virtual CRect | GetGroupInnerMargins (const CXTPTaskPanelGroup *pGroup)
Retrieves the inner margins of a specified group.
virtual CRect | GetControlMargins (const CXTPTaskPanel *pPanel)
Gets the default margins used for all groups within a specified Task Panel control.
virtual int | GetGroupSpacing (const CXTPTaskPanel *pPanel)
Gets the spacing used between groups within a specified Task Panel control.
virtual void | DrawScrollButton (CDC *pDC, CXTPTaskPanelScrollButton *pScrollButton)
Draws a group scroll button.
void | SetTextFormat (int nTextFormat, BOOL bCaption=FALSE)
Sets the text format for captions/items.
void | SetItemsFontIndirect (LOGFONT *pLogFont, BOOL bUseStandardItemsFont=FALSE)
Sets the text font for items.
void | SetCaptionFontIndirect (LOGFONT *pLogFont, BOOL bUseStandardCaptionFont=FALSE)
Sets the text font for captions.
virtual CFont * | GetItemFont (CXTPTaskPanelItem *pItem)
Retrieves the text font of a specified item.

Protected Member Functions

CRect | DrawGroupCaptionBackground (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Draws the group caption background of a specified group.
void | DrawGroupClientFace (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Draws the client face of a specified group.
void | FillGroupClientFace (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Fills the client face of a specified group.
void | FillTaskPanel (CDC *pDC, CXTPTaskPanel *pTaskPanel)
Fills the background of a specified task panel.
void | DrawGroupItemFrame (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc)
Draws a rectangle around a group item when it is selected, pressed or highlighted.
- Protected Member Functions inherited from CXTPTaskPanelShortcutBarOffice2003Theme
- Protected Member Functions inherited from CXTPTaskPanelToolboxTheme
- Protected Member Functions inherited from CXTPTaskPanelPaintManager
CRect | DrawGroupItemImageWithText (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw)
Draws the icon of a specified group item.
CRect | DrawGroupItemImageWithTextBelow (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw)
Draws the icon of a specified group item.
CRect | DrawGroupItemImage (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw)
Draws the icon of a specified group item.
virtual void | DrawGroupClientItems (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Draws the items of a specified group.
virtual CRect | DrawCaptionGripper (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Draws the caption gripper of a specified group.
virtual int | GetCaptionGripperWidth (CXTPTaskPanelGroup *pGroup, CRect rc)
Retrieves the width of the caption gripper of a specified group.
virtual void | DrawItemCaption (CDC *pDC, CXTPTaskPanelItem *pItem, CRect rcText, UINT nFormat)
Draws the text caption of a specified item.
virtual void | DrawItemImage (CDC *pDC, CXTPTaskPanelItem *pItem, CPoint ptIcon, CXTPImageManagerIcon *pImage, CSize szIcon)
Draws the icon of a specified item.
COLORREF | BlendColor (COLORREF clrFrom, COLORREF clrTo, int nAlpha)
Blends one color to another color by a specified amount.
CRect | DrawCaptionGripperBitmap (CDC *pDC, CXTPTaskPanelGroup *pGroup, BOOL bExpanded, BOOL bHot, CRect rc)
Draws the caption gripper bitmap.
void | DrawCaptionGripperSigns (CDC *pDC, CPoint pt, COLORREF clr, BOOL bExpanded)
Draws the ">>" and "<<" signs of the caption gripper when the theme of the Task Panel is set to Office 2000.
void | CreateGripperBitmaps ()
Loads the gripper bitmap when the theme of the Task Panel is set to either Windows XP or Classic Windows XP.
void | CreateGripperIcon (HICON &hIcon, UINT nIDResource, COLORREF clrGripperBack)
Creates the gripper bitmap icons when the theme of the Task Panel is set to either Windows XP or Classic Windows XP and either the operating system is not Windows XP or the operating system is Windows XP and Luna themes are used.
void | FreeBitmaps ()
Frees the memory used by the group caption bitmaps.
void | Rectangle (CDC *pDC, CRect rc, COLORREF clrPen, COLORREF clrBrush)
This method is only used when drawing hot, pressed, and selected group items and scroll buttons when m_bOfficeHighlight is TRUE.
virtual CPoint | GetHighlightOffset (CXTPTaskPanelGroupItem *pItem)
Retrieves the highlight offset of the text of a specified group item.
virtual void | DrawDragArrow (CDC *pDC, CXTPTaskPanelItem *pItem, CRect rc, BOOL bAfter=FALSE)
Draws the "drag arrow" of a specified item.
virtual void | DrawFocusRect (CDC *pDC, CRect rc)
Draws a rectangle around the focused item.

Protected Attributes

COLORREF | m_clrShortcutItemShadow
Shadow color of items.
- Protected Attributes inherited from CXTPTaskPanelPaintManagerPlain
BOOL | m_bRoundedFrame
TRUE to draw a rounded frame around all of the groups in the task panel.
BOOL | m_bOfficeCaption
FALSE to draw a rounded rectangle around caption.
- Protected Attributes inherited from CXTPTaskPanelPaintManager
BOOL | m_bUseBitmapGrippers
TRUE to use alpha grippers.
HICON | m_hGripperNormal
Icon of normal group header gripper.
HICON | m_hGripperSpecial
Icon of special group header gripper.
HBITMAP | m_bmpGrippers [8]
Bitmaps of alpha grippers.
CXTPFont | m_xtpFontCaption
Caption font.
CXTPFont | m_xtpFontIcon
Normal items font.
CXTPFont | m_xtpFontIconBold
Bold items font.
CXTPFont | m_xtpFontIconHot
"Hot" items font.
CXTPFont | m_xtpFontIconHotBold
Bold items font.
CXTPPaintManagerColorGradient | m_clrBackground
Background color of the Task Panel.
XTP_TASKPANEL_GROUPCOLORS | m_groupNormal
Normal colors set.
XTP_TASKPANEL_GROUPCOLORS | m_groupSpecial
Special colors set.
CXTPPaintManagerColor | m_clrHighlightHot
Color of items when they are "hot." This is the color of the item on mouseover if hot tracking is enabled.
CXTPPaintManagerColor m_clrHighlightSelected
Color of items when they are selected.
CXTPPaintManagerColor m_clrHighlightPressed
Color of items when they are pressed.
CXTPPaintManagerColorGradient | m_clrHighlightBorder
Border color of items when they are "hot." This is the border color of the item on mouse over if hot tracking is enabled.
BOOL | m_bOfficeBorder
TRUE to use Office borders.
BOOL | m_bLeftRoundedCorner
TRUE to round left corner of the group caption.
BOOL | m_bRightRoundedCorner
TRUE to round right corner of the group caption.
int | m_nCaptionHeight
Caption height, in pixels.
BOOL | m_bUseStandardCaptionFont
TRUE to use system font for group caption text.
BOOL | m_bUseStandardItemsFont
TRUE to use system font for item caption text.
int | m_nItemTextFormat
Format flags of item text.
int | m_nCaptionTextFormat
Format flags of caption text.

Additional Inherited Members

- Public Attributes inherited from CXTPTaskPanelListViewOffice2003Theme
CXTPPaintManagerColorGradient | m_grcHot
Color gradient used to colorize "hot" items for this theme.
CXTPPaintManagerColorGradient | m_grcPushed
Color gradient used to colorize "pushed" items for this theme.
- Public Attributes inherited from CXTPTaskPanelPaintManager
BOOL | m_bEmulateEplorerTheme
TRUE to use Explorer theme under WinXP and Office 2000 under older OS.
XTPTaskPanelGripper | m_eGripper
Gripper of the manager.
BOOL | m_bBoldCaption
TRUE to display caption text in bold font, FALSE to display caption text in normal type.
CRect | m_rcGroupOuterMargins
Outer margins of the group.
CRect | m_rcGroupInnerMargins
Inner margins of the group.
CRect | m_rcItemOuterMargins
Outer margins of the group items.
CRect | m_rcItemInnerMargins
Inner margins of the group items.
CRect | m_rcControlMargins
Default margins for all groups.
int | m_nGroupSpacing
Amount of space placed between groups in the task panel.
CRect | m_rcImageLayoutIconPadding
Padding around images for xtpTaskItemLayoutImages layout.
CRect | m_rcItemIconPadding
Padding around images for items.
CRect | m_rcGroupIconPadding
Padding around images for groups.
BOOL | m_bOfficeHighlight
TRUE to highlight group items and scroll buttons using the Office XP style (XPCOLOR_HIGHLIGHT, XPCOLOR_HIGHLIGHT_CHECKED, XPCOLOR_HIGHLIGHT_PUSHED).
BOOL | m_bInvertDragRect
Only used when the theme is set to xtpTaskPanelThemeVisualStudio2003.
BOOL | m_bCaptionScrollButton
TRUE if the group caption scroll button is visible, FALSE if the group caption scroll button is hidden.
BOOL | m_bEmbossedDisabledText
TRUE to draw disabled text embossed.
- Static Public Attributes inherited from CXTPTaskPanelPaintManager
static const CRect | rectDefault
System selected default margins.

Detailed Description

CXTPTaskPanelShortcutBarOffice2007Theme represents an Office 2007 ShortcutBar style theme.

See also
CXTPTaskPanel::SetTheme

Member Function Documentation

◆ DrawGroupCaptionBackground()

CRect DrawGroupCaptionBackground | ( | CDC * | pDC,
 |  | CXTPTaskPanelGroup * | pGroup,
 |  | CRect | rc )
 protectedvirtual

Draws the group caption background of a specified group.

Parameters
pDC | Pointer to a valid device context.
pGroup | Pointer to the group to draw the group caption background of.
rc | Bounding rectangle of the group caption.
Returns
The bounding rectangle of the text within the group caption.

Reimplemented from CXTPTaskPanelShortcutBarOffice2003Theme.

◆ DrawGroupClientFace()

void DrawGroupClientFace | ( | CDC * | pDC,
 |  | CXTPTaskPanelGroup * | pGroup,
 |  | CRect | rc )
 protectedvirtual

Draws the client face of a specified group.

Parameters
pDC | Pointer to a valid device context.
pGroup | Pointer to the group to draw the client face of.
rc | Rectangle of the group to draw the client face of.

Reimplemented from CXTPTaskPanelShortcutBarOffice2003Theme.

◆ DrawGroupItemFrame()

void DrawGroupItemFrame | ( | CDC * | pDC,
 |  | CXTPTaskPanelGroupItem * | pItem,
 |  | CRect | rc )
 protectedvirtual

Draws a rectangle around a group item when it is selected, pressed or highlighted.

Parameters
pDC | Pointer to a valid device context.
pItem | Pointer to the group item.
rc | Rectangle to be drawn.

Reimplemented from CXTPTaskPanelPaintManager.

◆ FillGroupClientFace()

void FillGroupClientFace | ( | CDC * | pDC,
 |  | CXTPTaskPanelGroup * | pGroup,
 |  | CRect | rc )
 protectedvirtual

Fills the client face of a specified group.

Parameters
pDC | Pointer to a valid device context.
pGroup | Pointer to the group to fill the client face of.
rc | Rectangle of the group to fill the client face of.
See also
DrawGroupClientFace

Reimplemented from CXTPTaskPanelShortcutBarOffice2003Theme.

◆ FillTaskPanel()

void FillTaskPanel | ( | CDC * | pDC,
 |  | CXTPTaskPanel * | pTaskPanel )
 protectedvirtual

Fills the background of a specified task panel.

Parameters
pDC | Pointer to a valid device context.
pTaskPanel | Pointer to the task panel to fill.

Reimplemented from CXTPTaskPanelShortcutBarOffice2003Theme.

The documentation for this class was generated from the following file:
  • XTPTaskPanelShortcutBarOffice2007Theme.h


Toolkit Pro: CXTPTaskPanelToolboxTheme Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPTaskPanelToolboxTheme Class Reference

CXTPTaskPanelToolboxTheme represents a Toolbox style theme. More...

Inheritance diagram for CXTPTaskPanelToolboxTheme:
[legend]

Public Member Functions

CXTPTaskPanelToolboxTheme ()
Constructs a CXTPTaskPanelToolboxTheme object.
void | RefreshMetrics ()
Refreshes the visual metrics of the task panel.
int | DrawGroupCaption (CDC *pDC, CXTPTaskPanelGroup *pGroup, BOOL bDraw)
Draws the caption of a specified group.
- Public Member Functions inherited from CXTPTaskPanelPaintManagerPlain
CXTPTaskPanelPaintManagerPlain ()
Constructs a CXTPTaskPanelPaintManagerPlain object.
void | DrawGroupClientFace (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Draws the client face of a specified group.
void | FillGroupClientFace (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Fills the client face of a specified group.
void | FillTaskPanel (CDC *pDC, CXTPTaskPanel *pTaskPanel)
Fills the background of a specified task panel.
- Public Member Functions inherited from CXTPTaskPanelPaintManager
CXTPTaskPanelPaintManager ()
Constructs a CXTPTaskPanelPaintManager object.
virtual | ~CXTPTaskPanelPaintManager ()
Destroys a CXTPTaskPanelPaintManager object, handles cleanup and deallocation.
virtual void | DrawGroupClient (CDC *pDC, CXTPTaskPanelGroup *pGroup)
Draws a specified group.
virtual CRect | DrawGroupItem (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw)
Draws a specified group item.
XTP_TASKPANEL_GROUPCOLORS * | GetGroupColors (BOOL bSpecial)
Retrieves a specified group color set.
virtual XTP_TASKPANEL_GROUPCOLORS * | GetGroupColors (CXTPTaskPanelGroup *pGroup)
Retrieves a specified group color set.
virtual void | DrawGroupItemFrame (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc)
Draws a rectangle around a group item when it is selected, pressed or highlighted.
virtual CRect | GetItemOuterMargins (const CXTPTaskPanelGroupItem *pItem)
Retrieves the outer margins of a specified group item.
virtual CRect | GetItemInnerMargins (const CXTPTaskPanelGroupItem *pItem)
Retrieves the inner margins of a specified group item.
virtual CRect | GetGroupOuterMargins (const CXTPTaskPanelGroup *pGroup)
Retrieves the outer margins of a specified group.
virtual CRect | GetItemIconPadding (const CXTPTaskPanelItem *pItem)
Retrieves the icon padding of a specified item.
virtual CRect | GetGroupInnerMargins (const CXTPTaskPanelGroup *pGroup)
Retrieves the inner margins of a specified group.
virtual CRect | GetControlMargins (const CXTPTaskPanel *pPanel)
Gets the default margins used for all groups within a specified Task Panel control.
virtual int | GetGroupSpacing (const CXTPTaskPanel *pPanel)
Gets the spacing used between groups within a specified Task Panel control.
virtual void | DrawScrollButton (CDC *pDC, CXTPTaskPanelScrollButton *pScrollButton)
Draws a group scroll button.
void | SetTextFormat (int nTextFormat, BOOL bCaption=FALSE)
Sets the text format for captions/items.
void | SetItemsFontIndirect (LOGFONT *pLogFont, BOOL bUseStandardItemsFont=FALSE)
Sets the text font for items.
void | SetCaptionFontIndirect (LOGFONT *pLogFont, BOOL bUseStandardCaptionFont=FALSE)
Sets the text font for captions.
virtual CFont * | GetItemFont (CXTPTaskPanelItem *pItem)
Retrieves the text font of a specified item.

Protected Member Functions

virtual CRect | DrawGroupCaptionBackground (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Draws the group caption background of a specified group.
- Protected Member Functions inherited from CXTPTaskPanelPaintManager
CRect | DrawGroupItemImageWithText (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw)
Draws the icon of a specified group item.
CRect | DrawGroupItemImageWithTextBelow (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw)
Draws the icon of a specified group item.
CRect | DrawGroupItemImage (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw)
Draws the icon of a specified group item.
virtual void | DrawGroupClientItems (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Draws the items of a specified group.
virtual CRect | DrawCaptionGripper (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Draws the caption gripper of a specified group.
virtual int | GetCaptionGripperWidth (CXTPTaskPanelGroup *pGroup, CRect rc)
Retrieves the width of the caption gripper of a specified group.
virtual void | DrawItemCaption (CDC *pDC, CXTPTaskPanelItem *pItem, CRect rcText, UINT nFormat)
Draws the text caption of a specified item.
virtual void | DrawItemImage (CDC *pDC, CXTPTaskPanelItem *pItem, CPoint ptIcon, CXTPImageManagerIcon *pImage, CSize szIcon)
Draws the icon of a specified item.
COLORREF | BlendColor (COLORREF clrFrom, COLORREF clrTo, int nAlpha)
Blends one color to another color by a specified amount.
CRect | DrawCaptionGripperBitmap (CDC *pDC, CXTPTaskPanelGroup *pGroup, BOOL bExpanded, BOOL bHot, CRect rc)
Draws the caption gripper bitmap.
void | DrawCaptionGripperSigns (CDC *pDC, CPoint pt, COLORREF clr, BOOL bExpanded)
Draws the ">>" and "<<" signs of the caption gripper when the theme of the Task Panel is set to Office 2000.
void | CreateGripperBitmaps ()
Loads the gripper bitmap when the theme of the Task Panel is set to either Windows XP or Classic Windows XP.
void | CreateGripperIcon (HICON &hIcon, UINT nIDResource, COLORREF clrGripperBack)
Creates the gripper bitmap icons when the theme of the Task Panel is set to either Windows XP or Classic Windows XP and either the operating system is not Windows XP or the operating system is Windows XP and Luna themes are used.
void | FreeBitmaps ()
Frees the memory used by the group caption bitmaps.
void | Rectangle (CDC *pDC, CRect rc, COLORREF clrPen, COLORREF clrBrush)
This method is only used when drawing hot, pressed, and selected group items and scroll buttons when m_bOfficeHighlight is TRUE.
virtual CPoint | GetHighlightOffset (CXTPTaskPanelGroupItem *pItem)
Retrieves the highlight offset of the text of a specified group item.
virtual void | DrawDragArrow (CDC *pDC, CXTPTaskPanelItem *pItem, CRect rc, BOOL bAfter=FALSE)
Draws the "drag arrow" of a specified item.
virtual void | DrawFocusRect (CDC *pDC, CRect rc)
Draws a rectangle around the focused item.

Additional Inherited Members

- Public Attributes inherited from CXTPTaskPanelPaintManager
BOOL | m_bEmulateEplorerTheme
TRUE to use Explorer theme under WinXP and Office 2000 under older OS.
XTPTaskPanelGripper | m_eGripper
Gripper of the manager.
BOOL | m_bBoldCaption
TRUE to display caption text in bold font, FALSE to display caption text in normal type.
CRect | m_rcGroupOuterMargins
Outer margins of the group.
CRect | m_rcGroupInnerMargins
Inner margins of the group.
CRect | m_rcItemOuterMargins
Outer margins of the group items.
CRect | m_rcItemInnerMargins
Inner margins of the group items.
CRect | m_rcControlMargins
Default margins for all groups.
int | m_nGroupSpacing
Amount of space placed between groups in the task panel.
CRect | m_rcImageLayoutIconPadding
Padding around images for xtpTaskItemLayoutImages layout.
CRect | m_rcItemIconPadding
Padding around images for items.
CRect | m_rcGroupIconPadding
Padding around images for groups.
BOOL | m_bOfficeHighlight
TRUE to highlight group items and scroll buttons using the Office XP style (XPCOLOR_HIGHLIGHT, XPCOLOR_HIGHLIGHT_CHECKED, XPCOLOR_HIGHLIGHT_PUSHED).
BOOL | m_bInvertDragRect
Only used when the theme is set to xtpTaskPanelThemeVisualStudio2003.
BOOL | m_bCaptionScrollButton
TRUE if the group caption scroll button is visible, FALSE if the group caption scroll button is hidden.
BOOL | m_bEmbossedDisabledText
TRUE to draw disabled text embossed.
- Static Public Attributes inherited from CXTPTaskPanelPaintManager
static const CRect | rectDefault
System selected default margins.
- Protected Attributes inherited from CXTPTaskPanelPaintManagerPlain
BOOL | m_bRoundedFrame
TRUE to draw a rounded frame around all of the groups in the task panel.
BOOL | m_bOfficeCaption
FALSE to draw a rounded rectangle around caption.
- Protected Attributes inherited from CXTPTaskPanelPaintManager
BOOL | m_bUseBitmapGrippers
TRUE to use alpha grippers.
HICON | m_hGripperNormal
Icon of normal group header gripper.
HICON | m_hGripperSpecial
Icon of special group header gripper.
HBITMAP | m_bmpGrippers [8]
Bitmaps of alpha grippers.
CXTPFont | m_xtpFontCaption
Caption font.
CXTPFont | m_xtpFontIcon
Normal items font.
CXTPFont | m_xtpFontIconBold
Bold items font.
CXTPFont | m_xtpFontIconHot
"Hot" items font.
CXTPFont | m_xtpFontIconHotBold
Bold items font.
CXTPPaintManagerColorGradient | m_clrBackground
Background color of the Task Panel.
XTP_TASKPANEL_GROUPCOLORS | m_groupNormal
Normal colors set.
XTP_TASKPANEL_GROUPCOLORS | m_groupSpecial
Special colors set.
CXTPPaintManagerColor | m_clrHighlightHot
Color of items when they are "hot." This is the color of the item on mouseover if hot tracking is enabled.
CXTPPaintManagerColor m_clrHighlightSelected
Color of items when they are selected.
CXTPPaintManagerColor m_clrHighlightPressed
Color of items when they are pressed.
CXTPPaintManagerColorGradient | m_clrHighlightBorder
Border color of items when they are "hot." This is the border color of the item on mouse over if hot tracking is enabled.
BOOL | m_bOfficeBorder
TRUE to use Office borders.
BOOL | m_bLeftRoundedCorner
TRUE to round left corner of the group caption.
BOOL | m_bRightRoundedCorner
TRUE to round right corner of the group caption.
int | m_nCaptionHeight
Caption height, in pixels.
BOOL | m_bUseStandardCaptionFont
TRUE to use system font for group caption text.
BOOL | m_bUseStandardItemsFont
TRUE to use system font for item caption text.
int | m_nItemTextFormat
Format flags of item text.
int | m_nCaptionTextFormat
Format flags of caption text.

Detailed Description

CXTPTaskPanelToolboxTheme represents a Toolbox style theme.

See also
CXTPTaskPanel::SetTheme

Member Function Documentation

◆ DrawGroupCaption()

int DrawGroupCaption | ( | CDC * | pDC,
 |  | CXTPTaskPanelGroup * | pGroup,
 |  | BOOL | bDraw )
 virtual

Draws the caption of a specified group.

Parameters
pDC | Pointer to a valid device context.
pGroup | Pointer to the group to draw the caption of.
bDraw | TRUE to draw the caption of the specified group, FALSE to retrieve the height of the caption.
Returns
The height of the caption.

Reimplemented from CXTPTaskPanelPaintManagerPlain.

◆ DrawGroupCaptionBackground()

virtual CRect DrawGroupCaptionBackground | ( | CDC * | pDC,
 |  | CXTPTaskPanelGroup * | pGroup,
 |  | CRect | rc )
 protectedvirtual

Draws the group caption background of a specified group.

Parameters
pDC | Pointer to a valid device context.
pGroup | Pointer to the group to draw the group caption background of.
rc | Bounding rectangle of the group caption.
Returns
The bounding rectangle of the text within the group caption.

Reimplemented in CXTPTaskPanelListViewOffice2003Theme, CXTPTaskPanelShortcutBarOffice2003Theme, CXTPTaskPanelShortcutBarOffice2007Theme, CXTPTaskPanelVisualStudio2005Theme, CXTPTaskPanelVisualStudio2010Theme, and CXTPTaskPanelVisualStudio2012Theme.

The documentation for this class was generated from the following file:
  • XTPTaskPanelToolboxTheme.h


Toolkit Pro: CXTPTaskPanelVisualStudio2005Theme Class Reference

Public Member Functions | List of all members
CXTPTaskPanelVisualStudio2005Theme Class Reference

CXTPTaskPanelVisualStudio2005Theme represents a Visual Studio 2005 style theme. More...

Inheritance diagram for CXTPTaskPanelVisualStudio2005Theme:
[legend]

Public Member Functions

CXTPTaskPanelVisualStudio2005Theme ()
Constructs a CXTPTaskPanelVisualStudio2005Theme object.
CRect | DrawGroupCaptionBackground (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Draws the group caption background of a specified group.
void | DrawGroupClientFace (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Draws the client face of a specified group.
void | FillGroupClientFace (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Fills the client face of a specified group.
void | FillTaskPanel (CDC *pDC, CXTPTaskPanel *pTaskPanel)
Fills the background of a specified task panel.
void | RefreshMetrics ()
Refreshes the visual metrics of the task panel.
- Public Member Functions inherited from CXTPTaskPanelToolboxTheme
CXTPTaskPanelToolboxTheme ()
Constructs a CXTPTaskPanelToolboxTheme object.
int | DrawGroupCaption (CDC *pDC, CXTPTaskPanelGroup *pGroup, BOOL bDraw)
Draws the caption of a specified group.
- Public Member Functions inherited from CXTPTaskPanelPaintManagerPlain
CXTPTaskPanelPaintManagerPlain ()
Constructs a CXTPTaskPanelPaintManagerPlain object.
- Public Member Functions inherited from CXTPTaskPanelPaintManager
CXTPTaskPanelPaintManager ()
Constructs a CXTPTaskPanelPaintManager object.
virtual | ~CXTPTaskPanelPaintManager ()
Destroys a CXTPTaskPanelPaintManager object, handles cleanup and deallocation.
virtual void | DrawGroupClient (CDC *pDC, CXTPTaskPanelGroup *pGroup)
Draws a specified group.
virtual CRect | DrawGroupItem (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw)
Draws a specified group item.
XTP_TASKPANEL_GROUPCOLORS * | GetGroupColors (BOOL bSpecial)
Retrieves a specified group color set.
virtual XTP_TASKPANEL_GROUPCOLORS * | GetGroupColors (CXTPTaskPanelGroup *pGroup)
Retrieves a specified group color set.
virtual void | DrawGroupItemFrame (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc)
Draws a rectangle around a group item when it is selected, pressed or highlighted.
virtual CRect | GetItemOuterMargins (const CXTPTaskPanelGroupItem *pItem)
Retrieves the outer margins of a specified group item.
virtual CRect | GetItemInnerMargins (const CXTPTaskPanelGroupItem *pItem)
Retrieves the inner margins of a specified group item.
virtual CRect | GetGroupOuterMargins (const CXTPTaskPanelGroup *pGroup)
Retrieves the outer margins of a specified group.
virtual CRect | GetItemIconPadding (const CXTPTaskPanelItem *pItem)
Retrieves the icon padding of a specified item.
virtual CRect | GetGroupInnerMargins (const CXTPTaskPanelGroup *pGroup)
Retrieves the inner margins of a specified group.
virtual CRect | GetControlMargins (const CXTPTaskPanel *pPanel)
Gets the default margins used for all groups within a specified Task Panel control.
virtual int | GetGroupSpacing (const CXTPTaskPanel *pPanel)
Gets the spacing used between groups within a specified Task Panel control.
virtual void | DrawScrollButton (CDC *pDC, CXTPTaskPanelScrollButton *pScrollButton)
Draws a group scroll button.
void | SetTextFormat (int nTextFormat, BOOL bCaption=FALSE)
Sets the text format for captions/items.
void | SetItemsFontIndirect (LOGFONT *pLogFont, BOOL bUseStandardItemsFont=FALSE)
Sets the text font for items.
void | SetCaptionFontIndirect (LOGFONT *pLogFont, BOOL bUseStandardCaptionFont=FALSE)
Sets the text font for captions.
virtual CFont * | GetItemFont (CXTPTaskPanelItem *pItem)
Retrieves the text font of a specified item.

Additional Inherited Members

- Public Attributes inherited from CXTPTaskPanelPaintManager
BOOL | m_bEmulateEplorerTheme
TRUE to use Explorer theme under WinXP and Office 2000 under older OS.
XTPTaskPanelGripper | m_eGripper
Gripper of the manager.
BOOL | m_bBoldCaption
TRUE to display caption text in bold font, FALSE to display caption text in normal type.
CRect | m_rcGroupOuterMargins
Outer margins of the group.
CRect | m_rcGroupInnerMargins
Inner margins of the group.
CRect | m_rcItemOuterMargins
Outer margins of the group items.
CRect | m_rcItemInnerMargins
Inner margins of the group items.
CRect | m_rcControlMargins
Default margins for all groups.
int | m_nGroupSpacing
Amount of space placed between groups in the task panel.
CRect | m_rcImageLayoutIconPadding
Padding around images for xtpTaskItemLayoutImages layout.
CRect | m_rcItemIconPadding
Padding around images for items.
CRect | m_rcGroupIconPadding
Padding around images for groups.
BOOL | m_bOfficeHighlight
TRUE to highlight group items and scroll buttons using the Office XP style (XPCOLOR_HIGHLIGHT, XPCOLOR_HIGHLIGHT_CHECKED, XPCOLOR_HIGHLIGHT_PUSHED).
BOOL | m_bInvertDragRect
Only used when the theme is set to xtpTaskPanelThemeVisualStudio2003.
BOOL | m_bCaptionScrollButton
TRUE if the group caption scroll button is visible, FALSE if the group caption scroll button is hidden.
BOOL | m_bEmbossedDisabledText
TRUE to draw disabled text embossed.
- Static Public Attributes inherited from CXTPTaskPanelPaintManager
static const CRect | rectDefault
System selected default margins.
- Protected Member Functions inherited from CXTPTaskPanelToolboxTheme
- Protected Member Functions inherited from CXTPTaskPanelPaintManager
CRect | DrawGroupItemImageWithText (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw)
Draws the icon of a specified group item.
CRect | DrawGroupItemImageWithTextBelow (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw)
Draws the icon of a specified group item.
CRect | DrawGroupItemImage (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw)
Draws the icon of a specified group item.
virtual void | DrawGroupClientItems (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Draws the items of a specified group.
virtual CRect | DrawCaptionGripper (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Draws the caption gripper of a specified group.
virtual int | GetCaptionGripperWidth (CXTPTaskPanelGroup *pGroup, CRect rc)
Retrieves the width of the caption gripper of a specified group.
virtual void | DrawItemCaption (CDC *pDC, CXTPTaskPanelItem *pItem, CRect rcText, UINT nFormat)
Draws the text caption of a specified item.
virtual void | DrawItemImage (CDC *pDC, CXTPTaskPanelItem *pItem, CPoint ptIcon, CXTPImageManagerIcon *pImage, CSize szIcon)
Draws the icon of a specified item.
COLORREF | BlendColor (COLORREF clrFrom, COLORREF clrTo, int nAlpha)
Blends one color to another color by a specified amount.
CRect | DrawCaptionGripperBitmap (CDC *pDC, CXTPTaskPanelGroup *pGroup, BOOL bExpanded, BOOL bHot, CRect rc)
Draws the caption gripper bitmap.
void | DrawCaptionGripperSigns (CDC *pDC, CPoint pt, COLORREF clr, BOOL bExpanded)
Draws the ">>" and "<<" signs of the caption gripper when the theme of the Task Panel is set to Office 2000.
void | CreateGripperBitmaps ()
Loads the gripper bitmap when the theme of the Task Panel is set to either Windows XP or Classic Windows XP.
void | CreateGripperIcon (HICON &hIcon, UINT nIDResource, COLORREF clrGripperBack)
Creates the gripper bitmap icons when the theme of the Task Panel is set to either Windows XP or Classic Windows XP and either the operating system is not Windows XP or the operating system is Windows XP and Luna themes are used.
void | FreeBitmaps ()
Frees the memory used by the group caption bitmaps.
void | Rectangle (CDC *pDC, CRect rc, COLORREF clrPen, COLORREF clrBrush)
This method is only used when drawing hot, pressed, and selected group items and scroll buttons when m_bOfficeHighlight is TRUE.
virtual CPoint | GetHighlightOffset (CXTPTaskPanelGroupItem *pItem)
Retrieves the highlight offset of the text of a specified group item.
virtual void | DrawDragArrow (CDC *pDC, CXTPTaskPanelItem *pItem, CRect rc, BOOL bAfter=FALSE)
Draws the "drag arrow" of a specified item.
virtual void | DrawFocusRect (CDC *pDC, CRect rc)
Draws a rectangle around the focused item.
- Protected Attributes inherited from CXTPTaskPanelPaintManagerPlain
BOOL | m_bRoundedFrame
TRUE to draw a rounded frame around all of the groups in the task panel.
BOOL | m_bOfficeCaption
FALSE to draw a rounded rectangle around caption.
- Protected Attributes inherited from CXTPTaskPanelPaintManager
BOOL | m_bUseBitmapGrippers
TRUE to use alpha grippers.
HICON | m_hGripperNormal
Icon of normal group header gripper.
HICON | m_hGripperSpecial
Icon of special group header gripper.
HBITMAP | m_bmpGrippers [8]
Bitmaps of alpha grippers.
CXTPFont | m_xtpFontCaption
Caption font.
CXTPFont | m_xtpFontIcon
Normal items font.
CXTPFont | m_xtpFontIconBold
Bold items font.
CXTPFont | m_xtpFontIconHot
"Hot" items font.
CXTPFont | m_xtpFontIconHotBold
Bold items font.
CXTPPaintManagerColorGradient | m_clrBackground
Background color of the Task Panel.
XTP_TASKPANEL_GROUPCOLORS | m_groupNormal
Normal colors set.
XTP_TASKPANEL_GROUPCOLORS | m_groupSpecial
Special colors set.
CXTPPaintManagerColor | m_clrHighlightHot
Color of items when they are "hot." This is the color of the item on mouseover if hot tracking is enabled.
CXTPPaintManagerColor m_clrHighlightSelected
Color of items when they are selected.
CXTPPaintManagerColor m_clrHighlightPressed
Color of items when they are pressed.
CXTPPaintManagerColorGradient | m_clrHighlightBorder
Border color of items when they are "hot." This is the border color of the item on mouse over if hot tracking is enabled.
BOOL | m_bOfficeBorder
TRUE to use Office borders.
BOOL | m_bLeftRoundedCorner
TRUE to round left corner of the group caption.
BOOL | m_bRightRoundedCorner
TRUE to round right corner of the group caption.
int | m_nCaptionHeight
Caption height, in pixels.
BOOL | m_bUseStandardCaptionFont
TRUE to use system font for group caption text.
BOOL | m_bUseStandardItemsFont
TRUE to use system font for item caption text.
int | m_nItemTextFormat
Format flags of item text.
int | m_nCaptionTextFormat
Format flags of caption text.

Detailed Description

CXTPTaskPanelVisualStudio2005Theme represents a Visual Studio 2005 style theme.

See also
CXTPTaskPanel::SetTheme

Member Function Documentation

◆ DrawGroupCaptionBackground()

CRect DrawGroupCaptionBackground | ( | CDC * | pDC,
 |  | CXTPTaskPanelGroup * | pGroup,
 |  | CRect | rc )
 virtual

Draws the group caption background of a specified group.

Parameters
pDC | Pointer to a valid device context.
pGroup | Pointer to the group to draw the group caption background of.
rc | Bounding rectangle of the group caption.
Returns
The bounding rectangle of the text within the group caption.

Reimplemented from CXTPTaskPanelToolboxTheme.

Reimplemented in CXTPTaskPanelVisualStudio2010Theme, and CXTPTaskPanelVisualStudio2012Theme.

◆ DrawGroupClientFace()

void DrawGroupClientFace | ( | CDC * | pDC,
 |  | CXTPTaskPanelGroup * | pGroup,
 |  | CRect | rc )
 virtual

Draws the client face of a specified group.

Parameters
pDC | Pointer to a valid device context.
pGroup | Pointer to the group to draw the client face of.
rc | Rectangle of the group to draw the client face of.

Reimplemented from CXTPTaskPanelPaintManagerPlain.

Reimplemented in CXTPTaskPanelVisualStudio2010Theme, and CXTPTaskPanelVisualStudio2012Theme.

◆ FillGroupClientFace()

void FillGroupClientFace | ( | CDC * | pDC,
 |  | CXTPTaskPanelGroup * | pGroup,
 |  | CRect | rc )
 virtual

Fills the client face of a specified group.

Parameters
pDC | Pointer to a valid device context.
pGroup | Pointer to the group to fill the client face of.
rc | Rectangle of the group to fill the client face of.
See also
DrawGroupClientFace

Reimplemented from CXTPTaskPanelPaintManagerPlain.

Reimplemented in CXTPTaskPanelVisualStudio2010Theme, and CXTPTaskPanelVisualStudio2012Theme.

◆ FillTaskPanel()

void FillTaskPanel | ( | CDC * | pDC,
 |  | CXTPTaskPanel * | pTaskPanel )
 virtual

Fills the background of a specified task panel.

Parameters
pDC | Pointer to a valid device context.
pTaskPanel | Pointer to the task panel to fill.

Reimplemented from CXTPTaskPanelPaintManagerPlain.

Reimplemented in CXTPTaskPanelVisualStudio2010Theme, and CXTPTaskPanelVisualStudio2012Theme.

The documentation for this class was generated from the following file:
  • XTPTaskPanelVisualStudio2005Theme.h


Toolkit Pro: CXTPTaskPanelVisualStudio2010Theme Class Reference

Public Member Functions | List of all members
CXTPTaskPanelVisualStudio2010Theme Class Reference

CXTPTaskPanelVisualStudio2010Theme represents a VS.NET 2010 style theme. More...

Inheritance diagram for CXTPTaskPanelVisualStudio2010Theme:
[legend]

Public Member Functions

CXTPTaskPanelVisualStudio2010Theme ()
Constructs a CXTPTaskPanelVisualStudio2010Theme object.
~CXTPTaskPanelVisualStudio2010Theme ()
Destroys a CXTPTaskPanelVisualStudio2010Theme object, handles cleanup and deallocation.
CRect | DrawGroupCaptionBackground (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Draws the group caption background of a specified group.
void | DrawGroupClientFace (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Draws the client face of a specified group.
void | FillGroupClientFace (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Fills the client face of a specified group.
void | FillTaskPanel (CDC *pDC, CXTPTaskPanel *pTaskPanel)
Fills the background of a specified task panel.
void | RefreshMetrics ()
Refreshes the visual metrics of the task panel.
- Public Member Functions inherited from CXTPTaskPanelVisualStudio2005Theme
CXTPTaskPanelVisualStudio2005Theme ()
Constructs a CXTPTaskPanelVisualStudio2005Theme object.
- Public Member Functions inherited from CXTPTaskPanelToolboxTheme
CXTPTaskPanelToolboxTheme ()
Constructs a CXTPTaskPanelToolboxTheme object.
int | DrawGroupCaption (CDC *pDC, CXTPTaskPanelGroup *pGroup, BOOL bDraw)
Draws the caption of a specified group.
- Public Member Functions inherited from CXTPTaskPanelPaintManagerPlain
CXTPTaskPanelPaintManagerPlain ()
Constructs a CXTPTaskPanelPaintManagerPlain object.
- Public Member Functions inherited from CXTPTaskPanelPaintManager
CXTPTaskPanelPaintManager ()
Constructs a CXTPTaskPanelPaintManager object.
virtual | ~CXTPTaskPanelPaintManager ()
Destroys a CXTPTaskPanelPaintManager object, handles cleanup and deallocation.
virtual void | DrawGroupClient (CDC *pDC, CXTPTaskPanelGroup *pGroup)
Draws a specified group.
virtual CRect | DrawGroupItem (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw)
Draws a specified group item.
XTP_TASKPANEL_GROUPCOLORS * | GetGroupColors (BOOL bSpecial)
Retrieves a specified group color set.
virtual XTP_TASKPANEL_GROUPCOLORS * | GetGroupColors (CXTPTaskPanelGroup *pGroup)
Retrieves a specified group color set.
virtual void | DrawGroupItemFrame (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc)
Draws a rectangle around a group item when it is selected, pressed or highlighted.
virtual CRect | GetItemOuterMargins (const CXTPTaskPanelGroupItem *pItem)
Retrieves the outer margins of a specified group item.
virtual CRect | GetItemInnerMargins (const CXTPTaskPanelGroupItem *pItem)
Retrieves the inner margins of a specified group item.
virtual CRect | GetGroupOuterMargins (const CXTPTaskPanelGroup *pGroup)
Retrieves the outer margins of a specified group.
virtual CRect | GetItemIconPadding (const CXTPTaskPanelItem *pItem)
Retrieves the icon padding of a specified item.
virtual CRect | GetGroupInnerMargins (const CXTPTaskPanelGroup *pGroup)
Retrieves the inner margins of a specified group.
virtual CRect | GetControlMargins (const CXTPTaskPanel *pPanel)
Gets the default margins used for all groups within a specified Task Panel control.
virtual int | GetGroupSpacing (const CXTPTaskPanel *pPanel)
Gets the spacing used between groups within a specified Task Panel control.
virtual void | DrawScrollButton (CDC *pDC, CXTPTaskPanelScrollButton *pScrollButton)
Draws a group scroll button.
void | SetTextFormat (int nTextFormat, BOOL bCaption=FALSE)
Sets the text format for captions/items.
void | SetItemsFontIndirect (LOGFONT *pLogFont, BOOL bUseStandardItemsFont=FALSE)
Sets the text font for items.
void | SetCaptionFontIndirect (LOGFONT *pLogFont, BOOL bUseStandardCaptionFont=FALSE)
Sets the text font for captions.
virtual CFont * | GetItemFont (CXTPTaskPanelItem *pItem)
Retrieves the text font of a specified item.

Additional Inherited Members

- Public Attributes inherited from CXTPTaskPanelPaintManager
BOOL | m_bEmulateEplorerTheme
TRUE to use Explorer theme under WinXP and Office 2000 under older OS.
XTPTaskPanelGripper | m_eGripper
Gripper of the manager.
BOOL | m_bBoldCaption
TRUE to display caption text in bold font, FALSE to display caption text in normal type.
CRect | m_rcGroupOuterMargins
Outer margins of the group.
CRect | m_rcGroupInnerMargins
Inner margins of the group.
CRect | m_rcItemOuterMargins
Outer margins of the group items.
CRect | m_rcItemInnerMargins
Inner margins of the group items.
CRect | m_rcControlMargins
Default margins for all groups.
int | m_nGroupSpacing
Amount of space placed between groups in the task panel.
CRect | m_rcImageLayoutIconPadding
Padding around images for xtpTaskItemLayoutImages layout.
CRect | m_rcItemIconPadding
Padding around images for items.
CRect | m_rcGroupIconPadding
Padding around images for groups.
BOOL | m_bOfficeHighlight
TRUE to highlight group items and scroll buttons using the Office XP style (XPCOLOR_HIGHLIGHT, XPCOLOR_HIGHLIGHT_CHECKED, XPCOLOR_HIGHLIGHT_PUSHED).
BOOL | m_bInvertDragRect
Only used when the theme is set to xtpTaskPanelThemeVisualStudio2003.
BOOL | m_bCaptionScrollButton
TRUE if the group caption scroll button is visible, FALSE if the group caption scroll button is hidden.
BOOL | m_bEmbossedDisabledText
TRUE to draw disabled text embossed.
- Static Public Attributes inherited from CXTPTaskPanelPaintManager
static const CRect | rectDefault
System selected default margins.
- Protected Member Functions inherited from CXTPTaskPanelVisualStudio2005Theme
- Protected Member Functions inherited from CXTPTaskPanelToolboxTheme
- Protected Member Functions inherited from CXTPTaskPanelPaintManager
CRect | DrawGroupItemImageWithText (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw)
Draws the icon of a specified group item.
CRect | DrawGroupItemImageWithTextBelow (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw)
Draws the icon of a specified group item.
CRect | DrawGroupItemImage (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw)
Draws the icon of a specified group item.
virtual void | DrawGroupClientItems (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Draws the items of a specified group.
virtual CRect | DrawCaptionGripper (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Draws the caption gripper of a specified group.
virtual int | GetCaptionGripperWidth (CXTPTaskPanelGroup *pGroup, CRect rc)
Retrieves the width of the caption gripper of a specified group.
virtual void | DrawItemCaption (CDC *pDC, CXTPTaskPanelItem *pItem, CRect rcText, UINT nFormat)
Draws the text caption of a specified item.
virtual void | DrawItemImage (CDC *pDC, CXTPTaskPanelItem *pItem, CPoint ptIcon, CXTPImageManagerIcon *pImage, CSize szIcon)
Draws the icon of a specified item.
COLORREF | BlendColor (COLORREF clrFrom, COLORREF clrTo, int nAlpha)
Blends one color to another color by a specified amount.
CRect | DrawCaptionGripperBitmap (CDC *pDC, CXTPTaskPanelGroup *pGroup, BOOL bExpanded, BOOL bHot, CRect rc)
Draws the caption gripper bitmap.
void | DrawCaptionGripperSigns (CDC *pDC, CPoint pt, COLORREF clr, BOOL bExpanded)
Draws the ">>" and "<<" signs of the caption gripper when the theme of the Task Panel is set to Office 2000.
void | CreateGripperBitmaps ()
Loads the gripper bitmap when the theme of the Task Panel is set to either Windows XP or Classic Windows XP.
void | CreateGripperIcon (HICON &hIcon, UINT nIDResource, COLORREF clrGripperBack)
Creates the gripper bitmap icons when the theme of the Task Panel is set to either Windows XP or Classic Windows XP and either the operating system is not Windows XP or the operating system is Windows XP and Luna themes are used.
void | FreeBitmaps ()
Frees the memory used by the group caption bitmaps.
void | Rectangle (CDC *pDC, CRect rc, COLORREF clrPen, COLORREF clrBrush)
This method is only used when drawing hot, pressed, and selected group items and scroll buttons when m_bOfficeHighlight is TRUE.
virtual CPoint | GetHighlightOffset (CXTPTaskPanelGroupItem *pItem)
Retrieves the highlight offset of the text of a specified group item.
virtual void | DrawDragArrow (CDC *pDC, CXTPTaskPanelItem *pItem, CRect rc, BOOL bAfter=FALSE)
Draws the "drag arrow" of a specified item.
virtual void | DrawFocusRect (CDC *pDC, CRect rc)
Draws a rectangle around the focused item.
- Protected Attributes inherited from CXTPTaskPanelPaintManagerPlain
BOOL | m_bRoundedFrame
TRUE to draw a rounded frame around all of the groups in the task panel.
BOOL | m_bOfficeCaption
FALSE to draw a rounded rectangle around caption.
- Protected Attributes inherited from CXTPTaskPanelPaintManager
BOOL | m_bUseBitmapGrippers
TRUE to use alpha grippers.
HICON | m_hGripperNormal
Icon of normal group header gripper.
HICON | m_hGripperSpecial
Icon of special group header gripper.
HBITMAP | m_bmpGrippers [8]
Bitmaps of alpha grippers.
CXTPFont | m_xtpFontCaption
Caption font.
CXTPFont | m_xtpFontIcon
Normal items font.
CXTPFont | m_xtpFontIconBold
Bold items font.
CXTPFont | m_xtpFontIconHot
"Hot" items font.
CXTPFont | m_xtpFontIconHotBold
Bold items font.
CXTPPaintManagerColorGradient | m_clrBackground
Background color of the Task Panel.
XTP_TASKPANEL_GROUPCOLORS | m_groupNormal
Normal colors set.
XTP_TASKPANEL_GROUPCOLORS | m_groupSpecial
Special colors set.
CXTPPaintManagerColor | m_clrHighlightHot
Color of items when they are "hot." This is the color of the item on mouseover if hot tracking is enabled.
CXTPPaintManagerColor m_clrHighlightSelected
Color of items when they are selected.
CXTPPaintManagerColor m_clrHighlightPressed
Color of items when they are pressed.
CXTPPaintManagerColorGradient | m_clrHighlightBorder
Border color of items when they are "hot." This is the border color of the item on mouse over if hot tracking is enabled.
BOOL | m_bOfficeBorder
TRUE to use Office borders.
BOOL | m_bLeftRoundedCorner
TRUE to round left corner of the group caption.
BOOL | m_bRightRoundedCorner
TRUE to round right corner of the group caption.
int | m_nCaptionHeight
Caption height, in pixels.
BOOL | m_bUseStandardCaptionFont
TRUE to use system font for group caption text.
BOOL | m_bUseStandardItemsFont
TRUE to use system font for item caption text.
int | m_nItemTextFormat
Format flags of item text.
int | m_nCaptionTextFormat
Format flags of caption text.

Detailed Description

CXTPTaskPanelVisualStudio2010Theme represents a VS.NET 2010 style theme.

See also
CXTPTaskPanel::SetTheme

Member Function Documentation

◆ DrawGroupCaptionBackground()

CRect DrawGroupCaptionBackground | ( | CDC * | pDC,
 |  | CXTPTaskPanelGroup * | pGroup,
 |  | CRect | rc )
 virtual

Draws the group caption background of a specified group.

Parameters
pDC | Pointer to a valid device context.
pGroup | Pointer to the group to draw the group caption background of.
rc | Bounding rectangle of the group caption.
Returns
The bounding rectangle of the text within the group caption.

Reimplemented from CXTPTaskPanelVisualStudio2005Theme.

◆ DrawGroupClientFace()

void DrawGroupClientFace | ( | CDC * | pDC,
 |  | CXTPTaskPanelGroup * | pGroup,
 |  | CRect | rc )
 virtual

Draws the client face of a specified group.

Parameters
pDC | Pointer to a valid device context.
pGroup | Pointer to the group to draw the client face of.
rc | Rectangle of the group to draw the client face of.

Reimplemented from CXTPTaskPanelVisualStudio2005Theme.

◆ FillGroupClientFace()

void FillGroupClientFace | ( | CDC * | pDC,
 |  | CXTPTaskPanelGroup * | pGroup,
 |  | CRect | rc )
 virtual

Fills the client face of a specified group.

Parameters
pDC | Pointer to a valid device context.
pGroup | Pointer to the group to fill the client face of.
rc | Rectangle of the group to fill the client face of.
See also
DrawGroupClientFace

Reimplemented from CXTPTaskPanelVisualStudio2005Theme.

◆ FillTaskPanel()

void FillTaskPanel | ( | CDC * | pDC,
 |  | CXTPTaskPanel * | pTaskPanel )
 virtual

Fills the background of a specified task panel.

Parameters
pDC | Pointer to a valid device context.
pTaskPanel | Pointer to the task panel to fill.

Reimplemented from CXTPTaskPanelVisualStudio2005Theme.

The documentation for this class was generated from the following file:
  • XTPTaskPanelVisualStudio2010Theme.h


Toolkit Pro: CXTPTaskPanelVisualStudio2012Theme Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPTaskPanelVisualStudio2012Theme Class Reference

CXTPTaskPanelVisualStudio2012Theme represents a VS.NET 2012 style theme. More...

Inheritance diagram for CXTPTaskPanelVisualStudio2012Theme:
[legend]

Public Member Functions

CXTPTaskPanelVisualStudio2012Theme (BOOL bLight=TRUE)
Constructs a CXTPTaskPanelVisualStudio2012Theme object.
virtual | ~CXTPTaskPanelVisualStudio2012Theme ()
Destroys a CXTPTaskPanelVisualStudio2012Theme object, handles cleanup and deallocation.
CRect | DrawGroupCaptionBackground (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Draws the group caption background of a specified group.
void | DrawGroupClientFace (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Draws the client face of a specified group.
virtual void | DrawGroupItemFrame (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc)
Draws a rectangle around a group item when it is selected, pressed or highlighted.
void | FillGroupClientFace (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Fills the client face of a specified group.
void | FillTaskPanel (CDC *pDC, CXTPTaskPanel *pTaskPanel)
Fills the background of a specified task panel.
virtual void | DrawItemCaption (CDC *pDC, CXTPTaskPanelItem *pItem, CRect rcText, UINT nFormat)
Draws the text caption of a specified item.
virtual void | RefreshMetrics ()
Refreshes the visual metrics of the task panel.
- Public Member Functions inherited from CXTPTaskPanelVisualStudio2005Theme
CXTPTaskPanelVisualStudio2005Theme ()
Constructs a CXTPTaskPanelVisualStudio2005Theme object.
- Public Member Functions inherited from CXTPTaskPanelToolboxTheme
CXTPTaskPanelToolboxTheme ()
Constructs a CXTPTaskPanelToolboxTheme object.
int | DrawGroupCaption (CDC *pDC, CXTPTaskPanelGroup *pGroup, BOOL bDraw)
Draws the caption of a specified group.
- Public Member Functions inherited from CXTPTaskPanelPaintManagerPlain
CXTPTaskPanelPaintManagerPlain ()
Constructs a CXTPTaskPanelPaintManagerPlain object.
- Public Member Functions inherited from CXTPTaskPanelPaintManager
CXTPTaskPanelPaintManager ()
Constructs a CXTPTaskPanelPaintManager object.
virtual | ~CXTPTaskPanelPaintManager ()
Destroys a CXTPTaskPanelPaintManager object, handles cleanup and deallocation.
virtual void | DrawGroupClient (CDC *pDC, CXTPTaskPanelGroup *pGroup)
Draws a specified group.
virtual CRect | DrawGroupItem (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw)
Draws a specified group item.
XTP_TASKPANEL_GROUPCOLORS * | GetGroupColors (BOOL bSpecial)
Retrieves a specified group color set.
virtual XTP_TASKPANEL_GROUPCOLORS * | GetGroupColors (CXTPTaskPanelGroup *pGroup)
Retrieves a specified group color set.
virtual CRect | GetItemOuterMargins (const CXTPTaskPanelGroupItem *pItem)
Retrieves the outer margins of a specified group item.
virtual CRect | GetItemInnerMargins (const CXTPTaskPanelGroupItem *pItem)
Retrieves the inner margins of a specified group item.
virtual CRect | GetGroupOuterMargins (const CXTPTaskPanelGroup *pGroup)
Retrieves the outer margins of a specified group.
virtual CRect | GetItemIconPadding (const CXTPTaskPanelItem *pItem)
Retrieves the icon padding of a specified item.
virtual CRect | GetGroupInnerMargins (const CXTPTaskPanelGroup *pGroup)
Retrieves the inner margins of a specified group.
virtual CRect | GetControlMargins (const CXTPTaskPanel *pPanel)
Gets the default margins used for all groups within a specified Task Panel control.
virtual int | GetGroupSpacing (const CXTPTaskPanel *pPanel)
Gets the spacing used between groups within a specified Task Panel control.
virtual void | DrawScrollButton (CDC *pDC, CXTPTaskPanelScrollButton *pScrollButton)
Draws a group scroll button.
void | SetTextFormat (int nTextFormat, BOOL bCaption=FALSE)
Sets the text format for captions/items.
void | SetItemsFontIndirect (LOGFONT *pLogFont, BOOL bUseStandardItemsFont=FALSE)
Sets the text font for items.
void | SetCaptionFontIndirect (LOGFONT *pLogFont, BOOL bUseStandardCaptionFont=FALSE)
Sets the text font for captions.
virtual CFont * | GetItemFont (CXTPTaskPanelItem *pItem)
Retrieves the text font of a specified item.

Protected Attributes

CXTPPaintManagerColor | m_clrSelectedWithoutFocus
Color of the selected item when the Task Panel does not have focus.
CXTPPaintManagerColor | m_clrText
Normal text color.
CXTPPaintManagerColor | m_clrSelectedText
Text color of the selected item.
CXTPPaintManagerColor | m_clrSelectedTextWithoutFocus
Text color of the selected item when the Task Panel does not have focus.
- Protected Attributes inherited from CXTPTaskPanelPaintManagerPlain
BOOL | m_bRoundedFrame
TRUE to draw a rounded frame around all of the groups in the task panel.
BOOL | m_bOfficeCaption
FALSE to draw a rounded rectangle around caption.
- Protected Attributes inherited from CXTPTaskPanelPaintManager
BOOL | m_bUseBitmapGrippers
TRUE to use alpha grippers.
HICON | m_hGripperNormal
Icon of normal group header gripper.
HICON | m_hGripperSpecial
Icon of special group header gripper.
HBITMAP | m_bmpGrippers [8]
Bitmaps of alpha grippers.
CXTPFont | m_xtpFontCaption
Caption font.
CXTPFont | m_xtpFontIcon
Normal items font.
CXTPFont | m_xtpFontIconBold
Bold items font.
CXTPFont | m_xtpFontIconHot
"Hot" items font.
CXTPFont | m_xtpFontIconHotBold
Bold items font.
CXTPPaintManagerColorGradient | m_clrBackground
Background color of the Task Panel.
XTP_TASKPANEL_GROUPCOLORS | m_groupNormal
Normal colors set.
XTP_TASKPANEL_GROUPCOLORS | m_groupSpecial
Special colors set.
CXTPPaintManagerColor | m_clrHighlightHot
Color of items when they are "hot." This is the color of the item on mouseover if hot tracking is enabled.
CXTPPaintManagerColor m_clrHighlightSelected
Color of items when they are selected.
CXTPPaintManagerColor m_clrHighlightPressed
Color of items when they are pressed.
CXTPPaintManagerColorGradient | m_clrHighlightBorder
Border color of items when they are "hot." This is the border color of the item on mouse over if hot tracking is enabled.
BOOL | m_bOfficeBorder
TRUE to use Office borders.
BOOL | m_bLeftRoundedCorner
TRUE to round left corner of the group caption.
BOOL | m_bRightRoundedCorner
TRUE to round right corner of the group caption.
int | m_nCaptionHeight
Caption height, in pixels.
BOOL | m_bUseStandardCaptionFont
TRUE to use system font for group caption text.
BOOL | m_bUseStandardItemsFont
TRUE to use system font for item caption text.
int | m_nItemTextFormat
Format flags of item text.
int | m_nCaptionTextFormat
Format flags of caption text.

Additional Inherited Members

- Public Attributes inherited from CXTPTaskPanelPaintManager
BOOL | m_bEmulateEplorerTheme
TRUE to use Explorer theme under WinXP and Office 2000 under older OS.
XTPTaskPanelGripper | m_eGripper
Gripper of the manager.
BOOL | m_bBoldCaption
TRUE to display caption text in bold font, FALSE to display caption text in normal type.
CRect | m_rcGroupOuterMargins
Outer margins of the group.
CRect | m_rcGroupInnerMargins
Inner margins of the group.
CRect | m_rcItemOuterMargins
Outer margins of the group items.
CRect | m_rcItemInnerMargins
Inner margins of the group items.
CRect | m_rcControlMargins
Default margins for all groups.
int | m_nGroupSpacing
Amount of space placed between groups in the task panel.
CRect | m_rcImageLayoutIconPadding
Padding around images for xtpTaskItemLayoutImages layout.
CRect | m_rcItemIconPadding
Padding around images for items.
CRect | m_rcGroupIconPadding
Padding around images for groups.
BOOL | m_bOfficeHighlight
TRUE to highlight group items and scroll buttons using the Office XP style (XPCOLOR_HIGHLIGHT, XPCOLOR_HIGHLIGHT_CHECKED, XPCOLOR_HIGHLIGHT_PUSHED).
BOOL | m_bInvertDragRect
Only used when the theme is set to xtpTaskPanelThemeVisualStudio2003.
BOOL | m_bCaptionScrollButton
TRUE if the group caption scroll button is visible, FALSE if the group caption scroll button is hidden.
BOOL | m_bEmbossedDisabledText
TRUE to draw disabled text embossed.
- Static Public Attributes inherited from CXTPTaskPanelPaintManager
static const CRect | rectDefault
System selected default margins.
- Protected Member Functions inherited from CXTPTaskPanelVisualStudio2005Theme
- Protected Member Functions inherited from CXTPTaskPanelToolboxTheme
- Protected Member Functions inherited from CXTPTaskPanelPaintManager
CRect | DrawGroupItemImageWithText (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw)
Draws the icon of a specified group item.
CRect | DrawGroupItemImageWithTextBelow (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw)
Draws the icon of a specified group item.
CRect | DrawGroupItemImage (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw)
Draws the icon of a specified group item.
virtual void | DrawGroupClientItems (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Draws the items of a specified group.
virtual CRect | DrawCaptionGripper (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Draws the caption gripper of a specified group.
virtual int | GetCaptionGripperWidth (CXTPTaskPanelGroup *pGroup, CRect rc)
Retrieves the width of the caption gripper of a specified group.
virtual void | DrawItemImage (CDC *pDC, CXTPTaskPanelItem *pItem, CPoint ptIcon, CXTPImageManagerIcon *pImage, CSize szIcon)
Draws the icon of a specified item.
COLORREF | BlendColor (COLORREF clrFrom, COLORREF clrTo, int nAlpha)
Blends one color to another color by a specified amount.
CRect | DrawCaptionGripperBitmap (CDC *pDC, CXTPTaskPanelGroup *pGroup, BOOL bExpanded, BOOL bHot, CRect rc)
Draws the caption gripper bitmap.
void | DrawCaptionGripperSigns (CDC *pDC, CPoint pt, COLORREF clr, BOOL bExpanded)
Draws the ">>" and "<<" signs of the caption gripper when the theme of the Task Panel is set to Office 2000.
void | CreateGripperBitmaps ()
Loads the gripper bitmap when the theme of the Task Panel is set to either Windows XP or Classic Windows XP.
void | CreateGripperIcon (HICON &hIcon, UINT nIDResource, COLORREF clrGripperBack)
Creates the gripper bitmap icons when the theme of the Task Panel is set to either Windows XP or Classic Windows XP and either the operating system is not Windows XP or the operating system is Windows XP and Luna themes are used.
void | FreeBitmaps ()
Frees the memory used by the group caption bitmaps.
void | Rectangle (CDC *pDC, CRect rc, COLORREF clrPen, COLORREF clrBrush)
This method is only used when drawing hot, pressed, and selected group items and scroll buttons when m_bOfficeHighlight is TRUE.
virtual CPoint | GetHighlightOffset (CXTPTaskPanelGroupItem *pItem)
Retrieves the highlight offset of the text of a specified group item.
virtual void | DrawDragArrow (CDC *pDC, CXTPTaskPanelItem *pItem, CRect rc, BOOL bAfter=FALSE)
Draws the "drag arrow" of a specified item.
virtual void | DrawFocusRect (CDC *pDC, CRect rc)
Draws a rectangle around the focused item.

Detailed Description

CXTPTaskPanelVisualStudio2012Theme represents a VS.NET 2012 style theme.

See also
CXTPTaskPanel::SetTheme

Constructor & Destructor Documentation

◆ CXTPTaskPanelVisualStudio2012Theme()

CXTPTaskPanelVisualStudio2012Theme ( BOOL bLight = TRUE )

Constructs a CXTPTaskPanelVisualStudio2012Theme object.

Parameters
bLight TRUE to draw light theme, FALSE otherwise.

Member Function Documentation

◆ DrawGroupCaptionBackground()

CRect DrawGroupCaptionBackground | ( | CDC * | pDC,
 |  | CXTPTaskPanelGroup * | pGroup,
 |  | CRect | rc )
 virtual

Draws the group caption background of a specified group.

Parameters
pDC | Pointer to a valid device context.
pGroup | Pointer to the group to draw the group caption background of.
rc | Bounding rectangle of the group caption.
Returns
The bounding rectangle of the text within the group caption.

Reimplemented from CXTPTaskPanelVisualStudio2005Theme.

◆ DrawGroupClientFace()

void DrawGroupClientFace | ( | CDC * | pDC,
 |  | CXTPTaskPanelGroup * | pGroup,
 |  | CRect | rc )
 virtual

Draws the client face of a specified group.

Parameters
pDC | Pointer to a valid device context.
pGroup | Pointer to the group to draw the client face of.
rc | Rectangle of the group to draw the client face of.

Reimplemented from CXTPTaskPanelVisualStudio2005Theme.

◆ DrawGroupItemFrame()

virtual void DrawGroupItemFrame | ( | CDC * | pDC,
 |  | CXTPTaskPanelGroupItem * | pItem,
 |  | CRect | rc )
 virtual

Draws a rectangle around a group item when it is selected, pressed or highlighted.

Parameters
pDC | Pointer to a valid device context.
pItem | Pointer to the group item.
rc | Rectangle to be drawn.

Reimplemented from CXTPTaskPanelPaintManager.

◆ DrawItemCaption()

virtual void DrawItemCaption | ( | CDC * | pDC,
 |  | CXTPTaskPanelItem * | pItem,
 |  | CRect | rcText,
 |  | UINT | nFormat )
 virtual

Draws the text caption of a specified item.

Parameters
pDC | Pointer to a valid device context.
pItem | Pointer to the item to draw the text caption of.
rcText | Rectangle of the item to draw the text caption of.
nFormat | Specifies the method of formatting the text.

DrawGroupCaption uses this method to draw the group caption with nFormat = DT_SINGLELINE | DT_LEFT | DT_END_ELLIPSIS | DT_VCENTER | DT_NOPREFIX

DrawGroupItemImageWithText and DrawGroupItemImageWithTextBelow both use this method to draw the group item caption.

Reimplemented from CXTPTaskPanelPaintManager.

◆ FillGroupClientFace()

void FillGroupClientFace | ( | CDC * | pDC,
 |  | CXTPTaskPanelGroup * | pGroup,
 |  | CRect | rc )
 virtual

Fills the client face of a specified group.

Parameters
pDC | Pointer to a valid device context.
pGroup | Pointer to the group to fill the client face of.
rc | Rectangle of the group to fill the client face of.
See also
DrawGroupClientFace

Reimplemented from CXTPTaskPanelVisualStudio2005Theme.

◆ FillTaskPanel()

void FillTaskPanel | ( | CDC * | pDC,
 |  | CXTPTaskPanel * | pTaskPanel )
 virtual

Fills the background of a specified task panel.

Parameters
pDC | Pointer to a valid device context.
pTaskPanel | Pointer to the task panel to fill.

Reimplemented from CXTPTaskPanelVisualStudio2005Theme.

The documentation for this class was generated from the following file:
  • XTPTaskPanelVisualStudio2012Theme.h


Toolkit Pro: CXTPTaskPanelVisualStudio2015Theme Class Reference

Public Member Functions | List of all members
CXTPTaskPanelVisualStudio2015Theme Class Reference

CXTPTaskPanelVisualStudio2015Theme represents a Visutal Studio 2015 style theme. More...

Inheritance diagram for CXTPTaskPanelVisualStudio2015Theme:
[legend]

Public Member Functions

CXTPTaskPanelVisualStudio2015Theme ()
Constructs a CXTPTaskPanelVisualStudio2015Theme object.
virtual | ~CXTPTaskPanelVisualStudio2015Theme ()
Destroys a CXTPTaskPanelVisualStudio2015Theme object, handles cleanup and deallocation.
virtual void | RefreshMetrics ()
Refreshes the visual metrics of the task panel.
- Public Member Functions inherited from CXTPTaskPanelVisualStudio2012Theme
CXTPTaskPanelVisualStudio2012Theme (BOOL bLight=TRUE)
Constructs a CXTPTaskPanelVisualStudio2012Theme object.
virtual | ~CXTPTaskPanelVisualStudio2012Theme ()
Destroys a CXTPTaskPanelVisualStudio2012Theme object, handles cleanup and deallocation.
CRect | DrawGroupCaptionBackground (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Draws the group caption background of a specified group.
void | DrawGroupClientFace (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Draws the client face of a specified group.
virtual void | DrawGroupItemFrame (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc)
Draws a rectangle around a group item when it is selected, pressed or highlighted.
void | FillGroupClientFace (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Fills the client face of a specified group.
void | FillTaskPanel (CDC *pDC, CXTPTaskPanel *pTaskPanel)
Fills the background of a specified task panel.
virtual void | DrawItemCaption (CDC *pDC, CXTPTaskPanelItem *pItem, CRect rcText, UINT nFormat)
Draws the text caption of a specified item.
- Public Member Functions inherited from CXTPTaskPanelVisualStudio2005Theme
CXTPTaskPanelVisualStudio2005Theme ()
Constructs a CXTPTaskPanelVisualStudio2005Theme object.
- Public Member Functions inherited from CXTPTaskPanelToolboxTheme
CXTPTaskPanelToolboxTheme ()
Constructs a CXTPTaskPanelToolboxTheme object.
int | DrawGroupCaption (CDC *pDC, CXTPTaskPanelGroup *pGroup, BOOL bDraw)
Draws the caption of a specified group.
- Public Member Functions inherited from CXTPTaskPanelPaintManagerPlain
CXTPTaskPanelPaintManagerPlain ()
Constructs a CXTPTaskPanelPaintManagerPlain object.
- Public Member Functions inherited from CXTPTaskPanelPaintManager
CXTPTaskPanelPaintManager ()
Constructs a CXTPTaskPanelPaintManager object.
virtual | ~CXTPTaskPanelPaintManager ()
Destroys a CXTPTaskPanelPaintManager object, handles cleanup and deallocation.
virtual void | DrawGroupClient (CDC *pDC, CXTPTaskPanelGroup *pGroup)
Draws a specified group.
virtual CRect | DrawGroupItem (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw)
Draws a specified group item.
XTP_TASKPANEL_GROUPCOLORS * | GetGroupColors (BOOL bSpecial)
Retrieves a specified group color set.
virtual XTP_TASKPANEL_GROUPCOLORS * | GetGroupColors (CXTPTaskPanelGroup *pGroup)
Retrieves a specified group color set.
virtual CRect | GetItemOuterMargins (const CXTPTaskPanelGroupItem *pItem)
Retrieves the outer margins of a specified group item.
virtual CRect | GetItemInnerMargins (const CXTPTaskPanelGroupItem *pItem)
Retrieves the inner margins of a specified group item.
virtual CRect | GetGroupOuterMargins (const CXTPTaskPanelGroup *pGroup)
Retrieves the outer margins of a specified group.
virtual CRect | GetItemIconPadding (const CXTPTaskPanelItem *pItem)
Retrieves the icon padding of a specified item.
virtual CRect | GetGroupInnerMargins (const CXTPTaskPanelGroup *pGroup)
Retrieves the inner margins of a specified group.
virtual CRect | GetControlMargins (const CXTPTaskPanel *pPanel)
Gets the default margins used for all groups within a specified Task Panel control.
virtual int | GetGroupSpacing (const CXTPTaskPanel *pPanel)
Gets the spacing used between groups within a specified Task Panel control.
virtual void | DrawScrollButton (CDC *pDC, CXTPTaskPanelScrollButton *pScrollButton)
Draws a group scroll button.
void | SetTextFormat (int nTextFormat, BOOL bCaption=FALSE)
Sets the text format for captions/items.
void | SetItemsFontIndirect (LOGFONT *pLogFont, BOOL bUseStandardItemsFont=FALSE)
Sets the text font for items.
void | SetCaptionFontIndirect (LOGFONT *pLogFont, BOOL bUseStandardCaptionFont=FALSE)
Sets the text font for captions.
virtual CFont * | GetItemFont (CXTPTaskPanelItem *pItem)
Retrieves the text font of a specified item.

Additional Inherited Members

- Public Attributes inherited from CXTPTaskPanelPaintManager
BOOL | m_bEmulateEplorerTheme
TRUE to use Explorer theme under WinXP and Office 2000 under older OS.
XTPTaskPanelGripper | m_eGripper
Gripper of the manager.
BOOL | m_bBoldCaption
TRUE to display caption text in bold font, FALSE to display caption text in normal type.
CRect | m_rcGroupOuterMargins
Outer margins of the group.
CRect | m_rcGroupInnerMargins
Inner margins of the group.
CRect | m_rcItemOuterMargins
Outer margins of the group items.
CRect | m_rcItemInnerMargins
Inner margins of the group items.
CRect | m_rcControlMargins
Default margins for all groups.
int | m_nGroupSpacing
Amount of space placed between groups in the task panel.
CRect | m_rcImageLayoutIconPadding
Padding around images for xtpTaskItemLayoutImages layout.
CRect | m_rcItemIconPadding
Padding around images for items.
CRect | m_rcGroupIconPadding
Padding around images for groups.
BOOL | m_bOfficeHighlight
TRUE to highlight group items and scroll buttons using the Office XP style (XPCOLOR_HIGHLIGHT, XPCOLOR_HIGHLIGHT_CHECKED, XPCOLOR_HIGHLIGHT_PUSHED).
BOOL | m_bInvertDragRect
Only used when the theme is set to xtpTaskPanelThemeVisualStudio2003.
BOOL | m_bCaptionScrollButton
TRUE if the group caption scroll button is visible, FALSE if the group caption scroll button is hidden.
BOOL | m_bEmbossedDisabledText
TRUE to draw disabled text embossed.
- Static Public Attributes inherited from CXTPTaskPanelPaintManager
static const CRect | rectDefault
System selected default margins.
- Protected Member Functions inherited from CXTPTaskPanelVisualStudio2012Theme
- Protected Member Functions inherited from CXTPTaskPanelVisualStudio2005Theme
- Protected Member Functions inherited from CXTPTaskPanelToolboxTheme
- Protected Member Functions inherited from CXTPTaskPanelPaintManager
CRect | DrawGroupItemImageWithText (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw)
Draws the icon of a specified group item.
CRect | DrawGroupItemImageWithTextBelow (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw)
Draws the icon of a specified group item.
CRect | DrawGroupItemImage (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw)
Draws the icon of a specified group item.
virtual void | DrawGroupClientItems (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Draws the items of a specified group.
virtual CRect | DrawCaptionGripper (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Draws the caption gripper of a specified group.
virtual int | GetCaptionGripperWidth (CXTPTaskPanelGroup *pGroup, CRect rc)
Retrieves the width of the caption gripper of a specified group.
virtual void | DrawItemImage (CDC *pDC, CXTPTaskPanelItem *pItem, CPoint ptIcon, CXTPImageManagerIcon *pImage, CSize szIcon)
Draws the icon of a specified item.
COLORREF | BlendColor (COLORREF clrFrom, COLORREF clrTo, int nAlpha)
Blends one color to another color by a specified amount.
CRect | DrawCaptionGripperBitmap (CDC *pDC, CXTPTaskPanelGroup *pGroup, BOOL bExpanded, BOOL bHot, CRect rc)
Draws the caption gripper bitmap.
void | DrawCaptionGripperSigns (CDC *pDC, CPoint pt, COLORREF clr, BOOL bExpanded)
Draws the ">>" and "<<" signs of the caption gripper when the theme of the Task Panel is set to Office 2000.
void | CreateGripperBitmaps ()
Loads the gripper bitmap when the theme of the Task Panel is set to either Windows XP or Classic Windows XP.
void | CreateGripperIcon (HICON &hIcon, UINT nIDResource, COLORREF clrGripperBack)
Creates the gripper bitmap icons when the theme of the Task Panel is set to either Windows XP or Classic Windows XP and either the operating system is not Windows XP or the operating system is Windows XP and Luna themes are used.
void | FreeBitmaps ()
Frees the memory used by the group caption bitmaps.
void | Rectangle (CDC *pDC, CRect rc, COLORREF clrPen, COLORREF clrBrush)
This method is only used when drawing hot, pressed, and selected group items and scroll buttons when m_bOfficeHighlight is TRUE.
virtual CPoint | GetHighlightOffset (CXTPTaskPanelGroupItem *pItem)
Retrieves the highlight offset of the text of a specified group item.
virtual void | DrawDragArrow (CDC *pDC, CXTPTaskPanelItem *pItem, CRect rc, BOOL bAfter=FALSE)
Draws the "drag arrow" of a specified item.
virtual void | DrawFocusRect (CDC *pDC, CRect rc)
Draws a rectangle around the focused item.
- Protected Attributes inherited from CXTPTaskPanelVisualStudio2012Theme
CXTPPaintManagerColor | m_clrSelectedWithoutFocus
Color of the selected item when the Task Panel does not have focus.
CXTPPaintManagerColor | m_clrText
Normal text color.
CXTPPaintManagerColor | m_clrSelectedText
Text color of the selected item.
CXTPPaintManagerColor | m_clrSelectedTextWithoutFocus
Text color of the selected item when the Task Panel does not have focus.
- Protected Attributes inherited from CXTPTaskPanelPaintManagerPlain
BOOL | m_bRoundedFrame
TRUE to draw a rounded frame around all of the groups in the task panel.
BOOL | m_bOfficeCaption
FALSE to draw a rounded rectangle around caption.
- Protected Attributes inherited from CXTPTaskPanelPaintManager
BOOL | m_bUseBitmapGrippers
TRUE to use alpha grippers.
HICON | m_hGripperNormal
Icon of normal group header gripper.
HICON | m_hGripperSpecial
Icon of special group header gripper.
HBITMAP | m_bmpGrippers [8]
Bitmaps of alpha grippers.
CXTPFont | m_xtpFontCaption
Caption font.
CXTPFont | m_xtpFontIcon
Normal items font.
CXTPFont | m_xtpFontIconBold
Bold items font.
CXTPFont | m_xtpFontIconHot
"Hot" items font.
CXTPFont | m_xtpFontIconHotBold
Bold items font.
CXTPPaintManagerColorGradient | m_clrBackground
Background color of the Task Panel.
XTP_TASKPANEL_GROUPCOLORS | m_groupNormal
Normal colors set.
XTP_TASKPANEL_GROUPCOLORS | m_groupSpecial
Special colors set.
CXTPPaintManagerColor | m_clrHighlightHot
Color of items when they are "hot." This is the color of the item on mouseover if hot tracking is enabled.
CXTPPaintManagerColor m_clrHighlightSelected
Color of items when they are selected.
CXTPPaintManagerColor m_clrHighlightPressed
Color of items when they are pressed.
CXTPPaintManagerColorGradient | m_clrHighlightBorder
Border color of items when they are "hot." This is the border color of the item on mouse over if hot tracking is enabled.
BOOL | m_bOfficeBorder
TRUE to use Office borders.
BOOL | m_bLeftRoundedCorner
TRUE to round left corner of the group caption.
BOOL | m_bRightRoundedCorner
TRUE to round right corner of the group caption.
int | m_nCaptionHeight
Caption height, in pixels.
BOOL | m_bUseStandardCaptionFont
TRUE to use system font for group caption text.
BOOL | m_bUseStandardItemsFont
TRUE to use system font for item caption text.
int | m_nItemTextFormat
Format flags of item text.
int | m_nCaptionTextFormat
Format flags of caption text.

Detailed Description

CXTPTaskPanelVisualStudio2015Theme represents a Visutal Studio 2015 style theme.

See also
CXTPTaskPanel::SetTheme
The documentation for this class was generated from the following file:
  • XTPTaskPanelVisualStudio2015Theme.h


Toolkit Pro: CXTPTaskPanelVisualStudio2017Theme Class Reference

Public Member Functions | List of all members
CXTPTaskPanelVisualStudio2017Theme Class Reference

CXTPTaskPanelVisualStudio2017Theme represents a Visutal Studio 2017 style theme. More...

Inheritance diagram for CXTPTaskPanelVisualStudio2017Theme:
[legend]

Public Member Functions

CXTPTaskPanelVisualStudio2017Theme ()
Constructs a CXTPTaskPanelVisualStudio2017Theme object.
virtual | ~CXTPTaskPanelVisualStudio2017Theme ()
Destroys a CXTPTaskPanelVisualStudio2017Theme object, handles cleanup and deallocation.
virtual void | RefreshMetrics ()
Refreshes the visual metrics of the task panel.
- Public Member Functions inherited from CXTPTaskPanelVisualStudio2012Theme
CXTPTaskPanelVisualStudio2012Theme (BOOL bLight=TRUE)
Constructs a CXTPTaskPanelVisualStudio2012Theme object.
virtual | ~CXTPTaskPanelVisualStudio2012Theme ()
Destroys a CXTPTaskPanelVisualStudio2012Theme object, handles cleanup and deallocation.
CRect | DrawGroupCaptionBackground (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Draws the group caption background of a specified group.
void | DrawGroupClientFace (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Draws the client face of a specified group.
virtual void | DrawGroupItemFrame (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc)
Draws a rectangle around a group item when it is selected, pressed or highlighted.
void | FillGroupClientFace (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Fills the client face of a specified group.
void | FillTaskPanel (CDC *pDC, CXTPTaskPanel *pTaskPanel)
Fills the background of a specified task panel.
virtual void | DrawItemCaption (CDC *pDC, CXTPTaskPanelItem *pItem, CRect rcText, UINT nFormat)
Draws the text caption of a specified item.
- Public Member Functions inherited from CXTPTaskPanelVisualStudio2005Theme
CXTPTaskPanelVisualStudio2005Theme ()
Constructs a CXTPTaskPanelVisualStudio2005Theme object.
- Public Member Functions inherited from CXTPTaskPanelToolboxTheme
CXTPTaskPanelToolboxTheme ()
Constructs a CXTPTaskPanelToolboxTheme object.
int | DrawGroupCaption (CDC *pDC, CXTPTaskPanelGroup *pGroup, BOOL bDraw)
Draws the caption of a specified group.
- Public Member Functions inherited from CXTPTaskPanelPaintManagerPlain
CXTPTaskPanelPaintManagerPlain ()
Constructs a CXTPTaskPanelPaintManagerPlain object.
- Public Member Functions inherited from CXTPTaskPanelPaintManager
CXTPTaskPanelPaintManager ()
Constructs a CXTPTaskPanelPaintManager object.
virtual | ~CXTPTaskPanelPaintManager ()
Destroys a CXTPTaskPanelPaintManager object, handles cleanup and deallocation.
virtual void | DrawGroupClient (CDC *pDC, CXTPTaskPanelGroup *pGroup)
Draws a specified group.
virtual CRect | DrawGroupItem (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw)
Draws a specified group item.
XTP_TASKPANEL_GROUPCOLORS * | GetGroupColors (BOOL bSpecial)
Retrieves a specified group color set.
virtual XTP_TASKPANEL_GROUPCOLORS * | GetGroupColors (CXTPTaskPanelGroup *pGroup)
Retrieves a specified group color set.
virtual CRect | GetItemOuterMargins (const CXTPTaskPanelGroupItem *pItem)
Retrieves the outer margins of a specified group item.
virtual CRect | GetItemInnerMargins (const CXTPTaskPanelGroupItem *pItem)
Retrieves the inner margins of a specified group item.
virtual CRect | GetGroupOuterMargins (const CXTPTaskPanelGroup *pGroup)
Retrieves the outer margins of a specified group.
virtual CRect | GetItemIconPadding (const CXTPTaskPanelItem *pItem)
Retrieves the icon padding of a specified item.
virtual CRect | GetGroupInnerMargins (const CXTPTaskPanelGroup *pGroup)
Retrieves the inner margins of a specified group.
virtual CRect | GetControlMargins (const CXTPTaskPanel *pPanel)
Gets the default margins used for all groups within a specified Task Panel control.
virtual int | GetGroupSpacing (const CXTPTaskPanel *pPanel)
Gets the spacing used between groups within a specified Task Panel control.
virtual void | DrawScrollButton (CDC *pDC, CXTPTaskPanelScrollButton *pScrollButton)
Draws a group scroll button.
void | SetTextFormat (int nTextFormat, BOOL bCaption=FALSE)
Sets the text format for captions/items.
void | SetItemsFontIndirect (LOGFONT *pLogFont, BOOL bUseStandardItemsFont=FALSE)
Sets the text font for items.
void | SetCaptionFontIndirect (LOGFONT *pLogFont, BOOL bUseStandardCaptionFont=FALSE)
Sets the text font for captions.
virtual CFont * | GetItemFont (CXTPTaskPanelItem *pItem)
Retrieves the text font of a specified item.

Additional Inherited Members

- Public Attributes inherited from CXTPTaskPanelPaintManager
BOOL | m_bEmulateEplorerTheme
TRUE to use Explorer theme under WinXP and Office 2000 under older OS.
XTPTaskPanelGripper | m_eGripper
Gripper of the manager.
BOOL | m_bBoldCaption
TRUE to display caption text in bold font, FALSE to display caption text in normal type.
CRect | m_rcGroupOuterMargins
Outer margins of the group.
CRect | m_rcGroupInnerMargins
Inner margins of the group.
CRect | m_rcItemOuterMargins
Outer margins of the group items.
CRect | m_rcItemInnerMargins
Inner margins of the group items.
CRect | m_rcControlMargins
Default margins for all groups.
int | m_nGroupSpacing
Amount of space placed between groups in the task panel.
CRect | m_rcImageLayoutIconPadding
Padding around images for xtpTaskItemLayoutImages layout.
CRect | m_rcItemIconPadding
Padding around images for items.
CRect | m_rcGroupIconPadding
Padding around images for groups.
BOOL | m_bOfficeHighlight
TRUE to highlight group items and scroll buttons using the Office XP style (XPCOLOR_HIGHLIGHT, XPCOLOR_HIGHLIGHT_CHECKED, XPCOLOR_HIGHLIGHT_PUSHED).
BOOL | m_bInvertDragRect
Only used when the theme is set to xtpTaskPanelThemeVisualStudio2003.
BOOL | m_bCaptionScrollButton
TRUE if the group caption scroll button is visible, FALSE if the group caption scroll button is hidden.
BOOL | m_bEmbossedDisabledText
TRUE to draw disabled text embossed.
- Static Public Attributes inherited from CXTPTaskPanelPaintManager
static const CRect | rectDefault
System selected default margins.
- Protected Member Functions inherited from CXTPTaskPanelVisualStudio2012Theme
- Protected Member Functions inherited from CXTPTaskPanelVisualStudio2005Theme
- Protected Member Functions inherited from CXTPTaskPanelToolboxTheme
- Protected Member Functions inherited from CXTPTaskPanelPaintManager
CRect | DrawGroupItemImageWithText (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw)
Draws the icon of a specified group item.
CRect | DrawGroupItemImageWithTextBelow (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw)
Draws the icon of a specified group item.
CRect | DrawGroupItemImage (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw)
Draws the icon of a specified group item.
virtual void | DrawGroupClientItems (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Draws the items of a specified group.
virtual CRect | DrawCaptionGripper (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Draws the caption gripper of a specified group.
virtual int | GetCaptionGripperWidth (CXTPTaskPanelGroup *pGroup, CRect rc)
Retrieves the width of the caption gripper of a specified group.
virtual void | DrawItemImage (CDC *pDC, CXTPTaskPanelItem *pItem, CPoint ptIcon, CXTPImageManagerIcon *pImage, CSize szIcon)
Draws the icon of a specified item.
COLORREF | BlendColor (COLORREF clrFrom, COLORREF clrTo, int nAlpha)
Blends one color to another color by a specified amount.
CRect | DrawCaptionGripperBitmap (CDC *pDC, CXTPTaskPanelGroup *pGroup, BOOL bExpanded, BOOL bHot, CRect rc)
Draws the caption gripper bitmap.
void | DrawCaptionGripperSigns (CDC *pDC, CPoint pt, COLORREF clr, BOOL bExpanded)
Draws the ">>" and "<<" signs of the caption gripper when the theme of the Task Panel is set to Office 2000.
void | CreateGripperBitmaps ()
Loads the gripper bitmap when the theme of the Task Panel is set to either Windows XP or Classic Windows XP.
void | CreateGripperIcon (HICON &hIcon, UINT nIDResource, COLORREF clrGripperBack)
Creates the gripper bitmap icons when the theme of the Task Panel is set to either Windows XP or Classic Windows XP and either the operating system is not Windows XP or the operating system is Windows XP and Luna themes are used.
void | FreeBitmaps ()
Frees the memory used by the group caption bitmaps.
void | Rectangle (CDC *pDC, CRect rc, COLORREF clrPen, COLORREF clrBrush)
This method is only used when drawing hot, pressed, and selected group items and scroll buttons when m_bOfficeHighlight is TRUE.
virtual CPoint | GetHighlightOffset (CXTPTaskPanelGroupItem *pItem)
Retrieves the highlight offset of the text of a specified group item.
virtual void | DrawDragArrow (CDC *pDC, CXTPTaskPanelItem *pItem, CRect rc, BOOL bAfter=FALSE)
Draws the "drag arrow" of a specified item.
virtual void | DrawFocusRect (CDC *pDC, CRect rc)
Draws a rectangle around the focused item.
- Protected Attributes inherited from CXTPTaskPanelVisualStudio2012Theme
CXTPPaintManagerColor | m_clrSelectedWithoutFocus
Color of the selected item when the Task Panel does not have focus.
CXTPPaintManagerColor | m_clrText
Normal text color.
CXTPPaintManagerColor | m_clrSelectedText
Text color of the selected item.
CXTPPaintManagerColor | m_clrSelectedTextWithoutFocus
Text color of the selected item when the Task Panel does not have focus.
- Protected Attributes inherited from CXTPTaskPanelPaintManagerPlain
BOOL | m_bRoundedFrame
TRUE to draw a rounded frame around all of the groups in the task panel.
BOOL | m_bOfficeCaption
FALSE to draw a rounded rectangle around caption.
- Protected Attributes inherited from CXTPTaskPanelPaintManager
BOOL | m_bUseBitmapGrippers
TRUE to use alpha grippers.
HICON | m_hGripperNormal
Icon of normal group header gripper.
HICON | m_hGripperSpecial
Icon of special group header gripper.
HBITMAP | m_bmpGrippers [8]
Bitmaps of alpha grippers.
CXTPFont | m_xtpFontCaption
Caption font.
CXTPFont | m_xtpFontIcon
Normal items font.
CXTPFont | m_xtpFontIconBold
Bold items font.
CXTPFont | m_xtpFontIconHot
"Hot" items font.
CXTPFont | m_xtpFontIconHotBold
Bold items font.
CXTPPaintManagerColorGradient | m_clrBackground
Background color of the Task Panel.
XTP_TASKPANEL_GROUPCOLORS | m_groupNormal
Normal colors set.
XTP_TASKPANEL_GROUPCOLORS | m_groupSpecial
Special colors set.
CXTPPaintManagerColor | m_clrHighlightHot
Color of items when they are "hot." This is the color of the item on mouseover if hot tracking is enabled.
CXTPPaintManagerColor m_clrHighlightSelected
Color of items when they are selected.
CXTPPaintManagerColor m_clrHighlightPressed
Color of items when they are pressed.
CXTPPaintManagerColorGradient | m_clrHighlightBorder
Border color of items when they are "hot." This is the border color of the item on mouse over if hot tracking is enabled.
BOOL | m_bOfficeBorder
TRUE to use Office borders.
BOOL | m_bLeftRoundedCorner
TRUE to round left corner of the group caption.
BOOL | m_bRightRoundedCorner
TRUE to round right corner of the group caption.
int | m_nCaptionHeight
Caption height, in pixels.
BOOL | m_bUseStandardCaptionFont
TRUE to use system font for group caption text.
BOOL | m_bUseStandardItemsFont
TRUE to use system font for item caption text.
int | m_nItemTextFormat
Format flags of item text.
int | m_nCaptionTextFormat
Format flags of caption text.

Detailed Description

CXTPTaskPanelVisualStudio2017Theme represents a Visutal Studio 2017 style theme.

See also
CXTPTaskPanel::SetTheme
The documentation for this class was generated from the following file:
  • XTPTaskPanelVisualStudio2017Theme.h


Toolkit Pro: CXTPTaskPanelVisualStudio2019Theme Class Reference

Public Member Functions | List of all members
CXTPTaskPanelVisualStudio2019Theme Class Reference

CXTPTaskPanelVisualStudio2019Theme represents a Visutal Studio 2019 style theme. More...

Inheritance diagram for CXTPTaskPanelVisualStudio2019Theme:
[legend]

Public Member Functions

CXTPTaskPanelVisualStudio2019Theme ()
Constructs a CXTPTaskPanelVisualStudio2019Theme object.
virtual | ~CXTPTaskPanelVisualStudio2019Theme ()
Destroys a CXTPTaskPanelVisualStudio2019Theme object, handles cleanup and deallocation.
virtual void | RefreshMetrics ()
Refreshes the visual metrics of the task panel.
- Public Member Functions inherited from CXTPTaskPanelVisualStudio2012Theme
CXTPTaskPanelVisualStudio2012Theme (BOOL bLight=TRUE)
Constructs a CXTPTaskPanelVisualStudio2012Theme object.
virtual | ~CXTPTaskPanelVisualStudio2012Theme ()
Destroys a CXTPTaskPanelVisualStudio2012Theme object, handles cleanup and deallocation.
CRect | DrawGroupCaptionBackground (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Draws the group caption background of a specified group.
void | DrawGroupClientFace (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Draws the client face of a specified group.
virtual void | DrawGroupItemFrame (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc)
Draws a rectangle around a group item when it is selected, pressed or highlighted.
void | FillGroupClientFace (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Fills the client face of a specified group.
void | FillTaskPanel (CDC *pDC, CXTPTaskPanel *pTaskPanel)
Fills the background of a specified task panel.
virtual void | DrawItemCaption (CDC *pDC, CXTPTaskPanelItem *pItem, CRect rcText, UINT nFormat)
Draws the text caption of a specified item.
- Public Member Functions inherited from CXTPTaskPanelVisualStudio2005Theme
CXTPTaskPanelVisualStudio2005Theme ()
Constructs a CXTPTaskPanelVisualStudio2005Theme object.
- Public Member Functions inherited from CXTPTaskPanelToolboxTheme
CXTPTaskPanelToolboxTheme ()
Constructs a CXTPTaskPanelToolboxTheme object.
int | DrawGroupCaption (CDC *pDC, CXTPTaskPanelGroup *pGroup, BOOL bDraw)
Draws the caption of a specified group.
- Public Member Functions inherited from CXTPTaskPanelPaintManagerPlain
CXTPTaskPanelPaintManagerPlain ()
Constructs a CXTPTaskPanelPaintManagerPlain object.
- Public Member Functions inherited from CXTPTaskPanelPaintManager
CXTPTaskPanelPaintManager ()
Constructs a CXTPTaskPanelPaintManager object.
virtual | ~CXTPTaskPanelPaintManager ()
Destroys a CXTPTaskPanelPaintManager object, handles cleanup and deallocation.
virtual void | DrawGroupClient (CDC *pDC, CXTPTaskPanelGroup *pGroup)
Draws a specified group.
virtual CRect | DrawGroupItem (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw)
Draws a specified group item.
XTP_TASKPANEL_GROUPCOLORS * | GetGroupColors (BOOL bSpecial)
Retrieves a specified group color set.
virtual XTP_TASKPANEL_GROUPCOLORS * | GetGroupColors (CXTPTaskPanelGroup *pGroup)
Retrieves a specified group color set.
virtual CRect | GetItemOuterMargins (const CXTPTaskPanelGroupItem *pItem)
Retrieves the outer margins of a specified group item.
virtual CRect | GetItemInnerMargins (const CXTPTaskPanelGroupItem *pItem)
Retrieves the inner margins of a specified group item.
virtual CRect | GetGroupOuterMargins (const CXTPTaskPanelGroup *pGroup)
Retrieves the outer margins of a specified group.
virtual CRect | GetItemIconPadding (const CXTPTaskPanelItem *pItem)
Retrieves the icon padding of a specified item.
virtual CRect | GetGroupInnerMargins (const CXTPTaskPanelGroup *pGroup)
Retrieves the inner margins of a specified group.
virtual CRect | GetControlMargins (const CXTPTaskPanel *pPanel)
Gets the default margins used for all groups within a specified Task Panel control.
virtual int | GetGroupSpacing (const CXTPTaskPanel *pPanel)
Gets the spacing used between groups within a specified Task Panel control.
virtual void | DrawScrollButton (CDC *pDC, CXTPTaskPanelScrollButton *pScrollButton)
Draws a group scroll button.
void | SetTextFormat (int nTextFormat, BOOL bCaption=FALSE)
Sets the text format for captions/items.
void | SetItemsFontIndirect (LOGFONT *pLogFont, BOOL bUseStandardItemsFont=FALSE)
Sets the text font for items.
void | SetCaptionFontIndirect (LOGFONT *pLogFont, BOOL bUseStandardCaptionFont=FALSE)
Sets the text font for captions.
virtual CFont * | GetItemFont (CXTPTaskPanelItem *pItem)
Retrieves the text font of a specified item.

Additional Inherited Members

- Public Attributes inherited from CXTPTaskPanelPaintManager
BOOL | m_bEmulateEplorerTheme
TRUE to use Explorer theme under WinXP and Office 2000 under older OS.
XTPTaskPanelGripper | m_eGripper
Gripper of the manager.
BOOL | m_bBoldCaption
TRUE to display caption text in bold font, FALSE to display caption text in normal type.
CRect | m_rcGroupOuterMargins
Outer margins of the group.
CRect | m_rcGroupInnerMargins
Inner margins of the group.
CRect | m_rcItemOuterMargins
Outer margins of the group items.
CRect | m_rcItemInnerMargins
Inner margins of the group items.
CRect | m_rcControlMargins
Default margins for all groups.
int | m_nGroupSpacing
Amount of space placed between groups in the task panel.
CRect | m_rcImageLayoutIconPadding
Padding around images for xtpTaskItemLayoutImages layout.
CRect | m_rcItemIconPadding
Padding around images for items.
CRect | m_rcGroupIconPadding
Padding around images for groups.
BOOL | m_bOfficeHighlight
TRUE to highlight group items and scroll buttons using the Office XP style (XPCOLOR_HIGHLIGHT, XPCOLOR_HIGHLIGHT_CHECKED, XPCOLOR_HIGHLIGHT_PUSHED).
BOOL | m_bInvertDragRect
Only used when the theme is set to xtpTaskPanelThemeVisualStudio2003.
BOOL | m_bCaptionScrollButton
TRUE if the group caption scroll button is visible, FALSE if the group caption scroll button is hidden.
BOOL | m_bEmbossedDisabledText
TRUE to draw disabled text embossed.
- Static Public Attributes inherited from CXTPTaskPanelPaintManager
static const CRect | rectDefault
System selected default margins.
- Protected Member Functions inherited from CXTPTaskPanelVisualStudio2012Theme
- Protected Member Functions inherited from CXTPTaskPanelVisualStudio2005Theme
- Protected Member Functions inherited from CXTPTaskPanelToolboxTheme
- Protected Member Functions inherited from CXTPTaskPanelPaintManager
CRect | DrawGroupItemImageWithText (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw)
Draws the icon of a specified group item.
CRect | DrawGroupItemImageWithTextBelow (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw)
Draws the icon of a specified group item.
CRect | DrawGroupItemImage (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw)
Draws the icon of a specified group item.
virtual void | DrawGroupClientItems (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Draws the items of a specified group.
virtual CRect | DrawCaptionGripper (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Draws the caption gripper of a specified group.
virtual int | GetCaptionGripperWidth (CXTPTaskPanelGroup *pGroup, CRect rc)
Retrieves the width of the caption gripper of a specified group.
virtual void | DrawItemImage (CDC *pDC, CXTPTaskPanelItem *pItem, CPoint ptIcon, CXTPImageManagerIcon *pImage, CSize szIcon)
Draws the icon of a specified item.
COLORREF | BlendColor (COLORREF clrFrom, COLORREF clrTo, int nAlpha)
Blends one color to another color by a specified amount.
CRect | DrawCaptionGripperBitmap (CDC *pDC, CXTPTaskPanelGroup *pGroup, BOOL bExpanded, BOOL bHot, CRect rc)
Draws the caption gripper bitmap.
void | DrawCaptionGripperSigns (CDC *pDC, CPoint pt, COLORREF clr, BOOL bExpanded)
Draws the ">>" and "<<" signs of the caption gripper when the theme of the Task Panel is set to Office 2000.
void | CreateGripperBitmaps ()
Loads the gripper bitmap when the theme of the Task Panel is set to either Windows XP or Classic Windows XP.
void | CreateGripperIcon (HICON &hIcon, UINT nIDResource, COLORREF clrGripperBack)
Creates the gripper bitmap icons when the theme of the Task Panel is set to either Windows XP or Classic Windows XP and either the operating system is not Windows XP or the operating system is Windows XP and Luna themes are used.
void | FreeBitmaps ()
Frees the memory used by the group caption bitmaps.
void | Rectangle (CDC *pDC, CRect rc, COLORREF clrPen, COLORREF clrBrush)
This method is only used when drawing hot, pressed, and selected group items and scroll buttons when m_bOfficeHighlight is TRUE.
virtual CPoint | GetHighlightOffset (CXTPTaskPanelGroupItem *pItem)
Retrieves the highlight offset of the text of a specified group item.
virtual void | DrawDragArrow (CDC *pDC, CXTPTaskPanelItem *pItem, CRect rc, BOOL bAfter=FALSE)
Draws the "drag arrow" of a specified item.
virtual void | DrawFocusRect (CDC *pDC, CRect rc)
Draws a rectangle around the focused item.
- Protected Attributes inherited from CXTPTaskPanelVisualStudio2012Theme
CXTPPaintManagerColor | m_clrSelectedWithoutFocus
Color of the selected item when the Task Panel does not have focus.
CXTPPaintManagerColor | m_clrText
Normal text color.
CXTPPaintManagerColor | m_clrSelectedText
Text color of the selected item.
CXTPPaintManagerColor | m_clrSelectedTextWithoutFocus
Text color of the selected item when the Task Panel does not have focus.
- Protected Attributes inherited from CXTPTaskPanelPaintManagerPlain
BOOL | m_bRoundedFrame
TRUE to draw a rounded frame around all of the groups in the task panel.
BOOL | m_bOfficeCaption
FALSE to draw a rounded rectangle around caption.
- Protected Attributes inherited from CXTPTaskPanelPaintManager
BOOL | m_bUseBitmapGrippers
TRUE to use alpha grippers.
HICON | m_hGripperNormal
Icon of normal group header gripper.
HICON | m_hGripperSpecial
Icon of special group header gripper.
HBITMAP | m_bmpGrippers [8]
Bitmaps of alpha grippers.
CXTPFont | m_xtpFontCaption
Caption font.
CXTPFont | m_xtpFontIcon
Normal items font.
CXTPFont | m_xtpFontIconBold
Bold items font.
CXTPFont | m_xtpFontIconHot
"Hot" items font.
CXTPFont | m_xtpFontIconHotBold
Bold items font.
CXTPPaintManagerColorGradient | m_clrBackground
Background color of the Task Panel.
XTP_TASKPANEL_GROUPCOLORS | m_groupNormal
Normal colors set.
XTP_TASKPANEL_GROUPCOLORS | m_groupSpecial
Special colors set.
CXTPPaintManagerColor | m_clrHighlightHot
Color of items when they are "hot." This is the color of the item on mouseover if hot tracking is enabled.
CXTPPaintManagerColor m_clrHighlightSelected
Color of items when they are selected.
CXTPPaintManagerColor m_clrHighlightPressed
Color of items when they are pressed.
CXTPPaintManagerColorGradient | m_clrHighlightBorder
Border color of items when they are "hot." This is the border color of the item on mouse over if hot tracking is enabled.
BOOL | m_bOfficeBorder
TRUE to use Office borders.
BOOL | m_bLeftRoundedCorner
TRUE to round left corner of the group caption.
BOOL | m_bRightRoundedCorner
TRUE to round right corner of the group caption.
int | m_nCaptionHeight
Caption height, in pixels.
BOOL | m_bUseStandardCaptionFont
TRUE to use system font for group caption text.
BOOL | m_bUseStandardItemsFont
TRUE to use system font for item caption text.
int | m_nItemTextFormat
Format flags of item text.
int | m_nCaptionTextFormat
Format flags of caption text.

Detailed Description

CXTPTaskPanelVisualStudio2019Theme represents a Visutal Studio 2019 style theme.

See also
CXTPTaskPanel::SetTheme
The documentation for this class was generated from the following file:
  • XTPTaskPanelVisualStudio2019Theme.h


Toolkit Pro: CXTPTaskPanelVisualStudio2022Theme Class Reference

Public Member Functions | List of all members
CXTPTaskPanelVisualStudio2022Theme Class Reference

CXTPTaskPanelVisualStudio2022Theme represents a Visutal Studio 2022 style theme. More...

Inheritance diagram for CXTPTaskPanelVisualStudio2022Theme:
[legend]

Public Member Functions

CXTPTaskPanelVisualStudio2022Theme ()
Constructs a CXTPTaskPanelVisualStudio2022Theme object.
virtual | ~CXTPTaskPanelVisualStudio2022Theme ()
Destroys a CXTPTaskPanelVisualStudio2022Theme object, handles cleanup and deallocation.
virtual void | RefreshMetrics ()
Refreshes the visual metrics of the task panel.
- Public Member Functions inherited from CXTPTaskPanelVisualStudio2012Theme
CXTPTaskPanelVisualStudio2012Theme (BOOL bLight=TRUE)
Constructs a CXTPTaskPanelVisualStudio2012Theme object.
virtual | ~CXTPTaskPanelVisualStudio2012Theme ()
Destroys a CXTPTaskPanelVisualStudio2012Theme object, handles cleanup and deallocation.
CRect | DrawGroupCaptionBackground (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Draws the group caption background of a specified group.
void | DrawGroupClientFace (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Draws the client face of a specified group.
virtual void | DrawGroupItemFrame (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc)
Draws a rectangle around a group item when it is selected, pressed or highlighted.
void | FillGroupClientFace (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Fills the client face of a specified group.
void | FillTaskPanel (CDC *pDC, CXTPTaskPanel *pTaskPanel)
Fills the background of a specified task panel.
virtual void | DrawItemCaption (CDC *pDC, CXTPTaskPanelItem *pItem, CRect rcText, UINT nFormat)
Draws the text caption of a specified item.
- Public Member Functions inherited from CXTPTaskPanelVisualStudio2005Theme
CXTPTaskPanelVisualStudio2005Theme ()
Constructs a CXTPTaskPanelVisualStudio2005Theme object.
- Public Member Functions inherited from CXTPTaskPanelToolboxTheme
CXTPTaskPanelToolboxTheme ()
Constructs a CXTPTaskPanelToolboxTheme object.
int | DrawGroupCaption (CDC *pDC, CXTPTaskPanelGroup *pGroup, BOOL bDraw)
Draws the caption of a specified group.
- Public Member Functions inherited from CXTPTaskPanelPaintManagerPlain
CXTPTaskPanelPaintManagerPlain ()
Constructs a CXTPTaskPanelPaintManagerPlain object.
- Public Member Functions inherited from CXTPTaskPanelPaintManager
CXTPTaskPanelPaintManager ()
Constructs a CXTPTaskPanelPaintManager object.
virtual | ~CXTPTaskPanelPaintManager ()
Destroys a CXTPTaskPanelPaintManager object, handles cleanup and deallocation.
virtual void | DrawGroupClient (CDC *pDC, CXTPTaskPanelGroup *pGroup)
Draws a specified group.
virtual CRect | DrawGroupItem (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw)
Draws a specified group item.
XTP_TASKPANEL_GROUPCOLORS * | GetGroupColors (BOOL bSpecial)
Retrieves a specified group color set.
virtual XTP_TASKPANEL_GROUPCOLORS * | GetGroupColors (CXTPTaskPanelGroup *pGroup)
Retrieves a specified group color set.
virtual CRect | GetItemOuterMargins (const CXTPTaskPanelGroupItem *pItem)
Retrieves the outer margins of a specified group item.
virtual CRect | GetItemInnerMargins (const CXTPTaskPanelGroupItem *pItem)
Retrieves the inner margins of a specified group item.
virtual CRect | GetGroupOuterMargins (const CXTPTaskPanelGroup *pGroup)
Retrieves the outer margins of a specified group.
virtual CRect | GetItemIconPadding (const CXTPTaskPanelItem *pItem)
Retrieves the icon padding of a specified item.
virtual CRect | GetGroupInnerMargins (const CXTPTaskPanelGroup *pGroup)
Retrieves the inner margins of a specified group.
virtual CRect | GetControlMargins (const CXTPTaskPanel *pPanel)
Gets the default margins used for all groups within a specified Task Panel control.
virtual int | GetGroupSpacing (const CXTPTaskPanel *pPanel)
Gets the spacing used between groups within a specified Task Panel control.
virtual void | DrawScrollButton (CDC *pDC, CXTPTaskPanelScrollButton *pScrollButton)
Draws a group scroll button.
void | SetTextFormat (int nTextFormat, BOOL bCaption=FALSE)
Sets the text format for captions/items.
void | SetItemsFontIndirect (LOGFONT *pLogFont, BOOL bUseStandardItemsFont=FALSE)
Sets the text font for items.
void | SetCaptionFontIndirect (LOGFONT *pLogFont, BOOL bUseStandardCaptionFont=FALSE)
Sets the text font for captions.
virtual CFont * | GetItemFont (CXTPTaskPanelItem *pItem)
Retrieves the text font of a specified item.

Additional Inherited Members

- Public Attributes inherited from CXTPTaskPanelPaintManager
BOOL | m_bEmulateEplorerTheme
TRUE to use Explorer theme under WinXP and Office 2000 under older OS.
XTPTaskPanelGripper | m_eGripper
Gripper of the manager.
BOOL | m_bBoldCaption
TRUE to display caption text in bold font, FALSE to display caption text in normal type.
CRect | m_rcGroupOuterMargins
Outer margins of the group.
CRect | m_rcGroupInnerMargins
Inner margins of the group.
CRect | m_rcItemOuterMargins
Outer margins of the group items.
CRect | m_rcItemInnerMargins
Inner margins of the group items.
CRect | m_rcControlMargins
Default margins for all groups.
int | m_nGroupSpacing
Amount of space placed between groups in the task panel.
CRect | m_rcImageLayoutIconPadding
Padding around images for xtpTaskItemLayoutImages layout.
CRect | m_rcItemIconPadding
Padding around images for items.
CRect | m_rcGroupIconPadding
Padding around images for groups.
BOOL | m_bOfficeHighlight
TRUE to highlight group items and scroll buttons using the Office XP style (XPCOLOR_HIGHLIGHT, XPCOLOR_HIGHLIGHT_CHECKED, XPCOLOR_HIGHLIGHT_PUSHED).
BOOL | m_bInvertDragRect
Only used when the theme is set to xtpTaskPanelThemeVisualStudio2003.
BOOL | m_bCaptionScrollButton
TRUE if the group caption scroll button is visible, FALSE if the group caption scroll button is hidden.
BOOL | m_bEmbossedDisabledText
TRUE to draw disabled text embossed.
- Static Public Attributes inherited from CXTPTaskPanelPaintManager
static const CRect | rectDefault
System selected default margins.
- Protected Member Functions inherited from CXTPTaskPanelVisualStudio2012Theme
- Protected Member Functions inherited from CXTPTaskPanelVisualStudio2005Theme
- Protected Member Functions inherited from CXTPTaskPanelToolboxTheme
- Protected Member Functions inherited from CXTPTaskPanelPaintManager
CRect | DrawGroupItemImageWithText (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw)
Draws the icon of a specified group item.
CRect | DrawGroupItemImageWithTextBelow (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw)
Draws the icon of a specified group item.
CRect | DrawGroupItemImage (CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw)
Draws the icon of a specified group item.
virtual void | DrawGroupClientItems (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Draws the items of a specified group.
virtual CRect | DrawCaptionGripper (CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Draws the caption gripper of a specified group.
virtual int | GetCaptionGripperWidth (CXTPTaskPanelGroup *pGroup, CRect rc)
Retrieves the width of the caption gripper of a specified group.
virtual void | DrawItemImage (CDC *pDC, CXTPTaskPanelItem *pItem, CPoint ptIcon, CXTPImageManagerIcon *pImage, CSize szIcon)
Draws the icon of a specified item.
COLORREF | BlendColor (COLORREF clrFrom, COLORREF clrTo, int nAlpha)
Blends one color to another color by a specified amount.
CRect | DrawCaptionGripperBitmap (CDC *pDC, CXTPTaskPanelGroup *pGroup, BOOL bExpanded, BOOL bHot, CRect rc)
Draws the caption gripper bitmap.
void | DrawCaptionGripperSigns (CDC *pDC, CPoint pt, COLORREF clr, BOOL bExpanded)
Draws the ">>" and "<<" signs of the caption gripper when the theme of the Task Panel is set to Office 2000.
void | CreateGripperBitmaps ()
Loads the gripper bitmap when the theme of the Task Panel is set to either Windows XP or Classic Windows XP.
void | CreateGripperIcon (HICON &hIcon, UINT nIDResource, COLORREF clrGripperBack)
Creates the gripper bitmap icons when the theme of the Task Panel is set to either Windows XP or Classic Windows XP and either the operating system is not Windows XP or the operating system is Windows XP and Luna themes are used.
void | FreeBitmaps ()
Frees the memory used by the group caption bitmaps.
void | Rectangle (CDC *pDC, CRect rc, COLORREF clrPen, COLORREF clrBrush)
This method is only used when drawing hot, pressed, and selected group items and scroll buttons when m_bOfficeHighlight is TRUE.
virtual CPoint | GetHighlightOffset (CXTPTaskPanelGroupItem *pItem)
Retrieves the highlight offset of the text of a specified group item.
virtual void | DrawDragArrow (CDC *pDC, CXTPTaskPanelItem *pItem, CRect rc, BOOL bAfter=FALSE)
Draws the "drag arrow" of a specified item.
virtual void | DrawFocusRect (CDC *pDC, CRect rc)
Draws a rectangle around the focused item.
- Protected Attributes inherited from CXTPTaskPanelVisualStudio2012Theme
CXTPPaintManagerColor | m_clrSelectedWithoutFocus
Color of the selected item when the Task Panel does not have focus.
CXTPPaintManagerColor | m_clrText
Normal text color.
CXTPPaintManagerColor | m_clrSelectedText
Text color of the selected item.
CXTPPaintManagerColor | m_clrSelectedTextWithoutFocus
Text color of the selected item when the Task Panel does not have focus.
- Protected Attributes inherited from CXTPTaskPanelPaintManagerPlain
BOOL | m_bRoundedFrame
TRUE to draw a rounded frame around all of the groups in the task panel.
BOOL | m_bOfficeCaption
FALSE to draw a rounded rectangle around caption.
- Protected Attributes inherited from CXTPTaskPanelPaintManager
BOOL | m_bUseBitmapGrippers
TRUE to use alpha grippers.
HICON | m_hGripperNormal
Icon of normal group header gripper.
HICON | m_hGripperSpecial
Icon of special group header gripper.
HBITMAP | m_bmpGrippers [8]
Bitmaps of alpha grippers.
CXTPFont | m_xtpFontCaption
Caption font.
CXTPFont | m_xtpFontIcon
Normal items font.
CXTPFont | m_xtpFontIconBold
Bold items font.
CXTPFont | m_xtpFontIconHot
"Hot" items font.
CXTPFont | m_xtpFontIconHotBold
Bold items font.
CXTPPaintManagerColorGradient | m_clrBackground
Background color of the Task Panel.
XTP_TASKPANEL_GROUPCOLORS | m_groupNormal
Normal colors set.
XTP_TASKPANEL_GROUPCOLORS | m_groupSpecial
Special colors set.
CXTPPaintManagerColor | m_clrHighlightHot
Color of items when they are "hot." This is the color of the item on mouseover if hot tracking is enabled.
CXTPPaintManagerColor m_clrHighlightSelected
Color of items when they are selected.
CXTPPaintManagerColor m_clrHighlightPressed
Color of items when they are pressed.
CXTPPaintManagerColorGradient | m_clrHighlightBorder
Border color of items when they are "hot." This is the border color of the item on mouse over if hot tracking is enabled.
BOOL | m_bOfficeBorder
TRUE to use Office borders.
BOOL | m_bLeftRoundedCorner
TRUE to round left corner of the group caption.
BOOL | m_bRightRoundedCorner
TRUE to round right corner of the group caption.
int | m_nCaptionHeight
Caption height, in pixels.
BOOL | m_bUseStandardCaptionFont
TRUE to use system font for group caption text.
BOOL | m_bUseStandardItemsFont
TRUE to use system font for item caption text.
int | m_nItemTextFormat
Format flags of item text.
int | m_nCaptionTextFormat
Format flags of caption text.

Detailed Description

CXTPTaskPanelVisualStudio2022Theme represents a Visutal Studio 2022 style theme.

See also
CXTPTaskPanel::SetTheme
The documentation for this class was generated from the following file:
  • XTPTaskPanelVisualStudio2022Theme.h


Toolkit Pro: CXTPTcbItem Class Reference

Public Member Functions | Public Attributes | List of all members
CXTPTcbItem Class Reference

The CXTPTcbItem class is used to maintain information for a particular tab item in a CXTPExcelTabCtrl, CXTPTabCtrl, or CXTPTabView object. More...

Public Member Functions

CXTPTcbItem ()
Constructs a CXTPTcbItem object.

Public Attributes

UINT | uiToolTipId
Resource ID for the tooltip.
CWnd * | pWnd
A CWnd pointer to the window associated with a tab.
CString | szTabLabel
User specified label for the tab.
CString | szToolTipLabel
Tooltip text for the tab.
CString | szCondensedLabel
The label actually being displayed for auto-condensing tabs.
DWORD | dwStyle
Stores the window style when the tab item was created.
DWORD | dwExStyle
Stores the extended window style when the tab item was created.
COLORREF | crTabBack
Application defined tab background color.
COLORREF | crTabText
Application defined tab text color.
COLORREF | crTabSelBack
Application defined selected tab background color.
COLORREF | crTabSelText
Application defined selected tab text color.

Detailed Description

The CXTPTcbItem class is used to maintain information for a particular tab item in a CXTPExcelTabCtrl, CXTPTabCtrl, or CXTPTabView object.

See also
CXTPExcelTabCtrl, CXTPTabCtrl and CXTPTabView
The documentation for this class was generated from the following file:
  • XTPGlobal.h


Toolkit Pro: CXTPTearOffFrame Class Reference

Public Member Functions | List of all members
CXTPTearOffFrame Class Reference

The class represents a floating torn off frame. More...

Inheritance diagram for CXTPTearOffFrame:
[legend]

Public Member Functions

CXTPTearOffFrame ()
Construct frame object.
virtual | ~CXTPTearOffFrame ()
Handles resources cleanup.
virtual BOOL | DestroyWindow ()
Handles frame window destruction.
void | Init (CXTPTabClientWnd *pTabClient, CXTPTabManagerItem *pTabItem)
Initializes frame object.
void | Update (CXTPTabClientWnd *pTabClient)
Updates an associated tab client object and and all related frame states.
CXTPTabClientWnd * | GetTabClient () const
Obtains an associated tab client object pointer.
BOOL | IsFrameBeingDragged () const
Determines if the frame is being dragged.
- Public Member Functions inherited from CXTPMDIFrameWnd
DECLARE_DYNCREATE (CXTPMDIFrameWnd) CXTPMDIFrameWnd()
Constructs a CXTPMDIFrameWnd object.
void | UpdateMDIChildrenTheme ()
Sends a theme update notification to all MDI children.
- Public Member Functions inherited from CXTPFrameWndBase< CMDIFrameWnd >
CXTPFrameWndBase ()
Constructs a CXTPFrameWndBase object.
~CXTPFrameWndBase ()
Destroys a CXTPFrameWndBase object, handles cleanup and deallocation.
- Public Member Functions inherited from CXTPCommandBarsSiteBase< CMDIFrameWnd >
CXTPCommandBarsSiteBase ()
Constructs a CXTPCommandBarsSiteBase object.
~CXTPCommandBarsSiteBase ()
Destroys a CXTPCommandBarsSiteBase object, handles cleanup and deallocation.
virtual BOOL | InitCommandBars (CRuntimeClass *pCommandBarsClass=RUNTIME_CLASS(CXTPCommandBars))
Creates command bars.
void | DockRightOf (CXTPToolBar *pBarToDock, CXTPToolBar *pBarOnLeft)
This member function will re-dock a toolbar specified by 'pBarToDock' to the right of a newly docked toolbar specified by 'pBarOnLeft'.
virtual void | SaveCommandBars (LPCTSTR lpszProfileName)
Call this function to save the state information to the registry or .INI file.
virtual void | LoadCommandBars (LPCTSTR lpszProfileName, BOOL bSilent=FALSE)
Call this function to retrieve state information from the registry or .INI file.
CXTPCommandBars * | GetCommandBars () const
Call this member to retrieve a pointer to the CommandBars object.

Detailed Description

The class represents a floating torn off frame.

Member Function Documentation

◆ DestroyWindow()

virtual BOOL DestroyWindow ( )
virtual

Handles frame window destruction.

Returns
TRUE if the window is destroyed successfully, FALSE otherwise.

◆ GetTabClient()

CXTPTabClientWnd * GetTabClient ( ) const

Obtains an associated tab client object pointer.

Returns
An associated tab client object pointer.

◆ Init()

void Init | ( | CXTPTabClientWnd * | pTabClient,
 |  | CXTPTabManagerItem * | pTabItem )

Initializes frame object.

Parameters
pTabClient | A pointer to the associated tab client object.
pTabItem | A pointer to the initial tab item object.

◆ IsFrameBeingDragged()

BOOL IsFrameBeingDragged ( ) const

Determines if the frame is being dragged.

Returns
TRUE if the frame is being dragged or FALSE otherwise.

◆ Update()

void Update ( CXTPTabClientWnd * pTabClient )

Updates an associated tab client object and and all related frame states.

Parameters
pTabClient A pointer to the new associated tab client object.
The documentation for this class was generated from the following file:
  • XTPTearOffFrame.h


Toolkit Pro: CXTPTempColorMask Class Reference

Public Member Functions | List of all members
CXTPTempColorMask Class Reference

The CXTPTempColorMask class can be used to temporarily set the color mask used by XTPImageManager when using images with different color masks. More...

Public Member Functions

CXTPTempColorMask (COLORREF crNewMask)
Constructs a CXTPTempColorMask object, initializes the application defined mask color, and saves the default mask color used by XTPImageManager.
~CXTPTempColorMask ()
Destructor for CXTPTempColorMask.

Detailed Description

The CXTPTempColorMask class can be used to temporarily set the color mask used by XTPImageManager when using images with different color masks.

When the destructor is called, the default mask is reset for XTPImageManager.

Example: The following example demonstrates using CXTPTempColorMask:

// temporarily change the mask color.
CXTPTempColorMask mask(RGB(0,255,0));
XTPImageManager()->SetIcons(IDB_FAVORITES,
icons, _countof(icons) CSize(16,16));

// set another mask color, CXTPTempColorMask will handle resetting
// the default color mask when it is destroyed.
XTPImageManager()->SetMaskColor(RGB(255,0,255));
XTPImageManager()->SetIcons(IDR_TOOLBAR_MASKED,
buttons, _countof(buttons), CSize(16,16), xtpImageNormal);
See also
CXTPImageManager::GetMaskColor, CXTPImageManager::SetMaskColor, CXTPPaintManagerColor::GetStandardColor

Constructor & Destructor Documentation

◆ CXTPTempColorMask()

CXTPTempColorMask ( COLORREF crNewMask )

Constructs a CXTPTempColorMask object, initializes the application defined mask color, and saves the default mask color used by XTPImageManager.

Parameters
crNewMask An RGB value that represents the new color mask value used by XTPImageManager.

◆ ~CXTPTempColorMask()

~CXTPTempColorMask ( )

Destructor for CXTPTempColorMask.

Resets the default mask color used by XTPImageManager back to its original color value.

The documentation for this class was generated from the following file:
  • XTPImageManager.h


Toolkit Pro: CXTPTextOnPath Class Reference

List of all members
CXTPTextOnPath Class Reference

GDI+ drawing of text on path. More...

Detailed Description

GDI+ drawing of text on path.

The documentation for this class was generated from the following file:
  • XTPTextOnPath.h


Toolkit Pro: CXTPTextPreviewProvider Class Reference

List of all members
CXTPTextPreviewProvider Class Reference

Provides a preview handler for the text file type (TXT). More...

Inheritance diagram for CXTPTextPreviewProvider:
[legend]

Additional Inherited Members

- Public Member Functions inherited from IXTPPreviewProvider
virtual | ~IXTPPreviewProvider ()
Handles object destruction.
- Protected Member Functions inherited from CXTPPreviewProviderBase
CXTPPreviewProviderBase ()
Handles object construction.
void | BindHost (IXTPPreviewHost &host)
The method is called by the host preview control when the provider is initially bound to the host.
IXTPPreviewHost & | GetHost () const
Obtains the preview host interface that the provider is bound to.

Detailed Description

Provides a preview handler for the text file type (TXT).

However, it can also be used to preview any textual file type.

See also
CXTPSystemPreviewProvider, CXTPCommonPicturePreviewProvider, CXTPGifPreviewProvider, CXTPMsgPreviewProvider, CXTPXamlPreviewProvider
The documentation for this class was generated from the following file:
  • XTPTextPreviewProvider.h


Toolkit Pro: CXTPThemeDLL Class Reference

Public Member Functions | List of all members
CXTPThemeDLL Class Reference

CXTPThemeDLL is a helper class used to load Codejock theme resource DLLs. More...

Public Member Functions

virtual | ~CXTPThemeDLL ()
Destructor, handles cleanup and deallocation.
BOOL | Init (HINSTANCE hAppInstance=NULL, LPCTSTR lpszDllPath=NULL)
This member function is called to load the style DLL's from the specified path.
BOOL | SetHandle (CString strINI)
Sets the handle to the resource DLL used for Codejock themes.
void | Reset ()
Resets all properties of ResourceImages.

Detailed Description

CXTPThemeDLL is a helper class used to load Codejock theme resource DLLs.

Use XTPThemeDLL() to access the meembers of this class.

See also
XTPThemeDLL()

Member Function Documentation

◆ Init()

BOOL Init | ( | HINSTANCE | hAppInstance = NULL,
 |  | LPCTSTR | lpszDllPath = NULL )

This member function is called to load the style DLL's from the specified path.

If 'lpszDllPath' is NULL then the application folder + \Styles path is used as a default.

Parameters
hAppInstance | Instance of application who's path will be used to locate the 'Styles' folder. Can be NULL when using 'lpszDllPath'.
lpszDllPath | Path where Codejock theme DLL's are located.
Returns
TRUE if one or more of the Codejock theme DLL's were located, otherwise FALSE.

◆ SetHandle()

BOOL SetHandle ( CString strINI )

Sets the handle to the resource DLL used for Codejock themes.

Parameters
strINI Name of the INI file to be loaded from the resource DLL.
Returns
TRUE if the handle was successfully set, otherwise FALSE.
See also
See XTPResourceImage.h for a list of constants you can use for strINI.
The documentation for this class was generated from the following file:
  • XTPThemeDLL.h


Toolkit Pro: CXTPThreadLocal< T > Class Template Reference

Public Types | Public Member Functions | List of all members
CXTPThreadLocal< T > Class Template Reference

Implements thread local variable adapter. More...

Inheritance diagram for CXTPThreadLocal< T >:
[legend]

Public Types

typedef T *(AFX_CDECL *) | CreateProc()
A custom object instance allocation and initialization callback type.
typedef void(AFX_CDECL *) | DestroyProc(T *)
A custom object instance destruction and deallocation callback type.

Public Member Functions

CXTPThreadLocal (CreateProc pfnCreate=DefaultProcs::Create, DestroyProc pfnDestroy=DefaultProcs::Destroy)
Construct adapter only, no thread local variable is constructed.
~CXTPThreadLocal ()
Deallocates all thread local variables.
BOOL | IsValid () const
Checks if an adapter is valid and can create thread local variables.
void | Reset (BOOL bCurrentThread=FALSE)
Resets and destroys allocated object either for the current thread or all threads that use the object.
T & | operator* ()
Gives access to a variable accessible only to the caller's thread.
const T & | operator* () const
Gives access to a variable accessible only to the caller's thread.

Detailed Description

template<class T>
class CXTPThreadLocal< T >

Implements thread local variable adapter.

By default it is assumed that the type of the adaptee is default constructible and can be destroyed using the delete operator, otherwise the custom object creation and destruction callbacks must be provided. Parameter: T - Type of thread local variable.

See also
XTPTlsAllocate, XTPTlsSetValue, XTPTlsGetValue, XTPTlsFree

Constructor & Destructor Documentation

◆ CXTPThreadLocal()

template<class T >
CXTPThreadLocal | ( | CreateProc | pfnCreate = DefaultProcs::Create,
 |  | DestroyProc | pfnDestroy = DefaultProcs::Destroy )

Construct adapter only, no thread local variable is constructed.

Parameters
pfnCreate | A custom object instance allocation and initialization callback pointer. If not specified then the default implementation is used.
pfnDestroy | A custom object instance destruction and deallocation callback pointer. If not specified then the default implementation is used.

Member Function Documentation

◆ IsValid()

template<class T >
BOOL IsValid ( ) const

Checks if an adapter is valid and can create thread local variables.

Returns
TRUE if the adapter is valid.

◆ operator*() [1/2]

template<class T >
T & operator* ( )

Gives access to a variable accessible only to the caller's thread.

If accesses occur for the first time during a thread's execution, then a new variable is allocated.

Returns
A reference to a thread local variable.

◆ operator*() [2/2]

template<class T >
const T & operator* ( ) const

Gives access to a variable accessible only to the caller's thread.

If accesses occur for the first time during a thread's execution, then a new variable is allocated.

Returns
A reference to a thread local variable.

◆ Reset()

template<class T >
void Reset ( BOOL bCurrentThread = FALSE )

Resets and destroys allocated object either for the current thread or all threads that use the object.

Parameters
bCurrentThread If TRUE then the current thread specific object will be reset, otherwise all previously created objects for all threads will be reset.
The documentation for this class was generated from the following file:
  • XTPSystemHelpers.h


Toolkit Pro: CXTPTimeEdit Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPTimeEdit Class Reference

CXTPTimeEdit is a CXTPDateEdit derived class. More...

Inheritance diagram for CXTPTimeEdit:
[legend]

Public Member Functions

CXTPTimeEdit ()
Constructs a CXTPTimeEdit object.
virtual void | SetHours (int nHours)
This member function will update the hours displayed.
virtual void | SetMins (int nMins)
This member function will update the minutes displayed.
virtual void | SetTime (int nHours, int nMins)
This member function will update the hours and minutes that are displayed for the time edit control.
int | GetHours () const
This member function will retrieve the hours displayed for the time edit control.
int | GetMins () const
This member function will retrieve the minutes displayed for the time edit control.
virtual BOOL | ProcessMask (TCHAR &nChar, int nEndPos)
This member function is used internally to process the character passed in by 'nChar' whose index is specified by 'nEndPos'.
virtual void | FormatOleDateTime (CString &strData, COleDateTime dt)
This member function will read the time passed in as 'dt', and format the 'strData' string as HH:MM.
void | SetMilitary (BOOL bMilitary=TRUE)
Sets military time format.
- Public Member Functions inherited from CXTPDateEdit
CXTPDateEdit ()
Constructs a CXTPDateEdit object.
virtual void | SetDateTime (COleDateTime &dt)
This member function will set the time based on the text string passed in as 'strDate'.
virtual void | SetDateTime (LPCTSTR strDate)
This member function will set the time based on the text string passed in as 'strDate'.
virtual COleDateTime | GetDateTime ()
This member function will retrieve a COleDateTime object that represents the currently displayed date.
virtual CString | GetWindowDateTime ()
This member function will retrieve a CString object that represents the currently displayed date.
virtual COleDateTime | ReadOleDateTime (LPCTSTR lpszData)
This member function will read the date string passed in as 'lpszData', convert it to a COleDateTime object, and return this COleDateTime object.
- Public Member Functions inherited from CXTPMaskEdit
CXTPMaskEdit ()
Constructs a CXTPMaskEdit object.
virtual bool | Initialize (CWnd *pParentWnd)
Initializes the CXTPMaskEdit control.
- Public Member Functions inherited from CXTPEdit
CXTPEdit ()
Constructs a CXTPEdit object.
virtual | ~CXTPEdit ()
Destroys a CXTPEdit object, handles cleanup and deallocation.
BOOL | SetEditMask (LPCTSTR lpszMask, LPCTSTR lpszLiteral, LPCTSTR lpszDefault=NULL)
This member function will set the mask for the edit control.
void | SetPattern (LPCTSTR lpszPattern)
Call this member function to set the pattern for the edit mask.
virtual BOOL | CanPaste ()
Call this member function to determine if the Clipboard contains information that can be pasted into this edit view.
BOOL | HasSelection () const
Call this member function to determine if a selection has been made.
void | AdjustBuddyRect (CWnd *pBuddy, CRect &rcUpDown, int nAlignment)
Called by the framework to adjust the size of the area to draw the buddy control borders on.
void | DrawBuddyBorders (CWnd *pBuddy, CDC *pDC, CRect rc, int nAlignment)
Called by the framework to draw the borders for the associated buddy window.
virtual void | RefreshMetrics ()
This member is called to update the color, text and other visual elements of the control.
virtual void | SetTheme (XTPControlTheme nTheme)
Call this member to switch the visual theme of the control.
XTPControlTheme GetThemeID ()
Call this member function to get the style for the theme.
CXTPEditTheme * GetTheme ()
Call this member to retrieve a pointer to the current theme.
BOOL | GetFlatStyle () const
Gets the flat style appearance of the button control.
void | SetFlatStyle (BOOL bFlatStyle=TRUE)
Sets the flat style appearance of the button control.
BOOL | GetUseVisualStyle () const
Determines if the control is drawn using visual styles/SkinFramework, if supported.
void | SetUseVisualStyle (BOOL bUseVisualStyle=TRUE)
Enables Windows XP visual styles for the control.
BOOL | IsPatternValid ()
Called by the framework to determine if the pattern set using SetPattern() is valid.
void | ShowThemedBorder (BOOL bShowThemedBorder)
Call this member function to enable/disable theme border display.
BOOL | IsHighlighted () const
Call this member function to determine if the edit state is highlighted, meaning that the mouse cursor is currently hovering over the control.
BOOL | IsFocused () const
Call this member function to determine if the edit-box has input focus.
BOOL | IsFlatStyle () const
Gets the flat style appearance of the edit control.
BOOL | ShowBorder () const
Call this member to determine if non-client borders are displayed.
- Public Member Functions inherited from CXTPMaskEditT< CEdit >
CXTPMaskEditT ()
Constructs a CXTPMaskEditT object.
void | SetUseMask (BOOL bUseMask)
Call this member function to enable or disable the mask for the mask edit control.
BOOL | CanUseMask () const
This member function is called to determine if the mask for the edit control can be used.
void | SetOverType (BOOL bOverType)
This member function is called to enable or disable type over, also known as insert mode.
BOOL | CanOverType () const
This member function is called to determine if type over has been enabled.
BOOL | PosInRange (int iPos) const
This member function is called to determine if the index specified by 'iPos' is a valid index for the currently displayed edit text.
TCHAR | GetPromptChar () const
This member function retrieves the character that is currently used as the mask prompt.
CString | GetPromptString (int nLength) const
This helper member function retrieves the string contains nLength prompt characters.
void | SetPromptChar (TCHAR ch, BOOL bAutoReplace=TRUE)
This member function is called to set the prompt character that is displayed to the user that indicates the field can be edited.
afx_msg BOOL | MaskCut ()
This member function is called to perform a cut operation using the currently selected text.
afx_msg BOOL | MaskCopy ()
This member function is called to perform a copy operation using the currently selected text.
void | MaskReplaceSel (LPCTSTR lpszNewText)
This member function is called to perform a replace operation using the currently selected text.
afx_msg BOOL | MaskPaste ()
This member function is called to perform a paste operation using the current clipboard text.
void | MaskDeleteSel ()
This member function is called to delete the selection.
afx_msg BOOL | MaskClear ()
This member function is called to clear the current text selection.
afx_msg BOOL | MaskUndo ()
This member function is called to undo the previous action.
afx_msg void | MaskSelectAll ()
This member function is called to select all text in the mask edit control.
BOOL | IsModified () const
This member function is called to determine if the text has been modified.
void | SetMaskedText (LPCTSTR lpszMaskedText, int iPos=0, BOOL bUpdateWindow=TRUE)
This method called to set masked text for the edit control.
TCHAR | ConvertUnicodeAlpha (TCHAR nChar, BOOL bUpperCase) const
Converts character to Upper/Lower case.
virtual BOOL | CheckChar (TCHAR &nChar, int nPos)
This member function is used internally to validate the character indicated by 'nChar'.
virtual BOOL | PreTranslateMessage (MSG *pMsg)
Used by class CWinApp to translate window messages before they are dispatched to theTranslateMessage andDispatchMessage Windows functions.
void | DeleteCharAt (int iPos)
Deletes character in specified position.
void | InsertCharAt (int iPos, TCHAR nChar)
Inserts character to specified position.
BOOL | CopyToClipboard (const CString &strText)
Copies text to system clipboard.
CString | GetMaskedText (int nStartPos=0, int nEndPos=-1) const
Retrieves masked text of the control.

Protected Attributes

int | m_iHours
Represents the hours to display.
int | m_iMins
Represents the minutes to display.
BOOL | m_bMilitary
true if military time is used.
- Protected Attributes inherited from CXTPEdit
CXTPEditTheme * | m_pTheme
Pointer to the current edit theme.
BOOL | m_bPreSubclassInit
TRUE if the control has been subclassed.
BOOL | m_bShowBorder
TRUE if non-client borders are displayed.
BOOL | m_bHighlighted
TRUE when the mouse is hovering over the control.
BOOL | m_bFocused
TRUE when the control has input focus.
CXTPRegExp * | m_pRegExp
Pointer to the CXTPRegExp object for this control.
- Protected Attributes inherited from CXTPMaskEditT< CEdit >
int | m_nStartChar
Current position of the first character in the current selection.
int | m_nEndChar
Current position of the first non-selected character past the end of the current selection.
BOOL | m_bUseMask
TRUE to use the edit mask.
BOOL | m_bOverType
TRUE to over type the text, set with VK_INSERT key press.
BOOL | m_bRedo
TRUE to redo, or FALSE to undo.
BOOL | m_bModified
TRUE if mask edit has been modified.
TCHAR | m_chPrompt
Prompt character used to identify the text entry.
CString | m_strMask
Buffer that holds the actual edit mask value.
CString | m_strDefault
Contains the edit controls default display text.
CString | m_strUndoBuffer
Holds the contents of the undo buffer.
CString | m_strRedoBuffer
Holds the contents of the redo buffer.
CString | m_strWindowText
Buffer that holds the actual edit text.
CString | m_strLiteral
Literal format that restricts where the user can enter text.
BOOL | m_bUpdateUndo
TRUE to update undo.

Additional Inherited Members

- Protected Member Functions inherited from CXTPEdit
HBRUSH | GetClientBrush (CDC *pDC)
Retrieves a handle to the client background brush.
void | RedrawEdit ()
Called by the framework to redraw the edit control.
void | RedrawFocusedFrame ()
Called by the framework to redraw the focus rectangle for the edit control.
- Protected Member Functions inherited from CXTPMaskEditT< CEdit >
virtual BOOL | OnCommand (WPARAM wParam, LPARAM lParam)
The framework calls this member function when the user selects an item from a menu.

Detailed Description

CXTPTimeEdit is a CXTPDateEdit derived class.

It is specifically geared toward editing time fields.

Member Function Documentation

◆ FormatOleDateTime()

virtual void FormatOleDateTime | ( | CString & | strData,
 |  | COleDateTime | dt )
 virtual

This member function will read the time passed in as 'dt', and format the 'strData' string as HH:MM.

Parameters
strData | String reference that is filled with the time.
dt | COleDateTime object that represents the time to format.

Reimplemented from CXTPDateEdit.

◆ GetHours()

int GetHours ( ) const

This member function will retrieve the hours displayed for the time edit control.

Returns
An integer value that represents the hours displayed.

◆ GetMins()

int GetMins ( ) const

This member function will retrieve the minutes displayed for the time edit control.

Returns
An integer value that represents the minutes displayed.

◆ ProcessMask()

virtual BOOL ProcessMask | ( | TCHAR & | nChar,
 |  | int | nEndPos )
 virtual

This member function is used internally to process the character passed in by 'nChar' whose index is specified by 'nEndPos'.

Parameters
nChar | Contains the character code value of the key.
nEndPos | Index of the character in the display string.
Returns
true if successful, otherwise false.

Reimplemented from CXTPDateEdit.

◆ SetHours()

virtual void SetHours ( int nHours )
virtual

This member function will update the hours displayed.

Parameters
nHours The new hours to be displayed.

◆ SetMilitary()

void SetMilitary ( BOOL bMilitary = TRUE )

Sets military time format.

Parameters
bMilitary true to use military time.

◆ SetMins()

virtual void SetMins ( int nMins )
virtual

This member function will update the minutes displayed.

Parameters
nMins The new minutes to be displayed.

◆ SetTime()

virtual void SetTime | ( | int | nHours,
 |  | int | nMins )
 virtual

This member function will update the hours and minutes that are displayed for the time edit control.

Parameters
nHours | The new hours to be displayed.
nMins | The new minutes to be displayed.
The documentation for this class was generated from the following file:
  • XTPMaskEdit.h


Toolkit Pro: CXTPTipOfTheDay Class Reference

Public Member Functions | Public Attributes | Protected Attributes | List of all members
CXTPTipOfTheDay Class Reference

CXTPTipOfTheDay is a CDialog derived class. More...

Public Member Functions

CXTPTipOfTheDay (LPCTSTR lpszTipFile=NULL, CWnd *pParent=NULL)
Constructs a CXTPTipOfTheDay object.
virtual | ~CXTPTipOfTheDay ()
Destroys a CXTPTipOfTheDay object, handles cleanup and deallocation.
virtual void | SetDefaultFonts (CFont *pFontTitle, CFont *pFontTip)
This member function will set the fonts to be used by the "Did you know..." and the Tip Of The Day text.
virtual void | GetNextTipString (CString &strNext)
This member function will retrieve the next string to be displayed as the Tip Of The Day.
virtual void | SetDefaultTitle (LPCTSTR lpszTitle)
This member function will set the text that is to be displayed in place of the "Did you know..." string.
virtual void | SetTipsFilePath (LPCTSTR lpszTipFile)
This member function will set the path to where the tips file is located.
void | AddTip (LPCTSTR lpszTip)
Call this method to add all tips manually.
void | SetTipText (LPCTSTR lpszText)
Call this member function to set the tip text.
void | EnableMarkup (BOOL bEnable)
Call this method to enable markup for tab captions.
CXTPMarkupContext * | GetMarkupContext () const
Call this method to get the Markup element that renders the item.

Public Attributes

BOOL m_bClassicStyle
Classic Style.

Protected Attributes

FILE * | m_pStream
A pointer to the open file stream.
CRect | m_rcBorder
Size of the total display area.
CRect | m_rcTipText
Size of the display area for tip text.
CXTPFont | m_xtpFontTitle
Default font used for "Did you know..." text.
CXTPFont | m_xtpFontTip
Default font used for tips.
CFont * | m_pFontTitle
User-defined font for "Did you know..." text.
CFont * | m_pFontTip
User-defined font for tips.
CString | m_strTipTitle
Represents the "Did you know" text.
CString | m_strTipText
Represents the Tip Of The Day text.
CString | m_strTipFile
Represents the file name and path for the tips file.
CXTPImageManagerIcon * | m_pLightBulbIcon
Bulb bitmap.
CXTPMarkupContext * | m_pMarkupContext
Markup Context.
CXTPMarkupUIElement * | m_pMarkupTipText
Markup element.
CStringArray | m_arrTips
Array of tips to display.
UINT | m_nNextTip
Index of next tip to display.

Detailed Description

CXTPTipOfTheDay is a CDialog derived class.

CXTPTipOfTheDay is used to create a Visual Studio(tm) style Tip Of The Day dialog. To use, place a file called "tips.txt" in the same directory as your application .exe. Place each tip on its own line.

Constructor & Destructor Documentation

◆ CXTPTipOfTheDay()

CXTPTipOfTheDay | ( | LPCTSTR | lpszTipFile = NULL,
 |  | CWnd * | pParent = NULL )

Constructs a CXTPTipOfTheDay object.

Parameters
lpszTipFile | A NULL-terminated string that represents the path and file name of where the tips text file is located. By default, the file name is set to "tips.txt".
pParent | Pointer to the parent window for the Tip Of The Day Dialog.

Member Function Documentation

◆ AddTip()

void AddTip ( LPCTSTR lpszTip )

Call this method to add all tips manually.

Parameters
lpszTip Next tooltip to add.

◆ EnableMarkup()

void EnableMarkup ( BOOL bEnable )

Call this method to enable markup for tab captions.

Parameters
bEnable TRUE to enable markup.

◆ GetMarkupContext()

CXTPMarkupContext * GetMarkupContext ( ) const

Call this method to get the Markup element that renders the item.

Returns
A pointer to a CXTPMarkupContext object.

◆ GetNextTipString()

virtual void GetNextTipString ( CString & strNext )
virtual

This member function will retrieve the next string to be displayed as the Tip Of The Day.

Parameters
strNext A CString reference that represents the next Tip Of The Day text that is to be displayed.

◆ SetDefaultFonts()

virtual void SetDefaultFonts | ( | CFont * | pFontTitle,
 |  | CFont * | pFontTip )
 virtual

This member function will set the fonts to be used by the "Did you know..." and the Tip Of The Day text.

Parameters
pFontTitle | Pointer to a CFont object that represents the new font to be used for the "Did you know..." text.
pFontTip | Pointer to a CFont object that represents the new font to be used for the Tip Of The Day text.

◆ SetDefaultTitle()

virtual void SetDefaultTitle ( LPCTSTR lpszTitle )
virtual

This member function will set the text that is to be displayed in place of the "Did you know..." string.

Parameters
lpszTitle Represents a NULL-terminated string that is the string to be displayed in place of the "Did you know..." text.

◆ SetTipsFilePath()

virtual void SetTipsFilePath ( LPCTSTR lpszTipFile )
virtual

This member function will set the path to where the tips file is located.

Parameters
lpszTipFile A NULL-terminated string that represents the full path to where the tips text file is located.

◆ SetTipText()

void SetTipText ( LPCTSTR lpszText )

Call this member function to set the tip text.

Parameters
lpszText A NULL-terminated string that represents the new tip text to display.
The documentation for this class was generated from the following file:
  • XTPTipOfTheDay.h


Toolkit Pro: CXTPTipWindow Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPTipWindow Class Reference

CXTPTipWindow is a CWnd derived class. More...

Public Member Functions

CXTPTipWindow ()
Constructs a CXTPTipWindow object.
virtual | ~CXTPTipWindow ()
Destroys a CXTPTipWindow object, handles cleanup and deallocation.
virtual BOOL | Create (CWnd *pParentWnd)
Call this member function to create the tooltip window.
void | SetTipOffsetPos (CPoint pointOffset)
Call this member function to offset the tip window by the distance specified by pointOffset.
void | HideTipWindow ()
Call this member function to hide the tip window.
void | SetTextTabStopPositions (LPINT pnTabStopPositions, int nTabPositions)
Call this member function to set the text tab stop positions for the tooltip window.
void | SetTipText (LPCTSTR lpszTitle, LPCTSTR lpszDescrip, BOOL bRedraw=FALSE)
This member function will set the text for the title and description values that are displayed in the tip window.
void | SetTipColors (COLORREF crBackColor, COLORREF crTextColor, BOOL bRedraw=FALSE)
This member function will set the text and background colors for the tip window display.
virtual BOOL | ShowTipWindow (const CPoint &point, DWORD dwTipStyle=TWS_XTP_DROPSHADOW, UINT nDelay=0, UINT nElapse=5000, BOOL bCenterHorz=FALSE)
This member function will display a tip window to display a title and description text.
virtual BOOL | ShowTipWindow (const CRect &rectCtrl, const CPoint &pointMousePos, DWORD dwTipStyle=TWS_XTP_DROPSHADOW, UINT nDelay=0, UINT nElapse=5000, BOOL bCenterHorz=FALSE, BOOL bShowTipAtCursorPos=FALSE)
This member function will display a tip window to display a title and description text.
void | SetMargins (CSize size)
This member function will set the text margins for the tip window.
void | SetLineSpace (int nLineSpace)
This member function will set the text line spacing for the tip window.

Protected Member Functions

void | DrawShadowRect (CDC *pDC, const CRect &rect)
This member function will draw a shadow rect to the device context specified by 'pDC'.
virtual void | InitializeSize (const CPoint &point, BOOL bCenterHorz=FALSE)
This member function will set the sizes for the tip window.
void | ForwardMessage (UINT uiMsg, UINT nFlags, CPoint point)
Forwards a message to the window at a specified cursor position.
void | CreateShadow ()
Updates style to show system shadow.

Protected Attributes

int | m_nLineSpace
Amount in pixels to space the title and description text.
int | m_nTabPositions
Specifies the number of tab-stop positions in the array pointed to by m_pnTabStopPositions.
UINT | m_nElapseTimerEventID
Elapse timer event ID.
UINT | m_nDelayTimerEventID
Delay timer event ID.
BOOL | m_bDelayTimerRunning
TRUE if the delay timer is running.
BOOL | m_bCenterHorz
TRUE if the window is to be centered horizontally.
LPINT | m_pnTabStopPositions
Pointer to an array of integers containing the tab-stop positions in logical units.
DWORD | m_dwTipStyle
Initial style for the tip window.
COLORREF | m_crBackColor
Background color for the tip window.
COLORREF | m_crTextColor
Text color for the tip window.
CRect | m_rcWindow
Initial size of the tip window.
CRect | m_rcScreenWindow
Initial size of the desktop.
CRect | m_rcShadow
Initial size of the tip window shadow.
CRect | m_rectTipArea
Size of the client area for the tip window.
CPoint | m_pointTipOffsetPos
Specifies the offset to move the top window in relation to the mouse cursor.
CPoint | m_ptMousePos
Initial x- and y- coordinates of the cursor when when tip window was created.
CWnd * | m_pParentWnd
Points to the parent window.
CSize | m_sizeMargin
Amount in pixels of the tip and side margins of where the tip text is displayed.
CSize | m_sizeTitle
Title text size.
CString | m_strTitle
Title text for the tip window.
CString | m_strDescrip
Description text for the tip window.
CStringArray | m_arStrings
Stores strings if the tip is multiline.

Detailed Description

CXTPTipWindow is a CWnd derived class.

It is used to create a CXTPTipWindow object. CXTPTipWindow objects are tooltip style pop-up windows that can display useful information to the end user. Possible options include shadows, borders, and background color settings.

Member Function Documentation

◆ Create()

virtual BOOL Create ( CWnd * pParentWnd )
virtual

Call this member function to create the tooltip window.

Parameters
pParentWnd Pointer to the parent of the tooltip window.
Returns
TRUE if successful, otherwise FALSE.

◆ DrawShadowRect()

void DrawShadowRect | ( | CDC * | pDC,
 |  | const CRect & | rect )
 protected

This member function will draw a shadow rect to the device context specified by 'pDC'.

Parameters
pDC | Device context of the window to cast the shadow on.
rect | Reference to a CRect object that represents the initial size of the shadow.

◆ ForwardMessage()

void ForwardMessage | ( | UINT | uiMsg,
 |  | UINT | nFlags,
 |  | CPoint | point )
 protected

Forwards a message to the window at a specified cursor position.

Parameters
uiMsg | Specifies the message to be sent.
nFlags | Indicates whether various virtual keys are down. See Remarks section for a list of values.
point | The x- and y- coordinates of the window to send the message to.

The nFlags parameter can be any combination of the following values:

MK_CONTROL: Set if the CTRL key is down. MK_LBUTTON: Set if the left mouse button is down. MK_MBUTTON: Set if the middle mouse button is down. MK_RBUTTON: Set if the right mouse button is down. MK_SHIFT: Set if the SHIFT key is down. This member function is called by the CXTPTipWindow object to hide the tip window and forward the message specified by uiMsg to the window at the coordinates specified by point.

◆ InitializeSize()

virtual void InitializeSize | ( | const CPoint & | point,
 |  | BOOL | bCenterHorz = FALSE )
 protectedvirtual

This member function will set the sizes for the tip window.

Parameters
point | The x- and y- coordinates of where the tip window is to be displayed.
bCenterHorz | TRUE to horizontally center the window position.

◆ SetLineSpace()

void SetLineSpace ( int nLineSpace )

This member function will set the text line spacing for the tip window.

Parameters
nLineSpace Initial size for the text line spacing.

◆ SetMargins()

void SetMargins ( CSize size )

This member function will set the text margins for the tip window.

Parameters
size Initial size for the horizontal and vertical text margins.

◆ SetTextTabStopPositions()

void SetTextTabStopPositions | ( | LPINT | pnTabStopPositions,
 |  | int | nTabPositions )

Call this member function to set the text tab stop positions for the tooltip window.

Parameters
pnTabStopPositions | Pointer to an integer array containing the tab stop positions (could be a static array).
nTabPositions | Number of array elements.

◆ SetTipColors()

void SetTipColors | ( | COLORREF | crBackColor,
 |  | COLORREF | crTextColor,
 |  | BOOL | bRedraw = FALSE )

This member function will set the text and background colors for the tip window display.

Parameters
crBackColor | An RGB color value to be used for the background of the tip window.
crTextColor | An RGB color value to be used for the text of the tip window.
bRedraw | If TRUE, then the tip window will be redrawn.

◆ SetTipOffsetPos()

void SetTipOffsetPos ( CPoint pointOffset )

Call this member function to offset the tip window by the distance specified by pointOffset.

Parameters
pointOffset A CPoint object that represents the XY offset.

◆ SetTipText()

void SetTipText | ( | LPCTSTR | lpszTitle,
 |  | LPCTSTR | lpszDescrip,
 |  | BOOL | bRedraw = FALSE )

This member function will set the text for the title and description values that are displayed in the tip window.

Parameters
lpszTitle | A NULL-terminated string that is to be displayed as the title for the tip window.
lpszDescrip | A NULL-terminated string that is to be displayed as the description text for the tip window.
bRedraw | If TRUE, then the tip window will be redrawn.

◆ ShowTipWindow() [1/2]

virtual BOOL ShowTipWindow | ( | const CPoint & | point,
 |  | DWORD | dwTipStyle = TWS_XTP_DROPSHADOW,
 |  | UINT | nDelay = 0,
 |  | UINT | nElapse = 5000,
 |  | BOOL | bCenterHorz = FALSE )
 virtual

This member function will display a tip window to display a title and description text.

Parameters
point | The initial x- and y- coordinates of where the tip window is to be displayed.
dwTipStyle | Initial style for the tip window. See the Remarks section for the styles that can be used with the tip window.
nDelay | Specifies the delay value in milliseconds of when the tip window should show.
nElapse | Specifies the time-out value in milliseconds of when the tip window should close.
bCenterHorz | Set this parameter to 'true' to center the window horizontally on the point passed in.
Returns
TRUE if the tip window was successfully created, otherwise FALSE.

Styles to be added or removed can be combined by using the bitwise OR (|) operator. It can be one or more of the following:

TWS_XTP_THICKBORDER: This style will cause the tip window to display a thick border around its edges. TWS_XTP_DROPSHADOW: This style will cause the tip window to cast a shadow on the parent window. TWS_XTP_ALPHASHADOW: Used with TWS_XTP_DROPSHADOW to display an alpha style shadow. By default, mono-shadowing is enabled.

◆ ShowTipWindow() [2/2]

virtual BOOL ShowTipWindow | ( | const CRect & | rectCtrl,
 |  | const CPoint & | pointMousePos,
 |  | DWORD | dwTipStyle = TWS_XTP_DROPSHADOW,
 |  | UINT | nDelay = 0,
 |  | UINT | nElapse = 5000,
 |  | BOOL | bCenterHorz = FALSE,
 |  | BOOL | bShowTipAtCursorPos = FALSE )
 virtual

This member function will display a tip window to display a title and description text.

Parameters
rectCtrl | Reference to a CRect object that represents the size of the control window where the tip is displayed.
pointMousePos | Reference to a CPoint object that represents the XY position of the mouse cursor.
dwTipStyle | Initial style for the tip window. See the Remarks section for the styles that can be used with the tip window.
nDelay | Specifies the delay value in milliseconds of when the tip window should show.
nElapse | Specifies the time-out value in milliseconds of when the tip window should close.
bCenterHorz | Set this parameter to 'true' to center the window horizontally on the point passed in.
bShowTipAtCursorPos | TRUE to show the tip at the cursor position.
Returns
TRUE if the tip window was successfully created, otherwise FALSE.

Styles to be added or removed can be combined by using the bitwise OR (|) operator. It can be one or more of the following:

TWS_XTP_THICKBORDER: This style will cause the tip window to display a thick border around its edges. TWS_XTP_DROPSHADOW: This style will cause the tip window to cast a shadow on the parent window. TWS_XTP_ALPHASHADOW: Used with TWS_XTP_DROPSHADOW to display an alpha style shadow. By default, mono-shadowing is enabled.

Member Data Documentation

◆ m_dwTipStyle

DWORD m_dwTipStyle
protected

Initial style for the tip window.

See ShowTipWindow(..).

◆ m_pnTabStopPositions

LPINT m_pnTabStopPositions
protected

Pointer to an array of integers containing the tab-stop positions in logical units.

The tab stops must be sorted in increasing order; the smallest x-value should be the first item in the array. Back tabs are not allowed.

The documentation for this class was generated from the following file:
  • XTPTipWindow.h


Toolkit Pro: CXTPToolBar Class Reference

Public Member Functions | Static Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPToolBar Class Reference

CXTPToolBar is a CXTPCommandBar derived class. More...

Inheritance diagram for CXTPToolBar:
[legend]

Public Member Functions

CXTPToolBar ()
Constructs a CXTPToolBar object.
~CXTPToolBar ()
Destroys a CXTPToolBar object, handles cleanup and deallocation.
virtual void | SetVisible (BOOL bVisible)
Call this member to set the visibility of the toolbar.
virtual BOOL | IsVisible () const
Call this member to check the visibility of the toolbar.
BOOL | SetPosition (XTPBarPosition barPosition)
Call this member to set the position of the toolbar.
BOOL | LoadToolBar (UINT nIDResource, BOOL bLoadIcons=TRUE)
Call this member function to load the toolbar specified by nIDResource.
BOOL | CreateToolBar (DWORD dwStyle, CWnd *pParentWnd, UINT nID=AFX_IDW_TOOLBAR)
This method creates the ToolBar control.
void | GetBarInfo (CToolBarInfo *pInfo)
Retrieves bar information for serialization routines.
void | SetBarInfo (CToolBarInfo *pInfo)
Sets bar information.
virtual CSize | CalcDockingLayout (int nLength, DWORD dwMode, int nWidth=0)
This method calculates the dimensions of a toolbar.
virtual CSize | CalcDynamicLayout (int nLength, DWORD dwMode)
This method calculates the dimensions of a toolbar.
void | EnableDocking (DWORD dwFlags=xtpFlagAlignAny|xtpFlagFloating|xtpFlagHideWrap)
Call this method to set docking flags.
BOOL | IsBuiltIn () const
Determines if the toolbar is built-in.
CXTPDockBar * | GetDockBar () const
Retrieves the parent dock bar.
virtual void | Reset (BOOL bShowWarningMessage)
Resets the controls to their original state.
void | OnSetPreviewMode (BOOL bPreview)
Call this method to show/hide toolbars in preview mode.
BOOL | OnHookKeyDown (UINT nChar, LPARAM lParam)
The framework calls this member function when a non-system key is pressed.
void | SetContextMenuPresent (BOOL bPresent)
Call this method to show/hide the toolbar in a context menu.
BOOL | IsContextMenuPresent () const
Call this member to determine if this toolbar is included in the right-click context menu.
void | SetCustomizeDialogPresent (BOOL bPresent)
Call this method to show/hide the toolbar in a customize dialog.
BOOL | IsCustomizeDialogPresent () const
Call this member to determine if this toolbar is included in the customize dialog.
void | ModifyBarStyle (DWORD dwRemove, DWORD dwAdd)
Modifies the styles of the toolbar.
void | SetCloseable (BOOL bCloseable)
Call this method to enable/disable the closeable property of the command bar.
BOOL | IsCloseable () const
Call this method to retrieve the closeable property of the command bar.
BOOL | IsTemporary () const
Call this method to determine if the control is temporary.
void | SetTemporary (BOOL bTemporary)
Call this method to set the control to temporary.
void | ShowExpandButton (BOOL bShowExpandButton)
Call this method to show/hide the expand button of the toolbar.
void | OnRecalcLayout ()
This method recalculates the position of the toolbar.
BOOL | IsWindowVisible () const
Determines if the toolbar is visible on the screen.
- Public Member Functions inherited from CXTPCommandBar
int | IsTrackingMode () const
Call this member to get the tracking state.
CXTPControls * | GetControls () const
Call this member to get the controls collection.
void | SetControls (CXTPControls *pControls)
Call this member to set the controls collection of the command bar.
XTPBarType | GetType () const
Call this member to get the type of the command bar.
void | SetTextOrientation (XTPBarTextOrientation nTextOrientation)
Call this member to change text orientation.
XTPBarTextOrientation | GetTextOrientation () const
Call this member to get the text orientation.
XTPBarPosition | GetPosition () const
Call this member to get the position of the command bar.
void | DelayLayout ()
Call this member to recalculate the layout.
virtual void | DelayRedraw ()
Call this member to redraw the command bar.
virtual BOOL | SetTrackingMode (int bMode, BOOL bSelectFirst=TRUE, BOOL bKeyboard=FALSE)
Call this member to change the tracking state.
virtual BOOL | LoadMenu (CMenu *pMenu, BOOL bRemoveControls=TRUE)
Call this member to convert menu items to command bar controls.
CXTPControl * | GetControl (int nIndex) const
Call this member to return the control at the specified index.
int | GetControlCount () const
Call this member to get the count of the controls.
virtual BOOL | SetSelected (int nSelected, BOOL bKeyboard=FALSE)
Call this member to select the specified control.
CXTPControl * | GetSelected () const
Call this member to get the currently selected control.
BOOL | SetPopuped (int nPopuped, BOOL bKeyboard=FALSE)
Call this member to pop-up the specified control.
void | SetTitle (LPCTSTR lpszTitle)
Call this member to set a title for this command bar.
CString | GetTitle () const
Call this member to get a title for this command bar.
CXTPCommandBars * | GetCommandBars () const
Call this member to get the command bar's object.
void | SetCommandBars (CXTPCommandBars *pCommandBars)
Call this member to set the command bar's object.
CWnd * | GetSite () const
Call this member to get the command bar's site.
CFrameWnd * | GetFrameSite () const
Call this member to get the command bar's site as CFrameWnd.
void | SetFlags (DWORD dwFlagsAdd, DWORD dwFlagsRemove=0)
Call this member to set the command bar's flags.
BOOL | SetButtons (UINT *pButtons, int nCount)
Call this member to set the controls from the button array.
void | SetIconSize (CSize size)
Call this function to set the size of the actual bitmapped images to be added to a toolbar.
virtual CSize | GetIconSize () const
Call this member function to get the size of the toolbar icon.
CSize | GetLargeIconSize (BOOL bAutoSize) const
Call this method to get the large icon size of the toolbar.
void | SetButtonSize (CSize size)
Sets the size of the buttons in the command bar.
virtual CSize | GetButtonSize () const
Call this function to get the size of the command bar button.
void | ShowTextBelowIcons (BOOL bTextBelow=TRUE)
Call this member to show the caption below control's icon.
BOOL | IsTextBelowIcons () const
Checks whether the caption is below the control's icon.
virtual BOOL | Popup (CXTPControlPopup *pControlPopup, BOOL bSelectFirst=FALSE)
This method is called to pop-up the command bar.
HWND | GetTrackFocus () const
Call this method to retrieve the current focused control.
void | SetTrackFocus (HWND hwnd)
Call this method to set focus to the window.
int | FindAccel (TCHAR chAccel) const
Call this method to get the index of the control with the specified accelerator character.
int | FindAccelEx (UINT chAccel, BOOL &bSelectOnly) const
Call this method to get the index of the control with the specified accelerator character.
BOOL | IsCustomizeMode () const
Call this method to check if the command bars are in customize mode.
virtual DROPEFFECT | OnCustomizeDragEnter (CXTPControl *pDataObject, CPoint point)
This member is called when a control is entered into the command bar.
virtual void | OnCustomizeDragLeave ()
This method is called when a control leaves the command bar.
virtual DROPEFFECT | OnCustomizeDragOver (CXTPControl *pDataObject, CPoint point)
This member is called when control is over the command bar.
virtual void | OnCustomizeDrop (CXTPControl *pDataObject, DROPEFFECT &dropEffect, CPoint ptDrop, CPoint ptDrag)
This method is called when a control is dropped to the command bar.
virtual BOOL | IsCustomizable () const
Call this method to check if the command bar is customizable.
BOOL | IsCustomizeDialogPresent () const
Call this method to check if the command bar is present in Customize dialog.
void | EnableCustomization (BOOL bEnable=TRUE)
Call this method to enable/disable customization of the command bar.
virtual void | OnTrackLost ()
Call this method to remove the tracking state of the command bar.
virtual void | OnTrackEnter ()
Call this method to track the command bar.
CWnd * | GetOwnerSite () const
Call this method to retrieve the owner window of the command bar.
void | InvalidateParents ()
Call this method to redraw all parent command bars.
DWORD | GetFlags () const
Call this method to retrieve the current behavior modification flags of the command bar.
UINT | GetBarID () const
Call this method to retrieve the identifier of the command bar.
void | SetBarID (UINT nID)
Call this method to set the identifier of the command bar.
virtual void | OnControlSelected (BOOL bSelected, CXTPControl *pControl)
This method is called when a child control becomes selected.
BOOL | SetStatusText (const CString &strDescription)
This method is called to set the description context.
void | SetCommandBarData (DWORD_PTR dwData)
This method sets the 32-bit value associated with the command bar.
DWORD_PTR | GetCommandBarData () const
This method retrieves the application-supplied, 32-bit value associated with the command bar.
virtual CXTPCommandBar * | GetParentCommandBar () const
This method retrieves the parent command bar.
CXTPCommandBar * | GetRootParent () const
Call this method to retrieve the top-level parent command bar.
CXTPPaintManager * | GetPaintManager () const
Call this method to retrieve the paint manager.
CXTPImageManager * | GetImageManager () const
Call this method to retrieve the image manager.
void | SetWidth (int nWidth)
Call this member to set the width of the floated or pop-up toolbar.
int | GetWidth () const
Call this member to get the width of the floated or pop-up toolbar.
void | SetPaintManager (CXTPPaintManager *pPaintManager)
Call this member to set the specified paint manager.
void | SetImageManager (CXTPImageManager *pImageManager)
Call this member to set the specified image manager.
BOOL | IsLayoutRTL () const
Call this member function to determine if the command bar layout is Right-to-Left (RTL).
virtual BOOL | IsDialogBar () const
Call this member function to determine if the command bar is a CXTPDialogBar.
virtual BOOL | IsRibbonBar () const
Call this member function to determine if the command bar is a CXTPRibbonBar.
virtual BOOL | IsMenuTitleBar () const
Call this member function to determine if the command bar is a CXTPMenuTitleBar.
virtual BOOL | IsPopupBar () const
Call this member function to determine if the command bar is a CXTPPopupBar.
virtual BOOL | IsKeyboardCuesVisible () const
Determines if underlines are visible in the command bar control.
void | SetGrabFocus (BOOL bGrabFocus)
This method is called internally to prevent the command bar from grabbing edit focus.
virtual void | Redraw (LPCRECT lpRect=0, BOOL bAnimate=TRUE)
The framework calls this member function to redraw the command bar.
virtual void | DrawCommandBar (CDC *pDC, CRect rcClipBox)
This method is called to draw the command bar in the given context.
void | EnableAnimation (BOOL bEnable=TRUE)
Call this method to enable animation for the command bar.
void | EnableDoubleBuffer (BOOL bEnable=TRUE)
Call this method to enable double buffer for toolbar drawing.
BOOL | IsAnimationEnabled () const
Determines if animation is enabled for the specified command bar.
virtual int | OnHookMessage (HWND hWnd, UINT nMessage, WPARAM &wParam, LPARAM &lParam, LRESULT &lResult)
This member function is called by WindowProc, or is called during message reflection.
virtual void | EnsureVisible (CXTPControl *pControl)
Call this method to ensure that a specified control is visible on the toolbar.
XTPButtonStyle | GetDefaultButtonStyle () const
Call this method to retrieve the default button style of the command bar.
void | SetDefaultButtonStyle (XTPButtonStyle buttonStyle)
Call this method to set the default button style of the command bar.
void | LockRedraw ()
Call this method to freeze redrawing until UnlockRedraw is called.
void | UnlockRedraw ()
Call this method to unfreeze redrawing.
void | SetShowGripper (BOOL bShow)
Call this method to set the visibility of the command bar's gripper.
BOOL | GetShowGripper () const
Call this method to check if the command bar's gripper is visible.
virtual void | FillCommandBarEntry (CDC *pDC)
This method is called to draw the background of the command bar.
virtual BOOL | IsResizable () const
Specifies whether the pop-up gallery can be resized by the user.
BOOL | IsKeyboardTipsVisible () const
Call this method to check if keyboard tips are visible for the command bar.
virtual void | CreateKeyboardTips ()
This method is called to create a keyboard tips collection for the command bar.
void | OnKeyboardTipChar (UINT chAccel)
This method is called when the user presses a key while keyboard tips are visible.
virtual void | OnKeyboardTip (CXTPCommandBarKeyboardTip *pTip)
This method is called when a keyboard tip is found for the command bar.
void | HideKeyboardTips ()
Call this method to hide keyboard tips.
void | LockMouseMove (CXTPControl *pControl)
Locks the mouse cursor for a specified control.
void | UnlockMouseMove ()
Unlocks the mouse cursor.
- Public Member Functions inherited from CXTPHookManagerHookAble
CXTPHookManagerHookAble ()
Constructs a CXTPHookManagerHookAble object.
virtual | ~CXTPHookManagerHookAble ()
Destroys a CXTPHookManagerHookAble object, handles cleanup and deallocation.
virtual int | OnPostHookMessage (HWND hWnd, UINT nMessage, WPARAM &wParam, LPARAM &lParam, LRESULT &lResult)
This member function is called after a message has been processed by default window procedure.
virtual void | OnHookAttached (HWND hWnd)
This member function is called right after a hook is attached to the window.
virtual void | OnHookDetached ()
This member function is called right before a hook is to be detached from the window.

Static Public Member Functions

static BOOL AFX_CDECL DoUpdateCustomizeMenuControl (CXTPControl *pControl, CCmdTarget *pTarget)
Tries to update a Customize menu control.

Protected Member Functions

virtual BOOL | Create (CWnd *pParentWnd, BOOL bFloat)
Creates a toolbar.
virtual void | DoPropExchange (CXTPPropExchange *pPX)
Either reads this object from or writes this object to an archive.
virtual void | Copy (CXTPCommandBar *pCommandBar, BOOL bRecursive=FALSE)
This method makes a copy of the command bar.
virtual CRect | GetBorders ()
This method retrieves the borders of the toolbar.
virtual void | OnPaintManagerChanged ()
This method is called when the paint manager is changed.
virtual BOOL | ShouldSerializeBar ()
Call this method to check if the toolbar has changed and must be saved.
virtual void | MergeToolBar (CXTPCommandBar *pCommandBar, BOOL bSilent)
This method is called to restore a toolbar to a previous state.
virtual void | MergeToolBar (CXTPCommandBar *pCommandBar, BOOL bSilent, int nDefaultConfirmationChoice)
This method is called to restore a toolbar to a previous state.
- Protected Member Functions inherited from CXTPCommandBar
CXTPCommandBar ()
Constructs a CXTPCommandBar object.
virtual | ~CXTPCommandBar ()
Destroys a CXTPCommandBar object, handles cleanup and deallocation.
virtual BOOL | ProcessSpecialKey (XTPSpecialKey key)
This method is called to process special keys.
virtual void | OnControlsChanged ()
This method is called when the controls array is changed.
virtual int | OnMouseHitTest (CPoint pt)
This method is called to determine mouse hit code.
virtual void | UpdateShortcuts ()
Updates the control's shortcuts.
UINT | GetActiveDocTemplate () const
Retrieves the active MDI document template.
virtual void | GenerateCommandBarList (DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam)
This method is called to assign self identifiers for the serialization process.
virtual void | RestoreCommandBarList (CXTPCommandBarList *pCommandBarList)
This method is called in the serialization process to restore pop-ups from a list of command bars.
BOOL | IsHelpMode () const
Determines if the parent frame is in help mode.
virtual void | OnRemoved ()
This method is called when a toolbar is removed from the command bars collection.

Protected Attributes

CXTPDockBar * | m_pDockBar
Parent dock bar.
CXTPDockContext * | m_pDockContext
Docking context.
BOOL | m_bBuiltIn
TRUE if toolbar is built-in.
BOOL | m_bTearOff
TRUE if toolbar is tear-offed.
BOOL | m_bPreviewVisible
TRUE if Toolbar was visible in preview mode.
BOOL | m_bPreviewMode
TRUE if Toolbar was visible in preview mode.
BOOL | m_bTemporary
TRUE if Toolbar is temporary (If it will be saved when the CommandBar layout is saved.)
BOOL | m_bShowExpandButton
TRUE to show expand button of toolbar.
BOOL | m_bContextMenuPresent
TRUE if the command bar is present in context menu.
BOOL | m_bInRecalcLayout
TRUE if RecalcLayout method is called.
BOOL | m_bVisible
TRUE if the command bar is visible.
- Protected Attributes inherited from CXTPCommandBar
BOOL | m_bGrabFocus
TRUE to grab current focus.
int | m_nMRUWidth
Recent width.
int | m_nSelected
Selected control index.
int | m_nPopuped
Pop-up'ed control index.
HWND | m_hwndFocus
The handle of the window that currently has focus.
UINT | m_nBarID
Command bar's identifier.
BOOL | m_bTracking
TRUE if the command bar is in tracking mode.
CWnd * | m_pSite
Command bar's site.
DWORD | m_nIdleFlags
Idle flags.
DWORD | m_dwFlags
Command bar's flags.
DWORD | m_dwStyle
Command bar's styles.
CString | m_strTitle
Command bar's caption.
XTPBarType | m_barType
Type of the command bar.
CXTPControls * | m_pControls
A pointer to controls collection.
XTPBarPosition | m_barPosition
Position of the command bar.
CXTPCommandBars * | m_pCommandBars
parent command bars class.
CWnd * | m_pOwner
Owner window.
CSize | m_szIcons
Size of the command bar's icons.
CSize | m_szButtons
Size of the command bar's buttons.
BOOL | m_bTextBelow
TRUE if text is shown below the CommandBar buttons.
BOOL | m_bExecOnRButton
TRUE if the control button is executed on a right-click.
BOOL | m_bIgnoreUpdateHandler
TRUE to skip update handler for all child controls.
BOOL | m_bRecursePopup
TRUE if pop-up bar was opened recursively.
BOOL | m_bKeyboardSelect
TRUE if last item was selected by keyboard.
BOOL | m_bCloseable
TRUE if the CommandBar can be closed and-or Hidden.
BOOL | m_bCustomizable
TRUE if command bar is customizable.
CRect | m_rcMarker
Marker position.
BOOL | m_bVerticalMarker
TRUE to draw marker vertically.
DWORD_PTR | m_dwData
The 32-bit value associated with the command bar.
UINT * | m_pReturnCmd
Return command holder.
BOOL | m_bCustomizeDialogPresent
TRUE if the command bar is present in Customize dialog.
BOOL | m_bAnimatePopup
TRUE to animate pop-up bar.
BOOL | m_nLockRedraw
TRUE if all drawing routines skipped.
CXTPPaintManager * | m_pPaintManager
Selected paint manager for command bar.
CXTPImageManager * | m_pImageManager
Selected image manager for command bar.
BOOL | m_bMultiLine
True if multi line commandbar.
XTPButtonStyle | m_buttonStyle
Default button Style.
XTPBarTextOrientation | m_nTextOrientation
Commandbar text orientation.
CXTPToolTipContext * | m_pToolTipContext
Tool tip Context.
CXTPCommandBarAnimation * | m_pAnimation
Animation context.
CSize | m_szButtonSpacing
Spacing used between toolbar buttons.

Additional Inherited Members

- Public Attributes inherited from CXTPCommandBar
int | m_nStateFlags
State of the command bars.
BOOL | m_bComboBar
TRUE if it is combobox list.
BOOL | m_bTrackOnHover
TRUE to select item if mouse stay over control.
- Public Attributes inherited from CXTPHookManagerHookAble
BOOL | m_bAutoDestroy
TRUE to automatically delete hook.
- Static Public Attributes inherited from CXTPCommandBar
static int | s_nHoverDelay
Hover delay time.
static int | s_nExpandDelay
Expand delay time.
static int | s_nExpandHoverDelay
Expand hover delay.

Detailed Description

CXTPToolBar is a CXTPCommandBar derived class.

Member Function Documentation

◆ CalcDockingLayout()

virtual CSize CalcDockingLayout | ( | int | nLength,
 |  | DWORD | dwMode,
 |  | int | nWidth = 0 )
 virtual

This method calculates the dimensions of a toolbar.

Parameters
nLength | Length of the bar.
dwMode | Mode to dock.
nWidth | Width of the bar.
Returns
Size of the docked toolbar.

Reimplemented in CXTPDialogBar, and CXTPTabToolBar.

◆ CalcDynamicLayout()

virtual CSize CalcDynamicLayout | ( | int | nLength,
 |  | DWORD | dwMode )
 virtual

This method calculates the dimensions of a toolbar.

Parameters
nLength | The requested dimension of the control bar, either horizontal or vertical, depending on dwMode.
dwMode | Mode to dock.
Returns
Size of the docked toolbar.

Reimplemented from CXTPCommandBar.

Reimplemented in CXTPDialogBar, and CXTPTabToolBar.

◆ Copy()

virtual void Copy | ( | CXTPCommandBar * | pCommandBar,
 |  | BOOL | bRecursive = FALSE )
 protectedvirtual

This method makes a copy of the command bar.

Parameters
pCommandBar | Command bar to be copied.
bRecursive | TRUE to copy recursively.

Reimplemented from CXTPCommandBar.

Reimplemented in CXTPMenuBar.

◆ Create()

virtual BOOL Create | ( | CWnd * | pParentWnd,
 |  | BOOL | bFloat )
 protectedvirtual

Creates a toolbar.

Parameters
pParentWnd | Pointer to a CWnd object.
bFloat | TRUE to create a floating bar.
Returns
TRUE if successful; otherwise FALSE.

◆ CreateToolBar()

BOOL CreateToolBar | ( | DWORD | dwStyle,
 |  | CWnd * | pParentWnd,
 |  | UINT | nID = AFX_IDW_TOOLBAR )

This method creates the ToolBar control.

Parameters
dwStyle | Styles for the toolbars.
pParentWnd | Specifies the parent window of the TaskPanel control.
nID | Specifies the Toolbar control ID.
Returns
TRUE if successful; otherwise FALSE.

◆ DoPropExchange()

virtual void DoPropExchange ( CXTPPropExchange * pPX )
protectedvirtual

Either reads this object from or writes this object to an archive.

Parameters
pPX A CXTPPropExchange object to serialize to or from.

Reimplemented from CXTPCommandBar.

Reimplemented in CXTPMenuBar.

◆ DoUpdateCustomizeMenuControl()

static BOOL AFX_CDECL DoUpdateCustomizeMenuControl | ( | CXTPControl * | pControl,
 |  | CCmdTarget * | pTarget )
 static

Tries to update a Customize menu control.

Parameters
pControl | A pointer to the customize menu control.
pTarget | A pointer to the target command handler.
Returns
TRUE if the control has been updated, otherwise FALSE.

◆ EnableDocking()

void EnableDocking ( DWORD dwFlags = xtpFlagAlignAny|xtpFlagFloating|xtpFlagHideWrap )

Call this method to set docking flags.

Parameters
dwFlags Flags for docking. Can be any of the values listed in the Remarks section.

dwFlags parameter can be one or more of the following: xtpFlagAlignTop: Allows docking at the top of the client area. xtpFlagAlignBottom: Allows docking at the bottom of the client area. xtpFlagAlignLeft: Allows docking on the left side of the client area. xtpFlagAlignRight: Allows docking on the right side of the client area. xtpFlagFloating: Allows floating. xtpFlagHideWrap: Allows to hide wrapped controls. xtpFlagStretched: Indicates the bar is stretched.

◆ GetBarInfo()

void GetBarInfo ( CToolBarInfo * pInfo )

Retrieves bar information for serialization routines.

Parameters
pInfo Pointer to a CToolBarInfo object.

◆ GetBorders()

virtual CRect GetBorders ( )
protectedvirtual

This method retrieves the borders of the toolbar.

Returns
The borders of the toolbar.

Reimplemented from CXTPCommandBar.

Reimplemented in CXTPTabToolBar.

◆ GetDockBar()

AFX_INLINE CXTPDockBar * GetDockBar ( ) const

Retrieves the parent dock bar.

Returns
A pointer to a CXTPDockBar object.

◆ IsBuiltIn()

AFX_INLINE BOOL IsBuiltIn ( ) const

Determines if the toolbar is built-in.

Returns
TRUE if toolbar is built-in; otherwise FALSE.

◆ IsCloseable()

AFX_INLINE BOOL IsCloseable ( ) const

Call this method to retrieve the closeable property of the command bar.

Returns
TRUE if the command bar is closeable, otherwise FALSE.

◆ IsContextMenuPresent()

AFX_INLINE BOOL IsContextMenuPresent ( ) const

Call this member to determine if this toolbar is included in the right-click context menu.

Returns
TRUE if this toolbar is included in the right-click context menu, otherwise FALSE.

◆ IsCustomizeDialogPresent()

AFX_INLINE BOOL IsCustomizeDialogPresent ( ) const

Call this member to determine if this toolbar is included in the customize dialog.

Returns
TRUE if this toolbar is included in the customize dialog, otherwise FALSE.

◆ IsTemporary()

AFX_INLINE BOOL IsTemporary ( ) const

Call this method to determine if the control is temporary.

Temporary toolbars will not be saved to the system registry when the application is closed (If SaveCommandBars is used), and they will not be restored when the application is opened (If LoadCommandBars is used).

Returns
TRUE if the control is temporary.

◆ IsVisible()

virtual BOOL IsVisible ( ) const
inlinevirtual

Call this member to check the visibility of the toolbar.

Returns
A BOOL value. TRUE if the toolbar is visible, otherwise FALSE.

Reimplemented from CXTPCommandBar.

◆ IsWindowVisible()

BOOL IsWindowVisible ( ) const

Determines if the toolbar is visible on the screen.

Returns
TRUE if the toolbar is visible.
See also
IsVisible

◆ LoadToolBar()

BOOL LoadToolBar | ( | UINT | nIDResource,
 |  | BOOL | bLoadIcons = TRUE )
 virtual

Call this member function to load the toolbar specified by nIDResource.

Parameters
nIDResource | Resource ID of the toolbar to be loaded.
bLoadIcons | TRUE to load icons from application resources.
Returns
Nonzero if successful; otherwise 0.

Reimplemented from CXTPCommandBar.

◆ MergeToolBar() [1/2]

virtual void MergeToolBar | ( | CXTPCommandBar * | pCommandBar,
 |  | BOOL | bSilent )
 protectedvirtual

This method is called to restore a toolbar to a previous state.

Parameters
pCommandBar | Previously saved toolbar.
bSilent | TRUE to restore without warnings.
See also
ShouldSerializeBar

◆ MergeToolBar() [2/2]

virtual void MergeToolBar | ( | CXTPCommandBar * | pCommandBar,
 |  | BOOL | bSilent,
 |  | int | nDefaultConfirmationChoice )
 protectedvirtual

This method is called to restore a toolbar to a previous state.

Parameters
pCommandBar | Previously saved toolbar.
bSilent | TRUE to restore without warnings.
nDefaultConfirmationChoice | Default confirmation choice value.
See also
ShouldSerializeBar

◆ ModifyBarStyle()

AFX_INLINE void ModifyBarStyle | ( | DWORD | dwRemove,
 |  | DWORD | dwAdd )

Modifies the styles of the toolbar.

Parameters
dwRemove | Styles to remove.
dwAdd | Styles to add.

◆ OnHookKeyDown()

BOOL OnHookKeyDown | ( | UINT | nChar,
 |  | LPARAM | lParam )
 virtual

The framework calls this member function when a non-system key is pressed.

Parameters
nChar | Specifies the virtual key code of the given key.
lParam | Specifies additional message-dependent information.
Returns
TRUE if the key was handled, otherwise FALSE.

Reimplemented from CXTPCommandBar.

◆ OnSetPreviewMode()

void OnSetPreviewMode ( BOOL bPreview )

Call this method to show/hide toolbars in preview mode.

Parameters
bPreview TRUE to show toolbars in preview mode, FALSE to hide toolbars in preview mode.

◆ Reset()

virtual void Reset ( BOOL bShowWarningMessage )
virtual

Resets the controls to their original state.

Parameters
bShowWarningMessage TRUE to show warning message.

Reimplemented in CXTPMenuBar, CXTPRibbonBar, and CXTPTabToolBar.

◆ SetBarInfo()

void SetBarInfo ( CToolBarInfo * pInfo )

Sets bar information.

Parameters
pInfo Pointer to a CToolBarInfo object.

◆ SetCloseable()

AFX_INLINE void SetCloseable ( BOOL bCloseable )

Call this method to enable/disable the closeable property of the command bar.

Parameters
bCloseable TRUE to allow the command bar to be closed by the user.

◆ SetContextMenuPresent()

AFX_INLINE void SetContextMenuPresent ( BOOL bPresent )

Call this method to show/hide the toolbar in a context menu.

Parameters
bPresent TRUE to show the toolbar in a context menu.

◆ SetCustomizeDialogPresent()

AFX_INLINE void SetCustomizeDialogPresent ( BOOL bPresent )

Call this method to show/hide the toolbar in a customize dialog.

Parameters
bPresent TRUE to show the toolbar in a customize dialog.

◆ SetPosition()

BOOL SetPosition ( XTPBarPosition barPosition )
virtual

Call this member to set the position of the toolbar.

Parameters
barPosition New position of the toolbar.
Returns
TRUE if successful, otherwise FALSE.

Reimplemented from CXTPCommandBar.

◆ SetTemporary()

AFX_INLINE void SetTemporary ( BOOL bTemporary )

Call this method to set the control to temporary.

Parameters
bTemporary TRUE to set the control to temporary.

Temporary toolbars will not be saved to the system registry when the application is closed (If SaveCommandBars is used), and they will not be restored when the application is opened (If LoadCommandBars is used).

◆ SetVisible()

virtual void SetVisible ( BOOL bVisible )
virtual

Call this member to set the visibility of the toolbar.

Parameters
bVisible A BOOL value. TRUE to set the toolbar to visible, FALSE to hide the toolbar.

Reimplemented from CXTPCommandBar.

Reimplemented in CXTPRibbonBar.

◆ ShouldSerializeBar()

virtual BOOL ShouldSerializeBar ( )
protectedvirtual

Call this method to check if the toolbar has changed and must be saved.

Returns
TRUE if the toolbar has changed and must be saved, otherwise FALSE.

Reimplemented in CXTPMenuBar.

◆ ShowExpandButton()

AFX_INLINE void ShowExpandButton ( BOOL bShowExpandButton )

Call this method to show/hide the expand button of the toolbar.

Parameters
bShowExpandButton TRUE to show the expand button of the toolbar, FALSE to hide the expand button of the toolbar.
The documentation for this class was generated from the following file:
  • XTPToolBar.h


Toolkit Pro: CXTPToolhelpApi Class Reference

Public Member Functions | Static Public Member Functions | List of all members
CXTPToolhelpApi Class Reference

A wrapper around the Toolhelp32 API. More...

Public Member Functions

BOOL | IsInitialized () const
The method should be used for checking if the Toolhelp32 API is supported and can be used.
HANDLE | CreateSnapshot (DWORD dwFlags, DWORD th32ProcessID)
Takes a snapshot of the specified processes, as well as the heaps, modules, and threads used by these processes.
BOOL | GetFirstThread (HANDLE hSnapshot, LPTHREADENTRY32 lpte)
Retrieves information about the first thread of any process encountered in a system snapshot.
BOOL | GetNextThread (HANDLE hSnapshot, LPTHREADENTRY32 lpte)
Retrieves information about the next thread of any process encountered in the system memory snapshot.
BOOL | GetFirstModule (HANDLE hSnapshot, LPMODULEENTRY32 lpme)
Retrieves information about the first module associated with a process.
BOOL | GetNextModule (HANDLE hSnapshot, LPMODULEENTRY32 lpme)
Retrieves information about the next module associated with a process or thread.

Static Public Member Functions

static CXTPToolhelpApi &AFX_CDECL Instance ()

Detailed Description

A wrapper around the Toolhelp32 API.

The API is loaded dynamically and IsInitialized can be used for checking if the API is supported. Refer to Platform SDK documentation on Toolhelp32 API details.

Member Function Documentation

◆ CreateSnapshot()

HANDLE CreateSnapshot | ( | DWORD | dwFlags,
 |  | DWORD | th32ProcessID )

Takes a snapshot of the specified processes, as well as the heaps, modules, and threads used by these processes.

Parameters
dwFlags | The portions of the system to be included in the snapshot.
th32ProcessID | The process identifier of the process to be included in the snapshot.
Returns
If the function succeeds, it returns an open handle to the specified snapshot. Otherwise, the result value is INVALID_HANDLE_VALUE.

◆ GetFirstModule()

BOOL GetFirstModule | ( | HANDLE | hSnapshot,
 |  | LPMODULEENTRY32 | lpme )

Retrieves information about the first module associated with a process.

Parameters
hSnapshot | A handle to the snapshot returned from a previous call to the CreateToolhelp32Snapshot function.
lpme | A pointer to a MODULEENTRY32 structure.
Returns
TRUE if the first entry of the module list has been copied to the buffer, otherwise FALSE.
See also
GetNextModule

◆ GetFirstThread()

BOOL GetFirstThread | ( | HANDLE | hSnapshot,
 |  | LPTHREADENTRY32 | lpte )

Retrieves information about the first thread of any process encountered in a system snapshot.

Parameters
hSnapshot | A handle to the snapshot returned from a previous call to the CreateToolhelp32Snapshot function.
lpte | A pointer to a THREADENTRY32 structure.
Returns
TRUE if the first entry of the thread list has been copied to the buffer, otherwise FALSE.
See also
GetNextThread

◆ GetNextModule()

BOOL GetNextModule | ( | HANDLE | hSnapshot,
 |  | LPMODULEENTRY32 | lpme )

Retrieves information about the next module associated with a process or thread.

Parameters
hSnapshot | A handle to the snapshot returned from a previous call to the CreateToolhelp32Snapshot function.
lpme | A pointer to a MODULEENTRY32 structure.
Returns
TRUE if the next entry of the module list has been copied to the buffer, otherwise FALSE.
See also
GetFirstModule

◆ GetNextThread()

BOOL GetNextThread | ( | HANDLE | hSnapshot,
 |  | LPTHREADENTRY32 | lpte )

Retrieves information about the next thread of any process encountered in the system memory snapshot.

Parameters
hSnapshot | A handle to the snapshot returned from a previous call to the CreateToolhelp32Snapshot function.
lpte | A pointer to a THREADENTRY32 structure.
Returns
TRUE if the next entry of the thread list has been copied to the buffer, otherwise FALSE.
See also
GetFirstThread

◆ Instance()

static CXTPToolhelpApi &AFX_CDECL Instance ( )
static
Returns
Obtains the only global class instance.

◆ IsInitialized()

AFX_INLINE BOOL IsInitialized ( ) const

The method should be used for checking if the Toolhelp32 API is supported and can be used.

Returns
TRUE if the Toolhelp32 API is supported and can be used.
The documentation for this class was generated from the following file:
  • XTPSystemHelpers.h


Toolkit Pro: CXTPToolTipContext Class Reference

Public Member Functions | Protected Attributes | Static Protected Attributes | List of all members
CXTPToolTipContext Class Reference

CXTPToolTipContext is a CXTPCmdTarget derived class. More...

Inheritance diagram for CXTPToolTipContext:
[legend]

Public Member Functions

CXTPToolTipContext ()
Constructs a CXTPToolTipContext object.
virtual | ~CXTPToolTipContext ()
Destroys a CXTPToolTipContext object, handles cleanup and deallocation.
void | ShowTitleAndDescription (BOOL bShowTitleAndDescription=TRUE, int nIconTitle=TTI_INFO)
Call this method to show title and description part of tooltip window.
BOOL | IsShowTitleAndDescription () const
Determines if TitleAndDescription option was set.
void | ShowImage (BOOL bShowImage, int nImageBase=0, int nImageSize=ICON_BIG)
Call this method to show image in tooltip.
void | SetVectorIconSize (CSize szSmall, CSize szLarge)
Call this method to set size of vector icon in tooltip.
BOOL | IsDpiBitmapScalingEnabled () const
Gets DPI bitmap scaling flag.
void | EnableDpiBitmapScaling (BOOL bEnable=TRUE)
Sets DPI bitmap scaling flag.
void | SetStyle (XTPToolTipStyle toolStyle)
Call this member to set the style of the tooltip.
XTPToolTipStyle | GetStyle () const
Call this member to get the style of the tooltip.
BOOL | IsBalloonStyleSupported () const
Call this method to determine if Balloon tooltips supported by the system.
void | SetMaxTipWidth (int iWidth)
Sets the maximum width for a tooltip window.
int | GetMaxTipWidth () const
Retrieves the maximum width for a tooltip window.
COLORREF | GetTipBkColor () const
Retrieves the background color in a tooltip window.
void | SetTipBkColor (COLORREF clr)
Sets the background color in a tooltip window.
COLORREF | GetTipTextColor () const
Retrieves the text color in a tooltip window.
void | SetMargin (LPCRECT lprc)
Sets the top, left, bottom, and right margins for a tooltip window.
CRect | GetMargin () const
void | SetTipTextColor (COLORREF clr)
Sets the text color in a tooltip window.
void | ModifyToolTipStyle (DWORD dwRemove, DWORD dwAdd)
Modifies the styles of the tool tip.
DWORD | GetControlStyle () const
void | SetDelayTime (DWORD dwDuration, int iTime)
Call this function to set the delay time for a tool tip control.
void | CancelToolTips ()
Call this member function to remove a tooltip from the screen if a tooltip is currently displayed.
void | SetFont (CFont *pFont)
Call this method to set the custom font for tooltips.
CFont * | GetFont ()
Call this method to get the custom font for tooltips.
void | SetFontIndirect (LOGFONT *lpLogFont)
Call this method to set custom font for tooltips.
void | SetToolTipCtrl (CXTPToolTipContextToolTip *pToolTipCtrl)
Call this method to set custom tooltip ctrl.
void | StripEllipsisFromToolTip (BOOL bSet)
Call this method to remove ellipsis from tip title.
BOOL | GetStripEllipsisFromToolTip () const
Call this method to determine if ellipsis will be removed from tip title.
virtual CWnd * | CreateToolTip (CWnd *pOwner)
This method is called to create tooltip window.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Attributes

BOOL | m_bShowTitleAndDescription
TRUE to show title and description for tooltip.
BOOL | m_bShowImage
TRUE to show images in tooltip.
BOOL | m_nImageSize
Size of images in tooltip.
CSize | m_szVectorIconSmall
Size of small vector icon.
CSize | m_szVectorIconLarge
Size of large vector icon.
int | m_nImageBase
This value will be added to tool identifier to retrieve image for tip.
BOOL | m_bImageDPIScaling
Enables DPI scaling of images.
XTPToolTipStyle | m_toolStyle
Tooltip style.
DWORD | m_dwComCtlVersion
CommCtrl.dll version.
int | m_nIconTitle
Icon title for extended tooltip.
int | m_nMaxTipWidth
Maximum width of tooltip window.
DWORD | m_dwStyle
Tooltip style.
CRect | m_rcMargin
Margin or "padding" placed around the tooltip text.
int | m_nDelayInitial
The length of time the pointer must remain stationary within a tool's bounding rectangle before the tool tip window appears.
int | m_nDelayReshow
The length of time it takes for subsequent tool tip windows to appear as the pointer moves from one tool to another.
int | m_nDelayAutoPop
the length of time a tooltip window remains visible if the pointer is stationary within a tool's bounding rectangle.
CWnd * | m_pToolTip
Owned Tooltip window.
XTP_TOOLTIP_TOOLINFO_EX | m_lastInfo
Last tooltip info.
COLORREF | m_clrTipBkColor
Background color in a tooltip window.
COLORREF | m_clrTipTextColor
Text color in a tooltip window.
BOOL | m_bStripEllipsisFromToolTip
TRUE to remove ellipses from tip caption (defailt is TRUE)
CXTPFont | m_xtpFont
Font of the tool tip.
CXTPFont | m_xtpFontTitle
Font of the tool tip title.

Static Protected Attributes

static CXTPToolTipContext * m_pModuleContext
Tooltip for current module.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

CXTPToolTipContext is a CXTPCmdTarget derived class.

It allows to change options for tool tips of parent object.

Member Function Documentation

◆ CreateToolTip()

virtual CWnd * CreateToolTip ( CWnd * pOwner )
virtual

This method is called to create tooltip window.

You can override it to create custom tool tip derived from CXTPToolTipContextToolTip

Parameters
pOwner Specifies the tool tip control's parent window.
Returns
New tool tip window.

◆ EnableDpiBitmapScaling()

void EnableDpiBitmapScaling ( BOOL bEnable = TRUE )

Sets DPI bitmap scaling flag.

If set, all raster icons and bitmaps used in the control will be stretched automatically if DPI scaling factor for control's window isn't equal to 100%. The default value is derived from CXTPDpi::IsDpiBitmapScalingEnabled. Once changed the new value will be used.

Parameters
bEnable TRUE to enable bitmaps scaling, FALSE to disable.

◆ GetControlStyle()

DWORD GetControlStyle ( ) const
Returns
Retrieves control style
See also
ModifyToolTipStyle

◆ GetFont()

CFont * GetFont ( )

Call this method to get the custom font for tooltips.

Returns
A pointer to the custom font for tooltips.

◆ GetMargin()

CRect GetMargin ( ) const
Returns
Retrieves the top, left, bottom, and right margins set for a tooltip window

◆ GetMaxTipWidth()

int GetMaxTipWidth ( ) const

Retrieves the maximum width for a tooltip window.

Returns
Returns an INT value that represents the maximum tooltip width, in pixels

◆ GetStripEllipsisFromToolTip()

BOOL GetStripEllipsisFromToolTip ( ) const

Call this method to determine if ellipsis will be removed from tip title.

Returns
TRUE if ellipsis are removed from tip title

◆ GetStyle()

XTPToolTipStyle GetStyle ( ) const

Call this member to get the style of the tooltip.

Returns
Returns style of the tooltip
See also
SetStyle, XTPToolTipStyle

◆ GetTipBkColor()

COLORREF GetTipBkColor ( ) const

Retrieves the background color in a tooltip window.

Returns
Returns a COLORREF value that represents the background color.

◆ GetTipTextColor()

COLORREF GetTipTextColor ( ) const

Retrieves the text color in a tooltip window.

Returns
Returns a COLORREF value that represents the text color.

◆ IsBalloonStyleSupported()

BOOL IsBalloonStyleSupported ( ) const

Call this method to determine if Balloon tooltips supported by the system.

Returns
True if Balloon tooltips is supported

◆ IsDpiBitmapScalingEnabled()

BOOL IsDpiBitmapScalingEnabled ( ) const

Gets DPI bitmap scaling flag.

If set, all raster icons and bitmaps used in the control will be stretched automatically if DPI scaling factor for control's window isn't equal to 100%. The default value is derived from CXTPDpi::IsDpiBitmapScalingEnabled. Once changed the new value will be used.

Returns
The current value of the DPI bitmap scaling flag for the control.

◆ IsShowTitleAndDescription()

BOOL IsShowTitleAndDescription ( ) const

Determines if TitleAndDescription option was set.

Returns
TRUE if description is visible for tooltips
See also
ShowTitleAndDescription

◆ ModifyToolTipStyle()

void ModifyToolTipStyle | ( | DWORD | dwRemove,
 |  | DWORD | dwAdd )

Modifies the styles of the tool tip.

Parameters
dwRemove | Styles to remove.
dwAdd | Styles to add.

Example:

m_wndToolBox.GetToolTipContext()->ModifyToolTipStyle(TTS_NOPREFIX, 0);

◆ SetDelayTime()

void SetDelayTime | ( | DWORD | dwDuration,
 |  | int | iTime )

Call this function to set the delay time for a tool tip control.

The delay time is the length of time the cursor must remain on a tool before the tool tip window appears. The default delay time is 500 milliseconds.

Parameters
dwDuration | Flag that specifies which duration value will be retrieved. See CToolTipCtrl::GetDelayTime for a description of the valid values.
iTime | The specified delay time, in milliseconds.

◆ SetFont()

void SetFont ( CFont * pFont )

Call this method to set the custom font for tooltips.

Parameters
pFont Pointer to the font to be set.

◆ SetFontIndirect()

void SetFontIndirect ( LOGFONT * lpLogFont )

Call this method to set custom font for tooltips.

Parameters
lpLogFont Font to be set

◆ SetMargin()

void SetMargin ( LPCRECT lprc )

Sets the top, left, bottom, and right margins for a tooltip window.

Parameters
lprc Address of a RECT structure that contains the margin information to be set.

◆ SetMaxTipWidth()

void SetMaxTipWidth ( int iWidth )

Sets the maximum width for a tooltip window.

Parameters
iWidth Maximum tooltip window width to be set.

◆ SetStyle()

void SetStyle ( XTPToolTipStyle toolStyle )

Call this member to set the style of the tooltip.

Parameters
toolStyle The style to be set. Can be any of the values listed in the Remarks section.

toolStyle parameter can be one of the following: xtpToolTipStandard Standard tooltip window style xtpToolTipBalloon Balloon tooltip window style xtpToolTipOffice Office tooltip window style

See also
GetStyle, XTPToolTipStyle

◆ SetTipBkColor()

void SetTipBkColor ( COLORREF clr )

Sets the background color in a tooltip window.

Parameters
clr New background color.

◆ SetTipTextColor()

void SetTipTextColor ( COLORREF clr )

Sets the text color in a tooltip window.

Parameters
clr New text color.

◆ SetToolTipCtrl()

void SetToolTipCtrl ( CXTPToolTipContextToolTip * pToolTipCtrl )

Call this method to set custom tooltip ctrl.

Parameters
pToolTipCtrl new tooltip to be set

Example:

pCommandBars->GetTooltipContext()->SetToolTipCtrl(new CMyTooltip());

◆ SetVectorIconSize()

void SetVectorIconSize | ( | CSize | szSmall,
 |  | CSize | szLarge )

Call this method to set size of vector icon in tooltip.

Parameters
szSmall | Size of small vector icon in tooltip
szLarge | Size of large vector icon in tooltip

◆ ShowImage()

void ShowImage | ( | BOOL | bShowImage,
 |  | int | nImageBase = 0,
 |  | int | nImageSize = ICON_BIG )

Call this method to show image in tooltip.

Parameters
bShowImage | TRUE to show image
nImageBase | Image base
nImageSize | Size of image in tooltip. By default largest image used.
See also
ShowTitleAndDescription, EnableImageDPIScaling

◆ ShowTitleAndDescription()

void ShowTitleAndDescription | ( | BOOL | bShowTitleAndDescription = TRUE,
 |  | int | nIconTitle = TTI_INFO )

Call this method to show title and description part of tooltip window.

Parameters
bShowTitleAndDescription | TRUE to show title and description part
nIconTitle | Icon to be set

Allow only if Internet Explorer 5.0 installed.

◆ StripEllipsisFromToolTip()

void StripEllipsisFromToolTip ( BOOL bSet )

Call this method to remove ellipsis from tip title.

Parameters
bSet TRUE to remove ellipsis from title

Member Data Documentation

◆ m_rcMargin

CRect m_rcMargin
protected

Margin or "padding" placed around the tooltip text.

The sides of the CRect indicate the amount of padding for the left, top, bottom, and right sides of the tooltip window.

The documentation for this class was generated from the following file:
  • XTPToolTipContext.h


Toolkit Pro: CXTPToolTipContextToolTip Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | Static Protected Attributes | List of all members
CXTPToolTipContextToolTip Class Reference

CXTPToolTipContextToolTip is CWnd derived class, the base class for custom tool tips. More...

Public Member Functions

CXTPToolTipContextToolTip (CXTPToolTipContext *pContext)
Constructs a CXTPToolTipContextToolTip object.
virtual ~CXTPToolTipContextToolTip ()
Destroys a CXTPToolTipContextToolTip object, handles cleanup and deallocation.

Protected Member Functions

virtual CSize | GetToolSize (TOOLITEM *lpToolInfo)
This method is called to retrieve size of tool tip to show.
virtual void | DrawEntry (CDC *pDC, TOOLITEM *lpToolInfo, CRect rc)
This method is called to draw face of tool tip.
virtual void | DrawBackground (CDC *pDC, TOOLITEM *lpToolInfo, CRect rc)
This method is called to draw background of tool tip.

Protected Attributes

CArray< TOOLITEM *, TOOLITEM * > | m_arrTools
Tool tips item array.
BOOL | m_bActive
TRUE if tracking is active.
CXTPToolTipContext * | m_pContext
Pointer to parent context class.
TOOLITEM | m_toolVisible
Currently visible tip.
TOOLITEM | m_toolDisabled
Currently ignored tip.
TOOLITEM | m_toolDelay
Currently delayed tip.
UINT_PTR | m_nDelayTimer
Hover timer.
DWORD | m_dwLastTip
Last tool tip time.
UINT | m_nDelayInitial
The length of time the pointer must remain stationary within a tool's bounding rectangle before the tool tip window appears.
UINT | m_nDelayReshow
The length of time it takes for subsequent tool tip windows to appear as the pointer moves from one tool to another.
UINT | m_nDelayAutoPop
Length of time the ToolTip window remains visible if the pointer is stationary within the bounding rectangle of a too.
UINT_PTR | m_nAutoPopTimer
Auto Pop timer.
CString | m_strTitle
Title of tooltip if enabled.
CXTPImageManagerIcon * | m_pIcon
Image.

Static Protected Attributes

static HHOOK | m_hHookMouse
Mouse hook.
static CXTPToolTipContextToolTip * | m_pWndMonitor
Mouse monitor pointer.

Detailed Description

CXTPToolTipContextToolTip is CWnd derived class, the base class for custom tool tips.

Constructor & Destructor Documentation

◆ CXTPToolTipContextToolTip()

CXTPToolTipContextToolTip ( CXTPToolTipContext * pContext )

Constructs a CXTPToolTipContextToolTip object.

Parameters
pContext Pointer to parent tooltip context

Member Function Documentation

◆ DrawBackground()

virtual void DrawBackground | ( | CDC * | pDC,
 |  | TOOLITEM * | lpToolInfo,
 |  | CRect | rc )
 protectedvirtual

This method is called to draw background of tool tip.

Parameters
pDC | Pointer to a valid device context
rc | Client rectangle
lpToolInfo | Pointer to tooltip specific information

◆ DrawEntry()

virtual void DrawEntry | ( | CDC * | pDC,
 |  | TOOLITEM * | lpToolInfo,
 |  | CRect | rc )
 protectedvirtual

This method is called to draw face of tool tip.

Parameters
pDC | Pointer to a valid device context
rc | Client rectangle
lpToolInfo | Pointer to tooltip specific information

◆ GetToolSize()

virtual CSize GetToolSize ( TOOLITEM * lpToolInfo )
protectedvirtual

This method is called to retrieve size of tool tip to show.

Parameters
lpToolInfo Pointer to tooltip specific information
Returns
Size of new tool tip.
See also
DrawEntry
The documentation for this class was generated from the following file:
  • XTPToolTipContext.h


Toolkit Pro: CXTPTrackBlock Class Reference

Public Member Functions | Public Attributes | Protected Attributes | List of all members
CXTPTrackBlock Class Reference

This class represents a track control block. More...

Inheritance diagram for CXTPTrackBlock:
[legend]

Public Member Functions

CXTPTrackBlock ()
Constructs a CXTPTrackBlock object.
virtual int | Draw (CDC *pDC, CRect rc, BOOL bSelected)
Draws the block.
virtual BOOL | IsKey () const
Determines if the item is a key.
virtual BOOL | IsResizable () const
Determines if the block is resizable.
void | SetPosition (int nPosition)
Sets the position for the block on the track.
int | GetPosition () const
Gets the position of the block on the track.
void | SetLength (int nLength)
Sets the length for the block on the track.
int | GetLength () const
Gets the length of the block on the track.
void | SetColor (COLORREF clr)
Sets the color for the block.
CRect | GetRect () const
Gets the bounding rectangle of the block.
BOOL | IsLocked () const
Gets the locked state of the block (i.e.
void | SetLocked (BOOL bLocked=TRUE)
Sets the locked state for the block (i.e.
void | SetHeightPercent (double dHeightPercent)
Sets the height percentage for the block compared to its track.
double | GetHeightPercent () const
Gets the height percentage of the block compared to its track.
void | SetVerticalAlignment (int nAlignment)
Sets the vertical alignment for the block in its track.
int | GetVerticalAlignment () const
Gets the vertical alignment of the block in its track.
CXTPTrackControlItem * | GetItem () const
Gets the track control to which the block is associated with.
int | GetIndex () const
Gets the index of the block in its track.
void | Select (BOOL bSelect=TRUE)
Sets the selected state for the block.
BOOL | IsSelected () const
Gets the selected state of the block.
CString | GetCaption () const
Gets the caption of the block.
void | SetCaption (LPCTSTR lpszCaption)
Sets the caption for the block.
virtual CString | GetTooltip () const
Gets the tooltip text of the block.
void | SetTooltip (LPCTSTR lpszTooltip)
Sets the tooltip text for the block.
void | SetDescriptionText (LPCTSTR lpszDescriptionText)
Sets the description text for the block.
CString | GetDescriptionText () const
Gets the description text of the block.
void | SetMinLength (int nMinLength)
Sets the minimum length for the block.
int | GetMinLength () const
Gets the minimum length of the block.
void | SetMaxLength (int nMaxLength)
Sets the maximum length for the block.
int | GetMaxLength () const
Gets the maximum length of the block.
void | DoPropExchange (CXTPPropExchange *pPX)
Call this member function to store/load the properties related to the block.
void | Remove ()
Removes the block.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Public Attributes

CRect | m_rcBlock
Drawing bounding rectangle of block.
CXTPTrackControlItem * | m_pItem
Pointer to the parent track of the block.
int | m_nPosition
Position that resolve overlaps with items on same track.
int | m_nLength
Length of the block.
BOOL | m_bLocked
TRUE if the block is not movable/resizable.
COLORREF | m_clrBlock
Color of the block.
CString | m_strCaption
Caption text.
double | m_dHeightPercent
Height percentage of the block compared to its track.
int | m_nVerticalAlignment
Vertical alignment of blocks with m_dHeightPercent < 1.

Protected Attributes

int | m_nMRUPosition
Last position that was set by the user.
CString | m_strToolTip
Tooltip text.
CString | m_strDescription
Description text.
int | m_nIndex
Index of the block in its parent track.
int | m_nLastDragTime
Last drag moment of user (used as priority for flexible draging).
int | m_nMinLength
Minimum resize length.
int | m_nMaxLength
Maximum resize length.
BOOL | m_bDragging
Block is currently dragging.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

This class represents a track control block.

Track blocks are a visual representation of units of time in a track. They can have both a minimum and maximum time period.

Member Function Documentation

◆ DoPropExchange()

void DoPropExchange ( CXTPPropExchange * pPX )

Call this member function to store/load the properties related to the block.

Parameters
pPX Source/destination CXTPPropExchange data object reference.

This member function is used to store/load property data to/from storage.

◆ Draw()

virtual int Draw | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | BOOL | bSelected )
 virtual

Draws the block.

Parameters
pDC | Pointer to the device context.
rc | Bounds of the drawing area.
bSelected | TRUE if the block is selected, FALSE otherwise.
Returns
A value of 1 if the drawing was successful, otherwise a value of 0.

This is a virtual function so derived classes can provide their specific implementations.

Reimplemented in CXTPTrackKey.

◆ GetCaption()

AFX_INLINE CString GetCaption ( ) const

Gets the caption of the block.

Returns
The caption of the block.

◆ GetDescriptionText()

AFX_INLINE CString GetDescriptionText ( ) const

Gets the description text of the block.

Returns
The description text of the block.

◆ GetHeightPercent()

AFX_INLINE double GetHeightPercent ( ) const

Gets the height percentage of the block compared to its track.

Returns
A double value denoting the height percentage.

◆ GetIndex()

AFX_INLINE int GetIndex ( ) const

Gets the index of the block in its track.

Returns
The index of the block in its track.

◆ GetItem()

AFX_INLINE CXTPTrackControlItem * GetItem ( ) const

Gets the track control to which the block is associated with.

Returns
A pointer to the CXTPTrackControl object to which the block is associated with.

Tracks are what hold blocks and keys.

◆ GetLength()

AFX_INLINE int GetLength ( ) const

Gets the length of the block on the track.

Returns
The length of the block on the track.

◆ GetMaxLength()

AFX_INLINE int GetMaxLength ( ) const

Gets the maximum length of the block.

Returns
The maximum length of the block.

◆ GetMinLength()

AFX_INLINE int GetMinLength ( ) const

Gets the minimum length of the block.

Returns
The minimum length of the block.

◆ GetPosition()

AFX_INLINE int GetPosition ( ) const

Gets the position of the block on the track.

Returns
The position of the block on the track.

◆ GetRect()

AFX_INLINE CRect GetRect ( ) const

Gets the bounding rectangle of the block.

Returns
A CRect object containing the bounding rectangle of the block.

◆ GetTooltip()

AFX_INLINE CString GetTooltip ( ) const
virtual

Gets the tooltip text of the block.

Returns
The tooltip text of the block.

◆ GetVerticalAlignment()

AFX_INLINE int GetVerticalAlignment ( ) const

Gets the vertical alignment of the block in its track.

Returns
A double value denoting the vertical alignment.

Vertical alignment is used for keys and blocks which do not share the same height as their track. Vertical alignment aligns blocks in relation to the center of the track.

◆ IsKey()

AFX_INLINE BOOL IsKey ( ) const
virtual

Determines if the item is a key.

Returns
TRUE if the item is a key, otherwise FALSE.

This is a virtual function so derived classes can provide their specific implementations.

Reimplemented in CXTPTrackKey.

◆ IsLocked()

BOOL IsLocked ( ) const

Gets the locked state of the block (i.e.

a locked block cannot be moved or resized).

Returns
TRUE if the block is locked, otherwise FALSE.

◆ IsResizable()

AFX_INLINE BOOL IsResizable ( ) const
virtual

Determines if the block is resizable.

Returns
TRUE if the block is resizable, otherwise FALSE.

This is a virtual function so derived classes can provide their specific implementations.

◆ IsSelected()

BOOL IsSelected ( ) const

Gets the selected state of the block.

Returns
TRUE if the block is selected, otherwise FALSE.

◆ Select()

void Select ( BOOL bSelect = TRUE )

Sets the selected state for the block.

Parameters
bSelect TRUE to select the block, FALSE to unselect; the default value for this parameter is TRUE.

◆ SetCaption()

AFX_INLINE void SetCaption ( LPCTSTR lpszCaption )

Sets the caption for the block.

Parameters
lpszCaption New caption for the block.

◆ SetColor()

AFX_INLINE void SetColor ( COLORREF clr )

Sets the color for the block.

Parameters
clr COLORREF value specifying the color for the block.

◆ SetDescriptionText()

AFX_INLINE void SetDescriptionText ( LPCTSTR lpszDescriptionText )

Sets the description text for the block.

Parameters
lpszDescriptionText New description text for the block.

◆ SetHeightPercent()

AFX_INLINE void SetHeightPercent ( double dHeightPercent )

Sets the height percentage for the block compared to its track.

Parameters
dHeightPercent Double value denoting the height percentage.

Blocks can be set to different heights and different vertical alignments within a track. This is used as a visual aid to make different blocks in the track visually different from each other.

◆ SetLength()

void SetLength ( int nLength )

Sets the length for the block on the track.

Parameters
nLength Length for the block on the track.

◆ SetLocked()

AFX_INLINE void SetLocked ( BOOL bLocked = TRUE )

Sets the locked state for the block (i.e.

a locked block cannot be moved or resized).

Parameters
bLocked TRUE to lock the block; the default value for this parameter is TRUE.

◆ SetMaxLength()

AFX_INLINE void SetMaxLength ( int nMaxLength )

Sets the maximum length for the block.

Parameters
nMaxLength Maximum length for the block.

◆ SetMinLength()

AFX_INLINE void SetMinLength ( int nMinLength )

Sets the minimum length for the block.

Parameters
nMinLength Minimum length for the block.

◆ SetPosition()

void SetPosition ( int nPosition )

Sets the position for the block on the track.

Parameters
nPosition Position for the block on the track.

◆ SetTooltip()

AFX_INLINE void SetTooltip ( LPCTSTR lpszTooltip )

Sets the tooltip text for the block.

Parameters
lpszTooltip New tooltip text for the block.

◆ SetVerticalAlignment()

AFX_INLINE void SetVerticalAlignment ( int nAlignment )

Sets the vertical alignment for the block in its track.

Parameters
nAlignment Double value denoting the vertical alignment.

Vertical alignment is used for keys and blocks which do not share the same height as their track. Vertical alignment aligns blocks in relation to the center of the track.

The documentation for this class was generated from the following file:
  • XTPTrackBlock.h


Toolkit Pro: CXTPTrackControl Class Reference

Classes | Public Member Functions | Public Attributes | Protected Attributes | List of all members
CXTPTrackControl Class Reference

This class represents a track control. More...

Inheritance diagram for CXTPTrackControl:
[legend]

Classes

struct DRAGBLOCK
This structure abstracts the state of block being dragged. More...

Public Member Functions

CXTPTrackControl ()
Constructs a CXTPTrackControl object.
~CXTPTrackControl ()
Destroys a CXTPTrackControl object, handles cleanup and deallocation.
BOOL | RegisterWindowClass (HINSTANCE hInstance=NULL)
Registers the window class if it has not already been registered.
void | SetTimeLinePosition (int nTimeLinePos)
Sets the time line position.
int | GetTimeLinePosition () const
Gets the time line position.
int | GetTimeLineMin () const
Gets the minimum time line position.
int | GetTimeLineMax () const
Gets the maximum time line position.
void | SetWorkArea (int nWorkAreaMin, int nWorkAreaMax)
Sets the bounds of the work area.
void | SetViewPort (int nViewPortMin, int nViewPortMax)
Sets the view port of the work area.
void | SetTimeLineRange (int nTimeScaleMin, int nTimeScaleMax)
Sets the time line range.
int | GetWorkAreaMin () const
Gets the minimum value of the work area range.
int | GetWorkAreaMax () const
Gets the maximum value of the work area range.
int | GetViewPortMin () const
Gets the minimum value of the view port.
int | GetViewPortMax () const
Gets the maximum value of the view port.
CXTPTrackPaintManager * | GetTrackPaintManager () const
Gets the track paint manager associated with this control.
void | DoPropExchange (CXTPPropExchange *pPX)
Call this member function to store/load the properties related to the track control.
CXTPTrackSelectedBlocks * | GetSelectedBlocks () const
Gets the selected blocks in the track control.
void | Populate ()
Populates the track control with the records.
int | DrawRows (CDC *pDC, CRect &rcClient, int y, CXTPGridRows *pRows, int nTopRow, int nColumnFrom, int nColumnTo, int *pnHeight)
Draws all rows in the provided device context.
int | GetTrackOffset () const
Gets the track offset.
void | AdjustLayout ()
Adjusts the layout of the track control when there is a change in the metrics of the control.
CXTPGridColumn * | GetTrackColumn () const
Gets the track column.
int | PositionToTrack (int nPosition)
Converts a coordinate point on the track control to a track point.
int | TrackToPosition (int nTrack) const
Converts a track point to a coordinate point on the track control.
int | GetTrackColumnIndex () const
Gets the index of the track column.
int | GetSnapMargin () const
Gets the snap margin.
CRect | GetTimelineArea () const
Gets the time line area.
void | EnsureVisible (CXTPTrackBlock *pBlock)
Call this function to ensure that a specified block is visible.
CXTPTrackMarkers * | GetMarkers () const
Gets the track markers object associated with the track control.
CXTPTrackUndoManager * | GetUndoManager () const
Gets the undo manager associated with the track control.
virtual BOOL | HitTest (CPoint pt, CXTPGridHitTestInfo *pInfo) const
Determines which grid part, if any, is at a specified point.
LRESULT | SendMessageToParent (UINT nMessage, CXTPTrackBlock *pBlock=NULL, CXTPTrackMarker *pMarker=NULL) const
Sends messages to the parent window of the track control.
void | StartDragBlocks (BOOL bResize)
Call this function when you are about to start dragging a block.
int | SnapPosition (int nPosition)
Gets a snap position for a block at a specified position on the track.
void | StartDragSelection ()
Call this function when you are about to start drag selection.
void | AdjustTrackColumnWidth ()
Adjusts the track column width.
void | SetMouseCursorMode (XTPTrackMouseCursorMode enMode)
Sets the mouse cursor mode.
XTPTrackMouseCursorMode | GetMouseCursorMode () const
Gets the mouse cursor mode.
- Public Member Functions inherited from CXTPGridControl
CXTPGridControl ()
Constructs a CXTPGridControl object.
virtual | ~CXTPGridControl ()
Destroys a CXTPGridControl object, handles cleanup and deallocation.
BOOL | Create (DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID, CCreateContext *pContext=NULL)
This method is called to create a Grid control.
virtual void | SerializeState (CArchive &ar)
(Re)Stores control configuration to/from the provided archive stream.
CXTPGridColumn * | AddColumn (CXTPGridColumn *pColumn)
Adds a specified column to the end of the columns array.
virtual CXTPGridRecord * | AddRecord (CXTPGridRecord *pRecord)
Adds a specified data record to the records collection.
virtual void | AddRecordEx (CXTPGridRecord *pRecord, CXTPGridRecord *pParentRecord=NULL, int nRowChildIndex=-1, int nRecordChildIndex=-1)
Adds a specified data record to the records collection and associates a row with it.
virtual BOOL | RemoveRecordEx (CXTPGridRecord *pRecord, BOOL bAdjustLayout=TRUE, BOOL bRemoveFromParent=TRUE)
Removes a specified record, the row associated with the specified record, and all child records and rows.
virtual BOOL | RemoveRowEx (CXTPGridRow *pRow, BOOL bAdjustLayout=TRUE)
Removes a specified row, the record associated with the specified row, and all child rows and records.
virtual void | UpdateRecord (CXTPGridRecord *pRecord, BOOL bUpdateChildren)
Updates a specified record.
void | BeginUpdate ()
Prevents the Grid control from being redrawn until the EndUpdate method is called.
void | ResetContent (BOOL bUpdateControl=TRUE)
Deletes all rows and records from the Grid control.
void | EndUpdate ()
Resumes drawing of the Grid control after drawing has been suspended by the BeginUpdate method.
int | GetLockUpdateCount () const
void | RedrawControl ()
Initiates Grid control redrawing.
CXTPToolTipContext * | GetToolTipContext () const
Gets the tooltip context.
CLIPFORMAT | EnableDragDrop (LPCTSTR lpszClipboardFormat, DWORD dwFlags, DWORD dwDropMarkerFlags=xtpGridDropBetween)
Call this method to enable built in drag and drop operations.
void | SetDropMarkerFlags (DWORD dwDropMarkerFlags)
Sets the drop marker flags.
DWORD | GetDropMarkerFlags () const
Gets the drop marker flags.
void | SetGridStyle (XTPGridOrientation orientation, XTPGridGridStyle gridStyle)
Sets the grid drawing style.
XTPGridGridStyle | GetGridStyle (XTPGridOrientation orientation) const
Gets the grid drawing style.
COLORREF | SetGridColor (COLORREF clrGridLine)
Sets the grid line color.
CXTPGridColumns * | GetColumns () const
Gets the collection of grid columns.
CXTPGridPaintManager * | GetPaintManager () const
Gets the paint manager object used to draw the Grid control window.
void | SetPaintManager (CXTPGridPaintManager *pPaintManager)
Sets the paint manager object used to draw the Grid control window.
CXTPGridNavigator * | GetNavigator () const
Gets the navigator object used for cell navigation by the Grid control.
virtual void | PopulateHeaderRows ()
Performs control's header rows population, creating a view from the data.
virtual void | PopulateFooterRows ()
Performs control's footer rows population, creating a view from the data.
void | EnsureVisible (CXTPGridRow *pRow)
Ensures that a Grid control row is at least partially visible.
void | EnsureVisible (CXTPGridColumn *pCheckColumn)
Ensures that a Grid control column is at least partially visible.
CXTPGridRow * | HitTest (CPoint pt) const
Determines which grid row is at a specified point, if any.
CXTPGridSelectedRows * | GetSelectedRows () const
Gets the collection of selected rows.
CXTPGridRow * | GetFocusedRow () const
Gets the currently focused row in the Grid control's view.
BOOL | SetFocusedRow (CXTPGridRow *pRow, BOOL bControlKey=FALSE)
Sets the currently focused row in the Grid control's view.
BOOL | SetFocusedRow (CXTPGridRow *pRow, BOOL bShiftKey, BOOL bControlKey)
Sets the currently focused row in the Grid control's view.
BOOL | SetFocusedRow (BOOL bEnsureVisible, CXTPGridRow *pRow, BOOL bShiftKey, BOOL bControlKey)
Sets the currently focused row in the Grid control's view.
int | GetGridAreaRows (int nStartRow, BOOL bMoveDown)
Calculates the number of visible rows between a specified row and the bottom/top of the current view.
void | SetTopRow (int nIndex)
Sets the top row of the Grid control view.
int | GetTopRowIndex () const
Gets the index of the top row of the Grid control view.
void | SetScrollOffsetH (int nOffset)
Sets the horizontal scroll position.
void | SetScrollOffsetV (int nOffset)
Sets the vertical scroll position.
void | SetLayoutRTL (BOOL bRightToLeft)
Sets right-to-left (RTL) mode.
BOOL | IsLayoutRTL ()
Determines if right-to-left (RTL) mode was set.
void | EnablePreviewMode (BOOL bIsPreviewMode)
Enables/disables preview mode for the control.
BOOL | IsPreviewMode () const
Determines if preview mode is enabled/disabled for the control.
void | ShowGroupBy (BOOL bEnable=TRUE)
Sets the visible state of the Group By area.
BOOL | IsGroupByVisible () const
Gets the visible state of the Group By area.
void | ShowHeader (BOOL bShow=TRUE)
Sets the visible state of column headers.
BOOL | IsHeaderVisible () const
Gets the visible state of column headers.
void | ShowFooter (BOOL bShow=TRUE)
Sets the visible state of column footers.
BOOL | IsFooterVisible () const
Gets the visible state of column footers.
void | ShadeGroupHeadings (BOOL bEnable=TRUE)
Enables/disables group items shading.
BOOL | IsShadeGroupHeadingsEnabled () const
Determines if group items shading is enabled/disabled.
void | SetGroupRowsBold (BOOL bBold=TRUE)
Sets the group rows text style: bold or normal.
BOOL | IsGroupRowsBold () const
Gets the group rows text style: bold or normal.
int | GetFreezeColumnsCount () const
Gets the number of frozen columns starting from the left hand side.
int | GetFreezeColumnsCount (int &nLastIndex) const
Gets the number of frozen columns starting from the left hand side.
int | GetFreezeColumnsIndex () const
Gets the index of the rightmost frozen column.
void | SetFreezeColumnsCount (int nCount, BOOL bReserved=FALSE)
Sets the number of frozen columns.
int | GetDisableReorderColumnsCount () const
Gets the number of columns at the left side where reordering is disabled.
void | SetDisableReorderColumnsCount (int nCount)
Sets the number of columns at the left side where reordering is disabled.
BOOL | IsFullColumnScrolling () const
Gets the horizontal scrolling mode.
void | SetFullColumnScrolling (BOOL bSet)
Sets the horizontal scrolling mode.
void | ReleaseItem (int nIndex)
Call this method to remove all items and column in specified position.
void | PinFooterRows (BOOL bPin=FALSE)
Specifies if footer records are pinned to the last body row.
BOOL | IsFooterRowsPinned () const
Determines if footer records are pinned to the last body row.
void | PinFooterRowsPrinted (BOOL bPin=FALSE)
Specifies if footer records are pinned to the last body row.
BOOL | IsFooterRowsPinnedPrinted () const
Determines if footer records are pinned to the last body row.
void | EnableMarkup (BOOL bEnable=TRUE)
Call this method to enable Markup for records.
CXTPMarkupContext * | GetMarkupContext () const
Gets the Markup context.
CXTPImageManager * | GetImageManager () const
Gets the image manager of the Grid control.
void | SetImageManager (CXTPImageManager *pImageManager)
Sets the image manager for the Grid control.
void | SetImageList (CImageList *pImageList)
Sets the image list for the paint manager.
CXTPGridHeader * | GetGridHeader () const
Gets the associated grid header object.
void | SetGridHeader (CXTPGridHeader *pGridHeader)
Sets the associated grid header object.
int | GetIndent (int nLevel) const
Calculates the indentation, in pixels, for a tree view row of a specified depth level.
LRESULT | SendMessageToParent (CXTPGridRow *pRow, CXTPGridRecordItem *pItem, CXTPGridColumn *pColumn, UINT nMessage, CPoint *pPoint, int nHyperlink=-1) const
Notifies the parent control about an event that occurred.
LRESULT | SendNotifyMessage (UINT nMessage, NMHDR *pNMHDR=NULL) const
Sends a specified message to the window.
void | CollapseAll ()
Collapses all rows.
void | ExpandAll (BOOL bRecursive=FALSE)
Expands all rows.
BOOL | IsMultipleSelection () const
Determines if multiple selections is enabled/disabled for the Grid control.
void | SetMultipleSelection (BOOL bMultipleSelection)
Enables/disables multiple selections for the Grid control.
BOOL | IsMultiSelectionMode () const
Determines if multi-selection mode is enabled/disabled for the Grid control.
void | SetMultiSelectionMode (BOOL bMultiSelectionMode)
Enables/disables multi-selection mode for the Grid control.
void | EnableToolTips (BOOL bEnable)
Enables/disables showing tooltips for the Grid control window.
void | SkipGroupsFocus (BOOL bSkipFocus)
Specifies if groups are skipped when navigating the Grid control by using the Up and Down keys.
BOOL | IsSkipGroupsFocusEnabled () const
Determines if groups are skipped when navigating the Grid control by using the Up and Down keys.
int | GetHeaderIndent () const
Gets the indentation of the header.
virtual void | AdjustScrollBars ()
Adjusts scrollbars depending on currently visible rows.
CXTPGridColumn * | GetFocusedColumn () const
Gets the selected column.
BOOL | SetFocusedColumn (CXTPGridColumn *pColumn)
Sets the selected column.
void | SetSelectionState (int index, int state)
Sets the selection state of a row.
void | EnsureFocusedRowVisible (BOOL bEnsureFocusedRowVisible)
Specifies if the visibility of focused rows should be ensured.
BOOL | IsEnsureFocusedRowVisible () const
Determines if the visibility of focused rows is ensured.
void | FocusSubItems (BOOL bFocusSubItems)
Specifies if each individual record item in a row should receive focus when an item in the row is clicked.
BOOL | IsFocusSubItems () const
Determines if each individual record item in a row receives focus when an item in the row is clicked.
void | EditOnClick (BOOL bEditOnClick)
Specifies if a CXTPGridRecordItem should become editable after being single-clicked.
BOOL | IsEditOnClick () const
Determines if a CXTPGridRecordItem becomes editable after being single-clicked.
void | EditOnDelayClick (BOOL bEditOnDelayClick)
Enables/disables the Delay Click Edit feature.
BOOL | IsEditOnDelayClick () const
Determines if the Delay Click Edit feature is enabled/disabled.
void | EditOnDoubleClick (BOOL bEditOnClick)
Specifies if a CXTPGridRecordItem should become editable after being double-clicked.
BOOL | IsEditOnDoubleClick () const
Determines if a CXTPGridRecordItem becomes editable after being double-clicked.
int | GetLastRqstEditRow () const
Gets the index of the most recent row that was requested for editing.
int | GetLastRqstEditCol () const
Gets the index of the most recent column that was requested for editing.
void | SetLastRqstEdit (int iRqstEditRow, int iRqstEditCol)
Sets an arbitrary index for both the most recent row and most recent column that was requested for editing.
void | EnsureStopLastRqstTimer ()
Stops the last request timer used for delay edit.
void | StartLastRqstTimer ()
Starts the last request timer used for delay edit.
UINT_PTR | GetDelayEditTimer () const
Gets the ID of the delay edit timer.
void | EnsureStopDelayEditTimer ()
Stops the delay edit timer.
void | StartDelayEditTimer ()
Starts the delay edit timer.
void | SetAutoCheckItems (BOOL bAutoCheck)
Enables/disables auto-check mode for checkbox items.
BOOL | IsAutoCheckItems () const
Determines if auto-check mode is enabled/disabled for checkbox items.
void | EditItem (XTP_GRIDRECORDITEM_ARGS *pItemArgs)
Edits a grid cell by focusing the specified cell and starting in-place editing for the control specified there.
CXTPGridInplaceEdit * | GetInplaceEdit () const
Gets the in-place edit control.
CXTPGridInplaceButtons * | GetInplaceButtons () const
Gets the collection of in-place buttons of the Grid control.
CXTPGridInplaceList * | GetInplaceList () const
Gets the in-place list of Grid controls.
BOOL | HasFocus () const
Determines if the Grid control has focus.
CXTPGridRecordItem * | GetActiveItem () const
Gets the active item (i.e.
CXTPGridRecordItem * | GetFocusedRecordItem () const
Gets the focused item.
void | SetTreeIndent (int nIndent)
Sets the indentation before the text of each child node in a hierarchical tree structure.
void | SetVirtualMode (CXTPGridRecord *pVirtualRecord, int nCount, int nFields=0)
Call this method to enable virtual mode of the control.
BOOL | IsVirtualMode () const
Determines if virtual mode is enabled/disabled.
virtual CString | GetFilterText ()
Gets the filter text of the control.
virtual void | SetFilterText (LPCTSTR strFilterText)
Sets the filter text for the control.
virtual BOOL | IsFilterHiddenColumns () const
Determines if search filter text is enabled/disabled in hidden columns.
virtual void | SetFilterHiddenColumns (BOOL bFilterHidden)
Enables/disables search filter text in hidden columns.
void | SetRecordsTreeFilterMode (int nMode)
Sets the filtering mode for the record tree.
int | GetRecordsTreeFilterMode () const
Gets the filtering mode of the record tree.
BOOL | RegisterWindowClass (HINSTANCE hInstance=NULL)
Registers the window class if it has not already been registered.
virtual BOOL | CanCut ()
Determines if the Cut operation is possible in the current context (i.e.
virtual BOOL | CanCopy ()
Determines if the Copy operation is posssible in the current context (i.e.
virtual BOOL | CanPaste ()
Determines if the Paste operation is possible in the current context (i.e.
virtual void | Cut ()
Copies the selected record data (in the binary and/or text data formats) to the clipboard and deletes the selected record data.
virtual void | Copy ()
Copies the selected record data (in the binary and/or text data formats) to the clipboard.
virtual void | Paste ()
Reads records from the clipboard and adds them to the records collection (the binary data format is used rather than the text data format).
virtual BOOL | IsEditMode ()
Determines if the in-place edit control is active (i.e.
virtual void | SetRowsCompareFunc (XTPGridRowsCompareFunc pCompareFunc)
Sets the compare function used to compare (and sort) rows.
BOOL | IsSortRecordChilds () const
Determines if the sort order is applied to record children.
void | SetSortRecordChilds (BOOL bSortRecordChildren)
Specifies if the sort order should be applied to record children.
int | GetHScrollStep () const
Gets the horizontal scrolling step.
void | SetHScrollStep (int nStep)
Sets the horizontal scrolling step.
UINT | GetAutoVScrollTimerResolution () const
Gets the vertical scrolling timer resolution.
void | SetAutoVScrollTimerResolution (UINT nNewTimerResolution)
Sets the vertical scrolling timer resolution.
BOOL | IsPreviewAllowEdit () const
Determines if preview editing is enabled/disabled.
void | PreviewAllowEdit (BOOL bAllowEdit)
Enables/disables preview editing.
BOOL | IsLockExpand () const
Determines if the user's ability to collapse/expand rows is locked.
void | LockExpand (BOOL bLockExpand)
Specifies if the user's ability to collapse/expand rows should be locked.
void | Recalc (BOOL bAll=FALSE)
Recalculates and redraws rows.
void | EnableDoubleBuffering (BOOL bEnable)
Enables/disables double-buffering.
BOOL | IsDoubleBuffering () const
Determines if double-buffering is enabled/disabled.
BOOL | IsInitialSelectionEnabled () const
Determines if initial selection is enabled/disabled.
void | InitialSelectionEnable (BOOL bEnable)
Enables/disables initial selection.
BOOL | IsRowFocusVisible () const
Determines if row focus is shown.
void | ShowRowFocus (BOOL bShow)
Specifies if row focus should be shown.
int | GetWatermarkAlignment () const
Gets the watermark alignment.
void | SetWatermarkAlignment (int nWatermarkAlignment)
Sets the watermark alignment.
void | DrawWatermark (CDC *pDC, CRect rcWatermark, CRect rcClient)
Draws a watermark.
CRect | GetElementRect (XTPGridElementRect nElement) const
Retrieves a specified grid element rectangle.
CXTPGridDataManager * GetDataManager ()
Gets the grid data manager.
void | SetMouseMode (XTPGridMouseMode nMode)
Sets the control mouse mode.
XTPGridMouseMode | GetMouseMode () const
Gets the control mouse mode.
virtual HBITMAP | GetWatermarkBitmap () const
Gets the watermark bitmap to be shown in the Grid control background.
virtual BOOL | SetWatermarkBitmap (HBITMAP hBitmap, BYTE Transparency)
Sets the watermark bitmap to be shown in the Grid control background.
virtual BOOL | SetWatermarkBitmap (LPCTSTR szPath, BYTE Transparency)
Sets the watermark bitmap to be shown in the Grid control background.
virtual CXTPGridColumn * | GetNextFocusableColumn (CXTPGridRow *pRow, int nColumnIndex, int nDirection)
Gets the next focusable column.
void | ShowIconWhenEditing (BOOL bShow)
Specifies if item icons should be shown while the item is being edited.
BOOL | IsShowIconWhenEditing ()
Determines if item icons are shown while the item is being edited.
void | SetFastDeselectMode (BOOL bFastDeselect=TRUE)
Enables/disables Fast Deselect mode (like in Windows Explorer).
void | SetIconColumn (CXTPGridColumn *pColumn)
Sets a column to be an icon view column.
void | CreateIconColumn (BOOL bUseColumnForNum=FALSE, int nWidth=40)
Creates a column as an icon view column and specifies if the column may be reused as a number column in the grid view.
void | AssignIconViewPropNumAndIconNum (int nCol=0, int nIcon=0, BOOL bUseColumnForNum=FALSE, int nWidth=20)
Creates a column as an icon view column and specifies if the column may be reused as a number column in the grid view.
void | SetIconView (BOOL bIconView=TRUE)
Toggles between Icon View mode and Grid View mode.
BOOL | IsIconView () const
Determines if Icon View mode is active.
int | GetRowsPerLine () const
Gets the number of rows per line.
int | GetNumRowsOnLine (int iTotalWidth) const
Gets the number of rows on a line of abitrary width.
void | SetNavigator (CXTPGridNavigator *pNavigator)
Sets the grid navigator.
void | ShowRowNumber (BOOL bSet)
Specifies if the row number should be shown.
BOOL | IsShowRowNumber ()
Determines if the row number is shown.
BOOL | SetCellText (int row, int col, CString sText)
Sets the text for a specified cell.
BOOL | SetCellFormula (int row, int col, CString sFormula)
Sets the formula for a specified cell.
void | UnselectGroupRows ()
Deselects all group rows.
void | ReleaseSorted ()
Releases all sorted items and clears memory.
int | GetLeftOffset () const
Gets the horizontal scroll position.
BOOL | IsDragMode () const
assessors for m_bDragMode
int | GetDragSensitivityX () const
Gets the horizontal sensitivity of Drag'n'Drop operations.
void | SetDragSensitivityX (int nDragSensitivityX)
Sets the horizontal sensitivity of Drag'n'Drop operations.
int | GetDragSensitivityY () const
Gets the vertical sensitivity of Drag'n'Drop operations.
void | SetDragSensitivityY (int nDragSensitivityY)
Sets the vertical sensitivity of Drag'n'Drop operation.
void | SetIconViewToDefaults ()
Resets the icon view column to its default values.
XTPGridScrollMode | GetScrollMode (XTPGridOrientation orientation) const
Gets the scroll mode.
void | SetScrollMode (XTPGridOrientation orientation, XTPGridScrollMode scrollMode)
Sets the scroll mode.
CXTPGridSections * | GetSections () const
Gets the sections collection.
virtual BOOL | IsCellMergingAllowed () const
Determines if cell merging is allowed.

Public Attributes

CPoint | m_ptStartDrag
The point in which dragging starts.
HCURSOR | m_hMoveCursor
The cursor while moving the blocks.
HCURSOR | m_hResizeCursor
The cursor while resizing the blocks.
int | m_nSnapMargin
The snap margin, specifies the margin that a block must be dragged into before it will snap to another block or snap to a marker.
BOOL | m_bSnapToBlocks
TRUE if the current block is about to be snapped to the blocks, otherwise.
BOOL | m_bSnapToMarkers
TRUE if the current block is is about to be snapped to the markers, FALSE otherwise.
BOOL | m_bScaleOnResize
Specifies whether to scale the track control view area when resizing the track control.
BOOL | m_bFlexibleDrag
Enables or disables flexible dragging of blocks in the track control.
BOOL | m_bAllowBlockRemove
Specifies whether the user can move blocks from one track to another.
BOOL | m_bAllowBlockScale
Specifies whether the user can resize a block.
BOOL | m_bAllowBlockMove
Specifies whether the user can move a block.
BOOL | m_bShowWorkArea
TRUE to show the work area and FALSE to hide it.
CString | m_strTimeFormat
The string which specifies the time format.
- Public Attributes inherited from CXTPGridControl
BOOL | m_bThemeMetrics
TRUE to allow themes to override control metrics.
BOOL | m_bMovePivot
Tells whether the freeze column is displayed or not when columns are added to the group by box.
BOOL | m_bStrictFiltering
Tells whether strict filtering is enabled or not.
BOOL | m_bForcePagination
Specifies whether to force the grid to be split up into "pages" while in print preview mode.
BOOL | m_bSelectionExcludeGroupRows
TRUE if the selection excludes group rows.
XTPGridInputState | m_mouseDownState
MouseDown state.
CXTPGridRow * | m_pHotExpandButtonRow
Row with hot expand button.
CXTPGridHyperlink * | m_pHotHyperlink
Hot hyperlink.
int | m_iIconWidth
Icon geometry settings.
int | m_iIconHeight
Icon geometry settings.
int | m_iIconWidthSpacing
Icon geometry settings.
int | m_iIconHeightSpacing
Icon geometry settings.
int | m_iIconPropNum
Icon view setting.
int | m_iIconNum
Icon view setting.
BOOL | m_bMarkupEnabled
Flag to check markup settings.
int | m_iIconViewColumn
Icon view setting.
BOOL | m_bIconColumnIndexNotValid
Used to indicate icon column is created, but does not yet have a valid index.
BOOL | m_bStrictBestFit
TRUE to use BestFit only for non-autosize mode.
BOOL | m_bWasShiftKey
Flag set on MouseUp or KeyUp if Shift key was On.
BOOL | m_bSortedDragDrop
Flag to set Drag Drop mode like Vista Windows Explorer or XP Windows Explorer.
BOOL | m_bTrapTabKey
Flag to set Trap Tab key in m_bEditOnClick && m_bAllowEdit case.
BOOL | m_bDesktopTrackerMode
Flag to set Vista Tracker Mode On or Off.
BOOL | m_bUnrestrictedDragDrop
TRUE to allow a child to be dropped to any pos; default = FALSE.
BOOL | m_bFreeHeightMode
Flag to set RC Free Height Mode.
int | m_nDefaultRowFreeHeight
Row height for initialization.
CString | m_sCustomTitle
Used for a unique title (e.g.
BOOL | m_bRClickDrag
TRUE to allow drag on right click.
BOOL | m_bKeepSelectionAfterSort
TRUE to keep the selection after sorting items.
int | m_iColumnForNum
Index of the row number column used.

Protected Attributes

int | m_nTimeLineMin
Minimum value for the time line.
int | m_nTimeLineMax
Maximum value for the time line.
double | m_nViewPortMin
Minimum value for the view port.
double | m_nViewPortMax
Maximum value for the view port.
int | m_nOldTrackWidth
The old track width.
double | m_nOldTrackViewPortRange
The old track view port range.
int | m_nWorkAreaMin
The minimum value for the work area.
int | m_nWorkAreaMax
The maximum value for the work area.
int | m_nTimeLinePosition
The trim line position.
int | m_nTrackColumnIndex
The track column index.
CRect | m_rcSelectedArea
The selected area.
CXTPTrackMarkers * | m_pMarkers
The marker collection object.
CRect | m_rcTimelineArea
The area of the time line.
CArray< DRAGBLOCK, DRAGBLOCK & > | m_arrDragBlocks
The collection of blocks which are being dragged.
CXTPTrackSelectedBlocks * | m_pSelectedBlocks
The pointer to the selected blocks object.
CXTPTrackUndoManager * | m_pUndoManager
The pointer to the undo manager object.
XTPTrackMouseCursorMode | m_mouseCursorMode
Current mouse operation mode.
- Protected Attributes inherited from CXTPGridControl
BOOL | m_bDoubleBuffering
Enables double-buffering.
BOOL | m_bChanged
Internal member for storing changed flag.
BOOL | m_bInternalMove
Internal member for storing DD run-time flag.
int | m_nLockUpdateCount
A counter of the update locks.
CRect | m_rcGroupByArea
The area occupied by Group By item.
CRect | m_rcHeaderArea
The area occupied by the header.
CRect | m_rcFooterArea
The area occupied by the footer.
CXTPGridColumns * | m_pColumns
List columns container.
CXTPGridRows * m_pRows
Virtual list rows container.
CXTPGridHeader * | m_pGridHeader
List header member.
CXTPMarkupContext * | m_pMarkupContext
Markup context.
CXTPGridPaintManager * | m_pPaintManager
Paint manager.
CXTPGridNavigator * | m_pNavigator
Navigator.
XTPGridScrollUpdateMode | m_scrollUpdateMode
Scroll update mode.
XTPGridScrollMode | m_scrollModeH
Horizontal scroll mode.
XTPGridScrollMode | m_scrollModeV
Vertical scroll mode.
int | m_nScrollOffsetH
Horizontal scroll position.
int | m_nScrollStepH
Horizontal scroll step (in pixels).
int | m_nScrollStepV
Vertical scroll step (in pixels).
int | m_nDisableReorderColumnsCount
Count of columns at the left side where reordering is disabled.
CXTPGridSelectedRows * | m_pSelectedRows
Container for the currently selected rows.
CXTPGridRow * | m_pHotRow
Hot row.
int | m_nRowsPerWheel
Amount of rows to scroll by mouse wheel.
CXTPGridTip * | m_pTip
Tip window.
CBitmap | m_bmpCache
Cached window bitmap.
BOOL | m_bGroupByEnabled
TRUE if Group By box is enabled.
BOOL | m_bSortRecordChilds
TRUE to apply sort order for record children.
XTPGridMouseMode | m_mouseMode
Current mouse operation mode.
BOOL | m_bBlockSelection
TRUE if multiple selection is enabled.
BOOL | m_bMultiSelectionMode
TRUE if multi-selection mode is enabled (i.e.
BOOL | m_bShowTooltips
TRUE if show tooltips is enabled.
BOOL | m_bAutoCheckItems
TRUE to enable auto-check mode, FALSE to disable auto-check mode.
CXTPImageManager * | m_pImageManager
Image list for the Grid control.
BOOL | m_bSkipGroupsFocus
TRUE if group rows are skipped when navigating rows with the Up and Down arrow keys.
BOOL | m_bLockExpand
TRUE if collapsing/expanding rows is locked.
BOOL | m_bEnsureFocusedRowVisible
TRUE if focused rows will be forced visible.
BOOL | m_bFocusSubItems
TRUE if sub-items can receive focus.
BOOL | m_bEditOnClick
TRUE if sub-items become editable on a single-click.
BOOL | m_bEditOnDelayClick
TRUE if sub-items become editable on a delay-click.
BOOL | m_bEditOnDoubleClick
TRUE if sub-items become editable on a double-click.
BOOL | m_bPreviewAllowEdit
TRUE if the preview of the row can be edited.
BOOL | m_bHeaderVisible
TRUE if column headers are visible.
BOOL | m_bFooterVisible
TRUE if column footers are visible.
BOOL | m_bPinFooterRows
TRUE if footer rows are drawn immediately after the body rows.
BOOL | m_bPinFooterRowsPrinted
TRUE if footer rows are printed immediately after the body rows.
BOOL | m_bInitialSelectionEnable
TRUE if Initial (in Populate() call) selection is enabled.
BOOL | m_bRowFocusVisible
TRUE if showing focused row rectangle is enabled.
CXTPGridColumn * | m_pFocusedColumn
Pointer to the currently focused CXTPGridColumn.
CXTPToolTipContext * | m_pToolTipContext
Tooltip context.
CXTPGridRecordItem * | m_pActiveItem
Pointer to the currently focused CXTPGridRecordItem.
CXTPGridInplaceEdit * | m_pInplaceEdit
In-place edit pointer.
CXTPGridInplaceButtons * | m_pInplaceButtons
In-place buttons pointer.
CXTPGridInplaceList * | m_pInplaceList
In-place list pointer.
BOOL | m_bVScrollBarVisible
TRUE if vertical scrollbar is visible.
BOOL | m_bHScrollBarVisible
TRUE if horizontal scrollbar is visible.
UINT | m_nAutoVScrollTimerResolution
Vertical scrolling timer resolution (in milliseconds).
CPoint | m_ptDrag
Drag position.
int | m_nDragSensitivityX
Horizontal sensitivity of Drag'n'Drop operation (in pixels).
int | m_nDragSensitivityY
Vertical sensitivity of Drag'n'Drop operation (in pixels).
BOOL | m_bPrepareDrag
TRUE if the user clicks the Grid control and does not release the button.
CString | m_strFilterText
Filter text.
BOOL | m_bFilterHiddenColumns
Search filter text in hidden columns too.
int | m_nRecordsTreeFilterMode
Tree Filter mode.
CLIPFORMAT | m_cfGrid
Grid clipboard format for drag/drop operations.
CGridDropTarget * | m_pDropTarget
Internal drag/drop helper.
BOOL | m_bDragMode
TRUE if records are currently being dragged.
BOOL | m_bInternalDrag
TRUE if records begin dragging from this control.
DWORD | m_dwDragDropFlags
Drag/drop flags.
DWORD | m_dwDropMarkerFlags
The drop marker flags.
CXTPGridSelectedRows * | m_pSelectedRowsBeforeDrag
The selected rows before a dragging action.
int | m_nDropPos
Position of records to be dropped.
CXTPGridRecords * | m_pDropRecords
Drop records.
BOOL | m_bAdjustLayoutRunning
TRUE if AdjustLayout handler is entered, FALSE otherwise.
UINT_PTR | m_uAutoScrollTimerID
Auto scroll timer ID or 0.
CXTPGridRow * | m_ptrVirtualEditingRow
Currently editing row in virtual mode.
XTPGridRowsCompareFunc | m_pRowsCompareFunc
Pointer to the rows compare function.
HBITMAP | m_hbmpWatermark
Watermark bitmap handle.
BYTE | m_WatermarkTransparency
Watermark bitmap transparency value.
BITMAP | m_bmWatermark
Watermark bitmap info.
XTPGridWatermarkAlignment | m_WatermarkAlignment
Watermark alignment flags.
int | m_nEnsureVisibleRowIdx
Ensure visible row index.
int | m_nEnsureVisibleColumnIdx
Ensure visible column index.
CXTPGridDataManager * | m_pDataManager
Data manager.
BOOL | m_bShowIconWhenEditing
TRUE to show item icons while the item is being edited.
BOOL | m_bCreated
TRUE if created using the Create() method.
BOOL | m_bIconView
TRUE if icon view, FALSE otherwise.
int | m_iIconViewRowsPerLine
The icon view rows per line.
CXTPGridColumnOrder * | m_pPrevVisible
The previous visible column order.
CXTPGridColumnOrder * m_pPrevGroupsOrder
The previous group column order.
BOOL | m_bPrevFocusSubItems
TRUE if there are previous focused sub-items, FALSE otherwise.
BOOL | m_bPrevHeaderAutoSize
TRUE if the previous header is auto-size, FALSE otherwise.
BOOL | m_bPrevHeaderRows
TRUE if there are previous header rows, FALSE otherwise.
BOOL | m_bPrevFooterRows
TRUE if there are previous footer rows, FALSE otherwise.
int | m_nPrevTreeIndent
Tree indentation.
BOOL | m_bPrevHeaderShow
Tells whether the previous header is visible or not.
BOOL | m_bPrevFooterShow
Tells whether the previous footer is visible or not.
BOOL | m_bPrevPreviewMode
Tells whether the preview mode is enabled or not previously.
BOOL | m_bNoNeedSortedDragDrop
Dynamic flag during Sorted DragDrop operation (set during OnDragOver state - used during OnDrop state)
UINT_PTR | m_uiDelayEditTimer
The delay edit timer.
UINT | m_uiDelayEditMaxTime
The delay edit time interval.
int | m_iLastRqstEditRow
The last row which requested a delay edit.
int | m_iLastRqstEditCol
The last column which requested a delay edit.
UINT_PTR | m_uRqstEditTimer
The edit timer ID.
BOOL | m_bFastDeselectMode
Tells whether the fast deselect mode is enabled or not.
XTPGridPaintTheme | m_themeCurrent
Currently set theme.
BOOL | m_bRelayWndMsg
Used for relaying window messages.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPGridControl
static BOOL AFX_CDECL | UseGridCustomHeap ()
Call this function to use the custom heap feature.
static BOOL AFX_CDECL | UseRowBatchAllocation ()
Call this function to enable the batch allocation feature for grid rows.
static void AFX_CDECL | FreeRowBatchExtraData ()
This function is used when row batch allocation is enabled to both check all allocated blocks and deallocate any blocks which are completely free.
- Protected Member Functions inherited from CXTPGridControl
virtual void | OnDraw (CDC *pDC)
Performs all drawing logic.
virtual void | DrawNoItems (CDC *pDC, const CRect &rcClient)
Draws the 'NoItems' text in the provided device conext.
BOOL | IsChanged () const
Determines if the internal control state was changed since the last drawing.
void | SetChanged (BOOL bChanged=TRUE)
Specifies if the internal control state was changed since the last drawing.
virtual void | ReSortRows ()
Re-sorts the rows tree according to the sort order for columns.
void | UpdateSubList ()
Updates the field chooser control with its content.
virtual int | InsertRow (int nIndex, CXTPGridRow *pRow)
Inserts a specified row at a specified index in the rows array.
virtual BOOL | ApplyFilter (CXTPGridRecord *pRecord, CString strFilterText, BOOL bIncludePreview)
Checks a record for filter text.
virtual void | OnSelectionChanged ()
This member function is called after a user selects a row or a column.
virtual BOOL | OnFocusChanging (CXTPGridRow *pNewRow, CXTPGridColumn *pNewCol)
This member function is called before the focus changes.
virtual void | GetItemMetrics (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pItemMetrics)
Calculates metrics for a row.
virtual CXTPGridRow * | CreateRow ()
Creates a CXTPGridRow object.
virtual CXTPGridGroupRow * | CreateGroupRow ()
Creates a CXTPGridGroupRow object.
virtual CXTPGridRow * | CreateHeaderFooterRow ()
Creates a CXTPGridRow object for header/footer rows.
virtual void | OnBeginDrag (CPoint point)
This method is called when the user begins dragging a row.
virtual void | OnBeginDrag (CPoint point, UINT nFlags)
This method is called when the user begins dragging a row.
virtual BOOL | OnBeforeCopyToText (CXTPGridRecord *pRecord, CStringArray &rarStrings)
This method is called before a record is copied to the clipboard in text format.
virtual BOOL | OnBeforePasteFromText (CStringArray &arStrings, CXTPGridRecord **ppRecord)
This method is called before creating a new record using text data from the clipboard.
virtual BOOL | OnBeforePaste (CXTPGridRecord **ppRecord)
This method is called after creating a new record using binary data from the clipboard, but before adding it to records collection.
virtual BOOL | OnPreviewKeyDown (UINT &rnChar, UINT nRepCnt, UINT nFlags)
This method is called before processing the OnKeyDown event.
virtual int | OnGetColumnDataBestFitWidth (CXTPGridColumn *pColumn)
This method is used by the Grid control to calculate the best-fit column width.
virtual int | OnGetItemsCaptionMaxWidth (CDC *pDC, CXTPGridRows *pRows, CXTPGridColumn *pColumn, int nStartRow=0, int nRowsCount=-1)
This method is used by the Grid control to calculate the items captions maximum width.
virtual void | EnsureStartAutoVertScroll ()
This method is used to start monitoring mouse position for automatic vertical scrolling.
virtual void | EnsureStopAutoVertScroll ()
This method is used to stop monitoring mouse position for automatic vertical scrolling.
virtual void | DoAutoVertScrollIfNeed (CPoint ptClick, CPoint pt)
This method is used to monitor mouse position.
virtual int | GetRowsHeight (CXTPGridRows *pRows, int nTotalWidth, int nMaxHeight=-1)
Calculates the combined height of all rows within a specified rows collection.
virtual BOOL | OnConstraintSelecting (CXTPGridRow *pRow, CXTPGridRecordItem *pItem, CXTPGridColumn *pColumn, CXTPGridRecordItemConstraint *pConstraint)
This method is used to notify about changes to the constraint selection.
virtual const XTP_NM_GRIDTOOLTIPINFO & | OnGetToolTipInfo (CXTPGridRow *pRow, CXTPGridRecordItem *pItem, CString &rstrToolTipText)
This method is called to get the tooltip text for the current record item.
void | AdjustIndentation ()
Adjusts control indentation properties depending on the current tree depth.
virtual DROPEFFECT | OnDragOver (COleDataObject *pDataObject, DWORD dwKeyState, CPoint point, int nState)
This member is called when an item is dragged over the Grid control.
virtual BOOL | OnDrop (COleDataObject *pDataObject, DROPEFFECT dropEffect, CPoint point)
This member is called when an item has been dropped into the Grid control.
virtual void | RelayToolTipEvent (UINT message)
Relays a tooltip event.
- Static Protected Member Functions inherited from CXTPGridControl
static UINT AFX_CDECL | GetMouseScrollLines ()
Gets the number of rows per mouse scroll.

Detailed Description

This class represents a track control.

The track control is an extension to the Grid control. It can do basically everything the Grid control can do with the addition of a track control.

Member Function Documentation

◆ DoPropExchange()

void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Call this member function to store/load the properties related to the track control.

Parameters
pPX Source/destination CXTPPropExchange data object reference.

This member function is used to store/load property data to/from storage.

Reimplemented from CXTPGridControl.

◆ DrawRows()

int DrawRows | ( | CDC * | pDC,
 |  | CRect & | rcClient,
 |  | int | y,
 |  | CXTPGridRows * | pRows,
 |  | int | nTopRow,
 |  | int | nColumnFrom,
 |  | int | nColumnTo,
 |  | int * | pnHeight )
 virtual

Draws all rows in the provided device context.

Parameters
pDC | Provided device context to draw rows image with.
rcClient | Reference to a rectangle to draw rows image into.
pRows | Rows collection to draw.
nTopRow | Index of the topmost visible row of the rows collection.
nColumnFrom | Index of the first column to draw from.
nColumnTo | Index of the last column to draw to.
pnHeight | Pointer to an integer to receive the total height of the drawn rows; can be NULL.
y | Distance from the top.
Returns
The index of the last printed row.

Reimplemented from CXTPGridControl.

◆ EnsureVisible()

void EnsureVisible ( CXTPTrackBlock * pBlock )

Call this function to ensure that a specified block is visible.

Parameters
pBlock Pointer to the CXTPTrackBlock whose visibility must be ensured.

◆ GetMarkers()

AFX_INLINE CXTPTrackMarkers * GetMarkers ( ) const

Gets the track markers object associated with the track control.

Returns
A pointer to the track markers object associated with the track control.

CXTPTrackMarkers is a collection of all of the track markers in the track control. This collection has methods to add/delete/access track markers. Track markers are used for block alignment. Blocks can be "snapped" to the left or right of these markers.

◆ GetMouseCursorMode()

AFX_INLINE XTPTrackMouseCursorMode GetMouseCursorMode ( ) const

Gets the mouse cursor mode.

Returns
The mouse cursor mode; one of the values defined by the XTPTrackMouseCursorMode enumeration.

◆ GetSelectedBlocks()

AFX_INLINE CXTPTrackSelectedBlocks * GetSelectedBlocks ( ) const

Gets the selected blocks in the track control.

Returns
A pointer to the CXTPTrackSelectedBlocks object.

◆ GetSnapMargin()

AFX_INLINE int GetSnapMargin ( ) const

Gets the snap margin.

Returns
The snap margin.

Snap margin specifies the margin that a block must be dragged into before it will snap to either another block or a marker.

◆ GetTimelineArea()

AFX_INLINE CRect GetTimelineArea ( ) const

Gets the time line area.

Returns
A CRect object containing the bounds of the time line area.

◆ GetTimeLineMax()

AFX_INLINE int GetTimeLineMax ( ) const

Gets the maximum time line position.

Returns
The maximum time line position.

◆ GetTimeLineMin()

AFX_INLINE int GetTimeLineMin ( ) const

Gets the minimum time line position.

Returns
The minimum time line position.

◆ GetTimeLinePosition()

AFX_INLINE int GetTimeLinePosition ( ) const

Gets the time line position.

Returns
The time line position.

◆ GetTrackColumn()

CXTPGridColumn * GetTrackColumn ( ) const

Gets the track column.

Returns
A pointer to the track column.

◆ GetTrackColumnIndex()

int GetTrackColumnIndex ( ) const

Gets the index of the track column.

Returns
The zero-based index of the track column.

◆ GetTrackOffset()

int GetTrackOffset ( ) const

Gets the track offset.

Returns
The track offset.

◆ GetTrackPaintManager()

AFX_INLINE CXTPTrackPaintManager * GetTrackPaintManager ( ) const

Gets the track paint manager associated with this control.

Returns
A pointer to the track paint manager associated with this control.

◆ GetUndoManager()

AFX_INLINE CXTPTrackUndoManager * GetUndoManager ( ) const

Gets the undo manager associated with the track control.

Returns
A pointer to the track undo manager object associated with the track control.

The track undo manager allows for certain operation to be undone and redone in the track control. Supported operations are add/remove/move markers and add/remove/move/resize blocks. If any of these operations are performed, then they can easily be undone/redone using the methods of the CXTPTrackUndoManager.

◆ GetViewPortMax()

AFX_INLINE int GetViewPortMax ( ) const

Gets the maximum value of the view port.

Returns
The maximum value of the view port.

◆ GetViewPortMin()

AFX_INLINE int GetViewPortMin ( ) const

Gets the minimum value of the view port.

Returns
The minimum value of the view port.

◆ GetWorkAreaMax()

AFX_INLINE int GetWorkAreaMax ( ) const

Gets the maximum value of the work area range.

Returns
The maximum value of the work area range.

◆ GetWorkAreaMin()

AFX_INLINE int GetWorkAreaMin ( ) const

Gets the minimum value of the work area range.

Returns
The minimum value of the work area range.

◆ HitTest()

virtual BOOL HitTest | ( | CPoint | pt,
 |  | CXTPGridHitTestInfo * | pInfo ) const
 virtual

Determines which grid part, if any, is at a specified point.

Parameters
pt | Point to be tested.
pInfo | Pointer to a CXTPGridHitTestInfo object that will receive returned information.
Returns
TRUE if successful, otherwise FALSE.

Reimplemented from CXTPGridControl.

◆ PositionToTrack()

int PositionToTrack ( int nPosition )

Converts a coordinate point on the track control to a track point.

Parameters
nPosition Coordinate point to convert.
Returns
The converted track point.

◆ RegisterWindowClass()

BOOL RegisterWindowClass ( HINSTANCE hInstance = NULL )

Registers the window class if it has not already been registered.

Parameters
hInstance Instance of the resource where the control is located.
Returns
TRUE if the window class was successfully registered.

◆ SendMessageToParent()

LRESULT SendMessageToParent | ( | UINT | nMessage,
 |  | CXTPTrackBlock * | pBlock = NULL,
 |  | CXTPTrackMarker * | pMarker = NULL ) const

Sends messages to the parent window of the track control.

Parameters
nMessage | Message to be sent.
pBlock | Related block.
pMarker | Related marker.

This function is useful to send notification to the parent window when some event happens in the track control.

Returns
The result of the message processing.

◆ SetMouseCursorMode()

AFX_INLINE void SetMouseCursorMode ( XTPTrackMouseCursorMode enMode )

Sets the mouse cursor mode.

Parameters
enMode Mouse cursor mode; must be one of the values defined by the XTPTrackMouseCursorMode enumeration.

◆ SetTimeLinePosition()

void SetTimeLinePosition ( int nTimeLinePos )

Sets the time line position.

Parameters
nTimeLinePos Time line position.

◆ SetTimeLineRange()

AFX_INLINE void SetTimeLineRange | ( | int | nTimeScaleMin,
 |  | int | nTimeScaleMax )

Sets the time line range.

Parameters
nTimeScaleMin | Start value of the view port rectangle.
nTimeScaleMax | End value of the view port rectangle.

◆ SetViewPort()

void SetViewPort | ( | int | nViewPortMin,
 |  | int | nViewPortMax )

Sets the view port of the work area.

Parameters
nViewPortMin | Start value of the view port rectangle.
nViewPortMax | End value of the view port rectangle.

◆ SetWorkArea()

AFX_INLINE void SetWorkArea | ( | int | nWorkAreaMin,
 |  | int | nWorkAreaMax )

Sets the bounds of the work area.

Parameters
nWorkAreaMin | Start value of the work area rectangle.
nWorkAreaMax | End value of the work area rectangle.

◆ SnapPosition()

int SnapPosition ( int nPosition )

Gets a snap position for a block at a specified position on the track.

The snap position depends on if the block should snap to either another block or a marker.

Parameters
nPosition Cursor position.
Returns
Snap position for the block.

◆ StartDragBlocks()

void StartDragBlocks ( BOOL bResize )

Call this function when you are about to start dragging a block.

Parameters
bResize TRUE to resize the block, FALSE to drag.

◆ TrackToPosition()

int TrackToPosition ( int nTrack ) const

Converts a track point to a coordinate point on the track control.

Parameters
nTrack Track point to convert.
Returns
The converted coordinate point on the track control.
The documentation for this class was generated from the following file:
  • XTPTrackControl.h


Toolkit Pro: CXTPTrackControl::DRAGBLOCK Struct Reference

  • CXTPTrackControl
  • DRAGBLOCK
Public Attributes | List of all members
CXTPTrackControl::DRAGBLOCK Struct Reference

This structure abstracts the state of block being dragged. More...

Public Attributes

int | nOldPos
The old position.
int | nOldLength
The old length.
CRect | rcOrigin
The original rectangle.
CXTPTrackBlock * | pBlock
Pointer to the block.

Detailed Description

This structure abstracts the state of block being dragged.

The documentation for this struct was generated from the following file:
  • XTPTrackControl.h


Toolkit Pro: CXTPTrackControlItem Class Reference

Public Member Functions | Public Attributes | Protected Member Functions | Protected Attributes | List of all members
CXTPTrackControlItem Class Reference

This class represents a container cell for a set of blocks and keys and inherits basic functionality from the CXTPGridRecordItem class. More...

Inheritance diagram for CXTPTrackControlItem:
[legend]

Public Member Functions

CXTPTrackControlItem ()
Creates a CXTPTrackControlItem item.
virtual | ~CXTPTrackControlItem ()
CXTPTrackControlItem default destructor.
CString | GetCaption (CXTPGridColumn *pColumn)
Retrieves the text caption of the current item.
virtual int | Draw (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs)
Should be overridden by descendants for drawing itself.
CXTPTrackBlock * | HitTest (CPoint ptPoint)
Determines which block, if any, is at a specified point.
BOOL | Remove (CXTPTrackBlock *pBlock)
Removes a block.
BOOL | RemoveAt (int nIndex)
Removes a block.
void | RemoveAll ()
Removes all blocks.
CXTPTrackBlock * | Add (CXTPTrackBlock *pBlock)
Adds a block to the track.
CXTPTrackControl * | GetTrackControl () const
Retrieves the track control associated with this item.
CXTPTrackBlock * | GetBlock (int nIndex) const
Retrieves a specified block.
int | GetBlockCount () const
Calculates the number of blocks in the track control.
BOOL | IsLocked () const
Gets the locked state of the track control.
void | SetLocked (BOOL bLocked=TRUE)
Sets the locked state of the track control.
virtual BOOL | OnLButtonDown (XTP_GRIDRECORDITEM_CLICKARGS *pClickArgs)
Processes mouse left button down clicks.
virtual BOOL | OnLButtonUp (XTP_GRIDRECORDITEM_CLICKARGS *pClickArgs)
Processes mouse left button up clicks.
virtual void | OnClick (XTP_GRIDRECORDITEM_CLICKARGS *pClickArgs)
Processes single mouse clicks.
virtual void | OnDblClick (XTP_GRIDRECORDITEM_CLICKARGS *pClickArgs)
Processes double mouse clicks.
virtual void | OnMouseMove (UINT nFlags, CPoint point, CXTPGridControl *pControl=NULL)
Processes the move mouse event.
virtual void | DoPropExchange (CXTPPropExchange *pPX)
Call this member function to store/load a grid record item using the specified data object.
INT_PTR | OnToolHitTest (CPoint point, TOOLINFO *pTI)
Call this member function to perform a hit test on the track control at a specified point and fill a TOOLINFO structure with the contextual display string.
void | RecalcLayout ()
Call this method to recalculate the size of the track items when the layout is changed.
void | AdjustBlockPosition (CXTPTrackBlock *pBlock, BOOL bResize=FALSE)
Adjusts the block position when a block is resized/moved.
void | RedrawControl ()
Redraws the track control.
virtual CString | GetCaption ()
Gets the text caption of the item.
- Public Member Functions inherited from CXTPGridRecordItem
CXTPGridRecordItem ()
CXTPGridRecordItem default constructor.
virtual | ~CXTPGridRecordItem ()
CXTPGridRecordItem default destructor.
virtual void | OnDrawCaption (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics)
Should be overridden by descendants for drawing itself.
virtual void | OnDrawControls (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CRect &rcItem)
Should be overridden by descendants for drawing itself.
CXTPGridRecordItemControl * | HitTest (CPoint ptPoint)
Determines which grid record item control, if any, is at a specified point.
virtual int | HitTestHyperlink (CPoint ptClick)
Determines if a mouse click occurred on a hyperlink.
CString | GetColumnCaptionPrefix (CXTPGridColumn *pColumn) const
Gets the caption prefix of a specified column.
virtual void | GetCaptionRect (XTP_GRIDRECORDITEM_ARGS *pDrawArgs, CRect &rcItem)
Retrieves the caption text bounding rectangle.
virtual CString | GetGroupCaption (CXTPGridColumn *pColumn)
Gets the group caption text.
virtual COleVariant | GetGroupCaptionValue (CXTPGridColumn *pColumn)
Gets the group caption native value.
virtual int | GetGroupCaptionID (CXTPGridColumn *pColumn)
Gets the group caption ID.
virtual int | CompareGroupCaption (CXTPGridColumn *pColumn, CXTPGridRecordItem *pItem)
Compares the group caption of the current record item with the group caption of a provided record item/group row.
virtual int | CompareGroupCaption (CXTPGridColumn *pColumn, CXTPGridGroupRow *pGroupRow)
Compares the group caption of the current record item with the group caption of a provided record item/group row.
virtual int | Compare (CXTPGridColumn *pColumn, CXTPGridRecordItem *pItem)
Compares the current record item with a provided record item.
virtual void | SetFont (CFont *pFont)
Sets the record item text font.
virtual CFont * | GetFont ()
Gets the record item text font.
virtual CString | GetTooltip () const
Gets the tooltip text of the record item.
virtual void | SetTooltip (LPCTSTR lpszTooltip)
Sets the tooltip text for the record item.
virtual void | SetTextColor (COLORREF clrText)
Sets the record item text color.
virtual COLORREF | GetTextColor ()
Gets the record item text color.
virtual void | SetBold (BOOL bBold=TRUE)
Sets the bold state of the record item font.
virtual BOOL | IsBold () const
Determines the bold state of the record item font.
virtual void | SetBackgroundColor (COLORREF clrBackground)
Sets the record item text background color.
virtual COLORREF | GetBackgroundColor ()
Gets the record item text background color.
virtual CString | GetFormula () const
Gets the record item formula.
virtual void | SetFormula (LPCTSTR sFormula)
Sets the record item formula.
virtual CString | GetFormatString () const
Gets the record item caption format string.
virtual void | SetFormatString (LPCTSTR strFormat)
Sets the record item caption format string.
virtual BOOL | IsEditable () const
Determines the editable state of the record item.
virtual BOOL | SetEditable (BOOL bEditable=TRUE)
Sets the editable state for the record item.
virtual int | AddHyperlink (CXTPGridHyperlink *pHyperlink)
Adds a new hyperlink to the record item.
virtual int | GetHyperlinksCount () const
Gets the number of hyperlinks in the record item.
virtual CXTPGridHyperlink * | GetHyperlinkAt (int nHyperlink) const
Retrieves the hyperlink at a specified index.
virtual void | RemoveHyperlinkAt (int nHyperlink)
Removes the hyperlink at a specified index.
virtual void | GetItemMetrics (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pItemMetrics)
Calculates preview item metrics based on specified draw arguments.
virtual BOOL | IsPreviewItem () const
Determines if the record item is a preview item.
int | GetIndex () const
Gets the index of the record item.
virtual int | GetIconIndex () const
Gets the ID of the associated resource bitmap.
virtual int | SetIconIndex (int nIconIndex)
Sets the ID for the associated resource bitmap.
int | GetAlignment () const
Gets the alignment value of the record item.
int | SetAlignment (int nAlignment)
Sets the alignment value for the record item.
virtual int | GetSortPriority () const
Gets the sort priority of the record item.
virtual void | SetSortPriority (int nSortPriority)
Sets the sort priority for the record item.
virtual int | GetGroupPriority () const
Gets the group priority of the record item.
virtual void | SetGroupPriority (int nGroupPriority)
Sets the group priority for the record item.
virtual void | SetGroupCaption (LPCTSTR strCaption)
Sets the group caption for the record item.
virtual void | SetCaption (LPCTSTR strCaption)
Sets the caption for the record item.
void | UpdateValue ()
Causes formula computed value to be updated.
virtual void | SetChecked (BOOL bChecked)
Sets if the record item is checked.
virtual BOOL | IsChecked () const
Determines if the record item is checked.
void | SetCheckedState (int iState)
Sets the checked state for the record item.
int | GetCheckedState () const
Gets the checked state of the record item.
virtual void | HasCheckbox (BOOL bHasCheckbox, BOOL bTristate=FALSE)
Adds check box area for item.
virtual BOOL | GetHasCheckbox () const
Determines if item has check box area.
BOOL | GetCanEditCheckboxItem () const
Returns whether items with a check box will go into edit mode on click.
void | SetCanEditCheckboxItem (BOOL bSet)
Specifies whether items with a check box will go into edit mode on click.
void | SetRecord (CXTPGridRecord *pGridRecord)
Sets the parent record object.
CXTPGridRecord * | GetRecord () const
Gets the parent record object.
virtual DWORD_PTR | GetItemData () const
Retrieves the application-supplied, 32-bit value associated with the record item.
virtual void | SetItemData (DWORD_PTR dwData)
Sets the 32-bit value associated with the record item.
virtual BOOL | IsFocusable () const
Determines if the record item can receive focus.
virtual void | SetFocusable (BOOL bFocusable)
Specifies if the record item can receive focus.
CXTPMarkupUIElement * | GetMarkupUIElement () const
Gets the Markup element that renders the item.
virtual void | ResetMarkupUIElement ()
Resets the Markup element.
BOOL | IsChildOfMerge () const
Determines if the current item is in a merge group and, if so, if it is not the left-top (main) item of the group.
virtual void | OnCancelEdit (CXTPGridControl *pControl, BOOL bApply)
This method is called when the user cancels editing an item.
virtual void | OnValidateEdit (XTP_GRIDRECORDITEM_ARGS *pItemArgs)
This method is called to save the value from an in-place edit.
virtual void | OnEditChanged (XTP_GRIDRECORDITEM_ARGS *pItemArgs, LPCTSTR szText)
This method is called when the value of the in-place edit control is changed.
virtual BOOL | OnEditChanging (XTP_GRIDRECORDITEM_ARGS *pItemArgs, CString &rstrNewText)
This method is called before the value of the in-place editor is changed by the user.
virtual void | OnEditCanceled (XTP_GRIDRECORDITEM_ARGS *pItemArgs)
This method is called when in-place editing has been canceled and the value has not changed.
virtual void | OnConstraintChanged (XTP_GRIDRECORDITEM_ARGS *pItemArgs, CXTPGridRecordItemConstraint *pConstraint)
This method is called when the value of the selected contraint of the in-place list is changed by the user.
virtual DWORD | GetSelectedConstraintData (XTP_GRIDRECORDITEM_ARGS *pItemArgs)
Gets the value associated with a selected constraint.
virtual void | OnInplaceButtonDown (CXTPGridInplaceButton *pButton)
This method is called when the user presses the in-place button of the item.
CXTPGridRecordItemEditOptions * | GetEditOptions (CXTPGridColumn *pColumn)
Gets the edit options of the item.
CXTPGridRecordItemControls * GetItemControls ()
Gets the item controls list.
BOOL | CreateBorder ()
Creates a border for this item.
BOOL | DestroyBorder ()
Destroys the border of this item.
CXTPGridBorder * | GetBorder () const
Gets the border of this item.
void | SetGridControl (CXTPGridControl *pControl)
Sets the parent grid object.
- Public Member Functions inherited from CXTPHeapObjectT< CXTPCmdTarget, CXTPGridDataAllocator >
void *PASCAL | operator new (size_t nSize)
Allocate memory block of nSize bytes.
void PASCAL | operator delete (void *p)
Free memory block previously allocated by operator new.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Public Attributes

BOOL m_bLocked
TRUE if the whole track is locked.
- Public Attributes inherited from CXTPGridRecordItem

Protected Member Functions

virtual void | HighlightWorkArea (CDC *pDC, CRect rcItem)
Highlights the work area.
- Protected Member Functions inherited from CXTPGridRecordItem
virtual void | DrawCheckBox (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CRect &rcItem)
Draws the check box bitmap.
CXTPGridHyperlinks * GetHyperlinks ()
Gets the hyperlinks collection.
virtual BOOL | OnRequestEdit (XTP_GRIDRECORDITEM_ARGS *pItemArgs)
This method is called when an editable item enters edit mode.
virtual void | OnBeginEdit (XTP_GRIDRECORDITEM_ARGS *pItemArgs)
This method is called when the user begins to edit an item.
virtual BOOL | OnChar (XTP_GRIDRECORDITEM_ARGS *pItemArgs, UINT nChar)
This method is called when the user presses a key.

Protected Attributes

CXTPTrackBlockArray | m_arrBlocks
Blocks array.
- Protected Attributes inherited from CXTPGridRecordItem
CXTPGridControl * | m_pControl
Parent Grid control.
CXTPGridRecord * | m_pRecord
Pointer to the associated record.
CXTPGridBorder * | m_pBorder
Item border.
CFont * | m_pFontCaption
Storage for item caption font.
COLORREF | m_clrText
Storage for item text color.
COLORREF | m_clrBackground
Storage for item background color.
BOOL | m_bBoldText
TRUE if bold text.
CString | m_strFormatString
Stores string for extra formatting of item caption.
CString | m_strFormula
Stores Formula with simple algorithm to calculate.
BOOL | m_bEditable
Stores editable flag.
CXTPGridHyperlinks * | m_pHyperlinks
Array of the Item's hyperlinks.
int | m_nIconIndex
ID of the bitmap from the application resources.
int | m_nSortPriority
Sort priority.
int | m_nGroupPriority
Group priority.
CString | m_strGroupCaption
Caption of the group.
CString | m_strCaption
Caption of the item.
BOOL | m_bFocusable
TRUE if item accept focus.
int | m_checkState
TRUE if item checked.
BOOL | m_bHasCheckbox
TRUE if item has check box.
BOOL | m_bCanEditCheckboxItem
TRUE if an item with a check box will get an edit control (only useful if column is wide)
BOOL | m_bTristateCheckbox
TRUE if the check box is tri-state.
DWORD_PTR | m_dwData
The 32-bit value associated with the item.
CString | m_strTooltip
Tooltip of the item.
CXTPGridRecordItemEditOptions * | m_pEditOptions
Edit options of the item.
XTPGridColumnIconAlignment | m_Alignment
Alignment style for item.
CXTPGridRecordItemControls * | m_pItemControls
Record item control list.
CXTPGridRecordItemControl * | m_pFocusedItemControl
Focused record item control.
BOOL | m_bItemControlUnderMouse
TRUE if an item control is under the mouse pointer.
CXTPGridRecordItemControlHookWnd * | m_pItemControlHookWnd
Item control hook window.
CRect | m_rcGlyph
Coordinates of drawn glyph.
CXTPMarkupUIElement * | m_pMarkupUIElement
Markup element.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

This class represents a container cell for a set of blocks and keys and inherits basic functionality from the CXTPGridRecordItem class.

See also
CXTPGridRecordItem

Member Function Documentation

◆ Add()

CXTPTrackBlock * Add ( CXTPTrackBlock * pBlock )

Adds a block to the track.

Parameters
pBlock Pointer to track block to be added.
Returns
A pointer to the newly added block.

◆ AdjustBlockPosition()

void AdjustBlockPosition | ( | CXTPTrackBlock * | pBlock,
 |  | BOOL | bResize = FALSE )

Adjusts the block position when a block is resized/moved.

Parameters
pBlock | Pointer to the track block that is being resized/moved.
bResize | TRUE if the block is being resized, FALSE if the block is being moved.

◆ DoPropExchange()

virtual void DoPropExchange ( CXTPPropExchange * pPX )
virtual

Call this member function to store/load a grid record item using the specified data object.

Parameters
pPX Source/destination CXTPPropExchange data object reference.

Reimplemented from CXTPGridRecordItem.

◆ Draw()

virtual int Draw ( XTP_GRIDRECORDITEM_DRAWARGS * pDrawArgs )
virtual

Should be overridden by descendants for drawing itself.

Parameters
pDrawArgs Pointer to an XTP_GRIDRECORDITEM_DRAWARGS structure containing drawing arguments.

This function simply prepares and calls the necessary drawing functions from PaintManager to draw a grid item. As such, you must provide your own implementation of PaintManager in order to change the appearance of your grid item.

Returns
Nonzero if successful, otherwise 0.

Example:

// fill structure
XTP_GRIDRECORDITEM_DRAWARGS drawArgs;
drawArgs.pDC = pDC;
drawArgs.pControl = m_pControl;
drawArgs.pRow = this;
// call function
Draw(&drawArgs);
See also
XTP_GRIDRECORDITEM_DRAWARGS

Reimplemented from CXTPGridRecordItem.

◆ GetBlock()

AFX_INLINE CXTPTrackBlock * GetBlock ( int nIndex ) const

Retrieves a specified block.

Parameters
nIndex Index of the block to retrieve.
Returns
A pointer to a CXTPTrackBlock object.

◆ GetBlockCount()

AFX_INLINE int GetBlockCount ( ) const

Calculates the number of blocks in the track control.

Returns
The number of blocks in the track control.

◆ GetCaption() [1/2]

virtual CString GetCaption ( )
virtual

Gets the text caption of the item.

Can be overridden by descendants.

Returns
The text caption of the item, or an empty string for a base record item class.

Reimplemented from CXTPGridRecordItem.

◆ GetCaption() [2/2]

CString GetCaption ( CXTPGridColumn * pColumn )
virtual

Retrieves the text caption of the current item.

Parameters
pColumn Pointer to the corresponding column of the current item.

Overwrites parents' member function.

Returns
The text caption of the current item.

Reimplemented from CXTPGridRecordItem.

◆ GetTrackControl()

CXTPTrackControl * GetTrackControl ( ) const

Retrieves the track control associated with this item.

Returns
A pointer to the track control associated with this item.

◆ HighlightWorkArea()

virtual void HighlightWorkArea | ( | CDC * | pDC,
 |  | CRect | rcItem )
 protectedvirtual

Highlights the work area.

Parameters
pDC | Pointer to the device context.
rcItem | Work area rectangle.

◆ HitTest()

CXTPTrackBlock * HitTest ( CPoint ptPoint )

Determines which block, if any, is at a specified point.

Parameters
ptPoint Point to be tested.
Returns
A pointer to the CXTPTrackBlock object at the specified point, if any, otherwise NULL.

◆ IsLocked()

AFX_INLINE BOOL IsLocked ( ) const

Gets the locked state of the track control.

Returns
TRUE if the track control is locked, otherwise FALSE.

If a track is locked, then it cannot be moved and none of its blocks or keys can be moved. When locked, blocks and keys from other tracks cannot be dragged into this track.

◆ OnClick()

virtual void OnClick ( XTP_GRIDRECORDITEM_CLICKARGS * pClickArgs )
virtual

Processes single mouse clicks.

Parameters
pClickArgs Pointer to an XTP_GRIDRECORDITEM_CLICKARGS structure containing click arguments.

Usually this function is called by GridRow's OnClick function.

See also
XTP_GRIDRECORDITEM_CLICKARGS

Reimplemented from CXTPGridRecordItem.

◆ OnDblClick()

virtual void OnDblClick ( XTP_GRIDRECORDITEM_CLICKARGS * pClickArgs )
virtual

Processes double mouse clicks.

Parameters
pClickArgs Pointer to an XTP_GRIDRECORDITEM_CLICKARGS structure containing click arguments.

Usually this function is called by GridRow's OnDblClick function.

See also
XTP_GRIDRECORDITEM_CLICKARGS

Reimplemented from CXTPGridRecordItem.

◆ OnLButtonDown()

virtual BOOL OnLButtonDown ( XTP_GRIDRECORDITEM_CLICKARGS * pClickArgs )
virtual

Processes mouse left button down clicks.

Parameters
pClickArgs Pointer to an XTP_GRIDRECORDITEM_CLICKARGS structure containing click arguments.
Returns
TRUE if the implementation handles the mouse click event and no further handling is required, otherwise FALSE.

Usually this function is called by GridRow's OnLButtonDown function.

See also
XTP_GRIDRECORDITEM_CLICKARGS

Reimplemented from CXTPGridRecordItem.

◆ OnLButtonUp()

virtual BOOL OnLButtonUp ( XTP_GRIDRECORDITEM_CLICKARGS * pClickArgs )
virtual

Processes mouse left button up clicks.

Parameters
pClickArgs Pointer to an XTP_GRIDRECORDITEM_CLICKARGS structure containing click arguments.
Returns
TRUE if the implementation handles the mouse click event and no further handling is required, otherwise FALSE.

Usually this function is called by GridRow's OnLButtonUp function.

See also
XTP_GRIDRECORDITEM_CLICKARGS

Reimplemented from CXTPGridRecordItem.

◆ OnMouseMove()

virtual void OnMouseMove | ( | UINT | nFlags,
 |  | CPoint | point,
 |  | CXTPGridControl * | pControl = NULL )
 virtual

Processes the move mouse event.

Parameters
point | Specifies the x- and y- coordinates of the cursor.
nFlags | Additional flags.
pControl | Pointer to the Grid control.

Usually this function is called by GridRow's OnMouseMove function.

Reimplemented from CXTPGridRecordItem.

◆ OnToolHitTest()

INT_PTR OnToolHitTest | ( | CPoint | point,
 |  | TOOLINFO * | pTI )
 virtual

Call this member function to perform a hit test on the track control at a specified point and fill a TOOLINFO structure with the contextual display string.

Parameters
point | Point to test.
pTI | Pointer to a TOOLINFO structure.
Returns
An INT_PTR value pointing to the track control item where the hit test was performed.

Reimplemented from CXTPGridRecordItem.

◆ Remove()

BOOL Remove ( CXTPTrackBlock * pBlock )

Removes a block.

Parameters
pBlock Pointer to the block to be removed.
Returns
TRUE if the removal is successful, otherwise FALSE.

◆ RemoveAt()

BOOL RemoveAt ( int nIndex )

Removes a block.

Parameters
nIndex Zero-based index of the block to be removed.
Returns
TRUE if the removal is successful, otherwise FALSE.

◆ SetLocked()

AFX_INLINE void SetLocked ( BOOL bLocked = TRUE )

Sets the locked state of the track control.

Parameters
bLocked TRUE to lock the track control, FALSE to unlock.

If a track is locked, then it cannot be moved and none of its blocks or keys can be moved. When locked, blocks and keys from other tracks cannot be dragged into this track.

The documentation for this class was generated from the following file:
  • XTPTrackControlItem.h


Toolkit Pro: CXTPTrackHeader Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPTrackHeader Class Reference

This class represents a track control header. More...

Inheritance diagram for CXTPTrackHeader:
[legend]

Public Member Functions

CXTPTrackHeader (CXTPGridControl *pControl, CXTPGridColumns *pColumns)
Creates a CXTPTrackHeader object.
~CXTPTrackHeader ()
CXTPTrackHeader default destructor.
void | Draw (CDC *pDC, CRect rcHeader, int nLeftOffset)
Call this function to draw the block.
void | OnLButtonDown (CPoint ptClick)
This function is called when the left mouse button is clicked on the header.
void | OnMouseMove (UINT nFlags, CPoint point)
This function is called when the mouse is moved over the header.
void | StartDragScrollBar (BOOL bResize)
This function is called when the scrollbar is about to be resized/dragged.
void | StartDragSlider (BOOL bResize)
This function is called when the slider is about to be resized/dragged.
void | StartDragMarker (int nMarkerIndex)
This function is called when the marker is about to be dragged.
- Public Member Functions inherited from CXTPGridHeader
CXTPGridHeader (CXTPGridControl *pControl, CXTPGridColumns *pColumns)
Constructs a CXTPGridHeader object.
virtual | ~CXTPGridHeader ()
Destroys CXTPGridHeader object, handles cleanup and deallocation.
BOOL | IsDragHeader () const
Determines if the header is being dragged.
void | AllowColumnRemove (BOOL bAllow)
Specifies if column removing is allowed.
BOOL | IsAllowColumnRemove () const
Determines if column removing is allowed.
void | AllowColumnReorder (BOOL bAllow)
Specifies if column reordering is allowed.
BOOL | IsAllowColumnReorder () const
Determines if column reordering is allowed.
void | AllowColumnResize (BOOL bAllow)
Specifies if column resizing is allowed.
BOOL | IsAllowColumnResize () const
Determines if column resizing is allowed.
void | ShowItemsInGroups (BOOL bShowInGroups)
Enables/disables show items in groups mode.
BOOL | IsShowItemsInGroups () const
Determines if show items in groups mode is enabled/disabled.
void | AllowColumnSort (BOOL bAllow)
Specifies if column sorting mode is allowed.
BOOL | IsAllowColumnSort () const
Determines if column sorting mode is allowed.
virtual CXTPGridColumn * | GetNextVisibleColumn (int nIndex, int nDirection)
Gets the next visible column in the array of columns.
virtual CXTPGridColumn * | HitTest (CPoint ptPoint) const
Determines which column, if any, is at a specified point.
virtual int | FindHeaderColumn (CPoint ptPoint) const
Calculates the header index of where to insert a column nearest to a specified point.
virtual int | FindGroupByColumn (CPoint ptPoint, BOOL bExactSearch=FALSE) const
Calculates index of where to insert a column nearest to the provided point.
virtual int | HitTestHeaderColumnIndex (CPoint ptPoint) const
private:
CXTPGridColumn * | MouseOverColumnResizeArea (CPoint ptPoint)
Determines if a specified point is over the column resize area.
int | GetFullColScrollInfo (CXTPGridColumn *&rpPrev, CXTPGridColumn *&rpCurr, CXTPGridColumn *&rpNext, int &rnScrollPos, int &rnScrollMax) const
Gets the current scroll information for full columns scroll mode and the helper information to scroll left or right.
void | AdjustColumnsWidth (int nTotalWidth, int nFirstIndex=0)
Adjusts the width of columns.
CXTPGridColumn * | GetDraggingColumn () const
Gets the dragging column if the control is in dragging mode.
CXTPGridColumn * | GetResizingColumn () const
Gets the resizing column if the control is in resizing mode.
BOOL | SetSubListCtrl (CXTPGridSubListControl *pSubList)
Sets the associated field chooser list control.
CXTPGridSubListControl * | GetSubListCtrl () const
Gets the associated field chooser list control.
BOOL | SetFilterEditCtrl (CXTPGridFilterEditControl *pFilterEdit)
Sets the associated filter edit control.
CXTPGridFilterEditControl * | GetFilterEditCtrl () const
Gets the associated filter edit control.
int | GetGroupByHeight () const
Gets the height of the Group By area, in pixels.
void | BestFit (CXTPGridColumn *pColumn)
Adjusts the width of a specified column to the width of the widest column item.
BOOL | IsLastVisibleColumn (CXTPGridColumn *pColumn) const
Determines if a specified column is the last visible column in the grid header.
BOOL | IsLastResizebleColumn (CXTPGridColumn *pColumn) const
Determines if a specified column in the last resizable column in the grid header.
int | GetIndentLevel () const
Gets the indent, in pixels, for a single level of tree depth for the Grid control in tree mode.
virtual void | OnColumnsChanged (int nReason, CXTPGridColumn *pColumn)
Updates header settings after any changes occur.
CXTPGridControl * | GetControl () const
Gets the parent Grid control.
void | SetAutoColumnSizing (BOOL bAutoColumnSizing)
Specifies if AutoColumnSizing should be used.
BOOL | IsAutoColumnSizing () const
Determines if AutoColumnSizing is used.
BOOL | ForceLayoutAdjustment () const
Call this member to determine m_bForceLayoutAdjustment flag.
int | GetWidth () const
Gets the total width of the header (i.e.
void | SetLastColumnExpand (BOOL bLastColumnExpand, BOOL bLastColumnExpandKeep)
Sets the expanded state of the last column.
int | GetMaxColumnWidth () const
Gets the maximum column width for all columns.
void | SetMaxColumnWidth (int nMaxColumnWidth)
Sets the maximum column width for all columns.
HCURSOR | GetResizeCursor () const
Gets the handler of the user's horizontal resizing cursor.
HCURSOR | GetResizeVCursor () const
Gets the handler of the user's vertical resizing cursor.
HCURSOR | GetDontDropCursor () const
Gets the handler of the user's Don't Drop cursor.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

void | OnMoveSlider (CPoint pt, BOOL bResize)
Call this function to resize/move the slider.
void | OnMoveMarker (CPoint pt, int nMarkerIndex)
Call this function to move the marker.
void | OnMoveScrollBar (CPoint pt, BOOL bResize)
Call this function to resize/move the scrollbar.
- Protected Member Functions inherited from CXTPGridHeader
virtual void | DrawGroupByControl (CDC *pDC, CRect &rcGroupBy)
Draws Group By area on a provided device context.
virtual void | DrawFooter (CDC *pDC, CRect &rcFooter, int nLeftOffset)
Draws columns footer on a provided device context.
virtual void | OnLButtonDblClk (CPoint ptDblClick)
Processes mouse left button double clicks.
virtual void | OnLButtonUp (UINT nFlags, CPoint ptClick)
Processes mouse left button up clicks.
virtual void | OnContextMenu (CPoint ptClick)
Processes context menu.
CXTPGridPaintManager * | GetPaintManager () const
Gets the paint manager object used to draw the Grid control window.
virtual void | DoPropExchange (CXTPPropExchange *pPX)
Reads/writes configuration to/from the provided archive stream.
void | StartDragging (CXTPGridColumn *pColumn, BOOL bHeader=FALSE)
Starts column header dragging mode.
void | ResizeColumn (CXTPGridColumn *pColumn, int nWidth)
Resizes a specified column to a specified width and adjusts the width of other columns in correspondence with the specified column.
void | CancelMouseMode ()
Resets the mouse mode to xtpMouseNothing and performs all necessary cleanup operations.
int | GetMaxAvailWidth (CXTPGridColumn *pColumn)
Gets the maximum available width of a specified column, in pixels.
int | SetHotDivider (int nIndex, BOOL bHeader=TRUE)
Sets a hot divider between columns.
virtual INT_PTR | OnToolHitTest (CPoint point, TOOLINFO *pTI) const
The framework calls this member function to determine whether a point is in the bounding rectangle of the specified tool.

Protected Attributes

CPoint | m_ptStartDrag
The drag start point.
int | m_nOldWorkAreaMin
The old work area minimum value.
int | m_nOldWorkAreaMax
The old work area maximum value.
int | m_nOldViewPortMin
The old view port minimum value.
int | m_nOldViewPortMax
The old view port maximum value.
int | m_nOldMarkerPos
The old marker position.
- Protected Attributes inherited from CXTPGridHeader
CXTPGridColumns * | m_pColumns
Pointer to the associated columns list.
CXTPGridControl * | m_pControl
Pointer to the parent Grid control.
int | m_nDropIndex
Item index of the column to drop to.
int | m_nVisIndex
Item visual index of the column to drag from.
CXTPGridHeaderDragWnd * | m_pDragWnd
Column drag window.
CXTPGridColumn * | m_pDragColumn
Dragging column.
CXTPGridColumn * | m_pResizeColumn
Resizing column.
CXTPGridColumn * | m_pHotTrackingColumn
Hot column.
BOOL | m_bDragHeader
Determines whether control is in header dragging mode or group by dragging mode.
BOOL | m_bDragGroupBox
Determines whether control is in group box dragging mode.
CXTPGridSubListControl * | m_pSubList
Field chooser list control.
CXTPGridFilterEditControl * | m_pFilterEdit
Filter edit control.
CRect | m_rcGroupBy
Group By area coordinates.
CRect | m_rcHeader
Header coordinates.
CPoint | m_ptMouse
Stores mouse coordinates for processing when required (resizing, etc.).
HCURSOR | m_hResizeCursor
Handler of the user's horizontal resizing cursor.
HCURSOR | m_hResizeVCursor
Handler of the user's vertical resizing cursor.
HCURSOR | m_hDontDropCursor
Handler of the user's Don't Drop cursor.
BOOL | m_bAllowColumnRemove
FALSE if columns removing is not allowed.
BOOL | m_bAllowColumnResize
FALSE if columns resizing is not allowed.
BOOL | m_bAllowColumnReorder
FALSE if columns reordering is not allowed.
BOOL | m_bAllowColumnSort
FALSE if columns sorting is not allowed.
BOOL | m_bAutoColumnSizing
TRUE if AutoColumnSizing should be used.
int | m_nResizeCaptureRange
Distance around column divider where column re-sizer is shown.
int | m_nIndentLevel
Width indent at the left of the column.
BOOL | m_bShowItemsInGroups
TRUE when showing items in groups, FALSE when grouping is not used.
int | m_nHeaderWidth
The combined width of all the visible column headers.
int | m_nForceLayoutAdjustment
Internal flag to Force Layout Adjustment (and also show scrollbar) if positive.
BOOL | m_bLastColumnExpand
Tells whether the last column is expanded or not.
BOOL | m_bLastColumnExpandKeep
Not used currently.
int | m_nMaxColumnWidth
Custom maximum column width.
enum CXTPGridHeader::GridDraggingMode | m_dragMode
Column dragging mode.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPGridHeader
BOOL | m_bHideColumnAfterGroupBoxDrop
Tell whether to hide the column after group box drop.
- Static Public Attributes inherited from CXTPGridHeader
static int | s_nMinAutoScrollStep
Minimal horizontal auto-scrolling step, in pixels.
static BOOL | s_bShowItemsInGroupsPXDefault
Store default value of m_bShowItemsInGroups member for serialization (PropExchange).
static BOOL | s_bSendContextMenuForWholeHeaderArea
If TRUE, then the Grid control sends ContextMenu event for clicks on whole header area (not only for columns) rectangles.
- Protected Types inherited from CXTPGridHeader
enum GridDraggingMode {
dragNothing = 0 , dragOutTarget = 1 , dragInHeader = 2 , dragInGroupBox = 4 ,
dragInTarget = 6 , dragFieldChooser = 8
}
Specifies grid dragging mode. More...

Detailed Description

This class represents a track control header.

Constructor & Destructor Documentation

◆ CXTPTrackHeader()

CXTPTrackHeader | ( | CXTPGridControl * | pControl,
 |  | CXTPGridColumns * | pColumns )

Creates a CXTPTrackHeader object.

Parameters
pControl | Pointer to the Grid control.
pColumns | Pointer to the grid columns.

Member Function Documentation

◆ Draw()

void Draw | ( | CDC * | pDC,
 |  | CRect | rcHeader,
 |  | int | nLeftOffset )
 virtual

Call this function to draw the block.

Parameters
pDC | Pointer to the device context.
rcHeader | Header rectangle.
nLeftOffset | Left offset.

Reimplemented from CXTPGridHeader.

◆ OnLButtonDown()

void OnLButtonDown ( CPoint ptClick )
virtual

This function is called when the left mouse button is clicked on the header.

Parameters
ptClick Point where the mouse event occurred.

Reimplemented from CXTPGridHeader.

◆ OnMouseMove()

void OnMouseMove | ( | UINT | nFlags,
 |  | CPoint | point )
 virtual

This function is called when the mouse is moved over the header.

Parameters
nFlags | State of mouse buttons, while the mouse is moved.
point | Point where the mouse event occurred.

Reimplemented from CXTPGridHeader.

◆ OnMoveMarker()

void OnMoveMarker | ( | CPoint | pt,
 |  | int | nMarkerIndex )
 protected

Call this function to move the marker.

Parameters
pt | New position for the marker.
nMarkerIndex | Zero-based index of the marker which is moving.

◆ OnMoveScrollBar()

void OnMoveScrollBar | ( | CPoint | pt,
 |  | BOOL | bResize )
 protected

Call this function to resize/move the scrollbar.

Parameters
pt | New position for the scrollbar.
bResize | TRUE if the scrollbar is resizing, FALSE if the scrollbar is moving.

◆ OnMoveSlider()

void OnMoveSlider | ( | CPoint | pt,
 |  | BOOL | bResize )
 protected

Call this function to resize/move the slider.

Parameters
pt | New position for the slider.
bResize | TRUE if the slider is resizing, FALSE if the slider is moving.

◆ StartDragMarker()

void StartDragMarker ( int nMarkerIndex )

This function is called when the marker is about to be dragged.

Parameters
nMarkerIndex Zero-based index of the marker which is about to be dragged.

◆ StartDragScrollBar()

void StartDragScrollBar ( BOOL bResize )

This function is called when the scrollbar is about to be resized/dragged.

Parameters
bResize TRUE if the scrollbar is about to be resized, FALSE if the scrollbar is about to be dragged.

◆ StartDragSlider()

void StartDragSlider ( BOOL bResize )

This function is called when the slider is about to be resized/dragged.

Parameters
bResize TRUE if the slider is about to be resized, FALSE if the slider is about to be dragged.
The documentation for this class was generated from the following file:
  • XTPTrackHeader.h


Toolkit Pro: CXTPTrackKey Class Reference

Public Member Functions | List of all members
CXTPTrackKey Class Reference

This class represents a track control key. More...

Inheritance diagram for CXTPTrackKey:
[legend]

Public Member Functions

CXTPTrackKey ()
Constructs a CXTPTrackKey object.
virtual int | Draw (CDC *pDC, CRect rc, BOOL bSelected)
Draws the key.
virtual BOOL | IsKey () const
Determines if the item is a key.
- Public Member Functions inherited from CXTPTrackBlock
CXTPTrackBlock ()
Constructs a CXTPTrackBlock object.
virtual BOOL | IsResizable () const
Determines if the block is resizable.
void | SetPosition (int nPosition)
Sets the position for the block on the track.
int | GetPosition () const
Gets the position of the block on the track.
void | SetLength (int nLength)
Sets the length for the block on the track.
int | GetLength () const
Gets the length of the block on the track.
void | SetColor (COLORREF clr)
Sets the color for the block.
CRect | GetRect () const
Gets the bounding rectangle of the block.
BOOL | IsLocked () const
Gets the locked state of the block (i.e.
void | SetLocked (BOOL bLocked=TRUE)
Sets the locked state for the block (i.e.
void | SetHeightPercent (double dHeightPercent)
Sets the height percentage for the block compared to its track.
double | GetHeightPercent () const
Gets the height percentage of the block compared to its track.
void | SetVerticalAlignment (int nAlignment)
Sets the vertical alignment for the block in its track.
int | GetVerticalAlignment () const
Gets the vertical alignment of the block in its track.
CXTPTrackControlItem * | GetItem () const
Gets the track control to which the block is associated with.
int | GetIndex () const
Gets the index of the block in its track.
void | Select (BOOL bSelect=TRUE)
Sets the selected state for the block.
BOOL | IsSelected () const
Gets the selected state of the block.
CString | GetCaption () const
Gets the caption of the block.
void | SetCaption (LPCTSTR lpszCaption)
Sets the caption for the block.
virtual CString | GetTooltip () const
Gets the tooltip text of the block.
void | SetTooltip (LPCTSTR lpszTooltip)
Sets the tooltip text for the block.
void | SetDescriptionText (LPCTSTR lpszDescriptionText)
Sets the description text for the block.
CString | GetDescriptionText () const
Gets the description text of the block.
void | SetMinLength (int nMinLength)
Sets the minimum length for the block.
int | GetMinLength () const
Gets the minimum length of the block.
void | SetMaxLength (int nMaxLength)
Sets the maximum length for the block.
int | GetMaxLength () const
Gets the maximum length of the block.
void | DoPropExchange (CXTPPropExchange *pPX)
Call this member function to store/load the properties related to the block.
void | Remove ()
Removes the block.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPTrackBlock
CRect | m_rcBlock
Drawing bounding rectangle of block.
CXTPTrackControlItem * | m_pItem
Pointer to the parent track of the block.
int | m_nPosition
Position that resolve overlaps with items on same track.
int | m_nLength
Length of the block.
BOOL | m_bLocked
TRUE if the block is not movable/resizable.
COLORREF | m_clrBlock
Color of the block.
CString | m_strCaption
Caption text.
double | m_dHeightPercent
Height percentage of the block compared to its track.
int | m_nVerticalAlignment
Vertical alignment of blocks with m_dHeightPercent < 1.
- Protected Attributes inherited from CXTPTrackBlock
int | m_nMRUPosition
Last position that was set by the user.
CString | m_strToolTip
Tooltip text.
CString | m_strDescription
Description text.
int | m_nIndex
Index of the block in its parent track.
int | m_nLastDragTime
Last drag moment of user (used as priority for flexible draging).
int | m_nMinLength
Minimum resize length.
int | m_nMaxLength
Maximum resize length.
BOOL | m_bDragging
Block is currently dragging.

Detailed Description

This class represents a track control key.

Keys are used simply as "notes" or reference points in the track. They can be added anywhere in the track to make note of some event at a given moment in time.

Member Function Documentation

◆ Draw()

virtual int Draw | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | BOOL | bSelected )
 virtual

Draws the key.

Parameters
pDC | Pointer to the device context.
rc | Bounds of the drawing area.
bSelected | TRUE if the block is selected, FALSE otherwise.
Returns
A value of 1 if the drawing was successful, otherwise a value of 0.

This is a virtual function so derived classes can provide their specific implementations.

Reimplemented from CXTPTrackBlock.

◆ IsKey()

AFX_INLINE BOOL IsKey ( ) const
virtual

Determines if the item is a key.

Returns
TRUE if the item is a key, otherwise FALSE.

This is a virtual function so derived classes can provide their specific implementations.

Reimplemented from CXTPTrackBlock.

The documentation for this class was generated from the following file:
  • XTPTrackBlock.h


Toolkit Pro: CXTPTrackMarker Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPTrackMarker Class Reference

This class represents a track control marker. More...

Inheritance diagram for CXTPTrackMarker:
[legend]

Public Member Functions

CXTPTrackMarker ()
Constructs a CXTPTrackMarker object.
void | SetPosition (int nPosition)
Sets the position of the marker.
int | GetPosition () const
Gets the position of the marker.
void | SetCaption (LPCTSTR lpszCaption)
Sets the caption for the marker.
CString | GetCaption () const
Gets the caption of the marker.
CRect | GetRect () const
Gets the bounding rectangle of the marker.
void | Remove ()
Removes the marker.
CXTPTrackControl * | GetControl () const
Gets the track control to which the marker is associated with.
void | DoPropExchange (CXTPPropExchange *pPX)
Call this member function to store/load the properties related to the marker.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Attributes

CString | m_strCaption
Caption of the marker.
int | m_nPosition
Position of the marker.
CRect | m_rcMarker
Drawing position of the marker.
CXTPTrackControl * | m_pControl
Parent control.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

This class represents a track control marker.

Markers are used for block alignment, blocks can be "snapped" to the left or right of these markers.

Member Function Documentation

◆ DoPropExchange()

void DoPropExchange ( CXTPPropExchange * pPX )

Call this member function to store/load the properties related to the marker.

Parameters
pPX Source/destination CXTPPropExchange data object reference.

This member function is used to store/load property data to/from storage.

◆ GetCaption()

AFX_INLINE CString GetCaption ( ) const

Gets the caption of the marker.

Returns
The caption of the marker.

◆ GetControl()

AFX_INLINE CXTPTrackControl * GetControl ( ) const

Gets the track control to which the marker is associated with.

Returns
A pointer to the CXTPTrackControl object to which the marker is associated with.

◆ GetPosition()

AFX_INLINE int GetPosition ( ) const

Gets the position of the marker.

Returns
The position of the marker on the time line.

◆ GetRect()

AFX_INLINE CRect GetRect ( ) const

Gets the bounding rectangle of the marker.

Returns
A CRect object containing the bounding rectangle of the marker.

◆ SetCaption()

AFX_INLINE void SetCaption ( LPCTSTR lpszCaption )

Sets the caption for the marker.

Parameters
lpszCaption New caption for the marker.

◆ SetPosition()

void SetPosition ( int nPosition )

Sets the position of the marker.

Parameters
nPosition Position of the marker on the time line.
The documentation for this class was generated from the following file:
  • XTPTrackBlock.h


Toolkit Pro: CXTPTrackMarkers Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPTrackMarkers Class Reference

This class abstracts the track control markers. More...

Inheritance diagram for CXTPTrackMarkers:
[legend]

Public Member Functions

CXTPTrackMarker * | Add (int nPosition, LPCTSTR lpszCaption)
Creates and adds a marker to the marker collection.
CXTPTrackMarker * | Add (CXTPTrackMarker *pMarker)
Adds a marker to the marker collection.
CXTPTrackMarker * | GetAt (int nIndex) const
Retrieves the marker at a specified index in the marker collection.
void | RemoveAt (int nIndex)
Removes the marker at a specified index from the marker collection.
void | Remove (CXTPTrackMarker *pMarker)
Removes a specified marker from the marker collection.
void | RemoveAll ()
Removes all markers from the marker collection.
int | IndexOf (CXTPTrackMarker *pMarker)
Retrieves the index of a marker in the marker collection.
int | GetCount () const
Gets the number of markers in the marker collection.
int | HitTest (CPoint pt) const
Call this member function to determine the index of the marker, if any, at a specified point.
void | DoPropExchange (CXTPPropExchange *pPX)
Call this member function to store/load the properties related to the marker collection.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

CXTPTrackMarkers (CXTPTrackControl *pControl)
Constructs a CXTPTrackMarkers object.
~CXTPTrackMarkers ()
Destroys the CXTPTrackMarkers object, handles cleanup and deallocation.

Protected Attributes

CXTPTrackControl * | m_pControl
Parent control.
CArray< CXTPTrackMarker *, CXTPTrackMarker * > | m_arrMarkers
Array of markers.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

This class abstracts the track control markers.

Markers are used for block alignment, blocks can be "snapped" to the left or right of these markers.

Constructor & Destructor Documentation

◆ CXTPTrackMarkers()

CXTPTrackMarkers ( CXTPTrackControl * pControl )
protected

Constructs a CXTPTrackMarkers object.

Parameters
pControl Pointer to parent Track Control object

Member Function Documentation

◆ Add() [1/2]

CXTPTrackMarker * Add ( CXTPTrackMarker * pMarker )

Adds a marker to the marker collection.

Parameters
pMarker Pointer to the marker to add.
Returns
A pointer to the added CXTPTrackMarker object.

◆ Add() [2/2]

CXTPTrackMarker * Add | ( | int | nPosition,
 |  | LPCTSTR | lpszCaption )

Creates and adds a marker to the marker collection.

Parameters
nPosition | Position of the marker.
lpszCaption | Caption of the marker.
Returns
A pointer to the newly created CXTPTrackMarker object.

◆ DoPropExchange()

void DoPropExchange ( CXTPPropExchange * pPX )

Call this member function to store/load the properties related to the marker collection.

Parameters
pPX Source/destination CXTPPropExchange data object reference.

This member function is used to store/load property data to/from storage.

◆ GetAt()

CXTPTrackMarker * GetAt ( int nIndex ) const

Retrieves the marker at a specified index in the marker collection.

Parameters
nIndex Zero-based index of the marker to retrieve.
Returns
A pointer to the CXTPTrackMarker at the specified index if successful, NULL if the specified index is not valid in the current context.

◆ GetCount()

int GetCount ( ) const

Gets the number of markers in the marker collection.

Returns
The number of markers in the marker collection.

◆ HitTest()

int HitTest ( CPoint pt ) const

Call this member function to determine the index of the marker, if any, at a specified point.

Parameters
pt Point to test.
Returns
The zero-based index of the marker at the specified point, if any, otherwise a value of -1.

◆ IndexOf()

int IndexOf ( CXTPTrackMarker * pMarker )

Retrieves the index of a marker in the marker collection.

Parameters
pMarker Pointer to the marker whose index must be retrieved.
Returns
The zero-based index of the marker in the marker collection.

◆ Remove()

void Remove ( CXTPTrackMarker * pMarker )

Removes a specified marker from the marker collection.

Parameters
pMarker Pointer to the marker to be removed.

◆ RemoveAt()

void RemoveAt ( int nIndex )

Removes the marker at a specified index from the marker collection.

Parameters
nIndex Zero-based index of the marker to remove.
The documentation for this class was generated from the following file:
  • XTPTrackBlock.h


Toolkit Pro: CXTPTrackPaintManager Class Reference

Public Member Functions | Public Attributes | List of all members
CXTPTrackPaintManager Class Reference

This class represents a track control paint manager. More...

Inheritance diagram for CXTPTrackPaintManager:
[legend]

Public Member Functions

CXTPTrackPaintManager ()
Creates a CXTPTrackPaintManager object.
~CXTPTrackPaintManager ()
CXTPTrackPaintManager destructor, handles cleanup and deallocation.
void | RefreshMetrics ()
Initializes all drawings defaults (fonts, colors, etc.).
virtual void | DrawTrackHeader (CDC *pDC)
Call this function to draw the track header.
virtual void | DrawMarkers (CDC *pDC)
Call this function to draw the markers.
virtual void | DrawTimeLine (CDC *pDC)
Call this function to draw the time line.
virtual CString | FormatTimeLineTick (int nPosition, COLORREF &clrTick, int &nTickLength)
Call this function to format the time and tick marker relative to a time line position.
virtual CString | FormatTime (int nPosition)
Call this function to format the time and tick marker relative to a time line position.
- Public Member Functions inherited from CXTPGridPaintManager
CXTPGridPaintManager ()
Default CXTPGridPaintManager constructor, handles properties initialization.
virtual | ~CXTPGridPaintManager ()
Default CXTPGridPaintManager destructor, handles member items deallocation.
virtual void | SetGridControl (CXTPGridControl *pControl)
Sets the associated Grid control for the paint manager.
virtual void | LoadGlyphs ()
Loads the default images used by the Grid control.
virtual int | GetRowHeight (CDC *pDC, CXTPGridRow *pRow)
Retrieves the default row height for print mode (i.e.
virtual int | GetRowHeight (CDC *pDC, CXTPGridRow *pRow, int nTotalWidth)
Retrieves the default row height for print mode (i.e.
int | GetRowHeightEx (CDC *pDC, CXTPGridRow *pRow, int nTotalWidth, const BOOL firstLevel=TRUE)
Retrieves the default row height for print mode (i.e.
int | GetItemHeight (XTP_GRIDRECORDITEM_DRAWARGS &drawArgs, int nWidth)
Retrieves the height of a record item for a given width.
BOOL | FindRowAdjacentToMergedEx (const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, int &nAdjRowIndex, BOOL bUpward)
Searches the topmost or bottommost row depending on the height of the current row.
int | FindRowAdjacentToMerged (const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, BOOL bUpward)
Wrapper for the FindRowAdjacentToMergedEx method.
int | RecalcTotalHightOfMergedRows (CXTPGridColumns *pColumns, CDC *pDC, CXTPGridRow *pRow, int nRowHeight, int nTotalWidth)
Recalculates row height according to the height of merged items.
virtual int | GetPreviewItemHeight (CDC *pDC, CXTPGridRow *pRow, int nWidth, int nHeight)
Retrieves the height of a preview item for print mode.
virtual int | GetHeaderHeight ()
Gets the column header height.
virtual int | GetHeaderHeight (CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0)
Calculates the optimal header height.
virtual void | SetHeaderHeight (int nHeight)
Sets the column header height.
virtual int | GetFooterHeight (CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0)
Calculates the optimal footer height.
virtual COLORREF | GetControlBackColor (CXTPGridControl *pControl)
Retrieves the parent Grid control's background color.
virtual void | FillRow (CDC *pDC, CXTPGridRow *pRow, CRect rcRow)
Fills a specified row with its background color.
virtual void | DrawGrid (CDC *pDC, XTPGridOrientation orientation, CRect rcGrid)
Draws a grid for the control.
virtual void | DrawFreezeColsDivider (CDC *pDC, const CRect &rc, CXTPGridControl *pControl, CXTPGridRow *pRow=NULL)
Draws a freeze column divider.
virtual void | DrawVerticalTimeLineMarker (CDC *pDC, int xPos, CXTPGridControl *pControl, COLORREF color=RGB(0, 255, 0))
Draws a vertical timeline marker.
virtual void | DrawGroupRow (CDC *pDC, CXTPGridGroupRow *pRow, CRect rcRow, XTP_GRIDRECORDITEM_METRICS *pMetrics)
Draws a group row.
virtual void | FillGroupRowMetrics (CXTPGridGroupRow *pRow, XTP_GRIDRECORDITEM_METRICS *pMetrics, BOOL bPrinting)
Fills the font and color members of the metrics structure for a specified group row.
virtual void | FillIndent (CDC *pDC, CRect rcRow)
Fills an indent area by its background.
virtual void | FillItemShade (CDC *pDC, CRect rcItem)
Fills an item shade by its background if necessary.
virtual void | FillHeaderControl (CDC *pDC, CRect rcHeader)
Fills a column header control area by its background.
virtual void | FillFooter (CDC *pDC, CRect rcFooter)
Fills a column footer control area by its background.
virtual void | DrawColumnText (CDC *pDC, CRect rcText, CString strCaption, int nHeaderAlignment, BOOL bIsHeader, BOOL bColumnPressed)
Draws text for the column header.
virtual void | DrawColumn (CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn, BOOL bDrawExternal=FALSE, int nShadowWidth=0)
Draws a column header with all related attributes (sort order, icon, etc.).
virtual void | DrawColumnFooterDivider (CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn)
Draws the column footer divider.
virtual void | DrawColumnFooter (CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn)
Draws the column footer with all related attributes (e.g.
virtual BOOL | IsColumHotTrackingEnabled () const
Determines if hot tracking is enabled for the current column style.
virtual void | DrawFocusedRow (CDC *pDC, CRect rcRow)
Draws focused rows.
virtual void | FillGroupByControl (CDC *pDC, CRect &rcGroupBy)
Draws the Group By box.
CXTPImageManager * | GetGlyphs () const
Gets a pointer to the additional image list with glyphs.
void | DrawHorizontalLine (CDC *pDC, int xPos, int yPos, int cx, COLORREF clr)
Draws a horizontal line.
void | DrawVerticalLine (CDC *pDC, int xPos, int yPos, int cy, COLORREF clr)
Draws a vertical line.
virtual void | DrawTriangle (CDC *pDC, CRect rcTriangle, BOOL bToDown, BOOL bDraggingFromHeader, int nShadowWidth, BOOL bColumnPressed)
Draws a triangle that shows the sort order of the column.
void | DrawConnector (CDC *pDC, CPoint ptFrom, CPoint ptTo)
Draws a column connector for the Group By box.
virtual CSize | DrawCollapsedBitmap (CDC *pDC, const CXTPGridRow *pRow, CRect &rcBitmap)
Draws a collapsed bitmap.
virtual int | DrawBitmap (CDC *pDC, CXTPGridControl *pControl, CRect rcColumn, int iImage)
Draws a bitmap.
virtual int | DrawColumnIcon (CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, CRect rcIcon, int iIcon)
Draws an icon for a column.
virtual CSize | DrawGlyph (CDC *pDC, CRect rcColumn, int iImage)
Draws the standard glyphs of the Grid control.
virtual CSize | DrawShellIcon (CDC *pDC, CRect rcColumn, int iImage)
Draws the shell icon.
void | EnablePreviewMode (BOOL bIsPreviewMode)
Enables/disables preview mode for the control.
BOOL | IsPreviewMode () const
Determines if preview mode is enabled/disabled for the control.
CFont * | GetTextFont ()
Gets the default text font used for control items.
int | SetMaxPreviewLines (int nMaxLines)
Sets the maximum number of lines of text for a preview item.
int | GetMaxPreviewLines ()
Gets the maximum number of lines of text for a preview item.
int | GetPreviewLinesCount (CDC *pDC, CRect &rcText, const CString &strText)
Calculates the number of lines required to draw a specified preview text string, taking into account the maximum number of lines of text for a preview item.
BOOL | IsGridVisible (BOOL bVertical) const
Determines the visibility of specified grid lines.
BOOL | IsGridVisible (XTPGridOrientation orientation) const
Determines the visibility of specified grid lines.
void | SetColumnStyle (XTPGridColumnStyle columnStyle)
Sets the header style.
XTPGridColumnStyle | GetColumnStyle () const
Gets the header style.
void | SetColumnOffice2007CustomThemeBaseColor (COLORREF clrBaseColor)
Sets the header's custom theme base color for Office2007 column style.
COLORREF | GetColumnOffice2007CustomThemeBaseColor () const
Gets the header's custom theme base color for Office2007 column style.
void | SetTextFont (LOGFONT &lf)
Creates and sets the default text font.
void | SetCaptionFont (LOGFONT &lf)
Creates and sets the default caption font.
void | SetPreviewIndent (int nLeft, int nTop, int nRight, int nBottom)
Sets the preview item indent.
virtual void | DrawInplaceButton (CDC *pDC, CXTPGridInplaceButton *pButton)
Draws the in-place button of the Grid control.
virtual BOOL | DrawInplaceComboButton (CDC *pDC, CRect *pRc)
Draws the combo button of the Grid control.
virtual BOOL | DrawInplaceExpandButton (CDC *pDC, CRect *pRc)
Draws the expand button of the Grid control.
virtual BOOL | DrawInplaceSpinButton (CDC *pDC, CRect *pRc)
Draws the spin button of the Grid control.
virtual void | DrawTreeStructure (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CRect rcItem, CSize sizeGlyph)
Draws tree elements of the Grid control.
virtual void | DrawItemBitmap (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CRect &rcItem, int nImage)
Draws an item bitmap.
virtual void | DrawItemCaption (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics)
Draws an item caption.
virtual void | DrawRowNumber (CDC *pDC, CRect rcNumber, CXTPGridRow *pRow)
Draws a row number.
virtual void | DrawItemControl (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CXTPGridRecordItemControl *pControl, CRect &rcItem)
Draws an item control.
BOOL | IsFixedRowHeight () const
Determines if the paint manager supports fixed or variable row height.
void | SetFixedRowHeight (BOOL bFixedRowHeight)
Sets if the paint manager supports fixed or variable row height.
BOOL | IsColumnWidthWYSIWYG () const
Determines if the paint manager supports column width WYSIWYG mode.
BOOL | IsLastColumnWidthWYSIWYG () const
Determines if the paint manager supports last column width WYSIWYG mode.
BOOL | IsShowWYSIWYGMarkers () const
Determines if the paint manager shows WYSIWYG page-end markers.
void | ShowWYSIWYGMarkers (BOOL bSet)
Sets if the paint manager shows WYSIWYG page-end markers.
void | SetColumnWidthWYSIWYG (BOOL bColumnWidthWYSIWYG)
Sets if the paint manager supports column width WYSIWYG mode.
void | SetLastColumnWidthWYSIWYG (BOOL bColumnWidthWYSIWYG)
Sets if the paint manager supports last column width WYSIWYG mode.
BOOL | IsFixedInplaceButtonHeight () const
Determines if the paint manager supports fixed or variable in-place button height.
void | SetInplaceButtonHeight (BOOL bFixedInplaceButtonHeight)
Sets if the paint manager supports fixed or variable in-place button height.
int | GetFreezeColsDividerStyle () const
Gets the style of the freeze columns divider line.
void | SetFreezeColsDividerStyle (int nStyle)
Sets the style for the freeze columns divider line.
virtual BOOL | OnDrawAction (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs)
Override this method to perform custom activities for the item before processing it.
virtual void | DrawNoGroupByText (CDC *pDC, CRect rcItem)
Draws the "No items" text message in the Group By area when there are no items inside it.
BOOL | IsDrawGridForEmptySpace () const
Determines if the grid fills empty space after body rows.
void | SetDrawGridForEmptySpace (BOOL bDrawGrid)
Sets if the grid fills empty space after body rows.
BOOL | IsPrintGroupRowIcon () const
Determines if the group row collapse-expand icon is drawn in print mode.
void | SetPrintGroupRowIcon (BOOL bDraw)
Sets if the group row collapse-expand icon is drawn in print mode.
BOOL | IsColumnPlusMinusSign () const
Determines if columns use expand/collapse icons (+/-) or directional arrows.
void | SetColumnPlusMinusSign (BOOL bDraw)
Specifies if columns use expand/collapse icons (+/-) or directional arrows.
virtual int | CalculateRowHeight (CDC *pDC, const CString &strText, int nMaxWidth, BOOL bWordBreak=TRUE)
Calculates the height required for a rectangle bounding multi-line text to draw the multi-line text when the width of the rectangle is fixed.
void | DrawSectionDivider (CDC *pDC, const CRect &rc, XTPGridSectionDividerPosition dividerPosition, XTPGridSectionDividerStyle dividerStyle, CXTPPaintManagerColor dividerColor)
Draws the divider between grid sections (e.g.
int | GetSectionDividerHeight (XTPGridFixedRowsDividerStyle dividerStyle)
Gets the height of the section divider.
BOOL | IsUseDropMarker () const
Determines if a drop marker will be used when dragging and dropping.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Public Attributes

COLORREF | m_clrWorkArea
The color of the work area.
COLORREF | m_clrTrackHeader
The track header color.
COLORREF | m_clrTrackTimeArea
The track time area color.
COLORREF | m_clrTimeHeaderDarkDark
The header deep dark color.
COLORREF | m_clrTimeHeaderDark
The header dark color.
COLORREF | m_clrTimeSliderBackground
The slider background color.
COLORREF | m_clrTimeHeaderDivider
The header divider color.
COLORREF | m_clrScrollBarLight
The scrollbar light color.
COLORREF | m_clrScrollBarDark
The scrollbar dark color.
COLORREF | m_clrSelectedArea
The color of the selected area.
COLORREF | m_clrMarker
The color of the marker.
COLORREF | m_clrTimeLineTick
The color of a time line tick.
COLORREF | m_clrMarkerBorder
The color of a time line marker's border.
COLORREF | m_clrMarkerBack
The color of a time line marker's back.
COLORREF | m_clrTrackMarkerBorder
The color of a track marker's border.
COLORREF | m_clrTrackMarkerText
The color of a track marker's text.
COLORREF | m_clrTrackMarkerTextBack
The color of a track marker's text back.
COLORREF | m_clrTrackMarkerTextBorder
The color of a track marker's text border.
COLORREF | m_clrTimeLinePosition
The color of a marked position on a time line.
COLORREF | m_clrTimeHeaderBorder
The color of a time line header's border.
COLORREF | m_clrScrollBarBorderDark
The scrollbar border dark color.
COLORREF | m_clrScrollBarBorderLight
The scrollbar border light color.
COLORREF | m_clrWorkAreaScrollBarLight
The workarea scrollbar light color.
COLORREF | m_clrWorkAreaScrollBarDark
The workarea scrollbar dark color.
COLORREF | m_clrWorkAreaScrollBarBorder
The workarea scrollbar border color.
- Public Attributes inherited from CXTPGridPaintManager
CXTPFont | m_xtpFontText
Grid items default text.
CXTPFont | m_xtpFontBoldText
Grid items default bold text.
CXTPFont | m_xtpFontCaption
Column header caption font.
CXTPFont | m_xtpFontPreview
Column header caption font.
CXTPGridHyperlinkStyle * | m_pHyperlinkStyle
Style for links.
CXTPGridHyperlinkStyle * | m_pHyperlinkHoverStyle
Style for hovered links.
CXTPPaintManagerColor | m_clrHighlight
Background color of the highlighted row.
CXTPPaintManagerColor | m_clrBoldText
Grid items bold text color.
CXTPPaintManagerColor | m_clrBoldTextHighlight
Grid items bold text highlight color.
CXTPPaintManagerColor | m_clrWindowText
Grid items default text color.
CXTPPaintManagerColor | m_clrHighlightText
Text color of the highlighted text.
CXTPPaintManagerColor | m_clrHeaderControl
Background color of the grid header.
CXTPPaintManagerColor | m_clrCaptionText
Column header text color.
CXTPPaintManagerColor | m_clrCaptionTextPressed
Column header text color when pressed.
CXTPPaintManagerColor | m_clrControlBack
Background color of the control grid area.
CXTPPaintManagerColor | m_clrGroupRowText
Row text color.
CXTPPaintManagerColor | m_clrGroupShadeBack
Group row background color when indentation shade is enabled.
CXTPPaintManagerColor | m_clrGroupShadeText
Group row foreground color when indentation shade is enabled.
CXTPPaintManagerColor | m_clrGroupShadeBorder
Color for group border's shade.
CXTPPaintManagerColor | m_clrGroupBoxBack
Color of group box.
CXTPPaintManagerColor | m_clrControlDark
Dark background color of the Grid control (used on Group By area).
CXTPPaintManagerColor | m_clrControlLightLight
Light background color used for drawing shades (used on column header area).
CXTPPaintManagerColor | m_clrHotDivider
Color of the column hot divider window (two arrows).
CXTPPaintManagerColor | m_clrIndentControl
Color of the tree indentation area.
CXTPPaintManagerColor | m_clrItemShade
Color of the shade on sorted by column items.
CXTPPaintManagerColor | m_clrBtnFace
Standard button face color.
CXTPPaintManagerColor | m_clrBtnText
Standard button text color.
CXTPPaintManagerColor | m_clrPreviewText
Preview text color.
CXTPPaintManagerColor | m_clrSelectedRow
Selected row background color.
CXTPPaintManagerColor | m_clrSelectedRowText
Selected row text color.
CXTPPaintManagerColor | m_clrBtnFacePressed
Standard button face color when pressed.
CXTPPaintManagerColor | m_clrConnector
Header column connector line color.
CXTPPaintManagerColor | m_clrDisableBitmapLightest
The lightest color of bitmap which covers disabled grid.
CXTPPaintManagerColor | m_clrDisableBitmapDarkest
The darkest color of bitmap which covers disabled grid.
CXTPPaintManagerColorGradient | m_grcGradientColumn
Color of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColorGradient | m_grcGradientColumnHot
HotTracking Color of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColorGradient | m_grcGradientColumnPushed
Pushed Color of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColor | m_clrGradientColumnShadow
Bottom shadow of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColor | m_clrGradientColumnSeparator
Separator of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColor | m_crlNoGroupByText
A color for "No items" text in GroupBy area (see m_strNoGroupBy member).
CXTPPaintManagerColor | m_clrFreezeColsDivider
Freeze Columns Divider color.
COLORREF | m_clrColumnOffice2007CustomTheme
Base color for Office2007 custom theme.
COLORREF | m_clrFormulaSum
Color for Formula Sum fields.
COLORREF | m_clrFormulaSubSum
Color for Formula SubSum fields.
COLORREF | m_clrAlternativeBackground
Color for Alternative Row Background.
BOOL | m_bUseAlternativeBackground
TRUE to use Alternative Row Background, FALSE otherwise.
BOOL | m_bAllowMergeCells
TRUE to Allow Merge Cells, FALSE otherwise.
int | m_nTextIndentForGroupRowsWithNoIcon
Specifies Text indent if a group row icon is not used.
int | m_nTreeIndent
Tree indentation.
int | m_nTreeStructureStyle
Tree structure style.
int | m_nTreeTextIndentRowParent
Text indent, in pixels, for rows with children.
int | m_nTreeTextIndentRowChildren
Text indent, in pixels, for rows without children.
int | m_nTreeTextIndent
Text indent, in pixels, for rows that are neither parent nor children.
int | m_nTreeTextIndentGroupRow
Text indent, in pixels, for group rows.
BOOL | m_bGroupRowTextBold
TRUE to draw group rows with bold text.
BOOL | m_bShadeGroupHeadings
TRUE to show the indentation shade, FALSE otherwise.
BOOL | m_bShadeSortColumn
TRUE to show the items shade in the sorted by column, FALSE otherwise.
BOOL | m_bHotTracking
TRUE to allow column hot tracking.
BOOL | m_bInvertColumnOnClick
TRUE to invert column on click.
CString | m_strNoItems
A string which contains customized "No Items" text for displaying in view when there are no visible rows.
CString | m_strSortBy
A string which contains customized "Sort By" text for displaying in tooltip.
CString | m_strIncreasing
A string which contains customized "Increasing" text for displaying in tooltip.
CString | m_strDecreasing
A string which contains customized "Decreasing" text for displaying in tooltip.
CString | m_strNoGroupBy
A string which contains customized "No items" text message for displaying in Group By area when there are no items inside it.
CString | m_strNoFieldsAvailable
A string which contains customized "No Fields Available" text message for displaying in Field Chooser.
CString | m_strExpand
A string which contains customized "Expand" text for displaying in tooltip.
CString | m_strCollapse
A string which contains customized "Collapse" text for displaying in tooltip.
BOOL | m_bHideSelection
TRUE when hiding Grid control's selection by drawing selected items as others, FALSE otherwise.
BOOL | m_bPrintSortTriangle
TRUE to show the sort triangle in printout.
BOOL | m_bRevertAlignment
TRUE to revert column alignments.
BOOL | m_bUseEditTextAlignment
TRUE to automatically apply edit alignment using column alignment.
BOOL | m_bShowLockIcon
TRUE to show the lock icon, FALSE to hide.
BOOL | m_bUseShellIcon
TRUE to use the shell icon, FALSE otherwise.
int | m_iRecOrRowStart
Start position in numbering (0 or 1 or something user want).
BOOL | m_bRecOrRowNum
TRUE to display record number if support mode is used, FALSE to display row number.
BOOL | m_bMakeUpper
TRUE to display column header and group row text in all caps.
XTPGridTreeStructureStyle | m_treeStructureStyle
Tree structure style.
CRect | m_rcPreviewIndent
Preview indentation.
int | m_nFixedColumnsIndent
Fixed Column total width.
BOOL | m_bMoveScrollbarOnFixedColumnsIndent
Move Scrollbar right follow FixedColumnsIndent.
BOOL | m_bThemedInplaceButtons
Draw in-place buttons using current theme settings.
BOOL | m_bBaseTreeIndent
TRUE to add Extra Tree indentation to cover initial TreeColumn.
CUIntArray | m_arStartCol
Start column in each virtual page.
int | m_PrintPageWidth
Width of print page (run-time)
BOOL | m_bPrintVirtualPageNumber
TRUE to print horizontal page number.
BOOL | m_bPrintPageRectangle
TRUE to draw rectangle around page.
int | m_RecordNumberWidth
Column width for row/record numbers.
BOOL | m_bForceDynamicMarkupForCell
TRUE if use Markup for Grid Record Item.
BOOL | m_bForceShowDropMarker
TRUE if Force Show Drop Marker.
BOOL | m_bShowNonActiveInPlaceButton
TRUE if use Show Non-Active In-Place Button (Combo, Expand, Spin).
BOOL | m_bPrintWatermark
TRUE to print watermark.
BOOL | m_bUseGroupRowSelectionState
TRUE if use GroupSelectionState Glyph.
BOOL | m_bForceShowTooltip
TRUE if use show tooltip for any cell width case.
BOOL | m_bCleanTooltip
TRUE if use show tooltip without markup.
BOOL | m_bGrayIfDisable
TRUE is disable draw in gray (standard behavior).
int | m_nRowHeightDefault
The default row height.
BOOL | m_bCompactText
TRUE to ignore Icon for Narrow column to show more text.
BOOL | m_bUseDropMarker
FALSE to not draw drop marked when dragging/dropping, TRUE by default.
BOOL | m_bSortTriangleOffsetFromRight
Offset of sort triangle.
int | m_nTreeColumnLineLength
This is the extra line length to apply to tree column lines if there is no expand button.
int | m_nBaseParentRecordIndent
This is initial number of pixels a parent node will be indented when in a group.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Member Functions inherited from CXTPGridPaintManager
virtual void | DrawTextLine (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nFlag, int &nCharCounter, int &nHyperlinkCounter)
Draws a line of text with respect to the drawing rectangle.
virtual int | DrawString (int *pnCurrDrawPos, CDC *pDC, const CString &strDraw, CRect rcDraw, UINT nFormat)
Draw a simple string into rectangle.
virtual void | DrawColumnBackground (CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, BOOL &bColumnPressed, BOOL &bDraggingFromHeader, CXTPGridHeader *pHeader=NULL)
This method is called to draw the background of a column using the current column style.
virtual void | DrawGridPattern (CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush)
Generates a custom grid pattern if necessary.
virtual void | DrawGridPattern (CDC *pDC, CXTPBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush)
Generates a custom grid pattern if necessary.
virtual void | DrawGridPattern (CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr)
Generates a custom grid pattern.
virtual void | DrawInplaceButtonFrame (CDC *pDC, CXTPGridInplaceButton *pButton)
Draws the in-place button frame.
virtual BOOL | DrawInplaceButtonIcon (CDC *pDC, CXTPGridInplaceButton *pButton)
Draws the in-place button icon.
virtual int | CalcColumnHeight (CDC *pDC, CXTPGridColumn *pColumn, int nTotalWidth=0)
Calculates the optimal height for a specified column.
virtual void | DrawMultiLineText (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, BOOL bWordBreak=TRUE)
Draws multi-line text.
virtual void | DrawSingleLineText (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nStartPos, int nEndPos, int nActualWidth)
Draws single-line text.
virtual int | DrawLink (int *pnCurrDrawPos, XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CXTPGridHyperlink *pHyperlink, CString strText, CRect rcLink, int nFlag, BOOL bTrim=FALSE)
Draws a hyperlink string using hyperlink text settings (i.e.
- Protected Attributes inherited from CXTPGridPaintManager
int | m_nRowHeight
Grid row default height.
int | m_nHeaderHeight
Column header height.
int | m_nFooterHeight
Column footer height.
int | m_nGroupGridLineHeight
The height of the group grid line.
CXTPImageManager * | m_pGlyphs
An additional image list for the Grid control.
BOOL | m_bIsPreviewMode
TRUE to show the item preview, FALSE to hide.
int | m_nResizingWidth
The width of the column resizing marker area.
int | m_nMaxPreviewLines
Restrict maximum lines for preview text.
CSize | m_szGlyph
Glyph size.
CXTPBrush | m_xtpBrushTreeStructure
Brush to draw tree nodes.
CXTPBrush | m_xtpBrushGroupGridLineStyle
Brush to draw group row grid lines.
int | m_nFreezeColsDividerStyle
A set of flags from XTPGridFreezeColsDividerStyle.
BOOL | m_bFixedRowHeight
TRUE if fixed rows used.
BOOL | m_bColumnWidthWYSIWYG
TRUE if columns width WYSIWYG mode used.
BOOL | m_bShowWYSIWYGMarkers
TRUE if in non-print mode header show red page-end markers.
BOOL | m_bLastColumnWidthWYSIWYG
TRUE if last column width WYSIWYG mode used.
BOOL | m_bDrawGridForEmptySpace
TRUE if grid fills the empty space (if any) after the body rows.
BOOL | m_bPrintGroupRowIcon
TRUE if printout draw collapse-expand icon for group row.
BOOL | m_bColumnPlusMinusSign
TRUE if expand/collapse icons are used, FALSE if directional arrows are used.
BOOL | m_bFixedInplaceButtonHeight
TRUE if fixed in-place button height is used.
XTPGridGridStyle | m_nGroupGridLineStyle
Current style for group row grid lines.
XTPGridColumnStyle | m_columnStyle
Column drawing style.
CXTPWinThemeWrapper * | m_themeHeader
Header theme wrapper.
CXTPWinThemeWrapper * | m_themeButton
In-place button theme wrapper.
CXTPWinThemeWrapper * | m_themeCombo
Combo box in-place button theme wrapper.
CXTPWinThemeWrapper * | m_themeSpin
Spin in-place button theme wrapper.
CXTPGridControl * | m_pControl
Pointer to the Grid control object.
CXTPMarkupUIElement * | m_pMarkupUIElement_NoGroupBy
The no group by markup UI element.
CString | m_strMarkupUIElement_NoGroupBy
The no group by markup UI element string.
CXTPBrush | m_xtpBrushVeriticalGrid
Brush to draw vertical grid lines.
CXTPBrush | m_xtpBrushHorizontalGrid
Brush to draw horizontal grid lines.
XTPGridGridStyle m_nGridLineStylePreviousV
Previous style for vertical grid lines.
XTPGridGridStyle m_nGridLineStylePreviousH
Previous style for horizontal grid lines.

Detailed Description

This class represents a track control paint manager.

This class does painting of various elements of the track control.

Member Function Documentation

◆ DrawMarkers()

virtual void DrawMarkers ( CDC * pDC )
virtual

Call this function to draw the markers.

Parameters
pDC Pointer to the device context.

This is a virtual function so derived classes can provide their specific implementations.

◆ DrawTimeLine()

virtual void DrawTimeLine ( CDC * pDC )
virtual

Call this function to draw the time line.

Parameters
pDC Pointer to the device context.

This is a virtual function so derived classes can provide their specific implementations.

◆ DrawTrackHeader()

virtual void DrawTrackHeader ( CDC * pDC )
virtual

Call this function to draw the track header.

Parameters
pDC Pointer to the device context.

This is a virtual function so derived classes can provide their specific implementations.

◆ FormatTime()

virtual CString FormatTime ( int nPosition )
virtual

Call this function to format the time and tick marker relative to a time line position.

Parameters
nPosition Point in the time line.
Returns
A CString containing the formatted time.

This is a virtual function so derived classes can provide their specific implementations.

◆ FormatTimeLineTick()

virtual CString FormatTimeLineTick | ( | int | nPosition,
 |  | COLORREF & | clrTick,
 |  | int & | nTickLength )
 virtual

Call this function to format the time and tick marker relative to a time line position.

Parameters
nPosition | Point in the time line.
clrTick | Tick mark color.
nTickLength | Tick mark length.
Returns
A CString containing the formatted time.

This is a virtual function so derived classes can provide their specific implementations.

◆ RefreshMetrics()

void RefreshMetrics ( )
virtual

Initializes all drawings defaults (fonts, colors, etc.).

Most of them are system defaults.

Reimplemented from CXTPGridPaintManager.

Reimplemented in CXTPTrackThemeNativeWindows10, CXTPTrackThemeNativeWindows11, CXTPTrackThemeOffice2003Luna, CXTPTrackThemeOffice2013, CXTPTrackThemeResource, CXTPTrackThemeVisualStudio2012Blue, CXTPTrackThemeVisualStudio2012Dark, CXTPTrackThemeVisualStudio2012Light, CXTPTrackThemeVisualStudio2015, CXTPTrackThemeVisualStudio2017, CXTPTrackThemeVisualStudio2019, and CXTPTrackThemeVisualStudio2022.

The documentation for this class was generated from the following file:
  • XTPTrackPaintManager.h


Toolkit Pro: CXTPTrackSelectedBlocks Class Reference

Public Member Functions | List of all members
CXTPTrackSelectedBlocks Class Reference

This class abstracts the selected blocks of the track control. More...

Inheritance diagram for CXTPTrackSelectedBlocks:
[legend]

Public Member Functions

CXTPTrackSelectedBlocks ()
Constructs the CXTPTrackSelectedBlocks object.
int | GetCount () const
Gets the number of blocks in selected blocks.
void | Add (CXTPTrackBlock *pBlock)
Adds a block to selected blocks.
BOOL | IsSelected (const CXTPTrackBlock *pBlock) const
Determines if a block is selected.
CXTPTrackBlock * | GetAt (int nIndex) const
Retrieves the block at a specified index in selected blocks.
void | RemoveAll ()
Removes all blocks from selected blocks.
void | RemoveAt (int nIndex)
Removes the block at a specified index from selected blocks.
void | Remove (CXTPTrackBlock *pBlock)
Removes a specified block from selected blocks.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

This class abstracts the selected blocks of the track control.

This class helps to perform a common task to the selected blocks (e.g. delete).

Member Function Documentation

◆ Add()

void Add ( CXTPTrackBlock * pBlock )

Adds a block to selected blocks.

Parameters
pBlock Pointer to the block to add.

◆ GetAt()

CXTPTrackBlock * GetAt ( int nIndex ) const

Retrieves the block at a specified index in selected blocks.

Parameters
nIndex Zero-based index of the block to retrieve.
Returns
A pointer to the CXTPTrackBlock at the specified index.

◆ GetCount()

int GetCount ( ) const

Gets the number of blocks in selected blocks.

Returns
The number of blocks in selected blocks.

◆ IsSelected()

BOOL IsSelected ( const CXTPTrackBlock * pBlock ) const

Determines if a block is selected.

Parameters
pBlock Pointer to the block to check.
Returns
TRUE if the block is selected, otherwise FALSE.

◆ Remove()

void Remove ( CXTPTrackBlock * pBlock )

Removes a specified block from selected blocks.

Parameters
pBlock Pointer to the block to be removed.

◆ RemoveAt()

void RemoveAt ( int nIndex )

Removes the block at a specified index from selected blocks.

Parameters
nIndex Zero-based index of the block to remove.
The documentation for this class was generated from the following file:
  • XTPTrackBlock.h


Toolkit Pro: CXTPTrackThemeDefault Class Reference

Public Member Functions | List of all members
CXTPTrackThemeDefault Class Reference

CXTPTrackThemeDefault is a CXTPTrackPaintManager derived class that represents an Office 97 style theme. More...

Inheritance diagram for CXTPTrackThemeDefault:
[legend]

Public Member Functions

CXTPTrackThemeDefault ()
Default paint manager constructor, handles properties initialization.
virtual void | DrawColumnBackground (CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, BOOL &bColumnPressed, BOOL &bDraggingFromHeader, CXTPGridHeader *pHeader=NULL)
This method is called to draw the background of a column using the current column style.
- Public Member Functions inherited from CXTPTrackPaintManager
CXTPTrackPaintManager ()
Creates a CXTPTrackPaintManager object.
~CXTPTrackPaintManager ()
CXTPTrackPaintManager destructor, handles cleanup and deallocation.
void | RefreshMetrics ()
Initializes all drawings defaults (fonts, colors, etc.).
virtual void | DrawTrackHeader (CDC *pDC)
Call this function to draw the track header.
virtual void | DrawMarkers (CDC *pDC)
Call this function to draw the markers.
virtual void | DrawTimeLine (CDC *pDC)
Call this function to draw the time line.
virtual CString | FormatTimeLineTick (int nPosition, COLORREF &clrTick, int &nTickLength)
Call this function to format the time and tick marker relative to a time line position.
virtual CString | FormatTime (int nPosition)
Call this function to format the time and tick marker relative to a time line position.
- Public Member Functions inherited from CXTPGridPaintManager
CXTPGridPaintManager ()
Default CXTPGridPaintManager constructor, handles properties initialization.
virtual | ~CXTPGridPaintManager ()
Default CXTPGridPaintManager destructor, handles member items deallocation.
virtual void | SetGridControl (CXTPGridControl *pControl)
Sets the associated Grid control for the paint manager.
virtual void | LoadGlyphs ()
Loads the default images used by the Grid control.
virtual int | GetRowHeight (CDC *pDC, CXTPGridRow *pRow)
Retrieves the default row height for print mode (i.e.
virtual int | GetRowHeight (CDC *pDC, CXTPGridRow *pRow, int nTotalWidth)
Retrieves the default row height for print mode (i.e.
int | GetRowHeightEx (CDC *pDC, CXTPGridRow *pRow, int nTotalWidth, const BOOL firstLevel=TRUE)
Retrieves the default row height for print mode (i.e.
int | GetItemHeight (XTP_GRIDRECORDITEM_DRAWARGS &drawArgs, int nWidth)
Retrieves the height of a record item for a given width.
BOOL | FindRowAdjacentToMergedEx (const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, int &nAdjRowIndex, BOOL bUpward)
Searches the topmost or bottommost row depending on the height of the current row.
int | FindRowAdjacentToMerged (const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, BOOL bUpward)
Wrapper for the FindRowAdjacentToMergedEx method.
int | RecalcTotalHightOfMergedRows (CXTPGridColumns *pColumns, CDC *pDC, CXTPGridRow *pRow, int nRowHeight, int nTotalWidth)
Recalculates row height according to the height of merged items.
virtual int | GetPreviewItemHeight (CDC *pDC, CXTPGridRow *pRow, int nWidth, int nHeight)
Retrieves the height of a preview item for print mode.
virtual int | GetHeaderHeight ()
Gets the column header height.
virtual int | GetHeaderHeight (CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0)
Calculates the optimal header height.
virtual void | SetHeaderHeight (int nHeight)
Sets the column header height.
virtual int | GetFooterHeight (CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0)
Calculates the optimal footer height.
virtual COLORREF | GetControlBackColor (CXTPGridControl *pControl)
Retrieves the parent Grid control's background color.
virtual void | FillRow (CDC *pDC, CXTPGridRow *pRow, CRect rcRow)
Fills a specified row with its background color.
virtual void | DrawGrid (CDC *pDC, XTPGridOrientation orientation, CRect rcGrid)
Draws a grid for the control.
virtual void | DrawFreezeColsDivider (CDC *pDC, const CRect &rc, CXTPGridControl *pControl, CXTPGridRow *pRow=NULL)
Draws a freeze column divider.
virtual void | DrawVerticalTimeLineMarker (CDC *pDC, int xPos, CXTPGridControl *pControl, COLORREF color=RGB(0, 255, 0))
Draws a vertical timeline marker.
virtual void | DrawGroupRow (CDC *pDC, CXTPGridGroupRow *pRow, CRect rcRow, XTP_GRIDRECORDITEM_METRICS *pMetrics)
Draws a group row.
virtual void | FillGroupRowMetrics (CXTPGridGroupRow *pRow, XTP_GRIDRECORDITEM_METRICS *pMetrics, BOOL bPrinting)
Fills the font and color members of the metrics structure for a specified group row.
virtual void | FillIndent (CDC *pDC, CRect rcRow)
Fills an indent area by its background.
virtual void | FillItemShade (CDC *pDC, CRect rcItem)
Fills an item shade by its background if necessary.
virtual void | FillHeaderControl (CDC *pDC, CRect rcHeader)
Fills a column header control area by its background.
virtual void | FillFooter (CDC *pDC, CRect rcFooter)
Fills a column footer control area by its background.
virtual void | DrawColumnText (CDC *pDC, CRect rcText, CString strCaption, int nHeaderAlignment, BOOL bIsHeader, BOOL bColumnPressed)
Draws text for the column header.
virtual void | DrawColumn (CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn, BOOL bDrawExternal=FALSE, int nShadowWidth=0)
Draws a column header with all related attributes (sort order, icon, etc.).
virtual void | DrawColumnFooterDivider (CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn)
Draws the column footer divider.
virtual void | DrawColumnFooter (CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn)
Draws the column footer with all related attributes (e.g.
virtual BOOL | IsColumHotTrackingEnabled () const
Determines if hot tracking is enabled for the current column style.
virtual void | DrawFocusedRow (CDC *pDC, CRect rcRow)
Draws focused rows.
virtual void | FillGroupByControl (CDC *pDC, CRect &rcGroupBy)
Draws the Group By box.
CXTPImageManager * | GetGlyphs () const
Gets a pointer to the additional image list with glyphs.
void | DrawHorizontalLine (CDC *pDC, int xPos, int yPos, int cx, COLORREF clr)
Draws a horizontal line.
void | DrawVerticalLine (CDC *pDC, int xPos, int yPos, int cy, COLORREF clr)
Draws a vertical line.
virtual void | DrawTriangle (CDC *pDC, CRect rcTriangle, BOOL bToDown, BOOL bDraggingFromHeader, int nShadowWidth, BOOL bColumnPressed)
Draws a triangle that shows the sort order of the column.
void | DrawConnector (CDC *pDC, CPoint ptFrom, CPoint ptTo)
Draws a column connector for the Group By box.
virtual CSize | DrawCollapsedBitmap (CDC *pDC, const CXTPGridRow *pRow, CRect &rcBitmap)
Draws a collapsed bitmap.
virtual int | DrawBitmap (CDC *pDC, CXTPGridControl *pControl, CRect rcColumn, int iImage)
Draws a bitmap.
virtual int | DrawColumnIcon (CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, CRect rcIcon, int iIcon)
Draws an icon for a column.
virtual CSize | DrawGlyph (CDC *pDC, CRect rcColumn, int iImage)
Draws the standard glyphs of the Grid control.
virtual CSize | DrawShellIcon (CDC *pDC, CRect rcColumn, int iImage)
Draws the shell icon.
void | EnablePreviewMode (BOOL bIsPreviewMode)
Enables/disables preview mode for the control.
BOOL | IsPreviewMode () const
Determines if preview mode is enabled/disabled for the control.
CFont * | GetTextFont ()
Gets the default text font used for control items.
int | SetMaxPreviewLines (int nMaxLines)
Sets the maximum number of lines of text for a preview item.
int | GetMaxPreviewLines ()
Gets the maximum number of lines of text for a preview item.
int | GetPreviewLinesCount (CDC *pDC, CRect &rcText, const CString &strText)
Calculates the number of lines required to draw a specified preview text string, taking into account the maximum number of lines of text for a preview item.
BOOL | IsGridVisible (BOOL bVertical) const
Determines the visibility of specified grid lines.
BOOL | IsGridVisible (XTPGridOrientation orientation) const
Determines the visibility of specified grid lines.
void | SetColumnStyle (XTPGridColumnStyle columnStyle)
Sets the header style.
XTPGridColumnStyle | GetColumnStyle () const
Gets the header style.
void | SetColumnOffice2007CustomThemeBaseColor (COLORREF clrBaseColor)
Sets the header's custom theme base color for Office2007 column style.
COLORREF | GetColumnOffice2007CustomThemeBaseColor () const
Gets the header's custom theme base color for Office2007 column style.
void | SetTextFont (LOGFONT &lf)
Creates and sets the default text font.
void | SetCaptionFont (LOGFONT &lf)
Creates and sets the default caption font.
void | SetPreviewIndent (int nLeft, int nTop, int nRight, int nBottom)
Sets the preview item indent.
virtual void | DrawInplaceButton (CDC *pDC, CXTPGridInplaceButton *pButton)
Draws the in-place button of the Grid control.
virtual BOOL | DrawInplaceComboButton (CDC *pDC, CRect *pRc)
Draws the combo button of the Grid control.
virtual BOOL | DrawInplaceExpandButton (CDC *pDC, CRect *pRc)
Draws the expand button of the Grid control.
virtual BOOL | DrawInplaceSpinButton (CDC *pDC, CRect *pRc)
Draws the spin button of the Grid control.
virtual void | DrawTreeStructure (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CRect rcItem, CSize sizeGlyph)
Draws tree elements of the Grid control.
virtual void | DrawItemBitmap (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CRect &rcItem, int nImage)
Draws an item bitmap.
virtual void | DrawItemCaption (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics)
Draws an item caption.
virtual void | DrawRowNumber (CDC *pDC, CRect rcNumber, CXTPGridRow *pRow)
Draws a row number.
virtual void | DrawItemControl (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CXTPGridRecordItemControl *pControl, CRect &rcItem)
Draws an item control.
BOOL | IsFixedRowHeight () const
Determines if the paint manager supports fixed or variable row height.
void | SetFixedRowHeight (BOOL bFixedRowHeight)
Sets if the paint manager supports fixed or variable row height.
BOOL | IsColumnWidthWYSIWYG () const
Determines if the paint manager supports column width WYSIWYG mode.
BOOL | IsLastColumnWidthWYSIWYG () const
Determines if the paint manager supports last column width WYSIWYG mode.
BOOL | IsShowWYSIWYGMarkers () const
Determines if the paint manager shows WYSIWYG page-end markers.
void | ShowWYSIWYGMarkers (BOOL bSet)
Sets if the paint manager shows WYSIWYG page-end markers.
void | SetColumnWidthWYSIWYG (BOOL bColumnWidthWYSIWYG)
Sets if the paint manager supports column width WYSIWYG mode.
void | SetLastColumnWidthWYSIWYG (BOOL bColumnWidthWYSIWYG)
Sets if the paint manager supports last column width WYSIWYG mode.
BOOL | IsFixedInplaceButtonHeight () const
Determines if the paint manager supports fixed or variable in-place button height.
void | SetInplaceButtonHeight (BOOL bFixedInplaceButtonHeight)
Sets if the paint manager supports fixed or variable in-place button height.
int | GetFreezeColsDividerStyle () const
Gets the style of the freeze columns divider line.
void | SetFreezeColsDividerStyle (int nStyle)
Sets the style for the freeze columns divider line.
virtual BOOL | OnDrawAction (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs)
Override this method to perform custom activities for the item before processing it.
virtual void | DrawNoGroupByText (CDC *pDC, CRect rcItem)
Draws the "No items" text message in the Group By area when there are no items inside it.
BOOL | IsDrawGridForEmptySpace () const
Determines if the grid fills empty space after body rows.
void | SetDrawGridForEmptySpace (BOOL bDrawGrid)
Sets if the grid fills empty space after body rows.
BOOL | IsPrintGroupRowIcon () const
Determines if the group row collapse-expand icon is drawn in print mode.
void | SetPrintGroupRowIcon (BOOL bDraw)
Sets if the group row collapse-expand icon is drawn in print mode.
BOOL | IsColumnPlusMinusSign () const
Determines if columns use expand/collapse icons (+/-) or directional arrows.
void | SetColumnPlusMinusSign (BOOL bDraw)
Specifies if columns use expand/collapse icons (+/-) or directional arrows.
virtual int | CalculateRowHeight (CDC *pDC, const CString &strText, int nMaxWidth, BOOL bWordBreak=TRUE)
Calculates the height required for a rectangle bounding multi-line text to draw the multi-line text when the width of the rectangle is fixed.
void | DrawSectionDivider (CDC *pDC, const CRect &rc, XTPGridSectionDividerPosition dividerPosition, XTPGridSectionDividerStyle dividerStyle, CXTPPaintManagerColor dividerColor)
Draws the divider between grid sections (e.g.
int | GetSectionDividerHeight (XTPGridFixedRowsDividerStyle dividerStyle)
Gets the height of the section divider.
BOOL | IsUseDropMarker () const
Determines if a drop marker will be used when dragging and dropping.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPTrackPaintManager
COLORREF | m_clrWorkArea
The color of the work area.
COLORREF | m_clrTrackHeader
The track header color.
COLORREF | m_clrTrackTimeArea
The track time area color.
COLORREF | m_clrTimeHeaderDarkDark
The header deep dark color.
COLORREF | m_clrTimeHeaderDark
The header dark color.
COLORREF | m_clrTimeSliderBackground
The slider background color.
COLORREF | m_clrTimeHeaderDivider
The header divider color.
COLORREF | m_clrScrollBarLight
The scrollbar light color.
COLORREF | m_clrScrollBarDark
The scrollbar dark color.
COLORREF | m_clrSelectedArea
The color of the selected area.
COLORREF | m_clrMarker
The color of the marker.
COLORREF | m_clrTimeLineTick
The color of a time line tick.
COLORREF | m_clrMarkerBorder
The color of a time line marker's border.
COLORREF | m_clrMarkerBack
The color of a time line marker's back.
COLORREF | m_clrTrackMarkerBorder
The color of a track marker's border.
COLORREF | m_clrTrackMarkerText
The color of a track marker's text.
COLORREF | m_clrTrackMarkerTextBack
The color of a track marker's text back.
COLORREF | m_clrTrackMarkerTextBorder
The color of a track marker's text border.
COLORREF | m_clrTimeLinePosition
The color of a marked position on a time line.
COLORREF | m_clrTimeHeaderBorder
The color of a time line header's border.
COLORREF | m_clrScrollBarBorderDark
The scrollbar border dark color.
COLORREF | m_clrScrollBarBorderLight
The scrollbar border light color.
COLORREF | m_clrWorkAreaScrollBarLight
The workarea scrollbar light color.
COLORREF | m_clrWorkAreaScrollBarDark
The workarea scrollbar dark color.
COLORREF | m_clrWorkAreaScrollBarBorder
The workarea scrollbar border color.
- Public Attributes inherited from CXTPGridPaintManager
CXTPFont | m_xtpFontText
Grid items default text.
CXTPFont | m_xtpFontBoldText
Grid items default bold text.
CXTPFont | m_xtpFontCaption
Column header caption font.
CXTPFont | m_xtpFontPreview
Column header caption font.
CXTPGridHyperlinkStyle * | m_pHyperlinkStyle
Style for links.
CXTPGridHyperlinkStyle * | m_pHyperlinkHoverStyle
Style for hovered links.
CXTPPaintManagerColor | m_clrHighlight
Background color of the highlighted row.
CXTPPaintManagerColor | m_clrBoldText
Grid items bold text color.
CXTPPaintManagerColor | m_clrBoldTextHighlight
Grid items bold text highlight color.
CXTPPaintManagerColor | m_clrWindowText
Grid items default text color.
CXTPPaintManagerColor | m_clrHighlightText
Text color of the highlighted text.
CXTPPaintManagerColor | m_clrHeaderControl
Background color of the grid header.
CXTPPaintManagerColor | m_clrCaptionText
Column header text color.
CXTPPaintManagerColor | m_clrCaptionTextPressed
Column header text color when pressed.
CXTPPaintManagerColor | m_clrControlBack
Background color of the control grid area.
CXTPPaintManagerColor | m_clrGroupRowText
Row text color.
CXTPPaintManagerColor | m_clrGroupShadeBack
Group row background color when indentation shade is enabled.
CXTPPaintManagerColor | m_clrGroupShadeText
Group row foreground color when indentation shade is enabled.
CXTPPaintManagerColor | m_clrGroupShadeBorder
Color for group border's shade.
CXTPPaintManagerColor | m_clrGroupBoxBack
Color of group box.
CXTPPaintManagerColor | m_clrControlDark
Dark background color of the Grid control (used on Group By area).
CXTPPaintManagerColor | m_clrControlLightLight
Light background color used for drawing shades (used on column header area).
CXTPPaintManagerColor | m_clrHotDivider
Color of the column hot divider window (two arrows).
CXTPPaintManagerColor | m_clrIndentControl
Color of the tree indentation area.
CXTPPaintManagerColor | m_clrItemShade
Color of the shade on sorted by column items.
CXTPPaintManagerColor | m_clrBtnFace
Standard button face color.
CXTPPaintManagerColor | m_clrBtnText
Standard button text color.
CXTPPaintManagerColor | m_clrPreviewText
Preview text color.
CXTPPaintManagerColor | m_clrSelectedRow
Selected row background color.
CXTPPaintManagerColor | m_clrSelectedRowText
Selected row text color.
CXTPPaintManagerColor | m_clrBtnFacePressed
Standard button face color when pressed.
CXTPPaintManagerColor | m_clrConnector
Header column connector line color.
CXTPPaintManagerColor | m_clrDisableBitmapLightest
The lightest color of bitmap which covers disabled grid.
CXTPPaintManagerColor | m_clrDisableBitmapDarkest
The darkest color of bitmap which covers disabled grid.
CXTPPaintManagerColorGradient | m_grcGradientColumn
Color of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColorGradient | m_grcGradientColumnHot
HotTracking Color of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColorGradient | m_grcGradientColumnPushed
Pushed Color of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColor | m_clrGradientColumnShadow
Bottom shadow of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColor | m_clrGradientColumnSeparator
Separator of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColor | m_crlNoGroupByText
A color for "No items" text in GroupBy area (see m_strNoGroupBy member).
CXTPPaintManagerColor | m_clrFreezeColsDivider
Freeze Columns Divider color.
COLORREF | m_clrColumnOffice2007CustomTheme
Base color for Office2007 custom theme.
COLORREF | m_clrFormulaSum
Color for Formula Sum fields.
COLORREF | m_clrFormulaSubSum
Color for Formula SubSum fields.
COLORREF | m_clrAlternativeBackground
Color for Alternative Row Background.
BOOL | m_bUseAlternativeBackground
TRUE to use Alternative Row Background, FALSE otherwise.
BOOL | m_bAllowMergeCells
TRUE to Allow Merge Cells, FALSE otherwise.
int | m_nTextIndentForGroupRowsWithNoIcon
Specifies Text indent if a group row icon is not used.
int | m_nTreeIndent
Tree indentation.
int | m_nTreeStructureStyle
Tree structure style.
int | m_nTreeTextIndentRowParent
Text indent, in pixels, for rows with children.
int | m_nTreeTextIndentRowChildren
Text indent, in pixels, for rows without children.
int | m_nTreeTextIndent
Text indent, in pixels, for rows that are neither parent nor children.
int | m_nTreeTextIndentGroupRow
Text indent, in pixels, for group rows.
BOOL | m_bGroupRowTextBold
TRUE to draw group rows with bold text.
BOOL | m_bShadeGroupHeadings
TRUE to show the indentation shade, FALSE otherwise.
BOOL | m_bShadeSortColumn
TRUE to show the items shade in the sorted by column, FALSE otherwise.
BOOL | m_bHotTracking
TRUE to allow column hot tracking.
BOOL | m_bInvertColumnOnClick
TRUE to invert column on click.
CString | m_strNoItems
A string which contains customized "No Items" text for displaying in view when there are no visible rows.
CString | m_strSortBy
A string which contains customized "Sort By" text for displaying in tooltip.
CString | m_strIncreasing
A string which contains customized "Increasing" text for displaying in tooltip.
CString | m_strDecreasing
A string which contains customized "Decreasing" text for displaying in tooltip.
CString | m_strNoGroupBy
A string which contains customized "No items" text message for displaying in Group By area when there are no items inside it.
CString | m_strNoFieldsAvailable
A string which contains customized "No Fields Available" text message for displaying in Field Chooser.
CString | m_strExpand
A string which contains customized "Expand" text for displaying in tooltip.
CString | m_strCollapse
A string which contains customized "Collapse" text for displaying in tooltip.
BOOL | m_bHideSelection
TRUE when hiding Grid control's selection by drawing selected items as others, FALSE otherwise.
BOOL | m_bPrintSortTriangle
TRUE to show the sort triangle in printout.
BOOL | m_bRevertAlignment
TRUE to revert column alignments.
BOOL | m_bUseEditTextAlignment
TRUE to automatically apply edit alignment using column alignment.
BOOL | m_bShowLockIcon
TRUE to show the lock icon, FALSE to hide.
BOOL | m_bUseShellIcon
TRUE to use the shell icon, FALSE otherwise.
int | m_iRecOrRowStart
Start position in numbering (0 or 1 or something user want).
BOOL | m_bRecOrRowNum
TRUE to display record number if support mode is used, FALSE to display row number.
BOOL | m_bMakeUpper
TRUE to display column header and group row text in all caps.
XTPGridTreeStructureStyle | m_treeStructureStyle
Tree structure style.
CRect | m_rcPreviewIndent
Preview indentation.
int | m_nFixedColumnsIndent
Fixed Column total width.
BOOL | m_bMoveScrollbarOnFixedColumnsIndent
Move Scrollbar right follow FixedColumnsIndent.
BOOL | m_bThemedInplaceButtons
Draw in-place buttons using current theme settings.
BOOL | m_bBaseTreeIndent
TRUE to add Extra Tree indentation to cover initial TreeColumn.
CUIntArray | m_arStartCol
Start column in each virtual page.
int | m_PrintPageWidth
Width of print page (run-time)
BOOL | m_bPrintVirtualPageNumber
TRUE to print horizontal page number.
BOOL | m_bPrintPageRectangle
TRUE to draw rectangle around page.
int | m_RecordNumberWidth
Column width for row/record numbers.
BOOL | m_bForceDynamicMarkupForCell
TRUE if use Markup for Grid Record Item.
BOOL | m_bForceShowDropMarker
TRUE if Force Show Drop Marker.
BOOL | m_bShowNonActiveInPlaceButton
TRUE if use Show Non-Active In-Place Button (Combo, Expand, Spin).
BOOL | m_bPrintWatermark
TRUE to print watermark.
BOOL | m_bUseGroupRowSelectionState
TRUE if use GroupSelectionState Glyph.
BOOL | m_bForceShowTooltip
TRUE if use show tooltip for any cell width case.
BOOL | m_bCleanTooltip
TRUE if use show tooltip without markup.
BOOL | m_bGrayIfDisable
TRUE is disable draw in gray (standard behavior).
int | m_nRowHeightDefault
The default row height.
BOOL | m_bCompactText
TRUE to ignore Icon for Narrow column to show more text.
BOOL | m_bUseDropMarker
FALSE to not draw drop marked when dragging/dropping, TRUE by default.
BOOL | m_bSortTriangleOffsetFromRight
Offset of sort triangle.
int | m_nTreeColumnLineLength
This is the extra line length to apply to tree column lines if there is no expand button.
int | m_nBaseParentRecordIndent
This is initial number of pixels a parent node will be indented when in a group.
- Protected Member Functions inherited from CXTPTrackPaintManager
- Protected Member Functions inherited from CXTPGridPaintManager
virtual void | DrawTextLine (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nFlag, int &nCharCounter, int &nHyperlinkCounter)
Draws a line of text with respect to the drawing rectangle.
virtual int | DrawString (int *pnCurrDrawPos, CDC *pDC, const CString &strDraw, CRect rcDraw, UINT nFormat)
Draw a simple string into rectangle.
virtual void | DrawGridPattern (CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush)
Generates a custom grid pattern if necessary.
virtual void | DrawGridPattern (CDC *pDC, CXTPBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush)
Generates a custom grid pattern if necessary.
virtual void | DrawGridPattern (CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr)
Generates a custom grid pattern.
virtual void | DrawInplaceButtonFrame (CDC *pDC, CXTPGridInplaceButton *pButton)
Draws the in-place button frame.
virtual BOOL | DrawInplaceButtonIcon (CDC *pDC, CXTPGridInplaceButton *pButton)
Draws the in-place button icon.
virtual int | CalcColumnHeight (CDC *pDC, CXTPGridColumn *pColumn, int nTotalWidth=0)
Calculates the optimal height for a specified column.
virtual void | DrawMultiLineText (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, BOOL bWordBreak=TRUE)
Draws multi-line text.
virtual void | DrawSingleLineText (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nStartPos, int nEndPos, int nActualWidth)
Draws single-line text.
virtual int | DrawLink (int *pnCurrDrawPos, XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CXTPGridHyperlink *pHyperlink, CString strText, CRect rcLink, int nFlag, BOOL bTrim=FALSE)
Draws a hyperlink string using hyperlink text settings (i.e.
- Protected Attributes inherited from CXTPGridPaintManager
int | m_nRowHeight
Grid row default height.
int | m_nHeaderHeight
Column header height.
int | m_nFooterHeight
Column footer height.
int | m_nGroupGridLineHeight
The height of the group grid line.
CXTPImageManager * | m_pGlyphs
An additional image list for the Grid control.
BOOL | m_bIsPreviewMode
TRUE to show the item preview, FALSE to hide.
int | m_nResizingWidth
The width of the column resizing marker area.
int | m_nMaxPreviewLines
Restrict maximum lines for preview text.
CSize | m_szGlyph
Glyph size.
CXTPBrush | m_xtpBrushTreeStructure
Brush to draw tree nodes.
CXTPBrush | m_xtpBrushGroupGridLineStyle
Brush to draw group row grid lines.
int | m_nFreezeColsDividerStyle
A set of flags from XTPGridFreezeColsDividerStyle.
BOOL | m_bFixedRowHeight
TRUE if fixed rows used.
BOOL | m_bColumnWidthWYSIWYG
TRUE if columns width WYSIWYG mode used.
BOOL | m_bShowWYSIWYGMarkers
TRUE if in non-print mode header show red page-end markers.
BOOL | m_bLastColumnWidthWYSIWYG
TRUE if last column width WYSIWYG mode used.
BOOL | m_bDrawGridForEmptySpace
TRUE if grid fills the empty space (if any) after the body rows.
BOOL | m_bPrintGroupRowIcon
TRUE if printout draw collapse-expand icon for group row.
BOOL | m_bColumnPlusMinusSign
TRUE if expand/collapse icons are used, FALSE if directional arrows are used.
BOOL | m_bFixedInplaceButtonHeight
TRUE if fixed in-place button height is used.
XTPGridGridStyle | m_nGroupGridLineStyle
Current style for group row grid lines.
XTPGridColumnStyle | m_columnStyle
Column drawing style.
CXTPWinThemeWrapper * | m_themeHeader
Header theme wrapper.
CXTPWinThemeWrapper * | m_themeButton
In-place button theme wrapper.
CXTPWinThemeWrapper * | m_themeCombo
Combo box in-place button theme wrapper.
CXTPWinThemeWrapper * | m_themeSpin
Spin in-place button theme wrapper.
CXTPGridControl * | m_pControl
Pointer to the Grid control object.
CXTPMarkupUIElement * | m_pMarkupUIElement_NoGroupBy
The no group by markup UI element.
CString | m_strMarkupUIElement_NoGroupBy
The no group by markup UI element string.
CXTPBrush | m_xtpBrushVeriticalGrid
Brush to draw vertical grid lines.
CXTPBrush | m_xtpBrushHorizontalGrid
Brush to draw horizontal grid lines.
XTPGridGridStyle m_nGridLineStylePreviousV
Previous style for vertical grid lines.
XTPGridGridStyle m_nGridLineStylePreviousH
Previous style for horizontal grid lines.

Detailed Description

CXTPTrackThemeDefault is a CXTPTrackPaintManager derived class that represents an Office 97 style theme.

Member Function Documentation

◆ DrawColumnBackground()

virtual void DrawColumnBackground | ( | CDC * | pDC,
 |  | CXTPGridColumn * | pColumn,
 |  | CRect | rcColumn,
 |  | BOOL & | bColumnPressed,
 |  | BOOL & | bDraggingFromHeader,
 |  | CXTPGridHeader * | pHeader = NULL )
 virtual

This method is called to draw the background of a column using the current column style.

Parameters
pDC | Pointer to the used device context.
pColumn | Pointer to the column whose background must be drawn.
rcColumn | Bounding rectangle of the column.
bColumnPressed | TRUE if the column is pressed by the user.
bDraggingFromHeader | TRUE if the column is being dragged from the header area.
pHeader | Pointer to the header that the column belongs to.

Reimplemented from CXTPGridPaintManager.

The documentation for this class was generated from the following file:
  • XTPTrackThemeDefault.h


Toolkit Pro: CXTPTrackThemeExplorer Class Reference

Public Member Functions | List of all members
CXTPTrackThemeExplorer Class Reference

CXTPTrackThemeExplorer is a CXTPTrackPaintManager derived class that represents an Explorer style theme. More...

Inheritance diagram for CXTPTrackThemeExplorer:
[legend]

Public Member Functions

CXTPTrackThemeExplorer ()
Default paint manager constructor, handles properties initialization.
virtual void | DrawTriangle (CDC *pDC, CRect rcTriangle, BOOL bToDown, int nShadowWidth=0)
Draws a triangle that shows the sort order of the column.
virtual CSize | DrawGlyph (CDC *pDC, CRect rcColumn, int iImage)
Draws the standard glyphs of the Grid control.
virtual BOOL | IsColumHotTrackingEnabled () const
Determines if hot tracking is enabled for the current column style.
virtual void | DrawColumnBackground (CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, BOOL &bColumnPressed, BOOL &bDraggingFromHeader, CXTPGridHeader *pHeader=NULL)
This method is called to draw the background of a column using the current column style.
void | DrawSectionDivider (CDC *pDC, const CRect &rc, XTPGridSectionDividerPosition dividerPosition, XTPGridSectionDividerStyle dividerStyle, CXTPPaintManagerColor dividerColor)
Draws the divider between grid sections (e.g.
- Public Member Functions inherited from CXTPTrackPaintManager
CXTPTrackPaintManager ()
Creates a CXTPTrackPaintManager object.
~CXTPTrackPaintManager ()
CXTPTrackPaintManager destructor, handles cleanup and deallocation.
void | RefreshMetrics ()
Initializes all drawings defaults (fonts, colors, etc.).
virtual void | DrawTrackHeader (CDC *pDC)
Call this function to draw the track header.
virtual void | DrawMarkers (CDC *pDC)
Call this function to draw the markers.
virtual void | DrawTimeLine (CDC *pDC)
Call this function to draw the time line.
virtual CString | FormatTimeLineTick (int nPosition, COLORREF &clrTick, int &nTickLength)
Call this function to format the time and tick marker relative to a time line position.
virtual CString | FormatTime (int nPosition)
Call this function to format the time and tick marker relative to a time line position.
- Public Member Functions inherited from CXTPGridPaintManager
CXTPGridPaintManager ()
Default CXTPGridPaintManager constructor, handles properties initialization.
virtual | ~CXTPGridPaintManager ()
Default CXTPGridPaintManager destructor, handles member items deallocation.
virtual void | SetGridControl (CXTPGridControl *pControl)
Sets the associated Grid control for the paint manager.
virtual void | LoadGlyphs ()
Loads the default images used by the Grid control.
virtual int | GetRowHeight (CDC *pDC, CXTPGridRow *pRow)
Retrieves the default row height for print mode (i.e.
virtual int | GetRowHeight (CDC *pDC, CXTPGridRow *pRow, int nTotalWidth)
Retrieves the default row height for print mode (i.e.
int | GetRowHeightEx (CDC *pDC, CXTPGridRow *pRow, int nTotalWidth, const BOOL firstLevel=TRUE)
Retrieves the default row height for print mode (i.e.
int | GetItemHeight (XTP_GRIDRECORDITEM_DRAWARGS &drawArgs, int nWidth)
Retrieves the height of a record item for a given width.
BOOL | FindRowAdjacentToMergedEx (const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, int &nAdjRowIndex, BOOL bUpward)
Searches the topmost or bottommost row depending on the height of the current row.
int | FindRowAdjacentToMerged (const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, BOOL bUpward)
Wrapper for the FindRowAdjacentToMergedEx method.
int | RecalcTotalHightOfMergedRows (CXTPGridColumns *pColumns, CDC *pDC, CXTPGridRow *pRow, int nRowHeight, int nTotalWidth)
Recalculates row height according to the height of merged items.
virtual int | GetPreviewItemHeight (CDC *pDC, CXTPGridRow *pRow, int nWidth, int nHeight)
Retrieves the height of a preview item for print mode.
virtual int | GetHeaderHeight ()
Gets the column header height.
virtual int | GetHeaderHeight (CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0)
Calculates the optimal header height.
virtual void | SetHeaderHeight (int nHeight)
Sets the column header height.
virtual int | GetFooterHeight (CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0)
Calculates the optimal footer height.
virtual COLORREF | GetControlBackColor (CXTPGridControl *pControl)
Retrieves the parent Grid control's background color.
virtual void | FillRow (CDC *pDC, CXTPGridRow *pRow, CRect rcRow)
Fills a specified row with its background color.
virtual void | DrawGrid (CDC *pDC, XTPGridOrientation orientation, CRect rcGrid)
Draws a grid for the control.
virtual void | DrawFreezeColsDivider (CDC *pDC, const CRect &rc, CXTPGridControl *pControl, CXTPGridRow *pRow=NULL)
Draws a freeze column divider.
virtual void | DrawVerticalTimeLineMarker (CDC *pDC, int xPos, CXTPGridControl *pControl, COLORREF color=RGB(0, 255, 0))
Draws a vertical timeline marker.
virtual void | DrawGroupRow (CDC *pDC, CXTPGridGroupRow *pRow, CRect rcRow, XTP_GRIDRECORDITEM_METRICS *pMetrics)
Draws a group row.
virtual void | FillGroupRowMetrics (CXTPGridGroupRow *pRow, XTP_GRIDRECORDITEM_METRICS *pMetrics, BOOL bPrinting)
Fills the font and color members of the metrics structure for a specified group row.
virtual void | FillIndent (CDC *pDC, CRect rcRow)
Fills an indent area by its background.
virtual void | FillItemShade (CDC *pDC, CRect rcItem)
Fills an item shade by its background if necessary.
virtual void | FillHeaderControl (CDC *pDC, CRect rcHeader)
Fills a column header control area by its background.
virtual void | FillFooter (CDC *pDC, CRect rcFooter)
Fills a column footer control area by its background.
virtual void | DrawColumnText (CDC *pDC, CRect rcText, CString strCaption, int nHeaderAlignment, BOOL bIsHeader, BOOL bColumnPressed)
Draws text for the column header.
virtual void | DrawColumn (CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn, BOOL bDrawExternal=FALSE, int nShadowWidth=0)
Draws a column header with all related attributes (sort order, icon, etc.).
virtual void | DrawColumnFooterDivider (CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn)
Draws the column footer divider.
virtual void | DrawColumnFooter (CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn)
Draws the column footer with all related attributes (e.g.
virtual void | DrawFocusedRow (CDC *pDC, CRect rcRow)
Draws focused rows.
virtual void | FillGroupByControl (CDC *pDC, CRect &rcGroupBy)
Draws the Group By box.
CXTPImageManager * | GetGlyphs () const
Gets a pointer to the additional image list with glyphs.
void | DrawHorizontalLine (CDC *pDC, int xPos, int yPos, int cx, COLORREF clr)
Draws a horizontal line.
void | DrawVerticalLine (CDC *pDC, int xPos, int yPos, int cy, COLORREF clr)
Draws a vertical line.
virtual void | DrawTriangle (CDC *pDC, CRect rcTriangle, BOOL bToDown, BOOL bDraggingFromHeader, int nShadowWidth, BOOL bColumnPressed)
Draws a triangle that shows the sort order of the column.
void | DrawConnector (CDC *pDC, CPoint ptFrom, CPoint ptTo)
Draws a column connector for the Group By box.
virtual CSize | DrawCollapsedBitmap (CDC *pDC, const CXTPGridRow *pRow, CRect &rcBitmap)
Draws a collapsed bitmap.
virtual int | DrawBitmap (CDC *pDC, CXTPGridControl *pControl, CRect rcColumn, int iImage)
Draws a bitmap.
virtual int | DrawColumnIcon (CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, CRect rcIcon, int iIcon)
Draws an icon for a column.
virtual CSize | DrawShellIcon (CDC *pDC, CRect rcColumn, int iImage)
Draws the shell icon.
void | EnablePreviewMode (BOOL bIsPreviewMode)
Enables/disables preview mode for the control.
BOOL | IsPreviewMode () const
Determines if preview mode is enabled/disabled for the control.
CFont * | GetTextFont ()
Gets the default text font used for control items.
int | SetMaxPreviewLines (int nMaxLines)
Sets the maximum number of lines of text for a preview item.
int | GetMaxPreviewLines ()
Gets the maximum number of lines of text for a preview item.
int | GetPreviewLinesCount (CDC *pDC, CRect &rcText, const CString &strText)
Calculates the number of lines required to draw a specified preview text string, taking into account the maximum number of lines of text for a preview item.
BOOL | IsGridVisible (BOOL bVertical) const
Determines the visibility of specified grid lines.
BOOL | IsGridVisible (XTPGridOrientation orientation) const
Determines the visibility of specified grid lines.
void | SetColumnStyle (XTPGridColumnStyle columnStyle)
Sets the header style.
XTPGridColumnStyle | GetColumnStyle () const
Gets the header style.
void | SetColumnOffice2007CustomThemeBaseColor (COLORREF clrBaseColor)
Sets the header's custom theme base color for Office2007 column style.
COLORREF | GetColumnOffice2007CustomThemeBaseColor () const
Gets the header's custom theme base color for Office2007 column style.
void | SetTextFont (LOGFONT &lf)
Creates and sets the default text font.
void | SetCaptionFont (LOGFONT &lf)
Creates and sets the default caption font.
void | SetPreviewIndent (int nLeft, int nTop, int nRight, int nBottom)
Sets the preview item indent.
virtual void | DrawInplaceButton (CDC *pDC, CXTPGridInplaceButton *pButton)
Draws the in-place button of the Grid control.
virtual BOOL | DrawInplaceComboButton (CDC *pDC, CRect *pRc)
Draws the combo button of the Grid control.
virtual BOOL | DrawInplaceExpandButton (CDC *pDC, CRect *pRc)
Draws the expand button of the Grid control.
virtual BOOL | DrawInplaceSpinButton (CDC *pDC, CRect *pRc)
Draws the spin button of the Grid control.
virtual void | DrawTreeStructure (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CRect rcItem, CSize sizeGlyph)
Draws tree elements of the Grid control.
virtual void | DrawItemBitmap (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CRect &rcItem, int nImage)
Draws an item bitmap.
virtual void | DrawItemCaption (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics)
Draws an item caption.
virtual void | DrawRowNumber (CDC *pDC, CRect rcNumber, CXTPGridRow *pRow)
Draws a row number.
virtual void | DrawItemControl (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CXTPGridRecordItemControl *pControl, CRect &rcItem)
Draws an item control.
BOOL | IsFixedRowHeight () const
Determines if the paint manager supports fixed or variable row height.
void | SetFixedRowHeight (BOOL bFixedRowHeight)
Sets if the paint manager supports fixed or variable row height.
BOOL | IsColumnWidthWYSIWYG () const
Determines if the paint manager supports column width WYSIWYG mode.
BOOL | IsLastColumnWidthWYSIWYG () const
Determines if the paint manager supports last column width WYSIWYG mode.
BOOL | IsShowWYSIWYGMarkers () const
Determines if the paint manager shows WYSIWYG page-end markers.
void | ShowWYSIWYGMarkers (BOOL bSet)
Sets if the paint manager shows WYSIWYG page-end markers.
void | SetColumnWidthWYSIWYG (BOOL bColumnWidthWYSIWYG)
Sets if the paint manager supports column width WYSIWYG mode.
void | SetLastColumnWidthWYSIWYG (BOOL bColumnWidthWYSIWYG)
Sets if the paint manager supports last column width WYSIWYG mode.
BOOL | IsFixedInplaceButtonHeight () const
Determines if the paint manager supports fixed or variable in-place button height.
void | SetInplaceButtonHeight (BOOL bFixedInplaceButtonHeight)
Sets if the paint manager supports fixed or variable in-place button height.
int | GetFreezeColsDividerStyle () const
Gets the style of the freeze columns divider line.
void | SetFreezeColsDividerStyle (int nStyle)
Sets the style for the freeze columns divider line.
virtual BOOL | OnDrawAction (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs)
Override this method to perform custom activities for the item before processing it.
virtual void | DrawNoGroupByText (CDC *pDC, CRect rcItem)
Draws the "No items" text message in the Group By area when there are no items inside it.
BOOL | IsDrawGridForEmptySpace () const
Determines if the grid fills empty space after body rows.
void | SetDrawGridForEmptySpace (BOOL bDrawGrid)
Sets if the grid fills empty space after body rows.
BOOL | IsPrintGroupRowIcon () const
Determines if the group row collapse-expand icon is drawn in print mode.
void | SetPrintGroupRowIcon (BOOL bDraw)
Sets if the group row collapse-expand icon is drawn in print mode.
BOOL | IsColumnPlusMinusSign () const
Determines if columns use expand/collapse icons (+/-) or directional arrows.
void | SetColumnPlusMinusSign (BOOL bDraw)
Specifies if columns use expand/collapse icons (+/-) or directional arrows.
virtual int | CalculateRowHeight (CDC *pDC, const CString &strText, int nMaxWidth, BOOL bWordBreak=TRUE)
Calculates the height required for a rectangle bounding multi-line text to draw the multi-line text when the width of the rectangle is fixed.
void | DrawSectionDivider (CDC *pDC, const CRect &rc, XTPGridSectionDividerPosition dividerPosition, XTPGridSectionDividerStyle dividerStyle, CXTPPaintManagerColor dividerColor)
Draws the divider between grid sections (e.g.
int | GetSectionDividerHeight (XTPGridFixedRowsDividerStyle dividerStyle)
Gets the height of the section divider.
BOOL | IsUseDropMarker () const
Determines if a drop marker will be used when dragging and dropping.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPTrackPaintManager
COLORREF | m_clrWorkArea
The color of the work area.
COLORREF | m_clrTrackHeader
The track header color.
COLORREF | m_clrTrackTimeArea
The track time area color.
COLORREF | m_clrTimeHeaderDarkDark
The header deep dark color.
COLORREF | m_clrTimeHeaderDark
The header dark color.
COLORREF | m_clrTimeSliderBackground
The slider background color.
COLORREF | m_clrTimeHeaderDivider
The header divider color.
COLORREF | m_clrScrollBarLight
The scrollbar light color.
COLORREF | m_clrScrollBarDark
The scrollbar dark color.
COLORREF | m_clrSelectedArea
The color of the selected area.
COLORREF | m_clrMarker
The color of the marker.
COLORREF | m_clrTimeLineTick
The color of a time line tick.
COLORREF | m_clrMarkerBorder
The color of a time line marker's border.
COLORREF | m_clrMarkerBack
The color of a time line marker's back.
COLORREF | m_clrTrackMarkerBorder
The color of a track marker's border.
COLORREF | m_clrTrackMarkerText
The color of a track marker's text.
COLORREF | m_clrTrackMarkerTextBack
The color of a track marker's text back.
COLORREF | m_clrTrackMarkerTextBorder
The color of a track marker's text border.
COLORREF | m_clrTimeLinePosition
The color of a marked position on a time line.
COLORREF | m_clrTimeHeaderBorder
The color of a time line header's border.
COLORREF | m_clrScrollBarBorderDark
The scrollbar border dark color.
COLORREF | m_clrScrollBarBorderLight
The scrollbar border light color.
COLORREF | m_clrWorkAreaScrollBarLight
The workarea scrollbar light color.
COLORREF | m_clrWorkAreaScrollBarDark
The workarea scrollbar dark color.
COLORREF | m_clrWorkAreaScrollBarBorder
The workarea scrollbar border color.
- Public Attributes inherited from CXTPGridPaintManager
CXTPFont | m_xtpFontText
Grid items default text.
CXTPFont | m_xtpFontBoldText
Grid items default bold text.
CXTPFont | m_xtpFontCaption
Column header caption font.
CXTPFont | m_xtpFontPreview
Column header caption font.
CXTPGridHyperlinkStyle * | m_pHyperlinkStyle
Style for links.
CXTPGridHyperlinkStyle * | m_pHyperlinkHoverStyle
Style for hovered links.
CXTPPaintManagerColor | m_clrHighlight
Background color of the highlighted row.
CXTPPaintManagerColor | m_clrBoldText
Grid items bold text color.
CXTPPaintManagerColor | m_clrBoldTextHighlight
Grid items bold text highlight color.
CXTPPaintManagerColor | m_clrWindowText
Grid items default text color.
CXTPPaintManagerColor | m_clrHighlightText
Text color of the highlighted text.
CXTPPaintManagerColor | m_clrHeaderControl
Background color of the grid header.
CXTPPaintManagerColor | m_clrCaptionText
Column header text color.
CXTPPaintManagerColor | m_clrCaptionTextPressed
Column header text color when pressed.
CXTPPaintManagerColor | m_clrControlBack
Background color of the control grid area.
CXTPPaintManagerColor | m_clrGroupRowText
Row text color.
CXTPPaintManagerColor | m_clrGroupShadeBack
Group row background color when indentation shade is enabled.
CXTPPaintManagerColor | m_clrGroupShadeText
Group row foreground color when indentation shade is enabled.
CXTPPaintManagerColor | m_clrGroupShadeBorder
Color for group border's shade.
CXTPPaintManagerColor | m_clrGroupBoxBack
Color of group box.
CXTPPaintManagerColor | m_clrControlDark
Dark background color of the Grid control (used on Group By area).
CXTPPaintManagerColor | m_clrControlLightLight
Light background color used for drawing shades (used on column header area).
CXTPPaintManagerColor | m_clrHotDivider
Color of the column hot divider window (two arrows).
CXTPPaintManagerColor | m_clrIndentControl
Color of the tree indentation area.
CXTPPaintManagerColor | m_clrItemShade
Color of the shade on sorted by column items.
CXTPPaintManagerColor | m_clrBtnFace
Standard button face color.
CXTPPaintManagerColor | m_clrBtnText
Standard button text color.
CXTPPaintManagerColor | m_clrPreviewText
Preview text color.
CXTPPaintManagerColor | m_clrSelectedRow
Selected row background color.
CXTPPaintManagerColor | m_clrSelectedRowText
Selected row text color.
CXTPPaintManagerColor | m_clrBtnFacePressed
Standard button face color when pressed.
CXTPPaintManagerColor | m_clrConnector
Header column connector line color.
CXTPPaintManagerColor | m_clrDisableBitmapLightest
The lightest color of bitmap which covers disabled grid.
CXTPPaintManagerColor | m_clrDisableBitmapDarkest
The darkest color of bitmap which covers disabled grid.
CXTPPaintManagerColorGradient | m_grcGradientColumn
Color of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColorGradient | m_grcGradientColumnHot
HotTracking Color of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColorGradient | m_grcGradientColumnPushed
Pushed Color of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColor | m_clrGradientColumnShadow
Bottom shadow of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColor | m_clrGradientColumnSeparator
Separator of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColor | m_crlNoGroupByText
A color for "No items" text in GroupBy area (see m_strNoGroupBy member).
CXTPPaintManagerColor | m_clrFreezeColsDivider
Freeze Columns Divider color.
COLORREF | m_clrColumnOffice2007CustomTheme
Base color for Office2007 custom theme.
COLORREF | m_clrFormulaSum
Color for Formula Sum fields.
COLORREF | m_clrFormulaSubSum
Color for Formula SubSum fields.
COLORREF | m_clrAlternativeBackground
Color for Alternative Row Background.
BOOL | m_bUseAlternativeBackground
TRUE to use Alternative Row Background, FALSE otherwise.
BOOL | m_bAllowMergeCells
TRUE to Allow Merge Cells, FALSE otherwise.
int | m_nTextIndentForGroupRowsWithNoIcon
Specifies Text indent if a group row icon is not used.
int | m_nTreeIndent
Tree indentation.
int | m_nTreeStructureStyle
Tree structure style.
int | m_nTreeTextIndentRowParent
Text indent, in pixels, for rows with children.
int | m_nTreeTextIndentRowChildren
Text indent, in pixels, for rows without children.
int | m_nTreeTextIndent
Text indent, in pixels, for rows that are neither parent nor children.
int | m_nTreeTextIndentGroupRow
Text indent, in pixels, for group rows.
BOOL | m_bGroupRowTextBold
TRUE to draw group rows with bold text.
BOOL | m_bShadeGroupHeadings
TRUE to show the indentation shade, FALSE otherwise.
BOOL | m_bShadeSortColumn
TRUE to show the items shade in the sorted by column, FALSE otherwise.
BOOL | m_bHotTracking
TRUE to allow column hot tracking.
BOOL | m_bInvertColumnOnClick
TRUE to invert column on click.
CString | m_strNoItems
A string which contains customized "No Items" text for displaying in view when there are no visible rows.
CString | m_strSortBy
A string which contains customized "Sort By" text for displaying in tooltip.
CString | m_strIncreasing
A string which contains customized "Increasing" text for displaying in tooltip.
CString | m_strDecreasing
A string which contains customized "Decreasing" text for displaying in tooltip.
CString | m_strNoGroupBy
A string which contains customized "No items" text message for displaying in Group By area when there are no items inside it.
CString | m_strNoFieldsAvailable
A string which contains customized "No Fields Available" text message for displaying in Field Chooser.
CString | m_strExpand
A string which contains customized "Expand" text for displaying in tooltip.
CString | m_strCollapse
A string which contains customized "Collapse" text for displaying in tooltip.
BOOL | m_bHideSelection
TRUE when hiding Grid control's selection by drawing selected items as others, FALSE otherwise.
BOOL | m_bPrintSortTriangle
TRUE to show the sort triangle in printout.
BOOL | m_bRevertAlignment
TRUE to revert column alignments.
BOOL | m_bUseEditTextAlignment
TRUE to automatically apply edit alignment using column alignment.
BOOL | m_bShowLockIcon
TRUE to show the lock icon, FALSE to hide.
BOOL | m_bUseShellIcon
TRUE to use the shell icon, FALSE otherwise.
int | m_iRecOrRowStart
Start position in numbering (0 or 1 or something user want).
BOOL | m_bRecOrRowNum
TRUE to display record number if support mode is used, FALSE to display row number.
BOOL | m_bMakeUpper
TRUE to display column header and group row text in all caps.
XTPGridTreeStructureStyle | m_treeStructureStyle
Tree structure style.
CRect | m_rcPreviewIndent
Preview indentation.
int | m_nFixedColumnsIndent
Fixed Column total width.
BOOL | m_bMoveScrollbarOnFixedColumnsIndent
Move Scrollbar right follow FixedColumnsIndent.
BOOL | m_bThemedInplaceButtons
Draw in-place buttons using current theme settings.
BOOL | m_bBaseTreeIndent
TRUE to add Extra Tree indentation to cover initial TreeColumn.
CUIntArray | m_arStartCol
Start column in each virtual page.
int | m_PrintPageWidth
Width of print page (run-time)
BOOL | m_bPrintVirtualPageNumber
TRUE to print horizontal page number.
BOOL | m_bPrintPageRectangle
TRUE to draw rectangle around page.
int | m_RecordNumberWidth
Column width for row/record numbers.
BOOL | m_bForceDynamicMarkupForCell
TRUE if use Markup for Grid Record Item.
BOOL | m_bForceShowDropMarker
TRUE if Force Show Drop Marker.
BOOL | m_bShowNonActiveInPlaceButton
TRUE if use Show Non-Active In-Place Button (Combo, Expand, Spin).
BOOL | m_bPrintWatermark
TRUE to print watermark.
BOOL | m_bUseGroupRowSelectionState
TRUE if use GroupSelectionState Glyph.
BOOL | m_bForceShowTooltip
TRUE if use show tooltip for any cell width case.
BOOL | m_bCleanTooltip
TRUE if use show tooltip without markup.
BOOL | m_bGrayIfDisable
TRUE is disable draw in gray (standard behavior).
int | m_nRowHeightDefault
The default row height.
BOOL | m_bCompactText
TRUE to ignore Icon for Narrow column to show more text.
BOOL | m_bUseDropMarker
FALSE to not draw drop marked when dragging/dropping, TRUE by default.
BOOL | m_bSortTriangleOffsetFromRight
Offset of sort triangle.
int | m_nTreeColumnLineLength
This is the extra line length to apply to tree column lines if there is no expand button.
int | m_nBaseParentRecordIndent
This is initial number of pixels a parent node will be indented when in a group.
- Protected Member Functions inherited from CXTPTrackPaintManager
- Protected Member Functions inherited from CXTPGridPaintManager
virtual void | DrawTextLine (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nFlag, int &nCharCounter, int &nHyperlinkCounter)
Draws a line of text with respect to the drawing rectangle.
virtual int | DrawString (int *pnCurrDrawPos, CDC *pDC, const CString &strDraw, CRect rcDraw, UINT nFormat)
Draw a simple string into rectangle.
virtual void | DrawGridPattern (CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush)
Generates a custom grid pattern if necessary.
virtual void | DrawGridPattern (CDC *pDC, CXTPBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush)
Generates a custom grid pattern if necessary.
virtual void | DrawGridPattern (CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr)
Generates a custom grid pattern.
virtual void | DrawInplaceButtonFrame (CDC *pDC, CXTPGridInplaceButton *pButton)
Draws the in-place button frame.
virtual BOOL | DrawInplaceButtonIcon (CDC *pDC, CXTPGridInplaceButton *pButton)
Draws the in-place button icon.
virtual int | CalcColumnHeight (CDC *pDC, CXTPGridColumn *pColumn, int nTotalWidth=0)
Calculates the optimal height for a specified column.
virtual void | DrawMultiLineText (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, BOOL bWordBreak=TRUE)
Draws multi-line text.
virtual void | DrawSingleLineText (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nStartPos, int nEndPos, int nActualWidth)
Draws single-line text.
virtual int | DrawLink (int *pnCurrDrawPos, XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CXTPGridHyperlink *pHyperlink, CString strText, CRect rcLink, int nFlag, BOOL bTrim=FALSE)
Draws a hyperlink string using hyperlink text settings (i.e.
- Protected Attributes inherited from CXTPGridPaintManager
int | m_nRowHeight
Grid row default height.
int | m_nHeaderHeight
Column header height.
int | m_nFooterHeight
Column footer height.
int | m_nGroupGridLineHeight
The height of the group grid line.
CXTPImageManager * | m_pGlyphs
An additional image list for the Grid control.
BOOL | m_bIsPreviewMode
TRUE to show the item preview, FALSE to hide.
int | m_nResizingWidth
The width of the column resizing marker area.
int | m_nMaxPreviewLines
Restrict maximum lines for preview text.
CSize | m_szGlyph
Glyph size.
CXTPBrush | m_xtpBrushTreeStructure
Brush to draw tree nodes.
CXTPBrush | m_xtpBrushGroupGridLineStyle
Brush to draw group row grid lines.
int | m_nFreezeColsDividerStyle
A set of flags from XTPGridFreezeColsDividerStyle.
BOOL | m_bFixedRowHeight
TRUE if fixed rows used.
BOOL | m_bColumnWidthWYSIWYG
TRUE if columns width WYSIWYG mode used.
BOOL | m_bShowWYSIWYGMarkers
TRUE if in non-print mode header show red page-end markers.
BOOL | m_bLastColumnWidthWYSIWYG
TRUE if last column width WYSIWYG mode used.
BOOL | m_bDrawGridForEmptySpace
TRUE if grid fills the empty space (if any) after the body rows.
BOOL | m_bPrintGroupRowIcon
TRUE if printout draw collapse-expand icon for group row.
BOOL | m_bColumnPlusMinusSign
TRUE if expand/collapse icons are used, FALSE if directional arrows are used.
BOOL | m_bFixedInplaceButtonHeight
TRUE if fixed in-place button height is used.
XTPGridGridStyle | m_nGroupGridLineStyle
Current style for group row grid lines.
XTPGridColumnStyle | m_columnStyle
Column drawing style.
CXTPWinThemeWrapper * | m_themeHeader
Header theme wrapper.
CXTPWinThemeWrapper * | m_themeButton
In-place button theme wrapper.
CXTPWinThemeWrapper * | m_themeCombo
Combo box in-place button theme wrapper.
CXTPWinThemeWrapper * | m_themeSpin
Spin in-place button theme wrapper.
CXTPGridControl * | m_pControl
Pointer to the Grid control object.
CXTPMarkupUIElement * | m_pMarkupUIElement_NoGroupBy
The no group by markup UI element.
CString | m_strMarkupUIElement_NoGroupBy
The no group by markup UI element string.
CXTPBrush | m_xtpBrushVeriticalGrid
Brush to draw vertical grid lines.
CXTPBrush | m_xtpBrushHorizontalGrid
Brush to draw horizontal grid lines.
XTPGridGridStyle m_nGridLineStylePreviousV
Previous style for vertical grid lines.
XTPGridGridStyle m_nGridLineStylePreviousH
Previous style for horizontal grid lines.

Detailed Description

CXTPTrackThemeExplorer is a CXTPTrackPaintManager derived class that represents an Explorer style theme.

Member Function Documentation

◆ DrawColumnBackground()

virtual void DrawColumnBackground | ( | CDC * | pDC,
 |  | CXTPGridColumn * | pColumn,
 |  | CRect | rcColumn,
 |  | BOOL & | bColumnPressed,
 |  | BOOL & | bDraggingFromHeader,
 |  | CXTPGridHeader * | pHeader = NULL )
 virtual

This method is called to draw the background of a column using the current column style.

Parameters
pDC | Pointer to the used device context.
pColumn | Pointer to the column whose background must be drawn.
rcColumn | Bounding rectangle of the column.
bColumnPressed | TRUE if the column is pressed by the user.
bDraggingFromHeader | TRUE if the column is being dragged from the header area.
pHeader | Pointer to the header that the column belongs to.

Reimplemented from CXTPGridPaintManager.

◆ DrawGlyph()

virtual CSize DrawGlyph | ( | CDC * | pDC,
 |  | CRect | rcColumn,
 |  | int | iImage )
 virtual

Draws the standard glyphs of the Grid control.

Parameters
pDC | Pointer to the used device context.
rcColumn | Bitmap area rectangle coordinates.
iImage | Image index.
Returns
The size of the drawn bitmap.

Reimplemented from CXTPGridPaintManager.

◆ DrawSectionDivider()

void DrawSectionDivider | ( | CDC * | pDC,
 |  | const CRect & | rc,
 |  | XTPGridSectionDividerPosition | dividerPosition,
 |  | XTPGridSectionDividerStyle | dividerStyle,
 |  | CXTPPaintManagerColor | dividerColor )

Draws the divider between grid sections (e.g.

dividing header record rows and body rows).

Parameters
pDC | Pointer to the used device context.
rc | Reference to rectangle coordinates.
dividerPosition | Position of the section divider; must be one of the values defined by the XTPGridSectionDividerPosition enumeration.
dividerStyle | Style of the section divider; must be one of the values defined by the XTPGridSectionDividerStyle enumeration.
dividerColor | Color of the section divider.

◆ DrawTriangle()

virtual void DrawTriangle | ( | CDC * | pDC,
 |  | CRect | rcTriangle,
 |  | BOOL | bToDown,
 |  | int | nShadowWidth = 0 )
 virtual

Draws a triangle that shows the sort order of the column.

Parameters
pDC | Pointer to the used device context.
rcTriangle | Triangle area rectangle coordinates.
bToDown | TRUE to turn the top of the triangle downward, FALSE to turn the top of the triangle upward.
nShadowWidth | Size, in pixels, of the shadow to draw under the triangle image, or 0 to disable the shadow; the default value for this parameter is 0.

This function is used to draw a triangle image on the header of the column that is sorted. The triangle represents the direction of the sort: ascending or descending. The size of the triangle depends on the rectangle area provided.

Example:

// draw ascendant triangle
CRect rcTriangle;
rcTriangle.CopyRect(rcHeader);
rcTriangle.DeflateRect(40, 5, 5, 5);
DrawTriangle(pDC, rcTriangle, TRUE);

// draw descendant triangle
CRect rcTriangle;
rcTriangle.CopyRect(rcHeader);
rcTriangle.DeflateRect(40, 5, 5, 5);
DrawTriangle(pDC, rcTriangle, FALSE);

◆ IsColumHotTrackingEnabled()

virtual BOOL IsColumHotTrackingEnabled ( ) const
virtual

Determines if hot tracking is enabled for the current column style.

Returns
TRUE if hot tracking is enabled, otherwise FALSE.

Hot tracking can only be used for the xtpGridColumnOffice2003 and xtpGridColumnExplorer styles.

See also
m_columnStyle, m_bHotTracking

Reimplemented from CXTPGridPaintManager.

The documentation for this class was generated from the following file:
  • XTPTrackThemeExplorer.h


Toolkit Pro: CXTPTrackThemeNativeWindows10 Class Reference

Public Member Functions | List of all members
CXTPTrackThemeNativeWindows10 Class Reference

CXTPTrackThemeNativeWindows10 is a CXTPTrackThemeOffice2013 derived class that represents a Native Windows 10 style theme. More...

Inheritance diagram for CXTPTrackThemeNativeWindows10:
[legend]

Public Member Functions

CXTPTrackThemeNativeWindows10 ()
Default paint manager constructor, handles properties initialization.
virtual void | RefreshMetrics ()
This method is called to refresh the visual metrics of the track control.
- Public Member Functions inherited from CXTPTrackThemeOffice2013
CXTPTrackThemeOffice2013 ()
Default paint manager constructor, handles properties initialization.
virtual void | LoadGlyphs ()
Loads the default images used by the track control.
virtual void | DrawColumnText (CDC *pDC, CRect rcText, CString strCaption, int nHeaderAlignment, BOOL bIsHeader, BOOL bColumnPressed)
Draws text for the column header.
virtual void | DrawColumnBackground (CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, BOOL &bColumnPressed, BOOL &bDraggingFromHeader, CXTPGridHeader *pHeader=NULL)
This method is called to draw the background of a column using the current column style.
virtual void | DrawTriangle (CDC *pDC, CRect rcTriangle, BOOL bToDown, BOOL bDraggingFromHeader, int nShadowWidth, BOOL bColumnPressed)
Draws a triangle that shows the sort order of the column.
virtual void | FillGroupRowMetrics (CXTPGridGroupRow *pRow, XTP_GRIDRECORDITEM_METRICS *pMetrics, BOOL bPrinting)
Fills the font and color members of the metrics structure for a specified group row.
virtual void | DrawGroupRow (CDC *pDC, CXTPGridGroupRow *pRow, CRect rcRow, XTP_GRIDRECORDITEM_METRICS *pMetrics)
Draws a group row.
virtual void | DrawFocusedRow (CDC *pDC, CRect rcRow)
Draws focused rows.
virtual int | GetRowHeight (CDC *pDC, CXTPGridRow *pRow)
Retrieves the default row height for print mode (i.e.
- Public Member Functions inherited from CXTPTrackPaintManager
CXTPTrackPaintManager ()
Creates a CXTPTrackPaintManager object.
~CXTPTrackPaintManager ()
CXTPTrackPaintManager destructor, handles cleanup and deallocation.
virtual void | DrawTrackHeader (CDC *pDC)
Call this function to draw the track header.
virtual void | DrawMarkers (CDC *pDC)
Call this function to draw the markers.
virtual void | DrawTimeLine (CDC *pDC)
Call this function to draw the time line.
virtual CString | FormatTimeLineTick (int nPosition, COLORREF &clrTick, int &nTickLength)
Call this function to format the time and tick marker relative to a time line position.
virtual CString | FormatTime (int nPosition)
Call this function to format the time and tick marker relative to a time line position.
- Public Member Functions inherited from CXTPGridPaintManager
CXTPGridPaintManager ()
Default CXTPGridPaintManager constructor, handles properties initialization.
virtual | ~CXTPGridPaintManager ()
Default CXTPGridPaintManager destructor, handles member items deallocation.
virtual void | SetGridControl (CXTPGridControl *pControl)
Sets the associated Grid control for the paint manager.
virtual int | GetRowHeight (CDC *pDC, CXTPGridRow *pRow, int nTotalWidth)
Retrieves the default row height for print mode (i.e.
int | GetRowHeightEx (CDC *pDC, CXTPGridRow *pRow, int nTotalWidth, const BOOL firstLevel=TRUE)
Retrieves the default row height for print mode (i.e.
int | GetItemHeight (XTP_GRIDRECORDITEM_DRAWARGS &drawArgs, int nWidth)
Retrieves the height of a record item for a given width.
BOOL | FindRowAdjacentToMergedEx (const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, int &nAdjRowIndex, BOOL bUpward)
Searches the topmost or bottommost row depending on the height of the current row.
int | FindRowAdjacentToMerged (const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, BOOL bUpward)
Wrapper for the FindRowAdjacentToMergedEx method.
int | RecalcTotalHightOfMergedRows (CXTPGridColumns *pColumns, CDC *pDC, CXTPGridRow *pRow, int nRowHeight, int nTotalWidth)
Recalculates row height according to the height of merged items.
virtual int | GetPreviewItemHeight (CDC *pDC, CXTPGridRow *pRow, int nWidth, int nHeight)
Retrieves the height of a preview item for print mode.
virtual int | GetHeaderHeight ()
Gets the column header height.
virtual int | GetHeaderHeight (CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0)
Calculates the optimal header height.
virtual void | SetHeaderHeight (int nHeight)
Sets the column header height.
virtual int | GetFooterHeight (CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0)
Calculates the optimal footer height.
virtual COLORREF | GetControlBackColor (CXTPGridControl *pControl)
Retrieves the parent Grid control's background color.
virtual void | FillRow (CDC *pDC, CXTPGridRow *pRow, CRect rcRow)
Fills a specified row with its background color.
virtual void | DrawGrid (CDC *pDC, XTPGridOrientation orientation, CRect rcGrid)
Draws a grid for the control.
virtual void | DrawFreezeColsDivider (CDC *pDC, const CRect &rc, CXTPGridControl *pControl, CXTPGridRow *pRow=NULL)
Draws a freeze column divider.
virtual void | DrawVerticalTimeLineMarker (CDC *pDC, int xPos, CXTPGridControl *pControl, COLORREF color=RGB(0, 255, 0))
Draws a vertical timeline marker.
virtual void | FillIndent (CDC *pDC, CRect rcRow)
Fills an indent area by its background.
virtual void | FillItemShade (CDC *pDC, CRect rcItem)
Fills an item shade by its background if necessary.
virtual void | FillHeaderControl (CDC *pDC, CRect rcHeader)
Fills a column header control area by its background.
virtual void | FillFooter (CDC *pDC, CRect rcFooter)
Fills a column footer control area by its background.
virtual void | DrawColumn (CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn, BOOL bDrawExternal=FALSE, int nShadowWidth=0)
Draws a column header with all related attributes (sort order, icon, etc.).
virtual void | DrawColumnFooterDivider (CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn)
Draws the column footer divider.
virtual void | DrawColumnFooter (CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn)
Draws the column footer with all related attributes (e.g.
virtual BOOL | IsColumHotTrackingEnabled () const
Determines if hot tracking is enabled for the current column style.
virtual void | FillGroupByControl (CDC *pDC, CRect &rcGroupBy)
Draws the Group By box.
CXTPImageManager * | GetGlyphs () const
Gets a pointer to the additional image list with glyphs.
void | DrawHorizontalLine (CDC *pDC, int xPos, int yPos, int cx, COLORREF clr)
Draws a horizontal line.
void | DrawVerticalLine (CDC *pDC, int xPos, int yPos, int cy, COLORREF clr)
Draws a vertical line.
void | DrawConnector (CDC *pDC, CPoint ptFrom, CPoint ptTo)
Draws a column connector for the Group By box.
virtual CSize | DrawCollapsedBitmap (CDC *pDC, const CXTPGridRow *pRow, CRect &rcBitmap)
Draws a collapsed bitmap.
virtual int | DrawBitmap (CDC *pDC, CXTPGridControl *pControl, CRect rcColumn, int iImage)
Draws a bitmap.
virtual int | DrawColumnIcon (CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, CRect rcIcon, int iIcon)
Draws an icon for a column.
virtual CSize | DrawGlyph (CDC *pDC, CRect rcColumn, int iImage)
Draws the standard glyphs of the Grid control.
virtual CSize | DrawShellIcon (CDC *pDC, CRect rcColumn, int iImage)
Draws the shell icon.
void | EnablePreviewMode (BOOL bIsPreviewMode)
Enables/disables preview mode for the control.
BOOL | IsPreviewMode () const
Determines if preview mode is enabled/disabled for the control.
CFont * | GetTextFont ()
Gets the default text font used for control items.
int | SetMaxPreviewLines (int nMaxLines)
Sets the maximum number of lines of text for a preview item.
int | GetMaxPreviewLines ()
Gets the maximum number of lines of text for a preview item.
int | GetPreviewLinesCount (CDC *pDC, CRect &rcText, const CString &strText)
Calculates the number of lines required to draw a specified preview text string, taking into account the maximum number of lines of text for a preview item.
BOOL | IsGridVisible (BOOL bVertical) const
Determines the visibility of specified grid lines.
BOOL | IsGridVisible (XTPGridOrientation orientation) const
Determines the visibility of specified grid lines.
void | SetColumnStyle (XTPGridColumnStyle columnStyle)
Sets the header style.
XTPGridColumnStyle | GetColumnStyle () const
Gets the header style.
void | SetColumnOffice2007CustomThemeBaseColor (COLORREF clrBaseColor)
Sets the header's custom theme base color for Office2007 column style.
COLORREF | GetColumnOffice2007CustomThemeBaseColor () const
Gets the header's custom theme base color for Office2007 column style.
void | SetTextFont (LOGFONT &lf)
Creates and sets the default text font.
void | SetCaptionFont (LOGFONT &lf)
Creates and sets the default caption font.
void | SetPreviewIndent (int nLeft, int nTop, int nRight, int nBottom)
Sets the preview item indent.
virtual void | DrawInplaceButton (CDC *pDC, CXTPGridInplaceButton *pButton)
Draws the in-place button of the Grid control.
virtual BOOL | DrawInplaceComboButton (CDC *pDC, CRect *pRc)
Draws the combo button of the Grid control.
virtual BOOL | DrawInplaceExpandButton (CDC *pDC, CRect *pRc)
Draws the expand button of the Grid control.
virtual BOOL | DrawInplaceSpinButton (CDC *pDC, CRect *pRc)
Draws the spin button of the Grid control.
virtual void | DrawTreeStructure (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CRect rcItem, CSize sizeGlyph)
Draws tree elements of the Grid control.
virtual void | DrawItemBitmap (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CRect &rcItem, int nImage)
Draws an item bitmap.
virtual void | DrawItemCaption (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics)
Draws an item caption.
virtual void | DrawRowNumber (CDC *pDC, CRect rcNumber, CXTPGridRow *pRow)
Draws a row number.
virtual void | DrawItemControl (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CXTPGridRecordItemControl *pControl, CRect &rcItem)
Draws an item control.
BOOL | IsFixedRowHeight () const
Determines if the paint manager supports fixed or variable row height.
void | SetFixedRowHeight (BOOL bFixedRowHeight)
Sets if the paint manager supports fixed or variable row height.
BOOL | IsColumnWidthWYSIWYG () const
Determines if the paint manager supports column width WYSIWYG mode.
BOOL | IsLastColumnWidthWYSIWYG () const
Determines if the paint manager supports last column width WYSIWYG mode.
BOOL | IsShowWYSIWYGMarkers () const
Determines if the paint manager shows WYSIWYG page-end markers.
void | ShowWYSIWYGMarkers (BOOL bSet)
Sets if the paint manager shows WYSIWYG page-end markers.
void | SetColumnWidthWYSIWYG (BOOL bColumnWidthWYSIWYG)
Sets if the paint manager supports column width WYSIWYG mode.
void | SetLastColumnWidthWYSIWYG (BOOL bColumnWidthWYSIWYG)
Sets if the paint manager supports last column width WYSIWYG mode.
BOOL | IsFixedInplaceButtonHeight () const
Determines if the paint manager supports fixed or variable in-place button height.
void | SetInplaceButtonHeight (BOOL bFixedInplaceButtonHeight)
Sets if the paint manager supports fixed or variable in-place button height.
int | GetFreezeColsDividerStyle () const
Gets the style of the freeze columns divider line.
void | SetFreezeColsDividerStyle (int nStyle)
Sets the style for the freeze columns divider line.
virtual BOOL | OnDrawAction (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs)
Override this method to perform custom activities for the item before processing it.
virtual void | DrawNoGroupByText (CDC *pDC, CRect rcItem)
Draws the "No items" text message in the Group By area when there are no items inside it.
BOOL | IsDrawGridForEmptySpace () const
Determines if the grid fills empty space after body rows.
void | SetDrawGridForEmptySpace (BOOL bDrawGrid)
Sets if the grid fills empty space after body rows.
BOOL | IsPrintGroupRowIcon () const
Determines if the group row collapse-expand icon is drawn in print mode.
void | SetPrintGroupRowIcon (BOOL bDraw)
Sets if the group row collapse-expand icon is drawn in print mode.
BOOL | IsColumnPlusMinusSign () const
Determines if columns use expand/collapse icons (+/-) or directional arrows.
void | SetColumnPlusMinusSign (BOOL bDraw)
Specifies if columns use expand/collapse icons (+/-) or directional arrows.
virtual int | CalculateRowHeight (CDC *pDC, const CString &strText, int nMaxWidth, BOOL bWordBreak=TRUE)
Calculates the height required for a rectangle bounding multi-line text to draw the multi-line text when the width of the rectangle is fixed.
void | DrawSectionDivider (CDC *pDC, const CRect &rc, XTPGridSectionDividerPosition dividerPosition, XTPGridSectionDividerStyle dividerStyle, CXTPPaintManagerColor dividerColor)
Draws the divider between grid sections (e.g.
int | GetSectionDividerHeight (XTPGridFixedRowsDividerStyle dividerStyle)
Gets the height of the section divider.
BOOL | IsUseDropMarker () const
Determines if a drop marker will be used when dragging and dropping.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPTrackThemeOffice2013
CXTPPaintManagerColor | m_clrGlyph
Header glyph color.
CXTPPaintManagerColor | m_clrGlyphHighlight
Header highlighted glyph color.
CXTPPaintManagerColor | m_clrSelectedBorder
Selected block border.
- Public Attributes inherited from CXTPTrackPaintManager
COLORREF | m_clrWorkArea
The color of the work area.
COLORREF | m_clrTrackHeader
The track header color.
COLORREF | m_clrTrackTimeArea
The track time area color.
COLORREF | m_clrTimeHeaderDarkDark
The header deep dark color.
COLORREF | m_clrTimeHeaderDark
The header dark color.
COLORREF | m_clrTimeSliderBackground
The slider background color.
COLORREF | m_clrTimeHeaderDivider
The header divider color.
COLORREF | m_clrScrollBarLight
The scrollbar light color.
COLORREF | m_clrScrollBarDark
The scrollbar dark color.
COLORREF | m_clrSelectedArea
The color of the selected area.
COLORREF | m_clrMarker
The color of the marker.
COLORREF | m_clrTimeLineTick
The color of a time line tick.
COLORREF | m_clrMarkerBorder
The color of a time line marker's border.
COLORREF | m_clrMarkerBack
The color of a time line marker's back.
COLORREF | m_clrTrackMarkerBorder
The color of a track marker's border.
COLORREF | m_clrTrackMarkerText
The color of a track marker's text.
COLORREF | m_clrTrackMarkerTextBack
The color of a track marker's text back.
COLORREF | m_clrTrackMarkerTextBorder
The color of a track marker's text border.
COLORREF | m_clrTimeLinePosition
The color of a marked position on a time line.
COLORREF | m_clrTimeHeaderBorder
The color of a time line header's border.
COLORREF | m_clrScrollBarBorderDark
The scrollbar border dark color.
COLORREF | m_clrScrollBarBorderLight
The scrollbar border light color.
COLORREF | m_clrWorkAreaScrollBarLight
The workarea scrollbar light color.
COLORREF | m_clrWorkAreaScrollBarDark
The workarea scrollbar dark color.
COLORREF | m_clrWorkAreaScrollBarBorder
The workarea scrollbar border color.
- Public Attributes inherited from CXTPGridPaintManager
CXTPFont | m_xtpFontText
Grid items default text.
CXTPFont | m_xtpFontBoldText
Grid items default bold text.
CXTPFont | m_xtpFontCaption
Column header caption font.
CXTPFont | m_xtpFontPreview
Column header caption font.
CXTPGridHyperlinkStyle * | m_pHyperlinkStyle
Style for links.
CXTPGridHyperlinkStyle * | m_pHyperlinkHoverStyle
Style for hovered links.
CXTPPaintManagerColor | m_clrHighlight
Background color of the highlighted row.
CXTPPaintManagerColor | m_clrBoldText
Grid items bold text color.
CXTPPaintManagerColor | m_clrBoldTextHighlight
Grid items bold text highlight color.
CXTPPaintManagerColor | m_clrWindowText
Grid items default text color.
CXTPPaintManagerColor | m_clrHighlightText
Text color of the highlighted text.
CXTPPaintManagerColor | m_clrHeaderControl
Background color of the grid header.
CXTPPaintManagerColor | m_clrCaptionText
Column header text color.
CXTPPaintManagerColor | m_clrCaptionTextPressed
Column header text color when pressed.
CXTPPaintManagerColor | m_clrControlBack
Background color of the control grid area.
CXTPPaintManagerColor | m_clrGroupRowText
Row text color.
CXTPPaintManagerColor | m_clrGroupShadeBack
Group row background color when indentation shade is enabled.
CXTPPaintManagerColor | m_clrGroupShadeText
Group row foreground color when indentation shade is enabled.
CXTPPaintManagerColor | m_clrGroupShadeBorder
Color for group border's shade.
CXTPPaintManagerColor | m_clrGroupBoxBack
Color of group box.
CXTPPaintManagerColor | m_clrControlDark
Dark background color of the Grid control (used on Group By area).
CXTPPaintManagerColor | m_clrControlLightLight
Light background color used for drawing shades (used on column header area).
CXTPPaintManagerColor | m_clrHotDivider
Color of the column hot divider window (two arrows).
CXTPPaintManagerColor | m_clrIndentControl
Color of the tree indentation area.
CXTPPaintManagerColor | m_clrItemShade
Color of the shade on sorted by column items.
CXTPPaintManagerColor | m_clrBtnFace
Standard button face color.
CXTPPaintManagerColor | m_clrBtnText
Standard button text color.
CXTPPaintManagerColor | m_clrPreviewText
Preview text color.
CXTPPaintManagerColor | m_clrSelectedRow
Selected row background color.
CXTPPaintManagerColor | m_clrSelectedRowText
Selected row text color.
CXTPPaintManagerColor | m_clrBtnFacePressed
Standard button face color when pressed.
CXTPPaintManagerColor | m_clrConnector
Header column connector line color.
CXTPPaintManagerColor | m_clrDisableBitmapLightest
The lightest color of bitmap which covers disabled grid.
CXTPPaintManagerColor | m_clrDisableBitmapDarkest
The darkest color of bitmap which covers disabled grid.
CXTPPaintManagerColorGradient | m_grcGradientColumn
Color of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColorGradient | m_grcGradientColumnHot
HotTracking Color of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColorGradient | m_grcGradientColumnPushed
Pushed Color of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColor | m_clrGradientColumnShadow
Bottom shadow of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColor | m_clrGradientColumnSeparator
Separator of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColor | m_crlNoGroupByText
A color for "No items" text in GroupBy area (see m_strNoGroupBy member).
CXTPPaintManagerColor | m_clrFreezeColsDivider
Freeze Columns Divider color.
COLORREF | m_clrColumnOffice2007CustomTheme
Base color for Office2007 custom theme.
COLORREF | m_clrFormulaSum
Color for Formula Sum fields.
COLORREF | m_clrFormulaSubSum
Color for Formula SubSum fields.
COLORREF | m_clrAlternativeBackground
Color for Alternative Row Background.
BOOL | m_bUseAlternativeBackground
TRUE to use Alternative Row Background, FALSE otherwise.
BOOL | m_bAllowMergeCells
TRUE to Allow Merge Cells, FALSE otherwise.
int | m_nTextIndentForGroupRowsWithNoIcon
Specifies Text indent if a group row icon is not used.
int | m_nTreeIndent
Tree indentation.
int | m_nTreeStructureStyle
Tree structure style.
int | m_nTreeTextIndentRowParent
Text indent, in pixels, for rows with children.
int | m_nTreeTextIndentRowChildren
Text indent, in pixels, for rows without children.
int | m_nTreeTextIndent
Text indent, in pixels, for rows that are neither parent nor children.
int | m_nTreeTextIndentGroupRow
Text indent, in pixels, for group rows.
BOOL | m_bGroupRowTextBold
TRUE to draw group rows with bold text.
BOOL | m_bShadeGroupHeadings
TRUE to show the indentation shade, FALSE otherwise.
BOOL | m_bShadeSortColumn
TRUE to show the items shade in the sorted by column, FALSE otherwise.
BOOL | m_bHotTracking
TRUE to allow column hot tracking.
BOOL | m_bInvertColumnOnClick
TRUE to invert column on click.
CString | m_strNoItems
A string which contains customized "No Items" text for displaying in view when there are no visible rows.
CString | m_strSortBy
A string which contains customized "Sort By" text for displaying in tooltip.
CString | m_strIncreasing
A string which contains customized "Increasing" text for displaying in tooltip.
CString | m_strDecreasing
A string which contains customized "Decreasing" text for displaying in tooltip.
CString | m_strNoGroupBy
A string which contains customized "No items" text message for displaying in Group By area when there are no items inside it.
CString | m_strNoFieldsAvailable
A string which contains customized "No Fields Available" text message for displaying in Field Chooser.
CString | m_strExpand
A string which contains customized "Expand" text for displaying in tooltip.
CString | m_strCollapse
A string which contains customized "Collapse" text for displaying in tooltip.
BOOL | m_bHideSelection
TRUE when hiding Grid control's selection by drawing selected items as others, FALSE otherwise.
BOOL | m_bPrintSortTriangle
TRUE to show the sort triangle in printout.
BOOL | m_bRevertAlignment
TRUE to revert column alignments.
BOOL | m_bUseEditTextAlignment
TRUE to automatically apply edit alignment using column alignment.
BOOL | m_bShowLockIcon
TRUE to show the lock icon, FALSE to hide.
BOOL | m_bUseShellIcon
TRUE to use the shell icon, FALSE otherwise.
int | m_iRecOrRowStart
Start position in numbering (0 or 1 or something user want).
BOOL | m_bRecOrRowNum
TRUE to display record number if support mode is used, FALSE to display row number.
BOOL | m_bMakeUpper
TRUE to display column header and group row text in all caps.
XTPGridTreeStructureStyle | m_treeStructureStyle
Tree structure style.
CRect | m_rcPreviewIndent
Preview indentation.
int | m_nFixedColumnsIndent
Fixed Column total width.
BOOL | m_bMoveScrollbarOnFixedColumnsIndent
Move Scrollbar right follow FixedColumnsIndent.
BOOL | m_bThemedInplaceButtons
Draw in-place buttons using current theme settings.
BOOL | m_bBaseTreeIndent
TRUE to add Extra Tree indentation to cover initial TreeColumn.
CUIntArray | m_arStartCol
Start column in each virtual page.
int | m_PrintPageWidth
Width of print page (run-time)
BOOL | m_bPrintVirtualPageNumber
TRUE to print horizontal page number.
BOOL | m_bPrintPageRectangle
TRUE to draw rectangle around page.
int | m_RecordNumberWidth
Column width for row/record numbers.
BOOL | m_bForceDynamicMarkupForCell
TRUE if use Markup for Grid Record Item.
BOOL | m_bForceShowDropMarker
TRUE if Force Show Drop Marker.
BOOL | m_bShowNonActiveInPlaceButton
TRUE if use Show Non-Active In-Place Button (Combo, Expand, Spin).
BOOL | m_bPrintWatermark
TRUE to print watermark.
BOOL | m_bUseGroupRowSelectionState
TRUE if use GroupSelectionState Glyph.
BOOL | m_bForceShowTooltip
TRUE if use show tooltip for any cell width case.
BOOL | m_bCleanTooltip
TRUE if use show tooltip without markup.
BOOL | m_bGrayIfDisable
TRUE is disable draw in gray (standard behavior).
int | m_nRowHeightDefault
The default row height.
BOOL | m_bCompactText
TRUE to ignore Icon for Narrow column to show more text.
BOOL | m_bUseDropMarker
FALSE to not draw drop marked when dragging/dropping, TRUE by default.
BOOL | m_bSortTriangleOffsetFromRight
Offset of sort triangle.
int | m_nTreeColumnLineLength
This is the extra line length to apply to tree column lines if there is no expand button.
int | m_nBaseParentRecordIndent
This is initial number of pixels a parent node will be indented when in a group.
- Protected Member Functions inherited from CXTPTrackPaintManager
- Protected Member Functions inherited from CXTPGridPaintManager
virtual void | DrawTextLine (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nFlag, int &nCharCounter, int &nHyperlinkCounter)
Draws a line of text with respect to the drawing rectangle.
virtual int | DrawString (int *pnCurrDrawPos, CDC *pDC, const CString &strDraw, CRect rcDraw, UINT nFormat)
Draw a simple string into rectangle.
virtual void | DrawGridPattern (CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush)
Generates a custom grid pattern if necessary.
virtual void | DrawGridPattern (CDC *pDC, CXTPBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush)
Generates a custom grid pattern if necessary.
virtual void | DrawGridPattern (CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr)
Generates a custom grid pattern.
virtual void | DrawInplaceButtonFrame (CDC *pDC, CXTPGridInplaceButton *pButton)
Draws the in-place button frame.
virtual BOOL | DrawInplaceButtonIcon (CDC *pDC, CXTPGridInplaceButton *pButton)
Draws the in-place button icon.
virtual int | CalcColumnHeight (CDC *pDC, CXTPGridColumn *pColumn, int nTotalWidth=0)
Calculates the optimal height for a specified column.
virtual void | DrawMultiLineText (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, BOOL bWordBreak=TRUE)
Draws multi-line text.
virtual void | DrawSingleLineText (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nStartPos, int nEndPos, int nActualWidth)
Draws single-line text.
virtual int | DrawLink (int *pnCurrDrawPos, XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CXTPGridHyperlink *pHyperlink, CString strText, CRect rcLink, int nFlag, BOOL bTrim=FALSE)
Draws a hyperlink string using hyperlink text settings (i.e.
- Protected Attributes inherited from CXTPGridPaintManager
int | m_nRowHeight
Grid row default height.
int | m_nHeaderHeight
Column header height.
int | m_nFooterHeight
Column footer height.
int | m_nGroupGridLineHeight
The height of the group grid line.
CXTPImageManager * | m_pGlyphs
An additional image list for the Grid control.
BOOL | m_bIsPreviewMode
TRUE to show the item preview, FALSE to hide.
int | m_nResizingWidth
The width of the column resizing marker area.
int | m_nMaxPreviewLines
Restrict maximum lines for preview text.
CSize | m_szGlyph
Glyph size.
CXTPBrush | m_xtpBrushTreeStructure
Brush to draw tree nodes.
CXTPBrush | m_xtpBrushGroupGridLineStyle
Brush to draw group row grid lines.
int | m_nFreezeColsDividerStyle
A set of flags from XTPGridFreezeColsDividerStyle.
BOOL | m_bFixedRowHeight
TRUE if fixed rows used.
BOOL | m_bColumnWidthWYSIWYG
TRUE if columns width WYSIWYG mode used.
BOOL | m_bShowWYSIWYGMarkers
TRUE if in non-print mode header show red page-end markers.
BOOL | m_bLastColumnWidthWYSIWYG
TRUE if last column width WYSIWYG mode used.
BOOL | m_bDrawGridForEmptySpace
TRUE if grid fills the empty space (if any) after the body rows.
BOOL | m_bPrintGroupRowIcon
TRUE if printout draw collapse-expand icon for group row.
BOOL | m_bColumnPlusMinusSign
TRUE if expand/collapse icons are used, FALSE if directional arrows are used.
BOOL | m_bFixedInplaceButtonHeight
TRUE if fixed in-place button height is used.
XTPGridGridStyle | m_nGroupGridLineStyle
Current style for group row grid lines.
XTPGridColumnStyle | m_columnStyle
Column drawing style.
CXTPWinThemeWrapper * | m_themeHeader
Header theme wrapper.
CXTPWinThemeWrapper * | m_themeButton
In-place button theme wrapper.
CXTPWinThemeWrapper * | m_themeCombo
Combo box in-place button theme wrapper.
CXTPWinThemeWrapper * | m_themeSpin
Spin in-place button theme wrapper.
CXTPGridControl * | m_pControl
Pointer to the Grid control object.
CXTPMarkupUIElement * | m_pMarkupUIElement_NoGroupBy
The no group by markup UI element.
CString | m_strMarkupUIElement_NoGroupBy
The no group by markup UI element string.
CXTPBrush | m_xtpBrushVeriticalGrid
Brush to draw vertical grid lines.
CXTPBrush | m_xtpBrushHorizontalGrid
Brush to draw horizontal grid lines.
XTPGridGridStyle m_nGridLineStylePreviousV
Previous style for vertical grid lines.
XTPGridGridStyle m_nGridLineStylePreviousH
Previous style for horizontal grid lines.

Detailed Description

CXTPTrackThemeNativeWindows10 is a CXTPTrackThemeOffice2013 derived class that represents a Native Windows 10 style theme.

The documentation for this class was generated from the following file:
  • XTPTrackThemeNativeWindows10.h


Toolkit Pro: CXTPTrackThemeNativeWindows11 Class Reference

Public Member Functions | List of all members
CXTPTrackThemeNativeWindows11 Class Reference

CXTPTrackThemeNativeWindows11 is a CXTPTrackThemeOffice2013 derived class that represents a Native Windows 10 style theme. More...

Inheritance diagram for CXTPTrackThemeNativeWindows11:
[legend]

Public Member Functions

CXTPTrackThemeNativeWindows11 ()
Default paint manager constructor, handles properties initialization.
virtual void | RefreshMetrics ()
This method is called to refresh the visual metrics of the track control.
- Public Member Functions inherited from CXTPTrackThemeOffice2013
CXTPTrackThemeOffice2013 ()
Default paint manager constructor, handles properties initialization.
virtual void | LoadGlyphs ()
Loads the default images used by the track control.
virtual void | DrawColumnText (CDC *pDC, CRect rcText, CString strCaption, int nHeaderAlignment, BOOL bIsHeader, BOOL bColumnPressed)
Draws text for the column header.
virtual void | DrawColumnBackground (CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, BOOL &bColumnPressed, BOOL &bDraggingFromHeader, CXTPGridHeader *pHeader=NULL)
This method is called to draw the background of a column using the current column style.
virtual void | DrawTriangle (CDC *pDC, CRect rcTriangle, BOOL bToDown, BOOL bDraggingFromHeader, int nShadowWidth, BOOL bColumnPressed)
Draws a triangle that shows the sort order of the column.
virtual void | FillGroupRowMetrics (CXTPGridGroupRow *pRow, XTP_GRIDRECORDITEM_METRICS *pMetrics, BOOL bPrinting)
Fills the font and color members of the metrics structure for a specified group row.
virtual void | DrawGroupRow (CDC *pDC, CXTPGridGroupRow *pRow, CRect rcRow, XTP_GRIDRECORDITEM_METRICS *pMetrics)
Draws a group row.
virtual void | DrawFocusedRow (CDC *pDC, CRect rcRow)
Draws focused rows.
virtual int | GetRowHeight (CDC *pDC, CXTPGridRow *pRow)
Retrieves the default row height for print mode (i.e.
- Public Member Functions inherited from CXTPTrackPaintManager
CXTPTrackPaintManager ()
Creates a CXTPTrackPaintManager object.
~CXTPTrackPaintManager ()
CXTPTrackPaintManager destructor, handles cleanup and deallocation.
virtual void | DrawTrackHeader (CDC *pDC)
Call this function to draw the track header.
virtual void | DrawMarkers (CDC *pDC)
Call this function to draw the markers.
virtual void | DrawTimeLine (CDC *pDC)
Call this function to draw the time line.
virtual CString | FormatTimeLineTick (int nPosition, COLORREF &clrTick, int &nTickLength)
Call this function to format the time and tick marker relative to a time line position.
virtual CString | FormatTime (int nPosition)
Call this function to format the time and tick marker relative to a time line position.
- Public Member Functions inherited from CXTPGridPaintManager
CXTPGridPaintManager ()
Default CXTPGridPaintManager constructor, handles properties initialization.
virtual | ~CXTPGridPaintManager ()
Default CXTPGridPaintManager destructor, handles member items deallocation.
virtual void | SetGridControl (CXTPGridControl *pControl)
Sets the associated Grid control for the paint manager.
virtual int | GetRowHeight (CDC *pDC, CXTPGridRow *pRow, int nTotalWidth)
Retrieves the default row height for print mode (i.e.
int | GetRowHeightEx (CDC *pDC, CXTPGridRow *pRow, int nTotalWidth, const BOOL firstLevel=TRUE)
Retrieves the default row height for print mode (i.e.
int | GetItemHeight (XTP_GRIDRECORDITEM_DRAWARGS &drawArgs, int nWidth)
Retrieves the height of a record item for a given width.
BOOL | FindRowAdjacentToMergedEx (const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, int &nAdjRowIndex, BOOL bUpward)
Searches the topmost or bottommost row depending on the height of the current row.
int | FindRowAdjacentToMerged (const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, BOOL bUpward)
Wrapper for the FindRowAdjacentToMergedEx method.
int | RecalcTotalHightOfMergedRows (CXTPGridColumns *pColumns, CDC *pDC, CXTPGridRow *pRow, int nRowHeight, int nTotalWidth)
Recalculates row height according to the height of merged items.
virtual int | GetPreviewItemHeight (CDC *pDC, CXTPGridRow *pRow, int nWidth, int nHeight)
Retrieves the height of a preview item for print mode.
virtual int | GetHeaderHeight ()
Gets the column header height.
virtual int | GetHeaderHeight (CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0)
Calculates the optimal header height.
virtual void | SetHeaderHeight (int nHeight)
Sets the column header height.
virtual int | GetFooterHeight (CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0)
Calculates the optimal footer height.
virtual COLORREF | GetControlBackColor (CXTPGridControl *pControl)
Retrieves the parent Grid control's background color.
virtual void | FillRow (CDC *pDC, CXTPGridRow *pRow, CRect rcRow)
Fills a specified row with its background color.
virtual void | DrawGrid (CDC *pDC, XTPGridOrientation orientation, CRect rcGrid)
Draws a grid for the control.
virtual void | DrawFreezeColsDivider (CDC *pDC, const CRect &rc, CXTPGridControl *pControl, CXTPGridRow *pRow=NULL)
Draws a freeze column divider.
virtual void | DrawVerticalTimeLineMarker (CDC *pDC, int xPos, CXTPGridControl *pControl, COLORREF color=RGB(0, 255, 0))
Draws a vertical timeline marker.
virtual void | FillIndent (CDC *pDC, CRect rcRow)
Fills an indent area by its background.
virtual void | FillItemShade (CDC *pDC, CRect rcItem)
Fills an item shade by its background if necessary.
virtual void | FillHeaderControl (CDC *pDC, CRect rcHeader)
Fills a column header control area by its background.
virtual void | FillFooter (CDC *pDC, CRect rcFooter)
Fills a column footer control area by its background.
virtual void | DrawColumn (CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn, BOOL bDrawExternal=FALSE, int nShadowWidth=0)
Draws a column header with all related attributes (sort order, icon, etc.).
virtual void | DrawColumnFooterDivider (CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn)
Draws the column footer divider.
virtual void | DrawColumnFooter (CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn)
Draws the column footer with all related attributes (e.g.
virtual BOOL | IsColumHotTrackingEnabled () const
Determines if hot tracking is enabled for the current column style.
virtual void | FillGroupByControl (CDC *pDC, CRect &rcGroupBy)
Draws the Group By box.
CXTPImageManager * | GetGlyphs () const
Gets a pointer to the additional image list with glyphs.
void | DrawHorizontalLine (CDC *pDC, int xPos, int yPos, int cx, COLORREF clr)
Draws a horizontal line.
void | DrawVerticalLine (CDC *pDC, int xPos, int yPos, int cy, COLORREF clr)
Draws a vertical line.
void | DrawConnector (CDC *pDC, CPoint ptFrom, CPoint ptTo)
Draws a column connector for the Group By box.
virtual CSize | DrawCollapsedBitmap (CDC *pDC, const CXTPGridRow *pRow, CRect &rcBitmap)
Draws a collapsed bitmap.
virtual int | DrawBitmap (CDC *pDC, CXTPGridControl *pControl, CRect rcColumn, int iImage)
Draws a bitmap.
virtual int | DrawColumnIcon (CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, CRect rcIcon, int iIcon)
Draws an icon for a column.
virtual CSize | DrawGlyph (CDC *pDC, CRect rcColumn, int iImage)
Draws the standard glyphs of the Grid control.
virtual CSize | DrawShellIcon (CDC *pDC, CRect rcColumn, int iImage)
Draws the shell icon.
void | EnablePreviewMode (BOOL bIsPreviewMode)
Enables/disables preview mode for the control.
BOOL | IsPreviewMode () const
Determines if preview mode is enabled/disabled for the control.
CFont * | GetTextFont ()
Gets the default text font used for control items.
int | SetMaxPreviewLines (int nMaxLines)
Sets the maximum number of lines of text for a preview item.
int | GetMaxPreviewLines ()
Gets the maximum number of lines of text for a preview item.
int | GetPreviewLinesCount (CDC *pDC, CRect &rcText, const CString &strText)
Calculates the number of lines required to draw a specified preview text string, taking into account the maximum number of lines of text for a preview item.
BOOL | IsGridVisible (BOOL bVertical) const
Determines the visibility of specified grid lines.
BOOL | IsGridVisible (XTPGridOrientation orientation) const
Determines the visibility of specified grid lines.
void | SetColumnStyle (XTPGridColumnStyle columnStyle)
Sets the header style.
XTPGridColumnStyle | GetColumnStyle () const
Gets the header style.
void | SetColumnOffice2007CustomThemeBaseColor (COLORREF clrBaseColor)
Sets the header's custom theme base color for Office2007 column style.
COLORREF | GetColumnOffice2007CustomThemeBaseColor () const
Gets the header's custom theme base color for Office2007 column style.
void | SetTextFont (LOGFONT &lf)
Creates and sets the default text font.
void | SetCaptionFont (LOGFONT &lf)
Creates and sets the default caption font.
void | SetPreviewIndent (int nLeft, int nTop, int nRight, int nBottom)
Sets the preview item indent.
virtual void | DrawInplaceButton (CDC *pDC, CXTPGridInplaceButton *pButton)
Draws the in-place button of the Grid control.
virtual BOOL | DrawInplaceComboButton (CDC *pDC, CRect *pRc)
Draws the combo button of the Grid control.
virtual BOOL | DrawInplaceExpandButton (CDC *pDC, CRect *pRc)
Draws the expand button of the Grid control.
virtual BOOL | DrawInplaceSpinButton (CDC *pDC, CRect *pRc)
Draws the spin button of the Grid control.
virtual void | DrawTreeStructure (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CRect rcItem, CSize sizeGlyph)
Draws tree elements of the Grid control.
virtual void | DrawItemBitmap (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CRect &rcItem, int nImage)
Draws an item bitmap.
virtual void | DrawItemCaption (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics)
Draws an item caption.
virtual void | DrawRowNumber (CDC *pDC, CRect rcNumber, CXTPGridRow *pRow)
Draws a row number.
virtual void | DrawItemControl (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CXTPGridRecordItemControl *pControl, CRect &rcItem)
Draws an item control.
BOOL | IsFixedRowHeight () const
Determines if the paint manager supports fixed or variable row height.
void | SetFixedRowHeight (BOOL bFixedRowHeight)
Sets if the paint manager supports fixed or variable row height.
BOOL | IsColumnWidthWYSIWYG () const
Determines if the paint manager supports column width WYSIWYG mode.
BOOL | IsLastColumnWidthWYSIWYG () const
Determines if the paint manager supports last column width WYSIWYG mode.
BOOL | IsShowWYSIWYGMarkers () const
Determines if the paint manager shows WYSIWYG page-end markers.
void | ShowWYSIWYGMarkers (BOOL bSet)
Sets if the paint manager shows WYSIWYG page-end markers.
void | SetColumnWidthWYSIWYG (BOOL bColumnWidthWYSIWYG)
Sets if the paint manager supports column width WYSIWYG mode.
void | SetLastColumnWidthWYSIWYG (BOOL bColumnWidthWYSIWYG)
Sets if the paint manager supports last column width WYSIWYG mode.
BOOL | IsFixedInplaceButtonHeight () const
Determines if the paint manager supports fixed or variable in-place button height.
void | SetInplaceButtonHeight (BOOL bFixedInplaceButtonHeight)
Sets if the paint manager supports fixed or variable in-place button height.
int | GetFreezeColsDividerStyle () const
Gets the style of the freeze columns divider line.
void | SetFreezeColsDividerStyle (int nStyle)
Sets the style for the freeze columns divider line.
virtual BOOL | OnDrawAction (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs)
Override this method to perform custom activities for the item before processing it.
virtual void | DrawNoGroupByText (CDC *pDC, CRect rcItem)
Draws the "No items" text message in the Group By area when there are no items inside it.
BOOL | IsDrawGridForEmptySpace () const
Determines if the grid fills empty space after body rows.
void | SetDrawGridForEmptySpace (BOOL bDrawGrid)
Sets if the grid fills empty space after body rows.
BOOL | IsPrintGroupRowIcon () const
Determines if the group row collapse-expand icon is drawn in print mode.
void | SetPrintGroupRowIcon (BOOL bDraw)
Sets if the group row collapse-expand icon is drawn in print mode.
BOOL | IsColumnPlusMinusSign () const
Determines if columns use expand/collapse icons (+/-) or directional arrows.
void | SetColumnPlusMinusSign (BOOL bDraw)
Specifies if columns use expand/collapse icons (+/-) or directional arrows.
virtual int | CalculateRowHeight (CDC *pDC, const CString &strText, int nMaxWidth, BOOL bWordBreak=TRUE)
Calculates the height required for a rectangle bounding multi-line text to draw the multi-line text when the width of the rectangle is fixed.
void | DrawSectionDivider (CDC *pDC, const CRect &rc, XTPGridSectionDividerPosition dividerPosition, XTPGridSectionDividerStyle dividerStyle, CXTPPaintManagerColor dividerColor)
Draws the divider between grid sections (e.g.
int | GetSectionDividerHeight (XTPGridFixedRowsDividerStyle dividerStyle)
Gets the height of the section divider.
BOOL | IsUseDropMarker () const
Determines if a drop marker will be used when dragging and dropping.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPTrackThemeOffice2013
CXTPPaintManagerColor | m_clrGlyph
Header glyph color.
CXTPPaintManagerColor | m_clrGlyphHighlight
Header highlighted glyph color.
CXTPPaintManagerColor | m_clrSelectedBorder
Selected block border.
- Public Attributes inherited from CXTPTrackPaintManager
COLORREF | m_clrWorkArea
The color of the work area.
COLORREF | m_clrTrackHeader
The track header color.
COLORREF | m_clrTrackTimeArea
The track time area color.
COLORREF | m_clrTimeHeaderDarkDark
The header deep dark color.
COLORREF | m_clrTimeHeaderDark
The header dark color.
COLORREF | m_clrTimeSliderBackground
The slider background color.
COLORREF | m_clrTimeHeaderDivider
The header divider color.
COLORREF | m_clrScrollBarLight
The scrollbar light color.
COLORREF | m_clrScrollBarDark
The scrollbar dark color.
COLORREF | m_clrSelectedArea
The color of the selected area.
COLORREF | m_clrMarker
The color of the marker.
COLORREF | m_clrTimeLineTick
The color of a time line tick.
COLORREF | m_clrMarkerBorder
The color of a time line marker's border.
COLORREF | m_clrMarkerBack
The color of a time line marker's back.
COLORREF | m_clrTrackMarkerBorder
The color of a track marker's border.
COLORREF | m_clrTrackMarkerText
The color of a track marker's text.
COLORREF | m_clrTrackMarkerTextBack
The color of a track marker's text back.
COLORREF | m_clrTrackMarkerTextBorder
The color of a track marker's text border.
COLORREF | m_clrTimeLinePosition
The color of a marked position on a time line.
COLORREF | m_clrTimeHeaderBorder
The color of a time line header's border.
COLORREF | m_clrScrollBarBorderDark
The scrollbar border dark color.
COLORREF | m_clrScrollBarBorderLight
The scrollbar border light color.
COLORREF | m_clrWorkAreaScrollBarLight
The workarea scrollbar light color.
COLORREF | m_clrWorkAreaScrollBarDark
The workarea scrollbar dark color.
COLORREF | m_clrWorkAreaScrollBarBorder
The workarea scrollbar border color.
- Public Attributes inherited from CXTPGridPaintManager
CXTPFont | m_xtpFontText
Grid items default text.
CXTPFont | m_xtpFontBoldText
Grid items default bold text.
CXTPFont | m_xtpFontCaption
Column header caption font.
CXTPFont | m_xtpFontPreview
Column header caption font.
CXTPGridHyperlinkStyle * | m_pHyperlinkStyle
Style for links.
CXTPGridHyperlinkStyle * | m_pHyperlinkHoverStyle
Style for hovered links.
CXTPPaintManagerColor | m_clrHighlight
Background color of the highlighted row.
CXTPPaintManagerColor | m_clrBoldText
Grid items bold text color.
CXTPPaintManagerColor | m_clrBoldTextHighlight
Grid items bold text highlight color.
CXTPPaintManagerColor | m_clrWindowText
Grid items default text color.
CXTPPaintManagerColor | m_clrHighlightText
Text color of the highlighted text.
CXTPPaintManagerColor | m_clrHeaderControl
Background color of the grid header.
CXTPPaintManagerColor | m_clrCaptionText
Column header text color.
CXTPPaintManagerColor | m_clrCaptionTextPressed
Column header text color when pressed.
CXTPPaintManagerColor | m_clrControlBack
Background color of the control grid area.
CXTPPaintManagerColor | m_clrGroupRowText
Row text color.
CXTPPaintManagerColor | m_clrGroupShadeBack
Group row background color when indentation shade is enabled.
CXTPPaintManagerColor | m_clrGroupShadeText
Group row foreground color when indentation shade is enabled.
CXTPPaintManagerColor | m_clrGroupShadeBorder
Color for group border's shade.
CXTPPaintManagerColor | m_clrGroupBoxBack
Color of group box.
CXTPPaintManagerColor | m_clrControlDark
Dark background color of the Grid control (used on Group By area).
CXTPPaintManagerColor | m_clrControlLightLight
Light background color used for drawing shades (used on column header area).
CXTPPaintManagerColor | m_clrHotDivider
Color of the column hot divider window (two arrows).
CXTPPaintManagerColor | m_clrIndentControl
Color of the tree indentation area.
CXTPPaintManagerColor | m_clrItemShade
Color of the shade on sorted by column items.
CXTPPaintManagerColor | m_clrBtnFace
Standard button face color.
CXTPPaintManagerColor | m_clrBtnText
Standard button text color.
CXTPPaintManagerColor | m_clrPreviewText
Preview text color.
CXTPPaintManagerColor | m_clrSelectedRow
Selected row background color.
CXTPPaintManagerColor | m_clrSelectedRowText
Selected row text color.
CXTPPaintManagerColor | m_clrBtnFacePressed
Standard button face color when pressed.
CXTPPaintManagerColor | m_clrConnector
Header column connector line color.
CXTPPaintManagerColor | m_clrDisableBitmapLightest
The lightest color of bitmap which covers disabled grid.
CXTPPaintManagerColor | m_clrDisableBitmapDarkest
The darkest color of bitmap which covers disabled grid.
CXTPPaintManagerColorGradient | m_grcGradientColumn
Color of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColorGradient | m_grcGradientColumnHot
HotTracking Color of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColorGradient | m_grcGradientColumnPushed
Pushed Color of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColor | m_clrGradientColumnShadow
Bottom shadow of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColor | m_clrGradientColumnSeparator
Separator of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColor | m_crlNoGroupByText
A color for "No items" text in GroupBy area (see m_strNoGroupBy member).
CXTPPaintManagerColor | m_clrFreezeColsDivider
Freeze Columns Divider color.
COLORREF | m_clrColumnOffice2007CustomTheme
Base color for Office2007 custom theme.
COLORREF | m_clrFormulaSum
Color for Formula Sum fields.
COLORREF | m_clrFormulaSubSum
Color for Formula SubSum fields.
COLORREF | m_clrAlternativeBackground
Color for Alternative Row Background.
BOOL | m_bUseAlternativeBackground
TRUE to use Alternative Row Background, FALSE otherwise.
BOOL | m_bAllowMergeCells
TRUE to Allow Merge Cells, FALSE otherwise.
int | m_nTextIndentForGroupRowsWithNoIcon
Specifies Text indent if a group row icon is not used.
int | m_nTreeIndent
Tree indentation.
int | m_nTreeStructureStyle
Tree structure style.
int | m_nTreeTextIndentRowParent
Text indent, in pixels, for rows with children.
int | m_nTreeTextIndentRowChildren
Text indent, in pixels, for rows without children.
int | m_nTreeTextIndent
Text indent, in pixels, for rows that are neither parent nor children.
int | m_nTreeTextIndentGroupRow
Text indent, in pixels, for group rows.
BOOL | m_bGroupRowTextBold
TRUE to draw group rows with bold text.
BOOL | m_bShadeGroupHeadings
TRUE to show the indentation shade, FALSE otherwise.
BOOL | m_bShadeSortColumn
TRUE to show the items shade in the sorted by column, FALSE otherwise.
BOOL | m_bHotTracking
TRUE to allow column hot tracking.
BOOL | m_bInvertColumnOnClick
TRUE to invert column on click.
CString | m_strNoItems
A string which contains customized "No Items" text for displaying in view when there are no visible rows.
CString | m_strSortBy
A string which contains customized "Sort By" text for displaying in tooltip.
CString | m_strIncreasing
A string which contains customized "Increasing" text for displaying in tooltip.
CString | m_strDecreasing
A string which contains customized "Decreasing" text for displaying in tooltip.
CString | m_strNoGroupBy
A string which contains customized "No items" text message for displaying in Group By area when there are no items inside it.
CString | m_strNoFieldsAvailable
A string which contains customized "No Fields Available" text message for displaying in Field Chooser.
CString | m_strExpand
A string which contains customized "Expand" text for displaying in tooltip.
CString | m_strCollapse
A string which contains customized "Collapse" text for displaying in tooltip.
BOOL | m_bHideSelection
TRUE when hiding Grid control's selection by drawing selected items as others, FALSE otherwise.
BOOL | m_bPrintSortTriangle
TRUE to show the sort triangle in printout.
BOOL | m_bRevertAlignment
TRUE to revert column alignments.
BOOL | m_bUseEditTextAlignment
TRUE to automatically apply edit alignment using column alignment.
BOOL | m_bShowLockIcon
TRUE to show the lock icon, FALSE to hide.
BOOL | m_bUseShellIcon
TRUE to use the shell icon, FALSE otherwise.
int | m_iRecOrRowStart
Start position in numbering (0 or 1 or something user want).
BOOL | m_bRecOrRowNum
TRUE to display record number if support mode is used, FALSE to display row number.
BOOL | m_bMakeUpper
TRUE to display column header and group row text in all caps.
XTPGridTreeStructureStyle | m_treeStructureStyle
Tree structure style.
CRect | m_rcPreviewIndent
Preview indentation.
int | m_nFixedColumnsIndent
Fixed Column total width.
BOOL | m_bMoveScrollbarOnFixedColumnsIndent
Move Scrollbar right follow FixedColumnsIndent.
BOOL | m_bThemedInplaceButtons
Draw in-place buttons using current theme settings.
BOOL | m_bBaseTreeIndent
TRUE to add Extra Tree indentation to cover initial TreeColumn.
CUIntArray | m_arStartCol
Start column in each virtual page.
int | m_PrintPageWidth
Width of print page (run-time)
BOOL | m_bPrintVirtualPageNumber
TRUE to print horizontal page number.
BOOL | m_bPrintPageRectangle
TRUE to draw rectangle around page.
int | m_RecordNumberWidth
Column width for row/record numbers.
BOOL | m_bForceDynamicMarkupForCell
TRUE if use Markup for Grid Record Item.
BOOL | m_bForceShowDropMarker
TRUE if Force Show Drop Marker.
BOOL | m_bShowNonActiveInPlaceButton
TRUE if use Show Non-Active In-Place Button (Combo, Expand, Spin).
BOOL | m_bPrintWatermark
TRUE to print watermark.
BOOL | m_bUseGroupRowSelectionState
TRUE if use GroupSelectionState Glyph.
BOOL | m_bForceShowTooltip
TRUE if use show tooltip for any cell width case.
BOOL | m_bCleanTooltip
TRUE if use show tooltip without markup.
BOOL | m_bGrayIfDisable
TRUE is disable draw in gray (standard behavior).
int | m_nRowHeightDefault
The default row height.
BOOL | m_bCompactText
TRUE to ignore Icon for Narrow column to show more text.
BOOL | m_bUseDropMarker
FALSE to not draw drop marked when dragging/dropping, TRUE by default.
BOOL | m_bSortTriangleOffsetFromRight
Offset of sort triangle.
int | m_nTreeColumnLineLength
This is the extra line length to apply to tree column lines if there is no expand button.
int | m_nBaseParentRecordIndent
This is initial number of pixels a parent node will be indented when in a group.
- Protected Member Functions inherited from CXTPTrackPaintManager
- Protected Member Functions inherited from CXTPGridPaintManager
virtual void | DrawTextLine (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nFlag, int &nCharCounter, int &nHyperlinkCounter)
Draws a line of text with respect to the drawing rectangle.
virtual int | DrawString (int *pnCurrDrawPos, CDC *pDC, const CString &strDraw, CRect rcDraw, UINT nFormat)
Draw a simple string into rectangle.
virtual void | DrawGridPattern (CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush)
Generates a custom grid pattern if necessary.
virtual void | DrawGridPattern (CDC *pDC, CXTPBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush)
Generates a custom grid pattern if necessary.
virtual void | DrawGridPattern (CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr)
Generates a custom grid pattern.
virtual void | DrawInplaceButtonFrame (CDC *pDC, CXTPGridInplaceButton *pButton)
Draws the in-place button frame.
virtual BOOL | DrawInplaceButtonIcon (CDC *pDC, CXTPGridInplaceButton *pButton)
Draws the in-place button icon.
virtual int | CalcColumnHeight (CDC *pDC, CXTPGridColumn *pColumn, int nTotalWidth=0)
Calculates the optimal height for a specified column.
virtual void | DrawMultiLineText (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, BOOL bWordBreak=TRUE)
Draws multi-line text.
virtual void | DrawSingleLineText (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nStartPos, int nEndPos, int nActualWidth)
Draws single-line text.
virtual int | DrawLink (int *pnCurrDrawPos, XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CXTPGridHyperlink *pHyperlink, CString strText, CRect rcLink, int nFlag, BOOL bTrim=FALSE)
Draws a hyperlink string using hyperlink text settings (i.e.
- Protected Attributes inherited from CXTPGridPaintManager
int | m_nRowHeight
Grid row default height.
int | m_nHeaderHeight
Column header height.
int | m_nFooterHeight
Column footer height.
int | m_nGroupGridLineHeight
The height of the group grid line.
CXTPImageManager * | m_pGlyphs
An additional image list for the Grid control.
BOOL | m_bIsPreviewMode
TRUE to show the item preview, FALSE to hide.
int | m_nResizingWidth
The width of the column resizing marker area.
int | m_nMaxPreviewLines
Restrict maximum lines for preview text.
CSize | m_szGlyph
Glyph size.
CXTPBrush | m_xtpBrushTreeStructure
Brush to draw tree nodes.
CXTPBrush | m_xtpBrushGroupGridLineStyle
Brush to draw group row grid lines.
int | m_nFreezeColsDividerStyle
A set of flags from XTPGridFreezeColsDividerStyle.
BOOL | m_bFixedRowHeight
TRUE if fixed rows used.
BOOL | m_bColumnWidthWYSIWYG
TRUE if columns width WYSIWYG mode used.
BOOL | m_bShowWYSIWYGMarkers
TRUE if in non-print mode header show red page-end markers.
BOOL | m_bLastColumnWidthWYSIWYG
TRUE if last column width WYSIWYG mode used.
BOOL | m_bDrawGridForEmptySpace
TRUE if grid fills the empty space (if any) after the body rows.
BOOL | m_bPrintGroupRowIcon
TRUE if printout draw collapse-expand icon for group row.
BOOL | m_bColumnPlusMinusSign
TRUE if expand/collapse icons are used, FALSE if directional arrows are used.
BOOL | m_bFixedInplaceButtonHeight
TRUE if fixed in-place button height is used.
XTPGridGridStyle | m_nGroupGridLineStyle
Current style for group row grid lines.
XTPGridColumnStyle | m_columnStyle
Column drawing style.
CXTPWinThemeWrapper * | m_themeHeader
Header theme wrapper.
CXTPWinThemeWrapper * | m_themeButton
In-place button theme wrapper.
CXTPWinThemeWrapper * | m_themeCombo
Combo box in-place button theme wrapper.
CXTPWinThemeWrapper * | m_themeSpin
Spin in-place button theme wrapper.
CXTPGridControl * | m_pControl
Pointer to the Grid control object.
CXTPMarkupUIElement * | m_pMarkupUIElement_NoGroupBy
The no group by markup UI element.
CString | m_strMarkupUIElement_NoGroupBy
The no group by markup UI element string.
CXTPBrush | m_xtpBrushVeriticalGrid
Brush to draw vertical grid lines.
CXTPBrush | m_xtpBrushHorizontalGrid
Brush to draw horizontal grid lines.
XTPGridGridStyle m_nGridLineStylePreviousV
Previous style for vertical grid lines.
XTPGridGridStyle m_nGridLineStylePreviousH
Previous style for horizontal grid lines.

Detailed Description

CXTPTrackThemeNativeWindows11 is a CXTPTrackThemeOffice2013 derived class that represents a Native Windows 10 style theme.

The documentation for this class was generated from the following file:
  • XTPTrackThemeNativeWindows11.h


Toolkit Pro: CXTPTrackThemeOffice2003 Class Reference

Public Member Functions | List of all members
CXTPTrackThemeOffice2003 Class Reference

CXTPTrackThemeOffice2003 is a CXTPTrackPaintManager derived class that represents an Office 2003 style theme. More...

Inheritance diagram for CXTPTrackThemeOffice2003:
[legend]

Public Member Functions

CXTPTrackThemeOffice2003 ()
Default paint manager constructor, handles properties initialization.
virtual void | DrawColumnBackground (CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, BOOL &bColumnPressed, BOOL &bDraggingFromHeader, CXTPGridHeader *pHeader=NULL)
This method is called to draw the background of a column using the current column style.
virtual void | DrawColumn (CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn, BOOL bDrawExternal=FALSE, int nShadowWidth=0)
Draws a column header with all related attributes (sort order, icon, etc.).
void | DrawSectionDivider (CDC *pDC, const CRect &rc, XTPGridSectionDividerPosition dividerPosition, XTPGridSectionDividerStyle dividerStyle, CXTPPaintManagerColor dividerColor)
Draws the divider between grid sections (e.g.
- Public Member Functions inherited from CXTPTrackPaintManager
CXTPTrackPaintManager ()
Creates a CXTPTrackPaintManager object.
~CXTPTrackPaintManager ()
CXTPTrackPaintManager destructor, handles cleanup and deallocation.
void | RefreshMetrics ()
Initializes all drawings defaults (fonts, colors, etc.).
virtual void | DrawTrackHeader (CDC *pDC)
Call this function to draw the track header.
virtual void | DrawMarkers (CDC *pDC)
Call this function to draw the markers.
virtual void | DrawTimeLine (CDC *pDC)
Call this function to draw the time line.
virtual CString | FormatTimeLineTick (int nPosition, COLORREF &clrTick, int &nTickLength)
Call this function to format the time and tick marker relative to a time line position.
virtual CString | FormatTime (int nPosition)
Call this function to format the time and tick marker relative to a time line position.
- Public Member Functions inherited from CXTPGridPaintManager
CXTPGridPaintManager ()
Default CXTPGridPaintManager constructor, handles properties initialization.
virtual | ~CXTPGridPaintManager ()
Default CXTPGridPaintManager destructor, handles member items deallocation.
virtual void | SetGridControl (CXTPGridControl *pControl)
Sets the associated Grid control for the paint manager.
virtual void | LoadGlyphs ()
Loads the default images used by the Grid control.
virtual int | GetRowHeight (CDC *pDC, CXTPGridRow *pRow)
Retrieves the default row height for print mode (i.e.
virtual int | GetRowHeight (CDC *pDC, CXTPGridRow *pRow, int nTotalWidth)
Retrieves the default row height for print mode (i.e.
int | GetRowHeightEx (CDC *pDC, CXTPGridRow *pRow, int nTotalWidth, const BOOL firstLevel=TRUE)
Retrieves the default row height for print mode (i.e.
int | GetItemHeight (XTP_GRIDRECORDITEM_DRAWARGS &drawArgs, int nWidth)
Retrieves the height of a record item for a given width.
BOOL | FindRowAdjacentToMergedEx (const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, int &nAdjRowIndex, BOOL bUpward)
Searches the topmost or bottommost row depending on the height of the current row.
int | FindRowAdjacentToMerged (const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, BOOL bUpward)
Wrapper for the FindRowAdjacentToMergedEx method.
int | RecalcTotalHightOfMergedRows (CXTPGridColumns *pColumns, CDC *pDC, CXTPGridRow *pRow, int nRowHeight, int nTotalWidth)
Recalculates row height according to the height of merged items.
virtual int | GetPreviewItemHeight (CDC *pDC, CXTPGridRow *pRow, int nWidth, int nHeight)
Retrieves the height of a preview item for print mode.
virtual int | GetHeaderHeight ()
Gets the column header height.
virtual int | GetHeaderHeight (CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0)
Calculates the optimal header height.
virtual void | SetHeaderHeight (int nHeight)
Sets the column header height.
virtual int | GetFooterHeight (CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0)
Calculates the optimal footer height.
virtual COLORREF | GetControlBackColor (CXTPGridControl *pControl)
Retrieves the parent Grid control's background color.
virtual void | FillRow (CDC *pDC, CXTPGridRow *pRow, CRect rcRow)
Fills a specified row with its background color.
virtual void | DrawGrid (CDC *pDC, XTPGridOrientation orientation, CRect rcGrid)
Draws a grid for the control.
virtual void | DrawFreezeColsDivider (CDC *pDC, const CRect &rc, CXTPGridControl *pControl, CXTPGridRow *pRow=NULL)
Draws a freeze column divider.
virtual void | DrawVerticalTimeLineMarker (CDC *pDC, int xPos, CXTPGridControl *pControl, COLORREF color=RGB(0, 255, 0))
Draws a vertical timeline marker.
virtual void | DrawGroupRow (CDC *pDC, CXTPGridGroupRow *pRow, CRect rcRow, XTP_GRIDRECORDITEM_METRICS *pMetrics)
Draws a group row.
virtual void | FillGroupRowMetrics (CXTPGridGroupRow *pRow, XTP_GRIDRECORDITEM_METRICS *pMetrics, BOOL bPrinting)
Fills the font and color members of the metrics structure for a specified group row.
virtual void | FillIndent (CDC *pDC, CRect rcRow)
Fills an indent area by its background.
virtual void | FillItemShade (CDC *pDC, CRect rcItem)
Fills an item shade by its background if necessary.
virtual void | FillHeaderControl (CDC *pDC, CRect rcHeader)
Fills a column header control area by its background.
virtual void | FillFooter (CDC *pDC, CRect rcFooter)
Fills a column footer control area by its background.
virtual void | DrawColumnText (CDC *pDC, CRect rcText, CString strCaption, int nHeaderAlignment, BOOL bIsHeader, BOOL bColumnPressed)
Draws text for the column header.
virtual void | DrawColumnFooterDivider (CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn)
Draws the column footer divider.
virtual void | DrawColumnFooter (CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn)
Draws the column footer with all related attributes (e.g.
virtual BOOL | IsColumHotTrackingEnabled () const
Determines if hot tracking is enabled for the current column style.
virtual void | DrawFocusedRow (CDC *pDC, CRect rcRow)
Draws focused rows.
virtual void | FillGroupByControl (CDC *pDC, CRect &rcGroupBy)
Draws the Group By box.
CXTPImageManager * | GetGlyphs () const
Gets a pointer to the additional image list with glyphs.
void | DrawHorizontalLine (CDC *pDC, int xPos, int yPos, int cx, COLORREF clr)
Draws a horizontal line.
void | DrawVerticalLine (CDC *pDC, int xPos, int yPos, int cy, COLORREF clr)
Draws a vertical line.
virtual void | DrawTriangle (CDC *pDC, CRect rcTriangle, BOOL bToDown, BOOL bDraggingFromHeader, int nShadowWidth, BOOL bColumnPressed)
Draws a triangle that shows the sort order of the column.
void | DrawConnector (CDC *pDC, CPoint ptFrom, CPoint ptTo)
Draws a column connector for the Group By box.
virtual CSize | DrawCollapsedBitmap (CDC *pDC, const CXTPGridRow *pRow, CRect &rcBitmap)
Draws a collapsed bitmap.
virtual int | DrawBitmap (CDC *pDC, CXTPGridControl *pControl, CRect rcColumn, int iImage)
Draws a bitmap.
virtual int | DrawColumnIcon (CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, CRect rcIcon, int iIcon)
Draws an icon for a column.
virtual CSize | DrawGlyph (CDC *pDC, CRect rcColumn, int iImage)
Draws the standard glyphs of the Grid control.
virtual CSize | DrawShellIcon (CDC *pDC, CRect rcColumn, int iImage)
Draws the shell icon.
void | EnablePreviewMode (BOOL bIsPreviewMode)
Enables/disables preview mode for the control.
BOOL | IsPreviewMode () const
Determines if preview mode is enabled/disabled for the control.
CFont * | GetTextFont ()
Gets the default text font used for control items.
int | SetMaxPreviewLines (int nMaxLines)
Sets the maximum number of lines of text for a preview item.
int | GetMaxPreviewLines ()
Gets the maximum number of lines of text for a preview item.
int | GetPreviewLinesCount (CDC *pDC, CRect &rcText, const CString &strText)
Calculates the number of lines required to draw a specified preview text string, taking into account the maximum number of lines of text for a preview item.
BOOL | IsGridVisible (BOOL bVertical) const
Determines the visibility of specified grid lines.
BOOL | IsGridVisible (XTPGridOrientation orientation) const
Determines the visibility of specified grid lines.
void | SetColumnStyle (XTPGridColumnStyle columnStyle)
Sets the header style.
XTPGridColumnStyle | GetColumnStyle () const
Gets the header style.
void | SetColumnOffice2007CustomThemeBaseColor (COLORREF clrBaseColor)
Sets the header's custom theme base color for Office2007 column style.
COLORREF | GetColumnOffice2007CustomThemeBaseColor () const
Gets the header's custom theme base color for Office2007 column style.
void | SetTextFont (LOGFONT &lf)
Creates and sets the default text font.
void | SetCaptionFont (LOGFONT &lf)
Creates and sets the default caption font.
void | SetPreviewIndent (int nLeft, int nTop, int nRight, int nBottom)
Sets the preview item indent.
virtual void | DrawInplaceButton (CDC *pDC, CXTPGridInplaceButton *pButton)
Draws the in-place button of the Grid control.
virtual BOOL | DrawInplaceComboButton (CDC *pDC, CRect *pRc)
Draws the combo button of the Grid control.
virtual BOOL | DrawInplaceExpandButton (CDC *pDC, CRect *pRc)
Draws the expand button of the Grid control.
virtual BOOL | DrawInplaceSpinButton (CDC *pDC, CRect *pRc)
Draws the spin button of the Grid control.
virtual void | DrawTreeStructure (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CRect rcItem, CSize sizeGlyph)
Draws tree elements of the Grid control.
virtual void | DrawItemBitmap (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CRect &rcItem, int nImage)
Draws an item bitmap.
virtual void | DrawItemCaption (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics)
Draws an item caption.
virtual void | DrawRowNumber (CDC *pDC, CRect rcNumber, CXTPGridRow *pRow)
Draws a row number.
virtual void | DrawItemControl (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CXTPGridRecordItemControl *pControl, CRect &rcItem)
Draws an item control.
BOOL | IsFixedRowHeight () const
Determines if the paint manager supports fixed or variable row height.
void | SetFixedRowHeight (BOOL bFixedRowHeight)
Sets if the paint manager supports fixed or variable row height.
BOOL | IsColumnWidthWYSIWYG () const
Determines if the paint manager supports column width WYSIWYG mode.
BOOL | IsLastColumnWidthWYSIWYG () const
Determines if the paint manager supports last column width WYSIWYG mode.
BOOL | IsShowWYSIWYGMarkers () const
Determines if the paint manager shows WYSIWYG page-end markers.
void | ShowWYSIWYGMarkers (BOOL bSet)
Sets if the paint manager shows WYSIWYG page-end markers.
void | SetColumnWidthWYSIWYG (BOOL bColumnWidthWYSIWYG)
Sets if the paint manager supports column width WYSIWYG mode.
void | SetLastColumnWidthWYSIWYG (BOOL bColumnWidthWYSIWYG)
Sets if the paint manager supports last column width WYSIWYG mode.
BOOL | IsFixedInplaceButtonHeight () const
Determines if the paint manager supports fixed or variable in-place button height.
void | SetInplaceButtonHeight (BOOL bFixedInplaceButtonHeight)
Sets if the paint manager supports fixed or variable in-place button height.
int | GetFreezeColsDividerStyle () const
Gets the style of the freeze columns divider line.
void | SetFreezeColsDividerStyle (int nStyle)
Sets the style for the freeze columns divider line.
virtual BOOL | OnDrawAction (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs)
Override this method to perform custom activities for the item before processing it.
virtual void | DrawNoGroupByText (CDC *pDC, CRect rcItem)
Draws the "No items" text message in the Group By area when there are no items inside it.
BOOL | IsDrawGridForEmptySpace () const
Determines if the grid fills empty space after body rows.
void | SetDrawGridForEmptySpace (BOOL bDrawGrid)
Sets if the grid fills empty space after body rows.
BOOL | IsPrintGroupRowIcon () const
Determines if the group row collapse-expand icon is drawn in print mode.
void | SetPrintGroupRowIcon (BOOL bDraw)
Sets if the group row collapse-expand icon is drawn in print mode.
BOOL | IsColumnPlusMinusSign () const
Determines if columns use expand/collapse icons (+/-) or directional arrows.
void | SetColumnPlusMinusSign (BOOL bDraw)
Specifies if columns use expand/collapse icons (+/-) or directional arrows.
virtual int | CalculateRowHeight (CDC *pDC, const CString &strText, int nMaxWidth, BOOL bWordBreak=TRUE)
Calculates the height required for a rectangle bounding multi-line text to draw the multi-line text when the width of the rectangle is fixed.
void | DrawSectionDivider (CDC *pDC, const CRect &rc, XTPGridSectionDividerPosition dividerPosition, XTPGridSectionDividerStyle dividerStyle, CXTPPaintManagerColor dividerColor)
Draws the divider between grid sections (e.g.
int | GetSectionDividerHeight (XTPGridFixedRowsDividerStyle dividerStyle)
Gets the height of the section divider.
BOOL | IsUseDropMarker () const
Determines if a drop marker will be used when dragging and dropping.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPTrackPaintManager
COLORREF | m_clrWorkArea
The color of the work area.
COLORREF | m_clrTrackHeader
The track header color.
COLORREF | m_clrTrackTimeArea
The track time area color.
COLORREF | m_clrTimeHeaderDarkDark
The header deep dark color.
COLORREF | m_clrTimeHeaderDark
The header dark color.
COLORREF | m_clrTimeSliderBackground
The slider background color.
COLORREF | m_clrTimeHeaderDivider
The header divider color.
COLORREF | m_clrScrollBarLight
The scrollbar light color.
COLORREF | m_clrScrollBarDark
The scrollbar dark color.
COLORREF | m_clrSelectedArea
The color of the selected area.
COLORREF | m_clrMarker
The color of the marker.
COLORREF | m_clrTimeLineTick
The color of a time line tick.
COLORREF | m_clrMarkerBorder
The color of a time line marker's border.
COLORREF | m_clrMarkerBack
The color of a time line marker's back.
COLORREF | m_clrTrackMarkerBorder
The color of a track marker's border.
COLORREF | m_clrTrackMarkerText
The color of a track marker's text.
COLORREF | m_clrTrackMarkerTextBack
The color of a track marker's text back.
COLORREF | m_clrTrackMarkerTextBorder
The color of a track marker's text border.
COLORREF | m_clrTimeLinePosition
The color of a marked position on a time line.
COLORREF | m_clrTimeHeaderBorder
The color of a time line header's border.
COLORREF | m_clrScrollBarBorderDark
The scrollbar border dark color.
COLORREF | m_clrScrollBarBorderLight
The scrollbar border light color.
COLORREF | m_clrWorkAreaScrollBarLight
The workarea scrollbar light color.
COLORREF | m_clrWorkAreaScrollBarDark
The workarea scrollbar dark color.
COLORREF | m_clrWorkAreaScrollBarBorder
The workarea scrollbar border color.
- Public Attributes inherited from CXTPGridPaintManager
CXTPFont | m_xtpFontText
Grid items default text.
CXTPFont | m_xtpFontBoldText
Grid items default bold text.
CXTPFont | m_xtpFontCaption
Column header caption font.
CXTPFont | m_xtpFontPreview
Column header caption font.
CXTPGridHyperlinkStyle * | m_pHyperlinkStyle
Style for links.
CXTPGridHyperlinkStyle * | m_pHyperlinkHoverStyle
Style for hovered links.
CXTPPaintManagerColor | m_clrHighlight
Background color of the highlighted row.
CXTPPaintManagerColor | m_clrBoldText
Grid items bold text color.
CXTPPaintManagerColor | m_clrBoldTextHighlight
Grid items bold text highlight color.
CXTPPaintManagerColor | m_clrWindowText
Grid items default text color.
CXTPPaintManagerColor | m_clrHighlightText
Text color of the highlighted text.
CXTPPaintManagerColor | m_clrHeaderControl
Background color of the grid header.
CXTPPaintManagerColor | m_clrCaptionText
Column header text color.
CXTPPaintManagerColor | m_clrCaptionTextPressed
Column header text color when pressed.
CXTPPaintManagerColor | m_clrControlBack
Background color of the control grid area.
CXTPPaintManagerColor | m_clrGroupRowText
Row text color.
CXTPPaintManagerColor | m_clrGroupShadeBack
Group row background color when indentation shade is enabled.
CXTPPaintManagerColor | m_clrGroupShadeText
Group row foreground color when indentation shade is enabled.
CXTPPaintManagerColor | m_clrGroupShadeBorder
Color for group border's shade.
CXTPPaintManagerColor | m_clrGroupBoxBack
Color of group box.
CXTPPaintManagerColor | m_clrControlDark
Dark background color of the Grid control (used on Group By area).
CXTPPaintManagerColor | m_clrControlLightLight
Light background color used for drawing shades (used on column header area).
CXTPPaintManagerColor | m_clrHotDivider
Color of the column hot divider window (two arrows).
CXTPPaintManagerColor | m_clrIndentControl
Color of the tree indentation area.
CXTPPaintManagerColor | m_clrItemShade
Color of the shade on sorted by column items.
CXTPPaintManagerColor | m_clrBtnFace
Standard button face color.
CXTPPaintManagerColor | m_clrBtnText
Standard button text color.
CXTPPaintManagerColor | m_clrPreviewText
Preview text color.
CXTPPaintManagerColor | m_clrSelectedRow
Selected row background color.
CXTPPaintManagerColor | m_clrSelectedRowText
Selected row text color.
CXTPPaintManagerColor | m_clrBtnFacePressed
Standard button face color when pressed.
CXTPPaintManagerColor | m_clrConnector
Header column connector line color.
CXTPPaintManagerColor | m_clrDisableBitmapLightest
The lightest color of bitmap which covers disabled grid.
CXTPPaintManagerColor | m_clrDisableBitmapDarkest
The darkest color of bitmap which covers disabled grid.
CXTPPaintManagerColorGradient | m_grcGradientColumn
Color of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColorGradient | m_grcGradientColumnHot
HotTracking Color of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColorGradient | m_grcGradientColumnPushed
Pushed Color of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColor | m_clrGradientColumnShadow
Bottom shadow of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColor | m_clrGradientColumnSeparator
Separator of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColor | m_crlNoGroupByText
A color for "No items" text in GroupBy area (see m_strNoGroupBy member).
CXTPPaintManagerColor | m_clrFreezeColsDivider
Freeze Columns Divider color.
COLORREF | m_clrColumnOffice2007CustomTheme
Base color for Office2007 custom theme.
COLORREF | m_clrFormulaSum
Color for Formula Sum fields.
COLORREF | m_clrFormulaSubSum
Color for Formula SubSum fields.
COLORREF | m_clrAlternativeBackground
Color for Alternative Row Background.
BOOL | m_bUseAlternativeBackground
TRUE to use Alternative Row Background, FALSE otherwise.
BOOL | m_bAllowMergeCells
TRUE to Allow Merge Cells, FALSE otherwise.
int | m_nTextIndentForGroupRowsWithNoIcon
Specifies Text indent if a group row icon is not used.
int | m_nTreeIndent
Tree indentation.
int | m_nTreeStructureStyle
Tree structure style.
int | m_nTreeTextIndentRowParent
Text indent, in pixels, for rows with children.
int | m_nTreeTextIndentRowChildren
Text indent, in pixels, for rows without children.
int | m_nTreeTextIndent
Text indent, in pixels, for rows that are neither parent nor children.
int | m_nTreeTextIndentGroupRow
Text indent, in pixels, for group rows.
BOOL | m_bGroupRowTextBold
TRUE to draw group rows with bold text.
BOOL | m_bShadeGroupHeadings
TRUE to show the indentation shade, FALSE otherwise.
BOOL | m_bShadeSortColumn
TRUE to show the items shade in the sorted by column, FALSE otherwise.
BOOL | m_bHotTracking
TRUE to allow column hot tracking.
BOOL | m_bInvertColumnOnClick
TRUE to invert column on click.
CString | m_strNoItems
A string which contains customized "No Items" text for displaying in view when there are no visible rows.
CString | m_strSortBy
A string which contains customized "Sort By" text for displaying in tooltip.
CString | m_strIncreasing
A string which contains customized "Increasing" text for displaying in tooltip.
CString | m_strDecreasing
A string which contains customized "Decreasing" text for displaying in tooltip.
CString | m_strNoGroupBy
A string which contains customized "No items" text message for displaying in Group By area when there are no items inside it.
CString | m_strNoFieldsAvailable
A string which contains customized "No Fields Available" text message for displaying in Field Chooser.
CString | m_strExpand
A string which contains customized "Expand" text for displaying in tooltip.
CString | m_strCollapse
A string which contains customized "Collapse" text for displaying in tooltip.
BOOL | m_bHideSelection
TRUE when hiding Grid control's selection by drawing selected items as others, FALSE otherwise.
BOOL | m_bPrintSortTriangle
TRUE to show the sort triangle in printout.
BOOL | m_bRevertAlignment
TRUE to revert column alignments.
BOOL | m_bUseEditTextAlignment
TRUE to automatically apply edit alignment using column alignment.
BOOL | m_bShowLockIcon
TRUE to show the lock icon, FALSE to hide.
BOOL | m_bUseShellIcon
TRUE to use the shell icon, FALSE otherwise.
int | m_iRecOrRowStart
Start position in numbering (0 or 1 or something user want).
BOOL | m_bRecOrRowNum
TRUE to display record number if support mode is used, FALSE to display row number.
BOOL | m_bMakeUpper
TRUE to display column header and group row text in all caps.
XTPGridTreeStructureStyle | m_treeStructureStyle
Tree structure style.
CRect | m_rcPreviewIndent
Preview indentation.
int | m_nFixedColumnsIndent
Fixed Column total width.
BOOL | m_bMoveScrollbarOnFixedColumnsIndent
Move Scrollbar right follow FixedColumnsIndent.
BOOL | m_bThemedInplaceButtons
Draw in-place buttons using current theme settings.
BOOL | m_bBaseTreeIndent
TRUE to add Extra Tree indentation to cover initial TreeColumn.
CUIntArray | m_arStartCol
Start column in each virtual page.
int | m_PrintPageWidth
Width of print page (run-time)
BOOL | m_bPrintVirtualPageNumber
TRUE to print horizontal page number.
BOOL | m_bPrintPageRectangle
TRUE to draw rectangle around page.
int | m_RecordNumberWidth
Column width for row/record numbers.
BOOL | m_bForceDynamicMarkupForCell
TRUE if use Markup for Grid Record Item.
BOOL | m_bForceShowDropMarker
TRUE if Force Show Drop Marker.
BOOL | m_bShowNonActiveInPlaceButton
TRUE if use Show Non-Active In-Place Button (Combo, Expand, Spin).
BOOL | m_bPrintWatermark
TRUE to print watermark.
BOOL | m_bUseGroupRowSelectionState
TRUE if use GroupSelectionState Glyph.
BOOL | m_bForceShowTooltip
TRUE if use show tooltip for any cell width case.
BOOL | m_bCleanTooltip
TRUE if use show tooltip without markup.
BOOL | m_bGrayIfDisable
TRUE is disable draw in gray (standard behavior).
int | m_nRowHeightDefault
The default row height.
BOOL | m_bCompactText
TRUE to ignore Icon for Narrow column to show more text.
BOOL | m_bUseDropMarker
FALSE to not draw drop marked when dragging/dropping, TRUE by default.
BOOL | m_bSortTriangleOffsetFromRight
Offset of sort triangle.
int | m_nTreeColumnLineLength
This is the extra line length to apply to tree column lines if there is no expand button.
int | m_nBaseParentRecordIndent
This is initial number of pixels a parent node will be indented when in a group.
- Protected Member Functions inherited from CXTPTrackPaintManager
- Protected Member Functions inherited from CXTPGridPaintManager
virtual void | DrawTextLine (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nFlag, int &nCharCounter, int &nHyperlinkCounter)
Draws a line of text with respect to the drawing rectangle.
virtual int | DrawString (int *pnCurrDrawPos, CDC *pDC, const CString &strDraw, CRect rcDraw, UINT nFormat)
Draw a simple string into rectangle.
virtual void | DrawGridPattern (CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush)
Generates a custom grid pattern if necessary.
virtual void | DrawGridPattern (CDC *pDC, CXTPBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush)
Generates a custom grid pattern if necessary.
virtual void | DrawGridPattern (CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr)
Generates a custom grid pattern.
virtual void | DrawInplaceButtonFrame (CDC *pDC, CXTPGridInplaceButton *pButton)
Draws the in-place button frame.
virtual BOOL | DrawInplaceButtonIcon (CDC *pDC, CXTPGridInplaceButton *pButton)
Draws the in-place button icon.
virtual int | CalcColumnHeight (CDC *pDC, CXTPGridColumn *pColumn, int nTotalWidth=0)
Calculates the optimal height for a specified column.
virtual void | DrawMultiLineText (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, BOOL bWordBreak=TRUE)
Draws multi-line text.
virtual void | DrawSingleLineText (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nStartPos, int nEndPos, int nActualWidth)
Draws single-line text.
virtual int | DrawLink (int *pnCurrDrawPos, XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CXTPGridHyperlink *pHyperlink, CString strText, CRect rcLink, int nFlag, BOOL bTrim=FALSE)
Draws a hyperlink string using hyperlink text settings (i.e.
- Protected Attributes inherited from CXTPGridPaintManager
int | m_nRowHeight
Grid row default height.
int | m_nHeaderHeight
Column header height.
int | m_nFooterHeight
Column footer height.
int | m_nGroupGridLineHeight
The height of the group grid line.
CXTPImageManager * | m_pGlyphs
An additional image list for the Grid control.
BOOL | m_bIsPreviewMode
TRUE to show the item preview, FALSE to hide.
int | m_nResizingWidth
The width of the column resizing marker area.
int | m_nMaxPreviewLines
Restrict maximum lines for preview text.
CSize | m_szGlyph
Glyph size.
CXTPBrush | m_xtpBrushTreeStructure
Brush to draw tree nodes.
CXTPBrush | m_xtpBrushGroupGridLineStyle
Brush to draw group row grid lines.
int | m_nFreezeColsDividerStyle
A set of flags from XTPGridFreezeColsDividerStyle.
BOOL | m_bFixedRowHeight
TRUE if fixed rows used.
BOOL | m_bColumnWidthWYSIWYG
TRUE if columns width WYSIWYG mode used.
BOOL | m_bShowWYSIWYGMarkers
TRUE if in non-print mode header show red page-end markers.
BOOL | m_bLastColumnWidthWYSIWYG
TRUE if last column width WYSIWYG mode used.
BOOL | m_bDrawGridForEmptySpace
TRUE if grid fills the empty space (if any) after the body rows.
BOOL | m_bPrintGroupRowIcon
TRUE if printout draw collapse-expand icon for group row.
BOOL | m_bColumnPlusMinusSign
TRUE if expand/collapse icons are used, FALSE if directional arrows are used.
BOOL | m_bFixedInplaceButtonHeight
TRUE if fixed in-place button height is used.
XTPGridGridStyle | m_nGroupGridLineStyle
Current style for group row grid lines.
XTPGridColumnStyle | m_columnStyle
Column drawing style.
CXTPWinThemeWrapper * | m_themeHeader
Header theme wrapper.
CXTPWinThemeWrapper * | m_themeButton
In-place button theme wrapper.
CXTPWinThemeWrapper * | m_themeCombo
Combo box in-place button theme wrapper.
CXTPWinThemeWrapper * | m_themeSpin
Spin in-place button theme wrapper.
CXTPGridControl * | m_pControl
Pointer to the Grid control object.
CXTPMarkupUIElement * | m_pMarkupUIElement_NoGroupBy
The no group by markup UI element.
CString | m_strMarkupUIElement_NoGroupBy
The no group by markup UI element string.
CXTPBrush | m_xtpBrushVeriticalGrid
Brush to draw vertical grid lines.
CXTPBrush | m_xtpBrushHorizontalGrid
Brush to draw horizontal grid lines.
XTPGridGridStyle m_nGridLineStylePreviousV
Previous style for vertical grid lines.
XTPGridGridStyle m_nGridLineStylePreviousH
Previous style for horizontal grid lines.

Detailed Description

CXTPTrackThemeOffice2003 is a CXTPTrackPaintManager derived class that represents an Office 2003 style theme.

Member Function Documentation

◆ DrawColumn()

virtual void DrawColumn | ( | CDC * | pDC,
 |  | CXTPGridColumn * | pColumn,
 |  | CXTPGridHeader * | pHeader,
 |  | CRect | rcColumn,
 |  | BOOL | bDrawExternal = FALSE,
 |  | int | nShadowWidth = 0 )
 virtual

Draws a column header with all related attributes (sort order, icon, etc.).

Parameters
pDC | Pointer to the used device context.
pColumn | Pointer to column header area rectangle coordinates.
pHeader | Pointer to the grid header.
rcColumn | Column area rectangle coordinates.
bDrawExternal | TRUE to draw the column above the header; the default value for this parameter is FALSE.
nShadowWidth | Size in pixels for the bottom shadow; the default value for this parameter is 0.

Example:

CXTPGridPaintManager* pPaintManager = m_pControl->GetPaintManager();
CXTPGridColumn* pColumn = CXTPGridColumn* pColumn = m_pColumns->GetAt(1);
CRect rcHeader(rcClient);
int nHeaderHeight = m_pControl->GetHeaderHeight();
rcHeader.bottom = rcHeader.top + nHeaderHeight;
GetPaintManager()->DrawColumn(pDC, pColumn, this, rcHeader);

Reimplemented from CXTPGridPaintManager.

◆ DrawColumnBackground()

virtual void DrawColumnBackground | ( | CDC * | pDC,
 |  | CXTPGridColumn * | pColumn,
 |  | CRect | rcColumn,
 |  | BOOL & | bColumnPressed,
 |  | BOOL & | bDraggingFromHeader,
 |  | CXTPGridHeader * | pHeader = NULL )
 virtual

This method is called to draw the background of a column using the current column style.

Parameters
pDC | Pointer to the used device context.
pColumn | Pointer to the column whose background must be drawn.
rcColumn | Bounding rectangle of the column.
bColumnPressed | TRUE if the column is pressed by the user.
bDraggingFromHeader | TRUE if the column is being dragged from the header area.
pHeader | Pointer to the header that the column belongs to.

Reimplemented from CXTPGridPaintManager.

◆ DrawSectionDivider()

void DrawSectionDivider | ( | CDC * | pDC,
 |  | const CRect & | rc,
 |  | XTPGridSectionDividerPosition | dividerPosition,
 |  | XTPGridSectionDividerStyle | dividerStyle,
 |  | CXTPPaintManagerColor | dividerColor )

Draws the divider between grid sections (e.g.

dividing header record rows and body rows).

Parameters
pDC | Pointer to the used device context.
rc | Reference to rectangle coordinates.
dividerPosition | Position of the section divider; must be one of the values defined by the XTPGridSectionDividerPosition enumeration.
dividerStyle | Style of the section divider; must be one of the values defined by the XTPGridSectionDividerStyle enumeration.
dividerColor | Color of the section divider.
The documentation for this class was generated from the following file:
  • XTPTrackThemeOffice2003.h


Toolkit Pro: CXTPTrackThemeOffice2003Luna Class Reference

Public Member Functions | List of all members
CXTPTrackThemeOffice2003Luna Class Reference

CXTPTrackThemeOffice2003Luna is a CXTPTrackPaintManager derived class that represents an Office 2003 Luna style theme. More...

Inheritance diagram for CXTPTrackThemeOffice2003Luna:
[legend]

Public Member Functions

CXTPTrackThemeOffice2003Luna ()
Default paint manager constructor, handles properties initialization.
virtual void | RefreshMetrics ()
This method is called to refresh the visual metrics of the track control.
virtual void | FillFooter (CDC *pDC, CRect rcFooter)
Fills the column footer control area by its background.
virtual BOOL | IsColumHotTrackingEnabled () const
Determines if hot tracking is enabled for the current column style.
virtual void | DrawColumnBackground (CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, BOOL &bColumnPressed, BOOL &bDraggingFromHeader, CXTPGridHeader *pHeader=NULL)
This method is called to draw the background of a column using the current column style.
virtual void | DrawColumnFooterDivider (CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn)
Draws the column footer divider.
void | DrawSectionDivider (CDC *pDC, const CRect &rc, XTPGridSectionDividerPosition dividerPosition, XTPGridSectionDividerStyle dividerStyle, CXTPPaintManagerColor dividerColor)
Draws the divider between grid sections (e.g.
- Public Member Functions inherited from CXTPTrackPaintManager
CXTPTrackPaintManager ()
Creates a CXTPTrackPaintManager object.
~CXTPTrackPaintManager ()
CXTPTrackPaintManager destructor, handles cleanup and deallocation.
virtual void | DrawTrackHeader (CDC *pDC)
Call this function to draw the track header.
virtual void | DrawMarkers (CDC *pDC)
Call this function to draw the markers.
virtual void | DrawTimeLine (CDC *pDC)
Call this function to draw the time line.
virtual CString | FormatTimeLineTick (int nPosition, COLORREF &clrTick, int &nTickLength)
Call this function to format the time and tick marker relative to a time line position.
virtual CString | FormatTime (int nPosition)
Call this function to format the time and tick marker relative to a time line position.
- Public Member Functions inherited from CXTPGridPaintManager
CXTPGridPaintManager ()
Default CXTPGridPaintManager constructor, handles properties initialization.
virtual | ~CXTPGridPaintManager ()
Default CXTPGridPaintManager destructor, handles member items deallocation.
virtual void | SetGridControl (CXTPGridControl *pControl)
Sets the associated Grid control for the paint manager.
virtual void | LoadGlyphs ()
Loads the default images used by the Grid control.
virtual int | GetRowHeight (CDC *pDC, CXTPGridRow *pRow)
Retrieves the default row height for print mode (i.e.
virtual int | GetRowHeight (CDC *pDC, CXTPGridRow *pRow, int nTotalWidth)
Retrieves the default row height for print mode (i.e.
int | GetRowHeightEx (CDC *pDC, CXTPGridRow *pRow, int nTotalWidth, const BOOL firstLevel=TRUE)
Retrieves the default row height for print mode (i.e.
int | GetItemHeight (XTP_GRIDRECORDITEM_DRAWARGS &drawArgs, int nWidth)
Retrieves the height of a record item for a given width.
BOOL | FindRowAdjacentToMergedEx (const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, int &nAdjRowIndex, BOOL bUpward)
Searches the topmost or bottommost row depending on the height of the current row.
int | FindRowAdjacentToMerged (const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, BOOL bUpward)
Wrapper for the FindRowAdjacentToMergedEx method.
int | RecalcTotalHightOfMergedRows (CXTPGridColumns *pColumns, CDC *pDC, CXTPGridRow *pRow, int nRowHeight, int nTotalWidth)
Recalculates row height according to the height of merged items.
virtual int | GetPreviewItemHeight (CDC *pDC, CXTPGridRow *pRow, int nWidth, int nHeight)
Retrieves the height of a preview item for print mode.
virtual int | GetHeaderHeight ()
Gets the column header height.
virtual int | GetHeaderHeight (CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0)
Calculates the optimal header height.
virtual void | SetHeaderHeight (int nHeight)
Sets the column header height.
virtual int | GetFooterHeight (CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0)
Calculates the optimal footer height.
virtual COLORREF | GetControlBackColor (CXTPGridControl *pControl)
Retrieves the parent Grid control's background color.
virtual void | FillRow (CDC *pDC, CXTPGridRow *pRow, CRect rcRow)
Fills a specified row with its background color.
virtual void | DrawGrid (CDC *pDC, XTPGridOrientation orientation, CRect rcGrid)
Draws a grid for the control.
virtual void | DrawFreezeColsDivider (CDC *pDC, const CRect &rc, CXTPGridControl *pControl, CXTPGridRow *pRow=NULL)
Draws a freeze column divider.
virtual void | DrawVerticalTimeLineMarker (CDC *pDC, int xPos, CXTPGridControl *pControl, COLORREF color=RGB(0, 255, 0))
Draws a vertical timeline marker.
virtual void | DrawGroupRow (CDC *pDC, CXTPGridGroupRow *pRow, CRect rcRow, XTP_GRIDRECORDITEM_METRICS *pMetrics)
Draws a group row.
virtual void | FillGroupRowMetrics (CXTPGridGroupRow *pRow, XTP_GRIDRECORDITEM_METRICS *pMetrics, BOOL bPrinting)
Fills the font and color members of the metrics structure for a specified group row.
virtual void | FillIndent (CDC *pDC, CRect rcRow)
Fills an indent area by its background.
virtual void | FillItemShade (CDC *pDC, CRect rcItem)
Fills an item shade by its background if necessary.
virtual void | FillHeaderControl (CDC *pDC, CRect rcHeader)
Fills a column header control area by its background.
virtual void | DrawColumnText (CDC *pDC, CRect rcText, CString strCaption, int nHeaderAlignment, BOOL bIsHeader, BOOL bColumnPressed)
Draws text for the column header.
virtual void | DrawColumn (CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn, BOOL bDrawExternal=FALSE, int nShadowWidth=0)
Draws a column header with all related attributes (sort order, icon, etc.).
virtual void | DrawColumnFooter (CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn)
Draws the column footer with all related attributes (e.g.
virtual void | DrawFocusedRow (CDC *pDC, CRect rcRow)
Draws focused rows.
virtual void | FillGroupByControl (CDC *pDC, CRect &rcGroupBy)
Draws the Group By box.
CXTPImageManager * | GetGlyphs () const
Gets a pointer to the additional image list with glyphs.
void | DrawHorizontalLine (CDC *pDC, int xPos, int yPos, int cx, COLORREF clr)
Draws a horizontal line.
void | DrawVerticalLine (CDC *pDC, int xPos, int yPos, int cy, COLORREF clr)
Draws a vertical line.
virtual void | DrawTriangle (CDC *pDC, CRect rcTriangle, BOOL bToDown, BOOL bDraggingFromHeader, int nShadowWidth, BOOL bColumnPressed)
Draws a triangle that shows the sort order of the column.
void | DrawConnector (CDC *pDC, CPoint ptFrom, CPoint ptTo)
Draws a column connector for the Group By box.
virtual CSize | DrawCollapsedBitmap (CDC *pDC, const CXTPGridRow *pRow, CRect &rcBitmap)
Draws a collapsed bitmap.
virtual int | DrawBitmap (CDC *pDC, CXTPGridControl *pControl, CRect rcColumn, int iImage)
Draws a bitmap.
virtual int | DrawColumnIcon (CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, CRect rcIcon, int iIcon)
Draws an icon for a column.
virtual CSize | DrawGlyph (CDC *pDC, CRect rcColumn, int iImage)
Draws the standard glyphs of the Grid control.
virtual CSize | DrawShellIcon (CDC *pDC, CRect rcColumn, int iImage)
Draws the shell icon.
void | EnablePreviewMode (BOOL bIsPreviewMode)
Enables/disables preview mode for the control.
BOOL | IsPreviewMode () const
Determines if preview mode is enabled/disabled for the control.
CFont * | GetTextFont ()
Gets the default text font used for control items.
int | SetMaxPreviewLines (int nMaxLines)
Sets the maximum number of lines of text for a preview item.
int | GetMaxPreviewLines ()
Gets the maximum number of lines of text for a preview item.
int | GetPreviewLinesCount (CDC *pDC, CRect &rcText, const CString &strText)
Calculates the number of lines required to draw a specified preview text string, taking into account the maximum number of lines of text for a preview item.
BOOL | IsGridVisible (BOOL bVertical) const
Determines the visibility of specified grid lines.
BOOL | IsGridVisible (XTPGridOrientation orientation) const
Determines the visibility of specified grid lines.
void | SetColumnStyle (XTPGridColumnStyle columnStyle)
Sets the header style.
XTPGridColumnStyle | GetColumnStyle () const
Gets the header style.
void | SetColumnOffice2007CustomThemeBaseColor (COLORREF clrBaseColor)
Sets the header's custom theme base color for Office2007 column style.
COLORREF | GetColumnOffice2007CustomThemeBaseColor () const
Gets the header's custom theme base color for Office2007 column style.
void | SetTextFont (LOGFONT &lf)
Creates and sets the default text font.
void | SetCaptionFont (LOGFONT &lf)
Creates and sets the default caption font.
void | SetPreviewIndent (int nLeft, int nTop, int nRight, int nBottom)
Sets the preview item indent.
virtual void | DrawInplaceButton (CDC *pDC, CXTPGridInplaceButton *pButton)
Draws the in-place button of the Grid control.
virtual BOOL | DrawInplaceComboButton (CDC *pDC, CRect *pRc)
Draws the combo button of the Grid control.
virtual BOOL | DrawInplaceExpandButton (CDC *pDC, CRect *pRc)
Draws the expand button of the Grid control.
virtual BOOL | DrawInplaceSpinButton (CDC *pDC, CRect *pRc)
Draws the spin button of the Grid control.
virtual void | DrawTreeStructure (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CRect rcItem, CSize sizeGlyph)
Draws tree elements of the Grid control.
virtual void | DrawItemBitmap (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CRect &rcItem, int nImage)
Draws an item bitmap.
virtual void | DrawItemCaption (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics)
Draws an item caption.
virtual void | DrawRowNumber (CDC *pDC, CRect rcNumber, CXTPGridRow *pRow)
Draws a row number.
virtual void | DrawItemControl (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CXTPGridRecordItemControl *pControl, CRect &rcItem)
Draws an item control.
BOOL | IsFixedRowHeight () const
Determines if the paint manager supports fixed or variable row height.
void | SetFixedRowHeight (BOOL bFixedRowHeight)
Sets if the paint manager supports fixed or variable row height.
BOOL | IsColumnWidthWYSIWYG () const
Determines if the paint manager supports column width WYSIWYG mode.
BOOL | IsLastColumnWidthWYSIWYG () const
Determines if the paint manager supports last column width WYSIWYG mode.
BOOL | IsShowWYSIWYGMarkers () const
Determines if the paint manager shows WYSIWYG page-end markers.
void | ShowWYSIWYGMarkers (BOOL bSet)
Sets if the paint manager shows WYSIWYG page-end markers.
void | SetColumnWidthWYSIWYG (BOOL bColumnWidthWYSIWYG)
Sets if the paint manager supports column width WYSIWYG mode.
void | SetLastColumnWidthWYSIWYG (BOOL bColumnWidthWYSIWYG)
Sets if the paint manager supports last column width WYSIWYG mode.
BOOL | IsFixedInplaceButtonHeight () const
Determines if the paint manager supports fixed or variable in-place button height.
void | SetInplaceButtonHeight (BOOL bFixedInplaceButtonHeight)
Sets if the paint manager supports fixed or variable in-place button height.
int | GetFreezeColsDividerStyle () const
Gets the style of the freeze columns divider line.
void | SetFreezeColsDividerStyle (int nStyle)
Sets the style for the freeze columns divider line.
virtual BOOL | OnDrawAction (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs)
Override this method to perform custom activities for the item before processing it.
virtual void | DrawNoGroupByText (CDC *pDC, CRect rcItem)
Draws the "No items" text message in the Group By area when there are no items inside it.
BOOL | IsDrawGridForEmptySpace () const
Determines if the grid fills empty space after body rows.
void | SetDrawGridForEmptySpace (BOOL bDrawGrid)
Sets if the grid fills empty space after body rows.
BOOL | IsPrintGroupRowIcon () const
Determines if the group row collapse-expand icon is drawn in print mode.
void | SetPrintGroupRowIcon (BOOL bDraw)
Sets if the group row collapse-expand icon is drawn in print mode.
BOOL | IsColumnPlusMinusSign () const
Determines if columns use expand/collapse icons (+/-) or directional arrows.
void | SetColumnPlusMinusSign (BOOL bDraw)
Specifies if columns use expand/collapse icons (+/-) or directional arrows.
virtual int | CalculateRowHeight (CDC *pDC, const CString &strText, int nMaxWidth, BOOL bWordBreak=TRUE)
Calculates the height required for a rectangle bounding multi-line text to draw the multi-line text when the width of the rectangle is fixed.
void | DrawSectionDivider (CDC *pDC, const CRect &rc, XTPGridSectionDividerPosition dividerPosition, XTPGridSectionDividerStyle dividerStyle, CXTPPaintManagerColor dividerColor)
Draws the divider between grid sections (e.g.
int | GetSectionDividerHeight (XTPGridFixedRowsDividerStyle dividerStyle)
Gets the height of the section divider.
BOOL | IsUseDropMarker () const
Determines if a drop marker will be used when dragging and dropping.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPTrackPaintManager
COLORREF | m_clrWorkArea
The color of the work area.
COLORREF | m_clrTrackHeader
The track header color.
COLORREF | m_clrTrackTimeArea
The track time area color.
COLORREF | m_clrTimeHeaderDarkDark
The header deep dark color.
COLORREF | m_clrTimeHeaderDark
The header dark color.
COLORREF | m_clrTimeSliderBackground
The slider background color.
COLORREF | m_clrTimeHeaderDivider
The header divider color.
COLORREF | m_clrScrollBarLight
The scrollbar light color.
COLORREF | m_clrScrollBarDark
The scrollbar dark color.
COLORREF | m_clrSelectedArea
The color of the selected area.
COLORREF | m_clrMarker
The color of the marker.
COLORREF | m_clrTimeLineTick
The color of a time line tick.
COLORREF | m_clrMarkerBorder
The color of a time line marker's border.
COLORREF | m_clrMarkerBack
The color of a time line marker's back.
COLORREF | m_clrTrackMarkerBorder
The color of a track marker's border.
COLORREF | m_clrTrackMarkerText
The color of a track marker's text.
COLORREF | m_clrTrackMarkerTextBack
The color of a track marker's text back.
COLORREF | m_clrTrackMarkerTextBorder
The color of a track marker's text border.
COLORREF | m_clrTimeLinePosition
The color of a marked position on a time line.
COLORREF | m_clrTimeHeaderBorder
The color of a time line header's border.
COLORREF | m_clrScrollBarBorderDark
The scrollbar border dark color.
COLORREF | m_clrScrollBarBorderLight
The scrollbar border light color.
COLORREF | m_clrWorkAreaScrollBarLight
The workarea scrollbar light color.
COLORREF | m_clrWorkAreaScrollBarDark
The workarea scrollbar dark color.
COLORREF | m_clrWorkAreaScrollBarBorder
The workarea scrollbar border color.
- Public Attributes inherited from CXTPGridPaintManager
CXTPFont | m_xtpFontText
Grid items default text.
CXTPFont | m_xtpFontBoldText
Grid items default bold text.
CXTPFont | m_xtpFontCaption
Column header caption font.
CXTPFont | m_xtpFontPreview
Column header caption font.
CXTPGridHyperlinkStyle * | m_pHyperlinkStyle
Style for links.
CXTPGridHyperlinkStyle * | m_pHyperlinkHoverStyle
Style for hovered links.
CXTPPaintManagerColor | m_clrHighlight
Background color of the highlighted row.
CXTPPaintManagerColor | m_clrBoldText
Grid items bold text color.
CXTPPaintManagerColor | m_clrBoldTextHighlight
Grid items bold text highlight color.
CXTPPaintManagerColor | m_clrWindowText
Grid items default text color.
CXTPPaintManagerColor | m_clrHighlightText
Text color of the highlighted text.
CXTPPaintManagerColor | m_clrHeaderControl
Background color of the grid header.
CXTPPaintManagerColor | m_clrCaptionText
Column header text color.
CXTPPaintManagerColor | m_clrCaptionTextPressed
Column header text color when pressed.
CXTPPaintManagerColor | m_clrControlBack
Background color of the control grid area.
CXTPPaintManagerColor | m_clrGroupRowText
Row text color.
CXTPPaintManagerColor | m_clrGroupShadeBack
Group row background color when indentation shade is enabled.
CXTPPaintManagerColor | m_clrGroupShadeText
Group row foreground color when indentation shade is enabled.
CXTPPaintManagerColor | m_clrGroupShadeBorder
Color for group border's shade.
CXTPPaintManagerColor | m_clrGroupBoxBack
Color of group box.
CXTPPaintManagerColor | m_clrControlDark
Dark background color of the Grid control (used on Group By area).
CXTPPaintManagerColor | m_clrControlLightLight
Light background color used for drawing shades (used on column header area).
CXTPPaintManagerColor | m_clrHotDivider
Color of the column hot divider window (two arrows).
CXTPPaintManagerColor | m_clrIndentControl
Color of the tree indentation area.
CXTPPaintManagerColor | m_clrItemShade
Color of the shade on sorted by column items.
CXTPPaintManagerColor | m_clrBtnFace
Standard button face color.
CXTPPaintManagerColor | m_clrBtnText
Standard button text color.
CXTPPaintManagerColor | m_clrPreviewText
Preview text color.
CXTPPaintManagerColor | m_clrSelectedRow
Selected row background color.
CXTPPaintManagerColor | m_clrSelectedRowText
Selected row text color.
CXTPPaintManagerColor | m_clrBtnFacePressed
Standard button face color when pressed.
CXTPPaintManagerColor | m_clrConnector
Header column connector line color.
CXTPPaintManagerColor | m_clrDisableBitmapLightest
The lightest color of bitmap which covers disabled grid.
CXTPPaintManagerColor | m_clrDisableBitmapDarkest
The darkest color of bitmap which covers disabled grid.
CXTPPaintManagerColorGradient | m_grcGradientColumn
Color of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColorGradient | m_grcGradientColumnHot
HotTracking Color of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColorGradient | m_grcGradientColumnPushed
Pushed Color of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColor | m_clrGradientColumnShadow
Bottom shadow of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColor | m_clrGradientColumnSeparator
Separator of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColor | m_crlNoGroupByText
A color for "No items" text in GroupBy area (see m_strNoGroupBy member).
CXTPPaintManagerColor | m_clrFreezeColsDivider
Freeze Columns Divider color.
COLORREF | m_clrColumnOffice2007CustomTheme
Base color for Office2007 custom theme.
COLORREF | m_clrFormulaSum
Color for Formula Sum fields.
COLORREF | m_clrFormulaSubSum
Color for Formula SubSum fields.
COLORREF | m_clrAlternativeBackground
Color for Alternative Row Background.
BOOL | m_bUseAlternativeBackground
TRUE to use Alternative Row Background, FALSE otherwise.
BOOL | m_bAllowMergeCells
TRUE to Allow Merge Cells, FALSE otherwise.
int | m_nTextIndentForGroupRowsWithNoIcon
Specifies Text indent if a group row icon is not used.
int | m_nTreeIndent
Tree indentation.
int | m_nTreeStructureStyle
Tree structure style.
int | m_nTreeTextIndentRowParent
Text indent, in pixels, for rows with children.
int | m_nTreeTextIndentRowChildren
Text indent, in pixels, for rows without children.
int | m_nTreeTextIndent
Text indent, in pixels, for rows that are neither parent nor children.
int | m_nTreeTextIndentGroupRow
Text indent, in pixels, for group rows.
BOOL | m_bGroupRowTextBold
TRUE to draw group rows with bold text.
BOOL | m_bShadeGroupHeadings
TRUE to show the indentation shade, FALSE otherwise.
BOOL | m_bShadeSortColumn
TRUE to show the items shade in the sorted by column, FALSE otherwise.
BOOL | m_bHotTracking
TRUE to allow column hot tracking.
BOOL | m_bInvertColumnOnClick
TRUE to invert column on click.
CString | m_strNoItems
A string which contains customized "No Items" text for displaying in view when there are no visible rows.
CString | m_strSortBy
A string which contains customized "Sort By" text for displaying in tooltip.
CString | m_strIncreasing
A string which contains customized "Increasing" text for displaying in tooltip.
CString | m_strDecreasing
A string which contains customized "Decreasing" text for displaying in tooltip.
CString | m_strNoGroupBy
A string which contains customized "No items" text message for displaying in Group By area when there are no items inside it.
CString | m_strNoFieldsAvailable
A string which contains customized "No Fields Available" text message for displaying in Field Chooser.
CString | m_strExpand
A string which contains customized "Expand" text for displaying in tooltip.
CString | m_strCollapse
A string which contains customized "Collapse" text for displaying in tooltip.
BOOL | m_bHideSelection
TRUE when hiding Grid control's selection by drawing selected items as others, FALSE otherwise.
BOOL | m_bPrintSortTriangle
TRUE to show the sort triangle in printout.
BOOL | m_bRevertAlignment
TRUE to revert column alignments.
BOOL | m_bUseEditTextAlignment
TRUE to automatically apply edit alignment using column alignment.
BOOL | m_bShowLockIcon
TRUE to show the lock icon, FALSE to hide.
BOOL | m_bUseShellIcon
TRUE to use the shell icon, FALSE otherwise.
int | m_iRecOrRowStart
Start position in numbering (0 or 1 or something user want).
BOOL | m_bRecOrRowNum
TRUE to display record number if support mode is used, FALSE to display row number.
BOOL | m_bMakeUpper
TRUE to display column header and group row text in all caps.
XTPGridTreeStructureStyle | m_treeStructureStyle
Tree structure style.
CRect | m_rcPreviewIndent
Preview indentation.
int | m_nFixedColumnsIndent
Fixed Column total width.
BOOL | m_bMoveScrollbarOnFixedColumnsIndent
Move Scrollbar right follow FixedColumnsIndent.
BOOL | m_bThemedInplaceButtons
Draw in-place buttons using current theme settings.
BOOL | m_bBaseTreeIndent
TRUE to add Extra Tree indentation to cover initial TreeColumn.
CUIntArray | m_arStartCol
Start column in each virtual page.
int | m_PrintPageWidth
Width of print page (run-time)
BOOL | m_bPrintVirtualPageNumber
TRUE to print horizontal page number.
BOOL | m_bPrintPageRectangle
TRUE to draw rectangle around page.
int | m_RecordNumberWidth
Column width for row/record numbers.
BOOL | m_bForceDynamicMarkupForCell
TRUE if use Markup for Grid Record Item.
BOOL | m_bForceShowDropMarker
TRUE if Force Show Drop Marker.
BOOL | m_bShowNonActiveInPlaceButton
TRUE if use Show Non-Active In-Place Button (Combo, Expand, Spin).
BOOL | m_bPrintWatermark
TRUE to print watermark.
BOOL | m_bUseGroupRowSelectionState
TRUE if use GroupSelectionState Glyph.
BOOL | m_bForceShowTooltip
TRUE if use show tooltip for any cell width case.
BOOL | m_bCleanTooltip
TRUE if use show tooltip without markup.
BOOL | m_bGrayIfDisable
TRUE is disable draw in gray (standard behavior).
int | m_nRowHeightDefault
The default row height.
BOOL | m_bCompactText
TRUE to ignore Icon for Narrow column to show more text.
BOOL | m_bUseDropMarker
FALSE to not draw drop marked when dragging/dropping, TRUE by default.
BOOL | m_bSortTriangleOffsetFromRight
Offset of sort triangle.
int | m_nTreeColumnLineLength
This is the extra line length to apply to tree column lines if there is no expand button.
int | m_nBaseParentRecordIndent
This is initial number of pixels a parent node will be indented when in a group.
- Protected Member Functions inherited from CXTPTrackPaintManager
- Protected Member Functions inherited from CXTPGridPaintManager
virtual void | DrawTextLine (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nFlag, int &nCharCounter, int &nHyperlinkCounter)
Draws a line of text with respect to the drawing rectangle.
virtual int | DrawString (int *pnCurrDrawPos, CDC *pDC, const CString &strDraw, CRect rcDraw, UINT nFormat)
Draw a simple string into rectangle.
virtual void | DrawGridPattern (CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush)
Generates a custom grid pattern if necessary.
virtual void | DrawGridPattern (CDC *pDC, CXTPBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush)
Generates a custom grid pattern if necessary.
virtual void | DrawGridPattern (CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr)
Generates a custom grid pattern.
virtual void | DrawInplaceButtonFrame (CDC *pDC, CXTPGridInplaceButton *pButton)
Draws the in-place button frame.
virtual BOOL | DrawInplaceButtonIcon (CDC *pDC, CXTPGridInplaceButton *pButton)
Draws the in-place button icon.
virtual int | CalcColumnHeight (CDC *pDC, CXTPGridColumn *pColumn, int nTotalWidth=0)
Calculates the optimal height for a specified column.
virtual void | DrawMultiLineText (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, BOOL bWordBreak=TRUE)
Draws multi-line text.
virtual void | DrawSingleLineText (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nStartPos, int nEndPos, int nActualWidth)
Draws single-line text.
virtual int | DrawLink (int *pnCurrDrawPos, XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CXTPGridHyperlink *pHyperlink, CString strText, CRect rcLink, int nFlag, BOOL bTrim=FALSE)
Draws a hyperlink string using hyperlink text settings (i.e.
- Protected Attributes inherited from CXTPGridPaintManager
int | m_nRowHeight
Grid row default height.
int | m_nHeaderHeight
Column header height.
int | m_nFooterHeight
Column footer height.
int | m_nGroupGridLineHeight
The height of the group grid line.
CXTPImageManager * | m_pGlyphs
An additional image list for the Grid control.
BOOL | m_bIsPreviewMode
TRUE to show the item preview, FALSE to hide.
int | m_nResizingWidth
The width of the column resizing marker area.
int | m_nMaxPreviewLines
Restrict maximum lines for preview text.
CSize | m_szGlyph
Glyph size.
CXTPBrush | m_xtpBrushTreeStructure
Brush to draw tree nodes.
CXTPBrush | m_xtpBrushGroupGridLineStyle
Brush to draw group row grid lines.
int | m_nFreezeColsDividerStyle
A set of flags from XTPGridFreezeColsDividerStyle.
BOOL | m_bFixedRowHeight
TRUE if fixed rows used.
BOOL | m_bColumnWidthWYSIWYG
TRUE if columns width WYSIWYG mode used.
BOOL | m_bShowWYSIWYGMarkers
TRUE if in non-print mode header show red page-end markers.
BOOL | m_bLastColumnWidthWYSIWYG
TRUE if last column width WYSIWYG mode used.
BOOL | m_bDrawGridForEmptySpace
TRUE if grid fills the empty space (if any) after the body rows.
BOOL | m_bPrintGroupRowIcon
TRUE if printout draw collapse-expand icon for group row.
BOOL | m_bColumnPlusMinusSign
TRUE if expand/collapse icons are used, FALSE if directional arrows are used.
BOOL | m_bFixedInplaceButtonHeight
TRUE if fixed in-place button height is used.
XTPGridGridStyle | m_nGroupGridLineStyle
Current style for group row grid lines.
XTPGridColumnStyle | m_columnStyle
Column drawing style.
CXTPWinThemeWrapper * | m_themeHeader
Header theme wrapper.
CXTPWinThemeWrapper * | m_themeButton
In-place button theme wrapper.
CXTPWinThemeWrapper * | m_themeCombo
Combo box in-place button theme wrapper.
CXTPWinThemeWrapper * | m_themeSpin
Spin in-place button theme wrapper.
CXTPGridControl * | m_pControl
Pointer to the Grid control object.
CXTPMarkupUIElement * | m_pMarkupUIElement_NoGroupBy
The no group by markup UI element.
CString | m_strMarkupUIElement_NoGroupBy
The no group by markup UI element string.
CXTPBrush | m_xtpBrushVeriticalGrid
Brush to draw vertical grid lines.
CXTPBrush | m_xtpBrushHorizontalGrid
Brush to draw horizontal grid lines.
XTPGridGridStyle m_nGridLineStylePreviousV
Previous style for vertical grid lines.
XTPGridGridStyle m_nGridLineStylePreviousH
Previous style for horizontal grid lines.

Detailed Description

CXTPTrackThemeOffice2003Luna is a CXTPTrackPaintManager derived class that represents an Office 2003 Luna style theme.

Member Function Documentation

◆ DrawColumnBackground()

virtual void DrawColumnBackground | ( | CDC * | pDC,
 |  | CXTPGridColumn * | pColumn,
 |  | CRect | rcColumn,
 |  | BOOL & | bColumnPressed,
 |  | BOOL & | bDraggingFromHeader,
 |  | CXTPGridHeader * | pHeader = NULL )
 virtual

This method is called to draw the background of a column using the current column style.

Parameters
pDC | Pointer to the used device context.
pColumn | Pointer to the column whose background must be drawn.
rcColumn | Bounding rectangle of the column.
bColumnPressed | TRUE if the column is pressed by the user.
bDraggingFromHeader | TRUE if the column is being dragged from the header area.
pHeader | Pointer to the header that the column belongs to.

Reimplemented from CXTPGridPaintManager.

◆ DrawColumnFooterDivider()

virtual void DrawColumnFooterDivider | ( | CDC * | pDC,
 |  | CXTPGridColumn * | pColumn,
 |  | CRect | rcColumn )
 virtual

Draws the column footer divider.

Parameters
pDC | Pointer to the used device context.
pColumn | Pointer to column header area rectangle coordinates.
rcColumn | Column area rectangle coordinates.

Reimplemented from CXTPGridPaintManager.

◆ DrawSectionDivider()

void DrawSectionDivider | ( | CDC * | pDC,
 |  | const CRect & | rc,
 |  | XTPGridSectionDividerPosition | dividerPosition,
 |  | XTPGridSectionDividerStyle | dividerStyle,
 |  | CXTPPaintManagerColor | dividerColor )

Draws the divider between grid sections (e.g.

dividing header record rows and body rows).

Parameters
pDC | Pointer to the used device context.
rc | Reference to rectangle coordinates.
dividerPosition | Position of the section divider; must be one of the values defined by the XTPGridSectionDividerPosition enumeration.
dividerStyle | Style of the section divider; must be one of the values defined by the XTPGridSectionDividerStyle enumeration.
dividerColor | Color of the section divider.

◆ FillFooter()

virtual void FillFooter | ( | CDC * | pDC,
 |  | CRect | rcFooter )
 virtual

Fills the column footer control area by its background.

Parameters
pDC | Pointer to the used device context.
rcFooter | Footer area rectangle coordinates.

Reimplemented from CXTPGridPaintManager.

◆ IsColumHotTrackingEnabled()

virtual BOOL IsColumHotTrackingEnabled ( ) const
virtual

Determines if hot tracking is enabled for the current column style.

Returns
TRUE if hot tracking is enabled, otherwise FALSE.

Hot tracking can only be used for the xtpGridColumnOffice2003 and xtpGridColumnExplorer styles.

See also
m_columnStyle, m_bHotTracking

Reimplemented from CXTPGridPaintManager.

The documentation for this class was generated from the following file:
  • XTPTrackThemeOffice2003Luna.h


Toolkit Pro: CXTPTrackThemeOffice2013 Class Reference

Public Member Functions | Public Attributes | List of all members
CXTPTrackThemeOffice2013 Class Reference

CXTPTrackThemeOffice2013 is a CXTPTrackPaintManager derived class that represents an Office 2013 style theme. More...

Inheritance diagram for CXTPTrackThemeOffice2013:
[legend]

Public Member Functions

CXTPTrackThemeOffice2013 ()
Default paint manager constructor, handles properties initialization.
virtual void | LoadGlyphs ()
Loads the default images used by the track control.
virtual void | RefreshMetrics ()
This method is called to refresh the visual metrics of the track control.
virtual void | DrawColumnText (CDC *pDC, CRect rcText, CString strCaption, int nHeaderAlignment, BOOL bIsHeader, BOOL bColumnPressed)
Draws text for the column header.
virtual void | DrawColumnBackground (CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, BOOL &bColumnPressed, BOOL &bDraggingFromHeader, CXTPGridHeader *pHeader=NULL)
This method is called to draw the background of a column using the current column style.
virtual void | DrawTriangle (CDC *pDC, CRect rcTriangle, BOOL bToDown, BOOL bDraggingFromHeader, int nShadowWidth, BOOL bColumnPressed)
Draws a triangle that shows the sort order of the column.
virtual void | FillGroupRowMetrics (CXTPGridGroupRow *pRow, XTP_GRIDRECORDITEM_METRICS *pMetrics, BOOL bPrinting)
Fills the font and color members of the metrics structure for a specified group row.
virtual void | DrawGroupRow (CDC *pDC, CXTPGridGroupRow *pRow, CRect rcRow, XTP_GRIDRECORDITEM_METRICS *pMetrics)
Draws a group row.
virtual void | DrawFocusedRow (CDC *pDC, CRect rcRow)
Draws focused rows.
virtual int | GetRowHeight (CDC *pDC, CXTPGridRow *pRow)
Retrieves the default row height for print mode (i.e.
- Public Member Functions inherited from CXTPTrackPaintManager
CXTPTrackPaintManager ()
Creates a CXTPTrackPaintManager object.
~CXTPTrackPaintManager ()
CXTPTrackPaintManager destructor, handles cleanup and deallocation.
virtual void | DrawTrackHeader (CDC *pDC)
Call this function to draw the track header.
virtual void | DrawMarkers (CDC *pDC)
Call this function to draw the markers.
virtual void | DrawTimeLine (CDC *pDC)
Call this function to draw the time line.
virtual CString | FormatTimeLineTick (int nPosition, COLORREF &clrTick, int &nTickLength)
Call this function to format the time and tick marker relative to a time line position.
virtual CString | FormatTime (int nPosition)
Call this function to format the time and tick marker relative to a time line position.
- Public Member Functions inherited from CXTPGridPaintManager
CXTPGridPaintManager ()
Default CXTPGridPaintManager constructor, handles properties initialization.
virtual | ~CXTPGridPaintManager ()
Default CXTPGridPaintManager destructor, handles member items deallocation.
virtual void | SetGridControl (CXTPGridControl *pControl)
Sets the associated Grid control for the paint manager.
virtual int | GetRowHeight (CDC *pDC, CXTPGridRow *pRow, int nTotalWidth)
Retrieves the default row height for print mode (i.e.
int | GetRowHeightEx (CDC *pDC, CXTPGridRow *pRow, int nTotalWidth, const BOOL firstLevel=TRUE)
Retrieves the default row height for print mode (i.e.
int | GetItemHeight (XTP_GRIDRECORDITEM_DRAWARGS &drawArgs, int nWidth)
Retrieves the height of a record item for a given width.
BOOL | FindRowAdjacentToMergedEx (const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, int &nAdjRowIndex, BOOL bUpward)
Searches the topmost or bottommost row depending on the height of the current row.
int | FindRowAdjacentToMerged (const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, BOOL bUpward)
Wrapper for the FindRowAdjacentToMergedEx method.
int | RecalcTotalHightOfMergedRows (CXTPGridColumns *pColumns, CDC *pDC, CXTPGridRow *pRow, int nRowHeight, int nTotalWidth)
Recalculates row height according to the height of merged items.
virtual int | GetPreviewItemHeight (CDC *pDC, CXTPGridRow *pRow, int nWidth, int nHeight)
Retrieves the height of a preview item for print mode.
virtual int | GetHeaderHeight ()
Gets the column header height.
virtual int | GetHeaderHeight (CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0)
Calculates the optimal header height.
virtual void | SetHeaderHeight (int nHeight)
Sets the column header height.
virtual int | GetFooterHeight (CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0)
Calculates the optimal footer height.
virtual COLORREF | GetControlBackColor (CXTPGridControl *pControl)
Retrieves the parent Grid control's background color.
virtual void | FillRow (CDC *pDC, CXTPGridRow *pRow, CRect rcRow)
Fills a specified row with its background color.
virtual void | DrawGrid (CDC *pDC, XTPGridOrientation orientation, CRect rcGrid)
Draws a grid for the control.
virtual void | DrawFreezeColsDivider (CDC *pDC, const CRect &rc, CXTPGridControl *pControl, CXTPGridRow *pRow=NULL)
Draws a freeze column divider.
virtual void | DrawVerticalTimeLineMarker (CDC *pDC, int xPos, CXTPGridControl *pControl, COLORREF color=RGB(0, 255, 0))
Draws a vertical timeline marker.
virtual void | FillIndent (CDC *pDC, CRect rcRow)
Fills an indent area by its background.
virtual void | FillItemShade (CDC *pDC, CRect rcItem)
Fills an item shade by its background if necessary.
virtual void | FillHeaderControl (CDC *pDC, CRect rcHeader)
Fills a column header control area by its background.
virtual void | FillFooter (CDC *pDC, CRect rcFooter)
Fills a column footer control area by its background.
virtual void | DrawColumn (CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn, BOOL bDrawExternal=FALSE, int nShadowWidth=0)
Draws a column header with all related attributes (sort order, icon, etc.).
virtual void | DrawColumnFooterDivider (CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn)
Draws the column footer divider.
virtual void | DrawColumnFooter (CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn)
Draws the column footer with all related attributes (e.g.
virtual BOOL | IsColumHotTrackingEnabled () const
Determines if hot tracking is enabled for the current column style.
virtual void | FillGroupByControl (CDC *pDC, CRect &rcGroupBy)
Draws the Group By box.
CXTPImageManager * | GetGlyphs () const
Gets a pointer to the additional image list with glyphs.
void | DrawHorizontalLine (CDC *pDC, int xPos, int yPos, int cx, COLORREF clr)
Draws a horizontal line.
void | DrawVerticalLine (CDC *pDC, int xPos, int yPos, int cy, COLORREF clr)
Draws a vertical line.
void | DrawConnector (CDC *pDC, CPoint ptFrom, CPoint ptTo)
Draws a column connector for the Group By box.
virtual CSize | DrawCollapsedBitmap (CDC *pDC, const CXTPGridRow *pRow, CRect &rcBitmap)
Draws a collapsed bitmap.
virtual int | DrawBitmap (CDC *pDC, CXTPGridControl *pControl, CRect rcColumn, int iImage)
Draws a bitmap.
virtual int | DrawColumnIcon (CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, CRect rcIcon, int iIcon)
Draws an icon for a column.
virtual CSize | DrawGlyph (CDC *pDC, CRect rcColumn, int iImage)
Draws the standard glyphs of the Grid control.
virtual CSize | DrawShellIcon (CDC *pDC, CRect rcColumn, int iImage)
Draws the shell icon.
void | EnablePreviewMode (BOOL bIsPreviewMode)
Enables/disables preview mode for the control.
BOOL | IsPreviewMode () const
Determines if preview mode is enabled/disabled for the control.
CFont * | GetTextFont ()
Gets the default text font used for control items.
int | SetMaxPreviewLines (int nMaxLines)
Sets the maximum number of lines of text for a preview item.
int | GetMaxPreviewLines ()
Gets the maximum number of lines of text for a preview item.
int | GetPreviewLinesCount (CDC *pDC, CRect &rcText, const CString &strText)
Calculates the number of lines required to draw a specified preview text string, taking into account the maximum number of lines of text for a preview item.
BOOL | IsGridVisible (BOOL bVertical) const
Determines the visibility of specified grid lines.
BOOL | IsGridVisible (XTPGridOrientation orientation) const
Determines the visibility of specified grid lines.
void | SetColumnStyle (XTPGridColumnStyle columnStyle)
Sets the header style.
XTPGridColumnStyle | GetColumnStyle () const
Gets the header style.
void | SetColumnOffice2007CustomThemeBaseColor (COLORREF clrBaseColor)
Sets the header's custom theme base color for Office2007 column style.
COLORREF | GetColumnOffice2007CustomThemeBaseColor () const
Gets the header's custom theme base color for Office2007 column style.
void | SetTextFont (LOGFONT &lf)
Creates and sets the default text font.
void | SetCaptionFont (LOGFONT &lf)
Creates and sets the default caption font.
void | SetPreviewIndent (int nLeft, int nTop, int nRight, int nBottom)
Sets the preview item indent.
virtual void | DrawInplaceButton (CDC *pDC, CXTPGridInplaceButton *pButton)
Draws the in-place button of the Grid control.
virtual BOOL | DrawInplaceComboButton (CDC *pDC, CRect *pRc)
Draws the combo button of the Grid control.
virtual BOOL | DrawInplaceExpandButton (CDC *pDC, CRect *pRc)
Draws the expand button of the Grid control.
virtual BOOL | DrawInplaceSpinButton (CDC *pDC, CRect *pRc)
Draws the spin button of the Grid control.
virtual void | DrawTreeStructure (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CRect rcItem, CSize sizeGlyph)
Draws tree elements of the Grid control.
virtual void | DrawItemBitmap (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CRect &rcItem, int nImage)
Draws an item bitmap.
virtual void | DrawItemCaption (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics)
Draws an item caption.
virtual void | DrawRowNumber (CDC *pDC, CRect rcNumber, CXTPGridRow *pRow)
Draws a row number.
virtual void | DrawItemControl (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CXTPGridRecordItemControl *pControl, CRect &rcItem)
Draws an item control.
BOOL | IsFixedRowHeight () const
Determines if the paint manager supports fixed or variable row height.
void | SetFixedRowHeight (BOOL bFixedRowHeight)
Sets if the paint manager supports fixed or variable row height.
BOOL | IsColumnWidthWYSIWYG () const
Determines if the paint manager supports column width WYSIWYG mode.
BOOL | IsLastColumnWidthWYSIWYG () const
Determines if the paint manager supports last column width WYSIWYG mode.
BOOL | IsShowWYSIWYGMarkers () const
Determines if the paint manager shows WYSIWYG page-end markers.
void | ShowWYSIWYGMarkers (BOOL bSet)
Sets if the paint manager shows WYSIWYG page-end markers.
void | SetColumnWidthWYSIWYG (BOOL bColumnWidthWYSIWYG)
Sets if the paint manager supports column width WYSIWYG mode.
void | SetLastColumnWidthWYSIWYG (BOOL bColumnWidthWYSIWYG)
Sets if the paint manager supports last column width WYSIWYG mode.
BOOL | IsFixedInplaceButtonHeight () const
Determines if the paint manager supports fixed or variable in-place button height.
void | SetInplaceButtonHeight (BOOL bFixedInplaceButtonHeight)
Sets if the paint manager supports fixed or variable in-place button height.
int | GetFreezeColsDividerStyle () const
Gets the style of the freeze columns divider line.
void | SetFreezeColsDividerStyle (int nStyle)
Sets the style for the freeze columns divider line.
virtual BOOL | OnDrawAction (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs)
Override this method to perform custom activities for the item before processing it.
virtual void | DrawNoGroupByText (CDC *pDC, CRect rcItem)
Draws the "No items" text message in the Group By area when there are no items inside it.
BOOL | IsDrawGridForEmptySpace () const
Determines if the grid fills empty space after body rows.
void | SetDrawGridForEmptySpace (BOOL bDrawGrid)
Sets if the grid fills empty space after body rows.
BOOL | IsPrintGroupRowIcon () const
Determines if the group row collapse-expand icon is drawn in print mode.
void | SetPrintGroupRowIcon (BOOL bDraw)
Sets if the group row collapse-expand icon is drawn in print mode.
BOOL | IsColumnPlusMinusSign () const
Determines if columns use expand/collapse icons (+/-) or directional arrows.
void | SetColumnPlusMinusSign (BOOL bDraw)
Specifies if columns use expand/collapse icons (+/-) or directional arrows.
virtual int | CalculateRowHeight (CDC *pDC, const CString &strText, int nMaxWidth, BOOL bWordBreak=TRUE)
Calculates the height required for a rectangle bounding multi-line text to draw the multi-line text when the width of the rectangle is fixed.
void | DrawSectionDivider (CDC *pDC, const CRect &rc, XTPGridSectionDividerPosition dividerPosition, XTPGridSectionDividerStyle dividerStyle, CXTPPaintManagerColor dividerColor)
Draws the divider between grid sections (e.g.
int | GetSectionDividerHeight (XTPGridFixedRowsDividerStyle dividerStyle)
Gets the height of the section divider.
BOOL | IsUseDropMarker () const
Determines if a drop marker will be used when dragging and dropping.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Public Attributes

CXTPPaintManagerColor | m_clrGlyph
Header glyph color.
CXTPPaintManagerColor | m_clrGlyphHighlight
Header highlighted glyph color.
CXTPPaintManagerColor | m_clrSelectedBorder
Selected block border.
- Public Attributes inherited from CXTPTrackPaintManager
COLORREF | m_clrWorkArea
The color of the work area.
COLORREF | m_clrTrackHeader
The track header color.
COLORREF | m_clrTrackTimeArea
The track time area color.
COLORREF | m_clrTimeHeaderDarkDark
The header deep dark color.
COLORREF | m_clrTimeHeaderDark
The header dark color.
COLORREF | m_clrTimeSliderBackground
The slider background color.
COLORREF | m_clrTimeHeaderDivider
The header divider color.
COLORREF | m_clrScrollBarLight
The scrollbar light color.
COLORREF | m_clrScrollBarDark
The scrollbar dark color.
COLORREF | m_clrSelectedArea
The color of the selected area.
COLORREF | m_clrMarker
The color of the marker.
COLORREF | m_clrTimeLineTick
The color of a time line tick.
COLORREF | m_clrMarkerBorder
The color of a time line marker's border.
COLORREF | m_clrMarkerBack
The color of a time line marker's back.
COLORREF | m_clrTrackMarkerBorder
The color of a track marker's border.
COLORREF | m_clrTrackMarkerText
The color of a track marker's text.
COLORREF | m_clrTrackMarkerTextBack
The color of a track marker's text back.
COLORREF | m_clrTrackMarkerTextBorder
The color of a track marker's text border.
COLORREF | m_clrTimeLinePosition
The color of a marked position on a time line.
COLORREF | m_clrTimeHeaderBorder
The color of a time line header's border.
COLORREF | m_clrScrollBarBorderDark
The scrollbar border dark color.
COLORREF | m_clrScrollBarBorderLight
The scrollbar border light color.
COLORREF | m_clrWorkAreaScrollBarLight
The workarea scrollbar light color.
COLORREF | m_clrWorkAreaScrollBarDark
The workarea scrollbar dark color.
COLORREF | m_clrWorkAreaScrollBarBorder
The workarea scrollbar border color.
- Public Attributes inherited from CXTPGridPaintManager
CXTPFont | m_xtpFontText
Grid items default text.
CXTPFont | m_xtpFontBoldText
Grid items default bold text.
CXTPFont | m_xtpFontCaption
Column header caption font.
CXTPFont | m_xtpFontPreview
Column header caption font.
CXTPGridHyperlinkStyle * | m_pHyperlinkStyle
Style for links.
CXTPGridHyperlinkStyle * | m_pHyperlinkHoverStyle
Style for hovered links.
CXTPPaintManagerColor | m_clrHighlight
Background color of the highlighted row.
CXTPPaintManagerColor | m_clrBoldText
Grid items bold text color.
CXTPPaintManagerColor | m_clrBoldTextHighlight
Grid items bold text highlight color.
CXTPPaintManagerColor | m_clrWindowText
Grid items default text color.
CXTPPaintManagerColor | m_clrHighlightText
Text color of the highlighted text.
CXTPPaintManagerColor | m_clrHeaderControl
Background color of the grid header.
CXTPPaintManagerColor | m_clrCaptionText
Column header text color.
CXTPPaintManagerColor | m_clrCaptionTextPressed
Column header text color when pressed.
CXTPPaintManagerColor | m_clrControlBack
Background color of the control grid area.
CXTPPaintManagerColor | m_clrGroupRowText
Row text color.
CXTPPaintManagerColor | m_clrGroupShadeBack
Group row background color when indentation shade is enabled.
CXTPPaintManagerColor | m_clrGroupShadeText
Group row foreground color when indentation shade is enabled.
CXTPPaintManagerColor | m_clrGroupShadeBorder
Color for group border's shade.
CXTPPaintManagerColor | m_clrGroupBoxBack
Color of group box.
CXTPPaintManagerColor | m_clrControlDark
Dark background color of the Grid control (used on Group By area).
CXTPPaintManagerColor | m_clrControlLightLight
Light background color used for drawing shades (used on column header area).
CXTPPaintManagerColor | m_clrHotDivider
Color of the column hot divider window (two arrows).
CXTPPaintManagerColor | m_clrIndentControl
Color of the tree indentation area.
CXTPPaintManagerColor | m_clrItemShade
Color of the shade on sorted by column items.
CXTPPaintManagerColor | m_clrBtnFace
Standard button face color.
CXTPPaintManagerColor | m_clrBtnText
Standard button text color.
CXTPPaintManagerColor | m_clrPreviewText
Preview text color.
CXTPPaintManagerColor | m_clrSelectedRow
Selected row background color.
CXTPPaintManagerColor | m_clrSelectedRowText
Selected row text color.
CXTPPaintManagerColor | m_clrBtnFacePressed
Standard button face color when pressed.
CXTPPaintManagerColor | m_clrConnector
Header column connector line color.
CXTPPaintManagerColor | m_clrDisableBitmapLightest
The lightest color of bitmap which covers disabled grid.
CXTPPaintManagerColor | m_clrDisableBitmapDarkest
The darkest color of bitmap which covers disabled grid.
CXTPPaintManagerColorGradient | m_grcGradientColumn
Color of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColorGradient | m_grcGradientColumnHot
HotTracking Color of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColorGradient | m_grcGradientColumnPushed
Pushed Color of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColor | m_clrGradientColumnShadow
Bottom shadow of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColor | m_clrGradientColumnSeparator
Separator of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColor | m_crlNoGroupByText
A color for "No items" text in GroupBy area (see m_strNoGroupBy member).
CXTPPaintManagerColor | m_clrFreezeColsDivider
Freeze Columns Divider color.
COLORREF | m_clrColumnOffice2007CustomTheme
Base color for Office2007 custom theme.
COLORREF | m_clrFormulaSum
Color for Formula Sum fields.
COLORREF | m_clrFormulaSubSum
Color for Formula SubSum fields.
COLORREF | m_clrAlternativeBackground
Color for Alternative Row Background.
BOOL | m_bUseAlternativeBackground
TRUE to use Alternative Row Background, FALSE otherwise.
BOOL | m_bAllowMergeCells
TRUE to Allow Merge Cells, FALSE otherwise.
int | m_nTextIndentForGroupRowsWithNoIcon
Specifies Text indent if a group row icon is not used.
int | m_nTreeIndent
Tree indentation.
int | m_nTreeStructureStyle
Tree structure style.
int | m_nTreeTextIndentRowParent
Text indent, in pixels, for rows with children.
int | m_nTreeTextIndentRowChildren
Text indent, in pixels, for rows without children.
int | m_nTreeTextIndent
Text indent, in pixels, for rows that are neither parent nor children.
int | m_nTreeTextIndentGroupRow
Text indent, in pixels, for group rows.
BOOL | m_bGroupRowTextBold
TRUE to draw group rows with bold text.
BOOL | m_bShadeGroupHeadings
TRUE to show the indentation shade, FALSE otherwise.
BOOL | m_bShadeSortColumn
TRUE to show the items shade in the sorted by column, FALSE otherwise.
BOOL | m_bHotTracking
TRUE to allow column hot tracking.
BOOL | m_bInvertColumnOnClick
TRUE to invert column on click.
CString | m_strNoItems
A string which contains customized "No Items" text for displaying in view when there are no visible rows.
CString | m_strSortBy
A string which contains customized "Sort By" text for displaying in tooltip.
CString | m_strIncreasing
A string which contains customized "Increasing" text for displaying in tooltip.
CString | m_strDecreasing
A string which contains customized "Decreasing" text for displaying in tooltip.
CString | m_strNoGroupBy
A string which contains customized "No items" text message for displaying in Group By area when there are no items inside it.
CString | m_strNoFieldsAvailable
A string which contains customized "No Fields Available" text message for displaying in Field Chooser.
CString | m_strExpand
A string which contains customized "Expand" text for displaying in tooltip.
CString | m_strCollapse
A string which contains customized "Collapse" text for displaying in tooltip.
BOOL | m_bHideSelection
TRUE when hiding Grid control's selection by drawing selected items as others, FALSE otherwise.
BOOL | m_bPrintSortTriangle
TRUE to show the sort triangle in printout.
BOOL | m_bRevertAlignment
TRUE to revert column alignments.
BOOL | m_bUseEditTextAlignment
TRUE to automatically apply edit alignment using column alignment.
BOOL | m_bShowLockIcon
TRUE to show the lock icon, FALSE to hide.
BOOL | m_bUseShellIcon
TRUE to use the shell icon, FALSE otherwise.
int | m_iRecOrRowStart
Start position in numbering (0 or 1 or something user want).
BOOL | m_bRecOrRowNum
TRUE to display record number if support mode is used, FALSE to display row number.
BOOL | m_bMakeUpper
TRUE to display column header and group row text in all caps.
XTPGridTreeStructureStyle | m_treeStructureStyle
Tree structure style.
CRect | m_rcPreviewIndent
Preview indentation.
int | m_nFixedColumnsIndent
Fixed Column total width.
BOOL | m_bMoveScrollbarOnFixedColumnsIndent
Move Scrollbar right follow FixedColumnsIndent.
BOOL | m_bThemedInplaceButtons
Draw in-place buttons using current theme settings.
BOOL | m_bBaseTreeIndent
TRUE to add Extra Tree indentation to cover initial TreeColumn.
CUIntArray | m_arStartCol
Start column in each virtual page.
int | m_PrintPageWidth
Width of print page (run-time)
BOOL | m_bPrintVirtualPageNumber
TRUE to print horizontal page number.
BOOL | m_bPrintPageRectangle
TRUE to draw rectangle around page.
int | m_RecordNumberWidth
Column width for row/record numbers.
BOOL | m_bForceDynamicMarkupForCell
TRUE if use Markup for Grid Record Item.
BOOL | m_bForceShowDropMarker
TRUE if Force Show Drop Marker.
BOOL | m_bShowNonActiveInPlaceButton
TRUE if use Show Non-Active In-Place Button (Combo, Expand, Spin).
BOOL | m_bPrintWatermark
TRUE to print watermark.
BOOL | m_bUseGroupRowSelectionState
TRUE if use GroupSelectionState Glyph.
BOOL | m_bForceShowTooltip
TRUE if use show tooltip for any cell width case.
BOOL | m_bCleanTooltip
TRUE if use show tooltip without markup.
BOOL | m_bGrayIfDisable
TRUE is disable draw in gray (standard behavior).
int | m_nRowHeightDefault
The default row height.
BOOL | m_bCompactText
TRUE to ignore Icon for Narrow column to show more text.
BOOL | m_bUseDropMarker
FALSE to not draw drop marked when dragging/dropping, TRUE by default.
BOOL | m_bSortTriangleOffsetFromRight
Offset of sort triangle.
int | m_nTreeColumnLineLength
This is the extra line length to apply to tree column lines if there is no expand button.
int | m_nBaseParentRecordIndent
This is initial number of pixels a parent node will be indented when in a group.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Member Functions inherited from CXTPTrackPaintManager
- Protected Member Functions inherited from CXTPGridPaintManager
virtual void | DrawTextLine (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nFlag, int &nCharCounter, int &nHyperlinkCounter)
Draws a line of text with respect to the drawing rectangle.
virtual int | DrawString (int *pnCurrDrawPos, CDC *pDC, const CString &strDraw, CRect rcDraw, UINT nFormat)
Draw a simple string into rectangle.
virtual void | DrawGridPattern (CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush)
Generates a custom grid pattern if necessary.
virtual void | DrawGridPattern (CDC *pDC, CXTPBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush)
Generates a custom grid pattern if necessary.
virtual void | DrawGridPattern (CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr)
Generates a custom grid pattern.
virtual void | DrawInplaceButtonFrame (CDC *pDC, CXTPGridInplaceButton *pButton)
Draws the in-place button frame.
virtual BOOL | DrawInplaceButtonIcon (CDC *pDC, CXTPGridInplaceButton *pButton)
Draws the in-place button icon.
virtual int | CalcColumnHeight (CDC *pDC, CXTPGridColumn *pColumn, int nTotalWidth=0)
Calculates the optimal height for a specified column.
virtual void | DrawMultiLineText (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, BOOL bWordBreak=TRUE)
Draws multi-line text.
virtual void | DrawSingleLineText (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nStartPos, int nEndPos, int nActualWidth)
Draws single-line text.
virtual int | DrawLink (int *pnCurrDrawPos, XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CXTPGridHyperlink *pHyperlink, CString strText, CRect rcLink, int nFlag, BOOL bTrim=FALSE)
Draws a hyperlink string using hyperlink text settings (i.e.
- Protected Attributes inherited from CXTPGridPaintManager
int | m_nRowHeight
Grid row default height.
int | m_nHeaderHeight
Column header height.
int | m_nFooterHeight
Column footer height.
int | m_nGroupGridLineHeight
The height of the group grid line.
CXTPImageManager * | m_pGlyphs
An additional image list for the Grid control.
BOOL | m_bIsPreviewMode
TRUE to show the item preview, FALSE to hide.
int | m_nResizingWidth
The width of the column resizing marker area.
int | m_nMaxPreviewLines
Restrict maximum lines for preview text.
CSize | m_szGlyph
Glyph size.
CXTPBrush | m_xtpBrushTreeStructure
Brush to draw tree nodes.
CXTPBrush | m_xtpBrushGroupGridLineStyle
Brush to draw group row grid lines.
int | m_nFreezeColsDividerStyle
A set of flags from XTPGridFreezeColsDividerStyle.
BOOL | m_bFixedRowHeight
TRUE if fixed rows used.
BOOL | m_bColumnWidthWYSIWYG
TRUE if columns width WYSIWYG mode used.
BOOL | m_bShowWYSIWYGMarkers
TRUE if in non-print mode header show red page-end markers.
BOOL | m_bLastColumnWidthWYSIWYG
TRUE if last column width WYSIWYG mode used.
BOOL | m_bDrawGridForEmptySpace
TRUE if grid fills the empty space (if any) after the body rows.
BOOL | m_bPrintGroupRowIcon
TRUE if printout draw collapse-expand icon for group row.
BOOL | m_bColumnPlusMinusSign
TRUE if expand/collapse icons are used, FALSE if directional arrows are used.
BOOL | m_bFixedInplaceButtonHeight
TRUE if fixed in-place button height is used.
XTPGridGridStyle | m_nGroupGridLineStyle
Current style for group row grid lines.
XTPGridColumnStyle | m_columnStyle
Column drawing style.
CXTPWinThemeWrapper * | m_themeHeader
Header theme wrapper.
CXTPWinThemeWrapper * | m_themeButton
In-place button theme wrapper.
CXTPWinThemeWrapper * | m_themeCombo
Combo box in-place button theme wrapper.
CXTPWinThemeWrapper * | m_themeSpin
Spin in-place button theme wrapper.
CXTPGridControl * | m_pControl
Pointer to the Grid control object.
CXTPMarkupUIElement * | m_pMarkupUIElement_NoGroupBy
The no group by markup UI element.
CString | m_strMarkupUIElement_NoGroupBy
The no group by markup UI element string.
CXTPBrush | m_xtpBrushVeriticalGrid
Brush to draw vertical grid lines.
CXTPBrush | m_xtpBrushHorizontalGrid
Brush to draw horizontal grid lines.
XTPGridGridStyle m_nGridLineStylePreviousV
Previous style for vertical grid lines.
XTPGridGridStyle m_nGridLineStylePreviousH
Previous style for horizontal grid lines.

Detailed Description

CXTPTrackThemeOffice2013 is a CXTPTrackPaintManager derived class that represents an Office 2013 style theme.

Member Function Documentation

◆ DrawColumnBackground()

virtual void DrawColumnBackground | ( | CDC * | pDC,
 |  | CXTPGridColumn * | pColumn,
 |  | CRect | rcColumn,
 |  | BOOL & | bColumnPressed,
 |  | BOOL & | bDraggingFromHeader,
 |  | CXTPGridHeader * | pHeader = NULL )
 virtual

This method is called to draw the background of a column using the current column style.

Parameters
pDC | Pointer to the used device context.
pColumn | Pointer to the column whose background must be drawn.
rcColumn | Bounding rectangle of the column.
bColumnPressed | TRUE if the column is pressed by the user.
bDraggingFromHeader | TRUE if the column is being dragged from the header area.
pHeader | Pointer to the header that the column belongs to.

Reimplemented from CXTPGridPaintManager.

◆ DrawColumnText()

virtual void DrawColumnText | ( | CDC * | pDC,
 |  | CRect | rcText,
 |  | CString | strCaption,
 |  | int | nHeaderAlignment,
 |  | BOOL | bIsHeader,
 |  | BOOL | bColumnPressed )
 virtual

Draws text for the column header.

Parameters
pDC | Pointer to the used device context.
rcText | Size and position of the text to render.
strCaption | NULL-terminated string representing the caption text.
nHeaderAlignment | DT_ text alignment flags.
bIsHeader | TRUE if the column is to be rendered for the header.
bColumnPressed | TRUE if the column is pressed by the user.

Reimplemented from CXTPGridPaintManager.

◆ DrawFocusedRow()

virtual void DrawFocusedRow | ( | CDC * | pDC,
 |  | CRect | rcRow )
 virtual

Draws focused rows.

Parameters
pDC | Pointer to the used device context.
rcRow | Area rectangle coordinates.

Example:

CRect rcClient(GetParent()->GetClientRect());
CXTPGridHeader* pHeader = m_pColumns->GetGridHeader();
CXTPGridPaintManager* pPaintManager = m_pControl->GetPaintManager();
GetPaintManager()->DrawResizingRect(pDC, pHeader, rcClient);

Reimplemented from CXTPGridPaintManager.

◆ DrawGroupRow()

virtual void DrawGroupRow | ( | CDC * | pDC,
 |  | CXTPGridGroupRow * | pRow,
 |  | CRect | rcRow,
 |  | XTP_GRIDRECORDITEM_METRICS * | pMetrics )
 virtual

Draws a group row.

Parameters
pDC | Pointer to the used device context.
pRow | Pointer to the group row.
rcRow | Group row area rectangle coordinates.
pMetrics | Pointer to a metrics structure.

Example:

CXTPGridPaintManager* pPaintManager = m_pControl->GetPaintManager();
pDC->SetBkMode(TRANSPARENT);
pPaintManager->DrawGroupRow(pDC, this, rcRow);

Reimplemented from CXTPGridPaintManager.

◆ DrawTriangle()

virtual void DrawTriangle | ( | CDC * | pDC,
 |  | CRect | rcTriangle,
 |  | BOOL | bToDown,
 |  | BOOL | bDraggingFromHeader,
 |  | int | nShadowWidth,
 |  | BOOL | bColumnPressed )
 virtual

Draws a triangle that shows the sort order of the column.

Parameters
pDC | Pointer to the used device context.
rcTriangle | Triangle area rectangle coordinates.
bToDown | TRUE to turn the top of the triangle downward, FALSE to turn the top of the triangle upward.
bDraggingFromHeader | TRUE if the column is being dragged from the header area.
nShadowWidth | Size, in pixels, of the shadow to draw under the triangle image, or 0 to disable the shadow; the default value for this parameter is 0.
bColumnPressed | TRUE if the column is pressed by the user.

This function is used to draw a triangle image on the header of the column that is sorted. The triangle represents the direction of the sort: ascending or descending. The size of the triangle depends on the rectangle area provided.

Example:

// draw ascendant triangle
CRect rcTriangle;
rcTriangle.CopyRect(rcHeader);
rcTriangle.DeflateRect(40, 5, 5, 5);
DrawTriangle(pDC, rcTriangle, TRUE);

// draw descendant triangle
CRect rcTriangle;
rcTriangle.CopyRect(rcHeader);
rcTriangle.DeflateRect(40, 5, 5, 5);
DrawTriangle(pDC, rcTriangle, FALSE);

Reimplemented from CXTPGridPaintManager.

◆ FillGroupRowMetrics()

virtual void FillGroupRowMetrics | ( | CXTPGridGroupRow * | pRow,
 |  | XTP_GRIDRECORDITEM_METRICS * | pMetrics,
 |  | BOOL | bPrinting )
 virtual

Fills the font and color members of the metrics structure for a specified group row.

Parameters
pRow | Pointer to the group row.
pMetrics | Pointer to the metrics structure to be filled.
bPrinting | TRUE if printing mode is enabled.

Reimplemented from CXTPGridPaintManager.

◆ GetRowHeight()

virtual int GetRowHeight | ( | CDC * | pDC,
 |  | CXTPGridRow * | pRow )
 virtual

Retrieves the default row height for print mode (i.e.

the height of the default rectangle where the row's items will be drawn).

Parameters
pDC | Pointer to the used device context.
pRow | Pointer to a grid row.
Returns
The default row height for print mode.

Example:

int nRowHeight = GetRowHeight(pDC, pRow)

Reimplemented from CXTPGridPaintManager.

The documentation for this class was generated from the following file:
  • XTPTrackThemeOffice2013.h


Toolkit Pro: CXTPTrackThemeOfficeXP Class Reference

Public Member Functions | List of all members
CXTPTrackThemeOfficeXP Class Reference

CXTPTrackThemeOfficeXP is a CXTPTrackPaintManager derived class that represents an Office XP style theme. More...

Inheritance diagram for CXTPTrackThemeOfficeXP:
[legend]

Public Member Functions

CXTPTrackThemeOfficeXP ()
Default paint manager constructor, handles properties initialization.
virtual void | DrawColumnBackground (CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, BOOL &bColumnPressed, BOOL &bDraggingFromHeader, CXTPGridHeader *pHeader=NULL)
This method is called to draw the background of a column using the current column style.
- Public Member Functions inherited from CXTPTrackPaintManager
CXTPTrackPaintManager ()
Creates a CXTPTrackPaintManager object.
~CXTPTrackPaintManager ()
CXTPTrackPaintManager destructor, handles cleanup and deallocation.
void | RefreshMetrics ()
Initializes all drawings defaults (fonts, colors, etc.).
virtual void | DrawTrackHeader (CDC *pDC)
Call this function to draw the track header.
virtual void | DrawMarkers (CDC *pDC)
Call this function to draw the markers.
virtual void | DrawTimeLine (CDC *pDC)
Call this function to draw the time line.
virtual CString | FormatTimeLineTick (int nPosition, COLORREF &clrTick, int &nTickLength)
Call this function to format the time and tick marker relative to a time line position.
virtual CString | FormatTime (int nPosition)
Call this function to format the time and tick marker relative to a time line position.
- Public Member Functions inherited from CXTPGridPaintManager
CXTPGridPaintManager ()
Default CXTPGridPaintManager constructor, handles properties initialization.
virtual | ~CXTPGridPaintManager ()
Default CXTPGridPaintManager destructor, handles member items deallocation.
virtual void | SetGridControl (CXTPGridControl *pControl)
Sets the associated Grid control for the paint manager.
virtual void | LoadGlyphs ()
Loads the default images used by the Grid control.
virtual int | GetRowHeight (CDC *pDC, CXTPGridRow *pRow)
Retrieves the default row height for print mode (i.e.
virtual int | GetRowHeight (CDC *pDC, CXTPGridRow *pRow, int nTotalWidth)
Retrieves the default row height for print mode (i.e.
int | GetRowHeightEx (CDC *pDC, CXTPGridRow *pRow, int nTotalWidth, const BOOL firstLevel=TRUE)
Retrieves the default row height for print mode (i.e.
int | GetItemHeight (XTP_GRIDRECORDITEM_DRAWARGS &drawArgs, int nWidth)
Retrieves the height of a record item for a given width.
BOOL | FindRowAdjacentToMergedEx (const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, int &nAdjRowIndex, BOOL bUpward)
Searches the topmost or bottommost row depending on the height of the current row.
int | FindRowAdjacentToMerged (const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, BOOL bUpward)
Wrapper for the FindRowAdjacentToMergedEx method.
int | RecalcTotalHightOfMergedRows (CXTPGridColumns *pColumns, CDC *pDC, CXTPGridRow *pRow, int nRowHeight, int nTotalWidth)
Recalculates row height according to the height of merged items.
virtual int | GetPreviewItemHeight (CDC *pDC, CXTPGridRow *pRow, int nWidth, int nHeight)
Retrieves the height of a preview item for print mode.
virtual int | GetHeaderHeight ()
Gets the column header height.
virtual int | GetHeaderHeight (CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0)
Calculates the optimal header height.
virtual void | SetHeaderHeight (int nHeight)
Sets the column header height.
virtual int | GetFooterHeight (CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0)
Calculates the optimal footer height.
virtual COLORREF | GetControlBackColor (CXTPGridControl *pControl)
Retrieves the parent Grid control's background color.
virtual void | FillRow (CDC *pDC, CXTPGridRow *pRow, CRect rcRow)
Fills a specified row with its background color.
virtual void | DrawGrid (CDC *pDC, XTPGridOrientation orientation, CRect rcGrid)
Draws a grid for the control.
virtual void | DrawFreezeColsDivider (CDC *pDC, const CRect &rc, CXTPGridControl *pControl, CXTPGridRow *pRow=NULL)
Draws a freeze column divider.
virtual void | DrawVerticalTimeLineMarker (CDC *pDC, int xPos, CXTPGridControl *pControl, COLORREF color=RGB(0, 255, 0))
Draws a vertical timeline marker.
virtual void | DrawGroupRow (CDC *pDC, CXTPGridGroupRow *pRow, CRect rcRow, XTP_GRIDRECORDITEM_METRICS *pMetrics)
Draws a group row.
virtual void | FillGroupRowMetrics (CXTPGridGroupRow *pRow, XTP_GRIDRECORDITEM_METRICS *pMetrics, BOOL bPrinting)
Fills the font and color members of the metrics structure for a specified group row.
virtual void | FillIndent (CDC *pDC, CRect rcRow)
Fills an indent area by its background.
virtual void | FillItemShade (CDC *pDC, CRect rcItem)
Fills an item shade by its background if necessary.
virtual void | FillHeaderControl (CDC *pDC, CRect rcHeader)
Fills a column header control area by its background.
virtual void | FillFooter (CDC *pDC, CRect rcFooter)
Fills a column footer control area by its background.
virtual void | DrawColumnText (CDC *pDC, CRect rcText, CString strCaption, int nHeaderAlignment, BOOL bIsHeader, BOOL bColumnPressed)
Draws text for the column header.
virtual void | DrawColumn (CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn, BOOL bDrawExternal=FALSE, int nShadowWidth=0)
Draws a column header with all related attributes (sort order, icon, etc.).
virtual void | DrawColumnFooterDivider (CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn)
Draws the column footer divider.
virtual void | DrawColumnFooter (CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn)
Draws the column footer with all related attributes (e.g.
virtual BOOL | IsColumHotTrackingEnabled () const
Determines if hot tracking is enabled for the current column style.
virtual void | DrawFocusedRow (CDC *pDC, CRect rcRow)
Draws focused rows.
virtual void | FillGroupByControl (CDC *pDC, CRect &rcGroupBy)
Draws the Group By box.
CXTPImageManager * | GetGlyphs () const
Gets a pointer to the additional image list with glyphs.
void | DrawHorizontalLine (CDC *pDC, int xPos, int yPos, int cx, COLORREF clr)
Draws a horizontal line.
void | DrawVerticalLine (CDC *pDC, int xPos, int yPos, int cy, COLORREF clr)
Draws a vertical line.
virtual void | DrawTriangle (CDC *pDC, CRect rcTriangle, BOOL bToDown, BOOL bDraggingFromHeader, int nShadowWidth, BOOL bColumnPressed)
Draws a triangle that shows the sort order of the column.
void | DrawConnector (CDC *pDC, CPoint ptFrom, CPoint ptTo)
Draws a column connector for the Group By box.
virtual CSize | DrawCollapsedBitmap (CDC *pDC, const CXTPGridRow *pRow, CRect &rcBitmap)
Draws a collapsed bitmap.
virtual int | DrawBitmap (CDC *pDC, CXTPGridControl *pControl, CRect rcColumn, int iImage)
Draws a bitmap.
virtual int | DrawColumnIcon (CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, CRect rcIcon, int iIcon)
Draws an icon for a column.
virtual CSize | DrawGlyph (CDC *pDC, CRect rcColumn, int iImage)
Draws the standard glyphs of the Grid control.
virtual CSize | DrawShellIcon (CDC *pDC, CRect rcColumn, int iImage)
Draws the shell icon.
void | EnablePreviewMode (BOOL bIsPreviewMode)
Enables/disables preview mode for the control.
BOOL | IsPreviewMode () const
Determines if preview mode is enabled/disabled for the control.
CFont * | GetTextFont ()
Gets the default text font used for control items.
int | SetMaxPreviewLines (int nMaxLines)
Sets the maximum number of lines of text for a preview item.
int | GetMaxPreviewLines ()
Gets the maximum number of lines of text for a preview item.
int | GetPreviewLinesCount (CDC *pDC, CRect &rcText, const CString &strText)
Calculates the number of lines required to draw a specified preview text string, taking into account the maximum number of lines of text for a preview item.
BOOL | IsGridVisible (BOOL bVertical) const
Determines the visibility of specified grid lines.
BOOL | IsGridVisible (XTPGridOrientation orientation) const
Determines the visibility of specified grid lines.
void | SetColumnStyle (XTPGridColumnStyle columnStyle)
Sets the header style.
XTPGridColumnStyle | GetColumnStyle () const
Gets the header style.
void | SetColumnOffice2007CustomThemeBaseColor (COLORREF clrBaseColor)
Sets the header's custom theme base color for Office2007 column style.
COLORREF | GetColumnOffice2007CustomThemeBaseColor () const
Gets the header's custom theme base color for Office2007 column style.
void | SetTextFont (LOGFONT &lf)
Creates and sets the default text font.
void | SetCaptionFont (LOGFONT &lf)
Creates and sets the default caption font.
void | SetPreviewIndent (int nLeft, int nTop, int nRight, int nBottom)
Sets the preview item indent.
virtual void | DrawInplaceButton (CDC *pDC, CXTPGridInplaceButton *pButton)
Draws the in-place button of the Grid control.
virtual BOOL | DrawInplaceComboButton (CDC *pDC, CRect *pRc)
Draws the combo button of the Grid control.
virtual BOOL | DrawInplaceExpandButton (CDC *pDC, CRect *pRc)
Draws the expand button of the Grid control.
virtual BOOL | DrawInplaceSpinButton (CDC *pDC, CRect *pRc)
Draws the spin button of the Grid control.
virtual void | DrawTreeStructure (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CRect rcItem, CSize sizeGlyph)
Draws tree elements of the Grid control.
virtual void | DrawItemBitmap (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CRect &rcItem, int nImage)
Draws an item bitmap.
virtual void | DrawItemCaption (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics)
Draws an item caption.
virtual void | DrawRowNumber (CDC *pDC, CRect rcNumber, CXTPGridRow *pRow)
Draws a row number.
virtual void | DrawItemControl (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CXTPGridRecordItemControl *pControl, CRect &rcItem)
Draws an item control.
BOOL | IsFixedRowHeight () const
Determines if the paint manager supports fixed or variable row height.
void | SetFixedRowHeight (BOOL bFixedRowHeight)
Sets if the paint manager supports fixed or variable row height.
BOOL | IsColumnWidthWYSIWYG () const
Determines if the paint manager supports column width WYSIWYG mode.
BOOL | IsLastColumnWidthWYSIWYG () const
Determines if the paint manager supports last column width WYSIWYG mode.
BOOL | IsShowWYSIWYGMarkers () const
Determines if the paint manager shows WYSIWYG page-end markers.
void | ShowWYSIWYGMarkers (BOOL bSet)
Sets if the paint manager shows WYSIWYG page-end markers.
void | SetColumnWidthWYSIWYG (BOOL bColumnWidthWYSIWYG)
Sets if the paint manager supports column width WYSIWYG mode.
void | SetLastColumnWidthWYSIWYG (BOOL bColumnWidthWYSIWYG)
Sets if the paint manager supports last column width WYSIWYG mode.
BOOL | IsFixedInplaceButtonHeight () const
Determines if the paint manager supports fixed or variable in-place button height.
void | SetInplaceButtonHeight (BOOL bFixedInplaceButtonHeight)
Sets if the paint manager supports fixed or variable in-place button height.
int | GetFreezeColsDividerStyle () const
Gets the style of the freeze columns divider line.
void | SetFreezeColsDividerStyle (int nStyle)
Sets the style for the freeze columns divider line.
virtual BOOL | OnDrawAction (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs)
Override this method to perform custom activities for the item before processing it.
virtual void | DrawNoGroupByText (CDC *pDC, CRect rcItem)
Draws the "No items" text message in the Group By area when there are no items inside it.
BOOL | IsDrawGridForEmptySpace () const
Determines if the grid fills empty space after body rows.
void | SetDrawGridForEmptySpace (BOOL bDrawGrid)
Sets if the grid fills empty space after body rows.
BOOL | IsPrintGroupRowIcon () const
Determines if the group row collapse-expand icon is drawn in print mode.
void | SetPrintGroupRowIcon (BOOL bDraw)
Sets if the group row collapse-expand icon is drawn in print mode.
BOOL | IsColumnPlusMinusSign () const
Determines if columns use expand/collapse icons (+/-) or directional arrows.
void | SetColumnPlusMinusSign (BOOL bDraw)
Specifies if columns use expand/collapse icons (+/-) or directional arrows.
virtual int | CalculateRowHeight (CDC *pDC, const CString &strText, int nMaxWidth, BOOL bWordBreak=TRUE)
Calculates the height required for a rectangle bounding multi-line text to draw the multi-line text when the width of the rectangle is fixed.
void | DrawSectionDivider (CDC *pDC, const CRect &rc, XTPGridSectionDividerPosition dividerPosition, XTPGridSectionDividerStyle dividerStyle, CXTPPaintManagerColor dividerColor)
Draws the divider between grid sections (e.g.
int | GetSectionDividerHeight (XTPGridFixedRowsDividerStyle dividerStyle)
Gets the height of the section divider.
BOOL | IsUseDropMarker () const
Determines if a drop marker will be used when dragging and dropping.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPTrackPaintManager
COLORREF | m_clrWorkArea
The color of the work area.
COLORREF | m_clrTrackHeader
The track header color.
COLORREF | m_clrTrackTimeArea
The track time area color.
COLORREF | m_clrTimeHeaderDarkDark
The header deep dark color.
COLORREF | m_clrTimeHeaderDark
The header dark color.
COLORREF | m_clrTimeSliderBackground
The slider background color.
COLORREF | m_clrTimeHeaderDivider
The header divider color.
COLORREF | m_clrScrollBarLight
The scrollbar light color.
COLORREF | m_clrScrollBarDark
The scrollbar dark color.
COLORREF | m_clrSelectedArea
The color of the selected area.
COLORREF | m_clrMarker
The color of the marker.
COLORREF | m_clrTimeLineTick
The color of a time line tick.
COLORREF | m_clrMarkerBorder
The color of a time line marker's border.
COLORREF | m_clrMarkerBack
The color of a time line marker's back.
COLORREF | m_clrTrackMarkerBorder
The color of a track marker's border.
COLORREF | m_clrTrackMarkerText
The color of a track marker's text.
COLORREF | m_clrTrackMarkerTextBack
The color of a track marker's text back.
COLORREF | m_clrTrackMarkerTextBorder
The color of a track marker's text border.
COLORREF | m_clrTimeLinePosition
The color of a marked position on a time line.
COLORREF | m_clrTimeHeaderBorder
The color of a time line header's border.
COLORREF | m_clrScrollBarBorderDark
The scrollbar border dark color.
COLORREF | m_clrScrollBarBorderLight
The scrollbar border light color.
COLORREF | m_clrWorkAreaScrollBarLight
The workarea scrollbar light color.
COLORREF | m_clrWorkAreaScrollBarDark
The workarea scrollbar dark color.
COLORREF | m_clrWorkAreaScrollBarBorder
The workarea scrollbar border color.
- Public Attributes inherited from CXTPGridPaintManager
CXTPFont | m_xtpFontText
Grid items default text.
CXTPFont | m_xtpFontBoldText
Grid items default bold text.
CXTPFont | m_xtpFontCaption
Column header caption font.
CXTPFont | m_xtpFontPreview
Column header caption font.
CXTPGridHyperlinkStyle * | m_pHyperlinkStyle
Style for links.
CXTPGridHyperlinkStyle * | m_pHyperlinkHoverStyle
Style for hovered links.
CXTPPaintManagerColor | m_clrHighlight
Background color of the highlighted row.
CXTPPaintManagerColor | m_clrBoldText
Grid items bold text color.
CXTPPaintManagerColor | m_clrBoldTextHighlight
Grid items bold text highlight color.
CXTPPaintManagerColor | m_clrWindowText
Grid items default text color.
CXTPPaintManagerColor | m_clrHighlightText
Text color of the highlighted text.
CXTPPaintManagerColor | m_clrHeaderControl
Background color of the grid header.
CXTPPaintManagerColor | m_clrCaptionText
Column header text color.
CXTPPaintManagerColor | m_clrCaptionTextPressed
Column header text color when pressed.
CXTPPaintManagerColor | m_clrControlBack
Background color of the control grid area.
CXTPPaintManagerColor | m_clrGroupRowText
Row text color.
CXTPPaintManagerColor | m_clrGroupShadeBack
Group row background color when indentation shade is enabled.
CXTPPaintManagerColor | m_clrGroupShadeText
Group row foreground color when indentation shade is enabled.
CXTPPaintManagerColor | m_clrGroupShadeBorder
Color for group border's shade.
CXTPPaintManagerColor | m_clrGroupBoxBack
Color of group box.
CXTPPaintManagerColor | m_clrControlDark
Dark background color of the Grid control (used on Group By area).
CXTPPaintManagerColor | m_clrControlLightLight
Light background color used for drawing shades (used on column header area).
CXTPPaintManagerColor | m_clrHotDivider
Color of the column hot divider window (two arrows).
CXTPPaintManagerColor | m_clrIndentControl
Color of the tree indentation area.
CXTPPaintManagerColor | m_clrItemShade
Color of the shade on sorted by column items.
CXTPPaintManagerColor | m_clrBtnFace
Standard button face color.
CXTPPaintManagerColor | m_clrBtnText
Standard button text color.
CXTPPaintManagerColor | m_clrPreviewText
Preview text color.
CXTPPaintManagerColor | m_clrSelectedRow
Selected row background color.
CXTPPaintManagerColor | m_clrSelectedRowText
Selected row text color.
CXTPPaintManagerColor | m_clrBtnFacePressed
Standard button face color when pressed.
CXTPPaintManagerColor | m_clrConnector
Header column connector line color.
CXTPPaintManagerColor | m_clrDisableBitmapLightest
The lightest color of bitmap which covers disabled grid.
CXTPPaintManagerColor | m_clrDisableBitmapDarkest
The darkest color of bitmap which covers disabled grid.
CXTPPaintManagerColorGradient | m_grcGradientColumn
Color of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColorGradient | m_grcGradientColumnHot
HotTracking Color of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColorGradient | m_grcGradientColumnPushed
Pushed Color of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColor | m_clrGradientColumnShadow
Bottom shadow of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColor | m_clrGradientColumnSeparator
Separator of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColor | m_crlNoGroupByText
A color for "No items" text in GroupBy area (see m_strNoGroupBy member).
CXTPPaintManagerColor | m_clrFreezeColsDivider
Freeze Columns Divider color.
COLORREF | m_clrColumnOffice2007CustomTheme
Base color for Office2007 custom theme.
COLORREF | m_clrFormulaSum
Color for Formula Sum fields.
COLORREF | m_clrFormulaSubSum
Color for Formula SubSum fields.
COLORREF | m_clrAlternativeBackground
Color for Alternative Row Background.
BOOL | m_bUseAlternativeBackground
TRUE to use Alternative Row Background, FALSE otherwise.
BOOL | m_bAllowMergeCells
TRUE to Allow Merge Cells, FALSE otherwise.
int | m_nTextIndentForGroupRowsWithNoIcon
Specifies Text indent if a group row icon is not used.
int | m_nTreeIndent
Tree indentation.
int | m_nTreeStructureStyle
Tree structure style.
int | m_nTreeTextIndentRowParent
Text indent, in pixels, for rows with children.
int | m_nTreeTextIndentRowChildren
Text indent, in pixels, for rows without children.
int | m_nTreeTextIndent
Text indent, in pixels, for rows that are neither parent nor children.
int | m_nTreeTextIndentGroupRow
Text indent, in pixels, for group rows.
BOOL | m_bGroupRowTextBold
TRUE to draw group rows with bold text.
BOOL | m_bShadeGroupHeadings
TRUE to show the indentation shade, FALSE otherwise.
BOOL | m_bShadeSortColumn
TRUE to show the items shade in the sorted by column, FALSE otherwise.
BOOL | m_bHotTracking
TRUE to allow column hot tracking.
BOOL | m_bInvertColumnOnClick
TRUE to invert column on click.
CString | m_strNoItems
A string which contains customized "No Items" text for displaying in view when there are no visible rows.
CString | m_strSortBy
A string which contains customized "Sort By" text for displaying in tooltip.
CString | m_strIncreasing
A string which contains customized "Increasing" text for displaying in tooltip.
CString | m_strDecreasing
A string which contains customized "Decreasing" text for displaying in tooltip.
CString | m_strNoGroupBy
A string which contains customized "No items" text message for displaying in Group By area when there are no items inside it.
CString | m_strNoFieldsAvailable
A string which contains customized "No Fields Available" text message for displaying in Field Chooser.
CString | m_strExpand
A string which contains customized "Expand" text for displaying in tooltip.
CString | m_strCollapse
A string which contains customized "Collapse" text for displaying in tooltip.
BOOL | m_bHideSelection
TRUE when hiding Grid control's selection by drawing selected items as others, FALSE otherwise.
BOOL | m_bPrintSortTriangle
TRUE to show the sort triangle in printout.
BOOL | m_bRevertAlignment
TRUE to revert column alignments.
BOOL | m_bUseEditTextAlignment
TRUE to automatically apply edit alignment using column alignment.
BOOL | m_bShowLockIcon
TRUE to show the lock icon, FALSE to hide.
BOOL | m_bUseShellIcon
TRUE to use the shell icon, FALSE otherwise.
int | m_iRecOrRowStart
Start position in numbering (0 or 1 or something user want).
BOOL | m_bRecOrRowNum
TRUE to display record number if support mode is used, FALSE to display row number.
BOOL | m_bMakeUpper
TRUE to display column header and group row text in all caps.
XTPGridTreeStructureStyle | m_treeStructureStyle
Tree structure style.
CRect | m_rcPreviewIndent
Preview indentation.
int | m_nFixedColumnsIndent
Fixed Column total width.
BOOL | m_bMoveScrollbarOnFixedColumnsIndent
Move Scrollbar right follow FixedColumnsIndent.
BOOL | m_bThemedInplaceButtons
Draw in-place buttons using current theme settings.
BOOL | m_bBaseTreeIndent
TRUE to add Extra Tree indentation to cover initial TreeColumn.
CUIntArray | m_arStartCol
Start column in each virtual page.
int | m_PrintPageWidth
Width of print page (run-time)
BOOL | m_bPrintVirtualPageNumber
TRUE to print horizontal page number.
BOOL | m_bPrintPageRectangle
TRUE to draw rectangle around page.
int | m_RecordNumberWidth
Column width for row/record numbers.
BOOL | m_bForceDynamicMarkupForCell
TRUE if use Markup for Grid Record Item.
BOOL | m_bForceShowDropMarker
TRUE if Force Show Drop Marker.
BOOL | m_bShowNonActiveInPlaceButton
TRUE if use Show Non-Active In-Place Button (Combo, Expand, Spin).
BOOL | m_bPrintWatermark
TRUE to print watermark.
BOOL | m_bUseGroupRowSelectionState
TRUE if use GroupSelectionState Glyph.
BOOL | m_bForceShowTooltip
TRUE if use show tooltip for any cell width case.
BOOL | m_bCleanTooltip
TRUE if use show tooltip without markup.
BOOL | m_bGrayIfDisable
TRUE is disable draw in gray (standard behavior).
int | m_nRowHeightDefault
The default row height.
BOOL | m_bCompactText
TRUE to ignore Icon for Narrow column to show more text.
BOOL | m_bUseDropMarker
FALSE to not draw drop marked when dragging/dropping, TRUE by default.
BOOL | m_bSortTriangleOffsetFromRight
Offset of sort triangle.
int | m_nTreeColumnLineLength
This is the extra line length to apply to tree column lines if there is no expand button.
int | m_nBaseParentRecordIndent
This is initial number of pixels a parent node will be indented when in a group.
- Protected Member Functions inherited from CXTPTrackPaintManager
- Protected Member Functions inherited from CXTPGridPaintManager
virtual void | DrawTextLine (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nFlag, int &nCharCounter, int &nHyperlinkCounter)
Draws a line of text with respect to the drawing rectangle.
virtual int | DrawString (int *pnCurrDrawPos, CDC *pDC, const CString &strDraw, CRect rcDraw, UINT nFormat)
Draw a simple string into rectangle.
virtual void | DrawGridPattern (CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush)
Generates a custom grid pattern if necessary.
virtual void | DrawGridPattern (CDC *pDC, CXTPBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush)
Generates a custom grid pattern if necessary.
virtual void | DrawGridPattern (CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr)
Generates a custom grid pattern.
virtual void | DrawInplaceButtonFrame (CDC *pDC, CXTPGridInplaceButton *pButton)
Draws the in-place button frame.
virtual BOOL | DrawInplaceButtonIcon (CDC *pDC, CXTPGridInplaceButton *pButton)
Draws the in-place button icon.
virtual int | CalcColumnHeight (CDC *pDC, CXTPGridColumn *pColumn, int nTotalWidth=0)
Calculates the optimal height for a specified column.
virtual void | DrawMultiLineText (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, BOOL bWordBreak=TRUE)
Draws multi-line text.
virtual void | DrawSingleLineText (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nStartPos, int nEndPos, int nActualWidth)
Draws single-line text.
virtual int | DrawLink (int *pnCurrDrawPos, XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CXTPGridHyperlink *pHyperlink, CString strText, CRect rcLink, int nFlag, BOOL bTrim=FALSE)
Draws a hyperlink string using hyperlink text settings (i.e.
- Protected Attributes inherited from CXTPGridPaintManager
int | m_nRowHeight
Grid row default height.
int | m_nHeaderHeight
Column header height.
int | m_nFooterHeight
Column footer height.
int | m_nGroupGridLineHeight
The height of the group grid line.
CXTPImageManager * | m_pGlyphs
An additional image list for the Grid control.
BOOL | m_bIsPreviewMode
TRUE to show the item preview, FALSE to hide.
int | m_nResizingWidth
The width of the column resizing marker area.
int | m_nMaxPreviewLines
Restrict maximum lines for preview text.
CSize | m_szGlyph
Glyph size.
CXTPBrush | m_xtpBrushTreeStructure
Brush to draw tree nodes.
CXTPBrush | m_xtpBrushGroupGridLineStyle
Brush to draw group row grid lines.
int | m_nFreezeColsDividerStyle
A set of flags from XTPGridFreezeColsDividerStyle.
BOOL | m_bFixedRowHeight
TRUE if fixed rows used.
BOOL | m_bColumnWidthWYSIWYG
TRUE if columns width WYSIWYG mode used.
BOOL | m_bShowWYSIWYGMarkers
TRUE if in non-print mode header show red page-end markers.
BOOL | m_bLastColumnWidthWYSIWYG
TRUE if last column width WYSIWYG mode used.
BOOL | m_bDrawGridForEmptySpace
TRUE if grid fills the empty space (if any) after the body rows.
BOOL | m_bPrintGroupRowIcon
TRUE if printout draw collapse-expand icon for group row.
BOOL | m_bColumnPlusMinusSign
TRUE if expand/collapse icons are used, FALSE if directional arrows are used.
BOOL | m_bFixedInplaceButtonHeight
TRUE if fixed in-place button height is used.
XTPGridGridStyle | m_nGroupGridLineStyle
Current style for group row grid lines.
XTPGridColumnStyle | m_columnStyle
Column drawing style.
CXTPWinThemeWrapper * | m_themeHeader
Header theme wrapper.
CXTPWinThemeWrapper * | m_themeButton
In-place button theme wrapper.
CXTPWinThemeWrapper * | m_themeCombo
Combo box in-place button theme wrapper.
CXTPWinThemeWrapper * | m_themeSpin
Spin in-place button theme wrapper.
CXTPGridControl * | m_pControl
Pointer to the Grid control object.
CXTPMarkupUIElement * | m_pMarkupUIElement_NoGroupBy
The no group by markup UI element.
CString | m_strMarkupUIElement_NoGroupBy
The no group by markup UI element string.
CXTPBrush | m_xtpBrushVeriticalGrid
Brush to draw vertical grid lines.
CXTPBrush | m_xtpBrushHorizontalGrid
Brush to draw horizontal grid lines.
XTPGridGridStyle m_nGridLineStylePreviousV
Previous style for vertical grid lines.
XTPGridGridStyle m_nGridLineStylePreviousH
Previous style for horizontal grid lines.

Detailed Description

CXTPTrackThemeOfficeXP is a CXTPTrackPaintManager derived class that represents an Office XP style theme.

Member Function Documentation

◆ DrawColumnBackground()

virtual void DrawColumnBackground | ( | CDC * | pDC,
 |  | CXTPGridColumn * | pColumn,
 |  | CRect | rcColumn,
 |  | BOOL & | bColumnPressed,
 |  | BOOL & | bDraggingFromHeader,
 |  | CXTPGridHeader * | pHeader = NULL )
 virtual

This method is called to draw the background of a column using the current column style.

Parameters
pDC | Pointer to the used device context.
pColumn | Pointer to the column whose background must be drawn.
rcColumn | Bounding rectangle of the column.
bColumnPressed | TRUE if the column is pressed by the user.
bDraggingFromHeader | TRUE if the column is being dragged from the header area.
pHeader | Pointer to the header that the column belongs to.

Reimplemented from CXTPGridPaintManager.

The documentation for this class was generated from the following file:
  • XTPTrackThemeOfficeXP.h


Toolkit Pro: CXTPTrackThemeResource Class Reference

Public Member Functions | Protected Member Functions | List of all members
CXTPTrackThemeResource Class Reference

CXTPTrackThemeResource is a CXTPTrackPaintManager derived class that represents a Resource style theme. More...

Inheritance diagram for CXTPTrackThemeResource:
[legend]

Public Member Functions

CXTPTrackThemeResource ()
Default paint manager constructor, handles properties initialization.
virtual void | RefreshMetrics ()
This method is called to refresh the visual metrics of the track control.
CSize | DrawCollapsedBitmap (CDC *pDC, const CXTPGridRow *pRow, CRect &rcBitmap)
Draws a collapsed bitmap.
virtual void | DrawNoGroupByText (CDC *pDC, CRect rcItem)
This method used to draw a "No items" text message in the Group By area when there are no items inside it.
virtual void | FillFooter (CDC *pDC, CRect rcFooter)
Fills the column footer control area by its background.
virtual void | DrawTriangle (CDC *pDC, CRect rcTriangle, BOOL bToDown, int nShadowWidth, BOOL bColumnPressed)
Draws a triangle that shows the sort order of the column.
virtual void | DrawColumnFooterDivider (CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn)
Draws the column footer divider.
virtual void | DrawColumnText (CDC *pDC, CRect rcText, CString strCaption, int nHeaderAlignment, BOOL bIsHeader, BOOL bColumnPressed)
Draws text for the column header.
void | DrawSectionDivider (CDC *pDC, const CRect &rc, XTPGridSectionDividerPosition dividerPosition, XTPGridSectionDividerStyle dividerStyle, CXTPPaintManagerColor dividerColor)
Draws the divider between grid sections (e.g.
- Public Member Functions inherited from CXTPTrackPaintManager
CXTPTrackPaintManager ()
Creates a CXTPTrackPaintManager object.
~CXTPTrackPaintManager ()
CXTPTrackPaintManager destructor, handles cleanup and deallocation.
virtual void | DrawTrackHeader (CDC *pDC)
Call this function to draw the track header.
virtual void | DrawMarkers (CDC *pDC)
Call this function to draw the markers.
virtual void | DrawTimeLine (CDC *pDC)
Call this function to draw the time line.
virtual CString | FormatTimeLineTick (int nPosition, COLORREF &clrTick, int &nTickLength)
Call this function to format the time and tick marker relative to a time line position.
virtual CString | FormatTime (int nPosition)
Call this function to format the time and tick marker relative to a time line position.
- Public Member Functions inherited from CXTPGridPaintManager
CXTPGridPaintManager ()
Default CXTPGridPaintManager constructor, handles properties initialization.
virtual | ~CXTPGridPaintManager ()
Default CXTPGridPaintManager destructor, handles member items deallocation.
virtual void | SetGridControl (CXTPGridControl *pControl)
Sets the associated Grid control for the paint manager.
virtual void | LoadGlyphs ()
Loads the default images used by the Grid control.
virtual int | GetRowHeight (CDC *pDC, CXTPGridRow *pRow)
Retrieves the default row height for print mode (i.e.
virtual int | GetRowHeight (CDC *pDC, CXTPGridRow *pRow, int nTotalWidth)
Retrieves the default row height for print mode (i.e.
int | GetRowHeightEx (CDC *pDC, CXTPGridRow *pRow, int nTotalWidth, const BOOL firstLevel=TRUE)
Retrieves the default row height for print mode (i.e.
int | GetItemHeight (XTP_GRIDRECORDITEM_DRAWARGS &drawArgs, int nWidth)
Retrieves the height of a record item for a given width.
BOOL | FindRowAdjacentToMergedEx (const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, int &nAdjRowIndex, BOOL bUpward)
Searches the topmost or bottommost row depending on the height of the current row.
int | FindRowAdjacentToMerged (const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, BOOL bUpward)
Wrapper for the FindRowAdjacentToMergedEx method.
int | RecalcTotalHightOfMergedRows (CXTPGridColumns *pColumns, CDC *pDC, CXTPGridRow *pRow, int nRowHeight, int nTotalWidth)
Recalculates row height according to the height of merged items.
virtual int | GetPreviewItemHeight (CDC *pDC, CXTPGridRow *pRow, int nWidth, int nHeight)
Retrieves the height of a preview item for print mode.
virtual int | GetHeaderHeight ()
Gets the column header height.
virtual int | GetHeaderHeight (CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0)
Calculates the optimal header height.
virtual void | SetHeaderHeight (int nHeight)
Sets the column header height.
virtual int | GetFooterHeight (CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0)
Calculates the optimal footer height.
virtual COLORREF | GetControlBackColor (CXTPGridControl *pControl)
Retrieves the parent Grid control's background color.
virtual void | FillRow (CDC *pDC, CXTPGridRow *pRow, CRect rcRow)
Fills a specified row with its background color.
virtual void | DrawGrid (CDC *pDC, XTPGridOrientation orientation, CRect rcGrid)
Draws a grid for the control.
virtual void | DrawFreezeColsDivider (CDC *pDC, const CRect &rc, CXTPGridControl *pControl, CXTPGridRow *pRow=NULL)
Draws a freeze column divider.
virtual void | DrawVerticalTimeLineMarker (CDC *pDC, int xPos, CXTPGridControl *pControl, COLORREF color=RGB(0, 255, 0))
Draws a vertical timeline marker.
virtual void | DrawGroupRow (CDC *pDC, CXTPGridGroupRow *pRow, CRect rcRow, XTP_GRIDRECORDITEM_METRICS *pMetrics)
Draws a group row.
virtual void | FillGroupRowMetrics (CXTPGridGroupRow *pRow, XTP_GRIDRECORDITEM_METRICS *pMetrics, BOOL bPrinting)
Fills the font and color members of the metrics structure for a specified group row.
virtual void | FillIndent (CDC *pDC, CRect rcRow)
Fills an indent area by its background.
virtual void | FillItemShade (CDC *pDC, CRect rcItem)
Fills an item shade by its background if necessary.
virtual void | FillHeaderControl (CDC *pDC, CRect rcHeader)
Fills a column header control area by its background.
virtual void | DrawColumn (CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn, BOOL bDrawExternal=FALSE, int nShadowWidth=0)
Draws a column header with all related attributes (sort order, icon, etc.).
virtual void | DrawColumnFooter (CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn)
Draws the column footer with all related attributes (e.g.
virtual BOOL | IsColumHotTrackingEnabled () const
Determines if hot tracking is enabled for the current column style.
virtual void | DrawFocusedRow (CDC *pDC, CRect rcRow)
Draws focused rows.
virtual void | FillGroupByControl (CDC *pDC, CRect &rcGroupBy)
Draws the Group By box.
CXTPImageManager * | GetGlyphs () const
Gets a pointer to the additional image list with glyphs.
void | DrawHorizontalLine (CDC *pDC, int xPos, int yPos, int cx, COLORREF clr)
Draws a horizontal line.
void | DrawVerticalLine (CDC *pDC, int xPos, int yPos, int cy, COLORREF clr)
Draws a vertical line.
virtual void | DrawTriangle (CDC *pDC, CRect rcTriangle, BOOL bToDown, BOOL bDraggingFromHeader, int nShadowWidth, BOOL bColumnPressed)
Draws a triangle that shows the sort order of the column.
void | DrawConnector (CDC *pDC, CPoint ptFrom, CPoint ptTo)
Draws a column connector for the Group By box.
virtual int | DrawBitmap (CDC *pDC, CXTPGridControl *pControl, CRect rcColumn, int iImage)
Draws a bitmap.
virtual int | DrawColumnIcon (CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, CRect rcIcon, int iIcon)
Draws an icon for a column.
virtual CSize | DrawGlyph (CDC *pDC, CRect rcColumn, int iImage)
Draws the standard glyphs of the Grid control.
virtual CSize | DrawShellIcon (CDC *pDC, CRect rcColumn, int iImage)
Draws the shell icon.
void | EnablePreviewMode (BOOL bIsPreviewMode)
Enables/disables preview mode for the control.
BOOL | IsPreviewMode () const
Determines if preview mode is enabled/disabled for the control.
CFont * | GetTextFont ()
Gets the default text font used for control items.
int | SetMaxPreviewLines (int nMaxLines)
Sets the maximum number of lines of text for a preview item.
int | GetMaxPreviewLines ()
Gets the maximum number of lines of text for a preview item.
int | GetPreviewLinesCount (CDC *pDC, CRect &rcText, const CString &strText)
Calculates the number of lines required to draw a specified preview text string, taking into account the maximum number of lines of text for a preview item.
BOOL | IsGridVisible (BOOL bVertical) const
Determines the visibility of specified grid lines.
BOOL | IsGridVisible (XTPGridOrientation orientation) const
Determines the visibility of specified grid lines.
void | SetColumnStyle (XTPGridColumnStyle columnStyle)
Sets the header style.
XTPGridColumnStyle | GetColumnStyle () const
Gets the header style.
void | SetColumnOffice2007CustomThemeBaseColor (COLORREF clrBaseColor)
Sets the header's custom theme base color for Office2007 column style.
COLORREF | GetColumnOffice2007CustomThemeBaseColor () const
Gets the header's custom theme base color for Office2007 column style.
void | SetTextFont (LOGFONT &lf)
Creates and sets the default text font.
void | SetCaptionFont (LOGFONT &lf)
Creates and sets the default caption font.
void | SetPreviewIndent (int nLeft, int nTop, int nRight, int nBottom)
Sets the preview item indent.
virtual void | DrawInplaceButton (CDC *pDC, CXTPGridInplaceButton *pButton)
Draws the in-place button of the Grid control.
virtual BOOL | DrawInplaceComboButton (CDC *pDC, CRect *pRc)
Draws the combo button of the Grid control.
virtual BOOL | DrawInplaceExpandButton (CDC *pDC, CRect *pRc)
Draws the expand button of the Grid control.
virtual BOOL | DrawInplaceSpinButton (CDC *pDC, CRect *pRc)
Draws the spin button of the Grid control.
virtual void | DrawTreeStructure (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CRect rcItem, CSize sizeGlyph)
Draws tree elements of the Grid control.
virtual void | DrawItemBitmap (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CRect &rcItem, int nImage)
Draws an item bitmap.
virtual void | DrawItemCaption (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics)
Draws an item caption.
virtual void | DrawRowNumber (CDC *pDC, CRect rcNumber, CXTPGridRow *pRow)
Draws a row number.
virtual void | DrawItemControl (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CXTPGridRecordItemControl *pControl, CRect &rcItem)
Draws an item control.
BOOL | IsFixedRowHeight () const
Determines if the paint manager supports fixed or variable row height.
void | SetFixedRowHeight (BOOL bFixedRowHeight)
Sets if the paint manager supports fixed or variable row height.
BOOL | IsColumnWidthWYSIWYG () const
Determines if the paint manager supports column width WYSIWYG mode.
BOOL | IsLastColumnWidthWYSIWYG () const
Determines if the paint manager supports last column width WYSIWYG mode.
BOOL | IsShowWYSIWYGMarkers () const
Determines if the paint manager shows WYSIWYG page-end markers.
void | ShowWYSIWYGMarkers (BOOL bSet)
Sets if the paint manager shows WYSIWYG page-end markers.
void | SetColumnWidthWYSIWYG (BOOL bColumnWidthWYSIWYG)
Sets if the paint manager supports column width WYSIWYG mode.
void | SetLastColumnWidthWYSIWYG (BOOL bColumnWidthWYSIWYG)
Sets if the paint manager supports last column width WYSIWYG mode.
BOOL | IsFixedInplaceButtonHeight () const
Determines if the paint manager supports fixed or variable in-place button height.
void | SetInplaceButtonHeight (BOOL bFixedInplaceButtonHeight)
Sets if the paint manager supports fixed or variable in-place button height.
int | GetFreezeColsDividerStyle () const
Gets the style of the freeze columns divider line.
void | SetFreezeColsDividerStyle (int nStyle)
Sets the style for the freeze columns divider line.
virtual BOOL | OnDrawAction (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs)
Override this method to perform custom activities for the item before processing it.
BOOL | IsDrawGridForEmptySpace () const
Determines if the grid fills empty space after body rows.
void | SetDrawGridForEmptySpace (BOOL bDrawGrid)
Sets if the grid fills empty space after body rows.
BOOL | IsPrintGroupRowIcon () const
Determines if the group row collapse-expand icon is drawn in print mode.
void | SetPrintGroupRowIcon (BOOL bDraw)
Sets if the group row collapse-expand icon is drawn in print mode.
BOOL | IsColumnPlusMinusSign () const
Determines if columns use expand/collapse icons (+/-) or directional arrows.
void | SetColumnPlusMinusSign (BOOL bDraw)
Specifies if columns use expand/collapse icons (+/-) or directional arrows.
virtual int | CalculateRowHeight (CDC *pDC, const CString &strText, int nMaxWidth, BOOL bWordBreak=TRUE)
Calculates the height required for a rectangle bounding multi-line text to draw the multi-line text when the width of the rectangle is fixed.
void | DrawSectionDivider (CDC *pDC, const CRect &rc, XTPGridSectionDividerPosition dividerPosition, XTPGridSectionDividerStyle dividerStyle, CXTPPaintManagerColor dividerColor)
Draws the divider between grid sections (e.g.
int | GetSectionDividerHeight (XTPGridFixedRowsDividerStyle dividerStyle)
Gets the height of the section divider.
BOOL | IsUseDropMarker () const
Determines if a drop marker will be used when dragging and dropping.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

virtual void | DrawColumnBackground (CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, BOOL &bColumnPressed, BOOL &bDraggingFromHeader, CXTPGridHeader *pHeader=NULL)
This method is called to draw the background of a column using the current column style.
- Protected Member Functions inherited from CXTPTrackPaintManager
- Protected Member Functions inherited from CXTPGridPaintManager
virtual void | DrawTextLine (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nFlag, int &nCharCounter, int &nHyperlinkCounter)
Draws a line of text with respect to the drawing rectangle.
virtual int | DrawString (int *pnCurrDrawPos, CDC *pDC, const CString &strDraw, CRect rcDraw, UINT nFormat)
Draw a simple string into rectangle.
virtual void | DrawGridPattern (CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush)
Generates a custom grid pattern if necessary.
virtual void | DrawGridPattern (CDC *pDC, CXTPBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush)
Generates a custom grid pattern if necessary.
virtual void | DrawGridPattern (CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr)
Generates a custom grid pattern.
virtual void | DrawInplaceButtonFrame (CDC *pDC, CXTPGridInplaceButton *pButton)
Draws the in-place button frame.
virtual BOOL | DrawInplaceButtonIcon (CDC *pDC, CXTPGridInplaceButton *pButton)
Draws the in-place button icon.
virtual int | CalcColumnHeight (CDC *pDC, CXTPGridColumn *pColumn, int nTotalWidth=0)
Calculates the optimal height for a specified column.
virtual void | DrawMultiLineText (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, BOOL bWordBreak=TRUE)
Draws multi-line text.
virtual void | DrawSingleLineText (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nStartPos, int nEndPos, int nActualWidth)
Draws single-line text.
virtual int | DrawLink (int *pnCurrDrawPos, XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CXTPGridHyperlink *pHyperlink, CString strText, CRect rcLink, int nFlag, BOOL bTrim=FALSE)
Draws a hyperlink string using hyperlink text settings (i.e.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPTrackPaintManager
COLORREF | m_clrWorkArea
The color of the work area.
COLORREF | m_clrTrackHeader
The track header color.
COLORREF | m_clrTrackTimeArea
The track time area color.
COLORREF | m_clrTimeHeaderDarkDark
The header deep dark color.
COLORREF | m_clrTimeHeaderDark
The header dark color.
COLORREF | m_clrTimeSliderBackground
The slider background color.
COLORREF | m_clrTimeHeaderDivider
The header divider color.
COLORREF | m_clrScrollBarLight
The scrollbar light color.
COLORREF | m_clrScrollBarDark
The scrollbar dark color.
COLORREF | m_clrSelectedArea
The color of the selected area.
COLORREF | m_clrMarker
The color of the marker.
COLORREF | m_clrTimeLineTick
The color of a time line tick.
COLORREF | m_clrMarkerBorder
The color of a time line marker's border.
COLORREF | m_clrMarkerBack
The color of a time line marker's back.
COLORREF | m_clrTrackMarkerBorder
The color of a track marker's border.
COLORREF | m_clrTrackMarkerText
The color of a track marker's text.
COLORREF | m_clrTrackMarkerTextBack
The color of a track marker's text back.
COLORREF | m_clrTrackMarkerTextBorder
The color of a track marker's text border.
COLORREF | m_clrTimeLinePosition
The color of a marked position on a time line.
COLORREF | m_clrTimeHeaderBorder
The color of a time line header's border.
COLORREF | m_clrScrollBarBorderDark
The scrollbar border dark color.
COLORREF | m_clrScrollBarBorderLight
The scrollbar border light color.
COLORREF | m_clrWorkAreaScrollBarLight
The workarea scrollbar light color.
COLORREF | m_clrWorkAreaScrollBarDark
The workarea scrollbar dark color.
COLORREF | m_clrWorkAreaScrollBarBorder
The workarea scrollbar border color.
- Public Attributes inherited from CXTPGridPaintManager
CXTPFont | m_xtpFontText
Grid items default text.
CXTPFont | m_xtpFontBoldText
Grid items default bold text.
CXTPFont | m_xtpFontCaption
Column header caption font.
CXTPFont | m_xtpFontPreview
Column header caption font.
CXTPGridHyperlinkStyle * | m_pHyperlinkStyle
Style for links.
CXTPGridHyperlinkStyle * | m_pHyperlinkHoverStyle
Style for hovered links.
CXTPPaintManagerColor | m_clrHighlight
Background color of the highlighted row.
CXTPPaintManagerColor | m_clrBoldText
Grid items bold text color.
CXTPPaintManagerColor | m_clrBoldTextHighlight
Grid items bold text highlight color.
CXTPPaintManagerColor | m_clrWindowText
Grid items default text color.
CXTPPaintManagerColor | m_clrHighlightText
Text color of the highlighted text.
CXTPPaintManagerColor | m_clrHeaderControl
Background color of the grid header.
CXTPPaintManagerColor | m_clrCaptionText
Column header text color.
CXTPPaintManagerColor | m_clrCaptionTextPressed
Column header text color when pressed.
CXTPPaintManagerColor | m_clrControlBack
Background color of the control grid area.
CXTPPaintManagerColor | m_clrGroupRowText
Row text color.
CXTPPaintManagerColor | m_clrGroupShadeBack
Group row background color when indentation shade is enabled.
CXTPPaintManagerColor | m_clrGroupShadeText
Group row foreground color when indentation shade is enabled.
CXTPPaintManagerColor | m_clrGroupShadeBorder
Color for group border's shade.
CXTPPaintManagerColor | m_clrGroupBoxBack
Color of group box.
CXTPPaintManagerColor | m_clrControlDark
Dark background color of the Grid control (used on Group By area).
CXTPPaintManagerColor | m_clrControlLightLight
Light background color used for drawing shades (used on column header area).
CXTPPaintManagerColor | m_clrHotDivider
Color of the column hot divider window (two arrows).
CXTPPaintManagerColor | m_clrIndentControl
Color of the tree indentation area.
CXTPPaintManagerColor | m_clrItemShade
Color of the shade on sorted by column items.
CXTPPaintManagerColor | m_clrBtnFace
Standard button face color.
CXTPPaintManagerColor | m_clrBtnText
Standard button text color.
CXTPPaintManagerColor | m_clrPreviewText
Preview text color.
CXTPPaintManagerColor | m_clrSelectedRow
Selected row background color.
CXTPPaintManagerColor | m_clrSelectedRowText
Selected row text color.
CXTPPaintManagerColor | m_clrBtnFacePressed
Standard button face color when pressed.
CXTPPaintManagerColor | m_clrConnector
Header column connector line color.
CXTPPaintManagerColor | m_clrDisableBitmapLightest
The lightest color of bitmap which covers disabled grid.
CXTPPaintManagerColor | m_clrDisableBitmapDarkest
The darkest color of bitmap which covers disabled grid.
CXTPPaintManagerColorGradient | m_grcGradientColumn
Color of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColorGradient | m_grcGradientColumnHot
HotTracking Color of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColorGradient | m_grcGradientColumnPushed
Pushed Color of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColor | m_clrGradientColumnShadow
Bottom shadow of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColor | m_clrGradientColumnSeparator
Separator of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColor | m_crlNoGroupByText
A color for "No items" text in GroupBy area (see m_strNoGroupBy member).
CXTPPaintManagerColor | m_clrFreezeColsDivider
Freeze Columns Divider color.
COLORREF | m_clrColumnOffice2007CustomTheme
Base color for Office2007 custom theme.
COLORREF | m_clrFormulaSum
Color for Formula Sum fields.
COLORREF | m_clrFormulaSubSum
Color for Formula SubSum fields.
COLORREF | m_clrAlternativeBackground
Color for Alternative Row Background.
BOOL | m_bUseAlternativeBackground
TRUE to use Alternative Row Background, FALSE otherwise.
BOOL | m_bAllowMergeCells
TRUE to Allow Merge Cells, FALSE otherwise.
int | m_nTextIndentForGroupRowsWithNoIcon
Specifies Text indent if a group row icon is not used.
int | m_nTreeIndent
Tree indentation.
int | m_nTreeStructureStyle
Tree structure style.
int | m_nTreeTextIndentRowParent
Text indent, in pixels, for rows with children.
int | m_nTreeTextIndentRowChildren
Text indent, in pixels, for rows without children.
int | m_nTreeTextIndent
Text indent, in pixels, for rows that are neither parent nor children.
int | m_nTreeTextIndentGroupRow
Text indent, in pixels, for group rows.
BOOL | m_bGroupRowTextBold
TRUE to draw group rows with bold text.
BOOL | m_bShadeGroupHeadings
TRUE to show the indentation shade, FALSE otherwise.
BOOL | m_bShadeSortColumn
TRUE to show the items shade in the sorted by column, FALSE otherwise.
BOOL | m_bHotTracking
TRUE to allow column hot tracking.
BOOL | m_bInvertColumnOnClick
TRUE to invert column on click.
CString | m_strNoItems
A string which contains customized "No Items" text for displaying in view when there are no visible rows.
CString | m_strSortBy
A string which contains customized "Sort By" text for displaying in tooltip.
CString | m_strIncreasing
A string which contains customized "Increasing" text for displaying in tooltip.
CString | m_strDecreasing
A string which contains customized "Decreasing" text for displaying in tooltip.
CString | m_strNoGroupBy
A string which contains customized "No items" text message for displaying in Group By area when there are no items inside it.
CString | m_strNoFieldsAvailable
A string which contains customized "No Fields Available" text message for displaying in Field Chooser.
CString | m_strExpand
A string which contains customized "Expand" text for displaying in tooltip.
CString | m_strCollapse
A string which contains customized "Collapse" text for displaying in tooltip.
BOOL | m_bHideSelection
TRUE when hiding Grid control's selection by drawing selected items as others, FALSE otherwise.
BOOL | m_bPrintSortTriangle
TRUE to show the sort triangle in printout.
BOOL | m_bRevertAlignment
TRUE to revert column alignments.
BOOL | m_bUseEditTextAlignment
TRUE to automatically apply edit alignment using column alignment.
BOOL | m_bShowLockIcon
TRUE to show the lock icon, FALSE to hide.
BOOL | m_bUseShellIcon
TRUE to use the shell icon, FALSE otherwise.
int | m_iRecOrRowStart
Start position in numbering (0 or 1 or something user want).
BOOL | m_bRecOrRowNum
TRUE to display record number if support mode is used, FALSE to display row number.
BOOL | m_bMakeUpper
TRUE to display column header and group row text in all caps.
XTPGridTreeStructureStyle | m_treeStructureStyle
Tree structure style.
CRect | m_rcPreviewIndent
Preview indentation.
int | m_nFixedColumnsIndent
Fixed Column total width.
BOOL | m_bMoveScrollbarOnFixedColumnsIndent
Move Scrollbar right follow FixedColumnsIndent.
BOOL | m_bThemedInplaceButtons
Draw in-place buttons using current theme settings.
BOOL | m_bBaseTreeIndent
TRUE to add Extra Tree indentation to cover initial TreeColumn.
CUIntArray | m_arStartCol
Start column in each virtual page.
int | m_PrintPageWidth
Width of print page (run-time)
BOOL | m_bPrintVirtualPageNumber
TRUE to print horizontal page number.
BOOL | m_bPrintPageRectangle
TRUE to draw rectangle around page.
int | m_RecordNumberWidth
Column width for row/record numbers.
BOOL | m_bForceDynamicMarkupForCell
TRUE if use Markup for Grid Record Item.
BOOL | m_bForceShowDropMarker
TRUE if Force Show Drop Marker.
BOOL | m_bShowNonActiveInPlaceButton
TRUE if use Show Non-Active In-Place Button (Combo, Expand, Spin).
BOOL | m_bPrintWatermark
TRUE to print watermark.
BOOL | m_bUseGroupRowSelectionState
TRUE if use GroupSelectionState Glyph.
BOOL | m_bForceShowTooltip
TRUE if use show tooltip for any cell width case.
BOOL | m_bCleanTooltip
TRUE if use show tooltip without markup.
BOOL | m_bGrayIfDisable
TRUE is disable draw in gray (standard behavior).
int | m_nRowHeightDefault
The default row height.
BOOL | m_bCompactText
TRUE to ignore Icon for Narrow column to show more text.
BOOL | m_bUseDropMarker
FALSE to not draw drop marked when dragging/dropping, TRUE by default.
BOOL | m_bSortTriangleOffsetFromRight
Offset of sort triangle.
int | m_nTreeColumnLineLength
This is the extra line length to apply to tree column lines if there is no expand button.
int | m_nBaseParentRecordIndent
This is initial number of pixels a parent node will be indented when in a group.
- Protected Attributes inherited from CXTPGridPaintManager
int | m_nRowHeight
Grid row default height.
int | m_nHeaderHeight
Column header height.
int | m_nFooterHeight
Column footer height.
int | m_nGroupGridLineHeight
The height of the group grid line.
CXTPImageManager * | m_pGlyphs
An additional image list for the Grid control.
BOOL | m_bIsPreviewMode
TRUE to show the item preview, FALSE to hide.
int | m_nResizingWidth
The width of the column resizing marker area.
int | m_nMaxPreviewLines
Restrict maximum lines for preview text.
CSize | m_szGlyph
Glyph size.
CXTPBrush | m_xtpBrushTreeStructure
Brush to draw tree nodes.
CXTPBrush | m_xtpBrushGroupGridLineStyle
Brush to draw group row grid lines.
int | m_nFreezeColsDividerStyle
A set of flags from XTPGridFreezeColsDividerStyle.
BOOL | m_bFixedRowHeight
TRUE if fixed rows used.
BOOL | m_bColumnWidthWYSIWYG
TRUE if columns width WYSIWYG mode used.
BOOL | m_bShowWYSIWYGMarkers
TRUE if in non-print mode header show red page-end markers.
BOOL | m_bLastColumnWidthWYSIWYG
TRUE if last column width WYSIWYG mode used.
BOOL | m_bDrawGridForEmptySpace
TRUE if grid fills the empty space (if any) after the body rows.
BOOL | m_bPrintGroupRowIcon
TRUE if printout draw collapse-expand icon for group row.
BOOL | m_bColumnPlusMinusSign
TRUE if expand/collapse icons are used, FALSE if directional arrows are used.
BOOL | m_bFixedInplaceButtonHeight
TRUE if fixed in-place button height is used.
XTPGridGridStyle | m_nGroupGridLineStyle
Current style for group row grid lines.
XTPGridColumnStyle | m_columnStyle
Column drawing style.
CXTPWinThemeWrapper * | m_themeHeader
Header theme wrapper.
CXTPWinThemeWrapper * | m_themeButton
In-place button theme wrapper.
CXTPWinThemeWrapper * | m_themeCombo
Combo box in-place button theme wrapper.
CXTPWinThemeWrapper * | m_themeSpin
Spin in-place button theme wrapper.
CXTPGridControl * | m_pControl
Pointer to the Grid control object.
CXTPMarkupUIElement * | m_pMarkupUIElement_NoGroupBy
The no group by markup UI element.
CString | m_strMarkupUIElement_NoGroupBy
The no group by markup UI element string.
CXTPBrush | m_xtpBrushVeriticalGrid
Brush to draw vertical grid lines.
CXTPBrush | m_xtpBrushHorizontalGrid
Brush to draw horizontal grid lines.
XTPGridGridStyle m_nGridLineStylePreviousV
Previous style for vertical grid lines.
XTPGridGridStyle m_nGridLineStylePreviousH
Previous style for horizontal grid lines.

Detailed Description

CXTPTrackThemeResource is a CXTPTrackPaintManager derived class that represents a Resource style theme.

Member Function Documentation

◆ DrawCollapsedBitmap()

CSize DrawCollapsedBitmap | ( | CDC * | pDC,
 |  | const CXTPGridRow * | pRow,
 |  | CRect & | rcBitmap )
 virtual

Draws a collapsed bitmap.

Parameters
pDC | Pointer to the used device context.
pRow | Pointer to the row.
rcBitmap | Reference to bitmap area rectangle coordinates.
Returns
The size of the drawn bitmap.

Reimplemented from CXTPGridPaintManager.

◆ DrawColumnBackground()

virtual void DrawColumnBackground | ( | CDC * | pDC,
 |  | CXTPGridColumn * | pColumn,
 |  | CRect | rcColumn,
 |  | BOOL & | bColumnPressed,
 |  | BOOL & | bDraggingFromHeader,
 |  | CXTPGridHeader * | pHeader = NULL )
 protectedvirtual

This method is called to draw the background of a column using the current column style.

Parameters
pDC | Pointer to the used device context.
pColumn | Pointer to the column whose background must be drawn.
rcColumn | Bounding rectangle of the column.
bColumnPressed | TRUE if the column is pressed by the user.
bDraggingFromHeader | TRUE if the column is being dragged from the header area.
pHeader | Pointer to the header that the column belongs to.

Reimplemented from CXTPGridPaintManager.

◆ DrawColumnFooterDivider()

virtual void DrawColumnFooterDivider | ( | CDC * | pDC,
 |  | CXTPGridColumn * | pColumn,
 |  | CRect | rcColumn )
 virtual

Draws the column footer divider.

Parameters
pDC | Pointer to the used device context.
pColumn | Column header area rectangle coordinates.
rcColumn | Column area rectangle coordinates.

Reimplemented from CXTPGridPaintManager.

◆ DrawColumnText()

virtual void DrawColumnText | ( | CDC * | pDC,
 |  | CRect | rcText,
 |  | CString | strCaption,
 |  | int | nHeaderAlignment,
 |  | BOOL | bIsHeader,
 |  | BOOL | bColumnPressed )
 virtual

Draws text for the column header.

Parameters
pDC | Pointer to the used device context.
rcText | Size and position of the text to render.
strCaption | NULL-terminated string representing the caption text.
nHeaderAlignment | DT_ text alignment flags.
bIsHeader | TRUE if the column is to be rendered for the header.
bColumnPressed | TRUE if the column is pressed by the user.

Reimplemented from CXTPGridPaintManager.

◆ DrawNoGroupByText()

virtual void DrawNoGroupByText | ( | CDC * | pDC,
 |  | CRect | rcItem )
 virtual

This method used to draw a "No items" text message in the Group By area when there are no items inside it.

Override it for custom drawing.

Parameters
pDC | Pointer to the used device context.
rcItem | Reference to text area rectangle coordinates.
See also
CXTPGridPaintManager::m_strNoGroupBy

Reimplemented from CXTPGridPaintManager.

◆ DrawSectionDivider()

void DrawSectionDivider | ( | CDC * | pDC,
 |  | const CRect & | rc,
 |  | XTPGridSectionDividerPosition | dividerPosition,
 |  | XTPGridSectionDividerStyle | dividerStyle,
 |  | CXTPPaintManagerColor | dividerColor )

Draws the divider between grid sections (e.g.

dividing header record rows and body rows).

Parameters
pDC | Pointer to the used device context.
rc | Reference to rectangle coordinates.
dividerPosition | Position of the section divider; must be one of the values defined by the XTPGridSectionDividerPosition enumeration.
dividerStyle | Style of the section divider; must be one of the values defined by the XTPGridSectionDividerStyle enumeration.
dividerColor | Color of the section divider.

◆ DrawTriangle()

virtual void DrawTriangle | ( | CDC * | pDC,
 |  | CRect | rcTriangle,
 |  | BOOL | bToDown,
 |  | int | nShadowWidth,
 |  | BOOL | bColumnPressed )
 virtual

Draws a triangle that shows the sort order of the column.

Parameters
pDC | Pointer to the used device context.
rcTriangle | Triangle area rectangle coordinates.
bToDown | TRUE to turn the top of the triangle downward, FALSE to turn the top of the triangle upward.
nShadowWidth | Size, in pixels, of the shadow to draw under the triangle image, or 0 to disable the shadow; the default value for this parameter is 0.
bColumnPressed | TRUE if the column is pressed by the user.

This function is used to draw a triangle image on the header of the column that is sorted. The triangle represents the direction of the sort: ascending or descending. The size of the triangle depends on the rectangle area provided.

Example:

// draw ascendant triangle
CRect rcTriangle;
rcTriangle.CopyRect(rcHeader);
rcTriangle.DeflateRect(40, 5, 5, 5);
DrawTriangle(pDC, rcTriangle, TRUE);

// draw descendant triangle
CRect rcTriangle;
rcTriangle.CopyRect(rcHeader);
rcTriangle.DeflateRect(40, 5, 5, 5);
DrawTriangle(pDC, rcTriangle, FALSE);

◆ FillFooter()

virtual void FillFooter | ( | CDC * | pDC,
 |  | CRect | rcFooter )
 virtual

Fills the column footer control area by its background.

Parameters
pDC | Pointer to the used device context.
rcFooter | Footer area rectangle coordinates.

Reimplemented from CXTPGridPaintManager.

The documentation for this class was generated from the following file:
  • XTPTrackThemeResource.h


Toolkit Pro: CXTPTrackThemeVisualStudio2012Blue Class Reference

Public Member Functions | List of all members
CXTPTrackThemeVisualStudio2012Blue Class Reference

CXTPTrackThemeVisualStudio2012Blue is a CXTPTrackThemeOffice2013 derived class that represents a Visual Studio 2012 Blue style theme. More...

Inheritance diagram for CXTPTrackThemeVisualStudio2012Blue:
[legend]

Public Member Functions

CXTPTrackThemeVisualStudio2012Blue ()
Default paint manager constructor, handles properties initialization.
virtual void | LoadGlyphs ()
Loads the default images used by the track control.
virtual void | RefreshMetrics ()
This method is called to refresh the visual metrics of the track control.
- Public Member Functions inherited from CXTPTrackThemeOffice2013
CXTPTrackThemeOffice2013 ()
Default paint manager constructor, handles properties initialization.
virtual void | DrawColumnText (CDC *pDC, CRect rcText, CString strCaption, int nHeaderAlignment, BOOL bIsHeader, BOOL bColumnPressed)
Draws text for the column header.
virtual void | DrawColumnBackground (CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, BOOL &bColumnPressed, BOOL &bDraggingFromHeader, CXTPGridHeader *pHeader=NULL)
This method is called to draw the background of a column using the current column style.
virtual void | DrawTriangle (CDC *pDC, CRect rcTriangle, BOOL bToDown, BOOL bDraggingFromHeader, int nShadowWidth, BOOL bColumnPressed)
Draws a triangle that shows the sort order of the column.
virtual void | FillGroupRowMetrics (CXTPGridGroupRow *pRow, XTP_GRIDRECORDITEM_METRICS *pMetrics, BOOL bPrinting)
Fills the font and color members of the metrics structure for a specified group row.
virtual void | DrawGroupRow (CDC *pDC, CXTPGridGroupRow *pRow, CRect rcRow, XTP_GRIDRECORDITEM_METRICS *pMetrics)
Draws a group row.
virtual void | DrawFocusedRow (CDC *pDC, CRect rcRow)
Draws focused rows.
virtual int | GetRowHeight (CDC *pDC, CXTPGridRow *pRow)
Retrieves the default row height for print mode (i.e.
- Public Member Functions inherited from CXTPTrackPaintManager
CXTPTrackPaintManager ()
Creates a CXTPTrackPaintManager object.
~CXTPTrackPaintManager ()
CXTPTrackPaintManager destructor, handles cleanup and deallocation.
virtual void | DrawTrackHeader (CDC *pDC)
Call this function to draw the track header.
virtual void | DrawMarkers (CDC *pDC)
Call this function to draw the markers.
virtual void | DrawTimeLine (CDC *pDC)
Call this function to draw the time line.
virtual CString | FormatTimeLineTick (int nPosition, COLORREF &clrTick, int &nTickLength)
Call this function to format the time and tick marker relative to a time line position.
virtual CString | FormatTime (int nPosition)
Call this function to format the time and tick marker relative to a time line position.
- Public Member Functions inherited from CXTPGridPaintManager
CXTPGridPaintManager ()
Default CXTPGridPaintManager constructor, handles properties initialization.
virtual | ~CXTPGridPaintManager ()
Default CXTPGridPaintManager destructor, handles member items deallocation.
virtual void | SetGridControl (CXTPGridControl *pControl)
Sets the associated Grid control for the paint manager.
virtual int | GetRowHeight (CDC *pDC, CXTPGridRow *pRow, int nTotalWidth)
Retrieves the default row height for print mode (i.e.
int | GetRowHeightEx (CDC *pDC, CXTPGridRow *pRow, int nTotalWidth, const BOOL firstLevel=TRUE)
Retrieves the default row height for print mode (i.e.
int | GetItemHeight (XTP_GRIDRECORDITEM_DRAWARGS &drawArgs, int nWidth)
Retrieves the height of a record item for a given width.
BOOL | FindRowAdjacentToMergedEx (const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, int &nAdjRowIndex, BOOL bUpward)
Searches the topmost or bottommost row depending on the height of the current row.
int | FindRowAdjacentToMerged (const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, BOOL bUpward)
Wrapper for the FindRowAdjacentToMergedEx method.
int | RecalcTotalHightOfMergedRows (CXTPGridColumns *pColumns, CDC *pDC, CXTPGridRow *pRow, int nRowHeight, int nTotalWidth)
Recalculates row height according to the height of merged items.
virtual int | GetPreviewItemHeight (CDC *pDC, CXTPGridRow *pRow, int nWidth, int nHeight)
Retrieves the height of a preview item for print mode.
virtual int | GetHeaderHeight ()
Gets the column header height.
virtual int | GetHeaderHeight (CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0)
Calculates the optimal header height.
virtual void | SetHeaderHeight (int nHeight)
Sets the column header height.
virtual int | GetFooterHeight (CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0)
Calculates the optimal footer height.
virtual COLORREF | GetControlBackColor (CXTPGridControl *pControl)
Retrieves the parent Grid control's background color.
virtual void | FillRow (CDC *pDC, CXTPGridRow *pRow, CRect rcRow)
Fills a specified row with its background color.
virtual void | DrawGrid (CDC *pDC, XTPGridOrientation orientation, CRect rcGrid)
Draws a grid for the control.
virtual void | DrawFreezeColsDivider (CDC *pDC, const CRect &rc, CXTPGridControl *pControl, CXTPGridRow *pRow=NULL)
Draws a freeze column divider.
virtual void | DrawVerticalTimeLineMarker (CDC *pDC, int xPos, CXTPGridControl *pControl, COLORREF color=RGB(0, 255, 0))
Draws a vertical timeline marker.
virtual void | FillIndent (CDC *pDC, CRect rcRow)
Fills an indent area by its background.
virtual void | FillItemShade (CDC *pDC, CRect rcItem)
Fills an item shade by its background if necessary.
virtual void | FillHeaderControl (CDC *pDC, CRect rcHeader)
Fills a column header control area by its background.
virtual void | FillFooter (CDC *pDC, CRect rcFooter)
Fills a column footer control area by its background.
virtual void | DrawColumn (CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn, BOOL bDrawExternal=FALSE, int nShadowWidth=0)
Draws a column header with all related attributes (sort order, icon, etc.).
virtual void | DrawColumnFooterDivider (CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn)
Draws the column footer divider.
virtual void | DrawColumnFooter (CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn)
Draws the column footer with all related attributes (e.g.
virtual BOOL | IsColumHotTrackingEnabled () const
Determines if hot tracking is enabled for the current column style.
virtual void | FillGroupByControl (CDC *pDC, CRect &rcGroupBy)
Draws the Group By box.
CXTPImageManager * | GetGlyphs () const
Gets a pointer to the additional image list with glyphs.
void | DrawHorizontalLine (CDC *pDC, int xPos, int yPos, int cx, COLORREF clr)
Draws a horizontal line.
void | DrawVerticalLine (CDC *pDC, int xPos, int yPos, int cy, COLORREF clr)
Draws a vertical line.
void | DrawConnector (CDC *pDC, CPoint ptFrom, CPoint ptTo)
Draws a column connector for the Group By box.
virtual CSize | DrawCollapsedBitmap (CDC *pDC, const CXTPGridRow *pRow, CRect &rcBitmap)
Draws a collapsed bitmap.
virtual int | DrawBitmap (CDC *pDC, CXTPGridControl *pControl, CRect rcColumn, int iImage)
Draws a bitmap.
virtual int | DrawColumnIcon (CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, CRect rcIcon, int iIcon)
Draws an icon for a column.
virtual CSize | DrawGlyph (CDC *pDC, CRect rcColumn, int iImage)
Draws the standard glyphs of the Grid control.
virtual CSize | DrawShellIcon (CDC *pDC, CRect rcColumn, int iImage)
Draws the shell icon.
void | EnablePreviewMode (BOOL bIsPreviewMode)
Enables/disables preview mode for the control.
BOOL | IsPreviewMode () const
Determines if preview mode is enabled/disabled for the control.
CFont * | GetTextFont ()
Gets the default text font used for control items.
int | SetMaxPreviewLines (int nMaxLines)
Sets the maximum number of lines of text for a preview item.
int | GetMaxPreviewLines ()
Gets the maximum number of lines of text for a preview item.
int | GetPreviewLinesCount (CDC *pDC, CRect &rcText, const CString &strText)
Calculates the number of lines required to draw a specified preview text string, taking into account the maximum number of lines of text for a preview item.
BOOL | IsGridVisible (BOOL bVertical) const
Determines the visibility of specified grid lines.
BOOL | IsGridVisible (XTPGridOrientation orientation) const
Determines the visibility of specified grid lines.
void | SetColumnStyle (XTPGridColumnStyle columnStyle)
Sets the header style.
XTPGridColumnStyle | GetColumnStyle () const
Gets the header style.
void | SetColumnOffice2007CustomThemeBaseColor (COLORREF clrBaseColor)
Sets the header's custom theme base color for Office2007 column style.
COLORREF | GetColumnOffice2007CustomThemeBaseColor () const
Gets the header's custom theme base color for Office2007 column style.
void | SetTextFont (LOGFONT &lf)
Creates and sets the default text font.
void | SetCaptionFont (LOGFONT &lf)
Creates and sets the default caption font.
void | SetPreviewIndent (int nLeft, int nTop, int nRight, int nBottom)
Sets the preview item indent.
virtual void | DrawInplaceButton (CDC *pDC, CXTPGridInplaceButton *pButton)
Draws the in-place button of the Grid control.
virtual BOOL | DrawInplaceComboButton (CDC *pDC, CRect *pRc)
Draws the combo button of the Grid control.
virtual BOOL | DrawInplaceExpandButton (CDC *pDC, CRect *pRc)
Draws the expand button of the Grid control.
virtual BOOL | DrawInplaceSpinButton (CDC *pDC, CRect *pRc)
Draws the spin button of the Grid control.
virtual void | DrawTreeStructure (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CRect rcItem, CSize sizeGlyph)
Draws tree elements of the Grid control.
virtual void | DrawItemBitmap (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CRect &rcItem, int nImage)
Draws an item bitmap.
virtual void | DrawItemCaption (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics)
Draws an item caption.
virtual void | DrawRowNumber (CDC *pDC, CRect rcNumber, CXTPGridRow *pRow)
Draws a row number.
virtual void | DrawItemControl (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CXTPGridRecordItemControl *pControl, CRect &rcItem)
Draws an item control.
BOOL | IsFixedRowHeight () const
Determines if the paint manager supports fixed or variable row height.
void | SetFixedRowHeight (BOOL bFixedRowHeight)
Sets if the paint manager supports fixed or variable row height.
BOOL | IsColumnWidthWYSIWYG () const
Determines if the paint manager supports column width WYSIWYG mode.
BOOL | IsLastColumnWidthWYSIWYG () const
Determines if the paint manager supports last column width WYSIWYG mode.
BOOL | IsShowWYSIWYGMarkers () const
Determines if the paint manager shows WYSIWYG page-end markers.
void | ShowWYSIWYGMarkers (BOOL bSet)
Sets if the paint manager shows WYSIWYG page-end markers.
void | SetColumnWidthWYSIWYG (BOOL bColumnWidthWYSIWYG)
Sets if the paint manager supports column width WYSIWYG mode.
void | SetLastColumnWidthWYSIWYG (BOOL bColumnWidthWYSIWYG)
Sets if the paint manager supports last column width WYSIWYG mode.
BOOL | IsFixedInplaceButtonHeight () const
Determines if the paint manager supports fixed or variable in-place button height.
void | SetInplaceButtonHeight (BOOL bFixedInplaceButtonHeight)
Sets if the paint manager supports fixed or variable in-place button height.
int | GetFreezeColsDividerStyle () const
Gets the style of the freeze columns divider line.
void | SetFreezeColsDividerStyle (int nStyle)
Sets the style for the freeze columns divider line.
virtual BOOL | OnDrawAction (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs)
Override this method to perform custom activities for the item before processing it.
virtual void | DrawNoGroupByText (CDC *pDC, CRect rcItem)
Draws the "No items" text message in the Group By area when there are no items inside it.
BOOL | IsDrawGridForEmptySpace () const
Determines if the grid fills empty space after body rows.
void | SetDrawGridForEmptySpace (BOOL bDrawGrid)
Sets if the grid fills empty space after body rows.
BOOL | IsPrintGroupRowIcon () const
Determines if the group row collapse-expand icon is drawn in print mode.
void | SetPrintGroupRowIcon (BOOL bDraw)
Sets if the group row collapse-expand icon is drawn in print mode.
BOOL | IsColumnPlusMinusSign () const
Determines if columns use expand/collapse icons (+/-) or directional arrows.
void | SetColumnPlusMinusSign (BOOL bDraw)
Specifies if columns use expand/collapse icons (+/-) or directional arrows.
virtual int | CalculateRowHeight (CDC *pDC, const CString &strText, int nMaxWidth, BOOL bWordBreak=TRUE)
Calculates the height required for a rectangle bounding multi-line text to draw the multi-line text when the width of the rectangle is fixed.
void | DrawSectionDivider (CDC *pDC, const CRect &rc, XTPGridSectionDividerPosition dividerPosition, XTPGridSectionDividerStyle dividerStyle, CXTPPaintManagerColor dividerColor)
Draws the divider between grid sections (e.g.
int | GetSectionDividerHeight (XTPGridFixedRowsDividerStyle dividerStyle)
Gets the height of the section divider.
BOOL | IsUseDropMarker () const
Determines if a drop marker will be used when dragging and dropping.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPTrackThemeOffice2013
CXTPPaintManagerColor | m_clrGlyph
Header glyph color.
CXTPPaintManagerColor | m_clrGlyphHighlight
Header highlighted glyph color.
CXTPPaintManagerColor | m_clrSelectedBorder
Selected block border.
- Public Attributes inherited from CXTPTrackPaintManager
COLORREF | m_clrWorkArea
The color of the work area.
COLORREF | m_clrTrackHeader
The track header color.
COLORREF | m_clrTrackTimeArea
The track time area color.
COLORREF | m_clrTimeHeaderDarkDark
The header deep dark color.
COLORREF | m_clrTimeHeaderDark
The header dark color.
COLORREF | m_clrTimeSliderBackground
The slider background color.
COLORREF | m_clrTimeHeaderDivider
The header divider color.
COLORREF | m_clrScrollBarLight
The scrollbar light color.
COLORREF | m_clrScrollBarDark
The scrollbar dark color.
COLORREF | m_clrSelectedArea
The color of the selected area.
COLORREF | m_clrMarker
The color of the marker.
COLORREF | m_clrTimeLineTick
The color of a time line tick.
COLORREF | m_clrMarkerBorder
The color of a time line marker's border.
COLORREF | m_clrMarkerBack
The color of a time line marker's back.
COLORREF | m_clrTrackMarkerBorder
The color of a track marker's border.
COLORREF | m_clrTrackMarkerText
The color of a track marker's text.
COLORREF | m_clrTrackMarkerTextBack
The color of a track marker's text back.
COLORREF | m_clrTrackMarkerTextBorder
The color of a track marker's text border.
COLORREF | m_clrTimeLinePosition
The color of a marked position on a time line.
COLORREF | m_clrTimeHeaderBorder
The color of a time line header's border.
COLORREF | m_clrScrollBarBorderDark
The scrollbar border dark color.
COLORREF | m_clrScrollBarBorderLight
The scrollbar border light color.
COLORREF | m_clrWorkAreaScrollBarLight
The workarea scrollbar light color.
COLORREF | m_clrWorkAreaScrollBarDark
The workarea scrollbar dark color.
COLORREF | m_clrWorkAreaScrollBarBorder
The workarea scrollbar border color.
- Public Attributes inherited from CXTPGridPaintManager
CXTPFont | m_xtpFontText
Grid items default text.
CXTPFont | m_xtpFontBoldText
Grid items default bold text.
CXTPFont | m_xtpFontCaption
Column header caption font.
CXTPFont | m_xtpFontPreview
Column header caption font.
CXTPGridHyperlinkStyle * | m_pHyperlinkStyle
Style for links.
CXTPGridHyperlinkStyle * | m_pHyperlinkHoverStyle
Style for hovered links.
CXTPPaintManagerColor | m_clrHighlight
Background color of the highlighted row.
CXTPPaintManagerColor | m_clrBoldText
Grid items bold text color.
CXTPPaintManagerColor | m_clrBoldTextHighlight
Grid items bold text highlight color.
CXTPPaintManagerColor | m_clrWindowText
Grid items default text color.
CXTPPaintManagerColor | m_clrHighlightText
Text color of the highlighted text.
CXTPPaintManagerColor | m_clrHeaderControl
Background color of the grid header.
CXTPPaintManagerColor | m_clrCaptionText
Column header text color.
CXTPPaintManagerColor | m_clrCaptionTextPressed
Column header text color when pressed.
CXTPPaintManagerColor | m_clrControlBack
Background color of the control grid area.
CXTPPaintManagerColor | m_clrGroupRowText
Row text color.
CXTPPaintManagerColor | m_clrGroupShadeBack
Group row background color when indentation shade is enabled.
CXTPPaintManagerColor | m_clrGroupShadeText
Group row foreground color when indentation shade is enabled.
CXTPPaintManagerColor | m_clrGroupShadeBorder
Color for group border's shade.
CXTPPaintManagerColor | m_clrGroupBoxBack
Color of group box.
CXTPPaintManagerColor | m_clrControlDark
Dark background color of the Grid control (used on Group By area).
CXTPPaintManagerColor | m_clrControlLightLight
Light background color used for drawing shades (used on column header area).
CXTPPaintManagerColor | m_clrHotDivider
Color of the column hot divider window (two arrows).
CXTPPaintManagerColor | m_clrIndentControl
Color of the tree indentation area.
CXTPPaintManagerColor | m_clrItemShade
Color of the shade on sorted by column items.
CXTPPaintManagerColor | m_clrBtnFace
Standard button face color.
CXTPPaintManagerColor | m_clrBtnText
Standard button text color.
CXTPPaintManagerColor | m_clrPreviewText
Preview text color.
CXTPPaintManagerColor | m_clrSelectedRow
Selected row background color.
CXTPPaintManagerColor | m_clrSelectedRowText
Selected row text color.
CXTPPaintManagerColor | m_clrBtnFacePressed
Standard button face color when pressed.
CXTPPaintManagerColor | m_clrConnector
Header column connector line color.
CXTPPaintManagerColor | m_clrDisableBitmapLightest
The lightest color of bitmap which covers disabled grid.
CXTPPaintManagerColor | m_clrDisableBitmapDarkest
The darkest color of bitmap which covers disabled grid.
CXTPPaintManagerColorGradient | m_grcGradientColumn
Color of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColorGradient | m_grcGradientColumnHot
HotTracking Color of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColorGradient | m_grcGradientColumnPushed
Pushed Color of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColor | m_clrGradientColumnShadow
Bottom shadow of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColor | m_clrGradientColumnSeparator
Separator of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColor | m_crlNoGroupByText
A color for "No items" text in GroupBy area (see m_strNoGroupBy member).
CXTPPaintManagerColor | m_clrFreezeColsDivider
Freeze Columns Divider color.
COLORREF | m_clrColumnOffice2007CustomTheme
Base color for Office2007 custom theme.
COLORREF | m_clrFormulaSum
Color for Formula Sum fields.
COLORREF | m_clrFormulaSubSum
Color for Formula SubSum fields.
COLORREF | m_clrAlternativeBackground
Color for Alternative Row Background.
BOOL | m_bUseAlternativeBackground
TRUE to use Alternative Row Background, FALSE otherwise.
BOOL | m_bAllowMergeCells
TRUE to Allow Merge Cells, FALSE otherwise.
int | m_nTextIndentForGroupRowsWithNoIcon
Specifies Text indent if a group row icon is not used.
int | m_nTreeIndent
Tree indentation.
int | m_nTreeStructureStyle
Tree structure style.
int | m_nTreeTextIndentRowParent
Text indent, in pixels, for rows with children.
int | m_nTreeTextIndentRowChildren
Text indent, in pixels, for rows without children.
int | m_nTreeTextIndent
Text indent, in pixels, for rows that are neither parent nor children.
int | m_nTreeTextIndentGroupRow
Text indent, in pixels, for group rows.
BOOL | m_bGroupRowTextBold
TRUE to draw group rows with bold text.
BOOL | m_bShadeGroupHeadings
TRUE to show the indentation shade, FALSE otherwise.
BOOL | m_bShadeSortColumn
TRUE to show the items shade in the sorted by column, FALSE otherwise.
BOOL | m_bHotTracking
TRUE to allow column hot tracking.
BOOL | m_bInvertColumnOnClick
TRUE to invert column on click.
CString | m_strNoItems
A string which contains customized "No Items" text for displaying in view when there are no visible rows.
CString | m_strSortBy
A string which contains customized "Sort By" text for displaying in tooltip.
CString | m_strIncreasing
A string which contains customized "Increasing" text for displaying in tooltip.
CString | m_strDecreasing
A string which contains customized "Decreasing" text for displaying in tooltip.
CString | m_strNoGroupBy
A string which contains customized "No items" text message for displaying in Group By area when there are no items inside it.
CString | m_strNoFieldsAvailable
A string which contains customized "No Fields Available" text message for displaying in Field Chooser.
CString | m_strExpand
A string which contains customized "Expand" text for displaying in tooltip.
CString | m_strCollapse
A string which contains customized "Collapse" text for displaying in tooltip.
BOOL | m_bHideSelection
TRUE when hiding Grid control's selection by drawing selected items as others, FALSE otherwise.
BOOL | m_bPrintSortTriangle
TRUE to show the sort triangle in printout.
BOOL | m_bRevertAlignment
TRUE to revert column alignments.
BOOL | m_bUseEditTextAlignment
TRUE to automatically apply edit alignment using column alignment.
BOOL | m_bShowLockIcon
TRUE to show the lock icon, FALSE to hide.
BOOL | m_bUseShellIcon
TRUE to use the shell icon, FALSE otherwise.
int | m_iRecOrRowStart
Start position in numbering (0 or 1 or something user want).
BOOL | m_bRecOrRowNum
TRUE to display record number if support mode is used, FALSE to display row number.
BOOL | m_bMakeUpper
TRUE to display column header and group row text in all caps.
XTPGridTreeStructureStyle | m_treeStructureStyle
Tree structure style.
CRect | m_rcPreviewIndent
Preview indentation.
int | m_nFixedColumnsIndent
Fixed Column total width.
BOOL | m_bMoveScrollbarOnFixedColumnsIndent
Move Scrollbar right follow FixedColumnsIndent.
BOOL | m_bThemedInplaceButtons
Draw in-place buttons using current theme settings.
BOOL | m_bBaseTreeIndent
TRUE to add Extra Tree indentation to cover initial TreeColumn.
CUIntArray | m_arStartCol
Start column in each virtual page.
int | m_PrintPageWidth
Width of print page (run-time)
BOOL | m_bPrintVirtualPageNumber
TRUE to print horizontal page number.
BOOL | m_bPrintPageRectangle
TRUE to draw rectangle around page.
int | m_RecordNumberWidth
Column width for row/record numbers.
BOOL | m_bForceDynamicMarkupForCell
TRUE if use Markup for Grid Record Item.
BOOL | m_bForceShowDropMarker
TRUE if Force Show Drop Marker.
BOOL | m_bShowNonActiveInPlaceButton
TRUE if use Show Non-Active In-Place Button (Combo, Expand, Spin).
BOOL | m_bPrintWatermark
TRUE to print watermark.
BOOL | m_bUseGroupRowSelectionState
TRUE if use GroupSelectionState Glyph.
BOOL | m_bForceShowTooltip
TRUE if use show tooltip for any cell width case.
BOOL | m_bCleanTooltip
TRUE if use show tooltip without markup.
BOOL | m_bGrayIfDisable
TRUE is disable draw in gray (standard behavior).
int | m_nRowHeightDefault
The default row height.
BOOL | m_bCompactText
TRUE to ignore Icon for Narrow column to show more text.
BOOL | m_bUseDropMarker
FALSE to not draw drop marked when dragging/dropping, TRUE by default.
BOOL | m_bSortTriangleOffsetFromRight
Offset of sort triangle.
int | m_nTreeColumnLineLength
This is the extra line length to apply to tree column lines if there is no expand button.
int | m_nBaseParentRecordIndent
This is initial number of pixels a parent node will be indented when in a group.
- Protected Member Functions inherited from CXTPTrackPaintManager
- Protected Member Functions inherited from CXTPGridPaintManager
virtual void | DrawTextLine (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nFlag, int &nCharCounter, int &nHyperlinkCounter)
Draws a line of text with respect to the drawing rectangle.
virtual int | DrawString (int *pnCurrDrawPos, CDC *pDC, const CString &strDraw, CRect rcDraw, UINT nFormat)
Draw a simple string into rectangle.
virtual void | DrawGridPattern (CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush)
Generates a custom grid pattern if necessary.
virtual void | DrawGridPattern (CDC *pDC, CXTPBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush)
Generates a custom grid pattern if necessary.
virtual void | DrawGridPattern (CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr)
Generates a custom grid pattern.
virtual void | DrawInplaceButtonFrame (CDC *pDC, CXTPGridInplaceButton *pButton)
Draws the in-place button frame.
virtual BOOL | DrawInplaceButtonIcon (CDC *pDC, CXTPGridInplaceButton *pButton)
Draws the in-place button icon.
virtual int | CalcColumnHeight (CDC *pDC, CXTPGridColumn *pColumn, int nTotalWidth=0)
Calculates the optimal height for a specified column.
virtual void | DrawMultiLineText (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, BOOL bWordBreak=TRUE)
Draws multi-line text.
virtual void | DrawSingleLineText (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nStartPos, int nEndPos, int nActualWidth)
Draws single-line text.
virtual int | DrawLink (int *pnCurrDrawPos, XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CXTPGridHyperlink *pHyperlink, CString strText, CRect rcLink, int nFlag, BOOL bTrim=FALSE)
Draws a hyperlink string using hyperlink text settings (i.e.
- Protected Attributes inherited from CXTPGridPaintManager
int | m_nRowHeight
Grid row default height.
int | m_nHeaderHeight
Column header height.
int | m_nFooterHeight
Column footer height.
int | m_nGroupGridLineHeight
The height of the group grid line.
CXTPImageManager * | m_pGlyphs
An additional image list for the Grid control.
BOOL | m_bIsPreviewMode
TRUE to show the item preview, FALSE to hide.
int | m_nResizingWidth
The width of the column resizing marker area.
int | m_nMaxPreviewLines
Restrict maximum lines for preview text.
CSize | m_szGlyph
Glyph size.
CXTPBrush | m_xtpBrushTreeStructure
Brush to draw tree nodes.
CXTPBrush | m_xtpBrushGroupGridLineStyle
Brush to draw group row grid lines.
int | m_nFreezeColsDividerStyle
A set of flags from XTPGridFreezeColsDividerStyle.
BOOL | m_bFixedRowHeight
TRUE if fixed rows used.
BOOL | m_bColumnWidthWYSIWYG
TRUE if columns width WYSIWYG mode used.
BOOL | m_bShowWYSIWYGMarkers
TRUE if in non-print mode header show red page-end markers.
BOOL | m_bLastColumnWidthWYSIWYG
TRUE if last column width WYSIWYG mode used.
BOOL | m_bDrawGridForEmptySpace
TRUE if grid fills the empty space (if any) after the body rows.
BOOL | m_bPrintGroupRowIcon
TRUE if printout draw collapse-expand icon for group row.
BOOL | m_bColumnPlusMinusSign
TRUE if expand/collapse icons are used, FALSE if directional arrows are used.
BOOL | m_bFixedInplaceButtonHeight
TRUE if fixed in-place button height is used.
XTPGridGridStyle | m_nGroupGridLineStyle
Current style for group row grid lines.
XTPGridColumnStyle | m_columnStyle
Column drawing style.
CXTPWinThemeWrapper * | m_themeHeader
Header theme wrapper.
CXTPWinThemeWrapper * | m_themeButton
In-place button theme wrapper.
CXTPWinThemeWrapper * | m_themeCombo
Combo box in-place button theme wrapper.
CXTPWinThemeWrapper * | m_themeSpin
Spin in-place button theme wrapper.
CXTPGridControl * | m_pControl
Pointer to the Grid control object.
CXTPMarkupUIElement * | m_pMarkupUIElement_NoGroupBy
The no group by markup UI element.
CString | m_strMarkupUIElement_NoGroupBy
The no group by markup UI element string.
CXTPBrush | m_xtpBrushVeriticalGrid
Brush to draw vertical grid lines.
CXTPBrush | m_xtpBrushHorizontalGrid
Brush to draw horizontal grid lines.
XTPGridGridStyle m_nGridLineStylePreviousV
Previous style for vertical grid lines.
XTPGridGridStyle m_nGridLineStylePreviousH
Previous style for horizontal grid lines.

Detailed Description

CXTPTrackThemeVisualStudio2012Blue is a CXTPTrackThemeOffice2013 derived class that represents a Visual Studio 2012 Blue style theme.

The documentation for this class was generated from the following file:
  • XTPTrackThemeVisualStudio2012.h


Toolkit Pro: CXTPTrackThemeVisualStudio2012Dark Class Reference

Public Member Functions | List of all members
CXTPTrackThemeVisualStudio2012Dark Class Reference

CXTPTrackThemeVisualStudio2012Dark is a CXTPTrackThemeOffice2013 derived class that represents a Visual Studio 2012 Dark style theme. More...

Inheritance diagram for CXTPTrackThemeVisualStudio2012Dark:
[legend]

Public Member Functions

CXTPTrackThemeVisualStudio2012Dark ()
Default paint manager constructor, handles properties initialization.
virtual void | LoadGlyphs ()
Loads the default images used by the track control.
virtual void | RefreshMetrics ()
This method is called to refresh the visual metrics of the track control.
- Public Member Functions inherited from CXTPTrackThemeOffice2013
CXTPTrackThemeOffice2013 ()
Default paint manager constructor, handles properties initialization.
virtual void | DrawColumnText (CDC *pDC, CRect rcText, CString strCaption, int nHeaderAlignment, BOOL bIsHeader, BOOL bColumnPressed)
Draws text for the column header.
virtual void | DrawColumnBackground (CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, BOOL &bColumnPressed, BOOL &bDraggingFromHeader, CXTPGridHeader *pHeader=NULL)
This method is called to draw the background of a column using the current column style.
virtual void | DrawTriangle (CDC *pDC, CRect rcTriangle, BOOL bToDown, BOOL bDraggingFromHeader, int nShadowWidth, BOOL bColumnPressed)
Draws a triangle that shows the sort order of the column.
virtual void | FillGroupRowMetrics (CXTPGridGroupRow *pRow, XTP_GRIDRECORDITEM_METRICS *pMetrics, BOOL bPrinting)
Fills the font and color members of the metrics structure for a specified group row.
virtual void | DrawGroupRow (CDC *pDC, CXTPGridGroupRow *pRow, CRect rcRow, XTP_GRIDRECORDITEM_METRICS *pMetrics)
Draws a group row.
virtual void | DrawFocusedRow (CDC *pDC, CRect rcRow)
Draws focused rows.
virtual int | GetRowHeight (CDC *pDC, CXTPGridRow *pRow)
Retrieves the default row height for print mode (i.e.
- Public Member Functions inherited from CXTPTrackPaintManager
CXTPTrackPaintManager ()
Creates a CXTPTrackPaintManager object.
~CXTPTrackPaintManager ()
CXTPTrackPaintManager destructor, handles cleanup and deallocation.
virtual void | DrawTrackHeader (CDC *pDC)
Call this function to draw the track header.
virtual void | DrawMarkers (CDC *pDC)
Call this function to draw the markers.
virtual void | DrawTimeLine (CDC *pDC)
Call this function to draw the time line.
virtual CString | FormatTimeLineTick (int nPosition, COLORREF &clrTick, int &nTickLength)
Call this function to format the time and tick marker relative to a time line position.
virtual CString | FormatTime (int nPosition)
Call this function to format the time and tick marker relative to a time line position.
- Public Member Functions inherited from CXTPGridPaintManager
CXTPGridPaintManager ()
Default CXTPGridPaintManager constructor, handles properties initialization.
virtual | ~CXTPGridPaintManager ()
Default CXTPGridPaintManager destructor, handles member items deallocation.
virtual void | SetGridControl (CXTPGridControl *pControl)
Sets the associated Grid control for the paint manager.
virtual int | GetRowHeight (CDC *pDC, CXTPGridRow *pRow, int nTotalWidth)
Retrieves the default row height for print mode (i.e.
int | GetRowHeightEx (CDC *pDC, CXTPGridRow *pRow, int nTotalWidth, const BOOL firstLevel=TRUE)
Retrieves the default row height for print mode (i.e.
int | GetItemHeight (XTP_GRIDRECORDITEM_DRAWARGS &drawArgs, int nWidth)
Retrieves the height of a record item for a given width.
BOOL | FindRowAdjacentToMergedEx (const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, int &nAdjRowIndex, BOOL bUpward)
Searches the topmost or bottommost row depending on the height of the current row.
int | FindRowAdjacentToMerged (const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, BOOL bUpward)
Wrapper for the FindRowAdjacentToMergedEx method.
int | RecalcTotalHightOfMergedRows (CXTPGridColumns *pColumns, CDC *pDC, CXTPGridRow *pRow, int nRowHeight, int nTotalWidth)
Recalculates row height according to the height of merged items.
virtual int | GetPreviewItemHeight (CDC *pDC, CXTPGridRow *pRow, int nWidth, int nHeight)
Retrieves the height of a preview item for print mode.
virtual int | GetHeaderHeight ()
Gets the column header height.
virtual int | GetHeaderHeight (CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0)
Calculates the optimal header height.
virtual void | SetHeaderHeight (int nHeight)
Sets the column header height.
virtual int | GetFooterHeight (CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0)
Calculates the optimal footer height.
virtual COLORREF | GetControlBackColor (CXTPGridControl *pControl)
Retrieves the parent Grid control's background color.
virtual void | FillRow (CDC *pDC, CXTPGridRow *pRow, CRect rcRow)
Fills a specified row with its background color.
virtual void | DrawGrid (CDC *pDC, XTPGridOrientation orientation, CRect rcGrid)
Draws a grid for the control.
virtual void | DrawFreezeColsDivider (CDC *pDC, const CRect &rc, CXTPGridControl *pControl, CXTPGridRow *pRow=NULL)
Draws a freeze column divider.
virtual void | DrawVerticalTimeLineMarker (CDC *pDC, int xPos, CXTPGridControl *pControl, COLORREF color=RGB(0, 255, 0))
Draws a vertical timeline marker.
virtual void | FillIndent (CDC *pDC, CRect rcRow)
Fills an indent area by its background.
virtual void | FillItemShade (CDC *pDC, CRect rcItem)
Fills an item shade by its background if necessary.
virtual void | FillHeaderControl (CDC *pDC, CRect rcHeader)
Fills a column header control area by its background.
virtual void | FillFooter (CDC *pDC, CRect rcFooter)
Fills a column footer control area by its background.
virtual void | DrawColumn (CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn, BOOL bDrawExternal=FALSE, int nShadowWidth=0)
Draws a column header with all related attributes (sort order, icon, etc.).
virtual void | DrawColumnFooterDivider (CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn)
Draws the column footer divider.
virtual void | DrawColumnFooter (CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn)
Draws the column footer with all related attributes (e.g.
virtual BOOL | IsColumHotTrackingEnabled () const
Determines if hot tracking is enabled for the current column style.
virtual void | FillGroupByControl (CDC *pDC, CRect &rcGroupBy)
Draws the Group By box.
CXTPImageManager * | GetGlyphs () const
Gets a pointer to the additional image list with glyphs.
void | DrawHorizontalLine (CDC *pDC, int xPos, int yPos, int cx, COLORREF clr)
Draws a horizontal line.
void | DrawVerticalLine (CDC *pDC, int xPos, int yPos, int cy, COLORREF clr)
Draws a vertical line.
void | DrawConnector (CDC *pDC, CPoint ptFrom, CPoint ptTo)
Draws a column connector for the Group By box.
virtual CSize | DrawCollapsedBitmap (CDC *pDC, const CXTPGridRow *pRow, CRect &rcBitmap)
Draws a collapsed bitmap.
virtual int | DrawBitmap (CDC *pDC, CXTPGridControl *pControl, CRect rcColumn, int iImage)
Draws a bitmap.
virtual int | DrawColumnIcon (CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, CRect rcIcon, int iIcon)
Draws an icon for a column.
virtual CSize | DrawGlyph (CDC *pDC, CRect rcColumn, int iImage)
Draws the standard glyphs of the Grid control.
virtual CSize | DrawShellIcon (CDC *pDC, CRect rcColumn, int iImage)
Draws the shell icon.
void | EnablePreviewMode (BOOL bIsPreviewMode)
Enables/disables preview mode for the control.
BOOL | IsPreviewMode () const
Determines if preview mode is enabled/disabled for the control.
CFont * | GetTextFont ()
Gets the default text font used for control items.
int | SetMaxPreviewLines (int nMaxLines)
Sets the maximum number of lines of text for a preview item.
int | GetMaxPreviewLines ()
Gets the maximum number of lines of text for a preview item.
int | GetPreviewLinesCount (CDC *pDC, CRect &rcText, const CString &strText)
Calculates the number of lines required to draw a specified preview text string, taking into account the maximum number of lines of text for a preview item.
BOOL | IsGridVisible (BOOL bVertical) const
Determines the visibility of specified grid lines.
BOOL | IsGridVisible (XTPGridOrientation orientation) const
Determines the visibility of specified grid lines.
void | SetColumnStyle (XTPGridColumnStyle columnStyle)
Sets the header style.
XTPGridColumnStyle | GetColumnStyle () const
Gets the header style.
void | SetColumnOffice2007CustomThemeBaseColor (COLORREF clrBaseColor)
Sets the header's custom theme base color for Office2007 column style.
COLORREF | GetColumnOffice2007CustomThemeBaseColor () const
Gets the header's custom theme base color for Office2007 column style.
void | SetTextFont (LOGFONT &lf)
Creates and sets the default text font.
void | SetCaptionFont (LOGFONT &lf)
Creates and sets the default caption font.
void | SetPreviewIndent (int nLeft, int nTop, int nRight, int nBottom)
Sets the preview item indent.
virtual void | DrawInplaceButton (CDC *pDC, CXTPGridInplaceButton *pButton)
Draws the in-place button of the Grid control.
virtual BOOL | DrawInplaceComboButton (CDC *pDC, CRect *pRc)
Draws the combo button of the Grid control.
virtual BOOL | DrawInplaceExpandButton (CDC *pDC, CRect *pRc)
Draws the expand button of the Grid control.
virtual BOOL | DrawInplaceSpinButton (CDC *pDC, CRect *pRc)
Draws the spin button of the Grid control.
virtual void | DrawTreeStructure (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CRect rcItem, CSize sizeGlyph)
Draws tree elements of the Grid control.
virtual void | DrawItemBitmap (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CRect &rcItem, int nImage)
Draws an item bitmap.
virtual void | DrawItemCaption (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics)
Draws an item caption.
virtual void | DrawRowNumber (CDC *pDC, CRect rcNumber, CXTPGridRow *pRow)
Draws a row number.
virtual void | DrawItemControl (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CXTPGridRecordItemControl *pControl, CRect &rcItem)
Draws an item control.
BOOL | IsFixedRowHeight () const
Determines if the paint manager supports fixed or variable row height.
void | SetFixedRowHeight (BOOL bFixedRowHeight)
Sets if the paint manager supports fixed or variable row height.
BOOL | IsColumnWidthWYSIWYG () const
Determines if the paint manager supports column width WYSIWYG mode.
BOOL | IsLastColumnWidthWYSIWYG () const
Determines if the paint manager supports last column width WYSIWYG mode.
BOOL | IsShowWYSIWYGMarkers () const
Determines if the paint manager shows WYSIWYG page-end markers.
void | ShowWYSIWYGMarkers (BOOL bSet)
Sets if the paint manager shows WYSIWYG page-end markers.
void | SetColumnWidthWYSIWYG (BOOL bColumnWidthWYSIWYG)
Sets if the paint manager supports column width WYSIWYG mode.
void | SetLastColumnWidthWYSIWYG (BOOL bColumnWidthWYSIWYG)
Sets if the paint manager supports last column width WYSIWYG mode.
BOOL | IsFixedInplaceButtonHeight () const
Determines if the paint manager supports fixed or variable in-place button height.
void | SetInplaceButtonHeight (BOOL bFixedInplaceButtonHeight)
Sets if the paint manager supports fixed or variable in-place button height.
int | GetFreezeColsDividerStyle () const
Gets the style of the freeze columns divider line.
void | SetFreezeColsDividerStyle (int nStyle)
Sets the style for the freeze columns divider line.
virtual BOOL | OnDrawAction (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs)
Override this method to perform custom activities for the item before processing it.
virtual void | DrawNoGroupByText (CDC *pDC, CRect rcItem)
Draws the "No items" text message in the Group By area when there are no items inside it.
BOOL | IsDrawGridForEmptySpace () const
Determines if the grid fills empty space after body rows.
void | SetDrawGridForEmptySpace (BOOL bDrawGrid)
Sets if the grid fills empty space after body rows.
BOOL | IsPrintGroupRowIcon () const
Determines if the group row collapse-expand icon is drawn in print mode.
void | SetPrintGroupRowIcon (BOOL bDraw)
Sets if the group row collapse-expand icon is drawn in print mode.
BOOL | IsColumnPlusMinusSign () const
Determines if columns use expand/collapse icons (+/-) or directional arrows.
void | SetColumnPlusMinusSign (BOOL bDraw)
Specifies if columns use expand/collapse icons (+/-) or directional arrows.
virtual int | CalculateRowHeight (CDC *pDC, const CString &strText, int nMaxWidth, BOOL bWordBreak=TRUE)
Calculates the height required for a rectangle bounding multi-line text to draw the multi-line text when the width of the rectangle is fixed.
void | DrawSectionDivider (CDC *pDC, const CRect &rc, XTPGridSectionDividerPosition dividerPosition, XTPGridSectionDividerStyle dividerStyle, CXTPPaintManagerColor dividerColor)
Draws the divider between grid sections (e.g.
int | GetSectionDividerHeight (XTPGridFixedRowsDividerStyle dividerStyle)
Gets the height of the section divider.
BOOL | IsUseDropMarker () const
Determines if a drop marker will be used when dragging and dropping.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPTrackThemeOffice2013
CXTPPaintManagerColor | m_clrGlyph
Header glyph color.
CXTPPaintManagerColor | m_clrGlyphHighlight
Header highlighted glyph color.
CXTPPaintManagerColor | m_clrSelectedBorder
Selected block border.
- Public Attributes inherited from CXTPTrackPaintManager
COLORREF | m_clrWorkArea
The color of the work area.
COLORREF | m_clrTrackHeader
The track header color.
COLORREF | m_clrTrackTimeArea
The track time area color.
COLORREF | m_clrTimeHeaderDarkDark
The header deep dark color.
COLORREF | m_clrTimeHeaderDark
The header dark color.
COLORREF | m_clrTimeSliderBackground
The slider background color.
COLORREF | m_clrTimeHeaderDivider
The header divider color.
COLORREF | m_clrScrollBarLight
The scrollbar light color.
COLORREF | m_clrScrollBarDark
The scrollbar dark color.
COLORREF | m_clrSelectedArea
The color of the selected area.
COLORREF | m_clrMarker
The color of the marker.
COLORREF | m_clrTimeLineTick
The color of a time line tick.
COLORREF | m_clrMarkerBorder
The color of a time line marker's border.
COLORREF | m_clrMarkerBack
The color of a time line marker's back.
COLORREF | m_clrTrackMarkerBorder
The color of a track marker's border.
COLORREF | m_clrTrackMarkerText
The color of a track marker's text.
COLORREF | m_clrTrackMarkerTextBack
The color of a track marker's text back.
COLORREF | m_clrTrackMarkerTextBorder
The color of a track marker's text border.
COLORREF | m_clrTimeLinePosition
The color of a marked position on a time line.
COLORREF | m_clrTimeHeaderBorder
The color of a time line header's border.
COLORREF | m_clrScrollBarBorderDark
The scrollbar border dark color.
COLORREF | m_clrScrollBarBorderLight
The scrollbar border light color.
COLORREF | m_clrWorkAreaScrollBarLight
The workarea scrollbar light color.
COLORREF | m_clrWorkAreaScrollBarDark
The workarea scrollbar dark color.
COLORREF | m_clrWorkAreaScrollBarBorder
The workarea scrollbar border color.
- Public Attributes inherited from CXTPGridPaintManager
CXTPFont | m_xtpFontText
Grid items default text.
CXTPFont | m_xtpFontBoldText
Grid items default bold text.
CXTPFont | m_xtpFontCaption
Column header caption font.
CXTPFont | m_xtpFontPreview
Column header caption font.
CXTPGridHyperlinkStyle * | m_pHyperlinkStyle
Style for links.
CXTPGridHyperlinkStyle * | m_pHyperlinkHoverStyle
Style for hovered links.
CXTPPaintManagerColor | m_clrHighlight
Background color of the highlighted row.
CXTPPaintManagerColor | m_clrBoldText
Grid items bold text color.
CXTPPaintManagerColor | m_clrBoldTextHighlight
Grid items bold text highlight color.
CXTPPaintManagerColor | m_clrWindowText
Grid items default text color.
CXTPPaintManagerColor | m_clrHighlightText
Text color of the highlighted text.
CXTPPaintManagerColor | m_clrHeaderControl
Background color of the grid header.
CXTPPaintManagerColor | m_clrCaptionText
Column header text color.
CXTPPaintManagerColor | m_clrCaptionTextPressed
Column header text color when pressed.
CXTPPaintManagerColor | m_clrControlBack
Background color of the control grid area.
CXTPPaintManagerColor | m_clrGroupRowText
Row text color.
CXTPPaintManagerColor | m_clrGroupShadeBack
Group row background color when indentation shade is enabled.
CXTPPaintManagerColor | m_clrGroupShadeText
Group row foreground color when indentation shade is enabled.
CXTPPaintManagerColor | m_clrGroupShadeBorder
Color for group border's shade.
CXTPPaintManagerColor | m_clrGroupBoxBack
Color of group box.
CXTPPaintManagerColor | m_clrControlDark
Dark background color of the Grid control (used on Group By area).
CXTPPaintManagerColor | m_clrControlLightLight
Light background color used for drawing shades (used on column header area).
CXTPPaintManagerColor | m_clrHotDivider
Color of the column hot divider window (two arrows).
CXTPPaintManagerColor | m_clrIndentControl
Color of the tree indentation area.
CXTPPaintManagerColor | m_clrItemShade
Color of the shade on sorted by column items.
CXTPPaintManagerColor | m_clrBtnFace
Standard button face color.
CXTPPaintManagerColor | m_clrBtnText
Standard button text color.
CXTPPaintManagerColor | m_clrPreviewText
Preview text color.
CXTPPaintManagerColor | m_clrSelectedRow
Selected row background color.
CXTPPaintManagerColor | m_clrSelectedRowText
Selected row text color.
CXTPPaintManagerColor | m_clrBtnFacePressed
Standard button face color when pressed.
CXTPPaintManagerColor | m_clrConnector
Header column connector line color.
CXTPPaintManagerColor | m_clrDisableBitmapLightest
The lightest color of bitmap which covers disabled grid.
CXTPPaintManagerColor | m_clrDisableBitmapDarkest
The darkest color of bitmap which covers disabled grid.
CXTPPaintManagerColorGradient | m_grcGradientColumn
Color of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColorGradient | m_grcGradientColumnHot
HotTracking Color of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColorGradient | m_grcGradientColumnPushed
Pushed Color of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColor | m_clrGradientColumnShadow
Bottom shadow of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColor | m_clrGradientColumnSeparator
Separator of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColor | m_crlNoGroupByText
A color for "No items" text in GroupBy area (see m_strNoGroupBy member).
CXTPPaintManagerColor | m_clrFreezeColsDivider
Freeze Columns Divider color.
COLORREF | m_clrColumnOffice2007CustomTheme
Base color for Office2007 custom theme.
COLORREF | m_clrFormulaSum
Color for Formula Sum fields.
COLORREF | m_clrFormulaSubSum
Color for Formula SubSum fields.
COLORREF | m_clrAlternativeBackground
Color for Alternative Row Background.
BOOL | m_bUseAlternativeBackground
TRUE to use Alternative Row Background, FALSE otherwise.
BOOL | m_bAllowMergeCells
TRUE to Allow Merge Cells, FALSE otherwise.
int | m_nTextIndentForGroupRowsWithNoIcon
Specifies Text indent if a group row icon is not used.
int | m_nTreeIndent
Tree indentation.
int | m_nTreeStructureStyle
Tree structure style.
int | m_nTreeTextIndentRowParent
Text indent, in pixels, for rows with children.
int | m_nTreeTextIndentRowChildren
Text indent, in pixels, for rows without children.
int | m_nTreeTextIndent
Text indent, in pixels, for rows that are neither parent nor children.
int | m_nTreeTextIndentGroupRow
Text indent, in pixels, for group rows.
BOOL | m_bGroupRowTextBold
TRUE to draw group rows with bold text.
BOOL | m_bShadeGroupHeadings
TRUE to show the indentation shade, FALSE otherwise.
BOOL | m_bShadeSortColumn
TRUE to show the items shade in the sorted by column, FALSE otherwise.
BOOL | m_bHotTracking
TRUE to allow column hot tracking.
BOOL | m_bInvertColumnOnClick
TRUE to invert column on click.
CString | m_strNoItems
A string which contains customized "No Items" text for displaying in view when there are no visible rows.
CString | m_strSortBy
A string which contains customized "Sort By" text for displaying in tooltip.
CString | m_strIncreasing
A string which contains customized "Increasing" text for displaying in tooltip.
CString | m_strDecreasing
A string which contains customized "Decreasing" text for displaying in tooltip.
CString | m_strNoGroupBy
A string which contains customized "No items" text message for displaying in Group By area when there are no items inside it.
CString | m_strNoFieldsAvailable
A string which contains customized "No Fields Available" text message for displaying in Field Chooser.
CString | m_strExpand
A string which contains customized "Expand" text for displaying in tooltip.
CString | m_strCollapse
A string which contains customized "Collapse" text for displaying in tooltip.
BOOL | m_bHideSelection
TRUE when hiding Grid control's selection by drawing selected items as others, FALSE otherwise.
BOOL | m_bPrintSortTriangle
TRUE to show the sort triangle in printout.
BOOL | m_bRevertAlignment
TRUE to revert column alignments.
BOOL | m_bUseEditTextAlignment
TRUE to automatically apply edit alignment using column alignment.
BOOL | m_bShowLockIcon
TRUE to show the lock icon, FALSE to hide.
BOOL | m_bUseShellIcon
TRUE to use the shell icon, FALSE otherwise.
int | m_iRecOrRowStart
Start position in numbering (0 or 1 or something user want).
BOOL | m_bRecOrRowNum
TRUE to display record number if support mode is used, FALSE to display row number.
BOOL | m_bMakeUpper
TRUE to display column header and group row text in all caps.
XTPGridTreeStructureStyle | m_treeStructureStyle
Tree structure style.
CRect | m_rcPreviewIndent
Preview indentation.
int | m_nFixedColumnsIndent
Fixed Column total width.
BOOL | m_bMoveScrollbarOnFixedColumnsIndent
Move Scrollbar right follow FixedColumnsIndent.
BOOL | m_bThemedInplaceButtons
Draw in-place buttons using current theme settings.
BOOL | m_bBaseTreeIndent
TRUE to add Extra Tree indentation to cover initial TreeColumn.
CUIntArray | m_arStartCol
Start column in each virtual page.
int | m_PrintPageWidth
Width of print page (run-time)
BOOL | m_bPrintVirtualPageNumber
TRUE to print horizontal page number.
BOOL | m_bPrintPageRectangle
TRUE to draw rectangle around page.
int | m_RecordNumberWidth
Column width for row/record numbers.
BOOL | m_bForceDynamicMarkupForCell
TRUE if use Markup for Grid Record Item.
BOOL | m_bForceShowDropMarker
TRUE if Force Show Drop Marker.
BOOL | m_bShowNonActiveInPlaceButton
TRUE if use Show Non-Active In-Place Button (Combo, Expand, Spin).
BOOL | m_bPrintWatermark
TRUE to print watermark.
BOOL | m_bUseGroupRowSelectionState
TRUE if use GroupSelectionState Glyph.
BOOL | m_bForceShowTooltip
TRUE if use show tooltip for any cell width case.
BOOL | m_bCleanTooltip
TRUE if use show tooltip without markup.
BOOL | m_bGrayIfDisable
TRUE is disable draw in gray (standard behavior).
int | m_nRowHeightDefault
The default row height.
BOOL | m_bCompactText
TRUE to ignore Icon for Narrow column to show more text.
BOOL | m_bUseDropMarker
FALSE to not draw drop marked when dragging/dropping, TRUE by default.
BOOL | m_bSortTriangleOffsetFromRight
Offset of sort triangle.
int | m_nTreeColumnLineLength
This is the extra line length to apply to tree column lines if there is no expand button.
int | m_nBaseParentRecordIndent
This is initial number of pixels a parent node will be indented when in a group.
- Protected Member Functions inherited from CXTPTrackPaintManager
- Protected Member Functions inherited from CXTPGridPaintManager
virtual void | DrawTextLine (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nFlag, int &nCharCounter, int &nHyperlinkCounter)
Draws a line of text with respect to the drawing rectangle.
virtual int | DrawString (int *pnCurrDrawPos, CDC *pDC, const CString &strDraw, CRect rcDraw, UINT nFormat)
Draw a simple string into rectangle.
virtual void | DrawGridPattern (CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush)
Generates a custom grid pattern if necessary.
virtual void | DrawGridPattern (CDC *pDC, CXTPBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush)
Generates a custom grid pattern if necessary.
virtual void | DrawGridPattern (CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr)
Generates a custom grid pattern.
virtual void | DrawInplaceButtonFrame (CDC *pDC, CXTPGridInplaceButton *pButton)
Draws the in-place button frame.
virtual BOOL | DrawInplaceButtonIcon (CDC *pDC, CXTPGridInplaceButton *pButton)
Draws the in-place button icon.
virtual int | CalcColumnHeight (CDC *pDC, CXTPGridColumn *pColumn, int nTotalWidth=0)
Calculates the optimal height for a specified column.
virtual void | DrawMultiLineText (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, BOOL bWordBreak=TRUE)
Draws multi-line text.
virtual void | DrawSingleLineText (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nStartPos, int nEndPos, int nActualWidth)
Draws single-line text.
virtual int | DrawLink (int *pnCurrDrawPos, XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CXTPGridHyperlink *pHyperlink, CString strText, CRect rcLink, int nFlag, BOOL bTrim=FALSE)
Draws a hyperlink string using hyperlink text settings (i.e.
- Protected Attributes inherited from CXTPGridPaintManager
int | m_nRowHeight
Grid row default height.
int | m_nHeaderHeight
Column header height.
int | m_nFooterHeight
Column footer height.
int | m_nGroupGridLineHeight
The height of the group grid line.
CXTPImageManager * | m_pGlyphs
An additional image list for the Grid control.
BOOL | m_bIsPreviewMode
TRUE to show the item preview, FALSE to hide.
int | m_nResizingWidth
The width of the column resizing marker area.
int | m_nMaxPreviewLines
Restrict maximum lines for preview text.
CSize | m_szGlyph
Glyph size.
CXTPBrush | m_xtpBrushTreeStructure
Brush to draw tree nodes.
CXTPBrush | m_xtpBrushGroupGridLineStyle
Brush to draw group row grid lines.
int | m_nFreezeColsDividerStyle
A set of flags from XTPGridFreezeColsDividerStyle.
BOOL | m_bFixedRowHeight
TRUE if fixed rows used.
BOOL | m_bColumnWidthWYSIWYG
TRUE if columns width WYSIWYG mode used.
BOOL | m_bShowWYSIWYGMarkers
TRUE if in non-print mode header show red page-end markers.
BOOL | m_bLastColumnWidthWYSIWYG
TRUE if last column width WYSIWYG mode used.
BOOL | m_bDrawGridForEmptySpace
TRUE if grid fills the empty space (if any) after the body rows.
BOOL | m_bPrintGroupRowIcon
TRUE if printout draw collapse-expand icon for group row.
BOOL | m_bColumnPlusMinusSign
TRUE if expand/collapse icons are used, FALSE if directional arrows are used.
BOOL | m_bFixedInplaceButtonHeight
TRUE if fixed in-place button height is used.
XTPGridGridStyle | m_nGroupGridLineStyle
Current style for group row grid lines.
XTPGridColumnStyle | m_columnStyle
Column drawing style.
CXTPWinThemeWrapper * | m_themeHeader
Header theme wrapper.
CXTPWinThemeWrapper * | m_themeButton
In-place button theme wrapper.
CXTPWinThemeWrapper * | m_themeCombo
Combo box in-place button theme wrapper.
CXTPWinThemeWrapper * | m_themeSpin
Spin in-place button theme wrapper.
CXTPGridControl * | m_pControl
Pointer to the Grid control object.
CXTPMarkupUIElement * | m_pMarkupUIElement_NoGroupBy
The no group by markup UI element.
CString | m_strMarkupUIElement_NoGroupBy
The no group by markup UI element string.
CXTPBrush | m_xtpBrushVeriticalGrid
Brush to draw vertical grid lines.
CXTPBrush | m_xtpBrushHorizontalGrid
Brush to draw horizontal grid lines.
XTPGridGridStyle m_nGridLineStylePreviousV
Previous style for vertical grid lines.
XTPGridGridStyle m_nGridLineStylePreviousH
Previous style for horizontal grid lines.

Detailed Description

CXTPTrackThemeVisualStudio2012Dark is a CXTPTrackThemeOffice2013 derived class that represents a Visual Studio 2012 Dark style theme.

The documentation for this class was generated from the following file:
  • XTPTrackThemeVisualStudio2012.h


Toolkit Pro: CXTPTrackThemeVisualStudio2012Light Class Reference

Public Member Functions | List of all members
CXTPTrackThemeVisualStudio2012Light Class Reference

CXTPTrackThemeVisualStudio2012Light is a CXTPTrackThemeOffice2013 derived class that represents a Visual Studio 2012 Light style theme. More...

Inheritance diagram for CXTPTrackThemeVisualStudio2012Light:
[legend]

Public Member Functions

CXTPTrackThemeVisualStudio2012Light ()
Default paint manager constructor, handles properties initialization.
virtual void | LoadGlyphs ()
Loads the default images used by the track control.
virtual void | RefreshMetrics ()
This method is called to refresh the visual metrics of the track control.
- Public Member Functions inherited from CXTPTrackThemeOffice2013
CXTPTrackThemeOffice2013 ()
Default paint manager constructor, handles properties initialization.
virtual void | DrawColumnText (CDC *pDC, CRect rcText, CString strCaption, int nHeaderAlignment, BOOL bIsHeader, BOOL bColumnPressed)
Draws text for the column header.
virtual void | DrawColumnBackground (CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, BOOL &bColumnPressed, BOOL &bDraggingFromHeader, CXTPGridHeader *pHeader=NULL)
This method is called to draw the background of a column using the current column style.
virtual void | DrawTriangle (CDC *pDC, CRect rcTriangle, BOOL bToDown, BOOL bDraggingFromHeader, int nShadowWidth, BOOL bColumnPressed)
Draws a triangle that shows the sort order of the column.
virtual void | FillGroupRowMetrics (CXTPGridGroupRow *pRow, XTP_GRIDRECORDITEM_METRICS *pMetrics, BOOL bPrinting)
Fills the font and color members of the metrics structure for a specified group row.
virtual void | DrawGroupRow (CDC *pDC, CXTPGridGroupRow *pRow, CRect rcRow, XTP_GRIDRECORDITEM_METRICS *pMetrics)
Draws a group row.
virtual void | DrawFocusedRow (CDC *pDC, CRect rcRow)
Draws focused rows.
virtual int | GetRowHeight (CDC *pDC, CXTPGridRow *pRow)
Retrieves the default row height for print mode (i.e.
- Public Member Functions inherited from CXTPTrackPaintManager
CXTPTrackPaintManager ()
Creates a CXTPTrackPaintManager object.
~CXTPTrackPaintManager ()
CXTPTrackPaintManager destructor, handles cleanup and deallocation.
virtual void | DrawTrackHeader (CDC *pDC)
Call this function to draw the track header.
virtual void | DrawMarkers (CDC *pDC)
Call this function to draw the markers.
virtual void | DrawTimeLine (CDC *pDC)
Call this function to draw the time line.
virtual CString | FormatTimeLineTick (int nPosition, COLORREF &clrTick, int &nTickLength)
Call this function to format the time and tick marker relative to a time line position.
virtual CString | FormatTime (int nPosition)
Call this function to format the time and tick marker relative to a time line position.
- Public Member Functions inherited from CXTPGridPaintManager
CXTPGridPaintManager ()
Default CXTPGridPaintManager constructor, handles properties initialization.
virtual | ~CXTPGridPaintManager ()
Default CXTPGridPaintManager destructor, handles member items deallocation.
virtual void | SetGridControl (CXTPGridControl *pControl)
Sets the associated Grid control for the paint manager.
virtual int | GetRowHeight (CDC *pDC, CXTPGridRow *pRow, int nTotalWidth)
Retrieves the default row height for print mode (i.e.
int | GetRowHeightEx (CDC *pDC, CXTPGridRow *pRow, int nTotalWidth, const BOOL firstLevel=TRUE)
Retrieves the default row height for print mode (i.e.
int | GetItemHeight (XTP_GRIDRECORDITEM_DRAWARGS &drawArgs, int nWidth)
Retrieves the height of a record item for a given width.
BOOL | FindRowAdjacentToMergedEx (const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, int &nAdjRowIndex, BOOL bUpward)
Searches the topmost or bottommost row depending on the height of the current row.
int | FindRowAdjacentToMerged (const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, BOOL bUpward)
Wrapper for the FindRowAdjacentToMergedEx method.
int | RecalcTotalHightOfMergedRows (CXTPGridColumns *pColumns, CDC *pDC, CXTPGridRow *pRow, int nRowHeight, int nTotalWidth)
Recalculates row height according to the height of merged items.
virtual int | GetPreviewItemHeight (CDC *pDC, CXTPGridRow *pRow, int nWidth, int nHeight)
Retrieves the height of a preview item for print mode.
virtual int | GetHeaderHeight ()
Gets the column header height.
virtual int | GetHeaderHeight (CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0)
Calculates the optimal header height.
virtual void | SetHeaderHeight (int nHeight)
Sets the column header height.
virtual int | GetFooterHeight (CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0)
Calculates the optimal footer height.
virtual COLORREF | GetControlBackColor (CXTPGridControl *pControl)
Retrieves the parent Grid control's background color.
virtual void | FillRow (CDC *pDC, CXTPGridRow *pRow, CRect rcRow)
Fills a specified row with its background color.
virtual void | DrawGrid (CDC *pDC, XTPGridOrientation orientation, CRect rcGrid)
Draws a grid for the control.
virtual void | DrawFreezeColsDivider (CDC *pDC, const CRect &rc, CXTPGridControl *pControl, CXTPGridRow *pRow=NULL)
Draws a freeze column divider.
virtual void | DrawVerticalTimeLineMarker (CDC *pDC, int xPos, CXTPGridControl *pControl, COLORREF color=RGB(0, 255, 0))
Draws a vertical timeline marker.
virtual void | FillIndent (CDC *pDC, CRect rcRow)
Fills an indent area by its background.
virtual void | FillItemShade (CDC *pDC, CRect rcItem)
Fills an item shade by its background if necessary.
virtual void | FillHeaderControl (CDC *pDC, CRect rcHeader)
Fills a column header control area by its background.
virtual void | FillFooter (CDC *pDC, CRect rcFooter)
Fills a column footer control area by its background.
virtual void | DrawColumn (CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn, BOOL bDrawExternal=FALSE, int nShadowWidth=0)
Draws a column header with all related attributes (sort order, icon, etc.).
virtual void | DrawColumnFooterDivider (CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn)
Draws the column footer divider.
virtual void | DrawColumnFooter (CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn)
Draws the column footer with all related attributes (e.g.
virtual BOOL | IsColumHotTrackingEnabled () const
Determines if hot tracking is enabled for the current column style.
virtual void | FillGroupByControl (CDC *pDC, CRect &rcGroupBy)
Draws the Group By box.
CXTPImageManager * | GetGlyphs () const
Gets a pointer to the additional image list with glyphs.
void | DrawHorizontalLine (CDC *pDC, int xPos, int yPos, int cx, COLORREF clr)
Draws a horizontal line.
void | DrawVerticalLine (CDC *pDC, int xPos, int yPos, int cy, COLORREF clr)
Draws a vertical line.
void | DrawConnector (CDC *pDC, CPoint ptFrom, CPoint ptTo)
Draws a column connector for the Group By box.
virtual CSize | DrawCollapsedBitmap (CDC *pDC, const CXTPGridRow *pRow, CRect &rcBitmap)
Draws a collapsed bitmap.
virtual int | DrawBitmap (CDC *pDC, CXTPGridControl *pControl, CRect rcColumn, int iImage)
Draws a bitmap.
virtual int | DrawColumnIcon (CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, CRect rcIcon, int iIcon)
Draws an icon for a column.
virtual CSize | DrawGlyph (CDC *pDC, CRect rcColumn, int iImage)
Draws the standard glyphs of the Grid control.
virtual CSize | DrawShellIcon (CDC *pDC, CRect rcColumn, int iImage)
Draws the shell icon.
void | EnablePreviewMode (BOOL bIsPreviewMode)
Enables/disables preview mode for the control.
BOOL | IsPreviewMode () const
Determines if preview mode is enabled/disabled for the control.
CFont * | GetTextFont ()
Gets the default text font used for control items.
int | SetMaxPreviewLines (int nMaxLines)
Sets the maximum number of lines of text for a preview item.
int | GetMaxPreviewLines ()
Gets the maximum number of lines of text for a preview item.
int | GetPreviewLinesCount (CDC *pDC, CRect &rcText, const CString &strText)
Calculates the number of lines required to draw a specified preview text string, taking into account the maximum number of lines of text for a preview item.
BOOL | IsGridVisible (BOOL bVertical) const
Determines the visibility of specified grid lines.
BOOL | IsGridVisible (XTPGridOrientation orientation) const
Determines the visibility of specified grid lines.
void | SetColumnStyle (XTPGridColumnStyle columnStyle)
Sets the header style.
XTPGridColumnStyle | GetColumnStyle () const
Gets the header style.
void | SetColumnOffice2007CustomThemeBaseColor (COLORREF clrBaseColor)
Sets the header's custom theme base color for Office2007 column style.
COLORREF | GetColumnOffice2007CustomThemeBaseColor () const
Gets the header's custom theme base color for Office2007 column style.
void | SetTextFont (LOGFONT &lf)
Creates and sets the default text font.
void | SetCaptionFont (LOGFONT &lf)
Creates and sets the default caption font.
void | SetPreviewIndent (int nLeft, int nTop, int nRight, int nBottom)
Sets the preview item indent.
virtual void | DrawInplaceButton (CDC *pDC, CXTPGridInplaceButton *pButton)
Draws the in-place button of the Grid control.
virtual BOOL | DrawInplaceComboButton (CDC *pDC, CRect *pRc)
Draws the combo button of the Grid control.
virtual BOOL | DrawInplaceExpandButton (CDC *pDC, CRect *pRc)
Draws the expand button of the Grid control.
virtual BOOL | DrawInplaceSpinButton (CDC *pDC, CRect *pRc)
Draws the spin button of the Grid control.
virtual void | DrawTreeStructure (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CRect rcItem, CSize sizeGlyph)
Draws tree elements of the Grid control.
virtual void | DrawItemBitmap (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CRect &rcItem, int nImage)
Draws an item bitmap.
virtual void | DrawItemCaption (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics)
Draws an item caption.
virtual void | DrawRowNumber (CDC *pDC, CRect rcNumber, CXTPGridRow *pRow)
Draws a row number.
virtual void | DrawItemControl (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CXTPGridRecordItemControl *pControl, CRect &rcItem)
Draws an item control.
BOOL | IsFixedRowHeight () const
Determines if the paint manager supports fixed or variable row height.
void | SetFixedRowHeight (BOOL bFixedRowHeight)
Sets if the paint manager supports fixed or variable row height.
BOOL | IsColumnWidthWYSIWYG () const
Determines if the paint manager supports column width WYSIWYG mode.
BOOL | IsLastColumnWidthWYSIWYG () const
Determines if the paint manager supports last column width WYSIWYG mode.
BOOL | IsShowWYSIWYGMarkers () const
Determines if the paint manager shows WYSIWYG page-end markers.
void | ShowWYSIWYGMarkers (BOOL bSet)
Sets if the paint manager shows WYSIWYG page-end markers.
void | SetColumnWidthWYSIWYG (BOOL bColumnWidthWYSIWYG)
Sets if the paint manager supports column width WYSIWYG mode.
void | SetLastColumnWidthWYSIWYG (BOOL bColumnWidthWYSIWYG)
Sets if the paint manager supports last column width WYSIWYG mode.
BOOL | IsFixedInplaceButtonHeight () const
Determines if the paint manager supports fixed or variable in-place button height.
void | SetInplaceButtonHeight (BOOL bFixedInplaceButtonHeight)
Sets if the paint manager supports fixed or variable in-place button height.
int | GetFreezeColsDividerStyle () const
Gets the style of the freeze columns divider line.
void | SetFreezeColsDividerStyle (int nStyle)
Sets the style for the freeze columns divider line.
virtual BOOL | OnDrawAction (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs)
Override this method to perform custom activities for the item before processing it.
virtual void | DrawNoGroupByText (CDC *pDC, CRect rcItem)
Draws the "No items" text message in the Group By area when there are no items inside it.
BOOL | IsDrawGridForEmptySpace () const
Determines if the grid fills empty space after body rows.
void | SetDrawGridForEmptySpace (BOOL bDrawGrid)
Sets if the grid fills empty space after body rows.
BOOL | IsPrintGroupRowIcon () const
Determines if the group row collapse-expand icon is drawn in print mode.
void | SetPrintGroupRowIcon (BOOL bDraw)
Sets if the group row collapse-expand icon is drawn in print mode.
BOOL | IsColumnPlusMinusSign () const
Determines if columns use expand/collapse icons (+/-) or directional arrows.
void | SetColumnPlusMinusSign (BOOL bDraw)
Specifies if columns use expand/collapse icons (+/-) or directional arrows.
virtual int | CalculateRowHeight (CDC *pDC, const CString &strText, int nMaxWidth, BOOL bWordBreak=TRUE)
Calculates the height required for a rectangle bounding multi-line text to draw the multi-line text when the width of the rectangle is fixed.
void | DrawSectionDivider (CDC *pDC, const CRect &rc, XTPGridSectionDividerPosition dividerPosition, XTPGridSectionDividerStyle dividerStyle, CXTPPaintManagerColor dividerColor)
Draws the divider between grid sections (e.g.
int | GetSectionDividerHeight (XTPGridFixedRowsDividerStyle dividerStyle)
Gets the height of the section divider.
BOOL | IsUseDropMarker () const
Determines if a drop marker will be used when dragging and dropping.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPTrackThemeOffice2013
CXTPPaintManagerColor | m_clrGlyph
Header glyph color.
CXTPPaintManagerColor | m_clrGlyphHighlight
Header highlighted glyph color.
CXTPPaintManagerColor | m_clrSelectedBorder
Selected block border.
- Public Attributes inherited from CXTPTrackPaintManager
COLORREF | m_clrWorkArea
The color of the work area.
COLORREF | m_clrTrackHeader
The track header color.
COLORREF | m_clrTrackTimeArea
The track time area color.
COLORREF | m_clrTimeHeaderDarkDark
The header deep dark color.
COLORREF | m_clrTimeHeaderDark
The header dark color.
COLORREF | m_clrTimeSliderBackground
The slider background color.
COLORREF | m_clrTimeHeaderDivider
The header divider color.
COLORREF | m_clrScrollBarLight
The scrollbar light color.
COLORREF | m_clrScrollBarDark
The scrollbar dark color.
COLORREF | m_clrSelectedArea
The color of the selected area.
COLORREF | m_clrMarker
The color of the marker.
COLORREF | m_clrTimeLineTick
The color of a time line tick.
COLORREF | m_clrMarkerBorder
The color of a time line marker's border.
COLORREF | m_clrMarkerBack
The color of a time line marker's back.
COLORREF | m_clrTrackMarkerBorder
The color of a track marker's border.
COLORREF | m_clrTrackMarkerText
The color of a track marker's text.
COLORREF | m_clrTrackMarkerTextBack
The color of a track marker's text back.
COLORREF | m_clrTrackMarkerTextBorder
The color of a track marker's text border.
COLORREF | m_clrTimeLinePosition
The color of a marked position on a time line.
COLORREF | m_clrTimeHeaderBorder
The color of a time line header's border.
COLORREF | m_clrScrollBarBorderDark
The scrollbar border dark color.
COLORREF | m_clrScrollBarBorderLight
The scrollbar border light color.
COLORREF | m_clrWorkAreaScrollBarLight
The workarea scrollbar light color.
COLORREF | m_clrWorkAreaScrollBarDark
The workarea scrollbar dark color.
COLORREF | m_clrWorkAreaScrollBarBorder
The workarea scrollbar border color.
- Public Attributes inherited from CXTPGridPaintManager
CXTPFont | m_xtpFontText
Grid items default text.
CXTPFont | m_xtpFontBoldText
Grid items default bold text.
CXTPFont | m_xtpFontCaption
Column header caption font.
CXTPFont | m_xtpFontPreview
Column header caption font.
CXTPGridHyperlinkStyle * | m_pHyperlinkStyle
Style for links.
CXTPGridHyperlinkStyle * | m_pHyperlinkHoverStyle
Style for hovered links.
CXTPPaintManagerColor | m_clrHighlight
Background color of the highlighted row.
CXTPPaintManagerColor | m_clrBoldText
Grid items bold text color.
CXTPPaintManagerColor | m_clrBoldTextHighlight
Grid items bold text highlight color.
CXTPPaintManagerColor | m_clrWindowText
Grid items default text color.
CXTPPaintManagerColor | m_clrHighlightText
Text color of the highlighted text.
CXTPPaintManagerColor | m_clrHeaderControl
Background color of the grid header.
CXTPPaintManagerColor | m_clrCaptionText
Column header text color.
CXTPPaintManagerColor | m_clrCaptionTextPressed
Column header text color when pressed.
CXTPPaintManagerColor | m_clrControlBack
Background color of the control grid area.
CXTPPaintManagerColor | m_clrGroupRowText
Row text color.
CXTPPaintManagerColor | m_clrGroupShadeBack
Group row background color when indentation shade is enabled.
CXTPPaintManagerColor | m_clrGroupShadeText
Group row foreground color when indentation shade is enabled.
CXTPPaintManagerColor | m_clrGroupShadeBorder
Color for group border's shade.
CXTPPaintManagerColor | m_clrGroupBoxBack
Color of group box.
CXTPPaintManagerColor | m_clrControlDark
Dark background color of the Grid control (used on Group By area).
CXTPPaintManagerColor | m_clrControlLightLight
Light background color used for drawing shades (used on column header area).
CXTPPaintManagerColor | m_clrHotDivider
Color of the column hot divider window (two arrows).
CXTPPaintManagerColor | m_clrIndentControl
Color of the tree indentation area.
CXTPPaintManagerColor | m_clrItemShade
Color of the shade on sorted by column items.
CXTPPaintManagerColor | m_clrBtnFace
Standard button face color.
CXTPPaintManagerColor | m_clrBtnText
Standard button text color.
CXTPPaintManagerColor | m_clrPreviewText
Preview text color.
CXTPPaintManagerColor | m_clrSelectedRow
Selected row background color.
CXTPPaintManagerColor | m_clrSelectedRowText
Selected row text color.
CXTPPaintManagerColor | m_clrBtnFacePressed
Standard button face color when pressed.
CXTPPaintManagerColor | m_clrConnector
Header column connector line color.
CXTPPaintManagerColor | m_clrDisableBitmapLightest
The lightest color of bitmap which covers disabled grid.
CXTPPaintManagerColor | m_clrDisableBitmapDarkest
The darkest color of bitmap which covers disabled grid.
CXTPPaintManagerColorGradient | m_grcGradientColumn
Color of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColorGradient | m_grcGradientColumnHot
HotTracking Color of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColorGradient | m_grcGradientColumnPushed
Pushed Color of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColor | m_clrGradientColumnShadow
Bottom shadow of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColor | m_clrGradientColumnSeparator
Separator of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColor | m_crlNoGroupByText
A color for "No items" text in GroupBy area (see m_strNoGroupBy member).
CXTPPaintManagerColor | m_clrFreezeColsDivider
Freeze Columns Divider color.
COLORREF | m_clrColumnOffice2007CustomTheme
Base color for Office2007 custom theme.
COLORREF | m_clrFormulaSum
Color for Formula Sum fields.
COLORREF | m_clrFormulaSubSum
Color for Formula SubSum fields.
COLORREF | m_clrAlternativeBackground
Color for Alternative Row Background.
BOOL | m_bUseAlternativeBackground
TRUE to use Alternative Row Background, FALSE otherwise.
BOOL | m_bAllowMergeCells
TRUE to Allow Merge Cells, FALSE otherwise.
int | m_nTextIndentForGroupRowsWithNoIcon
Specifies Text indent if a group row icon is not used.
int | m_nTreeIndent
Tree indentation.
int | m_nTreeStructureStyle
Tree structure style.
int | m_nTreeTextIndentRowParent
Text indent, in pixels, for rows with children.
int | m_nTreeTextIndentRowChildren
Text indent, in pixels, for rows without children.
int | m_nTreeTextIndent
Text indent, in pixels, for rows that are neither parent nor children.
int | m_nTreeTextIndentGroupRow
Text indent, in pixels, for group rows.
BOOL | m_bGroupRowTextBold
TRUE to draw group rows with bold text.
BOOL | m_bShadeGroupHeadings
TRUE to show the indentation shade, FALSE otherwise.
BOOL | m_bShadeSortColumn
TRUE to show the items shade in the sorted by column, FALSE otherwise.
BOOL | m_bHotTracking
TRUE to allow column hot tracking.
BOOL | m_bInvertColumnOnClick
TRUE to invert column on click.
CString | m_strNoItems
A string which contains customized "No Items" text for displaying in view when there are no visible rows.
CString | m_strSortBy
A string which contains customized "Sort By" text for displaying in tooltip.
CString | m_strIncreasing
A string which contains customized "Increasing" text for displaying in tooltip.
CString | m_strDecreasing
A string which contains customized "Decreasing" text for displaying in tooltip.
CString | m_strNoGroupBy
A string which contains customized "No items" text message for displaying in Group By area when there are no items inside it.
CString | m_strNoFieldsAvailable
A string which contains customized "No Fields Available" text message for displaying in Field Chooser.
CString | m_strExpand
A string which contains customized "Expand" text for displaying in tooltip.
CString | m_strCollapse
A string which contains customized "Collapse" text for displaying in tooltip.
BOOL | m_bHideSelection
TRUE when hiding Grid control's selection by drawing selected items as others, FALSE otherwise.
BOOL | m_bPrintSortTriangle
TRUE to show the sort triangle in printout.
BOOL | m_bRevertAlignment
TRUE to revert column alignments.
BOOL | m_bUseEditTextAlignment
TRUE to automatically apply edit alignment using column alignment.
BOOL | m_bShowLockIcon
TRUE to show the lock icon, FALSE to hide.
BOOL | m_bUseShellIcon
TRUE to use the shell icon, FALSE otherwise.
int | m_iRecOrRowStart
Start position in numbering (0 or 1 or something user want).
BOOL | m_bRecOrRowNum
TRUE to display record number if support mode is used, FALSE to display row number.
BOOL | m_bMakeUpper
TRUE to display column header and group row text in all caps.
XTPGridTreeStructureStyle | m_treeStructureStyle
Tree structure style.
CRect | m_rcPreviewIndent
Preview indentation.
int | m_nFixedColumnsIndent
Fixed Column total width.
BOOL | m_bMoveScrollbarOnFixedColumnsIndent
Move Scrollbar right follow FixedColumnsIndent.
BOOL | m_bThemedInplaceButtons
Draw in-place buttons using current theme settings.
BOOL | m_bBaseTreeIndent
TRUE to add Extra Tree indentation to cover initial TreeColumn.
CUIntArray | m_arStartCol
Start column in each virtual page.
int | m_PrintPageWidth
Width of print page (run-time)
BOOL | m_bPrintVirtualPageNumber
TRUE to print horizontal page number.
BOOL | m_bPrintPageRectangle
TRUE to draw rectangle around page.
int | m_RecordNumberWidth
Column width for row/record numbers.
BOOL | m_bForceDynamicMarkupForCell
TRUE if use Markup for Grid Record Item.
BOOL | m_bForceShowDropMarker
TRUE if Force Show Drop Marker.
BOOL | m_bShowNonActiveInPlaceButton
TRUE if use Show Non-Active In-Place Button (Combo, Expand, Spin).
BOOL | m_bPrintWatermark
TRUE to print watermark.
BOOL | m_bUseGroupRowSelectionState
TRUE if use GroupSelectionState Glyph.
BOOL | m_bForceShowTooltip
TRUE if use show tooltip for any cell width case.
BOOL | m_bCleanTooltip
TRUE if use show tooltip without markup.
BOOL | m_bGrayIfDisable
TRUE is disable draw in gray (standard behavior).
int | m_nRowHeightDefault
The default row height.
BOOL | m_bCompactText
TRUE to ignore Icon for Narrow column to show more text.
BOOL | m_bUseDropMarker
FALSE to not draw drop marked when dragging/dropping, TRUE by default.
BOOL | m_bSortTriangleOffsetFromRight
Offset of sort triangle.
int | m_nTreeColumnLineLength
This is the extra line length to apply to tree column lines if there is no expand button.
int | m_nBaseParentRecordIndent
This is initial number of pixels a parent node will be indented when in a group.
- Protected Member Functions inherited from CXTPTrackPaintManager
- Protected Member Functions inherited from CXTPGridPaintManager
virtual void | DrawTextLine (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nFlag, int &nCharCounter, int &nHyperlinkCounter)
Draws a line of text with respect to the drawing rectangle.
virtual int | DrawString (int *pnCurrDrawPos, CDC *pDC, const CString &strDraw, CRect rcDraw, UINT nFormat)
Draw a simple string into rectangle.
virtual void | DrawGridPattern (CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush)
Generates a custom grid pattern if necessary.
virtual void | DrawGridPattern (CDC *pDC, CXTPBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush)
Generates a custom grid pattern if necessary.
virtual void | DrawGridPattern (CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr)
Generates a custom grid pattern.
virtual void | DrawInplaceButtonFrame (CDC *pDC, CXTPGridInplaceButton *pButton)
Draws the in-place button frame.
virtual BOOL | DrawInplaceButtonIcon (CDC *pDC, CXTPGridInplaceButton *pButton)
Draws the in-place button icon.
virtual int | CalcColumnHeight (CDC *pDC, CXTPGridColumn *pColumn, int nTotalWidth=0)
Calculates the optimal height for a specified column.
virtual void | DrawMultiLineText (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, BOOL bWordBreak=TRUE)
Draws multi-line text.
virtual void | DrawSingleLineText (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nStartPos, int nEndPos, int nActualWidth)
Draws single-line text.
virtual int | DrawLink (int *pnCurrDrawPos, XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CXTPGridHyperlink *pHyperlink, CString strText, CRect rcLink, int nFlag, BOOL bTrim=FALSE)
Draws a hyperlink string using hyperlink text settings (i.e.
- Protected Attributes inherited from CXTPGridPaintManager
int | m_nRowHeight
Grid row default height.
int | m_nHeaderHeight
Column header height.
int | m_nFooterHeight
Column footer height.
int | m_nGroupGridLineHeight
The height of the group grid line.
CXTPImageManager * | m_pGlyphs
An additional image list for the Grid control.
BOOL | m_bIsPreviewMode
TRUE to show the item preview, FALSE to hide.
int | m_nResizingWidth
The width of the column resizing marker area.
int | m_nMaxPreviewLines
Restrict maximum lines for preview text.
CSize | m_szGlyph
Glyph size.
CXTPBrush | m_xtpBrushTreeStructure
Brush to draw tree nodes.
CXTPBrush | m_xtpBrushGroupGridLineStyle
Brush to draw group row grid lines.
int | m_nFreezeColsDividerStyle
A set of flags from XTPGridFreezeColsDividerStyle.
BOOL | m_bFixedRowHeight
TRUE if fixed rows used.
BOOL | m_bColumnWidthWYSIWYG
TRUE if columns width WYSIWYG mode used.
BOOL | m_bShowWYSIWYGMarkers
TRUE if in non-print mode header show red page-end markers.
BOOL | m_bLastColumnWidthWYSIWYG
TRUE if last column width WYSIWYG mode used.
BOOL | m_bDrawGridForEmptySpace
TRUE if grid fills the empty space (if any) after the body rows.
BOOL | m_bPrintGroupRowIcon
TRUE if printout draw collapse-expand icon for group row.
BOOL | m_bColumnPlusMinusSign
TRUE if expand/collapse icons are used, FALSE if directional arrows are used.
BOOL | m_bFixedInplaceButtonHeight
TRUE if fixed in-place button height is used.
XTPGridGridStyle | m_nGroupGridLineStyle
Current style for group row grid lines.
XTPGridColumnStyle | m_columnStyle
Column drawing style.
CXTPWinThemeWrapper * | m_themeHeader
Header theme wrapper.
CXTPWinThemeWrapper * | m_themeButton
In-place button theme wrapper.
CXTPWinThemeWrapper * | m_themeCombo
Combo box in-place button theme wrapper.
CXTPWinThemeWrapper * | m_themeSpin
Spin in-place button theme wrapper.
CXTPGridControl * | m_pControl
Pointer to the Grid control object.
CXTPMarkupUIElement * | m_pMarkupUIElement_NoGroupBy
The no group by markup UI element.
CString | m_strMarkupUIElement_NoGroupBy
The no group by markup UI element string.
CXTPBrush | m_xtpBrushVeriticalGrid
Brush to draw vertical grid lines.
CXTPBrush | m_xtpBrushHorizontalGrid
Brush to draw horizontal grid lines.
XTPGridGridStyle m_nGridLineStylePreviousV
Previous style for vertical grid lines.
XTPGridGridStyle m_nGridLineStylePreviousH
Previous style for horizontal grid lines.

Detailed Description

CXTPTrackThemeVisualStudio2012Light is a CXTPTrackThemeOffice2013 derived class that represents a Visual Studio 2012 Light style theme.

The documentation for this class was generated from the following file:
  • XTPTrackThemeVisualStudio2012.h


Toolkit Pro: CXTPTrackThemeVisualStudio2015 Class Reference

Public Member Functions | List of all members
CXTPTrackThemeVisualStudio2015 Class Reference

CXTPTrackThemeVisualStudio2015 is a CXTPTrackThemeOffice2013 derived class that represents a Visual Studio 2015 style theme. More...

Inheritance diagram for CXTPTrackThemeVisualStudio2015:
[legend]

Public Member Functions

CXTPTrackThemeVisualStudio2015 ()
Default paint manager constructor, handles properties initialization.
virtual void | RefreshMetrics ()
This method is called to refresh the visual metrics of the track control.
- Public Member Functions inherited from CXTPTrackThemeOffice2013
CXTPTrackThemeOffice2013 ()
Default paint manager constructor, handles properties initialization.
virtual void | LoadGlyphs ()
Loads the default images used by the track control.
virtual void | DrawColumnText (CDC *pDC, CRect rcText, CString strCaption, int nHeaderAlignment, BOOL bIsHeader, BOOL bColumnPressed)
Draws text for the column header.
virtual void | DrawColumnBackground (CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, BOOL &bColumnPressed, BOOL &bDraggingFromHeader, CXTPGridHeader *pHeader=NULL)
This method is called to draw the background of a column using the current column style.
virtual void | DrawTriangle (CDC *pDC, CRect rcTriangle, BOOL bToDown, BOOL bDraggingFromHeader, int nShadowWidth, BOOL bColumnPressed)
Draws a triangle that shows the sort order of the column.
virtual void | FillGroupRowMetrics (CXTPGridGroupRow *pRow, XTP_GRIDRECORDITEM_METRICS *pMetrics, BOOL bPrinting)
Fills the font and color members of the metrics structure for a specified group row.
virtual void | DrawGroupRow (CDC *pDC, CXTPGridGroupRow *pRow, CRect rcRow, XTP_GRIDRECORDITEM_METRICS *pMetrics)
Draws a group row.
virtual void | DrawFocusedRow (CDC *pDC, CRect rcRow)
Draws focused rows.
virtual int | GetRowHeight (CDC *pDC, CXTPGridRow *pRow)
Retrieves the default row height for print mode (i.e.
- Public Member Functions inherited from CXTPTrackPaintManager
CXTPTrackPaintManager ()
Creates a CXTPTrackPaintManager object.
~CXTPTrackPaintManager ()
CXTPTrackPaintManager destructor, handles cleanup and deallocation.
virtual void | DrawTrackHeader (CDC *pDC)
Call this function to draw the track header.
virtual void | DrawMarkers (CDC *pDC)
Call this function to draw the markers.
virtual void | DrawTimeLine (CDC *pDC)
Call this function to draw the time line.
virtual CString | FormatTimeLineTick (int nPosition, COLORREF &clrTick, int &nTickLength)
Call this function to format the time and tick marker relative to a time line position.
virtual CString | FormatTime (int nPosition)
Call this function to format the time and tick marker relative to a time line position.
- Public Member Functions inherited from CXTPGridPaintManager
CXTPGridPaintManager ()
Default CXTPGridPaintManager constructor, handles properties initialization.
virtual | ~CXTPGridPaintManager ()
Default CXTPGridPaintManager destructor, handles member items deallocation.
virtual void | SetGridControl (CXTPGridControl *pControl)
Sets the associated Grid control for the paint manager.
virtual int | GetRowHeight (CDC *pDC, CXTPGridRow *pRow, int nTotalWidth)
Retrieves the default row height for print mode (i.e.
int | GetRowHeightEx (CDC *pDC, CXTPGridRow *pRow, int nTotalWidth, const BOOL firstLevel=TRUE)
Retrieves the default row height for print mode (i.e.
int | GetItemHeight (XTP_GRIDRECORDITEM_DRAWARGS &drawArgs, int nWidth)
Retrieves the height of a record item for a given width.
BOOL | FindRowAdjacentToMergedEx (const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, int &nAdjRowIndex, BOOL bUpward)
Searches the topmost or bottommost row depending on the height of the current row.
int | FindRowAdjacentToMerged (const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, BOOL bUpward)
Wrapper for the FindRowAdjacentToMergedEx method.
int | RecalcTotalHightOfMergedRows (CXTPGridColumns *pColumns, CDC *pDC, CXTPGridRow *pRow, int nRowHeight, int nTotalWidth)
Recalculates row height according to the height of merged items.
virtual int | GetPreviewItemHeight (CDC *pDC, CXTPGridRow *pRow, int nWidth, int nHeight)
Retrieves the height of a preview item for print mode.
virtual int | GetHeaderHeight ()
Gets the column header height.
virtual int | GetHeaderHeight (CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0)
Calculates the optimal header height.
virtual void | SetHeaderHeight (int nHeight)
Sets the column header height.
virtual int | GetFooterHeight (CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0)
Calculates the optimal footer height.
virtual COLORREF | GetControlBackColor (CXTPGridControl *pControl)
Retrieves the parent Grid control's background color.
virtual void | FillRow (CDC *pDC, CXTPGridRow *pRow, CRect rcRow)
Fills a specified row with its background color.
virtual void | DrawGrid (CDC *pDC, XTPGridOrientation orientation, CRect rcGrid)
Draws a grid for the control.
virtual void | DrawFreezeColsDivider (CDC *pDC, const CRect &rc, CXTPGridControl *pControl, CXTPGridRow *pRow=NULL)
Draws a freeze column divider.
virtual void | DrawVerticalTimeLineMarker (CDC *pDC, int xPos, CXTPGridControl *pControl, COLORREF color=RGB(0, 255, 0))
Draws a vertical timeline marker.
virtual void | FillIndent (CDC *pDC, CRect rcRow)
Fills an indent area by its background.
virtual void | FillItemShade (CDC *pDC, CRect rcItem)
Fills an item shade by its background if necessary.
virtual void | FillHeaderControl (CDC *pDC, CRect rcHeader)
Fills a column header control area by its background.
virtual void | FillFooter (CDC *pDC, CRect rcFooter)
Fills a column footer control area by its background.
virtual void | DrawColumn (CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn, BOOL bDrawExternal=FALSE, int nShadowWidth=0)
Draws a column header with all related attributes (sort order, icon, etc.).
virtual void | DrawColumnFooterDivider (CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn)
Draws the column footer divider.
virtual void | DrawColumnFooter (CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn)
Draws the column footer with all related attributes (e.g.
virtual BOOL | IsColumHotTrackingEnabled () const
Determines if hot tracking is enabled for the current column style.
virtual void | FillGroupByControl (CDC *pDC, CRect &rcGroupBy)
Draws the Group By box.
CXTPImageManager * | GetGlyphs () const
Gets a pointer to the additional image list with glyphs.
void | DrawHorizontalLine (CDC *pDC, int xPos, int yPos, int cx, COLORREF clr)
Draws a horizontal line.
void | DrawVerticalLine (CDC *pDC, int xPos, int yPos, int cy, COLORREF clr)
Draws a vertical line.
void | DrawConnector (CDC *pDC, CPoint ptFrom, CPoint ptTo)
Draws a column connector for the Group By box.
virtual CSize | DrawCollapsedBitmap (CDC *pDC, const CXTPGridRow *pRow, CRect &rcBitmap)
Draws a collapsed bitmap.
virtual int | DrawBitmap (CDC *pDC, CXTPGridControl *pControl, CRect rcColumn, int iImage)
Draws a bitmap.
virtual int | DrawColumnIcon (CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, CRect rcIcon, int iIcon)
Draws an icon for a column.
virtual CSize | DrawGlyph (CDC *pDC, CRect rcColumn, int iImage)
Draws the standard glyphs of the Grid control.
virtual CSize | DrawShellIcon (CDC *pDC, CRect rcColumn, int iImage)
Draws the shell icon.
void | EnablePreviewMode (BOOL bIsPreviewMode)
Enables/disables preview mode for the control.
BOOL | IsPreviewMode () const
Determines if preview mode is enabled/disabled for the control.
CFont * | GetTextFont ()
Gets the default text font used for control items.
int | SetMaxPreviewLines (int nMaxLines)
Sets the maximum number of lines of text for a preview item.
int | GetMaxPreviewLines ()
Gets the maximum number of lines of text for a preview item.
int | GetPreviewLinesCount (CDC *pDC, CRect &rcText, const CString &strText)
Calculates the number of lines required to draw a specified preview text string, taking into account the maximum number of lines of text for a preview item.
BOOL | IsGridVisible (BOOL bVertical) const
Determines the visibility of specified grid lines.
BOOL | IsGridVisible (XTPGridOrientation orientation) const
Determines the visibility of specified grid lines.
void | SetColumnStyle (XTPGridColumnStyle columnStyle)
Sets the header style.
XTPGridColumnStyle | GetColumnStyle () const
Gets the header style.
void | SetColumnOffice2007CustomThemeBaseColor (COLORREF clrBaseColor)
Sets the header's custom theme base color for Office2007 column style.
COLORREF | GetColumnOffice2007CustomThemeBaseColor () const
Gets the header's custom theme base color for Office2007 column style.
void | SetTextFont (LOGFONT &lf)
Creates and sets the default text font.
void | SetCaptionFont (LOGFONT &lf)
Creates and sets the default caption font.
void | SetPreviewIndent (int nLeft, int nTop, int nRight, int nBottom)
Sets the preview item indent.
virtual void | DrawInplaceButton (CDC *pDC, CXTPGridInplaceButton *pButton)
Draws the in-place button of the Grid control.
virtual BOOL | DrawInplaceComboButton (CDC *pDC, CRect *pRc)
Draws the combo button of the Grid control.
virtual BOOL | DrawInplaceExpandButton (CDC *pDC, CRect *pRc)
Draws the expand button of the Grid control.
virtual BOOL | DrawInplaceSpinButton (CDC *pDC, CRect *pRc)
Draws the spin button of the Grid control.
virtual void | DrawTreeStructure (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CRect rcItem, CSize sizeGlyph)
Draws tree elements of the Grid control.
virtual void | DrawItemBitmap (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CRect &rcItem, int nImage)
Draws an item bitmap.
virtual void | DrawItemCaption (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics)
Draws an item caption.
virtual void | DrawRowNumber (CDC *pDC, CRect rcNumber, CXTPGridRow *pRow)
Draws a row number.
virtual void | DrawItemControl (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CXTPGridRecordItemControl *pControl, CRect &rcItem)
Draws an item control.
BOOL | IsFixedRowHeight () const
Determines if the paint manager supports fixed or variable row height.
void | SetFixedRowHeight (BOOL bFixedRowHeight)
Sets if the paint manager supports fixed or variable row height.
BOOL | IsColumnWidthWYSIWYG () const
Determines if the paint manager supports column width WYSIWYG mode.
BOOL | IsLastColumnWidthWYSIWYG () const
Determines if the paint manager supports last column width WYSIWYG mode.
BOOL | IsShowWYSIWYGMarkers () const
Determines if the paint manager shows WYSIWYG page-end markers.
void | ShowWYSIWYGMarkers (BOOL bSet)
Sets if the paint manager shows WYSIWYG page-end markers.
void | SetColumnWidthWYSIWYG (BOOL bColumnWidthWYSIWYG)
Sets if the paint manager supports column width WYSIWYG mode.
void | SetLastColumnWidthWYSIWYG (BOOL bColumnWidthWYSIWYG)
Sets if the paint manager supports last column width WYSIWYG mode.
BOOL | IsFixedInplaceButtonHeight () const
Determines if the paint manager supports fixed or variable in-place button height.
void | SetInplaceButtonHeight (BOOL bFixedInplaceButtonHeight)
Sets if the paint manager supports fixed or variable in-place button height.
int | GetFreezeColsDividerStyle () const
Gets the style of the freeze columns divider line.
void | SetFreezeColsDividerStyle (int nStyle)
Sets the style for the freeze columns divider line.
virtual BOOL | OnDrawAction (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs)
Override this method to perform custom activities for the item before processing it.
virtual void | DrawNoGroupByText (CDC *pDC, CRect rcItem)
Draws the "No items" text message in the Group By area when there are no items inside it.
BOOL | IsDrawGridForEmptySpace () const
Determines if the grid fills empty space after body rows.
void | SetDrawGridForEmptySpace (BOOL bDrawGrid)
Sets if the grid fills empty space after body rows.
BOOL | IsPrintGroupRowIcon () const
Determines if the group row collapse-expand icon is drawn in print mode.
void | SetPrintGroupRowIcon (BOOL bDraw)
Sets if the group row collapse-expand icon is drawn in print mode.
BOOL | IsColumnPlusMinusSign () const
Determines if columns use expand/collapse icons (+/-) or directional arrows.
void | SetColumnPlusMinusSign (BOOL bDraw)
Specifies if columns use expand/collapse icons (+/-) or directional arrows.
virtual int | CalculateRowHeight (CDC *pDC, const CString &strText, int nMaxWidth, BOOL bWordBreak=TRUE)
Calculates the height required for a rectangle bounding multi-line text to draw the multi-line text when the width of the rectangle is fixed.
void | DrawSectionDivider (CDC *pDC, const CRect &rc, XTPGridSectionDividerPosition dividerPosition, XTPGridSectionDividerStyle dividerStyle, CXTPPaintManagerColor dividerColor)
Draws the divider between grid sections (e.g.
int | GetSectionDividerHeight (XTPGridFixedRowsDividerStyle dividerStyle)
Gets the height of the section divider.
BOOL | IsUseDropMarker () const
Determines if a drop marker will be used when dragging and dropping.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPTrackThemeOffice2013
CXTPPaintManagerColor | m_clrGlyph
Header glyph color.
CXTPPaintManagerColor | m_clrGlyphHighlight
Header highlighted glyph color.
CXTPPaintManagerColor | m_clrSelectedBorder
Selected block border.
- Public Attributes inherited from CXTPTrackPaintManager
COLORREF | m_clrWorkArea
The color of the work area.
COLORREF | m_clrTrackHeader
The track header color.
COLORREF | m_clrTrackTimeArea
The track time area color.
COLORREF | m_clrTimeHeaderDarkDark
The header deep dark color.
COLORREF | m_clrTimeHeaderDark
The header dark color.
COLORREF | m_clrTimeSliderBackground
The slider background color.
COLORREF | m_clrTimeHeaderDivider
The header divider color.
COLORREF | m_clrScrollBarLight
The scrollbar light color.
COLORREF | m_clrScrollBarDark
The scrollbar dark color.
COLORREF | m_clrSelectedArea
The color of the selected area.
COLORREF | m_clrMarker
The color of the marker.
COLORREF | m_clrTimeLineTick
The color of a time line tick.
COLORREF | m_clrMarkerBorder
The color of a time line marker's border.
COLORREF | m_clrMarkerBack
The color of a time line marker's back.
COLORREF | m_clrTrackMarkerBorder
The color of a track marker's border.
COLORREF | m_clrTrackMarkerText
The color of a track marker's text.
COLORREF | m_clrTrackMarkerTextBack
The color of a track marker's text back.
COLORREF | m_clrTrackMarkerTextBorder
The color of a track marker's text border.
COLORREF | m_clrTimeLinePosition
The color of a marked position on a time line.
COLORREF | m_clrTimeHeaderBorder
The color of a time line header's border.
COLORREF | m_clrScrollBarBorderDark
The scrollbar border dark color.
COLORREF | m_clrScrollBarBorderLight
The scrollbar border light color.
COLORREF | m_clrWorkAreaScrollBarLight
The workarea scrollbar light color.
COLORREF | m_clrWorkAreaScrollBarDark
The workarea scrollbar dark color.
COLORREF | m_clrWorkAreaScrollBarBorder
The workarea scrollbar border color.
- Public Attributes inherited from CXTPGridPaintManager
CXTPFont | m_xtpFontText
Grid items default text.
CXTPFont | m_xtpFontBoldText
Grid items default bold text.
CXTPFont | m_xtpFontCaption
Column header caption font.
CXTPFont | m_xtpFontPreview
Column header caption font.
CXTPGridHyperlinkStyle * | m_pHyperlinkStyle
Style for links.
CXTPGridHyperlinkStyle * | m_pHyperlinkHoverStyle
Style for hovered links.
CXTPPaintManagerColor | m_clrHighlight
Background color of the highlighted row.
CXTPPaintManagerColor | m_clrBoldText
Grid items bold text color.
CXTPPaintManagerColor | m_clrBoldTextHighlight
Grid items bold text highlight color.
CXTPPaintManagerColor | m_clrWindowText
Grid items default text color.
CXTPPaintManagerColor | m_clrHighlightText
Text color of the highlighted text.
CXTPPaintManagerColor | m_clrHeaderControl
Background color of the grid header.
CXTPPaintManagerColor | m_clrCaptionText
Column header text color.
CXTPPaintManagerColor | m_clrCaptionTextPressed
Column header text color when pressed.
CXTPPaintManagerColor | m_clrControlBack
Background color of the control grid area.
CXTPPaintManagerColor | m_clrGroupRowText
Row text color.
CXTPPaintManagerColor | m_clrGroupShadeBack
Group row background color when indentation shade is enabled.
CXTPPaintManagerColor | m_clrGroupShadeText
Group row foreground color when indentation shade is enabled.
CXTPPaintManagerColor | m_clrGroupShadeBorder
Color for group border's shade.
CXTPPaintManagerColor | m_clrGroupBoxBack
Color of group box.
CXTPPaintManagerColor | m_clrControlDark
Dark background color of the Grid control (used on Group By area).
CXTPPaintManagerColor | m_clrControlLightLight
Light background color used for drawing shades (used on column header area).
CXTPPaintManagerColor | m_clrHotDivider
Color of the column hot divider window (two arrows).
CXTPPaintManagerColor | m_clrIndentControl
Color of the tree indentation area.
CXTPPaintManagerColor | m_clrItemShade
Color of the shade on sorted by column items.
CXTPPaintManagerColor | m_clrBtnFace
Standard button face color.
CXTPPaintManagerColor | m_clrBtnText
Standard button text color.
CXTPPaintManagerColor | m_clrPreviewText
Preview text color.
CXTPPaintManagerColor | m_clrSelectedRow
Selected row background color.
CXTPPaintManagerColor | m_clrSelectedRowText
Selected row text color.
CXTPPaintManagerColor | m_clrBtnFacePressed
Standard button face color when pressed.
CXTPPaintManagerColor | m_clrConnector
Header column connector line color.
CXTPPaintManagerColor | m_clrDisableBitmapLightest
The lightest color of bitmap which covers disabled grid.
CXTPPaintManagerColor | m_clrDisableBitmapDarkest
The darkest color of bitmap which covers disabled grid.
CXTPPaintManagerColorGradient | m_grcGradientColumn
Color of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColorGradient | m_grcGradientColumnHot
HotTracking Color of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColorGradient | m_grcGradientColumnPushed
Pushed Color of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColor | m_clrGradientColumnShadow
Bottom shadow of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColor | m_clrGradientColumnSeparator
Separator of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColor | m_crlNoGroupByText
A color for "No items" text in GroupBy area (see m_strNoGroupBy member).
CXTPPaintManagerColor | m_clrFreezeColsDivider
Freeze Columns Divider color.
COLORREF | m_clrColumnOffice2007CustomTheme
Base color for Office2007 custom theme.
COLORREF | m_clrFormulaSum
Color for Formula Sum fields.
COLORREF | m_clrFormulaSubSum
Color for Formula SubSum fields.
COLORREF | m_clrAlternativeBackground
Color for Alternative Row Background.
BOOL | m_bUseAlternativeBackground
TRUE to use Alternative Row Background, FALSE otherwise.
BOOL | m_bAllowMergeCells
TRUE to Allow Merge Cells, FALSE otherwise.
int | m_nTextIndentForGroupRowsWithNoIcon
Specifies Text indent if a group row icon is not used.
int | m_nTreeIndent
Tree indentation.
int | m_nTreeStructureStyle
Tree structure style.
int | m_nTreeTextIndentRowParent
Text indent, in pixels, for rows with children.
int | m_nTreeTextIndentRowChildren
Text indent, in pixels, for rows without children.
int | m_nTreeTextIndent
Text indent, in pixels, for rows that are neither parent nor children.
int | m_nTreeTextIndentGroupRow
Text indent, in pixels, for group rows.
BOOL | m_bGroupRowTextBold
TRUE to draw group rows with bold text.
BOOL | m_bShadeGroupHeadings
TRUE to show the indentation shade, FALSE otherwise.
BOOL | m_bShadeSortColumn
TRUE to show the items shade in the sorted by column, FALSE otherwise.
BOOL | m_bHotTracking
TRUE to allow column hot tracking.
BOOL | m_bInvertColumnOnClick
TRUE to invert column on click.
CString | m_strNoItems
A string which contains customized "No Items" text for displaying in view when there are no visible rows.
CString | m_strSortBy
A string which contains customized "Sort By" text for displaying in tooltip.
CString | m_strIncreasing
A string which contains customized "Increasing" text for displaying in tooltip.
CString | m_strDecreasing
A string which contains customized "Decreasing" text for displaying in tooltip.
CString | m_strNoGroupBy
A string which contains customized "No items" text message for displaying in Group By area when there are no items inside it.
CString | m_strNoFieldsAvailable
A string which contains customized "No Fields Available" text message for displaying in Field Chooser.
CString | m_strExpand
A string which contains customized "Expand" text for displaying in tooltip.
CString | m_strCollapse
A string which contains customized "Collapse" text for displaying in tooltip.
BOOL | m_bHideSelection
TRUE when hiding Grid control's selection by drawing selected items as others, FALSE otherwise.
BOOL | m_bPrintSortTriangle
TRUE to show the sort triangle in printout.
BOOL | m_bRevertAlignment
TRUE to revert column alignments.
BOOL | m_bUseEditTextAlignment
TRUE to automatically apply edit alignment using column alignment.
BOOL | m_bShowLockIcon
TRUE to show the lock icon, FALSE to hide.
BOOL | m_bUseShellIcon
TRUE to use the shell icon, FALSE otherwise.
int | m_iRecOrRowStart
Start position in numbering (0 or 1 or something user want).
BOOL | m_bRecOrRowNum
TRUE to display record number if support mode is used, FALSE to display row number.
BOOL | m_bMakeUpper
TRUE to display column header and group row text in all caps.
XTPGridTreeStructureStyle | m_treeStructureStyle
Tree structure style.
CRect | m_rcPreviewIndent
Preview indentation.
int | m_nFixedColumnsIndent
Fixed Column total width.
BOOL | m_bMoveScrollbarOnFixedColumnsIndent
Move Scrollbar right follow FixedColumnsIndent.
BOOL | m_bThemedInplaceButtons
Draw in-place buttons using current theme settings.
BOOL | m_bBaseTreeIndent
TRUE to add Extra Tree indentation to cover initial TreeColumn.
CUIntArray | m_arStartCol
Start column in each virtual page.
int | m_PrintPageWidth
Width of print page (run-time)
BOOL | m_bPrintVirtualPageNumber
TRUE to print horizontal page number.
BOOL | m_bPrintPageRectangle
TRUE to draw rectangle around page.
int | m_RecordNumberWidth
Column width for row/record numbers.
BOOL | m_bForceDynamicMarkupForCell
TRUE if use Markup for Grid Record Item.
BOOL | m_bForceShowDropMarker
TRUE if Force Show Drop Marker.
BOOL | m_bShowNonActiveInPlaceButton
TRUE if use Show Non-Active In-Place Button (Combo, Expand, Spin).
BOOL | m_bPrintWatermark
TRUE to print watermark.
BOOL | m_bUseGroupRowSelectionState
TRUE if use GroupSelectionState Glyph.
BOOL | m_bForceShowTooltip
TRUE if use show tooltip for any cell width case.
BOOL | m_bCleanTooltip
TRUE if use show tooltip without markup.
BOOL | m_bGrayIfDisable
TRUE is disable draw in gray (standard behavior).
int | m_nRowHeightDefault
The default row height.
BOOL | m_bCompactText
TRUE to ignore Icon for Narrow column to show more text.
BOOL | m_bUseDropMarker
FALSE to not draw drop marked when dragging/dropping, TRUE by default.
BOOL | m_bSortTriangleOffsetFromRight
Offset of sort triangle.
int | m_nTreeColumnLineLength
This is the extra line length to apply to tree column lines if there is no expand button.
int | m_nBaseParentRecordIndent
This is initial number of pixels a parent node will be indented when in a group.
- Protected Member Functions inherited from CXTPTrackPaintManager
- Protected Member Functions inherited from CXTPGridPaintManager
virtual void | DrawTextLine (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nFlag, int &nCharCounter, int &nHyperlinkCounter)
Draws a line of text with respect to the drawing rectangle.
virtual int | DrawString (int *pnCurrDrawPos, CDC *pDC, const CString &strDraw, CRect rcDraw, UINT nFormat)
Draw a simple string into rectangle.
virtual void | DrawGridPattern (CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush)
Generates a custom grid pattern if necessary.
virtual void | DrawGridPattern (CDC *pDC, CXTPBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush)
Generates a custom grid pattern if necessary.
virtual void | DrawGridPattern (CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr)
Generates a custom grid pattern.
virtual void | DrawInplaceButtonFrame (CDC *pDC, CXTPGridInplaceButton *pButton)
Draws the in-place button frame.
virtual BOOL | DrawInplaceButtonIcon (CDC *pDC, CXTPGridInplaceButton *pButton)
Draws the in-place button icon.
virtual int | CalcColumnHeight (CDC *pDC, CXTPGridColumn *pColumn, int nTotalWidth=0)
Calculates the optimal height for a specified column.
virtual void | DrawMultiLineText (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, BOOL bWordBreak=TRUE)
Draws multi-line text.
virtual void | DrawSingleLineText (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nStartPos, int nEndPos, int nActualWidth)
Draws single-line text.
virtual int | DrawLink (int *pnCurrDrawPos, XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CXTPGridHyperlink *pHyperlink, CString strText, CRect rcLink, int nFlag, BOOL bTrim=FALSE)
Draws a hyperlink string using hyperlink text settings (i.e.
- Protected Attributes inherited from CXTPGridPaintManager
int | m_nRowHeight
Grid row default height.
int | m_nHeaderHeight
Column header height.
int | m_nFooterHeight
Column footer height.
int | m_nGroupGridLineHeight
The height of the group grid line.
CXTPImageManager * | m_pGlyphs
An additional image list for the Grid control.
BOOL | m_bIsPreviewMode
TRUE to show the item preview, FALSE to hide.
int | m_nResizingWidth
The width of the column resizing marker area.
int | m_nMaxPreviewLines
Restrict maximum lines for preview text.
CSize | m_szGlyph
Glyph size.
CXTPBrush | m_xtpBrushTreeStructure
Brush to draw tree nodes.
CXTPBrush | m_xtpBrushGroupGridLineStyle
Brush to draw group row grid lines.
int | m_nFreezeColsDividerStyle
A set of flags from XTPGridFreezeColsDividerStyle.
BOOL | m_bFixedRowHeight
TRUE if fixed rows used.
BOOL | m_bColumnWidthWYSIWYG
TRUE if columns width WYSIWYG mode used.
BOOL | m_bShowWYSIWYGMarkers
TRUE if in non-print mode header show red page-end markers.
BOOL | m_bLastColumnWidthWYSIWYG
TRUE if last column width WYSIWYG mode used.
BOOL | m_bDrawGridForEmptySpace
TRUE if grid fills the empty space (if any) after the body rows.
BOOL | m_bPrintGroupRowIcon
TRUE if printout draw collapse-expand icon for group row.
BOOL | m_bColumnPlusMinusSign
TRUE if expand/collapse icons are used, FALSE if directional arrows are used.
BOOL | m_bFixedInplaceButtonHeight
TRUE if fixed in-place button height is used.
XTPGridGridStyle | m_nGroupGridLineStyle
Current style for group row grid lines.
XTPGridColumnStyle | m_columnStyle
Column drawing style.
CXTPWinThemeWrapper * | m_themeHeader
Header theme wrapper.
CXTPWinThemeWrapper * | m_themeButton
In-place button theme wrapper.
CXTPWinThemeWrapper * | m_themeCombo
Combo box in-place button theme wrapper.
CXTPWinThemeWrapper * | m_themeSpin
Spin in-place button theme wrapper.
CXTPGridControl * | m_pControl
Pointer to the Grid control object.
CXTPMarkupUIElement * | m_pMarkupUIElement_NoGroupBy
The no group by markup UI element.
CString | m_strMarkupUIElement_NoGroupBy
The no group by markup UI element string.
CXTPBrush | m_xtpBrushVeriticalGrid
Brush to draw vertical grid lines.
CXTPBrush | m_xtpBrushHorizontalGrid
Brush to draw horizontal grid lines.
XTPGridGridStyle m_nGridLineStylePreviousV
Previous style for vertical grid lines.
XTPGridGridStyle m_nGridLineStylePreviousH
Previous style for horizontal grid lines.

Detailed Description

CXTPTrackThemeVisualStudio2015 is a CXTPTrackThemeOffice2013 derived class that represents a Visual Studio 2015 style theme.

The documentation for this class was generated from the following file:
  • XTPTrackThemeVisualStudio2015.h


Toolkit Pro: CXTPTrackThemeVisualStudio2017 Class Reference

Public Member Functions | List of all members
CXTPTrackThemeVisualStudio2017 Class Reference

CXTPTrackThemeVisualStudio2017 is a CXTPTrackThemeOffice2013 derived class that represents a Visual Studio 2017 style theme. More...

Inheritance diagram for CXTPTrackThemeVisualStudio2017:
[legend]

Public Member Functions

CXTPTrackThemeVisualStudio2017 ()
Default paint manager constructor, handles properties initialization.
virtual void | RefreshMetrics ()
This method is called to refresh the visual metrics of the track control.
- Public Member Functions inherited from CXTPTrackThemeOffice2013
CXTPTrackThemeOffice2013 ()
Default paint manager constructor, handles properties initialization.
virtual void | LoadGlyphs ()
Loads the default images used by the track control.
virtual void | DrawColumnText (CDC *pDC, CRect rcText, CString strCaption, int nHeaderAlignment, BOOL bIsHeader, BOOL bColumnPressed)
Draws text for the column header.
virtual void | DrawColumnBackground (CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, BOOL &bColumnPressed, BOOL &bDraggingFromHeader, CXTPGridHeader *pHeader=NULL)
This method is called to draw the background of a column using the current column style.
virtual void | DrawTriangle (CDC *pDC, CRect rcTriangle, BOOL bToDown, BOOL bDraggingFromHeader, int nShadowWidth, BOOL bColumnPressed)
Draws a triangle that shows the sort order of the column.
virtual void | FillGroupRowMetrics (CXTPGridGroupRow *pRow, XTP_GRIDRECORDITEM_METRICS *pMetrics, BOOL bPrinting)
Fills the font and color members of the metrics structure for a specified group row.
virtual void | DrawGroupRow (CDC *pDC, CXTPGridGroupRow *pRow, CRect rcRow, XTP_GRIDRECORDITEM_METRICS *pMetrics)
Draws a group row.
virtual void | DrawFocusedRow (CDC *pDC, CRect rcRow)
Draws focused rows.
virtual int | GetRowHeight (CDC *pDC, CXTPGridRow *pRow)
Retrieves the default row height for print mode (i.e.
- Public Member Functions inherited from CXTPTrackPaintManager
CXTPTrackPaintManager ()
Creates a CXTPTrackPaintManager object.
~CXTPTrackPaintManager ()
CXTPTrackPaintManager destructor, handles cleanup and deallocation.
virtual void | DrawTrackHeader (CDC *pDC)
Call this function to draw the track header.
virtual void | DrawMarkers (CDC *pDC)
Call this function to draw the markers.
virtual void | DrawTimeLine (CDC *pDC)
Call this function to draw the time line.
virtual CString | FormatTimeLineTick (int nPosition, COLORREF &clrTick, int &nTickLength)
Call this function to format the time and tick marker relative to a time line position.
virtual CString | FormatTime (int nPosition)
Call this function to format the time and tick marker relative to a time line position.
- Public Member Functions inherited from CXTPGridPaintManager
CXTPGridPaintManager ()
Default CXTPGridPaintManager constructor, handles properties initialization.
virtual | ~CXTPGridPaintManager ()
Default CXTPGridPaintManager destructor, handles member items deallocation.
virtual void | SetGridControl (CXTPGridControl *pControl)
Sets the associated Grid control for the paint manager.
virtual int | GetRowHeight (CDC *pDC, CXTPGridRow *pRow, int nTotalWidth)
Retrieves the default row height for print mode (i.e.
int | GetRowHeightEx (CDC *pDC, CXTPGridRow *pRow, int nTotalWidth, const BOOL firstLevel=TRUE)
Retrieves the default row height for print mode (i.e.
int | GetItemHeight (XTP_GRIDRECORDITEM_DRAWARGS &drawArgs, int nWidth)
Retrieves the height of a record item for a given width.
BOOL | FindRowAdjacentToMergedEx (const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, int &nAdjRowIndex, BOOL bUpward)
Searches the topmost or bottommost row depending on the height of the current row.
int | FindRowAdjacentToMerged (const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, BOOL bUpward)
Wrapper for the FindRowAdjacentToMergedEx method.
int | RecalcTotalHightOfMergedRows (CXTPGridColumns *pColumns, CDC *pDC, CXTPGridRow *pRow, int nRowHeight, int nTotalWidth)
Recalculates row height according to the height of merged items.
virtual int | GetPreviewItemHeight (CDC *pDC, CXTPGridRow *pRow, int nWidth, int nHeight)
Retrieves the height of a preview item for print mode.
virtual int | GetHeaderHeight ()
Gets the column header height.
virtual int | GetHeaderHeight (CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0)
Calculates the optimal header height.
virtual void | SetHeaderHeight (int nHeight)
Sets the column header height.
virtual int | GetFooterHeight (CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0)
Calculates the optimal footer height.
virtual COLORREF | GetControlBackColor (CXTPGridControl *pControl)
Retrieves the parent Grid control's background color.
virtual void | FillRow (CDC *pDC, CXTPGridRow *pRow, CRect rcRow)
Fills a specified row with its background color.
virtual void | DrawGrid (CDC *pDC, XTPGridOrientation orientation, CRect rcGrid)
Draws a grid for the control.
virtual void | DrawFreezeColsDivider (CDC *pDC, const CRect &rc, CXTPGridControl *pControl, CXTPGridRow *pRow=NULL)
Draws a freeze column divider.
virtual void | DrawVerticalTimeLineMarker (CDC *pDC, int xPos, CXTPGridControl *pControl, COLORREF color=RGB(0, 255, 0))
Draws a vertical timeline marker.
virtual void | FillIndent (CDC *pDC, CRect rcRow)
Fills an indent area by its background.
virtual void | FillItemShade (CDC *pDC, CRect rcItem)
Fills an item shade by its background if necessary.
virtual void | FillHeaderControl (CDC *pDC, CRect rcHeader)
Fills a column header control area by its background.
virtual void | FillFooter (CDC *pDC, CRect rcFooter)
Fills a column footer control area by its background.
virtual void | DrawColumn (CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn, BOOL bDrawExternal=FALSE, int nShadowWidth=0)
Draws a column header with all related attributes (sort order, icon, etc.).
virtual void | DrawColumnFooterDivider (CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn)
Draws the column footer divider.
virtual void | DrawColumnFooter (CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn)
Draws the column footer with all related attributes (e.g.
virtual BOOL | IsColumHotTrackingEnabled () const
Determines if hot tracking is enabled for the current column style.
virtual void | FillGroupByControl (CDC *pDC, CRect &rcGroupBy)
Draws the Group By box.
CXTPImageManager * | GetGlyphs () const
Gets a pointer to the additional image list with glyphs.
void | DrawHorizontalLine (CDC *pDC, int xPos, int yPos, int cx, COLORREF clr)
Draws a horizontal line.
void | DrawVerticalLine (CDC *pDC, int xPos, int yPos, int cy, COLORREF clr)
Draws a vertical line.
void | DrawConnector (CDC *pDC, CPoint ptFrom, CPoint ptTo)
Draws a column connector for the Group By box.
virtual CSize | DrawCollapsedBitmap (CDC *pDC, const CXTPGridRow *pRow, CRect &rcBitmap)
Draws a collapsed bitmap.
virtual int | DrawBitmap (CDC *pDC, CXTPGridControl *pControl, CRect rcColumn, int iImage)
Draws a bitmap.
virtual int | DrawColumnIcon (CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, CRect rcIcon, int iIcon)
Draws an icon for a column.
virtual CSize | DrawGlyph (CDC *pDC, CRect rcColumn, int iImage)
Draws the standard glyphs of the Grid control.
virtual CSize | DrawShellIcon (CDC *pDC, CRect rcColumn, int iImage)
Draws the shell icon.
void | EnablePreviewMode (BOOL bIsPreviewMode)
Enables/disables preview mode for the control.
BOOL | IsPreviewMode () const
Determines if preview mode is enabled/disabled for the control.
CFont * | GetTextFont ()
Gets the default text font used for control items.
int | SetMaxPreviewLines (int nMaxLines)
Sets the maximum number of lines of text for a preview item.
int | GetMaxPreviewLines ()
Gets the maximum number of lines of text for a preview item.
int | GetPreviewLinesCount (CDC *pDC, CRect &rcText, const CString &strText)
Calculates the number of lines required to draw a specified preview text string, taking into account the maximum number of lines of text for a preview item.
BOOL | IsGridVisible (BOOL bVertical) const
Determines the visibility of specified grid lines.
BOOL | IsGridVisible (XTPGridOrientation orientation) const
Determines the visibility of specified grid lines.
void | SetColumnStyle (XTPGridColumnStyle columnStyle)
Sets the header style.
XTPGridColumnStyle | GetColumnStyle () const
Gets the header style.
void | SetColumnOffice2007CustomThemeBaseColor (COLORREF clrBaseColor)
Sets the header's custom theme base color for Office2007 column style.
COLORREF | GetColumnOffice2007CustomThemeBaseColor () const
Gets the header's custom theme base color for Office2007 column style.
void | SetTextFont (LOGFONT &lf)
Creates and sets the default text font.
void | SetCaptionFont (LOGFONT &lf)
Creates and sets the default caption font.
void | SetPreviewIndent (int nLeft, int nTop, int nRight, int nBottom)
Sets the preview item indent.
virtual void | DrawInplaceButton (CDC *pDC, CXTPGridInplaceButton *pButton)
Draws the in-place button of the Grid control.
virtual BOOL | DrawInplaceComboButton (CDC *pDC, CRect *pRc)
Draws the combo button of the Grid control.
virtual BOOL | DrawInplaceExpandButton (CDC *pDC, CRect *pRc)
Draws the expand button of the Grid control.
virtual BOOL | DrawInplaceSpinButton (CDC *pDC, CRect *pRc)
Draws the spin button of the Grid control.
virtual void | DrawTreeStructure (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CRect rcItem, CSize sizeGlyph)
Draws tree elements of the Grid control.
virtual void | DrawItemBitmap (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CRect &rcItem, int nImage)
Draws an item bitmap.
virtual void | DrawItemCaption (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics)
Draws an item caption.
virtual void | DrawRowNumber (CDC *pDC, CRect rcNumber, CXTPGridRow *pRow)
Draws a row number.
virtual void | DrawItemControl (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CXTPGridRecordItemControl *pControl, CRect &rcItem)
Draws an item control.
BOOL | IsFixedRowHeight () const
Determines if the paint manager supports fixed or variable row height.
void | SetFixedRowHeight (BOOL bFixedRowHeight)
Sets if the paint manager supports fixed or variable row height.
BOOL | IsColumnWidthWYSIWYG () const
Determines if the paint manager supports column width WYSIWYG mode.
BOOL | IsLastColumnWidthWYSIWYG () const
Determines if the paint manager supports last column width WYSIWYG mode.
BOOL | IsShowWYSIWYGMarkers () const
Determines if the paint manager shows WYSIWYG page-end markers.
void | ShowWYSIWYGMarkers (BOOL bSet)
Sets if the paint manager shows WYSIWYG page-end markers.
void | SetColumnWidthWYSIWYG (BOOL bColumnWidthWYSIWYG)
Sets if the paint manager supports column width WYSIWYG mode.
void | SetLastColumnWidthWYSIWYG (BOOL bColumnWidthWYSIWYG)
Sets if the paint manager supports last column width WYSIWYG mode.
BOOL | IsFixedInplaceButtonHeight () const
Determines if the paint manager supports fixed or variable in-place button height.
void | SetInplaceButtonHeight (BOOL bFixedInplaceButtonHeight)
Sets if the paint manager supports fixed or variable in-place button height.
int | GetFreezeColsDividerStyle () const
Gets the style of the freeze columns divider line.
void | SetFreezeColsDividerStyle (int nStyle)
Sets the style for the freeze columns divider line.
virtual BOOL | OnDrawAction (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs)
Override this method to perform custom activities for the item before processing it.
virtual void | DrawNoGroupByText (CDC *pDC, CRect rcItem)
Draws the "No items" text message in the Group By area when there are no items inside it.
BOOL | IsDrawGridForEmptySpace () const
Determines if the grid fills empty space after body rows.
void | SetDrawGridForEmptySpace (BOOL bDrawGrid)
Sets if the grid fills empty space after body rows.
BOOL | IsPrintGroupRowIcon () const
Determines if the group row collapse-expand icon is drawn in print mode.
void | SetPrintGroupRowIcon (BOOL bDraw)
Sets if the group row collapse-expand icon is drawn in print mode.
BOOL | IsColumnPlusMinusSign () const
Determines if columns use expand/collapse icons (+/-) or directional arrows.
void | SetColumnPlusMinusSign (BOOL bDraw)
Specifies if columns use expand/collapse icons (+/-) or directional arrows.
virtual int | CalculateRowHeight (CDC *pDC, const CString &strText, int nMaxWidth, BOOL bWordBreak=TRUE)
Calculates the height required for a rectangle bounding multi-line text to draw the multi-line text when the width of the rectangle is fixed.
void | DrawSectionDivider (CDC *pDC, const CRect &rc, XTPGridSectionDividerPosition dividerPosition, XTPGridSectionDividerStyle dividerStyle, CXTPPaintManagerColor dividerColor)
Draws the divider between grid sections (e.g.
int | GetSectionDividerHeight (XTPGridFixedRowsDividerStyle dividerStyle)
Gets the height of the section divider.
BOOL | IsUseDropMarker () const
Determines if a drop marker will be used when dragging and dropping.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPTrackThemeOffice2013
CXTPPaintManagerColor | m_clrGlyph
Header glyph color.
CXTPPaintManagerColor | m_clrGlyphHighlight
Header highlighted glyph color.
CXTPPaintManagerColor | m_clrSelectedBorder
Selected block border.
- Public Attributes inherited from CXTPTrackPaintManager
COLORREF | m_clrWorkArea
The color of the work area.
COLORREF | m_clrTrackHeader
The track header color.
COLORREF | m_clrTrackTimeArea
The track time area color.
COLORREF | m_clrTimeHeaderDarkDark
The header deep dark color.
COLORREF | m_clrTimeHeaderDark
The header dark color.
COLORREF | m_clrTimeSliderBackground
The slider background color.
COLORREF | m_clrTimeHeaderDivider
The header divider color.
COLORREF | m_clrScrollBarLight
The scrollbar light color.
COLORREF | m_clrScrollBarDark
The scrollbar dark color.
COLORREF | m_clrSelectedArea
The color of the selected area.
COLORREF | m_clrMarker
The color of the marker.
COLORREF | m_clrTimeLineTick
The color of a time line tick.
COLORREF | m_clrMarkerBorder
The color of a time line marker's border.
COLORREF | m_clrMarkerBack
The color of a time line marker's back.
COLORREF | m_clrTrackMarkerBorder
The color of a track marker's border.
COLORREF | m_clrTrackMarkerText
The color of a track marker's text.
COLORREF | m_clrTrackMarkerTextBack
The color of a track marker's text back.
COLORREF | m_clrTrackMarkerTextBorder
The color of a track marker's text border.
COLORREF | m_clrTimeLinePosition
The color of a marked position on a time line.
COLORREF | m_clrTimeHeaderBorder
The color of a time line header's border.
COLORREF | m_clrScrollBarBorderDark
The scrollbar border dark color.
COLORREF | m_clrScrollBarBorderLight
The scrollbar border light color.
COLORREF | m_clrWorkAreaScrollBarLight
The workarea scrollbar light color.
COLORREF | m_clrWorkAreaScrollBarDark
The workarea scrollbar dark color.
COLORREF | m_clrWorkAreaScrollBarBorder
The workarea scrollbar border color.
- Public Attributes inherited from CXTPGridPaintManager
CXTPFont | m_xtpFontText
Grid items default text.
CXTPFont | m_xtpFontBoldText
Grid items default bold text.
CXTPFont | m_xtpFontCaption
Column header caption font.
CXTPFont | m_xtpFontPreview
Column header caption font.
CXTPGridHyperlinkStyle * | m_pHyperlinkStyle
Style for links.
CXTPGridHyperlinkStyle * | m_pHyperlinkHoverStyle
Style for hovered links.
CXTPPaintManagerColor | m_clrHighlight
Background color of the highlighted row.
CXTPPaintManagerColor | m_clrBoldText
Grid items bold text color.
CXTPPaintManagerColor | m_clrBoldTextHighlight
Grid items bold text highlight color.
CXTPPaintManagerColor | m_clrWindowText
Grid items default text color.
CXTPPaintManagerColor | m_clrHighlightText
Text color of the highlighted text.
CXTPPaintManagerColor | m_clrHeaderControl
Background color of the grid header.
CXTPPaintManagerColor | m_clrCaptionText
Column header text color.
CXTPPaintManagerColor | m_clrCaptionTextPressed
Column header text color when pressed.
CXTPPaintManagerColor | m_clrControlBack
Background color of the control grid area.
CXTPPaintManagerColor | m_clrGroupRowText
Row text color.
CXTPPaintManagerColor | m_clrGroupShadeBack
Group row background color when indentation shade is enabled.
CXTPPaintManagerColor | m_clrGroupShadeText
Group row foreground color when indentation shade is enabled.
CXTPPaintManagerColor | m_clrGroupShadeBorder
Color for group border's shade.
CXTPPaintManagerColor | m_clrGroupBoxBack
Color of group box.
CXTPPaintManagerColor | m_clrControlDark
Dark background color of the Grid control (used on Group By area).
CXTPPaintManagerColor | m_clrControlLightLight
Light background color used for drawing shades (used on column header area).
CXTPPaintManagerColor | m_clrHotDivider
Color of the column hot divider window (two arrows).
CXTPPaintManagerColor | m_clrIndentControl
Color of the tree indentation area.
CXTPPaintManagerColor | m_clrItemShade
Color of the shade on sorted by column items.
CXTPPaintManagerColor | m_clrBtnFace
Standard button face color.
CXTPPaintManagerColor | m_clrBtnText
Standard button text color.
CXTPPaintManagerColor | m_clrPreviewText
Preview text color.
CXTPPaintManagerColor | m_clrSelectedRow
Selected row background color.
CXTPPaintManagerColor | m_clrSelectedRowText
Selected row text color.
CXTPPaintManagerColor | m_clrBtnFacePressed
Standard button face color when pressed.
CXTPPaintManagerColor | m_clrConnector
Header column connector line color.
CXTPPaintManagerColor | m_clrDisableBitmapLightest
The lightest color of bitmap which covers disabled grid.
CXTPPaintManagerColor | m_clrDisableBitmapDarkest
The darkest color of bitmap which covers disabled grid.
CXTPPaintManagerColorGradient | m_grcGradientColumn
Color of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColorGradient | m_grcGradientColumnHot
HotTracking Color of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColorGradient | m_grcGradientColumnPushed
Pushed Color of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColor | m_clrGradientColumnShadow
Bottom shadow of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColor | m_clrGradientColumnSeparator
Separator of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColor | m_crlNoGroupByText
A color for "No items" text in GroupBy area (see m_strNoGroupBy member).
CXTPPaintManagerColor | m_clrFreezeColsDivider
Freeze Columns Divider color.
COLORREF | m_clrColumnOffice2007CustomTheme
Base color for Office2007 custom theme.
COLORREF | m_clrFormulaSum
Color for Formula Sum fields.
COLORREF | m_clrFormulaSubSum
Color for Formula SubSum fields.
COLORREF | m_clrAlternativeBackground
Color for Alternative Row Background.
BOOL | m_bUseAlternativeBackground
TRUE to use Alternative Row Background, FALSE otherwise.
BOOL | m_bAllowMergeCells
TRUE to Allow Merge Cells, FALSE otherwise.
int | m_nTextIndentForGroupRowsWithNoIcon
Specifies Text indent if a group row icon is not used.
int | m_nTreeIndent
Tree indentation.
int | m_nTreeStructureStyle
Tree structure style.
int | m_nTreeTextIndentRowParent
Text indent, in pixels, for rows with children.
int | m_nTreeTextIndentRowChildren
Text indent, in pixels, for rows without children.
int | m_nTreeTextIndent
Text indent, in pixels, for rows that are neither parent nor children.
int | m_nTreeTextIndentGroupRow
Text indent, in pixels, for group rows.
BOOL | m_bGroupRowTextBold
TRUE to draw group rows with bold text.
BOOL | m_bShadeGroupHeadings
TRUE to show the indentation shade, FALSE otherwise.
BOOL | m_bShadeSortColumn
TRUE to show the items shade in the sorted by column, FALSE otherwise.
BOOL | m_bHotTracking
TRUE to allow column hot tracking.
BOOL | m_bInvertColumnOnClick
TRUE to invert column on click.
CString | m_strNoItems
A string which contains customized "No Items" text for displaying in view when there are no visible rows.
CString | m_strSortBy
A string which contains customized "Sort By" text for displaying in tooltip.
CString | m_strIncreasing
A string which contains customized "Increasing" text for displaying in tooltip.
CString | m_strDecreasing
A string which contains customized "Decreasing" text for displaying in tooltip.
CString | m_strNoGroupBy
A string which contains customized "No items" text message for displaying in Group By area when there are no items inside it.
CString | m_strNoFieldsAvailable
A string which contains customized "No Fields Available" text message for displaying in Field Chooser.
CString | m_strExpand
A string which contains customized "Expand" text for displaying in tooltip.
CString | m_strCollapse
A string which contains customized "Collapse" text for displaying in tooltip.
BOOL | m_bHideSelection
TRUE when hiding Grid control's selection by drawing selected items as others, FALSE otherwise.
BOOL | m_bPrintSortTriangle
TRUE to show the sort triangle in printout.
BOOL | m_bRevertAlignment
TRUE to revert column alignments.
BOOL | m_bUseEditTextAlignment
TRUE to automatically apply edit alignment using column alignment.
BOOL | m_bShowLockIcon
TRUE to show the lock icon, FALSE to hide.
BOOL | m_bUseShellIcon
TRUE to use the shell icon, FALSE otherwise.
int | m_iRecOrRowStart
Start position in numbering (0 or 1 or something user want).
BOOL | m_bRecOrRowNum
TRUE to display record number if support mode is used, FALSE to display row number.
BOOL | m_bMakeUpper
TRUE to display column header and group row text in all caps.
XTPGridTreeStructureStyle | m_treeStructureStyle
Tree structure style.
CRect | m_rcPreviewIndent
Preview indentation.
int | m_nFixedColumnsIndent
Fixed Column total width.
BOOL | m_bMoveScrollbarOnFixedColumnsIndent
Move Scrollbar right follow FixedColumnsIndent.
BOOL | m_bThemedInplaceButtons
Draw in-place buttons using current theme settings.
BOOL | m_bBaseTreeIndent
TRUE to add Extra Tree indentation to cover initial TreeColumn.
CUIntArray | m_arStartCol
Start column in each virtual page.
int | m_PrintPageWidth
Width of print page (run-time)
BOOL | m_bPrintVirtualPageNumber
TRUE to print horizontal page number.
BOOL | m_bPrintPageRectangle
TRUE to draw rectangle around page.
int | m_RecordNumberWidth
Column width for row/record numbers.
BOOL | m_bForceDynamicMarkupForCell
TRUE if use Markup for Grid Record Item.
BOOL | m_bForceShowDropMarker
TRUE if Force Show Drop Marker.
BOOL | m_bShowNonActiveInPlaceButton
TRUE if use Show Non-Active In-Place Button (Combo, Expand, Spin).
BOOL | m_bPrintWatermark
TRUE to print watermark.
BOOL | m_bUseGroupRowSelectionState
TRUE if use GroupSelectionState Glyph.
BOOL | m_bForceShowTooltip
TRUE if use show tooltip for any cell width case.
BOOL | m_bCleanTooltip
TRUE if use show tooltip without markup.
BOOL | m_bGrayIfDisable
TRUE is disable draw in gray (standard behavior).
int | m_nRowHeightDefault
The default row height.
BOOL | m_bCompactText
TRUE to ignore Icon for Narrow column to show more text.
BOOL | m_bUseDropMarker
FALSE to not draw drop marked when dragging/dropping, TRUE by default.
BOOL | m_bSortTriangleOffsetFromRight
Offset of sort triangle.
int | m_nTreeColumnLineLength
This is the extra line length to apply to tree column lines if there is no expand button.
int | m_nBaseParentRecordIndent
This is initial number of pixels a parent node will be indented when in a group.
- Protected Member Functions inherited from CXTPTrackPaintManager
- Protected Member Functions inherited from CXTPGridPaintManager
virtual void | DrawTextLine (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nFlag, int &nCharCounter, int &nHyperlinkCounter)
Draws a line of text with respect to the drawing rectangle.
virtual int | DrawString (int *pnCurrDrawPos, CDC *pDC, const CString &strDraw, CRect rcDraw, UINT nFormat)
Draw a simple string into rectangle.
virtual void | DrawGridPattern (CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush)
Generates a custom grid pattern if necessary.
virtual void | DrawGridPattern (CDC *pDC, CXTPBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush)
Generates a custom grid pattern if necessary.
virtual void | DrawGridPattern (CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr)
Generates a custom grid pattern.
virtual void | DrawInplaceButtonFrame (CDC *pDC, CXTPGridInplaceButton *pButton)
Draws the in-place button frame.
virtual BOOL | DrawInplaceButtonIcon (CDC *pDC, CXTPGridInplaceButton *pButton)
Draws the in-place button icon.
virtual int | CalcColumnHeight (CDC *pDC, CXTPGridColumn *pColumn, int nTotalWidth=0)
Calculates the optimal height for a specified column.
virtual void | DrawMultiLineText (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, BOOL bWordBreak=TRUE)
Draws multi-line text.
virtual void | DrawSingleLineText (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nStartPos, int nEndPos, int nActualWidth)
Draws single-line text.
virtual int | DrawLink (int *pnCurrDrawPos, XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CXTPGridHyperlink *pHyperlink, CString strText, CRect rcLink, int nFlag, BOOL bTrim=FALSE)
Draws a hyperlink string using hyperlink text settings (i.e.
- Protected Attributes inherited from CXTPGridPaintManager
int | m_nRowHeight
Grid row default height.
int | m_nHeaderHeight
Column header height.
int | m_nFooterHeight
Column footer height.
int | m_nGroupGridLineHeight
The height of the group grid line.
CXTPImageManager * | m_pGlyphs
An additional image list for the Grid control.
BOOL | m_bIsPreviewMode
TRUE to show the item preview, FALSE to hide.
int | m_nResizingWidth
The width of the column resizing marker area.
int | m_nMaxPreviewLines
Restrict maximum lines for preview text.
CSize | m_szGlyph
Glyph size.
CXTPBrush | m_xtpBrushTreeStructure
Brush to draw tree nodes.
CXTPBrush | m_xtpBrushGroupGridLineStyle
Brush to draw group row grid lines.
int | m_nFreezeColsDividerStyle
A set of flags from XTPGridFreezeColsDividerStyle.
BOOL | m_bFixedRowHeight
TRUE if fixed rows used.
BOOL | m_bColumnWidthWYSIWYG
TRUE if columns width WYSIWYG mode used.
BOOL | m_bShowWYSIWYGMarkers
TRUE if in non-print mode header show red page-end markers.
BOOL | m_bLastColumnWidthWYSIWYG
TRUE if last column width WYSIWYG mode used.
BOOL | m_bDrawGridForEmptySpace
TRUE if grid fills the empty space (if any) after the body rows.
BOOL | m_bPrintGroupRowIcon
TRUE if printout draw collapse-expand icon for group row.
BOOL | m_bColumnPlusMinusSign
TRUE if expand/collapse icons are used, FALSE if directional arrows are used.
BOOL | m_bFixedInplaceButtonHeight
TRUE if fixed in-place button height is used.
XTPGridGridStyle | m_nGroupGridLineStyle
Current style for group row grid lines.
XTPGridColumnStyle | m_columnStyle
Column drawing style.
CXTPWinThemeWrapper * | m_themeHeader
Header theme wrapper.
CXTPWinThemeWrapper * | m_themeButton
In-place button theme wrapper.
CXTPWinThemeWrapper * | m_themeCombo
Combo box in-place button theme wrapper.
CXTPWinThemeWrapper * | m_themeSpin
Spin in-place button theme wrapper.
CXTPGridControl * | m_pControl
Pointer to the Grid control object.
CXTPMarkupUIElement * | m_pMarkupUIElement_NoGroupBy
The no group by markup UI element.
CString | m_strMarkupUIElement_NoGroupBy
The no group by markup UI element string.
CXTPBrush | m_xtpBrushVeriticalGrid
Brush to draw vertical grid lines.
CXTPBrush | m_xtpBrushHorizontalGrid
Brush to draw horizontal grid lines.
XTPGridGridStyle m_nGridLineStylePreviousV
Previous style for vertical grid lines.
XTPGridGridStyle m_nGridLineStylePreviousH
Previous style for horizontal grid lines.

Detailed Description

CXTPTrackThemeVisualStudio2017 is a CXTPTrackThemeOffice2013 derived class that represents a Visual Studio 2017 style theme.

The documentation for this class was generated from the following file:
  • XTPTrackThemeVisualStudio2017.h


Toolkit Pro: CXTPTrackThemeVisualStudio2019 Class Reference

Public Member Functions | List of all members
CXTPTrackThemeVisualStudio2019 Class Reference

CXTPTrackThemeVisualStudio2019 is a CXTPTrackThemeOffice2013 derived class that represents a Visual Studio 2019 style theme. More...

Inheritance diagram for CXTPTrackThemeVisualStudio2019:
[legend]

Public Member Functions

CXTPTrackThemeVisualStudio2019 ()
Default paint manager constructor, handles properties initialization.
virtual void | RefreshMetrics ()
This method is called to refresh the visual metrics of the track control.
- Public Member Functions inherited from CXTPTrackThemeOffice2013
CXTPTrackThemeOffice2013 ()
Default paint manager constructor, handles properties initialization.
virtual void | LoadGlyphs ()
Loads the default images used by the track control.
virtual void | DrawColumnText (CDC *pDC, CRect rcText, CString strCaption, int nHeaderAlignment, BOOL bIsHeader, BOOL bColumnPressed)
Draws text for the column header.
virtual void | DrawColumnBackground (CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, BOOL &bColumnPressed, BOOL &bDraggingFromHeader, CXTPGridHeader *pHeader=NULL)
This method is called to draw the background of a column using the current column style.
virtual void | DrawTriangle (CDC *pDC, CRect rcTriangle, BOOL bToDown, BOOL bDraggingFromHeader, int nShadowWidth, BOOL bColumnPressed)
Draws a triangle that shows the sort order of the column.
virtual void | FillGroupRowMetrics (CXTPGridGroupRow *pRow, XTP_GRIDRECORDITEM_METRICS *pMetrics, BOOL bPrinting)
Fills the font and color members of the metrics structure for a specified group row.
virtual void | DrawGroupRow (CDC *pDC, CXTPGridGroupRow *pRow, CRect rcRow, XTP_GRIDRECORDITEM_METRICS *pMetrics)
Draws a group row.
virtual void | DrawFocusedRow (CDC *pDC, CRect rcRow)
Draws focused rows.
virtual int | GetRowHeight (CDC *pDC, CXTPGridRow *pRow)
Retrieves the default row height for print mode (i.e.
- Public Member Functions inherited from CXTPTrackPaintManager
CXTPTrackPaintManager ()
Creates a CXTPTrackPaintManager object.
~CXTPTrackPaintManager ()
CXTPTrackPaintManager destructor, handles cleanup and deallocation.
virtual void | DrawTrackHeader (CDC *pDC)
Call this function to draw the track header.
virtual void | DrawMarkers (CDC *pDC)
Call this function to draw the markers.
virtual void | DrawTimeLine (CDC *pDC)
Call this function to draw the time line.
virtual CString | FormatTimeLineTick (int nPosition, COLORREF &clrTick, int &nTickLength)
Call this function to format the time and tick marker relative to a time line position.
virtual CString | FormatTime (int nPosition)
Call this function to format the time and tick marker relative to a time line position.
- Public Member Functions inherited from CXTPGridPaintManager
CXTPGridPaintManager ()
Default CXTPGridPaintManager constructor, handles properties initialization.
virtual | ~CXTPGridPaintManager ()
Default CXTPGridPaintManager destructor, handles member items deallocation.
virtual void | SetGridControl (CXTPGridControl *pControl)
Sets the associated Grid control for the paint manager.
virtual int | GetRowHeight (CDC *pDC, CXTPGridRow *pRow, int nTotalWidth)
Retrieves the default row height for print mode (i.e.
int | GetRowHeightEx (CDC *pDC, CXTPGridRow *pRow, int nTotalWidth, const BOOL firstLevel=TRUE)
Retrieves the default row height for print mode (i.e.
int | GetItemHeight (XTP_GRIDRECORDITEM_DRAWARGS &drawArgs, int nWidth)
Retrieves the height of a record item for a given width.
BOOL | FindRowAdjacentToMergedEx (const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, int &nAdjRowIndex, BOOL bUpward)
Searches the topmost or bottommost row depending on the height of the current row.
int | FindRowAdjacentToMerged (const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, BOOL bUpward)
Wrapper for the FindRowAdjacentToMergedEx method.
int | RecalcTotalHightOfMergedRows (CXTPGridColumns *pColumns, CDC *pDC, CXTPGridRow *pRow, int nRowHeight, int nTotalWidth)
Recalculates row height according to the height of merged items.
virtual int | GetPreviewItemHeight (CDC *pDC, CXTPGridRow *pRow, int nWidth, int nHeight)
Retrieves the height of a preview item for print mode.
virtual int | GetHeaderHeight ()
Gets the column header height.
virtual int | GetHeaderHeight (CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0)
Calculates the optimal header height.
virtual void | SetHeaderHeight (int nHeight)
Sets the column header height.
virtual int | GetFooterHeight (CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0)
Calculates the optimal footer height.
virtual COLORREF | GetControlBackColor (CXTPGridControl *pControl)
Retrieves the parent Grid control's background color.
virtual void | FillRow (CDC *pDC, CXTPGridRow *pRow, CRect rcRow)
Fills a specified row with its background color.
virtual void | DrawGrid (CDC *pDC, XTPGridOrientation orientation, CRect rcGrid)
Draws a grid for the control.
virtual void | DrawFreezeColsDivider (CDC *pDC, const CRect &rc, CXTPGridControl *pControl, CXTPGridRow *pRow=NULL)
Draws a freeze column divider.
virtual void | DrawVerticalTimeLineMarker (CDC *pDC, int xPos, CXTPGridControl *pControl, COLORREF color=RGB(0, 255, 0))
Draws a vertical timeline marker.
virtual void | FillIndent (CDC *pDC, CRect rcRow)
Fills an indent area by its background.
virtual void | FillItemShade (CDC *pDC, CRect rcItem)
Fills an item shade by its background if necessary.
virtual void | FillHeaderControl (CDC *pDC, CRect rcHeader)
Fills a column header control area by its background.
virtual void | FillFooter (CDC *pDC, CRect rcFooter)
Fills a column footer control area by its background.
virtual void | DrawColumn (CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn, BOOL bDrawExternal=FALSE, int nShadowWidth=0)
Draws a column header with all related attributes (sort order, icon, etc.).
virtual void | DrawColumnFooterDivider (CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn)
Draws the column footer divider.
virtual void | DrawColumnFooter (CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn)
Draws the column footer with all related attributes (e.g.
virtual BOOL | IsColumHotTrackingEnabled () const
Determines if hot tracking is enabled for the current column style.
virtual void | FillGroupByControl (CDC *pDC, CRect &rcGroupBy)
Draws the Group By box.
CXTPImageManager * | GetGlyphs () const
Gets a pointer to the additional image list with glyphs.
void | DrawHorizontalLine (CDC *pDC, int xPos, int yPos, int cx, COLORREF clr)
Draws a horizontal line.
void | DrawVerticalLine (CDC *pDC, int xPos, int yPos, int cy, COLORREF clr)
Draws a vertical line.
void | DrawConnector (CDC *pDC, CPoint ptFrom, CPoint ptTo)
Draws a column connector for the Group By box.
virtual CSize | DrawCollapsedBitmap (CDC *pDC, const CXTPGridRow *pRow, CRect &rcBitmap)
Draws a collapsed bitmap.
virtual int | DrawBitmap (CDC *pDC, CXTPGridControl *pControl, CRect rcColumn, int iImage)
Draws a bitmap.
virtual int | DrawColumnIcon (CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, CRect rcIcon, int iIcon)
Draws an icon for a column.
virtual CSize | DrawGlyph (CDC *pDC, CRect rcColumn, int iImage)
Draws the standard glyphs of the Grid control.
virtual CSize | DrawShellIcon (CDC *pDC, CRect rcColumn, int iImage)
Draws the shell icon.
void | EnablePreviewMode (BOOL bIsPreviewMode)
Enables/disables preview mode for the control.
BOOL | IsPreviewMode () const
Determines if preview mode is enabled/disabled for the control.
CFont * | GetTextFont ()
Gets the default text font used for control items.
int | SetMaxPreviewLines (int nMaxLines)
Sets the maximum number of lines of text for a preview item.
int | GetMaxPreviewLines ()
Gets the maximum number of lines of text for a preview item.
int | GetPreviewLinesCount (CDC *pDC, CRect &rcText, const CString &strText)
Calculates the number of lines required to draw a specified preview text string, taking into account the maximum number of lines of text for a preview item.
BOOL | IsGridVisible (BOOL bVertical) const
Determines the visibility of specified grid lines.
BOOL | IsGridVisible (XTPGridOrientation orientation) const
Determines the visibility of specified grid lines.
void | SetColumnStyle (XTPGridColumnStyle columnStyle)
Sets the header style.
XTPGridColumnStyle | GetColumnStyle () const
Gets the header style.
void | SetColumnOffice2007CustomThemeBaseColor (COLORREF clrBaseColor)
Sets the header's custom theme base color for Office2007 column style.
COLORREF | GetColumnOffice2007CustomThemeBaseColor () const
Gets the header's custom theme base color for Office2007 column style.
void | SetTextFont (LOGFONT &lf)
Creates and sets the default text font.
void | SetCaptionFont (LOGFONT &lf)
Creates and sets the default caption font.
void | SetPreviewIndent (int nLeft, int nTop, int nRight, int nBottom)
Sets the preview item indent.
virtual void | DrawInplaceButton (CDC *pDC, CXTPGridInplaceButton *pButton)
Draws the in-place button of the Grid control.
virtual BOOL | DrawInplaceComboButton (CDC *pDC, CRect *pRc)
Draws the combo button of the Grid control.
virtual BOOL | DrawInplaceExpandButton (CDC *pDC, CRect *pRc)
Draws the expand button of the Grid control.
virtual BOOL | DrawInplaceSpinButton (CDC *pDC, CRect *pRc)
Draws the spin button of the Grid control.
virtual void | DrawTreeStructure (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CRect rcItem, CSize sizeGlyph)
Draws tree elements of the Grid control.
virtual void | DrawItemBitmap (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CRect &rcItem, int nImage)
Draws an item bitmap.
virtual void | DrawItemCaption (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics)
Draws an item caption.
virtual void | DrawRowNumber (CDC *pDC, CRect rcNumber, CXTPGridRow *pRow)
Draws a row number.
virtual void | DrawItemControl (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CXTPGridRecordItemControl *pControl, CRect &rcItem)
Draws an item control.
BOOL | IsFixedRowHeight () const
Determines if the paint manager supports fixed or variable row height.
void | SetFixedRowHeight (BOOL bFixedRowHeight)
Sets if the paint manager supports fixed or variable row height.
BOOL | IsColumnWidthWYSIWYG () const
Determines if the paint manager supports column width WYSIWYG mode.
BOOL | IsLastColumnWidthWYSIWYG () const
Determines if the paint manager supports last column width WYSIWYG mode.
BOOL | IsShowWYSIWYGMarkers () const
Determines if the paint manager shows WYSIWYG page-end markers.
void | ShowWYSIWYGMarkers (BOOL bSet)
Sets if the paint manager shows WYSIWYG page-end markers.
void | SetColumnWidthWYSIWYG (BOOL bColumnWidthWYSIWYG)
Sets if the paint manager supports column width WYSIWYG mode.
void | SetLastColumnWidthWYSIWYG (BOOL bColumnWidthWYSIWYG)
Sets if the paint manager supports last column width WYSIWYG mode.
BOOL | IsFixedInplaceButtonHeight () const
Determines if the paint manager supports fixed or variable in-place button height.
void | SetInplaceButtonHeight (BOOL bFixedInplaceButtonHeight)
Sets if the paint manager supports fixed or variable in-place button height.
int | GetFreezeColsDividerStyle () const
Gets the style of the freeze columns divider line.
void | SetFreezeColsDividerStyle (int nStyle)
Sets the style for the freeze columns divider line.
virtual BOOL | OnDrawAction (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs)
Override this method to perform custom activities for the item before processing it.
virtual void | DrawNoGroupByText (CDC *pDC, CRect rcItem)
Draws the "No items" text message in the Group By area when there are no items inside it.
BOOL | IsDrawGridForEmptySpace () const
Determines if the grid fills empty space after body rows.
void | SetDrawGridForEmptySpace (BOOL bDrawGrid)
Sets if the grid fills empty space after body rows.
BOOL | IsPrintGroupRowIcon () const
Determines if the group row collapse-expand icon is drawn in print mode.
void | SetPrintGroupRowIcon (BOOL bDraw)
Sets if the group row collapse-expand icon is drawn in print mode.
BOOL | IsColumnPlusMinusSign () const
Determines if columns use expand/collapse icons (+/-) or directional arrows.
void | SetColumnPlusMinusSign (BOOL bDraw)
Specifies if columns use expand/collapse icons (+/-) or directional arrows.
virtual int | CalculateRowHeight (CDC *pDC, const CString &strText, int nMaxWidth, BOOL bWordBreak=TRUE)
Calculates the height required for a rectangle bounding multi-line text to draw the multi-line text when the width of the rectangle is fixed.
void | DrawSectionDivider (CDC *pDC, const CRect &rc, XTPGridSectionDividerPosition dividerPosition, XTPGridSectionDividerStyle dividerStyle, CXTPPaintManagerColor dividerColor)
Draws the divider between grid sections (e.g.
int | GetSectionDividerHeight (XTPGridFixedRowsDividerStyle dividerStyle)
Gets the height of the section divider.
BOOL | IsUseDropMarker () const
Determines if a drop marker will be used when dragging and dropping.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPTrackThemeOffice2013
CXTPPaintManagerColor | m_clrGlyph
Header glyph color.
CXTPPaintManagerColor | m_clrGlyphHighlight
Header highlighted glyph color.
CXTPPaintManagerColor | m_clrSelectedBorder
Selected block border.
- Public Attributes inherited from CXTPTrackPaintManager
COLORREF | m_clrWorkArea
The color of the work area.
COLORREF | m_clrTrackHeader
The track header color.
COLORREF | m_clrTrackTimeArea
The track time area color.
COLORREF | m_clrTimeHeaderDarkDark
The header deep dark color.
COLORREF | m_clrTimeHeaderDark
The header dark color.
COLORREF | m_clrTimeSliderBackground
The slider background color.
COLORREF | m_clrTimeHeaderDivider
The header divider color.
COLORREF | m_clrScrollBarLight
The scrollbar light color.
COLORREF | m_clrScrollBarDark
The scrollbar dark color.
COLORREF | m_clrSelectedArea
The color of the selected area.
COLORREF | m_clrMarker
The color of the marker.
COLORREF | m_clrTimeLineTick
The color of a time line tick.
COLORREF | m_clrMarkerBorder
The color of a time line marker's border.
COLORREF | m_clrMarkerBack
The color of a time line marker's back.
COLORREF | m_clrTrackMarkerBorder
The color of a track marker's border.
COLORREF | m_clrTrackMarkerText
The color of a track marker's text.
COLORREF | m_clrTrackMarkerTextBack
The color of a track marker's text back.
COLORREF | m_clrTrackMarkerTextBorder
The color of a track marker's text border.
COLORREF | m_clrTimeLinePosition
The color of a marked position on a time line.
COLORREF | m_clrTimeHeaderBorder
The color of a time line header's border.
COLORREF | m_clrScrollBarBorderDark
The scrollbar border dark color.
COLORREF | m_clrScrollBarBorderLight
The scrollbar border light color.
COLORREF | m_clrWorkAreaScrollBarLight
The workarea scrollbar light color.
COLORREF | m_clrWorkAreaScrollBarDark
The workarea scrollbar dark color.
COLORREF | m_clrWorkAreaScrollBarBorder
The workarea scrollbar border color.
- Public Attributes inherited from CXTPGridPaintManager
CXTPFont | m_xtpFontText
Grid items default text.
CXTPFont | m_xtpFontBoldText
Grid items default bold text.
CXTPFont | m_xtpFontCaption
Column header caption font.
CXTPFont | m_xtpFontPreview
Column header caption font.
CXTPGridHyperlinkStyle * | m_pHyperlinkStyle
Style for links.
CXTPGridHyperlinkStyle * | m_pHyperlinkHoverStyle
Style for hovered links.
CXTPPaintManagerColor | m_clrHighlight
Background color of the highlighted row.
CXTPPaintManagerColor | m_clrBoldText
Grid items bold text color.
CXTPPaintManagerColor | m_clrBoldTextHighlight
Grid items bold text highlight color.
CXTPPaintManagerColor | m_clrWindowText
Grid items default text color.
CXTPPaintManagerColor | m_clrHighlightText
Text color of the highlighted text.
CXTPPaintManagerColor | m_clrHeaderControl
Background color of the grid header.
CXTPPaintManagerColor | m_clrCaptionText
Column header text color.
CXTPPaintManagerColor | m_clrCaptionTextPressed
Column header text color when pressed.
CXTPPaintManagerColor | m_clrControlBack
Background color of the control grid area.
CXTPPaintManagerColor | m_clrGroupRowText
Row text color.
CXTPPaintManagerColor | m_clrGroupShadeBack
Group row background color when indentation shade is enabled.
CXTPPaintManagerColor | m_clrGroupShadeText
Group row foreground color when indentation shade is enabled.
CXTPPaintManagerColor | m_clrGroupShadeBorder
Color for group border's shade.
CXTPPaintManagerColor | m_clrGroupBoxBack
Color of group box.
CXTPPaintManagerColor | m_clrControlDark
Dark background color of the Grid control (used on Group By area).
CXTPPaintManagerColor | m_clrControlLightLight
Light background color used for drawing shades (used on column header area).
CXTPPaintManagerColor | m_clrHotDivider
Color of the column hot divider window (two arrows).
CXTPPaintManagerColor | m_clrIndentControl
Color of the tree indentation area.
CXTPPaintManagerColor | m_clrItemShade
Color of the shade on sorted by column items.
CXTPPaintManagerColor | m_clrBtnFace
Standard button face color.
CXTPPaintManagerColor | m_clrBtnText
Standard button text color.
CXTPPaintManagerColor | m_clrPreviewText
Preview text color.
CXTPPaintManagerColor | m_clrSelectedRow
Selected row background color.
CXTPPaintManagerColor | m_clrSelectedRowText
Selected row text color.
CXTPPaintManagerColor | m_clrBtnFacePressed
Standard button face color when pressed.
CXTPPaintManagerColor | m_clrConnector
Header column connector line color.
CXTPPaintManagerColor | m_clrDisableBitmapLightest
The lightest color of bitmap which covers disabled grid.
CXTPPaintManagerColor | m_clrDisableBitmapDarkest
The darkest color of bitmap which covers disabled grid.
CXTPPaintManagerColorGradient | m_grcGradientColumn
Color of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColorGradient | m_grcGradientColumnHot
HotTracking Color of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColorGradient | m_grcGradientColumnPushed
Pushed Color of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColor | m_clrGradientColumnShadow
Bottom shadow of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColor | m_clrGradientColumnSeparator
Separator of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColor | m_crlNoGroupByText
A color for "No items" text in GroupBy area (see m_strNoGroupBy member).
CXTPPaintManagerColor | m_clrFreezeColsDivider
Freeze Columns Divider color.
COLORREF | m_clrColumnOffice2007CustomTheme
Base color for Office2007 custom theme.
COLORREF | m_clrFormulaSum
Color for Formula Sum fields.
COLORREF | m_clrFormulaSubSum
Color for Formula SubSum fields.
COLORREF | m_clrAlternativeBackground
Color for Alternative Row Background.
BOOL | m_bUseAlternativeBackground
TRUE to use Alternative Row Background, FALSE otherwise.
BOOL | m_bAllowMergeCells
TRUE to Allow Merge Cells, FALSE otherwise.
int | m_nTextIndentForGroupRowsWithNoIcon
Specifies Text indent if a group row icon is not used.
int | m_nTreeIndent
Tree indentation.
int | m_nTreeStructureStyle
Tree structure style.
int | m_nTreeTextIndentRowParent
Text indent, in pixels, for rows with children.
int | m_nTreeTextIndentRowChildren
Text indent, in pixels, for rows without children.
int | m_nTreeTextIndent
Text indent, in pixels, for rows that are neither parent nor children.
int | m_nTreeTextIndentGroupRow
Text indent, in pixels, for group rows.
BOOL | m_bGroupRowTextBold
TRUE to draw group rows with bold text.
BOOL | m_bShadeGroupHeadings
TRUE to show the indentation shade, FALSE otherwise.
BOOL | m_bShadeSortColumn
TRUE to show the items shade in the sorted by column, FALSE otherwise.
BOOL | m_bHotTracking
TRUE to allow column hot tracking.
BOOL | m_bInvertColumnOnClick
TRUE to invert column on click.
CString | m_strNoItems
A string which contains customized "No Items" text for displaying in view when there are no visible rows.
CString | m_strSortBy
A string which contains customized "Sort By" text for displaying in tooltip.
CString | m_strIncreasing
A string which contains customized "Increasing" text for displaying in tooltip.
CString | m_strDecreasing
A string which contains customized "Decreasing" text for displaying in tooltip.
CString | m_strNoGroupBy
A string which contains customized "No items" text message for displaying in Group By area when there are no items inside it.
CString | m_strNoFieldsAvailable
A string which contains customized "No Fields Available" text message for displaying in Field Chooser.
CString | m_strExpand
A string which contains customized "Expand" text for displaying in tooltip.
CString | m_strCollapse
A string which contains customized "Collapse" text for displaying in tooltip.
BOOL | m_bHideSelection
TRUE when hiding Grid control's selection by drawing selected items as others, FALSE otherwise.
BOOL | m_bPrintSortTriangle
TRUE to show the sort triangle in printout.
BOOL | m_bRevertAlignment
TRUE to revert column alignments.
BOOL | m_bUseEditTextAlignment
TRUE to automatically apply edit alignment using column alignment.
BOOL | m_bShowLockIcon
TRUE to show the lock icon, FALSE to hide.
BOOL | m_bUseShellIcon
TRUE to use the shell icon, FALSE otherwise.
int | m_iRecOrRowStart
Start position in numbering (0 or 1 or something user want).
BOOL | m_bRecOrRowNum
TRUE to display record number if support mode is used, FALSE to display row number.
BOOL | m_bMakeUpper
TRUE to display column header and group row text in all caps.
XTPGridTreeStructureStyle | m_treeStructureStyle
Tree structure style.
CRect | m_rcPreviewIndent
Preview indentation.
int | m_nFixedColumnsIndent
Fixed Column total width.
BOOL | m_bMoveScrollbarOnFixedColumnsIndent
Move Scrollbar right follow FixedColumnsIndent.
BOOL | m_bThemedInplaceButtons
Draw in-place buttons using current theme settings.
BOOL | m_bBaseTreeIndent
TRUE to add Extra Tree indentation to cover initial TreeColumn.
CUIntArray | m_arStartCol
Start column in each virtual page.
int | m_PrintPageWidth
Width of print page (run-time)
BOOL | m_bPrintVirtualPageNumber
TRUE to print horizontal page number.
BOOL | m_bPrintPageRectangle
TRUE to draw rectangle around page.
int | m_RecordNumberWidth
Column width for row/record numbers.
BOOL | m_bForceDynamicMarkupForCell
TRUE if use Markup for Grid Record Item.
BOOL | m_bForceShowDropMarker
TRUE if Force Show Drop Marker.
BOOL | m_bShowNonActiveInPlaceButton
TRUE if use Show Non-Active In-Place Button (Combo, Expand, Spin).
BOOL | m_bPrintWatermark
TRUE to print watermark.
BOOL | m_bUseGroupRowSelectionState
TRUE if use GroupSelectionState Glyph.
BOOL | m_bForceShowTooltip
TRUE if use show tooltip for any cell width case.
BOOL | m_bCleanTooltip
TRUE if use show tooltip without markup.
BOOL | m_bGrayIfDisable
TRUE is disable draw in gray (standard behavior).
int | m_nRowHeightDefault
The default row height.
BOOL | m_bCompactText
TRUE to ignore Icon for Narrow column to show more text.
BOOL | m_bUseDropMarker
FALSE to not draw drop marked when dragging/dropping, TRUE by default.
BOOL | m_bSortTriangleOffsetFromRight
Offset of sort triangle.
int | m_nTreeColumnLineLength
This is the extra line length to apply to tree column lines if there is no expand button.
int | m_nBaseParentRecordIndent
This is initial number of pixels a parent node will be indented when in a group.
- Protected Member Functions inherited from CXTPTrackPaintManager
- Protected Member Functions inherited from CXTPGridPaintManager
virtual void | DrawTextLine (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nFlag, int &nCharCounter, int &nHyperlinkCounter)
Draws a line of text with respect to the drawing rectangle.
virtual int | DrawString (int *pnCurrDrawPos, CDC *pDC, const CString &strDraw, CRect rcDraw, UINT nFormat)
Draw a simple string into rectangle.
virtual void | DrawGridPattern (CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush)
Generates a custom grid pattern if necessary.
virtual void | DrawGridPattern (CDC *pDC, CXTPBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush)
Generates a custom grid pattern if necessary.
virtual void | DrawGridPattern (CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr)
Generates a custom grid pattern.
virtual void | DrawInplaceButtonFrame (CDC *pDC, CXTPGridInplaceButton *pButton)
Draws the in-place button frame.
virtual BOOL | DrawInplaceButtonIcon (CDC *pDC, CXTPGridInplaceButton *pButton)
Draws the in-place button icon.
virtual int | CalcColumnHeight (CDC *pDC, CXTPGridColumn *pColumn, int nTotalWidth=0)
Calculates the optimal height for a specified column.
virtual void | DrawMultiLineText (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, BOOL bWordBreak=TRUE)
Draws multi-line text.
virtual void | DrawSingleLineText (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nStartPos, int nEndPos, int nActualWidth)
Draws single-line text.
virtual int | DrawLink (int *pnCurrDrawPos, XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CXTPGridHyperlink *pHyperlink, CString strText, CRect rcLink, int nFlag, BOOL bTrim=FALSE)
Draws a hyperlink string using hyperlink text settings (i.e.
- Protected Attributes inherited from CXTPGridPaintManager
int | m_nRowHeight
Grid row default height.
int | m_nHeaderHeight
Column header height.
int | m_nFooterHeight
Column footer height.
int | m_nGroupGridLineHeight
The height of the group grid line.
CXTPImageManager * | m_pGlyphs
An additional image list for the Grid control.
BOOL | m_bIsPreviewMode
TRUE to show the item preview, FALSE to hide.
int | m_nResizingWidth
The width of the column resizing marker area.
int | m_nMaxPreviewLines
Restrict maximum lines for preview text.
CSize | m_szGlyph
Glyph size.
CXTPBrush | m_xtpBrushTreeStructure
Brush to draw tree nodes.
CXTPBrush | m_xtpBrushGroupGridLineStyle
Brush to draw group row grid lines.
int | m_nFreezeColsDividerStyle
A set of flags from XTPGridFreezeColsDividerStyle.
BOOL | m_bFixedRowHeight
TRUE if fixed rows used.
BOOL | m_bColumnWidthWYSIWYG
TRUE if columns width WYSIWYG mode used.
BOOL | m_bShowWYSIWYGMarkers
TRUE if in non-print mode header show red page-end markers.
BOOL | m_bLastColumnWidthWYSIWYG
TRUE if last column width WYSIWYG mode used.
BOOL | m_bDrawGridForEmptySpace
TRUE if grid fills the empty space (if any) after the body rows.
BOOL | m_bPrintGroupRowIcon
TRUE if printout draw collapse-expand icon for group row.
BOOL | m_bColumnPlusMinusSign
TRUE if expand/collapse icons are used, FALSE if directional arrows are used.
BOOL | m_bFixedInplaceButtonHeight
TRUE if fixed in-place button height is used.
XTPGridGridStyle | m_nGroupGridLineStyle
Current style for group row grid lines.
XTPGridColumnStyle | m_columnStyle
Column drawing style.
CXTPWinThemeWrapper * | m_themeHeader
Header theme wrapper.
CXTPWinThemeWrapper * | m_themeButton
In-place button theme wrapper.
CXTPWinThemeWrapper * | m_themeCombo
Combo box in-place button theme wrapper.
CXTPWinThemeWrapper * | m_themeSpin
Spin in-place button theme wrapper.
CXTPGridControl * | m_pControl
Pointer to the Grid control object.
CXTPMarkupUIElement * | m_pMarkupUIElement_NoGroupBy
The no group by markup UI element.
CString | m_strMarkupUIElement_NoGroupBy
The no group by markup UI element string.
CXTPBrush | m_xtpBrushVeriticalGrid
Brush to draw vertical grid lines.
CXTPBrush | m_xtpBrushHorizontalGrid
Brush to draw horizontal grid lines.
XTPGridGridStyle m_nGridLineStylePreviousV
Previous style for vertical grid lines.
XTPGridGridStyle m_nGridLineStylePreviousH
Previous style for horizontal grid lines.

Detailed Description

CXTPTrackThemeVisualStudio2019 is a CXTPTrackThemeOffice2013 derived class that represents a Visual Studio 2019 style theme.

The documentation for this class was generated from the following file:
  • XTPTrackThemeVisualStudio2019.h


Toolkit Pro: CXTPTrackThemeVisualStudio2022 Class Reference

Public Member Functions | List of all members
CXTPTrackThemeVisualStudio2022 Class Reference

CXTPTrackThemeVisualStudio2022 is a CXTPTrackThemeOffice2013 derived class that represents a Visual Studio 2022 style theme. More...

Inheritance diagram for CXTPTrackThemeVisualStudio2022:
[legend]

Public Member Functions

CXTPTrackThemeVisualStudio2022 ()
Default paint manager constructor, handles properties initialization.
virtual void | RefreshMetrics ()
This method is called to refresh the visual metrics of the track control.
- Public Member Functions inherited from CXTPTrackThemeOffice2013
CXTPTrackThemeOffice2013 ()
Default paint manager constructor, handles properties initialization.
virtual void | LoadGlyphs ()
Loads the default images used by the track control.
virtual void | DrawColumnText (CDC *pDC, CRect rcText, CString strCaption, int nHeaderAlignment, BOOL bIsHeader, BOOL bColumnPressed)
Draws text for the column header.
virtual void | DrawColumnBackground (CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, BOOL &bColumnPressed, BOOL &bDraggingFromHeader, CXTPGridHeader *pHeader=NULL)
This method is called to draw the background of a column using the current column style.
virtual void | DrawTriangle (CDC *pDC, CRect rcTriangle, BOOL bToDown, BOOL bDraggingFromHeader, int nShadowWidth, BOOL bColumnPressed)
Draws a triangle that shows the sort order of the column.
virtual void | FillGroupRowMetrics (CXTPGridGroupRow *pRow, XTP_GRIDRECORDITEM_METRICS *pMetrics, BOOL bPrinting)
Fills the font and color members of the metrics structure for a specified group row.
virtual void | DrawGroupRow (CDC *pDC, CXTPGridGroupRow *pRow, CRect rcRow, XTP_GRIDRECORDITEM_METRICS *pMetrics)
Draws a group row.
virtual void | DrawFocusedRow (CDC *pDC, CRect rcRow)
Draws focused rows.
virtual int | GetRowHeight (CDC *pDC, CXTPGridRow *pRow)
Retrieves the default row height for print mode (i.e.
- Public Member Functions inherited from CXTPTrackPaintManager
CXTPTrackPaintManager ()
Creates a CXTPTrackPaintManager object.
~CXTPTrackPaintManager ()
CXTPTrackPaintManager destructor, handles cleanup and deallocation.
virtual void | DrawTrackHeader (CDC *pDC)
Call this function to draw the track header.
virtual void | DrawMarkers (CDC *pDC)
Call this function to draw the markers.
virtual void | DrawTimeLine (CDC *pDC)
Call this function to draw the time line.
virtual CString | FormatTimeLineTick (int nPosition, COLORREF &clrTick, int &nTickLength)
Call this function to format the time and tick marker relative to a time line position.
virtual CString | FormatTime (int nPosition)
Call this function to format the time and tick marker relative to a time line position.
- Public Member Functions inherited from CXTPGridPaintManager
CXTPGridPaintManager ()
Default CXTPGridPaintManager constructor, handles properties initialization.
virtual | ~CXTPGridPaintManager ()
Default CXTPGridPaintManager destructor, handles member items deallocation.
virtual void | SetGridControl (CXTPGridControl *pControl)
Sets the associated Grid control for the paint manager.
virtual int | GetRowHeight (CDC *pDC, CXTPGridRow *pRow, int nTotalWidth)
Retrieves the default row height for print mode (i.e.
int | GetRowHeightEx (CDC *pDC, CXTPGridRow *pRow, int nTotalWidth, const BOOL firstLevel=TRUE)
Retrieves the default row height for print mode (i.e.
int | GetItemHeight (XTP_GRIDRECORDITEM_DRAWARGS &drawArgs, int nWidth)
Retrieves the height of a record item for a given width.
BOOL | FindRowAdjacentToMergedEx (const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, int &nAdjRowIndex, BOOL bUpward)
Searches the topmost or bottommost row depending on the height of the current row.
int | FindRowAdjacentToMerged (const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, BOOL bUpward)
Wrapper for the FindRowAdjacentToMergedEx method.
int | RecalcTotalHightOfMergedRows (CXTPGridColumns *pColumns, CDC *pDC, CXTPGridRow *pRow, int nRowHeight, int nTotalWidth)
Recalculates row height according to the height of merged items.
virtual int | GetPreviewItemHeight (CDC *pDC, CXTPGridRow *pRow, int nWidth, int nHeight)
Retrieves the height of a preview item for print mode.
virtual int | GetHeaderHeight ()
Gets the column header height.
virtual int | GetHeaderHeight (CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0)
Calculates the optimal header height.
virtual void | SetHeaderHeight (int nHeight)
Sets the column header height.
virtual int | GetFooterHeight (CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0)
Calculates the optimal footer height.
virtual COLORREF | GetControlBackColor (CXTPGridControl *pControl)
Retrieves the parent Grid control's background color.
virtual void | FillRow (CDC *pDC, CXTPGridRow *pRow, CRect rcRow)
Fills a specified row with its background color.
virtual void | DrawGrid (CDC *pDC, XTPGridOrientation orientation, CRect rcGrid)
Draws a grid for the control.
virtual void | DrawFreezeColsDivider (CDC *pDC, const CRect &rc, CXTPGridControl *pControl, CXTPGridRow *pRow=NULL)
Draws a freeze column divider.
virtual void | DrawVerticalTimeLineMarker (CDC *pDC, int xPos, CXTPGridControl *pControl, COLORREF color=RGB(0, 255, 0))
Draws a vertical timeline marker.
virtual void | FillIndent (CDC *pDC, CRect rcRow)
Fills an indent area by its background.
virtual void | FillItemShade (CDC *pDC, CRect rcItem)
Fills an item shade by its background if necessary.
virtual void | FillHeaderControl (CDC *pDC, CRect rcHeader)
Fills a column header control area by its background.
virtual void | FillFooter (CDC *pDC, CRect rcFooter)
Fills a column footer control area by its background.
virtual void | DrawColumn (CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn, BOOL bDrawExternal=FALSE, int nShadowWidth=0)
Draws a column header with all related attributes (sort order, icon, etc.).
virtual void | DrawColumnFooterDivider (CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn)
Draws the column footer divider.
virtual void | DrawColumnFooter (CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn)
Draws the column footer with all related attributes (e.g.
virtual BOOL | IsColumHotTrackingEnabled () const
Determines if hot tracking is enabled for the current column style.
virtual void | FillGroupByControl (CDC *pDC, CRect &rcGroupBy)
Draws the Group By box.
CXTPImageManager * | GetGlyphs () const
Gets a pointer to the additional image list with glyphs.
void | DrawHorizontalLine (CDC *pDC, int xPos, int yPos, int cx, COLORREF clr)
Draws a horizontal line.
void | DrawVerticalLine (CDC *pDC, int xPos, int yPos, int cy, COLORREF clr)
Draws a vertical line.
void | DrawConnector (CDC *pDC, CPoint ptFrom, CPoint ptTo)
Draws a column connector for the Group By box.
virtual CSize | DrawCollapsedBitmap (CDC *pDC, const CXTPGridRow *pRow, CRect &rcBitmap)
Draws a collapsed bitmap.
virtual int | DrawBitmap (CDC *pDC, CXTPGridControl *pControl, CRect rcColumn, int iImage)
Draws a bitmap.
virtual int | DrawColumnIcon (CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, CRect rcIcon, int iIcon)
Draws an icon for a column.
virtual CSize | DrawGlyph (CDC *pDC, CRect rcColumn, int iImage)
Draws the standard glyphs of the Grid control.
virtual CSize | DrawShellIcon (CDC *pDC, CRect rcColumn, int iImage)
Draws the shell icon.
void | EnablePreviewMode (BOOL bIsPreviewMode)
Enables/disables preview mode for the control.
BOOL | IsPreviewMode () const
Determines if preview mode is enabled/disabled for the control.
CFont * | GetTextFont ()
Gets the default text font used for control items.
int | SetMaxPreviewLines (int nMaxLines)
Sets the maximum number of lines of text for a preview item.
int | GetMaxPreviewLines ()
Gets the maximum number of lines of text for a preview item.
int | GetPreviewLinesCount (CDC *pDC, CRect &rcText, const CString &strText)
Calculates the number of lines required to draw a specified preview text string, taking into account the maximum number of lines of text for a preview item.
BOOL | IsGridVisible (BOOL bVertical) const
Determines the visibility of specified grid lines.
BOOL | IsGridVisible (XTPGridOrientation orientation) const
Determines the visibility of specified grid lines.
void | SetColumnStyle (XTPGridColumnStyle columnStyle)
Sets the header style.
XTPGridColumnStyle | GetColumnStyle () const
Gets the header style.
void | SetColumnOffice2007CustomThemeBaseColor (COLORREF clrBaseColor)
Sets the header's custom theme base color for Office2007 column style.
COLORREF | GetColumnOffice2007CustomThemeBaseColor () const
Gets the header's custom theme base color for Office2007 column style.
void | SetTextFont (LOGFONT &lf)
Creates and sets the default text font.
void | SetCaptionFont (LOGFONT &lf)
Creates and sets the default caption font.
void | SetPreviewIndent (int nLeft, int nTop, int nRight, int nBottom)
Sets the preview item indent.
virtual void | DrawInplaceButton (CDC *pDC, CXTPGridInplaceButton *pButton)
Draws the in-place button of the Grid control.
virtual BOOL | DrawInplaceComboButton (CDC *pDC, CRect *pRc)
Draws the combo button of the Grid control.
virtual BOOL | DrawInplaceExpandButton (CDC *pDC, CRect *pRc)
Draws the expand button of the Grid control.
virtual BOOL | DrawInplaceSpinButton (CDC *pDC, CRect *pRc)
Draws the spin button of the Grid control.
virtual void | DrawTreeStructure (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CRect rcItem, CSize sizeGlyph)
Draws tree elements of the Grid control.
virtual void | DrawItemBitmap (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CRect &rcItem, int nImage)
Draws an item bitmap.
virtual void | DrawItemCaption (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics)
Draws an item caption.
virtual void | DrawRowNumber (CDC *pDC, CRect rcNumber, CXTPGridRow *pRow)
Draws a row number.
virtual void | DrawItemControl (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CXTPGridRecordItemControl *pControl, CRect &rcItem)
Draws an item control.
BOOL | IsFixedRowHeight () const
Determines if the paint manager supports fixed or variable row height.
void | SetFixedRowHeight (BOOL bFixedRowHeight)
Sets if the paint manager supports fixed or variable row height.
BOOL | IsColumnWidthWYSIWYG () const
Determines if the paint manager supports column width WYSIWYG mode.
BOOL | IsLastColumnWidthWYSIWYG () const
Determines if the paint manager supports last column width WYSIWYG mode.
BOOL | IsShowWYSIWYGMarkers () const
Determines if the paint manager shows WYSIWYG page-end markers.
void | ShowWYSIWYGMarkers (BOOL bSet)
Sets if the paint manager shows WYSIWYG page-end markers.
void | SetColumnWidthWYSIWYG (BOOL bColumnWidthWYSIWYG)
Sets if the paint manager supports column width WYSIWYG mode.
void | SetLastColumnWidthWYSIWYG (BOOL bColumnWidthWYSIWYG)
Sets if the paint manager supports last column width WYSIWYG mode.
BOOL | IsFixedInplaceButtonHeight () const
Determines if the paint manager supports fixed or variable in-place button height.
void | SetInplaceButtonHeight (BOOL bFixedInplaceButtonHeight)
Sets if the paint manager supports fixed or variable in-place button height.
int | GetFreezeColsDividerStyle () const
Gets the style of the freeze columns divider line.
void | SetFreezeColsDividerStyle (int nStyle)
Sets the style for the freeze columns divider line.
virtual BOOL | OnDrawAction (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs)
Override this method to perform custom activities for the item before processing it.
virtual void | DrawNoGroupByText (CDC *pDC, CRect rcItem)
Draws the "No items" text message in the Group By area when there are no items inside it.
BOOL | IsDrawGridForEmptySpace () const
Determines if the grid fills empty space after body rows.
void | SetDrawGridForEmptySpace (BOOL bDrawGrid)
Sets if the grid fills empty space after body rows.
BOOL | IsPrintGroupRowIcon () const
Determines if the group row collapse-expand icon is drawn in print mode.
void | SetPrintGroupRowIcon (BOOL bDraw)
Sets if the group row collapse-expand icon is drawn in print mode.
BOOL | IsColumnPlusMinusSign () const
Determines if columns use expand/collapse icons (+/-) or directional arrows.
void | SetColumnPlusMinusSign (BOOL bDraw)
Specifies if columns use expand/collapse icons (+/-) or directional arrows.
virtual int | CalculateRowHeight (CDC *pDC, const CString &strText, int nMaxWidth, BOOL bWordBreak=TRUE)
Calculates the height required for a rectangle bounding multi-line text to draw the multi-line text when the width of the rectangle is fixed.
void | DrawSectionDivider (CDC *pDC, const CRect &rc, XTPGridSectionDividerPosition dividerPosition, XTPGridSectionDividerStyle dividerStyle, CXTPPaintManagerColor dividerColor)
Draws the divider between grid sections (e.g.
int | GetSectionDividerHeight (XTPGridFixedRowsDividerStyle dividerStyle)
Gets the height of the section divider.
BOOL | IsUseDropMarker () const
Determines if a drop marker will be used when dragging and dropping.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPTrackThemeOffice2013
CXTPPaintManagerColor | m_clrGlyph
Header glyph color.
CXTPPaintManagerColor | m_clrGlyphHighlight
Header highlighted glyph color.
CXTPPaintManagerColor | m_clrSelectedBorder
Selected block border.
- Public Attributes inherited from CXTPTrackPaintManager
COLORREF | m_clrWorkArea
The color of the work area.
COLORREF | m_clrTrackHeader
The track header color.
COLORREF | m_clrTrackTimeArea
The track time area color.
COLORREF | m_clrTimeHeaderDarkDark
The header deep dark color.
COLORREF | m_clrTimeHeaderDark
The header dark color.
COLORREF | m_clrTimeSliderBackground
The slider background color.
COLORREF | m_clrTimeHeaderDivider
The header divider color.
COLORREF | m_clrScrollBarLight
The scrollbar light color.
COLORREF | m_clrScrollBarDark
The scrollbar dark color.
COLORREF | m_clrSelectedArea
The color of the selected area.
COLORREF | m_clrMarker
The color of the marker.
COLORREF | m_clrTimeLineTick
The color of a time line tick.
COLORREF | m_clrMarkerBorder
The color of a time line marker's border.
COLORREF | m_clrMarkerBack
The color of a time line marker's back.
COLORREF | m_clrTrackMarkerBorder
The color of a track marker's border.
COLORREF | m_clrTrackMarkerText
The color of a track marker's text.
COLORREF | m_clrTrackMarkerTextBack
The color of a track marker's text back.
COLORREF | m_clrTrackMarkerTextBorder
The color of a track marker's text border.
COLORREF | m_clrTimeLinePosition
The color of a marked position on a time line.
COLORREF | m_clrTimeHeaderBorder
The color of a time line header's border.
COLORREF | m_clrScrollBarBorderDark
The scrollbar border dark color.
COLORREF | m_clrScrollBarBorderLight
The scrollbar border light color.
COLORREF | m_clrWorkAreaScrollBarLight
The workarea scrollbar light color.
COLORREF | m_clrWorkAreaScrollBarDark
The workarea scrollbar dark color.
COLORREF | m_clrWorkAreaScrollBarBorder
The workarea scrollbar border color.
- Public Attributes inherited from CXTPGridPaintManager
CXTPFont | m_xtpFontText
Grid items default text.
CXTPFont | m_xtpFontBoldText
Grid items default bold text.
CXTPFont | m_xtpFontCaption
Column header caption font.
CXTPFont | m_xtpFontPreview
Column header caption font.
CXTPGridHyperlinkStyle * | m_pHyperlinkStyle
Style for links.
CXTPGridHyperlinkStyle * | m_pHyperlinkHoverStyle
Style for hovered links.
CXTPPaintManagerColor | m_clrHighlight
Background color of the highlighted row.
CXTPPaintManagerColor | m_clrBoldText
Grid items bold text color.
CXTPPaintManagerColor | m_clrBoldTextHighlight
Grid items bold text highlight color.
CXTPPaintManagerColor | m_clrWindowText
Grid items default text color.
CXTPPaintManagerColor | m_clrHighlightText
Text color of the highlighted text.
CXTPPaintManagerColor | m_clrHeaderControl
Background color of the grid header.
CXTPPaintManagerColor | m_clrCaptionText
Column header text color.
CXTPPaintManagerColor | m_clrCaptionTextPressed
Column header text color when pressed.
CXTPPaintManagerColor | m_clrControlBack
Background color of the control grid area.
CXTPPaintManagerColor | m_clrGroupRowText
Row text color.
CXTPPaintManagerColor | m_clrGroupShadeBack
Group row background color when indentation shade is enabled.
CXTPPaintManagerColor | m_clrGroupShadeText
Group row foreground color when indentation shade is enabled.
CXTPPaintManagerColor | m_clrGroupShadeBorder
Color for group border's shade.
CXTPPaintManagerColor | m_clrGroupBoxBack
Color of group box.
CXTPPaintManagerColor | m_clrControlDark
Dark background color of the Grid control (used on Group By area).
CXTPPaintManagerColor | m_clrControlLightLight
Light background color used for drawing shades (used on column header area).
CXTPPaintManagerColor | m_clrHotDivider
Color of the column hot divider window (two arrows).
CXTPPaintManagerColor | m_clrIndentControl
Color of the tree indentation area.
CXTPPaintManagerColor | m_clrItemShade
Color of the shade on sorted by column items.
CXTPPaintManagerColor | m_clrBtnFace
Standard button face color.
CXTPPaintManagerColor | m_clrBtnText
Standard button text color.
CXTPPaintManagerColor | m_clrPreviewText
Preview text color.
CXTPPaintManagerColor | m_clrSelectedRow
Selected row background color.
CXTPPaintManagerColor | m_clrSelectedRowText
Selected row text color.
CXTPPaintManagerColor | m_clrBtnFacePressed
Standard button face color when pressed.
CXTPPaintManagerColor | m_clrConnector
Header column connector line color.
CXTPPaintManagerColor | m_clrDisableBitmapLightest
The lightest color of bitmap which covers disabled grid.
CXTPPaintManagerColor | m_clrDisableBitmapDarkest
The darkest color of bitmap which covers disabled grid.
CXTPPaintManagerColorGradient | m_grcGradientColumn
Color of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColorGradient | m_grcGradientColumnHot
HotTracking Color of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColorGradient | m_grcGradientColumnPushed
Pushed Color of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColor | m_clrGradientColumnShadow
Bottom shadow of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColor | m_clrGradientColumnSeparator
Separator of column used with xtpGridColumnOffice2003 style.
CXTPPaintManagerColor | m_crlNoGroupByText
A color for "No items" text in GroupBy area (see m_strNoGroupBy member).
CXTPPaintManagerColor | m_clrFreezeColsDivider
Freeze Columns Divider color.
COLORREF | m_clrColumnOffice2007CustomTheme
Base color for Office2007 custom theme.
COLORREF | m_clrFormulaSum
Color for Formula Sum fields.
COLORREF | m_clrFormulaSubSum
Color for Formula SubSum fields.
COLORREF | m_clrAlternativeBackground
Color for Alternative Row Background.
BOOL | m_bUseAlternativeBackground
TRUE to use Alternative Row Background, FALSE otherwise.
BOOL | m_bAllowMergeCells
TRUE to Allow Merge Cells, FALSE otherwise.
int | m_nTextIndentForGroupRowsWithNoIcon
Specifies Text indent if a group row icon is not used.
int | m_nTreeIndent
Tree indentation.
int | m_nTreeStructureStyle
Tree structure style.
int | m_nTreeTextIndentRowParent
Text indent, in pixels, for rows with children.
int | m_nTreeTextIndentRowChildren
Text indent, in pixels, for rows without children.
int | m_nTreeTextIndent
Text indent, in pixels, for rows that are neither parent nor children.
int | m_nTreeTextIndentGroupRow
Text indent, in pixels, for group rows.
BOOL | m_bGroupRowTextBold
TRUE to draw group rows with bold text.
BOOL | m_bShadeGroupHeadings
TRUE to show the indentation shade, FALSE otherwise.
BOOL | m_bShadeSortColumn
TRUE to show the items shade in the sorted by column, FALSE otherwise.
BOOL | m_bHotTracking
TRUE to allow column hot tracking.
BOOL | m_bInvertColumnOnClick
TRUE to invert column on click.
CString | m_strNoItems
A string which contains customized "No Items" text for displaying in view when there are no visible rows.
CString | m_strSortBy
A string which contains customized "Sort By" text for displaying in tooltip.
CString | m_strIncreasing
A string which contains customized "Increasing" text for displaying in tooltip.
CString | m_strDecreasing
A string which contains customized "Decreasing" text for displaying in tooltip.
CString | m_strNoGroupBy
A string which contains customized "No items" text message for displaying in Group By area when there are no items inside it.
CString | m_strNoFieldsAvailable
A string which contains customized "No Fields Available" text message for displaying in Field Chooser.
CString | m_strExpand
A string which contains customized "Expand" text for displaying in tooltip.
CString | m_strCollapse
A string which contains customized "Collapse" text for displaying in tooltip.
BOOL | m_bHideSelection
TRUE when hiding Grid control's selection by drawing selected items as others, FALSE otherwise.
BOOL | m_bPrintSortTriangle
TRUE to show the sort triangle in printout.
BOOL | m_bRevertAlignment
TRUE to revert column alignments.
BOOL | m_bUseEditTextAlignment
TRUE to automatically apply edit alignment using column alignment.
BOOL | m_bShowLockIcon
TRUE to show the lock icon, FALSE to hide.
BOOL | m_bUseShellIcon
TRUE to use the shell icon, FALSE otherwise.
int | m_iRecOrRowStart
Start position in numbering (0 or 1 or something user want).
BOOL | m_bRecOrRowNum
TRUE to display record number if support mode is used, FALSE to display row number.
BOOL | m_bMakeUpper
TRUE to display column header and group row text in all caps.
XTPGridTreeStructureStyle | m_treeStructureStyle
Tree structure style.
CRect | m_rcPreviewIndent
Preview indentation.
int | m_nFixedColumnsIndent
Fixed Column total width.
BOOL | m_bMoveScrollbarOnFixedColumnsIndent
Move Scrollbar right follow FixedColumnsIndent.
BOOL | m_bThemedInplaceButtons
Draw in-place buttons using current theme settings.
BOOL | m_bBaseTreeIndent
TRUE to add Extra Tree indentation to cover initial TreeColumn.
CUIntArray | m_arStartCol
Start column in each virtual page.
int | m_PrintPageWidth
Width of print page (run-time)
BOOL | m_bPrintVirtualPageNumber
TRUE to print horizontal page number.
BOOL | m_bPrintPageRectangle
TRUE to draw rectangle around page.
int | m_RecordNumberWidth
Column width for row/record numbers.
BOOL | m_bForceDynamicMarkupForCell
TRUE if use Markup for Grid Record Item.
BOOL | m_bForceShowDropMarker
TRUE if Force Show Drop Marker.
BOOL | m_bShowNonActiveInPlaceButton
TRUE if use Show Non-Active In-Place Button (Combo, Expand, Spin).
BOOL | m_bPrintWatermark
TRUE to print watermark.
BOOL | m_bUseGroupRowSelectionState
TRUE if use GroupSelectionState Glyph.
BOOL | m_bForceShowTooltip
TRUE if use show tooltip for any cell width case.
BOOL | m_bCleanTooltip
TRUE if use show tooltip without markup.
BOOL | m_bGrayIfDisable
TRUE is disable draw in gray (standard behavior).
int | m_nRowHeightDefault
The default row height.
BOOL | m_bCompactText
TRUE to ignore Icon for Narrow column to show more text.
BOOL | m_bUseDropMarker
FALSE to not draw drop marked when dragging/dropping, TRUE by default.
BOOL | m_bSortTriangleOffsetFromRight
Offset of sort triangle.
int | m_nTreeColumnLineLength
This is the extra line length to apply to tree column lines if there is no expand button.
int | m_nBaseParentRecordIndent
This is initial number of pixels a parent node will be indented when in a group.
- Protected Member Functions inherited from CXTPTrackPaintManager
- Protected Member Functions inherited from CXTPGridPaintManager
virtual void | DrawTextLine (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nFlag, int &nCharCounter, int &nHyperlinkCounter)
Draws a line of text with respect to the drawing rectangle.
virtual int | DrawString (int *pnCurrDrawPos, CDC *pDC, const CString &strDraw, CRect rcDraw, UINT nFormat)
Draw a simple string into rectangle.
virtual void | DrawGridPattern (CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush)
Generates a custom grid pattern if necessary.
virtual void | DrawGridPattern (CDC *pDC, CXTPBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush)
Generates a custom grid pattern if necessary.
virtual void | DrawGridPattern (CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr)
Generates a custom grid pattern.
virtual void | DrawInplaceButtonFrame (CDC *pDC, CXTPGridInplaceButton *pButton)
Draws the in-place button frame.
virtual BOOL | DrawInplaceButtonIcon (CDC *pDC, CXTPGridInplaceButton *pButton)
Draws the in-place button icon.
virtual int | CalcColumnHeight (CDC *pDC, CXTPGridColumn *pColumn, int nTotalWidth=0)
Calculates the optimal height for a specified column.
virtual void | DrawMultiLineText (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, BOOL bWordBreak=TRUE)
Draws multi-line text.
virtual void | DrawSingleLineText (XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nStartPos, int nEndPos, int nActualWidth)
Draws single-line text.
virtual int | DrawLink (int *pnCurrDrawPos, XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CXTPGridHyperlink *pHyperlink, CString strText, CRect rcLink, int nFlag, BOOL bTrim=FALSE)
Draws a hyperlink string using hyperlink text settings (i.e.
- Protected Attributes inherited from CXTPGridPaintManager
int | m_nRowHeight
Grid row default height.
int | m_nHeaderHeight
Column header height.
int | m_nFooterHeight
Column footer height.
int | m_nGroupGridLineHeight
The height of the group grid line.
CXTPImageManager * | m_pGlyphs
An additional image list for the Grid control.
BOOL | m_bIsPreviewMode
TRUE to show the item preview, FALSE to hide.
int | m_nResizingWidth
The width of the column resizing marker area.
int | m_nMaxPreviewLines
Restrict maximum lines for preview text.
CSize | m_szGlyph
Glyph size.
CXTPBrush | m_xtpBrushTreeStructure
Brush to draw tree nodes.
CXTPBrush | m_xtpBrushGroupGridLineStyle
Brush to draw group row grid lines.
int | m_nFreezeColsDividerStyle
A set of flags from XTPGridFreezeColsDividerStyle.
BOOL | m_bFixedRowHeight
TRUE if fixed rows used.
BOOL | m_bColumnWidthWYSIWYG
TRUE if columns width WYSIWYG mode used.
BOOL | m_bShowWYSIWYGMarkers
TRUE if in non-print mode header show red page-end markers.
BOOL | m_bLastColumnWidthWYSIWYG
TRUE if last column width WYSIWYG mode used.
BOOL | m_bDrawGridForEmptySpace
TRUE if grid fills the empty space (if any) after the body rows.
BOOL | m_bPrintGroupRowIcon
TRUE if printout draw collapse-expand icon for group row.
BOOL | m_bColumnPlusMinusSign
TRUE if expand/collapse icons are used, FALSE if directional arrows are used.
BOOL | m_bFixedInplaceButtonHeight
TRUE if fixed in-place button height is used.
XTPGridGridStyle | m_nGroupGridLineStyle
Current style for group row grid lines.
XTPGridColumnStyle | m_columnStyle
Column drawing style.
CXTPWinThemeWrapper * | m_themeHeader
Header theme wrapper.
CXTPWinThemeWrapper * | m_themeButton
In-place button theme wrapper.
CXTPWinThemeWrapper * | m_themeCombo
Combo box in-place button theme wrapper.
CXTPWinThemeWrapper * | m_themeSpin
Spin in-place button theme wrapper.
CXTPGridControl * | m_pControl
Pointer to the Grid control object.
CXTPMarkupUIElement * | m_pMarkupUIElement_NoGroupBy
The no group by markup UI element.
CString | m_strMarkupUIElement_NoGroupBy
The no group by markup UI element string.
CXTPBrush | m_xtpBrushVeriticalGrid
Brush to draw vertical grid lines.
CXTPBrush | m_xtpBrushHorizontalGrid
Brush to draw horizontal grid lines.
XTPGridGridStyle m_nGridLineStylePreviousV
Previous style for vertical grid lines.
XTPGridGridStyle m_nGridLineStylePreviousH
Previous style for horizontal grid lines.

Detailed Description

CXTPTrackThemeVisualStudio2022 is a CXTPTrackThemeOffice2013 derived class that represents a Visual Studio 2022 style theme.

The documentation for this class was generated from the following file:
  • XTPTrackThemeVisualStudio2022.h


Toolkit Pro: CXTPTrackUndoAddBlockCommand Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPTrackUndoAddBlockCommand Class Reference

This class abstracts the undo add block command. More...

Inheritance diagram for CXTPTrackUndoAddBlockCommand:
[legend]

Public Member Functions

CXTPTrackUndoAddBlockCommand (CXTPTrackBlock *pBlock)
Constructor, creates a CXTPTrackUndoAddBlockCommand object.
virtual | ~CXTPTrackUndoAddBlockCommand ()
CXTPTrackUndoAddBlockCommand destructor, handles cleanup and deallocation.
- Public Member Functions inherited from CXTPTrackUndoCommand
int | GetID () const
Call this function to get the command ID associated with this object.

Protected Member Functions

virtual void | Undo ()
Call this function to do the undo operation.
- Protected Member Functions inherited from CXTPTrackUndoCommand
CXTPTrackUndoCommand (int nID)
Constructor, creates a CXTPTrackUndoCommand object.
virtual | ~CXTPTrackUndoCommand ()
CXTPTrackUndoCommand destructor, handles cleanup and deallocation.

Protected Attributes

CXTPTrackBlock * | m_pBlock
Pointer to the track block object.
- Protected Attributes inherited from CXTPTrackUndoCommand
const int | m_nID
The command ID.

Detailed Description

This class abstracts the undo add block command.

This is a kind of CXTPTrackUndoCommand.

Constructor & Destructor Documentation

◆ CXTPTrackUndoAddBlockCommand()

CXTPTrackUndoAddBlockCommand ( CXTPTrackBlock * pBlock )

Constructor, creates a CXTPTrackUndoAddBlockCommand object.

Parameters
pBlock Pointer to the track block object.

Member Function Documentation

◆ Undo()

virtual void Undo ( )
protectedvirtual

Call this function to do the undo operation.

This is a virtual function so derived classes can provide their specific implementations.

Reimplemented from CXTPTrackUndoCommand.

The documentation for this class was generated from the following file:
  • XTPTrackUndoManager.h


Toolkit Pro: CXTPTrackUndoAddMarkerCommand Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPTrackUndoAddMarkerCommand Class Reference

This class abstracts the undo add marker command. More...

Inheritance diagram for CXTPTrackUndoAddMarkerCommand:
[legend]

Public Member Functions

CXTPTrackUndoAddMarkerCommand (CXTPTrackMarker *pMarker)
Constructor, creates a CXTPTrackUndoDeleteMarkerCommand object.
virtual | ~CXTPTrackUndoAddMarkerCommand ()
CXTPTrackUndoAddMarkerCommand destructor, handles cleanup and deallocation.
- Public Member Functions inherited from CXTPTrackUndoCommand
int | GetID () const
Call this function to get the command ID associated with this object.

Protected Member Functions

virtual void | Undo ()
Call this function to do the undo operation.
- Protected Member Functions inherited from CXTPTrackUndoCommand
CXTPTrackUndoCommand (int nID)
Constructor, creates a CXTPTrackUndoCommand object.
virtual | ~CXTPTrackUndoCommand ()
CXTPTrackUndoCommand destructor, handles cleanup and deallocation.

Protected Attributes

CXTPTrackMarker * | m_pMarker
The track marker object.
- Protected Attributes inherited from CXTPTrackUndoCommand
const int | m_nID
The command ID.

Detailed Description

This class abstracts the undo add marker command.

This is a kind of CXTPTrackUndoCommand.

Constructor & Destructor Documentation

◆ CXTPTrackUndoAddMarkerCommand()

CXTPTrackUndoAddMarkerCommand ( CXTPTrackMarker * pMarker )

Constructor, creates a CXTPTrackUndoDeleteMarkerCommand object.

Parameters
pMarker Pointer to the track marker object.

Member Function Documentation

◆ Undo()

virtual void Undo ( )
protectedvirtual

Call this function to do the undo operation.

This is a virtual function so derived classes can provide their specific implementations.

Reimplemented from CXTPTrackUndoCommand.

The documentation for this class was generated from the following file:
  • XTPTrackUndoManager.h


Toolkit Pro: CXTPTrackUndoCommand Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPTrackUndoCommand Class Reference

This class abstracts the undo command. More...

Inheritance diagram for CXTPTrackUndoCommand:
[legend]

Public Member Functions

int GetID () const
Call this function to get the command ID associated with this object.

Protected Member Functions

CXTPTrackUndoCommand (int nID)
Constructor, creates a CXTPTrackUndoCommand object.
virtual | ~CXTPTrackUndoCommand ()
CXTPTrackUndoCommand destructor, handles cleanup and deallocation.
virtual void | Undo ()
Call this function to do the undo operation.

Protected Attributes

const int m_nID
The command ID.

Detailed Description

This class abstracts the undo command.

Constructor & Destructor Documentation

◆ CXTPTrackUndoCommand()

CXTPTrackUndoCommand ( int nID )
protected

Constructor, creates a CXTPTrackUndoCommand object.

Parameters
nID The command ID.

Member Function Documentation

◆ GetID()

AFX_INLINE int GetID ( ) const

Call this function to get the command ID associated with this object.

Returns
The command ID associated with this object.

◆ Undo()

virtual void Undo ( )
protectedvirtual

Call this function to do the undo operation.

This is a virtual function so derived classes can provide their specific implementations.

Reimplemented in CXTPTrackUndoAddBlockCommand, CXTPTrackUndoAddMarkerCommand, CXTPTrackUndoDeleteBlockCommand, CXTPTrackUndoDeleteMarkerCommand, CXTPTrackUndoGroupCommand, CXTPTrackUndoSetBlockPositionCommand, and CXTPTrackUndoSetMarkerPositionCommand.

The documentation for this class was generated from the following file:
  • XTPTrackUndoManager.h


Toolkit Pro: CXTPTrackUndoDeleteBlockCommand Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPTrackUndoDeleteBlockCommand Class Reference

This class abstracts the undo delete block command. More...

Inheritance diagram for CXTPTrackUndoDeleteBlockCommand:
[legend]

Public Member Functions

CXTPTrackUndoDeleteBlockCommand (CXTPTrackBlock *pBlock)
Constructor, creates a CXTPTrackUndoDeleteBlockCommand object.
virtual | ~CXTPTrackUndoDeleteBlockCommand ()
CXTPTrackUndoDeleteBlockCommand destructor, handles cleanup and deallocation.
- Public Member Functions inherited from CXTPTrackUndoCommand
int | GetID () const
Call this function to get the command ID associated with this object.

Protected Member Functions

virtual void | Undo ()
Call this function to do the undo operation.
- Protected Member Functions inherited from CXTPTrackUndoCommand
CXTPTrackUndoCommand (int nID)
Constructor, creates a CXTPTrackUndoCommand object.
virtual | ~CXTPTrackUndoCommand ()
CXTPTrackUndoCommand destructor, handles cleanup and deallocation.

Protected Attributes

CXTPTrackBlock * | m_pBlock
The track block object.
CXTPTrackControlItem * | m_pOldItem
The old track control item.
- Protected Attributes inherited from CXTPTrackUndoCommand
const int | m_nID
The command ID.

Detailed Description

This class abstracts the undo delete block command.

This is a kind of CXTPTrackUndoCommand.

Constructor & Destructor Documentation

◆ CXTPTrackUndoDeleteBlockCommand()

CXTPTrackUndoDeleteBlockCommand ( CXTPTrackBlock * pBlock )

Constructor, creates a CXTPTrackUndoDeleteBlockCommand object.

Parameters
pBlock Pointer to the track block object.

Member Function Documentation

◆ Undo()

virtual void Undo ( )
protectedvirtual

Call this function to do the undo operation.

This is a virtual function so derived classes can provide their specific implementations.

Reimplemented from CXTPTrackUndoCommand.

The documentation for this class was generated from the following file:
  • XTPTrackUndoManager.h


Toolkit Pro: CXTPTrackUndoDeleteMarkerCommand Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPTrackUndoDeleteMarkerCommand Class Reference

This class abstracts the undo delete marker command. More...

Inheritance diagram for CXTPTrackUndoDeleteMarkerCommand:
[legend]

Public Member Functions

CXTPTrackUndoDeleteMarkerCommand (CXTPTrackMarker *pMarker)
Constructor, creates a CXTPTrackUndoDeleteMarkerCommand object.
virtual | ~CXTPTrackUndoDeleteMarkerCommand ()
CXTPTrackUndoDeleteMarkerCommand destructor, handles cleanup and deallocation.
- Public Member Functions inherited from CXTPTrackUndoCommand
int | GetID () const
Call this function to get the command ID associated with this object.

Protected Member Functions

virtual void | Undo ()
Call this function to do the undo operation.
- Protected Member Functions inherited from CXTPTrackUndoCommand
CXTPTrackUndoCommand (int nID)
Constructor, creates a CXTPTrackUndoCommand object.
virtual | ~CXTPTrackUndoCommand ()
CXTPTrackUndoCommand destructor, handles cleanup and deallocation.

Protected Attributes

CXTPTrackMarker * | m_pMarker
The track marker object.
- Protected Attributes inherited from CXTPTrackUndoCommand
const int | m_nID
The command ID.

Detailed Description

This class abstracts the undo delete marker command.

This is a kind of CXTPTrackUndoCommand.

Constructor & Destructor Documentation

◆ CXTPTrackUndoDeleteMarkerCommand()

CXTPTrackUndoDeleteMarkerCommand ( CXTPTrackMarker * pMarker )

Constructor, creates a CXTPTrackUndoDeleteMarkerCommand object.

Parameters
pMarker Pointer to the track marker object.

Member Function Documentation

◆ Undo()

virtual void Undo ( )
protectedvirtual

Call this function to do the undo operation.

This is a virtual function so derived classes can provide their specific implementations.

Reimplemented from CXTPTrackUndoCommand.

The documentation for this class was generated from the following file:
  • XTPTrackUndoManager.h


Toolkit Pro: CXTPTrackUndoGroupCommand Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPTrackUndoGroupCommand Class Reference

This class abstracts the undo commands in a group. More...

Inheritance diagram for CXTPTrackUndoGroupCommand:
[legend]

Public Member Functions

virtual void | Undo ()
Call this function to do the undo operation.
int | GetCount () const
Call this function to get the number of command objects in this group.
void | Add (CXTPTrackUndoCommand *pCommand)
Call this function to add a command to the command group.
- Public Member Functions inherited from CXTPTrackUndoCommand
int | GetID () const
Call this function to get the command ID associated with this object.

Protected Member Functions

CXTPTrackUndoGroupCommand (CXTPTrackUndoManager *pManager)
Constructor, creates a CXTPTrackUndoCommand object.
virtual | ~CXTPTrackUndoGroupCommand ()
CXTPTrackUndoGroupCommand destructor, handles cleanup and deallocation.
- Protected Member Functions inherited from CXTPTrackUndoCommand
CXTPTrackUndoCommand (int nID)
Constructor, creates a CXTPTrackUndoCommand object.
virtual | ~CXTPTrackUndoCommand ()
CXTPTrackUndoCommand destructor, handles cleanup and deallocation.

Protected Attributes

CArray< CXTPTrackUndoCommand *, CXTPTrackUndoCommand * > | m_arrUndoCommands
The command collection.
CXTPTrackUndoManager * | m_pManager
The undo manager.
- Protected Attributes inherited from CXTPTrackUndoCommand
const int | m_nID
The command ID.

Detailed Description

This class abstracts the undo commands in a group.

Constructor & Destructor Documentation

◆ CXTPTrackUndoGroupCommand()

CXTPTrackUndoGroupCommand ( CXTPTrackUndoManager * pManager )
protected

Constructor, creates a CXTPTrackUndoCommand object.

Parameters
pManager Pointer to the track undo manager.

Member Function Documentation

◆ Add()

void Add ( CXTPTrackUndoCommand * pCommand )

Call this function to add a command to the command group.

Parameters
pCommand Pointer to the undo command object.

◆ GetCount()

int GetCount ( ) const

Call this function to get the number of command objects in this group.

Returns
The number of command objects in this group.

◆ Undo()

virtual void Undo ( )
virtual

Call this function to do the undo operation.

This is a virtual function so derived classes can provide their specific implementations.

Reimplemented from CXTPTrackUndoCommand.

The documentation for this class was generated from the following file:
  • XTPTrackUndoManager.h


Toolkit Pro: CXTPTrackUndoManager Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPTrackUndoManager Class Reference

This class abstracts an undo manager. More...

Inheritance diagram for CXTPTrackUndoManager:
[legend]

Public Member Functions

CXTPTrackUndoManager ()
Constructor, creates a CXTPTrackUndoManager object.
~CXTPTrackUndoManager ()
CXTPTrackUndoManager destructor, handles cleanup and deallocation.
void | Undo ()
Call this function to do the undo operation.
void | Redo ()
Call this function to do the redo operation.
BOOL | CanUndo () const
Determines if the undo operation is possible in the current context.
BOOL | CanRedo () const
Determines if the redo operation is possible in the current context.
void | Clear ()
Call this function to clear the list of undo and redo operations.
void | AddUndoCommand (CXTPTrackUndoCommand *pCommand)
Adds an undo command to the collection of undo commands.
void | StartGroup ()
Call this function to start an undo group command.
void | EndGroup ()
Call this function to end an undo group command.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Attributes

CArray< CXTPTrackUndoCommand *, CXTPTrackUndoCommand * > | m_arrUndoCommands
The undo commands array.
CArray< CXTPTrackUndoCommand *, CXTPTrackUndoCommand * > | m_arrRedoCommands
The redo command array.
int | m_nUndoContext
The undo context.
CXTPTrackUndoGroupCommand * | m_pUndoGroup
The undo group command.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

This class abstracts an undo manager.

It manages all the undo operations of the track control. This is a kind of CXTPCmdTarget.

Member Function Documentation

◆ AddUndoCommand()

void AddUndoCommand ( CXTPTrackUndoCommand * pCommand )

Adds an undo command to the collection of undo commands.

Parameters
pCommand Pointer to the track undo command object.

◆ CanRedo()

BOOL CanRedo ( ) const

Determines if the redo operation is possible in the current context.

Returns
TRUE if the redo operation is possible, otherwise FALSE.

◆ CanUndo()

BOOL CanUndo ( ) const

Determines if the undo operation is possible in the current context.

Returns
TRUE if the undo operation is possible, otherwise FALSE.
The documentation for this class was generated from the following file:
  • XTPTrackUndoManager.h


Toolkit Pro: CXTPTrackUndoSetBlockPositionCommand Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPTrackUndoSetBlockPositionCommand Class Reference

This class abstracts the undo set block position command. More...

Inheritance diagram for CXTPTrackUndoSetBlockPositionCommand:
[legend]

Public Member Functions

CXTPTrackUndoSetBlockPositionCommand (CXTPTrackBlock *pBlock, int nOldPosition, int nOldLength)
Constructor, creates a CXTPTrackUndoSetBlockPositionCommand object.
virtual | ~CXTPTrackUndoSetBlockPositionCommand ()
CXTPTrackUndoSetBlockPositionCommand destructor, handles cleanup and deallocation.
- Public Member Functions inherited from CXTPTrackUndoCommand
int | GetID () const
Call this function to get the command ID associated with this object.

Protected Member Functions

virtual void | Undo ()
Call this function to do the undo operation.
- Protected Member Functions inherited from CXTPTrackUndoCommand
CXTPTrackUndoCommand (int nID)
Constructor, creates a CXTPTrackUndoCommand object.
virtual | ~CXTPTrackUndoCommand ()
CXTPTrackUndoCommand destructor, handles cleanup and deallocation.

Protected Attributes

CXTPTrackBlock * | m_pBlock
Pointer to the track block object.
int | m_nOldPosition
Old position of the block.
int | m_nOldLength
Old length of the block.
- Protected Attributes inherited from CXTPTrackUndoCommand
const int | m_nID
The command ID.

Detailed Description

This class abstracts the undo set block position command.

This is a kind of CXTPTrackUndoCommand.

Constructor & Destructor Documentation

◆ CXTPTrackUndoSetBlockPositionCommand()

CXTPTrackUndoSetBlockPositionCommand | ( | CXTPTrackBlock * | pBlock,
 |  | int | nOldPosition,
 |  | int | nOldLength )

Constructor, creates a CXTPTrackUndoSetBlockPositionCommand object.

Parameters
pBlock | Pointer to the track block object.
nOldPosition | Old position of the block.
nOldLength | Old length of the block.

Member Function Documentation

◆ Undo()

virtual void Undo ( )
protectedvirtual

Call this function to do the undo operation.

This is a virtual function so derived classes can provide their specific implementations.

Reimplemented from CXTPTrackUndoCommand.

The documentation for this class was generated from the following file:
  • XTPTrackUndoManager.h


Toolkit Pro: CXTPTrackUndoSetMarkerPositionCommand Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPTrackUndoSetMarkerPositionCommand Class Reference

This class abstracts the undo set marker position command. More...

Inheritance diagram for CXTPTrackUndoSetMarkerPositionCommand:
[legend]

Public Member Functions

CXTPTrackUndoSetMarkerPositionCommand (CXTPTrackMarker *pMarker, int nOldPosition)
Constructor, creates a CXTPTrackUndoSetMarkerPositionCommand object.
virtual | ~CXTPTrackUndoSetMarkerPositionCommand ()
CXTPTrackUndoSetMarkerPositionCommand destructor, handles cleanup and deallocation.
- Public Member Functions inherited from CXTPTrackUndoCommand
int | GetID () const
Call this function to get the command ID associated with this object.

Protected Member Functions

virtual void | Undo ()
Call this function to do the undo operation.
- Protected Member Functions inherited from CXTPTrackUndoCommand
CXTPTrackUndoCommand (int nID)
Constructor, creates a CXTPTrackUndoCommand object.
virtual | ~CXTPTrackUndoCommand ()
CXTPTrackUndoCommand destructor, handles cleanup and deallocation.

Protected Attributes

CXTPTrackMarker * | m_pMarker
The track marker object.
int | m_nOldPosition
Old position of the marker.
- Protected Attributes inherited from CXTPTrackUndoCommand
const int | m_nID
The command ID.

Detailed Description

This class abstracts the undo set marker position command.

This is a kind of CXTPTrackUndoCommand.

Constructor & Destructor Documentation

◆ CXTPTrackUndoSetMarkerPositionCommand()

CXTPTrackUndoSetMarkerPositionCommand | ( | CXTPTrackMarker * | pMarker,
 |  | int | nOldPosition )

Constructor, creates a CXTPTrackUndoSetMarkerPositionCommand object.

Parameters
pMarker | Pointer to the track marker object.
nOldPosition | Old position of the marker.

Member Function Documentation

◆ Undo()

virtual void Undo ( )
protectedvirtual

Call this function to do the undo operation.

This is a virtual function so derived classes can provide their specific implementations.

Reimplemented from CXTPTrackUndoCommand.

The documentation for this class was generated from the following file:
  • XTPTrackUndoManager.h


Toolkit Pro: CXTPTransparentBitmap Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPTransparentBitmap Class Reference

CXTPTransparentBitmap is a helper class used to extract the transparent color from a transparent BitMap. More...

Public Member Functions

CXTPTransparentBitmap (HBITMAP hBitmap)
Constructor.
COLORREF | GetTransparentColor () const
Call this function to get the transparent color of the BitMap.
HICON | ConvertToIcon () const
Call this function to create an icon based on the BitMap.

Protected Attributes

HBITMAP m_hBitmap
A handle to a BtiMap.

Detailed Description

CXTPTransparentBitmap is a helper class used to extract the transparent color from a transparent BitMap.

Also, this class is used to convert a transparent BitMap into a transparent icon.

Constructor & Destructor Documentation

◆ CXTPTransparentBitmap()

CXTPTransparentBitmap ( HBITMAP hBitmap )

Constructor.

Construct a new CXTPTransparentBitmap from a handle to an existing BitMap.

Parameters
hBitmap Handle to an existing BitMap.

Member Function Documentation

◆ ConvertToIcon()

HICON ConvertToIcon ( ) const

Call this function to create an icon based on the BitMap.

Returns
NULL if the BitMap is NULL. NULL if the width or height of the BitMap is 0. Otherwise, a handle to the icon created from the BitMap.

◆ GetTransparentColor()

COLORREF GetTransparentColor ( ) const

Call this function to get the transparent color of the BitMap.

Returns
-1 if the BitMap is NULL. Otherwise, a COLORREF that contains the transparent color of the BitMap.
The documentation for this class was generated from the following file:
  • XTPDrawHelpers.h


Toolkit Pro: CXTPTrayIcon Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPTrayIcon Class Reference

CXTPTrayIcon is a CWnd derived class of the NOTIFYICONDATA structure. More...

Public Member Functions

CXTPTrayIcon ()
Constructs a CXTPTrayIcon object.
virtual | ~CXTPTrayIcon ()
Destroys a CXTPTrayIcon object, handles cleanup and deallocation.
BOOL | IsShellVersion5 () const
Determines if shell32.dll has Major version 5 or above.
virtual bool | Create (LPCTSTR lpszCaption, CWnd *pParentWnd, UINT nIconID, UINT uMenuID=0, UINT uDefMenuItemID=0, bool bDefMenuItemByPos=false)
This member function will create the system tray icon.
bool | ShowBalloonTip (LPCTSTR lpszInfo=NULL, LPCTSTR lpszInfoTitle=NULL, DWORD dwInfoFlags=NIIF_NONE, UINT uTimeout=10, HICON hBaloonIcon=NULL)
Call this member function to display a balloon tooltip for the system tray icon.
virtual void | StopAnimation ()
This member function will stop the tray icon animation timer.
virtual void | StartAnimation (UINT uElapse=500)
This member function will start the tray icon animation timer.
virtual void | SetAnimationIcons (const UINT *lpIDArray, const CString *lpStrTipArray, int nIDCount)
This member function will set the icons used for animated system tray icons.
virtual bool | SetAnimationIcons (const UINT *lpIDArray, int nIDCount, const CString *lpStrTipArray=NULL)
This member function will set the icons used for animated system tray icons.
bool | SetTooltipText (UINT nTipText)
Call this member function to set the tooltip text for the tray icon.
bool | SetTooltipText (LPCTSTR lpszTipText)
Call this member function to set the tooltip text for the tray icon.
CString | GetTooltipText () const
Call this member function to retrieve the tooltip text that is displayed by the tray icon.
void | SetDefaultValues ()
This member function is called to reset the tray icon control settings to their default value.
bool | SetCallbackMessage (UINT uNewCallbackMessage)
This member function will set the callback message to be used by the tray icon.
UINT | GetCallbackMessage ()
This member function will retrieve the notification message ID used by the tray icon.
bool | SetDefaultMenuItem (UINT uItem, bool bByPos)
This member function will set the default menu item for the tray icon's pop-up menu if the tray icon handles notification messages.
void | GetDefaultMenuItem (UINT &uItem, bool &bByPos)
Call this member function to retrieve the item ID and position flag for the tray icon.
bool | SetNotificationWnd (CWnd *pWndNotify)
Call this member function to set the window that is to receive notification messages from the tray icon.
CWnd * | GetNotificationWnd ()
Call this member function to retrieve a pointer to the window that receives notification messages from the tray icon.
bool | SetIcon (HICON hIcon)
Call this member function to set the icon that is displayed in the system tray.
bool | SetIcon (LPCTSTR lpszIconName)
Call this member function to set the icon that is displayed in the system tray.
bool | SetIcon (UINT nIDResource)
Call this member function to set the icon that is displayed in the system tray.
HICON | GetIcon () const
Call this member function to retrieve a handle to the icon displayed in the system tray.
bool | AddIcon ()
Call this member function to add the icon to the system tray.
bool | RemoveIcon ()
Call this member function to remove the icon from the system tray.
bool | HideIcon ()
Call this member function to hide the system tray icon in Windows 2000 or greater.
bool | ShowIcon ()
Call this member function to show the system tray icon in Windows 2000 or greater.
BOOL | ShowIcon (BOOL bShow)
Call this member function to show the system tray icon in Windows 2000 or greater.
void | MinimizeToTray (CWnd *pWnd)
Call this member function to minimize the specified window to the system tray.
void | MaximizeFromTray (CWnd *pWnd)
Call this member function to maximize the specified window from the system tray.
BOOL | ShellNotify (DWORD dwMessage)
Sends a message to the taskbar's status area.
virtual void | InstallIconPending ()
Adds an icon to the system tray.
virtual bool | CreateMinimizeWnd (CWnd *pWndApp)
Creates the tray icon's min/max window.
virtual void | RemoveAnimationIcons ()
Clears the animated icon array.
virtual void | SetTooltip (LPCTSTR strToolTip)
Sets the tooltip for the CXTPTrayIcon object.
virtual void | SetTrayIcon (UINT nIcon, DWORD dwMessage=NIM_ADD)
Sets the icon for the CXTPTrayIcon object.
virtual void | KillTimer ()
Stops the animation timer.
virtual void | SetTimer (UINT nIDEvent, UINT uElapse)
Sets the animation timer.

Protected Attributes

UINT | m_uFlags
Style settings for icon restore.
UINT | m_nIconID
Resource ID for the default icon.
UINT | m_nIDEvent
Timer event ID.
UINT | m_nCounter
Holds the current position in the timer loop.
UINT | m_uDefMenuItemID
Default pop-up menu item ID.
bool | m_bDefMenuItemByPos
Determines if the default menu item is a command or index.
bool | m_bHidden
State of the icon.
bool | m_bRemoved
true if the icon has been removed from the system tray.
bool | m_bShowPending
true if the icon display is pending.
HWND | m_hWndNotify
Handle to the window that receives command notifications.
CWnd | m_wndMinimize
Hidden window used during minimize and restore functions.
size_t | m_iMaxTipSize
Maximum size for a tooltip string.
CString | m_strToolTip
Tooltip for the default icon.
CXTPIconHandle | m_hIcon
Default icon.
CTrayIconList | m_arTrayIcons
Array of icons and text that are displayed during animation.
NOTIFYICONDATAEX | m_niData
Tray icon structure.

Detailed Description

CXTPTrayIcon is a CWnd derived class of the NOTIFYICONDATA structure.

It is used to display a system tray icon with an animation.

Member Function Documentation

◆ AddIcon()

bool AddIcon ( )

Call this member function to add the icon to the system tray.

Returns
true if successful, otherwise false.

◆ Create()

virtual bool Create | ( | LPCTSTR | lpszCaption,
 |  | CWnd * | pParentWnd,
 |  | UINT | nIconID,
 |  | UINT | uMenuID = 0,
 |  | UINT | uDefMenuItemID = 0,
 |  | bool | bDefMenuItemByPos = false )
 virtual

This member function will create the system tray icon.

Parameters
lpszCaption | A NULL-terminated string that contains the tooltip text displayed when the cursor is over the tray icon.
pParentWnd | Pointer to the window that will receive notification messages associated with an icon in the taskbar status area.
nIconID | Resource ID for the default tray icon.
uMenuID | Pop-up menu resource identifier.
uDefMenuItemID | Command ID that represents the default item for the menu.
bDefMenuItemByPos | true if the default is defined by its position, false if it is defined by its command ID.
Returns
true if successful, otherwise false.

◆ CreateMinimizeWnd()

virtual bool CreateMinimizeWnd ( CWnd * pWndApp )
virtual

Creates the tray icon's min/max window.

Called to create the minimize window used during minimize/maximize operations.

Parameters
pWndApp Pointer to the calling application's main window.
Returns
true if the minimize window was successfully created, otherwise false.

◆ GetCallbackMessage()

UINT GetCallbackMessage ( )

This member function will retrieve the notification message ID used by the tray icon.

Returns
An ID to a notification message.

◆ GetDefaultMenuItem()

void GetDefaultMenuItem | ( | UINT & | uItem,
 |  | bool & | bByPos )

Call this member function to retrieve the item ID and position flag for the tray icon.

Parameters
uItem | Reference to a UINT that is to receive the default menu item ID.
bByPos | Reference to a bool that is to receive the default menu item position flag.

◆ GetIcon()

HICON GetIcon ( ) const

Call this member function to retrieve a handle to the icon displayed in the system tray.

Returns
A handle to the icon displayed in the system tray.

◆ GetNotificationWnd()

CWnd * GetNotificationWnd ( )

Call this member function to retrieve a pointer to the window that receives notification messages from the tray icon.

Returns
A pointer to a valid CWnd object.

◆ GetTooltipText()

CString GetTooltipText ( ) const

Call this member function to retrieve the tooltip text that is displayed by the tray icon.

Returns
A CString object that represents the tooltip text.

◆ HideIcon()

bool HideIcon ( )

Call this member function to hide the system tray icon in Windows 2000 or greater.

Returns
true if successful, otherwise false.

◆ InstallIconPending()

virtual void InstallIconPending ( )
virtual

Adds an icon to the system tray.

This member is called by the CXTPTrayIcon object to initialize the icon display in the system tray. It checks to see if there is a pending request or if the icon is hidden first before attempting to add the icon. You can override this member to provide additional functionality.

◆ IsShellVersion5()

BOOL IsShellVersion5 ( ) const

Determines if shell32.dll has Major version 5 or above.

shell32.dll Major version 5 and above provide extended functionality.

Returns
TRUE if shell32.dll has Major version 5 or above.

◆ KillTimer()

virtual void KillTimer ( )
virtual

Stops the animation timer.

Called by the CXTPTrayIcon object to stop the animation timer event and sets the default icon and tooltip text. You can override this member to provide additional functionality.

◆ MaximizeFromTray()

void MaximizeFromTray ( CWnd * pWnd )

Call this member function to maximize the specified window from the system tray.

If window animation is supported, then the window will glide up from the system tray.

Parameters
pWnd Window to maximize.

◆ MinimizeToTray()

void MinimizeToTray ( CWnd * pWnd )

Call this member function to minimize the specified window to the system tray.

If window animation is supported, then the window will glide down to the system tray.

Parameters
pWnd Window to minimize.

◆ RemoveAnimationIcons()

virtual void RemoveAnimationIcons ( )
virtual

Clears the animated icon array.

Called to clear the animated icon array and free any associated GDI resources.

◆ RemoveIcon()

bool RemoveIcon ( )

Call this member function to remove the icon from the system tray.

Returns
true if successful, otherwise false.

◆ SetAnimationIcons() [1/2]

virtual void SetAnimationIcons | ( | const UINT * | lpIDArray,
 |  | const CString * | lpStrTipArray,
 |  | int | nIDCount )
 virtual

This member function will set the icons used for animated system tray icons.

To use, call SetAnimationIcons and then SetTimer.

Parameters
lpIDArray | [in] An array of resource IDs that represent the icons to display in the caption area.
nIDCount | [in] Zero-based size of the array passed. lpIDArray and lpStrTipArray must contain the same number of items and must match value specified by nIDCount.
lpStrTipArray | [in] An array of tooltips that match the icons passed in as 'lpStrTipArray'. If NULL, the default tooltip will be used.

◆ SetAnimationIcons() [2/2]

virtual bool SetAnimationIcons | ( | const UINT * | lpIDArray,
 |  | int | nIDCount,
 |  | const CString * | lpStrTipArray = NULL )
 virtual

This member function will set the icons used for animated system tray icons.

To use, call SetAnimationIcons and then SetTimer.

Parameters
lpIDArray | [in] An array of resource IDs that represent the icons to display in the caption area.
nIDCount | [in] Zero-based size of the array passed. lpIDArray and lpStrTipArray must contain the same number of items and must match value specified by nIDCount.
lpStrTipArray | [in] An array of tooltips that match the icons passed in as 'lpStrTipArray'. If NULL, the default tooltip will be used.
Returns
true if successful, otherwise false.

◆ SetCallbackMessage()

bool SetCallbackMessage ( UINT uNewCallbackMessage )

This member function will set the callback message to be used by the tray icon.

Parameters
uNewCallbackMessage Notification message ID.
Returns
true if successful, otherwise false.

◆ SetDefaultMenuItem()

bool SetDefaultMenuItem | ( | UINT | uItem,
 |  | bool | bByPos )

This member function will set the default menu item for the tray icon's pop-up menu if the tray icon handles notification messages.

Parameters
uItem | Command identifier or position of the default menu item.
bByPos | true if 'uItem' is the menu item's index, false if it is the menu item's command ID.
Returns
true if successful, otherwise false.

◆ SetIcon() [1/3]

bool SetIcon ( HICON hIcon )

Call this member function to set the icon that is displayed in the system tray.

Parameters
hIcon Handle to the icon to display.
Returns
true if the icon was set, otherwise false.

◆ SetIcon() [2/3]

bool SetIcon ( LPCTSTR lpszIconName )

Call this member function to set the icon that is displayed in the system tray.

Parameters
lpszIconName Resource name of the icon to display.
Returns
true if the icon was set, otherwise false.

◆ SetIcon() [3/3]

bool SetIcon ( UINT nIDResource )

Call this member function to set the icon that is displayed in the system tray.

Parameters
nIDResource Resource identifier of the icon to display.
Returns
true if the icon was set, otherwise false.

◆ SetNotificationWnd()

bool SetNotificationWnd ( CWnd * pWndNotify )

Call this member function to set the window that is to receive notification messages from the tray icon.

Parameters
pWndNotify Pointer to a valid CWnd object.
Returns
true if successful, otherwise false.

◆ SetTimer()

virtual void SetTimer | ( | UINT | nIDEvent,
 |  | UINT | uElapse )
 virtual

Sets the animation timer.

Parameters
nIDEvent | Specifies a nonzero timer identifier.
uElapse | Specifies the time-out value, in milliseconds.

Called by the CXTPTrayIcon object to initialize and start the animation timer. You can override this member to provide additional functionality.

◆ SetTooltip()

virtual void SetTooltip ( LPCTSTR strToolTip )
virtual

Sets the tooltip for the CXTPTrayIcon object.

Parameters
strToolTip A NULL-terminated string that contains the tooltip text displayed when the cursor is over the tray icon.

This member function is called to set the tooltip text for the icon that is displayed in the system tray.

◆ SetTooltipText() [1/2]

bool SetTooltipText ( LPCTSTR lpszTipText )

Call this member function to set the tooltip text for the tray icon.

Parameters
lpszTipText A NULL-terminated string that represents the tooltip text to display for the icon.
Returns
true if successful, otherwise false.

◆ SetTooltipText() [2/2]

bool SetTooltipText ( UINT nTipText )

Call this member function to set the tooltip text for the tray icon.

Parameters
nTipText Windows string resource ID that represents the tooltip text to display for the icon.
Returns
true if successful, otherwise false.

◆ SetTrayIcon()

virtual void SetTrayIcon | ( | UINT | nIcon,
 |  | DWORD | dwMessage = NIM_ADD )
 virtual

Sets the icon for the CXTPTrayIcon object.

Parameters
nIcon | Resource ID of the new icon to set.
dwMessage | Message to be sent. See ShellNotify for more details.

This member function is called to set a new icon to be displayed for the CXTPTrayIcon object.

◆ ShellNotify()

BOOL ShellNotify ( DWORD dwMessage )

Sends a message to the taskbar's status area.

Parameters
dwMessage [in] Variable of type DWORD that specifies the action to be taken. See remarks section for a list of values.

dwMessage can have one of the following values:

NIM_ADD: Adds an icon to the status area. The hWnd and uID members of the NOTIFYICONDATA structure pointed to by lpdata will be used to identify the icon in later calls to Shell_NotifyIcon. NIM_DELETE: Deletes an icon from the status area. Use the hWnd and uID members of the NOTIFYICONDATA structure pointed to by lpdata to identify the icon to be deleted. NIM_MODIFY: Modifies an icon in the status area. Use the hWnd and uID members of the NOTIFYICONDATA structure pointed to by lpdata to identify the icon to be modified. NIM_SETFOCUS: Version 5.0. Returns focus to the taskbar notification area. Taskbar icons should use this message when they have completed their user interface operation. For example, if the taskbar icon displays a shortcut menu, but the user presses ESCAPE to cancel it, use NIM_SETFOCUS to return focus to the taskbar notification area. NIM_SETVERSION: Version 5.0. Instructs the taskbar to behave according to the version number specified in the uVersion member of the structure pointed to by lpdata. This message allows you to specify whether you want the version 5.0 behavior found on Microsoft(r) Windows(r) 2000 systems, or that found with earlier Shell versions. The default value for uVersion is zero, indicating that the original Windows 95 notify icon behavior should be used. For details, see the Remarks section. The taskbar notification area is sometimes erroneously called the "tray."

Version 5.0 of the Shell, found on Windows 2000, handles Shell_NotifyIcon mouse and keyboard events differently than earlier Shell versions found on Windows NT(r) 4.0, Windows 95, and Windows 98. The differences are:

If a user selects a notify icon's shortcut menu with the keyboard, the version 5.0 Shell sends the associated application a WM_CONTEXTMENU message. Earlier versions send WM_RBUTTONDOWN and WM_RBUTTONUP messages.

If a user selects a notify icon with the keyboard and activates it with the space bar or ENTER key, the version 5.0 Shell sends the associated application an NIN_KEYSELECT notification. Earlier versions send WM_RBUTTONDOWN and WM_RBUTTONUP messages.

If a user selects a notify icon with the mouse and activates it with the ENTER key, the version 5.0 Shell sends the associated application an NIN_SELECT notification. Earlier versions send WM_RBUTTONDOWN and WM_RBUTTONUP messages.

If a user passes the mouse pointer over an icon with which a balloon ToolTip is associated, the version 5.0 Shell sends the following messages:

NIN_BALLOONSHOW: Sent when the balloon is shown (balloons are queued). NIN_BALLOONHIDE: Sent when the balloon disappears when the icon is deleted. For example, this message is not sent if the balloon is dismissed because of a timeout or mouse click by the user. NIN_BALLOONTIMEOUT: Sent when the balloon is dismissed because of a timeout. NIN_BALLOONUSERCLICK: Sent when the balloon is dismissed because the user clicked the mouse.

You can select which way the Shell should behave by calling Shell_NotifyIcon with dwMessage set to NIM_SETVERSION. Set the uVersion member of the NOTIFYICONDATA structure to indicate whether you want pre-version 5.0 behavior or version 5.0 and later behavior.

Returns
TRUE if successful, otherwise FALSE. If dwMessage is set to NIM_SETVERSION, then this function returns TRUE if the version was successfully changed, or FALSE if the requested version is not supported.

◆ ShowBalloonTip()

bool ShowBalloonTip | ( | LPCTSTR | lpszInfo = NULL,
 |  | LPCTSTR | lpszInfoTitle = NULL,
 |  | DWORD | dwInfoFlags = NIIF_NONE,
 |  | UINT | uTimeout = 10,
 |  | HICON | hBaloonIcon = NULL )

Call this member function to display a balloon tooltip for the system tray icon.

Must have Windows 2000 or later.

Parameters
lpszInfo | Pointer to a NULL-terminated string with the text for a balloon ToolTip. It can have a maximum of 255 characters.
lpszInfoTitle | Pointer to a NULL-terminated string containing a title for a balloon ToolTip. This title appears in boldface above the text. It can have a maximum of 63 characters.
dwInfoFlags | Flags that can be set to add an icon to a balloon ToolTip. It is placed to the left of the title. If the 'lpszInfoTitle' member is zero-length, then the icon is not shown and can be any of the values listed in the Remarks section.
uTimeout | The timeout value in seconds for a balloon ToolTip. The system enforces minimum and maximum timeout values. 'uTimeout' values that are too large default to the maximum value, and values that are too small default to the minimum value. The system minimum and maximum timeout values are currently set at 10 seconds and 30 seconds, respectively.
hBaloonIcon | Handle to the baloon icon to display.

The icon shown can be any of the following values:

NIIF_ERROR: An error icon. NIIF_INFO: An information icon. NIIF_NONE: No icon. NIIF_WARNING: A warning icon.

Returns
true if successful, otherwise false.

◆ ShowIcon() [1/2]

bool ShowIcon ( )

Call this member function to show the system tray icon in Windows 2000 or greater.

Returns
true if successful, otherwise false.

◆ ShowIcon() [2/2]

BOOL ShowIcon ( BOOL bShow )

Call this member function to show the system tray icon in Windows 2000 or greater.

Parameters
bShow TRUE to show the tray icon, FALSE otherwise.
Returns
TRUE if successful, otherwise FALSE.

◆ StartAnimation()

virtual void StartAnimation ( UINT uElapse = 500 )
virtual

This member function will start the tray icon animation timer.

Parameters
uElapse Specifies the time-out value in milliseconds between frames.

Member Data Documentation

◆ m_bHidden

bool m_bHidden
protected

State of the icon.

true to indicate that the icon is hidden.

◆ m_niData

NOTIFYICONDATAEX m_niData
protected

Tray icon structure.

See NOTIFYICONDATA.

The documentation for this class was generated from the following file:
  • XTPTrayIcon.h


Toolkit Pro: CXTPTreeBase Class Reference

Classes | Public Member Functions | Protected Types | Protected Member Functions | Protected Attributes | List of all members
CXTPTreeBase Class Reference

CXTPTreeBase is a CTreeView derived class. More...

Inheritance diagram for CXTPTreeBase:
[legend]

Classes

struct CLRFONT
CLRFONT structure is used to by the CXTPShellTreeCtrl and CXTPShellTreeView classes to maintain font information for a particular tree item. More...

Public Member Functions

virtual HTREEITEM | GetNextItem (HTREEITEM hItem) const
This member function will retrieve the tree view item that has the specified relationship, indicated by the 'nCode' parameter, to 'hItem'.
virtual HTREEITEM | GetNextItem (HTREEITEM hItem, UINT nCode) const
This member function will retrieve the tree view item that has the specified relationship, indicated by the 'nCode' parameter, to 'hItem'.
virtual HTREEITEM | GetPrevItem (HTREEITEM hItem) const
This member function gets the previous item as if the outline was completely expanded.
virtual HTREEITEM | GetLastItem (HTREEITEM hItem) const
This member function retrieves the last item in the branch.
virtual HTREEITEM | FindItem (LPCTSTR lpszSearch, BOOL bCaseSensitive=FALSE, BOOL bDownDir=TRUE, BOOL bWholeWord=FALSE, HTREEITEM hItem=NULL)
This member function searches the entire tree for an item label that contains the search string.
virtual HTREEITEM | FindItemExact (LPCTSTR lpszSearch, BOOL bCaseSensitive=FALSE, BOOL bDownDir=TRUE, HTREEITEM hItem=NULL)
This member function searches the entire tree for an item label that contains exactly the same text as search string.
virtual HTREEITEM | FindItemInBranch (LPCTSTR lpszSearch, BOOL bCaseSensitive, BOOL bWholeWord, HTREEITEM htiItem)
This member function searches the entire branch specified by 'htiItem' for an item label that contains the search string.
virtual void | SetItemFont (HTREEITEM hItem, LOGFONT &logfont)
This member function sets the font for the reference tree item.
virtual BOOL | GetItemFont (HTREEITEM hItem, LOGFONT *plogfont)
This member function retrieves the current LOGFONT font used by the tree item.
virtual void | SetItemBold (HTREEITEM hItem, BOOL bBold=TRUE)
This member function sets the reference tree item font to bold.
virtual BOOL | GetItemBold (HTREEITEM hItem)
This member function checks whether or not a tree item has a bold font.
virtual void | SetItemColor (HTREEITEM hItem, COLORREF color)
This member function sets the tree item text color.
virtual void | SetItemBackColor (HTREEITEM hItem, COLORREF color)
This member function sets the tree item background color.
virtual COLORREF | GetItemColor (HTREEITEM hItem)
This member function returns the RGB value for the specified tree item text color, or (COLORREF)-1 if the color was not set.
virtual COLORREF | GetItemBackColor (HTREEITEM hItem)
This member function returns the RGB value for the specified tree item background color, or (COLORREF)-1 if the color was not set.
virtual BOOL | EnableMultiSelect (BOOL bMultiSelect=TRUE)
This member function enables/disables multi-selection for the tree control.
virtual HTREEITEM | GetPrevSelectedItem (HTREEITEM hItem) const
This member function retrieves the previously selected tree item in a multi-selection tree control.
virtual HTREEITEM | GetNextSelectedItem (HTREEITEM hItem) const
This member function retrieves the next selected item in a multi-selection tree control.
virtual HTREEITEM | GetFirstSelectedItem () const
This member function retrieves the first selected item in a multi-selection tree control.
virtual UINT | GetSelectedCount () const
This member function retrieves the number of tree items that are selected.
BOOL | SetItemState (HTREEITEM hItem, UINT nState, UINT nStateMask)
This member function is a replacement for the base class function of the same name, to handle TVIS_FOCUSED in a multi-selection tree control.
UINT | GetItemState (HTREEITEM hItem, UINT nStateMask) const
This member function is a replacement for the base class function of the same name, to handle TVIS_FOCUSED in a multi-selection tree control.
BOOL | SelectItem (HTREEITEM hItem)
This member function is a replacement for the base class function of the same name, to handle TVIS_FOCUSED in a multi-select tree control.
HTREEITEM | GetFocusedItem () const
This member function retrieves the handle to the tree item that currently has focus.
BOOL | FocusItem (HTREEITEM hItem)
This member function will set the focus for the tree item specified by 'hItem'.
virtual void | SelectAll (BOOL bSelect=TRUE, HTREEITEM htItem=NULL)
Call this member function to clear, or select, all of the visible items in the tree control.
virtual void | SelectItems (HTREEITEM hItemFrom, HTREEITEM hItemTo, BOOL bOnly=TRUE)
This member function selects items from 'hItemFrom' to 'hItemTo' in a multi-selection tree control.
virtual BOOL | IsSelected (HTREEITEM hItem) const
This member function checks whether or not the specified item is selected.
BOOL | SelectChildren (HTREEITEM hParent, BOOL bSelect=TRUE, BOOL bRecurse=TRUE)
This member function will cause all of the children of the specified tree item to be selected or deselected.
void | GetSelectedList (CTypedPtrList< CPtrList, HTREEITEM > &list) const
This member function will retrieve a reference to the typed pointer array that contains the items selected in the tree control.
BOOL | IsMultiSelect () const
This member function checks to see if the tree control is a multi-selection tree.
BOOL | IsExplorerTheme () const
This member function checks to see if the tree control has Explorer theme applied.
void | SetExplorerTheme (BOOL bSet)
This member function sets the Explorer theme applied (Vista+).
BOOL | SetBandingHit (BOOL bLabel)
This member function sets the banding mode for a multi-selection tree control.
BOOL | IsDefaultItemDrawingEnabled () const
This member function checks if the tree control uses default (system specific) item drawing method.
void | EnableDefaultItemDrawing (BOOL bEnable=TRUE)
Enables/disables default item drawing method.
int | SetIconIndent (int iconIndent)
Sets the indent between the icon/text/expander.
int | GetIconIndent () const
Gets the current indent between the icon/text/expander.

Protected Types

typedef CMap< void *, void *, CLRFONT, CLRFONT & > CColorFontMap
Map for maintaining HTREEITEM to CLRFONT structure relationships.

Protected Member Functions

CXTPTreeBase ()
Protected constructor used by dynamic creation.
virtual | ~CXTPTreeBase ()
Destroys a CXTPTreeBase object, handles cleanup and deallocation.
virtual bool | Init ()
This member function is called by the CXTPTreeBase class to perform initialization when the window is created or sub-classed.
virtual LRESULT | SendNotify (LPNMHDR pNMHDR)
Sends a WM_NOTIFY message to the tree control owner window.
virtual void | SelectAllIgnore (BOOL bSelect, HTREEITEM hIgnore)
Toggles selection for all items in a multi-selection tree control.
virtual BOOL | OnButtonDown (BOOL bLeft, UINT nFlags, CPoint point)
Called when a mouse button click event occurs.
virtual void | DoPreSelection (HTREEITEM hItem, BOOL bLeft, UINT nFlags)
Called during item selection in a multi-selection tree control.
virtual void | DoAction (HTREEITEM hItem, BOOL bLeft, UINT nFlags, CPoint point)
Called during item selection in a multi-selection tree control.
virtual void | DoBanding (UINT nFlags, CPoint point)
Draws a selection rectangle during item selection.
virtual void | UpdateSelectionForRect (LPCRECT pRect, UINT nFlags, CTypedPtrList< CPtrList, HTREEITEM > &list)
Updates tree item selection.
virtual BOOL | IsFindValid (HTREEITEM hti)
Member override to determine if a tree item is valid.
virtual void | DoPaint (CDC &dc, BOOL bInternal=TRUE)
Called to render the tree control.
virtual COLORREF | GetTreeBackColor () const
Retrieves the tree control's background color.
virtual COLORREF | GetTreeTextColor () const
Retrieves the tree control's text color.
virtual CRect | GetItemIconRect (HTREEITEM hItem) const
Computes an item icon rectangle.
virtual CRect | GetItemStateIconRect (HTREEITEM hItem, const CRect &rcIcon) const
Computes an item state icon rectangle.
virtual CRect | GetItemExpanderRect (HTREEITEM hItem, CDC *pDC, const CRect &rcIcon, const CRect &rcStateIcon) const
Computes an item expander rectangle.
void | DrawItem (CDC *pDC, HTREEITEM hItem, const COLORREF crBack)
Custom drawing of an item along with its icon and lines if necessary.
void | DrawDarkThemeExpander (CDC *pDC, COLORREF crBack, CRect rcItem, CRect rcExpander, int nPart, int nState) const
Draws expander with explorer style when using a dark theme.
virtual COLORREF | GetItemBackColor (UINT uState, bool bTreeHasFocus, DWORD dwStyle, COLORREF crBack) const
Retrieves a tree item's background color.
virtual COLORREF | GetItemTextColor (UINT uState, bool bTreeHasFocus, DWORD dwStyle, COLORREF crText) const
Retrieves a tree item's text color.
bool | HasEditLabels () const
Determines if the tree control has edit labels.
virtual HTREEITEM | FindItemImpl (LPCTSTR lpszSearch, BOOL bCaseSensitive=FALSE, BOOL bDownDir=TRUE, BOOL bWholeWord=FALSE, HTREEITEM hItem=NULL, BOOL bExactlySameStr=FALSE)
This member function searches the entire tree for an item label that contains the search string.
virtual BOOL | IsFullRowSelectionEnabled ()
Checks if full row selection is enabled.
BOOL | SetInsertMark (HTREEITEM hItem, BOOL fAfter)
Sets the insertion mark in a tree view control.
COLORREF | GetInsertMarkColor () const
Retrieves the color used to draw the insertion mark for the tree view.
COLORREF | SetInsertMarkColor (COLORREF clrNew)
Sets the color used to draw the insertion mark for the tree view.

Protected Attributes

BOOL | m_bMultiSelect
TRUE for a multi-selection tree control.
BOOL | m_bBandLabel
TRUE to include the label when selecting tree items.
BOOL | m_bExplorerTheme
TRUE if Explorer theme is On for tree control (Windows Vista+)
HTREEITEM | m_hSelect
For shift selection.
HTREEITEM | m_htiEdit
Tree item that is currently edited.
HTREEITEM | m_htiLast
Tree item that last had the mouse over.
CColorFontMap | m_mapColorFont
Maps HTREEITEM handles with CLRFONT structures that contains the color and logfont information for the tree item.
int | m_nTheme
Self tree pointer.
BOOL | m_bDoDefaultItemDrawing
FALSE by default, which means an item will be drawn by the framework.
int | m_iconIndent
Indent between icon/text/expander.
HTREEITEM | m_hInsertMark
Tree item the insertion mark will be placed.
BOOL | m_InsertMarkAfter
Insertion mark is placed before or after.
COLORREF | m_InsertMarkColor
Insertion mark color.

Detailed Description

CXTPTreeBase is a CTreeView derived class.

It extends the CTreeView class to add additional functionality, including tree traversal, searching, color, and settings.

Member Typedef Documentation

◆ CColorFontMap

CMap<void*, void*, CLRFONT, CLRFONT&> CColorFontMap
protected

Map for maintaining HTREEITEM to CLRFONT structure relationships.

CMap definition used by the CXTPTreeBase class to maintain a list of HTREEITEM to CLRFONT structure relationships representing a tree item that has user defined color information.

See also
CXTPTreeBase, CLRFONT

Constructor & Destructor Documentation

◆ CXTPTreeBase()

CXTPTreeBase ( )
protected

Protected constructor used by dynamic creation.

Constructs a CXTPTreeBase object.

Member Function Documentation

◆ DoAction()

virtual void DoAction | ( | HTREEITEM | hItem,
 |  | BOOL | bLeft,
 |  | UINT | nFlags,
 |  | CPoint | point )
 protectedvirtual

Called during item selection in a multi-selection tree control.

Parameters
hItem | Handle to the last item clicked that will receive focus.
bLeft | TRUE if the left mouse button is down.
nFlags | Indicates whether various virtual keys are down. See Remarks section for a list of values.
point | Mouse cursor position.

nFlags can be any combination of the following values:

MK_CONTROL: Set if the CTRL key is down. MK_LBUTTON: Set if the left mouse button is down. MK_MBUTTON: Set if the middle mouse button is down. MK_RBUTTON: Set if the right mouse button is down. MK_SHIFT: Set if the SHIFT key is down.

◆ DoBanding()

virtual void DoBanding | ( | UINT | nFlags,
 |  | CPoint | point )
 protectedvirtual

Draws a selection rectangle during item selection.

Parameters
point | XY location of the mouse cursor.
nFlags | Indicates whether various virtual keys are down. See Remarks section for a list of values.

nFlags can be any combination of the following values:

MK_CONTROL: Set if the CTRL key is down. MK_LBUTTON: Set if the left mouse button is down. MK_MBUTTON: Set if the middle mouse button is down. MK_RBUTTON: Set if the right mouse button is down. MK_SHIFT: Set if the SHIFT key is down.

◆ DoPaint()

virtual void DoPaint | ( | CDC & | dc,
 |  | BOOL | bInternal = TRUE )
 protectedvirtual

Called to render the tree control.

Parameters
dc | Reference to the tree control device context.
bInternal | FALSE to skip extended rendering tasks and to use the tree control's default rendering.

This member is called to render the tree control using user defined fonts and colors. You can override this member to provide additional functionality.

◆ DoPreSelection()

virtual void DoPreSelection | ( | HTREEITEM | hItem,
 |  | BOOL | bLeft,
 |  | UINT | nFlags )
 protectedvirtual

Called during item selection in a multi-selection tree control.

Parameters
hItem | Handle to the last item clicked that will receive focus.
bLeft | TRUE if the left mouse button is down.
nFlags | Indicates whether various virtual keys are down. See Remarks section for a list of values.

nFlags can be any combination of the following values:

MK_CONTROL: Set if the CTRL key is down. MK_LBUTTON: Set if the left mouse button is down. MK_MBUTTON: Set if the middle mouse button is down. MK_RBUTTON: Set if the right mouse button is down. MK_SHIFT: Set if the SHIFT key is down.

◆ DrawDarkThemeExpander()

void DrawDarkThemeExpander | ( | CDC * | pDC,
 |  | COLORREF | crBack,
 |  | CRect | rcItem,
 |  | CRect | rcExpander,
 |  | int | nPart,
 |  | int | nState ) const
 protected

Draws expander with explorer style when using a dark theme.

Parameters
pDC | Pointer to the current device context.
crBack | Item back color.
rcItem | Item rectangle.
rcExpander | Expander rectangle.
nPart | Part number to draw.
nState | State number (of the part) to draw.

◆ DrawItem()

void DrawItem | ( | CDC * | pDC,
 |  | HTREEITEM | hItem,
 |  | const COLORREF | crBack )
 protected

Custom drawing of an item along with its icon and lines if necessary.

Parameters
pDC | Points to a valid device context.
hItem | Item handle for which an expander rectangle must be computed.
crBack | An RGB value representing the background color.

◆ EnableDefaultItemDrawing()

void EnableDefaultItemDrawing ( BOOL bEnable = TRUE )

Enables/disables default item drawing method.

By default, items are drawn by the framework, which means default item drawing is set to TRUE.

Parameters
bEnable TRUE to enable default item drawing method.

◆ EnableMultiSelect()

virtual BOOL EnableMultiSelect ( BOOL bMultiSelect = TRUE )
virtual

This member function enables/disables multi-selection for the tree control.

Parameters
bMultiSelect TRUE to enable multi-selection, FALSE to disable.
Returns
TRUE if successful, otherwise FALSE.

◆ FindItem()

virtual HTREEITEM FindItem | ( | LPCTSTR | lpszSearch,
 |  | BOOL | bCaseSensitive = FALSE,
 |  | BOOL | bDownDir = TRUE,
 |  | BOOL | bWholeWord = FALSE,
 |  | HTREEITEM | hItem = NULL )
 virtual

This member function searches the entire tree for an item label that contains the search string.

Parameters
lpszSearch | String to search for.
bCaseSensitive | TRUE if the search should be case sensitive.
bDownDir | TRUE for down.
bWholeWord | TRUE if the search should match whole words.
hItem | Handle of the tree item to start searching from, NULL to use the currently selected tree item.
Returns
The handle to the item if successful, otherwise NULL.
See also
IsFindValid

◆ FindItemExact()

virtual HTREEITEM FindItemExact | ( | LPCTSTR | lpszSearch,
 |  | BOOL | bCaseSensitive = FALSE,
 |  | BOOL | bDownDir = TRUE,
 |  | HTREEITEM | hItem = NULL )
 virtual

This member function searches the entire tree for an item label that contains exactly the same text as search string.

Parameters
lpszSearch | String to search for.
bCaseSensitive | TRUE if the search should be case sensitive.
bDownDir | TRUE for down.
hItem | Handle of the tree item to start searching from, NULL to use the currently selected tree item.
Returns
The handle to the item if successful, otherwise NULL.
See also
IsFindValid

◆ FindItemImpl()

virtual HTREEITEM FindItemImpl | ( | LPCTSTR | lpszSearch,
 |  | BOOL | bCaseSensitive = FALSE,
 |  | BOOL | bDownDir = TRUE,
 |  | BOOL | bWholeWord = FALSE,
 |  | HTREEITEM | hItem = NULL,
 |  | BOOL | bExactlySameStr = FALSE )
 protectedvirtual

This member function searches the entire tree for an item label that contains the search string.

Parameters
lpszSearch | String to search for.
bCaseSensitive | TRUE if the search should be case sensitive.
bDownDir | TRUE for down.
bWholeWord | TRUE if the search should match whole words.
hItem | Handle of the tree item to start searching from, NULL to use the currently selected tree item.
bExactlySameStr | TRUE if the item label and input search string should have exactly the same text. If this parameter is TRUE, then the value of bWholeWord is not taken into account.
Returns
The handle to the item if successful, otherwise NULL.
See also
IsFindValid

◆ FindItemInBranch()

virtual HTREEITEM FindItemInBranch | ( | LPCTSTR | lpszSearch,
 |  | BOOL | bCaseSensitive,
 |  | BOOL | bWholeWord,
 |  | HTREEITEM | htiItem )
 virtual

This member function searches the entire branch specified by 'htiItem' for an item label that contains the search string.

Parameters
lpszSearch | String to search for.
bCaseSensitive | TRUE if the search should be case sensitive.
bWholeWord | TRUE if the search should match whole words.
htiItem | Handle of the tree item to start searching from, NULL to use the currently selected tree item.
Returns
The handle to the item if successful, otherwise NULL.
See also
IsFindValid

◆ FocusItem()

BOOL FocusItem ( HTREEITEM hItem )

This member function will set the focus for the tree item specified by 'hItem'.

Parameters
hItem Handle of a tree item.
Returns
TRUE if successful, otherwise FALSE.

◆ GetFirstSelectedItem()

virtual HTREEITEM GetFirstSelectedItem ( ) const
virtual

This member function retrieves the first selected item in a multi-selection tree control.

Returns
A handle to the first selected tree item.

◆ GetFocusedItem()

HTREEITEM GetFocusedItem ( ) const

This member function retrieves the handle to the tree item that currently has focus.

Returns
The handle of the item that has focus, otherwise NULL.

◆ GetIconIndent()

int GetIconIndent ( ) const

Gets the current indent between the icon/text/expander.

Returns
The current indent between the icon/text/expander.

◆ GetInsertMarkColor()

COLORREF GetInsertMarkColor ( ) const
protected

Retrieves the color used to draw the insertion mark for the tree view.

Returns
Value that contains the current insertion mark color.

◆ GetItemBackColor() [1/2]

virtual COLORREF GetItemBackColor ( HTREEITEM hItem )
virtual

This member function returns the RGB value for the specified tree item background color, or (COLORREF)-1 if the color was not set.

Parameters
hItem Handle of the reference item.
Returns
The RGB value for the specified tree item background color, or (COLORREF)-1 if the color was not set.

◆ GetItemBackColor() [2/2]

virtual COLORREF GetItemBackColor | ( | UINT | uState,
 |  | bool | bTreeHasFocus,
 |  | DWORD | dwStyle,
 |  | COLORREF | crBack ) const
 protectedvirtual

Retrieves a tree item's background color.

Parameters
uState | Mask indicating which states are to be retrieved. For more information on possible values for nStateMask, see the discussion of the state and stateMask members of the TVITEM structure in the Platform SDK.
bTreeHasFocus | true if the tree item has input focus.
dwStyle | Set of flags specifying the tree item's state.
crBack | Default color to be returned; usually the tree control's background color.

This member function is called to retrieve a tree item's background color. The value retrieved will depend on the tree item's state and TVS_ style.

Returns
An RGB value representing the specified item's background color.
See also
GetTreeBackColor, GetTreeTextColor, GetItemTextColor

◆ GetItemBold()

virtual BOOL GetItemBold ( HTREEITEM hItem )
virtual

This member function checks whether or not a tree item has a bold font.

Parameters
hItem Handle of the reference item.
Returns
TRUE if the tree item has a bold font, otherwise FALSE.

◆ GetItemColor()

virtual COLORREF GetItemColor ( HTREEITEM hItem )
virtual

This member function returns the RGB value for the specified tree item text color, or (COLORREF)-1 if the color was not set.

Parameters
hItem Handle of the reference item.
Returns
The RGB value for the specified tree item text color, or (COLORREF)-1 if the color was not set.

◆ GetItemExpanderRect()

virtual CRect GetItemExpanderRect | ( | HTREEITEM | hItem,
 |  | CDC * | pDC,
 |  | const CRect & | rcIcon,
 |  | const CRect & | rcStateIcon ) const
 protectedvirtual

Computes an item expander rectangle.

Parameters
hItem | Item handle for which an expander rectangle must be computed.
pDC | Points to a valid device context.
rcIcon | Reference to a CRect object representing the size of the icon.
rcStateIcon | Reference to a CRect object representing the size of the state icon.
Returns
Item expander rectangle, or an empty rectangle if the item provided has no expander.

◆ GetItemFont()

virtual BOOL GetItemFont | ( | HTREEITEM | hItem,
 |  | LOGFONT * | plogfont )
 virtual

This member function retrieves the current LOGFONT font used by the tree item.

Parameters
hItem | Handle of the reference item.
plogfont | Pointer to receive LOGFONT information.
Returns
TRUE if successful, otherwise FALSE.

◆ GetItemIconRect()

virtual CRect GetItemIconRect ( HTREEITEM hItem ) const
protectedvirtual

Computes an item icon rectangle.

Parameters
hItem Item handle for which an icon rectangle must be computed.
Returns
Item icon rectangle, or an empty rectangle if the item provided has no icon.

◆ GetItemState()

UINT GetItemState | ( | HTREEITEM | hItem,
 |  | UINT | nStateMask ) const

This member function is a replacement for the base class function of the same name, to handle TVIS_FOCUSED in a multi-selection tree control.

Parameters
hItem | Handle of the item whose state is to be retrieved.
nStateMask | Mask indicating which states are to be retrieved. For more information on possible values for 'nStateMask', see the discussion of the 'state' and 'stateMask' members of the TVITEM structure in the Platform SDK.
Returns
The state of the item specified by 'hItem'.

◆ GetItemStateIconRect()

virtual CRect GetItemStateIconRect | ( | HTREEITEM | hItem,
 |  | const CRect & | rcIcon ) const
 protectedvirtual

Computes an item state icon rectangle.

Parameters
hItem | Item handle for which the state icon rectangle must be computed.
rcIcon | Reference to a CRect object representing the size of the icon.
Returns
Item state icon rectangle, or an empty rectangle if the item provided has no state icon.

◆ GetItemTextColor()

virtual COLORREF GetItemTextColor | ( | UINT | uState,
 |  | bool | bTreeHasFocus,
 |  | DWORD | dwStyle,
 |  | COLORREF | crText ) const
 protectedvirtual

Retrieves a tree item's text color.

Parameters
uState | Mask indicating which states are to be retrieved. For more information on possible values for nStateMask, see the discussion of the state and stateMask members of the TVITEM structure in the Platform SDK.
bTreeHasFocus | true if the tree item has input focus.
dwStyle | Set of flags specifying the tree item's state.
crText | Default color to be returned; usually the tree control's text color.

This member function is called to retrieve a tree item's text color. The value retrieved will depend on the tree item's state and TVS_ style.

Returns
An RGB value representing the specified item's text color.
See also
GetTreeBackColor, GetTreeTextColor, GetItemBackColor

◆ GetLastItem()

virtual HTREEITEM GetLastItem ( HTREEITEM hItem ) const
virtual

This member function retrieves the last item in the branch.

Parameters
hItem Node identifying the branch. NULL will return the last item in the outline.
Returns
The handle of the last item.

◆ GetNextItem() [1/2]

virtual HTREEITEM GetNextItem ( HTREEITEM hItem ) const
virtual

This member function will retrieve the tree view item that has the specified relationship, indicated by the 'nCode' parameter, to 'hItem'.

Parameters
hItem Handle of a tree item.
Returns
The handle of the next item if successful, otherwise NULL.

◆ GetNextItem() [2/2]

virtual HTREEITEM GetNextItem | ( | HTREEITEM | hItem,
 |  | UINT | nCode ) const
 virtual

This member function will retrieve the tree view item that has the specified relationship, indicated by the 'nCode' parameter, to 'hItem'.

Parameters
hItem | Handle of a tree item.
nCode | A flag indicating the type of relation to 'hItem'. This flag can be one of the values listed in the Details section.

nCode can be one of the following values: TVGN_CARET: Retrieves the currently selected item. TVGN_CHILD: Retrieves the first child item. The 'hItem' parameter must be NULL. TVGN_DROPHIGHLIGHT: Retrieves the item that is the target of a drag-and-drop operation. TVGN_FIRSTVISIBLE: Retrieves the first visible item. TVGN_NEXT: Retrieves the next sibling item. TVGN_NEXTVISIBLE: Retrieves the next visible item that follows the specified item. TVGN_PARENT: Retrieves the parent of the specified item. TVGN_PREVIOUS: Retrieves the previous sibling item. TVGN_PREVIOUSVISIBLE: Retrieves the first visible item that precedes the specified item. TVGN_ROOT: Retrieves the first child item of the root item of which the specified item is a part. The non-nCode version gets the next item as if the outline was completely expanded.

Returns
The handle of the next item if successful, otherwise NULL.

◆ GetNextSelectedItem()

virtual HTREEITEM GetNextSelectedItem ( HTREEITEM hItem ) const
virtual

This member function retrieves the next selected item in a multi-selection tree control.

Parameters
hItem Handle of the reference item.
Returns
A handle to the next selected tree item.

◆ GetPrevItem()

virtual HTREEITEM GetPrevItem ( HTREEITEM hItem ) const
virtual

This member function gets the previous item as if the outline was completely expanded.

Parameters
hItem Handle of the reference item.
Returns
The handle of the item immediately above the reference item.

◆ GetPrevSelectedItem()

virtual HTREEITEM GetPrevSelectedItem ( HTREEITEM hItem ) const
virtual

This member function retrieves the previously selected tree item in a multi-selection tree control.

Parameters
hItem Handle of the reference item.
Returns
A handle to the previously selected tree item.

◆ GetSelectedCount()

virtual UINT GetSelectedCount ( ) const
virtual

This member function retrieves the number of tree items that are selected.

Returns
A UINT value that represents the number of tree items selected.

◆ GetSelectedList()

void GetSelectedList ( CTypedPtrList< CPtrList, HTREEITEM > & list ) const

This member function will retrieve a reference to the typed pointer array that contains the items selected in the tree control.

Parameters
list Reference to a CTypedPtrList<CPtrList, HTREEITEM> object.

◆ GetTreeBackColor()

virtual COLORREF GetTreeBackColor ( ) const
protectedvirtual

Retrieves the tree control's background color.

Returns
An RGB value representing the tree control's background color.
See also
CTreeCtrl::SetBkColor, CTreeCtrl::GetBkColor, GetTreeTextColor, GetItemBackColor, GetItemTextColor

◆ GetTreeTextColor()

virtual COLORREF GetTreeTextColor ( ) const
protectedvirtual

Retrieves the tree control's text color.

Returns
An RGB value representing the tree control's text color.
See also
CTreeCtrl::SetTextColor, CTreeCtrl::GetTextColor, GetTreeBackColor, GetItemBackColor, GetItemTextColor

◆ HasEditLabels()

bool HasEditLabels ( ) const
protected

Determines if the tree control has edit labels.

Returns
true if the TVS_EDITLABELS style is set for the tree control, otherwise false.

◆ Init()

virtual bool Init ( )
protectedvirtual

This member function is called by the CXTPTreeBase class to perform initialization when the window is created or sub-classed.

Returns
TRUE if the window was successfully initialized, otherwise FALSE.

◆ IsDefaultItemDrawingEnabled()

BOOL IsDefaultItemDrawingEnabled ( ) const

This member function checks if the tree control uses default (system specific) item drawing method.

Returns
TRUE if the tree control uses default item drawing method, FALSE if items are drawn by the framework.

◆ IsExplorerTheme()

BOOL IsExplorerTheme ( ) const

This member function checks to see if the tree control has Explorer theme applied.

Returns
TRUE if the tree control has Explorer theme applied (Vista+).

◆ IsFindValid()

virtual BOOL IsFindValid ( HTREEITEM hti )
protectedvirtual

Member override to determine if a tree item is valid.

Parameters
hti Handle to the tree item that was found when FindItem or FindItemInBranch has been called.

Override this member function to determine if the tree item specified by hti is valid. If IsFindValid returns FALSE, then the calling functions FindItem and FindItemInBranch will return NULL.

Returns
TRUE in the base class. Derived classes must return TRUE to indicate success or FALSE to indicate failure.

◆ IsFullRowSelectionEnabled()

virtual BOOL IsFullRowSelectionEnabled ( )
protectedvirtual

Checks if full row selection is enabled.

Returns
TRUE if full row selection is enabled.

◆ IsMultiSelect()

BOOL IsMultiSelect ( ) const

This member function checks to see if the tree control is a multi-selection tree.

Returns
TRUE if the tree control is a multi-selection tree, otherwise FALSE.

◆ IsSelected()

virtual BOOL IsSelected ( HTREEITEM hItem ) const
virtual

This member function checks whether or not the specified item is selected.

Parameters
hItem Handle of a tree item.
Returns
TRUE if the specified item is selected, otherwise FALSE.

◆ OnButtonDown()

virtual BOOL OnButtonDown | ( | BOOL | bLeft,
 |  | UINT | nFlags,
 |  | CPoint | point )
 protectedvirtual

Called when a mouse button click event occurs.

Parameters
bLeft | TRUE if the left mouse button is down.
nFlags | Indicates whether various virtual keys are down. See Remarks section for a list of values.
point | XY cursor location.

nFlags can be any combination of the following values:

MK_CONTROL: Set if the CTRL key is down. MK_LBUTTON: Set if the left mouse button is down. MK_MBUTTON: Set if the middle mouse button is down. MK_RBUTTON: Set if the right mouse button is down. MK_SHIFT: Set if the SHIFT key is down.

Returns
TRUE if successful, otherwise FALSE.

◆ SelectAll()

virtual void SelectAll | ( | BOOL | bSelect = TRUE,
 |  | HTREEITEM | htItem = NULL )
 virtual

Call this member function to clear, or select, all of the visible items in the tree control.

This will not affect the focus of the tree items.

Parameters
bSelect | TRUE to select all the items, or FALSE to clear the selection.
htItem | Tree item to start selection from. If NULL, then selection will begin at the root.

◆ SelectAllIgnore()

virtual void SelectAllIgnore | ( | BOOL | bSelect,
 |  | HTREEITEM | hIgnore )
 protectedvirtual

Toggles selection for all items in a multi-selection tree control.

Parameters
bSelect | TRUE to select, FALSE to remove selection.
hIgnore | Handle to a tree item to skip while performing the operation.

Called to toggle selection for all items in a multi-selection tree control. You can override this member to provide additional functionality.

◆ SelectChildren()

BOOL SelectChildren | ( | HTREEITEM | hParent,
 |  | BOOL | bSelect = TRUE,
 |  | BOOL | bRecurse = TRUE )

This member function will cause all of the children of the specified tree item to be selected or deselected.

Parameters
hParent | Handle of tree item to begin selection from.
bSelect | TRUE to select only the child items, or FALSE to keep existing selections.
bRecurse | TRUE to recurse all siblings, or FALSE to select only children of the parent item.
Returns
TRUE if focus was on a child item, otherwise FALSE.

◆ SelectItem()

BOOL SelectItem ( HTREEITEM hItem )

This member function is a replacement for the base class function of the same name, to handle TVIS_FOCUSED in a multi-select tree control.

Call this function to select the given tree view item. If 'hItem' is NULL, then no items are selected.

Parameters
hItem Handle of a tree item.
Returns
Nonzero if successful, otherwise zero.

◆ SelectItems()

virtual void SelectItems | ( | HTREEITEM | hItemFrom,
 |  | HTREEITEM | hItemTo,
 |  | BOOL | bOnly = TRUE )
 virtual

This member function selects items from 'hItemFrom' to 'hItemTo' in a multi-selection tree control.

It does not select a child item if the parent is collapsed. It will remove the selection from all other items if 'bOnly' is set to TRUE.

Parameters
hItemFrom | Handle of the item to start selecting from.
hItemTo | Handle of the item to end selection at.
bOnly | TRUE to only select the specified range, or FALSE to keep existing selections.

◆ SendNotify()

virtual LRESULT SendNotify ( LPNMHDR pNMHDR )
protectedvirtual

Sends a WM_NOTIFY message to the tree control owner window.

Parameters
pNMHDR Pointer to an NMHDR structure that contains the notification code and additional information. For some notification messages, this parameter points to a larger structure that has the NMHDR structure as its first member.

Called by the tree control to package and send a WM_NOTIFY message to the tree control's owner window. You can override this member to provide additional functionality.

Returns
The return value is ignored except for notification messages that specify otherwise.

◆ SetBandingHit()

BOOL SetBandingHit ( BOOL bLabel )

This member function sets the banding mode for a multi-selection tree control.

If 'bLabel' is TRUE, then items are selected only when the banding rect passes over the tree item label. If FALSE, then passing over any part of the tree item will cause selection to be made when the banding rect passes over it.

Parameters
bLabel TRUE to select items only when the banding rect passes over the text label, FALSE to select items when banding rect passes over any part of the tree item.
Returns
The previous banding state.

◆ SetExplorerTheme()

void SetExplorerTheme ( BOOL bSet )

This member function sets the Explorer theme applied (Vista+).

Parameters
bSet TRUE to set Explorer theme

◆ SetIconIndent()

int SetIconIndent ( int iconIndent )

Sets the indent between the icon/text/expander.

Parameters
iconIndent The indent to be set between the icon/text/expander.
Returns
The previous indent between the icon/text/expander.

◆ SetInsertMark()

BOOL SetInsertMark | ( | HTREEITEM | hItem,
 |  | BOOL | fAfter )
 protected

Sets the insertion mark in a tree view control.

Parameters
hItem | specifies at which item the insertion mark will be placed. If this argument is NULL, the insertion mark is removed.
fAfter | specifies if the insertion mark is placed before or after the specified item.
Returns
TRUE value that specifies if the insertion mark is placed before or after the specified item.

◆ SetInsertMarkColor()

COLORREF SetInsertMarkColor ( COLORREF clrNew )
protected

Sets the color used to draw the insertion mark for the tree view.

Parameters
clrNew value that contains the new insertion mark color.
Returns
Value that contains the current insertion mark color.

◆ SetItemBackColor()

virtual void SetItemBackColor | ( | HTREEITEM | hItem,
 |  | COLORREF | color )
 virtual

This member function sets the tree item background color.

Parameters
hItem | Handle of the reference item.
color | An RGB value for the tree item's text.

◆ SetItemBold()

virtual void SetItemBold | ( | HTREEITEM | hItem,
 |  | BOOL | bBold = TRUE )
 virtual

This member function sets the reference tree item font to bold.

Parameters
hItem | Handle of the reference item.
bBold | TRUE for bold font.

◆ SetItemColor()

virtual void SetItemColor | ( | HTREEITEM | hItem,
 |  | COLORREF | color )
 virtual

This member function sets the tree item text color.

Parameters
hItem | Handle of the reference item.
color | An RGB value for the tree item's text.

◆ SetItemFont()

virtual void SetItemFont | ( | HTREEITEM | hItem,
 |  | LOGFONT & | logfont )
 virtual

This member function sets the font for the reference tree item.

Parameters
hItem | Handle of the reference item.
logfont | New font for the tree item.

◆ SetItemState()

BOOL SetItemState | ( | HTREEITEM | hItem,
 |  | UINT | nState,
 |  | UINT | nStateMask )

This member function is a replacement for the base class function of the same name, to handle TVIS_FOCUSED in a multi-selection tree control.

It sets the state of the item specified by hItem.

Parameters
hItem | Handle of the item whose state is to be set.
nState | Specifies the new states for the item.
nStateMask | Specifies which states are to be changed.
Returns
Nonzero if successful, otherwise zero.

When set, the TVIS_FOCUSED state flag will draw a focus rectangle around the tree item that currently has input focus. Only one tree item can have focus at any given time. For a list of possible item state flags, see Tree-View Control Item States in the MSDN documentation.

◆ UpdateSelectionForRect()

virtual void UpdateSelectionForRect | ( | LPCRECT | pRect,
 |  | UINT | nFlags,
 |  | CTypedPtrList< CPtrList, HTREEITEM > & | list )
 protectedvirtual

Updates tree item selection.

Parameters
pRect | Cursor drag rectangle representing tree items to select.
nFlags | Indicates whether various virtual keys are down. See Remarks section for a list of values.
list | An array of tree items that are currently selected.

Called by the tree control to select tree items based upon the area specified by pRect. nFlags can be any combination of the following values:

MK_CONTROL: Set if the CTRL key is down. MK_LBUTTON: Set if the left mouse button is down. MK_MBUTTON: Set if the middle mouse button is down. MK_RBUTTON: Set if the right mouse button is down. MK_SHIFT: Set if the SHIFT key is down.

Member Data Documentation

◆ m_bDoDefaultItemDrawing

BOOL m_bDoDefaultItemDrawing
protected

FALSE by default, which means an item will be drawn by the framework.

If TRUE, then items will be drawn in a standard way.

◆ m_nTheme

int m_nTheme
protected

Self tree pointer.

This variable will be removed with themes support.

The documentation for this class was generated from the following file:
  • XTPTreeBase.h


Toolkit Pro: CXTPTreeBase::CLRFONT Struct Reference

  • CXTPTreeBase
  • CLRFONT
Public Member Functions | Public Attributes | List of all members
CXTPTreeBase::CLRFONT Struct Reference

CLRFONT structure is used to by the CXTPShellTreeCtrl and CXTPShellTreeView classes to maintain font information for a particular tree item. More...

Public Member Functions

CLRFONT ()
Constructs a CLRFONT struct and initializes member data.

Public Attributes

LOGFONT | logfont
A LOGFONT object that represents the tree item font.
COLORREF | color
An RGB value that represents the text color for a tree item.
COLORREF | colorBack
An RGB value that represents the background color for a tree item.

Detailed Description

CLRFONT structure is used to by the CXTPShellTreeCtrl and CXTPShellTreeView classes to maintain font information for a particular tree item.

See also
CXTPShellTreeCtrl, CXTPShellTreeView
The documentation for this struct was generated from the following file:
  • XTPTreeBase.h


Toolkit Pro: CXTPTreeCtrl Class Reference

Public Member Functions | List of all members
CXTPTreeCtrl Class Reference

CXTPTreeCtrl is a CTreeCtrl derived class. More...

Inheritance diagram for CXTPTreeCtrl:
[legend]

Public Member Functions

CXTPTreeCtrl ()
Constructs a CXTPTreeCtrl object.
virtual ~CXTPTreeCtrl ()
Destroys a CXTPTreeCtrl object, handles cleanup and deallocation.

Detailed Description

CXTPTreeCtrl is a CTreeCtrl derived class.

It extends the CTreeCtrl class to add additional functionality, including tree traversal, searching, color, and settings.

The documentation for this class was generated from the following file:
  • XTPTreeCtrlView.h


Toolkit Pro: CXTPTreeNativeWindows10Theme Class Reference

Public Member Functions | List of all members
CXTPTreeNativeWindows10Theme Class Reference

CXTPTreeNativeWindows10Theme is a CXTPTreeTheme derived class used to render a Native Windows 10 style tree. More...

Inheritance diagram for CXTPTreeNativeWindows10Theme:
[legend]

Public Member Functions

CXTPTreeNativeWindows10Theme ()
Constructs a CXTPTreeNativeWindows10Theme object.
- Public Member Functions inherited from CXTPTreeOffice2013Theme
CXTPTreeOffice2013Theme ()
Constructs a CXTPTreeOffice2013Theme object.
virtual void | RefreshMetrics (CXTPTreeBase *pTreeBase)
This member function performs initialization for the tree theme.
- Public Member Functions inherited from CXTPTreeTheme
CXTPTreeTheme ()
Constructs a CXTPTreeTheme object.
virtual | ~CXTPTreeTheme ()
Destroys a CXTPTreeTheme object, handles cleanup and deallocation.
virtual COLORREF | GetTreeBackColor () const
This member function is used to retrieve the tree background color.
virtual COLORREF | GetTreeTextColor () const
This member function is used to retrieve the tree text color.
virtual COLORREF | GetItemTextColor (UINT uState, bool bTreeHasFocus, DWORD dwStyle, COLORREF crBackDef, CTreeCtrl *pTreeBase) const
This member function is used to retrieve the tree text color depending on the tree item state.
virtual COLORREF | GetItemBackColor (UINT uState, bool bTreeHasFocus, DWORD dwStyle, COLORREF crTextDef, CTreeCtrl *pTreeBase) const
This member function is used to retrieve the tree back color depending on the tree item state.
BOOL | IsDrawFocusRect () const
This member function is used to determine if a focus rectangle should be drawn around tree items that have input focus.
virtual BOOL | IsThemeDark () const
This member function is used to determine if a dark theme is used.
- Public Member Functions inherited from CXTPControlTheme
CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme | GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlTheme
static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Attributes inherited from CXTPTreeTheme
COLORREF | m_crText
Tree item text color.
COLORREF | m_crTextDisabled
Tree item disabled text color.
COLORREF | m_crTextSelected
Tree item selected text color.
COLORREF | m_crTextSelectedInactive
Tree item selected inactive text color when TVS_SHOWSELALWAYS is used.
COLORREF | m_crTextSelectedDisabled
Tree item selected disabled text color when TVS_SHOWSELALWAYS is used.
COLORREF | m_crBack
Tree item background color.
COLORREF | m_crBackDisabled
Tree item disabled background color.
COLORREF | m_crBackSelected
Tree item selected background color.
COLORREF | m_crBackSelectedInactive
Tree item selected inactive background color when TVS_SHOWSELALWAYS is used.
COLORREF | m_crBackSelectedDisabled
Tree item selected disabled background color when TVS_SHOWSELALWAYS is used.
BOOL | m_bDrawFocusRect
TRUE to draw a focus rectangle when a tree item has input focus.
BOOL | m_bDarkTheme
TRUE when using a darker background theme, FALSE when using a lighter background theme.
- Protected Attributes inherited from CXTPControlTheme
XTPControlTheme | m_nTheme
Currently selected theme style index.

Detailed Description

CXTPTreeNativeWindows10Theme is a CXTPTreeTheme derived class used to render a Native Windows 10 style tree.

The documentation for this class was generated from the following file:
  • XTPTreeTheme.h


Toolkit Pro: CXTPTreeNativeWindows11Theme Class Reference

Public Member Functions | List of all members
CXTPTreeNativeWindows11Theme Class Reference

CXTPTreeNativeWindows11Theme is a CXTPTreeTheme derived class used to render a Native Windows 11 style tree. More...

Inheritance diagram for CXTPTreeNativeWindows11Theme:
[legend]

Public Member Functions

CXTPTreeNativeWindows11Theme ()
Constructs a CXTPTreeNativeWindows11Theme object.
- Public Member Functions inherited from CXTPTreeOffice2013Theme
CXTPTreeOffice2013Theme ()
Constructs a CXTPTreeOffice2013Theme object.
virtual void | RefreshMetrics (CXTPTreeBase *pTreeBase)
This member function performs initialization for the tree theme.
- Public Member Functions inherited from CXTPTreeTheme
CXTPTreeTheme ()
Constructs a CXTPTreeTheme object.
virtual | ~CXTPTreeTheme ()
Destroys a CXTPTreeTheme object, handles cleanup and deallocation.
virtual COLORREF | GetTreeBackColor () const
This member function is used to retrieve the tree background color.
virtual COLORREF | GetTreeTextColor () const
This member function is used to retrieve the tree text color.
virtual COLORREF | GetItemTextColor (UINT uState, bool bTreeHasFocus, DWORD dwStyle, COLORREF crBackDef, CTreeCtrl *pTreeBase) const
This member function is used to retrieve the tree text color depending on the tree item state.
virtual COLORREF | GetItemBackColor (UINT uState, bool bTreeHasFocus, DWORD dwStyle, COLORREF crTextDef, CTreeCtrl *pTreeBase) const
This member function is used to retrieve the tree back color depending on the tree item state.
BOOL | IsDrawFocusRect () const
This member function is used to determine if a focus rectangle should be drawn around tree items that have input focus.
virtual BOOL | IsThemeDark () const
This member function is used to determine if a dark theme is used.
- Public Member Functions inherited from CXTPControlTheme
CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme | GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlTheme
static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Attributes inherited from CXTPTreeTheme
COLORREF | m_crText
Tree item text color.
COLORREF | m_crTextDisabled
Tree item disabled text color.
COLORREF | m_crTextSelected
Tree item selected text color.
COLORREF | m_crTextSelectedInactive
Tree item selected inactive text color when TVS_SHOWSELALWAYS is used.
COLORREF | m_crTextSelectedDisabled
Tree item selected disabled text color when TVS_SHOWSELALWAYS is used.
COLORREF | m_crBack
Tree item background color.
COLORREF | m_crBackDisabled
Tree item disabled background color.
COLORREF | m_crBackSelected
Tree item selected background color.
COLORREF | m_crBackSelectedInactive
Tree item selected inactive background color when TVS_SHOWSELALWAYS is used.
COLORREF | m_crBackSelectedDisabled
Tree item selected disabled background color when TVS_SHOWSELALWAYS is used.
BOOL | m_bDrawFocusRect
TRUE to draw a focus rectangle when a tree item has input focus.
BOOL | m_bDarkTheme
TRUE when using a darker background theme, FALSE when using a lighter background theme.
- Protected Attributes inherited from CXTPControlTheme
XTPControlTheme | m_nTheme
Currently selected theme style index.

Detailed Description

CXTPTreeNativeWindows11Theme is a CXTPTreeTheme derived class used to render a Native Windows 11 style tree.

The documentation for this class was generated from the following file:
  • XTPTreeTheme.h


Toolkit Pro: CXTPTreeOffice2013Theme Class Reference

Public Member Functions | List of all members
CXTPTreeOffice2013Theme Class Reference

CXTPTreeOffice2013Theme is a CXTPTreeTheme derived class used to render a Office 2013 style tree. More...

Inheritance diagram for CXTPTreeOffice2013Theme:
[legend]

Public Member Functions

CXTPTreeOffice2013Theme ()
Constructs a CXTPTreeOffice2013Theme object.
virtual void | RefreshMetrics (CXTPTreeBase *pTreeBase)
This member function performs initialization for the tree theme.
- Public Member Functions inherited from CXTPTreeTheme
CXTPTreeTheme ()
Constructs a CXTPTreeTheme object.
virtual | ~CXTPTreeTheme ()
Destroys a CXTPTreeTheme object, handles cleanup and deallocation.
virtual COLORREF | GetTreeBackColor () const
This member function is used to retrieve the tree background color.
virtual COLORREF | GetTreeTextColor () const
This member function is used to retrieve the tree text color.
virtual COLORREF | GetItemTextColor (UINT uState, bool bTreeHasFocus, DWORD dwStyle, COLORREF crBackDef, CTreeCtrl *pTreeBase) const
This member function is used to retrieve the tree text color depending on the tree item state.
virtual COLORREF | GetItemBackColor (UINT uState, bool bTreeHasFocus, DWORD dwStyle, COLORREF crTextDef, CTreeCtrl *pTreeBase) const
This member function is used to retrieve the tree back color depending on the tree item state.
BOOL | IsDrawFocusRect () const
This member function is used to determine if a focus rectangle should be drawn around tree items that have input focus.
virtual BOOL | IsThemeDark () const
This member function is used to determine if a dark theme is used.
- Public Member Functions inherited from CXTPControlTheme
CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme | GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlTheme
static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Attributes inherited from CXTPTreeTheme
COLORREF | m_crText
Tree item text color.
COLORREF | m_crTextDisabled
Tree item disabled text color.
COLORREF | m_crTextSelected
Tree item selected text color.
COLORREF | m_crTextSelectedInactive
Tree item selected inactive text color when TVS_SHOWSELALWAYS is used.
COLORREF | m_crTextSelectedDisabled
Tree item selected disabled text color when TVS_SHOWSELALWAYS is used.
COLORREF | m_crBack
Tree item background color.
COLORREF | m_crBackDisabled
Tree item disabled background color.
COLORREF | m_crBackSelected
Tree item selected background color.
COLORREF | m_crBackSelectedInactive
Tree item selected inactive background color when TVS_SHOWSELALWAYS is used.
COLORREF | m_crBackSelectedDisabled
Tree item selected disabled background color when TVS_SHOWSELALWAYS is used.
BOOL | m_bDrawFocusRect
TRUE to draw a focus rectangle when a tree item has input focus.
BOOL | m_bDarkTheme
TRUE when using a darker background theme, FALSE when using a lighter background theme.
- Protected Attributes inherited from CXTPControlTheme
XTPControlTheme | m_nTheme
Currently selected theme style index.

Detailed Description

CXTPTreeOffice2013Theme is a CXTPTreeTheme derived class used to render a Office 2013 style tree.

Member Function Documentation

◆ RefreshMetrics()

virtual void RefreshMetrics ( CXTPTreeBase * pTreeBase )
virtual

This member function performs initialization for the tree theme.

Parameters
pTreeBase Pointer to a valid CXTPTreeBase object.

Initializes all drawing defaults such as colors.

Reimplemented from CXTPTreeTheme.

The documentation for this class was generated from the following file:
  • XTPTreeTheme.h


Toolkit Pro: CXTPTreeTheme Class Reference

Public Member Functions | Protected Attributes | List of all members
CXTPTreeTheme Class Reference

CXTPTreeTheme is a class used to perform tree control theme drawing tasks. More...

Inheritance diagram for CXTPTreeTheme:
[legend]

Public Member Functions

CXTPTreeTheme ()
Constructs a CXTPTreeTheme object.
virtual | ~CXTPTreeTheme ()
Destroys a CXTPTreeTheme object, handles cleanup and deallocation.
virtual void | RefreshMetrics (CXTPTreeBase *pTreeBase)
This member function performs initialization for the tree theme.
virtual COLORREF | GetTreeBackColor () const
This member function is used to retrieve the tree background color.
virtual COLORREF | GetTreeTextColor () const
This member function is used to retrieve the tree text color.
virtual COLORREF | GetItemTextColor (UINT uState, bool bTreeHasFocus, DWORD dwStyle, COLORREF crBackDef, CTreeCtrl *pTreeBase) const
This member function is used to retrieve the tree text color depending on the tree item state.
virtual COLORREF | GetItemBackColor (UINT uState, bool bTreeHasFocus, DWORD dwStyle, COLORREF crTextDef, CTreeCtrl *pTreeBase) const
This member function is used to retrieve the tree back color depending on the tree item state.
BOOL | IsDrawFocusRect () const
This member function is used to determine if a focus rectangle should be drawn around tree items that have input focus.
virtual BOOL | IsThemeDark () const
This member function is used to determine if a dark theme is used.
- Public Member Functions inherited from CXTPControlTheme
CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme | GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Attributes

COLORREF | m_crText
Tree item text color.
COLORREF | m_crTextDisabled
Tree item disabled text color.
COLORREF | m_crTextSelected
Tree item selected text color.
COLORREF | m_crTextSelectedInactive
Tree item selected inactive text color when TVS_SHOWSELALWAYS is used.
COLORREF | m_crTextSelectedDisabled
Tree item selected disabled text color when TVS_SHOWSELALWAYS is used.
COLORREF | m_crBack
Tree item background color.
COLORREF | m_crBackDisabled
Tree item disabled background color.
COLORREF | m_crBackSelected
Tree item selected background color.
COLORREF | m_crBackSelectedInactive
Tree item selected inactive background color when TVS_SHOWSELALWAYS is used.
COLORREF | m_crBackSelectedDisabled
Tree item selected disabled background color when TVS_SHOWSELALWAYS is used.
BOOL | m_bDrawFocusRect
TRUE to draw a focus rectangle when a tree item has input focus.
BOOL | m_bDarkTheme
TRUE when using a darker background theme, FALSE when using a lighter background theme.
- Protected Attributes inherited from CXTPControlTheme
XTPControlTheme | m_nTheme
Currently selected theme style index.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlTheme
static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

CXTPTreeTheme is a class used to perform tree control theme drawing tasks.

This is the base class for all tree themes.

Member Function Documentation

◆ GetItemBackColor()

virtual COLORREF GetItemBackColor | ( | UINT | uState,
 |  | bool | bTreeHasFocus,
 |  | DWORD | dwStyle,
 |  | COLORREF | crTextDef,
 |  | CTreeCtrl * | pTreeBase ) const
 virtual

This member function is used to retrieve the tree back color depending on the tree item state.

Parameters
uState | TVIS state flags.
bTreeHasFocus | TRUE if the tree has input focus.
dwStyle | TVS style flags.
crTextDef | Default text color to be returned.
pTreeBase | Pointer to a valid CXTPTreeBase object.
Returns
An RGB value representing the tree item state back color.

◆ GetItemTextColor()

virtual COLORREF GetItemTextColor | ( | UINT | uState,
 |  | bool | bTreeHasFocus,
 |  | DWORD | dwStyle,
 |  | COLORREF | crBackDef,
 |  | CTreeCtrl * | pTreeBase ) const
 virtual

This member function is used to retrieve the tree text color depending on the tree item state.

Parameters
uState | TVIS state flags.
bTreeHasFocus | TRUE if the tree has input focus.
dwStyle | TVS style flags.
crBackDef | Default background color to be returned.
pTreeBase | Pointer to a valid CXTPTreeBase object.
Returns
An RGB value representing the tree item state text color.

◆ GetTreeBackColor()

virtual COLORREF GetTreeBackColor ( ) const
virtual

This member function is used to retrieve the tree background color.

Returns
An RGB value representing the tree background color.

◆ GetTreeTextColor()

virtual COLORREF GetTreeTextColor ( ) const
virtual

This member function is used to retrieve the tree text color.

Returns
An RGB value representing the tree text color.

◆ IsDrawFocusRect()

BOOL IsDrawFocusRect ( ) const
inline

This member function is used to determine if a focus rectangle should be drawn around tree items that have input focus.

Returns
TRUE if a focus rectangle should be drawn, otherwise FALSE.

◆ IsThemeDark()

virtual BOOL IsThemeDark ( ) const
inlinevirtual

This member function is used to determine if a dark theme is used.

Returns
TRUE when using a darker background theme, FALSE when using a lighter background theme.

◆ RefreshMetrics()

virtual void RefreshMetrics ( CXTPTreeBase * pTreeBase )
virtual

This member function performs initialization for the tree theme.

Parameters
pTreeBase Pointer to a valid CXTPTreeBase object.

Initializes all drawing defaults such as colors.

Reimplemented in CXTPTreeOffice2013Theme, and CXTPTreeVisualStudio2012Theme.

The documentation for this class was generated from the following file:
  • XTPTreeTheme.h


Toolkit Pro: CXTPTreeView Class Reference

Protected Member Functions | List of all members
CXTPTreeView Class Reference

CXTPTreeView is a CTreeView derived class. More...

Protected Member Functions

CXTPTreeView ()
Protected constructor used by dynamic creation.
virtual ~CXTPTreeView ()
Destroys a CXTPTreeView object, handles cleanup and deallocation.

Detailed Description

CXTPTreeView is a CTreeView derived class.

It extends the CTreeView class to add additional functionality, including tree traversal, searching, color, and settings.

Constructor & Destructor Documentation

◆ CXTPTreeView()

CXTPTreeView ( )
protected

Protected constructor used by dynamic creation.

Constructs a CXTPTreeView object.

The documentation for this class was generated from the following file:
  • XTPTreeCtrlView.h


Toolkit Pro: CXTPTreeVisualStudio2012Theme Class Reference

Public Member Functions | List of all members
CXTPTreeVisualStudio2012Theme Class Reference

CXTPTreeVisualStudio2012Theme is a CXTPTreeTheme derived class used to render a Visual Studio 2012 style tree. More...

Inheritance diagram for CXTPTreeVisualStudio2012Theme:
[legend]

Public Member Functions

CXTPTreeVisualStudio2012Theme (BOOL bLight=TRUE)
Constructs a CXTPTreeVisualStudio2012Theme object.
virtual void | RefreshMetrics (CXTPTreeBase *pTreeBase)
This member function performs initialization for the tree theme.
- Public Member Functions inherited from CXTPTreeTheme
CXTPTreeTheme ()
Constructs a CXTPTreeTheme object.
virtual | ~CXTPTreeTheme ()
Destroys a CXTPTreeTheme object, handles cleanup and deallocation.
virtual COLORREF | GetTreeBackColor () const
This member function is used to retrieve the tree background color.
virtual COLORREF | GetTreeTextColor () const
This member function is used to retrieve the tree text color.
virtual COLORREF | GetItemTextColor (UINT uState, bool bTreeHasFocus, DWORD dwStyle, COLORREF crBackDef, CTreeCtrl *pTreeBase) const
This member function is used to retrieve the tree text color depending on the tree item state.
virtual COLORREF | GetItemBackColor (UINT uState, bool bTreeHasFocus, DWORD dwStyle, COLORREF crTextDef, CTreeCtrl *pTreeBase) const
This member function is used to retrieve the tree back color depending on the tree item state.
BOOL | IsDrawFocusRect () const
This member function is used to determine if a focus rectangle should be drawn around tree items that have input focus.
virtual BOOL | IsThemeDark () const
This member function is used to determine if a dark theme is used.
- Public Member Functions inherited from CXTPControlTheme
CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme | GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlTheme
static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Attributes inherited from CXTPTreeTheme
COLORREF | m_crText
Tree item text color.
COLORREF | m_crTextDisabled
Tree item disabled text color.
COLORREF | m_crTextSelected
Tree item selected text color.
COLORREF | m_crTextSelectedInactive
Tree item selected inactive text color when TVS_SHOWSELALWAYS is used.
COLORREF | m_crTextSelectedDisabled
Tree item selected disabled text color when TVS_SHOWSELALWAYS is used.
COLORREF | m_crBack
Tree item background color.
COLORREF | m_crBackDisabled
Tree item disabled background color.
COLORREF | m_crBackSelected
Tree item selected background color.
COLORREF | m_crBackSelectedInactive
Tree item selected inactive background color when TVS_SHOWSELALWAYS is used.
COLORREF | m_crBackSelectedDisabled
Tree item selected disabled background color when TVS_SHOWSELALWAYS is used.
BOOL | m_bDrawFocusRect
TRUE to draw a focus rectangle when a tree item has input focus.
BOOL | m_bDarkTheme
TRUE when using a darker background theme, FALSE when using a lighter background theme.
- Protected Attributes inherited from CXTPControlTheme
XTPControlTheme | m_nTheme
Currently selected theme style index.

Detailed Description

CXTPTreeVisualStudio2012Theme is a CXTPTreeTheme derived class used to render a Visual Studio 2012 style tree.

Constructor & Destructor Documentation

◆ CXTPTreeVisualStudio2012Theme()

CXTPTreeVisualStudio2012Theme ( BOOL bLight = TRUE )

Constructs a CXTPTreeVisualStudio2012Theme object.

Parameters
bLight TRUE to use Light theme, FALSE to use Dark theme.

Member Function Documentation

◆ RefreshMetrics()

virtual void RefreshMetrics ( CXTPTreeBase * pTreeBase )
virtual

This member function performs initialization for the tree theme.

Parameters
pTreeBase Pointer to a valid CXTPTreeBase object.

Initializes all drawing defaults such as colors.

Reimplemented from CXTPTreeTheme.

The documentation for this class was generated from the following file:
  • XTPTreeTheme.h


Toolkit Pro: CXTPTreeVisualStudio2015Theme Class Reference

Public Member Functions | List of all members
CXTPTreeVisualStudio2015Theme Class Reference

CXTPTreeVisualStudio2015Theme is a CXTPTreeTheme derived class used to render a Visual Studio 2015 style tree. More...

Inheritance diagram for CXTPTreeVisualStudio2015Theme:
[legend]

Public Member Functions

CXTPTreeVisualStudio2015Theme ()
Constructs a CXTPTreeVisualStudio2015Theme object.
- Public Member Functions inherited from CXTPTreeOffice2013Theme
CXTPTreeOffice2013Theme ()
Constructs a CXTPTreeOffice2013Theme object.
virtual void | RefreshMetrics (CXTPTreeBase *pTreeBase)
This member function performs initialization for the tree theme.
- Public Member Functions inherited from CXTPTreeTheme
CXTPTreeTheme ()
Constructs a CXTPTreeTheme object.
virtual | ~CXTPTreeTheme ()
Destroys a CXTPTreeTheme object, handles cleanup and deallocation.
virtual COLORREF | GetTreeBackColor () const
This member function is used to retrieve the tree background color.
virtual COLORREF | GetTreeTextColor () const
This member function is used to retrieve the tree text color.
virtual COLORREF | GetItemTextColor (UINT uState, bool bTreeHasFocus, DWORD dwStyle, COLORREF crBackDef, CTreeCtrl *pTreeBase) const
This member function is used to retrieve the tree text color depending on the tree item state.
virtual COLORREF | GetItemBackColor (UINT uState, bool bTreeHasFocus, DWORD dwStyle, COLORREF crTextDef, CTreeCtrl *pTreeBase) const
This member function is used to retrieve the tree back color depending on the tree item state.
BOOL | IsDrawFocusRect () const
This member function is used to determine if a focus rectangle should be drawn around tree items that have input focus.
virtual BOOL | IsThemeDark () const
This member function is used to determine if a dark theme is used.
- Public Member Functions inherited from CXTPControlTheme
CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme | GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlTheme
static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Attributes inherited from CXTPTreeTheme
COLORREF | m_crText
Tree item text color.
COLORREF | m_crTextDisabled
Tree item disabled text color.
COLORREF | m_crTextSelected
Tree item selected text color.
COLORREF | m_crTextSelectedInactive
Tree item selected inactive text color when TVS_SHOWSELALWAYS is used.
COLORREF | m_crTextSelectedDisabled
Tree item selected disabled text color when TVS_SHOWSELALWAYS is used.
COLORREF | m_crBack
Tree item background color.
COLORREF | m_crBackDisabled
Tree item disabled background color.
COLORREF | m_crBackSelected
Tree item selected background color.
COLORREF | m_crBackSelectedInactive
Tree item selected inactive background color when TVS_SHOWSELALWAYS is used.
COLORREF | m_crBackSelectedDisabled
Tree item selected disabled background color when TVS_SHOWSELALWAYS is used.
BOOL | m_bDrawFocusRect
TRUE to draw a focus rectangle when a tree item has input focus.
BOOL | m_bDarkTheme
TRUE when using a darker background theme, FALSE when using a lighter background theme.
- Protected Attributes inherited from CXTPControlTheme
XTPControlTheme | m_nTheme
Currently selected theme style index.

Detailed Description

CXTPTreeVisualStudio2015Theme is a CXTPTreeTheme derived class used to render a Visual Studio 2015 style tree.

The documentation for this class was generated from the following file:
  • XTPTreeTheme.h


Toolkit Pro: CXTPTreeVisualStudio2017Theme Class Reference

Public Member Functions | List of all members
CXTPTreeVisualStudio2017Theme Class Reference

CXTPTreeVisualStudio2017Theme is a CXTPTreeTheme derived class used to render a Visual Studio 2017 style tree. More...

Inheritance diagram for CXTPTreeVisualStudio2017Theme:
[legend]

Public Member Functions

CXTPTreeVisualStudio2017Theme ()
Constructs a CXTPTreeVisualStudio2017Theme object.
- Public Member Functions inherited from CXTPTreeOffice2013Theme
CXTPTreeOffice2013Theme ()
Constructs a CXTPTreeOffice2013Theme object.
virtual void | RefreshMetrics (CXTPTreeBase *pTreeBase)
This member function performs initialization for the tree theme.
- Public Member Functions inherited from CXTPTreeTheme
CXTPTreeTheme ()
Constructs a CXTPTreeTheme object.
virtual | ~CXTPTreeTheme ()
Destroys a CXTPTreeTheme object, handles cleanup and deallocation.
virtual COLORREF | GetTreeBackColor () const
This member function is used to retrieve the tree background color.
virtual COLORREF | GetTreeTextColor () const
This member function is used to retrieve the tree text color.
virtual COLORREF | GetItemTextColor (UINT uState, bool bTreeHasFocus, DWORD dwStyle, COLORREF crBackDef, CTreeCtrl *pTreeBase) const
This member function is used to retrieve the tree text color depending on the tree item state.
virtual COLORREF | GetItemBackColor (UINT uState, bool bTreeHasFocus, DWORD dwStyle, COLORREF crTextDef, CTreeCtrl *pTreeBase) const
This member function is used to retrieve the tree back color depending on the tree item state.
BOOL | IsDrawFocusRect () const
This member function is used to determine if a focus rectangle should be drawn around tree items that have input focus.
virtual BOOL | IsThemeDark () const
This member function is used to determine if a dark theme is used.
- Public Member Functions inherited from CXTPControlTheme
CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme | GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlTheme
static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Attributes inherited from CXTPTreeTheme
COLORREF | m_crText
Tree item text color.
COLORREF | m_crTextDisabled
Tree item disabled text color.
COLORREF | m_crTextSelected
Tree item selected text color.
COLORREF | m_crTextSelectedInactive
Tree item selected inactive text color when TVS_SHOWSELALWAYS is used.
COLORREF | m_crTextSelectedDisabled
Tree item selected disabled text color when TVS_SHOWSELALWAYS is used.
COLORREF | m_crBack
Tree item background color.
COLORREF | m_crBackDisabled
Tree item disabled background color.
COLORREF | m_crBackSelected
Tree item selected background color.
COLORREF | m_crBackSelectedInactive
Tree item selected inactive background color when TVS_SHOWSELALWAYS is used.
COLORREF | m_crBackSelectedDisabled
Tree item selected disabled background color when TVS_SHOWSELALWAYS is used.
BOOL | m_bDrawFocusRect
TRUE to draw a focus rectangle when a tree item has input focus.
BOOL | m_bDarkTheme
TRUE when using a darker background theme, FALSE when using a lighter background theme.
- Protected Attributes inherited from CXTPControlTheme
XTPControlTheme | m_nTheme
Currently selected theme style index.

Detailed Description

CXTPTreeVisualStudio2017Theme is a CXTPTreeTheme derived class used to render a Visual Studio 2017 style tree.

The documentation for this class was generated from the following file:
  • XTPTreeTheme.h


Toolkit Pro: CXTPTreeVisualStudio2019Theme Class Reference

Public Member Functions | List of all members
CXTPTreeVisualStudio2019Theme Class Reference

CXTPTreeVisualStudio2019Theme is a CXTPTreeTheme derived class used to render a Visual Studio 2019 style tree. More...

Inheritance diagram for CXTPTreeVisualStudio2019Theme:
[legend]

Public Member Functions

CXTPTreeVisualStudio2019Theme ()
Constructs a CXTPTreeVisualStudio2019Theme object.
- Public Member Functions inherited from CXTPTreeOffice2013Theme
CXTPTreeOffice2013Theme ()
Constructs a CXTPTreeOffice2013Theme object.
virtual void | RefreshMetrics (CXTPTreeBase *pTreeBase)
This member function performs initialization for the tree theme.
- Public Member Functions inherited from CXTPTreeTheme
CXTPTreeTheme ()
Constructs a CXTPTreeTheme object.
virtual | ~CXTPTreeTheme ()
Destroys a CXTPTreeTheme object, handles cleanup and deallocation.
virtual COLORREF | GetTreeBackColor () const
This member function is used to retrieve the tree background color.
virtual COLORREF | GetTreeTextColor () const
This member function is used to retrieve the tree text color.
virtual COLORREF | GetItemTextColor (UINT uState, bool bTreeHasFocus, DWORD dwStyle, COLORREF crBackDef, CTreeCtrl *pTreeBase) const
This member function is used to retrieve the tree text color depending on the tree item state.
virtual COLORREF | GetItemBackColor (UINT uState, bool bTreeHasFocus, DWORD dwStyle, COLORREF crTextDef, CTreeCtrl *pTreeBase) const
This member function is used to retrieve the tree back color depending on the tree item state.
BOOL | IsDrawFocusRect () const
This member function is used to determine if a focus rectangle should be drawn around tree items that have input focus.
virtual BOOL | IsThemeDark () const
This member function is used to determine if a dark theme is used.
- Public Member Functions inherited from CXTPControlTheme
CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme | GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlTheme
static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Attributes inherited from CXTPTreeTheme
COLORREF | m_crText
Tree item text color.
COLORREF | m_crTextDisabled
Tree item disabled text color.
COLORREF | m_crTextSelected
Tree item selected text color.
COLORREF | m_crTextSelectedInactive
Tree item selected inactive text color when TVS_SHOWSELALWAYS is used.
COLORREF | m_crTextSelectedDisabled
Tree item selected disabled text color when TVS_SHOWSELALWAYS is used.
COLORREF | m_crBack
Tree item background color.
COLORREF | m_crBackDisabled
Tree item disabled background color.
COLORREF | m_crBackSelected
Tree item selected background color.
COLORREF | m_crBackSelectedInactive
Tree item selected inactive background color when TVS_SHOWSELALWAYS is used.
COLORREF | m_crBackSelectedDisabled
Tree item selected disabled background color when TVS_SHOWSELALWAYS is used.
BOOL | m_bDrawFocusRect
TRUE to draw a focus rectangle when a tree item has input focus.
BOOL | m_bDarkTheme
TRUE when using a darker background theme, FALSE when using a lighter background theme.
- Protected Attributes inherited from CXTPControlTheme
XTPControlTheme | m_nTheme
Currently selected theme style index.

Detailed Description

CXTPTreeVisualStudio2019Theme is a CXTPTreeTheme derived class used to render a Visual Studio 2019 style tree.

The documentation for this class was generated from the following file:
  • XTPTreeTheme.h


Toolkit Pro: CXTPTreeVisualStudio2022Theme Class Reference

Public Member Functions | List of all members
CXTPTreeVisualStudio2022Theme Class Reference

CXTPTreeVisualStudio2022Theme is a CXTPTreeTheme derived class used to render a Visual Studio 2022 style tree. More...

Inheritance diagram for CXTPTreeVisualStudio2022Theme:
[legend]

Public Member Functions

CXTPTreeVisualStudio2022Theme ()
Constructs a CXTPTreeVisualStudio2022Theme object.
- Public Member Functions inherited from CXTPTreeOffice2013Theme
CXTPTreeOffice2013Theme ()
Constructs a CXTPTreeOffice2013Theme object.
virtual void | RefreshMetrics (CXTPTreeBase *pTreeBase)
This member function performs initialization for the tree theme.
- Public Member Functions inherited from CXTPTreeTheme
CXTPTreeTheme ()
Constructs a CXTPTreeTheme object.
virtual | ~CXTPTreeTheme ()
Destroys a CXTPTreeTheme object, handles cleanup and deallocation.
virtual COLORREF | GetTreeBackColor () const
This member function is used to retrieve the tree background color.
virtual COLORREF | GetTreeTextColor () const
This member function is used to retrieve the tree text color.
virtual COLORREF | GetItemTextColor (UINT uState, bool bTreeHasFocus, DWORD dwStyle, COLORREF crBackDef, CTreeCtrl *pTreeBase) const
This member function is used to retrieve the tree text color depending on the tree item state.
virtual COLORREF | GetItemBackColor (UINT uState, bool bTreeHasFocus, DWORD dwStyle, COLORREF crTextDef, CTreeCtrl *pTreeBase) const
This member function is used to retrieve the tree back color depending on the tree item state.
BOOL | IsDrawFocusRect () const
This member function is used to determine if a focus rectangle should be drawn around tree items that have input focus.
virtual BOOL | IsThemeDark () const
This member function is used to determine if a dark theme is used.
- Public Member Functions inherited from CXTPControlTheme
CXTPControlTheme ()
Constructs a new CXTPControlTheme object and handles initialization.
XTPControlTheme | GetThemeStyle () const
Call this member function to get the style for the theme.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPControlTheme
static void AFX_CDECL | SetTheme (HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Protected Attributes inherited from CXTPTreeTheme
COLORREF | m_crText
Tree item text color.
COLORREF | m_crTextDisabled
Tree item disabled text color.
COLORREF | m_crTextSelected
Tree item selected text color.
COLORREF | m_crTextSelectedInactive
Tree item selected inactive text color when TVS_SHOWSELALWAYS is used.
COLORREF | m_crTextSelectedDisabled
Tree item selected disabled text color when TVS_SHOWSELALWAYS is used.
COLORREF | m_crBack
Tree item background color.
COLORREF | m_crBackDisabled
Tree item disabled background color.
COLORREF | m_crBackSelected
Tree item selected background color.
COLORREF | m_crBackSelectedInactive
Tree item selected inactive background color when TVS_SHOWSELALWAYS is used.
COLORREF | m_crBackSelectedDisabled
Tree item selected disabled background color when TVS_SHOWSELALWAYS is used.
BOOL | m_bDrawFocusRect
TRUE to draw a focus rectangle when a tree item has input focus.
BOOL | m_bDarkTheme
TRUE when using a darker background theme, FALSE when using a lighter background theme.
- Protected Attributes inherited from CXTPControlTheme
XTPControlTheme | m_nTheme
Currently selected theme style index.

Detailed Description

CXTPTreeVisualStudio2022Theme is a CXTPTreeTheme derived class used to render a Visual Studio 2022 style tree.

The documentation for this class was generated from the following file:
  • XTPTreeTheme.h


Toolkit Pro: CXTPVisualStudio2005Theme Class Reference

Public Member Functions | List of all members
CXTPVisualStudio2005Theme Class Reference

The CXTPVisualStudio2005Theme class is used to enable a Visual Studio 2005 style theme for Command Bars. More...

Inheritance diagram for CXTPVisualStudio2005Theme:
[legend]

Public Member Functions

CXTPVisualStudio2005Theme ()
Constructs a CXTPVisualStudio2005Theme object.
virtual | ~CXTPVisualStudio2005Theme ()
Destroys a CXTPVisualStudio2005Theme object, handles cleanup and deallocation.
void | RefreshMetrics ()
This method is called to refresh the visual metrics of the manager.
virtual XTPPaintTheme | BaseTheme ()
Retrieves the base theme of the manager.
- Public Member Functions inherited from CXTPCommandBarsOffice2003Theme
CXTPCommandBarsOffice2003Theme ()
Constructs a CXTPCommandBarsOffice2003Theme object.
virtual | ~CXTPCommandBarsOffice2003Theme ()
Destroys a CXTPCommandBarsOffice2003Theme object, handles cleanup and deallocation.
void | ExcludeCorners (CDC *pDC, CRect rc)
This method creates a new clipping region that consists of the existing clipping region minus the corners rectangles.
- Public Member Functions inherited from CXTPCommandBarsOfficeXPTheme
CXTPCommandBarsOfficeXPTheme ()
Constructs a CXTPCommandBarsOfficeXPTheme object.
virtual COLORREF | GetRectangleTextColor (BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition)
This method retrieves a buttons text color.
virtual CSize | DrawListBoxControl (CDC *pDC, CXTPControl *pButton, CRect rc, BOOL bSelected, BOOL bDraw, CXTPCommandBars *pCommandBars=0)
This method is called to draw the control placed on the ListBox.
virtual void | AdjustExcludeRect (CRect &rc, CXTPControl *pControl, BOOL bVertical)
This method is called to determine the offset of a pop-up bar.
virtual void | DrawPopupResizeGripper (CDC *pDC, CRect rcGripper, int nFlags)
This method is called to draw a resize gripper of a pop-up bar.
- Public Member Functions inherited from CXTPPaintManager
virtual void | SetImageHandle (HMODULE hResource, LPCTSTR lpszIniFileName)
Specifies the resource that contains the bitmaps to be loaded for the theme.
CSize | DrawControl (CDC *pDC, CXTPControl *pButton, BOOL bDraw=TRUE)
This method is called to draw the control.
virtual CSize | DrawControlToolBarParent (CDC *pDC, CXTPControl *pButton, BOOL bDraw)
This method is called to draw the control placed on the toolbar.
virtual COLORREF | GetControlEditBackColor (CXTPControl *pControl)
This method returns the edit control back color to draw.
virtual void | DrawControlEntry (CDC *pDC, CXTPControl *pButton)
This method is called to fill the control's face.
virtual COLORREF | GetControlTextColor (CXTPControl *pButton)
Call this method to get the control text color to draw.
virtual COLORREF | GetControlBackColor (CXTPControl *pButton)
Call this method to get the control back color to draw.
virtual void | DrawGalleryItemBack (CDC *pDC, CRect rcItem, BOOL bEnabled, BOOL bSelected, BOOL bPressed, BOOL bChecked, XTPBarType barType)
This method is called to draw the background for a gallery menu item.
virtual void | DrawCommandBarGroupSeparator (CDC *pDC, CXTPCommandBar *pBar, CXTPControl *pLeftControl, CXTPControl *pRightControl, BOOL bDraw=TRUE)
This method is called to draw a command bar's group separator.
virtual void | FillWorkspace (CDC *pDC, CRect rc, CRect rcExclude)
This method is called to fill a workspace.
int | GetShadowOptions () const
Determines the kind of shadow to use.
virtual void | DrawExpandGlyph (CDC *pDC, CXTPControl *pButton, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clr)
Draw expand or hidden glyphs for a button.
virtual void | DrawExpandGlyph (CDC *pDC, CXTPControl *pButton, COLORREF clr, BOOL bVertical)
Draw expand or hidden glyphs for a button.
virtual void | DrawHiddenGlyph (CDC *pDC, CXTPControl *pButton, COLORREF clr, BOOL bVertical)
Draw expand or hidden glyphs for a button.
virtual CRect | GetSplitButtonCommandRect (CXTPControl *pButton)
Determines split button command rectangle.
virtual void | SetCommandBarRegion (CXTPCommandBar *pCommandBar)
Call this method to set the bounding region of a pop-up bar.
XTPPaintTheme GetCurrentTheme ()
Call this member to get the current visual theme.
virtual BOOL | RequiresResourceImages ()
Used by the paint manager to determine if the theme requires a resource DLL to load image and color information.
virtual CFont * | GetControlFont (CXTPControl *pControl)
Call this member to retrieve the font of the command bar control.
virtual CFont * | GetCommandBarFont (CXTPCommandBar *pCommandBar)
Call this member to retrieve the font of the command bar.
virtual XTPBarTextOrientation | GetControlTextOrientation (CXTPControl *pControl)
Call this member to determine how to draw text.
virtual void | UpdateFonts ()
Refreshes the fonts to use.
virtual void | UpdateColors ()
Refreshes the standard colors to use.
void | SetCommandBarsFontIndirect (LOGFONT *pLogFont, BOOL bUseStandardFont=FALSE)
Call this member to set command bar's font.
CFont * | GetRegularFont ()
Returns the general font.
CFont * | GetRegularBoldFont ()
Returns the general bold font.
CFont * | GetIconFont ()
Returns the icon font.
CFont * | GetSmCaptionFont ()
Call this method to retrieve the caption of a floating mini frame.
void | UseOfficeFont (bool bUseOfficeFont)
Call this method to use Tahoma font despite system metrics.
int | GetControlHeight () const
This method returns the common controls height.
virtual CSize | GetDefaultCommandBarSize (CXTPCommandBar *pBar)
Computes default command bar size taking into account command bar font.
void | Rectangle (CDC *pDC, LPCRECT rc, int nPen, const int nBrush)
Draws a rectangle.
void | Rectangle (CDC *pDC, LPCRECT rc, COLORREF clrPen, COLORREF clrBrush)
Draws a rectangle.
void | RoundRect (CDC *pDC, LPCRECT rc, COLORREF clrPen, COLORREF clrBrush)
Draws a rectangle.
void | Draw3dRect (CDC *pDC, LPCRECT rc, int nTopLeft, int nBottomRight)
Call this member function to draw a three-dimensional rectangle.
void | Draw3dRect (CDC *pDC, LPCRECT rc, int frameThickness, COLORREF clrPen, COLORREF clrBrush)
Call this member function to draw a rectangle with predetermined thickness.
virtual void | DrawPopupBarCheckMark (CDC *pDC, CRect rcCheck, BOOL bEnabled, COLORREF clr)
Call this member function to draw a check mark.
void | DrawCheckMark (CDC *pDC, CRect rcCheck, COLORREF clr=0)
Call this member function to draw a check mark.
virtual void | DrawPopupBarRadioMark (CDC *pDC, CRect rcCheck, BOOL bEnabled, COLORREF clr)
Call this member function to draw a radio button.
virtual void | DrawComboExpandMark (CDC *pDC, CRect rc, COLORREF clr)
Call this member function to draw a combobox expand symbol.
virtual void | DrawControlMDIButton (CDC *pDC, CXTPControlButton *pButton)
Call this member function to draw menu MDI buttons.
void | Line (CDC *pDC, CPoint p0, CPoint p1)
Draws a line.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1, const int nPen)
Draws a line.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1, COLORREF clrPen)
Draws a line.
void | HorizontalLine (CDC *pDC, int x0, int y0, int x1, COLORREF clrPen)
Call this member function to draw a horizontal line using the specified coordinages and RGB color value.
void | VerticalLine (CDC *pDC, int x0, int y0, int y1, COLORREF clrPen)
Call this member function to draw a vertical line using the specified coordinages and RGB color value.
virtual void | DrawDropDownGlyph (CDC *pDC, CXTPControl *pControl, CPoint pt, BOOL bSelected, BOOL bPopuped, BOOL bEnabled, BOOL bVert)
This member function is called to draw a split button expand symbol.
void | Pixel (CDC *pDC, int xPos, int yPos, int nPen)
Sets the pixel at the point.
void | GradientFill (CDC *pDC, LPRECT lpRect, COLORREF crFrom, COLORREF crTo, BOOL bHorz, LPCRECT lpRectClip=NULL)
Gradient fills the rectangle.
XTP_COMMANDBARS_ICONSINFO * GetIconsInfo ()
virtual void | Animate (CDC *pDestDC, CDC *pSrcDC, CRect rc, XTPAnimationType animationType)
This method is called to animate the pop-up bar.
virtual void | AnimateExpanding (CXTPCommandBar *pCommandBar, CDC *pDestDC, CDC *pSrcDC, BOOL bExpandDown)
This method is called to animate the expanding process.
void | SetAnimationDelay (int nAnimationSteps, int nAnimationTime)
Call this method to set animation delay.
COLORREF | GetXtremeColor (UINT nIndex)
This function retrieves the current color of the specified XP display element.
void | SetColors (int cElements, CONST INT *lpaElements, CONST COLORREF *lpaRgbValues)
Call this member to set the colors for each element to the color in the specified color array.
CSize | DrawControlText (CDC *pDC, CXTPControl *pControl, CRect rcText, BOOL bDraw, BOOL bVert, BOOL bCentered, BOOL bTriangled)
This method is called to draw control text.
virtual void | UpdateRTLCaption (CString &strCaption)
This method is called to prepare a caption for Right-To-Left draw.
XTPCurrentSystemTheme GetCurrentSystemTheme ()
Call this member function to determine the current Windows XP theme in use.
void | SetLunaTheme (XTPCurrentSystemTheme systemTheme)
Call this method to force system theme.
virtual int | GetPopupBarGripperWidth (CXTPCommandBar *pBar)
Calculates the gripper of a pop-up bar.
virtual CXTPControlGalleryPaintManager * | GetGalleryPaintManager () const
Retrieves paint manager used to draw galleries.
virtual CXTPScrollBarPaintManager * | GetScrollBarPaintManager () const
Retrieves paint manager used to draw scrollbars.
virtual CXTPSliderPaintManager * | GetSliderPaintManager () const
Retrieves paint manager used to draw slider panes.
virtual CXTPProgressPaintManager * | GetProgressPaintManager () const
Retrieves paint manager used to draw progress bars.
virtual CXTPFramePaintManager * | GetFramePaintManager ()
Retrieves paint manager used to draw frames.
virtual CXTPStatusBarPaintManager * | GetStatusBarPaintManager ()
Retrieves paint manager used to draw the status bar.
virtual CXTPRibbonPaintManager * | GetRibbonPaintManager ()
Retrieves the ribbon paint manager.
virtual CXTPMessageBarPaintManager * | GetMessageBarPaintManager ()
Retrieves paint manager used to draw message bars.
CXTPShadowManager * | GetShadowManager () const
Retrieves shadow manager used to draw shadows.
BOOL | IsUseSystemAccentColorEnabled () const
Determines whether xtpApplicationUseSystemAccentColor application ambient property is set.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.
- Public Member Functions inherited from CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents >
void | Subscribe (IXTPPaintManagerEvents *pObserver, CXTPSubscriptionList< CXTPPaintManager, IXTPPaintManagerEvents > *pSubcriptionList=NULL)
Subscribes a unique observer for events.
void | Unsubscribe (IXTPPaintManagerEvents *pObserver)
Unsubscribes an observer from events.
void | Notify (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *))
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *))
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCommandBarsOffice2003Theme
static HBITMAP AFX_CDECL | GetModernBitmap (UINT nIDResource)
Loads bitmap specified by nIDResource and converts its colors.
static BOOL AFX_CDECL | LoadModernToolbarIcons (UINT nIDResource)
Loads bitmap specified by nIDResource and adds it to ImageManager.
static BOOL AFX_CDECL | LoadModernToolbarIcons (UINT nIDResource, UINT *pCommands, int nCount, CSize szIcon=CSize(16, 15))
Loads bitmap specified by nIDResource and adds it to ImageManager.
- Static Public Member Functions inherited from CXTPPaintManager
static CXTPPaintManager *AFX_CDECL | GetInstanceAddRef ()
Obtains a pointer to a global paint manager object and increments its reference counter.
static void AFX_CDECL | ReleaseInstance ()
Decrements global paint manager's reference counter and deletes its instance when the reference counter reaches 0.
static CXTPPaintManager *AFX_CDECL | CreateTheme (XTPPaintTheme paintTheme)
Creates a new CXTPPaintManager object.
static void AFX_CDECL | SetTheme (XTPPaintTheme paintTheme)
Call this member to switch the visual theme of the Command Bars.
static void AFX_CDECL | SetCustomTheme (CXTPPaintManager *pTheme)
Call this member to set a custom theme.
static void AFX_CDECL | Triangle (CDC *pDC, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clr)
Draws a triangle.
static BOOL AFX_CDECL | FontExists (LPCTSTR lpszFaceName)
Determines if a specified font exists in the system.
static void AFX_CDECL | StripMnemonics (CString &strClear)
This member function will search a string, strip off the mnemonic '&', and reformat the string.
static CXTPPaintManager *AFX_CDECL | GetGlobalPaintManager ()
Call this method to get the pointer to the global paint manager.
static void AFX_CDECL | SetGlobalPaintManager (CXTPPaintManager *pPaintManager)
Call this method to set the pointer to the global paint manager.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPCommandBarsOffice2003Theme
CXTPPaintManagerColorGradient | m_clrDockBar
Color of dockbar face.
CXTPPaintManagerColorGradient | m_clrCommandBar
Color of commandbar face.
CXTPPaintManagerColorGradient | m_clrToolbarExpand
Toolbar Expand button color.
CXTPPaintManagerColorGradient | m_clrMenuExpand
MenuBar Expand button color.
CXTPPaintManagerColorGradient | m_clrMenuExpandedGripper
Color of pop-up bar gripper.
CXTPPaintManagerColorGradient | m_clrMenuGripper
Color of the pop-up menu gripper.
CXTPPaintManagerColorGradient | m_clrPopupControl
color of pop-up control
CXTPPaintManagerColor | m_clrToolbarShadow
Toolbar bottom shadow color.
CXTPPaintManagerColor | m_clrTearOffGripper
TearOff gripper color.
BOOL | m_bLunaTheme
TRUE if luna theme is active.
BOOL | m_bPlainSeparators
TRUE to draw plain separators.
CImageList | m_ilGradientCircle
Gradient circle holder.
CXTPPaintManagerColorGradient | m_grcLunaChecked
Background color of checked button.
CXTPPaintManagerColorGradient | m_grcLunaPushed
Background color of pushed button.
CXTPPaintManagerColorGradient | m_grcLunaSelected
Background color of selected button.
- Public Attributes inherited from CXTPPaintManager
COLORREF | m_clrMessageBarText
Message bar text color.
CRect | m_rcMessageBarMargin
Margin of the message bar.
CXTPFramePaintManager * | m_pFramePaintManager
Frame paint manager.
CXTPStatusBarPaintManager * | m_pStatusBarPaintManager
Paint manager of the status bar.
CXTPRibbonPaintManager * | m_pRibbonPaintManager
Ribbon paint Manager.
CXTPControlGalleryPaintManager * | m_pGalleryPaintManager
Gallery paint manager.
CXTPProgressPaintManager * | m_pProgressPaintManager
Progress bar paint manager.
CXTPSliderPaintManager * | m_pSliderPaintManager
Slider pane paint manager.
CXTPScrollBarPaintManager * | m_pScrollBarPaintManager
Scrollbar paint manager.
CXTPPaintManagerColorGradient | m_clrDisabledIcon
Disabled icons color.
CXTPPaintManagerColor | m_clrFloatingGripper
Gripper color of floating toolbar.
CXTPPaintManagerColor | m_clrFloatingGripperText
Gripper text color of floating toolbar.
BOOL | m_bThickCheckMark
TRUE to draw thick check mark.
BOOL | m_bShowShadow
TRUE to show shadow.
BOOL | m_bThemedStatusBar
TRUE to draw status bar using WinXP theme.
BOOL | m_bThemedCheckBox
TRUE to draw check box using WinXP theme.
BOOL | m_bClearTypeTextQuality
TRUE to enable ClearType text for the font.
BOOL | m_bFlatToolBar
TRUE to draw toolbars flat.
BOOL | m_bFlatMenuBar
TRUE to draw menubar flat.
int | m_nPopupBarTextPadding
Distance between gripper and control text.
BOOL | m_bSelectImageInPopupBar
TRUE to select image as in explorer theme.
BOOL | m_bEnableAnimation
TRUE to enable animation for all toolbars.
BOOL | m_bOffice2007Padding
TRUE if Office2007 metrics used.
BOOL | m_bOffsetPopupLabelText
TRUE if labels in pop-ups drawn with offset.
BOOL | m_bWrapCaptionBelowText
Wrap text for xtpButtonIconAndCaptionBelow buttons.
CXTPPaintManagerFont | m_fontSmCaption
Small caption font.
CXTPPaintManagerFont | m_fontIcon
Icon font.
CXTPPaintManagerFont | m_fontIconBold
Icon bold font.
CXTPPaintManagerFont | m_fontToolTip
Tooltip font.
int | m_nSplitButtonDropDownWidth
Split button drop down width in toolbars.
int | m_nSplitButtonDropDownHeight
Split button drop down height in toolbars.
int | m_nSplitButtonPopupWidth
Split button drop down width in pop-ups.
BOOL | m_bAutoResizeIcons
TRUE to automatically resize icons using current DPI.
int | m_nStatusBarMinHeight
Minimum height for the status bar.
PVOID | m_pfnSetLayeredWindowAttributes
point to Transparency proc in USER32.dll module.
CRect | m_rcStatusBarBorder
Bounding rectangle of the status bar border.
BOOL | m_bUseOfficeFont
TRUE to use Tahoma font.
CString | m_strOfficeFont
Office font.
int | m_nTextHeight
Regular text field height (not font height).
- Protected Member Functions inherited from CXTPCommandBarsOffice2003Theme
virtual void | DrawPopupBarGripper (CDC *pDC, int xPos, int yPos, int cx, int cy, BOOL bExpanded=FALSE)
This method is called to draw a pop-up bar's right gripper.
virtual void | FillDockBar (CDC *pDC, CXTPDockBar *pBar)
This method is called to fill a dockbar.
virtual void | FillCommandBarEntry (CDC *pDC, CXTPCommandBar *pBar)
This method is called to fill the command bar's face.
virtual CSize | DrawCommandBarSeparator (CDC *pDC, CXTPCommandBar *pBar, CXTPControl *pControl, BOOL bDraw=TRUE)
This method is called to draw a command bar's separator.
virtual CSize | DrawCommandBarGripper (CDC *pDC, CXTPCommandBar *pBar, BOOL bDraw=TRUE)
This method is called to draw the command bar's gripper.
virtual void | DrawRectangle (CDC *pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition)
This method is called to fill the control's face.
virtual void | DrawRectangle (CDC *pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition, int nID)
This method is called to fill the control's face.
virtual BOOL | DrawRectangle (CDC *pDC, CXTPControl *pButton)
This method is called to fill the control's face.
virtual CSize | DrawSpecialControl (CDC *pDC, XTPSpecialControl controlType, CXTPControl *pButton, CXTPCommandBar *pBar, BOOL bDraw, LPVOID lpParam)
This method is called to draw the specified controls.
virtual CRect | GetCommandBarBorders (CXTPCommandBar *pBar)
This method is called to retrieve the command bar's borders.
virtual CSize | DrawTearOffGripper (CDC *pDC, CRect rcGripper, BOOL bSelected, BOOL bDraw)
This method is called to draw the tear-off gripper of a pop-up bar.
virtual CSize | DrawDialogBarGripper (CDC *pDC, CXTPDialogBar *pBar, BOOL bDraw)
Call this member to draw the gripper of a dialog bar.
void | CreateGradientCircle ()
Generates an expanded bitmap used for CXTPPopupBar.
virtual BOOL | HasFloatingBarGradientEntry (CXTPCommandBar *pBar)
Returns TRUE if a floating toolbar is drawn with a gradient background.
- Protected Member Functions inherited from CXTPCommandBarsOfficeXPTheme
virtual CSize | DrawControlPopupParent (CDC *pDC, CXTPControl *pButton, BOOL bDraw)
This method is called to draw the control placed on the pop-up bar.
virtual void | DrawImage (CDC *pDC, CPoint pt, CSize sz, CXTPImageManagerIcon *pImage, BOOL bSelected, BOOL bPressed, BOOL bEnabled=TRUE, BOOL bChecked=FALSE, BOOL bPopuped=FALSE, BOOL bToolBarImage=TRUE)
This method is called to draw the image of the control.
virtual CSize | DrawControlComboBox (CDC *pDC, CXTPControlComboBox *pComboBox, BOOL bDraw)
This method is called to draw the control.
virtual CSize | DrawControlEdit (CDC *pDC, CXTPControlEdit *pEdit, BOOL bDraw)
This method is called to draw the control.
void | FillIntersectRect (CDC *pDC, CXTPPopupBar *pPopupBar, COLORREF clr)
Draws intersect rectangle of a pop-up bar and its control.
virtual void | DrawSplitButtonFrame (CDC *pDC, CXTPControl *pButton, CRect rc)
This method is called to draw the frame for the SplitButton control.
virtual CSize | DrawControlCheckBoxMark (CDC *pDC, CRect rc, BOOL bDraw, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled)
This method is called to draw a check box mark area.
virtual CSize | DrawControlCheckBoxMark (CDC *pDC, CXTPControl *pButton, CRect rc, BOOL bDraw)
This method is called to draw a check box mark area.
virtual CSize | DrawControlRadioButtonMark (CDC *pDC, CRect rc, BOOL bDraw, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled)
This method is called to draw a radio button mark area.
- Protected Member Functions inherited from CXTPPaintManager
CXTPPaintManager ()
Constructs a CXTPPaintManager object.
virtual | ~CXTPPaintManager ()
Destroys a CXTPPaintManager object, handles cleanup and deallocation.
- Protected Member Functions inherited from CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents >
CXTPObservable ()
Constructs an observable object.
~CXTPObservable ()
Handles observable object destruction.
- Protected Attributes inherited from CXTPPaintManager
CXTPFont | m_xtpFontRegular
Regular font.
CXTPFont | m_xtpFontRegularBold
Regular bold font.
CXTPFont | m_xtpFontVert
Vertical font.
CXTPFont | m_xtpFontVertBold
Vertical font.
int | m_nEditHeight
Edit text height.
int | m_nFontHeight
Custom font height (optional).
BOOL | m_bUseStandardFont
TRUE to use system font.
BOOL | m_bEmbossedDisabledText
TRUE to draw disabled text embossed.
CXTPWinThemeWrapper * | m_themeStatusBar
StatusBar theme helper.
CXTPWinThemeWrapper * | m_themeButton
Buttons theme helper.
XTPPaintTheme | m_themeCurrent
Current theme.
XTP_COMMANDBARS_ICONSINFO | m_iconsInfo
Specific icons options.
int | m_nAnimationSteps
Steps of the animation.
int | m_nAnimationTime
Time of the animation.
BOOL | m_bShowKeyboardCues
TRUE to show keyboard cues - deprecated.
CXTPPaintManagerColor | m_arrColor [XPCOLOR_LAST+1]
Self colors array.
XTPCurrentSystemTheme | m_systemTheme
Current system theme.
CXTPShadowManager * | m_pShadowManager
Shadow manager.

Detailed Description

The CXTPVisualStudio2005Theme class is used to enable a Visual Studio 2005 style theme for Command Bars.

See also
CXTPPaintManager::SetTheme

Member Function Documentation

◆ BaseTheme()

virtual XTPPaintTheme BaseTheme ( )
inlinevirtual

Retrieves the base theme of the manager.

Returns
Base theme of the manager.

Reimplemented from CXTPCommandBarsOffice2003Theme.

Reimplemented in CXTPVisualStudio2008Theme.

The documentation for this class was generated from the following file:
  • XTPCommandBarsVisualStudio2005Theme.h


Toolkit Pro: CXTPVisualStudio2008Theme Class Reference

Public Member Functions | Static Public Member Functions | Public Attributes | List of all members
CXTPVisualStudio2008Theme Class Reference

The CXTPVisualStudio2008Theme class is used to enable a Visual Studio 2008 style theme for Command Bars. More...

Inheritance diagram for CXTPVisualStudio2008Theme:
[legend]

Public Member Functions

CXTPVisualStudio2008Theme ()
Constructs a CXTPVisualStudio2008Theme object.
virtual | ~CXTPVisualStudio2008Theme ()
Destroys a CXTPVisualStudio2008Theme object, handles cleanup and deallocation.
void | RefreshMetrics ()
This method is called to refresh the visual metrics of the manager.
virtual CRect | GetCommandBarBorders (CXTPCommandBar *pBar)
This method is called to retrieve the command bar's borders.
virtual void | DrawPopupBarGripper (CDC *pDC, int xPos, int yPos, int cx, int cy, BOOL bExpanded)
This method is called to draw a pop-up bar's right gripper.
virtual void | DrawRectangle (CDC *pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition)
This method is called to fill the control's face.
virtual void | DrawRectangle (CDC *pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition, int nID)
This method is called to fill the control's face.
virtual BOOL | DrawRectangle (CDC *pDC, CXTPControl *pButton)
This method is called to fill the control's face.
virtual COLORREF | GetRectangleTextColor (BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition)
This method retrieves a button's text color.
virtual void | AdjustExcludeRect (CRect &rc, CXTPControl *pControl, BOOL bVertical)
This method is called to determine the offset of a pop-up bar.
virtual CSize | DrawCommandBarSeparator (CDC *pDC, CXTPCommandBar *pBar, CXTPControl *pControl, BOOL bDraw)
This method is called to draw a command bar's separator.
virtual XTPPaintTheme | BaseTheme ()
Retrieves the base theme of the manager.
- Public Member Functions inherited from CXTPVisualStudio2005Theme
CXTPVisualStudio2005Theme ()
Constructs a CXTPVisualStudio2005Theme object.
virtual | ~CXTPVisualStudio2005Theme ()
Destroys a CXTPVisualStudio2005Theme object, handles cleanup and deallocation.
- Public Member Functions inherited from CXTPCommandBarsOffice2003Theme
CXTPCommandBarsOffice2003Theme ()
Constructs a CXTPCommandBarsOffice2003Theme object.
virtual | ~CXTPCommandBarsOffice2003Theme ()
Destroys a CXTPCommandBarsOffice2003Theme object, handles cleanup and deallocation.
void | ExcludeCorners (CDC *pDC, CRect rc)
This method creates a new clipping region that consists of the existing clipping region minus the corners rectangles.
- Public Member Functions inherited from CXTPCommandBarsOfficeXPTheme
CXTPCommandBarsOfficeXPTheme ()
Constructs a CXTPCommandBarsOfficeXPTheme object.
virtual CSize | DrawListBoxControl (CDC *pDC, CXTPControl *pButton, CRect rc, BOOL bSelected, BOOL bDraw, CXTPCommandBars *pCommandBars=0)
This method is called to draw the control placed on the ListBox.
virtual void | DrawPopupResizeGripper (CDC *pDC, CRect rcGripper, int nFlags)
This method is called to draw a resize gripper of a pop-up bar.
- Public Member Functions inherited from CXTPPaintManager
virtual void | SetImageHandle (HMODULE hResource, LPCTSTR lpszIniFileName)
Specifies the resource that contains the bitmaps to be loaded for the theme.
CSize | DrawControl (CDC *pDC, CXTPControl *pButton, BOOL bDraw=TRUE)
This method is called to draw the control.
virtual CSize | DrawControlToolBarParent (CDC *pDC, CXTPControl *pButton, BOOL bDraw)
This method is called to draw the control placed on the toolbar.
virtual COLORREF | GetControlEditBackColor (CXTPControl *pControl)
This method returns the edit control back color to draw.
virtual void | DrawControlEntry (CDC *pDC, CXTPControl *pButton)
This method is called to fill the control's face.
virtual COLORREF | GetControlTextColor (CXTPControl *pButton)
Call this method to get the control text color to draw.
virtual COLORREF | GetControlBackColor (CXTPControl *pButton)
Call this method to get the control back color to draw.
virtual void | DrawGalleryItemBack (CDC *pDC, CRect rcItem, BOOL bEnabled, BOOL bSelected, BOOL bPressed, BOOL bChecked, XTPBarType barType)
This method is called to draw the background for a gallery menu item.
virtual void | DrawCommandBarGroupSeparator (CDC *pDC, CXTPCommandBar *pBar, CXTPControl *pLeftControl, CXTPControl *pRightControl, BOOL bDraw=TRUE)
This method is called to draw a command bar's group separator.
virtual void | FillWorkspace (CDC *pDC, CRect rc, CRect rcExclude)
This method is called to fill a workspace.
int | GetShadowOptions () const
Determines the kind of shadow to use.
virtual void | DrawExpandGlyph (CDC *pDC, CXTPControl *pButton, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clr)
Draw expand or hidden glyphs for a button.
virtual void | DrawExpandGlyph (CDC *pDC, CXTPControl *pButton, COLORREF clr, BOOL bVertical)
Draw expand or hidden glyphs for a button.
virtual void | DrawHiddenGlyph (CDC *pDC, CXTPControl *pButton, COLORREF clr, BOOL bVertical)
Draw expand or hidden glyphs for a button.
virtual CRect | GetSplitButtonCommandRect (CXTPControl *pButton)
Determines split button command rectangle.
virtual void | SetCommandBarRegion (CXTPCommandBar *pCommandBar)
Call this method to set the bounding region of a pop-up bar.
XTPPaintTheme GetCurrentTheme ()
Call this member to get the current visual theme.
virtual BOOL | RequiresResourceImages ()
Used by the paint manager to determine if the theme requires a resource DLL to load image and color information.
virtual CFont * | GetControlFont (CXTPControl *pControl)
Call this member to retrieve the font of the command bar control.
virtual CFont * | GetCommandBarFont (CXTPCommandBar *pCommandBar)
Call this member to retrieve the font of the command bar.
virtual XTPBarTextOrientation | GetControlTextOrientation (CXTPControl *pControl)
Call this member to determine how to draw text.
virtual void | UpdateFonts ()
Refreshes the fonts to use.
virtual void | UpdateColors ()
Refreshes the standard colors to use.
void | SetCommandBarsFontIndirect (LOGFONT *pLogFont, BOOL bUseStandardFont=FALSE)
Call this member to set command bar's font.
CFont * | GetRegularFont ()
Returns the general font.
CFont * | GetRegularBoldFont ()
Returns the general bold font.
CFont * | GetIconFont ()
Returns the icon font.
CFont * | GetSmCaptionFont ()
Call this method to retrieve the caption of a floating mini frame.
void | UseOfficeFont (bool bUseOfficeFont)
Call this method to use Tahoma font despite system metrics.
int | GetControlHeight () const
This method returns the common controls height.
virtual CSize | GetDefaultCommandBarSize (CXTPCommandBar *pBar)
Computes default command bar size taking into account command bar font.
void | Rectangle (CDC *pDC, LPCRECT rc, int nPen, const int nBrush)
Draws a rectangle.
void | Rectangle (CDC *pDC, LPCRECT rc, COLORREF clrPen, COLORREF clrBrush)
Draws a rectangle.
void | RoundRect (CDC *pDC, LPCRECT rc, COLORREF clrPen, COLORREF clrBrush)
Draws a rectangle.
void | Draw3dRect (CDC *pDC, LPCRECT rc, int nTopLeft, int nBottomRight)
Call this member function to draw a three-dimensional rectangle.
void | Draw3dRect (CDC *pDC, LPCRECT rc, int frameThickness, COLORREF clrPen, COLORREF clrBrush)
Call this member function to draw a rectangle with predetermined thickness.
virtual void | DrawPopupBarCheckMark (CDC *pDC, CRect rcCheck, BOOL bEnabled, COLORREF clr)
Call this member function to draw a check mark.
void | DrawCheckMark (CDC *pDC, CRect rcCheck, COLORREF clr=0)
Call this member function to draw a check mark.
virtual void | DrawPopupBarRadioMark (CDC *pDC, CRect rcCheck, BOOL bEnabled, COLORREF clr)
Call this member function to draw a radio button.
virtual void | DrawComboExpandMark (CDC *pDC, CRect rc, COLORREF clr)
Call this member function to draw a combobox expand symbol.
virtual void | DrawControlMDIButton (CDC *pDC, CXTPControlButton *pButton)
Call this member function to draw menu MDI buttons.
void | Line (CDC *pDC, CPoint p0, CPoint p1)
Draws a line.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1, const int nPen)
Draws a line.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1, COLORREF clrPen)
Draws a line.
void | HorizontalLine (CDC *pDC, int x0, int y0, int x1, COLORREF clrPen)
Call this member function to draw a horizontal line using the specified coordinages and RGB color value.
void | VerticalLine (CDC *pDC, int x0, int y0, int y1, COLORREF clrPen)
Call this member function to draw a vertical line using the specified coordinages and RGB color value.
virtual void | DrawDropDownGlyph (CDC *pDC, CXTPControl *pControl, CPoint pt, BOOL bSelected, BOOL bPopuped, BOOL bEnabled, BOOL bVert)
This member function is called to draw a split button expand symbol.
void | Pixel (CDC *pDC, int xPos, int yPos, int nPen)
Sets the pixel at the point.
void | GradientFill (CDC *pDC, LPRECT lpRect, COLORREF crFrom, COLORREF crTo, BOOL bHorz, LPCRECT lpRectClip=NULL)
Gradient fills the rectangle.
XTP_COMMANDBARS_ICONSINFO * GetIconsInfo ()
virtual void | Animate (CDC *pDestDC, CDC *pSrcDC, CRect rc, XTPAnimationType animationType)
This method is called to animate the pop-up bar.
virtual void | AnimateExpanding (CXTPCommandBar *pCommandBar, CDC *pDestDC, CDC *pSrcDC, BOOL bExpandDown)
This method is called to animate the expanding process.
void | SetAnimationDelay (int nAnimationSteps, int nAnimationTime)
Call this method to set animation delay.
COLORREF | GetXtremeColor (UINT nIndex)
This function retrieves the current color of the specified XP display element.
void | SetColors (int cElements, CONST INT *lpaElements, CONST COLORREF *lpaRgbValues)
Call this member to set the colors for each element to the color in the specified color array.
CSize | DrawControlText (CDC *pDC, CXTPControl *pControl, CRect rcText, BOOL bDraw, BOOL bVert, BOOL bCentered, BOOL bTriangled)
This method is called to draw control text.
virtual void | UpdateRTLCaption (CString &strCaption)
This method is called to prepare a caption for Right-To-Left draw.
XTPCurrentSystemTheme GetCurrentSystemTheme ()
Call this member function to determine the current Windows XP theme in use.
void | SetLunaTheme (XTPCurrentSystemTheme systemTheme)
Call this method to force system theme.
virtual int | GetPopupBarGripperWidth (CXTPCommandBar *pBar)
Calculates the gripper of a pop-up bar.
virtual CXTPControlGalleryPaintManager * | GetGalleryPaintManager () const
Retrieves paint manager used to draw galleries.
virtual CXTPScrollBarPaintManager * | GetScrollBarPaintManager () const
Retrieves paint manager used to draw scrollbars.
virtual CXTPSliderPaintManager * | GetSliderPaintManager () const
Retrieves paint manager used to draw slider panes.
virtual CXTPProgressPaintManager * | GetProgressPaintManager () const
Retrieves paint manager used to draw progress bars.
virtual CXTPFramePaintManager * | GetFramePaintManager ()
Retrieves paint manager used to draw frames.
virtual CXTPStatusBarPaintManager * | GetStatusBarPaintManager ()
Retrieves paint manager used to draw the status bar.
virtual CXTPRibbonPaintManager * | GetRibbonPaintManager ()
Retrieves the ribbon paint manager.
virtual CXTPMessageBarPaintManager * | GetMessageBarPaintManager ()
Retrieves paint manager used to draw message bars.
CXTPShadowManager * | GetShadowManager () const
Retrieves shadow manager used to draw shadows.
BOOL | IsUseSystemAccentColorEnabled () const
Determines whether xtpApplicationUseSystemAccentColor application ambient property is set.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.
- Public Member Functions inherited from CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents >
void | Subscribe (IXTPPaintManagerEvents *pObserver, CXTPSubscriptionList< CXTPPaintManager, IXTPPaintManagerEvents > *pSubcriptionList=NULL)
Subscribes a unique observer for events.
void | Unsubscribe (IXTPPaintManagerEvents *pObserver)
Unsubscribes an observer from events.
void | Notify (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *))
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *))
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.

Static Public Member Functions

static void AFX_CDECL | AlphaPixel (CDC *pDC, int xPos, int yPos, COLORREF clr, int nAlpha)
Draws pixel in specific position with specify Alpha.
static void AFX_CDECL | AlphaBorder (CDC *pDC, CRect rc, COLORREF clrBorder)
Draws a border around a specified rectangle.
- Static Public Member Functions inherited from CXTPCommandBarsOffice2003Theme
static HBITMAP AFX_CDECL | GetModernBitmap (UINT nIDResource)
Loads bitmap specified by nIDResource and converts its colors.
static BOOL AFX_CDECL | LoadModernToolbarIcons (UINT nIDResource)
Loads bitmap specified by nIDResource and adds it to ImageManager.
static BOOL AFX_CDECL | LoadModernToolbarIcons (UINT nIDResource, UINT *pCommands, int nCount, CSize szIcon=CSize(16, 15))
Loads bitmap specified by nIDResource and adds it to ImageManager.
- Static Public Member Functions inherited from CXTPPaintManager
static CXTPPaintManager *AFX_CDECL | GetInstanceAddRef ()
Obtains a pointer to a global paint manager object and increments its reference counter.
static void AFX_CDECL | ReleaseInstance ()
Decrements global paint manager's reference counter and deletes its instance when the reference counter reaches 0.
static CXTPPaintManager *AFX_CDECL | CreateTheme (XTPPaintTheme paintTheme)
Creates a new CXTPPaintManager object.
static void AFX_CDECL | SetTheme (XTPPaintTheme paintTheme)
Call this member to switch the visual theme of the Command Bars.
static void AFX_CDECL | SetCustomTheme (CXTPPaintManager *pTheme)
Call this member to set a custom theme.
static void AFX_CDECL | Triangle (CDC *pDC, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clr)
Draws a triangle.
static BOOL AFX_CDECL | FontExists (LPCTSTR lpszFaceName)
Determines if a specified font exists in the system.
static void AFX_CDECL | StripMnemonics (CString &strClear)
This member function will search a string, strip off the mnemonic '&', and reformat the string.
static CXTPPaintManager *AFX_CDECL | GetGlobalPaintManager ()
Call this method to get the pointer to the global paint manager.
static void AFX_CDECL | SetGlobalPaintManager (CXTPPaintManager *pPaintManager)
Call this method to set the pointer to the global paint manager.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Public Attributes

CXTPPaintManagerColorGradient | m_clrMenuSelection
Gradient used to draw the current menu selection.
CXTPPaintManagerColor | m_clrMenuSelectionBorder
Color used to draw the border of the current menu selection.
CXTPPaintManagerColor | m_clrMenuSelectionText
Color used to draw the text of the current menu selection.
- Public Attributes inherited from CXTPCommandBarsOffice2003Theme
CXTPPaintManagerColorGradient | m_clrDockBar
Color of dockbar face.
CXTPPaintManagerColorGradient | m_clrCommandBar
Color of commandbar face.
CXTPPaintManagerColorGradient | m_clrToolbarExpand
Toolbar Expand button color.
CXTPPaintManagerColorGradient | m_clrMenuExpand
MenuBar Expand button color.
CXTPPaintManagerColorGradient | m_clrMenuExpandedGripper
Color of pop-up bar gripper.
CXTPPaintManagerColorGradient | m_clrMenuGripper
Color of the pop-up menu gripper.
CXTPPaintManagerColorGradient | m_clrPopupControl
color of pop-up control
CXTPPaintManagerColor | m_clrToolbarShadow
Toolbar bottom shadow color.
CXTPPaintManagerColor | m_clrTearOffGripper
TearOff gripper color.
BOOL | m_bLunaTheme
TRUE if luna theme is active.
BOOL | m_bPlainSeparators
TRUE to draw plain separators.
CImageList | m_ilGradientCircle
Gradient circle holder.
CXTPPaintManagerColorGradient | m_grcLunaChecked
Background color of checked button.
CXTPPaintManagerColorGradient | m_grcLunaPushed
Background color of pushed button.
CXTPPaintManagerColorGradient | m_grcLunaSelected
Background color of selected button.
- Public Attributes inherited from CXTPPaintManager
COLORREF | m_clrMessageBarText
Message bar text color.
CRect | m_rcMessageBarMargin
Margin of the message bar.
CXTPFramePaintManager * | m_pFramePaintManager
Frame paint manager.
CXTPStatusBarPaintManager * | m_pStatusBarPaintManager
Paint manager of the status bar.
CXTPRibbonPaintManager * | m_pRibbonPaintManager
Ribbon paint Manager.
CXTPControlGalleryPaintManager * | m_pGalleryPaintManager
Gallery paint manager.
CXTPProgressPaintManager * | m_pProgressPaintManager
Progress bar paint manager.
CXTPSliderPaintManager * | m_pSliderPaintManager
Slider pane paint manager.
CXTPScrollBarPaintManager * | m_pScrollBarPaintManager
Scrollbar paint manager.
CXTPPaintManagerColorGradient | m_clrDisabledIcon
Disabled icons color.
CXTPPaintManagerColor | m_clrFloatingGripper
Gripper color of floating toolbar.
CXTPPaintManagerColor | m_clrFloatingGripperText
Gripper text color of floating toolbar.
BOOL | m_bThickCheckMark
TRUE to draw thick check mark.
BOOL | m_bShowShadow
TRUE to show shadow.
BOOL | m_bThemedStatusBar
TRUE to draw status bar using WinXP theme.
BOOL | m_bThemedCheckBox
TRUE to draw check box using WinXP theme.
BOOL | m_bClearTypeTextQuality
TRUE to enable ClearType text for the font.
BOOL | m_bFlatToolBar
TRUE to draw toolbars flat.
BOOL | m_bFlatMenuBar
TRUE to draw menubar flat.
int | m_nPopupBarTextPadding
Distance between gripper and control text.
BOOL | m_bSelectImageInPopupBar
TRUE to select image as in explorer theme.
BOOL | m_bEnableAnimation
TRUE to enable animation for all toolbars.
BOOL | m_bOffice2007Padding
TRUE if Office2007 metrics used.
BOOL | m_bOffsetPopupLabelText
TRUE if labels in pop-ups drawn with offset.
BOOL | m_bWrapCaptionBelowText
Wrap text for xtpButtonIconAndCaptionBelow buttons.
CXTPPaintManagerFont | m_fontSmCaption
Small caption font.
CXTPPaintManagerFont | m_fontIcon
Icon font.
CXTPPaintManagerFont | m_fontIconBold
Icon bold font.
CXTPPaintManagerFont | m_fontToolTip
Tooltip font.
int | m_nSplitButtonDropDownWidth
Split button drop down width in toolbars.
int | m_nSplitButtonDropDownHeight
Split button drop down height in toolbars.
int | m_nSplitButtonPopupWidth
Split button drop down width in pop-ups.
BOOL | m_bAutoResizeIcons
TRUE to automatically resize icons using current DPI.
int | m_nStatusBarMinHeight
Minimum height for the status bar.
PVOID | m_pfnSetLayeredWindowAttributes
point to Transparency proc in USER32.dll module.
CRect | m_rcStatusBarBorder
Bounding rectangle of the status bar border.
BOOL | m_bUseOfficeFont
TRUE to use Tahoma font.
CString | m_strOfficeFont
Office font.
int | m_nTextHeight
Regular text field height (not font height).

Additional Inherited Members

- Protected Member Functions inherited from CXTPCommandBarsOffice2003Theme
virtual void | FillDockBar (CDC *pDC, CXTPDockBar *pBar)
This method is called to fill a dockbar.
virtual void | FillCommandBarEntry (CDC *pDC, CXTPCommandBar *pBar)
This method is called to fill the command bar's face.
virtual CSize | DrawCommandBarGripper (CDC *pDC, CXTPCommandBar *pBar, BOOL bDraw=TRUE)
This method is called to draw the command bar's gripper.
virtual CSize | DrawSpecialControl (CDC *pDC, XTPSpecialControl controlType, CXTPControl *pButton, CXTPCommandBar *pBar, BOOL bDraw, LPVOID lpParam)
This method is called to draw the specified controls.
virtual CSize | DrawTearOffGripper (CDC *pDC, CRect rcGripper, BOOL bSelected, BOOL bDraw)
This method is called to draw the tear-off gripper of a pop-up bar.
virtual CSize | DrawDialogBarGripper (CDC *pDC, CXTPDialogBar *pBar, BOOL bDraw)
Call this member to draw the gripper of a dialog bar.
void | CreateGradientCircle ()
Generates an expanded bitmap used for CXTPPopupBar.
virtual BOOL | HasFloatingBarGradientEntry (CXTPCommandBar *pBar)
Returns TRUE if a floating toolbar is drawn with a gradient background.
- Protected Member Functions inherited from CXTPCommandBarsOfficeXPTheme
virtual CSize | DrawControlPopupParent (CDC *pDC, CXTPControl *pButton, BOOL bDraw)
This method is called to draw the control placed on the pop-up bar.
virtual void | DrawImage (CDC *pDC, CPoint pt, CSize sz, CXTPImageManagerIcon *pImage, BOOL bSelected, BOOL bPressed, BOOL bEnabled=TRUE, BOOL bChecked=FALSE, BOOL bPopuped=FALSE, BOOL bToolBarImage=TRUE)
This method is called to draw the image of the control.
virtual CSize | DrawControlComboBox (CDC *pDC, CXTPControlComboBox *pComboBox, BOOL bDraw)
This method is called to draw the control.
virtual CSize | DrawControlEdit (CDC *pDC, CXTPControlEdit *pEdit, BOOL bDraw)
This method is called to draw the control.
void | FillIntersectRect (CDC *pDC, CXTPPopupBar *pPopupBar, COLORREF clr)
Draws intersect rectangle of a pop-up bar and its control.
virtual void | DrawSplitButtonFrame (CDC *pDC, CXTPControl *pButton, CRect rc)
This method is called to draw the frame for the SplitButton control.
virtual CSize | DrawControlCheckBoxMark (CDC *pDC, CRect rc, BOOL bDraw, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled)
This method is called to draw a check box mark area.
virtual CSize | DrawControlCheckBoxMark (CDC *pDC, CXTPControl *pButton, CRect rc, BOOL bDraw)
This method is called to draw a check box mark area.
virtual CSize | DrawControlRadioButtonMark (CDC *pDC, CRect rc, BOOL bDraw, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled)
This method is called to draw a radio button mark area.
- Protected Member Functions inherited from CXTPPaintManager
CXTPPaintManager ()
Constructs a CXTPPaintManager object.
virtual | ~CXTPPaintManager ()
Destroys a CXTPPaintManager object, handles cleanup and deallocation.
- Protected Member Functions inherited from CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents >
CXTPObservable ()
Constructs an observable object.
~CXTPObservable ()
Handles observable object destruction.
- Protected Attributes inherited from CXTPPaintManager
CXTPFont | m_xtpFontRegular
Regular font.
CXTPFont | m_xtpFontRegularBold
Regular bold font.
CXTPFont | m_xtpFontVert
Vertical font.
CXTPFont | m_xtpFontVertBold
Vertical font.
int | m_nEditHeight
Edit text height.
int | m_nFontHeight
Custom font height (optional).
BOOL | m_bUseStandardFont
TRUE to use system font.
BOOL | m_bEmbossedDisabledText
TRUE to draw disabled text embossed.
CXTPWinThemeWrapper * | m_themeStatusBar
StatusBar theme helper.
CXTPWinThemeWrapper * | m_themeButton
Buttons theme helper.
XTPPaintTheme | m_themeCurrent
Current theme.
XTP_COMMANDBARS_ICONSINFO | m_iconsInfo
Specific icons options.
int | m_nAnimationSteps
Steps of the animation.
int | m_nAnimationTime
Time of the animation.
BOOL | m_bShowKeyboardCues
TRUE to show keyboard cues - deprecated.
CXTPPaintManagerColor | m_arrColor [XPCOLOR_LAST+1]
Self colors array.
XTPCurrentSystemTheme | m_systemTheme
Current system theme.
CXTPShadowManager * | m_pShadowManager
Shadow manager.

Detailed Description

The CXTPVisualStudio2008Theme class is used to enable a Visual Studio 2008 style theme for Command Bars.

See also
CXTPPaintManager::SetTheme

Member Function Documentation

◆ AdjustExcludeRect()

virtual void AdjustExcludeRect | ( | CRect & | rc,
 |  | CXTPControl * | pControl,
 |  | BOOL | bVertical )
 virtual

This method is called to determine the offset of a pop-up bar.

Parameters
rc | Control's bounding rectangle.
pControl | Pointer to a CXTPControl object.
bVertical | TRUE if the control is docked vertically.

Reimplemented from CXTPCommandBarsOfficeXPTheme.

◆ AlphaBorder()

static void AFX_CDECL AlphaBorder | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | COLORREF | clrBorder )
 static

Draws a border around a specified rectangle.

Parameters
pDC | Pointer to a valid device context.
rc | Rectangle with the border to be drawn.
clrBorder | Color of the border to be drawn.
Returns

◆ AlphaPixel()

static void AFX_CDECL AlphaPixel | ( | CDC * | pDC,
 |  | int | xPos,
 |  | int | yPos,
 |  | COLORREF | clr,
 |  | int | nAlpha )
 static

Draws pixel in specific position with specify Alpha.

Parameters
pDC | Pointer to a valid device context.
xPos | Position to draw.
yPos | Position to draw.
clr | Color of pixel to draw.
nAlpha | Opacity of pixel.
Returns

◆ BaseTheme()

virtual XTPPaintTheme BaseTheme ( )
inlinevirtual

Retrieves the base theme of the manager.

Returns
The base theme of the manager.

Reimplemented from CXTPVisualStudio2005Theme.

◆ DrawCommandBarSeparator()

virtual CSize DrawCommandBarSeparator | ( | CDC * | pDC,
 |  | CXTPCommandBar * | pBar,
 |  | CXTPControl * | pControl,
 |  | BOOL | bDraw )
 virtual

This method is called to draw a command bar's separator.

Parameters
pDC | Pointer to a valid device context.
pBar | Pointer to a CXTPCommandBar object.
pControl | Pointer to a CXTPControl object.
bDraw | TRUE to draw; FALSE to retrieve the size of the separator.
Returns
Size of the separator.

Reimplemented from CXTPCommandBarsOffice2003Theme.

◆ DrawPopupBarGripper()

virtual void DrawPopupBarGripper | ( | CDC * | pDC,
 |  | int | xPos,
 |  | int | yPos,
 |  | int | cx,
 |  | int | cy,
 |  | BOOL | bExpanded )
 virtual

This method is called to draw a pop-up bar's right gripper.

Parameters
pDC | Pointer to a valid device context.
xPos | Specifies the logical x coordinate of the upper-left corner of the rectangle.
yPos | Specifies the logical y coordinate of the upper-left corner of the destination rectangle.
cx | Specifies the width of the rectangle.
cy | Specifies the height of the rectangle.
bExpanded | TRUE if expanded.

Reimplemented from CXTPCommandBarsOffice2003Theme.

◆ DrawRectangle() [1/3]

virtual void DrawRectangle | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | BOOL | bSelected,
 |  | BOOL | bPressed,
 |  | BOOL | bEnabled,
 |  | BOOL | bChecked,
 |  | BOOL | bPopuped,
 |  | XTPBarType | barType,
 |  | XTPBarPosition | barPosition )
 virtual

This method is called to fill the control's face.

Parameters
pDC | Pointer to a valid device context.
rc | Rectangle to draw.
bSelected | TRUE if the control is selected.
bPressed | TRUE if the control is pushed.
bEnabled | TRUE if the control is enabled.
bChecked | TRUE if the control is checked.
bPopuped | TRUE if the control is pop-up'ed.
barType | Parent's bar type.
barPosition | Parent's bar position.

Reimplemented from CXTPCommandBarsOffice2003Theme.

◆ DrawRectangle() [2/3]

virtual void DrawRectangle | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | BOOL | bSelected,
 |  | BOOL | bPressed,
 |  | BOOL | bEnabled,
 |  | BOOL | bChecked,
 |  | BOOL | bPopuped,
 |  | XTPBarType | barType,
 |  | XTPBarPosition | barPosition,
 |  | int | nID )
 virtual

This method is called to fill the control's face.

Parameters
pDC | Pointer to a valid device context.
rc | Rectangle to draw.
bSelected | TRUE if the control is selected.
bPressed | TRUE if the control is pushed.
bEnabled | TRUE if the control is enabled.
bChecked | TRUE if the control is checked.
bPopuped | TRUE if the control is pop-up'ed.
barType | Parent's bar type.
barPosition | Parent's bar position.
nID | Bar's control ID.

Reimplemented from CXTPCommandBarsOffice2003Theme.

◆ DrawRectangle() [3/3]

virtual BOOL DrawRectangle | ( | CDC * | pDC,
 |  | CXTPControl * | pButton )
 virtual

This method is called to fill the control's face.

Parameters
pDC | Pointer to a valid device context.
pButton | pointer to a button
Returns
TRUE if the rectange was drawn, otherwise FALSE.

Reimplemented from CXTPCommandBarsOffice2003Theme.

◆ GetCommandBarBorders()

virtual CRect GetCommandBarBorders ( CXTPCommandBar * pBar )
virtual

This method is called to retrieve the command bar's borders.

Parameters
pBar Pointer to the CXTPCommandBar object whose borders must be retrieved.
Returns
Borders of the command bar.

Reimplemented from CXTPCommandBarsOffice2003Theme.

◆ GetRectangleTextColor()

virtual COLORREF GetRectangleTextColor | ( | BOOL | bSelected,
 |  | BOOL | bPressed,
 |  | BOOL | bEnabled,
 |  | BOOL | bChecked,
 |  | BOOL | bPopuped,
 |  | XTPBarType | barType,
 |  | XTPBarPosition | barPosition )
 virtual

This method retrieves a button's text color.

Parameters
bSelected | TRUE if the control is selected.
bPressed | TRUE if the control is pushed.
bEnabled | TRUE if the control is enabled.
bChecked | TRUE if the control is checked.
bPopuped | TRUE if the control is pop-up'ed.
barType | Parent's bar type.
barPosition | Parent's bar position.
Returns
Button's text color.

Reimplemented from CXTPCommandBarsOfficeXPTheme.

The documentation for this class was generated from the following file:
  • XTPCommandBarsVisualStudio2008Theme.h


Toolkit Pro: CXTPVisualStudio2010Theme Class Reference

Public Member Functions | List of all members
CXTPVisualStudio2010Theme Class Reference

The CXTPVisualStudio2010Theme class is used to enable a Visual Studio 2010 style theme for Command Bars. More...

Inheritance diagram for CXTPVisualStudio2010Theme:
[legend]

Public Member Functions

CXTPVisualStudio2010Theme ()
Constructs a CXTPVisualStudio2008Theme object.
virtual | ~CXTPVisualStudio2010Theme ()
Destroys a CXTPVisualStudio2008Theme object, handles cleanup and deallocation.
void | RefreshMetrics ()
This method is called to refresh the visual metrics of the manager.
virtual CRect | GetCommandBarBorders (CXTPCommandBar *pBar)
This method is called to retrieve the command bar's borders.
virtual void | DrawPopupBarGripper (CDC *pDC, int xPos, int yPos, int cx, int cy, BOOL bExpanded)
This method is called to draw a pop-up bar's right gripper.
virtual void | DrawRectangle (CDC *pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition)
This method is called to fill the control's face.
virtual void | DrawRectangle (CDC *pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition, int nID)
This method is called to fill the control's face.
virtual BOOL | DrawRectangle (CDC *pDC, CXTPControl *pButton)
This method is called to fill the control's face.
virtual COLORREF | GetRectangleTextColor (BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition)
This method retrieves a button's text color.
virtual void | AdjustExcludeRect (CRect &rc, CXTPControl *pControl, BOOL bVertical)
This method is called to determine the offset of a pop-up bar.
virtual CSize | DrawCommandBarSeparator (CDC *pDC, CXTPCommandBar *pBar, CXTPControl *pControl, BOOL bDraw)
This method is called to draw a command bar's separator.
virtual void | FillCommandBarEntry (CDC *pDC, CXTPCommandBar *pBar)
This method is called to fill the command bar's face.
virtual XTPPaintTheme | BaseTheme ()
Retrieves the base theme of the manager.
- Public Member Functions inherited from CXTPCommandBarsOffice2003Theme
CXTPCommandBarsOffice2003Theme ()
Constructs a CXTPCommandBarsOffice2003Theme object.
virtual | ~CXTPCommandBarsOffice2003Theme ()
Destroys a CXTPCommandBarsOffice2003Theme object, handles cleanup and deallocation.
void | ExcludeCorners (CDC *pDC, CRect rc)
This method creates a new clipping region that consists of the existing clipping region minus the corners rectangles.
- Public Member Functions inherited from CXTPCommandBarsOfficeXPTheme
CXTPCommandBarsOfficeXPTheme ()
Constructs a CXTPCommandBarsOfficeXPTheme object.
virtual CSize | DrawListBoxControl (CDC *pDC, CXTPControl *pButton, CRect rc, BOOL bSelected, BOOL bDraw, CXTPCommandBars *pCommandBars=0)
This method is called to draw the control placed on the ListBox.
virtual void | DrawPopupResizeGripper (CDC *pDC, CRect rcGripper, int nFlags)
This method is called to draw a resize gripper of a pop-up bar.
- Public Member Functions inherited from CXTPPaintManager
virtual void | SetImageHandle (HMODULE hResource, LPCTSTR lpszIniFileName)
Specifies the resource that contains the bitmaps to be loaded for the theme.
CSize | DrawControl (CDC *pDC, CXTPControl *pButton, BOOL bDraw=TRUE)
This method is called to draw the control.
virtual CSize | DrawControlToolBarParent (CDC *pDC, CXTPControl *pButton, BOOL bDraw)
This method is called to draw the control placed on the toolbar.
virtual COLORREF | GetControlEditBackColor (CXTPControl *pControl)
This method returns the edit control back color to draw.
virtual void | DrawControlEntry (CDC *pDC, CXTPControl *pButton)
This method is called to fill the control's face.
virtual COLORREF | GetControlTextColor (CXTPControl *pButton)
Call this method to get the control text color to draw.
virtual COLORREF | GetControlBackColor (CXTPControl *pButton)
Call this method to get the control back color to draw.
virtual void | DrawGalleryItemBack (CDC *pDC, CRect rcItem, BOOL bEnabled, BOOL bSelected, BOOL bPressed, BOOL bChecked, XTPBarType barType)
This method is called to draw the background for a gallery menu item.
virtual void | DrawCommandBarGroupSeparator (CDC *pDC, CXTPCommandBar *pBar, CXTPControl *pLeftControl, CXTPControl *pRightControl, BOOL bDraw=TRUE)
This method is called to draw a command bar's group separator.
virtual void | FillWorkspace (CDC *pDC, CRect rc, CRect rcExclude)
This method is called to fill a workspace.
int | GetShadowOptions () const
Determines the kind of shadow to use.
virtual void | DrawExpandGlyph (CDC *pDC, CXTPControl *pButton, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clr)
Draw expand or hidden glyphs for a button.
virtual void | DrawExpandGlyph (CDC *pDC, CXTPControl *pButton, COLORREF clr, BOOL bVertical)
Draw expand or hidden glyphs for a button.
virtual void | DrawHiddenGlyph (CDC *pDC, CXTPControl *pButton, COLORREF clr, BOOL bVertical)
Draw expand or hidden glyphs for a button.
virtual CRect | GetSplitButtonCommandRect (CXTPControl *pButton)
Determines split button command rectangle.
virtual void | SetCommandBarRegion (CXTPCommandBar *pCommandBar)
Call this method to set the bounding region of a pop-up bar.
XTPPaintTheme GetCurrentTheme ()
Call this member to get the current visual theme.
virtual BOOL | RequiresResourceImages ()
Used by the paint manager to determine if the theme requires a resource DLL to load image and color information.
virtual CFont * | GetControlFont (CXTPControl *pControl)
Call this member to retrieve the font of the command bar control.
virtual CFont * | GetCommandBarFont (CXTPCommandBar *pCommandBar)
Call this member to retrieve the font of the command bar.
virtual XTPBarTextOrientation | GetControlTextOrientation (CXTPControl *pControl)
Call this member to determine how to draw text.
virtual void | UpdateFonts ()
Refreshes the fonts to use.
virtual void | UpdateColors ()
Refreshes the standard colors to use.
void | SetCommandBarsFontIndirect (LOGFONT *pLogFont, BOOL bUseStandardFont=FALSE)
Call this member to set command bar's font.
CFont * | GetRegularFont ()
Returns the general font.
CFont * | GetRegularBoldFont ()
Returns the general bold font.
CFont * | GetIconFont ()
Returns the icon font.
CFont * | GetSmCaptionFont ()
Call this method to retrieve the caption of a floating mini frame.
void | UseOfficeFont (bool bUseOfficeFont)
Call this method to use Tahoma font despite system metrics.
int | GetControlHeight () const
This method returns the common controls height.
virtual CSize | GetDefaultCommandBarSize (CXTPCommandBar *pBar)
Computes default command bar size taking into account command bar font.
void | Rectangle (CDC *pDC, LPCRECT rc, int nPen, const int nBrush)
Draws a rectangle.
void | Rectangle (CDC *pDC, LPCRECT rc, COLORREF clrPen, COLORREF clrBrush)
Draws a rectangle.
void | RoundRect (CDC *pDC, LPCRECT rc, COLORREF clrPen, COLORREF clrBrush)
Draws a rectangle.
void | Draw3dRect (CDC *pDC, LPCRECT rc, int nTopLeft, int nBottomRight)
Call this member function to draw a three-dimensional rectangle.
void | Draw3dRect (CDC *pDC, LPCRECT rc, int frameThickness, COLORREF clrPen, COLORREF clrBrush)
Call this member function to draw a rectangle with predetermined thickness.
virtual void | DrawPopupBarCheckMark (CDC *pDC, CRect rcCheck, BOOL bEnabled, COLORREF clr)
Call this member function to draw a check mark.
void | DrawCheckMark (CDC *pDC, CRect rcCheck, COLORREF clr=0)
Call this member function to draw a check mark.
virtual void | DrawPopupBarRadioMark (CDC *pDC, CRect rcCheck, BOOL bEnabled, COLORREF clr)
Call this member function to draw a radio button.
virtual void | DrawComboExpandMark (CDC *pDC, CRect rc, COLORREF clr)
Call this member function to draw a combobox expand symbol.
virtual void | DrawControlMDIButton (CDC *pDC, CXTPControlButton *pButton)
Call this member function to draw menu MDI buttons.
void | Line (CDC *pDC, CPoint p0, CPoint p1)
Draws a line.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1, const int nPen)
Draws a line.
void | Line (CDC *pDC, int x0, int y0, int x1, int y1, COLORREF clrPen)
Draws a line.
void | HorizontalLine (CDC *pDC, int x0, int y0, int x1, COLORREF clrPen)
Call this member function to draw a horizontal line using the specified coordinages and RGB color value.
void | VerticalLine (CDC *pDC, int x0, int y0, int y1, COLORREF clrPen)
Call this member function to draw a vertical line using the specified coordinages and RGB color value.
virtual void | DrawDropDownGlyph (CDC *pDC, CXTPControl *pControl, CPoint pt, BOOL bSelected, BOOL bPopuped, BOOL bEnabled, BOOL bVert)
This member function is called to draw a split button expand symbol.
void | Pixel (CDC *pDC, int xPos, int yPos, int nPen)
Sets the pixel at the point.
void | GradientFill (CDC *pDC, LPRECT lpRect, COLORREF crFrom, COLORREF crTo, BOOL bHorz, LPCRECT lpRectClip=NULL)
Gradient fills the rectangle.
XTP_COMMANDBARS_ICONSINFO * GetIconsInfo ()
virtual void | Animate (CDC *pDestDC, CDC *pSrcDC, CRect rc, XTPAnimationType animationType)
This method is called to animate the pop-up bar.
virtual void | AnimateExpanding (CXTPCommandBar *pCommandBar, CDC *pDestDC, CDC *pSrcDC, BOOL bExpandDown)
This method is called to animate the expanding process.
void | SetAnimationDelay (int nAnimationSteps, int nAnimationTime)
Call this method to set animation delay.
COLORREF | GetXtremeColor (UINT nIndex)
This function retrieves the current color of the specified XP display element.
void | SetColors (int cElements, CONST INT *lpaElements, CONST COLORREF *lpaRgbValues)
Call this member to set the colors for each element to the color in the specified color array.
CSize | DrawControlText (CDC *pDC, CXTPControl *pControl, CRect rcText, BOOL bDraw, BOOL bVert, BOOL bCentered, BOOL bTriangled)
This method is called to draw control text.
virtual void | UpdateRTLCaption (CString &strCaption)
This method is called to prepare a caption for Right-To-Left draw.
XTPCurrentSystemTheme GetCurrentSystemTheme ()
Call this member function to determine the current Windows XP theme in use.
void | SetLunaTheme (XTPCurrentSystemTheme systemTheme)
Call this method to force system theme.
virtual int | GetPopupBarGripperWidth (CXTPCommandBar *pBar)
Calculates the gripper of a pop-up bar.
virtual CXTPControlGalleryPaintManager * | GetGalleryPaintManager () const
Retrieves paint manager used to draw galleries.
virtual CXTPScrollBarPaintManager * | GetScrollBarPaintManager () const
Retrieves paint manager used to draw scrollbars.
virtual CXTPSliderPaintManager * | GetSliderPaintManager () const
Retrieves paint manager used to draw slider panes.
virtual CXTPProgressPaintManager * | GetProgressPaintManager () const
Retrieves paint manager used to draw progress bars.
virtual CXTPFramePaintManager * | GetFramePaintManager ()
Retrieves paint manager used to draw frames.
virtual CXTPStatusBarPaintManager * | GetStatusBarPaintManager ()
Retrieves paint manager used to draw the status bar.
virtual CXTPRibbonPaintManager * | GetRibbonPaintManager ()
Retrieves the ribbon paint manager.
virtual CXTPMessageBarPaintManager * | GetMessageBarPaintManager ()
Retrieves paint manager used to draw message bars.
CXTPShadowManager * | GetShadowManager () const
Retrieves shadow manager used to draw shadows.
BOOL | IsUseSystemAccentColorEnabled () const
Determines whether xtpApplicationUseSystemAccentColor application ambient property is set.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.
- Public Member Functions inherited from CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents >
void | Subscribe (IXTPPaintManagerEvents *pObserver, CXTPSubscriptionList< CXTPPaintManager, IXTPPaintManagerEvents > *pSubcriptionList=NULL)
Subscribes a unique observer for events.
void | Unsubscribe (IXTPPaintManagerEvents *pObserver)
Unsubscribes an observer from events.
void | Notify (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *))
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | Notify (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyReversed (void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *))
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamic (void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.
void | NotifyDynamicReversed (void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by an observer's method to be called for each subscribed observer.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCommandBarsOffice2003Theme
static HBITMAP AFX_CDECL | GetModernBitmap (UINT nIDResource)
Loads bitmap specified by nIDResource and converts its colors.
static BOOL AFX_CDECL | LoadModernToolbarIcons (UINT nIDResource)
Loads bitmap specified by nIDResource and adds it to ImageManager.
static BOOL AFX_CDECL | LoadModernToolbarIcons (UINT nIDResource, UINT *pCommands, int nCount, CSize szIcon=CSize(16, 15))
Loads bitmap specified by nIDResource and adds it to ImageManager.
- Static Public Member Functions inherited from CXTPPaintManager
static CXTPPaintManager *AFX_CDECL | GetInstanceAddRef ()
Obtains a pointer to a global paint manager object and increments its reference counter.
static void AFX_CDECL | ReleaseInstance ()
Decrements global paint manager's reference counter and deletes its instance when the reference counter reaches 0.
static CXTPPaintManager *AFX_CDECL | CreateTheme (XTPPaintTheme paintTheme)
Creates a new CXTPPaintManager object.
static void AFX_CDECL | SetTheme (XTPPaintTheme paintTheme)
Call this member to switch the visual theme of the Command Bars.
static void AFX_CDECL | SetCustomTheme (CXTPPaintManager *pTheme)
Call this member to set a custom theme.
static void AFX_CDECL | Triangle (CDC *pDC, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clr)
Draws a triangle.
static BOOL AFX_CDECL | FontExists (LPCTSTR lpszFaceName)
Determines if a specified font exists in the system.
static void AFX_CDECL | StripMnemonics (CString &strClear)
This member function will search a string, strip off the mnemonic '&', and reformat the string.
static CXTPPaintManager *AFX_CDECL | GetGlobalPaintManager ()
Call this method to get the pointer to the global paint manager.
static void AFX_CDECL | SetGlobalPaintManager (CXTPPaintManager *pPaintManager)
Call this method to set the pointer to the global paint manager.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
- Public Attributes inherited from CXTPCommandBarsOffice2003Theme
CXTPPaintManagerColorGradient | m_clrDockBar
Color of dockbar face.
CXTPPaintManagerColorGradient | m_clrCommandBar
Color of commandbar face.
CXTPPaintManagerColorGradient | m_clrToolbarExpand
Toolbar Expand button color.
CXTPPaintManagerColorGradient | m_clrMenuExpand
MenuBar Expand button color.
CXTPPaintManagerColorGradient | m_clrMenuExpandedGripper
Color of pop-up bar gripper.
CXTPPaintManagerColorGradient | m_clrMenuGripper
Color of the pop-up menu gripper.
CXTPPaintManagerColorGradient | m_clrPopupControl
color of pop-up control
CXTPPaintManagerColor | m_clrToolbarShadow
Toolbar bottom shadow color.
CXTPPaintManagerColor | m_clrTearOffGripper
TearOff gripper color.
BOOL | m_bLunaTheme
TRUE if luna theme is active.
BOOL | m_bPlainSeparators
TRUE to draw plain separators.
CImageList | m_ilGradientCircle
Gradient circle holder.
CXTPPaintManagerColorGradient | m_grcLunaChecked
Background color of checked button.
CXTPPaintManagerColorGradient | m_grcLunaPushed
Background color of pushed button.
CXTPPaintManagerColorGradient | m_grcLunaSelected
Background color of selected button.
- Public Attributes inherited from CXTPPaintManager
COLORREF | m_clrMessageBarText
Message bar text color.
CRect | m_rcMessageBarMargin
Margin of the message bar.
CXTPFramePaintManager * | m_pFramePaintManager
Frame paint manager.
CXTPStatusBarPaintManager * | m_pStatusBarPaintManager
Paint manager of the status bar.
CXTPRibbonPaintManager * | m_pRibbonPaintManager
Ribbon paint Manager.
CXTPControlGalleryPaintManager * | m_pGalleryPaintManager
Gallery paint manager.
CXTPProgressPaintManager * | m_pProgressPaintManager
Progress bar paint manager.
CXTPSliderPaintManager * | m_pSliderPaintManager
Slider pane paint manager.
CXTPScrollBarPaintManager * | m_pScrollBarPaintManager
Scrollbar paint manager.
CXTPPaintManagerColorGradient | m_clrDisabledIcon
Disabled icons color.
CXTPPaintManagerColor | m_clrFloatingGripper
Gripper color of floating toolbar.
CXTPPaintManagerColor | m_clrFloatingGripperText
Gripper text color of floating toolbar.
BOOL | m_bThickCheckMark
TRUE to draw thick check mark.
BOOL | m_bShowShadow
TRUE to show shadow.
BOOL | m_bThemedStatusBar
TRUE to draw status bar using WinXP theme.
BOOL | m_bThemedCheckBox
TRUE to draw check box using WinXP theme.
BOOL | m_bClearTypeTextQuality
TRUE to enable ClearType text for the font.
BOOL | m_bFlatToolBar
TRUE to draw toolbars flat.
BOOL | m_bFlatMenuBar
TRUE to draw menubar flat.
int | m_nPopupBarTextPadding
Distance between gripper and control text.
BOOL | m_bSelectImageInPopupBar
TRUE to select image as in explorer theme.
BOOL | m_bEnableAnimation
TRUE to enable animation for all toolbars.
BOOL | m_bOffice2007Padding
TRUE if Office2007 metrics used.
BOOL | m_bOffsetPopupLabelText
TRUE if labels in pop-ups drawn with offset.
BOOL | m_bWrapCaptionBelowText
Wrap text for xtpButtonIconAndCaptionBelow buttons.
CXTPPaintManagerFont | m_fontSmCaption
Small caption font.
CXTPPaintManagerFont | m_fontIcon
Icon font.
CXTPPaintManagerFont | m_fontIconBold
Icon bold font.
CXTPPaintManagerFont | m_fontToolTip
Tooltip font.
int | m_nSplitButtonDropDownWidth
Split button drop down width in toolbars.
int | m_nSplitButtonDropDownHeight
Split button drop down height in toolbars.
int | m_nSplitButtonPopupWidth
Split button drop down width in pop-ups.
BOOL | m_bAutoResizeIcons
TRUE to automatically resize icons using current DPI.
int | m_nStatusBarMinHeight
Minimum height for the status bar.
PVOID | m_pfnSetLayeredWindowAttributes
point to Transparency proc in USER32.dll module.
CRect | m_rcStatusBarBorder
Bounding rectangle of the status bar border.
BOOL | m_bUseOfficeFont
TRUE to use Tahoma font.
CString | m_strOfficeFont
Office font.
int | m_nTextHeight
Regular text field height (not font height).
- Protected Member Functions inherited from CXTPCommandBarsOffice2003Theme
virtual void | FillDockBar (CDC *pDC, CXTPDockBar *pBar)
This method is called to fill a dockbar.
virtual CSize | DrawCommandBarGripper (CDC *pDC, CXTPCommandBar *pBar, BOOL bDraw=TRUE)
This method is called to draw the command bar's gripper.
virtual CSize | DrawSpecialControl (CDC *pDC, XTPSpecialControl controlType, CXTPControl *pButton, CXTPCommandBar *pBar, BOOL bDraw, LPVOID lpParam)
This method is called to draw the specified controls.
virtual CSize | DrawTearOffGripper (CDC *pDC, CRect rcGripper, BOOL bSelected, BOOL bDraw)
This method is called to draw the tear-off gripper of a pop-up bar.
virtual CSize | DrawDialogBarGripper (CDC *pDC, CXTPDialogBar *pBar, BOOL bDraw)
Call this member to draw the gripper of a dialog bar.
void | CreateGradientCircle ()
Generates an expanded bitmap used for CXTPPopupBar.
virtual BOOL | HasFloatingBarGradientEntry (CXTPCommandBar *pBar)
Returns TRUE if a floating toolbar is drawn with a gradient background.
- Protected Member Functions inherited from CXTPCommandBarsOfficeXPTheme
virtual CSize | DrawControlPopupParent (CDC *pDC, CXTPControl *pButton, BOOL bDraw)
This method is called to draw the control placed on the pop-up bar.
virtual void | DrawImage (CDC *pDC, CPoint pt, CSize sz, CXTPImageManagerIcon *pImage, BOOL bSelected, BOOL bPressed, BOOL bEnabled=TRUE, BOOL bChecked=FALSE, BOOL bPopuped=FALSE, BOOL bToolBarImage=TRUE)
This method is called to draw the image of the control.
virtual CSize | DrawControlComboBox (CDC *pDC, CXTPControlComboBox *pComboBox, BOOL bDraw)
This method is called to draw the control.
virtual CSize | DrawControlEdit (CDC *pDC, CXTPControlEdit *pEdit, BOOL bDraw)
This method is called to draw the control.
void | FillIntersectRect (CDC *pDC, CXTPPopupBar *pPopupBar, COLORREF clr)
Draws intersect rectangle of a pop-up bar and its control.
virtual void | DrawSplitButtonFrame (CDC *pDC, CXTPControl *pButton, CRect rc)
This method is called to draw the frame for the SplitButton control.
virtual CSize | DrawControlCheckBoxMark (CDC *pDC, CRect rc, BOOL bDraw, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled)
This method is called to draw a check box mark area.
virtual CSize | DrawControlCheckBoxMark (CDC *pDC, CXTPControl *pButton, CRect rc, BOOL bDraw)
This method is called to draw a check box mark area.
virtual CSize | DrawControlRadioButtonMark (CDC *pDC, CRect rc, BOOL bDraw, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled)
This method is called to draw a radio button mark area.
- Protected Member Functions inherited from CXTPPaintManager
CXTPPaintManager ()
Constructs a CXTPPaintManager object.
virtual | ~CXTPPaintManager ()
Destroys a CXTPPaintManager object, handles cleanup and deallocation.
- Protected Member Functions inherited from CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents >
CXTPObservable ()
Constructs an observable object.
~CXTPObservable ()
Handles observable object destruction.
- Protected Attributes inherited from CXTPPaintManager
CXTPFont | m_xtpFontRegular
Regular font.
CXTPFont | m_xtpFontRegularBold
Regular bold font.
CXTPFont | m_xtpFontVert
Vertical font.
CXTPFont | m_xtpFontVertBold
Vertical font.
int | m_nEditHeight
Edit text height.
int | m_nFontHeight
Custom font height (optional).
BOOL | m_bUseStandardFont
TRUE to use system font.
BOOL | m_bEmbossedDisabledText
TRUE to draw disabled text embossed.
CXTPWinThemeWrapper * | m_themeStatusBar
StatusBar theme helper.
CXTPWinThemeWrapper * | m_themeButton
Buttons theme helper.
XTPPaintTheme | m_themeCurrent
Current theme.
XTP_COMMANDBARS_ICONSINFO | m_iconsInfo
Specific icons options.
int | m_nAnimationSteps
Steps of the animation.
int | m_nAnimationTime
Time of the animation.
BOOL | m_bShowKeyboardCues
TRUE to show keyboard cues - deprecated.
CXTPPaintManagerColor | m_arrColor [XPCOLOR_LAST+1]
Self colors array.
XTPCurrentSystemTheme | m_systemTheme
Current system theme.
CXTPShadowManager * | m_pShadowManager
Shadow manager.

Detailed Description

The CXTPVisualStudio2010Theme class is used to enable a Visual Studio 2010 style theme for Command Bars.

See also
CXTPPaintManager::SetTheme

Member Function Documentation

◆ AdjustExcludeRect()

virtual void AdjustExcludeRect | ( | CRect & | rc,
 |  | CXTPControl * | pControl,
 |  | BOOL | bVertical )
 virtual

This method is called to determine the offset of a pop-up bar.

Parameters
rc | Control's bounding rectangle.
pControl | Pointer to a CXTPControl object.
bVertical | TRUE if the control is docked vertically.

Reimplemented from CXTPCommandBarsOfficeXPTheme.

◆ BaseTheme()

virtual XTPPaintTheme BaseTheme ( )
inlinevirtual

Retrieves the base theme of the manager.

Returns
The base theme of the manager.

Reimplemented from CXTPCommandBarsOffice2003Theme.

◆ DrawCommandBarSeparator()

virtual CSize DrawCommandBarSeparator | ( | CDC * | pDC,
 |  | CXTPCommandBar * | pBar,
 |  | CXTPControl * | pControl,
 |  | BOOL | bDraw )
 virtual

This method is called to draw a command bar's separator.

Parameters
pDC | Pointer to a valid device context.
pBar | Pointer to a CXTPCommandBar object.
pControl | Pointer to a CXTPControl object.
bDraw | TRUE to draw; FALSE to retrieve the size of the separator.
Returns
Size of the separator.

Reimplemented from CXTPCommandBarsOffice2003Theme.

◆ DrawPopupBarGripper()

virtual void DrawPopupBarGripper | ( | CDC * | pDC,
 |  | int | xPos,
 |  | int | yPos,
 |  | int | cx,
 |  | int | cy,
 |  | BOOL | bExpanded )
 virtual

This method is called to draw a pop-up bar's right gripper.

Parameters
pDC | Pointer to a valid device context.
xPos | Specifies the logical x coordinate of the upper-left corner of the rectangle.
yPos | Specifies the logical y coordinate of the upper-left corner of the destination rectangle.
cx | Specifies the width of the rectangle.
cy | Specifies the height of the rectangle.
bExpanded | TRUE if expanded.

Reimplemented from CXTPCommandBarsOffice2003Theme.

◆ DrawRectangle() [1/3]

virtual void DrawRectangle | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | BOOL | bSelected,
 |  | BOOL | bPressed,
 |  | BOOL | bEnabled,
 |  | BOOL | bChecked,
 |  | BOOL | bPopuped,
 |  | XTPBarType | barType,
 |  | XTPBarPosition | barPosition )
 virtual

This method is called to fill the control's face.

Parameters
pDC | Pointer to a valid device context.
rc | Rectangle to draw.
bSelected | TRUE if the control is selected.
bPressed | TRUE if the control is pushed.
bEnabled | TRUE if the control is enabled.
bChecked | TRUE if the control is checked.
bPopuped | TRUE if the control is pop-up'ed.
barType | Parent's bar type.
barPosition | Parent's bar position.

Reimplemented from CXTPCommandBarsOffice2003Theme.

◆ DrawRectangle() [2/3]

virtual void DrawRectangle | ( | CDC * | pDC,
 |  | CRect | rc,
 |  | BOOL | bSelected,
 |  | BOOL | bPressed,
 |  | BOOL | bEnabled,
 |  | BOOL | bChecked,
 |  | BOOL | bPopuped,
 |  | XTPBarType | barType,
 |  | XTPBarPosition | barPosition,
 |  | int | nID )
 virtual

This method is called to fill the control's face.

Parameters
pDC | Pointer to a valid device context.
rc | Rectangle to draw.
bSelected | TRUE if the control is selected.
bPressed | TRUE if the control is pushed.
bEnabled | TRUE if the control is enabled.
bChecked | TRUE if the control is checked.
bPopuped | TRUE if the control is pop-up'ed.
barType | Parent's bar type.
barPosition | Parent's bar position.
nID | Bar's control ID.

Reimplemented from CXTPCommandBarsOffice2003Theme.

◆ DrawRectangle() [3/3]

virtual BOOL DrawRectangle | ( | CDC * | pDC,
 |  | CXTPControl * | pButton )
 virtual

This method is called to fill the control's face.

Parameters
pDC | Pointer to a valid device context.
pButton | pointer to a button
Returns
TRUE if the rectange was drawn, otherwise FALSE.

Reimplemented from CXTPCommandBarsOffice2003Theme.

◆ FillCommandBarEntry()

virtual void FillCommandBarEntry | ( | CDC * | pDC,
 |  | CXTPCommandBar * | pBar )
 virtual

This method is called to fill the command bar's face.

Parameters
pDC | Pointer to a valid device context.
pBar | Pointer to a CXTPCommandBar object to draw.

Reimplemented from CXTPCommandBarsOffice2003Theme.

◆ GetCommandBarBorders()

virtual CRect GetCommandBarBorders ( CXTPCommandBar * pBar )
virtual

This method is called to retrieve the command bar's borders.

Parameters
pBar Pointer to a CXTPCommandBar object that the borders need to get.
Returns
Borders of the command bar.

Reimplemented from CXTPCommandBarsOffice2003Theme.

◆ GetRectangleTextColor()

virtual COLORREF GetRectangleTextColor | ( | BOOL | bSelected,
 |  | BOOL | bPressed,
 |  | BOOL | bEnabled,
 |  | BOOL | bChecked,
 |  | BOOL | bPopuped,
 |  | XTPBarType | barType,
 |  | XTPBarPosition | barPosition )
 virtual

This method retrieves a button's text color.

Parameters
bSelected | TRUE if the control is selected.
bPressed | TRUE if the control is pushed.
bEnabled | TRUE if the control is enabled.
bChecked | TRUE if the control is checked.
bPopuped | TRUE if the control is pop-up'ed.
barType | Parent's bar type.
barPosition | Parent's bar position.
Returns
Button's text color.

Reimplemented from CXTPCommandBarsOfficeXPTheme.

The documentation for this class was generated from the following file:
  • XTPCommandBarsVisualStudio2010Theme.h


Toolkit Pro: CXTPWebBrowserCtrl Class Reference

Public Member Functions | List of all members
CXTPWebBrowserCtrl Class Reference

Implements the WebBrowser control that is capable of hosting different supported Web browsers. More...

Public Member Functions

CXTPWebBrowserCtrl (XTPWebBrowserProvider nProvider=xtpWebBrowserLatest)
Handles control construction.
virtual | ~CXTPWebBrowserCtrl ()
Handles control destruction.
BOOL | RegisterWindowClass (HINSTANCE hInstance=NULL)
Registers the window class if it has not already been registered.
virtual BOOL | Create (DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID, CCreateContext *pContext=NULL)
Creates a preview control window object.
virtual BOOL | CreateEx (DWORD dwExStyle, DWORD dwStyle, int x, int y, int nWidth, int nHeight, HWND hWndParent, HMENU nIDorHMenu, LPVOID lpParam=NULL)
Creates a preview control window object.
virtual BOOL | CreateEx (DWORD dwExStyle, DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID, LPVOID lpParam=NULL)
Creates a preview control window object.
virtual const COleVariant * | GetProperty (const CString &strName) const
Gets custom properties that providers can use if provided.
void | SetProperty (const CString &strName, COleVariant *pvtValue)
Sets custom properties that providers can use if provided.
BOOL | ReCreateProvider ()
Re-creates the current provider, i.e.
XTPWebBrowserProvider | GetProviderType () const
Obtains the active WebBrowser provider type.
BOOL | SetProviderType (XTPWebBrowserProvider nProvider)
Sets the active WebBrowser provider type.
CXTPWebBrowserProvider * | GetProvider () const
Obtains the active WebBrowser provider object or NULL if no provider has been activated yet or provider activation hasn't been completed.
IUnknown * | GetBrowserObject () const
Obtains the native WebBrowser provider object or NULL if no provider is activated or the current provider does not provide access to its core object via IUnknown.
IXTPWebBrowserEventSink * | GetEventSink () const
Gets the event sink interface for handling WebBrowser events.
void | SetEventSink (IXTPWebBrowserEventSink *pEventSink)
Sets the event sink interface for handling WebBrowser events.
HRESULT | Navigate (LPCTSTR pUrl)
Performs navigation to the specified URL.
HRESULT | LoadHtml (LPCTSTR pHtml)
Loads specified HTML code.
HRESULT | WaitUntilReady ()
Waits until an initiated navigation completes.
HRESULT | ExecuteScript (LPCWSTR pText, CComVariant *pvtResult=NULL)
Executes a script by the active WebBrowser provider.
virtual IDispatch * | GetExternal () const
Gets the object to be used by the "window.external" propery in the script execution context.
void | SetExternal (IDispatch *pExternal)
Sets the object to be used by the "window.external" propery in the script execution context.

Detailed Description

Implements the WebBrowser control that is capable of hosting different supported Web browsers.

The class provides a narrow interface that gives access to the most frequently needed functionality that is provided by each supported provider. The unified event handling interface simplifies event processing.

Constructor & Destructor Documentation

◆ CXTPWebBrowserCtrl()

CXTPWebBrowserCtrl ( XTPWebBrowserProvider nProvider = xtpWebBrowserLatest )

Handles control construction.

Parameters
nProvider Specifies the provider to initialize by default. It is not guaranteed that the specified provider will be activated as at the point of construction it is not yet known which of the providers are available and supported. In case the specified provider is impossible to activate the ShellExplorer provider will be activated by default.

Member Function Documentation

◆ Create()

virtual BOOL Create | ( | DWORD | dwStyle,
 |  | const RECT & | rect,
 |  | CWnd * | pParentWnd,
 |  | UINT | nID,
 |  | CCreateContext * | pContext = NULL )
 virtual

Creates a preview control window object.

Parameters
dwStyle | Bitwise combination (OR) of window styles; otherwise NULL for the default window style.
rect | The size and location of the window relative to the screen or the parent window.
pParentWnd | For a child window, pointer to the parent window; otherwise, a pointer to the owner window if the window has an owner.
nID | For a child window, the window ID; otherwise, the ID of a menu for the window.
pContext | CCreateContext object pointer or NULL.
Returns
TRUE if the method was successful, otherwise FALSE.

◆ CreateEx() [1/2]

virtual BOOL CreateEx | ( | DWORD | dwExStyle,
 |  | DWORD | dwStyle,
 |  | const RECT & | rect,
 |  | CWnd * | pParentWnd,
 |  | UINT | nID,
 |  | LPVOID | lpParam = NULL )
 virtual

Creates a preview control window object.

Parameters
dwExStyle | Bitwise combination (OR) of extended window styles; otherwise NULL for the default extended window style.
dwStyle | Bitwise combination (OR) of window styles; otherwise NULL for the default window style.
rect | The size and location of the window relative to the screen or the parent window.
pParentWnd | For a child window, pointer to the parent window; otherwise, a pointer to the owner window if the window has an owner.
nID | For a child window, the window ID; otherwise, the ID of a menu for the window.
lpParam | Pointer to user data that is passed to the CWnd::OnCreate method in the lpCreateParams field.
Returns
TRUE if the method was successful, otherwise FALSE.

◆ CreateEx() [2/2]

virtual BOOL CreateEx | ( | DWORD | dwExStyle,
 |  | DWORD | dwStyle,
 |  | int | x,
 |  | int | y,
 |  | int | nWidth,
 |  | int | nHeight,
 |  | HWND | hWndParent,
 |  | HMENU | nIDorHMenu,
 |  | LPVOID | lpParam = NULL )
 virtual

Creates a preview control window object.

Parameters
dwExStyle | Bitwise combination (OR) of extended window styles; otherwise NULL for the default extended window style.
dwStyle | Bitwise combination (OR) of window styles; otherwise NULL for the default window style.
x | The initial horizontal distance of the window from the left side of the screen or the parent window.
y | The initial vertical distance of the window from the top of the screen or the parent window.
nWidth | The width, in pixels, of the window.
nHeight | The height, in pixels, of the window.
hWndParent | For a child window, the handle to the parent window; otherwise, the handle of the owner window if the window has an owner.
nIDorHMenu | For a child window, the window ID; otherwise, the ID of a menu for the window.
lpParam | Pointer to user data that is passed to the CWnd::OnCreate method in the lpCreateParams field.
Returns
TRUE if the method was successful, otherwise FALSE.

◆ ExecuteScript()

HRESULT ExecuteScript | ( | LPCWSTR | pText,
 |  | CComVariant * | pvtResult = NULL )

Executes a script by the active WebBrowser provider.

Parameters
pText | Script code text.
pvtResult | The optional pointer to the variant object that is supposed to receive the result of the executed script.
Returns
S_OK if script execution or its attempt are successful or an error code otherwise.

The language of the script code is provider specific. Currently each provider supports JavaScript by default.

◆ GetBrowserObject()

IUnknown * GetBrowserObject ( ) const

Obtains the native WebBrowser provider object or NULL if no provider is activated or the current provider does not provide access to its core object via IUnknown.

Returns
Obtains the native WebBrowser provider object.

The ShellExplorer provider will return IWebBrowserApp object. The WebView provider will return ICoreWebView2Controller object.

◆ GetEventSink()

IXTPWebBrowserEventSink * GetEventSink ( ) const

Gets the event sink interface for handling WebBrowser events.

Returns
The current even sink interface pointer.

The control does not manage even sink object lifetime.

◆ GetExternal()

virtual IDispatch * GetExternal ( ) const
virtual

Gets the object to be used by the "window.external" propery in the script execution context.

Returns
The current external object.

The WebBrowser control holds a reference to the specified external object until a new object is set or the control is destructed.

◆ GetProperty()

virtual const COleVariant * GetProperty ( const CString & strName ) const
virtual

Gets custom properties that providers can use if provided.

Parameters
strName Property name.
Returns
Current property value if it is found or NULL otherwise.

Custom properties are held by the control object and don't belong to the current provider set, however they can be accessed by any provider. Currently supported properties include: "UDF" The string path value that indicates the UserDefaultFolder for WebView2 provider. "OverrideKeyPath" The string registry key path value relative to HKEY_CURRENT_USER that speicifies a registry key to override default Internet Explorer settings. "OptionKeyPath" The string registry key path value relative to HKEY_CURRENT_USER that speicifies a registry key to use as a default location of Internet Explorer settings. In order to apply custom properties to a provider that is already created the CXTPWebBrowserCtrl::ReCreateProvider method must be called.

See also
CXTPWebBrowserCtrl::ReCreateProvider

◆ GetProvider()

CXTPWebBrowserProvider * GetProvider ( ) const

Obtains the active WebBrowser provider object or NULL if no provider has been activated yet or provider activation hasn't been completed.

Returns
A pointer to the base WebBrowser provider implementation. The pointer can be cast to the actual WebBrowser provider implementation if extended access is required.

◆ GetProviderType()

XTPWebBrowserProvider GetProviderType ( ) const

Obtains the active WebBrowser provider type.

Returns
The type of of the active WebBrowser provider.

◆ LoadHtml()

HRESULT LoadHtml ( LPCTSTR pHtml )

Loads specified HTML code.

Parameters
pHtml The HTML code pointer to load.
Returns
S_OK if success or an error code otherwise.

To clear off the currently loaded web page navigation to 'about:blank' is performed prior to loading the specified HTML content.

◆ Navigate()

HRESULT Navigate ( LPCTSTR pUrl )

Performs navigation to the specified URL.

Parameters
pUrl The URL value to navigate to.
Returns
S_OK if navigation is succeeded or an error code otherwise.

If a provider is no yet activated the navigation will be postponed until a provider is activated.

◆ ReCreateProvider()

BOOL ReCreateProvider ( )

Re-creates the current provider, i.e.

the actual Web browser instance will be destroyed and re-created. The external object will be automatically bound if assigned, custom properties won't be affected, and the previously navigated location will be restored.

Returns
TRUE if a provider is re-created successfully, FALSE otherwise.

◆ RegisterWindowClass()

BOOL RegisterWindowClass ( HINSTANCE hInstance = NULL )

Registers the window class if it has not already been registered.

Parameters
hInstance Instance of the resource where the control is located.
Returns
TRUE if the window class was successfully registered, otherwise FALSE.

◆ SetEventSink()

void SetEventSink ( IXTPWebBrowserEventSink * pEventSink )

Sets the event sink interface for handling WebBrowser events.

Parameters
pEventSink The new event sink interface pointer or NULL to disable event handling.

The control does not manage even sink object lifetime.

◆ SetExternal()

void SetExternal ( IDispatch * pExternal )

Sets the object to be used by the "window.external" propery in the script execution context.

Parameters
pExternal The new external object to be used.

The WebBrowser control holds a reference to the specified external object until a new object is set or the control is destructed.

◆ SetProperty()

void SetProperty | ( | const CString & | strName,
 |  | COleVariant * | pvtValue )

Sets custom properties that providers can use if provided.

Parameters
strName | Property name.
pvtValue | Property value. The control will hold the ownership of the allocated data. NULL pointer value will cause removal of the previously set property value.

Custom properties are held by the control object and don't belong to the current provider set, however they can be accessed by any provider. Currently supported properties include: "UDF" The string path value that indicates the UserDefaultFolder for WebView2 provider. "OverrideKeyPath" The string registry key path value relative to HKEY_CURRENT_USER that speicifies a registry key to override default Internet Explorer settings. "OptionKeyPath" The string registry key path value relative to HKEY_CURRENT_USER that speicifies a registry key to use as a default location of Internet Explorer settings. In order to apply custom properties to a provider that is already created the CXTPWebBrowserCtrl::ReCreateProvider method must be called.

See also
CXTPWebBrowserCtrl::ReCreateProvider

◆ SetProviderType()

BOOL SetProviderType ( XTPWebBrowserProvider nProvider )

Sets the active WebBrowser provider type.

Parameters
nProvider A new provider type as defined by XTPWebBrowserProvider enumeration.
Returns
TRUE if the WebBrowser provider has been changed.

All previously set provider specific options will get reset.

◆ WaitUntilReady()

HRESULT WaitUntilReady ( )

Waits until an initiated navigation completes.

Returns
S_OK if success or an error code otherwise. If an error code is returned it doesn't indicate a navigation error, it only indicate inability to wait for some reason.
The documentation for this class was generated from the following file:
  • XTPWebBrowserCtrl.h


Toolkit Pro: CXTPWebBrowserProvider Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPWebBrowserProvider Class Referenceabstract

Implements the base class for a WebBrowser provider. More...

Inheritance diagram for CXTPWebBrowserProvider:
[legend]

Public Member Functions

virtual | ~CXTPWebBrowserProvider ()
Handles provider destruction.
IUnknown * | GetBrowserObject () const
Obtains the native WebBrowser provider object or NULL if no provider is activated or the current provider does not provide access to its core object via IUnknown.
IUnknown * | GetClientInterface (REFIID riid) const
Gets the client interface.
void | SetClientInterface (REFIID riid, IUnknown *pUnk)
Sets the client interface.
void | RemoveClientInterface (REFIID riid)
Removes the client interface.
virtual HRESULT | ExecuteScript (LPCWSTR pText, CComVariant *pvtResult=NULL)=0
Executes a script by the active WebBrowser provider.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Protected Member Functions

CXTPWebBrowserProvider (IXTPWebBrowserHost &host)
Handles provider construction.

Protected Attributes

IXTPWebBrowserHost & m_Host
The host control interface.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

Implements the base class for a WebBrowser provider.

Constructor & Destructor Documentation

◆ CXTPWebBrowserProvider()

CXTPWebBrowserProvider ( IXTPWebBrowserHost & host )
protected

Handles provider construction.

Parameters
host The host object.

Member Function Documentation

◆ ExecuteScript()

virtual HRESULT ExecuteScript | ( | LPCWSTR | pText,
 |  | CComVariant * | pvtResult = NULL )
 pure virtual

Executes a script by the active WebBrowser provider.

Parameters
pText | Script code text.
pvtResult | The optional pointer to the variant object that is supposed to receive the result of the executed script.
Returns
S_OK if script execution or its attempt are successful or an error code otherwise.

The language of the script code is provider specific. Currently each provider supports JavaScript by default.

Implemented in CXTPShellExplorerProvider, and CXTPWebViewProvider.

◆ GetBrowserObject()

IUnknown * GetBrowserObject ( ) const

Obtains the native WebBrowser provider object or NULL if no provider is activated or the current provider does not provide access to its core object via IUnknown.

Returns
Obtains the native WebBrowser provider object.

◆ GetClientInterface()

IUnknown * GetClientInterface ( REFIID riid ) const

Gets the client interface.

Parameters
riid Client interface IID.
Returns
Client interface pointer or NULL if no requested interface is added.

If a provider supports client site, the client interface provided may be requested by the provider at any moment thus making it possible to customize and extend WebBrowser functionality by adding provider specific client interfaces implemented by the user code.

◆ RemoveClientInterface()

void RemoveClientInterface ( REFIID riid )

Removes the client interface.

Parameters
riid Client interface IID.

If a provider supports client site, the client interface provided may be requested by the provider at any moment thus making it possible to customize and extend WebBrowser functionality by adding provider specific client interfaces implemented by the user code.

◆ SetClientInterface()

void SetClientInterface | ( | REFIID | riid,
 |  | IUnknown * | pUnk )

Sets the client interface.

Parameters
riid | Client interface IID.
pUnk | Client interface pointer.

If a provider supports client site, the client interface provided may be requested by the provider at any moment thus making it possible to customize and extend WebBrowser functionality by adding provider specific client interfaces implemented by the user code.

The documentation for this class was generated from the following file:
  • XTPWebBrowserProvider.h


Toolkit Pro: CXTPWebViewProvider Class Reference

Public Member Functions | Static Public Member Functions | List of all members
CXTPWebViewProvider Class Reference

Implements WebView2 WebBrowser provider and gives access to WebView2 specific functionality. More...

Inheritance diagram for CXTPWebViewProvider:
[legend]

Public Member Functions

CXTPWebViewProvider (IXTPWebBrowserHost &host)
Constructs provider object.
~CXTPWebViewProvider ()
Handles provider destruction.
virtual HRESULT | ExecuteScript (LPCWSTR pText, CComVariant *pvtResult=NULL)
Executes a JavaScript code.
- Public Member Functions inherited from CXTPWebBrowserProvider
virtual | ~CXTPWebBrowserProvider ()
Handles provider destruction.
IUnknown * | GetBrowserObject () const
Obtains the native WebBrowser provider object or NULL if no provider is activated or the current provider does not provide access to its core object via IUnknown.
IUnknown * | GetClientInterface (REFIID riid) const
Gets the client interface.
void | SetClientInterface (REFIID riid, IUnknown *pUnk)
Sets the client interface.
void | RemoveClientInterface (REFIID riid)
Removes the client interface.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Static Public Member Functions

static BOOL | IsAvailable ()
Determines if WebView2 implementation is available and can be used.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL | FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Additional Inherited Members

- Protected Member Functions inherited from CXTPWebBrowserProvider
CXTPWebBrowserProvider (IXTPWebBrowserHost &host)
Handles provider construction.
- Protected Attributes inherited from CXTPWebBrowserProvider
IXTPWebBrowserHost & m_Host
The host control interface.

Detailed Description

Implements WebView2 WebBrowser provider and gives access to WebView2 specific functionality.

Constructor & Destructor Documentation

◆ CXTPWebViewProvider()

CXTPWebViewProvider ( IXTPWebBrowserHost & host )

Constructs provider object.

Parameters
host The host control interface.

Member Function Documentation

◆ ExecuteScript()

virtual HRESULT ExecuteScript | ( | LPCWSTR | pText,
 |  | CComVariant * | pvtResult = NULL )
 virtual

Executes a JavaScript code.

Parameters
pText | Script code text.
pvtResult | The optional pointer to the variant object that is supposed to receive the result of the executed script.
Returns
S_OK if script execution or its attempt are successful or an error code otherwise.

Implements CXTPWebBrowserProvider.

◆ IsAvailable()

static BOOL IsAvailable ( )
static

Determines if WebView2 implementation is available and can be used.

Returns
TRUE if WebView2 implementation is available and can be used, otherwise FALSE.
The documentation for this class was generated from the following file:
  • XTPWebViewProvider.h


Toolkit Pro: CXTPWinApp Class Reference

Public Member Functions | List of all members
CXTPWinApp Class Reference

All XTP application classes have to derive from CXTPWinApp instead of CWinApp or CWinAppEx. More...

Public Member Functions

CXTPWinApp (int xtpComInit=xtpComInitAppDefault)
Constructs CXTPWinApp object.
virtual ~CXTPWinApp ()
Default destructor, handles cleanup / deallocation.

Detailed Description

All XTP application classes have to derive from CXTPWinApp instead of CWinApp or CWinAppEx.

This class handles XTP application initialization and resource cleanup.

In order to use CXTPWinApp derived from CWinAppEx ToolkitPro must be re-compiled with _XTP_USE_WINAPPEX macro globally defined in compiler settings. _XTP_USE_WINAPPEX will also have to be globally defined for the project that referencing Toolkit Pro. CXTPWinApp constructor arguments change depending on _XTP_USE_WINAPPEX macro presense in order to allow pass arguments to CWinAppEx class.

Constructor & Destructor Documentation

◆ CXTPWinApp()

CXTPWinApp ( int xtpComInit = xtpComInitAppDefault )

Constructs CXTPWinApp object.

Parameters
xtpComInit Global COM/OLE initialization method. xtpComInitAppDefault can be used for default initialization method.

If extended COM initialization flags are being used bu CoInitializeEx function is not available then xtpComInitSTA is assumed, all other flags get ignored and the legacy CoInitialize gets called.

See also
XTPComInit
The documentation for this class was generated from the following file:
  • XTPWinApp.h


Toolkit Pro: CXTPWindowList Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CXTPWindowList Class Reference

CXTPWindowList dialog. More...

Inheritance diagram for CXTPWindowList:
[legend]

Public Member Functions

CXTPWindowList (CMDIFrameWnd *pMDIFrameWnd)
Constructs a CXTPWindowList object.
CXTPWindowList (HWND hWndMDIClient)
Constructs a CXTPWindowList object.
void | SetWindowIcon (HICON hIcon)
Call this member function to set the dialog's icon.
- Public Member Functions inherited from CXTPResizeDialog
CXTPResizeDialog ()
Constructs a CXTPResizeDialog object.
CXTPResizeDialog (const UINT nID, CWnd *pParent=0, const UINT nFlags=0)
Constructs a CXTPResizeDialog object.
CXTPResizeDialog (LPCTSTR lpszTemplateName, CWnd *pParent=0, const UINT nFlags=0)
Constructs a CXTPResizeDialog object.
- Public Member Functions inherited from CXTPResize
CXTPResize (CWnd *pWnd, const UINT nFlags=0)
Constructs a CXTPResize object.
virtual | ~CXTPResize ()
Destroys a CXTPResize object, handles cleanup and deallocation.
void | SetResize (UINT nID, XTP_RESIZE left, XTP_RESIZE top, XTP_RESIZE right, XTP_RESIZE bottom)
The SetResize function specifies how much each side of a control will move when the dialog is resized.
void | SetResize (UINT nID, const XTP_RESIZERECT &rrcSizing)
The SetResize function specifies how much each side of a control will move when the dialog is resized.
void | SetResize (UINT nID, HWND hWnd, const XTP_RESIZERECT &rrcSizing)
The SetResize function specifies how much each side of a control will move when the dialog is resized.
void | SetResize (UINT nID, HWND hWnd, const XTP_RESIZEPOINT &rpTopLeft, const XTP_RESIZEPOINT &rpBottomRight)
The SetResize function specifies how much each side of a control will move when the dialog is resized.
void | SetResize (UINT nID, const XTP_RESIZEPOINT &rpTopLeft, const XTP_RESIZEPOINT &rpBottomRight)
The SetResize function specifies how much each side of a control will move when the dialog is resized.
void | SetMinSize (CSize &sz)
This member function sets the minimum size explicitly.
void | SetMaxSize (CSize &sz)
This member function sets the maximum size.
BOOL | SavePlacement (LPCTSTR pszSection)
This member function saves the window placement to the registry.
BOOL | LoadPlacement (LPCTSTR pszSection)
This member function loads saved window placement information from the registry.
BOOL | AutoLoadPlacement (LPCTSTR pszSection)
This member function loads saved window placement information from the registry.

Protected Member Functions

virtual void | InsertMDIChild (HWND hwndMDIChildWnd)
Call this member function to add a MDI child to the window list.
virtual CString | GetChildWndText (HWND hWnd) const
Call this member function to retrieve a MDI child window's text.
void | RestoreAndMinimize ()
Call this member function to toggle the restore/minimize state for selected MDI children.
virtual void | SetEnableButtons ()
Call this member function to enable/disable button controls for the window list dialog depending on selection.
void | FillMDIClientWindowList (HWND hWnd)
Call this member function to populate the window list with MDI children.
virtual void | FillMDIWindowList ()
Call this member function to populate the window list with currently open MDI children.
virtual void | SelectMDIActive ()
Call this member function to select the active MDI child window.
- Protected Member Functions inherited from CXTPResize
void | SetResize (CWnd *pWnd, const CXTPResizeRect &rrcSizing, CRect rcWindow)
The SetResize function specifies how much each side of a control will move when the dialog is resized.
BOOL | RemoveResize (UINT nID)
This member function is called to remove the specified dialog item from the list of items to be resized.
void | RemoveAllControls ()
This member function is called to purge the list that contains the dialog items to be sized.
virtual void | Init ()
This member function is called from OnInitDialog or OnInitialUpdate to initialize the resize manager.
virtual void | Size ()
This member function is called from OnSize to move and resize the dialog items that are managed.
void | Reset ()
This member function is called when a property sheet in wizard mode has changed pages to alert the resize manager that the property sheet (common control) has moved the page back to its original size/position on the sheet.
void | Offset (CPoint ptOffset)
Called to offset dialog items by the amount specified by ptOffset.
void | UpdateControlRect (CWnd *pWnd)
Call this method to reset m_rrcWindow for an item.
void | GetMinMaxInfo (MINMAXINFO *pMMI)
This member function is called from OnGetMinMaxInfo to get the maximized position or dimensions or the minimum or maximum tracking size.
virtual void | AdjustResizeRect (CSize &rcWindow)
This method is called in the Size method to adjust a window rectangle to fit real client size.
BOOL | HasFlag (XTPResize eFlag)
This member function is called to determine if the specified flag has been set for the resize manager.
void | SetFlag (XTPResize eFlag)
This member function is called to set a specific flag for the resize manager.
virtual BOOL | Defer (HDWP &hdwp, CXTPResizeItem *pItem, int dx, int dy)
Called by CXTPResize to resize a child window.

Protected Attributes

HWND | m_hWndMDIClient
Handle to a MDI client area.
HICON | m_hIcon
Resize dialog's handle.
CMDIFrameWnd * | m_pMDIFrameWnd
Pointer to application's MDI frame.
CXTPListBox | m_lboxWindows
Flicker free list box to display MDI children.
- Protected Attributes inherited from CXTPResizeDialog
UINT | m_nDialogID
Contains the ID number of a dialog box template resource.
- Protected Attributes inherited from CXTPResize
UINT | m_nFlagsXX
Flags passed from the constructor.
CWnd * | m_pWnd
The associative relation to the window to be resized.
CSize | m_szWindow
Last dialog size.
CSize | m_szInitWindow
Initial dialog size.
CSize | m_szMin
Smallest size allowed.
CSize | m_szMax
Largest size allowed.
CString | m_strSection
Section in registry where window placement information is saved.
CXTPSizeIcon | m_scSizeIcon
Size icon window.
CResizeItemArray | m_arrItems
Array of controls.

Additional Inherited Members

- Protected Types inherited from CXTPResize
typedef CArray< CXTPResizeItem *, CXTPResizeItem *& > CResizeItemArray
Used by CXTPResize to maintain a list of children that are sizable.

Detailed Description

CXTPWindowList dialog.

Constructor & Destructor Documentation

◆ CXTPWindowList() [1/2]

CXTPWindowList ( CMDIFrameWnd * pMDIFrameWnd )

Constructs a CXTPWindowList object.

Parameters
pMDIFrameWnd Pointer to the application's main window.

◆ CXTPWindowList() [2/2]

CXTPWindowList ( HWND hWndMDIClient )

Constructs a CXTPWindowList object.

Parameters
hWndMDIClient Handle to the application's MDI client window.

Member Function Documentation

◆ FillMDIClientWindowList()

void FillMDIClientWindowList ( HWND hWnd )
protected

Call this member function to populate the window list with MDI children.

Parameters
hWnd Handle to a MDI client window.

◆ GetChildWndText()

virtual CString GetChildWndText ( HWND hWnd ) const
protectedvirtual

Call this member function to retrieve a MDI child window's text.

Parameters
hWnd Handle to a MDI child window.
Returns
A CString object representing the window's text.

◆ InsertMDIChild()

virtual void InsertMDIChild ( HWND hwndMDIChildWnd )
protectedvirtual

Call this member function to add a MDI child to the window list.

Parameters
hwndMDIChildWnd Pointer to a MDI child window.

◆ SetWindowIcon()

void SetWindowIcon ( HICON hIcon )
inline

Call this member function to set the dialog's icon.

Parameters
hIcon Icon handle to set.
The documentation for this class was generated from the following file:
  • XTPWindowList.h


Toolkit Pro: CXTPWindowPos Class Reference

Public Member Functions | List of all members
CXTPWindowPos Class Reference

CXTPWindowPos is a WINDOWPLACEMENT structure derived class. More...

Public Member Functions

CXTPWindowPos ()
Constructs a CXTPWindowPos object.
BOOL | LoadWindowPos (LPCTSTR lpszWndPos=NULL, LPCTSTR lpszSection=NULL)
This member function will load the window specified by 'pWnd' to its previous window position.
BOOL | LoadWindowPos (CWnd *pWnd, LPCTSTR lpszWndPos=NULL, LPCTSTR lpszSection=NULL)
This member function will load the window specified by 'pWnd' to its previous window position.
BOOL | SaveWindowPos (CWnd *pWnd, LPCTSTR lpszWndPos=NULL, LPCTSTR lpszSection=NULL)
This member function will save the window specified by 'pWnd' by its current window position.

Detailed Description

CXTPWindowPos is a WINDOWPLACEMENT structure derived class.

It extends the WINDOWPLACEMENT structure, and is used to save and restore window position.

Member Function Documentation

◆ LoadWindowPos() [1/2]

BOOL LoadWindowPos | ( | CWnd * | pWnd,
 |  | LPCTSTR | lpszWndPos = NULL,
 |  | LPCTSTR | lpszSection = NULL )

This member function will load the window specified by 'pWnd' to its previous window position.

Parameters
pWnd | Pointer to the CWnd* derived window to be restored to its previous state.
lpszWndPos | If NULL, then the default entry name will be used. If using this for MDI children or other windows, pass in a unique string value here. This must match for both LoadWindowPos and SaveWindowPos.
lpszSection | A NULL-terminated string representing the registry section where the window position is to be stored. If NULL, then the default value is used.
Returns
TRUE if successful, otherwise FALSE.

◆ LoadWindowPos() [2/2]

BOOL LoadWindowPos | ( | LPCTSTR | lpszWndPos = NULL,
 |  | LPCTSTR | lpszSection = NULL )

This member function will load the window specified by 'pWnd' to its previous window position.

Parameters
lpszWndPos | If NULL, then the default entry name will be used. If using this for MDI children or other windows, pass in a unique string value here. This must match for both LoadWindowPos and SaveWindowPos.
lpszSection | A NULL-terminated string representing the registry section where the window position is to be stored. If NULL, then the default value is used.
Returns
TRUE if successful, otherwise FALSE.

◆ SaveWindowPos()

BOOL SaveWindowPos | ( | CWnd * | pWnd,
 |  | LPCTSTR | lpszWndPos = NULL,
 |  | LPCTSTR | lpszSection = NULL )

This member function will save the window specified by 'pWnd' by its current window position.

Parameters
pWnd | Pointer to the CWnd* derived windows positon to be saved.
lpszWndPos | If NULL, then the default entry name will be used. If using this for MDI children or other windows, pass in a unique string value here. This must match for both LoadWindowPos and SaveWindowPos.
lpszSection | A NULL-terminated string representing the registry section where the window position is to be stored. If NULL, then the default value is used.
Returns
TRUE if successful, otherwise FALSE.
The documentation for this class was generated from the following file:
  • XTPWindowPos.h


Toolkit Pro: CXTPWindowRect Class Reference

Public Member Functions | List of all members
CXTPWindowRect Class Reference

CXTPWindowRect is a helper class used to retrieve the screen size for a specified window. More...

Public Member Functions

CXTPWindowRect (HWND hWnd)
Constructs a CXTPWindowRect object used to retrieve the screen size for the specified window.
CXTPWindowRect (const CWnd *pWnd)
Constructs a CXTPWindowRect object used to retrieve the screen size for the specified window.

Detailed Description

CXTPWindowRect is a helper class used to retrieve the screen size for a specified window.

Constructor & Destructor Documentation

◆ CXTPWindowRect() [1/2]

CXTPWindowRect ( HWND hWnd )

Constructs a CXTPWindowRect object used to retrieve the screen size for the specified window.

Parameters
hWnd Handle to the window to retrieve the screen size for.

◆ CXTPWindowRect() [2/2]

CXTPWindowRect ( const CWnd * pWnd )

Constructs a CXTPWindowRect object used to retrieve the screen size for the specified window.

Parameters
pWnd Points to the window to retrieve the screen size for.
The documentation for this class was generated from the following file:
  • XTPDrawHelpers.h


Toolkit Pro: CXTPWinThemeWrapper Class Reference

Public Member Functions | List of all members
CXTPWinThemeWrapper Class Reference

The CXTPWinThemeWrapper class wraps the UxTheme.dll visual theme API. More...

Public Member Functions

CXTPWinThemeWrapper (BOOL bUseSkinFramework=TRUE)
Constructs a CXTPWinThemeWrapper object.
virtual | ~CXTPWinThemeWrapper ()
Destroys a CXTPWinThemeWrapper object, handles cleanup and deallocation.
void | OpenThemeData (HWND hWnd, LPCWSTR pszClassList)
Open the theme data for the specified HWND and semi-colon separated list of class names.
void | CloseThemeData ()
Closes the theme data handle.
HRESULT | DrawThemeBackground (HDC hDC, int iPartID, int iStateID, const RECT *pRect, const RECT *pClipRect)
Draws the theme-specified border and fill for the "iPartId" and "iStateId".
HRESULT | DrawThemeText (HDC hDC, int iPartID, int iStateID, LPCWSTR pszText, int iCharCount, DWORD dwTextFlags, DWORD dwTextFlags2, const RECT *pRect)
Draws the text using the theme-specified color and font for the "iPartID" and "iStateID".
HRESULT | GetThemeBackgroundContentRect (HDC hDC, int iPartID, int iStateID, const RECT *pBoundingRect, RECT *pContentRect)
Gets the size of the content for the theme-defined background.
HRESULT | GetThemeBackgroundExtent (HDC hDC, int iPartID, int iStateID, const RECT *pContentRect, RECT *pExtentRect)
Calculates the size/location of the theme-specified background based on the "pContentRect".
HRESULT | DrawThemeBackgroundEx (HDC hDC, int iPartID, int iStateID, const RECT *pRect, const PDTBGOPTS pOptions)
Draws the theme-specified border and fill for the "iPartId" and "iStateId".
HRESULT | DrawThemeEdge (HDC hDC, int iPartID, int iStateID, const RECT *pDestRect, UINT uEdge, UINT uFlags, RECT *pContentRect)
Similar to the DrawEdge() API, but uses part colors and is high-DPI aware.
HRESULT | DrawThemeIcon (HDC hDC, int iPartID, int iStateID, const RECT *pRect, HIMAGELIST himl, int iImageIndex)
Draws an image within an imagelist based on a (possible) theme-defined effect.
HRESULT | DrawThemeParentBackground (HWND hWnd, HDC hDC, RECT *pRect)
Used by partially-transparent or alpha-blended child controls to draw the part of their parent that they appear in front of.
HRESULT | EnableThemeDialogTexture (HWND hWnd, DWORD dwFlags)
Enables/disables dialog background theme.
HRESULT | EnableTheming (BOOL bEnable)
Enables or disables theming for the current user in the current and future sessions.
HRESULT | GetCurrentThemeName (LPWSTR pszThemeFileName, int dwMaxNameChars, LPWSTR pszColorBuff, int cchMaxColorChars, LPWSTR pszSizeBuff, int cchMaxSizeChars)
Get the name of the current theme in-use.
DWORD | ThemeAppProperties ()
Retrieves the property flags that control how visual styles are applied in the current application.
HRESULT | GetThemeBackgroundRegion (HDC hDC, int iPartID, int iStateID, const RECT *pRect, HRGN *pRegion)
Computes the region for a regular or partially transparent theme-specified background that is bound by the specified "pRect".
HRESULT | GetThemeBool (int iPartID, int iStateID, int iPropID, BOOL *pfVal)
Get the value for the specified BOOL property.
HRESULT | GetThemeColor (int iPartID, int iStateID, int iPropID, COLORREF *pColor)
Get the value for the specified COLOR property.
HRESULT | GetThemeDocumentationProperty (LPCWSTR pszThemeName, LPCWSTR pszPropertyName, LPWSTR pszValueBuff, int cchMaxValChars)
Get the value for the specified property name from the [documentation] section of the themes.ini file for the specified theme.
HRESULT | GetThemeEnumValue (int iPartID, int iStateID, int iPropID, int *piVal)
Get the value for the specified ENUM property.
HRESULT | GetThemeFilename (int iPartID, int iStateID, int iPropID, LPWSTR pszThemeFilename, int cchMaxBuffChars)
Get the value for the specified FILENAME property.
HRESULT | GetThemeFont (HDC hDC, int iPartID, int iStateID, int iPropID, LOGFONTW *pFont)
Get the value for the specified font property.
HRESULT | GetThemeInt (int iPartID, int iStateID, int iPropID, int *piVal)
Get the value for the specified int property.
HRESULT | GetThemeIntList (int iPartID, int iStateID, int iPropID, INTLIST *pIntList)
Get the value for the specified INTLIST struct.
HRESULT | GetThemeMargins (HDC hDC, int iPartID, int iStateID, int iPropID, RECT *pRect, MARGINS *pMargins)
Get the value for the specified MARGINS property.
HRESULT | GetThemeMetric (HDC hDC, int iPartID, int iStateID, int iPropID, int *piVal)
Get the value for the specified metric/size property.
HRESULT | GetThemePartSize (HDC hDC, int iPartID, int iStateID, RECT *pRect, THEMESIZE eSize, SIZE *pSize)
Returns the specified size of the theme part.
HRESULT | GetThemePosition (int iPartID, int iStateID, int iPropID, POINT *pPoint)
Get the value for the specified position property.
HRESULT | GetThemePropertyOrigin (int iPartID, int iStateID, int iPropID, PROPERTYORIGIN *pOrigin)
Searches for the specified theme property and sets "pOrigin" to indicate where it was found (or not found)
HRESULT | GetThemeRect (int iPartID, int iStateID, int iPropID, RECT *pRect)
Get the value for the specified RECT property.
HRESULT | GetThemeString (int iPartID, int iStateID, int iPropID, LPWSTR pszBuff, int cchMaxBuffChars)
Get the value for the specified string property.
BOOL | GetThemeSysBool (int iBoolID)
Get the boolean value of specified System metric.
COLORREF | GetThemeSysColor (int iColorID)
Get the value of the specified System color.
HBRUSH | GetThemeSysColorBrush (int iColorID)
Get the brush for the specified System color.
HRESULT | GetThemeSysFont (int iFontID, LOGFONT *pLF)
Get the LOGFONT for the specified System font.
HRESULT | GetThemeSysInt (int iIntID, int *piValue)
Get the value of specified System int.
int | GetThemeSysSize (int iSizeID)
Get the value of the specified System size metric.
HRESULT | GetThemeSysString (int iStringID, LPWSTR pszStringBuff, int cchMaxStringChars)
Get the value of specified System string metric.
HRESULT | GetThemeTextExtent (HDC hDC, int iPartID, int iStateID, LPCWSTR pszText, int iCharCount, DWORD dwTextFlags, const RECT *pBoundingRect, RECT *pExtentRect)
Calculates the size/location of the specified text when rendered in the Theme Font.
HRESULT | GetThemeTextMetrics (HDC hDC, int iPartID, int iStateID, TEXTMETRIC *ptm)
Returns info about the theme-specified font for the part/ state passed in.
HTHEME | GetWindowTheme (HWND hWnd)
If window is themed, returns its most recent HTHEME from OpenThemeData() - Otherwise, returns NULL.
HRESULT | HitTestThemeBackground (HDC hDC, int iPartID, int iStateID, DWORD dwOptions, const RECT *pRect, HRGN hRgn, POINT ptTest, WORD *pwHitTestCode)
Returns a HitTestCode (a subset of the values returned by WM_NCHITTEST) for the point "ptTest" within the theme- specified background (bound by pRect).
BOOL | IsAppThemed () const
Reports whether the current application's user interface displays using visual styles.
BOOL | IsThemeActive () const
Can be used to test if a system theme is active for the current user session.
BOOL | IsAppThemeReady () const
Call this member function to determine if the application should display Windows XP themes.
BOOL | IsAppThemeActive () const
Checks whether the current application's user interface displays using visual styles and the theme is opened and ready for for being used.
BOOL | IsThemeBackgroundPartiallyTransparent (int iPartID, int iStateID)
Returns TRUE if the theme specified background for the part/ state has transparent pieces or alpha-blended pieces.
BOOL | IsThemeDialogTextureEnabled (HWND hWnd)
Reports whether the dialog supports background texturing.
BOOL | IsThemePartDefined (int iPartID, int iStateID)
Returns TRUE if the theme has defined parameters for the specified "iPartID" and "iStateID".
void | SetThemeAppProperties (DWORD dwFlags)
Sets the flags that control theming within the app.
HRESULT | SetWindowTheme (HWND hWnd, LPCWSTR pszSubAppName, LPCWSTR pszSubIdList)
Redirects an existing Window to use a different section of the current theme information than its class normally asks for.
BOOL | ThemeDataOpen () const
Call this member function to determine if OpenThemeData() was called to open theme information for a particular window.
DWORD | GetThemeAppProperties ()
HRESULT | BufferedPaintSetAlpha (HPAINTBUFFER hBufferedPaint, const RECT *prc, BYTE alpha)
Sets the alpha to a specified value in a given rectangle.
HPAINTBUFFER | BeginBufferedPaint (HDC hdcTarget, const RECT *prcTarget, XTP_UX_BUFFERFORMAT dwFormat, XTP_UX_PAINTPARAMS *pPaintParams, HDC *phdc)
Begins a buffered paint operation.
void | EndBufferedPaint (HPAINTBUFFER hBufferedPaint, BOOL fUpdateTarget)
Completes a buffered paint operation and frees the associated buffered paint handle.
HRESULT | DrawThemeTextEx (HDC hdc, int iPartId, int iStateId, LPCWSTR pszText, int cchText, DWORD dwTextFlags, LPRECT pRect, const XTP_UX_DTTOPTS *pOptions)
Draws the text using the theme-specified color and font for the "iPartID" and "iStateID".
void | SetThemeWrapperPtr (int nThemeWrapper, LPVOID lpWrapperPtr)
This method is used to set user-defined wrappers.

Detailed Description

The CXTPWinThemeWrapper class wraps the UxTheme.dll visual theme API.

You can use this class for rendering Windows XP themes for owner drawn controls.

Constructor & Destructor Documentation

◆ CXTPWinThemeWrapper()

CXTPWinThemeWrapper ( BOOL bUseSkinFramework = TRUE )

Constructs a CXTPWinThemeWrapper object.

Parameters
bUseSkinFramework TRUE to use skinframework.

Member Function Documentation

◆ BeginBufferedPaint()

HPAINTBUFFER BeginBufferedPaint | ( | HDC | hdcTarget,
 |  | const RECT * | prcTarget,
 |  | XTP_UX_BUFFERFORMAT | dwFormat,
 |  | XTP_UX_PAINTPARAMS * | pPaintParams,
 |  | HDC * | phdc )

Begins a buffered paint operation.

Parameters
hdcTarget | Handle of the target device context (DC) on which the buffer will be painted.
prcTarget | Pointer to a RECT structure that specifies the area of the target DC in which to paint.
dwFormat | A member of the BP_BUFFERFORMAT enumeration that specifies the format of the buffer.
pPaintParams | [in] Pointer to a BP_PAINTPARAMS structure that defines the paint operation parameters. This value can be NULL.
phdc | [out] When this function returns, this value points to the handle of the new device context.
Returns
A handle to the buffered paint context
See also
EndBufferedPaint

◆ BufferedPaintSetAlpha()

HRESULT BufferedPaintSetAlpha | ( | HPAINTBUFFER | hBufferedPaint,
 |  | const RECT * | prc,
 |  | BYTE | alpha )

Sets the alpha to a specified value in a given rectangle.

The alpha controls the amount of transparency applied when blending with the buffer onto the destination target device context (DC).

Parameters
alpha | Alpha channel value.
prc | Target rectangle pointer.
hBufferedPaint | Paint buffer handle.
Returns
S_OK if successful or an error code otherwise.

◆ CloseThemeData()

void CloseThemeData ( )

Closes the theme data handle.

CXTPWinThemeWrapper will do this automatically when destroyed or when OpenThemeData is called. Your window should handle the WM_THEMECHANGED message when called followed by a call to OpenThemeData.

◆ DrawThemeBackground()

HRESULT DrawThemeBackground | ( | HDC | hDC,
 |  | int | iPartID,
 |  | int | iStateID,
 |  | const RECT * | pRect,
 |  | const RECT * | pClipRect )

Draws the theme-specified border and fill for the "iPartId" and "iStateId".

This could be based on a bitmap file, a border and fill, or other image description.

Parameters
hDC | HDC to draw into
iPartID | Part number to draw
iStateID | State number (of the part) to draw
pRect | Defines the size/location of the part
pClipRect | Optional clipping rect (don't draw outside it)
Returns
Returns S_OK if successful, or an error value otherwise.

◆ DrawThemeBackgroundEx()

HRESULT DrawThemeBackgroundEx | ( | HDC | hDC,
 |  | int | iPartID,
 |  | int | iStateID,
 |  | const RECT * | pRect,
 |  | const PDTBGOPTS | pOptions )

Draws the theme-specified border and fill for the "iPartId" and "iStateId".

This could be based on a bitmap file, a border and fill, or other image description.

Parameters
hDC | HDC to draw into
iPartID | Part number to draw
iStateID | State number (of the part) to draw
pRect | Defines the size/location of the part
pOptions | Pointer to optional parameters.
Returns
Returns S_OK if successful, or an error value otherwise.

◆ DrawThemeEdge()

HRESULT DrawThemeEdge | ( | HDC | hDC,
 |  | int | iPartID,
 |  | int | iStateID,
 |  | const RECT * | pDestRect,
 |  | UINT | uEdge,
 |  | UINT | uFlags,
 |  | RECT * | pContentRect )

Similar to the DrawEdge() API, but uses part colors and is high-DPI aware.

Parameters
hDC | HDC to draw into
iPartID | Part number to draw.
iStateID | State number of part
pDestRect | The RECT used to draw the line(s)
uEdge | Same as DrawEdge() API
uFlags | Same as DrawEdge() API
pContentRect | Receives the interior rect if (uFlags & BF_ADJUST)
Returns
Returns S_OK if successful, or an error value otherwise.

◆ DrawThemeIcon()

HRESULT DrawThemeIcon | ( | HDC | hDC,
 |  | int | iPartID,
 |  | int | iStateID,
 |  | const RECT * | pRect,
 |  | HIMAGELIST | himl,
 |  | int | iImageIndex )

Draws an image within an imagelist based on a (possible) theme-defined effect.

Parameters
hDC | HDC to draw into
iPartID | Part number to draw.
iStateID | State number of part
pRect | The RECT to draw the image within
himl | Handle to IMAGELIST
iImageIndex | Index into IMAGELIST (which icon to draw)
Returns
Returns S_OK if successful, or an error value otherwise.

◆ DrawThemeParentBackground()

HRESULT DrawThemeParentBackground | ( | HWND | hWnd,
 |  | HDC | hDC,
 |  | RECT * | pRect )

Used by partially-transparent or alpha-blended child controls to draw the part of their parent that they appear in front of.

Parameters
hWnd | Handle of the child control
hDC | HDC of the child control
pRect | (optional) rect that defines the area to be Drawn (CHILD coordinates)
Returns
Returns S_OK if successful, or an error value otherwise.

◆ DrawThemeText()

HRESULT DrawThemeText | ( | HDC | hDC,
 |  | int | iPartID,
 |  | int | iStateID,
 |  | LPCWSTR | pszText,
 |  | int | iCharCount,
 |  | DWORD | dwTextFlags,
 |  | DWORD | dwTextFlags2,
 |  | const RECT * | pRect )

Draws the text using the theme-specified color and font for the "iPartID" and "iStateID".

Parameters
hDC | HDC to draw into
iPartID | Part number to draw
iStateID | State number (of the part) to draw
pszText | Actual text to draw
iCharCount | Number of chars to draw (-1 for all)
dwTextFlags | Same as DrawText() "uFormat" param
dwTextFlags2 | Additional drawing options
pRect | Defines the size/location of the part
Returns
Returns S_OK if successful, or an error value otherwise.

◆ DrawThemeTextEx()

HRESULT DrawThemeTextEx | ( | HDC | hdc,
 |  | int | iPartId,
 |  | int | iStateId,
 |  | LPCWSTR | pszText,
 |  | int | cchText,
 |  | DWORD | dwTextFlags,
 |  | LPRECT | pRect,
 |  | const XTP_UX_DTTOPTS * | pOptions )

Draws the text using the theme-specified color and font for the "iPartID" and "iStateID".

Parameters
hdc | HDC to draw into
iPartId | Part number to draw
iStateId | State number (of the part) to draw
pszText | Actual text to draw
cchText | Number of chars to draw (-1 for all)
dwTextFlags | Same as DrawText() "uFormat" param
pRect | Defines the size/location of the part
pOptions | Additional drawing options
Returns
Returns S_OK if successful, or an error value otherwise.

◆ EnableThemeDialogTexture()

HRESULT EnableThemeDialogTexture | ( | HWND | hWnd,
 |  | DWORD | dwFlags )

Enables/disables dialog background theme.

This method can be used to tailor dialog compatibility with child windows and controls that may or may not coordinate the rendering of their client area backgrounds with that of their parent dialog in a manner that supports seamless background texturing.

Parameters
hWnd | The window handle of the target dialog
dwFlags | ETDT_ENABLE to enable the theme-defined dialog background texturing, ETDT_DISABLE to disable background texturing, ETDT_ENABLETAB to enable the theme-defined background texturing using the Tab texture
Returns
Returns S_OK if successful, or an error value otherwise.

◆ EnableTheming()

HRESULT EnableTheming ( BOOL bEnable )

Enables or disables theming for the current user in the current and future sessions.

Parameters
bEnable If FALSE, disable theming & turn themes off. if TRUE, enable theming and, if user previously had a theme active, make it active now.
Returns
Returns S_OK if successful, or an error value otherwise.

◆ EndBufferedPaint()

void EndBufferedPaint | ( | HPAINTBUFFER | hBufferedPaint,
 |  | BOOL | fUpdateTarget )

Completes a buffered paint operation and frees the associated buffered paint handle.

Parameters
hBufferedPaint | Handle of the buffered paint context, obtained through BeginBufferedPaint
fUpdateTarget | TRUE to copy the buffer to the target device context (DC)
See also
BeginBufferedPaint

◆ GetCurrentThemeName()

HRESULT GetCurrentThemeName | ( | LPWSTR | pszThemeFileName,
 |  | int | dwMaxNameChars,
 |  | LPWSTR | pszColorBuff,
 |  | int | cchMaxColorChars,
 |  | LPWSTR | pszSizeBuff,
 |  | int | cchMaxSizeChars )

Get the name of the current theme in-use.

Optionally, return the ColorScheme name and the Size name of the theme.

Parameters
pszThemeFileName | Receives the theme path & filename
dwMaxNameChars | Max chars allowed in pszNameBuff
pszColorBuff | (optional) receives the canonical color scheme name (not the display name)
cchMaxColorChars | Max chars allowed in pszColorBuff
pszSizeBuff | (optional) receives the canonical size name (not the display name)
cchMaxSizeChars | Max chars allowed in pszSizeBuff
Returns
Returns S_OK if successful, or an error value otherwise.

◆ GetThemeAppProperties()

DWORD GetThemeAppProperties ( )
Returns
Retrieves the property flags that control how visual styles are applied in the current application.

◆ GetThemeBackgroundContentRect()

HRESULT GetThemeBackgroundContentRect | ( | HDC | hDC,
 |  | int | iPartID,
 |  | int | iStateID,
 |  | const RECT * | pBoundingRect,
 |  | RECT * | pContentRect )

Gets the size of the content for the theme-defined background.

This is usually the area inside the borders or Margins.

Parameters
hDC | (optional) device content to be used for drawing
iPartID | Part number to draw
iStateID | State number (of the part) to draw
pBoundingRect | The outer RECT of the part being drawn
pContentRect | RECT to receive the content area
Returns
Returns S_OK if successful, or an error value otherwise.

◆ GetThemeBackgroundExtent()

HRESULT GetThemeBackgroundExtent | ( | HDC | hDC,
 |  | int | iPartID,
 |  | int | iStateID,
 |  | const RECT * | pContentRect,
 |  | RECT * | pExtentRect )

Calculates the size/location of the theme-specified background based on the "pContentRect".

Parameters
hDC | (optional) device content to be used for drawing
iPartID | Part number to draw
iStateID | State number (of the part) to draw
pContentRect | RECT that defines the content area
pExtentRect | RECT to receive the overall size/location of part
Returns
Returns S_OK if successful, or an error value otherwise.

◆ GetThemeBackgroundRegion()

HRESULT GetThemeBackgroundRegion | ( | HDC | hDC,
 |  | int | iPartID,
 |  | int | iStateID,
 |  | const RECT * | pRect,
 |  | HRGN * | pRegion )

Computes the region for a regular or partially transparent theme-specified background that is bound by the specified "pRect".

If the rectangle is empty, sets the hRgn to NULL and return S_FALSE.

Parameters
hDC | Optional hDC to draw into (DPI scaling)
iPartID | Part number to draw.
iStateID | State number (of the part)
pRect | The RECT used to draw the part
pRegion | Receives handle to calculated region
Returns
Returns S_OK if successful, or an error value otherwise.

◆ GetThemeBool()

HRESULT GetThemeBool | ( | int | iPartID,
 |  | int | iStateID,
 |  | int | iPropID,
 |  | BOOL * | pfVal )

Get the value for the specified BOOL property.

Parameters
iPartID | Part number
iStateID | State number of part
iPropID | The property number to get the value for
pfVal | Receives the value of the property
Returns
Returns S_OK if successful, or an error value otherwise.

◆ GetThemeColor()

HRESULT GetThemeColor | ( | int | iPartID,
 |  | int | iStateID,
 |  | int | iPropID,
 |  | COLORREF * | pColor )

Get the value for the specified COLOR property.

Parameters
iPartID | Part number
iStateID | State number of part
iPropID | The property number to get the value for
pColor | Receives the value of the property
Returns
Returns S_OK if successful, or an error value otherwise.

◆ GetThemeDocumentationProperty()

HRESULT GetThemeDocumentationProperty | ( | LPCWSTR | pszThemeName,
 |  | LPCWSTR | pszPropertyName,
 |  | LPWSTR | pszValueBuff,
 |  | int | cchMaxValChars )

Get the value for the specified property name from the [documentation] section of the themes.ini file for the specified theme.

If the property has been localized in the theme files string table, the localized version of the property value is returned.

Parameters
pszThemeName | Filename of the theme file to query
pszPropertyName | Name of the string property to retrieve a value for
pszValueBuff | Receives the property string value
cchMaxValChars | Max chars allowed in pszValueBuff
Returns
Returns S_OK if successful, or an error value otherwise.

◆ GetThemeEnumValue()

HRESULT GetThemeEnumValue | ( | int | iPartID,
 |  | int | iStateID,
 |  | int | iPropID,
 |  | int * | piVal )

Get the value for the specified ENUM property.

Parameters
iPartID | Part number
iStateID | State number of part
iPropID | The property number to get the value for
piVal | Receives the value of the enum (cast to int*)
Returns
Returns S_OK if successful, or an error value otherwise.

◆ GetThemeFilename()

HRESULT GetThemeFilename | ( | int | iPartID,
 |  | int | iStateID,
 |  | int | iPropID,
 |  | LPWSTR | pszThemeFilename,
 |  | int | cchMaxBuffChars )

Get the value for the specified FILENAME property.

Parameters
iPartID | Part number
iStateID | State number of part
iPropID | The property number to search for
pszThemeFilename | Output buffer to receive the filename
cchMaxBuffChars | The size of the return buffer, in chars
Returns
Returns S_OK if successful, or an error value otherwise.

◆ GetThemeFont()

HRESULT GetThemeFont | ( | HDC | hDC,
 |  | int | iPartID,
 |  | int | iStateID,
 |  | int | iPropID,
 |  | LOGFONTW * | pFont )

Get the value for the specified font property.

Parameters
hDC | (optional) hDC to be drawn to (DPI scaling)
iPartID | Part number
iStateID | State number of part
iPropID | The property number to get the value for
pFont | Receives the value of the LOGFONT property (scaled for the current logical screen dpi)
Returns
Returns S_OK if successful, or an error value otherwise.

◆ GetThemeInt()

HRESULT GetThemeInt | ( | int | iPartID,
 |  | int | iStateID,
 |  | int | iPropID,
 |  | int * | piVal )

Get the value for the specified int property.

Parameters
iPartID | Part number
iStateID | State number of part
iPropID | The property number to get the value for
piVal | Receives the value of the property
Returns
Returns S_OK if successful, or an error value otherwise.

◆ GetThemeIntList()

HRESULT GetThemeIntList | ( | int | iPartID,
 |  | int | iStateID,
 |  | int | iPropID,
 |  | INTLIST * | pIntList )

Get the value for the specified INTLIST struct.

Parameters
iPartID | Part number
iStateID | State number of part
iPropID | The property number to get the value for
pIntList | Receives the value of the INTLIST property
Returns
Returns S_OK if successful, or an error value otherwise.

◆ GetThemeMargins()

HRESULT GetThemeMargins | ( | HDC | hDC,
 |  | int | iPartID,
 |  | int | iStateID,
 |  | int | iPropID,
 |  | RECT * | pRect,
 |  | MARGINS * | pMargins )

Get the value for the specified MARGINS property.

Parameters
hDC | (optional) hDC to be used for drawing
iPartID | Part number
iStateID | State number of part
iPropID | The property number to get the value for
pRect | RECT for area to be drawn into
pMargins | Receives the value of the MARGINS property
Returns
Returns S_OK if successful, or an error value otherwise.

◆ GetThemeMetric()

HRESULT GetThemeMetric | ( | HDC | hDC,
 |  | int | iPartID,
 |  | int | iStateID,
 |  | int | iPropID,
 |  | int * | piVal )

Get the value for the specified metric/size property.

Parameters
hDC | (optional) hDC to be drawn into (DPI scaling)
iPartID | Part number
iStateID | State number of part
iPropID | The property number to get the value for
piVal | Receives the value of the property
Returns
Returns S_OK if successful, or an error value otherwise.

◆ GetThemePartSize()

HRESULT GetThemePartSize | ( | HDC | hDC,
 |  | int | iPartID,
 |  | int | iStateID,
 |  | RECT * | pRect,
 |  | THEMESIZE | eSize,
 |  | SIZE * | pSize )

Returns the specified size of the theme part.

Parameters
hDC | HDC to select font into & measure against
iPartID | Part number to retrieve size for
iStateID | State number (of the part)
pRect | (optional) rect for part drawing destination
eSize | The type of size to be retrieved
pSize | Receives the specified size of the part
Returns
Returns S_OK if successful, or an error value otherwise.

◆ GetThemePosition()

HRESULT GetThemePosition | ( | int | iPartID,
 |  | int | iStateID,
 |  | int | iPropID,
 |  | POINT * | pPoint )

Get the value for the specified position property.

Parameters
iPartID | Part number
iStateID | State number of part
iPropID | The property number to get the value for
pPoint | Receives the value of the position property
Returns
Returns S_OK if successful, or an error value otherwise.

◆ GetThemePropertyOrigin()

HRESULT GetThemePropertyOrigin | ( | int | iPartID,
 |  | int | iStateID,
 |  | int | iPropID,
 |  | PROPERTYORIGIN * | pOrigin )

Searches for the specified theme property and sets "pOrigin" to indicate where it was found (or not found)

Parameters
iPartID | Part number
iStateID | State number of part
iPropID | The property number to search for
pOrigin | Receives the value of the property origin
Returns
Returns S_OK if successful, or an error value otherwise.

◆ GetThemeRect()

HRESULT GetThemeRect | ( | int | iPartID,
 |  | int | iStateID,
 |  | int | iPropID,
 |  | RECT * | pRect )

Get the value for the specified RECT property.

Parameters
iPartID | Part number
iStateID | State number of part
iPropID | The property number to get the value for
pRect | Receives the value of the RECT property
Returns
Returns S_OK if successful, or an error value otherwise.

◆ GetThemeString()

HRESULT GetThemeString | ( | int | iPartID,
 |  | int | iStateID,
 |  | int | iPropID,
 |  | LPWSTR | pszBuff,
 |  | int | cchMaxBuffChars )

Get the value for the specified string property.

Parameters
iPartID | Part number
iStateID | State number of part
iPropID | The property number to get the value for
pszBuff | Receives the string property value
cchMaxBuffChars | Max. number of chars allowed in pszBuff
Returns
Returns S_OK if successful, or an error value otherwise.

◆ GetThemeSysBool()

BOOL GetThemeSysBool ( int iBoolID )

Get the boolean value of specified System metric.

Parameters
iBoolID The TMT_XXX BOOL number (first BOOL is TMT_FLATMENUS)
Returns
Returns S_OK if successful, or an error value otherwise.

◆ GetThemeSysColor()

COLORREF GetThemeSysColor ( int iColorID )

Get the value of the specified System color.

Parameters
iColorID The system color index defined in winuser.h
Returns
The value of the specified system color.

◆ GetThemeSysColorBrush()

HBRUSH GetThemeSysColorBrush ( int iColorID )

Get the brush for the specified System color.

Parameters
iColorID The system color index defined in winuser.h
Returns
Handle to brush data.

◆ GetThemeSysFont()

HRESULT GetThemeSysFont | ( | int | iFontID,
 |  | LOGFONT * | pLF )

Get the LOGFONT for the specified System font.

Parameters
iFontID | The TMT_XXX font number (first font is TMT_CAPTIONFONT)
pLF | Ptr to LOGFONT to receive the font value. (scaled for the current logical screen dpi)
Returns
Returns S_OK if successful, or an error value otherwise.

◆ GetThemeSysInt()

HRESULT GetThemeSysInt | ( | int | iIntID,
 |  | int * | piValue )

Get the value of specified System int.

Parameters
iIntID | Must be one of the following values: TMT_DPIX TMT_DPIY TMT_MINCOLORDEPTH
piValue | Ptr to int to receive value
Returns
Returns S_OK if successful, or an error value otherwise.

◆ GetThemeSysSize()

int GetThemeSysSize ( int iSizeID )

Get the value of the specified System size metric.

(scaled for the current logical screen dpi)

Parameters
iSizeID The following values are supported: SM_CXBORDER (border width) SM_CXVSCROLL (scrollbar width) SM_CYHSCROLL (scrollbar height) SM_CXSIZE (caption width) SM_CYSIZE (caption height) SM_CXSMSIZE (small caption width) SM_CYSMSIZE (small caption height) SM_CXMENUSIZE (menubar width) SM_CYMENUSIZE (menubar height)
Returns
Returns S_OK if successful, or an error value otherwise.

◆ GetThemeSysString()

HRESULT GetThemeSysString | ( | int | iStringID,
 |  | LPWSTR | pszStringBuff,
 |  | int | cchMaxStringChars )

Get the value of specified System string metric.

Parameters
iStringID | Must be one of the following values: TMT_CSSNAME TMT_XMLNAME
pszStringBuff | The buffer to receive the string value
cchMaxStringChars | Max. number of chars that pszStringBuff can hold
Returns
The size in dots per inch (DPI) scaled for the current logical screen.

◆ GetThemeTextExtent()

HRESULT GetThemeTextExtent | ( | HDC | hDC,
 |  | int | iPartID,
 |  | int | iStateID,
 |  | LPCWSTR | pszText,
 |  | int | iCharCount,
 |  | DWORD | dwTextFlags,
 |  | const RECT * | pBoundingRect,
 |  | RECT * | pExtentRect )

Calculates the size/location of the specified text when rendered in the Theme Font.

Parameters
hDC | HDC to select font & measure into
iPartID | Part number to draw.
iStateID | State number (of the part)
pszText | The text to be measured
iCharCount | Number of chars to draw (-1 for all)
dwTextFlags | Same as DrawText() "uFormat" param
pBoundingRect | Optional: to control layout of text
pExtentRect | Receives the RECT for text size/location
Returns
Returns S_OK if successful, or an error value otherwise.

◆ GetThemeTextMetrics()

HRESULT GetThemeTextMetrics | ( | HDC | hDC,
 |  | int | iPartID,
 |  | int | iStateID,
 |  | TEXTMETRIC * | ptm )

Returns info about the theme-specified font for the part/ state passed in.

Parameters
hDC | Optional: hDC for screen context
iPartID | Part number to draw.
iStateID | State number (of the part)
ptm | Receives the font info
Returns
Returns S_OK if successful, or an error value otherwise.

◆ GetWindowTheme()

HTHEME GetWindowTheme ( HWND hWnd )

If window is themed, returns its most recent HTHEME from OpenThemeData() - Otherwise, returns NULL.

Parameters
hWnd The window to get the HTHEME of
Returns
The most recent theme handle from OpenThemeData.

◆ HitTestThemeBackground()

HRESULT HitTestThemeBackground | ( | HDC | hDC,
 |  | int | iPartID,
 |  | int | iStateID,
 |  | DWORD | dwOptions,
 |  | const RECT * | pRect,
 |  | HRGN | hRgn,
 |  | POINT | ptTest,
 |  | WORD * | pwHitTestCode )

Returns a HitTestCode (a subset of the values returned by WM_NCHITTEST) for the point "ptTest" within the theme- specified background (bound by pRect).

"pRect" and "ptTest" should both be in the same coordinate system (client, screen, etc).

Parameters
hDC | HDC to draw into
iPartID | Part number to test against
iStateID | State number (of the part)
pRect | The RECT used to draw the part
hRgn | Optional region to use; must be in same coordinates as pRect and pTest.
ptTest | The hit point to be tested
dwOptions | HTTB_xxx constants
pwHitTestCode | Receives the returned hit test code One of: HTNOWHERE, HTLEFT, HTTOPLEFT, HTBOTTOMLEFT, HTRIGHT, HTTOPRIGHT, HTBOTTOMRIGHT, HTTOP, HTBOTTOM, HTCLIENT
Returns
Returns S_OK if successful, or an error value otherwise.

◆ IsAppThemeActive()

BOOL IsAppThemeActive ( ) const

Checks whether the current application's user interface displays using visual styles and the theme is opened and ready for for being used.

Returns
Returns one of the following values. TRUE - The application has a visual style applied and the theme is opened. FALSE - The application does not have a visual style applied or the theme is not opened.

◆ IsAppThemed()

BOOL IsAppThemed ( ) const

Reports whether the current application's user interface displays using visual styles.

Returns
Returns one of the following values. TRUE - The application has a visual style applied. FALSE - The application does not have a visual style applied.

◆ IsAppThemeReady()

BOOL IsAppThemeReady ( ) const

Call this member function to determine if the application should display Windows XP themes.

IsAppThemeReady() will first check to see if the operating system supports Windows XP theme display, then checks to see if the application has any controls that are able to display Windows XP themes, then finally checks to see if the application has included a manifest file.

Returns
TRUE if the application can display Windows XP themes, otherwise FALSE.

◆ IsThemeActive()

BOOL IsThemeActive ( ) const

Can be used to test if a system theme is active for the current user session.

use the API "IsAppThemed()" to test if a theme is active for the calling process.

Returns
Returns one of the following values: TRUE - A visual style is enabled, and windows with visual styles applied should call OpenThemeData to start using theme drawing services. FALSE - A visual style is not enabled, and the window message handler does not need to make another call to IsThemeActive until it receives a WM_THEMECHANGED message.

◆ IsThemeBackgroundPartiallyTransparent()

BOOL IsThemeBackgroundPartiallyTransparent | ( | int | iPartID,
 |  | int | iStateID )

Returns TRUE if the theme specified background for the part/ state has transparent pieces or alpha-blended pieces.

Parameters
iPartID | Part number
iStateID | State number of part
Returns
Returns one of the following values.

TRUE The theme-specified background for a particular iPartId and iStateId has transparent pieces or alpha- blended pieces.

FALSE The theme-specified background for a particular iPartId and iStateId does not have transparent pieces or alpha-blended pieces.

◆ IsThemeDialogTextureEnabled()

BOOL IsThemeDialogTextureEnabled ( HWND hWnd )

Reports whether the dialog supports background texturing.

Parameters
hWnd A handle of a window to check.
Returns
Returns one of the following values.

TRUE Background texturing is supported.

FALSE Background texturing is not supported.

◆ IsThemePartDefined()

BOOL IsThemePartDefined | ( | int | iPartID,
 |  | int | iStateID )

Returns TRUE if the theme has defined parameters for the specified "iPartID" and "iStateID".

Parameters
iPartID | Part number to find definition for
iStateID | State number of part
Returns
Returns one of the following values.

TRUE The theme has defined parameters for the specified iPartId and iStateId

FALSE The theme does not have defined parameters for the specified iPartId and iStateId

◆ OpenThemeData()

void OpenThemeData | ( | HWND | hWnd,
 |  | LPCWSTR | pszClassList )

Open the theme data for the specified HWND and semi-colon separated list of class names.

OpenThemeData() will try each class name, one at a time, and use the first matching theme info found.

Parameters
hWnd | Window handle of the control/window to be themed.
pszClassList | Class name (or list of names) to match to theme data section. if the list contains more than one name, the names are tested one at a time for a match. If a match is found, OpenThemeData() returns a theme handle associated with the matching class. This param is a list (instead of just a single class name) to provide the class an opportunity to get the "best" match between the class and the current theme. For example, a button might pass L"OkButton;Button" if its ID=ID_OK. If the current theme has an entry for OkButton, that will be used. Otherwise, we fall back on the normal Button entry.

◆ SetThemeAppProperties()

void SetThemeAppProperties ( DWORD dwFlags )

Sets the flags that control theming within the app.

Parameters
dwFlags The flag values to be set

◆ SetThemeWrapperPtr()

void SetThemeWrapperPtr | ( | int | nThemeWrapper,
 |  | LPVOID | lpWrapperPtr )

This method is used to set user-defined wrappers.

Parameters
nThemeWrapper | Wrapper ID.
lpWrapperPtr | Wrapper pointer.

◆ SetWindowTheme()

HRESULT SetWindowTheme | ( | HWND | hWnd,
 |  | LPCWSTR | pszSubAppName,
 |  | LPCWSTR | pszSubIdList )

Redirects an existing Window to use a different section of the current theme information than its class normally asks for.

Parameters
hWnd | The handle of the window (cannot be NULL)
pszSubAppName | App (group) name to use in place of the calling app's name. If NULL, the actual calling app name will be used.
pszSubIdList | Semicolon separated list of class Id names to use in place of actual list passed by the window's class. if NULL, the id list from the calling class is used.

The Theme Manager will remember the "pszSubAppName" and the "pszSubIdList" associations thru the lifetime of the window (even if themes are subsequently changed). The window is sent a "WM_THEMECHANGED" msg at the end of this call, so that the new theme can be found and applied. When "pszSubAppName" or "pszSubIdList" are NULL, the Theme Manager removes the previously remember association. To turn off theme-ing for the specified window, you can pass an empty string (L"") so it won't match any section entries.

Returns
Returns S_OK if successful, or an error value otherwise.

◆ ThemeAppProperties()

DWORD ThemeAppProperties ( )

Retrieves the property flags that control how visual styles are applied in the current application.

Returns
The following return values are bit flags combined with a logical OR operator. STAP_ALLOW_NONCLIENT - Specifies that the non-client areas of application windows have visual styles applied. STAP_ALLOW_CONTROLS - Specifies that controls in application windows have visual styles applied. STAP_ALLOW_WEBCONTENT - Specifies that all web content displayed in an application is rendered using visual styles.

◆ ThemeDataOpen()

BOOL ThemeDataOpen ( ) const

Call this member function to determine if OpenThemeData() was called to open theme information for a particular window.

Returns
TRUE if theme information was loaded, otherwise FALSE.
The documentation for this class was generated from the following file:
  • XTPWinThemeWrapper.h


Toolkit Pro: CXTPWinThread Class Reference

Public Member Functions | List of all members
CXTPWinThread Class Reference

All XTP threads should derive from CXTPWinThread instead of CWinThread in order to ensure compatibility with the main process thread that is derived from CXTPWinApp. More...

Inheritance diagram for CXTPWinThread:
[legend]

Public Member Functions

CXTPWinThread (int xtpComInit=xtpComInitAppDefault)
Default constructor.
virtual ~CXTPWinThread ()
Default destructor, handles cleanup / deallocation.

Detailed Description

All XTP threads should derive from CXTPWinThread instead of CWinThread in order to ensure compatibility with the main process thread that is derived from CXTPWinApp.

Constructor & Destructor Documentation

◆ CXTPWinThread()

CXTPWinThread ( int xtpComInit = xtpComInitAppDefault )

Default constructor.

Parameters
xtpComInit Global COM/OLE initialization method.

The default xtpComInitAppDefault makes a thread to use the same COM/OLE model that is used by the main application thread derived from CXTPWinApp. If extended COM initialization flags are being used bu CoInitializeEx function is not available then xtpComInitSTA is assumed, all other flags get ignored and the legacy CoInitialize gets called.

See also
XTPComInit
The documentation for this class was generated from the following file:
  • XTPWinThread.h


Toolkit Pro: CXTPXamlPreviewProvider Class Reference

List of all members
CXTPXamlPreviewProvider Class Reference

Provides a preview handler for XAML files that uses Markup components for rendering file contents. More...

Inheritance diagram for CXTPXamlPreviewProvider:
[legend]

Additional Inherited Members

- Public Member Functions inherited from IXTPPreviewProvider
virtual | ~IXTPPreviewProvider ()
Handles object destruction.
- Protected Member Functions inherited from CXTPPreviewProviderBase
CXTPPreviewProviderBase ()
Handles object construction.
void | BindHost (IXTPPreviewHost &host)
The method is called by the host preview control when the provider is initially bound to the host.
IXTPPreviewHost & | GetHost () const
Obtains the preview host interface that the provider is bound to.

Detailed Description

Provides a preview handler for XAML files that uses Markup components for rendering file contents.

See also
CXTPSystemPreviewProvider, CXTPCommonPicturePreviewProvider, CXTPGifPreviewProvider, CXTPMsgPreviewProvider, CXTPTextPreviewProvider
The documentation for this class was generated from the following file:
  • XTPXamlPreviewProvider.h


Toolkit Pro: CXTPZipMemFile Class Reference

List of all members
CXTPZipMemFile Class Reference

Zipped memory file. More...

Detailed Description

Zipped memory file.

The documentation for this class was generated from the following file:
  • XTPSystemHelpers.h


Toolkit Pro: ITimeProvider Class Reference

List of all members
ITimeProvider Class Referenceabstract

Interface for overriding the GetCurrentTime() function in calendar control. More...

Detailed Description

Interface for overriding the GetCurrentTime() function in calendar control.

Allows a custom date-time to be set for calendar

The documentation for this class was generated from the following file:
  • XTPCalendarUtils.h


Toolkit Pro: IXTPApplicationEvents Struct Reference

Public Member Functions | List of all members
IXTPApplicationEvents Struct Reference

Defines a callback interface for XTP application event sink. More...

Inheritance diagram for IXTPApplicationEvents:
[legend]

Public Member Functions

virtual | ~IXTPApplicationEvents ()
Handles object destruction.
virtual void | OnBeforeApplicationShutdown (CXTPApplication *pApplication)
Is called by framework before application shut down processing starts.
virtual void | OnApplicationShutdown (CXTPApplication *pApplication)
Is called by framework when application is being shutdown before the actual shutting down.
virtual void | OnAfterApplicationShutdown (CXTPApplication *pApplication)
Is called by framework after application shut down processing is completed.
virtual void | OnAmbientPropertyChanged (CXTPApplication *pApplication, XTPApplicationAmbientProperty nProperty)
Called by framework when an ambient property is changed.

Detailed Description

Defines a callback interface for XTP application event sink.

Member Function Documentation

◆ OnAfterApplicationShutdown()

virtual void OnAfterApplicationShutdown ( CXTPApplication * pApplication )
inlinevirtual

Is called by framework after application shut down processing is completed.

Parameters
pApplication Event sending application pointer.

◆ OnAmbientPropertyChanged()

virtual void OnAmbientPropertyChanged | ( | CXTPApplication * | pApplication,
 |  | XTPApplicationAmbientProperty | nProperty )
 inlinevirtual

Called by framework when an ambient property is changed.

Parameters
pApplication | Event sending application pointer.
nProperty | Updated ambient property identifier.
See also
CXTPApplication::SetAmbientProperty, CXTPApplication::GetAmbientProperty

◆ OnApplicationShutdown()

virtual void OnApplicationShutdown ( CXTPApplication * pApplication )
inlinevirtual

Is called by framework when application is being shutdown before the actual shutting down.

Parameters
pApplication Event sending application pointer.

◆ OnBeforeApplicationShutdown()

virtual void OnBeforeApplicationShutdown ( CXTPApplication * pApplication )
inlinevirtual

Is called by framework before application shut down processing starts.

Parameters
pApplication Event sending application pointer.

Reimplemented in CXTPSkinManager.

The documentation for this struct was generated from the following file:
  • XTPApplication.h


Toolkit Pro: IXTPFrameShadowManagerEvents Struct Reference

Public Member Functions | List of all members
IXTPFrameShadowManagerEvents Struct Reference

An interface for Frame Shadow Manager event listener. More...

Inheritance diagram for IXTPFrameShadowManagerEvents:
[legend]

Public Member Functions

virtual | ~IXTPFrameShadowManagerEvents ()
Handles object destruction.
virtual void | OnFrameShadowEnabled (CXTPFrameShadowManager *pManager, HWND hwndOwner, CXTPFrameShadow *pShadow)
Invoked right after a shadow is enabled for a window.
virtual void | OnFrameShadowDisabled (CXTPFrameShadowManager *pManager, HWND hwndOwner, CXTPFrameShadow *pShadow)
Invoked right before a shadow is disabled for a window.
virtual void | OnFlagsChanged (CXTPFrameShadowManager *pManager, int nOldEffectiveFlags, int nNewEffectiveFlags)
Invoked when flags are changed.

Detailed Description

An interface for Frame Shadow Manager event listener.

Member Function Documentation

◆ OnFlagsChanged()

virtual void OnFlagsChanged | ( | CXTPFrameShadowManager * | pManager,
 |  | int | nOldEffectiveFlags,
 |  | int | nNewEffectiveFlags )
 inlinevirtual

Invoked when flags are changed.

Parameters
pManager | Frame Shadow Manager pointer
nOldEffectiveFlags | A set of old effective flags.
nNewEffectiveFlags | A set of new effective flags.
See also
XTPFrameShadowManagerFlags

Reimplemented in CXTPFrameShadow.

◆ OnFrameShadowDisabled()

virtual void OnFrameShadowDisabled | ( | CXTPFrameShadowManager * | pManager,
 |  | HWND | hwndOwner,
 |  | CXTPFrameShadow * | pShadow )
 inlinevirtual

Invoked right before a shadow is disabled for a window.

Parameters
pManager | Frame Shadow Manager pointer
hwndOwner | Shadow owner window handle
pShadow | Shadow pointer

◆ OnFrameShadowEnabled()

virtual void OnFrameShadowEnabled | ( | CXTPFrameShadowManager * | pManager,
 |  | HWND | hwndOwner,
 |  | CXTPFrameShadow * | pShadow )
 inlinevirtual

Invoked right after a shadow is enabled for a window.

Parameters
pManager | Frame Shadow Manager pointer
hwndOwner | Shadow owner window handle
pShadow | Shadow pointer
The documentation for this struct was generated from the following file:
  • XTPFrameShadowManager.h


Toolkit Pro: IXTPGaugeClientSite Struct Reference

Public Member Functions | List of all members
IXTPGaugeClientSite Struct Referenceabstract

Provides a client site interface for a gauge control owner. More...

Public Member Functions

virtual void OnGaugeUpdated (CXTPGaugeBaseType &type)=0
Notifies client site about a gauge update event.

Detailed Description

Provides a client site interface for a gauge control owner.

Member Function Documentation

◆ OnGaugeUpdated()

virtual void OnGaugeUpdated ( CXTPGaugeBaseType & type )
pure virtual

Notifies client site about a gauge update event.

Parameters
type Gauge type.
The documentation for this struct was generated from the following file:
  • XTPGaugeCtrl.h


Toolkit Pro: IXTPMarkupClientSite Struct Reference

Public Member Functions | List of all members
IXTPMarkupClientSite Struct Reference

Defines default implementation of the markup client site interface. More...

Inheritance diagram for IXTPMarkupClientSite:
[legend]

Public Member Functions

virtual | ~IXTPMarkupClientSite ()
Handles object destruction.
virtual LPWSTR | PrepareCodeChunk (LPCWSTR pCode, const CList< LPCWSTR, LPCWSTR > &requirements)
Gets called by the markup context before executing script code chunk.

Detailed Description

Defines default implementation of the markup client site interface.

See also
CXTPMarkupContext

Member Function Documentation

◆ PrepareCodeChunk()

virtual LPWSTR PrepareCodeChunk | ( | LPCWSTR | pCode,
 |  | const CList< LPCWSTR, LPCWSTR > & | requirements )
 inlinevirtual

Gets called by the markup context before executing script code chunk.

Can be used for code enchancing depending on the provided list of requirements.

Parameters
pCode | Code chunk text.
requirements | The list of requirements as specified in the xtp:Script element.
Returns
If the provided code chunk has to be modified then the method must return a newly allocated buffer using new/malloc with the modified code text. If no code modifications are required then the return value can be either the value of pCode or NULL.
The documentation for this struct was generated from the following file:
  • XTPMarkupContext.h


Toolkit Pro: IXTPMarkupDeviceDependentImageSite Struct Reference

Public Member Functions | List of all members
IXTPMarkupDeviceDependentImageSite Struct Referenceabstract

Describes an image site interface. More...

Inheritance diagram for IXTPMarkupDeviceDependentImageSite:
[legend]

Public Member Functions

virtual | ~IXTPMarkupDeviceDependentImageSite ()
Handles object destruction.
virtual CXTPMarkupContext * | GetMarkupContext ()=0
Implementation must return a valid pointer to a markup context in which an image is to be rendered.
virtual void | OnImageUpdateRequired ()=0
(Optional) Implementation can re-draw the context when this method is called; usually when a new animation frame is to be rendered.

Detailed Description

Describes an image site interface.

Member Function Documentation

◆ GetMarkupContext()

virtual CXTPMarkupContext * GetMarkupContext ( )
pure virtual

Implementation must return a valid pointer to a markup context in which an image is to be rendered.

Returns
A valid markup context pointer.
The documentation for this struct was generated from the following file:
  • XTPMarkupDeviceDependentImage.h


Toolkit Pro: IXTPPreview Struct Reference

Public Member Functions | List of all members
IXTPPreview Struct Referenceabstract

The base interface for a preview handler implementation. More...

Public Member Functions

virtual | ~IXTPPreview ()
Handles object destruction.
virtual BOOL | IsReady () const =0
Returns TRUE if the handler has attempted and finished loading the preview regardless of the actual loading result.
virtual BOOL | IsAvailable () const =0
Determines if the preview is available (i.e.
virtual BOOL | HasOwnNavigator () const =0
Determines if the handler implements its own page navigator.
virtual UINT | GetNumberOfPages () const =0
Retrieves the number of pages available for the common page navigator.
virtual SIZE | GetPreferredPageSize () const =0
Obtains the preferred page size in pixels if that is required by the preview.
virtual void | GoToPage (UINT page)=0
If pages are supported by the preview, then it should cause navigation to the specified page number.
virtual void | Draw (HDC dc, SIZE clientSize, RECT updateRect)=0
This method is called every time the preview has to draw itself into the available client area.
virtual BOOL | OnHostWndMsg (LPMSG msg, LRESULT *result)=0
Handles a window message sent to the host preview control.
virtual BOOL | SupportsCompositedParent () const =0
Determines if the preview implementation is compatible with composited top level windows (i.e.
virtual void | Activate ()=0
Activate preview.

Detailed Description

The base interface for a preview handler implementation.

See also
IXTPPreviewHost, IXTPPreviewProvider

Member Function Documentation

◆ Draw()

virtual void Draw | ( | HDC | dc,
 |  | SIZE | clientSize,
 |  | RECT | updateRect )
 pure virtual

This method is called every time the preview has to draw itself into the available client area.

If the preview drawing is not provided by the preview handler, then the call should be ignored.

Parameters
dc | Target device context.
clientSize | The size of the available client rectangle starting at 0,0.
updateRect | Rectangular area requested for an update.

◆ GetNumberOfPages()

virtual UINT GetNumberOfPages ( ) const
pure virtual

Retrieves the number of pages available for the common page navigator.

Returns
The number of pages available for the common page navigator, or 0 if no pages are supported.

◆ GetPreferredPageSize()

virtual SIZE GetPreferredPageSize ( ) const
pure virtual

Obtains the preferred page size in pixels if that is required by the preview.

If zero size is returned, then it is assumed that the preview can be scaled to the entire available preview area.

Returns
Preferred page size, or 0,0.

◆ GoToPage()

virtual void GoToPage ( UINT page )
pure virtual

If pages are supported by the preview, then it should cause navigation to the specified page number.

Otherwise, the call should be ignored.

Parameters
page Zero-based page number to show preview for.

◆ HasOwnNavigator()

virtual BOOL HasOwnNavigator ( ) const
pure virtual

Determines if the handler implements its own page navigator.

In the case that the handler implements its own page navigator, it does not require the common page navigator to be used for it.

Returns
TRUE if the handler implements its own page navigator.

◆ IsAvailable()

virtual BOOL IsAvailable ( ) const
pure virtual

Determines if the preview is available (i.e.

the handler was able to load preview data successfully).

Returns
TRUE if the preview is available.

◆ IsReady()

virtual BOOL IsReady ( ) const
pure virtual

Returns TRUE if the handler has attempted and finished loading the preview regardless of the actual loading result.

Returns
TRUE if the handler is ready.

◆ OnHostWndMsg()

virtual BOOL OnHostWndMsg | ( | LPMSG | msg,
 |  | LRESULT * | result )
 pure virtual

Handles a window message sent to the host preview control.

It can be used by windowless preview handlers for handling events.

Parameters
msg | Message structure pointer.
result | Pointer to the message result.
Returns
TRUE if the message is handled by the preview handler and must not be forwarded to the host control, otherwise FALSE is expected.

◆ SupportsCompositedParent()

virtual BOOL SupportsCompositedParent ( ) const
pure virtual

Determines if the preview implementation is compatible with composited top level windows (i.e.

if any of its parents has the WS_EX_COMPOSITED style specified).

Returns
TRUE if the preview implementation is WS_EX_COMPOSITED compatible.
The documentation for this struct was generated from the following file:
  • XTPPreviewAbstract.h


Toolkit Pro: IXTPPreviewHost Struct Reference

Public Member Functions | List of all members
IXTPPreviewHost Struct Referenceabstract

Interface implemented by the preview host control. More...

Public Member Functions

virtual | ~IXTPPreviewHost ()
Handles object destruction.
virtual COLORREF | GetBackgroundColor () const =0
Obtains the background color used by the host control.
virtual COLORREF | GetForegroundColor () const =0
Obtains the foreground color used by the host control.

Detailed Description

Interface implemented by the preview host control.

See also
IXTPPreview, IXTPPreviewProvider

Member Function Documentation

◆ GetBackgroundColor()

virtual COLORREF GetBackgroundColor ( ) const
pure virtual

Obtains the background color used by the host control.

Returns
The background color used by the host control.

◆ GetForegroundColor()

virtual COLORREF GetForegroundColor ( ) const
pure virtual

Obtains the foreground color used by the host control.

Returns
The foreground color used by the host control.
The documentation for this struct was generated from the following file:
  • XTPPreviewAbstract.h


Toolkit Pro: IXTPPreviewProvider Struct Reference

Public Member Functions | List of all members
IXTPPreviewProvider Struct Referenceabstract

Interface to be implemented by a preview provider. More...

Inheritance diagram for IXTPPreviewProvider:
[legend]

Public Member Functions

virtual | ~IXTPPreviewProvider ()
Handles object destruction.
virtual void | BindHost (IXTPPreviewHost &host)=0
This method is called by the host control when it first binds the provider.
virtual LPCTSTR | GetDefaultFileAssociations () const =0
Obtains the list of file extensions supported by the associated preview implementation.
virtual IXTPPreview * | CreatePreview (LPCTSTR pFilePath, HWND hwndParent)=0
Creates a preview object for the specified file.
virtual IXTPPreview * | CreatePreview (IStream &stream, LPCTSTR pImpliedFileName, HWND hwndParent)=0
Creates a preview object for the specified file.

Detailed Description

Interface to be implemented by a preview provider.

See also
IXTPPreviewHost, IXTPPreview, CXTPPreviewProviderBase

Member Function Documentation

◆ BindHost()

virtual void BindHost ( IXTPPreviewHost & host )
pure virtual

This method is called by the host control when it first binds the provider.

Parameters
host Preview host control interface reference.

Implemented in CXTPPreviewProviderBase.

◆ CreatePreview() [1/2]

virtual IXTPPreview * CreatePreview | ( | IStream & | stream,
 |  | LPCTSTR | pImpliedFileName,
 |  | HWND | hwndParent )
 pure virtual

Creates a preview object for the specified file.

Parameters
stream | Data stream that contains file data to be previewed.
pImpliedFileName | An implied name of the file associated with the stream object, only extension part is important for identiying the format of the data to be previewed.
hwndParent | Preview parent window handle.
Returns
A valid pointer to the new preview object created, or NULL if it was not possible to create a preview object.

◆ CreatePreview() [2/2]

virtual IXTPPreview * CreatePreview | ( | LPCTSTR | pFilePath,
 |  | HWND | hwndParent )
 pure virtual

Creates a preview object for the specified file.

Parameters
pFilePath | File path value for which the preview is to be created.
hwndParent | Preview parent window handle.
Returns
A valid pointer to the new preview object created, or NULL if it was not possible to create a preview object.

◆ GetDefaultFileAssociations()

virtual LPCTSTR GetDefaultFileAssociations ( ) const
pure virtual

Obtains the list of file extensions supported by the associated preview implementation.

The list is a semicolon separated string of extensions without periods (e.g. "doc;docx;xls;xlsx"). The return value can also be NULL which means that the preview implementation is capable of extracting previews from all supplied file types.

Returns
The list of supported extensions, or NULL to indicate ability to preview all file types.
The documentation for this struct was generated from the following file:
  • XTPPreviewAbstract.h


Toolkit Pro: IXTPScrollable Struct Reference

Public Member Functions | List of all members
IXTPScrollable Struct Referenceabstract

This interface is to be implemented only by special scrollable controls that require overriding of scroll bars using CXTPScrollable adaptor and for which the default implementation of this interface by CXTPScrollable does not work. More...

Inheritance diagram for IXTPScrollable:
[legend]

Public Member Functions

virtual | ~IXTPScrollable ()
Handles object destruction.
virtual CWnd & | GetWnd ()=0
Obtains scrollable control window reference.
virtual BOOL | HasVScroll (DWORD dwStyle, DWORD dwExStyle) const =0
Returns TRUE if the control has vertical scroll bar for the combination of styles specified.
virtual BOOL | HasHScroll (DWORD dwStyle, DWORD dwExStyle) const =0
Returns TRUE if the control has horizontal scroll bar for the combination of styles specified.
virtual BOOL | HasLeftScrollbar (DWORD dwStyle, DWORD dwExStyle) const =0
Returns TRUE if the control has vertical scroll bar on the left side for the combination of styles specified.
virtual void | DisableScrollbars ()=0
Disables/removes standard scroll bars so that custom scroll bars created via this interface could be used.
virtual void | DisableScrollbars (CWnd &wnd)=0
Disables/removes standard scroll bars so that custom scroll bars created via this interface could be used.
virtual CScrollBar * | CreateBar () const =0
Creates a new scroll bar object.
virtual CWnd * | CreateControl () const =0
Creates a close instance of the control itself.
virtual DWORD | FilterStyle (DWORD dwStyle) const =0
Filters supplied window style if needed.
virtual DWORD | FilterExStyle (DWORD dwExStyle) const =0
Filters supplied extended window style if needed.
virtual BOOL | RequiresMouseWheelOverriding () const =0
Determines if mouse wheel handling logic must be overridden by scroll host when a hosted control is not able to handle mouse wheel interaction when its scroll bars are disabled.

Detailed Description

This interface is to be implemented only by special scrollable controls that require overriding of scroll bars using CXTPScrollable adaptor and for which the default implementation of this interface by CXTPScrollable does not work.

See also
CXTPScrollable

Member Function Documentation

◆ CreateBar()

virtual CScrollBar * CreateBar ( ) const
pure virtual

Creates a new scroll bar object.

Returns
A new instance of a scroll bar object that is derived from CScrollBar. It's caller's responsibility to handle object lifetime.

◆ CreateControl()

virtual CWnd * CreateControl ( ) const
pure virtual

Creates a close instance of the control itself.

Returns
A new instance of the control object. It's caller's responsibility to handle object lifetime.

◆ DisableScrollbars()

virtual void DisableScrollbars ( CWnd & wnd )
pure virtual

Disables/removes standard scroll bars so that custom scroll bars created via this interface could be used.

Parameters
wnd Window for which scrollbars must be disabled.

◆ FilterExStyle()

virtual DWORD FilterExStyle ( DWORD dwExStyle ) const
pure virtual

Filters supplied extended window style if needed.

The method is called every time a change in extended window style is detected.

Parameters
dwExStyle Current extended style bits.
Returns
Modified extended style bits or the original value if no change in extended style is required.

◆ FilterStyle()

virtual DWORD FilterStyle ( DWORD dwStyle ) const
pure virtual

Filters supplied window style if needed.

The method is called every time a change in window style is detected.

Parameters
dwStyle Current style bits.
Returns
Modified style bits or the original value if no change in style is required.

◆ GetWnd()

virtual CWnd & GetWnd ( )
pure virtual

Obtains scrollable control window reference.

Returns
Scrollable control window reference.

◆ HasHScroll()

virtual BOOL HasHScroll | ( | DWORD | dwStyle,
 |  | DWORD | dwExStyle ) const
 pure virtual

Returns TRUE if the control has horizontal scroll bar for the combination of styles specified.

Parameters
dwStyle | Window style bits.
dwExStyle | Window extended style bits.
Returns
TRUE if the control has horizontal scroll bar for the combination of styles specified, otherwise the return value is FALSE.

◆ HasLeftScrollbar()

virtual BOOL HasLeftScrollbar | ( | DWORD | dwStyle,
 |  | DWORD | dwExStyle ) const
 pure virtual

Returns TRUE if the control has vertical scroll bar on the left side for the combination of styles specified.

Parameters
dwStyle | Window style bits.
dwExStyle | Window extended style bits.
Returns
TRUE if the control has vertical scroll bar on the left side for the combination of styles specified, FALSE indicates scroll bar on the right side.

◆ HasVScroll()

virtual BOOL HasVScroll | ( | DWORD | dwStyle,
 |  | DWORD | dwExStyle ) const
 pure virtual

Returns TRUE if the control has vertical scroll bar for the combination of styles specified.

Parameters
dwStyle | Window style bits.
dwExStyle | Window extended style bits.
Returns
TRUE if the control has vertical scroll bar for the combination of styles specified, otherwise the return value is FALSE.

◆ RequiresMouseWheelOverriding()

virtual BOOL RequiresMouseWheelOverriding ( ) const
pure virtual

Determines if mouse wheel handling logic must be overridden by scroll host when a hosted control is not able to handle mouse wheel interaction when its scroll bars are disabled.

Returns
TRUE if scroll host is to provide its own default implementation of mouse wheel rotation handling. For default dehavior determined by the hosted control the return value must be FALSE.
The documentation for this struct was generated from the following file:
  • XTPScrollable.h


Toolkit Pro: IXTPSkinManagerWindowFilter Struct Reference

Public Member Functions | List of all members
IXTPSkinManagerWindowFilter Struct Referenceabstract

Implement this interface in order to provide custom configured window filter functionality. More...

Public Member Functions

virtual | ~IXTPSkinManagerWindowFilter ()
Handles object destruction.
virtual BOOL | FilterWindowClass (LPCSTR lpszClassName)=0
The implementation must make a decision as to whether a window class must be filtered out (not skinned) or not, depending on certain window class characteristics.
virtual BOOL | FilterWindowClass (LPCWSTR lpszClassName)=0
The implementation must make a decision as to whether a window class must be filtered out (not skinned) or not, depending on certain window class characteristics.
virtual BOOL | FilterWindow (HWND hWnd, LPCTSTR lpszClassName, LPCREATESTRUCT lpcs)=0
The implementation must make a decision as to whether a window must be filtered out (not skinned) or not depending on certain window characteristics.

Detailed Description

Implement this interface in order to provide custom configured window filter functionality.

The filtered out windows will not be skinned. If you find yourself frequently filtering out some system window in order to prevent application crashes, please report to us its class name and, ideally, the contents of the WNDCLASS structure filled out by a call to GetWindowClass for this window handle. Use CXTPSkinManager::SetWindowFilter for setting or disabling a custom provided window filter implementation.

Member Function Documentation

◆ FilterWindow()

virtual BOOL FilterWindow | ( | HWND | hWnd,
 |  | LPCTSTR | lpszClassName,
 |  | LPCREATESTRUCT | lpcs )
 pure virtual

The implementation must make a decision as to whether a window must be filtered out (not skinned) or not depending on certain window characteristics.

Parameters
hWnd | Window handle.
lpszClassName | Window class name if known, otherwise NULL.
lpcs | Pointer to the window's CREATESTRUCT structure if known, otherwise NULL.
Returns
TRUE if the window has to be filtered out, otherwise FALSE (default).

◆ FilterWindowClass() [1/2]

virtual BOOL FilterWindowClass ( LPCSTR lpszClassName )
pure virtual

The implementation must make a decision as to whether a window class must be filtered out (not skinned) or not, depending on certain window class characteristics.

Parameters
lpszClassName Window class name.
Returns
TRUE if the window class has to be filtered out, otherwise FALSE (default).

◆ FilterWindowClass() [2/2]

virtual BOOL FilterWindowClass ( LPCWSTR lpszClassName )
pure virtual

The implementation must make a decision as to whether a window class must be filtered out (not skinned) or not, depending on certain window class characteristics.

Parameters
lpszClassName Window class name.
Returns
TRUE if the window class has to be filtered out, otherwise FALSE (default).
The documentation for this struct was generated from the following file:
  • XTPSkinManager.h


Toolkit Pro: IXTPWebBrowserEventSink Struct Reference

Public Member Functions | List of all members
IXTPWebBrowserEventSink Struct Reference

Describes default WebBrowser control event sink interface and providers default implementation of the event handlers. More...

Public Member Functions

virtual | ~IXTPWebBrowserEventSink ()
Handles event sink destruction.
virtual void | ShellExplorer_OnStatusTextChange (CXTPWebBrowserCtrl &sender, LPCTSTR lpszText)
Handles StatusTextChange event for the ShellExplorer WebBrowser provider type.
virtual void | ShellExplorer_OnProgressChange (CXTPWebBrowserCtrl &sender, long nProgress, long nProgressMax)
Handles ProgressChange event for the ShellExplorer WebBrowser provider type.
virtual void | ShellExplorer_OnCommandStateChange (CXTPWebBrowserCtrl &sender, long nCommand, BOOL bEnable)
Handles CommandStateChange event for the ShellExplorer WebBrowser provider type.
virtual void | ShellExplorer_OnDownloadBegin (CXTPWebBrowserCtrl &sender)
Handles DownloadBegin event for the ShellExplorer WebBrowser provider type.
virtual void | ShellExplorer_OnDownloadComplete (CXTPWebBrowserCtrl &sender)
Handles DownloadComplete event for the ShellExplorer WebBrowser provider type.
virtual void | ShellExplorer_OnTitleChange (CXTPWebBrowserCtrl &sender, LPCTSTR lpszText)
Handles TitleChange event for the ShellExplorer WebBrowser provider type.
virtual void | ShellExplorer_OnPropertyChange (CXTPWebBrowserCtrl &sender, LPCTSTR lpszProperty)
Handles PropertyChange event for the ShellExplorer WebBrowser provider type.
virtual void | ShellExplorer_OnNewWindow2 (CXTPWebBrowserCtrl &sender, LPDISPATCH *ppDisp, BOOL *pbCancel)
Handles NewWindow2 event for the ShellExplorer WebBrowser provider type.
virtual void | ShellExplorer_OnQuit (CXTPWebBrowserCtrl &sender)
Handles OnQuit event for the ShellExplorer WebBrowser provider type.
virtual void | ShellExplorer_OnVisible (CXTPWebBrowserCtrl &sender, BOOL bVisible)
Handles OnVisible event for the ShellExplorer WebBrowser provider type.
virtual void | ShellExplorer_OnToolBar (CXTPWebBrowserCtrl &sender, BOOL bToolBar)
Handles OnToolBar event for the ShellExplorer WebBrowser provider type.
virtual void | ShellExplorer_OnMenuBar (CXTPWebBrowserCtrl &sender, BOOL bMenuBar)
Handles OnMenuBar event for the ShellExplorer WebBrowser provider type.
virtual void | ShellExplorer_OnStatusBar (CXTPWebBrowserCtrl &sender, BOOL bStatusBar)
Handles OnStatusBar event for the ShellExplorer WebBrowser provider type.
virtual void | ShellExplorer_OnFullScreen (CXTPWebBrowserCtrl &sender, BOOL bFullScreen)
Handles OnFullScreen event for the ShellExplorer WebBrowser provider type.
virtual void | ShellExplorer_OnTheaterMode (CXTPWebBrowserCtrl &sender, BOOL bTheaterMode)
Handles OnTheaterMode event for the ShellExplorer WebBrowser provider type.
virtual void | ShellExplorer_OnNavigateComplete2 (CXTPWebBrowserCtrl &sender, LPDISPATCH pDisp, VARIANT *pvtURL)
Handles NavigateComplete2 event for the ShellExplorer WebBrowser provider type.
virtual void | ShellExplorer_OnBeforeNavigate2 (CXTPWebBrowserCtrl &sender, LPDISPATCH pDisp, VARIANT *pvtURL, VARIANT *pvtFlags, VARIANT *pvtTargetFrameName, VARIANT *pvtPostData, VARIANT *pvtHeaders, BOOL *pbCancel)
Handles BeforeNavigate2 event for the ShellExplorer WebBrowser provider type.
virtual void | ShellExplorer_OnDocumentComplete (CXTPWebBrowserCtrl &sender, LPDISPATCH pDisp, VARIANT *pvtURL)
Handles DocumentComplete event for the ShellExplorer WebBrowser provider type.
virtual void | ShellExplorer_OnNavigateError (CXTPWebBrowserCtrl &sender, LPDISPATCH pDisp, VARIANT *pvtURL, VARIANT *pvtTargetFrameName, VARIANT *pvtStatusCode, BOOL *pbCancel)
Handles NavigateError event for the ShellExplorer WebBrowser provider type.
virtual void | ShellExplorer_OnWindowSetResizable (CXTPWebBrowserCtrl &sender, BOOL bResizable)
Handles WindowSetResizable event for the ShellExplorer WebBrowser provider type.
virtual void | ShellExplorer_OnWindowSetLeft (CXTPWebBrowserCtrl &sender, long nLeft)
Handles WindowSetLeft event for the ShellExplorer WebBrowser provider type.
virtual void | ShellExplorer_OnWindowSetTop (CXTPWebBrowserCtrl &sender, long nTop)
Handles WindowSetTop event for the ShellExplorer WebBrowser provider type.
virtual void | ShellExplorer_OnWindowSetWidth (CXTPWebBrowserCtrl &sender, long nWidth)
Handles WindowSetWidth event for the ShellExplorer WebBrowser provider type.
virtual void | ShellExplorer_OnWindowSetHeight (CXTPWebBrowserCtrl &sender, long nHeight)
Handles WindowSetHeight event for the ShellExplorer WebBrowser provider type.
virtual void | ShellExplorer_OnWindowClosing (CXTPWebBrowserCtrl &sender, BOOL bIsChildWindow, BOOL FAR *pbCancel)
Handles WindowClosing event for the ShellExplorer WebBrowser provider type.
virtual void | ShellExplorer_OnSetSecureLockIcon (CXTPWebBrowserCtrl &sender, long nSecureLockIcon)
Handles SetSecureLockIcon event for the ShellExplorer WebBrowser provider type.
virtual HRESULT | WebView2_NavigationStarting (CXTPWebBrowserCtrl &sender, ICoreWebView2NavigationStartingEventArgs *args)
Handles NavigationStarting event for the WebView2 WebBrowser provider type.
virtual HRESULT | WebView2_ContentLoading (CXTPWebBrowserCtrl &sender, ICoreWebView2ContentLoadingEventArgs *args)
Handles ContentLoading event for the WebView2 WebBrowser provider type.
virtual HRESULT | WebView2_SourceChanged (CXTPWebBrowserCtrl &sender, ICoreWebView2SourceChangedEventArgs *args)
Handles SourceChanged event for the WebView2 WebBrowser provider type.
virtual HRESULT | WebView2_HistoryChanged (CXTPWebBrowserCtrl &sender, IUnknown *args)
Handles HistoryChanged event for the WebView2 WebBrowser provider type.
virtual HRESULT | WebView2_NavigationCompleted (CXTPWebBrowserCtrl &sender, ICoreWebView2NavigationCompletedEventArgs *args)
Handles NavigationCompleted event for the WebView2 WebBrowser provider type.
virtual HRESULT | WebView2_FrameNavigationStarting (CXTPWebBrowserCtrl &sender, ICoreWebView2NavigationStartingEventArgs *args)
Handles FrameNavigationStarting event for the WebView2 WebBrowser provider type.
virtual HRESULT | WebView2_FrameNavigationCompleted (CXTPWebBrowserCtrl &sender, ICoreWebView2NavigationCompletedEventArgs *args)
Handles FrameNavigationCompleted event for the WebView2 WebBrowser provider type.
virtual HRESULT | WebView2_ScriptDialogOpening (CXTPWebBrowserCtrl &sender, ICoreWebView2ScriptDialogOpeningEventArgs *args)
Handles ScriptDialogOpening event for the WebView2 WebBrowser provider type.
virtual HRESULT | WebView2_PermissionRequested (CXTPWebBrowserCtrl &sender, ICoreWebView2PermissionRequestedEventArgs *args)
Handles PermissionRequested event for the WebView2 WebBrowser provider type.
virtual HRESULT | WebView2_ProcessFailed (CXTPWebBrowserCtrl &sender, ICoreWebView2ProcessFailedEventArgs *args)
Handles ProcessFailed event for the WebView2 WebBrowser provider type.
virtual HRESULT | WebView2_NewWindowRequested (CXTPWebBrowserCtrl &sender, ICoreWebView2NewWindowRequestedEventArgs *args)
Handles NewWindowRequested event for the WebView2 WebBrowser provider type.
virtual HRESULT | WebView2_DocumentTitleChanged (CXTPWebBrowserCtrl &sender, IUnknown *args)
Handles DocumentTitleChanged event for the WebView2 WebBrowser provider type.
virtual HRESULT | WebView2_ContainsFullScreenElementChanged (CXTPWebBrowserCtrl &sender, IUnknown *args)
Handles ContainsFullScreenElementChanged event for the WebView2 WebBrowser provider type.
virtual HRESULT | WebView2_WebResourceRequested (CXTPWebBrowserCtrl &sender, ICoreWebView2WebResourceRequestedEventArgs *args)
Handles WebResourceRequested event for the WebView2 WebBrowser provider type.
virtual HRESULT | WebView2_WindowCloseRequested (CXTPWebBrowserCtrl &sender, IUnknown *args)
Handles WindowCloseRequested event for the WebView2 WebBrowser provider type.

Detailed Description

Describes default WebBrowser control event sink interface and providers default implementation of the event handlers.

Member Function Documentation

◆ ShellExplorer_OnBeforeNavigate2()

virtual void ShellExplorer_OnBeforeNavigate2 | ( | CXTPWebBrowserCtrl & | sender,
 |  | LPDISPATCH | pDisp,
 |  | VARIANT * | pvtURL,
 |  | VARIANT * | pvtFlags,
 |  | VARIANT * | pvtTargetFrameName,
 |  | VARIANT * | pvtPostData,
 |  | VARIANT * | pvtHeaders,
 |  | BOOL * | pbCancel )
 inlinevirtual

Handles BeforeNavigate2 event for the ShellExplorer WebBrowser provider type.

Fires before navigation occurs in the given object (on either a window element or a frameset element).

Parameters
sender | WebBrowser control that triggered the event.
pDisp | A pointer to the IDispatch interface for the WebBrowser object that represents the window or frame. This interface can be queried for the IWebBrowser2 interface.
pvtURL | A pointer to a VARIANT structure of type VT_BSTR that contains the URL to navigate to.
pvtFlags | The result of an external window or tab that targets this browser. Contains zero or beforeNavigateExternalFrameTarget (0x1).
pvtTargetFrameName | A pointer to a VARIANT structure of type VT_BSTR that contains the name of the frame in which to display the resource, or NULL, if no named frame is targeted for the resource.
pvtPostData | A pointer to a VARIANT structure of type VT_BYREF|VT_VARIANT that contains the data to send to the server if the HTTP POST transaction is used.
pvtHeaders | A pointer to a VARIANT structure of type VT_BSTR that contains additional HTTP headers to send to the server (HTTPURLs only). The headers can specify information, such as the action required of the server, the type of data passed to the server, or a status code.
pbCancel | An application can set this parameter to TRUE to cancel the navigation operation, or to FALSE to allow the navigation operation to proceed.

◆ ShellExplorer_OnCommandStateChange()

virtual void ShellExplorer_OnCommandStateChange | ( | CXTPWebBrowserCtrl & | sender,
 |  | long | nCommand,
 |  | BOOL | bEnable )
 inlinevirtual

Handles CommandStateChange event for the ShellExplorer WebBrowser provider type.

Fires when the enabled state of a command changes.

Parameters
sender | WebBrowser control that triggered the event.
nCommand | Specifies the command that changed. Refer to CommandStateChangeConstants in Windows SDK for possible values.
bEnable | Specifies the enabled state.

◆ ShellExplorer_OnDocumentComplete()

virtual void ShellExplorer_OnDocumentComplete | ( | CXTPWebBrowserCtrl & | sender,
 |  | LPDISPATCH | pDisp,
 |  | VARIANT * | pvtURL )
 inlinevirtual

Handles DocumentComplete event for the ShellExplorer WebBrowser provider type.

Fires when a document is completely loaded and initialized.

Parameters
sender | WebBrowser control that triggered the event.
pDisp | A pointer to the IDispatch interface of the window or frame in which the document is loaded. This IDispatch interface can be queried for the IWebBrowser2 interface.
pvtURL | A pointer to a Variant structure of type String that specifies the URL, UNC file name, or a PIDL of the loaded document.

◆ ShellExplorer_OnDownloadBegin()

virtual void ShellExplorer_OnDownloadBegin ( CXTPWebBrowserCtrl & sender )
inlinevirtual

Handles DownloadBegin event for the ShellExplorer WebBrowser provider type.

Fires when a navigation operation begins.

Parameters
sender WebBrowser control that triggered the event.

◆ ShellExplorer_OnDownloadComplete()

virtual void ShellExplorer_OnDownloadComplete ( CXTPWebBrowserCtrl & sender )
inlinevirtual

Handles DownloadComplete event for the ShellExplorer WebBrowser provider type.

Fires when a navigation operation completes.

Parameters
sender WebBrowser control that triggered the event.

◆ ShellExplorer_OnFullScreen()

virtual void ShellExplorer_OnFullScreen | ( | CXTPWebBrowserCtrl & | sender,
 |  | BOOL | bFullScreen )
 inlinevirtual

Handles OnFullScreen event for the ShellExplorer WebBrowser provider type.

Fires when the FullScreen property is changed.

Parameters
sender | WebBrowser control that triggered the event.
bFullScreen | Specifies whether the browser window is in full-screen mode.

◆ ShellExplorer_OnMenuBar()

virtual void ShellExplorer_OnMenuBar | ( | CXTPWebBrowserCtrl & | sender,
 |  | BOOL | bMenuBar )
 inlinevirtual

Handles OnMenuBar event for the ShellExplorer WebBrowser provider type.

Fires when the MenuBar property is changed.

Parameters
sender | WebBrowser control that triggered the event.
bMenuBar | Specifies whether the menu bar is shown.

◆ ShellExplorer_OnNavigateComplete2()

virtual void ShellExplorer_OnNavigateComplete2 | ( | CXTPWebBrowserCtrl & | sender,
 |  | LPDISPATCH | pDisp,
 |  | VARIANT * | pvtURL )
 inlinevirtual

Handles NavigateComplete2 event for the ShellExplorer WebBrowser provider type.

Fires after a navigation to a link is completed on a window element or a frameSet element.

Parameters
sender | WebBrowser control that triggered the event.
pDisp | A pointer to the IDispatch interface for the WebBrowser object that represents the window or frame. This interface can be queried for the IWebBrowser2 interface.
pvtURL | A pointer to a Variant structure of type String that contains the URL, UNC file name, or PIDL that was navigated to. Note that this URL can be different from the URL that the browser was directed to navigate to. One reason is that this URL is the canonicalized and qualified URL. For example, if an application specified a URL of "www.microsoft.com" in a call to the Navigate method or the Navigate2 method, the URL passed by Navigate2 is "https://www.microsoft.com/." If the server has redirected the browser to a different URL, the redirected URL is reflected.

◆ ShellExplorer_OnNavigateError()

virtual void ShellExplorer_OnNavigateError | ( | CXTPWebBrowserCtrl & | sender,
 |  | LPDISPATCH | pDisp,
 |  | VARIANT * | pvtURL,
 |  | VARIANT * | pvtTargetFrameName,
 |  | VARIANT * | pvtStatusCode,
 |  | BOOL * | pbCancel )
 inlinevirtual

Handles NavigateError event for the ShellExplorer WebBrowser provider type.

Fires when an error occurs during navigation.

Parameters
sender | WebBrowser control that triggered the event.
pDisp | A pointer to an IDispatch interface for the WebBrowser object that represents the window or frame in which the navigation error occurred. This interface can be queried for the IWebBrowser2 interface.
pvtURL | A pointer to a VARIANT structure of type VT_BSTR that contains the URL for which navigation failed.
pvtTargetFrameName | A pointer to a VARIANT structure of type VT_BSTR that contains the name of the frame in which to display the resource, or NULL if no named frame was targeted for the resource.
pvtStatusCode | A pointer to a VT_I4 containing an error status code, if available. For a list of the possible HRESULT and HTTP status codes, see NavigateError Event Status Codes.
pbCancel | Specifies whether to cancel the navigation to an error page or to any further autosearch.

◆ ShellExplorer_OnNewWindow2()

virtual void ShellExplorer_OnNewWindow2 | ( | CXTPWebBrowserCtrl & | sender,
 |  | LPDISPATCH * | ppDisp,
 |  | BOOL * | pbCancel )
 inlinevirtual

Handles NewWindow2 event for the ShellExplorer WebBrowser provider type.

Fires when a new window is to be created.

Parameters
sender | WebBrowser control that triggered the event.
ppDisp | An interface pointer that, optionally, receives the IDispatch interface pointer of a new WebBrowser object or InternetExplorer object.
pbCancel | Value that determines whether the current navigation should be canceled.

◆ ShellExplorer_OnProgressChange()

virtual void ShellExplorer_OnProgressChange | ( | CXTPWebBrowserCtrl & | sender,
 |  | long | nProgress,
 |  | long | nProgressMax )
 inlinevirtual

Handles ProgressChange event for the ShellExplorer WebBrowser provider type.

Fires when the progress of a download operation is updated on the object.

Parameters
sender | WebBrowser control that triggered the event.
nProgress | Specifies the amount of total progress to show, or -1 when progress is complete.
nProgressMax | Specifies the maximum progress value.

◆ ShellExplorer_OnPropertyChange()

virtual void ShellExplorer_OnPropertyChange | ( | CXTPWebBrowserCtrl & | sender,
 |  | LPCTSTR | lpszProperty )
 inlinevirtual

Handles PropertyChange event for the ShellExplorer WebBrowser provider type.

Fires when the a property of the object is changed.

Parameters
sender | WebBrowser control that triggered the event.
lpszProperty | Specifies the name of the property whose value has changed.

◆ ShellExplorer_OnQuit()

virtual void ShellExplorer_OnQuit ( CXTPWebBrowserCtrl & sender )
inlinevirtual

Handles OnQuit event for the ShellExplorer WebBrowser provider type.

Fires before the Windows Internet Explorer application quits.

Parameters
sender WebBrowser control that triggered the event.

◆ ShellExplorer_OnSetSecureLockIcon()

virtual void ShellExplorer_OnSetSecureLockIcon | ( | CXTPWebBrowserCtrl & | sender,
 |  | long | nSecureLockIcon )
 inlinevirtual

Handles SetSecureLockIcon event for the ShellExplorer WebBrowser provider type.

Fires when there is a change in encryption level.

Parameters
sender | WebBrowser control that triggered the event.
nSecureLockIcon | specifies one of the SecureLockIconConstants from Windows SDK.

◆ ShellExplorer_OnStatusBar()

virtual void ShellExplorer_OnStatusBar | ( | CXTPWebBrowserCtrl & | sender,
 |  | BOOL | bStatusBar )
 inlinevirtual

Handles OnStatusBar event for the ShellExplorer WebBrowser provider type.

Fires when the StatusBar property is changed.

Parameters
sender | WebBrowser control that triggered the event.
bStatusBar | Specifies whether the status bar is shown.

◆ ShellExplorer_OnStatusTextChange()

virtual void ShellExplorer_OnStatusTextChange | ( | CXTPWebBrowserCtrl & | sender,
 |  | LPCTSTR | lpszText )
 inlinevirtual

Handles StatusTextChange event for the ShellExplorer WebBrowser provider type.

Fires when the status bar text of the object has changed.

Parameters
sender | WebBrowser control that triggered the event.
lpszText | The new status bar text

◆ ShellExplorer_OnTheaterMode()

virtual void ShellExplorer_OnTheaterMode | ( | CXTPWebBrowserCtrl & | sender,
 |  | BOOL | bTheaterMode )
 inlinevirtual

Handles OnTheaterMode event for the ShellExplorer WebBrowser provider type.

Fires when the TheaterMode property is changed.

Parameters
sender | WebBrowser control that triggered the event.
bTheaterMode | Specifies whether the browser window is in theater mode.

◆ ShellExplorer_OnTitleChange()

virtual void ShellExplorer_OnTitleChange | ( | CXTPWebBrowserCtrl & | sender,
 |  | LPCTSTR | lpszText )
 inlinevirtual

Handles TitleChange event for the ShellExplorer WebBrowser provider type.

Fires when the title of a document in the object becomes available or changes.

Parameters
sender | WebBrowser control that triggered the event.
lpszText | Specifies the new document title.

◆ ShellExplorer_OnToolBar()

virtual void ShellExplorer_OnToolBar | ( | CXTPWebBrowserCtrl & | sender,
 |  | BOOL | bToolBar )
 inlinevirtual

Handles OnToolBar event for the ShellExplorer WebBrowser provider type.

Fires when the ToolBar property is changed.

Parameters
sender | WebBrowser control that triggered the event.
bToolBar | Specifies whether the toolbar is shown.

◆ ShellExplorer_OnVisible()

virtual void ShellExplorer_OnVisible | ( | CXTPWebBrowserCtrl & | sender,
 |  | BOOL | bVisible )
 inlinevirtual

Handles OnVisible event for the ShellExplorer WebBrowser provider type.

Fires when the Visible property of the object is changed.

Parameters
sender | WebBrowser control that triggered the event.
bVisible | Specifies whether the object is visible.

◆ ShellExplorer_OnWindowClosing()

virtual void ShellExplorer_OnWindowClosing | ( | CXTPWebBrowserCtrl & | sender,
 |  | BOOL | bIsChildWindow,
 |  | BOOL FAR * | pbCancel )
 inlinevirtual

Handles WindowClosing event for the ShellExplorer WebBrowser provider type.

Fires when the window of the object is about to be closed by script.

Parameters
sender | WebBrowser control that triggered the event.
bIsChildWindow | Specifies whether the window was created from script.
pbCancel | Specifies whether the window is prevented from closing.

◆ ShellExplorer_OnWindowSetHeight()

virtual void ShellExplorer_OnWindowSetHeight | ( | CXTPWebBrowserCtrl & | sender,
 |  | long | nHeight )
 inlinevirtual

Handles WindowSetHeight event for the ShellExplorer WebBrowser provider type.

Fires when the object changes its height.

Parameters
sender | WebBrowser control that triggered the event.
nHeight | Specifies the new height of the WebBrowser window.

◆ ShellExplorer_OnWindowSetLeft()

virtual void ShellExplorer_OnWindowSetLeft | ( | CXTPWebBrowserCtrl & | sender,
 |  | long | nLeft )
 inlinevirtual

Handles WindowSetLeft event for the ShellExplorer WebBrowser provider type.

Fires when the object changes its left position.

Parameters
sender | WebBrowser control that triggered the event.
nLeft | Specifies the new left position of the WebBrowser window.

◆ ShellExplorer_OnWindowSetResizable()

virtual void ShellExplorer_OnWindowSetResizable | ( | CXTPWebBrowserCtrl & | sender,
 |  | BOOL | bResizable )
 inlinevirtual

Handles WindowSetResizable event for the ShellExplorer WebBrowser provider type.

Fires to indicate whether the host window should allow resizing of the object.

Parameters
sender | WebBrowser control that triggered the event.
bResizable | pecifies whether the WebBrowser control is resizable.

◆ ShellExplorer_OnWindowSetTop()

virtual void ShellExplorer_OnWindowSetTop | ( | CXTPWebBrowserCtrl & | sender,
 |  | long | nTop )
 inlinevirtual

Handles WindowSetTop event for the ShellExplorer WebBrowser provider type.

Fires when the object changes its top position.

Parameters
sender | WebBrowser control that triggered the event.
nTop | Specifies the new top position of the WebBrowser window.

◆ ShellExplorer_OnWindowSetWidth()

virtual void ShellExplorer_OnWindowSetWidth | ( | CXTPWebBrowserCtrl & | sender,
 |  | long | nWidth )
 inlinevirtual

Handles WindowSetWidth event for the ShellExplorer WebBrowser provider type.

Fires when the object changes its width.

Parameters
sender | WebBrowser control that triggered the event.
nWidth | Specifies the new width of the WebBrowser window.

◆ WebView2_ContainsFullScreenElementChanged()

virtual HRESULT WebView2_ContainsFullScreenElementChanged | ( | CXTPWebBrowserCtrl & | sender,
 |  | IUnknown * | args )
 inlinevirtual

Handles ContainsFullScreenElementChanged event for the WebView2 WebBrowser provider type.

Parameters
sender | WebBrowser control that triggered the event.
args | Object that describes event arguments.
Returns
S_OK if successful, or an error code otherwise.

◆ WebView2_ContentLoading()

virtual HRESULT WebView2_ContentLoading | ( | CXTPWebBrowserCtrl & | sender,
 |  | ICoreWebView2ContentLoadingEventArgs * | args )
 inlinevirtual

Handles ContentLoading event for the WebView2 WebBrowser provider type.

Parameters
sender | WebBrowser control that triggered the event.
args | Object that describes event arguments.
Returns
S_OK if successful, or an error code otherwise.

◆ WebView2_DocumentTitleChanged()

virtual HRESULT WebView2_DocumentTitleChanged | ( | CXTPWebBrowserCtrl & | sender,
 |  | IUnknown * | args )
 inlinevirtual

Handles DocumentTitleChanged event for the WebView2 WebBrowser provider type.

Parameters
sender | WebBrowser control that triggered the event.
args | Object that describes event arguments.
Returns
S_OK if successful, or an error code otherwise.

◆ WebView2_FrameNavigationCompleted()

virtual HRESULT WebView2_FrameNavigationCompleted | ( | CXTPWebBrowserCtrl & | sender,
 |  | ICoreWebView2NavigationCompletedEventArgs * | args )
 inlinevirtual

Handles FrameNavigationCompleted event for the WebView2 WebBrowser provider type.

Parameters
sender | WebBrowser control that triggered the event.
args | Object that describes event arguments.
Returns
S_OK if successful, or an error code otherwise.

◆ WebView2_FrameNavigationStarting()

virtual HRESULT WebView2_FrameNavigationStarting | ( | CXTPWebBrowserCtrl & | sender,
 |  | ICoreWebView2NavigationStartingEventArgs * | args )
 inlinevirtual

Handles FrameNavigationStarting event for the WebView2 WebBrowser provider type.

Parameters
sender | WebBrowser control that triggered the event.
args | Object that describes event arguments.
Returns
S_OK if successful, or an error code otherwise.

◆ WebView2_HistoryChanged()

virtual HRESULT WebView2_HistoryChanged | ( | CXTPWebBrowserCtrl & | sender,
 |  | IUnknown * | args )
 inlinevirtual

Handles HistoryChanged event for the WebView2 WebBrowser provider type.

Parameters
sender | WebBrowser control that triggered the event.
args | Object that describes event arguments.
Returns
S_OK if successful, or an error code otherwise.

◆ WebView2_NavigationCompleted()

virtual HRESULT WebView2_NavigationCompleted | ( | CXTPWebBrowserCtrl & | sender,
 |  | ICoreWebView2NavigationCompletedEventArgs * | args )
 inlinevirtual

Handles NavigationCompleted event for the WebView2 WebBrowser provider type.

Parameters
sender | WebBrowser control that triggered the event.
args | Object that describes event arguments.
Returns
S_OK if successful, or an error code otherwise.

◆ WebView2_NavigationStarting()

virtual HRESULT WebView2_NavigationStarting | ( | CXTPWebBrowserCtrl & | sender,
 |  | ICoreWebView2NavigationStartingEventArgs * | args )
 inlinevirtual

Handles NavigationStarting event for the WebView2 WebBrowser provider type.

Parameters
sender | WebBrowser control that triggered the event.
args | Object that describes event arguments.
Returns
S_OK if successful, or an error code otherwise.

◆ WebView2_NewWindowRequested()

virtual HRESULT WebView2_NewWindowRequested | ( | CXTPWebBrowserCtrl & | sender,
 |  | ICoreWebView2NewWindowRequestedEventArgs * | args )
 inlinevirtual

Handles NewWindowRequested event for the WebView2 WebBrowser provider type.

Parameters
sender | WebBrowser control that triggered the event.
args | Object that describes event arguments.
Returns
S_OK if successful, or an error code otherwise.

◆ WebView2_PermissionRequested()

virtual HRESULT WebView2_PermissionRequested | ( | CXTPWebBrowserCtrl & | sender,
 |  | ICoreWebView2PermissionRequestedEventArgs * | args )
 inlinevirtual

Handles PermissionRequested event for the WebView2 WebBrowser provider type.

Parameters
sender | WebBrowser control that triggered the event.
args | Object that describes event arguments.
Returns
S_OK if successful, or an error code otherwise.

◆ WebView2_ProcessFailed()

virtual HRESULT WebView2_ProcessFailed | ( | CXTPWebBrowserCtrl & | sender,
 |  | ICoreWebView2ProcessFailedEventArgs * | args )
 inlinevirtual

Handles ProcessFailed event for the WebView2 WebBrowser provider type.

Parameters
sender | WebBrowser control that triggered the event.
args | Object that describes event arguments.
Returns
S_OK if successful, or an error code otherwise.

◆ WebView2_ScriptDialogOpening()

virtual HRESULT WebView2_ScriptDialogOpening | ( | CXTPWebBrowserCtrl & | sender,
 |  | ICoreWebView2ScriptDialogOpeningEventArgs * | args )
 inlinevirtual

Handles ScriptDialogOpening event for the WebView2 WebBrowser provider type.

Parameters
sender | WebBrowser control that triggered the event.
args | Object that describes event arguments.
Returns
S_OK if successful, or an error code otherwise.

◆ WebView2_SourceChanged()

virtual HRESULT WebView2_SourceChanged | ( | CXTPWebBrowserCtrl & | sender,
 |  | ICoreWebView2SourceChangedEventArgs * | args )
 inlinevirtual

Handles SourceChanged event for the WebView2 WebBrowser provider type.

Parameters
sender | WebBrowser control that triggered the event.
args | Object that describes event arguments.
Returns
S_OK if successful, or an error code otherwise.

◆ WebView2_WebResourceRequested()

virtual HRESULT WebView2_WebResourceRequested | ( | CXTPWebBrowserCtrl & | sender,
 |  | ICoreWebView2WebResourceRequestedEventArgs * | args )
 inlinevirtual

Handles WebResourceRequested event for the WebView2 WebBrowser provider type.

Parameters
sender | WebBrowser control that triggered the event.
args | Object that describes event arguments.
Returns
S_OK if successful, or an error code otherwise.

◆ WebView2_WindowCloseRequested()

virtual HRESULT WebView2_WindowCloseRequested | ( | CXTPWebBrowserCtrl & | sender,
 |  | IUnknown * | args )
 inlinevirtual

Handles WindowCloseRequested event for the WebView2 WebBrowser provider type.

Parameters
sender | WebBrowser control that triggered the event.
args | Object that describes event arguments.
Returns
S_OK if successful, or an error code otherwise.
The documentation for this struct was generated from the following file:
  • XTPWebBrowserAbstract.h


Toolkit Pro: NMXTPCHARHDR Struct Reference

Public Attributes | List of all members
NMXTPCHARHDR Struct Reference

Structure used as a parameter for XTP_FN_SETFORMAT and XTP_FN_GETFORMAT messages. More...

Inheritance diagram for NMXTPCHARHDR:
[legend]

Public Attributes

CHARFORMAT | cf
Character formatting in a rich edit control.
- Public Attributes inherited from NMXTPCONTROL
NMHDR | hdr
NMHDR structure that contains additional information about this notification.
CXTPControl * | pControl
Pointer to the control that caused the event.

Detailed Description

Structure used as a parameter for XTP_FN_SETFORMAT and XTP_FN_GETFORMAT messages.

Example: See Example of XTP_FN_SETFORMAT.

See also
XTP_FN_SETFORMAT, XTP_FN_GETFORMAT, CXTPControlFontComboBox
The documentation for this struct was generated from the following file:
  • XTPControlComboBoxExt.h


Toolkit Pro: NMXTPCONTROL Struct Reference

Public Attributes | List of all members
NMXTPCONTROL Struct Reference

This structure is passed as a parameter in CBN_XTP_EXECUTE message. More...

Inheritance diagram for NMXTPCONTROL:
[legend]

Public Attributes

NMHDR | hdr
NMHDR structure that contains additional information about this notification.
CXTPControl * | pControl
Pointer to the control that caused the event.

Detailed Description

This structure is passed as a parameter in CBN_XTP_EXECUTE message.

See description of CBN_XTP_EXECUTE for details.

See also
CBN_XTP_EXECUTE
The documentation for this struct was generated from the following file:
  • XTPCommandBarsDefines.h


Toolkit Pro: NMXTPSCROLL Struct Reference

Public Attributes | List of all members
NMXTPSCROLL Struct Reference

The NMXTPSCROLL structure contains information about the scroll bar. More...

Public Attributes

NMHDR | hdr
NMHDR structure that contains additional information about this notification.
CObject * | pSender
Pointer to the object that sent the message.
int | nSBCode
Scroll bar request codes, such as SB_LINEUP, SB_LINEDOWN, etc.
int | nPos
Position of the scroll bar thumb.

Detailed Description

The NMXTPSCROLL structure contains information about the scroll bar.

The documentation for this struct was generated from the following file:
  • XTPScrollBase.h


Toolkit Pro: NMXTPTABCHANGE Struct Reference

Public Attributes | List of all members
NMXTPTABCHANGE Struct Reference

Structure used as a parameter for TCN_SELCHANGING and TCN_SELCHANGE messages when a Ribbon tab is changed. More...

Inheritance diagram for NMXTPTABCHANGE:
[legend]

Public Attributes

CXTPRibbonTab * | pTab
Ribbon tab to be selected.
- Public Attributes inherited from NMXTPCONTROL
NMHDR | hdr
NMHDR structure that contains additional information about this notification.
CXTPControl * | pControl
Pointer to the control that caused the event.

Detailed Description

Structure used as a parameter for TCN_SELCHANGING and TCN_SELCHANGE messages when a Ribbon tab is changed.

The documentation for this struct was generated from the following file:
  • XTPRibbonControlTab.h


Toolkit Pro: XTP_CALENDAR_DAYVIEWCELL_PARAMS Struct Reference

Public Attributes | List of all members
XTP_CALENDAR_DAYVIEWCELL_PARAMS Struct Reference

Set of parameters transferred from calendar items for an XTP_NC_CALENDAR_BEFORE_DRAW_DAYVIEWCELL notification. More...

Public Attributes

int | nIndex
[in] Cell index.
DATE | dtBeginTime
[in] Begin cell date and time.
BOOL | bSelected
[in] Is cell selected.
COLORREF | clrBackgroundColor
[in/out] Background cell color.

Detailed Description

Set of parameters transferred from calendar items for an XTP_NC_CALENDAR_BEFORE_DRAW_DAYVIEWCELL notification.

This structure defines day view cell (exclude all day events area) drawing attributes.

See also
XTP_NC_CALENDAR_BEFORE_DRAW_DAYVIEWCELL

Member Data Documentation

◆ bSelected

BOOL bSelected

[in] Is cell selected.

◆ nIndex

int nIndex

[in] Cell index.

The documentation for this struct was generated from the following file:
  • XTPCalendarNotifications.h


Toolkit Pro: XTP_CALENDAR_GETITEMTEXT_PARAMS Struct Reference

Public Attributes | List of all members
XTP_CALENDAR_GETITEMTEXT_PARAMS Struct Reference

Set of parameters transferred from calendar items for an XTP_NC_CALENDAR_GETITEMTEXT notification. More...

Public Attributes

int | nItem
[in] One of the values from enums XTPCalendarGetItemText, XTPCalendarGetItemTextEx;
CString * | pstrText
[in, out] - Pointer to item text;
CXTPCalendarViewEvent * | pViewEvent
[in] Pointer to a ViewEvent object or NULL.
CXTPCalendarViewDay * | pViewDay
[in] Pointer to a ViewDay object or NULL.
int | nWeekDay
[in] Zero or Week day number as: 1 - Sunday, 2 - Monday, etc, 7 - Saturday.
int | nWeekNum
[in] Zero or current visible range first week number.

Detailed Description

Set of parameters transferred from calendar items for an XTP_NC_CALENDAR_GETITEMTEXT notification.

This structure defines an calendar item, item data and in-out item text to customize.

See also
XTP_NC_CALENDAR_GETITEMTEXTL
XTPCalendarGetItemText
XTPCalendarGetItemTextEx.
The documentation for this struct was generated from the following file:
  • XTPCalendarNotifications.h


Toolkit Pro: XTP_CALENDAR_HITTESTINFO Struct Reference

Public Member Functions | Public Attributes | List of all members
XTP_CALENDAR_HITTESTINFO Struct Reference

Basic set of parameters transferred from calendar items to mouse handlers. More...

Inheritance diagram for XTP_CALENDAR_HITTESTINFO:
[legend]

Public Member Functions

XTP_CALENDAR_HITTESTINFO ()
Default constructor.
virtual | ~XTP_CALENDAR_HITTESTINFO ()
Default destructor.
BOOL | operator== (const XTP_CALENDAR_HITTESTINFO &hitInfo2)
Equality operator.
BOOL | operator!= (const XTP_CALENDAR_HITTESTINFO &hitInfo2)
Non-Equality operator.

Public Attributes

COleDateTime | dt
Time stamp on the specified point.
BOOL | bTimePartValid
Specifies whether date's time part is valid, i.e.
int | uHitCode
A bitwise combination of XTPCalendarHitTestCode constants.
int | nDay
Number of the day.
int | nGroup
Number of the group.
int | nEvent
ID of the specified event.
CXTPCalendarViewDay * pViewDay
Pointer to affected CXTPCalendarViewDay object.
CXTPCalendarViewGroup * | pViewGroup
Pointer to affected CXTPCalendarViewGroup object.
CXTPCalendarViewEvent * | pViewEvent
Pointer to affected CXTPCalendarViewEvent object.

Detailed Description

Basic set of parameters transferred from calendar items to mouse handlers.

This structure groups together all essential parameters used in items processing activities. It is a basic structure for all particular calendar's structures.

See also
XTP_CALENDAR_HITTESTINFO
XTP_CALENDAR_HITTESTINFO
XTP_CALENDAR_HITTESTINFO

Constructor & Destructor Documentation

◆ XTP_CALENDAR_HITTESTINFO()

XTP_CALENDAR_HITTESTINFO ( )
inline

Default constructor.

Initializes a XTP_CALENDAR_HITTESTINFO object to the empty and zero values.

Member Function Documentation

◆ operator!=()

BOOL operator!= ( const XTP_CALENDAR_HITTESTINFO & hitInfo2 )
inline

Non-Equality operator.

Parameters
hitInfo2 Second XTP_CALENDAR_HITTESTINFO object to compare.

Compare 2 XTP_CALENDAR_HITTESTINFO objects.

Returns
TRUE if specified objects are not equal, otherwise FALSE.

◆ operator==()

BOOL operator== ( const XTP_CALENDAR_HITTESTINFO & hitInfo2 )

Equality operator.

Parameters
hitInfo2 Second XTP_CALENDAR_HITTESTINFO object to compare.

Compare 2 XTP_CALENDAR_HITTESTINFO objects.

Returns
TRUE if specified objects are equal, otherwise FALSE.

Member Data Documentation

◆ bTimePartValid

BOOL bTimePartValid

Specifies whether date's time part is valid, i.e.

if we hit on all day events area, bTimePartValid will be FALSE.

◆ pViewDay

CXTPCalendarViewDay* pViewDay

Pointer to affected CXTPCalendarViewDay object.

The documentation for this struct was generated from the following file:
  • XTPCalendarDefines.h


Toolkit Pro: XTP_CALENDAR_HITTESTINFO_TIMELINE_VIEW Struct Reference

Public Member Functions | List of all members
XTP_CALENDAR_HITTESTINFO_TIMELINE_VIEW Struct Reference

Set of parameters transferred from calendar items to mouse handlers. More...

Inheritance diagram for XTP_CALENDAR_HITTESTINFO_TIMELINE_VIEW:
[legend]

Public Member Functions

XTP_CALENDAR_HITTESTINFO_TIMELINE_VIEW ()
Default constructor.
- Public Member Functions inherited from XTP_CALENDAR_HITTESTINFO
XTP_CALENDAR_HITTESTINFO ()
Default constructor.
virtual | ~XTP_CALENDAR_HITTESTINFO ()
Default destructor.
BOOL | operator== (const XTP_CALENDAR_HITTESTINFO &hitInfo2)
Equality operator.
BOOL | operator!= (const XTP_CALENDAR_HITTESTINFO &hitInfo2)
Non-Equality operator.

Additional Inherited Members

- Public Attributes inherited from XTP_CALENDAR_HITTESTINFO
COleDateTime | dt
Time stamp on the specified point.
BOOL | bTimePartValid
Specifies whether date's time part is valid, i.e.
int | uHitCode
A bitwise combination of XTPCalendarHitTestCode constants.
int | nDay
Number of the day.
int | nGroup
Number of the group.
int | nEvent
ID of the specified event.
CXTPCalendarViewDay * pViewDay
Pointer to affected CXTPCalendarViewDay object.
CXTPCalendarViewGroup * | pViewGroup
Pointer to affected CXTPCalendarViewGroup object.
CXTPCalendarViewEvent * | pViewEvent
Pointer to affected CXTPCalendarViewEvent object.

Detailed Description

Set of parameters transferred from calendar items to mouse handlers.

This structure groups together all essential parameters used in item processing activities. It is a basic structure for all particular calendar's structures.

See also
XTP_CALENDAR_HITTESTINFO

Constructor & Destructor Documentation

◆ XTP_CALENDAR_HITTESTINFO_TIMELINE_VIEW()

XTP_CALENDAR_HITTESTINFO_TIMELINE_VIEW ( )
inline

Default constructor.

Initializes an XTP_CALENDAR_HITTESTINFO_TIMELINE_VIEW object to the empty values.

The documentation for this struct was generated from the following file:
  • XTPCalendarTimeLineView.h


Toolkit Pro: XTP_CALENDAR_MONTHVIEW_DAYPOS Struct Reference

Public Member Functions | Public Attributes | List of all members
XTP_CALENDAR_MONTHVIEW_DAYPOS Struct Reference

Defines a set of data and methods to easily manipulate with day positions in month view. More...

Public Member Functions

operator int () const
This member function is used to obtain the sequential integer value.
const XTP_CALENDAR_MONTHVIEW_DAYPOS & | operator= (int nPOS)
This member function is used to set a new Sequential integer value.
XTP_CALENDAR_MONTHVIEW_DAYPOS & operator++ ()
This member function is used to pre-increment a sequential position by 1.
XTP_CALENDAR_MONTHVIEW_DAYPOS | operator++ (int)
This member function is used to post-increment a sequential position by 1.
int | GetPOS () const
This member function is used to obtain a sequential integer value.
void | SetPOS (int nWidx, int nWDidx)
This member function is used to set a new week/day index value.
void | SetPOS (int nPOS)
This member function is used to set a new sequential integer value.
BOOL | IsValid () const
This member function is used to determine if the WeekIndex and WeekDayIndex values are valid.

Public Attributes

int | nWeekIndex
Week index.
int | nWeekDayIndex
Week day cell index.

Detailed Description

Defines a set of data and methods to easily manipulate with day positions in month view.

Used to convert Week/Day indexes pair to sequential integer value and vice versa.

Member Function Documentation

◆ GetPOS()

AFX_INLINE int GetPOS ( ) const

This member function is used to obtain a sequential integer value.

Returns
An int that represents the sequential integer value.
See also
SetPOS
operator int()

◆ IsValid()

AFX_INLINE BOOL IsValid ( ) const

This member function is used to determine if the WeekIndex and WeekDayIndex values are valid.

The valid values are nWeekIndex >= 0 || nWeekDayIndex >= 0.

Returns
TRUE if values are valid. Otherwise FALSE.

◆ operator int()

AFX_INLINE operator int ( ) const

This member function is used to obtain the sequential integer value.

This is the overloaded int operator.

Returns
Sequential integer value.
See also
GetPOS

◆ operator++() [1/2]

AFX_INLINE XTP_CALENDAR_MONTHVIEW_DAYPOS & operator++ ( )

This member function is used to pre-increment a sequential position by 1.

This is the overloaded pre-increment operator.(++i)

Returns
This object reference incremented by 1.

◆ operator++() [2/2]

AFX_INLINE XTP_CALENDAR_MONTHVIEW_DAYPOS operator++ ( int )

This member function is used to post-increment a sequential position by 1.

This is the overloaded post-increment operator.(i++)

Returns
Object value before incrementing.

◆ operator=()

AFX_INLINE const XTP_CALENDAR_MONTHVIEW_DAYPOS & operator= ( int nPOS )

This member function is used to set a new Sequential integer value.

Parameters
nPOS An int that contains the new value.

This is the overloaded assignment operator.

Returns
An XTP_CALENDAR_MONTHVIEW_DAYPOS object reference.
See also
SetPOS

◆ SetPOS() [1/2]

AFX_INLINE void SetPOS ( int nPOS )

This member function is used to set a new sequential integer value.

Parameters
nPOS An int that contains the new integer value.
See also
operator=(int nPOS), SetPOS(int nWidx, int nWDidx)

◆ SetPOS() [2/2]

AFX_INLINE void SetPOS | ( | int | nWidx,
 |  | int | nWDidx )

This member function is used to set a new week/day index value.

Parameters
nWidx | An int that contains the Week index. Valid values are from 0 to XTP_CALENDAR_MONTHVIEW_SHOW_WEEKS_MAX.
nWDidx | An int that contains the Week day cell index. Valid values are From 0 to 6.
See also
operator=(int nPOS)
SetPOS(int nPOS)

Member Data Documentation

◆ nWeekDayIndex

int nWeekDayIndex

Week day cell index.

From 0 to 6

◆ nWeekIndex

int nWeekIndex

Week index.

From 0 to XTP_CALENDAR_MONTHVIEW_SHOW_WEEKS_MAX

The documentation for this struct was generated from the following files:
  • XTPCalendarDefines.h
  • XTPCalendarMonthView.h


Toolkit Pro: XTP_CALENDAR_PATTERN_END Struct Reference

Public Member Functions | Public Attributes | List of all members
XTP_CALENDAR_PATTERN_END Struct Reference

This structure describes parameters of the end of the recurrence pattern type. More...

Public Member Functions

XTP_CALENDAR_PATTERN_END ()
Default constructor of the structure.
virtual | ~XTP_CALENDAR_PATTERN_END ()
Default destructor of the structure.
const XTP_CALENDAR_PATTERN_END & | operator= (const XTP_CALENDAR_PATTERN_END &rSrc)
This assignment operator is used to initialize a XTP_CALENDAR_PATTERN_END object.

Public Attributes

XTPCalendarPatternEnd | m_nUseEnd
End type.
COleDateTime | m_dtPatternEndDate
End date.
int | m_nEndAfterOccurrences
End number of occurrences.

Detailed Description

This structure describes parameters of the end of the recurrence pattern type.

Constructor & Destructor Documentation

◆ XTP_CALENDAR_PATTERN_END()

XTP_CALENDAR_PATTERN_END ( )
inline

Default constructor of the structure.

Handles members initialization.

See also
~XTP_CALENDAR_PATTERN_END

◆ ~XTP_CALENDAR_PATTERN_END()

virtual ~XTP_CALENDAR_PATTERN_END ( )
inlinevirtual

Default destructor of the structure.

Handles members deallocation.

See also
XTP_CALENDAR_PATTERN_END

Member Function Documentation

◆ operator=()

const XTP_CALENDAR_PATTERN_END & operator= ( const XTP_CALENDAR_PATTERN_END & rSrc )
inline

This assignment operator is used to initialize a XTP_CALENDAR_PATTERN_END object.

Parameters
rSrc Source value.
Returns
A reference to a valid XTP_CALENDAR_PATTERN_END object.
The documentation for this struct was generated from the following file:
  • XTPCalendarDefines.h


Toolkit Pro: XTP_CALENDAR_RECURRENCE_OPTIONS Struct Reference

Classes | Public Member Functions | Public Attributes | List of all members
XTP_CALENDAR_RECURRENCE_OPTIONS Struct Reference

This structure defines a set of Recurrence Pattern options and is used by a CXTPRecurrencePattern to easily manage and transfer recurrence pattern data. More...

Classes

struct | PATTERN_DAILY
Defines a group of parameters to describe the Daily pattern. More...
struct | PATTERN_MONTHLY
Defines a group of parameters to describe the Month pattern. More...
struct | PATTERN_MONTHNTH
Defines a group of parameters to describe the Month pattern. More...
struct | PATTERN_WEEKLY
Defines a group of parameters to describe the Weekly pattern. More...
struct | PATTERN_YEARLY
Defines a group of parameters to describe the Year pattern. More...
struct | PATTERN_YEARNTH
Defines a group of parameters to describe the Year pattern. More...

Public Member Functions

XTP_CALENDAR_RECURRENCE_OPTIONS ()
Default class constructor.
const XTP_CALENDAR_RECURRENCE_OPTIONS & | operator= (const XTP_CALENDAR_RECURRENCE_OPTIONS &rSrc)
Copy operator.
void | GetData (long &rnData1, long &rnData2, long &rnData3, long &rnData4) const
Saves this object data as 4 long values.
void | SetData (long nData1, long nData2, long nData3, long nData4)
Restore this object data from 4 long values previously retrieved using GetData() member function.

Public Attributes

XTPCalendarEventRecurrenceType m_nRecurrenceType
Recurrence type, See Also: XTPCalendarEventRecurrenceType.

Detailed Description

This structure defines a set of Recurrence Pattern options and is used by a CXTPRecurrencePattern to easily manage and transfer recurrence pattern data.

See also
XTPCalendarEventRecurrenceType
XTPCalendarWeekDay
XTPCalendarWeekDay_Masks
XTPCalendarWeekDay
XTPCalendarWeek
CXTPRecurrencePattern

Member Function Documentation

◆ GetData()

void GetData | ( | long & | rnData1,
 |  | long & | rnData2,
 |  | long & | rnData3,
 |  | long & | rnData4 ) const
 inline

Saves this object data as 4 long values.

Parameters
rnData1 | [out] Reference to data variable number 1
rnData2 | [out] Reference to data variable number 2
rnData3 | [out] Reference to data variable number 3
rnData4 | [out] Reference to data variable number 4

Useful to save data in data storage;

See also
SetData()

◆ operator=()

const XTP_CALENDAR_RECURRENCE_OPTIONS & operator= ( const XTP_CALENDAR_RECURRENCE_OPTIONS & rSrc )
inline

Copy operator.

Parameters
rSrc The source object reference;
Returns
This object reference.

◆ SetData()

void SetData | ( | long | nData1,
 |  | long | nData2,
 |  | long | nData3,
 |  | long | nData4 )
 inline

Restore this object data from 4 long values previously retrieved using GetData() member function.

Parameters
nData1 | [in] data value number 1
nData2 | [in] data value number 2
nData3 | [in] data value number 3
nData4 | [in] data value number 4

Useful to load data from data storage;

See also
GetData()

Member Data Documentation

◆ m_Daily

PATTERN_DAILY m_Daily

Options for Daily Recurrence type.

◆ m_Weekly

PATTERN_WEEKLY m_Weekly

Options for Weekly Recurrence type.

◆ m_Yearly

PATTERN_YEARLY m_Yearly

Options for Yearly Recurrence type.

The documentation for this struct was generated from the following file:
  • XTPCalendarRecurrencePattern.h


Toolkit Pro: XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_DAILY Struct Reference

  • XTP_CALENDAR_RECURRENCE_OPTIONS
  • PATTERN_DAILY
Public Attributes | List of all members
XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_DAILY Struct Reference

Defines a group of parameters to describe the Daily pattern. More...

Public Attributes

BOOL | bEveryWeekDayOnly
Flag determines if the event occurs every week day.
int | nIntervalDays
Event occurs every nIntervalDays days beginning from a start date.

Detailed Description

Defines a group of parameters to describe the Daily pattern.

The documentation for this struct was generated from the following file:
  • XTPCalendarRecurrencePattern.h


Toolkit Pro: XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_MONTHLY Struct Reference

  • XTP_CALENDAR_RECURRENCE_OPTIONS
  • PATTERN_MONTHLY
Public Attributes | List of all members
XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_MONTHLY Struct Reference

Defines a group of parameters to describe the Month pattern. More...

Public Attributes

int | nIntervalMonths
Event occurs every nIntervalMonths with the first month beginning from the start date.
int | nDayOfMonth
Determines the day of the month when an event occurs.

Detailed Description

Defines a group of parameters to describe the Month pattern.

Member Data Documentation

◆ nDayOfMonth

int nDayOfMonth

Determines the day of the month when an event occurs.

See also
XTPCalendarWeek.
The documentation for this struct was generated from the following file:
  • XTPCalendarRecurrencePattern.h


Toolkit Pro: XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_MONTHNTH Struct Reference

  • XTP_CALENDAR_RECURRENCE_OPTIONS
  • PATTERN_MONTHNTH
Public Attributes | List of all members
XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_MONTHNTH Struct Reference

Defines a group of parameters to describe the Month pattern. More...

Public Attributes

int | nIntervalMonths
Event occurs every nIntervalMonths month beginning from start date.
int | nWhichDay
Determines the day of the month or nth order of day.
int | nWhichDayMask
Weekday code.

Detailed Description

Defines a group of parameters to describe the Month pattern.

The documentation for this struct was generated from the following file:
  • XTPCalendarRecurrencePattern.h


Toolkit Pro: XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_WEEKLY Struct Reference

  • XTP_CALENDAR_RECURRENCE_OPTIONS
  • PATTERN_WEEKLY
Public Attributes | List of all members
XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_WEEKLY Struct Reference

Defines a group of parameters to describe the Weekly pattern. More...

Public Attributes

int | nIntervalWeeks
Event occurs every nIntervalWeeks with the first week beginning from a start date.
int | nDayOfWeekMask
Determines the days of the week when an event occurs.

Detailed Description

Defines a group of parameters to describe the Weekly pattern.

Member Data Documentation

◆ nDayOfWeekMask

int nDayOfWeekMask

Determines the days of the week when an event occurs.

See also
XTPCalendarWeekDay, XTPCalendarWeekDay_Masks.
The documentation for this struct was generated from the following file:
  • XTPCalendarRecurrencePattern.h


Toolkit Pro: XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_YEARLY Struct Reference

  • XTP_CALENDAR_RECURRENCE_OPTIONS
  • PATTERN_YEARLY
Public Attributes | List of all members
XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_YEARLY Struct Reference

Defines a group of parameters to describe the Year pattern. More...

Public Attributes

int | nMonthOfYear
The month of every year that the event occurs on.
int | nDayOfMonth
The day of month that the event occurs on.

Detailed Description

Defines a group of parameters to describe the Year pattern.

The documentation for this struct was generated from the following file:
  • XTPCalendarRecurrencePattern.h


Toolkit Pro: XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_YEARNTH Struct Reference

  • XTP_CALENDAR_RECURRENCE_OPTIONS
  • PATTERN_YEARNTH
Public Attributes | List of all members
XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_YEARNTH Struct Reference

Defines a group of parameters to describe the Year pattern. More...

Public Attributes

int | nWhichDay
Determines the day of the month or the nth order of the day.
int | nWhichDayMask
Weekday code.
int | nMonthOfYear
Month of the year.

Detailed Description

Defines a group of parameters to describe the Year pattern.

The documentation for this struct was generated from the following file:
  • XTPCalendarRecurrencePattern.h


Toolkit Pro: XTP_CALENDAR_THEME_DAYVIEWCELL_PARAMS Struct Reference

Public Attributes | List of all members
XTP_CALENDAR_THEME_DAYVIEWCELL_PARAMS Struct Reference

Set of parameters transferred from calendar items for an XTP_NC_CALENDAR_BEFORE_DRAW_THEMEOBJECT notification. More...

Public Attributes

int | nIndex
[in] Cell index.
DATE | dtBeginTime
[in] Begin cell date and time.
BOOL | bSelected
[in] Is cell selected.
BOOL | bWorkCell
[in] The cell is work (or non-work).
CXTPCalendarDayViewGroup * | pViewGroup
[in] Owner group.

Detailed Description

Set of parameters transferred from calendar items for an XTP_NC_CALENDAR_BEFORE_DRAW_THEMEOBJECT notification.

This structure defines day view cell (exclude all day events area) drawing attributes.

See also
XTP_NC_CALENDAR_BEFORE_DRAW_THEMEOBJECT

Member Data Documentation

◆ bSelected

BOOL bSelected

[in] Is cell selected.

◆ dtBeginTime

DATE dtBeginTime

[in] Begin cell date and time.

◆ nIndex

int nIndex

[in] Cell index.

The documentation for this struct was generated from the following file:
  • XTPCalendarNotifications.h


Toolkit Pro: XTP_CALENDAR_THEME_DAYVIEWTIMESCALECELL_PARAMS Struct Reference

Public Attributes | List of all members
XTP_CALENDAR_THEME_DAYVIEWTIMESCALECELL_PARAMS Struct Reference

Set of parameters transferred from calendar items for an XTP_NC_CALENDAR_BEFORE_DRAW_THEMEOBJECT notification. More...

Public Attributes

int | nTimeScale
[in] Time scale number {1 - main, 2 - additional}
int | nIndex
[in] Cell index.
DATE | dtBeginTime
[in] Begin cell time.
int | nMinutes
[in] SubCell Minutes value {0, 5, 10, ...} or -1 for cell hour.

Detailed Description

Set of parameters transferred from calendar items for an XTP_NC_CALENDAR_BEFORE_DRAW_THEMEOBJECT notification.

This structure defines day timescale cell drawing attributes.

See also
XTP_NC_CALENDAR_BEFORE_DRAW_THEMEOBJECT
The documentation for this struct was generated from the following file:
  • XTPCalendarNotifications.h


Toolkit Pro: XTP_CALENDAR_TIMELINE_VIEW_SCALE Struct Reference

Public Attributes | List of all members
XTP_CALENDAR_TIMELINE_VIEW_SCALE Struct Reference

Timeline's view scale. More...

Public Attributes

int | m_eType
One of the values from enum XTPEnumCalendarDateItem.
int | m_nValue
Number of days to show (e.g.

Detailed Description

Timeline's view scale.

Member Data Documentation

◆ m_nValue

int m_nValue

Number of days to show (e.g.

1, 5, 7, 31).

The documentation for this struct was generated from the following file:
  • XTPCalendarTimeLineViewTimeScale.h


Toolkit Pro: XTP_CALENDAR_USERACTION_PARAMS Struct Reference

Classes | Public Attributes | List of all members
XTP_CALENDAR_USERACTION_PARAMS Struct Reference

Set of parameters transferred from calendar items for an XTP_NC_CALENDAR_USERACTION notification. More...

Classes

struct | EXPANDDAYBUTTONACTION_PARAMS
Defines parameters for xtpCalendarUserAction_OnExpandDay user action. More...
struct | SCROLLDAYBUTTONACTION_PARAMS
Defines parameters for xtpCalendarUserAction_OnScrollDay user action. More...

Public Attributes

XTPCalendarUserAction m_eAction
A value from XTPCalendarUserAction.

Detailed Description

Set of parameters transferred from calendar items for an XTP_NC_CALENDAR_USERACTION notification.

See also
XTPCalendarUserAction
The documentation for this struct was generated from the following file:
  • XTPCalendarNotifications.h


Toolkit Pro: XTP_CALENDAR_USERACTION_PARAMS::EXPANDDAYBUTTONACTION_PARAMS Struct Reference

  • XTP_CALENDAR_USERACTION_PARAMS
  • EXPANDDAYBUTTONACTION_PARAMS
Public Attributes | List of all members
XTP_CALENDAR_USERACTION_PARAMS::EXPANDDAYBUTTONACTION_PARAMS Struct Reference

Defines parameters for xtpCalendarUserAction_OnExpandDay user action. More...

Public Attributes

XTPCalendarExpandDayButton | nButton
Defines Month view or Week View expand button.
CXTPCalendarViewDay * | pViewDay
Pointer to a CXTPCalendarDayViewDay object or NULL.

Detailed Description

Defines parameters for xtpCalendarUserAction_OnExpandDay user action.

The documentation for this struct was generated from the following file:
  • XTPCalendarNotifications.h


Toolkit Pro: XTP_CALENDAR_USERACTION_PARAMS::SCROLLDAYBUTTONACTION_PARAMS Struct Reference

  • XTP_CALENDAR_USERACTION_PARAMS
  • SCROLLDAYBUTTONACTION_PARAMS
Public Attributes | List of all members
XTP_CALENDAR_USERACTION_PARAMS::SCROLLDAYBUTTONACTION_PARAMS Struct Reference

Defines parameters for xtpCalendarUserAction_OnScrollDay user action. More...

Public Attributes

XTPCalendarScrollDayButton | nButton
Defines Month view or Week View expand button.
CXTPCalendarDayViewGroup * | pViewGroup
Pointer to a CXTPCalendarDayViewGroup object or NULL.

Detailed Description

Defines parameters for xtpCalendarUserAction_OnScrollDay user action.

The documentation for this struct was generated from the following file:
  • XTPCalendarNotifications.h


Toolkit Pro: XTP_CALENDAR_VIEWSELECTION Struct Reference

Public Member Functions | Public Attributes | List of all members
XTP_CALENDAR_VIEWSELECTION Struct Reference

Structure contains the calendar day view selection block. More...

Public Member Functions

XTP_CALENDAR_VIEWSELECTION ()
Default constructor.
const XTP_CALENDAR_VIEWSELECTION & | operator= (const XTP_CALENDAR_VIEWSELECTION &rSrc)
Copy operator.
BOOL | IsValid () const
Determines if the values of date time object members are valid.

Public Attributes

int | nGroupIndex
Numeric index of the corresponding resource group.
COleDateTime | dtBegin
Selection start time.
COleDateTime | dtEnd
Selection finish time.
BOOL | bAllDayEvent
TRUE when all day is selected, FALSE otherwise.

Detailed Description

Structure contains the calendar day view selection block.

This structure describes a selection bounds on the calendar day view.

See also
CXTPCalendarDayView

Constructor & Destructor Documentation

◆ XTP_CALENDAR_VIEWSELECTION()

XTP_CALENDAR_VIEWSELECTION ( )
inline

Default constructor.

Initializes a XTP_CALENDAR_VIEWSELECTION object to the empty selection bounds.

Member Function Documentation

◆ IsValid()

BOOL IsValid ( ) const
inline

Determines if the values of date time object members are valid.

Returns
TRUE if date time object members are valid, otherwise FALSE.

◆ operator=()

const XTP_CALENDAR_VIEWSELECTION & operator= ( const XTP_CALENDAR_VIEWSELECTION & rSrc )
inline

Copy operator.

Parameters
rSrc The source object.

Initialize members from the specified object.

Returns
Reference to the current object.

Member Data Documentation

◆ bAllDayEvent

BOOL bAllDayEvent

TRUE when all day is selected, FALSE otherwise.

◆ dtBegin

COleDateTime dtBegin

Selection start time.

◆ dtEnd

COleDateTime dtEnd

Selection finish time.

The documentation for this struct was generated from the following file:
  • XTPCalendarDefines.h


Toolkit Pro: XTP_CALENDAR_WPARAM2 Struct Reference

Public Attributes | List of all members
XTP_CALENDAR_WPARAM2 Struct Reference

Doubled custom parameter for notifications. More...

Public Attributes

WPARAM | wParam1
First custom parameter

WPARAM | wParam2
Second custom parameter.

Detailed Description

Doubled custom parameter for notifications.

Used when single WPARAM is not enough.

The documentation for this struct was generated from the following file:
  • XTPCalendarNotifications.h


Toolkit Pro: XTP_COMMANDBARS_CATEGORYINFO Struct Reference

Public Attributes | List of all members
XTP_COMMANDBARS_CATEGORYINFO Struct Reference

This structure stores categories for CXTPCustomizeCommandsPage and CXTPCustomizeKeyboardPage option pages. More...

Public Attributes

CString | strCategory
Category caption.
CXTPControls * | pControls
Controls of this category.

Detailed Description

This structure stores categories for CXTPCustomizeCommandsPage and CXTPCustomizeKeyboardPage option pages.

See also
CXTPCustomizeCommandsPage, CXTPCustomizeKeyboardPage
The documentation for this struct was generated from the following file:
  • XTPCustomizePageCommands.h


Toolkit Pro: XTP_COMMANDBARS_CREATEBAR Struct Reference

Public Attributes | List of all members
XTP_COMMANDBARS_CREATEBAR Struct Reference

Creates a bar structure. More...

Public Attributes

CXTPCommandBar * | pCommandBar
Created command bar.
BOOL | bPopup
TRUE if it is a pop-up command bar.
BOOL | bExpandBar
TRUE if it is an expanded pop-up.
BOOL | bCustomBar
TRUE if it is a user-defined toolbar.
BOOL | bTearOffBar
TRUE if it is a user tear-off pop-up.
LPCTSTR | lpcstrCaption
Caption of the command bar.
UINT | nID
Identifier of the command bar.

Detailed Description

Creates a bar structure.

This structure contains extended information about a bar to be created. CXTPCommandBars sends an XTP_COMMANDBARS_CREATEBAR message to the owner site when a new CXTPCommandBar object is about to be created.

See also
WM_XTP_CREATECOMMANDBAR
The documentation for this struct was generated from the following file:
  • XTPCommandBarsDefines.h


Toolkit Pro: XTP_COMMANDBARS_CREATECONTROL Struct Reference

Public Attributes | List of all members
XTP_COMMANDBARS_CREATECONTROL Struct Reference

Creates a control structure. More...

Public Attributes

UINT | nID
Identifier of the control to be created.
CXTPControl * | pControl
Control to be created.
BOOL | bToolBar
TRUE if control is toolbar located.
int | nIndex
Index of the control to be created.
CMenu * | pMenu
A Pointer to CMenu object.
CXTPCommandBar * | pCommandBar
Pointer to the parent command bar class.
CString | strCaption
Caption of the control to be created.
XTPControlType | controlType
Type of the control.
XTPButtonStyle | buttonStyle
Button Style of the control.

Detailed Description

Creates a control structure.

This structure contains extended information about a CXTPControl object to be created. CXTPCommandBars sends an XTP_COMMANDBARS_CREATECONTROL message to the owner site when a new CXTPControl object is about to become created.

See also
WM_XTP_CREATECONTROL
The documentation for this struct was generated from the following file:
  • XTPCommandBarsDefines.h


Toolkit Pro: XTP_COMMANDBARS_ICONSINFO Struct Reference

Public Attributes | List of all members
XTP_COMMANDBARS_ICONSINFO Struct Reference

This structure collect icons options for command bars. More...

Public Attributes

BOOL | bUseFadedIcons
If TRUE, icons will appear faded.
BOOL | bUseDisabledIcons
If TRUE, disabled icons will be used when the control is disabled.
BOOL | bIconsWithShadow
If TRUE, when the mouse pointer is moved over a command bar control, the icons will appear to "jump" away from the screen casting a shadow.
BOOL | bOfficeStyleDisabledIcons
If TRUE, Office 2003 style disabled icons will be drawn when using disabled icons.

Detailed Description

This structure collect icons options for command bars.

Example:

XTPPaintManager()->GetIconsInfo()->bIconsWithShadow = FALSE;
See also
CXTPPaintManager::GetIconsInfo
The documentation for this struct was generated from the following file:
  • XTPPaintManager.h


Toolkit Pro: XTP_COMMANDBARS_PROPEXCHANGE_PARAM Struct Reference

Public Attributes | List of all members
XTP_COMMANDBARS_PROPEXCHANGE_PARAM Struct Reference

XTP_COMMANDBARS_PROPEXCHANGE_PARAM is a structure used to store the CommandBar's save settings. More...

Public Attributes

BOOL | bSerializeControls
If TRUE, the controls in the CommandBars will be saved.
BOOL | bSaveOnlyCustomized
If TRUE, only CommandBars that have been customized will be saved.
BOOL | bLoadSilent
If TRUE, no message boxes will be displayed when the CommandBar layout is loaded.
BOOL | bSaveOriginalControls
If TRUE, the original state of the CommandBars is saved along with the customized state.
BOOL | bSerializeImages
If TRUE, the images stored in the ImageManager will be saved.
BOOL | bSerializeOptions
If TRUE, the setting on the Keyboard and Options pages of the Customize dialog will be saved.
BOOL | bSerializeLayout
If TRUE, the layout of the CommandBars will be saved.
BOOL | bSerializeDesignerControls
In the CommandBar Designer you can export a XCB file to a XML file and Load it in your project.
BOOL | bSerializeActions
TRUE to save/restore actions for commandbars.
CXTPCommandBars * | pCommandBars
Pointer to the CommandBars object that the XTP_COMMANDBARS_PROPEXCHANGE_PARAM setting apply to.

Detailed Description

XTP_COMMANDBARS_PROPEXCHANGE_PARAM is a structure used to store the CommandBar's save settings.

This is a set of State options that will be used to change how and what will be saved and loaded when loading and saving XML files.

When saving your XML string to a file, be sure to use the .XML file extension. If you open up your .XML file in your favorite web browser it will automatically format the XML string into the correct format.

Example:

XTP_COMMANDBARS_PROPEXCHANGE_PARAM param;
param.bSerializeControls = TRUE;
// Serialize to XML
CXTPPropExchangeXMLNode px(FALSE, 0, _T("Settings"));
CXTPPropExchangeSection pxCommandBars(px.GetSection(_T("CommandBars")));
GetCommandBars()->DoPropExchange(&pxCommandBars, &param);
px.SaveToFile(m_strIniFileName);
See also
CXTPCommandBars::DoPropExchange, CXTPPropExchangeXMLNode

Member Data Documentation

◆ bLoadSilent

BOOL bLoadSilent

If TRUE, no message boxes will be displayed when the CommandBar layout is loaded.

i.e. The message box that asks for conformation before the CommandBar layout is reset.

◆ bSaveOnlyCustomized

BOOL bSaveOnlyCustomized

If TRUE, only CommandBars that have been customized will be saved.

The default is TRUE.

◆ bSaveOriginalControls

BOOL bSaveOriginalControls

If TRUE, the original state of the CommandBars is saved along with the customized state.

For example, if a button on a toolbar is moved, then both the original and modified states will be saved. The Default is TRUE.

◆ bSerializeControls

BOOL bSerializeControls

If TRUE, the controls in the CommandBars will be saved.

If FALSE, no controls will be saved, regardless of the other settings. The default is TRUE.

◆ bSerializeDesignerControls

BOOL bSerializeDesignerControls

In the CommandBar Designer you can export a XCB file to a XML file and Load it in your project.

If SerializeDesignerControls is TRUE, then the DesignerControls property will be filled with Control items from the CommandBar Designer's controls pane. This allows you to load the XML file instead of loading the XCB file using the LoadDesignerBars method. NOTE: DesignerControls are the controls displayed in the customization dialog. The CXTPPropExchangeXMLNode class is used to create the XML file. The default is FALSE.

◆ bSerializeImages

BOOL bSerializeImages

If TRUE, the images stored in the ImageManager will be saved.

The default is FALSE.

◆ bSerializeLayout

BOOL bSerializeLayout

If TRUE, the layout of the CommandBars will be saved.

The Layout includes information such as bar position, location, and size. The Default is TRUE.

◆ bSerializeOptions

BOOL bSerializeOptions

If TRUE, the setting on the Keyboard and Options pages of the Customize dialog will be saved.

This includes shortcut keys and CommandBar options like large icons and full menus. The default is FALSE.

The documentation for this struct was generated from the following file:
  • XTPCommandBars.h


Toolkit Pro: XTP_DAYITEM_METRICS Struct Reference

Public Member Functions | Public Attributes | List of all members
XTP_DAYITEM_METRICS Struct Reference

This structure represents a set of parameters which are used to display day items. More...

Inheritance diagram for XTP_DAYITEM_METRICS:
[legend]

Public Member Functions

CFont * | GetFont ()
Get day item font.
void | SetFont (CFont *pFont)
Set a new font for the day item.
- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.

Public Attributes

COLORREF | clrForeground
A COLORREF object that contains the item's foreground color.
COLORREF | clrBackground
A COLORREF object that contains the item's background color.

Additional Inherited Members

- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

This structure represents a set of parameters which are used to display day items.

  1. There could be customized foreground and background colors.
  2. Also you can text font for the displayed day text.
  3. And as the last thing you can customize a day picture displayed there, using OLE PICTUREDISP interface and OleSetPicture method.

Member Function Documentation

◆ GetFont()

CFont * GetFont ( )

Get day item font.

Returns
Return a day font stored by the structure.

◆ SetFont()

void SetFont ( CFont * pFont )

Set a new font for the day item.

Parameters
pFont Pointer to a CFont object.
The documentation for this struct was generated from the following file:
  • XTPDatePickerControl.h


Toolkit Pro: XTP_DOCKINGPANE_ACTION Struct Reference

Public Attributes | List of all members
XTP_DOCKINGPANE_ACTION Struct Reference

The XTP_DOCKINGPANE_ACTION structure contains information about the action performed by the user with docking panes. More...

Public Attributes

XTPDockingPaneAction | action
Current action the pane is performing.
BOOL | bCancel
If TRUE, then the current action will be ignored/canceled.
CXTPDockingPane * | pPane
Pane performing the action.
CXTPDockingPaneBase * | pDockContainer
Container of the xtpPaneActionDocking action.
XTPDockingPaneDirection | dockDirection
The direction that the pane is trying to dock, if any.

Detailed Description

The XTP_DOCKINGPANE_ACTION structure contains information about the action performed by the user with docking panes.

Example:

LRESULT CMainFrame::OnDockingPaneNotify(WPARAM wParam, LPARAM lParam)
{
   if (wParam == XTP_DPN_ACTION)
   {
      XTP_DOCKINGPANE_ACTION* pAction = (XTP_DOCKINGPANE_ACTION*)lParam;
      TRACE("Action %i\n", pAction->action);
      return TRUE;
   }
   return FALSE;
}
See also
XTP_DPN_ACTION, XTPDockingPaneAction
The documentation for this struct was generated from the following file:
  • XTPDockingPaneDefines.h


Toolkit Pro: XTP_DOCKINGPANE_CLICK Struct Reference

Public Attributes | List of all members
XTP_DOCKINGPANE_CLICK Struct Reference

The XTP_DOCKINGPANE_CLICK structure contains information about the pane that was used in an XTP_DPN_PANEMENUCLICK message. More...

Public Attributes

CXTPDockingPane * | pPane
Docking Pane pointer.
CXTPDockingPaneBase * | pContainer
Docking Pane container.
CPoint | pt
Mouse pointer.
CRect | rcExclude
Exclude rectangle.

Detailed Description

The XTP_DOCKINGPANE_CLICK structure contains information about the pane that was used in an XTP_DPN_PANEMENUCLICK message.

See also
XTP_DPN_PANEMENUCLICK
The documentation for this struct was generated from the following file:
  • XTPDockingPaneDefines.h


Toolkit Pro: XTP_DOCKINGPANE_INFO Struct Reference

Public Attributes | List of all members
XTP_DOCKINGPANE_INFO Struct Reference

Internal structure used by the Layout manager. More...

Public Attributes

CXTPDockingPane * | pPane
Docking Pane.
CXTPDockingPaneBase * | pFloatingHolder
Last floating holder of the pane.
CXTPDockingPaneBase * | pDockingHolder
Last docking holder of the pane.
CXTPDockingPaneBase * | pLastHolder
Last holder (must be pFloatingHolder or pDockingHolder).

Detailed Description

Internal structure used by the Layout manager.

See also
CXTPDockingPaneLayout
The documentation for this struct was generated from the following file:
  • XTPDockingPaneDefines.h


Toolkit Pro: XTP_EDIT_ACDATA Struct Reference

Public Member Functions | Public Attributes | List of all members
XTP_EDIT_ACDATA Struct Reference

The XTP_EDIT_ACDATA structure defines items' displayed data and provides text and icons for each displayed line in the auto-complete window. More...

Public Member Functions

XTP_EDIT_ACDATA (int nIcon, CString strText)
Default class constructor.

Public Attributes

int | m_nIcon
The icon ID.
CString | m_strText
The item text.

Detailed Description

The XTP_EDIT_ACDATA structure defines items' displayed data and provides text and icons for each displayed line in the auto-complete window.

Constructor & Destructor Documentation

◆ XTP_EDIT_ACDATA()

XTP_EDIT_ACDATA | ( | int | nIcon,
 |  | CString | strText )
 inline

Default class constructor.

Parameters
nIcon | The icon ID.
strText | The item text.
The documentation for this struct was generated from the following file:
  • XTPSyntaxEditAutoCompleteWnd.h


Toolkit Pro: XTP_EDIT_COLLAPSEDBLOCK Struct Reference

Public Attributes | List of all members
XTP_EDIT_COLLAPSEDBLOCK Struct Reference

Stores collapsed block parameters. More...

Public Attributes

XTP_EDIT_ROWSBLOCK | collBlock
Collapsed block parameters.
CRect | rcCollMark
Rectangle area to display collapsed block.

Detailed Description

Stores collapsed block parameters.

See also
XTP_EDIT_ROWSBLOCK
The documentation for this struct was generated from the following file:
  • XTPSyntaxEditStruct.h


Toolkit Pro: XTP_EDIT_COLORVALUES Struct Reference

Public Member Functions | Public Attributes | List of all members
XTP_EDIT_COLORVALUES Struct Reference

Stores the colors for different phrases. More...

Public Member Functions

COLORREF GetBackColorEx (CXTPSyntaxEditCtrl *pEditCtrl)
Gets the corresponding background color for either the edit or read-only mode of a specified CXTPSyntaxEditCtrl object.

Public Attributes

CXTPPaintManagerColor | crText
Text color.
CXTPPaintManagerColor | crBack
Back color.
CXTPPaintManagerColor | crReadOnlyBack
Back color for read only mode.
CXTPPaintManagerColor | crHiliteText
Text color of selection.
CXTPPaintManagerColor | crHiliteBack
Text color of selection back.
CXTPPaintManagerColor | crInactiveHiliteText
Inactive text color of selection.
CXTPPaintManagerColor | crInactiveHiliteBack
Inactive text color of selection back.
CXTPPaintManagerColor | crLineNumberText
Line numbers text and line color.
CXTPPaintManagerColor | crLineNumberBack
Line numbers text and line color.
CXTPPaintManagerColor | crBreakpointText
Breakpoint Text color.
CXTPPaintManagerColor | crBreakpointBack
Breakpoint Back color.

Detailed Description

Stores the colors for different phrases.

Member Function Documentation

◆ GetBackColorEx()

COLORREF GetBackColorEx ( CXTPSyntaxEditCtrl * pEditCtrl )

Gets the corresponding background color for either the edit or read-only mode of a specified CXTPSyntaxEditCtrl object.

Parameters
pEditCtrl Pointer to a CXTPSyntaxEditCtrl object.
Returns
The corresponding background color.
See also
crBack, crReadOnlyBack
The documentation for this struct was generated from the following file:
  • XTPSyntaxEditStruct.h


Toolkit Pro: XTP_EDIT_FONTOPTIONS Struct Reference

Public Member Functions | List of all members
XTP_EDIT_FONTOPTIONS Struct Reference

The XTP_EDIT_FONTOPTIONS structure is a self-initializing LOGFONT structure that initializes all values equal to XTP_EDIT_FONTOPTIONS_UNSPEC_OPTION except for lfFaceName which is set to zero length. More...

Public Member Functions

XTP_EDIT_FONTOPTIONS ()
Default constructor.

Detailed Description

The XTP_EDIT_FONTOPTIONS structure is a self-initializing LOGFONT structure that initializes all values equal to XTP_EDIT_FONTOPTIONS_UNSPEC_OPTION except for lfFaceName which is set to zero length.

See also
XTP_EDIT_FONTOPTIONS_UNSPEC_OPTION
The documentation for this struct was generated from the following file:
  • XTPSyntaxEditStruct.h


Toolkit Pro: XTP_EDIT_LINECOL Struct Reference

Public Member Functions | Static Public Member Functions | Public Attributes | Static Public Attributes | List of all members
XTP_EDIT_LINECOL Struct Reference

The XTP_EDIT_LINECOL structure represents the coordinates of text items on the displaying context in terms of line/column. More...

Public Member Functions

DWORD | GetXLC () const
Gets the coordinates in packed form.
BOOL | IsValidData () const
Determines if the data is valid.
void | Clear ()
Clears data members.
BOOL | operator< (const XTP_EDIT_LINECOL &pos2) const
Less than operator.
BOOL | operator<= (const XTP_EDIT_LINECOL &pos2) const
Less than or equal operator.
BOOL | operator> (const XTP_EDIT_LINECOL &pos2) const
Greater than operator.
BOOL | operator>= (const XTP_EDIT_LINECOL &pos2) const
Greater or equal operator.
BOOL | operator== (const XTP_EDIT_LINECOL &pos2) const
Equal operator.
BOOL | operator!= (const XTP_EDIT_LINECOL &pos2) const
Not Equal operator.

Static Public Member Functions

static const XTP_EDIT_LINECOL AFX_CDECL | MakeLineCol (int nParamLine, int nParamCol)
Constructs an XTP_EDIT_LINECOL object from a pair of coordinates (line and column).
static const XTP_EDIT_LINECOL AFX_CDECL | min2 (const XTP_EDIT_LINECOL &pos1, const XTP_EDIT_LINECOL &pos2)
Gets a minimum/maximum of two XTP_EDIT_LINECOL values.
static const XTP_EDIT_LINECOL AFX_CDECL | max2 (const XTP_EDIT_LINECOL &pos1, const XTP_EDIT_LINECOL &pos2)
Gets a minimum/maximum of two XTP_EDIT_LINECOL values.

Public Attributes

int | nLine
Line identifier.
int | nCol
Column identifier.

Static Public Attributes

static const XTP_EDIT_LINECOL | MAXPOS
Maximum position value.
static const XTP_EDIT_LINECOL | MINPOS
Minimum position value.
static const XTP_EDIT_LINECOL | Pos1
{1,0} position value.

Detailed Description

The XTP_EDIT_LINECOL structure represents the coordinates of text items on the displaying context in terms of line/column.

Member Function Documentation

◆ Clear()

void Clear ( )

Clears data members.

This function sets line/column coordinates to 0.

◆ GetXLC()

DWORD GetXLC ( ) const

Gets the coordinates in packed form.

Returns
The coordinates in packed form.

◆ IsValidData()

BOOL IsValidData ( ) const

Determines if the data is valid.

Returns
TRUE if the data is valid, otherwise FALSE.

◆ MakeLineCol()

static const XTP_EDIT_LINECOL AFX_CDECL MakeLineCol | ( | int | nParamLine,
 |  | int | nParamCol )
 static

Constructs an XTP_EDIT_LINECOL object from a pair of coordinates (line and column).

Parameters
nParamLine | [in] Line identifier.
nParamCol | [in] Column identifier.
Returns
Constructs an XTP_EDIT_LINECOL object

◆ max2()

static const XTP_EDIT_LINECOL AFX_CDECL max2 | ( | const XTP_EDIT_LINECOL & | pos1,
 |  | const XTP_EDIT_LINECOL & | pos2 )
 static

Gets a minimum/maximum of two XTP_EDIT_LINECOL values.

Parameters
pos1 | [in] Reference to the first value.
pos2 | [in] Reference to the second value.
Returns
maximum of two XTP_EDIT_LINECOL values

◆ min2()

static const XTP_EDIT_LINECOL AFX_CDECL min2 | ( | const XTP_EDIT_LINECOL & | pos1,
 |  | const XTP_EDIT_LINECOL & | pos2 )
 static

Gets a minimum/maximum of two XTP_EDIT_LINECOL values.

Parameters
pos1 | [in] Reference to the first value.
pos2 | [in] Reference to the second value.
Returns
minimum of two XTP_EDIT_LINECOL values

◆ operator!=()

BOOL operator!= ( const XTP_EDIT_LINECOL & pos2 ) const
inline

Not Equal operator.

Compares a specified struct with the current struct.

Parameters
pos2 [in] Reference to the struct to compare with the current struct.
Returns
TRUE if the current struct is not equal to the specified struct, otherwise FALSE.

◆ operator<()

BOOL operator< ( const XTP_EDIT_LINECOL & pos2 ) const

Less than operator.

Compares a specified struct with the current struct.

Parameters
pos2 [in] Reference to the struct to compare with the current struct.
Returns
TRUE if the current struct is less than the specified struct, otherwise FALSE.

◆ operator<=()

BOOL operator<= ( const XTP_EDIT_LINECOL & pos2 ) const

Less than or equal operator.

Compares a specified struct with the current struct.

Parameters
pos2 [in] Reference to the struct to compare with the current struct.
Returns
TRUE if the current struct is less than or equal to the specified struct, otherwise FALSE.

◆ operator==()

BOOL operator== ( const XTP_EDIT_LINECOL & pos2 ) const

Equal operator.

Compares a specified struct with the current struct.

Parameters
pos2 [in] Reference to the struct to compare with the current struct.
Returns
TRUE if the current struct is equal to the specified struct, otherwise FALSE.

◆ operator>()

BOOL operator> ( const XTP_EDIT_LINECOL & pos2 ) const

Greater than operator.

Compares a specified struct with the current struct.

Parameters
pos2 [in] Reference to the struct to compare with the current struct.
Returns
TRUE if the current struct is greater than the specified struct, otherwise FALSE.

◆ operator>=()

BOOL operator>= ( const XTP_EDIT_LINECOL & pos2 ) const

Greater or equal operator.

Compares a specified struct with the current struct.

Parameters
pos2 [in] Reference to the struct to compare with the current struct.
Returns
TRUE if the current struct is greater than or equal to the specified struct, otherwise FALSE.
The documentation for this struct was generated from the following file:
  • XTPSyntaxEditStruct.h


Toolkit Pro: XTP_EDIT_NMHDR_DOCMODIFIED Struct Reference

Public Attributes | List of all members
XTP_EDIT_NMHDR_DOCMODIFIED Struct Reference

Document notification structure. More...

Public Attributes

NMHDR | nmhdr
First param should be NMHDR.
BOOL | bModified
TRUE if the document was modified.

Detailed Description

Document notification structure.

Provided as LPARAM with WM_NOTIFY. This is used to notify of a change in the document's modified state.

The documentation for this struct was generated from the following file:
  • XTPSyntaxEditStruct.h


Toolkit Pro: XTP_EDIT_NMHDR_EDITCHANGED Struct Reference

Public Attributes | List of all members
XTP_EDIT_NMHDR_EDITCHANGED Struct Reference

Structure to notify "Edit changed" event. More...

Public Attributes

NMHDR | nmhdr
First param should be NMHDR.
int | nRowFrom
The start row for the action.
int | nRowTo
The end row for the action.
int | nAction
The actual action.

Detailed Description

Structure to notify "Edit changed" event.

The documentation for this struct was generated from the following file:
  • XTPSyntaxEditStruct.h


Toolkit Pro: XTP_EDIT_NMHDR_ENABLESCROLLBAR Struct Reference

Public Attributes | List of all members
XTP_EDIT_NMHDR_ENABLESCROLLBAR Struct Reference

Structure to notify XTP_EDIT_NM_ENABLESCROLLBAR event. More...

Public Attributes

NMHDR | nmhdr
First param should be NMHDR.
DWORD | dwScrollBar
Define the scroll bar(s) to change state as WS_HSCROLL and WS_VSCROLL flags.
DWORD | dwState
Define the scroll bar(s) state as WS_HSCROLL and WS_VSCROLL flags.

Detailed Description

Structure to notify XTP_EDIT_NM_ENABLESCROLLBAR event.

The documentation for this struct was generated from the following file:
  • XTPSyntaxEditStruct.h


Toolkit Pro: XTP_EDIT_NMHDR_MARGINCLICKED Struct Reference

Public Attributes | List of all members
XTP_EDIT_NMHDR_MARGINCLICKED Struct Reference

Structure to notify XTP_EDIT_NM_MARGINCLICKED event. More...

Public Attributes

NMHDR | nmhdr
First param should be NMHDR.
int | nRow
Document row number.
int | nDispRow
Visible row number (start from 1).

Detailed Description

Structure to notify XTP_EDIT_NM_MARGINCLICKED event.

The documentation for this struct was generated from the following file:
  • XTPSyntaxEditStruct.h


Toolkit Pro: XTP_EDIT_NMHDR_PARSEEVENT Struct Reference

Public Attributes | List of all members
XTP_EDIT_NMHDR_PARSEEVENT Struct Reference

Structure to notify XTP_EDIT_NM_PARSEEVENT event. More...

Public Attributes

NMHDR | nmhdr
First param should be NMHDR.
DWORD | code
Parser event.
WPARAM | wParam
First event parameter.
LPARAM | lParam
Second event parameter.

Detailed Description

Structure to notify XTP_EDIT_NM_PARSEEVENT event.

Member Data Documentation

◆ code

DWORD code

Parser event.

A value from the XTPSyntaxEditOnParseEvent enum.

The documentation for this struct was generated from the following file:
  • XTPSyntaxEditStruct.h


Toolkit Pro: XTP_EDIT_NMHDR_ROWCOLCHANGED Struct Reference

Public Attributes | List of all members
XTP_EDIT_NMHDR_ROWCOLCHANGED Struct Reference

Row column notification structure. More...

Public Attributes

NMHDR | nmhdr
First param should be NMHDR.
int | nRow
Current document row.
int | nCol
Current document column.

Detailed Description

Row column notification structure.

Provided as LPARAM with WM_NOTIFY. This is used to display the current row and column.

The documentation for this struct was generated from the following file:
  • XTPSyntaxEditStruct.h


Toolkit Pro: XTP_EDIT_NMHDR_SETSCROLLPOS Struct Reference

Public Attributes | List of all members
XTP_EDIT_NMHDR_SETSCROLLPOS Struct Reference

Structure to notify XTP_EDIT_NM_UPDATESCROLLPOS event. More...

Public Attributes

NMHDR | nmhdr
First param should be NMHDR.
DWORD | dwUpdate
Scroll position update flags can be any combination of XTP_EDIT_UPDATE_HORZ, XTP_EDIT_UPDATE_VERT or XTP_EDIT_UPDATE_DIAG.

Detailed Description

Structure to notify XTP_EDIT_NM_UPDATESCROLLPOS event.

The documentation for this struct was generated from the following file:
  • XTPSyntaxEditStruct.h


Toolkit Pro: XTP_EDIT_ROWCOLRECT Struct Reference

Public Attributes | List of all members
XTP_EDIT_ROWCOLRECT Struct Reference

The XTP_EDIT_ROWCOLRECT structure is used to define a row and column selection rectangle. More...

Public Attributes

int | nRow1
First row index for a text block.
int | nCol1
First column index for a text block.
int | nRow2
Last row index for a text block.
int | nCol2
Last column index for a text block.

Detailed Description

The XTP_EDIT_ROWCOLRECT structure is used to define a row and column selection rectangle.

The documentation for this struct was generated from the following file:
  • XTPSyntaxEditStruct.h


Toolkit Pro: XTP_EDIT_ROWSBLOCK Struct Reference

Public Attributes | List of all members
XTP_EDIT_ROWSBLOCK Struct Reference

XTP_EDIT_ROWSBLOCK structure. More...

Public Attributes

XTP_EDIT_LINECOL | lcStart
Start position.
XTP_EDIT_LINECOL | lcEnd
End Position.
CString | strCollapsedText
Collapsed text.

Detailed Description

XTP_EDIT_ROWSBLOCK structure.

The documentation for this struct was generated from the following file:
  • XTPSyntaxEditStruct.h


Toolkit Pro: XTP_EDIT_SENMBOOKMARK Struct Reference

Public Attributes | List of all members
XTP_EDIT_SENMBOOKMARK Struct Reference

Bookmark notification structure. More...

Public Attributes

NMHDR | nmhdr
First param should be NMHDR.
HDC | hDC
HDC for drawing.
RECT | rcBookmark
RECT for bookmark.
int | nRow
The row number.

Detailed Description

Bookmark notification structure.

Provided as LPARAM with WM_NOTIFY while bookmarks must be drawn.

The documentation for this struct was generated from the following file:
  • XTPSyntaxEditStruct.h


Toolkit Pro: XTP_EDIT_TEXTBLOCK Struct Reference

Public Member Functions | Public Attributes | List of all members
XTP_EDIT_TEXTBLOCK Struct Reference

Summary The XTP_EDIT_TEXTBLOCK structure stores the text blocks after parsing. More...

Public Member Functions

XTP_EDIT_TEXTBLOCK ()
Default constructor.

Public Attributes

int | nPos
Position.
int | nNextBlockPos
Position for the next block.
XTP_EDIT_COLORVALUES | clrBlock
Color for this block.
XTP_EDIT_FONTOPTIONS | lf
Font options for this block.

Detailed Description

Summary The XTP_EDIT_TEXTBLOCK structure stores the text blocks after parsing.

The documentation for this struct was generated from the following file:
  • XTPSyntaxEditStruct.h


Toolkit Pro: XTP_EVENT_DRAG_OPERATION_PARAMS Struct Reference

Public Attributes | List of all members
XTP_EVENT_DRAG_OPERATION_PARAMS Struct Reference

This structure is used with notifications for custom edit event notifications when eOperation is xtpCalendarEO_DragXXX. More...

Inheritance diagram for XTP_EVENT_DRAG_OPERATION_PARAMS:
[legend]

Public Attributes

CXTPCalendarEvent * | pDraggingEventOriginal
A pointer to original dragging event.
CXTPCalendarEvent * | pDraggingEvent
A pointer to event before dragging operation.
CXTPCalendarEvent * | pDraggingEventNew
A pointer to event after dragging operation.
- Public Attributes inherited from XTP_EVENT_EDIT_OPERATION_PARAMS
XTPCalendarEditOperation | eOperation
Edit operation.
CXTPCalendarViewEvents * | pEventViews
Event views array with events set for edit operation.
int | nRefCounter
Reserved.

Detailed Description

This structure is used with notifications for custom edit event notifications when eOperation is xtpCalendarEO_DragXXX.

Used only with XTP_NC_CALENDAR_IS_EVENT_EDIT_OPERATION_DISABLED notification.

See also
XTPCalendarEditOperation
XTP_NC_CALENDAR_BEFORE_EVENT_EDIT_OPERATION
XTP_EVENT_EDIT_OPERATION_PARAMS
The documentation for this struct was generated from the following file:
  • XTPCalendarNotifications.h


Toolkit Pro: XTP_EVENT_EDIT_OPERATION_PARAMS Struct Reference

Public Attributes | List of all members
XTP_EVENT_EDIT_OPERATION_PARAMS Struct Reference

This structure is used as a generic and base class for custom edit event notifications. More...

Inheritance diagram for XTP_EVENT_EDIT_OPERATION_PARAMS:
[legend]

Public Attributes

XTPCalendarEditOperation | eOperation
Edit operation.
CXTPCalendarViewEvents * | pEventViews
Event views array with events set for edit operation.
int | nRefCounter
Reserved.

Detailed Description

This structure is used as a generic and base class for custom edit event notifications.

See also
XTPCalendarEditOperation
XTP_NC_CALENDAR_IS_EVENT_EDIT_OPERATION_DISABLED
XTP_NC_CALENDAR_BEFORE_EVENT_EDIT_OPERATION
XTP_EVENT_PASTE_OPERATION_PARAMS
XTP_EVENT_IN_PLACE_CREATE_EVENT_OPERATION_PARAMS

Member Data Documentation

◆ nRefCounter

int nRefCounter

Reserved.

For internal use only.

The documentation for this struct was generated from the following file:
  • XTPCalendarNotifications.h


Toolkit Pro: XTP_EVENT_IN_PLACE_CREATE_EVENT_OPERATION_PARAMS Struct Reference

Public Attributes | List of all members
XTP_EVENT_IN_PLACE_CREATE_EVENT_OPERATION_PARAMS Struct Reference

This structure is used with notifications for custom edit event notifications when eOperation is xtpCalendarEO_InPlaceCreateEvent. More...

Inheritance diagram for XTP_EVENT_IN_PLACE_CREATE_EVENT_OPERATION_PARAMS:
[legend]

Public Attributes

LPCTSTR | pcszInitialSubject
A pointer to the string which contains initial subject value for new event (generally initial char).
- Public Attributes inherited from XTP_EVENT_EDIT_OPERATION_PARAMS
XTPCalendarEditOperation | eOperation
Edit operation.
CXTPCalendarViewEvents * | pEventViews
Event views array with events set for edit operation.
int | nRefCounter
Reserved.

Detailed Description

This structure is used with notifications for custom edit event notifications when eOperation is xtpCalendarEO_InPlaceCreateEvent.

See also
XTPCalendarEditOperation
XTP_NC_CALENDAR_IS_EVENT_EDIT_OPERATION_DISABLED
XTP_NC_CALENDAR_BEFORE_EVENT_EDIT_OPERATION
XTP_EVENT_EDIT_OPERATION_PARAMS
The documentation for this struct was generated from the following file:
  • XTPCalendarNotifications.h


Toolkit Pro: XTP_EVENT_PASTE_OPERATION_PARAMS Struct Reference

Public Attributes | List of all members
XTP_EVENT_PASTE_OPERATION_PARAMS Struct Reference

This structure is used with notifications for custom edit event notifications when eOperation is xtpCalendarEO_Paste. More...

Inheritance diagram for XTP_EVENT_PASTE_OPERATION_PARAMS:
[legend]

Public Attributes

CXTPCalendarEvent * | pEvent
A pointer to an event prepared for paste.
BOOL | bPasteWillChangeExistingEvent
If this member is TRUE, the new event will not be added, just existing event will be updated.
- Public Attributes inherited from XTP_EVENT_EDIT_OPERATION_PARAMS
XTPCalendarEditOperation | eOperation
Edit operation.
CXTPCalendarViewEvents * | pEventViews
Event views array with events set for edit operation.
int | nRefCounter
Reserved.

Detailed Description

This structure is used with notifications for custom edit event notifications when eOperation is xtpCalendarEO_Paste.

See also
XTPCalendarEditOperation
XTP_NC_CALENDAR_IS_EVENT_EDIT_OPERATION_DISABLED
XTP_NC_CALENDAR_BEFORE_EVENT_EDIT_OPERATION
XTP_EVENT_EDIT_OPERATION_PARAMS

Member Data Documentation

◆ bPasteWillChangeExistingEvent

BOOL bPasteWillChangeExistingEvent

If this member is TRUE, the new event will not be added, just existing event will be updated.

Used for creating recurrence event exceptions by cut operation.

The documentation for this struct was generated from the following file:
  • XTPCalendarNotifications.h


Toolkit Pro: XTP_GRIDDATAMANAGER_COM_ERROR Struct Reference

Public Member Functions | Public Attributes | List of all members
XTP_GRIDDATAMANAGER_COM_ERROR Struct Reference

Basic set of parameters transferred to item handlers. More...

Public Member Functions

XTP_GRIDDATAMANAGER_COM_ERROR ()
Performs default error object construction.
const XTP_GRIDDATAMANAGER_COM_ERROR & operator= (const XTP_GRIDDATAMANAGER_COM_ERROR &errorSrc)
Overloaded assignment operator.

Public Attributes

HRESULT | hResult
The HRESULT error value.
CString | strMessage
The error message.
CString | strSource
The error source.

Detailed Description

Basic set of parameters transferred to item handlers.

This structure groups together essential parameters used in item processing activities. It is the parent for all other structures: XTP_GRIDRECORDITEM_DRAWARGS, XTP_GRIDRECORDITEM_CLICKARGS, etc.

Example:

XTP_GRIDRECORDITEM_ARGS itemArgs(pControl, pRow, pColumn);
pItem->OnBeginEdit(&itemArgs);
See also
CXTPGridRecordItem::OnBeginEdit

Member Function Documentation

◆ operator=()

const XTP_GRIDDATAMANAGER_COM_ERROR & operator= ( const XTP_GRIDDATAMANAGER_COM_ERROR & errorSrc )
inline

Overloaded assignment operator.

Copies data values from a source error object.

Parameters
errorSrc A source error object.
Returns
Self reference.
The documentation for this struct was generated from the following file:
  • XTPGridDataManager.h


Toolkit Pro: XTP_GRIDRECORDITEM_ARGS Struct Reference

Public Attributes | List of all members
XTP_GRIDRECORDITEM_ARGS Struct Reference

Basic set of parameters transferred to item handlers. More...

Inheritance diagram for XTP_GRIDRECORDITEM_ARGS:
[legend]

Public Attributes

CXTPGridControl * | pControl
Pointer to the main Grid control.
CXTPGridRow * | pRow
Pointer to the associated row.
CXTPGridColumn * | pColumn
Grid column at click position, if any, NULL otherwise.
CXTPGridRecordItem * | pItem
Pointer to the associated item.
CRect | rcItem
Item position in control client coordinates.

Detailed Description

Basic set of parameters transferred to item handlers.

This structure groups together essential parameters used in item processing activities. It is the parent for all other structures: XTP_GRIDRECORDITEM_DRAWARGS, XTP_GRIDRECORDITEM_CLICKARGS, etc.

Example:

XTP_GRIDRECORDITEM_ARGS itemArgs(pControl, pRow, pColumn);
pItem->OnBeginEdit(&itemArgs);
See also
CXTPGridRecordItem::OnBeginEdit
The documentation for this struct was generated from the following file:
  • XTPGridRecordItem.h


Toolkit Pro: XTP_GRIDRECORDITEM_CLICKARGS Struct Reference

Public Attributes | List of all members
XTP_GRIDRECORDITEM_CLICKARGS Struct Reference

A set of parameters transferred to mouse click item handlers. More...

Inheritance diagram for XTP_GRIDRECORDITEM_CLICKARGS:
[legend]

Public Attributes

CPoint | ptClient
Coordinates of the mouse click point.
- Public Attributes inherited from XTP_GRIDRECORDITEM_ARGS
CXTPGridControl * | pControl
Pointer to the main Grid control.
CXTPGridRow * | pRow
Pointer to the associated row.
CXTPGridColumn * | pColumn
Grid column at click position, if any, NULL otherwise.
CXTPGridRecordItem * | pItem
Pointer to the associated item.
CRect | rcItem
Item position in control client coordinates.

Detailed Description

A set of parameters transferred to mouse click item handlers.

It inherits essential parameters from XTP_GRIDRECORDITEM_ARGS.

XTP_GRIDRECORDITEM_CLICKARGS is used in most functions involved in mouse event processing.

See also
CXTPGridControl, CXTPGridRecordItem::OnClick
The documentation for this struct was generated from the following file:
  • XTPGridRecordItem.h


Toolkit Pro: XTP_GRIDRECORDITEM_DRAWARGS Struct Reference

Public Attributes | List of all members
XTP_GRIDRECORDITEM_DRAWARGS Struct Reference

A set of parameters transferred to the Draw item handler. More...

Inheritance diagram for XTP_GRIDRECORDITEM_DRAWARGS:
[legend]

Public Attributes

CDC * | pDC
Pointer to control drawing context.
int | nTextAlign
Text alignment mode (DT_LEFT || DT_RIGHT || DT_CENTER).
- Public Attributes inherited from XTP_GRIDRECORDITEM_ARGS
CXTPGridControl * | pControl
Pointer to the main Grid control.
CXTPGridRow * | pRow
Pointer to the associated row.
CXTPGridColumn * | pColumn
Grid column at click position, if any, NULL otherwise.
CXTPGridRecordItem * | pItem
Pointer to the associated item.
CRect | rcItem
Item position in control client coordinates.

Detailed Description

A set of parameters transferred to the Draw item handler.

It inherits essential parameters from XTP_GRIDRECORDITEM_ARGS.

This structure is used in almost all functions concerning drawing activities.

Example:

// fill structure
XTP_GRIDRECORDITEM_DRAWARGS drawArgs;
drawArgs.pDC = pDC;
drawArgs.pControl = m_pControl;
drawArgs.pRow = pRow;
// call function
pItem->Draw(&drawArgs);
See also
CXTPGridPaintManager
The documentation for this struct was generated from the following file:
  • XTPGridRecordItem.h


Toolkit Pro: XTP_GRIDRECORDITEM_METRICS Struct Reference

Public Attributes | List of all members
XTP_GRIDRECORDITEM_METRICS Struct Reference

Record item drawing metrics. More...

Inheritance diagram for XTP_GRIDRECORDITEM_METRICS:
[legend]

Public Attributes

CFont * | pFont
Drawing font.
COLORREF | clrForeground
Item foreground color.
COLORREF | clrBackground
Item background color.
CString | strText
Item text.
int | nGroupRowIcon
Group row icon ID.
int | nGroupRowIconAlignment
Group row icon alignment.
int | nColumnAlignment
Column alignment.
int | nItemIcon
Item icon ID.
int | nVirtRowLevel
Virtual row level.
int | nVirtRowFlags
Virtual row flags.

Additional Inherited Members

- Public Member Functions inherited from CXTPCmdTarget
CXTPCmdTarget ()
Constructs command target instance.
- Static Public Member Functions inherited from CXTPCmdTarget
static CCmdTarget *AFX_CDECL FromIDispatchSafe (IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.

Detailed Description

Record item drawing metrics.

Its helper structures group together parameters to store general drawing metrics.

Member Data Documentation

◆ nColumnAlignment

int nColumnAlignment

Column alignment.

See XTPGridColumnIconAlignment.

◆ nGroupRowIcon

int nGroupRowIcon

Group row icon ID.

See CXTPGridControl::GetImageManager().

◆ nGroupRowIconAlignment

int nGroupRowIconAlignment

Group row icon alignment.

See XTPEnumGroupRowIconAlignment.

◆ nItemIcon

int nItemIcon

Item icon ID.

See CXTPGridControl::GetImageManager().

The documentation for this struct was generated from the following file:
  • XTPGridRecordItem.h


Toolkit Pro: XTP_IMAGERESOURCE_INFO Struct Reference

Public Attributes | List of all members
XTP_IMAGERESOURCE_INFO Struct Reference

This structure is used to define the position and style of the icon in resources. More...

Public Attributes

BOOL | bAlpha
TRUE if the icon has alpha layer, otherwise m_hbmpMask used to draw its mask.
CRect | rc
Position of the icon inside resources' m_hbmpImage bitmap.
CXTPImageManagerResource * | pResource
Pointer to owner resources.

Detailed Description

This structure is used to define the position and style of the icon in resources.

The documentation for this struct was generated from the following file:
  • XTPImageManager.h


Toolkit Pro: XTP_LC_TIMEFORMAT Struct Reference

List of all members
XTP_LC_TIMEFORMAT Struct Reference

Time format structure. More...

Detailed Description

Time format structure.

Time values for timescale will be formatted using this parameter.

The documentation for this struct was generated from the following file:
  • XTPCalendarDayViewTimeScale.h


Toolkit Pro: XTP_LVITEMDATA Struct Reference

Public Attributes | List of all members
XTP_LVITEMDATA Struct Reference

The XTP_LVITEMDATA structure is used to maintain information for a particular list item in a CXTPShellListCtrl or CXTPShellListView window. More...

Public Attributes

ULONG | ulAttribs
Shell item attributes.
LPITEMIDLIST | lpi
Pointer to an item ID list.
LPSHELLFOLDER | lpsfParent
Pointer to the parent shell folder item.

Detailed Description

The XTP_LVITEMDATA structure is used to maintain information for a particular list item in a CXTPShellListCtrl or CXTPShellListView window.

See also
CXTPShellListCtrl, CXTPShellListView
The documentation for this struct was generated from the following file:
  • XTPShellPidl.h


Toolkit Pro: XTP_NC_DATEPICKER_BUTTON Struct Reference

Public Attributes | List of all members
XTP_NC_DATEPICKER_BUTTON Struct Reference

Structure used to send button notification messages. More...

Public Attributes

NMHDR | hdr
Contains information about a notification message.
int | nID
Date picker button ID (could be XTP_IDS_DATEPICKER_TODAY or XTP_IDS_DATEPICKER_NONE)

Detailed Description

Structure used to send button notification messages.

This structure represents a set of parameters which are sent to the Main window in a WM_NOTIFY message from DatePicker control and notify the main window when a button event occurs.

The documentation for this struct was generated from the following file:
  • XTPDatePickerControl.h


Toolkit Pro: XTP_NM_FLOWGRAPH_CONNECTIONCHANGED Struct Reference

Public Attributes | List of all members
XTP_NM_FLOWGRAPH_CONNECTIONCHANGED Struct Reference

Information about the connection that has changed. More...

Public Attributes

NMHDR | hdr
Standard structure containing information about a notification message.
CXTPFlowGraphConnection * | pConnection
Connection.
int | nAction
0 - Added, 1 - Removed.

Detailed Description

Information about the connection that has changed.

The documentation for this struct was generated from the following file:
  • XTPFlowGraphMessages.h


Toolkit Pro: XTP_NM_FLOWGRAPH_CONNECTIONCHANGING Struct Reference

Public Attributes | List of all members
XTP_NM_FLOWGRAPH_CONNECTIONCHANGING Struct Reference

Information about the connection that is currently changing. More...

Public Attributes

NMHDR | hdr
Standard structure containing information about a notification message.
CXTPFlowGraphConnection * | pConnection
Connection.
CXTPFlowGraphConnectionPoint * | pInputConnectionPoint
Connection point.

Detailed Description

Information about the connection that is currently changing.

The documentation for this struct was generated from the following file:
  • XTPFlowGraphMessages.h


Toolkit Pro: XTP_NM_FLOWGRAPH_ENDLABELEDIT Struct Reference

Public Attributes | List of all members
XTP_NM_FLOWGRAPH_ENDLABELEDIT Struct Reference

Information about the label whose editing has ended. More...

Public Attributes

NMHDR | hdr
Standard structure containing information about a notification message.
CXTPFlowGraphElement * | pItem
Item whose caption will be changed.
CString | strNewString
New caption for the item.

Detailed Description

Information about the label whose editing has ended.

The documentation for this struct was generated from the following file:
  • XTPFlowGraphMessages.h


Toolkit Pro: XTP_NM_FLOWGRAPH_NODECHANGED Struct Reference

Public Attributes | List of all members
XTP_NM_FLOWGRAPH_NODECHANGED Struct Reference

Information about the node that has changed. More...

Public Attributes

NMHDR | hdr
Standard structure containing information about a notification message.
CXTPFlowGraphNode * | pNode
Node.

Detailed Description

Information about the node that has changed.

The documentation for this struct was generated from the following file:
  • XTPFlowGraphMessages.h


Toolkit Pro: XTP_NM_GRID_BEFORE_COPYPASTE Struct Reference

Public Attributes | List of all members
XTP_NM_GRID_BEFORE_COPYPASTE Struct Reference

This structure is sent to the Main window in a WM_NOTIFY message from Item and provides all parameters required by the Main window to process control specific notifications. More...

Public Attributes

NMHDR | hdr
Standard structure; contains information about a notification message.
CXTPGridRecord ** | ppRecord
[in/out] A pointer to a record pointer.
CStringArray * | parStrings
[in/out] A pointer to a strings array with record items values.

Detailed Description

This structure is sent to the Main window in a WM_NOTIFY message from Item and provides all parameters required by the Main window to process control specific notifications.

It is sent before clipboard Copy/Paste operations.

See also
XTP_NM_GRID_BEFORE_COPY_TOTEXT, XTP_NM_GRID_BEFORE_PASTE_FROMTEXT, XTP_NM_GRID_BEFORE_PASTE, CXTPGridControl::OnBeforeCopyToText(), CXTPGridControl::OnBeforePasteFromText(), CXTPGridControl::OnBeforePaste().
The documentation for this struct was generated from the following file:
  • XTPGridRecordItem.h


Toolkit Pro: XTP_NM_GRIDCOLUMNORDERCHANGED Struct Reference

Public Attributes | List of all members
XTP_NM_GRIDCOLUMNORDERCHANGED Struct Reference

This structure is sent to the main window in a WM_NOTIFY message after columns order or group order is changed. More...

Public Attributes

NMHDR | hdr
Standard structure, containing information about a notification message.
CXTPGridColumn * | pColumn
Affected column.
int | nReason
Change reason.

Detailed Description

This structure is sent to the main window in a WM_NOTIFY message after columns order or group order is changed.

See also
CXTPGridHeader::OnColumnsChanged, XTP_NM_GRID_COLUMNORDERCHANGED, XTP_NM_GRID_GROUPORDERCHANGED.
The documentation for this struct was generated from the following file:
  • XTPGridHeader.h


Toolkit Pro: XTP_NM_GRIDCOLUMNRESIZE Struct Reference

Public Attributes | List of all members
XTP_NM_GRIDCOLUMNRESIZE Struct Reference

This structure is sent to the main window in a WM_NOTIFY message after a column is resized. More...

Public Attributes

NMHDR | hdr
Standard structure, containing information about a notification message.
CXTPGridColumn * | pColumn
Resized column.
int | nPrevWidth
Previous width.
int | nNewWidth
New width.

Detailed Description

This structure is sent to the main window in a WM_NOTIFY message after a column is resized.

See also
CXTPGridHeader::ResizeColumn, CXTPGridHeader::AdjustColumnsWidth, XTP_NM_GRID_COLUMNWIDTHCHANGED.
The documentation for this struct was generated from the following file:
  • XTPGridHeader.h


Toolkit Pro: XTP_NM_GRIDCONSTRAINTSELECTING Struct Reference

Public Attributes | List of all members
XTP_NM_GRIDCONSTRAINTSELECTING Struct Reference

This structure is sent to the Main window in a WM_NOTIFY message from Item and provides all parameters required by the Main window to process control specific notifications. More...

Inheritance diagram for XTP_NM_GRIDCONSTRAINTSELECTING:
[legend]

Public Attributes

CXTPGridRecordItemConstraint * | pConstraint
Pointer to the constraint associated with the.
- Public Attributes inherited from XTP_NM_GRIDRECORDITEM
NMHDR | hdr
Standard structure; contains information about a notification message.
CXTPGridRow * | pRow
Pointer to the row associated with the notification.
CXTPGridRecordItem * | pItem
Pointer to the record item associated with the notification.
CXTPGridColumn * | pColumn
Pointer to the column associated with the notification.
int | nHyperlink
Index of clicked Hyperlink, if any, or -1 otherwise.
POINT | pt
Point where the message ocurred.

Detailed Description

This structure is sent to the Main window in a WM_NOTIFY message from Item and provides all parameters required by the Main window to process control specific notifications.

Use this structure to notify about constraint changing.

See also
XTP_NM_GRIDCONSTRAINTSELECTING
The documentation for this struct was generated from the following file:
  • XTPGridRecordItem.h


Toolkit Pro: XTP_NM_GRIDDRAGDROP Struct Reference

Public Attributes | List of all members
XTP_NM_GRIDDRAGDROP Struct Reference

This structure is sent to the Main window in a WM_NOTIFY message from Grid Control to determine if records are dragged or dropped. More...

Public Attributes

NMHDR | hdr
Standard structure; contains information about a notification message.
CXTPGridRecords * | pRecords
Records will be dragged/dropped.
CXTPGridRecord * | pTargetRecord
Target record (if any).
int | nTargetRow
Index of target row.
BOOL | bAbove
Where to insert (relative to the target record).
DROPEFFECT | dropEffect
DropEffect flags.
CPoint | pt
Current location of the cursor in client coordinates.
int | nState
Transition state (0 - enter, 1 - leave, 2 - over).
DWORD | dwKeyState
Key state.
COleDataSource * | pDataSource
Data Source - issue 22675.
COleDataObject * | pDataObject
Data Object - required for drag over and drop.
BOOL | bReturnValue
TRUE to accept dropEffect, FALSE to not accept dropEffect.

Detailed Description

This structure is sent to the Main window in a WM_NOTIFY message from Grid Control to determine if records are dragged or dropped.

Example:

BEGIN_MESSAGE_MAP(CGridSampleView, CXTPGridView)
ON_NOTIFY(XTP_NM_GRID_BEGINDRAG, XTP_ID_GRID_CONTROL, OnGridBeginDrag)
END_MESSAGE_MAP()

void CGridSampleView::OnGridBeginDrag(NMHDR*  pNotifyStruct, LRESULT* result)
{
   XTP_NM_GRIDDRAGDROP* pItemNotify = (XTP_NM_GRIDDRAGDROP*)pNotifyStruct;

   _ASSERTE(pItemNotify->pRecords);
}
See also
XTP_NM_GRID_DROP, XTP_NM_GRID_BEGINDRAG, CXTPGridControl::EnableDragDrop
The documentation for this struct was generated from the following file:
  • XTPGridControl.h


Toolkit Pro: XTP_NM_GRIDGIVEFEEDBACK Struct Reference

List of all members
XTP_NM_GRIDGIVEFEEDBACK Struct Reference

NM_GRIDGIVEFEEDBACK notification data. More...

Detailed Description

NM_GRIDGIVEFEEDBACK notification data.

The documentation for this struct was generated from the following file:
  • XTPGridHeader.h


Toolkit Pro: XTP_NM_GRIDINPLACEBUTTON Struct Reference

Public Attributes | List of all members
XTP_NM_GRIDINPLACEBUTTON Struct Reference

This structure is sent to the Main window in a WM_NOTIFY message from Item and provides all parameters required by the Main window to process control specific notifications. More...

Inheritance diagram for XTP_NM_GRIDINPLACEBUTTON:
[legend]

Public Attributes

CXTPGridInplaceButton * | pButton
Pointer to in-place button.
- Public Attributes inherited from XTP_NM_GRIDRECORDITEM
NMHDR | hdr
Standard structure; contains information about a notification message.
CXTPGridRow * | pRow
Pointer to the row associated with the notification.
CXTPGridRecordItem * | pItem
Pointer to the record item associated with the notification.
CXTPGridColumn * | pColumn
Pointer to the column associated with the notification.
int | nHyperlink
Index of clicked Hyperlink, if any, or -1 otherwise.
POINT | pt
Point where the message ocurred.

Detailed Description

This structure is sent to the Main window in a WM_NOTIFY message from Item and provides all parameters required by the Main window to process control specific notifications.

Use this structure to get the in-place button which produces the XTP_NM_GRID_INPLACEBUTTONDOWN message.

See also
XTP_NM_GRID_INPLACEBUTTONDOWN
The documentation for this struct was generated from the following file:
  • XTPGridRecordItem.h


Toolkit Pro: XTP_NM_GRIDITEMCONTROL Struct Reference

Public Attributes | List of all members
XTP_NM_GRIDITEMCONTROL Struct Reference

This structure is sent to the Main window in a WM_NOTIFY message from the item control and provides all parameters needed to process control specific notifications by the main window. More...

Inheritance diagram for XTP_NM_GRIDITEMCONTROL:
[legend]

Public Attributes

CXTPGridRecordItemControl * | pItemControl
Pointer to the item control.
- Public Attributes inherited from XTP_NM_GRIDRECORDITEM
NMHDR | hdr
Standard structure; contains information about a notification message.
CXTPGridRow * | pRow
Pointer to the row associated with the notification.
CXTPGridRecordItem * | pItem
Pointer to the record item associated with the notification.
CXTPGridColumn * | pColumn
Pointer to the column associated with the notification.
int | nHyperlink
Index of clicked Hyperlink, if any, or -1 otherwise.
POINT | pt
Point where the message ocurred.

Detailed Description

This structure is sent to the Main window in a WM_NOTIFY message from the item control and provides all parameters needed to process control specific notifications by the main window.

Use this structure to get the item control that produced the message.

See also
XTP_NM_GRID_ITEMBUTTONCLICK
The documentation for this struct was generated from the following file:
  • XTPGridRecordItemControls.h


Toolkit Pro: XTP_NM_GRIDITEMMETRICS Struct Reference

Public Attributes | List of all members
XTP_NM_GRIDITEMMETRICS Struct Reference

This structure is sent to the Main window in a WM_NOTIFY message from Item and provides all parameters required by the Main window to process control specific notifications. More...

Public Attributes

NMHDR | hdr
Standard structure; contains information about a notification message.
XTP_GRIDRECORDITEM_DRAWARGS * | pDrawArgs
Pointer to an XTP_GRIDRECORDITEM_DRAWARGS structure.
XTP_GRIDRECORDITEM_METRICS * | pItemMetrics
Pointer to an XTP_GRIDRECORDITEM_METRICS structure to be filled.

Detailed Description

This structure is sent to the Main window in a WM_NOTIFY message from Item and provides all parameters required by the Main window to process control specific notifications.

Example:

BEGIN_MESSAGE_MAP(CGridSampleView, CXTPGridView)
ON_NOTIFY(XTP_NM_GRID_GETITEMMETRICS, XTP_ID_GRID_CONTROL, OnGridGetItemMetrics)
END_MESSAGE_MAP()

void CGridSampleView::OnGridGetItemMetrics(NMHDR*  pNotifyStruct, LRESULT* result)
{
   XTP_NM_GRIDITEMMETRICS* pItemNotify = (XTP_NM_GRIDITEMMETRICS*)pNotifyStruct;

   _ASSERTE(pItemNotify->pDrawArgs);
   _ASSERTE(pItemNotify->pDrawArgs->pControl);
   _ASSERTE(pItemNotify->pDrawArgs->pRow);

   //     pItemNotify->pDrawArgs->pColumn   - may be NULL (for a group row)
   //     pItemNotify->pDrawArgs->pItem     - may be NULL (for a group row)

   _ASSERTE(pItemNotify->pItemMetrics);

   // NTcustomize members of pItemNotify->pItemMetrics.
}
See also
CXTPGridControl, CXTPGridControl::GetItemMetrics(), XTP_NM_GRID_GETITEMMETRICS
The documentation for this struct was generated from the following file:
  • XTPGridControl.h


Toolkit Pro: XTP_NM_GRIDPREVIEWKEYDOWN Struct Reference

Public Attributes | List of all members
XTP_NM_GRIDPREVIEWKEYDOWN Struct Reference

This structure is sent to the Main window in a WM_NOTIFY message before processing the OnKeyDown event. More...

Public Attributes

NMHDR | hdr
Standard structure; contains information about a notification message.
UINT | nChar
[in/out] Specifies the virtual key code of the given key.
UINT | nRepCnt
[in] Repeat count.
UINT | nFlags
[in] Specifies the scan code, key-transition code, previous key state, and context code.
BOOL | bCancel
[out] TRUE to cancel processing key, FALSE to continue.

Detailed Description

This structure is sent to the Main window in a WM_NOTIFY message before processing the OnKeyDown event.

See also
CXTPGridControl::OnPreviewKeyDown, XTP_NM_GRID_PREVIEWKEYDOWN, CXTPGridControl::OnKeyDown, CWnd::OnKeyDown.

Member Data Documentation

◆ hdr

NMHDR hdr

Standard structure; contains information about a notification message.

OnKeyDown parameters

The documentation for this struct was generated from the following file:
  • XTPGridControl.h


Toolkit Pro: XTP_NM_GRIDRECORDITEM Struct Reference

Public Attributes | List of all members
XTP_NM_GRIDRECORDITEM Struct Reference

This structure is sent to the Main window in a WM_NOTIFY message from Item and provides all parameters required by the Main window to process control specific notifications. More...

Inheritance diagram for XTP_NM_GRIDRECORDITEM:
[legend]

Public Attributes

NMHDR | hdr
Standard structure; contains information about a notification message.
CXTPGridRow * | pRow
Pointer to the row associated with the notification.
CXTPGridRecordItem * | pItem
Pointer to the record item associated with the notification.
CXTPGridColumn * | pColumn
Pointer to the column associated with the notification.
int | nHyperlink
Index of clicked Hyperlink, if any, or -1 otherwise.
POINT | pt
Point where the message ocurred.

Detailed Description

This structure is sent to the Main window in a WM_NOTIFY message from Item and provides all parameters required by the Main window to process control specific notifications.

Example:

BEGIN_MESSAGE_MAP(CPropertiesView, CView)
ON_NOTIFY(XTP_NM_GRID_VALUECHANGED, ID_GRID_CONTROL, OnPropertyChanged)
END_MESSAGE_MAP()

void CPropertiesView::OnPropertyChanged(NMHDR*  pNotifyStruct, LRESULT* result)
{
   XTP_NM_GRIDRECORDITEM* pItemNotify = (XTP_NM_GRIDRECORDITEM*) pNotifyStruct;

   switch (pItemNotify->pItem->GetItemData())
   {
      // Some code.
   }
}
See also
XTP_NM_GRIDINPLACEBUTTON
The documentation for this struct was generated from the following file:
  • XTPGridRecordItem.h


Toolkit Pro: XTP_NM_GRIDREQUESTEDIT Struct Reference

Public Attributes | List of all members
XTP_NM_GRIDREQUESTEDIT Struct Reference

A set of parameters transferred with an XTP_NM_GRID_REQUESTEDIT message. More...

Inheritance diagram for XTP_NM_GRIDREQUESTEDIT:
[legend]

Public Attributes

BOOL | bCancel
TRUE to cancel operation.
- Public Attributes inherited from XTP_NM_GRIDRECORDITEM
NMHDR | hdr
Standard structure; contains information about a notification message.
CXTPGridRow * | pRow
Pointer to the row associated with the notification.
CXTPGridRecordItem * | pItem
Pointer to the record item associated with the notification.
CXTPGridColumn * | pColumn
Pointer to the column associated with the notification.
int | nHyperlink
Index of clicked Hyperlink, if any, or -1 otherwise.
POINT | pt
Point where the message ocurred.

Detailed Description

A set of parameters transferred with an XTP_NM_GRID_REQUESTEDIT message.

XTP_NM_GRIDREQUESTEDIT is used to cancel edit operations.

See also
XTP_NM_GRID_REQUESTEDIT
The documentation for this struct was generated from the following file:
  • XTPGridRecordItem.h


Toolkit Pro: XTP_NM_GRIDROWRESIZE Struct Reference

Public Attributes | List of all members
XTP_NM_GRIDROWRESIZE Struct Reference

This structure is sent to the main window in a WM_NOTIFY message after a row is resized. More...

Public Attributes

NMHDR | hdr
Standard structure, containing information about a notification message.
CXTPGridRow * | pRow
Resized row.
int | nPrevHeight
Previous height.
int | nNewHeight
New height.

Detailed Description

This structure is sent to the main window in a WM_NOTIFY message after a row is resized.

See also
XTP_NM_GRID_ROWHEIGHTCHANGED.
The documentation for this struct was generated from the following file:
  • XTPGridHeader.h


Toolkit Pro: XTP_NM_GRIDSCROLL Struct Reference

Public Attributes | List of all members
XTP_NM_GRIDSCROLL Struct Reference

NM_GRIDSCROLL notification data. More...

Public Attributes

int | nSection
Index of the section.
int | nPosition
New scroll position.

Detailed Description

NM_GRIDSCROLL notification data.

The documentation for this struct was generated from the following file:
  • XTPGridHeader.h


Toolkit Pro: XTP_NM_GRIDSTATECHANGED Struct Reference

Public Attributes | List of all members
XTP_NM_GRIDSTATECHANGED Struct Reference

This structure contains information for use in processing an XTP_NM_GRID_STATECHANGED message. More...

Public Attributes

NMHDR | hdr
Standard structure, containing information.
int | nBegin
Zero-based index of the first item in the range of items.
int | nEnd
Zero-based index of the last item in the range of items.

Detailed Description

This structure contains information for use in processing an XTP_NM_GRID_STATECHANGED message.

The documentation for this struct was generated from the following file:
  • XTPGridRows.h


Toolkit Pro: XTP_NM_GRIDTOOLTIPINFO Struct Reference

Public Attributes | List of all members
XTP_NM_GRIDTOOLTIPINFO Struct Reference

This structure is sent to the Main window in a WM_NOTIFY message from Item and provides all parameters required by the Main window to process control specific notifications. More...

Inheritance diagram for XTP_NM_GRIDTOOLTIPINFO:
[legend]

Public Attributes

CString * | pstrText
Pointer to a CString object with Tooltip text.
- Public Attributes inherited from XTP_NM_GRIDRECORDITEM
NMHDR | hdr
Standard structure; contains information about a notification message.
CXTPGridRow * | pRow
Pointer to the row associated with the notification.
CXTPGridRecordItem * | pItem
Pointer to the record item associated with the notification.
CXTPGridColumn * | pColumn
Pointer to the column associated with the notification.
int | nHyperlink
Index of clicked Hyperlink, if any, or -1 otherwise.
POINT | pt
Point where the message ocurred.

Detailed Description

This structure is sent to the Main window in a WM_NOTIFY message from Item and provides all parameters required by the Main window to process control specific notifications.

Use this structure to notify about tooltip showing.

See also
XTP_NM_GRIDTOOLTIPTEXT
The documentation for this struct was generated from the following file:
  • XTPGridRecordItem.h


Toolkit Pro: XTP_NM_SELECTION_CHANGING Struct Reference

Public Attributes | List of all members
XTP_NM_SELECTION_CHANGING Struct Reference

This struct defines data for an XTP_NM_GRID_SELCHANGING notification. More...

Public Attributes

NMHDR | hdr
Standard structure, containing information about a notification message.
CXTPGridRow * pRow
Pointer to the row associated with the notification.
XTPGridSelectionChangeType | nType
Selection change action.

Detailed Description

This struct defines data for an XTP_NM_GRID_SELCHANGING notification.

See also
XTP_NM_GRID_SELCHANGING, XTP_NM_SELECTION_CHANGING

Member Data Documentation

◆ pRow

CXTPGridRow* pRow

Pointer to the row associated with the notification.

It is NULL for an xtpGridSelectionClear action.

The documentation for this struct was generated from the following file:
  • XTPGridRows.h


Toolkit Pro: XTP_NM_TRACKCONTROL Struct Reference

Public Attributes | List of all members
XTP_NM_TRACKCONTROL Struct Reference

This structure contains notification details. More...

Public Attributes

NMHDR | hdr
The NMHDR instance.
CXTPTrackBlock * | pBlock
The track block.
CXTPTrackMarker * | pMarker
The track marker.

Detailed Description

This structure contains notification details.

The documentation for this struct was generated from the following file:
  • XTPTrackControl.h


Toolkit Pro: XTP_PICK_BUTTON Struct Reference

Public Attributes | List of all members
XTP_PICK_BUTTON Struct Reference

XTP_PICK_BUTTON structure is used by the CXTPColorSelectorCtrl class to support a user-defined color list. More...

Public Attributes

COLORREF | clrButton
An RGB value representing the button color.
UINT | toolTipID
Resource ID for the tooltip for the color button.
TCHAR | szTip [256]
Tooltip string for the color button.

Detailed Description

XTP_PICK_BUTTON structure is used by the CXTPColorSelectorCtrl class to support a user-defined color list.

See also
CXTPColorSelectorCtrl

Member Data Documentation

◆ szTip

TCHAR szTip[256]

Tooltip string for the color button.

If defined, toolTipID must be 0.

The documentation for this struct was generated from the following file:
  • XTPColorSelectorCtrl.h


Toolkit Pro: XTP_PROPERTYGRID_NOTIFYEDIT Struct Reference

Public Attributes | List of all members
XTP_PROPERTYGRID_NOTIFYEDIT Struct Reference

This struct is passed with XTP_PGN_REQUESTEDIT, XTP_PGN_AFTEREDIT, and XTP_PGN_CANCELEDIT notifications to determine the item and its new value. More...

Public Attributes

BOOL | bCancel
TRUE to cancel user edit.
CString | strValue
New caption value to be set.
CXTPPropertyGridItem * | pItem
Item to be edited.

Detailed Description

This struct is passed with XTP_PGN_REQUESTEDIT, XTP_PGN_AFTEREDIT, and XTP_PGN_CANCELEDIT notifications to determine the item and its new value.

See also
XTP_PGN_REQUESTEDIT
The documentation for this struct was generated from the following file:
  • XTPPropertyGridDefines.h


Toolkit Pro: XTP_RESIZEPOINT Struct Reference

Public Attributes | List of all members
XTP_RESIZEPOINT Struct Reference

The XTP_RESIZEPOINT structure is used by the CXTPResizePoint class for defining single-precision floating point x- and y- coordinates of a point. More...

Inheritance diagram for XTP_RESIZEPOINT:
[legend]

Public Attributes

XTP_RESIZE | x
Specifies the x-coordinate of a point.
XTP_RESIZE | y
Specifies the y-coordinate of a point.

Detailed Description

The XTP_RESIZEPOINT structure is used by the CXTPResizePoint class for defining single-precision floating point x- and y- coordinates of a point.

See also
CXTPResizePoint
The documentation for this struct was generated from the following file:
  • XTPResizePoint.h


Toolkit Pro: XTP_RESIZERECT Struct Reference

Public Attributes | List of all members
XTP_RESIZERECT Struct Reference

XTP_RESIZERECT structure is used by the CXTPResizeRect class for defining single-precision floating point coordinates of the upper-left and lower-right corners of a rectangle. More...

Inheritance diagram for XTP_RESIZERECT:
[legend]

Public Attributes

XTP_RESIZE | left
Specifies the x-coordinate of the upper-left corner of a rectangle.
XTP_RESIZE | top
Specifies the y-coordinate of the upper-left corner of a rectangle.
XTP_RESIZE | right
Specifies the x-coordinate of the lower-right corner of a rectangle.
XTP_RESIZE | bottom
Specifies the y-coordinate of the lower-right corner of a rectangle.

Detailed Description

XTP_RESIZERECT structure is used by the CXTPResizeRect class for defining single-precision floating point coordinates of the upper-left and lower-right corners of a rectangle.

Example: The following example demonstrates alternate ways to initialize an XTP_RESIZERECT structure:

XTP_RESIZERECT rc1;
rc1.left = 20;
rc1.top = 30;
rc1.right = 180;
rc1.bottom = 230;

XTP_RESIZERECT rc2 = {20, 30, 180, 230};
See also
CXTPResizeRect, XTP_RESIZE
The documentation for this struct was generated from the following file:
  • XTPResizeRect.h


Toolkit Pro: XTP_RESOURCEMANAGER_LANGINFO Struct Reference

Public Attributes | List of all members
XTP_RESOURCEMANAGER_LANGINFO Struct Reference

Standalone structure used to manage Language Info. More...

Public Attributes

WORD | wLanguage
Language.
UINT | nCodePage
CodePage.
LPCTSTR | lpszEncoding
Encoding.
LPCTSTR | lpszCaption
Caption.
LPCTSTR | lpszLang
Lang.
LPCTSTR | lpszSubLang
SubLang.
BYTE | nFontCharSet
FontCharSet.

Detailed Description

Standalone structure used to manage Language Info.

The documentation for this struct was generated from the following file:
  • XTPResourceManager.h


Toolkit Pro: XTP_SCROLLBAR_POSINFO Struct Reference

Public Attributes | List of all members
XTP_SCROLLBAR_POSINFO Struct Reference

The XTP_SCROLLBAR_POSINFO structure contains scroll bar information. More...

Public Attributes

int | posMin
Minimum position.
int | posMax
Maximum position.
int | page
Page size.
int | pos
Position of thumb.
int | pxTop
Top bounding rectangle.
int | pxBottom
Bottom bounding rectangle.
int | pxLeft
Left bounding rectangle.
int | pxRight
Right bounding rectangle.
int | cpxThumb
Size of thumb button.
int | pxUpArrow
Position of Up arrow.
int | pxDownArrow
Position of Down arrow.
int | pxStart
Previous position of thumb button.
int | pxThumbBottom
Thumb bottom bounding rectangle.
int | pxThumbTop
Thumb top bounding rectangle.
int | pxPopup
In-place scroll position.
int | cpx
position in pixels
int | pxMin
Minimum position in pixels.
RECT | rc
Bounding rectangle.
int | ht
Hit test.
BOOL | fVert
TRUE if vertical.
BOOL | fSizebox
TRUE if is of size-box type, fVert is ignored.

Detailed Description

The XTP_SCROLLBAR_POSINFO structure contains scroll bar information.

The documentation for this struct was generated from the following file:
  • XTPScrollBase.h


Toolkit Pro: XTP_SCROLLBAR_TRACKINFO Struct Reference

Public Attributes | List of all members
XTP_SCROLLBAR_TRACKINFO Struct Reference

The XTP_SCROLLBAR_TRACKINFO structure contains tracking information. More...

Public Attributes

BOOL | fHitOld
Previous hittest.
RECT | rcTrack
Bounding rectangle of available thumb position.
UINT | cmdSB
Scroll command.
UINT_PTR | hTimerSB
Timer identifier.
int | dpxThumb
Delta of thumb button.
int | pxOld
Previous position in pixels.
int | posOld
Previous position.
int | posNew
new position
HWND | hWndTrack
Parent tracking window.
BOOL | bTrackThumb
TRUE if thumb is tracking.
XTP_SCROLLBAR_POSINFO * | pSBInfo
SCROLLBARPOSINFO pointer.

Detailed Description

The XTP_SCROLLBAR_TRACKINFO structure contains tracking information.

The documentation for this struct was generated from the following file:
  • XTPScrollBase.h


Toolkit Pro: XTP_SCROLLBARDRAWCOLORS Struct Reference

Public Attributes | List of all members
XTP_SCROLLBARDRAWCOLORS Struct Reference

Used by paint manager to retrieve the current state color settings when drawing scrollbars. More...

Inheritance diagram for XTP_SCROLLBARDRAWCOLORS:
[legend]

Public Attributes

COLORREF | clrScrollDownBack
Scrollbar down / right button background color.
COLORREF | clrScrollDownArrow
Scrollbar down / right button arrow color.
COLORREF | clrScrollDownBorder
Scrollbar down / right button border color.
- Public Attributes inherited from XTP_SCROLLBARINICOLORS
COLORREF | clrBack
Scrollbar background color.
COLORREF | clrScrollBack
Scrollbar button background color.
COLORREF | clrScrollArrow
Scrollbar button arrow color.
COLORREF | clrScrollBorder
Scrollbar button border color.
COLORREF | clrThumbBack
Scrollbar thumb background color.
COLORREF | clrThumbBorder
Scrollbar thumb border color.

Detailed Description

Used by paint manager to retrieve the current state color settings when drawing scrollbars.

The documentation for this struct was generated from the following file:
  • XTPScrollBarThemeOffice2013.h


Toolkit Pro: XTP_SCROLLBARINICOLORS Struct Reference

Public Attributes | List of all members
XTP_SCROLLBARINICOLORS Struct Reference

Used by paint manager to retrieve color settings from the loaded resource INI file. More...

Inheritance diagram for XTP_SCROLLBARINICOLORS:
[legend]

Public Attributes

COLORREF | clrBack
Scrollbar background color.
COLORREF | clrScrollBack
Scrollbar button background color.
COLORREF | clrScrollArrow
Scrollbar button arrow color.
COLORREF | clrScrollBorder
Scrollbar button border color.
COLORREF | clrThumbBack
Scrollbar thumb background color.
COLORREF | clrThumbBorder
Scrollbar thumb border color.

Detailed Description

Used by paint manager to retrieve color settings from the loaded resource INI file.

The documentation for this struct was generated from the following file:
  • XTPScrollBarThemeOffice2013.h


Toolkit Pro: XTP_SLIDERTICKS Struct Reference

Public Member Functions | Public Attributes | List of all members
XTP_SLIDERTICKS Struct Reference

The XTP_SLIDERTICKS structure contains slider ticks. More...

Public Member Functions

XTP_SLIDERTICKS (double *pTicks, int nCount)
Constructs an XTP_SLIDERTICKS object.
~XTP_SLIDERTICKS ()
Destroys an XTP_SLIDERTICKS object, handles cleanup and deallocation.

Public Attributes

double * | pTicks
Ticks array.
int | nCount
Count of ticks.

Detailed Description

The XTP_SLIDERTICKS structure contains slider ticks.

Constructor & Destructor Documentation

◆ XTP_SLIDERTICKS()

XTP_SLIDERTICKS | ( | double * | pTicks,
 |  | int | nCount )

Constructs an XTP_SLIDERTICKS object.

Parameters
pTicks | Point to double array
nCount | Count of double values
The documentation for this struct was generated from the following file:
  • XTPScrollBase.h


Toolkit Pro: XTP_TAGCLOUDTAG Struct Reference

Public Member Functions | Public Attributes | List of all members
XTP_TAGCLOUDTAG Struct Reference

Manages the attributes for each tag element such as weight, font, background and foreground color. More...

Public Member Functions

XTP_TAGCLOUDTAG (LPCTSTR lpszItem, int nScore)
Default constructor initializes members.

Public Attributes

int | nScore
Style for this tag.
CString | strItem
String value representing the tag text.
CXTPEmptyRect | rcItem
Size and location of the tag.

Detailed Description

Manages the attributes for each tag element such as weight, font, background and foreground color.

Constructor & Destructor Documentation

◆ XTP_TAGCLOUDTAG()

XTP_TAGCLOUDTAG | ( | LPCTSTR | lpszItem,
 |  | int | nScore )
 inline

Default constructor initializes members.

Parameters
lpszItem | Name of the tag cloud item.
nScore | Score of the tag cloud item.
The documentation for this struct was generated from the following file:
  • XTPTagCloudCtrl.h


Toolkit Pro: XTP_TASKPANEL_GROUPCOLORS Struct Reference

Public Attributes | List of all members
XTP_TASKPANEL_GROUPCOLORS Struct Reference

Structure used to store task panel group colorization information for various parts of the group. More...

Public Attributes

CXTPPaintManagerColorGradient | clrHead
Color gradient used for the background color of group headers.
CXTPPaintManagerColorGradient clrClient
Background color of the client area of the group.
CXTPPaintManagerColor clrClientBorder
Color of the client group border.
double | dHeadGradientFactor
Value used to calculate the gradient of the group header.
CXTPPaintManagerColor | clrHeadTextNormal
Color of normal text in the group header.
CXTPPaintManagerColor clrHeadTextHot
Color of "hot" text in the group header.
CXTPPaintManagerColor clrClientText
Color of text within the client or "body" of the group.
CXTPPaintManagerColor clrClientLink
Color of links within the client or "body" of the group.
CXTPPaintManagerColor clrClientLinkHot
Color of "hot" links within the client or "body" of the group.
CXTPPaintManagerColor clrClientLinkSelected
Color of links within the client or "body" of the group.

Detailed Description

Structure used to store task panel group colorization information for various parts of the group.

Example:

m_wndTaskPanel.GetPaintManager()->GetGroupColors(FALSE)->clrClientLink = RGB(0, 0, 255);
See also
CXTPTaskPanelPaintManager::GetGroupColors, CXTPTaskPanelPaintManager::m_groupNormal, CXTPTaskPanelPaintManager::m_groupSpecial

Member Data Documentation

◆ clrClient

CXTPPaintManagerColorGradient clrClient

Background color of the client area of the group.

This is the group area under the group header.

◆ clrClientBorder

CXTPPaintManagerColor clrClientBorder

Color of the client group border.

This is the group area under the group header.

◆ clrClientLink

CXTPPaintManagerColor clrClientLink

Color of links within the client or "body" of the group.

This is the area under the group header.

◆ clrClientLinkHot

CXTPPaintManagerColor clrClientLinkHot

Color of "hot" links within the client or "body" of the group.

This is the color of link text on mouse over.

◆ clrClientLinkSelected

CXTPPaintManagerColor clrClientLinkSelected

Color of links within the client or "body" of the group.

This is the area under the group header.

◆ clrClientText

CXTPPaintManagerColor clrClientText

Color of text within the client or "body" of the group.

This is the area under the group header.

◆ clrHeadTextHot

CXTPPaintManagerColor clrHeadTextHot

Color of "hot" text in the group header.

This is the color of text on mouse over.

◆ dHeadGradientFactor

double dHeadGradientFactor

Value used to calculate the gradient of the group header.

This is used to increase or decrease the color as the backcolor of the header is filled in.

The documentation for this struct was generated from the following file:
  • XTPTaskPanelPaintManager.h


Toolkit Pro: XTP_TPNENDLABELEDIT Struct Reference

Public Attributes | List of all members
XTP_TPNENDLABELEDIT Struct Reference

This structure is passed as a parameter when an XTP_TPN_ENDLABELEDIT event occurs. More...

Public Attributes

CXTPTaskPanelItem * | pItem
Item whose caption is about to be changed.
CString | strNewString
New caption of the item.

Detailed Description

This structure is passed as a parameter when an XTP_TPN_ENDLABELEDIT event occurs.

The documentation for this struct was generated from the following file:
  • XTPTaskPanelDefines.h


Toolkit Pro: XTP_TPNGROUPEXPANDING Struct Reference

Public Attributes | List of all members
XTP_TPNGROUPEXPANDING Struct Reference

This structure is passed as a parameter when an XTP_TPN_GROUPEXPANDING event occurs. More...

Public Attributes

CXTPTaskPanelGroup * | pGroup
Group that is about to be expanded.
BOOL | bExpanding
TRUE if the group must be expanded.

Detailed Description

This structure is passed as a parameter when an XTP_TPN_GROUPEXPANDING event occurs.

The documentation for this struct was generated from the following file:
  • XTPTaskPanelDefines.h


Toolkit Pro: XTP_TVITEMDATA Struct Reference

Public Attributes | List of all members
XTP_TVITEMDATA Struct Reference

The XTP_TVITEMDATA structure is used to maintain information for a particular tree item in a CXTPShellTreeCtrl or CXTPShellTreeView window. More...

Public Attributes

LPITEMIDLIST | lpi
Pointer to an item ID list.
LPITEMIDLIST | lpifq
Pointer to an item ID list.
LPSHELLFOLDER | lpsfParent
Pointer to the parent shell folder item.

Detailed Description

The XTP_TVITEMDATA structure is used to maintain information for a particular tree item in a CXTPShellTreeCtrl or CXTPShellTreeView window.

See also
CXTPShellTreeCtrl, CXTPShellTreeView
The documentation for this struct was generated from the following file:
  • XTPShellPidl.h


Toolkit Pro: XTP_URI Struct Reference

Public Attributes | List of all members
XTP_URI Struct Reference

Parse URI information. More...

Public Attributes

XTPUriType type
URI type.

Detailed Description

Parse URI information.

Member Data Documentation

◆ file

TCHAR file[MAX_PATH+1]

Valid only for xtpUriFile.

Local file full path.

The documentation for this struct was generated from the following file:
  • XTPSystemHelpers.h


Toolkit Pro: XTP_URI_DEFAULTS Struct Reference

List of all members
XTP_URI_DEFAULTS Struct Reference

Default URI values. More...

Detailed Description

Default URI values.

The documentation for this struct was generated from the following file:
  • XTPSystemHelpers.h


Toolkit Pro: XTP_WEEK_VIEW_LAYOUT Struct Reference

Public Attributes | List of all members
XTP_WEEK_VIEW_LAYOUT Struct Reference

This struct store a Week View layout. More...

Public Attributes

int | m_nGridColumns
Number of columns in a week day grid.
int | m_nDayHeaderHeight
Height of a day header.
int | m_nDayWidth
Width of day rectangle.
int | m_nDayHeight
Height of day rectangle.

Detailed Description

This struct store a Week View layout.

The documentation for this struct was generated from the following file:
  • XTPCalendarDefines.h


Toolkit Pro: XTPGridInputState Struct Reference

Public Attributes | List of all members
XTPGridInputState Struct Reference

Stores the mouse and key states. More...

Public Attributes

CPoint | ptMouse
Mouse position.
BOOL | bKeyControl
Control key state.
BOOL | bKeyShift
Shift key state.
int | nRow
Clicked row index.
BOOL | bSelected
Clicked row selection state.

Detailed Description

Stores the mouse and key states.

The documentation for this struct was generated from the following file:
  • XTPGridControl.h


Toolkit Pro: XTPPROGRESSDRAWSTRUCT Struct Reference

Public Attributes | List of all members
XTPPROGRESSDRAWSTRUCT Struct Reference

Struct used by the progress bar during paint operations. More...

Public Attributes

CDC * | pDC
Pointer to a valid device context.
CFont * | pFont
Pointer to the progress bar's CFont object.
CRect | rcClient
Client area of the progress bar.
CString | strText
Window text to be displayed on the progress bar.
CProgressCtrl * | pWndCtrl
Points to the progress control.
PBRANGE | range
High and low limits of a progress bar control.
int | nPos
Position of the progress bar.
BOOL | bVertical
TRUE if the progress bar is vertical, otherwise FALSE.
BOOL | bVista
TRUE if the Windows verison is greater than or equal to Vista.
BOOL | bSmooth
TRUE if the progress bar is drawn smooth.
BOOL | bMarquee
TRUE if this is a Marquee style progress bar.
BOOL | bFlatStyle
TRUE if the progress bar is to be drawn flat (deprecated).

Detailed Description

Struct used by the progress bar during paint operations.

The documentation for this struct was generated from the following file:
  • XTPProgressCtrlPaintManager.h


Toolkit Pro: XTPRIBBON_HEADER_COLOR Struct Reference

Public Attributes | List of all members
XTPRIBBON_HEADER_COLOR Struct Reference

Struct used to define context tab colors for the ribbon control. More...

Public Attributes

COLORREF | clrEdge
An RGB value representing context tab border color.
COLORREF | clrBack
An RGB value representing context tab background color.
COLORREF | clrText
An RGB value representing context tab text color.

Detailed Description

Struct used to define context tab colors for the ribbon control.

The documentation for this struct was generated from the following file:
  • XTPRibbonThemeOffice2013.h


Toolkit Pro: Class Index

Class Index
A | C | D | E | G | H | I | K | L | N | P | R | S | T | X
A
CXTPNotifySinkBase::ADVISE_DESCRIPTOR
C
CAppearanceSetPropertyPage2003
CAppearanceSetPropertyPage2007
CAppearanceSetPropertyPageAccess2007
CAppearanceSetPropertyPageFlat
CAppearanceSetPropertyPageSelected
CAppearanceSetStateButtons
CAppearanceSetVisio
CAppearanceSetVisualStudio2005
CXTPSyntaxEditCtrl::CAverageVal
CXTPSkinObjectFrame::CCaptionButton
CXTPCheckListBox::CCheckListState
CColorSetVisualStudio2003
CColorSetVisualStudio2005
CColorSetWinNative
CXTPDockingPaneWindowSelect::CColumn
CXTPNotifyConnection::CEmptySyncObject
CXTPRWCriticalSection::CExclusiveLock
CXTPDockingPaneWindowSelect::CItem
CXTPSimpleCriticalSection::CLock
CXTPPaintManager::CLogFont
CXTPTreeBase::CLRFONT
CXTPResourceManager::CManageState
CXTPCalendarMonthView::CMonthViewGrid
CXTPColorSelectorCtrl::COLOR_CELL
CXTPTabPaintManagerColorSet::COLORSET_TAB_EXCEL
CXTPTabPaintManagerColorSet::COLORSET_TAB_PROPERTYPAGE
CXTPTabPaintManagerColorSet::COLORSET_TAB_PROPERTYPAGE2003
CXTPTabPaintManagerColorSet::COLORSET_TAB_STATEBUTTON
CXTPNotifyConnection::CONNECTION_DESCRIPTOR
CXTPShortcutListBox::CONTENT_ITEM
CXTPTaskPanel::CRepositionContext
CXTPColorHex::CRgnCell
CXTPTabManager::CRowIndexer
CXTPCalendarView::CSelectionChanged_ContextData
CXTPCalendarView::CSelectionChangedContext
CXTPRWCriticalSection::CSharedLock
CXTPShellPidl::CShellMalloc
CXTPShellPidl::CShellSpecialFolder
CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager::CStringPtrArray
CXTPRibbonOffice2013Theme::CThemeStaticExtension
CXTPMouseManager::CTrackArray
CXTPColorHex::CRgnCell::CTX_DATA
CXTPCalendarControl::CUpdateContext
CXTPGridControl::CUpdateContext
CXTPCalendarControl::CViewChanged_ContextData
CXTPCalendarControl::CViewChangedContext
CXTPActiveScriptEngine
CXTPActiveScriptObjectContext
CXTPActiveScriptStdRuntime
CXTPAlphaWnd
CXTPAnimationDC
CXTPApplication
CXTPArcBall
CXTPArrayT
CXTPAsyncGuard
CXTPAutoResetValue
CXTPAuxData
CXTPBatchAllocObjT
CXTPBrowseButton
CXTPBrowseDialog
CXTPBrowseEdit
CXTPBrush
CXTPButton
CXTPButtonTheme
CXTPButtonThemeFlat
CXTPButtonThemeNativeWindows10
CXTPButtonThemeNativeWindows11
CXTPButtonThemeOffice2000
CXTPButtonThemeOffice2003
CXTPButtonThemeOffice2013
CXTPButtonThemeOfficeXP
CXTPButtonThemeResource
CXTPButtonThemeUltraFlat
CXTPButtonThemeVisualStudio2012
CXTPButtonThemeVisualStudio2015
CXTPButtonThemeVisualStudio2017
CXTPButtonThemeVisualStudio2019
CXTPButtonThemeVisualStudio2022
CXTPCalendarBusyStatusComboBox
CXTPCalendarCaptionBarControl
CXTPCalendarCaptionBarNativeWindows10Theme
CXTPCalendarCaptionBarNativeWindows11Theme
CXTPCalendarCaptionBarOffice2000Theme
CXTPCalendarCaptionBarOffice2003Theme
CXTPCalendarCaptionBarOffice2013Theme
CXTPCalendarCaptionBarOfficeXPTheme
CXTPCalendarCaptionBarPaintManager
CXTPCalendarCaptionBarResourceTheme
CXTPCalendarCaptionBarTheme
CXTPCalendarCaptionBarThemePart
CXTPCalendarCaptionBarVisualStudio2015Theme
CXTPCalendarCaptionBarVisualStudio2017Theme
CXTPCalendarCaptionBarVisualStudio2019Theme
CXTPCalendarCaptionBarVisualStudio2022Theme
CXTPCalendarComboBoxBase
CXTPCalendarControl
CXTPCalendarController
CXTPCalendarControlView
CXTPCalendarControlViewPrintOptions
CXTPCalendarCustomDataProvider
CXTPCalendarCustomProperties
CXTPCalendarData
CXTPCalendarDatabaseDataProvider
CXTPCalendarDayView
CXTPCalendarDayViewDay
CXTPCalendarDayViewEvent
CXTPCalendarDayViewGroup
CXTPCalendarDayViewTimeScale
CXTPCalendarEvent
CXTPCalendarEventCategories
CXTPCalendarEventCategory
CXTPCalendarEventCategoryComboBox
CXTPCalendarEventCategoryIDs
CXTPCalendarEventColorDlg
CXTPCalendarEventColorEdit
CXTPCalendarEventColorListBox
CXTPCalendarEventColorNewDlg
CXTPCalendarEventLabel
CXTPCalendarEventLabelComboBox
CXTPCalendarEventLabels
CXTPCalendarEventPropertiesDlg
CXTPCalendarEventRecurrenceDlg
CXTPCalendarEvents
CXTPCalendarIconIDs
CXTPCalendarMemoryDataProvider
CXTPCalendarMonthView
CXTPCalendarMonthViewDay
CXTPCalendarMonthViewEvent
CXTPCalendarMonthViewGroup
CXTPCalendarMsgNotifier
CXTPCalendarNativeWindows10Theme
CXTPCalendarNativeWindows11Theme
CXTPCalendarOccurSeriesChooseDlg
CXTPCalendarOffice2000Theme
CXTPCalendarOffice2003Theme
CXTPCalendarOffice2013Theme
CXTPCalendarOfficeXPTheme
CXTPCalendarOptions
CXTPCalendarPageSetupDialog
CXTPCalendarPaintManager
CXTPCalendarPtrCollectionT
CXTPCalendarRecurrencePattern
CXTPCalendarReminder
CXTPCalendarReminderForOccurrenceArray
CXTPCalendarReminders
CXTPCalendarRemindersDialog
CXTPCalendarRemindersManager
CXTPCalendarResource
CXTPCalendarResourceDescription
CXTPCalendarResources
CXTPCalendarResourcesManager
CXTPCalendarResourcesNf
CXTPCalendarResourceTheme
CXTPCalendarSchedule
CXTPCalendarSchedules
CXTPCalendarShadowDrawer
CXTPCalendarThemeBOOLValue
CXTPCalendarThemeCustomizableXValueT
CXTPCalendarThemeFontValue
CXTPCalendarThemeIntValue
CXTPCalendarThemeRectValue
CXTPCalendarThemeStringValue
CXTPCalendarTimeLineView
CXTPCalendarTimeLineViewEvent
CXTPCalendarTimeLineViewGroup
CXTPCalendarTimeLineViewGroups
CXTPCalendarTimeLineViewPart
CXTPCalendarTimeLineViewTimeScale
CXTPCalendarTimeLineViewTimeScalePart
CXTPCalendarTimeZone
CXTPCalendarTimeZones
CXTPCalendarTip
CXTPCalendarTLV_TimeScaleParams
CXTPCalendarTLV_TimeScaleParams_Day
CXTPCalendarTLV_TimeScaleParams_Month
CXTPCalendarTLV_TimeScaleParams_Week
CXTPCalendarTLV_TimeScaleParams_WorkWeek
CXTPCalendarTypedPtrAutoDeleteArray
CXTPCalendarTypedPtrAutoDeleteMap
CXTPCalendarUIntArray
CXTPCalendarUtils
CXTPCalendarView
CXTPCalendarViewDay
CXTPCalendarViewDayT
CXTPCalendarViewEvent
CXTPCalendarViewEvents
CXTPCalendarViewEventSubjectEditor
CXTPCalendarViewEventSubjectEditorColored
CXTPCalendarViewEventT
CXTPCalendarViewGroup
CXTPCalendarViewGroupT
CXTPCalendarViewPart
CXTPCalendarViewPartBrushValue
CXTPCalendarViewPartCustomizableValueT
CXTPCalendarViewPartFontValue
CXTPCalendarViewT
CXTPCalendarVisualStudio2015Theme
CXTPCalendarVisualStudio2017Theme
CXTPCalendarVisualStudio2019Theme
CXTPCalendarVisualStudio2022Theme
CXTPCalendarWeekView
CXTPCalendarWeekViewDay
CXTPCalendarWeekViewEvent
CXTPCalendarWeekViewGroup
CXTPCalendarWMHandler
CXTPCaption
CXTPCaptionButton
CXTPCaptionButtonTheme
CXTPCaptionButtonThemeOffice2003
CXTPCaptionButtonThemeOfficeXP
CXTPCaptionPopupWnd
CXTPCaptionTheme
CXTPCaptionThemeOffice2003
CXTPCaptionThemeOfficeXP
CXTPChart2dDiagram
CXTPChart2dDrawingObjectFactory
CXTPChart3dBox
CXTPChart3dDeviceCommand
CXTPChart3dDeviceContext
CXTPChart3dDiagram
CXTPChart3dDiagramView
CXTPChart3dDrawingObjectFactory
CXTPChart3dFunnelDeviceCommandEvents
CXTPChart3dFunnelDiagram
CXTPChart3dFunnelDiagramView
CXTPChart3dFunnelSeriesLabel
CXTPChart3dFunnelSeriesLabelDeviceCommand
CXTPChart3dFunnelSeriesLabelsView
CXTPChart3dFunnelSeriesLabelsViewDeviceCommand
CXTPChart3dFunnelSeriesLabelView
CXTPChart3dFunnelSeriesPointView
CXTPChart3dFunnelSeriesStyle
CXTPChart3dFunnelSeriesView
CXTPChart3dLineDeviceCommand
CXTPChart3dPie
CXTPChart3dPieDeviceCommand
CXTPChart3dPieDeviceCommandEvents
CXTPChart3dPieDiagram
CXTPChart3dPieDiagramView
CXTPChart3dPieSeriesLabel
CXTPChart3dPieSeriesLabelDeviceCommand
CXTPChart3dPieSeriesLabelsView
CXTPChart3dPieSeriesLabelsViewDeviceCommand
CXTPChart3dPieSeriesLabelView
CXTPChart3dPieSeriesPointView
CXTPChart3dPieSeriesStyle
CXTPChart3dPieSeriesView
CXTPChart3dPyramidDeviceCommandEvents
CXTPChart3dPyramidDiagram
CXTPChart3dPyramidDiagramView
CXTPChart3dPyramidSeriesLabel
CXTPChart3dPyramidSeriesLabelDeviceCommand
CXTPChart3dPyramidSeriesLabelsView
CXTPChart3dPyramidSeriesLabelsViewDeviceCommand
CXTPChart3dPyramidSeriesLabelView
CXTPChart3dPyramidSeriesPointView
CXTPChart3dPyramidSeriesStyle
CXTPChart3dPyramidSeriesView
CXTPChart3dRotateDeviceCommand
CXTPChart3dRotation
CXTPChart3dTranslateDeviceCommand
CXTPChartAppearance
CXTPChartAreaSeriesStyle
CXTPChartAreaSeriesView
CXTPChartAxis
CXTPChartAxisAppearance
CXTPChartAxisConstantLine
CXTPChartAxisConstantLines
CXTPChartAxisCustomLabel
CXTPChartAxisCustomLabels
CXTPChartAxisGridLines
CXTPChartAxisLabel
CXTPChartAxisRange
CXTPChartAxisStrip
CXTPChartAxisStrips
CXTPChartAxisTickMarks
CXTPChartAxisTitle
CXTPChartAxisViewTick
CXTPChartAxisX
CXTPChartAxisY
CXTPChartBarSeriesErrorBarView
CXTPChartBarSeriesLabel
CXTPChartBarSeriesLabelView
CXTPChartBarSeriesPointView
CXTPChartBarSeriesStyle
CXTPChartBarSeriesView
CXTPChartBorder
CXTPChartBoundedCircleDeviceCommand
CXTPChartBoundedPolygonDeviceCommand
CXTPChartBoundedTextDeviceCommand
CXTPChartBubbleSeriesLabel
CXTPChartBubbleSeriesLabelView
CXTPChartBubbleSeriesPointView
CXTPChartBubbleSeriesStyle
CXTPChartBubbleSeriesView
CXTPChartCandleStickSeriesPointView
CXTPChartCandleStickSeriesStyle
CXTPChartCandleStickSeriesView
CXTPChartCircleDeviceCommand
CXTPChartClipDeviceCommand
CXTPChartColor
CXTPChartContainer
CXTPChartContent
CXTPChartContentAppearance
CXTPChartContentView
CXTPChartControl
CXTPChartDateTimeScaleTypeMap
CXTPChartDeviceCommand
CXTPChartDeviceCommandEvents
CXTPChartDeviceContext
CXTPChartDiagram
CXTPChartDiagram2D
CXTPChartDiagram2DAppearance
CXTPChartDiagram2DAxisView
CXTPChartDiagram2DSeriesLabel
CXTPChartDiagram2DSeriesLabelView
CXTPChartDiagram2DSeriesStyle
CXTPChartDiagram2DView
CXTPChartDiagram3DAppearance
CXTPChartDiagramDomain
CXTPChartDiagramView
CXTPChartDrawingObjectFactory
CXTPChartElement
CXTPChartElementAppearance
CXTPChartElementCollection
CXTPChartElementView
CXTPChartEllipse
CXTPChartFastLineSeriesStyle
CXTPChartFastLineSeriesView
CXTPChartFillStyle
CXTPChartFinanceStyleAppearance
CXTPChartFont
CXTPChartFunnelDiagram
CXTPChartFunnelDiagramBase
CXTPChartFunnelDiagramView
CXTPChartFunnelSeriesLabel
CXTPChartFunnelSeriesLabelBase
CXTPChartFunnelSeriesLabelView
CXTPChartFunnelSeriesLabelViewBase
CXTPChartFunnelSeriesPointView
CXTPChartFunnelSeriesPointViewBase
CXTPChartFunnelSeriesStyle
CXTPChartFunnelSeriesStyleBase
CXTPChartFunnelSeriesView
CXTPChartFunnelSeriesViewBase
CXTPChartGanttSeriesPointView
CXTPChartGanttSeriesStyle
CXTPChartGanttSeriesView
CXTPChartHighLowSeriesPointView
CXTPChartHighLowSeriesStyle
CXTPChartHighLowSeriesView
CXTPChartHitTestElementCommand
CXTPChartLegend
CXTPChartLegendAppearance
CXTPChartLegendItemView
CXTPChartLegendView
CXTPChartLineDeviceCommand
CXTPChartLineSeriesErrorBarView
CXTPChartLineSeriesStyle
CXTPChartLineSeriesView
CXTPChartLineStyle
CXTPChartMarker
CXTPChartMarkupElementDeviceCommand
CXTPChartNumberFormat
CXTPChartNumericalScaleTypeMap
CXTPChartObject
CXTPChartPalette
CXTPChartPaletteEntry
CXTPChartPanel
CXTPChartPanelCollection
CXTPChartPie
CXTPChartPieBase
CXTPChartPieDeviceCommand
CXTPChartPieDeviceCommandImpl
CXTPChartPieDiagram
CXTPChartPieDiagramBase
CXTPChartPieDiagramView
CXTPChartPieSeriesLabel
CXTPChartPieSeriesLabelBase
CXTPChartPieSeriesLabelsView
CXTPChartPieSeriesLabelsViewBase
CXTPChartPieSeriesLabelView
CXTPChartPieSeriesLabelViewBase
CXTPChartPieSeriesPointView
CXTPChartPieSeriesPointViewBase
CXTPChartPieSeriesStyle
CXTPChartPieSeriesStyleBase
CXTPChartPieSeriesView
CXTPChartPieSeriesViewBase
CXTPChartPieStyleAppearance
CXTPChartPointSeriesErrorBarView
CXTPChartPointSeriesLabel
CXTPChartPointSeriesLabelView
CXTPChartPointSeriesPointView
CXTPChartPointSeriesStyle
CXTPChartPointSeriesView
CXTPChartPolygonAntialiasingDeviceCommand
CXTPChartPolygonDeviceCommand
CXTPChartPolylineDeviceCommand
CXTPChartPyramidDiagram
CXTPChartPyramidDiagramBase
CXTPChartPyramidDiagramView
CXTPChartPyramidSeriesLabel
CXTPChartPyramidSeriesLabelBase
CXTPChartPyramidSeriesLabelView
CXTPChartPyramidSeriesLabelViewBase
CXTPChartPyramidSeriesPointView
CXTPChartPyramidSeriesPointViewBase
CXTPChartPyramidSeriesStyle
CXTPChartPyramidSeriesStyleBase
CXTPChartPyramidSeriesView
CXTPChartPyramidSeriesViewBase
CXTPChartQualitativeScaleTypeMap
CXTPChartRadarAreaSeriesStyle
CXTPChartRadarAreaSeriesView
CXTPChartRadarAxisView
CXTPChartRadarAxisX
CXTPChartRadarAxisXView
CXTPChartRadarAxisXViewTick
CXTPChartRadarAxisY
CXTPChartRadarAxisYView
CXTPChartRadarAxisYViewTick
CXTPChartRadarDiagram
CXTPChartRadarDiagramSeriesStyle
CXTPChartRadarDiagramView
CXTPChartRadarLineSeriesStyle
CXTPChartRadarLineSeriesView
CXTPChartRadarPointSeriesLabel
CXTPChartRadarPointSeriesLabelView
CXTPChartRadarPointSeriesPointView
CXTPChartRadarPointSeriesStyle
CXTPChartRadarPointSeriesView
CXTPChartRadarSplineAreaSeriesStyle
CXTPChartRadarSplineAreaSeriesView
CXTPChartRadarSplineSeriesStyle
CXTPChartRadarSplineSeriesView
CXTPChartRangeAreaSeriesLabel
CXTPChartRangeAreaSeriesLabelView
CXTPChartRangeBarSeriesLabel
CXTPChartRangeBarSeriesLabelView
CXTPChartRangeBarSeriesPointView
CXTPChartRangeBarSeriesStyle
CXTPChartRangeBarSeriesView
CXTPChartRangeSplineAreaSeriesPointView
CXTPChartRangeSplineAreaSeriesStyle
CXTPChartRangeSplineAreaSeriesView
CXTPChartRectangleDeviceCommand
CXTPChartRotateDeviceCommand
CXTPChartRotatedTextPainterBase
CXTPChartRotatedTextPainterNearLine
CXTPChartScaleTypeMap
CXTPChartScatterLineSeriesStyle
CXTPChartSeries
CXTPChartSeriesCollection
CXTPChartSeriesLabel
CXTPChartSeriesPoint
CXTPChartSeriesPointCollection
CXTPChartSeriesPointView
CXTPChartSeriesStyle
CXTPChartSolidSplinePolygonDeviceCommand
CXTPChartSplineAreaSeriesStyle
CXTPChartSplineAreaSeriesView
CXTPChartSplineDeviceCommand
CXTPChartSplineSeriesStyle
CXTPChartSplineSeriesView
CXTPChartStackedAreaSeriesStyle
CXTPChartStackedAreaSeriesView
CXTPChartStackedBarSeriesPointView
CXTPChartStackedBarSeriesStyle
CXTPChartStackedBarSeriesView
CXTPChartStackedSplineAreaSeriesStyle
CXTPChartStackedSplineAreaSeriesView
CXTPChartStepAreaSeriesStyle
CXTPChartStepAreaSeriesView
CXTPChartStepLineSeriesPointView
CXTPChartStepLineSeriesStyle
CXTPChartStepLineSeriesView
CXTPChartStrings
CXTPChartTextAntialiasingDeviceCommand
CXTPChartTextDeviceCommand
CXTPChartTextElement
CXTPChartTextPainter
CXTPChartTextPainterBase
CXTPChartTimeScaleTypeMap
CXTPChartTitle
CXTPChartTitleAppearance
CXTPChartTitleCollection
CXTPChartTranslateDeviceCommand
CXTPCheckboxButtonPart
CXTPCheckListBox
CXTPClientCursorPos
CXTPClientRect
CXTPCmdTarget
CXTPColorBase
CXTPColorDialog
CXTPColorHex
CXTPColorLum
CXTPColorManager
CXTPColorPageCustom
CXTPColorPageStandard
CXTPColorPicker
CXTPColorPopup
CXTPColorSelectorCtrl
CXTPColorSelectorCtrlTheme
CXTPColorSelectorCtrlThemeNativeWindows10
CXTPColorSelectorCtrlThemeNativeWindows11
CXTPColorSelectorCtrlThemeOffice2003
CXTPColorSelectorCtrlThemeOffice2013
CXTPColorSelectorCtrlThemeOfficeXP
CXTPColorSelectorCtrlThemeResource
CXTPColorSelectorCtrlThemeVisualStudio2015
CXTPColorSelectorCtrlThemeVisualStudio2017
CXTPColorSelectorCtrlThemeVisualStudio2019
CXTPColorSelectorCtrlThemeVisualStudio2022
CXTPColorSetCaptionButton
CXTPColorSetStateButton
CXTPColorSetStateCheckBox
CXTPColorSetStateCheckMark
CXTPColorSetStateComboBox
CXTPColorSetStateMenu
CXTPColorSetStateMenuTitleBar
CXTPColorSetStateRibbon
CXTPColorSetStateToolbar
CXTPColorWnd
CXTPComboBox
CXTPComboBoxEditCtrl
CXTPComboBoxTheme
CXTPComboBoxThemeDefault
CXTPComboBoxThemeNativeWindows10
CXTPComboBoxThemeNativeWindows11
CXTPComboBoxThemeOffice2000
CXTPComboBoxThemeOffice2003
CXTPComboBoxThemeOffice2013
CXTPComboBoxThemeOfficeXPFlat
CXTPComboBoxThemeResource
CXTPComboBoxThemeVisualStudio
CXTPComboBoxThemeVisualStudio2010
CXTPComboBoxThemeVisualStudio2012
CXTPComboBoxThemeVisualStudio2015
CXTPComboBoxThemeVisualStudio2017
CXTPComboBoxThemeVisualStudio2019
CXTPComboBoxThemeVisualStudio2022
CXTPComInitializer
CXTPCommandBar
CXTPCommandBarEditCtrl
CXTPCommandBarKeyboardTip
CXTPCommandBarList
CXTPCommandBars
CXTPCommandBarsContextMenus
CXTPCommandBarScrollBarCtrl
CXTPCommandBarsFrameHook
CXTPCommandBarsModernUITheme
CXTPCommandBarsNativeWindows10Theme
CXTPCommandBarsNativeWindows11Theme
CXTPCommandBarsNativeXPTheme
CXTPCommandBarsOffice2000Theme
CXTPCommandBarsOffice2003Theme
CXTPCommandBarsOffice2013Theme
CXTPCommandBarsOfficeXPTheme
CXTPCommandBarsOptions
CXTPCommandBarsSiteBase
CXTPCommandBarsVisualStudio2012Theme
CXTPCommandBarsVisualStudio2015Theme
CXTPCommandBarsVisualStudio2017Theme
CXTPCommandBarsVisualStudio2019Theme
CXTPCommandBarsVisualStudio2022Theme
CXTPCommonPicturePreviewProvider
CXTPControl
CXTPControlAction
CXTPControlActions
CXTPControlBitmap
CXTPControlButton
CXTPControlButtonColor
CXTPControlCheckBox
CXTPControlColorSelector
CXTPControlComboBox
CXTPControlComboBoxEditCtrl
CXTPControlComboBoxGalleryPopupBar
CXTPControlComboBoxList
CXTPControlComboBoxPopupBar
CXTPControlCustom
CXTPControlEdit
CXTPControlEditCtrl
CXTPControlFontComboBox
CXTPControlFontComboBoxList
CXTPControlGallery
CXTPControlGalleryItem
CXTPControlGalleryItems
CXTPControlGalleryNativeWindows10Theme
CXTPControlGalleryNativeWindows11Theme
CXTPControlGalleryOffice2013Theme
CXTPControlGalleryPaintManager
CXTPControlGalleryResourceTheme
CXTPControlGalleryVisualStudio2015Theme
CXTPControlGalleryVisualStudio2017Theme
CXTPControlGalleryVisualStudio2019Theme
CXTPControlGalleryVisualStudio2022Theme
CXTPControlHyperlink
CXTPControlLabel
CXTPControlListBox
CXTPControlMarkupLabel
CXTPControlOleItems
CXTPControlPopup
CXTPControlPopupColor
CXTPControlProgress
CXTPControlRadioButton
CXTPControlRecentFileList
CXTPControls
CXTPControlScrollBar
CXTPControlSelector
CXTPControlSizeComboBox
CXTPControlSlider
CXTPControlSliderCtrl
CXTPControlStatic
CXTPControlTabWorkspace
CXTPControlTheme
CXTPControlToolbars::CXTPControlToolbar
CXTPControlToolbars
CXTPControlWindowList
CXTPControlWorkspaceActions
CXTPCriticalSection
CXTPCustomizeCommandsListBox
CXTPCustomizeCommandsPage
CXTPCustomizeKeyboardPage
CXTPCustomizeMenusPage
CXTPCustomizeOptionsPage
CXTPCustomizeSheet
CXTPCustomizeToolbarsPage
CXTPDateEdit
CXTPDateLabelPart
CXTPDatePickerButton
CXTPDatePickerButtons
CXTPDatePickerControl
CXTPDatePickerDaysCollection
CXTPDatePickerItemDay
CXTPDatePickerItemMonth
CXTPDatePickerList
CXTPDatePickerPaintManager
CXTPDatePickerThemeNativeWindows10
CXTPDatePickerThemeNativeWindows11
CXTPDatePickerThemeOffice2000
CXTPDatePickerThemeOffice2003
CXTPDatePickerThemeOffice2013
CXTPDatePickerThemeOfficeXP
CXTPDatePickerThemeResource
CXTPDatePickerThemeVisualStudio2015
CXTPDatePickerThemeVisualStudio2017
CXTPDatePickerThemeVisualStudio2019
CXTPDatePickerThemeVisualStudio2022
CXTPDeviceCaps
CXTPDialogBar
CXTPDialogBase
CXTPDialogEx
CXTPDialogScrollBarContainer
CXTPDirWatcher
CXTPDockBar
CXTPDockContext
CXTPDockingPane
CXTPDockingPaneAutoHidePanel
CXTPDockingPaneAutoHideWnd
CXTPDockingPaneBase
CXTPDockingPaneBaseContainer
CXTPDockingPaneCaptionButton
CXTPDockingPaneCaptionButtons
CXTPDockingPaneColorSet
CXTPDockingPaneColorSet2012
CXTPDockingPaneColorSet2013
CXTPDockingPaneColorSet2015
CXTPDockingPaneColorSet2017
CXTPDockingPaneColorSet2019
CXTPDockingPaneColorSet2022
CXTPDockingPaneColorSetNativeWindows10
CXTPDockingPaneColorSetNativeWindows11
CXTPDockingPaneContext
CXTPDockingPaneContextAlphaWnd
CXTPDockingPaneContextStickerWnd
CXTPDockingPaneDefaultTheme
CXTPDockingPaneGripperedTheme
CXTPDockingPaneLayout
CXTPDockingPaneManager
CXTPDockingPaneMiniWnd
CXTPDockingPaneNativeWindows10Theme
CXTPDockingPaneNativeWindows11Theme
CXTPDockingPaneOffice2002VisioTheme
CXTPDockingPaneOffice2003OutlookTheme
CXTPDockingPaneOffice2003Theme
CXTPDockingPaneOffice2003VisioTheme
CXTPDockingPaneOffice2007OutlookTheme
CXTPDockingPaneOffice2007Theme
CXTPDockingPaneOffice2007VisioTheme
CXTPDockingPaneOffice2007WordTheme
CXTPDockingPaneOffice2013Theme
CXTPDockingPanePaintManager
CXTPDockingPanePanelColorSet2012
CXTPDockingPanePanelColorSet2013
CXTPDockingPanePanelColorSet2015
CXTPDockingPanePanelColorSet2017
CXTPDockingPanePanelColorSet2019
CXTPDockingPanePanelColorSet2022
CXTPDockingPanePanelColorSetNativeWindows10
CXTPDockingPanePanelColorSetNativeWindows11
CXTPDockingPanePanelPaintManager
CXTPDockingPanePanelTheme2012
CXTPDockingPanePanelTheme2013
CXTPDockingPanePanelTheme2015
CXTPDockingPanePanelTheme2017
CXTPDockingPanePanelTheme2019
CXTPDockingPanePanelTheme2022
CXTPDockingPanePanelThemeNativeWindows10
CXTPDockingPanePanelThemeNativeWindows11
CXTPDockingPaneSidePanel
CXTPDockingPaneSplitterContainer
CXTPDockingPaneSplitterWnd
CXTPDockingPaneTabbedContainer
CXTPDockingPaneTabColorSet2012
CXTPDockingPaneTabColorSet2013
CXTPDockingPaneTabColorSet2015
CXTPDockingPaneTabColorSet2017
CXTPDockingPaneTabColorSet2019
CXTPDockingPaneTabColorSet2022
CXTPDockingPaneTabColorSetNativeWindows10
CXTPDockingPaneTabColorSetNativeWindows11
CXTPDockingPaneTabColorSetOfficePanel
CXTPDockingPaneTabColorSetVisualStudio2003
CXTPDockingPaneTabColorSetVisualStudio2005
CXTPDockingPaneTabPaintManager
CXTPDockingPaneTabTheme2012
CXTPDockingPaneTabTheme2013
CXTPDockingPaneTabTheme2015
CXTPDockingPaneTabTheme2017
CXTPDockingPaneTabTheme2019
CXTPDockingPaneTabTheme2022
CXTPDockingPaneTabThemeNativeWindows10
CXTPDockingPaneTabThemeNativeWindows11
CXTPDockingPaneVisualStudio2003Theme
CXTPDockingPaneVisualStudio2005Beta1Theme
CXTPDockingPaneVisualStudio2005Beta2Theme
CXTPDockingPaneVisualStudio2005Theme
CXTPDockingPaneVisualStudio2008Theme
CXTPDockingPaneVisualStudio2010Theme
CXTPDockingPaneVisualStudio2012Theme
CXTPDockingPaneVisualStudio2015Theme
CXTPDockingPaneVisualStudio2017Theme
CXTPDockingPaneVisualStudio2019Theme
CXTPDockingPaneVisualStudio2022Theme
CXTPDockingPaneVisualStudio6Theme
CXTPDockingPaneWindowSelect
CXTPDockingPaneWinExplorerTheme
CXTPDockingPaneWinNativeTheme
CXTPDockState
CXTPCalendarData::CXTPDPCache
CXTPDropSource
CXTPEdit
CXTPEditListBox
CXTPEditListBoxToolBar
CXTPEditTheme
CXTPEditThemeDefault
CXTPEditThemeFlat
CXTPEditThemeNativeWindows10
CXTPEditThemeNativeWindows11
CXTPEditThemeOffice2000
CXTPEditThemeOffice2003
CXTPEditThemeOffice2013
CXTPEditThemeOfficeXP
CXTPEditThemeResource
CXTPEditThemeUltraFlat
CXTPEditThemeVisualStudio2010
CXTPEditThemeVisualStudio2012
CXTPEditThemeVisualStudio2015
CXTPEditThemeVisualStudio2017
CXTPEditThemeVisualStudio2019
CXTPEditThemeVisualStudio2022
CXTPEmptyRect
CXTPEmptySize
CXTPExcelTabCtrl
CXTPExcelTabCtrlButtonState
CXTPExcelTabCtrlTheme
CXTPExcelTabCtrlThemeNativeWindows10
CXTPExcelTabCtrlThemeNativeWindows11
CXTPExcelTabCtrlThemeOffice2003
CXTPExcelTabCtrlThemeOffice2013
CXTPExcelTabCtrlThemeOfficeXP
CXTPExcelTabCtrlThemeVisualStudio2015
CXTPExcelTabCtrlThemeVisualStudio2017
CXTPExcelTabCtrlThemeVisualStudio2019
CXTPExcelTabCtrlThemeVisualStudio2022
CXTPExcludedMemberPadding
CXTPExpandButtonPart
CXTPEyeDropper
CXTPFlowGraphConnection
CXTPFlowGraphConnectionPoint
CXTPFlowGraphConnectionPoints
CXTPFlowGraphConnections
CXTPFlowGraphControl
CXTPFlowGraphEditItem
CXTPFlowGraphElement
CXTPFlowGraphImage
CXTPFlowGraphImages
CXTPFlowGraphNode
CXTPFlowGraphNodeCustom
CXTPFlowGraphNodeGroup
CXTPFlowGraphNodeGroups
CXTPFlowGraphNodes
CXTPFlowGraphPage
CXTPFlowGraphPageHistory
CXTPFlowGraphPageHistoryItem
CXTPFlowGraphPages
CXTPFlowGraphPaintManager
CXTPFlowGraphSelectedElements
CXTPFlowGraphUndoAddConnectionCommand
CXTPFlowGraphUndoAddConnectionPointCommand
CXTPFlowGraphUndoAddNodeCommand
CXTPFlowGraphUndoCommand
CXTPFlowGraphUndoDeleteConnectionCommand
CXTPFlowGraphUndoDeleteConnectionPointCommand
CXTPFlowGraphUndoDeleteNodeCommand
CXTPFlowGraphUndoGroupCommand
CXTPFlowGraphUndoManager
CXTPFlowGraphUndoSetConnectionPositionCommand
CXTPFlowGraphUndoSetNodeCaptionCommand
CXTPFlowGraphUndoSetNodePositionCommand
CXTPFlowGraphUndoSetNodeSizeCommand
CXTPFont
CXTPFontComboBox
CXTPFontCtrlBase
CXTPFontEnum
CXTPFontListBox
CXTPFontManager
CXTPFramePaintManager
CXTPFrameShadow
CXTPFrameShadowManager
CXTPFrameThemeOffice2007System
CXTPFrameWnd
CXTPFrameWndBase
CXTPGaugeBaseType
CXTPGaugeCtrl
CXTPGaugeMeterType
CXTPGaugeStateType
CXTPGaugeTraits
CXTPGdiObject
CXTPGifPreviewProvider
CXTPGlobalAtom
CXTPGraphicBitmapPng
CXTPGridColumn
CXTPGridColumnOrder
CXTPGridColumns
CXTPGridControl
CXTPGridControlLocale
CXTPGridDataManager
CXTPGridFilterEditControl
CXTPGridGroupRow
CXTPGridHeader
CXTPGridHeaderDragWnd
CXTPGridHeaderDropWnd
CXTPGridHyperlink
CXTPGridHyperlinks
CXTPGridHyperlinkStyle
CXTPGridIconNavigator
CXTPGridInplaceButton
CXTPGridInplaceButtons
CXTPGridInplaceControl
CXTPGridInplaceEdit
CXTPGridInplaceList
CXTPGridNavigator
CXTPGridPageSetupDialog
CXTPGridPaintManager
CXTPGridRecord
CXTPGridRecordItem
CXTPGridRecordItemButton
CXTPGridRecordItemCheckbox
CXTPGridRecordItemConstraint
CXTPGridRecordItemConstraints
CXTPGridRecordItemControl
CXTPGridRecordItemControlHookWnd
CXTPGridRecordItemControls
CXTPGridRecordItemDateTime
CXTPGridRecordItemEditOptions
CXTPGridRecordItemNumber
CXTPGridRecordItemPercentNumber
CXTPGridRecordItemPreview
CXTPGridRecordItemText
CXTPGridRecordItemVariant
CXTPGridRecords
CXTPGridRow
CXTPGridRows
CXTPGridSection
CXTPGridSections
CXTPGridSelectedRows
CXTPGridSubListControl
CXTPGridThemeDefault
CXTPGridThemeExplorer
CXTPGridThemeNativeWindows10
CXTPGridThemeNativeWindows11
CXTPGridThemeOffice2003
CXTPGridThemeOffice2003Luna
CXTPGridThemeOffice2013
CXTPGridThemeOfficeXP
CXTPGridThemeResource
CXTPGridThemeVisualStudio2012Blue
CXTPGridThemeVisualStudio2012Dark
CXTPGridThemeVisualStudio2012Light
CXTPGridThemeVisualStudio2015
CXTPGridThemeVisualStudio2017
CXTPGridThemeVisualStudio2019
CXTPGridThemeVisualStudio2022
CXTPGridThickness
CXTPGridTip
CXTPGridView
CXTPGridViewPrintOptions
CXTPGroupLine
CXTPHeaderCtrl
CXTPHeaderCtrlTheme
CXTPHeaderCtrlThemeExplorer
CXTPHeaderCtrlThemeOffice2003
CXTPHeaderCtrlThemeOfficeXP
CXTPHeaderCtrlThemeResource
CXTPHeapAllocatorT
CXTPHeapObjectT
CXTPHeapString
CXTPHeapStringT
CXTPHexEdit
CXTPHookManager
CXTPHookManagerHookAble
CXTPHyperLink
CXTPIconHandle
CXTPImageEditorDlg
CXTPImageList
CXTPImageManager
CXTPImageManagerIcon
CXTPImageManagerIconHandle
CXTPImageManagerIconSet
CXTPImageManagerImageList
CXTPImageManagerResource
CXTPImageManagerVectorImageHandle
CXTPInternalCollectionT
CXTPItemEdit
CXTPKeyboardManager
CXTPListBase
CXTPListBox
CXTPListBoxTheme
CXTPListBoxThemeDefault
CXTPListBoxThemeNativeWindows10
CXTPListBoxThemeNativeWindows11
CXTPListBoxThemeOffice2003
CXTPListBoxThemeOffice2013
CXTPListBoxThemeOfficeXP
CXTPListBoxThemeResource
CXTPListBoxThemeVisualStudio2015
CXTPListBoxThemeVisualStudio2017
CXTPListBoxThemeVisualStudio2019
CXTPListBoxThemeVisualStudio2022
CXTPListCtrl
CXTPListView
CXTPLockGuard
CXTPLogFont
CXTPMarkupBorder
CXTPMarkupButton
CXTPMarkupButtonBase
CXTPMarkupCheckBox
CXTPMarkupColumnDefinition
CXTPMarkupColumnDefinitionCollection
CXTPMarkupContentControl
CXTPMarkupContext
CXTPMarkupControl
CXTPMarkupDecorator
CXTPMarkupDefinitionBase
CXTPMarkupDefinitionCollection
CXTPMarkupDeviceDependentImage
CXTPMarkupDockPanel
CXTPMarkupExtension
CXTPMarkupFrameworkElement
CXTPMarkupGdiImage
CXTPMarkupGdiPlusImage
CXTPMarkupGdiPlusMatrixTransform
CXTPMarkupGdiPlusRotateTransform
CXTPMarkupGdiPlusScaleTransform
CXTPMarkupGdiPlusSkewTransform
CXTPMarkupGdiPlusTransformationMatrix
CXTPMarkupGdiPlusTransformObject
CXTPMarkupGdiPlusTransformObjectImpl
CXTPMarkupGdiPlusTranslateTransform
CXTPMarkupGrid
CXTPMarkupGridLength
CXTPMarkupImage
CXTPMarkupMatrixTransform
CXTPMarkupPage
CXTPMarkupPanel
CXTPMarkupRadioButton
CXTPMarkupRotateTransform
CXTPMarkupRowDefinition
CXTPMarkupRowDefinitionCollection
CXTPMarkupScaleTransform
CXTPMarkupSkewTransform
CXTPMarkupStackPanel
CXTPMarkupStaticExtension
CXTPMarkupStaticExtensionBooleanProperty
CXTPMarkupStaticExtensionBrushProperty
CXTPMarkupStaticExtensionColorProperty
CXTPMarkupStaticExtensionDoubleProperty
CXTPMarkupStaticExtensionIntegerProperty
CXTPMarkupStaticExtensionProperty
CXTPMarkupStaticExtensionStringProperty
CXTPMarkupSystemBrushKeyStaticExtension
CXTPMarkupSystemBrushStaticExtension
CXTPMarkupSystemColorKeyStaticExtension
CXTPMarkupSystemColorsStaticExtension
CXTPMarkupSystemColorStaticExtension
CXTPMarkupTextBlock
CXTPMarkupThemePart
CXTPMarkupThickness
CXTPMarkupToggleButton
CXTPMarkupTransform
CXTPMarkupTransformationMatrix
CXTPMarkupTranslateTransform
CXTPMarkupTreeCtrl
CXTPMarkupUIElement
CXTPMarkupUIElementCollection
CXTPMarkupUniformGrid
CXTPMarkupViewbox
CXTPMarkupVisual
CXTPMarkupWrapPanel
CXTPMarkupXtpScript
CXTPMarqueeCtrl
CXTPMarqueeCtrlPaintManager
CXTPMarqueeCtrlThemeFlat
CXTPMarqueeCtrlThemeNativeWindows
CXTPMarqueeCtrlThemeNativeWinXP
CXTPMarqueeCtrlThemeOffice2000
CXTPMarqueeCtrlThemeOffice2003
CXTPMarqueeCtrlThemeOffice2013
CXTPMarqueeCtrlThemeOfficeXP
CXTPMarqueeCtrlThemeResource
CXTPMarqueeCtrlThemeUltraFlat
CXTPMarqueeCtrlThemeVisualStudio2015
CXTPMarqueeCtrlThemeVisualStudio2017
CXTPMarqueeCtrlThemeVisualStudio2019
CXTPMarqueeCtrlThemeVisualStudio2022
CXTPMaskEdit
CXTPMaskEditT
CXTPMathUtils
CXTPMatrix
CXTPMDIClientWnd
CXTPMDIFrameWnd
CXTPMDIFrameWndEx
CXTPMDIWndTab
CXTPMemFile
CXTPMenuBar
CXTPMenuBarMDIMenuInfo
CXTPMenuBarMDIMenus
CXTPMessageBar
CXTPMessageBarButton
CXTPMessageBarPaintManager
CXTPMessageBarThemeNativeWindows10
CXTPMessageBarThemeNativeWindows11
CXTPMessageBarThemeOffice2010
CXTPMessageBarThemeOffice2013
CXTPMessageBarThemeVisualStudio2015
CXTPMessageBarThemeVisualStudio2017
CXTPMessageBarThemeVisualStudio2019
CXTPMessageBarThemeVisualStudio2022
CXTPMiniToolBar
CXTPModuleHandle
CXTPMouseManager
CXTPMsgPreviewProvider
CXTPMultiMonitor
CXTPNonClientMetrics
CXTPNotifyConnection
CXTPNotifyConnectionMT
CXTPNotifySinkBase
CXTPObservable
CXTPOpenGLListPool
CXTPOpenGLUtils
CXTPOriginalControls
CXTPPageScroller
CXTPPaintManager
CXTPPaintManagerColor
CXTPPaintManagerColorGradient
CXTPPaintManagerFont
CXTPPasswordPeek
CXTPPen
CXTPPoint2T
CXTPPoint3T
CXTPPopupBar
CXTPPopupControl
CXTPPopupItem
CXTPPopupPaintManager
CXTPPopupThemeMSN
CXTPPopupThemeOffice2000
CXTPPopupThemeOffice2003
CXTPPopupThemeOffice2013
CXTPPopupThemeOfficeXP
CXTPPopupThemeResource
CXTPPopupToolBar
CXTPPreviewCtrl
CXTPPreviewProviderBase
CXTPPreviewView
CXTPProgressBase
CXTPProgressCtrl
CXTPProgressCtrlPaintManager
CXTPProgressCtrlThemeFlat
CXTPProgressCtrlThemeNativeWindows
CXTPProgressCtrlThemeNativeWinXP
CXTPProgressCtrlThemeOffice2000
CXTPProgressCtrlThemeOffice2003
CXTPProgressCtrlThemeOffice2013
CXTPProgressCtrlThemeOfficeXP
CXTPProgressCtrlThemeResource
CXTPProgressCtrlThemeUltraFlat
CXTPProgressCtrlThemeVisualStudio2015
CXTPProgressCtrlThemeVisualStudio2017
CXTPProgressCtrlThemeVisualStudio2019
CXTPProgressCtrlThemeVisualStudio2022
CXTPProgressPaintManager
CXTPProgressThemeNativeWindows10
CXTPProgressThemeNativeWindows11
CXTPProgressThemeOffice2013
CXTPProgressThemeVisualStudio2015
CXTPProgressThemeVisualStudio2017
CXTPProgressThemeVisualStudio2019
CXTPProgressThemeVisualStudio2022
CXTPPropertyGrid
CXTPPropertyGridCoolTheme
CXTPPropertyGridDelphiTheme
CXTPPropertyGridInplaceButton
CXTPPropertyGridInplaceButtons
CXTPPropertyGridInplaceControl
CXTPPropertyGridInplaceControls
CXTPPropertyGridInplaceEdit
CXTPPropertyGridInplaceList
CXTPPropertyGridInplaceMonthCal
CXTPPropertyGridInplaceMultilineEdit
CXTPPropertyGridInplaceSlider
CXTPPropertyGridInplaceSpinButton
CXTPPropertyGridItem
CXTPPropertyGridItemBool
CXTPPropertyGridItemCategory
CXTPPropertyGridItemColor
CXTPPropertyGridItemConstraint
CXTPPropertyGridItemConstraints
CXTPPropertyGridItemDate
CXTPPropertyGridItemDouble
CXTPPropertyGridItemEnum
CXTPPropertyGridItemFlags
CXTPPropertyGridItemFont
CXTPPropertyGridItemMetrics
CXTPPropertyGridItemMultilineString
CXTPPropertyGridItemNumber
CXTPPropertyGridItemOption
CXTPPropertyGridItemPoint
CXTPPropertyGridItems
CXTPPropertyGridItemSize
CXTPPropertyGridNativeWindows10Theme
CXTPPropertyGridNativeWindows11Theme
CXTPPropertyGridNativeXPTheme
CXTPPropertyGridOffice2003Theme
CXTPPropertyGridOffice2007Theme
CXTPPropertyGridOffice2013Theme
CXTPPropertyGridOfficeXPTheme
CXTPPropertyGridPaintManager
CXTPPropertyGridSimpleTheme
CXTPPropertyGridToolBar
CXTPPropertyGridToolTip
CXTPPropertyGridUpdateContext
CXTPPropertyGridVerb
CXTPPropertyGridVerbs
CXTPPropertyGridView
CXTPPropertyGridVisualStudio2005Theme
CXTPPropertyGridVisualStudio2010Theme
CXTPPropertyGridVisualStudio2012Theme
CXTPPropertyGridVisualStudio2015Theme
CXTPPropertyGridVisualStudio2017Theme
CXTPPropertyGridVisualStudio2019Theme
CXTPPropertyGridVisualStudio2022Theme
CXTPPropertyPage
CXTPPropertyPageControlNavigator
CXTPPropertyPageListNavigator
CXTPPropertyPageNavigator
CXTPPropertyPageTreeNavigator
CXTPPropertySheet
CXTPPropExchange
CXTPPropExchangeArchive
CXTPPropExchangeEnumerator
CXTPPropExchangeIniFile
CXTPPropExchangeRegistry
CXTPPropExchangeSection
CXTPPropExchangeXMLNode
CXTPRadioButtonPart
CXTPReBar
CXTPReBarPaintManager
CXTPRecentFileList
CXTPRectT
CXTPRegistryManager
CXTPResize
CXTPResizeDialog
CXTPResizeFormView
CXTPResizeGroupBox
CXTPResizeItem
CXTPResizePoint
CXTPResizePropertyPage
CXTPResizePropertySheet
CXTPResizeRect
CXTPResourceImage
CXTPResourceImages
CXTPResourceManager
CXTPResourceManagerXML
CXTPResourceTheme
CXTPRibbonBackstageView
CXTPRibbonBar
CXTPRibbonControls
CXTPRibbonControlSystemButton
CXTPRibbonControlSystemPopupBarButton
CXTPRibbonControlSystemPopupBarListCaption
CXTPRibbonControlSystemPopupBarListItem
CXTPRibbonControlSystemPopupBarPinableListItem
CXTPRibbonControlSystemRecentFileList
CXTPRibbonControlTab
CXTPRibbonCustomizePage
CXTPRibbonCustomizeQuickAccessPage
CXTPRibbonGroup
CXTPRibbonGroups
CXTPRibbonMarkupFrameTheme
CXTPRibbonMarkupTheme
CXTPRibbonOffice2013Theme
CXTPRibbonPaintManager
CXTPRibbonQuickAccessControls
CXTPRibbonSystemPopupBar
CXTPRibbonSystemPopupBarPage
CXTPRibbonTab
CXTPRibbonTabPopupToolBar
CXTPRibbonTheme
CXTPRibbonThemeNativeWindows10
CXTPRibbonThemeNativeWindows11
CXTPRibbonThemeOffice2007System
CXTPRibbonThemeResource
CXTPRibbonThemeVisualStudio2015
CXTPRibbonThemeVisualStudio2017
CXTPRibbonThemeVisualStudio2019
CXTPRibbonThemeVisualStudio2022
CXTPRWCriticalSection
CXTPScrollable
CXTPScrollableEditT
CXTPScrollableListBoxT
CXTPScrollableListCtrlT
CXTPScrollableTreeCtrlT
CXTPScrollBar
CXTPScrollBarContainer
CXTPScrollBarCtrl
CXTPScrollBarPaintManager
CXTPScrollBarThemeFlat
CXTPScrollBarThemeNativeWindows10
CXTPScrollBarThemeNativeWindows11
CXTPScrollBarThemeOffice2000
CXTPScrollBarThemeOffice2003
CXTPScrollBarThemeOffice2013
CXTPScrollBarThemeOfficeXP
CXTPScrollBarThemeResource
CXTPScrollBarThemeUltraFlat
CXTPScrollBarThemeVisualStudio2012
CXTPScrollBarThemeVisualStudio2015
CXTPScrollBarThemeVisualStudio2017
CXTPScrollBarThemeVisualStudio2019
CXTPScrollBarThemeVisualStudio2022
CXTPScrollBarThemeWindowsClassic
CXTPScrollBarThemeWindowsUx
CXTPScrollBase
CXTPScrollDateButtonPart
CXTPSearchOptionsCtrl
CXTPSearchOptionsView
CXTPShadowManager
CXTPShellExplorerProvider
CXTPShellListBase
CXTPShellListCtrl
CXTPShellListCtrlEx
CXTPShellListView
CXTPShellPidl
CXTPShellSettings
CXTPShellTreeBase
CXTPShellTreeCtrl
CXTPShellTreeView
CXTPShortcutBar
CXTPShortcutBarItem
CXTPShortcutBarNativeWindows10Theme
CXTPShortcutBarNativeWindows11Theme
CXTPShortcutBarNativeWinXPTheme
CXTPShortcutBarOffice2000Theme
CXTPShortcutBarOffice2003Theme
CXTPShortcutBarOffice2013Theme
CXTPShortcutBarOfficeXPTheme
CXTPShortcutBarPaintManager
CXTPShortcutBarPane
CXTPShortcutBarPaneItem
CXTPShortcutBarResourceTheme
CXTPShortcutBarVisualStudio2015Theme
CXTPShortcutBarVisualStudio2017Theme
CXTPShortcutBarVisualStudio2019Theme
CXTPShortcutBarVisualStudio2022Theme
CXTPShortcutListBox
CXTPShortcutListBoxTheme
CXTPShortcutListBoxThemeOffice2003
CXTPShortcutListBoxThemeOfficeXP
CXTPShortcutManager
CXTPShortcutManagerAccel
CXTPShortcutManagerAccelTable
CXTPSimpleCriticalSection
CXTPSimpleEvent
CXTPSingleton
CXTPSingletonBase
CXTPSingletonDependencies
CXTPSingletonPointer
CXTPSizeIcon
CXTPSizeT
CXTPSkinImage
CXTPSkinImages
CXTPSkinManager
CXTPSkinManagerClass
CXTPSkinManagerColorFilter
CXTPSkinManagerMetrics
CXTPSkinManagerResourceFile
CXTPSkinManagerSchema
CXTPSkinManagerSchemaProperty
CXTPSkinObject
CXTPSkinObjectButton
CXTPSkinObjectClassMap
CXTPSkinObjectComboBox
CXTPSkinObjectComCtl32Control
CXTPSkinObjectDateTime
CXTPSkinObjectEdit
CXTPSkinObjectFrame
CXTPSkinObjectHeader
CXTPSkinObjectListBox
CXTPSkinObjectListView
CXTPSkinObjectMonthCal
CXTPSkinObjectProgress
CXTPSkinObjectReBar
CXTPSkinObjectScrollBar
CXTPSkinObjectSolidFilled
CXTPSkinObjectSpin
CXTPSkinObjectStatusBar
CXTPSkinObjectTab
CXTPSkinObjectToolBar
CXTPSkinObjectTrackBar
CXTPSkinObjectTreeView
CXTPSkinObjectUser32Control
CXTPSliderPaintManager
CXTPSmartPtrInternalT
CXTPSortClass
CXTPSoundManager
CXTPSpinButtonCtrl
CXTPSplitPath
CXTPSplitterWnd
CXTPSplitterWndEx
CXTPSplitterWndTheme
CXTPSplitterWndThemeOffice2003
CXTPSplitterWndThemeOffice2013
CXTPSplitterWndThemeOfficeXP
CXTPSplitterWndThemeResource
CXTPSplitterWndThemeVisualStudio2010
CXTPSplitterWndThemeVisualStudio2015
CXTPSplitterWndThemeVisualStudio2017
CXTPSplitterWndThemeVisualStudio2019
CXTPSplitterWndThemeVisualStudio2022
CXTPStatusBar
CXTPStatusBarPane
CXTPStatusBarProgressPane
CXTPStatusBarScrollBarPane
CXTPStatusBarSliderPane
CXTPStatusBarSwitchPane
CXTPStatusBarThemeNativeWindows10
CXTPStatusBarThemeNativeWindows11
CXTPStatusBarThemeOffice2013
CXTPStatusBarThemeVisualStudio2015
CXTPStatusBarThemeVisualStudio2017
CXTPStatusBarThemeVisualStudio2019
CXTPStatusBarThemeVisualStudio2022
CXTPStickerBase
CXTPSubscriptionList
CXTPSvgImage
CXTPSvgPreviewProvider
CXTPSwitchViewButtonPart
CXTPSynchronized
CXTPSyntaxEditAutoCompleteWnd
CXTPSyntaxEditBatchCommand
CXTPSyntaxEditBufferCommand
CXTPSyntaxEditBufferCommand::CXTPSyntaxEditBufferKeepOverwriteSettings
CXTPSyntaxEditBufferManager
CXTPSyntaxEditColorComboBox
CXTPSyntaxEditColorInfo
CXTPSyntaxEditColorInfoArray
CXTPSyntaxEditColorSampleText
CXTPSyntaxEditColorTheme
CXTPSyntaxEditColorThemesManager
CXTPSyntaxEditCommand
CXTPSyntaxEditConfigurationManager
CXTPSyntaxEditCtrl
CXTPSyntaxEditDeleteStringCommand
CXTPSyntaxEditDoc
CXTPSyntaxEditDrawTextProcessor
CXTPSyntaxEditFileChangesMonitor
CXTPSyntaxEditFindReplaceDlg
CXTPSyntaxEditGoToLineDlg
CXTPSyntaxEditInsertStringCommand
CXTPSyntaxEditLexClass
CXTPSyntaxEditLexOnScreenParseCnt
CXTPSyntaxEditLexParser
CXTPSyntaxEditLexParserSchemaOptions
CXTPSyntaxEditLexTextBlock
CXTPSyntaxEditLexTextSchema
CXTPSyntaxEditLexTokensDef
CXTPSyntaxEditLexVariable
CXTPSyntaxEditLexVariant
CXTPSyntaxEditLineMarksManager
CXTPSyntaxEditOptions
CXTPSyntaxEditPaintManager
CXTPSyntaxEditPropertiesDlg
CXTPSyntaxEditPropertiesPageColor
CXTPSyntaxEditPropertiesPageEdit
CXTPSyntaxEditPropertiesPageFont
CXTPSyntaxEditReplaceStringCommand
CXTPSyntaxEditSelection
CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager
CXTPSyntaxEditTextIterator
CXTPSyntaxEditTextRegion
CXTPSyntaxEditTextSchemesManager
CXTPSyntaxEditTipComboBox
CXTPSyntaxEditTipListBox
CXTPSyntaxEditTipWnd
CXTPSyntaxEditToolTipCtrl
CXTPSyntaxEditUndoRedoManager
CXTPSyntaxEditView
CXTPSyntaxEditViewPrintOptions
CXTPSystemMetrics
CXTPSystemPreviewProvider
CXTPSystemVersion
CXTPTabBase
CXTPTabBaseTheme
CXTPTabBaseThemeOffice2003
CXTPTabBaseThemeOfficeXP
CXTPTabClientContext
CXTPTabClientDraggingContents
CXTPTabClientSticker
CXTPTabClientWnd
CXTPTabColorSetDefault
CXTPTabColorSetNativeWindows10
CXTPTabColorSetNativeWindows11
CXTPTabColorSetOffice2003
CXTPTabColorSetOffice2007
CXTPTabColorSetOffice2007Access
CXTPTabColorSetOffice2013
CXTPTabColorSetVisualStudio2008
CXTPTabColorSetVisualStudio2010
CXTPTabColorSetVisualStudio2012
CXTPTabColorSetVisualStudio2012Dark
CXTPTabColorSetVisualStudio2015
CXTPTabColorSetVisualStudio2017
CXTPTabColorSetVisualStudio2019
CXTPTabColorSetVisualStudio2022
CXTPTabControl
CXTPTabCtrl
CXTPTabCtrlButton
CXTPTabCtrlButtons
CXTPTabExBase
CXTPTabManager
CXTPTabManagerAtom
CXTPTabManagerItem
CXTPTabManagerNavigateButton
CXTPTabManagerNavigateButtons
CXTPTabPaintManager
CXTPTabPaintManagerColorSet
CXTPTabPaintManagerTheme
CXTPTabThemeExcel2003
CXTPTabThemeFlat
CXTPTabThemeNativeWindows10
CXTPTabThemeNativeWindows11
CXTPTabThemeOffice2000
CXTPTabThemeOffice2013
CXTPTabThemeVisualStudio2003
CXTPTabThemeVisualStudio2010
CXTPTabThemeVisualStudio2012
CXTPTabThemeVisualStudio2015
CXTPTabThemeVisualStudio2017
CXTPTabThemeVisualStudio2019
CXTPTabThemeVisualStudio2022
CXTPTabToolBar
CXTPTabView
CXTPTagCloudCtrl
CXTPTagCloudStyle
CXTPTagCloudStyleManager
CXTPTagCloudTagArray
CXTPTaskButtonTheme
CXTPTaskButtonThemeExpando
CXTPTaskDialog
CXTPTaskDialogClient
CXTPTaskDialogLinkCtrl
CXTPTaskDialogProgressCtrl
CXTPTaskPanel
CXTPTaskPanelExplorerTheme
CXTPTaskPanelExplorerThemePlain
CXTPTaskPanelGroup
CXTPTaskPanelGroupItem
CXTPTaskPanelGroupItems
CXTPTaskPanelGroups
CXTPTaskPanelItem
CXTPTaskPanelItems
CXTPTaskPanelListViewOffice2003Theme
CXTPTaskPanelListViewOfficeXPTheme
CXTPTaskPanelListViewTheme
CXTPTaskPanelNativeWindows10Theme
CXTPTaskPanelNativeWindows11Theme
CXTPTaskPanelOffice2003Theme
CXTPTaskPanelOffice2003ThemePlain
CXTPTaskPanelOffice2013Theme
CXTPTaskPanelOfficeXPThemePlain
CXTPTaskPanelPaintManager
CXTPTaskPanelPaintManagerPlain
CXTPTaskPanelScrollButton
CXTPTaskPanelShortcutBarOffice2003Theme
CXTPTaskPanelShortcutBarOffice2007Theme
CXTPTaskPanelToolboxTheme
CXTPTaskPanelVisualStudio2005Theme
CXTPTaskPanelVisualStudio2010Theme
CXTPTaskPanelVisualStudio2012Theme
CXTPTaskPanelVisualStudio2015Theme
CXTPTaskPanelVisualStudio2017Theme
CXTPTaskPanelVisualStudio2019Theme
CXTPTaskPanelVisualStudio2022Theme
CXTPTcbItem
CXTPTearOffFrame
CXTPTempColorMask
CXTPTextOnPath
CXTPTextPreviewProvider
CXTPThemeDLL
CXTPThreadLocal
CXTPTimeEdit
CXTPTipOfTheDay
CXTPTipWindow
CXTPToolBar
CXTPToolhelpApi
CXTPToolTipContext
CXTPToolTipContextToolTip
CXTPTrackBlock
CXTPTrackControl
CXTPTrackControlItem
CXTPTrackHeader
CXTPTrackKey
CXTPTrackMarker
CXTPTrackMarkers
CXTPTrackPaintManager
CXTPTrackSelectedBlocks
CXTPTrackThemeDefault
CXTPTrackThemeExplorer
CXTPTrackThemeNativeWindows10
CXTPTrackThemeNativeWindows11
CXTPTrackThemeOffice2003
CXTPTrackThemeOffice2003Luna
CXTPTrackThemeOffice2013
CXTPTrackThemeOfficeXP
CXTPTrackThemeResource
CXTPTrackThemeVisualStudio2012Blue
CXTPTrackThemeVisualStudio2012Dark
CXTPTrackThemeVisualStudio2012Light
CXTPTrackThemeVisualStudio2015
CXTPTrackThemeVisualStudio2017
CXTPTrackThemeVisualStudio2019
CXTPTrackThemeVisualStudio2022
CXTPTrackUndoAddBlockCommand
CXTPTrackUndoAddMarkerCommand
CXTPTrackUndoCommand
CXTPTrackUndoDeleteBlockCommand
CXTPTrackUndoDeleteMarkerCommand
CXTPTrackUndoGroupCommand
CXTPTrackUndoManager
CXTPTrackUndoSetBlockPositionCommand
CXTPTrackUndoSetMarkerPositionCommand
CXTPTransparentBitmap
CXTPTrayIcon
CXTPTreeBase
CXTPTreeCtrl
CXTPTreeNativeWindows10Theme
CXTPTreeNativeWindows11Theme
CXTPTreeOffice2013Theme
CXTPTreeTheme
CXTPTreeView
CXTPTreeVisualStudio2012Theme
CXTPTreeVisualStudio2015Theme
CXTPTreeVisualStudio2017Theme
CXTPTreeVisualStudio2019Theme
CXTPTreeVisualStudio2022Theme
CXTPVisualStudio2005Theme
CXTPVisualStudio2008Theme
CXTPVisualStudio2010Theme
CXTPWebBrowserCtrl
CXTPWebBrowserProvider
CXTPWebViewProvider
CXTPWinApp
CXTPWindowList
CXTPWindowPos
CXTPWindowRect
CXTPWinThemeWrapper
CXTPWinThread
CXTPXamlPreviewProvider
CXTPZipMemFile
D
CXTPTrackControl::DRAGBLOCK
E
CXTPCalendarData::EventsMapByID_T
XTP_CALENDAR_USERACTION_PARAMS::EXPANDDAYBUTTONACTION_PARAMS
G
CXTPControlGallery::GALLERYITEM_POSITION
H
CXTPColorHex::CRgnCell::CTX_DATA::HEXAGON_DATA
I
CXTPSortClass::ITEMDATA
ITimeProvider
IXTPApplicationEvents
IXTPFrameShadowManagerEvents
IXTPGaugeClientSite
IXTPMarkupClientSite
IXTPMarkupDeviceDependentImageSite
IXTPPreview
IXTPPreviewHost
IXTPPreviewProvider
IXTPScrollable
IXTPSkinManagerWindowFilter
IXTPWebBrowserEventSink
K
CXTPCommandBars::KEYBOARDTIPS
L
CXTPTaskDialogLinkCtrl::LINKITEM
N
NMXTPCHARHDR
NMXTPCONTROL
NMXTPSCROLL
NMXTPTABCHANGE
P
XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_DAILY
XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_MONTHLY
XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_MONTHNTH
XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_WEEKLY
XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_YEARLY
XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_YEARNTH
CXTPPopupControl::POPUPSTATE
R
CXTPCalendarReminder::RecurrenceEventInfo
CXTPCalendarTimeZones::REGISTRY_TIMEZONE_INFORMATION
CXTPTabManager::ROW_ITEMS
CXTPListBase::ROWCOLOR
S
XTP_CALENDAR_USERACTION_PARAMS::SCROLLDAYBUTTONACTION_PARAMS
CXTPDatePickerDaysCollection::SELECTED_BLOCK
CXTPCalendarView::SEventTimeFormatInfo
CXTPStatusBarSwitchPane::SWITCH
T
CXTPMarkupVisual::TransformationMatrices
X
XTP_CALENDAR_DAYVIEWCELL_PARAMS
XTP_CALENDAR_GETITEMTEXT_PARAMS
XTP_CALENDAR_HITTESTINFO
XTP_CALENDAR_HITTESTINFO_TIMELINE_VIEW
XTP_CALENDAR_MONTHVIEW_DAYPOS
XTP_CALENDAR_PATTERN_END
XTP_CALENDAR_RECURRENCE_OPTIONS
XTP_CALENDAR_THEME_DAYVIEWCELL_PARAMS
XTP_CALENDAR_THEME_DAYVIEWTIMESCALECELL_PARAMS
XTP_CALENDAR_TIMELINE_VIEW_SCALE
XTP_CALENDAR_USERACTION_PARAMS
XTP_CALENDAR_VIEWSELECTION
XTP_CALENDAR_WPARAM2
XTP_COMMANDBARS_CATEGORYINFO
XTP_COMMANDBARS_CREATEBAR
XTP_COMMANDBARS_CREATECONTROL
XTP_COMMANDBARS_ICONSINFO
XTP_COMMANDBARS_PROPEXCHANGE_PARAM
XTP_DAYITEM_METRICS
XTP_DOCKINGPANE_ACTION
XTP_DOCKINGPANE_CLICK
XTP_DOCKINGPANE_INFO
XTP_EDIT_ACDATA
XTP_EDIT_COLLAPSEDBLOCK
XTP_EDIT_COLORVALUES
XTP_EDIT_FONTOPTIONS
XTP_EDIT_LINECOL
XTP_EDIT_NMHDR_DOCMODIFIED
XTP_EDIT_NMHDR_EDITCHANGED
XTP_EDIT_NMHDR_ENABLESCROLLBAR
XTP_EDIT_NMHDR_MARGINCLICKED
XTP_EDIT_NMHDR_PARSEEVENT
XTP_EDIT_NMHDR_ROWCOLCHANGED
XTP_EDIT_NMHDR_SETSCROLLPOS
XTP_EDIT_ROWCOLRECT
XTP_EDIT_ROWSBLOCK
XTP_EDIT_SENMBOOKMARK
XTP_EDIT_TEXTBLOCK
XTP_EVENT_DRAG_OPERATION_PARAMS
XTP_EVENT_EDIT_OPERATION_PARAMS
XTP_EVENT_IN_PLACE_CREATE_EVENT_OPERATION_PARAMS
XTP_EVENT_PASTE_OPERATION_PARAMS
XTP_GRIDDATAMANAGER_COM_ERROR
XTP_GRIDRECORDITEM_ARGS
XTP_GRIDRECORDITEM_CLICKARGS
XTP_GRIDRECORDITEM_DRAWARGS
XTP_GRIDRECORDITEM_METRICS
XTP_IMAGERESOURCE_INFO
XTP_LC_TIMEFORMAT
XTP_LVITEMDATA
XTP_NC_DATEPICKER_BUTTON
XTP_NM_FLOWGRAPH_CONNECTIONCHANGED
XTP_NM_FLOWGRAPH_CONNECTIONCHANGING
XTP_NM_FLOWGRAPH_ENDLABELEDIT
XTP_NM_FLOWGRAPH_NODECHANGED
XTP_NM_GRID_BEFORE_COPYPASTE
XTP_NM_GRIDCOLUMNORDERCHANGED
XTP_NM_GRIDCOLUMNRESIZE
XTP_NM_GRIDCONSTRAINTSELECTING
XTP_NM_GRIDDRAGDROP
XTP_NM_GRIDGIVEFEEDBACK
XTP_NM_GRIDINPLACEBUTTON
XTP_NM_GRIDITEMCONTROL
XTP_NM_GRIDITEMMETRICS
XTP_NM_GRIDPREVIEWKEYDOWN
XTP_NM_GRIDRECORDITEM
XTP_NM_GRIDREQUESTEDIT
XTP_NM_GRIDROWRESIZE
XTP_NM_GRIDSCROLL
XTP_NM_GRIDSTATECHANGED
XTP_NM_GRIDTOOLTIPINFO
XTP_NM_SELECTION_CHANGING
XTP_NM_TRACKCONTROL
XTP_PICK_BUTTON
XTP_PROPERTYGRID_NOTIFYEDIT
XTP_RESIZEPOINT
XTP_RESIZERECT
XTP_RESOURCEMANAGER_LANGINFO
XTP_SCROLLBAR_POSINFO
XTP_SCROLLBAR_TRACKINFO
XTP_SCROLLBARDRAWCOLORS
XTP_SCROLLBARINICOLORS
XTP_SLIDERTICKS
XTP_TAGCLOUDTAG
XTP_TASKPANEL_GROUPCOLORS
XTP_TPNENDLABELEDIT
XTP_TPNGROUPEXPANDING
XTP_TVITEMDATA
XTP_URI
XTP_URI_DEFAULTS
XTP_WEEK_VIEW_LAYOUT
XTPGridInputState
XTPPROGRESSDRAWSTRUCT
XTPRIBBON_HEADER_COLOR


Toolkit Pro: Class Hierarchy

Class Hierarchy

Go to the graphical class hierarchy

This inheritance list is sorted roughly, but not completely, alphabetically:
[detail level 12345678910]
C CXTPNotifySinkBase::ADVISE_DESCRIPTOR | This struct is used in to store connection between a Connection object(s), Notification code and the sink object
C CXTPSyntaxEditCtrl::CAverageVal | CXTPSyntaxEditCtrl::CAverageVal
C CXTPSkinObjectFrame::CCaptionButton | Caption button class
C CXTPCheckListBox::CCheckListState | CCheckListState is a helper class used by CXTPCheckListBox that contains information about the checkbox image that is used by the check list box
C CXTPDockingPaneWindowSelect::CColumn | Column description
C CXTPNotifyConnection::CEmptySyncObject | This struct is derived from CSyncObject and should be used instead of CCriticalSection to improve performance and to provide compatibility
C CXTPRWCriticalSection::CExclusiveLock | A convenience class for obtaining exclusive lock for a scope
C CXTPDockingPaneWindowSelect::CItem | Item description
C CXTPSimpleCriticalSection::CLock | A helper class for locking a scope or providing exception safe locking
C CXTPPaintManager::CLogFont | CLogFont is a self initializing LOGFONT derived class
C CXTPTreeBase::CLRFONT | CLRFONT structure is used to by the CXTPShellTreeCtrl and CXTPShellTreeView classes to maintain font information for a particular tree item
C CXTPResourceManager::CManageState | CManageState is used internally by the toolkit to switch module states
C CXTPCalendarMonthView::CMonthViewGrid |
C CXTPColorSelectorCtrl::COLOR_CELL | COLOR_CELL structure is used by the CXTPColorSelectorCtrl class to maintain information about a particular color cell
C CXTPTabPaintManagerColorSet::COLORSET_TAB_EXCEL | Colors used for Excel tab button colorization
C CXTPTabPaintManagerColorSet::COLORSET_TAB_PROPERTYPAGE | Colors used for Office 2000 tab button colorization
C CXTPTabPaintManagerColorSet::COLORSET_TAB_PROPERTYPAGE2003 | Colors used for Office 2003 tab button colorization
C CXTPTabPaintManagerColorSet::COLORSET_TAB_STATEBUTTON | Colors used for "State Button" tab button colorization
C CXTPNotifyConnection::CONNECTION_DESCRIPTOR | This struct is used in the implementation of the class CXTPNotifyConnection to store connection between a Connection object, Notification code and the sink object
C CXTPShortcutListBox::CONTENT_ITEM | CONTENT_ITEM structure is used by the CXTPShortcutListBox class to maintain information about a particular menu item
C CXTPTaskPanel::CRepositionContext | CRepositionContext is a helper class used to lock/unlock redraw for the Task Panel
C CXTPColorHex::CRgnCell | CRgnCell is a CRgn derived class used by the CXTPColorHex to create individual color cells
C CXTPTabManager::CRowIndexer | Helper class used to collect the indices of rows for a multi-row tab manager
C CXTPCalendarView::CSelectionChanged_ContextData | This class defines an internal structure used as a counter on selection changes, which is needed to redraw a view when necessary
C CXTPCalendarView::CSelectionChangedContext | Class CSelectionChangedContext is used to avoid multiple sending of an XTP_NC_CALENDAR_SELECTION_CHANGED notification for one selection changing operation
C CXTPRWCriticalSection::CSharedLock | A convenience class for obtaining shared lock for a scope
C CXTPShellPidl::CShellMalloc | CXTPShellPidl::CShellMalloc is a helper class that is used by CXTPShellPidl to initialize a pointer to the Shell's IMalloc interface used for allocating memory blocks
C CXTPShellPidl::CShellSpecialFolder | CXTPShellPidl::CShellSpecialFolder is a helper class that is used by CXTPShellPidl to initialize a pointer to an ITEMIDLIST structure of a special folder
C CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager::CStringPtrArray | Internal class, implements a collection of strings
C CXTPMouseManager::CTrackArray | Array of the tracking bars
C CXTPColorHex::CRgnCell::CTX_DATA | Contains pre-computed hexagon data for both small and big hexagons
C CXTPCalendarControl::CUpdateContext | Class CUpdateContext updates context and redraws control parts depending on input parameters
C CXTPGridControl::CUpdateContext | Internal grid update helper
C CXTPCalendarControl::CViewChanged_ContextData | Class CViewChanged_ContextData is used as locker context for CViewChangedContext
C CXTPCalendarControl::CViewChangedContext | Class CViewChangedContext used to avoid multiple sending of XTP_NC_CALENDARVIEWWASCHANGED notification for one action
C CXTPActiveScriptObjectContext | Wrapper around scriptable object
C CXTPAlphaWnd | CXTPTabClientAlphaWnd is CWnd derived class represents alpha context helper window
C CXTPAnimationDC | CXTPAnimationDC is a CXTPBufferDC derived class
C CXTPArcBall | Implements natural object rotation computation using quaternions
C CXTPAsyncGuard< Adaptee, RWLock > | A convenience class for guarding an adapted object reference by a RW-lock provided
C CXTPAutoResetValue< _TValue > | Helper class template provides functionality to temporary set some to variable and reset to initial or other value on destroy
C CXTPAuxData | CXTPAuxData is a standalone global item data structure class
C CXTPBatchAllocObjT< _TObject, _TBatchAllocData, _TAllocator > | This template class used as a helper class to override new/delete operators and use batch allocation inside them
C CXTPBrowseDialog | CXTPBrowseDialog is derived from the BROWSEINFO structure
►C CXTPButton | Push Button control
C CXTPBrowseButton | CXTPBrowseButton is a CXTPButton derived class
C CXTPCaptionButton | CXTPCaptionButton is a CXTPButton derived class
C CXTPColorPicker | CXTPColorPicker is a CXTPButton derived class
C CXTPResizeGroupBox | CXTPResizeGroupBox is a CButton derived class that can be used to display a flicker free group box while resizing
C CXTPCalendarCaptionBarControl | CXTPCalendarCaptionBarControl represents CalendarCaptionBar control and used as a part of CXTPCalendarControl object
►C CXTPCalendarComboBoxBase | This class is used as the base class for all owner drawn Calendar Event comboboxes
C CXTPCalendarBusyStatusComboBox | This class implements the busy status selector combobox
C CXTPCalendarEventCategoryComboBox | This class implements the event category selector combobox
C CXTPCalendarEventLabelComboBox | This class implements the event label selector combobox
C CXTPCalendarControl | Class CXTPCalendarControl implements the calendar's view interface
C CXTPCalendarControlView | Implementation of the Calendar control as a view class
C CXTPCalendarControlViewPrintOptions | Describes printing options for the Calendar Control
C CXTPCalendarEventColorDlg | This class is used to edit Calendar Event Category and Label information
C CXTPCalendarEventColorEdit | This class is used by CXTPCalendarEventColorListBox to create an inplace edit box for renaming event categories and labels
C CXTPCalendarEventColorListBox | This class is used to display a list of Calendar Event Categories or Labels that can be edited
C CXTPCalendarEventColorNewDlg | This class is used to add new Calendar Event Categories or Labels to the existing data array
C CXTPCalendarEventPropertiesDlg | This class is used to edit calendar event properties
C CXTPCalendarEventRecurrenceDlg | This class is used for manipulations with recurrence state of the events
C CXTPCalendarMsgNotifier | This class is used to catch windows messages, which the system sends to top-level windows, and to send them to subscribers windows
C CXTPCalendarOccurSeriesChooseDlg | This class implements a dialog to choose between current occurrence and whole recurrence event series (or pattern)
C CXTPCalendarPageSetupDialog | Customized Calendar control page setup dialog
C CXTPCalendarReminderForOccurrenceArray | This class implements a collection of CXTPCalendarReminderForOccurrence objects as well as some common operations on it
C CXTPCalendarRemindersDialog | This class used to display calendar reminders
C CXTPCalendarRemindersManager | This class is used to monitor and manage calendar events reminders
C CXTPCalendarShadowDrawer | This is a helper class which handles shadows drawing (for events, etc)
C CXTPCalendarThemeCustomizableXValueT< _TValue, _TValueRef > | Helper class template provides functionality to manage customized value for the specified type
►C CXTPCalendarThemeCustomizableXValueT< BOOL, BOOL > |
C CXTPCalendarThemeBOOLValue | Helper class provides functionality to manage customized BOOL value objects
►C CXTPCalendarThemeCustomizableXValueT< CRect, CRect > |
C CXTPCalendarThemeRectValue | Helper class provides functionality to manage customized CRect value objects
►C CXTPCalendarThemeCustomizableXValueT< CString, LPCTSTR > |
C CXTPCalendarThemeStringValue | Helper class provides functionality to manage customized string value objects
►C CXTPCalendarThemeCustomizableXValueT< int, int > |
C CXTPCalendarThemeIntValue | Helper class provides functionality to manage customized int value objects
C CXTPCalendarTip | Emulates the functionality of a "tool tip" control
C CXTPCalendarTypedPtrAutoDeleteArray< BASE_CLASS, PTR_TYPE > | This class represents a simple array collection of objects pointers
C CXTPCalendarTypedPtrAutoDeleteArray< CPtrArray, CMemFile * > |
C CXTPCalendarTypedPtrAutoDeleteArray< CPtrArray, CXTPCalendarViewPartBrushValue * > |
C CXTPCalendarTypedPtrAutoDeleteMap< KEY, TPtr > | This class represents a simple map of typed keys to typed objects pointers
C CXTPCalendarTypedPtrAutoDeleteMap< int, CXTPCalendarViewPartBrushValue * > |
C CXTPCalendarUtils | Helper class with static member functions to perform common tasks with dates, events and other objects
►C CXTPCalendarViewEventSubjectEditor | This class is used to edit an event subject
C CXTPCalendarViewEventSubjectEditorColored | This class is used to edit event subject in Office 2007 Theme
C CXTPCalendarViewPartCustomizableValueT< _TValue > | Helper class template provides functionality to manage customized values for the specified class objects
►C CXTPCalendarViewPartCustomizableValueT< CBrush > |
C CXTPCalendarViewPartBrushValue | Helper class provides functionality to manage brush value objects
►C CXTPCalendarViewPartCustomizableValueT< CFont > |
C CXTPCalendarThemeFontValue | Helper class provides functionality to manage font value objects
C CXTPCalendarViewPartFontValue | Helper class provides functionality to manage font settings for various graphical elements of control
C CXTPCaption | CXTPCaption is a CStatic derived class
C CXTPCaptionPopupWnd | CXTPCaptionPopupWnd is a CWnd derived class
C CXTPChart3dBox | Represents a 3D box build around included points and provides useful and fast operations
C CXTPChart3dRotation | Represents a 3D rotation primitive for chart objects using Euler angles Yaw, Pitch and Roll in degrees
C CXTPChartAxisViewTick | This class represents a tick mark in the axis
C CXTPChartColor | This class abstracts a color entity
►C CXTPChartContainer | This class represents the chart container
C CXTPChartControl | CXTPChartControl is a CWnd derived class
►C CXTPChartDeviceCommandEvents | Defines a callback interface for a chart device command event sink
►C CXTPChart3dFunnelDeviceCommandEvents | Defines interface for 3D chart funnel device command event sink
C CXTPChart3dFunnelSeriesPointView | This class abstracts the view of a funnel series point
C CXTPChart3dFunnelSeriesLabelsViewDeviceCommand | Represents device command for all funnel series labels view
►C CXTPChart3dPieDeviceCommandEvents | Defines interface for 3D chart pie device command event sink
C CXTPChart3dPieSeriesPointView | This class abstracts the view of a pie series point
C CXTPChart3dPieSeriesLabelsViewDeviceCommand | Represents device command for all pie series labels view
►C CXTPChart3dPyramidDeviceCommandEvents | Defines interface for 3D chart pyramid device command event sink
C CXTPChart3dPyramidSeriesPointView | This class abstracts the view of a pyramid series point
C CXTPChart3dPyramidSeriesLabelsViewDeviceCommand | Represents device command for all pyramid series labels view
C CXTPChartDiagramDomain | Represents a virtual diagram rectangular domain area
►C CXTPChartDrawingObjectFactory | Provides a set of factory methods for creating drawing device commands and a base class interface for an abstract drawing object factory
C CXTPChart2dDrawingObjectFactory | Implements a 2D drawing object factory singleton
C CXTPChart3dDrawingObjectFactory | Implements a 3D drawing object factory singleton
C CXTPChartEllipse | This class abstracts an ellipse
►C CXTPChartFunnelDiagramBase< BaseDiagram > | This class abstracts the funnel diagram
C CXTPChart3dFunnelDiagram | This class abstracts the funnel diagram
C CXTPChartFunnelDiagram | This class abstracts the funnel diagram
►C CXTPChartLegendItemView | CXTPChartLegendItemView is an abstract base class which represents a chart legend item
C CXTPChartAxisConstantLine | CXTPChartAxisConstantLine is a hybrid object derived from CXTPChartTextElement and CXTPChartLegendItemView
C CXTPChartAxisStrip | This is a hybrid object of CXTPChartElement and CXTPChartLegendItemView
►C CXTPChartSeriesPointView | Represents chart series point view
►C CXTPChartBarSeriesPointView | This class represents the view of a bar series point, which is a kind of CXTPChartPointSeriesPointView
►C CXTPChartRangeBarSeriesPointView | This class represents the view of a RangeBar series point, which is a kind of CXTPChartPointSeriesPointView
C CXTPChartGanttSeriesPointView | This class represents the view of a Gantt series point, which is a kind of CXTPChartPointSeriesPointView
C CXTPChartStackedBarSeriesPointView | This class represents the view of a bar series point, which is a kind of CXTPChartPointSeriesPointView
C CXTPChartCandleStickSeriesPointView | This class represents the view of a candle stick series point, which is a kind of CXTPChartSeriesPointView
►C CXTPChartFunnelSeriesPointViewBase | This class abstracts the view of a funnel series point
C CXTPChart3dFunnelSeriesPointView | This class abstracts the view of a funnel series point
C CXTPChartFunnelSeriesPointView | This class abstracts the view of a funnel series point
C CXTPChartHighLowSeriesPointView | This class abstracts the view of the stock series point of the chart
►C CXTPChartPieSeriesPointViewBase | This class abstracts the view of a pie series point
C CXTPChart3dPieSeriesPointView | This class abstracts the view of a pie series point
C CXTPChartPieSeriesPointView | This class abstracts the view of a pie series point
►C CXTPChartPointSeriesPointView | This class represents the view of a point series point, which is a kind of CXTPChartSeriesPointView
C CXTPChartBubbleSeriesPointView | This class represents the view of a bubble series point, which is a kind of CXTPChartPointSeriesPointView
C CXTPChartRangeSplineAreaSeriesPointView | This class represents the view of a RangeBar series point, which is a kind of CXTPChartPointSeriesPointView
C CXTPChartStepLineSeriesPointView | This class represents the view of a step line series point, which is a kind of CXTPChartSeriesPointView
►C CXTPChartPyramidSeriesPointViewBase | This class abstracts the view of a pyramid series point
C CXTPChart3dPyramidSeriesPointView | This class abstracts the view of a pyramid series point
C CXTPChartPyramidSeriesPointView | This class abstracts the view of a pyramid series point
C CXTPChartRadarPointSeriesPointView | This class represents the view of a point series point, which is a kind of CXTPChartSeriesPointView
►C CXTPChartObject | A base class for all chart objects
►C CXTPChartDeviceCommand | Defines a common implementation interface for chart drawing commands
►C CXTPChart3dDeviceCommand | Defines a common implementation interface for chart 3D drawing commands
C CXTPChart3dFunnelSeriesLabelDeviceCommand | Implements 3D chart funnel series label device command
C CXTPChart3dFunnelSeriesLabelsViewDeviceCommand | Represents device command for all funnel series labels view
C CXTPChart3dPieDeviceCommand | Base class implementation for 3D pie chart device command
C CXTPChart3dPieSeriesLabelDeviceCommand | Implements 3D chart pie series label device command
C CXTPChart3dPieSeriesLabelsViewDeviceCommand | Represents device command for all pie series labels view
C CXTPChart3dPyramidSeriesLabelDeviceCommand | Implements 3D chart pyramid series label device command
C CXTPChart3dPyramidSeriesLabelsViewDeviceCommand | Represents device command for all pyramid series labels view
C CXTPChart3dRotateDeviceCommand | Base class implementation for 3D chart rotation device command
C CXTPChart3dTranslateDeviceCommand | Base class implementation for 3D chart translation device command
C CXTPChart3dLineDeviceCommand | Provides an interface for 3D line drawing device command
C CXTPChartBoundedCircleDeviceCommand | This class represents a bounded circle device command, which is a kind of CXTPChartDeviceCommand
C CXTPChartBoundedPolygonDeviceCommand | Base class implementation for 2D chart bounded polygon device command
C CXTPChartCircleDeviceCommand | This class is the base class for all circle device commands
C CXTPChartClipDeviceCommand | Base class implementation for 2D chart clipping device command
C CXTPChartHitTestElementCommand | Defines a base class interface for a 2D hit test command
C CXTPChartLineDeviceCommand | Provides an interface for 2D line drawing device command
C CXTPChartMarkupElementDeviceCommand | Implements 2D markup element drawing device command
C CXTPChartPieDeviceCommand | Base class implementation for 2D pie chart device command
C CXTPChartPolygonAntialiasingDeviceCommand | Base class implementation for 2D chart antialiased polygon device command
C CXTPChartPolygonDeviceCommand | Base class implementation for 2D chart polygon device command
C CXTPChartPolylineDeviceCommand | Provides an interface for 2D poly-line drawing device command
C CXTPChartRectangleDeviceCommand | Base class implementation for 2D chart rectangle device command
C CXTPChartRotateDeviceCommand | Base class implementation for 2D chart rotation device command
C CXTPChartSolidSplinePolygonDeviceCommand | Base class implementation for 2D chart solid spline polygon device command
C CXTPChartSplineDeviceCommand | Provides an interface for 2D spline drawing device command
C CXTPChartTextAntialiasingDeviceCommand | This class represents a text device command, which is a kind of CXTPChartDeviceCommand
►C CXTPChartTextDeviceCommand | This class represents a text device command, which is a kind of CXTPChartDeviceCommand
C CXTPChartBoundedTextDeviceCommand | This class represents a bounded text device command, which is a kind of CXTPChartDeviceCommand
C CXTPChartTranslateDeviceCommand | Base class implementation for 2D chart translation device command
►C CXTPChartElement | This class abstracts a chart element, this class acts as a base class for all chart elements
►C CXTPChartAxis | This abstract base class represents a chart axis as a kind of chart element
C CXTPChartAxisX | CXTPChartAxisX is a derived class from the CXTPChartAxis class and represents the X axis of a chart
C CXTPChartAxisY | CXTPChartAxisY is a derived class from the CXTPChartAxis class and represents the Y axis of a chart
C CXTPChartRadarAxisX | CXTPChartRadarAxisX is a derived class from the CXTPChartAxis class and represents the X axis of a chart
C CXTPChartRadarAxisY | CXTPChartRadarAxisY is a derived class from the CXTPChartAxis class and represents the Y axis of a chart
C CXTPChartAxisCustomLabel | CXTPChartAxisCustomLabel is a CXTPChartElement derived class
C CXTPChartAxisGridLines | CXTPChartAxisGridLines is a kind of CXTPChartElement, This class represents the grid lines parallel to an axis
C CXTPChartAxisRange | This class represents the value range of the axis
C CXTPChartAxisStrip | This is a hybrid object of CXTPChartElement and CXTPChartLegendItemView
C CXTPChartAxisTickMarks | This class represents the tick marks in an axis
C CXTPChartBorder | This class abstracts the border of a chart, it is a kind of chart element
C CXTPChartContent | This class represents chart content, which is a kind of CXTPChartElement
►C CXTPChartElementAppearance | This class represents the appearance of a chart element
C CXTPChartAppearance | This class represents the appearance of the chart
C CXTPChartAxisAppearance | This class represents the appearance of a chart axis.This class is is subclassed from CXTPChartElementAppearance class
C CXTPChartContentAppearance | This class represents the appearance of a chart content
C CXTPChartDiagram2DAppearance | This class represents the appearance of diagram in 2D
C CXTPChartDiagram3DAppearance | This class represents the appearance of diagram in 3D
C CXTPChartLegendAppearance | This class represents the appearance of a chart legend
C CXTPChartTitleAppearance | This class represents the appearance of a chart title
►C CXTPChartElementCollection | This class abstracts a chart collection
C CXTPChartAxisConstantLines | This class encapsulates a collection of CXTPChartAxisConstantLine objects
C CXTPChartAxisCustomLabels | This class encapsulates a collection of CXTPChartAxisCustomLabel objects
C CXTPChartAxisStrips | This class encapsulates a collection of chart axis strip objects
C CXTPChartPanelCollection | This class abstracts a chart panel collection
C CXTPChartSeriesCollection | This class represents the collection of series in the chart, which is a kind of CXTPChartElement
C CXTPChartSeriesPointCollection | CXTPChartSeriesPointCollection class represents a collection of chart series points
C CXTPChartTitleCollection | CXTPChartTitleCollection represents a collection of chart titles
C CXTPChartMarker | This class abstracts a marker used in marking the points in a point series style chart
C CXTPChartNumberFormat | This class helper is used to format number to string
C CXTPChartPalette | This class abstracts a color palette
►C CXTPChartPanel | This class abstracts a chart panel
►C CXTPChartDiagram | This class represents a chart diagram, which is a kind of CXTPChartElement
C CXTPChart2dDiagram | The base class for all 2D diagrams
C CXTPChart3dDiagram | The base class for all 3D diagrams
C CXTPChartDiagram2D | This class represents a chart 2D diagram, which is a kind of CXTPChartDiagram
C CXTPChartRadarDiagram | This class represents a chart 2D diagram, which is a kind of CXTPChartDiagram
►C CXTPChartScaleTypeMap | This class abstracts a scale type map
C CXTPChartDateTimeScaleTypeMap | This class is a kind of CXTPChartScaleTypeMap, which abstracts a date-time scale type for an axis
C CXTPChartNumericalScaleTypeMap | This class is a kind of CXTPChartScaleTypeMap, which abstracts a numeric scale type for an axis
C CXTPChartQualitativeScaleTypeMap | This class abstracts a scale type map, which represents qualitative values
C CXTPChartTimeScaleTypeMap | This class is a kind of CXTPChartScaleTypeMap, which abstracts a time scale type for an axis
C CXTPChartSeries | This class represents a series in the chart, which is a kind of CXTPChartElement
C CXTPChartSeriesPoint | CXTPChartSeriesPoint is a kind of CXTPChartElement
►C CXTPChartSeriesStyle | CXTPChartSeriesStyle is a CXTPChartElement derived class
►C CXTPChartDiagram2DSeriesStyle | This class represents a line series style, which is a kind of CXTPChartSeriesStyle
►C CXTPChartBarSeriesStyle | This class represents a bar series style for the chart, which is a kind of CXTPChartSeriesStyle
►C CXTPChartRangeBarSeriesStyle | This class represents a RangeBar series style for the chart, which is a kind of CXTPChartBarSeriesStyle
C CXTPChartGanttSeriesStyle | This class represents a Gantt series style for the chart, which is a kind of CXTPChartBarSeriesStyle
C CXTPChartStackedBarSeriesStyle | This class represents a bar series style for the chart, which is a kind of CXTPChartSeriesStyle
C CXTPChartFastLineSeriesStyle | This class represents a line series style, which is a kind of CXTPChartPointSeriesStyle
►C CXTPChartHighLowSeriesStyle | This class represents the stock series style in the chart
C CXTPChartCandleStickSeriesStyle | This class represents a candle stick series style, which is a kind of CXTPChartHighLowSeriesStyle
►C CXTPChartPointSeriesStyle | This class represents a line series style, which is a kind of CXTPChartSeriesStyle
►C CXTPChartAreaSeriesStyle | CXTPChartAreaSeriesStyle is a CXTPChartPointSeriesStyle derived class which represents the area series style
C CXTPChartRangeSplineAreaSeriesStyle | CXTPChartRangeSplineAreaSeriesStyle is a CXTPChartAreaSeriesStyle derived class which represents the area series style
C CXTPChartSplineAreaSeriesStyle | This class represents a spline area series style, which is a kind of CXTPChartAreaSeriesStyle
►C CXTPChartStackedAreaSeriesStyle | CXTPChartStackedAreaSeriesStyle is a CXTPChartAreaSeriesStyle derived class which represents the area series style
C CXTPChartStackedSplineAreaSeriesStyle | CXTPChartStackedSplineAreaSeriesStyle is a CXTPChartStackedAreaSeriesStyle derived class which represents the area series style
C CXTPChartStepAreaSeriesStyle | This class represents a StepArea series style, which is a kind of CXTPChartAreaSeriesStyle
C CXTPChartBubbleSeriesStyle | This class represents a bubble series style, which is a kind of CXTPChartPointSeriesStyle
►C CXTPChartLineSeriesStyle | This class represents a line series style, which is a kind of CXTPChartPointSeriesStyle
C CXTPChartScatterLineSeriesStyle | This class represents a line series style, which is a kind of CXTPChartPointSeriesStyle
C CXTPChartSplineSeriesStyle | This class represents the spline series style in the chart
C CXTPChartStepLineSeriesStyle | This class represents a StepLine series style, which is a kind of CXTPChartLineSeriesStyle
►C CXTPChartFunnelSeriesStyleBase | This class abstracts the basic style of a funnel serie.This class is a kind of CXTPChartSeriesStyle
C CXTPChart3dFunnelSeriesStyle | This class abstracts the basic style of a funnel series
C CXTPChartFunnelSeriesStyle | This class abstracts the basic style of a funnel series
►C CXTPChartPieSeriesStyleBase | This class abstracts the basic style of a pie serie.This class is a kind of CXTPChartSeriesStyle
C CXTPChart3dPieSeriesStyle | This class abstracts the pie series style
C CXTPChartPieSeriesStyle | This class abstracts the pie series style
►C CXTPChartPyramidSeriesStyleBase | This class abstracts the basic style of a pyramid series
C CXTPChart3dPyramidSeriesStyle | This class abstracts the basic style of a pyramid series
C CXTPChartPyramidSeriesStyle | This class abstracts the basic style of a pyramid series
►C CXTPChartRadarDiagramSeriesStyle | This class represents a base radar series style, which is a kind of CXTPChartSeriesStyle
►C CXTPChartRadarPointSeriesStyle | This class represents a line series style, which is a kind of CXTPChartSeriesStyle
►C CXTPChartRadarAreaSeriesStyle | This class represents a line series style, which is a kind of CXTPChartSeriesStyle
C CXTPChartRadarSplineAreaSeriesStyle | This class represents a spline area series style, which is a kind of CXTPChartRadarAreaSeriesStyle
►C CXTPChartRadarLineSeriesStyle | This class represents a line series style, which is a kind of CXTPChartSeriesStyle
C CXTPChartRadarSplineSeriesStyle | This class represents the spline series style in the chart
►C CXTPChartTextElement | This class abstracts a chart text element
C CXTPChartAxisConstantLine | CXTPChartAxisConstantLine is a hybrid object derived from CXTPChartTextElement and CXTPChartLegendItemView
C CXTPChartAxisLabel | CXTPChartAxisLabel is a kind of CXTPChartTextElement
C CXTPChartAxisTitle | This class represents the axis title
C CXTPChartLegend | This class represents a chart legend as a kind of chart element
►C CXTPChartSeriesLabel | This class abstracts the label of a series
C CXTPChartBubbleSeriesLabel | CXTPChartBubbleSeriesLabel is a kind of CXTPChartSeriesLabel
►C CXTPChartDiagram2DSeriesLabel | This class abstracts the label of a point series
C CXTPChartBarSeriesLabel | This class abstracts the label of a bar series
►C CXTPChartPointSeriesLabel | This class abstracts the label of a point series
C CXTPChartRangeAreaSeriesLabel | This class abstracts the label of a bar series
C CXTPChartRangeBarSeriesLabel | This class abstracts the label of a bar series
►C CXTPChartFunnelSeriesLabelBase | CXTPChartFunnelSeriesLabelBase is a kind of CXTPChartSeriesLabel
C CXTPChart3dFunnelSeriesLabel | CXTPChartFunnelSeriesLabelBase is a kind of CXTPChart3dFunnelSeriesLabel
C CXTPChartFunnelSeriesLabel | CXTPChartFunnelSeriesLabel is a kind of CXTPChartSeriesLabel
►C CXTPChartPieSeriesLabelBase | CXTPChartPieSeriesLabelBase is a kind of CXTPChartSeriesLabel
C CXTPChart3dPieSeriesLabel | CXTPChartPieSeriesLabelBase is a kind of CXTPChart3dPieSeriesLabel
C CXTPChartPieSeriesLabel | CXTPChartPieSeriesLabelBase is a kind of CXTPChartPieSeriesLabel
►C CXTPChartPyramidSeriesLabelBase | This class abstracts the pyramid series label
C CXTPChart3dPyramidSeriesLabel | CXTPChartPyramidSeriesLabelBase is a kind of CXTPChart3dPyramidSeriesLabel
C CXTPChartPyramidSeriesLabel | CXTPChartPyramidSeriesLabel is a kind of CXTPChartSeriesLabel
C CXTPChartRadarPointSeriesLabel | This class abstracts the label of a point series
C CXTPChartTitle | This class represents a chart title
►C CXTPChartElementView | This class represents the view of a chart element
C CXTPChart3dFunnelSeriesLabelsView | Represents a view object for all funnel series labels
C CXTPChart3dPyramidSeriesLabelsView | Represents a view object for all pyramid series labels
C CXTPChartContentView | This class represents the view of the chart content, which is a kind of CXTPChartElementView
►C CXTPChartDiagramView | This class represents the view of a chart diagram, which is a kind of CXTPChartElementView
►C CXTPChart3dDiagramView | This class represents the view of a chart diagram, which is a kind of CXTPChartElementView
C CXTPChart3dFunnelDiagramView | This class abstracts the view of a funnel diagram
C CXTPChart3dPieDiagramView | This class abstracts the view of a pie diagram
C CXTPChart3dPyramidDiagramView | This class abstracts the view of a pyramid diagram
C CXTPChartDiagram2DView | This class represents the view of a chart 2D diagram, which is a kind of CXTPChartDiagramView
C CXTPChartFunnelDiagramView | This class abstracts the view of a funnel diagram
C CXTPChartPieDiagramView | This class abstracts the view of a pie diagram
C CXTPChartPyramidDiagramView | This class abstracts the view of a pyramid diagram
C CXTPChartRadarDiagramView | This class represents the view of a chart 2D diagram, which is a kind of CXTPChartDiagramView
C CXTPChartLegendView | This class abstracts the view of a legend and its child items in a bounding rectangle context
►C CXTPChartPieSeriesLabelsViewBase | Defines a base class interface for series label collection view
C CXTPChart3dPieSeriesLabelsView | Represents a view object for all pie series labels
C CXTPChartPieSeriesLabelsView | Defines 2D series label collection view
C CXTPChartSeriesPointView | Represents chart series point view
C CXTPChartPaletteEntry | This class represents a palette entry, which abstracts two 32 bit color values of type ARGB
►C CXTPChartPieBase | This class abstracts a pie chart
C CXTPChart3dPie | This class abstracts a pie chart
C CXTPChartPie | This class abstracts a pie chart
►C CXTPChartPieDeviceCommandImpl | This class is a common implementation for a pie chart device command
C CXTPChart3dPieDeviceCommand | Base class implementation for 3D pie chart device command
C CXTPChartPieDeviceCommand | Base class implementation for 2D pie chart device command
►C CXTPChartPieDiagramBase< BaseDiagram > | This class abstracts the pie diagram
C CXTPChart3dPieDiagram | This class abstracts the pie diagram
C CXTPChartPieDiagram | This class abstracts the pie diagram
►C CXTPChartPyramidDiagramBase< BaseDiagram > | This class abstracts the pyramid diagram
C CXTPChart3dPyramidDiagram | This class abstracts the pyramid diagram
C CXTPChartPyramidDiagram | This class abstracts the pyramid diagram
C CXTPChartRadarAxisXViewTick | This class represents a tick mark in the axis
C CXTPChartRadarAxisYViewTick | This class represents a tick mark in the axis
C CXTPChartStrings | This class is a collection class of strings
►C CXTPChartTextPainterBase | This abstract class represents a text painter which is used for drawing various text elements in the chart
►C CXTPChartRotatedTextPainterBase | This abstract base class represents a rotated text painter which is used for drawing various rotated text elements in the chart
C CXTPChartRotatedTextPainterNearLine | This abstract base class renders a rotated text near a line which is used for drawing various rotated text elements near lines in the chart
C CXTPChartTextPainter | This class represents a text painter which is used for drawing various text elements in the chart
C CXTPClientCursorPos | CXTPClientCursorPos is a helper class used to retrieve the cursor position in client coordinates
C CXTPClientRect | CXTPClientRect is a helper class used to retrieve the client area for a specified window
►C CXTPCmdTarget | Extends functionality of CCmdTarget and introduces workarounds for known issues and limitations of CCmdTarget
►C CXTPArrayT< UINT, UINT > |
►C CXTPCalendarUIntArray | This class represents the collection of UINT elements
C CXTPCalendarEventCategoryIDs | This class represents the collection of event categories IDs
C CXTPCalendarIconIDs | This class represents the collection of custom icons IDs
►C CXTPCalendarPtrCollectionT< CXTPCalendarEventCategory > |
C CXTPCalendarEventCategories | This class is used as a collection of CXTPCalendarEventCategory objects
►C CXTPCalendarPtrCollectionT< CXTPCalendarEventLabel > |
C CXTPCalendarEventLabels | This class is used as a collection of CXTPCalendarEventLabel objects
►C CXTPCalendarPtrCollectionT< CXTPCalendarReminder > |
C CXTPCalendarReminders | This class represents a simple array collection of CXTPCalendarReminder objects
►C CXTPCalendarPtrCollectionT< CXTPCalendarResource > |
►C CXTPCalendarResources | This class represents a simple array collection of CXTPCalendarResource objects
C CXTPCalendarResourcesNf | This class implements CXTPCalendarResource functionality with the addition of a notifications mechanism implemented by CXTPNotifySink
►C CXTPCalendarPtrCollectionT< CXTPCalendarSchedule > |
C CXTPCalendarSchedules | This class represents a simple array collection of CXTPCalendarSchedule objects
►C CXTPCalendarPtrCollectionT< CXTPCalendarTimeLineViewGroup > |
C CXTPCalendarTimeLineViewGroups | This class represents a collection of CXTPCalendarTimeLineViewGroup objects
►C CXTPCalendarPtrCollectionT< CXTPCalendarViewEvent > |
C CXTPCalendarViewEvents | This class is used as a collection of Event View objects
C CXTPCalendarPtrCollectionT< CXTPCalendarCaptionBarThemePart > |
C CXTPCalendarPtrCollectionT< CXTPCalendarDayViewEvent > |
C CXTPCalendarPtrCollectionT< CXTPCalendarData > |
C CXTPCalendarPtrCollectionT< CXTPCalendarResourceDescription > |
C CXTPCalendarPtrCollectionT< CXTPCalendarThemePart > |
C CXTPCalendarPtrCollectionT< CXTPCalendarTimeZone > |
C CXTPCalendarPtrCollectionT< CXTPCalendarViewDay > |
C CXTPCalendarPtrCollectionT< CXTPCalendarViewGroup > |
►C CXTPHeapObjectT< CXTPCmdTarget, CXTPGridDataAllocator > |
C CXTPGridHyperlink | This class represents hyperlinks
C CXTPGridRecord | CXTPGridRecord represents a collection of CXTPGridRecordItem objects or objects of classes that are children of CXTPGridRecordItem
►C CXTPGridRecordItem | Class for working with single list cell
C CXTPGridRecordItemCheckbox | This class represents a checkbox-only cell and inherits basic functionality from the CXTPGridRecordItem class
C CXTPGridRecordItemDateTime | Represents a time cell and inherits basic functionality from the CXTPGridRecordItem class
►C CXTPGridRecordItemNumber | This class represents a numeric cell and inherits basic functionality from the CXTPGridRecordItem class
C CXTPGridRecordItemPercentNumber | This class represents a numeric percent cell and inherits basic functionality from the CXTPGridRecordItemNumber class
C CXTPGridRecordItemPreview | This represents a preview cell and inherits basic functionality from the CXTPGridRecordItem class
C CXTPGridRecordItemText | This class represents a text-only cell and inherits basic functionality from the CXTPGridRecordItem class
C CXTPGridRecordItemVariant | Represents a variant item and inherits basic functionality from the CXTPGridRecordItem class
C CXTPTrackControlItem | This class represents a container cell for a set of blocks and keys and inherits basic functionality from the CXTPGridRecordItem class
C CXTPGridRecords | This class represents a grid records collection
C CXTPGridRows | This class represents a rows collection class
C CXTPActiveScriptEngine | Implements ActiveScript engine component
C CXTPActiveScriptStdRuntime | Implements standard scripting runtime library
►C CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE > | This class represents a simple array of typed elements
►C CXTPHeapObjectT< CXTPGridHyperlinks_base, CXTPGridDataAllocator > |
C CXTPGridHyperlinks | This class represents an array of pointers to CXTPGridHyperlink objects
C CXTPGridRecordItemControls | This class represents the inplace controls of a single item
►C CXTPCalendarCaptionBarPaintManager | Utility class, handles most of the drawing activities
►C CXTPCalendarCaptionBarOffice2000Theme | CXTPCalendarCaptionBarOffice2000Theme is a CXTPCalendarCaptionBarPaintManager derived class thatrepresents the Office 2000 calendar theme
►C CXTPCalendarCaptionBarOfficeXPTheme | CXTPCalendarCaptionBarOfficeXPTheme is a CXTPCalendarCaptionBarOffice2000Theme derived class that represents the Office XP calendar theme
►C CXTPCalendarCaptionBarOffice2003Theme | CXTPCalendarCaptionBarOffice2003Theme is a CXTPCalendarCaptionBarOfficeXPTheme derived class that represents the Office 2003 calendar theme
►C CXTPCalendarCaptionBarOffice2013Theme | CXTPCalendarCaptionBarOffice2013Theme is a CXTPCalendarCaptionBarOffice2003Theme derived class that represents the Office 2013 white calendar theme
C CXTPCalendarCaptionBarNativeWindows10Theme | CXTPCalendarCaptionBarNativeWindows10Theme is a CXTPCalendarCaptionBarOffice2013Theme derived class that represents the Native Windows 10 calendar theme
C CXTPCalendarCaptionBarNativeWindows11Theme | CXTPCalendarCaptionBarNativeWindows11Theme is a CXTPCalendarCaptionBarOffice2013Theme derived class that represents the Native Windows 11 calendar theme
C CXTPCalendarCaptionBarResourceTheme | CXTPCalendarCaptionBarResourceTheme is a CXTPCalendarCaptionBarOffice2013Theme derived class that represents the Resource calendar theme
C CXTPCalendarCaptionBarVisualStudio2015Theme | CXTPCalendarCaptionBarVisualStudio2015Theme is a CXTPCalendarCaptionBarOffice2013Theme derived class that represents the Visual Studio 2015 white calendar theme
C CXTPCalendarCaptionBarVisualStudio2017Theme | CXTPCalendarCaptionBarVisualStudio2017Theme is a CXTPCalendarCaptionBarOffice2013Theme derived class that represents the Visual Studio 2017 white calendar theme
C CXTPCalendarCaptionBarVisualStudio2019Theme | CXTPCalendarCaptionBarVisualStudio2019Theme is a CXTPCalendarCaptionBarOffice2013Theme derived class that represents the Visual Studio 2019 white calendar theme
C CXTPCalendarCaptionBarVisualStudio2022Theme | CXTPCalendarCaptionBarVisualStudio2022Theme is a CXTPCalendarCaptionBarOffice2013Theme derived class that represents Visual Studio 2022 white calendar theme
C CXTPCalendarController | Class CXTPCalendarController provides a connection between a CXTPCalendarControl object and a CXTPDatePickerControl object
C CXTPCalendarCustomProperties | This class is used to store properties collection
►C CXTPCalendarData | This class defines an abstract representation of the Calendar control data with all necessary methods and some predefined functionality added
C CXTPCalendarCustomDataProvider | Custom implementation of XTPCalendarData based on notifications
C CXTPCalendarDatabaseDataProvider | This class is the implementation of the XTPCalendarData abstract class which represents the data portion of the Calendar control
C CXTPCalendarMemoryDataProvider | This class implements an abstract representation of the data used in the XTPCalendarData class
C CXTPCalendarDayViewTimeScale | This class implements a specific view portion of the Calendar Day view - called Time scale
C CXTPCalendarEvent | This class represents the data of a single Event used in the Calendar control
C CXTPCalendarEventCategory | This class defines Calendar Event Category properties
C CXTPCalendarEventLabel | This class defines Calendar Event label properties
C CXTPCalendarEvents | This class represents a simple array collection of CXTPCalendarEvent objects
C CXTPCalendarOptions | Structure contains all calendar options
►C CXTPCalendarPaintManager | Utility class, handles most of the drawing activities
►C CXTPCalendarOffice2000Theme | CXTPCalendarOffice2000Theme is a CXTPCalendarPaintManager derived class that represents the Office 2000 calendar theme
C CXTPCalendarOffice2003Theme | CXTPCalendarOffice2003Theme is a CXTPCalendarOffice2000Theme derived class that represents the Office 2003 calendar theme
►C CXTPCalendarOffice2013Theme | CXTPCalendarOffice2013Theme is a CXTPCalendarOffice2000Theme derived class that represents the Office 2013 calendar theme
C CXTPCalendarNativeWindows10Theme | CXTPCalendarNativeWindows10Theme is a CXTPCalendarOffice2013Theme derived class that represents the Native Windows 10 calendar theme
C CXTPCalendarNativeWindows11Theme | CXTPCalendarNativeWindows11Theme is a CXTPCalendarOffice2013Theme derived class that represents the Native Windows 11 calendar theme
C CXTPCalendarVisualStudio2015Theme | CXTPCalendarVisualStudio2015Theme is a CXTPCalendarOffice2013Theme derived class that represents the Visual Studio 2015 calendar theme
C CXTPCalendarVisualStudio2017Theme | CXTPCalendarVisualStudio2017Theme is a CXTPCalendarOffice2013Theme derived class that represents the Visual Studio 2017 calendar theme
C CXTPCalendarVisualStudio2019Theme | CXTPCalendarVisualStudio2019Theme is a CXTPCalendarOffice2013Theme derived class that represents the Visual Studio 2019 calendar theme
C CXTPCalendarVisualStudio2022Theme | CXTPCalendarVisualStudio2022Theme is a CXTPCalendarOffice2013Theme derived class that represents the Visual Studio 2022 calendar theme
C CXTPCalendarOfficeXPTheme | CXTPCalendarOfficeXPTheme is a CXTPCalendarOffice2000Theme derived class that represents the Office XP calendar theme
C CXTPCalendarResourceTheme | CXTPCalendarResourceTheme is a CXTPCalendarPaintManager derived class that represents the Resource calendar theme
C CXTPCalendarPtrCollectionT< _TObject > | This class represents a simple array collection of objects
C CXTPCalendarRecurrencePattern | This class represents a recurrence pattern and stores data to build a schedule for recurrence events
C CXTPCalendarReminder | This class describes a reminder for a calendar event and implements base properties for and operations on the reminder
C CXTPCalendarResource | Class CXTPCalendarResource represents a calendar for some subject like a person, a shared resource, or even a group of people or resources
C CXTPCalendarResourceDescription | This class is a wrapper for CXTPCalendarResource class
C CXTPCalendarResourcesManager | This class is used as a helper to manage calendar resources (and schedules) data configurations
C CXTPCalendarSchedule | Calendar Schedule is a characteristic of the Calendar Event, which describes a belonging of the Event to a particular Schedule (which could be people schedule, common resource schedule, etc)
►C CXTPCalendarTLV_TimeScaleParams | This class implements Timeline scale params
C CXTPCalendarTLV_TimeScaleParams_Day | This class implements Timeline scale params for Day case
C CXTPCalendarTLV_TimeScaleParams_Month | This class implements Timeline scale params for Month case
C CXTPCalendarTLV_TimeScaleParams_Week | This class implements Timeline scale params for Week case
C CXTPCalendarTLV_TimeScaleParams_WorkWeek | This class implements Timeline scale params for WorkWeek case
C CXTPCalendarTimeLineViewTimeScale | This class implements a specific view portion of the Calendar control called Timeline view scale
C CXTPCalendarTimeZone | This class extends the TIME_ZONE_INFORMATION structure
C CXTPCalendarTimeZones | This class represents a simple array collection of CXTPCalendarTimeZone objects
►C CXTPCalendarViewPart | Helper base class to implement parts for calendar paint manager
C CXTPCalendarTimeLineViewPart | Helper base class to implement parts for calendar paint manager objects
C CXTPCalendarTimeLineViewTimeScalePart | Helper base class to implement parts for calendar paint manager
►C CXTPCalendarWMHandler | This class helps to handle Windows messages (WM_*) processing portion of the Calendar control views
C CXTPCalendarCaptionBarTheme | This class CalendarCaptionBar control drawing, user interaction logic and interaction logic with attached Calendar control
►C CXTPCalendarCaptionBarThemePart | This class used as a base class for graphical Parts of CalendarCaptionBar paint theme
C CXTPCheckboxButtonPart | This class implements Checkbox button part of the SwitchViewBar
C CXTPDateLabelPart | This class implements Date Label part of the ScrollDateBar
C CXTPExpandButtonPart | This class implements Expand button part of the ScrollDateBar
C CXTPRadioButtonPart | This class implements Radio button part of the SwitchViewBar
C CXTPScrollDateButtonPart | This class implements Scroll Date button part of the ScrollDateBar
C CXTPSwitchViewButtonPart | This class implements SwitchView button part of the SwitchViewBar
►C CXTPCalendarView | This class represents the view portion of the Calendar control
►C CXTPCalendarViewT< CXTPCalendarDayViewDay > |
C CXTPCalendarDayView | This class implements a specific view portion of the Calendar control - called Day view
►C CXTPCalendarViewT< CXTPCalendarMonthViewDay > |
C CXTPCalendarMonthView | This class implements a specific view portion of the Calendar control - called Month view
►C CXTPCalendarViewT< CXTPCalendarWeekViewDay > |
C CXTPCalendarWeekView | This class implements a specific view portion of the Calendar control - called Week view
C CXTPCalendarTimeLineView | This class implements a specific view portion of the Calendar control - called Timeline view
C CXTPCalendarViewT< _TViewDay > | This template class represents a view portion of the Calendar control
►C CXTPCalendarViewDay | This class represents the day view portion of the CalendarView
►C CXTPCalendarViewDayT< CXTPCalendarDayView, CXTPCalendarDayViewGroup, XTP_CALENDAR_HITTESTINFO, CXTPCalendarDayViewDay > |
C CXTPCalendarDayViewDay | This class represents a day view portion of the Calendar Day View
►C CXTPCalendarViewDayT< CXTPCalendarMonthView, CXTPCalendarMonthViewGroup, XTP_CALENDAR_HITTESTINFO, CXTPCalendarMonthViewDay > |
C CXTPCalendarMonthViewDay | This class represents a day view portion of the CalendarMonthView
►C CXTPCalendarViewDayT< CXTPCalendarWeekView, CXTPCalendarWeekViewGroup, XTP_CALENDAR_HITTESTINFO, CXTPCalendarWeekViewDay > |
C CXTPCalendarWeekViewDay | This class represents a day view portion of the CalendarWeekView
C CXTPCalendarViewDayT< _TView, _TViewGroup, XTP_CALENDAR_HITTESTINFO, _TPThis > | This class template customizes, overrides and implements some functionality for the CXTPCalendarViewDay base class
►C CXTPCalendarViewEvent | This class represents an event view portion of the CalendarViewGroup
►C CXTPCalendarViewEventT< CXTPCalendarDayViewGroup > |
C CXTPCalendarDayViewEvent | This class represents an event view portion of the CalendarDayViewDay
►C CXTPCalendarViewEventT< CXTPCalendarMonthViewGroup > |
C CXTPCalendarMonthViewEvent | This class represents an event view portion of the CalendarMonthViewDay
►C CXTPCalendarViewEventT< CXTPCalendarWeekViewGroup > |
C CXTPCalendarWeekViewEvent | This class represents an event view portion of the CalendarWeekViewDay
C CXTPCalendarTimeLineViewEvent | This class represents an event timeline view portion of the CXTPCalendarViewEvent
C CXTPCalendarViewEventT< _TViewGroup > | This class is used to build the ViewEvent layer of the DayView and ViewEvent hierarchies
►C CXTPCalendarViewGroup | Regular schema:
►C CXTPCalendarViewGroupT< CXTPCalendarDayViewDay, CXTPCalendarDayViewEvent, CXTPCalendarDayViewGroup > |
C CXTPCalendarDayViewGroup | This class represents a single resource view portion of the Calendar Day View
►C CXTPCalendarViewGroupT< CXTPCalendarMonthViewDay, CXTPCalendarMonthViewEvent, CXTPCalendarMonthViewGroup > |
C CXTPCalendarMonthViewGroup | This class represents a single resource view portion of the Calendar Month View
►C CXTPCalendarViewGroupT< CXTPCalendarWeekViewDay, CXTPCalendarWeekViewEvent, CXTPCalendarWeekViewGroup > |
C CXTPCalendarWeekViewGroup | This class represents a single resource view portion of the Calendar Week View
C CXTPCalendarTimeLineViewGroup | This class represents an event timeline view portion of the CalendarViewGroup
C CXTPCalendarViewGroupT< _TViewDay, _TViewEvent, _TPThis > | This class template customizes, overrides and implements some functionality for the CXTPCalendarViewGroup base class
►C CXTPChartDeviceContext | This class abstracts a device context
C CXTPChart3dDeviceContext | A base implementation of 3D device context
C CXTPChartFillStyle | This class abstracts a fill style used to fill the background of various chart elements
C CXTPChartFont | This class abstracts a font entity
C CXTPChartLineStyle | This class represents a chart line style, which is a kind of CXTPCmdTarget
C CXTPColorManager | CXTPColorManager is a stand alone class
►C CXTPColorSetStateButton | Base class used to define various state colors used by command bar buttons text, background and border
C CXTPColorSetStateMenu | Color set class used to define various state colors used by command bar menus
C CXTPColorSetStateMenuTitleBar | Color set class used to define various state colors used by command bar menu title bars
C CXTPColorSetStateRibbon | Color set class used to define various state colors used by command bar ribbon
C CXTPColorSetStateToolbar | Color set class used to define various state colors used by command bar toolbars
►C CXTPCommandBarList | CXTPCommandBarList is a CList derived class
C CXTPCommandBarsContextMenus | CXTPCommandBarsContextMenus is CXTPCommandBarList derived class which represents a collection of context menus
C CXTPCommandBars | CXTPCommandBars is a standalone class
C CXTPCommandBarsOptions | Options of the command bars
►C CXTPControl | CXTPControl is a CXTPCmdTarget derived class
►C CXTPControlButton | CXTPControlButton is a CXTPControl derived class
C CXTPControlButtonColor | CXTPControlButtonColor is a CXTPControlButton derived class
C CXTPControlCheckBox | CXTPControlCheckBox is a CXTPControlButton derived class
C CXTPControlCustom | CXTPControlCustom is a CXTPControlButton derived class
C CXTPControlOleItems | CXTPControlOleItems is a CXTPControlButton derived class
►C CXTPControlPopup | CXTPControlPopup is a CXTPControl derived class
►C CXTPControlComboBox | CXTPControlComboBox is a CXTPControl derived class
C CXTPControlFontComboBox | CXTPControlFontComboBox is a CXTPControlComboBox derived class
C CXTPControlSizeComboBox | CXTPControlSizeComboBox is a CXTPControlComboBox derived class
C CXTPControlGallery | CXTPControlGallery is a CXTPControlPopup derived class
C CXTPControlPopupColor | CXTPControlPopupColor is a CXTPControlPopup derived class
C CXTPRibbonControlSystemButton | CXTPRibbonControlSystemButton is a CXTPControlPopup derived class used as a system button for a Ribbon Bar
C CXTPRibbonControlTab | CXTPRibbonControlTab is a CXTPTabManager derived class
C CXTPControlRadioButton | CXTPControlRadioButton is a CXTPControlButton derived class
C CXTPControlRecentFileList | CXTPControlRecentFileList is a CXTPControlButton derived class
C CXTPControlTabWorkspace | TabWorkspace control
C CXTPControlToolbars | CXTPControlToolbars is a CXTPControlButton derived class
C CXTPControlToolbars::CXTPControlToolbar | Represents a single toolbar item
C CXTPControlWindowList | CXTPControlWindowList is a CXTPControlButton derived class
C CXTPControlWorkspaceActions | CXTPControlWorkspaceActions is a CXTPControlButton derived class
C CXTPRibbonControlSystemPopupBarButton | CXTPRibbonControlSystemPopupBarButton is a CXTPControlButton derived class used in a system pop-up bar for bottom option buttons
►C CXTPRibbonControlSystemPopupBarListItem | CXTPRibbonControlSystemPopupBarListItem is a CXTPControlButton derived class used in a Ribbon system pop-up to draw buttons of enumerable controls
C CXTPRibbonControlSystemPopupBarPinableListItem | CXTPRibbonControlSystemPopupBarPinableListItem is a CXTPRibbonControlSystemPopupBarListItem derived class used in a Ribbon system pop-up to draw recent file list items
C CXTPControlColorSelector | CXTPControlColorSelector is a CXTPControl derived class
C CXTPControlEdit | CXTPControlEdit is a CXTPControl derived class
C CXTPControlHyperlink | CXTPControlHyperlink is a CXTPControl derived class
►C CXTPControlLabel | CXTPControlLabel is a CXTPControl derived class
C CXTPControlBitmap | CXTPControlBitmap is a CXTPControlLabel derived class
C CXTPControlMarkupLabel | CXTPControlMarkupLabel is a CXTPControlLabel derived class
C CXTPControlListBox | CXTPControlComboBox is a CXTPControl derived class
C CXTPControlProgress | CXTPControlProgress is a CXTPControl derived class
C CXTPControlScrollBar | CXTPControlScrollBar is a CXTPControl derived class
C CXTPControlSelector | CXTPControlSelector is a CXTPControl derived class that represents a control selector
C CXTPControlSlider | CXTPControlSlider is a CXTPControl derived class
C CXTPControlStatic | CXTPControlStatic is a CXTPControl derived class
►C CXTPRibbonControlSystemPopupBarListCaption | CXTPRibbonControlSystemPopupBarListCaption is a CXTPControl derived class used in a Ribbon system pop-up to draw captions of enumerable controls
C CXTPRibbonControlSystemRecentFileList | CXTPRibbonControlSystemRecentFileList is a CXTPRibbonControlSystemPopupBarListCaption derived class used in a Ribbon system pop-up to draw recent file list controls
C CXTPControlAction | CXTPControlAction is a CXTPCmdTarget derived class
C CXTPControlActions | CXTPControlActions is a CXTPCmdTarget derived class
C CXTPControlGalleryItem | CXTPControlGalleryItem is a CXTPCmdTarget derived class
C CXTPControlGalleryItems | CXTPControlGalleryItems is a CXTPCmdTarget derived class
►C CXTPControlTheme | CXTPControlTheme can be used as a base class for user defined themes
►C CXTPButtonTheme | CXTPButtonTheme is a class used to perform Button Theme drawing tasks
C CXTPButtonThemeFlat | CXTPButtonThemeFlat is a class used to perform Flat Theme drawing tasks
►C CXTPButtonThemeUltraFlat | CXTPButtonThemeUltraFlat is a class used to perform Ultra Flat Theme drawing tasks
C CXTPButtonThemeOffice2000 | CXTPButtonThemeOffice2000 is a class used to perform Office 2000 Theme drawing tasks
►C CXTPButtonThemeOffice2013 | CXTPButtonThemeOffice2013 is a class used to perform Office 2013 theme drawing tasks
C CXTPButtonThemeNativeWindows10 | CXTPButtonThemeNativeWindows10 is a class used to perform Visual Studio 2015 theme drawing tasks
C CXTPButtonThemeNativeWindows11 | CXTPButtonThemeNativeWindows11 is a class used to perform Visual Studio 2015 theme drawing tasks
C CXTPButtonThemeVisualStudio2012 | CXTPButtonThemeVisualStudio2012 is a class used to perform Visual Studio 2012 theme drawing tasks
C CXTPButtonThemeVisualStudio2015 | CXTPButtonThemeVisualStudio2015 is a class used to perform Visual Studio 2015 theme drawing tasks
C CXTPButtonThemeVisualStudio2017 | CXTPButtonThemeVisualStudio2017 is a class used to perform Visual Studio 2017 theme drawing tasks
C CXTPButtonThemeVisualStudio2019 | CXTPButtonThemeVisualStudio2019 is a class used to perform Visual Studio 2019 theme drawing tasks
C CXTPButtonThemeVisualStudio2022 | CXTPButtonThemeVisualStudio2022 is a class used to perform Visual Studio 2022 theme drawing tasks
►C CXTPButtonThemeOfficeXP | CXTPButtonThemeOfficeXP is a class used to perform Office XP Theme drawing tasks
►C CXTPButtonThemeOffice2003 | CXTPButtonThemeOffice2003 is a class used to perform Office 2003 Theme drawing tasks
C CXTPCaptionButtonThemeOffice2003 | Class CXTPCaptionButtonThemeOffice2003 is a CXTPButtonOffice2003Theme derived class
C CXTPCaptionButtonThemeOfficeXP | Class CXTPCaptionButtonThemeOfficeXP is a CXTPButtonOfficeXPTheme derived class
C CXTPButtonThemeResource | CXTPButtonThemeResource is a class used to perform Office 2007 Theme drawing tasks
C CXTPCaptionButtonTheme | CXTPCaptionButtonTheme is derived from CXTPButtonTheme
C CXTPTaskButtonTheme | CXTPTaskButtonTheme
C CXTPTaskButtonThemeExpando | CXTPTaskButtonThemeExpando
►C CXTPCaptionTheme | CXTPCaptionTheme is a CXTPControlTheme derived class used to control caption themes
C CXTPCaptionThemeOffice2003 | CXTPCaptionThemeOffice2003 is derived from CXTPCaptionTheme
C CXTPCaptionThemeOfficeXP | CXTPCaptionThemeOfficeXP is derived from CXTPCaptionTheme
►C CXTPColorSelectorCtrlTheme | CXTPColorSelectorCtrlTheme is derived from CXTPControlThemeManagerStyle to handle theme specific visualizations for the CXTPColorSelectorCtrl class
►C CXTPColorSelectorCtrlThemeOffice2013 | CXTPColorSelectorCtrlThemeOffice2013 is derived from CXTPColorSelectorCtrlTheme to handle theme specific visualizations for the CXTPColorSelectorCtrl class
►C CXTPColorSelectorCtrlThemeVisualStudio2015 | CXTPColorSelectorCtrlThemeVisualStudio2015 is derived from CXTPColorSelectorCtrlThemeOffice2013 to handle theme specific visualizations for the CXTPColorSelectorCtrl class
C CXTPColorSelectorCtrlThemeNativeWindows10 | CXTPColorSelectorCtrlThemeNativeWindows10 is derived from CXTPColorSelectorCtrlThemeVisualStudio2015 to handle theme specific visualizations for the CXTPColorSelectorCtrl class
C CXTPColorSelectorCtrlThemeNativeWindows11 | CXTPColorSelectorCtrlThemeNativeWindows11 is derived from CXTPColorSelectorCtrlThemeVisualStudio2015 to handle theme specific visualizations for the CXTPColorSelectorCtrl class
C CXTPColorSelectorCtrlThemeVisualStudio2017 | CXTPColorSelectorCtrlThemeVisualStudio2017 is derived from CXTPColorSelectorCtrlThemeVisualStudio2015 to handle theme specific visualizations for the CXTPColorSelectorCtrl class
C CXTPColorSelectorCtrlThemeVisualStudio2019 | CXTPColorSelectorCtrlThemeVisualStudio2019 is derived from CXTPColorSelectorCtrlThemeVisualStudio2015 to handle theme specific visualizations for the CXTPColorSelectorCtrl class
C CXTPColorSelectorCtrlThemeVisualStudio2022 | CXTPColorSelectorCtrlThemeVisualStudio2022 is derived from CXTPColorSelectorCtrlThemeVisualStudio2015 to handle theme specific visualizations for the CXTPColorSelectorCtrl class
►C CXTPColorSelectorCtrlThemeOfficeXP | CXTPColorSelectorCtrlThemeOfficeXP is derived from CXTPColorSelectorCtrlTheme to handle theme specific visualizations for the CXTPColorSelectorCtrl class
C CXTPColorSelectorCtrlThemeOffice2003 | CXTPColorSelectorCtrlThemeOffice2003 is derived from CXTPColorSelectorCtrlThemeOfficeXP to handle theme specific visualizations for the CXTPColorSelectorCtrl class
C CXTPColorSelectorCtrlThemeResource | CXTPColorSelectorCtrlThemeResource is derived from CXTPColorSelectorCtrlThemeOfficeXP to handle theme specific visualizations for the CXTPColorSelectorCtrl class
►C CXTPComboBoxTheme | CXTPComboBoxTheme is a class used to perform ComboBox Theme drawing tasks
C CXTPComboBoxThemeDefault | Used as the paint manager for a combobox control to render a default appearance
C CXTPComboBoxThemeOffice2000 | Used as the paint manager for a combobox control to render an Office 2000 appearance
►C CXTPComboBoxThemeOffice2003 | Used as the paint manager for a combobox control to render an Office 2003 appearance
►C CXTPComboBoxThemeVisualStudio | Used as the paint manager for a combobox control to render a Visual Studio appearance
►C CXTPComboBoxThemeOffice2013 | Used as the paint manager for a combobox control to render an Office 2013 appearance
C CXTPComboBoxThemeNativeWindows10 | Used as the paint manager for a combobox control to render a Native Windows 10 appearance
C CXTPComboBoxThemeNativeWindows11 | Used as the paint manager for a combobox control to render a Native Windows 10 appearance
C CXTPComboBoxThemeVisualStudio2015 | Used as the paint manager for a combobox control to render a Visual Studio 2015 appearance
C CXTPComboBoxThemeVisualStudio2017 | Used as the paint manager for a combobox control to render a Visual Studio 2017 appearance
C CXTPComboBoxThemeVisualStudio2019 | Used as the paint manager for a combobox control to render a Visual Studio 2019 appearance
C CXTPComboBoxThemeVisualStudio2022 | Used as the paint manager for a combobox control to render a Visual Studio 2022 appearance
C CXTPComboBoxThemeVisualStudio2010 | Used as the paint manager for a combobox control to render a Visual Studio 2010 appearance
C CXTPComboBoxThemeVisualStudio2012 | Used as the paint manager for a combobox control to render a Visual Studio 2012 appearance
C CXTPComboBoxThemeOfficeXPFlat | Used as the paint manager for a combobox control to render an Office XP Flat appearance
C CXTPComboBoxThemeResource | Used as the paint manager for a combobox control to render a resource appearance
►C CXTPEditTheme | CXTPEditTheme is the base class for all edit themes used to perform drawing tasks
►C CXTPEditThemeDefault | CXTPEditThemeDefault is a class used to perform theme drawing tasks
►C CXTPEditThemeOffice2000 | CXTPEditThemeOffice2000 is a class used to perform theme drawing tasks
►C CXTPEditThemeOfficeXP | CXTPEditThemeOfficeXP is a class used to perform theme drawing tasks
C CXTPEditThemeFlat | CXTPEditThemeFlat is a class used to perform theme drawing tasks
C CXTPEditThemeOffice2003 | CXTPEditThemeOffice2003 is a class used to perform theme drawing tasks
►C CXTPEditThemeOffice2013 | CXTPEditThemeOffice2013 is a class used to perform theme drawing tasks
C CXTPEditThemeNativeWindows10 | CXTPEditThemeNativeWindows10 is a class used to perform theme drawing tasks
C CXTPEditThemeNativeWindows11 | CXTPEditThemeNativeWindows11 is a class used to perform theme drawing tasks
C CXTPEditThemeVisualStudio2015 | CXTPEditThemeVisualStudio2015 is a class used to perform theme drawing tasks
C CXTPEditThemeVisualStudio2017 | CXTPEditThemeVisualStudio2017 is a class used to perform theme drawing tasks
C CXTPEditThemeVisualStudio2019 | CXTPEditThemeVisualStudio2019 is a class used to perform theme drawing tasks
C CXTPEditThemeVisualStudio2022 | CXTPEditThemeVisualStudio2022 is a class used to perform theme drawing tasks
C CXTPEditThemeResource | CXTPEditThemeResource is a class used to perform theme drawing tasks
C CXTPEditThemeUltraFlat | CXTPEditThemeUltraFlat is a class used to perform theme drawing tasks
C CXTPEditThemeVisualStudio2010 | CXTPEditThemeVisualStudio2010 is a class used to perform theme drawing tasks
C CXTPEditThemeVisualStudio2012 | CXTPEditThemeVisualStudio2012 is a class used to perform theme drawing tasks
►C CXTPExcelTabCtrlTheme | CXTPExcelTabCtrlTheme is used to draw the CXTPExcelTabCtrl object
►C CXTPExcelTabCtrlThemeOffice2013 | This class is used to draw a CXTPTabCtrl object using Excel Office 2013 theme
C CXTPExcelTabCtrlThemeNativeWindows10 | This class is used to draw a CXTPTabCtrl object using Excel Native Windows 10 theme
C CXTPExcelTabCtrlThemeNativeWindows11 | This class is used to draw a CXTPTabCtrl object using Excel Native Windows 11 theme
C CXTPExcelTabCtrlThemeVisualStudio2015 | This class is used to draw a CXTPExcelTabCtrlThemeVisualStudio2015 object using Excel Visual Studio 2015 theme
C CXTPExcelTabCtrlThemeVisualStudio2017 | This class is used to draw a CXTPExcelTabCtrlThemeVisualStudio2017 object using Excel Visual Studio 2017 theme
C CXTPExcelTabCtrlThemeVisualStudio2019 | This class is used to draw a CXTPExcelTabCtrlThemeVisualStudio2019 object using Excel Visual Studio 2019 theme
C CXTPExcelTabCtrlThemeVisualStudio2022 | This class is used to draw a CXTPExcelTabCtrlThemeVisualStudio2022 object using Excel Visual Studio 2022 theme
►C CXTPExcelTabCtrlThemeOfficeXP | This class is used to draw a CXTPTabCtrl object using Excel Office XP theme
C CXTPExcelTabCtrlThemeOffice2003 | This class is used to draw a CXTPTabCtrl object using Excel Office 2003 theme
►C CXTPHeaderCtrlTheme | CXTPHeaderCtrlTheme is a theme class used to draw a Windows classic style theme for the header control
►C CXTPHeaderCtrlThemeOffice2003 | CXTPHeaderCtrlThemeOffice2003 is a CXTPHeaderCtrlTheme derived theme class used to draw an Office 2003 style theme for the header control
C CXTPHeaderCtrlThemeExplorer | CXTPHeaderCtrlThemeExplorer is a CXTPHeaderCtrlThemeOffice2003 derived theme class used to draw an Office XP style theme for the header control
►C CXTPHeaderCtrlThemeOfficeXP | CXTPHeaderCtrlThemeOfficeXP is a CXTPHeaderCtrlTheme derived theme class used to draw an Office XP style theme for the header control
C CXTPHeaderCtrlThemeResource | CXTPHeaderCtrlThemeResource is a CXTPHeaderCtrlThemeOfficeXP derived theme class used to draw a resource .dll style theme for the header control
►C CXTPShortcutListBoxTheme | CXTPShortcutListBoxTheme is used to draw the CXTPShortcutListBox object
►C CXTPShortcutListBoxThemeOfficeXP | Class CXTPShortcutListBoxThemeOfficeXP is derived from CXTPShortcutListBoxTheme
C CXTPShortcutListBoxThemeOffice2003 | Class CXTPShortcutListBoxThemeOffice2003 is derived from CXTPShortcutListBoxThemeXP
►C CXTPSplitterWndTheme | Class CXTPSplitterWndTheme is derived from CXTPControlTheme
►C CXTPSplitterWndThemeOfficeXP | Class CXTPSplitterWndThemeOfficeXP is derived from CXTPSplitterWndTheme
►C CXTPSplitterWndThemeOffice2003 | Class CXTPSplitterWndThemeOffice2003 is derived from CXTPSplitterWndTheme
C CXTPSplitterWndThemeResource | Class CXTPSplitterWndThemeResource is derived from CXTPSplitterWndTheme
C CXTPSplitterWndThemeVisualStudio2010 | Class CXTPSplitterWndThemeVisualStudio2010 is derived from CXTPSplitterWndTheme
►C CXTPSplitterWndThemeOffice2013 | Class CXTPSplitterWndThemeOffice2013 is derived from CXTPSplitterWndThemeOfficeXP
C CXTPSplitterWndThemeVisualStudio2015 | Class CXTPSplitterWndThemeVisualStudio2015 is derived from CXTPSplitterWndThemeOffice2013
C CXTPSplitterWndThemeVisualStudio2017 | Class CXTPSplitterWndThemeVisualStudio2017 is derived from CXTPSplitterWndThemeOffice2013
C CXTPSplitterWndThemeVisualStudio2019 | Class CXTPSplitterWndThemeVisualStudio2019 is derived from CXTPSplitterWndThemeOffice2013
C CXTPSplitterWndThemeVisualStudio2022 | Class CXTPSplitterWndThemeVisualStudio2022 is derived from CXTPSplitterWndThemeOffice2013
►C CXTPTabBaseTheme | CXTPTabBaseTheme is used to draw the CXTPTabBase object
►C CXTPTabBaseThemeOfficeXP | Class CXTPTabBaseThemeOfficeXP is derived from CXTPTabBaseTheme
C CXTPTabBaseThemeOffice2003 | Class CXTPTabBaseThemeOffice2003 is derived from CXTPTabBaseThemeOfficeXP
►C CXTPTreeTheme | CXTPTreeTheme is a class used to perform tree control theme drawing tasks
►C CXTPTreeOffice2013Theme | CXTPTreeOffice2013Theme is a CXTPTreeTheme derived class used to render a Office 2013 style tree
C CXTPTreeNativeWindows10Theme | CXTPTreeNativeWindows10Theme is a CXTPTreeTheme derived class used to render a Native Windows 10 style tree
C CXTPTreeNativeWindows11Theme | CXTPTreeNativeWindows11Theme is a CXTPTreeTheme derived class used to render a Native Windows 11 style tree
C CXTPTreeVisualStudio2015Theme | CXTPTreeVisualStudio2015Theme is a CXTPTreeTheme derived class used to render a Visual Studio 2015 style tree
C CXTPTreeVisualStudio2017Theme | CXTPTreeVisualStudio2017Theme is a CXTPTreeTheme derived class used to render a Visual Studio 2017 style tree
C CXTPTreeVisualStudio2019Theme | CXTPTreeVisualStudio2019Theme is a CXTPTreeTheme derived class used to render a Visual Studio 2019 style tree
C CXTPTreeVisualStudio2022Theme | CXTPTreeVisualStudio2022Theme is a CXTPTreeTheme derived class used to render a Visual Studio 2022 style tree
C CXTPTreeVisualStudio2012Theme | CXTPTreeVisualStudio2012Theme is a CXTPTreeTheme derived class used to render a Visual Studio 2012 style tree
►C CXTPControls | CXTPControls is a CXTPCmdTarget derived class
C CXTPOriginalControls | CXTPOriginalControls object
C CXTPRibbonControls | CXTPRibbonControls is a CXTPControls derived class
C CXTPRibbonQuickAccessControls | CXTPRibbonQuickAccessControls is a CXTPControls derived class
C CXTPDatePickerDaysCollection |
C CXTPDatePickerItemDay | Class CXTPDatePickerItemDay represents one displayed day item in the calendar
C CXTPDatePickerItemMonth | Class CXTPDatePickerItemMonth represents one month inside the date picker month grid
►C CXTPDatePickerPaintManager | Class CXTPDatePickerPaintManager handles most of the drawing activities for the DatePicker control
C CXTPDatePickerThemeOffice2000 | Class CXTPDatePickerThemeOffice2000 is derived from CXTPDatePickerPaintManager for rendering an Office 2000 style for DatePicker control
C CXTPDatePickerThemeOffice2003 | Class CXTPDatePickerThemeOffice2003 is derived from CXTPDatePickerPaintManager for rendering an Office 2003 style for DatePicker control
►C CXTPDatePickerThemeOffice2013 | Class CXTPDatePickerThemeOffice2013 is derived from CXTPDatePickerPaintManager for rendering an Office 2013 style for DatePicker control
C CXTPDatePickerThemeNativeWindows10 | Class CXTPDatePickerThemeNativeWindows10 is derived from CXTPDatePickerThemeOffice2013 for rendering an Native Windows 10 style for DatePicker control
C CXTPDatePickerThemeNativeWindows11 | Class CXTPDatePickerThemeNativeWindows11 is derived from CXTPDatePickerThemeOffice2013 for rendering an Native Windows 11 style for DatePicker control
C CXTPDatePickerThemeVisualStudio2015 | Class CXTPDatePickerThemeVisualStudio2015 is derived from CXTPDatePickerThemeOffice2013 for rendering an Visual Studio 2015 style for DatePicker control
C CXTPDatePickerThemeVisualStudio2017 | Class CXTPDatePickerThemeVisualStudio2017 is derived from CXTPDatePickerThemeOffice2013 for rendering an Visual Studio 2017 style for DatePicker control
C CXTPDatePickerThemeVisualStudio2019 | Class CXTPDatePickerThemeVisualStudio2019 is derived from CXTPDatePickerThemeOffice2013 for rendering an Visual Studio 2019 style for DatePicker control
C CXTPDatePickerThemeVisualStudio2022 | Class CXTPDatePickerThemeVisualStudio2022 is derived from CXTPDatePickerThemeOffice2013 for rendering an Visual Studio 2022 style for DatePicker control
C CXTPDatePickerThemeOfficeXP | Class CXTPDatePickerThemeOfficeXP is derived from CXTPDatePickerPaintManager for rendering an Office XP style for DatePicker control
C CXTPDatePickerThemeResource | Class CXTPDatePickerThemeResource is derived from CXTPDatePickerPaintManager for rendering a Resource DLL style for DatePicker control
C CXTPDockingPane | CXTPDockingPane is a CXTPDockingPaneBase derived class
C CXTPDockingPaneLayout | CXTPDockingPaneLayout is a standalone class
►C CXTPDockingPanePaintManager | CXTPDockingPanePaintManager is a standalone class
►C CXTPDockingPaneDefaultTheme | CXTPDockingPaneDefaultTheme is a CXTPDockingPanePaintManager derived class that represents a classic theme for docking panes
►C CXTPDockingPaneGripperedTheme | CXTPDockingPaneGripperedTheme is a CXTPDockingPaneDefaultTheme derived class that represents a gripper theme for docking panes
►C CXTPDockingPaneVisualStudio2003Theme | CXTPDockingPaneVisualStudio2003Theme is a CXTPDockingPaneGripperedTheme derived class that represents a Visual Studio 2003 theme for docking panes
►C CXTPDockingPaneOffice2002VisioTheme | CXTPDockingPaneOffice2002VisioTheme is a CXTPDockingPaneVisualStudio2003Theme derived class that represents a Visio theme for docking panes
►C CXTPDockingPaneOffice2003VisioTheme | CXTPDockingPaneOffice2003VisioTheme is a CXTPDockingPaneOffice2002VisioTheme derived class that represents an Office 2003 Visio theme for docking panes
C CXTPDockingPaneOffice2007VisioTheme | CXTPDockingPaneOffice2007VisioTheme is a CXTPDockingPaneOffice2003VisioTheme derived class that represents an Office 2007 Visio theme for docking panes
►C CXTPDockingPaneOffice2003Theme | CXTPDockingPaneOffice2003Theme is a CXTPDockingPaneVisualStudio2003Theme derived class that represents an Office 2003 theme for docking panes
C CXTPDockingPaneOffice2003OutlookTheme | CXTPDockingPaneOffice2003OutlookTheme is a CXTPDockingPaneOffice2003Theme derived class that represents an Office 2003 theme for docking panes
►C CXTPDockingPaneOffice2007Theme | CXTPDockingPaneOffice2007Theme is a CXTPDockingPaneOffice2003Theme derived class that represents an Office 2007 theme for docking panes
C CXTPDockingPaneOffice2007OutlookTheme | CXTPDockingPaneOffice2007OutlookTheme is CXTPDockingPaneOffice2007Theme derived class that represents an Outlook 2007 theme for docking panes
C CXTPDockingPaneOffice2007WordTheme | CXTPDockingPaneOffice2007WordTheme is a CXTPDockingPaneOffice2003Theme derived class that represents an Office Word 2007 theme for docking panes
►C CXTPDockingPaneVisualStudio2005Beta1Theme | CXTPDockingPaneVisualStudio2005Beta1Theme is CXTPDockingPaneVisualStudio2003Theme derived class that represents a Visual Studio 2005 Beta 1 theme for docking panes
►C CXTPDockingPaneVisualStudio2005Beta2Theme | CXTPDockingPaneVisualStudio2005Beta2Theme is CXTPDockingPaneVisualStudio2005Beta1Theme derived class that represents a Visual Studio 2005 Beta 2 theme for docking panes
►C CXTPDockingPaneVisualStudio2005Theme | CXTPDockingPaneVisualStudio2005Theme is a CXTPDockingPaneVisualStudio2005Beta2Theme derived class that represents a Visual Studio 2005 theme for docking panes
►C CXTPDockingPaneVisualStudio2008Theme | CXTPDockingPaneVisualStudio2008Theme is a CXTPDockingPaneVisualStudio2005Theme derived class that represents a Visual Studio 2008 theme for docking panes
C CXTPDockingPaneVisualStudio2010Theme | CXTPDockingPaneVisualStudio2010Theme is a CXTPDockingPaneVisualStudio2008Theme derived class that represents a Visual Studio 2010 theme for docking panes
C CXTPDockingPaneWinNativeTheme | CXTPDockingPaneWinNativeTheme is a CXTPDockingPaneVisualStudio2003Theme derived class that represents a Win Native theme for docking panes
C CXTPDockingPaneVisualStudio6Theme | CXTPDockingPaneVisualStudio6Theme is a CXTPDockingPaneGripperedTheme derived class that represents a Visual Studio 6 theme for docking panes
C CXTPDockingPaneWinExplorerTheme | CXTPDockingPaneWinExplorerTheme is a CXTPDockingPaneDefaultTheme derived class that represents an Explorer theme for docking panes
►C CXTPDockingPaneVisualStudio2012Theme | CXTPDockingPaneVisualStudio2012Theme is used to define drawing routines specific to a Visual Studio 2012 docking pane theme
C CXTPDockingPaneNativeWindows10Theme | CXTPDockingPaneNativeWindows10Theme is used to define drawing routines specific to a Native Windows 10 docking pane theme
C CXTPDockingPaneNativeWindows11Theme | CXTPDockingPaneNativeWindows11Theme is used to define drawing routines specific to a Native Windows 10 docking pane theme
C CXTPDockingPaneOffice2013Theme | CXTPDockingPaneOffice2013Theme is used to define drawing routines specific to an Office 2013 docking pane theme
C CXTPDockingPaneVisualStudio2015Theme | CXTPDockingPaneVisualStudio2015Theme is used to define drawing routines specific to a Visual Studio 2015 docking pane theme
C CXTPDockingPaneVisualStudio2017Theme | CXTPDockingPaneVisualStudio2017Theme is used to define drawing routines specific to a Visual Studio 2017 docking pane theme
C CXTPDockingPaneVisualStudio2019Theme | CXTPDockingPaneVisualStudio2019Theme is used to define drawing routines specific to a Visual Studio 2019 docking pane theme
C CXTPDockingPaneVisualStudio2022Theme | CXTPDockingPaneVisualStudio2022Theme is used to define drawing routines specific to a Visual Studio 2022 docking pane theme
C CXTPDockingPaneSplitterContainer | CXTPDockingPaneSplitterContainer is a CXTPDockingPaneBase derived class
C CXTPFlowGraphConnectionPoints | Represents a collection of connection points for a Node
C CXTPFlowGraphConnections | Represents a collection of connections for a Node
►C CXTPFlowGraphElement | Base class for all elements in the flow graph
C CXTPFlowGraphConnection | Represents a connection
C CXTPFlowGraphConnectionPoint | Represents a connection point for a node
►C CXTPFlowGraphNode | Represents a Node object
C CXTPFlowGraphNodeCustom | Represents a Node object defined by custom XAML markup
C CXTPFlowGraphNodeGroup | Represents a group of Nodes
C CXTPFlowGraphImage | Object used to represent an image displayed in a Node or connection point
C CXTPFlowGraphImages | Collection of images that can be used in the flow graph
C CXTPFlowGraphNodeGroups | Represents a collection of groups in a page
C CXTPFlowGraphNodes | Represents a collection of Nodes in a page or group
C CXTPFlowGraphPage | Represents a page in the flow graph
C CXTPFlowGraphPageHistory | Object that contains page transition history for the flow graph
C CXTPFlowGraphPages | Represents a collection of pages in the flow graph
C CXTPFlowGraphPaintManager | Handles most of the drawing activities of the flow graph
C CXTPFlowGraphSelectedElements | Collection of selected elements in the flow graph
C CXTPFlowGraphUndoManager | This class abstracts an undo manager
C CXTPFrameShadowManager | Provides frame shadow management functionality
►C CXTPGaugeBaseType | A base class for all gauge types
C CXTPGaugeMeterType | Implements a Meter gauge type
C CXTPGaugeStateType | Implements a State gauge type
C CXTPGridColumn | Represents a grid column item with its properties and operations
C CXTPGridColumnOrder | Represents the column order, used for sorting and grouping
C CXTPGridColumns | This class is a collection of grid column objects
C CXTPGridDataManager | Represents a grid data manager
►C CXTPGridHeader | A grid header is a part of the grid window positioned above columns of text or numbers
C CXTPTrackHeader | This class represents a track control header
C CXTPGridHyperlinkStyle | This class stores the anchor styles
►C CXTPGridNavigator | Utility class, handles Grid control item navigation
C CXTPGridIconNavigator | Utility class, handles Grid control icon navigation
►C CXTPGridPaintManager | Utility class that handles most drawing activities
C CXTPGridThemeDefault | CXTPGridThemeDefault is a CXTPGridPaintManager derived class that represents an Office 97 style theme
C CXTPGridThemeExplorer | CXTPGridThemeExplorer is a CXTPGridPaintManager derived class that represents an Explorer style theme
C CXTPGridThemeOffice2003 | CXTPGridThemeOffice2003 is a CXTPGridPaintManager derived class that represents an Office 2003 style theme
C CXTPGridThemeOffice2003Luna | CXTPGridThemeOffice2003Luna is a CXTPGridPaintManager derived class that represents an Office 2003 Luna style theme
►C CXTPGridThemeOffice2013 | CXTPGridThemeOffice2013 is a CXTPGridPaintManager derived class that represents an Office 2013 style theme
C CXTPGridThemeNativeWindows10 | CXTPGridThemeNativeWindows10 is a CXTPGridThemeOffice2013 derived class that represents a Native Windows 10 style theme
C CXTPGridThemeNativeWindows11 | CXTPGridThemeNativeWindows11 is a CXTPGridThemeOffice2013 derived class that represents a Native Windows 10 style theme
C CXTPGridThemeVisualStudio2012Blue | CXTPGridThemeVisualStudio2012Blue is a CXTPGridThemeOffice2013 derived class that represents a Visual Studio 2012 Blue style theme
C CXTPGridThemeVisualStudio2012Dark | CXTPGridThemeVisualStudio2012Dark is a CXTPGridThemeOffice2013 derived class that represents a Visual Studio 2012 Dark style theme
C CXTPGridThemeVisualStudio2012Light | CXTPGridThemeVisualStudio2012Light is a CXTPGridThemeOffice2013 derived class that represents a Visual Studio 2012 Light style theme
C CXTPGridThemeVisualStudio2015 | CXTPGridThemeVisualStudio2015 is a CXTPGridThemeOffice2013 derived class that represents a Visual Studio 2015 style theme
C CXTPGridThemeVisualStudio2017 | CXTPGridThemeVisualStudio2017 is a CXTPGridThemeOffice2013 derived class that represents a Visual Studio 2017 style theme
C CXTPGridThemeVisualStudio2019 | CXTPGridThemeVisualStudio2019 is a CXTPGridThemeOffice2013 derived class that represents a Visual Studio 2019 style theme
C CXTPGridThemeVisualStudio2022 | CXTPGridThemeVisualStudio2022 is a CXTPGridThemeOffice2013 derived class that represents a Visual Studio 2022 style theme
C CXTPGridThemeOfficeXP | CXTPGridThemeOfficeXP is a CXTPGridPaintManager derived class that represents an Office XP style theme
C CXTPGridThemeResource | CXTPGridThemeResource is a CXTPGridPaintManager derived class that represents a Resource style theme
►C CXTPTrackPaintManager | This class represents a track control paint manager
C CXTPTrackThemeDefault | CXTPTrackThemeDefault is a CXTPTrackPaintManager derived class that represents an Office 97 style theme
C CXTPTrackThemeExplorer | CXTPTrackThemeExplorer is a CXTPTrackPaintManager derived class that represents an Explorer style theme
C CXTPTrackThemeOffice2003 | CXTPTrackThemeOffice2003 is a CXTPTrackPaintManager derived class that represents an Office 2003 style theme
C CXTPTrackThemeOffice2003Luna | CXTPTrackThemeOffice2003Luna is a CXTPTrackPaintManager derived class that represents an Office 2003 Luna style theme
►C CXTPTrackThemeOffice2013 | CXTPTrackThemeOffice2013 is a CXTPTrackPaintManager derived class that represents an Office 2013 style theme
C CXTPTrackThemeNativeWindows10 | CXTPTrackThemeNativeWindows10 is a CXTPTrackThemeOffice2013 derived class that represents a Native Windows 10 style theme
C CXTPTrackThemeNativeWindows11 | CXTPTrackThemeNativeWindows11 is a CXTPTrackThemeOffice2013 derived class that represents a Native Windows 10 style theme
C CXTPTrackThemeVisualStudio2012Blue | CXTPTrackThemeVisualStudio2012Blue is a CXTPTrackThemeOffice2013 derived class that represents a Visual Studio 2012 Blue style theme
C CXTPTrackThemeVisualStudio2012Dark | CXTPTrackThemeVisualStudio2012Dark is a CXTPTrackThemeOffice2013 derived class that represents a Visual Studio 2012 Dark style theme
C CXTPTrackThemeVisualStudio2012Light | CXTPTrackThemeVisualStudio2012Light is a CXTPTrackThemeOffice2013 derived class that represents a Visual Studio 2012 Light style theme
C CXTPTrackThemeVisualStudio2015 | CXTPTrackThemeVisualStudio2015 is a CXTPTrackThemeOffice2013 derived class that represents a Visual Studio 2015 style theme
C CXTPTrackThemeVisualStudio2017 | CXTPTrackThemeVisualStudio2017 is a CXTPTrackThemeOffice2013 derived class that represents a Visual Studio 2017 style theme
C CXTPTrackThemeVisualStudio2019 | CXTPTrackThemeVisualStudio2019 is a CXTPTrackThemeOffice2013 derived class that represents a Visual Studio 2019 style theme
C CXTPTrackThemeVisualStudio2022 | CXTPTrackThemeVisualStudio2022 is a CXTPTrackThemeOffice2013 derived class that represents a Visual Studio 2022 style theme
C CXTPTrackThemeOfficeXP | CXTPTrackThemeOfficeXP is a CXTPTrackPaintManager derived class that represents an Office XP style theme
C CXTPTrackThemeResource | CXTPTrackThemeResource is a CXTPTrackPaintManager derived class that represents a Resource style theme
C CXTPGridRecordItemConstraint | CXTPGridRecordItemConstraint is a CXTPCmdTarget derived class
C CXTPGridRecordItemConstraints | CXTPGridRecordItemConstraints is a CXTPCmdTarget derived class
►C CXTPGridRecordItemControl | This class represents a generic item control and handles control's behaviour, common for all derived item controls
C CXTPGridRecordItemButton | This class represents an item button and inherits basic functionality from the CXTPGridRecordItemControl class
C CXTPGridRecordItemEditOptions | This class represents edit options for a single item or column
C CXTPGridSection | Represents a grid section
C CXTPGridSections | Collection of sections
C CXTPGridSelectedRows | Encapsulates a collection of CXTPGridRow pointers that represent the selected rows in a Grid control
C CXTPGridThickness | Describes the thickness of the left, top, right, and bottom sides of a rectangle
C CXTPImageManager | CXTPImageManager is a standalone class
C CXTPImageManagerIcon | Icons holder class
C CXTPImageManagerIconSet | CXTPImageManagerIconSet represents the collection of icons for a specified identifier
C CXTPMenuBarMDIMenuInfo | CXTPMenuBarMDIMenuInfo structure used to describe the parameters of application MDI menus
C CXTPMenuBarMDIMenus | CXTPMenuBarMDIMenus represents a collection of MDI menus for CXTPMenuBar
►C CXTPNotifyConnection | This class is used as implementation of Connection interface in a XTPNotification mechanism
C CXTPNotifyConnectionMT | This class is used as thread-safety implementation of Connection interface in a XTPNotification mechanism
►C CXTPPaintManager | Paint manager of the command bars
►C CXTPCommandBarsOffice2000Theme | Used to enable an Office 2000 style theme for Command Bars
C CXTPCommandBarsNativeXPTheme | Used to enable a Native Windows XP style theme for Command Bars
►C CXTPCommandBarsOfficeXPTheme | Used to enable an Office XP style theme for Command Bars
►C CXTPCommandBarsModernUITheme | Base class for the Modern UI themes for Command Bars
►C CXTPCommandBarsOffice2013Theme | Used to enable an Office 2013 style theme for Command Bars
C CXTPCommandBarsNativeWindows10Theme | Used to enable a Native Windows 10 style theme for Command Bars
C CXTPCommandBarsNativeWindows11Theme | Used to enable a Native Windows 10 style theme for Command Bars
C CXTPCommandBarsVisualStudio2015Theme | Used to enable a Visual Studio 2015 style theme for Command Bars
C CXTPCommandBarsVisualStudio2017Theme | Used to enable a Visual Studio 2017 style theme for Command Bars
C CXTPCommandBarsVisualStudio2019Theme | Used to enable a Visual Studio 2019 style theme for Command Bars
C CXTPCommandBarsVisualStudio2022Theme | Used to enable a Visual Studio 2022 style theme for Command Bars
C CXTPCommandBarsVisualStudio2012Theme | Used to enable a Visual Studio 2012 theme for Command Bars
►C CXTPCommandBarsOffice2003Theme | Used to enable an Office 2003 style theme for Command Bars
►C CXTPResourceTheme | Used to enable a resource style theme for Command Bars
C CXTPRibbonTheme | Used to enable a Ribbon style theme for Command Bars
►C CXTPVisualStudio2005Theme | Used to enable a Visual Studio 2005 style theme for Command Bars
C CXTPVisualStudio2008Theme | Used to enable a Visual Studio 2008 style theme for Command Bars
C CXTPVisualStudio2010Theme | Used to enable a Visual Studio 2010 style theme for Command Bars
C CXTPPopupItem | CXTPPopupItem is a class used to manage a pop-up item object
►C CXTPProgressCtrlPaintManager | Derived from CXTPCmdTarget and is used by the progress bar to perform all default drawing routines
►C CXTPProgressCtrlThemeFlat | Derived from CXTPProgressCtrlPaintManager and is used by the progress bar to draw a flat style progress bar
C CXTPProgressCtrlThemeUltraFlat | Derived from CXTPProgressCtrlThemeFlat and is used by the progress bar to draw a flat style progress bar with no borders
C CXTPProgressCtrlThemeNativeWinXP | Derived from CXTPProgressCtrlPaintManager and is used by the progress bar to draw a native Windows style progress bar
C CXTPProgressCtrlThemeNativeWindows | Derived from CXTPProgressCtrlPaintManager and is used by the progress bar to draw a native Windows style progress bar
►C CXTPProgressCtrlThemeOffice2000 | The CXTPProgressCtrlThemeFlat class is derived from CXTPProgressCtrlPaintManager and is used by the progress bar to draw an Office 2000 style progress bar
C CXTPProgressCtrlThemeOffice2003 | The CXTPProgressCtrlThemeFlat class is derived from CXTPProgressCtrlPaintManager and is used by the progress bar to draw an Office 2003 style progress bar
►C CXTPProgressCtrlThemeOffice2013 | The CXTPProgressCtrlThemeFlat class is derived from CXTPProgressCtrlPaintManager and is used by the progress bar to draw an Office 2013 style progress bar
C CXTPProgressCtrlThemeVisualStudio2015 | The CXTPProgressCtrlThemeFlat class is derived from CXTPProgressCtrlPaintManager and is used by the progress bar to draw a Visual Studio 2015 style progress bar
C CXTPProgressCtrlThemeVisualStudio2017 | Derived from CXTPProgressCtrlThemeOffice2013 and is used by the progress bar to draw a Visual Studio 2017 style progress bar
C CXTPProgressCtrlThemeVisualStudio2019 | Derived from CXTPProgressCtrlThemeOffice2013 and is used by the progress bar to draw a Visual Studio 2019 style progress bar
C CXTPProgressCtrlThemeVisualStudio2022 | Derived from CXTPProgressCtrlThemeOffice2013 and is used by the progress bar to draw a Visual Studio 2022 style progress bar
C CXTPProgressCtrlThemeOfficeXP | The CXTPProgressCtrlThemeXP class is derived from CXTPProgressCtrlThemeFlat and is used by the progress bar to draw an Office XP style progress bar
C CXTPProgressCtrlThemeResource | The CXTPProgressCtrlThemeFlat class is derived from CXTPProgressCtrlPaintManager and is used by the progress bar to draw an progress bar using a resource DLL
►C CXTPPropExchange | CXTPPropExchange is standalone pure class
C CXTPPropExchangeArchive | CXTPPropExchangeArchive is CXTPPropExchange derived class
C CXTPPropExchangeIniFile | CXTPPropExchangeIniFile is CXTPPropExchange derived class
C CXTPPropExchangeRegistry | CXTPPropExchangeRegistry is CXTPPropExchange derived class
C CXTPPropExchangeXMLNode | CXTPPropExchangeXMLNode is CXTPPropExchange derived class
C CXTPPropertyGridInplaceButton | CXTPPropertyGridInplaceButton is a CXTPCmdTarget derived class
C CXTPPropertyGridInplaceButtons | CXTPPropertyGridInplaceButtons is a CXTPCmdTarget derived class
►C CXTPPropertyGridItem | CXTPPropertyGridItem is the base class representing an item of the Property Grid control
C CXTPPropertyGridItemBool | CXTPPropertyGridItemBool is a CXTPPropertyGridItem derived class
C CXTPPropertyGridItemCategory | CXTPPropertyGridItemCategory is a CXTPPropertyGridItem derived class
C CXTPPropertyGridItemColor | CXTPPropertyGridItemColor is a CXTPPropertyGridItem derived class
C CXTPPropertyGridItemDate | CXTPPropertyGridItemDate is a CXTPPropertyGridItem derived class
C CXTPPropertyGridItemDouble | CXTPPropertyGridItemDouble is a CXTPPropertyGridItem derived class
C CXTPPropertyGridItemEnum | CXTPPropertyGridItemEnum is a CXTPPropertyGridItem derived class
C CXTPPropertyGridItemFlags | CXTPPropertyGridItemFlags is a CXTPPropertyGridItem derived class
C CXTPPropertyGridItemFont | CXTPPropertyGridItemFont is a CXTPPropertyGridItem derived class
C CXTPPropertyGridItemMultilineString | CXTPPropertyGridItemMultilineString is a CXTPPropertyGridItem derived class
C CXTPPropertyGridItemNumber | CXTPPropertyGridItemNumber is a CXTPPropertyGridItem derived class
C CXTPPropertyGridItemOption | CXTPPropertyGridItemOption is a CXTPPropertyGridItem derived class
C CXTPPropertyGridItemPoint | CXTPPropertyGridItemPoint is a CXTPPropertyGridItem derived class
C CXTPPropertyGridItemSize | CXTPPropertyGridItemSize is a CXTPPropertyGridItem derived class
C CXTPPropertyGridItemConstraint | CXTPPropertyGridItemConstraint is a CXTPCmdTarget derived class
C CXTPPropertyGridItemConstraints | CXTPPropertyGridItemConstraints is a CXTPCmdTarget derived class
C CXTPPropertyGridItemMetrics | Standalone class used by CXTPPropertyGridPaintManager to store item metrics
C CXTPPropertyGridItems | CXTPPropertyGridItems is a CList derived class
►C CXTPPropertyGridPaintManager | Standalone class used by CXTPPropertyGrid as the paint manager
C CXTPPropertyGridCoolTheme | CXTPPropertyGridCoolTheme is a CXTPPropertyGridPaintManager derived class
C CXTPPropertyGridDelphiTheme | CXTPPropertyGridDelphiTheme is a CXTPPropertyGridPaintManager derived class
C CXTPPropertyGridNativeXPTheme | CXTPPropertyGridNativeXPTheme is a CXTPPropertyGridPaintManager derived class
►C CXTPPropertyGridOffice2003Theme | CXTPPropertyGridOffice2003Theme is a CXTPPropertyGridPaintManager derived class
C CXTPPropertyGridOffice2007Theme | CXTPPropertyGridOffice2007Theme is a CXTPPropertyGridOffice2003Theme derived class
C CXTPPropertyGridOffice2013Theme | CXTPPropertyGridOffice2013Theme is a CXTPPropertyGridPaintManager derived class
C CXTPPropertyGridOfficeXPTheme | CXTPPropertyGridOfficeXPTheme is a CXTPPropertyGridPaintManager derived class
C CXTPPropertyGridSimpleTheme | CXTPPropertyGridSimpleTheme is a CXTPPropertyGridPaintManager derived class
C CXTPPropertyGridVisualStudio2005Theme | CXTPPropertyGridVisualStudio2005Theme is a CXTPPropertyGridPaintManager derived class
►C CXTPPropertyGridVisualStudio2010Theme | CXTPPropertyGridVisualStudio2010Theme is a CXTPPropertyGridPaintManager derived class
C CXTPPropertyGridNativeWindows10Theme | CXTPPropertyGridNativeWindows10Theme is a CXTPPropertyGridVisualStudio2010Theme derived class
C CXTPPropertyGridNativeWindows11Theme | CXTPPropertyGridNativeWindows11Theme is a CXTPPropertyGridVisualStudio2010Theme derived class
C CXTPPropertyGridVisualStudio2015Theme | CXTPPropertyGridVisualStudio2015Theme is a CXTPPropertyGridVisualStudio2010Theme derived class
C CXTPPropertyGridVisualStudio2017Theme | CXTPPropertyGridVisualStudio2017Theme is a CXTPPropertyGridVisualStudio2010Theme derived class
C CXTPPropertyGridVisualStudio2019Theme | CXTPPropertyGridVisualStudio2019Theme is a CXTPPropertyGridVisualStudio2010Theme derived class
C CXTPPropertyGridVisualStudio2022Theme | CXTPPropertyGridVisualStudio2022Theme is a CXTPPropertyGridVisualStudio2010Theme derived class
C CXTPPropertyGridVisualStudio2012Theme | CXTPPropertyGridVisualStudio2012Theme is a CXTPPropertyGridVisualStudio2010Theme derived class
C CXTPPropertyGridUpdateContext | CXTPPropertyGridUpdateContext is a CXTPCmdTarget derived class used to save the state of the property grid such as the currently selected item, XTPPropertyGridSortOrder preference, and the expanding state of each item in the grid
C CXTPPropertyGridVerb | CXTPPropertyGridVerb is used to create a verb link similar to what is seen in Visual Studio .NET
C CXTPPropertyGridVerbs | A collection of CXTPPropertyGridVerb objects that are displayed in the verb panel
C CXTPRecentFileList | CXTPRecentFileList is a CRecentFileList derived class
C CXTPResourceImage | Represent a resource image and provides basic images functions
C CXTPResourceImages | Implements resource image collection and its operations
C CXTPRibbonGroup | Represents a single group that is added to a CXTPRibbonTab
C CXTPRibbonGroups | Represents a collection of CXTPRibbonGroup objects
►C CXTPRibbonPaintManager | Standalone class used by CXTPRibbonBar as a paint manager
►C CXTPRibbonMarkupTheme | CXTPRibbonMarkupTheme class
►C CXTPRibbonOffice2013Theme | CXTPRibbonOffice2013Theme is a CXTPRibbonMarkupTheme derived class used to represent an Office 2013 ribbon theme
C CXTPRibbonThemeNativeWindows10 | CXTPRibbonThemeNativeWindows10 is a CXTPRibbonOffice2013Theme derived class used to represent a Native Windows 10 ribbon theme
C CXTPRibbonThemeNativeWindows11 | CXTPRibbonThemeNativeWindows11 is a CXTPRibbonOffice2013Theme derived class used to represent a Native Windows 10 ribbon theme
C CXTPRibbonThemeVisualStudio2015 | CXTPRibbonThemeVisualStudio2015 is a CXTPRibbonOffice2013Theme derived class used to represent a Visual Studio 2015 ribbon theme
C CXTPRibbonThemeVisualStudio2017 | CXTPRibbonThemeVisualStudio2017 is a CXTPRibbonOffice2013Theme derived class used to represent a Visual Studio 2017 ribbon theme
C CXTPRibbonThemeVisualStudio2019 | CXTPRibbonThemeVisualStudio2019 is a CXTPRibbonOffice2013Theme derived class used to represent a Visual Studio 2019 ribbon theme
C CXTPRibbonThemeVisualStudio2022 | CXTPRibbonThemeVisualStudio2022 is a CXTPRibbonOffice2013Theme derived class used to represent a Visual Studio 2022 ribbon theme
C CXTPRibbonThemeOffice2007System | CXTPRibbonThemeOffice2007System is a CXTPRibbonMarkupTheme derived class used to represent an Office 2007 ribbon theme
C CXTPRibbonThemeResource | CXTPRibbonThemeResource is a CXTPRibbonPaintManager derived class used to represent a Resource .DLL ribbon theme
C CXTPShadowManager | CXTPShadowManager is standalone class used to manage CommandBars' shadows
C CXTPShortcutBarItem | CXTPShortcutBarItem is a base class that represents an item for a shortcut bar control
►C CXTPShortcutBarPaintManager | CXTPShortcutBarPaintManager is a standalone class used as a paint manager for a shortcut bar control
C CXTPShortcutBarOffice2000Theme | CXTPShortcutBarOffice2000Theme is a CXTPShortcutBarPaintManager derived class that represents an Office 2000 shortcut bar theme
►C CXTPShortcutBarOffice2003Theme | CXTPShortcutBarOffice2003Theme is a CXTPShortcutBarPaintManager derived class that represents an Office 2003 shortcut bar theme
C CXTPShortcutBarNativeWinXPTheme | CXTPShortcutBarNativeWinXPTheme is a CXTPShortcutBarOffice2003Theme derived class that represents a Native Windows XP shortcut bar theme
►C CXTPShortcutBarResourceTheme | CXTPShortcutBarResourceTheme is a CXTPShortcutBarOffice2003Theme derived class that represents the Office 2007, 2010 and 2012 shortcut bar themes
►C CXTPShortcutBarOffice2013Theme | CXTPShortcutBarOffice2013Theme is a CXTPShortcutBarResourceTheme derived class that represents an Office 2013 shortcut bar theme
C CXTPShortcutBarNativeWindows10Theme | CXTPShortcutBarNativeWindows10Theme is a CXTPShortcutBarOffice2013Theme derived class that represents a Native Windows 10 shortcut bar theme
C CXTPShortcutBarNativeWindows11Theme | CXTPShortcutBarNativeWindows11Theme is a CXTPShortcutBarOffice2013Theme derived class that represents a Native Windows 10 shortcut bar theme
C CXTPShortcutBarVisualStudio2015Theme | CXTPShortcutBarVisualStudio2015Theme is a CXTPShortcutBarOffice2013Theme derived class that represents a Visual Studio 2015 shortcut bar theme
C CXTPShortcutBarVisualStudio2017Theme | CXTPShortcutBarVisualStudio2017Theme is a CXTPShortcutBarOffice2013Theme derived class that represents a Visual Studio 2017 shortcut bar theme
C CXTPShortcutBarVisualStudio2019Theme | CXTPShortcutBarVisualStudio2019Theme is a CXTPShortcutBarOffice2013Theme derived class that represents a Visual Studio 2019 shortcut bar theme
C CXTPShortcutBarVisualStudio2022Theme | CXTPShortcutBarVisualStudio2022Theme is a CXTPShortcutBarOffice2013Theme derived class that represents a Visual Studio 2022 shortcut bar theme
C CXTPShortcutBarOfficeXPTheme | CXTPShortcutBarOfficeXPTheme is a CXTPShortcutBarPaintManager derived class that represents an Office XP shortcut bar theme
C CXTPShortcutManager | CXTPShortcutManager is a standalone class used to manipulate accelerators of a frame
C CXTPShortcutManagerAccel | CXTPShortcutManagerAccel represents an accelerator key used in an accelerator table
C CXTPSkinManagerResourceFile | CXTPSkinManagerResourceFile is a standalone class that represents a manager of visual style resources
C CXTPSkinManagerSchema | CXTPSkinManagerSchema is a standalone class used to read a visual styles schema file
►C CXTPStatusBarPane | CXTPStatusBarPane is a CXTPCmdTarget derived class
C CXTPStatusBarProgressPane | CXTPStatusBarProgressPane is a CXTPStatusBarPane derived class
►C CXTPStatusBarScrollBarPane | CXTPStatusBarScrollBarPane is a CXTPStatusBarPane derived class
C CXTPStatusBarSliderPane | CXTPStatusBarSliderPane is a CXTPStatusBarPane derived class
C CXTPStatusBarSwitchPane | CXTPStatusBarSwitchPane is a CXTPStatusBarPane derived class
C CXTPSyntaxEditBufferManager | This class is the main class for buffer management
C CXTPSyntaxEditConfigurationManager | This class manages all configuration parameters of the control
C CXTPSyntaxEditLexClass | CXTPSyntaxEditLexClass class is used to represent lexical block of text definition and to parse text
C CXTPSyntaxEditLexParser | This class used to 'run' lex schema parsing in a separate thread
C CXTPSyntaxEditLexParserSchemaOptions | This class is designed to easily manipulate parser options
C CXTPSyntaxEditLexTextBlock | Block of text which corresponds to a lex class in a text schema
C CXTPSyntaxEditLexTextSchema | Used to store data which is necessary to parse a text and parsing results
C CXTPSyntaxEditLexVariant | CXTPSyntaxEditLexVariant provides functionality to manipulate Lexical Analyzer's related variant type
C CXTPSyntaxEditLineMarksManager | Functionality to manipulate marks on text lines
C CXTPSyntaxEditOptions | Shared Options of SyntaxEdit
C CXTPSyntaxEditPaintManager | This class is used by CXTPSyntaxEditCtrl as the paint manager
C CXTPSyntaxEditSelection | This class is used to represent syntax edit text selection and allows for selection properties to be get and set in two measurements: string and display
C CXTPSyntaxEditTextIterator | This class provides functionality to navigate text in the data buffer, seek forward/backward, retrieve text by lines, and determine control symbols like CRLF
►C CXTPTabManagerItem | CXTPTabManagerItem is the base class for the tabs that appear in the command bars tab workspace, docking panes, and tab control
C CXTPRibbonTab | Represents a tab in the Ribbon Bar
►C CXTPTabPaintManager | CXTPTabPaintManager is used to store the color and appearance information of the tabs in the tab manager
C CXTPDockingPanePanelPaintManager | CXTPDockingPanePanelPaintManager is a CXTPTabPaintManager derived class that is used to store the color and appearance information of the tabs in the tab manager
C CXTPDockingPaneTabPaintManager | CXTPDockingPaneTabPaintManager is a CXTPTabPaintManager derived class that is used to store the color and appearance information of the tabs in the tab manager
C CXTPTagCloudStyleManager | CXTPTagCloudStyleManager is a singleton class used to manage CXTPTagCloudStyle structs that identify each tag style used by CXTPTagCloudCtrl
►C CXTPTaskPanelItem | CXTPTaskPanelItem is used in a Task Panel control to represent a single item
C CXTPTaskPanelGroup | CXTPTaskPanelGroup is used in a Task Panel control to represent a group
C CXTPTaskPanelGroupItem | CXTPTaskPanelGroupItem is used in a TaskPanel control to represent a single item of a group
►C CXTPTaskPanelItems | CXTPTaskPanelItems is used in a Task Panel control to represent a collection of items
C CXTPTaskPanelGroupItems | CXTPTaskPanelGroupItems represents a collection of items in a group
C CXTPTaskPanelGroups | CXTPTaskPanelGroups represents a collection of groups in a Task Panel control
C CXTPToolTipContext | CXTPToolTipContext is a CXTPCmdTarget derived class
►C CXTPTrackBlock | This class represents a track control block
C CXTPTrackKey | This class represents a track control key
C CXTPTrackMarker | This class represents a track control marker
C CXTPTrackMarkers | This class abstracts the track control markers
C CXTPTrackSelectedBlocks | This class abstracts the selected blocks of the track control
C CXTPTrackUndoManager | This class abstracts an undo manager
►C CXTPWebBrowserProvider | Implements the base class for a WebBrowser provider
C CXTPShellExplorerProvider | Implements ShellExplorer WebBrowser provider and gives access to ShellExplorer specific functionality
C CXTPWebViewProvider | Implements WebView2 WebBrowser provider and gives access to WebView2 specific functionality
C XTP_DAYITEM_METRICS | This structure represents a set of parameters which are used to display day items
C XTP_GRIDRECORDITEM_METRICS | Record item drawing metrics
►C CXTPColorBase | CXTPColorBase is a CStatic derived base class
C CXTPColorLum | CXTPColorLum is a CXTPColorBase derived class
C CXTPColorWnd | CXTPColorWnd is a CXTPColorBase derived class
C CXTPColorDialog | CXTPColorDialog is a CPropertySheet derived class
C CXTPColorHex | CXTPColorHex is a CStatic derived class
C CXTPColorPageCustom | CXTPColorPageCustom is derived from CPropertyPage
C CXTPColorPageStandard | CXTPColorPageStandard is derived from CPropertyPage
►C CXTPColorSelectorCtrl | CXTPColorSelectorCtrl is a CWnd derived class
C CXTPColorPopup | CXTPColorPopup is a CXTPColorSelectorCtrl derived class
C CXTPColorSetCaptionButton | Default theme caption button color set
C CXTPColorSetStateCheckBox | Helper class used to define various state colors used by check box and radio button controls
C CXTPColorSetStateCheckMark | Helper class used to define various state colors used by command bar check marks foreground and background
C CXTPColorSetStateComboBox | Helper class used to define various state colors used by command bar glyphs
►C CXTPComboBox | Functionality of a themed Windows combobox
C CXTPFontComboBox | CXTPFontComboBox is a CXTPComboBox derived class
C CXTPComboBoxEditCtrl | Used by the CXTPComboBox object to subclass the edit-box portion of the control
C CXTPComInitializer | Initializes COM and increments and holds COM initialization reference counter for the thread where constructed
►C CXTPCommandBarEditCtrl | CXTPCommandBarEditCtrl is a CEdit derived class
C CXTPControlComboBoxEditCtrl | Inplace Edit control of the combo
C CXTPControlEditCtrl | Inplace Edit control of CXTPControlEdit
C CXTPCommandBarKeyboardTip | CXTPCommandBarKeyboardTip is a CWnd derived class which represents a keyboard tip single window
►C CXTPCommandBarsSiteBase< TBase > | CXTPCommandBarsSiteBase is a standalone class
C CXTPFrameWndBase< TBase > | CXTPFrameWndBase is a standalone class
►C CXTPCommandBarsSiteBase< CFrameWnd > |
►C CXTPFrameWndBase< CFrameWnd > |
C CXTPFrameWnd | CXTPFrameWnd is a CXTPFrameWndBase derived class
►C CXTPCommandBarsSiteBase< CMDIFrameWnd > |
►C CXTPFrameWndBase< CMDIFrameWnd > |
►C CXTPMDIFrameWnd | CXTPMDIFrameWnd is a CXTPFrameWndBase derived class
C CXTPMDIFrameWndEx | CXTPMDIFrameWndEx is a CXTPMDIFrameWnd derived class
C CXTPTearOffFrame | The class represents a floating torn off frame
►C CXTPControlGalleryPaintManager | CXTPControlGalleryPaintManager is a standalone class used to draw a CXTPControlGallery object
►C CXTPControlGalleryOffice2013Theme | The CXTPControlGalleryResourceTheme class is used to enable a Gallery Office 2013 style theme for Command Bars
C CXTPControlGalleryNativeWindows10Theme | The CXTPControlGalleryResourceTheme class is used to enable a Gallery Native Windows 10 style theme for Command Bars
C CXTPControlGalleryNativeWindows11Theme | The CXTPControlGalleryResourceTheme class is used to enable a Gallery Native Windows 10 style theme for Command Bars
C CXTPControlGalleryVisualStudio2015Theme | The CXTPControlGalleryResourceTheme class is used to enable a Gallery Visual Studio 2015 style theme for Command Bars
C CXTPControlGalleryVisualStudio2017Theme | The CXTPControlGalleryResourceTheme class is used to enable a Gallery Visual Studio 2017 style theme for Command Bars
C CXTPControlGalleryVisualStudio2019Theme | The CXTPControlGalleryResourceTheme class is used to enable a Gallery Visual Studio 2019 style theme for Command Bars
C CXTPControlGalleryVisualStudio2022Theme | The CXTPControlGalleryResourceTheme class is used to enable a Gallery Visual Studio 2022 style theme for Command Bars
C CXTPControlGalleryResourceTheme | Used to enable a Gallery Resource style theme for Command Bars
C CXTPControlSliderCtrl | Inplace slider control of CXTPControlSlider
C CXTPCriticalSection | Critical Section Wrapper
C CXTPCustomizeCommandsListBox | List of the commands
C CXTPDatePickerButton | This class represents a DatePicker button
C CXTPDatePickerButtons | Class CXTPDatePickerButtons represents a collection of buttons
C CXTPDatePickerControl | Class CXTPDatePickerControl encapsulates the functionality of a date and time picker control
C CXTPDatePickerList | This class provides the functionality of a list control which displays month names
C CXTPDeviceCaps | Used to store and update sytem information
C CXTPDialogBase< TBase > | CXTPDialogBase is a TBase derived class
►C CXTPDialogBase< CDialog > |
►C CXTPDialogEx | CXTPDialogEx is a CXTPDialogBase derived class
►C CXTPPropertySheet | CXTPPropertySheet is a CXTPDialogEx derived class
C CXTPCustomizeSheet | CXTPCustomizeSheet is a CPropertySheet derived class
C CXTPDockBar | CXTPDockBar is a CWnd derived class
C CXTPDockContext | CXTPDockContext is a standalone class
C CXTPDockingPaneAutoHideWnd | CXTPDockingPaneAutoHideWnd is a CMiniFrameWnd derived class
►C CXTPDockingPaneBase | CXTPDockingPaneBase is a standalone class
C CXTPDockingPane | CXTPDockingPane is a CXTPDockingPaneBase derived class
►C CXTPDockingPaneBaseContainer | CXTPDockingPaneBaseContainer is a CXTPDockingPaneBase derived class
C CXTPDockingPaneAutoHidePanel | CXTPDockingPaneAutoHidePanel is a multiple inheritance class derived from CWnd and CXTPDockingPaneBase
C CXTPDockingPaneSidePanel | CXTPDockingPaneSidePanel is a multiple inheritance class derived from CWnd and CXTPDockingPaneBase
C CXTPDockingPaneSplitterContainer | CXTPDockingPaneSplitterContainer is a CXTPDockingPaneBase derived class
C CXTPDockingPaneTabbedContainer | CXTPDockingPaneTabbedContainer is a multiple inheritance class derived from CWnd and CXTPDockingPaneBase
C CXTPDockingPaneMiniWnd | CXTPDockingPaneMiniWnd is a multiple inheritance class derived from CMiniFrameWnd and CXTPDockingPaneBase
C CXTPDockingPaneCaptionButton | CXTPDockingPaneCaptionButton is a standalone internal class
C CXTPDockingPaneCaptionButtons | CXTPDockingPaneCaptionButtons is a CArray derived class used to manipulate Caption Buttons
►C CXTPDockingPaneColorSet | Helper class used to initialize default colors for a theme from an .INI resource
C CXTPDockingPaneColorSet2012 | Helper class used to initialize default colors for a theme from an .INI resource
C CXTPDockingPaneColorSet2013 | Helper class used to initialize default colors for a theme from an .INI resource
C CXTPDockingPaneColorSet2015 | Helper class used to initialize default colors for a theme from an .INI resource
C CXTPDockingPaneColorSet2017 | Helper class used to initialize default colors for a theme from an .INI resource
C CXTPDockingPaneColorSet2019 | Helper class used to initialize default colors for a theme from an .INI resource
C CXTPDockingPaneColorSet2022 | Helper class used to initialize default colors for a theme from an .INI resource
C CXTPDockingPaneColorSetNativeWindows10 | Helper class used to initialize default colors for a theme from an .INI resource
C CXTPDockingPaneColorSetNativeWindows11 | Helper class used to initialize default colors for a theme from an .INI resource
C CXTPDockingPaneContext | CXTPDockingPaneContext is a standalone class
C CXTPDockingPaneContextAlphaWnd | CXTPDockingPaneContextAlphaWnd is a CWnd derived class that represents an alpha context helper window
C CXTPDockingPaneContextStickerWnd | CXTPDockingPaneContextStickerWnd is a CWnd derived class that represents a sticker window
C CXTPDockingPaneManager | CXTPDockingPaneManager is a CWnd derived class
C CXTPDockingPaneSplitterWnd | CXTPDockingPaneSplitterWnd is a CWnd derived class
C CXTPDockingPaneWindowSelect | CXTPDockingPaneWindowSelect is a CMiniFrameWnd derived class used to show a window selector for Ctrl+F9 and Alt+F7 handlers
C CXTPDockState | CXTPDockState is a standalone class
C CXTPCalendarData::CXTPDPCache |
C CXTPDropSource | Derived from IDropSource
C CXTPEditListBoxToolBar | CXTPEditListBoxToolBar is a CStatic derived class
C CXTPEmptyRect | CXTPEmptyRect is a helper class used to instantiate an empty CRect object
C CXTPEmptySize | CXTPEmptySize is a helper class used to instantiate an empty CSize object
C CXTPExcelTabCtrl | CXTPExcelTabCtrl is a CWnd derived class
C CXTPExcelTabCtrlButtonState | Used by the CXTPExcelTabCtrl class to manage navigation button information
C CXTPExcludedMemberPadding< Type > | The CXTPExcludedMemberPadding type is used for declaring padding members for the members that were excluded by conditional compilation in order to preserve the layout of the compiled classes
C CXTPExcludedMemberPadding< BOOL > |
C CXTPExcludedMemberPadding< CXTPButton * > |
C CXTPExcludedMemberPadding< CXTPComboBox * > |
C CXTPEyeDropper | Creates an eye dropper control that can be used to select any color that is displayed anywhere on the screen
C CXTPFlowGraphControl | Flow Graph Control
C CXTPFlowGraphEditItem | Represents an edit control used to edit captions for elements in the flow graph
C CXTPFlowGraphPageHistoryItem | Used internally to store Node history for history operations
►C CXTPFlowGraphUndoCommand | This class abstracts the undo command
C CXTPFlowGraphUndoAddConnectionCommand | This class abstracts the undo add connection command
C CXTPFlowGraphUndoAddConnectionPointCommand | This class abstracts the undo add connection point command
C CXTPFlowGraphUndoAddNodeCommand | This class abstracts the undo add Node command
C CXTPFlowGraphUndoDeleteConnectionCommand | This class abstracts the undo delete connection command
C CXTPFlowGraphUndoDeleteConnectionPointCommand | This class abstracts the undo delete connection point command
C CXTPFlowGraphUndoDeleteNodeCommand | This class abstracts the undo delete Node command
C CXTPFlowGraphUndoGroupCommand | This class abstracts the undo commands in a group
C CXTPFlowGraphUndoSetConnectionPositionCommand | This class abstracts the undo set connection position command
C CXTPFlowGraphUndoSetNodeCaptionCommand | This class abstracts the undo set Node caption command
C CXTPFlowGraphUndoSetNodePositionCommand | This class abstracts the undo set Node position command
C CXTPFlowGraphUndoSetNodeSizeCommand | This class abstracts the undo set Node size command
►C CXTPFontCtrlBase | CXTPFontCtrlBase is a base class used by CXTPFontListBox and CXTPFontComboBox controls to perform common drawing routines
C CXTPFontComboBox | CXTPFontComboBox is a CXTPComboBox derived class
C CXTPFontListBox | CXTPFontListBox is a CXTPListBox derived class
C CXTPFontEnum | CXTPFontEnum is a standalone singleton font enumeration class
C CXTPFontManager | Singleton class to manage fonts used by library windows and controls
►C CXTPFramePaintManager | Paint manager for the Office 2007 style window frame
►C CXTPRibbonMarkupFrameTheme | Used to enable a system style theme for Command Bars
C CXTPFrameThemeOffice2007System | Used to enable a system style theme for Command Bars
C CXTPGaugeCtrl | Gauge control hosts a JavaScript and Markup based gauge implementation of a certain type and provides a bidirectional data and event exchange between native and script implementation
C CXTPGaugeTraits | Defines a set of loaded gauge traits
►C CXTPGdiObject | Implements common functionality for all XTP GDI object
C CXTPBrush | Provides a convenient object oriented interface for HBRUSH GDI object and uses GDI handle caching
C CXTPFont | Provides a convenient object oriented interface for HFONT GDI object and uses GDI handle caching
C CXTPPen | Provides a convenient object oriented interface for HPEN GDI object and uses GDI handle caching
C CXTPGlobalAtom | A helper class for handling a global atom primitive
C CXTPGraphicBitmapPng | CXTPGraphicBitmapPng is a CBitmap derived class used to load .PNG files from files and resources
►C CXTPGridControl | Implementation of the Grid control
C CXTPTrackControl | This class represents a track control
C CXTPGridControlLocale | Helper class with static member functions used to control active locale for Grid control and perform some locale dependent tasks
C CXTPGridFilterEditControl | Functionality of the filter string edit control associated to the main Grid control window
C CXTPGridHeaderDragWnd | CXTPGridHeaderDragWnd is a CWnd derived class
C CXTPGridHeaderDropWnd | CXTPGridHeaderDropWnd is a CWnd derived class
C CXTPGridInplaceButtons | This class represents a collection of in-place buttons for a single item of the Grid control
C CXTPGridPageSetupDialog | Customized Grid control page setup dialog
C CXTPGridRecordItemControlHookWnd | This class represents an item control hook window
C CXTPGridSubListControl | Field chooser list box control
C CXTPGridTip | Encapsulates the functionality of a "tip control", a small pop-up window that displays a single line of text describing the hidden text when hovering an item on the grid area
C CXTPGridView | Implementation of the Grid control as a view class
C CXTPGridViewPrintOptions | This class is used to store printing options
C CXTPGroupLine | CXTPGroupLine is a CStatic derived class
C CXTPHeaderCtrl | CXTPHeaderCtrl is a CHeaderCtrl derived class
C CXTPHeapAllocatorT< _TData > | This template class used as a base class for allocators which can use a custom (separate) heap
C CXTPHeapObjectT< _TObject, _TAllocator > | This template class used as a helper class to override new/delete operators and use custom heap allocators inside them
►C CXTPHeapString | This class used to store strings
C CXTPHeapStringT< _TAllocator > | This template used to store strings using different allocators
C CXTPHexEdit | CXTPHexEdit is a CEdit derived class
C CXTPHookManager | CXTPHookManager is standalone class
►C CXTPHookManagerHookAble | HookAble interface
►C CXTPCommandBar | CXTPCommandBar is a CWnd derived class
►C CXTPPopupBar | CXTPPopupBar is a CXTPCommandBar derived class
►C CXTPControlComboBoxPopupBar | CXTPControlComboBoxPopupBar is a CXTPPopupBar derived class
C CXTPControlComboBoxGalleryPopupBar | CXTPControlComboBoxPopupBar object
►C CXTPControlComboBoxList | CXTPControlComboBoxList is a CXTPControlComboBoxPopupBar derived class
C CXTPControlFontComboBoxList | CXTPControlFontComboBoxList is a CXTPControlComboBoxList derived class
►C CXTPPopupToolBar | CXTPPopupToolBar is a CXTPPopupBar derived class
C CXTPMiniToolBar | Represents a MiniToolbar object
C CXTPRibbonTabPopupToolBar | Implements a pop-up when the Ribbon is in minimzed mode
C CXTPRibbonSystemPopupBar | CXTPRibbonSystemPopupBar is a CXTPPopupBar derived class used as a system pop-up bar for a Ribbon Bar
C CXTPRibbonSystemPopupBarPage | CXTPRibbonSystemPopupBarPage is a CXTPPopupBar derived class used as a system pop-up bar page of a Ribbon Bar
C CXTPRibbonBackstageView | CXTPRibbonBackstageView is a CDialog derived class used for a Backstage parent frame
►C CXTPToolBar | CXTPToolBar is a CXTPCommandBar derived class
C CXTPDialogBar | CXTPDialogBar is a CXTPToolBar derived class
►C CXTPMenuBar | CXTPMenuBar is a CXTPToolBar derived class
C CXTPRibbonBar | CXTPRibbonBar is a CXTPMenuBar derived class
C CXTPTabToolBar | CXTPTabToolBar is a CXTPToolBar derived class
►C CXTPCommandBarsFrameHook | CXTPCommandBarsFrameHook is a CXTPHookManagerHookAble derived class
C CXTPTearOffFrame | The class represents a floating torn off frame
C CXTPControlCustom | CXTPControlCustom is a CXTPControlButton derived class
C CXTPHyperLink | CXTPHyperLink is a CStatic derived class
C CXTPIconHandle | CXTPIconHandle is a standalone helper class
C CXTPImageEditorDlg | CXTPImageEditorDlg is a CDialog derived class
C CXTPImageList | CXTPImageList extends CImageList with add additional functionality for images resizing that depends on DPI
C CXTPImageManagerIconHandle | CXTPImageManagerIconHandle is a HICON wrapper class
C CXTPImageManagerImageList | This class is used to connect ImageManager with specified HIMAGELIST
C CXTPImageManagerResource |
C CXTPImageManagerVectorImageHandle | Represents a generic interface for a vector image of any possible format to be used with CXTPImageManager
C CXTPInternalCollectionT< _TObject > |
C CXTPKeyboardManager | CXTPKeyboardManager class used to handle keyboard hooks
►C CXTPListBase | CXTPListBase is a non-inherited class
C CXTPShellListBase | CXTPShellListBase is a multiple inheritance class derived from CXTPListView and CXTPShellPidl
►C CXTPListBox | CXTPListBox is a CListBox derived class
C CXTPCheckListBox | CXTPListBox derived class
C CXTPEditListBox | CXTPEditListBox is a CXTPListBox derived class
C CXTPFontListBox | CXTPFontListBox is a CXTPListBox derived class
C CXTPPropertyPageListNavigator | CXTPPropertyPageListNavigator is a CXTPListBox and CXTPPropertyPageControlNavigator derived class
►C CXTPListBoxTheme | CXTPListBoxTheme is the base class used by CXTPListBox themes to draw the list box control
C CXTPListBoxThemeDefault | CXTPListBoxThemeDefault is used by CXTPListBox to draw a default style list box
►C CXTPListBoxThemeOffice2013 | CXTPListBoxThemeOffice2013 is used by CXTPListBox to draw an Office 2013 style list box
C CXTPListBoxThemeNativeWindows10 | CXTPListBoxThemeNativeWindows10 is used by CXTPListBox to draw a Native Windows 10 style list box
C CXTPListBoxThemeNativeWindows11 | CXTPListBoxThemeNativeWindows11 is used by CXTPListBox to draw a Native Windows 10 style list box
C CXTPListBoxThemeVisualStudio2015 | CXTPListBoxThemeVisualStudio2015 is used by CXTPListBox to draw a Visual Studio 2015 style list box
C CXTPListBoxThemeVisualStudio2017 | CXTPListBoxThemeVisualStudio2017 is used by CXTPListBox to draw a Visual Studio 2017 style list box
C CXTPListBoxThemeVisualStudio2019 | CXTPListBoxThemeVisualStudio2019 is used by CXTPListBox to draw a Visual Studio 2019 style list box
C CXTPListBoxThemeVisualStudio2022 | CXTPListBoxThemeVisualStudio2022 is used by CXTPListBox to draw a Visual Studio 2022 style list box
►C CXTPListBoxThemeOfficeXP | CXTPListBoxThemeOfficeXP is used by CXTPListBox to draw an Office XP style list box
C CXTPListBoxThemeOffice2003 | CXTPListBoxThemeOffice2003 is used by CXTPListBox to draw an Office 2003 style list box
C CXTPListBoxThemeResource | CXTPListBoxThemeResource is used by CXTPListBox to draw a resource style list box
C CXTPListCtrl | CXTPListCtrl is a multiple inheritance class derived from CListCtrl and CXTPListBase
C CXTPListView | CXTPListView is a multiple inheritance class derived from CListView and CXTPListBase
C CXTPLockGuard | Critical Sections Lock/Unlock helper
C CXTPLogFont | CXTPLogFont is a self initializing LOGFONT derived class
►C CXTPMarkupContext | CXTPMarkupContext is a standalone class used to provide common settings for Markup objects
C CXTPMarkupTreeCtrl | Tree control class that allows for adding markup items
►C CXTPMarkupDeviceDependentImage | Implements an abstract device dependent image
C CXTPMarkupGdiImage | Implements an abstract GDI device dependent image
C CXTPMarkupGdiPlusImage | Implements an abstract GDI+ device dependent image
►C CXTPMarkupGdiPlusTransformObjectImpl | Implements GDI+ markup matrix access and delegates the actual transformation to a derived class
►C CXTPMarkupGdiPlusTransformObject< CXTPMarkupMatrixTransform > |
C CXTPMarkupGdiPlusMatrixTransform | GDI+ MatrixTransform implementation
►C CXTPMarkupGdiPlusTransformObject< CXTPMarkupRotateTransform > |
C CXTPMarkupGdiPlusRotateTransform | GDI+ RotateTransform implementation
►C CXTPMarkupGdiPlusTransformObject< CXTPMarkupScaleTransform > |
C CXTPMarkupGdiPlusScaleTransform | GDI+ ScaleTransform implementation
►C CXTPMarkupGdiPlusTransformObject< CXTPMarkupSkewTransform > |
C CXTPMarkupGdiPlusSkewTransform | GDI+ SkewTransform implementation
►C CXTPMarkupGdiPlusTransformObject< CXTPMarkupTranslateTransform > |
C CXTPMarkupGdiPlusTranslateTransform | GDI+ TranslateTransform implementation
C CXTPMarkupGdiPlusTransformObject< BaseTransform > | Base class for all GDI+ markup transformation objects
►C CXTPMarkupStaticExtension | A base class for a markup static extension composite object
►C CXTPMarkupStaticExtensionProperty | A convenience base class for all static extension properties
C CXTPMarkupStaticExtensionBooleanProperty | A convenience class that represents a boolean static extension property
C CXTPMarkupStaticExtensionBrushProperty | A convenience class that represents a brush static extension property
C CXTPMarkupStaticExtensionColorProperty | A convenience class that represents an RGB color static extension property
C CXTPMarkupStaticExtensionDoubleProperty | A convenience class that represents a double static extension property
C CXTPMarkupStaticExtensionIntegerProperty | A convenience class that represents an integer static extension property
C CXTPMarkupStaticExtensionStringProperty | A convenience class that represents a string static extension property
C CXTPMarkupSystemBrushKeyStaticExtension | A property static extension object that represents a system brush key
C CXTPMarkupSystemBrushStaticExtension | A property static extension object that represents a system brush
C CXTPMarkupSystemColorKeyStaticExtension | A property static extension object that represents a system color key
C CXTPMarkupSystemColorStaticExtension | A property static extension object that represents a system color
C CXTPMarkupSystemColorsStaticExtension | A composite static extension object that represents system colors
C CXTPRibbonOffice2013Theme::CThemeStaticExtension | Helper class used to define variables to be used by XAML Markup code
C CXTPMarkupThemePart | Used to create a theme part object used for rendering
►C CXTPMarkupTransformationMatrix | An abstract class for device context transformation matrix
C CXTPMarkupGdiPlusTransformationMatrix | Encapsulates GDI+ transformation matrix access
C CXTPMarqueeCtrl | CXTPMarqueeCtrl is a CProgressCtrl derived class
►C CXTPMarqueeCtrlPaintManager | Derived from CCmdTarget and is used by the progress bar to perform all default drawing routines
►C CXTPMarqueeCtrlThemeFlat | Derived from CXTPMarqueeCtrlPaintManager and is used by the progress bar to draw a flat style progress bar
C CXTPMarqueeCtrlThemeUltraFlat | Derived from CXTPMarqueeCtrlThemeFlat and is used by the progress bar to draw a flat style progress bar with no borders
C CXTPMarqueeCtrlThemeNativeWinXP | Derived from CXTPMarqueeCtrlPaintManager and is used by the progress bar to draw a native Windows style progress bar
C CXTPMarqueeCtrlThemeNativeWindows | Derived from CXTPMarqueeCtrlPaintManager and is used by the progress bar to draw a native Windows style progress bar
►C CXTPMarqueeCtrlThemeOffice2000 | The CXTPMarqueeCtrlThemeFlat class is derived from CXTPMarqueeCtrlPaintManager and is used by the progress bar to draw an Office 2000 style progress bar
C CXTPMarqueeCtrlThemeOffice2003 | The CXTPMarqueeCtrlThemeFlat class is derived from CXTPMarqueeCtrlPaintManager and is used by the progress bar to draw an Office 2003 style progress bar
►C CXTPMarqueeCtrlThemeOffice2013 | The CXTPMarqueeCtrlThemeFlat class is derived from CXTPMarqueeCtrlPaintManager and is used by the progress bar to draw an Office 2013 style progress bar
C CXTPMarqueeCtrlThemeVisualStudio2015 | The CXTPMarqueeCtrlThemeFlat class is derived from CXTPMarqueeCtrlPaintManager and is used by the progress bar to draw a Visual Studio 2015 style progress bar
C CXTPMarqueeCtrlThemeVisualStudio2017 | The CXTPMarqueeCtrlThemeFlat class is derived from CXTPMarqueeCtrlPaintManager and is used by the progress bar to draw a Visual Studio 2017 style progress bar
C CXTPMarqueeCtrlThemeVisualStudio2019 | The CXTPMarqueeCtrlThemeFlat class is derived from CXTPMarqueeCtrlPaintManager and is used by the progress bar to draw a Visual Studio 2019 style progress bar
C CXTPMarqueeCtrlThemeVisualStudio2022 | The CXTPMarqueeCtrlThemeFlat class is derived from CXTPMarqueeCtrlPaintManager and is used by the progress bar to draw a Visual Studio 2022 style progress bar
C CXTPMarqueeCtrlThemeOfficeXP | The CXTPMarqueeCtrlThemeXP class is derived from CXTPMarqueeCtrlThemeFlat and is used by the progress bar to draw an Office XP style progress bar
C CXTPMarqueeCtrlThemeResource | The CXTPMarqueeCtrlThemeFlat class is derived from CXTPMarqueeCtrlPaintManager and is used by the progress bar to draw an progress bar using a resource DLL
C CXTPMaskEditT< TBase > | CXTPMaskEditT is a template class
►C CXTPMaskEditT< CEdit > |
►C CXTPEdit | CXTPEdit is a CEdit derived class
►C CXTPBrowseEdit | CXTPBrowseEdit is a CXTPEdit derived class
C CXTPItemEdit | CXTPItemEdit is a CXTPBrowseEdit derived class
►C CXTPMaskEdit | CXTPMaskEdit is a CXTPEdit derived class
►C CXTPDateEdit | CXTPDateEdit is a CXTPMaskEdit derived class
C CXTPTimeEdit | CXTPTimeEdit is a CXTPDateEdit derived class
C CXTPPasswordPeek | CXTPPasswordPeek is a CXTPEdit derived class
C CXTPGridInplaceEdit | CXTPGridInplaceEdit is a CXTPGridInplaceControl derived class that represents an edit control to allow users to change a cell of a Grid control
C CXTPPropertyGridInplaceEdit | CXTPPropertyGridInplaceEdit is a CEdit derived class
C CXTPMathUtils | This class provide some mathematical utility functions
C CXTPMatrix< T > | Represents a matrix object built upon a continuos array of elements and provides basic algorithms for it
C CXTPMatrix< double > |
C CXTPMDIClientWnd | CXTPMDIClientWnd is a CWnd derived helper class for the CXTPMDIWndTab tab control
C CXTPMDIWndTab | Used for creating a tabbed MDI document interface
C CXTPMemFile | CXTPMemFile is a CMemFile derived class
C CXTPMessageBar | CXTPMessageBar is a CControlBar derived class
C CXTPMessageBarButton | CXTPMessageBarButton is a standalone class
►C CXTPMessageBarPaintManager | Used by the message bar to perform standard paint routines
C CXTPMessageBarThemeOffice2010 | Used by the message bar to draw an Office 2010 style message bar
►C CXTPMessageBarThemeOffice2013 | Used by the message bar to draw an Office 2013 style message bar
C CXTPMessageBarThemeNativeWindows10 | Used by the message bar to draw a Native Windows 10 style message bar
C CXTPMessageBarThemeNativeWindows11 | Used by the message bar to draw a Native Windows 10 style message bar
C CXTPMessageBarThemeVisualStudio2015 | Used by the message bar to draw a Visual Studio 2015 style message bar
C CXTPMessageBarThemeVisualStudio2017 | Used by the message bar to draw a Visual Studio 2017 style message bar
C CXTPMessageBarThemeVisualStudio2019 | Used by the message bar to draw a Visual Studio 2019 style message bar
C CXTPMessageBarThemeVisualStudio2022 | Used by the message bar to draw a Visual Studio 2022 style message bar
C CXTPModuleHandle | CXTPModuleHandle class is helper for LoadLibray/GetModuleHandle methods
C CXTPMouseManager | CXTPMouseManager is standalone class
C CXTPMultiMonitor | MultiMonitor API wrapper class
C CXTPNonClientMetrics | CXTPNonClientMetrics is a self-initializing NONCLIENTMETRICS derived class
►C CXTPNotifySinkBase | This class is used as implementation of Sink interface in a XTPNotification mechanism
C CXTPCalendarResourcesNf | This class implements CXTPCalendarResource functionality with the addition of a notifications mechanism implemented by CXTPNotifySink
C CXTPObservable< Owner, Observer > | Provides a basic implementation of the Observable design pattern
►C CXTPObservable< CXTPApplication, IXTPApplicationEvents > |
C CXTPApplication | Defines a global XTP application object interface
►C CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > |
C CXTPChartDeviceCommand | Defines a common implementation interface for chart drawing commands
►C CXTPObservable< CXTPFrameShadowManager, IXTPFrameShadowManagerEvents > |
C CXTPFrameShadowManager | Provides frame shadow management functionality
►C CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > |
C CXTPPaintManager | Paint manager of the command bars
C CXTPObservable< Observable, Observer > |
C CXTPOpenGLUtils | Provides a set of common OpenGL utilities
C CXTPPageScroller | CXTPPageScroller is a CWnd derived class
C CXTPPaintManagerColor | Used to manage COLORREF values for determining default and application defined colors
C CXTPPaintManagerColorGradient | Used to manage COLORREF values for determining light and dark gradient colors
C CXTPPaintManagerFont | PaintManagers used CFont wrapper
C CXTPPoint2T< T > | This class represents a two-dimensional point
C CXTPPoint2T< float > |
C CXTPPoint2T< int > |
C CXTPPoint3T< T > | This class represents a three-dimensional point
C CXTPPoint3T< double > |
C CXTPPoint3T< float > |
C CXTPPopupControl | CXTPPopupControl is a class for control of a pop-up window
►C CXTPPopupPaintManager | CXTPPopupPaintManager is a class used to perform specialized drawing tasks
►C CXTPPopupThemeOffice2000 | CXTPPopupThemeOffice2000 is a class used to perform Office 2000 drawing tasks
C CXTPPopupThemeMSN | CXTPPopupThemeMSN is a class used to perform MSN Messenger drawing tasks
►C CXTPPopupThemeOfficeXP | CXTPPopupThemeOfficeXP is a class used to perform Office XP drawing tasks
►C CXTPPopupThemeOffice2003 | CXTPPopupThemeOffice2003 is a class used to perform Office 2003 drawing tasks
C CXTPPopupThemeOffice2013 | CXTPPopupThemeOffice2013 is a class used to perform Office 2013 drawing tasks
C CXTPPopupThemeResource | CXTPPopupThemeResource is a class used to perform resource drawing tasks
C CXTPPreviewCtrl | Implements the preview control that can display visual preview data provided by the best matching preview provider registered to the control
C CXTPPreviewView | CXTPPreviewView is a CPreviewView derived class that represents a print preview window with a themed toolBar
►C CXTPProgressBase | CXTPControlProgressBase is base class for all progress objects
C CXTPControlProgress | CXTPControlProgress is a CXTPControl derived class
C CXTPStatusBarProgressPane | CXTPStatusBarProgressPane is a CXTPStatusBarPane derived class
C CXTPProgressCtrl | The ProgressBar control shows the progress of a lengthy operation by filling a rectangle with chunks from left to right
►C CXTPProgressPaintManager | CXTPProgressPaintManager object
►C CXTPProgressThemeOffice2013 | CXTPProgressThemeOffice2013 object
C CXTPProgressThemeNativeWindows10 | CXTPProgressThemeNativeWindows10 object
C CXTPProgressThemeNativeWindows11 | CXTPProgressThemeNativeWindows11 object
C CXTPProgressThemeVisualStudio2015 | CXTPProgressThemeVisualStudio2015 object
C CXTPProgressThemeVisualStudio2017 | CXTPProgressThemeVisualStudio2017 object
C CXTPProgressThemeVisualStudio2019 | CXTPProgressThemeVisualStudio2019 object
C CXTPProgressThemeVisualStudio2022 | CXTPProgressThemeVisualStudio2022 object
C CXTPPropertyGrid | CXTPPropertyGrid is a CWnd derived class
►C CXTPPropertyGridInplaceControl | CXTPPropertyGridInplaceControl is a CWnd derived class that represents the base class for all items with in-place controls
C CXTPPropertyGridInplaceSlider | CXTPPropertyGridInplaceSlider is a CXTPPropertyGridInplaceControl derived class
C CXTPPropertyGridInplaceSpinButton | CXTPPropertyGridInplaceSpinButton is a CXTPPropertyGridInplaceControl derived class
C CXTPPropertyGridInplaceControls | CXTPPropertyGridInplaceControls is a standalone class that represents a collection of CXTPPropertyGridInplaceControl classes
C CXTPPropertyGridInplaceList | CXTPPropertyGridInplaceList is a CListBox derived class
C CXTPPropertyGridInplaceMonthCal | Month calendar pop-up used for CXTPPropertyGridItemDate item
C CXTPPropertyGridInplaceMultilineEdit | CXTPPropertyGridInplaceMultilineEdit is a CEdit derived class
C CXTPPropertyGridToolBar | CXTPPropertyGridToolBar is a CToolBar derived class
C CXTPPropertyGridToolTip | CXTPPropertyGridToolTip is a CWnd derived class
C CXTPPropertyGridView | CXTPPropertyGridView is a CListBox derived class
►C CXTPPropertyPageNavigator | CXTPPropertyPageNavigator is a standalone class
►C CXTPPropertyPageControlNavigator | CXTPPropertyPageControlNavigator is a CXTPPropertyPageNavigator derived class
C CXTPPropertyPageListNavigator | CXTPPropertyPageListNavigator is a CXTPListBox and CXTPPropertyPageControlNavigator derived class
C CXTPPropertyPageTreeNavigator | CXTPPropertyPageTreeNavigator is a CTreeCtrl and CXTPPropertyPageControlNavigator derived class
C CXTPPropExchangeEnumerator | CXTPPropExchangeEnumerator is standalone class
C CXTPPropExchangeSection | CXTPPropExchangeSection is standalone class
C CXTPReBar | The CXTPReBar object extends the standard MFC CReBar class to provide extended functionality such as saving and restoring band layouts
C CXTPReBarPaintManager< TBase > | The CXTPReBarPaintManager template class is used to enable a ReBar theme for Command Bars
C CXTPRectT< T > | This class abstracts a rectangular entity and its operations
C CXTPRectT< float > |
C CXTPRegistryManager | CXTPRegistryManager is a standalone registry management class
►C CXTPResize | CXTPResize is a base class
►C CXTPPropertyPage | CXTPPropertyPage is a CPropertyPage derived class
C CXTPCustomizeCommandsPage | CXTPCustomizeCommandsPage is a CPropertyPage derived class
C CXTPCustomizeKeyboardPage | CXTPCustomizeKeyboardPage is a CPropertyPage derived class
C CXTPCustomizeMenusPage | CXTPCustomizeMenusPage is a CPropertyPage derived class
C CXTPCustomizeOptionsPage | CXTPCustomizeOptionsPage is a CPropertyPage derived class
C CXTPCustomizeToolbarsPage | CXTPCustomizeToolbarsPage is a CPropertyPage derived class
C CXTPRibbonCustomizePage | CXTPRibbonCustomizePage is a CPropertyPage derived class
C CXTPRibbonCustomizeQuickAccessPage | CXTPRibbonCustomizeQuickAccessPage is a CPropertyPage derived class
►C CXTPResizeDialog | CXTPResizeDialog is a multiple inheritance class derived from CDialog and CXTPResize
C CXTPWindowList | CXTPWindowList dialog
C CXTPResizeFormView | CXTPResizeFormView is a multiple inheritance class derived from CFormView and CXTPResize
C CXTPResizePropertyPage | CXTPResizePropertyPage is a multiple inheritance class derived from CPropertyPage and CXTPResize
C CXTPResizePropertySheet | CXTPResizePropertySheet is a multiple inheritance class derived from CPropertySheet and CXTPResize
C CXTPResizeItem | CXTPResizeItem is a standalone helper class
►C CXTPResourceManager | Standalone class used to managed toolkit resources
C CXTPResourceManagerXML | Class used to managed toolkit resources from an XML file
C CXTPRWCriticalSection | Implements recursive read-write lock synchronization pattern
C CXTPScrollBarContainer< Parent > | CXTPScrollBarContainer class adds XTP scroll bars to a class derived from CWnd
►C CXTPScrollBarContainer< CSplitterWnd > |
►C CXTPSplitterWnd | CXTPSplitterWnd is a CSplitterWnd derived class
C CXTPSplitterWndEx | CXTPSplitterWndEx is a CXTPSplitterWnd derived class
►C CXTPScrollBarContainer< CWnd > |
C CXTPTaskPanel | CXTPTaskPanel is used to implement an Explorer and Office-like Task Panel control
►C CXTPScrollBarContainer< Parent > |
C CXTPDialogScrollBarContainer< Parent > | CXTPDialogScrollBarContainer class adds XTP scroll bars to a class derived from CDialog
►C CXTPScrollBarPaintManager | CXTPScrollBarPaintManager is standalone class used to draw CXTPCommandBarScrollBarCtrl object
►C CXTPScrollBarThemeOffice2013 | Used to enable a Gallery Office 2013 style theme for Command Bars
C CXTPScrollBarThemeNativeWindows10 | Scrollbar paint manager used to draw Native Windows 10 like scrollbars
C CXTPScrollBarThemeNativeWindows11 | Scrollbar paint manager used to draw Native Windows 10 like scrollbars
C CXTPScrollBarThemeResource | Scrollbar paint manager used to draw scrollbars from the currently loaded resource image data
►C CXTPScrollBarThemeVisualStudio2012 | Scrollbar paint manager used to draw Visual Studio 2012 like scrollbars
C CXTPScrollBarThemeVisualStudio2015 | Scrollbar paint manager used to draw Visual Studio 2015 like scrollbars
C CXTPScrollBarThemeVisualStudio2017 | Scrollbar paint manager used to draw Visual Studio 2017 like scrollbars
C CXTPScrollBarThemeVisualStudio2019 | Scrollbar paint manager used to draw Visual Studio 2019 like scrollbars
C CXTPScrollBarThemeVisualStudio2022 | Scrollbar paint manager used to draw Visual Studio 2022 like scrollbars
►C CXTPScrollBarThemeWindowsClassic | Scrollbar paint manager used to draw classic Windows scrollbars
►C CXTPScrollBarThemeWindowsUx | Scrollbar paint manager used to draw scrollbars that use current Windows theme
►C CXTPScrollBarThemeFlat | Scrollbar paint manager used to draw flat scrollbars
C CXTPScrollBarThemeUltraFlat | Scrollbar paint manager used to draw ultra flat scrollbars
C CXTPScrollBarThemeOffice2000 | Scrollbar paint manager used to draw Office 200 like scrollbars
C CXTPScrollBarThemeOffice2003 | Scrollbar paint manager used to draw Office 2003 like scrollbars
C CXTPScrollBarThemeOfficeXP | Scrollbar paint manager used to draw Office XP like scrollbars
C CXTPSliderPaintManager | Paint manager for the slider control
►C CXTPScrollBase | CXTPScrollBase is the base class for all scrollable objects
C CXTPControlGallery | CXTPControlGallery is a CXTPControlPopup derived class
C CXTPControlScrollBar | CXTPControlScrollBar is a CXTPControl derived class
►C CXTPScrollBarCtrl | Scrollbar control
C CXTPCommandBarScrollBarCtrl | CXTPCommandBarScrollBarCtrl is a CScrollBar derived class
C CXTPScrollBar | Scrollbar control
C CXTPStatusBarScrollBarPane | CXTPStatusBarScrollBarPane is a CXTPStatusBarPane derived class
C CXTPSearchOptionsCtrl | CXTPSearchOptionsCtrl is a CStatic derived class
C CXTPSearchOptionsView | CXTPSearchOptionsView is a CFormView derived class
►C CXTPShellListCtrl | CXTPShellListCtrl is a multiple inheritance class derived from CXTPListCtrl and CXTPShellPidl
C CXTPShellListCtrlEx | CXTPShellListCtrlEx is a CXTPShellListCtrl derived class
C CXTPShellListView | CXTPShellListView is a multiple inheritance class derived from CXTPListView and CXTPShellPidl
►C CXTPShellPidl | CXTPShellPidl is a standalone base class
C CXTPShellListBase | CXTPShellListBase is a multiple inheritance class derived from CXTPListView and CXTPShellPidl
C CXTPShellTreeBase | CXTPShellTreeBase is a multiple inheritance class derived from CXTPTreeView and CXTPShellPidl
C CXTPShellSettings | CXTPShellSettings is a SHELLFLAGSTATE struct derived class
C CXTPShellTreeCtrl | CXTPShellTreeCtrl is a multiple inheritance class derived from CXTPTreeCtrl and CXTPShellPidl
C CXTPShellTreeView | CXTPShellTreeView is a multiple inheritance class derived from CXTPTreeView and CXTPShellPidl
C CXTPShortcutBar | CXTPShortcutBar is a CWnd derived class used to implement an Outlook 2003 shortcut bar control style
C CXTPShortcutBarPane | CXTPShortcutBarPane is a CWnd derived class used as a client area for a shortcut bar control
C CXTPShortcutBarPaneItem | CXTPShortcutBarPaneItem is a base class that represents an item for a shortcut bar pane
C CXTPShortcutListBox | CCXTPShortcutListBox is a CListBox derived class
C CXTPShortcutManagerAccelTable | CXTPShortcutManagerAccelTable represents an accelerator table for the CXTPShortcutManager class
C CXTPSimpleCriticalSection | Implements simple and lightweight synchronization critical section primitive
C CXTPSimpleEvent | Implements no-named simple and lightweight synchronization event primitive
C CXTPSingleton< T, Dependencies > | Implements Singleton design pattern
►C CXTPSingleton< CXTPChart2dDrawingObjectFactory > |
C CXTPChart2dDrawingObjectFactory | Implements a 2D drawing object factory singleton
►C CXTPSingleton< CXTPChart3dDrawingObjectFactory > |
C CXTPChart3dDrawingObjectFactory | Implements a 3D drawing object factory singleton
C CXTPSingleton< CXTPChartObjectFactory > |
►C CXTPSingleton< CXTPOpenGLListPool > |
C CXTPOpenGLListPool | Provides a convenient API around an OpenGL list for reliable list management
C CXTPSingleton< CXTPSkinManagerSchemaCodeManager > |
►C CXTPSingleton< Derived > |
C CXTPSingletonBase< Derived, Parent > | Implements Singleton design pattern for a derived class with possibility of providing a parent class
C CXTPSingletonDependencies< Singleton1, Singleton2, Singleton3, Singleton4, Singleton5, Singleton6, Singleton7, Singleton8, Singleton9, Singleton10 > | Describes the list of up to 10 optional singleton dependencies
C CXTPSizeIcon | CStatic derived helper class
C CXTPSizeT< T > | This class incapsulates size data
C CXTPSkinManagerColorFilter | CXTPSkinManagerColorFilter represents the parent class for all color filters of skin manager
C CXTPSmartPtrInternalT< _TObject > |
C CXTPSmartPtrInternalT< CXTPSyntaxEditConfigurationManager > |
C CXTPSmartPtrInternalT< CXTPSyntaxEditLexClass > |
C CXTPSmartPtrInternalT< CXTPSyntaxEditLexTextBlock > |
C CXTPSortClass | CXTPSortClass is a standalone class
C CXTPSoundManager | CXTPSoundManager is a standalone class
C CXTPSpinButtonCtrl | Functionality of a themed Windows spin button control
C CXTPSplitPath | CXTPSplitPath conveniently wraps the _splitpath API for easier access to path components such as file name and extension
C CXTPStatusBar | CXTPStatusBar is a CControlBar derived class
►C CXTPStatusBarThemeOffice2013 | The CXTPStatusBarThemeVisualStudio2015 class is used to enable the Office 2013 style theme for the status bar
C CXTPStatusBarThemeNativeWindows10 | Used to enable the Native Windows 10 style theme for the status bar
C CXTPStatusBarThemeNativeWindows11 | Used to enable the Native Windows 10 style theme for the status bar
C CXTPStatusBarThemeVisualStudio2015 | Used to enable the Visual Studio 2015 style theme for the status bar
C CXTPStatusBarThemeVisualStudio2017 | Used to enable the Visual Studio 2017 style theme for the status bar
C CXTPStatusBarThemeVisualStudio2019 | Used to enable the Visual Studio 2019 style theme for the status bar
C CXTPStatusBarThemeVisualStudio2022 | Used to enable the Visual Studio 2022 style theme for the status bar
►C CXTPStickerBase | A sticker base control
C CXTPTabClientSticker | A tab client sticker control
C CXTPSubscriptionList< Observable, Observer > | Holds a list of observable objects to which an oberser is subscribed
C CXTPSubscriptionList< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > |
C CXTPSubscriptionList< Owner, Observer > |
C CXTPSvgImage | Implements basic SVG image format support
►C CXTPSynchronized | A base class for a synchronized object
C CXTPApplication | Defines a global XTP application object interface
C CXTPSkinImage | Simple bitmap holder and draw operations for Skin Framework
C CXTPSkinImages | CXTPSkinImages represents a cached collection of CXTPSkinImage classes
C CXTPSkinManager | CXTPSkinManager is a standalone class that represents a global object that manages skins
C CXTPSkinManagerClass | CXTPSkinManagerClass is a standalone class that represents a single visual class of the skin manager
C CXTPSkinManagerMetrics | CXTPSkinManagerMetrics is a standalone class that represents a collection of metrics of the current skin
C CXTPSkinManagerResourceFile | CXTPSkinManagerResourceFile is a standalone class that represents a manager of visual style resources
C CXTPSkinManagerSchema | CXTPSkinManagerSchema is a standalone class used to read a visual styles schema file
C CXTPSkinManagerSchemaProperty | CXTPSkinManagerSchemaProperty is a standalone class representing a single property of a visual styles .ini file
►C CXTPSkinObject | CXTPSkinObject is a CWnd derived class
►C CXTPSkinObjectFrame | CXTPSkinObjectFrame is a CXTPSkinObject derived class
C CXTPSkinObjectButton | CXTPSkinObjectButton is a CXTPSkinObjectFrame derived class
►C CXTPSkinObjectComboBox | CXTPSkinObjectComboBox is a CXTPSkinObjectFrame derived class
C CXTPSkinObjectDateTime | CXTPSkinObjectDateTime is a CXTPSkinObjectComboBox derived class
C CXTPSkinObjectHeader | CXTPSkinObjectHeader is a CXTPSkinObjectFrame derived class
C CXTPSkinObjectMonthCal | CXTPSkinObjectMonthCal is a CXTPSkinObjectFrame derived class
C CXTPSkinObjectProgress | CXTPSkinObjectProgress is a CXTPSkinObjectFrame derived class
C CXTPSkinObjectReBar | CXTPSkinObjectReBar is a CXTPSkinObjectFrame derived class
C CXTPSkinObjectScrollBar | CXTPSkinObjectScrollBar is a CXTPSkinObjectFrame derived class
C CXTPSkinObjectSolidFilled | CXTPSkinObjectSolidFilled is a CXTPSkinObjectFrame derived class
C CXTPSkinObjectSpin | CXTPSkinObjectSpin is a CXTPSkinObjectFrame derived class
C CXTPSkinObjectStatusBar | CXTPSkinObjectStatusBar is a CXTPSkinObjectFrame derived class
C CXTPSkinObjectTab | CXTPSkinObjectTab is a CXTPSkinObjectFrame derived class
C CXTPSkinObjectToolBar | CXTPSkinObjectToolBar is a CXTPSkinObjectFrame derived class
C CXTPSkinObjectTrackBar | CXTPSkinObjectTrackBar is a CXTPSkinObjectFrame derived class
►C CXTPSkinObjectUser32Control | CXTPSkinObjectUser32Control is a CXTPSkinObjectFrame derived class
►C CXTPSkinObjectComCtl32Control | CXTPSkinObjectComCtl32Control is a CXTPSkinObjectUser32Control derived class
C CXTPSkinObjectListView | CXTPSkinObjectListView is a CXTPSkinObjectComCtl32Control derived class
C CXTPSkinObjectTreeView | CXTPSkinObjectTreeView is a CXTPSkinObjectComCtl32Control derived class
C CXTPSkinObjectEdit | CXTPSkinObjectEdit is a CXTPSkinObjectUser32Control derived class
C CXTPSkinObjectListBox | CXTPSkinObjectListBox is a CXTPSkinObjectUser32Control derived class
C CXTPSkinObjectClassMap | CXTPSkinObjectClassMap is a standalone class that helps map windows controls to skin framework classes
C CXTPSyntaxEditAutoCompleteWnd | This class implements the auto-complete window
C CXTPSyntaxEditBufferCommand::CXTPSyntaxEditBufferKeepOverwriteSettings | Keeps the buffer overwrite flag for the specified buffer manager from class construction until destruction, and resets this flag to FALSE during class lifetime
C CXTPSyntaxEditColorComboBox | This class allows for colors to be edited by using a combobox control
C CXTPSyntaxEditColorInfo | This storage class is designed to contain information from the color settings file section
C CXTPSyntaxEditColorInfoArray | This collection class stores the color info objects
C CXTPSyntaxEditColorSampleText | This class, derived from CStatic, is used to display a sample of colored text
C CXTPSyntaxEditColorTheme | This class provides the functionality to read configuration information from configuration files with a predefined structure
C CXTPSyntaxEditColorThemesManager | This class provides the functionality to store the set of all color themes that would be written from configuration files
►C CXTPSyntaxEditCommand | This class represents an abstract Edit Control command interface
C CXTPSyntaxEditBatchCommand | This class represents a pack of commands in one
►C CXTPSyntaxEditBufferCommand | The base class for all edit commands related to CXTPSyntaxEditBufferManager
C CXTPSyntaxEditDeleteStringCommand | This class represents the delete string command
C CXTPSyntaxEditInsertStringCommand | This class represents the insert string command
C CXTPSyntaxEditReplaceStringCommand | This class represents the replace string command
C CXTPSyntaxEditCtrl | This class is the main CWnd-based editor class
C CXTPSyntaxEditDoc | This class represents the Document portion of an Edit control
C CXTPSyntaxEditDrawTextProcessor | This helper class is used by CXTPSyntaxEditCtrl as the Draw Text Processor
C CXTPSyntaxEditFileChangesMonitor | This class monitors files changes
C CXTPSyntaxEditFindReplaceDlg | This class implements the "Find and Replace" and "Find" dialogs for a SyntaxEdit control
C CXTPSyntaxEditGoToLineDlg | This class implements the "GoToLine" dialog for a SyntaxEdit control
C CXTPSyntaxEditLexOnScreenParseCnt | CXTPSyntaxEditLexOnScreenParseCnt provides context data storage for OnScreen iterated parsing process
C CXTPSyntaxEditLexTokensDef | This class stores tokens definition: a list of tokens and corresponding lists of start and end tokens separators
C CXTPSyntaxEditLexVariable | XTPSyntaxEditLexAnalyser namespace is used group text parser classes, separate them from others and to make class names shorter without risk to be duplicated
C CXTPSyntaxEditPropertiesDlg | This class provides a default dialog to edit SyntaxEdit control settings
C CXTPSyntaxEditPropertiesPageColor | This class implements property page colors options
C CXTPSyntaxEditPropertiesPageEdit | This class implements a property page for common edit options
C CXTPSyntaxEditPropertiesPageFont | This class implements property page font options
C CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager | This is helper class designed to manage a set of strings
C CXTPSyntaxEditTextRegion | This class is designed to store the coordinates of a text region
C CXTPSyntaxEditTextSchemesManager | This class provides the functionality to store the set of all text schemes that would be written from configuration files
C CXTPSyntaxEditTipComboBox | This class implements a combo box with a tooltip
C CXTPSyntaxEditTipListBox | This class implements a list box with a tooltip
C CXTPSyntaxEditTipWnd | CXTPSyntaxEditTipWnd implements a tooltip window for the CXTPSyntaxEditTipListBox class
C CXTPSyntaxEditToolTipCtrl | Encapsulates the functionality of a "tip control," a small pop-up window that displays a single line of text describing the hidden text when hovering over an item on the report area
C CXTPSyntaxEditUndoRedoManager | This class maintains the list of undo/redo commands
C CXTPSyntaxEditView | This class represents a View portion of the Edit Control
C CXTPSyntaxEditViewPrintOptions | Describes printing options for the Calendar control
C CXTPSystemMetrics | Used to store and update sytem information
C CXTPSystemVersion | CXTPSystemVersion is used to get the current Windows OS version
►C CXTPTabBase | CXTPTabBase is a standalone base class
C CXTPTabExBase | CXTPTabExBase is a standalone base class
C CXTPTabClientContext | CXTPTabClientContext is a standalone class
C CXTPTabClientDraggingContents | Managers tab client dragging contents
C CXTPTabCtrl | CXTPTabCtrl is a multiple inheritance class derived from CTabCtrl and CXTPTabCtrlBase
C CXTPTabCtrlButton | CXTPTabCtrlButton is a standalone structure class
C CXTPTabCtrlButtons | CXTPTabCtrlButtons is a CWnd derived class
►C CXTPTabManagerAtom | CXTPTabManagerAtom is a class that has only one purpose; to catch the event when a property of the PaintManager is changed
C CXTPTabClientWnd | CXTPTabClientWnd is a CWnd derived class
►C CXTPTabManager | CXTPTabManager is the base class for docking pane tabs, tab control tabs, and MDI client tabs
C CXTPDockingPaneAutoHidePanel | CXTPDockingPaneAutoHidePanel is a multiple inheritance class derived from CWnd and CXTPDockingPaneBase
C CXTPDockingPaneTabbedContainer | CXTPDockingPaneTabbedContainer is a multiple inheritance class derived from CWnd and CXTPDockingPaneBase
C CXTPRibbonControlTab | CXTPRibbonControlTab is a CXTPTabManager derived class
C CXTPTabControl | CXTPTabControl is used to draw an enhanced tab control with Office 2003, Visual Studio, or Win XP tabs
C CXTPTabToolBar | CXTPTabToolBar is a CXTPToolBar derived class
C CXTPTabManagerNavigateButton | CXTPTabManagerNavigateButton is a class used to represent a tab navigation button
C CXTPTabManagerNavigateButtons | CXTPTabManagerNavigateButtons is a class used to represent a collection of tab navigation buttons
►C CXTPTabPaintManagerColorSet | CXTPTabPaintManagerColorSet represents the colors for all of the components of the tab manager (e.g
►C CXTPDockingPanePanelColorSet2012 | Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines
C CXTPDockingPanePanelColorSet2013 | Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines
C CXTPDockingPanePanelColorSet2015 | Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines
C CXTPDockingPanePanelColorSet2017 | Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines
C CXTPDockingPanePanelColorSet2019 | Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines
C CXTPDockingPanePanelColorSet2022 | Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines
C CXTPDockingPanePanelColorSetNativeWindows10 | Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines
C CXTPDockingPanePanelColorSetNativeWindows11 | Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines
►C CXTPDockingPaneTabColorSet2012 | Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines
C CXTPDockingPaneTabColorSet2015 | Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines
C CXTPDockingPaneTabColorSet2017 | Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines
C CXTPDockingPaneTabColorSet2019 | Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines
C CXTPDockingPaneTabColorSet2022 | Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines
C CXTPDockingPaneTabColorSetNativeWindows10 | Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines
C CXTPDockingPaneTabColorSetNativeWindows11 | Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines
C CXTPDockingPaneTabColorSet2013 | Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines
►C CXTPTabColorSetDefault | CXTPTabColorSetDefault implements a default tab color set
C CColorSetVisualStudio2003 | CColorSetVisualStudio2003 implements a Visual Studio 2003 tab color set
C CColorSetWinNative | CColorSetWinNative implements a Windows XP tab color set
►C CXTPTabColorSetOffice2003 | CXTPTabColorSetOffice2003 implements an Office 2003 tab color set
C CColorSetVisualStudio2005 | CColorSetVisualStudio2005 implements a Visual Studio 2005 tab color set
►C CXTPDockingPaneTabColorSetVisualStudio2003 | Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines
C CXTPDockingPaneTabColorSetOfficePanel | Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines
C CXTPDockingPaneTabColorSetVisualStudio2005 | Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines
►C CXTPTabColorSetOffice2007 | CXTPTabColorSetOffice2007 implements an Office 2007 tab color set
C CXTPTabColorSetOffice2007Access | CXTPTabColorSetOffice2007Access implements an Office 2007 Access tab color set
►C CXTPTabColorSetVisualStudio2008 | CXTPTabColorSetVisualStudio2008 implements a Visual Studio 2008 tab color set
C CXTPTabColorSetVisualStudio2010 | CXTPTabColorSetVisualStudio2010 implements a Visual Studio 2010 tab color set
►C CXTPTabColorSetVisualStudio2012 | CXTPTabColorSetVisualStudio2012 implements a Visual Studio 2012 tab color set
C CXTPTabColorSetNativeWindows10 | CXTPTabColorSetNativeWindows10 implements a Native Windows 10 tab color set
C CXTPTabColorSetNativeWindows11 | CXTPTabColorSetNativeWindows11 implements a Native Windows 10 tab color set
C CXTPTabColorSetOffice2013 | CXTPTabColorSetOffice2013 implements an Office 2013 tab color set
C CXTPTabColorSetVisualStudio2012Dark | CXTPTabColorSetVisualStudio2012Dark implements a Visual Studio 2012 Dark tab color set
►C CXTPTabColorSetVisualStudio2015 | CXTPTabColorSetVisualStudio2015 implements a Visual Studio 2015 tab color set
►C CXTPTabColorSetVisualStudio2017 | CXTPTabColorSetVisualStudio2017 implements a Visual Studio 2017 tab color set
►C CXTPTabColorSetVisualStudio2019 | CXTPTabColorSetVisualStudio2019 implements a Visual Studio 2019 tab color set
C CXTPTabColorSetVisualStudio2022 | CXTPTabColorSetVisualStudio2022 implements a Visual Studio 2022 tab color set
►C CXTPTabPaintManagerTheme | CXTPTabPaintManagerTheme is a class that represents the appearance of all components of the tab manager (e.g
►C CAppearanceSetPropertyPage2003 | CAppearanceSetPropertyPage2003 implements an Office 2003 tab appearance
C CAppearanceSetVisualStudio2005 | CAppearanceSetVisualStudio2005 implements a Visual Studio 2005 tab appearance
►C CAppearanceSetPropertyPage2007 | CAppearanceSetPropertyPage2007 implements an Office 2007 tab appearance
C CAppearanceSetPropertyPageAccess2007 | CAppearanceSetPropertyPageAccess2007 implements an Office 2007 tab appearance
C CAppearanceSetStateButtons | CAppearanceSetStateButtons implements a "State Button" tab appearance
C CAppearanceSetVisio | CAppearanceSetVisio implements a Visio tab appearance
►C CXTPTabThemeFlat | CXTPTabThemeFlat implements a "Flat" tab appearance
►C CAppearanceSetPropertyPageFlat | CAppearanceSetPropertyPageFlat implements an Office 2000 Flat tab appearance
C CXTPTabThemeVisualStudio2010 | CXTPTabThemeVisualStudio2010 implements a Visual Studio 2010 tab appearance
►C CXTPDockingPanePanelTheme2012 | Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines
C CXTPDockingPanePanelTheme2013 | Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines
C CXTPDockingPanePanelTheme2015 | Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines
C CXTPDockingPanePanelTheme2017 | Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines
C CXTPDockingPanePanelTheme2019 | Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines
C CXTPDockingPanePanelTheme2022 | Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines
C CXTPDockingPanePanelThemeNativeWindows10 | Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines
C CXTPDockingPanePanelThemeNativeWindows11 | Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines
►C CXTPDockingPaneTabTheme2012 | Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines
C CXTPDockingPaneTabTheme2015 | Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines
C CXTPDockingPaneTabTheme2017 | Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines
C CXTPDockingPaneTabTheme2019 | Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines
C CXTPDockingPaneTabTheme2022 | Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines
C CXTPDockingPaneTabThemeNativeWindows10 | Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines
C CXTPDockingPaneTabThemeNativeWindows11 | Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines
C CXTPDockingPaneTabTheme2013 | Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines
C CXTPTabThemeExcel2003 | CXTPTabThemeExcel2003 implements an Excel tab appearance
►C CXTPTabThemeVisualStudio2012 | CXTPTabThemeVisualStudio2012 implements a Visual Studio 2012 tab appearance
►C CXTPTabThemeOffice2013 | CXTPTabThemeOffice2013 implements an Office 2013 tab appearance
C CXTPTabThemeNativeWindows10 | CXTPTabThemeNativeWindows10 implements a Native Windows 10 tab appearance
C CXTPTabThemeNativeWindows11 | CXTPTabThemeNativeWindows11 implements a Native Windows 10 tab appearance
►C CXTPTabThemeVisualStudio2015 | CXTPTabThemeVisualStudio2015 implements a Visual Studio 2015 tab appearance
►C CXTPTabThemeVisualStudio2017 | CXTPTabThemeVisualStudio2017 implements a Visual Studio 2017 tab appearance
►C CXTPTabThemeVisualStudio2019 | CXTPTabThemeVisualStudio2019 implements a Visual Studio 2019 tab appearance
C CXTPTabThemeVisualStudio2022 | CXTPTabThemeVisualStudio2022 implements a Visual Studio 2022 tab appearance
►C CXTPTabThemeOffice2000 | CXTPTabThemeOffice2000 implements an Office 2000 tab appearance
C CAppearanceSetPropertyPageSelected | CAppearanceSetPropertyPageSelected implements an "Office 2000 Selected" tab appearance
C CXTPTabThemeVisualStudio2003 | CXTPTabThemeVisualStudio2003 implements a Visual Studio 2003 tab appearance
C CXTPTabView | CXTPTabView is a multiple inheritance class derived from CCtrlView and CXTPTabCtrlBaseEx
C CXTPTagCloudCtrl | Used to create a tag cloud control representing a visual depiction of generated tags identified by color and font size to represent the prominence or frequency of the tags depicted
C CXTPTagCloudStyle | CXTPTagCloudStyle is a helper class used by CXTPTagCloudStyleManager to manage styles for the CXTPTagCloudCtrl class
C CXTPTagCloudTagArray | CXTPTagCloudTagArray is a CArray derived class used to manage XTP_TAGCLOUDTAG objects for the CXTPTagCloudCtrl class
C CXTPTaskDialogClient | CXTPTaskDialogClient window
C CXTPTaskDialogLinkCtrl | CXTPTaskDialogLinkCtrl is a CStatic derived class that is used to display a text block that contains clickable links
C CXTPTaskDialogProgressCtrl | CXTPTaskDialogProgressCtrl
►C CXTPTaskPanelPaintManager | CXTPTaskPanelPaintManager is a standalone class used by CXTPTaskPanel as a paint manager
C CXTPTaskPanelExplorerTheme | CXTPTaskPanelExplorerTheme represents an Explorer style theme
C CXTPTaskPanelOffice2003Theme | CXTPTaskPanelOffice2003Theme represents an Office 2003 style theme
►C CXTPTaskPanelPaintManagerPlain | Base class theme that all other themes are derived from
C CXTPTaskPanelExplorerThemePlain | CXTPTaskPanelExplorerThemePlain represents a classic Explorer style theme
►C CXTPTaskPanelOfficeXPThemePlain | CXTPTaskPanelOfficeXPThemePlain represents a classic Office XP style theme
C CXTPTaskPanelOffice2003ThemePlain | CXTPTaskPanelOffice2003ThemePlain represents a classic Office 2003 style theme
►C CXTPTaskPanelToolboxTheme | CXTPTaskPanelToolboxTheme represents a Toolbox style theme
►C CXTPTaskPanelListViewTheme | CXTPTaskPanelListViewTheme class represents a List View style theme
►C CXTPTaskPanelListViewOfficeXPTheme | CXTPTaskPanelListViewOfficeXPTheme represents a List View Office XP style theme
►C CXTPTaskPanelListViewOffice2003Theme | CXTPTaskPanelListViewOffice2003Theme represents a List View Office 2003 style theme
►C CXTPTaskPanelShortcutBarOffice2003Theme | CXTPTaskPanelShortcutBarOffice2003Theme represents an Office 2003 ShortcutBar style theme
C CXTPTaskPanelShortcutBarOffice2007Theme | CXTPTaskPanelShortcutBarOffice2007Theme represents an Office 2007 ShortcutBar style theme
►C CXTPTaskPanelVisualStudio2005Theme | CXTPTaskPanelVisualStudio2005Theme represents a Visual Studio 2005 style theme
C CXTPTaskPanelVisualStudio2010Theme | CXTPTaskPanelVisualStudio2010Theme represents a VS.NET 2010 style theme
►C CXTPTaskPanelVisualStudio2012Theme | CXTPTaskPanelVisualStudio2012Theme represents a VS.NET 2012 style theme
C CXTPTaskPanelNativeWindows10Theme | CXTPTaskPanelNativeWindows10Theme represents a Native Windows 10 style theme
C CXTPTaskPanelNativeWindows11Theme | CXTPTaskPanelNativeWindows11Theme represents a Native Windows 10 style theme
C CXTPTaskPanelOffice2013Theme | CXTPTaskPanelOffice2013Theme represents an Office 2013 style theme
C CXTPTaskPanelVisualStudio2015Theme | CXTPTaskPanelVisualStudio2015Theme represents a Visutal Studio 2015 style theme
C CXTPTaskPanelVisualStudio2017Theme | CXTPTaskPanelVisualStudio2017Theme represents a Visutal Studio 2017 style theme
C CXTPTaskPanelVisualStudio2019Theme | CXTPTaskPanelVisualStudio2019Theme represents a Visutal Studio 2019 style theme
C CXTPTaskPanelVisualStudio2022Theme | CXTPTaskPanelVisualStudio2022Theme represents a Visutal Studio 2022 style theme
C CXTPTaskPanelScrollButton | CXTPTaskPanelScrollButton is a standalone class that represents a task panel scroll button
C CXTPTcbItem | Used to maintain information for a particular tab item in a CXTPExcelTabCtrl, CXTPTabCtrl, or CXTPTabView object
C CXTPTempColorMask | Can be used to temporarily set the color mask used by XTPImageManager when using images with different color masks
C CXTPTextOnPath | GDI+ drawing of text on path
C CXTPThemeDLL | CXTPThemeDLL is a helper class used to load Codejock theme resource DLLs
C CXTPThreadLocal< T > | Implements thread local variable adapter
C CXTPThreadLocal< BOOL > |
C CXTPTipOfTheDay | CXTPTipOfTheDay is a CDialog derived class
C CXTPTipWindow | CXTPTipWindow is a CWnd derived class
C CXTPToolhelpApi | A wrapper around the Toolhelp32 API
C CXTPToolTipContextToolTip | CXTPToolTipContextToolTip is CWnd derived class, the base class for custom tool tips
►C CXTPTrackUndoCommand | This class abstracts the undo command
C CXTPTrackUndoAddBlockCommand | This class abstracts the undo add block command
C CXTPTrackUndoAddMarkerCommand | This class abstracts the undo add marker command
C CXTPTrackUndoDeleteBlockCommand | This class abstracts the undo delete block command
C CXTPTrackUndoDeleteMarkerCommand | This class abstracts the undo delete marker command
C CXTPTrackUndoGroupCommand | This class abstracts the undo commands in a group
C CXTPTrackUndoSetBlockPositionCommand | This class abstracts the undo set block position command
C CXTPTrackUndoSetMarkerPositionCommand | This class abstracts the undo set marker position command
C CXTPTransparentBitmap | CXTPTransparentBitmap is a helper class used to extract the transparent color from a transparent BitMap
C CXTPTrayIcon | CXTPTrayIcon is a CWnd derived class of the NOTIFYICONDATA structure
►C CXTPTreeBase | CXTPTreeBase is a CTreeView derived class
C CXTPShellTreeBase | CXTPShellTreeBase is a multiple inheritance class derived from CXTPTreeView and CXTPShellPidl
►C CXTPTreeCtrl | CXTPTreeCtrl is a CTreeCtrl derived class
C CXTPMarkupTreeCtrl | Tree control class that allows for adding markup items
C CXTPTreeView | CXTPTreeView is a CTreeView derived class
C CXTPWebBrowserCtrl | Implements the WebBrowser control that is capable of hosting different supported Web browsers
C CXTPWinApp | All XTP application classes have to derive from CXTPWinApp instead of CWinApp or CWinAppEx
C CXTPWindowPos | CXTPWindowPos is a WINDOWPLACEMENT structure derived class
C CXTPWindowRect | CXTPWindowRect is a helper class used to retrieve the screen size for a specified window
C CXTPWinThemeWrapper | Wraps the UxTheme.dll visual theme API
►C CXTPWinThread | All XTP threads should derive from CXTPWinThread instead of CWinThread in order to ensure compatibility with the main process thread that is derived from CXTPWinApp
C CXTPDirWatcher | The CXTPDirWatcher is a thread class that will monitor a specified path for file and directory changes to occur
C CXTPZipMemFile | Zipped memory file
C CXTPTrackControl::DRAGBLOCK | This structure abstracts the state of block being dragged
C CXTPCalendarData::EventsMapByID_T< _TObject > |
C XTP_CALENDAR_USERACTION_PARAMS::EXPANDDAYBUTTONACTION_PARAMS | Defines parameters for xtpCalendarUserAction_OnExpandDay user action
C CXTPControlGallery::GALLERYITEM_POSITION | Structure contains item position description
C CXTPColorHex::CRgnCell::CTX_DATA::HEXAGON_DATA | Describes pre-computed hexagon data
C CXTPSortClass::ITEMDATA | This structure is used by the CXTPSortClass for storing a temporary item data pointer that contains each list item's name (used for sorting) and original item data (if any)
C ITimeProvider | Interface for overriding the GetCurrentTime() function in calendar control
►C IXTPApplicationEvents | Defines a callback interface for XTP application event sink
C CXTPCommandBars | CXTPCommandBars is a standalone class
C CXTPSingletonPointer | Implements Singleton design pattern for a pointer of unspecified type that is to be allocated, created and destroyed by a client
C CXTPSkinManager | CXTPSkinManager is a standalone class that represents a global object that manages skins
C CXTPStatusBarThemeVisualStudio2015 | Used to enable the Visual Studio 2015 style theme for the status bar
C CXTPStatusBarThemeVisualStudio2017 | Used to enable the Visual Studio 2017 style theme for the status bar
C CXTPStatusBarThemeVisualStudio2019 | Used to enable the Visual Studio 2019 style theme for the status bar
C CXTPStatusBarThemeVisualStudio2022 | Used to enable the Visual Studio 2022 style theme for the status bar
►C IXTPFrameShadowManagerEvents | An interface for Frame Shadow Manager event listener
C CXTPCommandBarsFrameHook | CXTPCommandBarsFrameHook is a CXTPHookManagerHookAble derived class
C CXTPFrameShadow | The class represents frame shadow object
C IXTPGaugeClientSite | Provides a client site interface for a gauge control owner
►C IXTPMarkupClientSite | Defines default implementation of the markup client site interface
C CXTPGaugeBaseType | A base class for all gauge types
►C IXTPMarkupDeviceDependentImageSite | Describes an image site interface
C CXTPMarkupImage | CXTPMarkupImage is a CXTPMarkupFrameworkElement derived class
C IXTPPreview | The base interface for a preview handler implementation
C IXTPPreviewHost | Interface implemented by the preview host control
►C IXTPPreviewProvider | Interface to be implemented by a preview provider
►C CXTPPreviewProviderBase | Base class for a preview provider which implements common behavior to be exposed by a preview provider
C CXTPCommonPicturePreviewProvider | Provides a preview handler for the common picture file types: BMP, PNG, TIF, TIFF, ICO, JPEG, JPG, EXIF, WMF, EMF
C CXTPGifPreviewProvider | Provides a preview handler for static and animated GIF files
C CXTPMsgPreviewProvider | Provides a preview handler for the Outlook Message (MSG) file type
C CXTPSvgPreviewProvider | Provides a preview handler for XAML files that uses Markup components for rendering file contents
C CXTPSystemPreviewProvider | Provides a preview handler that uses supported system means for previewing files
C CXTPTextPreviewProvider | Provides a preview handler for the text file type (TXT)
C CXTPXamlPreviewProvider | Provides a preview handler for XAML files that uses Markup components for rendering file contents
►C IXTPScrollable | This interface is to be implemented only by special scrollable controls that require overriding of scroll bars using CXTPScrollable adaptor and for which the default implementation of this interface by CXTPScrollable does not work
►C CXTPScrollable< EditBase > |
C CXTPScrollableEditT< EditBase > | An adaptor for any CEdit derived control that overrides standard scrollbars with custom scrollbars
►C CXTPScrollable< ListBoxBase > |
C CXTPScrollableListBoxT< ListBoxBase > | An adaptor for any CListBox derived control that overrides standard scrollbars with custom scrollbars
►C CXTPScrollable< ListBase > |
C CXTPScrollableListCtrlT< ListBase > | An adaptor for any CListCtrl derived control that overrides standard scrollbars with custom scrollbars
►C CXTPScrollable< TreeBase > |
C CXTPScrollableTreeCtrlT< TreeBase > | An adaptor for any CTreeCtrl derived control that overrides standard scrollbars with custom scrollbars
C CXTPScrollable< Base > | The adaptor class for a scrollable control for which standard scroll bars have to be overriden
C IXTPSkinManagerWindowFilter | Implement this interface in order to provide custom configured window filter functionality
C IXTPWebBrowserEventSink | Describes default WebBrowser control event sink interface and providers default implementation of the event handlers
C CXTPCommandBars::KEYBOARDTIPS | Keyboard tips information
C CXTPTaskDialogLinkCtrl::LINKITEM | LINKITEM is used to set and retrieve information about a link item
►C NMXTPCONTROL | This structure is passed as a parameter in CBN_XTP_EXECUTE message
C NMXTPCHARHDR | Structure used as a parameter for XTP_FN_SETFORMAT and XTP_FN_GETFORMAT messages
C NMXTPTABCHANGE | Structure used as a parameter for TCN_SELCHANGING and TCN_SELCHANGE messages when a Ribbon tab is changed
C NMXTPSCROLL | The NMXTPSCROLL structure contains information about the scroll bar
C XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_DAILY | Defines a group of parameters to describe the Daily pattern
C XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_MONTHLY | Defines a group of parameters to describe the Month pattern
C XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_MONTHNTH | Defines a group of parameters to describe the Month pattern
C XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_WEEKLY | Defines a group of parameters to describe the Weekly pattern
C XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_YEARLY | Defines a group of parameters to describe the Year pattern
C XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_YEARNTH | Defines a group of parameters to describe the Year pattern
C CXTPPopupControl::POPUPSTATE | Pop-up state descriptor
C CXTPCalendarReminder::RecurrenceEventInfo | This structure contains data members to unambiguously define related recurrence event occurrence
C CXTPCalendarTimeZones::REGISTRY_TIMEZONE_INFORMATION | This structure represents a format of binary data stored in the "TZI" registry key
C CXTPTabManager::ROW_ITEMS | Helper structure that contains the first and last item indices of rows of the tab manager
C CXTPListBase::ROWCOLOR | ROWCOLOR structure is used by the CXTPListBase class to store user-defined background and text color settings for a particular row in a list control
C XTP_CALENDAR_USERACTION_PARAMS::SCROLLDAYBUTTONACTION_PARAMS | Defines parameters for xtpCalendarUserAction_OnScrollDay user action
C CXTPDatePickerDaysCollection::SELECTED_BLOCK | Selected block structure
C CXTPCalendarView::SEventTimeFormatInfo |
C CXTPStatusBarSwitchPane::SWITCH | Holds status bar pane switch properties
C CXTPMarkupVisual::TransformationMatrices | A structure that optionally describes the previous and the new transformation matrices
C XTP_CALENDAR_DAYVIEWCELL_PARAMS | Set of parameters transferred from calendar items for an XTP_NC_CALENDAR_BEFORE_DRAW_DAYVIEWCELL notification
C XTP_CALENDAR_GETITEMTEXT_PARAMS | Set of parameters transferred from calendar items for an XTP_NC_CALENDAR_GETITEMTEXT notification
►C XTP_CALENDAR_HITTESTINFO | Basic set of parameters transferred from calendar items to mouse handlers
C XTP_CALENDAR_HITTESTINFO_TIMELINE_VIEW | Set of parameters transferred from calendar items to mouse handlers
C XTP_CALENDAR_MONTHVIEW_DAYPOS | Defines a set of data and methods to easily manipulate with day positions in month view
C XTP_CALENDAR_PATTERN_END | This structure describes parameters of the end of the recurrence pattern type
C XTP_CALENDAR_RECURRENCE_OPTIONS | This structure defines a set of Recurrence Pattern options and is used by a CXTPRecurrencePattern to easily manage and transfer recurrence pattern data
C XTP_CALENDAR_THEME_DAYVIEWCELL_PARAMS | Set of parameters transferred from calendar items for an XTP_NC_CALENDAR_BEFORE_DRAW_THEMEOBJECT notification
C XTP_CALENDAR_THEME_DAYVIEWTIMESCALECELL_PARAMS | Set of parameters transferred from calendar items for an XTP_NC_CALENDAR_BEFORE_DRAW_THEMEOBJECT notification
C XTP_CALENDAR_TIMELINE_VIEW_SCALE | Timeline's view scale
C XTP_CALENDAR_USERACTION_PARAMS | Set of parameters transferred from calendar items for an XTP_NC_CALENDAR_USERACTION notification
C XTP_CALENDAR_VIEWSELECTION | Structure contains the calendar day view selection block
C XTP_CALENDAR_WPARAM2 | Doubled custom parameter for notifications
C XTP_COMMANDBARS_CATEGORYINFO | This structure stores categories for CXTPCustomizeCommandsPage and CXTPCustomizeKeyboardPage option pages
C XTP_COMMANDBARS_CREATEBAR | Creates a bar structure
C XTP_COMMANDBARS_CREATECONTROL | Creates a control structure
C XTP_COMMANDBARS_ICONSINFO | This structure collect icons options for command bars
C XTP_COMMANDBARS_PROPEXCHANGE_PARAM | XTP_COMMANDBARS_PROPEXCHANGE_PARAM is a structure used to store the CommandBar's save settings
C XTP_DOCKINGPANE_ACTION | The XTP_DOCKINGPANE_ACTION structure contains information about the action performed by the user with docking panes
C XTP_DOCKINGPANE_CLICK | The XTP_DOCKINGPANE_CLICK structure contains information about the pane that was used in an XTP_DPN_PANEMENUCLICK message
C XTP_DOCKINGPANE_INFO | Internal structure used by the Layout manager
C XTP_EDIT_ACDATA | The XTP_EDIT_ACDATA structure defines items' displayed data and provides text and icons for each displayed line in the auto-complete window
C XTP_EDIT_COLLAPSEDBLOCK | Stores collapsed block parameters
C XTP_EDIT_COLORVALUES | Stores the colors for different phrases
C XTP_EDIT_FONTOPTIONS | The XTP_EDIT_FONTOPTIONS structure is a self-initializing LOGFONT structure that initializes all values equal to XTP_EDIT_FONTOPTIONS_UNSPEC_OPTION except for lfFaceName which is set to zero length
C XTP_EDIT_LINECOL | The XTP_EDIT_LINECOL structure represents the coordinates of text items on the displaying context in terms of line/column
C XTP_EDIT_NMHDR_DOCMODIFIED | Document notification structure
C XTP_EDIT_NMHDR_EDITCHANGED | Structure to notify "Edit changed" event
C XTP_EDIT_NMHDR_ENABLESCROLLBAR | Structure to notify XTP_EDIT_NM_ENABLESCROLLBAR event
C XTP_EDIT_NMHDR_MARGINCLICKED | Structure to notify XTP_EDIT_NM_MARGINCLICKED event
C XTP_EDIT_NMHDR_PARSEEVENT | Structure to notify XTP_EDIT_NM_PARSEEVENT event
C XTP_EDIT_NMHDR_ROWCOLCHANGED | Row column notification structure
C XTP_EDIT_NMHDR_SETSCROLLPOS | Structure to notify XTP_EDIT_NM_UPDATESCROLLPOS event
C XTP_EDIT_ROWCOLRECT | The XTP_EDIT_ROWCOLRECT structure is used to define a row and column selection rectangle
C XTP_EDIT_ROWSBLOCK | XTP_EDIT_ROWSBLOCK structure
C XTP_EDIT_SENMBOOKMARK | Bookmark notification structure
C XTP_EDIT_TEXTBLOCK | Summary The XTP_EDIT_TEXTBLOCK structure stores the text blocks after parsing
►C XTP_EVENT_EDIT_OPERATION_PARAMS | This structure is used as a generic and base class for custom edit event notifications
C XTP_EVENT_DRAG_OPERATION_PARAMS | This structure is used with notifications for custom edit event notifications when eOperation is xtpCalendarEO_DragXXX
C XTP_EVENT_IN_PLACE_CREATE_EVENT_OPERATION_PARAMS | This structure is used with notifications for custom edit event notifications when eOperation is xtpCalendarEO_InPlaceCreateEvent
C XTP_EVENT_PASTE_OPERATION_PARAMS | This structure is used with notifications for custom edit event notifications when eOperation is xtpCalendarEO_Paste
C XTP_GRIDDATAMANAGER_COM_ERROR | Basic set of parameters transferred to item handlers
►C XTP_GRIDRECORDITEM_ARGS | Basic set of parameters transferred to item handlers
►C CXTPGridInplaceControl | CXTPGridInplaceControl is the base class for all in-place controls of the Grid control item
C CXTPGridInplaceButton | CXTPGridInplaceButton is a CXTPGridInplaceControl derived class that represents a combo button and expand button of a grid cell
C CXTPGridInplaceEdit | CXTPGridInplaceEdit is a CXTPGridInplaceControl derived class that represents an edit control to allow users to change a cell of a Grid control
C CXTPGridInplaceList | CXTPGridInplaceList is a CXTPGridInplaceControl derived class that represents a list box with item constraints
C XTP_GRIDRECORDITEM_CLICKARGS | A set of parameters transferred to mouse click item handlers
C XTP_GRIDRECORDITEM_DRAWARGS | A set of parameters transferred to the Draw item handler
C XTP_IMAGERESOURCE_INFO | This structure is used to define the position and style of the icon in resources
C XTP_LC_TIMEFORMAT | Time format structure
C XTP_LVITEMDATA | The XTP_LVITEMDATA structure is used to maintain information for a particular list item in a CXTPShellListCtrl or CXTPShellListView window
C XTP_NC_DATEPICKER_BUTTON | Structure used to send button notification messages
C XTP_NM_FLOWGRAPH_CONNECTIONCHANGED | Information about the connection that has changed
C XTP_NM_FLOWGRAPH_CONNECTIONCHANGING | Information about the connection that is currently changing
C XTP_NM_FLOWGRAPH_ENDLABELEDIT | Information about the label whose editing has ended
C XTP_NM_FLOWGRAPH_NODECHANGED | Information about the node that has changed
C XTP_NM_GRID_BEFORE_COPYPASTE | This structure is sent to the Main window in a WM_NOTIFY message from Item and provides all parameters required by the Main window to process control specific notifications
C XTP_NM_GRIDCOLUMNORDERCHANGED | This structure is sent to the main window in a WM_NOTIFY message after columns order or group order is changed
C XTP_NM_GRIDCOLUMNRESIZE | This structure is sent to the main window in a WM_NOTIFY message after a column is resized
C XTP_NM_GRIDDRAGDROP | This structure is sent to the Main window in a WM_NOTIFY message from Grid Control to determine if records are dragged or dropped
C XTP_NM_GRIDGIVEFEEDBACK | NM_GRIDGIVEFEEDBACK notification data
C XTP_NM_GRIDITEMMETRICS | This structure is sent to the Main window in a WM_NOTIFY message from Item and provides all parameters required by the Main window to process control specific notifications
C XTP_NM_GRIDPREVIEWKEYDOWN | This structure is sent to the Main window in a WM_NOTIFY message before processing the OnKeyDown event
►C XTP_NM_GRIDRECORDITEM | This structure is sent to the Main window in a WM_NOTIFY message from Item and provides all parameters required by the Main window to process control specific notifications
C XTP_NM_GRIDCONSTRAINTSELECTING | This structure is sent to the Main window in a WM_NOTIFY message from Item and provides all parameters required by the Main window to process control specific notifications
C XTP_NM_GRIDINPLACEBUTTON | This structure is sent to the Main window in a WM_NOTIFY message from Item and provides all parameters required by the Main window to process control specific notifications
C XTP_NM_GRIDITEMCONTROL | This structure is sent to the Main window in a WM_NOTIFY message from the item control and provides all parameters needed to process control specific notifications by the main window
C XTP_NM_GRIDREQUESTEDIT | A set of parameters transferred with an XTP_NM_GRID_REQUESTEDIT message
C XTP_NM_GRIDTOOLTIPINFO | This structure is sent to the Main window in a WM_NOTIFY message from Item and provides all parameters required by the Main window to process control specific notifications
C XTP_NM_GRIDROWRESIZE | This structure is sent to the main window in a WM_NOTIFY message after a row is resized
C XTP_NM_GRIDSCROLL | NM_GRIDSCROLL notification data
C XTP_NM_GRIDSTATECHANGED | This structure contains information for use in processing an XTP_NM_GRID_STATECHANGED message
C XTP_NM_SELECTION_CHANGING | This struct defines data for an XTP_NM_GRID_SELCHANGING notification
C XTP_NM_TRACKCONTROL | This structure contains notification details
C XTP_PICK_BUTTON | XTP_PICK_BUTTON structure is used by the CXTPColorSelectorCtrl class to support a user-defined color list
C XTP_PROPERTYGRID_NOTIFYEDIT | This struct is passed with XTP_PGN_REQUESTEDIT, XTP_PGN_AFTEREDIT, and XTP_PGN_CANCELEDIT notifications to determine the item and its new value
►C XTP_RESIZEPOINT | The XTP_RESIZEPOINT structure is used by the CXTPResizePoint class for defining single-precision floating point x- and y- coordinates of a point
C CXTPResizePoint | CXTPResizePoint is an XTP_RESIZEPOINT structure derived class
►C XTP_RESIZERECT | XTP_RESIZERECT structure is used by the CXTPResizeRect class for defining single-precision floating point coordinates of the upper-left and lower-right corners of a rectangle
C CXTPResizeRect | CXTPResizeRect is an XTP_RESIZERECT structure derived class
C XTP_RESOURCEMANAGER_LANGINFO | Standalone structure used to manage Language Info
C XTP_SCROLLBAR_POSINFO | The XTP_SCROLLBAR_POSINFO structure contains scroll bar information
C XTP_SCROLLBAR_TRACKINFO | The XTP_SCROLLBAR_TRACKINFO structure contains tracking information
►C XTP_SCROLLBARINICOLORS | Used by paint manager to retrieve color settings from the loaded resource INI file
C XTP_SCROLLBARDRAWCOLORS | Used by paint manager to retrieve the current state color settings when drawing scrollbars
C XTP_SLIDERTICKS | The XTP_SLIDERTICKS structure contains slider ticks
C XTP_TAGCLOUDTAG | Manages the attributes for each tag element such as weight, font, background and foreground color
C XTP_TASKPANEL_GROUPCOLORS | Structure used to store task panel group colorization information for various parts of the group
C XTP_TPNENDLABELEDIT | This structure is passed as a parameter when an XTP_TPN_ENDLABELEDIT event occurs
C XTP_TPNGROUPEXPANDING | This structure is passed as a parameter when an XTP_TPN_GROUPEXPANDING event occurs
C XTP_TVITEMDATA | The XTP_TVITEMDATA structure is used to maintain information for a particular tree item in a CXTPShellTreeCtrl or CXTPShellTreeView window
C XTP_URI | Parse URI information
C XTP_URI_DEFAULTS | Default URI values
C XTP_WEEK_VIEW_LAYOUT | This struct store a Week View layout
C XTPGridInputState | Stores the mouse and key states
C XTPPROGRESSDRAWSTRUCT | Struct used by the progress bar during paint operations
C XTPRIBBON_HEADER_COLOR | Struct used to define context tab colors for the ribbon control


Toolkit Pro: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- _ -

  • __declspec() : CXTPGdiObject
  • _AddToCacheIfNeed() : CXTPCalendarData::CXTPDPCache
  • _AllocStringData() : CXTPHeapString, CXTPHeapStringT< _TAllocator >
  • _CalculateDateFormats() : CXTPCalendarMonthView
  • _CalculateEventCaptionFormat() : CXTPCalendarMonthView
  • _CalculateEventTimeFormat() : CXTPCalendarView
  • _CanSubjectEditor() : CXTPCalendarView
  • _CopySelectedEvents() : CXTPCalendarView
  • _DeleteItem() : CXTPExcelTabCtrl
  • _DoCollapse() : CXTPGridSection
  • _DoExpand() : CXTPGridSection
  • _DrawDateHeaderCalendar() : CXTPCalendarControlView
  • _EnableScrollBarNotify() : CXTPSyntaxEditCtrl
  • _EnsureVisibleH() : CXTPCalendarDayView
  • _EnsureVisibleSelectionH() : CXTPCalendarDayView
  • _EnsureVisibleV() : CXTPCalendarDayView
  • _FormatDayDate() : CXTPCalendarMonthView
  • _FreeStringData() : CXTPHeapString, CXTPHeapStringT< _TAllocator >
  • _GetAtGrow_BusyStatusBrushValue() : CXTPCalendarPaintManager
  • _GetButtonLength() : CXTPTabPaintManager
  • _GetDateHeaderMonths() : CXTPCalendarControlView
  • _GetDayHeaderFormat() : CXTPCalendarView
  • _GetEvents() : CXTPCalendarTimeLineView
  • _GetMaxWidth() : CXTPCalendarView
  • _GetMaxWidthFormat() : CXTPCalendarView
  • _GetNextID() : CXTPCalendarSchedules
  • _GetScrollRectClient() : CXTPCalendarDayView
  • _GetSubjectEditorWnd() : CXTPCalendarView
  • _GetTimeScaleWith() : CXTPCalendarDayView
  • _GetViewDay() : CXTPCalendarView
  • _HasEvents() : CXTPCalendarController
  • _HimetricToLP() : CXTPCalendarControlView
  • _ImageNameToResourceName() : CXTPResourceImages
  • _Init() : CXTPCalendarPaintManager
  • _InsertPane() : CXTPDockingPaneAutoHidePanel, CXTPDockingPaneSidePanel
  • _IsDragModeCopyMove() : CXTPCalendarView
  • _Load() : CXTPCalendarCustomProperties, CXTPCalendarMemoryDataProvider, CXTPCalendarResourcesManager, CXTPCalendarSchedules
  • _MoveRectY() : CXTPCalendarViewEvent
  • _ReadDefaultDateFormats() : CXTPCalendarMonthView
  • _ReadDefaultHeaderFormats() : CXTPCalendarView
  • _ReadEventsFromClipboard() : CXTPCalendarView
  • _RecalcHScrollMaxWidth() : CXTPSyntaxEditCtrl
  • _RecalcScrollBars() : CXTPSyntaxEditCtrl
  • _RedrawControl() : CXTPDatePickerControl
  • _RemoveDataForMasterEvent() : CXTPCalendarReminders
  • _RemoveYearPart() : CXTPCalendarView
  • _ResetDate_dbl() : CXTPCalendarUtils
  • _ResetTime_dbl() : CXTPCalendarUtils
  • _RoundDateTime_dbl() : CXTPCalendarUtils
  • _Save() : CXTPCalendarCustomProperties, CXTPCalendarMemoryDataProvider, CXTPCalendarResourcesManager, CXTPCalendarSchedules
  • _SaveCloseDPifNeed() : CXTPCalendarResourcesManager
  • _ScrollV() : CXTPCalendarDayView
  • _SetDataProvider() : CXTPCalendarControl
  • _SetExpanded() : CXTPGridRow
  • _SplitDateFormat() : CXTPCalendarMonthView
  • _SubtractSelSizeFromPos() : CXTPSyntaxEditCtrl
  • _Undo() : CXTPCalendarView
  • _UpdateIMEStatus() : CXTPSyntaxEditCtrl
  • _xtGetHeaderCtrl() : CXTPListBase
  • _xtpKeyboardThreadState : CXTPKeyboardManager


Toolkit Pro: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- a -

  • action : XTP_DOCKINGPANE_ACTION
  • Activate() : CXTPCalendarTip, CXTPGridInplaceButton, CXTPGridTip, CXTPPropertyGridToolTip, CXTPSyntaxEditToolTipCtrl, IXTPPreview
  • ActivateNextPane() : CXTPDockingPaneManager
  • ActivateView() : CXTPTabExBase
  • Add() : CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE >, CXTPCalendarData::EventsMapByID_T< _TObject >, CXTPCalendarEvents, CXTPCalendarPtrCollectionT< _TObject >, CXTPChartAxisConstantLines, CXTPChartAxisCustomLabels, CXTPChartAxisStrips, CXTPChartPanelCollection, CXTPChartSeriesCollection, CXTPChartSeriesPointCollection, CXTPChartTitleCollection, CXTPCommandBarList, CXTPCommandBars, CXTPCommandBarsContextMenus, CXTPControlActions, CXTPControls, CXTPDatePickerDaysCollection, CXTPFlowGraphUndoGroupCommand, CXTPGridColumnOrder, CXTPGridColumns, CXTPGridRecords, CXTPGridRows, CXTPGridSelectedRows, CXTPImageList, CXTPImageManagerResource, CXTPMatrix< T >, CXTPPropertyGridInplaceControls, CXTPPropertyGridVerbs, CXTPRecentFileList, CXTPRibbonGroup, CXTPRibbonGroups, CXTPShortcutManagerAccelTable, CXTPTabManagerNavigateButtons, CXTPTaskPanelItems, CXTPTrackControlItem, CXTPTrackMarkers, CXTPTrackSelectedBlocks, CXTPTrackUndoGroupCommand
  • AddAxisView() : CXTPChartDiagram2DView, CXTPChartRadarDiagramView
  • AddBlock() : CXTPGridSelectedRows
  • AddButton() : CXTPDatePickerControl, CXTPMessageBar, CXTPPropertyGridInplaceButtons, CXTPPropertySheet, CXTPTaskDialog
  • AddCategories() : CXTPCustomizeCommandsPage, CXTPCustomizeKeyboardPage, CXTPRibbonCustomizePage, CXTPRibbonCustomizeQuickAccessPage
  • AddCategory() : CXTPCustomizeCommandsPage, CXTPCustomizeKeyboardPage, CXTPPropertyGrid, CXTPPropertyGridView, CXTPRibbonCustomizePage, CXTPRibbonCustomizeQuickAccessPage
  • AddChild() : CXTPGridRow
  • AddChildCommand() : CXTPChartDeviceCommand
  • AddChildItem() : CXTPPropertyGridItem
  • AddChildView() : CXTPChartElementView
  • AddClass() : CXTPSkinObjectClassMap
  • AddClone() : CXTPControls, CXTPRibbonGroup
  • AddColor() : CXTPSyntaxEditColorComboBox
  • AddColorFilter() : CXTPSkinManager
  • AddColumn() : CXTPGridControl, CXTPListBase
  • AddComboButton() : CXTPGridRecordItemEditOptions, CXTPPropertyGridInplaceButtons, CXTPPropertyGridItem
  • AddComboString() : CXTPCustomizeOptionsPage
  • AddCommand() : CXTPControlWorkspaceActions, CXTPSyntaxEditBatchCommand, CXTPSyntaxEditUndoRedoManager
  • AddConnection() : CXTPFlowGraphConnections
  • AddConnectionPoint() : CXTPFlowGraphConnectionPoints
  • AddConstraint() : CXTPGridRecordItemEditOptions, CXTPPropertyGridItemConstraints
  • AddControl() : CXTPControlAction, CXTPGridRecordItemControls, CXTPSearchOptionsCtrl, CXTPStatusBar, CXTPTabExBase
  • AddControlItem() : CXTPTaskPanelGroup
  • AddCustomBar() : CXTPCommandBars
  • AddCustomIcon() : CXTPImageManager
  • AddCustomNode() : CXTPFlowGraphNodes
  • AddCustomNodeFromToolkitResource() : CXTPFlowGraphControl
  • AddCustomScriptItem() : CXTPMarkupContext
  • AddCustomTimeIntervalForReminder() : CXTPCalendarControl
  • AddDataProvider() : CXTPCalendarResourcesManager
  • AddDay() : CXTPCalendarDayView
  • AddDefaultProviders() : CXTPPreviewCtrl
  • AddEvent() : CXTPCalendarData
  • AddEventCategory() : CXTPCalendarData
  • AddEventLabel() : CXTPCalendarData
  • AddEvents() : CXTPCalendarData
  • AddExpandButton() : CXTPGridRecordItemEditOptions, CXTPPropertyGridInplaceButtons, CXTPPropertyGridItem
  • AddFont() : CXTPFontEnum
  • AddGridRecords() : CXTPGridDataManager
  • AddGroup() : CXTPFlowGraphNodeGroups, CXTPRibbonTab, CXTPTaskPanel
  • AddHandler() : CXTPMarkupContext
  • AddHyperlink() : CXTPGridRecordItem
  • AddIcon() : CXTPTrayIcon
  • AddIcons() : CXTPImageManager
  • AddIfNeed() : CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE >
  • AddImage() : CXTPFlowGraphImages
  • AddIndicator() : CXTPStatusBar
  • AddInputBox() : CXTPTaskDialog
  • AddItem() : CXTPCalendarEventColorListBox, CXTPChartLegendView, CXTPControlGalleryItems, CXTPGridRecord, CXTPMarkupTreeCtrl, CXTPPopupControl, CXTPShortcutBar, CXTPShortcutBarPane, CXTPTabClientWnd, CXTPTabManager
  • AddLabel() : CXTPControlGalleryItems
  • AddLinkItem() : CXTPTaskPanelGroup
  • AddListener() : CXTPColorPopup, CXTPColorSelectorCtrl
  • AddMDIMenu() : CXTPMenuBar
  • AddMenuItem() : CXTPControls, CXTPShortcutListBox
  • AddMonitorFile() : CXTPSyntaxEditFileChangesMonitor
  • AddMultiDayEvent_Slave() : CXTPCalendarViewEvent
  • AddNamedConnectionPoints() : CXTPFlowGraphNode, CXTPFlowGraphNodeCustom
  • AddNamedItem() : CXTPActiveScriptEngine
  • AddNewSchedule() : CXTPCalendarSchedules
  • AddNode() : CXTPFlowGraphNodeGroup, CXTPFlowGraphNodes
  • AddObserver() : CXTPTabPaintManager
  • AddPage() : CXTPCustomizeSheet, CXTPFlowGraphPages, CXTPPropertySheet
  • AddParam() : CXTPSyntaxEditColorInfo
  • AddPoints() : CXTPChartSeriesPointCollection
  • AddProvider() : CXTPPreviewCtrl
  • AddPtr() : CXTPInternalCollectionT< _TObject >
  • AddRadioButton() : CXTPTaskDialog
  • AddRecentColor() : CXTPColorSelectorCtrl
  • AddRecord() : CXTPGridControl, CXTPGridDataManager, CXTPGridSection
  • AddRecordEx() : CXTPGridControl
  • AddRef() : CXTPActiveScriptObjectContext
  • AddRemoveBookmark() : CXTPSyntaxEditCtrl
  • AddRemoveBreakPoint() : CXTPSyntaxEditCtrl
  • AddRemoveLineMark() : CXTPSyntaxEditLineMarksManager
  • AddResource() : CXTPCalendarResourcesManager, CXTPCalendarViewGroup
  • AddSelection() : CXTPFlowGraphSelectedElements
  • AddSliderControl() : CXTPPropertyGridItem
  • AddSpinButton() : CXTPGridRecordItemEditOptions, CXTPPropertyGridItem
  • AddStandardClasses() : CXTPSkinObjectClassMap
  • AddString() : CXTPControlComboBox
  • AddStyle() : CXTPTagCloudStyleManager
  • AddSwitch() : CXTPStatusBarSwitchPane
  • AddSynonymClass() : CXTPSkinObjectClassMap
  • AddSystemButton() : CXTPRibbonBar
  • AddTab() : CXTPRibbonBar
  • AddTag() : CXTPTagCloudCtrl
  • AddTail() : CXTPPropertyGridItems
  • AddTextItem() : CXTPTaskPanelGroup
  • AddTextSchemeInfo() : CXTPSyntaxEditTextSchemesManager
  • AddThemeInfo() : CXTPSyntaxEditColorThemesManager
  • AddTip() : CXTPTipOfTheDay
  • AddToCache() : CXTPCalendarData::CXTPDPCache
  • AddToCacheIfNeed() : CXTPCalendarData::CXTPDPCache
  • AddToDiscreteSelection() : CXTPCalendarView
  • AddToolBar() : CXTPReBar
  • AddToolbarCategory() : CXTPCustomizeCommandsPage
  • AddToolTip() : CXTPTabExBase
  • AddTrustedWindow() : CXTPMouseManager
  • AddUndoCommand() : CXTPFlowGraphUndoManager, CXTPTrackUndoManager
  • AddValue() : CXTPSyntaxEditCtrl::CAverageVal
  • AddView() : CXTPTabExBase
  • AddViewPart() : CXTPCalendarPaintManager
  • AddWorkspace() : CXTPTabClientWnd
  • AdjustAdditionalScaleTimeZone() : CXTPCalendarDayView
  • AdjustBlockPosition() : CXTPTrackControlItem
  • AdjustBorders() : CXTPTabBaseTheme, CXTPTabBaseThemeOfficeXP
  • AdjustBuddyRect() : CXTPEdit, CXTPEditTheme, CXTPEditThemeDefault, CXTPEditThemeOfficeXP, CXTPEditThemeResource
  • AdjustCalendarForPrint() : CXTPCalendarControlView
  • AdjustCaptionRect() : CXTPDockingPaneOffice2002VisioTheme, CXTPDockingPanePaintManager, CXTPDockingPaneVisualStudio2012Theme
  • AdjustClientRect() : CAppearanceSetVisio, CXTPDockingPaneOffice2007WordTheme, CXTPDockingPanePaintManager, CXTPDockingPaneVisualStudio2012Theme, CXTPTabPaintManager, CXTPTabPaintManagerTheme
  • AdjustColumnsWidth() : CXTPGridHeader
  • AdjustCursor() : CXTPDockingPaneContext
  • AdjustDayEvents() : CXTPCalendarDayViewGroup
  • AdjustDays() : CXTPCalendarMonthView::CMonthViewGrid
  • AdjustEvents() : CXTPCalendarMonthView::CMonthViewGrid
  • AdjustExcludeRect() : CXTPCommandBarsNativeXPTheme, CXTPCommandBarsOffice2000Theme, CXTPCommandBarsOfficeXPTheme, CXTPControlPopup, CXTPPaintManager, CXTPPopupBar, CXTPRibbonControlSystemButton, CXTPRibbonSystemPopupBarPage, CXTPRibbonTheme, CXTPVisualStudio2008Theme, CXTPVisualStudio2010Theme
  • AdjustFirstDayOfWeek() : CXTPCalendarMonthView::CMonthViewGrid, CXTPCalendarWeekView
  • AdjustGrid() : CXTPCalendarMonthView::CMonthViewGrid
  • AdjustHeader() : CXTPCalendarMonthView::CMonthViewGrid
  • AdjustIndentation() : CXTPGridControl
  • AdjustItemCaptionRect() : CXTPPropertyGridPaintManager
  • AdjustItemValueRect() : CXTPPropertyGridPaintManager
  • AdjustLayout() : CXTPCalendarCaptionBarControl, CXTPCalendarCaptionBarTheme, CXTPCalendarCaptionBarThemePart, CXTPCalendarControl, CXTPCalendarDayView, CXTPCalendarDayViewDay, CXTPCalendarDayViewEvent, CXTPCalendarDayViewGroup, CXTPCalendarDayViewTimeScale, CXTPCalendarMonthView, CXTPCalendarMonthView::CMonthViewGrid, CXTPCalendarMonthViewDay, CXTPCalendarMonthViewEvent, CXTPCalendarTimeLineView, CXTPCalendarTimeLineViewEvent, CXTPCalendarTimeLineViewGroup, CXTPCalendarTimeLineViewTimeScale, CXTPCalendarView, CXTPCalendarViewDay, CXTPCalendarViewDayT< _TView, _TViewGroup, XTP_CALENDAR_HITTESTINFO, _TPThis >, CXTPCalendarViewEvent, CXTPCalendarViewGroup, CXTPCalendarWeekView, CXTPCalendarWeekViewDay, CXTPCalendarWeekViewEvent, CXTPCheckboxButtonPart, CXTPDatePickerControl, CXTPDatePickerItemMonth, CXTPExpandButtonPart, CXTPGridControl, CXTPGridSections, CXTPRadioButtonPart, CXTPScrollDateButtonPart, CXTPSwitchViewButtonPart, CXTPTrackControl
  • AdjustLayout2() : CXTPCalendarDayView, CXTPCalendarDayViewDay, CXTPCalendarDayViewEvent, CXTPCalendarDayViewGroup, CXTPCalendarMonthView, CXTPCalendarMonthViewDay, CXTPCalendarMonthViewEvent, CXTPCalendarTimeLineViewEvent, CXTPCalendarView, CXTPCalendarViewEvent, CXTPCalendarViewGroup, CXTPCalendarWeekView, CXTPCalendarWeekViewDay, CXTPCalendarWeekViewEvent
  • AdjustMultidayEvent() : CXTPCalendarViewEvent
  • AdjustRect() : CXTPTabControl
  • AdjustRectangle() : CXTPDockingPaneContext
  • AdjustResizeRect() : CXTPResize, CXTPResizeFormView
  • AdjustScrollBar() : CXTPCalendarControl
  • AdjustScrollBarEx() : CXTPCalendarControl
  • AdjustScrollBars() : CXTPFlowGraphControl, CXTPGridControl
  • AdjustScrollSizes() : CXTPSearchOptionsView
  • AdjustSubjectEditor() : CXTPCalendarDayViewEvent, CXTPCalendarViewEvent
  • AdjustSubjectEditorEx() : CXTPCalendarDayViewEvent
  • AdjustTimeFont() : CXTPCalendarPaintManager
  • AdjustTrackColumnWidth() : CXTPTrackControl
  • AdjustWidth() : CXTPTabManagerNavigateButton
  • Advise() : CXTPCalendarMsgNotifier, CXTPNotifyConnection, CXTPNotifySinkBase
  • AdviseToNotifications() : CXTPCalendarController
  • AfterExecute() : CXTPChart3dLineDeviceCommand, CXTPChartDeviceCommand, CXTPChartPolygonAntialiasingDeviceCommand
  • AlignColIdxToTabs() : CXTPSyntaxEditDrawTextProcessor
  • Alloc() : CXTPShellPidl::CShellMalloc
  • Alloc_mem() : CXTPHeapAllocatorT< _TData >
  • AllocateList() : CXTPOpenGLListPool
  • AllocSysString() : CXTPHeapString
  • AllowAccess() : CXTPGridSection
  • AllowCollapse() : CXTPShortcutBar
  • AllowColumnRemove() : CXTPGridHeader
  • AllowColumnReorder() : CXTPGridHeader
  • AllowColumnResize() : CXTPGridHeader
  • AllowColumnSort() : CXTPGridHeader
  • AllowDrag() : CXTPTaskPanel, CXTPTaskPanelItem
  • AllowDrop() : CXTPTaskPanel, CXTPTaskPanelItem
  • AllowEdit() : CXTPGridSection, CXTPPropertyGrid
  • AllowFilter() : CXTPGridSection
  • AllowFreeResize() : CXTPShortcutBar
  • AllowGripperResize() : CXTPShortcutBar
  • AllowGroup() : CXTPGridSection
  • AllowMinimize() : CXTPRibbonBar, CXTPShortcutBar
  • AllowMove() : CXTPPopupControl
  • AllowNewToolbars() : CXTPCustomizeToolbarsPage
  • AllowNoncontinuousSelection() : CXTPDatePickerControl
  • AllowNullDate() : CXTPPropertyGridItemDate
  • AllowQuickAccessCustomization() : CXTPRibbonBar
  • AllowQuickAccessDuplicates() : CXTPRibbonBar
  • AllowReduce() : CXTPRibbonGroup
  • AllowRemove() : CXTPGridColumn
  • AllowSort() : CXTPGridSection
  • AllowUpperCase() : CXTPShellSettings
  • AlphaBlend() : CXTPImageManager
  • AlphaBlend2() : CXTPImageManager
  • AlphaBorder() : CXTPVisualStudio2008Theme
  • AlphaMask : CXTPChartColor
  • AlphaPixel() : CXTPCalendarShadowDrawer, CXTPVisualStudio2008Theme
  • AlphaShift : CXTPChartColor
  • Animate() : CXTPAnimationDC, CXTPPaintManager, CXTPPopupBar, CXTPPopupControl
  • AnimateExpanding() : CXTPPaintManager
  • AnimateGroups() : CXTPTaskPanel
  • AnimatePageTransition() : CXTPFlowGraphControl, CXTPFlowGraphPageHistory
  • AnimateTo() : CXTPFlowGraphControl
  • animationType : CXTPCommandBarsOptions
  • Antialiasing : CXTPChartDiagram3DAppearance
  • Append() : CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE >, CXTPCalendarEvents, CXTPCalendarPtrCollectionT< _TObject >, CXTPMemFile
  • Apply() : CXTPGridInplaceList, CXTPPropertyGridInplaceList, CXTPPropertyGridInplaceMultilineEdit
  • ApplyCenterPoint() : CXTPChartEllipse
  • ApplyColorFilter() : CXTPSkinManager, CXTPSkinManagerColorFilter
  • ApplyFieldWidths() : CXTPHeaderCtrl
  • ApplyFilter() : CXTPGridControl
  • ApplyRenderTransform() : CXTPMarkupUIElement, CXTPMarkupVisual
  • ApplySeriesStyle() : CXTPChartDeviceCommand
  • ApplyShadow2007BL() : CXTPCalendarShadowDrawer
  • ApplyShadow2007Bottom() : CXTPCalendarShadowDrawer
  • ApplyShadow2007BR() : CXTPCalendarShadowDrawer
  • ApplyShadow2007Center() : CXTPCalendarShadowDrawer
  • ApplyShadow2007Right() : CXTPCalendarShadowDrawer
  • ApplyShadow2007TR() : CXTPCalendarShadowDrawer
  • ApplyShadowBL() : CXTPCalendarShadowDrawer
  • ApplyShadowBR() : CXTPCalendarShadowDrawer
  • ApplyShadowLR() : CXTPCalendarShadowDrawer
  • ApplyShadowTB() : CXTPCalendarShadowDrawer
  • ApplyShadowTR() : CXTPCalendarShadowDrawer
  • ApplyTheme() : CXTPSyntaxEditCtrl, CXTPSyntaxEditLexTextSchema
  • ApplyThemeRecursive() : CXTPSyntaxEditLexTextSchema
  • ApplyTo() : CXTPChartSeriesStyle
  • ApplyToCalendar() : CXTPCalendarResourcesManager
  • ApplyToDeviceContext() : CXTPChartDiagram3DAppearance, CXTPChartElementAppearance
  • ApplyTransform() : CXTPMarkupGdiPlusTransformObjectImpl, CXTPMarkupMatrixTransform, CXTPMarkupRotateTransform, CXTPMarkupScaleTransform, CXTPMarkupSkewTransform, CXTPMarkupTransform, CXTPMarkupTranslateTransform
  • ApplyWindow() : CXTPSkinManager
  • Argb : CXTPChartColor
  • arr : CXTPCommandBars::KEYBOARDTIPS
  • Arrange() : CXTPFlowGraphControl, CXTPFlowGraphPage, CXTPMarkupUIElement
  • ArrangeCore() : CXTPMarkupUIElement
  • arrInplaceButtons : CXTPGridRecordItemEditOptions
  • AssignDocTemplate() : CXTPControl
  • AssignFile() : CXTPPropExchangeIniFile
  • AssignIconViewPropNumAndIconNum() : CXTPGridControl
  • AssociateCombo() : CXTPShellTreeBase, CXTPShellTreeCtrl
  • AssociateList() : CXTPShellTreeCtrl
  • AssociateTree() : CXTPShellListCtrl
  • Attach() : CXTPDockingPane, CXTPImageList, CXTPImageManagerIconHandle, CXTPTabClientWnd
  • AttachCalendar() : CXTPCalendarCaptionBarTheme
  • AttachPane() : CXTPDockingPaneManager
  • AttachView() : CXTPDockingPane
  • AutoAdjustLayout() : CXTPDatePickerItemMonth
  • AutoLoadPlacement() : CXTPPropertySheet, CXTPResize
  • AutoSaveColumns() : CXTPListBase
  • AutoSizeColumn() : CXTPListBase
  • AxisLabelTextColor : CXTPChartAxisAppearance
  • AxisTitleTextColor : CXTPChartAxisAppearance


Toolkit Pro: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- b -

  • b24_HFormat : CXTPCalendarView::SEventTimeFormatInfo
  • bAbove : XTP_NM_GRIDDRAGDROP
  • BackgroundColor : CXTPChartContentAppearance, CXTPChartDiagram2DAppearance, CXTPChartLegendAppearance
  • BackgroundColor2 : CXTPChartDiagram2DAppearance
  • BackgroundFillStyle : CXTPChartDiagram2DAppearance
  • bAllDayEvent : XTP_CALENDAR_VIEWSELECTION
  • bAlpha : XTP_IMAGERESOURCE_INFO
  • bAltDragCustomization : CXTPCommandBarsOptions
  • bAlwaysShowFullMenus : CXTPCommandBarsOptions
  • BaseTheme() : CXTPCommandBarsNativeXPTheme, CXTPCommandBarsOffice2000Theme, CXTPCommandBarsOffice2003Theme, CXTPCommandBarsOffice2013Theme, CXTPCommandBarsOfficeXPTheme, CXTPCommandBarsVisualStudio2012Theme, CXTPPaintManager, CXTPResourceTheme, CXTPRibbonTheme, CXTPVisualStudio2005Theme, CXTPVisualStudio2008Theme, CXTPVisualStudio2010Theme
  • bAutoUpdateShortcuts : CXTPCommandBarsOptions
  • bBeginRow : CXTPControlGallery::GALLERYITEM_POSITION
  • bBlockSelectionMode : CXTPSyntaxEditSelection
  • bCancel : XTP_DOCKINGPANE_ACTION, XTP_NM_GRIDPREVIEWKEYDOWN, XTP_NM_GRIDREQUESTEDIT, XTP_PROPERTYGRID_NOTIFYEDIT
  • bChecked : CXTPColorSelectorCtrl::COLOR_CELL, CXTPStatusBarSwitchPane::SWITCH
  • bCustomBar : XTP_COMMANDBARS_CREATEBAR
  • bDayView_AdditionalScaleLeftVisible : CXTPCalendarOptions
  • bDayView_AdditionalScaleRightVisible : CXTPCalendarOptions
  • bDayView_AutoResetBusyFlag : CXTPCalendarOptions
  • bDayView_DrawNowLineOverAppoinment : CXTPCalendarOptions
  • bDayView_ScaleLeftVisible : CXTPCalendarOptions
  • bDayView_ScaleRightVisible : CXTPCalendarOptions
  • bDayView_TimeScaleShowMinutes : CXTPCalendarOptions
  • bDblClickFloat : CXTPCommandBarsOptions
  • bDirtyState : CXTPCommandBarsOptions
  • bDisableCommandIfNoHandler : CXTPCommandBarsOptions
  • BeforeExecute() : CXTPChartDeviceCommand, CXTPChartPolygonAntialiasingDeviceCommand
  • BeforeUpdateRange() : CXTPChartBarSeriesView
  • BEGIN_VIEW_PART() : CXTPCalendarPaintManager
  • BeginBufferedPaint() : CXTPWinThemeWrapper
  • BeginDrag() : CXTPGridSubListControl, CXTPImageList, CXTPShellTreeBase
  • BeginEdit() : CXTPCalendarEventColorListBox, CXTPGridIconNavigator, CXTPGridNavigator
  • BeginFrequentUpdates() : CXTPChartContainer
  • BeginUpdate() : CXTPGridControl, CXTPPropertyGrid
  • bEnableAddNewTooltip : CXTPCalendarOptions
  • bEnabled : CXTPStatusBarSwitchPane::SWITCH, CXTPTaskPanelScrollButton
  • bEnableInPlaceCreateEvent : CXTPCalendarOptions
  • bEnableInPlaceEditEventSubject_AfterEventResize : CXTPCalendarOptions
  • bEnableInPlaceEditEventSubject_ByF2 : CXTPCalendarOptions
  • bEnableInPlaceEditEventSubject_ByMouseClick : CXTPCalendarOptions
  • bEnableInPlaceEditEventSubject_ByTab : CXTPCalendarOptions
  • bEnablePrevNextEventButtons : CXTPCalendarOptions
  • BestFit() : CXTPGridHeader, CXTPStatusBarPane
  • bEveryWeekDayOnly : XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_DAILY
  • bExpandBar : XTP_COMMANDBARS_CREATEBAR
  • bExpanding : XTP_TPNGROUPEXPANDING
  • bFlatStyle : XTPPROGRESSDRAWSTRUCT
  • bFlyByStatus : CXTPCommandBarsOptions
  • bHatchAllDayViewEventsBkgnd : CXTPCalendarOptions
  • bHighlighted : CXTPStatusBarSwitchPane::SWITCH
  • bHot : CXTPTaskPanelScrollButton
  • Bias : CXTPCalendarTimeZones::REGISTRY_TIMEZONE_INFORMATION
  • bIconsWithShadow : XTP_COMMANDBARS_ICONSINFO
  • BindHost() : CXTPPreviewProviderBase, IXTPPreviewProvider
  • BindToBool() : CXTPPropertyGridItemBool
  • BindToColor() : CXTPPropertyGridItemColor
  • BindToDate() : CXTPPropertyGridItemDate
  • BindToDouble() : CXTPPropertyGridItemDouble
  • BindToEnum() : CXTPPropertyGridItemEnum
  • BindToFlags() : CXTPPropertyGridItemFlags
  • BindToNumber() : CXTPPropertyGridItemNumber
  • BindToOption() : CXTPPropertyGridItemOption
  • BindToPoint() : CXTPPropertyGridItemPoint
  • BindToSize() : CXTPPropertyGridItemSize
  • BindToString() : CXTPPropertyGridItem
  • BindView() : CXTPChartDeviceCommand
  • bKeyControl : XTPGridInputState
  • bKeyShift : XTPGridInputState
  • BlackWhiteBitmap() : CXTPImageManager
  • bLargeIcons : CXTPCommandBarsOptions
  • BlendColor() : CXTPTaskPanelPaintManager
  • bLoadSilent : XTP_COMMANDBARS_PROPEXCHANGE_PARAM
  • BlueMask : CXTPChartColor
  • BlueShift : CXTPChartColor
  • bMarquee : XTPPROGRESSDRAWSTRUCT
  • bMenuShadows : CXTPAuxData
  • bModified : XTP_EDIT_NMHDR_DOCMODIFIED
  • bMonthView_CompressWeekendDays : CXTPCalendarOptions
  • bMonthView_HideTimes : CXTPCalendarOptions
  • bMonthView_ShowEndDate : CXTPCalendarOptions
  • bMonthView_ShowTimeAsClocks : CXTPCalendarOptions
  • bOfficeStyleDisabledIcons : XTP_COMMANDBARS_ICONSINFO
  • BorderColor : CXTPChartContentAppearance, CXTPChartDiagram2DAppearance, CXTPChartLegendAppearance, CXTPChartPieStyleAppearance
  • bottom : XTP_RESIZERECT
  • bPasteWillChangeExistingEvent : XTP_EVENT_PASTE_OPERATION_PARAMS
  • bPopup : XTP_COMMANDBARS_CREATEBAR
  • bPressed : CXTPStatusBarSwitchPane::SWITCH, CXTPTaskPanelScrollButton
  • bReturnValue : XTP_NM_GRIDDRAGDROP
  • BrowseCtrlCallback() : CXTPBrowseDialog
  • BrowseToFolder() : CXTPShellListCtrlEx
  • bSaveOnlyCustomized : XTP_COMMANDBARS_PROPEXCHANGE_PARAM
  • bSaveOriginalControls : XTP_COMMANDBARS_PROPEXCHANGE_PARAM
  • bScrollUp : CXTPTaskPanelScrollButton
  • bSelected : XTP_CALENDAR_DAYVIEWCELL_PARAMS, XTP_CALENDAR_THEME_DAYVIEWCELL_PARAMS, XTPGridInputState
  • bSelectingRunning : CXTPSyntaxEditSelection
  • bSerializeActions : XTP_COMMANDBARS_PROPEXCHANGE_PARAM
  • bSerializeControls : XTP_COMMANDBARS_PROPEXCHANGE_PARAM
  • bSerializeDesignerControls : XTP_COMMANDBARS_PROPEXCHANGE_PARAM
  • bSerializeImages : XTP_COMMANDBARS_PROPEXCHANGE_PARAM
  • bSerializeLayout : XTP_COMMANDBARS_PROPEXCHANGE_PARAM
  • bSerializeOptions : XTP_COMMANDBARS_PROPEXCHANGE_PARAM
  • bShowAllDayExpandButton : CXTPCalendarOptions
  • bShowCategoryIcons : CXTPCalendarOptions
  • bShowContextMenuAccelerators : CXTPCommandBarsOptions
  • bShowExpandButtonAlways : CXTPCommandBarsOptions
  • bShowFullAfterDelay : CXTPCommandBarsOptions
  • bShowKeyboardTips : CXTPCommandBarsOptions
  • bShowMiniToolbarTips : CXTPCommandBarsOptions
  • bShowPopupBarToolTips : CXTPCommandBarsOptions
  • bShowPopupButtonsSelectedToolbarOnly : CXTPCommandBarsOptions
  • bShowTextBelowIcons : CXTPCommandBarsOptions
  • bSmooth : XTPPROGRESSDRAWSTRUCT
  • bSyncFloatingBars : CXTPCommandBarsOptions
  • bTearOffBar : XTP_COMMANDBARS_CREATEBAR
  • bTimeLineCompact : CXTPCalendarOptions
  • bTimeLineFocused : CXTPCalendarOptions
  • bTimePartValid : XTP_CALENDAR_HITTESTINFO
  • bToolBar : XTP_COMMANDBARS_CREATECONTROL
  • bToolBarAccelTips : CXTPCommandBarsOptions
  • bToolBarScreenTips : CXTPCommandBarsOptions
  • bTrackThumb : XTP_SCROLLBAR_TRACKINFO
  • BufferedPaintSetAlpha() : CXTPWinThemeWrapper
  • BuildColumns() : CXTPListBase
  • BuildDefaultColumns() : CXTPShellListBase
  • BuildIfNeed() : CXTPSyntaxEditLexTextSchema
  • BuildTree() : CXTPGridSection
  • bUseAltNumPadKeys : CXTPCommandBarsOptions
  • bUseDisabledIcons : XTP_COMMANDBARS_ICONSINFO
  • bUseFadedIcons : XTP_COMMANDBARS_ICONSINFO
  • bUseOfficeFont : CXTPAuxData
  • bUseOutlookFontGlyphs : CXTPCalendarOptions
  • bUseSolidShadows : CXTPAuxData
  • bUseSystemSaveBitsStyle : CXTPCommandBarsOptions
  • ButtonHitTest() : CXTPExcelTabCtrl
  • buttonStyle : XTP_COMMANDBARS_CREATECONTROL
  • bVal : CXTPSkinManagerSchemaProperty
  • bVertical : XTPPROGRESSDRAWSTRUCT
  • bVista : XTPPROGRESSDRAWSTRUCT
  • bWeekView_ShowEndDate : CXTPCalendarOptions
  • bWeekView_ShowTimeAsClocks : CXTPCalendarOptions
  • bWin2K : CXTPAuxData
  • bWin95 : CXTPAuxData
  • bWin98 : CXTPAuxData
  • bWinNT : CXTPAuxData
  • bWinXP : CXTPAuxData
  • bWordSelectionMode : CXTPSyntaxEditSelection
  • bWorkCell : XTP_CALENDAR_THEME_DAYVIEWCELL_PARAMS
  • bWrapLargePopups : CXTPCommandBarsOptions
  • ByFontAdjustLayout() : CXTPDatePickerItemMonth


Toolkit Pro: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- c -

  • CacheGlobalData() : CXTPTaskPanelItem
  • CalcAbsCol() : CXTPSyntaxEditCtrl
  • CalcAveDataSize() : CXTPSyntaxEditBufferManager, CXTPSyntaxEditCtrl
  • CalcButtonBandRect() : CXTPDatePickerControl
  • CalcButtonSize() : CXTPDatePickerControl
  • CalcClientHeight() : CXTPRibbonBar
  • CalcColorRect() : CXTPCalendarComboBoxBase, CXTPCalendarEventColorListBox
  • CalcColumnHeight() : CXTPGridPaintManager
  • CalcDayDateRect() : CXTPCalendarMonthViewDay
  • CalcDayOfMonth() : CXTPCalendarUtils
  • CalcDayOfWeekRect() : CXTPDatePickerPaintManager
  • CalcDayRect() : CXTPDatePickerPaintManager
  • CalcDispCol() : CXTPSyntaxEditCtrl
  • CalcDockingLayout() : CXTPDialogBar, CXTPTabToolBar, CXTPToolBar
  • CalcDynamicLayout() : CXTPCommandBar, CXTPDialogBar, CXTPPopupBar, CXTPPopupToolBar, CXTPRibbonSystemPopupBar, CXTPRibbonSystemPopupBarPage, CXTPRibbonTabPopupToolBar, CXTPTabToolBar, CXTPToolBar
  • CalcDynamicSize() : CXTPControls, CXTPRibbonGroups
  • CalcEditRects() : CXTPSyntaxEditCtrl
  • CalcEllipseAngleFromCircleAngle() : CXTPChartEllipse
  • CalcEllipsePoint() : CXTPChartEllipse
  • CalcEllipseRadius() : CXTPChartEllipse
  • CalcEllipseSectorArea() : CXTPChartEllipse
  • CalcEllipseSectorFinishAngle() : CXTPChartEllipse
  • CalcEventSize() : CXTPCalendarPaintManager, CXTPCalendarTimeLineViewPart
  • CalcFrameBorder() : CXTPCommandBarsFrameHook, CXTPFramePaintManager, CXTPFrameThemeOffice2007System
  • CalcFrameCaption() : CXTPFramePaintManager
  • CalcFrameRegion() : CXTPFramePaintManager, CXTPFrameThemeOffice2007System
  • CalcGroupsHeight() : CXTPRibbonBar
  • CalcHeigt() : CXTPCalendarTimeLineViewTimeScalePart
  • CalcHScroll() : CXTPScrollBarPaintManager
  • CalcIconsRect() : CXTPCalendarViewEvent, CXTPCalendarWeekViewEvent
  • CalcInsideHeight() : CXTPTaskPanelGroup
  • CalcItemRect() : CXTPSyntaxEditTipWnd
  • CalcMaximumWidth() : CXTPSyntaxEditCtrl
  • CalcMaxLineTextLength() : CXTPSyntaxEditBufferManager
  • CalcMinimumItemHeight() : CXTPCheckListBox
  • CalcMinRect() : CXTPCalendarCaptionBarControl, CXTPCalendarCaptionBarTheme
  • CalcMinSize() : CXTPFlowGraphNode, CXTPFlowGraphNodeCustom
  • CalcMonthHeaderRect() : CXTPDatePickerPaintManager
  • CalcMonthRect() : CXTPDatePickerPaintManager
  • CalcPopupSize() : CXTPControls
  • CalcQuickAccessHeight() : CXTPRibbonBar
  • CalcRect() : CXTPCalendarTimeLineViewEvent
  • CalcRowLayout() : CXTPTagCloudCtrl
  • CalcScaleIntervalBegin() : CXTPCalendarTLV_TimeScaleParams
  • CalcSideMarginsValue() : CXTPChartAxis, CXTPChartAxisX, CXTPChartAxisY, CXTPChartRadarAxisX, CXTPChartRadarAxisY
  • CalcSize() : CXTPChartDiagram2DAxisView, CXTPChartLegendView, CXTPChartRadarAxisXView, CXTPChartRadarAxisYView, CXTPColorSelectorCtrl, CXTPColorSelectorCtrlTheme, CXTPColorSelectorCtrlThemeOffice2013, CXTPDialogBar
  • CalcStartEndDatesFromPattern() : CXTPCalendarEvent
  • CalcToolTipRect() : CXTPCalendarTip
  • CalculateAnchorPointAndAngles() : CXTPChartPieSeriesLabel
  • CalculateBounds() : CXTPChartRotatedTextPainterBase, CXTPChartTextPainter, CXTPChartTextPainterBase
  • CalculateCenter() : CXTPChartPieBase
  • CalculateDocumentRow() : CXTPSyntaxEditCtrl
  • CalculateEditbarLength() : CXTPSyntaxEditCtrl
  • CalculateHeaderFormat() : CXTPCalendarView
  • CalculateHeight() : CXTPPopupItem
  • CalculateLabelLayout() : CXTPChartFunnelSeriesViewBase, CXTPChartPieSeriesViewBase, CXTPChartPyramidSeriesViewBase
  • CalculateLayout() : CXTPChart3dFunnelSeriesPointView, CXTPChart3dPieSeriesPointView, CXTPChart3dPyramidSeriesPointView, CXTPChartFunnelSeriesPointViewBase, CXTPChartPieSeriesLabelView, CXTPChartPieSeriesPointView, CXTPChartPieSeriesPointViewBase, CXTPChartPyramidSeriesPointView, CXTPChartPyramidSeriesPointViewBase
  • CalculateLeftTopPoint() : CXTPChartRotatedTextPainterBase, CXTPChartRotatedTextPainterNearLine
  • CalculatePointLayout() : CXTPChart3dFunnelSeriesView, CXTPChart3dPieSeriesView, CXTPChart3dPyramidSeriesView, CXTPChartFunnelSeriesView, CXTPChartFunnelSeriesViewBase, CXTPChartPieSeriesView, CXTPChartPieSeriesViewBase, CXTPChartPyramidSeriesView, CXTPChartPyramidSeriesViewBase
  • CalculatePoints() : CXTPChartRotatedTextPainterBase
  • CalculatePopupRect() : CXTPPopupBar, CXTPRibbonTabPopupToolBar
  • CalculateRects() : CXTPColorDialog
  • CalculateRotation() : CXTPChartRotatedTextPainterBase, CXTPChartRotatedTextPainterNearLine
  • CalculateRowHeight() : CXTPGridPaintManager
  • CalculateSeriesLayout() : CXTPChartDiagram, CXTPChartFunnelDiagramBase< BaseDiagram >, CXTPChartPieDiagramBase< BaseDiagram >, CXTPChartPyramidDiagramBase< BaseDiagram >
  • CalculateTabWidth() : CXTPTabExBase
  • CalculateView() : CXTPChartContentView, CXTPChartDiagram2DView, CXTPChartDiagramView, CXTPChartLegendView, CXTPChartRadarDiagramView
  • CalculateVisibleRow() : CXTPSyntaxEditCtrl
  • CalculateVisibleRow_() : CXTPSyntaxEditCtrl
  • CalculateWidth() : CXTPPopupItem
  • CalcValidDispCol() : CXTPSyntaxEditCtrl
  • CalcVScroll() : CXTPScrollBarPaintManager
  • CalcWeekNumbersRect() : CXTPDatePickerPaintManager
  • CalcWidth() : CXTPCalendarDayViewTimeScale, CXTPCalendarPaintManager
  • CanAttach() : CXTPDockingPaneTabbedContainer
  • Cancel() : CXTPGridInplaceList, CXTPPropertyGridInplaceList, CXTPPropertyGridInplaceMultilineEdit
  • CancelDrag() : CXTPGridSubListControl
  • CancelDraggingEvent() : CXTPCalendarView
  • CancelLabelEdit() : CXTPFlowGraphControl
  • CancelLoop() : CXTPDockingPaneContext
  • CancelMouseMode() : CXTPGridHeader
  • CancelRightButtonDrag() : CXTPSyntaxEditCtrl
  • CancelToolTips() : CXTPToolTipContext
  • CanChangeReadonlyFile() : CXTPSyntaxEditView
  • CanCopy() : CXTPCalendarView, CXTPGridControl
  • CanCut() : CXTPCalendarView, CXTPGridControl
  • CanDock() : CXTPCommandBars
  • CanEditDoc() : CXTPSyntaxEditCtrl
  • CanGoBackward() : CXTPFlowGraphPageHistory
  • CanGoForward() : CXTPFlowGraphPageHistory
  • CanOverType() : CXTPMaskEditT< TBase >
  • CanPaste() : CXTPCalendarView, CXTPEdit, CXTPFlowGraphPage, CXTPGridControl
  • CanRedo() : CXTPCalendarView, CXTPFlowGraphUndoManager, CXTPSyntaxEditCtrl, CXTPSyntaxEditUndoRedoManager, CXTPTrackUndoManager
  • CanUndo() : CXTPCalendarView, CXTPFlowGraphUndoManager, CXTPSyntaxEditCtrl, CXTPSyntaxEditUndoRedoManager, CXTPTrackUndoManager
  • CanUseMask() : CXTPMaskEditT< TBase >
  • CAppearanceSetPropertyPage2003() : CAppearanceSetPropertyPage2003
  • CAppearanceSetPropertyPage2007() : CAppearanceSetPropertyPage2007
  • CAppearanceSetPropertyPageAccess2007() : CAppearanceSetPropertyPageAccess2007
  • CAppearanceSetPropertyPageFlat() : CAppearanceSetPropertyPageFlat
  • CAppearanceSetStateButtons() : CAppearanceSetStateButtons
  • CAppearanceSetVisualStudio2005() : CAppearanceSetVisualStudio2005
  • CAverageVal() : CXTPSyntaxEditCtrl::CAverageVal
  • CCaptionButton() : CXTPSkinObjectFrame::CCaptionButton
  • CCheckListState() : CXTPCheckListBox::CCheckListState
  • CColorCellList : CXTPColorSelectorCtrl
  • CColorFontMap : CXTPTreeBase
  • CColorSetVisualStudio2005() : CColorSetVisualStudio2005
  • CContentItemList : CXTPShortcutListBox
  • CEmptySyncObject() : CXTPNotifyConnection::CEmptySyncObject
  • CenterIcon() : CXTPPopupItem
  • CExclusiveLock() : CXTPRWCriticalSection::CExclusiveLock
  • cf : NMXTPCHARHDR
  • ChainLastCommand() : CXTPSyntaxEditUndoRedoManager
  • ChangeCase() : CXTPSyntaxEditBufferManager
  • ChangeColumnOrder() : CXTPGridColumns
  • ChangeEvent() : CXTPCalendarData
  • ChangeEventPlace() : CXTPCalendarDayViewEvent, CXTPCalendarTimeLineViewEvent, CXTPCalendarViewEvent
  • ChangeTabification() : CXTPSyntaxEditBufferManager
  • CheckChar() : CXTPMaskEditT< TBase >
  • CheckCommandBarsTheme() : CXTPTabClientWnd
  • CheckDeadEnd() : CXTPGridNavigator
  • CheckFileModified() : CXTPSyntaxEditDoc
  • CheckForMouseOver() : CXTPDockingPaneCaptionButton, CXTPDockingPaneCaptionButtons
  • CheckFromPoint() : CXTPCheckListBox
  • CheckKeyboardTips() : CXTPRibbonBackstageView
  • CheckScrollBarsDraw() : CXTPSkinObjectComCtl32Control, CXTPSkinObjectUser32Control
  • CheckScrollButtonMouseOver() : CXTPTaskPanel
  • CheckTabsKeyboardTips() : CXTPRibbonBackstageView
  • CheckValue() : CXTPCalendarShadowDrawer
  • ChooseDirectory() : CXTPBrowseEdit
  • ChooseFile() : CXTPBrowseEdit
  • CIconSetMap : CXTPImageManagerIconSet
  • ClampA() : CXTPChartColor
  • ClampB() : CXTPChartColor
  • ClampG() : CXTPChartColor
  • ClampR() : CXTPChartColor
  • CleanOfRedundant() : CXTPGridRecords
  • CleanUp() : CXTPHeaderCtrlTheme, CXTPSyntaxEditBufferManager
  • Cleanup() : CXTPFlowGraphPaintManager, CXTPSyntaxEditColorTheme
  • Clear() : CXTPCalendarEvent, CXTPDatePickerDaysCollection, CXTPFlowGraphPageHistory, CXTPFlowGraphSelectedElements, CXTPFlowGraphUndoManager, CXTPGridColumnOrder, CXTPGridColumns, CXTPGridRows, CXTPGridSelectedRows, CXTPImageManagerIconHandle, CXTPImageManagerResource, CXTPPropertyGridItems, CXTPSyntaxEditBatchCommand, CXTPSyntaxEditTextRegion, CXTPSyntaxEditUndoRedoManager, CXTPTaskPanelItems, CXTPTrackUndoManager, XTP_EDIT_LINECOL
  • ClearAllItems() : CXTPExcelTabCtrl
  • ClearCache() : CXTPCalendarData
  • ClearDays() : CXTPDatePickerItemMonth
  • ClearDeleteGridRecords() : CXTPGridDataManager
  • ClearDiscreteSelection() : CXTPCalendarView
  • ClearEventCategoryList() : CXTPCalendarData
  • ClearEventLabelList() : CXTPCalendarData
  • ClearFocus() : CXTPDatePickerControl
  • ClearGridControl() : CXTPGridDataManager
  • ClearIconMap() : CXTPDockingPaneManager
  • ClearIntermediateData() : CXTPCalendarEvent
  • ClearMergeHeight() : CXTPGridRows
  • ClearMonths() : CXTPDatePickerControl
  • ClearOnScreenSchCache() : CXTPSyntaxEditCtrl
  • ClearOriginalControls() : CXTPControls
  • ClearProperties() : CXTPCalendarReminderForOccurrenceArray, CXTPResourceImages
  • ClearProperty() : CXTPSkinManagerSchemaProperty
  • Click() : CXTPDockingPaneCaptionButton, CXTPMessageBar
  • ClickButton() : CXTPTaskDialog
  • ClickRadioButton() : CXTPTaskDialog
  • ClickToolBarButton() : CXTPControl
  • ClickVerification() : CXTPTaskDialog
  • CLineMarksListPtr : CXTPSyntaxEditLineMarksManager
  • ClipAndAddEllipsisIfNeeded() : CXTPDockingPanePaintManager
  • ClipItems() : CXTPControlGalleryItems
  • CListenerArray : CXTPColorSelectorCtrl
  • CLock() : CXTPSimpleCriticalSection::CLock
  • CLogFont() : CXTPPaintManager::CLogFont
  • Clone() : CXTPDockingPaneBase, CXTPMarkupGdiPlusTransformationMatrix, CXTPMarkupTransformationMatrix, CXTPMatrix< T >, CXTPPropExchangeXMLNode, CXTPSyntaxEditLexTextSchema, CXTPSyntaxEditLexVariant
  • CloneEvent() : CXTPCalendarEvent
  • CloneEvents() : CXTPCalendarEvents
  • CloneEventTo() : CXTPCalendarEvent
  • CloneForOccurrence() : CXTPCalendarEvent
  • ClonePattern() : CXTPCalendarRecurrencePattern
  • Close() : CXTPCalendarCustomDataProvider, CXTPCalendarData, CXTPCalendarDatabaseDataProvider, CXTPCalendarMemoryDataProvider, CXTPDockingPane, CXTPMemFile, CXTPPopupControl, CXTPResourceManager, CXTPResourceManagerXML, CXTPSkinManagerResourceFile, CXTPSyntaxEditBufferManager, CXTPSyntaxEditConfigurationManager, CXTPSyntaxEditLexClass, CXTPSyntaxEditLexParser, CXTPSyntaxEditLexTextBlock, CXTPSyntaxEditLexTextSchema
  • CloseActiveWindow() : CXTPDockingPaneAutoHidePanel
  • CloseActiveWindows() : CXTPDockingPaneAutoHidePanel
  • CloseAll() : CXTPDockingPaneManager
  • CloseClasses() : CXTPSyntaxEditLexClass
  • ClosePane() : CXTPDockingPaneManager
  • CloseParseThread() : CXTPSyntaxEditLexParser
  • ClosePopups() : CXTPCommandBars
  • CloseThemeData() : CXTPWinThemeWrapper
  • clr : CXTPColorSelectorCtrl::COLOR_CELL
  • clr3DDkShadow : CXTPAuxData
  • clr3DFace : CXTPAuxData
  • clr3DHilight : CXTPAuxData
  • clr3DLight : CXTPAuxData
  • clr3DShadow : CXTPAuxData
  • clrActiveCaption : CXTPAuxData
  • clrActiveCaptText : CXTPAuxData
  • clrBack : CXTPColorSetStateButton, CXTPColorSetStateCheckMark, CXTPColorSetStateComboBox, XTP_SCROLLBARINICOLORS, XTPRIBBON_HEADER_COLOR
  • clrBackChecked : CXTPColorSetStateButton
  • clrBackCheckedHighlight : CXTPColorSetStateButton
  • clrBackDisabled : CXTPColorSetStateButton, CXTPColorSetStateCheckMark, CXTPColorSetStateComboBox
  • clrBackDropped : CXTPColorSetStateComboBox
  • clrBackground : XTP_DAYITEM_METRICS, XTP_GRIDRECORDITEM_METRICS
  • clrBackgroundColor : XTP_CALENDAR_DAYVIEWCELL_PARAMS
  • clrBackHighlight : CXTPColorSetStateButton, CXTPColorSetStateCheckMark, CXTPColorSetStateComboBox
  • clrBackPushed : CXTPColorSetStateButton, CXTPColorSetStateCheckMark
  • clrBlock : XTP_EDIT_TEXTBLOCK
  • clrBorder : CXTPColorSetStateButton, CXTPColorSetStateComboBox, CXTPTabPaintManagerColorSet::COLORSET_TAB_STATEBUTTON
  • clrBorderChecked : CXTPColorSetStateButton
  • clrBorderCheckedHighlight : CXTPColorSetStateButton
  • clrBorderDisabled : CXTPColorSetStateButton, CXTPColorSetStateComboBox
  • clrBorderDropped : CXTPColorSetStateComboBox
  • clrBorderHighlight : CXTPColorSetStateButton, CXTPColorSetStateComboBox
  • clrBorderLeftHighlight : CXTPTabPaintManagerColorSet::COLORSET_TAB_PROPERTYPAGE2003
  • clrBorderPushed : CXTPColorSetStateButton
  • clrBorderTopHighlight : CXTPTabPaintManagerColorSet::COLORSET_TAB_PROPERTYPAGE2003
  • clrBtnText : CXTPAuxData
  • clrButton : XTP_PICK_BUTTON
  • clrCheck : CXTPColorSetStateCheckMark
  • clrCheckDisabled : CXTPColorSetStateCheckMark
  • clrCheckHighlight : CXTPColorSetStateCheckMark
  • clrCheckPushed : CXTPColorSetStateCheckMark
  • clrClient : XTP_TASKPANEL_GROUPCOLORS
  • clrClientBorder : XTP_TASKPANEL_GROUPCOLORS
  • clrClientLink : XTP_TASKPANEL_GROUPCOLORS
  • clrClientLinkHot : XTP_TASKPANEL_GROUPCOLORS
  • clrClientLinkSelected : XTP_TASKPANEL_GROUPCOLORS
  • clrClientText : XTP_TASKPANEL_GROUPCOLORS
  • clrDark : CXTPPaintManagerColorGradient
  • clrDarkShadow : CXTPTabPaintManagerColorSet::COLORSET_TAB_PROPERTYPAGE2003, CXTPTabPaintManagerColorSet::COLORSET_TAB_PROPERTYPAGE
  • clrDisabledIcon : CXTPColorSetStateToolbar
  • clrDropDownBack : CXTPColorSetStateComboBox
  • clrDropDownBackDisabled : CXTPColorSetStateComboBox
  • clrDropDownBackDropped : CXTPColorSetStateComboBox
  • clrDropDownBackHighlight : CXTPColorSetStateComboBox
  • clrDropDownBorder : CXTPColorSetStateComboBox
  • clrDropDownBorderDisabled : CXTPColorSetStateComboBox
  • clrDropDownBorderDropped : CXTPColorSetStateComboBox
  • clrDropDownBorderHighlight : CXTPColorSetStateComboBox
  • clrDropDownMarker : CXTPColorSetStateComboBox
  • clrDropDownMarkerDisabled : CXTPColorSetStateComboBox
  • clrDropDownMarkerDropped : CXTPColorSetStateComboBox
  • clrDropDownMarkerHighlight : CXTPColorSetStateComboBox
  • clrEdge : XTPRIBBON_HEADER_COLOR
  • clrEditBorder : CXTPColorSetStateToolbar
  • clrFace : CXTPTabPaintManagerColorSet::COLORSET_TAB_STATEBUTTON
  • CLRFONT() : CXTPTreeBase::CLRFONT
  • clrForeground : XTP_DAYITEM_METRICS, XTP_GRIDRECORDITEM_METRICS
  • clrFrameBorder : CXTPTabPaintManagerColorSet::COLORSET_TAB_PROPERTYPAGE2003
  • clrGradActiveCapt : CXTPAuxData
  • clrGradInActiveCapt : CXTPAuxData
  • clrGrayText : CXTPAuxData
  • clrGripper : CXTPColorSetStateMenu, CXTPColorSetStateToolbar
  • clrHead : XTP_TASKPANEL_GROUPCOLORS
  • clrHeadTextHot : XTP_TASKPANEL_GROUPCOLORS
  • clrHeadTextNormal : XTP_TASKPANEL_GROUPCOLORS
  • clrHighlight : CXTPAuxData, CXTPTabPaintManagerColorSet::COLORSET_TAB_PROPERTYPAGE
  • clrHighlightText : CXTPAuxData
  • clrInActiveCaption : CXTPAuxData
  • clrInactiveCaptText : CXTPAuxData
  • clrLeftInnerBorder : CXTPTabPaintManagerColorSet::COLORSET_TAB_EXCEL
  • clrLeftOuterBorder : CXTPTabPaintManagerColorSet::COLORSET_TAB_EXCEL
  • clrLight : CXTPPaintManagerColorGradient
  • clrMenu : CXTPAuxData
  • clrMenuBack : CXTPColorSetStateMenu
  • clrMenuBorder : CXTPColorSetStateMenu
  • clrMenuText : CXTPAuxData
  • clrRightInnerBorder : CXTPTabPaintManagerColorSet::COLORSET_TAB_EXCEL
  • clrRightOuterBorder : CXTPTabPaintManagerColorSet::COLORSET_TAB_EXCEL
  • clrScrollArrow : XTP_SCROLLBARINICOLORS
  • clrScrollBack : XTP_SCROLLBARINICOLORS
  • clrScrollBorder : XTP_SCROLLBARINICOLORS
  • clrScrollDownArrow : XTP_SCROLLBARDRAWCOLORS
  • clrScrollDownBack : XTP_SCROLLBARDRAWCOLORS
  • clrScrollDownBorder : XTP_SCROLLBARDRAWCOLORS
  • clrSeparator : CXTPColorSetStateMenu, CXTPColorSetStateToolbar
  • clrShadow : CXTPTabPaintManagerColorSet::COLORSET_TAB_PROPERTYPAGE
  • clrTabBackInactive : CXTPColorSetStateRibbon
  • clrTabTextInactive : CXTPColorSetStateRibbon
  • clrText : CXTPColorSetStateButton, XTPRIBBON_HEADER_COLOR
  • clrTextChecked : CXTPColorSetStateButton
  • clrTextCheckedHighlight : CXTPColorSetStateButton
  • clrTextDisabled : CXTPColorSetStateButton
  • clrTextHighlight : CXTPColorSetStateButton
  • clrTextPushed : CXTPColorSetStateButton
  • clrThumbBack : XTP_SCROLLBARINICOLORS
  • clrThumbBorder : XTP_SCROLLBARINICOLORS
  • clrToolbarActiveBack : CXTPColorSetStateToolbar
  • clrToolbarActiveBorder : CXTPColorSetStateToolbar
  • clrToolbarBack : CXTPColorSetStateToolbar
  • clrToolbarBorder : CXTPColorSetStateToolbar
  • clrToolbarInactiveBack : CXTPColorSetStateToolbar
  • clrToolbarInactiveBorder : CXTPColorSetStateToolbar
  • clrTopInnerBorder : CXTPTabPaintManagerColorSet::COLORSET_TAB_EXCEL
  • clrTopOuterBorder : CXTPTabPaintManagerColorSet::COLORSET_TAB_EXCEL
  • clrVal : CXTPSkinManagerSchemaProperty
  • clrWindow : CXTPAuxData
  • clrWindowFrame : CXTPAuxData
  • clrWindowText : CXTPAuxData
  • clrXPBarFace : CXTPAuxData
  • clrXPBarText : CXTPAuxData
  • clrXPBarTextPushed : CXTPAuxData
  • clrXPDisabled : CXTPAuxData
  • clrXPGrayText : CXTPAuxData
  • clrXPGripper : CXTPAuxData
  • clrXPHighlight : CXTPAuxData
  • clrXPHighlightBorder : CXTPAuxData
  • clrXPHighlightChecked : CXTPAuxData
  • clrXPHighlightCheckedBorder : CXTPAuxData
  • clrXPHighlightPushed : CXTPAuxData
  • clrXPHighlightText : CXTPAuxData
  • clrXPIconShadow : CXTPAuxData
  • clrXPMenuBorder : CXTPAuxData
  • clrXPMenuExpanded : CXTPAuxData
  • clrXPMenuText : CXTPAuxData
  • clrXPMenuTextBack : CXTPAuxData
  • clrXPSeparator : CXTPAuxData
  • clrXPTabInactiveBack : CXTPAuxData
  • clrXPTabInactiveText : CXTPAuxData
  • CManageState() : CXTPResourceManager::CManageState
  • cmdSB : XTP_SCROLLBAR_TRACKINFO
  • CMonthViewGrid() : CXTPCalendarMonthView::CMonthViewGrid
  • code : XTP_EDIT_NMHDR_PARSEEVENT
  • ColFromXPos() : CXTPSyntaxEditDrawTextProcessor
  • Collapse() : CXTPDockingPaneMiniWnd, CXTPDockingPaneSidePanel, CXTPPropertyGridItem
  • CollapseAll() : CXTPGridControl, CXTPGridSection, CXTPSyntaxEditCtrl
  • CollapseExpandBlock() : CXTPSyntaxEditCtrl
  • collBlock : XTP_EDIT_COLLAPSEDBLOCK
  • Color : CXTPChartAxisAppearance
  • color : CXTPTreeBase::CLRFONT
  • colorBack : CXTPTreeBase::CLRFONT
  • ColorFromPoint() : CXTPColorHex
  • ColToStrPos() : CXTPSyntaxEditBufferManager
  • CommandToIndex() : CXTPControls, CXTPStatusBar
  • Commit() : CXTPChartDeviceCommand
  • CommitContextMenu() : CXTPCustomizeMenusPage
  • CommitDraggingEvent() : CXTPCalendarView
  • CommitList() : CXTPOpenGLListPool
  • CommonConstruct() : CXTPChartSeriesPoint
  • Compare() : CXTPControl, CXTPControlComboBox, CXTPControlEdit, CXTPControlPopup, CXTPControls, CXTPGridRecordItem, CXTPGridRecordItemDateTime, CXTPGridRecordItemNumber, CXTPGridRecordItemVariant, CXTPGridRecords, CXTPMathUtils, CXTPSortClass
  • CompareEvents_ByID() : CXTPCalendarEvents
  • CompareEvents_ForView() : CXTPCalendarEvents
  • CompareEvents_ForViewByStart() : CXTPCalendarEvents
  • CompareGroupCaption() : CXTPGridRecordItem, CXTPGridRecordItemDateTime, CXTPGridRecordItemNumber, CXTPGridRecordItemVariant
  • ComparePidls() : CXTPShellPidl
  • CompareRows() : CXTPGridRows
  • CompareRows2() : CXTPGridRows
  • ComputeConnectorBend() : CXTPChart3dPieSeriesLabelDeviceCommand
  • ComputeConnectorVector() : CXTPChart3dFunnelSeriesLabelDeviceCommand, CXTPChart3dPieSeriesLabelDeviceCommand, CXTPChart3dPyramidSeriesLabelDeviceCommand
  • ComputeLabel() : CXTPChart3dFunnelSeriesLabelDeviceCommand, CXTPChart3dPieSeriesLabelDeviceCommand, CXTPChart3dPyramidSeriesLabelDeviceCommand
  • ComputeTriangleNormal() : CXTPMathUtils, CXTPOpenGLUtils
  • ComputeVectorCrossProduct() : CXTPMathUtils
  • ComputeVectorDotProduct() : CXTPMathUtils
  • ComputeVectorLength() : CXTPMathUtils
  • ConcatPidls() : CXTPShellPidl
  • Condense() : CXTPTabExBase
  • ConstantLineColor : CXTPChartAxisAppearance
  • ConstantLineTextColor : CXTPChartAxisAppearance
  • ConstructCaption() : CXTPControlWindowList
  • ContainPane() : CXTPDockingPaneBase, CXTPDockingPaneBaseContainer
  • Contains() : CXTPDatePickerDaysCollection, CXTPGridRows, CXTPGridSelectedRows, CXTPRectT< T >
  • ContainsInvisibleEvents() : CXTPCalendarViewDay
  • ContainsInvisibleEventsUpdate() : CXTPCalendarViewDay
  • ContainsPopup() : CXTPControlPopup
  • ContextMenu() : CXTPCommandBars, CXTPCustomizeSheet, CXTPTabClientWnd
  • Contract() : CXTPSearchOptionsCtrl
  • controlType : XTP_COMMANDBARS_CREATECONTROL
  • ConvertFrom() : CXTPMarkupGridLength
  • ConvertToBits() : CXTPResourceImage
  • ConvertToIcon() : CXTPTransparentBitmap
  • ConvertUnicodeAlpha() : CXTPMaskEditT< TBase >
  • Copy() : CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE >, CXTPCalendarView, CXTPCommandBar, CXTPControl, CXTPControlButton, CXTPControlButtonColor, CXTPControlComboBox, CXTPControlComboBoxList, CXTPControlCustom, CXTPControlEdit, CXTPControlFontComboBoxList, CXTPControlGallery, CXTPControlListBox, CXTPControlPopup, CXTPControlPopupColor, CXTPControlProgress, CXTPControls, CXTPControlSelector, CXTPControlStatic, CXTPDockingPane, CXTPDockingPaneBase, CXTPDockingPaneLayout, CXTPDockingPaneMiniWnd, CXTPDockingPaneSidePanel, CXTPDockingPaneSplitterContainer, CXTPDockingPaneTabbedContainer, CXTPFlowGraphPage, CXTPGridControl, CXTPImageList, CXTPImageManagerIcon, CXTPMenuBar, CXTPPopupBar, CXTPRibbonControls, CXTPRibbonControlTab, CXTPRibbonGroup, CXTPRibbonGroups, CXTPRibbonTab, CXTPSyntaxEditCtrl, CXTPTagCloudStyle, CXTPToolBar
  • CopyAccels() : CXTPShortcutManagerAccelTable
  • CopyAccelTable() : CXTPShortcutManagerAccelTable
  • CopyAlphaBitmap() : CXTPImageManagerIcon
  • CopyFrom() : CXTPGridHyperlinks, CXTPGridRecordItemControls
  • CopyHandle() : CXTPImageManagerIconHandle
  • CopyIDList() : CXTPShellPidl
  • CopyOrMoveText() : CXTPSyntaxEditCtrl
  • CopyPidlItem() : CXTPShellPidl
  • CopyRow() : CXTPListBase
  • CopySettings() : CXTPCalendarThemeCustomizableXValueT< _TValue, _TValueRef >, CXTPCalendarThemeFontValue, CXTPCalendarViewPartCustomizableValueT< _TValue >
  • CopyTo() : CXTPCalendarCustomProperties
  • CopyToClipboard() : CXTPChartControl, CXTPColorDialog, CXTPMaskEditT< TBase >, CXTPTaskPanelItem
  • Correct() : CXTPChartAxisRange
  • CorrectAxisSideMargins() : CXTPChartBarSeriesStyle, CXTPChartBubbleSeriesStyle, CXTPChartSeriesStyle, CXTPChartStackedBarSeriesStyle
  • cpx : XTP_SCROLLBAR_POSINFO
  • cpxThumb : XTP_SCROLLBAR_POSINFO
  • crBack : CXTPListBase::ROWCOLOR, XTP_EDIT_COLORVALUES
  • crBreakpointBack : XTP_EDIT_COLORVALUES
  • crBreakpointText : XTP_EDIT_COLORVALUES
  • Create() : CXTPBrowseButton, CXTPCalendarCaptionBarControl, CXTPCalendarControl, CXTPCalendarData, CXTPCalendarDatabaseDataProvider, CXTPCalendarMemoryDataProvider, CXTPCalendarRemindersDialog, CXTPCalendarTip, CXTPCaption, CXTPCaptionPopupWnd, CXTPChartScaleTypeMap, CXTPCheckListBox, CXTPColorPopup, CXTPColorSelectorCtrl, CXTPDatePickerControl, CXTPDatePickerList, CXTPDockingPaneAutoHidePanel, CXTPDockingPaneMiniWnd, CXTPDockingPaneSidePanel, CXTPDockingPaneSplitterWnd, CXTPExcelTabCtrl, CXTPEyeDropper, CXTPFlowGraphControl, CXTPFlowGraphEditItem, CXTPFrameShadow, CXTPGaugeCtrl, CXTPGridControl, CXTPGridHeaderDragWnd, CXTPGridHeaderDropWnd, CXTPGridInplaceButton, CXTPGridInplaceEdit, CXTPGridInplaceList, CXTPGridTip, CXTPHexEdit, CXTPImageList, CXTPItemEdit, CXTPMessageBar, CXTPPageScroller, CXTPPopupBar, CXTPPopupControl, CXTPPreviewCtrl, CXTPPropertyGrid, CXTPPropertyGridInplaceEdit, CXTPPropertyGridInplaceList, CXTPPropertyGridInplaceMultilineEdit, CXTPPropertyGridToolTip, CXTPPropertyPageNavigator, CXTPPropertySheet, CXTPScrollable< Base >, CXTPShortcutBar, CXTPShortcutBarPane, CXTPShortcutListBox, CXTPStatusBar, CXTPStickerBase, CXTPSyntaxEditAutoCompleteWnd, CXTPSyntaxEditCtrl, CXTPSyntaxEditTipWnd, CXTPSyntaxEditToolTipCtrl, CXTPTabClientDraggingContents, CXTPTabControl, CXTPTagCloudCtrl, CXTPTaskDialog, CXTPTaskDialogLinkCtrl, CXTPTaskPanel, CXTPTipWindow, CXTPToolBar, CXTPTrayIcon, CXTPWebBrowserCtrl
  • Create32BPPDIBSection() : CXTPImageManager
  • CreateAction() : CXTPCommandBars
  • CreateAutoButton() : CXTPColorSelectorCtrlTheme, CXTPColorSelectorCtrlThemeOffice2013
  • CreateBar() : IXTPScrollable
  • CreateBorder() : CXTPGridRecordItem
  • CreateBoundedPieDeviceCommand() : CXTPChart3dPie, CXTPChartPie, CXTPChartPieBase
  • CreateBrushIndirect() : CXTPBrush
  • CreateButtonIcons() : CXTPExcelTabCtrl
  • CreateButtons() : CXTPPropertySheet
  • CreateCellArray() : CXTPColorHex
  • CreateCircleDeviceCommand() : CXTPChartFillStyle
  • CreateColorButtons() : CXTPColorSelectorCtrlTheme
  • CreateColumns() : CXTPGridDataManager
  • CreateComboBoxGalleryPopupBar() : CXTPControlComboBoxGalleryPopupBar
  • CreateCommandBars() : CXTPCommandBars
  • CreateConnectorDeviceCommand() : CXTPChart3dFunnelSeriesLabelView, CXTPChart3dPieSeriesLabelView, CXTPChart3dPyramidSeriesLabelView, CXTPChartPieSeriesLabelView, CXTPChartPieSeriesLabelViewBase
  • CreateConstantLinesDeviceCommand() : CXTPChartDiagram2DAxisView, CXTPChartRadarAxisXView, CXTPChartRadarAxisYView
  • CreateContainer() : CXTPDockingPaneBase, CXTPDockingPaneMiniWnd, CXTPDockingPaneTabbedContainer
  • CreateContext() : CXTPActiveScriptEngine
  • CreateContextWindow() : CXTPDockingPaneContext
  • CreateControl() : IXTPScrollable
  • CreateControlCustom() : CXTPControlCustom
  • CreateControlPopup() : CXTPControlPopup
  • CreateDataProvider() : CXTPCalendarControl, CXTPCalendarData
  • CreateDeviceComand() : CXTPChartContent
  • CreateDeviceCommand() : CXTPChart3dDiagramView, CXTPChart3dFunnelSeriesLabelsView, CXTPChart3dFunnelSeriesLabelView, CXTPChart3dFunnelSeriesPointView, CXTPChart3dFunnelSeriesView, CXTPChart3dPieSeriesLabelsView, CXTPChart3dPieSeriesLabelView, CXTPChart3dPieSeriesPointView, CXTPChart3dPieSeriesView, CXTPChart3dPyramidSeriesLabelsView, CXTPChart3dPyramidSeriesLabelView, CXTPChart3dPyramidSeriesPointView, CXTPChart3dPyramidSeriesView, CXTPChartAreaSeriesView, CXTPChartBarSeriesLabelView, CXTPChartBarSeriesPointView, CXTPChartBorder, CXTPChartBubbleSeriesLabelView, CXTPChartBubbleSeriesPointView, CXTPChartBubbleSeriesView, CXTPChartCandleStickSeriesPointView, CXTPChartContentView, CXTPChartDiagram2DAxisView, CXTPChartDiagram2DSeriesLabelView, CXTPChartDiagram2DView, CXTPChartDiagramView, CXTPChartElementView, CXTPChartFastLineSeriesView, CXTPChartFillStyle, CXTPChartFunnelSeriesLabelView, CXTPChartFunnelSeriesLabelViewBase, CXTPChartFunnelSeriesPointView, CXTPChartFunnelSeriesPointViewBase, CXTPChartFunnelSeriesView, CXTPChartFunnelSeriesViewBase, CXTPChartHighLowSeriesPointView, CXTPChartLegendView, CXTPChartLineSeriesView, CXTPChartLineStyle, CXTPChartMarker, CXTPChartPieSeriesLabelsView, CXTPChartPieSeriesLabelsViewBase, CXTPChartPieSeriesLabelView, CXTPChartPieSeriesLabelViewBase, CXTPChartPieSeriesPointView, CXTPChartPieSeriesPointViewBase, CXTPChartPieSeriesView, CXTPChartPieSeriesViewBase, CXTPChartPointSeriesPointView, CXTPChartPyramidSeriesLabelView, CXTPChartPyramidSeriesLabelViewBase, CXTPChartPyramidSeriesPointView, CXTPChartPyramidSeriesPointViewBase, CXTPChartPyramidSeriesView, CXTPChartPyramidSeriesViewBase, CXTPChartRadarAreaSeriesView, CXTPChartRadarAxisXView, CXTPChartRadarAxisYView, CXTPChartRadarDiagramView, CXTPChartRadarLineSeriesView, CXTPChartRadarPointSeriesLabelView, CXTPChartRadarPointSeriesPointView, CXTPChartRadarSplineAreaSeriesView, CXTPChartRadarSplineSeriesView, CXTPChartRangeAreaSeriesLabelView, CXTPChartRangeBarSeriesLabelView, CXTPChartRangeBarSeriesPointView, CXTPChartRangeSplineAreaSeriesPointView, CXTPChartRangeSplineAreaSeriesView, CXTPChartRotatedTextPainterBase, CXTPChartSplineAreaSeriesView, CXTPChartSplineSeriesView, CXTPChartStackedAreaSeriesView, CXTPChartStackedBarSeriesPointView, CXTPChartStackedSplineAreaSeriesView, CXTPChartStepAreaSeriesView, CXTPChartStepLineSeriesView, CXTPChartTextPainter
  • CreateDeviceContext() : CXTPChartContent
  • CreateDiagram() : CXTPChart3dFunnelSeriesStyle, CXTPChart3dPieSeriesStyle, CXTPChart3dPyramidSeriesStyle, CXTPChartDiagram2DSeriesStyle, CXTPChartFunnelSeriesStyle, CXTPChartFunnelSeriesStyleBase, CXTPChartPieSeriesStyle, CXTPChartPieSeriesStyleBase, CXTPChartPyramidSeriesStyle, CXTPChartPyramidSeriesStyleBase, CXTPChartRadarDiagramSeriesStyle, CXTPChartSeriesStyle
  • CreateDiagramDomain() : CXTPChartFunnelSeriesViewBase, CXTPChartPieSeriesViewBase, CXTPChartPyramidSeriesViewBase
  • CreateDIBPatternBrush() : CXTPBrush
  • CreateDisabledIcon() : CXTPImageManagerIcon
  • CreateDrawContext() : CXTPFlowGraphControl
  • CreateEdit() : CXTPCommandBarEditCtrl
  • CreateEditControl() : CXTPControlComboBox, CXTPControlEdit, CXTPEditListBox
  • CreateEditGroup() : CXTPEditListBox
  • CreateEmptyRecord() : CXTPGridDataManager
  • CreateEx() : CXTPGaugeCtrl, CXTPPreviewCtrl, CXTPScrollable< Base >, CXTPStatusBar, CXTPWebBrowserCtrl
  • CreateExtendedButtons() : CXTPColorSelectorCtrlTheme, CXTPColorSelectorCtrlThemeOffice2013
  • CreateFont() : CXTPFont, CXTPHyperLink
  • CreateFontIndirect() : CXTPFont, CXTPSyntaxEditPaintManager
  • CreateFonts() : CXTPFontManager
  • CreateFromMenu() : CXTPControlActions
  • CreateFromOleData() : CXTPTaskPanelItem
  • CreateFromOleFile() : CXTPTaskPanelItem
  • CreateFromResource() : CXTPTaskDialog
  • CreateFromResourceParam() : CXTPTaskDialog
  • CreateGradientCircle() : CXTPCommandBarsOffice2003Theme
  • CreateGridLinesDeviceCommand() : CXTPChartDiagram2DAxisView, CXTPChartRadarAxisXView, CXTPChartRadarAxisYView
  • CreateGridView() : CXTPPropertyGrid
  • CreateGripperBitmaps() : CXTPTaskPanelPaintManager
  • CreateGripperIcon() : CXTPTaskPanelPaintManager
  • CreateGroup() : CXTPCalendarViewDay, CXTPCalendarViewDayT< _TView, _TViewGroup, XTP_CALENDAR_HITTESTINFO, _TPThis >
  • CreateGroupRow() : CXTPGridControl
  • CreateHatchBrush() : CXTPBrush
  • CreateHeaderFooterRow() : CXTPGridControl
  • CreateIcon() : CXTPImageManagerResource
  • CreateIconColumn() : CXTPGridControl
  • CreateIconFromResource() : CXTPImageManagerIconHandle, CXTPResourceManager
  • CreateIndexer() : CXTPTabManager::CRowIndexer
  • CreateInnerBorderDeviceCommand() : CXTPChartBorder
  • CreateInsertText() : CXTPSyntaxEditCtrl
  • CreateInterlacedDeviceCommand() : CXTPChartDiagram2DAxisView, CXTPChartRadarAxisXView, CXTPChartRadarAxisYView
  • CreateItems() : CXTPControlGalleryItems
  • CreateKeyboardTips() : CXTPCommandBar, CXTPCommandBars, CXTPRibbonTabPopupToolBar
  • CreateLabelsDeviceCommand() : CXTPChartDiagram2DAxisView, CXTPChartRadarAxisXView, CXTPChartRadarAxisYView
  • CreateLayout() : CXTPDockingPaneManager
  • CreateLegendDeviceCommand() : CXTPChart3dFunnelSeriesPointView, CXTPChart3dFunnelSeriesView, CXTPChart3dPieSeriesPointView, CXTPChart3dPieSeriesView, CXTPChart3dPyramidSeriesPointView, CXTPChart3dPyramidSeriesView, CXTPChartAreaSeriesView, CXTPChartAxisConstantLine, CXTPChartAxisStrip, CXTPChartBarSeriesPointView, CXTPChartBarSeriesView, CXTPChartCandleStickSeriesView, CXTPChartFastLineSeriesView, CXTPChartFunnelSeriesPointViewBase, CXTPChartFunnelSeriesView, CXTPChartFunnelSeriesViewBase, CXTPChartHighLowSeriesView, CXTPChartLegendItemView, CXTPChartLineSeriesView, CXTPChartPieSeriesPointView, CXTPChartPieSeriesPointViewBase, CXTPChartPieSeriesView, CXTPChartPieSeriesViewBase, CXTPChartPointSeriesPointView, CXTPChartPointSeriesView, CXTPChartPyramidSeriesPointViewBase, CXTPChartPyramidSeriesView, CXTPChartPyramidSeriesViewBase, CXTPChartRadarAreaSeriesView, CXTPChartRadarLineSeriesView, CXTPChartRadarPointSeriesPointView, CXTPChartRadarPointSeriesView, CXTPChartSeriesPointView, CXTPChartStepLineSeriesPointView, CXTPChartStepLineSeriesView
  • CreateListBox() : CXTPControlComboBoxList, CXTPControlFontComboBoxList
  • CreateMarkupContext() : CXTPImageManagerIcon
  • CreateMarkupHandle() : CXTPImageManagerVectorImageHandle
  • CreateMinimizeWnd() : CXTPTrayIcon
  • CreateMiniToolBar() : CXTPMiniToolBar
  • CreateMonthArray() : CXTPDatePickerControl
  • CreateMoreButton() : CXTPColorSelectorCtrlTheme, CXTPColorSelectorCtrlThemeOffice2013
  • CreateNewEvent() : CXTPCalendarData
  • CreateNewHorizontalGroup() : CXTPTabClientWnd
  • CreateNewRecurrencePattern() : CXTPCalendarData
  • CreateNewSticker() : CXTPDockingPaneContext
  • CreateNewVerticalGroup() : CXTPTabClientWnd
  • CreateOriginalControls() : CXTPControls
  • CreatePage() : CXTPPropertySheet
  • CreatePane() : CXTPDockingPaneManager
  • CreatePatternBrush() : CXTPBrush
  • CreatePen() : CXTPPen
  • CreatePenIndirect() : CXTPPen
  • CreatePidl() : CXTPShellPidl
  • CreatePieDeviceCommand() : CXTPChart3dPie, CXTPChartPie, CXTPChartPieBase
  • CreatePointFont() : CXTPFont
  • CreatePointFontIndirect() : CXTPFont
  • CreatePointsView() : CXTPChartBubbleSeriesView, CXTPChartFastLineSeriesView
  • CreatePopupBar() : CXTPPopupBar
  • CreatePopupToolBar() : CXTPPopupToolBar
  • CreatePreview() : IXTPPreviewProvider
  • CreateProc : CXTPThreadLocal< T >
  • CreateRecentColorButtons() : CXTPColorSelectorCtrlTheme, CXTPColorSelectorCtrlThemeOffice2013
  • CreateRow() : CXTPGridControl
  • CreateSafeFontIndirect() : CXTPSyntaxEditPropertiesPageFont
  • CreateSchema() : CXTPSkinManager, CXTPSkinManagerResourceFile
  • CreateScrollBarCtrl() : CXTPScrollBarContainer< Parent >
  • CreateSection() : CXTPPropExchangeXMLNode
  • CreateSeriesPointView() : CXTPChart3dFunnelSeriesView, CXTPChart3dPieSeriesView, CXTPChart3dPyramidSeriesView, CXTPChartAreaSeriesView, CXTPChartBarSeriesView, CXTPChartBubbleSeriesView, CXTPChartCandleStickSeriesView, CXTPChartFastLineSeriesView, CXTPChartFunnelSeriesView, CXTPChartFunnelSeriesViewBase, CXTPChartGanttSeriesView, CXTPChartHighLowSeriesView, CXTPChartLineSeriesView, CXTPChartPieSeriesView, CXTPChartPieSeriesViewBase, CXTPChartPointSeriesView, CXTPChartPyramidSeriesView, CXTPChartPyramidSeriesViewBase, CXTPChartRadarAreaSeriesView, CXTPChartRadarLineSeriesView, CXTPChartRadarPointSeriesView, CXTPChartRadarSplineAreaSeriesView, CXTPChartRadarSplineSeriesView, CXTPChartRangeBarSeriesView, CXTPChartSplineAreaSeriesView, CXTPChartSplineSeriesView, CXTPChartStackedAreaSeriesView, CXTPChartStackedBarSeriesView, CXTPChartStepLineSeriesView
  • CreateShadow() : CXTPFramePaintManager, CXTPTipWindow
  • CreateSnapshot() : CXTPToolhelpApi
  • CreateSolidBrush() : CXTPBrush
  • CreateSolidRectArray() : CXTPSkinImage
  • CreateSplineDeviceCommand() : CXTPChartFillStyle, CXTPChartLineStyle
  • CreateStockObject() : CXTPGdiObject
  • CreateStretchedPathData() : CXTPFlowGraphNodeCustom
  • CreateStripsDeviceCommand() : CXTPChartDiagram2DAxisView, CXTPChartRadarAxisXView, CXTPChartRadarAxisYView
  • CreateSvgHandle() : CXTPImageManagerVectorImageHandle
  • CreateSysColorBrush() : CXTPBrush
  • CreateSysFont() : CXTPAuxData
  • CreateTabControlBrush() : CXTPSkinManagerMetrics
  • CreateTabPaintManager() : CXTPRibbonPaintManager
  • CreateTabPopupToolBar() : CXTPRibbonBar
  • CreateTabView() : CXTPTabExBase
  • CreateTheme() : CXTPPaintManager
  • CreateThemeButtons() : CXTPColorSelectorCtrlTheme, CXTPColorSelectorCtrlThemeOffice2013
  • CreateTickMarks() : CXTPChartDiagram2DAxisView, CXTPChartRadarAxisXView, CXTPChartRadarAxisYView
  • CreateTickMarksDeviceCommand() : CXTPChartDiagram2DAxisView, CXTPChartRadarAxisXView, CXTPChartRadarAxisYView
  • CreateTitleDeviceCommand() : CXTPChartDiagram2DAxisView, CXTPChartRadarAxisYView
  • CreateToolBar() : CXTPToolBar
  • CreateToolbar() : CXTPPropertyGrid
  • CreateToolbarMenu() : CXTPControlToolbars
  • CreateToolTip() : CXTPToolTipContext
  • CreateTranspositionDeviceCommand() : CXTPChart3dFunnelSeriesLabelView, CXTPChart3dPieSeriesLabelView, CXTPChart3dPyramidSeriesLabelView
  • CreateUIFont() : CXTPFontCtrlBase
  • CreateView() : CXTPChart3dFunnelDiagram, CXTPChart3dFunnelSeriesLabel, CXTPChart3dFunnelSeriesStyle, CXTPChart3dPieDiagram, CXTPChart3dPieSeriesLabel, CXTPChart3dPieSeriesStyle, CXTPChart3dPyramidDiagram, CXTPChart3dPyramidSeriesLabel, CXTPChart3dPyramidSeriesStyle, CXTPChartAreaSeriesStyle, CXTPChartAxis, CXTPChartAxisX, CXTPChartAxisY, CXTPChartBarSeriesLabel, CXTPChartBarSeriesStyle, CXTPChartBubbleSeriesLabel, CXTPChartBubbleSeriesStyle, CXTPChartCandleStickSeriesStyle, CXTPChartContent, CXTPChartContentView, CXTPChartDiagram2D, CXTPChartDiagram2DAxisView, CXTPChartDiagram2DView, CXTPChartDiagram, CXTPChartDiagramView, CXTPChartFastLineSeriesStyle, CXTPChartFunnelDiagram, CXTPChartFunnelDiagramBase< BaseDiagram >, CXTPChartFunnelSeriesLabel, CXTPChartFunnelSeriesLabelBase, CXTPChartFunnelSeriesStyle, CXTPChartFunnelSeriesStyleBase, CXTPChartGanttSeriesStyle, CXTPChartHighLowSeriesStyle, CXTPChartLegend, CXTPChartLineSeriesStyle, CXTPChartPieDiagram, CXTPChartPieDiagramBase< BaseDiagram >, CXTPChartPieSeriesLabel, CXTPChartPieSeriesLabelBase, CXTPChartPieSeriesStyle, CXTPChartPieSeriesStyleBase, CXTPChartPointSeriesLabel, CXTPChartPointSeriesStyle, CXTPChartPyramidDiagram, CXTPChartPyramidDiagramBase< BaseDiagram >, CXTPChartPyramidSeriesLabel, CXTPChartPyramidSeriesLabelBase, CXTPChartPyramidSeriesStyle, CXTPChartPyramidSeriesStyleBase, CXTPChartRadarAreaSeriesStyle, CXTPChartRadarAxisX, CXTPChartRadarAxisXView, CXTPChartRadarAxisY, CXTPChartRadarAxisYView, CXTPChartRadarDiagram, CXTPChartRadarDiagramView, CXTPChartRadarLineSeriesStyle, CXTPChartRadarPointSeriesStyle, CXTPChartRadarSplineAreaSeriesStyle, CXTPChartRadarSplineSeriesStyle, CXTPChartRangeAreaSeriesLabel, CXTPChartRangeBarSeriesLabel, CXTPChartRangeBarSeriesStyle, CXTPChartRangeSplineAreaSeriesStyle, CXTPChartScatterLineSeriesStyle, CXTPChartSeriesStyle, CXTPChartSplineAreaSeriesStyle, CXTPChartSplineSeriesStyle, CXTPChartStackedAreaSeriesStyle, CXTPChartStackedBarSeriesStyle, CXTPChartStackedSplineAreaSeriesStyle, CXTPChartStepAreaSeriesStyle, CXTPChartStepLineSeriesStyle, CXTPPropertyGrid
  • CreateWnd() : CXTPCalendarMsgNotifier
  • CreateWorkspace() : CXTPTabClientWnd
  • Creator : CXTPSingletonPointer
  • CRepositionContext() : CXTPTaskPanel::CRepositionContext
  • CResizeItemArray : CXTPResize
  • CRgnCell() : CXTPColorHex::CRgnCell
  • CRgnCellList : CXTPColorHex
  • crHiliteBack : XTP_EDIT_COLORVALUES
  • crHiliteText : XTP_EDIT_COLORVALUES
  • crInactiveHiliteBack : XTP_EDIT_COLORVALUES
  • crInactiveHiliteText : XTP_EDIT_COLORVALUES
  • crLineNumberBack : XTP_EDIT_COLORVALUES
  • crLineNumberText : XTP_EDIT_COLORVALUES
  • CRowColorList : CXTPListBase
  • CRowIndexer() : CXTPTabManager::CRowIndexer
  • crReadOnlyBack : XTP_EDIT_COLORVALUES
  • crTabBack : CXTPTcbItem
  • crTabSelBack : CXTPTcbItem
  • crTabSelText : CXTPTcbItem
  • crTabText : CXTPTcbItem
  • crText : CXTPListBase::ROWCOLOR, XTP_EDIT_COLORVALUES
  • CSelectionChanged_ContextData() : CXTPCalendarView::CSelectionChanged_ContextData
  • CSelectionChangedContext() : CXTPCalendarView::CSelectionChangedContext
  • CSharedLock() : CXTPRWCriticalSection::CSharedLock
  • CShellMalloc() : CXTPShellPidl::CShellMalloc
  • CShellSpecialFolder() : CXTPShellPidl::CShellSpecialFolder
  • CStringPtrArray() : CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager::CStringPtrArray
  • CThemeStaticExtension() : CXTPRibbonOffice2013Theme::CThemeStaticExtension
  • CtlColor() : CXTPEditTheme, CXTPEditThemeDefault
  • CToolBarArray : CXTPDockBar
  • CUpdateContext() : CXTPCalendarControl::CUpdateContext, CXTPGridControl::CUpdateContext
  • CursorInWindow() : CXTPMiniToolBar
  • CustomizeStartDrag() : CXTPControl
  • CustomizeStartResize() : CXTPControl
  • Cut() : CXTPCalendarView, CXTPFlowGraphPage, CXTPGridControl, CXTPSyntaxEditCtrl
  • CViewChanged_ContextData() : CXTPCalendarControl::CViewChanged_ContextData
  • CViewChangedContext() : CXTPCalendarControl::CViewChangedContext
  • cxHThumb : CXTPAuxData
  • cxSize : CXTPAuxData
  • cxSmIcon : CXTPAuxData
  • CXTPActiveScriptEngine() : CXTPActiveScriptEngine
  • CXTPActiveScriptStdRuntime() : CXTPActiveScriptStdRuntime
  • CXTPAlphaWnd() : CXTPAlphaWnd
  • CXTPAnimationDC() : CXTPAnimationDC
  • CXTPArcBall() : CXTPArcBall
  • CXTPArrayT() : CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE >
  • CXTPAsyncGuard() : CXTPAsyncGuard< Adaptee, RWLock >
  • CXTPAutoResetValue() : CXTPAutoResetValue< _TValue >
  • CXTPBrowseButton() : CXTPBrowseButton
  • CXTPBrowseDialog() : CXTPBrowseDialog
  • CXTPBrowseEdit() : CXTPBrowseEdit
  • CXTPBrush() : CXTPBrush
  • CXTPButton() : CXTPButton
  • CXTPButtonTheme() : CXTPButtonTheme
  • CXTPButtonThemeFlat() : CXTPButtonThemeFlat
  • CXTPButtonThemeNativeWindows10() : CXTPButtonThemeNativeWindows10
  • CXTPButtonThemeNativeWindows11() : CXTPButtonThemeNativeWindows11
  • CXTPButtonThemeOffice2000() : CXTPButtonThemeOffice2000
  • CXTPButtonThemeOffice2003() : CXTPButtonThemeOffice2003
  • CXTPButtonThemeOfficeXP() : CXTPButtonThemeOfficeXP
  • CXTPButtonThemeResource() : CXTPButtonThemeResource
  • CXTPButtonThemeUltraFlat() : CXTPButtonThemeUltraFlat
  • CXTPButtonThemeVisualStudio2012() : CXTPButtonThemeVisualStudio2012
  • CXTPButtonThemeVisualStudio2015() : CXTPButtonThemeVisualStudio2015
  • CXTPButtonThemeVisualStudio2017() : CXTPButtonThemeVisualStudio2017
  • CXTPButtonThemeVisualStudio2019() : CXTPButtonThemeVisualStudio2019
  • CXTPButtonThemeVisualStudio2022() : CXTPButtonThemeVisualStudio2022
  • CXTPCalendarCaptionBarControl() : CXTPCalendarCaptionBarControl
  • CXTPCalendarCaptionBarNativeWindows10Theme() : CXTPCalendarCaptionBarNativeWindows10Theme
  • CXTPCalendarCaptionBarNativeWindows11Theme() : CXTPCalendarCaptionBarNativeWindows11Theme
  • CXTPCalendarCaptionBarOffice2000Theme() : CXTPCalendarCaptionBarOffice2000Theme
  • CXTPCalendarCaptionBarOffice2003Theme() : CXTPCalendarCaptionBarOffice2003Theme
  • CXTPCalendarCaptionBarOffice2013Theme() : CXTPCalendarCaptionBarOffice2013Theme
  • CXTPCalendarCaptionBarOfficeXPTheme() : CXTPCalendarCaptionBarOfficeXPTheme
  • CXTPCalendarCaptionBarPaintManager() : CXTPCalendarCaptionBarPaintManager
  • CXTPCalendarCaptionBarResourceTheme() : CXTPCalendarCaptionBarResourceTheme
  • CXTPCalendarCaptionBarTheme() : CXTPCalendarCaptionBarTheme
  • CXTPCalendarCaptionBarThemePart() : CXTPCalendarCaptionBarThemePart
  • CXTPCalendarCaptionBarVisualStudio2015Theme() : CXTPCalendarCaptionBarVisualStudio2015Theme
  • CXTPCalendarCaptionBarVisualStudio2017Theme() : CXTPCalendarCaptionBarVisualStudio2017Theme
  • CXTPCalendarCaptionBarVisualStudio2019Theme() : CXTPCalendarCaptionBarVisualStudio2019Theme
  • CXTPCalendarCaptionBarVisualStudio2022Theme() : CXTPCalendarCaptionBarVisualStudio2022Theme
  • CXTPCalendarComboBoxBase() : CXTPCalendarComboBoxBase
  • CXTPCalendarControl() : CXTPCalendarControl
  • CXTPCalendarController() : CXTPCalendarController
  • CXTPCalendarControlView() : CXTPCalendarControlView
  • CXTPCalendarControlViewPrintOptions() : CXTPCalendarControlViewPrintOptions
  • CXTPCalendarCustomDataProvider() : CXTPCalendarCustomDataProvider
  • CXTPCalendarCustomProperties() : CXTPCalendarCustomProperties
  • CXTPCalendarData() : CXTPCalendarData
  • CXTPCalendarDatabaseDataProvider() : CXTPCalendarDatabaseDataProvider
  • CXTPCalendarDayView() : CXTPCalendarDayView
  • CXTPCalendarDayViewDay() : CXTPCalendarDayViewDay
  • CXTPCalendarDayViewEvent() : CXTPCalendarDayViewEvent
  • CXTPCalendarDayViewGroup() : CXTPCalendarDayViewGroup
  • CXTPCalendarDayViewTimeScale() : CXTPCalendarDayViewTimeScale
  • CXTPCalendarEvent() : CXTPCalendarEvent
  • CXTPCalendarEventCategories() : CXTPCalendarEventCategories
  • CXTPCalendarEventCategory() : CXTPCalendarEventCategory
  • CXTPCalendarEventCategoryComboBox() : CXTPCalendarEventCategoryComboBox
  • CXTPCalendarEventCategoryIDs() : CXTPCalendarEventCategoryIDs
  • CXTPCalendarEventColorDlg() : CXTPCalendarEventColorDlg
  • CXTPCalendarEventColorEdit() : CXTPCalendarEventColorEdit
  • CXTPCalendarEventColorListBox() : CXTPCalendarEventColorListBox
  • CXTPCalendarEventColorNewDlg() : CXTPCalendarEventColorNewDlg
  • CXTPCalendarEventLabel() : CXTPCalendarEventLabel
  • CXTPCalendarEventLabels() : CXTPCalendarEventLabels
  • CXTPCalendarEventPropertiesDlg() : CXTPCalendarEventPropertiesDlg
  • CXTPCalendarEventRecurrenceDlg() : CXTPCalendarEventRecurrenceDlg
  • CXTPCalendarEvents() : CXTPCalendarEvents
  • CXTPCalendarIconIDs() : CXTPCalendarIconIDs
  • CXTPCalendarMemoryDataProvider() : CXTPCalendarMemoryDataProvider
  • CXTPCalendarMonthView() : CXTPCalendarMonthView
  • CXTPCalendarMonthViewDay() : CXTPCalendarMonthViewDay
  • CXTPCalendarMonthViewEvent() : CXTPCalendarMonthViewEvent
  • CXTPCalendarMonthViewGroup() : CXTPCalendarMonthViewGroup
  • CXTPCalendarMsgNotifier() : CXTPCalendarMsgNotifier
  • CXTPCalendarNativeWindows10Theme() : CXTPCalendarNativeWindows10Theme
  • CXTPCalendarNativeWindows11Theme() : CXTPCalendarNativeWindows11Theme
  • CXTPCalendarOccurSeriesChooseDlg() : CXTPCalendarOccurSeriesChooseDlg
  • CXTPCalendarOffice2000Theme() : CXTPCalendarOffice2000Theme
  • CXTPCalendarOffice2003Theme() : CXTPCalendarOffice2003Theme
  • CXTPCalendarOffice2013Theme() : CXTPCalendarOffice2013Theme
  • CXTPCalendarOfficeXPTheme() : CXTPCalendarOfficeXPTheme
  • CXTPCalendarOptions() : CXTPCalendarOptions
  • CXTPCalendarPageSetupDialog() : CXTPCalendarPageSetupDialog
  • CXTPCalendarPaintManager() : CXTPCalendarPaintManager
  • CXTPCalendarPtrCollectionT() : CXTPCalendarPtrCollectionT< _TObject >
  • CXTPCalendarRecurrencePattern() : CXTPCalendarRecurrencePattern
  • CXTPCalendarReminder() : CXTPCalendarReminder
  • CXTPCalendarReminderForOccurrenceArray() : CXTPCalendarReminderForOccurrenceArray
  • CXTPCalendarRemindersDialog() : CXTPCalendarRemindersDialog
  • CXTPCalendarRemindersManager() : CXTPCalendarRemindersManager
  • CXTPCalendarResource() : CXTPCalendarResource
  • CXTPCalendarResourceDescription() : CXTPCalendarResourceDescription
  • CXTPCalendarResources() : CXTPCalendarResources
  • CXTPCalendarResourcesManager() : CXTPCalendarResourcesManager
  • CXTPCalendarResourcesNf() : CXTPCalendarResourcesNf
  • CXTPCalendarResourceTheme() : CXTPCalendarResourceTheme
  • CXTPCalendarSchedule() : CXTPCalendarSchedule
  • CXTPCalendarSchedules() : CXTPCalendarSchedules
  • CXTPCalendarShadowDrawer() : CXTPCalendarShadowDrawer
  • CXTPCalendarThemeBOOLValue() : CXTPCalendarThemeBOOLValue
  • CXTPCalendarThemeCustomizableXValueT() : CXTPCalendarThemeCustomizableXValueT< _TValue, _TValueRef >
  • CXTPCalendarThemeFontValue() : CXTPCalendarThemeFontValue
  • CXTPCalendarThemeIntValue() : CXTPCalendarThemeIntValue
  • CXTPCalendarThemeRectValue() : CXTPCalendarThemeRectValue
  • CXTPCalendarThemeStringValue() : CXTPCalendarThemeStringValue
  • CXTPCalendarTimeLineView() : CXTPCalendarTimeLineView
  • CXTPCalendarTimeLineViewEvent() : CXTPCalendarTimeLineViewEvent
  • CXTPCalendarTimeLineViewGroup() : CXTPCalendarTimeLineViewGroup
  • CXTPCalendarTimeLineViewPart() : CXTPCalendarTimeLineViewPart
  • CXTPCalendarTimeLineViewTimeScale() : CXTPCalendarTimeLineViewTimeScale
  • CXTPCalendarTimeLineViewTimeScalePart() : CXTPCalendarTimeLineViewTimeScalePart
  • CXTPCalendarTimeZone() : CXTPCalendarTimeZone
  • CXTPCalendarTimeZones() : CXTPCalendarTimeZones
  • CXTPCalendarTip() : CXTPCalendarTip
  • CXTPCalendarTLV_TimeScaleParams() : CXTPCalendarTLV_TimeScaleParams
  • CXTPCalendarTLV_TimeScaleParams_Day() : CXTPCalendarTLV_TimeScaleParams_Day
  • CXTPCalendarTLV_TimeScaleParams_Month() : CXTPCalendarTLV_TimeScaleParams_Month
  • CXTPCalendarTLV_TimeScaleParams_Week() : CXTPCalendarTLV_TimeScaleParams_Week
  • CXTPCalendarTLV_TimeScaleParams_WorkWeek() : CXTPCalendarTLV_TimeScaleParams_WorkWeek
  • CXTPCalendarTypedPtrAutoDeleteArray() : CXTPCalendarTypedPtrAutoDeleteArray< BASE_CLASS, PTR_TYPE >
  • CXTPCalendarView() : CXTPCalendarView
  • CXTPCalendarViewDay() : CXTPCalendarViewDay
  • CXTPCalendarViewDayT() : CXTPCalendarViewDayT< _TView, _TViewGroup, XTP_CALENDAR_HITTESTINFO, _TPThis >
  • CXTPCalendarViewEvent() : CXTPCalendarViewEvent
  • CXTPCalendarViewEvents() : CXTPCalendarViewEvents
  • CXTPCalendarViewEventSubjectEditor() : CXTPCalendarViewEventSubjectEditor
  • CXTPCalendarViewEventSubjectEditorColored() : CXTPCalendarViewEventSubjectEditorColored
  • CXTPCalendarViewEventT() : CXTPCalendarViewEventT< _TViewGroup >
  • CXTPCalendarViewGroup() : CXTPCalendarViewGroup
  • CXTPCalendarViewGroupT() : CXTPCalendarViewGroupT< _TViewDay, _TViewEvent, _TPThis >
  • CXTPCalendarViewPart() : CXTPCalendarViewPart
  • CXTPCalendarViewPartCustomizableValueT() : CXTPCalendarViewPartCustomizableValueT< _TValue >
  • CXTPCalendarViewPartFontValue() : CXTPCalendarViewPartFontValue
  • CXTPCalendarViewT() : CXTPCalendarViewT< _TViewDay >
  • CXTPCalendarVisualStudio2015Theme() : CXTPCalendarVisualStudio2015Theme
  • CXTPCalendarVisualStudio2017Theme() : CXTPCalendarVisualStudio2017Theme
  • CXTPCalendarVisualStudio2019Theme() : CXTPCalendarVisualStudio2019Theme
  • CXTPCalendarVisualStudio2022Theme() : CXTPCalendarVisualStudio2022Theme
  • CXTPCalendarWeekView() : CXTPCalendarWeekView
  • CXTPCalendarWeekViewDay() : CXTPCalendarWeekViewDay
  • CXTPCalendarWeekViewEvent() : CXTPCalendarWeekViewEvent
  • CXTPCalendarWeekViewGroup() : CXTPCalendarWeekViewGroup
  • CXTPCalendarWMHandler() : CXTPCalendarWMHandler
  • CXTPCaption() : CXTPCaption
  • CXTPCaptionButton() : CXTPCaptionButton
  • CXTPCaptionButtonTheme() : CXTPCaptionButtonTheme
  • CXTPCaptionButtonThemeOfficeXP() : CXTPCaptionButtonThemeOfficeXP
  • CXTPCaptionPopupWnd() : CXTPCaptionPopupWnd
  • CXTPCaptionTheme() : CXTPCaptionTheme
  • CXTPCaptionThemeOffice2003() : CXTPCaptionThemeOffice2003
  • CXTPCaptionThemeOfficeXP() : CXTPCaptionThemeOfficeXP
  • CXTPChart2dDiagram() : CXTPChart2dDiagram
  • CXTPChart3dBox() : CXTPChart3dBox
  • CXTPChart3dDeviceCommand() : CXTPChart3dDeviceCommand
  • CXTPChart3dDeviceContext() : CXTPChart3dDeviceContext
  • CXTPChart3dDiagram() : CXTPChart3dDiagram
  • CXTPChart3dDiagramView() : CXTPChart3dDiagramView
  • CXTPChart3dFunnelDeviceCommandEvents() : CXTPChart3dFunnelDeviceCommandEvents
  • CXTPChart3dFunnelDiagram() : CXTPChart3dFunnelDiagram
  • CXTPChart3dFunnelDiagramView() : CXTPChart3dFunnelDiagramView
  • CXTPChart3dFunnelSeriesLabel() : CXTPChart3dFunnelSeriesLabel
  • CXTPChart3dFunnelSeriesLabelDeviceCommand() : CXTPChart3dFunnelSeriesLabelDeviceCommand
  • CXTPChart3dFunnelSeriesLabelsView() : CXTPChart3dFunnelSeriesLabelsView
  • CXTPChart3dFunnelSeriesLabelsViewDeviceCommand() : CXTPChart3dFunnelSeriesLabelsViewDeviceCommand
  • CXTPChart3dFunnelSeriesLabelView() : CXTPChart3dFunnelSeriesLabelView
  • CXTPChart3dFunnelSeriesPointView() : CXTPChart3dFunnelSeriesPointView
  • CXTPChart3dFunnelSeriesStyle() : CXTPChart3dFunnelSeriesStyle
  • CXTPChart3dFunnelSeriesView() : CXTPChart3dFunnelSeriesView
  • CXTPChart3dLineDeviceCommand() : CXTPChart3dLineDeviceCommand
  • CXTPChart3dPie() : CXTPChart3dPie
  • CXTPChart3dPieDeviceCommand() : CXTPChart3dPieDeviceCommand
  • CXTPChart3dPieDeviceCommandEvents() : CXTPChart3dPieDeviceCommandEvents
  • CXTPChart3dPieDiagram() : CXTPChart3dPieDiagram
  • CXTPChart3dPieDiagramView() : CXTPChart3dPieDiagramView
  • CXTPChart3dPieSeriesLabel() : CXTPChart3dPieSeriesLabel
  • CXTPChart3dPieSeriesLabelDeviceCommand() : CXTPChart3dPieSeriesLabelDeviceCommand
  • CXTPChart3dPieSeriesLabelsView() : CXTPChart3dPieSeriesLabelsView
  • CXTPChart3dPieSeriesLabelsViewDeviceCommand() : CXTPChart3dPieSeriesLabelsViewDeviceCommand
  • CXTPChart3dPieSeriesLabelView() : CXTPChart3dPieSeriesLabelView
  • CXTPChart3dPieSeriesPointView() : CXTPChart3dPieSeriesPointView
  • CXTPChart3dPieSeriesStyle() : CXTPChart3dPieSeriesStyle
  • CXTPChart3dPieSeriesView() : CXTPChart3dPieSeriesView
  • CXTPChart3dPyramidDeviceCommandEvents() : CXTPChart3dPyramidDeviceCommandEvents
  • CXTPChart3dPyramidDiagram() : CXTPChart3dPyramidDiagram
  • CXTPChart3dPyramidDiagramView() : CXTPChart3dPyramidDiagramView
  • CXTPChart3dPyramidSeriesLabel() : CXTPChart3dPyramidSeriesLabel
  • CXTPChart3dPyramidSeriesLabelDeviceCommand() : CXTPChart3dPyramidSeriesLabelDeviceCommand
  • CXTPChart3dPyramidSeriesLabelsView() : CXTPChart3dPyramidSeriesLabelsView
  • CXTPChart3dPyramidSeriesLabelsViewDeviceCommand() : CXTPChart3dPyramidSeriesLabelsViewDeviceCommand
  • CXTPChart3dPyramidSeriesLabelView() : CXTPChart3dPyramidSeriesLabelView
  • CXTPChart3dPyramidSeriesPointView() : CXTPChart3dPyramidSeriesPointView
  • CXTPChart3dPyramidSeriesStyle() : CXTPChart3dPyramidSeriesStyle
  • CXTPChart3dPyramidSeriesView() : CXTPChart3dPyramidSeriesView
  • CXTPChart3dRotateDeviceCommand() : CXTPChart3dRotateDeviceCommand
  • CXTPChart3dRotation() : CXTPChart3dRotation
  • CXTPChart3dTranslateDeviceCommand() : CXTPChart3dTranslateDeviceCommand
  • CXTPChartAppearance() : CXTPChartAppearance
  • CXTPChartAreaSeriesStyle() : CXTPChartAreaSeriesStyle
  • CXTPChartAreaSeriesView() : CXTPChartAreaSeriesView
  • CXTPChartAxis() : CXTPChartAxis
  • CXTPChartAxisAppearance() : CXTPChartAxisAppearance
  • CXTPChartAxisConstantLine() : CXTPChartAxisConstantLine
  • CXTPChartAxisConstantLines() : CXTPChartAxisConstantLines
  • CXTPChartAxisCustomLabel() : CXTPChartAxisCustomLabel
  • CXTPChartAxisCustomLabels() : CXTPChartAxisCustomLabels
  • CXTPChartAxisGridLines() : CXTPChartAxisGridLines
  • CXTPChartAxisLabel() : CXTPChartAxisLabel
  • CXTPChartAxisRange() : CXTPChartAxisRange
  • CXTPChartAxisStrip() : CXTPChartAxisStrip
  • CXTPChartAxisStrips() : CXTPChartAxisStrips
  • CXTPChartAxisTickMarks() : CXTPChartAxisTickMarks
  • CXTPChartAxisTitle() : CXTPChartAxisTitle
  • CXTPChartAxisX() : CXTPChartAxisX
  • CXTPChartAxisY() : CXTPChartAxisY
  • CXTPChartBarSeriesErrorBarView() : CXTPChartBarSeriesErrorBarView
  • CXTPChartBarSeriesLabel() : CXTPChartBarSeriesLabel
  • CXTPChartBarSeriesLabelView() : CXTPChartBarSeriesLabelView
  • CXTPChartBarSeriesPointView() : CXTPChartBarSeriesPointView
  • CXTPChartBarSeriesStyle() : CXTPChartBarSeriesStyle
  • CXTPChartBarSeriesView() : CXTPChartBarSeriesView
  • CXTPChartBorder() : CXTPChartBorder
  • CXTPChartBoundedCircleDeviceCommand() : CXTPChartBoundedCircleDeviceCommand
  • CXTPChartBoundedPolygonDeviceCommand() : CXTPChartBoundedPolygonDeviceCommand
  • CXTPChartBoundedTextDeviceCommand() : CXTPChartBoundedTextDeviceCommand
  • CXTPChartBubbleSeriesLabel() : CXTPChartBubbleSeriesLabel
  • CXTPChartBubbleSeriesLabelView() : CXTPChartBubbleSeriesLabelView
  • CXTPChartBubbleSeriesPointView() : CXTPChartBubbleSeriesPointView
  • CXTPChartBubbleSeriesStyle() : CXTPChartBubbleSeriesStyle
  • CXTPChartBubbleSeriesView() : CXTPChartBubbleSeriesView
  • CXTPChartCandleStickSeriesPointView() : CXTPChartCandleStickSeriesPointView
  • CXTPChartCandleStickSeriesStyle() : CXTPChartCandleStickSeriesStyle
  • CXTPChartCandleStickSeriesView() : CXTPChartCandleStickSeriesView
  • CXTPChartCircleDeviceCommand() : CXTPChartCircleDeviceCommand
  • CXTPChartClipDeviceCommand() : CXTPChartClipDeviceCommand
  • CXTPChartColor() : CXTPChartColor
  • CXTPChartContainer() : CXTPChartContainer
  • CXTPChartContent() : CXTPChartContent
  • CXTPChartContentAppearance() : CXTPChartContentAppearance
  • CXTPChartContentView() : CXTPChartContentView
  • CXTPChartControl() : CXTPChartControl
  • CXTPChartDeviceCommand() : CXTPChartDeviceCommand
  • CXTPChartDeviceCommandEvents() : CXTPChartDeviceCommandEvents
  • CXTPChartDeviceContext() : CXTPChartDeviceContext
  • CXTPChartDiagram() : CXTPChartDiagram
  • CXTPChartDiagram2D() : CXTPChartDiagram2D
  • CXTPChartDiagram2DAppearance() : CXTPChartDiagram2DAppearance
  • CXTPChartDiagram2DAxisView() : CXTPChartDiagram2DAxisView
  • CXTPChartDiagram2DSeriesLabel() : CXTPChartDiagram2DSeriesLabel
  • CXTPChartDiagram2DSeriesLabelView() : CXTPChartDiagram2DSeriesLabelView
  • CXTPChartDiagram2DSeriesStyle() : CXTPChartDiagram2DSeriesStyle
  • CXTPChartDiagram2DView() : CXTPChartDiagram2DView
  • CXTPChartDiagram3DAppearance() : CXTPChartDiagram3DAppearance
  • CXTPChartDiagramDomain() : CXTPChartDiagramDomain
  • CXTPChartDiagramView() : CXTPChartDiagramView
  • CXTPChartElement() : CXTPChartElement
  • CXTPChartElementAppearance() : CXTPChartElementAppearance
  • CXTPChartElementCollection() : CXTPChartElementCollection
  • CXTPChartElementView() : CXTPChartElementView
  • CXTPChartEllipse() : CXTPChartEllipse
  • CXTPChartFastLineSeriesStyle() : CXTPChartFastLineSeriesStyle
  • CXTPChartFastLineSeriesView() : CXTPChartFastLineSeriesView
  • CXTPChartFillStyle() : CXTPChartFillStyle
  • CXTPChartFinanceStyleAppearance() : CXTPChartFinanceStyleAppearance
  • CXTPChartFont() : CXTPChartFont
  • CXTPChartFunnelDiagram() : CXTPChartFunnelDiagram
  • CXTPChartFunnelDiagramBase() : CXTPChartFunnelDiagramBase< BaseDiagram >
  • CXTPChartFunnelDiagramView() : CXTPChartFunnelDiagramView
  • CXTPChartFunnelSeriesLabel() : CXTPChartFunnelSeriesLabel
  • CXTPChartFunnelSeriesLabelBase() : CXTPChartFunnelSeriesLabelBase
  • CXTPChartFunnelSeriesLabelView() : CXTPChartFunnelSeriesLabelView
  • CXTPChartFunnelSeriesLabelViewBase() : CXTPChartFunnelSeriesLabelViewBase
  • CXTPChartFunnelSeriesPointView() : CXTPChartFunnelSeriesPointView
  • CXTPChartFunnelSeriesPointViewBase() : CXTPChartFunnelSeriesPointViewBase
  • CXTPChartFunnelSeriesStyle() : CXTPChartFunnelSeriesStyle
  • CXTPChartFunnelSeriesStyleBase() : CXTPChartFunnelSeriesStyleBase
  • CXTPChartFunnelSeriesView() : CXTPChartFunnelSeriesView
  • CXTPChartFunnelSeriesViewBase() : CXTPChartFunnelSeriesViewBase
  • CXTPChartGanttSeriesPointView() : CXTPChartGanttSeriesPointView
  • CXTPChartGanttSeriesStyle() : CXTPChartGanttSeriesStyle
  • CXTPChartGanttSeriesView() : CXTPChartGanttSeriesView
  • CXTPChartHighLowSeriesPointView() : CXTPChartHighLowSeriesPointView
  • CXTPChartHighLowSeriesStyle() : CXTPChartHighLowSeriesStyle
  • CXTPChartHighLowSeriesView() : CXTPChartHighLowSeriesView
  • CXTPChartHitTestElementCommand() : CXTPChartHitTestElementCommand
  • CXTPChartLegend() : CXTPChartLegend
  • CXTPChartLegendAppearance() : CXTPChartLegendAppearance
  • CXTPChartLegendView() : CXTPChartLegendView
  • CXTPChartLineDeviceCommand() : CXTPChartLineDeviceCommand
  • CXTPChartLineSeriesErrorBarView() : CXTPChartLineSeriesErrorBarView
  • CXTPChartLineSeriesStyle() : CXTPChartLineSeriesStyle
  • CXTPChartLineSeriesView() : CXTPChartLineSeriesView
  • CXTPChartLineStyle() : CXTPChartLineStyle
  • CXTPChartMarker() : CXTPChartMarker
  • CXTPChartMarkupElementDeviceCommand() : CXTPChartMarkupElementDeviceCommand
  • CXTPChartNumberFormat() : CXTPChartNumberFormat
  • CXTPChartNumericalScaleTypeMap() : CXTPChartNumericalScaleTypeMap
  • CXTPChartObject() : CXTPChartObject
  • CXTPChartPalette() : CXTPChartPalette
  • CXTPChartPanel() : CXTPChartPanel
  • CXTPChartPanelCollection() : CXTPChartPanelCollection
  • CXTPChartPie() : CXTPChartPie
  • CXTPChartPieBase() : CXTPChartPieBase
  • CXTPChartPieDeviceCommand() : CXTPChartPieDeviceCommand
  • CXTPChartPieDiagram() : CXTPChartPieDiagram
  • CXTPChartPieDiagramBase() : CXTPChartPieDiagramBase< BaseDiagram >
  • CXTPChartPieDiagramView() : CXTPChartPieDiagramView
  • CXTPChartPieSeriesLabel() : CXTPChartPieSeriesLabel
  • CXTPChartPieSeriesLabelBase() : CXTPChartPieSeriesLabelBase
  • CXTPChartPieSeriesLabelsView() : CXTPChartPieSeriesLabelsView
  • CXTPChartPieSeriesLabelsViewBase() : CXTPChartPieSeriesLabelsViewBase
  • CXTPChartPieSeriesLabelView() : CXTPChartPieSeriesLabelView
  • CXTPChartPieSeriesLabelViewBase() : CXTPChartPieSeriesLabelViewBase
  • CXTPChartPieSeriesPointView() : CXTPChartPieSeriesPointView
  • CXTPChartPieSeriesPointViewBase() : CXTPChartPieSeriesPointViewBase
  • CXTPChartPieSeriesStyle() : CXTPChartPieSeriesStyle
  • CXTPChartPieSeriesStyleBase() : CXTPChartPieSeriesStyleBase
  • CXTPChartPieSeriesView() : CXTPChartPieSeriesView
  • CXTPChartPieSeriesViewBase() : CXTPChartPieSeriesViewBase
  • CXTPChartPieStyleAppearance() : CXTPChartPieStyleAppearance
  • CXTPChartPointSeriesErrorBarView() : CXTPChartPointSeriesErrorBarView
  • CXTPChartPointSeriesLabel() : CXTPChartPointSeriesLabel
  • CXTPChartPointSeriesLabelView() : CXTPChartPointSeriesLabelView
  • CXTPChartPointSeriesPointView() : CXTPChartPointSeriesPointView
  • CXTPChartPointSeriesStyle() : CXTPChartPointSeriesStyle
  • CXTPChartPointSeriesView() : CXTPChartPointSeriesView
  • CXTPChartPolygonAntialiasingDeviceCommand() : CXTPChartPolygonAntialiasingDeviceCommand
  • CXTPChartPolygonDeviceCommand() : CXTPChartPolygonDeviceCommand
  • CXTPChartPolylineDeviceCommand() : CXTPChartPolylineDeviceCommand
  • CXTPChartPyramidDiagram() : CXTPChartPyramidDiagram
  • CXTPChartPyramidDiagramBase() : CXTPChartPyramidDiagramBase< BaseDiagram >
  • CXTPChartPyramidDiagramView() : CXTPChartPyramidDiagramView
  • CXTPChartPyramidSeriesLabelBase() : CXTPChartPyramidSeriesLabelBase
  • CXTPChartPyramidSeriesLabelView() : CXTPChartPyramidSeriesLabelView
  • CXTPChartPyramidSeriesLabelViewBase() : CXTPChartPyramidSeriesLabelViewBase
  • CXTPChartPyramidSeriesPointView() : CXTPChartPyramidSeriesPointView
  • CXTPChartPyramidSeriesPointViewBase() : CXTPChartPyramidSeriesPointViewBase
  • CXTPChartPyramidSeriesStyle() : CXTPChartPyramidSeriesStyle
  • CXTPChartPyramidSeriesStyleBase() : CXTPChartPyramidSeriesStyleBase
  • CXTPChartPyramidSeriesView() : CXTPChartPyramidSeriesView
  • CXTPChartPyramidSeriesViewBase() : CXTPChartPyramidSeriesViewBase
  • CXTPChartQualitativeScaleTypeMap() : CXTPChartQualitativeScaleTypeMap
  • CXTPChartRadarAreaSeriesStyle() : CXTPChartRadarAreaSeriesStyle
  • CXTPChartRadarAreaSeriesView() : CXTPChartRadarAreaSeriesView
  • CXTPChartRadarAxisView() : CXTPChartRadarAxisView
  • CXTPChartRadarAxisX() : CXTPChartRadarAxisX
  • CXTPChartRadarAxisXView() : CXTPChartRadarAxisXView
  • CXTPChartRadarAxisY() : CXTPChartRadarAxisY
  • CXTPChartRadarAxisYView() : CXTPChartRadarAxisYView
  • CXTPChartRadarDiagram() : CXTPChartRadarDiagram
  • CXTPChartRadarDiagramSeriesStyle() : CXTPChartRadarDiagramSeriesStyle
  • CXTPChartRadarDiagramView() : CXTPChartRadarDiagramView
  • CXTPChartRadarLineSeriesStyle() : CXTPChartRadarLineSeriesStyle
  • CXTPChartRadarLineSeriesView() : CXTPChartRadarLineSeriesView
  • CXTPChartRadarPointSeriesLabel() : CXTPChartRadarPointSeriesLabel
  • CXTPChartRadarPointSeriesLabelView() : CXTPChartRadarPointSeriesLabelView
  • CXTPChartRadarPointSeriesPointView() : CXTPChartRadarPointSeriesPointView
  • CXTPChartRadarPointSeriesStyle() : CXTPChartRadarPointSeriesStyle
  • CXTPChartRadarPointSeriesView() : CXTPChartRadarPointSeriesView
  • CXTPChartRadarSplineAreaSeriesStyle() : CXTPChartRadarSplineAreaSeriesStyle
  • CXTPChartRadarSplineAreaSeriesView() : CXTPChartRadarSplineAreaSeriesView
  • CXTPChartRadarSplineSeriesStyle() : CXTPChartRadarSplineSeriesStyle
  • CXTPChartRadarSplineSeriesView() : CXTPChartRadarSplineSeriesView
  • CXTPChartRangeAreaSeriesLabel() : CXTPChartRangeAreaSeriesLabel
  • CXTPChartRangeAreaSeriesLabelView() : CXTPChartRangeAreaSeriesLabelView
  • CXTPChartRangeBarSeriesLabel() : CXTPChartRangeBarSeriesLabel
  • CXTPChartRangeBarSeriesLabelView() : CXTPChartRangeBarSeriesLabelView
  • CXTPChartRangeBarSeriesPointView() : CXTPChartRangeBarSeriesPointView
  • CXTPChartRangeBarSeriesStyle() : CXTPChartRangeBarSeriesStyle
  • CXTPChartRangeBarSeriesView() : CXTPChartRangeBarSeriesView
  • CXTPChartRangeSplineAreaSeriesPointView() : CXTPChartRangeSplineAreaSeriesPointView
  • CXTPChartRangeSplineAreaSeriesStyle() : CXTPChartRangeSplineAreaSeriesStyle
  • CXTPChartRangeSplineAreaSeriesView() : CXTPChartRangeSplineAreaSeriesView
  • CXTPChartRectangleDeviceCommand() : CXTPChartRectangleDeviceCommand
  • CXTPChartRotateDeviceCommand() : CXTPChartRotateDeviceCommand
  • CXTPChartRotatedTextPainterBase() : CXTPChartRotatedTextPainterBase
  • CXTPChartRotatedTextPainterNearLine() : CXTPChartRotatedTextPainterNearLine
  • CXTPChartScaleTypeMap() : CXTPChartScaleTypeMap
  • CXTPChartScatterLineSeriesStyle() : CXTPChartScatterLineSeriesStyle
  • CXTPChartSeries() : CXTPChartSeries
  • CXTPChartSeriesCollection() : CXTPChartSeriesCollection
  • CXTPChartSeriesLabel() : CXTPChartSeriesLabel
  • CXTPChartSeriesPoint() : CXTPChartSeriesPoint
  • CXTPChartSeriesPointCollection() : CXTPChartSeriesPointCollection
  • CXTPChartSeriesPointView() : CXTPChartSeriesPointView
  • CXTPChartSeriesStyle() : CXTPChartSeriesStyle
  • CXTPChartSolidSplinePolygonDeviceCommand() : CXTPChartSolidSplinePolygonDeviceCommand
  • CXTPChartSplineAreaSeriesStyle() : CXTPChartSplineAreaSeriesStyle
  • CXTPChartSplineAreaSeriesView() : CXTPChartSplineAreaSeriesView
  • CXTPChartSplineDeviceCommand() : CXTPChartSplineDeviceCommand
  • CXTPChartSplineSeriesStyle() : CXTPChartSplineSeriesStyle
  • CXTPChartSplineSeriesView() : CXTPChartSplineSeriesView
  • CXTPChartStackedAreaSeriesStyle() : CXTPChartStackedAreaSeriesStyle
  • CXTPChartStackedAreaSeriesView() : CXTPChartStackedAreaSeriesView
  • CXTPChartStackedBarSeriesPointView() : CXTPChartStackedBarSeriesPointView
  • CXTPChartStackedBarSeriesStyle() : CXTPChartStackedBarSeriesStyle
  • CXTPChartStackedBarSeriesView() : CXTPChartStackedBarSeriesView
  • CXTPChartStackedSplineAreaSeriesStyle() : CXTPChartStackedSplineAreaSeriesStyle
  • CXTPChartStackedSplineAreaSeriesView() : CXTPChartStackedSplineAreaSeriesView
  • CXTPChartStepAreaSeriesStyle() : CXTPChartStepAreaSeriesStyle
  • CXTPChartStepAreaSeriesView() : CXTPChartStepAreaSeriesView
  • CXTPChartStepLineSeriesPointView() : CXTPChartStepLineSeriesPointView
  • CXTPChartStepLineSeriesStyle() : CXTPChartStepLineSeriesStyle
  • CXTPChartStepLineSeriesView() : CXTPChartStepLineSeriesView
  • CXTPChartTextAntialiasingDeviceCommand() : CXTPChartTextAntialiasingDeviceCommand
  • CXTPChartTextDeviceCommand() : CXTPChartTextDeviceCommand
  • CXTPChartTextPainter() : CXTPChartTextPainter
  • CXTPChartTextPainterBase() : CXTPChartTextPainterBase
  • CXTPChartTitle() : CXTPChartTitle
  • CXTPChartTitleAppearance() : CXTPChartTitleAppearance
  • CXTPChartTitleCollection() : CXTPChartTitleCollection
  • CXTPChartTranslateDeviceCommand() : CXTPChartTranslateDeviceCommand
  • CXTPCheckListBox() : CXTPCheckListBox
  • CXTPClientCursorPos() : CXTPClientCursorPos
  • CXTPClientRect() : CXTPClientRect
  • CXTPCmdTarget() : CXTPCmdTarget
  • CXTPColorBase() : CXTPColorBase
  • CXTPColorDialog() : CXTPColorDialog
  • CXTPColorHex() : CXTPColorHex
  • CXTPColorLum() : CXTPColorLum
  • CXTPColorPageCustom() : CXTPColorPageCustom
  • CXTPColorPageStandard() : CXTPColorPageStandard
  • CXTPColorPicker() : CXTPColorPicker
  • CXTPColorPopup() : CXTPColorPopup
  • CXTPColorSelectorCtrl() : CXTPColorSelectorCtrl
  • CXTPColorSelectorCtrlTheme() : CXTPColorSelectorCtrlTheme
  • CXTPColorSelectorCtrlThemeNativeWindows10() : CXTPColorSelectorCtrlThemeNativeWindows10
  • CXTPColorSelectorCtrlThemeNativeWindows11() : CXTPColorSelectorCtrlThemeNativeWindows11
  • CXTPColorSelectorCtrlThemeOffice2003() : CXTPColorSelectorCtrlThemeOffice2003
  • CXTPColorSelectorCtrlThemeOffice2013() : CXTPColorSelectorCtrlThemeOffice2013
  • CXTPColorSelectorCtrlThemeOfficeXP() : CXTPColorSelectorCtrlThemeOfficeXP
  • CXTPColorSelectorCtrlThemeResource() : CXTPColorSelectorCtrlThemeResource
  • CXTPColorSelectorCtrlThemeVisualStudio2015() : CXTPColorSelectorCtrlThemeVisualStudio2015
  • CXTPColorSelectorCtrlThemeVisualStudio2017() : CXTPColorSelectorCtrlThemeVisualStudio2017
  • CXTPColorSelectorCtrlThemeVisualStudio2019() : CXTPColorSelectorCtrlThemeVisualStudio2019
  • CXTPColorSelectorCtrlThemeVisualStudio2022() : CXTPColorSelectorCtrlThemeVisualStudio2022
  • CXTPColorWnd() : CXTPColorWnd
  • CXTPComboBox() : CXTPComboBox
  • CXTPComboBoxTheme() : CXTPComboBoxTheme
  • CXTPComboBoxThemeDefault() : CXTPComboBoxThemeDefault
  • CXTPComboBoxThemeNativeWindows10() : CXTPComboBoxThemeNativeWindows10
  • CXTPComboBoxThemeNativeWindows11() : CXTPComboBoxThemeNativeWindows11
  • CXTPComboBoxThemeOffice2000() : CXTPComboBoxThemeOffice2000
  • CXTPComboBoxThemeOffice2003() : CXTPComboBoxThemeOffice2003
  • CXTPComboBoxThemeOffice2013() : CXTPComboBoxThemeOffice2013
  • CXTPComboBoxThemeOfficeXPFlat() : CXTPComboBoxThemeOfficeXPFlat
  • CXTPComboBoxThemeResource() : CXTPComboBoxThemeResource
  • CXTPComboBoxThemeVisualStudio() : CXTPComboBoxThemeVisualStudio
  • CXTPComboBoxThemeVisualStudio2010() : CXTPComboBoxThemeVisualStudio2010
  • CXTPComboBoxThemeVisualStudio2012() : CXTPComboBoxThemeVisualStudio2012
  • CXTPComboBoxThemeVisualStudio2015() : CXTPComboBoxThemeVisualStudio2015
  • CXTPComboBoxThemeVisualStudio2017() : CXTPComboBoxThemeVisualStudio2017
  • CXTPComboBoxThemeVisualStudio2019() : CXTPComboBoxThemeVisualStudio2019
  • CXTPComboBoxThemeVisualStudio2022() : CXTPComboBoxThemeVisualStudio2022
  • CXTPComInitializer() : CXTPComInitializer
  • CXTPCommandBar() : CXTPCommandBar
  • CXTPCommandBarEditCtrl() : CXTPCommandBarEditCtrl
  • CXTPCommandBarKeyboardTip() : CXTPCommandBarKeyboardTip
  • CXTPCommandBarList() : CXTPCommandBarList
  • CXTPCommandBars() : CXTPCommandBars
  • CXTPCommandBarsContextMenus() : CXTPCommandBarsContextMenus
  • CXTPCommandBarScrollBarCtrl() : CXTPCommandBarScrollBarCtrl
  • CXTPCommandBarsFrameHook() : CXTPCommandBarsFrameHook
  • CXTPCommandBarsModernUITheme() : CXTPCommandBarsModernUITheme
  • CXTPCommandBarsNativeWindows10Theme() : CXTPCommandBarsNativeWindows10Theme
  • CXTPCommandBarsNativeWindows11Theme() : CXTPCommandBarsNativeWindows11Theme
  • CXTPCommandBarsNativeXPTheme() : CXTPCommandBarsNativeXPTheme
  • CXTPCommandBarsOffice2000Theme() : CXTPCommandBarsOffice2000Theme
  • CXTPCommandBarsOffice2003Theme() : CXTPCommandBarsOffice2003Theme
  • CXTPCommandBarsOffice2013Theme() : CXTPCommandBarsOffice2013Theme
  • CXTPCommandBarsOfficeXPTheme() : CXTPCommandBarsOfficeXPTheme
  • CXTPCommandBarsOptions() : CXTPCommandBarsOptions
  • CXTPCommandBarsSiteBase() : CXTPCommandBarsSiteBase< TBase >
  • CXTPCommandBarsVisualStudio2012Theme() : CXTPCommandBarsVisualStudio2012Theme
  • CXTPCommandBarsVisualStudio2015Theme() : CXTPCommandBarsVisualStudio2015Theme
  • CXTPCommandBarsVisualStudio2017Theme() : CXTPCommandBarsVisualStudio2017Theme
  • CXTPCommandBarsVisualStudio2019Theme() : CXTPCommandBarsVisualStudio2019Theme
  • CXTPCommandBarsVisualStudio2022Theme() : CXTPCommandBarsVisualStudio2022Theme
  • CXTPControl() : CXTPControl
  • CXTPControlAction() : CXTPControlAction
  • CXTPControlActions() : CXTPControlActions
  • CXTPControlBitmap() : CXTPControlBitmap
  • CXTPControlButton() : CXTPControlButton
  • CXTPControlButtonColor() : CXTPControlButtonColor
  • CXTPControlCheckBox() : CXTPControlCheckBox
  • CXTPControlColorSelector() : CXTPControlColorSelector
  • CXTPControlComboBox() : CXTPControlComboBox
  • CXTPControlComboBoxGalleryPopupBar() : CXTPControlComboBoxGalleryPopupBar
  • CXTPControlComboBoxList() : CXTPControlComboBoxList
  • CXTPControlComboBoxPopupBar() : CXTPControlComboBoxPopupBar
  • CXTPControlCustom() : CXTPControlCustom
  • CXTPControlEdit() : CXTPControlEdit
  • CXTPControlFontComboBox() : CXTPControlFontComboBox
  • CXTPControlGallery() : CXTPControlGallery
  • CXTPControlGalleryItem() : CXTPControlGalleryItem
  • CXTPControlGalleryItems() : CXTPControlGalleryItems
  • CXTPControlGalleryNativeWindows10Theme() : CXTPControlGalleryNativeWindows10Theme
  • CXTPControlGalleryNativeWindows11Theme() : CXTPControlGalleryNativeWindows11Theme
  • CXTPControlGalleryOffice2013Theme() : CXTPControlGalleryOffice2013Theme
  • CXTPControlGalleryPaintManager() : CXTPControlGalleryPaintManager
  • CXTPControlGalleryResourceTheme() : CXTPControlGalleryResourceTheme
  • CXTPControlGalleryVisualStudio2015Theme() : CXTPControlGalleryVisualStudio2015Theme
  • CXTPControlGalleryVisualStudio2017Theme() : CXTPControlGalleryVisualStudio2017Theme
  • CXTPControlGalleryVisualStudio2019Theme() : CXTPControlGalleryVisualStudio2019Theme
  • CXTPControlGalleryVisualStudio2022Theme() : CXTPControlGalleryVisualStudio2022Theme
  • CXTPControlHyperlink() : CXTPControlHyperlink
  • CXTPControlListBox() : CXTPControlListBox
  • CXTPControlMarkupLabel() : CXTPControlMarkupLabel
  • CXTPControlPopup() : CXTPControlPopup
  • CXTPControlPopupColor() : CXTPControlPopupColor
  • CXTPControlProgress() : CXTPControlProgress
  • CXTPControlRadioButton() : CXTPControlRadioButton
  • CXTPControls() : CXTPControls
  • CXTPControlScrollBar() : CXTPControlScrollBar
  • CXTPControlSelector() : CXTPControlSelector
  • CXTPControlSizeComboBox() : CXTPControlSizeComboBox
  • CXTPControlSlider() : CXTPControlSlider
  • CXTPControlStatic() : CXTPControlStatic
  • CXTPControlTabWorkspace() : CXTPControlTabWorkspace
  • CXTPControlTheme() : CXTPControlTheme
  • CXTPControlToolbars() : CXTPControlToolbars
  • CXTPCriticalSection() : CXTPCriticalSection
  • CXTPCustomizeCommandsListBox() : CXTPCustomizeCommandsListBox
  • CXTPCustomizeCommandsPage() : CXTPCustomizeCommandsPage
  • CXTPCustomizeKeyboardPage() : CXTPCustomizeKeyboardPage
  • CXTPCustomizeMenusPage() : CXTPCustomizeMenusPage
  • CXTPCustomizeOptionsPage() : CXTPCustomizeOptionsPage
  • CXTPCustomizeSheet() : CXTPCustomizeSheet
  • CXTPCustomizeToolbarsPage() : CXTPCustomizeToolbarsPage
  • CXTPDateEdit() : CXTPDateEdit
  • CXTPDatePickerButton() : CXTPDatePickerButton
  • CXTPDatePickerControl() : CXTPDatePickerControl
  • CXTPDatePickerDaysCollection() : CXTPDatePickerDaysCollection
  • CXTPDatePickerItemDay() : CXTPDatePickerItemDay
  • CXTPDatePickerItemMonth() : CXTPDatePickerItemMonth
  • CXTPDatePickerList() : CXTPDatePickerList
  • CXTPDatePickerPaintManager() : CXTPDatePickerPaintManager
  • CXTPDatePickerThemeNativeWindows10() : CXTPDatePickerThemeNativeWindows10
  • CXTPDatePickerThemeNativeWindows11() : CXTPDatePickerThemeNativeWindows11
  • CXTPDatePickerThemeOffice2000() : CXTPDatePickerThemeOffice2000
  • CXTPDatePickerThemeOffice2003() : CXTPDatePickerThemeOffice2003
  • CXTPDatePickerThemeOffice2013() : CXTPDatePickerThemeOffice2013
  • CXTPDatePickerThemeOfficeXP() : CXTPDatePickerThemeOfficeXP
  • CXTPDatePickerThemeResource() : CXTPDatePickerThemeResource
  • CXTPDatePickerThemeVisualStudio2015() : CXTPDatePickerThemeVisualStudio2015
  • CXTPDatePickerThemeVisualStudio2017() : CXTPDatePickerThemeVisualStudio2017
  • CXTPDatePickerThemeVisualStudio2019() : CXTPDatePickerThemeVisualStudio2019
  • CXTPDatePickerThemeVisualStudio2022() : CXTPDatePickerThemeVisualStudio2022
  • CXTPDeviceCaps() : CXTPDeviceCaps
  • CXTPDialogBar() : CXTPDialogBar
  • CXTPDialogBase() : CXTPDialogBase< TBase >
  • CXTPDialogEx() : CXTPDialogEx
  • CXTPDialogScrollBarContainer() : CXTPDialogScrollBarContainer< Parent >
  • CXTPDirWatcher() : CXTPDirWatcher
  • CXTPDockBar() : CXTPDockBar
  • CXTPDockContext() : CXTPDockContext
  • CXTPDockingPane() : CXTPDockingPane
  • CXTPDockingPaneAutoHidePanel() : CXTPDockingPaneAutoHidePanel
  • CXTPDockingPaneBase() : CXTPDockingPaneBase
  • CXTPDockingPaneBaseContainer() : CXTPDockingPaneBaseContainer
  • CXTPDockingPaneCaptionButton() : CXTPDockingPaneCaptionButton
  • CXTPDockingPaneContext() : CXTPDockingPaneContext
  • CXTPDockingPaneContextAlphaWnd() : CXTPDockingPaneContextAlphaWnd
  • CXTPDockingPaneContextStickerWnd() : CXTPDockingPaneContextStickerWnd
  • CXTPDockingPaneDefaultTheme() : CXTPDockingPaneDefaultTheme
  • CXTPDockingPaneGripperedTheme() : CXTPDockingPaneGripperedTheme
  • CXTPDockingPaneLayout() : CXTPDockingPaneLayout
  • CXTPDockingPaneManager() : CXTPDockingPaneManager
  • CXTPDockingPaneMiniWnd() : CXTPDockingPaneMiniWnd
  • CXTPDockingPaneNativeWindows10Theme() : CXTPDockingPaneNativeWindows10Theme
  • CXTPDockingPaneNativeWindows11Theme() : CXTPDockingPaneNativeWindows11Theme
  • CXTPDockingPaneOffice2002VisioTheme() : CXTPDockingPaneOffice2002VisioTheme
  • CXTPDockingPaneOffice2003OutlookTheme() : CXTPDockingPaneOffice2003OutlookTheme
  • CXTPDockingPaneOffice2003Theme() : CXTPDockingPaneOffice2003Theme
  • CXTPDockingPaneOffice2003VisioTheme() : CXTPDockingPaneOffice2003VisioTheme
  • CXTPDockingPaneOffice2007OutlookTheme() : CXTPDockingPaneOffice2007OutlookTheme
  • CXTPDockingPaneOffice2007Theme() : CXTPDockingPaneOffice2007Theme
  • CXTPDockingPaneOffice2007VisioTheme() : CXTPDockingPaneOffice2007VisioTheme
  • CXTPDockingPaneOffice2007WordTheme() : CXTPDockingPaneOffice2007WordTheme
  • CXTPDockingPaneOffice2013Theme() : CXTPDockingPaneOffice2013Theme
  • CXTPDockingPanePaintManager() : CXTPDockingPanePaintManager
  • CXTPDockingPanePanelColorSet2012() : CXTPDockingPanePanelColorSet2012
  • CXTPDockingPanePanelColorSet2013() : CXTPDockingPanePanelColorSet2013
  • CXTPDockingPanePanelColorSet2015() : CXTPDockingPanePanelColorSet2015
  • CXTPDockingPanePanelColorSet2017() : CXTPDockingPanePanelColorSet2017
  • CXTPDockingPanePanelColorSet2019() : CXTPDockingPanePanelColorSet2019
  • CXTPDockingPanePanelColorSet2022() : CXTPDockingPanePanelColorSet2022
  • CXTPDockingPanePanelColorSetNativeWindows10() : CXTPDockingPanePanelColorSetNativeWindows10
  • CXTPDockingPanePanelColorSetNativeWindows11() : CXTPDockingPanePanelColorSetNativeWindows11
  • CXTPDockingPanePanelTheme2012() : CXTPDockingPanePanelTheme2012
  • CXTPDockingPanePanelTheme2013() : CXTPDockingPanePanelTheme2013
  • CXTPDockingPanePanelTheme2015() : CXTPDockingPanePanelTheme2015
  • CXTPDockingPanePanelTheme2017() : CXTPDockingPanePanelTheme2017
  • CXTPDockingPanePanelTheme2019() : CXTPDockingPanePanelTheme2019
  • CXTPDockingPanePanelTheme2022() : CXTPDockingPanePanelTheme2022
  • CXTPDockingPanePanelThemeNativeWindows10() : CXTPDockingPanePanelThemeNativeWindows10
  • CXTPDockingPanePanelThemeNativeWindows11() : CXTPDockingPanePanelThemeNativeWindows11
  • CXTPDockingPaneSidePanel() : CXTPDockingPaneSidePanel
  • CXTPDockingPaneSplitterContainer() : CXTPDockingPaneSplitterContainer
  • CXTPDockingPaneSplitterWnd() : CXTPDockingPaneSplitterWnd
  • CXTPDockingPaneTabbedContainer() : CXTPDockingPaneTabbedContainer
  • CXTPDockingPaneTabColorSet2012() : CXTPDockingPaneTabColorSet2012
  • CXTPDockingPaneTabColorSet2013() : CXTPDockingPaneTabColorSet2013
  • CXTPDockingPaneTabColorSet2015() : CXTPDockingPaneTabColorSet2015
  • CXTPDockingPaneTabColorSet2017() : CXTPDockingPaneTabColorSet2017
  • CXTPDockingPaneTabColorSet2019() : CXTPDockingPaneTabColorSet2019
  • CXTPDockingPaneTabColorSet2022() : CXTPDockingPaneTabColorSet2022
  • CXTPDockingPaneTabColorSetNativeWindows10() : CXTPDockingPaneTabColorSetNativeWindows10
  • CXTPDockingPaneTabColorSetNativeWindows11() : CXTPDockingPaneTabColorSetNativeWindows11
  • CXTPDockingPaneTabColorSetOfficePanel() : CXTPDockingPaneTabColorSetOfficePanel
  • CXTPDockingPaneTabColorSetVisualStudio2003() : CXTPDockingPaneTabColorSetVisualStudio2003
  • CXTPDockingPaneTabColorSetVisualStudio2005() : CXTPDockingPaneTabColorSetVisualStudio2005
  • CXTPDockingPaneTabTheme2012() : CXTPDockingPaneTabTheme2012
  • CXTPDockingPaneTabTheme2013() : CXTPDockingPaneTabTheme2013
  • CXTPDockingPaneTabTheme2015() : CXTPDockingPaneTabTheme2015
  • CXTPDockingPaneTabTheme2017() : CXTPDockingPaneTabTheme2017
  • CXTPDockingPaneTabTheme2019() : CXTPDockingPaneTabTheme2019
  • CXTPDockingPaneTabTheme2022() : CXTPDockingPaneTabTheme2022
  • CXTPDockingPaneTabThemeNativeWindows10() : CXTPDockingPaneTabThemeNativeWindows10
  • CXTPDockingPaneTabThemeNativeWindows11() : CXTPDockingPaneTabThemeNativeWindows11
  • CXTPDockingPaneVisualStudio2003Theme() : CXTPDockingPaneVisualStudio2003Theme
  • CXTPDockingPaneVisualStudio2005Beta1Theme() : CXTPDockingPaneVisualStudio2005Beta1Theme
  • CXTPDockingPaneVisualStudio2005Beta2Theme() : CXTPDockingPaneVisualStudio2005Beta2Theme
  • CXTPDockingPaneVisualStudio2005Theme() : CXTPDockingPaneVisualStudio2005Theme
  • CXTPDockingPaneVisualStudio2008Theme() : CXTPDockingPaneVisualStudio2008Theme
  • CXTPDockingPaneVisualStudio2010Theme() : CXTPDockingPaneVisualStudio2010Theme
  • CXTPDockingPaneVisualStudio2012Theme() : CXTPDockingPaneVisualStudio2012Theme
  • CXTPDockingPaneVisualStudio2015Theme() : CXTPDockingPaneVisualStudio2015Theme
  • CXTPDockingPaneVisualStudio2017Theme() : CXTPDockingPaneVisualStudio2017Theme
  • CXTPDockingPaneVisualStudio2019Theme() : CXTPDockingPaneVisualStudio2019Theme
  • CXTPDockingPaneVisualStudio2022Theme() : CXTPDockingPaneVisualStudio2022Theme
  • CXTPDockingPaneVisualStudio6Theme() : CXTPDockingPaneVisualStudio6Theme
  • CXTPDockingPaneWindowSelect() : CXTPDockingPaneWindowSelect
  • CXTPDockingPaneWinExplorerTheme() : CXTPDockingPaneWinExplorerTheme
  • CXTPDockingPaneWinNativeTheme() : CXTPDockingPaneWinNativeTheme
  • CXTPDockState() : CXTPDockState
  • CXTPDPCache() : CXTPCalendarData::CXTPDPCache
  • CXTPDropSource() : CXTPDropSource
  • CXTPEdit() : CXTPEdit
  • CXTPEditListBox() : CXTPEditListBox
  • CXTPEditListBoxToolBar() : CXTPEditListBoxToolBar
  • CXTPEditTheme() : CXTPEditTheme
  • CXTPEditThemeDefault() : CXTPEditThemeDefault
  • CXTPEditThemeFlat() : CXTPEditThemeFlat
  • CXTPEditThemeNativeWindows10() : CXTPEditThemeNativeWindows10
  • CXTPEditThemeNativeWindows11() : CXTPEditThemeNativeWindows11
  • CXTPEditThemeOffice2000() : CXTPEditThemeOffice2000
  • CXTPEditThemeOffice2003() : CXTPEditThemeOffice2003
  • CXTPEditThemeOffice2013() : CXTPEditThemeOffice2013
  • CXTPEditThemeOfficeXP() : CXTPEditThemeOfficeXP
  • CXTPEditThemeResource() : CXTPEditThemeResource
  • CXTPEditThemeUltraFlat() : CXTPEditThemeUltraFlat
  • CXTPEditThemeVisualStudio2010() : CXTPEditThemeVisualStudio2010
  • CXTPEditThemeVisualStudio2012() : CXTPEditThemeVisualStudio2012
  • CXTPEditThemeVisualStudio2015() : CXTPEditThemeVisualStudio2015
  • CXTPEditThemeVisualStudio2017() : CXTPEditThemeVisualStudio2017
  • CXTPEditThemeVisualStudio2019() : CXTPEditThemeVisualStudio2019
  • CXTPEditThemeVisualStudio2022() : CXTPEditThemeVisualStudio2022
  • CXTPEmptyRect() : CXTPEmptyRect
  • CXTPEmptySize() : CXTPEmptySize
  • CXTPExcelTabCtrl() : CXTPExcelTabCtrl
  • CXTPExcelTabCtrlButtonState() : CXTPExcelTabCtrlButtonState
  • CXTPExcelTabCtrlTheme() : CXTPExcelTabCtrlTheme
  • CXTPExcelTabCtrlThemeNativeWindows10() : CXTPExcelTabCtrlThemeNativeWindows10
  • CXTPExcelTabCtrlThemeNativeWindows11() : CXTPExcelTabCtrlThemeNativeWindows11
  • CXTPExcelTabCtrlThemeOffice2003() : CXTPExcelTabCtrlThemeOffice2003
  • CXTPExcelTabCtrlThemeOffice2013() : CXTPExcelTabCtrlThemeOffice2013
  • CXTPExcelTabCtrlThemeOfficeXP() : CXTPExcelTabCtrlThemeOfficeXP
  • CXTPExcelTabCtrlThemeVisualStudio2015() : CXTPExcelTabCtrlThemeVisualStudio2015
  • CXTPExcelTabCtrlThemeVisualStudio2017() : CXTPExcelTabCtrlThemeVisualStudio2017
  • CXTPExcelTabCtrlThemeVisualStudio2019() : CXTPExcelTabCtrlThemeVisualStudio2019
  • CXTPExcelTabCtrlThemeVisualStudio2022() : CXTPExcelTabCtrlThemeVisualStudio2022
  • CXTPEyeDropper() : CXTPEyeDropper
  • CXTPFlowGraphConnection() : CXTPFlowGraphConnection
  • CXTPFlowGraphConnectionPoint() : CXTPFlowGraphConnectionPoint
  • CXTPFlowGraphConnectionPoints() : CXTPFlowGraphConnectionPoints
  • CXTPFlowGraphConnections() : CXTPFlowGraphConnections
  • CXTPFlowGraphControl() : CXTPFlowGraphControl
  • CXTPFlowGraphEditItem() : CXTPFlowGraphEditItem
  • CXTPFlowGraphElement() : CXTPFlowGraphElement
  • CXTPFlowGraphImage() : CXTPFlowGraphImage
  • CXTPFlowGraphImages() : CXTPFlowGraphImages
  • CXTPFlowGraphNode() : CXTPFlowGraphNode
  • CXTPFlowGraphNodeCustom() : CXTPFlowGraphNodeCustom
  • CXTPFlowGraphNodeGroup() : CXTPFlowGraphNodeGroup
  • CXTPFlowGraphNodeGroups() : CXTPFlowGraphNodeGroups
  • CXTPFlowGraphNodes() : CXTPFlowGraphNodes
  • CXTPFlowGraphPage() : CXTPFlowGraphPage
  • CXTPFlowGraphPageHistory() : CXTPFlowGraphPageHistory
  • CXTPFlowGraphPages() : CXTPFlowGraphPages
  • CXTPFlowGraphPaintManager() : CXTPFlowGraphPaintManager
  • CXTPFlowGraphSelectedElements() : CXTPFlowGraphSelectedElements
  • CXTPFlowGraphUndoAddConnectionCommand() : CXTPFlowGraphUndoAddConnectionCommand
  • CXTPFlowGraphUndoAddConnectionPointCommand() : CXTPFlowGraphUndoAddConnectionPointCommand
  • CXTPFlowGraphUndoAddNodeCommand() : CXTPFlowGraphUndoAddNodeCommand
  • CXTPFlowGraphUndoCommand() : CXTPFlowGraphUndoCommand
  • CXTPFlowGraphUndoDeleteConnectionCommand() : CXTPFlowGraphUndoDeleteConnectionCommand
  • CXTPFlowGraphUndoDeleteConnectionPointCommand() : CXTPFlowGraphUndoDeleteConnectionPointCommand
  • CXTPFlowGraphUndoDeleteNodeCommand() : CXTPFlowGraphUndoDeleteNodeCommand
  • CXTPFlowGraphUndoGroupCommand() : CXTPFlowGraphUndoGroupCommand
  • CXTPFlowGraphUndoManager() : CXTPFlowGraphUndoManager
  • CXTPFlowGraphUndoSetConnectionPositionCommand() : CXTPFlowGraphUndoSetConnectionPositionCommand
  • CXTPFlowGraphUndoSetNodeCaptionCommand() : CXTPFlowGraphUndoSetNodeCaptionCommand
  • CXTPFlowGraphUndoSetNodePositionCommand() : CXTPFlowGraphUndoSetNodePositionCommand
  • CXTPFlowGraphUndoSetNodeSizeCommand() : CXTPFlowGraphUndoSetNodeSizeCommand
  • CXTPFont() : CXTPFont
  • CXTPFontComboBox() : CXTPFontComboBox
  • CXTPFontCtrlBase() : CXTPFontCtrlBase
  • CXTPFontEnum() : CXTPFontEnum
  • CXTPFontListBox() : CXTPFontListBox
  • CXTPFramePaintManager() : CXTPFramePaintManager
  • CXTPFrameShadow() : CXTPFrameShadow
  • CXTPFrameThemeOffice2007System() : CXTPFrameThemeOffice2007System
  • CXTPFrameWndBase() : CXTPFrameWndBase< TBase >
  • CXTPGaugeBaseType() : CXTPGaugeBaseType
  • CXTPGaugeCtrl() : CXTPGaugeCtrl
  • CXTPGaugeTraits() : CXTPGaugeTraits
  • CXTPGdiObject() : CXTPGdiObject
  • CXTPGlobalAtom() : CXTPGlobalAtom
  • CXTPGraphicBitmapPng() : CXTPGraphicBitmapPng
  • CXTPGridColumn() : CXTPGridColumn
  • CXTPGridColumnOrder() : CXTPGridColumnOrder
  • CXTPGridColumns() : CXTPGridColumns
  • CXTPGridControl() : CXTPGridControl
  • CXTPGridDataManager() : CXTPGridDataManager
  • CXTPGridFilterEditControl() : CXTPGridFilterEditControl
  • CXTPGridGroupRow() : CXTPGridGroupRow
  • CXTPGridHeader() : CXTPGridHeader
  • CXTPGridHeaderDragWnd() : CXTPGridHeaderDragWnd
  • CXTPGridHeaderDropWnd() : CXTPGridHeaderDropWnd
  • CXTPGridHyperlink() : CXTPGridHyperlink
  • CXTPGridHyperlinks() : CXTPGridHyperlinks
  • CXTPGridHyperlinkStyle() : CXTPGridHyperlinkStyle
  • CXTPGridIconNavigator() : CXTPGridIconNavigator
  • CXTPGridInplaceButton() : CXTPGridInplaceButton
  • CXTPGridInplaceButtons() : CXTPGridInplaceButtons
  • CXTPGridInplaceControl() : CXTPGridInplaceControl
  • CXTPGridInplaceEdit() : CXTPGridInplaceEdit
  • CXTPGridInplaceList() : CXTPGridInplaceList
  • CXTPGridNavigator() : CXTPGridNavigator
  • CXTPGridPageSetupDialog() : CXTPGridPageSetupDialog
  • CXTPGridPaintManager() : CXTPGridPaintManager
  • CXTPGridRecord() : CXTPGridRecord
  • CXTPGridRecordItem() : CXTPGridRecordItem
  • CXTPGridRecordItemButton() : CXTPGridRecordItemButton
  • CXTPGridRecordItemCheckbox() : CXTPGridRecordItemCheckbox
  • CXTPGridRecordItemConstraint() : CXTPGridRecordItemConstraint
  • CXTPGridRecordItemConstraints() : CXTPGridRecordItemConstraints
  • CXTPGridRecordItemControl() : CXTPGridRecordItemControl
  • CXTPGridRecordItemControlHookWnd() : CXTPGridRecordItemControlHookWnd
  • CXTPGridRecordItemControls() : CXTPGridRecordItemControls
  • CXTPGridRecordItemDateTime() : CXTPGridRecordItemDateTime
  • CXTPGridRecordItemEditOptions() : CXTPGridRecordItemEditOptions
  • CXTPGridRecordItemNumber() : CXTPGridRecordItemNumber
  • CXTPGridRecordItemPercentNumber() : CXTPGridRecordItemPercentNumber
  • CXTPGridRecordItemPreview() : CXTPGridRecordItemPreview
  • CXTPGridRecordItemText() : CXTPGridRecordItemText
  • CXTPGridRecordItemVariant() : CXTPGridRecordItemVariant
  • CXTPGridRecords() : CXTPGridRecords
  • CXTPGridRow() : CXTPGridRow
  • CXTPGridRows() : CXTPGridRows
  • CXTPGridSection() : CXTPGridSection
  • CXTPGridSections() : CXTPGridSections
  • CXTPGridSelectedRows() : CXTPGridSelectedRows
  • CXTPGridSubListControl() : CXTPGridSubListControl
  • CXTPGridThemeDefault() : CXTPGridThemeDefault
  • CXTPGridThemeExplorer() : CXTPGridThemeExplorer
  • CXTPGridThemeNativeWindows10() : CXTPGridThemeNativeWindows10
  • CXTPGridThemeNativeWindows11() : CXTPGridThemeNativeWindows11
  • CXTPGridThemeOffice2003() : CXTPGridThemeOffice2003
  • CXTPGridThemeOffice2003Luna() : CXTPGridThemeOffice2003Luna
  • CXTPGridThemeOffice2013() : CXTPGridThemeOffice2013
  • CXTPGridThemeOfficeXP() : CXTPGridThemeOfficeXP
  • CXTPGridThemeResource() : CXTPGridThemeResource
  • CXTPGridThemeVisualStudio2012Blue() : CXTPGridThemeVisualStudio2012Blue
  • CXTPGridThemeVisualStudio2012Dark() : CXTPGridThemeVisualStudio2012Dark
  • CXTPGridThemeVisualStudio2012Light() : CXTPGridThemeVisualStudio2012Light
  • CXTPGridThemeVisualStudio2015() : CXTPGridThemeVisualStudio2015
  • CXTPGridThemeVisualStudio2017() : CXTPGridThemeVisualStudio2017
  • CXTPGridThemeVisualStudio2019() : CXTPGridThemeVisualStudio2019
  • CXTPGridThemeVisualStudio2022() : CXTPGridThemeVisualStudio2022
  • CXTPGridThickness() : CXTPGridThickness
  • CXTPGridTip() : CXTPGridTip
  • CXTPGridView() : CXTPGridView
  • CXTPGridViewPrintOptions() : CXTPGridViewPrintOptions
  • CXTPGroupLine() : CXTPGroupLine
  • CXTPHeaderCtrl() : CXTPHeaderCtrl
  • CXTPHeaderCtrlTheme() : CXTPHeaderCtrlTheme
  • CXTPHeaderCtrlThemeExplorer() : CXTPHeaderCtrlThemeExplorer
  • CXTPHeaderCtrlThemeOffice2003() : CXTPHeaderCtrlThemeOffice2003
  • CXTPHeaderCtrlThemeOfficeXP() : CXTPHeaderCtrlThemeOfficeXP
  • CXTPHeaderCtrlThemeResource() : CXTPHeaderCtrlThemeResource
  • CXTPHeapString() : CXTPHeapString
  • CXTPHeapStringT() : CXTPHeapStringT< _TAllocator >
  • CXTPHexEdit() : CXTPHexEdit
  • CXTPHookManager() : CXTPHookManager
  • CXTPHookManagerHookAble() : CXTPHookManagerHookAble
  • CXTPHyperLink() : CXTPHyperLink
  • CXTPIconHandle() : CXTPIconHandle
  • CXTPImageEditorDlg() : CXTPImageEditorDlg
  • CXTPImageList() : CXTPImageList
  • CXTPImageManager() : CXTPImageManager
  • CXTPImageManagerIcon() : CXTPImageManagerIcon
  • CXTPImageManagerIconHandle() : CXTPImageManagerIconHandle
  • CXTPImageManagerIconSet() : CXTPImageManagerIconSet
  • CXTPImageManagerImageList() : CXTPImageManagerImageList
  • CXTPImageManagerResource() : CXTPImageManagerResource
  • CXTPImageManagerVectorImageHandle() : CXTPImageManagerVectorImageHandle
  • CXTPInternalCollectionT() : CXTPInternalCollectionT< _TObject >
  • CXTPItemEdit() : CXTPItemEdit
  • CXTPKeyboardManager() : CXTPKeyboardManager
  • CXTPListBase() : CXTPListBase
  • CXTPListBox() : CXTPListBox
  • CXTPListBoxThemeNativeWindows10() : CXTPListBoxThemeNativeWindows10
  • CXTPListBoxThemeNativeWindows11() : CXTPListBoxThemeNativeWindows11
  • CXTPListBoxThemeOffice2013() : CXTPListBoxThemeOffice2013
  • CXTPListBoxThemeVisualStudio2015() : CXTPListBoxThemeVisualStudio2015
  • CXTPListBoxThemeVisualStudio2017() : CXTPListBoxThemeVisualStudio2017
  • CXTPListBoxThemeVisualStudio2019() : CXTPListBoxThemeVisualStudio2019
  • CXTPListBoxThemeVisualStudio2022() : CXTPListBoxThemeVisualStudio2022
  • CXTPListCtrl() : CXTPListCtrl
  • CXTPListView() : CXTPListView
  • CXTPLockGuard() : CXTPLockGuard
  • CXTPLogFont() : CXTPLogFont
  • CXTPMarkupBorder() : CXTPMarkupBorder
  • CXTPMarkupButton() : CXTPMarkupButton
  • CXTPMarkupButtonBase() : CXTPMarkupButtonBase
  • CXTPMarkupCheckBox() : CXTPMarkupCheckBox
  • CXTPMarkupColumnDefinition() : CXTPMarkupColumnDefinition
  • CXTPMarkupColumnDefinitionCollection() : CXTPMarkupColumnDefinitionCollection
  • CXTPMarkupContentControl() : CXTPMarkupContentControl
  • CXTPMarkupContext() : CXTPMarkupContext
  • CXTPMarkupDecorator() : CXTPMarkupDecorator
  • CXTPMarkupDefinitionBase() : CXTPMarkupDefinitionBase
  • CXTPMarkupDefinitionCollection() : CXTPMarkupDefinitionCollection
  • CXTPMarkupDeviceDependentImage() : CXTPMarkupDeviceDependentImage
  • CXTPMarkupDockPanel() : CXTPMarkupDockPanel
  • CXTPMarkupExtension() : CXTPMarkupExtension
  • CXTPMarkupFrameworkElement() : CXTPMarkupFrameworkElement
  • CXTPMarkupGdiImage() : CXTPMarkupGdiImage
  • CXTPMarkupGdiPlusImage() : CXTPMarkupGdiPlusImage
  • CXTPMarkupGdiPlusMatrixTransform() : CXTPMarkupGdiPlusMatrixTransform
  • CXTPMarkupGdiPlusRotateTransform() : CXTPMarkupGdiPlusRotateTransform
  • CXTPMarkupGdiPlusScaleTransform() : CXTPMarkupGdiPlusScaleTransform
  • CXTPMarkupGdiPlusTransformationMatrix() : CXTPMarkupGdiPlusTransformationMatrix
  • CXTPMarkupGdiPlusTransformObject() : CXTPMarkupGdiPlusTransformObject< BaseTransform >
  • CXTPMarkupGdiPlusTransformObjectImpl() : CXTPMarkupGdiPlusTransformObjectImpl
  • CXTPMarkupGrid() : CXTPMarkupGrid
  • CXTPMarkupGridLength() : CXTPMarkupGridLength
  • CXTPMarkupImage() : CXTPMarkupImage
  • CXTPMarkupPage() : CXTPMarkupPage
  • CXTPMarkupPanel() : CXTPMarkupPanel
  • CXTPMarkupRadioButton() : CXTPMarkupRadioButton
  • CXTPMarkupRowDefinition() : CXTPMarkupRowDefinition
  • CXTPMarkupRowDefinitionCollection() : CXTPMarkupRowDefinitionCollection
  • CXTPMarkupStackPanel() : CXTPMarkupStackPanel
  • CXTPMarkupStaticExtension() : CXTPMarkupStaticExtension
  • CXTPMarkupStaticExtensionBooleanProperty() : CXTPMarkupStaticExtensionBooleanProperty
  • CXTPMarkupStaticExtensionBrushProperty() : CXTPMarkupStaticExtensionBrushProperty
  • CXTPMarkupStaticExtensionColorProperty() : CXTPMarkupStaticExtensionColorProperty
  • CXTPMarkupStaticExtensionDoubleProperty() : CXTPMarkupStaticExtensionDoubleProperty
  • CXTPMarkupStaticExtensionIntegerProperty() : CXTPMarkupStaticExtensionIntegerProperty
  • CXTPMarkupStaticExtensionProperty() : CXTPMarkupStaticExtensionProperty
  • CXTPMarkupStaticExtensionStringProperty() : CXTPMarkupStaticExtensionStringProperty
  • CXTPMarkupSystemBrushKeyStaticExtension() : CXTPMarkupSystemBrushKeyStaticExtension
  • CXTPMarkupSystemBrushStaticExtension() : CXTPMarkupSystemBrushStaticExtension
  • CXTPMarkupSystemColorKeyStaticExtension() : CXTPMarkupSystemColorKeyStaticExtension
  • CXTPMarkupSystemColorsStaticExtension() : CXTPMarkupSystemColorsStaticExtension
  • CXTPMarkupSystemColorStaticExtension() : CXTPMarkupSystemColorStaticExtension
  • CXTPMarkupTextBlock() : CXTPMarkupTextBlock
  • CXTPMarkupThemePart() : CXTPMarkupThemePart
  • CXTPMarkupThickness() : CXTPMarkupThickness
  • CXTPMarkupTransform() : CXTPMarkupTransform
  • CXTPMarkupTransformationMatrix() : CXTPMarkupTransformationMatrix
  • CXTPMarkupTreeCtrl() : CXTPMarkupTreeCtrl
  • CXTPMarkupUIElement() : CXTPMarkupUIElement
  • CXTPMarkupUIElementCollection() : CXTPMarkupUIElementCollection
  • CXTPMarkupUniformGrid() : CXTPMarkupUniformGrid
  • CXTPMarkupViewbox() : CXTPMarkupViewbox
  • CXTPMarkupVisual() : CXTPMarkupVisual
  • CXTPMarkupWrapPanel() : CXTPMarkupWrapPanel
  • CXTPMarqueeCtrl() : CXTPMarqueeCtrl
  • CXTPMarqueeCtrlPaintManager() : CXTPMarqueeCtrlPaintManager
  • CXTPMarqueeCtrlThemeFlat() : CXTPMarqueeCtrlThemeFlat
  • CXTPMarqueeCtrlThemeNativeWindows() : CXTPMarqueeCtrlThemeNativeWindows
  • CXTPMarqueeCtrlThemeNativeWinXP() : CXTPMarqueeCtrlThemeNativeWinXP
  • CXTPMarqueeCtrlThemeOffice2000() : CXTPMarqueeCtrlThemeOffice2000
  • CXTPMarqueeCtrlThemeOffice2003() : CXTPMarqueeCtrlThemeOffice2003
  • CXTPMarqueeCtrlThemeOffice2013() : CXTPMarqueeCtrlThemeOffice2013
  • CXTPMarqueeCtrlThemeOfficeXP() : CXTPMarqueeCtrlThemeOfficeXP
  • CXTPMarqueeCtrlThemeResource() : CXTPMarqueeCtrlThemeResource
  • CXTPMarqueeCtrlThemeUltraFlat() : CXTPMarqueeCtrlThemeUltraFlat
  • CXTPMarqueeCtrlThemeVisualStudio2015() : CXTPMarqueeCtrlThemeVisualStudio2015
  • CXTPMarqueeCtrlThemeVisualStudio2017() : CXTPMarqueeCtrlThemeVisualStudio2017
  • CXTPMarqueeCtrlThemeVisualStudio2019() : CXTPMarqueeCtrlThemeVisualStudio2019
  • CXTPMarqueeCtrlThemeVisualStudio2022() : CXTPMarqueeCtrlThemeVisualStudio2022
  • CXTPMaskEdit() : CXTPMaskEdit
  • CXTPMaskEditT() : CXTPMaskEditT< TBase >
  • CXTPMatrix() : CXTPMatrix< T >
  • CXTPMDIClientWnd() : CXTPMDIClientWnd
  • CXTPMDIWndTab() : CXTPMDIWndTab
  • CXTPMemFile() : CXTPMemFile
  • CXTPMenuBar() : CXTPMenuBar
  • CXTPMenuBarMDIMenuInfo() : CXTPMenuBarMDIMenuInfo
  • CXTPMenuBarMDIMenus() : CXTPMenuBarMDIMenus
  • CXTPMessageBar() : CXTPMessageBar
  • CXTPMessageBarButton() : CXTPMessageBarButton
  • CXTPMessageBarPaintManager() : CXTPMessageBarPaintManager
  • CXTPMessageBarThemeNativeWindows10() : CXTPMessageBarThemeNativeWindows10
  • CXTPMessageBarThemeNativeWindows11() : CXTPMessageBarThemeNativeWindows11
  • CXTPMessageBarThemeOffice2010() : CXTPMessageBarThemeOffice2010
  • CXTPMessageBarThemeOffice2013() : CXTPMessageBarThemeOffice2013
  • CXTPMessageBarThemeVisualStudio2015() : CXTPMessageBarThemeVisualStudio2015
  • CXTPMessageBarThemeVisualStudio2017() : CXTPMessageBarThemeVisualStudio2017
  • CXTPMessageBarThemeVisualStudio2019() : CXTPMessageBarThemeVisualStudio2019
  • CXTPMessageBarThemeVisualStudio2022() : CXTPMessageBarThemeVisualStudio2022
  • CXTPMiniToolBar() : CXTPMiniToolBar
  • CXTPModuleHandle() : CXTPModuleHandle
  • CXTPMouseManager() : CXTPMouseManager
  • CXTPNonClientMetrics() : CXTPNonClientMetrics
  • CXTPNotifyConnection() : CXTPNotifyConnection
  • CXTPNotifyConnectionMT() : CXTPNotifyConnectionMT
  • CXTPNotifySinkBase() : CXTPNotifySinkBase
  • CXTPObservable() : CXTPObservable< Owner, Observer >
  • CXTPOriginalControls() : CXTPOriginalControls
  • CXTPPageScroller() : CXTPPageScroller
  • CXTPPaintManager() : CXTPPaintManager
  • CXTPPaintManagerColor() : CXTPPaintManagerColor
  • CXTPPaintManagerColorGradient() : CXTPPaintManagerColorGradient
  • CXTPPaintManagerFont() : CXTPPaintManagerFont
  • CXTPPasswordPeek() : CXTPPasswordPeek
  • CXTPPen() : CXTPPen
  • CXTPPoint2T() : CXTPPoint2T< T >
  • CXTPPoint3T() : CXTPPoint3T< T >
  • CXTPPopupBar() : CXTPPopupBar
  • CXTPPopupControl() : CXTPPopupControl
  • CXTPPopupItem() : CXTPPopupItem
  • CXTPPopupPaintManager() : CXTPPopupPaintManager
  • CXTPPopupThemeMSN() : CXTPPopupThemeMSN
  • CXTPPopupThemeOffice2000() : CXTPPopupThemeOffice2000
  • CXTPPopupThemeOffice2003() : CXTPPopupThemeOffice2003
  • CXTPPopupThemeOffice2013() : CXTPPopupThemeOffice2013
  • CXTPPopupThemeOfficeXP() : CXTPPopupThemeOfficeXP
  • CXTPPopupThemeResource() : CXTPPopupThemeResource
  • CXTPPreviewCtrl() : CXTPPreviewCtrl
  • CXTPPreviewProviderBase() : CXTPPreviewProviderBase
  • CXTPPreviewView() : CXTPPreviewView
  • CXTPProgressBase() : CXTPProgressBase
  • CXTPProgressCtrl() : CXTPProgressCtrl
  • CXTPProgressCtrlPaintManager() : CXTPProgressCtrlPaintManager
  • CXTPProgressCtrlThemeFlat() : CXTPProgressCtrlThemeFlat
  • CXTPProgressCtrlThemeNativeWindows() : CXTPProgressCtrlThemeNativeWindows
  • CXTPProgressCtrlThemeNativeWinXP() : CXTPProgressCtrlThemeNativeWinXP
  • CXTPProgressCtrlThemeOffice2000() : CXTPProgressCtrlThemeOffice2000
  • CXTPProgressCtrlThemeOffice2003() : CXTPProgressCtrlThemeOffice2003
  • CXTPProgressCtrlThemeOffice2013() : CXTPProgressCtrlThemeOffice2013
  • CXTPProgressCtrlThemeOfficeXP() : CXTPProgressCtrlThemeOfficeXP
  • CXTPProgressCtrlThemeResource() : CXTPProgressCtrlThemeResource
  • CXTPProgressCtrlThemeUltraFlat() : CXTPProgressCtrlThemeUltraFlat
  • CXTPProgressCtrlThemeVisualStudio2015() : CXTPProgressCtrlThemeVisualStudio2015
  • CXTPProgressCtrlThemeVisualStudio2017() : CXTPProgressCtrlThemeVisualStudio2017
  • CXTPProgressCtrlThemeVisualStudio2019() : CXTPProgressCtrlThemeVisualStudio2019
  • CXTPProgressCtrlThemeVisualStudio2022() : CXTPProgressCtrlThemeVisualStudio2022
  • CXTPProgressPaintManager() : CXTPProgressPaintManager
  • CXTPProgressThemeNativeWindows10() : CXTPProgressThemeNativeWindows10
  • CXTPProgressThemeNativeWindows11() : CXTPProgressThemeNativeWindows11
  • CXTPProgressThemeOffice2013() : CXTPProgressThemeOffice2013
  • CXTPProgressThemeVisualStudio2015() : CXTPProgressThemeVisualStudio2015
  • CXTPProgressThemeVisualStudio2017() : CXTPProgressThemeVisualStudio2017
  • CXTPProgressThemeVisualStudio2019() : CXTPProgressThemeVisualStudio2019
  • CXTPProgressThemeVisualStudio2022() : CXTPProgressThemeVisualStudio2022
  • CXTPPropertyGrid() : CXTPPropertyGrid
  • CXTPPropertyGridCoolTheme() : CXTPPropertyGridCoolTheme
  • CXTPPropertyGridDelphiTheme() : CXTPPropertyGridDelphiTheme
  • CXTPPropertyGridInplaceButton() : CXTPPropertyGridInplaceButton
  • CXTPPropertyGridInplaceButtons() : CXTPPropertyGridInplaceButtons
  • CXTPPropertyGridInplaceControl() : CXTPPropertyGridInplaceControl
  • CXTPPropertyGridInplaceControls() : CXTPPropertyGridInplaceControls
  • CXTPPropertyGridInplaceEdit() : CXTPPropertyGridInplaceEdit
  • CXTPPropertyGridInplaceList() : CXTPPropertyGridInplaceList
  • CXTPPropertyGridInplaceMonthCal() : CXTPPropertyGridInplaceMonthCal
  • CXTPPropertyGridInplaceMultilineEdit() : CXTPPropertyGridInplaceMultilineEdit
  • CXTPPropertyGridInplaceSlider() : CXTPPropertyGridInplaceSlider
  • CXTPPropertyGridInplaceSpinButton() : CXTPPropertyGridInplaceSpinButton
  • CXTPPropertyGridItem() : CXTPPropertyGridItem
  • CXTPPropertyGridItemBool() : CXTPPropertyGridItemBool
  • CXTPPropertyGridItemCategory() : CXTPPropertyGridItemCategory
  • CXTPPropertyGridItemColor() : CXTPPropertyGridItemColor
  • CXTPPropertyGridItemConstraint() : CXTPPropertyGridItemConstraint
  • CXTPPropertyGridItemConstraints() : CXTPPropertyGridItemConstraints
  • CXTPPropertyGridItemDate() : CXTPPropertyGridItemDate
  • CXTPPropertyGridItemDouble() : CXTPPropertyGridItemDouble
  • CXTPPropertyGridItemEnum() : CXTPPropertyGridItemEnum
  • CXTPPropertyGridItemFlags() : CXTPPropertyGridItemFlags
  • CXTPPropertyGridItemFont() : CXTPPropertyGridItemFont
  • CXTPPropertyGridItemMetrics() : CXTPPropertyGridItemMetrics
  • CXTPPropertyGridItemMultilineString() : CXTPPropertyGridItemMultilineString
  • CXTPPropertyGridItemNumber() : CXTPPropertyGridItemNumber
  • CXTPPropertyGridItemOption() : CXTPPropertyGridItemOption
  • CXTPPropertyGridItemPoint() : CXTPPropertyGridItemPoint
  • CXTPPropertyGridItems() : CXTPPropertyGridItems
  • CXTPPropertyGridItemSize() : CXTPPropertyGridItemSize
  • CXTPPropertyGridNativeWindows10Theme() : CXTPPropertyGridNativeWindows10Theme
  • CXTPPropertyGridNativeWindows11Theme() : CXTPPropertyGridNativeWindows11Theme
  • CXTPPropertyGridNativeXPTheme() : CXTPPropertyGridNativeXPTheme
  • CXTPPropertyGridOffice2003Theme() : CXTPPropertyGridOffice2003Theme
  • CXTPPropertyGridOffice2007Theme() : CXTPPropertyGridOffice2007Theme
  • CXTPPropertyGridOffice2013Theme() : CXTPPropertyGridOffice2013Theme
  • CXTPPropertyGridOfficeXPTheme() : CXTPPropertyGridOfficeXPTheme
  • CXTPPropertyGridPaintManager() : CXTPPropertyGridPaintManager
  • CXTPPropertyGridSimpleTheme() : CXTPPropertyGridSimpleTheme
  • CXTPPropertyGridToolBar() : CXTPPropertyGridToolBar
  • CXTPPropertyGridToolTip() : CXTPPropertyGridToolTip
  • CXTPPropertyGridUpdateContext() : CXTPPropertyGridUpdateContext
  • CXTPPropertyGridVerb() : CXTPPropertyGridVerb
  • CXTPPropertyGridVerbs() : CXTPPropertyGridVerbs
  • CXTPPropertyGridView() : CXTPPropertyGridView
  • CXTPPropertyGridVisualStudio2005Theme() : CXTPPropertyGridVisualStudio2005Theme
  • CXTPPropertyGridVisualStudio2010Theme() : CXTPPropertyGridVisualStudio2010Theme
  • CXTPPropertyGridVisualStudio2012Theme() : CXTPPropertyGridVisualStudio2012Theme
  • CXTPPropertyGridVisualStudio2015Theme() : CXTPPropertyGridVisualStudio2015Theme
  • CXTPPropertyGridVisualStudio2017Theme() : CXTPPropertyGridVisualStudio2017Theme
  • CXTPPropertyGridVisualStudio2019Theme() : CXTPPropertyGridVisualStudio2019Theme
  • CXTPPropertyGridVisualStudio2022Theme() : CXTPPropertyGridVisualStudio2022Theme
  • CXTPPropertyPage() : CXTPPropertyPage
  • CXTPPropertyPageControlNavigator() : CXTPPropertyPageControlNavigator
  • CXTPPropertyPageListNavigator() : CXTPPropertyPageListNavigator
  • CXTPPropertyPageNavigator() : CXTPPropertyPageNavigator
  • CXTPPropertyPageTreeNavigator() : CXTPPropertyPageTreeNavigator
  • CXTPPropertySheet() : CXTPPropertySheet
  • CXTPPropExchange() : CXTPPropExchange
  • CXTPPropExchangeArchive() : CXTPPropExchangeArchive
  • CXTPPropExchangeEnumerator() : CXTPPropExchangeEnumerator
  • CXTPPropExchangeIniFile() : CXTPPropExchangeIniFile
  • CXTPPropExchangeRegistry() : CXTPPropExchangeRegistry
  • CXTPPropExchangeSection() : CXTPPropExchangeSection
  • CXTPPropExchangeXMLNode() : CXTPPropExchangeXMLNode
  • CXTPReBar() : CXTPReBar
  • CXTPReBarPaintManager() : CXTPReBarPaintManager< TBase >
  • CXTPRecentFileList() : CXTPRecentFileList
  • CXTPRectT() : CXTPRectT< T >
  • CXTPRegistryManager() : CXTPRegistryManager
  • CXTPResize() : CXTPResize
  • CXTPResizeDialog() : CXTPResizeDialog
  • CXTPResizeFormView() : CXTPResizeFormView
  • CXTPResizeGroupBox() : CXTPResizeGroupBox
  • CXTPResizeItem() : CXTPResizeItem
  • CXTPResizePoint() : CXTPResizePoint
  • CXTPResizePropertyPage() : CXTPResizePropertyPage
  • CXTPResizePropertySheet() : CXTPResizePropertySheet
  • CXTPResizeRect() : CXTPResizeRect
  • CXTPResourceImage() : CXTPResourceImage
  • CXTPResourceImages() : CXTPResourceImages
  • CXTPResourceManager() : CXTPResourceManager
  • CXTPResourceManagerXML() : CXTPResourceManagerXML
  • CXTPResourceTheme() : CXTPResourceTheme
  • CXTPRibbonBar() : CXTPRibbonBar
  • CXTPRibbonControls() : CXTPRibbonControls
  • CXTPRibbonControlSystemButton() : CXTPRibbonControlSystemButton
  • CXTPRibbonControlSystemPopupBarButton() : CXTPRibbonControlSystemPopupBarButton
  • CXTPRibbonControlSystemPopupBarListCaption() : CXTPRibbonControlSystemPopupBarListCaption
  • CXTPRibbonControlSystemPopupBarListItem() : CXTPRibbonControlSystemPopupBarListItem
  • CXTPRibbonControlSystemPopupBarPinableListItem() : CXTPRibbonControlSystemPopupBarPinableListItem
  • CXTPRibbonControlSystemRecentFileList() : CXTPRibbonControlSystemRecentFileList
  • CXTPRibbonControlTab() : CXTPRibbonControlTab
  • CXTPRibbonCustomizePage() : CXTPRibbonCustomizePage
  • CXTPRibbonCustomizeQuickAccessPage() : CXTPRibbonCustomizeQuickAccessPage
  • CXTPRibbonGroup() : CXTPRibbonGroup
  • CXTPRibbonGroups() : CXTPRibbonGroups
  • CXTPRibbonMarkupFrameTheme() : CXTPRibbonMarkupFrameTheme
  • CXTPRibbonMarkupTheme() : CXTPRibbonMarkupTheme
  • CXTPRibbonOffice2013Theme() : CXTPRibbonOffice2013Theme
  • CXTPRibbonPaintManager() : CXTPRibbonPaintManager
  • CXTPRibbonQuickAccessControls() : CXTPRibbonQuickAccessControls
  • CXTPRibbonSystemPopupBar() : CXTPRibbonSystemPopupBar
  • CXTPRibbonSystemPopupBarPage() : CXTPRibbonSystemPopupBarPage
  • CXTPRibbonTab() : CXTPRibbonTab
  • CXTPRibbonTabPopupToolBar() : CXTPRibbonTabPopupToolBar
  • CXTPRibbonTheme() : CXTPRibbonTheme
  • CXTPRibbonThemeNativeWindows10() : CXTPRibbonThemeNativeWindows10
  • CXTPRibbonThemeNativeWindows11() : CXTPRibbonThemeNativeWindows11
  • CXTPRibbonThemeOffice2007System() : CXTPRibbonThemeOffice2007System
  • CXTPRibbonThemeResource() : CXTPRibbonThemeResource
  • CXTPRibbonThemeVisualStudio2015() : CXTPRibbonThemeVisualStudio2015
  • CXTPRibbonThemeVisualStudio2017() : CXTPRibbonThemeVisualStudio2017
  • CXTPRibbonThemeVisualStudio2019() : CXTPRibbonThemeVisualStudio2019
  • CXTPRibbonThemeVisualStudio2022() : CXTPRibbonThemeVisualStudio2022
  • CXTPRWCriticalSection() : CXTPRWCriticalSection
  • CXTPScrollable() : CXTPScrollable< Base >
  • CXTPScrollableEditT() : CXTPScrollableEditT< EditBase >
  • CXTPScrollableListBoxT() : CXTPScrollableListBoxT< ListBoxBase >
  • CXTPScrollableListCtrlT() : CXTPScrollableListCtrlT< ListBase >
  • CXTPScrollableTreeCtrlT() : CXTPScrollableTreeCtrlT< TreeBase >
  • CXTPScrollBar() : CXTPScrollBar
  • CXTPScrollBarContainer() : CXTPScrollBarContainer< Parent >
  • CXTPScrollBarCtrl() : CXTPScrollBarCtrl
  • CXTPScrollBarPaintManager() : CXTPScrollBarPaintManager
  • CXTPScrollBarThemeOffice2013() : CXTPScrollBarThemeOffice2013
  • CXTPScrollBarThemeWindowsUx() : CXTPScrollBarThemeWindowsUx
  • CXTPScrollBase() : CXTPScrollBase
  • CXTPSearchOptionsCtrl() : CXTPSearchOptionsCtrl
  • CXTPSearchOptionsView() : CXTPSearchOptionsView
  • CXTPShadowManager() : CXTPShadowManager
  • CXTPShellExplorerProvider() : CXTPShellExplorerProvider
  • CXTPShellListBase() : CXTPShellListBase
  • CXTPShellListCtrl() : CXTPShellListCtrl
  • CXTPShellListCtrlEx() : CXTPShellListCtrlEx
  • CXTPShellListView() : CXTPShellListView
  • CXTPShellPidl() : CXTPShellPidl
  • CXTPShellSettings() : CXTPShellSettings
  • CXTPShellTreeBase() : CXTPShellTreeBase
  • CXTPShellTreeCtrl() : CXTPShellTreeCtrl
  • CXTPShellTreeView() : CXTPShellTreeView
  • CXTPShortcutBar() : CXTPShortcutBar
  • CXTPShortcutBarItem() : CXTPShortcutBarItem
  • CXTPShortcutBarNativeWindows10Theme() : CXTPShortcutBarNativeWindows10Theme
  • CXTPShortcutBarNativeWindows11Theme() : CXTPShortcutBarNativeWindows11Theme
  • CXTPShortcutBarNativeWinXPTheme() : CXTPShortcutBarNativeWinXPTheme
  • CXTPShortcutBarOffice2003Theme() : CXTPShortcutBarOffice2003Theme
  • CXTPShortcutBarOffice2013Theme() : CXTPShortcutBarOffice2013Theme
  • CXTPShortcutBarPaintManager() : CXTPShortcutBarPaintManager
  • CXTPShortcutBarPane() : CXTPShortcutBarPane
  • CXTPShortcutBarPaneItem() : CXTPShortcutBarPaneItem
  • CXTPShortcutBarResourceTheme() : CXTPShortcutBarResourceTheme
  • CXTPShortcutBarVisualStudio2015Theme() : CXTPShortcutBarVisualStudio2015Theme
  • CXTPShortcutBarVisualStudio2017Theme() : CXTPShortcutBarVisualStudio2017Theme
  • CXTPShortcutBarVisualStudio2019Theme() : CXTPShortcutBarVisualStudio2019Theme
  • CXTPShortcutBarVisualStudio2022Theme() : CXTPShortcutBarVisualStudio2022Theme
  • CXTPShortcutListBox() : CXTPShortcutListBox
  • CXTPShortcutListBoxTheme() : CXTPShortcutListBoxTheme
  • CXTPShortcutListBoxThemeOffice2003() : CXTPShortcutListBoxThemeOffice2003
  • CXTPShortcutListBoxThemeOfficeXP() : CXTPShortcutListBoxThemeOfficeXP
  • CXTPShortcutManager() : CXTPShortcutManager
  • CXTPShortcutManagerAccel() : CXTPShortcutManagerAccel
  • CXTPShortcutManagerAccelTable() : CXTPShortcutManagerAccelTable
  • CXTPSimpleCriticalSection() : CXTPSimpleCriticalSection
  • CXTPSimpleEvent() : CXTPSimpleEvent
  • CXTPSingletonBase() : CXTPSingletonBase< Derived, Parent >
  • CXTPSingletonPointer() : CXTPSingletonPointer
  • CXTPSizeIcon() : CXTPSizeIcon
  • CXTPSizeT() : CXTPSizeT< T >
  • CXTPSkinImage() : CXTPSkinImage
  • CXTPSkinImages() : CXTPSkinImages
  • CXTPSkinManager() : CXTPSkinManager
  • CXTPSkinManagerClass() : CXTPSkinManagerClass
  • CXTPSkinManagerMetrics() : CXTPSkinManagerMetrics
  • CXTPSkinManagerResourceFile() : CXTPSkinManagerResourceFile
  • CXTPSkinManagerSchema() : CXTPSkinManagerSchema
  • CXTPSkinManagerSchemaProperty() : CXTPSkinManagerSchemaProperty
  • CXTPSkinObject() : CXTPSkinObject
  • CXTPSkinObjectButton() : CXTPSkinObjectButton
  • CXTPSkinObjectClassMap() : CXTPSkinObjectClassMap
  • CXTPSkinObjectComboBox() : CXTPSkinObjectComboBox
  • CXTPSkinObjectComCtl32Control() : CXTPSkinObjectComCtl32Control
  • CXTPSkinObjectDateTime() : CXTPSkinObjectDateTime
  • CXTPSkinObjectEdit() : CXTPSkinObjectEdit
  • CXTPSkinObjectFrame() : CXTPSkinObjectFrame
  • CXTPSkinObjectHeader() : CXTPSkinObjectHeader
  • CXTPSkinObjectListBox() : CXTPSkinObjectListBox
  • CXTPSkinObjectListView() : CXTPSkinObjectListView
  • CXTPSkinObjectMonthCal() : CXTPSkinObjectMonthCal
  • CXTPSkinObjectProgress() : CXTPSkinObjectProgress
  • CXTPSkinObjectReBar() : CXTPSkinObjectReBar
  • CXTPSkinObjectScrollBar() : CXTPSkinObjectScrollBar
  • CXTPSkinObjectSolidFilled() : CXTPSkinObjectSolidFilled
  • CXTPSkinObjectSpin() : CXTPSkinObjectSpin
  • CXTPSkinObjectStatusBar() : CXTPSkinObjectStatusBar
  • CXTPSkinObjectTab() : CXTPSkinObjectTab
  • CXTPSkinObjectToolBar() : CXTPSkinObjectToolBar
  • CXTPSkinObjectTrackBar() : CXTPSkinObjectTrackBar
  • CXTPSkinObjectTreeView() : CXTPSkinObjectTreeView
  • CXTPSkinObjectUser32Control() : CXTPSkinObjectUser32Control
  • CXTPSliderPaintManager() : CXTPSliderPaintManager
  • CXTPSmartPtrInternalT() : CXTPSmartPtrInternalT< _TObject >
  • CXTPSortClass() : CXTPSortClass
  • CXTPSpinButtonCtrl() : CXTPSpinButtonCtrl
  • CXTPSplitPath() : CXTPSplitPath
  • CXTPSplitterWnd() : CXTPSplitterWnd
  • CXTPSplitterWndEx() : CXTPSplitterWndEx
  • CXTPSplitterWndTheme() : CXTPSplitterWndTheme
  • CXTPSplitterWndThemeOffice2003() : CXTPSplitterWndThemeOffice2003
  • CXTPSplitterWndThemeOffice2013() : CXTPSplitterWndThemeOffice2013
  • CXTPSplitterWndThemeOfficeXP() : CXTPSplitterWndThemeOfficeXP
  • CXTPSplitterWndThemeResource() : CXTPSplitterWndThemeResource
  • CXTPSplitterWndThemeVisualStudio2010() : CXTPSplitterWndThemeVisualStudio2010
  • CXTPSplitterWndThemeVisualStudio2015() : CXTPSplitterWndThemeVisualStudio2015
  • CXTPSplitterWndThemeVisualStudio2017() : CXTPSplitterWndThemeVisualStudio2017
  • CXTPSplitterWndThemeVisualStudio2019() : CXTPSplitterWndThemeVisualStudio2019
  • CXTPSplitterWndThemeVisualStudio2022() : CXTPSplitterWndThemeVisualStudio2022
  • CXTPStatusBar() : CXTPStatusBar
  • CXTPStatusBarPane() : CXTPStatusBarPane
  • CXTPStatusBarProgressPane() : CXTPStatusBarProgressPane
  • CXTPStatusBarScrollBarPane() : CXTPStatusBarScrollBarPane
  • CXTPStatusBarSliderPane() : CXTPStatusBarSliderPane
  • CXTPStatusBarSwitchPane() : CXTPStatusBarSwitchPane
  • CXTPStatusBarThemeNativeWindows10() : CXTPStatusBarThemeNativeWindows10
  • CXTPStatusBarThemeNativeWindows11() : CXTPStatusBarThemeNativeWindows11
  • CXTPStatusBarThemeOffice2013() : CXTPStatusBarThemeOffice2013
  • CXTPStatusBarThemeVisualStudio2015() : CXTPStatusBarThemeVisualStudio2015
  • CXTPStatusBarThemeVisualStudio2017() : CXTPStatusBarThemeVisualStudio2017
  • CXTPStatusBarThemeVisualStudio2019() : CXTPStatusBarThemeVisualStudio2019
  • CXTPStatusBarThemeVisualStudio2022() : CXTPStatusBarThemeVisualStudio2022
  • CXTPStickerBase() : CXTPStickerBase
  • CXTPSubscriptionList() : CXTPSubscriptionList< Observable, Observer >
  • CXTPSvgImage() : CXTPSvgImage
  • CXTPSyntaxEditAutoCompleteWnd() : CXTPSyntaxEditAutoCompleteWnd
  • CXTPSyntaxEditBufferCommand() : CXTPSyntaxEditBufferCommand
  • CXTPSyntaxEditBufferKeepOverwriteSettings() : CXTPSyntaxEditBufferCommand::CXTPSyntaxEditBufferKeepOverwriteSettings
  • CXTPSyntaxEditBufferManager() : CXTPSyntaxEditBufferManager
  • CXTPSyntaxEditColorComboBox() : CXTPSyntaxEditColorComboBox
  • CXTPSyntaxEditColorInfo() : CXTPSyntaxEditColorInfo
  • CXTPSyntaxEditColorInfoArray() : CXTPSyntaxEditColorInfoArray
  • CXTPSyntaxEditColorSampleText() : CXTPSyntaxEditColorSampleText
  • CXTPSyntaxEditColorTheme() : CXTPSyntaxEditColorTheme
  • CXTPSyntaxEditColorThemesManager() : CXTPSyntaxEditColorThemesManager
  • CXTPSyntaxEditCommand() : CXTPSyntaxEditCommand
  • CXTPSyntaxEditConfigurationManager() : CXTPSyntaxEditConfigurationManager
  • CXTPSyntaxEditCtrl() : CXTPSyntaxEditCtrl
  • CXTPSyntaxEditDeleteStringCommand() : CXTPSyntaxEditDeleteStringCommand
  • CXTPSyntaxEditDoc() : CXTPSyntaxEditDoc
  • CXTPSyntaxEditDrawTextProcessor() : CXTPSyntaxEditDrawTextProcessor
  • CXTPSyntaxEditFileChangesMonitor() : CXTPSyntaxEditFileChangesMonitor
  • CXTPSyntaxEditFindReplaceDlg() : CXTPSyntaxEditFindReplaceDlg
  • CXTPSyntaxEditGoToLineDlg() : CXTPSyntaxEditGoToLineDlg
  • CXTPSyntaxEditInsertStringCommand() : CXTPSyntaxEditInsertStringCommand
  • CXTPSyntaxEditLexClass() : CXTPSyntaxEditLexClass
  • CXTPSyntaxEditLexOnScreenParseCnt() : CXTPSyntaxEditLexOnScreenParseCnt
  • CXTPSyntaxEditLexParser() : CXTPSyntaxEditLexParser
  • CXTPSyntaxEditLexParserSchemaOptions() : CXTPSyntaxEditLexParserSchemaOptions
  • CXTPSyntaxEditLexTextBlock() : CXTPSyntaxEditLexTextBlock
  • CXTPSyntaxEditLexTextSchema() : CXTPSyntaxEditLexTextSchema
  • CXTPSyntaxEditLexTokensDef() : CXTPSyntaxEditLexTokensDef
  • CXTPSyntaxEditLexVariable() : CXTPSyntaxEditLexVariable
  • CXTPSyntaxEditLexVariant() : CXTPSyntaxEditLexVariant
  • CXTPSyntaxEditLineMarksManager() : CXTPSyntaxEditLineMarksManager
  • CXTPSyntaxEditPaintManager() : CXTPSyntaxEditPaintManager
  • CXTPSyntaxEditPropertiesDlg() : CXTPSyntaxEditPropertiesDlg
  • CXTPSyntaxEditPropertiesPageColor() : CXTPSyntaxEditPropertiesPageColor
  • CXTPSyntaxEditPropertiesPageEdit() : CXTPSyntaxEditPropertiesPageEdit
  • CXTPSyntaxEditPropertiesPageFont() : CXTPSyntaxEditPropertiesPageFont
  • CXTPSyntaxEditReplaceStringCommand() : CXTPSyntaxEditReplaceStringCommand
  • CXTPSyntaxEditSelection() : CXTPSyntaxEditSelection
  • CXTPSyntaxEditStringsManager() : CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager
  • CXTPSyntaxEditTextIterator() : CXTPSyntaxEditTextIterator
  • CXTPSyntaxEditTextSchemesManager() : CXTPSyntaxEditTextSchemesManager
  • CXTPSyntaxEditTipListBox() : CXTPSyntaxEditTipListBox
  • CXTPSyntaxEditTipWnd() : CXTPSyntaxEditTipWnd
  • CXTPSyntaxEditToolTipCtrl() : CXTPSyntaxEditToolTipCtrl
  • CXTPSyntaxEditUndoRedoManager() : CXTPSyntaxEditUndoRedoManager
  • CXTPSyntaxEditView() : CXTPSyntaxEditView
  • CXTPSyntaxEditViewPrintOptions() : CXTPSyntaxEditViewPrintOptions
  • CXTPSystemMetrics() : CXTPSystemMetrics
  • CXTPTabBase() : CXTPTabBase
  • CXTPTabBaseTheme() : CXTPTabBaseTheme
  • CXTPTabBaseThemeOffice2003() : CXTPTabBaseThemeOffice2003
  • CXTPTabBaseThemeOfficeXP() : CXTPTabBaseThemeOfficeXP
  • CXTPTabClientContext() : CXTPTabClientContext
  • CXTPTabClientSticker() : CXTPTabClientSticker
  • CXTPTabClientWnd() : CXTPTabClientWnd
  • CXTPTabColorSetVisualStudio2008() : CXTPTabColorSetVisualStudio2008
  • CXTPTabColorSetVisualStudio2010() : CXTPTabColorSetVisualStudio2010
  • CXTPTabControl() : CXTPTabControl
  • CXTPTabCtrl() : CXTPTabCtrl
  • CXTPTabExBase() : CXTPTabExBase
  • CXTPTabManager() : CXTPTabManager
  • CXTPTabManagerItem() : CXTPTabManagerItem
  • CXTPTabManagerNavigateButton() : CXTPTabManagerNavigateButton
  • CXTPTabManagerNavigateButtons() : CXTPTabManagerNavigateButtons
  • CXTPTabPaintManager() : CXTPTabPaintManager
  • CXTPTabPaintManagerColorSet() : CXTPTabPaintManagerColorSet
  • CXTPTabPaintManagerTheme() : CXTPTabPaintManagerTheme
  • CXTPTabThemeExcel2003() : CXTPTabThemeExcel2003
  • CXTPTabThemeFlat() : CXTPTabThemeFlat
  • CXTPTabThemeNativeWindows10() : CXTPTabThemeNativeWindows10
  • CXTPTabThemeNativeWindows11() : CXTPTabThemeNativeWindows11
  • CXTPTabThemeOffice2000() : CXTPTabThemeOffice2000
  • CXTPTabThemeOffice2013() : CXTPTabThemeOffice2013
  • CXTPTabThemeVisualStudio2003() : CXTPTabThemeVisualStudio2003
  • CXTPTabThemeVisualStudio2010() : CXTPTabThemeVisualStudio2010
  • CXTPTabThemeVisualStudio2015() : CXTPTabThemeVisualStudio2015
  • CXTPTabThemeVisualStudio2017() : CXTPTabThemeVisualStudio2017
  • CXTPTabThemeVisualStudio2019() : CXTPTabThemeVisualStudio2019
  • CXTPTabThemeVisualStudio2022() : CXTPTabThemeVisualStudio2022
  • CXTPTabToolBar() : CXTPTabToolBar
  • CXTPTabView() : CXTPTabView
  • CXTPTagCloudCtrl() : CXTPTagCloudCtrl
  • CXTPTagCloudStyle() : CXTPTagCloudStyle
  • CXTPTaskDialog() : CXTPTaskDialog
  • CXTPTaskDialogLinkCtrl() : CXTPTaskDialogLinkCtrl
  • CXTPTaskPanel() : CXTPTaskPanel
  • CXTPTaskPanelExplorerTheme() : CXTPTaskPanelExplorerTheme
  • CXTPTaskPanelExplorerThemePlain() : CXTPTaskPanelExplorerThemePlain
  • CXTPTaskPanelGroup() : CXTPTaskPanelGroup
  • CXTPTaskPanelGroupItem() : CXTPTaskPanelGroupItem
  • CXTPTaskPanelGroupItems() : CXTPTaskPanelGroupItems
  • CXTPTaskPanelGroups() : CXTPTaskPanelGroups
  • CXTPTaskPanelItem() : CXTPTaskPanelItem
  • CXTPTaskPanelItems() : CXTPTaskPanelItems
  • CXTPTaskPanelListViewOffice2003Theme() : CXTPTaskPanelListViewOffice2003Theme
  • CXTPTaskPanelListViewOfficeXPTheme() : CXTPTaskPanelListViewOfficeXPTheme
  • CXTPTaskPanelListViewTheme() : CXTPTaskPanelListViewTheme
  • CXTPTaskPanelNativeWindows10Theme() : CXTPTaskPanelNativeWindows10Theme
  • CXTPTaskPanelNativeWindows11Theme() : CXTPTaskPanelNativeWindows11Theme
  • CXTPTaskPanelOffice2003Theme() : CXTPTaskPanelOffice2003Theme
  • CXTPTaskPanelOffice2003ThemePlain() : CXTPTaskPanelOffice2003ThemePlain
  • CXTPTaskPanelOffice2013Theme() : CXTPTaskPanelOffice2013Theme
  • CXTPTaskPanelOfficeXPThemePlain() : CXTPTaskPanelOfficeXPThemePlain
  • CXTPTaskPanelPaintManager() : CXTPTaskPanelPaintManager
  • CXTPTaskPanelPaintManagerPlain() : CXTPTaskPanelPaintManagerPlain
  • CXTPTaskPanelScrollButton() : CXTPTaskPanelScrollButton
  • CXTPTaskPanelShortcutBarOffice2003Theme() : CXTPTaskPanelShortcutBarOffice2003Theme
  • CXTPTaskPanelShortcutBarOffice2007Theme() : CXTPTaskPanelShortcutBarOffice2007Theme
  • CXTPTaskPanelToolboxTheme() : CXTPTaskPanelToolboxTheme
  • CXTPTaskPanelVisualStudio2005Theme() : CXTPTaskPanelVisualStudio2005Theme
  • CXTPTaskPanelVisualStudio2010Theme() : CXTPTaskPanelVisualStudio2010Theme
  • CXTPTaskPanelVisualStudio2012Theme() : CXTPTaskPanelVisualStudio2012Theme
  • CXTPTaskPanelVisualStudio2015Theme() : CXTPTaskPanelVisualStudio2015Theme
  • CXTPTaskPanelVisualStudio2017Theme() : CXTPTaskPanelVisualStudio2017Theme
  • CXTPTaskPanelVisualStudio2019Theme() : CXTPTaskPanelVisualStudio2019Theme
  • CXTPTaskPanelVisualStudio2022Theme() : CXTPTaskPanelVisualStudio2022Theme
  • CXTPTcbItem() : CXTPTcbItem
  • CXTPTearOffFrame() : CXTPTearOffFrame
  • CXTPTempColorMask() : CXTPTempColorMask
  • CXTPThreadLocal() : CXTPThreadLocal< T >
  • CXTPTimeEdit() : CXTPTimeEdit
  • CXTPTipOfTheDay() : CXTPTipOfTheDay
  • CXTPTipWindow() : CXTPTipWindow
  • CXTPToolBar() : CXTPToolBar
  • CXTPToolTipContext() : CXTPToolTipContext
  • CXTPToolTipContextToolTip() : CXTPToolTipContextToolTip
  • CXTPTrackBlock() : CXTPTrackBlock
  • CXTPTrackControl() : CXTPTrackControl
  • CXTPTrackControlItem() : CXTPTrackControlItem
  • CXTPTrackHeader() : CXTPTrackHeader
  • CXTPTrackKey() : CXTPTrackKey
  • CXTPTrackMarker() : CXTPTrackMarker
  • CXTPTrackMarkers() : CXTPTrackMarkers
  • CXTPTrackPaintManager() : CXTPTrackPaintManager
  • CXTPTrackSelectedBlocks() : CXTPTrackSelectedBlocks
  • CXTPTrackThemeDefault() : CXTPTrackThemeDefault
  • CXTPTrackThemeExplorer() : CXTPTrackThemeExplorer
  • CXTPTrackThemeNativeWindows10() : CXTPTrackThemeNativeWindows10
  • CXTPTrackThemeNativeWindows11() : CXTPTrackThemeNativeWindows11
  • CXTPTrackThemeOffice2003() : CXTPTrackThemeOffice2003
  • CXTPTrackThemeOffice2003Luna() : CXTPTrackThemeOffice2003Luna
  • CXTPTrackThemeOffice2013() : CXTPTrackThemeOffice2013
  • CXTPTrackThemeOfficeXP() : CXTPTrackThemeOfficeXP
  • CXTPTrackThemeResource() : CXTPTrackThemeResource
  • CXTPTrackThemeVisualStudio2012Blue() : CXTPTrackThemeVisualStudio2012Blue
  • CXTPTrackThemeVisualStudio2012Dark() : CXTPTrackThemeVisualStudio2012Dark
  • CXTPTrackThemeVisualStudio2012Light() : CXTPTrackThemeVisualStudio2012Light
  • CXTPTrackThemeVisualStudio2015() : CXTPTrackThemeVisualStudio2015
  • CXTPTrackThemeVisualStudio2017() : CXTPTrackThemeVisualStudio2017
  • CXTPTrackThemeVisualStudio2019() : CXTPTrackThemeVisualStudio2019
  • CXTPTrackThemeVisualStudio2022() : CXTPTrackThemeVisualStudio2022
  • CXTPTrackUndoAddBlockCommand() : CXTPTrackUndoAddBlockCommand
  • CXTPTrackUndoAddMarkerCommand() : CXTPTrackUndoAddMarkerCommand
  • CXTPTrackUndoCommand() : CXTPTrackUndoCommand
  • CXTPTrackUndoDeleteBlockCommand() : CXTPTrackUndoDeleteBlockCommand
  • CXTPTrackUndoDeleteMarkerCommand() : CXTPTrackUndoDeleteMarkerCommand
  • CXTPTrackUndoGroupCommand() : CXTPTrackUndoGroupCommand
  • CXTPTrackUndoManager() : CXTPTrackUndoManager
  • CXTPTrackUndoSetBlockPositionCommand() : CXTPTrackUndoSetBlockPositionCommand
  • CXTPTrackUndoSetMarkerPositionCommand() : CXTPTrackUndoSetMarkerPositionCommand
  • CXTPTransparentBitmap() : CXTPTransparentBitmap
  • CXTPTrayIcon() : CXTPTrayIcon
  • CXTPTreeBase() : CXTPTreeBase
  • CXTPTreeCtrl() : CXTPTreeCtrl
  • CXTPTreeNativeWindows10Theme() : CXTPTreeNativeWindows10Theme
  • CXTPTreeNativeWindows11Theme() : CXTPTreeNativeWindows11Theme
  • CXTPTreeOffice2013Theme() : CXTPTreeOffice2013Theme
  • CXTPTreeTheme() : CXTPTreeTheme
  • CXTPTreeView() : CXTPTreeView
  • CXTPTreeVisualStudio2012Theme() : CXTPTreeVisualStudio2012Theme
  • CXTPTreeVisualStudio2015Theme() : CXTPTreeVisualStudio2015Theme
  • CXTPTreeVisualStudio2017Theme() : CXTPTreeVisualStudio2017Theme
  • CXTPTreeVisualStudio2019Theme() : CXTPTreeVisualStudio2019Theme
  • CXTPTreeVisualStudio2022Theme() : CXTPTreeVisualStudio2022Theme
  • CXTPVisualStudio2005Theme() : CXTPVisualStudio2005Theme
  • CXTPVisualStudio2008Theme() : CXTPVisualStudio2008Theme
  • CXTPVisualStudio2010Theme() : CXTPVisualStudio2010Theme
  • CXTPWebBrowserCtrl() : CXTPWebBrowserCtrl
  • CXTPWebBrowserProvider() : CXTPWebBrowserProvider
  • CXTPWebViewProvider() : CXTPWebViewProvider
  • CXTPWinApp() : CXTPWinApp
  • CXTPWindowList() : CXTPWindowList
  • CXTPWindowPos() : CXTPWindowPos
  • CXTPWindowRect() : CXTPWindowRect
  • CXTPWinThemeWrapper() : CXTPWinThemeWrapper
  • CXTPWinThread() : CXTPWinThread
  • cyMenuItem : CXTPAuxData
  • cySize : CXTPAuxData
  • cySmIcon : CXTPAuxData
  • cyVThumb : CXTPAuxData


Toolkit Pro: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- d -

  • DataBind() : CXTPGridDataManager
  • DataProviderTypeFromConStr() : CXTPCalendarControl, CXTPCalendarData
  • DataSourceFromConStr() : CXTPCalendarControl, CXTPCalendarData
  • DatePickerMouseMode : CXTPDatePickerControl
  • DaylightBias : CXTPCalendarTimeZones::REGISTRY_TIMEZONE_INFORMATION
  • DaylightDate : CXTPCalendarTimeZones::REGISTRY_TIMEZONE_INFORMATION
  • dayPOS : XTP_CALENDAR_HITTESTINFO
  • DayView_IsAutoResetBusyFlag() : CXTPCalendarControl
  • DayView_SetAutoResetBusyFlag() : CXTPCalendarControl
  • DECLARE_DYNAMIC() : CXTPMDIFrameWndEx
  • DECLARE_DYNCREATE() : CXTPFrameWnd, CXTPMDIFrameWnd
  • DECLARE_MESSAGE_MAP() : CXTPSyntaxEditPropertiesDlg
  • DecreaseIndent() : CXTPSyntaxEditCtrl
  • Default() : CXTPHookManager
  • DefaultAnimation() : CXTPAnimationDC
  • DefaultAntialiasing : CXTPChartDiagram3DAppearance
  • DefaultLightAmbientColor : CXTPChartDiagram3DAppearance
  • DefaultLightDiffuseColor : CXTPChartDiagram3DAppearance
  • DefaultLightModelAmbientColor : CXTPChartDiagram3DAppearance
  • DefaultLightPosition : CXTPChartDiagram3DAppearance
  • DefaultLightSpecularColor : CXTPChartDiagram3DAppearance
  • DefaultMaterialDiffuseColor : CXTPChartDiagram3DAppearance
  • DefaultMaterialEmissionColor : CXTPChartDiagram3DAppearance
  • DefaultMaterialShininess : CXTPChartDiagram3DAppearance
  • DefaultMaterialSpecularColor : CXTPChartDiagram3DAppearance
  • Defer() : CXTPResize, CXTPTabExBase
  • DeflateEditRect() : CXTPControlComboBox, CXTPControlEdit
  • DeflateRect() : CXTPMarqueeCtrlPaintManager, CXTPMarqueeCtrlThemeFlat, CXTPMarqueeCtrlThemeNativeWindows, CXTPMarqueeCtrlThemeNativeWinXP, CXTPProgressCtrlPaintManager, CXTPProgressCtrlThemeFlat, CXTPProgressCtrlThemeNativeWindows, CXTPProgressCtrlThemeNativeWinXP, CXTPRectT< T >
  • Degree2Radian() : CXTPMathUtils
  • DelayLayout() : CXTPCommandBar
  • DelayLayoutParent() : CXTPControl
  • DelayRecalcFrameLayout() : CXTPCommandBarsFrameHook
  • DelayRedraw() : CXTPCommandBar, CXTPPopupBar
  • DelayRedrawParent() : CXTPControl
  • Delete() : CXTPGridRecord
  • DeleteAllItems() : CXTPExcelTabCtrl, CXTPTabManager
  • DeleteBookmark() : CXTPSyntaxEditCtrl
  • DeleteBreakpoint() : CXTPSyntaxEditCtrl
  • DeleteBuffer() : CXTPSyntaxEditCtrl
  • DeleteChar() : CXTPSyntaxEditCtrl
  • DeleteCharAt() : CXTPMaskEditT< TBase >
  • DeleteColor() : CXTPSyntaxEditColorComboBox
  • DeleteCustomValue() : CXTPCalendarViewPartCustomizableValueT< _TValue >
  • DeleteEvent() : CXTPCalendarData
  • DeleteGridRecords() : CXTPGridDataManager
  • DeleteImageList() : CXTPImageList
  • DeleteItem() : CXTPCalendarEventColorListBox, CXTPControlComboBox, CXTPEditListBox, CXTPExcelTabCtrl, CXTPTabManager
  • DeleteKey() : CXTPRegistryManager
  • DeleteLineMark() : CXTPSyntaxEditLineMarksManager
  • DeleteObject() : CXTPGdiObject
  • DeletePane() : CXTPDockingPane, CXTPDockingPaneBase, CXTPDockingPaneSplitterContainer
  • DeletePaneColorSets() : CXTPDockingPaneVisualStudio2012Theme
  • DeleteRecord() : CXTPGridDataManager
  • DeleteSelectedLines() : CXTPSyntaxEditCtrl
  • DeleteSelection() : CXTPSyntaxEditCtrl
  • DeleteStandardValue() : CXTPCalendarViewPartCustomizableValueT< _TValue >
  • DeleteText() : CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager, CXTPSyntaxEditBufferManager
  • DeleteToolBar() : CXTPReBar
  • DeleteValue() : CXTPRegistryManager
  • DeleteView() : CXTPTabExBase
  • DepthTest() : CXTPChart3dDeviceContext
  • Deselect() : CXTPDatePickerControl
  • DeselectBlock() : CXTPGridSelectedRows
  • Destroy() : CXTPSingletonPointer
  • DestroyAll() : CXTPDockingPaneManager
  • DestroyBorder() : CXTPGridRecordItem
  • DestroyDockingStickers() : CXTPDockingPaneContext
  • Destroyer : CXTPSingletonPointer
  • DestroyItem() : CXTPPropertyGridInplaceEdit, CXTPPropertyGridInplaceList
  • DestroyMetrics() : CXTPSkinManagerMetrics
  • DestroyPane() : CXTPDockingPaneManager
  • DestroyProc : CXTPThreadLocal< T >
  • DestroyWindow() : CXTPPopupBar, CXTPTearOffFrame
  • Detach() : CXTPCalendarRemindersDialog, CXTPDockingPane, CXTPImageList, CXTPImageManagerIconHandle, CXTPSmartPtrInternalT< _TObject >, CXTPTabClientWnd
  • DetermineRTL() : CXTPHeaderCtrl
  • dHeadGradientFactor : XTP_TASKPANEL_GROUPCOLORS
  • DirectDraw() : CXTPImageManagerIcon, CXTPImageManagerVectorImageHandle, CXTPSvgImage
  • Disable() : CXTPGridSubListControl
  • DisableBitmap() : CXTPImageManager
  • DisableColumnSizing() : CXTPListBase
  • DisableDraggingContents() : CXTPTabClientContext
  • DisableDwm() : CXTPCommandBarsFrameHook
  • DisableFrameTheme() : CXTPCommandBarsFrameHook
  • DisableLunaColors() : CXTPColorManager, CXTPTabPaintManager
  • DisableScrollbars() : IXTPScrollable
  • DisableShadow() : CXTPCommandBarsFrameHook, CXTPFrameShadowManager, CXTPPopupBar
  • DisableShortcuts() : CXTPShortcutManager
  • DisableTabContextWindow() : CXTPTabClientContext
  • DisableTabFocusRect() : CXTPTabClientContext
  • DisableTabSticker() : CXTPTabClientContext
  • Discard() : CXTPMemFile
  • Dismiss() : CXTPCalendarReminder, CXTPCalendarRemindersManager
  • DismissAll() : CXTPCalendarRemindersManager
  • DisplayShadow() : CXTPColorPopup
  • DispPosToStrPos() : CXTPSyntaxEditDrawTextProcessor
  • DistanceToPoint() : CXTPChartDiagram2DAxisView
  • DoAction() : CXTPTreeBase
  • DoAutoIndentIfNeed() : CXTPSyntaxEditCtrl
  • DoAutoVertScrollIfNeed() : CXTPGridControl
  • DoBanding() : CXTPTreeBase
  • DoChangeSelectionCase() : CXTPSyntaxEditCtrl
  • DoChangeSelectionTabify() : CXTPSyntaxEditCtrl
  • DockCommandBar() : CXTPCommandBars
  • dockDirection : XTP_DOCKINGPANE_ACTION
  • DockPane() : CXTPDockingPaneManager
  • DockRightOf() : CXTPCommandBarsSiteBase< TBase >
  • DockSidePane() : CXTPDockingPaneManager
  • DoCommonPropExchange() : CXTPFlowGraphNode
  • DoCreate_Event() : CXTPCalendarCustomDataProvider, CXTPCalendarData, CXTPCalendarDatabaseDataProvider, CXTPCalendarMemoryDataProvider
  • DoCreate_RPattern() : CXTPCalendarCustomDataProvider, CXTPCalendarData, CXTPCalendarDatabaseDataProvider, CXTPCalendarMemoryDataProvider
  • DoCustomDragOver() : CXTPControl, CXTPControlCustom, CXTPControlOleItems, CXTPControlPopup, CXTPControlRecentFileList, CXTPControlToolbars, CXTPControlWindowList, CXTPRibbonControlSystemRecentFileList
  • DoDelete_Event() : CXTPCalendarCustomDataProvider, CXTPCalendarData, CXTPCalendarDatabaseDataProvider, CXTPCalendarMemoryDataProvider
  • DoDelete_RPattern() : CXTPCalendarCustomDataProvider, CXTPCalendarData, CXTPCalendarDatabaseDataProvider, CXTPCalendarMemoryDataProvider
  • DoDeleteEvent() : CXTPCalendarControl
  • DoDeleteSelectedEvents() : CXTPCalendarControl
  • DoDeleteText() : CXTPSyntaxEditBufferCommand
  • DoDestroy() : CXTPCalendarThemeCustomizableXValueT< _TValue, _TValueRef >, CXTPCalendarThemeStringValue
  • DoDropDown() : CXTPButton
  • DoesFontExist() : CXTPFontEnum
  • DoExchangeCfg() : CXTPCalendarResourcesManager
  • DoGetAllEvents_raw() : CXTPCalendarCustomDataProvider, CXTPCalendarData, CXTPCalendarDatabaseDataProvider, CXTPCalendarMemoryDataProvider
  • DoGetUpcomingEvents() : CXTPCalendarCustomDataProvider, CXTPCalendarData, CXTPCalendarDatabaseDataProvider, CXTPCalendarMemoryDataProvider
  • DoInsertText() : CXTPSyntaxEditBufferCommand
  • DoModal() : CXTPBrowseDialog, CXTPCustomizeSheet, CXTPPropertySheet, CXTPTaskDialog
  • DoPaint() : CXTPProgressCtrl, CXTPTreeBase
  • DoPreSelection() : CXTPTreeBase
  • DoPropExchange() : CXTPCalendarCustomProperties, CXTPCalendarEvent, CXTPCalendarEventCategoryIDs, CXTPCalendarIconIDs, CXTPCalendarMemoryDataProvider, CXTPCalendarOptions, CXTPCalendarRecurrencePattern, CXTPCalendarSchedules, CXTPCalendarThemeBOOLValue, CXTPCalendarThemeCustomizableXValueT< _TValue, _TValueRef >, CXTPCalendarThemeIntValue, CXTPCalendarThemeRectValue, CXTPCalendarThemeStringValue, CXTPCalendarUIntArray, CXTPChart3dFunnelSeriesStyle, CXTPChart3dPieSeriesStyle, CXTPChart3dPyramidSeriesStyle, CXTPChartAppearance, CXTPChartAreaSeriesStyle, CXTPChartAxis, CXTPChartAxisAppearance, CXTPChartAxisConstantLine, CXTPChartAxisConstantLines, CXTPChartAxisCustomLabel, CXTPChartAxisCustomLabels, CXTPChartAxisGridLines, CXTPChartAxisLabel, CXTPChartAxisRange, CXTPChartAxisStrip, CXTPChartAxisStrips, CXTPChartAxisTickMarks, CXTPChartAxisTitle, CXTPChartBarSeriesLabel, CXTPChartBarSeriesStyle, CXTPChartBorder, CXTPChartBubbleSeriesStyle, CXTPChartContent, CXTPChartContentAppearance, CXTPChartDiagram2D, CXTPChartDiagram2DAppearance, CXTPChartDiagram2DSeriesLabel, CXTPChartDiagram2DSeriesStyle, CXTPChartDiagram3DAppearance, CXTPChartDiagram, CXTPChartElement, CXTPChartFastLineSeriesStyle, CXTPChartFillStyle, CXTPChartFinanceStyleAppearance, CXTPChartFunnelSeriesLabelBase, CXTPChartFunnelSeriesStyleBase, CXTPChartGanttSeriesStyle, CXTPChartLegend, CXTPChartLegendAppearance, CXTPChartLineSeriesStyle, CXTPChartMarker, CXTPChartNumberFormat, CXTPChartPalette, CXTPChartPanel, CXTPChartPanelCollection, CXTPChartPieSeriesLabelBase, CXTPChartPieSeriesStyleBase, CXTPChartPieStyleAppearance, CXTPChartPointSeriesLabel, CXTPChartPointSeriesStyle, CXTPChartPyramidSeriesLabelBase, CXTPChartPyramidSeriesStyleBase, CXTPChartRadarAreaSeriesStyle, CXTPChartRadarDiagram, CXTPChartRadarDiagramSeriesStyle, CXTPChartRadarLineSeriesStyle, CXTPChartRadarPointSeriesLabel, CXTPChartRadarPointSeriesStyle, CXTPChartRangeAreaSeriesLabel, CXTPChartRangeBarSeriesLabel, CXTPChartRangeBarSeriesStyle, CXTPChartSeries, CXTPChartSeriesCollection, CXTPChartSeriesLabel, CXTPChartSeriesPoint, CXTPChartSeriesPointCollection, CXTPChartSeriesStyle, CXTPChartStackedBarSeriesStyle, CXTPChartStepAreaSeriesStyle, CXTPChartStepLineSeriesStyle, CXTPChartTitle, CXTPChartTitleAppearance, CXTPChartTitleCollection, CXTPCommandBar, CXTPCommandBars, CXTPCommandBarsOptions, CXTPControl, CXTPControlAction, CXTPControlActions, CXTPControlButton, CXTPControlButtonColor, CXTPControlComboBox, CXTPControlComboBoxList, CXTPControlCustom, CXTPControlEdit, CXTPControlFontComboBoxList, CXTPControlGallery, CXTPControlListBox, CXTPControlPopup, CXTPControlProgress, CXTPControls, CXTPControlSelector, CXTPControlStatic, CXTPDockingPane, CXTPDockingPaneAutoHidePanel, CXTPDockingPaneBase, CXTPDockingPaneLayout, CXTPDockingPaneManager, CXTPDockingPaneMiniWnd, CXTPDockingPaneSidePanel, CXTPDockingPaneSplitterContainer, CXTPDockingPaneTabbedContainer, CXTPDockState, CXTPFlowGraphConnection, CXTPFlowGraphConnectionPoint, CXTPFlowGraphConnectionPoints, CXTPFlowGraphConnections, CXTPFlowGraphControl, CXTPFlowGraphNode, CXTPFlowGraphNodeCustom, CXTPFlowGraphNodes, CXTPFlowGraphPage, CXTPFlowGraphPages, CXTPGridColumn, CXTPGridColumnOrder, CXTPGridColumns, CXTPGridControl, CXTPGridHeader, CXTPGridHyperlink, CXTPGridHyperlinks, CXTPGridRecord, CXTPGridRecordItem, CXTPGridRecordItemButton, CXTPGridRecordItemControl, CXTPGridRecordItemControls, CXTPGridRecordItemDateTime, CXTPGridRecordItemNumber, CXTPGridRecordItemPreview, CXTPGridRecordItemText, CXTPGridRecordItemVariant, CXTPGridRecords, CXTPImageManager, CXTPMenuBar, CXTPPopupBar, CXTPRibbonControlTab, CXTPRibbonGroup, CXTPRibbonGroups, CXTPRibbonTab, CXTPShortcutManager, CXTPStatusBar, CXTPTaskPanelGroup, CXTPTaskPanelGroupItem, CXTPTaskPanelItem, CXTPTaskPanelItems, CXTPToolBar, CXTPTrackBlock, CXTPTrackControl, CXTPTrackControlItem, CXTPTrackMarker, CXTPTrackMarkers
  • DoPX_Value() : CXTPCalendarThemeBOOLValue, CXTPCalendarThemeIntValue, CXTPCalendarThemeRectValue, CXTPCalendarThemeStringValue
  • DoRead_Event() : CXTPCalendarCustomDataProvider, CXTPCalendarData, CXTPCalendarDatabaseDataProvider, CXTPCalendarMemoryDataProvider
  • DoRead_RPattern() : CXTPCalendarCustomDataProvider, CXTPCalendarData, CXTPCalendarDatabaseDataProvider, CXTPCalendarMemoryDataProvider
  • DoRedo() : CXTPSyntaxEditUndoRedoManager
  • DoRemoveAllEvents() : CXTPCalendarCustomDataProvider, CXTPCalendarData, CXTPCalendarDatabaseDataProvider, CXTPCalendarMemoryDataProvider
  • DoReplaceText() : CXTPSyntaxEditReplaceStringCommand
  • DoRetrieveDayEvents() : CXTPCalendarCustomDataProvider, CXTPCalendarData, CXTPCalendarDatabaseDataProvider, CXTPCalendarMemoryDataProvider
  • DoSlideStep() : CXTPDockingPaneMiniWnd, CXTPDockingPaneSidePanel
  • DoubleClickOpen() : CXTPShellSettings
  • DoubleToString() : CXTPPropertyGridItemDouble
  • DoUndo() : CXTPSyntaxEditUndoRedoManager
  • DoUndoRedo() : CXTPSyntaxEditCtrl
  • DoUpdate_Event() : CXTPCalendarCustomDataProvider, CXTPCalendarData, CXTPCalendarDatabaseDataProvider, CXTPCalendarMemoryDataProvider
  • DoUpdate_RPattern() : CXTPCalendarCustomDataProvider, CXTPCalendarData, CXTPCalendarDatabaseDataProvider, CXTPCalendarMemoryDataProvider
  • DoUpdateCustomizeMenuControl() : CXTPToolBar
  • DownColor : CXTPChartFinanceStyleAppearance
  • dpxThumb : XTP_SCROLLBAR_TRACKINFO
  • Drag() : CXTPDockingPaneContext
  • dragFieldChooser : CXTPGridHeader
  • Dragging() : CXTPGridSubListControl
  • dragInGroupBox : CXTPGridHeader
  • dragInHeader : CXTPGridHeader
  • dragInTarget : CXTPGridHeader
  • dragNothing : CXTPGridHeader
  • dragOutTarget : CXTPGridHeader
  • Draw() : CXTPCalendarCaptionBarTheme, CXTPCalendarCaptionBarThemePart, CXTPCalendarDayView, CXTPCalendarDayViewDay, CXTPCalendarDayViewEvent, CXTPCalendarDayViewGroup, CXTPCalendarDayViewTimeScale, CXTPCalendarMonthView::CMonthViewGrid, CXTPCalendarMonthView, CXTPCalendarMonthViewDay, CXTPCalendarMonthViewEvent, CXTPCalendarTimeLineView, CXTPCalendarTimeLineViewEvent, CXTPCalendarTimeLineViewGroup, CXTPCalendarTimeLineViewPart, CXTPCalendarTimeLineViewTimeScale, CXTPCalendarTimeLineViewTimeScalePart, CXTPCalendarView, CXTPCalendarViewDay, CXTPCalendarViewEvent, CXTPCalendarViewGroup, CXTPCalendarWeekView, CXTPCalendarWeekViewDay, CXTPCalendarWeekViewEvent, CXTPCheckboxButtonPart, CXTPCheckListBox::CCheckListState, CXTPControl, CXTPControlBitmap, CXTPControlButtonColor, CXTPControlColorSelector, CXTPControlCustom, CXTPControlGalleryItem, CXTPControlHyperlink, CXTPControlListBox, CXTPControlMarkupLabel, CXTPControlProgress, CXTPControlSelector, CXTPControlStatic, CXTPControlTabWorkspace, CXTPDateLabelPart, CXTPDatePickerItemDay, CXTPDatePickerItemMonth, CXTPExpandButtonPart, CXTPFlowGraphNode, CXTPGridGroupRow, CXTPGridHeader, CXTPGridRecordItem, CXTPGridRow, CXTPGridSection, CXTPGridSections, CXTPImageList, CXTPImageManagerIcon, CXTPImageManagerIconHandle, CXTPImageManagerImageList, CXTPImageManagerResource, CXTPImageManagerVectorImageHandle, CXTPPopupItem, CXTPProgressCtrlPaintManager, CXTPProgressCtrlThemeOffice2013, CXTPProgressCtrlThemeResource, CXTPRadioButtonPart, CXTPRibbonControlSystemButton, CXTPRibbonControlSystemPopupBarButton, CXTPRibbonControlSystemPopupBarListCaption, CXTPRibbonControlSystemPopupBarListItem, CXTPRibbonControlSystemPopupBarPinableListItem, CXTPRibbonControlTab, CXTPRibbonGroup, CXTPScrollDateButtonPart, CXTPSkinObjectFrame::CCaptionButton, CXTPSvgImage, CXTPSwitchViewButtonPart, CXTPSyntaxEditCtrl, CXTPTabManagerNavigateButton, CXTPTrackBlock, CXTPTrackControlItem, CXTPTrackHeader, CXTPTrackKey, IXTPPreview
  • Draw2() : CXTPCalendarDayView, CXTPCalendarMonthView, CXTPCalendarTimeLineView, CXTPCalendarView, CXTPCalendarWeekView
  • Draw3dRect() : CXTPPaintManager
  • DrawAlphaBitmap() : CXTPImageManagerIcon
  • DrawArrowGlyph() : CXTPScrollBarPaintManager, CXTPSpinButtonCtrl
  • DrawArrows() : CXTPScrollBarPaintManager, CXTPScrollBarThemeFlat, CXTPScrollBarThemeOffice2000, CXTPScrollBarThemeOffice2013, CXTPScrollBarThemeResource, CXTPScrollBarThemeVisualStudio2012
  • DrawAutoHidePanel() : CXTPDockingPaneNativeWindows10Theme, CXTPDockingPaneNativeWindows11Theme, CXTPDockingPaneOffice2013Theme, CXTPDockingPanePaintManager, CXTPDockingPaneVisualStudio2012Theme, CXTPDockingPaneVisualStudio2015Theme, CXTPDockingPaneVisualStudio2017Theme, CXTPDockingPaneVisualStudio2019Theme, CXTPDockingPaneVisualStudio2022Theme
  • DrawBackground() : CXTPComboBoxTheme, CXTPComboBoxThemeOffice2000, CXTPComboBoxThemeOffice2003, CXTPComboBoxThemeOffice2013, CXTPComboBoxThemeOfficeXPFlat, CXTPDatePickerPaintManager, CXTPDatePickerThemeOffice2013, CXTPMarqueeCtrlPaintManager, CXTPMarqueeCtrlThemeResource, CXTPPopupPaintManager, CXTPPopupThemeMSN, CXTPPopupThemeOffice2000, CXTPPopupThemeOffice2003, CXTPPopupThemeOfficeXP, CXTPScrollBarPaintManager, CXTPScrollBarThemeOffice2013, CXTPScrollBarThemeResource, CXTPScrollBarThemeVisualStudio2012, CXTPToolTipContextToolTip
  • DrawBackImage() : CXTPRibbonOffice2013Theme
  • DrawBigHourCell() : CXTPCalendarPaintManager
  • DrawBitmap() : CXTPCalendarPaintManager, CXTPGridPaintManager
  • DrawBorder() : CXTPCalendarPaintManager, CXTPColorSelectorCtrlThemeOffice2013, CXTPDatePickerPaintManager, CXTPDatePickerThemeOffice2013, CXTPTabBaseTheme, CXTPTabBaseThemeOffice2003, CXTPTabBaseThemeOfficeXP
  • DrawBorders() : CXTPCalendarCaptionBarTheme, CXTPTabBaseTheme, CXTPTabBaseThemeOfficeXP
  • DrawBuddyBorders() : CXTPEdit, CXTPEditTheme, CXTPEditThemeDefault, CXTPEditThemeOffice2000, CXTPEditThemeOfficeXP, CXTPEditThemeResource
  • DrawBusyStatus() : CXTPCalendarPaintManager
  • DrawButton() : CXTPButtonTheme, CXTPComboBoxTheme, CXTPComboBoxThemeNativeWindows10, CXTPComboBoxThemeNativeWindows11, CXTPComboBoxThemeOffice2000, CXTPComboBoxThemeOffice2003, CXTPComboBoxThemeOffice2013, CXTPComboBoxThemeOfficeXPFlat, CXTPComboBoxThemeVisualStudio2012, CXTPComboBoxThemeVisualStudio2015, CXTPComboBoxThemeVisualStudio2017, CXTPComboBoxThemeVisualStudio2019, CXTPComboBoxThemeVisualStudio2022, CXTPDatePickerPaintManager, CXTPDatePickerThemeOffice2003, CXTPDatePickerThemeOffice2013, CXTPDatePickerThemeResource, CXTPExcelTabCtrlTheme, CXTPExcelTabCtrlThemeOffice2013, CXTPMessageBar, CXTPPopupPaintManager, CXTPTabBaseTheme, CXTPTabBaseThemeOfficeXP, CXTPTaskButtonTheme, CXTPTaskButtonThemeExpando
  • DrawButtonBack() : CXTPExcelTabCtrlTheme, CXTPExcelTabCtrlThemeOffice2003, CXTPExcelTabCtrlThemeOffice2013, CXTPExcelTabCtrlThemeOfficeXP
  • DrawButtonBackground() : CXTPButtonTheme, CXTPButtonThemeFlat, CXTPButtonThemeOffice2000, CXTPButtonThemeOffice2003, CXTPButtonThemeOffice2013, CXTPButtonThemeOfficeXP, CXTPButtonThemeResource, CXTPButtonThemeUltraFlat, CXTPButtonThemeVisualStudio2012, CXTPCaptionButtonTheme, CXTPCaptionButtonThemeOffice2003, CXTPCaptionButtonThemeOfficeXP
  • DrawButtons() : CXTPDatePickerControl, CXTPMessageBar, CXTPScrollBarPaintManager, CXTPScrollBarThemeFlat, CXTPScrollBarThemeOffice2000, CXTPScrollBarThemeOffice2013, CXTPScrollBarThemeResource, CXTPScrollBarThemeVisualStudio2012, CXTPScrollBarThemeWindowsClassic, CXTPScrollBarThemeWindowsUx
  • DrawButtonText() : CXTPButtonTheme, CXTPCaptionButtonTheme, CXTPCaptionButtonThemeOfficeXP
  • DrawButtonTriangle() : CXTPComboBoxTheme, CXTPComboBoxThemeOffice2013
  • DrawButtonVisualStyleBackground() : CXTPButtonTheme
  • DrawCaption() : CXTPDockingPaneDefaultTheme, CXTPDockingPaneGripperedTheme, CXTPDockingPaneOffice2002VisioTheme, CXTPDockingPaneOffice2003Theme, CXTPDockingPaneOffice2007OutlookTheme, CXTPDockingPaneOffice2007Theme, CXTPDockingPaneOffice2007WordTheme, CXTPDockingPaneOffice2013Theme, CXTPDockingPanePaintManager, CXTPDockingPaneVisualStudio2012Theme, CXTPDockingPaneWinNativeTheme
  • DrawCaptionBack() : CXTPCaption, CXTPCaptionTheme, CXTPCaptionThemeOffice2003, CXTPCaptionThemeOfficeXP
  • DrawCaptionBar() : CXTPFramePaintManager, CXTPFrameThemeOffice2007System
  • DrawCaptionButton() : CXTPDockingPaneOffice2013Theme, CXTPDockingPanePaintManager, CXTPDockingPaneVisualStudio2012Theme
  • DrawCaptionButtonEntry() : CXTPDockingPanePaintManager
  • DrawCaptionButtons() : CXTPDockingPanePaintManager
  • DrawCaptionGripper() : CXTPTaskPanelExplorerThemePlain, CXTPTaskPanelPaintManager
  • DrawCaptionGripperBitmap() : CXTPTaskPanelPaintManager
  • DrawCaptionGripperSigns() : CXTPTaskPanelPaintManager
  • DrawCaptionIcon() : CXTPCaption, CXTPCaptionTheme
  • DrawCaptionPart() : CXTPDockingPaneDefaultTheme, CXTPDockingPaneGripperedTheme, CXTPDockingPaneOffice2003Theme, CXTPDockingPaneOffice2007WordTheme, CXTPDockingPaneVisualStudio2003Theme, CXTPDockingPaneVisualStudio6Theme, CXTPDockingPaneWinExplorerTheme, CXTPDockingPaneWinNativeTheme
  • DrawCaptionText() : CXTPCaption, CXTPCaptionTheme, CXTPDockingPanePaintManager, CXTPFramePaintManager, CXTPTaskPanelItem
  • DrawCategoryCaptionBackground() : CXTPPropertyGridPaintManager, CXTPPropertyGridVisualStudio2005Theme
  • DrawCell() : CXTPColorHex::CRgnCell
  • DrawCheckBox() : CXTPGridRecordItem, CXTPPropertyGridPaintManager
  • DrawCheckBoxMark() : CXTPButtonTheme, CXTPButtonThemeOffice2013, CXTPButtonThemeResource, CXTPButtonThemeUltraFlat, CXTPButtonThemeVisualStudio2012
  • DrawCheckMark() : CXTPPaintManager, CXTPPropertyGridOffice2007Theme, CXTPPropertyGridPaintManager
  • DrawCheckRect() : CXTPCommandBarsNativeWindows10Theme, CXTPCommandBarsNativeWindows11Theme, CXTPCommandBarsVisualStudio2015Theme, CXTPCommandBarsVisualStudio2017Theme, CXTPCommandBarsVisualStudio2019Theme, CXTPCommandBarsVisualStudio2022Theme
  • DrawChunk() : CXTPMarqueeCtrlPaintManager, CXTPMarqueeCtrlThemeResource
  • DrawClock() : CXTPCalendarPaintManager
  • DrawCloseButton() : CXTPDockingPaneCaptionButton
  • DrawCollapsed() : CXTPCalendarEventCategoryComboBox
  • DrawCollapsedBitmap() : CXTPGridPaintManager, CXTPGridThemeOffice2013, CXTPGridThemeResource, CXTPTrackThemeResource
  • DrawCollapsedTextMarks() : CXTPSyntaxEditPaintManager
  • DrawColor() : CXTPColorSelectorCtrlThemeOffice2013, CXTPEyeDropper
  • DrawColorCell() : CXTPColorSelectorCtrlTheme, CXTPColorSelectorCtrlThemeOffice2013, CXTPColorSelectorCtrlThemeVisualStudio2015
  • DrawColorSelector() : CXTPColorSelectorCtrl, CXTPColorSelectorCtrlTheme, CXTPColorSelectorCtrlThemeOffice2013
  • DrawColumn() : CXTPGridPaintManager, CXTPGridThemeOffice2003, CXTPTrackThemeOffice2003
  • DrawColumnBackground() : CXTPGridPaintManager, CXTPGridThemeDefault, CXTPGridThemeExplorer, CXTPGridThemeOffice2003, CXTPGridThemeOffice2003Luna, CXTPGridThemeOffice2013, CXTPGridThemeOfficeXP, CXTPGridThemeResource, CXTPTrackThemeDefault, CXTPTrackThemeExplorer, CXTPTrackThemeOffice2003, CXTPTrackThemeOffice2003Luna, CXTPTrackThemeOffice2013, CXTPTrackThemeOfficeXP, CXTPTrackThemeResource
  • DrawColumnFooter() : CXTPGridPaintManager
  • DrawColumnFooterDivider() : CXTPGridPaintManager, CXTPGridThemeOffice2003Luna, CXTPGridThemeResource, CXTPTrackThemeOffice2003Luna, CXTPTrackThemeResource
  • DrawColumnIcon() : CXTPGridPaintManager
  • DrawColumnText() : CXTPGridPaintManager, CXTPGridThemeOffice2013, CXTPGridThemeResource, CXTPTrackThemeOffice2013, CXTPTrackThemeResource
  • DrawComboBox() : CXTPComboBoxTheme, CXTPComboBoxThemeDefault, CXTPComboBoxThemeResource
  • DrawComboExpandMark() : CXTPPaintManager
  • DrawCommandBar() : CXTPCommandBar, CXTPControlComboBoxList, CXTPPopupBar, CXTPRibbonBar, CXTPRibbonTabPopupToolBar, CXTPTabToolBar
  • DrawCommandBarGripper() : CXTPCommandBarsNativeWindows10Theme, CXTPCommandBarsNativeWindows11Theme, CXTPCommandBarsNativeXPTheme, CXTPCommandBarsOffice2000Theme, CXTPCommandBarsOffice2003Theme, CXTPCommandBarsOffice2013Theme, CXTPCommandBarsOfficeXPTheme, CXTPCommandBarsVisualStudio2012Theme, CXTPCommandBarsVisualStudio2015Theme, CXTPCommandBarsVisualStudio2017Theme, CXTPCommandBarsVisualStudio2019Theme, CXTPCommandBarsVisualStudio2022Theme, CXTPPaintManager, CXTPRibbonTheme
  • DrawCommandBarGroupSeparator() : CXTPCommandBarsOffice2013Theme, CXTPPaintManager
  • DrawCommandBarSeparator() : CXTPCommandBarsNativeXPTheme, CXTPCommandBarsOffice2000Theme, CXTPCommandBarsOffice2003Theme, CXTPCommandBarsOffice2013Theme, CXTPCommandBarsOfficeXPTheme, CXTPCommandBarsVisualStudio2012Theme, CXTPPaintManager, CXTPRibbonTheme, CXTPVisualStudio2008Theme, CXTPVisualStudio2010Theme
  • DrawConnection() : CXTPFlowGraphPaintManager
  • DrawConnectionPoints() : CXTPFlowGraphNode
  • DrawConnector() : CXTPGridPaintManager
  • DrawContent() : CXTPChartContent, CXTPMessageBar
  • DrawControl() : CXTPPaintManager
  • DrawControlBackground() : CXTPFlowGraphPaintManager
  • DrawControlCheckBoxMark() : CXTPCommandBarsOffice2013Theme, CXTPCommandBarsOfficeXPTheme, CXTPCommandBarsVisualStudio2012Theme, CXTPPaintManager
  • DrawControlComboBox() : CXTPCommandBarsNativeWindows10Theme, CXTPCommandBarsNativeWindows11Theme, CXTPCommandBarsOffice2000Theme, CXTPCommandBarsOffice2013Theme, CXTPCommandBarsOfficeXPTheme, CXTPCommandBarsVisualStudio2012Theme, CXTPCommandBarsVisualStudio2015Theme, CXTPCommandBarsVisualStudio2017Theme, CXTPCommandBarsVisualStudio2019Theme, CXTPCommandBarsVisualStudio2022Theme, CXTPPaintManager, CXTPRibbonTheme
  • DrawControlComboBoxButton() : CXTPCommandBarsNativeXPTheme, CXTPCommandBarsOffice2000Theme
  • DrawControlEdit() : CXTPCommandBarsOffice2000Theme, CXTPCommandBarsOffice2013Theme, CXTPCommandBarsOfficeXPTheme, CXTPPaintManager, CXTPRibbonTheme
  • DrawControlEditFrame() : CXTPCommandBarsNativeXPTheme, CXTPCommandBarsOffice2000Theme
  • DrawControlEditSpin() : CXTPCommandBarsNativeXPTheme, CXTPCommandBarsOffice2000Theme
  • DrawControlEntry() : CXTPCommandBarsNativeXPTheme, CXTPPaintManager, CXTPRibbonTheme
  • DrawControlGroupOption() : CXTPRibbonMarkupTheme, CXTPRibbonPaintManager, CXTPRibbonThemeResource
  • DrawControlGroupPopup() : CXTPRibbonMarkupTheme, CXTPRibbonPaintManager, CXTPRibbonThemeResource
  • DrawControlMDIButton() : CXTPCommandBarsNativeXPTheme, CXTPCommandBarsOffice2013Theme, CXTPPaintManager
  • DrawControlPopupGlyph() : CXTPRibbonTheme
  • DrawControlPopupParent() : CXTPCommandBarsOffice2000Theme, CXTPCommandBarsOfficeXPTheme, CXTPPaintManager
  • DrawControlRadioButtonMark() : CXTPCommandBarsOffice2013Theme, CXTPCommandBarsOfficeXPTheme, CXTPPaintManager
  • DrawControlText() : CXTPPaintManager
  • DrawControlToolBarParent() : CXTPPaintManager
  • DrawCrossHair() : CXTPColorWnd
  • DrawDarkThemeExpander() : CXTPTreeBase
  • DrawDateHeader() : CXTPCalendarControlView
  • DrawDay() : CXTPDatePickerPaintManager, CXTPDatePickerThemeOffice2013
  • DrawDayHeader() : CXTPCalendarPaintManager
  • DrawDaysOfWeek() : CXTPDatePickerPaintManager, CXTPDatePickerThemeOffice2013
  • DrawDialogBarGripper() : CXTPCommandBarsNativeXPTheme, CXTPCommandBarsOffice2000Theme, CXTPCommandBarsOffice2003Theme, CXTPCommandBarsOfficeXPTheme, CXTPPaintManager
  • DrawDottedLine() : CXTPDockingPaneVisualStudio2012Theme
  • DrawDragArrow() : CXTPTaskPanelPaintManager
  • DrawDropDownGlyph() : CXTPCommandBarsOffice2013Theme, CXTPCommandBarsVisualStudio2012Theme, CXTPPaintManager
  • DrawDropper() : CXTPEyeDropper
  • DrawDwmCaptionText() : CXTPRibbonPaintManager
  • DrawEditText() : CXTPControlComboBox, CXTPControlEdit
  • DrawEntry() : CXTPTabManagerNavigateButton, CXTPToolTipContextToolTip
  • DrawEvent() : CXTPCalendarPaintManager, CXTPCalendarTimeLineViewPart
  • DrawEvents() : CXTPCalendarDayViewDay
  • DrawExpandButton() : CXTPPropertyGridNativeWindows10Theme, CXTPPropertyGridNativeWindows11Theme, CXTPPropertyGridOffice2007Theme, CXTPPropertyGridOffice2013Theme, CXTPPropertyGridPaintManager, CXTPPropertyGridVisualStudio2005Theme, CXTPPropertyGridVisualStudio2010Theme, CXTPPropertyGridVisualStudio2012Theme, CXTPPropertyGridVisualStudio2015Theme, CXTPPropertyGridVisualStudio2017Theme, CXTPPropertyGridVisualStudio2019Theme, CXTPPropertyGridVisualStudio2022Theme, CXTPShortcutBarOffice2013Theme, CXTPShortcutBarPaintManager, CXTPShortcutBarResourceTheme
  • DrawExpanded() : CXTPCalendarEventCategoryComboBox
  • DrawExpandGlyph() : CXTPCommandBarsOffice2013Theme, CXTPCommandBarsVisualStudio2012Theme, CXTPPaintManager
  • DrawExpandSigns() : CXTPCalendarPaintManager
  • DrawFlat() : CXTPSpinButtonCtrl
  • DrawFlatButton() : CXTPSpinButtonCtrl
  • DrawFloatingFrame() : CXTPDockingPaneDefaultTheme, CXTPDockingPaneGripperedTheme, CXTPDockingPaneOffice2002VisioTheme, CXTPDockingPaneOffice2003Theme, CXTPDockingPaneOffice2013Theme, CXTPDockingPanePaintManager, CXTPDockingPaneVisualStudio2010Theme, CXTPDockingPaneVisualStudio2012Theme, CXTPDockingPaneWinNativeTheme
  • DrawFocusedRow() : CXTPGridPaintManager, CXTPGridThemeOffice2013, CXTPTrackThemeOffice2013
  • DrawFocusRect() : CXTPButtonTheme, CXTPDockingPaneContext, CXTPTaskPanel, CXTPTaskPanelPaintManager
  • DrawFooter() : CXTPGridHeader
  • DrawFrame() : CXTPComboBoxTheme, CXTPEditTheme, CXTPFramePaintManager, CXTPRibbonMarkupFrameTheme
  • DrawFrameBorder() : CXTPCommandBarsOffice2013Theme, CXTPRibbonMarkupFrameTheme
  • DrawFrameCaptionButton() : CXTPFramePaintManager, CXTPFrameThemeOffice2007System
  • DrawFreezeColsDivider() : CXTPGridPaintManager
  • DrawGalleryItemBack() : CXTPCommandBarsNativeWindows10Theme, CXTPCommandBarsNativeWindows11Theme, CXTPCommandBarsOffice2013Theme, CXTPCommandBarsVisualStudio2015Theme, CXTPCommandBarsVisualStudio2017Theme, CXTPCommandBarsVisualStudio2019Theme, CXTPCommandBarsVisualStudio2022Theme, CXTPPaintManager
  • DrawGlyph() : CXTPGridPaintManager, CXTPGridThemeExplorer, CXTPTrackThemeExplorer
  • DrawGrid() : CXTPGridPaintManager
  • DrawGridPattern() : CXTPGridPaintManager
  • DrawGripper() : CXTPDockingPaneVisualStudio2012Theme, CXTPExcelTabCtrl, CXTPExcelTabCtrlTheme, CXTPExcelTabCtrlThemeOffice2013, CXTPScrollBarPaintManager, CXTPScrollBarThemeFlat, CXTPScrollBarThemeOffice2013, CXTPScrollBarThemeResource, CXTPScrollBarThemeVisualStudio2012, CXTPScrollBarThemeWindowsClassic, CXTPScrollBarThemeWindowsUx, CXTPShortcutBarOffice2000Theme, CXTPShortcutBarOffice2003Theme, CXTPShortcutBarOffice2013Theme, CXTPShortcutBarOfficeXPTheme, CXTPShortcutBarPaintManager, CXTPShortcutBarResourceTheme
  • DrawGroup() : CXTPCalendarPaintManager, CXTPRibbonMarkupTheme, CXTPRibbonPaintManager, CXTPRibbonThemeResource
  • DrawGroupBox() : CXTPButtonTheme, CXTPButtonThemeOffice2013, CXTPButtonThemeUltraFlat
  • DrawGroupByControl() : CXTPGridHeader
  • DrawGroupCaption() : CXTPTaskPanelPaintManager, CXTPTaskPanelPaintManagerPlain, CXTPTaskPanelToolboxTheme
  • DrawGroupCaptionBackground() : CXTPTaskPanelListViewOffice2003Theme, CXTPTaskPanelShortcutBarOffice2003Theme, CXTPTaskPanelShortcutBarOffice2007Theme, CXTPTaskPanelToolboxTheme, CXTPTaskPanelVisualStudio2005Theme, CXTPTaskPanelVisualStudio2010Theme, CXTPTaskPanelVisualStudio2012Theme
  • DrawGroupClient() : CXTPTaskPanelPaintManager
  • DrawGroupClientFace() : CXTPTaskPanelPaintManager, CXTPTaskPanelPaintManagerPlain, CXTPTaskPanelShortcutBarOffice2003Theme, CXTPTaskPanelShortcutBarOffice2007Theme, CXTPTaskPanelVisualStudio2005Theme, CXTPTaskPanelVisualStudio2010Theme, CXTPTaskPanelVisualStudio2012Theme
  • DrawGroupClientItems() : CXTPTaskPanelPaintManager
  • DrawGroupItem() : CXTPTaskPanelPaintManager
  • DrawGroupItemFrame() : CXTPTaskPanelPaintManager, CXTPTaskPanelShortcutBarOffice2007Theme, CXTPTaskPanelVisualStudio2012Theme
  • DrawGroupItemImage() : CXTPTaskPanelPaintManager
  • DrawGroupItemImageWithText() : CXTPTaskPanelPaintManager
  • DrawGroupItemImageWithTextBelow() : CXTPTaskPanelPaintManager
  • DrawGroupRow() : CXTPGridPaintManager, CXTPGridThemeOffice2013, CXTPTrackThemeOffice2013
  • DrawHeader() : CXTPCalendarOffice2013Theme, CXTPCalendarPaintManager, CXTPCalendarTimeLineViewTimeScalePart, CXTPHeaderCtrlTheme
  • DrawHiddenGlyph() : CXTPCommandBarsOffice2013Theme, CXTPCommandBarsVisualStudio2012Theme, CXTPPaintManager
  • DrawHorizontalLine() : CXTPCalendarPaintManager, CXTPGridPaintManager
  • DrawHourCell() : CXTPCalendarPaintManager
  • DrawIcon() : CXTPDockingPaneAutoHidePanel, CXTPDockingPaneTabbedContainer, CXTPRibbonControlTab, CXTPTabControl, CXTPTabManager, CXTPTabToolBar
  • DrawIconChar() : CXTPCalendarPaintManager
  • DrawIconComposited() : CXTPImageManagerIcon
  • DrawIcons() : CXTPCalendarPaintManager
  • DrawImage() : CXTPButton, CXTPCommandBarsOffice2000Theme, CXTPCommandBarsOfficeXPTheme, CXTPPaintManager, CXTPResourceImage, CXTPShortcutBarOffice2000Theme, CXTPShortcutBarOffice2003Theme, CXTPShortcutBarOfficeXPTheme, CXTPShortcutBarPaintManager, CXTPShortcutListBoxTheme, CXTPShortcutListBoxThemeOffice2003, CXTPShortcutListBoxThemeOfficeXP, CXTPSkinImage, CXTPTabManagerItem
  • DrawImageFlipped() : CXTPResourceImage
  • DrawImagePart() : CXTPResourceImage
  • DrawIndirect() : CXTPImageList
  • DrawInplaceButton() : CXTPGridPaintManager
  • DrawInplaceButtonFrame() : CXTPGridPaintManager
  • DrawInplaceButtonIcon() : CXTPGridPaintManager
  • DrawInplaceButtons() : CXTPPropertyGridPaintManager
  • DrawInplaceComboButton() : CXTPGridPaintManager
  • DrawInplaceExpandButton() : CXTPGridPaintManager
  • DrawInplaceListItem() : CXTPPropertyGridPaintManager
  • DrawInplaceSpinButton() : CXTPGridPaintManager
  • DrawItem() : CXTPCalendarBusyStatusComboBox, CXTPCalendarEventCategoryComboBox, CXTPCalendarEventLabelComboBox, CXTPControlComboBoxList, CXTPListBoxTheme, CXTPListBoxThemeDefault, CXTPListBoxThemeOffice2003, CXTPListBoxThemeOffice2013, CXTPListBoxThemeOfficeXP, CXTPListBoxThemeResource, CXTPPopupPaintManager, CXTPPropertyGridCoolTheme, CXTPPropertyGridDelphiTheme, CXTPPropertyGridPaintManager, CXTPPropertyGridSimpleTheme, CXTPShortcutListBoxTheme, CXTPTreeBase
  • DrawItemBitmap() : CXTPGridPaintManager
  • DrawItemCaption() : CXTPGridPaintManager, CXTPPropertyGridPaintManager, CXTPTaskPanelPaintManager, CXTPTaskPanelVisualStudio2012Theme
  • DrawItemControl() : CXTPGridPaintManager
  • DrawItemIcon() : CXTPPopupPaintManager
  • DrawItemImage() : CXTPTaskPanelPaintManager
  • DrawItems() : CXTPControlGallery
  • DrawItemText() : CXTPListBoxTheme
  • DrawItemValue() : CXTPPropertyGridPaintManager
  • DrawKeyboardTip() : CXTPRibbonTheme
  • DrawLabel() : CXTPControlGalleryPaintManager, CXTPControlGalleryResourceTheme
  • DrawLine() : CXTPCalendarPaintManager
  • DrawLine_CenterLR() : CXTPCalendarViewPart
  • DrawLineCalcSel() : CXTPSyntaxEditPaintManager
  • DrawLineEx() : CXTPCalendarViewPart
  • DrawLineMark() : CXTPSyntaxEditPaintManager
  • DrawLineMarks() : CXTPSyntaxEditPaintManager
  • DrawLineNode() : CXTPSyntaxEditPaintManager
  • DrawLineNodeBackground() : CXTPSyntaxEditPaintManager
  • DrawLineNumber() : CXTPSyntaxEditPaintManager
  • DrawLineNumbersBorder() : CXTPSyntaxEditPaintManager
  • DrawLineTextEx() : CXTPSyntaxEditPaintManager
  • DrawLink() : CXTPGridPaintManager
  • DrawListBoxControl() : CXTPCommandBarsOffice2000Theme, CXTPCommandBarsOfficeXPTheme, CXTPPaintManager
  • DrawLuminanceBar() : CXTPColorLum
  • DrawMarkers() : CXTPTrackPaintManager
  • DrawMarkupItem() : CXTPMarkupTreeCtrl
  • DrawMarquee() : CXTPMarqueeCtrlPaintManager, CXTPMarqueeCtrlThemeFlat
  • DrawMaximizeRestoreButton() : CXTPDockingPaneCaptionButton
  • DrawMenuButton() : CXTPDockingPaneCaptionButton
  • DrawMessageBarButton() : CXTPMessageBarPaintManager, CXTPMessageBarThemeOffice2010, CXTPMessageBarThemeOffice2013
  • DrawMono() : CXTPImageManagerIcon
  • DrawMonthHeader() : CXTPDatePickerPaintManager, CXTPDatePickerThemeOffice2000
  • DrawMultiLineText() : CXTPGridPaintManager
  • DrawNavigateButton() : CXTPTabPaintManager
  • DrawNavigationItem() : CXTPShortcutBarPaintManager
  • DrawNcBorders() : CXTPEditTheme, CXTPEditThemeDefault, CXTPEditThemeOffice2000, CXTPEditThemeOfficeXP, CXTPListBoxTheme, CXTPListBoxThemeOffice2013, CXTPProgressCtrl, CXTPProgressCtrlPaintManager, CXTPProgressCtrlThemeOffice2000, CXTPProgressCtrlThemeOffice2003, CXTPProgressCtrlThemeOffice2013, CXTPProgressCtrlThemeOfficeXP
  • DrawNcBordersDefault() : CXTPEditThemeDefault
  • DrawNcScrollBack() : CXTPEditTheme, CXTPEditThemeDefault
  • DrawNodeGroup() : CXTPFlowGraphPaintManager
  • DrawNoGroupByText() : CXTPGridPaintManager, CXTPGridThemeResource, CXTPTrackThemeResource
  • DrawNoItems() : CXTPGridControl
  • DrawNowLine() : CXTPCalendarPaintManager
  • DrawOffice2007() : CXTPSpinButtonCtrl
  • DrawPane() : CXTPDockingPaneOffice2002VisioTheme, CXTPDockingPaneOffice2007WordTheme, CXTPDockingPaneOffice2013Theme, CXTPDockingPanePaintManager, CXTPDockingPaneVisualStudio2012Theme
  • DrawPaneCaption() : CXTPShortcutBarOffice2003Theme, CXTPShortcutBarPaintManager, CXTPShortcutBarResourceTheme
  • DrawPaneEntry() : CXTPStatusBar
  • DrawPaneItemCaption() : CXTPShortcutBarNativeWindows10Theme, CXTPShortcutBarNativeWindows11Theme, CXTPShortcutBarOffice2003Theme, CXTPShortcutBarOffice2013Theme, CXTPShortcutBarPaintManager, CXTPShortcutBarResourceTheme, CXTPShortcutBarVisualStudio2015Theme, CXTPShortcutBarVisualStudio2017Theme, CXTPShortcutBarVisualStudio2019Theme, CXTPShortcutBarVisualStudio2022Theme
  • DrawParentBackground() : CXTPTabManager
  • DrawPinButton() : CXTPDockingPaneCaptionButton
  • DrawPopupBarCheckMark() : CXTPCommandBarsNativeXPTheme, CXTPPaintManager, CXTPRibbonTheme
  • DrawPopupBarGripper() : CXTPCommandBarsNativeXPTheme, CXTPCommandBarsOffice2003Theme, CXTPCommandBarsOffice2013Theme, CXTPCommandBarsOfficeXPTheme, CXTPCommandBarsVisualStudio2012Theme, CXTPPaintManager, CXTPRibbonTheme, CXTPVisualStudio2008Theme, CXTPVisualStudio2010Theme
  • DrawPopupBarRadioMark() : CXTPCommandBarsNativeXPTheme, CXTPPaintManager, CXTPRibbonTheme
  • DrawPopupResizeGripper() : CXTPCommandBarsOffice2000Theme, CXTPCommandBarsOfficeXPTheme, CXTPPaintManager, CXTPRibbonTheme
  • DrawPopupScrollBar() : CXTPControlGalleryOffice2013Theme, CXTPControlGalleryPaintManager, CXTPControlGalleryResourceTheme
  • DrawProgress() : CXTPProgressPaintManager, CXTPProgressThemeOffice2013
  • DrawPropertyGridBorder() : CXTPPropertyGridPaintManager
  • DrawPushButtonDropDown() : CXTPButtonTheme, CXTPButtonThemeOffice2013
  • DrawPushButtonIcon() : CXTPButtonTheme, CXTPButtonThemeOffice2013
  • DrawPushButtonText() : CXTPButtonTheme, CXTPButtonThemeOffice2013
  • DrawQuickAccessControl() : CXTPRibbonOffice2013Theme, CXTPRibbonPaintManager
  • DrawRadioButtonMark() : CXTPButtonTheme, CXTPButtonThemeOffice2013, CXTPButtonThemeResource, CXTPButtonThemeUltraFlat, CXTPButtonThemeVisualStudio2012
  • DrawRadioMark() : CXTPPropertyGridOffice2007Theme, CXTPPropertyGridPaintManager
  • DrawRectangle() : CXTPCommandBarsNativeWindows10Theme, CXTPCommandBarsNativeWindows11Theme, CXTPCommandBarsNativeXPTheme, CXTPCommandBarsOffice2000Theme, CXTPCommandBarsOffice2003Theme, CXTPCommandBarsOffice2013Theme, CXTPCommandBarsOfficeXPTheme, CXTPCommandBarsVisualStudio2012Theme, CXTPCommandBarsVisualStudio2015Theme, CXTPCommandBarsVisualStudio2017Theme, CXTPCommandBarsVisualStudio2019Theme, CXTPCommandBarsVisualStudio2022Theme, CXTPPaintManager, CXTPRibbonTheme, CXTPVisualStudio2008Theme, CXTPVisualStudio2010Theme
  • DrawReverted() : CXTPImageManager
  • DrawRibbonApplicationIcon() : CXTPRibbonPaintManager
  • DrawRibbonFrameCaption() : CXTPRibbonMarkupTheme, CXTPRibbonOffice2013Theme, CXTPRibbonPaintManager, CXTPRibbonThemeResource
  • DrawRibbonFrameCaptionBar() : CXTPRibbonMarkupTheme, CXTPRibbonOffice2013Theme, CXTPRibbonPaintManager, CXTPRibbonThemeResource
  • DrawRibbonFrameContextHeaders() : CXTPRibbonMarkupTheme, CXTPRibbonOffice2013Theme, CXTPRibbonPaintManager, CXTPRibbonThemeNativeWindows10, CXTPRibbonThemeNativeWindows11, CXTPRibbonThemeResource
  • DrawRibbonFramePart() : CXTPCommandBarsFrameHook, CXTPRibbonPaintManager
  • DrawRibbonFrameSystemButton() : CXTPRibbonMarkupTheme, CXTPRibbonOffice2013Theme, CXTPRibbonPaintManager, CXTPRibbonThemeResource
  • DrawRibbonGroupControlEntry() : CXTPRibbonMarkupTheme, CXTPRibbonPaintManager, CXTPRibbonThemeResource
  • DrawRibbonGroupPopupToolBar() : CXTPRibbonMarkupTheme, CXTPRibbonPaintManager
  • DrawRibbonQuickAccessButton() : CXTPRibbonMarkupTheme, CXTPRibbonPaintManager, CXTPRibbonThemeOffice2007System, CXTPRibbonThemeResource
  • DrawRibbonQuickAccessControls() : CXTPRibbonMarkupTheme, CXTPRibbonThemeOffice2007System, CXTPRibbonThemeResource
  • DrawRibbonQuickAccessMoreButton() : CXTPRibbonMarkupTheme, CXTPRibbonPaintManager, CXTPRibbonThemeResource
  • DrawRibbonScrollButton() : CXTPRibbonMarkupTheme, CXTPRibbonPaintManager, CXTPRibbonThemeResource
  • DrawRibbonTab() : CXTPRibbonMarkupTheme, CXTPRibbonOffice2013Theme, CXTPRibbonPaintManager, CXTPRibbonThemeNativeWindows10, CXTPRibbonThemeNativeWindows11, CXTPRibbonThemeResource
  • DrawRowNumber() : CXTPGridPaintManager
  • DrawRowPart() : CXTPSyntaxEditDrawTextProcessor
  • DrawRows() : CXTPGridControl, CXTPTrackControl
  • DrawScrollBar() : CXTPScrollBarPaintManager, CXTPScrollBarThemeOffice2013, CXTPScrollBarThemeResource, CXTPScrollBarThemeVisualStudio2012, CXTPScrollBarThemeVisualStudio2015, CXTPScrollBarThemeVisualStudio2017, CXTPScrollBarThemeVisualStudio2019, CXTPScrollBarThemeVisualStudio2022, CXTPSliderPaintManager
  • DrawScrollButton() : CXTPTaskPanelPaintManager
  • DrawScrollTriangle() : CXTPDatePickerPaintManager
  • DrawSectionDivider() : CXTPGridPaintManager, CXTPGridThemeExplorer, CXTPGridThemeOffice2003, CXTPGridThemeOffice2003Luna, CXTPGridThemeResource, CXTPTrackThemeExplorer, CXTPTrackThemeOffice2003, CXTPTrackThemeOffice2003Luna, CXTPTrackThemeResource
  • DrawSelection() : CXTPColorHex::CRgnCell
  • DrawSelectionRect() : CXTPFlowGraphNode
  • DrawShadow() : CXTPCalendarPaintManager
  • DrawShadowRect() : CXTPTipWindow
  • DrawShadowRectPart() : CXTPCalendarShadowDrawer
  • DrawShellIcon() : CXTPGridPaintManager
  • DrawShortcutBarFrame() : CXTPShortcutBarOffice2000Theme, CXTPShortcutBarOffice2003Theme, CXTPShortcutBarOfficeXPTheme, CXTPShortcutBarPaintManager
  • DrawShortcutItem() : CXTPShortcutBarPaintManager
  • DrawSidePanel() : CXTPDockingPaneDefaultTheme, CXTPDockingPaneOffice2003Theme, CXTPDockingPaneOffice2013Theme, CXTPDockingPanePaintManager, CXTPDockingPaneVisualStudio2012Theme, CXTPDockingPaneWinNativeTheme
  • DrawSingleButton() : CAppearanceSetPropertyPage2003, CAppearanceSetPropertyPage2007, CAppearanceSetPropertyPageAccess2007, CAppearanceSetPropertyPageFlat, CAppearanceSetPropertyPageSelected, CAppearanceSetStateButtons, CAppearanceSetVisio, CAppearanceSetVisualStudio2005, CXTPDockingPanePanelTheme2012, CXTPDockingPaneTabTheme2012, CXTPDockingPaneTabTheme2013, CXTPDockingPaneTabTheme2015, CXTPDockingPaneTabTheme2017, CXTPDockingPaneTabTheme2019, CXTPDockingPaneTabTheme2022, CXTPDockingPaneTabThemeNativeWindows10, CXTPDockingPaneTabThemeNativeWindows11, CXTPTabPaintManagerTheme, CXTPTabThemeExcel2003, CXTPTabThemeFlat, CXTPTabThemeOffice2000, CXTPTabThemeVisualStudio2003, CXTPTabThemeVisualStudio2010, CXTPTabThemeVisualStudio2012
  • DrawSingleButtonIconAndText() : CXTPTabPaintManager
  • DrawSingleLineText() : CXTPGridPaintManager
  • DrawSliderArrow() : CXTPColorLum
  • DrawSortArrow() : CXTPHeaderCtrlTheme, CXTPHeaderCtrlThemeExplorer, CXTPHeaderCtrlThemeResource
  • DrawSpecialControl() : CXTPCommandBarsNativeXPTheme, CXTPCommandBarsOffice2000Theme, CXTPCommandBarsOffice2003Theme, CXTPPaintManager, CXTPRibbonTheme
  • DrawSplitButtonFrame() : CXTPCommandBarsNativeWindows10Theme, CXTPCommandBarsNativeWindows11Theme, CXTPCommandBarsNativeXPTheme, CXTPCommandBarsOffice2000Theme, CXTPCommandBarsOffice2013Theme, CXTPCommandBarsOfficeXPTheme, CXTPCommandBarsVisualStudio2012Theme, CXTPCommandBarsVisualStudio2015Theme, CXTPCommandBarsVisualStudio2017Theme, CXTPCommandBarsVisualStudio2019Theme, CXTPCommandBarsVisualStudio2022Theme, CXTPPaintManager, CXTPRibbonTheme
  • DrawSplitButtonPopup() : CXTPRibbonTheme
  • DrawSplitter() : CXTPDockingPaneNativeWindows10Theme, CXTPDockingPaneNativeWindows11Theme, CXTPDockingPaneOffice2013Theme, CXTPDockingPanePaintManager, CXTPDockingPaneVisualStudio2012Theme, CXTPDockingPaneVisualStudio2015Theme, CXTPDockingPaneVisualStudio2017Theme, CXTPDockingPaneVisualStudio2019Theme, CXTPDockingPaneVisualStudio2022Theme, CXTPSplitterWndTheme, CXTPSplitterWndThemeOffice2003, CXTPSplitterWndThemeVisualStudio2010
  • DrawStandard() : CXTPSpinButtonCtrl
  • DrawStatusBarButtonFace() : CXTPStatusBarThemeOffice2013
  • DrawStatusBarGripper() : CXTPRibbonTheme, CXTPStatusBarThemeNativeWindows10, CXTPStatusBarThemeNativeWindows11, CXTPStatusBarThemeOffice2013, CXTPStatusBarThemeVisualStudio2015, CXTPStatusBarThemeVisualStudio2017, CXTPStatusBarThemeVisualStudio2019, CXTPStatusBarThemeVisualStudio2022
  • DrawStatusBarPaneBorder() : CXTPRibbonTheme, CXTPStatusBarThemeOffice2013
  • DrawStatusBarPaneEntry() : CXTPStatusBarThemeOffice2013
  • DrawStatusBarPaneSeparator() : CXTPRibbonTheme, CXTPStatusBarThemeOffice2013
  • DrawStatusBarSwitchPane() : CXTPRibbonTheme, CXTPStatusBarThemeOffice2013
  • DrawStretch() : CXTPStatusBar
  • DrawString() : CXTPGridPaintManager
  • DrawSubj() : CXTPCalendarPaintManager
  • DrawSystemPopupBarButton() : CXTPRibbonMarkupTheme, CXTPRibbonPaintManager, CXTPRibbonThemeResource
  • DrawTab() : CXTPExcelTabCtrlTheme, CXTPExcelTabCtrlThemeOffice2013, CXTPTabBaseTheme
  • DrawTabControl() : CAppearanceSetVisio, CXTPTabPaintManager, CXTPTabPaintManagerTheme
  • DrawTabControlEx() : CXTPTabPaintManager
  • DrawTabCtrl() : CXTPTabBaseTheme
  • DrawTabIcon() : CXTPTabBaseTheme, CXTPTabBaseThemeOfficeXP
  • DrawTabText() : CXTPTabBaseTheme
  • DrawTearOffGripper() : CXTPCommandBarsOffice2000Theme, CXTPCommandBarsOffice2003Theme, CXTPCommandBarsOfficeXPTheme, CXTPPaintManager
  • DrawText() : CXTPCalendarViewPart, CXTPDockingPaneTabTheme2012, CXTPEditListBoxToolBar, CXTPProgressCtrlPaintManager, CXTPShortcutListBoxTheme, CXTPShortcutListBoxThemeOfficeXP, CXTPTabPaintManagerTheme
  • DrawTextLine() : CXTPGridPaintManager
  • DrawTextPathEllipsis() : CXTPTabPaintManager
  • DrawThemeBackground() : CXTPSkinManagerClass, CXTPWinThemeWrapper
  • DrawThemeBackgroundEx() : CXTPWinThemeWrapper
  • DrawThemeEdge() : CXTPWinThemeWrapper
  • DrawThemeIcon() : CXTPWinThemeWrapper
  • DrawThemeParentBackground() : CXTPWinThemeWrapper
  • DrawThemeText() : CXTPSkinManagerClass, CXTPWinThemeWrapper
  • DrawThemeTextEx() : CXTPWinThemeWrapper
  • DrawThumbButton() : CXTPScrollBarPaintManager, CXTPScrollBarThemeFlat, CXTPScrollBarThemeOffice2013, CXTPScrollBarThemeResource, CXTPScrollBarThemeVisualStudio2012, CXTPScrollBarThemeWindowsUx
  • DrawTimeLine() : CXTPTrackPaintManager
  • DrawTimes() : CXTPCalendarPaintManager
  • DrawTip() : CXTPSyntaxEditTipWnd
  • DrawTitleBar() : CXTPDockingPaneNativeWindows10Theme, CXTPDockingPaneNativeWindows11Theme, CXTPDockingPaneOffice2013Theme, CXTPDockingPaneVisualStudio2012Theme, CXTPDockingPaneVisualStudio2015Theme, CXTPDockingPaneVisualStudio2017Theme, CXTPDockingPaneVisualStudio2019Theme, CXTPDockingPaneVisualStudio2022Theme
  • DrawTopmostLayer() : CXTPCalendarDayViewDay
  • DrawTracker() : CXTPScrollBarPaintManager, CXTPScrollBarThemeFlat, CXTPScrollBarThemeResource, CXTPScrollBarThemeWindowsClassic, CXTPScrollBarThemeWindowsUx
  • DrawTrackHeader() : CXTPTrackPaintManager
  • DrawTransparentRectangle() : CXTPFlowGraphPaintManager
  • DrawTreeStructure() : CXTPGridPaintManager
  • DrawTriangle() : CXTPGridPaintManager, CXTPGridThemeExplorer, CXTPGridThemeOffice2013, CXTPGridThemeResource, CXTPTrackThemeExplorer, CXTPTrackThemeOffice2013, CXTPTrackThemeResource
  • DrawVerticalLine() : CXTPCalendarPaintManager, CXTPGridPaintManager
  • DrawVerticalTimeLineMarker() : CXTPGridPaintManager
  • DrawVisualStyle() : CXTPSpinButtonCtrl
  • DrawWatermark() : CXTPGridControl
  • DrawWeekNumbers() : CXTPDatePickerPaintManager, CXTPDatePickerThemeOffice2013
  • DrawWindowContent() : CXTPFlowGraphNode, CXTPFlowGraphNodeCustom
  • DrawWorkspacePart() : CXTPTabPaintManagerTheme, CXTPTabThemeVisualStudio2012
  • dropEffect : XTP_NM_GRIDDRAGDROP
  • Dropped() : CXTPGridSubListControl
  • dt : XTP_CALENDAR_HITTESTINFO
  • dtBegin : XTP_CALENDAR_VIEWSELECTION
  • dtBeginTime : XTP_CALENDAR_DAYVIEWCELL_PARAMS, XTP_CALENDAR_THEME_DAYVIEWCELL_PARAMS, XTP_CALENDAR_THEME_DAYVIEWTIMESCALECELL_PARAMS
  • dtEnd : XTP_CALENDAR_VIEWSELECTION
  • dtScaleMaxTime : CXTPCalendarOptions
  • dtScaleMinTime : CXTPCalendarOptions
  • dtWorkDayEndTime : CXTPCalendarOptions
  • dtWorkDayStartTime : CXTPCalendarOptions
  • DumpTraits() : CXTPGaugeBaseType
  • Duplicate() : CXTPControls, CXTPMemFile
  • DuplicateItem() : CXTPShellPidl
  • dwAdditionalOptions : CXTPCalendarOptions
  • dwConnectionID : CXTPNotifyConnection::CONNECTION_DESCRIPTOR, CXTPNotifySinkBase::ADVISE_DESCRIPTOR
  • dwData : CXTPSortClass::ITEMDATA
  • dwExStyle : CXTPTcbItem
  • dwKeyState : XTP_NM_GRIDDRAGDROP
  • dwNotifyCode : CXTPNotifyConnection::CONNECTION_DESCRIPTOR, CXTPNotifySinkBase::ADVISE_DESCRIPTOR
  • dwScrollBar : XTP_EDIT_NMHDR_ENABLESCROLLBAR
  • dwState : XTP_EDIT_NMHDR_ENABLESCROLLBAR
  • dwStyle : CXTPColorSelectorCtrl::COLOR_CELL, CXTPTcbItem
  • dwType : CXTPLogFont
  • dwUpdate : XTP_EDIT_NMHDR_SETSCROLLPOS


Toolkit Pro: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- e -

  • editAscii : CXTPHexEdit
  • editHigh : CXTPHexEdit
  • EditItem() : CXTPEditListBox, CXTPGridControl
  • EditListItem() : CXTPEditListBox
  • editLow : CXTPHexEdit
  • EditMode : CXTPHexEdit
  • editNone : CXTPHexEdit
  • EditOnClick() : CXTPGridControl
  • EditOnDelayClick() : CXTPGridControl
  • EditOnDoubleClick() : CXTPGridControl
  • ElementAt() : CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE >
  • EmptySection() : CXTPPropExchange, CXTPPropExchangeIniFile, CXTPPropExchangeRegistry, CXTPPropExchangeXMLNode
  • EmptyUndoBuffer() : CXTPCalendarView
  • Enable() : CXTPCheckListBox
  • Enable3dEdgeSmoothing() : CXTPChartSeriesStyle
  • EnableActions() : CXTPCommandBars
  • EnableAnimation() : CXTPCommandBar, CXTPShortcutBar, CXTPTaskPanel
  • EnableAutoComplete() : CXTPControlComboBox
  • EnableAutoCompletion() : CXTPComboBox
  • EnableAutoInit() : CXTPShellTreeCtrl
  • EnableAutomaticUpdate() : CXTPGaugeBaseType
  • EnableAutoPreviewActivate() : CXTPPreviewCtrl
  • EnableAutoSize() : CXTPHeaderCtrl
  • EnableBorder() : CXTPSplitterWnd
  • EnableButton() : CXTPTaskDialog
  • EnableButtons() : CXTPExcelTabCtrl
  • EnableCallbackTimer() : CXTPTaskDialog
  • EnableCancellation() : CXTPTaskDialog
  • EnableCaret() : CXTPHexEdit
  • EnableCommandLinks() : CXTPTaskDialog
  • EnableContextMenu() : CXTPShellListBase, CXTPShellTreeBase
  • EnableControls() : CXTPCustomizeKeyboardPage, CXTPSyntaxEditFindReplaceDlg, CXTPSyntaxEditPropertiesPageColor
  • EnableCurrentThread() : CXTPSkinManager
  • EnableCustomFont() : CXTPPaintManagerFont
  • EnableCustomization() : CXTPCommandBar, CXTPCommandBars, CXTPStatusBar
  • EnableDefaultBorderDrawing() : CXTPScrollable< Base >
  • EnableDefaultItemDrawing() : CXTPTreeBase
  • EnableDefaultResetCustomizedToolbarChoice() : CXTPCommandBars
  • EnableDocking() : CXTPCommandBars, CXTPToolBar
  • EnableDotTracker() : CXTPSplitterWnd
  • EnableDoubleBuffer() : CXTPCommandBar
  • EnableDoubleBuffering() : CXTPGridControl
  • EnableDpiBitmapScaling() : CXTPCommandBarsOptions, CXTPHeaderCtrl, CXTPPopupControl, CXTPToolTipContext
  • EnableDpiGalleryItemScaling() : CXTPCommandBarsOptions
  • EnableDragDrop() : CXTPGridControl
  • EnableDraggingContents() : CXTPTabClientContext
  • EnableEdit() : CXTPEditListBox, CXTPEditListBoxToolBar
  • EnableEditAccelerators() : CXTPSyntaxEditCtrl
  • EnableFloatingFrameTheme() : CXTPDockingPaneManager, CXTPTabClientContext
  • EnableFocusRect() : CXTPTagCloudCtrl
  • EnableFrameTheme() : CXTPCommandBars, CXTPCommandBarsFrameHook, CXTPRibbonBar
  • EnableFullDrag() : CXTPSplitterWnd
  • EnableGdiPlus() : CXTPMarkupContext
  • EnableHScroll() : CXTPCalendarView
  • EnableHyperlinks() : CXTPTaskDialog
  • EnableKeyboardNavigate() : CXTPDockingPaneManager
  • EnableMarkup() : CXTPButton, CXTPCalendarControl, CXTPChartContent, CXTPComboBox, CXTPControlGalleryItems, CXTPFlowGraphControl, CXTPGridControl, CXTPMessageBar, CXTPPopupControl, CXTPPropertyGrid, CXTPStatusBar, CXTPTabClientWnd, CXTPTabManager, CXTPTaskDialog, CXTPTaskPanel, CXTPTipOfTheDay
  • EnableMenuItem() : CXTPShortcutListBox
  • EnableMessageBoxStyle() : CXTPTaskDialog
  • EnableMinimize() : CXTPTaskDialog
  • EnableMulticolumns() : CXTPCalendarCaptionBarControl
  • EnableMultiSelect() : CXTPPropertyGrid, CXTPTreeBase
  • EnableNoSize() : CXTPSplitterWnd
  • EnableOkButton() : CXTPCalendarEventColorNewDlg
  • EnableOleDrag() : CXTPSyntaxEditCtrl
  • EnableParser() : CXTPSyntaxEditBufferManager
  • EnablePopupMenus() : CXTPHeaderCtrl
  • EnablePreviewMode() : CXTPGridControl, CXTPGridPaintManager
  • EnableRadioButton() : CXTPTaskDialog
  • EnableRedraw() : CXTPTabExBase
  • EnableRelativePosition() : CXTPTaskDialog
  • EnableReminders() : CXTPCalendarControl
  • EnableResize() : CXTPGridColumn
  • EnableRtlLayout() : CXTPTaskDialog
  • EnableScrollBar() : CXTPScrollBarContainer< Parent >
  • EnableScrollBarCtrl() : CXTPFlowGraphControl, CXTPSyntaxEditCtrl
  • EnableScrollBars() : CXTPHexEdit
  • EnableSendNotifications() : CXTPCalendarControl
  • EnableShadow() : CXTPCommandBarsFrameHook, CXTPFrameShadowManager
  • EnableShellAutoComplete() : CXTPControlComboBox, CXTPControlEdit
  • EnableShellExecute() : CXTPHyperLink
  • EnableSideDocking() : CXTPDockingPaneManager
  • EnableSwitch() : CXTPStatusBarSwitchPane
  • EnableSystemSounds() : CXTPSoundManager
  • EnableSysYearMonthFormat() : CXTPDatePickerControl
  • EnableTabColors() : CXTPSplitterWndTheme
  • EnableTabContextWindow() : CXTPTabClientContext
  • EnableTabFocusRect() : CXTPTabClientContext
  • EnableTabSticker() : CXTPTabClientContext
  • EnableTabThemeTexture() : CXTPTabManager
  • EnableTheme() : CXTPCalendarPaintManager, CXTPDatePickerPaintManager
  • EnableThemeDialogTexture() : CXTPSkinManager, CXTPWinThemeWrapper
  • EnableTheming() : CXTPWinThemeWrapper
  • EnableTimeline() : CXTPCalendarCaptionBarControl
  • EnableToolbarComposition() : CXTPCommandBars
  • EnableTooltip() : CXTPTagCloudCtrl
  • EnableToolTips() : CXTPCalendarControl, CXTPChartControl, CXTPGridControl, CXTPHyperLink, CXTPPropertyGrid, CXTPTabClientWnd, CXTPTabControl, CXTPTabCtrl, CXTPTabPaintManager
  • EnableToolTipsEx() : CXTPTabExBase
  • EnableUndoManager() : CXTPFlowGraphUndoManager
  • EnableUserListColor() : CXTPListBase
  • EnableUserRowColor() : CXTPListBase
  • EnableUserSortColor() : CXTPListBase
  • EnableVirtualSpace() : CXTPSyntaxEditCtrl
  • EnableVScroll() : CXTPCalendarView
  • EnableWhiteSpace() : CXTPSyntaxEditCtrl
  • END_VIEW_PART() : CXTPCalendarPaintManager
  • EndBufferedPaint() : CXTPWinThemeWrapper
  • EndChildren() : CXTPSyntaxEditLexTextBlock
  • EndEdit() : CXTPCalendarEventColorListBox
  • EndEditSubject() : CXTPCalendarView, CXTPCalendarViewEvent
  • EndFrequentUpdates() : CXTPChartContainer
  • EndGroup() : CXTPFlowGraphUndoManager, CXTPTrackUndoManager
  • EndLabelEdit() : CXTPItemEdit
  • EndSelection() : CXTPColorPopup, CXTPColorSelectorCtrl
  • EndUpdate() : CXTPGridControl, CXTPPropertyGrid
  • EnsureFocusedRowVisible() : CXTPGridControl
  • EnsureStartAutoVertScroll() : CXTPGridControl
  • EnsureStopAutoVertScroll() : CXTPGridControl
  • EnsureStopDelayEditTimer() : CXTPGridControl
  • EnsureStopLastRqstTimer() : CXTPGridControl
  • EnsureVisible() : CXTPCalendarDayView, CXTPCommandBar, CXTPControlGallery, CXTPDatePickerControl, CXTPDockingPaneManager, CXTPGridColumn, CXTPGridControl, CXTPGridRow, CXTPGridSections, CXTPPropertyGridItem, CXTPRibbonBar, CXTPRibbonTabPopupToolBar, CXTPTabManager, CXTPTabPaintManager, CXTPTaskPanel, CXTPTaskPanelGroup, CXTPTaskPanelItem, CXTPTrackControl
  • EnsureVisibleCol() : CXTPSyntaxEditCtrl
  • EnsureVisibleFocus() : CXTPDatePickerControl
  • EnsureVisibleH() : CXTPCalendarDayView
  • EnsureVisibleRow() : CXTPSyntaxEditCtrl
  • EnsureVisibleSelection() : CXTPDatePickerControl
  • Enter() : CXTPSimpleCriticalSection
  • EnterCritical() : CXTPCriticalSection
  • EnumCustomTraits() : CXTPGaugeTraits
  • EnumFontFamExProc() : CXTPFontEnum
  • EnumFontFamiliesEx() : CXTPControlFontComboBoxList
  • EnumKeys() : CXTPRegistryManager
  • EnumParams : CXTPCalendarMsgNotifier
  • EnumValues() : CXTPRegistryManager
  • eOperation : XTP_EVENT_EDIT_OPERATION_PARAMS
  • Equals() : CXTPMatrix< T >, CXTPRectT< T >
  • EventsMapByID_T() : CXTPCalendarData::EventsMapByID_T< _TObject >
  • EventType : CXTPCalendarReminder
  • evtNormal : CXTPCalendarReminder
  • evtRecurrence : CXTPCalendarReminder
  • ExchangeBlobProp() : CXTPPropExchange, CXTPPropExchangeArchive, CXTPPropExchangeRegistry
  • ExchangeEventPlace() : CXTPCalendarViewGroup
  • ExchangeLocale() : CXTPPropExchange
  • ExchangeObjectInstance() : CXTPPropExchange, CXTPPropExchangeArchive
  • ExchangeProp() : CXTPPropExchange, CXTPPropExchangeArchive, CXTPPropExchangeIniFile, CXTPPropExchangeRegistry, CXTPPropExchangeXMLNode
  • ExchangeRuntimeClass() : CXTPPropExchange, CXTPPropExchangeArchive
  • ExchangeSchema() : CXTPPropExchange
  • Exclude() : CXTPResizeGroupBox
  • ExcludeCorners() : CXTPCommandBarsOffice2003Theme
  • ExcludeDocTemplate() : CXTPControl
  • ExcludeModule() : CXTPSkinManager
  • Execute() : CXTPChartDeviceCommand, CXTPChartDeviceContext, CXTPSyntaxEditBatchCommand, CXTPSyntaxEditCommand, CXTPSyntaxEditDeleteStringCommand, CXTPSyntaxEditInsertStringCommand, CXTPSyntaxEditReplaceStringCommand
  • ExecuteInternal() : CXTPChartTextDeviceCommand
  • ExecuteOverride() : CXTPChart3dFunnelSeriesLabelDeviceCommand, CXTPChart3dFunnelSeriesLabelsViewDeviceCommand, CXTPChart3dPieSeriesLabelsViewDeviceCommand, CXTPChart3dPyramidSeriesLabelDeviceCommand, CXTPChart3dPyramidSeriesLabelsViewDeviceCommand, CXTPChartDeviceCommand, CXTPChartTextDeviceCommand
  • ExecuteScript() : CXTPShellExplorerProvider, CXTPWebBrowserCtrl, CXTPWebBrowserProvider, CXTPWebViewProvider
  • ExistsScheduleID() : CXTPCalendarResource
  • Expand() : CXTPDockingPaneMiniWnd, CXTPDockingPaneSidePanel, CXTPPropertyGridItem, CXTPSearchOptionsCtrl
  • ExpandAll() : CXTPGridControl, CXTPGridSection, CXTPSyntaxEditCtrl
  • ExpandBar() : CXTPPopupBar
  • ExpandChars() : CXTPSyntaxEditCtrl, CXTPSyntaxEditDrawTextProcessor
  • ExpandCommandBar() : CXTPControlPopup
  • ExpandedByDefault() : CXTPTaskDialog
  • ExpandFooterArea() : CXTPTaskDialog
  • ExpandGroup() : CXTPTaskPanel
  • Extend() : CXTPMarkupStaticExtension
  • Extract() : CXTPMemFile
  • ExtractIcon() : CXTPImageList
  • ExtractLinks() : CXTPTaskDialogLinkCtrl


Toolkit Pro: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- f -

  • fGradientFactor : CXTPPaintManagerColorGradient
  • fHitOld : XTP_SCROLLBAR_TRACKINFO
  • file : XTP_URI
  • FillBackground() : CXTPColorSelectorCtrlTheme, CXTPExcelTabCtrlTheme, CXTPExcelTabCtrlThemeOffice2013
  • FillButton() : CXTPTabPaintManagerTheme
  • FillButtons() : CXTPTabBaseTheme, CXTPTabBaseThemeOffice2003, CXTPTabBaseThemeOfficeXP
  • FillCaptionPart() : CXTPDockingPaneVisualStudio2003Theme, CXTPDockingPaneVisualStudio2005Beta2Theme, CXTPDockingPaneVisualStudio2010Theme
  • FillClient() : CColorSetWinNative, CXTPTabPaintManagerColorSet
  • FillCommandBarEntry() : CXTPCommandBar, CXTPCommandBarsNativeWindows11Theme, CXTPCommandBarsNativeXPTheme, CXTPCommandBarsOffice2000Theme, CXTPCommandBarsOffice2003Theme, CXTPCommandBarsOffice2013Theme, CXTPCommandBarsOfficeXPTheme, CXTPCommandBarsVisualStudio2012Theme, CXTPPaintManager, CXTPReBarPaintManager< TBase >, CXTPRibbonSystemPopupBar, CXTPRibbonTheme, CXTPVisualStudio2010Theme
  • FillControl() : CXTPControlGalleryOffice2013Theme, CXTPControlGalleryPaintManager, CXTPControlGalleryResourceTheme
  • FillDockBar() : CXTPCommandBarsNativeWindows11Theme, CXTPCommandBarsNativeXPTheme, CXTPCommandBarsOffice2003Theme, CXTPCommandBarsOffice2013Theme, CXTPCommandBarsVisualStudio2012Theme, CXTPPaintManager
  • FillDockBarRect() : CXTPCommandBarsNativeXPTheme
  • FillFooter() : CXTPGridPaintManager, CXTPGridThemeOffice2003Luna, CXTPGridThemeResource, CXTPTrackThemeOffice2003Luna, CXTPTrackThemeResource
  • FillFramePartRect() : CXTPDockingPaneTabColorSetVisualStudio2003
  • FillGroupByControl() : CXTPGridPaintManager
  • FillGroupClientFace() : CXTPTaskPanelPaintManager, CXTPTaskPanelPaintManagerPlain, CXTPTaskPanelShortcutBarOffice2003Theme, CXTPTaskPanelShortcutBarOffice2007Theme, CXTPTaskPanelVisualStudio2005Theme, CXTPTaskPanelVisualStudio2010Theme, CXTPTaskPanelVisualStudio2012Theme
  • FillGroupPopupToolBar() : CXTPRibbonMarkupTheme, CXTPRibbonPaintManager, CXTPRibbonThemeResource
  • FillGroupRect() : CXTPRibbonMarkupTheme, CXTPRibbonPaintManager, CXTPRibbonThemeNativeWindows10, CXTPRibbonThemeNativeWindows11, CXTPRibbonThemeResource
  • FillGroupRowMetrics() : CXTPGridPaintManager, CXTPGridThemeOffice2013, CXTPTrackThemeOffice2013
  • FillHeader() : CXTPDockingPaneTabColorSet2012, CXTPDockingPaneTabColorSet2013, CXTPDockingPaneTabColorSet2015, CXTPDockingPaneTabColorSet2017, CXTPDockingPaneTabColorSet2019, CXTPDockingPaneTabColorSet2022, CXTPDockingPaneTabColorSetNativeWindows10, CXTPDockingPaneTabColorSetNativeWindows11, CXTPDockingPaneTabColorSetVisualStudio2003, CXTPTabBaseTheme, CXTPTabBaseThemeOffice2003, CXTPTabBaseThemeOfficeXP, CXTPTabColorSetVisualStudio2010, CXTPTabPaintManagerColorSet
  • FillHeaderControl() : CXTPGridPaintManager
  • FillHitTestEx() : CXTPCalendarDayViewDay, CXTPCalendarDayViewGroup, CXTPCalendarMonthViewDay, CXTPCalendarMonthViewGroup, CXTPCalendarTimeLineViewGroup, CXTPCalendarViewDay, CXTPCalendarViewDayT< _TView, _TViewGroup, XTP_CALENDAR_HITTESTINFO, _TPThis >, CXTPCalendarViewGroup, CXTPCalendarViewGroupT< _TViewDay, _TViewEvent, _TPThis >, CXTPCalendarWeekViewDay, CXTPCalendarWeekViewGroup
  • FillIndent() : CXTPGridPaintManager
  • FillInplaceButton() : CXTPPropertyGridOffice2007Theme, CXTPPropertyGridPaintManager
  • FillIntersectRect() : CXTPCommandBarsOfficeXPTheme
  • FillItemShade() : CXTPGridPaintManager
  • FillMDIClientWindowList() : CXTPWindowList
  • FillMDIWindowList() : CXTPWindowList
  • FillMessageBar() : CXTPMessageBar, CXTPMessageBarPaintManager, CXTPMessageBarThemeOffice2010, CXTPMessageBarThemeOffice2013
  • FillMetrics() : CXTPGridRow
  • FillMorePopupToolBarEntry() : CXTPRibbonMarkupTheme, CXTPRibbonPaintManager, CXTPRibbonThemeResource
  • FillNavigateButton() : CColorSetVisualStudio2003, CColorSetWinNative, CXTPDockingPanePanelColorSet2012, CXTPDockingPaneTabColorSet2012, CXTPDockingPaneTabColorSet2013, CXTPTabColorSetDefault, CXTPTabColorSetOffice2003, CXTPTabColorSetOffice2007, CXTPTabColorSetOffice2013, CXTPTabColorSetVisualStudio2010, CXTPTabColorSetVisualStudio2012, CXTPTabColorSetVisualStudio2015, CXTPTabPaintManager, CXTPTabPaintManagerColorSet
  • FillNavigationItemEntry() : CXTPShortcutBarNativeWindows10Theme, CXTPShortcutBarNativeWindows11Theme, CXTPShortcutBarOffice2003Theme, CXTPShortcutBarOffice2013Theme, CXTPShortcutBarPaintManager, CXTPShortcutBarResourceTheme, CXTPShortcutBarVisualStudio2015Theme, CXTPShortcutBarVisualStudio2017Theme, CXTPShortcutBarVisualStudio2019Theme, CXTPShortcutBarVisualStudio2022Theme
  • FillPopupLabelEntry() : CXTPRibbonTheme
  • FillPropertyButton() : CColorSetVisualStudio2005, CColorSetWinNative, CXTPDockingPaneTabColorSetVisualStudio2003, CXTPTabColorSetOffice2003, CXTPTabColorSetOffice2013, CXTPTabColorSetVisualStudio2008, CXTPTabColorSetVisualStudio2010, CXTPTabColorSetVisualStudio2015, CXTPTabPaintManagerColorSet
  • FillPropertyGrid() : CXTPPropertyGridPaintManager
  • FillPropertyGridView() : CXTPPropertyGridPaintManager
  • FillRect() : CXTPEditTheme
  • FillRibbonBar() : CXTPRibbonMarkupTheme, CXTPRibbonOffice2013Theme, CXTPRibbonPaintManager, CXTPRibbonThemeResource
  • FillRibbonTabControl() : CXTPRibbonMarkupTheme, CXTPRibbonPaintManager, CXTPRibbonThemeResource
  • FillRow() : CXTPGridPaintManager
  • FillShortcutBar() : CXTPShortcutBarNativeWinXPTheme, CXTPShortcutBarOffice2000Theme, CXTPShortcutBarOffice2003Theme, CXTPShortcutBarOffice2013Theme, CXTPShortcutBarOfficeXPTheme, CXTPShortcutBarPaintManager, CXTPShortcutBarResourceTheme
  • FillShortcutItemEntry() : CXTPShortcutBarNativeWindows10Theme, CXTPShortcutBarNativeWindows11Theme, CXTPShortcutBarNativeWinXPTheme, CXTPShortcutBarOffice2000Theme, CXTPShortcutBarOffice2003Theme, CXTPShortcutBarOffice2013Theme, CXTPShortcutBarOfficeXPTheme, CXTPShortcutBarPaintManager, CXTPShortcutBarResourceTheme, CXTPShortcutBarVisualStudio2015Theme, CXTPShortcutBarVisualStudio2017Theme, CXTPShortcutBarVisualStudio2019Theme, CXTPShortcutBarVisualStudio2022Theme
  • FillSolidRect() : CXTPComboBoxTheme
  • FillStateButton() : CColorSetWinNative, CXTPTabPaintManagerColorSet
  • FillStatusBar() : CXTPRibbonTheme, CXTPStatusBarThemeOffice2013
  • FillSystemPopupBarEntry() : CXTPRibbonMarkupTheme, CXTPRibbonPaintManager, CXTPRibbonThemeResource
  • FillTabControl() : CAppearanceSetPropertyPage2003, CAppearanceSetPropertyPage2007, CAppearanceSetPropertyPageAccess2007, CAppearanceSetStateButtons, CXTPTabPaintManagerTheme, CXTPTabThemeFlat, CXTPTabThemeOffice2000, CXTPTabThemeVisualStudio2003
  • FillTabFace() : CXTPTabBaseTheme, CXTPTabBaseThemeOffice2003, CXTPTabBaseThemeOfficeXP
  • FillTabFaceNativeWinXP() : CXTPTabBaseTheme
  • FillTabPopupToolBar() : CXTPRibbonPaintManager
  • FillTabs() : CXTPSyntaxEditCtrl
  • FillTabsBackground() : CXTPExcelTabCtrlTheme, CXTPExcelTabCtrlThemeOffice2013
  • FillTaskPanel() : CXTPTaskPanelOffice2013Theme, CXTPTaskPanelPaintManager, CXTPTaskPanelPaintManagerPlain, CXTPTaskPanelShortcutBarOffice2003Theme, CXTPTaskPanelShortcutBarOffice2007Theme, CXTPTaskPanelVisualStudio2005Theme, CXTPTaskPanelVisualStudio2010Theme, CXTPTaskPanelVisualStudio2012Theme
  • FillWorkspace() : CXTPCommandBarsOffice2013Theme, CXTPPaintManager, CXTPResourceTheme
  • FilterEventsByScheduleID() : CXTPCalendarResource
  • FilterExStyle() : IXTPScrollable
  • FilterStyle() : IXTPScrollable
  • FilterWindow() : IXTPSkinManagerWindowFilter
  • FilterWindowClass() : IXTPSkinManagerWindowFilter
  • Find() : CXTPCalendarEventCategories, CXTPCalendarEventLabels, CXTPCalendarEvents, CXTPCalendarPtrCollectionT< _TObject >, CXTPCalendarReminderForOccurrenceArray, CXTPCalendarReminders, CXTPCalendarResources, CXTPCalendarTimeZones, CXTPCalendarUIntArray, CXTPCalendarViewEvents, CXTPDatePickerButtons, CXTPGridColumns, CXTPGridRows, CXTPMouseManager::CTrackArray, CXTPPropertyGridInplaceButtons, CXTPPropertyGridItems, CXTPSyntaxEditCtrl, CXTPTaskPanelItems
  • FindAccel() : CXTPCommandBar
  • FindAccelEx() : CXTPCommandBar
  • FindAction() : CXTPCommandBars, CXTPControlActions
  • FindBand() : CXTPReBar
  • FindButton() : CXTPMessageBar
  • FindByDataProvider() : CXTPCalendarResourcesNf
  • FindCaptionButton() : CXTPDockingPaneBase
  • FindCategory() : CXTPCustomizeCommandsPage, CXTPCustomizeKeyboardPage
  • FindChildPane() : CXTPDockingPaneSplitterContainer
  • FindColor() : CXTPSyntaxEditColorComboBox
  • FindCommandBar() : CXTPCommandBarList
  • FindConnection() : CXTPNotifyConnection
  • FindConnectionPoint() : CXTPFlowGraphConnectionPoints
  • FindConnectionPointByCaption() : CXTPFlowGraphConnectionPoints
  • FindConstraint() : CXTPGridRecordItemEditOptions, CXTPPropertyGridItemConstraints
  • FindControl() : CXTPCommandBars, CXTPControls, CXTPRibbonGroup
  • FindData() : CXTPMemFile
  • FindDefaultAccelerator() : CXTPShortcutManager
  • FindDefaultFrameAccelerator() : CXTPShortcutManager
  • FindDuplicate() : CXTPRibbonQuickAccessControls
  • FindElement() : CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE >
  • FindEvent() : CXTPCalendarEvents
  • FindEventToEditByTAB() : CXTPCalendarDayView, CXTPCalendarView
  • FindException() : CXTPCalendarRecurrencePattern
  • FindExceptionIndex() : CXTPCalendarRecurrencePattern
  • FindExceptions() : CXTPCalendarRecurrencePattern
  • FindExtension() : CXTPMarkupStaticExtension
  • FindGroup() : CXTPRibbonBar, CXTPRibbonTab, CXTPTaskPanel
  • FindGroupByColumn() : CXTPGridHeader
  • FindHeaderColumn() : CXTPGridHeader
  • FindIndex() : CXTPCalendarEventCategories, CXTPCalendarEventLabels, CXTPCalendarSchedules, CXTPCommandBars, CXTPTabClientWnd
  • FindInsertionPos() : CXTPGridRows
  • FindInTree() : CXTPGridRows
  • FindItem() : CXTPControlGallery, CXTPPropertyGrid, CXTPPropertyGridItems, CXTPShortcutBar, CXTPTabClientWnd, CXTPTaskPanel, CXTPTaskPanelGroup, CXTPTreeBase
  • FindItemData() : CXTPGridSubListControl
  • FindItemExact() : CXTPTreeBase
  • FindItemImpl() : CXTPTreeBase
  • FindItemInBranch() : CXTPTreeBase
  • FindLastSelectedDay() : CXTPCalendarView
  • FindMinMaxGroupDayEvents() : CXTPCalendarDayViewGroup
  • FindNavigateButton() : CXTPTabManager
  • FindNextFocusable() : CXTPTabManager
  • FindNextLineMark() : CXTPSyntaxEditLineMarksManager
  • FindNode() : CXTPFlowGraphNodes
  • FindPage() : CXTPFlowGraphPages
  • FindPane() : CXTPDockingPaneBase, CXTPDockingPaneBaseContainer, CXTPDockingPaneManager, CXTPDockingPaneMiniWnd, CXTPStatusBar
  • FindPrevLineMark() : CXTPSyntaxEditLineMarksManager
  • FindRecordByBookmark() : CXTPGridRecords
  • FindRecordItem() : CXTPGridRecords
  • FindRecordItemByRows() : CXTPGridRows
  • FindResource() : CXTPResourceManager
  • FindRowAdjacentToMerged() : CXTPGridPaintManager
  • FindRowAdjacentToMergedEx() : CXTPGridPaintManager
  • FindSchema() : CXTPSyntaxEditTextSchemesManager
  • FindString() : CXTPControlComboBox
  • FindStringExact() : CXTPControlComboBox
  • FindSwitch() : CXTPStatusBarSwitchPane
  • FindTab() : CXTPRibbonBar, CXTPRibbonControlTab
  • FindTargetTabClient() : CXTPTabClientContext
  • FindTreeItem() : CXTPShellTreeBase
  • FindViewEvent() : CXTPCalendarView
  • FindWord() : CXTPSyntaxEditCtrl
  • FindWordEx() : CXTPSyntaxEditCtrl
  • FindWordEx_str() : CXTPSyntaxEditCtrl
  • FitFieldWidths() : CXTPHeaderCtrl
  • FitToContent() : CXTPPopupItem
  • FloatCommandBar() : CXTPCommandBars
  • FloatPane() : CXTPDockingPaneManager
  • Flush() : CXTPMemFile
  • focusColorWheel : CXTPColorBase
  • FocusedControl : CXTPColorBase
  • FocusInplaceButton() : CXTPPropertyGridView
  • FocusItem() : CXTPTaskDialogLinkCtrl, CXTPTreeBase
  • focusLumination : CXTPColorBase
  • focusNone : CXTPColorBase
  • FocusSubItems() : CXTPGridControl
  • FontExists() : CXTPAuxData, CXTPFontManager, CXTPPaintManager
  • FontToString() : CXTPPropertyGridItemFont
  • ForceLayoutAdjustment() : CXTPGridHeader
  • Format() : CXTPCalendarDayViewTimeScale, CXTPPropertyGridItemDate, CXTPShortcutManager
  • FormatDate() : CXTPChartNumberFormat
  • FormatDateTime() : CXTPGridControlLocale
  • FormatEventTime() : CXTPCalendarView, CXTPCalendarViewEvent
  • FormatFontName() : CXTPCalendarPageSetupDialog
  • FormatNumber() : CXTPChartNumberFormat
  • FormatOleDateTime() : CXTPDateEdit, CXTPTimeEdit
  • FormatPoint() : CXTPChartNumberFormat
  • FormatString() : CXTPChartNumberFormat
  • FormatTime() : CXTPTrackPaintManager
  • FormatTimeDuration() : CXTPCalendarUtils
  • FormatTimeLineTick() : CXTPTrackPaintManager
  • ForwardMessage() : CXTPTipWindow
  • ForwardMouse() : CXTPPageScroller
  • Free() : CXTPShellPidl::CShellMalloc
  • Free_mem() : CXTPHeapAllocatorT< _TData >
  • FreeBitmaps() : CXTPTaskPanelPaintManager
  • FreeButtonIcons() : CXTPExcelTabCtrl
  • FreeExtraData() : CXTPBatchAllocObjT< _TObject, _TBatchAllocData, _TAllocator >
  • FreeLibrary() : CXTPModuleHandle
  • FreeMDIMenus() : CXTPMenuBar
  • FreePidl() : CXTPShellPidl
  • FreeRowBatchExtraData() : CXTPGridControl
  • FreeSkinData() : CXTPSkinManager
  • FreeSysFonts() : CXTPAuxData
  • FreezeColumn() : CXTPHeaderCtrl
  • FreezeUpdates() : CXTPFrameShadow, CXTPFrameShadowManager
  • FromHandle() : CXTPSkinManager
  • FromIDispatchSafe() : CXTPCmdTarget
  • FromUI() : CXTPControl
  • fSizebox : XTP_SCROLLBAR_POSINFO
  • FullDragWindows() : CXTPSplitterWnd
  • fVert : XTP_SCROLLBAR_POSINFO


Toolkit Pro: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- g -

  • GenerateCommandBarList() : CXTPCommandBar, CXTPControl, CXTPMenuBar
  • Get() : CXTPCalendarData::EventsMapByID_T< _TObject >, CXTPFontEnum
  • Get3dRotation() : CXTPChart3dPieSeriesStyle, CXTPChartSeriesStyle
  • GetA() : CXTPChartColor
  • GetAbsoluteVisualOffset() : CXTPMarkupVisual
  • GetAccess() : CXTPSingletonPointer
  • GetAccessCriticalSection() : CXTPSynchronized
  • GetAction() : CXTPControl, CXTPControlGalleryItems
  • GetActions() : CXTPCommandBars
  • GetActiveControlPane() : CXTPRibbonBackstageView
  • GetActiveDocTemplate() : CXTPCommandBar, CXTPCommandBars
  • GetActiveGroup() : CXTPTaskPanel
  • GetActiveIndex() : CXTPPropertySheet
  • GetActiveItem() : CXTPGridControl
  • GetActiveLCID() : CXTPCalendarControlViewPrintOptions, CXTPCalendarUtils, CXTPChartNumberFormat, CXTPGridControlLocale, CXTPGridViewPrintOptions, CXTPResourceManager
  • GetActiveMdiChildWnd() : CXTPMenuBar
  • GetActivePage() : CXTPFlowGraphControl, CXTPPropertySheet
  • GetActivePane() : CXTPDockingPaneManager
  • GetActiveReminders() : CXTPCalendarRemindersManager
  • GetActiveRemindersCount() : CXTPCalendarRemindersManager
  • GetActiveTab() : CXTPRibbonBackstageView
  • GetActiveTags() : CXTPSyntaxEditLexClass
  • GetActiveView() : CXTPCalendarControl, CXTPTabExBase
  • GetActualBackColor() : CXTPHexEdit
  • GetActualBackgroundColor() : CXTPChartContent, CXTPChartLegend
  • GetActualBorderColor() : CXTPChartContent, CXTPChartLegend
  • GetActualColor() : CXTPChartAreaSeriesView, CXTPChartAxis, CXTPChartAxisConstantLine, CXTPChartAxisStrip, CXTPChartBubbleSeriesPointView, CXTPChartRadarAreaSeriesView
  • GetActualColor2() : CXTPChartAreaSeriesView, CXTPChartBubbleSeriesPointView, CXTPChartRadarAreaSeriesView
  • GetActualHighlightBackColor() : CXTPHexEdit
  • GetActualHighlightTextColor() : CXTPHexEdit
  • GetActualInterlacedColor() : CXTPChartAxis
  • GetActualInterlacedColor2() : CXTPChartAxis
  • GetActualSize() : CXTPMarkupFrameworkElement
  • GetActualTextColor() : CXTPChartAxisConstantLine, CXTPChartAxisLabel, CXTPChartAxisTitle, CXTPChartLegend, CXTPChartTitle, CXTPHexEdit
  • GetAdditionalScaleText() : CXTPCalendarDayView
  • GetAdditionalScaleTimeZone() : CXTPCalendarDayView
  • GetAdditionalScaleTimeZoneInfo() : CXTPCalendarDayView
  • GetAddOrRemovePopup() : CXTPCommandBars
  • GetAlignment() : CXTPChartAxis, CXTPChartAxisConstantLine, CXTPChartAxisTitle, CXTPChartTitle, CXTPGridColumn, CXTPGridRecordItem, CXTPGridRecordItemControl, CXTPPropertyGridInplaceButton
  • GetAllDayEventsRect() : CXTPCalendarDayViewGroup
  • GetAllDayEventsScrollButtonRect() : CXTPCalendarDayViewGroup
  • GetAllEvents_raw() : CXTPCalendarData
  • GetAllowDeletes() : CXTPHexEdit
  • GetAllowModifyConnections() : CXTPFlowGraphControl
  • GetAllowMoveNodes() : CXTPFlowGraphControl
  • GetAllowNullDateString() : CXTPPropertyGridItemDate
  • GetAllowReduceLevel() : CXTPRibbonGroup
  • GetAllowResizeNodes() : CXTPFlowGraphControl
  • GetAlpha() : CXTPChartColor
  • GetAlphaTabClientContext() : CXTPTabClientContext
  • GetAmbientProperty() : CXTPApplication
  • GetAnchorPoint() : CXTPChartBarSeriesLabelView, CXTPChartDiagram2DSeriesLabelView, CXTPChartPointSeriesLabelView, CXTPChartRadarPointSeriesLabelView, CXTPChartRangeAreaSeriesLabelView, CXTPChartRangeBarSeriesLabelView
  • GetAngle() : CXTPChartAxisLabel, CXTPChartPointSeriesLabel, CXTPChartRadarPointSeriesLabel, CXTPMarkupRotateTransform
  • GetAngleX() : CXTPMarkupSkewTransform
  • GetAngleY() : CXTPMarkupSkewTransform
  • GetAnimateDelay() : CXTPPopupControl
  • GetAnimation() : CXTPTaskPanel
  • GetAnimationDelay() : CXTPDockingPaneManager, CXTPFlowGraphControl
  • GetAntialiasing() : CXTPChart3dDeviceContext, CXTPChartAxisConstantLine, CXTPChartAxisLabel, CXTPChartAxisTitle, CXTPChartFastLineSeriesStyle, CXTPChartLegend, CXTPChartSeriesLabel, CXTPChartTextElement, CXTPChartTitle
  • GetAppearance() : CXTPChartAppearance, CXTPChartAxis, CXTPChartContent, CXTPChartDiagram2D, CXTPChartElement, CXTPChartRadarDiagram, CXTPTabManager, CXTPTabPaintManager
  • GetAppearanceSet() : CXTPTabManager, CXTPTabPaintManager
  • GetApplyOptions() : CXTPSkinManager
  • GetAppRegistryKey() : CXTPRegistryManager
  • GetAppThreadId() : CXTPApplication
  • GetArchive() : CXTPPropExchange, CXTPPropExchangeArchive
  • GetArea() : CXTPChartEllipse
  • GetArgument() : CXTPChartSeriesPoint
  • GetArgumentScaleType() : CXTPChartSeries
  • GetArgumentValue() : CXTPChartSeriesPoint
  • GetArithmeticMean() : CXTPChartSeriesPointCollection
  • GetAscending() : CXTPHeaderCtrl
  • GetAskItemTextFlags() : CXTPCalendarControl, CXTPCalendarPaintManager
  • GetAsSystemTime() : CXTPPropertyGridItemDate
  • GetAt() : CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE >, CXTPCalendarEvents, CXTPCalendarPtrCollectionT< _TObject >, CXTPCalendarTimeZones, CXTPChartAxisConstantLines, CXTPChartAxisCustomLabels, CXTPChartAxisStrips, CXTPChartElementCollection, CXTPChartElementView, CXTPChartPanelCollection, CXTPChartSeriesCollection, CXTPChartSeriesPointCollection, CXTPChartTitleCollection, CXTPCommandBarList, CXTPCommandBars, CXTPControlActions, CXTPControls, CXTPFlowGraphConnectionPoints, CXTPFlowGraphConnections, CXTPFlowGraphImages, CXTPFlowGraphNodeGroup, CXTPFlowGraphNodeGroups, CXTPFlowGraphNodes, CXTPFlowGraphPages, CXTPFlowGraphSelectedElements, CXTPGridColumnOrder, CXTPGridColumns, CXTPGridRecordItemConstraints, CXTPGridRecords, CXTPGridRows, CXTPGridSelectedRows, CXTPInternalCollectionT< _TObject >, CXTPMatrix< T >, CXTPPropertyGridInplaceButtons, CXTPPropertyGridInplaceControls, CXTPPropertyGridItemConstraints, CXTPPropertyGridItems, CXTPPropertyGridVerbs, CXTPRibbonGroup, CXTPRibbonGroups, CXTPShortcutManagerAccelTable, CXTPTabManagerNavigateButtons, CXTPTaskPanel, CXTPTaskPanelGroup, CXTPTaskPanelItems, CXTPTrackMarkers, CXTPTrackSelectedBlocks
  • GetAtOffset() : CXTPGridColumns
  • GetAtom() : CXTPGlobalAtom
  • GetAtomString() : CXTPGlobalAtom
  • GetAttribute() : CXTPSyntaxEditLexClass
  • GetAttribute_BOOL() : CXTPSyntaxEditLexClass
  • GetAttribute_int() : CXTPSyntaxEditLexClass
  • GetAttributes() : CXTPShellPidl
  • GetAutoApplyNewThreads() : CXTPSkinManager
  • GetAutoApplyNewWindows() : CXTPSkinManager
  • GetAutoColor() : CXTPSyntaxEditColorComboBox
  • GetAutoCompleteWnd() : CXTPSyntaxEditCtrl
  • GetAutoCondense() : CXTPTabExBase
  • GetAutoIndent() : CXTPSyntaxEditCtrl
  • GetAutoReload() : CXTPSyntaxEditDoc
  • GetAutoscrollDirection() : CXTPSyntaxEditCtrl
  • GetAutoTheme() : CXTPTabClientWnd
  • GetAutoVScrollTimerResolution() : CXTPGridControl
  • GetAverageValue() : CXTPSyntaxEditCtrl::CAverageVal
  • GetAxis() : CXTPChartAxisGridLines, CXTPChartAxisLabel, CXTPChartAxisTickMarks, CXTPChartAxisTitle, CXTPChartScaleTypeMap
  • GetAxisAppearance() : CXTPChartDiagram2DAppearance
  • GetAxisMaxValue() : CXTPChartAxisStrip
  • GetAxisMinValue() : CXTPChartAxisStrip
  • GetAxisMinValueInternal() : CXTPChartAxisStrip
  • GetAxisValue() : CXTPChartAxisConstantLine, CXTPChartAxisCustomLabel
  • GetAxisValueInternal() : CXTPChartAxisConstantLine, CXTPChartAxisCustomLabel
  • GetAxisView() : CXTPChartDiagram2DView, CXTPChartRadarDiagramView
  • GetAxisX() : CXTPChartDiagram2D, CXTPChartRadarDiagram
  • GetAxisY() : CXTPChartDiagram2D, CXTPChartRadarDiagram
  • GetB() : CXTPChartColor
  • GetBackColor() : CXTPChartSeriesLabel, CXTPComboBox, CXTPComboBoxTheme, CXTPHexEdit, CXTPHyperLink, CXTPListBox, CXTPListBoxTheme, CXTPListBoxThemeOffice2013, CXTPMarqueeCtrlPaintManager, CXTPProgressCtrl, CXTPProgressCtrlPaintManager, CXTPShortcutListBoxTheme, CXTPSyntaxEditColorSampleText, CXTPSyntaxEditPaintManager, CXTPSyntaxEditTipWnd, CXTPTabBaseTheme, CXTPTabBaseThemeOffice2003, CXTPTagCloudCtrl, CXTPTaskDialogLinkCtrl, CXTPTaskPanelGroupItem
  • GetBackColorEx() : CXTPSyntaxEditPaintManager, XTP_EDIT_COLORVALUES
  • GetBackground() : CXTPMarkupBorder, CXTPMarkupControl, CXTPMarkupPanel, CXTPMarkupTextBlock
  • GetBackgroundBitmap() : CXTPPopupControl
  • GetBackgroundBrush() : CXTPComboBoxTheme
  • GetBackgroundColor() : CXTPCalendarEventCategory, CXTPCalendarViewPart, CXTPChartContent, CXTPChartLegend, CXTPGridRecordItem, CXTPPopupItem, CXTPPreviewCtrl, CXTPStatusBarPane, IXTPPreviewHost
  • GetBackImageName() : CXTPRibbonOffice2013Theme
  • GetBackstageStyle() : CXTPRibbonBackstageView
  • GetBarColor() : CXTPMarqueeCtrlPaintManager, CXTPProgressCtrl, CXTPProgressCtrlPaintManager
  • GetBarID() : CXTPCommandBar
  • GetBarInfo() : CXTPToolBar
  • GetBarWidth() : CXTPChartBarSeriesStyle
  • GetBaseEdgeCount() : CXTPChart3dFunnelSeriesStyle, CXTPChart3dPyramidSeriesStyle
  • GetBasePoint() : CXTPChartPieSeriesPointViewBase
  • GetBeginDate() : CXTPCalendarMonthView::CMonthViewGrid, CXTPCalendarWeekView
  • GetBeginGroup() : CXTPControl, CXTPStatusBarPane
  • GetBehaviour() : CXTPTaskPanel
  • GetBestFit() : CXTPStatusBarPane
  • GetBestFitMode() : CXTPGridColumn
  • GetBitmap() : CXTPImageManagerIconHandle, CXTPSvgImage
  • GetBitmapBits() : CXTPImageManagerIcon
  • GetBitmapHandle() : CXTPImageManagerImageList
  • GetBitmapMaskColor() : CXTPImageManager
  • GetBitmapPixel() : CXTPResourceImage
  • GetBkBaseColor() : CXTPCalendarEventCategory
  • GetBkColor() : CXTPImageList, CXTPPageScroller
  • GetBkColorAllDayEvents() : CXTPCalendarEventCategory
  • GetBkColorNonWorkCell() : CXTPCalendarEventCategory
  • GetBkColorWorkCell() : CXTPCalendarEventCategory
  • GetBlendingOptions() : CXTPFrameShadow
  • GetBlock() : CXTPTrackControlItem
  • GetBlockCount() : CXTPTrackControlItem
  • GetBlockFromPt() : CXTPSyntaxEditCtrl
  • GetBlocks() : CXTPSyntaxEditLexTextSchema
  • GetBlue() : CXTPChartColor
  • GetBody() : CXTPCalendarEvent
  • GetBoldDaysIdleStepTime_ms() : CXTPCalendarController
  • GetBoldDaysPerIdleStep() : CXTPCalendarController
  • GetBoldFont() : CXTPTabPaintManager
  • GetBookmark() : CXTPGridRecord
  • GetBookmarks() : CXTPSyntaxEditPaintManager
  • GetBool() : CXTPPropertyGridItemBool
  • GetBoolProperty() : CXTPSkinManagerSchema
  • GetBorder() : CXTPChartContent, CXTPChartFunnelSeriesStyleBase, CXTPChartLegend, CXTPChartPieSeriesStyleBase, CXTPChartPyramidSeriesStyleBase, CXTPGridRecordItem, CXTPGridSection, CXTPPageScroller
  • GetBorderActualColor() : CXTPChartAreaSeriesView, CXTPChartFunnelSeriesPointViewBase, CXTPChartPieSeriesStyleBase, CXTPChartPyramidSeriesPointViewBase, CXTPChartRadarAreaSeriesView
  • GetBorderBrush() : CXTPMarkupBorder
  • GetBorderColor() : CXTPCalendarEventCategory, CXTPMarqueeCtrlPaintManager, CXTPPopupItem, CXTPProgressCtrl, CXTPProgressCtrlPaintManager, CXTPSyntaxEditColorSampleText, CXTPTagCloudCtrl
  • GetBorderGap() : CXTPButton
  • GetBorderRect() : CXTPColorSelectorCtrl
  • GetBorders() : CXTPCalendarCaptionBarControl, CXTPCommandBar, CXTPControlGallery, CXTPPopupBar, CXTPRibbonSystemPopupBar, CXTPSkinObjectFrame, CXTPTabToolBar, CXTPToolBar
  • GetBorderStyle() : CXTPButton, CXTPDatePickerControl, CXTPPropertyGrid
  • GetBorderThickness() : CXTPMarkupBorder
  • GetBottom() : CXTPGridThickness, CXTPMarkupThickness, CXTPRectT< T >
  • GetBoundingRect() : CXTPFlowGraphConnection
  • GetBoundRect() : CXTPMarkupGdiPlusTransformationMatrix, CXTPMarkupTransformationMatrix, CXTPMarkupVisual
  • GetBounds() : CXTPChart3dDeviceContext, CXTPChartDiagramView, CXTPChartElementView, CXTPChartPieBase
  • GetBoundView() : CXTPChartDeviceCommand
  • GetBreakParsingEvent() : CXTPSyntaxEditLexTextSchema
  • GetBreakpointBackColor() : CXTPSyntaxEditPaintManager
  • GetBreakpointTextColor() : CXTPSyntaxEditPaintManager
  • GetBrowseButton() : CXTPBrowseEdit
  • GetBrowserObject() : CXTPWebBrowserCtrl, CXTPWebBrowserProvider
  • GetBrush() : CXTPSkinManagerMetrics
  • GetBuffer() : CXTPSyntaxEditBufferManager, CXTPSyntaxEditTextIterator
  • GetBusyStatus() : CXTPCalendarDayViewGroup, CXTPCalendarEvent
  • GetBusyStatusBrush() : CXTPCalendarPaintManager
  • GetButton() : CXTPDatePickerControl, CXTPGridRecordItemEditOptions
  • GetButtonBackColor() : CXTPButton
  • GetButtonColorSet() : CXTPDockingPaneColorSet
  • GetButtonCount() : CXTPDatePickerControl
  • GetButtonDrawRect() : CAppearanceSetPropertyPage2003, CAppearanceSetPropertyPageAccess2007, CAppearanceSetVisualStudio2005, CXTPTabPaintManagerTheme, CXTPTabThemeExcel2003, CXTPTabThemeOffice2000
  • GetButtonFont() : CXTPDatePickerPaintManager
  • GetButtonHeight() : CXTPTabPaintManagerTheme
  • GetButtonLength() : CXTPTabManagerItem, CXTPTabPaintManagerTheme
  • GetButtonRect() : CXTPButton, CXTPCaption, CXTPSkinObjectDateTime, CXTPSpinButtonCtrl
  • GetButtons() : CXTPTabBase
  • GetButtonSize() : CXTPColorSelectorCtrl, CXTPColorSelectorCtrlTheme, CXTPCommandBar, CXTPControl, CXTPPageScroller, CXTPRibbonBar, CXTPRibbonControlSystemPopupBarButton, CXTPRibbonTabPopupToolBar
  • GetButtonState() : CXTPPageScroller
  • GetButtonStyle() : CXTPButton
  • GetButtonText() : CXTPButton
  • GetButtonTextColor() : CXTPButton
  • GetCacheMode() : CXTPCalendarData
  • GetCalendar() : CXTPCalendarController
  • GetCalendarCaptionBarCtrl() : CXTPCalendarControlView
  • GetCalendarControl() : CXTPCalendarTimeLineViewGroup, CXTPCalendarView, CXTPCalendarViewDay, CXTPCalendarViewEvent, CXTPCalendarViewGroup
  • GetCalendarCtrl() : CXTPCalendarCaptionBarTheme, CXTPCalendarControlView
  • GetCalendarOptions() : CXTPCalendarControl, CXTPCalendarView
  • GetCallback() : CXTPBrowseDialog
  • GetCallbackDayMetrics() : CXTPDatePickerControl
  • GetCallbackMessage() : CXTPTrayIcon
  • GetCameraPosition() : CXTPChart3dDiagram
  • GetCanEditCheckboxItem() : CXTPGridRecordItem
  • GetCaption() : CXTPCalendarDayViewDay, CXTPCalendarDayViewTimeScale, CXTPCalendarViewGroup, CXTPCalendarWeekViewDay, CXTPCaptionButton, CXTPControl, CXTPControlAction, CXTPControlGalleryItem, CXTPControlPopup, CXTPDatePickerButton, CXTPDialogBar, CXTPFlowGraphConnection, CXTPFlowGraphConnectionPoint, CXTPFlowGraphElement, CXTPFlowGraphNode, CXTPFlowGraphNodeGroup, CXTPFlowGraphPage, CXTPGridColumn, CXTPGridGroupRow, CXTPGridRecordItem, CXTPGridRecordItemControl, CXTPGridRecordItemDateTime, CXTPGridRecordItemNumber, CXTPGridRecordItemPreview, CXTPGridRecordItemText, CXTPGridRecordItemVariant, CXTPPopupItem, CXTPPropertyGridInplaceButton, CXTPPropertyGridItem, CXTPPropertyGridVerb, CXTPPropertyPage, CXTPRibbonControlSystemButton, CXTPRibbonGroup, CXTPRibbonTab, CXTPShortcutBarItem, CXTPShortcutBarPane, CXTPShortcutBarPaneItem, CXTPStatusBarPane, CXTPTabManagerItem, CXTPTaskPanelItem, CXTPTrackBlock, CXTPTrackControlItem, CXTPTrackMarker
  • GetCaptionButton() : CXTPCaption
  • GetCaptionButtons() : CXTPCommandBarsFrameHook, CXTPDockingPaneBase, CXTPSkinObjectFrame
  • GetCaptionButtonStyle() : CXTPDockingPanePaintManager
  • GetCaptionColor() : CXTPGridRecordItemControl
  • GetCaptionDirection() : CXTPDockingPaneManager
  • GetCaptionGripperRect() : CXTPDockingPaneOffice2003OutlookTheme, CXTPDockingPaneOffice2003Theme, CXTPDockingPanePaintManager
  • GetCaptionGripperWidth() : CXTPTaskPanelPaintManager
  • GetCaptionHeight() : CXTPCommandBarsFrameHook, CXTPDockingPanePaintManager, CXTPRibbonBar, CXTPTaskPanelGroup
  • GetCaptionMetrics() : CXTPPropertyGridItem
  • GetCaptionPopup() : CXTPDialogBar
  • GetCaptionPosition() : CXTPFlowGraphNodeCustom
  • GetCaptionRect() : CXTPDockingPanePaintManager, CXTPFlowGraphNode, CXTPFlowGraphPaintManager, CXTPGridRecordItem, CXTPGridRecordItemPreview, CXTPRibbonBar, CXTPRibbonGroup, CXTPShortcutBarPaneItem, CXTPTaskPanelGroup
  • GetCaptionStyle() : CXTPCaption
  • GetCaptionText() : CXTPCaption
  • GetCaptionTextBlock() : CXTPFlowGraphNode
  • GetCaptionTextRect() : CXTPRibbonBar
  • GetCaptionTextSize() : CXTPTaskPanelItem
  • GetCaptionValue() : CXTPGridGroupRow
  • GetCaptionWidth() : CXTPGridColumn
  • GetCategories() : CXTPCalendarEvent, CXTPPropertyGrid
  • GetCategoriesCount() : CXTPCalendarEvent
  • GetCategory() : CXTPCalendarEventColorListBox, CXTPChartNumberFormat, CXTPControl, CXTPControlAction
  • GetCategoryArray() : CXTPCalendarEventCategoryComboBox
  • GetCategoryInfo() : CXTPCustomizeCommandsPage, CXTPCustomizeKeyboardPage
  • GetCellDateTime() : CXTPCalendarDayViewGroup
  • GetCellDuration() : CXTPCalendarDayView
  • GetCellEvents() : CXTPCalendarDayViewGroup
  • GetCellFromIndex() : CXTPColorSelectorCtrl
  • GetCellNumber() : CXTPCalendarDayView
  • GetCellRect() : CXTPCalendarDayViewGroup
  • GetCellTime() : CXTPCalendarDayView
  • GetCellViewPart() : CXTPCalendarDayViewGroup
  • GetCelRect() : CXTPCalendarMonthView::CMonthViewGrid
  • GetCenter() : CXTPChart3dBox, CXTPChartEllipse, CXTPRectT< T >
  • GetCenterCandidates() : CXTPChart3dBox
  • GetCenterPoint() : CXTPChartPieBase
  • GetCenterShapeConnectorPoint() : CXTPChart3dFunnelSeriesPointView, CXTPChart3dPieSeriesPointView, CXTPChart3dPyramidSeriesPointView
  • GetCenterX() : CXTPMarkupRotateTransform, CXTPMarkupScaleTransform, CXTPMarkupSkewTransform
  • GetCenterY() : CXTPMarkupRotateTransform, CXTPMarkupScaleTransform, CXTPMarkupSkewTransform
  • GetCheck() : CXTPCalendarCaptionBarThemePart, CXTPCheckListBox
  • GetChecked() : CXTPButton, CXTPCalendarEventCategoryComboBox, CXTPControl, CXTPControlAction, CXTPMarkupToggleButton
  • GetCheckedIcon() : CXTPImageManagerIcon
  • GetCheckedItem() : CXTPControlGallery
  • GetCheckedState() : CXTPGridRecordItem
  • GetCheckStyle() : CXTPCheckListBox
  • GetChild() : CXTPDockingPane, CXTPMarkupDecorator
  • GetChildCommand() : CXTPChartDeviceCommand
  • GetChildCommandCount() : CXTPChartDeviceCommand
  • GetChildHandlerAt() : CXTPCalendarCaptionBarTheme, CXTPCalendarView, CXTPCalendarViewDay, CXTPCalendarViewGroup, CXTPCalendarWMHandler
  • GetChildHandlersCount() : CXTPCalendarCaptionBarTheme, CXTPCalendarView, CXTPCalendarViewDay, CXTPCalendarViewGroup, CXTPCalendarWMHandler
  • GetChildRect() : CXTPTabBase
  • GetChildren() : CXTPChartElementView, CXTPMarkupPanel, CXTPSyntaxEditLexClass
  • GetChildrenDyn() : CXTPSyntaxEditLexClass
  • GetChildrenSelfRef() : CXTPSyntaxEditLexClass
  • GetChilds() : CXTPGridRecord, CXTPGridRow, CXTPPropertyGridItem
  • GetChildWndText() : CXTPMDIWndTab, CXTPWindowList
  • GetCilentSite() : CXTPGaugeCtrl
  • GetClassCode() : CXTPSkinManagerClass, CXTPSkinManagerSchema
  • GetClassMap() : CXTPSkinManager
  • GetClassName() : CXTPSkinManagerClass, CXTPSkinObject, CXTPSyntaxEditColorInfo, CXTPSyntaxEditLexClass
  • GetClassSchema() : CXTPSyntaxEditLexTextSchema
  • GetClassSchLoker() : CXTPSyntaxEditLexTextSchema
  • GetClickPoint() : CXTPPropertyGridVerb
  • GetClientBrush() : CXTPComboBox, CXTPEdit, CXTPEditTheme, CXTPSkinObjectFrame
  • GetClientColor() : CXTPTabColorSetOffice2013, CXTPTabColorSetVisualStudio2012, CXTPTabColorSetVisualStudio2015, CXTPTabPaintManagerColorSet
  • GetClientHeight() : CXTPTaskPanel
  • GetClientInterface() : CXTPWebBrowserProvider
  • GetClientMargin() : CXTPDockingPaneManager, CXTPTabPaintManagerTheme, CXTPTabThemeOffice2000
  • GetClientMargins() : CXTPDockingPaneManager
  • GetClientPane() : CXTPDockingPaneManager
  • GetClientPaneRect() : CXTPShortcutBar
  • GetClientRect() : CAppearanceSetVisio, CXTPCalendarTimeLineViewTimeScale, CXTPTabManager, CXTPTabPaintManagerTheme, CXTPTaskPanelGroup
  • GetClientSite() : CXTPMarkupContext
  • GetClientWindow() : CXTPShortcutBarItem
  • GetClipboardFormat() : CXTPTaskPanel
  • GetClipOwner() : CXTPFrameShadow
  • GetClipToBounds() : CXTPMarkupFrameworkElement
  • GetClockSize() : CXTPCalendarPaintManager
  • GetCloseButton() : CXTPDockingPaneTabbedContainer
  • GetCloseButtonRect() : CXTPMessageBarPaintManager, CXTPMessageBarThemeOffice2010, CXTPMessageBarThemeOffice2013
  • GetCloseSubMenuOnClick() : CXTPControl
  • GetCloudStyleArray() : CXTPTagCloudStyleManager
  • GetCltColor() : CXTPScrollBase
  • GetCodePage() : CXTPSyntaxEditBufferManager
  • GetColHeaderHeight() : CXTPCalendarMonthView::CMonthViewGrid
  • GetCollapsableBlocksInfo() : CXTPSyntaxEditCtrl, CXTPSyntaxEditLexTextSchema
  • GetCollapsedBlockLen() : CXTPSyntaxEditCtrl
  • GetCollapsedItemsCount() : CXTPShortcutBar
  • GetCollapsedText() : CXTPSyntaxEditCtrl
  • GetCollapsibleNodes() : CXTPSyntaxEditCtrl
  • GetColor() : CXTPCalendarResource, CXTPChartAxis, CXTPChartAxisGridLines, CXTPChartAxisStrip, CXTPChartBorder, CXTPChartPalette, CXTPChartSeriesPointView, CXTPChartSeriesStyle, CXTPColorDialog, CXTPColorManager, CXTPColorPicker, CXTPControlButtonColor, CXTPControlColorSelector, CXTPControlPopupColor, CXTPFlowGraphConnection, CXTPFlowGraphConnectionPoint, CXTPFlowGraphNode, CXTPFrameShadow, CXTPGridHyperlinkStyle, CXTPPropertyGridItemColor, CXTPPropertyGridItemFont, CXTPSkinManagerMetrics, CXTPSkinObject, CXTPTabManager, CXTPTabManagerItem, CXTPTabPaintManager
  • GetColor2() : CXTPCalendarCaptionBarResourceTheme, CXTPChartPalette, CXTPChartSeriesPointView
  • GetColorCell() : CXTPColorHex
  • GetColorCellBorder() : CXTPCalendarEventCategory
  • GetColorCellList() : CXTPColorSelectorCtrl
  • GetColorInfo() : CXTPSyntaxEditColorTheme
  • GetColorProperty() : CXTPSkinManagerSchema
  • GetColorRect() : CXTPEyeDropper
  • GetColorScheme() : CXTPSyntaxEditCtrl
  • GetColorSet() : CXTPDockingPaneVisualStudio2012Theme, CXTPTabManager, CXTPTabPaintManager, CXTPTabPaintManagerTheme
  • GetColPosX() : CXTPSyntaxEditDrawTextProcessor
  • GetCols() : CXTPDatePickerControl
  • GetColsCount() : CXTPCalendarMonthView::CMonthViewGrid
  • GetColumn() : CXTPMarkupGrid
  • GetColumnCaptionPrefix() : CXTPGridRecordItem
  • GetColumnCount() : CXTPListBase
  • GetColumnDefinitions() : CXTPMarkupGrid
  • GetColumnOffice2007CustomThemeBaseColor() : CXTPGridPaintManager
  • GetColumns() : CXTPGridColumn, CXTPGridControl, CXTPMarkupUniformGrid
  • GetColumnSpan() : CXTPMarkupGrid
  • GetColumnStyle() : CXTPGridPaintManager
  • GetColumnWidth() : CXTPTaskPanel
  • GetComboBoxPopupBar() : CXTPControlComboBox
  • GetComboBoxRect() : CXTPComboBox
  • GetComCtlVersion() : CXTPAuxData, CXTPSystemVersion
  • GetComInitFlags() : CXTPApplication
  • GetCommandBar() : CXTPControl, CXTPControlPopup, CXTPPreviewView
  • GetCommandBarBorders() : CXTPCommandBarsNativeWindows11Theme, CXTPCommandBarsOffice2000Theme, CXTPCommandBarsOffice2003Theme, CXTPPaintManager, CXTPVisualStudio2008Theme, CXTPVisualStudio2010Theme
  • GetCommandBarData() : CXTPCommandBar
  • GetCommandBarFont() : CXTPPaintManager
  • GetCommandBars() : CXTPCommandBar, CXTPCommandBarList, CXTPCommandBarsSiteBase< TBase >, CXTPControlAction, CXTPControls, CXTPCustomizeOptionsPage, CXTPCustomizeSheet, CXTPTabClientWnd
  • GetCommandBarsOptions() : CXTPCommandBars
  • GetCommandsCount() : CXTPSyntaxEditBatchCommand
  • GetCommandsPage() : CXTPCustomizeSheet
  • GetCommandText() : CXTPSyntaxEditCommand
  • GetConfigFile() : CXTPSyntaxEditBufferManager, CXTPSyntaxEditConfigurationManager, CXTPSyntaxEditCtrl
  • GetConnection() : CXTPCalendarCaptionBarTheme, CXTPCalendarControl, CXTPCalendarData, CXTPCalendarRemindersManager, CXTPCalendarResourcesNf, CXTPDatePickerControl, CXTPResourceImages, CXTPSyntaxEditBufferManager, CXTPSyntaxEditConfigurationManager, CXTPSyntaxEditLexParser, CXTPSyntaxEditLexTextSchema
  • GetConnectionPoints() : CXTPFlowGraphNode
  • GetConnections() : CXTPFlowGraphPage
  • GetConnectionsCount() : CXTPFlowGraphConnectionPoint
  • GetConnectionString() : CXTPCalendarData
  • GetConnectorBendPoint() : CXTPChart3dFunnelSeriesLabelView, CXTPChart3dPieSeriesLabelView, CXTPChart3dPyramidSeriesLabelView
  • GetConnectorEndPoint() : CXTPChart3dFunnelSeriesLabelView, CXTPChart3dPieSeriesLabelView, CXTPChart3dPyramidSeriesLabelView
  • GetConnectorEndpointVerticalOffset() : CXTPChart3dFunnelSeriesLabelDeviceCommand, CXTPChart3dPieSeriesLabelDeviceCommand, CXTPChart3dPyramidSeriesLabelDeviceCommand
  • GetConnectorLength() : CXTPChart3dFunnelSeriesLabelDeviceCommand, CXTPChart3dPyramidSeriesLabelDeviceCommand
  • GetConnectorLengthFactor() : CXTPChart3dPieSeriesLabelDeviceCommand
  • GetConnectorStartPoint() : CXTPChart3dFunnelSeriesLabelView, CXTPChart3dPieSeriesLabelView, CXTPChart3dPyramidSeriesLabelView
  • GetConstantLines() : CXTPChartAxis
  • GetConstraintAt() : CXTPPropertyGridItemConstraints
  • GetConstraintEdit() : CXTPPropertyGridItem
  • GetConstraints() : CXTPGridRecordItemEditOptions, CXTPPropertyGridItem
  • GetContainer() : CXTPChartDeviceContext, CXTPDockingPaneBase, CXTPDockingPaneSplitterWnd
  • GetContent() : CXTPChartControl, CXTPChartElement, CXTPMarkupContentControl, CXTPMarkupPage
  • GetContentAppearance() : CXTPChartAppearance
  • GetContentLength() : CXTPTabManagerItem
  • GetContext() : CXTPActiveScriptObjectContext
  • GetContextCaption() : CXTPRibbonTab
  • GetContextColor() : CXTPRibbonTab
  • GetContextHeader() : CXTPRibbonTab
  • GetContextHeaders() : CXTPRibbonBar
  • GetContextMenu() : CXTPCustomizeSheet, CXTPShellTreeBase
  • GetContextMenuEnabled() : CXTPShellExplorerProvider
  • GetContextMenus() : CXTPCommandBars
  • GetContextWindow() : CXTPMarkupContext
  • GetContrastColor() : CXTPColorPicker
  • GetControl() : CXTPChartContainer, CXTPChartControl, CXTPCommandBar, CXTPControlAction, CXTPControlCustom, CXTPFlowGraphConnection, CXTPFlowGraphConnectionPoint, CXTPFlowGraphElement, CXTPFlowGraphNode, CXTPFlowGraphNodeGroup, CXTPFlowGraphPage, CXTPGridColumn, CXTPGridHeader, CXTPGridRow, CXTPTrackMarker
  • GetControlBackColor() : CXTPCommandBarsOffice2013Theme, CXTPDatePickerPaintManager, CXTPGridPaintManager, CXTPPaintManager
  • GetControlComboBox() : CXTPControlComboBoxEditCtrl
  • GetControlCount() : CXTPCommandBar
  • GetControlEdit() : CXTPControlEditCtrl
  • GetControlEditBackColor() : CXTPCommandBarsOffice2013Theme, CXTPCommandBarsVisualStudio2012Theme, CXTPPaintManager, CXTPRibbonTheme
  • GetControlFont() : CXTPPaintManager
  • GetControlGroupOption() : CXTPRibbonGroup
  • GetControlGroupOptionSize() : CXTPRibbonMarkupTheme, CXTPRibbonPaintManager, CXTPRibbonThemeResource
  • GetControlGroupPopup() : CXTPRibbonGroup
  • GetControlHandle() : CXTPTaskPanelGroupItem
  • GetControlHeight() : CXTPPaintManager
  • GetControlMargins() : CXTPTaskPanelPaintManager
  • GetControlPoint() : CXTPFlowGraphConnection
  • GetControlPopup() : CXTPPopupBar
  • GetControlQuickAccess() : CXTPRibbonBar
  • GetControlRect() : CXTPTabManager
  • GetControls() : CXTPCommandBar, CXTPControl, CXTPCustomizeCommandsPage, CXTPRibbonCustomizePage, CXTPRibbonCustomizeQuickAccessPage
  • GetControlStyle() : CXTPToolTipContext
  • GetControlTab() : CXTPRibbonBar
  • GetControlTextColor() : CXTPCommandBarsNativeWindows10Theme, CXTPCommandBarsNativeWindows11Theme, CXTPCommandBarsNativeXPTheme, CXTPCommandBarsOffice2013Theme, CXTPCommandBarsVisualStudio2015Theme, CXTPCommandBarsVisualStudio2017Theme, CXTPCommandBarsVisualStudio2019Theme, CXTPCommandBarsVisualStudio2022Theme, CXTPPaintManager, CXTPRibbonTheme
  • GetControlTextOrientation() : CXTPPaintManager
  • GetCornerRadius() : CXTPMarkupBorder
  • GetCorners() : CXTPChart3dBox
  • GetCount() : CXTPCalendarCustomProperties, CXTPCalendarData::EventsMapByID_T< _TObject >, CXTPCalendarEvents, CXTPCalendarPtrCollectionT< _TObject >, CXTPCalendarTimeZones, CXTPChartElementCollection, CXTPChartElementView, CXTPChartPalette, CXTPCommandBarList, CXTPCommandBars, CXTPControlAction, CXTPControlActions, CXTPControlComboBox, CXTPControls, CXTPFlowGraphConnectionPoints, CXTPFlowGraphConnections, CXTPFlowGraphImages, CXTPFlowGraphNodeGroup, CXTPFlowGraphNodeGroups, CXTPFlowGraphNodes, CXTPFlowGraphPages, CXTPFlowGraphSelectedElements, CXTPFlowGraphUndoGroupCommand, CXTPGridColumnOrder, CXTPGridColumns, CXTPGridRecordItemConstraints, CXTPGridRecords, CXTPGridRows, CXTPGridSelectedRows, CXTPMenuBarMDIMenus, CXTPPropertyGrid, CXTPPropertyGridInplaceButtons, CXTPPropertyGridInplaceControls, CXTPPropertyGridItemConstraints, CXTPPropertyGridItems, CXTPPropertyGridVerbs, CXTPRibbonGroup, CXTPRibbonGroups, CXTPShortcutManagerAccelTable, CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager, CXTPSyntaxEditLineMarksManager, CXTPTaskPanelItems, CXTPTrackMarkers, CXTPTrackSelectedBlocks, CXTPTrackUndoGroupCommand
  • GetCreationTime() : CXTPCalendarEvent
  • GetCurAbsCol() : CXTPSyntaxEditCtrl
  • GetCurArrow() : CXTPSyntaxEditPaintManager
  • GetCurCol() : CXTPSyntaxEditCtrl
  • GetCurColor() : CXTPColorSelectorCtrl
  • GetCurCopy() : CXTPSyntaxEditPaintManager
  • GetCurCRLF() : CXTPSyntaxEditBufferManager
  • GetCurCRLFType() : CXTPSyntaxEditBufferManager
  • GetCurIBeam() : CXTPSyntaxEditPaintManager
  • GetCurLine() : CXTPSyntaxEditPaintManager
  • GetCurMove() : CXTPSyntaxEditPaintManager
  • GetCurNO() : CXTPSyntaxEditPaintManager
  • GetCurrencyString() : CXTPGridGroupRow
  • GetCurrencySymbol() : CXTPChartNumberFormat
  • GetCurrent() : CXTPGaugeMeterType, CXTPPropertyGridItemConstraints
  • GetCurrentColor() : CXTPColorDialog
  • GetCurrentDC() : CXTPChartDeviceCommand
  • GetCurrentDocumentRow() : CXTPSyntaxEditCtrl
  • GetCurrentFocusInFootersRows() : CXTPGridNavigator
  • GetCurrentFocusInHeadersRows() : CXTPGridNavigator
  • GetCurrentIndex() : CXTPEditListBox
  • GetCurrentMenuResource() : CXTPMenuBar
  • GetCurrentSystemTheme() : CXTPCalendarPaintManager, CXTPColorManager, CXTPDockingPanePaintManager, CXTPPaintManager
  • GetCurrentTheme() : CXTPDockingPaneManager, CXTPPaintManager, CXTPPropertyGrid, CXTPShortcutBar, CXTPSyntaxEditConfigurationManager, CXTPSyntaxEditCtrl, CXTPTaskPanel
  • GetCurrentThemeName() : CXTPSkinManager, CXTPWinThemeWrapper
  • GetCurrentTime() : CXTPCalendarUtils
  • GetCurrentTimeZoneInfo() : CXTPCalendarDayView, CXTPCalendarOptions
  • GetCurrentVisibleRow() : CXTPSyntaxEditCtrl
  • GetCurRow() : CXTPSyntaxEditCtrl
  • GetCurSel() : CXTPColorSelectorCtrl, CXTPControlComboBox, CXTPDatePickerControl, CXTPExcelTabCtrl, CXTPRibbonBar, CXTPTabManager, CXTPTagCloudCtrl
  • GetCursorBack() : CXTPDatePickerPaintManager
  • GetCustomDownColor() : CXTPChartHighLowSeriesStyle
  • GetCustomIcons() : CXTPCalendarEvent, CXTPCustomizeSheet
  • GetCustomizationVisible() : CXTPStatusBarPane
  • GetCustomizeCaption() : CXTPRibbonTab
  • GetCustomizeMinHeight() : CXTPControl
  • GetCustomizeMinWidth() : CXTPControl, CXTPControlComboBox, CXTPControlEdit
  • GetCustomLabels() : CXTPChartAxis
  • GetCustomMarkupProperty() : CXTPFlowGraphControl
  • GetCustomProperties() : CXTPCalendarData, CXTPCalendarEvent, CXTPCalendarRecurrencePattern, CXTPCalendarSchedule
  • GetCustomShortcutText() : CXTPControl, CXTPControlAction
  • GetCustomTitle() : CXTPColorSelectorCtrl
  • GetCustomTitleBrush() : CXTPDockingPanePaintManager
  • GetCustomToolTipPosition() : CXTPMarkupContext
  • GetCustomTrait() : CXTPGaugeTraits
  • GetCustomUpColor() : CXTPChartHighLowSeriesStyle
  • GetDarkColor() : CXTPChartColor, CXTPFlowGraphPaintManager
  • GetDashed() : CXTPFlowGraphConnection
  • GetDashStyle() : CXTPChartLineStyle
  • GetData() : CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE >, CXTPBrowseDialog, CXTPControlGalleryItem, CXTPHexEdit, CXTPMatrix< T >, CXTPTabManagerItem, XTP_CALENDAR_RECURRENCE_OPTIONS
  • GetDataLock() : CXTPNotifyConnection, CXTPNotifyConnectionMT
  • GetDataLoker() : CXTPSyntaxEditLexTextSchema
  • GetDataManager() : CXTPGridControl, CXTPSyntaxEditDoc, CXTPSyntaxEditView
  • GetDataProvider() : CXTPCalendarControl, CXTPCalendarEvent, CXTPCalendarResource, CXTPCalendarResourcesManager, CXTPCalendarViewGroup
  • GetDataProvider_ConnStr() : CXTPCalendarResourcesManager
  • GetDataProvidersCount() : CXTPCalendarResourcesManager
  • GetDataSize() : CXTPSyntaxEditBatchCommand, CXTPSyntaxEditBufferCommand, CXTPSyntaxEditCommand, CXTPSyntaxEditReplaceStringCommand, CXTPSyntaxEditUndoRedoManager
  • GetDataSource() : CXTPCalendarData, CXTPGridDataManager
  • GetDataStream() : CXTPImageManagerVectorImageHandle
  • GetDate() : CXTPDatePickerItemDay, CXTPPropertyGridItemDate
  • GetDateFormat() : CXTPCalendarUtils
  • GetDatePicker() : CXTPCalendarController
  • GetDatePickerControl() : CXTPDatePickerItemDay
  • GetDateTime() : CXTPDateEdit
  • GetDateTimeCell() : CXTPCalendarDayViewGroup
  • GetDay() : CXTPCalendarDayView, CXTPDatePickerItemMonth, CXTPPropertyGridItemDate
  • GetDayBackColor() : CXTPDatePickerPaintManager
  • GetDayCount() : CXTPDatePickerItemMonth
  • GetDayDate() : CXTPCalendarMonthView::CMonthViewGrid, CXTPCalendarViewDay
  • GetDayEventsRect() : CXTPCalendarMonthViewDay, CXTPCalendarWeekViewDay
  • GetDayHeaderFormat() : CXTPCalendarView
  • GetDayHeaderHeight() : CXTPCalendarWeekView
  • GetDayHeight() : CXTPCalendarWeekView
  • GetDayIndex() : CXTPCalendarViewDay
  • GetDayMetrics() : CXTPDatePickerControl
  • GetDayOfWeekCount() : CXTPCalendarUtils
  • GetDayOfWeekIndex() : CXTPCalendarUtils
  • GetDayOfWeekLocaleStringId() : CXTPCalendarUtils
  • GetDayOfWeekMask() : CXTPCalendarUtils
  • GetDayOfWeekName() : CXTPDatePickerControl
  • GetDayRect() : CXTPCalendarMonthView::CMonthViewGrid, CXTPCalendarViewDay
  • GetDaysOfWeekBackColor() : CXTPDatePickerPaintManager
  • GetDaysOfWeekTextColor() : CXTPDatePickerPaintManager
  • GetDaysOfWeekTextFont() : CXTPDatePickerPaintManager
  • GetDayTextColor() : CXTPDatePickerPaintManager
  • GetDayTextFont() : CXTPDatePickerPaintManager
  • GetDayTextFontBold() : CXTPDatePickerPaintManager
  • GetDayView() : CXTPCalendarControl, CXTPCalendarDayViewTimeScale
  • GetDayWidth() : CXTPCalendarWeekView
  • GetDecimalPlaces() : CXTPChartNumberFormat
  • GetDefaultAccelerator() : CXTPShortcutManager
  • GetDefaultBlendingOptions() : CXTPFrameShadowManager
  • GetDefaultButtonSize() : CXTPMessageBarPaintManager
  • GetDefaultButtonStyle() : CXTPCommandBar
  • GetDefaultCfgFilePath() : CXTPSyntaxEditCtrl
  • GetDefaultCharFormat() : CXTPControlComboBox, CXTPControlEdit
  • GetDefaultClipOwner() : CXTPFrameShadowManager
  • GetDefaultColor() : CXTPColorPicker, CXTPFrameShadowManager
  • GetDefaultColorSet() : CAppearanceSetPropertyPage2003, CAppearanceSetPropertyPage2007, CAppearanceSetPropertyPageAccess2007, CAppearanceSetPropertyPageFlat, CAppearanceSetStateButtons, CXTPTabPaintManagerTheme, CXTPTabThemeFlat, CXTPTabThemeNativeWindows10, CXTPTabThemeNativeWindows11, CXTPTabThemeOffice2000, CXTPTabThemeOffice2013, CXTPTabThemeVisualStudio2003, CXTPTabThemeVisualStudio2010, CXTPTabThemeVisualStudio2012, CXTPTabThemeVisualStudio2015, CXTPTabThemeVisualStudio2017, CXTPTabThemeVisualStudio2019, CXTPTabThemeVisualStudio2022
  • GetDefaultCommandBarSize() : CXTPPaintManager
  • GetDefaultFileAssociations() : IXTPPreviewProvider
  • GetDefaultForeground() : CXTPMarkupContext
  • GetDefaultInnerSize() : CXTPFrameShadowManager
  • GetDefaultItem() : CXTPPopupBar
  • GetDefaultItemClass() : CXTPTaskPanelGroupItems, CXTPTaskPanelGroups, CXTPTaskPanelItems
  • GetDefaultLogFont() : CXTPMarkupContext
  • GetDefaultMarkupTemplate() : CXTPFlowGraphControl
  • GetDefaultMenuItem() : CXTPTrayIcon
  • GetDefaultMenuResource() : CXTPMenuBar
  • GetDefaultOffset() : CXTPFrameShadowManager
  • GetDefaultOuterSize() : CXTPFrameShadowManager
  • GetDefaultPaneOptions() : CXTPDockingPaneManager
  • GetDefaultSmoothingMode() : CXTPMarkupContext
  • GetDefaultTextSmoothing() : CXTPMarkupContext
  • GetDefaultTransparency() : CXTPFrameShadowManager
  • GetDefaultValue() : CXTPPropertyGridItem
  • GetDefColor() : CXTPColorSelectorCtrl
  • GetDelay() : CXTPSyntaxEditToolTipCtrl
  • GetDelayEditTimer() : CXTPGridControl
  • GetDeleteButton() : CXTPEditListBoxToolBar
  • GetDelimiters() : CXTPSyntaxEditAutoCompleteWnd
  • GetDepth() : CXTPChart3dPieSeriesStyle, CXTPChartPieSeriesStyleBase
  • GetDescription() : CXTPControl, CXTPControlAction, CXTPControlGalleryItem, CXTPPropertyGridItem
  • GetDescriptionText() : CXTPTrackBlock
  • GetDesiredSize() : CXTPMarkupUIElement
  • GetDiagram() : CXTPChartAxis, CXTPChartDiagramView, CXTPChartSeries
  • GetDiagram2DAppearance() : CXTPChartAppearance
  • GetDiagram3DAppearance() : CXTPChartAppearance
  • GetDiff_Months() : CXTPCalendarUtils
  • GetDimensionCount() : CXTPGaugeMeterType
  • GetDir() : CXTPSplitPath
  • GetDirection() : CXTPChartLegend, CXTPDockingPaneAutoHidePanel, CXTPDockingPaneSidePanel
  • GetDisabledBackColor() : CXTPHexEdit
  • GetDisabledHighlightBackColor() : CXTPHexEdit
  • GetDisabledHighlightTextColor() : CXTPHexEdit
  • GetDisabledIcon() : CXTPImageManagerIcon
  • GetDisabledTextColor() : CXTPHexEdit
  • GetDisableReorderColumnsCount() : CXTPGridControl
  • GetDiscreteSelectionCount() : CXTPCalendarView
  • GetDiscreteSelectionValue() : CXTPCalendarView
  • GetDisplayName() : CXTPBrowseDialog, CXTPSyntaxEditPropertiesPageColor
  • GetDisplayOptions() : CXTPGridColumn
  • GetDisplaySettings() : CXTPMultiMonitor
  • GetDisplayString() : CXTPCalendarTimeZone
  • GetDividerColor() : CXTPGridSection
  • GetDividerPos() : CXTPPropertyGridView
  • GetDividerPosition() : CXTPGridSection
  • GetDividerRect() : CXTPGridSection
  • GetDividerStyle() : CXTPGridSection
  • GetDock() : CXTPMarkupDockPanel
  • GetDockBar() : CXTPCommandBars, CXTPToolBar
  • GetDocking() : CXTPChartTitle
  • GetDockingContext() : CXTPDockingPaneManager
  • GetDockingContextStickerStyle() : CXTPDockingPaneManager
  • GetDockingPaneManager() : CXTPDockingPaneBase, CXTPDockingPaneSplitterWnd
  • GetDockingSite() : CXTPDockingPane, CXTPDockingPaneBase
  • GetDockState() : CXTPCommandBars
  • GetDocument() : CXTPSyntaxEditView
  • GetDocumentRow() : CXTPSyntaxEditCtrl
  • GetDomain() : CXTPChartFunnelSeriesViewBase, CXTPChartPieSeriesViewBase, CXTPChartPyramidSeriesViewBase
  • GetDontDropCursor() : CXTPGridHeader
  • GetDouble() : CXTPPropertyGridItemDouble
  • GetDoubleClickedItem() : CXTPShellListBase
  • GetDownButton() : CXTPEditListBoxToolBar
  • GetDownColor() : CXTPChartHighLowSeriesStyle
  • GetDpiScaled() : CXTPImageManagerIconHandle
  • GetDragControl() : CXTPCommandBars, CXTPCustomizeSheet
  • GetDraggingColumn() : CXTPGridHeader
  • GetDraggingEventNew() : CXTPCalendarView
  • GetDraggingEventOrig() : CXTPCalendarView
  • GetDraggingMode() : CXTPCalendarView
  • GetDragSensitivityX() : CXTPGridControl
  • GetDragSensitivityY() : CXTPGridControl
  • GetDragText() : CXTPTaskPanelGroupItem
  • GetDrawDisabledText() : CXTPStatusBar
  • GetDrawFooterDivider() : CXTPGridColumn
  • GetDrawFooterRowsVGrid() : CXTPGridColumn
  • GetDrawHeaderDivider() : CXTPGridColumn
  • GetDrawHeaderRowsVGrid() : CXTPGridColumn
  • GetDrawingObjectFactory() : CXTPChartDeviceContext
  • GetDrawStyle() : CXTPHeaderCtrlTheme
  • GetDrawTextProcessor() : CXTPSyntaxEditCtrl
  • GetDrive() : CXTPSplitPath
  • GetDropDownItemCount() : CXTPPropertyGridItem
  • GetDropDownListStyle() : CXTPControlComboBox
  • GetDropDownWidth() : CXTPControlComboBox
  • GetDropListItemNumber() : CXTPGridInplaceButton, CXTPGridInplaceList
  • GetDropMarkerFlags() : CXTPGridControl
  • GetDroppedState() : CXTPControlComboBox
  • GetDropperRect() : CXTPEyeDropper
  • GetDropSource() : CXTPCommandBars
  • GetDropTarget() : CXTPPageScroller
  • GetDuration() : CXTPCalendarEvent, CXTPCalendarRecurrencePattern
  • GetDurationMinutes() : CXTPCalendarEvent, CXTPCalendarRecurrencePattern, CXTPCalendarUtils
  • GetEdirControl() : CXTPSyntaxEditFindReplaceDlg
  • GetEdit() : CXTPCalendarEventColorListBox
  • GetEditBuddy() : CXTPSpinButtonCtrl
  • GetEditBuffer() : CXTPSyntaxEditCtrl, CXTPSyntaxEditView
  • GetEditCtrl() : CXTPControlComboBox, CXTPControlEdit, CXTPSyntaxEditView
  • GetEditFont() : CXTPSyntaxEditPropertiesPageFont
  • GetEditGroup() : CXTPEditListBox
  • GetEditHeight() : CXTPRibbonPaintManager
  • GetEditHint() : CXTPControlAction, CXTPControlComboBox, CXTPControlEdit
  • GetEditIconId() : CXTPControlComboBox, CXTPControlEdit
  • GetEditingSubjectFromEditor() : CXTPCalendarViewEvent
  • GetEditItemText() : CXTPEditListBox
  • GetEditOptions() : CXTPGridColumn, CXTPGridRecordItem
  • GetEditorStyle() : CXTPPropertyGridItemColor
  • GetEditStyle() : CXTPControlComboBox, CXTPControlEdit, CXTPPropertyGridItem
  • GetEditText() : CXTPControlComboBox, CXTPControlEdit
  • GetEffectiveParent() : CXTPSyntaxEditCtrl
  • GetElementRect() : CXTPGridControl
  • GetEnable() : CXTPGridRecordItemControl
  • GetEnabled() : CXTPControl, CXTPControlAction, CXTPControlGalleryItem, CXTPDockingPane, CXTPPropertyGridInplaceButton, CXTPTaskPanelItem
  • GetEncodedXML() : CXTPPropExchangeXMLNode
  • GetEnd_disp() : CXTPSyntaxEditSelection
  • GetEnd_str() : CXTPSyntaxEditSelection
  • GetEndAfterOccurrences() : CXTPCalendarRecurrencePattern
  • GetEndOccurrenceTime() : CXTPCalendarRecurrencePattern
  • GetEndTagBeginXLC() : CXTPSyntaxEditLexTextBlock
  • GetEndTagEndXLC() : CXTPSyntaxEditLexTextBlock
  • GetEndTime() : CXTPCalendarEvent
  • GetEndTimeRect() : CXTPCalendarViewEvent
  • GetEngine() : CXTPActiveScriptObjectContext
  • GetEntries() : CXTPChartPalette
  • GetEntryNode() : CXTPPropExchangeXMLNode
  • GetEnum() : CXTPPropertyGridItemEnum
  • GetEnumerator() : CXTPPropExchange, CXTPPropExchangeXMLNode
  • GetEnumProperty() : CXTPSkinManagerSchema
  • GetEOL() : CXTPSyntaxEditTextIterator
  • GetErrorBar() : CXTPChartSeriesStyle
  • GetErrorCode() : CXTPRegistryManager
  • GetErrorMessage() : CXTPRegistryManager
  • GetEvent() : CXTPCalendarData, CXTPCalendarReminder, CXTPCalendarViewEvent
  • GetEventBackColor() : CXTPCalendarOffice2013Theme, CXTPCalendarPaintManager
  • GetEventCaptionFormat() : CXTPCalendarMonthView
  • GetEventCategories() : CXTPCalendarData
  • GetEventDurationInPixels() : CXTPCalendarTimeLineViewEvent
  • GetEventDurationMin() : CXTPCalendarDayView, CXTPCalendarView
  • GetEventEdgeColor() : CXTPCalendarOffice2013Theme
  • GetEventID() : CXTPCalendarEvent
  • GetEventPeriodDays() : CXTPCalendarEvent, CXTPCalendarUtils
  • GetEventPlaceCount() : CXTPCalendarDayViewEvent
  • GetEventPlaceNumber() : CXTPCalendarViewEvent
  • GetEventPlacePos() : CXTPCalendarDayViewEvent
  • GetEventRect() : CXTPCalendarViewEvent
  • GetEventsCountInAllDayArea() : CXTPCalendarDayViewGroup
  • GetEventSink() : CXTPWebBrowserCtrl
  • GetEventsRect() : CXTPCalendarDayViewEvent
  • GetEventTimelinePlaceNumber() : CXTPCalendarViewEvent
  • GetEventTimeWidth() : CXTPCalendarMonthView
  • GetExceptionData() : CXTPActiveScriptEngine
  • GetExceptionInfo() : CXTPActiveScriptEngine
  • GetExceptions() : CXTPCalendarRecurrencePattern
  • GetExecuteOnPressInterval() : CXTPControl
  • GetExpandButtonCheck() : CXTPCalendarCaptionBarTheme
  • GetExpanded() : CXTPControl
  • GetExpandedClientHeight() : CXTPTaskPanelGroup
  • GetExpandedLinesCount() : CXTPShortcutBar
  • GetExpandedLinesHeight() : CXTPShortcutBar
  • GetExpandSignRect() : CXTPCalendarViewDay
  • GetExpandSignSize() : CXTPCalendarPaintManager
  • GetExplodedDistancePercent() : CXTPChartPieSeriesStyleBase
  • GetExt() : CXTPSplitPath
  • GetExtendedColors() : CXTPColorSelectorCtrl
  • GetExtendedCount() : CXTPColorSelectorCtrl
  • GetExtendedStyle() : CXTPListBase
  • GetExtensionRoot() : CXTPMarkupContext
  • GetExtent() : CXTPIconHandle, CXTPImageManagerIcon, CXTPImageManagerIconHandle, CXTPImageManagerResource, CXTPResourceImage, CXTPSkinImage, CXTPSkinImages
  • GetExternal() : CXTPWebBrowserCtrl
  • GetExtLogPen() : CXTPPen
  • GetFadedIcon() : CXTPImageManagerIcon
  • GetFileExt() : CXTPSyntaxEditBufferManager, CXTPSyntaxEditTextIterator
  • GetFileName() : CXTPSyntaxEditColorTheme
  • GetFillAcrossXAxis() : CXTPChartAreaSeriesStyle
  • GetFillMode() : CXTPChartFillStyle
  • GetFillStyle() : CXTPChartAreaSeriesStyle, CXTPChartAxisStrip, CXTPChartFunnelSeriesStyleBase, CXTPChartLegend, CXTPChartPyramidSeriesStyleBase, CXTPChartRadarAreaSeriesStyle
  • GetFilterEditCtrl() : CXTPGridHeader
  • GetFilterText() : CXTPGridControl
  • GetFinalRect() : CXTPMarkupUIElement
  • GetFinanceStyleAppearance() : CXTPChartAppearance
  • GetFindReplaceDlg() : CXTPSyntaxEditView
  • GetFinishPoint() : CXTPChartPieBase
  • GetFirst() : CXTPControls
  • GetFirstClockRect() : CXTPCalendarViewEvent
  • GetFirstColumn() : CXTPMarkupUniformGrid
  • GetFirstDayOfWeek() : CXTPCalendarControl, CXTPCalendarMonthView::CMonthViewGrid, CXTPDatePickerControl
  • GetFirstLineMark() : CXTPSyntaxEditLineMarksManager
  • GetFirstModule() : CXTPToolhelpApi
  • GetFirstMruID() : CXTPControlRecentFileList, CXTPRibbonControlSystemRecentFileList
  • GetFirstPane() : CXTPDockingPaneBaseContainer
  • GetFirstParamNamePosition() : CXTPSyntaxEditColorInfo
  • GetFirstSelectedItem() : CXTPTreeBase
  • GetFirstSelectedRowPosition() : CXTPGridSelectedRows
  • GetFirstShadowPosition() : CXTPFrameShadowManager
  • GetFirstThread() : CXTPToolhelpApi
  • GetFirstView() : CXTPSyntaxEditDoc
  • GetFirstVisibleAllDayEvent() : CXTPCalendarDayViewGroup
  • GetFirstVisibleColumn() : CXTPGridColumns
  • GetFirstVisibleItem() : CXTPTaskPanelItems
  • GetFirstWeekOfYearDays() : CXTPCalendarControl, CXTPCalendarUtils, CXTPDatePickerControl
  • GetFlags() : CXTPCommandBar, CXTPControl, CXTPFrameShadowManager, CXTPGridRecordItemControl, CXTPPropertyGridItem, CXTPPropertyGridItemFlags, CXTPTabClientWnd, CXTPTabManagerNavigateButton
  • GetFlagsString() : CXTPPropertyGridItemFlags
  • GetFlatStyle() : CXTPButton, CXTPComboBox, CXTPEdit, CXTPProgressCtrl
  • GetFloatingFramesOpacity() : CXTPDockingPaneManager
  • GetFName() : CXTPSplitPath
  • GetFocusedColumn() : CXTPGridControl
  • GetFocusedControl() : CXTPRibbonBackstageView
  • GetFocusedItem() : CXTPTaskPanel, CXTPTreeBase
  • GetFocusedLink() : CXTPTaskDialogLinkCtrl
  • GetFocusedRecordItem() : CXTPGridControl
  • GetFocusedRow() : CXTPGridControl, CXTPGridRows, CXTPGridSection, CXTPGridSections
  • GetFocusedRowIndex() : CXTPGridRows
  • GetFolderData() : CXTPDirWatcher
  • GetFolderItemPath() : CXTPShellTreeBase
  • GetFolderPath() : CXTPDirWatcher
  • GetFont() : CXTPChartAxisConstantLine, CXTPChartAxisLabel, CXTPChartAxisTitle, CXTPChartLegend, CXTPChartSeriesLabel, CXTPChartTextElement, CXTPChartTitle, CXTPFontManager, CXTPGridRecordItem, CXTPGridRecordItemControl, CXTPPropertyGridItemFont, CXTPStatusBar, CXTPSyntaxEditPaintManager, CXTPTabPaintManager, CXTPToolTipContext, XTP_DAYITEM_METRICS
  • GetFontBold() : CXTPFontManager
  • GetFontCharset() : CXTPResourceManager
  • GetFontFamily() : CXTPMarkupTextBlock
  • GetFontHeight() : CXTPCheckListBox, CXTPCommandBars, CXTPRibbonBar, CXTPRibbonPaintManager
  • GetFontItalic() : CXTPFontManager
  • GetFontItalicBold() : CXTPFontManager
  • GetFontItemHeight() : CXTPFontCtrlBase
  • GetFontLineNumber() : CXTPSyntaxEditPaintManager
  • GetFontList() : CXTPFontEnum
  • GetFontProperty() : CXTPSkinManagerSchema
  • GetFontSize() : CXTPMarkupTextBlock
  • GetFontStyle() : CXTPMarkupTextBlock
  • GetFontText() : CXTPSyntaxEditPaintManager
  • GetFontToolTip() : CXTPSyntaxEditPaintManager
  • GetFontVertical() : CXTPFontManager
  • GetFontVerticalBold() : CXTPFontManager
  • GetFontWeight() : CXTPMarkupTextBlock
  • GetFooterAlignment() : CXTPGridColumn
  • GetFooterFont() : CXTPGridColumn
  • GetFooterHeight() : CXTPGridPaintManager
  • GetFooterText() : CXTPGridColumn
  • GetForeground() : CXTPMarkupControl, CXTPMarkupTextBlock
  • GetForegroundColor() : CXTPPreviewCtrl, IXTPPreviewHost
  • GetFormat() : CXTPChartAxisLabel, CXTPChartSeriesLabel
  • GetFormatString() : CXTPGridGroupRow, CXTPGridRecordItem
  • GetFormula() : CXTPGridGroupRow, CXTPGridRecordItem
  • GetFrameAccelerator() : CXTPCustomizeKeyboardPage
  • GetFrameBorder() : CXTPFrameThemeOffice2007System, CXTPRibbonMarkupFrameTheme
  • GetFrameCaptionAccentTextColor() : CXTPFramePaintManager
  • GetFrameCaptionActiveColor() : CXTPFramePaintManager
  • GetFrameCaptionHeight() : CXTPFramePaintManager
  • GetFrameHook() : CXTPCommandBars, CXTPRibbonBar
  • GetFrameLargeIcon() : CXTPFramePaintManager
  • GetFramePaintManager() : CXTPCommandBarsFrameHook, CXTPCommandBarsModernUITheme, CXTPPaintManager, CXTPResourceTheme, CXTPRibbonPaintManager
  • GetFrameReBar() : CXTPCommandBars
  • GetFrameSite() : CXTPCommandBar
  • GetFrameSmallIcon() : CXTPFramePaintManager
  • GetFrameWnd() : CXTPMDIWndTab
  • GetFreeHeight() : CXTPGridRecord
  • GetFreezeColsDividerStyle() : CXTPGridPaintManager
  • GetFreezeColumnsCount() : CXTPGridControl
  • GetFreezeColumnsIndex() : CXTPGridControl
  • GetFrozenColWidth() : CXTPHeaderCtrl
  • GetFullColScrollInfo() : CXTPGridHeader
  • GetFullName() : CXTPSplitPath
  • GetFullPath() : CXTPSplitPath
  • GetFullyQualPidl() : CXTPShellPidl
  • GetG() : CXTPChartColor
  • GetGalleryPaintManager() : CXTPControlGallery, CXTPPaintManager
  • GetGlobalContext() : CXTPActiveScriptEngine
  • GetGlobalPaintManager() : CXTPPaintManager
  • GetGlyphs() : CXTPGridPaintManager
  • GetGlyphSize() : CXTPButton
  • GetGpImage() : CXTPMarkupGdiPlusImage
  • GetGradientAngle() : CXTPChartFillStyle
  • GetGreen() : CXTPChartColor
  • GetGrid() : CXTPCalendarMonthView, CXTPPropertyGridInplaceButton, CXTPPropertyGridItem
  • GetGridAreaRows() : CXTPGridControl
  • GetGridCtrl() : CXTPGridFilterEditControl, CXTPGridSubListControl, CXTPGridView
  • GetGridHeader() : CXTPGridColumns, CXTPGridControl
  • GetGridLines() : CXTPChartAxis
  • GetGridSpacing() : CXTPChartAxis
  • GetGridStyle() : CXTPGridControl
  • GetGridView() : CXTPPropertyGrid
  • GetGripperPosition() : CXTPExcelTabCtrl
  • GetGripperRect() : CXTPShortcutBar
  • GetGroup() : CXTPFlowGraphNode
  • GetGroupByHeight() : CXTPGridHeader
  • GetGroupCaption() : CXTPGridRecordItem
  • GetGroupCaptionHeight() : CXTPRibbonPaintManager
  • GetGroupCaptionID() : CXTPGridRecordItem
  • GetGroupCaptionValue() : CXTPGridRecordItem, CXTPGridRecordItemDateTime, CXTPGridRecordItemNumber, CXTPGridRecordItemVariant
  • GetGroupColors() : CXTPTaskPanelPaintManager
  • GetGroupCount() : CXTPTaskPanel
  • GetGroupHeight() : CXTPCalendarTimeLineViewGroup
  • GetGroupIconSize() : CXTPTaskPanel
  • GetGroupIndex() : CXTPCalendarViewGroup
  • GetGroupInnerMargins() : CXTPTaskPanelPaintManager
  • GetGroupLevel() : CXTPGridRow
  • GetGroupOuterMargins() : CXTPTaskPanelPaintManager
  • GetGroupPriority() : CXTPGridRecordItem
  • GetGroups() : CXTPFlowGraphPage, CXTPRibbonTab, CXTPTaskPanel
  • GetGroupsHeight() : CXTPRibbonBar
  • GetGroupsOrder() : CXTPGridColumns
  • GetGroupSpacing() : CXTPTaskPanelPaintManager
  • GetGroupsRect() : CXTPRibbonBar, CXTPRibbonTabPopupToolBar
  • GetHalfAngle() : CXTPChartPieBase
  • GetHandle() : CXTPModuleHandle, CXTPResourceImages, CXTPTabManagerItem
  • GetHasCheckbox() : CXTPGridRecordItem
  • GetHatchStyle() : CXTPChartFillStyle
  • GetHDC() : CXTPChartDeviceContext
  • GetHeaderAlignment() : CXTPGridColumn
  • GetHeaderClipBox() : CXTPTabPaintManagerTheme, CXTPTabThemeOffice2000
  • GetHeaderDateFormat() : CXTPCalendarTimeLineViewTimeScalePart
  • GetHeaderHeight() : CXTPCalendarTimeLineViewTimeScalePart, CXTPGridPaintManager, CXTPTabPaintManagerTheme
  • GetHeaderIndent() : CXTPGridControl
  • GetHeaderMargin() : CAppearanceSetPropertyPage2003, CAppearanceSetPropertyPageAccess2007, CAppearanceSetVisualStudio2005, CXTPTabPaintManagerTheme, CXTPTabThemeExcel2003
  • GetHeaderOffset() : CXTPTabManager
  • GetHeaderRect() : CAppearanceSetVisio, CXTPCalendarViewGroup, CXTPTabBaseTheme, CXTPTabManager, CXTPTabPaintManagerTheme
  • GetHeaderTextFont() : CXTPDatePickerPaintManager
  • GetHeadPosition() : CXTPDockingPaneBaseContainer, CXTPShadowManager
  • GetHeight() : CXTPControl, CXTPGridRecordItemControl, CXTPGridRow, CXTPGridSection, CXTPImageManagerIcon, CXTPMarkupFrameworkElement, CXTPMatrix< T >, CXTPMessageBar, CXTPMessageBarPaintManager, CXTPPropertyGridItem, CXTPResourceImage, CXTPShortcutBarPaneItem, CXTPSkinImage, CXTPTabClientDraggingContents
  • GetHeightMode() : CXTPGridSection
  • GetHeightPercent() : CXTPTrackBlock
  • GetHeightToWidthRatio() : CXTPChartFunnelSeriesStyleBase, CXTPChartPyramidSeriesStyleBase
  • GetHelpBackColor() : CXTPPropertyGrid
  • GetHelpForeColor() : CXTPPropertyGrid
  • GetHelpHeight() : CXTPPropertyGrid
  • GetHelpId() : CXTPControl, CXTPControlAction
  • GetHelpTrackingId() : CXTPCommandBars
  • GetHexParam() : CXTPSyntaxEditColorInfo
  • GetHiddenColIndex() : CXTPSplitterWnd
  • GetHiddenControls() : CXTPCommandBars
  • GetHiddenRowIndex() : CXTPSplitterWnd
  • GetHideFlags() : CXTPControl
  • GetHighlightBackColor() : CXTPHexEdit
  • GetHighlightedControl() : CXTPRibbonBackstageView
  • GetHighlightedGroup() : CXTPRibbonBar
  • GetHighlightOffset() : CXTPTaskPanelPaintManager
  • GetHighlightTextColor() : CXTPHexEdit
  • GetHighlightToday() : CXTPDatePickerControl
  • GetHighlightTodayBackColor() : CXTPDatePickerThemeOffice2013
  • GetHighlightTodayBorderColor() : CXTPDatePickerThemeOffice2013
  • GetHighlightTodayColor() : CXTPDatePickerPaintManager
  • GetHighlightTodayTextColor() : CXTPDatePickerThemeOffice2013
  • GetHiliteBackColor() : CXTPSyntaxEditPaintManager
  • GetHiliteTextColor() : CXTPSyntaxEditPaintManager
  • GetHint() : CXTPGridFilterEditControl
  • GetHistory() : CXTPFlowGraphControl
  • GetHitTestRect() : CXTPTaskPanelGroup, CXTPTaskPanelGroupItem, CXTPTaskPanelItem
  • GetHolePercent() : CXTPChartPieBase, CXTPChartPieSeriesStyleBase
  • GetHorizontalAlignment() : CXTPChartLegend, CXTPMarkupFrameworkElement
  • GetHorzScrollBar() : CXTPSyntaxEditCtrl, CXTPSyntaxEditView
  • GetHost() : CXTPPreviewProviderBase
  • GetHotIcon() : CXTPImageManagerIcon
  • GetHotItem() : CXTPShortcutBar, CXTPTaskPanel
  • GetHotTrackStyle() : CXTPTaskPanel
  • GetHours() : CXTPTimeEdit
  • GetHoverColor() : CXTPHyperLink
  • GetHoverRect() : CXTPCalendarTip, CXTPGridTip
  • GetHScrollStep() : CXTPGridControl
  • GetHyperlinkAt() : CXTPGridRecordItem
  • GetHyperlinks() : CXTPGridRecordItem
  • GetHyperlinksCount() : CXTPGridRecordItem
  • GetIcon() : CXTPButton, CXTPDockingPane, CXTPDockingPaneManager, CXTPFlowGraphImage, CXTPImageEditorDlg, CXTPImageManagerIcon, CXTPImageManagerIconHandle, CXTPImageManagerIconSet, CXTPImageManagerImageList, CXTPMarkupGdiPlusImage, CXTPTrayIcon
  • GetIconFont() : CXTPPaintManager
  • GetIconHandle() : CXTPImageManagerImageList
  • GetIconID() : CXTPDockingPane, CXTPGridColumn
  • GetIconId() : CXTPControl, CXTPControlAction, CXTPRibbonGroup, CXTPShortcutBarItem
  • GetIconIndent() : CXTPTreeBase
  • GetIconIndex() : CXTPGridInplaceButton, CXTPGridRecordItem, CXTPGridRecordItemControl, CXTPPopupItem, CXTPPropertyGridInplaceButton, CXTPStatusBarPane, CXTPTaskPanelItem
  • GetIconOffset() : CXTPPopupItem
  • GetIconPadding() : CXTPTaskPanelItem
  • GetIcons() : CXTPImageManagerIconSet
  • GetIconSet() : CXTPImageManager
  • GetIconsInfo() : CXTPPaintManager
  • GetIconSize() : CXTPCommandBar, CXTPControl, CXTPImageManagerImageList, CXTPRibbonBar, CXTPRibbonControlSystemPopupBarButton, CXTPRibbonTabPopupToolBar
  • GetID() : CXTPCalendarEventCategory, CXTPCalendarSchedule, CXTPControl, CXTPControlAction, CXTPControlGalleryItem, CXTPDockingPane, CXTPDockingPaneCaptionButton, CXTPFlowGraphConnectionPoint, CXTPFlowGraphNode, CXTPFlowGraphPage, CXTPFlowGraphUndoCommand, CXTPGridInplaceButton, CXTPImageManagerIcon, CXTPImageManagerIconSet, CXTPPopupControl, CXTPPopupItem, CXTPPropertyGridInplaceButton, CXTPPropertyGridItem, CXTPPropertyGridVerb, CXTPRibbonGroup, CXTPRibbonTab, CXTPShortcutBarItem, CXTPStatusBarPane, CXTPTabManagerNavigateButton, CXTPTaskPanelItem, CXTPTrackUndoCommand
  • GetImage() : CXTPBrowseDialog, CXTPControl, CXTPControlGalleryItem, CXTPFlowGraphConnectionPoint, CXTPFlowGraphImage, CXTPFlowGraphNode, CXTPImageManager, CXTPPopupItem, CXTPPropertyGridInplaceButton, CXTPPropertyGridItemConstraint, CXTPShortcutBarItem, CXTPStatusBarPane, CXTPTaskPanelItem
  • GetImageAlignment() : CXTPButton
  • GetImageColor() : CXTPResourceImages
  • GetImageColorKey() : CXTPMarkupContext
  • GetImageCount() : CXTPImageList
  • GetImageGap() : CXTPButton
  • GetImageIndex() : CXTPControlGalleryItem, CXTPFlowGraphConnectionPoint, CXTPFlowGraphNode, CXTPTabManagerItem
  • GetImageInfo() : CXTPImageList
  • GetImageInt() : CXTPResourceImages
  • GetImageList() : CXTPImageManager, CXTPImageManagerIcon
  • GetImageManager() : CXTPCommandBar, CXTPCommandBars, CXTPControl, CXTPControlGalleryItems, CXTPDockingPaneManager, CXTPFlowGraphImages, CXTPGridControl, CXTPHeaderCtrl, CXTPMarkupContext, CXTPPasswordPeek, CXTPPopupControl, CXTPPropertyGrid, CXTPPropertyGridView, CXTPRibbonBackstageView, CXTPShortcutBar, CXTPStatusBar, CXTPSyntaxEditAutoCompleteWnd, CXTPTabControl, CXTPTaskPanel
  • GetImageRect() : CXTPResourceImages
  • GetImages() : CXTPFlowGraphControl, CXTPFramePaintManager, CXTPImageManager, CXTPResourceTheme, CXTPRibbonPaintManager, CXTPSkinManagerClass
  • GetImageSize() : CXTPButton, CXTPResourceImages
  • GetImageString() : CXTPResourceImages
  • GetImageValue() : CXTPResourceImages
  • GetImageWidth() : CXTPControlGalleryItem
  • GetImportance() : CXTPCalendarEvent
  • GetInactiveHiliteBackColor() : CXTPSyntaxEditPaintManager
  • GetInactiveHiliteTextColor() : CXTPSyntaxEditPaintManager
  • GetIndent() : CXTPChartTitle, CXTPGridColumn, CXTPGridControl, CXTPPropertyGridItem
  • GetIndentColumn() : CXTPGridColumns
  • GetIndentLevel() : CXTPGridHeader
  • GetIndex() : CXTPCalendarEventColorEdit, CXTPCalendarTimeZone, CXTPChartAxis, CXTPControl, CXTPControlGalleryItem, CXTPGridColumn, CXTPGridRecord, CXTPGridRecordItem, CXTPGridRecordItemConstraint, CXTPGridRecordItemControl, CXTPGridRow, CXTPGridSection, CXTPPropertyGridInplaceButton, CXTPPropertyGridItem, CXTPPropertyGridItemConstraint, CXTPPropertyGridVerb, CXTPRibbonGroup, CXTPStatusBarPane, CXTPTabManagerItem, CXTPTaskPanelItem, CXTPTaskPanelItems, CXTPTrackBlock
  • GetINIFileName() : CXTPRegistryManager
  • GetIniFileName() : CXTPSkinManagerResourceFile
  • GetInitFlags() : CXTPComInitializer
  • GetInitializationStatus() : CXTPComInitializer
  • GetInitialTextRect() : CXTPChartRotatedTextPainterBase
  • GetInlines() : CXTPMarkupTextBlock
  • GetInnerBounds() : CXTPChartDiagramDomain, CXTPChartFunnelSeriesView, CXTPChartFunnelSeriesViewBase, CXTPChartPieSeriesViewBase, CXTPChartPyramidSeriesView, CXTPChartPyramidSeriesViewBase
  • GetInnerMargins() : CXTPTaskPanelGroup
  • GetInnerSize() : CXTPFrameShadow
  • GetInplaceButtons() : CXTPGridControl, CXTPPropertyGridItem
  • GetInplaceControls() : CXTPPropertyGridItem
  • GetInPlacedEditValue() : CXTPPropertyGridItem
  • GetInplaceEdit() : CXTPGridControl, CXTPPropertyGridItem
  • GetInplaceList() : CXTPGridControl, CXTPPropertyGridItem
  • GetInputBoxText() : CXTPTaskDialog
  • GetInputConnectionAt() : CXTPFlowGraphConnectionPoint
  • GetInputConnectionsCount() : CXTPFlowGraphConnectionPoint
  • GetInputNode() : CXTPFlowGraphConnection
  • GetInputPoint() : CXTPFlowGraphConnection
  • GetInsertMarkColor() : CXTPTreeBase
  • GetInsideRect() : CXTPSplitterWndEx
  • GetInstance() : CXTPSingletonPointer
  • GetInstanceAddRef() : CXTPPaintManager
  • GetInterface() : CXTPSmartPtrInternalT< _TObject >
  • GetInterlacedColor() : CXTPChartAxis
  • GetInterlacedColor2() : CXTPChartAxis
  • GetInterlacedFillStyle() : CXTPChartAxis
  • GetInternalArgumentValue() : CXTPChartSeriesPoint
  • GetInternalName() : CXTPGridColumn
  • GetInternalValue() : CXTPChartSeriesPointView
  • GetIntProperty() : CXTPSkinManagerSchema
  • GetInvalidateRect() : CXTPTaskPanelGroup, CXTPTaskPanelItem
  • GetInvertedStep() : CXTPChartStepLineSeriesStyle
  • GetIsCanHScrollGroupsLeft() : CXTPCalendarDayView
  • GetIsCanHScrollGroupsRight() : CXTPCalendarDayView
  • GetItem() : CXTPControlGallery, CXTPControlGalleryItems, CXTPGridInplaceButton, CXTPGridInplaceEdit, CXTPGridRecord, CXTPMarkupDefinitionCollection, CXTPMarkupUIElementCollection, CXTPPopupControl, CXTPPropertyGrid, CXTPPropertyGridInplaceButton, CXTPPropertyGridInplaceEdit, CXTPPropertyGridView, CXTPShortcutBar, CXTPShortcutBarPane, CXTPTabClientWnd, CXTPTabManager, CXTPTabManagerNavigateButton, CXTPTrackBlock
  • GetItemBackColor() : CXTPPropertyGridPaintManager, CXTPTreeBase, CXTPTreeTheme
  • GetItemBold() : CXTPTreeBase
  • GetItemCaption() : CXTPControlGallery, CXTPDockingPaneWindowSelect, CXTPGridSubListControl, CXTPTabManager
  • GetItemColor() : CXTPDockingPane, CXTPDockingPanePanelColorSet2012, CXTPDockingPaneTabColorSet2012, CXTPDockingPaneTabColorSet2013, CXTPTabClientWnd, CXTPTabColorSetOffice2013, CXTPTabColorSetVisualStudio2012, CXTPTabColorSetVisualStudio2015, CXTPTabManager, CXTPTabPaintManagerColorSet, CXTPTreeBase
  • GetItemColumn() : CXTPGridSubListControl
  • GetItemControls() : CXTPGridRecordItem
  • GetItemCount() : CXTPControlGallery, CXTPControlGalleryItems, CXTPExcelTabCtrl, CXTPGridRecord, CXTPPopupControl, CXTPShortcutBar, CXTPTabClientWnd, CXTPTabManager, CXTPTaskPanelGroup
  • GetItemData() : CXTPControlComboBox, CXTPGridRecordItem, CXTPPropertyGridItem, CXTPShortcutBarItem, CXTPTaskPanelItem
  • GetItemDescription() : CXTPDockingPaneWindowSelect
  • GetItemDrawRect() : CXTPControlGallery
  • GetItemExpanderRect() : CXTPTreeBase
  • GetItemFont() : CXTPPropertyGridPaintManager, CXTPTaskPanelItem, CXTPTaskPanelPaintManager, CXTPTreeBase
  • GetItemGroup() : CXTPTaskPanelGroupItem, CXTPTaskPanelItem
  • GetItemHeight() : CXTPGridPaintManager
  • GetItemIcon() : CXTPShellPidl, CXTPTabClientWnd, CXTPTabManager
  • GetItemIconPadding() : CXTPTaskPanelPaintManager
  • GetItemIconRect() : CXTPTreeBase
  • GetItemIconSize() : CXTPTaskPanel, CXTPTaskPanelGroup
  • GetItemID() : CXTPStatusBar
  • GetItemIndex() : CXTPGridColumn
  • GetItemInnerMargins() : CXTPTaskPanelPaintManager
  • GetItemLayout() : CXTPTaskPanel, CXTPTaskPanelGroup
  • GetItemMetrics() : CXTPGridControl, CXTPGridRecord, CXTPGridRecordItem, CXTPGridRecordItemPreview, CXTPGridRow, CXTPPropertyGridPaintManager, CXTPTabManager
  • GetItemOuterMargins() : CXTPTaskPanelPaintManager
  • GetItemPane() : CXTPDockingPaneTabbedContainer
  • GetItemPath() : CXTPDockingPaneWindowSelect, CXTPShellListBase
  • GetItemPreview() : CXTPGridRecord
  • GetItemRect() : CXTPExcelTabCtrl, CXTPGridRow, CXTPPropertyGridItem, CXTPShortcutBarItem, CXTPStatusBar, CXTPTaskPanelGroupItem
  • GetItemRow() : CXTPTabManagerItem
  • GetItems() : CXTPControlGallery, CXTPTaskPanelGroup
  • GetItemsBorderHeight() : CXTPPropertyGridPaintManager
  • GetItemsInRow() : CXTPTaskPanelGroup
  • GetItemSize() : CXTPControlGalleryItems, CXTPShortcutBar
  • GetItemsLength() : CXTPDockingPaneAutoHidePanel, CXTPTabManager
  • GetItemsRect() : CXTPControlGallery
  • GetItemState() : CXTPTreeBase
  • GetItemStateIconRect() : CXTPTreeBase
  • GetItemText() : CXTPCalendarViewEvent, CXTPExcelTabCtrl, CXTPTabClientWnd
  • GetItemTextBody() : CXTPCalendarViewEvent
  • GetItemTextColor() : CXTPPropertyGridPaintManager, CXTPTreeBase, CXTPTreeTheme
  • GetItemTextEndTime() : CXTPCalendarViewEvent
  • GetItemTextEventTimeMax() : CXTPCalendarView
  • GetItemTextExtent() : CXTPMarkupTreeCtrl
  • GetItemTextLocation() : CXTPCalendarViewEvent
  • GetItemTextStartTime() : CXTPCalendarViewEvent
  • GetItemTextSubject() : CXTPCalendarViewEvent
  • GetItemTooltip() : CXTPTabClientWnd, CXTPTabManager
  • GetItemWindow() : CXTPExcelTabCtrl
  • GetKey() : CXTPControlAction
  • GetKeyboardManager() : CXTPCommandBars
  • GetKeyboardTip() : CXTPControl, CXTPControlAction, CXTPRibbonTab
  • GetKeyboardTipsBackColor() : CXTPRibbonBackstageView
  • GetKeyboardTipsFont() : CXTPRibbonBackstageView
  • GetKeyboardWindowSelectClass() : CXTPDockingPaneManager
  • GetKeyNameText() : CXTPShortcutManager
  • GetLabel() : CXTPCalendarEvent, CXTPCalendarEventColorListBox, CXTPChartAxis, CXTPChartSeriesStyle
  • GetLabelAnchorOrigin() : CXTPChart3dFunnelSeriesLabelView, CXTPChart3dPieSeriesLabelView, CXTPChart3dPyramidSeriesLabelView
  • GetLabelAnchorPoint() : CXTPChart3dFunnelSeriesLabelView, CXTPChart3dPieSeriesLabelView, CXTPChart3dPyramidSeriesLabelView
  • GetLabelID() : CXTPCalendarEvent, CXTPCalendarEventLabelComboBox
  • GetLabelList() : CXTPCalendarData
  • GetLabelRect() : CXTPChart3dFunnelSeriesLabelDeviceCommand, CXTPChart3dPieSeriesLabelDeviceCommand, CXTPChart3dPyramidSeriesLabelDeviceCommand
  • GetLabelsView() : CXTPChartDiagramView
  • GetLabelText() : CXTPChartSeriesPoint
  • GetLabelWidth() : CXTPControlComboBox, CXTPControlEdit
  • GetLanguage() : CXTPMarkupXtpScript
  • GetLargeIconSize() : CXTPCommandBar
  • GetLastChildFill() : CXTPMarkupDockPanel
  • GetLastChildRow() : CXTPGridRow
  • GetLastClockRect() : CXTPCalendarViewEvent
  • GetLastComError() : CXTPGridDataManager
  • GetLastITEM() : CXTPShellPidl
  • GetLastItem() : CXTPTreeBase
  • GetLastKnownChildView() : CXTPTabExBase
  • GetLastLineMark() : CXTPSyntaxEditLineMarksManager
  • GetLastModificationTime() : CXTPCalendarEvent
  • GetLastPane() : CXTPDockingPaneBaseContainer
  • GetLastParsedBlock() : CXTPSyntaxEditLexTextSchema
  • GetLastRqstEditCol() : CXTPGridControl
  • GetLastRqstEditRow() : CXTPGridControl
  • GetLastSelectedDate() : CXTPCalendarView
  • GetLastSelectedTabClientSticker() : CXTPTabClientContext
  • GetLastSelectedViewEvent() : CXTPCalendarView
  • GetLastTargetTabClient() : CXTPTabClientContext
  • GetLastVisibleAllDayEvent() : CXTPCalendarDayViewGroup
  • GetLastVisibleColumn() : CXTPGridColumns
  • GetLastVisibleItem() : CXTPTaskPanelItems
  • GetLastVisibleRect() : CXTPCalendarTimeLineViewEvent
  • GetLastWorkspace() : CXTPTabClientContext
  • GetLayout() : CXTPDockingPaneManager, CXTPTabManager, CXTPTabPaintManager
  • GetLayoutClip() : CXTPMarkupUIElement, CXTPMarkupVisual
  • GetLBCurSel() : CXTPCalendarEventCategoryComboBox, CXTPSyntaxEditColorComboBox
  • GetLBText() : CXTPControlComboBox, CXTPSyntaxEditPropertiesPageFont
  • GetLeft() : CXTPGridThickness, CXTPMarkupThickness, CXTPRectT< T >
  • GetLeftOffset() : CXTPGridControl
  • GetLegend() : CXTPChartContent
  • GetLegendAppearance() : CXTPChartContentAppearance
  • GetLegendItem() : CXTPChartSeries
  • GetLegendName() : CXTPChartAxisConstantLine, CXTPChartAxisStrip, CXTPChartLegendItemView, CXTPChartSeriesPointView
  • GetLegendText() : CXTPChartSeries, CXTPChartSeriesPoint
  • GetLegendView() : CXTPChartContentView
  • GetLength() : CXTPChartAxisTickMarks, CXTPTrackBlock
  • GetLexConfigurationManager() : CXTPSyntaxEditBufferManager, CXTPSyntaxEditCtrl, CXTPSyntaxEditView
  • GetLexParser() : CXTPSyntaxEditBufferManager, CXTPSyntaxEditView
  • GetLightAmbientColor() : CXTPChart3dDeviceContext
  • GetLightDiffuseColor() : CXTPChart3dDeviceContext
  • GetLightModelAmbientColor() : CXTPChart3dDeviceContext
  • GetLightPosition() : CXTPChart3dDeviceContext
  • GetLightSpecularColor() : CXTPChart3dDeviceContext
  • GetLineColor() : CXTPChartSeriesLabel
  • GetLineLen() : CXTPSyntaxEditTextIterator
  • GetLineLenBytes() : CXTPSyntaxEditTextIterator
  • GetLineLength() : CXTPChartSeriesLabel
  • GetLineMarkAt() : CXTPSyntaxEditLineMarksManager
  • GetLineMarksManager() : CXTPSyntaxEditBufferManager, CXTPSyntaxEditCtrl
  • GetLineNodeRect() : CXTPSyntaxEditCtrl
  • GetLineNumberBackColor() : CXTPSyntaxEditPaintManager
  • GetLineNumbers() : CXTPSyntaxEditCtrl
  • GetLineNumberTextColor() : CXTPSyntaxEditPaintManager
  • GetLinesIntersection() : CXTPMathUtils
  • GetLineStyle() : CXTPChartAxisConstantLine, CXTPChartAxisGridLines, CXTPChartFastLineSeriesStyle, CXTPChartLineSeriesStyle, CXTPChartRadarLineSeriesStyle
  • GetLineText() : CXTPSyntaxEditBufferManager, CXTPSyntaxEditCtrl
  • GetLineTextLength() : CXTPSyntaxEditBufferManager
  • GetLineTextLengthC() : CXTPSyntaxEditBufferManager
  • GetLineThickness() : CXTPChartHighLowSeriesStyle
  • GetLinkColor() : CXTPHyperLink
  • GetLinkCursor() : CXTPHyperLink
  • GetLinkPos() : CXTPTaskDialogLinkCtrl
  • GetListBackColor() : CXTPListBase
  • GetListBox() : CXTPSyntaxEditTipComboBox
  • GetListBoxCtrl() : CXTPControlComboBox, CXTPControlComboBoxList
  • GetListBoxText() : CXTPControlComboBox
  • GetListControlBackColor() : CXTPDatePickerPaintManager
  • GetListControlTextColor() : CXTPDatePickerPaintManager
  • GetListControlTextFont() : CXTPDatePickerPaintManager
  • GetListCtrl() : CXTPControlListBox
  • GetListIconId() : CXTPControlComboBox
  • GetListSize() : CXTPDatePickerList
  • GetListStyle() : CXTPListBox
  • GetListTextColor() : CXTPListBase
  • GetLiteral() : CXTPGridColumn
  • GetLocale() : CXTPChartNumberFormat
  • GetLocaleLong() : CXTPCalendarUtils
  • GetLocaleString() : CXTPCalendarUtils
  • GetLocation() : CXTPCalendarEvent, CXTPFlowGraphNode, CXTPRectT< T >
  • GetLockUpdateCount() : CXTPGridControl
  • GetLogBrush() : CXTPBrush
  • GetLogFont() : CXTPFont, CXTPFontEnum
  • GetLogicalChild() : CXTPMarkupVisual
  • GetLogicalChildrenCount() : CXTPMarkupVisual
  • GetLogPen() : CXTPPen
  • GetLumBarRect() : CXTPColorLum
  • GetLunaColor() : CXTPColorManager
  • GetMargin() : CXTPMarkupFrameworkElement, CXTPTagCloudCtrl, CXTPToolTipContext
  • GetMargins() : CXTPDialogBar, CXTPStatusBarPane, CXTPTaskPanel, CXTPTaskPanelGroupItem
  • GetMarker() : CXTPChartPointSeriesStyle, CXTPChartRadarPointSeriesStyle
  • GetMarkers() : CXTPTrackControl
  • GetMarkerSize() : CXTPChartLegend
  • GetMarkupCaption() : CXTPPropertyGridItem
  • GetMarkupContext() : CXTPButton, CXTPCalendarControl, CXTPChartContent, CXTPCommandBarsModernUITheme, CXTPControlGalleryItems, CXTPFlowGraphControl, CXTPGridControl, CXTPGridRecord, CXTPGridRecords, CXTPImageManagerIcon, CXTPImageManagerVectorImageHandle, CXTPMarkupTreeCtrl, CXTPMessageBar, CXTPPopupControl, CXTPPropertyGrid, CXTPStatusBar, CXTPTabManager, CXTPTaskPanel, CXTPTipOfTheDay, IXTPMarkupDeviceDependentImageSite
  • GetMarkupDescription() : CXTPPropertyGridItem
  • GetMarkupTableRowIndex() : CXTPFlowGraphNode
  • GetMarkupTemplate() : CXTPPropertyGridItem
  • GetMarkupText() : CXTPCalendarViewEvent
  • GetMarkupUIElement() : CXTPButton, CXTPCalendarViewEvent, CXTPControlGalleryItem, CXTPFlowGraphConnectionPoint, CXTPGridColumn, CXTPGridRecordItem, CXTPPopupItem, CXTPStatusBarPane, CXTPTabManagerItem, CXTPTaskPanelItem
  • GetMarkupValue() : CXTPPropertyGridItem
  • GetMarkupVisualElementRect() : CXTPFlowGraphNode
  • GetMask() : CXTPGridColumn
  • GetMaskColor() : CXTPImageManager
  • GetMaskedText() : CXTPMaskEditT< TBase >, CXTPPropertyGridItem
  • GetMasterEvent() : CXTPCalendarRecurrencePattern
  • GetMasterEventID() : CXTPCalendarRecurrencePattern
  • GetMasterTextSchema() : CXTPSyntaxEditBufferManager
  • GetMaterialDiffuseColor() : CXTPChart3dDeviceContext
  • GetMaterialEmissionColor() : CXTPChart3dDeviceContext
  • GetMaterialShininess() : CXTPChart3dDeviceContext
  • GetMaterialSpecularColor() : CXTPChart3dDeviceContext
  • GetMatrix() : CXTPMarkupGdiPlusTransformationMatrix
  • GetMax() : CXTPGaugeMeterType, CXTPPropertyGridInplaceSlider, CXTPPropertyGridInplaceSpinButton
  • GetMaxAvailWidth() : CXTPGridHeader
  • GetMaxBackOffset() : CXTPSyntaxEditTextIterator
  • GetMaxCharSize() : CXTPSystemVersion
  • GetMaxColumnWidth() : CXTPGridHeader
  • GetMaxConnections() : CXTPFlowGraphConnectionPoint
  • GetMaxDayPOS() : CXTPCalendarMonthView::CMonthViewGrid
  • GetMaxHeight() : CXTPMarkupFrameworkElement
  • GetMaxHeightFont() : CXTPCalendarUtils
  • GetMaximum() : CXTPChartSeriesPointCollection
  • GetMaximumColSize() : CXTPListBase
  • GetMaxLabelWidth() : CXTPChartFunnelSeriesViewBase, CXTPChartPieSeriesViewBase, CXTPChartPyramidSeriesViewBase
  • GetMaxLength() : CXTPTrackBlock
  • GetMaxLineTextLength() : CXTPSyntaxEditBufferManager
  • GetMaxMonthDay() : CXTPCalendarUtils
  • GetMaxPoint() : CXTPChart3dBox
  • GetMaxPreviewLines() : CXTPGridPaintManager
  • GetMaxSelCount() : CXTPDatePickerControl
  • GetMaxSize() : CXTPChartBubbleSeriesStyle, CXTPSearchOptionsCtrl
  • GetMaxTipWidth() : CXTPToolTipContext
  • GetMaxValue() : CXTPChartAxisRange
  • GetMaxWidth() : CXTPFontEnum, CXTPGridColumn, CXTPMarkupFrameworkElement
  • GetMDIMenus() : CXTPMenuBar
  • GetMeetingGlyphRect() : CXTPCalendarViewEvent
  • GetMenuBar() : CXTPCommandBars
  • GetMenuID() : CXTPTabExBase
  • GetMenuItem() : CXTPShortcutListBox
  • GetMenuTitleBar() : CXTPCommandBars
  • GetMenuWidth() : CXTPRibbonBackstageView
  • GetMergeHeight() : CXTPGridRow
  • GetMessageBarPaintManager() : CXTPMessageBar, CXTPPaintManager
  • GetMessageRect() : CXTPMessageBar
  • GetMeterType() : CXTPGaugeCtrl
  • GetMetrics() : CXTPPropertyGridItem, CXTPSkinManager, CXTPSkinManagerSchema, CXTPSkinObject
  • GetMiddleScrollBeginDate() : CXTPCalendarMonthView::CMonthViewGrid
  • GetMin() : CXTPGaugeMeterType, CXTPPropertyGridInplaceSlider, CXTPPropertyGridInplaceSpinButton
  • GetMinColumnWidth() : CXTPCalendarDayView
  • GetMinHeight() : CXTPMarkupFrameworkElement
  • GetMinimum() : CXTPChartSeriesPointCollection
  • GetMinimumClientHeight() : CXTPShortcutBarPane, CXTPTaskPanelGroup
  • GetMinimumColSize() : CXTPListBase
  • GetMinimumGroupClientHeight() : CXTPTaskPanel
  • GetMinimumVisibleWidth() : CXTPRibbonBar
  • GetMinimumWidth() : CXTPRibbonGroup
  • GetMinLength() : CXTPTrackBlock
  • GetMinMaxInfo() : CXTPDockingPane, CXTPDockingPaneBase, CXTPDockingPaneMiniWnd, CXTPDockingPaneSidePanel, CXTPDockingPaneSplitterContainer, CXTPDockingPaneTabbedContainer, CXTPResize
  • GetMinMaxRange() : CXTPDatePickerDaysCollection
  • GetMinorColor() : CXTPChartAxisGridLines
  • GetMinorCount() : CXTPChartAxis
  • GetMinorLength() : CXTPChartAxisTickMarks
  • GetMinorLineStyle() : CXTPChartAxisGridLines
  • GetMinorThickness() : CXTPChartAxisTickMarks
  • GetMinPoint() : CXTPChart3dBox
  • GetMinReqRect() : CXTPDatePickerControl, CXTPPropertyGridInplaceMonthCal
  • GetMins() : CXTPTimeEdit
  • GetMinSize() : CXTPChartBubbleSeriesStyle, CXTPFlowGraphNode, CXTPSearchOptionsCtrl
  • GetMinutesBeforeStart() : CXTPCalendarReminder
  • GetMinValue() : CXTPChartAxisRange
  • GetMinWidth() : CXTPGridColumn, CXTPMarkupFrameworkElement
  • GetModernBitmap() : CXTPCommandBarsOffice2003Theme
  • GetModuleHandle() : CXTPModuleHandle, CXTPSkinManagerResourceFile
  • GetModulePath() : CXTPSyntaxEditCtrl
  • GetModuleState() : CXTPApplication, CXTPModuleHandle
  • GetMonth() : CXTPDatePickerItemDay, CXTPDatePickerItemMonth, CXTPPropertyGridItemDate
  • GetMonthDelta() : CXTPDatePickerControl
  • GetMonthHeaderBackColor() : CXTPDatePickerPaintManager
  • GetMonthHeaderTextColor() : CXTPDatePickerPaintManager
  • GetMonthInterval() : CXTPDatePickerList
  • GetMonthName() : CXTPDatePickerControl
  • GetMonthRange() : CXTPDatePickerControl
  • GetMonthView() : CXTPCalendarControl
  • GetMouseCursorMode() : CXTPTrackControl
  • GetMouseManager() : CXTPCommandBars
  • GetMouseMode() : CXTPGridControl
  • GetMouseScrollLines() : CXTPGridControl
  • GetMovingAverage() : CXTPChartSeriesPointCollection
  • GetMultiDayEventFlags() : CXTPCalendarViewEvent
  • GetMultiLinesCount() : CXTPPropertyGridItem
  • GetName() : CXTPCalendarEventCategory, CXTPCalendarResource, CXTPCalendarSchedule, CXTPChartAxisStrip, CXTPChartSeries, CXTPFlowGraphConnectionPoint, CXTPGlobalAtom, CXTPMarkupStaticExtension, CXTPModuleHandle, CXTPShellPidl
  • GetNamedItemData() : CXTPActiveScriptEngine
  • GetNaN() : CXTPMathUtils
  • GetNativeGdiObject() : CXTPBrush, CXTPFont, CXTPImageList, CXTPPen
  • GetNativeImage() : CXTPMarkupGdiImage
  • GetNavigateButton() : CXTPTabManager
  • GetNavigateButtonCount() : CXTPTabManager
  • GetNavigateButtons() : CXTPTabManager, CXTPTabManagerItem
  • GetNavigator() : CXTPGridControl, CXTPPropertySheet
  • GetNeededScrollDirection() : CXTPCalendarDayView
  • GetNewButton() : CXTPEditListBoxToolBar
  • GetNewTabPositon() : CXTPTabClientWnd
  • GetNext() : CXTPControlGallery, CXTPControls, CXTPDockingPaneBaseContainer, CXTPGridRows, CXTPPropExchangeEnumerator, CXTPShadowManager
  • GetNextCustomTrait() : CXTPGaugeTraits
  • GetNextElement() : CXTPCalendarData::EventsMapByID_T< _TObject >
  • GetNextFocusableColumn() : CXTPGridControl
  • GetNextFreeTempID() : CXTPCalendarData
  • GetNextInColumn() : CXTPControlGallery
  • GetNextInPage() : CXTPControlGallery
  • GetNextInRow() : CXTPControlGallery
  • GetNextItem() : CXTPTaskPanel, CXTPTreeBase
  • GetNextLineMark() : CXTPSyntaxEditLineMarksManager
  • GetNextModule() : CXTPToolhelpApi
  • GetNextParamName() : CXTPSyntaxEditColorInfo
  • GetNextPidlItem() : CXTPShellPidl
  • GetNextPoint() : CXTPChartSeriesPoint
  • GetNextProperty() : CXTPCalendarCustomProperties
  • GetNextReminderTime() : CXTPCalendarReminder
  • GetNextSelectedItem() : CXTPTreeBase
  • GetNextSelectedRow() : CXTPGridSelectedRows
  • GetNextShadow() : CXTPFrameShadowManager
  • GetNextSiblingRow() : CXTPGridRow
  • GetNextThread() : CXTPToolhelpApi
  • GetNextTimeEditByTAB() : CXTPCalendarDayView, CXTPCalendarView
  • GetNextTipString() : CXTPTipOfTheDay
  • GetNextVisibleColumn() : CXTPGridHeader
  • GetNextVisibleGroup() : CXTPTaskPanel
  • GetNextVisibleIndex() : CXTPTaskPanelItems
  • GetNextVisibleItem() : CXTPTaskPanelGroup
  • GetNextVisualBlock() : CXTPGridColumn
  • GetNode() : CXTPFlowGraphConnectionPoint
  • GetNodeBoundingRectangle() : CXTPFlowGraphPaintManager
  • GetNodes() : CXTPFlowGraphPage
  • GetNonMonthDayBackColor() : CXTPDatePickerPaintManager
  • GetNonMonthDayTextColor() : CXTPDatePickerPaintManager
  • GetNonMonthDayTextFont() : CXTPDatePickerPaintManager
  • GetNormalAndSelectedIcons() : CXTPShellListBase, CXTPShellTreeBase
  • GetNormalEnd_disp() : CXTPSyntaxEditSelection
  • GetNormalEnd_str() : CXTPSyntaxEditSelection
  • GetNormalStart_disp() : CXTPSyntaxEditSelection
  • GetNormalStart_str() : CXTPSyntaxEditSelection
  • GetNotificationWnd() : CXTPTrayIcon
  • GetNotifyOnClear() : CXTPGridSelectedRows
  • GetNumber() : CXTPPropertyGridItemNumber
  • GetNumberOfPages() : IXTPPreview
  • GetNumCols() : CXTPColorSelectorCtrl
  • GetNumRowsOnLine() : CXTPGridControl
  • GetObject() : CXTPGdiObject
  • GetObjectType() : CXTPGdiObject
  • GetOccReminders() : CXTPCalendarRecurrencePattern
  • GetOccurrences() : CXTPCalendarRecurrencePattern
  • GetOccurrencesDates() : CXTPCalendarRecurrencePattern
  • GetOffset() : CXTPFrameShadow, CXTPGridColumns
  • GetOffsetItem() : CXTPTaskPanelGroup
  • GetOffsetSize() : CXTPSearchOptionsCtrl
  • GetOldVisibleIndex() : CXTPGridColumn
  • GetOneNoteColor() : CXTPTabPaintManager
  • GetOnScreenSch() : CXTPSyntaxEditCtrl
  • GetOpacity() : CXTPMarkupUIElement, CXTPMarkupVisual
  • GetOption() : CXTPPropertyGridItemOption
  • GetOptions() : CXTPBrowseDialog, CXTPDockingPane
  • GetOrientation() : CXTPMarkupStackPanel, CXTPMarkupWrapPanel
  • GetOriginalAccelerator() : CXTPShortcutManager
  • GetOriginalControls() : CXTPControls
  • GetOriginalSize() : CXTPMarkupImage
  • GetOSVersionInfo() : CXTPSystemVersion
  • GetOuterCenterConnectorPoint() : CXTPChart3dFunnelSeriesPointView, CXTPChart3dPieSeriesPointView, CXTPChart3dPyramidSeriesPointView
  • GetOuterMargins() : CXTPTaskPanelGroup
  • GetOuterSize() : CXTPFrameShadow
  • GetOutputConnectionAt() : CXTPFlowGraphConnectionPoint
  • GetOutputConnectionsCount() : CXTPFlowGraphConnectionPoint
  • GetOutputNode() : CXTPFlowGraphConnection
  • GetOutputPoint() : CXTPFlowGraphConnection
  • GetOverlap() : CXTPExcelTabCtrl
  • GetOverwriteFlag() : CXTPSyntaxEditBufferManager
  • GetOwner() : CXTPBrowseDialog, CXTPChartElement, CXTPFrameShadow, CXTPTaskPanelItems
  • GetOwnerRecord() : CXTPGridRecords
  • GetOwnerSite() : CXTPCommandBar
  • GetOwnerWnd() : CXTPCalendarCaptionBarTheme
  • GetPadding() : CXTPMarkupBorder, CXTPMarkupControl, CXTPMarkupTextBlock, CXTPMessageBarPaintManager, CXTPStatusBarPane, CXTPTagCloudCtrl
  • GetPage() : CXTPFlowGraphConnection, CXTPFlowGraphConnectionPoint, CXTPFlowGraphElement, CXTPFlowGraphNode, CXTPFlowGraphNodeGroup, CXTPFlowGraphNodeGroups, CXTPPropertySheet
  • GetPageBorderStyle() : CXTPPropertySheet
  • GetPageBrush() : CXTPPropertyPageNavigator
  • GetPageColor() : CXTPPropertyPageNavigator
  • GetPageCount() : CXTPPropertySheet
  • GetPageIndex() : CXTPPropertySheet
  • GetPageRect() : CXTPFlowGraphPage, CXTPPropertySheet
  • GetPages() : CXTPFlowGraphControl
  • GetPageTitle() : CXTPSyntaxEditView
  • GetPaintManager() : CXTPCalendarCaptionBarTheme, CXTPCalendarCaptionBarThemePart, CXTPCalendarControl, CXTPCalendarView, CXTPCommandBar, CXTPCommandBars, CXTPCommandBarsFrameHook, CXTPControl, CXTPControlTabWorkspace, CXTPDatePickerControl, CXTPDockingPaneAutoHidePanel, CXTPDockingPaneBase, CXTPDockingPaneManager, CXTPDockingPaneTabbedContainer, CXTPFlowGraphControl, CXTPGridControl, CXTPGridHeader, CXTPGridView, CXTPMarqueeCtrl, CXTPMessageBar, CXTPPopupControl, CXTPProgressCtrl, CXTPProgressPaintManager, CXTPPropertyGrid, CXTPPropertyGridView, CXTPRibbonControlTab, CXTPShortcutBar, CXTPStatusBar, CXTPSyntaxEditCtrl, CXTPSyntaxEditPropertiesPageFont, CXTPTabClientWnd, CXTPTabControl, CXTPTabManager, CXTPTabToolBar, CXTPTaskPanel, CXTPTaskPanelItem
  • GetPaintTheme() : CXTPCalendarCaptionBarPaintManager, CXTPCalendarCaptionBarTheme, CXTPCalendarCaptionBarThemePart, CXTPCalendarControl, CXTPCalendarPaintManager, CXTPDatePickerControl, CXTPDatePickerPaintManager
  • GetPalette() : CXTPChartAppearance
  • GetPaletteIndex() : CXTPChartSeries, CXTPChartSeriesPoint
  • GetPane() : CXTPChartDiagram2D, CXTPDockingPaneAutoHideWnd, CXTPDockingPaneCaptionButton, CXTPStatusBar
  • GetPaneBase() : CXTPDockingPaneSplitterWnd
  • GetPaneCaptionRect() : CXTPDockingPaneOffice2003Theme, CXTPDockingPanePaintManager, CXTPDockingPaneVisualStudio2012Theme
  • GetPaneCount() : CXTPStatusBar
  • GetPaneData() : CXTPDockingPane
  • GetPaneDirection() : CXTPDockingPaneManager, CXTPDockingPaneSplitterWnd
  • GetPaneHwnd() : CXTPDockingPaneAutoHidePanel, CXTPDockingPaneBase, CXTPDockingPaneMiniWnd, CXTPDockingPaneSidePanel, CXTPDockingPaneTabbedContainer
  • GetPaneInfo() : CXTPStatusBar
  • GetPanelDirection() : CXTPChartContent
  • GetPanelDistance() : CXTPChartContent
  • GetPanelHeight() : CXTPDockingPaneAutoHidePanel
  • GetPaneList() : CXTPDockingPaneLayout, CXTPDockingPaneManager
  • GetPanelPaintManager() : CXTPDockingPanePaintManager
  • GetPanels() : CXTPChartContent
  • GetPanes() : CXTPDockingPaneBaseContainer
  • GetPaneStack() : CXTPDockingPaneManager
  • GetPaneStyle() : CXTPStatusBar
  • GetPaneTab() : CXTPDockingPaneAutoHidePanel, CXTPDockingPaneTabbedContainer
  • GetPaneText() : CXTPStatusBar
  • GetPaneView() : CXTPChartDiagram2DView
  • GetPaneWindowRect() : CXTPDockingPaneBase
  • GetParam() : CXTPSyntaxEditColorInfo
  • GetParameter() : CXTPControl
  • GetParams() : CXTPCalendarPaintManager
  • GetParent() : CXTPControl, CXTPControls, CXTPRibbonGroup, CXTPRibbonTab
  • GetParentCommandBar() : CXTPCommandBar, CXTPPopupBar
  • GetParentFrame() : CXTPDockingPane, CXTPTabClientWnd
  • GetParentItem() : CXTPPropertyGridItem
  • GetParentItems() : CXTPTaskPanelItem
  • GetParentRecord() : CXTPGridRecord
  • GetParentRow() : CXTPGridRow
  • GetParentRows() : CXTPGridRow
  • GetParentTab() : CXTPRibbonGroup, CXTPRibbonGroups
  • GetParentTheme() : CXTPSyntaxEditColorTheme
  • GetParentThemeName() : CXTPSyntaxEditColorTheme
  • GetParentTimeScale() : CXTPCalendarTLV_TimeScaleParams
  • GetParentView() : CXTPChartElementView
  • GetParentWindow() : CXTPScrollBase
  • GetParseThreadPriority() : CXTPSyntaxEditLexParser
  • GetPart() : CXTPCalendarTimeLineViewEvent, CXTPCalendarTLV_TimeScaleParams, CXTPCalendarTLV_TimeScaleParams_Day, CXTPCalendarTLV_TimeScaleParams_Month, CXTPCalendarTLV_TimeScaleParams_Week, CXTPCalendarTLV_TimeScaleParams_WorkWeek, CXTPPropertyGridVerb
  • GetPartID() : CXTPCalendarCaptionBarThemePart
  • GetPassNumber() : CXTPChartDeviceCommand
  • GetPattern() : CXTPChartNumberFormat
  • GetPatternEnd() : CXTPCalendarRecurrencePattern
  • GetPatternEndDate() : CXTPCalendarRecurrencePattern
  • GetPatternID() : CXTPCalendarRecurrencePattern
  • GetPatternStartDate() : CXTPCalendarRecurrencePattern
  • GetPidlCount() : CXTPShellPidl
  • GetPidlItemCount() : CXTPShellPidl
  • GetPidlRoot() : CXTPBrowseDialog
  • GetPie() : CXTPChartPieSeriesPointViewBase
  • GetPieStyleAppearance() : CXTPChartAppearance
  • GetPinButton() : CXTPDockingPaneTabbedContainer
  • GetPlainMarkupItemText() : CXTPMarkupTreeCtrl
  • GetPoint() : CXTPChartSeriesPointView, CXTPPropertyGridItemPoint
  • GetPointDistance() : CXTPChartFunnelSeriesStyleBase, CXTPChartPyramidSeriesStyleBase
  • GetPointLegendFormat() : CXTPChartSeries
  • GetPointRect() : CXTPFlowGraphNodeCustom
  • GetPoints() : CXTPChartSeries
  • GetPopulatedRecordsCount() : CXTPGridSection
  • GetPopupAnimation() : CXTPPopupControl
  • GetPopupBarGripperWidth() : CXTPCommandBarsNativeXPTheme, CXTPPaintManager
  • GetPopupControl() : CXTPPopupItem
  • GetPopuped() : CXTPControl, CXTPControlPopup
  • GetPopupPos() : CXTPPopupControl
  • GetPopupSize() : CXTPPopupControl
  • GetPopupState() : CXTPPopupControl
  • GetPopupStyle() : CXTPColorSelectorCtrl
  • GetPOS() : XTP_CALENDAR_MONTHVIEW_DAYPOS
  • GetPos() : CXTPControlScrollBar, CXTPControlSlider, CXTPPageScroller, CXTPProgressBase, CXTPStatusBarScrollBarPane
  • GetPosEndLC() : CXTPSyntaxEditLexTextBlock
  • GetPosition() : CXTPChartFunnelSeriesLabelBase, CXTPChartFunnelSeriesLabelViewBase, CXTPChartPieSeriesLabelBase, CXTPChartPieSeriesLabelViewBase, CXTPChartPyramidSeriesLabelBase, CXTPChartPyramidSeriesLabelViewBase, CXTPCommandBar, CXTPControlTabWorkspace, CXTPDockBar, CXTPDockingPaneAutoHidePanel, CXTPPropExchangeEnumerator, CXTPTabManager, CXTPTabPaintManager, CXTPTrackBlock, CXTPTrackMarker
  • GetPosLC() : CXTPSyntaxEditTextIterator
  • GetPosLC_last() : CXTPSyntaxEditTextIterator
  • GetPreferredPageSize() : IXTPPreview
  • GetPressed() : CXTPColorSelectorCtrl, CXTPControl
  • GetPressedIcon() : CXTPImageManagerIcon
  • GetPressedItem() : CXTPShortcutBar
  • GetPrev() : CXTPGridRows
  • GetPrevChild() : CXTPSyntaxEditLexTextBlock
  • GetPreviewHeight() : CXTPGridRecordItemPreview
  • GetPreviewItemHeight() : CXTPGridPaintManager
  • GetPreviewLinesCount() : CXTPGridPaintManager
  • GetPreviewText() : CXTPGridRecordItemPreview
  • GetPreviousPoint() : CXTPChartSeriesPoint
  • GetPrevItem() : CXTPTreeBase
  • GetPrevSelectedItem() : CXTPTreeBase
  • GetPrimaryDiagram() : CXTPChartContent
  • GetPrintOptions() : CXTPCalendarControlView, CXTPGridView, CXTPSyntaxEditView
  • GetPrintWidth() : CXTPGridColumn
  • GetPrivateGlyphRect() : CXTPCalendarViewEvent
  • GetProcAddress() : CXTPModuleHandle
  • GetProfileBinary() : CXTPRegistryManager
  • GetProfileColor() : CXTPRegistryManager
  • GetProfileDouble() : CXTPRegistryManager
  • GetProfileDword() : CXTPRegistryManager
  • GetProfileInt() : CXTPRegistryManager
  • GetProfileNode() : CXTPPropExchangeXMLNode
  • GetProfilePoint() : CXTPRegistryManager
  • GetProfileRect() : CXTPRegistryManager
  • GetProfileSize() : CXTPRegistryManager
  • GetProfileString() : CXTPRegistryManager
  • GetProgressPaintManager() : CXTPControlProgress, CXTPPaintManager, CXTPProgressBase, CXTPStatusBarProgressPane
  • GetProgressRect() : CXTPControlProgress, CXTPProgressBase, CXTPStatusBarProgressPane
  • GetPrompt() : CXTPGridColumn
  • GetPromptChar() : CXTPMaskEditT< TBase >
  • GetPromptString() : CXTPMaskEditT< TBase >
  • GetProperty() : CXTPCalendarCustomProperties, CXTPSkinManagerClass, CXTPWebBrowserCtrl
  • GetPropertyGrid() : CXTPPropertyGridView
  • GetPropertySort() : CXTPPropertyGrid
  • GetPropValue() : CXTPSyntaxEditPropertiesPageColor
  • GetProvider() : CXTPWebBrowserCtrl
  • GetProviderType() : CXTPWebBrowserCtrl
  • GetPThis() : CXTPCalendarMonthViewDay, CXTPCalendarMonthViewGroup, CXTPCalendarViewDayT< _TView, _TViewGroup, XTP_CALENDAR_HITTESTINFO, _TPThis >, CXTPCalendarViewGroupT< _TViewDay, _TViewEvent, _TPThis >, CXTPCalendarWeekViewDay
  • GetPushButtonStyle() : CXTPButton
  • GetQuickAccessControls() : CXTPRibbonBar
  • GetQuickAccessHeight() : CXTPRibbonBar
  • GetQuickAccessRect() : CXTPRibbonBar
  • GetR() : CXTPChartColor
  • GetRange() : CXTPChartAxis, CXTPDatePickerControl, CXTPProgressBase
  • GetRawValue() : CXTPMarkupStaticExtensionBooleanProperty, CXTPMarkupStaticExtensionBrushProperty, CXTPMarkupStaticExtensionColorProperty, CXTPMarkupStaticExtensionDoubleProperty, CXTPMarkupStaticExtensionIntegerProperty, CXTPMarkupStaticExtensionStringProperty
  • GetReadOnly() : CXTPControlEdit, CXTPPropertyGridItem
  • GetRecentColors() : CXTPColorSelectorCtrl
  • GetRecentFileList() : CXTPControlRecentFileList, CXTPRibbonControlSystemRecentFileList
  • GetRecommendedExtent() : CXTPImageManagerIcon
  • GetRecord() : CXTPGridRecordItem, CXTPGridRow
  • GetRecords() : CXTPGridRecord, CXTPGridSection
  • GetRecordsTreeFilterMode() : CXTPGridControl
  • GetRect() : CXTPCalendarCaptionBarTheme, CXTPCalendarCaptionBarThemePart, CXTPCalendarTimeLineViewTimeScale, CXTPCalendarViewGroup, CXTPControl, CXTPDatePickerItemDay, CXTPDockingPaneCaptionButton, CXTPFlowGraphConnectionPoint, CXTPGridColumn, CXTPGridRecordItemControl, CXTPGridRow, CXTPGridSection, CXTPGridSections, CXTPPopupItem, CXTPPropertyGridInplaceButton, CXTPRibbonGroup, CXTPStatusBarPane, CXTPTabManagerItem, CXTPTabManagerNavigateButton, CXTPTrackBlock, CXTPTrackMarker
  • GetRectangleTextColor() : CXTPCommandBarsNativeXPTheme, CXTPCommandBarsOffice2000Theme, CXTPCommandBarsOffice2013Theme, CXTPCommandBarsOfficeXPTheme, CXTPPaintManager, CXTPResourceTheme, CXTPRibbonTheme, CXTPVisualStudio2008Theme, CXTPVisualStudio2010Theme
  • GetRectLength() : CXTPTabManager
  • GetRectProperty() : CXTPSkinManagerSchema
  • GetRecurrenceGlyphRect() : CXTPCalendarViewEvent
  • GetRecurrenceOptions() : CXTPCalendarRecurrencePattern
  • GetRecurrencePattern() : CXTPCalendarData, CXTPCalendarEvent
  • GetRecurrencePatternID() : CXTPCalendarEvent
  • GetRecurrenceState() : CXTPCalendarEvent
  • GetRecurrenceType() : CXTPCalendarRecurrencePattern
  • GetRed() : CXTPChartColor
  • GetRedoTextList() : CXTPSyntaxEditCtrl, CXTPSyntaxEditUndoRedoManager
  • GetRegBSTR() : CXTPCalendarTimeZones
  • GetRegDWORD() : CXTPCalendarTimeZones
  • GetRegisterAsDropTarget() : CXTPShellExplorerProvider
  • GetRegStr() : CXTPCalendarTimeZones
  • GetRegTZI() : CXTPCalendarTimeZones
  • GetRegularBoldFont() : CXTPPaintManager
  • GetRegularFont() : CXTPPaintManager
  • GetRegValues() : CXTPSyntaxEditCtrl
  • GetReminderGlyphRect() : CXTPCalendarViewEvent
  • GetReminderMinutesBeforeStart() : CXTPCalendarEvent
  • GetRemindersManager() : CXTPCalendarControl
  • GetReminderSoundFile() : CXTPCalendarEvent
  • GetRenderSize() : CXTPMarkupVisual
  • GetRenderTransform() : CXTPMarkupUIElement
  • GetRequires() : CXTPMarkupXtpScript
  • GetResizeCursor() : CXTPGridHeader
  • GetResizeVCursor() : CXTPGridHeader
  • GetResizingColumn() : CXTPGridHeader
  • GetResource() : CXTPCalendarResourcesManager, CXTPImageManager
  • GetResourceColor() : CXTPDatePickerThemeResource
  • GetResourceFile() : CXTPSkinManager, CXTPSkinManagerSchema
  • GetResourceHandle() : CXTPResourceManager
  • GetResourceLanguage() : CXTPResourceManager
  • GetResourceModule() : CXTPGaugeTraits
  • GetResourceNamespace() : CXTPGaugeTraits
  • GetResourcePath() : CXTPGaugeTraits, CXTPSkinManagerResourceFile
  • GetResources() : CXTPCalendarControl, CXTPCalendarView, CXTPCalendarViewDay, CXTPCalendarViewGroup
  • GetResourcesCount() : CXTPCalendarResourcesManager
  • GetResourcesGroupedByDP() : CXTPCalendarResourcesNf
  • GetResourcesLangID() : CXTPResourceManager
  • GetRException_EndTimeOrig() : CXTPCalendarEvent
  • GetRException_StartTimeOrig() : CXTPCalendarEvent
  • GetRibbonBar() : CXTPRibbonControlTab, CXTPRibbonCustomizePage, CXTPRibbonCustomizeQuickAccessPage, CXTPRibbonGroup, CXTPRibbonGroups, CXTPRibbonTab
  • GetRibbonCaptionHeight() : CXTPRibbonOffice2013Theme, CXTPRibbonPaintManager, CXTPRibbonThemeOffice2007System, CXTPRibbonThemeResource
  • GetRibbonDividerIndex() : CXTPStatusBar
  • GetRibbonGroup() : CXTPControl
  • GetRibbonPaintManager() : CXTPCommandBarsModernUITheme, CXTPPaintManager, CXTPResourceTheme, CXTPRibbonBar
  • GetRichEditContext() : CXTPCommandBarEditCtrl
  • GetRichRender() : CXTPPopupItem
  • GetRight() : CXTPGridThickness, CXTPMarkupThickness, CXTPRectT< T >
  • GetRootParent() : CXTPCommandBar
  • GetRotation() : CXTPChartPieSeriesStyleBase
  • GetRotationQuaternion() : CXTPArcBall
  • GetRoundedBounds() : CXTPChartTextPainterBase
  • GetRow() : CXTPMarkupGrid
  • GetRowBkColor() : CXTPSyntaxEditCtrl
  • GetRowColor() : CXTPSyntaxEditCtrl
  • GetRowColors() : CXTPSyntaxEditCtrl, CXTPSyntaxEditLexTextSchema
  • GetRowCount() : CXTPCalendarDayView, CXTPCalendarDayViewGroup, CXTPSyntaxEditBufferManager, CXTPSyntaxEditCtrl, CXTPTabManager
  • GetRowDefinitions() : CXTPMarkupGrid
  • GetRowHeight() : CXTPCalendarDayViewGroup, CXTPCalendarView, CXTPGridPaintManager, CXTPGridThemeOffice2013, CXTPSyntaxEditDrawTextProcessor, CXTPTrackThemeOffice2013
  • GetRowHeightEx() : CXTPGridPaintManager
  • GetRowItems() : CXTPTabManager::CRowIndexer
  • GetRowNodes() : CXTPSyntaxEditCtrl
  • GetRowPerPage() : CXTPSyntaxEditCtrl
  • GetRowRect() : CXTPControl
  • GetRows() : CXTPDatePickerControl, CXTPGridSection, CXTPMarkupUniformGrid
  • GetRowsCount() : CXTPSyntaxEditDrawTextProcessor
  • GetRowsHeight() : CXTPGridControl
  • GetRowsMaxWidth() : CXTPSyntaxEditDrawTextProcessor
  • GetRowSpan() : CXTPMarkupGrid
  • GetRowsPerLine() : CXTPGridControl
  • GetRowType() : CXTPGridSection, CXTPGridSelectedRows
  • GetRowWidth() : CXTPSyntaxEditDrawTextProcessor
  • GetRPatternRef() : CXTPCalendarEvent
  • GetRTLDirection() : CXTPDockingPaneManager
  • GetSafeHandle() : CXTPGdiObject, CXTPImageList
  • GetSafeHwnd() : CXTPPropertyPageNavigator
  • GetSafeLogFont() : CXTPSyntaxEditPropertiesPageFont
  • GetScaleInterval() : CXTPCalendarDayView, CXTPCalendarDayViewTimeScale, CXTPCalendarTLV_TimeScaleParams
  • GetScaleIntervalWidth_px() : CXTPCalendarTLV_TimeScaleParams
  • GetScaleMaxTime() : CXTPCalendarDayView
  • GetScaleMinTime() : CXTPCalendarDayView
  • GetScaleText() : CXTPCalendarDayView
  • GetScaleType() : CXTPChartAxis
  • GetScaleTypeMap() : CXTPChartAxis
  • GetScaleX() : CXTPMarkupScaleTransform
  • GetScaleY() : CXTPMarkupScaleTransform
  • GetScheduleID() : CXTPCalendarEvent, CXTPCalendarViewGroup
  • GetScheduleName() : CXTPCalendarSchedules
  • GetSchedules() : CXTPCalendarData, CXTPCalendarResource
  • GetScheduleSet() : CXTPCalendarEvent
  • GetSchema() : CXTPPropExchange, CXTPSkinManager, CXTPSyntaxEditTextSchemesManager
  • GetSchemaFileName() : CXTPSyntaxEditTextSchemesManager
  • GetSchemaList() : CXTPSyntaxEditTextSchemesManager
  • GetSchemaName() : CXTPSkinManagerSchema, CXTPSyntaxEditTextSchemesManager
  • GetSchemaOptions() : CXTPSyntaxEditLexParser
  • GetSchemes() : CXTPSyntaxEditTextSchemesManager
  • GetSchName() : CXTPSyntaxEditLexTextSchema
  • GetScreenArea() : CXTPMultiMonitor
  • GetScreenPoint() : CXTPChartCandleStickSeriesPointView, CXTPChartHighLowSeriesPointView, CXTPChartPointSeriesPointView, CXTPChartRadarPointSeriesPointView
  • GetScreenRect() : CXTPFlowGraphNode
  • GetScreenRows() : CXTPGridRows
  • GetScriptEngine() : CXTPMarkupContext
  • GetScriptErrorsSuppressed() : CXTPShellExplorerProvider
  • GetScrollBarColors() : CXTPScrollBarThemeOffice2013
  • GetScrollBarCtrl() : CXTPExcelTabCtrl, CXTPFlowGraphControl, CXTPGridView, CXTPRibbonBackstageView, CXTPScrollBarContainer< Parent >, CXTPSyntaxEditCtrl
  • GetScrollBarInfoH() : CXTPCalendarDayView, CXTPCalendarTimeLineView, CXTPCalendarView
  • GetScrollBarInfoV() : CXTPCalendarDayView, CXTPCalendarMonthView, CXTPCalendarTimeLineView, CXTPCalendarView, CXTPCalendarWeekView
  • GetScrollBarPaintManager() : CXTPCommandBarScrollBarCtrl, CXTPControlGallery, CXTPPaintManager, CXTPScrollBarCtrl, CXTPScrollBase, CXTPStatusBarSliderPane
  • GetScrollBarPartRect() : CXTPScrollBase
  • GetScrollBarPosInfo() : CXTPScrollBarCtrl, CXTPScrollBase
  • GetScrollBarRect() : CXTPScrollBase
  • GetScrollBarStyle() : CXTPScrollBase, CXTPShellExplorerProvider
  • GetScrollBarTheme() : CXTPPropertyGridCoolTheme, CXTPPropertyGridDelphiTheme, CXTPPropertyGridNativeWindows10Theme, CXTPPropertyGridNativeWindows11Theme, CXTPPropertyGridNativeXPTheme, CXTPPropertyGridOffice2003Theme, CXTPPropertyGridOffice2007Theme, CXTPPropertyGridOffice2013Theme, CXTPPropertyGridOfficeXPTheme, CXTPPropertyGridPaintManager, CXTPPropertyGridSimpleTheme, CXTPPropertyGridVisualStudio2005Theme, CXTPPropertyGridVisualStudio2010Theme, CXTPPropertyGridVisualStudio2012Theme, CXTPPropertyGridVisualStudio2015Theme, CXTPPropertyGridVisualStudio2017Theme, CXTPPropertyGridVisualStudio2019Theme, CXTPPropertyGridVisualStudio2022Theme
  • GetScrollBarTrackInfo() : CXTPScrollBarCtrl, CXTPScrollBase
  • GetScrollButton() : CXTPTaskPanel
  • GetScrollIndexV() : CXTPGridSection
  • GetScrollInfo() : CXTPScrollBarCtrl, CXTPScrollBase, CXTPSyntaxEditCtrl
  • GetScrollLimit() : CXTPFlowGraphControl, CXTPSyntaxEditCtrl
  • GetScrollMode() : CXTPGridControl
  • GetScrollOffset() : CXTPFlowGraphControl, CXTPFlowGraphPage, CXTPTaskPanel
  • GetScrollOffsetPos() : CXTPTaskPanelGroup
  • GetScrollOffsetV() : CXTPGridSection
  • GetScrollPos() : CXTPCalendarMonthView::CMonthViewGrid, CXTPControlGallery, CXTPRibbonGroups, CXTPSyntaxEditCtrl
  • GetScrollRange() : CXTPSyntaxEditCtrl
  • GetScrollXOffset() : CXTPSyntaxEditDrawTextProcessor
  • GetSearchHistoryCountMax() : CXTPSyntaxEditFindReplaceDlg
  • GetSecondaryAxisX() : CXTPChartDiagram2D
  • GetSecondaryAxisY() : CXTPChartDiagram2D
  • GetSection() : CXTPGridRow, CXTPPropExchange, CXTPPropExchangeArchive, CXTPPropExchangeIniFile, CXTPPropExchangeRegistry, CXTPPropExchangeXMLNode
  • GetSectionDividerHeight() : CXTPGridPaintManager
  • GetSectionKey() : CXTPRegistryManager
  • GetSectionName() : CXTPPropExchangeXMLNode
  • GetSectionNode() : CXTPPropExchangeXMLNode
  • GetSections() : CXTPGridControl
  • GetSegmentLength() : CXTPMathUtils
  • GetSel() : CXTPHexEdit
  • GetSelColor() : CXTPSyntaxEditColorComboBox
  • GetSelected() : CXTPCommandBar, CXTPControl, CXTPDockingPaneTabbedContainer
  • GetSelectedBlock() : CXTPDatePickerDaysCollection
  • GetSelectedBlocks() : CXTPTrackControl
  • GetSelectedBlocksCount() : CXTPDatePickerDaysCollection
  • GetSelectedButtonId() : CXTPTaskDialog
  • GetSelectedColor() : CXTPColorHex
  • GetSelectedConstraintData() : CXTPGridRecordItem, CXTPGridRecordItemVariant
  • GetSelectedCount() : CXTPTreeBase
  • GetSelectedDayBackColor() : CXTPDatePickerPaintManager
  • GetSelectedDays() : CXTPDatePickerControl
  • GetSelectedDaysCount() : CXTPDatePickerDaysCollection
  • GetSelectedDayTextColor() : CXTPDatePickerPaintManager
  • GetSelectedEvents() : CXTPCalendarView
  • GetSelectedFolderPath() : CXTPShellTreeBase
  • GetSelectedItem() : CXTPControlGallery, CXTPPropertyGrid, CXTPShortcutBar, CXTPTabClientWnd, CXTPTabManager
  • GetSelectedItems() : CXTPPropertyGrid
  • GetSelectedList() : CXTPTreeBase
  • GetSelectedPane() : CXTPDockingPaneMiniWnd, CXTPDockingPaneSidePanel
  • GetSelectedRadioButtonId() : CXTPTaskDialog
  • GetSelectedRows() : CXTPGridControl, CXTPGridSection
  • GetSelectedTab() : CXTPRibbonBar
  • GetSelectedViewEvents() : CXTPCalendarView
  • GetSelection() : CXTPCalendarDayView, CXTPCalendarView, CXTPFlowGraphPage, CXTPSyntaxEditCtrl
  • GetSelectionBuffer() : CXTPSyntaxEditCtrl
  • GetSelectionRect() : CXTPFlowGraphNode, CXTPFlowGraphNodeCustom
  • GetSelectionText() : CXTPSyntaxEditCtrl
  • GetSelFont() : CXTPFontCtrlBase
  • GetSelMargin() : CXTPSyntaxEditCtrl
  • GetSelPath() : CXTPBrowseDialog
  • GetSelRange() : CXTPDatePickerControl
  • GetSelTabBackColor() : CXTPExcelTabCtrl, CXTPExcelTabCtrlTheme
  • GetSelTabTextColor() : CXTPExcelTabCtrl, CXTPExcelTabCtrlTheme
  • GetSerializationData() : CXTPImageManagerVectorImageHandle
  • GetSeries() : CXTPChartContent, CXTPChartDiagram
  • GetSeriesLabelView() : CXTPChart3dFunnelSeriesLabelDeviceCommand, CXTPChart3dPieSeriesLabelDeviceCommand, CXTPChart3dPyramidSeriesLabelDeviceCommand
  • GetSeriesPointValueIndex() : CXTPChartBubbleSeriesStyle, CXTPChartSeriesStyle
  • GetSeriesStyleAppearance() : CXTPChartAppearance
  • GetSeriesView() : CXTPChartDiagramView, CXTPChartSeriesPointView
  • GetShadow() : CXTPCommandBarsFrameHook, CXTPFrameShadowManager
  • GetShadowIcon() : CXTPImageManagerIcon
  • GetShadowManager() : CXTPPaintManager
  • GetShadowOptions() : CXTPPaintManager, CXTPShadowManager
  • GetSHContextMenu() : CXTPShellPidl
  • GetShortcutBar() : CXTPShortcutBarItem
  • GetShortcutManager() : CXTPCommandBars
  • GetShortcutText() : CXTPControl, CXTPControlAction
  • GetShowAlways() : CXTPPropertyGridInplaceButton
  • GetShowCaptionAlways() : CXTPRibbonBar
  • GetShowContentsWhileDragging() : CXTPDockingPaneManager, CXTPTabClientContext
  • GetShowDaysAfter() : CXTPDatePickerItemMonth
  • GetShowDaysBefore() : CXTPDatePickerItemMonth
  • GetShowDelay() : CXTPPopupControl
  • GetShowFocus() : CXTPButton
  • GetShowGripper() : CXTPCommandBar
  • GetShowInplaceButtonsAlways() : CXTPPropertyGrid
  • GetShowKeyboardCues() : CXTPCommandBarsOptions
  • GetShowLeftScroll() : CXTPDatePickerItemMonth
  • GetShowLines() : CXTPChartSeriesLabel
  • GetShowNonMonthDays() : CXTPDatePickerControl
  • GetShowRightScroll() : CXTPDatePickerItemMonth
  • GetShowTabClientContextStickers() : CXTPTabClientContext
  • GetShowToolTipTimeOut() : CXTPCalendarView, CXTPCalendarViewEvent
  • GetShowWeekNumbers() : CXTPDatePickerControl
  • GetShowZeroLevel() : CXTPChartAxisRange
  • GetSideDockingMargin() : CXTPDockingPaneManager
  • GetSideMargins() : CXTPChartAxisRange
  • GetSite() : CXTPCommandBar, CXTPCommandBars, CXTPCommandBarsFrameHook, CXTPDockingPaneManager, CXTPMarkupDeviceDependentImage
  • GetSiteExStyle() : CXTPCommandBarsFrameHook
  • GetSiteStyle() : CXTPCommandBarsFrameHook
  • GetSize() : CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE >, CXTPChartDiagram2DAxisView, CXTPChartRadarAxisXView, CXTPChartRadarAxisYView, CXTPControl, CXTPControlBitmap, CXTPControlButtonColor, CXTPControlColorSelector, CXTPControlCustom, CXTPControlGalleryItem, CXTPControlHyperlink, CXTPControlListBox, CXTPControlMarkupLabel, CXTPControlProgress, CXTPControlSelector, CXTPControlStatic, CXTPControlTabWorkspace, CXTPFlowGraphImage, CXTPFlowGraphNode, CXTPGridRecordItemControl, CXTPMarkupBorder, CXTPMarkupDeviceDependentImage, CXTPPropertyGridItemSize, CXTPRectT< T >, CXTPRibbonControlSystemButton, CXTPRibbonControlSystemPopupBarButton, CXTPRibbonControlSystemPopupBarListCaption, CXTPRibbonControlSystemPopupBarListItem, CXTPSvgImage, CXTPTabManagerNavigateButton, CXTPTabManagerNavigateButtons, CXTPTaskPanelGroupItem
  • GetSizeProperty() : CXTPSkinManagerSchema
  • GetSkinClass() : CXTPSkinManager, CXTPSkinObject
  • GetSkinManager() : CXTPSkinManagerResourceFile, CXTPSkinManagerSchema, CXTPSkinObject
  • GetSliderCtrl() : CXTPControlSlider, CXTPPropertyGridInplaceSlider
  • GetSliderPaintManager() : CXTPPaintManager
  • GetSliderStyle() : CXTPControlSlider
  • GetSlotNumber() : CXTPCalendarDayViewEvent
  • GetSmCaptionFont() : CXTPPaintManager
  • GetSmoothingMode() : CXTPFlowGraphControl
  • GetSnapMargin() : CXTPTrackControl
  • GetSortBackColor() : CXTPListBase
  • GetSortDirection() : CXTPChartLegend
  • GetSortedCol() : CXTPHeaderCtrl
  • GetSortOrder() : CXTPGridColumns, CXTPTagCloudCtrl
  • GetSortPriority() : CXTPGridRecordItem
  • GetSortTextColor() : CXTPListBase
  • GetSource() : CXTPMarkupImage, CXTPMarkupXtpScript, CXTPResourceImage, CXTPSkinImage
  • GetSpaceWidth() : CXTPSyntaxEditDrawTextProcessor
  • GetSpinButtonCtrl() : CXTPPropertyGridInplaceSpinButton
  • GetSpinButtonMax() : CXTPGridInplaceButton
  • GetSpinButtonMin() : CXTPGridInplaceButton
  • GetSpinButtonsRect() : CXTPControlEdit
  • GetSpinButtonStep() : CXTPGridInplaceButton
  • GetSplashScreenMode() : CXTPPopupControl
  • GetSplitButtonCommandRect() : CXTPPaintManager
  • GetSplitterRect() : CXTPPropertyGridPaintManager
  • GetSplitterStyle() : CXTPDockingPanePaintManager
  • GetSplitterView() : CXTPSyntaxEditView
  • GetStandardColor() : CXTPPaintManagerColor
  • GetStandardColors() : CXTPColorPicker, CXTPColorSelectorCtrl
  • GetStandardDeviation() : CXTPChartSeriesPointCollection
  • GetStandardTitle() : CXTPColorSelectorCtrl
  • GetStandardValue() : CXTPCalendarThemeCustomizableXValueT< _TValue, _TValueRef >, CXTPCalendarViewPartCustomizableValueT< _TValue >
  • GetStart_disp() : CXTPSyntaxEditSelection
  • GetStart_str() : CXTPSyntaxEditSelection
  • GetStartAngle() : CXTPChartPieBase
  • GetStartEditSubjectTimeOut() : CXTPCalendarView
  • GetStartOccurrenceTime() : CXTPCalendarRecurrencePattern
  • GetStartPoint() : CXTPChartPieBase
  • GetStartPosition() : CXTPCalendarCustomProperties, CXTPCalendarData::EventsMapByID_T< _TObject >
  • GetStartTagEndXLC() : CXTPSyntaxEditLexTextBlock
  • GetStartTime() : CXTPCalendarEvent, CXTPCalendarRecurrencePattern
  • GetStartTimeRect() : CXTPCalendarViewEvent
  • GetStartViewDate() : CXTPCalendarTimeLineView, CXTPCalendarTimeLineViewTimeScale
  • GetState() : CXTPCalendarCaptionBarThemePart, CXTPDockingPaneCaptionButton, CXTPGaugeStateType, CXTPGridInplaceButton, CXTPGridRecordItemControl
  • GetStateColor() : CXTPCommandBarsNativeWindows10Theme, CXTPCommandBarsNativeWindows11Theme, CXTPCommandBarsVisualStudio2015Theme, CXTPCommandBarsVisualStudio2017Theme, CXTPCommandBarsVisualStudio2019Theme, CXTPCommandBarsVisualStudio2022Theme, CXTPStatusBarThemeNativeWindows10, CXTPStatusBarThemeNativeWindows11, CXTPStatusBarThemeVisualStudio2015, CXTPStatusBarThemeVisualStudio2017, CXTPStatusBarThemeVisualStudio2019, CXTPStatusBarThemeVisualStudio2022
  • GetStateCount() : CXTPGaugeStateType
  • GetStateType() : CXTPGaugeCtrl
  • GetStaticText() : CXTPShellExplorerProvider
  • GetStatusBar() : CXTPCommandBars, CXTPStatusBarPane
  • GetStatusBarCtrl() : CXTPStatusBar
  • GetStatusBarPaintManager() : CXTPPaintManager, CXTPStatusBar
  • GetSticker() : CXTPTabClientContext
  • GetStoredWidth() : CXTPListBase
  • GetStr() : CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager, CXTPSyntaxEditLexVariant
  • GetStrData() : CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager
  • GetStrDataC() : CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager
  • GetStretch() : CXTPMarkupImage, CXTPMarkupViewbox
  • GetStringProperty() : CXTPSkinManagerSchema
  • GetStripEllipsisFromToolTip() : CXTPToolTipContext
  • GetStrips() : CXTPChartAxis
  • GetStrLen() : CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager
  • GetStrLenC() : CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager
  • GetStyle() : CXTPChartFunnelSeriesLabel, CXTPChartFunnelSeriesLabelBase, CXTPChartPieSeriesLabelBase, CXTPChartPyramidSeriesLabelBase, CXTPChartSeries, CXTPControl, CXTPFlowGraphConnection, CXTPFlowGraphConnectionPoint, CXTPFlowGraphNode, CXTPMarkupFrameworkElement, CXTPStatusBarPane, CXTPTagCloudStyleManager, CXTPToolTipContext
  • GetStyleAppearance() : CXTPChartSeriesStyle
  • GetStyleEx() : CXTPControlButton
  • GetSubject() : CXTPCalendarEvent
  • GetSubjectEditor() : CXTPCalendarViewEvent
  • GetSubjectEditorFont() : CXTPCalendarDayViewEvent, CXTPCalendarMonthViewEvent, CXTPCalendarViewEvent, CXTPCalendarWeekViewEvent
  • GetSubjectEditorRect() : CXTPCalendarView, CXTPCalendarViewEvent
  • GetSubjectEditorStyles() : CXTPCalendarDayViewEvent, CXTPCalendarViewEvent
  • GetSubListCtrl() : CXTPGridHeader
  • GetSubscriptionCount() : CXTPSubscriptionList< Observable, Observer >
  • GetSupportedColorSets() : CXTPTabPaintManagerTheme
  • GetSwitch() : CXTPStatusBarSwitchPane
  • GetSwitchCount() : CXTPStatusBarSwitchPane
  • GetSyntaxColor() : CXTPSyntaxEditCtrl
  • GetSyntaxScheme() : CXTPSyntaxEditCtrl
  • GetSystemBrush() : CXTPMarkupSystemBrushStaticExtension
  • GetSystemButton() : CXTPRibbonBar
  • GetSystemColor() : CXTPMarkupSystemColorStaticExtension
  • GetSystemImageList() : CXTPShellPidl
  • GetTab() : CXTPRibbonBar, CXTPRibbonControlTab
  • GetTabBackColor() : CXTPExcelTabCtrl, CXTPExcelTabCtrlTheme
  • GetTabCaption() : CXTPDockingPane
  • GetTabClient() : CXTPTabClientContext, CXTPTearOffFrame
  • GetTabClientWnd() : CXTPMDIFrameWndEx
  • GetTabControlRect() : CXTPRibbonBar
  • GetTabCount() : CXTPRibbonBar
  • GetTabCtrl() : CXTPTabView
  • GetTabCtrlImpl() : CXTPTabBase
  • GetTabFont() : CXTPExcelTabCtrl
  • GetTabFromPoint() : CXTPTabExBase
  • GetTabHeight() : CXTPExcelTabCtrl
  • GetTabHighlightColor() : CXTPExcelTabCtrl
  • GetTabItemArray() : CXTPExcelTabCtrl
  • GetTableRowCaptionRect() : CXTPFlowGraphNode
  • GetTableRowTextBlock() : CXTPFlowGraphNode
  • GetTabManager() : CXTPTabManagerItem
  • GetTabPaintManager() : CXTPDockingPanePaintManager, CXTPRibbonBar, CXTPRibbonPaintManager
  • GetTabShadowColor() : CXTPExcelTabCtrl
  • GetTabsHeight() : CXTPDockingPanePaintManager, CXTPRibbonBar
  • GetTabSize() : CXTPSyntaxEditBufferManager, CXTPSyntaxEditCtrl, CXTPSyntaxEditDrawTextProcessor
  • GetTabsRect() : CXTPExcelTabCtrl
  • GetTabStop() : CXTPPropertyGridInplaceButton
  • GetTabStyle() : CXTPExcelTabCtrl, CXTPTabBaseTheme
  • GetTabTextColor() : CXTPExcelTabCtrl, CXTPExcelTabCtrlTheme
  • GetTabWidth() : CXTPExcelTabCtrl
  • GetTabWithSpace() : CXTPSyntaxEditCtrl
  • GetTag() : CXTPControl, CXTPControlAction, CXTPFlowGraphNode, CXTPMarkupFrameworkElement
  • GetTagArray() : CXTPTagCloudCtrl
  • GetTahoma12() : CXTPChartFont
  • GetTahoma18() : CXTPChartFont
  • GetTahoma8() : CXTPChartFont
  • GetTargetCaptionRect() : CXTPTaskPanelGroup
  • GetTargetClientRect() : CXTPTaskPanelGroup
  • GetTargetTabClientWnd() : CXTPTabClientSticker
  • GetTaskPanel() : CXTPTaskPanelItem
  • GetText() : CXTPCalendarCaptionBarThemePart, CXTPChartAxisConstantLine, CXTPChartAxisCustomLabel, CXTPChartAxisTitle, CXTPChartTitle, CXTPGridFilterEditControl, CXTPMarkupTextBlock, CXTPStatusBarPane, CXTPSyntaxEditCtrl, CXTPSyntaxEditTextIterator
  • GetTextAlignment() : CXTPButton, CXTPMarkupTextBlock, CXTPPopupItem, CXTPStatusBarPane
  • GetTextAngle() : CXTPChartTitle
  • GetTextAttributes() : CXTPSyntaxEditLexClass, CXTPSyntaxEditLexTextSchema
  • GetTextColor() : CXTPButtonTheme, CXTPButtonThemeOffice2013, CXTPButtonThemeVisualStudio2012, CXTPCalendarCaptionBarThemePart, CXTPCalendarViewPart, CXTPCaptionButtonTheme, CXTPCaptionButtonThemeOffice2003, CXTPCaptionButtonThemeOfficeXP, CXTPChartAxisConstantLine, CXTPChartAxisLabel, CXTPChartAxisTitle, CXTPChartLegend, CXTPChartSeriesLabel, CXTPChartTitle, CXTPComboBox, CXTPComboBoxTheme, CXTPGridRecordItem, CXTPHexEdit, CXTPPopupItem, CXTPProgressCtrl, CXTPProgressCtrlPaintManager, CXTPShortcutListBoxTheme, CXTPStatusBarPane, CXTPStatusBarThemeOffice2013, CXTPSyntaxEditColorSampleText, CXTPSyntaxEditPaintManager, CXTPSyntaxEditTipWnd, CXTPTaskButtonTheme, CXTPTaskDialogLinkCtrl, CXTPTaskPanelGroupItem
  • GetTextDecoration() : CXTPGridHyperlinkStyle
  • GetTextDecorations() : CXTPMarkupTextBlock
  • GetTextExtent() : CXTPCalendarViewPart
  • GetTextFont() : CXTPCalendarViewPart, CXTPGridPaintManager, CXTPPopupItem, CXTPStatusBarPane
  • GetTextGrayColor() : CXTPStatusBarPane
  • GetTextHeight() : CXTPShortcutListBox
  • GetTextImageRelation() : CXTPButton
  • GetTextLimit() : CXTPControlComboBox, CXTPControlEdit
  • GetTextLinkColor() : CXTPTaskDialogLinkCtrl
  • GetTextMetrics() : CXTPSyntaxEditDrawTextProcessor
  • GetTextOrientation() : CXTPCommandBar
  • GetTextRect() : CXTPCalendarViewEvent, CXTPCaption, CXTPSyntaxEditDrawTextProcessor, CXTPTaskPanelItem
  • GetTextSchema() : CXTPSyntaxEditLexParser
  • GetTextSchemesManager() : CXTPSyntaxEditConfigurationManager
  • GetTextTrimming() : CXTPMarkupTextBlock
  • GetTextWrapping() : CXTPMarkupTextBlock
  • GetTheme() : CXTPButton, CXTPCalendarCaptionBarControl, CXTPCalendarCaptionBarThemePart, CXTPCalendarControl, CXTPCalendarView, CXTPCaption, CXTPColorSelectorCtrl, CXTPComboBox, CXTPEdit, CXTPExcelTabCtrl, CXTPHeaderCtrl, CXTPPopupControl, CXTPPropertySheet, CXTPShortcutListBox, CXTPSplitterWnd, CXTPSyntaxEditColorThemesManager, CXTPTabBase
  • GetThemeAppProperties() : CXTPWinThemeWrapper
  • GetThemeBackgroundContentRect() : CXTPWinThemeWrapper
  • GetThemeBackgroundExtent() : CXTPWinThemeWrapper
  • GetThemeBackgroundRegion() : CXTPWinThemeWrapper
  • GetThemeBool() : CXTPSkinManagerClass, CXTPWinThemeWrapper
  • GetThemeColor() : CXTPSkinManagerClass, CXTPWinThemeWrapper
  • GetThemeColors() : CXTPColorPicker, CXTPColorSelectorCtrl
  • GetThemed() : CXTPGridRecordItemControl
  • GetThemeDocumentationProperty() : CXTPWinThemeWrapper
  • GetThemeEnumValue() : CXTPSkinManagerClass, CXTPWinThemeWrapper
  • GetThemeFilename() : CXTPWinThemeWrapper
  • GetThemeFont() : CXTPWinThemeWrapper
  • GetThemeID() : CXTPEdit, CXTPEditTheme
  • GetThemeInt() : CXTPSkinManagerClass, CXTPWinThemeWrapper
  • GetThemeIntList() : CXTPWinThemeWrapper
  • GetThemeManager() : CXTPSyntaxEditConfigurationManager
  • GetThemeMargins() : CXTPWinThemeWrapper
  • GetThemeMetric() : CXTPWinThemeWrapper
  • GetThemePartSize() : CXTPSkinManagerClass, CXTPWinThemeWrapper
  • GetThemePosition() : CXTPWinThemeWrapper
  • GetThemePropertyOrigin() : CXTPWinThemeWrapper
  • GetThemeRect() : CXTPSkinManagerClass, CXTPWinThemeWrapper
  • GetThemes() : CXTPSyntaxEditColorThemesManager, CXTPSyntaxEditCtrl
  • GetThemeSize() : CXTPSkinManagerClass
  • GetThemeString() : CXTPSkinManagerClass, CXTPWinThemeWrapper
  • GetThemeStyle() : CXTPControlTheme
  • GetThemeSysBool() : CXTPSkinManager, CXTPWinThemeWrapper
  • GetThemeSysColor() : CXTPSkinManager, CXTPWinThemeWrapper
  • GetThemeSysColorBrush() : CXTPWinThemeWrapper
  • GetThemeSysFont() : CXTPSkinManager, CXTPWinThemeWrapper
  • GetThemeSysInt() : CXTPWinThemeWrapper
  • GetThemeSysSize() : CXTPSkinManager, CXTPWinThemeWrapper
  • GetThemeSysString() : CXTPWinThemeWrapper
  • GetThemeTextExtent() : CXTPWinThemeWrapper
  • GetThemeTextMetrics() : CXTPWinThemeWrapper
  • GetThemeTip() : CXTPColorSelectorCtrl
  • GetThemeTitle() : CXTPColorSelectorCtrl
  • GetThemeVersion() : CXTPCalendarControl
  • GetThemeWrapper() : CXTPHeaderCtrlTheme
  • GetThickness() : CXTPChartAxis, CXTPChartAxisTickMarks, CXTPChartBorder, CXTPChartLineStyle
  • GetThumbWidth() : CXTPControlComboBox
  • GetTickMarks() : CXTPChartAxis
  • GetTicks() : CXTPScrollBase
  • GetTimeFormat() : CXTPCalendarUtils
  • GetTimeFormatString_HrMin() : CXTPCalendarUtils
  • GetTimeframeRect() : CXTPCalendarDayViewEvent
  • GetTimelineArea() : CXTPTrackControl
  • GetTimeLineMax() : CXTPTrackControl
  • GetTimeLineMin() : CXTPTrackControl
  • GetTimeLinePosition() : CXTPTrackControl
  • GetTimeLineScale() : CXTPCalendarControl
  • GetTimeLineView() : CXTPCalendarControl
  • GetTimeLineViewScale() : CXTPCalendarTLV_TimeScaleParams
  • GetTimePerPixel() : CXTPCalendarTLV_TimeScaleParams
  • GetTimeScale() : CXTPCalendarDayView, CXTPCalendarTimeLineView
  • GetTimeScaleID() : CXTPCalendarTimeLineView
  • GetTimeScaleParams() : CXTPCalendarTimeLineViewTimeScale
  • GetTimeScaleParamsID() : CXTPCalendarTLV_TimeScaleParams
  • GetTimeshift() : CXTPCalendarDayViewTimeScale
  • GetTimeZoneInfo() : CXTPCalendarTimeZone
  • GetTipBkColor() : CXTPToolTipContext
  • GetTips() : CXTPTabExBase
  • GetTipText() : CXTPExcelTabCtrl
  • GetTipTextColor() : CXTPToolTipContext
  • GetTitle() : CXTPBrowseDialog, CXTPChartAxis, CXTPCommandBar, CXTPDockingPane, CXTPDockingPaneBase, CXTPDockingPaneMiniWnd, CXTPDockingPaneSidePanel, CXTPDockingPaneTabbedContainer
  • GetTitleAppearance() : CXTPChartContentAppearance
  • GetTitles() : CXTPChartContent, CXTPChartPanel
  • GetTitleToolTip() : CXTPDockingPane
  • GetToday() : CXTPDatePickerControl
  • GetTodayDate() : CXTPCalendarControl
  • GetTodayDateOverride() : CXTPCalendarControl
  • GetTokensForAutoCompleate() : CXTPSyntaxEditLexParser
  • GetToolBar() : CXTPCommandBars, CXTPPropertyGrid, CXTPReBar
  • GetToolbarsPage() : CXTPCustomizeSheet
  • GetToolbarsPopup() : CXTPCommandBars
  • GetToolSize() : CXTPToolTipContextToolTip
  • GetToolText() : CXTPCalendarViewEvent
  • GetToolTip() : CXTPControlGalleryItem
  • GetTooltip() : CXTPButton, CXTPControl, CXTPControlAction, CXTPFlowGraphConnection, CXTPFlowGraphConnectionPoint, CXTPFlowGraphNode, CXTPGridColumn, CXTPGridGroupRow, CXTPGridRecordItem, CXTPPropertyGridInplaceButton, CXTPPropertyGridItem, CXTPShortcutBarItem, CXTPStatusBarPane, CXTPTabManagerItem, CXTPTabManagerNavigateButton, CXTPTaskPanelItem, CXTPTrackBlock
  • GetToolTipContext() : CXTPButton, CXTPChartControl, CXTPCommandBars, CXTPDockingPaneManager, CXTPFlowGraphControl, CXTPGridControl, CXTPMarkupContext, CXTPPropertyGrid, CXTPShortcutBar, CXTPStatusBar, CXTPTabClientWnd, CXTPTabControl, CXTPTaskPanel
  • GetTooltipControl() : CXTPEditListBoxToolBar
  • GetToolTipCtrl() : CXTPColorSelectorCtrl
  • GetTooltipRect() : CXTPCalendarDayViewGroup, CXTPCalendarMonthViewGroup, CXTPCalendarTimeLineView, CXTPCalendarView, CXTPCalendarViewGroup, CXTPGridTip
  • GetToolTips() : CXTPTabView
  • GetTooltipText() : CXTPCalendarTip, CXTPChartSeriesPoint, CXTPGridTip, CXTPTrayIcon
  • GetTop() : CXTPGridThickness, CXTPMarkupThickness, CXTPRectT< T >
  • GetTopClassForFileExt() : CXTPSyntaxEditLexTextSchema
  • GetTopContainer() : CXTPDockingPaneSidePanel
  • GetTopIndex() : CXTPPropertyGrid
  • GetTopPane() : CXTPDockingPaneManager, CXTPDockingPaneMiniWnd
  • GetTopRow() : CXTPCalendarDayView, CXTPCalendarDayViewGroup, CXTPSyntaxEditCtrl, CXTPSyntaxEditView
  • GetTopRowIndex() : CXTPGridControl
  • GetTotalArrowWidth() : CXTPExcelTabCtrl
  • GetTotalButtonRect() : CXTPExcelTabCtrl
  • GetTotalTabAreaWidth() : CXTPExcelTabCtrl
  • GetTotalTabWidth() : CXTPExcelTabCtrl
  • GetTrackBrush() : CXTPSplitterWndTheme, CXTPSplitterWndThemeOfficeXP
  • GetTrackColumn() : CXTPTrackControl
  • GetTrackColumnIndex() : CXTPTrackControl
  • GetTrackControl() : CXTPTrackControlItem
  • GetTrackFocus() : CXTPCommandBar
  • GetTrackOffset() : CXTPTrackControl
  • GetTrackPaintManager() : CXTPTrackControl
  • GetTrait() : CXTPGaugeBaseType
  • GetTraits() : CXTPGaugeTraits
  • GetTraitsArgument() : CXTPGaugeTraits
  • GetTransparency() : CXTPChartAreaSeriesStyle, CXTPChartRadarAreaSeriesStyle, CXTPChartSeriesLabel, CXTPChartSeriesStyle, CXTPFrameShadow, CXTPPopupControl
  • GetTransparentColor() : CXTPTransparentBitmap
  • GetTreeBackColor() : CXTPTreeBase, CXTPTreeTheme
  • GetTreeDepth() : CXTPGridRow
  • GetTreeTextColor() : CXTPTreeBase, CXTPTreeTheme
  • GetTwipSize() : CXTPControlSizeComboBox
  • GetType() : CXTPCalendarData, CXTPCommandBar, CXTPControl, CXTPDockingPaneBase, CXTPFlowGraphConnectionPoint, CXTPGaugeCtrl, CXTPGridRecordItemControl, CXTPGridRow, CXTPTaskPanelItem
  • GetTypeName() : CXTPGaugeBaseType, CXTPGaugeMeterType, CXTPGaugeStateType
  • GetUnderline() : CXTPHyperLink
  • GetUndoManager() : CXTPFlowGraphControl, CXTPTrackControl
  • GetUndoRedoManager() : CXTPSyntaxEditBufferManager
  • GetUndoTextList() : CXTPSyntaxEditCtrl, CXTPSyntaxEditUndoRedoManager
  • GetUnitType() : CXTPMarkupGridLength
  • GetUpButton() : CXTPEditListBoxToolBar
  • GetUpColor() : CXTPChartHighLowSeriesStyle
  • GetUpcomingEvents() : CXTPCalendarData
  • GetUpdatedTextRegion() : CXTPSyntaxEditLexTextSchema
  • GetUpdateRect() : CXTPMarkupVisual
  • GetURL() : CXTPHyperLink
  • GetUseCustomToolTipPosition() : CXTPMarkupContext
  • GetUseEndMethod() : CXTPCalendarRecurrencePattern
  • GetUserColor() : CXTPSyntaxEditColorComboBox
  • GetUserMaxSize() : CXTPMarkupDefinitionBase
  • GetUserMinSize() : CXTPMarkupDefinitionBase
  • GetUserSize() : CXTPFlowGraphNode, CXTPMarkupDefinitionBase
  • GetUseThousandSeparator() : CXTPChartNumberFormat
  • GetUseVisualStyle() : CXTPButton, CXTPComboBox, CXTPEdit, CXTPProgressCtrl, CXTPScrollBar, CXTPSpinButtonCtrl
  • GetValue() : CXTPActiveScriptObjectContext, CXTPCalendarThemeCustomizableXValueT< _TValue, _TValueRef >, CXTPCalendarViewPartCustomizableValueT< _TValue >, CXTPChartColor, CXTPChartSeriesPoint, CXTPGridRecordItemDateTime, CXTPGridRecordItemNumber, CXTPGridRecordItemText, CXTPGridRecordItemVariant, CXTPMarkupGridLength, CXTPMarkupStaticExtensionProperty, CXTPPropertyGridItem, CXTPStatusBarPane
  • GetValueLength() : CXTPChartSeriesPoint
  • GetValueMetrics() : CXTPPropertyGridItem
  • GetValueRect() : CXTPPropertyGridItem, CXTPPropertyGridItemColor, CXTPPropertyGridItemFont
  • GetValueScaleType() : CXTPChartSeries
  • GetValueX() : CXTPCalendarThemeCustomizableXValueT< _TValue, _TValueRef >
  • GetVariableData() : CXTPSyntaxEditLexVariable
  • GetVariableHelpHeight() : CXTPPropertyGrid
  • GetVariableSplitterPos() : CXTPPropertyGrid
  • GetVariance() : CXTPChartSeriesPointCollection
  • GetVarID() : CXTPSyntaxEditLexVariable
  • GetVectorCheckedIcon() : CXTPImageManagerIcon
  • GetVectorDisabledIcon() : CXTPImageManagerIcon
  • GetVectorHotIcon() : CXTPImageManagerIcon
  • GetVectorIcon() : CXTPImageManagerIcon
  • GetVectorPressedIcon() : CXTPImageManagerIcon
  • GetVerbs() : CXTPPropertyGrid
  • GetVerbsHeight() : CXTPPropertyGrid
  • GetVersion() : CXTPDockState, CXTPModuleHandle, CXTPSystemVersion
  • GetVerticalAlignment() : CXTPChartLegend, CXTPMarkupFrameworkElement, CXTPTrackBlock
  • GetVertScrollBar() : CXTPSyntaxEditCtrl, CXTPSyntaxEditView
  • GetView() : CXTPCalendarTimeLineViewEvent, CXTPCalendarTimeLineViewGroup, CXTPCalendarTimeLineViewTimeScale, CXTPCalendarViewDayT< _TView, _TViewGroup, XTP_CALENDAR_HITTESTINFO, _TPThis >, CXTPTabExBase
  • GetView_() : CXTPCalendarViewDay
  • GetViewDay() : CXTPCalendarMonthView::CMonthViewGrid, CXTPCalendarViewGroupT< _TViewDay, _TViewEvent, _TPThis >, CXTPCalendarViewT< _TViewDay >
  • GetViewDay_() : CXTPCalendarMonthView, CXTPCalendarTimeLineViewGroup, CXTPCalendarView, CXTPCalendarViewGroup
  • GetViewDayCount() : CXTPCalendarView
  • GetViewDayDate() : CXTPCalendarDayView, CXTPCalendarMonthView, CXTPCalendarTimeLineView, CXTPCalendarView, CXTPCalendarWeekView
  • GetViewDivider() : CXTPPropertyGrid
  • GetViewEvent() : CXTPCalendarTimeLineViewGroup, CXTPCalendarViewGroupT< _TViewDay, _TViewEvent, _TPThis >
  • GetViewEvent_() : CXTPCalendarViewDay, CXTPCalendarViewGroup
  • GetViewEventByEvent_() : CXTPCalendarViewGroup
  • GetViewEventByPlace_() : CXTPCalendarViewGroup
  • GetViewEventRect() : CXTPCalendarViewEvent
  • GetViewEventRectMax() : CXTPCalendarViewEvent
  • GetViewEventsCount() : CXTPCalendarViewDay, CXTPCalendarViewGroup
  • GetViewGroup() : CXTPCalendarTimeLineViewEvent, CXTPCalendarViewDayT< _TView, _TViewGroup, XTP_CALENDAR_HITTESTINFO, _TPThis >, CXTPCalendarViewEventT< _TViewGroup >
  • GetViewGroup_() : CXTPCalendarTimeLineViewEvent, CXTPCalendarViewDay, CXTPCalendarViewEvent, CXTPCalendarViewEventT< _TViewGroup >
  • GetViewGroupsCount() : CXTPCalendarViewDay
  • GetViewMaxValue() : CXTPChartAxisRange
  • GetViewMinValue() : CXTPChartAxisRange
  • GetViewName() : CXTPTabExBase
  • GetViewPortMax() : CXTPTrackControl
  • GetViewPortMin() : CXTPTrackControl
  • GetViewRect() : CXTPCalendarView, CXTPCalendarWeekViewEvent
  • GetViewRotationMatrix() : CXTPChart3dDiagram
  • GetViewType() : CXTPCalendarDayView, CXTPCalendarTimeLineView, CXTPCalendarView, CXTPCalendarViewT< _TViewDay >
  • GetViewValue() : CXTPPropertyGridItem, CXTPPropertyGridItemBool
  • GetVisibility() : CXTPMarkupUIElement
  • GetVisible() : CXTPCalendarDayViewTimeScale
  • GetVisibleAt() : CXTPControls, CXTPGridColumns
  • GetVisibleButtonCount() : CXTPDatePickerButtons
  • GetVisibleColumns() : CXTPGridColumns
  • GetVisibleColumnsCount() : CXTPGridColumns
  • GetVisibleCount() : CXTPControls
  • GetVisibleIndex() : CXTPGridColumn
  • GetVisibleItemsCount() : CXTPShortcutBar
  • GetVisiblePaneCount() : CXTPStatusBar
  • GetVisibleRange() : CXTPDatePickerControl
  • GetVisibleRow() : CXTPSyntaxEditCtrl
  • GetVisibleRowCount() : CXTPCalendarDayView, CXTPCalendarDayViewGroup
  • GetVisibleRowsCount() : CXTPSyntaxEditCtrl
  • GetVisited() : CXTPHyperLink
  • GetVisitedColor() : CXTPHyperLink
  • GetVisualChild() : CXTPMarkupVisual
  • GetVisualChildrenCount() : CXTPMarkupVisual
  • GetVisualOffset() : CXTPMarkupVisual
  • GetVisualParent() : CXTPMarkupVisual
  • GetWatermarkAlignment() : CXTPGridControl
  • GetWatermarkBitmap() : CXTPGridControl
  • GetWeekDayCol() : CXTPCalendarMonthView::CMonthViewGrid
  • GetWeekDayForColIndex() : CXTPCalendarMonthView::CMonthViewGrid
  • GetWeekDayTextIfNeed() : CXTPCalendarMonthView
  • GetWeekNumbersBackColor() : CXTPDatePickerPaintManager
  • GetWeekNumbersTextColor() : CXTPDatePickerPaintManager
  • GetWeekNumbersTextFont() : CXTPDatePickerPaintManager
  • GetWeekOfYear() : CXTPCalendarUtils
  • GetWeeksCount() : CXTPCalendarMonthView::CMonthViewGrid
  • GetWeekView() : CXTPCalendarControl
  • GetWideCaret() : CXTPSyntaxEditCtrl
  • GetWidth() : CXTPCalendarDayViewTimeScale, CXTPCommandBar, CXTPControl, CXTPFlowGraphConnection, CXTPGridColumn, CXTPGridHeader, CXTPGridInplaceButton, CXTPGridRecordItemControl, CXTPImageManagerIcon, CXTPMarkupFrameworkElement, CXTPMatrix< T >, CXTPPropertyGridInplaceButton, CXTPResourceImage, CXTPSkinImage, CXTPStatusBarPane, CXTPStatusBarSwitchPane, CXTPTabClientDraggingContents
  • GetWindow() : CXTPControlTabWorkspace
  • GetWindowDateTime() : CXTPDateEdit
  • GetWindowHandle() : CXTPFlowGraphNode
  • GetWindowSize() : CXTPFlowGraphNode
  • GetWindowTextEx() : CXTPCommandBarEditCtrl
  • GetWindowTheme() : CXTPWinThemeWrapper
  • GetWinThemeWrapperTheme() : CXTPColorManager
  • GetWnd() : IXTPScrollable
  • GetWndWidth() : CXTPSyntaxEditAutoCompleteWnd
  • GetWorkArea() : CXTPMultiMonitor
  • GetWorkAreaMax() : CXTPTrackControl
  • GetWorkAreaMin() : CXTPTrackControl
  • GetWorkDayEndTime() : CXTPCalendarControl
  • GetWorkDayStartTime() : CXTPCalendarControl
  • GetWorkRect() : CXTPFlowGraphNodeGroup
  • GetWorkspace() : CXTPTabClientWnd
  • GetWorkspaceCount() : CXTPTabClientWnd
  • GetWorkWeekMask() : CXTPCalendarControl
  • GetWrap() : CXTPControl
  • GetX() : CXTPMarkupTranslateTransform
  • GetXLC() : XTP_EDIT_LINECOL
  • GetXML() : CXTPPropExchangeXMLNode
  • GetXtremeColor() : CXTPDockingPanePaintManager, CXTPPaintManager
  • GetY() : CXTPMarkupTranslateTransform
  • GetYear() : CXTPPropertyGridItemDate
  • GetZoomLevel() : CXTPFlowGraphControl, CXTPFlowGraphPage
  • GetZoomParam() : CXTPFlowGraphControl
  • GetZoomState() : CXTPPreviewView
  • GiveFeedback() : CXTPDropSource
  • GoBackward() : CXTPFlowGraphPageHistory
  • GoForward() : CXTPFlowGraphPageHistory
  • GoModal() : CXTPDatePickerControl
  • GoToPage() : IXTPPreview
  • GoToRow() : CXTPSyntaxEditCtrl
  • GotoURL() : CXTPHyperLink
  • GradientFill() : CXTPPaintManager, CXTPTabPaintManagerColorSet
  • GradientFillTabFace() : CXTPTabBaseThemeOffice2003
  • grcCaption : CXTPColorManager
  • grcDockBar : CXTPColorManager
  • grcLunaChecked : CXTPColorManager
  • grcLunaPushed : CXTPColorManager
  • grcLunaSelected : CXTPColorManager
  • grcMenu : CXTPColorManager
  • grcMenuExpanded : CXTPColorManager
  • grcMenuItemPopup : CXTPColorManager
  • grcShortcutBarGripper : CXTPColorManager
  • grcToolBar : CXTPColorManager
  • GreenMask : CXTPChartColor
  • GreenShift : CXTPChartColor
  • GridDraggingMode : CXTPGridHeader
  • GridLinesColor : CXTPChartAxisAppearance
  • GridLinesMinorColor : CXTPChartAxisAppearance
  • GridUnitType : CXTPMarkupGridLength


Toolkit Pro: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- h -

  • half : CXTPColorHex::CRgnCell::CTX_DATA::HEXAGON_DATA
  • HandleDrop() : CXTPSyntaxEditCtrl
  • HasApplyOptions() : CXTPSkinManager
  • HasBookmarks() : CXTPSyntaxEditCtrl
  • HasBorders() : CXTPStatusBarPane
  • HasBottomSeparator() : CXTPControlGallery
  • HasBounds() : CXTPArcBall
  • HasBreakpoints() : CXTPSyntaxEditCtrl
  • HasCaptions() : CXTPColorSelectorCtrl
  • HasCheckbox() : CXTPGridRecordItem
  • HasCheckedIcon() : CXTPImageManagerIcon
  • HasChildren() : CXTPGridRecord, CXTPGridRow
  • HasChilds() : CXTPPropertyGridItem
  • HasCloseButton() : CXTPCaption
  • HasDisabledIcon() : CXTPImageManagerIcon
  • HasDwmCompositedRect() : CXTPControl
  • HasEditLabels() : CXTPTreeBase
  • HasFlag() : CXTPResize
  • HasFloatingBarGradientEntry() : CXTPCommandBarsOffice2003Theme
  • HasFocus() : CXTPControlComboBox, CXTPControlEdit, CXTPGridControl, CXTPGridRows, CXTPListBox
  • HasHotIcon() : CXTPImageManagerIcon
  • HasHScroll() : IXTPScrollable
  • HasIcon() : CXTPImageManagerIcon
  • HasLeftScrollbar() : IXTPScrollable
  • HasMergedItems() : CXTPGridRow
  • HasNormalIcon() : CXTPImageManagerIcon
  • HasOwnNavigator() : IXTPPreview
  • HasParent() : CXTPGridRow, CXTPPropertyGridItem
  • HasPressedIcon() : CXTPImageManagerIcon
  • HasRowMark() : CXTPSyntaxEditCtrl, CXTPSyntaxEditLineMarksManager
  • HasSelectedViewEvent() : CXTPCalendarView
  • HasSelection() : CXTPEdit
  • HasSharedBorder() : CXTPSpinButtonCtrl
  • HasSortArrow() : CXTPHeaderCtrl, CXTPHeaderCtrlTheme
  • HasSortTriangle() : CXTPGridColumn
  • HasText() : CXTPProgressCtrl
  • HasToolbar() : CXTPEditListBox
  • HasVisibleChilds() : CXTPPropertyGridItem
  • HasVScroll() : IXTPScrollable
  • hcurDragCopy : CXTPAuxData
  • hcurDragMove : CXTPAuxData
  • hcurDragNone : CXTPAuxData
  • hcurHand : CXTPAuxData
  • hcurHSplitBar : CXTPAuxData
  • hcurMove : CXTPAuxData
  • hcurVSplitBar : CXTPAuxData
  • hDC : XTP_EDIT_SENMBOOKMARK
  • hdr : NMXTPCONTROL, NMXTPSCROLL, XTP_NC_DATEPICKER_BUTTON, XTP_NM_FLOWGRAPH_CONNECTIONCHANGED, XTP_NM_FLOWGRAPH_CONNECTIONCHANGING, XTP_NM_FLOWGRAPH_ENDLABELEDIT, XTP_NM_FLOWGRAPH_NODECHANGED, XTP_NM_GRID_BEFORE_COPYPASTE, XTP_NM_GRIDCOLUMNORDERCHANGED, XTP_NM_GRIDCOLUMNRESIZE, XTP_NM_GRIDDRAGDROP, XTP_NM_GRIDITEMMETRICS, XTP_NM_GRIDPREVIEWKEYDOWN, XTP_NM_GRIDRECORDITEM, XTP_NM_GRIDROWRESIZE, XTP_NM_GRIDSTATECHANGED, XTP_NM_SELECTION_CHANGING, XTP_NM_TRACKCONTROL
  • HeaderHasFocus() : CXTPRibbonControlTab, CXTPTabControl, CXTPTabManager
  • Height : CXTPRectT< T >, CXTPResizeRect, CXTPSizeT< T >
  • height : CXTPColorHex::CRgnCell::CTX_DATA::HEXAGON_DATA
  • Hide() : CXTPDockingPane, CXTPFrameShadow, CXTPPopupControl, CXTPSyntaxEditAutoCompleteWnd, CXTPSyntaxEditToolTipCtrl
  • HideClient() : CXTPDockingPaneManager
  • HideColumn() : CXTPSplitterWnd
  • HideCommand() : CXTPCommandBars
  • HideCommands() : CXTPCommandBars
  • HideIcon() : CXTPTrayIcon
  • HideKeyboardTips() : CXTPCommandBar, CXTPCommandBars
  • HidePane() : CXTPDockingPaneManager
  • HideRow() : CXTPSplitterWnd
  • HideSelection() : CXTPControlGallery
  • HideTip() : CXTPSyntaxEditTipWnd
  • HideTipWindow() : CXTPTipWindow
  • HideToolTip() : CXTPCalendarControl, CXTPCalendarViewEvent
  • HideWindow() : CXTPGridInplaceEdit, CXTPPropertyGridInplaceEdit
  • HighlightChangedButtonItems() : CXTPPropertyGrid
  • HighlightChangedItems() : CXTPPropertyGrid
  • HighlightWorkArea() : CXTPTrackControlItem
  • HitTest() : CXTPCalendarCaptionBarThemePart, CXTPCalendarTimeLineView, CXTPCalendarTimeLineViewEvent, CXTPCalendarTimeLineViewGroup, CXTPCalendarView, CXTPCalendarViewDay, CXTPCalendarViewEvent, CXTPCalendarViewGroup, CXTPChart3dLineDeviceCommand, CXTPChart3dRotateDeviceCommand, CXTPChartBoundedTextDeviceCommand, CXTPChartCircleDeviceCommand, CXTPChartControl, CXTPChartDeviceCommand, CXTPChartHitTestElementCommand, CXTPChartLineDeviceCommand, CXTPChartMarkupElementDeviceCommand, CXTPChartRectangleDeviceCommand, CXTPChartRotateDeviceCommand, CXTPControls, CXTPDatePickerButtons, CXTPDatePickerControl, CXTPDatePickerItemMonth, CXTPDockingPaneAutoHidePanel, CXTPDockingPaneWindowSelect, CXTPExcelTabCtrl, CXTPGridControl, CXTPGridHeader, CXTPGridRecordItem, CXTPGridRow, CXTPGridSections, CXTPHeaderCtrl, CXTPMouseManager, CXTPPopupControl, CXTPPropertyGrid, CXTPPropertyGridInplaceButtons, CXTPRibbonBackstageView, CXTPRibbonGroups, CXTPShortcutBar, CXTPShortcutBarPane, CXTPSpinButtonCtrl, CXTPStatusBar, CXTPStatusBarSwitchPane, CXTPSyntaxEditAutoCompleteWnd, CXTPSyntaxEditDrawTextProcessor, CXTPSyntaxEditTipListBox, CXTPTabClientSticker, CXTPTabClientWnd, CXTPTabManager, CXTPTagCloudCtrl, CXTPTaskDialogLinkCtrl, CXTPTaskPanelGroup, CXTPTrackControl, CXTPTrackControlItem, CXTPTrackMarkers
  • HitTestAllDayEventsScrollIcons() : CXTPCalendarDayViewGroup
  • HitTestButton() : CXTPMessageBar
  • HitTestConnection() : CXTPFlowGraphControl
  • HitTestConnectionArea() : CXTPFlowGraphConnectionPoint, CXTPFlowGraphControl, CXTPFlowGraphPaintManager
  • HitTestConnectionPoint() : CXTPFlowGraphNode, CXTPFlowGraphNodeCustom
  • HitTestDateTime() : CXTPCalendarDayViewGroup, CXTPCalendarDayViewTimeScale
  • HitTestDiagramView() : CXTPChartContentView
  • HitTestEx() : CXTPCalendarDayView, CXTPCalendarDayViewEvent, CXTPCalendarDayViewGroup, CXTPCalendarMonthViewDay, CXTPCalendarMonthViewEvent, CXTPCalendarTimeLineView, CXTPCalendarTimeLineViewEvent, CXTPCalendarTimeLineViewTimeScale, CXTPCalendarView, CXTPCalendarViewDay, CXTPCalendarViewEvent, CXTPCalendarViewGroup, CXTPCalendarWeekViewDay, CXTPCalendarWeekViewEvent, CXTPListBase
  • HitTestGroup() : CXTPRibbonBar, CXTPRibbonTabPopupToolBar, CXTPTaskPanel
  • HitTestHeaderColumnIndex() : CXTPGridHeader
  • HitTestHyperlink() : CXTPGridRecordItem
  • HitTestItem() : CXTPControlGallery, CXTPTaskPanel
  • HitTestLineSegment() : CXTPMathUtils
  • HitTestMarkupItem() : CXTPMarkupTreeCtrl
  • HitTestNavigateButton() : CXTPTabManager
  • HitTestNode() : CXTPFlowGraphControl
  • HitTestRow() : CXTPSyntaxEditDrawTextProcessor
  • HitTestScrollBar() : CXTPScrollBase
  • HitTestScrollButton() : CXTPTaskPanel
  • HitTestThemeBackground() : CXTPWinThemeWrapper
  • HitTestVerbs() : CXTPPropertyGridPaintManager
  • HLStoRGB() : CXTPColorBase
  • Home() : CXTPExcelTabCtrl
  • HookKeyboard() : CXTPKeyboardManager
  • HorizontalLine() : CXTPPaintManager, CXTPTabBaseTheme
  • HorzEventScroll() : CXTPCalendarDayView
  • hResult : XTP_GRIDDATAMANAGER_COM_ERROR
  • ht : XTP_SCROLLBAR_POSINFO
  • hTimerSB : XTP_SCROLLBAR_TRACKINFO
  • HTMLDesktop() : CXTPShellSettings
  • hWndTrack : XTP_SCROLLBAR_TRACKINFO


Toolkit Pro: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- i -

  • iComCtlVersion : CXTPAuxData
  • IDD : CXTPCustomizeKeyboardPage, CXTPCustomizeOptionsPage, CXTPCustomizeToolbarsPage, CXTPImageEditorDlg
  • IDLFromPath() : CXTPShellPidl
  • idxExpandSignDown : CXTPCalendarPaintManager
  • idxExpandSignUp : CXTPCalendarPaintManager
  • idxMeeting : CXTPCalendarPaintManager
  • idxPrivate : CXTPCalendarPaintManager
  • idxRecurrenceException : CXTPCalendarPaintManager
  • idxRecurrenceOccurrence : CXTPCalendarPaintManager
  • idxReminder : CXTPCalendarPaintManager
  • IgnoreLButtonUp() : CXTPMouseManager
  • ImageChanged() : CXTPFlowGraphImage
  • ImplAttach() : CXTPListBase, CXTPTabBase
  • Import() : CXTPMemFile
  • Include() : CXTPChart3dBox, CXTPGridSubListControl
  • IncreaseIndent() : CXTPSyntaxEditCtrl
  • IndexOf() : CXTPChartElementCollection, CXTPChartStrings, CXTPGridColumnOrder, CXTPGridColumns, CXTPGridRecord, CXTPRibbonBackstageView, CXTPRibbonGroup, CXTPRibbonQuickAccessControls, CXTPTrackMarkers
  • Inflate() : CXTPRectT< T >
  • Init() : CXTPCalendarBusyStatusComboBox, CXTPCalendarComboBoxBase, CXTPCalendarEventCategoryComboBox, CXTPCalendarEventColorListBox, CXTPCalendarEventLabelComboBox, CXTPCheckListBox, CXTPColorBase, CXTPColorHex, CXTPDockingPaneMiniWnd, CXTPDockingPaneSidePanel, CXTPDockingPaneSplitterContainer, CXTPDockingPaneTabbedContainer, CXTPExcelTabCtrl, CXTPEyeDropper, CXTPFontEnum, CXTPHyperLink, CXTPImageManagerIconHandle, CXTPListBase, CXTPMDIWndTab, CXTPModuleHandle, CXTPResize, CXTPScrollBarCtrl, CXTPSearchOptionsCtrl, CXTPShellListBase, CXTPShellTreeCtrl, CXTPSpinButtonCtrl, CXTPSyntaxEditColorComboBox, CXTPTabBase, CXTPTabExBase, CXTPTabView, CXTPTearOffFrame, CXTPThemeDLL, CXTPTreeBase
  • InitBitmaps() : CXTPSyntaxEditPaintManager
  • InitBusyStatusDefaultColors() : CXTPCalendarPaintManager
  • InitClassData() : CXTPSyntaxEditPropertiesPageColor
  • InitColorComboxes() : CXTPSyntaxEditPropertiesPageFont
  • InitCommandBars() : CXTPCommandBarsSiteBase< TBase >
  • InitControl() : CXTPFontComboBox
  • InitDayOfWeekCBs() : CXTPCalendarEventRecurrenceDlg
  • InitDefaultStyles() : CXTPTagCloudStyleManager
  • InitDefaultValues() : CXTPCalendarEventCategories, CXTPCalendarEventLabels
  • InitDurationCB() : CXTPCalendarEventRecurrenceDlg
  • InitFont() : CXTPHyperLink
  • InitFontCombo() : CXTPSyntaxEditPropertiesPageFont
  • InitFromRegistry() : CXTPCalendarTimeZones
  • InitHistoryCombo() : CXTPSyntaxEditFindReplaceDlg
  • Initialize() : CXTPActiveScriptEngine, CXTPBrowseEdit, CXTPChartDeviceContext, CXTPComboBox, CXTPEditListBox, CXTPEditListBoxToolBar, CXTPFontListBox, CXTPListBox, CXTPMaskEdit
  • InitializeFont() : CXTPMDIWndTab, CXTPTabExBase
  • InitializeHeader() : CXTPHeaderCtrl
  • Initializer : CXTPSingletonPointer
  • InitializeSize() : CXTPTipWindow
  • InitializeTree() : CXTPShellTreeBase
  • InitialSelectionEnable() : CXTPGridControl
  • InitIcons() : CXTPPasswordPeek
  • InitListViewItems() : CXTPShellListBase
  • InitLoop() : CXTPDockingPaneContext
  • InitMonthCBs() : CXTPCalendarEventRecurrenceDlg
  • InitNames() : CXTPDatePickerControl
  • InitReminderComboBox() : CXTPCalendarEventPropertiesDlg
  • InitResourceHandle() : CXTPResourceImages
  • InitResources() : CXTPAuxData
  • InitRow() : CXTPGridRow
  • InitSchemaClasses() : CXTPSyntaxEditPropertiesPageColor
  • InitScriptCombo() : CXTPSyntaxEditPropertiesPageFont
  • InitScrollBars() : CXTPScrollable< Base >
  • InitSection() : CXTPPropExchange
  • InitSizeCombo() : CXTPSyntaxEditPropertiesPageFont
  • InitStandartVarsIfNeed() : CXTPSyntaxEditLexVariable
  • InitStartEndCB() : CXTPCalendarEventRecurrenceDlg
  • InitStyleCombo() : CXTPSyntaxEditPropertiesPageFont
  • InitSystemImageLists() : CXTPShellListBase, CXTPShellTreeBase
  • InitTreeNode() : CXTPShellTreeBase
  • InitTreeViewItems() : CXTPShellTreeBase
  • InitWhichDayCBs() : CXTPCalendarEventRecurrenceDlg
  • InputHitTest() : CXTPMarkupVisual
  • InputHitTestOverride() : CXTPMarkupVisual
  • Insert() : CXTPControlActions, CXTPMemFile
  • InsertAllCommandsCategory() : CXTPCustomizeCommandsPage
  • InsertAt() : CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE >, CXTPCalendarEvents, CXTPCalendarPtrCollectionT< _TObject >, CXTPChartElementCollection, CXTPControls, CXTPGridColumnOrder, CXTPGridRecords, CXTPGridRows, CXTPPropertyGridItems, CXTPRibbonGroup, CXTPRibbonGroups, CXTPTabManagerNavigateButtons, CXTPTaskPanelItems
  • InsertBuiltInMenus() : CXTPCustomizeCommandsPage
  • InsertCategory() : CXTPCustomizeCommandsPage, CXTPCustomizeKeyboardPage, CXTPPropertyGrid, CXTPPropertyGridView, CXTPRibbonCustomizePage, CXTPRibbonCustomizeQuickAccessPage, CXTPTabToolBar
  • InsertCharAt() : CXTPMaskEditT< TBase >
  • InsertChildItem() : CXTPPropertyGridItem
  • InsertCommas() : CXTPShellListBase
  • InsertDesktopItem() : CXTPShellTreeBase
  • InsertItem() : CXTPControlGalleryItems, CXTPExcelTabCtrl, CXTPTabControl
  • InsertMDIChild() : CXTPWindowList
  • InsertMenuItem() : CXTPShortcutListBox
  • InsertNewMenuCategory() : CXTPCustomizeCommandsPage
  • InsertPage() : CXTPPropertySheet
  • InsertRow() : CXTPGridControl, CXTPSyntaxEditCtrl
  • InsertSortColumn() : CXTPGridColumns
  • InsertStr() : CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager
  • InsertString() : CXTPControlComboBox, CXTPSyntaxEditCtrl
  • InsertTab() : CXTPRibbonBar
  • InsertTabWnd() : CXTPMDIWndTab
  • InsertText() : CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager, CXTPSyntaxEditBufferManager
  • InsertTextBlock() : CXTPSyntaxEditBufferManager, CXTPSyntaxEditCtrl
  • Install() : CXTPMDIWndTab
  • InstallDockingPanes() : CXTPDockingPaneManager
  • InstallIconPending() : CXTPTrayIcon
  • Instance() : CXTPSingleton< T, Dependencies >, CXTPToolhelpApi
  • InterlacedColor : CXTPChartAxisAppearance
  • InterlacedColor2 : CXTPChartAxisAppearance
  • InterlacedFillStyle : CXTPChartAxisAppearance
  • InternalTextChanged() : CXTPButton
  • InternalToValue() : CXTPChartDateTimeScaleTypeMap, CXTPChartNumericalScaleTypeMap, CXTPChartQualitativeScaleTypeMap, CXTPChartScaleTypeMap, CXTPChartTimeScaleTypeMap
  • Intersect() : CXTPRectT< T >
  • IntersectsWith() : CXTPRectT< T >
  • InvalidateArrange() : CXTPMarkupUIElement
  • InvalidateCheck() : CXTPCheckListBox
  • InvalidateCommandBars() : CXTPCommandBars
  • InvalidateItem() : CXTPCheckListBox
  • InvalidateItems() : CXTPControlGallery
  • InvalidateMeasure() : CXTPMarkupUIElement
  • InvalidateMeasureOverride() : CXTPMarkupUIElement
  • InvalidatePane() : CXTPDockingPaneAutoHidePanel, CXTPDockingPaneBase, CXTPDockingPaneMiniWnd, CXTPDockingPaneSidePanel
  • InvalidateParents() : CXTPCommandBar
  • InvalidateRect() : CXTPDockingPaneCaptionButton
  • InvalidateRow() : CXTPSyntaxEditCtrl
  • InvalidateRows() : CXTPSyntaxEditCtrl
  • InvalidateTabs() : CXTPExcelTabCtrl
  • InvalidateVisual() : CXTPMarkupUIElement
  • Invert() : CXTPGridSelectedRows
  • InvertAlphaBitmap() : CXTPImageManagerIcon
  • InvertBitmap() : CXTPResourceImage
  • Invoke() : CXTPActiveScriptObjectContext
  • InvokeAction() : CXTPGaugeBaseType
  • InvokeWithArgs() : CXTPActiveScriptObjectContext
  • iRow : CXTPListBase::ROWCOLOR
  • Is3D() : CXTPChartDeviceContext, CXTPChartObject
  • Is3dEdgeSmoothingEnabled() : CXTPChartSeriesStyle
  • IsAcceptFocus() : CXTPTaskPanelGroup, CXTPTaskPanelItem
  • IsActionsEnabled() : CXTPCommandBars
  • IsActive() : CXTPDialogBar, CXTPDockingPaneBase, CXTPDockingPaneMiniWnd, CXTPDockingPaneSidePanel, CXTPDockingPaneTabbedContainer, CXTPRibbonBar, CXTPSkinObjectFrame, CXTPSyntaxEditAutoCompleteWnd, CXTPSyntaxEditCtrl, CXTPTabManager
  • IsActiveTab() : CXTPRibbonBackstageView
  • IsAdditionalScaleLeftVisible() : CXTPCalendarDayView
  • IsAdditionalScaleRightVisible() : CXTPCalendarDayView
  • IsAdvancedMode() : CXTPCalendarTip
  • IsAllCaps() : CXTPCommandBars
  • IsAllDayEvent() : CXTPCalendarEvent
  • IsAllowAccess() : CXTPGridSection
  • IsAllowBlobValues() : CXTPPropExchange, CXTPPropExchangeArchive, CXTPPropExchangeRegistry
  • IsAllowColumnRemove() : CXTPGridHeader
  • IsAllowColumnReorder() : CXTPGridHeader
  • IsAllowColumnResize() : CXTPGridHeader
  • IsAllowColumnSort() : CXTPGridHeader
  • IsAllowDefaultValues() : CXTPPropExchange, CXTPPropExchangeArchive
  • IsAllowDrag() : CXTPTaskPanelItem
  • IsAllowDragging() : CXTPGridColumn
  • IsAllowDrop() : CXTPTaskPanelItem
  • IsAllowEdit() : CXTPGridSection, CXTPPropertyGridItem
  • IsAllowFilter() : CXTPGridSection
  • IsAllowFreeResize() : CXTPShortcutBar
  • IsAllowGroup() : CXTPGridSection
  • IsAllowMinimize() : CXTPShortcutBar
  • IsAllowNoncontinuousSelection() : CXTPDatePickerControl
  • IsAllowQuickAccessControl() : CXTPRibbonBar
  • IsAllowQuickAccessDuplicates() : CXTPRibbonBar
  • IsAllowRemove() : CXTPGridColumn
  • IsAllowReorder() : CXTPTabClientWnd, CXTPTabManager
  • IsAllowSort() : CXTPGridSection
  • IsAlpha() : CXTPGraphicBitmapPng, CXTPImageManagerIcon, CXTPImageManagerIconHandle, CXTPSvgImage
  • IsAlphaBitmapFile() : CXTPImageManagerIcon
  • IsAlphaBitmapResource() : CXTPImageManager, CXTPImageManagerIcon
  • IsAlphaDockingContext() : CXTPDockingPaneManager
  • IsAlphaIconHandle() : CXTPImageManagerIcon
  • IsAlphaIconsImageListSupported() : CXTPImageManager
  • IsAlphaIconsSupported() : CXTPImageManager
  • IsAlphaImage() : CXTPResourceImage, CXTPSkinImage
  • IsAlphaShadow() : CXTPShadowManager
  • IsAnimationEnabled() : CXTPCommandBar
  • IsAppCaption() : CXTPCaption
  • IsAppThemeActive() : CXTPWinThemeWrapper
  • IsAppThemed() : CColorSetWinNative, CXTPTabPaintManagerColorSet, CXTPWinThemeWrapper
  • IsAppThemeReady() : CXTPWinThemeWrapper
  • IsAttached() : CXTPTabClientWnd
  • IsAuto() : CXTPMarkupGridLength
  • IsAutoCheckItems() : CXTPGridControl
  • IsAutoColumnSizing() : CXTPGridHeader
  • IsAutoHeight() : CXTPTaskPanelGroupItem
  • IsAutomaticUpdateEnabled() : CXTPGaugeBaseType
  • IsAutoPopup() : CXTPCalendarRemindersDialog
  • IsAutoPreviewActivateEnabled() : CXTPPreviewCtrl
  • IsAutoSize() : CXTPDatePickerControl, CXTPGridColumn
  • IsAutoSortWhenGrouped() : CXTPGridColumn
  • IsAvailable() : CXTPWebViewProvider, IXTPPreview
  • IsBackstageViewVisible() : CXTPRibbonBar
  • IsBalloonStyleSupported() : CXTPToolTipContext
  • IsBarVisible() : CXTPPropertyGrid
  • IsbBlockSelectionMode() : CXTPSyntaxEditSelection
  • IsBeingFrequentlyUpdated() : CXTPChartContainer
  • IsBent() : CXTPChart3dPieSeriesLabelDeviceCommand
  • IsBold() : CXTPGridRecordItem, CXTPPopupItem, CXTPTaskPanelGroupItem
  • IsBoldDaysOnIdle() : CXTPCalendarController
  • IsBoldDaysWithEvents() : CXTPCalendarController
  • IsBorderVisible() : CXTPSplitterWnd
  • IsBottom() : CXTPTabBaseTheme
  • IsBrowsing() : CXTPBrowseEdit
  • IsBuddyButtonVisible() : CXTPControlEdit
  • IsBuiltIn() : CXTPToolBar
  • IsButton() : CXTPPopupItem, CXTPStatusBarPane
  • IsCaptionButtonVisible() : CXTPDockingPaneBase, CXTPDockingPaneMiniWnd, CXTPDockingPaneTabbedContainer
  • IsCaptionMaximizeButtonsVisible() : CXTPDockingPaneManager
  • IsCaptionVertical() : CXTPDockingPaneBase, CXTPDockingPaneMiniWnd, CXTPDockingPaneSidePanel, CXTPDockingPaneTabbedContainer
  • IsCaptionVisible() : CXTPCommandBarsFrameHook, CXTPControl, CXTPControlComboBox, CXTPControlEdit, CXTPRibbonBar, CXTPTaskPanelGroup
  • IsCaseSensitive() : CXTPGridRecords, CXTPSyntaxEditLexClass
  • IsCategory() : CXTPPropertyGridItem
  • IsCellMergingAllowed() : CXTPGridControl
  • IsChanged() : CXTPControls, CXTPGridControl, CXTPGridSelectedRows
  • IsCheckBoxStyle() : CXTPPropertyGridItemBool, CXTPPropertyGridItemOption
  • IsChecked() : CXTPGridRecordItem, CXTPStatusBarPane
  • IsChildItemDragOver() : CXTPTaskPanelGroup
  • IsChildOfMerge() : CXTPGridRecordItem
  • IsChildView() : CXTPTabExBase
  • IsClearTypeTextQualitySupported() : CXTPSystemVersion
  • IsClientHidden() : CXTPDockingPaneManager
  • IsClientPaneVisible() : CXTPShortcutBar
  • IsClosable() : CXTPTabManagerItem
  • IsCloseable() : CXTPToolBar
  • IsClosed() : CXTPDockingPane
  • IsCloseTag() : CXTPSyntaxEditAutoCompleteWnd
  • IsColFrozen() : CXTPHeaderCtrl
  • IsCollapsable() : CXTPSyntaxEditLexClass
  • IsCollapsed() : CXTPDockingPaneMiniWnd, CXTPDockingPaneSidePanel
  • IsColorDlgVisible() : CXTPColorSelectorCtrl
  • IsColorEach() : CXTPChartSeriesStyle
  • IsColorFilterExists() : CXTPSkinManager
  • IsColorStatic() : CXTPColorSelectorCtrl
  • IsColumHotTrackingEnabled() : CXTPGridPaintManager, CXTPGridThemeExplorer, CXTPGridThemeOffice2003Luna, CXTPTrackThemeExplorer, CXTPTrackThemeOffice2003Luna
  • IsColumnPlusMinusSign() : CXTPGridPaintManager
  • IsColumnWidthWYSIWYG() : CXTPGridPaintManager
  • IsComCtlV6() : CXTPSkinManager
  • IsComCtlValid() : CXTPAuxData
  • IsCommand() : CXTPRibbonBackstageView
  • IsCommandEnabled() : CXTPCommandBarEditCtrl
  • IsCommandHidden() : CXTPCommandBars
  • IsCommitted() : CXTPChartDeviceCommand
  • IsConfigFileMode() : CXTPSyntaxEditCtrl
  • IsConnectorVisible() : CXTPChart3dFunnelSeriesLabelView, CXTPChart3dPieSeriesLabelView, CXTPChart3dPyramidSeriesLabelView
  • IsContextMenu() : CXTPPopupBar
  • IsContextMenuPresent() : CXTPToolBar
  • IsControlEnabled() : CXTPRibbonBar
  • IsControlHidden() : CXTPCommandBars
  • IsControlsCentering() : CXTPRibbonGroup
  • IsControlsGrouping() : CXTPRibbonGroup
  • IsCreated() : CXTPFrameShadow
  • IsCreateScrollbarOnParent() : CXTPSyntaxEditCtrl
  • IsCrossAxis() : CXTPChartAxisTickMarks
  • IsCursorOver() : CXTPControl
  • IsCustomizable() : CXTPCommandBar, CXTPControlComboBoxList
  • IsCustomizeAvail() : CXTPCommandBars
  • IsCustomizeDialogPresent() : CXTPCommandBar, CXTPToolBar
  • IsCustomizeMode() : CXTPCommandBar, CXTPCommandBars, CXTPControl
  • IsCustomizeMovable() : CXTPControl
  • IsCustomizeResizeAllow() : CXTPControl, CXTPControlComboBox, CXTPControlEdit
  • IsCustomMarkup() : CXTPFlowGraphNode, CXTPFlowGraphNodeCustom
  • IsCustomValue() : CXTPCalendarThemeCustomizableXValueT< _TValue, _TValueRef >, CXTPCalendarViewPartCustomizableValueT< _TValue >, CXTPPaintManagerColor
  • IsDark() : CXTPStatusBarPane
  • IsDateLabel() : CXTPCalendarCaptionBarTheme
  • IsDayInCache() : CXTPCalendarData::CXTPDPCache
  • IsDefaultItemDrawingEnabled() : CXTPTreeBase
  • IsDefaultValue() : CXTPCalendarThemeCustomizableXValueT< _TValue, _TValueRef >, CXTPCalendarViewPartCustomizableValueT< _TValue >, CXTPCalendarViewPartFontValue, CXTPPaintManagerColor
  • IsDialogBar() : CXTPCommandBar, CXTPDialogBar
  • IsDialogCode() : CXTPCommandBarEditCtrl
  • IsDirectDrawSupported() : CXTPImageManagerIcon, CXTPImageManagerVectorImageHandle
  • IsDirectionClockwise() : CXTPChartRadarAxisX
  • IsDirty() : CXTPTaskPanel, CXTPTaskPanelGroup
  • IsDoubleBuffering() : CXTPGridControl
  • IsDoubleGripper() : CXTPPopupBar
  • IsDownAllDayEventsScrollButtonVisible() : CXTPCalendarDayViewGroup
  • IsDpiAware() : CXTPMarkupContext
  • IsDpiBitmapScalingEnabled() : CXTPCommandBarsOptions, CXTPHeaderCtrl, CXTPPopupControl, CXTPToolTipContext
  • IsDpiGalleryItemScalingEnabled() : CXTPCommandBarsOptions
  • IsDpiIconsScalingEnabled() : CXTPRibbonBackstageView
  • IsDpiImageScalingEnabled() : CXTPButton
  • IsDragging() : CXTPGridColumn
  • IsDragHeader() : CXTPGridHeader
  • IsDragMode() : CXTPGridControl
  • IsDrawFocusRect() : CXTPTaskPanel, CXTPTreeTheme
  • IsDrawGridForEmptySpace() : CXTPGridPaintManager
  • IsDrawNowLine() : CXTPCalendarDayViewTimeScale
  • IsDrawNowLineOverAppoinment() : CXTPCalendarDayView
  • IsDrawReverted() : CXTPImageManager
  • IsDrawStaticFrame() : CXTPTabManager
  • IsDropDownStyle() : CXTPButton
  • IsDroppedDown() : CXTPComboBox
  • IsDroppedOff() : CXTPTaskPanelItem
  • IsDwmEnabled() : CXTPCommandBars, CXTPCommandBarsFrameHook, CXTPRibbonBar
  • IsEditable() : CXTPGridColumn, CXTPGridRecord, CXTPGridRecordItem
  • IsEditingSubject() : CXTPCalendarView, CXTPCalendarViewEvent
  • IsEditMode() : CXTPGridControl
  • IsEditOnClick() : CXTPGridControl
  • IsEditOnDelayClick() : CXTPGridControl
  • IsEditOnDoubleClick() : CXTPGridControl
  • IsEditOperationDisabledNotify() : CXTPCalendarView
  • IsEmpty() : CXTPChartColor, CXTPDockingPaneBase, CXTPDockingPaneBaseContainer, CXTPHeapString, CXTPImageManagerIconHandle, CXTPPropertyGridItemConstraints, CXTPPropertyGridItems, CXTPPropertyGridUpdateContext, CXTPPropertyGridVerbs, CXTPSizeT< T >
  • IsEmptyArea() : CXTPRectT< T >
  • IsEnabled() : CXTPChart3dDeviceCommand, CXTPChartDeviceCommand, CXTPCheckListBox, CXTPDockingPaneCaptionButton, CXTPMarkupUIElement, CXTPShortcutBarItem, CXTPSkinManager, CXTPStatusBarPane, CXTPTabManagerItem, CXTPTabManagerNavigateButton
  • IsEnabledEditAccelerators() : CXTPSyntaxEditCtrl
  • IsEnabledVirtualSpace() : CXTPSyntaxEditCtrl
  • IsEnabledWhiteSpace() : CXTPSyntaxEditCtrl
  • IsEnableFrameTheme() : CXTPCommandBars
  • IsEnsureFocusedRowVisible() : CXTPGridControl
  • IsEOF() : CXTPSyntaxEditTextIterator
  • IsEqual() : CXTPCalendarTimeZone, CXTPCalendarUtils
  • IsEqualHeight() : CXTPChartFunnelSeriesStyleBase
  • IsEqualID() : CXTPCalendarReminder
  • IsEqualIDs() : CXTPCalendarEvent
  • IsEqualLexClasses() : CXTPSyntaxEditLexTextBlock
  • IsEqualStartEnd() : CXTPCalendarEvent
  • IsEventInCache() : CXTPCalendarData::CXTPDPCache
  • IsEventVisible() : CXTPCalendarEvent
  • IsExist() : CXTPCalendarData::EventsMapByID_T< _TObject >
  • IsExpandable() : CXTPPropertyGridItem, CXTPShortcutBarPaneItem, CXTPTaskPanel, CXTPTaskPanelGroup
  • IsExpandButton() : CXTPCalendarCaptionBarTheme
  • IsExpandButtonVisible() : CXTPShortcutBar
  • IsExpandDown() : CXTPCalendarDayView, CXTPCalendarDayViewGroup
  • IsExpanded() : CXTPCalendarViewDay, CXTPGridColumn, CXTPGridRecord, CXTPGridRow, CXTPPropertyGridItem, CXTPSearchOptionsCtrl, CXTPShortcutBarItem, CXTPShortcutBarPaneItem, CXTPTaskPanelGroup
  • IsExpanding() : CXTPTaskPanelGroup
  • IsExpandUp() : CXTPCalendarDayView, CXTPCalendarDayViewGroup
  • IsExplorerBehaviour() : CXTPTaskPanel
  • IsExplorerTheme() : CXTPTreeBase
  • IsFailed() : CXTPChart3dFunnelSeriesLabelDeviceCommand, CXTPChart3dPieSeriesLabelDeviceCommand, CXTPChart3dPyramidSeriesLabelDeviceCommand
  • IsFileExtSupported() : CXTPSyntaxEditLexTextSchema
  • IsFillHorz() : CXTPTagCloudCtrl
  • IsFilterable() : CXTPGridColumn
  • IsFiltered() : CXTPGridRecord
  • IsFilterHiddenColumns() : CXTPGridControl
  • IsFindValid() : CXTPTreeBase
  • IsFixed() : CXTPGridColumn
  • IsFixedInplaceButtonHeight() : CXTPGridPaintManager
  • IsFixedRowHeight() : CXTPGridPaintManager
  • IsFlatStyle() : CXTPEdit, CXTPEditTheme
  • IsFloating() : CXTPDockingPane
  • IsFloatingCaptionMaximizeButtonsVisible() : CXTPDockingPaneManager
  • IsFloatingFrameThemeEnabled() : CXTPDockingPaneManager, CXTPTabClientContext
  • IsFocus() : CXTPDockingPane
  • IsFocusable() : CXTPControl, CXTPControlComboBox, CXTPControlEdit, CXTPGridRecordItem, CXTPMarkupUIElement, CXTPRibbonControlTab
  • IsFocused() : CXTPComboBox, CXTPControl, CXTPControlCheckBox, CXTPControlComboBox, CXTPControlEdit, CXTPControlListBox, CXTPControlRadioButton, CXTPDatePickerControl, CXTPEdit, CXTPGridRow, CXTPPropertyGridInplaceButton, CXTPPropertyGridVerb, CXTPRibbonControlTab, CXTPTabManagerItem
  • IsFocusedControl() : CXTPRibbonBackstageView
  • IsFocusEnabled() : CXTPTagCloudCtrl
  • IsFocusSubItems() : CXTPGridControl
  • IsFooterRowsPinned() : CXTPGridControl
  • IsFooterRowsPinnedPrinted() : CXTPGridControl
  • IsFooterVisible() : CXTPGridControl
  • IsForceExpanded() : CXTPMouseManager
  • IsFormatChar() : CXTPCalendarUtils
  • IsFrameActive() : CXTPCommandBarsFrameHook
  • IsFrameBeingDragged() : CXTPTearOffFrame
  • IsFrameHasStatusBar() : CXTPCommandBarsFrameHook
  • IsFrameThemeEnabled() : CXTPRibbonBar
  • IsFrozen() : CXTPGridColumn
  • IsFullColumnScrolling() : CXTPGridControl
  • IsFullRowSelectionEnabled() : CXTPTreeBase
  • IsGdiPlusEnabled() : CXTPMarkupContext
  • IsGridVisible() : CXTPGridPaintManager
  • IsGroup() : CXTPTaskPanelItem
  • IsGroupable() : CXTPGridColumn
  • IsGroupByVisible() : CXTPGridControl
  • IsGroupExpanded() : CXTPTaskPanel
  • IsGroupHeaderVisible() : CXTPCalendarDayView, CXTPCalendarDayViewGroup
  • IsGroupRow() : CXTPGridGroupRow, CXTPGridRow
  • IsGroupRowsBold() : CXTPGridControl
  • IsGroupsVisible() : CXTPRibbonBar
  • IsHandCursor() : CXTPPopupItem
  • IsHandleOwnershipGuaranteed() : CXTPGdiObject
  • IsHeaderVisible() : CXTPGridControl
  • IsHelpMode() : CXTPCommandBar
  • IsHelpVisible() : CXTPPropertyGrid
  • IsHidden() : CXTPDockingPane, CXTPDockingPaneBase, CXTPDockingPaneTabbedContainer, CXTPPropertyGridItem, CXTPShortcutBarItem
  • IsHideCaret() : CXTPSyntaxEditCtrl
  • IsHideEventTime() : CXTPCalendarDayViewEvent
  • IsHighlightChangedButtonItems() : CXTPPropertyGrid
  • IsHighlightChangedItems() : CXTPPropertyGrid
  • IsHighlighted() : CXTPButton, CXTPComboBox, CXTPEdit, CXTPRibbonGroup, CXTPShortcutBarPaneItem, CXTPSkinObjectFrame::CCaptionButton, CXTPStatusBarPane, CXTPTabManagerItem, CXTPTabManagerNavigateButton
  • IsHighlightedControl() : CXTPRibbonBackstageView
  • IsHoriz() : CXTPDockingPaneSplitterContainer
  • IsHorizontal() : CXTPDockingPaneSidePanel, CXTPDockingPaneSplitterWnd
  • IsHorizontalPosition() : CXTPTabManager
  • IsHorz() : CXTPTabBaseTheme
  • IsHot() : CXTPPropertyGridInplaceButton
  • IsHotTracking() : CXTPGridColumn
  • IsHScrollEnabled() : CXTPCalendarView
  • IsHyperLink() : CXTPPopupItem
  • IsHyperlink() : CXTPPropertyGridInplaceButton
  • IsIcon() : CXTPMarkupDeviceDependentImage
  • IsIconView() : CXTPGridControl
  • IsImagesAvailable() : CXTPResourceTheme, CXTPRibbonTheme
  • IsImageVisible() : CXTPControlComboBox, CXTPControlEdit
  • IsImeMode() : CXTPCommandBarEditCtrl
  • IsInclude() : CXTPSyntaxEditLexTextBlock
  • IsInDiscreteSelection() : CXTPCalendarView
  • IsInitialized() : CXTPToolhelpApi
  • IsInitialSelectionEnabled() : CXTPGridControl
  • IsInplaceButtonVisible() : CXTPPropertyGridItem
  • IsInputLocked() : CXTPKeyboardManager
  • IsInSel_disp() : CXTPSyntaxEditSelection
  • IsInSel_str() : CXTPSyntaxEditSelection
  • IsInside() : CXTPChartFunnelSeriesLabelBase, CXTPChartPieSeriesLabelBase, CXTPChartPyramidSeriesLabelBase
  • IsInsideCellButton() : CXTPGridInplaceButton
  • IsInterlaced() : CXTPChartAxis
  • IsIntersectSel_disp() : CXTPSyntaxEditSelection
  • IsIntersectSel_str() : CXTPSyntaxEditSelection
  • IsIntResource() : CXTPResourceManager
  • IsItemChecked() : CXTPControlGallery
  • IsItemDefault() : CXTPControl
  • IsItemDragging() : CXTPTaskPanelItem
  • IsItemDragOver() : CXTPTaskPanelItem
  • IsItemExpandButton() : CXTPShortcutBarItem
  • IsItemFiltered() : CXTPShellListBase
  • IsItemFocused() : CXTPTaskPanelItem
  • IsItemHot() : CXTPTaskPanelItem
  • IsItemPressed() : CXTPTaskPanelItem
  • IsItemSelected() : CXTPControlGallery, CXTPTaskPanelGroupItem
  • IsItemShrinked() : CXTPTabManagerItem
  • IsItemsVisible() : CXTPGridRow
  • IsItemVisible() : CXTPTaskPanelGroup
  • IsKey() : CXTPTrackBlock, CXTPTrackKey
  • IsKeyboardCuesVisible() : CXTPCommandBar, CXTPRibbonBar, CXTPRibbonTabPopupToolBar
  • IsKeyboardHooked() : CXTPKeyboardManager
  • IsKeyboardNavigateEnabled() : CXTPDockingPaneManager
  • IsKeyboardTipsVisible() : CXTPCommandBar
  • IsLabel() : CXTPControlGalleryItem
  • IsLabeled() : CXTPControlEdit
  • IsLastColumnWidthWYSIWYG() : CXTPGridPaintManager
  • IsLastResizebleColumn() : CXTPGridHeader
  • IsLastTreeRow() : CXTPGridRow
  • IsLastVisibleColumn() : CXTPGridHeader
  • IsLayoutChanged() : CXTPControl
  • IsLayoutRTL() : CXTPCalendarControl, CXTPCommandBar, CXTPCommandBars, CXTPControl, CXTPDockingPaneManager, CXTPGridControl, CXTPPopupControl, CXTPPropertyGrid, CXTPTabClientWnd
  • IsLayoutRTLSupported() : CXTPSystemVersion
  • IsLeft() : CXTPTabBaseTheme
  • IsLeftDirected() : CXTPChart3dFunnelSeriesLabelView, CXTPChart3dPieSeriesLabelView, CXTPChart3dPyramidSeriesLabelView
  • IsLegendVisible() : CXTPChartAxisConstantLine, CXTPChartAxisStrip, CXTPChartSeries
  • IsLinkHot() : CXTPHyperLink
  • IsLoaded() : CXTPGaugeCtrl, CXTPMarkupDeviceDependentImage, CXTPSvgImage
  • IsLoading() : CXTPPropExchange
  • IsLocked() : CXTPFlowGraphConnectionPoint, CXTPFlowGraphNode, CXTPGridRecord, CXTPTrackBlock, CXTPTrackControlItem
  • IsLockedExclusively() : CXTPRWCriticalSection
  • IsLockedSharedly() : CXTPRWCriticalSection
  • IsLockExpand() : CXTPGridControl, CXTPGridRow
  • IsLookLikeClosed() : CXTPSyntaxEditLexTextBlock
  • IsLowResolution() : CXTPColorManager
  • IsLunaColorsDisabled() : CXTPColorManager, CXTPTabPaintManager
  • IsMarkerVisible() : CXTPChartLegend
  • IsMarkupEnabled() : CXTPCalendarControl
  • IsMarkupImage() : CXTPImageManagerVectorImageHandle
  • IsMarquee() : CXTPMarqueeCtrl
  • IsMDIMaximized() : CXTPCommandBarsFrameHook
  • IsMeeting() : CXTPCalendarEvent
  • IsMenuSeparator() : CXTPRibbonBackstageView
  • IsMenuTitleBar() : CXTPCommandBar
  • IsMeterType() : CXTPGaugeCtrl
  • IsMetricObject() : CXTPSkinManagerMetrics
  • IsMinimizeButtonVisible() : CXTPShortcutBar
  • IsMinorVisible() : CXTPChartAxisGridLines, CXTPChartAxisTickMarks
  • IsModal() : CXTPDatePickerControl
  • IsModified() : CXTPCalendarEventColorListBox, CXTPMaskEditT< TBase >, CXTPSyntaxEditBufferManager, CXTPSyntaxEditUndoRedoManager
  • IsMonitoringRunning() : CXTPCalendarRemindersManager
  • IsMouseLocked() : CXTPMouseManager, CXTPRibbonControlTab, CXTPTabManager
  • IsMultiColumn() : CXTPTaskPanel
  • IsMulticolumnsEnable() : CXTPCalendarCaptionBarControl
  • IsMultidayEvent() : CXTPCalendarDayViewEvent, CXTPCalendarViewEvent
  • IsMultiLine() : CXTPPropertyGridItem
  • IsMultilineForce() : CXTPGridTip
  • IsMultipleSelection() : CXTPGridControl
  • IsMultiSelect() : CXTPTreeBase
  • IsMultiSelectionMode() : CXTPDatePickerControl, CXTPGridControl
  • IsMultyDayTextAlign() : CXTPCalendarViewEvent
  • IsNan() : CXTPMathUtils
  • IsNavigateButtonAutomaticVisible() : CXTPTabManager
  • IsNavigateButtonVisible() : CXTPTabManager
  • IsNewWindowTab() : CXTPTabManagerItem
  • IsNoEndDate() : CXTPCalendarRecurrencePattern
  • IsNoneButtonVisible() : CXTPDatePickerControl
  • IsNormalized() : CXTPResizeRect
  • IsNull() : CXTPPaintManagerColorGradient
  • IsNumericOnly() : CXTPControlEdit
  • IsOneLine() : CXTPCalendarCaptionBarTheme
  • IsOnQuickAccess() : CXTPControl
  • IsOpen() : CXTPCalendarData
  • IsOpenTag() : CXTPSyntaxEditAutoCompleteWnd
  • IsOptionButtonVisible() : CXTPRibbonGroup
  • IsOriginalControls() : CXTPControls
  • IsOutOfClientRect() : CXTPCalendarDayView
  • IsOwnerActive() : CXTPTabManagerNavigateButton
  • IsOwnerDrawn() : CXTPSyntaxEditTipWnd
  • IsOwnerHighlighted() : CXTPTabManagerNavigateButton
  • IsOwnerNull() : CXTPTabManagerNavigateButton
  • IsOwnerSelected() : CXTPTabManagerNavigateButton
  • IsPaneClosed() : CXTPDockingPaneManager
  • IsPaneHidden() : CXTPDockingPaneManager
  • IsPaneSelected() : CXTPDockingPaneManager
  • IsParserEnabled() : CXTPSyntaxEditBufferManager
  • IsPathValid() : CXTPDirWatcher
  • IsPatternValid() : CXTPEdit
  • IsPeekButtonEnabled() : CXTPPasswordPeek
  • IsPersistentModule() : CXTPSkinManager
  • IsPlusMinus() : CXTPGridColumn
  • IsPngBitmapFile() : CXTPImageManagerIcon
  • IsPngBitmapResource() : CXTPImageManager, CXTPImageManagerIcon
  • IsPopupBar() : CXTPCommandBar, CXTPPopupBar
  • IsPopupBarTracking() : CXTPRibbonControlTab
  • IsPressed() : CXTPDockingPaneCaptionButton, CXTPGridInplaceButton, CXTPMarkupButtonBase, CXTPPopupItem, CXTPPropertyGridInplaceButton, CXTPSkinObjectFrame::CCaptionButton, CXTPStatusBarPane, CXTPTabManagerItem, CXTPTabManagerNavigateButton
  • IsPreviewAllowEdit() : CXTPGridControl
  • IsPreviewItem() : CXTPGridRecordItem, CXTPGridRecordItemPreview
  • IsPreviewMode() : CXTPGridControl, CXTPGridPaintManager
  • IsPreviewVisible() : CXTPGridRow
  • IsPrimaryImageExists() : CXTPImageManager
  • IsPrintGroupRowIcon() : CXTPGridPaintManager
  • IsPrivate() : CXTPCalendarEvent
  • IsProperty() : CXTPMarkupStaticExtension
  • IsPropertyExists() : CXTPPropExchangeRegistry, CXTPPropExchangeXMLNode
  • IsPushButton() : CXTPButton
  • IsPushed() : CXTPButton, CXTPColorPicker
  • IsQuickAccessBelowRibbon() : CXTPRibbonBar
  • IsQuickAccessControl() : CXTPRibbonBar
  • IsQuickAccessVisible() : CXTPRibbonBar
  • IsQuickCustomizeMode() : CXTPCommandBars
  • IsRasterIcon() : CXTPImageManagerIcon
  • IsReadOnly() : CXTPHexEdit, CXTPSyntaxEditCtrl
  • IsReadonly() : CXTPSyntaxEditDoc
  • IsReadonlyMode() : CXTPCalendarControl
  • IsReady() : CXTPApplication, IXTPPreview
  • IsReduced() : CXTPRibbonGroup
  • IsReminder() : CXTPCalendarEvent
  • IsRemindersEnabled() : CXTPCalendarControl
  • IsRenderingAntialiasing() : CXTPChart3dDeviceContext
  • IsReplaceDialog() : CXTPSyntaxEditFindReplaceDlg
  • IsResizable() : CXTPCommandBar, CXTPControlGallery, CXTPFlowGraphNode, CXTPGridColumn, CXTPPopupBar, CXTPTrackBlock
  • IsReversed() : CXTPChartAxis
  • IsRExceptionDeleted() : CXTPCalendarEvent
  • IsRibbonBar() : CXTPCommandBar, CXTPRibbonBar
  • IsRibbonBarVisible() : CXTPRibbonBar
  • IsRibbonMinimized() : CXTPRibbonBar
  • IsRight() : CXTPTabBaseTheme
  • IsRightButtonDrag() : CXTPSyntaxEditCtrl
  • IsRightDirected() : CXTPChart3dFunnelSeriesLabelView, CXTPChart3dPieSeriesLabelView, CXTPChart3dPyramidSeriesLabelView
  • IsRootSection() : CXTPPropExchange
  • IsRotated() : CXTPChart3dRotation
  • IsRowFocusVisible() : CXTPGridControl
  • IsRowValid() : CXTPSyntaxEditCtrl
  • IsRowVisible() : CXTPSyntaxEditCtrl
  • IsScaled() : CXTPImageManagerIcon
  • IsScaleLeftVisible() : CXTPCalendarDayView
  • IsScaleRightVisible() : CXTPCalendarDayView
  • IsSchedulesSetEmpty() : CXTPCalendarResource
  • IsScrollBarAuto() : CXTPControlGallery
  • IsScrollBarEnabled() : CXTPControlGallery, CXTPScrollBase
  • IsScrollBarVisible() : CXTPControlGallery
  • IsScrollButtonEnabled() : CXTPControlGallery, CXTPTaskPanelGroup
  • IsScrollDateButtons() : CXTPCalendarCaptionBarTheme
  • IsSectionExists() : CXTPPropExchangeRegistry, CXTPPropExchangeXMLNode
  • IsSelected() : CXTPCalendarTimeLineViewEvent, CXTPCalendarViewDay, CXTPCalendarViewEvent, CXTPDatePickerControl, CXTPDatePickerList, CXTPDockingPane, CXTPDockingPaneCaptionButton, CXTPFlowGraphElement, CXTPGridRow, CXTPPopupItem, CXTPPropertyGridItem, CXTPShortcutBarItem, CXTPTabManagerItem, CXTPTrackBlock, CXTPTrackSelectedBlocks, CXTPTreeBase
  • IsSelectionEnabled() : CXTPGridSection
  • IsSelectionExist() : CXTPSyntaxEditCtrl
  • IsSelExist() : CXTPSyntaxEditSelection
  • IsSelNormal() : CXTPSyntaxEditSelection
  • IsShadeGroupHeadingsEnabled() : CXTPGridControl
  • IsShadowEnabled() : CXTPFrameShadowManager
  • IsShadowSupported() : CXTPFrameShadow, CXTPFrameShadowManager
  • IsShellVersion5() : CXTPTrayIcon
  • IsShortcutBarMinimized() : CXTPShortcutBar
  • IsShortcutItemTruncated() : CXTPShortcutBarPaintManager
  • IsShowActiveItemOnTop() : CXTPShortcutBar
  • IsShowAllDayEventsDownScrollButton() : CXTPCalendarDayViewGroup
  • IsShowAllDayEventsUpScrollButton() : CXTPCalendarDayViewGroup
  • IsShowBorders() : CXTPControlGallery
  • IsShowCaptionBar() : CXTPCalendarControlView
  • IsShowDockingContextStickers() : CXTPDockingPaneManager
  • IsShowEndTime() : CXTPCalendarMonthViewEvent, CXTPCalendarWeekViewEvent
  • IsShowIconWhenEditing() : CXTPGridControl
  • IsShowInFieldChooser() : CXTPGridColumn
  • IsShowingToolTip() : CXTPCalendarViewEvent
  • IsShowInTaskBar() : CXTPCalendarRemindersDialog
  • IsShowItemsInGroups() : CXTPGridHeader
  • IsShownAsButton() : CXTPControlGallery
  • IsShowRowNumber() : CXTPGridControl
  • IsShowTitleAndDescription() : CXTPToolTipContext
  • IsShowWYSIWYGMarkers() : CXTPGridPaintManager
  • IsSideDockingEnabled() : CXTPDockingPaneManager
  • IsSidePanel() : CXTPDockingPane
  • IsSignaled() : CXTPSimpleEvent
  • IsSimpleButton() : CXTPRibbonControlSystemButton
  • IsSingleEventSelected() : CXTPCalendarView
  • IsSingleSelection() : CXTPShortcutBar, CXTPTaskPanel
  • IsSkipGroupsFocusEnabled() : CXTPGridControl
  • IsSkippingAntialiasing() : CXTPChart3dDeviceContext
  • IsSlider() : CXTPScrollBase
  • IsSmooth() : CXTPMarqueeCtrl
  • IsSortable() : CXTPGridColumn
  • IsSorted() : CXTPGridColumn
  • IsSortedDecreasing() : CXTPGridColumn
  • IsSortedIncreasing() : CXTPGridColumn
  • IsSortRecordChilds() : CXTPGridControl
  • IsSound() : CXTPCalendarEvent
  • IsSpecialGroup() : CXTPTaskPanelGroup
  • IsSpinButtonsVisible() : CXTPControlEdit
  • IsSplittersLocked() : CXTPDockingPaneManager
  • IsSplitterTrackerUsed() : CXTPDockingPaneManager, CXTPTabClientWnd
  • IsStandardValue() : CXTPCalendarThemeCustomizableXValueT< _TValue, _TValueRef >, CXTPCalendarViewPartCustomizableValueT< _TValue >, CXTPPaintManagerColor
  • IsStar() : CXTPMarkupGridLength
  • IsStateType() : CXTPGaugeCtrl
  • IsStickyFloatingFrames() : CXTPDockingPaneManager
  • IsStoring() : CXTPPropExchange
  • IsStrType() : CXTPSyntaxEditLexVariant
  • IsStyleDiagram() : CXTPChart3dFunnelSeriesStyle, CXTPChart3dPyramidSeriesStyle, CXTPChartDiagram2DSeriesStyle, CXTPChartFunnelSeriesStyle, CXTPChartFunnelSeriesStyleBase, CXTPChartPieSeriesStyleBase, CXTPChartPyramidSeriesStyle, CXTPChartPyramidSeriesStyleBase, CXTPChartRadarDiagramSeriesStyle, CXTPChartSeriesStyle
  • IsSuspended() : CXTPSkinManager
  • IsSvgImage() : CXTPImageManagerVectorImageHandle
  • IsSwitchViewButtons() : CXTPCalendarCaptionBarTheme
  • IsTabsVisible() : CXTPDockingPane, CXTPDockingPaneTabbedContainer, CXTPRibbonBar
  • IsTearOffPopup() : CXTPPopupBar
  • IsTemporary() : CXTPControl, CXTPToolBar
  • IsTextBelowIcons() : CXTPCommandBar
  • IsTextControl() : CXTPHyperLink
  • IsTextCRLF() : CXTPSyntaxEditBufferManager
  • IsTextInColor() : CXTPColorPicker
  • IsTextOutOfBorders() : CXTPCalendarViewEvent
  • IsTextShown() : CXTPColorPicker
  • IsThemeActive() : CXTPWinThemeWrapper
  • IsThemeBackgroundPartiallyTransparent() : CXTPWinThemeWrapper
  • IsThemed() : CXTPDockingPaneMiniWnd
  • IsThemeDark() : CXTPTreeTheme
  • IsThemeDialogTextureEnabled() : CXTPWinThemeWrapper
  • IsThemeEnabled() : CXTPCalendarPaintManager, CXTPCommandBarsNativeXPTheme
  • IsThemePartDefined() : CXTPWinThemeWrapper
  • IsThemeValid() : CXTPHeaderCtrl
  • IsThreeState() : CXTPMarkupToggleButton
  • IsTimeAsClock() : CXTPCalendarMonthViewEvent, CXTPCalendarWeekViewEvent
  • IsTimelineEnable() : CXTPCalendarCaptionBarControl
  • IsTipEnabled() : CXTPTagCloudCtrl
  • IsTitleVisible() : CXTPDockingPaneTabbedContainer
  • IsToday() : CXTPCalendarControl, CXTPDatePickerItemDay
  • IsTodayButtonVisible() : CXTPDatePickerControl
  • IsTodayVisible() : CXTPCalendarView
  • IsToolTipsEnabled() : CXTPCalendarControl
  • IsToolTipVisible() : CXTPCalendarControl
  • IsTop() : CXTPTabBaseTheme
  • IsTopLevelClass() : CXTPSyntaxEditPropertiesPageColor
  • IsTopParentActive() : CXTPMouseManager
  • IsTorus() : CXTPChart3dPieSeriesStyle
  • IsTrackedLock() : CXTPMouseManager
  • IsTrackingMode() : CXTPCommandBar
  • IsTransparent() : CXTPControl, CXTPControlGallery, CXTPRibbonControlSystemPopupBarButton
  • IsTreeColumn() : CXTPGridColumn
  • IsType() : CXTPGaugeCtrl
  • IsUndefinedIcon() : CXTPImageManagerIcon
  • IsUnderline() : CXTPPopupItem
  • IsUpAllDayEventsScrollButtonVisible() : CXTPCalendarDayViewGroup
  • IsUseDropMarker() : CXTPGridPaintManager
  • IsUseMask() : CXTPGridColumn
  • IsUseOneLine() : CXTPCalendarCaptionBarControl
  • IsUseResourceFileLocale() : CXTPChartNumberFormat, CXTPGridControlLocale
  • IsUserLayout() : CXTPDockingPaneLayout
  • IsUserListColor() : CXTPListBase
  • IsUserRowColor() : CXTPListBase
  • IsUserSortColor() : CXTPListBase
  • IsUseSystemAccentColorEnabled() : CXTPFramePaintManager, CXTPPaintManager
  • IsValid() : CXTPChart3dBox, CXTPDockingPane, CXTPDockingPaneLayout, CXTPResourceImages, CXTPThreadLocal< T >, XTP_CALENDAR_MONTHVIEW_DAYPOS, XTP_CALENDAR_VIEWSELECTION
  • IsValidColor() : CXTPColorHex
  • IsValidData() : XTP_EDIT_LINECOL
  • IsValueChanged() : CXTPPropertyGridItem
  • IsValuesAxis() : CXTPChartAxis, CXTPChartAxisX, CXTPChartAxisY, CXTPChartRadarAxisX, CXTPChartRadarAxisY
  • IsVectorIcon() : CXTPImageManagerIcon
  • IsVerbsVisible() : CXTPPropertyGrid
  • IsVerificiationChecked() : CXTPTaskDialog
  • IsVert() : CXTPTabBaseTheme
  • IsVertical() : CXTPChartAxis, CXTPChartAxisX, CXTPChartAxisY, CXTPChartDiagram2DAxisView, CXTPChartRadarAxisX, CXTPChartRadarAxisY, CXTPMarqueeCtrl, CXTPSpinButtonCtrl
  • IsVerticalPosition() : CXTPDockBar
  • IsViewOnly() : CXTPSyntaxEditCtrl
  • IsVirtualMode() : CXTPGridControl, CXTPGridSection
  • IsVisible() : CXTPCalendarCaptionBarThemePart, CXTPCalendarDayViewEvent, CXTPCalendarMonthViewEvent, CXTPCalendarTimeLineViewEvent, CXTPCalendarViewEvent, CXTPCalendarWeekViewEvent, CXTPChartAxis, CXTPChartAxisConstantLine, CXTPChartAxisGridLines, CXTPChartAxisLabel, CXTPChartAxisStrip, CXTPChartAxisTickMarks, CXTPChartAxisTitle, CXTPChartBorder, CXTPChartLegend, CXTPChartSeries, CXTPChartSeriesLabel, CXTPChartTitle, CXTPCommandBar, CXTPControl, CXTPControlAction, CXTPDatePickerItemDay, CXTPDockingPaneCaptionButton, CXTPFlowGraphNode, CXTPGridColumn, CXTPGridRecord, CXTPGridRow, CXTPGridSection, CXTPMarkupUIElement, CXTPMarkupVisual, CXTPPopupBar, CXTPPropertyGridItem, CXTPRibbonGroup, CXTPShortcutBarItem, CXTPStatusBarPane, CXTPTabManagerItem, CXTPTabManagerNavigateButton, CXTPTaskPanelItem, CXTPTaskPanelScrollButton, CXTPToolBar
  • IsVisibleEx() : CXTPCalendarDayViewEvent
  • IsVScrollEnabled() : CXTPCalendarView
  • IsWin10OrGreater() : CXTPSystemVersion
  • IsWin11OrGreater() : CXTPSystemVersion
  • IsWin2K() : CXTPSystemVersion
  • IsWin2KOrGreater() : CXTPSystemVersion
  • IsWin31() : CXTPSystemVersion
  • IsWin31OrGreater() : CXTPSystemVersion
  • IsWin7OrGreater() : CXTPSystemVersion
  • IsWin81OrGreater() : CXTPSystemVersion
  • IsWin8OrGreater() : CXTPSystemVersion
  • IsWin95() : CXTPSystemVersion
  • IsWin95OrGreater() : CXTPSystemVersion
  • IsWin98() : CXTPSystemVersion
  • IsWin98OrGreater() : CXTPSystemVersion
  • IsWin9x() : CXTPCalendarUtils, CXTPSkinManager, CXTPSystemVersion
  • IsWindowVisible() : CXTPToolBar
  • IsWinME() : CXTPSystemVersion
  • IsWinMEOrGreater() : CXTPSystemVersion
  • IsWinNT4() : CXTPSystemVersion
  • IsWinNT4OrGreater() : CXTPSystemVersion
  • IsWinVistaOrGreater() : CXTPSystemVersion
  • IsWinXP() : CXTPSystemVersion
  • IsWinXPOrGreater() : CXTPSystemVersion
  • IsWizard() : CXTPResizePropertySheet
  • IsWordSelectionMode() : CXTPSyntaxEditSelection
  • IsWorkDateTime() : CXTPCalendarDayViewGroup
  • IsWorkspaceCommandEnabled() : CXTPTabClientWnd
  • IsXMLSupported() : CXTPPropExchangeXMLNode
  • IsZero() : CXTPPoint2T< T >, CXTPPoint3T< T >
  • IsZeroTime() : CXTPCalendarUtils
  • ItemFromPoint() : CXTPPropertyGridView
  • itemMDIFrame : CXTPDockingPaneWindowSelect
  • itemPane : CXTPDockingPaneWindowSelect
  • ItemPressed() : CXTPHeaderCtrl
  • itemSDIFrame : CXTPDockingPaneWindowSelect
  • ItemType : CXTPDockingPaneWindowSelect
  • iVal : CXTPSkinManagerSchemaProperty


Toolkit Pro: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- k -

  • keyboardCuesUse : CXTPCommandBarsOptions
  • KillChildWindow() : CXTPCaption
  • KillTimer() : CXTPCalendarView, CXTPCalendarViewDay, CXTPCalendarViewEvent, CXTPCalendarViewGroup, CXTPTrayIcon


Toolkit Pro: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- l -

  • Layout() : CXTPHeaderCtrlTheme, CXTPHeaderCtrlThemeExplorer, CXTPHeaderCtrlThemeOffice2003
  • lcEnd : XTP_EDIT_ROWSBLOCK
  • LCPosAdd() : CXTPSyntaxEditTextIterator
  • LCPosDec() : CXTPSyntaxEditTextIterator
  • lcStart : XTP_EDIT_ROWSBLOCK
  • Leave() : CXTPSimpleCriticalSection
  • LeaveCritical() : CXTPCriticalSection
  • left : XTP_RESIZERECT
  • lf : XTP_EDIT_TEXTBLOCK
  • lfVal : CXTPSkinManagerSchemaProperty
  • lg : CXTPColorHex::CRgnCell::CTX_DATA
  • LightAmbientColor : CXTPChartDiagram3DAppearance
  • LightColor() : CXTPColorManager
  • LightDiffuseColor : CXTPChartDiagram3DAppearance
  • LightModelAmbientColor : CXTPChartDiagram3DAppearance
  • LightSpecularColor : CXTPChartDiagram3DAppearance
  • LimitDataSize() : CXTPSyntaxEditUndoRedoManager
  • Line() : CXTPDockingPanePaintManager, CXTPPaintManager, CXTPShortcutBarOffice2000Theme, CXTPShortcutBarPaintManager
  • ListViewCompareProc() : CXTPShellPidl
  • Load() : CXTPCalendarReminderForOccurrenceArray, CXTPDockingPaneLayout, CXTPGaugeCtrl, CXTPMarkupDeviceDependentImage, CXTPMarkupGdiImage, CXTPMarkupGdiPlusImage, CXTPMemFile, CXTPSvgImage, CXTPSyntaxEditBufferManager, CXTPSyntaxEditColorTheme
  • LoadAlphaBitmap() : CXTPImageManagerIcon
  • LoadAlphaIcon() : CXTPImageManagerIcon
  • LoadAppearance() : CXTPChartAppearance
  • LoadBarState() : CXTPCommandBars
  • LoadBitmap() : CXTPResourceImages, CXTPResourceManager
  • LoadBitmapFromFile() : CXTPImageManagerIcon
  • LoadBitmapFromResource() : CXTPImageManagerIcon
  • LoadCfg() : CXTPCalendarResourcesManager
  • LoadClassSchema() : CXTPSyntaxEditLexTextSchema
  • LoadCode() : CXTPActiveScriptEngine
  • LoadColumnWidths() : CXTPListBase
  • LoadCommandBars() : CXTPCommandBarsSiteBase< TBase >
  • LoadCursor() : CXTPResourceManager
  • LoadDesignerBars() : CXTPCommandBars
  • LoadDialogTemplate() : CXTPResourceManager, CXTPResourceManagerXML
  • LoadDialogTemplate2() : CXTPResourceManager
  • LoadFile() : CXTPResourceImage, CXTPResourceImages, CXTPSkinImage, CXTPSkinImages
  • LoadFromEncodedString() : CXTPPropExchangeXMLNode
  • LoadFromFile() : CXTPDockingPaneLayout, CXTPFlowGraphImage, CXTPGraphicBitmapPng, CXTPPropExchangeIniFile, CXTPPropExchangeXMLNode
  • LoadFromNode() : CXTPDockingPaneLayout
  • LoadFromResource() : CXTPFlowGraphImage, CXTPGraphicBitmapPng, CXTPPropExchangeXMLNode
  • LoadFromString() : CXTPCalendarUIntArray, CXTPPropExchangeXMLNode, CXTPSyntaxEditColorTheme
  • LoadFromXML() : CXTPCalendarCustomProperties
  • LoadGlyphs() : CXTPGridPaintManager, CXTPGridThemeOffice2013, CXTPGridThemeVisualStudio2012Blue, CXTPGridThemeVisualStudio2012Dark, CXTPGridThemeVisualStudio2012Light, CXTPTrackThemeOffice2013, CXTPTrackThemeVisualStudio2012Blue, CXTPTrackThemeVisualStudio2012Dark, CXTPTrackThemeVisualStudio2012Light
  • LoadHistory() : CXTPSyntaxEditFindReplaceDlg
  • LoadHTML() : CXTPResourceManager
  • LoadHtml() : CXTPWebBrowserCtrl
  • LoadIcon() : CXTPResourceManager
  • LoadImage() : CXTPFramePaintManager, CXTPResourceImages, CXTPResourceTheme, CXTPRibbonPaintManager, CXTPScrollBarThemeResource, CXTPSkinManagerResourceFile
  • LoadLibrary() : CXTPModuleHandle
  • LoadMenu() : CXTPCommandBar, CXTPControls, CXTPResourceManager, CXTPResourceManagerXML
  • LoadMenuBar() : CXTPMenuBar
  • LoadMeterType() : CXTPGaugeCtrl
  • LoadModernToolbarIcons() : CXTPCommandBarsOffice2003Theme
  • LoadOptions() : CXTPCommandBars
  • LoadPalette() : CXTPChartAppearance
  • LoadPart() : CXTPMarkupThemePart
  • LoadParts() : CXTPFrameThemeOffice2007System, CXTPRibbonMarkupFrameTheme, CXTPRibbonMarkupTheme, CXTPRibbonOffice2013Theme, CXTPRibbonThemeOffice2007System
  • LoadPlacement() : CXTPPropertySheet, CXTPResize
  • LoadPos() : CXTPSyntaxEditGoToLineDlg
  • LoadProperties() : CXTPResourceImages
  • LoadScriptCodeChunk() : CXTPMarkupContext
  • LoadShortcuts() : CXTPShortcutManager
  • LoadSkin() : CXTPSkinManager
  • LoadState() : CXTPDockState, CXTPReBar, CXTPShortcutBar, CXTPStatusBar, CXTPTabClientWnd
  • LoadStateType() : CXTPGaugeCtrl
  • LoadString() : CXTPCalendarUtils, CXTPResourceManager, CXTPResourceManagerXML
  • LoadString2() : CXTPCalendarUtils
  • LoadSVG() : CXTPResourceManager
  • LoadSysCursors() : CXTPAuxData
  • LoadSysFonts() : CXTPAuxData
  • LoadTextScheme() : CXTPSyntaxEditTextSchemesManager
  • LoadTextStringScheme() : CXTPSyntaxEditTextSchemesManager
  • LoadTheme() : CXTPSyntaxEditColorThemesManager
  • LoadThemeFromString() : CXTPSyntaxEditColorThemesManager
  • LoadToolBar() : CXTPCommandBar, CXTPResourceManager, CXTPRibbonGroup, CXTPToolBar
  • LoadWindowPos() : CXTPWindowPos
  • LoadXAML() : CXTPResourceManager
  • LoadXamlTemplate() : CXTPFlowGraphControl
  • Lock() : CXTPNotifyConnection::CEmptySyncObject
  • LockDivider() : CXTPPropertyGridView
  • LockExclusive() : CXTPRWCriticalSection
  • LockExpand() : CXTPGridControl, CXTPGridRow
  • LockInput() : CXTPKeyboardManager
  • LockMouseMove() : CXTPCommandBar, CXTPMouseManager
  • LockRedraw() : CXTPCommandBar
  • LockShared() : CXTPRWCriticalSection
  • LockSplitters() : CXTPDockingPaneManager
  • LockThread() : CXTPLockGuard
  • logfont : CXTPTreeBase::CLRFONT
  • Lookup() : CXTPCommandBarList, CXTPHookManager, CXTPImageManager, CXTPImageManagerImageList, CXTPListBase, CXTPSkinManager, CXTPSkinObjectClassMap
  • LookUpColor() : CXTPColorSelectorCtrl
  • LowercaseSelection() : CXTPSyntaxEditCtrl
  • lParam : CXTPListBase::ROWCOLOR, XTP_EDIT_NMHDR_PARSEEVENT
  • lpcstrCaption : XTP_COMMANDBARS_CREATEBAR
  • LPFNANIMATION : CXTPAnimationDC
  • LPFNUPDATELAYEREDWINDOW : CXTPMiniToolBar
  • lpi : XTP_LVITEMDATA, XTP_TVITEMDATA
  • lpifq : XTP_TVITEMDATA
  • lpName : XTP_URI
  • lpsfParent : XTP_LVITEMDATA, XTP_TVITEMDATA
  • lpszCaption : XTP_RESOURCEMANAGER_LANGINFO
  • lpszEncoding : XTP_RESOURCEMANAGER_LANGINFO
  • lpszLang : XTP_RESOURCEMANAGER_LANGINFO
  • lpszSubLang : XTP_RESOURCEMANAGER_LANGINFO
  • lpszVal : CXTPSkinManagerSchemaProperty
  • lpType : XTP_URI, XTP_URI_DEFAULTS


Toolkit Pro: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- m -

  • m_Across : CXTPPreviewView
  • m_afterCloseTabPosition : CXTPTabClientWnd
  • m_Alignment : CXTPGridRecordItem, CXTPGridRecordItemControl
  • m_anchorBounds : CXTPChartPieBase
  • m_aPageStart : CXTPSyntaxEditView
  • m_ar : CXTPPropExchangeArchive
  • m_arActiveReminders : CXTPCalendarRemindersDialog, CXTPCalendarRemindersManager
  • m_arBuffer : CXTPSyntaxEditTextIterator
  • m_arBusyStatusBrushes : CXTPCalendarPaintManager
  • m_arButton : CXTPEditListBoxToolBar
  • m_arCells : CXTPColorSelectorCtrl
  • m_arChecked : CXTPCalendarEventCategoryComboBox, CXTPCalendarEventColorListBox
  • m_arClipRect : CXTPEditListBoxToolBar
  • m_arColHeaderText : CXTPCalendarMonthView::CMonthViewGrid
  • m_arCollapsedTextRows : CXTPSyntaxEditCtrl
  • m_arColsLeftX : CXTPCalendarMonthView::CMonthViewGrid
  • m_arContentItems : CXTPShortcutListBox
  • m_arData : CXTPSyntaxEditCtrl::CAverageVal
  • m_arDataProviders : CXTPCalendarResourcesManager
  • m_arDayOfWeekNames : CXTPDatePickerControl
  • m_arDays : CXTPCalendarView
  • m_arElements : CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE >, CXTPCalendarPtrCollectionT< _TObject >
  • m_arEndSeps : CXTPSyntaxEditLexTokensDef
  • m_arEvents : CXTPCalendarEvents, CXTPCalendarViewGroup
  • m_arFrozenCols : CXTPHeaderCtrl
  • m_arHideCtrls : CXTPSearchOptionsCtrl
  • m_arMDIChildern : CXTPMDIWndTab
  • m_arMonthNames : CXTPDatePickerControl
  • m_arMoveCtrls : CXTPSearchOptionsCtrl
  • m_arOnScreenSchCache : CXTPSyntaxEditCtrl
  • m_arPersistentModuleCache : CXTPSkinManager
  • m_arrAccels : CXTPShortcutManagerAccelTable
  • m_arrACData : CXTPSyntaxEditAutoCompleteWnd
  • m_arrACDataFiltered : CXTPSyntaxEditAutoCompleteWnd
  • m_arrActions : CXTPControlActions
  • m_arrAlloc : CXTPImageManagerResource
  • m_arrBars : CXTPCommandBarList, CXTPCommandBars, CXTPDockBar
  • m_arrBlocks : CXTPTrackControlItem
  • m_arrButtons : CXTPDatePickerControl, CXTPMessageBar, CXTPPropertySheet, CXTPSkinObjectFrame, CXTPTabManagerNavigateButtons, CXTPTaskDialog
  • m_arrCategories : CXTPCustomizeCommandsPage, CXTPCustomizeKeyboardPage, CXTPRibbonCustomizePage, CXTPRibbonCustomizeQuickAccessPage
  • m_arrChildren : CXTPChartDeviceCommand, CXTPChartElementView
  • m_arrColor : CXTPDockingPanePaintManager, CXTPPaintManager
  • m_arrColumns : CXTPGridColumnOrder, CXTPGridColumns
  • m_arrCommandButtons : CXTPTaskDialogClient
  • m_arrConnectionPoints : CXTPFlowGraphConnectionPoints
  • m_arrConnections : CXTPFlowGraphConnections, CXTPNotifyConnection
  • m_arrConstraints : CXTPGridRecordItemConstraints
  • m_arrControls : CXTPControlAction, CXTPControls, CXTPPropertyGridInplaceControls, CXTPRibbonGroup
  • m_arrDays : CXTPDatePickerItemMonth
  • m_arrDragBlocks : CXTPTrackControl
  • m_arRecentColors : CXTPColorSelectorCtrl
  • m_arrElements : CXTPChartElementCollection
  • m_arrEntries : CXTPChartPalette
  • m_arResizeWnd : CXTPSearchOptionsView
  • m_arResources : CXTPCalendarResourcesManager
  • m_arrFilters : CXTPSkinManager
  • m_arrFrameRegions : CXTPSkinManagerSchema
  • m_arrGrid : CXTPSyntaxEditAutoCompleteWnd
  • m_arrGroups : CXTPFlowGraphNodeGroups, CXTPRibbonGroups
  • m_arrGroupStack : CXTPFlowGraphUndoManager
  • m_arrIcons : CXTPImageManagerResource
  • m_arrImages : CXTPFlowGraphImages
  • m_arrItems : CXTPChartLegendView, CXTPControlGalleryItems, CXTPGridRecord, CXTPPopupControl, CXTPResize, CXTPShortcutBar, CXTPShortcutBarPane, CXTPTabManager, CXTPTaskPanelItems
  • m_arrLinkButtons : CXTPTaskDialogClient
  • m_arrLinks : CXTPTaskDialogLinkCtrl
  • m_arrMarkers : CXTPTrackMarkers
  • m_arrMonths : CXTPDatePickerControl
  • m_arrNavigateButtons : CXTPTabManager, CXTPTabManagerItem
  • m_arrNodes : CXTPFlowGraphNodeGroup, CXTPFlowGraphNodes
  • m_arrObservers : CXTPTabPaintManager
  • m_arRowColor : CXTPListBase
  • m_arRowsTopY : CXTPCalendarMonthView::CMonthViewGrid
  • m_arrPageRedo : CXTPFlowGraphPageHistory
  • m_arrPages : CXTPFlowGraphPages, CXTPPropertySheet
  • m_arrPageUndo : CXTPFlowGraphPageHistory
  • m_arrPanes : CXTPStatusBar
  • m_arrRadioButtons : CXTPTaskDialog, CXTPTaskDialogClient
  • m_arrRecords : CXTPGridRecords
  • m_arrRects : CXTPControlGallery
  • m_arrRedoCommands : CXTPFlowGraphUndoManager, CXTPTrackUndoManager
  • m_arrSelectedBlocks : CXTPDatePickerDaysCollection
  • m_arrSelectedElements : CXTPFlowGraphSelectedElements
  • m_arrSendQueueCache : CXTPNotifyConnection
  • m_arrSeries : CXTPChartDiagram
  • m_arrSolidRects : CXTPSkinImage
  • m_arrStyles : CXTPTagCloudStyleManager
  • m_arrSwitches : CXTPStatusBarSwitchPane
  • m_arrTags : CXTPTagCloudCtrl
  • m_arrTagsSorted : CXTPTagCloudCtrl
  • m_arrTicks : CXTPChartDiagram2DAxisView, CXTPChartRadarAxisXView, CXTPChartRadarAxisYView
  • m_arrTips : CXTPTipOfTheDay
  • m_arrTools : CXTPToolTipContextToolTip
  • m_arrUndoCommands : CXTPFlowGraphUndoGroupCommand, CXTPFlowGraphUndoManager, CXTPTrackUndoGroupCommand, CXTPTrackUndoManager
  • m_arrVerbs : CXTPPropertyGridVerbs
  • m_arrWorkspace : CXTPTabClientWnd
  • m_arScheduleIDs : CXTPCalendarResource
  • m_arStandardColors : CXTPColorPicker, CXTPColorSelectorCtrl
  • m_arStartCol : CXTPCalendarPaintManager, CXTPGridPaintManager
  • m_arStartRow : CXTPCalendarPaintManager
  • m_arStartSeps : CXTPSyntaxEditLexTokensDef
  • m_arStrings : CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager, CXTPTipWindow
  • m_arStrVals : CXTPSyntaxEditLexVariant
  • m_arThemeColors : CXTPColorPicker, CXTPColorSelectorCtrl
  • m_arTokens : CXTPSyntaxEditLexTokensDef
  • m_arTrayIcons : CXTPTrayIcon
  • m_arTZInfo : CXTPCalendarTimeZones
  • m_arValidDispRows : CXTPSyntaxEditCtrl
  • m_arViewGroups : CXTPCalendarViewDay
  • m_arWaitingReminders : CXTPCalendarRemindersManager
  • m_aveRedrawScreenTime : CXTPSyntaxEditCtrl
  • m_b3SmallCal : CXTPCalendarControlViewPrintOptions
  • m_bAcceptFocus : CXTPTaskPanel
  • m_bActivated : CXTPMiniToolBar
  • m_bActivateOnFocus : CXTPSyntaxEditCtrl
  • m_bActive : CXTPCommandBarsFrameHook, CXTPDialogBar, CXTPDockingPaneTabbedContainer, CXTPSkinObjectFrame, CXTPSyntaxEditAutoCompleteWnd, CXTPTabManager, CXTPTagCloudCtrl, CXTPToolTipContextToolTip
  • m_bActiveX : CXTPSkinObject
  • m_bAddEvent : CXTPCalendarEventPropertiesDlg
  • m_bAddressIsWide : CXTPHexEdit
  • m_bAdjustLayoutRunning : CXTPGridControl
  • m_bAdjustScrollBars : CXTPFlowGraphControl
  • m_bAdvancedMode : CXTPCalendarTip
  • m_bAlignShortcut : CXTPRibbonControlSystemPopupBarListItem
  • m_bAllDayEvent : CXTPCalendarEvent, CXTPCalendarEventPropertiesDlg
  • m_bAllowAccess : CXTPGridSection
  • m_bAllowApply : CXTPPropertySheet
  • m_bAllowBlockMove : CXTPTrackControl
  • m_bAllowBlockRemove : CXTPTrackControl
  • m_bAllowBlockScale : CXTPTrackControl
  • m_bAllowCollapse : CXTPShortcutBar
  • m_bAllowColumnRemove : CXTPGridHeader
  • m_bAllowColumnReorder : CXTPGridHeader
  • m_bAllowColumnResize : CXTPGridHeader
  • m_bAllowColumnSort : CXTPGridHeader
  • m_bAllowCut : CXTPGridView
  • m_bAllowDeletes : CXTPHexEdit
  • m_bAllowDoubleKeyShortcuts : CXTPShortcutManager
  • m_bAllowDrag : CXTPGridColumn
  • m_bAllowDrop : CXTPTaskPanel, CXTPTaskPanelItem
  • m_bAllowEdit : CXTPGridRecordItemEditOptions, CXTPGridSection, CXTPPropertyGrid
  • m_bAllowEscapeShortcut : CXTPShortcutManager
  • m_bAllowFilter : CXTPGridSection
  • m_bAllowFreeResize : CXTPShortcutBar
  • m_bAllowGroup : CXTPGridSection
  • m_bAllowMergeCells : CXTPGridPaintManager
  • m_bAllowMinimize : CXTPRibbonBar
  • m_bAllowModifyConnections : CXTPFlowGraphControl
  • m_bAllowMove : CXTPPopupControl
  • m_bAllowMoveNodes : CXTPFlowGraphControl
  • m_bAllowNewToolbars : CXTPCustomizeToolbarsPage
  • m_bAllowNoncontinuousSelection : CXTPDatePickerControl
  • m_bAllowPaste : CXTPGridView
  • m_bAllowQuickAccessCustomization : CXTPRibbonBar
  • m_bAllowQuickAccessDuplicates : CXTPRibbonBar
  • m_bAllowRemove : CXTPGridColumn
  • m_bAllowReorder : CXTPTabClientWnd, CXTPTabManager
  • m_bAllowResize : CXTPShortcutBar
  • m_bAllowSort : CXTPGridSection
  • m_bAlpha : CXTPFlowGraphNode, CXTPGraphicBitmapPng, CXTPResourceImage, CXTPSkinImage
  • m_bAlphaDockingContext : CXTPDockingPaneManager
  • m_bAlwaysDrawConnectionPoints : CXTPFlowGraphPaintManager
  • m_bAnimatePopup : CXTPCommandBar
  • m_bAnimation : CXTPScrollBase, CXTPTaskPanel
  • m_bAntiAlias : CXTPChartPolygonAntialiasingDeviceCommand, CXTPChartTextAntialiasingDeviceCommand
  • m_bAntialiasing : CXTPChart3dDeviceContext, CXTPChartAxisConstantLine, CXTPChartAxisLabel, CXTPChartAxisTitle, CXTPChartLegend, CXTPChartSeriesLabel, CXTPChartTitle
  • m_bAppCaption : CXTPCaption
  • m_barPosition : CXTPCommandBar
  • m_bArrangeDirty : CXTPMarkupUIElement
  • m_bArrangeInProgress : CXTPMarkupUIElement
  • m_barType : CXTPCommandBar
  • m_bAsc : CXTPTagCloudCtrl
  • m_bAscending : CXTPHeaderCtrl, CXTPListBase
  • m_bAutoApplyThreads : CXTPSkinManager
  • m_bAutoApplyWindows : CXTPSkinManager
  • m_bAutoArrangeEditCaption : CXTPRibbonGroup
  • m_bAutoCheckItems : CXTPGridControl
  • m_bAutoColumnSizing : CXTPGridHeader
  • m_bAutoComp : CXTPComboBox
  • m_bAutoComplete : CXTPControlComboBox, CXTPPropertyGridItem
  • m_bAutoCondensing : CXTPTabBase
  • m_bAutoDelete : CXTPColorPopup, CXTPItemEdit, CXTPPopupControl, CXTPResizeItem
  • m_bAutoDelete_Custom : CXTPCalendarViewPartCustomizableValueT< _TValue >
  • m_bAutoDelete_Standard : CXTPCalendarViewPartCustomizableValueT< _TValue >
  • m_bAutoDeleteWnd : CXTPStatusBarPane
  • m_bAutoDestroy : CXTPHookManagerHookAble
  • m_bAutoDestroy_Custom : CXTPCalendarThemeCustomizableXValueT< _TValue, _TValueRef >
  • m_bAutoDestroy_Standard : CXTPCalendarThemeCustomizableXValueT< _TValue, _TValueRef >
  • m_bAutoDivider : CXTPPropertyGridView
  • m_bAutoFont : CXTPListBase
  • m_bAutoHeight : CXTPTaskPanelGroupItem
  • m_bAutoIndent : CXTPSyntaxEditOptions
  • m_bAutoInit : CXTPShellTreeCtrl
  • m_bAutoInitialUpdate : CXTPDockingPaneManager
  • m_bAutoNumbering : CXTPGridColumn
  • m_bAutoPopup : CXTPCalendarRemindersDialog
  • m_bAutoReload : CXTPSyntaxEditDoc
  • m_bAutoResample : CXTPImageManager
  • m_bAutoResizeIcons : CXTPPaintManager
  • m_bAutoSave : CXTPListBase
  • m_bAutoScaleDpi : CXTPControlGallery
  • m_bAutoScaleDpiGalleryItems : CXTPCommandBarsOptions
  • m_bAutoScaleDpiToolbarIcons : CXTPCommandBarsOptions
  • m_bAutoSize : CXTPDatePickerControl, CXTPGridColumn, CXTPHeaderCtrl, CXTPMessageBar
  • m_bAutoSortWhenGrouped : CXTPGridColumn
  • m_bAutoTheme : CXTPTabClientWnd
  • m_bAutoUpdateTabCaption : CXTPTabClientWnd
  • m_bBandLabel : CXTPTreeBase
  • m_bBaseTreeIndent : CXTPGridPaintManager
  • m_bBeginGroup : CXTPControl, CXTPStatusBarPane
  • m_bBeingDestructed : CXTPCommandBarsFrameHook
  • m_bBlockSelection : CXTPGridControl
  • m_bBlurPoints : CAppearanceSetPropertyPageFlat
  • m_bBold : CXTPPopupItem, CXTPTaskPanelGroupItem
  • m_bBoldCaption : CXTPTaskPanelPaintManager
  • m_bBoldDaysOnIdle : CXTPCalendarController
  • m_bBoldDaysWithEvents : CXTPCalendarController
  • m_bBoldFont : CXTPTabBase
  • m_bBoldItemCaptionFont : CXTPShortcutBarPaintManager
  • m_bBoldNormal : CXTPTabPaintManager
  • m_bBoldSelected : CXTPTabPaintManager
  • m_bBoldText : CXTPGridRecordItem
  • m_bBorderVisible : CXTPChartMarker
  • m_bBrowsing : CXTPBrowseEdit
  • m_bBuiltIn : CXTPToolBar
  • m_bButton : CXTPPopupItem, CXTPStatusBarPane
  • m_bButtonPressed : CXTPCommandBarsFrameHook
  • m_bButtonsReverseZOrder : CXTPTabPaintManagerTheme
  • m_bCancel : CXTPPropertyGridInplaceEdit
  • m_bCanEditCheckboxItem : CXTPGridRecordItem
  • m_bCaptionCenterAligned : CXTPFramePaintManager
  • m_bCaptionPopup : CXTPDialogBar
  • m_bCaptions : CXTPColorPicker, CXTPColorSelectorCtrl
  • m_bCaptionScrollButton : CXTPTaskPanelPaintManager
  • m_bCaptionVisible : CXTPDialogBar, CXTPTaskPanelGroup
  • m_bCaseSensitive : CXTPGridRecords, CXTPSyntaxEditCtrl
  • m_bCategories : CXTPCalendarEventColorDlg, CXTPCalendarEventColorListBox, CXTPCalendarEventColorNewDlg
  • m_bCategory : CXTPPropertyGridItem
  • m_bCenterHorz : CXTPTipWindow
  • m_bChanged : CXTPDatePickerControl, CXTPGridControl, CXTPMenuBarMDIMenuInfo
  • m_bChangeNodeColorWhenSelected : CXTPFlowGraphPaintManager
  • m_bCheckAutoComplete : CXTPPropertyGridInplaceEdit
  • m_bCheckBoxStyle : CXTPPropertyGridItemBool, CXTPPropertyGridItemOption
  • m_bChecked : CXTPButton, CXTPControl, CXTPControlAction
  • m_bChildSection : CXTPPropExchange
  • m_bClassicStyle : CXTPTipOfTheDay
  • m_bCleanTooltip : CXTPGridPaintManager
  • m_bClearHandles : CXTPImageManagerIconHandle
  • m_bClearTypeTextQuality : CXTPPaintManager, CXTPShortcutBarPaintManager, CXTPTabPaintManager
  • m_bClientPaneVisible : CXTPShortcutBar
  • m_bClipHeader : CXTPTabPaintManager
  • m_bClipItems : CXTPControlGalleryItems
  • m_bClipStyles : CXTPSplitterWnd
  • m_bClosable : CXTPTabManagerItem
  • m_bCloseable : CXTPCommandBar
  • m_bCloseActiveWindow : CXTPDockingPaneAutoHidePanel
  • m_bCloseDataProviderWhenDestroy : CXTPCalendarResource
  • m_bCloseEnabled : CXTPDockingPaneMiniWnd
  • m_bCloseGroupOnButtonClick : CXTPDockingPaneManager
  • m_bCloseItemButton : CXTPTabManager
  • m_bCloseParentKey : CXTPPropExchangeRegistry
  • m_bClosePosted : CXTPItemEdit
  • m_bCloseSubMenuOnClick : CXTPControl
  • m_bCollapsed : CXTPDockingPaneMiniWnd, CXTPDockingPaneSidePanel, CXTPPopupBar
  • m_bColorEach : CXTPChartSeriesStyle
  • m_bColorText : CXTPColorPicker
  • m_bColumnPlusMinusSign : CXTPGridPaintManager
  • m_bColumnWidthWYSIWYG : CXTPGridPaintManager
  • m_bComboBar : CXTPCommandBar
  • m_bCompactMode : CXTPPropExchangeXMLNode
  • m_bCompactText : CXTPGridPaintManager
  • m_bComposited : CXTPCommandBarEditCtrl
  • m_bConfigChangedReparceInSeparateThread : CXTPSyntaxEditLexParserSchemaOptions
  • m_bConfigFileMode : CXTPSyntaxEditConfigurationManager, CXTPSyntaxEditCtrl
  • m_bConnectorVisible : CXTPChart3dFunnelSeriesLabelView, CXTPChart3dPieSeriesLabelView, CXTPChart3dPyramidSeriesLabelView
  • m_bConstraintEdit : CXTPGridRecordItemEditOptions, CXTPPropertyGridItem
  • m_bContextMenu : CXTPPopupBar, CXTPShellListBase, CXTPShellTreeBase
  • m_bContextMenuPresent : CXTPToolBar
  • m_bControlsCentering : CXTPRibbonGroup
  • m_bControlsGrouping : CXTPRibbonGroup
  • m_bControlVisible : CXTPControlCustom
  • m_bCreated : CXTPGridControl, CXTPPropertyGridInplaceEdit
  • m_bCreateScrollbarOnParent : CXTPFlowGraphControl, CXTPSyntaxEditCtrl
  • m_bCrossAxis : CXTPChartAxisTickMarks
  • m_bCustomizable : CXTPCommandBar, CXTPStatusBar, CXTPStatusBarPane
  • m_bCustomizeAvail : CXTPCommandBars
  • m_bCustomizeDialogPresent : CXTPCommandBar
  • m_bCustomizeMode : CXTPCommandBars
  • m_bDarkTheme : CXTPTreeTheme
  • m_bDefaultItem : CXTPControl
  • m_bDefaultResetCustomizedToolbarChoice : CXTPCommandBars
  • m_bDefaultResetCustomizedToolbarChoiceEnabled : CXTPCommandBars
  • m_bDefaultValues : CXTPCalendarEventCategories, CXTPCalendarEventLabels
  • m_bDefMenuItemByPos : CXTPTrayIcon
  • m_bDelayCreate : CXTPPropertyGridInplaceEdit
  • m_bDelayDestroy : CXTPControlComboBox, CXTPControlEdit
  • m_bDelayInvalidate : CXTPDockingPaneMiniWnd
  • m_bDelayLock : CXTPTabClientWnd
  • m_bDelayReclalcLayout : CXTPCommandBarsFrameHook
  • m_bDelayRedraw : CXTPDockingPaneTabbedContainer
  • m_bDelayReposition : CXTPControlComboBox, CXTPControlEdit
  • m_bDelayTimerRunning : CXTPTipWindow
  • m_bDeleteOcurrenceEventIfNoPrompt : CXTPCalendarControl
  • m_bDeleteOnFinalRelease : CXTPCalendarControl, CXTPDatePickerControl
  • m_bDesignerMode : CXTPCommandBars
  • m_bDesktopTrackerMode : CXTPGridControl
  • m_bDestroyCustomTitleBrushes : CXTPDockingPanePaintManager
  • m_bDF_mode : CXTPCalendarControlView, CXTPCalendarDayView
  • m_bDirectionClockwise : CXTPChartRadarAxisX
  • m_bDirty : CXTPFlowGraphElement
  • m_bDisableAC : CXTPComboBox
  • m_bDisableNotificationsSending : CXTPCalendarData
  • m_bDisableOnCapture : CXTPShortcutManager
  • m_bDisableRedraw : CXTPCalendarControl, CXTPSyntaxEditCtrl
  • m_bDisableRemove : CXTPCalendarEventRecurrenceDlg
  • m_bDisplayShadow : CXTPColorPopup
  • m_bDocCreated : CXTPSyntaxEditDoc
  • m_bDoDefaultItemDrawing : CXTPTreeBase
  • m_bDotTracker : CXTPSplitterWnd
  • m_bDoubleBuffering : CXTPGridControl
  • m_bDoubleGripper : CXTPPopupBar
  • m_bDoubleHighlightedBorder : CAppearanceSetPropertyPage2003
  • m_bDoughnut : CXTPChartPieDeviceCommandImpl
  • m_bDpiBitmapScaling : CXTPHeaderCtrl
  • m_bDpiBitmapScalingModified : CXTPHeaderCtrl
  • m_bDraftMode : CXTPCalendarDayView, CXTPCalendarMonthView
  • m_bDragable : CXTPCustomizeCommandsListBox
  • m_bDragging : CXTPSyntaxEditCtrl, CXTPTrackBlock
  • m_bDraggingOver : CXTPSyntaxEditView
  • m_bDraggingStartedHere : CXTPSyntaxEditView
  • m_bDragGroupBox : CXTPGridHeader
  • m_bDragHeader : CXTPGridHeader
  • m_bDragKeyboard : CXTPDockingPaneContext
  • m_bDragMode : CXTPGridControl
  • m_bDrawCaptionIcon : CXTPDockingPanePaintManager
  • m_bDrawComposited : CXTPImageManagerIcon
  • m_bDrawDisabledText : CXTPStatusBar
  • m_bDrawFocusRect : CXTPTabPaintManager, CXTPTaskPanel, CXTPTreeTheme
  • m_bDrawFooterDivider : CXTPGridColumn
  • m_bDrawFooterRowsVGrid : CXTPGridColumn
  • m_bDrawGridForEmptySpace : CXTPGridPaintManager
  • m_bDrawGripper : CXTPDockingPaneOffice2003Theme
  • m_bDrawHeaderDivider : CXTPGridColumn
  • m_bDrawHeaderRowsVGrid : CXTPGridColumn
  • m_bDrawNodes : CXTPSyntaxEditOptions
  • m_bDrawNowLine : CXTPCalendarDayViewTimeScale
  • m_bDrawSingleTab : CXTPDockingPanePaintManager
  • m_bDrawTextEndEllipsis : CXTPTabPaintManager
  • m_bDrawTextHidePrefix : CXTPTabPaintManager
  • m_bDrawTextNoPrefix : CXTPTabPaintManager
  • m_bDrawTextPathEllipsis : CXTPTabPaintManager
  • m_bDropDown : CXTPControlComboBox
  • m_bDroppable : CXTPSyntaxEditCtrl
  • m_bDwmEnabled : CXTPCommandBarsFrameHook
  • m_bDynamicBPR : CXTPHexEdit
  • m_bDynamicLayout : CXTPPopupBar
  • m_bEcoAllDayMode : CXTPCalendarDayView
  • m_bEditable : CXTPGridColumn, CXTPGridRecord, CXTPGridRecordItem
  • m_bEditChanged : CXTPControlComboBox, CXTPControlEdit
  • m_bEditMode : CXTPPropertyGridInplaceEdit
  • m_bEditOnClick : CXTPGridControl
  • m_bEditOnDelayClick : CXTPGridControl
  • m_bEditOnDoubleClick : CXTPGridControl
  • m_bEditReparceInSeparateThread : CXTPSyntaxEditLexParserSchemaOptions
  • m_bEmbossedDisabledText : CXTPPaintManager, CXTPTaskPanelPaintManager
  • m_bEmptySection : CXTPPropExchange
  • m_bEmulateEplorerTheme : CXTPTaskPanelPaintManager
  • m_bEnableActions : CXTPCommandBars
  • m_bEnableAnimation : CXTPPaintManager
  • m_bEnabled : CXTPCalendarResourceDescription, CXTPCommandBarKeyboardTip, CXTPControl, CXTPControlAction, CXTPControlGalleryItem, CXTPDockingPane, CXTPExcelTabCtrlButtonState, CXTPFlowGraphUndoManager, CXTPGridRecordItemControl, CXTPPropertyGridItemConstraint, CXTPShortcutBarItem, CXTPShortcutListBox::CONTENT_ITEM, CXTPSkinManager, CXTPTabManagerItem, CXTPTabManagerNavigateButton, CXTPTaskPanelItem
  • m_bEnableEdit : CXTPEditListBox, CXTPEditListBoxToolBar
  • m_bEnableEditAccelerators : CXTPSyntaxEditOptions
  • m_bEnableGroups : CXTPTabClientWnd
  • m_bEnableLunaBlueForAeroTheme : CXTPColorManager
  • m_bEnableLunaBlueForRoyaleTheme : CXTPColorManager
  • m_bEnableMarkup : CXTPButton, CXTPComboBox, CXTPTaskDialogClient
  • m_bEnableMenus : CXTPHeaderCtrl
  • m_bEnableOleDrag : CXTPSyntaxEditCtrl
  • m_bEnableTheme : CXTPCalendarPaintManager, CXTPDatePickerPaintManager
  • m_bEnableTooltips : CXTPPropertyGrid
  • m_bEnableWhiteSpace : CXTPSyntaxEditOptions
  • m_bEndByParent : CXTPSyntaxEditLexTextBlock
  • m_bEnsureFocusedRowVisible : CXTPGridControl
  • m_bEnsureSelectedTab : CXTPDockingPaneTabbedContainer
  • m_bEOF : CXTPSyntaxEditTextIterator
  • m_bEscapeKey : CXTPFlowGraphEditItem, CXTPItemEdit
  • m_bEventVisible : CXTPCalendarEvent
  • m_bExecOnRButton : CXTPCommandBar
  • m_bExpandable : CXTPPropertyGridItem, CXTPShortcutBarPaneItem, CXTPTaskPanel, CXTPTaskPanelGroup
  • m_bExpandButton : CXTPShortcutBarItem
  • m_bExpandDOWN : CXTPCalendarDayViewGroup
  • m_bExpanded : CXTPControl, CXTPDockingPaneMiniWnd, CXTPDockingPaneSidePanel, CXTPGridColumn, CXTPGridRecord, CXTPGridRow, CXTPPopupBar, CXTPPropertyGridItem, CXTPSearchOptionsCtrl, CXTPShortcutBarItem, CXTPShortcutBarPaneItem, CXTPTaskDialogClient, CXTPTaskPanelGroup
  • m_bExpanding : CXTPPopupBar, CXTPTaskPanelGroup
  • m_bExpandOnSelect : CXTPGridRecordItemEditOptions
  • m_bExpandUP : CXTPCalendarDayViewGroup
  • m_bExplicit : CXTPCommandBarKeyboardTip
  • m_bExplorerStyle : CXTPShellTreeBase
  • m_bExplorerTheme : CXTPTaskPanelExplorerTheme, CXTPTaskPanelExplorerThemePlain, CXTPTreeBase
  • m_bFastDeselectMode : CXTPGridControl
  • m_bFilesDragging : CXTPSyntaxEditView
  • m_bFillBackground : CXTPTabPaintManager
  • m_bFilterable : CXTPGridColumn
  • m_bFiltered : CXTPSkinImage
  • m_bFilteredMode : CXTPSyntaxEditAutoCompleteWnd
  • m_bFilterHiddenColumns : CXTPGridControl
  • m_bFirstParseInSeparateThread : CXTPSyntaxEditLexParserSchemaOptions
  • m_bFixed : CXTPGridColumn
  • m_bFixedBottom : CXTPSyntaxEditAutoCompleteWnd
  • m_bFixedInplaceButtonHeight : CXTPGridPaintManager
  • m_bFixedRowHeight : CXTPGridPaintManager
  • m_bFlatFrame : CXTPFramePaintManager, CXTPRibbonPaintManager
  • m_bFlatMenuBar : CXTPPaintManager
  • m_bFlatMenus : CXTPCommandBarsNativeXPTheme
  • m_bFlatStyle : CXTPButton, CXTPComboBox, CXTPEditTheme, CXTPProgressCtrl
  • m_bFlatToolBar : CXTPPaintManager
  • m_bFlexibleDrag : CXTPTrackControl
  • m_bFlipped : CXTPResourceImage
  • m_bFocusable : CXTPGridRecordItem
  • m_bFocused : CXTPComboBox, CXTPControlComboBox, CXTPControlEdit, CXTPEdit, CXTPRibbonControlTab, CXTPSyntaxEditCtrl
  • m_bFocusRect : CXTPTagCloudCtrl
  • m_bFocusSubItems : CXTPGridControl
  • m_bFooterVisible : CXTPGridControl
  • m_bForceDynamicMarkupForCell : CXTPGridPaintManager
  • m_bForcePagination : CXTPCalendarControl, CXTPGridControl
  • m_bForceRecalc : CXTPControlTabWorkspace
  • m_bForceShowDropMarker : CXTPGridPaintManager
  • m_bForceShowTooltip : CXTPGridPaintManager
  • m_bForceToRecalc : CXTPTabClientWnd
  • m_bFrameStatusBar : CXTPFramePaintManager
  • m_bFreeHeightMode : CXTPGridControl
  • m_bFreeOnRelease : CXTPResourceImages
  • m_bFriday : CXTPCalendarEventRecurrenceDlg
  • m_bFrozen : CXTPGridColumn
  • m_bFullDateMode : CXTPCalendarControl
  • m_bFullDrag : CXTPSplitterWnd
  • m_bGenerateName : CXTPCalendarResourceDescription
  • m_bGrabbingFocus : CXTPTaskPanel
  • m_bGrabFocus : CXTPCommandBar
  • m_bGradientButton : CColorSetVisualStudio2005, CXTPTabColorSetVisualStudio2008, CXTPTabColorSetVisualStudio2010
  • m_bGradientCaption : CXTPDockingPaneVisualStudio2003Theme
  • m_bGrayIfDisable : CXTPGridPaintManager
  • m_bGridSpacingAuto : CXTPChartAxis
  • m_bGroupable : CXTPGridColumn
  • m_bGroupByEnabled : CXTPGridControl
  • m_bGroupInsertMode : CXTPSyntaxEditUndoRedoManager
  • m_bGroupReducedChanged : CXTPRibbonBar
  • m_bGroupRowTextBold : CXTPGridPaintManager
  • m_bGroupsVisible : CXTPRibbonBar
  • m_bHasCheckbox : CXTPGridRecordItem
  • m_bHasSelectedChilds : CXTPGridRow
  • m_bHeaderVisible : CXTPGridControl
  • m_bHelpVisible : CXTPPropertyGrid
  • m_bHidden : CXTPPropertyGridItem, CXTPShortcutBarItem, CXTPTrayIcon
  • m_bHideCaptionBar : CXTPCalendarControl
  • m_bHideCaret : CXTPSyntaxEditOptions
  • m_bHideClient : CXTPDockingPaneManager
  • m_bHideColumnAfterGroupBoxDrop : CXTPGridHeader
  • m_bHideEventTime : CXTPCalendarDayViewEvent
  • m_bHideGroupOnButtonClick : CXTPDockingPaneManager
  • m_bHideLinkContainer : CXTPCalendarControl, CXTPCalendarDayView
  • m_bHideOnFind : CXTPSyntaxEditGoToLineDlg
  • m_bHideSelection : CXTPControlGallery, CXTPGridPaintManager, CXTPPropertyGrid
  • m_bHighLight : CXTPSyntaxEditAutoCompleteWnd
  • m_bHighlight : CXTPDatePickerButton
  • m_bHighlightActiveCaption : CXTPDockingPanePaintManager
  • m_bHighlightChanged : CXTPPropertyGrid
  • m_bHighlightChangedButton : CXTPPropertyGrid
  • m_bHighlighted : CXTPComboBox, CXTPEdit
  • m_bHighlightToday : CXTPDatePickerControl
  • m_bHilight : CXTPExcelTabCtrlButtonState, CXTPShortcutListBox
  • m_bHilightItemID : CXTPShortcutListBox
  • m_bHiliteBorders : CXTPShortcutBarNativeWindows10Theme, CXTPShortcutBarNativeWindows11Theme, CXTPShortcutBarVisualStudio2015Theme, CXTPShortcutBarVisualStudio2017Theme, CXTPShortcutBarVisualStudio2019Theme, CXTPShortcutBarVisualStudio2022Theme
  • m_bHoriz : CXTPDockingPaneSplitterContainer
  • m_bHorizSplitting : CXTPTabClientWnd
  • m_bHorz : CXTPTagCloudCtrl
  • m_bHorzScrollBar : CXTPSyntaxEditCtrl
  • m_bHot : CXTPButton, CXTPMessageBarButton, CXTPSkinObjectButton
  • m_bHotTracking : CXTPGridPaintManager, CXTPTabPaintManager
  • m_bHotTrackingGroups : CXTPRibbonPaintManager
  • m_bHScrollBarVisible : CXTPGridControl
  • m_bHScrollEnabled : CXTPCalendarEventPropertiesDlg
  • m_bHyperLink : CXTPPopupItem
  • m_bIconColumnIndexNotValid : CXTPGridControl
  • m_bIconView : CXTPGridControl
  • m_bIgnoreAutoComplete : CXTPControlComboBox
  • m_bIgnoreEditChanged : CXTPPropertyGridInplaceEdit
  • m_bIgnoreShiftMenuKey : CXTPCommandBars
  • m_bIgnoreUpdateHandler : CXTPCommandBar
  • m_bIgonoreEditChanged : CXTPCommandBarEditCtrl
  • m_bImageDPIScaling : CXTPButton, CXTPToolTipContext
  • m_bImageOrientaionPreserved : CXTPResourceImage
  • m_bImeMode : CXTPCommandBarEditCtrl
  • m_bIMEsupported : CXTPSyntaxEditCtrl
  • m_bInAction : CXTPFlowGraphControl
  • m_bInitControl : CXTPShellListCtrl
  • m_bInitialized : CXTPPropExchange
  • m_bInitialPass : CXTPChart3dDeviceContext
  • m_bInitialSelectionEnable : CXTPGridControl
  • m_bInitialSize : CXTPResizeItem
  • m_bInitialUpdate : CXTPTabExBase
  • m_bInputOutPair : CXTPFlowGraphConnectionPoint
  • m_bInRecalcLayout : CXTPToolBar
  • m_bInsideCell : CXTPGridInplaceButton
  • m_bInterlaced : CXTPChartAxis
  • m_bInternalDrag : CXTPGridControl
  • m_bInternalFrameHook : CXTPCommandBars
  • m_bInternalMove : CXTPGridControl
  • m_bIntersect : CXTPCommandBarsOffice2013Theme
  • m_bInUpdateFrame : CXTPCommandBarsFrameHook
  • m_bInUpdateScrollBar : CXTPTaskPanel
  • m_bInvert : CXTPResourceImage, CXTPSkinImage
  • m_bInvertColumnOnClick : CXTPGridPaintManager
  • m_bInvertDragRect : CXTPTaskPanelPaintManager
  • m_bInvertGradient : CXTPTabPaintManager
  • m_bIs3D : CXTPChartDeviceContext
  • m_bIsActive : CXTPSyntaxEditCtrl
  • m_bIsCaptionBarInBackstageMode : CXTPRibbonBar
  • m_bIsCustomSet : CXTPCalendarThemeCustomizableXValueT< _TValue, _TValueRef >
  • m_bIsDark : CXTPStatusBarPane
  • m_bIsDateLabel : CXTPCalendarCaptionBarTheme
  • m_bIsDragging : CXTPSyntaxEditCtrl
  • m_bIsExpandButton : CXTPCalendarCaptionBarTheme
  • m_bIsGroupBox : CXTPResizeItem
  • m_bIsModal : CXTPDatePickerControl
  • m_bIsOneLine : CXTPCalendarCaptionBarTheme
  • m_bIsParserEnabled : CXTPSyntaxEditBufferManager
  • m_bIsPreviewMode : CXTPGridPaintManager
  • m_bIsResizable : CXTPGridColumn
  • m_bIsScrollDateButtons : CXTPCalendarCaptionBarTheme
  • m_bIsScrollingEndRow : CXTPSyntaxEditCtrl
  • m_bIsSmartIndent : CXTPSyntaxEditCtrl
  • m_bIsStandardSet : CXTPCalendarThemeCustomizableXValueT< _TValue, _TValueRef >
  • m_bIsSubclassed : CXTPMarqueeCtrl
  • m_bIsSwitchViewButtons : CXTPCalendarCaptionBarTheme
  • m_bItemControlUnderMouse : CXTPGridRecordItem
  • m_bitmap : CXTPAnimationDC
  • m_bKeepSelectionAfterSort : CXTPGridControl
  • m_bKeyboardCuesVisible : CXTPCommandBars
  • m_bKeyboardEnabled : CXTPDockingPaneManager
  • m_bKeyboardSelect : CXTPCommandBar
  • m_bKeyboardSelected : CXTPControlGallery
  • m_bLabel : CXTPControlEdit, CXTPControlGalleryItem
  • m_bLastColumnExpand : CXTPGridHeader
  • m_bLastColumnExpandKeep : CXTPGridHeader
  • m_bLastColumnWidthWYSIWYG : CXTPGridPaintManager
  • m_bLastItemDrawnThemed : CXTPCheckListBox
  • m_bLayoutRTL : CXTPControl
  • m_bLBtnDown : CXTPHeaderCtrl
  • m_bLeftDirected : CXTPChart3dFunnelSeriesLabelView, CXTPChart3dPieSeriesLabelView, CXTPChart3dPyramidSeriesLabelView
  • m_bLeftRoundedCorner : CXTPTaskPanelPaintManager
  • m_bLegendVisible : CXTPChartAxisConstantLine, CXTPChartAxisStrip, CXTPChartSeries
  • m_bLight : CXTPButtonThemeVisualStudio2012
  • m_bLimitMonthDaysSelection : CXTPDatePickerControl
  • m_bLineNumbers : CXTPSyntaxEditOptions
  • m_bListColor : CXTPListBase
  • m_bLoading : CXTPPropExchange
  • m_bLocalUpdate : CXTPGridDataManager
  • m_bLocked : CXTPFlowGraphConnectionPoint, CXTPFlowGraphNode, CXTPGridRecord, CXTPTrackBlock, CXTPTrackControlItem
  • m_bLockExpand : CXTPGridControl, CXTPGridRow
  • m_bLockFrameDraw : CXTPSkinObjectFrame
  • m_bLockNCPaint : CXTPCommandBarsFrameHook
  • m_bLockReposition : CXTPTabClientWnd
  • m_bLockSplitters : CXTPDockingPaneManager
  • m_bLockUpdate : CXTPTabClientWnd
  • m_bLogarithmic : CXTPChartAxis
  • m_bLunaTheme : CXTPCommandBarsOffice2003Theme, CXTPDockingPanePaintManager, CXTPPropertyGridOffice2003Theme, CXTPTabColorSetOffice2003
  • m_bMakeUpper : CXTPGridPaintManager
  • m_bManagingViews : CXTPExcelTabCtrl
  • m_bMarkerVisible : CXTPChartLegend
  • m_bMarkupEnabled : CXTPGridControl
  • m_bMarkupPartsLoaded : CXTPFrameThemeOffice2007System, CXTPRibbonMarkupFrameTheme
  • m_bMarkupPoint : CXTPFlowGraphConnectionPoint
  • m_bMatchCase : CXTPSyntaxEditFindReplaceDlg
  • m_bMatchWholeWord : CXTPSyntaxEditFindReplaceDlg
  • m_bMaximized : CXTPDockingPaneTabbedContainer
  • m_bMdiApp : CXTPMenuBar
  • m_bMDIClient : CXTPSkinObjectFrame
  • m_bMeasureDirty : CXTPMarkupUIElement
  • m_bMeasureInProgress : CXTPMarkupUIElement
  • m_bMeeting : CXTPCalendarEvent, CXTPCalendarEventPropertiesDlg
  • m_bMessageBoxStyle : CXTPTaskDialogClient
  • m_bMilitary : CXTPTimeEdit
  • m_bMinimized : CXTPRibbonBar
  • m_bMinimizeOnDblClick : CXTPRibbonBar
  • m_bMinorVisible : CXTPChartAxisGridLines, CXTPChartAxisTickMarks
  • m_bMirrorImage : CXTPSkinImage
  • m_bModeless : CXTPPropertySheet
  • m_bModified : CXTPCalendarEventColorListBox, CXTPItemEdit, CXTPMaskEditT< TBase >, CXTPPropertyPage, CXTPSyntaxEditPropertiesPageColor, CXTPSyntaxEditPropertiesPageEdit, CXTPSyntaxEditPropertiesPageFont
  • m_bMonday : CXTPCalendarEventRecurrenceDlg
  • m_bMonitoringRunning : CXTPCalendarRemindersManager
  • m_bMouseLocked : CXTPControlListBox
  • m_bMouseOver : CXTPHyperLink
  • m_bMovePivot : CXTPGridControl
  • m_bMoveScrollbarOnFixedColumnsIndent : CXTPGridPaintManager
  • m_bmpCache : CXTPChartControl, CXTPDatePickerControl, CXTPFlowGraphControl, CXTPGridControl, CXTPSyntaxEditCtrl
  • m_bmpElsewherePattern : CXTPCalendarPaintManager
  • m_bmpGrayDC : CXTPGridView
  • m_bmpGrippers : CXTPTaskPanelPaintManager
  • m_bmpPicker : CXTPColorHex, CXTPColorWnd
  • m_bmpPreview : CXTPTaskPanelGroupItem
  • m_bmpTentativePattern : CXTPCalendarPaintManager
  • m_bMultiColorScheduleMode : CXTPCalendarControl
  • m_bMultiColumn : CXTPTaskPanel
  • m_bMulticolumnsEnable : CXTPCalendarCaptionBarTheme
  • m_bMultiColumnWeekMode : CXTPCalendarControl
  • m_bMultiLine : CXTPCommandBar
  • m_bMultiline : CXTPGridTip
  • m_bMultipleSchedulesMode : CXTPCalendarControl
  • m_bMultipleSchedulesNoSelfLinks : CXTPCalendarControl
  • m_bMultiplSel : CXTPControlListBox
  • m_bMultiply : CXTPResourceImage
  • m_bMultiRowFixedSelection : CXTPTabPaintManager
  • m_bMultiRowJustified : CXTPTabPaintManager
  • m_bMultiRowTabsOptimization : CXTPTabPaintManager
  • m_bMultiSelect : CXTPPropertyGrid, CXTPTreeBase
  • m_bMultiSelectionMode : CXTPDatePickerControl, CXTPGridControl
  • m_bMultyDayTextAlign : CXTPCalendarViewEvent
  • m_bmWatermark : CXTPGridControl
  • m_bNameIgnoreCase : CXTPCalendarCustomProperties
  • m_bNavigateButton : CXTPShortcutBarItem
  • m_bNavigationButton : CXTPShortcutBarPaintManager
  • m_bNeverArranged : CXTPMarkupUIElement
  • m_bNeverMeasured : CXTPMarkupUIElement
  • m_bNewFile : CXTPSyntaxEditDoc
  • m_bNewItem : CXTPEditListBox
  • m_bNewWindowTab : CXTPTabManagerItem
  • m_bNoBorder : CXTPShortcutListBox
  • m_bNoColSizing : CXTPListBase
  • m_bNoIcons : CXTPMDIWndTab
  • m_bNoNeedSortedDragDrop : CXTPGridControl
  • m_bNoSize : CXTPSplitterWnd
  • m_bNoUnderline : CXTPShortcutListBox
  • m_bNumericOnly : CXTPControlEdit
  • m_bOccur : CXTPCalendarOccurSeriesChooseDlg
  • m_bOccurrence : CXTPCalendarEventPropertiesDlg
  • m_bOffice2007Padding : CXTPPaintManager
  • m_bOfficeBorder : CXTPTaskPanelPaintManager
  • m_bOfficeCaption : CXTPTaskPanelPaintManagerPlain
  • m_bOfficeHighlight : CXTPTaskPanelPaintManager
  • m_bOffsetPopupLabelText : CXTPPaintManager
  • m_bOleDragging : CXTPSyntaxEditView
  • m_bOneNoteColors : CXTPTabPaintManager
  • m_bOnQuickAccess : CXTPControl
  • m_bOnSizeRunning : CXTPSyntaxEditView
  • m_bOpened : CXTPCalendarData, CXTPSyntaxEditDoc
  • m_bOpenFileDialog : CXTPBrowseEdit
  • m_bOptimized : CXTPSkinImage
  • m_Borders : CXTPCalendarCaptionBarControl, CXTPCalendarControl
  • m_borderStyle : CXTPDatePickerControl
  • m_bOriginalControls : CXTPControls
  • m_bounds : CXTPChartPolygonDeviceCommand
  • m_bOver : CXTPGridInplaceButton
  • m_bOverType : CXTPMaskEditT< TBase >
  • m_bOverwrite : CXTPSyntaxEditBufferManager
  • m_bPageDirty : CXTPSyntaxEditCtrl
  • m_bPainted : CXTPExcelTabCtrl, CXTPHeaderCtrl
  • m_bPanelManager : CXTPTabPaintManager
  • m_bPassword : CXTPPropertyGridItem
  • m_bPercentCompleteDisplay : CXTPGridRecordItemPercentNumber
  • m_bPinable : CXTPRecentFileList
  • m_bPinFooterRows : CXTPGridControl
  • m_bPinFooterRowsPrinted : CXTPGridControl
  • m_bPlainSeparators : CXTPCommandBarsOffice2003Theme
  • m_bPlusMinus : CXTPGridColumn
  • m_bPopup : CXTPControlPopup
  • m_bPopupActive : CXTPColorPicker
  • m_bPreInit : CXTPEyeDropper
  • m_bPremultiplyImages : CXTPResourceImages
  • m_bPrepareDrag : CXTPGridControl
  • m_bPressed : CXTPControl, CXTPControlGallery, CXTPDatePickerButton, CXTPDockingPaneCaptionButton, CXTPExcelTabCtrlButtonState, CXTPGridInplaceButton, CXTPMessageBarButton, CXTPStatusBarPane, CXTPTabManagerNavigateButton
  • m_bPreSubclassInit : CXTPColorBase, CXTPColorHex, CXTPComboBox, CXTPEdit, CXTPHyperLink, CXTPProgressCtrl, CXTPScrollBarCtrl, CXTPSearchOptionsCtrl, CXTPSpinButtonCtrl
  • m_bPreSubclassWindow : CXTPPropertyGrid, CXTPShortcutBar, CXTPTaskPanel
  • m_bPreventAutoAllDayMode : CXTPCalendarControl
  • m_bPreventDragAllDayEventInDayView : CXTPCalendarDayView
  • m_bPrevFocusSubItems : CXTPGridControl
  • m_bPrevFooterRows : CXTPGridControl
  • m_bPrevFooterShow : CXTPGridControl
  • m_bPrevHeaderAutoSize : CXTPGridControl
  • m_bPrevHeaderRows : CXTPGridControl
  • m_bPrevHeaderShow : CXTPGridControl
  • m_bPreview : CXTPControlGallery
  • m_bPreviewAllowEdit : CXTPGridControl
  • m_bPreviewMode : CXTPToolBar
  • m_bPreviewVisible : CXTPToolBar
  • m_bPrevPreviewMode : CXTPGridControl
  • m_bPrintDateHeader : CXTPCalendarControlViewPrintOptions
  • m_bPrintDirect : CXTPCalendarControlView, CXTPGridView, CXTPSyntaxEditView
  • m_bPrintFineMode : CXTPCalendarControlView
  • m_bPrintFromToExactly : CXTPCalendarControlViewPrintOptions
  • m_bPrintFullScale : CXTPCalendarControlView, CXTPCalendarDayView
  • m_bPrintGroupRowIcon : CXTPGridPaintManager
  • m_bPrintPageRectangle : CXTPGridPaintManager
  • m_bPrintRepeatHeaderFooterMode : CXTPCalendarControlView, CXTPCalendarDayView
  • m_bPrintSelection : CXTPGridView
  • m_bPrintSortTriangle : CXTPGridPaintManager
  • m_bPrintVirtualPageNumber : CXTPGridPaintManager
  • m_bPrintWatermark : CXTPGridPaintManager
  • m_bPrivate : CXTPCalendarEvent, CXTPCalendarEventPropertiesDlg
  • m_bPromptToDeleteRecurrentEvent : CXTPCalendarControl
  • m_bPushed : CXTPButton, CXTPSkinObjectButton
  • m_bQuickCustomizeMode : CXTPCommandBars
  • m_bRClickDrag : CXTPGridControl
  • m_bReadOnly : CXTPControlEdit, CXTPPropertyGridItem, CXTPSyntaxEditOptions
  • m_bReadOnlyMode : CXTPCalendarControl
  • m_bRecalcConnectionLayoutWhenNeeded : CXTPFlowGraphPaintManager
  • m_bRecalcLayout : CXTPDockingPaneSplitterContainer
  • m_bRecOrRowNum : CXTPGridPaintManager
  • m_bRecurrenceUpdate : CXTPCalendarEventPropertiesDlg
  • m_bRecursePopup : CXTPCommandBar
  • m_bRedo : CXTPMaskEditT< TBase >
  • m_bReduced : CXTPRibbonGroup
  • m_bRefreshed : CXTPTabClientWnd
  • m_bRefreshMetrics : CXTPSkinManagerMetrics
  • m_bRegionChanged : CXTPSkinObjectFrame
  • m_bRelayWndMsg : CXTPGridControl
  • m_bReloading : CXTPSyntaxEditDoc
  • m_bReminder : CXTPCalendarEvent, CXTPCalendarEventPropertiesDlg
  • m_bRemoved : CXTPTrayIcon
  • m_bRenderingAntialiasing : CXTPChart3dDeviceContext
  • m_bRepeatFooterRows : CXTPGridViewPrintOptions
  • m_bRepeatHeaderRows : CXTPGridViewPrintOptions
  • m_bReplaceDlg : CXTPSyntaxEditFindReplaceDlg
  • m_bReposition : CXTPFlowGraphControl
  • m_bRequest : CXTPCalendarControl::CViewChanged_ContextData
  • m_bRequest_Day : CXTPCalendarView::CSelectionChanged_ContextData
  • m_bRequest_Event : CXTPCalendarView::CSelectionChanged_ContextData
  • m_bResetUndoBuffer : CXTPCalendarView
  • m_bResizable : CXTPDialogBar, CXTPPopupBar, CXTPPropertySheet
  • m_bResizeControlWithView : CXTPCalendarControlView, CXTPGridView, CXTPSyntaxEditView
  • m_bRestrictMode : CXTPDatePickerControl
  • m_bReversed : CXTPChartAxis
  • m_bRevertAlignment : CXTPGridPaintManager
  • m_bRExceptionDeleted : CXTPCalendarEvent
  • m_bRibbonBarVisible : CXTPRibbonBar
  • m_bRightButtonDrag : CXTPSyntaxEditCtrl
  • m_bRightRoundedCorner : CXTPTaskPanelPaintManager
  • m_bRightToLeft : CXTPDatePickerControl, CXTPPopupControl
  • m_bRotateImageOnVerticalDraw : CXTPTabPaintManager
  • m_bRoundedCaption : CXTPDockingPaneOffice2003Theme
  • m_bRoundedFrame : CXTPTaskPanelPaintManagerPlain
  • m_bRowColor : CXTPListBase
  • m_bRowFocusVisible : CXTPGridControl
  • m_brTheme : CXTPSkinManagerMetrics
  • m_bRTL : CXTPHeaderCtrl
  • m_bSaturday : CXTPCalendarEventRecurrenceDlg
  • m_bScaleOnResize : CXTPTrackControl
  • m_bScrollBars : CXTPSyntaxEditView
  • m_bScrollH_Disabled : CXTPCalendarView
  • m_bScrolling : CXTPSyntaxEditCtrl
  • m_bScrollTextOnEdit : CXTPGridRecordItemEditOptions
  • m_bScrollV_Disabled : CXTPCalendarView
  • m_bScrollVisible : CXTPTaskPanel
  • m_bSelected : CXTPCalendarViewEvent, CXTPControl, CXTPDockingPaneCaptionButton, CXTPFlowGraphElement, CXTPGridRecord, CXTPShortcutBarItem, CXTPTaskPanelGroupItem
  • m_bSelectImageInPopupBar : CXTPPaintManager
  • m_bSelectionEnable : CXTPGridSection
  • m_bSelectionExcludeGroupRows : CXTPGridControl
  • m_bSelectItemOnFocus : CXTPTaskPanel
  • m_bSelectLine : CXTPSyntaxEditGoToLineDlg
  • m_bSelectOnButtonDown : CXTPTabPaintManager
  • m_bSelectOnDragOver : CXTPTabPaintManager
  • m_bSelectTextOnEdit : CXTPGridRecordItemEditOptions
  • m_bSelectWeek : CXTPDatePickerControl
  • m_bSelEndOk : CXTPControlComboBox
  • m_bSelMargin : CXTPSyntaxEditOptions
  • m_bSet : CXTPResourceManager::CManageState
  • m_bSetClipboard : CXTPEyeDropper
  • m_bSetWindowText : CXTPGridInplaceEdit
  • m_bShadeGroupHeadings : CXTPGridPaintManager
  • m_bShadeSortColumn : CXTPGridPaintManager
  • m_bShellExec : CXTPHyperLink
  • m_bShowActiveItemOnTop : CXTPShortcutBar
  • m_bShowAddress : CXTPHexEdit
  • m_bShowAllDayEventsOnly : CXTPCalendarDayView
  • m_bShowArrow : CXTPCalendarDayViewEvent
  • m_bShowAscii : CXTPHexEdit
  • m_bShowBehind : CXTPChartAxisConstantLine
  • m_bShowBorder : CXTPEdit, CXTPSplitterWnd
  • m_bShowBorders : CXTPControlGallery
  • m_bShowCaption : CXTPDockingPanePaintManager, CXTPShortcutBarPane, CXTPShortcutBarPaneItem
  • m_bShowCaptionAlways : CXTPRibbonBar
  • m_bShowCaptionBar : CXTPCalendarControlView
  • m_bShowCaret : CXTPHexEdit
  • m_bShowCloseTabButton : CXTPDockingPaneManager
  • m_bShowContentsWhileDragging : CXTPDockingPaneManager
  • m_bShowDaysAfter : CXTPDatePickerItemMonth
  • m_bShowDaysBefore : CXTPDatePickerItemMonth
  • m_bShowDockingContextStickers : CXTPDockingPaneManager
  • m_bShowExpandButton : CXTPToolBar
  • m_bShowFiles : CXTPShellTreeBase
  • m_bShowFloatingMaximizeButton : CXTPDockingPaneManager
  • m_bShowFocus : CXTPButton
  • m_bShowGrid : CXTPFlowGraphPaintManager
  • m_bShowGripper : CXTPShortcutBar
  • m_bShowHex : CXTPHexEdit
  • m_bShowIcons : CXTPTabPaintManager
  • m_bShowIconWhenEditing : CXTPGridControl
  • m_bShowImage : CXTPToolTipContext
  • m_bShowInFieldChooser : CXTPGridColumn
  • m_bShowInplaceButtonsAlways : CXTPPropertyGrid
  • m_bShowInputBox : CXTPTaskDialogClient
  • m_bShowInTaskBar : CXTPCalendarRemindersDialog
  • m_bShowItemsInGroups : CXTPGridHeader
  • m_bShowKeyboardCues : CXTPPaintManager
  • m_bShowLabels : CXTPControlGallery
  • m_bShowLeftScroll : CXTPDatePickerItemMonth
  • m_bShowLines : CXTPChartSeriesLabel
  • m_bShowLinks : CXTPCalendarControl, CXTPCalendarDayView
  • m_bShowLockIcon : CXTPGridPaintManager
  • m_bShowMaximizeButton : CXTPDockingPaneManager
  • m_bShowMinutes : CXTPCalendarPaintManager
  • m_bShowNewDeleteButtons : CXTPEditListBoxToolBar
  • m_bShowNodeGroupsAlways : CXTPFlowGraphPaintManager
  • m_bShowNonActiveInPlaceButton : CXTPGridPaintManager
  • m_bShowNonMonthDays : CXTPDatePickerControl
  • m_bShowOptionButton : CXTPRibbonGroup
  • m_bShowPanelScrollButtons : CXTPDockingPaneManager
  • m_bShowPending : CXTPTrayIcon
  • m_bShowPinButton : CXTPDockingPaneMiniWnd
  • m_bShowPreview : CXTPEyeDropper
  • m_bShowQuickAccess : CXTPRibbonBar
  • m_bShowQuickAccessBelow : CXTPRibbonBar, CXTPRibbonCustomizeQuickAccessPage
  • m_bShowRadioButtons : CXTPControlWindowList
  • m_bShowRightScroll : CXTPDatePickerItemMonth
  • m_bShowRowNumber : CXTPGridView
  • m_bShowScrollBar : CXTPControlGallery
  • m_bShowShadow : CXTPControlPopup, CXTPPaintManager, CXTPPopupBar, CXTPPropertyGridInplaceList
  • m_bShowShellLinkIcons : CXTPShellPidl
  • m_bShowSizeCursorWhileDragging : CXTPDockingPaneManager
  • m_bShowSizeGripper : CXTPStatusBar
  • m_bShowSpinButtons : CXTPControlEdit
  • m_bShowTabs : CXTPTabPaintManager
  • m_bShowText : CXTPColorPicker
  • m_bShowTextBelow : CXTPChartAxisConstantLine
  • m_bShowTitleAndDescription : CXTPToolTipContext
  • m_bShowTooltipForAllDayEvents : CXTPCalendarControl
  • m_bShowTooltipForNotFocused : CXTPCalendarControl
  • m_bShowTooltips : CXTPGridControl
  • m_bShowTopBorder : CXTPSplitterWndEx
  • m_bShowTopLeftCaptionShadow : CXTPShortcutBarOffice2003Theme
  • m_bShowUpDownButtons : CXTPEditListBoxToolBar
  • m_bShowWeekNumbers : CXTPDatePickerControl
  • m_bShowWorkArea : CXTPTrackControl
  • m_bShowWorkspace : CXTPTabClientWnd
  • m_bShowWYSIWYGMarkers : CXTPGridPaintManager
  • m_bShowZeroLevel : CXTPChartAxisRange
  • m_bSideDocking : CXTPDockingPaneManager
  • m_bSideMargins : CXTPChartAxisRange
  • m_bSingleSelection : CXTPShortcutBar, CXTPTaskPanel
  • m_bSkipGroupsFocus : CXTPGridControl
  • m_bSkippingAntialiasing : CXTPChart3dDeviceContext
  • m_bSlideOut : CXTPDockingPaneMiniWnd, CXTPDockingPaneSidePanel
  • m_bSmooth3dEdges : CXTPChartSeriesStyle
  • m_bSnapToBlocks : CXTPTrackControl
  • m_bSnapToMarkers : CXTPTrackControl
  • m_bSortable : CXTPGridColumn
  • m_bSortAscending : CXTPGridSubListControl
  • m_bSortColor : CXTPListBase
  • m_bSortedDragDrop : CXTPGridControl
  • m_bSortIncreasing : CXTPGridColumn
  • m_bSortRecordChilds : CXTPGridControl
  • m_bSortTriangleOffsetFromRight : CXTPGridPaintManager
  • m_bSoundAvailable : CXTPSoundManager
  • m_bSpecial : CXTPTaskPanelGroup
  • m_bSplashScreenMode : CXTPPopupControl
  • m_bStandardFont : CXTPPaintManagerFont
  • m_bStartedClickInside : CXTPCalendarView
  • m_bStaticFrame : CXTPTabPaintManager
  • m_bStickyFloatingFrames : CXTPDockingPaneManager
  • m_bStrictBestFit : CXTPGridControl
  • m_bStrictFiltering : CXTPGridControl
  • m_bStripEllipsisFromToolTip : CXTPToolTipContext
  • m_bStyle : CXTPSkinObjectButton
  • m_bSubclassed : CXTPCaption, CXTPExcelTabCtrl, CXTPSplitterWnd, CXTPTabBase
  • m_bSunday : CXTPCalendarEventRecurrenceDlg
  • m_bSwitchMode : CXTPGridView
  • m_bSwitchToDayViewIfPickedSingleDay : CXTPCalendarControl
  • m_bSyncActiveFloatingFrames : CXTPDockingPaneManager
  • m_bSyntaxColor : CXTPSyntaxEditOptions
  • m_bSystemDrawing : CXTPTabBaseTheme
  • m_bTabCaptions : CXTPPropertyGrid
  • m_bTabColors : CXTPSplitterWndTheme
  • m_bTabItems : CXTPPropertyGrid, CXTPTaskPanel
  • m_bTabsVisible : CXTPRibbonBar
  • m_bTabWithSpace : CXTPSyntaxEditOptions
  • m_bTearOff : CXTPToolBar
  • m_bTearOffPopup : CXTPPopupBar
  • m_bTearOffSelected : CXTPPopupBar
  • m_bTearOffTracking : CXTPPopupBar
  • m_bTempFile : CXTPPropExchangeIniFile
  • m_bTemporary : CXTPControl, CXTPToolBar
  • m_bTextBelow : CXTPCommandBar
  • m_bTextOutOfBorders : CXTPCalendarViewEvent
  • m_bThemed : CXTPGridRecordItemControl
  • m_bThemedBackColor : CXTPTabClientWnd
  • m_bThemedCheckBox : CXTPPaintManager
  • m_bThemedFloatingFrames : CXTPDockingPaneManager
  • m_bThemedInplaceButtons : CXTPGridPaintManager
  • m_bThemedStatusBar : CXTPPaintManager
  • m_bThemeFrameEnabled : CXTPCommandBarsFrameHook
  • m_bThemeMetrics : CXTPGridControl
  • m_bThemeReady : CXTPTaskDialogClient
  • m_bThickCheckMark : CXTPPaintManager
  • m_bThinBorder : CXTPColorSelectorCtrlTheme
  • m_bThinSplitter : CXTPPropertyGridPaintManager
  • m_bThursday : CXTPCalendarEventRecurrenceDlg
  • m_bTimelineEnable : CXTPCalendarCaptionBarTheme
  • m_bTimelineMode : CXTPCalendarControl
  • m_bTimeLineSeparateGroup : CXTPCalendarTimeLineView
  • m_bTimerActive : CXTPShortcutListBox
  • m_bTimerGroupHover : CXTPTaskPanel
  • m_bTipEnabled : CXTPHyperLink, CXTPTagCloudCtrl
  • m_bTitleVisible : CXTPDockingPaneTabbedContainer
  • m_btnAlwaysShowFullMenus : CXTPCustomizeOptionsPage
  • m_btnBrowse : CXTPBrowseEdit
  • m_btnCaption : CXTPCaption
  • m_btnDelete : CXTPCustomizeToolbarsPage
  • m_btnLargeIcons : CXTPCustomizeOptionsPage
  • m_btnNew : CXTPCustomizeToolbarsPage
  • m_btnRename : CXTPCustomizeToolbarsPage
  • m_btnReset : CXTPCustomizeToolbarsPage
  • m_btnResetData : CXTPCustomizeOptionsPage
  • m_btnShowFullAfterDelay : CXTPCustomizeOptionsPage
  • m_btnToolBarAccelTips : CXTPCustomizeOptionsPage
  • m_btnToolBarScreenTips : CXTPCustomizeOptionsPage
  • m_bTokensLoaded : CXTPSyntaxEditCtrl
  • m_bToolBarVisible : CXTPPropertyGrid
  • m_bTooltipUnderMouse : CXTPCalendarControl
  • m_bTracking : CXTPCommandBar, CXTPExcelTabCtrl, CXTPMiniToolBar, CXTPPropertyGridView
  • m_bTrackingSize : CXTPShortcutBar
  • m_bTrackOnHover : CXTPCommandBar
  • m_bTrackSelection : CXTPPropertyGridInplaceList
  • m_bTransparent : CXTPPropertyGridPaintManager
  • m_bTrapTabKey : CXTPGridControl
  • m_bTristateCheckbox : CXTPGridRecordItem
  • m_bTuesday : CXTPCalendarEventRecurrenceDlg
  • m_bTunneling : CXTPShellTreeBase
  • m_bTwoSides : CXTPChartSolidSplinePolygonDeviceCommand
  • m_bUnderline : CXTPHyperLink, CXTPPopupItem
  • m_bUnicodeFileFormat : CXTPSyntaxEditBufferManager
  • m_bUnrestrictedDragDrop : CXTPGridControl
  • m_bUpdate : CXTPHexEdit
  • m_bUpdateContents : CXTPTabClientWnd
  • m_bUpdateUndo : CXTPMaskEditT< TBase >
  • m_bUpdateWhenEventChangedNotify : CXTPCalendarControl
  • m_bUpdateWindow : CXTPChartControl
  • m_bUseActiveViewResoucesForBold : CXTPCalendarController
  • m_bUseAlphaContext : CXTPDockingPaneContext
  • m_bUseAlternativeBackground : CXTPGridPaintManager
  • m_bUseBitmapGrippers : CXTPTaskPanelPaintManager
  • m_bUseBoldCaptionFont : CXTPDockingPanePaintManager
  • m_bUseComCtl32 : CXTPTaskDialog
  • m_bUseDefaultOnLoad : CXTPPropExchange
  • m_bUseDefaultOnSave : CXTPPropExchange
  • m_bUseDockingStickers : CXTPDockingPaneContext
  • m_bUseDropMarker : CXTPGridPaintManager
  • m_bUseEditTextAlignment : CXTPGridPaintManager
  • m_bUseGlobalPaintManager : CXTPCommandBarsFrameHook
  • m_bUseGroupRowSelectionState : CXTPGridPaintManager
  • m_bUseMask : CXTPGridColumn, CXTPMaskEditT< TBase >, CXTPPropertyGridItem
  • m_bUseMonitor : CXTPSyntaxEditConfigurationManager, CXTPSyntaxEditCtrl
  • m_bUseNewHitTestCode : CXTPCalendarDayView
  • m_bUseOfficeFont : CXTPDockingPanePaintManager, CXTPPaintManager
  • m_bUseOutputDC : CXTPSyntaxEditDrawTextProcessor
  • m_bUserColors : CXTPCaption, CXTPExcelTabCtrl
  • m_bUseResources : CXTPImageManager, CXTPImageManagerIconHandle
  • m_bUserWorkspace : CXTPTabClientWnd
  • m_bUseShellIcon : CXTPGridPaintManager
  • m_bUseSplitterTracker : CXTPDockingPaneManager, CXTPTabClientWnd
  • m_bUseStandardCaptionFont : CXTPTaskPanelPaintManager
  • m_bUseStandardFont : CXTPDockingPanePaintManager, CXTPPaintManager, CXTPShortcutBarPaintManager, CXTPTabPaintManager
  • m_bUseStandardItemsFont : CXTPTaskPanelPaintManager
  • m_bUseSysIcons : CXTPTaskDialogClient
  • m_bUseSystemDecimalSymbol : CXTPPropertyGridItemDouble
  • m_bUseSystemKeyNameText : CXTPShortcutManager
  • m_bUseSystemSaveBitsStyle : CXTPShadowManager
  • m_bUseThousandSeparator : CXTPChartNumberFormat
  • m_bUseVisualStyle : CXTPButton, CXTPComboBox, CXTPScrollBar, CXTPSpinButtonCtrl
  • m_bUseWinTheme : CXTPEditTheme, CXTPMarqueeCtrlPaintManager, CXTPProgressCtrlPaintManager
  • m_bUseWinThemes : CXTPHeaderCtrlTheme, CXTPTabBaseTheme
  • m_buttonCustomStyle : CXTPControl
  • m_buttonRibbonStyle : CXTPControl
  • m_buttons : CXTPExcelTabCtrl
  • m_buttonsStyle : CXTPPropertyGridPaintManager
  • m_buttonStyle : CXTPCommandBar, CXTPControl
  • m_buttonStyleEx : CXTPControlButton
  • m_bValid : CXTPResourceManager
  • m_bValue : CXTPPropertyGridItemBool
  • m_bVariableHelpHeight : CXTPPropertyGrid
  • m_bVariableItemsHeight : CXTPPropertyGrid
  • m_bVariableSplitterPos : CXTPPropertyGridView
  • m_bVerbsVisible : CXTPPropertyGrid
  • m_bVerification : CXTPTaskDialogClient
  • m_bVerticalMarker : CXTPCommandBar
  • m_bVerticalTextTopToBottom : CXTPTabPaintManager
  • m_bVertScrollBar : CXTPSyntaxEditCtrl
  • m_bViewOnly : CXTPSyntaxEditOptions
  • m_bViewVisible : CXTPPropertyGrid
  • m_bVirtualSpace : CXTPSyntaxEditOptions
  • m_bVisible : CXTPCalendarCaptionBarThemePart, CXTPCalendarDayViewTimeScale, CXTPChartAxis, CXTPChartAxisConstantLine, CXTPChartAxisGridLines, CXTPChartAxisLabel, CXTPChartAxisStrip, CXTPChartAxisTickMarks, CXTPChartAxisTitle, CXTPChartBorder, CXTPChartLegend, CXTPChartMarker, CXTPChartSeries, CXTPChartSeriesLabel, CXTPChartTitle, CXTPCommandBarKeyboardTip, CXTPControlAction, CXTPDatePickerButton, CXTPDatePickerItemDay, CXTPFlowGraphNode, CXTPGridColumn, CXTPGridRecord, CXTPGridRow, CXTPGridSection, CXTPPropertyGridItem, CXTPRibbonGroup, CXTPShortcutBarItem, CXTPTabManagerItem, CXTPTaskPanelItem, CXTPToolBar
  • m_bVisited : CXTPHyperLink
  • m_bVisualStudio2005Style : CAppearanceSetPropertyPageFlat
  • m_bVScrollBarVisible : CXTPGridControl
  • m_bVScrollEnabled : CXTPCalendarEventPropertiesDlg
  • m_bWasShiftKey : CXTPGridControl
  • m_bWatchSubtree : CXTPDirWatcher
  • m_bWednesday : CXTPCalendarEventRecurrenceDlg
  • m_bWideCaret : CXTPSyntaxEditOptions
  • m_bWin9x : CXTPSkinManager
  • m_bWindowsForms : CXTPSkinObject
  • m_bWndCreateInProgress : CXTPSyntaxEditCtrl
  • m_bWrap : CXTPControl
  • m_bWrapCaptionBelowText : CXTPPaintManager
  • m_bXPBorder : CXTPTabBase
  • m_bYearsTriangle : CXTPDatePickerControl
  • m_callerParam : CXTPColorPopup
  • m_cameraState : CXTPChart3dDeviceContext
  • m_Caption : CXTPCaptionPopupWnd
  • m_CaptionButton : CXTPCaptionPopupWnd
  • m_captionDirection : CXTPDockingPaneManager
  • m_center : CXTPChartBoundedCircleDeviceCommand, CXTPChartCircleDeviceCommand
  • m_cfGrid : CXTPGridControl
  • m_cfItem : CXTPTaskPanel
  • m_cfNode : CXTPFlowGraphPage
  • m_chAlpha : CXTPMarqueeCtrl
  • m_checkList : CXTPCustomizeToolbarsPage
  • m_checkListState : CXTPCheckListBox
  • m_checkState : CXTPGridRecordItem
  • m_chPrevLeadByte : CXTPSyntaxEditCtrl
  • m_chPrompt : CXTPGridColumn, CXTPMaskEditT< TBase >, CXTPPropertyGridItem
  • m_chSecondLevelCurrentChar : CXTPRibbonBackstageView
  • m_ClickArgs : CXTPGridRecordItemControlHookWnd
  • m_clientFrame : CXTPTabPaintManager
  • m_clr : CXTPControlButtonColor, CXTPGridHeaderDropWnd, CXTPGridRecordItemPercentNumber
  • m_clr3DFace : CXTPDatePickerPaintManager, CXTPExcelTabCtrlTheme
  • m_clr3DFaceHilite : CXTPExcelTabCtrlTheme
  • m_clr3DFacePushed : CXTPExcelTabCtrlTheme
  • m_clr3DHilight : CXTPExcelTabCtrlTheme
  • m_clr3DHilite : CXTPMarqueeCtrlPaintManager
  • m_clr3DLight : CXTPDatePickerPaintManager
  • m_clr3DShadow : CXTPCalendarPaintManager, CXTPCommandBarsOffice2013Theme, CXTPDatePickerPaintManager, CXTPExcelTabCtrlTheme, CXTPMarqueeCtrlPaintManager
  • m_clr3DText : CXTPDatePickerPaintManager
  • m_clrActiveBack : CXTPCommandBarsNativeWindows11Theme
  • m_clrActiveCaption : CXTPDockingPanePaintManager
  • m_clrActiveCaptionText : CXTPDockingPanePaintManager
  • m_clrActiveFilesBack : CXTPTabPaintManagerColorSet
  • m_clrActiveFilesBackHighlighted : CXTPTabPaintManagerColorSet
  • m_clrActiveFilesBackPressed : CXTPTabPaintManagerColorSet
  • m_clrActiveFilesGlyph : CXTPTabPaintManagerColorSet
  • m_clrActiveFilesGlyphHighlighted : CXTPTabPaintManagerColorSet
  • m_clrActiveFilesGlyphPressed : CXTPTabPaintManagerColorSet
  • m_clrAlternativeBackground : CXTPGridPaintManager
  • m_clrAutoHideFace : CXTPTabPaintManagerColorSet
  • m_clrBack : CXTPCommandBarsOffice2013Theme, CXTPEditTheme, CXTPGridInplaceEdit, CXTPHyperLink, CXTPListBoxThemeOffice2013, CXTPMarqueeCtrlPaintManager, CXTPMessageBarPaintManager, CXTPPopupItem, CXTPProgressCtrlPaintManager, CXTPProgressThemeOffice2013, CXTPPropertyGridInplaceEdit, CXTPPropertyGridItemMetrics, CXTPTagCloudCtrl
  • m_clrBackColor : CXTPChartSeriesLabel
  • m_clrBackDisabled : CXTPComboBoxTheme
  • m_clrBackground : CXTPCalendarPaintManager, CXTPCalendarTimeLineView, CXTPCalendarViewPart, CXTPChartContent, CXTPColorSetCaptionButton, CXTPComboBoxTheme, CXTPDatePickerThemeOffice2013, CXTPDockingPaneColorSet, CXTPDockingPanePaintManager, CXTPFlowGraphPaintManager, CXTPGridRecordItem, CXTPPopupPaintManager, CXTPStatusBarPane, CXTPTaskPanelPaintManager
  • m_clrBackground2 : CXTPCalendarPaintManager
  • m_clrBackgroundColor : CXTPChartLegend
  • m_clrBackgroundSlave : CXTPCalendarPaintManager
  • m_clrBackHighlight : CXTPComboBoxTheme
  • m_clrBackHiliteSelected : CXTPShortcutBarNativeWindows10Theme, CXTPShortcutBarNativeWindows11Theme, CXTPShortcutBarVisualStudio2015Theme, CXTPShortcutBarVisualStudio2017Theme, CXTPShortcutBarVisualStudio2019Theme, CXTPShortcutBarVisualStudio2022Theme
  • m_clrBackNonClient : CXTPEditTheme
  • m_clrBackstageSysButtonBack2013Highlighted : CXTPRibbonMarkupTheme
  • m_clrBackstageSysButtonBack2013Normal : CXTPRibbonMarkupTheme
  • m_clrBar : CXTPMarqueeCtrlPaintManager, CXTPProgressCtrlPaintManager, CXTPProgressThemeOffice2013
  • m_clrBarText : CXTPProgressCtrlPaintManager
  • m_clrBkBase : CXTPCalendarEventCategory
  • m_clrBlock : CXTPTrackBlock
  • m_clrBoldText : CXTPGridPaintManager
  • m_clrBoldTextHighlight : CXTPGridPaintManager
  • m_clrBorder : CXTPCalendarEventCategory, CXTPCaption, CXTPDockingPaneColorSet, CXTPEditTheme, CXTPListBoxThemeOffice2013, CXTPMessageBarPaintManager, CXTPPopupItem, CXTPProgressCtrlPaintManager, CXTPProgressThemeOffice2013, CXTPTagCloudCtrl, CXTPTagCloudStyle
  • m_clrBorder3DHilite : CXTPExcelTabCtrlTheme
  • m_clrBorder3DShadow : CXTPExcelTabCtrlTheme
  • m_clrBorderColor : CXTPChartMarker
  • m_clrBorderDisabled : CXTPComboBoxTheme, CXTPEditThemeOfficeXP
  • m_clrBorderHighlight : CXTPTabPaintManagerColorSet
  • m_clrBorderHilite : CXTPEditThemeOfficeXP, CXTPShortcutBarNativeWindows10Theme, CXTPShortcutBarNativeWindows11Theme, CXTPShortcutBarVisualStudio2015Theme, CXTPShortcutBarVisualStudio2017Theme, CXTPShortcutBarVisualStudio2019Theme, CXTPShortcutBarVisualStudio2022Theme
  • m_clrBorderHot : CXTPComboBoxTheme
  • m_clrBorderNormal : CXTPComboBoxTheme
  • m_clrBorders : CXTPCalendarCaptionBarPaintManager, CXTPCalendarPaintManager
  • m_clrBtnFace : CXTPCommandBarsOffice2013Theme, CXTPGridPaintManager
  • m_clrBtnFacePressed : CXTPGridPaintManager
  • m_clrBtnText : CXTPExcelTabCtrlTheme, CXTPGridPaintManager
  • m_clrBtnTextGray : CXTPExcelTabCtrlTheme
  • m_clrBtnTextHilite : CXTPExcelTabCtrlTheme
  • m_clrBtnTextPushed : CXTPExcelTabCtrlTheme
  • m_clrButtonArrowDisabled : CXTPComboBoxThemeOffice2013
  • m_clrButtonArrowHot : CXTPComboBoxTheme
  • m_clrButtonArrowNormal : CXTPComboBoxTheme
  • m_clrButtonArrowPressed : CXTPComboBoxTheme
  • m_clrButtonBack : CXTPMessageBarThemeOffice2013, CXTPStatusBarThemeOffice2013
  • m_clrButtonBackChecked : CXTPStatusBarThemeOffice2013
  • m_clrButtonBackHighlight : CXTPStatusBarThemeOffice2013
  • m_clrButtonBackHilite : CXTPMessageBarThemeOffice2013
  • m_clrButtonBackPushed : CXTPMessageBarThemeOffice2013, CXTPStatusBarThemeOffice2013
  • m_clrButtonBorder : CXTPMessageBarThemeOffice2013, CXTPTabPaintManagerColorSet
  • m_clrButtonBorderHighlighted : CXTPTabPaintManagerColorSet
  • m_clrButtonBorderHilite : CXTPMessageBarThemeOffice2013
  • m_clrButtonBorderHot : CXTPTabPaintManagerColorSet
  • m_clrButtonBorderKeyTips : CXTPTabPaintManagerColorSet
  • m_clrButtonBorderPushed : CXTPMessageBarThemeOffice2013
  • m_clrButtonBorderTabContext1 : CXTPTabPaintManagerColorSet
  • m_clrButtonBorderTabContext2 : CXTPTabPaintManagerColorSet
  • m_clrButtonDisabled : CXTPComboBoxThemeOffice2013
  • m_clrButtonFace : CXTPCalendarPaintManager, CXTPDatePickerPaintManager
  • m_clrButtonFaceText : CXTPCalendarPaintManager
  • m_clrButtonHighlighted : CXTPTabPaintManagerColorSet
  • m_clrButtonHighlightedClose : CXTPTabPaintManagerColorSet
  • m_clrButtonHot : CXTPComboBoxTheme
  • m_clrButtonNormal : CXTPComboBoxTheme, CXTPTabBaseThemeOffice2003, CXTPTabPaintManagerColorSet
  • m_clrButtonPressed : CXTPComboBoxTheme, CXTPPopupPaintManager, CXTPTabPaintManagerColorSet
  • m_clrButtonPressedBorder : CXTPPopupPaintManager
  • m_clrButtonSelected : CXTPPopupPaintManager, CXTPTabBaseThemeOffice2003, CXTPTabPaintManagerColorSet
  • m_clrButtonSelectedBorder : CXTPPopupPaintManager
  • m_clrButtonSelectedHighlighted : CXTPTabPaintManagerColorSet
  • m_clrButtonSelectedPressed : CXTPTabPaintManagerColorSet
  • m_clrButtonText : CXTPDatePickerPaintManager, CXTPTabColorSetOffice2007
  • m_clrButtonTextChecked : CXTPStatusBarThemeOffice2013
  • m_clrButtonTextHighlight : CXTPStatusBarThemeOffice2013
  • m_clrButtonTextPushed : CXTPStatusBarThemeOffice2013
  • m_clrCaption : CXTPDockingPaneColorSet, CXTPGridRecordItemControl
  • m_clrCaptionBorder : CXTPDockingPaneNativeWindows10Theme, CXTPDockingPaneNativeWindows11Theme, CXTPDockingPaneVisualStudio2005Beta2Theme, CXTPDockingPaneVisualStudio2015Theme, CXTPDockingPaneVisualStudio2017Theme, CXTPDockingPaneVisualStudio2019Theme, CXTPDockingPaneVisualStudio2022Theme
  • m_clrCaptionButtonFill : CXTPCommandBarsOffice2013Theme
  • m_clrCaptionText : CXTPGridPaintManager, CXTPShortcutBarOffice2003Theme
  • m_clrCaptionTextPressed : CXTPGridPaintManager
  • m_clrCategoryFore : CXTPPropertyGridItemMetrics
  • m_clrCategorySeparator : CXTPPropertyGridPaintManager
  • m_clrClassicUnderline : CXTPCalendarPaintManager
  • m_clrColor : CXTPCalendarEventLabel, CXTPChartAxis, CXTPChartAxisConstantLine, CXTPChartAxisGridLines, CXTPChartAxisStrip, CXTPChartBorder, CXTPChartMarker, CXTPChartSeriesStyle, CXTPColorHex, CXTPColorSelectorCtrl
  • m_clrColor2 : CXTPChartAxisStrip
  • m_clrColumnOffice2007CustomTheme : CXTPGridPaintManager
  • m_clrCommandBar : CXTPCommandBarsOffice2003Theme
  • m_clrConnection : CXTPFlowGraphConnection, CXTPFlowGraphPaintManager
  • m_clrConnector : CXTPGridPaintManager
  • m_clrControlBack : CXTPDatePickerPaintManager, CXTPGridPaintManager
  • m_clrControlDark : CXTPGridPaintManager
  • m_clrControlEditDisabledBorder : CXTPRibbonTheme
  • m_clrControlEditNormal : CXTPRibbonTheme
  • m_clrControlEditSelected : CXTPRibbonTheme
  • m_clrControlFace : CXTPTabPaintManagerColorSet
  • m_clrControlGalleryBorder : CXTPControlGalleryResourceTheme
  • m_clrControlGalleryNormal : CXTPControlGalleryResourceTheme
  • m_clrControlGallerySelected : CXTPControlGalleryResourceTheme
  • m_clrControlLightLight : CXTPGridPaintManager
  • m_clrCurrent : CXTPColorDialog, CXTPScrollBarThemeOffice2013
  • m_clrCustomValue : CXTPPaintManagerColor
  • m_clrDarkShadow : CXTPTabBaseThemeOffice2003
  • m_clrDayBack : CXTPDatePickerPaintManager
  • m_clrDaysOfWeekBack : CXTPDatePickerPaintManager
  • m_clrDaysOfWeekText : CXTPDatePickerPaintManager
  • m_clrDayText : CXTPDatePickerPaintManager
  • m_clrDefault : CXTPColorPicker, CXTPColorSelectorCtrl
  • m_clrDisableBitmapDarkest : CXTPGridPaintManager
  • m_clrDisableBitmapLightest : CXTPGridPaintManager
  • m_clrDisabled : CXTPScrollBarThemeOffice2013
  • m_clrDisabledCaptionText : CXTPDockingPanePaintManager
  • m_clrDisabledIcon : CXTPPaintManager
  • m_clrDisabledText : CXTPShortcutBarPaintManager
  • m_clrDivider : CXTPGridSection
  • m_clrDockBar : CXTPCommandBarsOffice2003Theme
  • m_clrDownColor : CXTPChartHighLowSeriesStyle
  • m_clrEdgeDkShadow : CXTPSkinManagerMetrics
  • m_clrEdgeHighLight : CXTPSkinManagerMetrics
  • m_clrEdgeHighLightColor : CXTPCommandBarsNativeXPTheme
  • m_clrEdgeLight : CXTPCaptionTheme, CXTPSkinManagerMetrics
  • m_clrEdgeShadow : CXTPCaptionTheme, CXTPSkinManagerMetrics
  • m_clrEdgeShadowColor : CXTPCommandBarsNativeXPTheme
  • m_clrEventBar : CXTPCalendarPaintManager, CXTPCalendarTimeLineView
  • m_clrEventBarLine : CXTPCalendarPaintManager, CXTPCalendarTimeLineView
  • m_clrEventBorderLine : CXTPCalendarPaintManager, CXTPCalendarTimeLineView
  • m_clrFace : CXTPCaption, CXTPPropertyGridPaintManager
  • m_clrFileButtonText : CXTPRibbonPaintManager
  • m_clrFill : CXTPColorSetCaptionButton
  • m_clrFloatingGripper : CXTPPaintManager
  • m_clrFloatingGripperText : CXTPPaintManager
  • m_clrFore : CXTPPropertyGridItemMetrics
  • m_clrFormulaSubSum : CXTPGridPaintManager
  • m_clrFormulaSum : CXTPGridPaintManager
  • m_clrFrame : CXTPPopupPaintManager
  • m_clrFrameBorder : CXTPTabPaintManagerColorSet
  • m_clrFrameCaptionActive : CXTPFramePaintManager
  • m_clrFrameCaptionInactive : CXTPFramePaintManager
  • m_clrFrameCaptionTextActive : CXTPFramePaintManager
  • m_clrFrameCaptionTextActiveBSMode : CXTPFramePaintManager
  • m_clrFrameCaptionTextActiveTitle : CXTPFramePaintManager
  • m_clrFrameCaptionTextActiveTitleBSMode : CXTPFramePaintManager
  • m_clrFrameCaptionTextInactive : CXTPFramePaintManager
  • m_clrFrameCaptionTextInactiveBSMode : CXTPFramePaintManager
  • m_clrFreezeColsDivider : CXTPGridPaintManager
  • m_clrGlyph : CXTPCommandBarsOffice2013Theme, CXTPGridThemeOffice2013, CXTPShortcutBarOffice2013Theme, CXTPTrackThemeOffice2013
  • m_clrGlyphBorder : CXTPGridThemeOffice2013, CXTPPropertyGridOffice2013Theme
  • m_clrGlyphContract : CXTPGridThemeOffice2013, CXTPPropertyGridOffice2013Theme
  • m_clrGlyphDisabled : CXTPCommandBarsOffice2013Theme
  • m_clrGlyphExpand : CXTPGridThemeOffice2013, CXTPPropertyGridOffice2013Theme
  • m_clrGlyphExpanded : CXTPShortcutBarOffice2013Theme
  • m_clrGlyphFill : CXTPShortcutBarOffice2013Theme
  • m_clrGlyphHighlight : CXTPCommandBarsOffice2013Theme, CXTPGridThemeOffice2013, CXTPTrackThemeOffice2013
  • m_clrGlyphPushed : CXTPCommandBarsOffice2013Theme, CXTPShortcutBarOffice2013Theme
  • m_clrGradientColumnSeparator : CXTPGridPaintManager
  • m_clrGradientColumnShadow : CXTPGridPaintManager
  • m_clrGridColor : CXTPFlowGraphPaintManager
  • m_clrGripper : CXTPDockingPaneColorSet, CXTPPopupThemeOffice2003
  • m_clrGroupBoxBack : CXTPGridPaintManager
  • m_clrGroupRowText : CXTPGridPaintManager
  • m_clrGroupShadeBack : CXTPGridPaintManager
  • m_clrGroupShadeBorder : CXTPGridPaintManager
  • m_clrGroupShadeText : CXTPGridPaintManager
  • m_clrHeader : CXTPRibbonOffice2013Theme
  • m_clrHeaderBottomLine : CXTPCalendarPaintManager
  • m_clrHeaderControl : CXTPGridPaintManager
  • m_clrHeaderFace : CXTPTabBaseThemeOffice2003, CXTPTabPaintManagerColorSet
  • m_clrHelpBack : CXTPPropertyGridItemMetrics
  • m_clrHelpFore : CXTPPropertyGridItemMetrics
  • m_clrHighLight : CXTPSyntaxEditAutoCompleteWnd
  • m_clrHighlight : CXTPCalendarPaintManager, CXTPCommandBarsOffice2013Theme, CXTPGridPaintManager, CXTPPropertyGridPaintManager, CXTPTabBaseThemeOffice2003
  • m_clrHighlightBorder : CXTPTaskPanelPaintManager
  • m_clrHighlightHot : CXTPTaskPanelPaintManager
  • m_clrHighlightPressed : CXTPTaskPanelPaintManager
  • m_clrHighlightSelected : CXTPTaskPanelPaintManager
  • m_clrHighLightText : CXTPSyntaxEditAutoCompleteWnd
  • m_clrHighlightText : CXTPGridPaintManager, CXTPPropertyGridPaintManager
  • m_clrHighlightToday : CXTPDatePickerPaintManager
  • m_clrHotDivider : CXTPGridPaintManager
  • m_clrHotText : CXTPPopupItem, CXTPShortcutBarPaintManager
  • m_clrHour : CXTPCalendarPaintManager
  • m_clrHover : CXTPHyperLink
  • m_clrInactiveBack : CXTPCommandBarsNativeWindows11Theme
  • m_clrIndentControl : CXTPGridPaintManager
  • m_clrInfoBack : CXTPMessageBarPaintManager
  • m_clrInterlacedColor : CXTPChartAxis
  • m_clrInterlacedColor2 : CXTPChartAxis
  • m_clrItem : CXTPTabManagerItem
  • m_clrItemBack : CXTPListBoxThemeOffice2013
  • m_clrItemBackHighlight : CXTPListBoxThemeOffice2013
  • m_clrItemBackSelected : CXTPListBoxThemeOffice2013
  • m_clrItemBorder : CXTPListBoxThemeOffice2013
  • m_clrItemBorderHighlight : CXTPListBoxThemeOffice2013
  • m_clrItemBorderSelected : CXTPListBoxThemeOffice2013
  • m_clrItemCaptionShadow : CXTPShortcutBarOffice2003Theme
  • m_clrItemCaptionText : CXTPShortcutBarOffice2003Theme
  • m_clrItemCaptionTop : CXTPShortcutBarOffice2003Theme
  • m_clrItemShade : CXTPGridPaintManager
  • m_clrItemTab : CXTPDockingPane
  • m_clrItemText : CXTPListBoxThemeOffice2013
  • m_clrItemTextHighlight : CXTPListBoxThemeOffice2013
  • m_clrItemTextSelected : CXTPListBoxThemeOffice2013
  • m_clrLightAmbientColor : CXTPChart3dDeviceContext
  • m_clrLightDiffuseColor : CXTPChart3dDeviceContext
  • m_clrLightModelAmbientColor : CXTPChart3dDeviceContext
  • m_clrLightSpecularColor : CXTPChart3dDeviceContext
  • m_clrLine : CXTPPropertyGridItemMetrics
  • m_clrLineColor : CXTPChartSeriesLabel
  • m_clrLink : CXTPHyperLink
  • m_clrListControlBack : CXTPDatePickerPaintManager
  • m_clrListControlText : CXTPDatePickerPaintManager
  • m_clrMarker : CXTPTrackPaintManager
  • m_clrMarkerBack : CXTPTrackPaintManager
  • m_clrMarkerBorder : CXTPTrackPaintManager
  • m_clrMaterialDiffuseColor : CXTPChart3dDeviceContext
  • m_clrMaterialEmissionColor : CXTPChart3dDeviceContext
  • m_clrMaterialSpecularColor : CXTPChart3dDeviceContext
  • m_clrMenuExpand : CXTPCommandBarsOffice2003Theme
  • m_clrMenuExpandedGripper : CXTPCommandBarsOffice2003Theme
  • m_clrMenuGripper : CXTPCommandBarsOffice2003Theme
  • m_clrMenuPopupGripperShadow : CXTPRibbonTheme
  • m_clrMenuPopupSeparator : CXTPRibbonTheme
  • m_clrMenuSelection : CXTPVisualStudio2008Theme
  • m_clrMenuSelectionBorder : CXTPVisualStudio2008Theme
  • m_clrMenuSelectionText : CXTPVisualStudio2008Theme
  • m_clrMessageBarText : CXTPCommandBarsOffice2013Theme, CXTPPaintManager
  • m_clrMinimizedFrameEdgeHighLight : CXTPRibbonPaintManager
  • m_clrMinimizedFrameEdgeShadow : CXTPRibbonPaintManager
  • m_clrMinorColor : CXTPChartAxisGridLines
  • m_clrMonthBorder : CXTPDatePickerPaintManager
  • m_clrMonthHeaderBack : CXTPDatePickerPaintManager
  • m_clrMonthHeaderButton : CXTPDatePickerPaintManager
  • m_clrMonthHeaderText : CXTPDatePickerPaintManager
  • m_clrMultiDayEventFrameColor : CXTPCalendarPaintManager
  • m_clrNavigateButtonBorder : CXTPTabColorSetOffice2003
  • m_clrNew : CXTPColorDialog
  • m_clrNode : CXTPFlowGraphNode
  • m_clrNodeBackground : CXTPFlowGraphPaintManager
  • m_clrNonHighlightBack : CXTPPropertyGridPaintManager
  • m_clrNonHighlightText : CXTPPropertyGridPaintManager
  • m_clrNonMonthDayBack : CXTPDatePickerPaintManager
  • m_clrNonMonthDayText : CXTPDatePickerPaintManager
  • m_clrNormal : CXTPScrollBarThemeOffice2013
  • m_clrNormalCaption : CXTPDockingPanePaintManager
  • m_clrNormalCaptionText : CXTPDockingPanePaintManager
  • m_clrNormalText : CXTPShortcutBarPaintManager, CXTPTabBaseTheme
  • m_clrOutline : CXTPColorSetCaptionButton
  • m_clrPaneFace : CXTPTabPaintManagerColorSet
  • m_clrPoint : CXTPFlowGraphConnectionPoint
  • m_clrPopupControl : CXTPCommandBarsOffice2003Theme
  • m_clrPressed : CXTPScrollBarThemeOffice2013
  • m_clrPressedText : CXTPCommandBarsNativeXPTheme
  • m_clrPreviewText : CXTPGridPaintManager
  • m_clrPushedText : CXTPShortcutBarPaintManager
  • m_clrReadOnlyFore : CXTPPropertyGridItemMetrics
  • m_clrRecentFileListEdgeHighLight : CXTPRibbonPaintManager
  • m_clrRecentFileListEdgeShadow : CXTPRibbonPaintManager
  • m_clrRibbonBorder : CXTPRibbonPaintManager
  • m_clrRibbonFace : CXTPRibbonPaintManager
  • m_clrRibbonGrayText : CXTPRibbonTheme
  • m_clrRibbonGroupCaptionText : CXTPRibbonPaintManager
  • m_clrRibbonInactiveFace : CXTPRibbonPaintManager
  • m_clrRibbonInactiveFaceState : CXTPRibbonOffice2013Theme
  • m_clrRibbonTabDelimeter : CXTPRibbonOffice2013Theme
  • m_clrRibbonText : CXTPRibbonTheme
  • m_clrScrollBarBorderDark : CXTPTrackPaintManager
  • m_clrScrollBarBorderLight : CXTPTrackPaintManager
  • m_clrScrollBarDark : CXTPTrackPaintManager
  • m_clrScrollBarLight : CXTPTrackPaintManager
  • m_clrScrollDateBarBk : CXTPCalendarCaptionBarPaintManager
  • m_clrScrollTriangleColor : CXTPCalendarCaptionBarPaintManager
  • m_clrSelected : CXTPColorPicker, CXTPScrollBarThemeOffice2013
  • m_clrSelectedArea : CXTPTrackPaintManager
  • m_clrSelectedBackground : CXTPCalendarPaintManager, CXTPCalendarTimeLineView
  • m_clrSelectedBorder : CXTPTrackThemeOffice2013
  • m_clrSelectedDayBack : CXTPDatePickerPaintManager
  • m_clrSelectedDayText : CXTPDatePickerPaintManager
  • m_clrSelectedRow : CXTPGridPaintManager
  • m_clrSelectedRowText : CXTPGridPaintManager
  • m_clrSelectedText : CXTPCalendarPaintManager, CXTPCalendarTimeLineView, CXTPCommandBarsNativeXPTheme, CXTPShortcutBarPaintManager, CXTPTaskPanelVisualStudio2012Theme
  • m_clrSelectedTextWithoutFocus : CXTPTaskPanelVisualStudio2012Theme
  • m_clrSelectedWithoutFocus : CXTPTaskPanelVisualStudio2012Theme
  • m_clrSelection : CXTPFlowGraphPaintManager
  • m_clrSelectionInactive : CXTPFlowGraphPaintManager
  • m_clrShadow : CXTPCalendarPaintManager, CXTPPropertyGridPaintManager, CXTPTabBaseThemeOffice2003
  • m_clrShortcutItemShadow : CXTPShortcutBarPaintManager, CXTPTaskPanelShortcutBarOffice2007Theme
  • m_clrSplitter : CXTPDockingPaneColorSet, CXTPDockingPanePaintManager, CXTPPropertyGridPaintManager
  • m_clrSplitterGradient : CXTPDockingPanePaintManager
  • m_clrSplitterGripper : CXTPDockingPanePaintManager
  • m_clrStandardValue : CXTPPaintManagerColor
  • m_clrStaticBorder : CXTPDatePickerPaintManager
  • m_clrSwitchViewBarBk : CXTPCalendarCaptionBarPaintManager
  • m_clrTabBackackstageLeft : CXTPRibbonOffice2013Theme
  • m_clrTabBackackstageRight : CXTPRibbonOffice2013Theme
  • m_clrTabBackInactiveState : CXTPRibbonOffice2013Theme
  • m_clrTabClientBack : CXTPTabPaintManagerColorSet
  • m_clrTabClientBorder : CXTPTabPaintManagerColorSet
  • m_clrTearOffGripper : CXTPCommandBarsOffice2003Theme
  • m_clrText : CXTPCalendarPaintManager, CXTPCalendarTimeLineView, CXTPCaption, CXTPComboBoxTheme, CXTPDockingPaneColorSet, CXTPEditTheme, CXTPGridInplaceEdit, CXTPGridRecordItem, CXTPMessageBarPaintManager, CXTPPopupItem, CXTPPopupPaintManager, CXTPProgressCtrlPaintManager, CXTPStatusBarPane, CXTPTagCloudStyle, CXTPTaskPanelGroupItem, CXTPTaskPanelVisualStudio2012Theme
  • m_clrTextColor : CXTPCalendarCaptionBarPaintManager, CXTPCalendarCaptionBarThemePart, CXTPCalendarViewPart, CXTPChartAxisConstantLine, CXTPChartAxisLabel, CXTPChartAxisTitle, CXTPChartLegend, CXTPChartSeriesLabel, CXTPChartTitle, CXTPFlowGraphPaintManager
  • m_clrTextColorSelected : CXTPFlowGraphPaintManager
  • m_clrTextDisabled : CXTPComboBoxTheme, CXTPTabPaintManagerColorSet
  • m_clrTextGray : CXTPStatusBarPane
  • m_clrTextHighlight : CXTPComboBoxTheme, CXTPTabPaintManagerColorSet
  • m_clrTextHighlightClose : CXTPTabPaintManagerColorSet
  • m_clrTextHighLightColor : CXTPCalendarPaintManager
  • m_clrTextHilite : CXTPMessageBarThemeOffice2010, CXTPMessageBarThemeOffice2013
  • m_clrTextHover : CXTPTagCloudStyle
  • m_clrTextNormal : CXTPTabPaintManagerColorSet
  • m_clrTextNormalColor : CXTPCalendarPaintManager
  • m_clrTextPressed : CXTPTabPaintManagerColorSet
  • m_clrTextReadOnly : CXTPEditTheme
  • m_clrTextSelected : CXTPTabPaintManagerColorSet
  • m_clrTextSelectedHighlighted : CXTPTabPaintManagerColorSet
  • m_clrTextSelectedPressed : CXTPTabPaintManagerColorSet
  • m_clrTheme : CXTPSkinManagerMetrics
  • m_clrTimeHeaderBorder : CXTPTrackPaintManager
  • m_clrTimeHeaderDark : CXTPTrackPaintManager
  • m_clrTimeHeaderDarkDark : CXTPTrackPaintManager
  • m_clrTimeHeaderDivider : CXTPTrackPaintManager
  • m_clrTimeLinePosition : CXTPTrackPaintManager
  • m_clrTimeLineTick : CXTPTrackPaintManager
  • m_clrTimeScaleBackground : CXTPCalendarPaintManager, CXTPCalendarTimeLineView
  • m_clrTimeScaleBorder : CXTPCalendarTimeLineView
  • m_clrTimeScaleHighlight : CXTPCalendarTimeLineView
  • m_clrTimeScaleHightlite : CXTPCalendarPaintManager
  • m_clrTimeScaleText : CXTPCalendarPaintManager, CXTPCalendarTimeLineView
  • m_clrTimeSliderBackground : CXTPTrackPaintManager
  • m_clrTipBkColor : CXTPToolTipContext
  • m_clrTipTextColor : CXTPToolTipContext
  • m_clrToolbarExpand : CXTPCommandBarsOffice2003Theme
  • m_clrToolbarShadow : CXTPCommandBarsOffice2003Theme
  • m_clrTrackHeader : CXTPTrackPaintManager
  • m_clrTrackMarkerBorder : CXTPTrackPaintManager
  • m_clrTrackMarkerText : CXTPTrackPaintManager
  • m_clrTrackMarkerTextBack : CXTPTrackPaintManager
  • m_clrTrackMarkerTextBorder : CXTPTrackPaintManager
  • m_clrTrackTimeArea : CXTPTrackPaintManager
  • m_clrUnderLineHdr : CXTPCalendarPaintManager
  • m_clrUpColor : CXTPChartHighLowSeriesStyle
  • m_clrValue : CXTPPropertyGridItemColor, CXTPPropertyGridItemFont
  • m_clrValues : CXTPSyntaxEditPaintManager
  • m_clrVerbFace : CXTPPropertyGridItemMetrics
  • m_clrVisited : CXTPHyperLink
  • m_clrWeekendBackground : CXTPCalendarPaintManager, CXTPCalendarTimeLineView
  • m_clrWeekNumbersBack : CXTPDatePickerPaintManager
  • m_clrWeekNumbersText : CXTPDatePickerPaintManager
  • m_clrWindow : CXTPCalendarPaintManager, CXTPExcelTabCtrlTheme, CXTPSyntaxEditAutoCompleteWnd
  • m_clrWindowText : CXTPCalendarPaintManager, CXTPExcelTabCtrlTheme, CXTPGridPaintManager, CXTPSyntaxEditAutoCompleteWnd
  • m_clrWorkArea : CXTPTrackPaintManager
  • m_clrWorkAreaScrollBarBorder : CXTPTrackPaintManager
  • m_clrWorkAreaScrollBarDark : CXTPTrackPaintManager
  • m_clrWorkAreaScrollBarLight : CXTPTrackPaintManager
  • m_clrWorkspace : CXTPCommandBarsOffice2013Theme
  • m_cmbCategories : CXTPRibbonCustomizePage
  • m_cmbTabGroup : CXTPRibbonCustomizePage
  • m_cntSelChanged : CXTPCalendarView
  • m_cntViewChanged : CXTPCalendarControl
  • m_Color : CXTPCalendarResource
  • m_color : CXTPChart3dLineDeviceCommand, CXTPChartBoundedCircleDeviceCommand, CXTPChartBoundedPolygonDeviceCommand, CXTPChartLineDeviceCommand, CXTPChartMarkupElementDeviceCommand, CXTPChartSolidSplinePolygonDeviceCommand, CXTPChartTextDeviceCommand, CXTPColorHex::CRgnCell, CXTPEyeDropper
  • m_colorEditor : CXTPPropertyGridItemColor
  • m_colorHex : CXTPColorPageStandard
  • m_columnStyle : CXTPGridPaintManager
  • m_comboAnimationType : CXTPCustomizeOptionsPage
  • m_comboCategory : CXTPCustomizeKeyboardPage
  • m_comboStyle : CXTPControlComboBox
  • m_CommandList : CXTPSyntaxEditBatchCommand, CXTPSyntaxEditUndoRedoManager
  • m_config : CXTPTaskDialog
  • m_controlType : CXTPControl
  • m_cr3DDkShadow : CXTPHeaderCtrlTheme
  • m_cr3DFace : CXTPHeaderCtrlTheme
  • m_cr3DHighLight : CXTPHeaderCtrlTheme, CXTPTaskDialogClient
  • m_cr3DLight : CXTPTaskDialogClient
  • m_cr3DShadow : CXTPHeaderCtrlTheme, CXTPTaskDialogClient
  • m_crArrowDisabled : CXTPSpinButtonCtrl
  • m_crArrowEnabled : CXTPSpinButtonCtrl
  • m_crArrowHilite : CXTPSpinButtonCtrl
  • m_crArrowPushed : CXTPSpinButtonCtrl
  • m_crBack : CXTPButtonTheme, CXTPColorSelectorCtrlTheme, CXTPHexEdit, CXTPScrollBarPaintManager, CXTPSpinButtonCtrl, CXTPSplitterWndTheme, CXTPTaskDialogLinkCtrl, CXTPTreeTheme
  • m_crBackChecked : CXTPButtonThemeUltraFlat, CXTPColorSelectorCtrlTheme
  • m_crBackColor : CXTPTipWindow
  • m_crBackDisabled : CXTPButtonThemeOffice2013, CXTPSpinButtonCtrl, CXTPTreeTheme
  • m_crBackHilight : CXTPColorSelectorCtrlTheme
  • m_crBackHilite : CXTPButtonThemeUltraFlat, CXTPScrollBarPaintManager, CXTPSpinButtonCtrl
  • m_crBackPressed : CXTPColorSelectorCtrlTheme
  • m_crBackPushed : CXTPButtonThemeUltraFlat, CXTPScrollBarPaintManager, CXTPSpinButtonCtrl
  • m_crBackSelected : CXTPTreeTheme
  • m_crBackSelectedDisabled : CXTPTreeTheme
  • m_crBackSelectedInactive : CXTPTreeTheme
  • m_crBorder : CXTPButtonThemeOffice2013, CXTPColorSelectorCtrlTheme, CXTPScrollBarPaintManager, CXTPSpinButtonCtrl
  • m_crBorder3DHilite : CXTPButtonTheme
  • m_crBorder3DShadow : CXTPButtonTheme
  • m_crBorderDefault : CXTPButtonThemeOffice2013
  • m_crBorderDisabled : CXTPButtonThemeOffice2013, CXTPSpinButtonCtrl
  • m_crBorderHilight : CXTPColorSelectorCtrlTheme
  • m_crBorderHilite : CXTPButtonTheme, CXTPScrollBarPaintManager, CXTPSpinButtonCtrl
  • m_crBorderInside : CXTPColorSelectorCtrlThemeOffice2013
  • m_crBorderPressed : CXTPColorSelectorCtrlTheme
  • m_crBorderPushed : CXTPButtonThemeUltraFlat, CXTPSpinButtonCtrl
  • m_crBorderShadow : CXTPButtonTheme
  • m_crBoxBack : CXTPSplitterWndTheme
  • m_crCheckMark : CXTPButtonThemeUltraFlat
  • m_crCompColor : CXTPShellSettings
  • m_crContent : CXTPTaskDialogClient
  • m_crContentText : CXTPTaskDialogClient
  • m_crDisabledBack : CXTPHexEdit
  • m_crDisabledHighlightBack : CXTPHexEdit
  • m_crDisabledHighlightText : CXTPHexEdit
  • m_crDisabledText : CXTPHexEdit
  • m_crEncrColor : CXTPShellSettings
  • m_crFooter : CXTPTaskDialogClient
  • m_crFooterText : CXTPTaskDialogClient
  • m_crgBack : CXTPHeaderCtrlThemeResource, CXTPShortcutListBoxTheme
  • m_crgBackPressed : CXTPHeaderCtrlThemeResource
  • m_crgItemBackHot : CXTPShortcutListBoxTheme
  • m_crgItemBackPressed : CXTPShortcutListBoxTheme
  • m_crgItemBorder : CXTPShortcutListBoxTheme
  • m_crHighlightBack : CXTPHexEdit
  • m_crHighlightText : CXTPHexEdit
  • m_crInnerBorder : CXTPSplitterWndTheme
  • m_crInnerBoxBorder : CXTPSplitterWndTheme
  • m_crItemText : CXTPShortcutListBoxTheme
  • m_crItemTextDisabled : CXTPShortcutListBoxTheme
  • m_crListBack : CXTPListBase
  • m_crListText : CXTPListBase
  • m_crlNoGroupByText : CXTPGridPaintManager
  • m_crMainText : CXTPTaskDialogClient
  • m_crMark : CXTPButtonThemeOffice2013
  • m_crMarkDisabled : CXTPButtonThemeOffice2013
  • m_crMarkHilite : CXTPButtonThemeOffice2013
  • m_crMarkPushed : CXTPButtonThemeOffice2013
  • m_crOuterBorder : CXTPSplitterWndTheme
  • m_crOuterBoxBorder : CXTPSplitterWndTheme
  • m_crPopupBorder : CXTPColorSelectorCtrlTheme
  • m_crSortBack : CXTPListBase
  • m_crSortText : CXTPListBase
  • m_crText : CXTPButtonTheme, CXTPColorSelectorCtrlTheme, CXTPHeaderCtrlTheme, CXTPHexEdit, CXTPTaskDialogLinkCtrl, CXTPTreeTheme
  • m_crTextCheck : CXTPButtonTheme
  • m_crTextColor : CXTPTipWindow
  • m_crTextDisabled : CXTPButtonTheme, CXTPTreeTheme
  • m_crTextHilite : CXTPButtonThemeUltraFlat
  • m_crTextLink : CXTPTaskDialogLinkCtrl
  • m_crTextPressed : CXTPColorSelectorCtrlTheme
  • m_crTextPushed : CXTPButtonThemeUltraFlat
  • m_crTextSelected : CXTPTreeTheme
  • m_crTextSelectedDisabled : CXTPTreeTheme
  • m_crTextSelectedInactive : CXTPTreeTheme
  • m_crTitleBack : CXTPColorSelectorCtrlThemeOffice2013
  • m_crTitleText : CXTPColorSelectorCtrlThemeOffice2013
  • m_cs : CXTPImageManagerResource, CXTPResourceImages
  • m_csCaptionButtonHot : CXTPDockingPaneColorSet
  • m_csCaptionButtonNormal : CXTPDockingPaneColorSet
  • m_csCaptionButtonPressed : CXTPDockingPaneColorSet
  • m_csCheckBox : CXTPCommandBarsOffice2013Theme
  • m_csCheckMark : CXTPCommandBarsOffice2013Theme
  • m_csComboBox : CXTPCommandBarsOffice2013Theme
  • m_csExcelNormal : CXTPTabPaintManagerColorSet
  • m_csExcelSelected : CXTPTabPaintManagerColorSet
  • m_csFindText : CXTPSyntaxEditFindReplaceDlg
  • m_csIncludeEXT : CXTPShellListBase
  • m_csMenu : CXTPCommandBarsOffice2013Theme
  • m_csMenuTitleBar : CXTPCommandBarsOffice2013Theme
  • m_csObjects : CXTPSkinManager
  • m_csPropertyPage : CXTPTabPaintManagerColorSet
  • m_csPropertyPage2003 : CXTPTabPaintManagerColorSet
  • m_csReplaceText : CXTPSyntaxEditFindReplaceDlg
  • m_csRibbon : CXTPCommandBarsOffice2013Theme
  • m_csStateButton : CXTPTabPaintManagerColorSet
  • m_csSymbol : CXTPFontCtrlBase
  • m_csToolbar : CXTPCommandBarsOffice2013Theme
  • m_cThumb : CXTPScrollBarPaintManager
  • m_ctrl3SmallCal : CXTPCalendarPageSetupDialog
  • m_ctrlBlackWhitePrinting : CXTPCalendarPageSetupDialog
  • m_ctrlDateHeaderFont : CXTPCalendarPageSetupDialog
  • m_ctrlDateHeaderFontButton : CXTPCalendarPageSetupDialog
  • m_ctrlDateHeaderFontLabel : CXTPCalendarPageSetupDialog
  • m_ctrlDescription : CXTPCalendarRemindersDialog
  • m_ctrlDismissAllBtn : CXTPCalendarRemindersDialog
  • m_ctrlDismissBtn : CXTPCalendarRemindersDialog
  • m_ctrlFooterFormat : CXTPCalendarPageSetupDialog
  • m_ctrlFooterFormatBtn : CXTPCalendarPageSetupDialog
  • m_ctrlHeaderFormat : CXTPCalendarPageSetupDialog
  • m_ctrlHeaderFormatBtn : CXTPCalendarPageSetupDialog
  • m_ctrlIcon : CXTPCalendarOccurSeriesChooseDlg
  • m_ctrlMessage : CXTPCalendarOccurSeriesChooseDlg
  • m_ctrlMonthViewPrintFrom : CXTPCalendarPageSetupDialog
  • m_ctrlMonthViewPrintRange : CXTPCalendarPageSetupDialog
  • m_ctrlMonthViewPrintTo : CXTPCalendarPageSetupDialog
  • m_ctrlOccur : CXTPCalendarOccurSeriesChooseDlg
  • m_ctrlOpenItemBtn : CXTPCalendarRemindersDialog
  • m_ctrlPrintDateHeader : CXTPCalendarPageSetupDialog
  • m_ctrlPrintFromCmb : CXTPCalendarPageSetupDialog
  • m_ctrlPrintFromTo : CXTPCalendarPageSetupDialog
  • m_ctrlPrintToCmb : CXTPCalendarPageSetupDialog
  • m_ctrlRemindersList : CXTPCalendarRemindersDialog
  • m_ctrlScheduleIDCB : CXTPCalendarEventPropertiesDlg
  • m_ctrlScheduleLabel : CXTPCalendarEventPropertiesDlg
  • m_ctrlScheduleSet : CXTPCalendarEventPropertiesDlg
  • m_ctrlSeries : CXTPCalendarOccurSeriesChooseDlg
  • m_ctrlSnoozeBtn : CXTPCalendarRemindersDialog
  • m_ctrlSnoozeTimeCB : CXTPCalendarRemindersDialog
  • m_CurrSystemTheme : CXTPCalendarPaintManager
  • m_cx : CXTPExcelTabCtrl
  • m_cxBorder : CXTPSkinManagerMetrics
  • m_cxChunk : CXTPMarqueeCtrl
  • m_cxEdge : CXTPSkinManagerMetrics
  • m_cxHScroll : CXTPScrollBarPaintManager, CXTPSkinManagerMetrics
  • m_cxIcon : CXTPShortcutListBoxTheme
  • m_cxOsVScroll : CXTPSkinManagerMetrics
  • m_cxPaneSpacing : CXTPStatusBar
  • m_cxPixelsPerInch : CXTPPreviewView
  • m_cxPopup : CXTPControlGalleryPaintManager
  • m_cxText : CXTPStatusBarPane
  • m_cxVScroll : CXTPScrollBarPaintManager, CXTPSkinManagerMetrics
  • m_cy : CXTPExcelTabCtrl
  • m_cyBorder : CXTPSkinManagerMetrics
  • m_cyCaption : CXTPSkinManagerMetrics
  • m_cyEdge : CXTPShortcutListBoxTheme, CXTPSkinManagerMetrics
  • m_cyHScroll : CXTPScrollBarPaintManager, CXTPSkinManagerMetrics
  • m_cyIcon : CXTPShortcutListBoxTheme
  • m_cyOsCaption : CXTPSkinManagerMetrics
  • m_cyOsSmallCaption : CXTPSkinManagerMetrics
  • m_cyPixelsPerInch : CXTPPreviewView
  • m_cyPopupDown : CXTPControlGalleryPaintManager
  • m_cyPopupUp : CXTPControlGalleryPaintManager
  • m_cyProgress : CXTPProgressPaintManager
  • m_cySmallCaption : CXTPSkinManagerMetrics
  • m_cyText : CXTPCheckListBox
  • m_cyTopBorderGap : CXTPSplitterWndEx
  • m_cyVScroll : CXTPScrollBarPaintManager, CXTPSkinManagerMetrics
  • m_Daily : XTP_CALENDAR_RECURRENCE_OPTIONS
  • m_dAnimationDelay : CXTPDockingPaneAutoHideWnd
  • m_dAnimationStep : CXTPControlGallery
  • m_dArea : CXTPChartEllipse
  • m_dArgument : CXTPChartSeriesPoint
  • m_DataLockerCS : CXTPNotifyConnectionMT
  • m_dAxisMaxValue : CXTPChartAxisStrip
  • m_dAxisMinValue : CXTPChartAxisStrip
  • m_DayPOS_LastSelected : CXTPCalendarMonthView
  • m_dc : CXTPImageManagerResource
  • m_dCorrectedDepth : CXTPChartPieDeviceCommandImpl
  • m_dDepth : CXTPChartPieDeviceCommandImpl
  • m_dDisabledAlphaFactor : CXTPImageManager
  • m_dDisabledBrightnessFactor : CXTPImageManager
  • m_dDivider : CXTPPropertyGridView
  • m_dEPS : CXTPMathUtils
  • m_depth : CXTPChartPieBase
  • m_dFacetSize : CXTPChartPieDeviceCommandImpl
  • m_dGridSpacing : CXTPChartAxis
  • m_dHeightPercent : CXTPTrackBlock
  • m_dHolePercent : CXTPChartPieDeviceCommandImpl
  • m_dInnerMajorSemiAxis : CXTPChartPieDeviceCommandImpl
  • m_dInnerMinorSemiAxis : CXTPChartPieDeviceCommandImpl
  • m_dInnerRadius : CXTPChartPieDeviceCommandImpl
  • m_dInternalArgument : CXTPChartSeriesPoint
  • m_dInternalValue : CXTPChartSeriesPointView
  • m_direction : CXTPDockingPaneAutoHidePanel, CXTPDockingPaneSidePanel
  • m_dividerPosition : CXTPGridSection
  • m_dividerStyle : CXTPGridSection
  • m_dLineAngle : CXTPChartPieSeriesLabelView
  • m_dLogarithmicBase : CXTPChartAxis
  • m_dMajorSemiAxis : CXTPChartPieDeviceCommandImpl
  • m_dMajorSemiaxis : CXTPChartEllipse
  • m_dMaxAlpha : CXTPCalendarShadowDrawer
  • m_dMaxValue : CXTPChartNumericalScaleTypeMap, CXTPChartQualitativeScaleTypeMap
  • m_dMaxWidthDivisor : CXTPPopupBar
  • m_dMaxZoom : CXTPFlowGraphControl
  • m_dMinorSemiAxis : CXTPChartPieDeviceCommandImpl
  • m_dMinorSemiaxis : CXTPChartEllipse
  • m_dMinValue : CXTPChartNumericalScaleTypeMap, CXTPChartQualitativeScaleTypeMap
  • m_dMinZoom : CXTPFlowGraphControl
  • m_dMinZoomLevelBackground : CXTPFlowGraphPaintManager
  • m_dMinZoomLevelConnectionPoints : CXTPFlowGraphPaintManager
  • m_dMinZoomLevelConnections : CXTPFlowGraphPaintManager
  • m_dMinZoomLevelGDIQuality : CXTPFlowGraphPaintManager
  • m_dNewEventID : CXTPCalendarEventPropertiesDlg
  • m_Down : CXTPPreviewView
  • m_dPI : CXTPMathUtils
  • m_dPitch : CXTPChart3dRotation
  • m_dRadius : CXTPChartPieDeviceCommandImpl
  • m_dragMode : CXTPGridHeader
  • m_dRoll : CXTPChart3dRotation
  • m_dropTarget : CXTPSyntaxEditView
  • m_dScale : CXTPCalendarCaptionBarTheme
  • m_dStartAngle : CXTPChartPieBase, CXTPChartPieDeviceCommandImpl
  • m_dSweepAngle : CXTPChartPieBase, CXTPChartPieDeviceCommandImpl
  • m_dtBeginDate : CXTPCalendarMonthView::CMonthViewGrid, CXTPCalendarWeekView
  • m_dtCreationTime : CXTPCalendarEvent
  • m_dtDate : CXTPCalendarViewDay
  • m_dtDay : CXTPDatePickerItemDay
  • m_dtEnd : CXTPCalendarEventRecurrenceDlg
  • m_dtEndDate : CXTPCalendarEventPropertiesDlg, CXTPCalendarEventRecurrenceDlg
  • m_dtEndTime : CXTPCalendarEvent, CXTPCalendarEventPropertiesDlg
  • m_dtEventStartTime : CXTPCalendarReminder
  • m_dtFirstClicked : CXTPDatePickerControl
  • m_dtFirstMonth : CXTPDatePickerControl
  • m_dtFocused : CXTPDatePickerControl
  • m_dtFSelBase : CXTPDatePickerControl
  • m_dtLastClicked : CXTPDatePickerControl
  • m_dtLastModificationTime : CXTPCalendarEvent
  • m_dtLastUpdateTime : CXTPCalendarRemindersManager
  • m_dtLightColorDateBase : CXTPCalendarMonthView
  • m_dtMaxRange : CXTPDatePickerControl
  • m_dtMiddleMonth : CXTPDatePickerList
  • m_dtMinRange : CXTPDatePickerControl
  • m_dtMonth : CXTPDatePickerItemMonth
  • m_dtMonthViewPrintBeginDate : CXTPCalendarControlViewPrintOptions
  • m_dtMonthViewPrintEndDate : CXTPCalendarControlViewPrintOptions
  • m_dtNextReminderTime : CXTPCalendarReminder
  • m_dtOccurrenceEndTime : CXTPCalendarReminder::RecurrenceEventInfo
  • m_dtOccurrenceStartTime : CXTPCalendarReminder::RecurrenceEventInfo
  • m_dtPatternEndDate : XTP_CALENDAR_PATTERN_END
  • m_dtPrintFrom : CXTPCalendarControlView, CXTPCalendarControlViewPrintOptions
  • m_dtPrintTo : CXTPCalendarControlView, CXTPCalendarControlViewPrintOptions
  • m_dtRException_EndTimeOrig : CXTPCalendarEvent
  • m_dtRException_StartTimeOrig : CXTPCalendarEvent
  • m_dtSelMonth : CXTPDatePickerList
  • m_dtStart : CXTPCalendarEventRecurrenceDlg
  • m_dtStartDate : CXTPCalendarEventPropertiesDlg, CXTPCalendarEventRecurrenceDlg
  • m_dtStartMonth : CXTPDatePickerList
  • m_dtStartTime : CXTPCalendarEvent, CXTPCalendarEventPropertiesDlg
  • m_dtStartViewDate : CXTPCalendarTimeLineViewTimeScale
  • m_dtTimeScaleMax : CXTPCalendarDayView
  • m_dtTimeScaleMin : CXTPCalendarDayView
  • m_dtTimeScaleOldMaxTime : CXTPCalendarControlView
  • m_dtTimeScaleOldMinTime : CXTPCalendarControlView
  • m_dtToday : CXTPDatePickerControl
  • m_dValue : CXTPChartAxisViewTick, CXTPChartFunnelSeriesPointViewBase, CXTPChartPyramidSeriesPointViewBase, CXTPChartRadarAxisXViewTick, CXTPChartRadarAxisYViewTick, CXTPGridRecordItemNumber
  • m_dValues : CXTPChartSeriesPoint
  • m_dwAlign : CXTPCommandBarKeyboardTip
  • m_dwApplyOptions : CXTPSkinManager
  • m_dwAskItemTextFlags : CXTPCalendarPaintManager
  • m_dwAutoScrollDirection : CXTPSyntaxEditCtrl
  • m_dwBaseAddress : CXTPHexEdit
  • m_dwBStyle : CXTPBrowseButton, CXTPBrowseEdit
  • m_dwComCtlVersion : CXTPToolTipContext
  • m_dwComCtrl : CXTPSkinManager
  • m_dwCommandBarID : CXTPControlPopup
  • m_dwData : CXTPCommandBar, CXTPControlGalleryItem, CXTPDockingPane, CXTPGridRecordItem, CXTPGridRecordItemConstraint, CXTPPropertyGridItem, CXTPPropertyGridItemConstraint, CXTPPropertyPage, CXTPPropExchange, CXTPShortcutBarItem, CXTPTabManagerItem, CXTPTaskPanelItem
  • m_dwDefaultPaneOptions : CXTPDockingPaneManager
  • m_dwDialogTexture : CXTPSkinObjectFrame
  • m_dwDragDropFlags : CXTPGridControl
  • m_dwDrawStyle : CXTPHeaderCtrlTheme
  • m_dwDropMarkerFlags : CXTPGridControl
  • m_dwEditReparceTimeout_ms : CXTPSyntaxEditLexParserSchemaOptions
  • m_dwEditStyle : CXTPControlComboBox, CXTPControlEdit, CXTPGridRecordItemEditOptions, CXTPPropertyGridItem
  • m_dwEventID : CXTPCalendarEvent
  • m_dwExStyle : CXTPCaption, CXTPSkinObjectFrame
  • m_dwFlags : CXTPBrowseEdit, CXTPCommandBar, CXTPControl, CXTPTabClientWnd, CXTPTabManagerNavigateButton
  • m_dwHideFlags : CXTPControl, CXTPStatusBarPane
  • m_dwIdx : CXTPSyntaxEditTipListBox
  • m_dwIndex : CXTPCalendarTimeZone
  • m_dwInitSignature : CXTPMDIWndTab
  • m_dwInsertPos : CXTPSyntaxEditCtrl
  • m_dwLastRedrawTime : CXTPSyntaxEditCtrl
  • m_dwLastTip : CXTPToolTipContextToolTip
  • m_dwLStyle : CXTPEditListBox
  • m_dwMasterEventID : CXTPCalendarReminder::RecurrenceEventInfo
  • m_dwMaxBackParseOffset : CXTPSyntaxEditLexParserSchemaOptions
  • m_dwMonitorEvents : CXTPDirWatcher
  • m_dwNormalEventID : CXTPCalendarReminder
  • m_dwOnScreenSchCacheLifeTime_sec : CXTPSyntaxEditLexParserSchemaOptions
  • m_dwOptions : CXTPDockingPane
  • m_dwParserThreadIdleLifeTime_ms : CXTPSyntaxEditLexParserSchemaOptions
  • m_dwPopup : CXTPColorPicker, CXTPColorSelectorCtrl
  • m_dwRecurrencePatternID : CXTPCalendarEvent
  • m_dwRecurrencePatternID_ToUse : CXTPCalendarEvent
  • m_dwRstEvent : CXTPGridDataManager
  • m_dwShellAutoCompleteFlags : CXTPControlComboBox, CXTPControlEdit
  • m_dwSliderStyle : CXTPControlSlider
  • m_dwSplitterStyle : CXTPDockingPanePaintManager
  • m_dwState : CXTPDockingPaneCaptionButton
  • m_dwStyle : CXTPColorDialog, CXTPCommandBar, CXTPDockBar, CXTPExcelTabCtrl, CXTPFontCtrlBase, CXTPSkinObjectFrame, CXTPToolTipContext
  • m_dwStyleListBox : CXTPControlFontComboBoxList
  • m_dwTag : CXTPFlowGraphNode
  • m_dwTipStyle : CXTPTipWindow
  • m_dwUpdateOptions : CXTPChartControl
  • m_dx : CXTPChart3dTranslateDeviceCommand, CXTPChartTranslateDeviceCommand
  • m_dy : CXTPChart3dTranslateDeviceCommand, CXTPChartTranslateDeviceCommand
  • m_dYaw : CXTPChart3dRotation
  • m_dz : CXTPChart3dTranslateDeviceCommand
  • m_dZoomLevel : CXTPFlowGraphPage
  • m_eAction : XTP_CALENDAR_USERACTION_PARAMS
  • m_eAnimation : CXTPTaskPanel
  • m_editGroup : CXTPEditListBox
  • m_editShortcutKey : CXTPCustomizeKeyboardPage
  • m_eDraggingMode : CXTPCalendarView
  • m_eEditMode : CXTPHexEdit
  • m_eEventType : CXTPCalendarReminder
  • m_eGripper : CXTPTaskPanelPaintManager
  • m_eHasFocus : CXTPColorBase
  • m_ellipse : CXTPChartPieBase
  • m_emptyLocker : CXTPNotifyConnection
  • m_eType : XTP_CALENDAR_TIMELINE_VIEW_SCALE
  • m_eUndoMode : CXTPCalendarView
  • m_EventTimeFormat : CXTPCalendarView
  • m_eViewType : CXTPCalendarControl
  • m_ExpandDayButton : XTP_CALENDAR_USERACTION_PARAMS
  • m_fAngle : CXTPChartRotateDeviceCommand, CXTPChartRotatedTextPainterBase
  • m_fcCollapsable : CXTPSyntaxEditCtrl
  • m_fChartBoxSize : CXTPChart3dDiagram
  • m_fcRowColors : CXTPSyntaxEditCtrl
  • m_fMaterialShininess : CXTPChart3dDeviceContext
  • m_fMaxModelDistance : CXTPChart3dDeviceContext, CXTPChart3dDiagram
  • m_fMinModelDistance : CXTPChart3dDeviceContext, CXTPChart3dDiagram
  • m_fntFrameCaption : CXTPFramePaintManager
  • m_fntScaleHeaderText : CXTPCalendarTimeLineViewTimeScalePart
  • m_fntText : CXTPCalendarViewPart
  • m_fntTextFont : CXTPCalendarCaptionBarPaintManager, CXTPDateLabelPart
  • m_fntTimeText : CXTPCalendarPaintManager
  • m_fontGroupCaption : CXTPRibbonPaintManager
  • m_fontIcon : CXTPPaintManager
  • m_fontIconBold : CXTPPaintManager
  • m_fontSmCaption : CXTPPaintManager
  • m_fontToolTip : CXTPPaintManager
  • m_fValue : CXTPPropertyGridItemDouble
  • m_grcButton : CXTPComboBoxTheme
  • m_grcButtonHilite : CXTPComboBoxTheme
  • m_grcButtonPushed : CXTPComboBoxTheme
  • m_grcCaption : CXTPShortcutBarOffice2003Theme
  • m_grcGradientColumn : CXTPGridPaintManager
  • m_grcGradientColumnHot : CXTPGridPaintManager
  • m_grcGradientColumnPushed : CXTPGridPaintManager
  • m_grcHot : CXTPShortcutBarPaintManager, CXTPTaskPanelListViewOffice2003Theme
  • m_grcItemCaption : CXTPShortcutBarOffice2003Theme
  • m_grcItemHotCaption : CXTPShortcutBarOffice2003Theme
  • m_grclrBackground : CXTPCalendarEventCategory
  • m_grclrBk : CXTPCalendarViewEventSubjectEditorColored
  • m_grclrClassicSelDay : CXTPCalendarPaintManager
  • m_grclrToday : CXTPCalendarPaintManager
  • m_grcLunaChecked : CXTPCommandBarsOffice2003Theme
  • m_grcLunaPushed : CXTPCommandBarsOffice2003Theme
  • m_grcLunaSelected : CXTPCommandBarsOffice2003Theme
  • m_grcPushed : CXTPShortcutBarPaintManager, CXTPTaskPanelListViewOffice2003Theme
  • m_grcSelected : CXTPShortcutBarPaintManager
  • m_grcShortcutBarGripper : CXTPShortcutBarPaintManager
  • m_grcShortcutItem : CXTPShortcutBarPaintManager
  • m_groupNormal : CXTPTaskPanelPaintManager
  • m_groupSpecial : CXTPTaskPanelPaintManager
  • m_hActiveChild : CXTPMDIWndTab
  • m_hBitmap : CXTPImageManagerIconHandle, CXTPSkinImage, CXTPTransparentBitmap
  • m_hbmLayer : CXTPResourceImages
  • m_hbmpImage : CXTPImageManagerResource
  • m_hbmpMask : CXTPImageManagerResource
  • m_hbmpWatermark : CXTPGridControl
  • m_hbrActiveTitleHorz : CXTPDockingPanePaintManager
  • m_hbrActiveTitleVert : CXTPDockingPanePaintManager
  • m_hbrInactiveTitleHorz : CXTPDockingPanePaintManager
  • m_hbrInactiveTitleVert : CXTPDockingPanePaintManager
  • m_hCurArrow : CXTPSyntaxEditPaintManager
  • m_hCurCopy : CXTPSyntaxEditPaintManager
  • m_hCurEyeDropper : CXTPEyeDropper
  • m_hcurHand : CXTPHyperLink, CXTPTaskDialogLinkCtrl
  • m_hCurIBeam : CXTPSyntaxEditPaintManager
  • m_hCurLine : CXTPSyntaxEditPaintManager
  • m_hCurMove : CXTPSyntaxEditPaintManager
  • m_hCurNO : CXTPSyntaxEditPaintManager
  • m_hCurPrevious : CXTPEyeDropper
  • m_hCursor : CXTPControlHyperlink, CXTPPropertyGridView, CXTPShortcutListBox, CXTPSizeIcon, CXTPTagCloudCtrl
  • m_hCursorBack : CXTPDatePickerPaintManager
  • m_hCursorDelete : CXTPTabClientWnd
  • m_hCursorHand : CXTPPropertyGrid
  • m_hCursorHoriz : CXTPTabClientWnd
  • m_hCursorNew : CXTPTabClientWnd
  • m_hCursorSplit : CXTPPropertyGrid
  • m_hCursorVert : CXTPTabClientWnd
  • m_hDC : CXTPChartDeviceContext
  • m_hDestDC : CXTPAnimationDC
  • m_hDontDropCursor : CXTPGridHeader
  • m_heightMode : CXTPGridSection
  • m_hGripperNormal : CXTPTaskPanelPaintManager
  • m_hGripperSpecial : CXTPTaskPanelPaintManager
  • m_hHandCursor : CXTPPopupControl, CXTPShortcutBar, CXTPShortcutBarPane, CXTPTaskPanel
  • m_hHookCallWndProc : CXTPKeyboardManager
  • m_hHookGetMessage : CXTPKeyboardManager
  • m_hHookKeyboard : CXTPKeyboardManager
  • m_hHookMouse : CXTPToolTipContextToolTip
  • m_hIcon : CXTPCalendarOccurSeriesChooseDlg, CXTPCaption, CXTPEyeDropper, CXTPFramePaintManager, CXTPIconHandle, CXTPImageManagerIconHandle, CXTPMenuBarMDIMenuInfo, CXTPTabManagerItem, CXTPTrayIcon, CXTPWindowList
  • m_hIconFooter : CXTPTaskDialogClient
  • m_hIconMain : CXTPTaskDialogClient
  • m_hIconOff : CXTPCaptionPopupWnd
  • m_hIconOn : CXTPCaptionPopupWnd
  • m_hInsertMark : CXTPTreeBase
  • m_hInstance : CXTPSkinManagerResourceFile
  • m_hKeyBase : CXTPRegistryManager
  • m_hMenuDefault : CXTPMenuBar
  • m_hModOldResource : CXTPResourceManager::CManageState
  • m_hModule : CXTPSkinManagerResourceFile
  • m_hModXTResource : CXTPResourceManager
  • m_hMoveCursor : CXTPTrackControl
  • m_hOldBitmap : CXTPAnimationDC
  • m_Host : CXTPWebBrowserProvider
  • m_hotTrackStyle : CXTPTaskPanel
  • m_hParentKey : CXTPPropExchangeRegistry
  • m_hResizeCursor : CXTPGridHeader, CXTPTrackControl
  • m_hResizeVCursor : CXTPGridHeader
  • m_hResource : CXTPResourceImages
  • m_hResourceFile : CXTPResourceManager
  • m_hSectionKey : CXTPPropExchangeRegistry
  • m_hSelect : CXTPTreeBase
  • m_hSizeCursor : CXTPShortcutBar
  • m_htiEdit : CXTPTreeBase
  • m_htiLast : CXTPTreeBase
  • m_hWinEventHook : CXTPSkinManager
  • m_hWnd : CXTPFlowGraphNode, CXTPTabManagerItem, CXTPTaskPanelGroupItem
  • m_hWndActiveChild : CXTPMenuBar
  • m_hWndBuddy : CXTPButton
  • m_hwndChild : CXTPDialogBar, CXTPDockingPane, CXTPShortcutBarItem
  • m_hwndClient : CXTPShortcutBar
  • m_hwndControl : CXTPControlCustom
  • m_hwndFocus : CXTPCommandBar
  • m_hWndMDIClient : CXTPWindowList
  • m_hWndNotify : CXTPTrayIcon
  • m_hWndPane : CXTPStatusBarPane
  • m_hwndSite : CXTPCommandBarsFrameHook
  • m_hwndTaskDialog : CXTPTaskDialog
  • m_iArrowPadding : CXTPHeaderCtrlTheme
  • m_iBorderGap : CXTPMDIClientWnd, CXTPMDIWndTab
  • m_iBtnEnd : CXTPExcelTabCtrl
  • m_iBtnHilight : CXTPExcelTabCtrl
  • m_iBtnHome : CXTPExcelTabCtrl
  • m_iBtnLeft : CXTPExcelTabCtrl
  • m_iBtnRight : CXTPExcelTabCtrl
  • m_iCategory : CXTPCustomizeKeyboardPage
  • m_iCell : CXTPColorHex::CRgnCell
  • m_iCharSet : CXTPSyntaxEditPropertiesPageFont
  • m_iColumnForNum : CXTPGridControl
  • m_iCommand : CXTPExcelTabCtrlButtonState
  • m_iconIndent : CXTPTreeBase
  • m_iconsInfo : CXTPPaintManager
  • m_IconType : CXTPExcelTabCtrlButtonState
  • m_icoSize : CXTPEyeDropper
  • m_iCRLFStyle : CXTPSyntaxEditBufferManager
  • m_iEdge : CXTPTabBaseTheme
  • m_iGripperPosPerCent : CXTPExcelTabCtrl
  • m_iHitTest : CXTPMDIWndTab
  • m_iHours : CXTPTimeEdit
  • m_iHScrollPos : CXTPSyntaxEditDoc
  • m_iIconHeight : CXTPGridControl
  • m_iIconHeightSpacing : CXTPGridControl
  • m_iIconNum : CXTPGridControl
  • m_iIconPropNum : CXTPGridControl
  • m_iIconViewColumn : CXTPGridControl
  • m_iIconViewRowsPerLine : CXTPGridControl
  • m_iIconWidth : CXTPGridControl
  • m_iIconWidthSpacing : CXTPGridControl
  • m_iIndex : CXTPSyntaxEditTipWnd
  • m_iLastRqstEditCol : CXTPGridControl
  • m_iLastRqstEditRow : CXTPGridControl
  • m_ilGradientCircle : CXTPCommandBarsOffice2003Theme
  • m_imageList : CXTPMDIWndTab
  • m_iMaxLineNo : CXTPSyntaxEditGoToLineDlg
  • m_iMaxSize : CXTPSearchOptionsCtrl
  • m_iMaxTipSize : CXTPTrayIcon
  • m_iMins : CXTPTimeEdit
  • m_iMinSize : CXTPHeaderCtrl, CXTPSearchOptionsCtrl
  • m_InsertMarkAfter : CXTPTreeBase
  • m_InsertMarkColor : CXTPTreeBase
  • m_iOverIndex : CXTPHeaderCtrl
  • m_iRecOrRowStart : CXTPGridPaintManager
  • m_iTabHeight : CXTPExcelTabCtrl
  • m_itemLayout : CXTPTaskPanel, CXTPTaskPanelGroup
  • m_iTopRow : CXTPSyntaxEditDoc, CXTPSyntaxEditView
  • m_LastHitInfo : CXTPCalendarView
  • m_lastInfo : CXTPToolTipContext
  • m_Layout : CXTPCalendarDayViewTimeScale, CXTPCalendarView, CXTPCalendarViewDay, CXTPCalendarViewGroup
  • m_LayoutX : CXTPCalendarDayView, CXTPCalendarDayViewGroup, CXTPCalendarWeekView
  • m_lboxCommands : CXTPCustomizeKeyboardPage
  • m_lboxKeys : CXTPCustomizeKeyboardPage
  • m_lboxWindows : CXTPWindowList
  • m_lcFrom : CXTPSyntaxEditBufferCommand
  • m_lcidDateTime : CXTPPropExchange
  • m_LCpos : CXTPSyntaxEditTextIterator
  • m_lcTo : CXTPSyntaxEditBufferCommand
  • m_lf : CXTPChartFont
  • m_lfCaption : CXTPFlowGraphPaintManager
  • m_lfDateHeader : CXTPCalendarPageSetupDialog
  • m_lfDateHeaderCalendarFont : CXTPCalendarControlViewPrintOptions
  • m_lfDateHeaderFont : CXTPCalendarControlViewPrintOptions
  • m_lfDateHeaderWeekDayFont : CXTPCalendarControlViewPrintOptions
  • m_lfPrevFont : CXTPSyntaxEditView
  • m_lfText : CXTPFlowGraphPaintManager
  • m_lfValue : CXTPPropertyGridItemFont
  • m_listeners : CXTPColorSelectorCtrl
  • m_listFonts : CXTPFontEnum
  • m_lpCurrencyFmt : CXTPGridGroupRow
  • m_lpDlgTemplate : CXTPPropertySheet
  • m_lpFolder : CXTPShellPidl::CShellSpecialFolder
  • m_lpMalloc : CXTPShellPidl::CShellMalloc
  • m_lpsfFolder : CXTPShellListBase
  • m_lpTextFile : CXTPSkinManagerResourceFile
  • m_lpTextFileEnd : CXTPSkinManagerResourceFile
  • m_lstCategories : CXTPCustomizeCommandsPage, CXTPRibbonCustomizeQuickAccessPage
  • m_lstCommands : CXTPCustomizeCommandsPage, CXTPRibbonCustomizeQuickAccessPage
  • m_lstKeyboardHooks : CXTPKeyboardManager
  • m_lstPanes : CXTPDockingPaneBaseContainer
  • m_lstQuickAccess : CXTPRibbonCustomizeQuickAccessPage
  • m_lstRects : CXTPDockingPaneTabbedContainer
  • m_lstSpliters : CXTPDockingPaneSplitterContainer
  • m_lstStickers : CXTPDockingPaneContext
  • m_lstViewParts : CXTPCalendarPaintManager
  • m_managerInstance : CXTPResourceManager
  • m_mapAdviseData : CXTPNotifySinkBase
  • m_mapCachedProperties : CXTPSkinManagerClass
  • m_mapClasses : CXTPSkinManagerSchema
  • m_mapColorFont : CXTPTreeBase
  • m_mapCustomReminderValues : CXTPCalendarControl
  • m_mapDocTemplatesAssigned : CXTPControl
  • m_mapDocTemplatesExcluded : CXTPControl
  • m_mapHiddenCommands : CXTPCommandBarsOptions
  • m_mapIcon : CXTPGridRecordItemControl
  • m_mapID2Object : CXTPCalendarData::EventsMapByID_T< _TObject >
  • m_mapImages : CXTPResourceImages, CXTPSkinImages
  • m_mapInfo : CXTPSkinObjectClassMap
  • m_mapInternalRowBkColor : CXTPSyntaxEditCtrl
  • m_mapInternalRowForeColor : CXTPSyntaxEditCtrl
  • m_mapLexClassInfo : CXTPSyntaxEditPropertiesPageColor
  • m_mapLine2Len : CXTPSyntaxEditTextIterator
  • m_mapMenus : CXTPMenuBarMDIMenus
  • m_mapObjects : CXTPSkinManager
  • m_mapProperties : CXTPCalendarCustomProperties, CXTPSkinManagerSchema
  • m_mapPropeties : CXTPResourceImages
  • m_mapRowBkColor : CXTPSyntaxEditOptions
  • m_mapRowForeColor : CXTPSyntaxEditOptions
  • m_mapState : CXTPPropertyGridUpdateContext
  • m_mapTabIcons : CXTPMDIWndTab
  • m_mapTabLabels : CXTPMDIWndTab
  • m_mapUsedCommands : CXTPCommandBarsOptions
  • m_mapWndSize : CXTPTaskDialogClient
  • m_MonthDate : CXTPCalendarEventRecurrenceDlg
  • m_Monthly : XTP_CALENDAR_RECURRENCE_OPTIONS
  • m_MonthNth : XTP_CALENDAR_RECURRENCE_OPTIONS
  • m_mouseCursorMode : CXTPTrackControl
  • m_mouseDownState : CXTPGridControl
  • m_mouseMode : CXTPCalendarControl, CXTPDatePickerControl, CXTPGridControl
  • m_nActiv_EndTags_Offset : CXTPSyntaxEditLexClass
  • m_nAlign : CXTPPopupItem
  • m_nAlignment : CXTPChartAxis, CXTPChartAxisConstantLine, CXTPChartAxisTitle, CXTPChartTitle, CXTPGridColumn, CXTPStatusBarPane
  • m_nAllDayEventSet : CXTPCalendarEventPropertiesDlg
  • m_nAllocWidth : CXTPImageManagerResource
  • m_nAllowDrag : CXTPTaskPanel, CXTPTaskPanelItem
  • m_nAllowReduce : CXTPRibbonGroup
  • m_nAlphaClipFormat : CXTPImageManager
  • m_nAngle : CXTPChartAxisLabel, CXTPChartPointSeriesLabel, CXTPChartRadarPointSeriesLabel
  • m_nAnimateTimer : CXTPTaskPanel
  • m_nAnimationDelay : CXTPFlowGraphControl
  • m_nAnimationDuration : CXTPDockingPaneAutoHideWnd
  • m_nAnimationInterval : CXTPDockingPaneAutoHideWnd, CXTPPopupControl
  • m_nAnimationStep : CXTPTaskPanel
  • m_nAnimationSteps : CXTPPaintManager
  • m_nAnimationTime : CXTPPaintManager
  • m_nAnimationType : CXTPCustomizeOptionsPage
  • m_nArgumentScaleType : CXTPChartSeries
  • m_nAutoButton : CXTPColorSelectorCtrlTheme
  • m_nAutoIndentCol : CXTPSyntaxEditCtrl
  • m_nAutoNumberingBase : CXTPGridColumn
  • m_nAutoPopTimer : CXTPToolTipContextToolTip
  • m_nAutoVScrollTimerResolution : CXTPGridControl
  • m_nAverageLineLen : CXTPSyntaxEditBufferManager, CXTPSyntaxEditCtrl
  • m_nAxisIndexX : CXTPChartDiagram2DSeriesStyle
  • m_nAxisIndexY : CXTPChartDiagram2DSeriesStyle
  • m_nBackgroundAlignemnt : CXTPTaskPanelGroup
  • m_nBackgroundBitmap : CXTPPopupControl
  • m_nBackgroundImage : CXTPTaskPanelGroup
  • m_nBackstageMenuWidth : CXTPRibbonBar
  • m_nBackstageSysButtonBottom : CXTPRibbonBar
  • m_nBackstageSysButtonTop : CXTPRibbonBar
  • m_nBarCount : CXTPChartBarSeriesView
  • m_nBarID : CXTPCommandBar
  • m_nBarIndex : CXTPChartBarSeriesView
  • m_nBaseParentRecordIndent : CXTPGridPaintManager
  • m_nBestFit : CXTPStatusBarPane
  • m_nBestFitMode : CXTPGridColumn
  • m_nBoldDaysIdleStepTime_ms : CXTPCalendarController
  • m_nBoldDaysPerIdleStep : CXTPCalendarController
  • m_nBorder : CXTPCaption
  • m_nBorderGap : CXTPButton
  • m_nBordersHeight : CXTPSyntaxEditAutoCompleteWnd
  • m_nBorderSize : CXTPSkinManagerMetrics
  • m_nBorderStyle : CXTPButton
  • m_nBorderY : CXTPSystemMetrics
  • m_nBottom : CXTPGridThickness
  • m_nBottomCalculatedRow : CXTPSyntaxEditCtrl
  • m_nBufOffsetB : CXTPSyntaxEditTextIterator
  • m_nBufOffsetB_max : CXTPSyntaxEditTextIterator
  • m_nBufOffsetB_normal : CXTPSyntaxEditTextIterator
  • m_nBufSizeB : CXTPSyntaxEditTextIterator
  • m_nBusyStatus : CXTPCalendarEvent, CXTPCalendarEventPropertiesDlg
  • m_nButtonExtraLength : CXTPTabPaintManager
  • m_nButtonHeight : CXTPTabPaintManagerTheme
  • m_nButtonLength : CXTPTabManagerItem
  • m_nBytePerRow : CXTPHexEdit
  • m_nCaption : CXTPColorSelectorCtrlTheme
  • m_nCaptionButtonStyle : CXTPDockingPanePaintManager
  • m_nCaptionFontGap : CXTPDockingPanePaintManager
  • m_nCaptionHeight : CXTPCalendarControl, CXTPDialogBar, CXTPTaskPanelGroup, CXTPTaskPanelPaintManager
  • m_nCaptionTextFormat : CXTPTaskPanelPaintManager
  • m_nCaptionY : CXTPSystemMetrics
  • m_nCategory : CXTPChartNumberFormat
  • m_nChecked : CXTPControlGallery
  • m_nCheckHotStateTimerID : CXTPCalendarCaptionBarTheme
  • m_nChildIndex : CXTPGridRow
  • m_nClassCode : CXTPSkinManagerClass
  • m_nClassPart : CXTPSkinObjectFrame::CCaptionButton
  • m_nClientHeight : CXTPExcelTabCtrl, CXTPTaskPanel
  • m_nClientWidth : CXTPExcelTabCtrl
  • m_nCodePage : CXTPSyntaxEditBufferManager
  • m_nColHeaderHeight : CXTPCalendarMonthView::CMonthViewGrid
  • m_nCollapsedTextRowsCount : CXTPSyntaxEditCtrl
  • m_nCols : CXTPColorPicker, CXTPColorSelectorCtrl
  • m_nColumn : CXTPDatePickerItemMonth
  • m_nColumnAutoWidth : CXTPGridColumn
  • m_nColumnCount : CXTPChartLegend
  • m_nColumns : CXTPDatePickerControl
  • m_nColumnStaticWidth : CXTPGridColumn
  • m_nColumnWidth : CXTPTaskPanel
  • m_nCommand : CXTPSkinObjectFrame::CCaptionButton
  • m_nConnectorType : CXTPFlowGraphPaintManager
  • m_nContentLength : CXTPTabManagerItem
  • m_nContextColor : CXTPRibbonTab
  • m_nControlID : CXTPControlCustom
  • m_nCount : CXTPPropExchangeEnumerator
  • m_nCounter : CXTPTrayIcon
  • m_nCurPage : CXTPCalendarDayView
  • m_nCurrentAddress : CXTPHexEdit
  • m_nCurrentCol : CXTPSyntaxEditCtrl
  • m_nCurrentDocumentRow : CXTPSyntaxEditCtrl
  • m_nCurrentTransparency : CXTPPopupControl
  • m_nCurrPos : CXTPCalendarWeekView
  • m_nCurSel : CXTPColorSelectorCtrl, CXTPExcelTabCtrl
  • m_nCustomClientHeight : CXTPRibbonBar
  • m_nCustomGroupsHeight : CXTPRibbonBar
  • m_nCustomHeight : CXTPMessageBar
  • m_nCustomIconId : CXTPControl
  • m_nDashStyle : CXTPChartLineStyle
  • m_nDataSize : CXTPSyntaxEditCtrl::CAverageVal
  • m_nDataSizeLimit : CXTPSyntaxEditUndoRedoManager
  • m_nDayHeaderHeight : XTP_WEEK_VIEW_LAYOUT
  • m_nDayHeaderPeriod : CXTPCalendarDayView
  • m_nDayHeight : XTP_WEEK_VIEW_LAYOUT
  • m_nDayInterval : CXTPCalendarEventRecurrenceDlg
  • m_nDayOfMonth : CXTPCalendarEventRecurrenceDlg
  • m_nDayViewPrintInterval : CXTPCalendarDayView
  • m_nDayWidth : XTP_WEEK_VIEW_LAYOUT
  • m_nDeactivationCount : CXTPDockingPaneMiniWnd, CXTPDockingPaneSidePanel
  • m_nDecimalPlaces : CXTPChartNumberFormat
  • m_nDefaultGap : CXTPBrowseEdit
  • m_nDefaultMenuID : CXTPCommandBars
  • m_nDefaultRowFreeHeight : CXTPGridControl
  • m_nDefCmd : CXTPMDIWndTab
  • m_nDelayAutoPop : CXTPToolTipContext, CXTPToolTipContextToolTip
  • m_nDelayInitial : CXTPToolTipContext, CXTPToolTipContextToolTip
  • m_nDelayReshow : CXTPToolTipContext, CXTPToolTipContextToolTip
  • m_nDelayTime : CXTPSyntaxEditToolTipCtrl
  • m_nDelayTimer : CXTPToolTipContextToolTip
  • m_nDelayTimerEventID : CXTPTipWindow
  • m_nDesiredColumns : CXTPDatePickerControl
  • m_nDesiredExpandedLinesHeight : CXTPShortcutBar
  • m_nDesiredRows : CXTPDatePickerControl
  • m_nDialogID : CXTPResizeDialog, CXTPResizePropertyPage
  • m_nDirection : CXTPChartLegend
  • m_nDisableReorderColumnsCount : CXTPGridControl
  • m_nDisableShortcuts : CXTPShortcutManager
  • m_nDispCol : CXTPSyntaxEditCtrl
  • m_nDocking : CXTPChartTitle
  • m_nDockingContextStickerStyle : CXTPDockingPaneManager
  • m_nDragSensitivityX : CXTPGridControl
  • m_nDragSensitivityY : CXTPGridControl
  • m_nDrawingRow : CXTPSyntaxEditDrawTextProcessor
  • m_nDrawTextFormat : CXTPTabPaintManager
  • m_nDropDownItemCount : CXTPControlComboBox, CXTPPropertyGridItem
  • m_nDropIndex : CXTPGridHeader, CXTPGridSubListControl
  • m_nDropPos : CXTPGridControl
  • m_nEditbarLength : CXTPSyntaxEditCtrl
  • m_nEditHeight : CXTPPaintManager
  • m_nEditIconId : CXTPControlComboBox, CXTPControlEdit
  • m_nElapseTimerEventID : CXTPTipWindow
  • m_nEllipseSize : CXTPFlowGraphPaintManager
  • m_nEnableCustomShortcutText : CXTPShortcutManager
  • m_nEndAfterOccurrences : XTP_CALENDAR_PATTERN_END
  • m_nEndChar : CXTPMaskEditT< TBase >
  • m_nEndReplacePos : CXTPSyntaxEditAutoCompleteWnd
  • m_nEndTagXLCLen : CXTPSyntaxEditLexTextBlock
  • m_nEnsureVisibleColumnIdx : CXTPGridControl
  • m_nEnsureVisibleRowIdx : CXTPGridControl
  • m_nEventCaptionFormat : CXTPCalendarMonthView
  • m_nEventDurationInPixels : CXTPCalendarTimeLineViewEvent
  • m_nEventPlaceNumber : CXTPCalendarViewEvent
  • m_nEventTimelinePlaceNumber : CXTPCalendarViewEvent
  • m_nEventTimeWidth : CXTPCalendarMonthView
  • m_newTabPosition : CXTPTabClientWnd
  • m_nExecuteOnPressInterval : CXTPControl
  • m_nExpandedClientHeight : CXTPTaskPanelGroup
  • m_nExpandedHeight : CXTPDockingPaneMiniWnd
  • m_nExpandedIconWidth : CXTPShortcutBarPaintManager
  • m_nExpandedLines : CXTPShortcutBar
  • m_nExplodedDistancePercent : CXTPChartPieSeriesStyleBase
  • m_nExtendedColors : CXTPColorPicker, CXTPColorSelectorCtrl
  • m_nFillAcrossXAxis : CXTPChartAreaSeriesStyle
  • m_nFillMode : CXTPChartFillStyle
  • m_nFirstDayOfWeek : CXTPDatePickerControl
  • m_nFirstDayOfWeekIndex : CXTPCalendarMonthView::CMonthViewGrid, CXTPCalendarWeekView
  • m_nFirstDisplayedStr : CXTPSyntaxEditAutoCompleteWnd
  • m_nFirstWeekOfYearDays : CXTPDatePickerControl
  • m_nFistMDIChild : CXTPControlWindowList
  • m_nFixedColumnsIndent : CXTPGridPaintManager
  • m_nFixedHeight : CXTPGridInplaceButton
  • m_nFixedTabWidth : CXTPTabPaintManager
  • m_nFlags : CXTPPropertyGridItem
  • m_nFlagsXX : CXTPResize
  • m_nFloatingFramesOpacity : CXTPDockingPaneManager
  • m_nFocused : CXTPTaskDialogLinkCtrl
  • m_nFocusedRow : CXTPGridRows
  • m_nFocusedVerb : CXTPPropertyGrid
  • m_nFontHeight : CXTPPaintManager
  • m_nFontSize : CXTPDockingPaneVisualStudio2012Theme
  • m_nFooterAlignment : CXTPGridColumn
  • m_nFooterHeight : CXTPGridPaintManager
  • m_nForceLayoutAdjustment : CXTPGridHeader
  • m_nFrameCaptionHeight : CXTPFramePaintManager
  • m_nFreeHeight : CXTPGridRecord, CXTPGridRow
  • m_nFreezeColsDividerStyle : CXTPGridPaintManager
  • m_nFullDrag : CXTPSplitterWnd
  • m_nGap : CXTPBrowseEdit, CXTPMarqueeCtrl
  • m_nGradientAngle : CXTPChartFillStyle
  • m_nGridColumns : XTP_WEEK_VIEW_LAYOUT
  • m_nGridLineStylePreviousH : CXTPGridPaintManager
  • m_nGridLineStylePreviousV : CXTPGridPaintManager
  • m_nGripperWidth : CXTPDockingPanePanelTheme2012
  • m_nGroupCaptionHeight : CXTPRibbonPaintManager
  • m_nGroupGridLineHeight : CXTPGridPaintManager
  • m_nGroupGridLineStyle : CXTPGridPaintManager
  • m_nGroupId : CXTPFlowGraphNode
  • m_nGroupLevel : CXTPGridRow
  • m_nGroupMinClientHeight : CXTPTaskPanel
  • m_nGroupPriority : CXTPGridRecordItem
  • m_nGroupSpacing : CXTPRibbonPaintManager, CXTPTaskPanel, CXTPTaskPanelPaintManager
  • m_nGroupsScrollPos : CXTPRibbonGroups
  • m_nHatchStyle : CXTPChartFillStyle
  • m_nHeaderAlignment : CXTPGridColumn
  • m_nHeaderHeight : CXTPGridPaintManager
  • m_nHeaderOffset : CXTPTabManager
  • m_nHeaderWidth : CXTPGridHeader
  • m_nHeight : CXTPChartTextPainterBase, CXTPControl, CXTPGridHeaderDropWnd, CXTPGridSection, CXTPPropertyGridItem, CXTPShortcutBarPaneItem
  • m_nHelpHeight : CXTPPropertyGridPaintManager
  • m_nHelpId : CXTPControl, CXTPControlAction
  • m_nHiddenCol : CXTPSplitterWnd
  • m_nHiddenRow : CXTPSplitterWnd
  • m_nHighLightLine : CXTPSyntaxEditAutoCompleteWnd
  • m_nHitTest : CXTPDockContext
  • m_nHolePercent : CXTPChartPieBase, CXTPChartPieSeriesStyleBase
  • m_nHorizontalAlignment : CXTPChartLegend
  • m_nHotButton : CXTPSpinButtonCtrl
  • m_nHotItem : CXTPListBox
  • m_nHourWidth : CXTPCalendarPaintManager
  • m_nHScrollMaxWidth : CXTPSyntaxEditCtrl
  • m_nHScrollPos : CXTPCalendarTimeLineView
  • m_nHTCode : CXTPSkinObjectFrame::CCaptionButton
  • m_nHue : CXTPColorBase
  • m_nHyperTextBegin : CXTPGridHyperlink
  • m_nHyperTextLen : CXTPGridHyperlink
  • m_nIcon : XTP_EDIT_ACDATA
  • m_nIconID : CXTPDockingPane, CXTPGridColumn, CXTPTrayIcon
  • m_nIconId : CXTPControl, CXTPControlAction, CXTPRibbonGroup, CXTPShortcutBarItem
  • m_nIconIndex : CXTPGridInplaceButton, CXTPGridRecordItem, CXTPPopupItem, CXTPStatusBarPane, CXTPTaskPanelItem
  • m_nIconTitle : CXTPToolTipContext
  • m_nIconX : CXTPSystemMetrics
  • m_nIconY : CXTPSystemMetrics
  • m_nID : CXTPBrowseButton, CXTPCalendarEventCategory, CXTPDatePickerButton, CXTPDockingPane, CXTPDockingPaneCaptionButton, CXTPFlowGraphUndoCommand, CXTPGridInplaceButton, CXTPMessageBarButton, CXTPPopupControl, CXTPPopupItem, CXTPPropertyGridItem, CXTPPropertyGridVerb, CXTPShortcutBarItem, CXTPStatusBarPane, CXTPTabManagerNavigateButton, CXTPTaskPanelItem, CXTPTrackUndoCommand
  • m_nId : CXTPControl, CXTPControlAction, CXTPControlGalleryItem, CXTPFlowGraphConnectionPoint, CXTPFlowGraphNode, CXTPFlowGraphPage, CXTPRibbonGroup, CXTPRibbonTab
  • m_niData : CXTPTrayIcon
  • m_nIDEvent : CXTPTrayIcon
  • m_nIDHelp : CXTPDockingPane
  • m_nIDHelpTracking : CXTPCommandBars
  • m_nIdleFlags : CXTPCommandBar
  • m_nIDResource : CXTPMenuBar, CXTPMenuBarMDIMenuInfo
  • m_nIDResourceCurrent : CXTPMenuBar
  • m_nIDResourceLabels : CXTPCalendarOccurSeriesChooseDlg
  • m_nImage : CXTPControlGalleryItem, CXTPPropertyGridItemConstraint, CXTPPropertyGridItemMetrics, CXTPTabManagerItem
  • m_nImageAlignment : CXTPButton
  • m_nImageBase : CXTPToolTipContext
  • m_nImageClipFormat : CXTPImageManager
  • m_nImageGap : CXTPButton
  • m_nImageIndex : CXTPFlowGraphConnectionPoint, CXTPFlowGraphNode
  • m_nImageSize : CXTPToolTipContext
  • m_nImageWidth : CXTPControlGalleryItem
  • m_nImportance : CXTPCalendarEvent
  • m_nInactiveCollapseDelay : CXTPDockingPaneAutoHideWnd
  • m_nIndent : CXTPChartTitle, CXTPPropertyGridItem
  • m_nIndentLevel : CXTPGridHeader
  • m_nIndex : CXTPChartSeriesPoint, CXTPControl, CXTPControlGalleryItem, CXTPEditListBox, CXTPGridRecord, CXTPGridRecordItemConstraint, CXTPGridRecordItemControl, CXTPGridRow, CXTPPopupItem, CXTPPropertyGridItem, CXTPPropertyGridItemConstraint, CXTPPropertyGridVerb, CXTPRibbonGroup, CXTPShortcutListBox::CONTENT_ITEM, CXTPStatusBarPane, CXTPTabManagerItem, CXTPTrackBlock
  • m_nInnerIndent : CXTPChartTitle
  • m_nInputId : CXTPFlowGraphConnection
  • m_nInputLockCount : CXTPKeyboardManager
  • m_nInsertSpaceCount : CXTPSyntaxEditCtrl
  • m_nInsertTabCount : CXTPSyntaxEditCtrl
  • m_nItemCount : CXTPControlWindowList
  • m_nItemHeight : CXTPListBox, CXTPPropertyGridView
  • m_nItemIndex : CXTPGridColumn
  • m_nItemRow : CXTPTabManagerItem
  • m_nItemsAbove : CXTPDatePickerList
  • m_nItemsBelow : CXTPDatePickerList
  • m_nItemsBorderHeight : CXTPPropertyGridPaintManager
  • m_nItemsInRow : CXTPTaskPanelGroup
  • m_nItemTextFormat : CXTPTaskPanelPaintManager
  • m_nKeyboardTipsLevel : CXTPRibbonBackstageView
  • m_nKeyStateTimerID : CXTPCalendarView
  • m_nLabelID : CXTPCalendarEvent, CXTPCalendarEventLabel
  • m_nLabelWidth : CXTPControlComboBox, CXTPControlEdit
  • m_nLastDragTime : CXTPTrackBlock
  • m_nLastSel : CXTPControlComboBox
  • m_nLeft : CXTPGridThickness
  • m_nLength : CXTPChartAxisTickMarks, CXTPChartSeriesPoint, CXTPHexEdit, CXTPTrackBlock
  • m_nLineHeight : CXTPHexEdit, CXTPSyntaxEditAutoCompleteWnd
  • m_nLineLength : CXTPChartSeriesLabel
  • m_nLineNumLength : CXTPSyntaxEditCtrl
  • m_nLines : CXTPSyntaxEditAutoCompleteWnd
  • m_nLinesCount : CXTPPropertyGridItem
  • m_nLineSpace : CXTPTipWindow
  • m_nLinesPerPage : CXTPHexEdit
  • m_nLineThickness : CXTPChartHighLowSeriesStyle
  • m_nListBoxLinesMax : CXTPControlListBox
  • m_nListBoxLinesMin : CXTPControlListBox
  • m_nLocale : CXTPChartNumberFormat
  • m_nLockCount : CXTPCalendarControl::CViewChanged_ContextData, CXTPCalendarView::CSelectionChanged_ContextData
  • m_nLockCount_Day : CXTPCalendarView::CSelectionChanged_ContextData
  • m_nLockCount_Event : CXTPCalendarView::CSelectionChanged_ContextData
  • m_nLockRedraw : CXTPCommandBar, CXTPTaskPanel
  • m_nLockReposition : CXTPDockingPaneTabbedContainer
  • m_nLockUpdate : CXTPPropertyGridView
  • m_nLockUpdateCount : CXTPDatePickerControl, CXTPGridControl
  • m_nLogPixelsX : CXTPDeviceCaps
  • m_nLogPixelsY : CXTPDeviceCaps
  • m_nLum : CXTPColorBase
  • m_nMargin : CXTPColorSelectorCtrlTheme, CXTPTagCloudCtrl
  • m_nMarginLength : CXTPSyntaxEditCtrl
  • m_nMarqueeDelay : CXTPProgressCtrl
  • m_nMarqueePos : CXTPProgressCtrl
  • m_nMax : CXTPControlScrollBar, CXTPControlSlider, CXTPProgressBase, CXTPPropertyGridInplaceSlider, CXTPPropertyGridInplaceSpinButton, CXTPStatusBarScrollBarPane
  • m_nMaxClientWidth : CXTPTaskDialogClient
  • m_nMaxColumnWidth : CXTPGridHeader
  • m_nMaxColWidth : CXTPListBase
  • m_nMaxConnections : CXTPFlowGraphConnectionPoint
  • m_nMaxHeight : CXTPPopupBar
  • m_nMaxItemWidth : CXTPGridColumn
  • m_nMaxLength : CXTPGridRecordItemEditOptions, CXTPHexEdit, CXTPPropertyGridItemMetrics, CXTPTrackBlock
  • m_nMaxPreviewLines : CXTPGridPaintManager
  • m_nMaxSelectionDays : CXTPDatePickerControl
  • m_nMaxTabWidth : CXTPTabPaintManager
  • m_nMaxTipWidth : CXTPToolTipContext
  • m_nMaxValue : CXTPChartAxisRange
  • m_nMaxWidth : CXTPGridColumn
  • m_nMenu : CXTPBrowseButton, CXTPBrowseEdit
  • m_nMergeHeight : CXTPGridRow
  • m_nMin : CXTPControlScrollBar, CXTPControlSlider, CXTPProgressBase, CXTPPropertyGridInplaceSlider, CXTPPropertyGridInplaceSpinButton, CXTPStatusBarScrollBarPane
  • m_nMinClientHeight : CXTPShortcutBar, CXTPShortcutBarPane, CXTPTaskPanelGroup
  • m_nMinClientWidth : CXTPTaskDialogClient
  • m_nMinColumnWidth : CXTPCalendarDayView
  • m_nMinColWidth : CXTPListBase
  • m_nMinHeight : CXTPStatusBar
  • m_nMinLength : CXTPTrackBlock
  • m_nMinorCount : CXTPChartAxis
  • m_nMinorLength : CXTPChartAxisTickMarks
  • m_nMinorThickness : CXTPChartAxisTickMarks
  • m_nMinTabWidth : CXTPTabPaintManager
  • m_nMinutesBeforeStart : CXTPCalendarReminder
  • m_nMinValue : CXTPChartAxisRange
  • m_nMinVisibleHeight : CXTPRibbonBar
  • m_nMinVisibleWidth : CXTPRibbonBar
  • m_nMinWidth : CXTPCalendarPaintManager, CXTPGridColumn, CXTPTabToolBar
  • m_nMonthDelta : CXTPDatePickerControl
  • m_nMonthInterval : CXTPCalendarEventRecurrenceDlg
  • m_nMonthInterval2 : CXTPCalendarEventRecurrenceDlg
  • m_nMouseHoverDelay : CXTPDockingPaneAutoHideWnd
  • m_nMRUPosition : CXTPTrackBlock
  • m_nMRUWidth : CXTPCommandBar
  • m_nMsgQueryFrameHook : CXTPCommandBarsFrameHook
  • m_nMultiDayEventFlags : CXTPCalendarViewEvent
  • m_nNameColumnWidth : CXTPShellListBase
  • m_nNearPosition : CXTPChartRotatedTextPainterNearLine
  • m_nNextIndex : CXTPSyntaxEditCtrl::CAverageVal
  • m_nNextLine : CXTPSyntaxEditTextIterator
  • m_nNextRefreshIndex : CXTPCalendarRemindersDialog
  • m_nNextRowPosX : CXTPSyntaxEditDrawTextProcessor
  • m_nNextTip : CXTPTipOfTheDay
  • m_nNextVisualBlock : CXTPGridColumn
  • m_nNodeFrameSize : CXTPFlowGraphPaintManager
  • m_nNodesWidth : CXTPSyntaxEditCtrl
  • m_nNormalIconWidth : CXTPShortcutBarPaintManager
  • m_nNullWidth : CXTPHexEdit
  • m_nObjType : CXTPSyntaxEditLexVariant
  • m_nOccurNum : CXTPCalendarEventRecurrenceDlg
  • m_nOffAddress : CXTPHexEdit
  • m_nOffAscii : CXTPHexEdit
  • m_nOffHex : CXTPHexEdit
  • m_nOffset : CXTPCaption, CXTPExcelTabCtrl
  • m_nOldClientHeight : CXTPTaskPanel
  • m_nOldLength : CXTPTrackUndoSetBlockPositionCommand
  • m_nOldMarkerPos : CXTPTrackHeader
  • m_nOldPosition : CXTPTrackUndoSetBlockPositionCommand, CXTPTrackUndoSetMarkerPositionCommand
  • m_nOldTrackViewPortRange : CXTPTrackControl
  • m_nOldTrackWidth : CXTPTrackControl
  • m_nOldViewPortMax : CXTPTrackHeader
  • m_nOldViewPortMin : CXTPTrackHeader
  • m_nOldVisibleIndex : CXTPGridColumn
  • m_nOldWorkAreaMax : CXTPTrackHeader
  • m_nOldWorkAreaMin : CXTPTrackHeader
  • m_nOLEDropMode : CXTPTaskPanel
  • m_nOpacity : CXTPMiniToolBar
  • m_nOutputId : CXTPFlowGraphConnection
  • m_nPadding : CXTPEyeDropper, CXTPTagCloudCtrl, CXTPTaskDialogClient
  • m_nPage : CXTPControlScrollBar, CXTPStatusBarScrollBarPane
  • m_nPageBorderStyle : CXTPPropertySheet
  • m_nPaintTheme : CXTPCalendarPaintManager, CXTPDatePickerPaintManager
  • m_nPaletteIndex : CXTPChartSeries, CXTPChartSeriesPoint
  • m_nPaneItemHeight : CXTPShortcutBarPaintManager
  • m_nPanelDirection : CXTPChartContent
  • m_nPanelDistance : CXTPChartContent
  • m_nParserThreadPriority_WhenActive : CXTPSyntaxEditView
  • m_nParserThreadPriority_WhenInactive : CXTPSyntaxEditView
  • m_nPartID : CXTPCalendarCaptionBarThemePart
  • m_nPointTextMargin : CXTPFlowGraphPaintManager
  • m_nPopulatedRecordsCount : CXTPGridSection
  • m_nPopupBarText : CXTPCommandBarsOffice2000Theme
  • m_nPopupBarTextPadding : CXTPPaintManager
  • m_nPopuped : CXTPCommandBar
  • m_nPopupLocation : CXTPPopupControl
  • m_nPos : CXTPControlScrollBar, CXTPControlSlider, CXTPHeaderCtrl, CXTPMarqueeCtrl, CXTPMDIWndTab, CXTPProgressBase, CXTPTabExBase
  • m_nPosition : CXTPChartFunnelSeriesLabelBase, CXTPChartPieSeriesLabelBase, CXTPChartPyramidSeriesLabelBase, CXTPTrackBlock, CXTPTrackMarker
  • m_nPressed : CXTPColorSelectorCtrl
  • m_nPressedButton : CXTPSpinButtonCtrl
  • m_nPreviewHeight : CXTPGridRow
  • m_nPrevIndex : CXTPShortcutListBox
  • m_nPrevTopRow : CXTPSyntaxEditView
  • m_nPrevTreeIndent : CXTPGridControl
  • m_nPrimitiveSize : CXTPChart3dDiagram
  • m_nPrintingRow : CXTPSyntaxEditDrawTextProcessor
  • m_nPushButtonStyle : CXTPButton
  • m_nQuickAccessHeight : CXTPRibbonBar
  • m_nRecordsTreeFilterMode : CXTPGridControl
  • m_nRecurrenceState : CXTPCalendarEvent
  • m_nRecurrenceType : XTP_CALENDAR_RECURRENCE_OPTIONS
  • m_nReminderMinutesBeforeStart : CXTPCalendarEvent
  • m_nResizable : CXTPControlGallery
  • m_nResizeCaptureRange : CXTPGridHeader
  • m_nResizingWidth : CXTPGridPaintManager
  • m_nRibbonCaptionHeight : CXTPResourceTheme
  • m_nRibbonDividerIndex : CXTPStatusBar
  • m_nRight : CXTPGridThickness
  • m_nRootFolder : CXTPShellTreeBase
  • m_nRotation : CXTPChartPieSeriesStyleBase
  • m_nRow : CXTPDatePickerItemMonth
  • m_nRowCount : CXTPRibbonGroup
  • m_nRowEnd : CXTPSyntaxEditLexOnScreenParseCnt
  • m_nRowHeight : CXTPGridPaintManager, CXTPSyntaxEditDrawTextProcessor
  • m_nRowHeightDefault : CXTPGridPaintManager
  • m_nRowIndex : CXTPGridTip
  • m_nRowLevel : CXTPGridRow
  • m_nRowMargin : CXTPTabPaintManagerTheme
  • m_nRows : CXTPDatePickerControl
  • m_nRowsPerWheel : CXTPCalendarControl, CXTPGridControl
  • m_nRowStart : CXTPSyntaxEditLexOnScreenParseCnt
  • m_nSat : CXTPColorBase
  • m_nSavedState : CXTPGridRecordItemButton
  • m_nScaleIntervalWidth_px : CXTPCalendarTLV_TimeScaleParams
  • m_nScaleType : CXTPChartAxis
  • m_nSchema : CXTPPropExchange
  • m_nScore : CXTPTagCloudStyle
  • m_nScrollDelta : CXTPTabManager
  • m_nScrollIndexV : CXTPGridSection
  • m_nScrollOffset : CXTPTaskPanelGroup
  • m_nScrollOffsetH : CXTPGridControl
  • m_nScrollOffsetV : CXTPGridSection
  • m_nScrollOffsetX : CXTPCalendarDayView
  • m_nScrollPos : CXTPControlGallery
  • m_nScrollPosTarget : CXTPControlGallery
  • m_nScrollStepH : CXTPGridControl
  • m_nScrollStepV : CXTPGridControl
  • m_nScrollXOffset : CXTPSyntaxEditDrawTextProcessor
  • m_nSearchDirection : CXTPSyntaxEditFindReplaceDlg
  • m_nSearchHistoryCountMax : CXTPSyntaxEditFindReplaceDlg
  • m_nSelButtonID : CXTPTaskDialog
  • m_nSelected : CXTPCommandBar, CXTPControlGallery, CXTPPropertyGridUpdateContext
  • m_nSelectOnDragOverDelay : CXTPTabPaintManager
  • m_nSelEnd : CXTPHexEdit
  • m_nSelRadioButtonID : CXTPTaskDialogClient
  • m_nSelStart : CXTPHexEdit
  • m_nSendQueueCacheSize : CXTPNotifyConnection
  • m_nSize : CXTPChartDiagram2DAxisView, CXTPChartMarker, CXTPChartRadarAxisXView, CXTPChartRadarAxisYView
  • m_nSizeFrameY : CXTPSystemMetrics
  • m_nSlideStep : CXTPDockingPaneMiniWnd, CXTPDockingPaneSidePanel
  • m_nSmallIconX : CXTPSystemMetrics
  • m_nSmallIconY : CXTPSystemMetrics
  • m_nSmoothingMode : CXTPFlowGraphControl
  • m_nSnapMargin : CXTPTrackControl
  • m_nSortDirection : CXTPChartLegend
  • m_nSortedCol : CXTPHeaderCtrl, CXTPListBase
  • m_nSortLocale : CXTPGridRecordItemVariant
  • m_nSortOrder : CXTPTagCloudCtrl
  • m_nSortPriority : CXTPGridRecordItem
  • m_nSpaceWidth : CXTPSyntaxEditDrawTextProcessor
  • m_nSpinIncrement : CXTPGridInplaceButton
  • m_nSpinMax : CXTPGridInplaceButton
  • m_nSpinMin : CXTPGridInplaceButton
  • m_nSpinStep : CXTPGridInplaceButton
  • m_nSplitButtonDropDownHeight : CXTPPaintManager
  • m_nSplitButtonDropDownWidth : CXTPPaintManager
  • m_nSplitButtonPopupWidth : CXTPPaintManager
  • m_nSplitterGap : CXTPDockingPaneManager
  • m_nSplitterHeight : CXTPPropertyGridPaintManager
  • m_nSplitterIndent : CXTPDockingPanePaintManager
  • m_nSplitterSize : CXTPDockingPanePaintManager, CXTPTabClientWnd
  • m_nStartChar : CXTPMaskEditT< TBase >
  • m_nStartReplacePos : CXTPSyntaxEditAutoCompleteWnd
  • m_nStartTagLen : CXTPSyntaxEditLexTextBlock
  • m_nState : CXTPCalendarCaptionBarThemePart, CXTPGridInplaceButton, CXTPGridRecordItemControl
  • m_nStateFlags : CXTPCommandBar
  • m_nStatusBarMinHeight : CXTPPaintManager
  • m_nStep : CXTPPopupControl
  • m_nStepsCount : CXTPDockingPaneMiniWnd, CXTPDockingPaneSidePanel
  • m_nStickyGap : CXTPDockingPaneManager
  • m_nStrLen : CXTPHeapString
  • m_nStyle : CXTPCheckListBox, CXTPFlowGraphConnection, CXTPFlowGraphConnectionPoint, CXTPFlowGraphNode, CXTPStatusBarPane
  • m_nSubMenuIndx : CXTPBrowseButton, CXTPBrowseEdit
  • m_nTabPositions : CXTPTipWindow
  • m_nTabsHeight : CXTPDockingPanePaintManager, CXTPRibbonPaintManager
  • m_nTabSize : CXTPSyntaxEditBufferManager, CXTPSyntaxEditDrawTextProcessor
  • m_nTag : CXTPControl, CXTPControlAction
  • m_nTearOffID : CXTPPopupBar
  • m_nTearOffTimer : CXTPPopupBar
  • m_nTearOffWidth : CXTPPopupBar
  • m_nTextFormat : CXTPTaskPanelItem
  • m_nTextHeight : CXTPPaintManager
  • m_nTextImageRelation : CXTPButton
  • m_nTextIndentForGroupRowsWithNoIcon : CXTPGridPaintManager
  • m_nTextLimit : CXTPControlComboBox, CXTPControlEdit
  • m_nTextOrientation : CXTPCommandBar
  • m_nTextPadding : CXTPListBox
  • m_nTheme : CXTPComboBoxThemeOfficeXPFlat, CXTPControlTheme, CXTPEditTheme, CXTPMarqueeCtrlPaintManager, CXTPProgressCtrlPaintManager, CXTPScrollBar, CXTPSpinButtonCtrl, CXTPTreeBase
  • m_nThickness : CXTPChart3dLineDeviceCommand, CXTPChartAxis, CXTPChartAxisTickMarks, CXTPChartBorder, CXTPChartLineDeviceCommand, CXTPChartLineStyle, CXTPChartPolylineDeviceCommand, CXTPChartSplineDeviceCommand
  • m_nThumbWidth : CXTPComboBoxTheme, CXTPControlComboBox
  • m_nTimeLineMax : CXTPTrackControl
  • m_nTimelineMaxPixelsForEvent : CXTPCalendarTimeLineView
  • m_nTimelineMaxPixelsForEvent_ScaleDay : CXTPCalendarTimeLineView
  • m_nTimelineMaxPixelsForEvent_ScaleWeek : CXTPCalendarTimeLineView
  • m_nTimeLineMin : CXTPTrackControl
  • m_nTimeLinePosition : CXTPTrackControl
  • m_nTimelineScale : CXTPCalendarControl
  • m_nTimerElapse : CXTPScrollBase
  • m_nTimerID : CXTPDatePickerControl
  • m_nTimerID_ShowToolTip : CXTPCalendarView, CXTPCalendarViewEvent
  • m_nTimerID_StartEditSubject : CXTPCalendarView
  • m_nTimeshift_min : CXTPCalendarDayViewTimeScale
  • m_nTitleHeight : CXTPDockingPanePaintManager
  • m_nTmpOffsetB : CXTPSyntaxEditTextIterator
  • m_nTmpOffsetC : CXTPSyntaxEditTextIterator
  • m_nTop : CXTPGridThickness
  • m_nTopCalculatedRow : CXTPSyntaxEditCtrl
  • m_nTopIndex : CXTPHexEdit, CXTPPropertyGridUpdateContext
  • m_nTopRow : CXTPSyntaxEditCtrl
  • m_nTotalHeight : CXTPControlGallery
  • m_nTrackColumnIndex : CXTPTrackControl
  • m_nTransparency : CXTPChartAreaSeriesStyle, CXTPChartRadarAreaSeriesStyle, CXTPChartSeriesLabel, CXTPChartSeriesStyle, CXTPPopupControl
  • m_nTreeColumnLineLength : CXTPGridPaintManager
  • m_nTreeIndent : CXTPGridPaintManager
  • m_nTreeStructureStyle : CXTPGridPaintManager
  • m_nTreeTextIndent : CXTPGridPaintManager
  • m_nTreeTextIndentGroupRow : CXTPGridPaintManager
  • m_nTreeTextIndentRowChildren : CXTPGridPaintManager
  • m_nTreeTextIndentRowParent : CXTPGridPaintManager
  • m_nType : CXTPChartMarker, CXTPFlowGraphConnectionPoint, CXTPGridRecordItemControl
  • m_nUndoContext : CXTPFlowGraphUndoManager, CXTPTrackUndoManager
  • m_nUseEnd : XTP_CALENDAR_PATTERN_END
  • m_nValue : CXTPMarkupGridLength, CXTPPropertyGridInplaceSlider, CXTPPropertyGridItemEnum, CXTPPropertyGridItemFlags, CXTPPropertyGridItemNumber, CXTPPropertyGridItemOption, CXTPStatusBarScrollBarPane, CXTPSyntaxEditLexVariant, XTP_CALENDAR_TIMELINE_VIEW_SCALE
  • m_nValueScaleType : CXTPChartSeries
  • m_nVarFlags : CXTPSyntaxEditLexVariable
  • m_nVarID : CXTPSyntaxEditLexVariable
  • m_nVerbsHeight : CXTPPropertyGridPaintManager
  • m_nVerticalAlignment : CXTPChartLegend, CXTPTrackBlock
  • m_nViewPortMax : CXTPTrackControl
  • m_nViewPortMin : CXTPTrackControl
  • m_nVirtualRecordsCount : CXTPGridRecords
  • m_nVirtualRowsCount : CXTPGridRows
  • m_nVisIndex : CXTPGridHeader
  • m_nVScrollPos : CXTPCalendarTimeLineView
  • m_nWeekDayIndex : CXTPCalendarMonthViewDay
  • m_nWeekIndex : CXTPCalendarMonthViewDay
  • m_nWeeklyInterval : CXTPCalendarEventRecurrenceDlg
  • m_nWeeksCount : CXTPCalendarMonthView::CMonthViewGrid
  • m_nWheelScroll : CXTPSyntaxEditCtrl
  • m_nWidth : CXTPChartTextPainterBase, CXTPControl, CXTPGridInplaceButton, CXTPPropertyGridInplaceControl
  • m_nWndHeight : CXTPSyntaxEditAutoCompleteWnd
  • m_nWndWidth : CXTPSyntaxEditAutoCompleteWnd
  • m_nWorkAreaMax : CXTPTrackControl
  • m_nWorkAreaMin : CXTPTrackControl
  • m_odtValue : CXTPGridRecordItemDateTime
  • m_oleDate : CXTPPropertyGridItemDate
  • m_oleValue : CXTPGridRecordItemVariant
  • m_OwnerUser : CXTPCalendarControl
  • m_p : CXTPChartPolylineDeviceCommand, CXTPChartSplineDeviceCommand
  • m_p1 : CXTPChart3dLineDeviceCommand, CXTPChartLineDeviceCommand
  • m_p2 : CXTPChart3dLineDeviceCommand, CXTPChartLineDeviceCommand
  • m_p3dPointView : CXTPChart3dFunnelSeriesLabelView, CXTPChart3dPieSeriesLabelView, CXTPChart3dPyramidSeriesLabelView
  • m_pAccelTable : CXTPShortcutManager
  • m_pAction : CXTPControl, CXTPControlGalleryItems
  • m_pActions : CXTPCommandBars, CXTPControlAction
  • m_pActiveGroup : CXTPTaskPanel
  • m_pActiveItem : CXTPGridControl
  • m_pActivePage : CXTPFlowGraphControl, CXTPPropertySheet
  • m_pActivePane : CXTPDockingPaneManager
  • m_pActiveWnd : CXTPDockingPaneAutoHidePanel
  • m_pActiveWorkspace : CXTPTabClientWnd
  • m_Page2 : CXTPSyntaxEditPropertiesDlg
  • m_Page3 : CXTPSyntaxEditPropertiesDlg
  • m_PageOffset : CXTPPreviewView
  • m_paintTheme : CXTPPopupControl, CXTPShortcutBar, CXTPTaskPanel
  • m_panelBehaviour : CXTPTaskPanel
  • m_pAnimation : CXTPCommandBar, CXTPShortcutBar, CXTPTaskPanel
  • m_pAppearance : CXTPChartContent
  • m_pAppearanceSet : CXTPTabPaintManager
  • m_parLexClassInfo : CXTPSyntaxEditPropertiesPageColor
  • m_pAutoComplete : CXTPSyntaxEditCtrl
  • m_pAutoCompleteWnd : CXTPControlComboBox, CXTPControlEdit
  • m_pAxis : CXTPChartAxisRange
  • m_pAxisAppearance : CXTPChartDiagram2DAppearance
  • m_pAxisViews : CXTPChartDiagram2DView, CXTPChartRadarDiagramView
  • m_pAxisX : CXTPChartRadarDiagram
  • m_pAxisY : CXTPChartRadarDiagram
  • m_pBar : CXTPDockContext
  • m_pBindBool : CXTPPropertyGridItemBool
  • m_pBindColor : CXTPPropertyGridItemColor
  • m_pBindDate : CXTPPropertyGridItemDate
  • m_pBindDouble : CXTPPropertyGridItemDouble
  • m_pBindEnum : CXTPPropertyGridItemEnum
  • m_pBindNumber : CXTPPropertyGridItemNumber
  • m_pBindOption : CXTPPropertyGridItemOption
  • m_pBindString : CXTPPropertyGridItem
  • m_pBits : CXTPImageManagerIconHandle, CXTPImageManagerResource, CXTPResourceImage
  • m_pBlock : CXTPTrackUndoAddBlockCommand, CXTPTrackUndoDeleteBlockCommand, CXTPTrackUndoSetBlockPositionCommand
  • m_pBoldFont : CXTPExcelTabCtrl
  • m_pBorder : CXTPChartAreaSeriesStyle, CXTPChartContent, CXTPChartLegend, CXTPChartPieSeriesStyleBase, CXTPChartRadarAreaSeriesStyle, CXTPChartSeriesLabel, CXTPGridRecordItem, CXTPGridSection
  • m_pBtnExpando : CXTPTaskDialogClient
  • m_pBtnVerify : CXTPTaskDialogClient
  • m_pBuffer : CXTPSyntaxEditCtrl
  • m_pBufferMgr : CXTPSyntaxEditBufferCommand
  • m_pButtonCaptured : CXTPDatePickerControl
  • m_pButtonHot : CXTPSkinObjectFrame
  • m_pButtonPressed : CXTPSkinObjectFrame
  • m_pButtonViewDay : CXTPCalendarCaptionBarTheme
  • m_pButtonViewMonth : CXTPCalendarCaptionBarTheme
  • m_pButtonViewWeek : CXTPCalendarCaptionBarTheme
  • m_pCalendar : CXTPCalendarCaptionBarTheme, CXTPCalendarRemindersDialog
  • m_pCalendarCtrl : CXTPCalendarController, CXTPCalendarEventColorDlg, CXTPCalendarResource
  • m_pCalendarOptions : CXTPCalendarData
  • m_pCallbackParam : CXTPDatePickerControl
  • m_pCaption : CXTPCaptionButton
  • m_pCaptionBar : CXTPCalendarCaptionBarTheme
  • m_pCaptionButtons : CXTPCommandBarsFrameHook, CXTPDockingPaneBase
  • m_pCaptionMetrics : CXTPPropertyGridItem
  • m_pCaptureView : CXTPChartControl
  • m_pCategories : CXTPCalendarEventCategoryComboBox, CXTPPropertyGridView
  • m_pCell : CXTPColorHex
  • m_pChildParent : CXTPCaptionPopupWnd
  • m_pChildren : CXTPCalendarTimeLineViewGroup, CXTPGridRecord
  • m_pChilds : CXTPGridRow, CXTPPropertyGridItem
  • m_pChildWnd : CXTPCaption, CXTPCaptionPopupWnd
  • m_pClassMap : CXTPSkinManager
  • m_pClipToBoundsProperty : CXTPMarkupUIElement
  • m_pColorDlg : CXTPColorSelectorCtrl
  • m_pColorSet : CXTPTabPaintManager
  • m_pColumn : CXTPGridHeaderDragWnd
  • m_pColumns : CXTPGridColumn, CXTPGridColumnOrder, CXTPGridControl, CXTPGridHeader
  • m_pComboBox : CXTPFontCtrlBase, CXTPShellTreeBase
  • m_pCommand : CXTPChartControl
  • m_pCommandBar : CXTPControlPopup, CXTPPreviewView
  • m_pCommandBars : CXTPCommandBar, CXTPCommandBarKeyboardTip, CXTPCommandBarList, CXTPCommandBarScrollBarCtrl, CXTPCommandBarsFrameHook, CXTPControlActions, CXTPControls, CXTPCustomizeCommandsListBox, CXTPCustomizeSheet, CXTPDockBar, CXTPMessageBar, CXTPRibbonCustomizePage, CXTPRibbonCustomizeQuickAccessPage, CXTPShortcutManager
  • m_pConfig : CXTPTaskDialogClient
  • m_pConnection : CXTPCalendarData, CXTPCalendarRemindersManager, CXTPDatePickerControl, CXTPFlowGraphUndoAddConnectionCommand, CXTPFlowGraphUndoDeleteConnectionCommand, CXTPFlowGraphUndoSetConnectionPositionCommand, CXTPGridDataManager, CXTPResourceImages, CXTPSyntaxEditBufferManager
  • m_pConnectionPoint : CXTPFlowGraphUndoAddConnectionPointCommand, CXTPFlowGraphUndoDeleteConnectionPointCommand
  • m_pConnectionPoints : CXTPFlowGraphNode
  • m_pConnections : CXTPFlowGraphPage
  • m_pConstantLines : CXTPChartAxis
  • m_pConstraints : CXTPGridRecordItemEditOptions, CXTPPropertyGridItem
  • m_pContainer : CXTPChartDeviceContext, CXTPChartElementView, CXTPPropExchangeEnumerator
  • m_pContent : CXTPChartContentView, CXTPChartControl
  • m_pContentAppearance : CXTPChartAppearance
  • m_pContentView : CXTPChartControl
  • m_pContext : CXTPDockingPaneContextStickerWnd, CXTPToolTipContextToolTip
  • m_pContextHeader : CXTPRibbonTab
  • m_pContextHeaders : CXTPRibbonBar
  • m_pContextMenu : CXTPCustomizeMenusPage, CXTPCustomizeSheet, CXTPMiniToolBar
  • m_pContextMenus : CXTPCommandBars
  • m_pControl : CXTPCalendarPaintManager, CXTPCalendarView, CXTPControlComboBoxEditCtrl, CXTPControlEditCtrl, CXTPControlSliderCtrl, CXTPDatePickerDaysCollection, CXTPDatePickerItemDay, CXTPDatePickerItemMonth, CXTPDatePickerList, CXTPFlowGraphPage, CXTPFlowGraphPageHistory, CXTPFlowGraphPages, CXTPGridColumns, CXTPGridControl::CUpdateContext, CXTPGridHeader, CXTPGridPaintManager, CXTPGridRecord, CXTPGridRecordItem, CXTPGridRecords, CXTPGridRow, CXTPGridSection, CXTPGridSections, CXTPPopupItem, CXTPTrackMarker, CXTPTrackMarkers
  • m_pControlGroupOption : CXTPRibbonGroup
  • m_pControlGroupPopup : CXTPRibbonGroup
  • m_pControlPopup : CXTPPopupBar
  • m_pControlQuickAccess : CXTPRibbonBar
  • m_pControlQuickAccessMore : CXTPRibbonBar
  • m_pControls : CXTPCommandBar, CXTPControl, CXTPMenuBarMDIMenuInfo
  • m_pControlSystemButton : CXTPRibbonBar
  • m_pControlTab : CXTPRibbonBar
  • m_pcsActive : CXTPDockingPaneVisualStudio2012Theme
  • m_pcsInactive : CXTPDockingPaneVisualStudio2012Theme
  • m_pcszString : CXTPHeapString
  • m_pCurSel : CXTPTagCloudCtrl
  • m_pCustomIcons : CXTPCustomizeSheet
  • m_pCustomIconsIDs : CXTPCalendarEvent
  • m_pCustomLabels : CXTPChartAxis
  • m_pCustomProperties : CXTPCalendarData, CXTPCalendarEvent, CXTPCalendarSchedule
  • m_pData : CXTPCalendarEventColorListBox, CXTPHexEdit, CXTPSyntaxEditTextIterator
  • m_pDataManager : CXTPGridControl
  • m_pDataProvider : CXTPCalendarEvent, CXTPCalendarOptions, CXTPCalendarResource
  • m_pDataSource : CXTPGridDataManager
  • m_pDateLabel : CXTPCalendarCaptionBarTheme
  • m_pDatePickerCtrl : CXTPCalendarController
  • m_pDayView : CXTPCalendarDayViewTimeScale
  • m_pDC : CXTPCalendarShadowDrawer
  • m_pdc : CXTPResourceImages
  • m_pDeleteRecords : CXTPGridDataManager
  • m_pDesignerControls : CXTPCommandBars
  • m_pDiagram : CXTPChartAxis, CXTPChartDiagramView, CXTPChartSeries
  • m_pDiagram2DAppearance : CXTPChartAppearance
  • m_pDiagram3DAppearance : CXTPChartAppearance
  • m_pDiagramView : CXTPChartContentView
  • m_pDirThread : CXTPShellListBase
  • m_pDisplayOptions : CXTPGridColumn
  • m_pDockBar : CXTPToolBar
  • m_pDockBarClass : CXTPCommandBars
  • m_pDockContext : CXTPToolBar
  • m_pDockingContext : CXTPDockingPaneManager
  • m_pDockingSite : CXTPDockingPaneBase
  • m_pDocks : CXTPCommandBars
  • m_pDomain : CXTPChartFunnelSeriesViewBase, CXTPChartPyramidSeriesViewBase
  • m_pDragColumn : CXTPGridHeader
  • m_pDragSelected : CXTPCommandBars
  • m_pDragWnd : CXTPGridHeader, CXTPGridSubListControl
  • m_pDrawingObjectFactory : CXTPChartDeviceContext
  • m_pDrawTextProcessor : CXTPSyntaxEditCtrl
  • m_pDrawThread : CXTPChartControl
  • m_pDropRecords : CXTPGridControl
  • m_pDropSource : CXTPCommandBars
  • m_pDropTarget : CXTPDockingPaneTabbedContainer, CXTPGridControl, CXTPTaskPanel
  • m_pEdit : CXTPControlComboBox, CXTPControlEdit
  • m_pEditCtrl : CXTPSyntaxEditFindReplaceDlg, CXTPSyntaxEditGoToLineDlg, CXTPSyntaxEditView
  • m_pEditOptions : CXTPGridColumn, CXTPGridRecordItem
  • m_pEditView : CXTPSyntaxEditPropertiesPageColor, CXTPSyntaxEditPropertiesPageEdit, CXTPSyntaxEditPropertiesPageFont
  • m_pEditWnd : CXTPBrowseButton
  • m_pElement : CXTPChartHitTestElementCommand, CXTPFlowGraphEditItem
  • m_penGray : CXTPSyntaxEditPaintManager
  • m_pErrorBar : CXTPChartSeriesStyle
  • m_pEvent : CXTPCalendarEventColorDlg, CXTPCalendarEventColorListBox
  • m_pEventCategories : CXTPCalendarData
  • m_pEventCategoryIDs : CXTPCalendarEvent
  • m_pEventDataProvider : CXTPCalendarReminder
  • m_pExpandButton : CXTPCalendarCaptionBarTheme
  • m_pExpandIcon : CXTPShortcutBarPaintManager
  • m_pExpandSigns : CXTPCalendarPaintManager
  • m_pExtendedColors : CXTPColorPicker, CXTPColorSelectorCtrl
  • m_pFileDialog : CXTPBrowseEdit
  • m_pFillStyle : CXTPChartAreaSeriesStyle, CXTPChartAxisStrip, CXTPChartLegend, CXTPChartRadarAreaSeriesStyle
  • m_pFilterEdit : CXTPGridHeader
  • m_pFinanceStyleAppearance : CXTPChartAppearance
  • m_pFindReplaceDlg : CXTPSyntaxEditView
  • m_pFirstVisibleConnection : CXTPFlowGraphPage
  • m_pFirstVisibleNode : CXTPFlowGraphPage
  • m_pfnCallback : CXTPDatePickerControl
  • m_pfnCompare : CXTPSortClass
  • m_pfnSetLayeredWindowAttributes : CXTPDockingPaneContext, CXTPDockingPaneManager, CXTPMiniToolBar, CXTPPaintManager
  • m_pfnUpdateLayeredWindow : CXTPMiniToolBar
  • m_pFocusableProperty : CXTPMarkupUIElement
  • m_pFocusedButton : CXTPPropertyGridView
  • m_pFocusedColumn : CXTPGridControl
  • m_pFocusedItemControl : CXTPGridRecordItem
  • m_pFont : CXTPCalendarTip, CXTPChartAxisConstantLine, CXTPChartAxisLabel, CXTPChartAxisTitle, CXTPChartLegend, CXTPChartMarkupElementDeviceCommand, CXTPChartSeriesLabel, CXTPChartTextDeviceCommand, CXTPChartTitle
  • m_pFontCaption : CXTPGridRecordItem
  • m_pFontTip : CXTPTipOfTheDay
  • m_pFontTitle : CXTPTipOfTheDay
  • m_pFrame : CXTPCommandBars, CXTPSkinObjectFrame::CCaptionButton
  • m_pFrameHook : CXTPCommandBars
  • m_pFramePaintManager : CXTPPaintManager
  • m_pGalleryPaintManager : CXTPPaintManager
  • m_pGlyphs : CXTPCalendarPaintManager, CXTPGridPaintManager
  • m_pGlyphsFont : CXTPCalendarPaintManager
  • m_pGrid : CXTPCalendarMonthView, CXTPGridView, CXTPPropertyGridInplaceEdit, CXTPPropertyGridItem, CXTPPropertyGridPaintManager, CXTPPropertyGridToolTip, CXTPPropertyGridVerbs, CXTPPropertyGridView
  • m_pGridControl : CXTPGridDataManager, CXTPGridNavigator, CXTPGridTip
  • m_pGridCtrl : CXTPGridFilterEditControl, CXTPGridSubListControl
  • m_pGridHeader : CXTPGridControl
  • m_pGridLines : CXTPChartAxis
  • m_pGroup : CXTPCalendarTimeLineViewEvent, CXTPFlowGraphNode
  • m_pGroups : CXTPCalendarTimeLineView, CXTPFlowGraphNodeGroup, CXTPFlowGraphPage, CXTPRibbonGroup, CXTPRibbonTab, CXTPTaskPanel
  • m_pGroupsOrder : CXTPGridColumns
  • m_pHeader : CXTPGridHeaderDragWnd
  • m_pHighlighted : CXTPShortcutBarPane, CXTPStatusBarSwitchPane, CXTPTabManager
  • m_pHighlightedNavigateButton : CXTPTabManager
  • m_pHighlightedPane : CXTPStatusBar
  • m_pHistory : CXTPFlowGraphControl
  • m_pHotButton : CXTPMessageBar, CXTPPropertyGridView
  • m_pHotExpandButtonRow : CXTPGridControl
  • m_pHotHyperlink : CXTPGridControl
  • m_pHotItem : CXTPShortcutBar
  • m_pHotRow : CXTPGridControl
  • m_pHotTrackingColumn : CXTPGridHeader
  • m_pHover : CXTPTagCloudCtrl
  • m_pHyperlinkHoverStyle : CXTPGridPaintManager
  • m_pHyperlinks : CXTPGridRecordItem
  • m_pHyperlinkStyle : CXTPGridPaintManager
  • m_pIcon : CXTPButton, CXTPFlowGraphImage, CXTPShortcutListBox::CONTENT_ITEM, CXTPToolTipContextToolTip
  • m_pIcons : CXTPRibbonControlSystemPopupBarPinableListItem
  • m_pidlINet : CXTPShellListBase
  • m_pImage : CXTPFlowGraphImage
  • m_pImageManager : CXTPCommandBar, CXTPCommandBars, CXTPControlGalleryItems, CXTPDockingPaneManager, CXTPFlowGraphImages, CXTPGridControl, CXTPHeaderCtrl, CXTPImageManagerIconHandle, CXTPImageManagerResource, CXTPPopupControl, CXTPPropertyGrid, CXTPShortcutBar, CXTPSyntaxEditAutoCompleteWnd, CXTPTaskPanel
  • m_pImages : CXTPCommandBarsModernUITheme, CXTPFlowGraphControl, CXTPResourceImage, CXTPSkinManagerClass
  • m_pImmWrapper : CXTPSyntaxEditCtrl
  • m_pIniFile : CXTPSkinManagerResourceFile
  • m_pInlines : CXTPMarkupTextBlock
  • m_pInplaceButtons : CXTPGridControl, CXTPPropertyGridItem
  • m_pInplaceControls : CXTPPropertyGridItem
  • m_pInplaceEdit : CXTPGridControl, CXTPPropertyGrid
  • m_pInplaceList : CXTPGridControl
  • m_pInplaceListBox : CXTPPropertyGrid
  • m_pInputPoint : CXTPFlowGraphConnection
  • m_pInterlacedFillStyle : CXTPChartAxis
  • m_pIsEnabledProperty : CXTPMarkupUIElement
  • m_pItem : CXTPGridTip, CXTPPropertyGridInplaceControl, CXTPPropertyGridInplaceEdit, CXTPPropertyGridInplaceMonthCal, CXTPPropertyGridItemConstraint, CXTPTabManagerNavigateButton, CXTPTrackBlock
  • m_pItemControlHookWnd : CXTPGridRecordItem
  • m_pItemControls : CXTPGridRecordItem
  • m_pItemDragging : CXTPTaskPanel
  • m_pItemDragOver : CXTPTaskPanel
  • m_pItemEdit : CXTPEditListBox
  • m_pItemFocused : CXTPTaskPanel
  • m_pItemHot : CXTPTaskPanel
  • m_pItemPressed : CXTPTaskPanel
  • m_pItems : CXTPControlGalleryItem, CXTPTaskPanelGroup, CXTPTaskPanelItem
  • m_pKeyboardManager : CXTPCommandBars
  • m_pKeyNameText : CXTPShortcutManager
  • m_pLabel : CXTPChartAxis, CXTPChartSeriesStyle
  • m_pLabelList : CXTPCalendarData
  • m_pLabelsView : CXTPChartDiagramView
  • m_pLanguageInfo : CXTPResourceManager
  • m_pLastActiveView : CXTPTabExBase
  • m_pLastEvent : CXTPCalendarView
  • m_pLastStickerPane : CXTPDockingPaneContext
  • m_pLayerBits : CXTPResourceImages
  • m_pLayout : CXTPDockingPaneBase, CXTPDockingPaneManager
  • m_pLegend : CXTPChartContent, CXTPChartLegendView
  • m_pLegendAppearance : CXTPChartContentAppearance
  • m_pLegendItem : CXTPChartSeries
  • m_pLegendView : CXTPChartContentView
  • m_pLexParser : CXTPSyntaxEditBufferManager
  • m_pLightBulbIcon : CXTPTipOfTheDay
  • m_pLineMarksManager : CXTPSyntaxEditBufferManager
  • m_pLineStyle : CXTPChartAxisConstantLine, CXTPChartAxisGridLines, CXTPChartFastLineSeriesStyle, CXTPChartLineSeriesStyle
  • m_pListBox : CXTPControlListBox, CXTPFontCtrlBase, CXTPSyntaxEditTipWnd
  • m_pListControl : CXTPDatePickerControl
  • m_pListCtrl : CXTPListBase, CXTPShellTreeCtrl, CXTPSortClass
  • m_pManager : CXTPDockingPaneContext, CXTPFlowGraphUndoGroupCommand, CXTPShortcutManagerAccelTable, CXTPSkinManagerResourceFile, CXTPSkinManagerSchema, CXTPSkinObject, CXTPTabManagerNavigateButton, CXTPTrackUndoGroupCommand
  • m_pMarker : CXTPTrackUndoAddMarkerCommand, CXTPTrackUndoDeleteMarkerCommand, CXTPTrackUndoSetMarkerPositionCommand
  • m_pMarkers : CXTPTrackControl
  • m_pMarkup : CXTPFlowGraphNode
  • m_pMarkupCaption : CXTPPropertyGridItem
  • m_pMarkupContext : CXTPButton, CXTPCalendarControl, CXTPChartContent, CXTPComboBox, CXTPCommandBarsModernUITheme, CXTPFlowGraphControl, CXTPFrameThemeOffice2007System, CXTPGridControl, CXTPGridRecords, CXTPGridSection, CXTPMessageBar, CXTPPopupControl, CXTPPropertyGrid, CXTPRibbonMarkupTheme, CXTPStatusBar, CXTPTabClientWnd, CXTPTabManager, CXTPTaskDialogClient, CXTPTaskPanel, CXTPTipOfTheDay
  • m_pMarkupDescription : CXTPPropertyGridItem
  • m_pMarkupTipText : CXTPTipOfTheDay
  • m_pMarkupUIElement : CXTPChartMarkupElementDeviceCommand, CXTPControlMarkupLabel, CXTPGridColumn, CXTPGridGroupRow, CXTPGridRecordItem, CXTPMarkupThemePart, CXTPStatusBarPane, CXTPTabManagerItem, CXTPTaskPanelItem
  • m_pMarkupUIElement_NoGroupBy : CXTPGridPaintManager
  • m_pMarkupValue : CXTPPropertyGridItem
  • m_pMasterView : CXTPCalendarViewEvent
  • m_pMDIClientWnd : CXTPMDIWndTab
  • m_pMDIFrameWnd : CXTPMDIWndTab, CXTPWindowList
  • m_pMDIMenus : CXTPMenuBar
  • m_pMDIWndTab : CXTPMDIClientWnd
  • m_pMenuBar : CXTPMenuBarMDIMenus
  • m_pMenuBarClass : CXTPCommandBars
  • m_pMenuTitleBar : CXTPCommandBarsFrameHook
  • m_pMenuTitleBarClass : CXTPCommandBars
  • m_pMetrics : CXTPPropertyGridPaintManager, CXTPSkinManagerSchema
  • m_pMinorLineStyle : CXTPChartAxisGridLines
  • m_pModuleContext : CXTPToolTipContext
  • m_pMonth : CXTPDatePickerItemDay
  • m_pMouseManager : CXTPCommandBars
  • m_pNavBtns : CXTPTabBase
  • m_pNavigator : CXTPGridControl, CXTPPropertySheet
  • m_pNextVisibleConnection : CXTPFlowGraphConnection
  • m_pNextVisibleNode : CXTPFlowGraphNode
  • m_pNode : CXTPFlowGraphConnectionPoint, CXTPFlowGraphConnectionPoints, CXTPFlowGraphUndoAddNodeCommand, CXTPFlowGraphUndoDeleteConnectionPointCommand, CXTPFlowGraphUndoDeleteNodeCommand, CXTPFlowGraphUndoSetNodeCaptionCommand, CXTPFlowGraphUndoSetNodePositionCommand, CXTPFlowGraphUndoSetNodeSizeCommand
  • m_pNodes : CXTPFlowGraphPage
  • m_pNormFont : CXTPExcelTabCtrl
  • m_pnTabStopPositions : CXTPTipWindow
  • m_pObject : CXTPSmartPtrInternalT< _TObject >
  • m_point : CXTPColorSelectorCtrl, CXTPShortcutListBox, CXTPSplitterWnd
  • m_points : CXTPChartBoundedPolygonDeviceCommand, CXTPChartPolygonDeviceCommand
  • m_pointTipOffsetPos : CXTPTipWindow
  • m_pOldItem : CXTPTrackUndoDeleteBlockCommand
  • m_pOldWndProc : CXTPSkinObject
  • m_pOpacityProperty : CXTPMarkupUIElement
  • m_pOptions : CXTPCalendarPageSetupDialog, CXTPCommandBars, CXTPGridPageSetupDialog
  • m_popupAnimation : CXTPPopupControl
  • m_popupFlags : CXTPPopupBar
  • m_popupMenuID : CXTPHeaderCtrl, CXTPMDIWndTab, CXTPTabExBase
  • m_popupState : CXTPPopupControl
  • m_pOriginalAccelTable : CXTPShortcutManager
  • m_pOriginalControls : CXTPControls
  • m_pOriginalWindowProc : CXTPFlowGraphNode
  • m_posEnd : CXTPSyntaxEditTextRegion
  • m_PosEndLC : CXTPSyntaxEditLexTextBlock
  • m_posFirstUndo : CXTPSyntaxEditUndoRedoManager
  • m_posSavedMark : CXTPSyntaxEditUndoRedoManager
  • m_posStart : CXTPSyntaxEditTextRegion
  • m_PosStartLC : CXTPSyntaxEditLexTextBlock
  • m_pOutputPoint : CXTPFlowGraphConnection
  • m_pOwner : CXTPCalendarViewEventSubjectEditor, CXTPChartFillStyle, CXTPChartLineStyle, CXTPCommandBar, CXTPCommandBarKeyboardTip, CXTPPropExchange, CXTPTaskPanelItems
  • m_pOwnerRecord : CXTPGridRecords
  • m_pOwnerWnd : CXTPCalendarEventPropertiesDlg
  • m_pPage : CXTPFlowGraphConnection, CXTPFlowGraphConnections, CXTPFlowGraphNode, CXTPFlowGraphNodeGroups, CXTPFlowGraphNodes, CXTPFlowGraphSelectedElements, CXTPFlowGraphUndoDeleteConnectionCommand, CXTPFlowGraphUndoDeleteNodeCommand
  • m_pPageCommands : CXTPCustomizeSheet
  • m_pPageInfo2 : CXTPPreviewView
  • m_pPages : CXTPFlowGraphControl
  • m_pPageToolBars : CXTPCustomizeSheet
  • m_pPaintManager : CXTPCalendarViewPart, CXTPCommandBar, CXTPCommandBars, CXTPCommandBarsFrameHook, CXTPDatePickerControl, CXTPDockingPaneManager, CXTPFlowGraphControl, CXTPFramePaintManager, CXTPGridControl, CXTPGridHeaderDragWnd, CXTPMarqueeCtrl, CXTPMessageBarPaintManager, CXTPPopupControl, CXTPProgressCtrl, CXTPProgressPaintManager, CXTPPropertyGrid, CXTPPropertyGridItemMetrics, CXTPRibbonPaintManager, CXTPShortcutBar, CXTPTabClientWnd, CXTPTabPaintManagerColorSet, CXTPTabPaintManagerTheme, CXTPTaskPanel
  • m_pPaintManeger : CXTPSyntaxEditCtrl
  • m_pPalette : CXTPChartAppearance
  • m_pPane : CXTPChartDiagram2D, CXTPDockingPaneCaptionButton, CXTPDockingPaneContext, CXTPShortcutBarPaneItem
  • m_pPanel : CXTPTaskPanelItem, CXTPTaskPanelItems
  • m_pPanelPaintManager : CXTPDockingPanePaintManager
  • m_pPanels : CXTPChartContent
  • m_pPaneView : CXTPChartDiagram2DView
  • m_pParent : CXTPControl, CXTPControls, CXTPFlowGraphImage, CXTPPropertyGridItem, CXTPRibbonGroup, CXTPRibbonTab
  • m_pParentContainer : CXTPDockingPaneBase
  • m_pParentFrame : CXTPTabClientWnd, CXTPTabExBase
  • m_pParentGroup : CXTPCalendarTimeLineViewGroup
  • m_pParentPart : CXTPCalendarViewPart
  • m_pParentRow : CXTPGridRow
  • m_pParentRows : CXTPGridRow
  • m_pParentSheet : CXTPColorPageCustom, CXTPColorPageStandard
  • m_pParentTab : CXTPRibbonGroups
  • m_pParentView : CXTPCalendarTimeLineViewTimeScale, CXTPCaption, CXTPChartElementView
  • m_pParentWnd : CXTPCalendarTip, CXTPCaptionPopupWnd, CXTPColorSelectorCtrl, CXTPEditListBox, CXTPGridTip, CXTPSyntaxEditAutoCompleteWnd, CXTPSyntaxEditCtrl, CXTPSyntaxEditToolTipCtrl, CXTPTabExBase, CXTPTipWindow
  • m_pPath : CXTPFlowGraphConnection
  • m_pPieStyleAppearance : CXTPChartAppearance
  • m_pPoint : CXTPChartSeriesPointView
  • m_pPointLegendFormat : CXTPChartSeries
  • m_pPoints : CXTPChartSeries
  • m_pPopupBar : CXTPDialogBar
  • m_pPopupBarClass : CXTPCommandBars
  • m_pPopupToolBarClass : CXTPCommandBars
  • m_pPopupWnd : CXTPCaption
  • m_pPressed : CXTPPopupControl, CXTPTabManager
  • m_pPressedItem : CXTPShortcutBar
  • m_pPrevGroupsOrder : CXTPGridControl
  • m_pPreviewItem : CXTPGridRecord
  • m_pPreviewLayout : CXTPDockingPaneManager
  • m_pPrevUndoBuffer : CXTPCalendarView
  • m_pPrevVisible : CXTPGridControl
  • m_pPrintOptions : CXTPCalendarControlView, CXTPGridView, CXTPSyntaxEditView
  • m_pProgressPaintManager : CXTPPaintManager
  • m_pPropertyAngle : CXTPMarkupRotateTransform
  • m_pPropertyAngleX : CXTPMarkupSkewTransform
  • m_pPropertyAngleY : CXTPMarkupSkewTransform
  • m_pPropertyCenterX : CXTPMarkupRotateTransform, CXTPMarkupScaleTransform, CXTPMarkupSkewTransform
  • m_pPropertyCenterY : CXTPMarkupRotateTransform, CXTPMarkupScaleTransform, CXTPMarkupSkewTransform
  • m_pPropertyScaleX : CXTPMarkupScaleTransform
  • m_pPropertyScaleY : CXTPMarkupScaleTransform
  • m_pPropertyX : CXTPMarkupTranslateTransform
  • m_pPropertyY : CXTPMarkupTranslateTransform
  • m_pQuickAccessControls : CXTPRibbonBar
  • m_pRange : CXTPChartAxis
  • m_pRecord : CXTPGridRecordItem, CXTPGridRow
  • m_pRecordItem : CXTPGridRecordItemControls
  • m_pRecords : CXTPGridRecord, CXTPGridSection
  • m_pRegExp : CXTPEdit
  • m_pRemindersMan : CXTPCalendarRemindersDialog
  • m_pRemindersManager : CXTPCalendarControl
  • m_pRenderTransformOriginProperty : CXTPMarkupUIElement
  • m_pRenderTransformProperty : CXTPMarkupUIElement
  • m_pResizeColumn : CXTPGridHeader
  • m_pResourceFile : CXTPSkinManager, CXTPSkinManagerSchema
  • m_pResources : CXTPCalendarView, CXTPCalendarViewDay, CXTPCalendarViewGroup
  • m_pResourcesNf : CXTPCalendarRemindersManager
  • m_pReturnCmd : CXTPCommandBar
  • m_pRibbonBar : CXTPCommandBarsFrameHook, CXTPRibbonGroup, CXTPRibbonTab, CXTPRibbonTabPopupToolBar
  • m_pRibbonGroup : CXTPControl
  • m_pRibbonPaintManager : CXTPPaintManager
  • m_pRibbonTab : CXTPRibbonTabPopupToolBar
  • m_pRichRender : CXTPPopupItem
  • m_pRInfo : CXTPImageManagerIconHandle
  • m_PrintPageWidth : CXTPCalendarPaintManager, CXTPGridPaintManager
  • m_properetySort : CXTPPropertyGridView
  • m_propertySort : CXTPPropertyGridUpdateContext
  • m_pRowIndexer : CXTPTabManager
  • m_pRows : CXTPGridControl, CXTPGridSection
  • m_pRowsCompareFunc : CXTPGridControl
  • m_pRstEvent : CXTPGridDataManager
  • m_pSBTrack : CXTPScrollBase, CXTPSkinObjectFrame
  • m_pScaleTypeMap : CXTPChartAxis
  • m_pSchedules : CXTPCalendarData
  • m_pSchema : CXTPSkinManager, CXTPSkinManagerClass, CXTPSkinManagerMetrics
  • m_pScreenRows : CXTPGridRows
  • m_pScrollBarHor : CXTPGridView
  • m_pScrollBarPaintManager : CXTPPaintManager
  • m_pScrollBarVer : CXTPGridView
  • m_pScrollButton : CXTPTaskPanel
  • m_pScrollNextDate : CXTPCalendarCaptionBarTheme
  • m_pScrollPrevDate : CXTPCalendarCaptionBarTheme
  • m_pSection : CXTPGridRow
  • m_pSelected : CXTPCommandBarsFrameHook, CXTPPopupControl, CXTPPropertyGridView, CXTPTabManager
  • m_pSelectedBlocks : CXTPTrackControl
  • m_pSelectedConstraint : CXTPGridInplaceEdit
  • m_pSelectedDays : CXTPDatePickerControl
  • m_pSelectedElements : CXTPFlowGraphPage
  • m_pSelectedEvents : CXTPCalendarView
  • m_pSelectedItem : CXTPShortcutBar
  • m_pSelectedPane : CXTPDockingPaneTabbedContainer
  • m_pSelectedRows : CXTPGridControl
  • m_pSelectedRowsBeforeDrag : CXTPGridControl
  • m_pSelection : CXTPSyntaxEditCtrl
  • m_pSeries : CXTPChartContent
  • m_pSeriesLabelsView : CXTPChart3dFunnelSeriesLabelsViewDeviceCommand, CXTPChart3dPieSeriesLabelsViewDeviceCommand
  • m_pSeriesView : CXTPChartDiagramView
  • m_pSetWindowTheme : CXTPSkinManager
  • m_pSetWinEventHook : CXTPSkinManager
  • m_psh : CXTPPropertySheet
  • m_pShadow : CXTPCommandBarsFrameHook
  • m_pShadowManager : CXTPColorPopup, CXTPPaintManager
  • m_pSheet : CXTPCustomizeCommandsPage, CXTPCustomizeKeyboardPage, CXTPCustomizeMenusPage, CXTPCustomizeOptionsPage, CXTPCustomizeToolbarsPage, CXTPPropertyPage, CXTPPropertyPageNavigator, CXTPRibbonCustomizePage, CXTPRibbonCustomizeQuickAccessPage
  • m_pShortcutBar : CXTPShortcutBarItem, CXTPShortcutBarPane
  • m_pShortcutManager : CXTPCommandBars
  • m_pShowFullWeek : CXTPCalendarCaptionBarTheme
  • m_pShowMcWeek : CXTPCalendarCaptionBarTheme
  • m_pShowTimeline : CXTPCalendarCaptionBarTheme
  • m_pShowWorkWeek : CXTPCalendarCaptionBarTheme
  • m_pSite : CXTPCommandBar, CXTPDockingPaneManager
  • m_pSliderCtrl : CXTPControlSlider
  • m_pSliderPaintManager : CXTPPaintManager
  • m_pSortOrder : CXTPGridColumns
  • m_pSplitterWnd : CXTPCaption
  • m_pStatusBar : CXTPStatusBarPane
  • m_pStatusBarPaintManager : CXTPPaintManager
  • m_pStickerPane : CXTPDockingPaneContext
  • m_pStorage : CXTPChartQualitativeScaleTypeMap
  • m_pStream : CXTPTipOfTheDay
  • m_pStrips : CXTPChartAxis
  • m_pStyle : CXTPChartSeries
  • m_pSubjectEditor : CXTPCalendarViewEvent
  • m_pSubList : CXTPGridHeader
  • m_pSyncWnd : CXTPShellListCtrlEx
  • m_pt : CXTPCommandBarKeyboardTip, CXTPHeaderCtrl
  • m_pTabCtrl : CXTPTabBase
  • m_pTabManager : CXTPTabManagerItem
  • m_pTabPaintManager : CXTPDockingPanePaintManager, CXTPRibbonPaintManager, CXTPTabToolBar
  • m_pTabWorkspace : CXTPTabClientWnd
  • m_pTarget : CXTPControlAction
  • m_pTaskPanel : CXTPTaskPanel::CRepositionContext
  • m_ptBasePoint : CXTPChartRotatedTextPainterBase
  • m_ptBend : CXTPChart3dFunnelSeriesLabelView, CXTPChart3dPieSeriesLabelView, CXTPChart3dPyramidSeriesLabelView
  • m_ptBorder : CXTPTaskDialogClient
  • m_ptBtnSpacing : CXTPTaskDialogClient
  • m_ptCenter : CXTPChartEllipse, CXTPChartPieDeviceCommandImpl
  • m_ptClick : CXTPPropertyGridVerb
  • m_ptContextMenu : CXTPCustomizeMenusPage
  • m_ptControlPoint : CXTPFlowGraphConnection
  • m_ptCursor : CXTPSyntaxEditTipWnd
  • m_ptDrag : CXTPGridControl
  • m_ptDropPos : CXTPSyntaxEditCtrl
  • m_pTearOffBar : CXTPPopupBar
  • m_ptEditPos : CXTPHexEdit
  • m_ptEnd : CXTPChart3dFunnelSeriesLabelView, CXTPChart3dPieSeriesLabelView, CXTPChart3dPyramidSeriesLabelView
  • m_pTextProvider : CXTPChartTextPainterBase
  • m_pTextSchemesMgr : CXTPSyntaxEditPropertiesPageColor
  • m_pTheme : CXTPButton, CXTPCalendarCaptionBarControl, CXTPCalendarCaptionBarPaintManager, CXTPCalendarCaptionBarThemePart, CXTPCalendarTip, CXTPCaption, CXTPColorSelectorCtrl, CXTPComboBox, CXTPEdit, CXTPExcelTabCtrl, CXTPHeaderCtrl, CXTPListBox, CXTPShortcutListBox, CXTPSplitterWnd, CXTPTabBase
  • m_pTickMarks : CXTPChartAxis
  • m_pTicks : CXTPScrollBase
  • m_pTimeScale : CXTPCalendarTimeLineView
  • m_pTimeScaleParams : CXTPCalendarTimeLineViewTimeScale
  • m_ptInputPoint : CXTPFlowGraphConnection
  • m_pTip : CXTPGridControl
  • m_pTitle : CXTPChartAxis
  • m_pTitleAppearance : CXTPChartContentAppearance
  • m_pTitles : CXTPChartContent
  • m_pTitlesView : CXTPChartContentView, CXTPChartDiagramView
  • m_ptLabelAnchor : CXTPChart3dFunnelSeriesLabelView, CXTPChart3dPieSeriesLabelView, CXTPChart3dPyramidSeriesLabelView
  • m_ptLabelAnchorOrigin : CXTPChart3dFunnelSeriesLabelView, CXTPChart3dPieSeriesLabelView, CXTPChart3dPyramidSeriesLabelView
  • m_ptLast : CXTPDockContext, CXTPDockingPaneContext
  • m_ptLightPosition : CXTPChart3dDeviceContext
  • m_ptLocation : CXTPFlowGraphNode
  • m_ptMargin : CXTPTaskDialogClient
  • m_ptMaxTrackSize : CXTPDockingPane
  • m_ptMinClientSize : CXTPDockingPaneManager
  • m_ptMinTrackSize : CXTPDockingPane
  • m_ptMouse : CXTPFlowGraphControl, CXTPGridHeader
  • m_ptMousePos : CXTPColorBase, CXTPTipWindow
  • m_ptMRUFloatPos : CXTPDockContext
  • m_ptNextPrintPos : CXTPSyntaxEditDrawTextProcessor
  • m_ptOffset : CXTPPopupItem
  • m_ptOldPosition : CXTPFlowGraphUndoSetConnectionPositionCommand, CXTPFlowGraphUndoSetNodePositionCommand
  • m_pToolBarClass : CXTPCommandBars
  • m_pToolTip : CXTPSyntaxEditCtrl, CXTPToolTipContext
  • m_pToolTipContext : CXTPButton, CXTPChartControl, CXTPCommandBar, CXTPCommandBars, CXTPDockingPaneManager, CXTPFlowGraphControl, CXTPGridControl, CXTPPropertyGrid, CXTPShortcutBar, CXTPTabClientWnd, CXTPTaskPanel
  • m_pTopContainer : CXTPDockingPaneMiniWnd
  • m_ptOutputPoint : CXTPFlowGraphConnection
  • m_ptPadding : CXTPTaskDialogClient
  • m_ptPopup : CXTPPopupBar, CXTPPopupControl
  • m_ptPressed : CXTPControlGallery, CXTPTaskPanel
  • m_ptPrevMouse : CXTPSyntaxEditCtrl
  • m_pTrackingPane : CXTPDockingPaneTabbedContainer
  • m_ptrClass : CXTPSyntaxEditLexVariant
  • m_ptrConfigMgr : CXTPSyntaxEditPropertiesPageColor
  • m_ptrControl : CXTPCalendarEventPropertiesDlg
  • m_ptrDataMan : CXTPSyntaxEditDoc
  • m_ptrDefaultLexConfigurationManager : CXTPSyntaxEditBufferManager
  • m_ptrDraggingEventNew : CXTPCalendarView
  • m_ptrDraggingEventOrig : CXTPCalendarView
  • m_ptrEditingEvent : CXTPCalendarEventPropertiesDlg
  • m_ptrEditingViewEvent : CXTPCalendarView
  • m_pTree : CXTPGridSection
  • m_pTreeColumn : CXTPGridColumns
  • m_pTreeCtrl : CXTPShellListCtrl
  • m_ptrEvent : CXTPCalendarViewEvent
  • m_ptrLastChild : CXTPSyntaxEditLexTextBlock
  • m_ptrLexClass : CXTPSyntaxEditLexTextBlock
  • m_ptrLexConfigurationManager : CXTPSyntaxEditBufferManager
  • m_ptrLVArrayPtr : CXTPSyntaxEditLexVariant
  • m_ptrMasterEvent : CXTPCalendarEventRecurrenceDlg
  • m_ptrNext : CXTPSyntaxEditLexTextBlock
  • m_ptRotateVector : CXTPChartRotateDeviceCommand
  • m_ptrParent : CXTPSyntaxEditLexTextBlock
  • m_ptrPattern : CXTPCalendarEventRecurrenceDlg
  • m_ptrPrev : CXTPSyntaxEditLexTextBlock
  • m_ptrResource : CXTPCalendarResourceDescription
  • m_ptrRPattern : CXTPCalendarEvent
  • m_ptrTBLast : CXTPSyntaxEditLexOnScreenParseCnt
  • m_ptrVirtualEditingRow : CXTPGridControl
  • m_pts : CXTPColorHex::CRgnCell
  • m_ptScrollOffset : CXTPFlowGraphPage
  • m_ptStart : CXTPChart3dFunnelSeriesLabelView, CXTPChart3dPieSeriesLabelView, CXTPChart3dPyramidSeriesLabelView
  • m_ptStartDrag : CXTPFlowGraphControl, CXTPTrackControl, CXTPTrackHeader
  • m_ptStartDragging : CXTPCalendarView
  • m_ptStartPoint : CXTPChartPieSeriesLabelView
  • m_ptSticky : CXTPDockingPaneContext
  • m_ptVisualOffset : CXTPMarkupVisual
  • m_ptWndPos : CXTPSyntaxEditFindReplaceDlg, CXTPSyntaxEditGoToLineDlg
  • m_pUIElement : CXTPButton, CXTPCalendarViewEvent, CXTPMessageBar, CXTPMessageBarButton, CXTPPopupItem
  • m_pUndoBuffer : CXTPCalendarView
  • m_pUndoGroup : CXTPFlowGraphUndoManager, CXTPTrackUndoManager
  • m_pUndoManager : CXTPFlowGraphControl, CXTPTrackControl
  • m_pUndoRedoManager : CXTPSyntaxEditBufferManager
  • m_pUnhookWinEvent : CXTPSkinManager
  • m_pValueCustom : CXTPCalendarViewPartCustomizableValueT< _TValue >
  • m_pValueMetrics : CXTPPropertyGridItem
  • m_pValueStandard : CXTPCalendarViewPartCustomizableValueT< _TValue >
  • m_pVerbs : CXTPPropertyGrid, CXTPPropertyGridVerb
  • m_pView : CXTPCalendarMonthView::CMonthViewGrid, CXTPCalendarViewDay, CXTPPropertyGrid
  • m_pViewDay : CXTPCalendarViewGroup
  • m_pViewEvent : CXTPCalendarViewEventSubjectEditorColored
  • m_pVirtualRow : CXTPGridRows
  • m_pVisibilityProperty : CXTPMarkupUIElement
  • m_pWindowFilter : CXTPSkinManager
  • m_pWindowSelectClass : CXTPDockingPaneManager
  • m_pWnd : CXTPResize, CXTPResizeItem
  • m_pWndClient : CXTPShortcutBarPaneItem
  • m_pWndEdit : CXTPCalendarEventColorListBox, CXTPComboBox
  • m_pWndLastFocus : CXTPExcelTabCtrl
  • m_pWndMonitor : CXTPToolTipContextToolTip
  • m_pWndParent : CXTPCustomizeSheet
  • m_radius : CXTPChartBoundedCircleDeviceCommand, CXTPChartCircleDeviceCommand
  • m_rcBlock : CXTPTrackBlock
  • m_rcBorder : CXTPTipOfTheDay
  • m_rcBorders : CXTPColorSelectorCtrl, CXTPControlCustom, CXTPDialogBar, CXTPPopupBar, CXTPSkinObjectFrame
  • m_rcBoundingRect : CXTPFlowGraphConnection
  • m_rcBoundRect : CXTPMarkupVisual
  • m_rcBounds : CXTPChart3dDeviceContext, CXTPChartContentView, CXTPChartDiagram2DAxisView, CXTPChartDiagramView, CXTPChartElementView, CXTPChartHitTestElementCommand, CXTPChartLegendView, CXTPChartPieSeriesLabelView, CXTPChartRadarAxisXView, CXTPChartRadarAxisYView, CXTPChartTextPainterBase
  • m_rcButton : CXTPDatePickerButton, CXTPDockingPaneCaptionButton, CXTPMessageBarButton, CXTPSkinObjectFrame::CCaptionButton, CXTPTabManagerNavigateButton
  • m_rcButtonMargin : CXTPPropertyPageNavigator, CXTPTabPaintManager
  • m_rcButtonTextPadding : CXTPTabPaintManager
  • m_rcCaption : CXTPRibbonBar, CXTPShortcutBarPaneItem
  • m_rcCaptionMargin : CXTPDockingPanePaintManager
  • m_rcCaptionPadding : CXTPShortcutBarPaintManager
  • m_rcCaptionText : CXTPRibbonBar
  • m_rcChild : CXTPCaption
  • m_rcClient : CXTPShortcutBar, CXTPShortcutBarPaneItem
  • m_rcClientMargin : CXTPTabPaintManager
  • m_rcClientMargins : CXTPDockingPaneManager
  • m_rcClip : CXTPChartClipDeviceCommand
  • m_rcCollapse : CXTPGridRow
  • m_rcColumn : CXTPGridColumn
  • m_rcCommandButtons : CXTPTaskDialogClient
  • m_rcContent : CXTPMessageBar, CXTPTaskDialogClient
  • m_rcControl : CXTPControl, CXTPDatePickerControl, CXTPGridRecordItemControl, CXTPTabManager
  • m_rcControlMargin : CXTPTabPaintManager
  • m_rcControlMargins : CXTPTaskPanelPaintManager
  • m_rcCurrent : CXTPColorDialog
  • m_rcDay : CXTPDatePickerItemDay
  • m_rcDaysArea : CXTPDatePickerItemMonth
  • m_rcDaysOfWeek : CXTPDatePickerItemMonth
  • m_rcDivider : CXTPGridSection
  • m_rcDragWnd : CXTPGridSubListControl
  • m_rcDropTarget1 : CXTPGridSubListControl
  • m_rcDropTarget2 : CXTPGridSubListControl
  • m_rcEndTime : CXTPCalendarViewEvent
  • m_rcEvent : CXTPCalendarViewEvent
  • m_rcEventMax : CXTPCalendarViewEvent
  • m_rcExclude : CXTPColorPopup, CXTPPopupBar
  • m_rcExpandedInformation : CXTPTaskDialogClient
  • m_rcFileButtonMargin : CXTPRibbonPaintManager
  • m_rcFinalRect : CXTPMarkupUIElement
  • m_rcFirstClock : CXTPCalendarViewEvent
  • m_rcFooter : CXTPTaskDialogClient
  • m_rcFooterArea : CXTPGridControl
  • m_rcGlyph : CXTPGridRecordItem
  • m_rcGrid : CXTPDatePickerControl
  • m_rcGripper : CXTPShortcutBar
  • m_rcGroup : CXTPRibbonGroup
  • m_rcGroupBy : CXTPGridColumn, CXTPGridHeader
  • m_rcGroupByArea : CXTPGridControl
  • m_rcGroupCurrent : CXTPTaskPanelGroup
  • m_rcGroupIconPadding : CXTPTaskPanelPaintManager
  • m_rcGroupInnerMargins : CXTPTaskPanelPaintManager
  • m_rcGroupOuterMargins : CXTPTaskPanelPaintManager
  • m_rcGroups : CXTPRibbonBar, CXTPRibbonTabPopupToolBar
  • m_rcGroupTarget : CXTPTaskPanelGroup
  • m_rcHeader : CXTPDatePickerItemMonth, CXTPGridHeader, CXTPRibbonBar
  • m_rcHeaderArea : CXTPGridControl
  • m_rcHeaderMargin : CXTPTabPaintManagerTheme
  • m_rcHeaderRect : CXTPTabManager
  • m_rcHover : CXTPCalendarTip, CXTPGridTip, CXTPSyntaxEditToolTipCtrl
  • m_rcHyperSpot : CXTPGridHyperlink
  • m_rcIconMargin : CXTPFramePaintManager
  • m_rcIconPadding : CXTPTaskPanelItem
  • m_rcImageLayoutIconPadding : CXTPTaskPanelPaintManager
  • m_rcIndent : CXTPShortcutBarPane
  • m_rcItem : CXTPPopupItem, CXTPShortcutBarItem, CXTPTabManagerItem, CXTPTaskPanelGroupItem
  • m_rcItemCaptionPadding : CXTPShortcutBarPaintManager
  • m_rcItemIconPadding : CXTPTaskPanelPaintManager
  • m_rcItemInnerMargins : CXTPTaskPanelPaintManager
  • m_rcItemOuterMargins : CXTPTaskPanelPaintManager
  • m_rcLabel : CXTPSearchOptionsCtrl
  • m_rcLastClock : CXTPCalendarViewEvent
  • m_rcLeftScroll : CXTPDatePickerItemMonth
  • m_rcLinkButtons : CXTPTaskDialogClient
  • m_rcListControl : CXTPDatePickerList
  • m_rcMainInstruction : CXTPTaskDialogClient
  • m_rcMargin : CXTPControlGallery, CXTPToolTipContext
  • m_rcMargins : CXTPStatusBarPane, CXTPTaskPanel, CXTPTaskPanelGroupItem
  • m_rcMarginsInner : CXTPTaskPanelGroup
  • m_rcMarginsOuter : CXTPTaskPanelGroup
  • m_rcMarker : CXTPCommandBar, CXTPTrackMarker
  • m_rcMaxPage : CXTPPropertySheet
  • m_rcMeetingGlyph : CXTPCalendarViewEvent
  • m_rcMessageBarMargin : CXTPPaintManager
  • m_rcMinPage : CXTPPropertySheet
  • m_rcMonth : CXTPDatePickerItemMonth
  • m_rcNavigatorMargin : CXTPPropertyPageNavigator
  • m_rcNew : CXTPColorDialog
  • m_rcPadding : CXTPControlSlider, CXTPStatusBarPane
  • m_rcPage : CXTPFlowGraphPage, CXTPPropertySheet
  • m_rcPageMargin : CXTPPropertyPageNavigator
  • m_rcPane : CXTPStatusBarPane
  • m_rcPaneBounds : CXTPChartRadarAxisYView
  • m_rcParent : CXTPCaption
  • m_rcPart : CXTPPropertyGridVerb
  • m_rcPreviewIndent : CXTPGridPaintManager
  • m_rcPrevUpdateRect : CXTPMarkupVisual
  • m_rcPrivateGlyph : CXTPCalendarViewEvent
  • m_rcQuickAccess : CXTPRibbonBar
  • m_rcRadioButtons : CXTPTaskDialogClient
  • m_rcRecentText : CXTPColorSelectorCtrlTheme
  • m_rcRect : CXTPCalendarCaptionBarTheme, CXTPCalendarCaptionBarThemePart, CXTPCalendarTimeLineViewTimeScale
  • m_rcRecurrenceGlyph : CXTPCalendarViewEvent
  • m_rcReminderGlyph : CXTPCalendarViewEvent
  • m_rcResizeGripper : CXTPPopupBar
  • m_rcRightScroll : CXTPDatePickerItemMonth
  • m_rcRoundedBounds : CXTPChartTextPainterBase
  • m_rcRow : CXTPControl, CXTPGridRow
  • m_rcScale : CXTPCalendarTimeLineViewTimeScale
  • m_rcScreenWindow : CXTPTipWindow
  • m_rcSection : CXTPGridSection
  • m_rcSections : CXTPGridSections
  • m_rcSelectedArea : CXTPFlowGraphControl, CXTPTrackControl
  • m_rcShadow : CXTPTipWindow
  • m_rcSideDockingMargin : CXTPDockingPaneManager
  • m_rcSplitter : CXTPCaption
  • m_rcStandardText : CXTPColorSelectorCtrlTheme
  • m_rcStartTime : CXTPCalendarViewEvent
  • m_rcStatusBarBorder : CXTPPaintManager
  • m_rcSubjectEditor : CXTPCalendarViewEvent
  • m_rcTabControl : CXTPRibbonBar, CXTPTabToolBar
  • m_rcTearOffGripper : CXTPPopupBar
  • m_rcText : CXTPCalendarViewEvent, CXTPTaskPanelItem
  • m_rcTextRect : CXTPSyntaxEditDrawTextProcessor
  • m_rcThemeText : CXTPColorSelectorCtrlTheme
  • m_rcTimeframe : CXTPCalendarDayViewEvent
  • m_rcTimelineArea : CXTPTrackControl
  • m_rcTipText : CXTPTipOfTheDay
  • m_rcToolTip : CXTPCalendarViewEvent, CXTPPropertyGridView
  • m_rcTooltip : CXTPCalendarView, CXTPGridTip
  • m_rcUpdateRect : CXTPMarkupVisual
  • m_rcView : CXTPCalendarView
  • m_rcWeekNumbers : CXTPDatePickerItemMonth
  • m_rcWindow : CXTPDockingPaneBase, CXTPSearchOptionsView, CXTPTipWindow
  • m_rcWnd : CXTPColorSelectorCtrl
  • m_rcWorkRect : CXTPFlowGraphNodeGroup, CXTPFlowGraphPage
  • m_RecordNumberWidth : CXTPGridPaintManager
  • m_rect : CXTPAnimationDC, CXTPChartBoundedTextDeviceCommand, CXTPChartMarkupElementDeviceCommand, CXTPChartRectangleDeviceCommand, CXTPColorHex::CRgnCell, CXTPExcelTabCtrlButtonState
  • m_rectDragDock : CXTPDockContext
  • m_rectDragFrame : CXTPDockContext, CXTPDockingPaneContext
  • m_rectDragFrameScreen : CXTPDockingPaneContext
  • m_rectGripper : CXTPExcelTabCtrl
  • m_rectMRUDockPos : CXTPDockContext
  • m_rectSB_H : CXTPExcelTabCtrl
  • m_rectStickerPane : CXTPDockingPaneContext
  • m_rectTabs : CXTPExcelTabCtrl
  • m_rectTipArea : CXTPTipWindow
  • m_rectViews : CXTPExcelTabCtrl
  • m_RecurrenceEventInfo : CXTPCalendarReminder
  • m_rgn : CXTPGridHeaderDropWnd
  • m_rgnList : CXTPColorHex
  • m_rotation : CXTPChart3dRotateDeviceCommand
  • m_Rotation3d : CXTPChartSeriesStyle
  • m_rrcInitWindow : CXTPResizeItem
  • m_rrcSizing : CXTPResizeItem
  • m_rrcWindow : CXTPResizeItem
  • m_rWindow : CXTPSyntaxEditTipWnd
  • m_scaleInterval : CXTPCalendarTLV_TimeScaleParams
  • m_scrollBarStyle : CXTPScrollBase
  • m_ScrollDayButton : XTP_CALENDAR_USERACTION_PARAMS
  • m_scrollModeH : CXTPGridControl
  • m_scrollModeV : CXTPGridControl
  • m_scrollUpdateMode : CXTPGridControl
  • m_scSizeIcon : CXTPPropertySheet, CXTPResize
  • m_sCustomFormat4Tooltip : CXTPCalendarControl
  • m_sCustomTitle : CXTPCalendarControl, CXTPGridControl
  • m_selectedBlock : CXTPCalendarView
  • m_selectedSticker : CXTPDockingPaneContextStickerWnd
  • m_shSettings : CXTPShellListBase, CXTPShellTreeBase
  • m_sIniSet : CXTPSyntaxEditConfigurationManager, CXTPSyntaxEditCtrl
  • m_sizeArrow : CXTPHeaderCtrlTheme
  • m_sizeButton : CXTPColorSelectorCtrlTheme
  • m_sizeCheck : CXTPCheckListBox::CCheckListState
  • m_sizeCheckThemed : CXTPCheckListBox::CCheckListState
  • m_sizeColor : CXTPCalendarEventColorListBox
  • m_sizeCommandButton : CXTPTaskDialogClient
  • m_sizeControl : CXTPGridRecordItemControl
  • m_sizeIcon : CXTPCaption
  • m_sizeIconFooter : CXTPTaskDialogClient
  • m_sizeIconMain : CXTPTaskDialogClient
  • m_sizeMargin : CXTPTipWindow
  • m_sizePadding : CXTPHeaderCtrlTheme
  • m_sizeTitle : CXTPTipWindow
  • m_sLineNumberFormat : CXTPSyntaxEditPaintManager
  • m_sMultipleSchedules : CXTPCalendarEvent
  • m_sPassedIniSet : CXTPSyntaxEditCtrl
  • m_spDraggingStartOffset : CXTPCalendarView
  • m_spi : CXTPScrollBase, CXTPSkinObjectFrame
  • m_spPeriod2Cache : CXTPCalendarRemindersManager
  • m_stateCurrent : CXTPPopupControl
  • m_stateTarget : CXTPPopupControl
  • m_stickers : CXTPStickerBase
  • m_strArgument : CXTPChartSeriesPoint
  • m_strAxisMaxValue : CXTPChartAxisStrip
  • m_strAxisMinValue : CXTPChartAxisStrip
  • m_strAxisValue : CXTPChartAxisConstantLine, CXTPChartAxisCustomLabel
  • m_strBody : CXTPCalendarEvent, CXTPCalendarEventPropertiesDlg
  • m_strBuffer : CXTPTaskDialogLinkCtrl
  • m_strCaption : CXTPCalendarDayViewTimeScale, CXTPCaption, CXTPCommandBarKeyboardTip, CXTPControl, CXTPControlAction, CXTPControlGalleryItem, CXTPDatePickerButton, CXTPDialogBar, CXTPFlowGraphConnection, CXTPFlowGraphConnectionPoint, CXTPFlowGraphNode, CXTPFlowGraphPage, CXTPGridRecordItem, CXTPGridRecordItemControl, CXTPMessageBarButton, CXTPPopupItem, CXTPPropertyGridItem, CXTPPropertyGridVerb, CXTPPropertySheet, CXTPRibbonGroup, CXTPShortcutBarItem, CXTPShortcutBarPane, CXTPShortcutBarPaneItem, CXTPStatusBarPane, CXTPTabManagerItem, CXTPTaskPanelItem, CXTPTrackBlock, CXTPTrackMarker
  • m_strCaptionText : CXTPRibbonBar
  • m_strCategory : CXTPControl, CXTPControlAction
  • m_strClass : CXTPSkinManagerClass
  • m_strClassName : CXTPSkinObject
  • m_strCloseTags : CXTPSyntaxEditAutoCompleteWnd
  • m_strCollapse : CXTPGridPaintManager
  • m_strCollapsedControlText : CXTPTaskDialogClient
  • m_strColorScheme : CXTPSyntaxEditCtrl
  • m_strCommandText : CXTPSyntaxEditCommand
  • m_strConnectionString : CXTPCalendarData
  • m_strConstraint : CXTPGridRecordItemConstraint, CXTPPropertyGridItemConstraint
  • m_strContent : CXTPMessageBar, CXTPTaskDialogClient
  • m_strContextCaption : CXTPRibbonTab
  • m_strContractLabel : CXTPSearchOptionsCtrl
  • m_strControlsFileName : CXTPCommandBars
  • m_strCurrencySymbol : CXTPChartNumberFormat
  • m_strCustomCaption : CXTPControl
  • m_strCustomizeCaption : CXTPRibbonTab
  • m_strCustomShortcutText : CXTPControlAction
  • m_strDayHeaderFormatDefaultLong : CXTPCalendarView
  • m_strDayHeaderFormatDefaultMiddle : CXTPCalendarView
  • m_strDayHeaderFormatDefaultShort : CXTPCalendarView
  • m_strDayHeaderFormatDefaultShortest : CXTPCalendarView
  • m_strDayHeaderFormatLong : CXTPCalendarView
  • m_strDayHeaderFormatMiddle : CXTPCalendarView
  • m_strDayHeaderFormatShort : CXTPCalendarView
  • m_strDayHeaderFormatShortest : CXTPCalendarView
  • m_strDecreasing : CXTPGridPaintManager
  • m_strDefault : CXTPListBase, CXTPMaskEditT< TBase >
  • m_strDefaultCfgFilePath : CXTPSyntaxEditCtrl
  • m_strDefaultMenu : CXTPCustomizeMenusPage
  • m_strDefaultMenuDesc : CXTPCustomizeMenusPage
  • m_strDefaultValue : CXTPPropertyGridItem
  • m_strDefExt : CXTPBrowseEdit
  • m_strDelims : CXTPSyntaxEditAutoCompleteWnd
  • m_strDesc : CXTPCustomizeKeyboardPage
  • m_strDescrip : CXTPTipWindow
  • m_strDescription : CXTPMenuBarMDIMenuInfo, CXTPPropertyGridItem, CXTPTrackBlock
  • m_strDescriptionText : CXTPControl, CXTPControlAction, CXTPControlGalleryItem
  • m_strDisplayString : CXTPCalendarTimeZone
  • m_strDllFileName : CXTPResourceImages
  • m_strDragText : CXTPTaskPanelGroupItem
  • m_strEditHint : CXTPControlAction, CXTPControlComboBox, CXTPControlEdit
  • m_strEditText : CXTPControlComboBox, CXTPControlEdit
  • m_strEncoding : CXTPPropExchangeXMLNode
  • m_strEntry : CXTPListBase
  • m_strExpand : CXTPGridPaintManager
  • m_strExpandedControlText : CXTPTaskDialogClient
  • m_strExpandedInformation : CXTPTaskDialogClient
  • m_strExpandLabel : CXTPSearchOptionsCtrl
  • m_strFalseText : CXTPPropertyGridItemBool
  • m_strFileExt : CXTPSyntaxEditBufferManager
  • m_strFileName : CXTPBrowseEdit, CXTPPropExchangeIniFile
  • m_strFilter : CXTPBrowseEdit, CXTPEditListBox
  • m_strFilterText : CXTPGridControl
  • m_strFloatingFrameCaption : CXTPDockingPaneManager
  • m_strFolderPath : CXTPDirWatcher
  • m_strFontFace : CXTPDockingPaneVisualStudio2012Theme
  • m_strFooter : CXTPTaskDialogClient
  • m_strFooterText : CXTPGridColumn
  • m_strFormat : CXTPGridGroupRow, CXTPPropertyGridItem
  • m_strFormatString : CXTPGridRecordItem
  • m_strFormula : CXTPGridGroupRow, CXTPGridRecordItem
  • m_strGroupCaption : CXTPGridRecordItem
  • m_strGroupLabel : CXTPGridGroupRow
  • m_strGroupText : CXTPGridGroupRow
  • m_strHeaderFormat : CXTPCalendarView
  • m_strHighlightedPrefix : CXTPRibbonMarkupTheme
  • m_strHint : CXTPGridFilterEditControl
  • m_strIncreasing : CXTPGridPaintManager
  • m_Strings : CXTPSyntaxEditBufferManager
  • m_strINIFileName : CXTPRegistryManager
  • m_strIniFileName : CXTPResourceImages, CXTPSkinManagerResourceFile
  • m_strInitialDir : CXTPBrowseEdit, CXTPEditListBox
  • m_strInputBoxText : CXTPTaskDialogClient
  • m_strInternalName : CXTPGridColumn
  • m_strItemDefaultText : CXTPEditListBox
  • m_strItemPath : CXTPShellListCtrlEx
  • m_strItemText : CXTPEditListBox
  • m_strKey : CXTPControlAction
  • m_strKeyboardTip : CXTPControl, CXTPControlAction, CXTPRibbonTab
  • m_strLabel : CXTPChartAxisViewTick, CXTPChartRadarAxisXViewTick, CXTPChartRadarAxisYViewTick
  • m_strLastText : CXTPControlComboBox, CXTPControlEdit
  • m_strLegendName : CXTPChartAxisConstantLine, CXTPChartAxisStrip
  • m_strLegendText : CXTPChartSeries
  • m_strLegentText : CXTPChartSeriesPoint
  • m_strLink : CXTPHyperLink
  • m_strLiteral : CXTPGridColumn, CXTPMaskEditT< TBase >, CXTPPropertyGridItem
  • m_strLocation : CXTPCalendarEvent, CXTPCalendarEventPropertiesDlg
  • m_strLongDateFormat : CXTPCalendarMonthView
  • m_strMainInstruction : CXTPTaskDialogClient
  • m_strMarkupTemplate : CXTPPropertyGridItem
  • m_strMarkupUIElement_NoGroupBy : CXTPGridPaintManager
  • m_strMask : CXTPGridColumn, CXTPMaskEditT< TBase >, CXTPPropertyGridItem
  • m_strMessage : CXTPCalendarOccurSeriesChooseDlg
  • m_strName : CXTPCalendarEventCategory, CXTPCalendarEventLabel, CXTPChartAxisStrip, CXTPChartSeries, CXTPFlowGraphConnectionPoint, CXTPGridColumn
  • m_strNoFieldsAvailable : CXTPGridPaintManager
  • m_strNoGroupBy : CXTPGridPaintManager
  • m_strNoItems : CXTPGridPaintManager
  • m_strNormalPrefix : CXTPRibbonMarkupTheme
  • m_strNullValue : CXTPPropertyGridItemDate
  • m_strOccur : CXTPCalendarOccurSeriesChooseDlg
  • m_strOfficeFont : CXTPDockingPanePaintManager, CXTPPaintManager, CXTPShortcutBarPaintManager
  • m_strOldCaption : CXTPFlowGraphUndoSetNodeCaptionCommand
  • m_strOpenTags : CXTPSyntaxEditAutoCompleteWnd
  • m_strParameter : CXTPControl
  • m_strPattern : CXTPChartNumberFormat
  • m_strPrefix : CXTPCommandBarKeyboardTip
  • m_strPreviewText : CXTPGridRecordItemPreview
  • m_strProfileName : CXTPRegistryManager
  • m_strRedoBuffer : CXTPMaskEditT< TBase >
  • m_strRedoUIText : CXTPCalendarControl
  • m_strRegistryKey : CXTPRegistryManager
  • m_strReminderSoundFile : CXTPCalendarEvent
  • m_strReplacedText : CXTPSyntaxEditReplaceStringCommand
  • m_strResourceName : CXTPCalendarResource
  • m_strResourcePath : CXTPSkinManagerResourceFile
  • m_strScheduleName : CXTPCalendarSchedule
  • m_strSchemaName : CXTPSkinManagerSchema
  • m_strSearch : CXTPSyntaxEditAutoCompleteWnd
  • m_strSection : CXTPListBase, CXTPResize
  • m_strSectionName : CXTPPropExchangeEnumerator, CXTPPropExchangeIniFile, CXTPPropExchangeRegistry, CXTPPropExchangeXMLNode
  • m_strSeries : CXTPCalendarOccurSeriesChooseDlg
  • m_strShortcutText : CXTPControl, CXTPControlAction
  • m_strShortcutTextAuto : CXTPControl
  • m_strSmallDateFormat : CXTPCalendarMonthView
  • m_strSortBy : CXTPGridPaintManager
  • m_strSubject : CXTPCalendarEvent, CXTPCalendarEventPropertiesDlg
  • m_strSyntaxScheme : CXTPSyntaxEditCtrl
  • m_strTabCaption : CXTPDockingPane
  • m_strTag : CXTPFlowGraphConnection
  • m_strTearOffCaption : CXTPPopupBar
  • m_strText : CXTPCalendarCaptionBarThemePart, CXTPChartAxisConstantLine, CXTPChartAxisCustomLabel, CXTPChartAxisTitle, CXTPChartTextDeviceCommand, CXTPChartTextPainterBase, CXTPChartTitle, CXTPGridRecordItemText, CXTPShortcutListBox::CONTENT_ITEM, CXTPStatusBarPane, CXTPSyntaxEditBufferCommand, XTP_EDIT_ACDATA
  • m_strText_prev : CXTPGridInplaceEdit
  • m_strTimeFormat : CXTPTrackControl
  • m_strTip : CXTPCommandBarKeyboardTip
  • m_strTipFile : CXTPTipOfTheDay
  • m_strTipText : CXTPHyperLink, CXTPPropertyGridView, CXTPTipOfTheDay
  • m_strTipTitle : CXTPTipOfTheDay
  • m_strTitle : CXTPBrowseEdit, CXTPCalendarOccurSeriesChooseDlg, CXTPCommandBar, CXTPDockingPane, CXTPEditListBox, CXTPMenuBarMDIMenuInfo, CXTPTipWindow, CXTPToolTipContextToolTip
  • m_strTitleCustom : CXTPColorPicker, CXTPColorSelectorCtrl
  • m_strTitleRecent : CXTPColorSelectorCtrl
  • m_strTitleStandard : CXTPColorPicker, CXTPColorSelectorCtrl
  • m_strTitleTheme : CXTPColorPicker, CXTPColorSelectorCtrl
  • m_strTitleToolTip : CXTPDockingPane
  • m_strTmpCloseTag : CXTPSyntaxEditAutoCompleteWnd
  • m_strTmpOpenTag : CXTPSyntaxEditAutoCompleteWnd
  • m_strToolTip : CXTPControlGalleryItem, CXTPMessageBarButton, CXTPStatusBarPane, CXTPTabManagerItem, CXTPTabManagerNavigateButton, CXTPTrackBlock, CXTPTrayIcon
  • m_strTooltip : CXTPButton, CXTPFlowGraphConnection, CXTPFlowGraphConnectionPoint, CXTPFlowGraphNode, CXTPGridColumn, CXTPGridRecordItem, CXTPPropertyGridItem, CXTPShortcutBarItem, CXTPTaskPanelItem
  • m_strToolTipPart : CXTPStatusBarScrollBarPane
  • m_strToolTipText : CXTPSyntaxEditToolTipCtrl
  • m_strTooltipText : CXTPCalendarTip, CXTPControl, CXTPControlAction, CXTPGridTip
  • m_strTrueText : CXTPPropertyGridItemBool
  • m_strUIElementText : CXTPCalendarViewEvent
  • m_strUndoBuffer : CXTPMaskEditT< TBase >
  • m_strUndoUIText : CXTPCalendarControl
  • m_strValue : CXTPGridInplaceEdit, CXTPPropertyGridInplaceEdit, CXTPPropertyGridItem, CXTPStatusBarPane
  • m_strVar : CXTPSyntaxEditLexVariable
  • m_strVerificationText : CXTPTaskDialogClient
  • m_strWindowText : CXTPItemEdit, CXTPMaskEditT< TBase >
  • m_strYearMonthFormat : CXTPDatePickerControl
  • m_systemTheme : CXTPDockingPanePaintManager, CXTPPaintManager
  • m_szActualSize : CXTPFlowGraphNode
  • m_szBitmap : CXTPSkinImage
  • m_szBounds : CXTPChartAxisViewTick, CXTPChartRadarAxisXViewTick, CXTPChartRadarAxisYViewTick
  • m_szButton : CXTPPropertySheet
  • m_szButtons : CXTPCommandBar
  • m_szButtonSpacing : CXTPCommandBar
  • m_szCaret : CXTPHexEdit
  • m_szClockRect : CXTPCalendarPaintManager
  • m_szControl : CXTPControlCustom
  • m_szDayMargin : CXTPDatePickerPaintManager
  • m_szDesiredSize : CXTPMarkupUIElement
  • m_szDir : CXTPSplitPath
  • m_szDocking : CXTPDockingPaneBase
  • m_szDockingClient : CXTPDialogBar
  • m_szDrive : CXTPSplitPath
  • m_szExt : CXTPSplitPath
  • m_szExtent : CXTPResourceImage
  • m_szFloatingClient : CXTPDialogBar
  • m_szFName : CXTPSplitPath
  • m_szFrameRegion : CXTPCommandBarsFrameHook, CXTPSkinObjectFrame
  • m_szGlyph : CXTPGridPaintManager
  • m_szGroupIcon : CXTPTaskPanel
  • m_szIcon : CXTPControl, CXTPFramePaintManager, CXTPImageManagerIconHandle, CXTPImageManagerResource, CXTPTabPaintManager
  • m_szIcons : CXTPCommandBar
  • m_szImage : CXTPFlowGraphImage
  • m_szInitWindow : CXTPResize
  • m_szItem : CXTPControlGalleryItem, CXTPControlGalleryItems, CXTPControlSelector, CXTPShortcutBar, CXTPTaskPanelGroupItem
  • m_szItemIcon : CXTPTaskPanel, CXTPTaskPanelGroup
  • m_szItemsActive : CXTPControlSelector
  • m_szItemsCount : CXTPControlSelector
  • m_szItemsMax : CXTPControlSelector
  • m_szItemsVisible : CXTPControlSelector
  • m_szLabel : CXTPChartAxisViewTick, CXTPChartRadarAxisXViewTick, CXTPChartRadarAxisYViewTick
  • m_szMarkerSize : CXTPChartLegend
  • m_szMax : CXTPResize
  • m_szMin : CXTPResize
  • m_szMinTrackRect : CXTPDialogBar
  • m_szNavigateButton : CXTPTabPaintManager
  • m_szOldSize : CXTPFlowGraphUndoSetNodeSizeCommand
  • m_szPage : CXTPSyntaxEditView
  • m_szPopup : CXTPPopupControl
  • m_szPreview : CXTPTaskPanelGroupItem
  • m_szPreviousAvailableSize : CXTPMarkupUIElement
  • m_szRenderSize : CXTPMarkupVisual
  • m_szResult : CXTPControlSelector
  • m_szSelPath : CXTPBrowseDialog
  • m_szTabCloseButton : CXTPTabPaintManager
  • m_szTearOffBar : CXTPPopupBar
  • m_szText : CXTPCalendarViewEvent
  • m_szTextSize : CXTPChartTextPainterBase
  • m_szUserMinSize : CXTPFlowGraphNode
  • m_szUserSize : CXTPFlowGraphNode
  • m_szVectorIcon : CXTPButton
  • m_szVectorIconLarge : CXTPToolTipContext
  • m_szVectorIconSmall : CXTPToolTipContext
  • m_szWindow : CXTPFlowGraphNode, CXTPPropertySheet, CXTPResize
  • m_tabAppearance : CXTPTabPaintManager
  • m_tabColor : CXTPTabPaintManager
  • m_tabCtrl : CXTPResizePropertySheet
  • m_tabLayout : CXTPTabPaintManager
  • m_tabPosition : CXTPTabPaintManager
  • m_tcbItems : CXTPExcelTabCtrl, CXTPTabExBase
  • m_theme : CXTPEditListBoxToolBar, CXTPListBox
  • m_themeButton : CXTPDatePickerPaintManager, CXTPDockingPanePaintManager, CXTPGridPaintManager, CXTPPaintManager, CXTPPropertyGridPaintManager
  • m_themeCombo : CXTPCommandBarsNativeXPTheme, CXTPGridPaintManager, CXTPPropertyGridPaintManager
  • m_themeComboBox : CXTPComboBoxTheme
  • m_themeCommandBars : CXTPTabClientWnd
  • m_themeCurrent : CXTPDockingPanePaintManager, CXTPGridControl, CXTPPaintManager, CXTPPropertyGrid
  • m_themeExplorer : CXTPDockingPanePaintManager
  • m_themeHeader : CXTPGridPaintManager, CXTPHeaderCtrlTheme
  • m_themeHelper : CXTPCheckListBox
  • m_themeMenu : CXTPCommandBarsNativeXPTheme
  • m_themeRebar : CXTPCommandBarsNativeXPTheme, CXTPDockingPanePaintManager, CXTPReBarPaintManager< TBase >
  • m_themeSpin : CXTPCommandBarsNativeXPTheme, CXTPGridPaintManager, CXTPSpinButtonCtrl
  • m_themeStatusBar : CXTPPaintManager
  • m_themeTab : CXTPTabBaseTheme
  • m_themeTabButton : CColorSetWinNative
  • m_themeToolbar : CColorSetWinNative, CXTPCommandBarsNativeXPTheme, CXTPDockingPanePaintManager
  • m_themeTree : CXTPPropertyGridPaintManager
  • m_themeWindow : CXTPCommandBarsNativeXPTheme, CXTPDockingPanePaintManager
  • m_themeWrapper : CXTPTagCloudCtrl
  • m_thickness : CXTPChartBoundedCircleDeviceCommand, CXTPChartBoundedPolygonDeviceCommand
  • m_tmText : CXTPSyntaxEditDrawTextProcessor
  • m_toolBehaviour : CXTPTabPaintManager
  • m_toolDelay : CXTPToolTipContextToolTip
  • m_toolDisabled : CXTPToolTipContextToolTip
  • m_toolStyle : CXTPToolTipContext
  • m_ToolTip : CXTPExcelTabCtrl
  • m_toolTip : CXTPHyperLink
  • m_tooltip : CXTPColorSelectorCtrl, CXTPEditListBoxToolBar
  • m_toolVisible : CXTPToolTipContextToolTip
  • m_treeCommands : CXTPRibbonCustomizePage
  • m_treeRibbon : CXTPRibbonCustomizePage
  • m_treeStructureStyle : CXTPGridPaintManager
  • m_tvid : CXTPDirWatcher
  • m_type : CXTPDockingPaneBase, CXTPMarkupGridLength
  • m_typeItem : CXTPTaskPanelItem
  • m_typeProvider : CXTPCalendarData
  • m_typeSticker : CXTPDockingPaneContextStickerWnd
  • m_uAnimationDelay : CXTPPopupControl
  • m_UaSorted : CXTPGridSection
  • m_uAutoScrollTimerID : CXTPGridControl
  • m_uDefMenuItemID : CXTPTrayIcon
  • m_uDrawTextFormat : CXTPPropertyGridItemMetrics
  • m_uFaceSize : CXTPSyntaxEditPropertiesPageFont
  • m_uFlags : CXTPShellListBase, CXTPShellTreeBase, CXTPTrayIcon
  • m_uiDelayEditMaxTime : CXTPGridControl
  • m_uiDelayEditTimer : CXTPGridControl
  • m_uiRefCount : CXTPDropSource
  • m_ulSFGAOFlags : CXTPShellPidl
  • m_uMRUDockPosition : CXTPDockContext
  • m_unFlags : CXTPGridRecordItemControl
  • m_unSpinTimerCnt : CXTPGridInplaceButton
  • m_unSpinTimerId : CXTPGridInplaceButton
  • m_uRqstEditTimer : CXTPGridControl
  • m_uScheduleID : CXTPCalendarEvent, CXTPCalendarSchedule
  • m_uShowDelay : CXTPPopupControl
  • m_ValueCustom : CXTPCalendarThemeCustomizableXValueT< _TValue, _TValueRef >
  • m_ValueStandard : CXTPCalendarThemeCustomizableXValueT< _TValue, _TValueRef >
  • m_Variable : CXTPSyntaxEditLexVariant
  • m_verticalOptions : CXTPControlCustom
  • m_vtBookmark : CXTPGridRecord
  • m_vtCaptionValue : CXTPGridGroupRow
  • m_WatermarkAlignment : CXTPGridControl
  • m_WatermarkTransparency : CXTPGridControl
  • m_Weekly : XTP_CALENDAR_RECURRENCE_OPTIONS
  • m_WindowToNodeHash : CXTPFlowGraphNode
  • m_winTheme : CXTPEditTheme, CXTPMarqueeCtrlPaintManager, CXTPProgressCtrlPaintManager
  • m_wndAttachedTab : CXTPDockingPaneContext
  • m_wndBusyStatusCombo : CXTPCalendarEventPropertiesDlg
  • m_wndCategoryCombo : CXTPCalendarEventPropertiesDlg
  • m_wndCbDuration : CXTPCalendarEventRecurrenceDlg
  • m_wndCbEnd : CXTPCalendarEventRecurrenceDlg
  • m_wndCbMonthDay : CXTPCalendarEventRecurrenceDlg
  • m_wndCbMonthWhich : CXTPCalendarEventRecurrenceDlg
  • m_wndCbStart : CXTPCalendarEventRecurrenceDlg
  • m_wndCbYearDay : CXTPCalendarEventRecurrenceDlg
  • m_wndCbYearWhich : CXTPCalendarEventRecurrenceDlg
  • m_wndComboYearMonth2 : CXTPCalendarEventRecurrenceDlg
  • m_wndContent : CXTPTaskDialogClient
  • m_wndContext : CXTPDockingPaneContext
  • m_wndExpandedInformation : CXTPTaskDialogClient
  • m_wndEyeDropper : CXTPColorDialog
  • m_wndFooter : CXTPTaskDialogClient
  • m_wndGrid : CXTPGridView
  • m_wndHeader : CXTPListBase
  • m_wndHexEdit : CXTPColorDialog
  • m_wndHScrollBar : CXTPExcelTabCtrl
  • m_wndIcon : CXTPCustomizeMenusPage
  • m_wndInfoTip : CXTPSyntaxEditTipListBox
  • m_wndInputBox : CXTPTaskDialogClient
  • m_wndLabelCombo : CXTPCalendarEventPropertiesDlg
  • m_wndMinimize : CXTPTrayIcon
  • m_wndOtherGroup : CXTPCustomizeOptionsPage
  • m_wndPersonalizedGroup : CXTPCustomizeOptionsPage
  • m_wndProgressBar : CXTPTaskDialogClient
  • m_wndReminderCombo : CXTPCalendarEventPropertiesDlg
  • m_wndTip : CXTPPropertyGridView
  • m_wndToolbar : CXTPPropertyGrid
  • m_wndToolTip : CXTPTagCloudCtrl
  • m_wndYearMonth : CXTPCalendarEventRecurrenceDlg
  • m_xGripperPos : CXTPExcelTabCtrl
  • m_xmlDocPtr : CXTPPropExchangeXMLNode
  • m_xmlParentNode : CXTPPropExchangeXMLNode
  • m_xmlSectionNode : CXTPPropExchangeXMLNode
  • m_xtpBrush : CXTPSearchOptionsView
  • m_xtpBrushBack : CXTPEditTheme, CXTPGridInplaceEdit, CXTPPropertyGridInplaceEdit
  • m_xtpBrushBackground : CXTPComboBoxTheme
  • m_xtpBrushDialog : CXTPSkinManagerMetrics
  • m_xtpBrushElsewhere : CXTPCalendarPaintManager
  • m_xtpBrushGroupGridLineStyle : CXTPGridPaintManager
  • m_xtpBrushHorizontalGrid : CXTPGridPaintManager
  • m_xtpBrushTabControl : CXTPSkinManagerMetrics
  • m_xtpBrushTentative : CXTPCalendarPaintManager
  • m_xtpBrushTreeStructure : CXTPGridPaintManager
  • m_xtpBrushVeriticalGrid : CXTPGridPaintManager
  • m_xtpBrushWindow : CXTPSkinManagerMetrics
  • m_xtpFont : CXTPFlowGraphEditItem, CXTPFontManager, CXTPHyperLink, CXTPPropertyGridToolTip, CXTPSyntaxEditPaintManager, CXTPTagCloudStyle, CXTPTaskDialogClient, CXTPToolTipContext
  • m_xtpFontBasic : CXTPSyntaxEditAutoCompleteWnd
  • m_xtpFontBold : CXTPFontManager, CXTPPropertyGridItemMetrics, CXTPTabPaintManager
  • m_xtpFontBoldText : CXTPGridPaintManager
  • m_xtpFontButton : CXTPDatePickerPaintManager
  • m_xtpFontCaption : CXTPGridPaintManager, CXTPGridRecordItemControl, CXTPSkinManagerMetrics, CXTPTaskPanelPaintManager
  • m_xtpFontCustomValue : CXTPCalendarViewPartFontValue
  • m_xtpFontDay : CXTPDatePickerPaintManager
  • m_xtpFontDayBold : CXTPDatePickerPaintManager
  • m_xtpFontDaysOfWeek : CXTPDatePickerPaintManager
  • m_xtpFontEdit : CXTPGridInplaceEdit, CXTPSyntaxEditPropertiesPageColor, CXTPSyntaxEditPropertiesPageFont
  • m_xtpFontFooter : CXTPGridColumn
  • m_xtpFontHeader : CXTPDatePickerPaintManager
  • m_xtpFontHex : CXTPHexEdit
  • m_xtpFontIcon : CXTPTaskPanelPaintManager
  • m_xtpFontIconBold : CXTPTaskPanelPaintManager
  • m_xtpFontIconHot : CXTPTaskPanelPaintManager
  • m_xtpFontIconHotBold : CXTPTaskPanelPaintManager
  • m_xtpFontItalic : CXTPFontManager
  • m_xtpFontItalicBold : CXTPFontManager
  • m_xtpFontItem : CXTPTaskPanelItem
  • m_xtpFontLarge : CXTPTaskDialogClient
  • m_xtpFontLineNumber : CXTPSyntaxEditPaintManager
  • m_xtpFontListControl : CXTPDatePickerPaintManager
  • m_xtpFontMenu : CXTPSkinManagerMetrics
  • m_xtpFontNonMonthDay : CXTPDatePickerPaintManager
  • m_xtpFontNormal : CXTPPropertyGridItemMetrics, CXTPPropertySheet, CXTPTabPaintManager
  • m_xtpFontPaneCaption : CXTPShortcutBarPaintManager
  • m_xtpFontPaneItemCaption : CXTPShortcutBarPaintManager
  • m_xtpFontPreview : CXTPGridPaintManager
  • m_xtpFontRegular : CXTPPaintManager
  • m_xtpFontRegularBold : CXTPPaintManager
  • m_xtpFontSmCaption : CXTPSkinManagerMetrics
  • m_xtpFontStandardValue : CXTPCalendarViewPartFontValue
  • m_xtpFontStatus : CXTPStatusBar
  • m_xtpFontText : CXTPGridPaintManager, CXTPPopupItem, CXTPPopupPaintManager, CXTPShortcutBarPaintManager, CXTPStatusBarPane, CXTPSyntaxEditPaintManager
  • m_xtpFontTip : CXTPTipOfTheDay
  • m_xtpFontTitle : CXTPDockingPanePaintManager, CXTPTipOfTheDay, CXTPToolTipContext
  • m_xtpFontTitleVertical : CXTPDockingPanePaintManager
  • m_xtpFontToolTip : CXTPGridTip, CXTPSyntaxEditPaintManager
  • m_xtpFontUL : CXTPTaskDialogLinkCtrl
  • m_xtpFontUnderline : CXTPPropertyGridItemMetrics
  • m_xtpFontVert : CXTPPaintManager
  • m_xtpFontVertBold : CXTPPaintManager
  • m_xtpFontVertical : CXTPFontManager
  • m_xtpFontVerticalBold : CXTPFontManager, CXTPTabPaintManager
  • m_xtpFontVerticalNormal : CXTPTabPaintManager
  • m_xtpFontVerticalText : CXTPShortcutBarPaintManager
  • m_xtpFontWeekNumbers : CXTPDatePickerPaintManager
  • m_xTrackingDelta : CXTPExcelTabCtrl
  • m_Yearly : XTP_CALENDAR_RECURRENCE_OPTIONS
  • m_YearNth : XTP_CALENDAR_RECURRENCE_OPTIONS
  • MakeARGB() : CXTPChartColor
  • MakeAsRException() : CXTPCalendarEvent
  • MakeDaysOfWeekMask_Mo_() : CXTPCalendarUtils
  • MakeEventAsRecurrence() : CXTPCalendarEvent
  • MakeIntResource() : CXTPResourceManager
  • MakeLineCol() : XTP_EDIT_LINECOL
  • MakeTransparent() : CXTPResizeItem
  • MapShellFlagsToItemAttributes() : CXTPShellPidl
  • MarkSaved() : CXTPSyntaxEditUndoRedoManager
  • MaskClear() : CXTPMaskEditT< TBase >
  • MaskCopy() : CXTPMaskEditT< TBase >
  • MaskCut() : CXTPMaskEditT< TBase >
  • MaskDeleteSel() : CXTPMaskEditT< TBase >
  • MaskPaste() : CXTPMaskEditT< TBase >
  • MaskReplaceSel() : CXTPMaskEditT< TBase >
  • MaskSelectAll() : CXTPMaskEditT< TBase >
  • MaskUndo() : CXTPMaskEditT< TBase >
  • MatchText() : CXTPSyntaxEditCtrl
  • MaterialDiffuseColor : CXTPChartDiagram3DAppearance
  • MaterialEmissionColor : CXTPChartDiagram3DAppearance
  • MaterialShininess : CXTPChartDiagram3DAppearance
  • MaterialSpecularColor : CXTPChartDiagram3DAppearance
  • max2() : XTP_EDIT_LINECOL
  • MaximizeFromTray() : CXTPTrayIcon
  • MAXPOS : XTP_EDIT_LINECOL
  • McTransparentBlt() : CXTPImageManager
  • MDIActivate() : CXTPTabClientWnd
  • MDIGetActive() : CXTPTabClientWnd
  • MDITile() : CXTPTabClientWnd
  • Measure() : CXTPMarkupThemePart, CXTPMarkupUIElement
  • MeasureButton() : CXTPMessageBar
  • MeasureContent() : CXTPMessageBar
  • MeasureCore() : CXTPMarkupUIElement
  • MeasureItem() : CXTPCalendarComboBoxBase, CXTPControlComboBoxList, CXTPPropertyGridItem, CXTPPropertyGridItemOption, CXTPPropertyGridPaintManager
  • MeasureMarkupElement() : CXTPChartDeviceContext
  • MeasureString() : CXTPChartDeviceContext
  • MergeToolBar() : CXTPToolBar
  • MessageBox() : CXTPCustomizeSheet
  • min2() : XTP_EDIT_LINECOL
  • MinimizeToTray() : CXTPTrayIcon
  • MINPOS : XTP_EDIT_LINECOL
  • Minutes2Span() : CXTPCalendarUtils
  • ModifyApplyOptions() : CXTPSkinManager
  • ModifyBarStyle() : CXTPToolBar
  • ModifyCaptionStyle() : CXTPCaption
  • ModifyCPStyle() : CXTPColorPicker
  • ModifyExtendedStyle() : CXTPListBase
  • ModifyListBoxStyle() : CXTPControlComboBox
  • ModifyPopupStyle() : CXTPColorSelectorCtrl
  • ModifyTabStyle() : CXTPTabExBase
  • ModifyTaskStyle() : CXTPTaskDialog
  • ModifyToolTipStyle() : CXTPToolTipContext
  • MonitorNotifications() : CXTPDirWatcher
  • MonthView_IsCompressWeekendDays() : CXTPCalendarControl
  • MonthView_IsShowEndDate() : CXTPCalendarControl
  • MonthView_IsShowTimeAsClocks() : CXTPCalendarControl
  • MonthView_SetCompressWeekendDays() : CXTPCalendarControl
  • MonthView_SetShowEndDate() : CXTPCalendarControl
  • MonthView_SetShowTimeAsClocks() : CXTPCalendarControl
  • mouseDeselecting : CXTPDatePickerControl
  • mouseNothing : CXTPDatePickerControl
  • MouseOverColumnResizeArea() : CXTPGridHeader
  • mouseScrollingLeft : CXTPDatePickerControl
  • mouseScrollingRight : CXTPDatePickerControl
  • mouseSelecting : CXTPDatePickerControl
  • mouseTrackingHeaderList : CXTPDatePickerControl
  • Move() : CXTPDockContext, CXTPDockingPaneContext, CXTPGridRecords, CXTPPropertyGridItem, CXTPTabManagerItem, CXTPTaskPanelItems
  • MoveBefore() : CXTPControls
  • MoveButton() : CXTPTaskDialogClient
  • MoveButtons() : CXTPEditListBoxToolBar
  • MoveChildWindow() : CXTPDialogBar
  • MoveControl() : CXTPSearchOptionsCtrl
  • MoveCurrentVisibleRowDown() : CXTPSyntaxEditCtrl
  • MoveCurrentVisibleRowUp() : CXTPSyntaxEditCtrl
  • MoveDown() : CXTPGridIconNavigator, CXTPGridNavigator
  • MoveDownStep() : CXTPGridIconNavigator, CXTPGridNavigator
  • MoveEvent() : CXTPCalendarEvent
  • MoveFirstColumn() : CXTPGridNavigator
  • MoveFirstRow() : CXTPGridNavigator
  • MoveFirstVisibleRow() : CXTPGridNavigator
  • MoveItem() : CXTPTabManager
  • MoveItemDown() : CXTPEditListBox
  • MoveItemUp() : CXTPEditListBox
  • MoveLastColumn() : CXTPGridNavigator
  • MoveLastRow() : CXTPGridNavigator
  • MoveLastVisibleRow() : CXTPGridNavigator
  • MoveLeft() : CXTPGridNavigator
  • MoveLeftRight() : CXTPGridIconNavigator, CXTPGridNavigator
  • MovePageDown() : CXTPGridIconNavigator, CXTPGridNavigator
  • MovePageUp() : CXTPGridIconNavigator, CXTPGridNavigator
  • MovePanel() : CXTPDockingPaneSidePanel
  • MoveRecord() : CXTPGridRecords
  • MoveResource() : CXTPCalendarResourcesManager
  • MoveRight() : CXTPGridNavigator
  • MoveRow() : CXTPListBase
  • MoveTo() : CXTPCalendarDayViewTimeScale
  • MoveToColumn() : CXTPGridNavigator
  • MoveToFront() : CXTPFlowGraphNodes
  • MoveToNextGroup() : CXTPTabClientWnd
  • MoveToPreviousGroup() : CXTPTabClientWnd
  • MoveToRow() : CXTPGridNavigator
  • MoveUp() : CXTPGridIconNavigator, CXTPGridNavigator
  • MoveUpStep() : CXTPGridIconNavigator, CXTPGridNavigator
  • ms_bDroppedHere : CXTPSyntaxEditView
  • ms_dwNextFreeTempID : CXTPCalendarData
  • ms_dwSignature : CXTPSyntaxEditView
  • ms_pTargetView : CXTPSyntaxEditView
  • ms_ptDropPos : CXTPSyntaxEditView
  • msgAll : CXTPCalendarMsgNotifier
  • MsgBox_WrongValue() : CXTPCalendarEventRecurrenceDlg
  • MsgBox_WrongValueRange() : CXTPCalendarEventRecurrenceDlg
  • Multiply() : CXTPMatrix< T >
  • MultiplyByMatrix() : CXTPOpenGLUtils


Toolkit Pro: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- n -

  • nAction : XTP_EDIT_NMHDR_EDITCHANGED, XTP_NM_FLOWGRAPH_CONNECTIONCHANGED
  • Navigate() : CXTPWebBrowserCtrl
  • Navigate2() : CXTPShellExplorerProvider
  • NavigateItems() : CXTPPropertyGrid, CXTPTaskPanel
  • NavigatePage() : CXTPTaskDialog
  • nBegin : XTP_NM_GRIDSTATECHANGED
  • nButton : XTP_CALENDAR_USERACTION_PARAMS::EXPANDDAYBUTTONACTION_PARAMS, XTP_CALENDAR_USERACTION_PARAMS::SCROLLDAYBUTTONACTION_PARAMS
  • nChar : XTP_NM_GRIDPREVIEWKEYDOWN
  • nCodePage : XTP_RESOURCEMANAGER_LANGINFO
  • nCol : XTP_EDIT_LINECOL, XTP_EDIT_NMHDR_ROWCOLCHANGED
  • nCol1 : XTP_EDIT_ROWCOLRECT
  • nCol2 : XTP_EDIT_ROWCOLRECT
  • nColumn : CXTPDockingPaneWindowSelect::CItem
  • nColumnAlignment : XTP_GRIDRECORDITEM_METRICS
  • nCount : XTP_SLIDERTICKS
  • nDateBegin : CXTPDatePickerDaysCollection::SELECTED_BLOCK
  • nDateEnd : CXTPDatePickerDaysCollection::SELECTED_BLOCK
  • nDay : XTP_CALENDAR_HITTESTINFO
  • nDayOfMonth : XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_MONTHLY, XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_YEARLY
  • nDayOfWeekMask : XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_WEEKLY
  • nDayView_CurrentTimeMarkVisible : CXTPCalendarOptions
  • nDayView_ScaleInterval : CXTPCalendarOptions
  • nDispRow : XTP_EDIT_NMHDR_MARGINCLICKED
  • NeedRedraw() : CXTPComboBox
  • NeedScrollAllDayEvents() : CXTPCalendarDayViewGroup
  • nEnd : XTP_NM_GRIDSTATECHANGED
  • nEvent : XTP_CALENDAR_HITTESTINFO
  • NextBookmark() : CXTPSyntaxEditCtrl
  • NextView() : CXTPTabExBase
  • nFirstDayOfTheWeek : CXTPCalendarOptions
  • nFirstItem : CXTPTabManager::ROW_ITEMS
  • nFlags : XTP_NM_GRIDPREVIEWKEYDOWN
  • nFontCharSet : XTP_RESOURCEMANAGER_LANGINFO
  • nGroup : XTP_CALENDAR_HITTESTINFO
  • nGroupIndex : XTP_CALENDAR_VIEWSELECTION
  • nGroupRowIcon : XTP_GRIDRECORDITEM_METRICS
  • nGroupRowIconAlignment : XTP_GRIDRECORDITEM_METRICS
  • nHyperlink : XTP_NM_GRIDRECORDITEM
  • nID : CXTPColorSelectorCtrl::COLOR_CELL, CXTPStatusBarSwitchPane::SWITCH, XTP_COMMANDBARS_CREATEBAR, XTP_COMMANDBARS_CREATECONTROL, XTP_NC_DATEPICKER_BUTTON
  • nIndex : CXTPColorSelectorCtrl::COLOR_CELL, CXTPDockingPaneWindowSelect::CItem, CXTPTaskDialogLinkCtrl::LINKITEM, XTP_CALENDAR_DAYVIEWCELL_PARAMS, XTP_CALENDAR_THEME_DAYVIEWCELL_PARAMS, XTP_CALENDAR_THEME_DAYVIEWTIMESCALECELL_PARAMS, XTP_COMMANDBARS_CREATECONTROL
  • nIntervalDays : XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_DAILY
  • nIntervalMonths : XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_MONTHLY, XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_MONTHNTH
  • nIntervalWeeks : XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_WEEKLY
  • nItem : XTP_CALENDAR_GETITEMTEXT_PARAMS
  • nItemIcon : XTP_GRIDRECORDITEM_METRICS
  • nKey : CXTPCommandBars::KEYBOARDTIPS
  • nLastItem : CXTPTabManager::ROW_ITEMS
  • nLevel : CXTPCommandBars::KEYBOARDTIPS
  • nLine : XTP_EDIT_LINECOL
  • nmhdr : XTP_EDIT_NMHDR_DOCMODIFIED, XTP_EDIT_NMHDR_EDITCHANGED, XTP_EDIT_NMHDR_ENABLESCROLLBAR, XTP_EDIT_NMHDR_MARGINCLICKED, XTP_EDIT_NMHDR_PARSEEVENT, XTP_EDIT_NMHDR_ROWCOLCHANGED, XTP_EDIT_NMHDR_SETSCROLLPOS, XTP_EDIT_SENMBOOKMARK
  • nMinutes : XTP_CALENDAR_THEME_DAYVIEWTIMESCALECELL_PARAMS
  • nMonthOfYear : XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_YEARLY, XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_YEARNTH
  • nNewHeight : XTP_NM_GRIDROWRESIZE
  • nNewWidth : XTP_NM_GRIDCOLUMNRESIZE
  • nNextBlockPos : XTP_EDIT_TEXTBLOCK
  • NoConfirmRecycle() : CXTPShellSettings
  • NoDefaultRadioButton() : CXTPTaskDialog
  • nOldLength : CXTPTrackControl::DRAGBLOCK
  • nOldPos : CXTPTrackControl::DRAGBLOCK
  • Normalize() : CXTPRectT< T >
  • NormalizeDegree() : CXTPMathUtils
  • NormalizeDockingSize() : CXTPDockingPaneSplitterContainer
  • NormalizeRadian() : CXTPMathUtils
  • NormalizeSplitters() : CXTPDockingPaneManager
  • Notify() : CXTPObservable< Owner, Observer >, CXTPPopupControl
  • NotifyAction() : CXTPDockingPaneManager
  • NotifyCurRowCol() : CXTPSyntaxEditCtrl
  • NotifyDynamic() : CXTPObservable< Owner, Observer >
  • NotifyDynamicReversed() : CXTPObservable< Owner, Observer >
  • NotifyEditChanged() : CXTPSyntaxEditCtrl
  • NotifyMarginLBtnClick() : CXTPSyntaxEditCtrl
  • NotifyMouseEvent() : CXTPSyntaxEditCtrl
  • NotifyOwner() : CXTPDockingPaneManager, CXTPFontComboBox, CXTPSyntaxEditColorComboBox, CXTPTaskPanel
  • NotifyParent() : CXTPSyntaxEditCtrl
  • NotifyParseEvent() : CXTPSyntaxEditCtrl
  • NotifyReminders() : CXTPCalendarRemindersManager
  • NotifyReversed() : CXTPObservable< Owner, Observer >
  • NotifySelInit() : CXTPSyntaxEditCtrl
  • NotifySite() : CXTPControl
  • NotifyValueChanged() : CXTPPropertyGridItem
  • nPos : NMXTPSCROLL, XTP_EDIT_TEXTBLOCK, XTPPROGRESSDRAWSTRUCT
  • nPosition : XTP_NM_GRIDSCROLL
  • nPrevHeight : XTP_NM_GRIDROWRESIZE
  • nPrevWidth : XTP_NM_GRIDCOLUMNRESIZE
  • nPropertyCode : CXTPSkinManagerSchemaProperty
  • nReason : XTP_NM_GRIDCOLUMNORDERCHANGED
  • nRefCounter : XTP_EVENT_EDIT_OPERATION_PARAMS
  • nRepCnt : XTP_NM_GRIDPREVIEWKEYDOWN
  • nRow : CXTPDockingPaneWindowSelect::CItem, XTP_EDIT_NMHDR_MARGINCLICKED, XTP_EDIT_NMHDR_ROWCOLCHANGED, XTP_EDIT_SENMBOOKMARK, XTPGridInputState
  • nRow1 : XTP_EDIT_ROWCOLRECT
  • nRow2 : XTP_EDIT_ROWCOLRECT
  • nRowFrom : XTP_EDIT_NMHDR_EDITCHANGED
  • nRowTo : XTP_EDIT_NMHDR_EDITCHANGED
  • nSBCode : NMXTPSCROLL
  • nScore : XTP_TAGCLOUDTAG
  • nSection : XTP_NM_GRIDSCROLL
  • nSelStartTextRowFromLeftBar : CXTPSyntaxEditSelection
  • nStart : CXTPTaskDialogLinkCtrl::LINKITEM
  • nState : XTP_NM_GRIDDRAGDROP
  • nTargetRow : XTP_NM_GRIDDRAGDROP
  • nTextAlign : XTP_GRIDRECORDITEM_DRAWARGS
  • nTimeScale : XTP_CALENDAR_THEME_DAYVIEWTIMESCALECELL_PARAMS
  • nTransparency : CXTPPopupControl::POPUPSTATE
  • nType : XTP_NM_SELECTION_CHANGING
  • nVirtRowFlags : XTP_GRIDRECORDITEM_METRICS
  • nVirtRowLevel : XTP_GRIDRECORDITEM_METRICS
  • nWeekDay : XTP_CALENDAR_GETITEMTEXT_PARAMS
  • nWeekDayIndex : XTP_CALENDAR_MONTHVIEW_DAYPOS
  • nWeekIndex : XTP_CALENDAR_MONTHVIEW_DAYPOS
  • nWeekNum : XTP_CALENDAR_GETITEMTEXT_PARAMS
  • nWhichDay : XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_MONTHNTH, XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_YEARNTH
  • nWhichDayMask : XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_MONTHNTH, XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_YEARNTH
  • nWidth : CXTPStatusBarSwitchPane::SWITCH
  • nWorkWeekMask : CXTPCalendarEventRecurrenceDlg, CXTPCalendarOptions


Toolkit Pro: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- o -

  • Offset() : CXTPMarkupGdiPlusTransformationMatrix, CXTPMarkupTransformationMatrix, CXTPPoint2T< T >, CXTPPoint3T< T >, CXTPRectT< T >, CXTPResize
  • OffsetShadow() : CXTPShadowManager
  • OnAccept() : CXTPPropertyGridInplaceMonthCal
  • OnAction() : CXTPDockingPaneBaseContainer, CXTPDockingPaneMiniWnd
  • OnActionChanged() : CXTPControl, CXTPControlComboBox, CXTPControlCustom, CXTPControlEdit
  • OnActionChanging() : CXTPControl, CXTPControlComboBox, CXTPControlEdit
  • OnActivatePane() : CXTPDockingPaneManager
  • OnActivateView() : CXTPCalendarDayView, CXTPCalendarView
  • OnAddChildItem() : CXTPPropertyGridItem
  • OnAddPadding() : CXTPTabBase
  • OnAdjustValueRect() : CXTPPropertyGridInplaceControl, CXTPPropertyGridInplaceSlider, CXTPPropertyGridInplaceSpinButton
  • OnAfterApplicationShutdown() : IXTPApplicationEvents
  • OnAfterCalcSize() : CXTPRibbonGroup
  • OnAfterEdit() : CXTPPropertyGridItem
  • OnAfterExecute() : CXTPChartDeviceCommandEvents
  • OnAllDaysAreaClick() : CXTPCalendarDayViewGroup
  • OnAmbientPropertyChanged() : IXTPApplicationEvents
  • OnAnimate() : CXTPTaskPanelGroup, CXTPTaskPanelGroupItem
  • OnApplicationShutdown() : IXTPApplicationEvents
  • OnBeforeAdd() : CXTPShortcutManager
  • OnBeforeApplicationShutdown() : CXTPSkinManager, IXTPApplicationEvents
  • OnBeforeCalcSize() : CXTPRibbonGroup
  • OnBeforeCopyToText() : CXTPGridControl
  • OnBeforeDestroy() : CXTPCalendarCaptionBarTheme, CXTPCalendarControl, CXTPCalendarTimeLineView, CXTPCalendarView, CXTPCalendarViewEvent, CXTPCalendarWMHandler
  • OnBeforeEditChanged() : CXTPSyntaxEditCtrl, CXTPSyntaxEditLexParser
  • OnBeforeEditOperationNotify() : CXTPCalendarView
  • OnBeforeExchange() : CXTPPropExchange, CXTPPropExchangeIniFile, CXTPPropExchangeRegistry, CXTPPropExchangeXMLNode
  • OnBeforeExecute() : CXTPChartDeviceCommandEvents
  • OnBeforeInsert() : CXTPPropertyGridItem, CXTPPropertyGridItemBool, CXTPPropertyGridItemColor, CXTPPropertyGridItemDate, CXTPPropertyGridItemDouble, CXTPPropertyGridItemEnum, CXTPPropertyGridItemFlags, CXTPPropertyGridItemNumber, CXTPPropertyGridItemOption, CXTPPropertyGridItemPoint, CXTPPropertyGridItemSize
  • OnBeforeItemClick() : CXTPTabManager, CXTPTabToolBar
  • OnBeforePaste() : CXTPGridControl
  • OnBeforePasteFromText() : CXTPGridControl
  • OnBeforePasteNotify() : CXTPCalendarView
  • OnBeforeRemove() : CXTPShortcutManager
  • OnBeginDrag() : CXTPGridControl
  • OnBeginEdit() : CXTPGridRecordItem, CXTPGridRecordItemPreview
  • OnBnClickedDateHeaderFont() : CXTPCalendarPageSetupDialog
  • OnBnClickedPrintDateHeader() : CXTPCalendarPageSetupDialog
  • OnBrowse() : CXTPBrowseEdit
  • OnButtonClick() : CXTPDatePickerControl
  • OnButtonClicked() : CXTPTaskDialog
  • OnButtonDown() : CXTPTreeBase
  • OnButtonRemoved() : CXTPPropertyGridInplaceButtons
  • OnCalcClientHeight() : CXTPTaskPanelGroup
  • OnCalcDynamicSize() : CXTPControl, CXTPControlComboBox, CXTPControlCustom, CXTPControlEdit, CXTPControlGallery, CXTPControlListBox, CXTPControlOleItems, CXTPControlRecentFileList, CXTPControlSelector, CXTPControlToolbars, CXTPControlWindowList, CXTPControlWorkspaceActions, CXTPRibbonControlSystemRecentFileList, CXTPRibbonGroup
  • OnCalendarTimeline() : CXTPCalendarControl
  • OnCancel() : CXTPPropertyGridInplaceMonthCal
  • OnCancelEdit() : CXTPGridRecordItem, CXTPPropertyGridItem
  • OnCaptionButtonClick() : CXTPDockingPaneMiniWnd, CXTPDockingPaneTabbedContainer
  • OnCaptionButtonDown() : CXTPDockingPaneMiniWnd
  • OnCaptionButtonRectChanged() : CXTPDockingPaneBase
  • OnCaptionChanged() : CXTPControl, CXTPControlMarkupLabel, CXTPPropertyGridItem
  • OnCaptionLButtonDown() : CXTPDockingPaneTabbedContainer
  • OnChange() : CXTPHexEdit
  • OnChanged() : CXTPControlAction, CXTPMarkupUIElementCollection
  • OnChangeLayout() : CXTPPasswordPeek
  • OnChanging() : CXTPControlAction
  • OnChar() : CXTPCalendarView, CXTPCalendarWMHandler, CXTPGridRecordItem, CXTPPropertyGridItem
  • OnChartChanged() : CXTPChartContainer, CXTPChartContent, CXTPChartControl, CXTPChartElement
  • OnChecked() : CXTPMarkupToggleButton
  • OnChildContainerChanged() : CXTPDockingPaneAutoHidePanel, CXTPDockingPaneBase, CXTPDockingPaneMiniWnd, CXTPDockingPaneSplitterContainer
  • OnClick() : CXTPControl, CXTPControlButton, CXTPControlColorSelector, CXTPControlComboBox, CXTPControlCustom, CXTPControlEdit, CXTPControlHyperlink, CXTPControlListBox, CXTPControlPopup, CXTPControlProgress, CXTPControlTabWorkspace, CXTPGridGroupRow, CXTPGridRecordItem, CXTPGridRow, CXTPMarkupButtonBase, CXTPMarkupToggleButton, CXTPPopupControl, CXTPTaskPanel, CXTPTrackControlItem
  • OnClickScrollButton() : CXTPTaskPanel
  • OnClientHeightChanged() : CXTPTaskPanel
  • OnCmdMsg() : CXTPCommandBarEditCtrl, CXTPRibbonTab
  • OnCollapsing() : CXTPPopupControl
  • OnColumnsChanged() : CXTPGridHeader
  • OnCommand() : CXTPCommandBarEditCtrl, CXTPMaskEditT< TBase >
  • OnCompareItem() : CXTPFontCtrlBase
  • OnConstraintChanged() : CXTPGridRecordItem, CXTPGridRecordItemVariant
  • OnConstraintsChanged() : CXTPPropertyGridItem, CXTPPropertyGridItemEnum, CXTPPropertyGridItemFlags
  • OnConstraintSelecting() : CXTPGridControl
  • OnContextMenu() : CXTPGridHeader, CXTPGridRow
  • OnControlAdded() : CXTPControls, CXTPRibbonQuickAccessControls
  • OnControlRemoved() : CXTPControls, CXTPRibbonControls, CXTPRibbonQuickAccessControls
  • OnControlRemoving() : CXTPControls, CXTPRibbonControls
  • OnControlsChanged() : CXTPCommandBar, CXTPPopupBar
  • OnControlSelected() : CXTPCommandBar
  • OnCopy() : CXTPCalendarControl
  • OnCreatePane() : CXTPDockingPaneManager
  • OnCreateSplitter() : CXTPDockingPaneSplitterContainer
  • OnCreateWindow() : CXTPPropertyGridInplaceControl, CXTPPropertyGridInplaceSlider, CXTPPropertyGridInplaceSpinButton
  • OnCustomizeDragEnter() : CXTPCommandBar
  • OnCustomizeDragLeave() : CXTPCommandBar
  • OnCustomizeDragOver() : CXTPCommandBar, CXTPControl, CXTPControlPopup
  • OnCustomizeDrop() : CXTPCommandBar, CXTPTabToolBar
  • OnCustomizeMouseMove() : CXTPControl
  • OnCut() : CXTPCalendarControl
  • OnDblClick() : CXTPGridGroupRow, CXTPGridRecordItem, CXTPGridRow, CXTPTrackControlItem
  • OnDblclk() : CXTPShellListView
  • OnDeselect() : CXTPPropertyGridItem, CXTPPropertyGridItemOption
  • OnDestroyWindow() : CXTPPropertyGridInplaceControl
  • OnDialogConstructed() : CXTPTaskDialog
  • OnDialogDestroyed() : CXTPTaskDialog
  • OnDialogNotify() : CXTPTaskDialog
  • OnDragDrop() : CXTPShellListBase
  • OnDragging() : CXTPCalendarDayView, CXTPCalendarView
  • OnDragOver() : CXTPGridControl, CXTPTaskPanel
  • OnDraw() : CXTPButton, CXTPCalendarControl, CXTPCalendarDayView, CXTPCalendarPaintManager, CXTPCalendarView, CXTPDatePickerControl, CXTPDockingPaneContextStickerWnd, CXTPFlowGraphControl, CXTPFlowGraphPage, CXTPGridControl, CXTPGridHeaderDragWnd, CXTPPropertyGridInplaceButton, CXTPShortcutBar, CXTPSkinObjectComboBox, CXTPSpinButtonCtrl, CXTPStatusBarPane, CXTPStatusBarProgressPane, CXTPStatusBarSwitchPane, CXTPTabClientWnd, CXTPTagCloudCtrl, CXTPTaskPanel
  • OnDrawAction() : CXTPGridPaintManager
  • OnDrawBackground() : CXTPHeaderCtrlTheme, CXTPHeaderCtrlThemeExplorer, CXTPHeaderCtrlThemeOffice2003, CXTPHeaderCtrlThemeOfficeXP, CXTPHeaderCtrlThemeResource
  • OnDrawBackgroundWinThemed() : CXTPHeaderCtrlTheme
  • OnDrawBookmark() : CXTPSyntaxEditView
  • OnDrawButton() : CXTPPasswordPeek
  • OnDrawCaption() : CXTPGridRecordItem, CXTPGridRecordItemPercentNumber, CXTPGridRecordItemPreview
  • OnDrawControls() : CXTPGridRecordItem
  • OnDrawDayDate() : CXTPCalendarPaintManager
  • OnDrawEvent() : CXTPCalendarPaintManager
  • OnDrawGrid() : CXTPCalendarPaintManager
  • OnDrawItem() : CXTPControlSelector, CXTPFontCtrlBase, CXTPTaskPanelGroupItem
  • OnDrawItemBackground() : CXTPHeaderCtrlTheme, CXTPHeaderCtrlThemeOffice2003, CXTPHeaderCtrlThemeOfficeXP, CXTPHeaderCtrlThemeResource
  • OnDrawItemBackgroundWinThemed() : CXTPHeaderCtrlTheme, CXTPHeaderCtrlThemeExplorer
  • OnDrawItemBitmap() : CXTPHeaderCtrlTheme
  • OnDrawItemConstraint() : CXTPPropertyGridItem
  • OnDrawItemSortArrow() : CXTPHeaderCtrlTheme, CXTPHeaderCtrlThemeResource
  • OnDrawItemText() : CXTPHeaderCtrlTheme, CXTPHeaderCtrlThemeResource
  • OnDrawItemValue() : CXTPPropertyGridItem, CXTPPropertyGridItemBool, CXTPPropertyGridItemColor, CXTPPropertyGridItemFont, CXTPPropertyGridItemOption
  • OnDrawSplitter() : CXTPSplitterWndEx
  • OnDrop() : CXTPGridControl, CXTPTaskPanel
  • OnDropDown() : CXTPButton
  • OnEditCanceled() : CXTPGridRecordItem
  • OnEditChanged() : CXTPControlComboBox, CXTPControlEdit, CXTPGridRecordItem, CXTPGridRecordItemDateTime, CXTPGridRecordItemNumber, CXTPGridRecordItemPreview, CXTPGridRecordItemText, CXTPGridRecordItemVariant, CXTPSyntaxEditCtrl, CXTPSyntaxEditLexParser, CXTPSyntaxEditView
  • OnEditChanging() : CXTPGridRecordItem, CXTPGridRecordItemVariant, CXTPSyntaxEditView
  • OnEditCommand() : CXTPCalendarControl
  • OnEditMouseWheel() : CXTPPropertyGridInplaceControl, CXTPPropertyGridInplaceSlider, CXTPPropertyGridInplaceSpinButton
  • OnEnabledChanged() : CXTPControl, CXTPControlComboBox, CXTPControlCustom, CXTPControlEdit, CXTPControlListBox, CXTPControlSlider
  • OnEnableScrollBar() : CXTPSyntaxEditView
  • OnEndDragging() : CXTPCalendarDayView, CXTPCalendarView
  • OnEndLabelEdit() : CXTPFlowGraphControl, CXTPTaskPanel
  • OnEndSelection() : CXTPColorSelectorCtrl
  • OneUpPATH() : CXTPShellPidl
  • OneUpPIDL() : CXTPShellPidl
  • OnEvent() : CXTPCalendarResourcesNf, CXTPNotifySinkBase
  • OnEvent_CalendarOptionsChanged() : CXTPCalendarController
  • OnEvent_CalendarResourcesChanged() : CXTPCalendarController
  • OnEvent_CalendarThemeChanged() : CXTPCalendarController
  • OnEvent_CalendarView() : CXTPCalendarController
  • OnEvent_DatePicker() : CXTPCalendarController
  • OnEvent_DtPickGetItemMetrics() : CXTPCalendarController
  • OnEventChanged_InDataProvider() : CXTPCalendarView
  • OnExecute() : CXTPControl, CXTPControlColorSelector, CXTPControlComboBox, CXTPControlFontComboBox, CXTPControlHyperlink, CXTPControlSizeComboBox, CXTPRibbonBackstageView, CXTPTabManagerNavigateButton
  • OnExpandButtonDown() : CXTPShortcutBar
  • OnExpanding() : CXTPPopupControl
  • OnExpandoButtonClicked() : CXTPTaskDialog
  • OnExtendSize() : CXTPRibbonGroup
  • OnFillBackground() : CXTPTabClientWnd
  • OnFillClient() : CXTPTaskPanelGroup
  • OnFlagsChanged() : CXTPFrameShadow, IXTPFrameShadowManagerEvents
  • OnFocusChanged() : CXTPDockingPaneBase, CXTPDockingPaneMiniWnd
  • OnFocusChanging() : CXTPGridControl
  • OnFolderExpanding() : CXTPShellTreeBase
  • OnFolderSelected() : CXTPShellTreeBase
  • OnFrameAccel() : CXTPCommandBars
  • OnFrameShadowDisabled() : IXTPFrameShadowManagerEvents
  • OnFrameShadowEnabled() : IXTPFrameShadowManagerEvents
  • OnFrameWndMsg() : CXTPCommandBars
  • OnGaugeUpdated() : IXTPGaugeClientSite
  • OnGetCheckPosition() : CXTPCheckListBox
  • OnGetColumnDataBestFitWidth() : CXTPGridControl
  • OnGetItemsCaptionMaxWidth() : CXTPGridControl
  • OnGetToolTipInfo() : CXTPGridControl
  • OnGraphChanged() : CXTPFlowGraphConnectionPoint, CXTPFlowGraphControl, CXTPFlowGraphElement, CXTPFlowGraphPage
  • OnGroupAdded() : CXTPRibbonGroup
  • OnGroupRemoved() : CXTPRibbonGroup
  • OnGroupsScroll() : CXTPRibbonTabPopupToolBar
  • OnHelp() : CXTPTaskDialog
  • OnHookAttached() : CXTPHookManagerHookAble, CXTPSkinObject, CXTPSkinObjectFrame
  • OnHookDetached() : CXTPHookManagerHookAble, CXTPSkinObject, CXTPSkinObjectFrame
  • OnHookKeyDown() : CXTPCommandBar, CXTPControl, CXTPControlCheckBox, CXTPControlComboBox, CXTPControlComboBoxList, CXTPControlEdit, CXTPControlListBox, CXTPControlRadioButton, CXTPMiniToolBar, CXTPPopupBar, CXTPRibbonControlTab, CXTPToolBar
  • OnHookMessage() : CXTPCommandBar, CXTPCommandBarsFrameHook, CXTPControlComboBoxList, CXTPControlCustom, CXTPHookManagerHookAble, CXTPMenuBar, CXTPRibbonBackstageView
  • OnHookMouseWheel() : CXTPControl
  • OnHostWndMsg() : IXTPPreview
  • OnHyperlinkClicked() : CXTPTaskDialog
  • OnIdleUpdate() : CXTPControl
  • OnImageUpdateRequired() : IXTPMarkupDeviceDependentImageSite
  • OnIndeterminate() : CXTPMarkupToggleButton
  • OnIndexChanged() : CXTPPropertyGridItem
  • OnInit() : CXTPFontCtrlBase
  • OnInitControl() : CXTPMarqueeCtrl
  • OnInitDialog() : CXTPCalendarPageSetupDialog, CXTPGridPageSetupDialog
  • OnInpaceControlFocus() : CXTPPropertyGridItem, CXTPPropertyGridItemOption
  • OnInplaceButtonDown() : CXTPGridRecordItem, CXTPPropertyGridItem, CXTPPropertyGridItemColor, CXTPPropertyGridItemDate, CXTPPropertyGridItemFont, CXTPPropertyGridItemMultilineString
  • OnInPlaceCreateEvent() : CXTPCalendarView
  • OnInputBoxChanged() : CXTPTaskDialog
  • OnInserted() : CXTPTaskPanelItem
  • OnInsertKey() : CXTPSyntaxEditView
  • OnInvertTracker() : CXTPPropertyGrid
  • OnItemClick() : CXTPRibbonControlTab, CXTPTabControl, CXTPTabManager
  • OnItemHandleChanged() : CXTPTabManager
  • OnItemInserted() : CXTPPopupItem
  • OnItemOrderChanged() : CXTPTabManager
  • OnItemRemoved() : CXTPTaskPanel
  • OnItemsChanged() : CXTPControlGalleryItems, CXTPTabManager
  • OnKeyboardTip() : CXTPCommandBar, CXTPRibbonTabPopupToolBar
  • OnKeyboardTipChar() : CXTPCommandBar
  • OnKeyDown() : CXTPCalendarDayView, CXTPCalendarMonthView, CXTPCalendarView, CXTPCalendarWeekView, CXTPCalendarWMHandler, CXTPPropertyGridInplaceButton, CXTPPropertyGridItem, CXTPPropertyGridItemBool, CXTPPropertyGridItemOption, CXTPScrollDateButtonPart
  • OnKeyUp() : CXTPCalendarWMHandler, CXTPScrollDateButtonPart
  • OnKillFocus() : CXTPControlComboBox, CXTPControlEdit
  • OnLButtonDblClk() : CXTPCalendarDayViewGroup, CXTPCalendarView, CXTPCalendarViewEvent, CXTPCalendarWMHandler, CXTPControl, CXTPControlPopup, CXTPGridHeader, CXTPPropertyGridItem, CXTPPropertyGridItemBool, CXTPPropertyGridItemOption, CXTPRibbonControlSystemButton
  • OnLButtonDown() : CXTPCalendarCaptionBarThemePart, CXTPCalendarDayView, CXTPCalendarDayViewGroup, CXTPCalendarMonthView, CXTPCalendarMonthViewDay, CXTPCalendarView, CXTPCalendarViewEvent, CXTPCalendarWeekViewDay, CXTPCalendarWMHandler, CXTPControl, CXTPDatePickerItemMonth, CXTPGridHeader, CXTPGridRecordItem, CXTPGridRecordItemButton, CXTPGridRecordItemControl, CXTPGridRow, CXTPPropertyGridInplaceButton, CXTPPropertyGridItem, CXTPPropertyGridItemBool, CXTPPropertyGridItemOption, CXTPScrollDateButtonPart, CXTPStatusBarPane, CXTPStatusBarSwitchPane, CXTPTrackControlItem, CXTPTrackHeader
  • OnLButtonUp() : CXTPCalendarCaptionBarThemePart, CXTPCalendarDayView, CXTPCalendarView, CXTPCalendarViewEvent, CXTPCalendarWMHandler, CXTPControl, CXTPControlButton, CXTPControlColorSelector, CXTPControlPopup, CXTPControlSelector, CXTPDatePickerItemMonth, CXTPGridHeader, CXTPGridRecordItem, CXTPGridRecordItemButton, CXTPGridRecordItemControl, CXTPGridRow, CXTPPropertyGridItem, CXTPRibbonControlSystemPopupBarPinableListItem, CXTPTrackControlItem
  • OnLexCfgWasChanged() : CXTPSyntaxEditCtrl
  • OnLoadingFailed() : CXTPResourceManager
  • OnMarginClicked() : CXTPSyntaxEditView
  • OnMarkupChanged() : CXTPPropertyGridItem
  • OnMDIActivate() : CXTPMDIWndTab
  • OnMDICreate() : CXTPMDIWndTab
  • OnMDIDestroy() : CXTPMDIWndTab
  • OnMeasureItem() : CXTPFontCtrlBase
  • OnMergeItemConstraint() : CXTPPropertyGridItem
  • OnMouseEnter() : CXTPGridRecordItemButton, CXTPGridRecordItemControl
  • OnMouseHitTest() : CXTPCommandBar, CXTPDialogBar
  • OnMouseHover() : CXTPControl, CXTPControlComboBox, CXTPControlEdit, CXTPControlPopup
  • OnMouseLeave() : CXTPGridRecordItemButton, CXTPGridRecordItemControl
  • OnMouseMove() : CXTPCalendarCaptionBarTheme, CXTPCalendarCaptionBarThemePart, CXTPCalendarDayView, CXTPCalendarDayViewDay, CXTPCalendarDayViewGroup, CXTPCalendarMonthView, CXTPCalendarMonthViewDay, CXTPCalendarView, CXTPCalendarViewEvent, CXTPCalendarWeekViewDay, CXTPCalendarWMHandler, CXTPControl, CXTPControlColorSelector, CXTPControlComboBox, CXTPControlEdit, CXTPControlHyperlink, CXTPControlPopup, CXTPControlSelector, CXTPControlTabWorkspace, CXTPDatePickerItemMonth, CXTPGridHeader, CXTPGridRecordItem, CXTPGridRecordItemButton, CXTPGridRecordItemControl, CXTPGridRow, CXTPRibbonControlSystemPopupBarPinableListItem, CXTPStatusBarPane, CXTPStatusBarSwitchPane, CXTPTrackControlItem, CXTPTrackHeader
  • OnMouseWheel() : CXTPChartDiagram2DView, CXTPChartDiagramView
  • OnMoveMarker() : CXTPTrackHeader
  • OnMoveScrollBar() : CXTPTrackHeader
  • OnMoveSelection() : CXTPFlowGraphControl
  • OnMoveSlider() : CXTPTrackHeader
  • OnNavigate() : CXTPPropertyGrid
  • OnNavigateButtonClick() : CXTPDockingPaneTabbedContainer, CXTPTabControl, CXTPTabManager
  • OnNavigateButtonDown() : CXTPShortcutBar
  • OnNavigated() : CXTPTaskDialog
  • OnNcCalcSize() : CXTPPropertyGridPaintManager
  • OnNotify() : CXTPListBase, CXTPTagCloudCtrl
  • OnOK() : CXTPCalendarPageSetupDialog, CXTPGridPageSetupDialog
  • OnOptionsChanged() : CXTPCalendarControl, CXTPCalendarOptions
  • OnPageSelected() : CXTPPropertyPageNavigator
  • OnPaint() : CXTPTaskPanelGroup
  • OnPaintManagerChanged() : CXTPToolBar
  • OnParentContainerChanged() : CXTPDockingPaneBase, CXTPDockingPaneSplitterContainer
  • OnParseEvent() : CXTPSyntaxEditCtrl, CXTPSyntaxEditView
  • OnPartClick() : CXTPCalendarCaptionBarTheme
  • OnPaste() : CXTPCalendarControl
  • OnPinButtonClick() : CXTPDockingPaneMiniWnd, CXTPDockingPaneSidePanel
  • OnPostAdjustLayout() : CXTPCalendarDayViewEvent, CXTPCalendarMonthViewEvent, CXTPCalendarViewEvent, CXTPCalendarWeekViewEvent, CXTPCalendarWMHandler
  • OnPostHookMessage() : CXTPHookManagerHookAble
  • OnPrepareValue() : CXTPMarkupStaticExtension
  • OnPrePopulate() : CXTPCalendarViewGroup
  • OnPrePopulateDay() : CXTPCalendarViewDay
  • OnPreviewEditKey() : CXTPShortcutManager
  • OnPreviewKeyDown() : CXTPGridControl
  • OnPropertyChanged() : CXTPTabManagerAtom, CXTPTabPaintManager
  • OnRadioButtonClicked() : CXTPTaskDialog
  • OnRButtonDown() : CXTPControl, CXTPPropertyGridItem
  • OnRButtonUp() : CXTPControl
  • OnRecalcLayout() : CXTPCommandBar, CXTPControlTabWorkspace, CXTPPopupBar, CXTPToolBar
  • OnReduceSize() : CXTPRibbonGroup
  • OnRemoved() : CXTPCommandBar, CXTPControl, CXTPControlAction, CXTPControlComboBox, CXTPControlCustom, CXTPControlEdit, CXTPControlTabWorkspace, CXTPFlowGraphConnection, CXTPFlowGraphConnectionPoint, CXTPFlowGraphElement, CXTPFlowGraphImage, CXTPFlowGraphNode, CXTPFlowGraphPage, CXTPRibbonTab, CXTPTabManagerItem, CXTPTaskPanelGroup, CXTPTaskPanelItem
  • OnRender() : CXTPMarkupVisual
  • OnRenderFocusVisual() : CXTPMarkupVisual
  • OnReposition() : CXTPTaskPanelGroup, CXTPTaskPanelGroupItem
  • OnRepositionDone() : CXTPShortcutBar
  • OnRequestEdit() : CXTPGridRecordItem, CXTPPropertyGridItem
  • OnResize() : CXTPDialogBar
  • OnRowColChanged() : CXTPSyntaxEditView
  • OnScroll() : CXTPControlScrollBar, CXTPControlSlider, CXTPPropertyGridInplaceSlider
  • OnScrollChanged() : CXTPTaskPanel
  • OnScrollEnd() : CXTPCalendarTimeLineView, CXTPCalendarView
  • OnScrollHeader() : CXTPTabManager
  • OnSelChange() : CXTPTabExBase
  • OnSelChanged() : CXTPControlComboBox
  • OnSelChanging() : CXTPTabExBase
  • OnSelect() : CXTPPropertyGridItem
  • OnSelectedItemChanged() : CXTPControlGallery
  • OnSelectionChanged() : CXTPGridControl, CXTPGridInplaceList, CXTPPropertyGrid
  • OnSelInit() : CXTPSyntaxEditView
  • OnSeriesAdded() : CXTPChartDiagram
  • OnSeriesRemoved() : CXTPChartDiagram
  • OnSeriesStyleChanged() : CXTPChartContent
  • OnSetConnectorPoints() : CXTPChart3dFunnelDeviceCommandEvents, CXTPChart3dFunnelSeriesPointView, CXTPChart3dPieDeviceCommandEvents, CXTPChart3dPieSeriesPointView, CXTPChart3dPyramidDeviceCommandEvents, CXTPChart3dPyramidSeriesPointView
  • OnSetCursor() : CXTPDatePickerItemMonth
  • OnSetDocModified() : CXTPSyntaxEditView
  • OnSetFocus() : CXTPControlComboBox, CXTPControlEdit
  • OnSetPopup() : CXTPControl, CXTPControlComboBox, CXTPControlPopup, CXTPControlSizeComboBox
  • OnSetPreviewMode() : CXTPCommandBars, CXTPDockingPaneManager, CXTPToolBar
  • OnSetSelected() : CXTPControl, CXTPControlColorSelector, CXTPControlComboBox, CXTPControlEdit, CXTPControlListBox, CXTPControlPopup, CXTPControlSelector, CXTPRibbonControlSystemPopupBarPinableListItem, CXTPRibbonControlTab
  • OnShadowedFrameActiveStateChanged() : CXTPFramePaintManager
  • OnShow() : CXTPPopupControl
  • OnShowContextMenu() : CXTPShellPidl
  • OnSizeParent() : CXTPDockingPane, CXTPDockingPaneBase, CXTPDockingPaneSplitterContainer
  • OnSizeParentEx() : CXTPDockingPaneAutoHidePanel
  • OnSizingFloatingFrame() : CXTPDockingPaneContext
  • OnSkinChanged() : CXTPSkinManager, CXTPSkinObject, CXTPSkinObjectDateTime, CXTPSkinObjectFrame
  • OnSortChanged() : CXTPPropertyGrid
  • OnStartDragging() : CXTPCalendarDayView, CXTPCalendarView
  • OnStartGroupDrag() : CXTPTaskPanel
  • OnStartItemDrag() : CXTPTaskPanel
  • OnStartOleDrag() : CXTPSyntaxEditView
  • OnSwitchItem() : CXTPTabManager
  • OnSysKeyDown() : CXTPCalendarView, CXTPCalendarWMHandler
  • OnTabChanged() : CXTPRibbonBar
  • OnTabChanging() : CXTPRibbonBar
  • OnTabsChanged() : CXTPDockingPaneTabbedContainer
  • OnThemeChanged() : CXTPControl, CXTPControlMarkupLabel, CXTPHeaderCtrl, CXTPTabExBase
  • OnThemedChanged() : CXTPDockingPaneMiniWnd
  • OnTimer() : CXTPCalendarCaptionBarTheme, CXTPCalendarDayView, CXTPCalendarView, CXTPCalendarViewEvent, CXTPCalendarWMHandler, CXTPTaskDialog
  • OnTimeZoneChanged() : CXTPCalendarData, CXTPCalendarMemoryDataProvider
  • OnToggle() : CXTPMarkupToggleButton
  • OnToolBarAdded() : CXTPCommandBars
  • OnToolBarRemoved() : CXTPCommandBars
  • OnToolHitTest() : CXTPControl, CXTPControlColorSelector, CXTPControlTabWorkspace, CXTPDockingPaneSidePanel, CXTPGridGroupRow, CXTPGridHeader, CXTPGridRecordItem, CXTPGridRow, CXTPRibbonTabPopupToolBar, CXTPStatusBarPane, CXTPStatusBarSwitchPane, CXTPTrackControlItem
  • OnTrackEnter() : CXTPCommandBar
  • OnTrackingModeChanged() : CXTPCommandBars
  • OnTrackLost() : CXTPCommandBar
  • OnUnchecked() : CXTPMarkupToggleButton
  • OnUnderlineActivate() : CXTPControl, CXTPControlComboBox, CXTPControlEdit, CXTPControlPopup, CXTPRibbonControlTab
  • OnUndo() : CXTPCalendarControl
  • OnUnsubscribe() : CXTPChartDeviceCommandEvents
  • OnUpdateBounds() : CXTPChart3dFunnelSeriesPointView, CXTPChart3dPieSeriesPointView, CXTPChart3dPyramidSeriesPointView, CXTPChartDeviceCommandEvents
  • OnUpdateCameraState() : CXTPChart3dDeviceContext
  • OnUpdateCmdUI() : CXTPCalendarControl
  • OnUpdateCopy() : CXTPCalendarControl
  • OnUpdateCut() : CXTPCalendarControl
  • OnUpdateEditingSubject() : CXTPCalendarView
  • OnUpdateMDIChildrenTheme() : CXTPCommandBarsFrameHook
  • OnUpdatePaste() : CXTPCalendarControl
  • OnUpdateScrollPos() : CXTPSyntaxEditView
  • OnUpdateUndo() : CXTPCalendarControl
  • OnValidateEdit() : CXTPGridRecordItem, CXTPPropertyGridItem
  • OnValueChanged() : CXTPPropertyGridInplaceControl, CXTPPropertyGridInplaceSlider, CXTPPropertyGridInplaceSpinButton, CXTPPropertyGridItem, CXTPPropertyGridItemDate
  • OnValueChanging() : CXTPGridRecordItemVariant
  • OnVerbClick() : CXTPPropertyGrid
  • OnVerbsChanged() : CXTPPropertyGrid
  • OnVerificationClicked() : CXTPTaskDialog
  • OnWndMsg() : CXTPCalendarControl, CXTPCalendarViewEvent, CXTPCalendarWMHandler
  • OnWndMsg_Children() : CXTPCalendarControl
  • Open() : CXTPCalendarData, CXTPCalendarDatabaseDataProvider, CXTPCalendarMemoryDataProvider, CXTPMemFile, CXTPSkinManagerResourceFile
  • OpenEx() : CXTPCalendarDatabaseDataProvider
  • OpenThemeData() : CXTPWinThemeWrapper
  • operator _TObject *() : CXTPSmartPtrInternalT< _TObject >
  • operator _TValue &() : CXTPAutoResetValue< _TValue >
  • operator _TValue *() : CXTPCalendarViewPartCustomizableValueT< _TValue >
  • operator _TValueRef() : CXTPCalendarThemeCustomizableXValueT< _TValue, _TValueRef >
  • operator Adaptee *() : CXTPAsyncGuard< Adaptee, RWLock >
  • operator BOOL() : CXTPImageManagerVectorImageHandle
  • operator bool() : CXTPSmartPtrInternalT< _TObject >
  • operator CBrush &() : CXTPBrush
  • operator CFont &() : CXTPCalendarViewPartFontValue, CXTPFont
  • operator CFont *() : CXTPCalendarViewPartFontValue
  • operator CGdiObject &() : CXTPGdiObject
  • operator CImageList &() : CXTPImageList
  • operator COLORREF() : CXTPPaintManagerColor, CXTPPaintManagerColorGradient
  • operator const Adaptee *() : CXTPAsyncGuard< Adaptee, RWLock >
  • operator const CBrush &() : CXTPBrush
  • operator const CFont &() : CXTPFont
  • operator const CGdiObject &() : CXTPGdiObject
  • operator const CImageList &() : CXTPImageList
  • operator const CPen &() : CXTPPen
  • operator const CString &() : CXTPCalendarThemeStringValue
  • operator CPen &() : CXTPPen
  • operator CRect() : CXTPResizeRect
  • operator CRITICAL_SECTION &() : CXTPCriticalSection
  • operator CString() : CXTPHeapString, CXTPHeapStringT< _TAllocator >
  • operator CXTPPaintManagerColor &() : CXTPPaintManagerColorGradient
  • operator CXTPPoint2d() : CXTPPoint2T< T >, CXTPPoint3T< T >
  • operator CXTPPoint2f() : CXTPPoint2T< T >, CXTPPoint3T< T >
  • operator CXTPPoint2i() : CXTPPoint2T< T >, CXTPPoint3T< T >
  • operator CXTPPoint3d() : CXTPPoint3T< T >
  • operator CXTPPoint3f() : CXTPPoint3T< T >
  • operator CXTPPoint3i() : CXTPPoint3T< T >
  • operator delete() : CXTPBatchAllocObjT< _TObject, _TBatchAllocData, _TAllocator >, CXTPHeapObjectT< _TObject, _TAllocator >
  • operator HBRUSH() : CXTPBrush
  • operator HFONT() : CXTPFont
  • operator HGDIOBJ() : CXTPGdiObject
  • operator HICON() : CXTPIconHandle, CXTPImageManagerIconHandle
  • operator HIMAGELIST() : CXTPImageList
  • operator HMODULE() : CXTPModuleHandle
  • operator HPEN() : CXTPPen
  • operator int() : XTP_CALENDAR_MONTHVIEW_DAYPOS
  • operator LPCTSTR() : CXTPHeapString, CXTPHeapStringT< _TAllocator >
  • operator LPMALLOC() : CXTPShellPidl::CShellMalloc
  • operator LPSHELLFOLDER() : CXTPShellPidl::CShellSpecialFolder
  • operator new() : CXTPBatchAllocObjT< _TObject, _TBatchAllocData, _TAllocator >, CXTPHeapObjectT< _TObject, _TAllocator >
  • operator!() : CXTPSmartPtrInternalT< _TObject >
  • operator!=() : CXTPGdiObject, CXTPHeapString, CXTPHeapStringT< _TAllocator >, CXTPPoint2T< T >, CXTPPoint3T< T >, CXTPRectT< T >, CXTPResizeRect, CXTPSizeT< T >, CXTPSmartPtrInternalT< _TObject >, CXTPSyntaxEditSelection, XTP_CALENDAR_HITTESTINFO, XTP_EDIT_LINECOL
  • operator&() : CXTPResizeRect
  • operator*() : CXTPAsyncGuard< Adaptee, RWLock >, CXTPSmartPtrInternalT< _TObject >, CXTPThreadLocal< T >
  • operator+() : CXTPResizeRect, CXTPSizeT< T >
  • operator++() : XTP_CALENDAR_MONTHVIEW_DAYPOS
  • operator+=() : CXTPMemFile, CXTPResizeRect
  • operator-() : CXTPSizeT< T >
  • operator->() : CXTPAsyncGuard< Adaptee, RWLock >, CXTPCalendarViewPartCustomizableValueT< _TValue >, CXTPCalendarViewPartFontValue, CXTPSmartPtrInternalT< _TObject >
  • operator<() : XTP_EDIT_LINECOL
  • operator<=() : XTP_EDIT_LINECOL
  • operator=() : CXTPAutoResetValue< _TValue >, CXTPCalendarEventLabel, CXTPCalendarThemeBOOLValue, CXTPCalendarThemeCustomizableXValueT< _TValue, _TValueRef >, CXTPCalendarThemeFontValue, CXTPCalendarThemeIntValue, CXTPCalendarThemeRectValue, CXTPCalendarThemeStringValue, CXTPCalendarTimeZone, CXTPCalendarViewPartFontValue, CXTPChart3dBox, CXTPChart3dRotation, CXTPEmptySize, CXTPGridThickness, CXTPHeapString, CXTPHeapStringT< _TAllocator >, CXTPIconHandle, CXTPImageManagerVectorImageHandle, CXTPLogFont, CXTPMemFile, CXTPPaintManagerColor, CXTPPaintManagerColorGradient, CXTPResizeRect, CXTPSmartPtrInternalT< _TObject >, CXTPSyntaxEditCtrl, CXTPSyntaxEditLexParserSchemaOptions, CXTPSyntaxEditLexTokensDef, CXTPSyntaxEditLexVariable, CXTPSyntaxEditLexVariant, CXTPSyntaxEditSelection, CXTPTagCloudStyle, XTP_CALENDAR_MONTHVIEW_DAYPOS, XTP_CALENDAR_PATTERN_END, XTP_CALENDAR_RECURRENCE_OPTIONS, XTP_CALENDAR_VIEWSELECTION, XTP_GRIDDATAMANAGER_COM_ERROR
  • operator==() : CXTPGdiObject, CXTPHeapString, CXTPHeapStringT< _TAllocator >, CXTPPoint2T< T >, CXTPPoint3T< T >, CXTPRectT< T >, CXTPResizeRect, CXTPSizeT< T >, CXTPSmartPtrInternalT< _TObject >, CXTPSyntaxEditLexVariable, CXTPSyntaxEditLexVariant, CXTPSyntaxEditSelection, XTP_CALENDAR_HITTESTINFO, XTP_EDIT_LINECOL
  • operator>() : XTP_EDIT_LINECOL
  • operator>=() : XTP_EDIT_LINECOL
  • operator[]() : CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE >, CXTPCalendarTypedPtrAutoDeleteMap< KEY, TPtr >, CXTPMemFile, CXTPTabManagerNavigateButtons
  • OptimizeChildrenClipping() : CXTPScrollBarContainer< Parent >
  • OverrideTimeProvider() : CXTPCalendarUtils
  • OwnerDrawTip() : CXTPSyntaxEditTipWnd


Toolkit Pro: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- p -

  • p_sColorScheme : CXTPSyntaxEditConfigurationManager
  • p_sSyntaxScheme : CXTPSyntaxEditConfigurationManager
  • page : XTP_SCROLLBAR_POSINFO
  • PageToScreen() : CXTPFlowGraphPage
  • PageToSize() : CXTPPropertyPageNavigator
  • PaneHasBorders() : CXTPDockingPaneOffice2007WordTheme
  • ParceTimeDuration_min() : CXTPCalendarUtils
  • ParceTimeString_min() : CXTPCalendarUtils
  • Parse() : CXTPMarkupContext, CXTPMarkupStaticExtension
  • ParseDateTime() : CXTPPropertyGridItemDate
  • ParseSection() : CXTPSyntaxEditColorTheme
  • ParseSectionFromString() : CXTPSyntaxEditColorTheme
  • parStrings : XTP_NM_GRID_BEFORE_COPYPASTE
  • PassKeyboardInputToBackstageView() : CXTPRibbonBar
  • Paste() : CXTPCalendarView, CXTPFlowGraphPage, CXTPGridControl, CXTPSyntaxEditCtrl
  • PasteFromClipboard() : CXTPTaskPanelItem
  • PathFindNextComponent() : CXTPShellTreeBase
  • pBlock : CXTPTrackControl::DRAGBLOCK, XTP_NM_TRACKCONTROL
  • pButton : XTP_NM_GRIDINPLACEBUTTON
  • pColumn : XTP_GRIDRECORDITEM_ARGS, XTP_NM_GRIDCOLUMNORDERCHANGED, XTP_NM_GRIDCOLUMNRESIZE, XTP_NM_GRIDRECORDITEM
  • pCommandBar : XTP_COMMANDBARS_CREATEBAR, XTP_COMMANDBARS_CREATECONTROL
  • pCommandBars : XTP_COMMANDBARS_PROPEXCHANGE_PARAM
  • pConnection : CXTPNotifySinkBase::ADVISE_DESCRIPTOR, XTP_NM_FLOWGRAPH_CONNECTIONCHANGED, XTP_NM_FLOWGRAPH_CONNECTIONCHANGING
  • pConstraint : XTP_NM_GRIDCONSTRAINTSELECTING
  • pContainer : XTP_DOCKINGPANE_CLICK
  • pControl : NMXTPCONTROL, XTP_COMMANDBARS_CREATECONTROL, XTP_GRIDRECORDITEM_ARGS
  • pControls : XTP_COMMANDBARS_CATEGORYINFO
  • pcszInitialSubject : XTP_EVENT_IN_PLACE_CREATE_EVENT_OPERATION_PARAMS
  • pDataObject : XTP_NM_GRIDDRAGDROP
  • pDataSource : XTP_NM_GRIDDRAGDROP
  • pDC : XTP_GRIDRECORDITEM_DRAWARGS, XTPPROGRESSDRAWSTRUCT
  • pDockContainer : XTP_DOCKINGPANE_ACTION
  • pDockingHolder : XTP_DOCKINGPANE_INFO
  • pDraggingEvent : XTP_EVENT_DRAG_OPERATION_PARAMS
  • pDraggingEventNew : XTP_EVENT_DRAG_OPERATION_PARAMS
  • pDraggingEventOriginal : XTP_EVENT_DRAG_OPERATION_PARAMS
  • pDrawArgs : XTP_NM_GRIDITEMMETRICS
  • PeekButtonEnable() : CXTPPasswordPeek
  • PerformClick() : CXTPMessageBarButton, CXTPTabManager, CXTPTabManagerNavigateButton
  • PerformKeyDown() : CXTPTabManager
  • PerformMouseMove() : CXTPTabManager
  • PerformToolHitTest() : CXTPTabManager
  • PerformTrackInit() : CXTPScrollBase
  • pEvent : XTP_EVENT_PASTE_OPERATION_PARAMS
  • pEventViews : XTP_EVENT_EDIT_OPERATION_PARAMS
  • pFloatingHolder : XTP_DOCKINGPANE_INFO
  • PFNGETSYSCOLOR : CXTPColorManager
  • PFNSETLAYEREDWINDOWATTRIBUTES : CXTPMiniToolBar
  • pFont : XTP_GRIDRECORDITEM_METRICS, XTPPROGRESSDRAWSTRUCT
  • pFrom : CXTPFlowGraphPageHistoryItem
  • pGroup : XTP_TPNGROUPEXPANDING
  • pGroupCaption : CXTPTaskPanelScrollButton
  • pGroupScroll : CXTPTaskPanelScrollButton
  • PinFooterRows() : CXTPGridControl
  • PinFooterRowsPrinted() : CXTPGridControl
  • pInputConnectionPoint : XTP_NM_FLOWGRAPH_CONNECTIONCHANGING
  • pItem : CXTPControlGallery::GALLERYITEM_POSITION, XTP_GRIDRECORDITEM_ARGS, XTP_NM_FLOWGRAPH_ENDLABELEDIT, XTP_NM_GRIDRECORDITEM, XTP_PROPERTYGRID_NOTIFYEDIT, XTP_TPNENDLABELEDIT
  • pItemControl : XTP_NM_GRIDITEMCONTROL
  • pItemMetrics : XTP_NM_GRIDITEMMETRICS
  • Pixel() : CXTPDockingPanePaintManager, CXTPPaintManager, CXTPTabBaseTheme
  • pLastHolder : XTP_DOCKINGPANE_INFO
  • PlaySystemSound() : CXTPSoundManager
  • pMarker : XTP_NM_TRACKCONTROL
  • pMenu : XTP_COMMANDBARS_CREATECONTROL
  • pNewMatrix : CXTPMarkupVisual::TransformationMatrices
  • pNode : XTP_NM_FLOWGRAPH_NODECHANGED
  • PointInRect() : CXTPTagCloudCtrl
  • PointList : CXTPChart3dBox
  • Polar2Cartesian() : CXTPChartEllipse
  • pOldMatrix : CXTPMarkupVisual::TransformationMatrices
  • Populate() : CXTPCalendarControl, CXTPCalendarDayViewDay, CXTPCalendarMonthView, CXTPCalendarTimeLineView, CXTPCalendarTimeLineViewGroup, CXTPCalendarView, CXTPCalendarViewDay, CXTPCalendarViewGroup, CXTPCalendarWeekView, CXTPDatePickerControl, CXTPGridControl, CXTPGridSection, CXTPTrackControl
  • PopulateDays() : CXTPDatePickerItemMonth
  • PopulateFooterRows() : CXTPGridControl
  • PopulateHeaderRows() : CXTPGridControl
  • PopulateListView() : CXTPShellListBase
  • PopulateTree() : CXTPShellTreeBase
  • PopulateTreeView() : CXTPShellTreeBase
  • Popup() : CXTPCommandBar, CXTPControlComboBoxList, CXTPPopupBar, CXTPRibbonBackstageView
  • PopupMenu() : CXTPBrowseEdit
  • pos : XTP_SCROLLBAR_POSINFO
  • Pos1 : XTP_EDIT_LINECOL
  • PosInRange() : CXTPMaskEditT< TBase >
  • PositionBrowseButton() : CXTPBrowseEdit
  • PositionControls() : CXTPStatusBar
  • PositionToTrack() : CXTPTrackControl
  • posMax : XTP_SCROLLBAR_POSINFO
  • posMin : XTP_SCROLLBAR_POSINFO
  • posNew : XTP_SCROLLBAR_TRACKINFO
  • posOld : XTP_SCROLLBAR_TRACKINFO
  • PostEvent() : CXTPNotifyConnectionMT
  • PostNotify_RemindersFire() : CXTPCalendarRemindersManager
  • pPane : XTP_DOCKINGPANE_ACTION, XTP_DOCKINGPANE_CLICK, XTP_DOCKINGPANE_INFO
  • ppRecord : XTP_NM_GRID_BEFORE_COPYPASTE
  • PreCompareItem() : CXTPCheckListBox
  • pRecords : XTP_NM_GRIDDRAGDROP
  • PreDeleteItem() : CXTPCheckListBox
  • PreDrawItem() : CXTPCheckListBox, CXTPControlGalleryItems
  • PreDrawItemNonThemed() : CXTPCheckListBox
  • PreDrawItemThemed() : CXTPCheckListBox
  • PreMeasureItem() : CXTPCheckListBox
  • PreMultiply() : CXTPImageManagerIconHandle
  • Premultiply() : CXTPResourceImage
  • PreMultiplyAlphaBitmap() : CXTPImageManagerIcon
  • PreMultiplyAlphaBitmapBits() : CXTPImageManager
  • Prepare() : CXTPChartDeviceCommand
  • PrepareCodeChunk() : IXTPMarkupClientSite
  • PrepareDeleteGridRecords() : CXTPGridDataManager
  • PrepareDrag() : CXTPTaskPanelGroupItem
  • PrepareName() : CXTPCalendarCustomProperties
  • PrepareOverride() : CXTPChartDeviceCommand
  • PrepareToDropping() : CXTPGridRecords
  • PreserveOrientation() : CXTPResourceImage
  • pResource : XTP_IMAGERESOURCE_INFO
  • PreSubclassWindow() : CXTPDatePickerControl
  • PreTranslateFrameMessage() : CXTPCommandBars
  • PreTranslateMessage() : CXTPMaskEditT< TBase >
  • PrevBookmark() : CXTPSyntaxEditCtrl
  • Preview() : CXTPPreviewCtrl
  • PreviewAllowEdit() : CXTPGridControl
  • PrevView() : CXTPTabExBase
  • PrintClient() : CXTPSplitterWnd
  • PrintFixedRowsDivider() : CXTPGridView
  • PrintFooter() : CXTPGridView
  • PrintGrid() : CXTPGridView
  • PrintHeader() : CXTPGridView
  • PrintLineTextEx() : CXTPSyntaxEditPaintManager
  • PrintPage() : CXTPGridView, CXTPSyntaxEditCtrl
  • PrintPageFooter() : CXTPGridView
  • PrintPageHeader() : CXTPGridView
  • PrintRowPart() : CXTPSyntaxEditDrawTextProcessor
  • PrintToDC() : CXTPChartControl
  • ProcessButtons() : CXTPDatePickerControl
  • ProcessCollapsedBlockDblClick() : CXTPSyntaxEditCtrl
  • ProcessCollapsedText() : CXTPSyntaxEditCtrl
  • ProcessCollapsedTextEx() : CXTPSyntaxEditCtrl
  • ProcessDaySelection() : CXTPCalendarDayView, CXTPCalendarView
  • ProcessEventSelection() : CXTPCalendarView
  • ProcessHookKeyDown() : CXTPControlComboBoxList
  • ProcessKeyboardHooks() : CXTPKeyboardManager
  • ProcessKeyboardInput() : CXTPRibbonBackstageView
  • ProcessMask() : CXTPDateEdit, CXTPMaskEditT< TBase >, CXTPTimeEdit
  • ProcessSpecialKey() : CXTPCommandBar, CXTPRibbonTabPopupToolBar
  • Project() : CXTPChart3dDeviceContext, CXTPOpenGLUtils
  • PropExists() : CXTPSyntaxEditPropertiesPageColor
  • propType : CXTPSkinManagerSchemaProperty
  • PropV() : CXTPSyntaxEditLexClass
  • ProvideValue() : CXTPMarkupStaticExtension, CXTPMarkupStaticExtensionProperty
  • pRow : XTP_GRIDRECORDITEM_ARGS, XTP_NM_GRIDRECORDITEM, XTP_NM_GRIDROWRESIZE, XTP_NM_SELECTION_CHANGING
  • pSBInfo : XTP_SCROLLBAR_TRACKINFO
  • pSender : NMXTPSCROLL
  • pSink : CXTPNotifyConnection::CONNECTION_DESCRIPTOR
  • pstrText : XTP_CALENDAR_GETITEMTEXT_PARAMS, XTP_NM_GRIDTOOLTIPINFO
  • pt : XTP_CALENDAR_HITTESTINFO, XTP_DOCKINGPANE_CLICK, XTP_NM_GRIDDRAGDROP, XTP_NM_GRIDRECORDITEM
  • pTab : NMXTPTABCHANGE
  • pTargetRecord : XTP_NM_GRIDDRAGDROP
  • ptClient : XTP_GRIDRECORDITEM_CLICKARGS
  • pTicks : XTP_SLIDERTICKS
  • PtInCheckBoxRect() : CXTPPropertyGridItemBool
  • PtInRect() : CXTPDockingPaneCaptionButton, CXTPFlowGraphConnection, CXTPMarkupGdiPlusTransformationMatrix, CXTPMarkupTransformationMatrix
  • PtInRectTransform() : CXTPMarkupVisual
  • PtInValueRect() : CXTPPropertyGridItem
  • ptMouse : XTPGridInputState
  • pTo : CXTPFlowGraphPageHistoryItem
  • PumpMessage() : CXTPMiniToolBar, CXTPPopupBar
  • PutSection() : CXTPPropExchangeXMLNode
  • pViewDay : XTP_CALENDAR_GETITEMTEXT_PARAMS, XTP_CALENDAR_HITTESTINFO, XTP_CALENDAR_USERACTION_PARAMS::EXPANDDAYBUTTONACTION_PARAMS
  • pViewEvent : XTP_CALENDAR_GETITEMTEXT_PARAMS, XTP_CALENDAR_HITTESTINFO
  • pViewGroup : XTP_CALENDAR_HITTESTINFO, XTP_CALENDAR_THEME_DAYVIEWCELL_PARAMS, XTP_CALENDAR_USERACTION_PARAMS::SCROLLDAYBUTTONACTION_PARAMS
  • pWnd : CXTPTcbItem
  • pWndCtrl : XTPPROGRESSDRAWSTRUCT
  • pxBottom : XTP_SCROLLBAR_POSINFO
  • pxDownArrow : XTP_SCROLLBAR_POSINFO
  • pxLeft : XTP_SCROLLBAR_POSINFO
  • pxMin : XTP_SCROLLBAR_POSINFO
  • pxOld : XTP_SCROLLBAR_TRACKINFO
  • pxPopup : XTP_SCROLLBAR_POSINFO
  • pxRight : XTP_SCROLLBAR_POSINFO
  • pxStart : XTP_SCROLLBAR_POSINFO
  • pxThumbBottom : XTP_SCROLLBAR_POSINFO
  • pxThumbTop : XTP_SCROLLBAR_POSINFO
  • pxTop : XTP_SCROLLBAR_POSINFO
  • pxUpArrow : XTP_SCROLLBAR_POSINFO


Toolkit Pro: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- q -

  • QueryContinueDrag() : CXTPDropSource
  • QueryInterface() : CXTPDropSource
  • QueueDayViewSwitch() : CXTPCalendarControl


Toolkit Pro: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- r -

  • Radian2Degree() : CXTPMathUtils
  • range : XTPPROGRESSDRAWSTRUCT
  • rc : CXTPDockingPaneWindowSelect::CItem, XTP_IMAGERESOURCE_INFO, XTP_SCROLLBAR_POSINFO
  • rcBookmark : XTP_EDIT_SENMBOOKMARK
  • rcBorder : CXTPColorSelectorCtrl::COLOR_CELL
  • rcButton : CXTPTaskPanelScrollButton
  • rcClient : XTPPROGRESSDRAWSTRUCT
  • rcCollMark : XTP_EDIT_COLLAPSEDBLOCK
  • rcExclude : XTP_DOCKINGPANE_CLICK
  • rcItem : CXTPControlGallery::GALLERYITEM_POSITION, XTP_GRIDRECORDITEM_ARGS, XTP_TAGCLOUDTAG
  • rcOrigin : CXTPTrackControl::DRAGBLOCK
  • rcPopup : CXTPPopupControl::POPUPSTATE
  • rcTrack : XTP_SCROLLBAR_TRACKINFO
  • rcVal : CXTPSkinManagerSchemaProperty
  • Read() : CXTPImageList, CXTPPropExchange, CXTPPropExchangeArchive
  • ReadCount() : CXTPPropExchange, CXTPPropExchangeArchive
  • ReadList() : CXTPRecentFileList
  • ReadOleDateTime() : CXTPDateEdit
  • ReadProperties() : CXTPSkinManagerSchema
  • ReadRegistryValues() : CXTPSyntaxEditPropertiesPageEdit, CXTPSyntaxEditPropertiesPageFont
  • ReadSkinData() : CXTPSkinManager
  • ReadString() : CXTPMemFile, CXTPSkinManagerResourceFile
  • RebuildControls() : CXTPRibbonBar
  • ReBuildInternalData() : CXTPCalendarResourcesNf
  • Recalc() : CXTPGridControl
  • RecalcConnectionLayout() : CXTPFlowGraphPaintManager
  • RecalcFrameLayout() : CXTPCommandBars, CXTPCommandBarsFrameHook, CXTPDockingPaneManager
  • RecalcFramesLayout() : CXTPDockingPaneManager
  • RecalcHorzScrollPos() : CXTPSyntaxEditCtrl
  • RecalcLayout() : CXTPCaptionPopupWnd, CXTPEditListBox, CXTPExcelTabCtrl, CXTPFlowGraphConnection, CXTPHeaderCtrl, CXTPMDIWndTab, CXTPMessageBar, CXTPShortcutBarPane, CXTPSplitterWndEx, CXTPStatusBar, CXTPTabExBase, CXTPTagCloudCtrl, CXTPTrackControlItem
  • RecalcRowHeight() : CXTPSyntaxEditDrawTextProcessor
  • RecalcScrollBars() : CXTPSyntaxEditCtrl
  • RecalcSize() : CXTPPageScroller
  • RecalcTotalHightOfMergedRows() : CXTPGridPaintManager
  • RecalcVertScrollPos() : CXTPSyntaxEditCtrl
  • RecalLayout() : CXTPFlowGraphNode
  • ReclaimList() : CXTPOpenGLListPool
  • ReCreateProvider() : CXTPWebBrowserCtrl
  • rect : CXTPColorSelectorCtrl::COLOR_CELL
  • Rectangle() : CXTPDockingPanePaintManager, CXTPPaintManager, CXTPShortcutBarOffice2000Theme, CXTPShortcutBarPaintManager, CXTPTabColorSetOffice2003, CXTPTaskPanelPaintManager
  • rectDefault : CXTPTaskPanelPaintManager
  • RedMask : CXTPChartColor
  • Redo() : CXTPCalendarView, CXTPFlowGraphUndoManager, CXTPResourceManager::CManageState, CXTPSyntaxEditCtrl, CXTPTrackUndoManager
  • Redraw() : CXTPCalendarCaptionBarTheme, CXTPCalendarCaptionBarThemePart, CXTPCommandBar, CXTPStatusBarPane, CXTPTaskPanel
  • RedrawAllControls() : CXTPSkinManager
  • RedrawButton() : CXTPButton
  • RedrawComboBox() : CXTPComboBox
  • RedrawCommandBars() : CXTPCommandBars
  • RedrawControl() : CXTPCalendarControl, CXTPCalendarView, CXTPControlTabWorkspace, CXTPDatePickerControl, CXTPDockingPaneTabbedContainer, CXTPFlowGraphControl, CXTPGridControl, CXTPPopupControl, CXTPPopupItem, CXTPPropertyGrid, CXTPRibbonControlTab, CXTPShortcutBar, CXTPTabControl, CXTPTabManager, CXTPTabToolBar, CXTPTrackControlItem
  • RedrawControls() : CXTPControlAction
  • RedrawEdit() : CXTPEdit
  • RedrawFocusedFrame() : CXTPComboBox, CXTPEdit, CXTPEditTheme, CXTPEditThemeOffice2000, CXTPEditThemeOfficeXP
  • RedrawFrame() : CXTPCommandBarsFrameHook
  • RedrawItem() : CXTPPropertyGridItem
  • RedrawLB() : CXTPCalendarEventCategoryComboBox
  • RedrawLineMarks() : CXTPSyntaxEditCtrl
  • RedrawMenuTitleBar() : CXTPCommandBarsFrameHook
  • RedrawPane() : CXTPDockingPaneBase, CXTPDockingPaneMiniWnd
  • RedrawPanel() : CXTPTaskPanelItem
  • RedrawPanes() : CXTPDockingPaneManager
  • RedrawParent() : CXTPControl
  • RedrawProgress() : CXTPControlProgress, CXTPProgressBase, CXTPStatusBarProgressPane
  • RedrawRibbonBar() : CXTPCommandBarsFrameHook
  • RedrawScrollBar() : CXTPScrollBase, CXTPSkinObjectFrame
  • RedShift : CXTPChartColor
  • RefeshBindings() : CXTPPropertyGrid
  • Refresh() : CXTPImageManagerIcon, CXTPPropertyGrid, CXTPPropertyGridView, CXTPSyntaxEditColorSampleText, CXTPSyntaxEditView, CXTPTabClientWnd
  • RefreshActiveSel() : CXTPMDIWndTab
  • RefreshAll() : CXTPImageManager, CXTPImageManagerIconSet
  • RefreshButton() : CXTPCaption
  • RefreshCaptionBar() : CXTPCalendarControl
  • RefreshChildIndices() : CXTPGridRows
  • RefreshColors() : CXTPColorManager, CXTPColorSetStateButton, CXTPColorSetStateCheckBox, CXTPColorSetStateCheckMark, CXTPColorSetStateComboBox, CXTPColorSetStateMenu, CXTPColorSetStateRibbon, CXTPColorSetStateToolbar, CXTPSyntaxEditCtrl
  • RefreshCursor() : CXTPMouseManager
  • RefreshFiles() : CXTPSyntaxEditFileChangesMonitor
  • RefreshFolder() : CXTPDirWatcher
  • RefreshIndexes() : CXTPGridRecordItemControls, CXTPGridSection, CXTPGridSections, CXTPMDIWndTab
  • RefreshLineMarks() : CXTPSyntaxEditCtrl, CXTPSyntaxEditLineMarksManager
  • RefreshLunaColors() : CXTPColorManager
  • RefreshManagersArray() : CXTPDockingPaneAutoHidePanel
  • RefreshMenu() : CXTPMenuBar
  • RefreshMetrics() : CAppearanceSetPropertyPage2003, CAppearanceSetPropertyPage2007, CAppearanceSetPropertyPageAccess2007, CColorSetVisualStudio2003, CColorSetVisualStudio2005, CColorSetWinNative, CXTPButton, CXTPButtonTheme, CXTPButtonThemeNativeWindows10, CXTPButtonThemeNativeWindows11, CXTPButtonThemeOffice2003, CXTPButtonThemeOffice2013, CXTPButtonThemeOfficeXP, CXTPButtonThemeResource, CXTPButtonThemeUltraFlat, CXTPButtonThemeVisualStudio2012, CXTPButtonThemeVisualStudio2015, CXTPButtonThemeVisualStudio2017, CXTPButtonThemeVisualStudio2019, CXTPButtonThemeVisualStudio2022, CXTPCalendarCaptionBarOffice2000Theme, CXTPCalendarCaptionBarOffice2013Theme, CXTPCalendarCaptionBarOfficeXPTheme, CXTPCalendarCaptionBarPaintManager, CXTPCalendarCaptionBarResourceTheme, CXTPCalendarCaptionBarTheme, CXTPCalendarCaptionBarThemePart, CXTPCalendarOffice2003Theme, CXTPCalendarOffice2013Theme, CXTPCalendarPaintManager, CXTPCalendarResourceTheme, CXTPCalendarTimeLineView, CXTPCalendarTimeLineViewTimeScalePart, CXTPCalendarViewPart, CXTPCaption, CXTPCaptionTheme, CXTPCheckboxButtonPart, CXTPColorSelectorCtrl, CXTPColorSelectorCtrlTheme, CXTPColorSelectorCtrlThemeOffice2003, CXTPColorSelectorCtrlThemeOffice2013, CXTPColorSelectorCtrlThemeOfficeXP, CXTPColorSelectorCtrlThemeResource, CXTPColorSelectorCtrlThemeVisualStudio2015, CXTPColorSetCaptionButton, CXTPComboBox, CXTPComboBoxTheme, CXTPComboBoxThemeDefault, CXTPComboBoxThemeNativeWindows10, CXTPComboBoxThemeNativeWindows11, CXTPComboBoxThemeOffice2000, CXTPComboBoxThemeOffice2003, CXTPComboBoxThemeOffice2013, CXTPComboBoxThemeOfficeXPFlat, CXTPComboBoxThemeResource, CXTPComboBoxThemeVisualStudio2010, CXTPComboBoxThemeVisualStudio2012, CXTPComboBoxThemeVisualStudio2015, CXTPComboBoxThemeVisualStudio2017, CXTPComboBoxThemeVisualStudio2019, CXTPComboBoxThemeVisualStudio2022, CXTPComboBoxThemeVisualStudio, CXTPCommandBarsModernUITheme, CXTPCommandBarsNativeWindows11Theme, CXTPCommandBarsNativeXPTheme, CXTPCommandBarsOffice2000Theme, CXTPCommandBarsOffice2003Theme, CXTPCommandBarsOffice2013Theme, CXTPCommandBarsVisualStudio2012Theme, CXTPControlGalleryOffice2013Theme, CXTPControlGalleryPaintManager, CXTPControlGalleryResourceTheme, CXTPDateLabelPart, CXTPDatePickerPaintManager, CXTPDatePickerThemeOffice2003, CXTPDatePickerThemeOffice2013, CXTPDatePickerThemeResource, CXTPDeviceCaps, CXTPDockingPaneColorSet2012, CXTPDockingPaneColorSet2013, CXTPDockingPaneColorSet2015, CXTPDockingPaneColorSet2017, CXTPDockingPaneColorSet2019, CXTPDockingPaneColorSet2022, CXTPDockingPaneColorSet, CXTPDockingPaneColorSetNativeWindows10, CXTPDockingPaneColorSetNativeWindows11, CXTPDockingPaneDefaultTheme, CXTPDockingPaneGripperedTheme, CXTPDockingPaneNativeWindows10Theme, CXTPDockingPaneNativeWindows11Theme, CXTPDockingPaneOffice2002VisioTheme, CXTPDockingPaneOffice2003OutlookTheme, CXTPDockingPaneOffice2003Theme, CXTPDockingPaneOffice2007OutlookTheme, CXTPDockingPaneOffice2007Theme, CXTPDockingPaneOffice2007WordTheme, CXTPDockingPaneOffice2013Theme, CXTPDockingPanePaintManager, CXTPDockingPanePanelColorSet2012, CXTPDockingPanePanelColorSet2013, CXTPDockingPanePanelColorSet2015, CXTPDockingPanePanelColorSet2017, CXTPDockingPanePanelColorSet2019, CXTPDockingPanePanelColorSet2022, CXTPDockingPanePanelColorSetNativeWindows10, CXTPDockingPanePanelColorSetNativeWindows11, CXTPDockingPanePanelTheme2012, CXTPDockingPaneTabColorSet2012, CXTPDockingPaneTabColorSet2013, CXTPDockingPaneTabColorSetOfficePanel, CXTPDockingPaneTabColorSetVisualStudio2003, CXTPDockingPaneTabColorSetVisualStudio2005, CXTPDockingPaneTabTheme2012, CXTPDockingPaneTabTheme2013, CXTPDockingPaneVisualStudio2003Theme, CXTPDockingPaneVisualStudio2005Beta1Theme, CXTPDockingPaneVisualStudio2005Beta2Theme, CXTPDockingPaneVisualStudio2008Theme, CXTPDockingPaneVisualStudio2010Theme, CXTPDockingPaneVisualStudio2012Theme, CXTPDockingPaneVisualStudio2015Theme, CXTPDockingPaneVisualStudio2017Theme, CXTPDockingPaneVisualStudio2019Theme, CXTPDockingPaneVisualStudio2022Theme, CXTPDockingPaneWinExplorerTheme, CXTPDockingPaneWinNativeTheme, CXTPEdit, CXTPEditListBox, CXTPEditTheme, CXTPEditThemeDefault, CXTPEditThemeFlat, CXTPEditThemeOffice2000, CXTPEditThemeOffice2003, CXTPEditThemeOffice2013, CXTPEditThemeOfficeXP, CXTPEditThemeResource, CXTPEditThemeUltraFlat, CXTPEditThemeVisualStudio2010, CXTPEditThemeVisualStudio2012, CXTPExcelTabCtrl, CXTPExcelTabCtrlTheme, CXTPExcelTabCtrlThemeOffice2003, CXTPExcelTabCtrlThemeOffice2013, CXTPExcelTabCtrlThemeOfficeXP, CXTPFlowGraphPaintManager, CXTPFramePaintManager, CXTPFrameThemeOffice2007System, CXTPGridPaintManager, CXTPGridThemeNativeWindows10, CXTPGridThemeNativeWindows11, CXTPGridThemeOffice2003Luna, CXTPGridThemeOffice2013, CXTPGridThemeResource, CXTPGridThemeVisualStudio2012Blue, CXTPGridThemeVisualStudio2012Dark, CXTPGridThemeVisualStudio2012Light, CXTPGridThemeVisualStudio2015, CXTPGridThemeVisualStudio2017, CXTPGridThemeVisualStudio2019, CXTPGridThemeVisualStudio2022, CXTPHeaderCtrl, CXTPHeaderCtrlTheme, CXTPHeaderCtrlThemeResource, CXTPListBase, CXTPListBox, CXTPListBoxTheme, CXTPListBoxThemeDefault, CXTPListBoxThemeOffice2003, CXTPListBoxThemeOffice2013, CXTPListBoxThemeOfficeXP, CXTPListBoxThemeResource, CXTPMarqueeCtrl, CXTPMarqueeCtrlPaintManager, CXTPMarqueeCtrlThemeFlat, CXTPMarqueeCtrlThemeOffice2000, CXTPMarqueeCtrlThemeOffice2003, CXTPMarqueeCtrlThemeOffice2013, CXTPMarqueeCtrlThemeOfficeXP, CXTPMarqueeCtrlThemeUltraFlat, CXTPMessageBarPaintManager, CXTPMessageBarThemeOffice2010, CXTPMessageBarThemeOffice2013, CXTPPaintManager, CXTPPopupPaintManager, CXTPPopupThemeMSN, CXTPPopupThemeOffice2000, CXTPPopupThemeOffice2003, CXTPPopupThemeOffice2013, CXTPPopupThemeOfficeXP, CXTPPopupThemeResource, CXTPProgressCtrl, CXTPProgressCtrlPaintManager, CXTPProgressCtrlThemeFlat, CXTPProgressCtrlThemeOffice2003, CXTPProgressCtrlThemeOffice2013, CXTPProgressCtrlThemeUltraFlat, CXTPProgressCtrlThemeVisualStudio2015, CXTPProgressPaintManager, CXTPProgressThemeOffice2013, CXTPPropertyGridCoolTheme, CXTPPropertyGridDelphiTheme, CXTPPropertyGridNativeWindows10Theme, CXTPPropertyGridNativeWindows11Theme, CXTPPropertyGridNativeXPTheme, CXTPPropertyGridOffice2003Theme, CXTPPropertyGridOffice2007Theme, CXTPPropertyGridOffice2013Theme, CXTPPropertyGridOfficeXPTheme, CXTPPropertyGridPaintManager, CXTPPropertyGridSimpleTheme, CXTPPropertyGridVisualStudio2005Theme, CXTPPropertyGridVisualStudio2010Theme, CXTPPropertyGridVisualStudio2012Theme, CXTPPropertyGridVisualStudio2015Theme, CXTPPropertyGridVisualStudio2017Theme, CXTPPropertyGridVisualStudio2019Theme, CXTPPropertyGridVisualStudio2022Theme, CXTPRadioButtonPart, CXTPReBarPaintManager< TBase >, CXTPResourceTheme, CXTPRibbonMarkupTheme, CXTPRibbonOffice2013Theme, CXTPRibbonPaintManager, CXTPRibbonTheme, CXTPRibbonThemeNativeWindows10, CXTPRibbonThemeNativeWindows11, CXTPRibbonThemeOffice2007System, CXTPRibbonThemeResource, CXTPScrollBarCtrl, CXTPScrollBarPaintManager, CXTPScrollBarThemeFlat, CXTPScrollBarThemeOffice2003, CXTPScrollBarThemeOffice2013, CXTPScrollBarThemeOfficeXP, CXTPScrollBarThemeUltraFlat, CXTPScrollBarThemeWindowsUx, CXTPShortcutBarNativeWindows10Theme, CXTPShortcutBarNativeWindows11Theme, CXTPShortcutBarNativeWinXPTheme, CXTPShortcutBarOffice2003Theme, CXTPShortcutBarOffice2013Theme, CXTPShortcutBarPaintManager, CXTPShortcutBarResourceTheme, CXTPShortcutBarVisualStudio2015Theme, CXTPShortcutBarVisualStudio2017Theme, CXTPShortcutBarVisualStudio2019Theme, CXTPShortcutBarVisualStudio2022Theme, CXTPShortcutListBox, CXTPShortcutListBoxTheme, CXTPShortcutListBoxThemeOffice2003, CXTPShortcutListBoxThemeOfficeXP, CXTPSkinManagerMetrics, CXTPSkinObject, CXTPSkinObjectDateTime, CXTPSkinObjectFrame, CXTPSkinObjectMonthCal, CXTPSliderPaintManager, CXTPSpinButtonCtrl, CXTPSplitterWnd, CXTPSplitterWndTheme, CXTPSplitterWndThemeOffice2003, CXTPSplitterWndThemeOffice2013, CXTPSplitterWndThemeOfficeXP, CXTPSplitterWndThemeResource, CXTPSplitterWndThemeVisualStudio2010, CXTPStatusBarThemeNativeWindows10, CXTPStatusBarThemeNativeWindows11, CXTPStatusBarThemeOffice2013, CXTPStatusBarThemeVisualStudio2015, CXTPStatusBarThemeVisualStudio2017, CXTPStatusBarThemeVisualStudio2019, CXTPStatusBarThemeVisualStudio2022, CXTPSwitchViewButtonPart, CXTPSyntaxEditAutoCompleteWnd, CXTPSyntaxEditPaintManager, CXTPSystemMetrics, CXTPTabBase, CXTPTabBaseTheme, CXTPTabBaseThemeOffice2003, CXTPTabBaseThemeOfficeXP, CXTPTabColorSetDefault, CXTPTabColorSetNativeWindows10, CXTPTabColorSetNativeWindows11, CXTPTabColorSetOffice2003, CXTPTabColorSetOffice2007, CXTPTabColorSetOffice2007Access, CXTPTabColorSetOffice2013, CXTPTabColorSetVisualStudio2008, CXTPTabColorSetVisualStudio2010, CXTPTabColorSetVisualStudio2012, CXTPTabColorSetVisualStudio2012Dark, CXTPTabColorSetVisualStudio2015, CXTPTabColorSetVisualStudio2017, CXTPTabColorSetVisualStudio2019, CXTPTabColorSetVisualStudio2022, CXTPTabPaintManager, CXTPTabPaintManagerColorSet, CXTPTabPaintManagerTheme, CXTPTabThemeNativeWindows10, CXTPTabThemeNativeWindows11, CXTPTabThemeOffice2000, CXTPTabThemeOffice2013, CXTPTabThemeVisualStudio2012, CXTPTabThemeVisualStudio2015, CXTPTabThemeVisualStudio2017, CXTPTabThemeVisualStudio2019, CXTPTabThemeVisualStudio2022, CXTPTaskButtonTheme, CXTPTaskPanelExplorerTheme, CXTPTaskPanelExplorerThemePlain, CXTPTaskPanelListViewOffice2003Theme, CXTPTaskPanelListViewOfficeXPTheme, CXTPTaskPanelListViewTheme, CXTPTaskPanelNativeWindows10Theme, CXTPTaskPanelNativeWindows11Theme, CXTPTaskPanelOffice2003Theme, CXTPTaskPanelOffice2003ThemePlain, CXTPTaskPanelOffice2013Theme, CXTPTaskPanelOfficeXPThemePlain, CXTPTaskPanelPaintManager, CXTPTaskPanelPaintManagerPlain, CXTPTaskPanelShortcutBarOffice2003Theme, CXTPTaskPanelShortcutBarOffice2007Theme, CXTPTaskPanelToolboxTheme, CXTPTaskPanelVisualStudio2005Theme, CXTPTaskPanelVisualStudio2010Theme, CXTPTaskPanelVisualStudio2012Theme, CXTPTaskPanelVisualStudio2015Theme, CXTPTaskPanelVisualStudio2017Theme, CXTPTaskPanelVisualStudio2019Theme, CXTPTaskPanelVisualStudio2022Theme, CXTPTrackPaintManager, CXTPTrackThemeNativeWindows10, CXTPTrackThemeNativeWindows11, CXTPTrackThemeOffice2003Luna, CXTPTrackThemeOffice2013, CXTPTrackThemeResource, CXTPTrackThemeVisualStudio2012Blue, CXTPTrackThemeVisualStudio2012Dark, CXTPTrackThemeVisualStudio2012Light, CXTPTrackThemeVisualStudio2015, CXTPTrackThemeVisualStudio2017, CXTPTrackThemeVisualStudio2019, CXTPTrackThemeVisualStudio2022, CXTPTreeOffice2013Theme, CXTPTreeTheme, CXTPTreeVisualStudio2012Theme, CXTPVisualStudio2005Theme, CXTPVisualStudio2008Theme, CXTPVisualStudio2010Theme
  • RefreshQuickAccessList() : CXTPRibbonCustomizeQuickAccessPage
  • RefreshRibbonList() : CXTPRibbonCustomizePage
  • RefreshRowColors() : CXTPShellListBase
  • RefreshScrollBarMetrics() : CXTPScrollBarContainer< Parent >
  • RefreshSettings() : CXTPShellSettings
  • RefreshStandardColors() : CXTPCommandBarsOffice2013Theme
  • RefreshSysButtons() : CXTPMenuBar
  • RefreshTabLabels() : CXTPMDIWndTab
  • RefreshToolBarButtons() : CXTPPropertyGrid
  • RefreshTree() : CXTPDirWatcher
  • RegisterCustomMarkupProperties() : CXTPFlowGraphControl
  • RegisterWindowClass() : CXTPCalendarCaptionBarControl, CXTPCalendarControl, CXTPCaptionPopupWnd, CXTPChartControl, CXTPDatePickerControl, CXTPFlowGraphControl, CXTPGaugeCtrl, CXTPGridControl, CXTPPreviewCtrl, CXTPPropertyGrid, CXTPShortcutBar, CXTPSyntaxEditAutoCompleteWnd, CXTPSyntaxEditCtrl, CXTPSyntaxEditTipWnd, CXTPTagCloudCtrl, CXTPTaskPanel, CXTPTrackControl, CXTPWebBrowserCtrl
  • RelayToolTipEvent() : CXTPGridControl
  • Release() : CXTPActiveScriptObjectContext, CXTPChartDiagram, CXTPChartElement, CXTPChartElementCollection, CXTPChartFillStyle, CXTPChartFont, CXTPChartLineStyle, CXTPChartSeries
  • ReleaseArchive() : CXTPPropExchange, CXTPPropExchangeArchive
  • ReleaseInstance() : CXTPPaintManager
  • ReleaseItem() : CXTPGridControl
  • ReleaseSorted() : CXTPGridControl
  • ReloadConfig() : CXTPSyntaxEditConfigurationManager
  • ReloadConfigAsync() : CXTPSyntaxEditConfigurationManager
  • ReloadFile() : CXTPSyntaxEditColorThemesManager, CXTPSyntaxEditConfigurationManager, CXTPSyntaxEditTextSchemesManager
  • ReloadList() : CXTPCustomizeKeyboardPage
  • ReloadMarkupParts() : CXTPRibbonMarkupFrameTheme
  • ReloadSyntaxConfigFileMode() : CXTPSyntaxEditCtrl
  • ReloadSyntaxStringMode() : CXTPSyntaxEditCtrl
  • Remove() : CXTPCalendarData::EventsMapByID_T< _TObject >, CXTPCalendarPtrCollectionT< _TObject >, CXTPCalendarViewEvents, CXTPChartElementCollection, CXTPCommandBarList, CXTPCommandBars, CXTPControlActions, CXTPControlGalleryItems, CXTPControls, CXTPDatePickerDaysCollection, CXTPFlowGraphConnection, CXTPFlowGraphConnectionPoints, CXTPFlowGraphConnections, CXTPFlowGraphImages, CXTPFlowGraphNode, CXTPFlowGraphNodeGroup, CXTPFlowGraphNodeGroups, CXTPFlowGraphNodes, CXTPFlowGraphPage, CXTPFlowGraphPages, CXTPFlowGraphSelectedElements, CXTPGridColumnOrder, CXTPGridColumns, CXTPGridSelectedRows, CXTPImageList, CXTPPropertyGridInplaceButtons, CXTPPropertyGridItem, CXTPRecentFileList, CXTPRibbonGroup, CXTPRibbonGroups, CXTPRibbonQuickAccessControls, CXTPSkinManager, CXTPStatusBarPane, CXTPTabManagerItem, CXTPTaskPanelItem, CXTPTaskPanelItems, CXTPTrackBlock, CXTPTrackControlItem, CXTPTrackMarker, CXTPTrackMarkers, CXTPTrackSelectedBlocks
  • RemoveAll() : CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE >, CXTPCalendarCustomProperties, CXTPCalendarData::EventsMapByID_T< _TObject >, CXTPCalendarEvents, CXTPCalendarPtrCollectionT< _TObject >, CXTPCalendarRemindersManager, CXTPCalendarResourcesManager, CXTPCalendarTypedPtrAutoDeleteArray< BASE_CLASS, PTR_TYPE >, CXTPCalendarTypedPtrAutoDeleteMap< KEY, TPtr >, CXTPChartElementCollection, CXTPCommandBarList, CXTPCommandBars, CXTPControlActions, CXTPControlGalleryItems, CXTPControls, CXTPFlowGraphConnectionPoints, CXTPFlowGraphConnections, CXTPFlowGraphImages, CXTPFlowGraphNodeGroup, CXTPFlowGraphNodeGroups, CXTPFlowGraphNodes, CXTPFlowGraphPages, CXTPGridHyperlinks, CXTPGridRecord, CXTPGridRecordItemConstraints, CXTPGridRecordItemControls, CXTPGridRecords, CXTPHookManager, CXTPImageManager, CXTPImageManagerIconSet, CXTPImageManagerImageList, CXTPNotifyConnection, CXTPPropertyGridInplaceButtons, CXTPPropertyGridInplaceControls, CXTPPropertyGridItemConstraints, CXTPPropertyGridVerbs, CXTPResourceImages, CXTPRibbonGroup, CXTPRibbonGroups, CXTPShortcutManagerAccelTable, CXTPSkinImages, CXTPSkinManager, CXTPSkinObjectClassMap, CXTPStatusBar, CXTPStatusBarSwitchPane, CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager::CStringPtrArray, CXTPSyntaxEditColorInfoArray, CXTPSyntaxEditColorThemesManager, CXTPSyntaxEditLexTextSchema, CXTPSyntaxEditLineMarksManager, CXTPSyntaxEditTextSchemesManager, CXTPTabManagerNavigateButtons, CXTPTagCloudCtrl, CXTPTagCloudStyleManager, CXTPTrackControlItem, CXTPTrackMarkers, CXTPTrackSelectedBlocks
  • RemoveAllControls() : CXTPResize
  • RemoveAllEvents() : CXTPCalendarData
  • RemoveAllExceptions() : CXTPCalendarRecurrencePattern
  • RemoveAllInternal() : CXTPTagCloudCtrl
  • RemoveAllItems() : CXTPPopupControl, CXTPShortcutBar
  • RemoveAllStrs() : CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager
  • RemoveAllTabs() : CXTPRibbonBar, CXTPTabExBase
  • RemoveAnimationIcons() : CXTPTrayIcon
  • RemoveAt() : CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE >, CXTPCalendarEvents, CXTPCalendarPtrCollectionT< _TObject >, CXTPChartElementCollection, CXTPFlowGraphConnectionPoints, CXTPFlowGraphConnections, CXTPFlowGraphImages, CXTPFlowGraphNodes, CXTPFlowGraphPages, CXTPFlowGraphSelectedElements, CXTPGridColumnOrder, CXTPGridHyperlinks, CXTPGridRecordItemControls, CXTPGridRecords, CXTPGridRows, CXTPPropertyGridInplaceButtons, CXTPPropertyGridItemConstraints, CXTPPropertyGridItems, CXTPRibbonGroup, CXTPShortcutManagerAccelTable, CXTPStatusBar, CXTPTabManagerNavigateButtons, CXTPTaskPanelItems, CXTPTrackControlItem, CXTPTrackMarkers, CXTPTrackSelectedBlocks
  • RemoveButtons() : CXTPGridRecordItemEditOptions, CXTPMessageBar, CXTPPropertySheet
  • RemoveByID() : CXTPCalendarEvents
  • RemoveClass() : CXTPSkinObjectClassMap
  • RemoveClientInterface() : CXTPWebBrowserProvider
  • RemoveColorFilters() : CXTPSkinManager
  • RemoveControl() : CXTPControlAction
  • RemoveCustomScriptItem() : CXTPMarkupContext
  • RemoveDataForEvent() : CXTPCalendarReminders
  • RemoveDataProvider() : CXTPCalendarResourcesManager
  • RemoveDataSource() : CXTPGridDataManager
  • RemoveElement() : CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE >
  • RemoveException() : CXTPCalendarRecurrencePattern
  • RemoveFormatPart() : CXTPCalendarUtils
  • RemoveHook() : CXTPHookManager
  • RemoveHyperlinkAt() : CXTPGridRecordItem
  • RemoveIcon() : CXTPImageManager, CXTPTrayIcon
  • RemoveID() : CXTPCalendarUIntArray
  • RemoveIndicator() : CXTPStatusBar
  • RemoveItem() : CXTPPopupControl, CXTPShortcutBar
  • RemoveKey() : CXTPCalendarTypedPtrAutoDeleteMap< KEY, TPtr >
  • RemoveLine() : CXTPSyntaxEditBufferManager
  • RemoveListener() : CXTPColorSelectorCtrl
  • RemoveListItem() : CXTPTabExBase
  • RemoveMarkupTableRow() : CXTPFlowGraphNode
  • RemoveNode() : CXTPFlowGraphNodeGroup
  • RemoveNonNumeric() : CXTPSortClass
  • RemovePage() : CXTPPropertySheet
  • RemovePane() : CXTPDockingPaneAutoHidePanel, CXTPDockingPaneBase, CXTPDockingPaneMiniWnd, CXTPDockingPaneSplitterContainer
  • RemoveProperty() : CXTPCalendarCustomProperties
  • RemoveRecord() : CXTPGridRecords
  • RemoveRecordEx() : CXTPGridControl
  • RemoveRecurrence() : CXTPCalendarEvent
  • RemoveResize() : CXTPResize
  • RemoveResource() : CXTPCalendarResourcesManager
  • RemoveRow() : CXTPGridRows, CXTPSyntaxEditCtrl
  • RemoveRowColors() : CXTPListBase
  • RemoveRowEx() : CXTPGridControl
  • RemoveSchedule() : CXTPCalendarSchedules
  • RemoveSelected() : CXTPMouseManager
  • RemoveShadow() : CXTPShadowManager
  • RemoveStr() : CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager
  • RemoveStyle() : CXTPTagCloudStyleManager
  • RemoveSwitch() : CXTPStatusBarSwitchPane
  • RemoveTab() : CXTPRibbonBar
  • RemoveTag() : CXTPTagCloudCtrl
  • RemoveTrack() : CXTPMouseManager
  • RemoveTrustedWindow() : CXTPMouseManager
  • RenameConnectionPoint() : CXTPFlowGraphControl
  • RenameItem() : CXTPTaskPanel
  • RenameNode() : CXTPFlowGraphControl
  • Render() : CXTPMarkupVisual
  • RenderClipped() : CXTPMarkupVisual
  • RenderMarkup() : CXTPMarkupThemePart, CXTPRibbonMarkupTheme
  • ReOpen() : CXTPSyntaxEditDoc
  • ReOrder() : CXTPTabManager
  • Replace() : CXTPImageList
  • ReplaceAll() : CXTPSyntaxEditCtrl
  • ReplaceSel() : CXTPSyntaxEditCtrl
  • ReplaceView() : CXTPSplitterWnd
  • ReportError() : CXTPHyperLink
  • Reposition() : CXTPControlGallery, CXTPDockingPaneTabbedContainer, CXTPDockingPaneWindowSelect, CXTPFlowGraphControl, CXTPFlowGraphPage, CXTPPropertyGrid, CXTPRibbonControlTab, CXTPShortcutBar, CXTPTabClientWnd, CXTPTabControl, CXTPTabManagerAtom, CXTPTabManagerItem, CXTPTabManagerNavigateButton, CXTPTabToolBar, CXTPTaskPanel
  • RepositionBars() : CXTPSyntaxEditCtrl
  • RepositionControls() : CXTPControlAction, CXTPRibbonGroup
  • RepositionNavigateButtons() : CXTPTabPaintManager
  • RepositionPanel() : CXTPTaskPanelItem
  • RepositionScrollButtons() : CXTPTaskPanel
  • RepositionTabControl() : CAppearanceSetVisio, CXTPTabPaintManager, CXTPTabPaintManagerTheme
  • RepositionTabControlEx() : CXTPTabPaintManager
  • RepositionTabControlMultiRow() : CXTPTabPaintManager
  • RequiresMouseWheelOverriding() : IXTPScrollable
  • RequiresResourceImages() : CXTPCommandBarsOffice2013Theme, CXTPCommandBarsVisualStudio2012Theme, CXTPPaintManager, CXTPResourceTheme
  • res : XTP_URI
  • ResampleAlphaLayer() : CXTPImageManager
  • reserved : XTP_URI
  • Reset() : CXTPControl, CXTPMenuBar, CXTPPreviewCtrl, CXTPResize, CXTPResourceImages, CXTPRibbonBar, CXTPRibbonQuickAccessControls, CXTPShortcutManager, CXTPSimpleEvent, CXTPTabToolBar, CXTPThemeDLL, CXTPThreadLocal< T >, CXTPToolBar
  • Reset_disp() : CXTPSyntaxEditSelection
  • Reset_str() : CXTPSyntaxEditSelection
  • ResetBackColor() : CXTPComboBoxTheme
  • ResetContent() : CXTPControlComboBox, CXTPGridControl, CXTPGridSection, CXTPPropertyGrid, CXTPPropertyGridView, CXTPTaskDialog
  • ResetCustomTimeFormat() : CXTPCalendarDayViewTimeScale, CXTPCalendarView
  • ResetDate() : CXTPCalendarUtils
  • ResetMarkupUIElement() : CXTPGridColumn, CXTPGridGroupRow, CXTPGridRecordItem
  • ResetMouseOver() : CXTPExcelTabCtrl
  • ResetParent() : CXTPCaptionPopupWnd
  • ResetRecentColors() : CXTPColorSelectorCtrl
  • ResetRowInfo() : CXTPSyntaxEditDrawTextProcessor
  • ResetSavedCameraState() : CXTPChart3dDeviceContext
  • ResetSelection() : CXTPCalendarView
  • ResetSortOrder() : CXTPGridColumns
  • ResetTextColor() : CXTPComboBoxTheme
  • ResetTime() : CXTPCalendarUtils
  • ResetTimeProvider() : CXTPCalendarUtils
  • ResetTodayDateOverride() : CXTPCalendarControl
  • ResetToolTips() : CXTPTabExBase
  • ResetUsageData() : CXTPCommandBars
  • ResetValue() : CXTPPropertyGridItem
  • Resize() : CXTPDockContext
  • ResizeColumn() : CXTPGridHeader
  • ResizeColumnsToFit() : CXTPHeaderCtrl
  • ResizeTabView() : CXTPTabExBase
  • ResolveOverlapping() : CXTPChart3dFunnelSeriesLabelsView, CXTPChart3dPieSeriesLabelsView, CXTPChart3dPyramidSeriesLabelsView, CXTPChartPieSeriesLabelsView, CXTPChartPieSeriesLabelsViewBase
  • ResolveOverlappingColumn() : CXTPChartPieSeriesLabelsView
  • ReSortRows() : CXTPGridControl, CXTPGridSection, CXTPGridSections
  • RestoreAndMinimize() : CXTPWindowList
  • RestoreCommandBarList() : CXTPCommandBar, CXTPControl, CXTPControlPopup, CXTPMenuBar
  • RestoreConnection() : CXTPFlowGraphConnection
  • RestoreCursor() : CXTPSyntaxEditCtrl
  • RestoreDefaultFont() : CXTPHexEdit
  • RestoreDefaults() : CXTPTagCloudCtrl
  • RestoreEventCategoryList() : CXTPCalendarData
  • RestoreEventLabelList() : CXTPCalendarData
  • RestoreRenderTransform() : CXTPMarkupUIElement, CXTPMarkupVisual
  • Resume() : CXTPSkinManager
  • RetrieveDayEvents() : CXTPCalendarData, CXTPCalendarResource, CXTPCalendarResources, CXTPCalendarView
  • RetrieveEvents() : CXTPCalendarMemoryDataProvider
  • RetriveEventEndDate() : CXTPCalendarUtils
  • RGBtoHex() : CXTPColorDialog
  • RGBtoHSL() : CXTPColorBase, CXTPColorPageCustom
  • RGBToString() : CXTPPropertyGridItemColor
  • right : XTP_RESIZERECT
  • roof : CXTPColorHex::CRgnCell::CTX_DATA::HEXAGON_DATA
  • Rotate() : CXTPChart3dDeviceContext, CXTPMatrix< T >, CXTPOpenGLUtils
  • RotateArcBallToPoint() : CXTPChart3dDiagram
  • Round() : CXTPMathUtils, CXTPPoint2T< T >, CXTPPoint3T< T >, CXTPRectT< T >
  • RoundRect() : CXTPPaintManager
  • RowColFromPoint() : CXTPSyntaxEditCtrl
  • Run() : CXTPActiveScriptEngine
  • RunParse() : CXTPSyntaxEditLexClass
  • RunParseOnScreen() : CXTPSyntaxEditLexTextSchema
  • RunParseUpdate() : CXTPSyntaxEditLexTextSchema
  • RunScriptEngine() : CXTPMarkupContext


Toolkit Pro: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- s -

  • s_bSendContextMenuForWholeHeaderArea : CXTPGridHeader
  • s_bShowItemsInGroupsPXDefault : CXTPGridHeader
  • s_bVarMapInitialized : CXTPSyntaxEditLexVariable
  • s_mapVar2ID : CXTPSyntaxEditLexVariable
  • s_nExpandDelay : CXTPCommandBar
  • s_nExpandHoverDelay : CXTPCommandBar
  • s_nHoverDelay : CXTPCommandBar
  • s_nMinAutoScrollStep : CXTPGridHeader
  • SafeClose() : CXTPCalendarData::CXTPDPCache
  • SafeRemoveAll() : CXTPCalendarData::CXTPDPCache
  • Save() : CXTPCalendarData, CXTPCalendarDatabaseDataProvider, CXTPCalendarMemoryDataProvider, CXTPCalendarReminderForOccurrenceArray, CXTPDockingPaneLayout, CXTPMemFile
  • SaveAsImage() : CXTPChartControl
  • SaveBarState() : CXTPCommandBars
  • SaveCfg() : CXTPCalendarResourcesManager
  • SaveColumnWidths() : CXTPListBase
  • SaveCommandBars() : CXTPCommandBarsSiteBase< TBase >
  • SaveHistory() : CXTPSyntaxEditFindReplaceDlg
  • SaveOptions() : CXTPCommandBars
  • SavePlacement() : CXTPPropertySheet, CXTPResize
  • SavePos() : CXTPSyntaxEditGoToLineDlg
  • SaveShortcuts() : CXTPShortcutManager
  • SaveState() : CXTPDockState, CXTPReBar, CXTPShortcutBar, CXTPStatusBar, CXTPTabClientWnd
  • SaveToFile() : CXTPDockingPaneLayout, CXTPFlowGraphControl, CXTPPropExchangeIniFile, CXTPPropExchangeXMLNode
  • SaveToNode() : CXTPDockingPaneLayout
  • SaveToString() : CXTPCalendarUIntArray
  • SaveToXML() : CXTPCalendarCustomProperties
  • SaveWindowPos() : CXTPWindowPos
  • Scale() : CXTPMarkupContext
  • ScalePoint() : CXTPDockState
  • ScaleRectPos() : CXTPDockState
  • ScaleToFit() : CXTPIconHandle, CXTPImageManagerIcon
  • ScaleX() : CXTPMarkupContext
  • ScaleY() : CXTPMarkupContext
  • ScoreExists() : CXTPTagCloudStyleManager
  • ScreenToClient() : CXTPControl
  • ScreenToPage() : CXTPFlowGraphPage
  • ScreenToWorkspace() : CXTPTabClientWnd
  • Scroll() : CXTPSyntaxEditCtrl, CXTPTaskPanelGroup
  • ScrollBarStyle : CXTPShellExplorerProvider
  • ScrollDaysToNext() : CXTPCalendarDayView
  • ScrollDaysToPrev() : CXTPCalendarDayView
  • ScrollDown() : CXTPDatePickerList
  • ScrollH() : CXTPCalendarDayView, CXTPCalendarTimeLineView, CXTPCalendarView
  • ScrollIcon_ScrollAllDayEventsDown() : CXTPCalendarDayViewGroup
  • ScrollIcon_ScrollAllDayEventsUp() : CXTPCalendarDayViewGroup
  • ScrollLeft() : CXTPDatePickerControl
  • ScrollRight() : CXTPDatePickerControl
  • ScrollToColumn() : CXTPCalendarDayView
  • ScrollToWorkDayBegin() : CXTPCalendarDayView
  • ScrollUp() : CXTPDatePickerList
  • ScrollV() : CXTPCalendarDayView, CXTPCalendarMonthView::CMonthViewGrid, CXTPCalendarMonthView, CXTPCalendarTimeLineView, CXTPCalendarView, CXTPCalendarWeekView
  • ScrollWindow() : CXTPSyntaxEditCtrl
  • ScrollWindowEx() : CXTPSyntaxEditCtrl
  • SearchTree() : CXTPShellTreeBase
  • SeekBegin() : CXTPSyntaxEditTextIterator
  • SeekNext() : CXTPSyntaxEditTextIterator
  • SeekPos() : CXTPSyntaxEditTextIterator
  • SeekPrev() : CXTPSyntaxEditTextIterator
  • SelChanged() : CXTPSyntaxEditTipListBox
  • Select() : CXTPDatePickerControl, CXTPDatePickerDaysCollection, CXTPDockingPane, CXTPDockingPaneWindowSelect, CXTPFlowGraphNode, CXTPGridSelectedRows, CXTPPropertyGridItem, CXTPSyntaxEditCtrl, CXTPTabManagerItem, CXTPTrackBlock
  • SelectAll() : CXTPFlowGraphControl, CXTPSyntaxEditCtrl, CXTPTreeBase
  • SelectAllIgnore() : CXTPTreeBase
  • SelectBlock() : CXTPGridSelectedRows
  • SelectChildren() : CXTPTreeBase
  • SelectChilds() : CXTPGridRow
  • SelectClipRgn() : CColorSetWinNative, CXTPTabPaintManagerColorSet
  • SelectColor() : CXTPColorSelectorCtrl
  • SelectColorCell() : CXTPColorSelectorCtrl
  • SelectConstraint() : CXTPPropertyGridInplaceEdit
  • SelectDay() : CXTPCalendarDayView, CXTPCalendarView
  • SelectDays() : CXTPCalendarView
  • SelectEvent() : CXTPCalendarView
  • SelectEventById() : CXTPCalendarControl
  • SelectionChanged() : CXTPShellTreeBase, CXTPShellTreeCtrl, CXTPShellTreeView
  • SelectionContains() : CXTPCalendarView
  • SelectionEnable() : CXTPGridSection
  • SelectItem() : CXTPShortcutBar, CXTPTreeBase
  • SelectItems() : CXTPTreeBase
  • SelectMDIActive() : CXTPWindowList
  • SelectNextConstraint() : CXTPPropertyGridItem
  • SelectNextTab() : CXTPRibbonBar
  • SelectPane() : CXTPDockingPaneTabbedContainer
  • SelectRange() : CXTPDatePickerDaysCollection
  • SelectUserColor() : CXTPSyntaxEditColorComboBox
  • SelectViewEvent() : CXTPCalendarView
  • SelectViewEventByIdAndGroup() : CXTPCalendarControl
  • SelectWord() : CXTPSyntaxEditCtrl
  • SendCancelMessage() : CXTPCaptionPopupWnd
  • SendCommand() : CXTPEditListBoxToolBar
  • SendEvent() : CXTPNotifyConnection
  • SendInitialUpdate() : CXTPTabExBase
  • SendMessageToParent() : CXTPDatePickerControl, CXTPGridControl, CXTPTrackControl
  • SendNotification() : CXTPCalendarControl, CXTPCalendarData, CXTPCalendarView, CXTPDatePickerControl
  • SendNotificationAlways() : CXTPCalendarControl
  • SendNotify() : CXTPHeaderCtrl, CXTPTreeBase
  • SendNotifyMessage() : CXTPFlowGraphControl, CXTPGridControl, CXTPPropertyGrid, CXTPPropertyGridView
  • SendTrackLost() : CXTPMouseManager
  • Serialize() : CXTPCalendarMemoryDataProvider, CXTPCalendarThemeCustomizableXValueT< _TValue, _TValueRef >, CXTPCalendarThemeFontValue, CXTPCommandBarsOptions, CXTPDockingPaneLayout, CXTPImageManager, CXTPImageManagerIcon, CXTPPaintManagerColor, CXTPPaintManagerColorGradient, CXTPSyntaxEditBufferManager
  • SerializeBarState() : CXTPCommandBars
  • SerializeEx() : CXTPSyntaxEditBufferManager
  • SerializeIcon() : CXTPImageManagerIcon
  • SerializeState() : CXTPGridControl
  • Set() : CXTPCalendarControlViewPrintOptions, CXTPGridThickness, CXTPGridViewPrintOptions, CXTPMatrix< T >, CXTPSimpleEvent, CXTPSyntaxEditTextRegion
  • Set3dRotation() : CXTPChartSeriesStyle
  • SetAccelerators() : CXTPShortcutManager
  • SetAction() : CXTPControl
  • SetActionId() : CXTPControlActions
  • SetActive() : CXTPSyntaxEditCtrl, CXTPTabManager, CXTPTagCloudCtrl
  • SetActivePage() : CXTPFlowGraphControl, CXTPPropertySheet
  • SetActivePane() : CXTPSplitterWnd
  • SetActiveTab() : CXTPRibbonBackstageView
  • SetActiveView() : CXTPCalendarControl, CXTPTabExBase
  • SetActiveWorkspace() : CXTPTabClientWnd
  • SetAdditionalScaleText() : CXTPCalendarDayView
  • SetAdditionalScaleTimeZone() : CXTPCalendarDayView
  • SetAddressBase() : CXTPHexEdit
  • SetAdvancedMode() : CXTPCalendarTip
  • SetAfterCloseActiveTab() : CXTPTabClientWnd
  • SetAlignment() : CXTPChartAxis, CXTPChartAxisConstantLine, CXTPChartAxisTitle, CXTPChartTitle, CXTPGridColumn, CXTPGridRecordItem, CXTPGridRecordItemControl, CXTPPropertyGridInplaceButton
  • SetAlingment() : CXTPHeaderCtrl
  • SetAllCaps() : CXTPCommandBars
  • SetAllDayEvent() : CXTPCalendarEvent
  • SetAllowDeletes() : CXTPHexEdit
  • SetAllowDrag() : CXTPGridColumn
  • SetAllowModifyConnections() : CXTPFlowGraphControl
  • SetAllowMoveNodes() : CXTPFlowGraphControl
  • SetAllowReorder() : CXTPTabClientWnd, CXTPTabManager
  • SetAllowResizeNodes() : CXTPFlowGraphControl
  • SetAlphaDockingContext() : CXTPDockingPaneManager
  • SetAlphaTabClientContext() : CXTPTabClientContext
  • SetAmbientProperty() : CXTPApplication
  • SetAngle() : CXTPChartAxisLabel, CXTPChartPointSeriesLabel, CXTPChartRadarPointSeriesLabel, CXTPMarkupRotateTransform
  • SetAngleX() : CXTPMarkupSkewTransform
  • SetAngleY() : CXTPMarkupSkewTransform
  • SetAnimateDelay() : CXTPPopupControl
  • SetAnimation() : CXTPTaskPanel
  • SetAnimationDelay() : CXTPDockingPaneManager, CXTPFlowGraphControl, CXTPPaintManager
  • SetAnimationIcons() : CXTPTrayIcon
  • SetAntialiasing() : CXTPChart3dDeviceContext, CXTPChartAxisConstantLine, CXTPChartAxisLabel, CXTPChartAxisTitle, CXTPChartFastLineSeriesStyle, CXTPChartLegend, CXTPChartSeriesLabel, CXTPChartTitle
  • SetAppCaption() : CXTPCaption
  • SetAppearance() : CXTPDockingPanePanelPaintManager, CXTPDockingPaneTabPaintManager, CXTPTabManager, CXTPTabPaintManager
  • SetAppearanceSet() : CXTPTabManager, CXTPTabPaintManager
  • SetApplyOptions() : CXTPSkinManager
  • SetArcBallBounds() : CXTPChart3dDiagram
  • SetArgumentScaleType() : CXTPChartSeries
  • SetArgumentValue() : CXTPChartSeriesPoint
  • SetArrangeEditCaption() : CXTPRibbonGroup
  • SetAskItemTextFlags() : CXTPCalendarPaintManager
  • SetAt() : CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE >, CXTPCalendarEvents, CXTPCalendarPtrCollectionT< _TObject >, CXTPCalendarTypedPtrAutoDeleteMap< KEY, TPtr >, CXTPGridRecords, CXTPMatrix< T >
  • SetAtGrow() : CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE >
  • SetAtGrowStr() : CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager
  • SetAttribute() : CXTPSyntaxEditLexClass
  • SetAttributes() : CXTPShellListBase, CXTPShellTreeBase
  • SetAutoApplyNewThreads() : CXTPSkinManager
  • SetAutoApplyNewWindows() : CXTPSkinManager
  • SetAutoCheckItems() : CXTPGridControl
  • SetAutoColor() : CXTPSyntaxEditColorComboBox
  • SetAutoColumnSizing() : CXTPGridHeader
  • SetAutoComplete() : CXTPPropertyGridItem
  • SetAutoCompleteList() : CXTPSyntaxEditCtrl
  • SetAutoCondense() : CXTPTabExBase
  • SetAutoDelete() : CXTPPopupControl
  • SetAutoFont() : CXTPListBase
  • SetAutoIndent() : CXTPSyntaxEditCtrl, CXTPSyntaxEditView
  • SetAutoPopup() : CXTPCalendarRemindersDialog
  • SetAutoRange() : CXTPChartAxisRange
  • SetAutoReload() : CXTPSyntaxEditDoc
  • SetAutoSize() : CXTPDatePickerControl, CXTPGridColumn, CXTPMessageBar
  • SetAutoSortWhenGrouped() : CXTPGridColumn
  • SetAutoTheme() : CXTPTabClientWnd
  • SetAutoVScrollTimerResolution() : CXTPGridControl
  • SetAxisMaxValue() : CXTPChartAxisStrip
  • SetAxisMinValue() : CXTPChartAxisStrip
  • SetAxisValue() : CXTPChartAxisConstantLine, CXTPChartAxisCustomLabel
  • SetBackColor() : CXTPChartSeriesLabel, CXTPComboBox, CXTPComboBoxTheme, CXTPHexEdit, CXTPHyperLink, CXTPMarqueeCtrlPaintManager, CXTPProgressCtrlPaintManager, CXTPSyntaxEditColorSampleText, CXTPSyntaxEditPaintManager, CXTPTagCloudCtrl, CXTPTaskDialogLinkCtrl
  • SetBackground() : CXTPMarkupBorder, CXTPMarkupControl, CXTPMarkupPanel, CXTPMarkupTextBlock
  • SetBackgroundBitmap() : CXTPPopupControl
  • SetBackgroundColor() : CXTPCalendarViewPart, CXTPChartContent, CXTPChartLegend, CXTPGridRecordItem, CXTPPreviewCtrl, CXTPStatusBarPane
  • SetBackImage() : CXTPRibbonOffice2013Theme
  • SetBackstageStyle() : CXTPRibbonBackstageView
  • SetBandInfo() : CXTPReBar
  • SetBandingHit() : CXTPTreeBase
  • SetBarColor() : CXTPMarqueeCtrlPaintManager, CXTPProgressCtrl, CXTPProgressCtrlPaintManager
  • SetBarID() : CXTPCommandBar
  • SetBarInfo() : CXTPToolBar
  • SetBarWidth() : CXTPChartBarSeriesStyle
  • SetBaseEdgeCount() : CXTPChart3dFunnelSeriesStyle, CXTPChart3dPyramidSeriesStyle
  • SetBasePoint() : CXTPChartRotatedTextPainterBase
  • SetBegin() : CXTPArcBall
  • SetBeginDate() : CXTPCalendarMonthView::CMonthViewGrid, CXTPCalendarWeekView
  • SetBeginGroup() : CXTPControl, CXTPStatusBarPane
  • SetBehaviour() : CXTPTaskPanel
  • SetBestFitMode() : CXTPGridColumn
  • SetBitmap() : CXTPButton, CXTPFlowGraphImage, CXTPHeaderCtrl, CXTPHeaderCtrlTheme, CXTPResourceImage, CXTPSkinImage
  • SetBkBaseColor() : CXTPCalendarEventCategory
  • SetBkColor() : CXTPImageList, CXTPPageScroller, CXTPProgressCtrl
  • SetBlendingOptions() : CXTPFrameShadow
  • SetBody() : CXTPCalendarEvent
  • SetBold() : CXTPGridRecordItem, CXTPPopupItem, CXTPTaskPanelGroupItem
  • SetBoldDaysIdleStepTime_ms() : CXTPCalendarController
  • SetBoldDaysOnIdle() : CXTPCalendarController
  • SetBoldDaysPerIdleStep() : CXTPCalendarController
  • SetBoldDaysWithEvents() : CXTPCalendarController
  • SetBookmark() : CXTPGridRecord
  • SetBool() : CXTPPropertyGridItemBool
  • SetBorder() : CXTPPageScroller
  • SetBorderBrush() : CXTPMarkupBorder
  • SetBorderColor() : CXTPCalendarEventCategory, CXTPMarqueeCtrlPaintManager, CXTPProgressCtrl, CXTPProgressCtrlPaintManager, CXTPSyntaxEditColorSampleText, CXTPTagCloudCtrl
  • SetBorderGap() : CXTPButton, CXTPMDIClientWnd, CXTPMDIWndTab
  • SetBorders() : CXTPCalendarCaptionBarControl, CXTPCalendarControl, CXTPColorSelectorCtrl, CXTPControlCustom, CXTPPopupBar
  • SetBorderStyle() : CXTPButton, CXTPDatePickerControl, CXTPPropertyGrid
  • SetBorderThickness() : CXTPMarkupBorder
  • SetBottom() : CXTPGridThickness
  • SetBounds() : CXTPArcBall, CXTPChartDiagram2DAxisView, CXTPChartRadarAxisXView, CXTPChartRadarAxisYView
  • SetBPR() : CXTPHexEdit
  • SetBreakpointBackColor() : CXTPSyntaxEditPaintManager
  • SetBreakpointTextColor() : CXTPSyntaxEditPaintManager
  • SetBrowseStyle() : CXTPBrowseButton
  • SetBuddy() : CXTPButton
  • SetBusyStatus() : CXTPCalendarEvent
  • SetBusyStatusBrush() : CXTPCalendarPaintManager
  • SetButton() : CXTPPopupItem, CXTPStatusBarPane
  • SetButtonElevationRequired() : CXTPTaskDialog
  • SetButtonFont() : CXTPDatePickerPaintManager
  • SetButtonFontIndirect() : CXTPDatePickerPaintManager
  • SetButtonRect() : CXTPDatePickerControl
  • SetButtons() : CXTPCommandBar, CXTPRibbonGroup
  • SetButtonSize() : CXTPCommandBar, CXTPPageScroller
  • SetButtonsVisible() : CXTPDatePickerControl
  • SetButtonText() : CXTPCalendarCaptionBarControl
  • SetButtonTheme() : CXTPEditListBoxToolBar
  • SetCacheMode() : CXTPCalendarData
  • SetCalendar() : CXTPCalendarController
  • SetCalendarCtrl() : CXTPCalendarControlView
  • SetCallback() : CXTPBrowseDialog
  • SetCallbackDayMetrics() : CXTPDatePickerControl
  • SetCallbackMessage() : CXTPTrayIcon
  • SetCanEditCheckboxItem() : CXTPGridRecordItem
  • SetCaption() : CXTPCalendarDayViewTimeScale, CXTPCaptionButton, CXTPControl, CXTPControlAction, CXTPControlGalleryItem, CXTPDatePickerButton, CXTPDialogBar, CXTPFlowGraphConnection, CXTPFlowGraphConnectionPoint, CXTPFlowGraphElement, CXTPFlowGraphNode, CXTPFlowGraphNodeGroup, CXTPFlowGraphPage, CXTPGridColumn, CXTPGridGroupRow, CXTPGridRecordItem, CXTPGridRecordItemControl, CXTPGridRecordItemPreview, CXTPPopupItem, CXTPPropertyGridInplaceButton, CXTPPropertyGridItem, CXTPPropertyPage, CXTPRibbonGroup, CXTPShortcutBarItem, CXTPShortcutBarPane, CXTPShortcutBarPaneItem, CXTPStatusBarPane, CXTPTabManagerItem, CXTPTaskPanelItem, CXTPTrackBlock, CXTPTrackMarker
  • SetCaptionButtonStyle() : CXTPDockingPanePaintManager
  • SetCaptionColor() : CXTPGridRecordItemControl
  • SetCaptionColors() : CXTPCaption
  • SetCaptionDirection() : CXTPDockingPaneManager
  • SetCaptionFont() : CXTPGridPaintManager
  • SetCaptionFontIndirect() : CXTPDockingPanePaintManager, CXTPTaskPanelPaintManager
  • SetCaptionPopup() : CXTPDialogBar
  • SetCaptionPosition() : CXTPFlowGraphNodeCustom
  • SetCaptionVisible() : CXTPDialogBar
  • SetCapture() : CXTPChartContainer, CXTPChartControl
  • SetCaretByPoint() : CXTPSyntaxEditDrawTextProcessor
  • SetCaretPos() : CXTPSyntaxEditDrawTextProcessor
  • SetCaseSensitive() : CXTPGridRecords
  • SetCategory() : CXTPChartNumberFormat, CXTPControl, CXTPControlAction
  • SetCellFormula() : CXTPGridControl
  • SetCellText() : CXTPGridControl
  • SetCenterX() : CXTPMarkupRotateTransform, CXTPMarkupScaleTransform, CXTPMarkupSkewTransform
  • SetCenterY() : CXTPMarkupRotateTransform, CXTPMarkupScaleTransform, CXTPMarkupSkewTransform
  • SetChanged() : CXTPGridControl, CXTPGridSelectedRows
  • SetCharFormat() : CXTPControlFontComboBox
  • SetCheck() : CXTPCalendarCaptionBarThemePart, CXTPCheckListBox
  • SetCheckBoxStyle() : CXTPPropertyGridItemBool, CXTPPropertyGridItemOption
  • SetChecked() : CXTPButton, CXTPControl, CXTPControlAction, CXTPGridRecordItem, CXTPMarkupToggleButton, CXTPStatusBarPane, CXTPStatusBarSwitchPane
  • SetCheckedIcon() : CXTPImageManagerIcon
  • SetCheckedItem() : CXTPControlGallery
  • SetCheckedState() : CXTPGridRecordItem
  • SetCheckStyle() : CXTPCheckListBox
  • SetChild() : CXTPDialogBar, CXTPMarkupDecorator, CXTPPageScroller
  • SetChildWindow() : CXTPCaption
  • SetCilentSite() : CXTPGaugeCtrl
  • SetClientBitmap() : CXTPTaskPanelGroup
  • SetClientInterface() : CXTPWebBrowserProvider
  • SetClientMargin() : CXTPDockingPaneManager
  • SetClientMargins() : CXTPDockingPaneManager
  • SetClientPaneVisible() : CXTPShortcutBar
  • SetClientSite() : CXTPMarkupContext
  • SetClientWindow() : CXTPShortcutBarItem
  • SetClipboard() : CXTPEyeDropper
  • SetClipboardText() : CXTPEyeDropper
  • SetClipOwner() : CXTPFrameShadow
  • SetClipToBounds() : CXTPMarkupFrameworkElement
  • SetClosable() : CXTPTabManagerItem
  • SetCloseable() : CXTPToolBar
  • SetCloseSubMenuOnClick() : CXTPControl
  • SetCloseTags() : CXTPSyntaxEditAutoCompleteWnd
  • SetColHeaderHeight() : CXTPCalendarMonthView::CMonthViewGrid
  • SetCollapsedControlText() : CXTPTaskDialog
  • SetCollapseRect() : CXTPGridRow
  • SetCollapsibleNodes() : CXTPSyntaxEditCtrl
  • SetColor() : CXTPCalendarResource, CXTPChartAxis, CXTPChartAxisStrip, CXTPChartSeriesStyle, CXTPColorLum, CXTPColorManager, CXTPColorPageStandard, CXTPColorPicker, CXTPColorWnd, CXTPControlButtonColor, CXTPControlColorSelector, CXTPControlPopupColor, CXTPDockingPanePanelPaintManager, CXTPDockingPaneTabPaintManager, CXTPFlowGraphConnection, CXTPFlowGraphConnectionPoint, CXTPFlowGraphNode, CXTPFlowGraphNodeCustom, CXTPFrameShadow, CXTPGridHyperlinkStyle, CXTPPropertyGridItemColor, CXTPPropertyGridItemFont, CXTPTabManager, CXTPTabManagerItem, CXTPTabPaintManager, CXTPTrackBlock
  • SetColor2() : CXTPChartAxisStrip
  • SetColorEach() : CXTPChartSeriesStyle
  • SetColors() : CXTPColorManager, CXTPColorPicker, CXTPColorSelectorCtrl, CXTPDockingPanePaintManager, CXTPHyperLink, CXTPMarqueeCtrl, CXTPPaintManager, CXTPShortcutListBox, CXTPTagCloudStyleManager
  • SetColorSet() : CXTPTabManager, CXTPTabPaintManager
  • SetColumn() : CXTPMarkupGrid
  • SetColumnAnchorVerticalPosition() : CXTPChart3dPieSeriesLabelDeviceCommand
  • SetColumnOffice2007CustomThemeBaseColor() : CXTPGridPaintManager
  • SetColumnPlusMinusSign() : CXTPGridPaintManager
  • SetColumns() : CXTPMarkupUniformGrid
  • SetColumnSpan() : CXTPMarkupGrid
  • SetColumnStyle() : CXTPGridPaintManager
  • SetColumnWidth() : CXTPTaskPanel
  • SetColumnWidthWYSIWYG() : CXTPGridPaintManager
  • SetCommandBar() : CXTPControlPopup
  • SetCommandBarData() : CXTPCommandBar
  • SetCommandBarRegion() : CXTPPaintManager, CXTPRibbonTheme
  • SetCommandBars() : CXTPCommandBar, CXTPCommandBarScrollBarCtrl, CXTPControls, CXTPStatusBar, CXTPTabClientWnd
  • SetCommandBarsFontIndirect() : CXTPPaintManager
  • SetCommandText() : CXTPSyntaxEditCommand
  • SetCommandUsed() : CXTPCommandBars
  • SetCommonButtons() : CXTPTaskDialog
  • SetCompactMode() : CXTPPropExchangeXMLNode
  • SetConfigFile() : CXTPSyntaxEditBufferManager, CXTPSyntaxEditCtrl, CXTPSyntaxEditDoc
  • SetConfigurationManager() : CXTPSyntaxEditFileChangesMonitor
  • SetConnectionString() : CXTPCalendarData
  • SetConnectorBendPoint() : CXTPChart3dFunnelSeriesLabelView, CXTPChart3dPieSeriesLabelView, CXTPChart3dPyramidSeriesLabelView
  • SetConnectorEndPoint() : CXTPChart3dFunnelSeriesLabelView, CXTPChart3dPieSeriesLabelView, CXTPChart3dPyramidSeriesLabelView
  • SetConnectorEndpointVerticalOffset() : CXTPChart3dFunnelSeriesLabelDeviceCommand, CXTPChart3dPieSeriesLabelDeviceCommand, CXTPChart3dPyramidSeriesLabelDeviceCommand
  • SetConnectorLength() : CXTPChart3dFunnelSeriesLabelDeviceCommand, CXTPChart3dPyramidSeriesLabelDeviceCommand
  • SetConnectorLengthFactor() : CXTPChart3dPieSeriesLabelDeviceCommand
  • SetConnectorStartPoint() : CXTPChart3dFunnelSeriesLabelView, CXTPChart3dPieSeriesLabelView, CXTPChart3dPyramidSeriesLabelView
  • SetConnectorVisible() : CXTPChart3dFunnelSeriesLabelView, CXTPChart3dPieSeriesLabelView, CXTPChart3dPyramidSeriesLabelView
  • SetConstraintEdit() : CXTPPropertyGridItem
  • SetContent() : CXTPChartControl, CXTPMarkupContentControl, CXTPMarkupPage, CXTPTaskDialog
  • SetContentObject() : CXTPMarkupXtpScript
  • SetContextCaption() : CXTPRibbonTab
  • SetContextColor() : CXTPRibbonTab
  • SetContextMenuEnabled() : CXTPShellExplorerProvider
  • SetContextMenuPresent() : CXTPToolBar
  • SetContextTab() : CXTPRibbonTab
  • SetContextWindow() : CXTPMarkupContext
  • SetControl() : CXTPCalendarPaintManager, CXTPControlCustom, CXTPGridGroupRow, CXTPGridRow
  • SetControlHandle() : CXTPTaskPanelGroupItem
  • SetControlPoint() : CXTPFlowGraphConnection
  • SetControls() : CXTPCommandBar
  • SetControlsCentering() : CXTPRibbonGroup
  • SetControlsGrouping() : CXTPRibbonGroup
  • SetControlSize() : CXTPControlGallery
  • SetControlType() : CXTPControls, CXTPRibbonGroup
  • SetCopyCursor() : CXTPSyntaxEditPaintManager
  • SetCornerRadius() : CXTPMarkupBorder
  • SetCreateScrollbarOnParent() : CXTPSyntaxEditCtrl
  • SetCreationTime() : CXTPCalendarEvent
  • SetCRLFStyle() : CXTPSyntaxEditBufferManager
  • SetCrossAxis() : CXTPChartAxisTickMarks
  • SetCurCaretPos() : CXTPSyntaxEditCtrl
  • SetCurPos() : CXTPSyntaxEditCtrl
  • SetCurrencyFormat() : CXTPGridGroupRow
  • SetCurrencySymbol() : CXTPChartNumberFormat
  • SetCurrent() : CXTPGaugeMeterType, CXTPPropertyGridItemConstraints
  • SetCurrentColor() : CXTPColorDialog
  • SetCurrentDocumentRow() : CXTPSyntaxEditCtrl
  • SetCurrentFocusInFootersRows() : CXTPGridNavigator
  • SetCurrentFocusInHeadersRows() : CXTPGridNavigator
  • SetCurSel() : CXTPColorSelectorCtrl, CXTPControlComboBox, CXTPDatePickerControl, CXTPExcelTabCtrl, CXTPRibbonBar, CXTPTabManager, CXTPTagCloudCtrl
  • SetCustomAnimation() : CXTPAnimationDC
  • SetCustomColors() : CXTPPropertyGrid
  • SetCustomControlKeyboardInteraction() : CXTPMiniToolBar
  • SetCustomFont() : CXTPPaintManagerFont
  • SetCustomIcon() : CXTPControl
  • SetCustomizationDataFileName() : CXTPCommandBars
  • SetCustomizationVisible() : CXTPStatusBarPane
  • SetCustomizeCaption() : CXTPRibbonTab
  • SetCustomizeDialogPresent() : CXTPToolBar
  • SetCustomizeMode() : CXTPCommandBars
  • SetCustomShortcutText() : CXTPControl, CXTPControlAction
  • SetCustomTheme() : CXTPDockingPaneManager, CXTPPaintManager, CXTPPropertyGrid, CXTPShortcutBar, CXTPTaskPanel
  • SetCustomTimeFormat() : CXTPCalendarDayViewTimeScale, CXTPCalendarView
  • SetCustomTitleBrushes() : CXTPDockingPanePaintManager
  • SetCustomTrait() : CXTPGaugeTraits
  • SetCustomValue() : CXTPCalendarThemeCustomizableXValueT< _TValue, _TValueRef >, CXTPCalendarThemeFontValue, CXTPCalendarViewPartCustomizableValueT< _TValue >, CXTPPaintManagerColor, CXTPPaintManagerColorGradient
  • SetDark() : CXTPStatusBarPane
  • SetDashed() : CXTPFlowGraphConnection
  • SetDashStyle() : CXTPChartLineStyle
  • SetData() : CXTPBrowseDialog, CXTPControlGalleryItem, CXTPHexEdit, CXTPTabManagerItem, XTP_CALENDAR_RECURRENCE_OPTIONS
  • SetDataManager() : CXTPSyntaxEditDoc
  • SetDataProvider() : CXTPCalendarControl, CXTPCalendarOptions, CXTPCalendarResource, CXTPCalendarResourcesManager
  • SetDataSource() : CXTPGridDataManager
  • SetDate() : CXTPPropertyGridItemDate
  • SetDateFormat() : CXTPPropertyGridItemDate
  • SetDateLabel() : CXTPCalendarCaptionBarTheme
  • SetDatePicker() : CXTPCalendarController
  • SetDateTime() : CXTPDateEdit
  • SetDateTimeScaleUnit() : CXTPChartAxis
  • SetDay() : CXTPPropertyGridItemDate
  • SetDayDate() : CXTPCalendarViewDay
  • SetDayHeaderFormat() : CXTPCalendarView
  • SetDayHeaderFormatLong() : CXTPCalendarView
  • SetDayHeaderFormatMiddle() : CXTPCalendarView
  • SetDayHeaderFormatShort() : CXTPCalendarView
  • SetDayHeaderFormatShortest() : CXTPCalendarView
  • SetDayInCache() : CXTPCalendarData::CXTPDPCache
  • SetDayOfWeekName() : CXTPDatePickerControl
  • SetDayRect() : CXTPCalendarViewDay
  • SetDecimalPlaces() : CXTPChartNumberFormat
  • SetDefaultAccelerator() : CXTPShortcutManager
  • SetDefaultBlendingOptions() : CXTPFrameShadowManager
  • SetDefaultButton() : CXTPTaskDialog
  • SetDefaultButtonStyle() : CXTPCommandBar
  • SetDefaultClipOwner() : CXTPFrameShadowManager
  • SetDefaultColor() : CXTPColorPicker, CXTPFrameShadowManager
  • SetDefaultFolder() : CXTPSyntaxEditFileChangesMonitor
  • SetDefaultFont() : CXTPMarkupContext
  • SetDefaultFonts() : CXTPTipOfTheDay
  • SetDefaultInnerSize() : CXTPFrameShadowManager
  • SetDefaultItem() : CXTPPopupBar
  • SetDefaultLocation() : CXTPPopupControl
  • SetDefaultMarkup() : CXTPFlowGraphNode, CXTPFlowGraphNodeCustom
  • SetDefaultMenuItem() : CXTPTrayIcon
  • SetDefaultOffset() : CXTPFrameShadowManager
  • SetDefaultOuterSize() : CXTPFrameShadowManager
  • SetDefaultPaneOptions() : CXTPDockingPaneManager
  • SetDefaultRadioButton() : CXTPTaskDialog
  • SetDefaults() : CXTPSyntaxEditPropertiesPageColor
  • SetDefaultSmoothingMode() : CXTPMarkupContext
  • SetDefaultTextColor() : CXTPMarkupContext
  • SetDefaultTextSmoothing() : CXTPMarkupContext
  • SetDefaultTitle() : CXTPTipOfTheDay
  • SetDefaultTransparency() : CXTPFrameShadowManager
  • SetDefaultValue() : CXTPCalendarThemeCustomizableXValueT< _TValue, _TValueRef >, CXTPCalendarViewPartCustomizableValueT< _TValue >, CXTPCalendarViewPartFontValue, CXTPPaintManagerColor, CXTPPropertyGridItem
  • SetDefaultValues() : CXTPCalendarEventCategories, CXTPCalendarEventLabels, CXTPPropertyGridItemMetrics, CXTPTrayIcon
  • SetDelay() : CXTPSyntaxEditToolTipCtrl
  • SetDelayTime() : CXTPToolTipContext
  • SetDelegate() : CXTPMarkupContext
  • SetDelimiters() : CXTPSyntaxEditAutoCompleteWnd
  • SetDepth() : CXTPChart3dPieSeriesStyle
  • SetDescription() : CXTPControl, CXTPControlAction, CXTPControlGalleryItem, CXTPPropertyGridItem
  • SetDescriptionText() : CXTPTrackBlock
  • SetDesiredVisibleAndFullRange() : CXTPDatePickerControl
  • SetDiagram() : CXTPChartSeries
  • SetDirection() : CXTPChartLegend
  • SetDirectionClockwise() : CXTPChartRadarAxisX
  • SetDirty() : CXTPSyntaxEditView
  • SetDisabledBackColor() : CXTPHexEdit
  • SetDisabledHighlightBackColor() : CXTPHexEdit
  • SetDisabledHighlightTextColor() : CXTPHexEdit
  • SetDisabledIcon() : CXTPImageManagerIcon
  • SetDisabledTextColor() : CXTPHexEdit
  • SetDisableReorderColumnsCount() : CXTPGridControl
  • SetDisplayName() : CXTPBrowseDialog
  • SetDividerColor() : CXTPGridSection
  • SetDividerPos() : CXTPPropertyGridView
  • SetDividerPosition() : CXTPGridSection
  • SetDividerStyle() : CXTPGridSection
  • SetDlgDefExt() : CXTPBrowseEdit
  • SetDlgFileName() : CXTPBrowseEdit
  • SetDlgFilter() : CXTPBrowseEdit, CXTPEditListBox
  • SetDlgInitialDir() : CXTPBrowseEdit, CXTPEditListBox
  • SetDlgOpenFile() : CXTPBrowseEdit
  • SetDlgStyle() : CXTPBrowseEdit
  • SetDlgTitle() : CXTPBrowseEdit
  • SetDock() : CXTPMarkupDockPanel
  • SetDockBarClass() : CXTPCommandBars
  • SetDocking() : CXTPChartTitle
  • SetDockingContext() : CXTPDockingPaneManager
  • SetDockingContextStickerStyle() : CXTPDockingPaneManager
  • SetDockingSite() : CXTPDockingPaneBase
  • SetDockState() : CXTPCommandBars
  • SetDocModified() : CXTPSyntaxEditCtrl
  • SetDouble() : CXTPPropertyGridItemDouble
  • SetDoubleGripper() : CXTPPopupBar
  • SetDpiAware() : CXTPMarkupContext
  • SetDpiImageScaling() : CXTPButton
  • SetDragControl() : CXTPCommandBars
  • SetDragCursorImage() : CXTPImageList
  • SetDraggingEvent() : CXTPCalendarView
  • SetDragSensitivityX() : CXTPGridControl
  • SetDragSensitivityY() : CXTPGridControl
  • SetDragText() : CXTPTaskPanelGroupItem
  • SetDrawDisabledText() : CXTPStatusBar
  • SetDrawFooterDivider() : CXTPGridColumn
  • SetDrawFooterRowsVGrid() : CXTPGridColumn
  • SetDrawGridForEmptySpace() : CXTPGridPaintManager
  • SetDrawHeaderDivider() : CXTPGridColumn
  • SetDrawHeaderRowsVGrid() : CXTPGridColumn
  • SetDrawStyle() : CXTPHeaderCtrlTheme
  • SetDropDownItemCount() : CXTPControlComboBox, CXTPPropertyGridItem
  • SetDropDownListStyle() : CXTPControlComboBox
  • SetDropDownWidth() : CXTPControlComboBox
  • SetDropListItemNumber() : CXTPGridInplaceButton, CXTPGridInplaceList
  • SetDropMarkerFlags() : CXTPGridControl
  • SetDropPos() : CXTPSyntaxEditCtrl
  • SetDuration() : CXTPCalendarEvent
  • SetDurationMinutes() : CXTPCalendarRecurrencePattern
  • SetEditable() : CXTPGridColumn, CXTPGridRecord, CXTPGridRecordItem
  • SetEditCtrl() : CXTPSyntaxEditView
  • SetEditHint() : CXTPControlAction, CXTPControlComboBox, CXTPControlEdit
  • SetEditIconId() : CXTPControlComboBox, CXTPControlEdit
  • SetEditMask() : CXTPEdit, CXTPMaskEditT< TBase >
  • SetEditorStyle() : CXTPPropertyGridItemColor
  • SetEditStyle() : CXTPControlComboBox, CXTPControlEdit, CXTPPropertyGridItem
  • SetEditText() : CXTPControlComboBox, CXTPControlEdit, CXTPEditListBox, CXTPPropertyGridItem
  • SetEmpty() : CXTPRectT< T >
  • SetEnable() : CXTPGridRecordItemControl
  • SetEnableButtons() : CXTPWindowList
  • SetEnabled() : CXTPChartDeviceCommand, CXTPControl, CXTPControlAction, CXTPControlGalleryItem, CXTPDockingPane, CXTPPropertyGridInplaceButton, CXTPShortcutBarItem, CXTPStatusBarPane, CXTPTabManagerItem, CXTPTaskPanelItem
  • SetEncoding() : CXTPPropExchangeXMLNode
  • SetEnd() : CXTPArcBall
  • SetEnd_disp() : CXTPSyntaxEditSelection
  • SetEnd_str() : CXTPSyntaxEditSelection
  • SetEndAfterOccurrences() : CXTPCalendarRecurrencePattern
  • SetEndTime() : CXTPCalendarEvent
  • SetEnum() : CXTPPropertyGridItemEnum
  • SetEnumFlags() : CXTPShellListBase, CXTPShellTreeBase
  • SetEqualHeight() : CXTPChartFunnelSeriesStyleBase
  • SetErrorBar() : CXTPChartSeriesStyle
  • SetEvent() : CXTPCalendarOccurSeriesChooseDlg, CXTPCalendarReminder
  • SetEventID() : CXTPCalendarEvent
  • SetEventPlaceCount() : CXTPCalendarDayViewEvent
  • SetEventPlacePos() : CXTPCalendarDayViewEvent
  • SetEventSink() : CXTPWebBrowserCtrl
  • SetEventVisible() : CXTPCalendarEvent
  • SetException() : CXTPCalendarRecurrencePattern
  • SetExecuteOnPressInterval() : CXTPControl
  • SetExpandable() : CXTPPropertyGridItem, CXTPShortcutBarPaneItem, CXTPTaskPanel, CXTPTaskPanelGroup
  • SetExpandButton() : CXTPCalendarCaptionBarTheme
  • SetExpandButtonCheck() : CXTPCalendarCaptionBarTheme
  • SetExpandDown() : CXTPCalendarDayViewGroup
  • SetExpanded() : CXTPControl, CXTPGridColumn, CXTPGridRecord, CXTPGridRow, CXTPShortcutBarPaneItem, CXTPTaskPanelGroup
  • SetExpandedControlText() : CXTPTaskDialog
  • SetExpandedInformation() : CXTPTaskDialog
  • SetExpandedLinesCount() : CXTPShortcutBar
  • SetExpandedLinesHeight() : CXTPShortcutBar
  • SetExpandUp() : CXTPCalendarDayViewGroup
  • SetExplodedDistancePercent() : CXTPChartPieSeriesStyleBase
  • SetExplorerStyle() : CXTPShellListBase, CXTPShellTreeBase
  • SetExplorerTheme() : CXTPTreeBase
  • SetExtendedStyle() : CXTPListBase
  • SetExternal() : CXTPWebBrowserCtrl
  • SetFailed() : CXTPChart3dFunnelSeriesLabelDeviceCommand, CXTPChart3dPieSeriesLabelDeviceCommand, CXTPChart3dPyramidSeriesLabelDeviceCommand
  • SetFailedMessage() : CXTPPreviewCtrl
  • SetFastDeselectMode() : CXTPGridControl
  • SetFileDialog() : CXTPBrowseEdit
  • SetFileExt() : CXTPSyntaxEditBufferManager
  • SetFillAcrossXAxis() : CXTPChartAreaSeriesStyle
  • SetFillMode() : CXTPChartFillStyle
  • SetFilterable() : CXTPGridColumn
  • SetFilterEditCtrl() : CXTPGridHeader
  • SetFilterHiddenColumns() : CXTPGridControl
  • SetFilterText() : CXTPGridControl
  • SetFirstColumn() : CXTPMarkupUniformGrid
  • SetFirstDayOfWeek() : CXTPCalendarControl, CXTPDatePickerControl
  • SetFirstDayOfWeekToDatePicker() : CXTPCalendarController
  • SetFirstWeekOfYearDays() : CXTPCalendarControl, CXTPDatePickerControl
  • SetFixed() : CXTPGridColumn
  • SetFixedRowHeight() : CXTPGridPaintManager
  • SetFlag() : CXTPResize
  • SetFlags() : CXTPCommandBar, CXTPControl, CXTPFrameShadowManager, CXTPGridRecordItemControl, CXTPPropertyGridItem, CXTPPropertyGridItemFlags, CXTPTabClientWnd, CXTPTabManagerNavigateButton
  • SetFlatStyle() : CXTPButton, CXTPComboBox, CXTPEdit, CXTPEditTheme, CXTPProgressCtrl
  • SetFloatingFrameCaption() : CXTPDockingPaneManager
  • SetFloatingFramesOpacity() : CXTPDockingPaneManager
  • SetFocus() : CXTPDockingPane
  • SetFocusable() : CXTPGridRecordItem
  • SetFocused() : CXTPControl, CXTPControlComboBox, CXTPControlEdit, CXTPRibbonControlTab
  • SetFocusedColumn() : CXTPGridControl
  • SetFocusedControl() : CXTPRibbonBackstageView
  • SetFocusedItem() : CXTPTabControl, CXTPTabManager, CXTPTaskPanel
  • SetFocusedRow() : CXTPGridControl
  • SetFocusedRowIndex() : CXTPGridRows
  • SetFocusToInplaceControl() : CXTPPropertyGridItem
  • SetFolderData() : CXTPDirWatcher
  • SetFolderPath() : CXTPDirWatcher
  • SetFont() : CXTPCalendarTip, CXTPChartAxisConstantLine, CXTPChartAxisLabel, CXTPChartAxisTitle, CXTPChartLegend, CXTPChartSeriesLabel, CXTPChartTitle, CXTPGridInplaceEdit, CXTPGridRecordItem, CXTPGridRecordItemControl, CXTPGridTip, CXTPPopupPaintManager, CXTPPropertyGrid, CXTPPropertyGridItemFont, CXTPStatusBar, CXTPSyntaxEditPaintManager, CXTPTagCloudStyle, CXTPTagCloudStyleManager, CXTPToolTipContext, XTP_DAYITEM_METRICS
  • SetFontBold() : CXTPHeaderCtrl
  • SetFontCharset() : CXTPResourceManager
  • SetFontFamily() : CXTPMarkupTextBlock
  • SetFontHeight() : CXTPCommandBars, CXTPRibbonBar, CXTPRibbonPaintManager
  • SetFontIndirect() : CXTPDatePickerPaintManager, CXTPSyntaxEditCtrl, CXTPSyntaxEditView, CXTPTabPaintManager, CXTPToolTipContext
  • SetFontLineNumber() : CXTPSyntaxEditPaintManager
  • SetFontSize() : CXTPMarkupTextBlock
  • SetFontStyle() : CXTPMarkupTextBlock
  • SetFontText() : CXTPSyntaxEditPaintManager
  • SetFontToolTip() : CXTPSyntaxEditPaintManager
  • SetFontWeight() : CXTPMarkupTextBlock
  • SetFooter() : CXTPTaskDialog
  • SetFooterAlignment() : CXTPGridColumn
  • SetFooterFont() : CXTPGridColumn
  • SetFooterIcon() : CXTPTaskDialog
  • SetFooterText() : CXTPGridColumn
  • SetForceExpanded() : CXTPMouseManager
  • SetForeground() : CXTPMarkupControl, CXTPMarkupTextBlock
  • SetForegroundColor() : CXTPPreviewCtrl
  • SetFormat() : CXTPChartAxisLabel, CXTPChartSeriesLabel
  • SetFormatString() : CXTPGridGroupRow, CXTPGridRecordItem
  • SetFormula() : CXTPGridGroupRow, CXTPGridRecordItem
  • SetFrameHook() : CXTPCommandBars
  • SetFreeHeight() : CXTPGridRecord
  • SetFreezeColsDividerStyle() : CXTPGridPaintManager
  • SetFreezeColumnsCount() : CXTPGridControl
  • SetFromCOLORREF() : CXTPChartColor
  • SetFromString() : CXTPChart3dRotation, CXTPChartColor
  • SetFrozen() : CXTPGridColumn
  • SetFullColumnScrolling() : CXTPGridControl
  • SetFullExpanded() : CXTPGridRow
  • SetGap() : CXTPBrowseEdit
  • SetGetSysColorPtr() : CXTPColorManager
  • SetGlobalBlendingOptions() : CXTPFrameShadowManager
  • SetGlobalClipOwner() : CXTPFrameShadowManager
  • SetGlobalColor() : CXTPFrameShadowManager
  • SetGlobalFont() : CXTPAuxData
  • SetGlobalInnerSize() : CXTPFrameShadowManager
  • SetGlobalOffset() : CXTPFrameShadowManager
  • SetGlobalOuterSize() : CXTPFrameShadowManager
  • SetGlobalPaintManager() : CXTPPaintManager
  • SetGlobalTransparency() : CXTPFrameShadowManager
  • SetGrabFocus() : CXTPCommandBar
  • SetGradientAngle() : CXTPChartFillStyle
  • SetGridColor() : CXTPGridControl
  • SetGridControl() : CXTPGridPaintManager, CXTPGridRecordItem
  • SetGridCtrl() : CXTPGridFilterEditControl, CXTPGridSubListControl, CXTPGridView
  • SetGridDimentions() : CXTPDatePickerControl
  • SetGridHeader() : CXTPGridControl
  • SetGridSize() : CXTPDatePickerControl
  • SetGridSpacing() : CXTPChartAxis
  • SetGridSpacingAuto() : CXTPChartAxis
  • SetGridStyle() : CXTPGridControl
  • SetGripperPosition() : CXTPExcelTabCtrl
  • SetGroupable() : CXTPGridColumn
  • SetGroupCaption() : CXTPGridRecordItem
  • SetGroupIconSize() : CXTPTaskPanel
  • SetGroupImageList() : CXTPTaskPanel
  • SetGroupInsertMode() : CXTPSyntaxEditUndoRedoManager
  • SetGroupPriority() : CXTPGridRecordItem
  • SetGroupRowsBold() : CXTPGridControl
  • SetGroupsHeight() : CXTPRibbonBar
  • SetGroupsVisible() : CXTPRibbonBar
  • SetHandCursor() : CXTPPopupItem
  • SetHandle() : CXTPResourceImages, CXTPTabManagerItem, CXTPThemeDLL
  • SetHandleOwnershipNotGuaranteed() : CXTPGdiObject
  • SetHatchStyle() : CXTPChartFillStyle
  • SetHeaderAlignment() : CXTPGridColumn
  • SetHeaderHeight() : CXTPGridPaintManager
  • SetHeaderOffset() : CXTPTabManager
  • SetHeight() : CXTPControl, CXTPGridRecordItemControl, CXTPGridSection, CXTPMarkupFrameworkElement, CXTPMarkupRowDefinition, CXTPMessageBar, CXTPPropertyGridItem, CXTPShortcutBarPaneItem
  • SetHeightMode() : CXTPGridSection
  • SetHeightPercent() : CXTPTrackBlock
  • SetHeightToWidthRatio() : CXTPChartFunnelSeriesStyleBase, CXTPChartPyramidSeriesStyleBase
  • SetHelpHeight() : CXTPPropertyGrid
  • SetHelpID() : CXTPDockingPane
  • SetHelpId() : CXTPControl, CXTPControlAction
  • SetHexFont() : CXTPHexEdit
  • SetHidden() : CXTPPropertyGridItem
  • SetHideCaret() : CXTPSyntaxEditCtrl
  • SetHideFlag() : CXTPControl
  • SetHideFlags() : CXTPControl, CXTPControlComboBox, CXTPControlCustom, CXTPControlEdit
  • SetHideWrap() : CXTPControl
  • SetHighlightBackColor() : CXTPHexEdit
  • SetHighlightCursor() : CXTPShortcutListBox
  • SetHighlighted() : CXTPComboBox
  • SetHighlightTextColor() : CXTPHexEdit
  • SetHighlightToday() : CXTPDatePickerControl
  • SetHiliteBackColor() : CXTPSyntaxEditPaintManager
  • SetHiliteTextColor() : CXTPSyntaxEditPaintManager
  • SetHint() : CXTPGridFilterEditControl
  • SetHolePercent() : CXTPChartPieSeriesStyleBase
  • SetHook() : CXTPHookManager, CXTPSkinManager
  • SetHorizontalAlignment() : CXTPChartLegend, CXTPMarkupFrameworkElement
  • SetHotDivider() : CXTPGridHeader
  • SetHotIcon() : CXTPImageManagerIcon
  • SetHotItem() : CXTPShortcutBar, CXTPTaskPanel
  • SetHotTrackStyle() : CXTPTaskPanel
  • SetHours() : CXTPTimeEdit
  • SetHoverRect() : CXTPCalendarTip, CXTPGridTip, CXTPSyntaxEditToolTipCtrl
  • SetHScrollStep() : CXTPGridControl
  • SetHue() : CXTPColorWnd
  • SetHyperLink() : CXTPPopupItem
  • SetHyperlink() : CXTPPropertyGridInplaceButton
  • SetIcon() : CXTPButton, CXTPDockingPaneManager, CXTPFlowGraphImage, CXTPFramePaintManager, CXTPImageEditorDlg, CXTPImageManager, CXTPImageManagerIcon, CXTPPopupItem, CXTPTrayIcon
  • SetIconColumn() : CXTPGridControl
  • SetIconFromIcoFile() : CXTPImageManager
  • SetIconFromResource() : CXTPImageManager
  • SetIconID() : CXTPDockingPane, CXTPGridColumn
  • SetIconId() : CXTPControl, CXTPControlAction, CXTPRibbonGroup, CXTPShortcutBarItem
  • SetIconIndent() : CXTPTreeBase
  • SetIconIndex() : CXTPGridInplaceButton, CXTPGridRecordItem, CXTPGridRecordItemControl, CXTPPopupItem, CXTPPropertyGridInplaceButton, CXTPStatusBarPane, CXTPTaskPanelItem
  • SetIcons() : CXTPDockingPaneManager, CXTPImageManager, CXTPPopupItem
  • SetIconSize() : CXTPCommandBar, CXTPControl, CXTPImageEditorDlg, CXTPTaskPanel, CXTPTaskPanelGroup
  • SetIconView() : CXTPGridControl
  • SetIconViewToDefaults() : CXTPGridControl
  • SetID() : CXTPCalendarEventCategory, CXTPCalendarSchedule, CXTPControl, CXTPControlGalleryItem, CXTPDockingPane, CXTPFlowGraphConnectionPoint, CXTPFlowGraphNode, CXTPFlowGraphPage, CXTPPopupItem, CXTPPropertyGridItem, CXTPRibbonGroup, CXTPRibbonTab, CXTPShortcutBarItem, CXTPTaskPanelItem
  • SetIdentity() : CXTPMatrix< T >
  • SetImageAlignment() : CXTPButton
  • SetImageColorKey() : CXTPMarkupContext
  • SetImageCount() : CXTPImageList
  • SetImageGap() : CXTPButton
  • SetImageHandle() : CXTPPaintManager, CXTPResourceTheme
  • SetImageIndex() : CXTPControlGalleryItem, CXTPFlowGraphConnectionPoint, CXTPFlowGraphNode, CXTPTabManagerItem
  • SetImageList() : CXTPGridControl, CXTPImageManager, CXTPTabControl, CXTPTaskPanel
  • SetImageManager() : CXTPCommandBar, CXTPCommandBars, CXTPControlGalleryItems, CXTPDockingPaneManager, CXTPGridControl, CXTPHeaderCtrl, CXTPMarkupContext, CXTPPasswordPeek, CXTPPopupControl, CXTPPropertyGrid, CXTPShortcutBar, CXTPTabControl, CXTPTaskPanel
  • SetImages() : CXTPResourceTheme
  • SetImageWidth() : CXTPControlGalleryItem
  • SetImportance() : CXTPCalendarEvent
  • SetInactiveHiliteBackColor() : CXTPSyntaxEditPaintManager
  • SetInactiveHiliteTextColor() : CXTPSyntaxEditPaintManager
  • SetIncludeExtensions() : CXTPShellListBase
  • SetIndent() : CXTPChartTitle, CXTPShortcutBarPane
  • SetIndex() : CXTPChartAxis, CXTPControl, CXTPGridRow
  • SetIndicators() : CXTPStatusBar
  • SetInfo() : CXTPExcelTabCtrlButtonState
  • SetIniData() : CXTPResourceImages
  • SetINIFileName() : CXTPRegistryManager
  • SetInnerSize() : CXTPFrameShadow
  • SetInplaceButtonHeight() : CXTPGridPaintManager
  • SetInplaceEdit() : CXTPPropertyGrid
  • SetInplaceList() : CXTPPropertyGrid
  • SetInputBoxText() : CXTPTaskDialog
  • SetInputPoint() : CXTPFlowGraphConnection
  • SetInsertMark() : CXTPTreeBase
  • SetInsertMarkColor() : CXTPTreeBase
  • SetInsideCellButton() : CXTPGridInplaceButton
  • SetInterlaced() : CXTPChartAxis
  • SetInterlacedColor() : CXTPChartAxis
  • SetInterlacedColor2() : CXTPChartAxis
  • SetInternalArgumentValue() : CXTPChartSeriesPoint
  • SetInternalName() : CXTPGridColumn
  • SetInvertedStep() : CXTPChartStepLineSeriesStyle
  • SetItemArgs() : CXTPGridInplaceControl, CXTPGridInplaceList
  • SetItemBackColor() : CXTPTreeBase
  • SetItemBold() : CXTPTreeBase
  • SetItemColor() : CXTPCalendarEventColorListBox, CXTPDockingPane, CXTPTreeBase
  • SetItemData() : CXTPControlComboBox, CXTPGridRecordItem, CXTPPropertyGridItem, CXTPShortcutBarItem, CXTPTaskPanelItem
  • SetItemDefault() : CXTPControl
  • SetItemFont() : CXTPTaskPanelItem, CXTPTreeBase
  • SetItemIndex() : CXTPGridColumn
  • SetItemLayout() : CXTPTaskPanel, CXTPTaskPanelGroup
  • SetItemMetrics() : CXTPTabManager
  • SetItemRect() : CXTPTaskPanelGroupItem
  • SetItems() : CXTPControlGallery
  • SetItemsActive() : CXTPControlSelector
  • SetItemsBorderHeight() : CXTPPropertyGridPaintManager
  • SetItemSelected() : CXTPTaskPanelGroupItem
  • SetItemsFontIndirect() : CXTPTaskPanelPaintManager
  • SetItemSize() : CXTPControlGalleryItems, CXTPShortcutBar
  • SetItemsMargin() : CXTPControlGallery
  • SetItemState() : CXTPTreeBase
  • SetItemText() : CXTPExcelTabCtrl
  • SetKey() : CXTPControlAction
  • SetKeyboardTip() : CXTPControl, CXTPControlAction, CXTPRibbonTab
  • SetKeyboardWindowSelectClass() : CXTPDockingPaneManager
  • SetKeyNameText() : CXTPShortcutManager
  • SetLabel() : CXTPChartSeriesStyle
  • SetLabelAnchorOrigin() : CXTPChart3dFunnelSeriesLabelView, CXTPChart3dPieSeriesLabelView, CXTPChart3dPyramidSeriesLabelView
  • SetLabelAnchorPoint() : CXTPChart3dFunnelSeriesLabelView, CXTPChart3dPieSeriesLabelView, CXTPChart3dPyramidSeriesLabelView
  • SetLabelID() : CXTPCalendarEvent, CXTPCalendarEventLabelComboBox
  • SetLabelList() : CXTPCalendarData
  • SetLabelRect() : CXTPChart3dFunnelSeriesLabelDeviceCommand, CXTPChart3dPieSeriesLabelDeviceCommand, CXTPChart3dPyramidSeriesLabelDeviceCommand
  • SetLabelText() : CXTPChartSeriesPoint, CXTPSearchOptionsCtrl
  • SetLabelWidth() : CXTPControlComboBox, CXTPControlEdit
  • SetLastChildFill() : CXTPMarkupDockPanel
  • SetLastColumnExpand() : CXTPGridHeader
  • SetLastColumnWidthWYSIWYG() : CXTPGridPaintManager
  • SetLastCommandText() : CXTPSyntaxEditUndoRedoManager
  • SetLastModificationTime() : CXTPCalendarEvent
  • SetLastRqstEdit() : CXTPGridControl
  • SetLastVisibleRect() : CXTPCalendarTimeLineViewEvent
  • SetLayeredWindowAttributes() : CXTPPopupControl
  • SetLayout() : CXTPDockingPaneManager, CXTPTabPaintManager
  • SetLayoutRTL() : CXTPCalendarControl, CXTPCommandBars, CXTPDatePickerControl, CXTPGridControl, CXTPPopupControl, CXTPPropertyGrid, CXTPShortcutBar, CXTPTabClientWnd, CXTPTaskPanel
  • SetLayoutStyle() : CXTPTabManager
  • SetLeft() : CXTPGridThickness, CXTPMarkupThickness
  • SetLeftDirected() : CXTPChart3dFunnelSeriesLabelView, CXTPChart3dPieSeriesLabelView, CXTPChart3dPyramidSeriesLabelView
  • SetLegendName() : CXTPChartAxisConstantLine, CXTPChartAxisStrip
  • SetLegendText() : CXTPChartSeries, CXTPChartSeriesPoint
  • SetLegendVisible() : CXTPChartAxisConstantLine, CXTPChartAxisStrip, CXTPChartSeries
  • SetLength() : CXTPChartAxisTickMarks, CXTPTrackBlock
  • SetLexConfigurationManager() : CXTPSyntaxEditBufferManager
  • SetLightAmbientColor() : CXTPChart3dDeviceContext
  • SetLightDiffuseColor() : CXTPChart3dDeviceContext
  • SetLightModelAmbientColor() : CXTPChart3dDeviceContext
  • SetLightPosition() : CXTPChart3dDeviceContext
  • SetLightSpecularColor() : CXTPChart3dDeviceContext
  • SetLineColor() : CXTPChartSeriesLabel
  • SetLineLength() : CXTPChartSeriesLabel
  • SetLineMark() : CXTPSyntaxEditLineMarksManager
  • SetLineNumberBackColor() : CXTPSyntaxEditPaintManager
  • SetLineNumbers() : CXTPSyntaxEditCtrl, CXTPSyntaxEditView
  • SetLineNumberTextColor() : CXTPSyntaxEditPaintManager
  • SetLineSelCursor() : CXTPSyntaxEditPaintManager
  • SetLinesMinMax() : CXTPControlListBox
  • SetLineSpace() : CXTPTipWindow
  • SetLineThickness() : CXTPChartHighLowSeriesStyle
  • SetLinkCursor() : CXTPHyperLink
  • SetList() : CXTPSyntaxEditAutoCompleteWnd
  • SetListBackColor() : CXTPListBase
  • SetListEditStyle() : CXTPEditListBox
  • SetListIconId() : CXTPControlComboBox
  • SetListStyle() : CXTPFontComboBox, CXTPFontListBox, CXTPListBox
  • SetListTextColor() : CXTPListBase
  • SetLoading() : CXTPPropExchangeXMLNode
  • SetLoadingMessage() : CXTPPreviewCtrl
  • SetLocale() : CXTPChartNumberFormat
  • SetLocation() : CXTPCalendarEvent, CXTPFlowGraphNode
  • SetLocked() : CXTPFlowGraphConnectionPoint, CXTPFlowGraphNode, CXTPGridRecord, CXTPTrackBlock, CXTPTrackControlItem
  • SetLockRedraw() : CXTPTabControl, CXTPTaskPanel
  • SetLogarithmic() : CXTPChartAxis
  • SetLogarithmicBase() : CXTPChartAxis
  • SetLogFont() : CXTPChartFont
  • SetLongDayHeaderFormat() : CXTPCalendarControl, CXTPCalendarMonthView
  • SetLuminance() : CXTPColorLum
  • SetLunaTheme() : CXTPColorManager, CXTPDockingPanePaintManager, CXTPPaintManager
  • SetMainIcon() : CXTPTaskDialog
  • SetMainInstruction() : CXTPTaskDialog
  • SetMargin() : CXTPMarkupFrameworkElement, CXTPTagCloudCtrl, CXTPToolTipContext
  • SetMargins() : CXTPStatusBarPane, CXTPTaskPanel, CXTPTipWindow
  • SetMarkerSize() : CXTPChartLegend
  • SetMarkerVisible() : CXTPChartLegend
  • SetMarkupContext() : CXTPGridRecords, CXTPGridSection, CXTPGridSections
  • SetMarkupTemplate() : CXTPPropertyGridItem
  • SetMarkupText() : CXTPFlowGraphNode, CXTPPopupItem
  • SetMarquee() : CXTPMarqueeCtrl, CXTPProgressCtrl
  • SetMarqueeProgressBar() : CXTPTaskDialog
  • SetMask() : CXTPGridColumn, CXTPPropertyGridItem
  • SetMaskColor() : CXTPImageManager
  • SetMaskedText() : CXTPMaskEditT< TBase >, CXTPPropertyGridItem
  • SetMasterEventID() : CXTPCalendarRecurrencePattern
  • SetMaterialDiffuseColor() : CXTPChart3dDeviceContext
  • SetMaterialEmissionColor() : CXTPChart3dDeviceContext
  • SetMaterialShininess() : CXTPChart3dDeviceContext
  • SetMaterialSpecularColor() : CXTPChart3dDeviceContext
  • SetMax() : CXTPGaugeMeterType, CXTPPropertyGridInplaceSlider, CXTPPropertyGridInplaceSpinButton
  • SetMaxColumnWidth() : CXTPGridHeader
  • SetMaxConnections() : CXTPFlowGraphConnectionPoint
  • SetMaxHeight() : CXTPMarkupFrameworkElement, CXTPMarkupRowDefinition
  • SetMaxLength() : CXTPTrackBlock
  • SetMaxPreviewLines() : CXTPGridPaintManager
  • SetMaxSelCount() : CXTPDatePickerControl
  • SetMaxSize() : CXTPChartBubbleSeriesStyle, CXTPResize
  • SetMaxTipWidth() : CXTPToolTipContext
  • SetMaxTrackSize() : CXTPDockingPane
  • SetMaxValue() : CXTPChartAxisRange
  • SetMaxWidth() : CXTPGridColumn, CXTPMarkupColumnDefinition, CXTPMarkupFrameworkElement
  • SetMeeting() : CXTPCalendarEvent
  • SetMenu() : CXTPCommandBars
  • SetMenuBarClass() : CXTPCommandBars
  • SetMenuID() : CXTPHeaderCtrl, CXTPMDIWndTab, CXTPTabExBase
  • SetMenuTitleBar() : CXTPCommandBars
  • SetMenuTitleBarClass() : CXTPCommandBars
  • SetMergeHeight() : CXTPGridRow
  • SetMessage() : CXTPMessageBar
  • SetMilitary() : CXTPTimeEdit
  • SetMin() : CXTPGaugeMeterType, CXTPPropertyGridInplaceSlider, CXTPPropertyGridInplaceSpinButton
  • SetMinColumnWidth() : CXTPCalendarDayView
  • SetMinHeight() : CXTPMarkupFrameworkElement, CXTPMarkupRowDefinition
  • SetMinimumClientHeight() : CXTPShortcutBar, CXTPShortcutBarPane, CXTPTaskPanelGroup
  • SetMinimumColSize() : CXTPListBase
  • SetMinimumGroupClientHeight() : CXTPTaskPanel
  • SetMinimumVisibleSize() : CXTPRibbonBar
  • SetMinimumVisibleWidth() : CXTPRibbonBar
  • SetMinimumWidth() : CXTPTabToolBar
  • SetMinLength() : CXTPTrackBlock
  • SetMinorCount() : CXTPChartAxis
  • SetMinorLength() : CXTPChartAxisTickMarks
  • SetMinorThickness() : CXTPChartAxisTickMarks
  • SetMinorVisible() : CXTPChartAxisGridLines, CXTPChartAxisTickMarks
  • SetMins() : CXTPTimeEdit
  • SetMinSize() : CXTPChartBubbleSeriesStyle, CXTPFlowGraphNode, CXTPHeaderCtrl, CXTPResize
  • SetMinTrackSize() : CXTPDockingPane
  • SetMinValue() : CXTPChartAxisRange
  • SetMinWidth() : CXTPGridColumn, CXTPMarkupColumnDefinition, CXTPMarkupFrameworkElement
  • SetModelDistanceLimits() : CXTPChart3dDeviceContext
  • SetModified() : CXTPCalendarEventColorListBox, CXTPSyntaxEditPropertiesPageColor, CXTPSyntaxEditPropertiesPageEdit, CXTPSyntaxEditPropertiesPageFont
  • SetModuleHandle() : CXTPSkinManagerResourceFile
  • SetMonth() : CXTPPropertyGridItemDate
  • SetMonthDelta() : CXTPDatePickerControl
  • SetMonthName() : CXTPDatePickerControl
  • SetMouseCursorMode() : CXTPTrackControl
  • SetMouseMode() : CXTPGridControl
  • SetMouseOutOfDragArea() : CXTPCalendarDayView
  • SetMoveCursor() : CXTPSyntaxEditPaintManager
  • SetMultiColumn() : CXTPTaskPanel
  • SetMultiDayEvent_MasterSlave() : CXTPCalendarViewEvent
  • SetMultiLinesCount() : CXTPPropertyGridItem
  • SetMultipleSelection() : CXTPGridControl
  • SetMultiplSel() : CXTPControlListBox
  • SetMultiSelectionMode() : CXTPDatePickerControl, CXTPGridControl
  • SetName() : CXTPCalendarEventCategory, CXTPCalendarResource, CXTPCalendarSchedule, CXTPChartAxisStrip, CXTPChartSeries, CXTPFlowGraphConnectionPoint
  • SetNavigator() : CXTPGridControl, CXTPPropertySheet
  • SetNewColor() : CXTPColorDialog
  • SetNewItemDefaultText() : CXTPEditListBox
  • SetNewTabPosition() : CXTPTabClientWnd
  • SetNewWindowTab() : CXTPTabManagerItem
  • SetNextVisualBlock() : CXTPGridColumn
  • SetNoEndDate() : CXTPCalendarRecurrencePattern
  • SetNormalIcon() : CXTPImageManagerIcon
  • SetNotificationWnd() : CXTPTrayIcon
  • SetNotifyOnClear() : CXTPGridSelectedRows
  • SetNumber() : CXTPPropertyGridItemNumber
  • SetNumericOnly() : CXTPControlEdit
  • SetOccReminder() : CXTPCalendarRecurrencePattern
  • SetOffice2003Colors() : CXTPCaption
  • SetOffset() : CXTPFrameShadow
  • SetOffsetItem() : CXTPTaskPanelGroup
  • SetOneLine() : CXTPCalendarCaptionBarTheme
  • SetOneNoteColors() : CXTPTabPaintManager
  • SetOnQuickAccess() : CXTPControl
  • SetOpenTags() : CXTPSyntaxEditAutoCompleteWnd
  • SetOption() : CXTPPropertyGridItemOption
  • SetOptions() : CXTPBrowseDialog, CXTPDockingPane, CXTPHexEdit
  • SetOrientation() : CXTPMarkupStackPanel, CXTPMarkupWrapPanel
  • SetOriginalControls() : CXTPControls
  • SetOuterSize() : CXTPFrameShadow
  • SetOutputPoint() : CXTPFlowGraphConnection
  • SetOverlayImage() : CXTPImageList
  • SetOverType() : CXTPMaskEditT< TBase >
  • SetOverwriteFlag() : CXTPSyntaxEditBufferManager
  • SetOverwriteMode() : CXTPSyntaxEditCtrl
  • SetOwner() : CXTPBrowseDialog, CXTPCalendarCaptionBarTheme
  • SetPadding() : CXTPMarkupBorder, CXTPMarkupControl, CXTPMarkupTextBlock, CXTPStatusBarPane, CXTPTagCloudCtrl
  • SetPageBorderStyle() : CXTPPropertySheet
  • SetPageSize() : CXTPPropertySheet
  • SetPageSizeMax() : CXTPPropertySheet
  • SetPageSizeMin() : CXTPPropertySheet
  • SetPaintManager() : CXTPCalendarControl, CXTPCommandBar, CXTPCommandBars, CXTPDockingPaneTabbedContainer, CXTPFlowGraphControl, CXTPGridControl, CXTPSyntaxEditCtrl, CXTPTabClientWnd, CXTPTabControl, CXTPTabManager
  • SetPaintTheme() : CXTPCalendarCaptionBarTheme, CXTPCalendarControl, CXTPCalendarPaintManager, CXTPDatePickerControl
  • SetPane() : CXTPChartDiagram2D
  • SetPaneColorSets() : CXTPDockingPaneVisualStudio2012Theme
  • SetPaneData() : CXTPDockingPane
  • SetPaneInfo() : CXTPStatusBar
  • SetPanelDirection() : CXTPChartContent
  • SetPanelDistance() : CXTPChartContent
  • SetPanelPaintManager() : CXTPDockingPanePaintManager
  • SetPaneStyle() : CXTPStatusBar
  • SetPaneText() : CXTPStatusBar
  • SetPaneWidth() : CXTPStatusBar
  • SetParameter() : CXTPControl
  • SetParent() : CXTPControl, CXTPControlComboBox, CXTPControlEdit, CXTPControlListBox, CXTPControls
  • SetParentContainer() : CXTPDockingPane, CXTPDockingPaneBase
  • SetParseThreadPriority() : CXTPSyntaxEditLexParser
  • SetPart() : CXTPPropertyGridVerb
  • SetPassedIniSet() : CXTPSyntaxEditCtrl
  • SetPasswordMask() : CXTPPropertyGridItem
  • SetPattern() : CXTPChartNumberFormat, CXTPEdit
  • SetPatternEnd() : CXTPCalendarRecurrencePattern
  • SetPatternEndDate() : CXTPCalendarRecurrencePattern
  • SetPatternID() : CXTPCalendarRecurrencePattern
  • SetPatternStartDate() : CXTPCalendarRecurrencePattern
  • SetPidlRoot() : CXTPBrowseDialog
  • SetPlusMinus() : CXTPGridColumn
  • SetPoint() : CXTPPoint2T< T >, CXTPPoint3T< T >, CXTPPropertyGridItemPoint
  • SetPointDistance() : CXTPChartFunnelSeriesStyleBase, CXTPChartPyramidSeriesStyleBase
  • SetPointLegendFormat() : CXTPChartSeries
  • SetPoints() : CXTPChartSeries
  • SetPopupAnimation() : CXTPPopupControl
  • SetPopupBarClass() : CXTPCommandBars
  • SetPopuped() : CXTPCommandBar
  • SetPopupFlags() : CXTPPopupBar
  • SetPopupPos() : CXTPPopupControl
  • SetPopupSize() : CXTPPopupControl
  • SetPopupState() : CXTPPopupControl
  • SetPopupToolBar() : CXTPPopupBar
  • SetPopupToolBarClass() : CXTPCommandBars
  • SetPOS() : XTP_CALENDAR_MONTHVIEW_DAYPOS
  • SetPos() : CXTPControlScrollBar, CXTPControlSlider, CXTPPageScroller, CXTPProgressBase, CXTPStatusBarScrollBarPane
  • SetPosition() : CXTPChartFunnelSeriesLabelBase, CXTPChartPieSeriesLabelBase, CXTPChartPyramidSeriesLabelBase, CXTPCommandBar, CXTPTabManager, CXTPTabPaintManager, CXTPToolBar, CXTPTrackBlock, CXTPTrackMarker
  • SetPositionInternally() : CXTPSyntaxEditCommand
  • SetPressed() : CXTPControl
  • SetPressedIcon() : CXTPImageManagerIcon
  • SetPreviewIndent() : CXTPGridPaintManager
  • SetPreviewItem() : CXTPGridRecord
  • SetPreviewText() : CXTPGridRecordItemPreview
  • SetPrintGroupRowIcon() : CXTPGridPaintManager
  • SetPrivate() : CXTPCalendarEvent
  • SetProgressBarPos() : CXTPTaskDialog
  • SetProgressBarRange() : CXTPTaskDialog
  • SetProgressBarState() : CXTPTaskDialog
  • SetPrompt() : CXTPControl, CXTPControlAction, CXTPPropertyGridItem
  • SetPromptChar() : CXTPMaskEditT< TBase >
  • SetProperty() : CXTPCalendarCustomProperties, CXTPWebBrowserCtrl
  • SetPropertyBool() : CXTPSkinManagerSchemaProperty
  • SetPropertyColor() : CXTPSkinManagerSchemaProperty
  • SetPropertyEnum() : CXTPSkinManagerSchemaProperty
  • SetPropertyFont() : CXTPSkinManagerSchemaProperty
  • SetPropertyInt() : CXTPSkinManagerSchemaProperty
  • SetPropertyRect() : CXTPSkinManagerSchemaProperty
  • SetPropertySize() : CXTPSkinManagerSchemaProperty
  • SetPropertySort() : CXTPPropertyGrid
  • SetPropertyString() : CXTPSkinManagerSchemaProperty
  • SetProviderType() : CXTPWebBrowserCtrl
  • SetPtr() : CXTPSmartPtrInternalT< _TObject >
  • SetPushButtonStyle() : CXTPButton
  • SetQuickAccessEmptyIconId() : CXTPRibbonBar
  • SetQuickCustomizeMode() : CXTPCommandBars
  • SetRange() : CXTPControlScrollBar, CXTPControlSlider, CXTPDatePickerControl, CXTPProgressBase, CXTPStatusBarScrollBarPane
  • SetReadOnly() : CXTPControlEdit, CXTPPropertyGridItem, CXTPPropertyGridItemFlags, CXTPSyntaxEditCtrl
  • SetReadOnlyBackColor() : CXTPSyntaxEditPaintManager
  • SetRecentColors() : CXTPColorSelectorCtrl
  • SetRecord() : CXTPGridRecordItem
  • SetRecordsTreeFilterMode() : CXTPGridControl
  • SetRect() : CXTPControl, CXTPControlComboBox, CXTPControlCustom, CXTPControlEdit, CXTPControlListBox, CXTPControlTabWorkspace, CXTPDatePickerItemDay, CXTPDockingPaneCaptionButton, CXTPFlowGraphConnectionPoint, CXTPGridRecordItemControl, CXTPRectT< T >, CXTPRibbonGroup, CXTPTabManagerItem, CXTPTabManagerNavigateButton
  • SetRecurrenceOptions() : CXTPCalendarRecurrencePattern
  • SetRecurrencePatternID() : CXTPCalendarEvent
  • SetRecurrenceState_ExceptionOccurrence() : CXTPCalendarEvent
  • SetRecurrenceState_Master() : CXTPCalendarEvent
  • SetRecurrenceState_NotRecurring() : CXTPCalendarEvent
  • SetRegisterAsDropTarget() : CXTPShellExplorerProvider
  • SetRegistryKey() : CXTPRegistryManager
  • SetReminder() : CXTPCalendarEvent
  • SetReminderMinutesBeforeStart() : CXTPCalendarEvent
  • SetRemindersManager() : CXTPCalendarRemindersDialog
  • SetReminderSoundFile() : CXTPCalendarEvent
  • SetResizable() : CXTPControlGallery, CXTPDialogBar, CXTPPropertySheet
  • SetResize() : CXTPResize, CXTPSearchOptionsView
  • SetResourceFile() : CXTPResourceManager, CXTPSkinManager
  • SetResourceFontCharset() : CXTPResourceManager
  • SetResourceHandle() : CXTPResourceManager
  • SetResourceManager() : CXTPResourceManager
  • SetResourceModule() : CXTPGaugeTraits
  • SetResourcePath() : CXTPGaugeTraits
  • SetResources() : CXTPCalendarControl, CXTPCalendarView, CXTPCalendarViewDay, CXTPCalendarViewGroup
  • SetReversed() : CXTPChartAxis
  • SetRException_EndTimeOrig() : CXTPCalendarEvent
  • SetRException_StartTimeOrig() : CXTPCalendarEvent
  • SetRExceptionDeleted() : CXTPCalendarEvent
  • SetRibbonDividerIndex() : CXTPStatusBar
  • SetRibbonMinimized() : CXTPRibbonBar
  • SetRibbonPaintManager() : CXTPRibbonTheme
  • SetRight() : CXTPGridThickness
  • SetRightButtonDrag() : CXTPSyntaxEditCtrl
  • SetRightDirected() : CXTPChart3dFunnelSeriesLabelView, CXTPChart3dPieSeriesLabelView, CXTPChart3dPyramidSeriesLabelView
  • SetRootFolder() : CXTPShellTreeBase
  • SetRotation() : CXTPChartPieSeriesStyleBase
  • SetRoundRectRegion() : CXTPRibbonTheme
  • SetRow() : CXTPMarkupGrid
  • SetRowBkColor() : CXTPSyntaxEditCtrl
  • SetRowColor() : CXTPListBase, CXTPSyntaxEditCtrl
  • SetRowColors() : CXTPListBase
  • SetRowRect() : CXTPControl
  • SetRows() : CXTPMarkupUniformGrid
  • SetRowsCompareFunc() : CXTPGridControl
  • SetRowSpan() : CXTPMarkupGrid
  • SetRowTabPositions() : CXTPSyntaxEditDrawTextProcessor
  • SetRowText() : CXTPSyntaxEditCtrl
  • SetRowValid() : CXTPSyntaxEditCtrl
  • SetRTFText() : CXTPPopupItem
  • SetSaturation() : CXTPColorWnd
  • SetScaleInterval() : CXTPCalendarDayView, CXTPCalendarTLV_TimeScaleParams
  • SetScaleMaxTime() : CXTPCalendarDayView
  • SetScaleMinTime() : CXTPCalendarDayView
  • SetScaleText() : CXTPCalendarDayView
  • SetScaleX() : CXTPMarkupScaleTransform
  • SetScaleY() : CXTPMarkupScaleTransform
  • SetScheduleID() : CXTPCalendarEvent
  • SetScheduleName() : CXTPCalendarSchedules
  • SetScheduleSet() : CXTPCalendarEvent
  • SetSchema() : CXTPPropExchange
  • SetScriptErrorsSuppressed() : CXTPShellExplorerProvider
  • SetScrollBarAuto() : CXTPControlGallery
  • SetScrollBarClass() : CXTPScrollBarContainer< Parent >
  • SetScrollBarCtrl() : CXTPCalendarControlView, CXTPGridView
  • SetScrollBars() : CXTPSyntaxEditCtrl, CXTPSyntaxEditView
  • SetScrollBarStyle() : CXTPScrollBase, CXTPShellExplorerProvider
  • SetScrollBarTheme() : CXTPScrollable< Base >, CXTPScrollBarContainer< Parent >
  • SetScrollDateButtons() : CXTPCalendarCaptionBarTheme
  • SetScrollIndexV() : CXTPGridSection
  • SetScrollInfo() : CXTPSyntaxEditCtrl
  • SetScrollMode() : CXTPGridControl
  • SetScrollOffset() : CXTPFlowGraphPage
  • SetScrollOffsetH() : CXTPGridControl
  • SetScrollOffsetV() : CXTPGridControl, CXTPGridSection
  • SetScrollPos() : CXTPControlGallery, CXTPRibbonBackstageView, CXTPSyntaxEditCtrl
  • SetScrollRange() : CXTPSyntaxEditCtrl
  • SetScrollXOffset() : CXTPSyntaxEditDrawTextProcessor
  • SetSearchHistoryCountMax() : CXTPSyntaxEditFindReplaceDlg
  • SetSel() : CXTPHexEdit
  • SetSelColor() : CXTPSyntaxEditColorComboBox
  • SetSelected() : CXTPCalendarMonthViewDay, CXTPCalendarViewDay, CXTPCalendarViewEvent, CXTPCommandBar, CXTPGridRow, CXTPMouseManager, CXTPPopupBar, CXTPShortcutBarItem
  • SetSelectedColor() : CXTPColorHex
  • SetSelectedItem() : CXTPControlGallery, CXTPRibbonControlTab, CXTPTabControl, CXTPTabManager, CXTPTabToolBar, CXTPTaskPanelGroup
  • SetSelection() : CXTPCalendarView, CXTPFlowGraphSelectedElements
  • SetSelectionCheck() : CXTPCheckListBox
  • SetSelectionState() : CXTPGridControl
  • SetSelectItemOnFocus() : CXTPTaskPanel
  • SetSelFont() : CXTPFontCtrlBase
  • SetSelMargin() : CXTPSyntaxEditCtrl, CXTPSyntaxEditView
  • SetSelPath() : CXTPBrowseDialog
  • SetSelRange() : CXTPDatePickerControl
  • SetSelTabBackColor() : CXTPExcelTabCtrl
  • SetSelTabTextColor() : CXTPExcelTabCtrl
  • SetShadow() : CXTPShadowManager
  • SetShadowColor() : CXTPShadowManager
  • SetShadowOptions() : CXTPShadowManager
  • SetShortcutManager() : CXTPCommandBars
  • SetShortcutText() : CXTPControl, CXTPControlAction
  • SetShowAllDayEventsDownScrollButton() : CXTPCalendarDayViewGroup
  • SetShowAllDayEventsUpScrollButton() : CXTPCalendarDayViewGroup
  • SetShowAlways() : CXTPPropertyGridInplaceButton
  • SetShowContentsWhileDragging() : CXTPDockingPaneManager, CXTPTabClientContext
  • SetShowDaysAfter() : CXTPDatePickerItemMonth
  • SetShowDaysBefore() : CXTPDatePickerItemMonth
  • SetShowDelay() : CXTPPopupControl
  • SetShowDockingContextStickers() : CXTPDockingPaneManager
  • SetShowFocus() : CXTPButton
  • SetShowGripper() : CXTPCommandBar
  • SetShowInFieldChooser() : CXTPGridColumn
  • SetShowInplaceButtonsAlways() : CXTPPropertyGrid
  • SetShowInTaskBar() : CXTPCalendarRemindersDialog
  • SetShowLines() : CXTPChartSeriesLabel
  • SetShowNonMonthDays() : CXTPDatePickerControl
  • SetShowScrolling() : CXTPDatePickerItemMonth
  • SetShowTabClientContextStickers() : CXTPTabClientContext
  • SetShowWeekNumbers() : CXTPDatePickerControl
  • SetShowZeroLevel() : CXTPChartAxisRange
  • SetSideDockingMargin() : CXTPDockingPaneManager
  • SetSideMargins() : CXTPChartAxisRange
  • SetSingleSelection() : CXTPShortcutBar, CXTPTaskPanel
  • SetSite() : CXTPCommandBars
  • SetSize() : CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE >, CXTPCalendarEvents, CXTPCalendarPtrCollectionT< _TObject >, CXTPControlCustom, CXTPControlGalleryItem, CXTPDialogBar, CXTPFlowGraphNode, CXTPFlowGraphNodeCustom, CXTPGridRecordItemControl, CXTPGridRecords, CXTPPropertyGridItemSize, CXTPSvgImage, CXTPTaskPanelGroupItem
  • SetSizeCore() : CXTPFlowGraphNode
  • SetSizeEmpty() : CXTPEmptySize
  • SetSkinManager() : CXTPSkinManager
  • SetSliderCtrl() : CXTPGridView
  • SetSliderStyle() : CXTPControlSlider
  • SetSlotNumber() : CXTPCalendarDayViewEvent
  • SetSmallDayHeaderFormat() : CXTPCalendarControl, CXTPCalendarMonthView
  • SetSmoothingMode() : CXTPFlowGraphControl
  • SetSortable() : CXTPGridColumn
  • SetSortBackColor() : CXTPListBase
  • SetSortColumn() : CXTPGridColumns
  • SetSortDirection() : CXTPChartLegend
  • SetSortImage() : CXTPHeaderCtrl, CXTPListBase
  • SetSortIncreasing() : CXTPGridColumn
  • SetSortOrder() : CXTPTagCloudCtrl
  • SetSortPriority() : CXTPGridRecordItem
  • SetSortRecordChilds() : CXTPGridControl
  • SetSortTextColor() : CXTPListBase
  • SetSource() : CXTPMarkupImage
  • SetSpecialGroup() : CXTPTaskPanelGroup
  • SetSpinButtonMax() : CXTPGridInplaceButton
  • SetSpinButtonMin() : CXTPGridInplaceButton
  • SetSpinButtonStep() : CXTPGridInplaceButton
  • SetSplashScreenMode() : CXTPPopupControl
  • SetSplitterStyle() : CXTPDockingPanePaintManager
  • SetStandardColors() : CXTPColorPicker, CXTPColorSelectorCtrl, CXTPPropertyGrid
  • SetStandardFont() : CXTPPaintManagerFont
  • SetStandardValue() : CXTPCalendarThemeCustomizableXValueT< _TValue, _TValueRef >, CXTPCalendarThemeFontValue, CXTPCalendarViewPartCustomizableValueT< _TValue >, CXTPCalendarViewPartFontValue, CXTPPaintManagerColor, CXTPPaintManagerColorGradient
  • SetStart_disp() : CXTPSyntaxEditSelection
  • SetStart_str() : CXTPSyntaxEditSelection
  • SetStartArcBallRotationPoint() : CXTPChart3dDiagram
  • SetStartTime() : CXTPCalendarEvent, CXTPCalendarRecurrencePattern
  • SetStartViewDate() : CXTPCalendarTimeLineView, CXTPCalendarTimeLineViewTimeScale
  • SetState() : CXTPCalendarCaptionBarThemePart, CXTPDockingPaneCaptionButton, CXTPGaugeStateType, CXTPGridRecordItemControl
  • SetStateColor() : CXTPCommandBarsNativeWindows10Theme, CXTPCommandBarsNativeWindows11Theme, CXTPCommandBarsVisualStudio2015Theme, CXTPCommandBarsVisualStudio2017Theme, CXTPCommandBarsVisualStudio2019Theme, CXTPCommandBarsVisualStudio2022Theme, CXTPStatusBarThemeNativeWindows10, CXTPStatusBarThemeNativeWindows11, CXTPStatusBarThemeVisualStudio2015, CXTPStatusBarThemeVisualStudio2017, CXTPStatusBarThemeVisualStudio2019, CXTPStatusBarThemeVisualStudio2022
  • SetStaticText() : CXTPShellExplorerProvider
  • SetStatusText() : CXTPCommandBar
  • SetStickyFloatingFrames() : CXTPDockingPaneManager
  • SetStoredWidth() : CXTPListBase
  • SetStretch() : CXTPMarkupImage, CXTPMarkupViewbox
  • SetString() : CXTPHeapString
  • SetStyle() : CXTPChartSeries, CXTPControl, CXTPFlowGraphConnection, CXTPFlowGraphConnectionPoint, CXTPFlowGraphNode, CXTPStatusBarPane, CXTPToolTipContext
  • SetStyleEx() : CXTPControlButton
  • SetSubject() : CXTPCalendarEvent
  • SetSubListCtrl() : CXTPGridHeader
  • SetSwitches() : CXTPStatusBarSwitchPane
  • SetSwitchViewButtons() : CXTPCalendarCaptionBarTheme
  • SetSyncWnd() : CXTPShellListCtrlEx
  • SetSyntaxAndColorScheme() : CXTPSyntaxEditConfigurationManager, CXTPSyntaxEditCtrl
  • SetSyntaxColor() : CXTPSyntaxEditCtrl, CXTPSyntaxEditView
  • SetTabBackColor() : CXTPExcelTabCtrl
  • SetTabCaption() : CXTPDockingPane
  • SetTabClient() : CXTPTabClientContext
  • SetTabFonts() : CXTPExcelTabCtrl
  • SetTabHeight() : CXTPExcelTabCtrl
  • SetTabHighlightColor() : CXTPExcelTabCtrl
  • SetTabIcon() : CXTPMDIWndTab
  • SetTabImageList() : CXTPTabView
  • SetTabLabel() : CXTPMDIWndTab
  • SetTabPaintManager() : CXTPDockingPanePaintManager
  • SetTabShadowColor() : CXTPExcelTabCtrl
  • SetTabSize() : CXTPSyntaxEditBufferManager, CXTPSyntaxEditCtrl, CXTPSyntaxEditDrawTextProcessor
  • SetTabStyle() : CXTPExcelTabCtrl
  • SetTabsVisible() : CXTPRibbonBar
  • SetTabText() : CXTPTabExBase
  • SetTabTextColor() : CXTPExcelTabCtrl
  • SetTabWithSpace() : CXTPSyntaxEditCtrl
  • SetTabWorkspace() : CXTPTabClientWnd
  • SetTag() : CXTPControl, CXTPControlAction, CXTPFlowGraphNode, CXTPMarkupFrameworkElement
  • SetTearOffPopup() : CXTPPopupBar
  • SetTemporary() : CXTPToolBar
  • SetText() : CXTPCalendarCaptionBarThemePart, CXTPChartAxisConstantLine, CXTPChartAxisCustomLabel, CXTPChartAxisTitle, CXTPChartTitle, CXTPGridFilterEditControl, CXTPMarkupTextBlock, CXTPStatusBarPane, CXTPSyntaxEditCtrl
  • SetTextAlignment() : CXTPButton, CXTPMarkupTextBlock, CXTPPopupItem, CXTPStatusBarPane
  • SetTextColor() : CXTPCalendarViewPart, CXTPChartAxisConstantLine, CXTPChartAxisLabel, CXTPChartAxisTitle, CXTPChartLegend, CXTPChartSeriesLabel, CXTPChartTitle, CXTPComboBox, CXTPComboBoxTheme, CXTPGridRecordItem, CXTPHexEdit, CXTPPopupItem, CXTPProgressCtrl, CXTPProgressCtrlPaintManager, CXTPStatusBarPane, CXTPSyntaxEditColorSampleText, CXTPSyntaxEditPaintManager, CXTPTabColorSetOffice2013, CXTPTabColorSetVisualStudio2010, CXTPTabColorSetVisualStudio2015, CXTPTabPaintManagerColorSet, CXTPTaskDialogLinkCtrl, CXTPTaskPanelGroupItem
  • SetTextDecoration() : CXTPGridHyperlinkStyle
  • SetTextDecorations() : CXTPMarkupTextBlock
  • SetTextFont() : CXTPCalendarViewPart, CXTPGridPaintManager, CXTPPopupItem, CXTPStatusBarPane
  • SetTextFormat() : CXTPTaskPanelPaintManager
  • SetTextGrayColor() : CXTPStatusBarPane
  • SetTextImageRelation() : CXTPButton
  • SetTextLimit() : CXTPControlComboBox, CXTPControlEdit
  • SetTextLinkColor() : CXTPTaskDialogLinkCtrl
  • SetTextOrientation() : CXTPCommandBar
  • SetTextOutOfBorders() : CXTPCalendarViewEvent
  • SetTextRect() : CXTPSyntaxEditDrawTextProcessor, CXTPTaskPanelItem
  • SetTextSchema() : CXTPSyntaxEditLexParser
  • SetTextTabStopPositions() : CXTPTipWindow
  • SetTextTrimming() : CXTPMarkupTextBlock
  • SetTextWrapping() : CXTPMarkupTextBlock
  • SetTheme() : CXTPButton, CXTPCalendarCaptionBarControl, CXTPCalendarControl, CXTPCalendarTip, CXTPCaption, CXTPCaptionButton, CXTPCaptionPopupWnd, CXTPColorSelectorCtrl, CXTPComboBox, CXTPCommandBars, CXTPControlTheme, CXTPDatePickerControl, CXTPDockingPaneManager, CXTPEdit, CXTPEditListBoxToolBar, CXTPExcelTabCtrl, CXTPGridView, CXTPHeaderCtrl, CXTPListBox, CXTPMarqueeCtrl, CXTPPaintManager, CXTPPopupControl, CXTPProgressCtrl, CXTPPropertyGrid, CXTPPropertyPageNavigator, CXTPPropertySheet, CXTPRibbonBackstageView, CXTPScrollBar, CXTPScrollBarCtrl, CXTPShortcutBar, CXTPShortcutListBox, CXTPSpinButtonCtrl, CXTPSplitterWnd, CXTPSyntaxEditConfigurationManager, CXTPSyntaxEditTextSchemesManager, CXTPTabBase, CXTPTaskPanel
  • SetThemeAppProperties() : CXTPWinThemeWrapper
  • SetThemeColors() : CXTPColorPicker, CXTPColorSelectorCtrl
  • SetThemed() : CXTPGridRecordItemControl
  • SetThemeWrapperPtr() : CXTPWinThemeWrapper
  • SetThickness() : CXTPChartAxis, CXTPChartAxisTickMarks, CXTPChartBorder, CXTPChartLineStyle
  • SetThinSplitter() : CXTPPropertyGridPaintManager
  • SetThreeState() : CXTPMarkupToggleButton
  • SetThumbWidth() : CXTPControlComboBox
  • SetTicks() : CXTPScrollBase, CXTPStatusBarSliderPane
  • SetTime() : CXTPTimeEdit
  • SetTime_235959() : CXTPCalendarUtils
  • SetTimeLinePosition() : CXTPTrackControl
  • SetTimeLineRange() : CXTPTrackControl
  • SetTimer() : CXTPCalendarControl, CXTPCalendarView, CXTPCalendarViewDay, CXTPCalendarViewEvent, CXTPCalendarViewGroup, CXTPTrayIcon
  • SetTimeScaleID() : CXTPCalendarTimeLineView
  • SetTimeScaleParams() : CXTPCalendarTimeLineViewTimeScale
  • SetTimeScaleParams2() : CXTPCalendarTimeLineViewTimeScale
  • SetTimeshift() : CXTPCalendarDayViewTimeScale
  • SetTipBkColor() : CXTPToolTipContext
  • SetTipColors() : CXTPTipWindow
  • SetTipOffsetPos() : CXTPTipWindow
  • SetTips() : CXTPTabExBase
  • SetTipsFilePath() : CXTPTipOfTheDay
  • SetTipText() : CXTPExcelTabCtrl, CXTPHyperLink, CXTPTipOfTheDay, CXTPTipWindow
  • SetTipTextColor() : CXTPToolTipContext
  • SetTitle() : CXTPBrowseDialog, CXTPCommandBar, CXTPDockingPane, CXTPPropertySheet
  • SetTitleToolTip() : CXTPDockingPane
  • SetToday() : CXTPDatePickerControl
  • SetTodayDateOverride() : CXTPCalendarControl
  • SetToolBarClass() : CXTPCommandBars
  • SetToolBarFocus() : CXTPCommandBars
  • SetToolTip() : CXTPControlGalleryItem
  • SetTooltip() : CXTPButton, CXTPControl, CXTPControlAction, CXTPFlowGraphConnection, CXTPFlowGraphConnectionPoint, CXTPFlowGraphNode, CXTPGridColumn, CXTPGridRecordItem, CXTPPropertyGridInplaceButton, CXTPPropertyGridItem, CXTPShortcutBarItem, CXTPStatusBarPane, CXTPTabManagerItem, CXTPTabManagerNavigateButton, CXTPTaskPanelItem, CXTPTrackBlock, CXTPTrayIcon
  • SetToolTipCtrl() : CXTPToolTipContext
  • SetTooltipPart() : CXTPStatusBarScrollBarPane
  • SetTooltipRect() : CXTPGridTip
  • SetToolTips() : CXTPTabView
  • SetTooltipText() : CXTPCalendarTip, CXTPChartSeriesPoint, CXTPGridTip, CXTPTrayIcon
  • SetTop() : CXTPGridThickness
  • SetTopIndex() : CXTPControlGallery, CXTPPropertyGrid
  • SetTopRow() : CXTPGridControl, CXTPSyntaxEditCtrl, CXTPSyntaxEditView
  • SetTorus() : CXTPChart3dPieSeriesStyle
  • SetTrack() : CXTPMouseManager
  • SetTrackFocus() : CXTPCommandBar
  • SetTracking() : CXTPExcelTabCtrl
  • SetTrackingMode() : CXTPCommandBar, CXTPControlComboBoxList, CXTPPopupBar, CXTPRibbonBackstageView, CXTPRibbonTabPopupToolBar
  • SetTrait() : CXTPGaugeBaseType
  • SetTraits() : CXTPGaugeTraits
  • SetTraitsArgument() : CXTPGaugeTraits
  • SetTransparency() : CXTPChartAreaSeriesStyle, CXTPChartRadarAreaSeriesStyle, CXTPChartSeriesLabel, CXTPChartSeriesStyle, CXTPFrameShadow, CXTPPopupControl
  • SetTrayIcon() : CXTPTrayIcon
  • SetTreeColumn() : CXTPGridColumn
  • SetTreeIndent() : CXTPGridControl
  • SetTrueFalseText() : CXTPPropertyGridItemBool
  • SetTwipSize() : CXTPControlSizeComboBox
  • SetTxtOffset() : CXTPSyntaxEditTextIterator
  • SetType() : CXTPFlowGraphConnectionPoint, CXTPTaskPanelItem
  • SetUnderline() : CXTPHyperLink, CXTPPopupItem
  • SetupCallWndProcHook() : CXTPKeyboardManager
  • SetUpdateWindow() : CXTPChartControl
  • SetupDefaultMarkupTemplates() : CXTPFlowGraphControl
  • SetupHook() : CXTPMenuBar
  • SetupKeyboardHook() : CXTPKeyboardManager
  • SetupMenu() : CXTPMenuBar
  • SetupStartCol() : CXTPGridView
  • SetURL() : CXTPHyperLink
  • SetUseComCtl32() : CXTPTaskDialog
  • SetUseCustomToolTipPosition() : CXTPMarkupContext
  • SetUseMask() : CXTPMaskEditT< TBase >
  • SetUserColor() : CXTPSyntaxEditColorComboBox
  • SetUseResourceFileLocale() : CXTPChartNumberFormat, CXTPGridControlLocale
  • SetUseSysIcons() : CXTPTaskDialog
  • SetUseThousandSeparator() : CXTPChartNumberFormat
  • SetUseVisualStyle() : CXTPButton, CXTPComboBox, CXTPEdit, CXTPProgressCtrl, CXTPScrollBar, CXTPSpinButtonCtrl
  • SetValue() : CXTPActiveScriptObjectContext, CXTPChartColor, CXTPChartSeriesPoint, CXTPGridRecordItemDateTime, CXTPGridRecordItemNumber, CXTPGridRecordItemText, CXTPGridRecordItemVariant, CXTPMarkupStaticExtensionBooleanProperty, CXTPMarkupStaticExtensionBrushProperty, CXTPMarkupStaticExtensionColorProperty, CXTPMarkupStaticExtensionDoubleProperty, CXTPMarkupStaticExtensionIntegerProperty, CXTPMarkupStaticExtensionProperty, CXTPMarkupStaticExtensionStringProperty, CXTPPropertyGridInplaceEdit, CXTPPropertyGridItem, CXTPPropertyGridItemBool, CXTPPropertyGridItemColor, CXTPPropertyGridItemDate, CXTPPropertyGridItemDouble, CXTPPropertyGridItemEnum, CXTPPropertyGridItemFlags, CXTPPropertyGridItemNumber, CXTPPropertyGridItemOption, CXTPStatusBarPane
  • SetValueLength() : CXTPChartSeriesPoint
  • SetValueScaleType() : CXTPChartSeries
  • SetValueText() : CXTPPropertyGridItemBool
  • SetVariable() : CXTPSyntaxEditLexVariable, CXTPSyntaxEditLexVariant
  • SetVariableHelpHeight() : CXTPPropertyGrid
  • SetVariableItemsHeight() : CXTPPropertyGrid
  • SetVariableSplitterPos() : CXTPPropertyGrid
  • SetVectorCheckedIcon() : CXTPImageManagerIcon, CXTPImageManagerIconSet
  • SetVectorDisabledIcon() : CXTPImageManagerIcon, CXTPImageManagerIconSet
  • SetVectorHotIcon() : CXTPImageManagerIcon, CXTPImageManagerIconSet
  • SetVectorIcon() : CXTPImageManager, CXTPImageManagerIcon, CXTPImageManagerIconSet
  • SetVectorIconSize() : CXTPToolTipContext
  • SetVectorPressedIcon() : CXTPImageManagerIcon, CXTPImageManagerIconSet
  • SetVerbsHeight() : CXTPPropertyGrid
  • SetVerificationText() : CXTPTaskDialog
  • SetVerifyCheckState() : CXTPTaskDialog
  • SetVerticalAlignment() : CXTPChartLegend, CXTPMarkupFrameworkElement, CXTPTrackBlock
  • SetVerticalPositionOption() : CXTPControlCustom
  • SetViewAutoRange() : CXTPChartAxisRange
  • SetViewDivider() : CXTPPropertyGrid
  • SetViewDividerPos() : CXTPPropertyGrid
  • SetViewMaxValue() : CXTPChartAxisRange
  • SetViewMinValue() : CXTPChartAxisRange
  • SetViewOnly() : CXTPSyntaxEditCtrl
  • SetViewPort() : CXTPTrackControl
  • SetVirtualMode() : CXTPGridControl, CXTPGridRows
  • SetVisibility() : CXTPMarkupUIElement
  • SetVisible() : CXTPCalendarCaptionBarThemePart, CXTPCalendarDayViewTimeScale, CXTPChartAxis, CXTPChartAxisConstantLine, CXTPChartAxisGridLines, CXTPChartAxisLabel, CXTPChartAxisStrip, CXTPChartAxisTickMarks, CXTPChartAxisTitle, CXTPChartLegend, CXTPChartSeries, CXTPChartSeriesLabel, CXTPChartTitle, CXTPCommandBar, CXTPControl, CXTPControlAction, CXTPFlowGraphNode, CXTPGridColumn, CXTPGridRecord, CXTPGridRow, CXTPGridSection, CXTPPropertyGridItem, CXTPRibbonBar, CXTPRibbonGroup, CXTPRibbonTab, CXTPShortcutBarItem, CXTPStatusBarPane, CXTPTabManagerItem, CXTPTaskPanelItem, CXTPToolBar
  • SetVisibleNodesWindowsRegions() : CXTPFlowGraphPage
  • SetVisited() : CXTPHyperLink
  • SetWatermarkAlignment() : CXTPGridControl
  • SetWatermarkBitmap() : CXTPGridControl
  • SetWeeksCount() : CXTPCalendarMonthView::CMonthViewGrid
  • SetWideCaret() : CXTPSyntaxEditCtrl
  • SetWidth() : CXTPCommandBar, CXTPControl, CXTPControlListBox, CXTPControlStatic, CXTPFlowGraphConnection, CXTPGridColumn, CXTPGridRecordItemControl, CXTPMarkupColumnDefinition, CXTPMarkupFrameworkElement, CXTPPropertyGridInplaceButton, CXTPStatusBarPane, CXTPTaskDialog
  • SetWindowFilter() : CXTPSkinManager
  • SetWindowHandle() : CXTPFlowGraphNode, CXTPFlowGraphNodeCustom
  • SetWindowIcon() : CXTPWindowList
  • SetWindowPos() : CXTPGridHeaderDropWnd
  • SetWindowRect() : CXTPDockingPane
  • SetWindowSize() : CXTPFlowGraphNode, CXTPFlowGraphNodeCustom
  • SetWindowText() : CXTPGridInplaceEdit
  • SetWindowTextEx() : CXTPCommandBarEditCtrl
  • SetWindowTheme() : CXTPSkinManager, CXTPWinThemeWrapper
  • SetWindowTitle() : CXTPTaskDialog
  • SetWndWidth() : CXTPSyntaxEditAutoCompleteWnd
  • SetWorkArea() : CXTPTrackControl
  • SetWorkDayEndTime() : CXTPCalendarControl
  • SetWorkDayStartTime() : CXTPCalendarControl
  • SetWorkWeekMask() : CXTPCalendarControl
  • SetWrap() : CXTPControl
  • SetX() : CXTPMarkupTranslateTransform
  • SetY() : CXTPMarkupTranslateTransform
  • SetYear() : CXTPPropertyGridItemDate
  • SetZero() : CXTPMatrix< T >
  • SetZoomLevel() : CXTPFlowGraphControl, CXTPFlowGraphPage
  • SetZoomRange() : CXTPFlowGraphControl
  • SetZoomState() : CXTPPreviewView
  • SEventTimeFormatInfo() : CXTPCalendarView::SEventTimeFormatInfo
  • ShadeGroupHeadings() : CXTPGridControl
  • ShellExplorer_OnBeforeNavigate2() : IXTPWebBrowserEventSink
  • ShellExplorer_OnCommandStateChange() : IXTPWebBrowserEventSink
  • ShellExplorer_OnDocumentComplete() : IXTPWebBrowserEventSink
  • ShellExplorer_OnDownloadBegin() : IXTPWebBrowserEventSink
  • ShellExplorer_OnDownloadComplete() : IXTPWebBrowserEventSink
  • ShellExplorer_OnFullScreen() : IXTPWebBrowserEventSink
  • ShellExplorer_OnMenuBar() : IXTPWebBrowserEventSink
  • ShellExplorer_OnNavigateComplete2() : IXTPWebBrowserEventSink
  • ShellExplorer_OnNavigateError() : IXTPWebBrowserEventSink
  • ShellExplorer_OnNewWindow2() : IXTPWebBrowserEventSink
  • ShellExplorer_OnProgressChange() : IXTPWebBrowserEventSink
  • ShellExplorer_OnPropertyChange() : IXTPWebBrowserEventSink
  • ShellExplorer_OnQuit() : IXTPWebBrowserEventSink
  • ShellExplorer_OnSetSecureLockIcon() : IXTPWebBrowserEventSink
  • ShellExplorer_OnStatusBar() : IXTPWebBrowserEventSink
  • ShellExplorer_OnStatusTextChange() : IXTPWebBrowserEventSink
  • ShellExplorer_OnTheaterMode() : IXTPWebBrowserEventSink
  • ShellExplorer_OnTitleChange() : IXTPWebBrowserEventSink
  • ShellExplorer_OnToolBar() : IXTPWebBrowserEventSink
  • ShellExplorer_OnVisible() : IXTPWebBrowserEventSink
  • ShellExplorer_OnWindowClosing() : IXTPWebBrowserEventSink
  • ShellExplorer_OnWindowSetHeight() : IXTPWebBrowserEventSink
  • ShellExplorer_OnWindowSetLeft() : IXTPWebBrowserEventSink
  • ShellExplorer_OnWindowSetResizable() : IXTPWebBrowserEventSink
  • ShellExplorer_OnWindowSetTop() : IXTPWebBrowserEventSink
  • ShellExplorer_OnWindowSetWidth() : IXTPWebBrowserEventSink
  • ShellNotify() : CXTPTrayIcon
  • ShellOpenItem() : CXTPShellListBase
  • ShiftCurrentVisibleRowDown() : CXTPSyntaxEditCtrl
  • ShiftCurrentVisibleRowUp() : CXTPSyntaxEditCtrl
  • ShiftDate() : CXTPDatePickerControl
  • ShiftDate_Month() : CXTPCalendarUtils
  • ShiftDate_Year() : CXTPCalendarUtils
  • ShiftDateToCell_00() : CXTPCalendarMonthView::CMonthViewGrid
  • ShiftDateToWeekBegin() : CXTPCalendarUtils
  • ShiftTreeIndent() : CXTPGridRow
  • ShouldSerializeBar() : CXTPMenuBar, CXTPToolBar
  • ShouldSerializeControl() : CXTPControls, CXTPRibbonControls
  • Show() : CXTPFrameShadow, CXTPPopupControl, CXTPSyntaxEditAutoCompleteWnd
  • ShowActiveItemOnTop() : CXTPShortcutBar
  • ShowAdditionalScale() : CXTPCalendarDayView
  • ShowAllFiles() : CXTPShellSettings
  • ShowAttributes() : CXTPShellSettings
  • ShowBalloonTip() : CXTPTrayIcon
  • ShowBorder() : CXTPEdit
  • ShowBorders() : CXTPControlGallery, CXTPStatusBarPane
  • ShowBuddyButton() : CXTPControlEdit
  • ShowButtons() : CXTPTabBaseTheme
  • ShowCalendarPopup() : CXTPCalendarTimeLineView
  • ShowCaption() : CXTPShortcutBarPane, CXTPShortcutBarPaneItem, CXTPTaskPanelGroup
  • ShowCaptionAlways() : CXTPRibbonBar
  • ShowCaptionBar() : CXTPCalendarControlView
  • ShowCaptionMaximizeButton() : CXTPDockingPaneManager
  • ShowCaptions() : CXTPColorPicker, CXTPColorSelectorCtrl
  • ShowCloseItemButton() : CXTPTabManager
  • ShowCollapsedToolTip() : CXTPSyntaxEditCtrl
  • ShowColumn() : CXTPSplitterWnd
  • ShowCompColor() : CXTPShellSettings
  • ShowContextMenu() : CXTPCommandBarEditCtrl, CXTPShellPidl
  • ShowDay() : CXTPCalendarDayView, CXTPCalendarMonthView, CXTPCalendarTimeLineView, CXTPCalendarView, CXTPCalendarWeekView
  • ShowDays() : CXTPCalendarDayView
  • ShowDefaultContextMenu() : CXTPSyntaxEditCtrl
  • ShowDialog() : CXTPSyntaxEditFindReplaceDlg, CXTPSyntaxEditGoToLineDlg
  • ShowExpandButton() : CXTPShortcutBar, CXTPToolBar
  • ShowExtensions() : CXTPShellSettings
  • ShowFiles() : CXTPShellTreeBase
  • ShowFloatingCaptionMaximizeButton() : CXTPDockingPaneManager
  • ShowFooter() : CXTPGridControl
  • ShowGripper() : CXTPShortcutBar
  • ShowGroupBy() : CXTPGridControl
  • ShowHeader() : CXTPGridControl
  • ShowHelp() : CXTPPropertyGrid
  • ShowHScrollBar() : CXTPSyntaxEditCtrl
  • ShowIcon() : CXTPTrayIcon
  • ShowIcons() : CXTPTabManager
  • ShowIconWhenEditing() : CXTPGridControl
  • ShowImage() : CXTPToolTipContext
  • ShowInfoTips() : CXTPShellSettings
  • ShowItemsInGroups() : CXTPGridHeader
  • ShowKeyboardCues() : CXTPCommandBars, CXTPCommandBarsOptions
  • ShowKeyboardTips() : CXTPCommandBars
  • ShowLabel() : CXTPControlEdit
  • ShowLabels() : CXTPControlGallery
  • ShowListHeader() : CXTPDatePickerControl
  • ShowMapNetworkDrive() : CXTPShellSettings
  • ShowMessageBox() : CXTPResourceManager
  • ShowMinimizeButton() : CXTPShortcutBar
  • ShowModal() : CXTPPopupControl
  • ShowNavButtons() : CXTPTabBase
  • ShowNewWindowTab() : CXTPTabClientWnd
  • ShowOptionButton() : CXTPRibbonGroup
  • ShowPane() : CXTPDockingPaneAutoHidePanel, CXTPDockingPaneManager
  • ShowPopupWindow() : CXTPCaption, CXTPColorPicker
  • ShowPreview() : CXTPEyeDropper
  • ShowProgressBar() : CXTPTaskDialog
  • ShowQuickAccess() : CXTPRibbonBar
  • ShowQuickAccessBelowRibbon() : CXTPRibbonBar
  • ShowRow() : CXTPSplitterWnd
  • ShowRowFocus() : CXTPGridControl
  • ShowRowNumber() : CXTPGridControl
  • ShowScrollBar() : CXTPControlGallery, CXTPScrollBarContainer< Parent >, CXTPSyntaxEditCtrl
  • ShowShellContextMenu() : CXTPShellListBase
  • ShowShellLinkIcons() : CXTPShellPidl
  • ShowSortArrow() : CXTPHeaderCtrl
  • ShowSpinButtons() : CXTPControlEdit
  • ShowSysFiles() : CXTPShellSettings
  • ShowText() : CXTPColorPicker
  • ShowTextBelowIcons() : CXTPCommandBar
  • ShowTextInColor() : CXTPColorPicker
  • ShowThemedBorder() : CXTPEdit
  • ShowTip() : CXTPSyntaxEditTipListBox, CXTPSyntaxEditTipWnd
  • ShowTipWindow() : CXTPTipWindow
  • ShowTitleAndDescription() : CXTPToolTipContext
  • ShowToolBar() : CXTPPropertyGrid
  • ShowToolTip() : CXTPCalendarControl, CXTPCalendarView, CXTPCalendarViewEvent, CXTPGridRow, CXTPPropertyGridView
  • ShowTopBorder() : CXTPSplitterWndEx
  • ShowView() : CXTPPropertyGrid
  • ShowWindow() : CXTPDockingPane
  • ShowWorkingDays() : CXTPCalendarDayView
  • ShowWorkspace() : CXTPTabClientWnd
  • ShowWYSIWYGMarkers() : CXTPGridPaintManager
  • Shutdown() : CXTPActiveScriptStdRuntime, CXTPMarkupContext
  • side : CXTPColorHex::CRgnCell::CTX_DATA::HEXAGON_DATA
  • Sign() : CXTPMathUtils
  • Size() : CXTPResize
  • SizeMinReq() : CXTPDatePickerControl
  • SizeToFit() : CXTPTabPaintManager
  • SizeToPage() : CXTPPropertyPageNavigator
  • SkipGroupsFocus() : CXTPGridControl
  • sm : CXTPColorHex::CRgnCell::CTX_DATA
  • SnapPosition() : CXTPTrackControl
  • Snooze() : CXTPCalendarReminder, CXTPCalendarRemindersManager
  • Sort() : CXTPCalendarEvents, CXTPCalendarReminders, CXTPControls, CXTPGridRows, CXTPPropertyGridItemConstraints, CXTPPropertyGridItems, CXTPSortClass, CXTPTagCloudTagArray
  • SortAscending() : CXTPGridSubListControl
  • SortChildren() : CXTPShellTreeBase
  • SortDateTime() : CXTPSortClass
  • SortDecimal() : CXTPSortClass
  • SortEx() : CXTPGridRows
  • SortInt() : CXTPSortClass
  • SortList() : CXTPListBase, CXTPShellListBase
  • SortRows() : CXTPGridSection
  • SortString() : CXTPSortClass
  • SortTree() : CXTPGridSection
  • SplitPath() : CXTPSplitPath
  • StandardBias : CXTPCalendarTimeZones::REGISTRY_TIMEZONE_INFORMATION
  • StandardDate : CXTPCalendarTimeZones::REGISTRY_TIMEZONE_INFORMATION
  • StartAnimation() : CXTPTrayIcon
  • StartDelayEditTimer() : CXTPGridControl
  • StartDrag() : CXTPDockContext
  • StartDragBlocks() : CXTPTrackControl
  • StartDragConnection() : CXTPFlowGraphControl
  • StartDragConnectionPoint() : CXTPFlowGraphControl
  • StartDragging() : CXTPGridHeader
  • StartDragMarker() : CXTPTrackHeader
  • StartDragNodes() : CXTPFlowGraphControl
  • StartDragScreen() : CXTPFlowGraphControl
  • StartDragScrollBar() : CXTPTrackHeader
  • StartDragSelection() : CXTPFlowGraphControl, CXTPTrackControl
  • StartDragSlider() : CXTPTrackHeader
  • StartEditNewEventInplace() : CXTPCalendarView
  • StartEditSubject() : CXTPCalendarDayViewEvent, CXTPCalendarView, CXTPCalendarViewEvent
  • StartGroup() : CXTPFlowGraphUndoManager, CXTPTrackUndoManager
  • StartLastRqstTimer() : CXTPGridControl
  • StartMonitoring() : CXTPCalendarRemindersManager, CXTPSyntaxEditFileChangesMonitor
  • StartOleDrag() : CXTPSyntaxEditView
  • StartParseInThread() : CXTPSyntaxEditLexParser
  • StartProgressBarMarquee() : CXTPTaskDialog
  • StartResize() : CXTPDockContext
  • StartResizeNode() : CXTPFlowGraphControl
  • StopAnimation() : CXTPTrayIcon
  • StopHorzEventScroll() : CXTPCalendarDayView
  • StopMonitoring() : CXTPCalendarRemindersManager, CXTPSyntaxEditFileChangesMonitor
  • StopNotifications() : CXTPDirWatcher
  • StopParseInThread() : CXTPSyntaxEditLexParser
  • StopThread() : CXTPSoundManager
  • StopVertEventScroll() : CXTPCalendarDayView
  • strAM : CXTPCalendarView::SEventTimeFormatInfo
  • strCaption : XTP_COMMANDBARS_CREATECONTROL
  • strCategory : XTP_COMMANDBARS_CATEGORYINFO
  • strCollapsedText : XTP_EDIT_ROWSBLOCK
  • strDayView_AdditionalScaleLabel : CXTPCalendarOptions
  • strDayView_ScaleLabel : CXTPCalendarOptions
  • Stretch() : CXTPDockContext
  • strFormat : CXTPCalendarView::SEventTimeFormatInfo
  • StringToDouble() : CXTPPropertyGridItemDouble
  • StringToRGB() : CXTPPropertyGridItemColor
  • StripColor : CXTPChartAxisAppearance
  • StripColor2 : CXTPChartAxisAppearance
  • StripEllipsisFromToolTip() : CXTPToolTipContext
  • StripFormat() : CXTPCalendarUtils
  • StripMnemonics() : CXTPPaintManager
  • strItem : CXTPSortClass::ITEMDATA, XTP_TAGCLOUDTAG
  • strLabel : CXTPTaskDialogLinkCtrl::LINKITEM
  • strMessage : XTP_GRIDDATAMANAGER_COM_ERROR
  • strNewString : XTP_NM_FLOWGRAPH_ENDLABELEDIT, XTP_TPNENDLABELEDIT
  • strPM : CXTPCalendarView::SEventTimeFormatInfo
  • StrPosToCol() : CXTPSyntaxEditBufferManager
  • StrPosToDispPos() : CXTPSyntaxEditDrawTextProcessor
  • strSource : XTP_GRIDDATAMANAGER_COM_ERROR
  • strText : XTP_GRIDRECORDITEM_METRICS, XTPPROGRESSDRAWSTRUCT
  • strToolTip : CXTPStatusBarSwitchPane::SWITCH
  • strTooltipAddNewText : CXTPCalendarOptions
  • strUrl : CXTPTaskDialogLinkCtrl::LINKITEM
  • strValue : XTP_PROPERTYGRID_NOTIFYEDIT
  • SubclassHeader() : CXTPListBase
  • Subscribe() : CXTPObservable< Owner, Observer >
  • Subtract() : CXTPMatrix< T >
  • SupportsCompositedParent() : IXTPPreview
  • Suspend() : CXTPSkinManager
  • SwapColors() : CXTPTabBaseTheme
  • SwapIfNeed() : CXTPGridSelectedRows
  • SwitchActiveMenu() : CXTPMenuBar
  • SwitchActiveView() : CXTPCalendarControl
  • SwitchMDIMenu() : CXTPMenuBar
  • SwitchView() : CXTPSplitterWnd
  • SyncActiveFloatingFrames() : CXTPDockingPaneManager
  • SyncActiveMdiChild() : CXTPMenuBar
  • SyncPanesState() : CXTPDockingPaneManager
  • SyncScrollBar() : CXTPExcelTabCtrl
  • SystemTimeToTzSpecificLocalTime() : CXTPCalendarUtils
  • szCondensedLabel : CXTPTcbItem
  • szFilePath : XTP_URI
  • szIcons : CXTPCommandBarsOptions
  • szLargeIcons : CXTPCommandBarsOptions
  • szPopupIcons : CXTPCommandBarsOptions
  • szTabLabel : CXTPTcbItem
  • szText : CXTPColorSelectorCtrl::COLOR_CELL
  • szTip : XTP_PICK_BUTTON
  • szToolTipLabel : CXTPTcbItem
  • szVal : CXTPSkinManagerSchemaProperty


Toolkit Pro: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- t -

  • T_CompareFunc : CXTPCalendarEvents
  • TabFromPoint() : CXTPMDIWndTab
  • TabifySelection() : CXTPSyntaxEditCtrl
  • TBase : CXTPCalendarDayView, CXTPCalendarDayViewDay, CXTPCalendarDayViewEvent, CXTPCalendarDayViewGroup, CXTPCalendarMonthView, CXTPCalendarMonthViewDay, CXTPCalendarMonthViewEvent, CXTPCalendarMonthViewGroup, CXTPCalendarTimeLineView, CXTPCalendarTimeLineViewGroup, CXTPCalendarTypedPtrAutoDeleteArray< BASE_CLASS, PTR_TYPE >, CXTPCalendarWeekView, CXTPCalendarWeekViewDay, CXTPCalendarWeekViewEvent, CXTPCalendarWeekViewGroup, CXTPSyntaxEditLexClass
  • TextColor : CXTPChartLegendAppearance
  • TextPrepareSingleline() : CXTPCalendarUtils
  • ThawAllColumns() : CXTPHeaderCtrl
  • ThawColumn() : CXTPHeaderCtrl
  • ThemeAppProperties() : CXTPWinThemeWrapper
  • ThemeDataOpen() : CXTPWinThemeWrapper
  • TObject : CXTPInternalCollectionT< _TObject >
  • TObjectPtr : CXTPCalendarPtrCollectionT< _TObject >, CXTPInternalCollectionT< _TObject >
  • TObjPtr : CXTPCalendarData::EventsMapByID_T< _TObject >
  • ToCOLORREF() : CXTPChartColor
  • ToggleAutoHide() : CXTPDockingPaneManager
  • ToggleCheck() : CXTPCalendarEventColorListBox
  • ToggleConstraint() : CXTPPropertyGridItemOption
  • ToggleDocking() : CXTPDockContext, CXTPDockingPaneManager
  • ToggleVisible() : CXTPCommandBars
  • toolTipID : XTP_PICK_BUTTON
  • top : XTP_RESIZERECT
  • Track() : CXTPDockContext, CXTPDockingPaneContext
  • TrackClick() : CXTPTabManager
  • TrackMiniBar() : CXTPMiniToolBar
  • TrackMouseEvent() : CXTPCalendarUtils
  • TrackMouseLeave() : CXTPMouseManager
  • TrackMove() : CXTPPopupControl
  • TrackPopupMenu() : CXTPCommandBars, CXTPMiniToolBar
  • TrackPopupMenuEx() : CXTPCommandBars
  • TrackToPosition() : CXTPTrackControl
  • Transform() : CXTPChart3dDeviceContext
  • TransformationMatrices() : CXTPMarkupVisual::TransformationMatrices
  • TransformMatrix() : CXTPMarkupGdiPlusMatrixTransform, CXTPMarkupGdiPlusRotateTransform, CXTPMarkupGdiPlusScaleTransform, CXTPMarkupGdiPlusTransformObjectImpl
  • TransformPoint() : CXTPFlowGraphControl
  • TranslateAccelerator() : CXTPShortcutManager
  • TranslateKeyboardTip() : CXTPRibbonBackstageView
  • TransparentBlt() : CXTPImageManager
  • Transpose() : CXTPMatrix< T >
  • TreeAddRef() : CXTPGridRecord
  • TreeRelease() : CXTPGridRecord
  • TreeViewCompareProc() : CXTPShellPidl
  • Triangle() : CXTPDatePickerPaintManager, CXTPPaintManager
  • TriggerAmbientPropertyUpdate() : CXTPApplication
  • TryItemFromPoint() : CXTPListBox
  • Tthis : CXTPSmartPtrInternalT< _TObject >
  • TunnelTree() : CXTPShellTreeBase
  • TView : CXTPCalendarViewDayT< _TView, _TViewGroup, XTP_CALENDAR_HITTESTINFO, _TPThis >
  • TViewDay : CXTPCalendarViewGroupT< _TViewDay, _TViewEvent, _TPThis >
  • TViewEventsCollection : CXTPCalendarTimeLineViewGroup
  • TwipsToPointString() : CXTPControlSizeComboBox
  • type : CXTPDockingPaneWindowSelect::CItem, XTP_URI
  • tziDayView_AdditionalScaleTimeZone : CXTPCalendarOptions


Toolkit Pro: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- u -

  • uHitCode : XTP_CALENDAR_HITTESTINFO
  • uiToolTipId : CXTPTcbItem
  • ulAttribs : XTP_LVITEMDATA
  • Unadvise() : CXTPCalendarMsgNotifier, CXTPNotifyConnection, CXTPNotifySinkBase
  • UnadviseAll() : CXTPNotifySinkBase
  • Undo() : CXTPCalendarView, CXTPFlowGraphUndoAddConnectionCommand, CXTPFlowGraphUndoAddConnectionPointCommand, CXTPFlowGraphUndoAddNodeCommand, CXTPFlowGraphUndoCommand, CXTPFlowGraphUndoDeleteConnectionCommand, CXTPFlowGraphUndoDeleteConnectionPointCommand, CXTPFlowGraphUndoDeleteNodeCommand, CXTPFlowGraphUndoGroupCommand, CXTPFlowGraphUndoManager, CXTPFlowGraphUndoSetConnectionPositionCommand, CXTPFlowGraphUndoSetNodeCaptionCommand, CXTPFlowGraphUndoSetNodePositionCommand, CXTPFlowGraphUndoSetNodeSizeCommand, CXTPResourceManager::CManageState, CXTPSyntaxEditCtrl, CXTPTrackUndoAddBlockCommand, CXTPTrackUndoAddMarkerCommand, CXTPTrackUndoCommand, CXTPTrackUndoDeleteBlockCommand, CXTPTrackUndoDeleteMarkerCommand, CXTPTrackUndoGroupCommand, CXTPTrackUndoManager, CXTPTrackUndoSetBlockPositionCommand, CXTPTrackUndoSetMarkerPositionCommand
  • UnExecute() : CXTPSyntaxEditBatchCommand, CXTPSyntaxEditCommand, CXTPSyntaxEditDeleteStringCommand, CXTPSyntaxEditInsertStringCommand, CXTPSyntaxEditReplaceStringCommand
  • UnhookKeyboard() : CXTPKeyboardManager
  • Uninitialize() : CXTPActiveScriptEngine
  • UnInstall() : CXTPMDIWndTab
  • Union() : CXTPRectT< T >
  • unitCM : CXTPSvgImage
  • unitEM : CXTPSvgImage
  • unitEX : CXTPSvgImage
  • unitIN : CXTPSvgImage
  • unitMM : CXTPSvgImage
  • unitPC : CXTPSvgImage
  • unitPercent : CXTPSvgImage
  • unitPT : CXTPSvgImage
  • unitPX : CXTPSvgImage
  • Units : CXTPSvgImage
  • unitTypeAuto : CXTPMarkupGridLength
  • unitTypePixel : CXTPMarkupGridLength
  • unitTypeStar : CXTPMarkupGridLength
  • Unload() : CXTPGaugeCtrl
  • Unlock() : CXTPNotifyConnection::CEmptySyncObject
  • UnlockExclusive() : CXTPRWCriticalSection
  • UnlockInput() : CXTPKeyboardManager
  • UnlockMouseMove() : CXTPCommandBar, CXTPMouseManager
  • UnlockRedraw() : CXTPCommandBar
  • UnlockShared() : CXTPRWCriticalSection
  • UnLockThread() : CXTPLockGuard
  • Unproject() : CXTPChart3dDeviceContext, CXTPOpenGLUtils
  • Unselect() : CXTPSyntaxEditCtrl
  • UnselectAllEvents() : CXTPCalendarView
  • UnselectGroupRows() : CXTPGridControl
  • UnsetCurrent() : CXTPGaugeMeterType
  • UnsetMax() : CXTPGaugeMeterType
  • UnsetMin() : CXTPGaugeMeterType
  • Unsubscribe() : CXTPObservable< Owner, Observer >
  • UnTabifySelection() : CXTPSyntaxEditCtrl
  • UpColor : CXTPChartFinanceStyleAppearance
  • Update() : CXTPCalendarEvent, CXTPCalendarRecurrencePattern, CXTPGaugeBaseType, CXTPTearOffFrame
  • UpdateAcellTable() : CXTPCustomizeKeyboardPage
  • UpdateAllViews() : CXTPSyntaxEditView
  • UpdateBackgroundBrush() : CXTPComboBoxTheme
  • UpdateBorders() : CXTPCalendarCaptionBarControl, CXTPCalendarControl
  • UpdateBounds() : CXTPChartPieBase
  • UpdateCaption() : CXTPCaption
  • UpdateCaptionColor() : CXTPFlowGraphNode, CXTPFlowGraphNodeCustom
  • UpdateCaptionText() : CXTPCaption
  • UpdateCategories() : CXTPCalendarEventColorListBox
  • UpdateCharFormat() : CXTPControlComboBoxEditCtrl, CXTPControlEditCtrl
  • UpdateChilds() : CXTPPropertyGridItemFlags
  • UpdateColorRecursive() : CXTPFlowGraphNode, CXTPFlowGraphNodeCustom
  • UpdateColors() : CXTPPaintManager
  • UpdateColorValue() : CXTPSyntaxEditPropertiesPageColor
  • UpdateCommandBars() : CXTPCommandBars
  • UpdateConnectionPoints() : CXTPFlowGraphNode, CXTPFlowGraphNodeCustom
  • UpdateContents() : CXTPTabClientWnd
  • UpdateControlRect() : CXTPResize
  • UpdateControlsFromEvent() : CXTPCalendarEventPropertiesDlg
  • UpdateControlsState() : CXTPCalendarCaptionBarTheme, CXTPCalendarEventPropertiesDlg
  • UpdateCursorPos() : CXTPColorBase, CXTPColorLum, CXTPColorWnd
  • UpdateDate() : CXTPCalendarUtils
  • UpdateDefaultColors() : CXTPExcelTabCtrl
  • UpdateDefaultValues() : CXTPCalendarEventCategories, CXTPCalendarEventLabels
  • UpdateDiagram() : CXTPChartContent
  • UpdateDockingStickers() : CXTPDockingPaneContext
  • UpdateDocTitle() : CXTPTabView
  • UpdateDraggingContents() : CXTPTabClientContext
  • UpdateDwmClientArea() : CXTPCommandBarsFrameHook
  • UpdateEventCategories() : CXTPCalendarData
  • UpdateEventCategoriesDefaultColors() : CXTPCalendarOffice2013Theme, CXTPCalendarPaintManager
  • UpdateEventLabels() : CXTPCalendarData
  • UpdateEventLabelsDefaultColors() : CXTPCalendarOffice2013Theme, CXTPCalendarPaintManager
  • UpdateExpandingState() : CXTPPopupBar
  • UpdateField() : CXTPGridDataManager
  • UpdateFlags() : CXTPPopupBar, CXTPTabClientWnd
  • UpdateFont() : CXTPSyntaxEditPropertiesPageColor
  • UpdateFonts() : CXTPPaintManager
  • UpdateFontValue() : CXTPSyntaxEditPropertiesPageColor
  • UpdateFromManager() : CXTPCalendarRemindersDialog
  • UpdateGlyphs() : CXTPCalendarOffice2013Theme, CXTPCalendarPaintManager
  • UpdateGridRecords() : CXTPGridDataManager
  • UpdateHistoryCombo() : CXTPSyntaxEditFindReplaceDlg
  • UpdateIndexes() : CXTPGridRecords
  • UpdateLabels() : CXTPCalendarEventColorListBox
  • UpdateLayout() : CXTPChartDiagram2D, CXTPChartRadarDiagram
  • UpdateList() : CXTPGridSubListControl
  • UpdateLocation() : CXTPPopupBar
  • UpdateMarkupCaption() : CXTPFlowGraphNode, CXTPFlowGraphNodeCustom
  • UpdateMarkupFont() : CXTPFlowGraphNode
  • UpdateMarkupImage() : CXTPFlowGraphNode
  • UpdateMarkupPointCaption() : CXTPFlowGraphNode
  • UpdateMarkupPointColor() : CXTPFlowGraphNode, CXTPFlowGraphNodeCustom
  • UpdateMarkupPointImage() : CXTPFlowGraphNode
  • UpdateMarkupPointName() : CXTPFlowGraphNode
  • UpdateMDIChildrenTheme() : CXTPMDIFrameWnd
  • UpdateMinMaxRange() : CXTPChartRangeBarSeriesPointView, CXTPChartRangeSplineAreaSeriesPointView, CXTPChartSeriesPointView
  • UpdateMonthDay() : CXTPCalendarUtils
  • UpdateMouseCursor() : CXTPCalendarControl
  • UpdateNextTimeEditByTAB() : CXTPCalendarDayView, CXTPCalendarView
  • UpdateOccIfNeed() : CXTPCalendarReminderForOccurrenceArray
  • UpdateOccIfNeedEx() : CXTPCalendarReminderForOccurrenceArray
  • UpdateOpacity() : CXTPMiniToolBar
  • UpdatePage() : CXTPPropertyPage, CXTPRibbonCustomizeQuickAccessPage
  • UpdatePages() : CXTPPropertySheet
  • UpdatePanes() : CXTPDockingPaneManager
  • UpdatePosition() : CXTPFrameShadow
  • UpdateRange() : CXTPChartAxis, CXTPChartAxisRange, CXTPChartDiagram2DView, CXTPChartDiagramView, CXTPChartRadarDiagramView, CXTPChartStackedBarSeriesView
  • UpdateRecord() : CXTPGridControl, CXTPGridDataManager
  • UpdateRecordField() : CXTPGridRecord
  • UpdateRecurrence() : CXTPCalendarEvent
  • UpdateResourcesLangID() : CXTPResourceManager, CXTPResourceManagerXML
  • UpdateRowInfoInternally() : CXTPSyntaxEditCtrl
  • UpdateRTLCaption() : CXTPPaintManager
  • UpdateSampleColors() : CXTPSyntaxEditPropertiesPageColor, CXTPSyntaxEditPropertiesPageFont
  • UpdateSampleFont() : CXTPSyntaxEditPropertiesPageFont
  • UpdateScrollBar() : CXTPTaskPanel
  • UpdateScrollBars() : CXTPGridView
  • UpdateScrollButtons() : CXTPTaskPanel
  • UpdateScrollInfo() : CXTPRibbonBackstageView
  • UpdateScrollPos() : CXTPSyntaxEditCtrl, CXTPSyntaxEditView
  • UpdateSelColor() : CXTPCalendarEventColorDlg
  • UpdateSelection() : CXTPColorHex
  • UpdateSelectionForRect() : CXTPTreeBase
  • UpdateSeries() : CXTPChartQualitativeScaleTypeMap, CXTPChartScaleTypeMap
  • UpdateSeriesPointArgument() : CXTPChartDateTimeScaleTypeMap, CXTPChartNumericalScaleTypeMap, CXTPChartQualitativeScaleTypeMap, CXTPChartScaleTypeMap, CXTPChartTimeScaleTypeMap
  • UpdateShadow() : CXTPControlPopup
  • UpdateShortcuts() : CXTPCommandBar
  • UpdateSiblings() : CXTPSyntaxEditView
  • UpdateSiblingScrollPos() : CXTPSyntaxEditView
  • UpdateStartEndDatesFromPatternExceptions() : CXTPCalendarEvent
  • UpdateState() : CXTPPopupControl
  • UpdateSubList() : CXTPGridControl
  • UpdateSysColors() : CXTPAuxData
  • UpdateSysMetrics() : CXTPAuxData
  • UpdateTabContextWindow() : CXTPTabClientContext
  • UpdateTabFocusRect() : CXTPTabClientContext
  • UpdateTabLabel() : CXTPTabExBase
  • UpdateTabs() : CXTPTabToolBar
  • UpdateTabSticker() : CXTPTabClientContext
  • UpdateTextBlocks() : CXTPSyntaxEditLexTextSchema
  • UpdateTextFont() : CXTPSyntaxEditPaintManager
  • UpdateTime() : CXTPCalendarUtils
  • UpdateToolTip() : CXTPTabExBase
  • UpdateValue() : CXTPGridGroupRow, CXTPGridRecordItem
  • UpdateWindowOpacity() : CXTPDockingPaneMiniWnd
  • UpdateWindowPosition() : CXTPFlowGraphNode, CXTPFlowGraphNodeCustom
  • UppercaseSelection() : CXTPSyntaxEditCtrl
  • UseDefaultOnLoad() : CXTPPropExchange
  • UseDefaultOnSave() : CXTPPropExchange
  • UseGridCustomHeap() : CXTPGridControl
  • UseOfficeFont() : CXTPAuxData, CXTPDockingPanePaintManager, CXTPPaintManager
  • UseOneLine() : CXTPCalendarCaptionBarControl
  • UserAction_OnExpandDay() : CXTPCalendarViewDay
  • UserAction_OnScrollAllDayEvents() : CXTPCalendarDayViewGroup
  • UserAction_OnScrollDay() : CXTPCalendarDayViewGroup
  • UseRowBatchAllocation() : CXTPGridControl
  • UseSplitterTracker() : CXTPDockingPaneManager, CXTPTabClientWnd
  • UseSystemDecimalSymbol() : CXTPPropertyGridItemDouble
  • UseSystemKeyNameText() : CXTPShortcutManager
  • UseWinTheme() : CXTPEditTheme
  • UseWinThemes() : CXTPMarqueeCtrl, CXTPMarqueeCtrlPaintManager, CXTPProgressCtrlPaintManager
  • UseWinXPThemes() : CXTPHeaderCtrlTheme
  • UsingWinThemes() : CXTPMarqueeCtrlPaintManager, CXTPProgressCtrlPaintManager


Toolkit Pro: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- v -

  • ValidateCol() : CXTPSyntaxEditCtrl
  • ValidateXML() : CXTPMarkupContext
  • ValueToInternal() : CXTPChartDateTimeScaleTypeMap, CXTPChartNumericalScaleTypeMap, CXTPChartQualitativeScaleTypeMap, CXTPChartScaleTypeMap, CXTPChartTimeScaleTypeMap
  • ValueToPoint() : CXTPChartDiagram2DAxisView
  • VariantChangeTypeEx() : CXTPGridControlLocale
  • VerifyVersion() : CXTPSystemVersion
  • VerifyWinVer() : CXTPSystemVersion
  • VertEventScroll() : CXTPCalendarDayView
  • Vertex() : CXTPOpenGLUtils
  • VerticalLine() : CXTPPaintManager, CXTPTabBaseTheme


Toolkit Pro: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- w -

  • Wait() : CXTPSimpleEvent
  • WaitPathChangedEvent() : CXTPDirWatcher
  • WaitUntilReady() : CXTPWebBrowserCtrl
  • WebView2_ContainsFullScreenElementChanged() : IXTPWebBrowserEventSink
  • WebView2_ContentLoading() : IXTPWebBrowserEventSink
  • WebView2_DocumentTitleChanged() : IXTPWebBrowserEventSink
  • WebView2_FrameNavigationCompleted() : IXTPWebBrowserEventSink
  • WebView2_FrameNavigationStarting() : IXTPWebBrowserEventSink
  • WebView2_HistoryChanged() : IXTPWebBrowserEventSink
  • WebView2_NavigationCompleted() : IXTPWebBrowserEventSink
  • WebView2_NavigationStarting() : IXTPWebBrowserEventSink
  • WebView2_NewWindowRequested() : IXTPWebBrowserEventSink
  • WebView2_PermissionRequested() : IXTPWebBrowserEventSink
  • WebView2_ProcessFailed() : IXTPWebBrowserEventSink
  • WebView2_ScriptDialogOpening() : IXTPWebBrowserEventSink
  • WebView2_SourceChanged() : IXTPWebBrowserEventSink
  • WebView2_WebResourceRequested() : IXTPWebBrowserEventSink
  • WebView2_WindowCloseRequested() : IXTPWebBrowserEventSink
  • WeekView_IsShowEndDate() : CXTPCalendarControl
  • WeekView_IsShowTimeAsClocks() : CXTPCalendarControl
  • WeekView_SetShowEndDate() : CXTPCalendarControl
  • WeekView_SetShowTimeAsClocks() : CXTPCalendarControl
  • Width : CXTPRectT< T >, CXTPResizeRect, CXTPSizeT< T >
  • width : CXTPColorHex::CRgnCell::CTX_DATA::HEXAGON_DATA
  • Win95Classic() : CXTPShellSettings
  • wLanguage : XTP_RESOURCEMANAGER_LANGINFO
  • WorkspaceToScreen() : CXTPTabClientWnd
  • wParam : XTP_EDIT_NMHDR_PARSEEVENT
  • wParam1 : XTP_CALENDAR_WPARAM2
  • wParam2 : XTP_CALENDAR_WPARAM2
  • Write() : CXTPImageList, CXTPPropExchange, CXTPPropExchangeArchive
  • WriteCfgFile() : CXTPSyntaxEditColorTheme
  • WriteCount() : CXTPPropExchange, CXTPPropExchangeArchive
  • WriteList() : CXTPRecentFileList
  • WriteProfileBinary() : CXTPRegistryManager
  • WriteProfileColor() : CXTPRegistryManager
  • WriteProfileDouble() : CXTPRegistryManager
  • WriteProfileDword() : CXTPRegistryManager
  • WriteProfileInt() : CXTPRegistryManager
  • WriteProfilePoint() : CXTPRegistryManager
  • WriteProfileRect() : CXTPRegistryManager
  • WriteProfileSize() : CXTPRegistryManager
  • WriteProfileString() : CXTPRegistryManager
  • WriteRegistryValues() : CXTPSyntaxEditPropertiesPageColor, CXTPSyntaxEditPropertiesPageEdit, CXTPSyntaxEditPropertiesPageFont
  • WriteString() : CXTPMemFile


Toolkit Pro: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- x -

  • X : CXTPPoint2T< T >, CXTPPoint3T< T >, CXTPRectT< T >
  • x : XTP_RESIZEPOINT
  • XTP_CALENDAR_HITTESTINFO() : XTP_CALENDAR_HITTESTINFO
  • XTP_CALENDAR_HITTESTINFO_TIMELINE_VIEW() : XTP_CALENDAR_HITTESTINFO_TIMELINE_VIEW
  • XTP_CALENDAR_PATTERN_END() : XTP_CALENDAR_PATTERN_END
  • XTP_CALENDAR_RECURRENCE_OPTIONS() : XTP_CALENDAR_RECURRENCE_OPTIONS
  • XTP_CALENDAR_VIEWSELECTION() : XTP_CALENDAR_VIEWSELECTION
  • XTP_EDIT_ACDATA() : XTP_EDIT_ACDATA
  • XTP_EDIT_FONTOPTIONS() : XTP_EDIT_FONTOPTIONS
  • XTP_EDIT_TEXTBLOCK() : XTP_EDIT_TEXTBLOCK
  • XTP_GRIDDATAMANAGER_COM_ERROR() : XTP_GRIDDATAMANAGER_COM_ERROR
  • XTP_SLIDERTICKS() : XTP_SLIDERTICKS
  • XTP_TAGCLOUDTAG() : XTP_TAGCLOUDTAG
  • XTPAuxData : CXTPAuxData
  • XTPBorderPart : CXTPRibbonMarkupFrameTheme
  • xtpBorderPartBottom : CXTPRibbonMarkupFrameTheme
  • xtpBorderPartCount : CXTPRibbonMarkupFrameTheme
  • xtpBorderPartLeft : CXTPRibbonMarkupFrameTheme
  • xtpBorderPartLeftCaption : CXTPRibbonMarkupFrameTheme
  • xtpBorderPartRight : CXTPRibbonMarkupFrameTheme
  • xtpBorderPartRightCaption : CXTPRibbonMarkupFrameTheme
  • xtpBorderPartTop : CXTPRibbonMarkupFrameTheme
  • xtpBottom : CXTPSyntaxEditCtrl
  • xtpCalendarDPF_CloseOnDestroy : CXTPCalendarResourcesManager
  • xtpCalendarDPF_CreateIfNotExists : CXTPCalendarResourcesManager
  • xtpCalendarDPF_SaveOnDestroy : CXTPCalendarResourcesManager
  • xtpCalendarDPFUnknown : CXTPCalendarResourcesManager
  • XTPCalendarMsgNotifier : CXTPCalendarMsgNotifier
  • xtpEditCfgObjMainConfig : CXTPSyntaxEditConfigurationManager
  • xtpEditCfgObjSchMan : CXTPSyntaxEditConfigurationManager
  • xtpEditCfgObjThemeMan : CXTPSyntaxEditConfigurationManager
  • xtpEditUTBError : CXTPSyntaxEditLexTextSchema
  • xtpEditUTBNearestUpdated : CXTPSyntaxEditLexTextSchema
  • xtpEditUTBNothing : CXTPSyntaxEditLexTextSchema
  • xtpEditUTBReparse : CXTPSyntaxEditLexTextSchema
  • xtpEditVarfNot : CXTPSyntaxEditLexVariable
  • xtpEditVarID_alpha : CXTPSyntaxEditLexVariable
  • xtpEditVarID_digit : CXTPSyntaxEditLexVariable
  • xtpEditVarID_EOL : CXTPSyntaxEditLexVariable
  • xtpEditVarID_HexDigit : CXTPSyntaxEditLexVariable
  • xtpEditVarID_specs : CXTPSyntaxEditLexVariable
  • xtpEditVarID_Unknown : CXTPSyntaxEditLexVariable
  • XTPEnumCalendarDataProviderFlags : CXTPCalendarResourcesManager
  • XTPEnumEventGlyphs : CXTPCalendarPaintManager
  • XTPEnumExpandSigns : CXTPCalendarPaintManager
  • xtpFont : CXTPAuxData
  • xtpFontBold : CXTPAuxData
  • xtpFontIconTitle : CXTPAuxData
  • xtpFontIconTitleBold : CXTPAuxData
  • xtpFontMarlettIcon : CXTPAuxData
  • xtpFontSmCaption : CXTPAuxData
  • xtpFontStatus : CXTPAuxData
  • xtpFontULine : CXTPAuxData
  • xtpFontVert : CXTPAuxData
  • xtpFontVertBold : CXTPAuxData
  • XTPGetApplication : CXTPApplication
  • XTPGetHeaderCtrl() : CXTPListBase
  • XTPGetVersion() : CXTPAuxData
  • XTPHookManager : CXTPHookManager
  • XTPImageManager : CXTPImageManager
  • XTPInitialize : CXTPApplication
  • xtpLeft : CXTPSyntaxEditCtrl
  • xtpModLoaded : CXTPModuleHandle
  • xtpModMapped : CXTPModuleHandle
  • xtpModNone : CXTPModuleHandle
  • XTPModuleState : CXTPModuleHandle
  • XTPMultiMonitor : CXTPMultiMonitor
  • XTPPaintManager : CXTPPaintManager
  • xtpRight : CXTPSyntaxEditCtrl
  • XTPScrolDirection : CXTPSyntaxEditCtrl
  • xtpScrollBarFlat : CXTPShellExplorerProvider
  • xtpScrollBarNone : CXTPShellExplorerProvider
  • xtpScrollBarStandard : CXTPShellExplorerProvider
  • XTPShutdown : CXTPApplication
  • XTPSkinManager : CXTPSkinManager
  • XTPSoundManager : CXTPSoundManager
  • XTPSyntaxEditCfgObjects : CXTPSyntaxEditConfigurationManager
  • XTPSyntaxEditLexVarFlags : CXTPSyntaxEditLexVariable
  • XTPSyntaxEditLexVarID : CXTPSyntaxEditLexVariable
  • XTPSyntaxEditUpdateTBRes : CXTPSyntaxEditLexTextSchema
  • XTPSystemVersion : CXTPSystemVersion
  • XTPTabCloudStyleManager : CXTPTagCloudStyleManager
  • XTPThemeDLL : CXTPThemeDLL
  • xtpTop : CXTPSyntaxEditCtrl


Toolkit Pro: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- y -

  • Y : CXTPPoint2T< T >, CXTPPoint3T< T >, CXTPRectT< T >
  • y : XTP_RESIZEPOINT


Toolkit Pro: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- z -

  • Z : CXTPPoint3T< T >
  • ZoomArcBall() : CXTPChart3dDiagram
  • ZoomFitToWindow() : CXTPFlowGraphControl
  • ZoomToRect() : CXTPFlowGraphControl
  • ZoomToSelection() : CXTPFlowGraphControl


Toolkit Pro: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- ~ -

  • ~CCaptionButton() : CXTPSkinObjectFrame::CCaptionButton
  • ~CCheckListState() : CXTPCheckListBox::CCheckListState
  • ~CExclusiveLock() : CXTPRWCriticalSection::CExclusiveLock
  • ~CLock() : CXTPSimpleCriticalSection::CLock
  • ~CManageState() : CXTPResourceManager::CManageState
  • ~CMonthViewGrid() : CXTPCalendarMonthView::CMonthViewGrid
  • ~CRepositionContext() : CXTPTaskPanel::CRepositionContext
  • ~CRowIndexer() : CXTPTabManager::CRowIndexer
  • ~CSelectionChangedContext() : CXTPCalendarView::CSelectionChangedContext
  • ~CSharedLock() : CXTPRWCriticalSection::CSharedLock
  • ~CShellMalloc() : CXTPShellPidl::CShellMalloc
  • ~CShellSpecialFolder() : CXTPShellPidl::CShellSpecialFolder
  • ~CStringPtrArray() : CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager::CStringPtrArray
  • ~CTimeLineViewPart() : CXTPCalendarPaintManager
  • ~CUpdateContext() : CXTPCalendarControl::CUpdateContext, CXTPGridControl::CUpdateContext
  • ~CViewChangedContext() : CXTPCalendarControl::CViewChangedContext
  • ~CXTPActiveScriptEngine() : CXTPActiveScriptEngine
  • ~CXTPActiveScriptStdRuntime() : CXTPActiveScriptStdRuntime
  • ~CXTPAlphaWnd() : CXTPAlphaWnd
  • ~CXTPAnimationDC() : CXTPAnimationDC
  • ~CXTPArrayT() : CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE >
  • ~CXTPAsyncGuard() : CXTPAsyncGuard< Adaptee, RWLock >
  • ~CXTPAutoResetValue() : CXTPAutoResetValue< _TValue >
  • ~CXTPAuxData() : CXTPAuxData
  • ~CXTPBrowseButton() : CXTPBrowseButton
  • ~CXTPBrowseDialog() : CXTPBrowseDialog
  • ~CXTPBrowseEdit() : CXTPBrowseEdit
  • ~CXTPBrush() : CXTPBrush
  • ~CXTPButton() : CXTPButton
  • ~CXTPButtonTheme() : CXTPButtonTheme
  • ~CXTPCalendarCaptionBarControl() : CXTPCalendarCaptionBarControl
  • ~CXTPCalendarCaptionBarNativeWindows10Theme() : CXTPCalendarCaptionBarNativeWindows10Theme
  • ~CXTPCalendarCaptionBarNativeWindows11Theme() : CXTPCalendarCaptionBarNativeWindows11Theme
  • ~CXTPCalendarCaptionBarOffice2000Theme() : CXTPCalendarCaptionBarOffice2000Theme
  • ~CXTPCalendarCaptionBarOffice2003Theme() : CXTPCalendarCaptionBarOffice2003Theme
  • ~CXTPCalendarCaptionBarOffice2013Theme() : CXTPCalendarCaptionBarOffice2013Theme
  • ~CXTPCalendarCaptionBarOfficeXPTheme() : CXTPCalendarCaptionBarOfficeXPTheme
  • ~CXTPCalendarCaptionBarPaintManager() : CXTPCalendarCaptionBarPaintManager
  • ~CXTPCalendarCaptionBarResourceTheme() : CXTPCalendarCaptionBarResourceTheme
  • ~CXTPCalendarCaptionBarTheme() : CXTPCalendarCaptionBarTheme
  • ~CXTPCalendarCaptionBarThemePart() : CXTPCalendarCaptionBarThemePart
  • ~CXTPCalendarCaptionBarVisualStudio2015Theme() : CXTPCalendarCaptionBarVisualStudio2015Theme
  • ~CXTPCalendarCaptionBarVisualStudio2017Theme() : CXTPCalendarCaptionBarVisualStudio2017Theme
  • ~CXTPCalendarCaptionBarVisualStudio2019Theme() : CXTPCalendarCaptionBarVisualStudio2019Theme
  • ~CXTPCalendarCaptionBarVisualStudio2022Theme() : CXTPCalendarCaptionBarVisualStudio2022Theme
  • ~CXTPCalendarComboBoxBase() : CXTPCalendarComboBoxBase
  • ~CXTPCalendarControl() : CXTPCalendarControl
  • ~CXTPCalendarController() : CXTPCalendarController
  • ~CXTPCalendarControlView() : CXTPCalendarControlView
  • ~CXTPCalendarCustomDataProvider() : CXTPCalendarCustomDataProvider
  • ~CXTPCalendarCustomProperties() : CXTPCalendarCustomProperties
  • ~CXTPCalendarData() : CXTPCalendarData
  • ~CXTPCalendarDatabaseDataProvider() : CXTPCalendarDatabaseDataProvider
  • ~CXTPCalendarDayView() : CXTPCalendarDayView
  • ~CXTPCalendarDayViewDay() : CXTPCalendarDayViewDay
  • ~CXTPCalendarDayViewEvent() : CXTPCalendarDayViewEvent
  • ~CXTPCalendarDayViewGroup() : CXTPCalendarDayViewGroup
  • ~CXTPCalendarDayViewTimeScale() : CXTPCalendarDayViewTimeScale
  • ~CXTPCalendarEvent() : CXTPCalendarEvent
  • ~CXTPCalendarEventCategories() : CXTPCalendarEventCategories
  • ~CXTPCalendarEventCategory() : CXTPCalendarEventCategory
  • ~CXTPCalendarEventCategoryComboBox() : CXTPCalendarEventCategoryComboBox
  • ~CXTPCalendarEventCategoryIDs() : CXTPCalendarEventCategoryIDs
  • ~CXTPCalendarEventColorListBox() : CXTPCalendarEventColorListBox
  • ~CXTPCalendarEventLabel() : CXTPCalendarEventLabel
  • ~CXTPCalendarEventLabels() : CXTPCalendarEventLabels
  • ~CXTPCalendarEventPropertiesDlg() : CXTPCalendarEventPropertiesDlg
  • ~CXTPCalendarEventRecurrenceDlg() : CXTPCalendarEventRecurrenceDlg
  • ~CXTPCalendarEvents() : CXTPCalendarEvents
  • ~CXTPCalendarIconIDs() : CXTPCalendarIconIDs
  • ~CXTPCalendarMemoryDataProvider() : CXTPCalendarMemoryDataProvider
  • ~CXTPCalendarMonthView() : CXTPCalendarMonthView
  • ~CXTPCalendarMonthViewDay() : CXTPCalendarMonthViewDay
  • ~CXTPCalendarMonthViewEvent() : CXTPCalendarMonthViewEvent
  • ~CXTPCalendarMonthViewGroup() : CXTPCalendarMonthViewGroup
  • ~CXTPCalendarMsgNotifier() : CXTPCalendarMsgNotifier
  • ~CXTPCalendarNativeWindows10Theme() : CXTPCalendarNativeWindows10Theme
  • ~CXTPCalendarNativeWindows11Theme() : CXTPCalendarNativeWindows11Theme
  • ~CXTPCalendarOccurSeriesChooseDlg() : CXTPCalendarOccurSeriesChooseDlg
  • ~CXTPCalendarOffice2000Theme() : CXTPCalendarOffice2000Theme
  • ~CXTPCalendarOffice2003Theme() : CXTPCalendarOffice2003Theme
  • ~CXTPCalendarOffice2013Theme() : CXTPCalendarOffice2013Theme
  • ~CXTPCalendarOfficeXPTheme() : CXTPCalendarOfficeXPTheme
  • ~CXTPCalendarOptions() : CXTPCalendarOptions
  • ~CXTPCalendarPageSetupDialog() : CXTPCalendarPageSetupDialog
  • ~CXTPCalendarPaintManager() : CXTPCalendarPaintManager
  • ~CXTPCalendarPtrCollectionT() : CXTPCalendarPtrCollectionT< _TObject >
  • ~CXTPCalendarRecurrencePattern() : CXTPCalendarRecurrencePattern
  • ~CXTPCalendarReminder() : CXTPCalendarReminder
  • ~CXTPCalendarReminderForOccurrenceArray() : CXTPCalendarReminderForOccurrenceArray
  • ~CXTPCalendarRemindersDialog() : CXTPCalendarRemindersDialog
  • ~CXTPCalendarRemindersManager() : CXTPCalendarRemindersManager
  • ~CXTPCalendarResource() : CXTPCalendarResource
  • ~CXTPCalendarResources() : CXTPCalendarResources
  • ~CXTPCalendarResourcesManager() : CXTPCalendarResourcesManager
  • ~CXTPCalendarResourcesNf() : CXTPCalendarResourcesNf
  • ~CXTPCalendarResourceTheme() : CXTPCalendarResourceTheme
  • ~CXTPCalendarSchedule() : CXTPCalendarSchedule
  • ~CXTPCalendarSchedules() : CXTPCalendarSchedules
  • ~CXTPCalendarShadowDrawer() : CXTPCalendarShadowDrawer
  • ~CXTPCalendarThemeCustomizableXValueT() : CXTPCalendarThemeCustomizableXValueT< _TValue, _TValueRef >
  • ~CXTPCalendarThemeFontValue() : CXTPCalendarThemeFontValue
  • ~CXTPCalendarTimeLineView() : CXTPCalendarTimeLineView
  • ~CXTPCalendarTimeLineViewGroup() : CXTPCalendarTimeLineViewGroup
  • ~CXTPCalendarTimeLineViewTimeScale() : CXTPCalendarTimeLineViewTimeScale
  • ~CXTPCalendarTimeZone() : CXTPCalendarTimeZone
  • ~CXTPCalendarTimeZones() : CXTPCalendarTimeZones
  • ~CXTPCalendarTip() : CXTPCalendarTip
  • ~CXTPCalendarTLV_TimeScaleParams() : CXTPCalendarTLV_TimeScaleParams
  • ~CXTPCalendarTLV_TimeScaleParams_Day() : CXTPCalendarTLV_TimeScaleParams_Day
  • ~CXTPCalendarTLV_TimeScaleParams_Month() : CXTPCalendarTLV_TimeScaleParams_Month
  • ~CXTPCalendarTLV_TimeScaleParams_Week() : CXTPCalendarTLV_TimeScaleParams_Week
  • ~CXTPCalendarTLV_TimeScaleParams_WorkWeek() : CXTPCalendarTLV_TimeScaleParams_WorkWeek
  • ~CXTPCalendarTypedPtrAutoDeleteArray() : CXTPCalendarTypedPtrAutoDeleteArray< BASE_CLASS, PTR_TYPE >
  • ~CXTPCalendarTypedPtrAutoDeleteMap() : CXTPCalendarTypedPtrAutoDeleteMap< KEY, TPtr >
  • ~CXTPCalendarView() : CXTPCalendarView
  • ~CXTPCalendarViewDay() : CXTPCalendarViewDay
  • ~CXTPCalendarViewDayT() : CXTPCalendarViewDayT< _TView, _TViewGroup, XTP_CALENDAR_HITTESTINFO, _TPThis >
  • ~CXTPCalendarViewEvent() : CXTPCalendarViewEvent
  • ~CXTPCalendarViewEvents() : CXTPCalendarViewEvents
  • ~CXTPCalendarViewEventSubjectEditor() : CXTPCalendarViewEventSubjectEditor
  • ~CXTPCalendarViewEventSubjectEditorColored() : CXTPCalendarViewEventSubjectEditorColored
  • ~CXTPCalendarViewEventT() : CXTPCalendarViewEventT< _TViewGroup >
  • ~CXTPCalendarViewGroup() : CXTPCalendarViewGroup
  • ~CXTPCalendarViewGroupT() : CXTPCalendarViewGroupT< _TViewDay, _TViewEvent, _TPThis >
  • ~CXTPCalendarViewPart() : CXTPCalendarViewPart
  • ~CXTPCalendarViewPartBrushValue() : CXTPCalendarViewPartBrushValue
  • ~CXTPCalendarViewPartCustomizableValueT() : CXTPCalendarViewPartCustomizableValueT< _TValue >
  • ~CXTPCalendarViewT() : CXTPCalendarViewT< _TViewDay >
  • ~CXTPCalendarVisualStudio2015Theme() : CXTPCalendarVisualStudio2015Theme
  • ~CXTPCalendarVisualStudio2017Theme() : CXTPCalendarVisualStudio2017Theme
  • ~CXTPCalendarVisualStudio2019Theme() : CXTPCalendarVisualStudio2019Theme
  • ~CXTPCalendarVisualStudio2022Theme() : CXTPCalendarVisualStudio2022Theme
  • ~CXTPCalendarWeekView() : CXTPCalendarWeekView
  • ~CXTPCalendarWeekViewDay() : CXTPCalendarWeekViewDay
  • ~CXTPCalendarWeekViewEvent() : CXTPCalendarWeekViewEvent
  • ~CXTPCalendarWeekViewGroup() : CXTPCalendarWeekViewGroup
  • ~CXTPCaption() : CXTPCaption
  • ~CXTPCaptionPopupWnd() : CXTPCaptionPopupWnd
  • ~CXTPChart3dDeviceContext() : CXTPChart3dDeviceContext
  • ~CXTPChart3dDiagram() : CXTPChart3dDiagram
  • ~CXTPChart3dFunnelSeriesLabelView() : CXTPChart3dFunnelSeriesLabelView
  • ~CXTPChart3dFunnelSeriesPointView() : CXTPChart3dFunnelSeriesPointView
  • ~CXTPChart3dPieSeriesLabelView() : CXTPChart3dPieSeriesLabelView
  • ~CXTPChart3dPieSeriesPointView() : CXTPChart3dPieSeriesPointView
  • ~CXTPChart3dPyramidSeriesLabelView() : CXTPChart3dPyramidSeriesLabelView
  • ~CXTPChart3dPyramidSeriesPointView() : CXTPChart3dPyramidSeriesPointView
  • ~CXTPChartAppearance() : CXTPChartAppearance
  • ~CXTPChartAreaSeriesStyle() : CXTPChartAreaSeriesStyle
  • ~CXTPChartAxis() : CXTPChartAxis
  • ~CXTPChartAxisAppearance() : CXTPChartAxisAppearance
  • ~CXTPChartAxisConstantLine() : CXTPChartAxisConstantLine
  • ~CXTPChartAxisConstantLines() : CXTPChartAxisConstantLines
  • ~CXTPChartAxisCustomLabel() : CXTPChartAxisCustomLabel
  • ~CXTPChartAxisCustomLabels() : CXTPChartAxisCustomLabels
  • ~CXTPChartAxisGridLines() : CXTPChartAxisGridLines
  • ~CXTPChartAxisLabel() : CXTPChartAxisLabel
  • ~CXTPChartAxisRange() : CXTPChartAxisRange
  • ~CXTPChartAxisStrip() : CXTPChartAxisStrip
  • ~CXTPChartAxisStrips() : CXTPChartAxisStrips
  • ~CXTPChartAxisTickMarks() : CXTPChartAxisTickMarks
  • ~CXTPChartAxisTitle() : CXTPChartAxisTitle
  • ~CXTPChartBarSeriesLabel() : CXTPChartBarSeriesLabel
  • ~CXTPChartBarSeriesStyle() : CXTPChartBarSeriesStyle
  • ~CXTPChartBorder() : CXTPChartBorder
  • ~CXTPChartBubbleSeriesLabel() : CXTPChartBubbleSeriesLabel
  • ~CXTPChartBubbleSeriesStyle() : CXTPChartBubbleSeriesStyle
  • ~CXTPChartCandleStickSeriesStyle() : CXTPChartCandleStickSeriesStyle
  • ~CXTPChartContainer() : CXTPChartContainer
  • ~CXTPChartContent() : CXTPChartContent
  • ~CXTPChartContentAppearance() : CXTPChartContentAppearance
  • ~CXTPChartControl() : CXTPChartControl
  • ~CXTPChartDeviceCommand() : CXTPChartDeviceCommand
  • ~CXTPChartDeviceContext() : CXTPChartDeviceContext
  • ~CXTPChartDiagram2D() : CXTPChartDiagram2D
  • ~CXTPChartDiagram2DAppearance() : CXTPChartDiagram2DAppearance
  • ~CXTPChartDiagram2DAxisView() : CXTPChartDiagram2DAxisView
  • ~CXTPChartDiagram2DSeriesLabel() : CXTPChartDiagram2DSeriesLabel
  • ~CXTPChartDiagram2DSeriesStyle() : CXTPChartDiagram2DSeriesStyle
  • ~CXTPChartDiagram3DAppearance() : CXTPChartDiagram3DAppearance
  • ~CXTPChartElement() : CXTPChartElement
  • ~CXTPChartElementAppearance() : CXTPChartElementAppearance
  • ~CXTPChartElementCollection() : CXTPChartElementCollection
  • ~CXTPChartElementView() : CXTPChartElementView
  • ~CXTPChartFastLineSeriesStyle() : CXTPChartFastLineSeriesStyle
  • ~CXTPChartFinanceStyleAppearance() : CXTPChartFinanceStyleAppearance
  • ~CXTPChartFont() : CXTPChartFont
  • ~CXTPChartFunnelSeriesLabelBase() : CXTPChartFunnelSeriesLabelBase
  • ~CXTPChartFunnelSeriesPointViewBase() : CXTPChartFunnelSeriesPointViewBase
  • ~CXTPChartFunnelSeriesStyleBase() : CXTPChartFunnelSeriesStyleBase
  • ~CXTPChartFunnelSeriesViewBase() : CXTPChartFunnelSeriesViewBase
  • ~CXTPChartGanttSeriesStyle() : CXTPChartGanttSeriesStyle
  • ~CXTPChartHighLowSeriesStyle() : CXTPChartHighLowSeriesStyle
  • ~CXTPChartLegend() : CXTPChartLegend
  • ~CXTPChartLegendItemView() : CXTPChartLegendItemView
  • ~CXTPChartLegendView() : CXTPChartLegendView
  • ~CXTPChartLineSeriesStyle() : CXTPChartLineSeriesStyle
  • ~CXTPChartMarker() : CXTPChartMarker
  • ~CXTPChartMarkupElementDeviceCommand() : CXTPChartMarkupElementDeviceCommand
  • ~CXTPChartNumberFormat() : CXTPChartNumberFormat
  • ~CXTPChartPalette() : CXTPChartPalette
  • ~CXTPChartPanel() : CXTPChartPanel
  • ~CXTPChartPanelCollection() : CXTPChartPanelCollection
  • ~CXTPChartPieBase() : CXTPChartPieBase
  • ~CXTPChartPieDeviceCommandImpl() : CXTPChartPieDeviceCommandImpl
  • ~CXTPChartPieSeriesLabelBase() : CXTPChartPieSeriesLabelBase
  • ~CXTPChartPieSeriesPointViewBase() : CXTPChartPieSeriesPointViewBase
  • ~CXTPChartPieSeriesStyleBase() : CXTPChartPieSeriesStyleBase
  • ~CXTPChartPieSeriesViewBase() : CXTPChartPieSeriesViewBase
  • ~CXTPChartPieStyleAppearance() : CXTPChartPieStyleAppearance
  • ~CXTPChartPointSeriesLabel() : CXTPChartPointSeriesLabel
  • ~CXTPChartPointSeriesStyle() : CXTPChartPointSeriesStyle
  • ~CXTPChartPyramidSeriesLabelBase() : CXTPChartPyramidSeriesLabelBase
  • ~CXTPChartPyramidSeriesPointViewBase() : CXTPChartPyramidSeriesPointViewBase
  • ~CXTPChartPyramidSeriesStyleBase() : CXTPChartPyramidSeriesStyleBase
  • ~CXTPChartPyramidSeriesViewBase() : CXTPChartPyramidSeriesViewBase
  • ~CXTPChartQualitativeScaleTypeMap() : CXTPChartQualitativeScaleTypeMap
  • ~CXTPChartRadarAreaSeriesStyle() : CXTPChartRadarAreaSeriesStyle
  • ~CXTPChartRadarAxisView() : CXTPChartRadarAxisView
  • ~CXTPChartRadarAxisXView() : CXTPChartRadarAxisXView
  • ~CXTPChartRadarAxisYView() : CXTPChartRadarAxisYView
  • ~CXTPChartRadarDiagram() : CXTPChartRadarDiagram
  • ~CXTPChartRadarDiagramSeriesStyle() : CXTPChartRadarDiagramSeriesStyle
  • ~CXTPChartRadarLineSeriesStyle() : CXTPChartRadarLineSeriesStyle
  • ~CXTPChartRadarPointSeriesLabel() : CXTPChartRadarPointSeriesLabel
  • ~CXTPChartRadarPointSeriesStyle() : CXTPChartRadarPointSeriesStyle
  • ~CXTPChartRadarSplineAreaSeriesStyle() : CXTPChartRadarSplineAreaSeriesStyle
  • ~CXTPChartRadarSplineSeriesStyle() : CXTPChartRadarSplineSeriesStyle
  • ~CXTPChartRangeAreaSeriesLabel() : CXTPChartRangeAreaSeriesLabel
  • ~CXTPChartRangeBarSeriesLabel() : CXTPChartRangeBarSeriesLabel
  • ~CXTPChartRangeBarSeriesStyle() : CXTPChartRangeBarSeriesStyle
  • ~CXTPChartRangeSplineAreaSeriesStyle() : CXTPChartRangeSplineAreaSeriesStyle
  • ~CXTPChartScaleTypeMap() : CXTPChartScaleTypeMap
  • ~CXTPChartScatterLineSeriesStyle() : CXTPChartScatterLineSeriesStyle
  • ~CXTPChartSeries() : CXTPChartSeries
  • ~CXTPChartSeriesCollection() : CXTPChartSeriesCollection
  • ~CXTPChartSeriesLabel() : CXTPChartSeriesLabel
  • ~CXTPChartSeriesPoint() : CXTPChartSeriesPoint
  • ~CXTPChartSeriesPointCollection() : CXTPChartSeriesPointCollection
  • ~CXTPChartSeriesStyle() : CXTPChartSeriesStyle
  • ~CXTPChartSplineAreaSeriesStyle() : CXTPChartSplineAreaSeriesStyle
  • ~CXTPChartSplineSeriesStyle() : CXTPChartSplineSeriesStyle
  • ~CXTPChartStackedAreaSeriesStyle() : CXTPChartStackedAreaSeriesStyle
  • ~CXTPChartStackedBarSeriesStyle() : CXTPChartStackedBarSeriesStyle
  • ~CXTPChartStackedSplineAreaSeriesStyle() : CXTPChartStackedSplineAreaSeriesStyle
  • ~CXTPChartStepAreaSeriesStyle() : CXTPChartStepAreaSeriesStyle
  • ~CXTPChartStepLineSeriesStyle() : CXTPChartStepLineSeriesStyle
  • ~CXTPChartTextPainterBase() : CXTPChartTextPainterBase
  • ~CXTPChartTitle() : CXTPChartTitle
  • ~CXTPChartTitleCollection() : CXTPChartTitleCollection
  • ~CXTPCheckListBox() : CXTPCheckListBox
  • ~CXTPColorBase() : CXTPColorBase
  • ~CXTPColorDialog() : CXTPColorDialog
  • ~CXTPColorHex() : CXTPColorHex
  • ~CXTPColorLum() : CXTPColorLum
  • ~CXTPColorPageCustom() : CXTPColorPageCustom
  • ~CXTPColorPageStandard() : CXTPColorPageStandard
  • ~CXTPColorPicker() : CXTPColorPicker
  • ~CXTPColorPopup() : CXTPColorPopup
  • ~CXTPColorSelectorCtrl() : CXTPColorSelectorCtrl
  • ~CXTPColorSetCaptionButton() : CXTPColorSetCaptionButton
  • ~CXTPColorSetStateCheckBox() : CXTPColorSetStateCheckBox
  • ~CXTPColorSetStateCheckMark() : CXTPColorSetStateCheckMark
  • ~CXTPColorSetStateComboBox() : CXTPColorSetStateComboBox
  • ~CXTPColorWnd() : CXTPColorWnd
  • ~CXTPComboBox() : CXTPComboBox
  • ~CXTPComboBoxTheme() : CXTPComboBoxTheme
  • ~CXTPComboBoxThemeDefault() : CXTPComboBoxThemeDefault
  • ~CXTPComboBoxThemeNativeWindows10() : CXTPComboBoxThemeNativeWindows10
  • ~CXTPComboBoxThemeNativeWindows11() : CXTPComboBoxThemeNativeWindows11
  • ~CXTPComboBoxThemeOffice2000() : CXTPComboBoxThemeOffice2000
  • ~CXTPComboBoxThemeOffice2003() : CXTPComboBoxThemeOffice2003
  • ~CXTPComboBoxThemeOffice2013() : CXTPComboBoxThemeOffice2013
  • ~CXTPComboBoxThemeOfficeXPFlat() : CXTPComboBoxThemeOfficeXPFlat
  • ~CXTPComboBoxThemeResource() : CXTPComboBoxThemeResource
  • ~CXTPComboBoxThemeVisualStudio() : CXTPComboBoxThemeVisualStudio
  • ~CXTPComboBoxThemeVisualStudio2010() : CXTPComboBoxThemeVisualStudio2010
  • ~CXTPComboBoxThemeVisualStudio2012() : CXTPComboBoxThemeVisualStudio2012
  • ~CXTPComboBoxThemeVisualStudio2015() : CXTPComboBoxThemeVisualStudio2015
  • ~CXTPComboBoxThemeVisualStudio2017() : CXTPComboBoxThemeVisualStudio2017
  • ~CXTPComboBoxThemeVisualStudio2019() : CXTPComboBoxThemeVisualStudio2019
  • ~CXTPComboBoxThemeVisualStudio2022() : CXTPComboBoxThemeVisualStudio2022
  • ~CXTPComInitializer() : CXTPComInitializer
  • ~CXTPCommandBar() : CXTPCommandBar
  • ~CXTPCommandBarList() : CXTPCommandBarList
  • ~CXTPCommandBars() : CXTPCommandBars
  • ~CXTPCommandBarScrollBarCtrl() : CXTPCommandBarScrollBarCtrl
  • ~CXTPCommandBarsFrameHook() : CXTPCommandBarsFrameHook
  • ~CXTPCommandBarsModernUITheme() : CXTPCommandBarsModernUITheme
  • ~CXTPCommandBarsNativeWindows10Theme() : CXTPCommandBarsNativeWindows10Theme
  • ~CXTPCommandBarsNativeWindows11Theme() : CXTPCommandBarsNativeWindows11Theme
  • ~CXTPCommandBarsNativeXPTheme() : CXTPCommandBarsNativeXPTheme
  • ~CXTPCommandBarsOffice2003Theme() : CXTPCommandBarsOffice2003Theme
  • ~CXTPCommandBarsOffice2013Theme() : CXTPCommandBarsOffice2013Theme
  • ~CXTPCommandBarsSiteBase() : CXTPCommandBarsSiteBase< TBase >
  • ~CXTPCommandBarsVisualStudio2012Theme() : CXTPCommandBarsVisualStudio2012Theme
  • ~CXTPCommandBarsVisualStudio2015Theme() : CXTPCommandBarsVisualStudio2015Theme
  • ~CXTPCommandBarsVisualStudio2017Theme() : CXTPCommandBarsVisualStudio2017Theme
  • ~CXTPCommandBarsVisualStudio2019Theme() : CXTPCommandBarsVisualStudio2019Theme
  • ~CXTPCommandBarsVisualStudio2022Theme() : CXTPCommandBarsVisualStudio2022Theme
  • ~CXTPControl() : CXTPControl
  • ~CXTPControlAction() : CXTPControlAction
  • ~CXTPControlActions() : CXTPControlActions
  • ~CXTPControlButton() : CXTPControlButton
  • ~CXTPControlComboBox() : CXTPControlComboBox
  • ~CXTPControlCustom() : CXTPControlCustom
  • ~CXTPControlEdit() : CXTPControlEdit
  • ~CXTPControlFontComboBox() : CXTPControlFontComboBox
  • ~CXTPControlGallery() : CXTPControlGallery
  • ~CXTPControlGalleryItem() : CXTPControlGalleryItem
  • ~CXTPControlGalleryItems() : CXTPControlGalleryItems
  • ~CXTPControlListBox() : CXTPControlListBox
  • ~CXTPControlMarkupLabel() : CXTPControlMarkupLabel
  • ~CXTPControlPopup() : CXTPControlPopup
  • ~CXTPControlPopupColor() : CXTPControlPopupColor
  • ~CXTPControls() : CXTPControls
  • ~CXTPControlScrollBar() : CXTPControlScrollBar
  • ~CXTPControlSizeComboBox() : CXTPControlSizeComboBox
  • ~CXTPControlSlider() : CXTPControlSlider
  • ~CXTPControlTabWorkspace() : CXTPControlTabWorkspace
  • ~CXTPCriticalSection() : CXTPCriticalSection
  • ~CXTPCustomizeCommandsPage() : CXTPCustomizeCommandsPage
  • ~CXTPCustomizeKeyboardPage() : CXTPCustomizeKeyboardPage
  • ~CXTPCustomizeMenusPage() : CXTPCustomizeMenusPage
  • ~CXTPCustomizeOptionsPage() : CXTPCustomizeOptionsPage
  • ~CXTPCustomizeSheet() : CXTPCustomizeSheet
  • ~CXTPCustomizeToolbarsPage() : CXTPCustomizeToolbarsPage
  • ~CXTPDatePickerButton() : CXTPDatePickerButton
  • ~CXTPDatePickerControl() : CXTPDatePickerControl
  • ~CXTPDatePickerDaysCollection() : CXTPDatePickerDaysCollection
  • ~CXTPDatePickerItemDay() : CXTPDatePickerItemDay
  • ~CXTPDatePickerItemMonth() : CXTPDatePickerItemMonth
  • ~CXTPDatePickerList() : CXTPDatePickerList
  • ~CXTPDatePickerPaintManager() : CXTPDatePickerPaintManager
  • ~CXTPDatePickerThemeNativeWindows10() : CXTPDatePickerThemeNativeWindows10
  • ~CXTPDatePickerThemeNativeWindows11() : CXTPDatePickerThemeNativeWindows11
  • ~CXTPDatePickerThemeOffice2000() : CXTPDatePickerThemeOffice2000
  • ~CXTPDatePickerThemeOffice2003() : CXTPDatePickerThemeOffice2003
  • ~CXTPDatePickerThemeOffice2013() : CXTPDatePickerThemeOffice2013
  • ~CXTPDatePickerThemeOfficeXP() : CXTPDatePickerThemeOfficeXP
  • ~CXTPDatePickerThemeResource() : CXTPDatePickerThemeResource
  • ~CXTPDatePickerThemeVisualStudio2015() : CXTPDatePickerThemeVisualStudio2015
  • ~CXTPDatePickerThemeVisualStudio2017() : CXTPDatePickerThemeVisualStudio2017
  • ~CXTPDatePickerThemeVisualStudio2019() : CXTPDatePickerThemeVisualStudio2019
  • ~CXTPDatePickerThemeVisualStudio2022() : CXTPDatePickerThemeVisualStudio2022
  • ~CXTPDialogBar() : CXTPDialogBar
  • ~CXTPDirWatcher() : CXTPDirWatcher
  • ~CXTPDockBar() : CXTPDockBar
  • ~CXTPDockContext() : CXTPDockContext
  • ~CXTPDockingPane() : CXTPDockingPane
  • ~CXTPDockingPaneAutoHidePanel() : CXTPDockingPaneAutoHidePanel
  • ~CXTPDockingPaneBase() : CXTPDockingPaneBase
  • ~CXTPDockingPaneBaseContainer() : CXTPDockingPaneBaseContainer
  • ~CXTPDockingPaneColorSet() : CXTPDockingPaneColorSet
  • ~CXTPDockingPaneContext() : CXTPDockingPaneContext
  • ~CXTPDockingPaneContextAlphaWnd() : CXTPDockingPaneContextAlphaWnd
  • ~CXTPDockingPaneContextStickerWnd() : CXTPDockingPaneContextStickerWnd
  • ~CXTPDockingPaneLayout() : CXTPDockingPaneLayout
  • ~CXTPDockingPaneManager() : CXTPDockingPaneManager
  • ~CXTPDockingPaneMiniWnd() : CXTPDockingPaneMiniWnd
  • ~CXTPDockingPaneNativeWindows10Theme() : CXTPDockingPaneNativeWindows10Theme
  • ~CXTPDockingPaneNativeWindows11Theme() : CXTPDockingPaneNativeWindows11Theme
  • ~CXTPDockingPaneOffice2003OutlookTheme() : CXTPDockingPaneOffice2003OutlookTheme
  • ~CXTPDockingPaneOffice2003Theme() : CXTPDockingPaneOffice2003Theme
  • ~CXTPDockingPaneOffice2013Theme() : CXTPDockingPaneOffice2013Theme
  • ~CXTPDockingPanePaintManager() : CXTPDockingPanePaintManager
  • ~CXTPDockingPaneSidePanel() : CXTPDockingPaneSidePanel
  • ~CXTPDockingPaneSplitterContainer() : CXTPDockingPaneSplitterContainer
  • ~CXTPDockingPaneSplitterWnd() : CXTPDockingPaneSplitterWnd
  • ~CXTPDockingPaneTabbedContainer() : CXTPDockingPaneTabbedContainer
  • ~CXTPDockingPaneVisualStudio2012Theme() : CXTPDockingPaneVisualStudio2012Theme
  • ~CXTPDockingPaneVisualStudio2015Theme() : CXTPDockingPaneVisualStudio2015Theme
  • ~CXTPDockingPaneVisualStudio2017Theme() : CXTPDockingPaneVisualStudio2017Theme
  • ~CXTPDockingPaneVisualStudio2019Theme() : CXTPDockingPaneVisualStudio2019Theme
  • ~CXTPDockingPaneVisualStudio2022Theme() : CXTPDockingPaneVisualStudio2022Theme
  • ~CXTPDockingPaneWindowSelect() : CXTPDockingPaneWindowSelect
  • ~CXTPDockState() : CXTPDockState
  • ~CXTPDPCache() : CXTPCalendarData::CXTPDPCache
  • ~CXTPDropSource() : CXTPDropSource
  • ~CXTPEdit() : CXTPEdit
  • ~CXTPEditListBox() : CXTPEditListBox
  • ~CXTPEditListBoxToolBar() : CXTPEditListBoxToolBar
  • ~CXTPEditTheme() : CXTPEditTheme
  • ~CXTPEditThemeDefault() : CXTPEditThemeDefault
  • ~CXTPEditThemeFlat() : CXTPEditThemeFlat
  • ~CXTPEditThemeNativeWindows10() : CXTPEditThemeNativeWindows10
  • ~CXTPEditThemeNativeWindows11() : CXTPEditThemeNativeWindows11
  • ~CXTPEditThemeOffice2000() : CXTPEditThemeOffice2000
  • ~CXTPEditThemeOffice2003() : CXTPEditThemeOffice2003
  • ~CXTPEditThemeOffice2013() : CXTPEditThemeOffice2013
  • ~CXTPEditThemeOfficeXP() : CXTPEditThemeOfficeXP
  • ~CXTPEditThemeResource() : CXTPEditThemeResource
  • ~CXTPEditThemeUltraFlat() : CXTPEditThemeUltraFlat
  • ~CXTPEditThemeVisualStudio2010() : CXTPEditThemeVisualStudio2010
  • ~CXTPEditThemeVisualStudio2012() : CXTPEditThemeVisualStudio2012
  • ~CXTPEditThemeVisualStudio2015() : CXTPEditThemeVisualStudio2015
  • ~CXTPEditThemeVisualStudio2017() : CXTPEditThemeVisualStudio2017
  • ~CXTPEditThemeVisualStudio2019() : CXTPEditThemeVisualStudio2019
  • ~CXTPEditThemeVisualStudio2022() : CXTPEditThemeVisualStudio2022
  • ~CXTPExcelTabCtrl() : CXTPExcelTabCtrl
  • ~CXTPExcelTabCtrlTheme() : CXTPExcelTabCtrlTheme
  • ~CXTPEyeDropper() : CXTPEyeDropper
  • ~CXTPFlowGraphConnection() : CXTPFlowGraphConnection
  • ~CXTPFlowGraphConnectionPoint() : CXTPFlowGraphConnectionPoint
  • ~CXTPFlowGraphConnectionPoints() : CXTPFlowGraphConnectionPoints
  • ~CXTPFlowGraphConnections() : CXTPFlowGraphConnections
  • ~CXTPFlowGraphControl() : CXTPFlowGraphControl
  • ~CXTPFlowGraphElement() : CXTPFlowGraphElement
  • ~CXTPFlowGraphImage() : CXTPFlowGraphImage
  • ~CXTPFlowGraphImages() : CXTPFlowGraphImages
  • ~CXTPFlowGraphNode() : CXTPFlowGraphNode
  • ~CXTPFlowGraphNodeCustom() : CXTPFlowGraphNodeCustom
  • ~CXTPFlowGraphNodeGroup() : CXTPFlowGraphNodeGroup
  • ~CXTPFlowGraphNodeGroups() : CXTPFlowGraphNodeGroups
  • ~CXTPFlowGraphNodes() : CXTPFlowGraphNodes
  • ~CXTPFlowGraphPage() : CXTPFlowGraphPage
  • ~CXTPFlowGraphPageHistory() : CXTPFlowGraphPageHistory
  • ~CXTPFlowGraphPages() : CXTPFlowGraphPages
  • ~CXTPFlowGraphPaintManager() : CXTPFlowGraphPaintManager
  • ~CXTPFlowGraphSelectedElements() : CXTPFlowGraphSelectedElements
  • ~CXTPFlowGraphUndoAddConnectionCommand() : CXTPFlowGraphUndoAddConnectionCommand
  • ~CXTPFlowGraphUndoAddConnectionPointCommand() : CXTPFlowGraphUndoAddConnectionPointCommand
  • ~CXTPFlowGraphUndoAddNodeCommand() : CXTPFlowGraphUndoAddNodeCommand
  • ~CXTPFlowGraphUndoCommand() : CXTPFlowGraphUndoCommand
  • ~CXTPFlowGraphUndoDeleteConnectionCommand() : CXTPFlowGraphUndoDeleteConnectionCommand
  • ~CXTPFlowGraphUndoDeleteConnectionPointCommand() : CXTPFlowGraphUndoDeleteConnectionPointCommand
  • ~CXTPFlowGraphUndoDeleteNodeCommand() : CXTPFlowGraphUndoDeleteNodeCommand
  • ~CXTPFlowGraphUndoGroupCommand() : CXTPFlowGraphUndoGroupCommand
  • ~CXTPFlowGraphUndoManager() : CXTPFlowGraphUndoManager
  • ~CXTPFlowGraphUndoSetConnectionPositionCommand() : CXTPFlowGraphUndoSetConnectionPositionCommand
  • ~CXTPFlowGraphUndoSetNodeCaptionCommand() : CXTPFlowGraphUndoSetNodeCaptionCommand
  • ~CXTPFlowGraphUndoSetNodePositionCommand() : CXTPFlowGraphUndoSetNodePositionCommand
  • ~CXTPFlowGraphUndoSetNodeSizeCommand() : CXTPFlowGraphUndoSetNodeSizeCommand
  • ~CXTPFont() : CXTPFont
  • ~CXTPFontComboBox() : CXTPFontComboBox
  • ~CXTPFontCtrlBase() : CXTPFontCtrlBase
  • ~CXTPFontEnum() : CXTPFontEnum
  • ~CXTPFontListBox() : CXTPFontListBox
  • ~CXTPFramePaintManager() : CXTPFramePaintManager
  • ~CXTPFrameShadow() : CXTPFrameShadow
  • ~CXTPFrameThemeOffice2007System() : CXTPFrameThemeOffice2007System
  • ~CXTPFrameWndBase() : CXTPFrameWndBase< TBase >
  • ~CXTPGaugeBaseType() : CXTPGaugeBaseType
  • ~CXTPGaugeCtrl() : CXTPGaugeCtrl
  • ~CXTPGaugeMeterType() : CXTPGaugeMeterType
  • ~CXTPGaugeStateType() : CXTPGaugeStateType
  • ~CXTPGaugeTraits() : CXTPGaugeTraits
  • ~CXTPGdiObject() : CXTPGdiObject
  • ~CXTPGlobalAtom() : CXTPGlobalAtom
  • ~CXTPGridColumn() : CXTPGridColumn
  • ~CXTPGridColumns() : CXTPGridColumns
  • ~CXTPGridControl() : CXTPGridControl
  • ~CXTPGridDataManager() : CXTPGridDataManager
  • ~CXTPGridFilterEditControl() : CXTPGridFilterEditControl
  • ~CXTPGridGroupRow() : CXTPGridGroupRow
  • ~CXTPGridHeader() : CXTPGridHeader
  • ~CXTPGridHeaderDragWnd() : CXTPGridHeaderDragWnd
  • ~CXTPGridHeaderDropWnd() : CXTPGridHeaderDropWnd
  • ~CXTPGridHyperlink() : CXTPGridHyperlink
  • ~CXTPGridHyperlinks() : CXTPGridHyperlinks
  • ~CXTPGridIconNavigator() : CXTPGridIconNavigator
  • ~CXTPGridInplaceControl() : CXTPGridInplaceControl
  • ~CXTPGridInplaceEdit() : CXTPGridInplaceEdit
  • ~CXTPGridNavigator() : CXTPGridNavigator
  • ~CXTPGridPageSetupDialog() : CXTPGridPageSetupDialog
  • ~CXTPGridPaintManager() : CXTPGridPaintManager
  • ~CXTPGridRecord() : CXTPGridRecord
  • ~CXTPGridRecordItem() : CXTPGridRecordItem
  • ~CXTPGridRecordItemConstraints() : CXTPGridRecordItemConstraints
  • ~CXTPGridRecordItemControl() : CXTPGridRecordItemControl
  • ~CXTPGridRecordItemControlHookWnd() : CXTPGridRecordItemControlHookWnd
  • ~CXTPGridRecordItemControls() : CXTPGridRecordItemControls
  • ~CXTPGridRecordItemEditOptions() : CXTPGridRecordItemEditOptions
  • ~CXTPGridRecords() : CXTPGridRecords
  • ~CXTPGridRow() : CXTPGridRow
  • ~CXTPGridRows() : CXTPGridRows
  • ~CXTPGridSection() : CXTPGridSection
  • ~CXTPGridSections() : CXTPGridSections
  • ~CXTPGridSubListControl() : CXTPGridSubListControl
  • ~CXTPGridTip() : CXTPGridTip
  • ~CXTPGridView() : CXTPGridView
  • ~CXTPHeaderCtrl() : CXTPHeaderCtrl
  • ~CXTPHeaderCtrlTheme() : CXTPHeaderCtrlTheme
  • ~CXTPHeaderCtrlThemeExplorer() : CXTPHeaderCtrlThemeExplorer
  • ~CXTPHeaderCtrlThemeOffice2003() : CXTPHeaderCtrlThemeOffice2003
  • ~CXTPHeaderCtrlThemeOfficeXP() : CXTPHeaderCtrlThemeOfficeXP
  • ~CXTPHeapString() : CXTPHeapString
  • ~CXTPHeapStringT() : CXTPHeapStringT< _TAllocator >
  • ~CXTPHexEdit() : CXTPHexEdit
  • ~CXTPHookManager() : CXTPHookManager
  • ~CXTPHookManagerHookAble() : CXTPHookManagerHookAble
  • ~CXTPHyperLink() : CXTPHyperLink
  • ~CXTPIconHandle() : CXTPIconHandle
  • ~CXTPImageList() : CXTPImageList
  • ~CXTPImageManager() : CXTPImageManager
  • ~CXTPImageManagerIcon() : CXTPImageManagerIcon
  • ~CXTPImageManagerIconHandle() : CXTPImageManagerIconHandle
  • ~CXTPImageManagerIconSet() : CXTPImageManagerIconSet
  • ~CXTPImageManagerImageList() : CXTPImageManagerImageList
  • ~CXTPImageManagerResource() : CXTPImageManagerResource
  • ~CXTPImageManagerVectorImageHandle() : CXTPImageManagerVectorImageHandle
  • ~CXTPInternalCollectionT() : CXTPInternalCollectionT< _TObject >
  • ~CXTPItemEdit() : CXTPItemEdit
  • ~CXTPKeyboardManager() : CXTPKeyboardManager
  • ~CXTPListBase() : CXTPListBase
  • ~CXTPListBox() : CXTPListBox
  • ~CXTPListBoxTheme() : CXTPListBoxTheme
  • ~CXTPListCtrl() : CXTPListCtrl
  • ~CXTPListView() : CXTPListView
  • ~CXTPLockGuard() : CXTPLockGuard
  • ~CXTPMarkupBorder() : CXTPMarkupBorder
  • ~CXTPMarkupButton() : CXTPMarkupButton
  • ~CXTPMarkupButtonBase() : CXTPMarkupButtonBase
  • ~CXTPMarkupCheckBox() : CXTPMarkupCheckBox
  • ~CXTPMarkupContentControl() : CXTPMarkupContentControl
  • ~CXTPMarkupContext() : CXTPMarkupContext
  • ~CXTPMarkupDecorator() : CXTPMarkupDecorator
  • ~CXTPMarkupDeviceDependentImage() : CXTPMarkupDeviceDependentImage
  • ~CXTPMarkupDockPanel() : CXTPMarkupDockPanel
  • ~CXTPMarkupFrameworkElement() : CXTPMarkupFrameworkElement
  • ~CXTPMarkupGdiImage() : CXTPMarkupGdiImage
  • ~CXTPMarkupGdiPlusImage() : CXTPMarkupGdiPlusImage
  • ~CXTPMarkupGdiPlusTransformationMatrix() : CXTPMarkupGdiPlusTransformationMatrix
  • ~CXTPMarkupGdiPlusTransformObjectImpl() : CXTPMarkupGdiPlusTransformObjectImpl
  • ~CXTPMarkupGrid() : CXTPMarkupGrid
  • ~CXTPMarkupImage() : CXTPMarkupImage
  • ~CXTPMarkupPage() : CXTPMarkupPage
  • ~CXTPMarkupPanel() : CXTPMarkupPanel
  • ~CXTPMarkupRadioButton() : CXTPMarkupRadioButton
  • ~CXTPMarkupStackPanel() : CXTPMarkupStackPanel
  • ~CXTPMarkupStaticExtension() : CXTPMarkupStaticExtension
  • ~CXTPMarkupStaticExtensionProperty() : CXTPMarkupStaticExtensionProperty
  • ~CXTPMarkupTextBlock() : CXTPMarkupTextBlock
  • ~CXTPMarkupThemePart() : CXTPMarkupThemePart
  • ~CXTPMarkupTransformationMatrix() : CXTPMarkupTransformationMatrix
  • ~CXTPMarkupTreeCtrl() : CXTPMarkupTreeCtrl
  • ~CXTPMarkupUIElement() : CXTPMarkupUIElement
  • ~CXTPMarkupUIElementCollection() : CXTPMarkupUIElementCollection
  • ~CXTPMarkupUniformGrid() : CXTPMarkupUniformGrid
  • ~CXTPMarkupViewbox() : CXTPMarkupViewbox
  • ~CXTPMarkupVisual() : CXTPMarkupVisual
  • ~CXTPMarkupWrapPanel() : CXTPMarkupWrapPanel
  • ~CXTPMarqueeCtrl() : CXTPMarqueeCtrl
  • ~CXTPMarqueeCtrlPaintManager() : CXTPMarqueeCtrlPaintManager
  • ~CXTPMatrix() : CXTPMatrix< T >
  • ~CXTPMDIClientWnd() : CXTPMDIClientWnd
  • ~CXTPMDIFrameWndEx() : CXTPMDIFrameWndEx
  • ~CXTPMDIWndTab() : CXTPMDIWndTab
  • ~CXTPMemFile() : CXTPMemFile
  • ~CXTPMenuBar() : CXTPMenuBar
  • ~CXTPMenuBarMDIMenuInfo() : CXTPMenuBarMDIMenuInfo
  • ~CXTPMenuBarMDIMenus() : CXTPMenuBarMDIMenus
  • ~CXTPMessageBar() : CXTPMessageBar
  • ~CXTPMessageBarButton() : CXTPMessageBarButton
  • ~CXTPMessageBarPaintManager() : CXTPMessageBarPaintManager
  • ~CXTPMiniToolBar() : CXTPMiniToolBar
  • ~CXTPModuleHandle() : CXTPModuleHandle
  • ~CXTPMouseManager() : CXTPMouseManager
  • ~CXTPNotifyConnection() : CXTPNotifyConnection
  • ~CXTPNotifyConnectionMT() : CXTPNotifyConnectionMT
  • ~CXTPNotifySinkBase() : CXTPNotifySinkBase
  • ~CXTPObservable() : CXTPObservable< Owner, Observer >
  • ~CXTPPageScroller() : CXTPPageScroller
  • ~CXTPPaintManager() : CXTPPaintManager
  • ~CXTPPaintManagerColor() : CXTPPaintManagerColor
  • ~CXTPPaintManagerColorGradient() : CXTPPaintManagerColorGradient
  • ~CXTPPasswordPeek() : CXTPPasswordPeek
  • ~CXTPPen() : CXTPPen
  • ~CXTPPopupBar() : CXTPPopupBar
  • ~CXTPPopupControl() : CXTPPopupControl
  • ~CXTPPopupItem() : CXTPPopupItem
  • ~CXTPPopupPaintManager() : CXTPPopupPaintManager
  • ~CXTPPopupThemeMSN() : CXTPPopupThemeMSN
  • ~CXTPPopupThemeOffice2000() : CXTPPopupThemeOffice2000
  • ~CXTPPopupThemeOffice2003() : CXTPPopupThemeOffice2003
  • ~CXTPPopupThemeOffice2013() : CXTPPopupThemeOffice2013
  • ~CXTPPopupThemeOfficeXP() : CXTPPopupThemeOfficeXP
  • ~CXTPPreviewCtrl() : CXTPPreviewCtrl
  • ~CXTPPreviewView() : CXTPPreviewView
  • ~CXTPProgressBase() : CXTPProgressBase
  • ~CXTPProgressCtrl() : CXTPProgressCtrl
  • ~CXTPProgressCtrlPaintManager() : CXTPProgressCtrlPaintManager
  • ~CXTPProgressPaintManager() : CXTPProgressPaintManager
  • ~CXTPProgressThemeNativeWindows10() : CXTPProgressThemeNativeWindows10
  • ~CXTPProgressThemeNativeWindows11() : CXTPProgressThemeNativeWindows11
  • ~CXTPProgressThemeOffice2013() : CXTPProgressThemeOffice2013
  • ~CXTPProgressThemeVisualStudio2015() : CXTPProgressThemeVisualStudio2015
  • ~CXTPProgressThemeVisualStudio2017() : CXTPProgressThemeVisualStudio2017
  • ~CXTPProgressThemeVisualStudio2019() : CXTPProgressThemeVisualStudio2019
  • ~CXTPProgressThemeVisualStudio2022() : CXTPProgressThemeVisualStudio2022
  • ~CXTPPropertyGrid() : CXTPPropertyGrid
  • ~CXTPPropertyGridInplaceButton() : CXTPPropertyGridInplaceButton
  • ~CXTPPropertyGridInplaceButtons() : CXTPPropertyGridInplaceButtons
  • ~CXTPPropertyGridInplaceControls() : CXTPPropertyGridInplaceControls
  • ~CXTPPropertyGridInplaceEdit() : CXTPPropertyGridInplaceEdit
  • ~CXTPPropertyGridInplaceList() : CXTPPropertyGridInplaceList
  • ~CXTPPropertyGridInplaceMultilineEdit() : CXTPPropertyGridInplaceMultilineEdit
  • ~CXTPPropertyGridItem() : CXTPPropertyGridItem
  • ~CXTPPropertyGridItemBool() : CXTPPropertyGridItemBool
  • ~CXTPPropertyGridItemColor() : CXTPPropertyGridItemColor
  • ~CXTPPropertyGridItemConstraints() : CXTPPropertyGridItemConstraints
  • ~CXTPPropertyGridItemDouble() : CXTPPropertyGridItemDouble
  • ~CXTPPropertyGridItemEnum() : CXTPPropertyGridItemEnum
  • ~CXTPPropertyGridItemFlags() : CXTPPropertyGridItemFlags
  • ~CXTPPropertyGridItemFont() : CXTPPropertyGridItemFont
  • ~CXTPPropertyGridItemNumber() : CXTPPropertyGridItemNumber
  • ~CXTPPropertyGridItemOption() : CXTPPropertyGridItemOption
  • ~CXTPPropertyGridItemPoint() : CXTPPropertyGridItemPoint
  • ~CXTPPropertyGridItemSize() : CXTPPropertyGridItemSize
  • ~CXTPPropertyGridPaintManager() : CXTPPropertyGridPaintManager
  • ~CXTPPropertyGridToolBar() : CXTPPropertyGridToolBar
  • ~CXTPPropertyGridVerbs() : CXTPPropertyGridVerbs
  • ~CXTPPropertyGridView() : CXTPPropertyGridView
  • ~CXTPPropertyGridVisualStudio2010Theme() : CXTPPropertyGridVisualStudio2010Theme
  • ~CXTPPropertyPage() : CXTPPropertyPage
  • ~CXTPPropertyPageNavigator() : CXTPPropertyPageNavigator
  • ~CXTPPropertySheet() : CXTPPropertySheet
  • ~CXTPPropExchange() : CXTPPropExchange
  • ~CXTPPropExchangeEnumerator() : CXTPPropExchangeEnumerator
  • ~CXTPPropExchangeIniFile() : CXTPPropExchangeIniFile
  • ~CXTPPropExchangeRegistry() : CXTPPropExchangeRegistry
  • ~CXTPPropExchangeSection() : CXTPPropExchangeSection
  • ~CXTPReBar() : CXTPReBar
  • ~CXTPRecentFileList() : CXTPRecentFileList
  • ~CXTPRegistryManager() : CXTPRegistryManager
  • ~CXTPResize() : CXTPResize
  • ~CXTPResizeGroupBox() : CXTPResizeGroupBox
  • ~CXTPResizeItem() : CXTPResizeItem
  • ~CXTPResourceImage() : CXTPResourceImage
  • ~CXTPResourceImages() : CXTPResourceImages
  • ~CXTPResourceManager() : CXTPResourceManager
  • ~CXTPResourceManagerXML() : CXTPResourceManagerXML
  • ~CXTPResourceTheme() : CXTPResourceTheme
  • ~CXTPRibbonBar() : CXTPRibbonBar
  • ~CXTPRibbonControlSystemPopupBarPinableListItem() : CXTPRibbonControlSystemPopupBarPinableListItem
  • ~CXTPRibbonControlTab() : CXTPRibbonControlTab
  • ~CXTPRibbonCustomizePage() : CXTPRibbonCustomizePage
  • ~CXTPRibbonCustomizeQuickAccessPage() : CXTPRibbonCustomizeQuickAccessPage
  • ~CXTPRibbonGroup() : CXTPRibbonGroup
  • ~CXTPRibbonGroups() : CXTPRibbonGroups
  • ~CXTPRibbonMarkupFrameTheme() : CXTPRibbonMarkupFrameTheme
  • ~CXTPRibbonMarkupTheme() : CXTPRibbonMarkupTheme
  • ~CXTPRibbonOffice2013Theme() : CXTPRibbonOffice2013Theme
  • ~CXTPRibbonPaintManager() : CXTPRibbonPaintManager
  • ~CXTPRibbonQuickAccessControls() : CXTPRibbonQuickAccessControls
  • ~CXTPRibbonTab() : CXTPRibbonTab
  • ~CXTPRibbonTabPopupToolBar() : CXTPRibbonTabPopupToolBar
  • ~CXTPRibbonTheme() : CXTPRibbonTheme
  • ~CXTPRibbonThemeNativeWindows10() : CXTPRibbonThemeNativeWindows10
  • ~CXTPRibbonThemeNativeWindows11() : CXTPRibbonThemeNativeWindows11
  • ~CXTPRibbonThemeOffice2007System() : CXTPRibbonThemeOffice2007System
  • ~CXTPRibbonThemeResource() : CXTPRibbonThemeResource
  • ~CXTPRibbonThemeVisualStudio2015() : CXTPRibbonThemeVisualStudio2015
  • ~CXTPRibbonThemeVisualStudio2017() : CXTPRibbonThemeVisualStudio2017
  • ~CXTPRibbonThemeVisualStudio2019() : CXTPRibbonThemeVisualStudio2019
  • ~CXTPRibbonThemeVisualStudio2022() : CXTPRibbonThemeVisualStudio2022
  • ~CXTPRWCriticalSection() : CXTPRWCriticalSection
  • ~CXTPScrollBar() : CXTPScrollBar
  • ~CXTPScrollBarCtrl() : CXTPScrollBarCtrl
  • ~CXTPScrollBarThemeOffice2013() : CXTPScrollBarThemeOffice2013
  • ~CXTPScrollBarThemeWindowsUx() : CXTPScrollBarThemeWindowsUx
  • ~CXTPScrollBase() : CXTPScrollBase
  • ~CXTPSearchOptionsCtrl() : CXTPSearchOptionsCtrl
  • ~CXTPSearchOptionsView() : CXTPSearchOptionsView
  • ~CXTPShadowManager() : CXTPShadowManager
  • ~CXTPShellExplorerProvider() : CXTPShellExplorerProvider
  • ~CXTPShellListBase() : CXTPShellListBase
  • ~CXTPShellListCtrl() : CXTPShellListCtrl
  • ~CXTPShellListCtrlEx() : CXTPShellListCtrlEx
  • ~CXTPShellListView() : CXTPShellListView
  • ~CXTPShellPidl() : CXTPShellPidl
  • ~CXTPShellSettings() : CXTPShellSettings
  • ~CXTPShellTreeBase() : CXTPShellTreeBase
  • ~CXTPShellTreeCtrl() : CXTPShellTreeCtrl
  • ~CXTPShellTreeView() : CXTPShellTreeView
  • ~CXTPShortcutBar() : CXTPShortcutBar
  • ~CXTPShortcutBarNativeWindows10Theme() : CXTPShortcutBarNativeWindows10Theme
  • ~CXTPShortcutBarNativeWindows11Theme() : CXTPShortcutBarNativeWindows11Theme
  • ~CXTPShortcutBarNativeWinXPTheme() : CXTPShortcutBarNativeWinXPTheme
  • ~CXTPShortcutBarOffice2013Theme() : CXTPShortcutBarOffice2013Theme
  • ~CXTPShortcutBarPaintManager() : CXTPShortcutBarPaintManager
  • ~CXTPShortcutBarPane() : CXTPShortcutBarPane
  • ~CXTPShortcutBarVisualStudio2015Theme() : CXTPShortcutBarVisualStudio2015Theme
  • ~CXTPShortcutBarVisualStudio2017Theme() : CXTPShortcutBarVisualStudio2017Theme
  • ~CXTPShortcutBarVisualStudio2019Theme() : CXTPShortcutBarVisualStudio2019Theme
  • ~CXTPShortcutBarVisualStudio2022Theme() : CXTPShortcutBarVisualStudio2022Theme
  • ~CXTPShortcutListBox() : CXTPShortcutListBox
  • ~CXTPShortcutListBoxTheme() : CXTPShortcutListBoxTheme
  • ~CXTPShortcutManager() : CXTPShortcutManager
  • ~CXTPShortcutManagerAccelTable() : CXTPShortcutManagerAccelTable
  • ~CXTPSimpleCriticalSection() : CXTPSimpleCriticalSection
  • ~CXTPSingletonPointer() : CXTPSingletonPointer
  • ~CXTPSizeIcon() : CXTPSizeIcon
  • ~CXTPSkinImage() : CXTPSkinImage
  • ~CXTPSkinImages() : CXTPSkinImages
  • ~CXTPSkinManager() : CXTPSkinManager
  • ~CXTPSkinManagerClass() : CXTPSkinManagerClass
  • ~CXTPSkinManagerColorFilter() : CXTPSkinManagerColorFilter
  • ~CXTPSkinManagerMetrics() : CXTPSkinManagerMetrics
  • ~CXTPSkinManagerResourceFile() : CXTPSkinManagerResourceFile
  • ~CXTPSkinManagerSchema() : CXTPSkinManagerSchema
  • ~CXTPSkinManagerSchemaProperty() : CXTPSkinManagerSchemaProperty
  • ~CXTPSkinObject() : CXTPSkinObject
  • ~CXTPSkinObjectButton() : CXTPSkinObjectButton
  • ~CXTPSkinObjectClassMap() : CXTPSkinObjectClassMap
  • ~CXTPSkinObjectComboBox() : CXTPSkinObjectComboBox
  • ~CXTPSkinObjectEdit() : CXTPSkinObjectEdit
  • ~CXTPSkinObjectFrame() : CXTPSkinObjectFrame
  • ~CXTPSkinObjectHeader() : CXTPSkinObjectHeader
  • ~CXTPSkinObjectListBox() : CXTPSkinObjectListBox
  • ~CXTPSkinObjectListView() : CXTPSkinObjectListView
  • ~CXTPSkinObjectProgress() : CXTPSkinObjectProgress
  • ~CXTPSkinObjectReBar() : CXTPSkinObjectReBar
  • ~CXTPSkinObjectScrollBar() : CXTPSkinObjectScrollBar
  • ~CXTPSkinObjectSpin() : CXTPSkinObjectSpin
  • ~CXTPSkinObjectStatusBar() : CXTPSkinObjectStatusBar
  • ~CXTPSkinObjectTab() : CXTPSkinObjectTab
  • ~CXTPSkinObjectToolBar() : CXTPSkinObjectToolBar
  • ~CXTPSkinObjectTrackBar() : CXTPSkinObjectTrackBar
  • ~CXTPSkinObjectTreeView() : CXTPSkinObjectTreeView
  • ~CXTPSmartPtrInternalT() : CXTPSmartPtrInternalT< _TObject >
  • ~CXTPSortClass() : CXTPSortClass
  • ~CXTPSoundManager() : CXTPSoundManager
  • ~CXTPSpinButtonCtrl() : CXTPSpinButtonCtrl
  • ~CXTPSplitPath() : CXTPSplitPath
  • ~CXTPSplitterWnd() : CXTPSplitterWnd
  • ~CXTPSplitterWndEx() : CXTPSplitterWndEx
  • ~CXTPStatusBar() : CXTPStatusBar
  • ~CXTPStatusBarPane() : CXTPStatusBarPane
  • ~CXTPStatusBarProgressPane() : CXTPStatusBarProgressPane
  • ~CXTPStatusBarScrollBarPane() : CXTPStatusBarScrollBarPane
  • ~CXTPStatusBarSliderPane() : CXTPStatusBarSliderPane
  • ~CXTPStatusBarSwitchPane() : CXTPStatusBarSwitchPane
  • ~CXTPStatusBarThemeVisualStudio2015() : CXTPStatusBarThemeVisualStudio2015
  • ~CXTPStatusBarThemeVisualStudio2017() : CXTPStatusBarThemeVisualStudio2017
  • ~CXTPStatusBarThemeVisualStudio2019() : CXTPStatusBarThemeVisualStudio2019
  • ~CXTPStatusBarThemeVisualStudio2022() : CXTPStatusBarThemeVisualStudio2022
  • ~CXTPStickerBase() : CXTPStickerBase
  • ~CXTPSubscriptionList() : CXTPSubscriptionList< Observable, Observer >
  • ~CXTPSvgImage() : CXTPSvgImage
  • ~CXTPSyntaxEditAutoCompleteWnd() : CXTPSyntaxEditAutoCompleteWnd
  • ~CXTPSyntaxEditBatchCommand() : CXTPSyntaxEditBatchCommand
  • ~CXTPSyntaxEditBufferCommand() : CXTPSyntaxEditBufferCommand
  • ~CXTPSyntaxEditBufferKeepOverwriteSettings() : CXTPSyntaxEditBufferCommand::CXTPSyntaxEditBufferKeepOverwriteSettings
  • ~CXTPSyntaxEditBufferManager() : CXTPSyntaxEditBufferManager
  • ~CXTPSyntaxEditColorComboBox() : CXTPSyntaxEditColorComboBox
  • ~CXTPSyntaxEditColorInfo() : CXTPSyntaxEditColorInfo
  • ~CXTPSyntaxEditColorInfoArray() : CXTPSyntaxEditColorInfoArray
  • ~CXTPSyntaxEditColorSampleText() : CXTPSyntaxEditColorSampleText
  • ~CXTPSyntaxEditColorTheme() : CXTPSyntaxEditColorTheme
  • ~CXTPSyntaxEditColorThemesManager() : CXTPSyntaxEditColorThemesManager
  • ~CXTPSyntaxEditCommand() : CXTPSyntaxEditCommand
  • ~CXTPSyntaxEditConfigurationManager() : CXTPSyntaxEditConfigurationManager
  • ~CXTPSyntaxEditCtrl() : CXTPSyntaxEditCtrl
  • ~CXTPSyntaxEditDeleteStringCommand() : CXTPSyntaxEditDeleteStringCommand
  • ~CXTPSyntaxEditDoc() : CXTPSyntaxEditDoc
  • ~CXTPSyntaxEditFileChangesMonitor() : CXTPSyntaxEditFileChangesMonitor
  • ~CXTPSyntaxEditInsertStringCommand() : CXTPSyntaxEditInsertStringCommand
  • ~CXTPSyntaxEditLexClass() : CXTPSyntaxEditLexClass
  • ~CXTPSyntaxEditLexOnScreenParseCnt() : CXTPSyntaxEditLexOnScreenParseCnt
  • ~CXTPSyntaxEditLexParser() : CXTPSyntaxEditLexParser
  • ~CXTPSyntaxEditLexTextBlock() : CXTPSyntaxEditLexTextBlock
  • ~CXTPSyntaxEditLexTextSchema() : CXTPSyntaxEditLexTextSchema
  • ~CXTPSyntaxEditLexTokensDef() : CXTPSyntaxEditLexTokensDef
  • ~CXTPSyntaxEditLexVariable() : CXTPSyntaxEditLexVariable
  • ~CXTPSyntaxEditLexVariant() : CXTPSyntaxEditLexVariant
  • ~CXTPSyntaxEditLineMarksManager() : CXTPSyntaxEditLineMarksManager
  • ~CXTPSyntaxEditPaintManager() : CXTPSyntaxEditPaintManager
  • ~CXTPSyntaxEditPropertiesDlg() : CXTPSyntaxEditPropertiesDlg
  • ~CXTPSyntaxEditPropertiesPageColor() : CXTPSyntaxEditPropertiesPageColor
  • ~CXTPSyntaxEditPropertiesPageEdit() : CXTPSyntaxEditPropertiesPageEdit
  • ~CXTPSyntaxEditPropertiesPageFont() : CXTPSyntaxEditPropertiesPageFont
  • ~CXTPSyntaxEditReplaceStringCommand() : CXTPSyntaxEditReplaceStringCommand
  • ~CXTPSyntaxEditSelection() : CXTPSyntaxEditSelection
  • ~CXTPSyntaxEditStringsManager() : CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager
  • ~CXTPSyntaxEditTextIterator() : CXTPSyntaxEditTextIterator
  • ~CXTPSyntaxEditTextSchemesManager() : CXTPSyntaxEditTextSchemesManager
  • ~CXTPSyntaxEditTipWnd() : CXTPSyntaxEditTipWnd
  • ~CXTPSyntaxEditToolTipCtrl() : CXTPSyntaxEditToolTipCtrl
  • ~CXTPSyntaxEditUndoRedoManager() : CXTPSyntaxEditUndoRedoManager
  • ~CXTPSyntaxEditView() : CXTPSyntaxEditView
  • ~CXTPTabBase() : CXTPTabBase
  • ~CXTPTabBaseTheme() : CXTPTabBaseTheme
  • ~CXTPTabClientContext() : CXTPTabClientContext
  • ~CXTPTabClientDraggingContents() : CXTPTabClientDraggingContents
  • ~CXTPTabClientSticker() : CXTPTabClientSticker
  • ~CXTPTabClientWnd() : CXTPTabClientWnd
  • ~CXTPTabControl() : CXTPTabControl
  • ~CXTPTabCtrl() : CXTPTabCtrl
  • ~CXTPTabExBase() : CXTPTabExBase
  • ~CXTPTabManager() : CXTPTabManager
  • ~CXTPTabManagerAtom() : CXTPTabManagerAtom
  • ~CXTPTabManagerItem() : CXTPTabManagerItem
  • ~CXTPTabManagerNavigateButton() : CXTPTabManagerNavigateButton
  • ~CXTPTabManagerNavigateButtons() : CXTPTabManagerNavigateButtons
  • ~CXTPTabPaintManager() : CXTPTabPaintManager
  • ~CXTPTabPaintManagerColorSet() : CXTPTabPaintManagerColorSet
  • ~CXTPTabPaintManagerTheme() : CXTPTabPaintManagerTheme
  • ~CXTPTabToolBar() : CXTPTabToolBar
  • ~CXTPTabView() : CXTPTabView
  • ~CXTPTagCloudCtrl() : CXTPTagCloudCtrl
  • ~CXTPTagCloudStyleManager() : CXTPTagCloudStyleManager
  • ~CXTPTaskDialog() : CXTPTaskDialog
  • ~CXTPTaskDialogLinkCtrl() : CXTPTaskDialogLinkCtrl
  • ~CXTPTaskPanel() : CXTPTaskPanel
  • ~CXTPTaskPanelGroup() : CXTPTaskPanelGroup
  • ~CXTPTaskPanelGroupItem() : CXTPTaskPanelGroupItem
  • ~CXTPTaskPanelItem() : CXTPTaskPanelItem
  • ~CXTPTaskPanelItems() : CXTPTaskPanelItems
  • ~CXTPTaskPanelNativeWindows10Theme() : CXTPTaskPanelNativeWindows10Theme
  • ~CXTPTaskPanelNativeWindows11Theme() : CXTPTaskPanelNativeWindows11Theme
  • ~CXTPTaskPanelOffice2013Theme() : CXTPTaskPanelOffice2013Theme
  • ~CXTPTaskPanelPaintManager() : CXTPTaskPanelPaintManager
  • ~CXTPTaskPanelVisualStudio2010Theme() : CXTPTaskPanelVisualStudio2010Theme
  • ~CXTPTaskPanelVisualStudio2012Theme() : CXTPTaskPanelVisualStudio2012Theme
  • ~CXTPTaskPanelVisualStudio2015Theme() : CXTPTaskPanelVisualStudio2015Theme
  • ~CXTPTaskPanelVisualStudio2017Theme() : CXTPTaskPanelVisualStudio2017Theme
  • ~CXTPTaskPanelVisualStudio2019Theme() : CXTPTaskPanelVisualStudio2019Theme
  • ~CXTPTaskPanelVisualStudio2022Theme() : CXTPTaskPanelVisualStudio2022Theme
  • ~CXTPTearOffFrame() : CXTPTearOffFrame
  • ~CXTPTempColorMask() : CXTPTempColorMask
  • ~CXTPThemeDLL() : CXTPThemeDLL
  • ~CXTPThreadLocal() : CXTPThreadLocal< T >
  • ~CXTPTipOfTheDay() : CXTPTipOfTheDay
  • ~CXTPTipWindow() : CXTPTipWindow
  • ~CXTPToolBar() : CXTPToolBar
  • ~CXTPToolTipContext() : CXTPToolTipContext
  • ~CXTPToolTipContextToolTip() : CXTPToolTipContextToolTip
  • ~CXTPTrackControl() : CXTPTrackControl
  • ~CXTPTrackControlItem() : CXTPTrackControlItem
  • ~CXTPTrackHeader() : CXTPTrackHeader
  • ~CXTPTrackMarkers() : CXTPTrackMarkers
  • ~CXTPTrackPaintManager() : CXTPTrackPaintManager
  • ~CXTPTrackUndoAddBlockCommand() : CXTPTrackUndoAddBlockCommand
  • ~CXTPTrackUndoAddMarkerCommand() : CXTPTrackUndoAddMarkerCommand
  • ~CXTPTrackUndoCommand() : CXTPTrackUndoCommand
  • ~CXTPTrackUndoDeleteBlockCommand() : CXTPTrackUndoDeleteBlockCommand
  • ~CXTPTrackUndoDeleteMarkerCommand() : CXTPTrackUndoDeleteMarkerCommand
  • ~CXTPTrackUndoGroupCommand() : CXTPTrackUndoGroupCommand
  • ~CXTPTrackUndoManager() : CXTPTrackUndoManager
  • ~CXTPTrackUndoSetBlockPositionCommand() : CXTPTrackUndoSetBlockPositionCommand
  • ~CXTPTrackUndoSetMarkerPositionCommand() : CXTPTrackUndoSetMarkerPositionCommand
  • ~CXTPTrayIcon() : CXTPTrayIcon
  • ~CXTPTreeBase() : CXTPTreeBase
  • ~CXTPTreeCtrl() : CXTPTreeCtrl
  • ~CXTPTreeTheme() : CXTPTreeTheme
  • ~CXTPTreeView() : CXTPTreeView
  • ~CXTPVisualStudio2005Theme() : CXTPVisualStudio2005Theme
  • ~CXTPVisualStudio2008Theme() : CXTPVisualStudio2008Theme
  • ~CXTPVisualStudio2010Theme() : CXTPVisualStudio2010Theme
  • ~CXTPWebBrowserCtrl() : CXTPWebBrowserCtrl
  • ~CXTPWebBrowserProvider() : CXTPWebBrowserProvider
  • ~CXTPWebViewProvider() : CXTPWebViewProvider
  • ~CXTPWinApp() : CXTPWinApp
  • ~CXTPWinThemeWrapper() : CXTPWinThemeWrapper
  • ~CXTPWinThread() : CXTPWinThread
  • ~EventsMapByID_T() : CXTPCalendarData::EventsMapByID_T< _TObject >
  • ~IXTPApplicationEvents() : IXTPApplicationEvents
  • ~IXTPFrameShadowManagerEvents() : IXTPFrameShadowManagerEvents
  • ~IXTPMarkupClientSite() : IXTPMarkupClientSite
  • ~IXTPMarkupDeviceDependentImageSite() : IXTPMarkupDeviceDependentImageSite
  • ~IXTPPreview() : IXTPPreview
  • ~IXTPPreviewHost() : IXTPPreviewHost
  • ~IXTPPreviewProvider() : IXTPPreviewProvider
  • ~IXTPScrollable() : IXTPScrollable
  • ~IXTPSkinManagerWindowFilter() : IXTPSkinManagerWindowFilter
  • ~IXTPWebBrowserEventSink() : IXTPWebBrowserEventSink
  • ~XTP_CALENDAR_HITTESTINFO() : XTP_CALENDAR_HITTESTINFO
  • ~XTP_CALENDAR_PATTERN_END() : XTP_CALENDAR_PATTERN_END
  • ~XTP_SLIDERTICKS() : XTP_SLIDERTICKS


Toolkit Pro: Class Members - Functions

Here is a list of all documented functions with links to the class documentation for each member:

- _ -

  • __declspec() : CXTPGdiObject
  • _AddToCacheIfNeed() : CXTPCalendarData::CXTPDPCache
  • _AllocStringData() : CXTPHeapString, CXTPHeapStringT< _TAllocator >
  • _CalculateDateFormats() : CXTPCalendarMonthView
  • _CalculateEventCaptionFormat() : CXTPCalendarMonthView
  • _CalculateEventTimeFormat() : CXTPCalendarView
  • _CanSubjectEditor() : CXTPCalendarView
  • _CopySelectedEvents() : CXTPCalendarView
  • _DeleteItem() : CXTPExcelTabCtrl
  • _DoCollapse() : CXTPGridSection
  • _DoExpand() : CXTPGridSection
  • _DrawDateHeaderCalendar() : CXTPCalendarControlView
  • _EnableScrollBarNotify() : CXTPSyntaxEditCtrl
  • _EnsureVisibleH() : CXTPCalendarDayView
  • _EnsureVisibleSelectionH() : CXTPCalendarDayView
  • _EnsureVisibleV() : CXTPCalendarDayView
  • _FormatDayDate() : CXTPCalendarMonthView
  • _FreeStringData() : CXTPHeapString, CXTPHeapStringT< _TAllocator >
  • _GetAtGrow_BusyStatusBrushValue() : CXTPCalendarPaintManager
  • _GetButtonLength() : CXTPTabPaintManager
  • _GetDateHeaderMonths() : CXTPCalendarControlView
  • _GetDayHeaderFormat() : CXTPCalendarView
  • _GetEvents() : CXTPCalendarTimeLineView
  • _GetMaxWidth() : CXTPCalendarView
  • _GetMaxWidthFormat() : CXTPCalendarView
  • _GetNextID() : CXTPCalendarSchedules
  • _GetScrollRectClient() : CXTPCalendarDayView
  • _GetSubjectEditorWnd() : CXTPCalendarView
  • _GetTimeScaleWith() : CXTPCalendarDayView
  • _GetViewDay() : CXTPCalendarView
  • _HasEvents() : CXTPCalendarController
  • _HimetricToLP() : CXTPCalendarControlView
  • _ImageNameToResourceName() : CXTPResourceImages
  • _Init() : CXTPCalendarPaintManager
  • _InsertPane() : CXTPDockingPaneAutoHidePanel, CXTPDockingPaneSidePanel
  • _IsDragModeCopyMove() : CXTPCalendarView
  • _Load() : CXTPCalendarCustomProperties, CXTPCalendarMemoryDataProvider, CXTPCalendarResourcesManager, CXTPCalendarSchedules
  • _MoveRectY() : CXTPCalendarViewEvent
  • _ReadDefaultDateFormats() : CXTPCalendarMonthView
  • _ReadDefaultHeaderFormats() : CXTPCalendarView
  • _ReadEventsFromClipboard() : CXTPCalendarView
  • _RecalcHScrollMaxWidth() : CXTPSyntaxEditCtrl
  • _RecalcScrollBars() : CXTPSyntaxEditCtrl
  • _RedrawControl() : CXTPDatePickerControl
  • _RemoveDataForMasterEvent() : CXTPCalendarReminders
  • _RemoveYearPart() : CXTPCalendarView
  • _ResetDate_dbl() : CXTPCalendarUtils
  • _ResetTime_dbl() : CXTPCalendarUtils
  • _RoundDateTime_dbl() : CXTPCalendarUtils
  • _Save() : CXTPCalendarCustomProperties, CXTPCalendarMemoryDataProvider, CXTPCalendarResourcesManager, CXTPCalendarSchedules
  • _SaveCloseDPifNeed() : CXTPCalendarResourcesManager
  • _ScrollV() : CXTPCalendarDayView
  • _SetDataProvider() : CXTPCalendarControl
  • _SetExpanded() : CXTPGridRow
  • _SplitDateFormat() : CXTPCalendarMonthView
  • _SubtractSelSizeFromPos() : CXTPSyntaxEditCtrl
  • _Undo() : CXTPCalendarView
  • _UpdateIMEStatus() : CXTPSyntaxEditCtrl
  • _xtGetHeaderCtrl() : CXTPListBase


Toolkit Pro: Class Members - Functions

Here is a list of all documented functions with links to the class documentation for each member:

- a -

  • Activate() : CXTPCalendarTip, CXTPGridInplaceButton, CXTPGridTip, CXTPPropertyGridToolTip, CXTPSyntaxEditToolTipCtrl, IXTPPreview
  • ActivateNextPane() : CXTPDockingPaneManager
  • ActivateView() : CXTPTabExBase
  • Add() : CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE >, CXTPCalendarData::EventsMapByID_T< _TObject >, CXTPCalendarEvents, CXTPCalendarPtrCollectionT< _TObject >, CXTPChartAxisConstantLines, CXTPChartAxisCustomLabels, CXTPChartAxisStrips, CXTPChartPanelCollection, CXTPChartSeriesCollection, CXTPChartSeriesPointCollection, CXTPChartTitleCollection, CXTPCommandBarList, CXTPCommandBars, CXTPCommandBarsContextMenus, CXTPControlActions, CXTPControls, CXTPDatePickerDaysCollection, CXTPFlowGraphUndoGroupCommand, CXTPGridColumnOrder, CXTPGridColumns, CXTPGridRecords, CXTPGridRows, CXTPGridSelectedRows, CXTPImageList, CXTPImageManagerResource, CXTPMatrix< T >, CXTPPropertyGridInplaceControls, CXTPPropertyGridVerbs, CXTPRecentFileList, CXTPRibbonGroup, CXTPRibbonGroups, CXTPShortcutManagerAccelTable, CXTPTabManagerNavigateButtons, CXTPTaskPanelItems, CXTPTrackControlItem, CXTPTrackMarkers, CXTPTrackSelectedBlocks, CXTPTrackUndoGroupCommand
  • AddAxisView() : CXTPChartDiagram2DView, CXTPChartRadarDiagramView
  • AddBlock() : CXTPGridSelectedRows
  • AddButton() : CXTPDatePickerControl, CXTPMessageBar, CXTPPropertyGridInplaceButtons, CXTPPropertySheet, CXTPTaskDialog
  • AddCategories() : CXTPCustomizeCommandsPage, CXTPCustomizeKeyboardPage, CXTPRibbonCustomizePage, CXTPRibbonCustomizeQuickAccessPage
  • AddCategory() : CXTPCustomizeCommandsPage, CXTPCustomizeKeyboardPage, CXTPPropertyGrid, CXTPPropertyGridView, CXTPRibbonCustomizePage, CXTPRibbonCustomizeQuickAccessPage
  • AddChild() : CXTPGridRow
  • AddChildCommand() : CXTPChartDeviceCommand
  • AddChildItem() : CXTPPropertyGridItem
  • AddChildView() : CXTPChartElementView
  • AddClass() : CXTPSkinObjectClassMap
  • AddClone() : CXTPControls, CXTPRibbonGroup
  • AddColor() : CXTPSyntaxEditColorComboBox
  • AddColorFilter() : CXTPSkinManager
  • AddColumn() : CXTPGridControl, CXTPListBase
  • AddComboButton() : CXTPGridRecordItemEditOptions, CXTPPropertyGridInplaceButtons, CXTPPropertyGridItem
  • AddComboString() : CXTPCustomizeOptionsPage
  • AddCommand() : CXTPControlWorkspaceActions, CXTPSyntaxEditBatchCommand, CXTPSyntaxEditUndoRedoManager
  • AddConnection() : CXTPFlowGraphConnections
  • AddConnectionPoint() : CXTPFlowGraphConnectionPoints
  • AddConstraint() : CXTPGridRecordItemEditOptions, CXTPPropertyGridItemConstraints
  • AddControl() : CXTPControlAction, CXTPGridRecordItemControls, CXTPSearchOptionsCtrl, CXTPStatusBar, CXTPTabExBase
  • AddControlItem() : CXTPTaskPanelGroup
  • AddCustomBar() : CXTPCommandBars
  • AddCustomIcon() : CXTPImageManager
  • AddCustomNode() : CXTPFlowGraphNodes
  • AddCustomNodeFromToolkitResource() : CXTPFlowGraphControl
  • AddCustomScriptItem() : CXTPMarkupContext
  • AddCustomTimeIntervalForReminder() : CXTPCalendarControl
  • AddDataProvider() : CXTPCalendarResourcesManager
  • AddDay() : CXTPCalendarDayView
  • AddDefaultProviders() : CXTPPreviewCtrl
  • AddEvent() : CXTPCalendarData
  • AddEventCategory() : CXTPCalendarData
  • AddEventLabel() : CXTPCalendarData
  • AddEvents() : CXTPCalendarData
  • AddExpandButton() : CXTPGridRecordItemEditOptions, CXTPPropertyGridInplaceButtons, CXTPPropertyGridItem
  • AddFont() : CXTPFontEnum
  • AddGridRecords() : CXTPGridDataManager
  • AddGroup() : CXTPFlowGraphNodeGroups, CXTPRibbonTab, CXTPTaskPanel
  • AddHandler() : CXTPMarkupContext
  • AddHyperlink() : CXTPGridRecordItem
  • AddIcon() : CXTPTrayIcon
  • AddIcons() : CXTPImageManager
  • AddIfNeed() : CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE >
  • AddImage() : CXTPFlowGraphImages
  • AddIndicator() : CXTPStatusBar
  • AddInputBox() : CXTPTaskDialog
  • AddItem() : CXTPCalendarEventColorListBox, CXTPChartLegendView, CXTPControlGalleryItems, CXTPGridRecord, CXTPMarkupTreeCtrl, CXTPPopupControl, CXTPShortcutBar, CXTPShortcutBarPane, CXTPTabClientWnd, CXTPTabManager
  • AddLabel() : CXTPControlGalleryItems
  • AddLinkItem() : CXTPTaskPanelGroup
  • AddListener() : CXTPColorPopup, CXTPColorSelectorCtrl
  • AddMDIMenu() : CXTPMenuBar
  • AddMenuItem() : CXTPControls, CXTPShortcutListBox
  • AddMonitorFile() : CXTPSyntaxEditFileChangesMonitor
  • AddMultiDayEvent_Slave() : CXTPCalendarViewEvent
  • AddNamedConnectionPoints() : CXTPFlowGraphNode, CXTPFlowGraphNodeCustom
  • AddNamedItem() : CXTPActiveScriptEngine
  • AddNewSchedule() : CXTPCalendarSchedules
  • AddNode() : CXTPFlowGraphNodeGroup, CXTPFlowGraphNodes
  • AddObserver() : CXTPTabPaintManager
  • AddPage() : CXTPCustomizeSheet, CXTPFlowGraphPages, CXTPPropertySheet
  • AddParam() : CXTPSyntaxEditColorInfo
  • AddPoints() : CXTPChartSeriesPointCollection
  • AddProvider() : CXTPPreviewCtrl
  • AddPtr() : CXTPInternalCollectionT< _TObject >
  • AddRadioButton() : CXTPTaskDialog
  • AddRecentColor() : CXTPColorSelectorCtrl
  • AddRecord() : CXTPGridControl, CXTPGridDataManager, CXTPGridSection
  • AddRecordEx() : CXTPGridControl
  • AddRef() : CXTPActiveScriptObjectContext
  • AddRemoveBookmark() : CXTPSyntaxEditCtrl
  • AddRemoveBreakPoint() : CXTPSyntaxEditCtrl
  • AddRemoveLineMark() : CXTPSyntaxEditLineMarksManager
  • AddResource() : CXTPCalendarResourcesManager, CXTPCalendarViewGroup
  • AddSelection() : CXTPFlowGraphSelectedElements
  • AddSliderControl() : CXTPPropertyGridItem
  • AddSpinButton() : CXTPGridRecordItemEditOptions, CXTPPropertyGridItem
  • AddStandardClasses() : CXTPSkinObjectClassMap
  • AddString() : CXTPControlComboBox
  • AddStyle() : CXTPTagCloudStyleManager
  • AddSwitch() : CXTPStatusBarSwitchPane
  • AddSynonymClass() : CXTPSkinObjectClassMap
  • AddSystemButton() : CXTPRibbonBar
  • AddTab() : CXTPRibbonBar
  • AddTag() : CXTPTagCloudCtrl
  • AddTail() : CXTPPropertyGridItems
  • AddTextItem() : CXTPTaskPanelGroup
  • AddTextSchemeInfo() : CXTPSyntaxEditTextSchemesManager
  • AddThemeInfo() : CXTPSyntaxEditColorThemesManager
  • AddTip() : CXTPTipOfTheDay
  • AddToCache() : CXTPCalendarData::CXTPDPCache
  • AddToCacheIfNeed() : CXTPCalendarData::CXTPDPCache
  • AddToDiscreteSelection() : CXTPCalendarView
  • AddToolBar() : CXTPReBar
  • AddToolbarCategory() : CXTPCustomizeCommandsPage
  • AddToolTip() : CXTPTabExBase
  • AddTrustedWindow() : CXTPMouseManager
  • AddUndoCommand() : CXTPFlowGraphUndoManager, CXTPTrackUndoManager
  • AddValue() : CXTPSyntaxEditCtrl::CAverageVal
  • AddView() : CXTPTabExBase
  • AddViewPart() : CXTPCalendarPaintManager
  • AddWorkspace() : CXTPTabClientWnd
  • AdjustAdditionalScaleTimeZone() : CXTPCalendarDayView
  • AdjustBlockPosition() : CXTPTrackControlItem
  • AdjustBorders() : CXTPTabBaseTheme, CXTPTabBaseThemeOfficeXP
  • AdjustBuddyRect() : CXTPEdit, CXTPEditTheme, CXTPEditThemeDefault, CXTPEditThemeOfficeXP, CXTPEditThemeResource
  • AdjustCalendarForPrint() : CXTPCalendarControlView
  • AdjustCaptionRect() : CXTPDockingPaneOffice2002VisioTheme, CXTPDockingPanePaintManager, CXTPDockingPaneVisualStudio2012Theme
  • AdjustClientRect() : CAppearanceSetVisio, CXTPDockingPaneOffice2007WordTheme, CXTPDockingPanePaintManager, CXTPDockingPaneVisualStudio2012Theme, CXTPTabPaintManager, CXTPTabPaintManagerTheme
  • AdjustColumnsWidth() : CXTPGridHeader
  • AdjustCursor() : CXTPDockingPaneContext
  • AdjustDayEvents() : CXTPCalendarDayViewGroup
  • AdjustDays() : CXTPCalendarMonthView::CMonthViewGrid
  • AdjustEvents() : CXTPCalendarMonthView::CMonthViewGrid
  • AdjustExcludeRect() : CXTPCommandBarsNativeXPTheme, CXTPCommandBarsOffice2000Theme, CXTPCommandBarsOfficeXPTheme, CXTPControlPopup, CXTPPaintManager, CXTPPopupBar, CXTPRibbonControlSystemButton, CXTPRibbonSystemPopupBarPage, CXTPRibbonTheme, CXTPVisualStudio2008Theme, CXTPVisualStudio2010Theme
  • AdjustFirstDayOfWeek() : CXTPCalendarMonthView::CMonthViewGrid, CXTPCalendarWeekView
  • AdjustGrid() : CXTPCalendarMonthView::CMonthViewGrid
  • AdjustHeader() : CXTPCalendarMonthView::CMonthViewGrid
  • AdjustIndentation() : CXTPGridControl
  • AdjustItemCaptionRect() : CXTPPropertyGridPaintManager
  • AdjustItemValueRect() : CXTPPropertyGridPaintManager
  • AdjustLayout() : CXTPCalendarCaptionBarControl, CXTPCalendarCaptionBarTheme, CXTPCalendarCaptionBarThemePart, CXTPCalendarControl, CXTPCalendarDayView, CXTPCalendarDayViewDay, CXTPCalendarDayViewEvent, CXTPCalendarDayViewGroup, CXTPCalendarDayViewTimeScale, CXTPCalendarMonthView, CXTPCalendarMonthView::CMonthViewGrid, CXTPCalendarMonthViewDay, CXTPCalendarMonthViewEvent, CXTPCalendarTimeLineView, CXTPCalendarTimeLineViewEvent, CXTPCalendarTimeLineViewGroup, CXTPCalendarTimeLineViewTimeScale, CXTPCalendarView, CXTPCalendarViewDay, CXTPCalendarViewDayT< _TView, _TViewGroup, XTP_CALENDAR_HITTESTINFO, _TPThis >, CXTPCalendarViewEvent, CXTPCalendarViewGroup, CXTPCalendarWeekView, CXTPCalendarWeekViewDay, CXTPCalendarWeekViewEvent, CXTPCheckboxButtonPart, CXTPDatePickerControl, CXTPDatePickerItemMonth, CXTPExpandButtonPart, CXTPGridControl, CXTPGridSections, CXTPRadioButtonPart, CXTPScrollDateButtonPart, CXTPSwitchViewButtonPart, CXTPTrackControl
  • AdjustLayout2() : CXTPCalendarDayView, CXTPCalendarDayViewDay, CXTPCalendarDayViewEvent, CXTPCalendarDayViewGroup, CXTPCalendarMonthView, CXTPCalendarMonthViewDay, CXTPCalendarMonthViewEvent, CXTPCalendarTimeLineViewEvent, CXTPCalendarView, CXTPCalendarViewEvent, CXTPCalendarViewGroup, CXTPCalendarWeekView, CXTPCalendarWeekViewDay, CXTPCalendarWeekViewEvent
  • AdjustMultidayEvent() : CXTPCalendarViewEvent
  • AdjustRect() : CXTPTabControl
  • AdjustRectangle() : CXTPDockingPaneContext
  • AdjustResizeRect() : CXTPResize, CXTPResizeFormView
  • AdjustScrollBar() : CXTPCalendarControl
  • AdjustScrollBarEx() : CXTPCalendarControl
  • AdjustScrollBars() : CXTPFlowGraphControl, CXTPGridControl
  • AdjustScrollSizes() : CXTPSearchOptionsView
  • AdjustSubjectEditor() : CXTPCalendarDayViewEvent, CXTPCalendarViewEvent
  • AdjustSubjectEditorEx() : CXTPCalendarDayViewEvent
  • AdjustTimeFont() : CXTPCalendarPaintManager
  • AdjustTrackColumnWidth() : CXTPTrackControl
  • AdjustWidth() : CXTPTabManagerNavigateButton
  • Advise() : CXTPCalendarMsgNotifier, CXTPNotifyConnection, CXTPNotifySinkBase
  • AdviseToNotifications() : CXTPCalendarController
  • AfterExecute() : CXTPChart3dLineDeviceCommand, CXTPChartDeviceCommand, CXTPChartPolygonAntialiasingDeviceCommand
  • AlignColIdxToTabs() : CXTPSyntaxEditDrawTextProcessor
  • Alloc() : CXTPShellPidl::CShellMalloc
  • Alloc_mem() : CXTPHeapAllocatorT< _TData >
  • AllocateList() : CXTPOpenGLListPool
  • AllocSysString() : CXTPHeapString
  • AllowAccess() : CXTPGridSection
  • AllowCollapse() : CXTPShortcutBar
  • AllowColumnRemove() : CXTPGridHeader
  • AllowColumnReorder() : CXTPGridHeader
  • AllowColumnResize() : CXTPGridHeader
  • AllowColumnSort() : CXTPGridHeader
  • AllowDrag() : CXTPTaskPanel, CXTPTaskPanelItem
  • AllowDrop() : CXTPTaskPanel, CXTPTaskPanelItem
  • AllowEdit() : CXTPGridSection, CXTPPropertyGrid
  • AllowFilter() : CXTPGridSection
  • AllowFreeResize() : CXTPShortcutBar
  • AllowGripperResize() : CXTPShortcutBar
  • AllowGroup() : CXTPGridSection
  • AllowMinimize() : CXTPRibbonBar, CXTPShortcutBar
  • AllowMove() : CXTPPopupControl
  • AllowNewToolbars() : CXTPCustomizeToolbarsPage
  • AllowNoncontinuousSelection() : CXTPDatePickerControl
  • AllowNullDate() : CXTPPropertyGridItemDate
  • AllowQuickAccessCustomization() : CXTPRibbonBar
  • AllowQuickAccessDuplicates() : CXTPRibbonBar
  • AllowReduce() : CXTPRibbonGroup
  • AllowRemove() : CXTPGridColumn
  • AllowSort() : CXTPGridSection
  • AllowUpperCase() : CXTPShellSettings
  • AlphaBlend() : CXTPImageManager
  • AlphaBlend2() : CXTPImageManager
  • AlphaBorder() : CXTPVisualStudio2008Theme
  • AlphaPixel() : CXTPCalendarShadowDrawer, CXTPVisualStudio2008Theme
  • Animate() : CXTPAnimationDC, CXTPPaintManager, CXTPPopupBar, CXTPPopupControl
  • AnimateExpanding() : CXTPPaintManager
  • AnimateGroups() : CXTPTaskPanel
  • AnimatePageTransition() : CXTPFlowGraphControl, CXTPFlowGraphPageHistory
  • AnimateTo() : CXTPFlowGraphControl
  • Append() : CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE >, CXTPCalendarEvents, CXTPCalendarPtrCollectionT< _TObject >, CXTPMemFile
  • Apply() : CXTPGridInplaceList, CXTPPropertyGridInplaceList, CXTPPropertyGridInplaceMultilineEdit
  • ApplyCenterPoint() : CXTPChartEllipse
  • ApplyColorFilter() : CXTPSkinManager, CXTPSkinManagerColorFilter
  • ApplyFieldWidths() : CXTPHeaderCtrl
  • ApplyFilter() : CXTPGridControl
  • ApplyRenderTransform() : CXTPMarkupUIElement, CXTPMarkupVisual
  • ApplySeriesStyle() : CXTPChartDeviceCommand
  • ApplyShadow2007BL() : CXTPCalendarShadowDrawer
  • ApplyShadow2007Bottom() : CXTPCalendarShadowDrawer
  • ApplyShadow2007BR() : CXTPCalendarShadowDrawer
  • ApplyShadow2007Center() : CXTPCalendarShadowDrawer
  • ApplyShadow2007Right() : CXTPCalendarShadowDrawer
  • ApplyShadow2007TR() : CXTPCalendarShadowDrawer
  • ApplyShadowBL() : CXTPCalendarShadowDrawer
  • ApplyShadowBR() : CXTPCalendarShadowDrawer
  • ApplyShadowLR() : CXTPCalendarShadowDrawer
  • ApplyShadowTB() : CXTPCalendarShadowDrawer
  • ApplyShadowTR() : CXTPCalendarShadowDrawer
  • ApplyTheme() : CXTPSyntaxEditCtrl, CXTPSyntaxEditLexTextSchema
  • ApplyThemeRecursive() : CXTPSyntaxEditLexTextSchema
  • ApplyTo() : CXTPChartSeriesStyle
  • ApplyToCalendar() : CXTPCalendarResourcesManager
  • ApplyToDeviceContext() : CXTPChartDiagram3DAppearance, CXTPChartElementAppearance
  • ApplyTransform() : CXTPMarkupGdiPlusTransformObjectImpl, CXTPMarkupMatrixTransform, CXTPMarkupRotateTransform, CXTPMarkupScaleTransform, CXTPMarkupSkewTransform, CXTPMarkupTransform, CXTPMarkupTranslateTransform
  • ApplyWindow() : CXTPSkinManager
  • Arrange() : CXTPFlowGraphControl, CXTPFlowGraphPage, CXTPMarkupUIElement
  • ArrangeCore() : CXTPMarkupUIElement
  • AssignDocTemplate() : CXTPControl
  • AssignFile() : CXTPPropExchangeIniFile
  • AssignIconViewPropNumAndIconNum() : CXTPGridControl
  • AssociateCombo() : CXTPShellTreeBase, CXTPShellTreeCtrl
  • AssociateList() : CXTPShellTreeCtrl
  • AssociateTree() : CXTPShellListCtrl
  • Attach() : CXTPDockingPane, CXTPImageList, CXTPImageManagerIconHandle, CXTPTabClientWnd
  • AttachCalendar() : CXTPCalendarCaptionBarTheme
  • AttachPane() : CXTPDockingPaneManager
  • AttachView() : CXTPDockingPane
  • AutoAdjustLayout() : CXTPDatePickerItemMonth
  • AutoLoadPlacement() : CXTPPropertySheet, CXTPResize
  • AutoSaveColumns() : CXTPListBase
  • AutoSizeColumn() : CXTPListBase


Toolkit Pro: Class Members - Functions

Here is a list of all documented functions with links to the class documentation for each member:

- b -

  • BaseTheme() : CXTPCommandBarsNativeXPTheme, CXTPCommandBarsOffice2000Theme, CXTPCommandBarsOffice2003Theme, CXTPCommandBarsOffice2013Theme, CXTPCommandBarsOfficeXPTheme, CXTPCommandBarsVisualStudio2012Theme, CXTPPaintManager, CXTPResourceTheme, CXTPRibbonTheme, CXTPVisualStudio2005Theme, CXTPVisualStudio2008Theme, CXTPVisualStudio2010Theme
  • BeforeExecute() : CXTPChartDeviceCommand, CXTPChartPolygonAntialiasingDeviceCommand
  • BeforeUpdateRange() : CXTPChartBarSeriesView
  • BEGIN_VIEW_PART() : CXTPCalendarPaintManager
  • BeginBufferedPaint() : CXTPWinThemeWrapper
  • BeginDrag() : CXTPGridSubListControl, CXTPImageList, CXTPShellTreeBase
  • BeginEdit() : CXTPCalendarEventColorListBox, CXTPGridIconNavigator, CXTPGridNavigator
  • BeginFrequentUpdates() : CXTPChartContainer
  • BeginUpdate() : CXTPGridControl, CXTPPropertyGrid
  • BestFit() : CXTPGridHeader, CXTPStatusBarPane
  • BindHost() : CXTPPreviewProviderBase, IXTPPreviewProvider
  • BindToBool() : CXTPPropertyGridItemBool
  • BindToColor() : CXTPPropertyGridItemColor
  • BindToDate() : CXTPPropertyGridItemDate
  • BindToDouble() : CXTPPropertyGridItemDouble
  • BindToEnum() : CXTPPropertyGridItemEnum
  • BindToFlags() : CXTPPropertyGridItemFlags
  • BindToNumber() : CXTPPropertyGridItemNumber
  • BindToOption() : CXTPPropertyGridItemOption
  • BindToPoint() : CXTPPropertyGridItemPoint
  • BindToSize() : CXTPPropertyGridItemSize
  • BindToString() : CXTPPropertyGridItem
  • BindView() : CXTPChartDeviceCommand
  • BlackWhiteBitmap() : CXTPImageManager
  • BlendColor() : CXTPTaskPanelPaintManager
  • BrowseCtrlCallback() : CXTPBrowseDialog
  • BrowseToFolder() : CXTPShellListCtrlEx
  • BufferedPaintSetAlpha() : CXTPWinThemeWrapper
  • BuildColumns() : CXTPListBase
  • BuildDefaultColumns() : CXTPShellListBase
  • BuildIfNeed() : CXTPSyntaxEditLexTextSchema
  • BuildTree() : CXTPGridSection
  • ButtonHitTest() : CXTPExcelTabCtrl
  • ByFontAdjustLayout() : CXTPDatePickerItemMonth


Toolkit Pro: Class Members - Functions

Here is a list of all documented functions with links to the class documentation for each member:

- c -

  • CacheGlobalData() : CXTPTaskPanelItem
  • CalcAbsCol() : CXTPSyntaxEditCtrl
  • CalcAveDataSize() : CXTPSyntaxEditBufferManager, CXTPSyntaxEditCtrl
  • CalcButtonBandRect() : CXTPDatePickerControl
  • CalcButtonSize() : CXTPDatePickerControl
  • CalcClientHeight() : CXTPRibbonBar
  • CalcColorRect() : CXTPCalendarComboBoxBase, CXTPCalendarEventColorListBox
  • CalcColumnHeight() : CXTPGridPaintManager
  • CalcDayDateRect() : CXTPCalendarMonthViewDay
  • CalcDayOfMonth() : CXTPCalendarUtils
  • CalcDayOfWeekRect() : CXTPDatePickerPaintManager
  • CalcDayRect() : CXTPDatePickerPaintManager
  • CalcDispCol() : CXTPSyntaxEditCtrl
  • CalcDockingLayout() : CXTPDialogBar, CXTPTabToolBar, CXTPToolBar
  • CalcDynamicLayout() : CXTPCommandBar, CXTPDialogBar, CXTPPopupBar, CXTPPopupToolBar, CXTPRibbonSystemPopupBar, CXTPRibbonSystemPopupBarPage, CXTPRibbonTabPopupToolBar, CXTPTabToolBar, CXTPToolBar
  • CalcDynamicSize() : CXTPControls, CXTPRibbonGroups
  • CalcEditRects() : CXTPSyntaxEditCtrl
  • CalcEllipseAngleFromCircleAngle() : CXTPChartEllipse
  • CalcEllipsePoint() : CXTPChartEllipse
  • CalcEllipseRadius() : CXTPChartEllipse
  • CalcEllipseSectorArea() : CXTPChartEllipse
  • CalcEllipseSectorFinishAngle() : CXTPChartEllipse
  • CalcEventSize() : CXTPCalendarPaintManager, CXTPCalendarTimeLineViewPart
  • CalcFrameBorder() : CXTPCommandBarsFrameHook, CXTPFramePaintManager, CXTPFrameThemeOffice2007System
  • CalcFrameCaption() : CXTPFramePaintManager
  • CalcFrameRegion() : CXTPFramePaintManager, CXTPFrameThemeOffice2007System
  • CalcGroupsHeight() : CXTPRibbonBar
  • CalcHeigt() : CXTPCalendarTimeLineViewTimeScalePart
  • CalcHScroll() : CXTPScrollBarPaintManager
  • CalcIconsRect() : CXTPCalendarViewEvent, CXTPCalendarWeekViewEvent
  • CalcInsideHeight() : CXTPTaskPanelGroup
  • CalcItemRect() : CXTPSyntaxEditTipWnd
  • CalcMaximumWidth() : CXTPSyntaxEditCtrl
  • CalcMaxLineTextLength() : CXTPSyntaxEditBufferManager
  • CalcMinimumItemHeight() : CXTPCheckListBox
  • CalcMinRect() : CXTPCalendarCaptionBarControl, CXTPCalendarCaptionBarTheme
  • CalcMinSize() : CXTPFlowGraphNode, CXTPFlowGraphNodeCustom
  • CalcMonthHeaderRect() : CXTPDatePickerPaintManager
  • CalcMonthRect() : CXTPDatePickerPaintManager
  • CalcPopupSize() : CXTPControls
  • CalcQuickAccessHeight() : CXTPRibbonBar
  • CalcRect() : CXTPCalendarTimeLineViewEvent
  • CalcRowLayout() : CXTPTagCloudCtrl
  • CalcScaleIntervalBegin() : CXTPCalendarTLV_TimeScaleParams
  • CalcSideMarginsValue() : CXTPChartAxis, CXTPChartAxisX, CXTPChartAxisY, CXTPChartRadarAxisX, CXTPChartRadarAxisY
  • CalcSize() : CXTPChartDiagram2DAxisView, CXTPChartLegendView, CXTPChartRadarAxisXView, CXTPChartRadarAxisYView, CXTPColorSelectorCtrl, CXTPColorSelectorCtrlTheme, CXTPColorSelectorCtrlThemeOffice2013, CXTPDialogBar
  • CalcStartEndDatesFromPattern() : CXTPCalendarEvent
  • CalcToolTipRect() : CXTPCalendarTip
  • CalculateAnchorPointAndAngles() : CXTPChartPieSeriesLabel
  • CalculateBounds() : CXTPChartRotatedTextPainterBase, CXTPChartTextPainter, CXTPChartTextPainterBase
  • CalculateCenter() : CXTPChartPieBase
  • CalculateDocumentRow() : CXTPSyntaxEditCtrl
  • CalculateEditbarLength() : CXTPSyntaxEditCtrl
  • CalculateHeaderFormat() : CXTPCalendarView
  • CalculateHeight() : CXTPPopupItem
  • CalculateLabelLayout() : CXTPChartFunnelSeriesViewBase, CXTPChartPieSeriesViewBase, CXTPChartPyramidSeriesViewBase
  • CalculateLayout() : CXTPChart3dFunnelSeriesPointView, CXTPChart3dPieSeriesPointView, CXTPChart3dPyramidSeriesPointView, CXTPChartFunnelSeriesPointViewBase, CXTPChartPieSeriesLabelView, CXTPChartPieSeriesPointView, CXTPChartPieSeriesPointViewBase, CXTPChartPyramidSeriesPointView, CXTPChartPyramidSeriesPointViewBase
  • CalculateLeftTopPoint() : CXTPChartRotatedTextPainterBase, CXTPChartRotatedTextPainterNearLine
  • CalculatePointLayout() : CXTPChart3dFunnelSeriesView, CXTPChart3dPieSeriesView, CXTPChart3dPyramidSeriesView, CXTPChartFunnelSeriesView, CXTPChartFunnelSeriesViewBase, CXTPChartPieSeriesView, CXTPChartPieSeriesViewBase, CXTPChartPyramidSeriesView, CXTPChartPyramidSeriesViewBase
  • CalculatePoints() : CXTPChartRotatedTextPainterBase
  • CalculatePopupRect() : CXTPPopupBar, CXTPRibbonTabPopupToolBar
  • CalculateRects() : CXTPColorDialog
  • CalculateRotation() : CXTPChartRotatedTextPainterBase, CXTPChartRotatedTextPainterNearLine
  • CalculateRowHeight() : CXTPGridPaintManager
  • CalculateSeriesLayout() : CXTPChartDiagram, CXTPChartFunnelDiagramBase< BaseDiagram >, CXTPChartPieDiagramBase< BaseDiagram >, CXTPChartPyramidDiagramBase< BaseDiagram >
  • CalculateTabWidth() : CXTPTabExBase
  • CalculateView() : CXTPChartContentView, CXTPChartDiagram2DView, CXTPChartDiagramView, CXTPChartLegendView, CXTPChartRadarDiagramView
  • CalculateVisibleRow() : CXTPSyntaxEditCtrl
  • CalculateVisibleRow_() : CXTPSyntaxEditCtrl
  • CalculateWidth() : CXTPPopupItem
  • CalcValidDispCol() : CXTPSyntaxEditCtrl
  • CalcVScroll() : CXTPScrollBarPaintManager
  • CalcWeekNumbersRect() : CXTPDatePickerPaintManager
  • CalcWidth() : CXTPCalendarDayViewTimeScale, CXTPCalendarPaintManager
  • CanAttach() : CXTPDockingPaneTabbedContainer
  • Cancel() : CXTPGridInplaceList, CXTPPropertyGridInplaceList, CXTPPropertyGridInplaceMultilineEdit
  • CancelDrag() : CXTPGridSubListControl
  • CancelDraggingEvent() : CXTPCalendarView
  • CancelLabelEdit() : CXTPFlowGraphControl
  • CancelLoop() : CXTPDockingPaneContext
  • CancelMouseMode() : CXTPGridHeader
  • CancelRightButtonDrag() : CXTPSyntaxEditCtrl
  • CancelToolTips() : CXTPToolTipContext
  • CanChangeReadonlyFile() : CXTPSyntaxEditView
  • CanCopy() : CXTPCalendarView, CXTPGridControl
  • CanCut() : CXTPCalendarView, CXTPGridControl
  • CanDock() : CXTPCommandBars
  • CanEditDoc() : CXTPSyntaxEditCtrl
  • CanGoBackward() : CXTPFlowGraphPageHistory
  • CanGoForward() : CXTPFlowGraphPageHistory
  • CanOverType() : CXTPMaskEditT< TBase >
  • CanPaste() : CXTPCalendarView, CXTPEdit, CXTPFlowGraphPage, CXTPGridControl
  • CanRedo() : CXTPCalendarView, CXTPFlowGraphUndoManager, CXTPSyntaxEditCtrl, CXTPSyntaxEditUndoRedoManager, CXTPTrackUndoManager
  • CanUndo() : CXTPCalendarView, CXTPFlowGraphUndoManager, CXTPSyntaxEditCtrl, CXTPSyntaxEditUndoRedoManager, CXTPTrackUndoManager
  • CanUseMask() : CXTPMaskEditT< TBase >
  • CAppearanceSetPropertyPage2003() : CAppearanceSetPropertyPage2003
  • CAppearanceSetPropertyPage2007() : CAppearanceSetPropertyPage2007
  • CAppearanceSetPropertyPageAccess2007() : CAppearanceSetPropertyPageAccess2007
  • CAppearanceSetPropertyPageFlat() : CAppearanceSetPropertyPageFlat
  • CAppearanceSetStateButtons() : CAppearanceSetStateButtons
  • CAppearanceSetVisualStudio2005() : CAppearanceSetVisualStudio2005
  • CAverageVal() : CXTPSyntaxEditCtrl::CAverageVal
  • CCaptionButton() : CXTPSkinObjectFrame::CCaptionButton
  • CCheckListState() : CXTPCheckListBox::CCheckListState
  • CColorSetVisualStudio2005() : CColorSetVisualStudio2005
  • CEmptySyncObject() : CXTPNotifyConnection::CEmptySyncObject
  • CenterIcon() : CXTPPopupItem
  • CExclusiveLock() : CXTPRWCriticalSection::CExclusiveLock
  • ChainLastCommand() : CXTPSyntaxEditUndoRedoManager
  • ChangeCase() : CXTPSyntaxEditBufferManager
  • ChangeColumnOrder() : CXTPGridColumns
  • ChangeEvent() : CXTPCalendarData
  • ChangeEventPlace() : CXTPCalendarDayViewEvent, CXTPCalendarTimeLineViewEvent, CXTPCalendarViewEvent
  • ChangeTabification() : CXTPSyntaxEditBufferManager
  • CheckChar() : CXTPMaskEditT< TBase >
  • CheckCommandBarsTheme() : CXTPTabClientWnd
  • CheckDeadEnd() : CXTPGridNavigator
  • CheckFileModified() : CXTPSyntaxEditDoc
  • CheckForMouseOver() : CXTPDockingPaneCaptionButton, CXTPDockingPaneCaptionButtons
  • CheckFromPoint() : CXTPCheckListBox
  • CheckKeyboardTips() : CXTPRibbonBackstageView
  • CheckScrollBarsDraw() : CXTPSkinObjectComCtl32Control, CXTPSkinObjectUser32Control
  • CheckScrollButtonMouseOver() : CXTPTaskPanel
  • CheckTabsKeyboardTips() : CXTPRibbonBackstageView
  • CheckValue() : CXTPCalendarShadowDrawer
  • ChooseDirectory() : CXTPBrowseEdit
  • ChooseFile() : CXTPBrowseEdit
  • ClampA() : CXTPChartColor
  • ClampB() : CXTPChartColor
  • ClampG() : CXTPChartColor
  • ClampR() : CXTPChartColor
  • CleanOfRedundant() : CXTPGridRecords
  • CleanUp() : CXTPHeaderCtrlTheme, CXTPSyntaxEditBufferManager
  • Cleanup() : CXTPFlowGraphPaintManager, CXTPSyntaxEditColorTheme
  • Clear() : CXTPCalendarEvent, CXTPDatePickerDaysCollection, CXTPFlowGraphPageHistory, CXTPFlowGraphSelectedElements, CXTPFlowGraphUndoManager, CXTPGridColumnOrder, CXTPGridColumns, CXTPGridRows, CXTPGridSelectedRows, CXTPImageManagerIconHandle, CXTPImageManagerResource, CXTPPropertyGridItems, CXTPSyntaxEditBatchCommand, CXTPSyntaxEditTextRegion, CXTPSyntaxEditUndoRedoManager, CXTPTaskPanelItems, CXTPTrackUndoManager, XTP_EDIT_LINECOL
  • ClearAllItems() : CXTPExcelTabCtrl
  • ClearCache() : CXTPCalendarData
  • ClearDays() : CXTPDatePickerItemMonth
  • ClearDeleteGridRecords() : CXTPGridDataManager
  • ClearDiscreteSelection() : CXTPCalendarView
  • ClearEventCategoryList() : CXTPCalendarData
  • ClearEventLabelList() : CXTPCalendarData
  • ClearFocus() : CXTPDatePickerControl
  • ClearGridControl() : CXTPGridDataManager
  • ClearIconMap() : CXTPDockingPaneManager
  • ClearIntermediateData() : CXTPCalendarEvent
  • ClearMergeHeight() : CXTPGridRows
  • ClearMonths() : CXTPDatePickerControl
  • ClearOnScreenSchCache() : CXTPSyntaxEditCtrl
  • ClearOriginalControls() : CXTPControls
  • ClearProperties() : CXTPCalendarReminderForOccurrenceArray, CXTPResourceImages
  • ClearProperty() : CXTPSkinManagerSchemaProperty
  • Click() : CXTPDockingPaneCaptionButton, CXTPMessageBar
  • ClickButton() : CXTPTaskDialog
  • ClickRadioButton() : CXTPTaskDialog
  • ClickToolBarButton() : CXTPControl
  • ClickVerification() : CXTPTaskDialog
  • ClipAndAddEllipsisIfNeeded() : CXTPDockingPanePaintManager
  • ClipItems() : CXTPControlGalleryItems
  • CLock() : CXTPSimpleCriticalSection::CLock
  • CLogFont() : CXTPPaintManager::CLogFont
  • Clone() : CXTPDockingPaneBase, CXTPMarkupGdiPlusTransformationMatrix, CXTPMarkupTransformationMatrix, CXTPMatrix< T >, CXTPPropExchangeXMLNode, CXTPSyntaxEditLexTextSchema, CXTPSyntaxEditLexVariant
  • CloneEvent() : CXTPCalendarEvent
  • CloneEvents() : CXTPCalendarEvents
  • CloneEventTo() : CXTPCalendarEvent
  • CloneForOccurrence() : CXTPCalendarEvent
  • ClonePattern() : CXTPCalendarRecurrencePattern
  • Close() : CXTPCalendarCustomDataProvider, CXTPCalendarData, CXTPCalendarDatabaseDataProvider, CXTPCalendarMemoryDataProvider, CXTPDockingPane, CXTPMemFile, CXTPPopupControl, CXTPResourceManager, CXTPResourceManagerXML, CXTPSkinManagerResourceFile, CXTPSyntaxEditBufferManager, CXTPSyntaxEditConfigurationManager, CXTPSyntaxEditLexClass, CXTPSyntaxEditLexParser, CXTPSyntaxEditLexTextBlock, CXTPSyntaxEditLexTextSchema
  • CloseActiveWindow() : CXTPDockingPaneAutoHidePanel
  • CloseActiveWindows() : CXTPDockingPaneAutoHidePanel
  • CloseAll() : CXTPDockingPaneManager
  • CloseClasses() : CXTPSyntaxEditLexClass
  • ClosePane() : CXTPDockingPaneManager
  • CloseParseThread() : CXTPSyntaxEditLexParser
  • ClosePopups() : CXTPCommandBars
  • CloseThemeData() : CXTPWinThemeWrapper
  • CLRFONT() : CXTPTreeBase::CLRFONT
  • CManageState() : CXTPResourceManager::CManageState
  • CMonthViewGrid() : CXTPCalendarMonthView::CMonthViewGrid
  • ColFromXPos() : CXTPSyntaxEditDrawTextProcessor
  • Collapse() : CXTPDockingPaneMiniWnd, CXTPDockingPaneSidePanel, CXTPPropertyGridItem
  • CollapseAll() : CXTPGridControl, CXTPGridSection, CXTPSyntaxEditCtrl
  • CollapseExpandBlock() : CXTPSyntaxEditCtrl
  • ColorFromPoint() : CXTPColorHex
  • ColToStrPos() : CXTPSyntaxEditBufferManager
  • CommandToIndex() : CXTPControls, CXTPStatusBar
  • Commit() : CXTPChartDeviceCommand
  • CommitContextMenu() : CXTPCustomizeMenusPage
  • CommitDraggingEvent() : CXTPCalendarView
  • CommitList() : CXTPOpenGLListPool
  • CommonConstruct() : CXTPChartSeriesPoint
  • Compare() : CXTPControl, CXTPControlComboBox, CXTPControlEdit, CXTPControlPopup, CXTPControls, CXTPGridRecordItem, CXTPGridRecordItemDateTime, CXTPGridRecordItemNumber, CXTPGridRecordItemVariant, CXTPGridRecords, CXTPMathUtils, CXTPSortClass
  • CompareEvents_ByID() : CXTPCalendarEvents
  • CompareEvents_ForView() : CXTPCalendarEvents
  • CompareEvents_ForViewByStart() : CXTPCalendarEvents
  • CompareGroupCaption() : CXTPGridRecordItem, CXTPGridRecordItemDateTime, CXTPGridRecordItemNumber, CXTPGridRecordItemVariant
  • ComparePidls() : CXTPShellPidl
  • CompareRows() : CXTPGridRows
  • CompareRows2() : CXTPGridRows
  • ComputeConnectorBend() : CXTPChart3dPieSeriesLabelDeviceCommand
  • ComputeConnectorVector() : CXTPChart3dFunnelSeriesLabelDeviceCommand, CXTPChart3dPieSeriesLabelDeviceCommand, CXTPChart3dPyramidSeriesLabelDeviceCommand
  • ComputeLabel() : CXTPChart3dFunnelSeriesLabelDeviceCommand, CXTPChart3dPieSeriesLabelDeviceCommand, CXTPChart3dPyramidSeriesLabelDeviceCommand
  • ComputeTriangleNormal() : CXTPMathUtils, CXTPOpenGLUtils
  • ComputeVectorCrossProduct() : CXTPMathUtils
  • ComputeVectorDotProduct() : CXTPMathUtils
  • ComputeVectorLength() : CXTPMathUtils
  • ConcatPidls() : CXTPShellPidl
  • Condense() : CXTPTabExBase
  • ConstructCaption() : CXTPControlWindowList
  • ContainPane() : CXTPDockingPaneBase, CXTPDockingPaneBaseContainer
  • Contains() : CXTPDatePickerDaysCollection, CXTPGridRows, CXTPGridSelectedRows, CXTPRectT< T >
  • ContainsInvisibleEvents() : CXTPCalendarViewDay
  • ContainsInvisibleEventsUpdate() : CXTPCalendarViewDay
  • ContainsPopup() : CXTPControlPopup
  • ContextMenu() : CXTPCommandBars, CXTPCustomizeSheet, CXTPTabClientWnd
  • Contract() : CXTPSearchOptionsCtrl
  • ConvertFrom() : CXTPMarkupGridLength
  • ConvertToBits() : CXTPResourceImage
  • ConvertToIcon() : CXTPTransparentBitmap
  • ConvertUnicodeAlpha() : CXTPMaskEditT< TBase >
  • Copy() : CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE >, CXTPCalendarView, CXTPCommandBar, CXTPControl, CXTPControlButton, CXTPControlButtonColor, CXTPControlComboBox, CXTPControlComboBoxList, CXTPControlCustom, CXTPControlEdit, CXTPControlFontComboBoxList, CXTPControlGallery, CXTPControlListBox, CXTPControlPopup, CXTPControlPopupColor, CXTPControlProgress, CXTPControls, CXTPControlSelector, CXTPControlStatic, CXTPDockingPane, CXTPDockingPaneBase, CXTPDockingPaneLayout, CXTPDockingPaneMiniWnd, CXTPDockingPaneSidePanel, CXTPDockingPaneSplitterContainer, CXTPDockingPaneTabbedContainer, CXTPFlowGraphPage, CXTPGridControl, CXTPImageList, CXTPImageManagerIcon, CXTPMenuBar, CXTPPopupBar, CXTPRibbonControls, CXTPRibbonControlTab, CXTPRibbonGroup, CXTPRibbonGroups, CXTPRibbonTab, CXTPSyntaxEditCtrl, CXTPTagCloudStyle, CXTPToolBar
  • CopyAccels() : CXTPShortcutManagerAccelTable
  • CopyAccelTable() : CXTPShortcutManagerAccelTable
  • CopyAlphaBitmap() : CXTPImageManagerIcon
  • CopyFrom() : CXTPGridHyperlinks, CXTPGridRecordItemControls
  • CopyHandle() : CXTPImageManagerIconHandle
  • CopyIDList() : CXTPShellPidl
  • CopyOrMoveText() : CXTPSyntaxEditCtrl
  • CopyPidlItem() : CXTPShellPidl
  • CopyRow() : CXTPListBase
  • CopySettings() : CXTPCalendarThemeCustomizableXValueT< _TValue, _TValueRef >, CXTPCalendarThemeFontValue, CXTPCalendarViewPartCustomizableValueT< _TValue >
  • CopyTo() : CXTPCalendarCustomProperties
  • CopyToClipboard() : CXTPChartControl, CXTPColorDialog, CXTPMaskEditT< TBase >, CXTPTaskPanelItem
  • Correct() : CXTPChartAxisRange
  • CorrectAxisSideMargins() : CXTPChartBarSeriesStyle, CXTPChartBubbleSeriesStyle, CXTPChartSeriesStyle, CXTPChartStackedBarSeriesStyle
  • Create() : CXTPBrowseButton, CXTPCalendarCaptionBarControl, CXTPCalendarControl, CXTPCalendarData, CXTPCalendarDatabaseDataProvider, CXTPCalendarMemoryDataProvider, CXTPCalendarRemindersDialog, CXTPCalendarTip, CXTPCaption, CXTPCaptionPopupWnd, CXTPChartScaleTypeMap, CXTPCheckListBox, CXTPColorPopup, CXTPColorSelectorCtrl, CXTPDatePickerControl, CXTPDatePickerList, CXTPDockingPaneAutoHidePanel, CXTPDockingPaneMiniWnd, CXTPDockingPaneSidePanel, CXTPDockingPaneSplitterWnd, CXTPExcelTabCtrl, CXTPEyeDropper, CXTPFlowGraphControl, CXTPFlowGraphEditItem, CXTPFrameShadow, CXTPGaugeCtrl, CXTPGridControl, CXTPGridHeaderDragWnd, CXTPGridHeaderDropWnd, CXTPGridInplaceButton, CXTPGridInplaceEdit, CXTPGridInplaceList, CXTPGridTip, CXTPHexEdit, CXTPImageList, CXTPItemEdit, CXTPMessageBar, CXTPPageScroller, CXTPPopupBar, CXTPPopupControl, CXTPPreviewCtrl, CXTPPropertyGrid, CXTPPropertyGridInplaceEdit, CXTPPropertyGridInplaceList, CXTPPropertyGridInplaceMultilineEdit, CXTPPropertyGridToolTip, CXTPPropertyPageNavigator, CXTPPropertySheet, CXTPScrollable< Base >, CXTPShortcutBar, CXTPShortcutBarPane, CXTPShortcutListBox, CXTPStatusBar, CXTPStickerBase, CXTPSyntaxEditAutoCompleteWnd, CXTPSyntaxEditCtrl, CXTPSyntaxEditTipWnd, CXTPSyntaxEditToolTipCtrl, CXTPTabClientDraggingContents, CXTPTabControl, CXTPTagCloudCtrl, CXTPTaskDialog, CXTPTaskDialogLinkCtrl, CXTPTaskPanel, CXTPTipWindow, CXTPToolBar, CXTPTrayIcon, CXTPWebBrowserCtrl
  • Create32BPPDIBSection() : CXTPImageManager
  • CreateAction() : CXTPCommandBars
  • CreateAutoButton() : CXTPColorSelectorCtrlTheme, CXTPColorSelectorCtrlThemeOffice2013
  • CreateBar() : IXTPScrollable
  • CreateBorder() : CXTPGridRecordItem
  • CreateBoundedPieDeviceCommand() : CXTPChart3dPie, CXTPChartPie, CXTPChartPieBase
  • CreateBrushIndirect() : CXTPBrush
  • CreateButtonIcons() : CXTPExcelTabCtrl
  • CreateButtons() : CXTPPropertySheet
  • CreateCellArray() : CXTPColorHex
  • CreateCircleDeviceCommand() : CXTPChartFillStyle
  • CreateColorButtons() : CXTPColorSelectorCtrlTheme
  • CreateColumns() : CXTPGridDataManager
  • CreateComboBoxGalleryPopupBar() : CXTPControlComboBoxGalleryPopupBar
  • CreateCommandBars() : CXTPCommandBars
  • CreateConnectorDeviceCommand() : CXTPChart3dFunnelSeriesLabelView, CXTPChart3dPieSeriesLabelView, CXTPChart3dPyramidSeriesLabelView, CXTPChartPieSeriesLabelView, CXTPChartPieSeriesLabelViewBase
  • CreateConstantLinesDeviceCommand() : CXTPChartDiagram2DAxisView, CXTPChartRadarAxisXView, CXTPChartRadarAxisYView
  • CreateContainer() : CXTPDockingPaneBase, CXTPDockingPaneMiniWnd, CXTPDockingPaneTabbedContainer
  • CreateContext() : CXTPActiveScriptEngine
  • CreateContextWindow() : CXTPDockingPaneContext
  • CreateControl() : IXTPScrollable
  • CreateControlCustom() : CXTPControlCustom
  • CreateControlPopup() : CXTPControlPopup
  • CreateDataProvider() : CXTPCalendarControl, CXTPCalendarData
  • CreateDeviceComand() : CXTPChartContent
  • CreateDeviceCommand() : CXTPChart3dDiagramView, CXTPChart3dFunnelSeriesLabelsView, CXTPChart3dFunnelSeriesLabelView, CXTPChart3dFunnelSeriesPointView, CXTPChart3dFunnelSeriesView, CXTPChart3dPieSeriesLabelsView, CXTPChart3dPieSeriesLabelView, CXTPChart3dPieSeriesPointView, CXTPChart3dPieSeriesView, CXTPChart3dPyramidSeriesLabelsView, CXTPChart3dPyramidSeriesLabelView, CXTPChart3dPyramidSeriesPointView, CXTPChart3dPyramidSeriesView, CXTPChartAreaSeriesView, CXTPChartBarSeriesLabelView, CXTPChartBarSeriesPointView, CXTPChartBorder, CXTPChartBubbleSeriesLabelView, CXTPChartBubbleSeriesPointView, CXTPChartBubbleSeriesView, CXTPChartCandleStickSeriesPointView, CXTPChartContentView, CXTPChartDiagram2DAxisView, CXTPChartDiagram2DSeriesLabelView, CXTPChartDiagram2DView, CXTPChartDiagramView, CXTPChartElementView, CXTPChartFastLineSeriesView, CXTPChartFillStyle, CXTPChartFunnelSeriesLabelView, CXTPChartFunnelSeriesLabelViewBase, CXTPChartFunnelSeriesPointView, CXTPChartFunnelSeriesPointViewBase, CXTPChartFunnelSeriesView, CXTPChartFunnelSeriesViewBase, CXTPChartHighLowSeriesPointView, CXTPChartLegendView, CXTPChartLineSeriesView, CXTPChartLineStyle, CXTPChartMarker, CXTPChartPieSeriesLabelsView, CXTPChartPieSeriesLabelsViewBase, CXTPChartPieSeriesLabelView, CXTPChartPieSeriesLabelViewBase, CXTPChartPieSeriesPointView, CXTPChartPieSeriesPointViewBase, CXTPChartPieSeriesView, CXTPChartPieSeriesViewBase, CXTPChartPointSeriesPointView, CXTPChartPyramidSeriesLabelView, CXTPChartPyramidSeriesLabelViewBase, CXTPChartPyramidSeriesPointView, CXTPChartPyramidSeriesPointViewBase, CXTPChartPyramidSeriesView, CXTPChartPyramidSeriesViewBase, CXTPChartRadarAreaSeriesView, CXTPChartRadarAxisXView, CXTPChartRadarAxisYView, CXTPChartRadarDiagramView, CXTPChartRadarLineSeriesView, CXTPChartRadarPointSeriesLabelView, CXTPChartRadarPointSeriesPointView, CXTPChartRadarSplineAreaSeriesView, CXTPChartRadarSplineSeriesView, CXTPChartRangeAreaSeriesLabelView, CXTPChartRangeBarSeriesLabelView, CXTPChartRangeBarSeriesPointView, CXTPChartRangeSplineAreaSeriesPointView, CXTPChartRangeSplineAreaSeriesView, CXTPChartRotatedTextPainterBase, CXTPChartSplineAreaSeriesView, CXTPChartSplineSeriesView, CXTPChartStackedAreaSeriesView, CXTPChartStackedBarSeriesPointView, CXTPChartStackedSplineAreaSeriesView, CXTPChartStepAreaSeriesView, CXTPChartStepLineSeriesView, CXTPChartTextPainter
  • CreateDeviceContext() : CXTPChartContent
  • CreateDiagram() : CXTPChart3dFunnelSeriesStyle, CXTPChart3dPieSeriesStyle, CXTPChart3dPyramidSeriesStyle, CXTPChartDiagram2DSeriesStyle, CXTPChartFunnelSeriesStyle, CXTPChartFunnelSeriesStyleBase, CXTPChartPieSeriesStyle, CXTPChartPieSeriesStyleBase, CXTPChartPyramidSeriesStyle, CXTPChartPyramidSeriesStyleBase, CXTPChartRadarDiagramSeriesStyle, CXTPChartSeriesStyle
  • CreateDiagramDomain() : CXTPChartFunnelSeriesViewBase, CXTPChartPieSeriesViewBase, CXTPChartPyramidSeriesViewBase
  • CreateDIBPatternBrush() : CXTPBrush
  • CreateDisabledIcon() : CXTPImageManagerIcon
  • CreateDrawContext() : CXTPFlowGraphControl
  • CreateEdit() : CXTPCommandBarEditCtrl
  • CreateEditControl() : CXTPControlComboBox, CXTPControlEdit, CXTPEditListBox
  • CreateEditGroup() : CXTPEditListBox
  • CreateEmptyRecord() : CXTPGridDataManager
  • CreateEx() : CXTPGaugeCtrl, CXTPPreviewCtrl, CXTPScrollable< Base >, CXTPStatusBar, CXTPWebBrowserCtrl
  • CreateExtendedButtons() : CXTPColorSelectorCtrlTheme, CXTPColorSelectorCtrlThemeOffice2013
  • CreateFont() : CXTPFont, CXTPHyperLink
  • CreateFontIndirect() : CXTPFont, CXTPSyntaxEditPaintManager
  • CreateFonts() : CXTPFontManager
  • CreateFromMenu() : CXTPControlActions
  • CreateFromOleData() : CXTPTaskPanelItem
  • CreateFromOleFile() : CXTPTaskPanelItem
  • CreateFromResource() : CXTPTaskDialog
  • CreateFromResourceParam() : CXTPTaskDialog
  • CreateGradientCircle() : CXTPCommandBarsOffice2003Theme
  • CreateGridLinesDeviceCommand() : CXTPChartDiagram2DAxisView, CXTPChartRadarAxisXView, CXTPChartRadarAxisYView
  • CreateGridView() : CXTPPropertyGrid
  • CreateGripperBitmaps() : CXTPTaskPanelPaintManager
  • CreateGripperIcon() : CXTPTaskPanelPaintManager
  • CreateGroup() : CXTPCalendarViewDay, CXTPCalendarViewDayT< _TView, _TViewGroup, XTP_CALENDAR_HITTESTINFO, _TPThis >
  • CreateGroupRow() : CXTPGridControl
  • CreateHatchBrush() : CXTPBrush
  • CreateHeaderFooterRow() : CXTPGridControl
  • CreateIcon() : CXTPImageManagerResource
  • CreateIconColumn() : CXTPGridControl
  • CreateIconFromResource() : CXTPImageManagerIconHandle, CXTPResourceManager
  • CreateIndexer() : CXTPTabManager::CRowIndexer
  • CreateInnerBorderDeviceCommand() : CXTPChartBorder
  • CreateInsertText() : CXTPSyntaxEditCtrl
  • CreateInterlacedDeviceCommand() : CXTPChartDiagram2DAxisView, CXTPChartRadarAxisXView, CXTPChartRadarAxisYView
  • CreateItems() : CXTPControlGalleryItems
  • CreateKeyboardTips() : CXTPCommandBar, CXTPCommandBars, CXTPRibbonTabPopupToolBar
  • CreateLabelsDeviceCommand() : CXTPChartDiagram2DAxisView, CXTPChartRadarAxisXView, CXTPChartRadarAxisYView
  • CreateLayout() : CXTPDockingPaneManager
  • CreateLegendDeviceCommand() : CXTPChart3dFunnelSeriesPointView, CXTPChart3dFunnelSeriesView, CXTPChart3dPieSeriesPointView, CXTPChart3dPieSeriesView, CXTPChart3dPyramidSeriesPointView, CXTPChart3dPyramidSeriesView, CXTPChartAreaSeriesView, CXTPChartAxisConstantLine, CXTPChartAxisStrip, CXTPChartBarSeriesPointView, CXTPChartBarSeriesView, CXTPChartCandleStickSeriesView, CXTPChartFastLineSeriesView, CXTPChartFunnelSeriesPointViewBase, CXTPChartFunnelSeriesView, CXTPChartFunnelSeriesViewBase, CXTPChartHighLowSeriesView, CXTPChartLegendItemView, CXTPChartLineSeriesView, CXTPChartPieSeriesPointView, CXTPChartPieSeriesPointViewBase, CXTPChartPieSeriesView, CXTPChartPieSeriesViewBase, CXTPChartPointSeriesPointView, CXTPChartPointSeriesView, CXTPChartPyramidSeriesPointViewBase, CXTPChartPyramidSeriesView, CXTPChartPyramidSeriesViewBase, CXTPChartRadarAreaSeriesView, CXTPChartRadarLineSeriesView, CXTPChartRadarPointSeriesPointView, CXTPChartRadarPointSeriesView, CXTPChartSeriesPointView, CXTPChartStepLineSeriesPointView, CXTPChartStepLineSeriesView
  • CreateListBox() : CXTPControlComboBoxList, CXTPControlFontComboBoxList
  • CreateMarkupContext() : CXTPImageManagerIcon
  • CreateMarkupHandle() : CXTPImageManagerVectorImageHandle
  • CreateMinimizeWnd() : CXTPTrayIcon
  • CreateMiniToolBar() : CXTPMiniToolBar
  • CreateMonthArray() : CXTPDatePickerControl
  • CreateMoreButton() : CXTPColorSelectorCtrlTheme, CXTPColorSelectorCtrlThemeOffice2013
  • CreateNewEvent() : CXTPCalendarData
  • CreateNewHorizontalGroup() : CXTPTabClientWnd
  • CreateNewRecurrencePattern() : CXTPCalendarData
  • CreateNewSticker() : CXTPDockingPaneContext
  • CreateNewVerticalGroup() : CXTPTabClientWnd
  • CreateOriginalControls() : CXTPControls
  • CreatePage() : CXTPPropertySheet
  • CreatePane() : CXTPDockingPaneManager
  • CreatePatternBrush() : CXTPBrush
  • CreatePen() : CXTPPen
  • CreatePenIndirect() : CXTPPen
  • CreatePidl() : CXTPShellPidl
  • CreatePieDeviceCommand() : CXTPChart3dPie, CXTPChartPie, CXTPChartPieBase
  • CreatePointFont() : CXTPFont
  • CreatePointFontIndirect() : CXTPFont
  • CreatePointsView() : CXTPChartBubbleSeriesView, CXTPChartFastLineSeriesView
  • CreatePopupBar() : CXTPPopupBar
  • CreatePopupToolBar() : CXTPPopupToolBar
  • CreatePreview() : IXTPPreviewProvider
  • CreateRecentColorButtons() : CXTPColorSelectorCtrlTheme, CXTPColorSelectorCtrlThemeOffice2013
  • CreateRow() : CXTPGridControl
  • CreateSafeFontIndirect() : CXTPSyntaxEditPropertiesPageFont
  • CreateSchema() : CXTPSkinManager, CXTPSkinManagerResourceFile
  • CreateScrollBarCtrl() : CXTPScrollBarContainer< Parent >
  • CreateSection() : CXTPPropExchangeXMLNode
  • CreateSeriesPointView() : CXTPChart3dFunnelSeriesView, CXTPChart3dPieSeriesView, CXTPChart3dPyramidSeriesView, CXTPChartAreaSeriesView, CXTPChartBarSeriesView, CXTPChartBubbleSeriesView, CXTPChartCandleStickSeriesView, CXTPChartFastLineSeriesView, CXTPChartFunnelSeriesView, CXTPChartFunnelSeriesViewBase, CXTPChartGanttSeriesView, CXTPChartHighLowSeriesView, CXTPChartLineSeriesView, CXTPChartPieSeriesView, CXTPChartPieSeriesViewBase, CXTPChartPointSeriesView, CXTPChartPyramidSeriesView, CXTPChartPyramidSeriesViewBase, CXTPChartRadarAreaSeriesView, CXTPChartRadarLineSeriesView, CXTPChartRadarPointSeriesView, CXTPChartRadarSplineAreaSeriesView, CXTPChartRadarSplineSeriesView, CXTPChartRangeBarSeriesView, CXTPChartSplineAreaSeriesView, CXTPChartSplineSeriesView, CXTPChartStackedAreaSeriesView, CXTPChartStackedBarSeriesView, CXTPChartStepLineSeriesView
  • CreateShadow() : CXTPFramePaintManager, CXTPTipWindow
  • CreateSnapshot() : CXTPToolhelpApi
  • CreateSolidBrush() : CXTPBrush
  • CreateSolidRectArray() : CXTPSkinImage
  • CreateSplineDeviceCommand() : CXTPChartFillStyle, CXTPChartLineStyle
  • CreateStockObject() : CXTPGdiObject
  • CreateStretchedPathData() : CXTPFlowGraphNodeCustom
  • CreateStripsDeviceCommand() : CXTPChartDiagram2DAxisView, CXTPChartRadarAxisXView, CXTPChartRadarAxisYView
  • CreateSvgHandle() : CXTPImageManagerVectorImageHandle
  • CreateSysColorBrush() : CXTPBrush
  • CreateSysFont() : CXTPAuxData
  • CreateTabControlBrush() : CXTPSkinManagerMetrics
  • CreateTabPaintManager() : CXTPRibbonPaintManager
  • CreateTabPopupToolBar() : CXTPRibbonBar
  • CreateTabView() : CXTPTabExBase
  • CreateTheme() : CXTPPaintManager
  • CreateThemeButtons() : CXTPColorSelectorCtrlTheme, CXTPColorSelectorCtrlThemeOffice2013
  • CreateTickMarks() : CXTPChartDiagram2DAxisView, CXTPChartRadarAxisXView, CXTPChartRadarAxisYView
  • CreateTickMarksDeviceCommand() : CXTPChartDiagram2DAxisView, CXTPChartRadarAxisXView, CXTPChartRadarAxisYView
  • CreateTitleDeviceCommand() : CXTPChartDiagram2DAxisView, CXTPChartRadarAxisYView
  • CreateToolBar() : CXTPToolBar
  • CreateToolbar() : CXTPPropertyGrid
  • CreateToolbarMenu() : CXTPControlToolbars
  • CreateToolTip() : CXTPToolTipContext
  • CreateTranspositionDeviceCommand() : CXTPChart3dFunnelSeriesLabelView, CXTPChart3dPieSeriesLabelView, CXTPChart3dPyramidSeriesLabelView
  • CreateUIFont() : CXTPFontCtrlBase
  • CreateView() : CXTPChart3dFunnelDiagram, CXTPChart3dFunnelSeriesLabel, CXTPChart3dFunnelSeriesStyle, CXTPChart3dPieDiagram, CXTPChart3dPieSeriesLabel, CXTPChart3dPieSeriesStyle, CXTPChart3dPyramidDiagram, CXTPChart3dPyramidSeriesLabel, CXTPChart3dPyramidSeriesStyle, CXTPChartAreaSeriesStyle, CXTPChartAxis, CXTPChartAxisX, CXTPChartAxisY, CXTPChartBarSeriesLabel, CXTPChartBarSeriesStyle, CXTPChartBubbleSeriesLabel, CXTPChartBubbleSeriesStyle, CXTPChartCandleStickSeriesStyle, CXTPChartContent, CXTPChartContentView, CXTPChartDiagram2D, CXTPChartDiagram2DAxisView, CXTPChartDiagram2DView, CXTPChartDiagram, CXTPChartDiagramView, CXTPChartFastLineSeriesStyle, CXTPChartFunnelDiagram, CXTPChartFunnelDiagramBase< BaseDiagram >, CXTPChartFunnelSeriesLabel, CXTPChartFunnelSeriesLabelBase, CXTPChartFunnelSeriesStyle, CXTPChartFunnelSeriesStyleBase, CXTPChartGanttSeriesStyle, CXTPChartHighLowSeriesStyle, CXTPChartLegend, CXTPChartLineSeriesStyle, CXTPChartPieDiagram, CXTPChartPieDiagramBase< BaseDiagram >, CXTPChartPieSeriesLabel, CXTPChartPieSeriesLabelBase, CXTPChartPieSeriesStyle, CXTPChartPieSeriesStyleBase, CXTPChartPointSeriesLabel, CXTPChartPointSeriesStyle, CXTPChartPyramidDiagram, CXTPChartPyramidDiagramBase< BaseDiagram >, CXTPChartPyramidSeriesLabel, CXTPChartPyramidSeriesLabelBase, CXTPChartPyramidSeriesStyle, CXTPChartPyramidSeriesStyleBase, CXTPChartRadarAreaSeriesStyle, CXTPChartRadarAxisX, CXTPChartRadarAxisXView, CXTPChartRadarAxisY, CXTPChartRadarAxisYView, CXTPChartRadarDiagram, CXTPChartRadarDiagramView, CXTPChartRadarLineSeriesStyle, CXTPChartRadarPointSeriesStyle, CXTPChartRadarSplineAreaSeriesStyle, CXTPChartRadarSplineSeriesStyle, CXTPChartRangeAreaSeriesLabel, CXTPChartRangeBarSeriesLabel, CXTPChartRangeBarSeriesStyle, CXTPChartRangeSplineAreaSeriesStyle, CXTPChartScatterLineSeriesStyle, CXTPChartSeriesStyle, CXTPChartSplineAreaSeriesStyle, CXTPChartSplineSeriesStyle, CXTPChartStackedAreaSeriesStyle, CXTPChartStackedBarSeriesStyle, CXTPChartStackedSplineAreaSeriesStyle, CXTPChartStepAreaSeriesStyle, CXTPChartStepLineSeriesStyle, CXTPPropertyGrid
  • CreateWnd() : CXTPCalendarMsgNotifier
  • CreateWorkspace() : CXTPTabClientWnd
  • CRepositionContext() : CXTPTaskPanel::CRepositionContext
  • CRgnCell() : CXTPColorHex::CRgnCell
  • CRowIndexer() : CXTPTabManager::CRowIndexer
  • CSelectionChanged_ContextData() : CXTPCalendarView::CSelectionChanged_ContextData
  • CSelectionChangedContext() : CXTPCalendarView::CSelectionChangedContext
  • CSharedLock() : CXTPRWCriticalSection::CSharedLock
  • CShellMalloc() : CXTPShellPidl::CShellMalloc
  • CShellSpecialFolder() : CXTPShellPidl::CShellSpecialFolder
  • CStringPtrArray() : CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager::CStringPtrArray
  • CThemeStaticExtension() : CXTPRibbonOffice2013Theme::CThemeStaticExtension
  • CtlColor() : CXTPEditTheme, CXTPEditThemeDefault
  • CUpdateContext() : CXTPCalendarControl::CUpdateContext, CXTPGridControl::CUpdateContext
  • CursorInWindow() : CXTPMiniToolBar
  • CustomizeStartDrag() : CXTPControl
  • CustomizeStartResize() : CXTPControl
  • Cut() : CXTPCalendarView, CXTPFlowGraphPage, CXTPGridControl, CXTPSyntaxEditCtrl
  • CViewChanged_ContextData() : CXTPCalendarControl::CViewChanged_ContextData
  • CViewChangedContext() : CXTPCalendarControl::CViewChangedContext
  • CXTPActiveScriptEngine() : CXTPActiveScriptEngine
  • CXTPActiveScriptStdRuntime() : CXTPActiveScriptStdRuntime
  • CXTPAlphaWnd() : CXTPAlphaWnd
  • CXTPAnimationDC() : CXTPAnimationDC
  • CXTPArcBall() : CXTPArcBall
  • CXTPArrayT() : CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE >
  • CXTPAsyncGuard() : CXTPAsyncGuard< Adaptee, RWLock >
  • CXTPAutoResetValue() : CXTPAutoResetValue< _TValue >
  • CXTPBrowseButton() : CXTPBrowseButton
  • CXTPBrowseDialog() : CXTPBrowseDialog
  • CXTPBrowseEdit() : CXTPBrowseEdit
  • CXTPBrush() : CXTPBrush
  • CXTPButton() : CXTPButton
  • CXTPButtonTheme() : CXTPButtonTheme
  • CXTPButtonThemeFlat() : CXTPButtonThemeFlat
  • CXTPButtonThemeNativeWindows10() : CXTPButtonThemeNativeWindows10
  • CXTPButtonThemeNativeWindows11() : CXTPButtonThemeNativeWindows11
  • CXTPButtonThemeOffice2000() : CXTPButtonThemeOffice2000
  • CXTPButtonThemeOffice2003() : CXTPButtonThemeOffice2003
  • CXTPButtonThemeOfficeXP() : CXTPButtonThemeOfficeXP
  • CXTPButtonThemeResource() : CXTPButtonThemeResource
  • CXTPButtonThemeUltraFlat() : CXTPButtonThemeUltraFlat
  • CXTPButtonThemeVisualStudio2012() : CXTPButtonThemeVisualStudio2012
  • CXTPButtonThemeVisualStudio2015() : CXTPButtonThemeVisualStudio2015
  • CXTPButtonThemeVisualStudio2017() : CXTPButtonThemeVisualStudio2017
  • CXTPButtonThemeVisualStudio2019() : CXTPButtonThemeVisualStudio2019
  • CXTPButtonThemeVisualStudio2022() : CXTPButtonThemeVisualStudio2022
  • CXTPCalendarCaptionBarControl() : CXTPCalendarCaptionBarControl
  • CXTPCalendarCaptionBarNativeWindows10Theme() : CXTPCalendarCaptionBarNativeWindows10Theme
  • CXTPCalendarCaptionBarNativeWindows11Theme() : CXTPCalendarCaptionBarNativeWindows11Theme
  • CXTPCalendarCaptionBarOffice2000Theme() : CXTPCalendarCaptionBarOffice2000Theme
  • CXTPCalendarCaptionBarOffice2003Theme() : CXTPCalendarCaptionBarOffice2003Theme
  • CXTPCalendarCaptionBarOffice2013Theme() : CXTPCalendarCaptionBarOffice2013Theme
  • CXTPCalendarCaptionBarOfficeXPTheme() : CXTPCalendarCaptionBarOfficeXPTheme
  • CXTPCalendarCaptionBarPaintManager() : CXTPCalendarCaptionBarPaintManager
  • CXTPCalendarCaptionBarResourceTheme() : CXTPCalendarCaptionBarResourceTheme
  • CXTPCalendarCaptionBarTheme() : CXTPCalendarCaptionBarTheme
  • CXTPCalendarCaptionBarThemePart() : CXTPCalendarCaptionBarThemePart
  • CXTPCalendarCaptionBarVisualStudio2015Theme() : CXTPCalendarCaptionBarVisualStudio2015Theme
  • CXTPCalendarCaptionBarVisualStudio2017Theme() : CXTPCalendarCaptionBarVisualStudio2017Theme
  • CXTPCalendarCaptionBarVisualStudio2019Theme() : CXTPCalendarCaptionBarVisualStudio2019Theme
  • CXTPCalendarCaptionBarVisualStudio2022Theme() : CXTPCalendarCaptionBarVisualStudio2022Theme
  • CXTPCalendarComboBoxBase() : CXTPCalendarComboBoxBase
  • CXTPCalendarControl() : CXTPCalendarControl
  • CXTPCalendarController() : CXTPCalendarController
  • CXTPCalendarControlView() : CXTPCalendarControlView
  • CXTPCalendarControlViewPrintOptions() : CXTPCalendarControlViewPrintOptions
  • CXTPCalendarCustomDataProvider() : CXTPCalendarCustomDataProvider
  • CXTPCalendarCustomProperties() : CXTPCalendarCustomProperties
  • CXTPCalendarData() : CXTPCalendarData
  • CXTPCalendarDatabaseDataProvider() : CXTPCalendarDatabaseDataProvider
  • CXTPCalendarDayView() : CXTPCalendarDayView
  • CXTPCalendarDayViewDay() : CXTPCalendarDayViewDay
  • CXTPCalendarDayViewEvent() : CXTPCalendarDayViewEvent
  • CXTPCalendarDayViewGroup() : CXTPCalendarDayViewGroup
  • CXTPCalendarDayViewTimeScale() : CXTPCalendarDayViewTimeScale
  • CXTPCalendarEvent() : CXTPCalendarEvent
  • CXTPCalendarEventCategories() : CXTPCalendarEventCategories
  • CXTPCalendarEventCategory() : CXTPCalendarEventCategory
  • CXTPCalendarEventCategoryComboBox() : CXTPCalendarEventCategoryComboBox
  • CXTPCalendarEventCategoryIDs() : CXTPCalendarEventCategoryIDs
  • CXTPCalendarEventColorDlg() : CXTPCalendarEventColorDlg
  • CXTPCalendarEventColorEdit() : CXTPCalendarEventColorEdit
  • CXTPCalendarEventColorListBox() : CXTPCalendarEventColorListBox
  • CXTPCalendarEventColorNewDlg() : CXTPCalendarEventColorNewDlg
  • CXTPCalendarEventLabel() : CXTPCalendarEventLabel
  • CXTPCalendarEventLabels() : CXTPCalendarEventLabels
  • CXTPCalendarEventPropertiesDlg() : CXTPCalendarEventPropertiesDlg
  • CXTPCalendarEventRecurrenceDlg() : CXTPCalendarEventRecurrenceDlg
  • CXTPCalendarEvents() : CXTPCalendarEvents
  • CXTPCalendarIconIDs() : CXTPCalendarIconIDs
  • CXTPCalendarMemoryDataProvider() : CXTPCalendarMemoryDataProvider
  • CXTPCalendarMonthView() : CXTPCalendarMonthView
  • CXTPCalendarMonthViewDay() : CXTPCalendarMonthViewDay
  • CXTPCalendarMonthViewEvent() : CXTPCalendarMonthViewEvent
  • CXTPCalendarMonthViewGroup() : CXTPCalendarMonthViewGroup
  • CXTPCalendarMsgNotifier() : CXTPCalendarMsgNotifier
  • CXTPCalendarNativeWindows10Theme() : CXTPCalendarNativeWindows10Theme
  • CXTPCalendarNativeWindows11Theme() : CXTPCalendarNativeWindows11Theme
  • CXTPCalendarOccurSeriesChooseDlg() : CXTPCalendarOccurSeriesChooseDlg
  • CXTPCalendarOffice2000Theme() : CXTPCalendarOffice2000Theme
  • CXTPCalendarOffice2003Theme() : CXTPCalendarOffice2003Theme
  • CXTPCalendarOffice2013Theme() : CXTPCalendarOffice2013Theme
  • CXTPCalendarOfficeXPTheme() : CXTPCalendarOfficeXPTheme
  • CXTPCalendarOptions() : CXTPCalendarOptions
  • CXTPCalendarPageSetupDialog() : CXTPCalendarPageSetupDialog
  • CXTPCalendarPaintManager() : CXTPCalendarPaintManager
  • CXTPCalendarPtrCollectionT() : CXTPCalendarPtrCollectionT< _TObject >
  • CXTPCalendarRecurrencePattern() : CXTPCalendarRecurrencePattern
  • CXTPCalendarReminder() : CXTPCalendarReminder
  • CXTPCalendarReminderForOccurrenceArray() : CXTPCalendarReminderForOccurrenceArray
  • CXTPCalendarRemindersDialog() : CXTPCalendarRemindersDialog
  • CXTPCalendarRemindersManager() : CXTPCalendarRemindersManager
  • CXTPCalendarResource() : CXTPCalendarResource
  • CXTPCalendarResourceDescription() : CXTPCalendarResourceDescription
  • CXTPCalendarResources() : CXTPCalendarResources
  • CXTPCalendarResourcesManager() : CXTPCalendarResourcesManager
  • CXTPCalendarResourcesNf() : CXTPCalendarResourcesNf
  • CXTPCalendarResourceTheme() : CXTPCalendarResourceTheme
  • CXTPCalendarSchedule() : CXTPCalendarSchedule
  • CXTPCalendarSchedules() : CXTPCalendarSchedules
  • CXTPCalendarShadowDrawer() : CXTPCalendarShadowDrawer
  • CXTPCalendarThemeBOOLValue() : CXTPCalendarThemeBOOLValue
  • CXTPCalendarThemeCustomizableXValueT() : CXTPCalendarThemeCustomizableXValueT< _TValue, _TValueRef >
  • CXTPCalendarThemeFontValue() : CXTPCalendarThemeFontValue
  • CXTPCalendarThemeIntValue() : CXTPCalendarThemeIntValue
  • CXTPCalendarThemeRectValue() : CXTPCalendarThemeRectValue
  • CXTPCalendarThemeStringValue() : CXTPCalendarThemeStringValue
  • CXTPCalendarTimeLineView() : CXTPCalendarTimeLineView
  • CXTPCalendarTimeLineViewEvent() : CXTPCalendarTimeLineViewEvent
  • CXTPCalendarTimeLineViewGroup() : CXTPCalendarTimeLineViewGroup
  • CXTPCalendarTimeLineViewPart() : CXTPCalendarTimeLineViewPart
  • CXTPCalendarTimeLineViewTimeScale() : CXTPCalendarTimeLineViewTimeScale
  • CXTPCalendarTimeLineViewTimeScalePart() : CXTPCalendarTimeLineViewTimeScalePart
  • CXTPCalendarTimeZone() : CXTPCalendarTimeZone
  • CXTPCalendarTimeZones() : CXTPCalendarTimeZones
  • CXTPCalendarTip() : CXTPCalendarTip
  • CXTPCalendarTLV_TimeScaleParams() : CXTPCalendarTLV_TimeScaleParams
  • CXTPCalendarTLV_TimeScaleParams_Day() : CXTPCalendarTLV_TimeScaleParams_Day
  • CXTPCalendarTLV_TimeScaleParams_Month() : CXTPCalendarTLV_TimeScaleParams_Month
  • CXTPCalendarTLV_TimeScaleParams_Week() : CXTPCalendarTLV_TimeScaleParams_Week
  • CXTPCalendarTLV_TimeScaleParams_WorkWeek() : CXTPCalendarTLV_TimeScaleParams_WorkWeek
  • CXTPCalendarTypedPtrAutoDeleteArray() : CXTPCalendarTypedPtrAutoDeleteArray< BASE_CLASS, PTR_TYPE >
  • CXTPCalendarView() : CXTPCalendarView
  • CXTPCalendarViewDay() : CXTPCalendarViewDay
  • CXTPCalendarViewDayT() : CXTPCalendarViewDayT< _TView, _TViewGroup, XTP_CALENDAR_HITTESTINFO, _TPThis >
  • CXTPCalendarViewEvent() : CXTPCalendarViewEvent
  • CXTPCalendarViewEvents() : CXTPCalendarViewEvents
  • CXTPCalendarViewEventSubjectEditor() : CXTPCalendarViewEventSubjectEditor
  • CXTPCalendarViewEventSubjectEditorColored() : CXTPCalendarViewEventSubjectEditorColored
  • CXTPCalendarViewEventT() : CXTPCalendarViewEventT< _TViewGroup >
  • CXTPCalendarViewGroup() : CXTPCalendarViewGroup
  • CXTPCalendarViewGroupT() : CXTPCalendarViewGroupT< _TViewDay, _TViewEvent, _TPThis >
  • CXTPCalendarViewPart() : CXTPCalendarViewPart
  • CXTPCalendarViewPartCustomizableValueT() : CXTPCalendarViewPartCustomizableValueT< _TValue >
  • CXTPCalendarViewPartFontValue() : CXTPCalendarViewPartFontValue
  • CXTPCalendarViewT() : CXTPCalendarViewT< _TViewDay >
  • CXTPCalendarVisualStudio2015Theme() : CXTPCalendarVisualStudio2015Theme
  • CXTPCalendarVisualStudio2017Theme() : CXTPCalendarVisualStudio2017Theme
  • CXTPCalendarVisualStudio2019Theme() : CXTPCalendarVisualStudio2019Theme
  • CXTPCalendarVisualStudio2022Theme() : CXTPCalendarVisualStudio2022Theme
  • CXTPCalendarWeekView() : CXTPCalendarWeekView
  • CXTPCalendarWeekViewDay() : CXTPCalendarWeekViewDay
  • CXTPCalendarWeekViewEvent() : CXTPCalendarWeekViewEvent
  • CXTPCalendarWeekViewGroup() : CXTPCalendarWeekViewGroup
  • CXTPCalendarWMHandler() : CXTPCalendarWMHandler
  • CXTPCaption() : CXTPCaption
  • CXTPCaptionButton() : CXTPCaptionButton
  • CXTPCaptionButtonTheme() : CXTPCaptionButtonTheme
  • CXTPCaptionButtonThemeOfficeXP() : CXTPCaptionButtonThemeOfficeXP
  • CXTPCaptionPopupWnd() : CXTPCaptionPopupWnd
  • CXTPCaptionTheme() : CXTPCaptionTheme
  • CXTPCaptionThemeOffice2003() : CXTPCaptionThemeOffice2003
  • CXTPCaptionThemeOfficeXP() : CXTPCaptionThemeOfficeXP
  • CXTPChart2dDiagram() : CXTPChart2dDiagram
  • CXTPChart3dBox() : CXTPChart3dBox
  • CXTPChart3dDeviceCommand() : CXTPChart3dDeviceCommand
  • CXTPChart3dDeviceContext() : CXTPChart3dDeviceContext
  • CXTPChart3dDiagram() : CXTPChart3dDiagram
  • CXTPChart3dDiagramView() : CXTPChart3dDiagramView
  • CXTPChart3dFunnelDeviceCommandEvents() : CXTPChart3dFunnelDeviceCommandEvents
  • CXTPChart3dFunnelDiagram() : CXTPChart3dFunnelDiagram
  • CXTPChart3dFunnelDiagramView() : CXTPChart3dFunnelDiagramView
  • CXTPChart3dFunnelSeriesLabel() : CXTPChart3dFunnelSeriesLabel
  • CXTPChart3dFunnelSeriesLabelDeviceCommand() : CXTPChart3dFunnelSeriesLabelDeviceCommand
  • CXTPChart3dFunnelSeriesLabelsView() : CXTPChart3dFunnelSeriesLabelsView
  • CXTPChart3dFunnelSeriesLabelsViewDeviceCommand() : CXTPChart3dFunnelSeriesLabelsViewDeviceCommand
  • CXTPChart3dFunnelSeriesLabelView() : CXTPChart3dFunnelSeriesLabelView
  • CXTPChart3dFunnelSeriesPointView() : CXTPChart3dFunnelSeriesPointView
  • CXTPChart3dFunnelSeriesStyle() : CXTPChart3dFunnelSeriesStyle
  • CXTPChart3dFunnelSeriesView() : CXTPChart3dFunnelSeriesView
  • CXTPChart3dLineDeviceCommand() : CXTPChart3dLineDeviceCommand
  • CXTPChart3dPie() : CXTPChart3dPie
  • CXTPChart3dPieDeviceCommand() : CXTPChart3dPieDeviceCommand
  • CXTPChart3dPieDeviceCommandEvents() : CXTPChart3dPieDeviceCommandEvents
  • CXTPChart3dPieDiagram() : CXTPChart3dPieDiagram
  • CXTPChart3dPieDiagramView() : CXTPChart3dPieDiagramView
  • CXTPChart3dPieSeriesLabel() : CXTPChart3dPieSeriesLabel
  • CXTPChart3dPieSeriesLabelDeviceCommand() : CXTPChart3dPieSeriesLabelDeviceCommand
  • CXTPChart3dPieSeriesLabelsView() : CXTPChart3dPieSeriesLabelsView
  • CXTPChart3dPieSeriesLabelsViewDeviceCommand() : CXTPChart3dPieSeriesLabelsViewDeviceCommand
  • CXTPChart3dPieSeriesLabelView() : CXTPChart3dPieSeriesLabelView
  • CXTPChart3dPieSeriesPointView() : CXTPChart3dPieSeriesPointView
  • CXTPChart3dPieSeriesStyle() : CXTPChart3dPieSeriesStyle
  • CXTPChart3dPieSeriesView() : CXTPChart3dPieSeriesView
  • CXTPChart3dPyramidDeviceCommandEvents() : CXTPChart3dPyramidDeviceCommandEvents
  • CXTPChart3dPyramidDiagram() : CXTPChart3dPyramidDiagram
  • CXTPChart3dPyramidDiagramView() : CXTPChart3dPyramidDiagramView
  • CXTPChart3dPyramidSeriesLabel() : CXTPChart3dPyramidSeriesLabel
  • CXTPChart3dPyramidSeriesLabelDeviceCommand() : CXTPChart3dPyramidSeriesLabelDeviceCommand
  • CXTPChart3dPyramidSeriesLabelsView() : CXTPChart3dPyramidSeriesLabelsView
  • CXTPChart3dPyramidSeriesLabelsViewDeviceCommand() : CXTPChart3dPyramidSeriesLabelsViewDeviceCommand
  • CXTPChart3dPyramidSeriesLabelView() : CXTPChart3dPyramidSeriesLabelView
  • CXTPChart3dPyramidSeriesPointView() : CXTPChart3dPyramidSeriesPointView
  • CXTPChart3dPyramidSeriesStyle() : CXTPChart3dPyramidSeriesStyle
  • CXTPChart3dPyramidSeriesView() : CXTPChart3dPyramidSeriesView
  • CXTPChart3dRotateDeviceCommand() : CXTPChart3dRotateDeviceCommand
  • CXTPChart3dRotation() : CXTPChart3dRotation
  • CXTPChart3dTranslateDeviceCommand() : CXTPChart3dTranslateDeviceCommand
  • CXTPChartAppearance() : CXTPChartAppearance
  • CXTPChartAreaSeriesStyle() : CXTPChartAreaSeriesStyle
  • CXTPChartAreaSeriesView() : CXTPChartAreaSeriesView
  • CXTPChartAxis() : CXTPChartAxis
  • CXTPChartAxisAppearance() : CXTPChartAxisAppearance
  • CXTPChartAxisConstantLine() : CXTPChartAxisConstantLine
  • CXTPChartAxisConstantLines() : CXTPChartAxisConstantLines
  • CXTPChartAxisCustomLabel() : CXTPChartAxisCustomLabel
  • CXTPChartAxisCustomLabels() : CXTPChartAxisCustomLabels
  • CXTPChartAxisGridLines() : CXTPChartAxisGridLines
  • CXTPChartAxisLabel() : CXTPChartAxisLabel
  • CXTPChartAxisRange() : CXTPChartAxisRange
  • CXTPChartAxisStrip() : CXTPChartAxisStrip
  • CXTPChartAxisStrips() : CXTPChartAxisStrips
  • CXTPChartAxisTickMarks() : CXTPChartAxisTickMarks
  • CXTPChartAxisTitle() : CXTPChartAxisTitle
  • CXTPChartAxisX() : CXTPChartAxisX
  • CXTPChartAxisY() : CXTPChartAxisY
  • CXTPChartBarSeriesErrorBarView() : CXTPChartBarSeriesErrorBarView
  • CXTPChartBarSeriesLabel() : CXTPChartBarSeriesLabel
  • CXTPChartBarSeriesLabelView() : CXTPChartBarSeriesLabelView
  • CXTPChartBarSeriesPointView() : CXTPChartBarSeriesPointView
  • CXTPChartBarSeriesStyle() : CXTPChartBarSeriesStyle
  • CXTPChartBarSeriesView() : CXTPChartBarSeriesView
  • CXTPChartBorder() : CXTPChartBorder
  • CXTPChartBoundedCircleDeviceCommand() : CXTPChartBoundedCircleDeviceCommand
  • CXTPChartBoundedPolygonDeviceCommand() : CXTPChartBoundedPolygonDeviceCommand
  • CXTPChartBoundedTextDeviceCommand() : CXTPChartBoundedTextDeviceCommand
  • CXTPChartBubbleSeriesLabel() : CXTPChartBubbleSeriesLabel
  • CXTPChartBubbleSeriesLabelView() : CXTPChartBubbleSeriesLabelView
  • CXTPChartBubbleSeriesPointView() : CXTPChartBubbleSeriesPointView
  • CXTPChartBubbleSeriesStyle() : CXTPChartBubbleSeriesStyle
  • CXTPChartBubbleSeriesView() : CXTPChartBubbleSeriesView
  • CXTPChartCandleStickSeriesPointView() : CXTPChartCandleStickSeriesPointView
  • CXTPChartCandleStickSeriesStyle() : CXTPChartCandleStickSeriesStyle
  • CXTPChartCandleStickSeriesView() : CXTPChartCandleStickSeriesView
  • CXTPChartCircleDeviceCommand() : CXTPChartCircleDeviceCommand
  • CXTPChartClipDeviceCommand() : CXTPChartClipDeviceCommand
  • CXTPChartColor() : CXTPChartColor
  • CXTPChartContainer() : CXTPChartContainer
  • CXTPChartContent() : CXTPChartContent
  • CXTPChartContentAppearance() : CXTPChartContentAppearance
  • CXTPChartContentView() : CXTPChartContentView
  • CXTPChartControl() : CXTPChartControl
  • CXTPChartDeviceCommand() : CXTPChartDeviceCommand
  • CXTPChartDeviceCommandEvents() : CXTPChartDeviceCommandEvents
  • CXTPChartDeviceContext() : CXTPChartDeviceContext
  • CXTPChartDiagram() : CXTPChartDiagram
  • CXTPChartDiagram2D() : CXTPChartDiagram2D
  • CXTPChartDiagram2DAppearance() : CXTPChartDiagram2DAppearance
  • CXTPChartDiagram2DAxisView() : CXTPChartDiagram2DAxisView
  • CXTPChartDiagram2DSeriesLabel() : CXTPChartDiagram2DSeriesLabel
  • CXTPChartDiagram2DSeriesLabelView() : CXTPChartDiagram2DSeriesLabelView
  • CXTPChartDiagram2DSeriesStyle() : CXTPChartDiagram2DSeriesStyle
  • CXTPChartDiagram2DView() : CXTPChartDiagram2DView
  • CXTPChartDiagram3DAppearance() : CXTPChartDiagram3DAppearance
  • CXTPChartDiagramDomain() : CXTPChartDiagramDomain
  • CXTPChartDiagramView() : CXTPChartDiagramView
  • CXTPChartElement() : CXTPChartElement
  • CXTPChartElementAppearance() : CXTPChartElementAppearance
  • CXTPChartElementCollection() : CXTPChartElementCollection
  • CXTPChartElementView() : CXTPChartElementView
  • CXTPChartEllipse() : CXTPChartEllipse
  • CXTPChartFastLineSeriesStyle() : CXTPChartFastLineSeriesStyle
  • CXTPChartFastLineSeriesView() : CXTPChartFastLineSeriesView
  • CXTPChartFillStyle() : CXTPChartFillStyle
  • CXTPChartFinanceStyleAppearance() : CXTPChartFinanceStyleAppearance
  • CXTPChartFont() : CXTPChartFont
  • CXTPChartFunnelDiagram() : CXTPChartFunnelDiagram
  • CXTPChartFunnelDiagramBase() : CXTPChartFunnelDiagramBase< BaseDiagram >
  • CXTPChartFunnelDiagramView() : CXTPChartFunnelDiagramView
  • CXTPChartFunnelSeriesLabel() : CXTPChartFunnelSeriesLabel
  • CXTPChartFunnelSeriesLabelBase() : CXTPChartFunnelSeriesLabelBase
  • CXTPChartFunnelSeriesLabelView() : CXTPChartFunnelSeriesLabelView
  • CXTPChartFunnelSeriesLabelViewBase() : CXTPChartFunnelSeriesLabelViewBase
  • CXTPChartFunnelSeriesPointView() : CXTPChartFunnelSeriesPointView
  • CXTPChartFunnelSeriesPointViewBase() : CXTPChartFunnelSeriesPointViewBase
  • CXTPChartFunnelSeriesStyle() : CXTPChartFunnelSeriesStyle
  • CXTPChartFunnelSeriesStyleBase() : CXTPChartFunnelSeriesStyleBase
  • CXTPChartFunnelSeriesView() : CXTPChartFunnelSeriesView
  • CXTPChartFunnelSeriesViewBase() : CXTPChartFunnelSeriesViewBase
  • CXTPChartGanttSeriesPointView() : CXTPChartGanttSeriesPointView
  • CXTPChartGanttSeriesStyle() : CXTPChartGanttSeriesStyle
  • CXTPChartGanttSeriesView() : CXTPChartGanttSeriesView
  • CXTPChartHighLowSeriesPointView() : CXTPChartHighLowSeriesPointView
  • CXTPChartHighLowSeriesStyle() : CXTPChartHighLowSeriesStyle
  • CXTPChartHighLowSeriesView() : CXTPChartHighLowSeriesView
  • CXTPChartHitTestElementCommand() : CXTPChartHitTestElementCommand
  • CXTPChartLegend() : CXTPChartLegend
  • CXTPChartLegendAppearance() : CXTPChartLegendAppearance
  • CXTPChartLegendView() : CXTPChartLegendView
  • CXTPChartLineDeviceCommand() : CXTPChartLineDeviceCommand
  • CXTPChartLineSeriesErrorBarView() : CXTPChartLineSeriesErrorBarView
  • CXTPChartLineSeriesStyle() : CXTPChartLineSeriesStyle
  • CXTPChartLineSeriesView() : CXTPChartLineSeriesView
  • CXTPChartLineStyle() : CXTPChartLineStyle
  • CXTPChartMarker() : CXTPChartMarker
  • CXTPChartMarkupElementDeviceCommand() : CXTPChartMarkupElementDeviceCommand
  • CXTPChartNumberFormat() : CXTPChartNumberFormat
  • CXTPChartNumericalScaleTypeMap() : CXTPChartNumericalScaleTypeMap
  • CXTPChartObject() : CXTPChartObject
  • CXTPChartPalette() : CXTPChartPalette
  • CXTPChartPanel() : CXTPChartPanel
  • CXTPChartPanelCollection() : CXTPChartPanelCollection
  • CXTPChartPie() : CXTPChartPie
  • CXTPChartPieBase() : CXTPChartPieBase
  • CXTPChartPieDeviceCommand() : CXTPChartPieDeviceCommand
  • CXTPChartPieDiagram() : CXTPChartPieDiagram
  • CXTPChartPieDiagramBase() : CXTPChartPieDiagramBase< BaseDiagram >
  • CXTPChartPieDiagramView() : CXTPChartPieDiagramView
  • CXTPChartPieSeriesLabel() : CXTPChartPieSeriesLabel
  • CXTPChartPieSeriesLabelBase() : CXTPChartPieSeriesLabelBase
  • CXTPChartPieSeriesLabelsView() : CXTPChartPieSeriesLabelsView
  • CXTPChartPieSeriesLabelsViewBase() : CXTPChartPieSeriesLabelsViewBase
  • CXTPChartPieSeriesLabelView() : CXTPChartPieSeriesLabelView
  • CXTPChartPieSeriesLabelViewBase() : CXTPChartPieSeriesLabelViewBase
  • CXTPChartPieSeriesPointView() : CXTPChartPieSeriesPointView
  • CXTPChartPieSeriesPointViewBase() : CXTPChartPieSeriesPointViewBase
  • CXTPChartPieSeriesStyle() : CXTPChartPieSeriesStyle
  • CXTPChartPieSeriesStyleBase() : CXTPChartPieSeriesStyleBase
  • CXTPChartPieSeriesView() : CXTPChartPieSeriesView
  • CXTPChartPieSeriesViewBase() : CXTPChartPieSeriesViewBase
  • CXTPChartPieStyleAppearance() : CXTPChartPieStyleAppearance
  • CXTPChartPointSeriesErrorBarView() : CXTPChartPointSeriesErrorBarView
  • CXTPChartPointSeriesLabel() : CXTPChartPointSeriesLabel
  • CXTPChartPointSeriesLabelView() : CXTPChartPointSeriesLabelView
  • CXTPChartPointSeriesPointView() : CXTPChartPointSeriesPointView
  • CXTPChartPointSeriesStyle() : CXTPChartPointSeriesStyle
  • CXTPChartPointSeriesView() : CXTPChartPointSeriesView
  • CXTPChartPolygonAntialiasingDeviceCommand() : CXTPChartPolygonAntialiasingDeviceCommand
  • CXTPChartPolygonDeviceCommand() : CXTPChartPolygonDeviceCommand
  • CXTPChartPolylineDeviceCommand() : CXTPChartPolylineDeviceCommand
  • CXTPChartPyramidDiagram() : CXTPChartPyramidDiagram
  • CXTPChartPyramidDiagramBase() : CXTPChartPyramidDiagramBase< BaseDiagram >
  • CXTPChartPyramidDiagramView() : CXTPChartPyramidDiagramView
  • CXTPChartPyramidSeriesLabelBase() : CXTPChartPyramidSeriesLabelBase
  • CXTPChartPyramidSeriesLabelView() : CXTPChartPyramidSeriesLabelView
  • CXTPChartPyramidSeriesLabelViewBase() : CXTPChartPyramidSeriesLabelViewBase
  • CXTPChartPyramidSeriesPointView() : CXTPChartPyramidSeriesPointView
  • CXTPChartPyramidSeriesPointViewBase() : CXTPChartPyramidSeriesPointViewBase
  • CXTPChartPyramidSeriesStyle() : CXTPChartPyramidSeriesStyle
  • CXTPChartPyramidSeriesStyleBase() : CXTPChartPyramidSeriesStyleBase
  • CXTPChartPyramidSeriesView() : CXTPChartPyramidSeriesView
  • CXTPChartPyramidSeriesViewBase() : CXTPChartPyramidSeriesViewBase
  • CXTPChartQualitativeScaleTypeMap() : CXTPChartQualitativeScaleTypeMap
  • CXTPChartRadarAreaSeriesStyle() : CXTPChartRadarAreaSeriesStyle
  • CXTPChartRadarAreaSeriesView() : CXTPChartRadarAreaSeriesView
  • CXTPChartRadarAxisView() : CXTPChartRadarAxisView
  • CXTPChartRadarAxisX() : CXTPChartRadarAxisX
  • CXTPChartRadarAxisXView() : CXTPChartRadarAxisXView
  • CXTPChartRadarAxisY() : CXTPChartRadarAxisY
  • CXTPChartRadarAxisYView() : CXTPChartRadarAxisYView
  • CXTPChartRadarDiagram() : CXTPChartRadarDiagram
  • CXTPChartRadarDiagramSeriesStyle() : CXTPChartRadarDiagramSeriesStyle
  • CXTPChartRadarDiagramView() : CXTPChartRadarDiagramView
  • CXTPChartRadarLineSeriesStyle() : CXTPChartRadarLineSeriesStyle
  • CXTPChartRadarLineSeriesView() : CXTPChartRadarLineSeriesView
  • CXTPChartRadarPointSeriesLabel() : CXTPChartRadarPointSeriesLabel
  • CXTPChartRadarPointSeriesLabelView() : CXTPChartRadarPointSeriesLabelView
  • CXTPChartRadarPointSeriesPointView() : CXTPChartRadarPointSeriesPointView
  • CXTPChartRadarPointSeriesStyle() : CXTPChartRadarPointSeriesStyle
  • CXTPChartRadarPointSeriesView() : CXTPChartRadarPointSeriesView
  • CXTPChartRadarSplineAreaSeriesStyle() : CXTPChartRadarSplineAreaSeriesStyle
  • CXTPChartRadarSplineAreaSeriesView() : CXTPChartRadarSplineAreaSeriesView
  • CXTPChartRadarSplineSeriesStyle() : CXTPChartRadarSplineSeriesStyle
  • CXTPChartRadarSplineSeriesView() : CXTPChartRadarSplineSeriesView
  • CXTPChartRangeAreaSeriesLabel() : CXTPChartRangeAreaSeriesLabel
  • CXTPChartRangeAreaSeriesLabelView() : CXTPChartRangeAreaSeriesLabelView
  • CXTPChartRangeBarSeriesLabel() : CXTPChartRangeBarSeriesLabel
  • CXTPChartRangeBarSeriesLabelView() : CXTPChartRangeBarSeriesLabelView
  • CXTPChartRangeBarSeriesPointView() : CXTPChartRangeBarSeriesPointView
  • CXTPChartRangeBarSeriesStyle() : CXTPChartRangeBarSeriesStyle
  • CXTPChartRangeBarSeriesView() : CXTPChartRangeBarSeriesView
  • CXTPChartRangeSplineAreaSeriesPointView() : CXTPChartRangeSplineAreaSeriesPointView
  • CXTPChartRangeSplineAreaSeriesStyle() : CXTPChartRangeSplineAreaSeriesStyle
  • CXTPChartRangeSplineAreaSeriesView() : CXTPChartRangeSplineAreaSeriesView
  • CXTPChartRectangleDeviceCommand() : CXTPChartRectangleDeviceCommand
  • CXTPChartRotateDeviceCommand() : CXTPChartRotateDeviceCommand
  • CXTPChartRotatedTextPainterBase() : CXTPChartRotatedTextPainterBase
  • CXTPChartRotatedTextPainterNearLine() : CXTPChartRotatedTextPainterNearLine
  • CXTPChartScaleTypeMap() : CXTPChartScaleTypeMap
  • CXTPChartScatterLineSeriesStyle() : CXTPChartScatterLineSeriesStyle
  • CXTPChartSeries() : CXTPChartSeries
  • CXTPChartSeriesCollection() : CXTPChartSeriesCollection
  • CXTPChartSeriesLabel() : CXTPChartSeriesLabel
  • CXTPChartSeriesPoint() : CXTPChartSeriesPoint
  • CXTPChartSeriesPointCollection() : CXTPChartSeriesPointCollection
  • CXTPChartSeriesPointView() : CXTPChartSeriesPointView
  • CXTPChartSeriesStyle() : CXTPChartSeriesStyle
  • CXTPChartSolidSplinePolygonDeviceCommand() : CXTPChartSolidSplinePolygonDeviceCommand
  • CXTPChartSplineAreaSeriesStyle() : CXTPChartSplineAreaSeriesStyle
  • CXTPChartSplineAreaSeriesView() : CXTPChartSplineAreaSeriesView
  • CXTPChartSplineDeviceCommand() : CXTPChartSplineDeviceCommand
  • CXTPChartSplineSeriesStyle() : CXTPChartSplineSeriesStyle
  • CXTPChartSplineSeriesView() : CXTPChartSplineSeriesView
  • CXTPChartStackedAreaSeriesStyle() : CXTPChartStackedAreaSeriesStyle
  • CXTPChartStackedAreaSeriesView() : CXTPChartStackedAreaSeriesView
  • CXTPChartStackedBarSeriesPointView() : CXTPChartStackedBarSeriesPointView
  • CXTPChartStackedBarSeriesStyle() : CXTPChartStackedBarSeriesStyle
  • CXTPChartStackedBarSeriesView() : CXTPChartStackedBarSeriesView
  • CXTPChartStackedSplineAreaSeriesStyle() : CXTPChartStackedSplineAreaSeriesStyle
  • CXTPChartStackedSplineAreaSeriesView() : CXTPChartStackedSplineAreaSeriesView
  • CXTPChartStepAreaSeriesStyle() : CXTPChartStepAreaSeriesStyle
  • CXTPChartStepAreaSeriesView() : CXTPChartStepAreaSeriesView
  • CXTPChartStepLineSeriesPointView() : CXTPChartStepLineSeriesPointView
  • CXTPChartStepLineSeriesStyle() : CXTPChartStepLineSeriesStyle
  • CXTPChartStepLineSeriesView() : CXTPChartStepLineSeriesView
  • CXTPChartTextAntialiasingDeviceCommand() : CXTPChartTextAntialiasingDeviceCommand
  • CXTPChartTextDeviceCommand() : CXTPChartTextDeviceCommand
  • CXTPChartTextPainter() : CXTPChartTextPainter
  • CXTPChartTextPainterBase() : CXTPChartTextPainterBase
  • CXTPChartTitle() : CXTPChartTitle
  • CXTPChartTitleAppearance() : CXTPChartTitleAppearance
  • CXTPChartTitleCollection() : CXTPChartTitleCollection
  • CXTPChartTranslateDeviceCommand() : CXTPChartTranslateDeviceCommand
  • CXTPCheckListBox() : CXTPCheckListBox
  • CXTPClientCursorPos() : CXTPClientCursorPos
  • CXTPClientRect() : CXTPClientRect
  • CXTPCmdTarget() : CXTPCmdTarget
  • CXTPColorBase() : CXTPColorBase
  • CXTPColorDialog() : CXTPColorDialog
  • CXTPColorHex() : CXTPColorHex
  • CXTPColorLum() : CXTPColorLum
  • CXTPColorPageCustom() : CXTPColorPageCustom
  • CXTPColorPageStandard() : CXTPColorPageStandard
  • CXTPColorPicker() : CXTPColorPicker
  • CXTPColorPopup() : CXTPColorPopup
  • CXTPColorSelectorCtrl() : CXTPColorSelectorCtrl
  • CXTPColorSelectorCtrlTheme() : CXTPColorSelectorCtrlTheme
  • CXTPColorSelectorCtrlThemeNativeWindows10() : CXTPColorSelectorCtrlThemeNativeWindows10
  • CXTPColorSelectorCtrlThemeNativeWindows11() : CXTPColorSelectorCtrlThemeNativeWindows11
  • CXTPColorSelectorCtrlThemeOffice2003() : CXTPColorSelectorCtrlThemeOffice2003
  • CXTPColorSelectorCtrlThemeOffice2013() : CXTPColorSelectorCtrlThemeOffice2013
  • CXTPColorSelectorCtrlThemeOfficeXP() : CXTPColorSelectorCtrlThemeOfficeXP
  • CXTPColorSelectorCtrlThemeResource() : CXTPColorSelectorCtrlThemeResource
  • CXTPColorSelectorCtrlThemeVisualStudio2015() : CXTPColorSelectorCtrlThemeVisualStudio2015
  • CXTPColorSelectorCtrlThemeVisualStudio2017() : CXTPColorSelectorCtrlThemeVisualStudio2017
  • CXTPColorSelectorCtrlThemeVisualStudio2019() : CXTPColorSelectorCtrlThemeVisualStudio2019
  • CXTPColorSelectorCtrlThemeVisualStudio2022() : CXTPColorSelectorCtrlThemeVisualStudio2022
  • CXTPColorWnd() : CXTPColorWnd
  • CXTPComboBox() : CXTPComboBox
  • CXTPComboBoxTheme() : CXTPComboBoxTheme
  • CXTPComboBoxThemeDefault() : CXTPComboBoxThemeDefault
  • CXTPComboBoxThemeNativeWindows10() : CXTPComboBoxThemeNativeWindows10
  • CXTPComboBoxThemeNativeWindows11() : CXTPComboBoxThemeNativeWindows11
  • CXTPComboBoxThemeOffice2000() : CXTPComboBoxThemeOffice2000
  • CXTPComboBoxThemeOffice2003() : CXTPComboBoxThemeOffice2003
  • CXTPComboBoxThemeOffice2013() : CXTPComboBoxThemeOffice2013
  • CXTPComboBoxThemeOfficeXPFlat() : CXTPComboBoxThemeOfficeXPFlat
  • CXTPComboBoxThemeResource() : CXTPComboBoxThemeResource
  • CXTPComboBoxThemeVisualStudio() : CXTPComboBoxThemeVisualStudio
  • CXTPComboBoxThemeVisualStudio2010() : CXTPComboBoxThemeVisualStudio2010
  • CXTPComboBoxThemeVisualStudio2012() : CXTPComboBoxThemeVisualStudio2012
  • CXTPComboBoxThemeVisualStudio2015() : CXTPComboBoxThemeVisualStudio2015
  • CXTPComboBoxThemeVisualStudio2017() : CXTPComboBoxThemeVisualStudio2017
  • CXTPComboBoxThemeVisualStudio2019() : CXTPComboBoxThemeVisualStudio2019
  • CXTPComboBoxThemeVisualStudio2022() : CXTPComboBoxThemeVisualStudio2022
  • CXTPComInitializer() : CXTPComInitializer
  • CXTPCommandBar() : CXTPCommandBar
  • CXTPCommandBarEditCtrl() : CXTPCommandBarEditCtrl
  • CXTPCommandBarKeyboardTip() : CXTPCommandBarKeyboardTip
  • CXTPCommandBarList() : CXTPCommandBarList
  • CXTPCommandBars() : CXTPCommandBars
  • CXTPCommandBarsContextMenus() : CXTPCommandBarsContextMenus
  • CXTPCommandBarScrollBarCtrl() : CXTPCommandBarScrollBarCtrl
  • CXTPCommandBarsFrameHook() : CXTPCommandBarsFrameHook
  • CXTPCommandBarsModernUITheme() : CXTPCommandBarsModernUITheme
  • CXTPCommandBarsNativeWindows10Theme() : CXTPCommandBarsNativeWindows10Theme
  • CXTPCommandBarsNativeWindows11Theme() : CXTPCommandBarsNativeWindows11Theme
  • CXTPCommandBarsNativeXPTheme() : CXTPCommandBarsNativeXPTheme
  • CXTPCommandBarsOffice2000Theme() : CXTPCommandBarsOffice2000Theme
  • CXTPCommandBarsOffice2003Theme() : CXTPCommandBarsOffice2003Theme
  • CXTPCommandBarsOffice2013Theme() : CXTPCommandBarsOffice2013Theme
  • CXTPCommandBarsOfficeXPTheme() : CXTPCommandBarsOfficeXPTheme
  • CXTPCommandBarsOptions() : CXTPCommandBarsOptions
  • CXTPCommandBarsSiteBase() : CXTPCommandBarsSiteBase< TBase >
  • CXTPCommandBarsVisualStudio2012Theme() : CXTPCommandBarsVisualStudio2012Theme
  • CXTPCommandBarsVisualStudio2015Theme() : CXTPCommandBarsVisualStudio2015Theme
  • CXTPCommandBarsVisualStudio2017Theme() : CXTPCommandBarsVisualStudio2017Theme
  • CXTPCommandBarsVisualStudio2019Theme() : CXTPCommandBarsVisualStudio2019Theme
  • CXTPCommandBarsVisualStudio2022Theme() : CXTPCommandBarsVisualStudio2022Theme
  • CXTPControl() : CXTPControl
  • CXTPControlAction() : CXTPControlAction
  • CXTPControlActions() : CXTPControlActions
  • CXTPControlBitmap() : CXTPControlBitmap
  • CXTPControlButton() : CXTPControlButton
  • CXTPControlButtonColor() : CXTPControlButtonColor
  • CXTPControlCheckBox() : CXTPControlCheckBox
  • CXTPControlColorSelector() : CXTPControlColorSelector
  • CXTPControlComboBox() : CXTPControlComboBox
  • CXTPControlComboBoxGalleryPopupBar() : CXTPControlComboBoxGalleryPopupBar
  • CXTPControlComboBoxList() : CXTPControlComboBoxList
  • CXTPControlComboBoxPopupBar() : CXTPControlComboBoxPopupBar
  • CXTPControlCustom() : CXTPControlCustom
  • CXTPControlEdit() : CXTPControlEdit
  • CXTPControlFontComboBox() : CXTPControlFontComboBox
  • CXTPControlGallery() : CXTPControlGallery
  • CXTPControlGalleryItem() : CXTPControlGalleryItem
  • CXTPControlGalleryItems() : CXTPControlGalleryItems
  • CXTPControlGalleryNativeWindows10Theme() : CXTPControlGalleryNativeWindows10Theme
  • CXTPControlGalleryNativeWindows11Theme() : CXTPControlGalleryNativeWindows11Theme
  • CXTPControlGalleryOffice2013Theme() : CXTPControlGalleryOffice2013Theme
  • CXTPControlGalleryPaintManager() : CXTPControlGalleryPaintManager
  • CXTPControlGalleryResourceTheme() : CXTPControlGalleryResourceTheme
  • CXTPControlGalleryVisualStudio2015Theme() : CXTPControlGalleryVisualStudio2015Theme
  • CXTPControlGalleryVisualStudio2017Theme() : CXTPControlGalleryVisualStudio2017Theme
  • CXTPControlGalleryVisualStudio2019Theme() : CXTPControlGalleryVisualStudio2019Theme
  • CXTPControlGalleryVisualStudio2022Theme() : CXTPControlGalleryVisualStudio2022Theme
  • CXTPControlHyperlink() : CXTPControlHyperlink
  • CXTPControlListBox() : CXTPControlListBox
  • CXTPControlMarkupLabel() : CXTPControlMarkupLabel
  • CXTPControlPopup() : CXTPControlPopup
  • CXTPControlPopupColor() : CXTPControlPopupColor
  • CXTPControlProgress() : CXTPControlProgress
  • CXTPControlRadioButton() : CXTPControlRadioButton
  • CXTPControls() : CXTPControls
  • CXTPControlScrollBar() : CXTPControlScrollBar
  • CXTPControlSelector() : CXTPControlSelector
  • CXTPControlSizeComboBox() : CXTPControlSizeComboBox
  • CXTPControlSlider() : CXTPControlSlider
  • CXTPControlStatic() : CXTPControlStatic
  • CXTPControlTabWorkspace() : CXTPControlTabWorkspace
  • CXTPControlTheme() : CXTPControlTheme
  • CXTPControlToolbars() : CXTPControlToolbars
  • CXTPCriticalSection() : CXTPCriticalSection
  • CXTPCustomizeCommandsListBox() : CXTPCustomizeCommandsListBox
  • CXTPCustomizeCommandsPage() : CXTPCustomizeCommandsPage
  • CXTPCustomizeKeyboardPage() : CXTPCustomizeKeyboardPage
  • CXTPCustomizeMenusPage() : CXTPCustomizeMenusPage
  • CXTPCustomizeOptionsPage() : CXTPCustomizeOptionsPage
  • CXTPCustomizeSheet() : CXTPCustomizeSheet
  • CXTPCustomizeToolbarsPage() : CXTPCustomizeToolbarsPage
  • CXTPDateEdit() : CXTPDateEdit
  • CXTPDatePickerButton() : CXTPDatePickerButton
  • CXTPDatePickerControl() : CXTPDatePickerControl
  • CXTPDatePickerDaysCollection() : CXTPDatePickerDaysCollection
  • CXTPDatePickerItemDay() : CXTPDatePickerItemDay
  • CXTPDatePickerItemMonth() : CXTPDatePickerItemMonth
  • CXTPDatePickerList() : CXTPDatePickerList
  • CXTPDatePickerPaintManager() : CXTPDatePickerPaintManager
  • CXTPDatePickerThemeNativeWindows10() : CXTPDatePickerThemeNativeWindows10
  • CXTPDatePickerThemeNativeWindows11() : CXTPDatePickerThemeNativeWindows11
  • CXTPDatePickerThemeOffice2000() : CXTPDatePickerThemeOffice2000
  • CXTPDatePickerThemeOffice2003() : CXTPDatePickerThemeOffice2003
  • CXTPDatePickerThemeOffice2013() : CXTPDatePickerThemeOffice2013
  • CXTPDatePickerThemeOfficeXP() : CXTPDatePickerThemeOfficeXP
  • CXTPDatePickerThemeResource() : CXTPDatePickerThemeResource
  • CXTPDatePickerThemeVisualStudio2015() : CXTPDatePickerThemeVisualStudio2015
  • CXTPDatePickerThemeVisualStudio2017() : CXTPDatePickerThemeVisualStudio2017
  • CXTPDatePickerThemeVisualStudio2019() : CXTPDatePickerThemeVisualStudio2019
  • CXTPDatePickerThemeVisualStudio2022() : CXTPDatePickerThemeVisualStudio2022
  • CXTPDeviceCaps() : CXTPDeviceCaps
  • CXTPDialogBar() : CXTPDialogBar
  • CXTPDialogBase() : CXTPDialogBase< TBase >
  • CXTPDialogEx() : CXTPDialogEx
  • CXTPDialogScrollBarContainer() : CXTPDialogScrollBarContainer< Parent >
  • CXTPDirWatcher() : CXTPDirWatcher
  • CXTPDockBar() : CXTPDockBar
  • CXTPDockContext() : CXTPDockContext
  • CXTPDockingPane() : CXTPDockingPane
  • CXTPDockingPaneAutoHidePanel() : CXTPDockingPaneAutoHidePanel
  • CXTPDockingPaneBase() : CXTPDockingPaneBase
  • CXTPDockingPaneBaseContainer() : CXTPDockingPaneBaseContainer
  • CXTPDockingPaneCaptionButton() : CXTPDockingPaneCaptionButton
  • CXTPDockingPaneContext() : CXTPDockingPaneContext
  • CXTPDockingPaneContextAlphaWnd() : CXTPDockingPaneContextAlphaWnd
  • CXTPDockingPaneContextStickerWnd() : CXTPDockingPaneContextStickerWnd
  • CXTPDockingPaneDefaultTheme() : CXTPDockingPaneDefaultTheme
  • CXTPDockingPaneGripperedTheme() : CXTPDockingPaneGripperedTheme
  • CXTPDockingPaneLayout() : CXTPDockingPaneLayout
  • CXTPDockingPaneManager() : CXTPDockingPaneManager
  • CXTPDockingPaneMiniWnd() : CXTPDockingPaneMiniWnd
  • CXTPDockingPaneNativeWindows10Theme() : CXTPDockingPaneNativeWindows10Theme
  • CXTPDockingPaneNativeWindows11Theme() : CXTPDockingPaneNativeWindows11Theme
  • CXTPDockingPaneOffice2002VisioTheme() : CXTPDockingPaneOffice2002VisioTheme
  • CXTPDockingPaneOffice2003OutlookTheme() : CXTPDockingPaneOffice2003OutlookTheme
  • CXTPDockingPaneOffice2003Theme() : CXTPDockingPaneOffice2003Theme
  • CXTPDockingPaneOffice2003VisioTheme() : CXTPDockingPaneOffice2003VisioTheme
  • CXTPDockingPaneOffice2007OutlookTheme() : CXTPDockingPaneOffice2007OutlookTheme
  • CXTPDockingPaneOffice2007Theme() : CXTPDockingPaneOffice2007Theme
  • CXTPDockingPaneOffice2007VisioTheme() : CXTPDockingPaneOffice2007VisioTheme
  • CXTPDockingPaneOffice2007WordTheme() : CXTPDockingPaneOffice2007WordTheme
  • CXTPDockingPaneOffice2013Theme() : CXTPDockingPaneOffice2013Theme
  • CXTPDockingPanePaintManager() : CXTPDockingPanePaintManager
  • CXTPDockingPanePanelColorSet2012() : CXTPDockingPanePanelColorSet2012
  • CXTPDockingPanePanelColorSet2013() : CXTPDockingPanePanelColorSet2013
  • CXTPDockingPanePanelColorSet2015() : CXTPDockingPanePanelColorSet2015
  • CXTPDockingPanePanelColorSet2017() : CXTPDockingPanePanelColorSet2017
  • CXTPDockingPanePanelColorSet2019() : CXTPDockingPanePanelColorSet2019
  • CXTPDockingPanePanelColorSet2022() : CXTPDockingPanePanelColorSet2022
  • CXTPDockingPanePanelColorSetNativeWindows10() : CXTPDockingPanePanelColorSetNativeWindows10
  • CXTPDockingPanePanelColorSetNativeWindows11() : CXTPDockingPanePanelColorSetNativeWindows11
  • CXTPDockingPanePanelTheme2012() : CXTPDockingPanePanelTheme2012
  • CXTPDockingPanePanelTheme2013() : CXTPDockingPanePanelTheme2013
  • CXTPDockingPanePanelTheme2015() : CXTPDockingPanePanelTheme2015
  • CXTPDockingPanePanelTheme2017() : CXTPDockingPanePanelTheme2017
  • CXTPDockingPanePanelTheme2019() : CXTPDockingPanePanelTheme2019
  • CXTPDockingPanePanelTheme2022() : CXTPDockingPanePanelTheme2022
  • CXTPDockingPanePanelThemeNativeWindows10() : CXTPDockingPanePanelThemeNativeWindows10
  • CXTPDockingPanePanelThemeNativeWindows11() : CXTPDockingPanePanelThemeNativeWindows11
  • CXTPDockingPaneSidePanel() : CXTPDockingPaneSidePanel
  • CXTPDockingPaneSplitterContainer() : CXTPDockingPaneSplitterContainer
  • CXTPDockingPaneSplitterWnd() : CXTPDockingPaneSplitterWnd
  • CXTPDockingPaneTabbedContainer() : CXTPDockingPaneTabbedContainer
  • CXTPDockingPaneTabColorSet2012() : CXTPDockingPaneTabColorSet2012
  • CXTPDockingPaneTabColorSet2013() : CXTPDockingPaneTabColorSet2013
  • CXTPDockingPaneTabColorSet2015() : CXTPDockingPaneTabColorSet2015
  • CXTPDockingPaneTabColorSet2017() : CXTPDockingPaneTabColorSet2017
  • CXTPDockingPaneTabColorSet2019() : CXTPDockingPaneTabColorSet2019
  • CXTPDockingPaneTabColorSet2022() : CXTPDockingPaneTabColorSet2022
  • CXTPDockingPaneTabColorSetNativeWindows10() : CXTPDockingPaneTabColorSetNativeWindows10
  • CXTPDockingPaneTabColorSetNativeWindows11() : CXTPDockingPaneTabColorSetNativeWindows11
  • CXTPDockingPaneTabColorSetOfficePanel() : CXTPDockingPaneTabColorSetOfficePanel
  • CXTPDockingPaneTabColorSetVisualStudio2003() : CXTPDockingPaneTabColorSetVisualStudio2003
  • CXTPDockingPaneTabColorSetVisualStudio2005() : CXTPDockingPaneTabColorSetVisualStudio2005
  • CXTPDockingPaneTabTheme2012() : CXTPDockingPaneTabTheme2012
  • CXTPDockingPaneTabTheme2013() : CXTPDockingPaneTabTheme2013
  • CXTPDockingPaneTabTheme2015() : CXTPDockingPaneTabTheme2015
  • CXTPDockingPaneTabTheme2017() : CXTPDockingPaneTabTheme2017
  • CXTPDockingPaneTabTheme2019() : CXTPDockingPaneTabTheme2019
  • CXTPDockingPaneTabTheme2022() : CXTPDockingPaneTabTheme2022
  • CXTPDockingPaneTabThemeNativeWindows10() : CXTPDockingPaneTabThemeNativeWindows10
  • CXTPDockingPaneTabThemeNativeWindows11() : CXTPDockingPaneTabThemeNativeWindows11
  • CXTPDockingPaneVisualStudio2003Theme() : CXTPDockingPaneVisualStudio2003Theme
  • CXTPDockingPaneVisualStudio2005Beta1Theme() : CXTPDockingPaneVisualStudio2005Beta1Theme
  • CXTPDockingPaneVisualStudio2005Beta2Theme() : CXTPDockingPaneVisualStudio2005Beta2Theme
  • CXTPDockingPaneVisualStudio2005Theme() : CXTPDockingPaneVisualStudio2005Theme
  • CXTPDockingPaneVisualStudio2008Theme() : CXTPDockingPaneVisualStudio2008Theme
  • CXTPDockingPaneVisualStudio2010Theme() : CXTPDockingPaneVisualStudio2010Theme
  • CXTPDockingPaneVisualStudio2012Theme() : CXTPDockingPaneVisualStudio2012Theme
  • CXTPDockingPaneVisualStudio2015Theme() : CXTPDockingPaneVisualStudio2015Theme
  • CXTPDockingPaneVisualStudio2017Theme() : CXTPDockingPaneVisualStudio2017Theme
  • CXTPDockingPaneVisualStudio2019Theme() : CXTPDockingPaneVisualStudio2019Theme
  • CXTPDockingPaneVisualStudio2022Theme() : CXTPDockingPaneVisualStudio2022Theme
  • CXTPDockingPaneVisualStudio6Theme() : CXTPDockingPaneVisualStudio6Theme
  • CXTPDockingPaneWindowSelect() : CXTPDockingPaneWindowSelect
  • CXTPDockingPaneWinExplorerTheme() : CXTPDockingPaneWinExplorerTheme
  • CXTPDockingPaneWinNativeTheme() : CXTPDockingPaneWinNativeTheme
  • CXTPDockState() : CXTPDockState
  • CXTPDPCache() : CXTPCalendarData::CXTPDPCache
  • CXTPDropSource() : CXTPDropSource
  • CXTPEdit() : CXTPEdit
  • CXTPEditListBox() : CXTPEditListBox
  • CXTPEditListBoxToolBar() : CXTPEditListBoxToolBar
  • CXTPEditTheme() : CXTPEditTheme
  • CXTPEditThemeDefault() : CXTPEditThemeDefault
  • CXTPEditThemeFlat() : CXTPEditThemeFlat
  • CXTPEditThemeNativeWindows10() : CXTPEditThemeNativeWindows10
  • CXTPEditThemeNativeWindows11() : CXTPEditThemeNativeWindows11
  • CXTPEditThemeOffice2000() : CXTPEditThemeOffice2000
  • CXTPEditThemeOffice2003() : CXTPEditThemeOffice2003
  • CXTPEditThemeOffice2013() : CXTPEditThemeOffice2013
  • CXTPEditThemeOfficeXP() : CXTPEditThemeOfficeXP
  • CXTPEditThemeResource() : CXTPEditThemeResource
  • CXTPEditThemeUltraFlat() : CXTPEditThemeUltraFlat
  • CXTPEditThemeVisualStudio2010() : CXTPEditThemeVisualStudio2010
  • CXTPEditThemeVisualStudio2012() : CXTPEditThemeVisualStudio2012
  • CXTPEditThemeVisualStudio2015() : CXTPEditThemeVisualStudio2015
  • CXTPEditThemeVisualStudio2017() : CXTPEditThemeVisualStudio2017
  • CXTPEditThemeVisualStudio2019() : CXTPEditThemeVisualStudio2019
  • CXTPEditThemeVisualStudio2022() : CXTPEditThemeVisualStudio2022
  • CXTPEmptyRect() : CXTPEmptyRect
  • CXTPEmptySize() : CXTPEmptySize
  • CXTPExcelTabCtrl() : CXTPExcelTabCtrl
  • CXTPExcelTabCtrlButtonState() : CXTPExcelTabCtrlButtonState
  • CXTPExcelTabCtrlTheme() : CXTPExcelTabCtrlTheme
  • CXTPExcelTabCtrlThemeNativeWindows10() : CXTPExcelTabCtrlThemeNativeWindows10
  • CXTPExcelTabCtrlThemeNativeWindows11() : CXTPExcelTabCtrlThemeNativeWindows11
  • CXTPExcelTabCtrlThemeOffice2003() : CXTPExcelTabCtrlThemeOffice2003
  • CXTPExcelTabCtrlThemeOffice2013() : CXTPExcelTabCtrlThemeOffice2013
  • CXTPExcelTabCtrlThemeOfficeXP() : CXTPExcelTabCtrlThemeOfficeXP
  • CXTPExcelTabCtrlThemeVisualStudio2015() : CXTPExcelTabCtrlThemeVisualStudio2015
  • CXTPExcelTabCtrlThemeVisualStudio2017() : CXTPExcelTabCtrlThemeVisualStudio2017
  • CXTPExcelTabCtrlThemeVisualStudio2019() : CXTPExcelTabCtrlThemeVisualStudio2019
  • CXTPExcelTabCtrlThemeVisualStudio2022() : CXTPExcelTabCtrlThemeVisualStudio2022
  • CXTPEyeDropper() : CXTPEyeDropper
  • CXTPFlowGraphConnection() : CXTPFlowGraphConnection
  • CXTPFlowGraphConnectionPoint() : CXTPFlowGraphConnectionPoint
  • CXTPFlowGraphConnectionPoints() : CXTPFlowGraphConnectionPoints
  • CXTPFlowGraphConnections() : CXTPFlowGraphConnections
  • CXTPFlowGraphControl() : CXTPFlowGraphControl
  • CXTPFlowGraphEditItem() : CXTPFlowGraphEditItem
  • CXTPFlowGraphElement() : CXTPFlowGraphElement
  • CXTPFlowGraphImage() : CXTPFlowGraphImage
  • CXTPFlowGraphImages() : CXTPFlowGraphImages
  • CXTPFlowGraphNode() : CXTPFlowGraphNode
  • CXTPFlowGraphNodeCustom() : CXTPFlowGraphNodeCustom
  • CXTPFlowGraphNodeGroup() : CXTPFlowGraphNodeGroup
  • CXTPFlowGraphNodeGroups() : CXTPFlowGraphNodeGroups
  • CXTPFlowGraphNodes() : CXTPFlowGraphNodes
  • CXTPFlowGraphPage() : CXTPFlowGraphPage
  • CXTPFlowGraphPageHistory() : CXTPFlowGraphPageHistory
  • CXTPFlowGraphPages() : CXTPFlowGraphPages
  • CXTPFlowGraphPaintManager() : CXTPFlowGraphPaintManager
  • CXTPFlowGraphSelectedElements() : CXTPFlowGraphSelectedElements
  • CXTPFlowGraphUndoAddConnectionCommand() : CXTPFlowGraphUndoAddConnectionCommand
  • CXTPFlowGraphUndoAddConnectionPointCommand() : CXTPFlowGraphUndoAddConnectionPointCommand
  • CXTPFlowGraphUndoAddNodeCommand() : CXTPFlowGraphUndoAddNodeCommand
  • CXTPFlowGraphUndoCommand() : CXTPFlowGraphUndoCommand
  • CXTPFlowGraphUndoDeleteConnectionCommand() : CXTPFlowGraphUndoDeleteConnectionCommand
  • CXTPFlowGraphUndoDeleteConnectionPointCommand() : CXTPFlowGraphUndoDeleteConnectionPointCommand
  • CXTPFlowGraphUndoDeleteNodeCommand() : CXTPFlowGraphUndoDeleteNodeCommand
  • CXTPFlowGraphUndoGroupCommand() : CXTPFlowGraphUndoGroupCommand
  • CXTPFlowGraphUndoManager() : CXTPFlowGraphUndoManager
  • CXTPFlowGraphUndoSetConnectionPositionCommand() : CXTPFlowGraphUndoSetConnectionPositionCommand
  • CXTPFlowGraphUndoSetNodeCaptionCommand() : CXTPFlowGraphUndoSetNodeCaptionCommand
  • CXTPFlowGraphUndoSetNodePositionCommand() : CXTPFlowGraphUndoSetNodePositionCommand
  • CXTPFlowGraphUndoSetNodeSizeCommand() : CXTPFlowGraphUndoSetNodeSizeCommand
  • CXTPFont() : CXTPFont
  • CXTPFontComboBox() : CXTPFontComboBox
  • CXTPFontCtrlBase() : CXTPFontCtrlBase
  • CXTPFontEnum() : CXTPFontEnum
  • CXTPFontListBox() : CXTPFontListBox
  • CXTPFramePaintManager() : CXTPFramePaintManager
  • CXTPFrameShadow() : CXTPFrameShadow
  • CXTPFrameThemeOffice2007System() : CXTPFrameThemeOffice2007System
  • CXTPFrameWndBase() : CXTPFrameWndBase< TBase >
  • CXTPGaugeBaseType() : CXTPGaugeBaseType
  • CXTPGaugeCtrl() : CXTPGaugeCtrl
  • CXTPGaugeTraits() : CXTPGaugeTraits
  • CXTPGdiObject() : CXTPGdiObject
  • CXTPGlobalAtom() : CXTPGlobalAtom
  • CXTPGraphicBitmapPng() : CXTPGraphicBitmapPng
  • CXTPGridColumn() : CXTPGridColumn
  • CXTPGridColumnOrder() : CXTPGridColumnOrder
  • CXTPGridColumns() : CXTPGridColumns
  • CXTPGridControl() : CXTPGridControl
  • CXTPGridDataManager() : CXTPGridDataManager
  • CXTPGridFilterEditControl() : CXTPGridFilterEditControl
  • CXTPGridGroupRow() : CXTPGridGroupRow
  • CXTPGridHeader() : CXTPGridHeader
  • CXTPGridHeaderDragWnd() : CXTPGridHeaderDragWnd
  • CXTPGridHeaderDropWnd() : CXTPGridHeaderDropWnd
  • CXTPGridHyperlink() : CXTPGridHyperlink
  • CXTPGridHyperlinks() : CXTPGridHyperlinks
  • CXTPGridHyperlinkStyle() : CXTPGridHyperlinkStyle
  • CXTPGridIconNavigator() : CXTPGridIconNavigator
  • CXTPGridInplaceButton() : CXTPGridInplaceButton
  • CXTPGridInplaceButtons() : CXTPGridInplaceButtons
  • CXTPGridInplaceControl() : CXTPGridInplaceControl
  • CXTPGridInplaceEdit() : CXTPGridInplaceEdit
  • CXTPGridInplaceList() : CXTPGridInplaceList
  • CXTPGridNavigator() : CXTPGridNavigator
  • CXTPGridPageSetupDialog() : CXTPGridPageSetupDialog
  • CXTPGridPaintManager() : CXTPGridPaintManager
  • CXTPGridRecord() : CXTPGridRecord
  • CXTPGridRecordItem() : CXTPGridRecordItem
  • CXTPGridRecordItemButton() : CXTPGridRecordItemButton
  • CXTPGridRecordItemCheckbox() : CXTPGridRecordItemCheckbox
  • CXTPGridRecordItemConstraint() : CXTPGridRecordItemConstraint
  • CXTPGridRecordItemConstraints() : CXTPGridRecordItemConstraints
  • CXTPGridRecordItemControl() : CXTPGridRecordItemControl
  • CXTPGridRecordItemControlHookWnd() : CXTPGridRecordItemControlHookWnd
  • CXTPGridRecordItemControls() : CXTPGridRecordItemControls
  • CXTPGridRecordItemDateTime() : CXTPGridRecordItemDateTime
  • CXTPGridRecordItemEditOptions() : CXTPGridRecordItemEditOptions
  • CXTPGridRecordItemNumber() : CXTPGridRecordItemNumber
  • CXTPGridRecordItemPercentNumber() : CXTPGridRecordItemPercentNumber
  • CXTPGridRecordItemPreview() : CXTPGridRecordItemPreview
  • CXTPGridRecordItemText() : CXTPGridRecordItemText
  • CXTPGridRecordItemVariant() : CXTPGridRecordItemVariant
  • CXTPGridRecords() : CXTPGridRecords
  • CXTPGridRow() : CXTPGridRow
  • CXTPGridRows() : CXTPGridRows
  • CXTPGridSection() : CXTPGridSection
  • CXTPGridSections() : CXTPGridSections
  • CXTPGridSelectedRows() : CXTPGridSelectedRows
  • CXTPGridSubListControl() : CXTPGridSubListControl
  • CXTPGridThemeDefault() : CXTPGridThemeDefault
  • CXTPGridThemeExplorer() : CXTPGridThemeExplorer
  • CXTPGridThemeNativeWindows10() : CXTPGridThemeNativeWindows10
  • CXTPGridThemeNativeWindows11() : CXTPGridThemeNativeWindows11
  • CXTPGridThemeOffice2003() : CXTPGridThemeOffice2003
  • CXTPGridThemeOffice2003Luna() : CXTPGridThemeOffice2003Luna
  • CXTPGridThemeOffice2013() : CXTPGridThemeOffice2013
  • CXTPGridThemeOfficeXP() : CXTPGridThemeOfficeXP
  • CXTPGridThemeResource() : CXTPGridThemeResource
  • CXTPGridThemeVisualStudio2012Blue() : CXTPGridThemeVisualStudio2012Blue
  • CXTPGridThemeVisualStudio2012Dark() : CXTPGridThemeVisualStudio2012Dark
  • CXTPGridThemeVisualStudio2012Light() : CXTPGridThemeVisualStudio2012Light
  • CXTPGridThemeVisualStudio2015() : CXTPGridThemeVisualStudio2015
  • CXTPGridThemeVisualStudio2017() : CXTPGridThemeVisualStudio2017
  • CXTPGridThemeVisualStudio2019() : CXTPGridThemeVisualStudio2019
  • CXTPGridThemeVisualStudio2022() : CXTPGridThemeVisualStudio2022
  • CXTPGridThickness() : CXTPGridThickness
  • CXTPGridTip() : CXTPGridTip
  • CXTPGridView() : CXTPGridView
  • CXTPGridViewPrintOptions() : CXTPGridViewPrintOptions
  • CXTPGroupLine() : CXTPGroupLine
  • CXTPHeaderCtrl() : CXTPHeaderCtrl
  • CXTPHeaderCtrlTheme() : CXTPHeaderCtrlTheme
  • CXTPHeaderCtrlThemeExplorer() : CXTPHeaderCtrlThemeExplorer
  • CXTPHeaderCtrlThemeOffice2003() : CXTPHeaderCtrlThemeOffice2003
  • CXTPHeaderCtrlThemeOfficeXP() : CXTPHeaderCtrlThemeOfficeXP
  • CXTPHeaderCtrlThemeResource() : CXTPHeaderCtrlThemeResource
  • CXTPHeapString() : CXTPHeapString
  • CXTPHeapStringT() : CXTPHeapStringT< _TAllocator >
  • CXTPHexEdit() : CXTPHexEdit
  • CXTPHookManager() : CXTPHookManager
  • CXTPHookManagerHookAble() : CXTPHookManagerHookAble
  • CXTPHyperLink() : CXTPHyperLink
  • CXTPIconHandle() : CXTPIconHandle
  • CXTPImageEditorDlg() : CXTPImageEditorDlg
  • CXTPImageList() : CXTPImageList
  • CXTPImageManager() : CXTPImageManager
  • CXTPImageManagerIcon() : CXTPImageManagerIcon
  • CXTPImageManagerIconHandle() : CXTPImageManagerIconHandle
  • CXTPImageManagerIconSet() : CXTPImageManagerIconSet
  • CXTPImageManagerImageList() : CXTPImageManagerImageList
  • CXTPImageManagerResource() : CXTPImageManagerResource
  • CXTPImageManagerVectorImageHandle() : CXTPImageManagerVectorImageHandle
  • CXTPInternalCollectionT() : CXTPInternalCollectionT< _TObject >
  • CXTPItemEdit() : CXTPItemEdit
  • CXTPKeyboardManager() : CXTPKeyboardManager
  • CXTPListBase() : CXTPListBase
  • CXTPListBox() : CXTPListBox
  • CXTPListBoxThemeNativeWindows10() : CXTPListBoxThemeNativeWindows10
  • CXTPListBoxThemeNativeWindows11() : CXTPListBoxThemeNativeWindows11
  • CXTPListBoxThemeOffice2013() : CXTPListBoxThemeOffice2013
  • CXTPListBoxThemeVisualStudio2015() : CXTPListBoxThemeVisualStudio2015
  • CXTPListBoxThemeVisualStudio2017() : CXTPListBoxThemeVisualStudio2017
  • CXTPListBoxThemeVisualStudio2019() : CXTPListBoxThemeVisualStudio2019
  • CXTPListBoxThemeVisualStudio2022() : CXTPListBoxThemeVisualStudio2022
  • CXTPListCtrl() : CXTPListCtrl
  • CXTPListView() : CXTPListView
  • CXTPLockGuard() : CXTPLockGuard
  • CXTPLogFont() : CXTPLogFont
  • CXTPMarkupBorder() : CXTPMarkupBorder
  • CXTPMarkupButton() : CXTPMarkupButton
  • CXTPMarkupButtonBase() : CXTPMarkupButtonBase
  • CXTPMarkupCheckBox() : CXTPMarkupCheckBox
  • CXTPMarkupColumnDefinition() : CXTPMarkupColumnDefinition
  • CXTPMarkupColumnDefinitionCollection() : CXTPMarkupColumnDefinitionCollection
  • CXTPMarkupContentControl() : CXTPMarkupContentControl
  • CXTPMarkupContext() : CXTPMarkupContext
  • CXTPMarkupDecorator() : CXTPMarkupDecorator
  • CXTPMarkupDefinitionBase() : CXTPMarkupDefinitionBase
  • CXTPMarkupDefinitionCollection() : CXTPMarkupDefinitionCollection
  • CXTPMarkupDeviceDependentImage() : CXTPMarkupDeviceDependentImage
  • CXTPMarkupDockPanel() : CXTPMarkupDockPanel
  • CXTPMarkupExtension() : CXTPMarkupExtension
  • CXTPMarkupFrameworkElement() : CXTPMarkupFrameworkElement
  • CXTPMarkupGdiImage() : CXTPMarkupGdiImage
  • CXTPMarkupGdiPlusImage() : CXTPMarkupGdiPlusImage
  • CXTPMarkupGdiPlusMatrixTransform() : CXTPMarkupGdiPlusMatrixTransform
  • CXTPMarkupGdiPlusRotateTransform() : CXTPMarkupGdiPlusRotateTransform
  • CXTPMarkupGdiPlusScaleTransform() : CXTPMarkupGdiPlusScaleTransform
  • CXTPMarkupGdiPlusTransformationMatrix() : CXTPMarkupGdiPlusTransformationMatrix
  • CXTPMarkupGdiPlusTransformObject() : CXTPMarkupGdiPlusTransformObject< BaseTransform >
  • CXTPMarkupGdiPlusTransformObjectImpl() : CXTPMarkupGdiPlusTransformObjectImpl
  • CXTPMarkupGrid() : CXTPMarkupGrid
  • CXTPMarkupGridLength() : CXTPMarkupGridLength
  • CXTPMarkupImage() : CXTPMarkupImage
  • CXTPMarkupPage() : CXTPMarkupPage
  • CXTPMarkupPanel() : CXTPMarkupPanel
  • CXTPMarkupRadioButton() : CXTPMarkupRadioButton
  • CXTPMarkupRowDefinition() : CXTPMarkupRowDefinition
  • CXTPMarkupRowDefinitionCollection() : CXTPMarkupRowDefinitionCollection
  • CXTPMarkupStackPanel() : CXTPMarkupStackPanel
  • CXTPMarkupStaticExtension() : CXTPMarkupStaticExtension
  • CXTPMarkupStaticExtensionBooleanProperty() : CXTPMarkupStaticExtensionBooleanProperty
  • CXTPMarkupStaticExtensionBrushProperty() : CXTPMarkupStaticExtensionBrushProperty
  • CXTPMarkupStaticExtensionColorProperty() : CXTPMarkupStaticExtensionColorProperty
  • CXTPMarkupStaticExtensionDoubleProperty() : CXTPMarkupStaticExtensionDoubleProperty
  • CXTPMarkupStaticExtensionIntegerProperty() : CXTPMarkupStaticExtensionIntegerProperty
  • CXTPMarkupStaticExtensionProperty() : CXTPMarkupStaticExtensionProperty
  • CXTPMarkupStaticExtensionStringProperty() : CXTPMarkupStaticExtensionStringProperty
  • CXTPMarkupSystemBrushKeyStaticExtension() : CXTPMarkupSystemBrushKeyStaticExtension
  • CXTPMarkupSystemBrushStaticExtension() : CXTPMarkupSystemBrushStaticExtension
  • CXTPMarkupSystemColorKeyStaticExtension() : CXTPMarkupSystemColorKeyStaticExtension
  • CXTPMarkupSystemColorsStaticExtension() : CXTPMarkupSystemColorsStaticExtension
  • CXTPMarkupSystemColorStaticExtension() : CXTPMarkupSystemColorStaticExtension
  • CXTPMarkupTextBlock() : CXTPMarkupTextBlock
  • CXTPMarkupThemePart() : CXTPMarkupThemePart
  • CXTPMarkupThickness() : CXTPMarkupThickness
  • CXTPMarkupTransform() : CXTPMarkupTransform
  • CXTPMarkupTransformationMatrix() : CXTPMarkupTransformationMatrix
  • CXTPMarkupTreeCtrl() : CXTPMarkupTreeCtrl
  • CXTPMarkupUIElement() : CXTPMarkupUIElement
  • CXTPMarkupUIElementCollection() : CXTPMarkupUIElementCollection
  • CXTPMarkupUniformGrid() : CXTPMarkupUniformGrid
  • CXTPMarkupViewbox() : CXTPMarkupViewbox
  • CXTPMarkupVisual() : CXTPMarkupVisual
  • CXTPMarkupWrapPanel() : CXTPMarkupWrapPanel
  • CXTPMarqueeCtrl() : CXTPMarqueeCtrl
  • CXTPMarqueeCtrlPaintManager() : CXTPMarqueeCtrlPaintManager
  • CXTPMarqueeCtrlThemeFlat() : CXTPMarqueeCtrlThemeFlat
  • CXTPMarqueeCtrlThemeNativeWindows() : CXTPMarqueeCtrlThemeNativeWindows
  • CXTPMarqueeCtrlThemeNativeWinXP() : CXTPMarqueeCtrlThemeNativeWinXP
  • CXTPMarqueeCtrlThemeOffice2000() : CXTPMarqueeCtrlThemeOffice2000
  • CXTPMarqueeCtrlThemeOffice2003() : CXTPMarqueeCtrlThemeOffice2003
  • CXTPMarqueeCtrlThemeOffice2013() : CXTPMarqueeCtrlThemeOffice2013
  • CXTPMarqueeCtrlThemeOfficeXP() : CXTPMarqueeCtrlThemeOfficeXP
  • CXTPMarqueeCtrlThemeResource() : CXTPMarqueeCtrlThemeResource
  • CXTPMarqueeCtrlThemeUltraFlat() : CXTPMarqueeCtrlThemeUltraFlat
  • CXTPMarqueeCtrlThemeVisualStudio2015() : CXTPMarqueeCtrlThemeVisualStudio2015
  • CXTPMarqueeCtrlThemeVisualStudio2017() : CXTPMarqueeCtrlThemeVisualStudio2017
  • CXTPMarqueeCtrlThemeVisualStudio2019() : CXTPMarqueeCtrlThemeVisualStudio2019
  • CXTPMarqueeCtrlThemeVisualStudio2022() : CXTPMarqueeCtrlThemeVisualStudio2022
  • CXTPMaskEdit() : CXTPMaskEdit
  • CXTPMaskEditT() : CXTPMaskEditT< TBase >
  • CXTPMatrix() : CXTPMatrix< T >
  • CXTPMDIClientWnd() : CXTPMDIClientWnd
  • CXTPMDIWndTab() : CXTPMDIWndTab
  • CXTPMemFile() : CXTPMemFile
  • CXTPMenuBar() : CXTPMenuBar
  • CXTPMenuBarMDIMenuInfo() : CXTPMenuBarMDIMenuInfo
  • CXTPMenuBarMDIMenus() : CXTPMenuBarMDIMenus
  • CXTPMessageBar() : CXTPMessageBar
  • CXTPMessageBarButton() : CXTPMessageBarButton
  • CXTPMessageBarPaintManager() : CXTPMessageBarPaintManager
  • CXTPMessageBarThemeNativeWindows10() : CXTPMessageBarThemeNativeWindows10
  • CXTPMessageBarThemeNativeWindows11() : CXTPMessageBarThemeNativeWindows11
  • CXTPMessageBarThemeOffice2010() : CXTPMessageBarThemeOffice2010
  • CXTPMessageBarThemeOffice2013() : CXTPMessageBarThemeOffice2013
  • CXTPMessageBarThemeVisualStudio2015() : CXTPMessageBarThemeVisualStudio2015
  • CXTPMessageBarThemeVisualStudio2017() : CXTPMessageBarThemeVisualStudio2017
  • CXTPMessageBarThemeVisualStudio2019() : CXTPMessageBarThemeVisualStudio2019
  • CXTPMessageBarThemeVisualStudio2022() : CXTPMessageBarThemeVisualStudio2022
  • CXTPMiniToolBar() : CXTPMiniToolBar
  • CXTPModuleHandle() : CXTPModuleHandle
  • CXTPMouseManager() : CXTPMouseManager
  • CXTPNonClientMetrics() : CXTPNonClientMetrics
  • CXTPNotifyConnection() : CXTPNotifyConnection
  • CXTPNotifyConnectionMT() : CXTPNotifyConnectionMT
  • CXTPNotifySinkBase() : CXTPNotifySinkBase
  • CXTPObservable() : CXTPObservable< Owner, Observer >
  • CXTPOriginalControls() : CXTPOriginalControls
  • CXTPPageScroller() : CXTPPageScroller
  • CXTPPaintManager() : CXTPPaintManager
  • CXTPPaintManagerColor() : CXTPPaintManagerColor
  • CXTPPaintManagerColorGradient() : CXTPPaintManagerColorGradient
  • CXTPPaintManagerFont() : CXTPPaintManagerFont
  • CXTPPasswordPeek() : CXTPPasswordPeek
  • CXTPPen() : CXTPPen
  • CXTPPoint2T() : CXTPPoint2T< T >
  • CXTPPoint3T() : CXTPPoint3T< T >
  • CXTPPopupBar() : CXTPPopupBar
  • CXTPPopupControl() : CXTPPopupControl
  • CXTPPopupItem() : CXTPPopupItem
  • CXTPPopupPaintManager() : CXTPPopupPaintManager
  • CXTPPopupThemeMSN() : CXTPPopupThemeMSN
  • CXTPPopupThemeOffice2000() : CXTPPopupThemeOffice2000
  • CXTPPopupThemeOffice2003() : CXTPPopupThemeOffice2003
  • CXTPPopupThemeOffice2013() : CXTPPopupThemeOffice2013
  • CXTPPopupThemeOfficeXP() : CXTPPopupThemeOfficeXP
  • CXTPPopupThemeResource() : CXTPPopupThemeResource
  • CXTPPreviewCtrl() : CXTPPreviewCtrl
  • CXTPPreviewProviderBase() : CXTPPreviewProviderBase
  • CXTPPreviewView() : CXTPPreviewView
  • CXTPProgressBase() : CXTPProgressBase
  • CXTPProgressCtrl() : CXTPProgressCtrl
  • CXTPProgressCtrlPaintManager() : CXTPProgressCtrlPaintManager
  • CXTPProgressCtrlThemeFlat() : CXTPProgressCtrlThemeFlat
  • CXTPProgressCtrlThemeNativeWindows() : CXTPProgressCtrlThemeNativeWindows
  • CXTPProgressCtrlThemeNativeWinXP() : CXTPProgressCtrlThemeNativeWinXP
  • CXTPProgressCtrlThemeOffice2000() : CXTPProgressCtrlThemeOffice2000
  • CXTPProgressCtrlThemeOffice2003() : CXTPProgressCtrlThemeOffice2003
  • CXTPProgressCtrlThemeOffice2013() : CXTPProgressCtrlThemeOffice2013
  • CXTPProgressCtrlThemeOfficeXP() : CXTPProgressCtrlThemeOfficeXP
  • CXTPProgressCtrlThemeResource() : CXTPProgressCtrlThemeResource
  • CXTPProgressCtrlThemeUltraFlat() : CXTPProgressCtrlThemeUltraFlat
  • CXTPProgressCtrlThemeVisualStudio2015() : CXTPProgressCtrlThemeVisualStudio2015
  • CXTPProgressCtrlThemeVisualStudio2017() : CXTPProgressCtrlThemeVisualStudio2017
  • CXTPProgressCtrlThemeVisualStudio2019() : CXTPProgressCtrlThemeVisualStudio2019
  • CXTPProgressCtrlThemeVisualStudio2022() : CXTPProgressCtrlThemeVisualStudio2022
  • CXTPProgressPaintManager() : CXTPProgressPaintManager
  • CXTPProgressThemeNativeWindows10() : CXTPProgressThemeNativeWindows10
  • CXTPProgressThemeNativeWindows11() : CXTPProgressThemeNativeWindows11
  • CXTPProgressThemeOffice2013() : CXTPProgressThemeOffice2013
  • CXTPProgressThemeVisualStudio2015() : CXTPProgressThemeVisualStudio2015
  • CXTPProgressThemeVisualStudio2017() : CXTPProgressThemeVisualStudio2017
  • CXTPProgressThemeVisualStudio2019() : CXTPProgressThemeVisualStudio2019
  • CXTPProgressThemeVisualStudio2022() : CXTPProgressThemeVisualStudio2022
  • CXTPPropertyGrid() : CXTPPropertyGrid
  • CXTPPropertyGridCoolTheme() : CXTPPropertyGridCoolTheme
  • CXTPPropertyGridDelphiTheme() : CXTPPropertyGridDelphiTheme
  • CXTPPropertyGridInplaceButton() : CXTPPropertyGridInplaceButton
  • CXTPPropertyGridInplaceButtons() : CXTPPropertyGridInplaceButtons
  • CXTPPropertyGridInplaceControl() : CXTPPropertyGridInplaceControl
  • CXTPPropertyGridInplaceControls() : CXTPPropertyGridInplaceControls
  • CXTPPropertyGridInplaceEdit() : CXTPPropertyGridInplaceEdit
  • CXTPPropertyGridInplaceList() : CXTPPropertyGridInplaceList
  • CXTPPropertyGridInplaceMonthCal() : CXTPPropertyGridInplaceMonthCal
  • CXTPPropertyGridInplaceMultilineEdit() : CXTPPropertyGridInplaceMultilineEdit
  • CXTPPropertyGridInplaceSlider() : CXTPPropertyGridInplaceSlider
  • CXTPPropertyGridInplaceSpinButton() : CXTPPropertyGridInplaceSpinButton
  • CXTPPropertyGridItem() : CXTPPropertyGridItem
  • CXTPPropertyGridItemBool() : CXTPPropertyGridItemBool
  • CXTPPropertyGridItemCategory() : CXTPPropertyGridItemCategory
  • CXTPPropertyGridItemColor() : CXTPPropertyGridItemColor
  • CXTPPropertyGridItemConstraint() : CXTPPropertyGridItemConstraint
  • CXTPPropertyGridItemConstraints() : CXTPPropertyGridItemConstraints
  • CXTPPropertyGridItemDate() : CXTPPropertyGridItemDate
  • CXTPPropertyGridItemDouble() : CXTPPropertyGridItemDouble
  • CXTPPropertyGridItemEnum() : CXTPPropertyGridItemEnum
  • CXTPPropertyGridItemFlags() : CXTPPropertyGridItemFlags
  • CXTPPropertyGridItemFont() : CXTPPropertyGridItemFont
  • CXTPPropertyGridItemMetrics() : CXTPPropertyGridItemMetrics
  • CXTPPropertyGridItemMultilineString() : CXTPPropertyGridItemMultilineString
  • CXTPPropertyGridItemNumber() : CXTPPropertyGridItemNumber
  • CXTPPropertyGridItemOption() : CXTPPropertyGridItemOption
  • CXTPPropertyGridItemPoint() : CXTPPropertyGridItemPoint
  • CXTPPropertyGridItems() : CXTPPropertyGridItems
  • CXTPPropertyGridItemSize() : CXTPPropertyGridItemSize
  • CXTPPropertyGridNativeWindows10Theme() : CXTPPropertyGridNativeWindows10Theme
  • CXTPPropertyGridNativeWindows11Theme() : CXTPPropertyGridNativeWindows11Theme
  • CXTPPropertyGridNativeXPTheme() : CXTPPropertyGridNativeXPTheme
  • CXTPPropertyGridOffice2003Theme() : CXTPPropertyGridOffice2003Theme
  • CXTPPropertyGridOffice2007Theme() : CXTPPropertyGridOffice2007Theme
  • CXTPPropertyGridOffice2013Theme() : CXTPPropertyGridOffice2013Theme
  • CXTPPropertyGridOfficeXPTheme() : CXTPPropertyGridOfficeXPTheme
  • CXTPPropertyGridPaintManager() : CXTPPropertyGridPaintManager
  • CXTPPropertyGridSimpleTheme() : CXTPPropertyGridSimpleTheme
  • CXTPPropertyGridToolBar() : CXTPPropertyGridToolBar
  • CXTPPropertyGridToolTip() : CXTPPropertyGridToolTip
  • CXTPPropertyGridUpdateContext() : CXTPPropertyGridUpdateContext
  • CXTPPropertyGridVerb() : CXTPPropertyGridVerb
  • CXTPPropertyGridVerbs() : CXTPPropertyGridVerbs
  • CXTPPropertyGridView() : CXTPPropertyGridView
  • CXTPPropertyGridVisualStudio2005Theme() : CXTPPropertyGridVisualStudio2005Theme
  • CXTPPropertyGridVisualStudio2010Theme() : CXTPPropertyGridVisualStudio2010Theme
  • CXTPPropertyGridVisualStudio2012Theme() : CXTPPropertyGridVisualStudio2012Theme
  • CXTPPropertyGridVisualStudio2015Theme() : CXTPPropertyGridVisualStudio2015Theme
  • CXTPPropertyGridVisualStudio2017Theme() : CXTPPropertyGridVisualStudio2017Theme
  • CXTPPropertyGridVisualStudio2019Theme() : CXTPPropertyGridVisualStudio2019Theme
  • CXTPPropertyGridVisualStudio2022Theme() : CXTPPropertyGridVisualStudio2022Theme
  • CXTPPropertyPage() : CXTPPropertyPage
  • CXTPPropertyPageControlNavigator() : CXTPPropertyPageControlNavigator
  • CXTPPropertyPageListNavigator() : CXTPPropertyPageListNavigator
  • CXTPPropertyPageNavigator() : CXTPPropertyPageNavigator
  • CXTPPropertyPageTreeNavigator() : CXTPPropertyPageTreeNavigator
  • CXTPPropertySheet() : CXTPPropertySheet
  • CXTPPropExchange() : CXTPPropExchange
  • CXTPPropExchangeArchive() : CXTPPropExchangeArchive
  • CXTPPropExchangeEnumerator() : CXTPPropExchangeEnumerator
  • CXTPPropExchangeIniFile() : CXTPPropExchangeIniFile
  • CXTPPropExchangeRegistry() : CXTPPropExchangeRegistry
  • CXTPPropExchangeSection() : CXTPPropExchangeSection
  • CXTPPropExchangeXMLNode() : CXTPPropExchangeXMLNode
  • CXTPReBar() : CXTPReBar
  • CXTPReBarPaintManager() : CXTPReBarPaintManager< TBase >
  • CXTPRecentFileList() : CXTPRecentFileList
  • CXTPRectT() : CXTPRectT< T >
  • CXTPRegistryManager() : CXTPRegistryManager
  • CXTPResize() : CXTPResize
  • CXTPResizeDialog() : CXTPResizeDialog
  • CXTPResizeFormView() : CXTPResizeFormView
  • CXTPResizeGroupBox() : CXTPResizeGroupBox
  • CXTPResizeItem() : CXTPResizeItem
  • CXTPResizePoint() : CXTPResizePoint
  • CXTPResizePropertyPage() : CXTPResizePropertyPage
  • CXTPResizePropertySheet() : CXTPResizePropertySheet
  • CXTPResizeRect() : CXTPResizeRect
  • CXTPResourceImage() : CXTPResourceImage
  • CXTPResourceImages() : CXTPResourceImages
  • CXTPResourceManager() : CXTPResourceManager
  • CXTPResourceManagerXML() : CXTPResourceManagerXML
  • CXTPResourceTheme() : CXTPResourceTheme
  • CXTPRibbonBar() : CXTPRibbonBar
  • CXTPRibbonControls() : CXTPRibbonControls
  • CXTPRibbonControlSystemButton() : CXTPRibbonControlSystemButton
  • CXTPRibbonControlSystemPopupBarButton() : CXTPRibbonControlSystemPopupBarButton
  • CXTPRibbonControlSystemPopupBarListCaption() : CXTPRibbonControlSystemPopupBarListCaption
  • CXTPRibbonControlSystemPopupBarListItem() : CXTPRibbonControlSystemPopupBarListItem
  • CXTPRibbonControlSystemPopupBarPinableListItem() : CXTPRibbonControlSystemPopupBarPinableListItem
  • CXTPRibbonControlSystemRecentFileList() : CXTPRibbonControlSystemRecentFileList
  • CXTPRibbonControlTab() : CXTPRibbonControlTab
  • CXTPRibbonCustomizePage() : CXTPRibbonCustomizePage
  • CXTPRibbonCustomizeQuickAccessPage() : CXTPRibbonCustomizeQuickAccessPage
  • CXTPRibbonGroup() : CXTPRibbonGroup
  • CXTPRibbonGroups() : CXTPRibbonGroups
  • CXTPRibbonMarkupFrameTheme() : CXTPRibbonMarkupFrameTheme
  • CXTPRibbonMarkupTheme() : CXTPRibbonMarkupTheme
  • CXTPRibbonOffice2013Theme() : CXTPRibbonOffice2013Theme
  • CXTPRibbonPaintManager() : CXTPRibbonPaintManager
  • CXTPRibbonQuickAccessControls() : CXTPRibbonQuickAccessControls
  • CXTPRibbonSystemPopupBar() : CXTPRibbonSystemPopupBar
  • CXTPRibbonSystemPopupBarPage() : CXTPRibbonSystemPopupBarPage
  • CXTPRibbonTab() : CXTPRibbonTab
  • CXTPRibbonTabPopupToolBar() : CXTPRibbonTabPopupToolBar
  • CXTPRibbonTheme() : CXTPRibbonTheme
  • CXTPRibbonThemeNativeWindows10() : CXTPRibbonThemeNativeWindows10
  • CXTPRibbonThemeNativeWindows11() : CXTPRibbonThemeNativeWindows11
  • CXTPRibbonThemeOffice2007System() : CXTPRibbonThemeOffice2007System
  • CXTPRibbonThemeResource() : CXTPRibbonThemeResource
  • CXTPRibbonThemeVisualStudio2015() : CXTPRibbonThemeVisualStudio2015
  • CXTPRibbonThemeVisualStudio2017() : CXTPRibbonThemeVisualStudio2017
  • CXTPRibbonThemeVisualStudio2019() : CXTPRibbonThemeVisualStudio2019
  • CXTPRibbonThemeVisualStudio2022() : CXTPRibbonThemeVisualStudio2022
  • CXTPRWCriticalSection() : CXTPRWCriticalSection
  • CXTPScrollable() : CXTPScrollable< Base >
  • CXTPScrollableEditT() : CXTPScrollableEditT< EditBase >
  • CXTPScrollableListBoxT() : CXTPScrollableListBoxT< ListBoxBase >
  • CXTPScrollableListCtrlT() : CXTPScrollableListCtrlT< ListBase >
  • CXTPScrollableTreeCtrlT() : CXTPScrollableTreeCtrlT< TreeBase >
  • CXTPScrollBar() : CXTPScrollBar
  • CXTPScrollBarContainer() : CXTPScrollBarContainer< Parent >
  • CXTPScrollBarCtrl() : CXTPScrollBarCtrl
  • CXTPScrollBarPaintManager() : CXTPScrollBarPaintManager
  • CXTPScrollBarThemeOffice2013() : CXTPScrollBarThemeOffice2013
  • CXTPScrollBarThemeWindowsUx() : CXTPScrollBarThemeWindowsUx
  • CXTPScrollBase() : CXTPScrollBase
  • CXTPSearchOptionsCtrl() : CXTPSearchOptionsCtrl
  • CXTPSearchOptionsView() : CXTPSearchOptionsView
  • CXTPShadowManager() : CXTPShadowManager
  • CXTPShellExplorerProvider() : CXTPShellExplorerProvider
  • CXTPShellListBase() : CXTPShellListBase
  • CXTPShellListCtrl() : CXTPShellListCtrl
  • CXTPShellListCtrlEx() : CXTPShellListCtrlEx
  • CXTPShellListView() : CXTPShellListView
  • CXTPShellPidl() : CXTPShellPidl
  • CXTPShellSettings() : CXTPShellSettings
  • CXTPShellTreeBase() : CXTPShellTreeBase
  • CXTPShellTreeCtrl() : CXTPShellTreeCtrl
  • CXTPShellTreeView() : CXTPShellTreeView
  • CXTPShortcutBar() : CXTPShortcutBar
  • CXTPShortcutBarItem() : CXTPShortcutBarItem
  • CXTPShortcutBarNativeWindows10Theme() : CXTPShortcutBarNativeWindows10Theme
  • CXTPShortcutBarNativeWindows11Theme() : CXTPShortcutBarNativeWindows11Theme
  • CXTPShortcutBarNativeWinXPTheme() : CXTPShortcutBarNativeWinXPTheme
  • CXTPShortcutBarOffice2003Theme() : CXTPShortcutBarOffice2003Theme
  • CXTPShortcutBarOffice2013Theme() : CXTPShortcutBarOffice2013Theme
  • CXTPShortcutBarPaintManager() : CXTPShortcutBarPaintManager
  • CXTPShortcutBarPane() : CXTPShortcutBarPane
  • CXTPShortcutBarPaneItem() : CXTPShortcutBarPaneItem
  • CXTPShortcutBarResourceTheme() : CXTPShortcutBarResourceTheme
  • CXTPShortcutBarVisualStudio2015Theme() : CXTPShortcutBarVisualStudio2015Theme
  • CXTPShortcutBarVisualStudio2017Theme() : CXTPShortcutBarVisualStudio2017Theme
  • CXTPShortcutBarVisualStudio2019Theme() : CXTPShortcutBarVisualStudio2019Theme
  • CXTPShortcutBarVisualStudio2022Theme() : CXTPShortcutBarVisualStudio2022Theme
  • CXTPShortcutListBox() : CXTPShortcutListBox
  • CXTPShortcutListBoxTheme() : CXTPShortcutListBoxTheme
  • CXTPShortcutListBoxThemeOffice2003() : CXTPShortcutListBoxThemeOffice2003
  • CXTPShortcutListBoxThemeOfficeXP() : CXTPShortcutListBoxThemeOfficeXP
  • CXTPShortcutManager() : CXTPShortcutManager
  • CXTPShortcutManagerAccel() : CXTPShortcutManagerAccel
  • CXTPShortcutManagerAccelTable() : CXTPShortcutManagerAccelTable
  • CXTPSimpleCriticalSection() : CXTPSimpleCriticalSection
  • CXTPSimpleEvent() : CXTPSimpleEvent
  • CXTPSingletonBase() : CXTPSingletonBase< Derived, Parent >
  • CXTPSingletonPointer() : CXTPSingletonPointer
  • CXTPSizeIcon() : CXTPSizeIcon
  • CXTPSizeT() : CXTPSizeT< T >
  • CXTPSkinImage() : CXTPSkinImage
  • CXTPSkinImages() : CXTPSkinImages
  • CXTPSkinManager() : CXTPSkinManager
  • CXTPSkinManagerClass() : CXTPSkinManagerClass
  • CXTPSkinManagerMetrics() : CXTPSkinManagerMetrics
  • CXTPSkinManagerResourceFile() : CXTPSkinManagerResourceFile
  • CXTPSkinManagerSchema() : CXTPSkinManagerSchema
  • CXTPSkinManagerSchemaProperty() : CXTPSkinManagerSchemaProperty
  • CXTPSkinObject() : CXTPSkinObject
  • CXTPSkinObjectButton() : CXTPSkinObjectButton
  • CXTPSkinObjectClassMap() : CXTPSkinObjectClassMap
  • CXTPSkinObjectComboBox() : CXTPSkinObjectComboBox
  • CXTPSkinObjectComCtl32Control() : CXTPSkinObjectComCtl32Control
  • CXTPSkinObjectDateTime() : CXTPSkinObjectDateTime
  • CXTPSkinObjectEdit() : CXTPSkinObjectEdit
  • CXTPSkinObjectFrame() : CXTPSkinObjectFrame
  • CXTPSkinObjectHeader() : CXTPSkinObjectHeader
  • CXTPSkinObjectListBox() : CXTPSkinObjectListBox
  • CXTPSkinObjectListView() : CXTPSkinObjectListView
  • CXTPSkinObjectMonthCal() : CXTPSkinObjectMonthCal
  • CXTPSkinObjectProgress() : CXTPSkinObjectProgress
  • CXTPSkinObjectReBar() : CXTPSkinObjectReBar
  • CXTPSkinObjectScrollBar() : CXTPSkinObjectScrollBar
  • CXTPSkinObjectSolidFilled() : CXTPSkinObjectSolidFilled
  • CXTPSkinObjectSpin() : CXTPSkinObjectSpin
  • CXTPSkinObjectStatusBar() : CXTPSkinObjectStatusBar
  • CXTPSkinObjectTab() : CXTPSkinObjectTab
  • CXTPSkinObjectToolBar() : CXTPSkinObjectToolBar
  • CXTPSkinObjectTrackBar() : CXTPSkinObjectTrackBar
  • CXTPSkinObjectTreeView() : CXTPSkinObjectTreeView
  • CXTPSkinObjectUser32Control() : CXTPSkinObjectUser32Control
  • CXTPSliderPaintManager() : CXTPSliderPaintManager
  • CXTPSmartPtrInternalT() : CXTPSmartPtrInternalT< _TObject >
  • CXTPSortClass() : CXTPSortClass
  • CXTPSpinButtonCtrl() : CXTPSpinButtonCtrl
  • CXTPSplitPath() : CXTPSplitPath
  • CXTPSplitterWnd() : CXTPSplitterWnd
  • CXTPSplitterWndEx() : CXTPSplitterWndEx
  • CXTPSplitterWndTheme() : CXTPSplitterWndTheme
  • CXTPSplitterWndThemeOffice2003() : CXTPSplitterWndThemeOffice2003
  • CXTPSplitterWndThemeOffice2013() : CXTPSplitterWndThemeOffice2013
  • CXTPSplitterWndThemeOfficeXP() : CXTPSplitterWndThemeOfficeXP
  • CXTPSplitterWndThemeResource() : CXTPSplitterWndThemeResource
  • CXTPSplitterWndThemeVisualStudio2010() : CXTPSplitterWndThemeVisualStudio2010
  • CXTPSplitterWndThemeVisualStudio2015() : CXTPSplitterWndThemeVisualStudio2015
  • CXTPSplitterWndThemeVisualStudio2017() : CXTPSplitterWndThemeVisualStudio2017
  • CXTPSplitterWndThemeVisualStudio2019() : CXTPSplitterWndThemeVisualStudio2019
  • CXTPSplitterWndThemeVisualStudio2022() : CXTPSplitterWndThemeVisualStudio2022
  • CXTPStatusBar() : CXTPStatusBar
  • CXTPStatusBarPane() : CXTPStatusBarPane
  • CXTPStatusBarProgressPane() : CXTPStatusBarProgressPane
  • CXTPStatusBarScrollBarPane() : CXTPStatusBarScrollBarPane
  • CXTPStatusBarSliderPane() : CXTPStatusBarSliderPane
  • CXTPStatusBarSwitchPane() : CXTPStatusBarSwitchPane
  • CXTPStatusBarThemeNativeWindows10() : CXTPStatusBarThemeNativeWindows10
  • CXTPStatusBarThemeNativeWindows11() : CXTPStatusBarThemeNativeWindows11
  • CXTPStatusBarThemeOffice2013() : CXTPStatusBarThemeOffice2013
  • CXTPStatusBarThemeVisualStudio2015() : CXTPStatusBarThemeVisualStudio2015
  • CXTPStatusBarThemeVisualStudio2017() : CXTPStatusBarThemeVisualStudio2017
  • CXTPStatusBarThemeVisualStudio2019() : CXTPStatusBarThemeVisualStudio2019
  • CXTPStatusBarThemeVisualStudio2022() : CXTPStatusBarThemeVisualStudio2022
  • CXTPStickerBase() : CXTPStickerBase
  • CXTPSubscriptionList() : CXTPSubscriptionList< Observable, Observer >
  • CXTPSvgImage() : CXTPSvgImage
  • CXTPSyntaxEditAutoCompleteWnd() : CXTPSyntaxEditAutoCompleteWnd
  • CXTPSyntaxEditBufferCommand() : CXTPSyntaxEditBufferCommand
  • CXTPSyntaxEditBufferKeepOverwriteSettings() : CXTPSyntaxEditBufferCommand::CXTPSyntaxEditBufferKeepOverwriteSettings
  • CXTPSyntaxEditBufferManager() : CXTPSyntaxEditBufferManager
  • CXTPSyntaxEditColorComboBox() : CXTPSyntaxEditColorComboBox
  • CXTPSyntaxEditColorInfo() : CXTPSyntaxEditColorInfo
  • CXTPSyntaxEditColorInfoArray() : CXTPSyntaxEditColorInfoArray
  • CXTPSyntaxEditColorSampleText() : CXTPSyntaxEditColorSampleText
  • CXTPSyntaxEditColorTheme() : CXTPSyntaxEditColorTheme
  • CXTPSyntaxEditColorThemesManager() : CXTPSyntaxEditColorThemesManager
  • CXTPSyntaxEditCommand() : CXTPSyntaxEditCommand
  • CXTPSyntaxEditConfigurationManager() : CXTPSyntaxEditConfigurationManager
  • CXTPSyntaxEditCtrl() : CXTPSyntaxEditCtrl
  • CXTPSyntaxEditDeleteStringCommand() : CXTPSyntaxEditDeleteStringCommand
  • CXTPSyntaxEditDoc() : CXTPSyntaxEditDoc
  • CXTPSyntaxEditDrawTextProcessor() : CXTPSyntaxEditDrawTextProcessor
  • CXTPSyntaxEditFileChangesMonitor() : CXTPSyntaxEditFileChangesMonitor
  • CXTPSyntaxEditFindReplaceDlg() : CXTPSyntaxEditFindReplaceDlg
  • CXTPSyntaxEditGoToLineDlg() : CXTPSyntaxEditGoToLineDlg
  • CXTPSyntaxEditInsertStringCommand() : CXTPSyntaxEditInsertStringCommand
  • CXTPSyntaxEditLexClass() : CXTPSyntaxEditLexClass
  • CXTPSyntaxEditLexOnScreenParseCnt() : CXTPSyntaxEditLexOnScreenParseCnt
  • CXTPSyntaxEditLexParser() : CXTPSyntaxEditLexParser
  • CXTPSyntaxEditLexParserSchemaOptions() : CXTPSyntaxEditLexParserSchemaOptions
  • CXTPSyntaxEditLexTextBlock() : CXTPSyntaxEditLexTextBlock
  • CXTPSyntaxEditLexTextSchema() : CXTPSyntaxEditLexTextSchema
  • CXTPSyntaxEditLexTokensDef() : CXTPSyntaxEditLexTokensDef
  • CXTPSyntaxEditLexVariable() : CXTPSyntaxEditLexVariable
  • CXTPSyntaxEditLexVariant() : CXTPSyntaxEditLexVariant
  • CXTPSyntaxEditLineMarksManager() : CXTPSyntaxEditLineMarksManager
  • CXTPSyntaxEditPaintManager() : CXTPSyntaxEditPaintManager
  • CXTPSyntaxEditPropertiesDlg() : CXTPSyntaxEditPropertiesDlg
  • CXTPSyntaxEditPropertiesPageColor() : CXTPSyntaxEditPropertiesPageColor
  • CXTPSyntaxEditPropertiesPageEdit() : CXTPSyntaxEditPropertiesPageEdit
  • CXTPSyntaxEditPropertiesPageFont() : CXTPSyntaxEditPropertiesPageFont
  • CXTPSyntaxEditReplaceStringCommand() : CXTPSyntaxEditReplaceStringCommand
  • CXTPSyntaxEditSelection() : CXTPSyntaxEditSelection
  • CXTPSyntaxEditStringsManager() : CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager
  • CXTPSyntaxEditTextIterator() : CXTPSyntaxEditTextIterator
  • CXTPSyntaxEditTextSchemesManager() : CXTPSyntaxEditTextSchemesManager
  • CXTPSyntaxEditTipListBox() : CXTPSyntaxEditTipListBox
  • CXTPSyntaxEditTipWnd() : CXTPSyntaxEditTipWnd
  • CXTPSyntaxEditToolTipCtrl() : CXTPSyntaxEditToolTipCtrl
  • CXTPSyntaxEditUndoRedoManager() : CXTPSyntaxEditUndoRedoManager
  • CXTPSyntaxEditView() : CXTPSyntaxEditView
  • CXTPSyntaxEditViewPrintOptions() : CXTPSyntaxEditViewPrintOptions
  • CXTPSystemMetrics() : CXTPSystemMetrics
  • CXTPTabBase() : CXTPTabBase
  • CXTPTabBaseTheme() : CXTPTabBaseTheme
  • CXTPTabBaseThemeOffice2003() : CXTPTabBaseThemeOffice2003
  • CXTPTabBaseThemeOfficeXP() : CXTPTabBaseThemeOfficeXP
  • CXTPTabClientContext() : CXTPTabClientContext
  • CXTPTabClientSticker() : CXTPTabClientSticker
  • CXTPTabClientWnd() : CXTPTabClientWnd
  • CXTPTabColorSetVisualStudio2008() : CXTPTabColorSetVisualStudio2008
  • CXTPTabColorSetVisualStudio2010() : CXTPTabColorSetVisualStudio2010
  • CXTPTabControl() : CXTPTabControl
  • CXTPTabCtrl() : CXTPTabCtrl
  • CXTPTabExBase() : CXTPTabExBase
  • CXTPTabManager() : CXTPTabManager
  • CXTPTabManagerItem() : CXTPTabManagerItem
  • CXTPTabManagerNavigateButton() : CXTPTabManagerNavigateButton
  • CXTPTabManagerNavigateButtons() : CXTPTabManagerNavigateButtons
  • CXTPTabPaintManager() : CXTPTabPaintManager
  • CXTPTabPaintManagerColorSet() : CXTPTabPaintManagerColorSet
  • CXTPTabPaintManagerTheme() : CXTPTabPaintManagerTheme
  • CXTPTabThemeExcel2003() : CXTPTabThemeExcel2003
  • CXTPTabThemeFlat() : CXTPTabThemeFlat
  • CXTPTabThemeNativeWindows10() : CXTPTabThemeNativeWindows10
  • CXTPTabThemeNativeWindows11() : CXTPTabThemeNativeWindows11
  • CXTPTabThemeOffice2000() : CXTPTabThemeOffice2000
  • CXTPTabThemeOffice2013() : CXTPTabThemeOffice2013
  • CXTPTabThemeVisualStudio2003() : CXTPTabThemeVisualStudio2003
  • CXTPTabThemeVisualStudio2010() : CXTPTabThemeVisualStudio2010
  • CXTPTabThemeVisualStudio2015() : CXTPTabThemeVisualStudio2015
  • CXTPTabThemeVisualStudio2017() : CXTPTabThemeVisualStudio2017
  • CXTPTabThemeVisualStudio2019() : CXTPTabThemeVisualStudio2019
  • CXTPTabThemeVisualStudio2022() : CXTPTabThemeVisualStudio2022
  • CXTPTabToolBar() : CXTPTabToolBar
  • CXTPTabView() : CXTPTabView
  • CXTPTagCloudCtrl() : CXTPTagCloudCtrl
  • CXTPTagCloudStyle() : CXTPTagCloudStyle
  • CXTPTaskDialog() : CXTPTaskDialog
  • CXTPTaskDialogLinkCtrl() : CXTPTaskDialogLinkCtrl
  • CXTPTaskPanel() : CXTPTaskPanel
  • CXTPTaskPanelExplorerTheme() : CXTPTaskPanelExplorerTheme
  • CXTPTaskPanelExplorerThemePlain() : CXTPTaskPanelExplorerThemePlain
  • CXTPTaskPanelGroup() : CXTPTaskPanelGroup
  • CXTPTaskPanelGroupItem() : CXTPTaskPanelGroupItem
  • CXTPTaskPanelGroupItems() : CXTPTaskPanelGroupItems
  • CXTPTaskPanelGroups() : CXTPTaskPanelGroups
  • CXTPTaskPanelItem() : CXTPTaskPanelItem
  • CXTPTaskPanelItems() : CXTPTaskPanelItems
  • CXTPTaskPanelListViewOffice2003Theme() : CXTPTaskPanelListViewOffice2003Theme
  • CXTPTaskPanelListViewOfficeXPTheme() : CXTPTaskPanelListViewOfficeXPTheme
  • CXTPTaskPanelListViewTheme() : CXTPTaskPanelListViewTheme
  • CXTPTaskPanelNativeWindows10Theme() : CXTPTaskPanelNativeWindows10Theme
  • CXTPTaskPanelNativeWindows11Theme() : CXTPTaskPanelNativeWindows11Theme
  • CXTPTaskPanelOffice2003Theme() : CXTPTaskPanelOffice2003Theme
  • CXTPTaskPanelOffice2003ThemePlain() : CXTPTaskPanelOffice2003ThemePlain
  • CXTPTaskPanelOffice2013Theme() : CXTPTaskPanelOffice2013Theme
  • CXTPTaskPanelOfficeXPThemePlain() : CXTPTaskPanelOfficeXPThemePlain
  • CXTPTaskPanelPaintManager() : CXTPTaskPanelPaintManager
  • CXTPTaskPanelPaintManagerPlain() : CXTPTaskPanelPaintManagerPlain
  • CXTPTaskPanelScrollButton() : CXTPTaskPanelScrollButton
  • CXTPTaskPanelShortcutBarOffice2003Theme() : CXTPTaskPanelShortcutBarOffice2003Theme
  • CXTPTaskPanelShortcutBarOffice2007Theme() : CXTPTaskPanelShortcutBarOffice2007Theme
  • CXTPTaskPanelToolboxTheme() : CXTPTaskPanelToolboxTheme
  • CXTPTaskPanelVisualStudio2005Theme() : CXTPTaskPanelVisualStudio2005Theme
  • CXTPTaskPanelVisualStudio2010Theme() : CXTPTaskPanelVisualStudio2010Theme
  • CXTPTaskPanelVisualStudio2012Theme() : CXTPTaskPanelVisualStudio2012Theme
  • CXTPTaskPanelVisualStudio2015Theme() : CXTPTaskPanelVisualStudio2015Theme
  • CXTPTaskPanelVisualStudio2017Theme() : CXTPTaskPanelVisualStudio2017Theme
  • CXTPTaskPanelVisualStudio2019Theme() : CXTPTaskPanelVisualStudio2019Theme
  • CXTPTaskPanelVisualStudio2022Theme() : CXTPTaskPanelVisualStudio2022Theme
  • CXTPTcbItem() : CXTPTcbItem
  • CXTPTearOffFrame() : CXTPTearOffFrame
  • CXTPTempColorMask() : CXTPTempColorMask
  • CXTPThreadLocal() : CXTPThreadLocal< T >
  • CXTPTimeEdit() : CXTPTimeEdit
  • CXTPTipOfTheDay() : CXTPTipOfTheDay
  • CXTPTipWindow() : CXTPTipWindow
  • CXTPToolBar() : CXTPToolBar
  • CXTPToolTipContext() : CXTPToolTipContext
  • CXTPToolTipContextToolTip() : CXTPToolTipContextToolTip
  • CXTPTrackBlock() : CXTPTrackBlock
  • CXTPTrackControl() : CXTPTrackControl
  • CXTPTrackControlItem() : CXTPTrackControlItem
  • CXTPTrackHeader() : CXTPTrackHeader
  • CXTPTrackKey() : CXTPTrackKey
  • CXTPTrackMarker() : CXTPTrackMarker
  • CXTPTrackMarkers() : CXTPTrackMarkers
  • CXTPTrackPaintManager() : CXTPTrackPaintManager
  • CXTPTrackSelectedBlocks() : CXTPTrackSelectedBlocks
  • CXTPTrackThemeDefault() : CXTPTrackThemeDefault
  • CXTPTrackThemeExplorer() : CXTPTrackThemeExplorer
  • CXTPTrackThemeNativeWindows10() : CXTPTrackThemeNativeWindows10
  • CXTPTrackThemeNativeWindows11() : CXTPTrackThemeNativeWindows11
  • CXTPTrackThemeOffice2003() : CXTPTrackThemeOffice2003
  • CXTPTrackThemeOffice2003Luna() : CXTPTrackThemeOffice2003Luna
  • CXTPTrackThemeOffice2013() : CXTPTrackThemeOffice2013
  • CXTPTrackThemeOfficeXP() : CXTPTrackThemeOfficeXP
  • CXTPTrackThemeResource() : CXTPTrackThemeResource
  • CXTPTrackThemeVisualStudio2012Blue() : CXTPTrackThemeVisualStudio2012Blue
  • CXTPTrackThemeVisualStudio2012Dark() : CXTPTrackThemeVisualStudio2012Dark
  • CXTPTrackThemeVisualStudio2012Light() : CXTPTrackThemeVisualStudio2012Light
  • CXTPTrackThemeVisualStudio2015() : CXTPTrackThemeVisualStudio2015
  • CXTPTrackThemeVisualStudio2017() : CXTPTrackThemeVisualStudio2017
  • CXTPTrackThemeVisualStudio2019() : CXTPTrackThemeVisualStudio2019
  • CXTPTrackThemeVisualStudio2022() : CXTPTrackThemeVisualStudio2022
  • CXTPTrackUndoAddBlockCommand() : CXTPTrackUndoAddBlockCommand
  • CXTPTrackUndoAddMarkerCommand() : CXTPTrackUndoAddMarkerCommand
  • CXTPTrackUndoCommand() : CXTPTrackUndoCommand
  • CXTPTrackUndoDeleteBlockCommand() : CXTPTrackUndoDeleteBlockCommand
  • CXTPTrackUndoDeleteMarkerCommand() : CXTPTrackUndoDeleteMarkerCommand
  • CXTPTrackUndoGroupCommand() : CXTPTrackUndoGroupCommand
  • CXTPTrackUndoManager() : CXTPTrackUndoManager
  • CXTPTrackUndoSetBlockPositionCommand() : CXTPTrackUndoSetBlockPositionCommand
  • CXTPTrackUndoSetMarkerPositionCommand() : CXTPTrackUndoSetMarkerPositionCommand
  • CXTPTransparentBitmap() : CXTPTransparentBitmap
  • CXTPTrayIcon() : CXTPTrayIcon
  • CXTPTreeBase() : CXTPTreeBase
  • CXTPTreeCtrl() : CXTPTreeCtrl
  • CXTPTreeNativeWindows10Theme() : CXTPTreeNativeWindows10Theme
  • CXTPTreeNativeWindows11Theme() : CXTPTreeNativeWindows11Theme
  • CXTPTreeOffice2013Theme() : CXTPTreeOffice2013Theme
  • CXTPTreeTheme() : CXTPTreeTheme
  • CXTPTreeView() : CXTPTreeView
  • CXTPTreeVisualStudio2012Theme() : CXTPTreeVisualStudio2012Theme
  • CXTPTreeVisualStudio2015Theme() : CXTPTreeVisualStudio2015Theme
  • CXTPTreeVisualStudio2017Theme() : CXTPTreeVisualStudio2017Theme
  • CXTPTreeVisualStudio2019Theme() : CXTPTreeVisualStudio2019Theme
  • CXTPTreeVisualStudio2022Theme() : CXTPTreeVisualStudio2022Theme
  • CXTPVisualStudio2005Theme() : CXTPVisualStudio2005Theme
  • CXTPVisualStudio2008Theme() : CXTPVisualStudio2008Theme
  • CXTPVisualStudio2010Theme() : CXTPVisualStudio2010Theme
  • CXTPWebBrowserCtrl() : CXTPWebBrowserCtrl
  • CXTPWebBrowserProvider() : CXTPWebBrowserProvider
  • CXTPWebViewProvider() : CXTPWebViewProvider
  • CXTPWinApp() : CXTPWinApp
  • CXTPWindowList() : CXTPWindowList
  • CXTPWindowPos() : CXTPWindowPos
  • CXTPWindowRect() : CXTPWindowRect
  • CXTPWinThemeWrapper() : CXTPWinThemeWrapper
  • CXTPWinThread() : CXTPWinThread


Toolkit Pro: Class Members - Functions

Here is a list of all documented functions with links to the class documentation for each member:

- d -

  • DataBind() : CXTPGridDataManager
  • DataProviderTypeFromConStr() : CXTPCalendarControl, CXTPCalendarData
  • DataSourceFromConStr() : CXTPCalendarControl, CXTPCalendarData
  • DayView_IsAutoResetBusyFlag() : CXTPCalendarControl
  • DayView_SetAutoResetBusyFlag() : CXTPCalendarControl
  • DECLARE_DYNAMIC() : CXTPMDIFrameWndEx
  • DECLARE_DYNCREATE() : CXTPFrameWnd, CXTPMDIFrameWnd
  • DECLARE_MESSAGE_MAP() : CXTPSyntaxEditPropertiesDlg
  • DecreaseIndent() : CXTPSyntaxEditCtrl
  • Default() : CXTPHookManager
  • DefaultAnimation() : CXTPAnimationDC
  • Defer() : CXTPResize, CXTPTabExBase
  • DeflateEditRect() : CXTPControlComboBox, CXTPControlEdit
  • DeflateRect() : CXTPMarqueeCtrlPaintManager, CXTPMarqueeCtrlThemeFlat, CXTPMarqueeCtrlThemeNativeWindows, CXTPMarqueeCtrlThemeNativeWinXP, CXTPProgressCtrlPaintManager, CXTPProgressCtrlThemeFlat, CXTPProgressCtrlThemeNativeWindows, CXTPProgressCtrlThemeNativeWinXP, CXTPRectT< T >
  • Degree2Radian() : CXTPMathUtils
  • DelayLayout() : CXTPCommandBar
  • DelayLayoutParent() : CXTPControl
  • DelayRecalcFrameLayout() : CXTPCommandBarsFrameHook
  • DelayRedraw() : CXTPCommandBar, CXTPPopupBar
  • DelayRedrawParent() : CXTPControl
  • Delete() : CXTPGridRecord
  • DeleteAllItems() : CXTPExcelTabCtrl, CXTPTabManager
  • DeleteBookmark() : CXTPSyntaxEditCtrl
  • DeleteBreakpoint() : CXTPSyntaxEditCtrl
  • DeleteBuffer() : CXTPSyntaxEditCtrl
  • DeleteChar() : CXTPSyntaxEditCtrl
  • DeleteCharAt() : CXTPMaskEditT< TBase >
  • DeleteColor() : CXTPSyntaxEditColorComboBox
  • DeleteCustomValue() : CXTPCalendarViewPartCustomizableValueT< _TValue >
  • DeleteEvent() : CXTPCalendarData
  • DeleteGridRecords() : CXTPGridDataManager
  • DeleteImageList() : CXTPImageList
  • DeleteItem() : CXTPCalendarEventColorListBox, CXTPControlComboBox, CXTPEditListBox, CXTPExcelTabCtrl, CXTPTabManager
  • DeleteKey() : CXTPRegistryManager
  • DeleteLineMark() : CXTPSyntaxEditLineMarksManager
  • DeleteObject() : CXTPGdiObject
  • DeletePane() : CXTPDockingPane, CXTPDockingPaneBase, CXTPDockingPaneSplitterContainer
  • DeletePaneColorSets() : CXTPDockingPaneVisualStudio2012Theme
  • DeleteRecord() : CXTPGridDataManager
  • DeleteSelectedLines() : CXTPSyntaxEditCtrl
  • DeleteSelection() : CXTPSyntaxEditCtrl
  • DeleteStandardValue() : CXTPCalendarViewPartCustomizableValueT< _TValue >
  • DeleteText() : CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager, CXTPSyntaxEditBufferManager
  • DeleteToolBar() : CXTPReBar
  • DeleteValue() : CXTPRegistryManager
  • DeleteView() : CXTPTabExBase
  • DepthTest() : CXTPChart3dDeviceContext
  • Deselect() : CXTPDatePickerControl
  • DeselectBlock() : CXTPGridSelectedRows
  • Destroy() : CXTPSingletonPointer
  • DestroyAll() : CXTPDockingPaneManager
  • DestroyBorder() : CXTPGridRecordItem
  • DestroyDockingStickers() : CXTPDockingPaneContext
  • DestroyItem() : CXTPPropertyGridInplaceEdit, CXTPPropertyGridInplaceList
  • DestroyMetrics() : CXTPSkinManagerMetrics
  • DestroyPane() : CXTPDockingPaneManager
  • DestroyWindow() : CXTPPopupBar, CXTPTearOffFrame
  • Detach() : CXTPCalendarRemindersDialog, CXTPDockingPane, CXTPImageList, CXTPImageManagerIconHandle, CXTPSmartPtrInternalT< _TObject >, CXTPTabClientWnd
  • DetermineRTL() : CXTPHeaderCtrl
  • DirectDraw() : CXTPImageManagerIcon, CXTPImageManagerVectorImageHandle, CXTPSvgImage
  • Disable() : CXTPGridSubListControl
  • DisableBitmap() : CXTPImageManager
  • DisableColumnSizing() : CXTPListBase
  • DisableDraggingContents() : CXTPTabClientContext
  • DisableDwm() : CXTPCommandBarsFrameHook
  • DisableFrameTheme() : CXTPCommandBarsFrameHook
  • DisableLunaColors() : CXTPColorManager, CXTPTabPaintManager
  • DisableScrollbars() : IXTPScrollable
  • DisableShadow() : CXTPCommandBarsFrameHook, CXTPFrameShadowManager, CXTPPopupBar
  • DisableShortcuts() : CXTPShortcutManager
  • DisableTabContextWindow() : CXTPTabClientContext
  • DisableTabFocusRect() : CXTPTabClientContext
  • DisableTabSticker() : CXTPTabClientContext
  • Discard() : CXTPMemFile
  • Dismiss() : CXTPCalendarReminder, CXTPCalendarRemindersManager
  • DismissAll() : CXTPCalendarRemindersManager
  • DisplayShadow() : CXTPColorPopup
  • DispPosToStrPos() : CXTPSyntaxEditDrawTextProcessor
  • DistanceToPoint() : CXTPChartDiagram2DAxisView
  • DoAction() : CXTPTreeBase
  • DoAutoIndentIfNeed() : CXTPSyntaxEditCtrl
  • DoAutoVertScrollIfNeed() : CXTPGridControl
  • DoBanding() : CXTPTreeBase
  • DoChangeSelectionCase() : CXTPSyntaxEditCtrl
  • DoChangeSelectionTabify() : CXTPSyntaxEditCtrl
  • DockCommandBar() : CXTPCommandBars
  • DockPane() : CXTPDockingPaneManager
  • DockRightOf() : CXTPCommandBarsSiteBase< TBase >
  • DockSidePane() : CXTPDockingPaneManager
  • DoCommonPropExchange() : CXTPFlowGraphNode
  • DoCreate_Event() : CXTPCalendarCustomDataProvider, CXTPCalendarData, CXTPCalendarDatabaseDataProvider, CXTPCalendarMemoryDataProvider
  • DoCreate_RPattern() : CXTPCalendarCustomDataProvider, CXTPCalendarData, CXTPCalendarDatabaseDataProvider, CXTPCalendarMemoryDataProvider
  • DoCustomDragOver() : CXTPControl, CXTPControlCustom, CXTPControlOleItems, CXTPControlPopup, CXTPControlRecentFileList, CXTPControlToolbars, CXTPControlWindowList, CXTPRibbonControlSystemRecentFileList
  • DoDelete_Event() : CXTPCalendarCustomDataProvider, CXTPCalendarData, CXTPCalendarDatabaseDataProvider, CXTPCalendarMemoryDataProvider
  • DoDelete_RPattern() : CXTPCalendarCustomDataProvider, CXTPCalendarData, CXTPCalendarDatabaseDataProvider, CXTPCalendarMemoryDataProvider
  • DoDeleteEvent() : CXTPCalendarControl
  • DoDeleteSelectedEvents() : CXTPCalendarControl
  • DoDeleteText() : CXTPSyntaxEditBufferCommand
  • DoDestroy() : CXTPCalendarThemeCustomizableXValueT< _TValue, _TValueRef >, CXTPCalendarThemeStringValue
  • DoDropDown() : CXTPButton
  • DoesFontExist() : CXTPFontEnum
  • DoExchangeCfg() : CXTPCalendarResourcesManager
  • DoGetAllEvents_raw() : CXTPCalendarCustomDataProvider, CXTPCalendarData, CXTPCalendarDatabaseDataProvider, CXTPCalendarMemoryDataProvider
  • DoGetUpcomingEvents() : CXTPCalendarCustomDataProvider, CXTPCalendarData, CXTPCalendarDatabaseDataProvider, CXTPCalendarMemoryDataProvider
  • DoInsertText() : CXTPSyntaxEditBufferCommand
  • DoModal() : CXTPBrowseDialog, CXTPCustomizeSheet, CXTPPropertySheet, CXTPTaskDialog
  • DoPaint() : CXTPProgressCtrl, CXTPTreeBase
  • DoPreSelection() : CXTPTreeBase
  • DoPropExchange() : CXTPCalendarCustomProperties, CXTPCalendarEvent, CXTPCalendarEventCategoryIDs, CXTPCalendarIconIDs, CXTPCalendarMemoryDataProvider, CXTPCalendarOptions, CXTPCalendarRecurrencePattern, CXTPCalendarSchedules, CXTPCalendarThemeBOOLValue, CXTPCalendarThemeCustomizableXValueT< _TValue, _TValueRef >, CXTPCalendarThemeIntValue, CXTPCalendarThemeRectValue, CXTPCalendarThemeStringValue, CXTPCalendarUIntArray, CXTPChart3dFunnelSeriesStyle, CXTPChart3dPieSeriesStyle, CXTPChart3dPyramidSeriesStyle, CXTPChartAppearance, CXTPChartAreaSeriesStyle, CXTPChartAxis, CXTPChartAxisAppearance, CXTPChartAxisConstantLine, CXTPChartAxisConstantLines, CXTPChartAxisCustomLabel, CXTPChartAxisCustomLabels, CXTPChartAxisGridLines, CXTPChartAxisLabel, CXTPChartAxisRange, CXTPChartAxisStrip, CXTPChartAxisStrips, CXTPChartAxisTickMarks, CXTPChartAxisTitle, CXTPChartBarSeriesLabel, CXTPChartBarSeriesStyle, CXTPChartBorder, CXTPChartBubbleSeriesStyle, CXTPChartContent, CXTPChartContentAppearance, CXTPChartDiagram2D, CXTPChartDiagram2DAppearance, CXTPChartDiagram2DSeriesLabel, CXTPChartDiagram2DSeriesStyle, CXTPChartDiagram3DAppearance, CXTPChartDiagram, CXTPChartElement, CXTPChartFastLineSeriesStyle, CXTPChartFillStyle, CXTPChartFinanceStyleAppearance, CXTPChartFunnelSeriesLabelBase, CXTPChartFunnelSeriesStyleBase, CXTPChartGanttSeriesStyle, CXTPChartLegend, CXTPChartLegendAppearance, CXTPChartLineSeriesStyle, CXTPChartMarker, CXTPChartNumberFormat, CXTPChartPalette, CXTPChartPanel, CXTPChartPanelCollection, CXTPChartPieSeriesLabelBase, CXTPChartPieSeriesStyleBase, CXTPChartPieStyleAppearance, CXTPChartPointSeriesLabel, CXTPChartPointSeriesStyle, CXTPChartPyramidSeriesLabelBase, CXTPChartPyramidSeriesStyleBase, CXTPChartRadarAreaSeriesStyle, CXTPChartRadarDiagram, CXTPChartRadarDiagramSeriesStyle, CXTPChartRadarLineSeriesStyle, CXTPChartRadarPointSeriesLabel, CXTPChartRadarPointSeriesStyle, CXTPChartRangeAreaSeriesLabel, CXTPChartRangeBarSeriesLabel, CXTPChartRangeBarSeriesStyle, CXTPChartSeries, CXTPChartSeriesCollection, CXTPChartSeriesLabel, CXTPChartSeriesPoint, CXTPChartSeriesPointCollection, CXTPChartSeriesStyle, CXTPChartStackedBarSeriesStyle, CXTPChartStepAreaSeriesStyle, CXTPChartStepLineSeriesStyle, CXTPChartTitle, CXTPChartTitleAppearance, CXTPChartTitleCollection, CXTPCommandBar, CXTPCommandBars, CXTPCommandBarsOptions, CXTPControl, CXTPControlAction, CXTPControlActions, CXTPControlButton, CXTPControlButtonColor, CXTPControlComboBox, CXTPControlComboBoxList, CXTPControlCustom, CXTPControlEdit, CXTPControlFontComboBoxList, CXTPControlGallery, CXTPControlListBox, CXTPControlPopup, CXTPControlProgress, CXTPControls, CXTPControlSelector, CXTPControlStatic, CXTPDockingPane, CXTPDockingPaneAutoHidePanel, CXTPDockingPaneBase, CXTPDockingPaneLayout, CXTPDockingPaneManager, CXTPDockingPaneMiniWnd, CXTPDockingPaneSidePanel, CXTPDockingPaneSplitterContainer, CXTPDockingPaneTabbedContainer, CXTPDockState, CXTPFlowGraphConnection, CXTPFlowGraphConnectionPoint, CXTPFlowGraphConnectionPoints, CXTPFlowGraphConnections, CXTPFlowGraphControl, CXTPFlowGraphNode, CXTPFlowGraphNodeCustom, CXTPFlowGraphNodes, CXTPFlowGraphPage, CXTPFlowGraphPages, CXTPGridColumn, CXTPGridColumnOrder, CXTPGridColumns, CXTPGridControl, CXTPGridHeader, CXTPGridHyperlink, CXTPGridHyperlinks, CXTPGridRecord, CXTPGridRecordItem, CXTPGridRecordItemButton, CXTPGridRecordItemControl, CXTPGridRecordItemControls, CXTPGridRecordItemDateTime, CXTPGridRecordItemNumber, CXTPGridRecordItemPreview, CXTPGridRecordItemText, CXTPGridRecordItemVariant, CXTPGridRecords, CXTPImageManager, CXTPMenuBar, CXTPPopupBar, CXTPRibbonControlTab, CXTPRibbonGroup, CXTPRibbonGroups, CXTPRibbonTab, CXTPShortcutManager, CXTPStatusBar, CXTPTaskPanelGroup, CXTPTaskPanelGroupItem, CXTPTaskPanelItem, CXTPTaskPanelItems, CXTPToolBar, CXTPTrackBlock, CXTPTrackControl, CXTPTrackControlItem, CXTPTrackMarker, CXTPTrackMarkers
  • DoPX_Value() : CXTPCalendarThemeBOOLValue, CXTPCalendarThemeIntValue, CXTPCalendarThemeRectValue, CXTPCalendarThemeStringValue
  • DoRead_Event() : CXTPCalendarCustomDataProvider, CXTPCalendarData, CXTPCalendarDatabaseDataProvider, CXTPCalendarMemoryDataProvider
  • DoRead_RPattern() : CXTPCalendarCustomDataProvider, CXTPCalendarData, CXTPCalendarDatabaseDataProvider, CXTPCalendarMemoryDataProvider
  • DoRedo() : CXTPSyntaxEditUndoRedoManager
  • DoRemoveAllEvents() : CXTPCalendarCustomDataProvider, CXTPCalendarData, CXTPCalendarDatabaseDataProvider, CXTPCalendarMemoryDataProvider
  • DoReplaceText() : CXTPSyntaxEditReplaceStringCommand
  • DoRetrieveDayEvents() : CXTPCalendarCustomDataProvider, CXTPCalendarData, CXTPCalendarDatabaseDataProvider, CXTPCalendarMemoryDataProvider
  • DoSlideStep() : CXTPDockingPaneMiniWnd, CXTPDockingPaneSidePanel
  • DoubleClickOpen() : CXTPShellSettings
  • DoubleToString() : CXTPPropertyGridItemDouble
  • DoUndo() : CXTPSyntaxEditUndoRedoManager
  • DoUndoRedo() : CXTPSyntaxEditCtrl
  • DoUpdate_Event() : CXTPCalendarCustomDataProvider, CXTPCalendarData, CXTPCalendarDatabaseDataProvider, CXTPCalendarMemoryDataProvider
  • DoUpdate_RPattern() : CXTPCalendarCustomDataProvider, CXTPCalendarData, CXTPCalendarDatabaseDataProvider, CXTPCalendarMemoryDataProvider
  • DoUpdateCustomizeMenuControl() : CXTPToolBar
  • Drag() : CXTPDockingPaneContext
  • Dragging() : CXTPGridSubListControl
  • Draw() : CXTPCalendarCaptionBarTheme, CXTPCalendarCaptionBarThemePart, CXTPCalendarDayView, CXTPCalendarDayViewDay, CXTPCalendarDayViewEvent, CXTPCalendarDayViewGroup, CXTPCalendarDayViewTimeScale, CXTPCalendarMonthView::CMonthViewGrid, CXTPCalendarMonthView, CXTPCalendarMonthViewDay, CXTPCalendarMonthViewEvent, CXTPCalendarTimeLineView, CXTPCalendarTimeLineViewEvent, CXTPCalendarTimeLineViewGroup, CXTPCalendarTimeLineViewPart, CXTPCalendarTimeLineViewTimeScale, CXTPCalendarTimeLineViewTimeScalePart, CXTPCalendarView, CXTPCalendarViewDay, CXTPCalendarViewEvent, CXTPCalendarViewGroup, CXTPCalendarWeekView, CXTPCalendarWeekViewDay, CXTPCalendarWeekViewEvent, CXTPCheckboxButtonPart, CXTPCheckListBox::CCheckListState, CXTPControl, CXTPControlBitmap, CXTPControlButtonColor, CXTPControlColorSelector, CXTPControlCustom, CXTPControlGalleryItem, CXTPControlHyperlink, CXTPControlListBox, CXTPControlMarkupLabel, CXTPControlProgress, CXTPControlSelector, CXTPControlStatic, CXTPControlTabWorkspace, CXTPDateLabelPart, CXTPDatePickerItemDay, CXTPDatePickerItemMonth, CXTPExpandButtonPart, CXTPFlowGraphNode, CXTPGridGroupRow, CXTPGridHeader, CXTPGridRecordItem, CXTPGridRow, CXTPGridSection, CXTPGridSections, CXTPImageList, CXTPImageManagerIcon, CXTPImageManagerIconHandle, CXTPImageManagerImageList, CXTPImageManagerResource, CXTPImageManagerVectorImageHandle, CXTPPopupItem, CXTPProgressCtrlPaintManager, CXTPProgressCtrlThemeOffice2013, CXTPProgressCtrlThemeResource, CXTPRadioButtonPart, CXTPRibbonControlSystemButton, CXTPRibbonControlSystemPopupBarButton, CXTPRibbonControlSystemPopupBarListCaption, CXTPRibbonControlSystemPopupBarListItem, CXTPRibbonControlSystemPopupBarPinableListItem, CXTPRibbonControlTab, CXTPRibbonGroup, CXTPScrollDateButtonPart, CXTPSkinObjectFrame::CCaptionButton, CXTPSvgImage, CXTPSwitchViewButtonPart, CXTPSyntaxEditCtrl, CXTPTabManagerNavigateButton, CXTPTrackBlock, CXTPTrackControlItem, CXTPTrackHeader, CXTPTrackKey, IXTPPreview
  • Draw2() : CXTPCalendarDayView, CXTPCalendarMonthView, CXTPCalendarTimeLineView, CXTPCalendarView, CXTPCalendarWeekView
  • Draw3dRect() : CXTPPaintManager
  • DrawAlphaBitmap() : CXTPImageManagerIcon
  • DrawArrowGlyph() : CXTPScrollBarPaintManager, CXTPSpinButtonCtrl
  • DrawArrows() : CXTPScrollBarPaintManager, CXTPScrollBarThemeFlat, CXTPScrollBarThemeOffice2000, CXTPScrollBarThemeOffice2013, CXTPScrollBarThemeResource, CXTPScrollBarThemeVisualStudio2012
  • DrawAutoHidePanel() : CXTPDockingPaneNativeWindows10Theme, CXTPDockingPaneNativeWindows11Theme, CXTPDockingPaneOffice2013Theme, CXTPDockingPanePaintManager, CXTPDockingPaneVisualStudio2012Theme, CXTPDockingPaneVisualStudio2015Theme, CXTPDockingPaneVisualStudio2017Theme, CXTPDockingPaneVisualStudio2019Theme, CXTPDockingPaneVisualStudio2022Theme
  • DrawBackground() : CXTPComboBoxTheme, CXTPComboBoxThemeOffice2000, CXTPComboBoxThemeOffice2003, CXTPComboBoxThemeOffice2013, CXTPComboBoxThemeOfficeXPFlat, CXTPDatePickerPaintManager, CXTPDatePickerThemeOffice2013, CXTPMarqueeCtrlPaintManager, CXTPMarqueeCtrlThemeResource, CXTPPopupPaintManager, CXTPPopupThemeMSN, CXTPPopupThemeOffice2000, CXTPPopupThemeOffice2003, CXTPPopupThemeOfficeXP, CXTPScrollBarPaintManager, CXTPScrollBarThemeOffice2013, CXTPScrollBarThemeResource, CXTPScrollBarThemeVisualStudio2012, CXTPToolTipContextToolTip
  • DrawBackImage() : CXTPRibbonOffice2013Theme
  • DrawBigHourCell() : CXTPCalendarPaintManager
  • DrawBitmap() : CXTPCalendarPaintManager, CXTPGridPaintManager
  • DrawBorder() : CXTPCalendarPaintManager, CXTPColorSelectorCtrlThemeOffice2013, CXTPDatePickerPaintManager, CXTPDatePickerThemeOffice2013, CXTPTabBaseTheme, CXTPTabBaseThemeOffice2003, CXTPTabBaseThemeOfficeXP
  • DrawBorders() : CXTPCalendarCaptionBarTheme, CXTPTabBaseTheme, CXTPTabBaseThemeOfficeXP
  • DrawBuddyBorders() : CXTPEdit, CXTPEditTheme, CXTPEditThemeDefault, CXTPEditThemeOffice2000, CXTPEditThemeOfficeXP, CXTPEditThemeResource
  • DrawBusyStatus() : CXTPCalendarPaintManager
  • DrawButton() : CXTPButtonTheme, CXTPComboBoxTheme, CXTPComboBoxThemeNativeWindows10, CXTPComboBoxThemeNativeWindows11, CXTPComboBoxThemeOffice2000, CXTPComboBoxThemeOffice2003, CXTPComboBoxThemeOffice2013, CXTPComboBoxThemeOfficeXPFlat, CXTPComboBoxThemeVisualStudio2012, CXTPComboBoxThemeVisualStudio2015, CXTPComboBoxThemeVisualStudio2017, CXTPComboBoxThemeVisualStudio2019, CXTPComboBoxThemeVisualStudio2022, CXTPDatePickerPaintManager, CXTPDatePickerThemeOffice2003, CXTPDatePickerThemeOffice2013, CXTPDatePickerThemeResource, CXTPExcelTabCtrlTheme, CXTPExcelTabCtrlThemeOffice2013, CXTPMessageBar, CXTPPopupPaintManager, CXTPTabBaseTheme, CXTPTabBaseThemeOfficeXP, CXTPTaskButtonTheme, CXTPTaskButtonThemeExpando
  • DrawButtonBack() : CXTPExcelTabCtrlTheme, CXTPExcelTabCtrlThemeOffice2003, CXTPExcelTabCtrlThemeOffice2013, CXTPExcelTabCtrlThemeOfficeXP
  • DrawButtonBackground() : CXTPButtonTheme, CXTPButtonThemeFlat, CXTPButtonThemeOffice2000, CXTPButtonThemeOffice2003, CXTPButtonThemeOffice2013, CXTPButtonThemeOfficeXP, CXTPButtonThemeResource, CXTPButtonThemeUltraFlat, CXTPButtonThemeVisualStudio2012, CXTPCaptionButtonTheme, CXTPCaptionButtonThemeOffice2003, CXTPCaptionButtonThemeOfficeXP
  • DrawButtons() : CXTPDatePickerControl, CXTPMessageBar, CXTPScrollBarPaintManager, CXTPScrollBarThemeFlat, CXTPScrollBarThemeOffice2000, CXTPScrollBarThemeOffice2013, CXTPScrollBarThemeResource, CXTPScrollBarThemeVisualStudio2012, CXTPScrollBarThemeWindowsClassic, CXTPScrollBarThemeWindowsUx
  • DrawButtonText() : CXTPButtonTheme, CXTPCaptionButtonTheme, CXTPCaptionButtonThemeOfficeXP
  • DrawButtonTriangle() : CXTPComboBoxTheme, CXTPComboBoxThemeOffice2013
  • DrawButtonVisualStyleBackground() : CXTPButtonTheme
  • DrawCaption() : CXTPDockingPaneDefaultTheme, CXTPDockingPaneGripperedTheme, CXTPDockingPaneOffice2002VisioTheme, CXTPDockingPaneOffice2003Theme, CXTPDockingPaneOffice2007OutlookTheme, CXTPDockingPaneOffice2007Theme, CXTPDockingPaneOffice2007WordTheme, CXTPDockingPaneOffice2013Theme, CXTPDockingPanePaintManager, CXTPDockingPaneVisualStudio2012Theme, CXTPDockingPaneWinNativeTheme
  • DrawCaptionBack() : CXTPCaption, CXTPCaptionTheme, CXTPCaptionThemeOffice2003, CXTPCaptionThemeOfficeXP
  • DrawCaptionBar() : CXTPFramePaintManager, CXTPFrameThemeOffice2007System
  • DrawCaptionButton() : CXTPDockingPaneOffice2013Theme, CXTPDockingPanePaintManager, CXTPDockingPaneVisualStudio2012Theme
  • DrawCaptionButtonEntry() : CXTPDockingPanePaintManager
  • DrawCaptionButtons() : CXTPDockingPanePaintManager
  • DrawCaptionGripper() : CXTPTaskPanelExplorerThemePlain, CXTPTaskPanelPaintManager
  • DrawCaptionGripperBitmap() : CXTPTaskPanelPaintManager
  • DrawCaptionGripperSigns() : CXTPTaskPanelPaintManager
  • DrawCaptionIcon() : CXTPCaption, CXTPCaptionTheme
  • DrawCaptionPart() : CXTPDockingPaneDefaultTheme, CXTPDockingPaneGripperedTheme, CXTPDockingPaneOffice2003Theme, CXTPDockingPaneOffice2007WordTheme, CXTPDockingPaneVisualStudio2003Theme, CXTPDockingPaneVisualStudio6Theme, CXTPDockingPaneWinExplorerTheme, CXTPDockingPaneWinNativeTheme
  • DrawCaptionText() : CXTPCaption, CXTPCaptionTheme, CXTPDockingPanePaintManager, CXTPFramePaintManager, CXTPTaskPanelItem
  • DrawCategoryCaptionBackground() : CXTPPropertyGridPaintManager, CXTPPropertyGridVisualStudio2005Theme
  • DrawCell() : CXTPColorHex::CRgnCell
  • DrawCheckBox() : CXTPGridRecordItem, CXTPPropertyGridPaintManager
  • DrawCheckBoxMark() : CXTPButtonTheme, CXTPButtonThemeOffice2013, CXTPButtonThemeResource, CXTPButtonThemeUltraFlat, CXTPButtonThemeVisualStudio2012
  • DrawCheckMark() : CXTPPaintManager, CXTPPropertyGridOffice2007Theme, CXTPPropertyGridPaintManager
  • DrawCheckRect() : CXTPCommandBarsNativeWindows10Theme, CXTPCommandBarsNativeWindows11Theme, CXTPCommandBarsVisualStudio2015Theme, CXTPCommandBarsVisualStudio2017Theme, CXTPCommandBarsVisualStudio2019Theme, CXTPCommandBarsVisualStudio2022Theme
  • DrawChunk() : CXTPMarqueeCtrlPaintManager, CXTPMarqueeCtrlThemeResource
  • DrawClock() : CXTPCalendarPaintManager
  • DrawCloseButton() : CXTPDockingPaneCaptionButton
  • DrawCollapsed() : CXTPCalendarEventCategoryComboBox
  • DrawCollapsedBitmap() : CXTPGridPaintManager, CXTPGridThemeOffice2013, CXTPGridThemeResource, CXTPTrackThemeResource
  • DrawCollapsedTextMarks() : CXTPSyntaxEditPaintManager
  • DrawColor() : CXTPColorSelectorCtrlThemeOffice2013, CXTPEyeDropper
  • DrawColorCell() : CXTPColorSelectorCtrlTheme, CXTPColorSelectorCtrlThemeOffice2013, CXTPColorSelectorCtrlThemeVisualStudio2015
  • DrawColorSelector() : CXTPColorSelectorCtrl, CXTPColorSelectorCtrlTheme, CXTPColorSelectorCtrlThemeOffice2013
  • DrawColumn() : CXTPGridPaintManager, CXTPGridThemeOffice2003, CXTPTrackThemeOffice2003
  • DrawColumnBackground() : CXTPGridPaintManager, CXTPGridThemeDefault, CXTPGridThemeExplorer, CXTPGridThemeOffice2003, CXTPGridThemeOffice2003Luna, CXTPGridThemeOffice2013, CXTPGridThemeOfficeXP, CXTPGridThemeResource, CXTPTrackThemeDefault, CXTPTrackThemeExplorer, CXTPTrackThemeOffice2003, CXTPTrackThemeOffice2003Luna, CXTPTrackThemeOffice2013, CXTPTrackThemeOfficeXP, CXTPTrackThemeResource
  • DrawColumnFooter() : CXTPGridPaintManager
  • DrawColumnFooterDivider() : CXTPGridPaintManager, CXTPGridThemeOffice2003Luna, CXTPGridThemeResource, CXTPTrackThemeOffice2003Luna, CXTPTrackThemeResource
  • DrawColumnIcon() : CXTPGridPaintManager
  • DrawColumnText() : CXTPGridPaintManager, CXTPGridThemeOffice2013, CXTPGridThemeResource, CXTPTrackThemeOffice2013, CXTPTrackThemeResource
  • DrawComboBox() : CXTPComboBoxTheme, CXTPComboBoxThemeDefault, CXTPComboBoxThemeResource
  • DrawComboExpandMark() : CXTPPaintManager
  • DrawCommandBar() : CXTPCommandBar, CXTPControlComboBoxList, CXTPPopupBar, CXTPRibbonBar, CXTPRibbonTabPopupToolBar, CXTPTabToolBar
  • DrawCommandBarGripper() : CXTPCommandBarsNativeWindows10Theme, CXTPCommandBarsNativeWindows11Theme, CXTPCommandBarsNativeXPTheme, CXTPCommandBarsOffice2000Theme, CXTPCommandBarsOffice2003Theme, CXTPCommandBarsOffice2013Theme, CXTPCommandBarsOfficeXPTheme, CXTPCommandBarsVisualStudio2012Theme, CXTPCommandBarsVisualStudio2015Theme, CXTPCommandBarsVisualStudio2017Theme, CXTPCommandBarsVisualStudio2019Theme, CXTPCommandBarsVisualStudio2022Theme, CXTPPaintManager, CXTPRibbonTheme
  • DrawCommandBarGroupSeparator() : CXTPCommandBarsOffice2013Theme, CXTPPaintManager
  • DrawCommandBarSeparator() : CXTPCommandBarsNativeXPTheme, CXTPCommandBarsOffice2000Theme, CXTPCommandBarsOffice2003Theme, CXTPCommandBarsOffice2013Theme, CXTPCommandBarsOfficeXPTheme, CXTPCommandBarsVisualStudio2012Theme, CXTPPaintManager, CXTPRibbonTheme, CXTPVisualStudio2008Theme, CXTPVisualStudio2010Theme
  • DrawConnection() : CXTPFlowGraphPaintManager
  • DrawConnectionPoints() : CXTPFlowGraphNode
  • DrawConnector() : CXTPGridPaintManager
  • DrawContent() : CXTPChartContent, CXTPMessageBar
  • DrawControl() : CXTPPaintManager
  • DrawControlBackground() : CXTPFlowGraphPaintManager
  • DrawControlCheckBoxMark() : CXTPCommandBarsOffice2013Theme, CXTPCommandBarsOfficeXPTheme, CXTPCommandBarsVisualStudio2012Theme, CXTPPaintManager
  • DrawControlComboBox() : CXTPCommandBarsNativeWindows10Theme, CXTPCommandBarsNativeWindows11Theme, CXTPCommandBarsOffice2000Theme, CXTPCommandBarsOffice2013Theme, CXTPCommandBarsOfficeXPTheme, CXTPCommandBarsVisualStudio2012Theme, CXTPCommandBarsVisualStudio2015Theme, CXTPCommandBarsVisualStudio2017Theme, CXTPCommandBarsVisualStudio2019Theme, CXTPCommandBarsVisualStudio2022Theme, CXTPPaintManager, CXTPRibbonTheme
  • DrawControlComboBoxButton() : CXTPCommandBarsNativeXPTheme, CXTPCommandBarsOffice2000Theme
  • DrawControlEdit() : CXTPCommandBarsOffice2000Theme, CXTPCommandBarsOffice2013Theme, CXTPCommandBarsOfficeXPTheme, CXTPPaintManager, CXTPRibbonTheme
  • DrawControlEditFrame() : CXTPCommandBarsNativeXPTheme, CXTPCommandBarsOffice2000Theme
  • DrawControlEditSpin() : CXTPCommandBarsNativeXPTheme, CXTPCommandBarsOffice2000Theme
  • DrawControlEntry() : CXTPCommandBarsNativeXPTheme, CXTPPaintManager, CXTPRibbonTheme
  • DrawControlGroupOption() : CXTPRibbonMarkupTheme, CXTPRibbonPaintManager, CXTPRibbonThemeResource
  • DrawControlGroupPopup() : CXTPRibbonMarkupTheme, CXTPRibbonPaintManager, CXTPRibbonThemeResource
  • DrawControlMDIButton() : CXTPCommandBarsNativeXPTheme, CXTPCommandBarsOffice2013Theme, CXTPPaintManager
  • DrawControlPopupGlyph() : CXTPRibbonTheme
  • DrawControlPopupParent() : CXTPCommandBarsOffice2000Theme, CXTPCommandBarsOfficeXPTheme, CXTPPaintManager
  • DrawControlRadioButtonMark() : CXTPCommandBarsOffice2013Theme, CXTPCommandBarsOfficeXPTheme, CXTPPaintManager
  • DrawControlText() : CXTPPaintManager
  • DrawControlToolBarParent() : CXTPPaintManager
  • DrawCrossHair() : CXTPColorWnd
  • DrawDarkThemeExpander() : CXTPTreeBase
  • DrawDateHeader() : CXTPCalendarControlView
  • DrawDay() : CXTPDatePickerPaintManager, CXTPDatePickerThemeOffice2013
  • DrawDayHeader() : CXTPCalendarPaintManager
  • DrawDaysOfWeek() : CXTPDatePickerPaintManager, CXTPDatePickerThemeOffice2013
  • DrawDialogBarGripper() : CXTPCommandBarsNativeXPTheme, CXTPCommandBarsOffice2000Theme, CXTPCommandBarsOffice2003Theme, CXTPCommandBarsOfficeXPTheme, CXTPPaintManager
  • DrawDottedLine() : CXTPDockingPaneVisualStudio2012Theme
  • DrawDragArrow() : CXTPTaskPanelPaintManager
  • DrawDropDownGlyph() : CXTPCommandBarsOffice2013Theme, CXTPCommandBarsVisualStudio2012Theme, CXTPPaintManager
  • DrawDropper() : CXTPEyeDropper
  • DrawDwmCaptionText() : CXTPRibbonPaintManager
  • DrawEditText() : CXTPControlComboBox, CXTPControlEdit
  • DrawEntry() : CXTPTabManagerNavigateButton, CXTPToolTipContextToolTip
  • DrawEvent() : CXTPCalendarPaintManager, CXTPCalendarTimeLineViewPart
  • DrawEvents() : CXTPCalendarDayViewDay
  • DrawExpandButton() : CXTPPropertyGridNativeWindows10Theme, CXTPPropertyGridNativeWindows11Theme, CXTPPropertyGridOffice2007Theme, CXTPPropertyGridOffice2013Theme, CXTPPropertyGridPaintManager, CXTPPropertyGridVisualStudio2005Theme, CXTPPropertyGridVisualStudio2010Theme, CXTPPropertyGridVisualStudio2012Theme, CXTPPropertyGridVisualStudio2015Theme, CXTPPropertyGridVisualStudio2017Theme, CXTPPropertyGridVisualStudio2019Theme, CXTPPropertyGridVisualStudio2022Theme, CXTPShortcutBarOffice2013Theme, CXTPShortcutBarPaintManager, CXTPShortcutBarResourceTheme
  • DrawExpanded() : CXTPCalendarEventCategoryComboBox
  • DrawExpandGlyph() : CXTPCommandBarsOffice2013Theme, CXTPCommandBarsVisualStudio2012Theme, CXTPPaintManager
  • DrawExpandSigns() : CXTPCalendarPaintManager
  • DrawFlat() : CXTPSpinButtonCtrl
  • DrawFlatButton() : CXTPSpinButtonCtrl
  • DrawFloatingFrame() : CXTPDockingPaneDefaultTheme, CXTPDockingPaneGripperedTheme, CXTPDockingPaneOffice2002VisioTheme, CXTPDockingPaneOffice2003Theme, CXTPDockingPaneOffice2013Theme, CXTPDockingPanePaintManager, CXTPDockingPaneVisualStudio2010Theme, CXTPDockingPaneVisualStudio2012Theme, CXTPDockingPaneWinNativeTheme
  • DrawFocusedRow() : CXTPGridPaintManager, CXTPGridThemeOffice2013, CXTPTrackThemeOffice2013
  • DrawFocusRect() : CXTPButtonTheme, CXTPDockingPaneContext, CXTPTaskPanel, CXTPTaskPanelPaintManager
  • DrawFooter() : CXTPGridHeader
  • DrawFrame() : CXTPComboBoxTheme, CXTPEditTheme, CXTPFramePaintManager, CXTPRibbonMarkupFrameTheme
  • DrawFrameBorder() : CXTPCommandBarsOffice2013Theme, CXTPRibbonMarkupFrameTheme
  • DrawFrameCaptionButton() : CXTPFramePaintManager, CXTPFrameThemeOffice2007System
  • DrawFreezeColsDivider() : CXTPGridPaintManager
  • DrawGalleryItemBack() : CXTPCommandBarsNativeWindows10Theme, CXTPCommandBarsNativeWindows11Theme, CXTPCommandBarsOffice2013Theme, CXTPCommandBarsVisualStudio2015Theme, CXTPCommandBarsVisualStudio2017Theme, CXTPCommandBarsVisualStudio2019Theme, CXTPCommandBarsVisualStudio2022Theme, CXTPPaintManager
  • DrawGlyph() : CXTPGridPaintManager, CXTPGridThemeExplorer, CXTPTrackThemeExplorer
  • DrawGrid() : CXTPGridPaintManager
  • DrawGridPattern() : CXTPGridPaintManager
  • DrawGripper() : CXTPDockingPaneVisualStudio2012Theme, CXTPExcelTabCtrl, CXTPExcelTabCtrlTheme, CXTPExcelTabCtrlThemeOffice2013, CXTPScrollBarPaintManager, CXTPScrollBarThemeFlat, CXTPScrollBarThemeOffice2013, CXTPScrollBarThemeResource, CXTPScrollBarThemeVisualStudio2012, CXTPScrollBarThemeWindowsClassic, CXTPScrollBarThemeWindowsUx, CXTPShortcutBarOffice2000Theme, CXTPShortcutBarOffice2003Theme, CXTPShortcutBarOffice2013Theme, CXTPShortcutBarOfficeXPTheme, CXTPShortcutBarPaintManager, CXTPShortcutBarResourceTheme
  • DrawGroup() : CXTPCalendarPaintManager, CXTPRibbonMarkupTheme, CXTPRibbonPaintManager, CXTPRibbonThemeResource
  • DrawGroupBox() : CXTPButtonTheme, CXTPButtonThemeOffice2013, CXTPButtonThemeUltraFlat
  • DrawGroupByControl() : CXTPGridHeader
  • DrawGroupCaption() : CXTPTaskPanelPaintManager, CXTPTaskPanelPaintManagerPlain, CXTPTaskPanelToolboxTheme
  • DrawGroupCaptionBackground() : CXTPTaskPanelListViewOffice2003Theme, CXTPTaskPanelShortcutBarOffice2003Theme, CXTPTaskPanelShortcutBarOffice2007Theme, CXTPTaskPanelToolboxTheme, CXTPTaskPanelVisualStudio2005Theme, CXTPTaskPanelVisualStudio2010Theme, CXTPTaskPanelVisualStudio2012Theme
  • DrawGroupClient() : CXTPTaskPanelPaintManager
  • DrawGroupClientFace() : CXTPTaskPanelPaintManager, CXTPTaskPanelPaintManagerPlain, CXTPTaskPanelShortcutBarOffice2003Theme, CXTPTaskPanelShortcutBarOffice2007Theme, CXTPTaskPanelVisualStudio2005Theme, CXTPTaskPanelVisualStudio2010Theme, CXTPTaskPanelVisualStudio2012Theme
  • DrawGroupClientItems() : CXTPTaskPanelPaintManager
  • DrawGroupItem() : CXTPTaskPanelPaintManager
  • DrawGroupItemFrame() : CXTPTaskPanelPaintManager, CXTPTaskPanelShortcutBarOffice2007Theme, CXTPTaskPanelVisualStudio2012Theme
  • DrawGroupItemImage() : CXTPTaskPanelPaintManager
  • DrawGroupItemImageWithText() : CXTPTaskPanelPaintManager
  • DrawGroupItemImageWithTextBelow() : CXTPTaskPanelPaintManager
  • DrawGroupRow() : CXTPGridPaintManager, CXTPGridThemeOffice2013, CXTPTrackThemeOffice2013
  • DrawHeader() : CXTPCalendarOffice2013Theme, CXTPCalendarPaintManager, CXTPCalendarTimeLineViewTimeScalePart, CXTPHeaderCtrlTheme
  • DrawHiddenGlyph() : CXTPCommandBarsOffice2013Theme, CXTPCommandBarsVisualStudio2012Theme, CXTPPaintManager
  • DrawHorizontalLine() : CXTPCalendarPaintManager, CXTPGridPaintManager
  • DrawHourCell() : CXTPCalendarPaintManager
  • DrawIcon() : CXTPDockingPaneAutoHidePanel, CXTPDockingPaneTabbedContainer, CXTPRibbonControlTab, CXTPTabControl, CXTPTabManager, CXTPTabToolBar
  • DrawIconChar() : CXTPCalendarPaintManager
  • DrawIconComposited() : CXTPImageManagerIcon
  • DrawIcons() : CXTPCalendarPaintManager
  • DrawImage() : CXTPButton, CXTPCommandBarsOffice2000Theme, CXTPCommandBarsOfficeXPTheme, CXTPPaintManager, CXTPResourceImage, CXTPShortcutBarOffice2000Theme, CXTPShortcutBarOffice2003Theme, CXTPShortcutBarOfficeXPTheme, CXTPShortcutBarPaintManager, CXTPShortcutListBoxTheme, CXTPShortcutListBoxThemeOffice2003, CXTPShortcutListBoxThemeOfficeXP, CXTPSkinImage, CXTPTabManagerItem
  • DrawImageFlipped() : CXTPResourceImage
  • DrawImagePart() : CXTPResourceImage
  • DrawIndirect() : CXTPImageList
  • DrawInplaceButton() : CXTPGridPaintManager
  • DrawInplaceButtonFrame() : CXTPGridPaintManager
  • DrawInplaceButtonIcon() : CXTPGridPaintManager
  • DrawInplaceButtons() : CXTPPropertyGridPaintManager
  • DrawInplaceComboButton() : CXTPGridPaintManager
  • DrawInplaceExpandButton() : CXTPGridPaintManager
  • DrawInplaceListItem() : CXTPPropertyGridPaintManager
  • DrawInplaceSpinButton() : CXTPGridPaintManager
  • DrawItem() : CXTPCalendarBusyStatusComboBox, CXTPCalendarEventCategoryComboBox, CXTPCalendarEventLabelComboBox, CXTPControlComboBoxList, CXTPListBoxTheme, CXTPListBoxThemeDefault, CXTPListBoxThemeOffice2003, CXTPListBoxThemeOffice2013, CXTPListBoxThemeOfficeXP, CXTPListBoxThemeResource, CXTPPopupPaintManager, CXTPPropertyGridCoolTheme, CXTPPropertyGridDelphiTheme, CXTPPropertyGridPaintManager, CXTPPropertyGridSimpleTheme, CXTPShortcutListBoxTheme, CXTPTreeBase
  • DrawItemBitmap() : CXTPGridPaintManager
  • DrawItemCaption() : CXTPGridPaintManager, CXTPPropertyGridPaintManager, CXTPTaskPanelPaintManager, CXTPTaskPanelVisualStudio2012Theme
  • DrawItemControl() : CXTPGridPaintManager
  • DrawItemIcon() : CXTPPopupPaintManager
  • DrawItemImage() : CXTPTaskPanelPaintManager
  • DrawItems() : CXTPControlGallery
  • DrawItemText() : CXTPListBoxTheme
  • DrawItemValue() : CXTPPropertyGridPaintManager
  • DrawKeyboardTip() : CXTPRibbonTheme
  • DrawLabel() : CXTPControlGalleryPaintManager, CXTPControlGalleryResourceTheme
  • DrawLine() : CXTPCalendarPaintManager
  • DrawLine_CenterLR() : CXTPCalendarViewPart
  • DrawLineCalcSel() : CXTPSyntaxEditPaintManager
  • DrawLineEx() : CXTPCalendarViewPart
  • DrawLineMark() : CXTPSyntaxEditPaintManager
  • DrawLineMarks() : CXTPSyntaxEditPaintManager
  • DrawLineNode() : CXTPSyntaxEditPaintManager
  • DrawLineNodeBackground() : CXTPSyntaxEditPaintManager
  • DrawLineNumber() : CXTPSyntaxEditPaintManager
  • DrawLineNumbersBorder() : CXTPSyntaxEditPaintManager
  • DrawLineTextEx() : CXTPSyntaxEditPaintManager
  • DrawLink() : CXTPGridPaintManager
  • DrawListBoxControl() : CXTPCommandBarsOffice2000Theme, CXTPCommandBarsOfficeXPTheme, CXTPPaintManager
  • DrawLuminanceBar() : CXTPColorLum
  • DrawMarkers() : CXTPTrackPaintManager
  • DrawMarkupItem() : CXTPMarkupTreeCtrl
  • DrawMarquee() : CXTPMarqueeCtrlPaintManager, CXTPMarqueeCtrlThemeFlat
  • DrawMaximizeRestoreButton() : CXTPDockingPaneCaptionButton
  • DrawMenuButton() : CXTPDockingPaneCaptionButton
  • DrawMessageBarButton() : CXTPMessageBarPaintManager, CXTPMessageBarThemeOffice2010, CXTPMessageBarThemeOffice2013
  • DrawMono() : CXTPImageManagerIcon
  • DrawMonthHeader() : CXTPDatePickerPaintManager, CXTPDatePickerThemeOffice2000
  • DrawMultiLineText() : CXTPGridPaintManager
  • DrawNavigateButton() : CXTPTabPaintManager
  • DrawNavigationItem() : CXTPShortcutBarPaintManager
  • DrawNcBorders() : CXTPEditTheme, CXTPEditThemeDefault, CXTPEditThemeOffice2000, CXTPEditThemeOfficeXP, CXTPListBoxTheme, CXTPListBoxThemeOffice2013, CXTPProgressCtrl, CXTPProgressCtrlPaintManager, CXTPProgressCtrlThemeOffice2000, CXTPProgressCtrlThemeOffice2003, CXTPProgressCtrlThemeOffice2013, CXTPProgressCtrlThemeOfficeXP
  • DrawNcBordersDefault() : CXTPEditThemeDefault
  • DrawNcScrollBack() : CXTPEditTheme, CXTPEditThemeDefault
  • DrawNodeGroup() : CXTPFlowGraphPaintManager
  • DrawNoGroupByText() : CXTPGridPaintManager, CXTPGridThemeResource, CXTPTrackThemeResource
  • DrawNoItems() : CXTPGridControl
  • DrawNowLine() : CXTPCalendarPaintManager
  • DrawOffice2007() : CXTPSpinButtonCtrl
  • DrawPane() : CXTPDockingPaneOffice2002VisioTheme, CXTPDockingPaneOffice2007WordTheme, CXTPDockingPaneOffice2013Theme, CXTPDockingPanePaintManager, CXTPDockingPaneVisualStudio2012Theme
  • DrawPaneCaption() : CXTPShortcutBarOffice2003Theme, CXTPShortcutBarPaintManager, CXTPShortcutBarResourceTheme
  • DrawPaneEntry() : CXTPStatusBar
  • DrawPaneItemCaption() : CXTPShortcutBarNativeWindows10Theme, CXTPShortcutBarNativeWindows11Theme, CXTPShortcutBarOffice2003Theme, CXTPShortcutBarOffice2013Theme, CXTPShortcutBarPaintManager, CXTPShortcutBarResourceTheme, CXTPShortcutBarVisualStudio2015Theme, CXTPShortcutBarVisualStudio2017Theme, CXTPShortcutBarVisualStudio2019Theme, CXTPShortcutBarVisualStudio2022Theme
  • DrawParentBackground() : CXTPTabManager
  • DrawPinButton() : CXTPDockingPaneCaptionButton
  • DrawPopupBarCheckMark() : CXTPCommandBarsNativeXPTheme, CXTPPaintManager, CXTPRibbonTheme
  • DrawPopupBarGripper() : CXTPCommandBarsNativeXPTheme, CXTPCommandBarsOffice2003Theme, CXTPCommandBarsOffice2013Theme, CXTPCommandBarsOfficeXPTheme, CXTPCommandBarsVisualStudio2012Theme, CXTPPaintManager, CXTPRibbonTheme, CXTPVisualStudio2008Theme, CXTPVisualStudio2010Theme
  • DrawPopupBarRadioMark() : CXTPCommandBarsNativeXPTheme, CXTPPaintManager, CXTPRibbonTheme
  • DrawPopupResizeGripper() : CXTPCommandBarsOffice2000Theme, CXTPCommandBarsOfficeXPTheme, CXTPPaintManager, CXTPRibbonTheme
  • DrawPopupScrollBar() : CXTPControlGalleryOffice2013Theme, CXTPControlGalleryPaintManager, CXTPControlGalleryResourceTheme
  • DrawProgress() : CXTPProgressPaintManager, CXTPProgressThemeOffice2013
  • DrawPropertyGridBorder() : CXTPPropertyGridPaintManager
  • DrawPushButtonDropDown() : CXTPButtonTheme, CXTPButtonThemeOffice2013
  • DrawPushButtonIcon() : CXTPButtonTheme, CXTPButtonThemeOffice2013
  • DrawPushButtonText() : CXTPButtonTheme, CXTPButtonThemeOffice2013
  • DrawQuickAccessControl() : CXTPRibbonOffice2013Theme, CXTPRibbonPaintManager
  • DrawRadioButtonMark() : CXTPButtonTheme, CXTPButtonThemeOffice2013, CXTPButtonThemeResource, CXTPButtonThemeUltraFlat, CXTPButtonThemeVisualStudio2012
  • DrawRadioMark() : CXTPPropertyGridOffice2007Theme, CXTPPropertyGridPaintManager
  • DrawRectangle() : CXTPCommandBarsNativeWindows10Theme, CXTPCommandBarsNativeWindows11Theme, CXTPCommandBarsNativeXPTheme, CXTPCommandBarsOffice2000Theme, CXTPCommandBarsOffice2003Theme, CXTPCommandBarsOffice2013Theme, CXTPCommandBarsOfficeXPTheme, CXTPCommandBarsVisualStudio2012Theme, CXTPCommandBarsVisualStudio2015Theme, CXTPCommandBarsVisualStudio2017Theme, CXTPCommandBarsVisualStudio2019Theme, CXTPCommandBarsVisualStudio2022Theme, CXTPPaintManager, CXTPRibbonTheme, CXTPVisualStudio2008Theme, CXTPVisualStudio2010Theme
  • DrawReverted() : CXTPImageManager
  • DrawRibbonApplicationIcon() : CXTPRibbonPaintManager
  • DrawRibbonFrameCaption() : CXTPRibbonMarkupTheme, CXTPRibbonOffice2013Theme, CXTPRibbonPaintManager, CXTPRibbonThemeResource
  • DrawRibbonFrameCaptionBar() : CXTPRibbonMarkupTheme, CXTPRibbonOffice2013Theme, CXTPRibbonPaintManager, CXTPRibbonThemeResource
  • DrawRibbonFrameContextHeaders() : CXTPRibbonMarkupTheme, CXTPRibbonOffice2013Theme, CXTPRibbonPaintManager, CXTPRibbonThemeNativeWindows10, CXTPRibbonThemeNativeWindows11, CXTPRibbonThemeResource
  • DrawRibbonFramePart() : CXTPCommandBarsFrameHook, CXTPRibbonPaintManager
  • DrawRibbonFrameSystemButton() : CXTPRibbonMarkupTheme, CXTPRibbonOffice2013Theme, CXTPRibbonPaintManager, CXTPRibbonThemeResource
  • DrawRibbonGroupControlEntry() : CXTPRibbonMarkupTheme, CXTPRibbonPaintManager, CXTPRibbonThemeResource
  • DrawRibbonGroupPopupToolBar() : CXTPRibbonMarkupTheme, CXTPRibbonPaintManager
  • DrawRibbonQuickAccessButton() : CXTPRibbonMarkupTheme, CXTPRibbonPaintManager, CXTPRibbonThemeOffice2007System, CXTPRibbonThemeResource
  • DrawRibbonQuickAccessControls() : CXTPRibbonMarkupTheme, CXTPRibbonThemeOffice2007System, CXTPRibbonThemeResource
  • DrawRibbonQuickAccessMoreButton() : CXTPRibbonMarkupTheme, CXTPRibbonPaintManager, CXTPRibbonThemeResource
  • DrawRibbonScrollButton() : CXTPRibbonMarkupTheme, CXTPRibbonPaintManager, CXTPRibbonThemeResource
  • DrawRibbonTab() : CXTPRibbonMarkupTheme, CXTPRibbonOffice2013Theme, CXTPRibbonPaintManager, CXTPRibbonThemeNativeWindows10, CXTPRibbonThemeNativeWindows11, CXTPRibbonThemeResource
  • DrawRowNumber() : CXTPGridPaintManager
  • DrawRowPart() : CXTPSyntaxEditDrawTextProcessor
  • DrawRows() : CXTPGridControl, CXTPTrackControl
  • DrawScrollBar() : CXTPScrollBarPaintManager, CXTPScrollBarThemeOffice2013, CXTPScrollBarThemeResource, CXTPScrollBarThemeVisualStudio2012, CXTPScrollBarThemeVisualStudio2015, CXTPScrollBarThemeVisualStudio2017, CXTPScrollBarThemeVisualStudio2019, CXTPScrollBarThemeVisualStudio2022, CXTPSliderPaintManager
  • DrawScrollButton() : CXTPTaskPanelPaintManager
  • DrawScrollTriangle() : CXTPDatePickerPaintManager
  • DrawSectionDivider() : CXTPGridPaintManager, CXTPGridThemeExplorer, CXTPGridThemeOffice2003, CXTPGridThemeOffice2003Luna, CXTPGridThemeResource, CXTPTrackThemeExplorer, CXTPTrackThemeOffice2003, CXTPTrackThemeOffice2003Luna, CXTPTrackThemeResource
  • DrawSelection() : CXTPColorHex::CRgnCell
  • DrawSelectionRect() : CXTPFlowGraphNode
  • DrawShadow() : CXTPCalendarPaintManager
  • DrawShadowRect() : CXTPTipWindow
  • DrawShadowRectPart() : CXTPCalendarShadowDrawer
  • DrawShellIcon() : CXTPGridPaintManager
  • DrawShortcutBarFrame() : CXTPShortcutBarOffice2000Theme, CXTPShortcutBarOffice2003Theme, CXTPShortcutBarOfficeXPTheme, CXTPShortcutBarPaintManager
  • DrawShortcutItem() : CXTPShortcutBarPaintManager
  • DrawSidePanel() : CXTPDockingPaneDefaultTheme, CXTPDockingPaneOffice2003Theme, CXTPDockingPaneOffice2013Theme, CXTPDockingPanePaintManager, CXTPDockingPaneVisualStudio2012Theme, CXTPDockingPaneWinNativeTheme
  • DrawSingleButton() : CAppearanceSetPropertyPage2003, CAppearanceSetPropertyPage2007, CAppearanceSetPropertyPageAccess2007, CAppearanceSetPropertyPageFlat, CAppearanceSetPropertyPageSelected, CAppearanceSetStateButtons, CAppearanceSetVisio, CAppearanceSetVisualStudio2005, CXTPDockingPanePanelTheme2012, CXTPDockingPaneTabTheme2012, CXTPDockingPaneTabTheme2013, CXTPDockingPaneTabTheme2015, CXTPDockingPaneTabTheme2017, CXTPDockingPaneTabTheme2019, CXTPDockingPaneTabTheme2022, CXTPDockingPaneTabThemeNativeWindows10, CXTPDockingPaneTabThemeNativeWindows11, CXTPTabPaintManagerTheme, CXTPTabThemeExcel2003, CXTPTabThemeFlat, CXTPTabThemeOffice2000, CXTPTabThemeVisualStudio2003, CXTPTabThemeVisualStudio2010, CXTPTabThemeVisualStudio2012
  • DrawSingleButtonIconAndText() : CXTPTabPaintManager
  • DrawSingleLineText() : CXTPGridPaintManager
  • DrawSliderArrow() : CXTPColorLum
  • DrawSortArrow() : CXTPHeaderCtrlTheme, CXTPHeaderCtrlThemeExplorer, CXTPHeaderCtrlThemeResource
  • DrawSpecialControl() : CXTPCommandBarsNativeXPTheme, CXTPCommandBarsOffice2000Theme, CXTPCommandBarsOffice2003Theme, CXTPPaintManager, CXTPRibbonTheme
  • DrawSplitButtonFrame() : CXTPCommandBarsNativeWindows10Theme, CXTPCommandBarsNativeWindows11Theme, CXTPCommandBarsNativeXPTheme, CXTPCommandBarsOffice2000Theme, CXTPCommandBarsOffice2013Theme, CXTPCommandBarsOfficeXPTheme, CXTPCommandBarsVisualStudio2012Theme, CXTPCommandBarsVisualStudio2015Theme, CXTPCommandBarsVisualStudio2017Theme, CXTPCommandBarsVisualStudio2019Theme, CXTPCommandBarsVisualStudio2022Theme, CXTPPaintManager, CXTPRibbonTheme
  • DrawSplitButtonPopup() : CXTPRibbonTheme
  • DrawSplitter() : CXTPDockingPaneNativeWindows10Theme, CXTPDockingPaneNativeWindows11Theme, CXTPDockingPaneOffice2013Theme, CXTPDockingPanePaintManager, CXTPDockingPaneVisualStudio2012Theme, CXTPDockingPaneVisualStudio2015Theme, CXTPDockingPaneVisualStudio2017Theme, CXTPDockingPaneVisualStudio2019Theme, CXTPDockingPaneVisualStudio2022Theme, CXTPSplitterWndTheme, CXTPSplitterWndThemeOffice2003, CXTPSplitterWndThemeVisualStudio2010
  • DrawStandard() : CXTPSpinButtonCtrl
  • DrawStatusBarButtonFace() : CXTPStatusBarThemeOffice2013
  • DrawStatusBarGripper() : CXTPRibbonTheme, CXTPStatusBarThemeNativeWindows10, CXTPStatusBarThemeNativeWindows11, CXTPStatusBarThemeOffice2013, CXTPStatusBarThemeVisualStudio2015, CXTPStatusBarThemeVisualStudio2017, CXTPStatusBarThemeVisualStudio2019, CXTPStatusBarThemeVisualStudio2022
  • DrawStatusBarPaneBorder() : CXTPRibbonTheme, CXTPStatusBarThemeOffice2013
  • DrawStatusBarPaneEntry() : CXTPStatusBarThemeOffice2013
  • DrawStatusBarPaneSeparator() : CXTPRibbonTheme, CXTPStatusBarThemeOffice2013
  • DrawStatusBarSwitchPane() : CXTPRibbonTheme, CXTPStatusBarThemeOffice2013
  • DrawStretch() : CXTPStatusBar
  • DrawString() : CXTPGridPaintManager
  • DrawSubj() : CXTPCalendarPaintManager
  • DrawSystemPopupBarButton() : CXTPRibbonMarkupTheme, CXTPRibbonPaintManager, CXTPRibbonThemeResource
  • DrawTab() : CXTPExcelTabCtrlTheme, CXTPExcelTabCtrlThemeOffice2013, CXTPTabBaseTheme
  • DrawTabControl() : CAppearanceSetVisio, CXTPTabPaintManager, CXTPTabPaintManagerTheme
  • DrawTabControlEx() : CXTPTabPaintManager
  • DrawTabCtrl() : CXTPTabBaseTheme
  • DrawTabIcon() : CXTPTabBaseTheme, CXTPTabBaseThemeOfficeXP
  • DrawTabText() : CXTPTabBaseTheme
  • DrawTearOffGripper() : CXTPCommandBarsOffice2000Theme, CXTPCommandBarsOffice2003Theme, CXTPCommandBarsOfficeXPTheme, CXTPPaintManager
  • DrawText() : CXTPCalendarViewPart, CXTPDockingPaneTabTheme2012, CXTPEditListBoxToolBar, CXTPProgressCtrlPaintManager, CXTPShortcutListBoxTheme, CXTPShortcutListBoxThemeOfficeXP, CXTPTabPaintManagerTheme
  • DrawTextLine() : CXTPGridPaintManager
  • DrawTextPathEllipsis() : CXTPTabPaintManager
  • DrawThemeBackground() : CXTPSkinManagerClass, CXTPWinThemeWrapper
  • DrawThemeBackgroundEx() : CXTPWinThemeWrapper
  • DrawThemeEdge() : CXTPWinThemeWrapper
  • DrawThemeIcon() : CXTPWinThemeWrapper
  • DrawThemeParentBackground() : CXTPWinThemeWrapper
  • DrawThemeText() : CXTPSkinManagerClass, CXTPWinThemeWrapper
  • DrawThemeTextEx() : CXTPWinThemeWrapper
  • DrawThumbButton() : CXTPScrollBarPaintManager, CXTPScrollBarThemeFlat, CXTPScrollBarThemeOffice2013, CXTPScrollBarThemeResource, CXTPScrollBarThemeVisualStudio2012, CXTPScrollBarThemeWindowsUx
  • DrawTimeLine() : CXTPTrackPaintManager
  • DrawTimes() : CXTPCalendarPaintManager
  • DrawTip() : CXTPSyntaxEditTipWnd
  • DrawTitleBar() : CXTPDockingPaneNativeWindows10Theme, CXTPDockingPaneNativeWindows11Theme, CXTPDockingPaneOffice2013Theme, CXTPDockingPaneVisualStudio2012Theme, CXTPDockingPaneVisualStudio2015Theme, CXTPDockingPaneVisualStudio2017Theme, CXTPDockingPaneVisualStudio2019Theme, CXTPDockingPaneVisualStudio2022Theme
  • DrawTopmostLayer() : CXTPCalendarDayViewDay
  • DrawTracker() : CXTPScrollBarPaintManager, CXTPScrollBarThemeFlat, CXTPScrollBarThemeResource, CXTPScrollBarThemeWindowsClassic, CXTPScrollBarThemeWindowsUx
  • DrawTrackHeader() : CXTPTrackPaintManager
  • DrawTransparentRectangle() : CXTPFlowGraphPaintManager
  • DrawTreeStructure() : CXTPGridPaintManager
  • DrawTriangle() : CXTPGridPaintManager, CXTPGridThemeExplorer, CXTPGridThemeOffice2013, CXTPGridThemeResource, CXTPTrackThemeExplorer, CXTPTrackThemeOffice2013, CXTPTrackThemeResource
  • DrawVerticalLine() : CXTPCalendarPaintManager, CXTPGridPaintManager
  • DrawVerticalTimeLineMarker() : CXTPGridPaintManager
  • DrawVisualStyle() : CXTPSpinButtonCtrl
  • DrawWatermark() : CXTPGridControl
  • DrawWeekNumbers() : CXTPDatePickerPaintManager, CXTPDatePickerThemeOffice2013
  • DrawWindowContent() : CXTPFlowGraphNode, CXTPFlowGraphNodeCustom
  • DrawWorkspacePart() : CXTPTabPaintManagerTheme, CXTPTabThemeVisualStudio2012
  • Dropped() : CXTPGridSubListControl
  • DumpTraits() : CXTPGaugeBaseType
  • Duplicate() : CXTPControls, CXTPMemFile
  • DuplicateItem() : CXTPShellPidl


Toolkit Pro: Class Members - Functions

Here is a list of all documented functions with links to the class documentation for each member:

- e -

  • EditItem() : CXTPEditListBox, CXTPGridControl
  • EditListItem() : CXTPEditListBox
  • EditOnClick() : CXTPGridControl
  • EditOnDelayClick() : CXTPGridControl
  • EditOnDoubleClick() : CXTPGridControl
  • ElementAt() : CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE >
  • EmptySection() : CXTPPropExchange, CXTPPropExchangeIniFile, CXTPPropExchangeRegistry, CXTPPropExchangeXMLNode
  • EmptyUndoBuffer() : CXTPCalendarView
  • Enable() : CXTPCheckListBox
  • Enable3dEdgeSmoothing() : CXTPChartSeriesStyle
  • EnableActions() : CXTPCommandBars
  • EnableAnimation() : CXTPCommandBar, CXTPShortcutBar, CXTPTaskPanel
  • EnableAutoComplete() : CXTPControlComboBox
  • EnableAutoCompletion() : CXTPComboBox
  • EnableAutoInit() : CXTPShellTreeCtrl
  • EnableAutomaticUpdate() : CXTPGaugeBaseType
  • EnableAutoPreviewActivate() : CXTPPreviewCtrl
  • EnableAutoSize() : CXTPHeaderCtrl
  • EnableBorder() : CXTPSplitterWnd
  • EnableButton() : CXTPTaskDialog
  • EnableButtons() : CXTPExcelTabCtrl
  • EnableCallbackTimer() : CXTPTaskDialog
  • EnableCancellation() : CXTPTaskDialog
  • EnableCaret() : CXTPHexEdit
  • EnableCommandLinks() : CXTPTaskDialog
  • EnableContextMenu() : CXTPShellListBase, CXTPShellTreeBase
  • EnableControls() : CXTPCustomizeKeyboardPage, CXTPSyntaxEditFindReplaceDlg, CXTPSyntaxEditPropertiesPageColor
  • EnableCurrentThread() : CXTPSkinManager
  • EnableCustomFont() : CXTPPaintManagerFont
  • EnableCustomization() : CXTPCommandBar, CXTPCommandBars, CXTPStatusBar
  • EnableDefaultBorderDrawing() : CXTPScrollable< Base >
  • EnableDefaultItemDrawing() : CXTPTreeBase
  • EnableDefaultResetCustomizedToolbarChoice() : CXTPCommandBars
  • EnableDocking() : CXTPCommandBars, CXTPToolBar
  • EnableDotTracker() : CXTPSplitterWnd
  • EnableDoubleBuffer() : CXTPCommandBar
  • EnableDoubleBuffering() : CXTPGridControl
  • EnableDpiBitmapScaling() : CXTPCommandBarsOptions, CXTPHeaderCtrl, CXTPPopupControl, CXTPToolTipContext
  • EnableDpiGalleryItemScaling() : CXTPCommandBarsOptions
  • EnableDragDrop() : CXTPGridControl
  • EnableDraggingContents() : CXTPTabClientContext
  • EnableEdit() : CXTPEditListBox, CXTPEditListBoxToolBar
  • EnableEditAccelerators() : CXTPSyntaxEditCtrl
  • EnableFloatingFrameTheme() : CXTPDockingPaneManager, CXTPTabClientContext
  • EnableFocusRect() : CXTPTagCloudCtrl
  • EnableFrameTheme() : CXTPCommandBars, CXTPCommandBarsFrameHook, CXTPRibbonBar
  • EnableFullDrag() : CXTPSplitterWnd
  • EnableGdiPlus() : CXTPMarkupContext
  • EnableHScroll() : CXTPCalendarView
  • EnableHyperlinks() : CXTPTaskDialog
  • EnableKeyboardNavigate() : CXTPDockingPaneManager
  • EnableMarkup() : CXTPButton, CXTPCalendarControl, CXTPChartContent, CXTPComboBox, CXTPControlGalleryItems, CXTPFlowGraphControl, CXTPGridControl, CXTPMessageBar, CXTPPopupControl, CXTPPropertyGrid, CXTPStatusBar, CXTPTabClientWnd, CXTPTabManager, CXTPTaskDialog, CXTPTaskPanel, CXTPTipOfTheDay
  • EnableMenuItem() : CXTPShortcutListBox
  • EnableMessageBoxStyle() : CXTPTaskDialog
  • EnableMinimize() : CXTPTaskDialog
  • EnableMulticolumns() : CXTPCalendarCaptionBarControl
  • EnableMultiSelect() : CXTPPropertyGrid, CXTPTreeBase
  • EnableNoSize() : CXTPSplitterWnd
  • EnableOkButton() : CXTPCalendarEventColorNewDlg
  • EnableOleDrag() : CXTPSyntaxEditCtrl
  • EnableParser() : CXTPSyntaxEditBufferManager
  • EnablePopupMenus() : CXTPHeaderCtrl
  • EnablePreviewMode() : CXTPGridControl, CXTPGridPaintManager
  • EnableRadioButton() : CXTPTaskDialog
  • EnableRedraw() : CXTPTabExBase
  • EnableRelativePosition() : CXTPTaskDialog
  • EnableReminders() : CXTPCalendarControl
  • EnableResize() : CXTPGridColumn
  • EnableRtlLayout() : CXTPTaskDialog
  • EnableScrollBar() : CXTPScrollBarContainer< Parent >
  • EnableScrollBarCtrl() : CXTPFlowGraphControl, CXTPSyntaxEditCtrl
  • EnableScrollBars() : CXTPHexEdit
  • EnableSendNotifications() : CXTPCalendarControl
  • EnableShadow() : CXTPCommandBarsFrameHook, CXTPFrameShadowManager
  • EnableShellAutoComplete() : CXTPControlComboBox, CXTPControlEdit
  • EnableShellExecute() : CXTPHyperLink
  • EnableSideDocking() : CXTPDockingPaneManager
  • EnableSwitch() : CXTPStatusBarSwitchPane
  • EnableSystemSounds() : CXTPSoundManager
  • EnableSysYearMonthFormat() : CXTPDatePickerControl
  • EnableTabColors() : CXTPSplitterWndTheme
  • EnableTabContextWindow() : CXTPTabClientContext
  • EnableTabFocusRect() : CXTPTabClientContext
  • EnableTabSticker() : CXTPTabClientContext
  • EnableTabThemeTexture() : CXTPTabManager
  • EnableTheme() : CXTPCalendarPaintManager, CXTPDatePickerPaintManager
  • EnableThemeDialogTexture() : CXTPSkinManager, CXTPWinThemeWrapper
  • EnableTheming() : CXTPWinThemeWrapper
  • EnableTimeline() : CXTPCalendarCaptionBarControl
  • EnableToolbarComposition() : CXTPCommandBars
  • EnableTooltip() : CXTPTagCloudCtrl
  • EnableToolTips() : CXTPCalendarControl, CXTPChartControl, CXTPGridControl, CXTPHyperLink, CXTPPropertyGrid, CXTPTabClientWnd, CXTPTabControl, CXTPTabCtrl, CXTPTabPaintManager
  • EnableToolTipsEx() : CXTPTabExBase
  • EnableUndoManager() : CXTPFlowGraphUndoManager
  • EnableUserListColor() : CXTPListBase
  • EnableUserRowColor() : CXTPListBase
  • EnableUserSortColor() : CXTPListBase
  • EnableVirtualSpace() : CXTPSyntaxEditCtrl
  • EnableVScroll() : CXTPCalendarView
  • EnableWhiteSpace() : CXTPSyntaxEditCtrl
  • END_VIEW_PART() : CXTPCalendarPaintManager
  • EndBufferedPaint() : CXTPWinThemeWrapper
  • EndChildren() : CXTPSyntaxEditLexTextBlock
  • EndEdit() : CXTPCalendarEventColorListBox
  • EndEditSubject() : CXTPCalendarView, CXTPCalendarViewEvent
  • EndFrequentUpdates() : CXTPChartContainer
  • EndGroup() : CXTPFlowGraphUndoManager, CXTPTrackUndoManager
  • EndLabelEdit() : CXTPItemEdit
  • EndSelection() : CXTPColorPopup, CXTPColorSelectorCtrl
  • EndUpdate() : CXTPGridControl, CXTPPropertyGrid
  • EnsureFocusedRowVisible() : CXTPGridControl
  • EnsureStartAutoVertScroll() : CXTPGridControl
  • EnsureStopAutoVertScroll() : CXTPGridControl
  • EnsureStopDelayEditTimer() : CXTPGridControl
  • EnsureStopLastRqstTimer() : CXTPGridControl
  • EnsureVisible() : CXTPCalendarDayView, CXTPCommandBar, CXTPControlGallery, CXTPDatePickerControl, CXTPDockingPaneManager, CXTPGridColumn, CXTPGridControl, CXTPGridRow, CXTPGridSections, CXTPPropertyGridItem, CXTPRibbonBar, CXTPRibbonTabPopupToolBar, CXTPTabManager, CXTPTabPaintManager, CXTPTaskPanel, CXTPTaskPanelGroup, CXTPTaskPanelItem, CXTPTrackControl
  • EnsureVisibleCol() : CXTPSyntaxEditCtrl
  • EnsureVisibleFocus() : CXTPDatePickerControl
  • EnsureVisibleH() : CXTPCalendarDayView
  • EnsureVisibleRow() : CXTPSyntaxEditCtrl
  • EnsureVisibleSelection() : CXTPDatePickerControl
  • Enter() : CXTPSimpleCriticalSection
  • EnterCritical() : CXTPCriticalSection
  • EnumCustomTraits() : CXTPGaugeTraits
  • EnumFontFamExProc() : CXTPFontEnum
  • EnumFontFamiliesEx() : CXTPControlFontComboBoxList
  • EnumKeys() : CXTPRegistryManager
  • EnumValues() : CXTPRegistryManager
  • Equals() : CXTPMatrix< T >, CXTPRectT< T >
  • EventsMapByID_T() : CXTPCalendarData::EventsMapByID_T< _TObject >
  • ExchangeBlobProp() : CXTPPropExchange, CXTPPropExchangeArchive, CXTPPropExchangeRegistry
  • ExchangeEventPlace() : CXTPCalendarViewGroup
  • ExchangeLocale() : CXTPPropExchange
  • ExchangeObjectInstance() : CXTPPropExchange, CXTPPropExchangeArchive
  • ExchangeProp() : CXTPPropExchange, CXTPPropExchangeArchive, CXTPPropExchangeIniFile, CXTPPropExchangeRegistry, CXTPPropExchangeXMLNode
  • ExchangeRuntimeClass() : CXTPPropExchange, CXTPPropExchangeArchive
  • ExchangeSchema() : CXTPPropExchange
  • Exclude() : CXTPResizeGroupBox
  • ExcludeCorners() : CXTPCommandBarsOffice2003Theme
  • ExcludeDocTemplate() : CXTPControl
  • ExcludeModule() : CXTPSkinManager
  • Execute() : CXTPChartDeviceCommand, CXTPChartDeviceContext, CXTPSyntaxEditBatchCommand, CXTPSyntaxEditCommand, CXTPSyntaxEditDeleteStringCommand, CXTPSyntaxEditInsertStringCommand, CXTPSyntaxEditReplaceStringCommand
  • ExecuteInternal() : CXTPChartTextDeviceCommand
  • ExecuteOverride() : CXTPChart3dFunnelSeriesLabelDeviceCommand, CXTPChart3dFunnelSeriesLabelsViewDeviceCommand, CXTPChart3dPieSeriesLabelsViewDeviceCommand, CXTPChart3dPyramidSeriesLabelDeviceCommand, CXTPChart3dPyramidSeriesLabelsViewDeviceCommand, CXTPChartDeviceCommand, CXTPChartTextDeviceCommand
  • ExecuteScript() : CXTPShellExplorerProvider, CXTPWebBrowserCtrl, CXTPWebBrowserProvider, CXTPWebViewProvider
  • ExistsScheduleID() : CXTPCalendarResource
  • Expand() : CXTPDockingPaneMiniWnd, CXTPDockingPaneSidePanel, CXTPPropertyGridItem, CXTPSearchOptionsCtrl
  • ExpandAll() : CXTPGridControl, CXTPGridSection, CXTPSyntaxEditCtrl
  • ExpandBar() : CXTPPopupBar
  • ExpandChars() : CXTPSyntaxEditCtrl, CXTPSyntaxEditDrawTextProcessor
  • ExpandCommandBar() : CXTPControlPopup
  • ExpandedByDefault() : CXTPTaskDialog
  • ExpandFooterArea() : CXTPTaskDialog
  • ExpandGroup() : CXTPTaskPanel
  • Extend() : CXTPMarkupStaticExtension
  • Extract() : CXTPMemFile
  • ExtractIcon() : CXTPImageList
  • ExtractLinks() : CXTPTaskDialogLinkCtrl


Toolkit Pro: Class Members - Functions

Here is a list of all documented functions with links to the class documentation for each member:

- f -

  • FillBackground() : CXTPColorSelectorCtrlTheme, CXTPExcelTabCtrlTheme, CXTPExcelTabCtrlThemeOffice2013
  • FillButton() : CXTPTabPaintManagerTheme
  • FillButtons() : CXTPTabBaseTheme, CXTPTabBaseThemeOffice2003, CXTPTabBaseThemeOfficeXP
  • FillCaptionPart() : CXTPDockingPaneVisualStudio2003Theme, CXTPDockingPaneVisualStudio2005Beta2Theme, CXTPDockingPaneVisualStudio2010Theme
  • FillClient() : CColorSetWinNative, CXTPTabPaintManagerColorSet
  • FillCommandBarEntry() : CXTPCommandBar, CXTPCommandBarsNativeWindows11Theme, CXTPCommandBarsNativeXPTheme, CXTPCommandBarsOffice2000Theme, CXTPCommandBarsOffice2003Theme, CXTPCommandBarsOffice2013Theme, CXTPCommandBarsOfficeXPTheme, CXTPCommandBarsVisualStudio2012Theme, CXTPPaintManager, CXTPReBarPaintManager< TBase >, CXTPRibbonSystemPopupBar, CXTPRibbonTheme, CXTPVisualStudio2010Theme
  • FillControl() : CXTPControlGalleryOffice2013Theme, CXTPControlGalleryPaintManager, CXTPControlGalleryResourceTheme
  • FillDockBar() : CXTPCommandBarsNativeWindows11Theme, CXTPCommandBarsNativeXPTheme, CXTPCommandBarsOffice2003Theme, CXTPCommandBarsOffice2013Theme, CXTPCommandBarsVisualStudio2012Theme, CXTPPaintManager
  • FillDockBarRect() : CXTPCommandBarsNativeXPTheme
  • FillFooter() : CXTPGridPaintManager, CXTPGridThemeOffice2003Luna, CXTPGridThemeResource, CXTPTrackThemeOffice2003Luna, CXTPTrackThemeResource
  • FillFramePartRect() : CXTPDockingPaneTabColorSetVisualStudio2003
  • FillGroupByControl() : CXTPGridPaintManager
  • FillGroupClientFace() : CXTPTaskPanelPaintManager, CXTPTaskPanelPaintManagerPlain, CXTPTaskPanelShortcutBarOffice2003Theme, CXTPTaskPanelShortcutBarOffice2007Theme, CXTPTaskPanelVisualStudio2005Theme, CXTPTaskPanelVisualStudio2010Theme, CXTPTaskPanelVisualStudio2012Theme
  • FillGroupPopupToolBar() : CXTPRibbonMarkupTheme, CXTPRibbonPaintManager, CXTPRibbonThemeResource
  • FillGroupRect() : CXTPRibbonMarkupTheme, CXTPRibbonPaintManager, CXTPRibbonThemeNativeWindows10, CXTPRibbonThemeNativeWindows11, CXTPRibbonThemeResource
  • FillGroupRowMetrics() : CXTPGridPaintManager, CXTPGridThemeOffice2013, CXTPTrackThemeOffice2013
  • FillHeader() : CXTPDockingPaneTabColorSet2012, CXTPDockingPaneTabColorSet2013, CXTPDockingPaneTabColorSet2015, CXTPDockingPaneTabColorSet2017, CXTPDockingPaneTabColorSet2019, CXTPDockingPaneTabColorSet2022, CXTPDockingPaneTabColorSetNativeWindows10, CXTPDockingPaneTabColorSetNativeWindows11, CXTPDockingPaneTabColorSetVisualStudio2003, CXTPTabBaseTheme, CXTPTabBaseThemeOffice2003, CXTPTabBaseThemeOfficeXP, CXTPTabColorSetVisualStudio2010, CXTPTabPaintManagerColorSet
  • FillHeaderControl() : CXTPGridPaintManager
  • FillHitTestEx() : CXTPCalendarDayViewDay, CXTPCalendarDayViewGroup, CXTPCalendarMonthViewDay, CXTPCalendarMonthViewGroup, CXTPCalendarTimeLineViewGroup, CXTPCalendarViewDay, CXTPCalendarViewDayT< _TView, _TViewGroup, XTP_CALENDAR_HITTESTINFO, _TPThis >, CXTPCalendarViewGroup, CXTPCalendarViewGroupT< _TViewDay, _TViewEvent, _TPThis >, CXTPCalendarWeekViewDay, CXTPCalendarWeekViewGroup
  • FillIndent() : CXTPGridPaintManager
  • FillInplaceButton() : CXTPPropertyGridOffice2007Theme, CXTPPropertyGridPaintManager
  • FillIntersectRect() : CXTPCommandBarsOfficeXPTheme
  • FillItemShade() : CXTPGridPaintManager
  • FillMDIClientWindowList() : CXTPWindowList
  • FillMDIWindowList() : CXTPWindowList
  • FillMessageBar() : CXTPMessageBar, CXTPMessageBarPaintManager, CXTPMessageBarThemeOffice2010, CXTPMessageBarThemeOffice2013
  • FillMetrics() : CXTPGridRow
  • FillMorePopupToolBarEntry() : CXTPRibbonMarkupTheme, CXTPRibbonPaintManager, CXTPRibbonThemeResource
  • FillNavigateButton() : CColorSetVisualStudio2003, CColorSetWinNative, CXTPDockingPanePanelColorSet2012, CXTPDockingPaneTabColorSet2012, CXTPDockingPaneTabColorSet2013, CXTPTabColorSetDefault, CXTPTabColorSetOffice2003, CXTPTabColorSetOffice2007, CXTPTabColorSetOffice2013, CXTPTabColorSetVisualStudio2010, CXTPTabColorSetVisualStudio2012, CXTPTabColorSetVisualStudio2015, CXTPTabPaintManager, CXTPTabPaintManagerColorSet
  • FillNavigationItemEntry() : CXTPShortcutBarNativeWindows10Theme, CXTPShortcutBarNativeWindows11Theme, CXTPShortcutBarOffice2003Theme, CXTPShortcutBarOffice2013Theme, CXTPShortcutBarPaintManager, CXTPShortcutBarResourceTheme, CXTPShortcutBarVisualStudio2015Theme, CXTPShortcutBarVisualStudio2017Theme, CXTPShortcutBarVisualStudio2019Theme, CXTPShortcutBarVisualStudio2022Theme
  • FillPopupLabelEntry() : CXTPRibbonTheme
  • FillPropertyButton() : CColorSetVisualStudio2005, CColorSetWinNative, CXTPDockingPaneTabColorSetVisualStudio2003, CXTPTabColorSetOffice2003, CXTPTabColorSetOffice2013, CXTPTabColorSetVisualStudio2008, CXTPTabColorSetVisualStudio2010, CXTPTabColorSetVisualStudio2015, CXTPTabPaintManagerColorSet
  • FillPropertyGrid() : CXTPPropertyGridPaintManager
  • FillPropertyGridView() : CXTPPropertyGridPaintManager
  • FillRect() : CXTPEditTheme
  • FillRibbonBar() : CXTPRibbonMarkupTheme, CXTPRibbonOffice2013Theme, CXTPRibbonPaintManager, CXTPRibbonThemeResource
  • FillRibbonTabControl() : CXTPRibbonMarkupTheme, CXTPRibbonPaintManager, CXTPRibbonThemeResource
  • FillRow() : CXTPGridPaintManager
  • FillShortcutBar() : CXTPShortcutBarNativeWinXPTheme, CXTPShortcutBarOffice2000Theme, CXTPShortcutBarOffice2003Theme, CXTPShortcutBarOffice2013Theme, CXTPShortcutBarOfficeXPTheme, CXTPShortcutBarPaintManager, CXTPShortcutBarResourceTheme
  • FillShortcutItemEntry() : CXTPShortcutBarNativeWindows10Theme, CXTPShortcutBarNativeWindows11Theme, CXTPShortcutBarNativeWinXPTheme, CXTPShortcutBarOffice2000Theme, CXTPShortcutBarOffice2003Theme, CXTPShortcutBarOffice2013Theme, CXTPShortcutBarOfficeXPTheme, CXTPShortcutBarPaintManager, CXTPShortcutBarResourceTheme, CXTPShortcutBarVisualStudio2015Theme, CXTPShortcutBarVisualStudio2017Theme, CXTPShortcutBarVisualStudio2019Theme, CXTPShortcutBarVisualStudio2022Theme
  • FillSolidRect() : CXTPComboBoxTheme
  • FillStateButton() : CColorSetWinNative, CXTPTabPaintManagerColorSet
  • FillStatusBar() : CXTPRibbonTheme, CXTPStatusBarThemeOffice2013
  • FillSystemPopupBarEntry() : CXTPRibbonMarkupTheme, CXTPRibbonPaintManager, CXTPRibbonThemeResource
  • FillTabControl() : CAppearanceSetPropertyPage2003, CAppearanceSetPropertyPage2007, CAppearanceSetPropertyPageAccess2007, CAppearanceSetStateButtons, CXTPTabPaintManagerTheme, CXTPTabThemeFlat, CXTPTabThemeOffice2000, CXTPTabThemeVisualStudio2003
  • FillTabFace() : CXTPTabBaseTheme, CXTPTabBaseThemeOffice2003, CXTPTabBaseThemeOfficeXP
  • FillTabFaceNativeWinXP() : CXTPTabBaseTheme
  • FillTabPopupToolBar() : CXTPRibbonPaintManager
  • FillTabs() : CXTPSyntaxEditCtrl
  • FillTabsBackground() : CXTPExcelTabCtrlTheme, CXTPExcelTabCtrlThemeOffice2013
  • FillTaskPanel() : CXTPTaskPanelOffice2013Theme, CXTPTaskPanelPaintManager, CXTPTaskPanelPaintManagerPlain, CXTPTaskPanelShortcutBarOffice2003Theme, CXTPTaskPanelShortcutBarOffice2007Theme, CXTPTaskPanelVisualStudio2005Theme, CXTPTaskPanelVisualStudio2010Theme, CXTPTaskPanelVisualStudio2012Theme
  • FillWorkspace() : CXTPCommandBarsOffice2013Theme, CXTPPaintManager, CXTPResourceTheme
  • FilterEventsByScheduleID() : CXTPCalendarResource
  • FilterExStyle() : IXTPScrollable
  • FilterStyle() : IXTPScrollable
  • FilterWindow() : IXTPSkinManagerWindowFilter
  • FilterWindowClass() : IXTPSkinManagerWindowFilter
  • Find() : CXTPCalendarEventCategories, CXTPCalendarEventLabels, CXTPCalendarEvents, CXTPCalendarPtrCollectionT< _TObject >, CXTPCalendarReminderForOccurrenceArray, CXTPCalendarReminders, CXTPCalendarResources, CXTPCalendarTimeZones, CXTPCalendarUIntArray, CXTPCalendarViewEvents, CXTPDatePickerButtons, CXTPGridColumns, CXTPGridRows, CXTPMouseManager::CTrackArray, CXTPPropertyGridInplaceButtons, CXTPPropertyGridItems, CXTPSyntaxEditCtrl, CXTPTaskPanelItems
  • FindAccel() : CXTPCommandBar
  • FindAccelEx() : CXTPCommandBar
  • FindAction() : CXTPCommandBars, CXTPControlActions
  • FindBand() : CXTPReBar
  • FindButton() : CXTPMessageBar
  • FindByDataProvider() : CXTPCalendarResourcesNf
  • FindCaptionButton() : CXTPDockingPaneBase
  • FindCategory() : CXTPCustomizeCommandsPage, CXTPCustomizeKeyboardPage
  • FindChildPane() : CXTPDockingPaneSplitterContainer
  • FindColor() : CXTPSyntaxEditColorComboBox
  • FindCommandBar() : CXTPCommandBarList
  • FindConnection() : CXTPNotifyConnection
  • FindConnectionPoint() : CXTPFlowGraphConnectionPoints
  • FindConnectionPointByCaption() : CXTPFlowGraphConnectionPoints
  • FindConstraint() : CXTPGridRecordItemEditOptions, CXTPPropertyGridItemConstraints
  • FindControl() : CXTPCommandBars, CXTPControls, CXTPRibbonGroup
  • FindData() : CXTPMemFile
  • FindDefaultAccelerator() : CXTPShortcutManager
  • FindDefaultFrameAccelerator() : CXTPShortcutManager
  • FindDuplicate() : CXTPRibbonQuickAccessControls
  • FindElement() : CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE >
  • FindEvent() : CXTPCalendarEvents
  • FindEventToEditByTAB() : CXTPCalendarDayView, CXTPCalendarView
  • FindException() : CXTPCalendarRecurrencePattern
  • FindExceptionIndex() : CXTPCalendarRecurrencePattern
  • FindExceptions() : CXTPCalendarRecurrencePattern
  • FindExtension() : CXTPMarkupStaticExtension
  • FindGroup() : CXTPRibbonBar, CXTPRibbonTab, CXTPTaskPanel
  • FindGroupByColumn() : CXTPGridHeader
  • FindHeaderColumn() : CXTPGridHeader
  • FindIndex() : CXTPCalendarEventCategories, CXTPCalendarEventLabels, CXTPCalendarSchedules, CXTPCommandBars, CXTPTabClientWnd
  • FindInsertionPos() : CXTPGridRows
  • FindInTree() : CXTPGridRows
  • FindItem() : CXTPControlGallery, CXTPPropertyGrid, CXTPPropertyGridItems, CXTPShortcutBar, CXTPTabClientWnd, CXTPTaskPanel, CXTPTaskPanelGroup, CXTPTreeBase
  • FindItemData() : CXTPGridSubListControl
  • FindItemExact() : CXTPTreeBase
  • FindItemImpl() : CXTPTreeBase
  • FindItemInBranch() : CXTPTreeBase
  • FindLastSelectedDay() : CXTPCalendarView
  • FindMinMaxGroupDayEvents() : CXTPCalendarDayViewGroup
  • FindNavigateButton() : CXTPTabManager
  • FindNextFocusable() : CXTPTabManager
  • FindNextLineMark() : CXTPSyntaxEditLineMarksManager
  • FindNode() : CXTPFlowGraphNodes
  • FindPage() : CXTPFlowGraphPages
  • FindPane() : CXTPDockingPaneBase, CXTPDockingPaneBaseContainer, CXTPDockingPaneManager, CXTPDockingPaneMiniWnd, CXTPStatusBar
  • FindPrevLineMark() : CXTPSyntaxEditLineMarksManager
  • FindRecordByBookmark() : CXTPGridRecords
  • FindRecordItem() : CXTPGridRecords
  • FindRecordItemByRows() : CXTPGridRows
  • FindResource() : CXTPResourceManager
  • FindRowAdjacentToMerged() : CXTPGridPaintManager
  • FindRowAdjacentToMergedEx() : CXTPGridPaintManager
  • FindSchema() : CXTPSyntaxEditTextSchemesManager
  • FindString() : CXTPControlComboBox
  • FindStringExact() : CXTPControlComboBox
  • FindSwitch() : CXTPStatusBarSwitchPane
  • FindTab() : CXTPRibbonBar, CXTPRibbonControlTab
  • FindTargetTabClient() : CXTPTabClientContext
  • FindTreeItem() : CXTPShellTreeBase
  • FindViewEvent() : CXTPCalendarView
  • FindWord() : CXTPSyntaxEditCtrl
  • FindWordEx() : CXTPSyntaxEditCtrl
  • FindWordEx_str() : CXTPSyntaxEditCtrl
  • FitFieldWidths() : CXTPHeaderCtrl
  • FitToContent() : CXTPPopupItem
  • FloatCommandBar() : CXTPCommandBars
  • FloatPane() : CXTPDockingPaneManager
  • Flush() : CXTPMemFile
  • FocusInplaceButton() : CXTPPropertyGridView
  • FocusItem() : CXTPTaskDialogLinkCtrl, CXTPTreeBase
  • FocusSubItems() : CXTPGridControl
  • FontExists() : CXTPAuxData, CXTPFontManager, CXTPPaintManager
  • FontToString() : CXTPPropertyGridItemFont
  • ForceLayoutAdjustment() : CXTPGridHeader
  • Format() : CXTPCalendarDayViewTimeScale, CXTPPropertyGridItemDate, CXTPShortcutManager
  • FormatDate() : CXTPChartNumberFormat
  • FormatDateTime() : CXTPGridControlLocale
  • FormatEventTime() : CXTPCalendarView, CXTPCalendarViewEvent
  • FormatFontName() : CXTPCalendarPageSetupDialog
  • FormatNumber() : CXTPChartNumberFormat
  • FormatOleDateTime() : CXTPDateEdit, CXTPTimeEdit
  • FormatPoint() : CXTPChartNumberFormat
  • FormatString() : CXTPChartNumberFormat
  • FormatTime() : CXTPTrackPaintManager
  • FormatTimeDuration() : CXTPCalendarUtils
  • FormatTimeLineTick() : CXTPTrackPaintManager
  • ForwardMessage() : CXTPTipWindow
  • ForwardMouse() : CXTPPageScroller
  • Free() : CXTPShellPidl::CShellMalloc
  • Free_mem() : CXTPHeapAllocatorT< _TData >
  • FreeBitmaps() : CXTPTaskPanelPaintManager
  • FreeButtonIcons() : CXTPExcelTabCtrl
  • FreeExtraData() : CXTPBatchAllocObjT< _TObject, _TBatchAllocData, _TAllocator >
  • FreeLibrary() : CXTPModuleHandle
  • FreeMDIMenus() : CXTPMenuBar
  • FreePidl() : CXTPShellPidl
  • FreeRowBatchExtraData() : CXTPGridControl
  • FreeSkinData() : CXTPSkinManager
  • FreeSysFonts() : CXTPAuxData
  • FreezeColumn() : CXTPHeaderCtrl
  • FreezeUpdates() : CXTPFrameShadow, CXTPFrameShadowManager
  • FromHandle() : CXTPSkinManager
  • FromIDispatchSafe() : CXTPCmdTarget
  • FromUI() : CXTPControl
  • FullDragWindows() : CXTPSplitterWnd


Toolkit Pro: Class Members - Functions

Here is a list of all documented functions with links to the class documentation for each member:

- g -

  • GenerateCommandBarList() : CXTPCommandBar, CXTPControl, CXTPMenuBar
  • Get() : CXTPCalendarData::EventsMapByID_T< _TObject >, CXTPFontEnum
  • Get3dRotation() : CXTPChart3dPieSeriesStyle, CXTPChartSeriesStyle
  • GetA() : CXTPChartColor
  • GetAbsoluteVisualOffset() : CXTPMarkupVisual
  • GetAccess() : CXTPSingletonPointer
  • GetAccessCriticalSection() : CXTPSynchronized
  • GetAction() : CXTPControl, CXTPControlGalleryItems
  • GetActions() : CXTPCommandBars
  • GetActiveControlPane() : CXTPRibbonBackstageView
  • GetActiveDocTemplate() : CXTPCommandBar, CXTPCommandBars
  • GetActiveGroup() : CXTPTaskPanel
  • GetActiveIndex() : CXTPPropertySheet
  • GetActiveItem() : CXTPGridControl
  • GetActiveLCID() : CXTPCalendarControlViewPrintOptions, CXTPCalendarUtils, CXTPChartNumberFormat, CXTPGridControlLocale, CXTPGridViewPrintOptions, CXTPResourceManager
  • GetActiveMdiChildWnd() : CXTPMenuBar
  • GetActivePage() : CXTPFlowGraphControl, CXTPPropertySheet
  • GetActivePane() : CXTPDockingPaneManager
  • GetActiveReminders() : CXTPCalendarRemindersManager
  • GetActiveRemindersCount() : CXTPCalendarRemindersManager
  • GetActiveTab() : CXTPRibbonBackstageView
  • GetActiveTags() : CXTPSyntaxEditLexClass
  • GetActiveView() : CXTPCalendarControl, CXTPTabExBase
  • GetActualBackColor() : CXTPHexEdit
  • GetActualBackgroundColor() : CXTPChartContent, CXTPChartLegend
  • GetActualBorderColor() : CXTPChartContent, CXTPChartLegend
  • GetActualColor() : CXTPChartAreaSeriesView, CXTPChartAxis, CXTPChartAxisConstantLine, CXTPChartAxisStrip, CXTPChartBubbleSeriesPointView, CXTPChartRadarAreaSeriesView
  • GetActualColor2() : CXTPChartAreaSeriesView, CXTPChartBubbleSeriesPointView, CXTPChartRadarAreaSeriesView
  • GetActualHighlightBackColor() : CXTPHexEdit
  • GetActualHighlightTextColor() : CXTPHexEdit
  • GetActualInterlacedColor() : CXTPChartAxis
  • GetActualInterlacedColor2() : CXTPChartAxis
  • GetActualSize() : CXTPMarkupFrameworkElement
  • GetActualTextColor() : CXTPChartAxisConstantLine, CXTPChartAxisLabel, CXTPChartAxisTitle, CXTPChartLegend, CXTPChartTitle, CXTPHexEdit
  • GetAdditionalScaleText() : CXTPCalendarDayView
  • GetAdditionalScaleTimeZone() : CXTPCalendarDayView
  • GetAdditionalScaleTimeZoneInfo() : CXTPCalendarDayView
  • GetAddOrRemovePopup() : CXTPCommandBars
  • GetAlignment() : CXTPChartAxis, CXTPChartAxisConstantLine, CXTPChartAxisTitle, CXTPChartTitle, CXTPGridColumn, CXTPGridRecordItem, CXTPGridRecordItemControl, CXTPPropertyGridInplaceButton
  • GetAllDayEventsRect() : CXTPCalendarDayViewGroup
  • GetAllDayEventsScrollButtonRect() : CXTPCalendarDayViewGroup
  • GetAllEvents_raw() : CXTPCalendarData
  • GetAllowDeletes() : CXTPHexEdit
  • GetAllowModifyConnections() : CXTPFlowGraphControl
  • GetAllowMoveNodes() : CXTPFlowGraphControl
  • GetAllowNullDateString() : CXTPPropertyGridItemDate
  • GetAllowReduceLevel() : CXTPRibbonGroup
  • GetAllowResizeNodes() : CXTPFlowGraphControl
  • GetAlpha() : CXTPChartColor
  • GetAlphaTabClientContext() : CXTPTabClientContext
  • GetAmbientProperty() : CXTPApplication
  • GetAnchorPoint() : CXTPChartBarSeriesLabelView, CXTPChartDiagram2DSeriesLabelView, CXTPChartPointSeriesLabelView, CXTPChartRadarPointSeriesLabelView, CXTPChartRangeAreaSeriesLabelView, CXTPChartRangeBarSeriesLabelView
  • GetAngle() : CXTPChartAxisLabel, CXTPChartPointSeriesLabel, CXTPChartRadarPointSeriesLabel, CXTPMarkupRotateTransform
  • GetAngleX() : CXTPMarkupSkewTransform
  • GetAngleY() : CXTPMarkupSkewTransform
  • GetAnimateDelay() : CXTPPopupControl
  • GetAnimation() : CXTPTaskPanel
  • GetAnimationDelay() : CXTPDockingPaneManager, CXTPFlowGraphControl
  • GetAntialiasing() : CXTPChart3dDeviceContext, CXTPChartAxisConstantLine, CXTPChartAxisLabel, CXTPChartAxisTitle, CXTPChartFastLineSeriesStyle, CXTPChartLegend, CXTPChartSeriesLabel, CXTPChartTextElement, CXTPChartTitle
  • GetAppearance() : CXTPChartAppearance, CXTPChartAxis, CXTPChartContent, CXTPChartDiagram2D, CXTPChartElement, CXTPChartRadarDiagram, CXTPTabManager, CXTPTabPaintManager
  • GetAppearanceSet() : CXTPTabManager, CXTPTabPaintManager
  • GetApplyOptions() : CXTPSkinManager
  • GetAppRegistryKey() : CXTPRegistryManager
  • GetAppThreadId() : CXTPApplication
  • GetArchive() : CXTPPropExchange, CXTPPropExchangeArchive
  • GetArea() : CXTPChartEllipse
  • GetArgument() : CXTPChartSeriesPoint
  • GetArgumentScaleType() : CXTPChartSeries
  • GetArgumentValue() : CXTPChartSeriesPoint
  • GetArithmeticMean() : CXTPChartSeriesPointCollection
  • GetAscending() : CXTPHeaderCtrl
  • GetAskItemTextFlags() : CXTPCalendarControl, CXTPCalendarPaintManager
  • GetAsSystemTime() : CXTPPropertyGridItemDate
  • GetAt() : CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE >, CXTPCalendarEvents, CXTPCalendarPtrCollectionT< _TObject >, CXTPCalendarTimeZones, CXTPChartAxisConstantLines, CXTPChartAxisCustomLabels, CXTPChartAxisStrips, CXTPChartElementCollection, CXTPChartElementView, CXTPChartPanelCollection, CXTPChartSeriesCollection, CXTPChartSeriesPointCollection, CXTPChartTitleCollection, CXTPCommandBarList, CXTPCommandBars, CXTPControlActions, CXTPControls, CXTPFlowGraphConnectionPoints, CXTPFlowGraphConnections, CXTPFlowGraphImages, CXTPFlowGraphNodeGroup, CXTPFlowGraphNodeGroups, CXTPFlowGraphNodes, CXTPFlowGraphPages, CXTPFlowGraphSelectedElements, CXTPGridColumnOrder, CXTPGridColumns, CXTPGridRecordItemConstraints, CXTPGridRecords, CXTPGridRows, CXTPGridSelectedRows, CXTPInternalCollectionT< _TObject >, CXTPMatrix< T >, CXTPPropertyGridInplaceButtons, CXTPPropertyGridInplaceControls, CXTPPropertyGridItemConstraints, CXTPPropertyGridItems, CXTPPropertyGridVerbs, CXTPRibbonGroup, CXTPRibbonGroups, CXTPShortcutManagerAccelTable, CXTPTabManagerNavigateButtons, CXTPTaskPanel, CXTPTaskPanelGroup, CXTPTaskPanelItems, CXTPTrackMarkers, CXTPTrackSelectedBlocks
  • GetAtOffset() : CXTPGridColumns
  • GetAtom() : CXTPGlobalAtom
  • GetAtomString() : CXTPGlobalAtom
  • GetAttribute() : CXTPSyntaxEditLexClass
  • GetAttribute_BOOL() : CXTPSyntaxEditLexClass
  • GetAttribute_int() : CXTPSyntaxEditLexClass
  • GetAttributes() : CXTPShellPidl
  • GetAutoApplyNewThreads() : CXTPSkinManager
  • GetAutoApplyNewWindows() : CXTPSkinManager
  • GetAutoColor() : CXTPSyntaxEditColorComboBox
  • GetAutoCompleteWnd() : CXTPSyntaxEditCtrl
  • GetAutoCondense() : CXTPTabExBase
  • GetAutoIndent() : CXTPSyntaxEditCtrl
  • GetAutoReload() : CXTPSyntaxEditDoc
  • GetAutoscrollDirection() : CXTPSyntaxEditCtrl
  • GetAutoTheme() : CXTPTabClientWnd
  • GetAutoVScrollTimerResolution() : CXTPGridControl
  • GetAverageValue() : CXTPSyntaxEditCtrl::CAverageVal
  • GetAxis() : CXTPChartAxisGridLines, CXTPChartAxisLabel, CXTPChartAxisTickMarks, CXTPChartAxisTitle, CXTPChartScaleTypeMap
  • GetAxisAppearance() : CXTPChartDiagram2DAppearance
  • GetAxisMaxValue() : CXTPChartAxisStrip
  • GetAxisMinValue() : CXTPChartAxisStrip
  • GetAxisMinValueInternal() : CXTPChartAxisStrip
  • GetAxisValue() : CXTPChartAxisConstantLine, CXTPChartAxisCustomLabel
  • GetAxisValueInternal() : CXTPChartAxisConstantLine, CXTPChartAxisCustomLabel
  • GetAxisView() : CXTPChartDiagram2DView, CXTPChartRadarDiagramView
  • GetAxisX() : CXTPChartDiagram2D, CXTPChartRadarDiagram
  • GetAxisY() : CXTPChartDiagram2D, CXTPChartRadarDiagram
  • GetB() : CXTPChartColor
  • GetBackColor() : CXTPChartSeriesLabel, CXTPComboBox, CXTPComboBoxTheme, CXTPHexEdit, CXTPHyperLink, CXTPListBox, CXTPListBoxTheme, CXTPListBoxThemeOffice2013, CXTPMarqueeCtrlPaintManager, CXTPProgressCtrl, CXTPProgressCtrlPaintManager, CXTPShortcutListBoxTheme, CXTPSyntaxEditColorSampleText, CXTPSyntaxEditPaintManager, CXTPSyntaxEditTipWnd, CXTPTabBaseTheme, CXTPTabBaseThemeOffice2003, CXTPTagCloudCtrl, CXTPTaskDialogLinkCtrl, CXTPTaskPanelGroupItem
  • GetBackColorEx() : CXTPSyntaxEditPaintManager, XTP_EDIT_COLORVALUES
  • GetBackground() : CXTPMarkupBorder, CXTPMarkupControl, CXTPMarkupPanel, CXTPMarkupTextBlock
  • GetBackgroundBitmap() : CXTPPopupControl
  • GetBackgroundBrush() : CXTPComboBoxTheme
  • GetBackgroundColor() : CXTPCalendarEventCategory, CXTPCalendarViewPart, CXTPChartContent, CXTPChartLegend, CXTPGridRecordItem, CXTPPopupItem, CXTPPreviewCtrl, CXTPStatusBarPane, IXTPPreviewHost
  • GetBackImageName() : CXTPRibbonOffice2013Theme
  • GetBackstageStyle() : CXTPRibbonBackstageView
  • GetBarColor() : CXTPMarqueeCtrlPaintManager, CXTPProgressCtrl, CXTPProgressCtrlPaintManager
  • GetBarID() : CXTPCommandBar
  • GetBarInfo() : CXTPToolBar
  • GetBarWidth() : CXTPChartBarSeriesStyle
  • GetBaseEdgeCount() : CXTPChart3dFunnelSeriesStyle, CXTPChart3dPyramidSeriesStyle
  • GetBasePoint() : CXTPChartPieSeriesPointViewBase
  • GetBeginDate() : CXTPCalendarMonthView::CMonthViewGrid, CXTPCalendarWeekView
  • GetBeginGroup() : CXTPControl, CXTPStatusBarPane
  • GetBehaviour() : CXTPTaskPanel
  • GetBestFit() : CXTPStatusBarPane
  • GetBestFitMode() : CXTPGridColumn
  • GetBitmap() : CXTPImageManagerIconHandle, CXTPSvgImage
  • GetBitmapBits() : CXTPImageManagerIcon
  • GetBitmapHandle() : CXTPImageManagerImageList
  • GetBitmapMaskColor() : CXTPImageManager
  • GetBitmapPixel() : CXTPResourceImage
  • GetBkBaseColor() : CXTPCalendarEventCategory
  • GetBkColor() : CXTPImageList, CXTPPageScroller
  • GetBkColorAllDayEvents() : CXTPCalendarEventCategory
  • GetBkColorNonWorkCell() : CXTPCalendarEventCategory
  • GetBkColorWorkCell() : CXTPCalendarEventCategory
  • GetBlendingOptions() : CXTPFrameShadow
  • GetBlock() : CXTPTrackControlItem
  • GetBlockCount() : CXTPTrackControlItem
  • GetBlockFromPt() : CXTPSyntaxEditCtrl
  • GetBlocks() : CXTPSyntaxEditLexTextSchema
  • GetBlue() : CXTPChartColor
  • GetBody() : CXTPCalendarEvent
  • GetBoldDaysIdleStepTime_ms() : CXTPCalendarController
  • GetBoldDaysPerIdleStep() : CXTPCalendarController
  • GetBoldFont() : CXTPTabPaintManager
  • GetBookmark() : CXTPGridRecord
  • GetBookmarks() : CXTPSyntaxEditPaintManager
  • GetBool() : CXTPPropertyGridItemBool
  • GetBoolProperty() : CXTPSkinManagerSchema
  • GetBorder() : CXTPChartContent, CXTPChartFunnelSeriesStyleBase, CXTPChartLegend, CXTPChartPieSeriesStyleBase, CXTPChartPyramidSeriesStyleBase, CXTPGridRecordItem, CXTPGridSection, CXTPPageScroller
  • GetBorderActualColor() : CXTPChartAreaSeriesView, CXTPChartFunnelSeriesPointViewBase, CXTPChartPieSeriesStyleBase, CXTPChartPyramidSeriesPointViewBase, CXTPChartRadarAreaSeriesView
  • GetBorderBrush() : CXTPMarkupBorder
  • GetBorderColor() : CXTPCalendarEventCategory, CXTPMarqueeCtrlPaintManager, CXTPPopupItem, CXTPProgressCtrl, CXTPProgressCtrlPaintManager, CXTPSyntaxEditColorSampleText, CXTPTagCloudCtrl
  • GetBorderGap() : CXTPButton
  • GetBorderRect() : CXTPColorSelectorCtrl
  • GetBorders() : CXTPCalendarCaptionBarControl, CXTPCommandBar, CXTPControlGallery, CXTPPopupBar, CXTPRibbonSystemPopupBar, CXTPSkinObjectFrame, CXTPTabToolBar, CXTPToolBar
  • GetBorderStyle() : CXTPButton, CXTPDatePickerControl, CXTPPropertyGrid
  • GetBorderThickness() : CXTPMarkupBorder
  • GetBottom() : CXTPGridThickness, CXTPMarkupThickness, CXTPRectT< T >
  • GetBoundingRect() : CXTPFlowGraphConnection
  • GetBoundRect() : CXTPMarkupGdiPlusTransformationMatrix, CXTPMarkupTransformationMatrix, CXTPMarkupVisual
  • GetBounds() : CXTPChart3dDeviceContext, CXTPChartDiagramView, CXTPChartElementView, CXTPChartPieBase
  • GetBoundView() : CXTPChartDeviceCommand
  • GetBreakParsingEvent() : CXTPSyntaxEditLexTextSchema
  • GetBreakpointBackColor() : CXTPSyntaxEditPaintManager
  • GetBreakpointTextColor() : CXTPSyntaxEditPaintManager
  • GetBrowseButton() : CXTPBrowseEdit
  • GetBrowserObject() : CXTPWebBrowserCtrl, CXTPWebBrowserProvider
  • GetBrush() : CXTPSkinManagerMetrics
  • GetBuffer() : CXTPSyntaxEditBufferManager, CXTPSyntaxEditTextIterator
  • GetBusyStatus() : CXTPCalendarDayViewGroup, CXTPCalendarEvent
  • GetBusyStatusBrush() : CXTPCalendarPaintManager
  • GetButton() : CXTPDatePickerControl, CXTPGridRecordItemEditOptions
  • GetButtonBackColor() : CXTPButton
  • GetButtonColorSet() : CXTPDockingPaneColorSet
  • GetButtonCount() : CXTPDatePickerControl
  • GetButtonDrawRect() : CAppearanceSetPropertyPage2003, CAppearanceSetPropertyPageAccess2007, CAppearanceSetVisualStudio2005, CXTPTabPaintManagerTheme, CXTPTabThemeExcel2003, CXTPTabThemeOffice2000
  • GetButtonFont() : CXTPDatePickerPaintManager
  • GetButtonHeight() : CXTPTabPaintManagerTheme
  • GetButtonLength() : CXTPTabManagerItem, CXTPTabPaintManagerTheme
  • GetButtonRect() : CXTPButton, CXTPCaption, CXTPSkinObjectDateTime, CXTPSpinButtonCtrl
  • GetButtons() : CXTPTabBase
  • GetButtonSize() : CXTPColorSelectorCtrl, CXTPColorSelectorCtrlTheme, CXTPCommandBar, CXTPControl, CXTPPageScroller, CXTPRibbonBar, CXTPRibbonControlSystemPopupBarButton, CXTPRibbonTabPopupToolBar
  • GetButtonState() : CXTPPageScroller
  • GetButtonStyle() : CXTPButton
  • GetButtonText() : CXTPButton
  • GetButtonTextColor() : CXTPButton
  • GetCacheMode() : CXTPCalendarData
  • GetCalendar() : CXTPCalendarController
  • GetCalendarCaptionBarCtrl() : CXTPCalendarControlView
  • GetCalendarControl() : CXTPCalendarTimeLineViewGroup, CXTPCalendarView, CXTPCalendarViewDay, CXTPCalendarViewEvent, CXTPCalendarViewGroup
  • GetCalendarCtrl() : CXTPCalendarCaptionBarTheme, CXTPCalendarControlView
  • GetCalendarOptions() : CXTPCalendarControl, CXTPCalendarView
  • GetCallback() : CXTPBrowseDialog
  • GetCallbackDayMetrics() : CXTPDatePickerControl
  • GetCallbackMessage() : CXTPTrayIcon
  • GetCameraPosition() : CXTPChart3dDiagram
  • GetCanEditCheckboxItem() : CXTPGridRecordItem
  • GetCaption() : CXTPCalendarDayViewDay, CXTPCalendarDayViewTimeScale, CXTPCalendarViewGroup, CXTPCalendarWeekViewDay, CXTPCaptionButton, CXTPControl, CXTPControlAction, CXTPControlGalleryItem, CXTPControlPopup, CXTPDatePickerButton, CXTPDialogBar, CXTPFlowGraphConnection, CXTPFlowGraphConnectionPoint, CXTPFlowGraphElement, CXTPFlowGraphNode, CXTPFlowGraphNodeGroup, CXTPFlowGraphPage, CXTPGridColumn, CXTPGridGroupRow, CXTPGridRecordItem, CXTPGridRecordItemControl, CXTPGridRecordItemDateTime, CXTPGridRecordItemNumber, CXTPGridRecordItemPreview, CXTPGridRecordItemText, CXTPGridRecordItemVariant, CXTPPopupItem, CXTPPropertyGridInplaceButton, CXTPPropertyGridItem, CXTPPropertyGridVerb, CXTPPropertyPage, CXTPRibbonControlSystemButton, CXTPRibbonGroup, CXTPRibbonTab, CXTPShortcutBarItem, CXTPShortcutBarPane, CXTPShortcutBarPaneItem, CXTPStatusBarPane, CXTPTabManagerItem, CXTPTaskPanelItem, CXTPTrackBlock, CXTPTrackControlItem, CXTPTrackMarker
  • GetCaptionButton() : CXTPCaption
  • GetCaptionButtons() : CXTPCommandBarsFrameHook, CXTPDockingPaneBase, CXTPSkinObjectFrame
  • GetCaptionButtonStyle() : CXTPDockingPanePaintManager
  • GetCaptionColor() : CXTPGridRecordItemControl
  • GetCaptionDirection() : CXTPDockingPaneManager
  • GetCaptionGripperRect() : CXTPDockingPaneOffice2003OutlookTheme, CXTPDockingPaneOffice2003Theme, CXTPDockingPanePaintManager
  • GetCaptionGripperWidth() : CXTPTaskPanelPaintManager
  • GetCaptionHeight() : CXTPCommandBarsFrameHook, CXTPDockingPanePaintManager, CXTPRibbonBar, CXTPTaskPanelGroup
  • GetCaptionMetrics() : CXTPPropertyGridItem
  • GetCaptionPopup() : CXTPDialogBar
  • GetCaptionPosition() : CXTPFlowGraphNodeCustom
  • GetCaptionRect() : CXTPDockingPanePaintManager, CXTPFlowGraphNode, CXTPFlowGraphPaintManager, CXTPGridRecordItem, CXTPGridRecordItemPreview, CXTPRibbonBar, CXTPRibbonGroup, CXTPShortcutBarPaneItem, CXTPTaskPanelGroup
  • GetCaptionStyle() : CXTPCaption
  • GetCaptionText() : CXTPCaption
  • GetCaptionTextBlock() : CXTPFlowGraphNode
  • GetCaptionTextRect() : CXTPRibbonBar
  • GetCaptionTextSize() : CXTPTaskPanelItem
  • GetCaptionValue() : CXTPGridGroupRow
  • GetCaptionWidth() : CXTPGridColumn
  • GetCategories() : CXTPCalendarEvent, CXTPPropertyGrid
  • GetCategoriesCount() : CXTPCalendarEvent
  • GetCategory() : CXTPCalendarEventColorListBox, CXTPChartNumberFormat, CXTPControl, CXTPControlAction
  • GetCategoryArray() : CXTPCalendarEventCategoryComboBox
  • GetCategoryInfo() : CXTPCustomizeCommandsPage, CXTPCustomizeKeyboardPage
  • GetCellDateTime() : CXTPCalendarDayViewGroup
  • GetCellDuration() : CXTPCalendarDayView
  • GetCellEvents() : CXTPCalendarDayViewGroup
  • GetCellFromIndex() : CXTPColorSelectorCtrl
  • GetCellNumber() : CXTPCalendarDayView
  • GetCellRect() : CXTPCalendarDayViewGroup
  • GetCellTime() : CXTPCalendarDayView
  • GetCellViewPart() : CXTPCalendarDayViewGroup
  • GetCelRect() : CXTPCalendarMonthView::CMonthViewGrid
  • GetCenter() : CXTPChart3dBox, CXTPChartEllipse, CXTPRectT< T >
  • GetCenterCandidates() : CXTPChart3dBox
  • GetCenterPoint() : CXTPChartPieBase
  • GetCenterShapeConnectorPoint() : CXTPChart3dFunnelSeriesPointView, CXTPChart3dPieSeriesPointView, CXTPChart3dPyramidSeriesPointView
  • GetCenterX() : CXTPMarkupRotateTransform, CXTPMarkupScaleTransform, CXTPMarkupSkewTransform
  • GetCenterY() : CXTPMarkupRotateTransform, CXTPMarkupScaleTransform, CXTPMarkupSkewTransform
  • GetCheck() : CXTPCalendarCaptionBarThemePart, CXTPCheckListBox
  • GetChecked() : CXTPButton, CXTPCalendarEventCategoryComboBox, CXTPControl, CXTPControlAction, CXTPMarkupToggleButton
  • GetCheckedIcon() : CXTPImageManagerIcon
  • GetCheckedItem() : CXTPControlGallery
  • GetCheckedState() : CXTPGridRecordItem
  • GetCheckStyle() : CXTPCheckListBox
  • GetChild() : CXTPDockingPane, CXTPMarkupDecorator
  • GetChildCommand() : CXTPChartDeviceCommand
  • GetChildCommandCount() : CXTPChartDeviceCommand
  • GetChildHandlerAt() : CXTPCalendarCaptionBarTheme, CXTPCalendarView, CXTPCalendarViewDay, CXTPCalendarViewGroup, CXTPCalendarWMHandler
  • GetChildHandlersCount() : CXTPCalendarCaptionBarTheme, CXTPCalendarView, CXTPCalendarViewDay, CXTPCalendarViewGroup, CXTPCalendarWMHandler
  • GetChildRect() : CXTPTabBase
  • GetChildren() : CXTPChartElementView, CXTPMarkupPanel, CXTPSyntaxEditLexClass
  • GetChildrenDyn() : CXTPSyntaxEditLexClass
  • GetChildrenSelfRef() : CXTPSyntaxEditLexClass
  • GetChilds() : CXTPGridRecord, CXTPGridRow, CXTPPropertyGridItem
  • GetChildWndText() : CXTPMDIWndTab, CXTPWindowList
  • GetCilentSite() : CXTPGaugeCtrl
  • GetClassCode() : CXTPSkinManagerClass, CXTPSkinManagerSchema
  • GetClassMap() : CXTPSkinManager
  • GetClassName() : CXTPSkinManagerClass, CXTPSkinObject, CXTPSyntaxEditColorInfo, CXTPSyntaxEditLexClass
  • GetClassSchema() : CXTPSyntaxEditLexTextSchema
  • GetClassSchLoker() : CXTPSyntaxEditLexTextSchema
  • GetClickPoint() : CXTPPropertyGridVerb
  • GetClientBrush() : CXTPComboBox, CXTPEdit, CXTPEditTheme, CXTPSkinObjectFrame
  • GetClientColor() : CXTPTabColorSetOffice2013, CXTPTabColorSetVisualStudio2012, CXTPTabColorSetVisualStudio2015, CXTPTabPaintManagerColorSet
  • GetClientHeight() : CXTPTaskPanel
  • GetClientInterface() : CXTPWebBrowserProvider
  • GetClientMargin() : CXTPDockingPaneManager, CXTPTabPaintManagerTheme, CXTPTabThemeOffice2000
  • GetClientMargins() : CXTPDockingPaneManager
  • GetClientPane() : CXTPDockingPaneManager
  • GetClientPaneRect() : CXTPShortcutBar
  • GetClientRect() : CAppearanceSetVisio, CXTPCalendarTimeLineViewTimeScale, CXTPTabManager, CXTPTabPaintManagerTheme, CXTPTaskPanelGroup
  • GetClientSite() : CXTPMarkupContext
  • GetClientWindow() : CXTPShortcutBarItem
  • GetClipboardFormat() : CXTPTaskPanel
  • GetClipOwner() : CXTPFrameShadow
  • GetClipToBounds() : CXTPMarkupFrameworkElement
  • GetClockSize() : CXTPCalendarPaintManager
  • GetCloseButton() : CXTPDockingPaneTabbedContainer
  • GetCloseButtonRect() : CXTPMessageBarPaintManager, CXTPMessageBarThemeOffice2010, CXTPMessageBarThemeOffice2013
  • GetCloseSubMenuOnClick() : CXTPControl
  • GetCloudStyleArray() : CXTPTagCloudStyleManager
  • GetCltColor() : CXTPScrollBase
  • GetCodePage() : CXTPSyntaxEditBufferManager
  • GetColHeaderHeight() : CXTPCalendarMonthView::CMonthViewGrid
  • GetCollapsableBlocksInfo() : CXTPSyntaxEditCtrl, CXTPSyntaxEditLexTextSchema
  • GetCollapsedBlockLen() : CXTPSyntaxEditCtrl
  • GetCollapsedItemsCount() : CXTPShortcutBar
  • GetCollapsedText() : CXTPSyntaxEditCtrl
  • GetCollapsibleNodes() : CXTPSyntaxEditCtrl
  • GetColor() : CXTPCalendarResource, CXTPChartAxis, CXTPChartAxisGridLines, CXTPChartAxisStrip, CXTPChartBorder, CXTPChartPalette, CXTPChartSeriesPointView, CXTPChartSeriesStyle, CXTPColorDialog, CXTPColorManager, CXTPColorPicker, CXTPControlButtonColor, CXTPControlColorSelector, CXTPControlPopupColor, CXTPFlowGraphConnection, CXTPFlowGraphConnectionPoint, CXTPFlowGraphNode, CXTPFrameShadow, CXTPGridHyperlinkStyle, CXTPPropertyGridItemColor, CXTPPropertyGridItemFont, CXTPSkinManagerMetrics, CXTPSkinObject, CXTPTabManager, CXTPTabManagerItem, CXTPTabPaintManager
  • GetColor2() : CXTPCalendarCaptionBarResourceTheme, CXTPChartPalette, CXTPChartSeriesPointView
  • GetColorCell() : CXTPColorHex
  • GetColorCellBorder() : CXTPCalendarEventCategory
  • GetColorCellList() : CXTPColorSelectorCtrl
  • GetColorInfo() : CXTPSyntaxEditColorTheme
  • GetColorProperty() : CXTPSkinManagerSchema
  • GetColorRect() : CXTPEyeDropper
  • GetColorScheme() : CXTPSyntaxEditCtrl
  • GetColorSet() : CXTPDockingPaneVisualStudio2012Theme, CXTPTabManager, CXTPTabPaintManager, CXTPTabPaintManagerTheme
  • GetColPosX() : CXTPSyntaxEditDrawTextProcessor
  • GetCols() : CXTPDatePickerControl
  • GetColsCount() : CXTPCalendarMonthView::CMonthViewGrid
  • GetColumn() : CXTPMarkupGrid
  • GetColumnCaptionPrefix() : CXTPGridRecordItem
  • GetColumnCount() : CXTPListBase
  • GetColumnDefinitions() : CXTPMarkupGrid
  • GetColumnOffice2007CustomThemeBaseColor() : CXTPGridPaintManager
  • GetColumns() : CXTPGridColumn, CXTPGridControl, CXTPMarkupUniformGrid
  • GetColumnSpan() : CXTPMarkupGrid
  • GetColumnStyle() : CXTPGridPaintManager
  • GetColumnWidth() : CXTPTaskPanel
  • GetComboBoxPopupBar() : CXTPControlComboBox
  • GetComboBoxRect() : CXTPComboBox
  • GetComCtlVersion() : CXTPAuxData, CXTPSystemVersion
  • GetComInitFlags() : CXTPApplication
  • GetCommandBar() : CXTPControl, CXTPControlPopup, CXTPPreviewView
  • GetCommandBarBorders() : CXTPCommandBarsNativeWindows11Theme, CXTPCommandBarsOffice2000Theme, CXTPCommandBarsOffice2003Theme, CXTPPaintManager, CXTPVisualStudio2008Theme, CXTPVisualStudio2010Theme
  • GetCommandBarData() : CXTPCommandBar
  • GetCommandBarFont() : CXTPPaintManager
  • GetCommandBars() : CXTPCommandBar, CXTPCommandBarList, CXTPCommandBarsSiteBase< TBase >, CXTPControlAction, CXTPControls, CXTPCustomizeOptionsPage, CXTPCustomizeSheet, CXTPTabClientWnd
  • GetCommandBarsOptions() : CXTPCommandBars
  • GetCommandsCount() : CXTPSyntaxEditBatchCommand
  • GetCommandsPage() : CXTPCustomizeSheet
  • GetCommandText() : CXTPSyntaxEditCommand
  • GetConfigFile() : CXTPSyntaxEditBufferManager, CXTPSyntaxEditConfigurationManager, CXTPSyntaxEditCtrl
  • GetConnection() : CXTPCalendarCaptionBarTheme, CXTPCalendarControl, CXTPCalendarData, CXTPCalendarRemindersManager, CXTPCalendarResourcesNf, CXTPDatePickerControl, CXTPResourceImages, CXTPSyntaxEditBufferManager, CXTPSyntaxEditConfigurationManager, CXTPSyntaxEditLexParser, CXTPSyntaxEditLexTextSchema
  • GetConnectionPoints() : CXTPFlowGraphNode
  • GetConnections() : CXTPFlowGraphPage
  • GetConnectionsCount() : CXTPFlowGraphConnectionPoint
  • GetConnectionString() : CXTPCalendarData
  • GetConnectorBendPoint() : CXTPChart3dFunnelSeriesLabelView, CXTPChart3dPieSeriesLabelView, CXTPChart3dPyramidSeriesLabelView
  • GetConnectorEndPoint() : CXTPChart3dFunnelSeriesLabelView, CXTPChart3dPieSeriesLabelView, CXTPChart3dPyramidSeriesLabelView
  • GetConnectorEndpointVerticalOffset() : CXTPChart3dFunnelSeriesLabelDeviceCommand, CXTPChart3dPieSeriesLabelDeviceCommand, CXTPChart3dPyramidSeriesLabelDeviceCommand
  • GetConnectorLength() : CXTPChart3dFunnelSeriesLabelDeviceCommand, CXTPChart3dPyramidSeriesLabelDeviceCommand
  • GetConnectorLengthFactor() : CXTPChart3dPieSeriesLabelDeviceCommand
  • GetConnectorStartPoint() : CXTPChart3dFunnelSeriesLabelView, CXTPChart3dPieSeriesLabelView, CXTPChart3dPyramidSeriesLabelView
  • GetConstantLines() : CXTPChartAxis
  • GetConstraintAt() : CXTPPropertyGridItemConstraints
  • GetConstraintEdit() : CXTPPropertyGridItem
  • GetConstraints() : CXTPGridRecordItemEditOptions, CXTPPropertyGridItem
  • GetContainer() : CXTPChartDeviceContext, CXTPDockingPaneBase, CXTPDockingPaneSplitterWnd
  • GetContent() : CXTPChartControl, CXTPChartElement, CXTPMarkupContentControl, CXTPMarkupPage
  • GetContentAppearance() : CXTPChartAppearance
  • GetContentLength() : CXTPTabManagerItem
  • GetContext() : CXTPActiveScriptObjectContext
  • GetContextCaption() : CXTPRibbonTab
  • GetContextColor() : CXTPRibbonTab
  • GetContextHeader() : CXTPRibbonTab
  • GetContextHeaders() : CXTPRibbonBar
  • GetContextMenu() : CXTPCustomizeSheet, CXTPShellTreeBase
  • GetContextMenuEnabled() : CXTPShellExplorerProvider
  • GetContextMenus() : CXTPCommandBars
  • GetContextWindow() : CXTPMarkupContext
  • GetContrastColor() : CXTPColorPicker
  • GetControl() : CXTPChartContainer, CXTPChartControl, CXTPCommandBar, CXTPControlAction, CXTPControlCustom, CXTPFlowGraphConnection, CXTPFlowGraphConnectionPoint, CXTPFlowGraphElement, CXTPFlowGraphNode, CXTPFlowGraphNodeGroup, CXTPFlowGraphPage, CXTPGridColumn, CXTPGridHeader, CXTPGridRow, CXTPTrackMarker
  • GetControlBackColor() : CXTPCommandBarsOffice2013Theme, CXTPDatePickerPaintManager, CXTPGridPaintManager, CXTPPaintManager
  • GetControlComboBox() : CXTPControlComboBoxEditCtrl
  • GetControlCount() : CXTPCommandBar
  • GetControlEdit() : CXTPControlEditCtrl
  • GetControlEditBackColor() : CXTPCommandBarsOffice2013Theme, CXTPCommandBarsVisualStudio2012Theme, CXTPPaintManager, CXTPRibbonTheme
  • GetControlFont() : CXTPPaintManager
  • GetControlGroupOption() : CXTPRibbonGroup
  • GetControlGroupOptionSize() : CXTPRibbonMarkupTheme, CXTPRibbonPaintManager, CXTPRibbonThemeResource
  • GetControlGroupPopup() : CXTPRibbonGroup
  • GetControlHandle() : CXTPTaskPanelGroupItem
  • GetControlHeight() : CXTPPaintManager
  • GetControlMargins() : CXTPTaskPanelPaintManager
  • GetControlPoint() : CXTPFlowGraphConnection
  • GetControlPopup() : CXTPPopupBar
  • GetControlQuickAccess() : CXTPRibbonBar
  • GetControlRect() : CXTPTabManager
  • GetControls() : CXTPCommandBar, CXTPControl, CXTPCustomizeCommandsPage, CXTPRibbonCustomizePage, CXTPRibbonCustomizeQuickAccessPage
  • GetControlStyle() : CXTPToolTipContext
  • GetControlTab() : CXTPRibbonBar
  • GetControlTextColor() : CXTPCommandBarsNativeWindows10Theme, CXTPCommandBarsNativeWindows11Theme, CXTPCommandBarsNativeXPTheme, CXTPCommandBarsOffice2013Theme, CXTPCommandBarsVisualStudio2015Theme, CXTPCommandBarsVisualStudio2017Theme, CXTPCommandBarsVisualStudio2019Theme, CXTPCommandBarsVisualStudio2022Theme, CXTPPaintManager, CXTPRibbonTheme
  • GetControlTextOrientation() : CXTPPaintManager
  • GetCornerRadius() : CXTPMarkupBorder
  • GetCorners() : CXTPChart3dBox
  • GetCount() : CXTPCalendarCustomProperties, CXTPCalendarData::EventsMapByID_T< _TObject >, CXTPCalendarEvents, CXTPCalendarPtrCollectionT< _TObject >, CXTPCalendarTimeZones, CXTPChartElementCollection, CXTPChartElementView, CXTPChartPalette, CXTPCommandBarList, CXTPCommandBars, CXTPControlAction, CXTPControlActions, CXTPControlComboBox, CXTPControls, CXTPFlowGraphConnectionPoints, CXTPFlowGraphConnections, CXTPFlowGraphImages, CXTPFlowGraphNodeGroup, CXTPFlowGraphNodeGroups, CXTPFlowGraphNodes, CXTPFlowGraphPages, CXTPFlowGraphSelectedElements, CXTPFlowGraphUndoGroupCommand, CXTPGridColumnOrder, CXTPGridColumns, CXTPGridRecordItemConstraints, CXTPGridRecords, CXTPGridRows, CXTPGridSelectedRows, CXTPMenuBarMDIMenus, CXTPPropertyGrid, CXTPPropertyGridInplaceButtons, CXTPPropertyGridInplaceControls, CXTPPropertyGridItemConstraints, CXTPPropertyGridItems, CXTPPropertyGridVerbs, CXTPRibbonGroup, CXTPRibbonGroups, CXTPShortcutManagerAccelTable, CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager, CXTPSyntaxEditLineMarksManager, CXTPTaskPanelItems, CXTPTrackMarkers, CXTPTrackSelectedBlocks, CXTPTrackUndoGroupCommand
  • GetCreationTime() : CXTPCalendarEvent
  • GetCurAbsCol() : CXTPSyntaxEditCtrl
  • GetCurArrow() : CXTPSyntaxEditPaintManager
  • GetCurCol() : CXTPSyntaxEditCtrl
  • GetCurColor() : CXTPColorSelectorCtrl
  • GetCurCopy() : CXTPSyntaxEditPaintManager
  • GetCurCRLF() : CXTPSyntaxEditBufferManager
  • GetCurCRLFType() : CXTPSyntaxEditBufferManager
  • GetCurIBeam() : CXTPSyntaxEditPaintManager
  • GetCurLine() : CXTPSyntaxEditPaintManager
  • GetCurMove() : CXTPSyntaxEditPaintManager
  • GetCurNO() : CXTPSyntaxEditPaintManager
  • GetCurrencyString() : CXTPGridGroupRow
  • GetCurrencySymbol() : CXTPChartNumberFormat
  • GetCurrent() : CXTPGaugeMeterType, CXTPPropertyGridItemConstraints
  • GetCurrentColor() : CXTPColorDialog
  • GetCurrentDC() : CXTPChartDeviceCommand
  • GetCurrentDocumentRow() : CXTPSyntaxEditCtrl
  • GetCurrentFocusInFootersRows() : CXTPGridNavigator
  • GetCurrentFocusInHeadersRows() : CXTPGridNavigator
  • GetCurrentIndex() : CXTPEditListBox
  • GetCurrentMenuResource() : CXTPMenuBar
  • GetCurrentSystemTheme() : CXTPCalendarPaintManager, CXTPColorManager, CXTPDockingPanePaintManager, CXTPPaintManager
  • GetCurrentTheme() : CXTPDockingPaneManager, CXTPPaintManager, CXTPPropertyGrid, CXTPShortcutBar, CXTPSyntaxEditConfigurationManager, CXTPSyntaxEditCtrl, CXTPTaskPanel
  • GetCurrentThemeName() : CXTPSkinManager, CXTPWinThemeWrapper
  • GetCurrentTime() : CXTPCalendarUtils
  • GetCurrentTimeZoneInfo() : CXTPCalendarDayView, CXTPCalendarOptions
  • GetCurrentVisibleRow() : CXTPSyntaxEditCtrl
  • GetCurRow() : CXTPSyntaxEditCtrl
  • GetCurSel() : CXTPColorSelectorCtrl, CXTPControlComboBox, CXTPDatePickerControl, CXTPExcelTabCtrl, CXTPRibbonBar, CXTPTabManager, CXTPTagCloudCtrl
  • GetCursorBack() : CXTPDatePickerPaintManager
  • GetCustomDownColor() : CXTPChartHighLowSeriesStyle
  • GetCustomIcons() : CXTPCalendarEvent, CXTPCustomizeSheet
  • GetCustomizationVisible() : CXTPStatusBarPane
  • GetCustomizeCaption() : CXTPRibbonTab
  • GetCustomizeMinHeight() : CXTPControl
  • GetCustomizeMinWidth() : CXTPControl, CXTPControlComboBox, CXTPControlEdit
  • GetCustomLabels() : CXTPChartAxis
  • GetCustomMarkupProperty() : CXTPFlowGraphControl
  • GetCustomProperties() : CXTPCalendarData, CXTPCalendarEvent, CXTPCalendarRecurrencePattern, CXTPCalendarSchedule
  • GetCustomShortcutText() : CXTPControl, CXTPControlAction
  • GetCustomTitle() : CXTPColorSelectorCtrl
  • GetCustomTitleBrush() : CXTPDockingPanePaintManager
  • GetCustomToolTipPosition() : CXTPMarkupContext
  • GetCustomTrait() : CXTPGaugeTraits
  • GetCustomUpColor() : CXTPChartHighLowSeriesStyle
  • GetDarkColor() : CXTPChartColor, CXTPFlowGraphPaintManager
  • GetDashed() : CXTPFlowGraphConnection
  • GetDashStyle() : CXTPChartLineStyle
  • GetData() : CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE >, CXTPBrowseDialog, CXTPControlGalleryItem, CXTPHexEdit, CXTPMatrix< T >, CXTPTabManagerItem, XTP_CALENDAR_RECURRENCE_OPTIONS
  • GetDataLock() : CXTPNotifyConnection, CXTPNotifyConnectionMT
  • GetDataLoker() : CXTPSyntaxEditLexTextSchema
  • GetDataManager() : CXTPGridControl, CXTPSyntaxEditDoc, CXTPSyntaxEditView
  • GetDataProvider() : CXTPCalendarControl, CXTPCalendarEvent, CXTPCalendarResource, CXTPCalendarResourcesManager, CXTPCalendarViewGroup
  • GetDataProvider_ConnStr() : CXTPCalendarResourcesManager
  • GetDataProvidersCount() : CXTPCalendarResourcesManager
  • GetDataSize() : CXTPSyntaxEditBatchCommand, CXTPSyntaxEditBufferCommand, CXTPSyntaxEditCommand, CXTPSyntaxEditReplaceStringCommand, CXTPSyntaxEditUndoRedoManager
  • GetDataSource() : CXTPCalendarData, CXTPGridDataManager
  • GetDataStream() : CXTPImageManagerVectorImageHandle
  • GetDate() : CXTPDatePickerItemDay, CXTPPropertyGridItemDate
  • GetDateFormat() : CXTPCalendarUtils
  • GetDatePicker() : CXTPCalendarController
  • GetDatePickerControl() : CXTPDatePickerItemDay
  • GetDateTime() : CXTPDateEdit
  • GetDateTimeCell() : CXTPCalendarDayViewGroup
  • GetDay() : CXTPCalendarDayView, CXTPDatePickerItemMonth, CXTPPropertyGridItemDate
  • GetDayBackColor() : CXTPDatePickerPaintManager
  • GetDayCount() : CXTPDatePickerItemMonth
  • GetDayDate() : CXTPCalendarMonthView::CMonthViewGrid, CXTPCalendarViewDay
  • GetDayEventsRect() : CXTPCalendarMonthViewDay, CXTPCalendarWeekViewDay
  • GetDayHeaderFormat() : CXTPCalendarView
  • GetDayHeaderHeight() : CXTPCalendarWeekView
  • GetDayHeight() : CXTPCalendarWeekView
  • GetDayIndex() : CXTPCalendarViewDay
  • GetDayMetrics() : CXTPDatePickerControl
  • GetDayOfWeekCount() : CXTPCalendarUtils
  • GetDayOfWeekIndex() : CXTPCalendarUtils
  • GetDayOfWeekLocaleStringId() : CXTPCalendarUtils
  • GetDayOfWeekMask() : CXTPCalendarUtils
  • GetDayOfWeekName() : CXTPDatePickerControl
  • GetDayRect() : CXTPCalendarMonthView::CMonthViewGrid, CXTPCalendarViewDay
  • GetDaysOfWeekBackColor() : CXTPDatePickerPaintManager
  • GetDaysOfWeekTextColor() : CXTPDatePickerPaintManager
  • GetDaysOfWeekTextFont() : CXTPDatePickerPaintManager
  • GetDayTextColor() : CXTPDatePickerPaintManager
  • GetDayTextFont() : CXTPDatePickerPaintManager
  • GetDayTextFontBold() : CXTPDatePickerPaintManager
  • GetDayView() : CXTPCalendarControl, CXTPCalendarDayViewTimeScale
  • GetDayWidth() : CXTPCalendarWeekView
  • GetDecimalPlaces() : CXTPChartNumberFormat
  • GetDefaultAccelerator() : CXTPShortcutManager
  • GetDefaultBlendingOptions() : CXTPFrameShadowManager
  • GetDefaultButtonSize() : CXTPMessageBarPaintManager
  • GetDefaultButtonStyle() : CXTPCommandBar
  • GetDefaultCfgFilePath() : CXTPSyntaxEditCtrl
  • GetDefaultCharFormat() : CXTPControlComboBox, CXTPControlEdit
  • GetDefaultClipOwner() : CXTPFrameShadowManager
  • GetDefaultColor() : CXTPColorPicker, CXTPFrameShadowManager
  • GetDefaultColorSet() : CAppearanceSetPropertyPage2003, CAppearanceSetPropertyPage2007, CAppearanceSetPropertyPageAccess2007, CAppearanceSetPropertyPageFlat, CAppearanceSetStateButtons, CXTPTabPaintManagerTheme, CXTPTabThemeFlat, CXTPTabThemeNativeWindows10, CXTPTabThemeNativeWindows11, CXTPTabThemeOffice2000, CXTPTabThemeOffice2013, CXTPTabThemeVisualStudio2003, CXTPTabThemeVisualStudio2010, CXTPTabThemeVisualStudio2012, CXTPTabThemeVisualStudio2015, CXTPTabThemeVisualStudio2017, CXTPTabThemeVisualStudio2019, CXTPTabThemeVisualStudio2022
  • GetDefaultCommandBarSize() : CXTPPaintManager
  • GetDefaultFileAssociations() : IXTPPreviewProvider
  • GetDefaultForeground() : CXTPMarkupContext
  • GetDefaultInnerSize() : CXTPFrameShadowManager
  • GetDefaultItem() : CXTPPopupBar
  • GetDefaultItemClass() : CXTPTaskPanelGroupItems, CXTPTaskPanelGroups, CXTPTaskPanelItems
  • GetDefaultLogFont() : CXTPMarkupContext
  • GetDefaultMarkupTemplate() : CXTPFlowGraphControl
  • GetDefaultMenuItem() : CXTPTrayIcon
  • GetDefaultMenuResource() : CXTPMenuBar
  • GetDefaultOffset() : CXTPFrameShadowManager
  • GetDefaultOuterSize() : CXTPFrameShadowManager
  • GetDefaultPaneOptions() : CXTPDockingPaneManager
  • GetDefaultSmoothingMode() : CXTPMarkupContext
  • GetDefaultTextSmoothing() : CXTPMarkupContext
  • GetDefaultTransparency() : CXTPFrameShadowManager
  • GetDefaultValue() : CXTPPropertyGridItem
  • GetDefColor() : CXTPColorSelectorCtrl
  • GetDelay() : CXTPSyntaxEditToolTipCtrl
  • GetDelayEditTimer() : CXTPGridControl
  • GetDeleteButton() : CXTPEditListBoxToolBar
  • GetDelimiters() : CXTPSyntaxEditAutoCompleteWnd
  • GetDepth() : CXTPChart3dPieSeriesStyle, CXTPChartPieSeriesStyleBase
  • GetDescription() : CXTPControl, CXTPControlAction, CXTPControlGalleryItem, CXTPPropertyGridItem
  • GetDescriptionText() : CXTPTrackBlock
  • GetDesiredSize() : CXTPMarkupUIElement
  • GetDiagram() : CXTPChartAxis, CXTPChartDiagramView, CXTPChartSeries
  • GetDiagram2DAppearance() : CXTPChartAppearance
  • GetDiagram3DAppearance() : CXTPChartAppearance
  • GetDiff_Months() : CXTPCalendarUtils
  • GetDimensionCount() : CXTPGaugeMeterType
  • GetDir() : CXTPSplitPath
  • GetDirection() : CXTPChartLegend, CXTPDockingPaneAutoHidePanel, CXTPDockingPaneSidePanel
  • GetDisabledBackColor() : CXTPHexEdit
  • GetDisabledHighlightBackColor() : CXTPHexEdit
  • GetDisabledHighlightTextColor() : CXTPHexEdit
  • GetDisabledIcon() : CXTPImageManagerIcon
  • GetDisabledTextColor() : CXTPHexEdit
  • GetDisableReorderColumnsCount() : CXTPGridControl
  • GetDiscreteSelectionCount() : CXTPCalendarView
  • GetDiscreteSelectionValue() : CXTPCalendarView
  • GetDisplayName() : CXTPBrowseDialog, CXTPSyntaxEditPropertiesPageColor
  • GetDisplayOptions() : CXTPGridColumn
  • GetDisplaySettings() : CXTPMultiMonitor
  • GetDisplayString() : CXTPCalendarTimeZone
  • GetDividerColor() : CXTPGridSection
  • GetDividerPos() : CXTPPropertyGridView
  • GetDividerPosition() : CXTPGridSection
  • GetDividerRect() : CXTPGridSection
  • GetDividerStyle() : CXTPGridSection
  • GetDock() : CXTPMarkupDockPanel
  • GetDockBar() : CXTPCommandBars, CXTPToolBar
  • GetDocking() : CXTPChartTitle
  • GetDockingContext() : CXTPDockingPaneManager
  • GetDockingContextStickerStyle() : CXTPDockingPaneManager
  • GetDockingPaneManager() : CXTPDockingPaneBase, CXTPDockingPaneSplitterWnd
  • GetDockingSite() : CXTPDockingPane, CXTPDockingPaneBase
  • GetDockState() : CXTPCommandBars
  • GetDocument() : CXTPSyntaxEditView
  • GetDocumentRow() : CXTPSyntaxEditCtrl
  • GetDomain() : CXTPChartFunnelSeriesViewBase, CXTPChartPieSeriesViewBase, CXTPChartPyramidSeriesViewBase
  • GetDontDropCursor() : CXTPGridHeader
  • GetDouble() : CXTPPropertyGridItemDouble
  • GetDoubleClickedItem() : CXTPShellListBase
  • GetDownButton() : CXTPEditListBoxToolBar
  • GetDownColor() : CXTPChartHighLowSeriesStyle
  • GetDpiScaled() : CXTPImageManagerIconHandle
  • GetDragControl() : CXTPCommandBars, CXTPCustomizeSheet
  • GetDraggingColumn() : CXTPGridHeader
  • GetDraggingEventNew() : CXTPCalendarView
  • GetDraggingEventOrig() : CXTPCalendarView
  • GetDraggingMode() : CXTPCalendarView
  • GetDragSensitivityX() : CXTPGridControl
  • GetDragSensitivityY() : CXTPGridControl
  • GetDragText() : CXTPTaskPanelGroupItem
  • GetDrawDisabledText() : CXTPStatusBar
  • GetDrawFooterDivider() : CXTPGridColumn
  • GetDrawFooterRowsVGrid() : CXTPGridColumn
  • GetDrawHeaderDivider() : CXTPGridColumn
  • GetDrawHeaderRowsVGrid() : CXTPGridColumn
  • GetDrawingObjectFactory() : CXTPChartDeviceContext
  • GetDrawStyle() : CXTPHeaderCtrlTheme
  • GetDrawTextProcessor() : CXTPSyntaxEditCtrl
  • GetDrive() : CXTPSplitPath
  • GetDropDownItemCount() : CXTPPropertyGridItem
  • GetDropDownListStyle() : CXTPControlComboBox
  • GetDropDownWidth() : CXTPControlComboBox
  • GetDropListItemNumber() : CXTPGridInplaceButton, CXTPGridInplaceList
  • GetDropMarkerFlags() : CXTPGridControl
  • GetDroppedState() : CXTPControlComboBox
  • GetDropperRect() : CXTPEyeDropper
  • GetDropSource() : CXTPCommandBars
  • GetDropTarget() : CXTPPageScroller
  • GetDuration() : CXTPCalendarEvent, CXTPCalendarRecurrencePattern
  • GetDurationMinutes() : CXTPCalendarEvent, CXTPCalendarRecurrencePattern, CXTPCalendarUtils
  • GetEdirControl() : CXTPSyntaxEditFindReplaceDlg
  • GetEdit() : CXTPCalendarEventColorListBox
  • GetEditBuddy() : CXTPSpinButtonCtrl
  • GetEditBuffer() : CXTPSyntaxEditCtrl, CXTPSyntaxEditView
  • GetEditCtrl() : CXTPControlComboBox, CXTPControlEdit, CXTPSyntaxEditView
  • GetEditFont() : CXTPSyntaxEditPropertiesPageFont
  • GetEditGroup() : CXTPEditListBox
  • GetEditHeight() : CXTPRibbonPaintManager
  • GetEditHint() : CXTPControlAction, CXTPControlComboBox, CXTPControlEdit
  • GetEditIconId() : CXTPControlComboBox, CXTPControlEdit
  • GetEditingSubjectFromEditor() : CXTPCalendarViewEvent
  • GetEditItemText() : CXTPEditListBox
  • GetEditOptions() : CXTPGridColumn, CXTPGridRecordItem
  • GetEditorStyle() : CXTPPropertyGridItemColor
  • GetEditStyle() : CXTPControlComboBox, CXTPControlEdit, CXTPPropertyGridItem
  • GetEditText() : CXTPControlComboBox, CXTPControlEdit
  • GetEffectiveParent() : CXTPSyntaxEditCtrl
  • GetElementRect() : CXTPGridControl
  • GetEnable() : CXTPGridRecordItemControl
  • GetEnabled() : CXTPControl, CXTPControlAction, CXTPControlGalleryItem, CXTPDockingPane, CXTPPropertyGridInplaceButton, CXTPTaskPanelItem
  • GetEncodedXML() : CXTPPropExchangeXMLNode
  • GetEnd_disp() : CXTPSyntaxEditSelection
  • GetEnd_str() : CXTPSyntaxEditSelection
  • GetEndAfterOccurrences() : CXTPCalendarRecurrencePattern
  • GetEndOccurrenceTime() : CXTPCalendarRecurrencePattern
  • GetEndTagBeginXLC() : CXTPSyntaxEditLexTextBlock
  • GetEndTagEndXLC() : CXTPSyntaxEditLexTextBlock
  • GetEndTime() : CXTPCalendarEvent
  • GetEndTimeRect() : CXTPCalendarViewEvent
  • GetEngine() : CXTPActiveScriptObjectContext
  • GetEntries() : CXTPChartPalette
  • GetEntryNode() : CXTPPropExchangeXMLNode
  • GetEnum() : CXTPPropertyGridItemEnum
  • GetEnumerator() : CXTPPropExchange, CXTPPropExchangeXMLNode
  • GetEnumProperty() : CXTPSkinManagerSchema
  • GetEOL() : CXTPSyntaxEditTextIterator
  • GetErrorBar() : CXTPChartSeriesStyle
  • GetErrorCode() : CXTPRegistryManager
  • GetErrorMessage() : CXTPRegistryManager
  • GetEvent() : CXTPCalendarData, CXTPCalendarReminder, CXTPCalendarViewEvent
  • GetEventBackColor() : CXTPCalendarOffice2013Theme, CXTPCalendarPaintManager
  • GetEventCaptionFormat() : CXTPCalendarMonthView
  • GetEventCategories() : CXTPCalendarData
  • GetEventDurationInPixels() : CXTPCalendarTimeLineViewEvent
  • GetEventDurationMin() : CXTPCalendarDayView, CXTPCalendarView
  • GetEventEdgeColor() : CXTPCalendarOffice2013Theme
  • GetEventID() : CXTPCalendarEvent
  • GetEventPeriodDays() : CXTPCalendarEvent, CXTPCalendarUtils
  • GetEventPlaceCount() : CXTPCalendarDayViewEvent
  • GetEventPlaceNumber() : CXTPCalendarViewEvent
  • GetEventPlacePos() : CXTPCalendarDayViewEvent
  • GetEventRect() : CXTPCalendarViewEvent
  • GetEventsCountInAllDayArea() : CXTPCalendarDayViewGroup
  • GetEventSink() : CXTPWebBrowserCtrl
  • GetEventsRect() : CXTPCalendarDayViewEvent
  • GetEventTimelinePlaceNumber() : CXTPCalendarViewEvent
  • GetEventTimeWidth() : CXTPCalendarMonthView
  • GetExceptionData() : CXTPActiveScriptEngine
  • GetExceptionInfo() : CXTPActiveScriptEngine
  • GetExceptions() : CXTPCalendarRecurrencePattern
  • GetExecuteOnPressInterval() : CXTPControl
  • GetExpandButtonCheck() : CXTPCalendarCaptionBarTheme
  • GetExpanded() : CXTPControl
  • GetExpandedClientHeight() : CXTPTaskPanelGroup
  • GetExpandedLinesCount() : CXTPShortcutBar
  • GetExpandedLinesHeight() : CXTPShortcutBar
  • GetExpandSignRect() : CXTPCalendarViewDay
  • GetExpandSignSize() : CXTPCalendarPaintManager
  • GetExplodedDistancePercent() : CXTPChartPieSeriesStyleBase
  • GetExt() : CXTPSplitPath
  • GetExtendedColors() : CXTPColorSelectorCtrl
  • GetExtendedCount() : CXTPColorSelectorCtrl
  • GetExtendedStyle() : CXTPListBase
  • GetExtensionRoot() : CXTPMarkupContext
  • GetExtent() : CXTPIconHandle, CXTPImageManagerIcon, CXTPImageManagerIconHandle, CXTPImageManagerResource, CXTPResourceImage, CXTPSkinImage, CXTPSkinImages
  • GetExternal() : CXTPWebBrowserCtrl
  • GetExtLogPen() : CXTPPen
  • GetFadedIcon() : CXTPImageManagerIcon
  • GetFileExt() : CXTPSyntaxEditBufferManager, CXTPSyntaxEditTextIterator
  • GetFileName() : CXTPSyntaxEditColorTheme
  • GetFillAcrossXAxis() : CXTPChartAreaSeriesStyle
  • GetFillMode() : CXTPChartFillStyle
  • GetFillStyle() : CXTPChartAreaSeriesStyle, CXTPChartAxisStrip, CXTPChartFunnelSeriesStyleBase, CXTPChartLegend, CXTPChartPyramidSeriesStyleBase, CXTPChartRadarAreaSeriesStyle
  • GetFilterEditCtrl() : CXTPGridHeader
  • GetFilterText() : CXTPGridControl
  • GetFinalRect() : CXTPMarkupUIElement
  • GetFinanceStyleAppearance() : CXTPChartAppearance
  • GetFindReplaceDlg() : CXTPSyntaxEditView
  • GetFinishPoint() : CXTPChartPieBase
  • GetFirst() : CXTPControls
  • GetFirstClockRect() : CXTPCalendarViewEvent
  • GetFirstColumn() : CXTPMarkupUniformGrid
  • GetFirstDayOfWeek() : CXTPCalendarControl, CXTPCalendarMonthView::CMonthViewGrid, CXTPDatePickerControl
  • GetFirstLineMark() : CXTPSyntaxEditLineMarksManager
  • GetFirstModule() : CXTPToolhelpApi
  • GetFirstMruID() : CXTPControlRecentFileList, CXTPRibbonControlSystemRecentFileList
  • GetFirstPane() : CXTPDockingPaneBaseContainer
  • GetFirstParamNamePosition() : CXTPSyntaxEditColorInfo
  • GetFirstSelectedItem() : CXTPTreeBase
  • GetFirstSelectedRowPosition() : CXTPGridSelectedRows
  • GetFirstShadowPosition() : CXTPFrameShadowManager
  • GetFirstThread() : CXTPToolhelpApi
  • GetFirstView() : CXTPSyntaxEditDoc
  • GetFirstVisibleAllDayEvent() : CXTPCalendarDayViewGroup
  • GetFirstVisibleColumn() : CXTPGridColumns
  • GetFirstVisibleItem() : CXTPTaskPanelItems
  • GetFirstWeekOfYearDays() : CXTPCalendarControl, CXTPCalendarUtils, CXTPDatePickerControl
  • GetFlags() : CXTPCommandBar, CXTPControl, CXTPFrameShadowManager, CXTPGridRecordItemControl, CXTPPropertyGridItem, CXTPPropertyGridItemFlags, CXTPTabClientWnd, CXTPTabManagerNavigateButton
  • GetFlagsString() : CXTPPropertyGridItemFlags
  • GetFlatStyle() : CXTPButton, CXTPComboBox, CXTPEdit, CXTPProgressCtrl
  • GetFloatingFramesOpacity() : CXTPDockingPaneManager
  • GetFName() : CXTPSplitPath
  • GetFocusedColumn() : CXTPGridControl
  • GetFocusedControl() : CXTPRibbonBackstageView
  • GetFocusedItem() : CXTPTaskPanel, CXTPTreeBase
  • GetFocusedLink() : CXTPTaskDialogLinkCtrl
  • GetFocusedRecordItem() : CXTPGridControl
  • GetFocusedRow() : CXTPGridControl, CXTPGridRows, CXTPGridSection, CXTPGridSections
  • GetFocusedRowIndex() : CXTPGridRows
  • GetFolderData() : CXTPDirWatcher
  • GetFolderItemPath() : CXTPShellTreeBase
  • GetFolderPath() : CXTPDirWatcher
  • GetFont() : CXTPChartAxisConstantLine, CXTPChartAxisLabel, CXTPChartAxisTitle, CXTPChartLegend, CXTPChartSeriesLabel, CXTPChartTextElement, CXTPChartTitle, CXTPFontManager, CXTPGridRecordItem, CXTPGridRecordItemControl, CXTPPropertyGridItemFont, CXTPStatusBar, CXTPSyntaxEditPaintManager, CXTPTabPaintManager, CXTPToolTipContext, XTP_DAYITEM_METRICS
  • GetFontBold() : CXTPFontManager
  • GetFontCharset() : CXTPResourceManager
  • GetFontFamily() : CXTPMarkupTextBlock
  • GetFontHeight() : CXTPCheckListBox, CXTPCommandBars, CXTPRibbonBar, CXTPRibbonPaintManager
  • GetFontItalic() : CXTPFontManager
  • GetFontItalicBold() : CXTPFontManager
  • GetFontItemHeight() : CXTPFontCtrlBase
  • GetFontLineNumber() : CXTPSyntaxEditPaintManager
  • GetFontList() : CXTPFontEnum
  • GetFontProperty() : CXTPSkinManagerSchema
  • GetFontSize() : CXTPMarkupTextBlock
  • GetFontStyle() : CXTPMarkupTextBlock
  • GetFontText() : CXTPSyntaxEditPaintManager
  • GetFontToolTip() : CXTPSyntaxEditPaintManager
  • GetFontVertical() : CXTPFontManager
  • GetFontVerticalBold() : CXTPFontManager
  • GetFontWeight() : CXTPMarkupTextBlock
  • GetFooterAlignment() : CXTPGridColumn
  • GetFooterFont() : CXTPGridColumn
  • GetFooterHeight() : CXTPGridPaintManager
  • GetFooterText() : CXTPGridColumn
  • GetForeground() : CXTPMarkupControl, CXTPMarkupTextBlock
  • GetForegroundColor() : CXTPPreviewCtrl, IXTPPreviewHost
  • GetFormat() : CXTPChartAxisLabel, CXTPChartSeriesLabel
  • GetFormatString() : CXTPGridGroupRow, CXTPGridRecordItem
  • GetFormula() : CXTPGridGroupRow, CXTPGridRecordItem
  • GetFrameAccelerator() : CXTPCustomizeKeyboardPage
  • GetFrameBorder() : CXTPFrameThemeOffice2007System, CXTPRibbonMarkupFrameTheme
  • GetFrameCaptionAccentTextColor() : CXTPFramePaintManager
  • GetFrameCaptionActiveColor() : CXTPFramePaintManager
  • GetFrameCaptionHeight() : CXTPFramePaintManager
  • GetFrameHook() : CXTPCommandBars, CXTPRibbonBar
  • GetFrameLargeIcon() : CXTPFramePaintManager
  • GetFramePaintManager() : CXTPCommandBarsFrameHook, CXTPCommandBarsModernUITheme, CXTPPaintManager, CXTPResourceTheme, CXTPRibbonPaintManager
  • GetFrameReBar() : CXTPCommandBars
  • GetFrameSite() : CXTPCommandBar
  • GetFrameSmallIcon() : CXTPFramePaintManager
  • GetFrameWnd() : CXTPMDIWndTab
  • GetFreeHeight() : CXTPGridRecord
  • GetFreezeColsDividerStyle() : CXTPGridPaintManager
  • GetFreezeColumnsCount() : CXTPGridControl
  • GetFreezeColumnsIndex() : CXTPGridControl
  • GetFrozenColWidth() : CXTPHeaderCtrl
  • GetFullColScrollInfo() : CXTPGridHeader
  • GetFullName() : CXTPSplitPath
  • GetFullPath() : CXTPSplitPath
  • GetFullyQualPidl() : CXTPShellPidl
  • GetG() : CXTPChartColor
  • GetGalleryPaintManager() : CXTPControlGallery, CXTPPaintManager
  • GetGlobalContext() : CXTPActiveScriptEngine
  • GetGlobalPaintManager() : CXTPPaintManager
  • GetGlyphs() : CXTPGridPaintManager
  • GetGlyphSize() : CXTPButton
  • GetGpImage() : CXTPMarkupGdiPlusImage
  • GetGradientAngle() : CXTPChartFillStyle
  • GetGreen() : CXTPChartColor
  • GetGrid() : CXTPCalendarMonthView, CXTPPropertyGridInplaceButton, CXTPPropertyGridItem
  • GetGridAreaRows() : CXTPGridControl
  • GetGridCtrl() : CXTPGridFilterEditControl, CXTPGridSubListControl, CXTPGridView
  • GetGridHeader() : CXTPGridColumns, CXTPGridControl
  • GetGridLines() : CXTPChartAxis
  • GetGridSpacing() : CXTPChartAxis
  • GetGridStyle() : CXTPGridControl
  • GetGridView() : CXTPPropertyGrid
  • GetGripperPosition() : CXTPExcelTabCtrl
  • GetGripperRect() : CXTPShortcutBar
  • GetGroup() : CXTPFlowGraphNode
  • GetGroupByHeight() : CXTPGridHeader
  • GetGroupCaption() : CXTPGridRecordItem
  • GetGroupCaptionHeight() : CXTPRibbonPaintManager
  • GetGroupCaptionID() : CXTPGridRecordItem
  • GetGroupCaptionValue() : CXTPGridRecordItem, CXTPGridRecordItemDateTime, CXTPGridRecordItemNumber, CXTPGridRecordItemVariant
  • GetGroupColors() : CXTPTaskPanelPaintManager
  • GetGroupCount() : CXTPTaskPanel
  • GetGroupHeight() : CXTPCalendarTimeLineViewGroup
  • GetGroupIconSize() : CXTPTaskPanel
  • GetGroupIndex() : CXTPCalendarViewGroup
  • GetGroupInnerMargins() : CXTPTaskPanelPaintManager
  • GetGroupLevel() : CXTPGridRow
  • GetGroupOuterMargins() : CXTPTaskPanelPaintManager
  • GetGroupPriority() : CXTPGridRecordItem
  • GetGroups() : CXTPFlowGraphPage, CXTPRibbonTab, CXTPTaskPanel
  • GetGroupsHeight() : CXTPRibbonBar
  • GetGroupsOrder() : CXTPGridColumns
  • GetGroupSpacing() : CXTPTaskPanelPaintManager
  • GetGroupsRect() : CXTPRibbonBar, CXTPRibbonTabPopupToolBar
  • GetHalfAngle() : CXTPChartPieBase
  • GetHandle() : CXTPModuleHandle, CXTPResourceImages, CXTPTabManagerItem
  • GetHasCheckbox() : CXTPGridRecordItem
  • GetHatchStyle() : CXTPChartFillStyle
  • GetHDC() : CXTPChartDeviceContext
  • GetHeaderAlignment() : CXTPGridColumn
  • GetHeaderClipBox() : CXTPTabPaintManagerTheme, CXTPTabThemeOffice2000
  • GetHeaderDateFormat() : CXTPCalendarTimeLineViewTimeScalePart
  • GetHeaderHeight() : CXTPCalendarTimeLineViewTimeScalePart, CXTPGridPaintManager, CXTPTabPaintManagerTheme
  • GetHeaderIndent() : CXTPGridControl
  • GetHeaderMargin() : CAppearanceSetPropertyPage2003, CAppearanceSetPropertyPageAccess2007, CAppearanceSetVisualStudio2005, CXTPTabPaintManagerTheme, CXTPTabThemeExcel2003
  • GetHeaderOffset() : CXTPTabManager
  • GetHeaderRect() : CAppearanceSetVisio, CXTPCalendarViewGroup, CXTPTabBaseTheme, CXTPTabManager, CXTPTabPaintManagerTheme
  • GetHeaderTextFont() : CXTPDatePickerPaintManager
  • GetHeadPosition() : CXTPDockingPaneBaseContainer, CXTPShadowManager
  • GetHeight() : CXTPControl, CXTPGridRecordItemControl, CXTPGridRow, CXTPGridSection, CXTPImageManagerIcon, CXTPMarkupFrameworkElement, CXTPMatrix< T >, CXTPMessageBar, CXTPMessageBarPaintManager, CXTPPropertyGridItem, CXTPResourceImage, CXTPShortcutBarPaneItem, CXTPSkinImage, CXTPTabClientDraggingContents
  • GetHeightMode() : CXTPGridSection
  • GetHeightPercent() : CXTPTrackBlock
  • GetHeightToWidthRatio() : CXTPChartFunnelSeriesStyleBase, CXTPChartPyramidSeriesStyleBase
  • GetHelpBackColor() : CXTPPropertyGrid
  • GetHelpForeColor() : CXTPPropertyGrid
  • GetHelpHeight() : CXTPPropertyGrid
  • GetHelpId() : CXTPControl, CXTPControlAction
  • GetHelpTrackingId() : CXTPCommandBars
  • GetHexParam() : CXTPSyntaxEditColorInfo
  • GetHiddenColIndex() : CXTPSplitterWnd
  • GetHiddenControls() : CXTPCommandBars
  • GetHiddenRowIndex() : CXTPSplitterWnd
  • GetHideFlags() : CXTPControl
  • GetHighlightBackColor() : CXTPHexEdit
  • GetHighlightedControl() : CXTPRibbonBackstageView
  • GetHighlightedGroup() : CXTPRibbonBar
  • GetHighlightOffset() : CXTPTaskPanelPaintManager
  • GetHighlightTextColor() : CXTPHexEdit
  • GetHighlightToday() : CXTPDatePickerControl
  • GetHighlightTodayBackColor() : CXTPDatePickerThemeOffice2013
  • GetHighlightTodayBorderColor() : CXTPDatePickerThemeOffice2013
  • GetHighlightTodayColor() : CXTPDatePickerPaintManager
  • GetHighlightTodayTextColor() : CXTPDatePickerThemeOffice2013
  • GetHiliteBackColor() : CXTPSyntaxEditPaintManager
  • GetHiliteTextColor() : CXTPSyntaxEditPaintManager
  • GetHint() : CXTPGridFilterEditControl
  • GetHistory() : CXTPFlowGraphControl
  • GetHitTestRect() : CXTPTaskPanelGroup, CXTPTaskPanelGroupItem, CXTPTaskPanelItem
  • GetHolePercent() : CXTPChartPieBase, CXTPChartPieSeriesStyleBase
  • GetHorizontalAlignment() : CXTPChartLegend, CXTPMarkupFrameworkElement
  • GetHorzScrollBar() : CXTPSyntaxEditCtrl, CXTPSyntaxEditView
  • GetHost() : CXTPPreviewProviderBase
  • GetHotIcon() : CXTPImageManagerIcon
  • GetHotItem() : CXTPShortcutBar, CXTPTaskPanel
  • GetHotTrackStyle() : CXTPTaskPanel
  • GetHours() : CXTPTimeEdit
  • GetHoverColor() : CXTPHyperLink
  • GetHoverRect() : CXTPCalendarTip, CXTPGridTip
  • GetHScrollStep() : CXTPGridControl
  • GetHyperlinkAt() : CXTPGridRecordItem
  • GetHyperlinks() : CXTPGridRecordItem
  • GetHyperlinksCount() : CXTPGridRecordItem
  • GetIcon() : CXTPButton, CXTPDockingPane, CXTPDockingPaneManager, CXTPFlowGraphImage, CXTPImageEditorDlg, CXTPImageManagerIcon, CXTPImageManagerIconHandle, CXTPImageManagerIconSet, CXTPImageManagerImageList, CXTPMarkupGdiPlusImage, CXTPTrayIcon
  • GetIconFont() : CXTPPaintManager
  • GetIconHandle() : CXTPImageManagerImageList
  • GetIconID() : CXTPDockingPane, CXTPGridColumn
  • GetIconId() : CXTPControl, CXTPControlAction, CXTPRibbonGroup, CXTPShortcutBarItem
  • GetIconIndent() : CXTPTreeBase
  • GetIconIndex() : CXTPGridInplaceButton, CXTPGridRecordItem, CXTPGridRecordItemControl, CXTPPopupItem, CXTPPropertyGridInplaceButton, CXTPStatusBarPane, CXTPTaskPanelItem
  • GetIconOffset() : CXTPPopupItem
  • GetIconPadding() : CXTPTaskPanelItem
  • GetIcons() : CXTPImageManagerIconSet
  • GetIconSet() : CXTPImageManager
  • GetIconsInfo() : CXTPPaintManager
  • GetIconSize() : CXTPCommandBar, CXTPControl, CXTPImageManagerImageList, CXTPRibbonBar, CXTPRibbonControlSystemPopupBarButton, CXTPRibbonTabPopupToolBar
  • GetID() : CXTPCalendarEventCategory, CXTPCalendarSchedule, CXTPControl, CXTPControlAction, CXTPControlGalleryItem, CXTPDockingPane, CXTPDockingPaneCaptionButton, CXTPFlowGraphConnectionPoint, CXTPFlowGraphNode, CXTPFlowGraphPage, CXTPFlowGraphUndoCommand, CXTPGridInplaceButton, CXTPImageManagerIcon, CXTPImageManagerIconSet, CXTPPopupControl, CXTPPopupItem, CXTPPropertyGridInplaceButton, CXTPPropertyGridItem, CXTPPropertyGridVerb, CXTPRibbonGroup, CXTPRibbonTab, CXTPShortcutBarItem, CXTPStatusBarPane, CXTPTabManagerNavigateButton, CXTPTaskPanelItem, CXTPTrackUndoCommand
  • GetImage() : CXTPBrowseDialog, CXTPControl, CXTPControlGalleryItem, CXTPFlowGraphConnectionPoint, CXTPFlowGraphImage, CXTPFlowGraphNode, CXTPImageManager, CXTPPopupItem, CXTPPropertyGridInplaceButton, CXTPPropertyGridItemConstraint, CXTPShortcutBarItem, CXTPStatusBarPane, CXTPTaskPanelItem
  • GetImageAlignment() : CXTPButton
  • GetImageColor() : CXTPResourceImages
  • GetImageColorKey() : CXTPMarkupContext
  • GetImageCount() : CXTPImageList
  • GetImageGap() : CXTPButton
  • GetImageIndex() : CXTPControlGalleryItem, CXTPFlowGraphConnectionPoint, CXTPFlowGraphNode, CXTPTabManagerItem
  • GetImageInfo() : CXTPImageList
  • GetImageInt() : CXTPResourceImages
  • GetImageList() : CXTPImageManager, CXTPImageManagerIcon
  • GetImageManager() : CXTPCommandBar, CXTPCommandBars, CXTPControl, CXTPControlGalleryItems, CXTPDockingPaneManager, CXTPFlowGraphImages, CXTPGridControl, CXTPHeaderCtrl, CXTPMarkupContext, CXTPPasswordPeek, CXTPPopupControl, CXTPPropertyGrid, CXTPPropertyGridView, CXTPRibbonBackstageView, CXTPShortcutBar, CXTPStatusBar, CXTPSyntaxEditAutoCompleteWnd, CXTPTabControl, CXTPTaskPanel
  • GetImageRect() : CXTPResourceImages
  • GetImages() : CXTPFlowGraphControl, CXTPFramePaintManager, CXTPImageManager, CXTPResourceTheme, CXTPRibbonPaintManager, CXTPSkinManagerClass
  • GetImageSize() : CXTPButton, CXTPResourceImages
  • GetImageString() : CXTPResourceImages
  • GetImageValue() : CXTPResourceImages
  • GetImageWidth() : CXTPControlGalleryItem
  • GetImportance() : CXTPCalendarEvent
  • GetInactiveHiliteBackColor() : CXTPSyntaxEditPaintManager
  • GetInactiveHiliteTextColor() : CXTPSyntaxEditPaintManager
  • GetIndent() : CXTPChartTitle, CXTPGridColumn, CXTPGridControl, CXTPPropertyGridItem
  • GetIndentColumn() : CXTPGridColumns
  • GetIndentLevel() : CXTPGridHeader
  • GetIndex() : CXTPCalendarEventColorEdit, CXTPCalendarTimeZone, CXTPChartAxis, CXTPControl, CXTPControlGalleryItem, CXTPGridColumn, CXTPGridRecord, CXTPGridRecordItem, CXTPGridRecordItemConstraint, CXTPGridRecordItemControl, CXTPGridRow, CXTPGridSection, CXTPPropertyGridInplaceButton, CXTPPropertyGridItem, CXTPPropertyGridItemConstraint, CXTPPropertyGridVerb, CXTPRibbonGroup, CXTPStatusBarPane, CXTPTabManagerItem, CXTPTaskPanelItem, CXTPTaskPanelItems, CXTPTrackBlock
  • GetINIFileName() : CXTPRegistryManager
  • GetIniFileName() : CXTPSkinManagerResourceFile
  • GetInitFlags() : CXTPComInitializer
  • GetInitializationStatus() : CXTPComInitializer
  • GetInitialTextRect() : CXTPChartRotatedTextPainterBase
  • GetInlines() : CXTPMarkupTextBlock
  • GetInnerBounds() : CXTPChartDiagramDomain, CXTPChartFunnelSeriesView, CXTPChartFunnelSeriesViewBase, CXTPChartPieSeriesViewBase, CXTPChartPyramidSeriesView, CXTPChartPyramidSeriesViewBase
  • GetInnerMargins() : CXTPTaskPanelGroup
  • GetInnerSize() : CXTPFrameShadow
  • GetInplaceButtons() : CXTPGridControl, CXTPPropertyGridItem
  • GetInplaceControls() : CXTPPropertyGridItem
  • GetInPlacedEditValue() : CXTPPropertyGridItem
  • GetInplaceEdit() : CXTPGridControl, CXTPPropertyGridItem
  • GetInplaceList() : CXTPGridControl, CXTPPropertyGridItem
  • GetInputBoxText() : CXTPTaskDialog
  • GetInputConnectionAt() : CXTPFlowGraphConnectionPoint
  • GetInputConnectionsCount() : CXTPFlowGraphConnectionPoint
  • GetInputNode() : CXTPFlowGraphConnection
  • GetInputPoint() : CXTPFlowGraphConnection
  • GetInsertMarkColor() : CXTPTreeBase
  • GetInsideRect() : CXTPSplitterWndEx
  • GetInstance() : CXTPSingletonPointer
  • GetInstanceAddRef() : CXTPPaintManager
  • GetInterface() : CXTPSmartPtrInternalT< _TObject >
  • GetInterlacedColor() : CXTPChartAxis
  • GetInterlacedColor2() : CXTPChartAxis
  • GetInterlacedFillStyle() : CXTPChartAxis
  • GetInternalArgumentValue() : CXTPChartSeriesPoint
  • GetInternalName() : CXTPGridColumn
  • GetInternalValue() : CXTPChartSeriesPointView
  • GetIntProperty() : CXTPSkinManagerSchema
  • GetInvalidateRect() : CXTPTaskPanelGroup, CXTPTaskPanelItem
  • GetInvertedStep() : CXTPChartStepLineSeriesStyle
  • GetIsCanHScrollGroupsLeft() : CXTPCalendarDayView
  • GetIsCanHScrollGroupsRight() : CXTPCalendarDayView
  • GetItem() : CXTPControlGallery, CXTPControlGalleryItems, CXTPGridInplaceButton, CXTPGridInplaceEdit, CXTPGridRecord, CXTPMarkupDefinitionCollection, CXTPMarkupUIElementCollection, CXTPPopupControl, CXTPPropertyGrid, CXTPPropertyGridInplaceButton, CXTPPropertyGridInplaceEdit, CXTPPropertyGridView, CXTPShortcutBar, CXTPShortcutBarPane, CXTPTabClientWnd, CXTPTabManager, CXTPTabManagerNavigateButton, CXTPTrackBlock
  • GetItemBackColor() : CXTPPropertyGridPaintManager, CXTPTreeBase, CXTPTreeTheme
  • GetItemBold() : CXTPTreeBase
  • GetItemCaption() : CXTPControlGallery, CXTPDockingPaneWindowSelect, CXTPGridSubListControl, CXTPTabManager
  • GetItemColor() : CXTPDockingPane, CXTPDockingPanePanelColorSet2012, CXTPDockingPaneTabColorSet2012, CXTPDockingPaneTabColorSet2013, CXTPTabClientWnd, CXTPTabColorSetOffice2013, CXTPTabColorSetVisualStudio2012, CXTPTabColorSetVisualStudio2015, CXTPTabManager, CXTPTabPaintManagerColorSet, CXTPTreeBase
  • GetItemColumn() : CXTPGridSubListControl
  • GetItemControls() : CXTPGridRecordItem
  • GetItemCount() : CXTPControlGallery, CXTPControlGalleryItems, CXTPExcelTabCtrl, CXTPGridRecord, CXTPPopupControl, CXTPShortcutBar, CXTPTabClientWnd, CXTPTabManager, CXTPTaskPanelGroup
  • GetItemData() : CXTPControlComboBox, CXTPGridRecordItem, CXTPPropertyGridItem, CXTPShortcutBarItem, CXTPTaskPanelItem
  • GetItemDescription() : CXTPDockingPaneWindowSelect
  • GetItemDrawRect() : CXTPControlGallery
  • GetItemExpanderRect() : CXTPTreeBase
  • GetItemFont() : CXTPPropertyGridPaintManager, CXTPTaskPanelItem, CXTPTaskPanelPaintManager, CXTPTreeBase
  • GetItemGroup() : CXTPTaskPanelGroupItem, CXTPTaskPanelItem
  • GetItemHeight() : CXTPGridPaintManager
  • GetItemIcon() : CXTPShellPidl, CXTPTabClientWnd, CXTPTabManager
  • GetItemIconPadding() : CXTPTaskPanelPaintManager
  • GetItemIconRect() : CXTPTreeBase
  • GetItemIconSize() : CXTPTaskPanel, CXTPTaskPanelGroup
  • GetItemID() : CXTPStatusBar
  • GetItemIndex() : CXTPGridColumn
  • GetItemInnerMargins() : CXTPTaskPanelPaintManager
  • GetItemLayout() : CXTPTaskPanel, CXTPTaskPanelGroup
  • GetItemMetrics() : CXTPGridControl, CXTPGridRecord, CXTPGridRecordItem, CXTPGridRecordItemPreview, CXTPGridRow, CXTPPropertyGridPaintManager, CXTPTabManager
  • GetItemOuterMargins() : CXTPTaskPanelPaintManager
  • GetItemPane() : CXTPDockingPaneTabbedContainer
  • GetItemPath() : CXTPDockingPaneWindowSelect, CXTPShellListBase
  • GetItemPreview() : CXTPGridRecord
  • GetItemRect() : CXTPExcelTabCtrl, CXTPGridRow, CXTPPropertyGridItem, CXTPShortcutBarItem, CXTPStatusBar, CXTPTaskPanelGroupItem
  • GetItemRow() : CXTPTabManagerItem
  • GetItems() : CXTPControlGallery, CXTPTaskPanelGroup
  • GetItemsBorderHeight() : CXTPPropertyGridPaintManager
  • GetItemsInRow() : CXTPTaskPanelGroup
  • GetItemSize() : CXTPControlGalleryItems, CXTPShortcutBar
  • GetItemsLength() : CXTPDockingPaneAutoHidePanel, CXTPTabManager
  • GetItemsRect() : CXTPControlGallery
  • GetItemState() : CXTPTreeBase
  • GetItemStateIconRect() : CXTPTreeBase
  • GetItemText() : CXTPCalendarViewEvent, CXTPExcelTabCtrl, CXTPTabClientWnd
  • GetItemTextBody() : CXTPCalendarViewEvent
  • GetItemTextColor() : CXTPPropertyGridPaintManager, CXTPTreeBase, CXTPTreeTheme
  • GetItemTextEndTime() : CXTPCalendarViewEvent
  • GetItemTextEventTimeMax() : CXTPCalendarView
  • GetItemTextExtent() : CXTPMarkupTreeCtrl
  • GetItemTextLocation() : CXTPCalendarViewEvent
  • GetItemTextStartTime() : CXTPCalendarViewEvent
  • GetItemTextSubject() : CXTPCalendarViewEvent
  • GetItemTooltip() : CXTPTabClientWnd, CXTPTabManager
  • GetItemWindow() : CXTPExcelTabCtrl
  • GetKey() : CXTPControlAction
  • GetKeyboardManager() : CXTPCommandBars
  • GetKeyboardTip() : CXTPControl, CXTPControlAction, CXTPRibbonTab
  • GetKeyboardTipsBackColor() : CXTPRibbonBackstageView
  • GetKeyboardTipsFont() : CXTPRibbonBackstageView
  • GetKeyboardWindowSelectClass() : CXTPDockingPaneManager
  • GetKeyNameText() : CXTPShortcutManager
  • GetLabel() : CXTPCalendarEvent, CXTPCalendarEventColorListBox, CXTPChartAxis, CXTPChartSeriesStyle
  • GetLabelAnchorOrigin() : CXTPChart3dFunnelSeriesLabelView, CXTPChart3dPieSeriesLabelView, CXTPChart3dPyramidSeriesLabelView
  • GetLabelAnchorPoint() : CXTPChart3dFunnelSeriesLabelView, CXTPChart3dPieSeriesLabelView, CXTPChart3dPyramidSeriesLabelView
  • GetLabelID() : CXTPCalendarEvent, CXTPCalendarEventLabelComboBox
  • GetLabelList() : CXTPCalendarData
  • GetLabelRect() : CXTPChart3dFunnelSeriesLabelDeviceCommand, CXTPChart3dPieSeriesLabelDeviceCommand, CXTPChart3dPyramidSeriesLabelDeviceCommand
  • GetLabelsView() : CXTPChartDiagramView
  • GetLabelText() : CXTPChartSeriesPoint
  • GetLabelWidth() : CXTPControlComboBox, CXTPControlEdit
  • GetLanguage() : CXTPMarkupXtpScript
  • GetLargeIconSize() : CXTPCommandBar
  • GetLastChildFill() : CXTPMarkupDockPanel
  • GetLastChildRow() : CXTPGridRow
  • GetLastClockRect() : CXTPCalendarViewEvent
  • GetLastComError() : CXTPGridDataManager
  • GetLastITEM() : CXTPShellPidl
  • GetLastItem() : CXTPTreeBase
  • GetLastKnownChildView() : CXTPTabExBase
  • GetLastLineMark() : CXTPSyntaxEditLineMarksManager
  • GetLastModificationTime() : CXTPCalendarEvent
  • GetLastPane() : CXTPDockingPaneBaseContainer
  • GetLastParsedBlock() : CXTPSyntaxEditLexTextSchema
  • GetLastRqstEditCol() : CXTPGridControl
  • GetLastRqstEditRow() : CXTPGridControl
  • GetLastSelectedDate() : CXTPCalendarView
  • GetLastSelectedTabClientSticker() : CXTPTabClientContext
  • GetLastSelectedViewEvent() : CXTPCalendarView
  • GetLastTargetTabClient() : CXTPTabClientContext
  • GetLastVisibleAllDayEvent() : CXTPCalendarDayViewGroup
  • GetLastVisibleColumn() : CXTPGridColumns
  • GetLastVisibleItem() : CXTPTaskPanelItems
  • GetLastVisibleRect() : CXTPCalendarTimeLineViewEvent
  • GetLastWorkspace() : CXTPTabClientContext
  • GetLayout() : CXTPDockingPaneManager, CXTPTabManager, CXTPTabPaintManager
  • GetLayoutClip() : CXTPMarkupUIElement, CXTPMarkupVisual
  • GetLBCurSel() : CXTPCalendarEventCategoryComboBox, CXTPSyntaxEditColorComboBox
  • GetLBText() : CXTPControlComboBox, CXTPSyntaxEditPropertiesPageFont
  • GetLeft() : CXTPGridThickness, CXTPMarkupThickness, CXTPRectT< T >
  • GetLeftOffset() : CXTPGridControl
  • GetLegend() : CXTPChartContent
  • GetLegendAppearance() : CXTPChartContentAppearance
  • GetLegendItem() : CXTPChartSeries
  • GetLegendName() : CXTPChartAxisConstantLine, CXTPChartAxisStrip, CXTPChartLegendItemView, CXTPChartSeriesPointView
  • GetLegendText() : CXTPChartSeries, CXTPChartSeriesPoint
  • GetLegendView() : CXTPChartContentView
  • GetLength() : CXTPChartAxisTickMarks, CXTPTrackBlock
  • GetLexConfigurationManager() : CXTPSyntaxEditBufferManager, CXTPSyntaxEditCtrl, CXTPSyntaxEditView
  • GetLexParser() : CXTPSyntaxEditBufferManager, CXTPSyntaxEditView
  • GetLightAmbientColor() : CXTPChart3dDeviceContext
  • GetLightDiffuseColor() : CXTPChart3dDeviceContext
  • GetLightModelAmbientColor() : CXTPChart3dDeviceContext
  • GetLightPosition() : CXTPChart3dDeviceContext
  • GetLightSpecularColor() : CXTPChart3dDeviceContext
  • GetLineColor() : CXTPChartSeriesLabel
  • GetLineLen() : CXTPSyntaxEditTextIterator
  • GetLineLenBytes() : CXTPSyntaxEditTextIterator
  • GetLineLength() : CXTPChartSeriesLabel
  • GetLineMarkAt() : CXTPSyntaxEditLineMarksManager
  • GetLineMarksManager() : CXTPSyntaxEditBufferManager, CXTPSyntaxEditCtrl
  • GetLineNodeRect() : CXTPSyntaxEditCtrl
  • GetLineNumberBackColor() : CXTPSyntaxEditPaintManager
  • GetLineNumbers() : CXTPSyntaxEditCtrl
  • GetLineNumberTextColor() : CXTPSyntaxEditPaintManager
  • GetLinesIntersection() : CXTPMathUtils
  • GetLineStyle() : CXTPChartAxisConstantLine, CXTPChartAxisGridLines, CXTPChartFastLineSeriesStyle, CXTPChartLineSeriesStyle, CXTPChartRadarLineSeriesStyle
  • GetLineText() : CXTPSyntaxEditBufferManager, CXTPSyntaxEditCtrl
  • GetLineTextLength() : CXTPSyntaxEditBufferManager
  • GetLineTextLengthC() : CXTPSyntaxEditBufferManager
  • GetLineThickness() : CXTPChartHighLowSeriesStyle
  • GetLinkColor() : CXTPHyperLink
  • GetLinkCursor() : CXTPHyperLink
  • GetLinkPos() : CXTPTaskDialogLinkCtrl
  • GetListBackColor() : CXTPListBase
  • GetListBox() : CXTPSyntaxEditTipComboBox
  • GetListBoxCtrl() : CXTPControlComboBox, CXTPControlComboBoxList
  • GetListBoxText() : CXTPControlComboBox
  • GetListControlBackColor() : CXTPDatePickerPaintManager
  • GetListControlTextColor() : CXTPDatePickerPaintManager
  • GetListControlTextFont() : CXTPDatePickerPaintManager
  • GetListCtrl() : CXTPControlListBox
  • GetListIconId() : CXTPControlComboBox
  • GetListSize() : CXTPDatePickerList
  • GetListStyle() : CXTPListBox
  • GetListTextColor() : CXTPListBase
  • GetLiteral() : CXTPGridColumn
  • GetLocale() : CXTPChartNumberFormat
  • GetLocaleLong() : CXTPCalendarUtils
  • GetLocaleString() : CXTPCalendarUtils
  • GetLocation() : CXTPCalendarEvent, CXTPFlowGraphNode, CXTPRectT< T >
  • GetLockUpdateCount() : CXTPGridControl
  • GetLogBrush() : CXTPBrush
  • GetLogFont() : CXTPFont, CXTPFontEnum
  • GetLogicalChild() : CXTPMarkupVisual
  • GetLogicalChildrenCount() : CXTPMarkupVisual
  • GetLogPen() : CXTPPen
  • GetLumBarRect() : CXTPColorLum
  • GetLunaColor() : CXTPColorManager
  • GetMargin() : CXTPMarkupFrameworkElement, CXTPTagCloudCtrl, CXTPToolTipContext
  • GetMargins() : CXTPDialogBar, CXTPStatusBarPane, CXTPTaskPanel, CXTPTaskPanelGroupItem
  • GetMarker() : CXTPChartPointSeriesStyle, CXTPChartRadarPointSeriesStyle
  • GetMarkers() : CXTPTrackControl
  • GetMarkerSize() : CXTPChartLegend
  • GetMarkupCaption() : CXTPPropertyGridItem
  • GetMarkupContext() : CXTPButton, CXTPCalendarControl, CXTPChartContent, CXTPCommandBarsModernUITheme, CXTPControlGalleryItems, CXTPFlowGraphControl, CXTPGridControl, CXTPGridRecord, CXTPGridRecords, CXTPImageManagerIcon, CXTPImageManagerVectorImageHandle, CXTPMarkupTreeCtrl, CXTPMessageBar, CXTPPopupControl, CXTPPropertyGrid, CXTPStatusBar, CXTPTabManager, CXTPTaskPanel, CXTPTipOfTheDay, IXTPMarkupDeviceDependentImageSite
  • GetMarkupDescription() : CXTPPropertyGridItem
  • GetMarkupTableRowIndex() : CXTPFlowGraphNode
  • GetMarkupTemplate() : CXTPPropertyGridItem
  • GetMarkupText() : CXTPCalendarViewEvent
  • GetMarkupUIElement() : CXTPButton, CXTPCalendarViewEvent, CXTPControlGalleryItem, CXTPFlowGraphConnectionPoint, CXTPGridColumn, CXTPGridRecordItem, CXTPPopupItem, CXTPStatusBarPane, CXTPTabManagerItem, CXTPTaskPanelItem
  • GetMarkupValue() : CXTPPropertyGridItem
  • GetMarkupVisualElementRect() : CXTPFlowGraphNode
  • GetMask() : CXTPGridColumn
  • GetMaskColor() : CXTPImageManager
  • GetMaskedText() : CXTPMaskEditT< TBase >, CXTPPropertyGridItem
  • GetMasterEvent() : CXTPCalendarRecurrencePattern
  • GetMasterEventID() : CXTPCalendarRecurrencePattern
  • GetMasterTextSchema() : CXTPSyntaxEditBufferManager
  • GetMaterialDiffuseColor() : CXTPChart3dDeviceContext
  • GetMaterialEmissionColor() : CXTPChart3dDeviceContext
  • GetMaterialShininess() : CXTPChart3dDeviceContext
  • GetMaterialSpecularColor() : CXTPChart3dDeviceContext
  • GetMatrix() : CXTPMarkupGdiPlusTransformationMatrix
  • GetMax() : CXTPGaugeMeterType, CXTPPropertyGridInplaceSlider, CXTPPropertyGridInplaceSpinButton
  • GetMaxAvailWidth() : CXTPGridHeader
  • GetMaxBackOffset() : CXTPSyntaxEditTextIterator
  • GetMaxCharSize() : CXTPSystemVersion
  • GetMaxColumnWidth() : CXTPGridHeader
  • GetMaxConnections() : CXTPFlowGraphConnectionPoint
  • GetMaxDayPOS() : CXTPCalendarMonthView::CMonthViewGrid
  • GetMaxHeight() : CXTPMarkupFrameworkElement
  • GetMaxHeightFont() : CXTPCalendarUtils
  • GetMaximum() : CXTPChartSeriesPointCollection
  • GetMaximumColSize() : CXTPListBase
  • GetMaxLabelWidth() : CXTPChartFunnelSeriesViewBase, CXTPChartPieSeriesViewBase, CXTPChartPyramidSeriesViewBase
  • GetMaxLength() : CXTPTrackBlock
  • GetMaxLineTextLength() : CXTPSyntaxEditBufferManager
  • GetMaxMonthDay() : CXTPCalendarUtils
  • GetMaxPoint() : CXTPChart3dBox
  • GetMaxPreviewLines() : CXTPGridPaintManager
  • GetMaxSelCount() : CXTPDatePickerControl
  • GetMaxSize() : CXTPChartBubbleSeriesStyle, CXTPSearchOptionsCtrl
  • GetMaxTipWidth() : CXTPToolTipContext
  • GetMaxValue() : CXTPChartAxisRange
  • GetMaxWidth() : CXTPFontEnum, CXTPGridColumn, CXTPMarkupFrameworkElement
  • GetMDIMenus() : CXTPMenuBar
  • GetMeetingGlyphRect() : CXTPCalendarViewEvent
  • GetMenuBar() : CXTPCommandBars
  • GetMenuID() : CXTPTabExBase
  • GetMenuItem() : CXTPShortcutListBox
  • GetMenuTitleBar() : CXTPCommandBars
  • GetMenuWidth() : CXTPRibbonBackstageView
  • GetMergeHeight() : CXTPGridRow
  • GetMessageBarPaintManager() : CXTPMessageBar, CXTPPaintManager
  • GetMessageRect() : CXTPMessageBar
  • GetMeterType() : CXTPGaugeCtrl
  • GetMetrics() : CXTPPropertyGridItem, CXTPSkinManager, CXTPSkinManagerSchema, CXTPSkinObject
  • GetMiddleScrollBeginDate() : CXTPCalendarMonthView::CMonthViewGrid
  • GetMin() : CXTPGaugeMeterType, CXTPPropertyGridInplaceSlider, CXTPPropertyGridInplaceSpinButton
  • GetMinColumnWidth() : CXTPCalendarDayView
  • GetMinHeight() : CXTPMarkupFrameworkElement
  • GetMinimum() : CXTPChartSeriesPointCollection
  • GetMinimumClientHeight() : CXTPShortcutBarPane, CXTPTaskPanelGroup
  • GetMinimumColSize() : CXTPListBase
  • GetMinimumGroupClientHeight() : CXTPTaskPanel
  • GetMinimumVisibleWidth() : CXTPRibbonBar
  • GetMinimumWidth() : CXTPRibbonGroup
  • GetMinLength() : CXTPTrackBlock
  • GetMinMaxInfo() : CXTPDockingPane, CXTPDockingPaneBase, CXTPDockingPaneMiniWnd, CXTPDockingPaneSidePanel, CXTPDockingPaneSplitterContainer, CXTPDockingPaneTabbedContainer, CXTPResize
  • GetMinMaxRange() : CXTPDatePickerDaysCollection
  • GetMinorColor() : CXTPChartAxisGridLines
  • GetMinorCount() : CXTPChartAxis
  • GetMinorLength() : CXTPChartAxisTickMarks
  • GetMinorLineStyle() : CXTPChartAxisGridLines
  • GetMinorThickness() : CXTPChartAxisTickMarks
  • GetMinPoint() : CXTPChart3dBox
  • GetMinReqRect() : CXTPDatePickerControl, CXTPPropertyGridInplaceMonthCal
  • GetMins() : CXTPTimeEdit
  • GetMinSize() : CXTPChartBubbleSeriesStyle, CXTPFlowGraphNode, CXTPSearchOptionsCtrl
  • GetMinutesBeforeStart() : CXTPCalendarReminder
  • GetMinValue() : CXTPChartAxisRange
  • GetMinWidth() : CXTPGridColumn, CXTPMarkupFrameworkElement
  • GetModernBitmap() : CXTPCommandBarsOffice2003Theme
  • GetModuleHandle() : CXTPModuleHandle, CXTPSkinManagerResourceFile
  • GetModulePath() : CXTPSyntaxEditCtrl
  • GetModuleState() : CXTPApplication, CXTPModuleHandle
  • GetMonth() : CXTPDatePickerItemDay, CXTPDatePickerItemMonth, CXTPPropertyGridItemDate
  • GetMonthDelta() : CXTPDatePickerControl
  • GetMonthHeaderBackColor() : CXTPDatePickerPaintManager
  • GetMonthHeaderTextColor() : CXTPDatePickerPaintManager
  • GetMonthInterval() : CXTPDatePickerList
  • GetMonthName() : CXTPDatePickerControl
  • GetMonthRange() : CXTPDatePickerControl
  • GetMonthView() : CXTPCalendarControl
  • GetMouseCursorMode() : CXTPTrackControl
  • GetMouseManager() : CXTPCommandBars
  • GetMouseMode() : CXTPGridControl
  • GetMouseScrollLines() : CXTPGridControl
  • GetMovingAverage() : CXTPChartSeriesPointCollection
  • GetMultiDayEventFlags() : CXTPCalendarViewEvent
  • GetMultiLinesCount() : CXTPPropertyGridItem
  • GetName() : CXTPCalendarEventCategory, CXTPCalendarResource, CXTPCalendarSchedule, CXTPChartAxisStrip, CXTPChartSeries, CXTPFlowGraphConnectionPoint, CXTPGlobalAtom, CXTPMarkupStaticExtension, CXTPModuleHandle, CXTPShellPidl
  • GetNamedItemData() : CXTPActiveScriptEngine
  • GetNaN() : CXTPMathUtils
  • GetNativeGdiObject() : CXTPBrush, CXTPFont, CXTPImageList, CXTPPen
  • GetNativeImage() : CXTPMarkupGdiImage
  • GetNavigateButton() : CXTPTabManager
  • GetNavigateButtonCount() : CXTPTabManager
  • GetNavigateButtons() : CXTPTabManager, CXTPTabManagerItem
  • GetNavigator() : CXTPGridControl, CXTPPropertySheet
  • GetNeededScrollDirection() : CXTPCalendarDayView
  • GetNewButton() : CXTPEditListBoxToolBar
  • GetNewTabPositon() : CXTPTabClientWnd
  • GetNext() : CXTPControlGallery, CXTPControls, CXTPDockingPaneBaseContainer, CXTPGridRows, CXTPPropExchangeEnumerator, CXTPShadowManager
  • GetNextCustomTrait() : CXTPGaugeTraits
  • GetNextElement() : CXTPCalendarData::EventsMapByID_T< _TObject >
  • GetNextFocusableColumn() : CXTPGridControl
  • GetNextFreeTempID() : CXTPCalendarData
  • GetNextInColumn() : CXTPControlGallery
  • GetNextInPage() : CXTPControlGallery
  • GetNextInRow() : CXTPControlGallery
  • GetNextItem() : CXTPTaskPanel, CXTPTreeBase
  • GetNextLineMark() : CXTPSyntaxEditLineMarksManager
  • GetNextModule() : CXTPToolhelpApi
  • GetNextParamName() : CXTPSyntaxEditColorInfo
  • GetNextPidlItem() : CXTPShellPidl
  • GetNextPoint() : CXTPChartSeriesPoint
  • GetNextProperty() : CXTPCalendarCustomProperties
  • GetNextReminderTime() : CXTPCalendarReminder
  • GetNextSelectedItem() : CXTPTreeBase
  • GetNextSelectedRow() : CXTPGridSelectedRows
  • GetNextShadow() : CXTPFrameShadowManager
  • GetNextSiblingRow() : CXTPGridRow
  • GetNextThread() : CXTPToolhelpApi
  • GetNextTimeEditByTAB() : CXTPCalendarDayView, CXTPCalendarView
  • GetNextTipString() : CXTPTipOfTheDay
  • GetNextVisibleColumn() : CXTPGridHeader
  • GetNextVisibleGroup() : CXTPTaskPanel
  • GetNextVisibleIndex() : CXTPTaskPanelItems
  • GetNextVisibleItem() : CXTPTaskPanelGroup
  • GetNextVisualBlock() : CXTPGridColumn
  • GetNode() : CXTPFlowGraphConnectionPoint
  • GetNodeBoundingRectangle() : CXTPFlowGraphPaintManager
  • GetNodes() : CXTPFlowGraphPage
  • GetNonMonthDayBackColor() : CXTPDatePickerPaintManager
  • GetNonMonthDayTextColor() : CXTPDatePickerPaintManager
  • GetNonMonthDayTextFont() : CXTPDatePickerPaintManager
  • GetNormalAndSelectedIcons() : CXTPShellListBase, CXTPShellTreeBase
  • GetNormalEnd_disp() : CXTPSyntaxEditSelection
  • GetNormalEnd_str() : CXTPSyntaxEditSelection
  • GetNormalStart_disp() : CXTPSyntaxEditSelection
  • GetNormalStart_str() : CXTPSyntaxEditSelection
  • GetNotificationWnd() : CXTPTrayIcon
  • GetNotifyOnClear() : CXTPGridSelectedRows
  • GetNumber() : CXTPPropertyGridItemNumber
  • GetNumberOfPages() : IXTPPreview
  • GetNumCols() : CXTPColorSelectorCtrl
  • GetNumRowsOnLine() : CXTPGridControl
  • GetObject() : CXTPGdiObject
  • GetObjectType() : CXTPGdiObject
  • GetOccReminders() : CXTPCalendarRecurrencePattern
  • GetOccurrences() : CXTPCalendarRecurrencePattern
  • GetOccurrencesDates() : CXTPCalendarRecurrencePattern
  • GetOffset() : CXTPFrameShadow, CXTPGridColumns
  • GetOffsetItem() : CXTPTaskPanelGroup
  • GetOffsetSize() : CXTPSearchOptionsCtrl
  • GetOldVisibleIndex() : CXTPGridColumn
  • GetOneNoteColor() : CXTPTabPaintManager
  • GetOnScreenSch() : CXTPSyntaxEditCtrl
  • GetOpacity() : CXTPMarkupUIElement, CXTPMarkupVisual
  • GetOption() : CXTPPropertyGridItemOption
  • GetOptions() : CXTPBrowseDialog, CXTPDockingPane
  • GetOrientation() : CXTPMarkupStackPanel, CXTPMarkupWrapPanel
  • GetOriginalAccelerator() : CXTPShortcutManager
  • GetOriginalControls() : CXTPControls
  • GetOriginalSize() : CXTPMarkupImage
  • GetOSVersionInfo() : CXTPSystemVersion
  • GetOuterCenterConnectorPoint() : CXTPChart3dFunnelSeriesPointView, CXTPChart3dPieSeriesPointView, CXTPChart3dPyramidSeriesPointView
  • GetOuterMargins() : CXTPTaskPanelGroup
  • GetOuterSize() : CXTPFrameShadow
  • GetOutputConnectionAt() : CXTPFlowGraphConnectionPoint
  • GetOutputConnectionsCount() : CXTPFlowGraphConnectionPoint
  • GetOutputNode() : CXTPFlowGraphConnection
  • GetOutputPoint() : CXTPFlowGraphConnection
  • GetOverlap() : CXTPExcelTabCtrl
  • GetOverwriteFlag() : CXTPSyntaxEditBufferManager
  • GetOwner() : CXTPBrowseDialog, CXTPChartElement, CXTPFrameShadow, CXTPTaskPanelItems
  • GetOwnerRecord() : CXTPGridRecords
  • GetOwnerSite() : CXTPCommandBar
  • GetOwnerWnd() : CXTPCalendarCaptionBarTheme
  • GetPadding() : CXTPMarkupBorder, CXTPMarkupControl, CXTPMarkupTextBlock, CXTPMessageBarPaintManager, CXTPStatusBarPane, CXTPTagCloudCtrl
  • GetPage() : CXTPFlowGraphConnection, CXTPFlowGraphConnectionPoint, CXTPFlowGraphElement, CXTPFlowGraphNode, CXTPFlowGraphNodeGroup, CXTPFlowGraphNodeGroups, CXTPPropertySheet
  • GetPageBorderStyle() : CXTPPropertySheet
  • GetPageBrush() : CXTPPropertyPageNavigator
  • GetPageColor() : CXTPPropertyPageNavigator
  • GetPageCount() : CXTPPropertySheet
  • GetPageIndex() : CXTPPropertySheet
  • GetPageRect() : CXTPFlowGraphPage, CXTPPropertySheet
  • GetPages() : CXTPFlowGraphControl
  • GetPageTitle() : CXTPSyntaxEditView
  • GetPaintManager() : CXTPCalendarCaptionBarTheme, CXTPCalendarCaptionBarThemePart, CXTPCalendarControl, CXTPCalendarView, CXTPCommandBar, CXTPCommandBars, CXTPCommandBarsFrameHook, CXTPControl, CXTPControlTabWorkspace, CXTPDatePickerControl, CXTPDockingPaneAutoHidePanel, CXTPDockingPaneBase, CXTPDockingPaneManager, CXTPDockingPaneTabbedContainer, CXTPFlowGraphControl, CXTPGridControl, CXTPGridHeader, CXTPGridView, CXTPMarqueeCtrl, CXTPMessageBar, CXTPPopupControl, CXTPProgressCtrl, CXTPProgressPaintManager, CXTPPropertyGrid, CXTPPropertyGridView, CXTPRibbonControlTab, CXTPShortcutBar, CXTPStatusBar, CXTPSyntaxEditCtrl, CXTPSyntaxEditPropertiesPageFont, CXTPTabClientWnd, CXTPTabControl, CXTPTabManager, CXTPTabToolBar, CXTPTaskPanel, CXTPTaskPanelItem
  • GetPaintTheme() : CXTPCalendarCaptionBarPaintManager, CXTPCalendarCaptionBarTheme, CXTPCalendarCaptionBarThemePart, CXTPCalendarControl, CXTPCalendarPaintManager, CXTPDatePickerControl, CXTPDatePickerPaintManager
  • GetPalette() : CXTPChartAppearance
  • GetPaletteIndex() : CXTPChartSeries, CXTPChartSeriesPoint
  • GetPane() : CXTPChartDiagram2D, CXTPDockingPaneAutoHideWnd, CXTPDockingPaneCaptionButton, CXTPStatusBar
  • GetPaneBase() : CXTPDockingPaneSplitterWnd
  • GetPaneCaptionRect() : CXTPDockingPaneOffice2003Theme, CXTPDockingPanePaintManager, CXTPDockingPaneVisualStudio2012Theme
  • GetPaneCount() : CXTPStatusBar
  • GetPaneData() : CXTPDockingPane
  • GetPaneDirection() : CXTPDockingPaneManager, CXTPDockingPaneSplitterWnd
  • GetPaneHwnd() : CXTPDockingPaneAutoHidePanel, CXTPDockingPaneBase, CXTPDockingPaneMiniWnd, CXTPDockingPaneSidePanel, CXTPDockingPaneTabbedContainer
  • GetPaneInfo() : CXTPStatusBar
  • GetPanelDirection() : CXTPChartContent
  • GetPanelDistance() : CXTPChartContent
  • GetPanelHeight() : CXTPDockingPaneAutoHidePanel
  • GetPaneList() : CXTPDockingPaneLayout, CXTPDockingPaneManager
  • GetPanelPaintManager() : CXTPDockingPanePaintManager
  • GetPanels() : CXTPChartContent
  • GetPanes() : CXTPDockingPaneBaseContainer
  • GetPaneStack() : CXTPDockingPaneManager
  • GetPaneStyle() : CXTPStatusBar
  • GetPaneTab() : CXTPDockingPaneAutoHidePanel, CXTPDockingPaneTabbedContainer
  • GetPaneText() : CXTPStatusBar
  • GetPaneView() : CXTPChartDiagram2DView
  • GetPaneWindowRect() : CXTPDockingPaneBase
  • GetParam() : CXTPSyntaxEditColorInfo
  • GetParameter() : CXTPControl
  • GetParams() : CXTPCalendarPaintManager
  • GetParent() : CXTPControl, CXTPControls, CXTPRibbonGroup, CXTPRibbonTab
  • GetParentCommandBar() : CXTPCommandBar, CXTPPopupBar
  • GetParentFrame() : CXTPDockingPane, CXTPTabClientWnd
  • GetParentItem() : CXTPPropertyGridItem
  • GetParentItems() : CXTPTaskPanelItem
  • GetParentRecord() : CXTPGridRecord
  • GetParentRow() : CXTPGridRow
  • GetParentRows() : CXTPGridRow
  • GetParentTab() : CXTPRibbonGroup, CXTPRibbonGroups
  • GetParentTheme() : CXTPSyntaxEditColorTheme
  • GetParentThemeName() : CXTPSyntaxEditColorTheme
  • GetParentTimeScale() : CXTPCalendarTLV_TimeScaleParams
  • GetParentView() : CXTPChartElementView
  • GetParentWindow() : CXTPScrollBase
  • GetParseThreadPriority() : CXTPSyntaxEditLexParser
  • GetPart() : CXTPCalendarTimeLineViewEvent, CXTPCalendarTLV_TimeScaleParams, CXTPCalendarTLV_TimeScaleParams_Day, CXTPCalendarTLV_TimeScaleParams_Month, CXTPCalendarTLV_TimeScaleParams_Week, CXTPCalendarTLV_TimeScaleParams_WorkWeek, CXTPPropertyGridVerb
  • GetPartID() : CXTPCalendarCaptionBarThemePart
  • GetPassNumber() : CXTPChartDeviceCommand
  • GetPattern() : CXTPChartNumberFormat
  • GetPatternEnd() : CXTPCalendarRecurrencePattern
  • GetPatternEndDate() : CXTPCalendarRecurrencePattern
  • GetPatternID() : CXTPCalendarRecurrencePattern
  • GetPatternStartDate() : CXTPCalendarRecurrencePattern
  • GetPidlCount() : CXTPShellPidl
  • GetPidlItemCount() : CXTPShellPidl
  • GetPidlRoot() : CXTPBrowseDialog
  • GetPie() : CXTPChartPieSeriesPointViewBase
  • GetPieStyleAppearance() : CXTPChartAppearance
  • GetPinButton() : CXTPDockingPaneTabbedContainer
  • GetPlainMarkupItemText() : CXTPMarkupTreeCtrl
  • GetPoint() : CXTPChartSeriesPointView, CXTPPropertyGridItemPoint
  • GetPointDistance() : CXTPChartFunnelSeriesStyleBase, CXTPChartPyramidSeriesStyleBase
  • GetPointLegendFormat() : CXTPChartSeries
  • GetPointRect() : CXTPFlowGraphNodeCustom
  • GetPoints() : CXTPChartSeries
  • GetPopulatedRecordsCount() : CXTPGridSection
  • GetPopupAnimation() : CXTPPopupControl
  • GetPopupBarGripperWidth() : CXTPCommandBarsNativeXPTheme, CXTPPaintManager
  • GetPopupControl() : CXTPPopupItem
  • GetPopuped() : CXTPControl, CXTPControlPopup
  • GetPopupPos() : CXTPPopupControl
  • GetPopupSize() : CXTPPopupControl
  • GetPopupState() : CXTPPopupControl
  • GetPopupStyle() : CXTPColorSelectorCtrl
  • GetPOS() : XTP_CALENDAR_MONTHVIEW_DAYPOS
  • GetPos() : CXTPControlScrollBar, CXTPControlSlider, CXTPPageScroller, CXTPProgressBase, CXTPStatusBarScrollBarPane
  • GetPosEndLC() : CXTPSyntaxEditLexTextBlock
  • GetPosition() : CXTPChartFunnelSeriesLabelBase, CXTPChartFunnelSeriesLabelViewBase, CXTPChartPieSeriesLabelBase, CXTPChartPieSeriesLabelViewBase, CXTPChartPyramidSeriesLabelBase, CXTPChartPyramidSeriesLabelViewBase, CXTPCommandBar, CXTPControlTabWorkspace, CXTPDockBar, CXTPDockingPaneAutoHidePanel, CXTPPropExchangeEnumerator, CXTPTabManager, CXTPTabPaintManager, CXTPTrackBlock, CXTPTrackMarker
  • GetPosLC() : CXTPSyntaxEditTextIterator
  • GetPosLC_last() : CXTPSyntaxEditTextIterator
  • GetPreferredPageSize() : IXTPPreview
  • GetPressed() : CXTPColorSelectorCtrl, CXTPControl
  • GetPressedIcon() : CXTPImageManagerIcon
  • GetPressedItem() : CXTPShortcutBar
  • GetPrev() : CXTPGridRows
  • GetPrevChild() : CXTPSyntaxEditLexTextBlock
  • GetPreviewHeight() : CXTPGridRecordItemPreview
  • GetPreviewItemHeight() : CXTPGridPaintManager
  • GetPreviewLinesCount() : CXTPGridPaintManager
  • GetPreviewText() : CXTPGridRecordItemPreview
  • GetPreviousPoint() : CXTPChartSeriesPoint
  • GetPrevItem() : CXTPTreeBase
  • GetPrevSelectedItem() : CXTPTreeBase
  • GetPrimaryDiagram() : CXTPChartContent
  • GetPrintOptions() : CXTPCalendarControlView, CXTPGridView, CXTPSyntaxEditView
  • GetPrintWidth() : CXTPGridColumn
  • GetPrivateGlyphRect() : CXTPCalendarViewEvent
  • GetProcAddress() : CXTPModuleHandle
  • GetProfileBinary() : CXTPRegistryManager
  • GetProfileColor() : CXTPRegistryManager
  • GetProfileDouble() : CXTPRegistryManager
  • GetProfileDword() : CXTPRegistryManager
  • GetProfileInt() : CXTPRegistryManager
  • GetProfileNode() : CXTPPropExchangeXMLNode
  • GetProfilePoint() : CXTPRegistryManager
  • GetProfileRect() : CXTPRegistryManager
  • GetProfileSize() : CXTPRegistryManager
  • GetProfileString() : CXTPRegistryManager
  • GetProgressPaintManager() : CXTPControlProgress, CXTPPaintManager, CXTPProgressBase, CXTPStatusBarProgressPane
  • GetProgressRect() : CXTPControlProgress, CXTPProgressBase, CXTPStatusBarProgressPane
  • GetPrompt() : CXTPGridColumn
  • GetPromptChar() : CXTPMaskEditT< TBase >
  • GetPromptString() : CXTPMaskEditT< TBase >
  • GetProperty() : CXTPCalendarCustomProperties, CXTPSkinManagerClass, CXTPWebBrowserCtrl
  • GetPropertyGrid() : CXTPPropertyGridView
  • GetPropertySort() : CXTPPropertyGrid
  • GetPropValue() : CXTPSyntaxEditPropertiesPageColor
  • GetProvider() : CXTPWebBrowserCtrl
  • GetProviderType() : CXTPWebBrowserCtrl
  • GetPThis() : CXTPCalendarMonthViewDay, CXTPCalendarMonthViewGroup, CXTPCalendarViewDayT< _TView, _TViewGroup, XTP_CALENDAR_HITTESTINFO, _TPThis >, CXTPCalendarViewGroupT< _TViewDay, _TViewEvent, _TPThis >, CXTPCalendarWeekViewDay
  • GetPushButtonStyle() : CXTPButton
  • GetQuickAccessControls() : CXTPRibbonBar
  • GetQuickAccessHeight() : CXTPRibbonBar
  • GetQuickAccessRect() : CXTPRibbonBar
  • GetR() : CXTPChartColor
  • GetRange() : CXTPChartAxis, CXTPDatePickerControl, CXTPProgressBase
  • GetRawValue() : CXTPMarkupStaticExtensionBooleanProperty, CXTPMarkupStaticExtensionBrushProperty, CXTPMarkupStaticExtensionColorProperty, CXTPMarkupStaticExtensionDoubleProperty, CXTPMarkupStaticExtensionIntegerProperty, CXTPMarkupStaticExtensionStringProperty
  • GetReadOnly() : CXTPControlEdit, CXTPPropertyGridItem
  • GetRecentColors() : CXTPColorSelectorCtrl
  • GetRecentFileList() : CXTPControlRecentFileList, CXTPRibbonControlSystemRecentFileList
  • GetRecommendedExtent() : CXTPImageManagerIcon
  • GetRecord() : CXTPGridRecordItem, CXTPGridRow
  • GetRecords() : CXTPGridRecord, CXTPGridSection
  • GetRecordsTreeFilterMode() : CXTPGridControl
  • GetRect() : CXTPCalendarCaptionBarTheme, CXTPCalendarCaptionBarThemePart, CXTPCalendarTimeLineViewTimeScale, CXTPCalendarViewGroup, CXTPControl, CXTPDatePickerItemDay, CXTPDockingPaneCaptionButton, CXTPFlowGraphConnectionPoint, CXTPGridColumn, CXTPGridRecordItemControl, CXTPGridRow, CXTPGridSection, CXTPGridSections, CXTPPopupItem, CXTPPropertyGridInplaceButton, CXTPRibbonGroup, CXTPStatusBarPane, CXTPTabManagerItem, CXTPTabManagerNavigateButton, CXTPTrackBlock, CXTPTrackMarker
  • GetRectangleTextColor() : CXTPCommandBarsNativeXPTheme, CXTPCommandBarsOffice2000Theme, CXTPCommandBarsOffice2013Theme, CXTPCommandBarsOfficeXPTheme, CXTPPaintManager, CXTPResourceTheme, CXTPRibbonTheme, CXTPVisualStudio2008Theme, CXTPVisualStudio2010Theme
  • GetRectLength() : CXTPTabManager
  • GetRectProperty() : CXTPSkinManagerSchema
  • GetRecurrenceGlyphRect() : CXTPCalendarViewEvent
  • GetRecurrenceOptions() : CXTPCalendarRecurrencePattern
  • GetRecurrencePattern() : CXTPCalendarData, CXTPCalendarEvent
  • GetRecurrencePatternID() : CXTPCalendarEvent
  • GetRecurrenceState() : CXTPCalendarEvent
  • GetRecurrenceType() : CXTPCalendarRecurrencePattern
  • GetRed() : CXTPChartColor
  • GetRedoTextList() : CXTPSyntaxEditCtrl, CXTPSyntaxEditUndoRedoManager
  • GetRegBSTR() : CXTPCalendarTimeZones
  • GetRegDWORD() : CXTPCalendarTimeZones
  • GetRegisterAsDropTarget() : CXTPShellExplorerProvider
  • GetRegStr() : CXTPCalendarTimeZones
  • GetRegTZI() : CXTPCalendarTimeZones
  • GetRegularBoldFont() : CXTPPaintManager
  • GetRegularFont() : CXTPPaintManager
  • GetRegValues() : CXTPSyntaxEditCtrl
  • GetReminderGlyphRect() : CXTPCalendarViewEvent
  • GetReminderMinutesBeforeStart() : CXTPCalendarEvent
  • GetRemindersManager() : CXTPCalendarControl
  • GetReminderSoundFile() : CXTPCalendarEvent
  • GetRenderSize() : CXTPMarkupVisual
  • GetRenderTransform() : CXTPMarkupUIElement
  • GetRequires() : CXTPMarkupXtpScript
  • GetResizeCursor() : CXTPGridHeader
  • GetResizeVCursor() : CXTPGridHeader
  • GetResizingColumn() : CXTPGridHeader
  • GetResource() : CXTPCalendarResourcesManager, CXTPImageManager
  • GetResourceColor() : CXTPDatePickerThemeResource
  • GetResourceFile() : CXTPSkinManager, CXTPSkinManagerSchema
  • GetResourceHandle() : CXTPResourceManager
  • GetResourceLanguage() : CXTPResourceManager
  • GetResourceModule() : CXTPGaugeTraits
  • GetResourceNamespace() : CXTPGaugeTraits
  • GetResourcePath() : CXTPGaugeTraits, CXTPSkinManagerResourceFile
  • GetResources() : CXTPCalendarControl, CXTPCalendarView, CXTPCalendarViewDay, CXTPCalendarViewGroup
  • GetResourcesCount() : CXTPCalendarResourcesManager
  • GetResourcesGroupedByDP() : CXTPCalendarResourcesNf
  • GetResourcesLangID() : CXTPResourceManager
  • GetRException_EndTimeOrig() : CXTPCalendarEvent
  • GetRException_StartTimeOrig() : CXTPCalendarEvent
  • GetRibbonBar() : CXTPRibbonControlTab, CXTPRibbonCustomizePage, CXTPRibbonCustomizeQuickAccessPage, CXTPRibbonGroup, CXTPRibbonGroups, CXTPRibbonTab
  • GetRibbonCaptionHeight() : CXTPRibbonOffice2013Theme, CXTPRibbonPaintManager, CXTPRibbonThemeOffice2007System, CXTPRibbonThemeResource
  • GetRibbonDividerIndex() : CXTPStatusBar
  • GetRibbonGroup() : CXTPControl
  • GetRibbonPaintManager() : CXTPCommandBarsModernUITheme, CXTPPaintManager, CXTPResourceTheme, CXTPRibbonBar
  • GetRichEditContext() : CXTPCommandBarEditCtrl
  • GetRichRender() : CXTPPopupItem
  • GetRight() : CXTPGridThickness, CXTPMarkupThickness, CXTPRectT< T >
  • GetRootParent() : CXTPCommandBar
  • GetRotation() : CXTPChartPieSeriesStyleBase
  • GetRotationQuaternion() : CXTPArcBall
  • GetRoundedBounds() : CXTPChartTextPainterBase
  • GetRow() : CXTPMarkupGrid
  • GetRowBkColor() : CXTPSyntaxEditCtrl
  • GetRowColor() : CXTPSyntaxEditCtrl
  • GetRowColors() : CXTPSyntaxEditCtrl, CXTPSyntaxEditLexTextSchema
  • GetRowCount() : CXTPCalendarDayView, CXTPCalendarDayViewGroup, CXTPSyntaxEditBufferManager, CXTPSyntaxEditCtrl, CXTPTabManager
  • GetRowDefinitions() : CXTPMarkupGrid
  • GetRowHeight() : CXTPCalendarDayViewGroup, CXTPCalendarView, CXTPGridPaintManager, CXTPGridThemeOffice2013, CXTPSyntaxEditDrawTextProcessor, CXTPTrackThemeOffice2013
  • GetRowHeightEx() : CXTPGridPaintManager
  • GetRowItems() : CXTPTabManager::CRowIndexer
  • GetRowNodes() : CXTPSyntaxEditCtrl
  • GetRowPerPage() : CXTPSyntaxEditCtrl
  • GetRowRect() : CXTPControl
  • GetRows() : CXTPDatePickerControl, CXTPGridSection, CXTPMarkupUniformGrid
  • GetRowsCount() : CXTPSyntaxEditDrawTextProcessor
  • GetRowsHeight() : CXTPGridControl
  • GetRowsMaxWidth() : CXTPSyntaxEditDrawTextProcessor
  • GetRowSpan() : CXTPMarkupGrid
  • GetRowsPerLine() : CXTPGridControl
  • GetRowType() : CXTPGridSection, CXTPGridSelectedRows
  • GetRowWidth() : CXTPSyntaxEditDrawTextProcessor
  • GetRPatternRef() : CXTPCalendarEvent
  • GetRTLDirection() : CXTPDockingPaneManager
  • GetSafeHandle() : CXTPGdiObject, CXTPImageList
  • GetSafeHwnd() : CXTPPropertyPageNavigator
  • GetSafeLogFont() : CXTPSyntaxEditPropertiesPageFont
  • GetScaleInterval() : CXTPCalendarDayView, CXTPCalendarDayViewTimeScale, CXTPCalendarTLV_TimeScaleParams
  • GetScaleIntervalWidth_px() : CXTPCalendarTLV_TimeScaleParams
  • GetScaleMaxTime() : CXTPCalendarDayView
  • GetScaleMinTime() : CXTPCalendarDayView
  • GetScaleText() : CXTPCalendarDayView
  • GetScaleType() : CXTPChartAxis
  • GetScaleTypeMap() : CXTPChartAxis
  • GetScaleX() : CXTPMarkupScaleTransform
  • GetScaleY() : CXTPMarkupScaleTransform
  • GetScheduleID() : CXTPCalendarEvent, CXTPCalendarViewGroup
  • GetScheduleName() : CXTPCalendarSchedules
  • GetSchedules() : CXTPCalendarData, CXTPCalendarResource
  • GetScheduleSet() : CXTPCalendarEvent
  • GetSchema() : CXTPPropExchange, CXTPSkinManager, CXTPSyntaxEditTextSchemesManager
  • GetSchemaFileName() : CXTPSyntaxEditTextSchemesManager
  • GetSchemaList() : CXTPSyntaxEditTextSchemesManager
  • GetSchemaName() : CXTPSkinManagerSchema, CXTPSyntaxEditTextSchemesManager
  • GetSchemaOptions() : CXTPSyntaxEditLexParser
  • GetSchemes() : CXTPSyntaxEditTextSchemesManager
  • GetSchName() : CXTPSyntaxEditLexTextSchema
  • GetScreenArea() : CXTPMultiMonitor
  • GetScreenPoint() : CXTPChartCandleStickSeriesPointView, CXTPChartHighLowSeriesPointView, CXTPChartPointSeriesPointView, CXTPChartRadarPointSeriesPointView
  • GetScreenRect() : CXTPFlowGraphNode
  • GetScreenRows() : CXTPGridRows
  • GetScriptEngine() : CXTPMarkupContext
  • GetScriptErrorsSuppressed() : CXTPShellExplorerProvider
  • GetScrollBarColors() : CXTPScrollBarThemeOffice2013
  • GetScrollBarCtrl() : CXTPExcelTabCtrl, CXTPFlowGraphControl, CXTPGridView, CXTPRibbonBackstageView, CXTPScrollBarContainer< Parent >, CXTPSyntaxEditCtrl
  • GetScrollBarInfoH() : CXTPCalendarDayView, CXTPCalendarTimeLineView, CXTPCalendarView
  • GetScrollBarInfoV() : CXTPCalendarDayView, CXTPCalendarMonthView, CXTPCalendarTimeLineView, CXTPCalendarView, CXTPCalendarWeekView
  • GetScrollBarPaintManager() : CXTPCommandBarScrollBarCtrl, CXTPControlGallery, CXTPPaintManager, CXTPScrollBarCtrl, CXTPScrollBase, CXTPStatusBarSliderPane
  • GetScrollBarPartRect() : CXTPScrollBase
  • GetScrollBarPosInfo() : CXTPScrollBarCtrl, CXTPScrollBase
  • GetScrollBarRect() : CXTPScrollBase
  • GetScrollBarStyle() : CXTPScrollBase, CXTPShellExplorerProvider
  • GetScrollBarTheme() : CXTPPropertyGridCoolTheme, CXTPPropertyGridDelphiTheme, CXTPPropertyGridNativeWindows10Theme, CXTPPropertyGridNativeWindows11Theme, CXTPPropertyGridNativeXPTheme, CXTPPropertyGridOffice2003Theme, CXTPPropertyGridOffice2007Theme, CXTPPropertyGridOffice2013Theme, CXTPPropertyGridOfficeXPTheme, CXTPPropertyGridPaintManager, CXTPPropertyGridSimpleTheme, CXTPPropertyGridVisualStudio2005Theme, CXTPPropertyGridVisualStudio2010Theme, CXTPPropertyGridVisualStudio2012Theme, CXTPPropertyGridVisualStudio2015Theme, CXTPPropertyGridVisualStudio2017Theme, CXTPPropertyGridVisualStudio2019Theme, CXTPPropertyGridVisualStudio2022Theme
  • GetScrollBarTrackInfo() : CXTPScrollBarCtrl, CXTPScrollBase
  • GetScrollButton() : CXTPTaskPanel
  • GetScrollIndexV() : CXTPGridSection
  • GetScrollInfo() : CXTPScrollBarCtrl, CXTPScrollBase, CXTPSyntaxEditCtrl
  • GetScrollLimit() : CXTPFlowGraphControl, CXTPSyntaxEditCtrl
  • GetScrollMode() : CXTPGridControl
  • GetScrollOffset() : CXTPFlowGraphControl, CXTPFlowGraphPage, CXTPTaskPanel
  • GetScrollOffsetPos() : CXTPTaskPanelGroup
  • GetScrollOffsetV() : CXTPGridSection
  • GetScrollPos() : CXTPCalendarMonthView::CMonthViewGrid, CXTPControlGallery, CXTPRibbonGroups, CXTPSyntaxEditCtrl
  • GetScrollRange() : CXTPSyntaxEditCtrl
  • GetScrollXOffset() : CXTPSyntaxEditDrawTextProcessor
  • GetSearchHistoryCountMax() : CXTPSyntaxEditFindReplaceDlg
  • GetSecondaryAxisX() : CXTPChartDiagram2D
  • GetSecondaryAxisY() : CXTPChartDiagram2D
  • GetSection() : CXTPGridRow, CXTPPropExchange, CXTPPropExchangeArchive, CXTPPropExchangeIniFile, CXTPPropExchangeRegistry, CXTPPropExchangeXMLNode
  • GetSectionDividerHeight() : CXTPGridPaintManager
  • GetSectionKey() : CXTPRegistryManager
  • GetSectionName() : CXTPPropExchangeXMLNode
  • GetSectionNode() : CXTPPropExchangeXMLNode
  • GetSections() : CXTPGridControl
  • GetSegmentLength() : CXTPMathUtils
  • GetSel() : CXTPHexEdit
  • GetSelColor() : CXTPSyntaxEditColorComboBox
  • GetSelected() : CXTPCommandBar, CXTPControl, CXTPDockingPaneTabbedContainer
  • GetSelectedBlock() : CXTPDatePickerDaysCollection
  • GetSelectedBlocks() : CXTPTrackControl
  • GetSelectedBlocksCount() : CXTPDatePickerDaysCollection
  • GetSelectedButtonId() : CXTPTaskDialog
  • GetSelectedColor() : CXTPColorHex
  • GetSelectedConstraintData() : CXTPGridRecordItem, CXTPGridRecordItemVariant
  • GetSelectedCount() : CXTPTreeBase
  • GetSelectedDayBackColor() : CXTPDatePickerPaintManager
  • GetSelectedDays() : CXTPDatePickerControl
  • GetSelectedDaysCount() : CXTPDatePickerDaysCollection
  • GetSelectedDayTextColor() : CXTPDatePickerPaintManager
  • GetSelectedEvents() : CXTPCalendarView
  • GetSelectedFolderPath() : CXTPShellTreeBase
  • GetSelectedItem() : CXTPControlGallery, CXTPPropertyGrid, CXTPShortcutBar, CXTPTabClientWnd, CXTPTabManager
  • GetSelectedItems() : CXTPPropertyGrid
  • GetSelectedList() : CXTPTreeBase
  • GetSelectedPane() : CXTPDockingPaneMiniWnd, CXTPDockingPaneSidePanel
  • GetSelectedRadioButtonId() : CXTPTaskDialog
  • GetSelectedRows() : CXTPGridControl, CXTPGridSection
  • GetSelectedTab() : CXTPRibbonBar
  • GetSelectedViewEvents() : CXTPCalendarView
  • GetSelection() : CXTPCalendarDayView, CXTPCalendarView, CXTPFlowGraphPage, CXTPSyntaxEditCtrl
  • GetSelectionBuffer() : CXTPSyntaxEditCtrl
  • GetSelectionRect() : CXTPFlowGraphNode, CXTPFlowGraphNodeCustom
  • GetSelectionText() : CXTPSyntaxEditCtrl
  • GetSelFont() : CXTPFontCtrlBase
  • GetSelMargin() : CXTPSyntaxEditCtrl
  • GetSelPath() : CXTPBrowseDialog
  • GetSelRange() : CXTPDatePickerControl
  • GetSelTabBackColor() : CXTPExcelTabCtrl, CXTPExcelTabCtrlTheme
  • GetSelTabTextColor() : CXTPExcelTabCtrl, CXTPExcelTabCtrlTheme
  • GetSerializationData() : CXTPImageManagerVectorImageHandle
  • GetSeries() : CXTPChartContent, CXTPChartDiagram
  • GetSeriesLabelView() : CXTPChart3dFunnelSeriesLabelDeviceCommand, CXTPChart3dPieSeriesLabelDeviceCommand, CXTPChart3dPyramidSeriesLabelDeviceCommand
  • GetSeriesPointValueIndex() : CXTPChartBubbleSeriesStyle, CXTPChartSeriesStyle
  • GetSeriesStyleAppearance() : CXTPChartAppearance
  • GetSeriesView() : CXTPChartDiagramView, CXTPChartSeriesPointView
  • GetShadow() : CXTPCommandBarsFrameHook, CXTPFrameShadowManager
  • GetShadowIcon() : CXTPImageManagerIcon
  • GetShadowManager() : CXTPPaintManager
  • GetShadowOptions() : CXTPPaintManager, CXTPShadowManager
  • GetSHContextMenu() : CXTPShellPidl
  • GetShortcutBar() : CXTPShortcutBarItem
  • GetShortcutManager() : CXTPCommandBars
  • GetShortcutText() : CXTPControl, CXTPControlAction
  • GetShowAlways() : CXTPPropertyGridInplaceButton
  • GetShowCaptionAlways() : CXTPRibbonBar
  • GetShowContentsWhileDragging() : CXTPDockingPaneManager, CXTPTabClientContext
  • GetShowDaysAfter() : CXTPDatePickerItemMonth
  • GetShowDaysBefore() : CXTPDatePickerItemMonth
  • GetShowDelay() : CXTPPopupControl
  • GetShowFocus() : CXTPButton
  • GetShowGripper() : CXTPCommandBar
  • GetShowInplaceButtonsAlways() : CXTPPropertyGrid
  • GetShowKeyboardCues() : CXTPCommandBarsOptions
  • GetShowLeftScroll() : CXTPDatePickerItemMonth
  • GetShowLines() : CXTPChartSeriesLabel
  • GetShowNonMonthDays() : CXTPDatePickerControl
  • GetShowRightScroll() : CXTPDatePickerItemMonth
  • GetShowTabClientContextStickers() : CXTPTabClientContext
  • GetShowToolTipTimeOut() : CXTPCalendarView, CXTPCalendarViewEvent
  • GetShowWeekNumbers() : CXTPDatePickerControl
  • GetShowZeroLevel() : CXTPChartAxisRange
  • GetSideDockingMargin() : CXTPDockingPaneManager
  • GetSideMargins() : CXTPChartAxisRange
  • GetSite() : CXTPCommandBar, CXTPCommandBars, CXTPCommandBarsFrameHook, CXTPDockingPaneManager, CXTPMarkupDeviceDependentImage
  • GetSiteExStyle() : CXTPCommandBarsFrameHook
  • GetSiteStyle() : CXTPCommandBarsFrameHook
  • GetSize() : CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE >, CXTPChartDiagram2DAxisView, CXTPChartRadarAxisXView, CXTPChartRadarAxisYView, CXTPControl, CXTPControlBitmap, CXTPControlButtonColor, CXTPControlColorSelector, CXTPControlCustom, CXTPControlGalleryItem, CXTPControlHyperlink, CXTPControlListBox, CXTPControlMarkupLabel, CXTPControlProgress, CXTPControlSelector, CXTPControlStatic, CXTPControlTabWorkspace, CXTPFlowGraphImage, CXTPFlowGraphNode, CXTPGridRecordItemControl, CXTPMarkupBorder, CXTPMarkupDeviceDependentImage, CXTPPropertyGridItemSize, CXTPRectT< T >, CXTPRibbonControlSystemButton, CXTPRibbonControlSystemPopupBarButton, CXTPRibbonControlSystemPopupBarListCaption, CXTPRibbonControlSystemPopupBarListItem, CXTPSvgImage, CXTPTabManagerNavigateButton, CXTPTabManagerNavigateButtons, CXTPTaskPanelGroupItem
  • GetSizeProperty() : CXTPSkinManagerSchema
  • GetSkinClass() : CXTPSkinManager, CXTPSkinObject
  • GetSkinManager() : CXTPSkinManagerResourceFile, CXTPSkinManagerSchema, CXTPSkinObject
  • GetSliderCtrl() : CXTPControlSlider, CXTPPropertyGridInplaceSlider
  • GetSliderPaintManager() : CXTPPaintManager
  • GetSliderStyle() : CXTPControlSlider
  • GetSlotNumber() : CXTPCalendarDayViewEvent
  • GetSmCaptionFont() : CXTPPaintManager
  • GetSmoothingMode() : CXTPFlowGraphControl
  • GetSnapMargin() : CXTPTrackControl
  • GetSortBackColor() : CXTPListBase
  • GetSortDirection() : CXTPChartLegend
  • GetSortedCol() : CXTPHeaderCtrl
  • GetSortOrder() : CXTPGridColumns, CXTPTagCloudCtrl
  • GetSortPriority() : CXTPGridRecordItem
  • GetSortTextColor() : CXTPListBase
  • GetSource() : CXTPMarkupImage, CXTPMarkupXtpScript, CXTPResourceImage, CXTPSkinImage
  • GetSpaceWidth() : CXTPSyntaxEditDrawTextProcessor
  • GetSpinButtonCtrl() : CXTPPropertyGridInplaceSpinButton
  • GetSpinButtonMax() : CXTPGridInplaceButton
  • GetSpinButtonMin() : CXTPGridInplaceButton
  • GetSpinButtonsRect() : CXTPControlEdit
  • GetSpinButtonStep() : CXTPGridInplaceButton
  • GetSplashScreenMode() : CXTPPopupControl
  • GetSplitButtonCommandRect() : CXTPPaintManager
  • GetSplitterRect() : CXTPPropertyGridPaintManager
  • GetSplitterStyle() : CXTPDockingPanePaintManager
  • GetSplitterView() : CXTPSyntaxEditView
  • GetStandardColor() : CXTPPaintManagerColor
  • GetStandardColors() : CXTPColorPicker, CXTPColorSelectorCtrl
  • GetStandardDeviation() : CXTPChartSeriesPointCollection
  • GetStandardTitle() : CXTPColorSelectorCtrl
  • GetStandardValue() : CXTPCalendarThemeCustomizableXValueT< _TValue, _TValueRef >, CXTPCalendarViewPartCustomizableValueT< _TValue >
  • GetStart_disp() : CXTPSyntaxEditSelection
  • GetStart_str() : CXTPSyntaxEditSelection
  • GetStartAngle() : CXTPChartPieBase
  • GetStartEditSubjectTimeOut() : CXTPCalendarView
  • GetStartOccurrenceTime() : CXTPCalendarRecurrencePattern
  • GetStartPoint() : CXTPChartPieBase
  • GetStartPosition() : CXTPCalendarCustomProperties, CXTPCalendarData::EventsMapByID_T< _TObject >
  • GetStartTagEndXLC() : CXTPSyntaxEditLexTextBlock
  • GetStartTime() : CXTPCalendarEvent, CXTPCalendarRecurrencePattern
  • GetStartTimeRect() : CXTPCalendarViewEvent
  • GetStartViewDate() : CXTPCalendarTimeLineView, CXTPCalendarTimeLineViewTimeScale
  • GetState() : CXTPCalendarCaptionBarThemePart, CXTPDockingPaneCaptionButton, CXTPGaugeStateType, CXTPGridInplaceButton, CXTPGridRecordItemControl
  • GetStateColor() : CXTPCommandBarsNativeWindows10Theme, CXTPCommandBarsNativeWindows11Theme, CXTPCommandBarsVisualStudio2015Theme, CXTPCommandBarsVisualStudio2017Theme, CXTPCommandBarsVisualStudio2019Theme, CXTPCommandBarsVisualStudio2022Theme, CXTPStatusBarThemeNativeWindows10, CXTPStatusBarThemeNativeWindows11, CXTPStatusBarThemeVisualStudio2015, CXTPStatusBarThemeVisualStudio2017, CXTPStatusBarThemeVisualStudio2019, CXTPStatusBarThemeVisualStudio2022
  • GetStateCount() : CXTPGaugeStateType
  • GetStateType() : CXTPGaugeCtrl
  • GetStaticText() : CXTPShellExplorerProvider
  • GetStatusBar() : CXTPCommandBars, CXTPStatusBarPane
  • GetStatusBarCtrl() : CXTPStatusBar
  • GetStatusBarPaintManager() : CXTPPaintManager, CXTPStatusBar
  • GetSticker() : CXTPTabClientContext
  • GetStoredWidth() : CXTPListBase
  • GetStr() : CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager, CXTPSyntaxEditLexVariant
  • GetStrData() : CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager
  • GetStrDataC() : CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager
  • GetStretch() : CXTPMarkupImage, CXTPMarkupViewbox
  • GetStringProperty() : CXTPSkinManagerSchema
  • GetStripEllipsisFromToolTip() : CXTPToolTipContext
  • GetStrips() : CXTPChartAxis
  • GetStrLen() : CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager
  • GetStrLenC() : CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager
  • GetStyle() : CXTPChartFunnelSeriesLabel, CXTPChartFunnelSeriesLabelBase, CXTPChartPieSeriesLabelBase, CXTPChartPyramidSeriesLabelBase, CXTPChartSeries, CXTPControl, CXTPFlowGraphConnection, CXTPFlowGraphConnectionPoint, CXTPFlowGraphNode, CXTPMarkupFrameworkElement, CXTPStatusBarPane, CXTPTagCloudStyleManager, CXTPToolTipContext
  • GetStyleAppearance() : CXTPChartSeriesStyle
  • GetStyleEx() : CXTPControlButton
  • GetSubject() : CXTPCalendarEvent
  • GetSubjectEditor() : CXTPCalendarViewEvent
  • GetSubjectEditorFont() : CXTPCalendarDayViewEvent, CXTPCalendarMonthViewEvent, CXTPCalendarViewEvent, CXTPCalendarWeekViewEvent
  • GetSubjectEditorRect() : CXTPCalendarView, CXTPCalendarViewEvent
  • GetSubjectEditorStyles() : CXTPCalendarDayViewEvent, CXTPCalendarViewEvent
  • GetSubListCtrl() : CXTPGridHeader
  • GetSubscriptionCount() : CXTPSubscriptionList< Observable, Observer >
  • GetSupportedColorSets() : CXTPTabPaintManagerTheme
  • GetSwitch() : CXTPStatusBarSwitchPane
  • GetSwitchCount() : CXTPStatusBarSwitchPane
  • GetSyntaxColor() : CXTPSyntaxEditCtrl
  • GetSyntaxScheme() : CXTPSyntaxEditCtrl
  • GetSystemBrush() : CXTPMarkupSystemBrushStaticExtension
  • GetSystemButton() : CXTPRibbonBar
  • GetSystemColor() : CXTPMarkupSystemColorStaticExtension
  • GetSystemImageList() : CXTPShellPidl
  • GetTab() : CXTPRibbonBar, CXTPRibbonControlTab
  • GetTabBackColor() : CXTPExcelTabCtrl, CXTPExcelTabCtrlTheme
  • GetTabCaption() : CXTPDockingPane
  • GetTabClient() : CXTPTabClientContext, CXTPTearOffFrame
  • GetTabClientWnd() : CXTPMDIFrameWndEx
  • GetTabControlRect() : CXTPRibbonBar
  • GetTabCount() : CXTPRibbonBar
  • GetTabCtrl() : CXTPTabView
  • GetTabCtrlImpl() : CXTPTabBase
  • GetTabFont() : CXTPExcelTabCtrl
  • GetTabFromPoint() : CXTPTabExBase
  • GetTabHeight() : CXTPExcelTabCtrl
  • GetTabHighlightColor() : CXTPExcelTabCtrl
  • GetTabItemArray() : CXTPExcelTabCtrl
  • GetTableRowCaptionRect() : CXTPFlowGraphNode
  • GetTableRowTextBlock() : CXTPFlowGraphNode
  • GetTabManager() : CXTPTabManagerItem
  • GetTabPaintManager() : CXTPDockingPanePaintManager, CXTPRibbonBar, CXTPRibbonPaintManager
  • GetTabShadowColor() : CXTPExcelTabCtrl
  • GetTabsHeight() : CXTPDockingPanePaintManager, CXTPRibbonBar
  • GetTabSize() : CXTPSyntaxEditBufferManager, CXTPSyntaxEditCtrl, CXTPSyntaxEditDrawTextProcessor
  • GetTabsRect() : CXTPExcelTabCtrl
  • GetTabStop() : CXTPPropertyGridInplaceButton
  • GetTabStyle() : CXTPExcelTabCtrl, CXTPTabBaseTheme
  • GetTabTextColor() : CXTPExcelTabCtrl, CXTPExcelTabCtrlTheme
  • GetTabWidth() : CXTPExcelTabCtrl
  • GetTabWithSpace() : CXTPSyntaxEditCtrl
  • GetTag() : CXTPControl, CXTPControlAction, CXTPFlowGraphNode, CXTPMarkupFrameworkElement
  • GetTagArray() : CXTPTagCloudCtrl
  • GetTahoma12() : CXTPChartFont
  • GetTahoma18() : CXTPChartFont
  • GetTahoma8() : CXTPChartFont
  • GetTargetCaptionRect() : CXTPTaskPanelGroup
  • GetTargetClientRect() : CXTPTaskPanelGroup
  • GetTargetTabClientWnd() : CXTPTabClientSticker
  • GetTaskPanel() : CXTPTaskPanelItem
  • GetText() : CXTPCalendarCaptionBarThemePart, CXTPChartAxisConstantLine, CXTPChartAxisCustomLabel, CXTPChartAxisTitle, CXTPChartTitle, CXTPGridFilterEditControl, CXTPMarkupTextBlock, CXTPStatusBarPane, CXTPSyntaxEditCtrl, CXTPSyntaxEditTextIterator
  • GetTextAlignment() : CXTPButton, CXTPMarkupTextBlock, CXTPPopupItem, CXTPStatusBarPane
  • GetTextAngle() : CXTPChartTitle
  • GetTextAttributes() : CXTPSyntaxEditLexClass, CXTPSyntaxEditLexTextSchema
  • GetTextColor() : CXTPButtonTheme, CXTPButtonThemeOffice2013, CXTPButtonThemeVisualStudio2012, CXTPCalendarCaptionBarThemePart, CXTPCalendarViewPart, CXTPCaptionButtonTheme, CXTPCaptionButtonThemeOffice2003, CXTPCaptionButtonThemeOfficeXP, CXTPChartAxisConstantLine, CXTPChartAxisLabel, CXTPChartAxisTitle, CXTPChartLegend, CXTPChartSeriesLabel, CXTPChartTitle, CXTPComboBox, CXTPComboBoxTheme, CXTPGridRecordItem, CXTPHexEdit, CXTPPopupItem, CXTPProgressCtrl, CXTPProgressCtrlPaintManager, CXTPShortcutListBoxTheme, CXTPStatusBarPane, CXTPStatusBarThemeOffice2013, CXTPSyntaxEditColorSampleText, CXTPSyntaxEditPaintManager, CXTPSyntaxEditTipWnd, CXTPTaskButtonTheme, CXTPTaskDialogLinkCtrl, CXTPTaskPanelGroupItem
  • GetTextDecoration() : CXTPGridHyperlinkStyle
  • GetTextDecorations() : CXTPMarkupTextBlock
  • GetTextExtent() : CXTPCalendarViewPart
  • GetTextFont() : CXTPCalendarViewPart, CXTPGridPaintManager, CXTPPopupItem, CXTPStatusBarPane
  • GetTextGrayColor() : CXTPStatusBarPane
  • GetTextHeight() : CXTPShortcutListBox
  • GetTextImageRelation() : CXTPButton
  • GetTextLimit() : CXTPControlComboBox, CXTPControlEdit
  • GetTextLinkColor() : CXTPTaskDialogLinkCtrl
  • GetTextMetrics() : CXTPSyntaxEditDrawTextProcessor
  • GetTextOrientation() : CXTPCommandBar
  • GetTextRect() : CXTPCalendarViewEvent, CXTPCaption, CXTPSyntaxEditDrawTextProcessor, CXTPTaskPanelItem
  • GetTextSchema() : CXTPSyntaxEditLexParser
  • GetTextSchemesManager() : CXTPSyntaxEditConfigurationManager
  • GetTextTrimming() : CXTPMarkupTextBlock
  • GetTextWrapping() : CXTPMarkupTextBlock
  • GetTheme() : CXTPButton, CXTPCalendarCaptionBarControl, CXTPCalendarCaptionBarThemePart, CXTPCalendarControl, CXTPCalendarView, CXTPCaption, CXTPColorSelectorCtrl, CXTPComboBox, CXTPEdit, CXTPExcelTabCtrl, CXTPHeaderCtrl, CXTPPopupControl, CXTPPropertySheet, CXTPShortcutListBox, CXTPSplitterWnd, CXTPSyntaxEditColorThemesManager, CXTPTabBase
  • GetThemeAppProperties() : CXTPWinThemeWrapper
  • GetThemeBackgroundContentRect() : CXTPWinThemeWrapper
  • GetThemeBackgroundExtent() : CXTPWinThemeWrapper
  • GetThemeBackgroundRegion() : CXTPWinThemeWrapper
  • GetThemeBool() : CXTPSkinManagerClass, CXTPWinThemeWrapper
  • GetThemeColor() : CXTPSkinManagerClass, CXTPWinThemeWrapper
  • GetThemeColors() : CXTPColorPicker, CXTPColorSelectorCtrl
  • GetThemed() : CXTPGridRecordItemControl
  • GetThemeDocumentationProperty() : CXTPWinThemeWrapper
  • GetThemeEnumValue() : CXTPSkinManagerClass, CXTPWinThemeWrapper
  • GetThemeFilename() : CXTPWinThemeWrapper
  • GetThemeFont() : CXTPWinThemeWrapper
  • GetThemeID() : CXTPEdit, CXTPEditTheme
  • GetThemeInt() : CXTPSkinManagerClass, CXTPWinThemeWrapper
  • GetThemeIntList() : CXTPWinThemeWrapper
  • GetThemeManager() : CXTPSyntaxEditConfigurationManager
  • GetThemeMargins() : CXTPWinThemeWrapper
  • GetThemeMetric() : CXTPWinThemeWrapper
  • GetThemePartSize() : CXTPSkinManagerClass, CXTPWinThemeWrapper
  • GetThemePosition() : CXTPWinThemeWrapper
  • GetThemePropertyOrigin() : CXTPWinThemeWrapper
  • GetThemeRect() : CXTPSkinManagerClass, CXTPWinThemeWrapper
  • GetThemes() : CXTPSyntaxEditColorThemesManager, CXTPSyntaxEditCtrl
  • GetThemeSize() : CXTPSkinManagerClass
  • GetThemeString() : CXTPSkinManagerClass, CXTPWinThemeWrapper
  • GetThemeStyle() : CXTPControlTheme
  • GetThemeSysBool() : CXTPSkinManager, CXTPWinThemeWrapper
  • GetThemeSysColor() : CXTPSkinManager, CXTPWinThemeWrapper
  • GetThemeSysColorBrush() : CXTPWinThemeWrapper
  • GetThemeSysFont() : CXTPSkinManager, CXTPWinThemeWrapper
  • GetThemeSysInt() : CXTPWinThemeWrapper
  • GetThemeSysSize() : CXTPSkinManager, CXTPWinThemeWrapper
  • GetThemeSysString() : CXTPWinThemeWrapper
  • GetThemeTextExtent() : CXTPWinThemeWrapper
  • GetThemeTextMetrics() : CXTPWinThemeWrapper
  • GetThemeTip() : CXTPColorSelectorCtrl
  • GetThemeTitle() : CXTPColorSelectorCtrl
  • GetThemeVersion() : CXTPCalendarControl
  • GetThemeWrapper() : CXTPHeaderCtrlTheme
  • GetThickness() : CXTPChartAxis, CXTPChartAxisTickMarks, CXTPChartBorder, CXTPChartLineStyle
  • GetThumbWidth() : CXTPControlComboBox
  • GetTickMarks() : CXTPChartAxis
  • GetTicks() : CXTPScrollBase
  • GetTimeFormat() : CXTPCalendarUtils
  • GetTimeFormatString_HrMin() : CXTPCalendarUtils
  • GetTimeframeRect() : CXTPCalendarDayViewEvent
  • GetTimelineArea() : CXTPTrackControl
  • GetTimeLineMax() : CXTPTrackControl
  • GetTimeLineMin() : CXTPTrackControl
  • GetTimeLinePosition() : CXTPTrackControl
  • GetTimeLineScale() : CXTPCalendarControl
  • GetTimeLineView() : CXTPCalendarControl
  • GetTimeLineViewScale() : CXTPCalendarTLV_TimeScaleParams
  • GetTimePerPixel() : CXTPCalendarTLV_TimeScaleParams
  • GetTimeScale() : CXTPCalendarDayView, CXTPCalendarTimeLineView
  • GetTimeScaleID() : CXTPCalendarTimeLineView
  • GetTimeScaleParams() : CXTPCalendarTimeLineViewTimeScale
  • GetTimeScaleParamsID() : CXTPCalendarTLV_TimeScaleParams
  • GetTimeshift() : CXTPCalendarDayViewTimeScale
  • GetTimeZoneInfo() : CXTPCalendarTimeZone
  • GetTipBkColor() : CXTPToolTipContext
  • GetTips() : CXTPTabExBase
  • GetTipText() : CXTPExcelTabCtrl
  • GetTipTextColor() : CXTPToolTipContext
  • GetTitle() : CXTPBrowseDialog, CXTPChartAxis, CXTPCommandBar, CXTPDockingPane, CXTPDockingPaneBase, CXTPDockingPaneMiniWnd, CXTPDockingPaneSidePanel, CXTPDockingPaneTabbedContainer
  • GetTitleAppearance() : CXTPChartContentAppearance
  • GetTitles() : CXTPChartContent, CXTPChartPanel
  • GetTitleToolTip() : CXTPDockingPane
  • GetToday() : CXTPDatePickerControl
  • GetTodayDate() : CXTPCalendarControl
  • GetTodayDateOverride() : CXTPCalendarControl
  • GetTokensForAutoCompleate() : CXTPSyntaxEditLexParser
  • GetToolBar() : CXTPCommandBars, CXTPPropertyGrid, CXTPReBar
  • GetToolbarsPage() : CXTPCustomizeSheet
  • GetToolbarsPopup() : CXTPCommandBars
  • GetToolSize() : CXTPToolTipContextToolTip
  • GetToolText() : CXTPCalendarViewEvent
  • GetToolTip() : CXTPControlGalleryItem
  • GetTooltip() : CXTPButton, CXTPControl, CXTPControlAction, CXTPFlowGraphConnection, CXTPFlowGraphConnectionPoint, CXTPFlowGraphNode, CXTPGridColumn, CXTPGridGroupRow, CXTPGridRecordItem, CXTPPropertyGridInplaceButton, CXTPPropertyGridItem, CXTPShortcutBarItem, CXTPStatusBarPane, CXTPTabManagerItem, CXTPTabManagerNavigateButton, CXTPTaskPanelItem, CXTPTrackBlock
  • GetToolTipContext() : CXTPButton, CXTPChartControl, CXTPCommandBars, CXTPDockingPaneManager, CXTPFlowGraphControl, CXTPGridControl, CXTPMarkupContext, CXTPPropertyGrid, CXTPShortcutBar, CXTPStatusBar, CXTPTabClientWnd, CXTPTabControl, CXTPTaskPanel
  • GetTooltipControl() : CXTPEditListBoxToolBar
  • GetToolTipCtrl() : CXTPColorSelectorCtrl
  • GetTooltipRect() : CXTPCalendarDayViewGroup, CXTPCalendarMonthViewGroup, CXTPCalendarTimeLineView, CXTPCalendarView, CXTPCalendarViewGroup, CXTPGridTip
  • GetToolTips() : CXTPTabView
  • GetTooltipText() : CXTPCalendarTip, CXTPChartSeriesPoint, CXTPGridTip, CXTPTrayIcon
  • GetTop() : CXTPGridThickness, CXTPMarkupThickness, CXTPRectT< T >
  • GetTopClassForFileExt() : CXTPSyntaxEditLexTextSchema
  • GetTopContainer() : CXTPDockingPaneSidePanel
  • GetTopIndex() : CXTPPropertyGrid
  • GetTopPane() : CXTPDockingPaneManager, CXTPDockingPaneMiniWnd
  • GetTopRow() : CXTPCalendarDayView, CXTPCalendarDayViewGroup, CXTPSyntaxEditCtrl, CXTPSyntaxEditView
  • GetTopRowIndex() : CXTPGridControl
  • GetTotalArrowWidth() : CXTPExcelTabCtrl
  • GetTotalButtonRect() : CXTPExcelTabCtrl
  • GetTotalTabAreaWidth() : CXTPExcelTabCtrl
  • GetTotalTabWidth() : CXTPExcelTabCtrl
  • GetTrackBrush() : CXTPSplitterWndTheme, CXTPSplitterWndThemeOfficeXP
  • GetTrackColumn() : CXTPTrackControl
  • GetTrackColumnIndex() : CXTPTrackControl
  • GetTrackControl() : CXTPTrackControlItem
  • GetTrackFocus() : CXTPCommandBar
  • GetTrackOffset() : CXTPTrackControl
  • GetTrackPaintManager() : CXTPTrackControl
  • GetTrait() : CXTPGaugeBaseType
  • GetTraits() : CXTPGaugeTraits
  • GetTraitsArgument() : CXTPGaugeTraits
  • GetTransparency() : CXTPChartAreaSeriesStyle, CXTPChartRadarAreaSeriesStyle, CXTPChartSeriesLabel, CXTPChartSeriesStyle, CXTPFrameShadow, CXTPPopupControl
  • GetTransparentColor() : CXTPTransparentBitmap
  • GetTreeBackColor() : CXTPTreeBase, CXTPTreeTheme
  • GetTreeDepth() : CXTPGridRow
  • GetTreeTextColor() : CXTPTreeBase, CXTPTreeTheme
  • GetTwipSize() : CXTPControlSizeComboBox
  • GetType() : CXTPCalendarData, CXTPCommandBar, CXTPControl, CXTPDockingPaneBase, CXTPFlowGraphConnectionPoint, CXTPGaugeCtrl, CXTPGridRecordItemControl, CXTPGridRow, CXTPTaskPanelItem
  • GetTypeName() : CXTPGaugeBaseType, CXTPGaugeMeterType, CXTPGaugeStateType
  • GetUnderline() : CXTPHyperLink
  • GetUndoManager() : CXTPFlowGraphControl, CXTPTrackControl
  • GetUndoRedoManager() : CXTPSyntaxEditBufferManager
  • GetUndoTextList() : CXTPSyntaxEditCtrl, CXTPSyntaxEditUndoRedoManager
  • GetUnitType() : CXTPMarkupGridLength
  • GetUpButton() : CXTPEditListBoxToolBar
  • GetUpColor() : CXTPChartHighLowSeriesStyle
  • GetUpcomingEvents() : CXTPCalendarData
  • GetUpdatedTextRegion() : CXTPSyntaxEditLexTextSchema
  • GetUpdateRect() : CXTPMarkupVisual
  • GetURL() : CXTPHyperLink
  • GetUseCustomToolTipPosition() : CXTPMarkupContext
  • GetUseEndMethod() : CXTPCalendarRecurrencePattern
  • GetUserColor() : CXTPSyntaxEditColorComboBox
  • GetUserMaxSize() : CXTPMarkupDefinitionBase
  • GetUserMinSize() : CXTPMarkupDefinitionBase
  • GetUserSize() : CXTPFlowGraphNode, CXTPMarkupDefinitionBase
  • GetUseThousandSeparator() : CXTPChartNumberFormat
  • GetUseVisualStyle() : CXTPButton, CXTPComboBox, CXTPEdit, CXTPProgressCtrl, CXTPScrollBar, CXTPSpinButtonCtrl
  • GetValue() : CXTPActiveScriptObjectContext, CXTPCalendarThemeCustomizableXValueT< _TValue, _TValueRef >, CXTPCalendarViewPartCustomizableValueT< _TValue >, CXTPChartColor, CXTPChartSeriesPoint, CXTPGridRecordItemDateTime, CXTPGridRecordItemNumber, CXTPGridRecordItemText, CXTPGridRecordItemVariant, CXTPMarkupGridLength, CXTPMarkupStaticExtensionProperty, CXTPPropertyGridItem, CXTPStatusBarPane
  • GetValueLength() : CXTPChartSeriesPoint
  • GetValueMetrics() : CXTPPropertyGridItem
  • GetValueRect() : CXTPPropertyGridItem, CXTPPropertyGridItemColor, CXTPPropertyGridItemFont
  • GetValueScaleType() : CXTPChartSeries
  • GetValueX() : CXTPCalendarThemeCustomizableXValueT< _TValue, _TValueRef >
  • GetVariableData() : CXTPSyntaxEditLexVariable
  • GetVariableHelpHeight() : CXTPPropertyGrid
  • GetVariableSplitterPos() : CXTPPropertyGrid
  • GetVariance() : CXTPChartSeriesPointCollection
  • GetVarID() : CXTPSyntaxEditLexVariable
  • GetVectorCheckedIcon() : CXTPImageManagerIcon
  • GetVectorDisabledIcon() : CXTPImageManagerIcon
  • GetVectorHotIcon() : CXTPImageManagerIcon
  • GetVectorIcon() : CXTPImageManagerIcon
  • GetVectorPressedIcon() : CXTPImageManagerIcon
  • GetVerbs() : CXTPPropertyGrid
  • GetVerbsHeight() : CXTPPropertyGrid
  • GetVersion() : CXTPDockState, CXTPModuleHandle, CXTPSystemVersion
  • GetVerticalAlignment() : CXTPChartLegend, CXTPMarkupFrameworkElement, CXTPTrackBlock
  • GetVertScrollBar() : CXTPSyntaxEditCtrl, CXTPSyntaxEditView
  • GetView() : CXTPCalendarTimeLineViewEvent, CXTPCalendarTimeLineViewGroup, CXTPCalendarTimeLineViewTimeScale, CXTPCalendarViewDayT< _TView, _TViewGroup, XTP_CALENDAR_HITTESTINFO, _TPThis >, CXTPTabExBase
  • GetView_() : CXTPCalendarViewDay
  • GetViewDay() : CXTPCalendarMonthView::CMonthViewGrid, CXTPCalendarViewGroupT< _TViewDay, _TViewEvent, _TPThis >, CXTPCalendarViewT< _TViewDay >
  • GetViewDay_() : CXTPCalendarMonthView, CXTPCalendarTimeLineViewGroup, CXTPCalendarView, CXTPCalendarViewGroup
  • GetViewDayCount() : CXTPCalendarView
  • GetViewDayDate() : CXTPCalendarDayView, CXTPCalendarMonthView, CXTPCalendarTimeLineView, CXTPCalendarView, CXTPCalendarWeekView
  • GetViewDivider() : CXTPPropertyGrid
  • GetViewEvent() : CXTPCalendarTimeLineViewGroup, CXTPCalendarViewGroupT< _TViewDay, _TViewEvent, _TPThis >
  • GetViewEvent_() : CXTPCalendarViewDay, CXTPCalendarViewGroup
  • GetViewEventByEvent_() : CXTPCalendarViewGroup
  • GetViewEventByPlace_() : CXTPCalendarViewGroup
  • GetViewEventRect() : CXTPCalendarViewEvent
  • GetViewEventRectMax() : CXTPCalendarViewEvent
  • GetViewEventsCount() : CXTPCalendarViewDay, CXTPCalendarViewGroup
  • GetViewGroup() : CXTPCalendarTimeLineViewEvent, CXTPCalendarViewDayT< _TView, _TViewGroup, XTP_CALENDAR_HITTESTINFO, _TPThis >, CXTPCalendarViewEventT< _TViewGroup >
  • GetViewGroup_() : CXTPCalendarTimeLineViewEvent, CXTPCalendarViewDay, CXTPCalendarViewEvent, CXTPCalendarViewEventT< _TViewGroup >
  • GetViewGroupsCount() : CXTPCalendarViewDay
  • GetViewMaxValue() : CXTPChartAxisRange
  • GetViewMinValue() : CXTPChartAxisRange
  • GetViewName() : CXTPTabExBase
  • GetViewPortMax() : CXTPTrackControl
  • GetViewPortMin() : CXTPTrackControl
  • GetViewRect() : CXTPCalendarView, CXTPCalendarWeekViewEvent
  • GetViewRotationMatrix() : CXTPChart3dDiagram
  • GetViewType() : CXTPCalendarDayView, CXTPCalendarTimeLineView, CXTPCalendarView, CXTPCalendarViewT< _TViewDay >
  • GetViewValue() : CXTPPropertyGridItem, CXTPPropertyGridItemBool
  • GetVisibility() : CXTPMarkupUIElement
  • GetVisible() : CXTPCalendarDayViewTimeScale
  • GetVisibleAt() : CXTPControls, CXTPGridColumns
  • GetVisibleButtonCount() : CXTPDatePickerButtons
  • GetVisibleColumns() : CXTPGridColumns
  • GetVisibleColumnsCount() : CXTPGridColumns
  • GetVisibleCount() : CXTPControls
  • GetVisibleIndex() : CXTPGridColumn
  • GetVisibleItemsCount() : CXTPShortcutBar
  • GetVisiblePaneCount() : CXTPStatusBar
  • GetVisibleRange() : CXTPDatePickerControl
  • GetVisibleRow() : CXTPSyntaxEditCtrl
  • GetVisibleRowCount() : CXTPCalendarDayView, CXTPCalendarDayViewGroup
  • GetVisibleRowsCount() : CXTPSyntaxEditCtrl
  • GetVisited() : CXTPHyperLink
  • GetVisitedColor() : CXTPHyperLink
  • GetVisualChild() : CXTPMarkupVisual
  • GetVisualChildrenCount() : CXTPMarkupVisual
  • GetVisualOffset() : CXTPMarkupVisual
  • GetVisualParent() : CXTPMarkupVisual
  • GetWatermarkAlignment() : CXTPGridControl
  • GetWatermarkBitmap() : CXTPGridControl
  • GetWeekDayCol() : CXTPCalendarMonthView::CMonthViewGrid
  • GetWeekDayForColIndex() : CXTPCalendarMonthView::CMonthViewGrid
  • GetWeekDayTextIfNeed() : CXTPCalendarMonthView
  • GetWeekNumbersBackColor() : CXTPDatePickerPaintManager
  • GetWeekNumbersTextColor() : CXTPDatePickerPaintManager
  • GetWeekNumbersTextFont() : CXTPDatePickerPaintManager
  • GetWeekOfYear() : CXTPCalendarUtils
  • GetWeeksCount() : CXTPCalendarMonthView::CMonthViewGrid
  • GetWeekView() : CXTPCalendarControl
  • GetWideCaret() : CXTPSyntaxEditCtrl
  • GetWidth() : CXTPCalendarDayViewTimeScale, CXTPCommandBar, CXTPControl, CXTPFlowGraphConnection, CXTPGridColumn, CXTPGridHeader, CXTPGridInplaceButton, CXTPGridRecordItemControl, CXTPImageManagerIcon, CXTPMarkupFrameworkElement, CXTPMatrix< T >, CXTPPropertyGridInplaceButton, CXTPResourceImage, CXTPSkinImage, CXTPStatusBarPane, CXTPStatusBarSwitchPane, CXTPTabClientDraggingContents
  • GetWindow() : CXTPControlTabWorkspace
  • GetWindowDateTime() : CXTPDateEdit
  • GetWindowHandle() : CXTPFlowGraphNode
  • GetWindowSize() : CXTPFlowGraphNode
  • GetWindowTextEx() : CXTPCommandBarEditCtrl
  • GetWindowTheme() : CXTPWinThemeWrapper
  • GetWinThemeWrapperTheme() : CXTPColorManager
  • GetWnd() : IXTPScrollable
  • GetWndWidth() : CXTPSyntaxEditAutoCompleteWnd
  • GetWorkArea() : CXTPMultiMonitor
  • GetWorkAreaMax() : CXTPTrackControl
  • GetWorkAreaMin() : CXTPTrackControl
  • GetWorkDayEndTime() : CXTPCalendarControl
  • GetWorkDayStartTime() : CXTPCalendarControl
  • GetWorkRect() : CXTPFlowGraphNodeGroup
  • GetWorkspace() : CXTPTabClientWnd
  • GetWorkspaceCount() : CXTPTabClientWnd
  • GetWorkWeekMask() : CXTPCalendarControl
  • GetWrap() : CXTPControl
  • GetX() : CXTPMarkupTranslateTransform
  • GetXLC() : XTP_EDIT_LINECOL
  • GetXML() : CXTPPropExchangeXMLNode
  • GetXtremeColor() : CXTPDockingPanePaintManager, CXTPPaintManager
  • GetY() : CXTPMarkupTranslateTransform
  • GetYear() : CXTPPropertyGridItemDate
  • GetZoomLevel() : CXTPFlowGraphControl, CXTPFlowGraphPage
  • GetZoomParam() : CXTPFlowGraphControl
  • GetZoomState() : CXTPPreviewView
  • GiveFeedback() : CXTPDropSource
  • GoBackward() : CXTPFlowGraphPageHistory
  • GoForward() : CXTPFlowGraphPageHistory
  • GoModal() : CXTPDatePickerControl
  • GoToPage() : IXTPPreview
  • GoToRow() : CXTPSyntaxEditCtrl
  • GotoURL() : CXTPHyperLink
  • GradientFill() : CXTPPaintManager, CXTPTabPaintManagerColorSet
  • GradientFillTabFace() : CXTPTabBaseThemeOffice2003


Toolkit Pro: Class Members - Functions

Here is a list of all documented functions with links to the class documentation for each member:

- h -

  • HandleDrop() : CXTPSyntaxEditCtrl
  • HasApplyOptions() : CXTPSkinManager
  • HasBookmarks() : CXTPSyntaxEditCtrl
  • HasBorders() : CXTPStatusBarPane
  • HasBottomSeparator() : CXTPControlGallery
  • HasBounds() : CXTPArcBall
  • HasBreakpoints() : CXTPSyntaxEditCtrl
  • HasCaptions() : CXTPColorSelectorCtrl
  • HasCheckbox() : CXTPGridRecordItem
  • HasCheckedIcon() : CXTPImageManagerIcon
  • HasChildren() : CXTPGridRecord, CXTPGridRow
  • HasChilds() : CXTPPropertyGridItem
  • HasCloseButton() : CXTPCaption
  • HasDisabledIcon() : CXTPImageManagerIcon
  • HasDwmCompositedRect() : CXTPControl
  • HasEditLabels() : CXTPTreeBase
  • HasFlag() : CXTPResize
  • HasFloatingBarGradientEntry() : CXTPCommandBarsOffice2003Theme
  • HasFocus() : CXTPControlComboBox, CXTPControlEdit, CXTPGridControl, CXTPGridRows, CXTPListBox
  • HasHotIcon() : CXTPImageManagerIcon
  • HasHScroll() : IXTPScrollable
  • HasIcon() : CXTPImageManagerIcon
  • HasLeftScrollbar() : IXTPScrollable
  • HasMergedItems() : CXTPGridRow
  • HasNormalIcon() : CXTPImageManagerIcon
  • HasOwnNavigator() : IXTPPreview
  • HasParent() : CXTPGridRow, CXTPPropertyGridItem
  • HasPressedIcon() : CXTPImageManagerIcon
  • HasRowMark() : CXTPSyntaxEditCtrl, CXTPSyntaxEditLineMarksManager
  • HasSelectedViewEvent() : CXTPCalendarView
  • HasSelection() : CXTPEdit
  • HasSharedBorder() : CXTPSpinButtonCtrl
  • HasSortArrow() : CXTPHeaderCtrl, CXTPHeaderCtrlTheme
  • HasSortTriangle() : CXTPGridColumn
  • HasText() : CXTPProgressCtrl
  • HasToolbar() : CXTPEditListBox
  • HasVisibleChilds() : CXTPPropertyGridItem
  • HasVScroll() : IXTPScrollable
  • HeaderHasFocus() : CXTPRibbonControlTab, CXTPTabControl, CXTPTabManager
  • Height() : CXTPResizeRect
  • Hide() : CXTPDockingPane, CXTPFrameShadow, CXTPPopupControl, CXTPSyntaxEditAutoCompleteWnd, CXTPSyntaxEditToolTipCtrl
  • HideClient() : CXTPDockingPaneManager
  • HideColumn() : CXTPSplitterWnd
  • HideCommand() : CXTPCommandBars
  • HideCommands() : CXTPCommandBars
  • HideIcon() : CXTPTrayIcon
  • HideKeyboardTips() : CXTPCommandBar, CXTPCommandBars
  • HidePane() : CXTPDockingPaneManager
  • HideRow() : CXTPSplitterWnd
  • HideSelection() : CXTPControlGallery
  • HideTip() : CXTPSyntaxEditTipWnd
  • HideTipWindow() : CXTPTipWindow
  • HideToolTip() : CXTPCalendarControl, CXTPCalendarViewEvent
  • HideWindow() : CXTPGridInplaceEdit, CXTPPropertyGridInplaceEdit
  • HighlightChangedButtonItems() : CXTPPropertyGrid
  • HighlightChangedItems() : CXTPPropertyGrid
  • HighlightWorkArea() : CXTPTrackControlItem
  • HitTest() : CXTPCalendarCaptionBarThemePart, CXTPCalendarTimeLineView, CXTPCalendarTimeLineViewEvent, CXTPCalendarTimeLineViewGroup, CXTPCalendarView, CXTPCalendarViewDay, CXTPCalendarViewEvent, CXTPCalendarViewGroup, CXTPChart3dLineDeviceCommand, CXTPChart3dRotateDeviceCommand, CXTPChartBoundedTextDeviceCommand, CXTPChartCircleDeviceCommand, CXTPChartControl, CXTPChartDeviceCommand, CXTPChartHitTestElementCommand, CXTPChartLineDeviceCommand, CXTPChartMarkupElementDeviceCommand, CXTPChartRectangleDeviceCommand, CXTPChartRotateDeviceCommand, CXTPControls, CXTPDatePickerButtons, CXTPDatePickerControl, CXTPDatePickerItemMonth, CXTPDockingPaneAutoHidePanel, CXTPDockingPaneWindowSelect, CXTPExcelTabCtrl, CXTPGridControl, CXTPGridHeader, CXTPGridRecordItem, CXTPGridRow, CXTPGridSections, CXTPHeaderCtrl, CXTPMouseManager, CXTPPopupControl, CXTPPropertyGrid, CXTPPropertyGridInplaceButtons, CXTPRibbonBackstageView, CXTPRibbonGroups, CXTPShortcutBar, CXTPShortcutBarPane, CXTPSpinButtonCtrl, CXTPStatusBar, CXTPStatusBarSwitchPane, CXTPSyntaxEditAutoCompleteWnd, CXTPSyntaxEditDrawTextProcessor, CXTPSyntaxEditTipListBox, CXTPTabClientSticker, CXTPTabClientWnd, CXTPTabManager, CXTPTagCloudCtrl, CXTPTaskDialogLinkCtrl, CXTPTaskPanelGroup, CXTPTrackControl, CXTPTrackControlItem, CXTPTrackMarkers
  • HitTestAllDayEventsScrollIcons() : CXTPCalendarDayViewGroup
  • HitTestButton() : CXTPMessageBar
  • HitTestConnection() : CXTPFlowGraphControl
  • HitTestConnectionArea() : CXTPFlowGraphConnectionPoint, CXTPFlowGraphControl, CXTPFlowGraphPaintManager
  • HitTestConnectionPoint() : CXTPFlowGraphNode, CXTPFlowGraphNodeCustom
  • HitTestDateTime() : CXTPCalendarDayViewGroup, CXTPCalendarDayViewTimeScale
  • HitTestDiagramView() : CXTPChartContentView
  • HitTestEx() : CXTPCalendarDayView, CXTPCalendarDayViewEvent, CXTPCalendarDayViewGroup, CXTPCalendarMonthViewDay, CXTPCalendarMonthViewEvent, CXTPCalendarTimeLineView, CXTPCalendarTimeLineViewEvent, CXTPCalendarTimeLineViewTimeScale, CXTPCalendarView, CXTPCalendarViewDay, CXTPCalendarViewEvent, CXTPCalendarViewGroup, CXTPCalendarWeekViewDay, CXTPCalendarWeekViewEvent, CXTPListBase
  • HitTestGroup() : CXTPRibbonBar, CXTPRibbonTabPopupToolBar, CXTPTaskPanel
  • HitTestHeaderColumnIndex() : CXTPGridHeader
  • HitTestHyperlink() : CXTPGridRecordItem
  • HitTestItem() : CXTPControlGallery, CXTPTaskPanel
  • HitTestLineSegment() : CXTPMathUtils
  • HitTestMarkupItem() : CXTPMarkupTreeCtrl
  • HitTestNavigateButton() : CXTPTabManager
  • HitTestNode() : CXTPFlowGraphControl
  • HitTestRow() : CXTPSyntaxEditDrawTextProcessor
  • HitTestScrollBar() : CXTPScrollBase
  • HitTestScrollButton() : CXTPTaskPanel
  • HitTestThemeBackground() : CXTPWinThemeWrapper
  • HitTestVerbs() : CXTPPropertyGridPaintManager
  • HLStoRGB() : CXTPColorBase
  • Home() : CXTPExcelTabCtrl
  • HookKeyboard() : CXTPKeyboardManager
  • HorizontalLine() : CXTPPaintManager, CXTPTabBaseTheme
  • HorzEventScroll() : CXTPCalendarDayView
  • HTMLDesktop() : CXTPShellSettings


Toolkit Pro: Class Members - Functions

Here is a list of all documented functions with links to the class documentation for each member:

- i -

  • IDLFromPath() : CXTPShellPidl
  • IgnoreLButtonUp() : CXTPMouseManager
  • ImageChanged() : CXTPFlowGraphImage
  • ImplAttach() : CXTPListBase, CXTPTabBase
  • Import() : CXTPMemFile
  • Include() : CXTPChart3dBox, CXTPGridSubListControl
  • IncreaseIndent() : CXTPSyntaxEditCtrl
  • IndexOf() : CXTPChartElementCollection, CXTPChartStrings, CXTPGridColumnOrder, CXTPGridColumns, CXTPGridRecord, CXTPRibbonBackstageView, CXTPRibbonGroup, CXTPRibbonQuickAccessControls, CXTPTrackMarkers
  • Inflate() : CXTPRectT< T >
  • Init() : CXTPCalendarBusyStatusComboBox, CXTPCalendarComboBoxBase, CXTPCalendarEventCategoryComboBox, CXTPCalendarEventColorListBox, CXTPCalendarEventLabelComboBox, CXTPCheckListBox, CXTPColorBase, CXTPColorHex, CXTPDockingPaneMiniWnd, CXTPDockingPaneSidePanel, CXTPDockingPaneSplitterContainer, CXTPDockingPaneTabbedContainer, CXTPExcelTabCtrl, CXTPEyeDropper, CXTPFontEnum, CXTPHyperLink, CXTPImageManagerIconHandle, CXTPListBase, CXTPMDIWndTab, CXTPModuleHandle, CXTPResize, CXTPScrollBarCtrl, CXTPSearchOptionsCtrl, CXTPShellListBase, CXTPShellTreeCtrl, CXTPSpinButtonCtrl, CXTPSyntaxEditColorComboBox, CXTPTabBase, CXTPTabExBase, CXTPTabView, CXTPTearOffFrame, CXTPThemeDLL, CXTPTreeBase
  • InitBitmaps() : CXTPSyntaxEditPaintManager
  • InitBusyStatusDefaultColors() : CXTPCalendarPaintManager
  • InitClassData() : CXTPSyntaxEditPropertiesPageColor
  • InitColorComboxes() : CXTPSyntaxEditPropertiesPageFont
  • InitCommandBars() : CXTPCommandBarsSiteBase< TBase >
  • InitControl() : CXTPFontComboBox
  • InitDayOfWeekCBs() : CXTPCalendarEventRecurrenceDlg
  • InitDefaultStyles() : CXTPTagCloudStyleManager
  • InitDefaultValues() : CXTPCalendarEventCategories, CXTPCalendarEventLabels
  • InitDurationCB() : CXTPCalendarEventRecurrenceDlg
  • InitFont() : CXTPHyperLink
  • InitFontCombo() : CXTPSyntaxEditPropertiesPageFont
  • InitFromRegistry() : CXTPCalendarTimeZones
  • InitHistoryCombo() : CXTPSyntaxEditFindReplaceDlg
  • Initialize() : CXTPActiveScriptEngine, CXTPBrowseEdit, CXTPChartDeviceContext, CXTPComboBox, CXTPEditListBox, CXTPEditListBoxToolBar, CXTPFontListBox, CXTPListBox, CXTPMaskEdit
  • InitializeFont() : CXTPMDIWndTab, CXTPTabExBase
  • InitializeHeader() : CXTPHeaderCtrl
  • InitializeSize() : CXTPTipWindow
  • InitializeTree() : CXTPShellTreeBase
  • InitialSelectionEnable() : CXTPGridControl
  • InitIcons() : CXTPPasswordPeek
  • InitListViewItems() : CXTPShellListBase
  • InitLoop() : CXTPDockingPaneContext
  • InitMonthCBs() : CXTPCalendarEventRecurrenceDlg
  • InitNames() : CXTPDatePickerControl
  • InitReminderComboBox() : CXTPCalendarEventPropertiesDlg
  • InitResourceHandle() : CXTPResourceImages
  • InitResources() : CXTPAuxData
  • InitRow() : CXTPGridRow
  • InitSchemaClasses() : CXTPSyntaxEditPropertiesPageColor
  • InitScriptCombo() : CXTPSyntaxEditPropertiesPageFont
  • InitScrollBars() : CXTPScrollable< Base >
  • InitSection() : CXTPPropExchange
  • InitSizeCombo() : CXTPSyntaxEditPropertiesPageFont
  • InitStandartVarsIfNeed() : CXTPSyntaxEditLexVariable
  • InitStartEndCB() : CXTPCalendarEventRecurrenceDlg
  • InitStyleCombo() : CXTPSyntaxEditPropertiesPageFont
  • InitSystemImageLists() : CXTPShellListBase, CXTPShellTreeBase
  • InitTreeNode() : CXTPShellTreeBase
  • InitTreeViewItems() : CXTPShellTreeBase
  • InitWhichDayCBs() : CXTPCalendarEventRecurrenceDlg
  • InputHitTest() : CXTPMarkupVisual
  • InputHitTestOverride() : CXTPMarkupVisual
  • Insert() : CXTPControlActions, CXTPMemFile
  • InsertAllCommandsCategory() : CXTPCustomizeCommandsPage
  • InsertAt() : CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE >, CXTPCalendarEvents, CXTPCalendarPtrCollectionT< _TObject >, CXTPChartElementCollection, CXTPControls, CXTPGridColumnOrder, CXTPGridRecords, CXTPGridRows, CXTPPropertyGridItems, CXTPRibbonGroup, CXTPRibbonGroups, CXTPTabManagerNavigateButtons, CXTPTaskPanelItems
  • InsertBuiltInMenus() : CXTPCustomizeCommandsPage
  • InsertCategory() : CXTPCustomizeCommandsPage, CXTPCustomizeKeyboardPage, CXTPPropertyGrid, CXTPPropertyGridView, CXTPRibbonCustomizePage, CXTPRibbonCustomizeQuickAccessPage, CXTPTabToolBar
  • InsertCharAt() : CXTPMaskEditT< TBase >
  • InsertChildItem() : CXTPPropertyGridItem
  • InsertCommas() : CXTPShellListBase
  • InsertDesktopItem() : CXTPShellTreeBase
  • InsertItem() : CXTPControlGalleryItems, CXTPExcelTabCtrl, CXTPTabControl
  • InsertMDIChild() : CXTPWindowList
  • InsertMenuItem() : CXTPShortcutListBox
  • InsertNewMenuCategory() : CXTPCustomizeCommandsPage
  • InsertPage() : CXTPPropertySheet
  • InsertRow() : CXTPGridControl, CXTPSyntaxEditCtrl
  • InsertSortColumn() : CXTPGridColumns
  • InsertStr() : CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager
  • InsertString() : CXTPControlComboBox, CXTPSyntaxEditCtrl
  • InsertTab() : CXTPRibbonBar
  • InsertTabWnd() : CXTPMDIWndTab
  • InsertText() : CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager, CXTPSyntaxEditBufferManager
  • InsertTextBlock() : CXTPSyntaxEditBufferManager, CXTPSyntaxEditCtrl
  • Install() : CXTPMDIWndTab
  • InstallDockingPanes() : CXTPDockingPaneManager
  • InstallIconPending() : CXTPTrayIcon
  • Instance() : CXTPSingleton< T, Dependencies >, CXTPToolhelpApi
  • InternalTextChanged() : CXTPButton
  • InternalToValue() : CXTPChartDateTimeScaleTypeMap, CXTPChartNumericalScaleTypeMap, CXTPChartQualitativeScaleTypeMap, CXTPChartScaleTypeMap, CXTPChartTimeScaleTypeMap
  • Intersect() : CXTPRectT< T >
  • IntersectsWith() : CXTPRectT< T >
  • InvalidateArrange() : CXTPMarkupUIElement
  • InvalidateCheck() : CXTPCheckListBox
  • InvalidateCommandBars() : CXTPCommandBars
  • InvalidateItem() : CXTPCheckListBox
  • InvalidateItems() : CXTPControlGallery
  • InvalidateMeasure() : CXTPMarkupUIElement
  • InvalidateMeasureOverride() : CXTPMarkupUIElement
  • InvalidatePane() : CXTPDockingPaneAutoHidePanel, CXTPDockingPaneBase, CXTPDockingPaneMiniWnd, CXTPDockingPaneSidePanel
  • InvalidateParents() : CXTPCommandBar
  • InvalidateRect() : CXTPDockingPaneCaptionButton
  • InvalidateRow() : CXTPSyntaxEditCtrl
  • InvalidateRows() : CXTPSyntaxEditCtrl
  • InvalidateTabs() : CXTPExcelTabCtrl
  • InvalidateVisual() : CXTPMarkupUIElement
  • Invert() : CXTPGridSelectedRows
  • InvertAlphaBitmap() : CXTPImageManagerIcon
  • InvertBitmap() : CXTPResourceImage
  • Invoke() : CXTPActiveScriptObjectContext
  • InvokeAction() : CXTPGaugeBaseType
  • InvokeWithArgs() : CXTPActiveScriptObjectContext
  • Is3D() : CXTPChartDeviceContext, CXTPChartObject
  • Is3dEdgeSmoothingEnabled() : CXTPChartSeriesStyle
  • IsAcceptFocus() : CXTPTaskPanelGroup, CXTPTaskPanelItem
  • IsActionsEnabled() : CXTPCommandBars
  • IsActive() : CXTPDialogBar, CXTPDockingPaneBase, CXTPDockingPaneMiniWnd, CXTPDockingPaneSidePanel, CXTPDockingPaneTabbedContainer, CXTPRibbonBar, CXTPSkinObjectFrame, CXTPSyntaxEditAutoCompleteWnd, CXTPSyntaxEditCtrl, CXTPTabManager
  • IsActiveTab() : CXTPRibbonBackstageView
  • IsAdditionalScaleLeftVisible() : CXTPCalendarDayView
  • IsAdditionalScaleRightVisible() : CXTPCalendarDayView
  • IsAdvancedMode() : CXTPCalendarTip
  • IsAllCaps() : CXTPCommandBars
  • IsAllDayEvent() : CXTPCalendarEvent
  • IsAllowAccess() : CXTPGridSection
  • IsAllowBlobValues() : CXTPPropExchange, CXTPPropExchangeArchive, CXTPPropExchangeRegistry
  • IsAllowColumnRemove() : CXTPGridHeader
  • IsAllowColumnReorder() : CXTPGridHeader
  • IsAllowColumnResize() : CXTPGridHeader
  • IsAllowColumnSort() : CXTPGridHeader
  • IsAllowDefaultValues() : CXTPPropExchange, CXTPPropExchangeArchive
  • IsAllowDrag() : CXTPTaskPanelItem
  • IsAllowDragging() : CXTPGridColumn
  • IsAllowDrop() : CXTPTaskPanelItem
  • IsAllowEdit() : CXTPGridSection, CXTPPropertyGridItem
  • IsAllowFilter() : CXTPGridSection
  • IsAllowFreeResize() : CXTPShortcutBar
  • IsAllowGroup() : CXTPGridSection
  • IsAllowMinimize() : CXTPShortcutBar
  • IsAllowNoncontinuousSelection() : CXTPDatePickerControl
  • IsAllowQuickAccessControl() : CXTPRibbonBar
  • IsAllowQuickAccessDuplicates() : CXTPRibbonBar
  • IsAllowRemove() : CXTPGridColumn
  • IsAllowReorder() : CXTPTabClientWnd, CXTPTabManager
  • IsAllowSort() : CXTPGridSection
  • IsAlpha() : CXTPGraphicBitmapPng, CXTPImageManagerIcon, CXTPImageManagerIconHandle, CXTPSvgImage
  • IsAlphaBitmapFile() : CXTPImageManagerIcon
  • IsAlphaBitmapResource() : CXTPImageManager, CXTPImageManagerIcon
  • IsAlphaDockingContext() : CXTPDockingPaneManager
  • IsAlphaIconHandle() : CXTPImageManagerIcon
  • IsAlphaIconsImageListSupported() : CXTPImageManager
  • IsAlphaIconsSupported() : CXTPImageManager
  • IsAlphaImage() : CXTPResourceImage, CXTPSkinImage
  • IsAlphaShadow() : CXTPShadowManager
  • IsAnimationEnabled() : CXTPCommandBar
  • IsAppCaption() : CXTPCaption
  • IsAppThemeActive() : CXTPWinThemeWrapper
  • IsAppThemed() : CColorSetWinNative, CXTPTabPaintManagerColorSet, CXTPWinThemeWrapper
  • IsAppThemeReady() : CXTPWinThemeWrapper
  • IsAttached() : CXTPTabClientWnd
  • IsAuto() : CXTPMarkupGridLength
  • IsAutoCheckItems() : CXTPGridControl
  • IsAutoColumnSizing() : CXTPGridHeader
  • IsAutoHeight() : CXTPTaskPanelGroupItem
  • IsAutomaticUpdateEnabled() : CXTPGaugeBaseType
  • IsAutoPopup() : CXTPCalendarRemindersDialog
  • IsAutoPreviewActivateEnabled() : CXTPPreviewCtrl
  • IsAutoSize() : CXTPDatePickerControl, CXTPGridColumn
  • IsAutoSortWhenGrouped() : CXTPGridColumn
  • IsAvailable() : CXTPWebViewProvider, IXTPPreview
  • IsBackstageViewVisible() : CXTPRibbonBar
  • IsBalloonStyleSupported() : CXTPToolTipContext
  • IsBarVisible() : CXTPPropertyGrid
  • IsbBlockSelectionMode() : CXTPSyntaxEditSelection
  • IsBeingFrequentlyUpdated() : CXTPChartContainer
  • IsBent() : CXTPChart3dPieSeriesLabelDeviceCommand
  • IsBold() : CXTPGridRecordItem, CXTPPopupItem, CXTPTaskPanelGroupItem
  • IsBoldDaysOnIdle() : CXTPCalendarController
  • IsBoldDaysWithEvents() : CXTPCalendarController
  • IsBorderVisible() : CXTPSplitterWnd
  • IsBottom() : CXTPTabBaseTheme
  • IsBrowsing() : CXTPBrowseEdit
  • IsBuddyButtonVisible() : CXTPControlEdit
  • IsBuiltIn() : CXTPToolBar
  • IsButton() : CXTPPopupItem, CXTPStatusBarPane
  • IsCaptionButtonVisible() : CXTPDockingPaneBase, CXTPDockingPaneMiniWnd, CXTPDockingPaneTabbedContainer
  • IsCaptionMaximizeButtonsVisible() : CXTPDockingPaneManager
  • IsCaptionVertical() : CXTPDockingPaneBase, CXTPDockingPaneMiniWnd, CXTPDockingPaneSidePanel, CXTPDockingPaneTabbedContainer
  • IsCaptionVisible() : CXTPCommandBarsFrameHook, CXTPControl, CXTPControlComboBox, CXTPControlEdit, CXTPRibbonBar, CXTPTaskPanelGroup
  • IsCaseSensitive() : CXTPGridRecords, CXTPSyntaxEditLexClass
  • IsCategory() : CXTPPropertyGridItem
  • IsCellMergingAllowed() : CXTPGridControl
  • IsChanged() : CXTPControls, CXTPGridControl, CXTPGridSelectedRows
  • IsCheckBoxStyle() : CXTPPropertyGridItemBool, CXTPPropertyGridItemOption
  • IsChecked() : CXTPGridRecordItem, CXTPStatusBarPane
  • IsChildItemDragOver() : CXTPTaskPanelGroup
  • IsChildOfMerge() : CXTPGridRecordItem
  • IsChildView() : CXTPTabExBase
  • IsClearTypeTextQualitySupported() : CXTPSystemVersion
  • IsClientHidden() : CXTPDockingPaneManager
  • IsClientPaneVisible() : CXTPShortcutBar
  • IsClosable() : CXTPTabManagerItem
  • IsCloseable() : CXTPToolBar
  • IsClosed() : CXTPDockingPane
  • IsCloseTag() : CXTPSyntaxEditAutoCompleteWnd
  • IsColFrozen() : CXTPHeaderCtrl
  • IsCollapsable() : CXTPSyntaxEditLexClass
  • IsCollapsed() : CXTPDockingPaneMiniWnd, CXTPDockingPaneSidePanel
  • IsColorDlgVisible() : CXTPColorSelectorCtrl
  • IsColorEach() : CXTPChartSeriesStyle
  • IsColorFilterExists() : CXTPSkinManager
  • IsColorStatic() : CXTPColorSelectorCtrl
  • IsColumHotTrackingEnabled() : CXTPGridPaintManager, CXTPGridThemeExplorer, CXTPGridThemeOffice2003Luna, CXTPTrackThemeExplorer, CXTPTrackThemeOffice2003Luna
  • IsColumnPlusMinusSign() : CXTPGridPaintManager
  • IsColumnWidthWYSIWYG() : CXTPGridPaintManager
  • IsComCtlV6() : CXTPSkinManager
  • IsComCtlValid() : CXTPAuxData
  • IsCommand() : CXTPRibbonBackstageView
  • IsCommandEnabled() : CXTPCommandBarEditCtrl
  • IsCommandHidden() : CXTPCommandBars
  • IsCommitted() : CXTPChartDeviceCommand
  • IsConfigFileMode() : CXTPSyntaxEditCtrl
  • IsConnectorVisible() : CXTPChart3dFunnelSeriesLabelView, CXTPChart3dPieSeriesLabelView, CXTPChart3dPyramidSeriesLabelView
  • IsContextMenu() : CXTPPopupBar
  • IsContextMenuPresent() : CXTPToolBar
  • IsControlEnabled() : CXTPRibbonBar
  • IsControlHidden() : CXTPCommandBars
  • IsControlsCentering() : CXTPRibbonGroup
  • IsControlsGrouping() : CXTPRibbonGroup
  • IsCreated() : CXTPFrameShadow
  • IsCreateScrollbarOnParent() : CXTPSyntaxEditCtrl
  • IsCrossAxis() : CXTPChartAxisTickMarks
  • IsCursorOver() : CXTPControl
  • IsCustomizable() : CXTPCommandBar, CXTPControlComboBoxList
  • IsCustomizeAvail() : CXTPCommandBars
  • IsCustomizeDialogPresent() : CXTPCommandBar, CXTPToolBar
  • IsCustomizeMode() : CXTPCommandBar, CXTPCommandBars, CXTPControl
  • IsCustomizeMovable() : CXTPControl
  • IsCustomizeResizeAllow() : CXTPControl, CXTPControlComboBox, CXTPControlEdit
  • IsCustomMarkup() : CXTPFlowGraphNode, CXTPFlowGraphNodeCustom
  • IsCustomValue() : CXTPCalendarThemeCustomizableXValueT< _TValue, _TValueRef >, CXTPCalendarViewPartCustomizableValueT< _TValue >, CXTPPaintManagerColor
  • IsDark() : CXTPStatusBarPane
  • IsDateLabel() : CXTPCalendarCaptionBarTheme
  • IsDayInCache() : CXTPCalendarData::CXTPDPCache
  • IsDefaultItemDrawingEnabled() : CXTPTreeBase
  • IsDefaultValue() : CXTPCalendarThemeCustomizableXValueT< _TValue, _TValueRef >, CXTPCalendarViewPartCustomizableValueT< _TValue >, CXTPCalendarViewPartFontValue, CXTPPaintManagerColor
  • IsDialogBar() : CXTPCommandBar, CXTPDialogBar
  • IsDialogCode() : CXTPCommandBarEditCtrl
  • IsDirectDrawSupported() : CXTPImageManagerIcon, CXTPImageManagerVectorImageHandle
  • IsDirectionClockwise() : CXTPChartRadarAxisX
  • IsDirty() : CXTPTaskPanel, CXTPTaskPanelGroup
  • IsDoubleBuffering() : CXTPGridControl
  • IsDoubleGripper() : CXTPPopupBar
  • IsDownAllDayEventsScrollButtonVisible() : CXTPCalendarDayViewGroup
  • IsDpiAware() : CXTPMarkupContext
  • IsDpiBitmapScalingEnabled() : CXTPCommandBarsOptions, CXTPHeaderCtrl, CXTPPopupControl, CXTPToolTipContext
  • IsDpiGalleryItemScalingEnabled() : CXTPCommandBarsOptions
  • IsDpiIconsScalingEnabled() : CXTPRibbonBackstageView
  • IsDpiImageScalingEnabled() : CXTPButton
  • IsDragging() : CXTPGridColumn
  • IsDragHeader() : CXTPGridHeader
  • IsDragMode() : CXTPGridControl
  • IsDrawFocusRect() : CXTPTaskPanel, CXTPTreeTheme
  • IsDrawGridForEmptySpace() : CXTPGridPaintManager
  • IsDrawNowLine() : CXTPCalendarDayViewTimeScale
  • IsDrawNowLineOverAppoinment() : CXTPCalendarDayView
  • IsDrawReverted() : CXTPImageManager
  • IsDrawStaticFrame() : CXTPTabManager
  • IsDropDownStyle() : CXTPButton
  • IsDroppedDown() : CXTPComboBox
  • IsDroppedOff() : CXTPTaskPanelItem
  • IsDwmEnabled() : CXTPCommandBars, CXTPCommandBarsFrameHook, CXTPRibbonBar
  • IsEditable() : CXTPGridColumn, CXTPGridRecord, CXTPGridRecordItem
  • IsEditingSubject() : CXTPCalendarView, CXTPCalendarViewEvent
  • IsEditMode() : CXTPGridControl
  • IsEditOnClick() : CXTPGridControl
  • IsEditOnDelayClick() : CXTPGridControl
  • IsEditOnDoubleClick() : CXTPGridControl
  • IsEditOperationDisabledNotify() : CXTPCalendarView
  • IsEmpty() : CXTPChartColor, CXTPDockingPaneBase, CXTPDockingPaneBaseContainer, CXTPHeapString, CXTPImageManagerIconHandle, CXTPPropertyGridItemConstraints, CXTPPropertyGridItems, CXTPPropertyGridUpdateContext, CXTPPropertyGridVerbs, CXTPSizeT< T >
  • IsEmptyArea() : CXTPRectT< T >
  • IsEnabled() : CXTPChart3dDeviceCommand, CXTPChartDeviceCommand, CXTPCheckListBox, CXTPDockingPaneCaptionButton, CXTPMarkupUIElement, CXTPShortcutBarItem, CXTPSkinManager, CXTPStatusBarPane, CXTPTabManagerItem, CXTPTabManagerNavigateButton
  • IsEnabledEditAccelerators() : CXTPSyntaxEditCtrl
  • IsEnabledVirtualSpace() : CXTPSyntaxEditCtrl
  • IsEnabledWhiteSpace() : CXTPSyntaxEditCtrl
  • IsEnableFrameTheme() : CXTPCommandBars
  • IsEnsureFocusedRowVisible() : CXTPGridControl
  • IsEOF() : CXTPSyntaxEditTextIterator
  • IsEqual() : CXTPCalendarTimeZone, CXTPCalendarUtils
  • IsEqualHeight() : CXTPChartFunnelSeriesStyleBase
  • IsEqualID() : CXTPCalendarReminder
  • IsEqualIDs() : CXTPCalendarEvent
  • IsEqualLexClasses() : CXTPSyntaxEditLexTextBlock
  • IsEqualStartEnd() : CXTPCalendarEvent
  • IsEventInCache() : CXTPCalendarData::CXTPDPCache
  • IsEventVisible() : CXTPCalendarEvent
  • IsExist() : CXTPCalendarData::EventsMapByID_T< _TObject >
  • IsExpandable() : CXTPPropertyGridItem, CXTPShortcutBarPaneItem, CXTPTaskPanel, CXTPTaskPanelGroup
  • IsExpandButton() : CXTPCalendarCaptionBarTheme
  • IsExpandButtonVisible() : CXTPShortcutBar
  • IsExpandDown() : CXTPCalendarDayView, CXTPCalendarDayViewGroup
  • IsExpanded() : CXTPCalendarViewDay, CXTPGridColumn, CXTPGridRecord, CXTPGridRow, CXTPPropertyGridItem, CXTPSearchOptionsCtrl, CXTPShortcutBarItem, CXTPShortcutBarPaneItem, CXTPTaskPanelGroup
  • IsExpanding() : CXTPTaskPanelGroup
  • IsExpandUp() : CXTPCalendarDayView, CXTPCalendarDayViewGroup
  • IsExplorerBehaviour() : CXTPTaskPanel
  • IsExplorerTheme() : CXTPTreeBase
  • IsFailed() : CXTPChart3dFunnelSeriesLabelDeviceCommand, CXTPChart3dPieSeriesLabelDeviceCommand, CXTPChart3dPyramidSeriesLabelDeviceCommand
  • IsFileExtSupported() : CXTPSyntaxEditLexTextSchema
  • IsFillHorz() : CXTPTagCloudCtrl
  • IsFilterable() : CXTPGridColumn
  • IsFiltered() : CXTPGridRecord
  • IsFilterHiddenColumns() : CXTPGridControl
  • IsFindValid() : CXTPTreeBase
  • IsFixed() : CXTPGridColumn
  • IsFixedInplaceButtonHeight() : CXTPGridPaintManager
  • IsFixedRowHeight() : CXTPGridPaintManager
  • IsFlatStyle() : CXTPEdit, CXTPEditTheme
  • IsFloating() : CXTPDockingPane
  • IsFloatingCaptionMaximizeButtonsVisible() : CXTPDockingPaneManager
  • IsFloatingFrameThemeEnabled() : CXTPDockingPaneManager, CXTPTabClientContext
  • IsFocus() : CXTPDockingPane
  • IsFocusable() : CXTPControl, CXTPControlComboBox, CXTPControlEdit, CXTPGridRecordItem, CXTPMarkupUIElement, CXTPRibbonControlTab
  • IsFocused() : CXTPComboBox, CXTPControl, CXTPControlCheckBox, CXTPControlComboBox, CXTPControlEdit, CXTPControlListBox, CXTPControlRadioButton, CXTPDatePickerControl, CXTPEdit, CXTPGridRow, CXTPPropertyGridInplaceButton, CXTPPropertyGridVerb, CXTPRibbonControlTab, CXTPTabManagerItem
  • IsFocusedControl() : CXTPRibbonBackstageView
  • IsFocusEnabled() : CXTPTagCloudCtrl
  • IsFocusSubItems() : CXTPGridControl
  • IsFooterRowsPinned() : CXTPGridControl
  • IsFooterRowsPinnedPrinted() : CXTPGridControl
  • IsFooterVisible() : CXTPGridControl
  • IsForceExpanded() : CXTPMouseManager
  • IsFormatChar() : CXTPCalendarUtils
  • IsFrameActive() : CXTPCommandBarsFrameHook
  • IsFrameBeingDragged() : CXTPTearOffFrame
  • IsFrameHasStatusBar() : CXTPCommandBarsFrameHook
  • IsFrameThemeEnabled() : CXTPRibbonBar
  • IsFrozen() : CXTPGridColumn
  • IsFullColumnScrolling() : CXTPGridControl
  • IsFullRowSelectionEnabled() : CXTPTreeBase
  • IsGdiPlusEnabled() : CXTPMarkupContext
  • IsGridVisible() : CXTPGridPaintManager
  • IsGroup() : CXTPTaskPanelItem
  • IsGroupable() : CXTPGridColumn
  • IsGroupByVisible() : CXTPGridControl
  • IsGroupExpanded() : CXTPTaskPanel
  • IsGroupHeaderVisible() : CXTPCalendarDayView, CXTPCalendarDayViewGroup
  • IsGroupRow() : CXTPGridGroupRow, CXTPGridRow
  • IsGroupRowsBold() : CXTPGridControl
  • IsGroupsVisible() : CXTPRibbonBar
  • IsHandCursor() : CXTPPopupItem
  • IsHandleOwnershipGuaranteed() : CXTPGdiObject
  • IsHeaderVisible() : CXTPGridControl
  • IsHelpMode() : CXTPCommandBar
  • IsHelpVisible() : CXTPPropertyGrid
  • IsHidden() : CXTPDockingPane, CXTPDockingPaneBase, CXTPDockingPaneTabbedContainer, CXTPPropertyGridItem, CXTPShortcutBarItem
  • IsHideCaret() : CXTPSyntaxEditCtrl
  • IsHideEventTime() : CXTPCalendarDayViewEvent
  • IsHighlightChangedButtonItems() : CXTPPropertyGrid
  • IsHighlightChangedItems() : CXTPPropertyGrid
  • IsHighlighted() : CXTPButton, CXTPComboBox, CXTPEdit, CXTPRibbonGroup, CXTPShortcutBarPaneItem, CXTPSkinObjectFrame::CCaptionButton, CXTPStatusBarPane, CXTPTabManagerItem, CXTPTabManagerNavigateButton
  • IsHighlightedControl() : CXTPRibbonBackstageView
  • IsHoriz() : CXTPDockingPaneSplitterContainer
  • IsHorizontal() : CXTPDockingPaneSidePanel, CXTPDockingPaneSplitterWnd
  • IsHorizontalPosition() : CXTPTabManager
  • IsHorz() : CXTPTabBaseTheme
  • IsHot() : CXTPPropertyGridInplaceButton
  • IsHotTracking() : CXTPGridColumn
  • IsHScrollEnabled() : CXTPCalendarView
  • IsHyperLink() : CXTPPopupItem
  • IsHyperlink() : CXTPPropertyGridInplaceButton
  • IsIcon() : CXTPMarkupDeviceDependentImage
  • IsIconView() : CXTPGridControl
  • IsImagesAvailable() : CXTPResourceTheme, CXTPRibbonTheme
  • IsImageVisible() : CXTPControlComboBox, CXTPControlEdit
  • IsImeMode() : CXTPCommandBarEditCtrl
  • IsInclude() : CXTPSyntaxEditLexTextBlock
  • IsInDiscreteSelection() : CXTPCalendarView
  • IsInitialized() : CXTPToolhelpApi
  • IsInitialSelectionEnabled() : CXTPGridControl
  • IsInplaceButtonVisible() : CXTPPropertyGridItem
  • IsInputLocked() : CXTPKeyboardManager
  • IsInSel_disp() : CXTPSyntaxEditSelection
  • IsInSel_str() : CXTPSyntaxEditSelection
  • IsInside() : CXTPChartFunnelSeriesLabelBase, CXTPChartPieSeriesLabelBase, CXTPChartPyramidSeriesLabelBase
  • IsInsideCellButton() : CXTPGridInplaceButton
  • IsInterlaced() : CXTPChartAxis
  • IsIntersectSel_disp() : CXTPSyntaxEditSelection
  • IsIntersectSel_str() : CXTPSyntaxEditSelection
  • IsIntResource() : CXTPResourceManager
  • IsItemChecked() : CXTPControlGallery
  • IsItemDefault() : CXTPControl
  • IsItemDragging() : CXTPTaskPanelItem
  • IsItemDragOver() : CXTPTaskPanelItem
  • IsItemExpandButton() : CXTPShortcutBarItem
  • IsItemFiltered() : CXTPShellListBase
  • IsItemFocused() : CXTPTaskPanelItem
  • IsItemHot() : CXTPTaskPanelItem
  • IsItemPressed() : CXTPTaskPanelItem
  • IsItemSelected() : CXTPControlGallery, CXTPTaskPanelGroupItem
  • IsItemShrinked() : CXTPTabManagerItem
  • IsItemsVisible() : CXTPGridRow
  • IsItemVisible() : CXTPTaskPanelGroup
  • IsKey() : CXTPTrackBlock, CXTPTrackKey
  • IsKeyboardCuesVisible() : CXTPCommandBar, CXTPRibbonBar, CXTPRibbonTabPopupToolBar
  • IsKeyboardHooked() : CXTPKeyboardManager
  • IsKeyboardNavigateEnabled() : CXTPDockingPaneManager
  • IsKeyboardTipsVisible() : CXTPCommandBar
  • IsLabel() : CXTPControlGalleryItem
  • IsLabeled() : CXTPControlEdit
  • IsLastColumnWidthWYSIWYG() : CXTPGridPaintManager
  • IsLastResizebleColumn() : CXTPGridHeader
  • IsLastTreeRow() : CXTPGridRow
  • IsLastVisibleColumn() : CXTPGridHeader
  • IsLayoutChanged() : CXTPControl
  • IsLayoutRTL() : CXTPCalendarControl, CXTPCommandBar, CXTPCommandBars, CXTPControl, CXTPDockingPaneManager, CXTPGridControl, CXTPPopupControl, CXTPPropertyGrid, CXTPTabClientWnd
  • IsLayoutRTLSupported() : CXTPSystemVersion
  • IsLeft() : CXTPTabBaseTheme
  • IsLeftDirected() : CXTPChart3dFunnelSeriesLabelView, CXTPChart3dPieSeriesLabelView, CXTPChart3dPyramidSeriesLabelView
  • IsLegendVisible() : CXTPChartAxisConstantLine, CXTPChartAxisStrip, CXTPChartSeries
  • IsLinkHot() : CXTPHyperLink
  • IsLoaded() : CXTPGaugeCtrl, CXTPMarkupDeviceDependentImage, CXTPSvgImage
  • IsLoading() : CXTPPropExchange
  • IsLocked() : CXTPFlowGraphConnectionPoint, CXTPFlowGraphNode, CXTPGridRecord, CXTPTrackBlock, CXTPTrackControlItem
  • IsLockedExclusively() : CXTPRWCriticalSection
  • IsLockedSharedly() : CXTPRWCriticalSection
  • IsLockExpand() : CXTPGridControl, CXTPGridRow
  • IsLookLikeClosed() : CXTPSyntaxEditLexTextBlock
  • IsLowResolution() : CXTPColorManager
  • IsLunaColorsDisabled() : CXTPColorManager, CXTPTabPaintManager
  • IsMarkerVisible() : CXTPChartLegend
  • IsMarkupEnabled() : CXTPCalendarControl
  • IsMarkupImage() : CXTPImageManagerVectorImageHandle
  • IsMarquee() : CXTPMarqueeCtrl
  • IsMDIMaximized() : CXTPCommandBarsFrameHook
  • IsMeeting() : CXTPCalendarEvent
  • IsMenuSeparator() : CXTPRibbonBackstageView
  • IsMenuTitleBar() : CXTPCommandBar
  • IsMeterType() : CXTPGaugeCtrl
  • IsMetricObject() : CXTPSkinManagerMetrics
  • IsMinimizeButtonVisible() : CXTPShortcutBar
  • IsMinorVisible() : CXTPChartAxisGridLines, CXTPChartAxisTickMarks
  • IsModal() : CXTPDatePickerControl
  • IsModified() : CXTPCalendarEventColorListBox, CXTPMaskEditT< TBase >, CXTPSyntaxEditBufferManager, CXTPSyntaxEditUndoRedoManager
  • IsMonitoringRunning() : CXTPCalendarRemindersManager
  • IsMouseLocked() : CXTPMouseManager, CXTPRibbonControlTab, CXTPTabManager
  • IsMultiColumn() : CXTPTaskPanel
  • IsMulticolumnsEnable() : CXTPCalendarCaptionBarControl
  • IsMultidayEvent() : CXTPCalendarDayViewEvent, CXTPCalendarViewEvent
  • IsMultiLine() : CXTPPropertyGridItem
  • IsMultilineForce() : CXTPGridTip
  • IsMultipleSelection() : CXTPGridControl
  • IsMultiSelect() : CXTPTreeBase
  • IsMultiSelectionMode() : CXTPDatePickerControl, CXTPGridControl
  • IsMultyDayTextAlign() : CXTPCalendarViewEvent
  • IsNan() : CXTPMathUtils
  • IsNavigateButtonAutomaticVisible() : CXTPTabManager
  • IsNavigateButtonVisible() : CXTPTabManager
  • IsNewWindowTab() : CXTPTabManagerItem
  • IsNoEndDate() : CXTPCalendarRecurrencePattern
  • IsNoneButtonVisible() : CXTPDatePickerControl
  • IsNormalized() : CXTPResizeRect
  • IsNull() : CXTPPaintManagerColorGradient
  • IsNumericOnly() : CXTPControlEdit
  • IsOneLine() : CXTPCalendarCaptionBarTheme
  • IsOnQuickAccess() : CXTPControl
  • IsOpen() : CXTPCalendarData
  • IsOpenTag() : CXTPSyntaxEditAutoCompleteWnd
  • IsOptionButtonVisible() : CXTPRibbonGroup
  • IsOriginalControls() : CXTPControls
  • IsOutOfClientRect() : CXTPCalendarDayView
  • IsOwnerActive() : CXTPTabManagerNavigateButton
  • IsOwnerDrawn() : CXTPSyntaxEditTipWnd
  • IsOwnerHighlighted() : CXTPTabManagerNavigateButton
  • IsOwnerNull() : CXTPTabManagerNavigateButton
  • IsOwnerSelected() : CXTPTabManagerNavigateButton
  • IsPaneClosed() : CXTPDockingPaneManager
  • IsPaneHidden() : CXTPDockingPaneManager
  • IsPaneSelected() : CXTPDockingPaneManager
  • IsParserEnabled() : CXTPSyntaxEditBufferManager
  • IsPathValid() : CXTPDirWatcher
  • IsPatternValid() : CXTPEdit
  • IsPeekButtonEnabled() : CXTPPasswordPeek
  • IsPersistentModule() : CXTPSkinManager
  • IsPlusMinus() : CXTPGridColumn
  • IsPngBitmapFile() : CXTPImageManagerIcon
  • IsPngBitmapResource() : CXTPImageManager, CXTPImageManagerIcon
  • IsPopupBar() : CXTPCommandBar, CXTPPopupBar
  • IsPopupBarTracking() : CXTPRibbonControlTab
  • IsPressed() : CXTPDockingPaneCaptionButton, CXTPGridInplaceButton, CXTPMarkupButtonBase, CXTPPopupItem, CXTPPropertyGridInplaceButton, CXTPSkinObjectFrame::CCaptionButton, CXTPStatusBarPane, CXTPTabManagerItem, CXTPTabManagerNavigateButton
  • IsPreviewAllowEdit() : CXTPGridControl
  • IsPreviewItem() : CXTPGridRecordItem, CXTPGridRecordItemPreview
  • IsPreviewMode() : CXTPGridControl, CXTPGridPaintManager
  • IsPreviewVisible() : CXTPGridRow
  • IsPrimaryImageExists() : CXTPImageManager
  • IsPrintGroupRowIcon() : CXTPGridPaintManager
  • IsPrivate() : CXTPCalendarEvent
  • IsProperty() : CXTPMarkupStaticExtension
  • IsPropertyExists() : CXTPPropExchangeRegistry, CXTPPropExchangeXMLNode
  • IsPushButton() : CXTPButton
  • IsPushed() : CXTPButton, CXTPColorPicker
  • IsQuickAccessBelowRibbon() : CXTPRibbonBar
  • IsQuickAccessControl() : CXTPRibbonBar
  • IsQuickAccessVisible() : CXTPRibbonBar
  • IsQuickCustomizeMode() : CXTPCommandBars
  • IsRasterIcon() : CXTPImageManagerIcon
  • IsReadOnly() : CXTPHexEdit, CXTPSyntaxEditCtrl
  • IsReadonly() : CXTPSyntaxEditDoc
  • IsReadonlyMode() : CXTPCalendarControl
  • IsReady() : CXTPApplication, IXTPPreview
  • IsReduced() : CXTPRibbonGroup
  • IsReminder() : CXTPCalendarEvent
  • IsRemindersEnabled() : CXTPCalendarControl
  • IsRenderingAntialiasing() : CXTPChart3dDeviceContext
  • IsReplaceDialog() : CXTPSyntaxEditFindReplaceDlg
  • IsResizable() : CXTPCommandBar, CXTPControlGallery, CXTPFlowGraphNode, CXTPGridColumn, CXTPPopupBar, CXTPTrackBlock
  • IsReversed() : CXTPChartAxis
  • IsRExceptionDeleted() : CXTPCalendarEvent
  • IsRibbonBar() : CXTPCommandBar, CXTPRibbonBar
  • IsRibbonBarVisible() : CXTPRibbonBar
  • IsRibbonMinimized() : CXTPRibbonBar
  • IsRight() : CXTPTabBaseTheme
  • IsRightButtonDrag() : CXTPSyntaxEditCtrl
  • IsRightDirected() : CXTPChart3dFunnelSeriesLabelView, CXTPChart3dPieSeriesLabelView, CXTPChart3dPyramidSeriesLabelView
  • IsRootSection() : CXTPPropExchange
  • IsRotated() : CXTPChart3dRotation
  • IsRowFocusVisible() : CXTPGridControl
  • IsRowValid() : CXTPSyntaxEditCtrl
  • IsRowVisible() : CXTPSyntaxEditCtrl
  • IsScaled() : CXTPImageManagerIcon
  • IsScaleLeftVisible() : CXTPCalendarDayView
  • IsScaleRightVisible() : CXTPCalendarDayView
  • IsSchedulesSetEmpty() : CXTPCalendarResource
  • IsScrollBarAuto() : CXTPControlGallery
  • IsScrollBarEnabled() : CXTPControlGallery, CXTPScrollBase
  • IsScrollBarVisible() : CXTPControlGallery
  • IsScrollButtonEnabled() : CXTPControlGallery, CXTPTaskPanelGroup
  • IsScrollDateButtons() : CXTPCalendarCaptionBarTheme
  • IsSectionExists() : CXTPPropExchangeRegistry, CXTPPropExchangeXMLNode
  • IsSelected() : CXTPCalendarTimeLineViewEvent, CXTPCalendarViewDay, CXTPCalendarViewEvent, CXTPDatePickerControl, CXTPDatePickerList, CXTPDockingPane, CXTPDockingPaneCaptionButton, CXTPFlowGraphElement, CXTPGridRow, CXTPPopupItem, CXTPPropertyGridItem, CXTPShortcutBarItem, CXTPTabManagerItem, CXTPTrackBlock, CXTPTrackSelectedBlocks, CXTPTreeBase
  • IsSelectionEnabled() : CXTPGridSection
  • IsSelectionExist() : CXTPSyntaxEditCtrl
  • IsSelExist() : CXTPSyntaxEditSelection
  • IsSelNormal() : CXTPSyntaxEditSelection
  • IsShadeGroupHeadingsEnabled() : CXTPGridControl
  • IsShadowEnabled() : CXTPFrameShadowManager
  • IsShadowSupported() : CXTPFrameShadow, CXTPFrameShadowManager
  • IsShellVersion5() : CXTPTrayIcon
  • IsShortcutBarMinimized() : CXTPShortcutBar
  • IsShortcutItemTruncated() : CXTPShortcutBarPaintManager
  • IsShowActiveItemOnTop() : CXTPShortcutBar
  • IsShowAllDayEventsDownScrollButton() : CXTPCalendarDayViewGroup
  • IsShowAllDayEventsUpScrollButton() : CXTPCalendarDayViewGroup
  • IsShowBorders() : CXTPControlGallery
  • IsShowCaptionBar() : CXTPCalendarControlView
  • IsShowDockingContextStickers() : CXTPDockingPaneManager
  • IsShowEndTime() : CXTPCalendarMonthViewEvent, CXTPCalendarWeekViewEvent
  • IsShowIconWhenEditing() : CXTPGridControl
  • IsShowInFieldChooser() : CXTPGridColumn
  • IsShowingToolTip() : CXTPCalendarViewEvent
  • IsShowInTaskBar() : CXTPCalendarRemindersDialog
  • IsShowItemsInGroups() : CXTPGridHeader
  • IsShownAsButton() : CXTPControlGallery
  • IsShowRowNumber() : CXTPGridControl
  • IsShowTitleAndDescription() : CXTPToolTipContext
  • IsShowWYSIWYGMarkers() : CXTPGridPaintManager
  • IsSideDockingEnabled() : CXTPDockingPaneManager
  • IsSidePanel() : CXTPDockingPane
  • IsSignaled() : CXTPSimpleEvent
  • IsSimpleButton() : CXTPRibbonControlSystemButton
  • IsSingleEventSelected() : CXTPCalendarView
  • IsSingleSelection() : CXTPShortcutBar, CXTPTaskPanel
  • IsSkipGroupsFocusEnabled() : CXTPGridControl
  • IsSkippingAntialiasing() : CXTPChart3dDeviceContext
  • IsSlider() : CXTPScrollBase
  • IsSmooth() : CXTPMarqueeCtrl
  • IsSortable() : CXTPGridColumn
  • IsSorted() : CXTPGridColumn
  • IsSortedDecreasing() : CXTPGridColumn
  • IsSortedIncreasing() : CXTPGridColumn
  • IsSortRecordChilds() : CXTPGridControl
  • IsSound() : CXTPCalendarEvent
  • IsSpecialGroup() : CXTPTaskPanelGroup
  • IsSpinButtonsVisible() : CXTPControlEdit
  • IsSplittersLocked() : CXTPDockingPaneManager
  • IsSplitterTrackerUsed() : CXTPDockingPaneManager, CXTPTabClientWnd
  • IsStandardValue() : CXTPCalendarThemeCustomizableXValueT< _TValue, _TValueRef >, CXTPCalendarViewPartCustomizableValueT< _TValue >, CXTPPaintManagerColor
  • IsStar() : CXTPMarkupGridLength
  • IsStateType() : CXTPGaugeCtrl
  • IsStickyFloatingFrames() : CXTPDockingPaneManager
  • IsStoring() : CXTPPropExchange
  • IsStrType() : CXTPSyntaxEditLexVariant
  • IsStyleDiagram() : CXTPChart3dFunnelSeriesStyle, CXTPChart3dPyramidSeriesStyle, CXTPChartDiagram2DSeriesStyle, CXTPChartFunnelSeriesStyle, CXTPChartFunnelSeriesStyleBase, CXTPChartPieSeriesStyleBase, CXTPChartPyramidSeriesStyle, CXTPChartPyramidSeriesStyleBase, CXTPChartRadarDiagramSeriesStyle, CXTPChartSeriesStyle
  • IsSuspended() : CXTPSkinManager
  • IsSvgImage() : CXTPImageManagerVectorImageHandle
  • IsSwitchViewButtons() : CXTPCalendarCaptionBarTheme
  • IsTabsVisible() : CXTPDockingPane, CXTPDockingPaneTabbedContainer, CXTPRibbonBar
  • IsTearOffPopup() : CXTPPopupBar
  • IsTemporary() : CXTPControl, CXTPToolBar
  • IsTextBelowIcons() : CXTPCommandBar
  • IsTextControl() : CXTPHyperLink
  • IsTextCRLF() : CXTPSyntaxEditBufferManager
  • IsTextInColor() : CXTPColorPicker
  • IsTextOutOfBorders() : CXTPCalendarViewEvent
  • IsTextShown() : CXTPColorPicker
  • IsThemeActive() : CXTPWinThemeWrapper
  • IsThemeBackgroundPartiallyTransparent() : CXTPWinThemeWrapper
  • IsThemed() : CXTPDockingPaneMiniWnd
  • IsThemeDark() : CXTPTreeTheme
  • IsThemeDialogTextureEnabled() : CXTPWinThemeWrapper
  • IsThemeEnabled() : CXTPCalendarPaintManager, CXTPCommandBarsNativeXPTheme
  • IsThemePartDefined() : CXTPWinThemeWrapper
  • IsThemeValid() : CXTPHeaderCtrl
  • IsThreeState() : CXTPMarkupToggleButton
  • IsTimeAsClock() : CXTPCalendarMonthViewEvent, CXTPCalendarWeekViewEvent
  • IsTimelineEnable() : CXTPCalendarCaptionBarControl
  • IsTipEnabled() : CXTPTagCloudCtrl
  • IsTitleVisible() : CXTPDockingPaneTabbedContainer
  • IsToday() : CXTPCalendarControl, CXTPDatePickerItemDay
  • IsTodayButtonVisible() : CXTPDatePickerControl
  • IsTodayVisible() : CXTPCalendarView
  • IsToolTipsEnabled() : CXTPCalendarControl
  • IsToolTipVisible() : CXTPCalendarControl
  • IsTop() : CXTPTabBaseTheme
  • IsTopLevelClass() : CXTPSyntaxEditPropertiesPageColor
  • IsTopParentActive() : CXTPMouseManager
  • IsTorus() : CXTPChart3dPieSeriesStyle
  • IsTrackedLock() : CXTPMouseManager
  • IsTrackingMode() : CXTPCommandBar
  • IsTransparent() : CXTPControl, CXTPControlGallery, CXTPRibbonControlSystemPopupBarButton
  • IsTreeColumn() : CXTPGridColumn
  • IsType() : CXTPGaugeCtrl
  • IsUndefinedIcon() : CXTPImageManagerIcon
  • IsUnderline() : CXTPPopupItem
  • IsUpAllDayEventsScrollButtonVisible() : CXTPCalendarDayViewGroup
  • IsUseDropMarker() : CXTPGridPaintManager
  • IsUseMask() : CXTPGridColumn
  • IsUseOneLine() : CXTPCalendarCaptionBarControl
  • IsUseResourceFileLocale() : CXTPChartNumberFormat, CXTPGridControlLocale
  • IsUserLayout() : CXTPDockingPaneLayout
  • IsUserListColor() : CXTPListBase
  • IsUserRowColor() : CXTPListBase
  • IsUserSortColor() : CXTPListBase
  • IsUseSystemAccentColorEnabled() : CXTPFramePaintManager, CXTPPaintManager
  • IsValid() : CXTPChart3dBox, CXTPDockingPane, CXTPDockingPaneLayout, CXTPResourceImages, CXTPThreadLocal< T >, XTP_CALENDAR_MONTHVIEW_DAYPOS, XTP_CALENDAR_VIEWSELECTION
  • IsValidColor() : CXTPColorHex
  • IsValidData() : XTP_EDIT_LINECOL
  • IsValueChanged() : CXTPPropertyGridItem
  • IsValuesAxis() : CXTPChartAxis, CXTPChartAxisX, CXTPChartAxisY, CXTPChartRadarAxisX, CXTPChartRadarAxisY
  • IsVectorIcon() : CXTPImageManagerIcon
  • IsVerbsVisible() : CXTPPropertyGrid
  • IsVerificiationChecked() : CXTPTaskDialog
  • IsVert() : CXTPTabBaseTheme
  • IsVertical() : CXTPChartAxis, CXTPChartAxisX, CXTPChartAxisY, CXTPChartDiagram2DAxisView, CXTPChartRadarAxisX, CXTPChartRadarAxisY, CXTPMarqueeCtrl, CXTPSpinButtonCtrl
  • IsVerticalPosition() : CXTPDockBar
  • IsViewOnly() : CXTPSyntaxEditCtrl
  • IsVirtualMode() : CXTPGridControl, CXTPGridSection
  • IsVisible() : CXTPCalendarCaptionBarThemePart, CXTPCalendarDayViewEvent, CXTPCalendarMonthViewEvent, CXTPCalendarTimeLineViewEvent, CXTPCalendarViewEvent, CXTPCalendarWeekViewEvent, CXTPChartAxis, CXTPChartAxisConstantLine, CXTPChartAxisGridLines, CXTPChartAxisLabel, CXTPChartAxisStrip, CXTPChartAxisTickMarks, CXTPChartAxisTitle, CXTPChartBorder, CXTPChartLegend, CXTPChartSeries, CXTPChartSeriesLabel, CXTPChartTitle, CXTPCommandBar, CXTPControl, CXTPControlAction, CXTPDatePickerItemDay, CXTPDockingPaneCaptionButton, CXTPFlowGraphNode, CXTPGridColumn, CXTPGridRecord, CXTPGridRow, CXTPGridSection, CXTPMarkupUIElement, CXTPMarkupVisual, CXTPPopupBar, CXTPPropertyGridItem, CXTPRibbonGroup, CXTPShortcutBarItem, CXTPStatusBarPane, CXTPTabManagerItem, CXTPTabManagerNavigateButton, CXTPTaskPanelItem, CXTPTaskPanelScrollButton, CXTPToolBar
  • IsVisibleEx() : CXTPCalendarDayViewEvent
  • IsVScrollEnabled() : CXTPCalendarView
  • IsWin10OrGreater() : CXTPSystemVersion
  • IsWin11OrGreater() : CXTPSystemVersion
  • IsWin2K() : CXTPSystemVersion
  • IsWin2KOrGreater() : CXTPSystemVersion
  • IsWin31() : CXTPSystemVersion
  • IsWin31OrGreater() : CXTPSystemVersion
  • IsWin7OrGreater() : CXTPSystemVersion
  • IsWin81OrGreater() : CXTPSystemVersion
  • IsWin8OrGreater() : CXTPSystemVersion
  • IsWin95() : CXTPSystemVersion
  • IsWin95OrGreater() : CXTPSystemVersion
  • IsWin98() : CXTPSystemVersion
  • IsWin98OrGreater() : CXTPSystemVersion
  • IsWin9x() : CXTPCalendarUtils, CXTPSkinManager, CXTPSystemVersion
  • IsWindowVisible() : CXTPToolBar
  • IsWinME() : CXTPSystemVersion
  • IsWinMEOrGreater() : CXTPSystemVersion
  • IsWinNT4() : CXTPSystemVersion
  • IsWinNT4OrGreater() : CXTPSystemVersion
  • IsWinVistaOrGreater() : CXTPSystemVersion
  • IsWinXP() : CXTPSystemVersion
  • IsWinXPOrGreater() : CXTPSystemVersion
  • IsWizard() : CXTPResizePropertySheet
  • IsWordSelectionMode() : CXTPSyntaxEditSelection
  • IsWorkDateTime() : CXTPCalendarDayViewGroup
  • IsWorkspaceCommandEnabled() : CXTPTabClientWnd
  • IsXMLSupported() : CXTPPropExchangeXMLNode
  • IsZero() : CXTPPoint2T< T >, CXTPPoint3T< T >
  • IsZeroTime() : CXTPCalendarUtils
  • ItemFromPoint() : CXTPPropertyGridView
  • ItemPressed() : CXTPHeaderCtrl


Toolkit Pro: Class Members - Functions

Here is a list of all documented functions with links to the class documentation for each member:

- k -

  • KillChildWindow() : CXTPCaption
  • KillTimer() : CXTPCalendarView, CXTPCalendarViewDay, CXTPCalendarViewEvent, CXTPCalendarViewGroup, CXTPTrayIcon


Toolkit Pro: Class Members - Functions

Here is a list of all documented functions with links to the class documentation for each member:

- l -

  • Layout() : CXTPHeaderCtrlTheme, CXTPHeaderCtrlThemeExplorer, CXTPHeaderCtrlThemeOffice2003
  • LCPosAdd() : CXTPSyntaxEditTextIterator
  • LCPosDec() : CXTPSyntaxEditTextIterator
  • Leave() : CXTPSimpleCriticalSection
  • LeaveCritical() : CXTPCriticalSection
  • LightColor() : CXTPColorManager
  • LimitDataSize() : CXTPSyntaxEditUndoRedoManager
  • Line() : CXTPDockingPanePaintManager, CXTPPaintManager, CXTPShortcutBarOffice2000Theme, CXTPShortcutBarPaintManager
  • ListViewCompareProc() : CXTPShellPidl
  • Load() : CXTPCalendarReminderForOccurrenceArray, CXTPDockingPaneLayout, CXTPGaugeCtrl, CXTPMarkupDeviceDependentImage, CXTPMarkupGdiImage, CXTPMarkupGdiPlusImage, CXTPMemFile, CXTPSvgImage, CXTPSyntaxEditBufferManager, CXTPSyntaxEditColorTheme
  • LoadAlphaBitmap() : CXTPImageManagerIcon
  • LoadAlphaIcon() : CXTPImageManagerIcon
  • LoadAppearance() : CXTPChartAppearance
  • LoadBarState() : CXTPCommandBars
  • LoadBitmap() : CXTPResourceImages, CXTPResourceManager
  • LoadBitmapFromFile() : CXTPImageManagerIcon
  • LoadBitmapFromResource() : CXTPImageManagerIcon
  • LoadCfg() : CXTPCalendarResourcesManager
  • LoadClassSchema() : CXTPSyntaxEditLexTextSchema
  • LoadCode() : CXTPActiveScriptEngine
  • LoadColumnWidths() : CXTPListBase
  • LoadCommandBars() : CXTPCommandBarsSiteBase< TBase >
  • LoadCursor() : CXTPResourceManager
  • LoadDesignerBars() : CXTPCommandBars
  • LoadDialogTemplate() : CXTPResourceManager, CXTPResourceManagerXML
  • LoadDialogTemplate2() : CXTPResourceManager
  • LoadFile() : CXTPResourceImage, CXTPResourceImages, CXTPSkinImage, CXTPSkinImages
  • LoadFromEncodedString() : CXTPPropExchangeXMLNode
  • LoadFromFile() : CXTPDockingPaneLayout, CXTPFlowGraphImage, CXTPGraphicBitmapPng, CXTPPropExchangeIniFile, CXTPPropExchangeXMLNode
  • LoadFromNode() : CXTPDockingPaneLayout
  • LoadFromResource() : CXTPFlowGraphImage, CXTPGraphicBitmapPng, CXTPPropExchangeXMLNode
  • LoadFromString() : CXTPCalendarUIntArray, CXTPPropExchangeXMLNode, CXTPSyntaxEditColorTheme
  • LoadFromXML() : CXTPCalendarCustomProperties
  • LoadGlyphs() : CXTPGridPaintManager, CXTPGridThemeOffice2013, CXTPGridThemeVisualStudio2012Blue, CXTPGridThemeVisualStudio2012Dark, CXTPGridThemeVisualStudio2012Light, CXTPTrackThemeOffice2013, CXTPTrackThemeVisualStudio2012Blue, CXTPTrackThemeVisualStudio2012Dark, CXTPTrackThemeVisualStudio2012Light
  • LoadHistory() : CXTPSyntaxEditFindReplaceDlg
  • LoadHTML() : CXTPResourceManager
  • LoadHtml() : CXTPWebBrowserCtrl
  • LoadIcon() : CXTPResourceManager
  • LoadImage() : CXTPFramePaintManager, CXTPResourceImages, CXTPResourceTheme, CXTPRibbonPaintManager, CXTPScrollBarThemeResource, CXTPSkinManagerResourceFile
  • LoadLibrary() : CXTPModuleHandle
  • LoadMenu() : CXTPCommandBar, CXTPControls, CXTPResourceManager, CXTPResourceManagerXML
  • LoadMenuBar() : CXTPMenuBar
  • LoadMeterType() : CXTPGaugeCtrl
  • LoadModernToolbarIcons() : CXTPCommandBarsOffice2003Theme
  • LoadOptions() : CXTPCommandBars
  • LoadPalette() : CXTPChartAppearance
  • LoadPart() : CXTPMarkupThemePart
  • LoadParts() : CXTPFrameThemeOffice2007System, CXTPRibbonMarkupFrameTheme, CXTPRibbonMarkupTheme, CXTPRibbonOffice2013Theme, CXTPRibbonThemeOffice2007System
  • LoadPlacement() : CXTPPropertySheet, CXTPResize
  • LoadPos() : CXTPSyntaxEditGoToLineDlg
  • LoadProperties() : CXTPResourceImages
  • LoadScriptCodeChunk() : CXTPMarkupContext
  • LoadShortcuts() : CXTPShortcutManager
  • LoadSkin() : CXTPSkinManager
  • LoadState() : CXTPDockState, CXTPReBar, CXTPShortcutBar, CXTPStatusBar, CXTPTabClientWnd
  • LoadStateType() : CXTPGaugeCtrl
  • LoadString() : CXTPCalendarUtils, CXTPResourceManager, CXTPResourceManagerXML
  • LoadString2() : CXTPCalendarUtils
  • LoadSVG() : CXTPResourceManager
  • LoadSysCursors() : CXTPAuxData
  • LoadSysFonts() : CXTPAuxData
  • LoadTextScheme() : CXTPSyntaxEditTextSchemesManager
  • LoadTextStringScheme() : CXTPSyntaxEditTextSchemesManager
  • LoadTheme() : CXTPSyntaxEditColorThemesManager
  • LoadThemeFromString() : CXTPSyntaxEditColorThemesManager
  • LoadToolBar() : CXTPCommandBar, CXTPResourceManager, CXTPRibbonGroup, CXTPToolBar
  • LoadWindowPos() : CXTPWindowPos
  • LoadXAML() : CXTPResourceManager
  • LoadXamlTemplate() : CXTPFlowGraphControl
  • Lock() : CXTPNotifyConnection::CEmptySyncObject
  • LockDivider() : CXTPPropertyGridView
  • LockExclusive() : CXTPRWCriticalSection
  • LockExpand() : CXTPGridControl, CXTPGridRow
  • LockInput() : CXTPKeyboardManager
  • LockMouseMove() : CXTPCommandBar, CXTPMouseManager
  • LockRedraw() : CXTPCommandBar
  • LockShared() : CXTPRWCriticalSection
  • LockSplitters() : CXTPDockingPaneManager
  • LockThread() : CXTPLockGuard
  • Lookup() : CXTPCommandBarList, CXTPHookManager, CXTPImageManager, CXTPImageManagerImageList, CXTPListBase, CXTPSkinManager, CXTPSkinObjectClassMap
  • LookUpColor() : CXTPColorSelectorCtrl
  • LowercaseSelection() : CXTPSyntaxEditCtrl


Toolkit Pro: Class Members - Functions

Here is a list of all documented functions with links to the class documentation for each member:

- m -

  • MakeARGB() : CXTPChartColor
  • MakeAsRException() : CXTPCalendarEvent
  • MakeDaysOfWeekMask_Mo_() : CXTPCalendarUtils
  • MakeEventAsRecurrence() : CXTPCalendarEvent
  • MakeIntResource() : CXTPResourceManager
  • MakeLineCol() : XTP_EDIT_LINECOL
  • MakeTransparent() : CXTPResizeItem
  • MapShellFlagsToItemAttributes() : CXTPShellPidl
  • MarkSaved() : CXTPSyntaxEditUndoRedoManager
  • MaskClear() : CXTPMaskEditT< TBase >
  • MaskCopy() : CXTPMaskEditT< TBase >
  • MaskCut() : CXTPMaskEditT< TBase >
  • MaskDeleteSel() : CXTPMaskEditT< TBase >
  • MaskPaste() : CXTPMaskEditT< TBase >
  • MaskReplaceSel() : CXTPMaskEditT< TBase >
  • MaskSelectAll() : CXTPMaskEditT< TBase >
  • MaskUndo() : CXTPMaskEditT< TBase >
  • MatchText() : CXTPSyntaxEditCtrl
  • max2() : XTP_EDIT_LINECOL
  • MaximizeFromTray() : CXTPTrayIcon
  • McTransparentBlt() : CXTPImageManager
  • MDIActivate() : CXTPTabClientWnd
  • MDIGetActive() : CXTPTabClientWnd
  • MDITile() : CXTPTabClientWnd
  • Measure() : CXTPMarkupThemePart, CXTPMarkupUIElement
  • MeasureButton() : CXTPMessageBar
  • MeasureContent() : CXTPMessageBar
  • MeasureCore() : CXTPMarkupUIElement
  • MeasureItem() : CXTPCalendarComboBoxBase, CXTPControlComboBoxList, CXTPPropertyGridItem, CXTPPropertyGridItemOption, CXTPPropertyGridPaintManager
  • MeasureMarkupElement() : CXTPChartDeviceContext
  • MeasureString() : CXTPChartDeviceContext
  • MergeToolBar() : CXTPToolBar
  • MessageBox() : CXTPCustomizeSheet
  • min2() : XTP_EDIT_LINECOL
  • MinimizeToTray() : CXTPTrayIcon
  • Minutes2Span() : CXTPCalendarUtils
  • ModifyApplyOptions() : CXTPSkinManager
  • ModifyBarStyle() : CXTPToolBar
  • ModifyCaptionStyle() : CXTPCaption
  • ModifyCPStyle() : CXTPColorPicker
  • ModifyExtendedStyle() : CXTPListBase
  • ModifyListBoxStyle() : CXTPControlComboBox
  • ModifyPopupStyle() : CXTPColorSelectorCtrl
  • ModifyTabStyle() : CXTPTabExBase
  • ModifyTaskStyle() : CXTPTaskDialog
  • ModifyToolTipStyle() : CXTPToolTipContext
  • MonitorNotifications() : CXTPDirWatcher
  • MonthView_IsCompressWeekendDays() : CXTPCalendarControl
  • MonthView_IsShowEndDate() : CXTPCalendarControl
  • MonthView_IsShowTimeAsClocks() : CXTPCalendarControl
  • MonthView_SetCompressWeekendDays() : CXTPCalendarControl
  • MonthView_SetShowEndDate() : CXTPCalendarControl
  • MonthView_SetShowTimeAsClocks() : CXTPCalendarControl
  • MouseOverColumnResizeArea() : CXTPGridHeader
  • Move() : CXTPDockContext, CXTPDockingPaneContext, CXTPGridRecords, CXTPPropertyGridItem, CXTPTabManagerItem, CXTPTaskPanelItems
  • MoveBefore() : CXTPControls
  • MoveButton() : CXTPTaskDialogClient
  • MoveButtons() : CXTPEditListBoxToolBar
  • MoveChildWindow() : CXTPDialogBar
  • MoveControl() : CXTPSearchOptionsCtrl
  • MoveCurrentVisibleRowDown() : CXTPSyntaxEditCtrl
  • MoveCurrentVisibleRowUp() : CXTPSyntaxEditCtrl
  • MoveDown() : CXTPGridIconNavigator, CXTPGridNavigator
  • MoveDownStep() : CXTPGridIconNavigator, CXTPGridNavigator
  • MoveEvent() : CXTPCalendarEvent
  • MoveFirstColumn() : CXTPGridNavigator
  • MoveFirstRow() : CXTPGridNavigator
  • MoveFirstVisibleRow() : CXTPGridNavigator
  • MoveItem() : CXTPTabManager
  • MoveItemDown() : CXTPEditListBox
  • MoveItemUp() : CXTPEditListBox
  • MoveLastColumn() : CXTPGridNavigator
  • MoveLastRow() : CXTPGridNavigator
  • MoveLastVisibleRow() : CXTPGridNavigator
  • MoveLeft() : CXTPGridNavigator
  • MoveLeftRight() : CXTPGridIconNavigator, CXTPGridNavigator
  • MovePageDown() : CXTPGridIconNavigator, CXTPGridNavigator
  • MovePageUp() : CXTPGridIconNavigator, CXTPGridNavigator
  • MovePanel() : CXTPDockingPaneSidePanel
  • MoveRecord() : CXTPGridRecords
  • MoveResource() : CXTPCalendarResourcesManager
  • MoveRight() : CXTPGridNavigator
  • MoveRow() : CXTPListBase
  • MoveTo() : CXTPCalendarDayViewTimeScale
  • MoveToColumn() : CXTPGridNavigator
  • MoveToFront() : CXTPFlowGraphNodes
  • MoveToNextGroup() : CXTPTabClientWnd
  • MoveToPreviousGroup() : CXTPTabClientWnd
  • MoveToRow() : CXTPGridNavigator
  • MoveUp() : CXTPGridIconNavigator, CXTPGridNavigator
  • MoveUpStep() : CXTPGridIconNavigator, CXTPGridNavigator
  • MsgBox_WrongValue() : CXTPCalendarEventRecurrenceDlg
  • MsgBox_WrongValueRange() : CXTPCalendarEventRecurrenceDlg
  • Multiply() : CXTPMatrix< T >
  • MultiplyByMatrix() : CXTPOpenGLUtils


Toolkit Pro: Class Members - Functions

Here is a list of all documented functions with links to the class documentation for each member:

- n -

  • Navigate() : CXTPWebBrowserCtrl
  • Navigate2() : CXTPShellExplorerProvider
  • NavigateItems() : CXTPPropertyGrid, CXTPTaskPanel
  • NavigatePage() : CXTPTaskDialog
  • NeedRedraw() : CXTPComboBox
  • NeedScrollAllDayEvents() : CXTPCalendarDayViewGroup
  • NextBookmark() : CXTPSyntaxEditCtrl
  • NextView() : CXTPTabExBase
  • NoConfirmRecycle() : CXTPShellSettings
  • NoDefaultRadioButton() : CXTPTaskDialog
  • Normalize() : CXTPRectT< T >
  • NormalizeDegree() : CXTPMathUtils
  • NormalizeDockingSize() : CXTPDockingPaneSplitterContainer
  • NormalizeRadian() : CXTPMathUtils
  • NormalizeSplitters() : CXTPDockingPaneManager
  • Notify() : CXTPObservable< Owner, Observer >, CXTPPopupControl
  • NotifyAction() : CXTPDockingPaneManager
  • NotifyCurRowCol() : CXTPSyntaxEditCtrl
  • NotifyDynamic() : CXTPObservable< Owner, Observer >
  • NotifyDynamicReversed() : CXTPObservable< Owner, Observer >
  • NotifyEditChanged() : CXTPSyntaxEditCtrl
  • NotifyMarginLBtnClick() : CXTPSyntaxEditCtrl
  • NotifyMouseEvent() : CXTPSyntaxEditCtrl
  • NotifyOwner() : CXTPDockingPaneManager, CXTPFontComboBox, CXTPSyntaxEditColorComboBox, CXTPTaskPanel
  • NotifyParent() : CXTPSyntaxEditCtrl
  • NotifyParseEvent() : CXTPSyntaxEditCtrl
  • NotifyReminders() : CXTPCalendarRemindersManager
  • NotifyReversed() : CXTPObservable< Owner, Observer >
  • NotifySelInit() : CXTPSyntaxEditCtrl
  • NotifySite() : CXTPControl
  • NotifyValueChanged() : CXTPPropertyGridItem


Toolkit Pro: Class Members - Functions

Here is a list of all documented functions with links to the class documentation for each member:

- o -

  • Offset() : CXTPMarkupGdiPlusTransformationMatrix, CXTPMarkupTransformationMatrix, CXTPPoint2T< T >, CXTPPoint3T< T >, CXTPRectT< T >, CXTPResize
  • OffsetShadow() : CXTPShadowManager
  • OnAccept() : CXTPPropertyGridInplaceMonthCal
  • OnAction() : CXTPDockingPaneBaseContainer, CXTPDockingPaneMiniWnd
  • OnActionChanged() : CXTPControl, CXTPControlComboBox, CXTPControlCustom, CXTPControlEdit
  • OnActionChanging() : CXTPControl, CXTPControlComboBox, CXTPControlEdit
  • OnActivatePane() : CXTPDockingPaneManager
  • OnActivateView() : CXTPCalendarDayView, CXTPCalendarView
  • OnAddChildItem() : CXTPPropertyGridItem
  • OnAddPadding() : CXTPTabBase
  • OnAdjustValueRect() : CXTPPropertyGridInplaceControl, CXTPPropertyGridInplaceSlider, CXTPPropertyGridInplaceSpinButton
  • OnAfterApplicationShutdown() : IXTPApplicationEvents
  • OnAfterCalcSize() : CXTPRibbonGroup
  • OnAfterEdit() : CXTPPropertyGridItem
  • OnAfterExecute() : CXTPChartDeviceCommandEvents
  • OnAllDaysAreaClick() : CXTPCalendarDayViewGroup
  • OnAmbientPropertyChanged() : IXTPApplicationEvents
  • OnAnimate() : CXTPTaskPanelGroup, CXTPTaskPanelGroupItem
  • OnApplicationShutdown() : IXTPApplicationEvents
  • OnBeforeAdd() : CXTPShortcutManager
  • OnBeforeApplicationShutdown() : CXTPSkinManager, IXTPApplicationEvents
  • OnBeforeCalcSize() : CXTPRibbonGroup
  • OnBeforeCopyToText() : CXTPGridControl
  • OnBeforeDestroy() : CXTPCalendarCaptionBarTheme, CXTPCalendarControl, CXTPCalendarTimeLineView, CXTPCalendarView, CXTPCalendarViewEvent, CXTPCalendarWMHandler
  • OnBeforeEditChanged() : CXTPSyntaxEditCtrl, CXTPSyntaxEditLexParser
  • OnBeforeEditOperationNotify() : CXTPCalendarView
  • OnBeforeExchange() : CXTPPropExchange, CXTPPropExchangeIniFile, CXTPPropExchangeRegistry, CXTPPropExchangeXMLNode
  • OnBeforeExecute() : CXTPChartDeviceCommandEvents
  • OnBeforeInsert() : CXTPPropertyGridItem, CXTPPropertyGridItemBool, CXTPPropertyGridItemColor, CXTPPropertyGridItemDate, CXTPPropertyGridItemDouble, CXTPPropertyGridItemEnum, CXTPPropertyGridItemFlags, CXTPPropertyGridItemNumber, CXTPPropertyGridItemOption, CXTPPropertyGridItemPoint, CXTPPropertyGridItemSize
  • OnBeforeItemClick() : CXTPTabManager, CXTPTabToolBar
  • OnBeforePaste() : CXTPGridControl
  • OnBeforePasteFromText() : CXTPGridControl
  • OnBeforePasteNotify() : CXTPCalendarView
  • OnBeforeRemove() : CXTPShortcutManager
  • OnBeginDrag() : CXTPGridControl
  • OnBeginEdit() : CXTPGridRecordItem, CXTPGridRecordItemPreview
  • OnBnClickedDateHeaderFont() : CXTPCalendarPageSetupDialog
  • OnBnClickedPrintDateHeader() : CXTPCalendarPageSetupDialog
  • OnBrowse() : CXTPBrowseEdit
  • OnButtonClick() : CXTPDatePickerControl
  • OnButtonClicked() : CXTPTaskDialog
  • OnButtonDown() : CXTPTreeBase
  • OnButtonRemoved() : CXTPPropertyGridInplaceButtons
  • OnCalcClientHeight() : CXTPTaskPanelGroup
  • OnCalcDynamicSize() : CXTPControl, CXTPControlComboBox, CXTPControlCustom, CXTPControlEdit, CXTPControlGallery, CXTPControlListBox, CXTPControlOleItems, CXTPControlRecentFileList, CXTPControlSelector, CXTPControlToolbars, CXTPControlWindowList, CXTPControlWorkspaceActions, CXTPRibbonControlSystemRecentFileList, CXTPRibbonGroup
  • OnCalendarTimeline() : CXTPCalendarControl
  • OnCancel() : CXTPPropertyGridInplaceMonthCal
  • OnCancelEdit() : CXTPGridRecordItem, CXTPPropertyGridItem
  • OnCaptionButtonClick() : CXTPDockingPaneMiniWnd, CXTPDockingPaneTabbedContainer
  • OnCaptionButtonDown() : CXTPDockingPaneMiniWnd
  • OnCaptionButtonRectChanged() : CXTPDockingPaneBase
  • OnCaptionChanged() : CXTPControl, CXTPControlMarkupLabel, CXTPPropertyGridItem
  • OnCaptionLButtonDown() : CXTPDockingPaneTabbedContainer
  • OnChange() : CXTPHexEdit
  • OnChanged() : CXTPControlAction, CXTPMarkupUIElementCollection
  • OnChangeLayout() : CXTPPasswordPeek
  • OnChanging() : CXTPControlAction
  • OnChar() : CXTPCalendarView, CXTPCalendarWMHandler, CXTPGridRecordItem, CXTPPropertyGridItem
  • OnChartChanged() : CXTPChartContainer, CXTPChartContent, CXTPChartControl, CXTPChartElement
  • OnChecked() : CXTPMarkupToggleButton
  • OnChildContainerChanged() : CXTPDockingPaneAutoHidePanel, CXTPDockingPaneBase, CXTPDockingPaneMiniWnd, CXTPDockingPaneSplitterContainer
  • OnClick() : CXTPControl, CXTPControlButton, CXTPControlColorSelector, CXTPControlComboBox, CXTPControlCustom, CXTPControlEdit, CXTPControlHyperlink, CXTPControlListBox, CXTPControlPopup, CXTPControlProgress, CXTPControlTabWorkspace, CXTPGridGroupRow, CXTPGridRecordItem, CXTPGridRow, CXTPMarkupButtonBase, CXTPMarkupToggleButton, CXTPPopupControl, CXTPTaskPanel, CXTPTrackControlItem
  • OnClickScrollButton() : CXTPTaskPanel
  • OnClientHeightChanged() : CXTPTaskPanel
  • OnCmdMsg() : CXTPCommandBarEditCtrl, CXTPRibbonTab
  • OnCollapsing() : CXTPPopupControl
  • OnColumnsChanged() : CXTPGridHeader
  • OnCommand() : CXTPCommandBarEditCtrl, CXTPMaskEditT< TBase >
  • OnCompareItem() : CXTPFontCtrlBase
  • OnConstraintChanged() : CXTPGridRecordItem, CXTPGridRecordItemVariant
  • OnConstraintsChanged() : CXTPPropertyGridItem, CXTPPropertyGridItemEnum, CXTPPropertyGridItemFlags
  • OnConstraintSelecting() : CXTPGridControl
  • OnContextMenu() : CXTPGridHeader, CXTPGridRow
  • OnControlAdded() : CXTPControls, CXTPRibbonQuickAccessControls
  • OnControlRemoved() : CXTPControls, CXTPRibbonControls, CXTPRibbonQuickAccessControls
  • OnControlRemoving() : CXTPControls, CXTPRibbonControls
  • OnControlsChanged() : CXTPCommandBar, CXTPPopupBar
  • OnControlSelected() : CXTPCommandBar
  • OnCopy() : CXTPCalendarControl
  • OnCreatePane() : CXTPDockingPaneManager
  • OnCreateSplitter() : CXTPDockingPaneSplitterContainer
  • OnCreateWindow() : CXTPPropertyGridInplaceControl, CXTPPropertyGridInplaceSlider, CXTPPropertyGridInplaceSpinButton
  • OnCustomizeDragEnter() : CXTPCommandBar
  • OnCustomizeDragLeave() : CXTPCommandBar
  • OnCustomizeDragOver() : CXTPCommandBar, CXTPControl, CXTPControlPopup
  • OnCustomizeDrop() : CXTPCommandBar, CXTPTabToolBar
  • OnCustomizeMouseMove() : CXTPControl
  • OnCut() : CXTPCalendarControl
  • OnDblClick() : CXTPGridGroupRow, CXTPGridRecordItem, CXTPGridRow, CXTPTrackControlItem
  • OnDblclk() : CXTPShellListView
  • OnDeselect() : CXTPPropertyGridItem, CXTPPropertyGridItemOption
  • OnDestroyWindow() : CXTPPropertyGridInplaceControl
  • OnDialogConstructed() : CXTPTaskDialog
  • OnDialogDestroyed() : CXTPTaskDialog
  • OnDialogNotify() : CXTPTaskDialog
  • OnDragDrop() : CXTPShellListBase
  • OnDragging() : CXTPCalendarDayView, CXTPCalendarView
  • OnDragOver() : CXTPGridControl, CXTPTaskPanel
  • OnDraw() : CXTPButton, CXTPCalendarControl, CXTPCalendarDayView, CXTPCalendarPaintManager, CXTPCalendarView, CXTPDatePickerControl, CXTPDockingPaneContextStickerWnd, CXTPFlowGraphControl, CXTPFlowGraphPage, CXTPGridControl, CXTPGridHeaderDragWnd, CXTPPropertyGridInplaceButton, CXTPShortcutBar, CXTPSkinObjectComboBox, CXTPSpinButtonCtrl, CXTPStatusBarPane, CXTPStatusBarProgressPane, CXTPStatusBarSwitchPane, CXTPTabClientWnd, CXTPTagCloudCtrl, CXTPTaskPanel
  • OnDrawAction() : CXTPGridPaintManager
  • OnDrawBackground() : CXTPHeaderCtrlTheme, CXTPHeaderCtrlThemeExplorer, CXTPHeaderCtrlThemeOffice2003, CXTPHeaderCtrlThemeOfficeXP, CXTPHeaderCtrlThemeResource
  • OnDrawBackgroundWinThemed() : CXTPHeaderCtrlTheme
  • OnDrawBookmark() : CXTPSyntaxEditView
  • OnDrawButton() : CXTPPasswordPeek
  • OnDrawCaption() : CXTPGridRecordItem, CXTPGridRecordItemPercentNumber, CXTPGridRecordItemPreview
  • OnDrawControls() : CXTPGridRecordItem
  • OnDrawDayDate() : CXTPCalendarPaintManager
  • OnDrawEvent() : CXTPCalendarPaintManager
  • OnDrawGrid() : CXTPCalendarPaintManager
  • OnDrawItem() : CXTPControlSelector, CXTPFontCtrlBase, CXTPTaskPanelGroupItem
  • OnDrawItemBackground() : CXTPHeaderCtrlTheme, CXTPHeaderCtrlThemeOffice2003, CXTPHeaderCtrlThemeOfficeXP, CXTPHeaderCtrlThemeResource
  • OnDrawItemBackgroundWinThemed() : CXTPHeaderCtrlTheme, CXTPHeaderCtrlThemeExplorer
  • OnDrawItemBitmap() : CXTPHeaderCtrlTheme
  • OnDrawItemConstraint() : CXTPPropertyGridItem
  • OnDrawItemSortArrow() : CXTPHeaderCtrlTheme, CXTPHeaderCtrlThemeResource
  • OnDrawItemText() : CXTPHeaderCtrlTheme, CXTPHeaderCtrlThemeResource
  • OnDrawItemValue() : CXTPPropertyGridItem, CXTPPropertyGridItemBool, CXTPPropertyGridItemColor, CXTPPropertyGridItemFont, CXTPPropertyGridItemOption
  • OnDrawSplitter() : CXTPSplitterWndEx
  • OnDrop() : CXTPGridControl, CXTPTaskPanel
  • OnDropDown() : CXTPButton
  • OnEditCanceled() : CXTPGridRecordItem
  • OnEditChanged() : CXTPControlComboBox, CXTPControlEdit, CXTPGridRecordItem, CXTPGridRecordItemDateTime, CXTPGridRecordItemNumber, CXTPGridRecordItemPreview, CXTPGridRecordItemText, CXTPGridRecordItemVariant, CXTPSyntaxEditCtrl, CXTPSyntaxEditLexParser, CXTPSyntaxEditView
  • OnEditChanging() : CXTPGridRecordItem, CXTPGridRecordItemVariant, CXTPSyntaxEditView
  • OnEditCommand() : CXTPCalendarControl
  • OnEditMouseWheel() : CXTPPropertyGridInplaceControl, CXTPPropertyGridInplaceSlider, CXTPPropertyGridInplaceSpinButton
  • OnEnabledChanged() : CXTPControl, CXTPControlComboBox, CXTPControlCustom, CXTPControlEdit, CXTPControlListBox, CXTPControlSlider
  • OnEnableScrollBar() : CXTPSyntaxEditView
  • OnEndDragging() : CXTPCalendarDayView, CXTPCalendarView
  • OnEndLabelEdit() : CXTPFlowGraphControl, CXTPTaskPanel
  • OnEndSelection() : CXTPColorSelectorCtrl
  • OneUpPATH() : CXTPShellPidl
  • OneUpPIDL() : CXTPShellPidl
  • OnEvent() : CXTPCalendarResourcesNf, CXTPNotifySinkBase
  • OnEvent_CalendarOptionsChanged() : CXTPCalendarController
  • OnEvent_CalendarResourcesChanged() : CXTPCalendarController
  • OnEvent_CalendarThemeChanged() : CXTPCalendarController
  • OnEvent_CalendarView() : CXTPCalendarController
  • OnEvent_DatePicker() : CXTPCalendarController
  • OnEvent_DtPickGetItemMetrics() : CXTPCalendarController
  • OnEventChanged_InDataProvider() : CXTPCalendarView
  • OnExecute() : CXTPControl, CXTPControlColorSelector, CXTPControlComboBox, CXTPControlFontComboBox, CXTPControlHyperlink, CXTPControlSizeComboBox, CXTPRibbonBackstageView, CXTPTabManagerNavigateButton
  • OnExpandButtonDown() : CXTPShortcutBar
  • OnExpanding() : CXTPPopupControl
  • OnExpandoButtonClicked() : CXTPTaskDialog
  • OnExtendSize() : CXTPRibbonGroup
  • OnFillBackground() : CXTPTabClientWnd
  • OnFillClient() : CXTPTaskPanelGroup
  • OnFlagsChanged() : CXTPFrameShadow, IXTPFrameShadowManagerEvents
  • OnFocusChanged() : CXTPDockingPaneBase, CXTPDockingPaneMiniWnd
  • OnFocusChanging() : CXTPGridControl
  • OnFolderExpanding() : CXTPShellTreeBase
  • OnFolderSelected() : CXTPShellTreeBase
  • OnFrameAccel() : CXTPCommandBars
  • OnFrameShadowDisabled() : IXTPFrameShadowManagerEvents
  • OnFrameShadowEnabled() : IXTPFrameShadowManagerEvents
  • OnFrameWndMsg() : CXTPCommandBars
  • OnGaugeUpdated() : IXTPGaugeClientSite
  • OnGetCheckPosition() : CXTPCheckListBox
  • OnGetColumnDataBestFitWidth() : CXTPGridControl
  • OnGetItemsCaptionMaxWidth() : CXTPGridControl
  • OnGetToolTipInfo() : CXTPGridControl
  • OnGraphChanged() : CXTPFlowGraphConnectionPoint, CXTPFlowGraphControl, CXTPFlowGraphElement, CXTPFlowGraphPage
  • OnGroupAdded() : CXTPRibbonGroup
  • OnGroupRemoved() : CXTPRibbonGroup
  • OnGroupsScroll() : CXTPRibbonTabPopupToolBar
  • OnHelp() : CXTPTaskDialog
  • OnHookAttached() : CXTPHookManagerHookAble, CXTPSkinObject, CXTPSkinObjectFrame
  • OnHookDetached() : CXTPHookManagerHookAble, CXTPSkinObject, CXTPSkinObjectFrame
  • OnHookKeyDown() : CXTPCommandBar, CXTPControl, CXTPControlCheckBox, CXTPControlComboBox, CXTPControlComboBoxList, CXTPControlEdit, CXTPControlListBox, CXTPControlRadioButton, CXTPMiniToolBar, CXTPPopupBar, CXTPRibbonControlTab, CXTPToolBar
  • OnHookMessage() : CXTPCommandBar, CXTPCommandBarsFrameHook, CXTPControlComboBoxList, CXTPControlCustom, CXTPHookManagerHookAble, CXTPMenuBar, CXTPRibbonBackstageView
  • OnHookMouseWheel() : CXTPControl
  • OnHostWndMsg() : IXTPPreview
  • OnHyperlinkClicked() : CXTPTaskDialog
  • OnIdleUpdate() : CXTPControl
  • OnImageUpdateRequired() : IXTPMarkupDeviceDependentImageSite
  • OnIndeterminate() : CXTPMarkupToggleButton
  • OnIndexChanged() : CXTPPropertyGridItem
  • OnInit() : CXTPFontCtrlBase
  • OnInitControl() : CXTPMarqueeCtrl
  • OnInitDialog() : CXTPCalendarPageSetupDialog, CXTPGridPageSetupDialog
  • OnInpaceControlFocus() : CXTPPropertyGridItem, CXTPPropertyGridItemOption
  • OnInplaceButtonDown() : CXTPGridRecordItem, CXTPPropertyGridItem, CXTPPropertyGridItemColor, CXTPPropertyGridItemDate, CXTPPropertyGridItemFont, CXTPPropertyGridItemMultilineString
  • OnInPlaceCreateEvent() : CXTPCalendarView
  • OnInputBoxChanged() : CXTPTaskDialog
  • OnInserted() : CXTPTaskPanelItem
  • OnInsertKey() : CXTPSyntaxEditView
  • OnInvertTracker() : CXTPPropertyGrid
  • OnItemClick() : CXTPRibbonControlTab, CXTPTabControl, CXTPTabManager
  • OnItemHandleChanged() : CXTPTabManager
  • OnItemInserted() : CXTPPopupItem
  • OnItemOrderChanged() : CXTPTabManager
  • OnItemRemoved() : CXTPTaskPanel
  • OnItemsChanged() : CXTPControlGalleryItems, CXTPTabManager
  • OnKeyboardTip() : CXTPCommandBar, CXTPRibbonTabPopupToolBar
  • OnKeyboardTipChar() : CXTPCommandBar
  • OnKeyDown() : CXTPCalendarDayView, CXTPCalendarMonthView, CXTPCalendarView, CXTPCalendarWeekView, CXTPCalendarWMHandler, CXTPPropertyGridInplaceButton, CXTPPropertyGridItem, CXTPPropertyGridItemBool, CXTPPropertyGridItemOption, CXTPScrollDateButtonPart
  • OnKeyUp() : CXTPCalendarWMHandler, CXTPScrollDateButtonPart
  • OnKillFocus() : CXTPControlComboBox, CXTPControlEdit
  • OnLButtonDblClk() : CXTPCalendarDayViewGroup, CXTPCalendarView, CXTPCalendarViewEvent, CXTPCalendarWMHandler, CXTPControl, CXTPControlPopup, CXTPGridHeader, CXTPPropertyGridItem, CXTPPropertyGridItemBool, CXTPPropertyGridItemOption, CXTPRibbonControlSystemButton
  • OnLButtonDown() : CXTPCalendarCaptionBarThemePart, CXTPCalendarDayView, CXTPCalendarDayViewGroup, CXTPCalendarMonthView, CXTPCalendarMonthViewDay, CXTPCalendarView, CXTPCalendarViewEvent, CXTPCalendarWeekViewDay, CXTPCalendarWMHandler, CXTPControl, CXTPDatePickerItemMonth, CXTPGridHeader, CXTPGridRecordItem, CXTPGridRecordItemButton, CXTPGridRecordItemControl, CXTPGridRow, CXTPPropertyGridInplaceButton, CXTPPropertyGridItem, CXTPPropertyGridItemBool, CXTPPropertyGridItemOption, CXTPScrollDateButtonPart, CXTPStatusBarPane, CXTPStatusBarSwitchPane, CXTPTrackControlItem, CXTPTrackHeader
  • OnLButtonUp() : CXTPCalendarCaptionBarThemePart, CXTPCalendarDayView, CXTPCalendarView, CXTPCalendarViewEvent, CXTPCalendarWMHandler, CXTPControl, CXTPControlButton, CXTPControlColorSelector, CXTPControlPopup, CXTPControlSelector, CXTPDatePickerItemMonth, CXTPGridHeader, CXTPGridRecordItem, CXTPGridRecordItemButton, CXTPGridRecordItemControl, CXTPGridRow, CXTPPropertyGridItem, CXTPRibbonControlSystemPopupBarPinableListItem, CXTPTrackControlItem
  • OnLexCfgWasChanged() : CXTPSyntaxEditCtrl
  • OnLoadingFailed() : CXTPResourceManager
  • OnMarginClicked() : CXTPSyntaxEditView
  • OnMarkupChanged() : CXTPPropertyGridItem
  • OnMDIActivate() : CXTPMDIWndTab
  • OnMDICreate() : CXTPMDIWndTab
  • OnMDIDestroy() : CXTPMDIWndTab
  • OnMeasureItem() : CXTPFontCtrlBase
  • OnMergeItemConstraint() : CXTPPropertyGridItem
  • OnMouseEnter() : CXTPGridRecordItemButton, CXTPGridRecordItemControl
  • OnMouseHitTest() : CXTPCommandBar, CXTPDialogBar
  • OnMouseHover() : CXTPControl, CXTPControlComboBox, CXTPControlEdit, CXTPControlPopup
  • OnMouseLeave() : CXTPGridRecordItemButton, CXTPGridRecordItemControl
  • OnMouseMove() : CXTPCalendarCaptionBarTheme, CXTPCalendarCaptionBarThemePart, CXTPCalendarDayView, CXTPCalendarDayViewDay, CXTPCalendarDayViewGroup, CXTPCalendarMonthView, CXTPCalendarMonthViewDay, CXTPCalendarView, CXTPCalendarViewEvent, CXTPCalendarWeekViewDay, CXTPCalendarWMHandler, CXTPControl, CXTPControlColorSelector, CXTPControlComboBox, CXTPControlEdit, CXTPControlHyperlink, CXTPControlPopup, CXTPControlSelector, CXTPControlTabWorkspace, CXTPDatePickerItemMonth, CXTPGridHeader, CXTPGridRecordItem, CXTPGridRecordItemButton, CXTPGridRecordItemControl, CXTPGridRow, CXTPRibbonControlSystemPopupBarPinableListItem, CXTPStatusBarPane, CXTPStatusBarSwitchPane, CXTPTrackControlItem, CXTPTrackHeader
  • OnMouseWheel() : CXTPChartDiagram2DView, CXTPChartDiagramView
  • OnMoveMarker() : CXTPTrackHeader
  • OnMoveScrollBar() : CXTPTrackHeader
  • OnMoveSelection() : CXTPFlowGraphControl
  • OnMoveSlider() : CXTPTrackHeader
  • OnNavigate() : CXTPPropertyGrid
  • OnNavigateButtonClick() : CXTPDockingPaneTabbedContainer, CXTPTabControl, CXTPTabManager
  • OnNavigateButtonDown() : CXTPShortcutBar
  • OnNavigated() : CXTPTaskDialog
  • OnNcCalcSize() : CXTPPropertyGridPaintManager
  • OnNotify() : CXTPListBase, CXTPTagCloudCtrl
  • OnOK() : CXTPCalendarPageSetupDialog, CXTPGridPageSetupDialog
  • OnOptionsChanged() : CXTPCalendarControl, CXTPCalendarOptions
  • OnPageSelected() : CXTPPropertyPageNavigator
  • OnPaint() : CXTPTaskPanelGroup
  • OnPaintManagerChanged() : CXTPToolBar
  • OnParentContainerChanged() : CXTPDockingPaneBase, CXTPDockingPaneSplitterContainer
  • OnParseEvent() : CXTPSyntaxEditCtrl, CXTPSyntaxEditView
  • OnPartClick() : CXTPCalendarCaptionBarTheme
  • OnPaste() : CXTPCalendarControl
  • OnPinButtonClick() : CXTPDockingPaneMiniWnd, CXTPDockingPaneSidePanel
  • OnPostAdjustLayout() : CXTPCalendarDayViewEvent, CXTPCalendarMonthViewEvent, CXTPCalendarViewEvent, CXTPCalendarWeekViewEvent, CXTPCalendarWMHandler
  • OnPostHookMessage() : CXTPHookManagerHookAble
  • OnPrepareValue() : CXTPMarkupStaticExtension
  • OnPrePopulate() : CXTPCalendarViewGroup
  • OnPrePopulateDay() : CXTPCalendarViewDay
  • OnPreviewEditKey() : CXTPShortcutManager
  • OnPreviewKeyDown() : CXTPGridControl
  • OnPropertyChanged() : CXTPTabManagerAtom, CXTPTabPaintManager
  • OnRadioButtonClicked() : CXTPTaskDialog
  • OnRButtonDown() : CXTPControl, CXTPPropertyGridItem
  • OnRButtonUp() : CXTPControl
  • OnRecalcLayout() : CXTPCommandBar, CXTPControlTabWorkspace, CXTPPopupBar, CXTPToolBar
  • OnReduceSize() : CXTPRibbonGroup
  • OnRemoved() : CXTPCommandBar, CXTPControl, CXTPControlAction, CXTPControlComboBox, CXTPControlCustom, CXTPControlEdit, CXTPControlTabWorkspace, CXTPFlowGraphConnection, CXTPFlowGraphConnectionPoint, CXTPFlowGraphElement, CXTPFlowGraphImage, CXTPFlowGraphNode, CXTPFlowGraphPage, CXTPRibbonTab, CXTPTabManagerItem, CXTPTaskPanelGroup, CXTPTaskPanelItem
  • OnRender() : CXTPMarkupVisual
  • OnRenderFocusVisual() : CXTPMarkupVisual
  • OnReposition() : CXTPTaskPanelGroup, CXTPTaskPanelGroupItem
  • OnRepositionDone() : CXTPShortcutBar
  • OnRequestEdit() : CXTPGridRecordItem, CXTPPropertyGridItem
  • OnResize() : CXTPDialogBar
  • OnRowColChanged() : CXTPSyntaxEditView
  • OnScroll() : CXTPControlScrollBar, CXTPControlSlider, CXTPPropertyGridInplaceSlider
  • OnScrollChanged() : CXTPTaskPanel
  • OnScrollEnd() : CXTPCalendarTimeLineView, CXTPCalendarView
  • OnScrollHeader() : CXTPTabManager
  • OnSelChange() : CXTPTabExBase
  • OnSelChanged() : CXTPControlComboBox
  • OnSelChanging() : CXTPTabExBase
  • OnSelect() : CXTPPropertyGridItem
  • OnSelectedItemChanged() : CXTPControlGallery
  • OnSelectionChanged() : CXTPGridControl, CXTPGridInplaceList, CXTPPropertyGrid
  • OnSelInit() : CXTPSyntaxEditView
  • OnSeriesAdded() : CXTPChartDiagram
  • OnSeriesRemoved() : CXTPChartDiagram
  • OnSeriesStyleChanged() : CXTPChartContent
  • OnSetConnectorPoints() : CXTPChart3dFunnelDeviceCommandEvents, CXTPChart3dFunnelSeriesPointView, CXTPChart3dPieDeviceCommandEvents, CXTPChart3dPieSeriesPointView, CXTPChart3dPyramidDeviceCommandEvents, CXTPChart3dPyramidSeriesPointView
  • OnSetCursor() : CXTPDatePickerItemMonth
  • OnSetDocModified() : CXTPSyntaxEditView
  • OnSetFocus() : CXTPControlComboBox, CXTPControlEdit
  • OnSetPopup() : CXTPControl, CXTPControlComboBox, CXTPControlPopup, CXTPControlSizeComboBox
  • OnSetPreviewMode() : CXTPCommandBars, CXTPDockingPaneManager, CXTPToolBar
  • OnSetSelected() : CXTPControl, CXTPControlColorSelector, CXTPControlComboBox, CXTPControlEdit, CXTPControlListBox, CXTPControlPopup, CXTPControlSelector, CXTPRibbonControlSystemPopupBarPinableListItem, CXTPRibbonControlTab
  • OnShadowedFrameActiveStateChanged() : CXTPFramePaintManager
  • OnShow() : CXTPPopupControl
  • OnShowContextMenu() : CXTPShellPidl
  • OnSizeParent() : CXTPDockingPane, CXTPDockingPaneBase, CXTPDockingPaneSplitterContainer
  • OnSizeParentEx() : CXTPDockingPaneAutoHidePanel
  • OnSizingFloatingFrame() : CXTPDockingPaneContext
  • OnSkinChanged() : CXTPSkinManager, CXTPSkinObject, CXTPSkinObjectDateTime, CXTPSkinObjectFrame
  • OnSortChanged() : CXTPPropertyGrid
  • OnStartDragging() : CXTPCalendarDayView, CXTPCalendarView
  • OnStartGroupDrag() : CXTPTaskPanel
  • OnStartItemDrag() : CXTPTaskPanel
  • OnStartOleDrag() : CXTPSyntaxEditView
  • OnSwitchItem() : CXTPTabManager
  • OnSysKeyDown() : CXTPCalendarView, CXTPCalendarWMHandler
  • OnTabChanged() : CXTPRibbonBar
  • OnTabChanging() : CXTPRibbonBar
  • OnTabsChanged() : CXTPDockingPaneTabbedContainer
  • OnThemeChanged() : CXTPControl, CXTPControlMarkupLabel, CXTPHeaderCtrl, CXTPTabExBase
  • OnThemedChanged() : CXTPDockingPaneMiniWnd
  • OnTimer() : CXTPCalendarCaptionBarTheme, CXTPCalendarDayView, CXTPCalendarView, CXTPCalendarViewEvent, CXTPCalendarWMHandler, CXTPTaskDialog
  • OnTimeZoneChanged() : CXTPCalendarData, CXTPCalendarMemoryDataProvider
  • OnToggle() : CXTPMarkupToggleButton
  • OnToolBarAdded() : CXTPCommandBars
  • OnToolBarRemoved() : CXTPCommandBars
  • OnToolHitTest() : CXTPControl, CXTPControlColorSelector, CXTPControlTabWorkspace, CXTPDockingPaneSidePanel, CXTPGridGroupRow, CXTPGridHeader, CXTPGridRecordItem, CXTPGridRow, CXTPRibbonTabPopupToolBar, CXTPStatusBarPane, CXTPStatusBarSwitchPane, CXTPTrackControlItem
  • OnTrackEnter() : CXTPCommandBar
  • OnTrackingModeChanged() : CXTPCommandBars
  • OnTrackLost() : CXTPCommandBar
  • OnUnchecked() : CXTPMarkupToggleButton
  • OnUnderlineActivate() : CXTPControl, CXTPControlComboBox, CXTPControlEdit, CXTPControlPopup, CXTPRibbonControlTab
  • OnUndo() : CXTPCalendarControl
  • OnUnsubscribe() : CXTPChartDeviceCommandEvents
  • OnUpdateBounds() : CXTPChart3dFunnelSeriesPointView, CXTPChart3dPieSeriesPointView, CXTPChart3dPyramidSeriesPointView, CXTPChartDeviceCommandEvents
  • OnUpdateCameraState() : CXTPChart3dDeviceContext
  • OnUpdateCmdUI() : CXTPCalendarControl
  • OnUpdateCopy() : CXTPCalendarControl
  • OnUpdateCut() : CXTPCalendarControl
  • OnUpdateEditingSubject() : CXTPCalendarView
  • OnUpdateMDIChildrenTheme() : CXTPCommandBarsFrameHook
  • OnUpdatePaste() : CXTPCalendarControl
  • OnUpdateScrollPos() : CXTPSyntaxEditView
  • OnUpdateUndo() : CXTPCalendarControl
  • OnValidateEdit() : CXTPGridRecordItem, CXTPPropertyGridItem
  • OnValueChanged() : CXTPPropertyGridInplaceControl, CXTPPropertyGridInplaceSlider, CXTPPropertyGridInplaceSpinButton, CXTPPropertyGridItem, CXTPPropertyGridItemDate
  • OnValueChanging() : CXTPGridRecordItemVariant
  • OnVerbClick() : CXTPPropertyGrid
  • OnVerbsChanged() : CXTPPropertyGrid
  • OnVerificationClicked() : CXTPTaskDialog
  • OnWndMsg() : CXTPCalendarControl, CXTPCalendarViewEvent, CXTPCalendarWMHandler
  • OnWndMsg_Children() : CXTPCalendarControl
  • Open() : CXTPCalendarData, CXTPCalendarDatabaseDataProvider, CXTPCalendarMemoryDataProvider, CXTPMemFile, CXTPSkinManagerResourceFile
  • OpenEx() : CXTPCalendarDatabaseDataProvider
  • OpenThemeData() : CXTPWinThemeWrapper
  • operator _TObject *() : CXTPSmartPtrInternalT< _TObject >
  • operator _TValue &() : CXTPAutoResetValue< _TValue >
  • operator _TValue *() : CXTPCalendarViewPartCustomizableValueT< _TValue >
  • operator _TValueRef() : CXTPCalendarThemeCustomizableXValueT< _TValue, _TValueRef >
  • operator Adaptee *() : CXTPAsyncGuard< Adaptee, RWLock >
  • operator BOOL() : CXTPImageManagerVectorImageHandle
  • operator bool() : CXTPSmartPtrInternalT< _TObject >
  • operator CBrush &() : CXTPBrush
  • operator CFont &() : CXTPCalendarViewPartFontValue, CXTPFont
  • operator CFont *() : CXTPCalendarViewPartFontValue
  • operator CGdiObject &() : CXTPGdiObject
  • operator CImageList &() : CXTPImageList
  • operator COLORREF() : CXTPPaintManagerColor, CXTPPaintManagerColorGradient
  • operator const Adaptee *() : CXTPAsyncGuard< Adaptee, RWLock >
  • operator const CBrush &() : CXTPBrush
  • operator const CFont &() : CXTPFont
  • operator const CGdiObject &() : CXTPGdiObject
  • operator const CImageList &() : CXTPImageList
  • operator const CPen &() : CXTPPen
  • operator const CString &() : CXTPCalendarThemeStringValue
  • operator CPen &() : CXTPPen
  • operator CRect() : CXTPResizeRect
  • operator CRITICAL_SECTION &() : CXTPCriticalSection
  • operator CString() : CXTPHeapString, CXTPHeapStringT< _TAllocator >
  • operator CXTPPaintManagerColor &() : CXTPPaintManagerColorGradient
  • operator CXTPPoint2d() : CXTPPoint2T< T >, CXTPPoint3T< T >
  • operator CXTPPoint2f() : CXTPPoint2T< T >, CXTPPoint3T< T >
  • operator CXTPPoint2i() : CXTPPoint2T< T >, CXTPPoint3T< T >
  • operator CXTPPoint3d() : CXTPPoint3T< T >
  • operator CXTPPoint3f() : CXTPPoint3T< T >
  • operator CXTPPoint3i() : CXTPPoint3T< T >
  • operator delete() : CXTPBatchAllocObjT< _TObject, _TBatchAllocData, _TAllocator >, CXTPHeapObjectT< _TObject, _TAllocator >
  • operator HBRUSH() : CXTPBrush
  • operator HFONT() : CXTPFont
  • operator HGDIOBJ() : CXTPGdiObject
  • operator HICON() : CXTPIconHandle, CXTPImageManagerIconHandle
  • operator HIMAGELIST() : CXTPImageList
  • operator HMODULE() : CXTPModuleHandle
  • operator HPEN() : CXTPPen
  • operator int() : XTP_CALENDAR_MONTHVIEW_DAYPOS
  • operator LPCTSTR() : CXTPHeapString, CXTPHeapStringT< _TAllocator >
  • operator LPMALLOC() : CXTPShellPidl::CShellMalloc
  • operator LPSHELLFOLDER() : CXTPShellPidl::CShellSpecialFolder
  • operator new() : CXTPBatchAllocObjT< _TObject, _TBatchAllocData, _TAllocator >, CXTPHeapObjectT< _TObject, _TAllocator >
  • operator!() : CXTPSmartPtrInternalT< _TObject >
  • operator!=() : CXTPGdiObject, CXTPHeapString, CXTPHeapStringT< _TAllocator >, CXTPPoint2T< T >, CXTPPoint3T< T >, CXTPRectT< T >, CXTPResizeRect, CXTPSizeT< T >, CXTPSmartPtrInternalT< _TObject >, CXTPSyntaxEditSelection, XTP_CALENDAR_HITTESTINFO, XTP_EDIT_LINECOL
  • operator&() : CXTPResizeRect
  • operator*() : CXTPAsyncGuard< Adaptee, RWLock >, CXTPSmartPtrInternalT< _TObject >, CXTPThreadLocal< T >
  • operator+() : CXTPResizeRect, CXTPSizeT< T >
  • operator++() : XTP_CALENDAR_MONTHVIEW_DAYPOS
  • operator+=() : CXTPMemFile, CXTPResizeRect
  • operator-() : CXTPSizeT< T >
  • operator->() : CXTPAsyncGuard< Adaptee, RWLock >, CXTPCalendarViewPartCustomizableValueT< _TValue >, CXTPCalendarViewPartFontValue, CXTPSmartPtrInternalT< _TObject >
  • operator<() : XTP_EDIT_LINECOL
  • operator<=() : XTP_EDIT_LINECOL
  • operator=() : CXTPAutoResetValue< _TValue >, CXTPCalendarEventLabel, CXTPCalendarThemeBOOLValue, CXTPCalendarThemeCustomizableXValueT< _TValue, _TValueRef >, CXTPCalendarThemeFontValue, CXTPCalendarThemeIntValue, CXTPCalendarThemeRectValue, CXTPCalendarThemeStringValue, CXTPCalendarTimeZone, CXTPCalendarViewPartFontValue, CXTPChart3dBox, CXTPChart3dRotation, CXTPEmptySize, CXTPGridThickness, CXTPHeapString, CXTPHeapStringT< _TAllocator >, CXTPIconHandle, CXTPImageManagerVectorImageHandle, CXTPLogFont, CXTPMemFile, CXTPPaintManagerColor, CXTPPaintManagerColorGradient, CXTPResizeRect, CXTPSmartPtrInternalT< _TObject >, CXTPSyntaxEditCtrl, CXTPSyntaxEditLexParserSchemaOptions, CXTPSyntaxEditLexTokensDef, CXTPSyntaxEditLexVariable, CXTPSyntaxEditLexVariant, CXTPSyntaxEditSelection, CXTPTagCloudStyle, XTP_CALENDAR_MONTHVIEW_DAYPOS, XTP_CALENDAR_PATTERN_END, XTP_CALENDAR_RECURRENCE_OPTIONS, XTP_CALENDAR_VIEWSELECTION, XTP_GRIDDATAMANAGER_COM_ERROR
  • operator==() : CXTPGdiObject, CXTPHeapString, CXTPHeapStringT< _TAllocator >, CXTPPoint2T< T >, CXTPPoint3T< T >, CXTPRectT< T >, CXTPResizeRect, CXTPSizeT< T >, CXTPSmartPtrInternalT< _TObject >, CXTPSyntaxEditLexVariable, CXTPSyntaxEditLexVariant, CXTPSyntaxEditSelection, XTP_CALENDAR_HITTESTINFO, XTP_EDIT_LINECOL
  • operator>() : XTP_EDIT_LINECOL
  • operator>=() : XTP_EDIT_LINECOL
  • operator[]() : CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE >, CXTPCalendarTypedPtrAutoDeleteMap< KEY, TPtr >, CXTPMemFile, CXTPTabManagerNavigateButtons
  • OptimizeChildrenClipping() : CXTPScrollBarContainer< Parent >
  • OverrideTimeProvider() : CXTPCalendarUtils
  • OwnerDrawTip() : CXTPSyntaxEditTipWnd


Toolkit Pro: Class Members - Functions

Here is a list of all documented functions with links to the class documentation for each member:

- p -

  • PageToScreen() : CXTPFlowGraphPage
  • PageToSize() : CXTPPropertyPageNavigator
  • PaneHasBorders() : CXTPDockingPaneOffice2007WordTheme
  • ParceTimeDuration_min() : CXTPCalendarUtils
  • ParceTimeString_min() : CXTPCalendarUtils
  • Parse() : CXTPMarkupContext, CXTPMarkupStaticExtension
  • ParseDateTime() : CXTPPropertyGridItemDate
  • ParseSection() : CXTPSyntaxEditColorTheme
  • ParseSectionFromString() : CXTPSyntaxEditColorTheme
  • PassKeyboardInputToBackstageView() : CXTPRibbonBar
  • Paste() : CXTPCalendarView, CXTPFlowGraphPage, CXTPGridControl, CXTPSyntaxEditCtrl
  • PasteFromClipboard() : CXTPTaskPanelItem
  • PathFindNextComponent() : CXTPShellTreeBase
  • PeekButtonEnable() : CXTPPasswordPeek
  • PerformClick() : CXTPMessageBarButton, CXTPTabManager, CXTPTabManagerNavigateButton
  • PerformKeyDown() : CXTPTabManager
  • PerformMouseMove() : CXTPTabManager
  • PerformToolHitTest() : CXTPTabManager
  • PerformTrackInit() : CXTPScrollBase
  • PinFooterRows() : CXTPGridControl
  • PinFooterRowsPrinted() : CXTPGridControl
  • Pixel() : CXTPDockingPanePaintManager, CXTPPaintManager, CXTPTabBaseTheme
  • PlaySystemSound() : CXTPSoundManager
  • PointInRect() : CXTPTagCloudCtrl
  • Polar2Cartesian() : CXTPChartEllipse
  • Populate() : CXTPCalendarControl, CXTPCalendarDayViewDay, CXTPCalendarMonthView, CXTPCalendarTimeLineView, CXTPCalendarTimeLineViewGroup, CXTPCalendarView, CXTPCalendarViewDay, CXTPCalendarViewGroup, CXTPCalendarWeekView, CXTPDatePickerControl, CXTPGridControl, CXTPGridSection, CXTPTrackControl
  • PopulateDays() : CXTPDatePickerItemMonth
  • PopulateFooterRows() : CXTPGridControl
  • PopulateHeaderRows() : CXTPGridControl
  • PopulateListView() : CXTPShellListBase
  • PopulateTree() : CXTPShellTreeBase
  • PopulateTreeView() : CXTPShellTreeBase
  • Popup() : CXTPCommandBar, CXTPControlComboBoxList, CXTPPopupBar, CXTPRibbonBackstageView
  • PopupMenu() : CXTPBrowseEdit
  • PosInRange() : CXTPMaskEditT< TBase >
  • PositionBrowseButton() : CXTPBrowseEdit
  • PositionControls() : CXTPStatusBar
  • PositionToTrack() : CXTPTrackControl
  • PostEvent() : CXTPNotifyConnectionMT
  • PostNotify_RemindersFire() : CXTPCalendarRemindersManager
  • PreCompareItem() : CXTPCheckListBox
  • PreDeleteItem() : CXTPCheckListBox
  • PreDrawItem() : CXTPCheckListBox, CXTPControlGalleryItems
  • PreDrawItemNonThemed() : CXTPCheckListBox
  • PreDrawItemThemed() : CXTPCheckListBox
  • PreMeasureItem() : CXTPCheckListBox
  • PreMultiply() : CXTPImageManagerIconHandle
  • Premultiply() : CXTPResourceImage
  • PreMultiplyAlphaBitmap() : CXTPImageManagerIcon
  • PreMultiplyAlphaBitmapBits() : CXTPImageManager
  • Prepare() : CXTPChartDeviceCommand
  • PrepareCodeChunk() : IXTPMarkupClientSite
  • PrepareDeleteGridRecords() : CXTPGridDataManager
  • PrepareDrag() : CXTPTaskPanelGroupItem
  • PrepareName() : CXTPCalendarCustomProperties
  • PrepareOverride() : CXTPChartDeviceCommand
  • PrepareToDropping() : CXTPGridRecords
  • PreserveOrientation() : CXTPResourceImage
  • PreSubclassWindow() : CXTPDatePickerControl
  • PreTranslateFrameMessage() : CXTPCommandBars
  • PreTranslateMessage() : CXTPMaskEditT< TBase >
  • PrevBookmark() : CXTPSyntaxEditCtrl
  • Preview() : CXTPPreviewCtrl
  • PreviewAllowEdit() : CXTPGridControl
  • PrevView() : CXTPTabExBase
  • PrintClient() : CXTPSplitterWnd
  • PrintFixedRowsDivider() : CXTPGridView
  • PrintFooter() : CXTPGridView
  • PrintGrid() : CXTPGridView
  • PrintHeader() : CXTPGridView
  • PrintLineTextEx() : CXTPSyntaxEditPaintManager
  • PrintPage() : CXTPGridView, CXTPSyntaxEditCtrl
  • PrintPageFooter() : CXTPGridView
  • PrintPageHeader() : CXTPGridView
  • PrintRowPart() : CXTPSyntaxEditDrawTextProcessor
  • PrintToDC() : CXTPChartControl
  • ProcessButtons() : CXTPDatePickerControl
  • ProcessCollapsedBlockDblClick() : CXTPSyntaxEditCtrl
  • ProcessCollapsedText() : CXTPSyntaxEditCtrl
  • ProcessCollapsedTextEx() : CXTPSyntaxEditCtrl
  • ProcessDaySelection() : CXTPCalendarDayView, CXTPCalendarView
  • ProcessEventSelection() : CXTPCalendarView
  • ProcessHookKeyDown() : CXTPControlComboBoxList
  • ProcessKeyboardHooks() : CXTPKeyboardManager
  • ProcessKeyboardInput() : CXTPRibbonBackstageView
  • ProcessMask() : CXTPDateEdit, CXTPMaskEditT< TBase >, CXTPTimeEdit
  • ProcessSpecialKey() : CXTPCommandBar, CXTPRibbonTabPopupToolBar
  • Project() : CXTPChart3dDeviceContext, CXTPOpenGLUtils
  • PropExists() : CXTPSyntaxEditPropertiesPageColor
  • PropV() : CXTPSyntaxEditLexClass
  • ProvideValue() : CXTPMarkupStaticExtension, CXTPMarkupStaticExtensionProperty
  • PtInCheckBoxRect() : CXTPPropertyGridItemBool
  • PtInRect() : CXTPDockingPaneCaptionButton, CXTPFlowGraphConnection, CXTPMarkupGdiPlusTransformationMatrix, CXTPMarkupTransformationMatrix
  • PtInRectTransform() : CXTPMarkupVisual
  • PtInValueRect() : CXTPPropertyGridItem
  • PumpMessage() : CXTPMiniToolBar, CXTPPopupBar
  • PutSection() : CXTPPropExchangeXMLNode


Toolkit Pro: Class Members - Functions

Here is a list of all documented functions with links to the class documentation for each member:

- q -

  • QueryContinueDrag() : CXTPDropSource
  • QueryInterface() : CXTPDropSource
  • QueueDayViewSwitch() : CXTPCalendarControl


Toolkit Pro: Class Members - Functions

Here is a list of all documented functions with links to the class documentation for each member:

- r -

  • Radian2Degree() : CXTPMathUtils
  • Read() : CXTPImageList, CXTPPropExchange, CXTPPropExchangeArchive
  • ReadCount() : CXTPPropExchange, CXTPPropExchangeArchive
  • ReadList() : CXTPRecentFileList
  • ReadOleDateTime() : CXTPDateEdit
  • ReadProperties() : CXTPSkinManagerSchema
  • ReadRegistryValues() : CXTPSyntaxEditPropertiesPageEdit, CXTPSyntaxEditPropertiesPageFont
  • ReadSkinData() : CXTPSkinManager
  • ReadString() : CXTPMemFile, CXTPSkinManagerResourceFile
  • RebuildControls() : CXTPRibbonBar
  • ReBuildInternalData() : CXTPCalendarResourcesNf
  • Recalc() : CXTPGridControl
  • RecalcConnectionLayout() : CXTPFlowGraphPaintManager
  • RecalcFrameLayout() : CXTPCommandBars, CXTPCommandBarsFrameHook, CXTPDockingPaneManager
  • RecalcFramesLayout() : CXTPDockingPaneManager
  • RecalcHorzScrollPos() : CXTPSyntaxEditCtrl
  • RecalcLayout() : CXTPCaptionPopupWnd, CXTPEditListBox, CXTPExcelTabCtrl, CXTPFlowGraphConnection, CXTPHeaderCtrl, CXTPMDIWndTab, CXTPMessageBar, CXTPShortcutBarPane, CXTPSplitterWndEx, CXTPStatusBar, CXTPTabExBase, CXTPTagCloudCtrl, CXTPTrackControlItem
  • RecalcRowHeight() : CXTPSyntaxEditDrawTextProcessor
  • RecalcScrollBars() : CXTPSyntaxEditCtrl
  • RecalcSize() : CXTPPageScroller
  • RecalcTotalHightOfMergedRows() : CXTPGridPaintManager
  • RecalcVertScrollPos() : CXTPSyntaxEditCtrl
  • RecalLayout() : CXTPFlowGraphNode
  • ReclaimList() : CXTPOpenGLListPool
  • ReCreateProvider() : CXTPWebBrowserCtrl
  • Rectangle() : CXTPDockingPanePaintManager, CXTPPaintManager, CXTPShortcutBarOffice2000Theme, CXTPShortcutBarPaintManager, CXTPTabColorSetOffice2003, CXTPTaskPanelPaintManager
  • Redo() : CXTPCalendarView, CXTPFlowGraphUndoManager, CXTPResourceManager::CManageState, CXTPSyntaxEditCtrl, CXTPTrackUndoManager
  • Redraw() : CXTPCalendarCaptionBarTheme, CXTPCalendarCaptionBarThemePart, CXTPCommandBar, CXTPStatusBarPane, CXTPTaskPanel
  • RedrawAllControls() : CXTPSkinManager
  • RedrawButton() : CXTPButton
  • RedrawComboBox() : CXTPComboBox
  • RedrawCommandBars() : CXTPCommandBars
  • RedrawControl() : CXTPCalendarControl, CXTPCalendarView, CXTPControlTabWorkspace, CXTPDatePickerControl, CXTPDockingPaneTabbedContainer, CXTPFlowGraphControl, CXTPGridControl, CXTPPopupControl, CXTPPopupItem, CXTPPropertyGrid, CXTPRibbonControlTab, CXTPShortcutBar, CXTPTabControl, CXTPTabManager, CXTPTabToolBar, CXTPTrackControlItem
  • RedrawControls() : CXTPControlAction
  • RedrawEdit() : CXTPEdit
  • RedrawFocusedFrame() : CXTPComboBox, CXTPEdit, CXTPEditTheme, CXTPEditThemeOffice2000, CXTPEditThemeOfficeXP
  • RedrawFrame() : CXTPCommandBarsFrameHook
  • RedrawItem() : CXTPPropertyGridItem
  • RedrawLB() : CXTPCalendarEventCategoryComboBox
  • RedrawLineMarks() : CXTPSyntaxEditCtrl
  • RedrawMenuTitleBar() : CXTPCommandBarsFrameHook
  • RedrawPane() : CXTPDockingPaneBase, CXTPDockingPaneMiniWnd
  • RedrawPanel() : CXTPTaskPanelItem
  • RedrawPanes() : CXTPDockingPaneManager
  • RedrawParent() : CXTPControl
  • RedrawProgress() : CXTPControlProgress, CXTPProgressBase, CXTPStatusBarProgressPane
  • RedrawRibbonBar() : CXTPCommandBarsFrameHook
  • RedrawScrollBar() : CXTPScrollBase, CXTPSkinObjectFrame
  • RefeshBindings() : CXTPPropertyGrid
  • Refresh() : CXTPImageManagerIcon, CXTPPropertyGrid, CXTPPropertyGridView, CXTPSyntaxEditColorSampleText, CXTPSyntaxEditView, CXTPTabClientWnd
  • RefreshActiveSel() : CXTPMDIWndTab
  • RefreshAll() : CXTPImageManager, CXTPImageManagerIconSet
  • RefreshButton() : CXTPCaption
  • RefreshCaptionBar() : CXTPCalendarControl
  • RefreshChildIndices() : CXTPGridRows
  • RefreshColors() : CXTPColorManager, CXTPColorSetStateButton, CXTPColorSetStateCheckBox, CXTPColorSetStateCheckMark, CXTPColorSetStateComboBox, CXTPColorSetStateMenu, CXTPColorSetStateRibbon, CXTPColorSetStateToolbar, CXTPSyntaxEditCtrl
  • RefreshCursor() : CXTPMouseManager
  • RefreshFiles() : CXTPSyntaxEditFileChangesMonitor
  • RefreshFolder() : CXTPDirWatcher
  • RefreshIndexes() : CXTPGridRecordItemControls, CXTPGridSection, CXTPGridSections, CXTPMDIWndTab
  • RefreshLineMarks() : CXTPSyntaxEditCtrl, CXTPSyntaxEditLineMarksManager
  • RefreshLunaColors() : CXTPColorManager
  • RefreshManagersArray() : CXTPDockingPaneAutoHidePanel
  • RefreshMenu() : CXTPMenuBar
  • RefreshMetrics() : CAppearanceSetPropertyPage2003, CAppearanceSetPropertyPage2007, CAppearanceSetPropertyPageAccess2007, CColorSetVisualStudio2003, CColorSetVisualStudio2005, CColorSetWinNative, CXTPButton, CXTPButtonTheme, CXTPButtonThemeNativeWindows10, CXTPButtonThemeNativeWindows11, CXTPButtonThemeOffice2003, CXTPButtonThemeOffice2013, CXTPButtonThemeOfficeXP, CXTPButtonThemeResource, CXTPButtonThemeUltraFlat, CXTPButtonThemeVisualStudio2012, CXTPButtonThemeVisualStudio2015, CXTPButtonThemeVisualStudio2017, CXTPButtonThemeVisualStudio2019, CXTPButtonThemeVisualStudio2022, CXTPCalendarCaptionBarOffice2000Theme, CXTPCalendarCaptionBarOffice2013Theme, CXTPCalendarCaptionBarOfficeXPTheme, CXTPCalendarCaptionBarPaintManager, CXTPCalendarCaptionBarResourceTheme, CXTPCalendarCaptionBarTheme, CXTPCalendarCaptionBarThemePart, CXTPCalendarOffice2003Theme, CXTPCalendarOffice2013Theme, CXTPCalendarPaintManager, CXTPCalendarResourceTheme, CXTPCalendarTimeLineView, CXTPCalendarTimeLineViewTimeScalePart, CXTPCalendarViewPart, CXTPCaption, CXTPCaptionTheme, CXTPCheckboxButtonPart, CXTPColorSelectorCtrl, CXTPColorSelectorCtrlTheme, CXTPColorSelectorCtrlThemeOffice2003, CXTPColorSelectorCtrlThemeOffice2013, CXTPColorSelectorCtrlThemeOfficeXP, CXTPColorSelectorCtrlThemeResource, CXTPColorSelectorCtrlThemeVisualStudio2015, CXTPColorSetCaptionButton, CXTPComboBox, CXTPComboBoxTheme, CXTPComboBoxThemeDefault, CXTPComboBoxThemeNativeWindows10, CXTPComboBoxThemeNativeWindows11, CXTPComboBoxThemeOffice2000, CXTPComboBoxThemeOffice2003, CXTPComboBoxThemeOffice2013, CXTPComboBoxThemeOfficeXPFlat, CXTPComboBoxThemeResource, CXTPComboBoxThemeVisualStudio2010, CXTPComboBoxThemeVisualStudio2012, CXTPComboBoxThemeVisualStudio2015, CXTPComboBoxThemeVisualStudio2017, CXTPComboBoxThemeVisualStudio2019, CXTPComboBoxThemeVisualStudio2022, CXTPComboBoxThemeVisualStudio, CXTPCommandBarsModernUITheme, CXTPCommandBarsNativeWindows11Theme, CXTPCommandBarsNativeXPTheme, CXTPCommandBarsOffice2000Theme, CXTPCommandBarsOffice2003Theme, CXTPCommandBarsOffice2013Theme, CXTPCommandBarsVisualStudio2012Theme, CXTPControlGalleryOffice2013Theme, CXTPControlGalleryPaintManager, CXTPControlGalleryResourceTheme, CXTPDateLabelPart, CXTPDatePickerPaintManager, CXTPDatePickerThemeOffice2003, CXTPDatePickerThemeOffice2013, CXTPDatePickerThemeResource, CXTPDeviceCaps, CXTPDockingPaneColorSet2012, CXTPDockingPaneColorSet2013, CXTPDockingPaneColorSet2015, CXTPDockingPaneColorSet2017, CXTPDockingPaneColorSet2019, CXTPDockingPaneColorSet2022, CXTPDockingPaneColorSet, CXTPDockingPaneColorSetNativeWindows10, CXTPDockingPaneColorSetNativeWindows11, CXTPDockingPaneDefaultTheme, CXTPDockingPaneGripperedTheme, CXTPDockingPaneNativeWindows10Theme, CXTPDockingPaneNativeWindows11Theme, CXTPDockingPaneOffice2002VisioTheme, CXTPDockingPaneOffice2003OutlookTheme, CXTPDockingPaneOffice2003Theme, CXTPDockingPaneOffice2007OutlookTheme, CXTPDockingPaneOffice2007Theme, CXTPDockingPaneOffice2007WordTheme, CXTPDockingPaneOffice2013Theme, CXTPDockingPanePaintManager, CXTPDockingPanePanelColorSet2012, CXTPDockingPanePanelColorSet2013, CXTPDockingPanePanelColorSet2015, CXTPDockingPanePanelColorSet2017, CXTPDockingPanePanelColorSet2019, CXTPDockingPanePanelColorSet2022, CXTPDockingPanePanelColorSetNativeWindows10, CXTPDockingPanePanelColorSetNativeWindows11, CXTPDockingPanePanelTheme2012, CXTPDockingPaneTabColorSet2012, CXTPDockingPaneTabColorSet2013, CXTPDockingPaneTabColorSetOfficePanel, CXTPDockingPaneTabColorSetVisualStudio2003, CXTPDockingPaneTabColorSetVisualStudio2005, CXTPDockingPaneTabTheme2012, CXTPDockingPaneTabTheme2013, CXTPDockingPaneVisualStudio2003Theme, CXTPDockingPaneVisualStudio2005Beta1Theme, CXTPDockingPaneVisualStudio2005Beta2Theme, CXTPDockingPaneVisualStudio2008Theme, CXTPDockingPaneVisualStudio2010Theme, CXTPDockingPaneVisualStudio2012Theme, CXTPDockingPaneVisualStudio2015Theme, CXTPDockingPaneVisualStudio2017Theme, CXTPDockingPaneVisualStudio2019Theme, CXTPDockingPaneVisualStudio2022Theme, CXTPDockingPaneWinExplorerTheme, CXTPDockingPaneWinNativeTheme, CXTPEdit, CXTPEditListBox, CXTPEditTheme, CXTPEditThemeDefault, CXTPEditThemeFlat, CXTPEditThemeOffice2000, CXTPEditThemeOffice2003, CXTPEditThemeOffice2013, CXTPEditThemeOfficeXP, CXTPEditThemeResource, CXTPEditThemeUltraFlat, CXTPEditThemeVisualStudio2010, CXTPEditThemeVisualStudio2012, CXTPExcelTabCtrl, CXTPExcelTabCtrlTheme, CXTPExcelTabCtrlThemeOffice2003, CXTPExcelTabCtrlThemeOffice2013, CXTPExcelTabCtrlThemeOfficeXP, CXTPFlowGraphPaintManager, CXTPFramePaintManager, CXTPFrameThemeOffice2007System, CXTPGridPaintManager, CXTPGridThemeNativeWindows10, CXTPGridThemeNativeWindows11, CXTPGridThemeOffice2003Luna, CXTPGridThemeOffice2013, CXTPGridThemeResource, CXTPGridThemeVisualStudio2012Blue, CXTPGridThemeVisualStudio2012Dark, CXTPGridThemeVisualStudio2012Light, CXTPGridThemeVisualStudio2015, CXTPGridThemeVisualStudio2017, CXTPGridThemeVisualStudio2019, CXTPGridThemeVisualStudio2022, CXTPHeaderCtrl, CXTPHeaderCtrlTheme, CXTPHeaderCtrlThemeResource, CXTPListBase, CXTPListBox, CXTPListBoxTheme, CXTPListBoxThemeDefault, CXTPListBoxThemeOffice2003, CXTPListBoxThemeOffice2013, CXTPListBoxThemeOfficeXP, CXTPListBoxThemeResource, CXTPMarqueeCtrl, CXTPMarqueeCtrlPaintManager, CXTPMarqueeCtrlThemeFlat, CXTPMarqueeCtrlThemeOffice2000, CXTPMarqueeCtrlThemeOffice2003, CXTPMarqueeCtrlThemeOffice2013, CXTPMarqueeCtrlThemeOfficeXP, CXTPMarqueeCtrlThemeUltraFlat, CXTPMessageBarPaintManager, CXTPMessageBarThemeOffice2010, CXTPMessageBarThemeOffice2013, CXTPPaintManager, CXTPPopupPaintManager, CXTPPopupThemeMSN, CXTPPopupThemeOffice2000, CXTPPopupThemeOffice2003, CXTPPopupThemeOffice2013, CXTPPopupThemeOfficeXP, CXTPPopupThemeResource, CXTPProgressCtrl, CXTPProgressCtrlPaintManager, CXTPProgressCtrlThemeFlat, CXTPProgressCtrlThemeOffice2003, CXTPProgressCtrlThemeOffice2013, CXTPProgressCtrlThemeUltraFlat, CXTPProgressCtrlThemeVisualStudio2015, CXTPProgressPaintManager, CXTPProgressThemeOffice2013, CXTPPropertyGridCoolTheme, CXTPPropertyGridDelphiTheme, CXTPPropertyGridNativeWindows10Theme, CXTPPropertyGridNativeWindows11Theme, CXTPPropertyGridNativeXPTheme, CXTPPropertyGridOffice2003Theme, CXTPPropertyGridOffice2007Theme, CXTPPropertyGridOffice2013Theme, CXTPPropertyGridOfficeXPTheme, CXTPPropertyGridPaintManager, CXTPPropertyGridSimpleTheme, CXTPPropertyGridVisualStudio2005Theme, CXTPPropertyGridVisualStudio2010Theme, CXTPPropertyGridVisualStudio2012Theme, CXTPPropertyGridVisualStudio2015Theme, CXTPPropertyGridVisualStudio2017Theme, CXTPPropertyGridVisualStudio2019Theme, CXTPPropertyGridVisualStudio2022Theme, CXTPRadioButtonPart, CXTPReBarPaintManager< TBase >, CXTPResourceTheme, CXTPRibbonMarkupTheme, CXTPRibbonOffice2013Theme, CXTPRibbonPaintManager, CXTPRibbonTheme, CXTPRibbonThemeNativeWindows10, CXTPRibbonThemeNativeWindows11, CXTPRibbonThemeOffice2007System, CXTPRibbonThemeResource, CXTPScrollBarCtrl, CXTPScrollBarPaintManager, CXTPScrollBarThemeFlat, CXTPScrollBarThemeOffice2003, CXTPScrollBarThemeOffice2013, CXTPScrollBarThemeOfficeXP, CXTPScrollBarThemeUltraFlat, CXTPScrollBarThemeWindowsUx, CXTPShortcutBarNativeWindows10Theme, CXTPShortcutBarNativeWindows11Theme, CXTPShortcutBarNativeWinXPTheme, CXTPShortcutBarOffice2003Theme, CXTPShortcutBarOffice2013Theme, CXTPShortcutBarPaintManager, CXTPShortcutBarResourceTheme, CXTPShortcutBarVisualStudio2015Theme, CXTPShortcutBarVisualStudio2017Theme, CXTPShortcutBarVisualStudio2019Theme, CXTPShortcutBarVisualStudio2022Theme, CXTPShortcutListBox, CXTPShortcutListBoxTheme, CXTPShortcutListBoxThemeOffice2003, CXTPShortcutListBoxThemeOfficeXP, CXTPSkinManagerMetrics, CXTPSkinObject, CXTPSkinObjectDateTime, CXTPSkinObjectFrame, CXTPSkinObjectMonthCal, CXTPSliderPaintManager, CXTPSpinButtonCtrl, CXTPSplitterWnd, CXTPSplitterWndTheme, CXTPSplitterWndThemeOffice2003, CXTPSplitterWndThemeOffice2013, CXTPSplitterWndThemeOfficeXP, CXTPSplitterWndThemeResource, CXTPSplitterWndThemeVisualStudio2010, CXTPStatusBarThemeNativeWindows10, CXTPStatusBarThemeNativeWindows11, CXTPStatusBarThemeOffice2013, CXTPStatusBarThemeVisualStudio2015, CXTPStatusBarThemeVisualStudio2017, CXTPStatusBarThemeVisualStudio2019, CXTPStatusBarThemeVisualStudio2022, CXTPSwitchViewButtonPart, CXTPSyntaxEditAutoCompleteWnd, CXTPSyntaxEditPaintManager, CXTPSystemMetrics, CXTPTabBase, CXTPTabBaseTheme, CXTPTabBaseThemeOffice2003, CXTPTabBaseThemeOfficeXP, CXTPTabColorSetDefault, CXTPTabColorSetNativeWindows10, CXTPTabColorSetNativeWindows11, CXTPTabColorSetOffice2003, CXTPTabColorSetOffice2007, CXTPTabColorSetOffice2007Access, CXTPTabColorSetOffice2013, CXTPTabColorSetVisualStudio2008, CXTPTabColorSetVisualStudio2010, CXTPTabColorSetVisualStudio2012, CXTPTabColorSetVisualStudio2012Dark, CXTPTabColorSetVisualStudio2015, CXTPTabColorSetVisualStudio2017, CXTPTabColorSetVisualStudio2019, CXTPTabColorSetVisualStudio2022, CXTPTabPaintManager, CXTPTabPaintManagerColorSet, CXTPTabPaintManagerTheme, CXTPTabThemeNativeWindows10, CXTPTabThemeNativeWindows11, CXTPTabThemeOffice2000, CXTPTabThemeOffice2013, CXTPTabThemeVisualStudio2012, CXTPTabThemeVisualStudio2015, CXTPTabThemeVisualStudio2017, CXTPTabThemeVisualStudio2019, CXTPTabThemeVisualStudio2022, CXTPTaskButtonTheme, CXTPTaskPanelExplorerTheme, CXTPTaskPanelExplorerThemePlain, CXTPTaskPanelListViewOffice2003Theme, CXTPTaskPanelListViewOfficeXPTheme, CXTPTaskPanelListViewTheme, CXTPTaskPanelNativeWindows10Theme, CXTPTaskPanelNativeWindows11Theme, CXTPTaskPanelOffice2003Theme, CXTPTaskPanelOffice2003ThemePlain, CXTPTaskPanelOffice2013Theme, CXTPTaskPanelOfficeXPThemePlain, CXTPTaskPanelPaintManager, CXTPTaskPanelPaintManagerPlain, CXTPTaskPanelShortcutBarOffice2003Theme, CXTPTaskPanelShortcutBarOffice2007Theme, CXTPTaskPanelToolboxTheme, CXTPTaskPanelVisualStudio2005Theme, CXTPTaskPanelVisualStudio2010Theme, CXTPTaskPanelVisualStudio2012Theme, CXTPTaskPanelVisualStudio2015Theme, CXTPTaskPanelVisualStudio2017Theme, CXTPTaskPanelVisualStudio2019Theme, CXTPTaskPanelVisualStudio2022Theme, CXTPTrackPaintManager, CXTPTrackThemeNativeWindows10, CXTPTrackThemeNativeWindows11, CXTPTrackThemeOffice2003Luna, CXTPTrackThemeOffice2013, CXTPTrackThemeResource, CXTPTrackThemeVisualStudio2012Blue, CXTPTrackThemeVisualStudio2012Dark, CXTPTrackThemeVisualStudio2012Light, CXTPTrackThemeVisualStudio2015, CXTPTrackThemeVisualStudio2017, CXTPTrackThemeVisualStudio2019, CXTPTrackThemeVisualStudio2022, CXTPTreeOffice2013Theme, CXTPTreeTheme, CXTPTreeVisualStudio2012Theme, CXTPVisualStudio2005Theme, CXTPVisualStudio2008Theme, CXTPVisualStudio2010Theme
  • RefreshQuickAccessList() : CXTPRibbonCustomizeQuickAccessPage
  • RefreshRibbonList() : CXTPRibbonCustomizePage
  • RefreshRowColors() : CXTPShellListBase
  • RefreshScrollBarMetrics() : CXTPScrollBarContainer< Parent >
  • RefreshSettings() : CXTPShellSettings
  • RefreshStandardColors() : CXTPCommandBarsOffice2013Theme
  • RefreshSysButtons() : CXTPMenuBar
  • RefreshTabLabels() : CXTPMDIWndTab
  • RefreshToolBarButtons() : CXTPPropertyGrid
  • RefreshTree() : CXTPDirWatcher
  • RegisterCustomMarkupProperties() : CXTPFlowGraphControl
  • RegisterWindowClass() : CXTPCalendarCaptionBarControl, CXTPCalendarControl, CXTPCaptionPopupWnd, CXTPChartControl, CXTPDatePickerControl, CXTPFlowGraphControl, CXTPGaugeCtrl, CXTPGridControl, CXTPPreviewCtrl, CXTPPropertyGrid, CXTPShortcutBar, CXTPSyntaxEditAutoCompleteWnd, CXTPSyntaxEditCtrl, CXTPSyntaxEditTipWnd, CXTPTagCloudCtrl, CXTPTaskPanel, CXTPTrackControl, CXTPWebBrowserCtrl
  • RelayToolTipEvent() : CXTPGridControl
  • Release() : CXTPActiveScriptObjectContext, CXTPChartDiagram, CXTPChartElement, CXTPChartElementCollection, CXTPChartFillStyle, CXTPChartFont, CXTPChartLineStyle, CXTPChartSeries
  • ReleaseArchive() : CXTPPropExchange, CXTPPropExchangeArchive
  • ReleaseInstance() : CXTPPaintManager
  • ReleaseItem() : CXTPGridControl
  • ReleaseSorted() : CXTPGridControl
  • ReloadConfig() : CXTPSyntaxEditConfigurationManager
  • ReloadConfigAsync() : CXTPSyntaxEditConfigurationManager
  • ReloadFile() : CXTPSyntaxEditColorThemesManager, CXTPSyntaxEditConfigurationManager, CXTPSyntaxEditTextSchemesManager
  • ReloadList() : CXTPCustomizeKeyboardPage
  • ReloadMarkupParts() : CXTPRibbonMarkupFrameTheme
  • ReloadSyntaxConfigFileMode() : CXTPSyntaxEditCtrl
  • ReloadSyntaxStringMode() : CXTPSyntaxEditCtrl
  • Remove() : CXTPCalendarData::EventsMapByID_T< _TObject >, CXTPCalendarPtrCollectionT< _TObject >, CXTPCalendarViewEvents, CXTPChartElementCollection, CXTPCommandBarList, CXTPCommandBars, CXTPControlActions, CXTPControlGalleryItems, CXTPControls, CXTPDatePickerDaysCollection, CXTPFlowGraphConnection, CXTPFlowGraphConnectionPoints, CXTPFlowGraphConnections, CXTPFlowGraphImages, CXTPFlowGraphNode, CXTPFlowGraphNodeGroup, CXTPFlowGraphNodeGroups, CXTPFlowGraphNodes, CXTPFlowGraphPage, CXTPFlowGraphPages, CXTPFlowGraphSelectedElements, CXTPGridColumnOrder, CXTPGridColumns, CXTPGridSelectedRows, CXTPImageList, CXTPPropertyGridInplaceButtons, CXTPPropertyGridItem, CXTPRecentFileList, CXTPRibbonGroup, CXTPRibbonGroups, CXTPRibbonQuickAccessControls, CXTPSkinManager, CXTPStatusBarPane, CXTPTabManagerItem, CXTPTaskPanelItem, CXTPTaskPanelItems, CXTPTrackBlock, CXTPTrackControlItem, CXTPTrackMarker, CXTPTrackMarkers, CXTPTrackSelectedBlocks
  • RemoveAll() : CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE >, CXTPCalendarCustomProperties, CXTPCalendarData::EventsMapByID_T< _TObject >, CXTPCalendarEvents, CXTPCalendarPtrCollectionT< _TObject >, CXTPCalendarRemindersManager, CXTPCalendarResourcesManager, CXTPCalendarTypedPtrAutoDeleteArray< BASE_CLASS, PTR_TYPE >, CXTPCalendarTypedPtrAutoDeleteMap< KEY, TPtr >, CXTPChartElementCollection, CXTPCommandBarList, CXTPCommandBars, CXTPControlActions, CXTPControlGalleryItems, CXTPControls, CXTPFlowGraphConnectionPoints, CXTPFlowGraphConnections, CXTPFlowGraphImages, CXTPFlowGraphNodeGroup, CXTPFlowGraphNodeGroups, CXTPFlowGraphNodes, CXTPFlowGraphPages, CXTPGridHyperlinks, CXTPGridRecord, CXTPGridRecordItemConstraints, CXTPGridRecordItemControls, CXTPGridRecords, CXTPHookManager, CXTPImageManager, CXTPImageManagerIconSet, CXTPImageManagerImageList, CXTPNotifyConnection, CXTPPropertyGridInplaceButtons, CXTPPropertyGridInplaceControls, CXTPPropertyGridItemConstraints, CXTPPropertyGridVerbs, CXTPResourceImages, CXTPRibbonGroup, CXTPRibbonGroups, CXTPShortcutManagerAccelTable, CXTPSkinImages, CXTPSkinManager, CXTPSkinObjectClassMap, CXTPStatusBar, CXTPStatusBarSwitchPane, CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager::CStringPtrArray, CXTPSyntaxEditColorInfoArray, CXTPSyntaxEditColorThemesManager, CXTPSyntaxEditLexTextSchema, CXTPSyntaxEditLineMarksManager, CXTPSyntaxEditTextSchemesManager, CXTPTabManagerNavigateButtons, CXTPTagCloudCtrl, CXTPTagCloudStyleManager, CXTPTrackControlItem, CXTPTrackMarkers, CXTPTrackSelectedBlocks
  • RemoveAllControls() : CXTPResize
  • RemoveAllEvents() : CXTPCalendarData
  • RemoveAllExceptions() : CXTPCalendarRecurrencePattern
  • RemoveAllInternal() : CXTPTagCloudCtrl
  • RemoveAllItems() : CXTPPopupControl, CXTPShortcutBar
  • RemoveAllStrs() : CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager
  • RemoveAllTabs() : CXTPRibbonBar, CXTPTabExBase
  • RemoveAnimationIcons() : CXTPTrayIcon
  • RemoveAt() : CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE >, CXTPCalendarEvents, CXTPCalendarPtrCollectionT< _TObject >, CXTPChartElementCollection, CXTPFlowGraphConnectionPoints, CXTPFlowGraphConnections, CXTPFlowGraphImages, CXTPFlowGraphNodes, CXTPFlowGraphPages, CXTPFlowGraphSelectedElements, CXTPGridColumnOrder, CXTPGridHyperlinks, CXTPGridRecordItemControls, CXTPGridRecords, CXTPGridRows, CXTPPropertyGridInplaceButtons, CXTPPropertyGridItemConstraints, CXTPPropertyGridItems, CXTPRibbonGroup, CXTPShortcutManagerAccelTable, CXTPStatusBar, CXTPTabManagerNavigateButtons, CXTPTaskPanelItems, CXTPTrackControlItem, CXTPTrackMarkers, CXTPTrackSelectedBlocks
  • RemoveButtons() : CXTPGridRecordItemEditOptions, CXTPMessageBar, CXTPPropertySheet
  • RemoveByID() : CXTPCalendarEvents
  • RemoveClass() : CXTPSkinObjectClassMap
  • RemoveClientInterface() : CXTPWebBrowserProvider
  • RemoveColorFilters() : CXTPSkinManager
  • RemoveControl() : CXTPControlAction
  • RemoveCustomScriptItem() : CXTPMarkupContext
  • RemoveDataForEvent() : CXTPCalendarReminders
  • RemoveDataProvider() : CXTPCalendarResourcesManager
  • RemoveDataSource() : CXTPGridDataManager
  • RemoveElement() : CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE >
  • RemoveException() : CXTPCalendarRecurrencePattern
  • RemoveFormatPart() : CXTPCalendarUtils
  • RemoveHook() : CXTPHookManager
  • RemoveHyperlinkAt() : CXTPGridRecordItem
  • RemoveIcon() : CXTPImageManager, CXTPTrayIcon
  • RemoveID() : CXTPCalendarUIntArray
  • RemoveIndicator() : CXTPStatusBar
  • RemoveItem() : CXTPPopupControl, CXTPShortcutBar
  • RemoveKey() : CXTPCalendarTypedPtrAutoDeleteMap< KEY, TPtr >
  • RemoveLine() : CXTPSyntaxEditBufferManager
  • RemoveListener() : CXTPColorSelectorCtrl
  • RemoveListItem() : CXTPTabExBase
  • RemoveMarkupTableRow() : CXTPFlowGraphNode
  • RemoveNode() : CXTPFlowGraphNodeGroup
  • RemoveNonNumeric() : CXTPSortClass
  • RemovePage() : CXTPPropertySheet
  • RemovePane() : CXTPDockingPaneAutoHidePanel, CXTPDockingPaneBase, CXTPDockingPaneMiniWnd, CXTPDockingPaneSplitterContainer
  • RemoveProperty() : CXTPCalendarCustomProperties
  • RemoveRecord() : CXTPGridRecords
  • RemoveRecordEx() : CXTPGridControl
  • RemoveRecurrence() : CXTPCalendarEvent
  • RemoveResize() : CXTPResize
  • RemoveResource() : CXTPCalendarResourcesManager
  • RemoveRow() : CXTPGridRows, CXTPSyntaxEditCtrl
  • RemoveRowColors() : CXTPListBase
  • RemoveRowEx() : CXTPGridControl
  • RemoveSchedule() : CXTPCalendarSchedules
  • RemoveSelected() : CXTPMouseManager
  • RemoveShadow() : CXTPShadowManager
  • RemoveStr() : CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager
  • RemoveStyle() : CXTPTagCloudStyleManager
  • RemoveSwitch() : CXTPStatusBarSwitchPane
  • RemoveTab() : CXTPRibbonBar
  • RemoveTag() : CXTPTagCloudCtrl
  • RemoveTrack() : CXTPMouseManager
  • RemoveTrustedWindow() : CXTPMouseManager
  • RenameConnectionPoint() : CXTPFlowGraphControl
  • RenameItem() : CXTPTaskPanel
  • RenameNode() : CXTPFlowGraphControl
  • Render() : CXTPMarkupVisual
  • RenderClipped() : CXTPMarkupVisual
  • RenderMarkup() : CXTPMarkupThemePart, CXTPRibbonMarkupTheme
  • ReOpen() : CXTPSyntaxEditDoc
  • ReOrder() : CXTPTabManager
  • Replace() : CXTPImageList
  • ReplaceAll() : CXTPSyntaxEditCtrl
  • ReplaceSel() : CXTPSyntaxEditCtrl
  • ReplaceView() : CXTPSplitterWnd
  • ReportError() : CXTPHyperLink
  • Reposition() : CXTPControlGallery, CXTPDockingPaneTabbedContainer, CXTPDockingPaneWindowSelect, CXTPFlowGraphControl, CXTPFlowGraphPage, CXTPPropertyGrid, CXTPRibbonControlTab, CXTPShortcutBar, CXTPTabClientWnd, CXTPTabControl, CXTPTabManagerAtom, CXTPTabManagerItem, CXTPTabManagerNavigateButton, CXTPTabToolBar, CXTPTaskPanel
  • RepositionBars() : CXTPSyntaxEditCtrl
  • RepositionControls() : CXTPControlAction, CXTPRibbonGroup
  • RepositionNavigateButtons() : CXTPTabPaintManager
  • RepositionPanel() : CXTPTaskPanelItem
  • RepositionScrollButtons() : CXTPTaskPanel
  • RepositionTabControl() : CAppearanceSetVisio, CXTPTabPaintManager, CXTPTabPaintManagerTheme
  • RepositionTabControlEx() : CXTPTabPaintManager
  • RepositionTabControlMultiRow() : CXTPTabPaintManager
  • RequiresMouseWheelOverriding() : IXTPScrollable
  • RequiresResourceImages() : CXTPCommandBarsOffice2013Theme, CXTPCommandBarsVisualStudio2012Theme, CXTPPaintManager, CXTPResourceTheme
  • ResampleAlphaLayer() : CXTPImageManager
  • Reset() : CXTPControl, CXTPMenuBar, CXTPPreviewCtrl, CXTPResize, CXTPResourceImages, CXTPRibbonBar, CXTPRibbonQuickAccessControls, CXTPShortcutManager, CXTPSimpleEvent, CXTPTabToolBar, CXTPThemeDLL, CXTPThreadLocal< T >, CXTPToolBar
  • Reset_disp() : CXTPSyntaxEditSelection
  • Reset_str() : CXTPSyntaxEditSelection
  • ResetBackColor() : CXTPComboBoxTheme
  • ResetContent() : CXTPControlComboBox, CXTPGridControl, CXTPGridSection, CXTPPropertyGrid, CXTPPropertyGridView, CXTPTaskDialog
  • ResetCustomTimeFormat() : CXTPCalendarDayViewTimeScale, CXTPCalendarView
  • ResetDate() : CXTPCalendarUtils
  • ResetMarkupUIElement() : CXTPGridColumn, CXTPGridGroupRow, CXTPGridRecordItem
  • ResetMouseOver() : CXTPExcelTabCtrl
  • ResetParent() : CXTPCaptionPopupWnd
  • ResetRecentColors() : CXTPColorSelectorCtrl
  • ResetRowInfo() : CXTPSyntaxEditDrawTextProcessor
  • ResetSavedCameraState() : CXTPChart3dDeviceContext
  • ResetSelection() : CXTPCalendarView
  • ResetSortOrder() : CXTPGridColumns
  • ResetTextColor() : CXTPComboBoxTheme
  • ResetTime() : CXTPCalendarUtils
  • ResetTimeProvider() : CXTPCalendarUtils
  • ResetTodayDateOverride() : CXTPCalendarControl
  • ResetToolTips() : CXTPTabExBase
  • ResetUsageData() : CXTPCommandBars
  • ResetValue() : CXTPPropertyGridItem
  • Resize() : CXTPDockContext
  • ResizeColumn() : CXTPGridHeader
  • ResizeColumnsToFit() : CXTPHeaderCtrl
  • ResizeTabView() : CXTPTabExBase
  • ResolveOverlapping() : CXTPChart3dFunnelSeriesLabelsView, CXTPChart3dPieSeriesLabelsView, CXTPChart3dPyramidSeriesLabelsView, CXTPChartPieSeriesLabelsView, CXTPChartPieSeriesLabelsViewBase
  • ResolveOverlappingColumn() : CXTPChartPieSeriesLabelsView
  • ReSortRows() : CXTPGridControl, CXTPGridSection, CXTPGridSections
  • RestoreAndMinimize() : CXTPWindowList
  • RestoreCommandBarList() : CXTPCommandBar, CXTPControl, CXTPControlPopup, CXTPMenuBar
  • RestoreConnection() : CXTPFlowGraphConnection
  • RestoreCursor() : CXTPSyntaxEditCtrl
  • RestoreDefaultFont() : CXTPHexEdit
  • RestoreDefaults() : CXTPTagCloudCtrl
  • RestoreEventCategoryList() : CXTPCalendarData
  • RestoreEventLabelList() : CXTPCalendarData
  • RestoreRenderTransform() : CXTPMarkupUIElement, CXTPMarkupVisual
  • Resume() : CXTPSkinManager
  • RetrieveDayEvents() : CXTPCalendarData, CXTPCalendarResource, CXTPCalendarResources, CXTPCalendarView
  • RetrieveEvents() : CXTPCalendarMemoryDataProvider
  • RetriveEventEndDate() : CXTPCalendarUtils
  • RGBtoHex() : CXTPColorDialog
  • RGBtoHSL() : CXTPColorBase, CXTPColorPageCustom
  • RGBToString() : CXTPPropertyGridItemColor
  • Rotate() : CXTPChart3dDeviceContext, CXTPMatrix< T >, CXTPOpenGLUtils
  • RotateArcBallToPoint() : CXTPChart3dDiagram
  • Round() : CXTPMathUtils, CXTPPoint2T< T >, CXTPPoint3T< T >, CXTPRectT< T >
  • RoundRect() : CXTPPaintManager
  • RowColFromPoint() : CXTPSyntaxEditCtrl
  • Run() : CXTPActiveScriptEngine
  • RunParse() : CXTPSyntaxEditLexClass
  • RunParseOnScreen() : CXTPSyntaxEditLexTextSchema
  • RunParseUpdate() : CXTPSyntaxEditLexTextSchema
  • RunScriptEngine() : CXTPMarkupContext


Toolkit Pro: Class Members - Functions

Here is a list of all documented functions with links to the class documentation for each member:

- s -

  • SafeClose() : CXTPCalendarData::CXTPDPCache
  • SafeRemoveAll() : CXTPCalendarData::CXTPDPCache
  • Save() : CXTPCalendarData, CXTPCalendarDatabaseDataProvider, CXTPCalendarMemoryDataProvider, CXTPCalendarReminderForOccurrenceArray, CXTPDockingPaneLayout, CXTPMemFile
  • SaveAsImage() : CXTPChartControl
  • SaveBarState() : CXTPCommandBars
  • SaveCfg() : CXTPCalendarResourcesManager
  • SaveColumnWidths() : CXTPListBase
  • SaveCommandBars() : CXTPCommandBarsSiteBase< TBase >
  • SaveHistory() : CXTPSyntaxEditFindReplaceDlg
  • SaveOptions() : CXTPCommandBars
  • SavePlacement() : CXTPPropertySheet, CXTPResize
  • SavePos() : CXTPSyntaxEditGoToLineDlg
  • SaveShortcuts() : CXTPShortcutManager
  • SaveState() : CXTPDockState, CXTPReBar, CXTPShortcutBar, CXTPStatusBar, CXTPTabClientWnd
  • SaveToFile() : CXTPDockingPaneLayout, CXTPFlowGraphControl, CXTPPropExchangeIniFile, CXTPPropExchangeXMLNode
  • SaveToNode() : CXTPDockingPaneLayout
  • SaveToString() : CXTPCalendarUIntArray
  • SaveToXML() : CXTPCalendarCustomProperties
  • SaveWindowPos() : CXTPWindowPos
  • Scale() : CXTPMarkupContext
  • ScalePoint() : CXTPDockState
  • ScaleRectPos() : CXTPDockState
  • ScaleToFit() : CXTPIconHandle, CXTPImageManagerIcon
  • ScaleX() : CXTPMarkupContext
  • ScaleY() : CXTPMarkupContext
  • ScoreExists() : CXTPTagCloudStyleManager
  • ScreenToClient() : CXTPControl
  • ScreenToPage() : CXTPFlowGraphPage
  • ScreenToWorkspace() : CXTPTabClientWnd
  • Scroll() : CXTPSyntaxEditCtrl, CXTPTaskPanelGroup
  • ScrollDaysToNext() : CXTPCalendarDayView
  • ScrollDaysToPrev() : CXTPCalendarDayView
  • ScrollDown() : CXTPDatePickerList
  • ScrollH() : CXTPCalendarDayView, CXTPCalendarTimeLineView, CXTPCalendarView
  • ScrollIcon_ScrollAllDayEventsDown() : CXTPCalendarDayViewGroup
  • ScrollIcon_ScrollAllDayEventsUp() : CXTPCalendarDayViewGroup
  • ScrollLeft() : CXTPDatePickerControl
  • ScrollRight() : CXTPDatePickerControl
  • ScrollToColumn() : CXTPCalendarDayView
  • ScrollToWorkDayBegin() : CXTPCalendarDayView
  • ScrollUp() : CXTPDatePickerList
  • ScrollV() : CXTPCalendarDayView, CXTPCalendarMonthView::CMonthViewGrid, CXTPCalendarMonthView, CXTPCalendarTimeLineView, CXTPCalendarView, CXTPCalendarWeekView
  • ScrollWindow() : CXTPSyntaxEditCtrl
  • ScrollWindowEx() : CXTPSyntaxEditCtrl
  • SearchTree() : CXTPShellTreeBase
  • SeekBegin() : CXTPSyntaxEditTextIterator
  • SeekNext() : CXTPSyntaxEditTextIterator
  • SeekPos() : CXTPSyntaxEditTextIterator
  • SeekPrev() : CXTPSyntaxEditTextIterator
  • SelChanged() : CXTPSyntaxEditTipListBox
  • Select() : CXTPDatePickerControl, CXTPDatePickerDaysCollection, CXTPDockingPane, CXTPDockingPaneWindowSelect, CXTPFlowGraphNode, CXTPGridSelectedRows, CXTPPropertyGridItem, CXTPSyntaxEditCtrl, CXTPTabManagerItem, CXTPTrackBlock
  • SelectAll() : CXTPFlowGraphControl, CXTPSyntaxEditCtrl, CXTPTreeBase
  • SelectAllIgnore() : CXTPTreeBase
  • SelectBlock() : CXTPGridSelectedRows
  • SelectChildren() : CXTPTreeBase
  • SelectChilds() : CXTPGridRow
  • SelectClipRgn() : CColorSetWinNative, CXTPTabPaintManagerColorSet
  • SelectColor() : CXTPColorSelectorCtrl
  • SelectColorCell() : CXTPColorSelectorCtrl
  • SelectConstraint() : CXTPPropertyGridInplaceEdit
  • SelectDay() : CXTPCalendarDayView, CXTPCalendarView
  • SelectDays() : CXTPCalendarView
  • SelectEvent() : CXTPCalendarView
  • SelectEventById() : CXTPCalendarControl
  • SelectionChanged() : CXTPShellTreeBase, CXTPShellTreeCtrl, CXTPShellTreeView
  • SelectionContains() : CXTPCalendarView
  • SelectionEnable() : CXTPGridSection
  • SelectItem() : CXTPShortcutBar, CXTPTreeBase
  • SelectItems() : CXTPTreeBase
  • SelectMDIActive() : CXTPWindowList
  • SelectNextConstraint() : CXTPPropertyGridItem
  • SelectNextTab() : CXTPRibbonBar
  • SelectPane() : CXTPDockingPaneTabbedContainer
  • SelectRange() : CXTPDatePickerDaysCollection
  • SelectUserColor() : CXTPSyntaxEditColorComboBox
  • SelectViewEvent() : CXTPCalendarView
  • SelectViewEventByIdAndGroup() : CXTPCalendarControl
  • SelectWord() : CXTPSyntaxEditCtrl
  • SendCancelMessage() : CXTPCaptionPopupWnd
  • SendCommand() : CXTPEditListBoxToolBar
  • SendEvent() : CXTPNotifyConnection
  • SendInitialUpdate() : CXTPTabExBase
  • SendMessageToParent() : CXTPDatePickerControl, CXTPGridControl, CXTPTrackControl
  • SendNotification() : CXTPCalendarControl, CXTPCalendarData, CXTPCalendarView, CXTPDatePickerControl
  • SendNotificationAlways() : CXTPCalendarControl
  • SendNotify() : CXTPHeaderCtrl, CXTPTreeBase
  • SendNotifyMessage() : CXTPFlowGraphControl, CXTPGridControl, CXTPPropertyGrid, CXTPPropertyGridView
  • SendTrackLost() : CXTPMouseManager
  • Serialize() : CXTPCalendarMemoryDataProvider, CXTPCalendarThemeCustomizableXValueT< _TValue, _TValueRef >, CXTPCalendarThemeFontValue, CXTPCommandBarsOptions, CXTPDockingPaneLayout, CXTPImageManager, CXTPImageManagerIcon, CXTPPaintManagerColor, CXTPPaintManagerColorGradient, CXTPSyntaxEditBufferManager
  • SerializeBarState() : CXTPCommandBars
  • SerializeEx() : CXTPSyntaxEditBufferManager
  • SerializeIcon() : CXTPImageManagerIcon
  • SerializeState() : CXTPGridControl
  • Set() : CXTPCalendarControlViewPrintOptions, CXTPGridThickness, CXTPGridViewPrintOptions, CXTPMatrix< T >, CXTPSimpleEvent, CXTPSyntaxEditTextRegion
  • Set3dRotation() : CXTPChartSeriesStyle
  • SetAccelerators() : CXTPShortcutManager
  • SetAction() : CXTPControl
  • SetActionId() : CXTPControlActions
  • SetActive() : CXTPSyntaxEditCtrl, CXTPTabManager, CXTPTagCloudCtrl
  • SetActivePage() : CXTPFlowGraphControl, CXTPPropertySheet
  • SetActivePane() : CXTPSplitterWnd
  • SetActiveTab() : CXTPRibbonBackstageView
  • SetActiveView() : CXTPCalendarControl, CXTPTabExBase
  • SetActiveWorkspace() : CXTPTabClientWnd
  • SetAdditionalScaleText() : CXTPCalendarDayView
  • SetAdditionalScaleTimeZone() : CXTPCalendarDayView
  • SetAddressBase() : CXTPHexEdit
  • SetAdvancedMode() : CXTPCalendarTip
  • SetAfterCloseActiveTab() : CXTPTabClientWnd
  • SetAlignment() : CXTPChartAxis, CXTPChartAxisConstantLine, CXTPChartAxisTitle, CXTPChartTitle, CXTPGridColumn, CXTPGridRecordItem, CXTPGridRecordItemControl, CXTPPropertyGridInplaceButton
  • SetAlingment() : CXTPHeaderCtrl
  • SetAllCaps() : CXTPCommandBars
  • SetAllDayEvent() : CXTPCalendarEvent
  • SetAllowDeletes() : CXTPHexEdit
  • SetAllowDrag() : CXTPGridColumn
  • SetAllowModifyConnections() : CXTPFlowGraphControl
  • SetAllowMoveNodes() : CXTPFlowGraphControl
  • SetAllowReorder() : CXTPTabClientWnd, CXTPTabManager
  • SetAllowResizeNodes() : CXTPFlowGraphControl
  • SetAlphaDockingContext() : CXTPDockingPaneManager
  • SetAlphaTabClientContext() : CXTPTabClientContext
  • SetAmbientProperty() : CXTPApplication
  • SetAngle() : CXTPChartAxisLabel, CXTPChartPointSeriesLabel, CXTPChartRadarPointSeriesLabel, CXTPMarkupRotateTransform
  • SetAngleX() : CXTPMarkupSkewTransform
  • SetAngleY() : CXTPMarkupSkewTransform
  • SetAnimateDelay() : CXTPPopupControl
  • SetAnimation() : CXTPTaskPanel
  • SetAnimationDelay() : CXTPDockingPaneManager, CXTPFlowGraphControl, CXTPPaintManager
  • SetAnimationIcons() : CXTPTrayIcon
  • SetAntialiasing() : CXTPChart3dDeviceContext, CXTPChartAxisConstantLine, CXTPChartAxisLabel, CXTPChartAxisTitle, CXTPChartFastLineSeriesStyle, CXTPChartLegend, CXTPChartSeriesLabel, CXTPChartTitle
  • SetAppCaption() : CXTPCaption
  • SetAppearance() : CXTPDockingPanePanelPaintManager, CXTPDockingPaneTabPaintManager, CXTPTabManager, CXTPTabPaintManager
  • SetAppearanceSet() : CXTPTabManager, CXTPTabPaintManager
  • SetApplyOptions() : CXTPSkinManager
  • SetArcBallBounds() : CXTPChart3dDiagram
  • SetArgumentScaleType() : CXTPChartSeries
  • SetArgumentValue() : CXTPChartSeriesPoint
  • SetArrangeEditCaption() : CXTPRibbonGroup
  • SetAskItemTextFlags() : CXTPCalendarPaintManager
  • SetAt() : CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE >, CXTPCalendarEvents, CXTPCalendarPtrCollectionT< _TObject >, CXTPCalendarTypedPtrAutoDeleteMap< KEY, TPtr >, CXTPGridRecords, CXTPMatrix< T >
  • SetAtGrow() : CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE >
  • SetAtGrowStr() : CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager
  • SetAttribute() : CXTPSyntaxEditLexClass
  • SetAttributes() : CXTPShellListBase, CXTPShellTreeBase
  • SetAutoApplyNewThreads() : CXTPSkinManager
  • SetAutoApplyNewWindows() : CXTPSkinManager
  • SetAutoCheckItems() : CXTPGridControl
  • SetAutoColor() : CXTPSyntaxEditColorComboBox
  • SetAutoColumnSizing() : CXTPGridHeader
  • SetAutoComplete() : CXTPPropertyGridItem
  • SetAutoCompleteList() : CXTPSyntaxEditCtrl
  • SetAutoCondense() : CXTPTabExBase
  • SetAutoDelete() : CXTPPopupControl
  • SetAutoFont() : CXTPListBase
  • SetAutoIndent() : CXTPSyntaxEditCtrl, CXTPSyntaxEditView
  • SetAutoPopup() : CXTPCalendarRemindersDialog
  • SetAutoRange() : CXTPChartAxisRange
  • SetAutoReload() : CXTPSyntaxEditDoc
  • SetAutoSize() : CXTPDatePickerControl, CXTPGridColumn, CXTPMessageBar
  • SetAutoSortWhenGrouped() : CXTPGridColumn
  • SetAutoTheme() : CXTPTabClientWnd
  • SetAutoVScrollTimerResolution() : CXTPGridControl
  • SetAxisMaxValue() : CXTPChartAxisStrip
  • SetAxisMinValue() : CXTPChartAxisStrip
  • SetAxisValue() : CXTPChartAxisConstantLine, CXTPChartAxisCustomLabel
  • SetBackColor() : CXTPChartSeriesLabel, CXTPComboBox, CXTPComboBoxTheme, CXTPHexEdit, CXTPHyperLink, CXTPMarqueeCtrlPaintManager, CXTPProgressCtrlPaintManager, CXTPSyntaxEditColorSampleText, CXTPSyntaxEditPaintManager, CXTPTagCloudCtrl, CXTPTaskDialogLinkCtrl
  • SetBackground() : CXTPMarkupBorder, CXTPMarkupControl, CXTPMarkupPanel, CXTPMarkupTextBlock
  • SetBackgroundBitmap() : CXTPPopupControl
  • SetBackgroundColor() : CXTPCalendarViewPart, CXTPChartContent, CXTPChartLegend, CXTPGridRecordItem, CXTPPreviewCtrl, CXTPStatusBarPane
  • SetBackImage() : CXTPRibbonOffice2013Theme
  • SetBackstageStyle() : CXTPRibbonBackstageView
  • SetBandInfo() : CXTPReBar
  • SetBandingHit() : CXTPTreeBase
  • SetBarColor() : CXTPMarqueeCtrlPaintManager, CXTPProgressCtrl, CXTPProgressCtrlPaintManager
  • SetBarID() : CXTPCommandBar
  • SetBarInfo() : CXTPToolBar
  • SetBarWidth() : CXTPChartBarSeriesStyle
  • SetBaseEdgeCount() : CXTPChart3dFunnelSeriesStyle, CXTPChart3dPyramidSeriesStyle
  • SetBasePoint() : CXTPChartRotatedTextPainterBase
  • SetBegin() : CXTPArcBall
  • SetBeginDate() : CXTPCalendarMonthView::CMonthViewGrid, CXTPCalendarWeekView
  • SetBeginGroup() : CXTPControl, CXTPStatusBarPane
  • SetBehaviour() : CXTPTaskPanel
  • SetBestFitMode() : CXTPGridColumn
  • SetBitmap() : CXTPButton, CXTPFlowGraphImage, CXTPHeaderCtrl, CXTPHeaderCtrlTheme, CXTPResourceImage, CXTPSkinImage
  • SetBkBaseColor() : CXTPCalendarEventCategory
  • SetBkColor() : CXTPImageList, CXTPPageScroller, CXTPProgressCtrl
  • SetBlendingOptions() : CXTPFrameShadow
  • SetBody() : CXTPCalendarEvent
  • SetBold() : CXTPGridRecordItem, CXTPPopupItem, CXTPTaskPanelGroupItem
  • SetBoldDaysIdleStepTime_ms() : CXTPCalendarController
  • SetBoldDaysOnIdle() : CXTPCalendarController
  • SetBoldDaysPerIdleStep() : CXTPCalendarController
  • SetBoldDaysWithEvents() : CXTPCalendarController
  • SetBookmark() : CXTPGridRecord
  • SetBool() : CXTPPropertyGridItemBool
  • SetBorder() : CXTPPageScroller
  • SetBorderBrush() : CXTPMarkupBorder
  • SetBorderColor() : CXTPCalendarEventCategory, CXTPMarqueeCtrlPaintManager, CXTPProgressCtrl, CXTPProgressCtrlPaintManager, CXTPSyntaxEditColorSampleText, CXTPTagCloudCtrl
  • SetBorderGap() : CXTPButton, CXTPMDIClientWnd, CXTPMDIWndTab
  • SetBorders() : CXTPCalendarCaptionBarControl, CXTPCalendarControl, CXTPColorSelectorCtrl, CXTPControlCustom, CXTPPopupBar
  • SetBorderStyle() : CXTPButton, CXTPDatePickerControl, CXTPPropertyGrid
  • SetBorderThickness() : CXTPMarkupBorder
  • SetBottom() : CXTPGridThickness
  • SetBounds() : CXTPArcBall, CXTPChartDiagram2DAxisView, CXTPChartRadarAxisXView, CXTPChartRadarAxisYView
  • SetBPR() : CXTPHexEdit
  • SetBreakpointBackColor() : CXTPSyntaxEditPaintManager
  • SetBreakpointTextColor() : CXTPSyntaxEditPaintManager
  • SetBrowseStyle() : CXTPBrowseButton
  • SetBuddy() : CXTPButton
  • SetBusyStatus() : CXTPCalendarEvent
  • SetBusyStatusBrush() : CXTPCalendarPaintManager
  • SetButton() : CXTPPopupItem, CXTPStatusBarPane
  • SetButtonElevationRequired() : CXTPTaskDialog
  • SetButtonFont() : CXTPDatePickerPaintManager
  • SetButtonFontIndirect() : CXTPDatePickerPaintManager
  • SetButtonRect() : CXTPDatePickerControl
  • SetButtons() : CXTPCommandBar, CXTPRibbonGroup
  • SetButtonSize() : CXTPCommandBar, CXTPPageScroller
  • SetButtonsVisible() : CXTPDatePickerControl
  • SetButtonText() : CXTPCalendarCaptionBarControl
  • SetButtonTheme() : CXTPEditListBoxToolBar
  • SetCacheMode() : CXTPCalendarData
  • SetCalendar() : CXTPCalendarController
  • SetCalendarCtrl() : CXTPCalendarControlView
  • SetCallback() : CXTPBrowseDialog
  • SetCallbackDayMetrics() : CXTPDatePickerControl
  • SetCallbackMessage() : CXTPTrayIcon
  • SetCanEditCheckboxItem() : CXTPGridRecordItem
  • SetCaption() : CXTPCalendarDayViewTimeScale, CXTPCaptionButton, CXTPControl, CXTPControlAction, CXTPControlGalleryItem, CXTPDatePickerButton, CXTPDialogBar, CXTPFlowGraphConnection, CXTPFlowGraphConnectionPoint, CXTPFlowGraphElement, CXTPFlowGraphNode, CXTPFlowGraphNodeGroup, CXTPFlowGraphPage, CXTPGridColumn, CXTPGridGroupRow, CXTPGridRecordItem, CXTPGridRecordItemControl, CXTPGridRecordItemPreview, CXTPPopupItem, CXTPPropertyGridInplaceButton, CXTPPropertyGridItem, CXTPPropertyPage, CXTPRibbonGroup, CXTPShortcutBarItem, CXTPShortcutBarPane, CXTPShortcutBarPaneItem, CXTPStatusBarPane, CXTPTabManagerItem, CXTPTaskPanelItem, CXTPTrackBlock, CXTPTrackMarker
  • SetCaptionButtonStyle() : CXTPDockingPanePaintManager
  • SetCaptionColor() : CXTPGridRecordItemControl
  • SetCaptionColors() : CXTPCaption
  • SetCaptionDirection() : CXTPDockingPaneManager
  • SetCaptionFont() : CXTPGridPaintManager
  • SetCaptionFontIndirect() : CXTPDockingPanePaintManager, CXTPTaskPanelPaintManager
  • SetCaptionPopup() : CXTPDialogBar
  • SetCaptionPosition() : CXTPFlowGraphNodeCustom
  • SetCaptionVisible() : CXTPDialogBar
  • SetCapture() : CXTPChartContainer, CXTPChartControl
  • SetCaretByPoint() : CXTPSyntaxEditDrawTextProcessor
  • SetCaretPos() : CXTPSyntaxEditDrawTextProcessor
  • SetCaseSensitive() : CXTPGridRecords
  • SetCategory() : CXTPChartNumberFormat, CXTPControl, CXTPControlAction
  • SetCellFormula() : CXTPGridControl
  • SetCellText() : CXTPGridControl
  • SetCenterX() : CXTPMarkupRotateTransform, CXTPMarkupScaleTransform, CXTPMarkupSkewTransform
  • SetCenterY() : CXTPMarkupRotateTransform, CXTPMarkupScaleTransform, CXTPMarkupSkewTransform
  • SetChanged() : CXTPGridControl, CXTPGridSelectedRows
  • SetCharFormat() : CXTPControlFontComboBox
  • SetCheck() : CXTPCalendarCaptionBarThemePart, CXTPCheckListBox
  • SetCheckBoxStyle() : CXTPPropertyGridItemBool, CXTPPropertyGridItemOption
  • SetChecked() : CXTPButton, CXTPControl, CXTPControlAction, CXTPGridRecordItem, CXTPMarkupToggleButton, CXTPStatusBarPane, CXTPStatusBarSwitchPane
  • SetCheckedIcon() : CXTPImageManagerIcon
  • SetCheckedItem() : CXTPControlGallery
  • SetCheckedState() : CXTPGridRecordItem
  • SetCheckStyle() : CXTPCheckListBox
  • SetChild() : CXTPDialogBar, CXTPMarkupDecorator, CXTPPageScroller
  • SetChildWindow() : CXTPCaption
  • SetCilentSite() : CXTPGaugeCtrl
  • SetClientBitmap() : CXTPTaskPanelGroup
  • SetClientInterface() : CXTPWebBrowserProvider
  • SetClientMargin() : CXTPDockingPaneManager
  • SetClientMargins() : CXTPDockingPaneManager
  • SetClientPaneVisible() : CXTPShortcutBar
  • SetClientSite() : CXTPMarkupContext
  • SetClientWindow() : CXTPShortcutBarItem
  • SetClipboard() : CXTPEyeDropper
  • SetClipboardText() : CXTPEyeDropper
  • SetClipOwner() : CXTPFrameShadow
  • SetClipToBounds() : CXTPMarkupFrameworkElement
  • SetClosable() : CXTPTabManagerItem
  • SetCloseable() : CXTPToolBar
  • SetCloseSubMenuOnClick() : CXTPControl
  • SetCloseTags() : CXTPSyntaxEditAutoCompleteWnd
  • SetColHeaderHeight() : CXTPCalendarMonthView::CMonthViewGrid
  • SetCollapsedControlText() : CXTPTaskDialog
  • SetCollapseRect() : CXTPGridRow
  • SetCollapsibleNodes() : CXTPSyntaxEditCtrl
  • SetColor() : CXTPCalendarResource, CXTPChartAxis, CXTPChartAxisStrip, CXTPChartSeriesStyle, CXTPColorLum, CXTPColorManager, CXTPColorPageStandard, CXTPColorPicker, CXTPColorWnd, CXTPControlButtonColor, CXTPControlColorSelector, CXTPControlPopupColor, CXTPDockingPanePanelPaintManager, CXTPDockingPaneTabPaintManager, CXTPFlowGraphConnection, CXTPFlowGraphConnectionPoint, CXTPFlowGraphNode, CXTPFlowGraphNodeCustom, CXTPFrameShadow, CXTPGridHyperlinkStyle, CXTPPropertyGridItemColor, CXTPPropertyGridItemFont, CXTPTabManager, CXTPTabManagerItem, CXTPTabPaintManager, CXTPTrackBlock
  • SetColor2() : CXTPChartAxisStrip
  • SetColorEach() : CXTPChartSeriesStyle
  • SetColors() : CXTPColorManager, CXTPColorPicker, CXTPColorSelectorCtrl, CXTPDockingPanePaintManager, CXTPHyperLink, CXTPMarqueeCtrl, CXTPPaintManager, CXTPShortcutListBox, CXTPTagCloudStyleManager
  • SetColorSet() : CXTPTabManager, CXTPTabPaintManager
  • SetColumn() : CXTPMarkupGrid
  • SetColumnAnchorVerticalPosition() : CXTPChart3dPieSeriesLabelDeviceCommand
  • SetColumnOffice2007CustomThemeBaseColor() : CXTPGridPaintManager
  • SetColumnPlusMinusSign() : CXTPGridPaintManager
  • SetColumns() : CXTPMarkupUniformGrid
  • SetColumnSpan() : CXTPMarkupGrid
  • SetColumnStyle() : CXTPGridPaintManager
  • SetColumnWidth() : CXTPTaskPanel
  • SetColumnWidthWYSIWYG() : CXTPGridPaintManager
  • SetCommandBar() : CXTPControlPopup
  • SetCommandBarData() : CXTPCommandBar
  • SetCommandBarRegion() : CXTPPaintManager, CXTPRibbonTheme
  • SetCommandBars() : CXTPCommandBar, CXTPCommandBarScrollBarCtrl, CXTPControls, CXTPStatusBar, CXTPTabClientWnd
  • SetCommandBarsFontIndirect() : CXTPPaintManager
  • SetCommandText() : CXTPSyntaxEditCommand
  • SetCommandUsed() : CXTPCommandBars
  • SetCommonButtons() : CXTPTaskDialog
  • SetCompactMode() : CXTPPropExchangeXMLNode
  • SetConfigFile() : CXTPSyntaxEditBufferManager, CXTPSyntaxEditCtrl, CXTPSyntaxEditDoc
  • SetConfigurationManager() : CXTPSyntaxEditFileChangesMonitor
  • SetConnectionString() : CXTPCalendarData
  • SetConnectorBendPoint() : CXTPChart3dFunnelSeriesLabelView, CXTPChart3dPieSeriesLabelView, CXTPChart3dPyramidSeriesLabelView
  • SetConnectorEndPoint() : CXTPChart3dFunnelSeriesLabelView, CXTPChart3dPieSeriesLabelView, CXTPChart3dPyramidSeriesLabelView
  • SetConnectorEndpointVerticalOffset() : CXTPChart3dFunnelSeriesLabelDeviceCommand, CXTPChart3dPieSeriesLabelDeviceCommand, CXTPChart3dPyramidSeriesLabelDeviceCommand
  • SetConnectorLength() : CXTPChart3dFunnelSeriesLabelDeviceCommand, CXTPChart3dPyramidSeriesLabelDeviceCommand
  • SetConnectorLengthFactor() : CXTPChart3dPieSeriesLabelDeviceCommand
  • SetConnectorStartPoint() : CXTPChart3dFunnelSeriesLabelView, CXTPChart3dPieSeriesLabelView, CXTPChart3dPyramidSeriesLabelView
  • SetConnectorVisible() : CXTPChart3dFunnelSeriesLabelView, CXTPChart3dPieSeriesLabelView, CXTPChart3dPyramidSeriesLabelView
  • SetConstraintEdit() : CXTPPropertyGridItem
  • SetContent() : CXTPChartControl, CXTPMarkupContentControl, CXTPMarkupPage, CXTPTaskDialog
  • SetContentObject() : CXTPMarkupXtpScript
  • SetContextCaption() : CXTPRibbonTab
  • SetContextColor() : CXTPRibbonTab
  • SetContextMenuEnabled() : CXTPShellExplorerProvider
  • SetContextMenuPresent() : CXTPToolBar
  • SetContextTab() : CXTPRibbonTab
  • SetContextWindow() : CXTPMarkupContext
  • SetControl() : CXTPCalendarPaintManager, CXTPControlCustom, CXTPGridGroupRow, CXTPGridRow
  • SetControlHandle() : CXTPTaskPanelGroupItem
  • SetControlPoint() : CXTPFlowGraphConnection
  • SetControls() : CXTPCommandBar
  • SetControlsCentering() : CXTPRibbonGroup
  • SetControlsGrouping() : CXTPRibbonGroup
  • SetControlSize() : CXTPControlGallery
  • SetControlType() : CXTPControls, CXTPRibbonGroup
  • SetCopyCursor() : CXTPSyntaxEditPaintManager
  • SetCornerRadius() : CXTPMarkupBorder
  • SetCreateScrollbarOnParent() : CXTPSyntaxEditCtrl
  • SetCreationTime() : CXTPCalendarEvent
  • SetCRLFStyle() : CXTPSyntaxEditBufferManager
  • SetCrossAxis() : CXTPChartAxisTickMarks
  • SetCurCaretPos() : CXTPSyntaxEditCtrl
  • SetCurPos() : CXTPSyntaxEditCtrl
  • SetCurrencyFormat() : CXTPGridGroupRow
  • SetCurrencySymbol() : CXTPChartNumberFormat
  • SetCurrent() : CXTPGaugeMeterType, CXTPPropertyGridItemConstraints
  • SetCurrentColor() : CXTPColorDialog
  • SetCurrentDocumentRow() : CXTPSyntaxEditCtrl
  • SetCurrentFocusInFootersRows() : CXTPGridNavigator
  • SetCurrentFocusInHeadersRows() : CXTPGridNavigator
  • SetCurSel() : CXTPColorSelectorCtrl, CXTPControlComboBox, CXTPDatePickerControl, CXTPExcelTabCtrl, CXTPRibbonBar, CXTPTabManager, CXTPTagCloudCtrl
  • SetCustomAnimation() : CXTPAnimationDC
  • SetCustomColors() : CXTPPropertyGrid
  • SetCustomControlKeyboardInteraction() : CXTPMiniToolBar
  • SetCustomFont() : CXTPPaintManagerFont
  • SetCustomIcon() : CXTPControl
  • SetCustomizationDataFileName() : CXTPCommandBars
  • SetCustomizationVisible() : CXTPStatusBarPane
  • SetCustomizeCaption() : CXTPRibbonTab
  • SetCustomizeDialogPresent() : CXTPToolBar
  • SetCustomizeMode() : CXTPCommandBars
  • SetCustomShortcutText() : CXTPControl, CXTPControlAction
  • SetCustomTheme() : CXTPDockingPaneManager, CXTPPaintManager, CXTPPropertyGrid, CXTPShortcutBar, CXTPTaskPanel
  • SetCustomTimeFormat() : CXTPCalendarDayViewTimeScale, CXTPCalendarView
  • SetCustomTitleBrushes() : CXTPDockingPanePaintManager
  • SetCustomTrait() : CXTPGaugeTraits
  • SetCustomValue() : CXTPCalendarThemeCustomizableXValueT< _TValue, _TValueRef >, CXTPCalendarThemeFontValue, CXTPCalendarViewPartCustomizableValueT< _TValue >, CXTPPaintManagerColor, CXTPPaintManagerColorGradient
  • SetDark() : CXTPStatusBarPane
  • SetDashed() : CXTPFlowGraphConnection
  • SetDashStyle() : CXTPChartLineStyle
  • SetData() : CXTPBrowseDialog, CXTPControlGalleryItem, CXTPHexEdit, CXTPTabManagerItem, XTP_CALENDAR_RECURRENCE_OPTIONS
  • SetDataManager() : CXTPSyntaxEditDoc
  • SetDataProvider() : CXTPCalendarControl, CXTPCalendarOptions, CXTPCalendarResource, CXTPCalendarResourcesManager
  • SetDataSource() : CXTPGridDataManager
  • SetDate() : CXTPPropertyGridItemDate
  • SetDateFormat() : CXTPPropertyGridItemDate
  • SetDateLabel() : CXTPCalendarCaptionBarTheme
  • SetDatePicker() : CXTPCalendarController
  • SetDateTime() : CXTPDateEdit
  • SetDateTimeScaleUnit() : CXTPChartAxis
  • SetDay() : CXTPPropertyGridItemDate
  • SetDayDate() : CXTPCalendarViewDay
  • SetDayHeaderFormat() : CXTPCalendarView
  • SetDayHeaderFormatLong() : CXTPCalendarView
  • SetDayHeaderFormatMiddle() : CXTPCalendarView
  • SetDayHeaderFormatShort() : CXTPCalendarView
  • SetDayHeaderFormatShortest() : CXTPCalendarView
  • SetDayInCache() : CXTPCalendarData::CXTPDPCache
  • SetDayOfWeekName() : CXTPDatePickerControl
  • SetDayRect() : CXTPCalendarViewDay
  • SetDecimalPlaces() : CXTPChartNumberFormat
  • SetDefaultAccelerator() : CXTPShortcutManager
  • SetDefaultBlendingOptions() : CXTPFrameShadowManager
  • SetDefaultButton() : CXTPTaskDialog
  • SetDefaultButtonStyle() : CXTPCommandBar
  • SetDefaultClipOwner() : CXTPFrameShadowManager
  • SetDefaultColor() : CXTPColorPicker, CXTPFrameShadowManager
  • SetDefaultFolder() : CXTPSyntaxEditFileChangesMonitor
  • SetDefaultFont() : CXTPMarkupContext
  • SetDefaultFonts() : CXTPTipOfTheDay
  • SetDefaultInnerSize() : CXTPFrameShadowManager
  • SetDefaultItem() : CXTPPopupBar
  • SetDefaultLocation() : CXTPPopupControl
  • SetDefaultMarkup() : CXTPFlowGraphNode, CXTPFlowGraphNodeCustom
  • SetDefaultMenuItem() : CXTPTrayIcon
  • SetDefaultOffset() : CXTPFrameShadowManager
  • SetDefaultOuterSize() : CXTPFrameShadowManager
  • SetDefaultPaneOptions() : CXTPDockingPaneManager
  • SetDefaultRadioButton() : CXTPTaskDialog
  • SetDefaults() : CXTPSyntaxEditPropertiesPageColor
  • SetDefaultSmoothingMode() : CXTPMarkupContext
  • SetDefaultTextColor() : CXTPMarkupContext
  • SetDefaultTextSmoothing() : CXTPMarkupContext
  • SetDefaultTitle() : CXTPTipOfTheDay
  • SetDefaultTransparency() : CXTPFrameShadowManager
  • SetDefaultValue() : CXTPCalendarThemeCustomizableXValueT< _TValue, _TValueRef >, CXTPCalendarViewPartCustomizableValueT< _TValue >, CXTPCalendarViewPartFontValue, CXTPPaintManagerColor, CXTPPropertyGridItem
  • SetDefaultValues() : CXTPCalendarEventCategories, CXTPCalendarEventLabels, CXTPPropertyGridItemMetrics, CXTPTrayIcon
  • SetDelay() : CXTPSyntaxEditToolTipCtrl
  • SetDelayTime() : CXTPToolTipContext
  • SetDelegate() : CXTPMarkupContext
  • SetDelimiters() : CXTPSyntaxEditAutoCompleteWnd
  • SetDepth() : CXTPChart3dPieSeriesStyle
  • SetDescription() : CXTPControl, CXTPControlAction, CXTPControlGalleryItem, CXTPPropertyGridItem
  • SetDescriptionText() : CXTPTrackBlock
  • SetDesiredVisibleAndFullRange() : CXTPDatePickerControl
  • SetDiagram() : CXTPChartSeries
  • SetDirection() : CXTPChartLegend
  • SetDirectionClockwise() : CXTPChartRadarAxisX
  • SetDirty() : CXTPSyntaxEditView
  • SetDisabledBackColor() : CXTPHexEdit
  • SetDisabledHighlightBackColor() : CXTPHexEdit
  • SetDisabledHighlightTextColor() : CXTPHexEdit
  • SetDisabledIcon() : CXTPImageManagerIcon
  • SetDisabledTextColor() : CXTPHexEdit
  • SetDisableReorderColumnsCount() : CXTPGridControl
  • SetDisplayName() : CXTPBrowseDialog
  • SetDividerColor() : CXTPGridSection
  • SetDividerPos() : CXTPPropertyGridView
  • SetDividerPosition() : CXTPGridSection
  • SetDividerStyle() : CXTPGridSection
  • SetDlgDefExt() : CXTPBrowseEdit
  • SetDlgFileName() : CXTPBrowseEdit
  • SetDlgFilter() : CXTPBrowseEdit, CXTPEditListBox
  • SetDlgInitialDir() : CXTPBrowseEdit, CXTPEditListBox
  • SetDlgOpenFile() : CXTPBrowseEdit
  • SetDlgStyle() : CXTPBrowseEdit
  • SetDlgTitle() : CXTPBrowseEdit
  • SetDock() : CXTPMarkupDockPanel
  • SetDockBarClass() : CXTPCommandBars
  • SetDocking() : CXTPChartTitle
  • SetDockingContext() : CXTPDockingPaneManager
  • SetDockingContextStickerStyle() : CXTPDockingPaneManager
  • SetDockingSite() : CXTPDockingPaneBase
  • SetDockState() : CXTPCommandBars
  • SetDocModified() : CXTPSyntaxEditCtrl
  • SetDouble() : CXTPPropertyGridItemDouble
  • SetDoubleGripper() : CXTPPopupBar
  • SetDpiAware() : CXTPMarkupContext
  • SetDpiImageScaling() : CXTPButton
  • SetDragControl() : CXTPCommandBars
  • SetDragCursorImage() : CXTPImageList
  • SetDraggingEvent() : CXTPCalendarView
  • SetDragSensitivityX() : CXTPGridControl
  • SetDragSensitivityY() : CXTPGridControl
  • SetDragText() : CXTPTaskPanelGroupItem
  • SetDrawDisabledText() : CXTPStatusBar
  • SetDrawFooterDivider() : CXTPGridColumn
  • SetDrawFooterRowsVGrid() : CXTPGridColumn
  • SetDrawGridForEmptySpace() : CXTPGridPaintManager
  • SetDrawHeaderDivider() : CXTPGridColumn
  • SetDrawHeaderRowsVGrid() : CXTPGridColumn
  • SetDrawStyle() : CXTPHeaderCtrlTheme
  • SetDropDownItemCount() : CXTPControlComboBox, CXTPPropertyGridItem
  • SetDropDownListStyle() : CXTPControlComboBox
  • SetDropDownWidth() : CXTPControlComboBox
  • SetDropListItemNumber() : CXTPGridInplaceButton, CXTPGridInplaceList
  • SetDropMarkerFlags() : CXTPGridControl
  • SetDropPos() : CXTPSyntaxEditCtrl
  • SetDuration() : CXTPCalendarEvent
  • SetDurationMinutes() : CXTPCalendarRecurrencePattern
  • SetEditable() : CXTPGridColumn, CXTPGridRecord, CXTPGridRecordItem
  • SetEditCtrl() : CXTPSyntaxEditView
  • SetEditHint() : CXTPControlAction, CXTPControlComboBox, CXTPControlEdit
  • SetEditIconId() : CXTPControlComboBox, CXTPControlEdit
  • SetEditMask() : CXTPEdit, CXTPMaskEditT< TBase >
  • SetEditorStyle() : CXTPPropertyGridItemColor
  • SetEditStyle() : CXTPControlComboBox, CXTPControlEdit, CXTPPropertyGridItem
  • SetEditText() : CXTPControlComboBox, CXTPControlEdit, CXTPEditListBox, CXTPPropertyGridItem
  • SetEmpty() : CXTPRectT< T >
  • SetEnable() : CXTPGridRecordItemControl
  • SetEnableButtons() : CXTPWindowList
  • SetEnabled() : CXTPChartDeviceCommand, CXTPControl, CXTPControlAction, CXTPControlGalleryItem, CXTPDockingPane, CXTPPropertyGridInplaceButton, CXTPShortcutBarItem, CXTPStatusBarPane, CXTPTabManagerItem, CXTPTaskPanelItem
  • SetEncoding() : CXTPPropExchangeXMLNode
  • SetEnd() : CXTPArcBall
  • SetEnd_disp() : CXTPSyntaxEditSelection
  • SetEnd_str() : CXTPSyntaxEditSelection
  • SetEndAfterOccurrences() : CXTPCalendarRecurrencePattern
  • SetEndTime() : CXTPCalendarEvent
  • SetEnum() : CXTPPropertyGridItemEnum
  • SetEnumFlags() : CXTPShellListBase, CXTPShellTreeBase
  • SetEqualHeight() : CXTPChartFunnelSeriesStyleBase
  • SetErrorBar() : CXTPChartSeriesStyle
  • SetEvent() : CXTPCalendarOccurSeriesChooseDlg, CXTPCalendarReminder
  • SetEventID() : CXTPCalendarEvent
  • SetEventPlaceCount() : CXTPCalendarDayViewEvent
  • SetEventPlacePos() : CXTPCalendarDayViewEvent
  • SetEventSink() : CXTPWebBrowserCtrl
  • SetEventVisible() : CXTPCalendarEvent
  • SetException() : CXTPCalendarRecurrencePattern
  • SetExecuteOnPressInterval() : CXTPControl
  • SetExpandable() : CXTPPropertyGridItem, CXTPShortcutBarPaneItem, CXTPTaskPanel, CXTPTaskPanelGroup
  • SetExpandButton() : CXTPCalendarCaptionBarTheme
  • SetExpandButtonCheck() : CXTPCalendarCaptionBarTheme
  • SetExpandDown() : CXTPCalendarDayViewGroup
  • SetExpanded() : CXTPControl, CXTPGridColumn, CXTPGridRecord, CXTPGridRow, CXTPShortcutBarPaneItem, CXTPTaskPanelGroup
  • SetExpandedControlText() : CXTPTaskDialog
  • SetExpandedInformation() : CXTPTaskDialog
  • SetExpandedLinesCount() : CXTPShortcutBar
  • SetExpandedLinesHeight() : CXTPShortcutBar
  • SetExpandUp() : CXTPCalendarDayViewGroup
  • SetExplodedDistancePercent() : CXTPChartPieSeriesStyleBase
  • SetExplorerStyle() : CXTPShellListBase, CXTPShellTreeBase
  • SetExplorerTheme() : CXTPTreeBase
  • SetExtendedStyle() : CXTPListBase
  • SetExternal() : CXTPWebBrowserCtrl
  • SetFailed() : CXTPChart3dFunnelSeriesLabelDeviceCommand, CXTPChart3dPieSeriesLabelDeviceCommand, CXTPChart3dPyramidSeriesLabelDeviceCommand
  • SetFailedMessage() : CXTPPreviewCtrl
  • SetFastDeselectMode() : CXTPGridControl
  • SetFileDialog() : CXTPBrowseEdit
  • SetFileExt() : CXTPSyntaxEditBufferManager
  • SetFillAcrossXAxis() : CXTPChartAreaSeriesStyle
  • SetFillMode() : CXTPChartFillStyle
  • SetFilterable() : CXTPGridColumn
  • SetFilterEditCtrl() : CXTPGridHeader
  • SetFilterHiddenColumns() : CXTPGridControl
  • SetFilterText() : CXTPGridControl
  • SetFirstColumn() : CXTPMarkupUniformGrid
  • SetFirstDayOfWeek() : CXTPCalendarControl, CXTPDatePickerControl
  • SetFirstDayOfWeekToDatePicker() : CXTPCalendarController
  • SetFirstWeekOfYearDays() : CXTPCalendarControl, CXTPDatePickerControl
  • SetFixed() : CXTPGridColumn
  • SetFixedRowHeight() : CXTPGridPaintManager
  • SetFlag() : CXTPResize
  • SetFlags() : CXTPCommandBar, CXTPControl, CXTPFrameShadowManager, CXTPGridRecordItemControl, CXTPPropertyGridItem, CXTPPropertyGridItemFlags, CXTPTabClientWnd, CXTPTabManagerNavigateButton
  • SetFlatStyle() : CXTPButton, CXTPComboBox, CXTPEdit, CXTPEditTheme, CXTPProgressCtrl
  • SetFloatingFrameCaption() : CXTPDockingPaneManager
  • SetFloatingFramesOpacity() : CXTPDockingPaneManager
  • SetFocus() : CXTPDockingPane
  • SetFocusable() : CXTPGridRecordItem
  • SetFocused() : CXTPControl, CXTPControlComboBox, CXTPControlEdit, CXTPRibbonControlTab
  • SetFocusedColumn() : CXTPGridControl
  • SetFocusedControl() : CXTPRibbonBackstageView
  • SetFocusedItem() : CXTPTabControl, CXTPTabManager, CXTPTaskPanel
  • SetFocusedRow() : CXTPGridControl
  • SetFocusedRowIndex() : CXTPGridRows
  • SetFocusToInplaceControl() : CXTPPropertyGridItem
  • SetFolderData() : CXTPDirWatcher
  • SetFolderPath() : CXTPDirWatcher
  • SetFont() : CXTPCalendarTip, CXTPChartAxisConstantLine, CXTPChartAxisLabel, CXTPChartAxisTitle, CXTPChartLegend, CXTPChartSeriesLabel, CXTPChartTitle, CXTPGridInplaceEdit, CXTPGridRecordItem, CXTPGridRecordItemControl, CXTPGridTip, CXTPPopupPaintManager, CXTPPropertyGrid, CXTPPropertyGridItemFont, CXTPStatusBar, CXTPSyntaxEditPaintManager, CXTPTagCloudStyle, CXTPTagCloudStyleManager, CXTPToolTipContext, XTP_DAYITEM_METRICS
  • SetFontBold() : CXTPHeaderCtrl
  • SetFontCharset() : CXTPResourceManager
  • SetFontFamily() : CXTPMarkupTextBlock
  • SetFontHeight() : CXTPCommandBars, CXTPRibbonBar, CXTPRibbonPaintManager
  • SetFontIndirect() : CXTPDatePickerPaintManager, CXTPSyntaxEditCtrl, CXTPSyntaxEditView, CXTPTabPaintManager, CXTPToolTipContext
  • SetFontLineNumber() : CXTPSyntaxEditPaintManager
  • SetFontSize() : CXTPMarkupTextBlock
  • SetFontStyle() : CXTPMarkupTextBlock
  • SetFontText() : CXTPSyntaxEditPaintManager
  • SetFontToolTip() : CXTPSyntaxEditPaintManager
  • SetFontWeight() : CXTPMarkupTextBlock
  • SetFooter() : CXTPTaskDialog
  • SetFooterAlignment() : CXTPGridColumn
  • SetFooterFont() : CXTPGridColumn
  • SetFooterIcon() : CXTPTaskDialog
  • SetFooterText() : CXTPGridColumn
  • SetForceExpanded() : CXTPMouseManager
  • SetForeground() : CXTPMarkupControl, CXTPMarkupTextBlock
  • SetForegroundColor() : CXTPPreviewCtrl
  • SetFormat() : CXTPChartAxisLabel, CXTPChartSeriesLabel
  • SetFormatString() : CXTPGridGroupRow, CXTPGridRecordItem
  • SetFormula() : CXTPGridGroupRow, CXTPGridRecordItem
  • SetFrameHook() : CXTPCommandBars
  • SetFreeHeight() : CXTPGridRecord
  • SetFreezeColsDividerStyle() : CXTPGridPaintManager
  • SetFreezeColumnsCount() : CXTPGridControl
  • SetFromCOLORREF() : CXTPChartColor
  • SetFromString() : CXTPChart3dRotation, CXTPChartColor
  • SetFrozen() : CXTPGridColumn
  • SetFullColumnScrolling() : CXTPGridControl
  • SetFullExpanded() : CXTPGridRow
  • SetGap() : CXTPBrowseEdit
  • SetGetSysColorPtr() : CXTPColorManager
  • SetGlobalBlendingOptions() : CXTPFrameShadowManager
  • SetGlobalClipOwner() : CXTPFrameShadowManager
  • SetGlobalColor() : CXTPFrameShadowManager
  • SetGlobalFont() : CXTPAuxData
  • SetGlobalInnerSize() : CXTPFrameShadowManager
  • SetGlobalOffset() : CXTPFrameShadowManager
  • SetGlobalOuterSize() : CXTPFrameShadowManager
  • SetGlobalPaintManager() : CXTPPaintManager
  • SetGlobalTransparency() : CXTPFrameShadowManager
  • SetGrabFocus() : CXTPCommandBar
  • SetGradientAngle() : CXTPChartFillStyle
  • SetGridColor() : CXTPGridControl
  • SetGridControl() : CXTPGridPaintManager, CXTPGridRecordItem
  • SetGridCtrl() : CXTPGridFilterEditControl, CXTPGridSubListControl, CXTPGridView
  • SetGridDimentions() : CXTPDatePickerControl
  • SetGridHeader() : CXTPGridControl
  • SetGridSize() : CXTPDatePickerControl
  • SetGridSpacing() : CXTPChartAxis
  • SetGridSpacingAuto() : CXTPChartAxis
  • SetGridStyle() : CXTPGridControl
  • SetGripperPosition() : CXTPExcelTabCtrl
  • SetGroupable() : CXTPGridColumn
  • SetGroupCaption() : CXTPGridRecordItem
  • SetGroupIconSize() : CXTPTaskPanel
  • SetGroupImageList() : CXTPTaskPanel
  • SetGroupInsertMode() : CXTPSyntaxEditUndoRedoManager
  • SetGroupPriority() : CXTPGridRecordItem
  • SetGroupRowsBold() : CXTPGridControl
  • SetGroupsHeight() : CXTPRibbonBar
  • SetGroupsVisible() : CXTPRibbonBar
  • SetHandCursor() : CXTPPopupItem
  • SetHandle() : CXTPResourceImages, CXTPTabManagerItem, CXTPThemeDLL
  • SetHandleOwnershipNotGuaranteed() : CXTPGdiObject
  • SetHatchStyle() : CXTPChartFillStyle
  • SetHeaderAlignment() : CXTPGridColumn
  • SetHeaderHeight() : CXTPGridPaintManager
  • SetHeaderOffset() : CXTPTabManager
  • SetHeight() : CXTPControl, CXTPGridRecordItemControl, CXTPGridSection, CXTPMarkupFrameworkElement, CXTPMarkupRowDefinition, CXTPMessageBar, CXTPPropertyGridItem, CXTPShortcutBarPaneItem
  • SetHeightMode() : CXTPGridSection
  • SetHeightPercent() : CXTPTrackBlock
  • SetHeightToWidthRatio() : CXTPChartFunnelSeriesStyleBase, CXTPChartPyramidSeriesStyleBase
  • SetHelpHeight() : CXTPPropertyGrid
  • SetHelpID() : CXTPDockingPane
  • SetHelpId() : CXTPControl, CXTPControlAction
  • SetHexFont() : CXTPHexEdit
  • SetHidden() : CXTPPropertyGridItem
  • SetHideCaret() : CXTPSyntaxEditCtrl
  • SetHideFlag() : CXTPControl
  • SetHideFlags() : CXTPControl, CXTPControlComboBox, CXTPControlCustom, CXTPControlEdit
  • SetHideWrap() : CXTPControl
  • SetHighlightBackColor() : CXTPHexEdit
  • SetHighlightCursor() : CXTPShortcutListBox
  • SetHighlighted() : CXTPComboBox
  • SetHighlightTextColor() : CXTPHexEdit
  • SetHighlightToday() : CXTPDatePickerControl
  • SetHiliteBackColor() : CXTPSyntaxEditPaintManager
  • SetHiliteTextColor() : CXTPSyntaxEditPaintManager
  • SetHint() : CXTPGridFilterEditControl
  • SetHolePercent() : CXTPChartPieSeriesStyleBase
  • SetHook() : CXTPHookManager, CXTPSkinManager
  • SetHorizontalAlignment() : CXTPChartLegend, CXTPMarkupFrameworkElement
  • SetHotDivider() : CXTPGridHeader
  • SetHotIcon() : CXTPImageManagerIcon
  • SetHotItem() : CXTPShortcutBar, CXTPTaskPanel
  • SetHotTrackStyle() : CXTPTaskPanel
  • SetHours() : CXTPTimeEdit
  • SetHoverRect() : CXTPCalendarTip, CXTPGridTip, CXTPSyntaxEditToolTipCtrl
  • SetHScrollStep() : CXTPGridControl
  • SetHue() : CXTPColorWnd
  • SetHyperLink() : CXTPPopupItem
  • SetHyperlink() : CXTPPropertyGridInplaceButton
  • SetIcon() : CXTPButton, CXTPDockingPaneManager, CXTPFlowGraphImage, CXTPFramePaintManager, CXTPImageEditorDlg, CXTPImageManager, CXTPImageManagerIcon, CXTPPopupItem, CXTPTrayIcon
  • SetIconColumn() : CXTPGridControl
  • SetIconFromIcoFile() : CXTPImageManager
  • SetIconFromResource() : CXTPImageManager
  • SetIconID() : CXTPDockingPane, CXTPGridColumn
  • SetIconId() : CXTPControl, CXTPControlAction, CXTPRibbonGroup, CXTPShortcutBarItem
  • SetIconIndent() : CXTPTreeBase
  • SetIconIndex() : CXTPGridInplaceButton, CXTPGridRecordItem, CXTPGridRecordItemControl, CXTPPopupItem, CXTPPropertyGridInplaceButton, CXTPStatusBarPane, CXTPTaskPanelItem
  • SetIcons() : CXTPDockingPaneManager, CXTPImageManager, CXTPPopupItem
  • SetIconSize() : CXTPCommandBar, CXTPControl, CXTPImageEditorDlg, CXTPTaskPanel, CXTPTaskPanelGroup
  • SetIconView() : CXTPGridControl
  • SetIconViewToDefaults() : CXTPGridControl
  • SetID() : CXTPCalendarEventCategory, CXTPCalendarSchedule, CXTPControl, CXTPControlGalleryItem, CXTPDockingPane, CXTPFlowGraphConnectionPoint, CXTPFlowGraphNode, CXTPFlowGraphPage, CXTPPopupItem, CXTPPropertyGridItem, CXTPRibbonGroup, CXTPRibbonTab, CXTPShortcutBarItem, CXTPTaskPanelItem
  • SetIdentity() : CXTPMatrix< T >
  • SetImageAlignment() : CXTPButton
  • SetImageColorKey() : CXTPMarkupContext
  • SetImageCount() : CXTPImageList
  • SetImageGap() : CXTPButton
  • SetImageHandle() : CXTPPaintManager, CXTPResourceTheme
  • SetImageIndex() : CXTPControlGalleryItem, CXTPFlowGraphConnectionPoint, CXTPFlowGraphNode, CXTPTabManagerItem
  • SetImageList() : CXTPGridControl, CXTPImageManager, CXTPTabControl, CXTPTaskPanel
  • SetImageManager() : CXTPCommandBar, CXTPCommandBars, CXTPControlGalleryItems, CXTPDockingPaneManager, CXTPGridControl, CXTPHeaderCtrl, CXTPMarkupContext, CXTPPasswordPeek, CXTPPopupControl, CXTPPropertyGrid, CXTPShortcutBar, CXTPTabControl, CXTPTaskPanel
  • SetImages() : CXTPResourceTheme
  • SetImageWidth() : CXTPControlGalleryItem
  • SetImportance() : CXTPCalendarEvent
  • SetInactiveHiliteBackColor() : CXTPSyntaxEditPaintManager
  • SetInactiveHiliteTextColor() : CXTPSyntaxEditPaintManager
  • SetIncludeExtensions() : CXTPShellListBase
  • SetIndent() : CXTPChartTitle, CXTPShortcutBarPane
  • SetIndex() : CXTPChartAxis, CXTPControl, CXTPGridRow
  • SetIndicators() : CXTPStatusBar
  • SetInfo() : CXTPExcelTabCtrlButtonState
  • SetIniData() : CXTPResourceImages
  • SetINIFileName() : CXTPRegistryManager
  • SetInnerSize() : CXTPFrameShadow
  • SetInplaceButtonHeight() : CXTPGridPaintManager
  • SetInplaceEdit() : CXTPPropertyGrid
  • SetInplaceList() : CXTPPropertyGrid
  • SetInputBoxText() : CXTPTaskDialog
  • SetInputPoint() : CXTPFlowGraphConnection
  • SetInsertMark() : CXTPTreeBase
  • SetInsertMarkColor() : CXTPTreeBase
  • SetInsideCellButton() : CXTPGridInplaceButton
  • SetInterlaced() : CXTPChartAxis
  • SetInterlacedColor() : CXTPChartAxis
  • SetInterlacedColor2() : CXTPChartAxis
  • SetInternalArgumentValue() : CXTPChartSeriesPoint
  • SetInternalName() : CXTPGridColumn
  • SetInvertedStep() : CXTPChartStepLineSeriesStyle
  • SetItemArgs() : CXTPGridInplaceControl, CXTPGridInplaceList
  • SetItemBackColor() : CXTPTreeBase
  • SetItemBold() : CXTPTreeBase
  • SetItemColor() : CXTPCalendarEventColorListBox, CXTPDockingPane, CXTPTreeBase
  • SetItemData() : CXTPControlComboBox, CXTPGridRecordItem, CXTPPropertyGridItem, CXTPShortcutBarItem, CXTPTaskPanelItem
  • SetItemDefault() : CXTPControl
  • SetItemFont() : CXTPTaskPanelItem, CXTPTreeBase
  • SetItemIndex() : CXTPGridColumn
  • SetItemLayout() : CXTPTaskPanel, CXTPTaskPanelGroup
  • SetItemMetrics() : CXTPTabManager
  • SetItemRect() : CXTPTaskPanelGroupItem
  • SetItems() : CXTPControlGallery
  • SetItemsActive() : CXTPControlSelector
  • SetItemsBorderHeight() : CXTPPropertyGridPaintManager
  • SetItemSelected() : CXTPTaskPanelGroupItem
  • SetItemsFontIndirect() : CXTPTaskPanelPaintManager
  • SetItemSize() : CXTPControlGalleryItems, CXTPShortcutBar
  • SetItemsMargin() : CXTPControlGallery
  • SetItemState() : CXTPTreeBase
  • SetItemText() : CXTPExcelTabCtrl
  • SetKey() : CXTPControlAction
  • SetKeyboardTip() : CXTPControl, CXTPControlAction, CXTPRibbonTab
  • SetKeyboardWindowSelectClass() : CXTPDockingPaneManager
  • SetKeyNameText() : CXTPShortcutManager
  • SetLabel() : CXTPChartSeriesStyle
  • SetLabelAnchorOrigin() : CXTPChart3dFunnelSeriesLabelView, CXTPChart3dPieSeriesLabelView, CXTPChart3dPyramidSeriesLabelView
  • SetLabelAnchorPoint() : CXTPChart3dFunnelSeriesLabelView, CXTPChart3dPieSeriesLabelView, CXTPChart3dPyramidSeriesLabelView
  • SetLabelID() : CXTPCalendarEvent, CXTPCalendarEventLabelComboBox
  • SetLabelList() : CXTPCalendarData
  • SetLabelRect() : CXTPChart3dFunnelSeriesLabelDeviceCommand, CXTPChart3dPieSeriesLabelDeviceCommand, CXTPChart3dPyramidSeriesLabelDeviceCommand
  • SetLabelText() : CXTPChartSeriesPoint, CXTPSearchOptionsCtrl
  • SetLabelWidth() : CXTPControlComboBox, CXTPControlEdit
  • SetLastChildFill() : CXTPMarkupDockPanel
  • SetLastColumnExpand() : CXTPGridHeader
  • SetLastColumnWidthWYSIWYG() : CXTPGridPaintManager
  • SetLastCommandText() : CXTPSyntaxEditUndoRedoManager
  • SetLastModificationTime() : CXTPCalendarEvent
  • SetLastRqstEdit() : CXTPGridControl
  • SetLastVisibleRect() : CXTPCalendarTimeLineViewEvent
  • SetLayeredWindowAttributes() : CXTPPopupControl
  • SetLayout() : CXTPDockingPaneManager, CXTPTabPaintManager
  • SetLayoutRTL() : CXTPCalendarControl, CXTPCommandBars, CXTPDatePickerControl, CXTPGridControl, CXTPPopupControl, CXTPPropertyGrid, CXTPShortcutBar, CXTPTabClientWnd, CXTPTaskPanel
  • SetLayoutStyle() : CXTPTabManager
  • SetLeft() : CXTPGridThickness, CXTPMarkupThickness
  • SetLeftDirected() : CXTPChart3dFunnelSeriesLabelView, CXTPChart3dPieSeriesLabelView, CXTPChart3dPyramidSeriesLabelView
  • SetLegendName() : CXTPChartAxisConstantLine, CXTPChartAxisStrip
  • SetLegendText() : CXTPChartSeries, CXTPChartSeriesPoint
  • SetLegendVisible() : CXTPChartAxisConstantLine, CXTPChartAxisStrip, CXTPChartSeries
  • SetLength() : CXTPChartAxisTickMarks, CXTPTrackBlock
  • SetLexConfigurationManager() : CXTPSyntaxEditBufferManager
  • SetLightAmbientColor() : CXTPChart3dDeviceContext
  • SetLightDiffuseColor() : CXTPChart3dDeviceContext
  • SetLightModelAmbientColor() : CXTPChart3dDeviceContext
  • SetLightPosition() : CXTPChart3dDeviceContext
  • SetLightSpecularColor() : CXTPChart3dDeviceContext
  • SetLineColor() : CXTPChartSeriesLabel
  • SetLineLength() : CXTPChartSeriesLabel
  • SetLineMark() : CXTPSyntaxEditLineMarksManager
  • SetLineNumberBackColor() : CXTPSyntaxEditPaintManager
  • SetLineNumbers() : CXTPSyntaxEditCtrl, CXTPSyntaxEditView
  • SetLineNumberTextColor() : CXTPSyntaxEditPaintManager
  • SetLineSelCursor() : CXTPSyntaxEditPaintManager
  • SetLinesMinMax() : CXTPControlListBox
  • SetLineSpace() : CXTPTipWindow
  • SetLineThickness() : CXTPChartHighLowSeriesStyle
  • SetLinkCursor() : CXTPHyperLink
  • SetList() : CXTPSyntaxEditAutoCompleteWnd
  • SetListBackColor() : CXTPListBase
  • SetListEditStyle() : CXTPEditListBox
  • SetListIconId() : CXTPControlComboBox
  • SetListStyle() : CXTPFontComboBox, CXTPFontListBox, CXTPListBox
  • SetListTextColor() : CXTPListBase
  • SetLoading() : CXTPPropExchangeXMLNode
  • SetLoadingMessage() : CXTPPreviewCtrl
  • SetLocale() : CXTPChartNumberFormat
  • SetLocation() : CXTPCalendarEvent, CXTPFlowGraphNode
  • SetLocked() : CXTPFlowGraphConnectionPoint, CXTPFlowGraphNode, CXTPGridRecord, CXTPTrackBlock, CXTPTrackControlItem
  • SetLockRedraw() : CXTPTabControl, CXTPTaskPanel
  • SetLogarithmic() : CXTPChartAxis
  • SetLogarithmicBase() : CXTPChartAxis
  • SetLogFont() : CXTPChartFont
  • SetLongDayHeaderFormat() : CXTPCalendarControl, CXTPCalendarMonthView
  • SetLuminance() : CXTPColorLum
  • SetLunaTheme() : CXTPColorManager, CXTPDockingPanePaintManager, CXTPPaintManager
  • SetMainIcon() : CXTPTaskDialog
  • SetMainInstruction() : CXTPTaskDialog
  • SetMargin() : CXTPMarkupFrameworkElement, CXTPTagCloudCtrl, CXTPToolTipContext
  • SetMargins() : CXTPStatusBarPane, CXTPTaskPanel, CXTPTipWindow
  • SetMarkerSize() : CXTPChartLegend
  • SetMarkerVisible() : CXTPChartLegend
  • SetMarkupContext() : CXTPGridRecords, CXTPGridSection, CXTPGridSections
  • SetMarkupTemplate() : CXTPPropertyGridItem
  • SetMarkupText() : CXTPFlowGraphNode, CXTPPopupItem
  • SetMarquee() : CXTPMarqueeCtrl, CXTPProgressCtrl
  • SetMarqueeProgressBar() : CXTPTaskDialog
  • SetMask() : CXTPGridColumn, CXTPPropertyGridItem
  • SetMaskColor() : CXTPImageManager
  • SetMaskedText() : CXTPMaskEditT< TBase >, CXTPPropertyGridItem
  • SetMasterEventID() : CXTPCalendarRecurrencePattern
  • SetMaterialDiffuseColor() : CXTPChart3dDeviceContext
  • SetMaterialEmissionColor() : CXTPChart3dDeviceContext
  • SetMaterialShininess() : CXTPChart3dDeviceContext
  • SetMaterialSpecularColor() : CXTPChart3dDeviceContext
  • SetMax() : CXTPGaugeMeterType, CXTPPropertyGridInplaceSlider, CXTPPropertyGridInplaceSpinButton
  • SetMaxColumnWidth() : CXTPGridHeader
  • SetMaxConnections() : CXTPFlowGraphConnectionPoint
  • SetMaxHeight() : CXTPMarkupFrameworkElement, CXTPMarkupRowDefinition
  • SetMaxLength() : CXTPTrackBlock
  • SetMaxPreviewLines() : CXTPGridPaintManager
  • SetMaxSelCount() : CXTPDatePickerControl
  • SetMaxSize() : CXTPChartBubbleSeriesStyle, CXTPResize
  • SetMaxTipWidth() : CXTPToolTipContext
  • SetMaxTrackSize() : CXTPDockingPane
  • SetMaxValue() : CXTPChartAxisRange
  • SetMaxWidth() : CXTPGridColumn, CXTPMarkupColumnDefinition, CXTPMarkupFrameworkElement
  • SetMeeting() : CXTPCalendarEvent
  • SetMenu() : CXTPCommandBars
  • SetMenuBarClass() : CXTPCommandBars
  • SetMenuID() : CXTPHeaderCtrl, CXTPMDIWndTab, CXTPTabExBase
  • SetMenuTitleBar() : CXTPCommandBars
  • SetMenuTitleBarClass() : CXTPCommandBars
  • SetMergeHeight() : CXTPGridRow
  • SetMessage() : CXTPMessageBar
  • SetMilitary() : CXTPTimeEdit
  • SetMin() : CXTPGaugeMeterType, CXTPPropertyGridInplaceSlider, CXTPPropertyGridInplaceSpinButton
  • SetMinColumnWidth() : CXTPCalendarDayView
  • SetMinHeight() : CXTPMarkupFrameworkElement, CXTPMarkupRowDefinition
  • SetMinimumClientHeight() : CXTPShortcutBar, CXTPShortcutBarPane, CXTPTaskPanelGroup
  • SetMinimumColSize() : CXTPListBase
  • SetMinimumGroupClientHeight() : CXTPTaskPanel
  • SetMinimumVisibleSize() : CXTPRibbonBar
  • SetMinimumVisibleWidth() : CXTPRibbonBar
  • SetMinimumWidth() : CXTPTabToolBar
  • SetMinLength() : CXTPTrackBlock
  • SetMinorCount() : CXTPChartAxis
  • SetMinorLength() : CXTPChartAxisTickMarks
  • SetMinorThickness() : CXTPChartAxisTickMarks
  • SetMinorVisible() : CXTPChartAxisGridLines, CXTPChartAxisTickMarks
  • SetMins() : CXTPTimeEdit
  • SetMinSize() : CXTPChartBubbleSeriesStyle, CXTPFlowGraphNode, CXTPHeaderCtrl, CXTPResize
  • SetMinTrackSize() : CXTPDockingPane
  • SetMinValue() : CXTPChartAxisRange
  • SetMinWidth() : CXTPGridColumn, CXTPMarkupColumnDefinition, CXTPMarkupFrameworkElement
  • SetModelDistanceLimits() : CXTPChart3dDeviceContext
  • SetModified() : CXTPCalendarEventColorListBox, CXTPSyntaxEditPropertiesPageColor, CXTPSyntaxEditPropertiesPageEdit, CXTPSyntaxEditPropertiesPageFont
  • SetModuleHandle() : CXTPSkinManagerResourceFile
  • SetMonth() : CXTPPropertyGridItemDate
  • SetMonthDelta() : CXTPDatePickerControl
  • SetMonthName() : CXTPDatePickerControl
  • SetMouseCursorMode() : CXTPTrackControl
  • SetMouseMode() : CXTPGridControl
  • SetMouseOutOfDragArea() : CXTPCalendarDayView
  • SetMoveCursor() : CXTPSyntaxEditPaintManager
  • SetMultiColumn() : CXTPTaskPanel
  • SetMultiDayEvent_MasterSlave() : CXTPCalendarViewEvent
  • SetMultiLinesCount() : CXTPPropertyGridItem
  • SetMultipleSelection() : CXTPGridControl
  • SetMultiplSel() : CXTPControlListBox
  • SetMultiSelectionMode() : CXTPDatePickerControl, CXTPGridControl
  • SetName() : CXTPCalendarEventCategory, CXTPCalendarResource, CXTPCalendarSchedule, CXTPChartAxisStrip, CXTPChartSeries, CXTPFlowGraphConnectionPoint
  • SetNavigator() : CXTPGridControl, CXTPPropertySheet
  • SetNewColor() : CXTPColorDialog
  • SetNewItemDefaultText() : CXTPEditListBox
  • SetNewTabPosition() : CXTPTabClientWnd
  • SetNewWindowTab() : CXTPTabManagerItem
  • SetNextVisualBlock() : CXTPGridColumn
  • SetNoEndDate() : CXTPCalendarRecurrencePattern
  • SetNormalIcon() : CXTPImageManagerIcon
  • SetNotificationWnd() : CXTPTrayIcon
  • SetNotifyOnClear() : CXTPGridSelectedRows
  • SetNumber() : CXTPPropertyGridItemNumber
  • SetNumericOnly() : CXTPControlEdit
  • SetOccReminder() : CXTPCalendarRecurrencePattern
  • SetOffice2003Colors() : CXTPCaption
  • SetOffset() : CXTPFrameShadow
  • SetOffsetItem() : CXTPTaskPanelGroup
  • SetOneLine() : CXTPCalendarCaptionBarTheme
  • SetOneNoteColors() : CXTPTabPaintManager
  • SetOnQuickAccess() : CXTPControl
  • SetOpenTags() : CXTPSyntaxEditAutoCompleteWnd
  • SetOption() : CXTPPropertyGridItemOption
  • SetOptions() : CXTPBrowseDialog, CXTPDockingPane, CXTPHexEdit
  • SetOrientation() : CXTPMarkupStackPanel, CXTPMarkupWrapPanel
  • SetOriginalControls() : CXTPControls
  • SetOuterSize() : CXTPFrameShadow
  • SetOutputPoint() : CXTPFlowGraphConnection
  • SetOverlayImage() : CXTPImageList
  • SetOverType() : CXTPMaskEditT< TBase >
  • SetOverwriteFlag() : CXTPSyntaxEditBufferManager
  • SetOverwriteMode() : CXTPSyntaxEditCtrl
  • SetOwner() : CXTPBrowseDialog, CXTPCalendarCaptionBarTheme
  • SetPadding() : CXTPMarkupBorder, CXTPMarkupControl, CXTPMarkupTextBlock, CXTPStatusBarPane, CXTPTagCloudCtrl
  • SetPageBorderStyle() : CXTPPropertySheet
  • SetPageSize() : CXTPPropertySheet
  • SetPageSizeMax() : CXTPPropertySheet
  • SetPageSizeMin() : CXTPPropertySheet
  • SetPaintManager() : CXTPCalendarControl, CXTPCommandBar, CXTPCommandBars, CXTPDockingPaneTabbedContainer, CXTPFlowGraphControl, CXTPGridControl, CXTPSyntaxEditCtrl, CXTPTabClientWnd, CXTPTabControl, CXTPTabManager
  • SetPaintTheme() : CXTPCalendarCaptionBarTheme, CXTPCalendarControl, CXTPCalendarPaintManager, CXTPDatePickerControl
  • SetPane() : CXTPChartDiagram2D
  • SetPaneColorSets() : CXTPDockingPaneVisualStudio2012Theme
  • SetPaneData() : CXTPDockingPane
  • SetPaneInfo() : CXTPStatusBar
  • SetPanelDirection() : CXTPChartContent
  • SetPanelDistance() : CXTPChartContent
  • SetPanelPaintManager() : CXTPDockingPanePaintManager
  • SetPaneStyle() : CXTPStatusBar
  • SetPaneText() : CXTPStatusBar
  • SetPaneWidth() : CXTPStatusBar
  • SetParameter() : CXTPControl
  • SetParent() : CXTPControl, CXTPControlComboBox, CXTPControlEdit, CXTPControlListBox, CXTPControls
  • SetParentContainer() : CXTPDockingPane, CXTPDockingPaneBase
  • SetParseThreadPriority() : CXTPSyntaxEditLexParser
  • SetPart() : CXTPPropertyGridVerb
  • SetPassedIniSet() : CXTPSyntaxEditCtrl
  • SetPasswordMask() : CXTPPropertyGridItem
  • SetPattern() : CXTPChartNumberFormat, CXTPEdit
  • SetPatternEnd() : CXTPCalendarRecurrencePattern
  • SetPatternEndDate() : CXTPCalendarRecurrencePattern
  • SetPatternID() : CXTPCalendarRecurrencePattern
  • SetPatternStartDate() : CXTPCalendarRecurrencePattern
  • SetPidlRoot() : CXTPBrowseDialog
  • SetPlusMinus() : CXTPGridColumn
  • SetPoint() : CXTPPoint2T< T >, CXTPPoint3T< T >, CXTPPropertyGridItemPoint
  • SetPointDistance() : CXTPChartFunnelSeriesStyleBase, CXTPChartPyramidSeriesStyleBase
  • SetPointLegendFormat() : CXTPChartSeries
  • SetPoints() : CXTPChartSeries
  • SetPopupAnimation() : CXTPPopupControl
  • SetPopupBarClass() : CXTPCommandBars
  • SetPopuped() : CXTPCommandBar
  • SetPopupFlags() : CXTPPopupBar
  • SetPopupPos() : CXTPPopupControl
  • SetPopupSize() : CXTPPopupControl
  • SetPopupState() : CXTPPopupControl
  • SetPopupToolBar() : CXTPPopupBar
  • SetPopupToolBarClass() : CXTPCommandBars
  • SetPOS() : XTP_CALENDAR_MONTHVIEW_DAYPOS
  • SetPos() : CXTPControlScrollBar, CXTPControlSlider, CXTPPageScroller, CXTPProgressBase, CXTPStatusBarScrollBarPane
  • SetPosition() : CXTPChartFunnelSeriesLabelBase, CXTPChartPieSeriesLabelBase, CXTPChartPyramidSeriesLabelBase, CXTPCommandBar, CXTPTabManager, CXTPTabPaintManager, CXTPToolBar, CXTPTrackBlock, CXTPTrackMarker
  • SetPositionInternally() : CXTPSyntaxEditCommand
  • SetPressed() : CXTPControl
  • SetPressedIcon() : CXTPImageManagerIcon
  • SetPreviewIndent() : CXTPGridPaintManager
  • SetPreviewItem() : CXTPGridRecord
  • SetPreviewText() : CXTPGridRecordItemPreview
  • SetPrintGroupRowIcon() : CXTPGridPaintManager
  • SetPrivate() : CXTPCalendarEvent
  • SetProgressBarPos() : CXTPTaskDialog
  • SetProgressBarRange() : CXTPTaskDialog
  • SetProgressBarState() : CXTPTaskDialog
  • SetPrompt() : CXTPControl, CXTPControlAction, CXTPPropertyGridItem
  • SetPromptChar() : CXTPMaskEditT< TBase >
  • SetProperty() : CXTPCalendarCustomProperties, CXTPWebBrowserCtrl
  • SetPropertyBool() : CXTPSkinManagerSchemaProperty
  • SetPropertyColor() : CXTPSkinManagerSchemaProperty
  • SetPropertyEnum() : CXTPSkinManagerSchemaProperty
  • SetPropertyFont() : CXTPSkinManagerSchemaProperty
  • SetPropertyInt() : CXTPSkinManagerSchemaProperty
  • SetPropertyRect() : CXTPSkinManagerSchemaProperty
  • SetPropertySize() : CXTPSkinManagerSchemaProperty
  • SetPropertySort() : CXTPPropertyGrid
  • SetPropertyString() : CXTPSkinManagerSchemaProperty
  • SetProviderType() : CXTPWebBrowserCtrl
  • SetPtr() : CXTPSmartPtrInternalT< _TObject >
  • SetPushButtonStyle() : CXTPButton
  • SetQuickAccessEmptyIconId() : CXTPRibbonBar
  • SetQuickCustomizeMode() : CXTPCommandBars
  • SetRange() : CXTPControlScrollBar, CXTPControlSlider, CXTPDatePickerControl, CXTPProgressBase, CXTPStatusBarScrollBarPane
  • SetReadOnly() : CXTPControlEdit, CXTPPropertyGridItem, CXTPPropertyGridItemFlags, CXTPSyntaxEditCtrl
  • SetReadOnlyBackColor() : CXTPSyntaxEditPaintManager
  • SetRecentColors() : CXTPColorSelectorCtrl
  • SetRecord() : CXTPGridRecordItem
  • SetRecordsTreeFilterMode() : CXTPGridControl
  • SetRect() : CXTPControl, CXTPControlComboBox, CXTPControlCustom, CXTPControlEdit, CXTPControlListBox, CXTPControlTabWorkspace, CXTPDatePickerItemDay, CXTPDockingPaneCaptionButton, CXTPFlowGraphConnectionPoint, CXTPGridRecordItemControl, CXTPRectT< T >, CXTPRibbonGroup, CXTPTabManagerItem, CXTPTabManagerNavigateButton
  • SetRecurrenceOptions() : CXTPCalendarRecurrencePattern
  • SetRecurrencePatternID() : CXTPCalendarEvent
  • SetRecurrenceState_ExceptionOccurrence() : CXTPCalendarEvent
  • SetRecurrenceState_Master() : CXTPCalendarEvent
  • SetRecurrenceState_NotRecurring() : CXTPCalendarEvent
  • SetRegisterAsDropTarget() : CXTPShellExplorerProvider
  • SetRegistryKey() : CXTPRegistryManager
  • SetReminder() : CXTPCalendarEvent
  • SetReminderMinutesBeforeStart() : CXTPCalendarEvent
  • SetRemindersManager() : CXTPCalendarRemindersDialog
  • SetReminderSoundFile() : CXTPCalendarEvent
  • SetResizable() : CXTPControlGallery, CXTPDialogBar, CXTPPropertySheet
  • SetResize() : CXTPResize, CXTPSearchOptionsView
  • SetResourceFile() : CXTPResourceManager, CXTPSkinManager
  • SetResourceFontCharset() : CXTPResourceManager
  • SetResourceHandle() : CXTPResourceManager
  • SetResourceManager() : CXTPResourceManager
  • SetResourceModule() : CXTPGaugeTraits
  • SetResourcePath() : CXTPGaugeTraits
  • SetResources() : CXTPCalendarControl, CXTPCalendarView, CXTPCalendarViewDay, CXTPCalendarViewGroup
  • SetReversed() : CXTPChartAxis
  • SetRException_EndTimeOrig() : CXTPCalendarEvent
  • SetRException_StartTimeOrig() : CXTPCalendarEvent
  • SetRExceptionDeleted() : CXTPCalendarEvent
  • SetRibbonDividerIndex() : CXTPStatusBar
  • SetRibbonMinimized() : CXTPRibbonBar
  • SetRibbonPaintManager() : CXTPRibbonTheme
  • SetRight() : CXTPGridThickness
  • SetRightButtonDrag() : CXTPSyntaxEditCtrl
  • SetRightDirected() : CXTPChart3dFunnelSeriesLabelView, CXTPChart3dPieSeriesLabelView, CXTPChart3dPyramidSeriesLabelView
  • SetRootFolder() : CXTPShellTreeBase
  • SetRotation() : CXTPChartPieSeriesStyleBase
  • SetRoundRectRegion() : CXTPRibbonTheme
  • SetRow() : CXTPMarkupGrid
  • SetRowBkColor() : CXTPSyntaxEditCtrl
  • SetRowColor() : CXTPListBase, CXTPSyntaxEditCtrl
  • SetRowColors() : CXTPListBase
  • SetRowRect() : CXTPControl
  • SetRows() : CXTPMarkupUniformGrid
  • SetRowsCompareFunc() : CXTPGridControl
  • SetRowSpan() : CXTPMarkupGrid
  • SetRowTabPositions() : CXTPSyntaxEditDrawTextProcessor
  • SetRowText() : CXTPSyntaxEditCtrl
  • SetRowValid() : CXTPSyntaxEditCtrl
  • SetRTFText() : CXTPPopupItem
  • SetSaturation() : CXTPColorWnd
  • SetScaleInterval() : CXTPCalendarDayView, CXTPCalendarTLV_TimeScaleParams
  • SetScaleMaxTime() : CXTPCalendarDayView
  • SetScaleMinTime() : CXTPCalendarDayView
  • SetScaleText() : CXTPCalendarDayView
  • SetScaleX() : CXTPMarkupScaleTransform
  • SetScaleY() : CXTPMarkupScaleTransform
  • SetScheduleID() : CXTPCalendarEvent
  • SetScheduleName() : CXTPCalendarSchedules
  • SetScheduleSet() : CXTPCalendarEvent
  • SetSchema() : CXTPPropExchange
  • SetScriptErrorsSuppressed() : CXTPShellExplorerProvider
  • SetScrollBarAuto() : CXTPControlGallery
  • SetScrollBarClass() : CXTPScrollBarContainer< Parent >
  • SetScrollBarCtrl() : CXTPCalendarControlView, CXTPGridView
  • SetScrollBars() : CXTPSyntaxEditCtrl, CXTPSyntaxEditView
  • SetScrollBarStyle() : CXTPScrollBase, CXTPShellExplorerProvider
  • SetScrollBarTheme() : CXTPScrollable< Base >, CXTPScrollBarContainer< Parent >
  • SetScrollDateButtons() : CXTPCalendarCaptionBarTheme
  • SetScrollIndexV() : CXTPGridSection
  • SetScrollInfo() : CXTPSyntaxEditCtrl
  • SetScrollMode() : CXTPGridControl
  • SetScrollOffset() : CXTPFlowGraphPage
  • SetScrollOffsetH() : CXTPGridControl
  • SetScrollOffsetV() : CXTPGridControl, CXTPGridSection
  • SetScrollPos() : CXTPControlGallery, CXTPRibbonBackstageView, CXTPSyntaxEditCtrl
  • SetScrollRange() : CXTPSyntaxEditCtrl
  • SetScrollXOffset() : CXTPSyntaxEditDrawTextProcessor
  • SetSearchHistoryCountMax() : CXTPSyntaxEditFindReplaceDlg
  • SetSel() : CXTPHexEdit
  • SetSelColor() : CXTPSyntaxEditColorComboBox
  • SetSelected() : CXTPCalendarMonthViewDay, CXTPCalendarViewDay, CXTPCalendarViewEvent, CXTPCommandBar, CXTPGridRow, CXTPMouseManager, CXTPPopupBar, CXTPShortcutBarItem
  • SetSelectedColor() : CXTPColorHex
  • SetSelectedItem() : CXTPControlGallery, CXTPRibbonControlTab, CXTPTabControl, CXTPTabManager, CXTPTabToolBar, CXTPTaskPanelGroup
  • SetSelection() : CXTPCalendarView, CXTPFlowGraphSelectedElements
  • SetSelectionCheck() : CXTPCheckListBox
  • SetSelectionState() : CXTPGridControl
  • SetSelectItemOnFocus() : CXTPTaskPanel
  • SetSelFont() : CXTPFontCtrlBase
  • SetSelMargin() : CXTPSyntaxEditCtrl, CXTPSyntaxEditView
  • SetSelPath() : CXTPBrowseDialog
  • SetSelRange() : CXTPDatePickerControl
  • SetSelTabBackColor() : CXTPExcelTabCtrl
  • SetSelTabTextColor() : CXTPExcelTabCtrl
  • SetShadow() : CXTPShadowManager
  • SetShadowColor() : CXTPShadowManager
  • SetShadowOptions() : CXTPShadowManager
  • SetShortcutManager() : CXTPCommandBars
  • SetShortcutText() : CXTPControl, CXTPControlAction
  • SetShowAllDayEventsDownScrollButton() : CXTPCalendarDayViewGroup
  • SetShowAllDayEventsUpScrollButton() : CXTPCalendarDayViewGroup
  • SetShowAlways() : CXTPPropertyGridInplaceButton
  • SetShowContentsWhileDragging() : CXTPDockingPaneManager, CXTPTabClientContext
  • SetShowDaysAfter() : CXTPDatePickerItemMonth
  • SetShowDaysBefore() : CXTPDatePickerItemMonth
  • SetShowDelay() : CXTPPopupControl
  • SetShowDockingContextStickers() : CXTPDockingPaneManager
  • SetShowFocus() : CXTPButton
  • SetShowGripper() : CXTPCommandBar
  • SetShowInFieldChooser() : CXTPGridColumn
  • SetShowInplaceButtonsAlways() : CXTPPropertyGrid
  • SetShowInTaskBar() : CXTPCalendarRemindersDialog
  • SetShowLines() : CXTPChartSeriesLabel
  • SetShowNonMonthDays() : CXTPDatePickerControl
  • SetShowScrolling() : CXTPDatePickerItemMonth
  • SetShowTabClientContextStickers() : CXTPTabClientContext
  • SetShowWeekNumbers() : CXTPDatePickerControl
  • SetShowZeroLevel() : CXTPChartAxisRange
  • SetSideDockingMargin() : CXTPDockingPaneManager
  • SetSideMargins() : CXTPChartAxisRange
  • SetSingleSelection() : CXTPShortcutBar, CXTPTaskPanel
  • SetSite() : CXTPCommandBars
  • SetSize() : CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE >, CXTPCalendarEvents, CXTPCalendarPtrCollectionT< _TObject >, CXTPControlCustom, CXTPControlGalleryItem, CXTPDialogBar, CXTPFlowGraphNode, CXTPFlowGraphNodeCustom, CXTPGridRecordItemControl, CXTPGridRecords, CXTPPropertyGridItemSize, CXTPSvgImage, CXTPTaskPanelGroupItem
  • SetSizeCore() : CXTPFlowGraphNode
  • SetSizeEmpty() : CXTPEmptySize
  • SetSkinManager() : CXTPSkinManager
  • SetSliderCtrl() : CXTPGridView
  • SetSliderStyle() : CXTPControlSlider
  • SetSlotNumber() : CXTPCalendarDayViewEvent
  • SetSmallDayHeaderFormat() : CXTPCalendarControl, CXTPCalendarMonthView
  • SetSmoothingMode() : CXTPFlowGraphControl
  • SetSortable() : CXTPGridColumn
  • SetSortBackColor() : CXTPListBase
  • SetSortColumn() : CXTPGridColumns
  • SetSortDirection() : CXTPChartLegend
  • SetSortImage() : CXTPHeaderCtrl, CXTPListBase
  • SetSortIncreasing() : CXTPGridColumn
  • SetSortOrder() : CXTPTagCloudCtrl
  • SetSortPriority() : CXTPGridRecordItem
  • SetSortRecordChilds() : CXTPGridControl
  • SetSortTextColor() : CXTPListBase
  • SetSource() : CXTPMarkupImage
  • SetSpecialGroup() : CXTPTaskPanelGroup
  • SetSpinButtonMax() : CXTPGridInplaceButton
  • SetSpinButtonMin() : CXTPGridInplaceButton
  • SetSpinButtonStep() : CXTPGridInplaceButton
  • SetSplashScreenMode() : CXTPPopupControl
  • SetSplitterStyle() : CXTPDockingPanePaintManager
  • SetStandardColors() : CXTPColorPicker, CXTPColorSelectorCtrl, CXTPPropertyGrid
  • SetStandardFont() : CXTPPaintManagerFont
  • SetStandardValue() : CXTPCalendarThemeCustomizableXValueT< _TValue, _TValueRef >, CXTPCalendarThemeFontValue, CXTPCalendarViewPartCustomizableValueT< _TValue >, CXTPCalendarViewPartFontValue, CXTPPaintManagerColor, CXTPPaintManagerColorGradient
  • SetStart_disp() : CXTPSyntaxEditSelection
  • SetStart_str() : CXTPSyntaxEditSelection
  • SetStartArcBallRotationPoint() : CXTPChart3dDiagram
  • SetStartTime() : CXTPCalendarEvent, CXTPCalendarRecurrencePattern
  • SetStartViewDate() : CXTPCalendarTimeLineView, CXTPCalendarTimeLineViewTimeScale
  • SetState() : CXTPCalendarCaptionBarThemePart, CXTPDockingPaneCaptionButton, CXTPGaugeStateType, CXTPGridRecordItemControl
  • SetStateColor() : CXTPCommandBarsNativeWindows10Theme, CXTPCommandBarsNativeWindows11Theme, CXTPCommandBarsVisualStudio2015Theme, CXTPCommandBarsVisualStudio2017Theme, CXTPCommandBarsVisualStudio2019Theme, CXTPCommandBarsVisualStudio2022Theme, CXTPStatusBarThemeNativeWindows10, CXTPStatusBarThemeNativeWindows11, CXTPStatusBarThemeVisualStudio2015, CXTPStatusBarThemeVisualStudio2017, CXTPStatusBarThemeVisualStudio2019, CXTPStatusBarThemeVisualStudio2022
  • SetStaticText() : CXTPShellExplorerProvider
  • SetStatusText() : CXTPCommandBar
  • SetStickyFloatingFrames() : CXTPDockingPaneManager
  • SetStoredWidth() : CXTPListBase
  • SetStretch() : CXTPMarkupImage, CXTPMarkupViewbox
  • SetString() : CXTPHeapString
  • SetStyle() : CXTPChartSeries, CXTPControl, CXTPFlowGraphConnection, CXTPFlowGraphConnectionPoint, CXTPFlowGraphNode, CXTPStatusBarPane, CXTPToolTipContext
  • SetStyleEx() : CXTPControlButton
  • SetSubject() : CXTPCalendarEvent
  • SetSubListCtrl() : CXTPGridHeader
  • SetSwitches() : CXTPStatusBarSwitchPane
  • SetSwitchViewButtons() : CXTPCalendarCaptionBarTheme
  • SetSyncWnd() : CXTPShellListCtrlEx
  • SetSyntaxAndColorScheme() : CXTPSyntaxEditConfigurationManager, CXTPSyntaxEditCtrl
  • SetSyntaxColor() : CXTPSyntaxEditCtrl, CXTPSyntaxEditView
  • SetTabBackColor() : CXTPExcelTabCtrl
  • SetTabCaption() : CXTPDockingPane
  • SetTabClient() : CXTPTabClientContext
  • SetTabFonts() : CXTPExcelTabCtrl
  • SetTabHeight() : CXTPExcelTabCtrl
  • SetTabHighlightColor() : CXTPExcelTabCtrl
  • SetTabIcon() : CXTPMDIWndTab
  • SetTabImageList() : CXTPTabView
  • SetTabLabel() : CXTPMDIWndTab
  • SetTabPaintManager() : CXTPDockingPanePaintManager
  • SetTabShadowColor() : CXTPExcelTabCtrl
  • SetTabSize() : CXTPSyntaxEditBufferManager, CXTPSyntaxEditCtrl, CXTPSyntaxEditDrawTextProcessor
  • SetTabStyle() : CXTPExcelTabCtrl
  • SetTabsVisible() : CXTPRibbonBar
  • SetTabText() : CXTPTabExBase
  • SetTabTextColor() : CXTPExcelTabCtrl
  • SetTabWithSpace() : CXTPSyntaxEditCtrl
  • SetTabWorkspace() : CXTPTabClientWnd
  • SetTag() : CXTPControl, CXTPControlAction, CXTPFlowGraphNode, CXTPMarkupFrameworkElement
  • SetTearOffPopup() : CXTPPopupBar
  • SetTemporary() : CXTPToolBar
  • SetText() : CXTPCalendarCaptionBarThemePart, CXTPChartAxisConstantLine, CXTPChartAxisCustomLabel, CXTPChartAxisTitle, CXTPChartTitle, CXTPGridFilterEditControl, CXTPMarkupTextBlock, CXTPStatusBarPane, CXTPSyntaxEditCtrl
  • SetTextAlignment() : CXTPButton, CXTPMarkupTextBlock, CXTPPopupItem, CXTPStatusBarPane
  • SetTextColor() : CXTPCalendarViewPart, CXTPChartAxisConstantLine, CXTPChartAxisLabel, CXTPChartAxisTitle, CXTPChartLegend, CXTPChartSeriesLabel, CXTPChartTitle, CXTPComboBox, CXTPComboBoxTheme, CXTPGridRecordItem, CXTPHexEdit, CXTPPopupItem, CXTPProgressCtrl, CXTPProgressCtrlPaintManager, CXTPStatusBarPane, CXTPSyntaxEditColorSampleText, CXTPSyntaxEditPaintManager, CXTPTabColorSetOffice2013, CXTPTabColorSetVisualStudio2010, CXTPTabColorSetVisualStudio2015, CXTPTabPaintManagerColorSet, CXTPTaskDialogLinkCtrl, CXTPTaskPanelGroupItem
  • SetTextDecoration() : CXTPGridHyperlinkStyle
  • SetTextDecorations() : CXTPMarkupTextBlock
  • SetTextFont() : CXTPCalendarViewPart, CXTPGridPaintManager, CXTPPopupItem, CXTPStatusBarPane
  • SetTextFormat() : CXTPTaskPanelPaintManager
  • SetTextGrayColor() : CXTPStatusBarPane
  • SetTextImageRelation() : CXTPButton
  • SetTextLimit() : CXTPControlComboBox, CXTPControlEdit
  • SetTextLinkColor() : CXTPTaskDialogLinkCtrl
  • SetTextOrientation() : CXTPCommandBar
  • SetTextOutOfBorders() : CXTPCalendarViewEvent
  • SetTextRect() : CXTPSyntaxEditDrawTextProcessor, CXTPTaskPanelItem
  • SetTextSchema() : CXTPSyntaxEditLexParser
  • SetTextTabStopPositions() : CXTPTipWindow
  • SetTextTrimming() : CXTPMarkupTextBlock
  • SetTextWrapping() : CXTPMarkupTextBlock
  • SetTheme() : CXTPButton, CXTPCalendarCaptionBarControl, CXTPCalendarControl, CXTPCalendarTip, CXTPCaption, CXTPCaptionButton, CXTPCaptionPopupWnd, CXTPColorSelectorCtrl, CXTPComboBox, CXTPCommandBars, CXTPControlTheme, CXTPDatePickerControl, CXTPDockingPaneManager, CXTPEdit, CXTPEditListBoxToolBar, CXTPExcelTabCtrl, CXTPGridView, CXTPHeaderCtrl, CXTPListBox, CXTPMarqueeCtrl, CXTPPaintManager, CXTPPopupControl, CXTPProgressCtrl, CXTPPropertyGrid, CXTPPropertyPageNavigator, CXTPPropertySheet, CXTPRibbonBackstageView, CXTPScrollBar, CXTPScrollBarCtrl, CXTPShortcutBar, CXTPShortcutListBox, CXTPSpinButtonCtrl, CXTPSplitterWnd, CXTPSyntaxEditConfigurationManager, CXTPSyntaxEditTextSchemesManager, CXTPTabBase, CXTPTaskPanel
  • SetThemeAppProperties() : CXTPWinThemeWrapper
  • SetThemeColors() : CXTPColorPicker, CXTPColorSelectorCtrl
  • SetThemed() : CXTPGridRecordItemControl
  • SetThemeWrapperPtr() : CXTPWinThemeWrapper
  • SetThickness() : CXTPChartAxis, CXTPChartAxisTickMarks, CXTPChartBorder, CXTPChartLineStyle
  • SetThinSplitter() : CXTPPropertyGridPaintManager
  • SetThreeState() : CXTPMarkupToggleButton
  • SetThumbWidth() : CXTPControlComboBox
  • SetTicks() : CXTPScrollBase, CXTPStatusBarSliderPane
  • SetTime() : CXTPTimeEdit
  • SetTime_235959() : CXTPCalendarUtils
  • SetTimeLinePosition() : CXTPTrackControl
  • SetTimeLineRange() : CXTPTrackControl
  • SetTimer() : CXTPCalendarControl, CXTPCalendarView, CXTPCalendarViewDay, CXTPCalendarViewEvent, CXTPCalendarViewGroup, CXTPTrayIcon
  • SetTimeScaleID() : CXTPCalendarTimeLineView
  • SetTimeScaleParams() : CXTPCalendarTimeLineViewTimeScale
  • SetTimeScaleParams2() : CXTPCalendarTimeLineViewTimeScale
  • SetTimeshift() : CXTPCalendarDayViewTimeScale
  • SetTipBkColor() : CXTPToolTipContext
  • SetTipColors() : CXTPTipWindow
  • SetTipOffsetPos() : CXTPTipWindow
  • SetTips() : CXTPTabExBase
  • SetTipsFilePath() : CXTPTipOfTheDay
  • SetTipText() : CXTPExcelTabCtrl, CXTPHyperLink, CXTPTipOfTheDay, CXTPTipWindow
  • SetTipTextColor() : CXTPToolTipContext
  • SetTitle() : CXTPBrowseDialog, CXTPCommandBar, CXTPDockingPane, CXTPPropertySheet
  • SetTitleToolTip() : CXTPDockingPane
  • SetToday() : CXTPDatePickerControl
  • SetTodayDateOverride() : CXTPCalendarControl
  • SetToolBarClass() : CXTPCommandBars
  • SetToolBarFocus() : CXTPCommandBars
  • SetToolTip() : CXTPControlGalleryItem
  • SetTooltip() : CXTPButton, CXTPControl, CXTPControlAction, CXTPFlowGraphConnection, CXTPFlowGraphConnectionPoint, CXTPFlowGraphNode, CXTPGridColumn, CXTPGridRecordItem, CXTPPropertyGridInplaceButton, CXTPPropertyGridItem, CXTPShortcutBarItem, CXTPStatusBarPane, CXTPTabManagerItem, CXTPTabManagerNavigateButton, CXTPTaskPanelItem, CXTPTrackBlock, CXTPTrayIcon
  • SetToolTipCtrl() : CXTPToolTipContext
  • SetTooltipPart() : CXTPStatusBarScrollBarPane
  • SetTooltipRect() : CXTPGridTip
  • SetToolTips() : CXTPTabView
  • SetTooltipText() : CXTPCalendarTip, CXTPChartSeriesPoint, CXTPGridTip, CXTPTrayIcon
  • SetTop() : CXTPGridThickness
  • SetTopIndex() : CXTPControlGallery, CXTPPropertyGrid
  • SetTopRow() : CXTPGridControl, CXTPSyntaxEditCtrl, CXTPSyntaxEditView
  • SetTorus() : CXTPChart3dPieSeriesStyle
  • SetTrack() : CXTPMouseManager
  • SetTrackFocus() : CXTPCommandBar
  • SetTracking() : CXTPExcelTabCtrl
  • SetTrackingMode() : CXTPCommandBar, CXTPControlComboBoxList, CXTPPopupBar, CXTPRibbonBackstageView, CXTPRibbonTabPopupToolBar
  • SetTrait() : CXTPGaugeBaseType
  • SetTraits() : CXTPGaugeTraits
  • SetTraitsArgument() : CXTPGaugeTraits
  • SetTransparency() : CXTPChartAreaSeriesStyle, CXTPChartRadarAreaSeriesStyle, CXTPChartSeriesLabel, CXTPChartSeriesStyle, CXTPFrameShadow, CXTPPopupControl
  • SetTrayIcon() : CXTPTrayIcon
  • SetTreeColumn() : CXTPGridColumn
  • SetTreeIndent() : CXTPGridControl
  • SetTrueFalseText() : CXTPPropertyGridItemBool
  • SetTwipSize() : CXTPControlSizeComboBox
  • SetTxtOffset() : CXTPSyntaxEditTextIterator
  • SetType() : CXTPFlowGraphConnectionPoint, CXTPTaskPanelItem
  • SetUnderline() : CXTPHyperLink, CXTPPopupItem
  • SetupCallWndProcHook() : CXTPKeyboardManager
  • SetUpdateWindow() : CXTPChartControl
  • SetupDefaultMarkupTemplates() : CXTPFlowGraphControl
  • SetupHook() : CXTPMenuBar
  • SetupKeyboardHook() : CXTPKeyboardManager
  • SetupMenu() : CXTPMenuBar
  • SetupStartCol() : CXTPGridView
  • SetURL() : CXTPHyperLink
  • SetUseComCtl32() : CXTPTaskDialog
  • SetUseCustomToolTipPosition() : CXTPMarkupContext
  • SetUseMask() : CXTPMaskEditT< TBase >
  • SetUserColor() : CXTPSyntaxEditColorComboBox
  • SetUseResourceFileLocale() : CXTPChartNumberFormat, CXTPGridControlLocale
  • SetUseSysIcons() : CXTPTaskDialog
  • SetUseThousandSeparator() : CXTPChartNumberFormat
  • SetUseVisualStyle() : CXTPButton, CXTPComboBox, CXTPEdit, CXTPProgressCtrl, CXTPScrollBar, CXTPSpinButtonCtrl
  • SetValue() : CXTPActiveScriptObjectContext, CXTPChartColor, CXTPChartSeriesPoint, CXTPGridRecordItemDateTime, CXTPGridRecordItemNumber, CXTPGridRecordItemText, CXTPGridRecordItemVariant, CXTPMarkupStaticExtensionBooleanProperty, CXTPMarkupStaticExtensionBrushProperty, CXTPMarkupStaticExtensionColorProperty, CXTPMarkupStaticExtensionDoubleProperty, CXTPMarkupStaticExtensionIntegerProperty, CXTPMarkupStaticExtensionProperty, CXTPMarkupStaticExtensionStringProperty, CXTPPropertyGridInplaceEdit, CXTPPropertyGridItem, CXTPPropertyGridItemBool, CXTPPropertyGridItemColor, CXTPPropertyGridItemDate, CXTPPropertyGridItemDouble, CXTPPropertyGridItemEnum, CXTPPropertyGridItemFlags, CXTPPropertyGridItemNumber, CXTPPropertyGridItemOption, CXTPStatusBarPane
  • SetValueLength() : CXTPChartSeriesPoint
  • SetValueScaleType() : CXTPChartSeries
  • SetValueText() : CXTPPropertyGridItemBool
  • SetVariable() : CXTPSyntaxEditLexVariable, CXTPSyntaxEditLexVariant
  • SetVariableHelpHeight() : CXTPPropertyGrid
  • SetVariableItemsHeight() : CXTPPropertyGrid
  • SetVariableSplitterPos() : CXTPPropertyGrid
  • SetVectorCheckedIcon() : CXTPImageManagerIcon, CXTPImageManagerIconSet
  • SetVectorDisabledIcon() : CXTPImageManagerIcon, CXTPImageManagerIconSet
  • SetVectorHotIcon() : CXTPImageManagerIcon, CXTPImageManagerIconSet
  • SetVectorIcon() : CXTPImageManager, CXTPImageManagerIcon, CXTPImageManagerIconSet
  • SetVectorIconSize() : CXTPToolTipContext
  • SetVectorPressedIcon() : CXTPImageManagerIcon, CXTPImageManagerIconSet
  • SetVerbsHeight() : CXTPPropertyGrid
  • SetVerificationText() : CXTPTaskDialog
  • SetVerifyCheckState() : CXTPTaskDialog
  • SetVerticalAlignment() : CXTPChartLegend, CXTPMarkupFrameworkElement, CXTPTrackBlock
  • SetVerticalPositionOption() : CXTPControlCustom
  • SetViewAutoRange() : CXTPChartAxisRange
  • SetViewDivider() : CXTPPropertyGrid
  • SetViewDividerPos() : CXTPPropertyGrid
  • SetViewMaxValue() : CXTPChartAxisRange
  • SetViewMinValue() : CXTPChartAxisRange
  • SetViewOnly() : CXTPSyntaxEditCtrl
  • SetViewPort() : CXTPTrackControl
  • SetVirtualMode() : CXTPGridControl, CXTPGridRows
  • SetVisibility() : CXTPMarkupUIElement
  • SetVisible() : CXTPCalendarCaptionBarThemePart, CXTPCalendarDayViewTimeScale, CXTPChartAxis, CXTPChartAxisConstantLine, CXTPChartAxisGridLines, CXTPChartAxisLabel, CXTPChartAxisStrip, CXTPChartAxisTickMarks, CXTPChartAxisTitle, CXTPChartLegend, CXTPChartSeries, CXTPChartSeriesLabel, CXTPChartTitle, CXTPCommandBar, CXTPControl, CXTPControlAction, CXTPFlowGraphNode, CXTPGridColumn, CXTPGridRecord, CXTPGridRow, CXTPGridSection, CXTPPropertyGridItem, CXTPRibbonBar, CXTPRibbonGroup, CXTPRibbonTab, CXTPShortcutBarItem, CXTPStatusBarPane, CXTPTabManagerItem, CXTPTaskPanelItem, CXTPToolBar
  • SetVisibleNodesWindowsRegions() : CXTPFlowGraphPage
  • SetVisited() : CXTPHyperLink
  • SetWatermarkAlignment() : CXTPGridControl
  • SetWatermarkBitmap() : CXTPGridControl
  • SetWeeksCount() : CXTPCalendarMonthView::CMonthViewGrid
  • SetWideCaret() : CXTPSyntaxEditCtrl
  • SetWidth() : CXTPCommandBar, CXTPControl, CXTPControlListBox, CXTPControlStatic, CXTPFlowGraphConnection, CXTPGridColumn, CXTPGridRecordItemControl, CXTPMarkupColumnDefinition, CXTPMarkupFrameworkElement, CXTPPropertyGridInplaceButton, CXTPStatusBarPane, CXTPTaskDialog
  • SetWindowFilter() : CXTPSkinManager
  • SetWindowHandle() : CXTPFlowGraphNode, CXTPFlowGraphNodeCustom
  • SetWindowIcon() : CXTPWindowList
  • SetWindowPos() : CXTPGridHeaderDropWnd
  • SetWindowRect() : CXTPDockingPane
  • SetWindowSize() : CXTPFlowGraphNode, CXTPFlowGraphNodeCustom
  • SetWindowText() : CXTPGridInplaceEdit
  • SetWindowTextEx() : CXTPCommandBarEditCtrl
  • SetWindowTheme() : CXTPSkinManager, CXTPWinThemeWrapper
  • SetWindowTitle() : CXTPTaskDialog
  • SetWndWidth() : CXTPSyntaxEditAutoCompleteWnd
  • SetWorkArea() : CXTPTrackControl
  • SetWorkDayEndTime() : CXTPCalendarControl
  • SetWorkDayStartTime() : CXTPCalendarControl
  • SetWorkWeekMask() : CXTPCalendarControl
  • SetWrap() : CXTPControl
  • SetX() : CXTPMarkupTranslateTransform
  • SetY() : CXTPMarkupTranslateTransform
  • SetYear() : CXTPPropertyGridItemDate
  • SetZero() : CXTPMatrix< T >
  • SetZoomLevel() : CXTPFlowGraphControl, CXTPFlowGraphPage
  • SetZoomRange() : CXTPFlowGraphControl
  • SetZoomState() : CXTPPreviewView
  • SEventTimeFormatInfo() : CXTPCalendarView::SEventTimeFormatInfo
  • ShadeGroupHeadings() : CXTPGridControl
  • ShellExplorer_OnBeforeNavigate2() : IXTPWebBrowserEventSink
  • ShellExplorer_OnCommandStateChange() : IXTPWebBrowserEventSink
  • ShellExplorer_OnDocumentComplete() : IXTPWebBrowserEventSink
  • ShellExplorer_OnDownloadBegin() : IXTPWebBrowserEventSink
  • ShellExplorer_OnDownloadComplete() : IXTPWebBrowserEventSink
  • ShellExplorer_OnFullScreen() : IXTPWebBrowserEventSink
  • ShellExplorer_OnMenuBar() : IXTPWebBrowserEventSink
  • ShellExplorer_OnNavigateComplete2() : IXTPWebBrowserEventSink
  • ShellExplorer_OnNavigateError() : IXTPWebBrowserEventSink
  • ShellExplorer_OnNewWindow2() : IXTPWebBrowserEventSink
  • ShellExplorer_OnProgressChange() : IXTPWebBrowserEventSink
  • ShellExplorer_OnPropertyChange() : IXTPWebBrowserEventSink
  • ShellExplorer_OnQuit() : IXTPWebBrowserEventSink
  • ShellExplorer_OnSetSecureLockIcon() : IXTPWebBrowserEventSink
  • ShellExplorer_OnStatusBar() : IXTPWebBrowserEventSink
  • ShellExplorer_OnStatusTextChange() : IXTPWebBrowserEventSink
  • ShellExplorer_OnTheaterMode() : IXTPWebBrowserEventSink
  • ShellExplorer_OnTitleChange() : IXTPWebBrowserEventSink
  • ShellExplorer_OnToolBar() : IXTPWebBrowserEventSink
  • ShellExplorer_OnVisible() : IXTPWebBrowserEventSink
  • ShellExplorer_OnWindowClosing() : IXTPWebBrowserEventSink
  • ShellExplorer_OnWindowSetHeight() : IXTPWebBrowserEventSink
  • ShellExplorer_OnWindowSetLeft() : IXTPWebBrowserEventSink
  • ShellExplorer_OnWindowSetResizable() : IXTPWebBrowserEventSink
  • ShellExplorer_OnWindowSetTop() : IXTPWebBrowserEventSink
  • ShellExplorer_OnWindowSetWidth() : IXTPWebBrowserEventSink
  • ShellNotify() : CXTPTrayIcon
  • ShellOpenItem() : CXTPShellListBase
  • ShiftCurrentVisibleRowDown() : CXTPSyntaxEditCtrl
  • ShiftCurrentVisibleRowUp() : CXTPSyntaxEditCtrl
  • ShiftDate() : CXTPDatePickerControl
  • ShiftDate_Month() : CXTPCalendarUtils
  • ShiftDate_Year() : CXTPCalendarUtils
  • ShiftDateToCell_00() : CXTPCalendarMonthView::CMonthViewGrid
  • ShiftDateToWeekBegin() : CXTPCalendarUtils
  • ShiftTreeIndent() : CXTPGridRow
  • ShouldSerializeBar() : CXTPMenuBar, CXTPToolBar
  • ShouldSerializeControl() : CXTPControls, CXTPRibbonControls
  • Show() : CXTPFrameShadow, CXTPPopupControl, CXTPSyntaxEditAutoCompleteWnd
  • ShowActiveItemOnTop() : CXTPShortcutBar
  • ShowAdditionalScale() : CXTPCalendarDayView
  • ShowAllFiles() : CXTPShellSettings
  • ShowAttributes() : CXTPShellSettings
  • ShowBalloonTip() : CXTPTrayIcon
  • ShowBorder() : CXTPEdit
  • ShowBorders() : CXTPControlGallery, CXTPStatusBarPane
  • ShowBuddyButton() : CXTPControlEdit
  • ShowButtons() : CXTPTabBaseTheme
  • ShowCalendarPopup() : CXTPCalendarTimeLineView
  • ShowCaption() : CXTPShortcutBarPane, CXTPShortcutBarPaneItem, CXTPTaskPanelGroup
  • ShowCaptionAlways() : CXTPRibbonBar
  • ShowCaptionBar() : CXTPCalendarControlView
  • ShowCaptionMaximizeButton() : CXTPDockingPaneManager
  • ShowCaptions() : CXTPColorPicker, CXTPColorSelectorCtrl
  • ShowCloseItemButton() : CXTPTabManager
  • ShowCollapsedToolTip() : CXTPSyntaxEditCtrl
  • ShowColumn() : CXTPSplitterWnd
  • ShowCompColor() : CXTPShellSettings
  • ShowContextMenu() : CXTPCommandBarEditCtrl, CXTPShellPidl
  • ShowDay() : CXTPCalendarDayView, CXTPCalendarMonthView, CXTPCalendarTimeLineView, CXTPCalendarView, CXTPCalendarWeekView
  • ShowDays() : CXTPCalendarDayView
  • ShowDefaultContextMenu() : CXTPSyntaxEditCtrl
  • ShowDialog() : CXTPSyntaxEditFindReplaceDlg, CXTPSyntaxEditGoToLineDlg
  • ShowExpandButton() : CXTPShortcutBar, CXTPToolBar
  • ShowExtensions() : CXTPShellSettings
  • ShowFiles() : CXTPShellTreeBase
  • ShowFloatingCaptionMaximizeButton() : CXTPDockingPaneManager
  • ShowFooter() : CXTPGridControl
  • ShowGripper() : CXTPShortcutBar
  • ShowGroupBy() : CXTPGridControl
  • ShowHeader() : CXTPGridControl
  • ShowHelp() : CXTPPropertyGrid
  • ShowHScrollBar() : CXTPSyntaxEditCtrl
  • ShowIcon() : CXTPTrayIcon
  • ShowIcons() : CXTPTabManager
  • ShowIconWhenEditing() : CXTPGridControl
  • ShowImage() : CXTPToolTipContext
  • ShowInfoTips() : CXTPShellSettings
  • ShowItemsInGroups() : CXTPGridHeader
  • ShowKeyboardCues() : CXTPCommandBars, CXTPCommandBarsOptions
  • ShowKeyboardTips() : CXTPCommandBars
  • ShowLabel() : CXTPControlEdit
  • ShowLabels() : CXTPControlGallery
  • ShowListHeader() : CXTPDatePickerControl
  • ShowMapNetworkDrive() : CXTPShellSettings
  • ShowMessageBox() : CXTPResourceManager
  • ShowMinimizeButton() : CXTPShortcutBar
  • ShowModal() : CXTPPopupControl
  • ShowNavButtons() : CXTPTabBase
  • ShowNewWindowTab() : CXTPTabClientWnd
  • ShowOptionButton() : CXTPRibbonGroup
  • ShowPane() : CXTPDockingPaneAutoHidePanel, CXTPDockingPaneManager
  • ShowPopupWindow() : CXTPCaption, CXTPColorPicker
  • ShowPreview() : CXTPEyeDropper
  • ShowProgressBar() : CXTPTaskDialog
  • ShowQuickAccess() : CXTPRibbonBar
  • ShowQuickAccessBelowRibbon() : CXTPRibbonBar
  • ShowRow() : CXTPSplitterWnd
  • ShowRowFocus() : CXTPGridControl
  • ShowRowNumber() : CXTPGridControl
  • ShowScrollBar() : CXTPControlGallery, CXTPScrollBarContainer< Parent >, CXTPSyntaxEditCtrl
  • ShowShellContextMenu() : CXTPShellListBase
  • ShowShellLinkIcons() : CXTPShellPidl
  • ShowSortArrow() : CXTPHeaderCtrl
  • ShowSpinButtons() : CXTPControlEdit
  • ShowSysFiles() : CXTPShellSettings
  • ShowText() : CXTPColorPicker
  • ShowTextBelowIcons() : CXTPCommandBar
  • ShowTextInColor() : CXTPColorPicker
  • ShowThemedBorder() : CXTPEdit
  • ShowTip() : CXTPSyntaxEditTipListBox, CXTPSyntaxEditTipWnd
  • ShowTipWindow() : CXTPTipWindow
  • ShowTitleAndDescription() : CXTPToolTipContext
  • ShowToolBar() : CXTPPropertyGrid
  • ShowToolTip() : CXTPCalendarControl, CXTPCalendarView, CXTPCalendarViewEvent, CXTPGridRow, CXTPPropertyGridView
  • ShowTopBorder() : CXTPSplitterWndEx
  • ShowView() : CXTPPropertyGrid
  • ShowWindow() : CXTPDockingPane
  • ShowWorkingDays() : CXTPCalendarDayView
  • ShowWorkspace() : CXTPTabClientWnd
  • ShowWYSIWYGMarkers() : CXTPGridPaintManager
  • Shutdown() : CXTPActiveScriptStdRuntime, CXTPMarkupContext
  • Sign() : CXTPMathUtils
  • Size() : CXTPResize
  • SizeMinReq() : CXTPDatePickerControl
  • SizeToFit() : CXTPTabPaintManager
  • SizeToPage() : CXTPPropertyPageNavigator
  • SkipGroupsFocus() : CXTPGridControl
  • SnapPosition() : CXTPTrackControl
  • Snooze() : CXTPCalendarReminder, CXTPCalendarRemindersManager
  • Sort() : CXTPCalendarEvents, CXTPCalendarReminders, CXTPControls, CXTPGridRows, CXTPPropertyGridItemConstraints, CXTPPropertyGridItems, CXTPSortClass, CXTPTagCloudTagArray
  • SortAscending() : CXTPGridSubListControl
  • SortChildren() : CXTPShellTreeBase
  • SortDateTime() : CXTPSortClass
  • SortDecimal() : CXTPSortClass
  • SortEx() : CXTPGridRows
  • SortInt() : CXTPSortClass
  • SortList() : CXTPListBase, CXTPShellListBase
  • SortRows() : CXTPGridSection
  • SortString() : CXTPSortClass
  • SortTree() : CXTPGridSection
  • SplitPath() : CXTPSplitPath
  • StartAnimation() : CXTPTrayIcon
  • StartDelayEditTimer() : CXTPGridControl
  • StartDrag() : CXTPDockContext
  • StartDragBlocks() : CXTPTrackControl
  • StartDragConnection() : CXTPFlowGraphControl
  • StartDragConnectionPoint() : CXTPFlowGraphControl
  • StartDragging() : CXTPGridHeader
  • StartDragMarker() : CXTPTrackHeader
  • StartDragNodes() : CXTPFlowGraphControl
  • StartDragScreen() : CXTPFlowGraphControl
  • StartDragScrollBar() : CXTPTrackHeader
  • StartDragSelection() : CXTPFlowGraphControl, CXTPTrackControl
  • StartDragSlider() : CXTPTrackHeader
  • StartEditNewEventInplace() : CXTPCalendarView
  • StartEditSubject() : CXTPCalendarDayViewEvent, CXTPCalendarView, CXTPCalendarViewEvent
  • StartGroup() : CXTPFlowGraphUndoManager, CXTPTrackUndoManager
  • StartLastRqstTimer() : CXTPGridControl
  • StartMonitoring() : CXTPCalendarRemindersManager, CXTPSyntaxEditFileChangesMonitor
  • StartOleDrag() : CXTPSyntaxEditView
  • StartParseInThread() : CXTPSyntaxEditLexParser
  • StartProgressBarMarquee() : CXTPTaskDialog
  • StartResize() : CXTPDockContext
  • StartResizeNode() : CXTPFlowGraphControl
  • StopAnimation() : CXTPTrayIcon
  • StopHorzEventScroll() : CXTPCalendarDayView
  • StopMonitoring() : CXTPCalendarRemindersManager, CXTPSyntaxEditFileChangesMonitor
  • StopNotifications() : CXTPDirWatcher
  • StopParseInThread() : CXTPSyntaxEditLexParser
  • StopThread() : CXTPSoundManager
  • StopVertEventScroll() : CXTPCalendarDayView
  • Stretch() : CXTPDockContext
  • StringToDouble() : CXTPPropertyGridItemDouble
  • StringToRGB() : CXTPPropertyGridItemColor
  • StripEllipsisFromToolTip() : CXTPToolTipContext
  • StripFormat() : CXTPCalendarUtils
  • StripMnemonics() : CXTPPaintManager
  • StrPosToCol() : CXTPSyntaxEditBufferManager
  • StrPosToDispPos() : CXTPSyntaxEditDrawTextProcessor
  • SubclassHeader() : CXTPListBase
  • Subscribe() : CXTPObservable< Owner, Observer >
  • Subtract() : CXTPMatrix< T >
  • SupportsCompositedParent() : IXTPPreview
  • Suspend() : CXTPSkinManager
  • SwapColors() : CXTPTabBaseTheme
  • SwapIfNeed() : CXTPGridSelectedRows
  • SwitchActiveMenu() : CXTPMenuBar
  • SwitchActiveView() : CXTPCalendarControl
  • SwitchMDIMenu() : CXTPMenuBar
  • SwitchView() : CXTPSplitterWnd
  • SyncActiveFloatingFrames() : CXTPDockingPaneManager
  • SyncActiveMdiChild() : CXTPMenuBar
  • SyncPanesState() : CXTPDockingPaneManager
  • SyncScrollBar() : CXTPExcelTabCtrl
  • SystemTimeToTzSpecificLocalTime() : CXTPCalendarUtils


Toolkit Pro: Class Members - Functions

Here is a list of all documented functions with links to the class documentation for each member:

- t -

  • TabFromPoint() : CXTPMDIWndTab
  • TabifySelection() : CXTPSyntaxEditCtrl
  • TextPrepareSingleline() : CXTPCalendarUtils
  • ThawAllColumns() : CXTPHeaderCtrl
  • ThawColumn() : CXTPHeaderCtrl
  • ThemeAppProperties() : CXTPWinThemeWrapper
  • ThemeDataOpen() : CXTPWinThemeWrapper
  • ToCOLORREF() : CXTPChartColor
  • ToggleAutoHide() : CXTPDockingPaneManager
  • ToggleCheck() : CXTPCalendarEventColorListBox
  • ToggleConstraint() : CXTPPropertyGridItemOption
  • ToggleDocking() : CXTPDockContext, CXTPDockingPaneManager
  • ToggleVisible() : CXTPCommandBars
  • Track() : CXTPDockContext, CXTPDockingPaneContext
  • TrackClick() : CXTPTabManager
  • TrackMiniBar() : CXTPMiniToolBar
  • TrackMouseEvent() : CXTPCalendarUtils
  • TrackMouseLeave() : CXTPMouseManager
  • TrackMove() : CXTPPopupControl
  • TrackPopupMenu() : CXTPCommandBars, CXTPMiniToolBar
  • TrackPopupMenuEx() : CXTPCommandBars
  • TrackToPosition() : CXTPTrackControl
  • Transform() : CXTPChart3dDeviceContext
  • TransformationMatrices() : CXTPMarkupVisual::TransformationMatrices
  • TransformMatrix() : CXTPMarkupGdiPlusMatrixTransform, CXTPMarkupGdiPlusRotateTransform, CXTPMarkupGdiPlusScaleTransform, CXTPMarkupGdiPlusTransformObjectImpl
  • TransformPoint() : CXTPFlowGraphControl
  • TranslateAccelerator() : CXTPShortcutManager
  • TranslateKeyboardTip() : CXTPRibbonBackstageView
  • TransparentBlt() : CXTPImageManager
  • Transpose() : CXTPMatrix< T >
  • TreeAddRef() : CXTPGridRecord
  • TreeRelease() : CXTPGridRecord
  • TreeViewCompareProc() : CXTPShellPidl
  • Triangle() : CXTPDatePickerPaintManager, CXTPPaintManager
  • TriggerAmbientPropertyUpdate() : CXTPApplication
  • TryItemFromPoint() : CXTPListBox
  • TunnelTree() : CXTPShellTreeBase
  • TwipsToPointString() : CXTPControlSizeComboBox


Toolkit Pro: Class Members - Functions

Here is a list of all documented functions with links to the class documentation for each member:

- u -

  • Unadvise() : CXTPCalendarMsgNotifier, CXTPNotifyConnection, CXTPNotifySinkBase
  • UnadviseAll() : CXTPNotifySinkBase
  • Undo() : CXTPCalendarView, CXTPFlowGraphUndoAddConnectionCommand, CXTPFlowGraphUndoAddConnectionPointCommand, CXTPFlowGraphUndoAddNodeCommand, CXTPFlowGraphUndoCommand, CXTPFlowGraphUndoDeleteConnectionCommand, CXTPFlowGraphUndoDeleteConnectionPointCommand, CXTPFlowGraphUndoDeleteNodeCommand, CXTPFlowGraphUndoGroupCommand, CXTPFlowGraphUndoManager, CXTPFlowGraphUndoSetConnectionPositionCommand, CXTPFlowGraphUndoSetNodeCaptionCommand, CXTPFlowGraphUndoSetNodePositionCommand, CXTPFlowGraphUndoSetNodeSizeCommand, CXTPResourceManager::CManageState, CXTPSyntaxEditCtrl, CXTPTrackUndoAddBlockCommand, CXTPTrackUndoAddMarkerCommand, CXTPTrackUndoCommand, CXTPTrackUndoDeleteBlockCommand, CXTPTrackUndoDeleteMarkerCommand, CXTPTrackUndoGroupCommand, CXTPTrackUndoManager, CXTPTrackUndoSetBlockPositionCommand, CXTPTrackUndoSetMarkerPositionCommand
  • UnExecute() : CXTPSyntaxEditBatchCommand, CXTPSyntaxEditCommand, CXTPSyntaxEditDeleteStringCommand, CXTPSyntaxEditInsertStringCommand, CXTPSyntaxEditReplaceStringCommand
  • UnhookKeyboard() : CXTPKeyboardManager
  • Uninitialize() : CXTPActiveScriptEngine
  • UnInstall() : CXTPMDIWndTab
  • Union() : CXTPRectT< T >
  • Unload() : CXTPGaugeCtrl
  • Unlock() : CXTPNotifyConnection::CEmptySyncObject
  • UnlockExclusive() : CXTPRWCriticalSection
  • UnlockInput() : CXTPKeyboardManager
  • UnlockMouseMove() : CXTPCommandBar, CXTPMouseManager
  • UnlockRedraw() : CXTPCommandBar
  • UnlockShared() : CXTPRWCriticalSection
  • UnLockThread() : CXTPLockGuard
  • Unproject() : CXTPChart3dDeviceContext, CXTPOpenGLUtils
  • Unselect() : CXTPSyntaxEditCtrl
  • UnselectAllEvents() : CXTPCalendarView
  • UnselectGroupRows() : CXTPGridControl
  • UnsetCurrent() : CXTPGaugeMeterType
  • UnsetMax() : CXTPGaugeMeterType
  • UnsetMin() : CXTPGaugeMeterType
  • Unsubscribe() : CXTPObservable< Owner, Observer >
  • UnTabifySelection() : CXTPSyntaxEditCtrl
  • Update() : CXTPCalendarEvent, CXTPCalendarRecurrencePattern, CXTPGaugeBaseType, CXTPTearOffFrame
  • UpdateAcellTable() : CXTPCustomizeKeyboardPage
  • UpdateAllViews() : CXTPSyntaxEditView
  • UpdateBackgroundBrush() : CXTPComboBoxTheme
  • UpdateBorders() : CXTPCalendarCaptionBarControl, CXTPCalendarControl
  • UpdateBounds() : CXTPChartPieBase
  • UpdateCaption() : CXTPCaption
  • UpdateCaptionColor() : CXTPFlowGraphNode, CXTPFlowGraphNodeCustom
  • UpdateCaptionText() : CXTPCaption
  • UpdateCategories() : CXTPCalendarEventColorListBox
  • UpdateCharFormat() : CXTPControlComboBoxEditCtrl, CXTPControlEditCtrl
  • UpdateChilds() : CXTPPropertyGridItemFlags
  • UpdateColorRecursive() : CXTPFlowGraphNode, CXTPFlowGraphNodeCustom
  • UpdateColors() : CXTPPaintManager
  • UpdateColorValue() : CXTPSyntaxEditPropertiesPageColor
  • UpdateCommandBars() : CXTPCommandBars
  • UpdateConnectionPoints() : CXTPFlowGraphNode, CXTPFlowGraphNodeCustom
  • UpdateContents() : CXTPTabClientWnd
  • UpdateControlRect() : CXTPResize
  • UpdateControlsFromEvent() : CXTPCalendarEventPropertiesDlg
  • UpdateControlsState() : CXTPCalendarCaptionBarTheme, CXTPCalendarEventPropertiesDlg
  • UpdateCursorPos() : CXTPColorBase, CXTPColorLum, CXTPColorWnd
  • UpdateDate() : CXTPCalendarUtils
  • UpdateDefaultColors() : CXTPExcelTabCtrl
  • UpdateDefaultValues() : CXTPCalendarEventCategories, CXTPCalendarEventLabels
  • UpdateDiagram() : CXTPChartContent
  • UpdateDockingStickers() : CXTPDockingPaneContext
  • UpdateDocTitle() : CXTPTabView
  • UpdateDraggingContents() : CXTPTabClientContext
  • UpdateDwmClientArea() : CXTPCommandBarsFrameHook
  • UpdateEventCategories() : CXTPCalendarData
  • UpdateEventCategoriesDefaultColors() : CXTPCalendarOffice2013Theme, CXTPCalendarPaintManager
  • UpdateEventLabels() : CXTPCalendarData
  • UpdateEventLabelsDefaultColors() : CXTPCalendarOffice2013Theme, CXTPCalendarPaintManager
  • UpdateExpandingState() : CXTPPopupBar
  • UpdateField() : CXTPGridDataManager
  • UpdateFlags() : CXTPPopupBar, CXTPTabClientWnd
  • UpdateFont() : CXTPSyntaxEditPropertiesPageColor
  • UpdateFonts() : CXTPPaintManager
  • UpdateFontValue() : CXTPSyntaxEditPropertiesPageColor
  • UpdateFromManager() : CXTPCalendarRemindersDialog
  • UpdateGlyphs() : CXTPCalendarOffice2013Theme, CXTPCalendarPaintManager
  • UpdateGridRecords() : CXTPGridDataManager
  • UpdateHistoryCombo() : CXTPSyntaxEditFindReplaceDlg
  • UpdateIndexes() : CXTPGridRecords
  • UpdateLabels() : CXTPCalendarEventColorListBox
  • UpdateLayout() : CXTPChartDiagram2D, CXTPChartRadarDiagram
  • UpdateList() : CXTPGridSubListControl
  • UpdateLocation() : CXTPPopupBar
  • UpdateMarkupCaption() : CXTPFlowGraphNode, CXTPFlowGraphNodeCustom
  • UpdateMarkupFont() : CXTPFlowGraphNode
  • UpdateMarkupImage() : CXTPFlowGraphNode
  • UpdateMarkupPointCaption() : CXTPFlowGraphNode
  • UpdateMarkupPointColor() : CXTPFlowGraphNode, CXTPFlowGraphNodeCustom
  • UpdateMarkupPointImage() : CXTPFlowGraphNode
  • UpdateMarkupPointName() : CXTPFlowGraphNode
  • UpdateMDIChildrenTheme() : CXTPMDIFrameWnd
  • UpdateMinMaxRange() : CXTPChartRangeBarSeriesPointView, CXTPChartRangeSplineAreaSeriesPointView, CXTPChartSeriesPointView
  • UpdateMonthDay() : CXTPCalendarUtils
  • UpdateMouseCursor() : CXTPCalendarControl
  • UpdateNextTimeEditByTAB() : CXTPCalendarDayView, CXTPCalendarView
  • UpdateOccIfNeed() : CXTPCalendarReminderForOccurrenceArray
  • UpdateOccIfNeedEx() : CXTPCalendarReminderForOccurrenceArray
  • UpdateOpacity() : CXTPMiniToolBar
  • UpdatePage() : CXTPPropertyPage, CXTPRibbonCustomizeQuickAccessPage
  • UpdatePages() : CXTPPropertySheet
  • UpdatePanes() : CXTPDockingPaneManager
  • UpdatePosition() : CXTPFrameShadow
  • UpdateRange() : CXTPChartAxis, CXTPChartAxisRange, CXTPChartDiagram2DView, CXTPChartDiagramView, CXTPChartRadarDiagramView, CXTPChartStackedBarSeriesView
  • UpdateRecord() : CXTPGridControl, CXTPGridDataManager
  • UpdateRecordField() : CXTPGridRecord
  • UpdateRecurrence() : CXTPCalendarEvent
  • UpdateResourcesLangID() : CXTPResourceManager, CXTPResourceManagerXML
  • UpdateRowInfoInternally() : CXTPSyntaxEditCtrl
  • UpdateRTLCaption() : CXTPPaintManager
  • UpdateSampleColors() : CXTPSyntaxEditPropertiesPageColor, CXTPSyntaxEditPropertiesPageFont
  • UpdateSampleFont() : CXTPSyntaxEditPropertiesPageFont
  • UpdateScrollBar() : CXTPTaskPanel
  • UpdateScrollBars() : CXTPGridView
  • UpdateScrollButtons() : CXTPTaskPanel
  • UpdateScrollInfo() : CXTPRibbonBackstageView
  • UpdateScrollPos() : CXTPSyntaxEditCtrl, CXTPSyntaxEditView
  • UpdateSelColor() : CXTPCalendarEventColorDlg
  • UpdateSelection() : CXTPColorHex
  • UpdateSelectionForRect() : CXTPTreeBase
  • UpdateSeries() : CXTPChartQualitativeScaleTypeMap, CXTPChartScaleTypeMap
  • UpdateSeriesPointArgument() : CXTPChartDateTimeScaleTypeMap, CXTPChartNumericalScaleTypeMap, CXTPChartQualitativeScaleTypeMap, CXTPChartScaleTypeMap, CXTPChartTimeScaleTypeMap
  • UpdateShadow() : CXTPControlPopup
  • UpdateShortcuts() : CXTPCommandBar
  • UpdateSiblings() : CXTPSyntaxEditView
  • UpdateSiblingScrollPos() : CXTPSyntaxEditView
  • UpdateStartEndDatesFromPatternExceptions() : CXTPCalendarEvent
  • UpdateState() : CXTPPopupControl
  • UpdateSubList() : CXTPGridControl
  • UpdateSysColors() : CXTPAuxData
  • UpdateSysMetrics() : CXTPAuxData
  • UpdateTabContextWindow() : CXTPTabClientContext
  • UpdateTabFocusRect() : CXTPTabClientContext
  • UpdateTabLabel() : CXTPTabExBase
  • UpdateTabs() : CXTPTabToolBar
  • UpdateTabSticker() : CXTPTabClientContext
  • UpdateTextBlocks() : CXTPSyntaxEditLexTextSchema
  • UpdateTextFont() : CXTPSyntaxEditPaintManager
  • UpdateTime() : CXTPCalendarUtils
  • UpdateToolTip() : CXTPTabExBase
  • UpdateValue() : CXTPGridGroupRow, CXTPGridRecordItem
  • UpdateWindowOpacity() : CXTPDockingPaneMiniWnd
  • UpdateWindowPosition() : CXTPFlowGraphNode, CXTPFlowGraphNodeCustom
  • UppercaseSelection() : CXTPSyntaxEditCtrl
  • UseDefaultOnLoad() : CXTPPropExchange
  • UseDefaultOnSave() : CXTPPropExchange
  • UseGridCustomHeap() : CXTPGridControl
  • UseOfficeFont() : CXTPAuxData, CXTPDockingPanePaintManager, CXTPPaintManager
  • UseOneLine() : CXTPCalendarCaptionBarControl
  • UserAction_OnExpandDay() : CXTPCalendarViewDay
  • UserAction_OnScrollAllDayEvents() : CXTPCalendarDayViewGroup
  • UserAction_OnScrollDay() : CXTPCalendarDayViewGroup
  • UseRowBatchAllocation() : CXTPGridControl
  • UseSplitterTracker() : CXTPDockingPaneManager, CXTPTabClientWnd
  • UseSystemDecimalSymbol() : CXTPPropertyGridItemDouble
  • UseSystemKeyNameText() : CXTPShortcutManager
  • UseWinTheme() : CXTPEditTheme
  • UseWinThemes() : CXTPMarqueeCtrl, CXTPMarqueeCtrlPaintManager, CXTPProgressCtrlPaintManager
  • UseWinXPThemes() : CXTPHeaderCtrlTheme
  • UsingWinThemes() : CXTPMarqueeCtrlPaintManager, CXTPProgressCtrlPaintManager


Toolkit Pro: Class Members - Functions

Here is a list of all documented functions with links to the class documentation for each member:

- v -

  • ValidateCol() : CXTPSyntaxEditCtrl
  • ValidateXML() : CXTPMarkupContext
  • ValueToInternal() : CXTPChartDateTimeScaleTypeMap, CXTPChartNumericalScaleTypeMap, CXTPChartQualitativeScaleTypeMap, CXTPChartScaleTypeMap, CXTPChartTimeScaleTypeMap
  • ValueToPoint() : CXTPChartDiagram2DAxisView
  • VariantChangeTypeEx() : CXTPGridControlLocale
  • VerifyVersion() : CXTPSystemVersion
  • VerifyWinVer() : CXTPSystemVersion
  • VertEventScroll() : CXTPCalendarDayView
  • Vertex() : CXTPOpenGLUtils
  • VerticalLine() : CXTPPaintManager, CXTPTabBaseTheme


Toolkit Pro: Class Members - Functions

Here is a list of all documented functions with links to the class documentation for each member:

- w -

  • Wait() : CXTPSimpleEvent
  • WaitPathChangedEvent() : CXTPDirWatcher
  • WaitUntilReady() : CXTPWebBrowserCtrl
  • WebView2_ContainsFullScreenElementChanged() : IXTPWebBrowserEventSink
  • WebView2_ContentLoading() : IXTPWebBrowserEventSink
  • WebView2_DocumentTitleChanged() : IXTPWebBrowserEventSink
  • WebView2_FrameNavigationCompleted() : IXTPWebBrowserEventSink
  • WebView2_FrameNavigationStarting() : IXTPWebBrowserEventSink
  • WebView2_HistoryChanged() : IXTPWebBrowserEventSink
  • WebView2_NavigationCompleted() : IXTPWebBrowserEventSink
  • WebView2_NavigationStarting() : IXTPWebBrowserEventSink
  • WebView2_NewWindowRequested() : IXTPWebBrowserEventSink
  • WebView2_PermissionRequested() : IXTPWebBrowserEventSink
  • WebView2_ProcessFailed() : IXTPWebBrowserEventSink
  • WebView2_ScriptDialogOpening() : IXTPWebBrowserEventSink
  • WebView2_SourceChanged() : IXTPWebBrowserEventSink
  • WebView2_WebResourceRequested() : IXTPWebBrowserEventSink
  • WebView2_WindowCloseRequested() : IXTPWebBrowserEventSink
  • WeekView_IsShowEndDate() : CXTPCalendarControl
  • WeekView_IsShowTimeAsClocks() : CXTPCalendarControl
  • WeekView_SetShowEndDate() : CXTPCalendarControl
  • WeekView_SetShowTimeAsClocks() : CXTPCalendarControl
  • Width() : CXTPResizeRect
  • Win95Classic() : CXTPShellSettings
  • WorkspaceToScreen() : CXTPTabClientWnd
  • Write() : CXTPImageList, CXTPPropExchange, CXTPPropExchangeArchive
  • WriteCfgFile() : CXTPSyntaxEditColorTheme
  • WriteCount() : CXTPPropExchange, CXTPPropExchangeArchive
  • WriteList() : CXTPRecentFileList
  • WriteProfileBinary() : CXTPRegistryManager
  • WriteProfileColor() : CXTPRegistryManager
  • WriteProfileDouble() : CXTPRegistryManager
  • WriteProfileDword() : CXTPRegistryManager
  • WriteProfileInt() : CXTPRegistryManager
  • WriteProfilePoint() : CXTPRegistryManager
  • WriteProfileRect() : CXTPRegistryManager
  • WriteProfileSize() : CXTPRegistryManager
  • WriteProfileString() : CXTPRegistryManager
  • WriteRegistryValues() : CXTPSyntaxEditPropertiesPageColor, CXTPSyntaxEditPropertiesPageEdit, CXTPSyntaxEditPropertiesPageFont
  • WriteString() : CXTPMemFile


Toolkit Pro: Class Members - Functions

Here is a list of all documented functions with links to the class documentation for each member:

- x -

  • XTP_CALENDAR_HITTESTINFO() : XTP_CALENDAR_HITTESTINFO
  • XTP_CALENDAR_HITTESTINFO_TIMELINE_VIEW() : XTP_CALENDAR_HITTESTINFO_TIMELINE_VIEW
  • XTP_CALENDAR_PATTERN_END() : XTP_CALENDAR_PATTERN_END
  • XTP_CALENDAR_RECURRENCE_OPTIONS() : XTP_CALENDAR_RECURRENCE_OPTIONS
  • XTP_CALENDAR_VIEWSELECTION() : XTP_CALENDAR_VIEWSELECTION
  • XTP_EDIT_ACDATA() : XTP_EDIT_ACDATA
  • XTP_EDIT_FONTOPTIONS() : XTP_EDIT_FONTOPTIONS
  • XTP_EDIT_TEXTBLOCK() : XTP_EDIT_TEXTBLOCK
  • XTP_GRIDDATAMANAGER_COM_ERROR() : XTP_GRIDDATAMANAGER_COM_ERROR
  • XTP_SLIDERTICKS() : XTP_SLIDERTICKS
  • XTP_TAGCLOUDTAG() : XTP_TAGCLOUDTAG
  • XTPGetHeaderCtrl() : CXTPListBase
  • XTPGetVersion() : CXTPAuxData


Toolkit Pro: Class Members - Functions

Here is a list of all documented functions with links to the class documentation for each member:

- z -

  • ZoomArcBall() : CXTPChart3dDiagram
  • ZoomFitToWindow() : CXTPFlowGraphControl
  • ZoomToRect() : CXTPFlowGraphControl
  • ZoomToSelection() : CXTPFlowGraphControl


Toolkit Pro: Class Members - Functions

Here is a list of all documented functions with links to the class documentation for each member:

- ~ -

  • ~CCaptionButton() : CXTPSkinObjectFrame::CCaptionButton
  • ~CCheckListState() : CXTPCheckListBox::CCheckListState
  • ~CExclusiveLock() : CXTPRWCriticalSection::CExclusiveLock
  • ~CLock() : CXTPSimpleCriticalSection::CLock
  • ~CManageState() : CXTPResourceManager::CManageState
  • ~CMonthViewGrid() : CXTPCalendarMonthView::CMonthViewGrid
  • ~CRepositionContext() : CXTPTaskPanel::CRepositionContext
  • ~CRowIndexer() : CXTPTabManager::CRowIndexer
  • ~CSelectionChangedContext() : CXTPCalendarView::CSelectionChangedContext
  • ~CSharedLock() : CXTPRWCriticalSection::CSharedLock
  • ~CShellMalloc() : CXTPShellPidl::CShellMalloc
  • ~CShellSpecialFolder() : CXTPShellPidl::CShellSpecialFolder
  • ~CStringPtrArray() : CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager::CStringPtrArray
  • ~CTimeLineViewPart() : CXTPCalendarPaintManager
  • ~CUpdateContext() : CXTPCalendarControl::CUpdateContext, CXTPGridControl::CUpdateContext
  • ~CViewChangedContext() : CXTPCalendarControl::CViewChangedContext
  • ~CXTPActiveScriptEngine() : CXTPActiveScriptEngine
  • ~CXTPActiveScriptStdRuntime() : CXTPActiveScriptStdRuntime
  • ~CXTPAlphaWnd() : CXTPAlphaWnd
  • ~CXTPAnimationDC() : CXTPAnimationDC
  • ~CXTPArrayT() : CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE >
  • ~CXTPAsyncGuard() : CXTPAsyncGuard< Adaptee, RWLock >
  • ~CXTPAutoResetValue() : CXTPAutoResetValue< _TValue >
  • ~CXTPAuxData() : CXTPAuxData
  • ~CXTPBrowseButton() : CXTPBrowseButton
  • ~CXTPBrowseDialog() : CXTPBrowseDialog
  • ~CXTPBrowseEdit() : CXTPBrowseEdit
  • ~CXTPBrush() : CXTPBrush
  • ~CXTPButton() : CXTPButton
  • ~CXTPButtonTheme() : CXTPButtonTheme
  • ~CXTPCalendarCaptionBarControl() : CXTPCalendarCaptionBarControl
  • ~CXTPCalendarCaptionBarNativeWindows10Theme() : CXTPCalendarCaptionBarNativeWindows10Theme
  • ~CXTPCalendarCaptionBarNativeWindows11Theme() : CXTPCalendarCaptionBarNativeWindows11Theme
  • ~CXTPCalendarCaptionBarOffice2000Theme() : CXTPCalendarCaptionBarOffice2000Theme
  • ~CXTPCalendarCaptionBarOffice2003Theme() : CXTPCalendarCaptionBarOffice2003Theme
  • ~CXTPCalendarCaptionBarOffice2013Theme() : CXTPCalendarCaptionBarOffice2013Theme
  • ~CXTPCalendarCaptionBarOfficeXPTheme() : CXTPCalendarCaptionBarOfficeXPTheme
  • ~CXTPCalendarCaptionBarPaintManager() : CXTPCalendarCaptionBarPaintManager
  • ~CXTPCalendarCaptionBarResourceTheme() : CXTPCalendarCaptionBarResourceTheme
  • ~CXTPCalendarCaptionBarTheme() : CXTPCalendarCaptionBarTheme
  • ~CXTPCalendarCaptionBarThemePart() : CXTPCalendarCaptionBarThemePart
  • ~CXTPCalendarCaptionBarVisualStudio2015Theme() : CXTPCalendarCaptionBarVisualStudio2015Theme
  • ~CXTPCalendarCaptionBarVisualStudio2017Theme() : CXTPCalendarCaptionBarVisualStudio2017Theme
  • ~CXTPCalendarCaptionBarVisualStudio2019Theme() : CXTPCalendarCaptionBarVisualStudio2019Theme
  • ~CXTPCalendarCaptionBarVisualStudio2022Theme() : CXTPCalendarCaptionBarVisualStudio2022Theme
  • ~CXTPCalendarComboBoxBase() : CXTPCalendarComboBoxBase
  • ~CXTPCalendarControl() : CXTPCalendarControl
  • ~CXTPCalendarController() : CXTPCalendarController
  • ~CXTPCalendarControlView() : CXTPCalendarControlView
  • ~CXTPCalendarCustomDataProvider() : CXTPCalendarCustomDataProvider
  • ~CXTPCalendarCustomProperties() : CXTPCalendarCustomProperties
  • ~CXTPCalendarData() : CXTPCalendarData
  • ~CXTPCalendarDatabaseDataProvider() : CXTPCalendarDatabaseDataProvider
  • ~CXTPCalendarDayView() : CXTPCalendarDayView
  • ~CXTPCalendarDayViewDay() : CXTPCalendarDayViewDay
  • ~CXTPCalendarDayViewEvent() : CXTPCalendarDayViewEvent
  • ~CXTPCalendarDayViewGroup() : CXTPCalendarDayViewGroup
  • ~CXTPCalendarDayViewTimeScale() : CXTPCalendarDayViewTimeScale
  • ~CXTPCalendarEvent() : CXTPCalendarEvent
  • ~CXTPCalendarEventCategories() : CXTPCalendarEventCategories
  • ~CXTPCalendarEventCategory() : CXTPCalendarEventCategory
  • ~CXTPCalendarEventCategoryComboBox() : CXTPCalendarEventCategoryComboBox
  • ~CXTPCalendarEventCategoryIDs() : CXTPCalendarEventCategoryIDs
  • ~CXTPCalendarEventColorListBox() : CXTPCalendarEventColorListBox
  • ~CXTPCalendarEventLabel() : CXTPCalendarEventLabel
  • ~CXTPCalendarEventLabels() : CXTPCalendarEventLabels
  • ~CXTPCalendarEventPropertiesDlg() : CXTPCalendarEventPropertiesDlg
  • ~CXTPCalendarEventRecurrenceDlg() : CXTPCalendarEventRecurrenceDlg
  • ~CXTPCalendarEvents() : CXTPCalendarEvents
  • ~CXTPCalendarIconIDs() : CXTPCalendarIconIDs
  • ~CXTPCalendarMemoryDataProvider() : CXTPCalendarMemoryDataProvider
  • ~CXTPCalendarMonthView() : CXTPCalendarMonthView
  • ~CXTPCalendarMonthViewDay() : CXTPCalendarMonthViewDay
  • ~CXTPCalendarMonthViewEvent() : CXTPCalendarMonthViewEvent
  • ~CXTPCalendarMonthViewGroup() : CXTPCalendarMonthViewGroup
  • ~CXTPCalendarMsgNotifier() : CXTPCalendarMsgNotifier
  • ~CXTPCalendarNativeWindows10Theme() : CXTPCalendarNativeWindows10Theme
  • ~CXTPCalendarNativeWindows11Theme() : CXTPCalendarNativeWindows11Theme
  • ~CXTPCalendarOccurSeriesChooseDlg() : CXTPCalendarOccurSeriesChooseDlg
  • ~CXTPCalendarOffice2000Theme() : CXTPCalendarOffice2000Theme
  • ~CXTPCalendarOffice2003Theme() : CXTPCalendarOffice2003Theme
  • ~CXTPCalendarOffice2013Theme() : CXTPCalendarOffice2013Theme
  • ~CXTPCalendarOfficeXPTheme() : CXTPCalendarOfficeXPTheme
  • ~CXTPCalendarOptions() : CXTPCalendarOptions
  • ~CXTPCalendarPageSetupDialog() : CXTPCalendarPageSetupDialog
  • ~CXTPCalendarPaintManager() : CXTPCalendarPaintManager
  • ~CXTPCalendarPtrCollectionT() : CXTPCalendarPtrCollectionT< _TObject >
  • ~CXTPCalendarRecurrencePattern() : CXTPCalendarRecurrencePattern
  • ~CXTPCalendarReminder() : CXTPCalendarReminder
  • ~CXTPCalendarReminderForOccurrenceArray() : CXTPCalendarReminderForOccurrenceArray
  • ~CXTPCalendarRemindersDialog() : CXTPCalendarRemindersDialog
  • ~CXTPCalendarRemindersManager() : CXTPCalendarRemindersManager
  • ~CXTPCalendarResource() : CXTPCalendarResource
  • ~CXTPCalendarResources() : CXTPCalendarResources
  • ~CXTPCalendarResourcesManager() : CXTPCalendarResourcesManager
  • ~CXTPCalendarResourcesNf() : CXTPCalendarResourcesNf
  • ~CXTPCalendarResourceTheme() : CXTPCalendarResourceTheme
  • ~CXTPCalendarSchedule() : CXTPCalendarSchedule
  • ~CXTPCalendarSchedules() : CXTPCalendarSchedules
  • ~CXTPCalendarShadowDrawer() : CXTPCalendarShadowDrawer
  • ~CXTPCalendarThemeCustomizableXValueT() : CXTPCalendarThemeCustomizableXValueT< _TValue, _TValueRef >
  • ~CXTPCalendarThemeFontValue() : CXTPCalendarThemeFontValue
  • ~CXTPCalendarTimeLineView() : CXTPCalendarTimeLineView
  • ~CXTPCalendarTimeLineViewGroup() : CXTPCalendarTimeLineViewGroup
  • ~CXTPCalendarTimeLineViewTimeScale() : CXTPCalendarTimeLineViewTimeScale
  • ~CXTPCalendarTimeZone() : CXTPCalendarTimeZone
  • ~CXTPCalendarTimeZones() : CXTPCalendarTimeZones
  • ~CXTPCalendarTip() : CXTPCalendarTip
  • ~CXTPCalendarTLV_TimeScaleParams() : CXTPCalendarTLV_TimeScaleParams
  • ~CXTPCalendarTLV_TimeScaleParams_Day() : CXTPCalendarTLV_TimeScaleParams_Day
  • ~CXTPCalendarTLV_TimeScaleParams_Month() : CXTPCalendarTLV_TimeScaleParams_Month
  • ~CXTPCalendarTLV_TimeScaleParams_Week() : CXTPCalendarTLV_TimeScaleParams_Week
  • ~CXTPCalendarTLV_TimeScaleParams_WorkWeek() : CXTPCalendarTLV_TimeScaleParams_WorkWeek
  • ~CXTPCalendarTypedPtrAutoDeleteArray() : CXTPCalendarTypedPtrAutoDeleteArray< BASE_CLASS, PTR_TYPE >
  • ~CXTPCalendarTypedPtrAutoDeleteMap() : CXTPCalendarTypedPtrAutoDeleteMap< KEY, TPtr >
  • ~CXTPCalendarView() : CXTPCalendarView
  • ~CXTPCalendarViewDay() : CXTPCalendarViewDay
  • ~CXTPCalendarViewDayT() : CXTPCalendarViewDayT< _TView, _TViewGroup, XTP_CALENDAR_HITTESTINFO, _TPThis >
  • ~CXTPCalendarViewEvent() : CXTPCalendarViewEvent
  • ~CXTPCalendarViewEvents() : CXTPCalendarViewEvents
  • ~CXTPCalendarViewEventSubjectEditor() : CXTPCalendarViewEventSubjectEditor
  • ~CXTPCalendarViewEventSubjectEditorColored() : CXTPCalendarViewEventSubjectEditorColored
  • ~CXTPCalendarViewEventT() : CXTPCalendarViewEventT< _TViewGroup >
  • ~CXTPCalendarViewGroup() : CXTPCalendarViewGroup
  • ~CXTPCalendarViewGroupT() : CXTPCalendarViewGroupT< _TViewDay, _TViewEvent, _TPThis >
  • ~CXTPCalendarViewPart() : CXTPCalendarViewPart
  • ~CXTPCalendarViewPartBrushValue() : CXTPCalendarViewPartBrushValue
  • ~CXTPCalendarViewPartCustomizableValueT() : CXTPCalendarViewPartCustomizableValueT< _TValue >
  • ~CXTPCalendarViewT() : CXTPCalendarViewT< _TViewDay >
  • ~CXTPCalendarVisualStudio2015Theme() : CXTPCalendarVisualStudio2015Theme
  • ~CXTPCalendarVisualStudio2017Theme() : CXTPCalendarVisualStudio2017Theme
  • ~CXTPCalendarVisualStudio2019Theme() : CXTPCalendarVisualStudio2019Theme
  • ~CXTPCalendarVisualStudio2022Theme() : CXTPCalendarVisualStudio2022Theme
  • ~CXTPCalendarWeekView() : CXTPCalendarWeekView
  • ~CXTPCalendarWeekViewDay() : CXTPCalendarWeekViewDay
  • ~CXTPCalendarWeekViewEvent() : CXTPCalendarWeekViewEvent
  • ~CXTPCalendarWeekViewGroup() : CXTPCalendarWeekViewGroup
  • ~CXTPCaption() : CXTPCaption
  • ~CXTPCaptionPopupWnd() : CXTPCaptionPopupWnd
  • ~CXTPChart3dDeviceContext() : CXTPChart3dDeviceContext
  • ~CXTPChart3dDiagram() : CXTPChart3dDiagram
  • ~CXTPChart3dFunnelSeriesLabelView() : CXTPChart3dFunnelSeriesLabelView
  • ~CXTPChart3dFunnelSeriesPointView() : CXTPChart3dFunnelSeriesPointView
  • ~CXTPChart3dPieSeriesLabelView() : CXTPChart3dPieSeriesLabelView
  • ~CXTPChart3dPieSeriesPointView() : CXTPChart3dPieSeriesPointView
  • ~CXTPChart3dPyramidSeriesLabelView() : CXTPChart3dPyramidSeriesLabelView
  • ~CXTPChart3dPyramidSeriesPointView() : CXTPChart3dPyramidSeriesPointView
  • ~CXTPChartAppearance() : CXTPChartAppearance
  • ~CXTPChartAreaSeriesStyle() : CXTPChartAreaSeriesStyle
  • ~CXTPChartAxis() : CXTPChartAxis
  • ~CXTPChartAxisAppearance() : CXTPChartAxisAppearance
  • ~CXTPChartAxisConstantLine() : CXTPChartAxisConstantLine
  • ~CXTPChartAxisConstantLines() : CXTPChartAxisConstantLines
  • ~CXTPChartAxisCustomLabel() : CXTPChartAxisCustomLabel
  • ~CXTPChartAxisCustomLabels() : CXTPChartAxisCustomLabels
  • ~CXTPChartAxisGridLines() : CXTPChartAxisGridLines
  • ~CXTPChartAxisLabel() : CXTPChartAxisLabel
  • ~CXTPChartAxisRange() : CXTPChartAxisRange
  • ~CXTPChartAxisStrip() : CXTPChartAxisStrip
  • ~CXTPChartAxisStrips() : CXTPChartAxisStrips
  • ~CXTPChartAxisTickMarks() : CXTPChartAxisTickMarks
  • ~CXTPChartAxisTitle() : CXTPChartAxisTitle
  • ~CXTPChartBarSeriesLabel() : CXTPChartBarSeriesLabel
  • ~CXTPChartBarSeriesStyle() : CXTPChartBarSeriesStyle
  • ~CXTPChartBorder() : CXTPChartBorder
  • ~CXTPChartBubbleSeriesLabel() : CXTPChartBubbleSeriesLabel
  • ~CXTPChartBubbleSeriesStyle() : CXTPChartBubbleSeriesStyle
  • ~CXTPChartCandleStickSeriesStyle() : CXTPChartCandleStickSeriesStyle
  • ~CXTPChartContainer() : CXTPChartContainer
  • ~CXTPChartContent() : CXTPChartContent
  • ~CXTPChartContentAppearance() : CXTPChartContentAppearance
  • ~CXTPChartControl() : CXTPChartControl
  • ~CXTPChartDeviceCommand() : CXTPChartDeviceCommand
  • ~CXTPChartDeviceContext() : CXTPChartDeviceContext
  • ~CXTPChartDiagram2D() : CXTPChartDiagram2D
  • ~CXTPChartDiagram2DAppearance() : CXTPChartDiagram2DAppearance
  • ~CXTPChartDiagram2DAxisView() : CXTPChartDiagram2DAxisView
  • ~CXTPChartDiagram2DSeriesLabel() : CXTPChartDiagram2DSeriesLabel
  • ~CXTPChartDiagram2DSeriesStyle() : CXTPChartDiagram2DSeriesStyle
  • ~CXTPChartDiagram3DAppearance() : CXTPChartDiagram3DAppearance
  • ~CXTPChartElement() : CXTPChartElement
  • ~CXTPChartElementAppearance() : CXTPChartElementAppearance
  • ~CXTPChartElementCollection() : CXTPChartElementCollection
  • ~CXTPChartElementView() : CXTPChartElementView
  • ~CXTPChartFastLineSeriesStyle() : CXTPChartFastLineSeriesStyle
  • ~CXTPChartFinanceStyleAppearance() : CXTPChartFinanceStyleAppearance
  • ~CXTPChartFont() : CXTPChartFont
  • ~CXTPChartFunnelSeriesLabelBase() : CXTPChartFunnelSeriesLabelBase
  • ~CXTPChartFunnelSeriesPointViewBase() : CXTPChartFunnelSeriesPointViewBase
  • ~CXTPChartFunnelSeriesStyleBase() : CXTPChartFunnelSeriesStyleBase
  • ~CXTPChartFunnelSeriesViewBase() : CXTPChartFunnelSeriesViewBase
  • ~CXTPChartGanttSeriesStyle() : CXTPChartGanttSeriesStyle
  • ~CXTPChartHighLowSeriesStyle() : CXTPChartHighLowSeriesStyle
  • ~CXTPChartLegend() : CXTPChartLegend
  • ~CXTPChartLegendItemView() : CXTPChartLegendItemView
  • ~CXTPChartLegendView() : CXTPChartLegendView
  • ~CXTPChartLineSeriesStyle() : CXTPChartLineSeriesStyle
  • ~CXTPChartMarker() : CXTPChartMarker
  • ~CXTPChartMarkupElementDeviceCommand() : CXTPChartMarkupElementDeviceCommand
  • ~CXTPChartNumberFormat() : CXTPChartNumberFormat
  • ~CXTPChartPalette() : CXTPChartPalette
  • ~CXTPChartPanel() : CXTPChartPanel
  • ~CXTPChartPanelCollection() : CXTPChartPanelCollection
  • ~CXTPChartPieBase() : CXTPChartPieBase
  • ~CXTPChartPieDeviceCommandImpl() : CXTPChartPieDeviceCommandImpl
  • ~CXTPChartPieSeriesLabelBase() : CXTPChartPieSeriesLabelBase
  • ~CXTPChartPieSeriesPointViewBase() : CXTPChartPieSeriesPointViewBase
  • ~CXTPChartPieSeriesStyleBase() : CXTPChartPieSeriesStyleBase
  • ~CXTPChartPieSeriesViewBase() : CXTPChartPieSeriesViewBase
  • ~CXTPChartPieStyleAppearance() : CXTPChartPieStyleAppearance
  • ~CXTPChartPointSeriesLabel() : CXTPChartPointSeriesLabel
  • ~CXTPChartPointSeriesStyle() : CXTPChartPointSeriesStyle
  • ~CXTPChartPyramidSeriesLabelBase() : CXTPChartPyramidSeriesLabelBase
  • ~CXTPChartPyramidSeriesPointViewBase() : CXTPChartPyramidSeriesPointViewBase
  • ~CXTPChartPyramidSeriesStyleBase() : CXTPChartPyramidSeriesStyleBase
  • ~CXTPChartPyramidSeriesViewBase() : CXTPChartPyramidSeriesViewBase
  • ~CXTPChartQualitativeScaleTypeMap() : CXTPChartQualitativeScaleTypeMap
  • ~CXTPChartRadarAreaSeriesStyle() : CXTPChartRadarAreaSeriesStyle
  • ~CXTPChartRadarAxisView() : CXTPChartRadarAxisView
  • ~CXTPChartRadarAxisXView() : CXTPChartRadarAxisXView
  • ~CXTPChartRadarAxisYView() : CXTPChartRadarAxisYView
  • ~CXTPChartRadarDiagram() : CXTPChartRadarDiagram
  • ~CXTPChartRadarDiagramSeriesStyle() : CXTPChartRadarDiagramSeriesStyle
  • ~CXTPChartRadarLineSeriesStyle() : CXTPChartRadarLineSeriesStyle
  • ~CXTPChartRadarPointSeriesLabel() : CXTPChartRadarPointSeriesLabel
  • ~CXTPChartRadarPointSeriesStyle() : CXTPChartRadarPointSeriesStyle
  • ~CXTPChartRadarSplineAreaSeriesStyle() : CXTPChartRadarSplineAreaSeriesStyle
  • ~CXTPChartRadarSplineSeriesStyle() : CXTPChartRadarSplineSeriesStyle
  • ~CXTPChartRangeAreaSeriesLabel() : CXTPChartRangeAreaSeriesLabel
  • ~CXTPChartRangeBarSeriesLabel() : CXTPChartRangeBarSeriesLabel
  • ~CXTPChartRangeBarSeriesStyle() : CXTPChartRangeBarSeriesStyle
  • ~CXTPChartRangeSplineAreaSeriesStyle() : CXTPChartRangeSplineAreaSeriesStyle
  • ~CXTPChartScaleTypeMap() : CXTPChartScaleTypeMap
  • ~CXTPChartScatterLineSeriesStyle() : CXTPChartScatterLineSeriesStyle
  • ~CXTPChartSeries() : CXTPChartSeries
  • ~CXTPChartSeriesCollection() : CXTPChartSeriesCollection
  • ~CXTPChartSeriesLabel() : CXTPChartSeriesLabel
  • ~CXTPChartSeriesPoint() : CXTPChartSeriesPoint
  • ~CXTPChartSeriesPointCollection() : CXTPChartSeriesPointCollection
  • ~CXTPChartSeriesStyle() : CXTPChartSeriesStyle
  • ~CXTPChartSplineAreaSeriesStyle() : CXTPChartSplineAreaSeriesStyle
  • ~CXTPChartSplineSeriesStyle() : CXTPChartSplineSeriesStyle
  • ~CXTPChartStackedAreaSeriesStyle() : CXTPChartStackedAreaSeriesStyle
  • ~CXTPChartStackedBarSeriesStyle() : CXTPChartStackedBarSeriesStyle
  • ~CXTPChartStackedSplineAreaSeriesStyle() : CXTPChartStackedSplineAreaSeriesStyle
  • ~CXTPChartStepAreaSeriesStyle() : CXTPChartStepAreaSeriesStyle
  • ~CXTPChartStepLineSeriesStyle() : CXTPChartStepLineSeriesStyle
  • ~CXTPChartTextPainterBase() : CXTPChartTextPainterBase
  • ~CXTPChartTitle() : CXTPChartTitle
  • ~CXTPChartTitleCollection() : CXTPChartTitleCollection
  • ~CXTPCheckListBox() : CXTPCheckListBox
  • ~CXTPColorBase() : CXTPColorBase
  • ~CXTPColorDialog() : CXTPColorDialog
  • ~CXTPColorHex() : CXTPColorHex
  • ~CXTPColorLum() : CXTPColorLum
  • ~CXTPColorPageCustom() : CXTPColorPageCustom
  • ~CXTPColorPageStandard() : CXTPColorPageStandard
  • ~CXTPColorPicker() : CXTPColorPicker
  • ~CXTPColorPopup() : CXTPColorPopup
  • ~CXTPColorSelectorCtrl() : CXTPColorSelectorCtrl
  • ~CXTPColorSetCaptionButton() : CXTPColorSetCaptionButton
  • ~CXTPColorSetStateCheckBox() : CXTPColorSetStateCheckBox
  • ~CXTPColorSetStateCheckMark() : CXTPColorSetStateCheckMark
  • ~CXTPColorSetStateComboBox() : CXTPColorSetStateComboBox
  • ~CXTPColorWnd() : CXTPColorWnd
  • ~CXTPComboBox() : CXTPComboBox
  • ~CXTPComboBoxTheme() : CXTPComboBoxTheme
  • ~CXTPComboBoxThemeDefault() : CXTPComboBoxThemeDefault
  • ~CXTPComboBoxThemeNativeWindows10() : CXTPComboBoxThemeNativeWindows10
  • ~CXTPComboBoxThemeNativeWindows11() : CXTPComboBoxThemeNativeWindows11
  • ~CXTPComboBoxThemeOffice2000() : CXTPComboBoxThemeOffice2000
  • ~CXTPComboBoxThemeOffice2003() : CXTPComboBoxThemeOffice2003
  • ~CXTPComboBoxThemeOffice2013() : CXTPComboBoxThemeOffice2013
  • ~CXTPComboBoxThemeOfficeXPFlat() : CXTPComboBoxThemeOfficeXPFlat
  • ~CXTPComboBoxThemeResource() : CXTPComboBoxThemeResource
  • ~CXTPComboBoxThemeVisualStudio() : CXTPComboBoxThemeVisualStudio
  • ~CXTPComboBoxThemeVisualStudio2010() : CXTPComboBoxThemeVisualStudio2010
  • ~CXTPComboBoxThemeVisualStudio2012() : CXTPComboBoxThemeVisualStudio2012
  • ~CXTPComboBoxThemeVisualStudio2015() : CXTPComboBoxThemeVisualStudio2015
  • ~CXTPComboBoxThemeVisualStudio2017() : CXTPComboBoxThemeVisualStudio2017
  • ~CXTPComboBoxThemeVisualStudio2019() : CXTPComboBoxThemeVisualStudio2019
  • ~CXTPComboBoxThemeVisualStudio2022() : CXTPComboBoxThemeVisualStudio2022
  • ~CXTPComInitializer() : CXTPComInitializer
  • ~CXTPCommandBar() : CXTPCommandBar
  • ~CXTPCommandBarList() : CXTPCommandBarList
  • ~CXTPCommandBars() : CXTPCommandBars
  • ~CXTPCommandBarScrollBarCtrl() : CXTPCommandBarScrollBarCtrl
  • ~CXTPCommandBarsFrameHook() : CXTPCommandBarsFrameHook
  • ~CXTPCommandBarsModernUITheme() : CXTPCommandBarsModernUITheme
  • ~CXTPCommandBarsNativeWindows10Theme() : CXTPCommandBarsNativeWindows10Theme
  • ~CXTPCommandBarsNativeWindows11Theme() : CXTPCommandBarsNativeWindows11Theme
  • ~CXTPCommandBarsNativeXPTheme() : CXTPCommandBarsNativeXPTheme
  • ~CXTPCommandBarsOffice2003Theme() : CXTPCommandBarsOffice2003Theme
  • ~CXTPCommandBarsOffice2013Theme() : CXTPCommandBarsOffice2013Theme
  • ~CXTPCommandBarsSiteBase() : CXTPCommandBarsSiteBase< TBase >
  • ~CXTPCommandBarsVisualStudio2012Theme() : CXTPCommandBarsVisualStudio2012Theme
  • ~CXTPCommandBarsVisualStudio2015Theme() : CXTPCommandBarsVisualStudio2015Theme
  • ~CXTPCommandBarsVisualStudio2017Theme() : CXTPCommandBarsVisualStudio2017Theme
  • ~CXTPCommandBarsVisualStudio2019Theme() : CXTPCommandBarsVisualStudio2019Theme
  • ~CXTPCommandBarsVisualStudio2022Theme() : CXTPCommandBarsVisualStudio2022Theme
  • ~CXTPControl() : CXTPControl
  • ~CXTPControlAction() : CXTPControlAction
  • ~CXTPControlActions() : CXTPControlActions
  • ~CXTPControlButton() : CXTPControlButton
  • ~CXTPControlComboBox() : CXTPControlComboBox
  • ~CXTPControlCustom() : CXTPControlCustom
  • ~CXTPControlEdit() : CXTPControlEdit
  • ~CXTPControlFontComboBox() : CXTPControlFontComboBox
  • ~CXTPControlGallery() : CXTPControlGallery
  • ~CXTPControlGalleryItem() : CXTPControlGalleryItem
  • ~CXTPControlGalleryItems() : CXTPControlGalleryItems
  • ~CXTPControlListBox() : CXTPControlListBox
  • ~CXTPControlMarkupLabel() : CXTPControlMarkupLabel
  • ~CXTPControlPopup() : CXTPControlPopup
  • ~CXTPControlPopupColor() : CXTPControlPopupColor
  • ~CXTPControls() : CXTPControls
  • ~CXTPControlScrollBar() : CXTPControlScrollBar
  • ~CXTPControlSizeComboBox() : CXTPControlSizeComboBox
  • ~CXTPControlSlider() : CXTPControlSlider
  • ~CXTPControlTabWorkspace() : CXTPControlTabWorkspace
  • ~CXTPCriticalSection() : CXTPCriticalSection
  • ~CXTPCustomizeCommandsPage() : CXTPCustomizeCommandsPage
  • ~CXTPCustomizeKeyboardPage() : CXTPCustomizeKeyboardPage
  • ~CXTPCustomizeMenusPage() : CXTPCustomizeMenusPage
  • ~CXTPCustomizeOptionsPage() : CXTPCustomizeOptionsPage
  • ~CXTPCustomizeSheet() : CXTPCustomizeSheet
  • ~CXTPCustomizeToolbarsPage() : CXTPCustomizeToolbarsPage
  • ~CXTPDatePickerButton() : CXTPDatePickerButton
  • ~CXTPDatePickerControl() : CXTPDatePickerControl
  • ~CXTPDatePickerDaysCollection() : CXTPDatePickerDaysCollection
  • ~CXTPDatePickerItemDay() : CXTPDatePickerItemDay
  • ~CXTPDatePickerItemMonth() : CXTPDatePickerItemMonth
  • ~CXTPDatePickerList() : CXTPDatePickerList
  • ~CXTPDatePickerPaintManager() : CXTPDatePickerPaintManager
  • ~CXTPDatePickerThemeNativeWindows10() : CXTPDatePickerThemeNativeWindows10
  • ~CXTPDatePickerThemeNativeWindows11() : CXTPDatePickerThemeNativeWindows11
  • ~CXTPDatePickerThemeOffice2000() : CXTPDatePickerThemeOffice2000
  • ~CXTPDatePickerThemeOffice2003() : CXTPDatePickerThemeOffice2003
  • ~CXTPDatePickerThemeOffice2013() : CXTPDatePickerThemeOffice2013
  • ~CXTPDatePickerThemeOfficeXP() : CXTPDatePickerThemeOfficeXP
  • ~CXTPDatePickerThemeResource() : CXTPDatePickerThemeResource
  • ~CXTPDatePickerThemeVisualStudio2015() : CXTPDatePickerThemeVisualStudio2015
  • ~CXTPDatePickerThemeVisualStudio2017() : CXTPDatePickerThemeVisualStudio2017
  • ~CXTPDatePickerThemeVisualStudio2019() : CXTPDatePickerThemeVisualStudio2019
  • ~CXTPDatePickerThemeVisualStudio2022() : CXTPDatePickerThemeVisualStudio2022
  • ~CXTPDialogBar() : CXTPDialogBar
  • ~CXTPDirWatcher() : CXTPDirWatcher
  • ~CXTPDockBar() : CXTPDockBar
  • ~CXTPDockContext() : CXTPDockContext
  • ~CXTPDockingPane() : CXTPDockingPane
  • ~CXTPDockingPaneAutoHidePanel() : CXTPDockingPaneAutoHidePanel
  • ~CXTPDockingPaneBase() : CXTPDockingPaneBase
  • ~CXTPDockingPaneBaseContainer() : CXTPDockingPaneBaseContainer
  • ~CXTPDockingPaneColorSet() : CXTPDockingPaneColorSet
  • ~CXTPDockingPaneContext() : CXTPDockingPaneContext
  • ~CXTPDockingPaneContextAlphaWnd() : CXTPDockingPaneContextAlphaWnd
  • ~CXTPDockingPaneContextStickerWnd() : CXTPDockingPaneContextStickerWnd
  • ~CXTPDockingPaneLayout() : CXTPDockingPaneLayout
  • ~CXTPDockingPaneManager() : CXTPDockingPaneManager
  • ~CXTPDockingPaneMiniWnd() : CXTPDockingPaneMiniWnd
  • ~CXTPDockingPaneNativeWindows10Theme() : CXTPDockingPaneNativeWindows10Theme
  • ~CXTPDockingPaneNativeWindows11Theme() : CXTPDockingPaneNativeWindows11Theme
  • ~CXTPDockingPaneOffice2003OutlookTheme() : CXTPDockingPaneOffice2003OutlookTheme
  • ~CXTPDockingPaneOffice2003Theme() : CXTPDockingPaneOffice2003Theme
  • ~CXTPDockingPaneOffice2013Theme() : CXTPDockingPaneOffice2013Theme
  • ~CXTPDockingPanePaintManager() : CXTPDockingPanePaintManager
  • ~CXTPDockingPaneSidePanel() : CXTPDockingPaneSidePanel
  • ~CXTPDockingPaneSplitterContainer() : CXTPDockingPaneSplitterContainer
  • ~CXTPDockingPaneSplitterWnd() : CXTPDockingPaneSplitterWnd
  • ~CXTPDockingPaneTabbedContainer() : CXTPDockingPaneTabbedContainer
  • ~CXTPDockingPaneVisualStudio2012Theme() : CXTPDockingPaneVisualStudio2012Theme
  • ~CXTPDockingPaneVisualStudio2015Theme() : CXTPDockingPaneVisualStudio2015Theme
  • ~CXTPDockingPaneVisualStudio2017Theme() : CXTPDockingPaneVisualStudio2017Theme
  • ~CXTPDockingPaneVisualStudio2019Theme() : CXTPDockingPaneVisualStudio2019Theme
  • ~CXTPDockingPaneVisualStudio2022Theme() : CXTPDockingPaneVisualStudio2022Theme
  • ~CXTPDockingPaneWindowSelect() : CXTPDockingPaneWindowSelect
  • ~CXTPDockState() : CXTPDockState
  • ~CXTPDPCache() : CXTPCalendarData::CXTPDPCache
  • ~CXTPDropSource() : CXTPDropSource
  • ~CXTPEdit() : CXTPEdit
  • ~CXTPEditListBox() : CXTPEditListBox
  • ~CXTPEditListBoxToolBar() : CXTPEditListBoxToolBar
  • ~CXTPEditTheme() : CXTPEditTheme
  • ~CXTPEditThemeDefault() : CXTPEditThemeDefault
  • ~CXTPEditThemeFlat() : CXTPEditThemeFlat
  • ~CXTPEditThemeNativeWindows10() : CXTPEditThemeNativeWindows10
  • ~CXTPEditThemeNativeWindows11() : CXTPEditThemeNativeWindows11
  • ~CXTPEditThemeOffice2000() : CXTPEditThemeOffice2000
  • ~CXTPEditThemeOffice2003() : CXTPEditThemeOffice2003
  • ~CXTPEditThemeOffice2013() : CXTPEditThemeOffice2013
  • ~CXTPEditThemeOfficeXP() : CXTPEditThemeOfficeXP
  • ~CXTPEditThemeResource() : CXTPEditThemeResource
  • ~CXTPEditThemeUltraFlat() : CXTPEditThemeUltraFlat
  • ~CXTPEditThemeVisualStudio2010() : CXTPEditThemeVisualStudio2010
  • ~CXTPEditThemeVisualStudio2012() : CXTPEditThemeVisualStudio2012
  • ~CXTPEditThemeVisualStudio2015() : CXTPEditThemeVisualStudio2015
  • ~CXTPEditThemeVisualStudio2017() : CXTPEditThemeVisualStudio2017
  • ~CXTPEditThemeVisualStudio2019() : CXTPEditThemeVisualStudio2019
  • ~CXTPEditThemeVisualStudio2022() : CXTPEditThemeVisualStudio2022
  • ~CXTPExcelTabCtrl() : CXTPExcelTabCtrl
  • ~CXTPExcelTabCtrlTheme() : CXTPExcelTabCtrlTheme
  • ~CXTPEyeDropper() : CXTPEyeDropper
  • ~CXTPFlowGraphConnection() : CXTPFlowGraphConnection
  • ~CXTPFlowGraphConnectionPoint() : CXTPFlowGraphConnectionPoint
  • ~CXTPFlowGraphConnectionPoints() : CXTPFlowGraphConnectionPoints
  • ~CXTPFlowGraphConnections() : CXTPFlowGraphConnections
  • ~CXTPFlowGraphControl() : CXTPFlowGraphControl
  • ~CXTPFlowGraphElement() : CXTPFlowGraphElement
  • ~CXTPFlowGraphImage() : CXTPFlowGraphImage
  • ~CXTPFlowGraphImages() : CXTPFlowGraphImages
  • ~CXTPFlowGraphNode() : CXTPFlowGraphNode
  • ~CXTPFlowGraphNodeCustom() : CXTPFlowGraphNodeCustom
  • ~CXTPFlowGraphNodeGroup() : CXTPFlowGraphNodeGroup
  • ~CXTPFlowGraphNodeGroups() : CXTPFlowGraphNodeGroups
  • ~CXTPFlowGraphNodes() : CXTPFlowGraphNodes
  • ~CXTPFlowGraphPage() : CXTPFlowGraphPage
  • ~CXTPFlowGraphPageHistory() : CXTPFlowGraphPageHistory
  • ~CXTPFlowGraphPages() : CXTPFlowGraphPages
  • ~CXTPFlowGraphPaintManager() : CXTPFlowGraphPaintManager
  • ~CXTPFlowGraphSelectedElements() : CXTPFlowGraphSelectedElements
  • ~CXTPFlowGraphUndoAddConnectionCommand() : CXTPFlowGraphUndoAddConnectionCommand
  • ~CXTPFlowGraphUndoAddConnectionPointCommand() : CXTPFlowGraphUndoAddConnectionPointCommand
  • ~CXTPFlowGraphUndoAddNodeCommand() : CXTPFlowGraphUndoAddNodeCommand
  • ~CXTPFlowGraphUndoCommand() : CXTPFlowGraphUndoCommand
  • ~CXTPFlowGraphUndoDeleteConnectionCommand() : CXTPFlowGraphUndoDeleteConnectionCommand
  • ~CXTPFlowGraphUndoDeleteConnectionPointCommand() : CXTPFlowGraphUndoDeleteConnectionPointCommand
  • ~CXTPFlowGraphUndoDeleteNodeCommand() : CXTPFlowGraphUndoDeleteNodeCommand
  • ~CXTPFlowGraphUndoGroupCommand() : CXTPFlowGraphUndoGroupCommand
  • ~CXTPFlowGraphUndoManager() : CXTPFlowGraphUndoManager
  • ~CXTPFlowGraphUndoSetConnectionPositionCommand() : CXTPFlowGraphUndoSetConnectionPositionCommand
  • ~CXTPFlowGraphUndoSetNodeCaptionCommand() : CXTPFlowGraphUndoSetNodeCaptionCommand
  • ~CXTPFlowGraphUndoSetNodePositionCommand() : CXTPFlowGraphUndoSetNodePositionCommand
  • ~CXTPFlowGraphUndoSetNodeSizeCommand() : CXTPFlowGraphUndoSetNodeSizeCommand
  • ~CXTPFont() : CXTPFont
  • ~CXTPFontComboBox() : CXTPFontComboBox
  • ~CXTPFontCtrlBase() : CXTPFontCtrlBase
  • ~CXTPFontEnum() : CXTPFontEnum
  • ~CXTPFontListBox() : CXTPFontListBox
  • ~CXTPFramePaintManager() : CXTPFramePaintManager
  • ~CXTPFrameShadow() : CXTPFrameShadow
  • ~CXTPFrameThemeOffice2007System() : CXTPFrameThemeOffice2007System
  • ~CXTPFrameWndBase() : CXTPFrameWndBase< TBase >
  • ~CXTPGaugeBaseType() : CXTPGaugeBaseType
  • ~CXTPGaugeCtrl() : CXTPGaugeCtrl
  • ~CXTPGaugeMeterType() : CXTPGaugeMeterType
  • ~CXTPGaugeStateType() : CXTPGaugeStateType
  • ~CXTPGaugeTraits() : CXTPGaugeTraits
  • ~CXTPGdiObject() : CXTPGdiObject
  • ~CXTPGlobalAtom() : CXTPGlobalAtom
  • ~CXTPGridColumn() : CXTPGridColumn
  • ~CXTPGridColumns() : CXTPGridColumns
  • ~CXTPGridControl() : CXTPGridControl
  • ~CXTPGridDataManager() : CXTPGridDataManager
  • ~CXTPGridFilterEditControl() : CXTPGridFilterEditControl
  • ~CXTPGridGroupRow() : CXTPGridGroupRow
  • ~CXTPGridHeader() : CXTPGridHeader
  • ~CXTPGridHeaderDragWnd() : CXTPGridHeaderDragWnd
  • ~CXTPGridHeaderDropWnd() : CXTPGridHeaderDropWnd
  • ~CXTPGridHyperlink() : CXTPGridHyperlink
  • ~CXTPGridHyperlinks() : CXTPGridHyperlinks
  • ~CXTPGridIconNavigator() : CXTPGridIconNavigator
  • ~CXTPGridInplaceControl() : CXTPGridInplaceControl
  • ~CXTPGridInplaceEdit() : CXTPGridInplaceEdit
  • ~CXTPGridNavigator() : CXTPGridNavigator
  • ~CXTPGridPageSetupDialog() : CXTPGridPageSetupDialog
  • ~CXTPGridPaintManager() : CXTPGridPaintManager
  • ~CXTPGridRecord() : CXTPGridRecord
  • ~CXTPGridRecordItem() : CXTPGridRecordItem
  • ~CXTPGridRecordItemConstraints() : CXTPGridRecordItemConstraints
  • ~CXTPGridRecordItemControl() : CXTPGridRecordItemControl
  • ~CXTPGridRecordItemControlHookWnd() : CXTPGridRecordItemControlHookWnd
  • ~CXTPGridRecordItemControls() : CXTPGridRecordItemControls
  • ~CXTPGridRecordItemEditOptions() : CXTPGridRecordItemEditOptions
  • ~CXTPGridRecords() : CXTPGridRecords
  • ~CXTPGridRow() : CXTPGridRow
  • ~CXTPGridRows() : CXTPGridRows
  • ~CXTPGridSection() : CXTPGridSection
  • ~CXTPGridSections() : CXTPGridSections
  • ~CXTPGridSubListControl() : CXTPGridSubListControl
  • ~CXTPGridTip() : CXTPGridTip
  • ~CXTPGridView() : CXTPGridView
  • ~CXTPHeaderCtrl() : CXTPHeaderCtrl
  • ~CXTPHeaderCtrlTheme() : CXTPHeaderCtrlTheme
  • ~CXTPHeaderCtrlThemeExplorer() : CXTPHeaderCtrlThemeExplorer
  • ~CXTPHeaderCtrlThemeOffice2003() : CXTPHeaderCtrlThemeOffice2003
  • ~CXTPHeaderCtrlThemeOfficeXP() : CXTPHeaderCtrlThemeOfficeXP
  • ~CXTPHeapString() : CXTPHeapString
  • ~CXTPHeapStringT() : CXTPHeapStringT< _TAllocator >
  • ~CXTPHexEdit() : CXTPHexEdit
  • ~CXTPHookManager() : CXTPHookManager
  • ~CXTPHookManagerHookAble() : CXTPHookManagerHookAble
  • ~CXTPHyperLink() : CXTPHyperLink
  • ~CXTPIconHandle() : CXTPIconHandle
  • ~CXTPImageList() : CXTPImageList
  • ~CXTPImageManager() : CXTPImageManager
  • ~CXTPImageManagerIcon() : CXTPImageManagerIcon
  • ~CXTPImageManagerIconHandle() : CXTPImageManagerIconHandle
  • ~CXTPImageManagerIconSet() : CXTPImageManagerIconSet
  • ~CXTPImageManagerImageList() : CXTPImageManagerImageList
  • ~CXTPImageManagerResource() : CXTPImageManagerResource
  • ~CXTPImageManagerVectorImageHandle() : CXTPImageManagerVectorImageHandle
  • ~CXTPInternalCollectionT() : CXTPInternalCollectionT< _TObject >
  • ~CXTPItemEdit() : CXTPItemEdit
  • ~CXTPKeyboardManager() : CXTPKeyboardManager
  • ~CXTPListBase() : CXTPListBase
  • ~CXTPListBox() : CXTPListBox
  • ~CXTPListBoxTheme() : CXTPListBoxTheme
  • ~CXTPListCtrl() : CXTPListCtrl
  • ~CXTPListView() : CXTPListView
  • ~CXTPLockGuard() : CXTPLockGuard
  • ~CXTPMarkupBorder() : CXTPMarkupBorder
  • ~CXTPMarkupButton() : CXTPMarkupButton
  • ~CXTPMarkupButtonBase() : CXTPMarkupButtonBase
  • ~CXTPMarkupCheckBox() : CXTPMarkupCheckBox
  • ~CXTPMarkupContentControl() : CXTPMarkupContentControl
  • ~CXTPMarkupContext() : CXTPMarkupContext
  • ~CXTPMarkupDecorator() : CXTPMarkupDecorator
  • ~CXTPMarkupDeviceDependentImage() : CXTPMarkupDeviceDependentImage
  • ~CXTPMarkupDockPanel() : CXTPMarkupDockPanel
  • ~CXTPMarkupFrameworkElement() : CXTPMarkupFrameworkElement
  • ~CXTPMarkupGdiImage() : CXTPMarkupGdiImage
  • ~CXTPMarkupGdiPlusImage() : CXTPMarkupGdiPlusImage
  • ~CXTPMarkupGdiPlusTransformationMatrix() : CXTPMarkupGdiPlusTransformationMatrix
  • ~CXTPMarkupGdiPlusTransformObjectImpl() : CXTPMarkupGdiPlusTransformObjectImpl
  • ~CXTPMarkupGrid() : CXTPMarkupGrid
  • ~CXTPMarkupImage() : CXTPMarkupImage
  • ~CXTPMarkupPage() : CXTPMarkupPage
  • ~CXTPMarkupPanel() : CXTPMarkupPanel
  • ~CXTPMarkupRadioButton() : CXTPMarkupRadioButton
  • ~CXTPMarkupStackPanel() : CXTPMarkupStackPanel
  • ~CXTPMarkupStaticExtension() : CXTPMarkupStaticExtension
  • ~CXTPMarkupStaticExtensionProperty() : CXTPMarkupStaticExtensionProperty
  • ~CXTPMarkupTextBlock() : CXTPMarkupTextBlock
  • ~CXTPMarkupThemePart() : CXTPMarkupThemePart
  • ~CXTPMarkupTransformationMatrix() : CXTPMarkupTransformationMatrix
  • ~CXTPMarkupTreeCtrl() : CXTPMarkupTreeCtrl
  • ~CXTPMarkupUIElement() : CXTPMarkupUIElement
  • ~CXTPMarkupUIElementCollection() : CXTPMarkupUIElementCollection
  • ~CXTPMarkupUniformGrid() : CXTPMarkupUniformGrid
  • ~CXTPMarkupViewbox() : CXTPMarkupViewbox
  • ~CXTPMarkupVisual() : CXTPMarkupVisual
  • ~CXTPMarkupWrapPanel() : CXTPMarkupWrapPanel
  • ~CXTPMarqueeCtrl() : CXTPMarqueeCtrl
  • ~CXTPMarqueeCtrlPaintManager() : CXTPMarqueeCtrlPaintManager
  • ~CXTPMatrix() : CXTPMatrix< T >
  • ~CXTPMDIClientWnd() : CXTPMDIClientWnd
  • ~CXTPMDIFrameWndEx() : CXTPMDIFrameWndEx
  • ~CXTPMDIWndTab() : CXTPMDIWndTab
  • ~CXTPMemFile() : CXTPMemFile
  • ~CXTPMenuBar() : CXTPMenuBar
  • ~CXTPMenuBarMDIMenuInfo() : CXTPMenuBarMDIMenuInfo
  • ~CXTPMenuBarMDIMenus() : CXTPMenuBarMDIMenus
  • ~CXTPMessageBar() : CXTPMessageBar
  • ~CXTPMessageBarButton() : CXTPMessageBarButton
  • ~CXTPMessageBarPaintManager() : CXTPMessageBarPaintManager
  • ~CXTPMiniToolBar() : CXTPMiniToolBar
  • ~CXTPModuleHandle() : CXTPModuleHandle
  • ~CXTPMouseManager() : CXTPMouseManager
  • ~CXTPNotifyConnection() : CXTPNotifyConnection
  • ~CXTPNotifyConnectionMT() : CXTPNotifyConnectionMT
  • ~CXTPNotifySinkBase() : CXTPNotifySinkBase
  • ~CXTPObservable() : CXTPObservable< Owner, Observer >
  • ~CXTPPageScroller() : CXTPPageScroller
  • ~CXTPPaintManager() : CXTPPaintManager
  • ~CXTPPaintManagerColor() : CXTPPaintManagerColor
  • ~CXTPPaintManagerColorGradient() : CXTPPaintManagerColorGradient
  • ~CXTPPasswordPeek() : CXTPPasswordPeek
  • ~CXTPPen() : CXTPPen
  • ~CXTPPopupBar() : CXTPPopupBar
  • ~CXTPPopupControl() : CXTPPopupControl
  • ~CXTPPopupItem() : CXTPPopupItem
  • ~CXTPPopupPaintManager() : CXTPPopupPaintManager
  • ~CXTPPopupThemeMSN() : CXTPPopupThemeMSN
  • ~CXTPPopupThemeOffice2000() : CXTPPopupThemeOffice2000
  • ~CXTPPopupThemeOffice2003() : CXTPPopupThemeOffice2003
  • ~CXTPPopupThemeOffice2013() : CXTPPopupThemeOffice2013
  • ~CXTPPopupThemeOfficeXP() : CXTPPopupThemeOfficeXP
  • ~CXTPPreviewCtrl() : CXTPPreviewCtrl
  • ~CXTPPreviewView() : CXTPPreviewView
  • ~CXTPProgressBase() : CXTPProgressBase
  • ~CXTPProgressCtrl() : CXTPProgressCtrl
  • ~CXTPProgressCtrlPaintManager() : CXTPProgressCtrlPaintManager
  • ~CXTPProgressPaintManager() : CXTPProgressPaintManager
  • ~CXTPProgressThemeNativeWindows10() : CXTPProgressThemeNativeWindows10
  • ~CXTPProgressThemeNativeWindows11() : CXTPProgressThemeNativeWindows11
  • ~CXTPProgressThemeOffice2013() : CXTPProgressThemeOffice2013
  • ~CXTPProgressThemeVisualStudio2015() : CXTPProgressThemeVisualStudio2015
  • ~CXTPProgressThemeVisualStudio2017() : CXTPProgressThemeVisualStudio2017
  • ~CXTPProgressThemeVisualStudio2019() : CXTPProgressThemeVisualStudio2019
  • ~CXTPProgressThemeVisualStudio2022() : CXTPProgressThemeVisualStudio2022
  • ~CXTPPropertyGrid() : CXTPPropertyGrid
  • ~CXTPPropertyGridInplaceButton() : CXTPPropertyGridInplaceButton
  • ~CXTPPropertyGridInplaceButtons() : CXTPPropertyGridInplaceButtons
  • ~CXTPPropertyGridInplaceControls() : CXTPPropertyGridInplaceControls
  • ~CXTPPropertyGridInplaceEdit() : CXTPPropertyGridInplaceEdit
  • ~CXTPPropertyGridInplaceList() : CXTPPropertyGridInplaceList
  • ~CXTPPropertyGridInplaceMultilineEdit() : CXTPPropertyGridInplaceMultilineEdit
  • ~CXTPPropertyGridItem() : CXTPPropertyGridItem
  • ~CXTPPropertyGridItemBool() : CXTPPropertyGridItemBool
  • ~CXTPPropertyGridItemColor() : CXTPPropertyGridItemColor
  • ~CXTPPropertyGridItemConstraints() : CXTPPropertyGridItemConstraints
  • ~CXTPPropertyGridItemDouble() : CXTPPropertyGridItemDouble
  • ~CXTPPropertyGridItemEnum() : CXTPPropertyGridItemEnum
  • ~CXTPPropertyGridItemFlags() : CXTPPropertyGridItemFlags
  • ~CXTPPropertyGridItemFont() : CXTPPropertyGridItemFont
  • ~CXTPPropertyGridItemNumber() : CXTPPropertyGridItemNumber
  • ~CXTPPropertyGridItemOption() : CXTPPropertyGridItemOption
  • ~CXTPPropertyGridItemPoint() : CXTPPropertyGridItemPoint
  • ~CXTPPropertyGridItemSize() : CXTPPropertyGridItemSize
  • ~CXTPPropertyGridPaintManager() : CXTPPropertyGridPaintManager
  • ~CXTPPropertyGridToolBar() : CXTPPropertyGridToolBar
  • ~CXTPPropertyGridVerbs() : CXTPPropertyGridVerbs
  • ~CXTPPropertyGridView() : CXTPPropertyGridView
  • ~CXTPPropertyGridVisualStudio2010Theme() : CXTPPropertyGridVisualStudio2010Theme
  • ~CXTPPropertyPage() : CXTPPropertyPage
  • ~CXTPPropertyPageNavigator() : CXTPPropertyPageNavigator
  • ~CXTPPropertySheet() : CXTPPropertySheet
  • ~CXTPPropExchange() : CXTPPropExchange
  • ~CXTPPropExchangeEnumerator() : CXTPPropExchangeEnumerator
  • ~CXTPPropExchangeIniFile() : CXTPPropExchangeIniFile
  • ~CXTPPropExchangeRegistry() : CXTPPropExchangeRegistry
  • ~CXTPPropExchangeSection() : CXTPPropExchangeSection
  • ~CXTPReBar() : CXTPReBar
  • ~CXTPRecentFileList() : CXTPRecentFileList
  • ~CXTPRegistryManager() : CXTPRegistryManager
  • ~CXTPResize() : CXTPResize
  • ~CXTPResizeGroupBox() : CXTPResizeGroupBox
  • ~CXTPResizeItem() : CXTPResizeItem
  • ~CXTPResourceImage() : CXTPResourceImage
  • ~CXTPResourceImages() : CXTPResourceImages
  • ~CXTPResourceManager() : CXTPResourceManager
  • ~CXTPResourceManagerXML() : CXTPResourceManagerXML
  • ~CXTPResourceTheme() : CXTPResourceTheme
  • ~CXTPRibbonBar() : CXTPRibbonBar
  • ~CXTPRibbonControlSystemPopupBarPinableListItem() : CXTPRibbonControlSystemPopupBarPinableListItem
  • ~CXTPRibbonControlTab() : CXTPRibbonControlTab
  • ~CXTPRibbonCustomizePage() : CXTPRibbonCustomizePage
  • ~CXTPRibbonCustomizeQuickAccessPage() : CXTPRibbonCustomizeQuickAccessPage
  • ~CXTPRibbonGroup() : CXTPRibbonGroup
  • ~CXTPRibbonGroups() : CXTPRibbonGroups
  • ~CXTPRibbonMarkupFrameTheme() : CXTPRibbonMarkupFrameTheme
  • ~CXTPRibbonMarkupTheme() : CXTPRibbonMarkupTheme
  • ~CXTPRibbonOffice2013Theme() : CXTPRibbonOffice2013Theme
  • ~CXTPRibbonPaintManager() : CXTPRibbonPaintManager
  • ~CXTPRibbonQuickAccessControls() : CXTPRibbonQuickAccessControls
  • ~CXTPRibbonTab() : CXTPRibbonTab
  • ~CXTPRibbonTabPopupToolBar() : CXTPRibbonTabPopupToolBar
  • ~CXTPRibbonTheme() : CXTPRibbonTheme
  • ~CXTPRibbonThemeNativeWindows10() : CXTPRibbonThemeNativeWindows10
  • ~CXTPRibbonThemeNativeWindows11() : CXTPRibbonThemeNativeWindows11
  • ~CXTPRibbonThemeOffice2007System() : CXTPRibbonThemeOffice2007System
  • ~CXTPRibbonThemeResource() : CXTPRibbonThemeResource
  • ~CXTPRibbonThemeVisualStudio2015() : CXTPRibbonThemeVisualStudio2015
  • ~CXTPRibbonThemeVisualStudio2017() : CXTPRibbonThemeVisualStudio2017
  • ~CXTPRibbonThemeVisualStudio2019() : CXTPRibbonThemeVisualStudio2019
  • ~CXTPRibbonThemeVisualStudio2022() : CXTPRibbonThemeVisualStudio2022
  • ~CXTPRWCriticalSection() : CXTPRWCriticalSection
  • ~CXTPScrollBar() : CXTPScrollBar
  • ~CXTPScrollBarCtrl() : CXTPScrollBarCtrl
  • ~CXTPScrollBarThemeOffice2013() : CXTPScrollBarThemeOffice2013
  • ~CXTPScrollBarThemeWindowsUx() : CXTPScrollBarThemeWindowsUx
  • ~CXTPScrollBase() : CXTPScrollBase
  • ~CXTPSearchOptionsCtrl() : CXTPSearchOptionsCtrl
  • ~CXTPSearchOptionsView() : CXTPSearchOptionsView
  • ~CXTPShadowManager() : CXTPShadowManager
  • ~CXTPShellExplorerProvider() : CXTPShellExplorerProvider
  • ~CXTPShellListBase() : CXTPShellListBase
  • ~CXTPShellListCtrl() : CXTPShellListCtrl
  • ~CXTPShellListCtrlEx() : CXTPShellListCtrlEx
  • ~CXTPShellListView() : CXTPShellListView
  • ~CXTPShellPidl() : CXTPShellPidl
  • ~CXTPShellSettings() : CXTPShellSettings
  • ~CXTPShellTreeBase() : CXTPShellTreeBase
  • ~CXTPShellTreeCtrl() : CXTPShellTreeCtrl
  • ~CXTPShellTreeView() : CXTPShellTreeView
  • ~CXTPShortcutBar() : CXTPShortcutBar
  • ~CXTPShortcutBarNativeWindows10Theme() : CXTPShortcutBarNativeWindows10Theme
  • ~CXTPShortcutBarNativeWindows11Theme() : CXTPShortcutBarNativeWindows11Theme
  • ~CXTPShortcutBarNativeWinXPTheme() : CXTPShortcutBarNativeWinXPTheme
  • ~CXTPShortcutBarOffice2013Theme() : CXTPShortcutBarOffice2013Theme
  • ~CXTPShortcutBarPaintManager() : CXTPShortcutBarPaintManager
  • ~CXTPShortcutBarPane() : CXTPShortcutBarPane
  • ~CXTPShortcutBarVisualStudio2015Theme() : CXTPShortcutBarVisualStudio2015Theme
  • ~CXTPShortcutBarVisualStudio2017Theme() : CXTPShortcutBarVisualStudio2017Theme
  • ~CXTPShortcutBarVisualStudio2019Theme() : CXTPShortcutBarVisualStudio2019Theme
  • ~CXTPShortcutBarVisualStudio2022Theme() : CXTPShortcutBarVisualStudio2022Theme
  • ~CXTPShortcutListBox() : CXTPShortcutListBox
  • ~CXTPShortcutListBoxTheme() : CXTPShortcutListBoxTheme
  • ~CXTPShortcutManager() : CXTPShortcutManager
  • ~CXTPShortcutManagerAccelTable() : CXTPShortcutManagerAccelTable
  • ~CXTPSimpleCriticalSection() : CXTPSimpleCriticalSection
  • ~CXTPSingletonPointer() : CXTPSingletonPointer
  • ~CXTPSizeIcon() : CXTPSizeIcon
  • ~CXTPSkinImage() : CXTPSkinImage
  • ~CXTPSkinImages() : CXTPSkinImages
  • ~CXTPSkinManager() : CXTPSkinManager
  • ~CXTPSkinManagerClass() : CXTPSkinManagerClass
  • ~CXTPSkinManagerColorFilter() : CXTPSkinManagerColorFilter
  • ~CXTPSkinManagerMetrics() : CXTPSkinManagerMetrics
  • ~CXTPSkinManagerResourceFile() : CXTPSkinManagerResourceFile
  • ~CXTPSkinManagerSchema() : CXTPSkinManagerSchema
  • ~CXTPSkinManagerSchemaProperty() : CXTPSkinManagerSchemaProperty
  • ~CXTPSkinObject() : CXTPSkinObject
  • ~CXTPSkinObjectButton() : CXTPSkinObjectButton
  • ~CXTPSkinObjectClassMap() : CXTPSkinObjectClassMap
  • ~CXTPSkinObjectComboBox() : CXTPSkinObjectComboBox
  • ~CXTPSkinObjectEdit() : CXTPSkinObjectEdit
  • ~CXTPSkinObjectFrame() : CXTPSkinObjectFrame
  • ~CXTPSkinObjectHeader() : CXTPSkinObjectHeader
  • ~CXTPSkinObjectListBox() : CXTPSkinObjectListBox
  • ~CXTPSkinObjectListView() : CXTPSkinObjectListView
  • ~CXTPSkinObjectProgress() : CXTPSkinObjectProgress
  • ~CXTPSkinObjectReBar() : CXTPSkinObjectReBar
  • ~CXTPSkinObjectScrollBar() : CXTPSkinObjectScrollBar
  • ~CXTPSkinObjectSpin() : CXTPSkinObjectSpin
  • ~CXTPSkinObjectStatusBar() : CXTPSkinObjectStatusBar
  • ~CXTPSkinObjectTab() : CXTPSkinObjectTab
  • ~CXTPSkinObjectToolBar() : CXTPSkinObjectToolBar
  • ~CXTPSkinObjectTrackBar() : CXTPSkinObjectTrackBar
  • ~CXTPSkinObjectTreeView() : CXTPSkinObjectTreeView
  • ~CXTPSmartPtrInternalT() : CXTPSmartPtrInternalT< _TObject >
  • ~CXTPSortClass() : CXTPSortClass
  • ~CXTPSoundManager() : CXTPSoundManager
  • ~CXTPSpinButtonCtrl() : CXTPSpinButtonCtrl
  • ~CXTPSplitPath() : CXTPSplitPath
  • ~CXTPSplitterWnd() : CXTPSplitterWnd
  • ~CXTPSplitterWndEx() : CXTPSplitterWndEx
  • ~CXTPStatusBar() : CXTPStatusBar
  • ~CXTPStatusBarPane() : CXTPStatusBarPane
  • ~CXTPStatusBarProgressPane() : CXTPStatusBarProgressPane
  • ~CXTPStatusBarScrollBarPane() : CXTPStatusBarScrollBarPane
  • ~CXTPStatusBarSliderPane() : CXTPStatusBarSliderPane
  • ~CXTPStatusBarSwitchPane() : CXTPStatusBarSwitchPane
  • ~CXTPStatusBarThemeVisualStudio2015() : CXTPStatusBarThemeVisualStudio2015
  • ~CXTPStatusBarThemeVisualStudio2017() : CXTPStatusBarThemeVisualStudio2017
  • ~CXTPStatusBarThemeVisualStudio2019() : CXTPStatusBarThemeVisualStudio2019
  • ~CXTPStatusBarThemeVisualStudio2022() : CXTPStatusBarThemeVisualStudio2022
  • ~CXTPStickerBase() : CXTPStickerBase
  • ~CXTPSubscriptionList() : CXTPSubscriptionList< Observable, Observer >
  • ~CXTPSvgImage() : CXTPSvgImage
  • ~CXTPSyntaxEditAutoCompleteWnd() : CXTPSyntaxEditAutoCompleteWnd
  • ~CXTPSyntaxEditBatchCommand() : CXTPSyntaxEditBatchCommand
  • ~CXTPSyntaxEditBufferCommand() : CXTPSyntaxEditBufferCommand
  • ~CXTPSyntaxEditBufferKeepOverwriteSettings() : CXTPSyntaxEditBufferCommand::CXTPSyntaxEditBufferKeepOverwriteSettings
  • ~CXTPSyntaxEditBufferManager() : CXTPSyntaxEditBufferManager
  • ~CXTPSyntaxEditColorComboBox() : CXTPSyntaxEditColorComboBox
  • ~CXTPSyntaxEditColorInfo() : CXTPSyntaxEditColorInfo
  • ~CXTPSyntaxEditColorInfoArray() : CXTPSyntaxEditColorInfoArray
  • ~CXTPSyntaxEditColorSampleText() : CXTPSyntaxEditColorSampleText
  • ~CXTPSyntaxEditColorTheme() : CXTPSyntaxEditColorTheme
  • ~CXTPSyntaxEditColorThemesManager() : CXTPSyntaxEditColorThemesManager
  • ~CXTPSyntaxEditCommand() : CXTPSyntaxEditCommand
  • ~CXTPSyntaxEditConfigurationManager() : CXTPSyntaxEditConfigurationManager
  • ~CXTPSyntaxEditCtrl() : CXTPSyntaxEditCtrl
  • ~CXTPSyntaxEditDeleteStringCommand() : CXTPSyntaxEditDeleteStringCommand
  • ~CXTPSyntaxEditDoc() : CXTPSyntaxEditDoc
  • ~CXTPSyntaxEditFileChangesMonitor() : CXTPSyntaxEditFileChangesMonitor
  • ~CXTPSyntaxEditInsertStringCommand() : CXTPSyntaxEditInsertStringCommand
  • ~CXTPSyntaxEditLexClass() : CXTPSyntaxEditLexClass
  • ~CXTPSyntaxEditLexOnScreenParseCnt() : CXTPSyntaxEditLexOnScreenParseCnt
  • ~CXTPSyntaxEditLexParser() : CXTPSyntaxEditLexParser
  • ~CXTPSyntaxEditLexTextBlock() : CXTPSyntaxEditLexTextBlock
  • ~CXTPSyntaxEditLexTextSchema() : CXTPSyntaxEditLexTextSchema
  • ~CXTPSyntaxEditLexTokensDef() : CXTPSyntaxEditLexTokensDef
  • ~CXTPSyntaxEditLexVariable() : CXTPSyntaxEditLexVariable
  • ~CXTPSyntaxEditLexVariant() : CXTPSyntaxEditLexVariant
  • ~CXTPSyntaxEditLineMarksManager() : CXTPSyntaxEditLineMarksManager
  • ~CXTPSyntaxEditPaintManager() : CXTPSyntaxEditPaintManager
  • ~CXTPSyntaxEditPropertiesDlg() : CXTPSyntaxEditPropertiesDlg
  • ~CXTPSyntaxEditPropertiesPageColor() : CXTPSyntaxEditPropertiesPageColor
  • ~CXTPSyntaxEditPropertiesPageEdit() : CXTPSyntaxEditPropertiesPageEdit
  • ~CXTPSyntaxEditPropertiesPageFont() : CXTPSyntaxEditPropertiesPageFont
  • ~CXTPSyntaxEditReplaceStringCommand() : CXTPSyntaxEditReplaceStringCommand
  • ~CXTPSyntaxEditSelection() : CXTPSyntaxEditSelection
  • ~CXTPSyntaxEditStringsManager() : CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager
  • ~CXTPSyntaxEditTextIterator() : CXTPSyntaxEditTextIterator
  • ~CXTPSyntaxEditTextSchemesManager() : CXTPSyntaxEditTextSchemesManager
  • ~CXTPSyntaxEditTipWnd() : CXTPSyntaxEditTipWnd
  • ~CXTPSyntaxEditToolTipCtrl() : CXTPSyntaxEditToolTipCtrl
  • ~CXTPSyntaxEditUndoRedoManager() : CXTPSyntaxEditUndoRedoManager
  • ~CXTPSyntaxEditView() : CXTPSyntaxEditView
  • ~CXTPTabBase() : CXTPTabBase
  • ~CXTPTabBaseTheme() : CXTPTabBaseTheme
  • ~CXTPTabClientContext() : CXTPTabClientContext
  • ~CXTPTabClientDraggingContents() : CXTPTabClientDraggingContents
  • ~CXTPTabClientSticker() : CXTPTabClientSticker
  • ~CXTPTabClientWnd() : CXTPTabClientWnd
  • ~CXTPTabControl() : CXTPTabControl
  • ~CXTPTabCtrl() : CXTPTabCtrl
  • ~CXTPTabExBase() : CXTPTabExBase
  • ~CXTPTabManager() : CXTPTabManager
  • ~CXTPTabManagerAtom() : CXTPTabManagerAtom
  • ~CXTPTabManagerItem() : CXTPTabManagerItem
  • ~CXTPTabManagerNavigateButton() : CXTPTabManagerNavigateButton
  • ~CXTPTabManagerNavigateButtons() : CXTPTabManagerNavigateButtons
  • ~CXTPTabPaintManager() : CXTPTabPaintManager
  • ~CXTPTabPaintManagerColorSet() : CXTPTabPaintManagerColorSet
  • ~CXTPTabPaintManagerTheme() : CXTPTabPaintManagerTheme
  • ~CXTPTabToolBar() : CXTPTabToolBar
  • ~CXTPTabView() : CXTPTabView
  • ~CXTPTagCloudCtrl() : CXTPTagCloudCtrl
  • ~CXTPTagCloudStyleManager() : CXTPTagCloudStyleManager
  • ~CXTPTaskDialog() : CXTPTaskDialog
  • ~CXTPTaskDialogLinkCtrl() : CXTPTaskDialogLinkCtrl
  • ~CXTPTaskPanel() : CXTPTaskPanel
  • ~CXTPTaskPanelGroup() : CXTPTaskPanelGroup
  • ~CXTPTaskPanelGroupItem() : CXTPTaskPanelGroupItem
  • ~CXTPTaskPanelItem() : CXTPTaskPanelItem
  • ~CXTPTaskPanelItems() : CXTPTaskPanelItems
  • ~CXTPTaskPanelNativeWindows10Theme() : CXTPTaskPanelNativeWindows10Theme
  • ~CXTPTaskPanelNativeWindows11Theme() : CXTPTaskPanelNativeWindows11Theme
  • ~CXTPTaskPanelOffice2013Theme() : CXTPTaskPanelOffice2013Theme
  • ~CXTPTaskPanelPaintManager() : CXTPTaskPanelPaintManager
  • ~CXTPTaskPanelVisualStudio2010Theme() : CXTPTaskPanelVisualStudio2010Theme
  • ~CXTPTaskPanelVisualStudio2012Theme() : CXTPTaskPanelVisualStudio2012Theme
  • ~CXTPTaskPanelVisualStudio2015Theme() : CXTPTaskPanelVisualStudio2015Theme
  • ~CXTPTaskPanelVisualStudio2017Theme() : CXTPTaskPanelVisualStudio2017Theme
  • ~CXTPTaskPanelVisualStudio2019Theme() : CXTPTaskPanelVisualStudio2019Theme
  • ~CXTPTaskPanelVisualStudio2022Theme() : CXTPTaskPanelVisualStudio2022Theme
  • ~CXTPTearOffFrame() : CXTPTearOffFrame
  • ~CXTPTempColorMask() : CXTPTempColorMask
  • ~CXTPThemeDLL() : CXTPThemeDLL
  • ~CXTPThreadLocal() : CXTPThreadLocal< T >
  • ~CXTPTipOfTheDay() : CXTPTipOfTheDay
  • ~CXTPTipWindow() : CXTPTipWindow
  • ~CXTPToolBar() : CXTPToolBar
  • ~CXTPToolTipContext() : CXTPToolTipContext
  • ~CXTPToolTipContextToolTip() : CXTPToolTipContextToolTip
  • ~CXTPTrackControl() : CXTPTrackControl
  • ~CXTPTrackControlItem() : CXTPTrackControlItem
  • ~CXTPTrackHeader() : CXTPTrackHeader
  • ~CXTPTrackMarkers() : CXTPTrackMarkers
  • ~CXTPTrackPaintManager() : CXTPTrackPaintManager
  • ~CXTPTrackUndoAddBlockCommand() : CXTPTrackUndoAddBlockCommand
  • ~CXTPTrackUndoAddMarkerCommand() : CXTPTrackUndoAddMarkerCommand
  • ~CXTPTrackUndoCommand() : CXTPTrackUndoCommand
  • ~CXTPTrackUndoDeleteBlockCommand() : CXTPTrackUndoDeleteBlockCommand
  • ~CXTPTrackUndoDeleteMarkerCommand() : CXTPTrackUndoDeleteMarkerCommand
  • ~CXTPTrackUndoGroupCommand() : CXTPTrackUndoGroupCommand
  • ~CXTPTrackUndoManager() : CXTPTrackUndoManager
  • ~CXTPTrackUndoSetBlockPositionCommand() : CXTPTrackUndoSetBlockPositionCommand
  • ~CXTPTrackUndoSetMarkerPositionCommand() : CXTPTrackUndoSetMarkerPositionCommand
  • ~CXTPTrayIcon() : CXTPTrayIcon
  • ~CXTPTreeBase() : CXTPTreeBase
  • ~CXTPTreeCtrl() : CXTPTreeCtrl
  • ~CXTPTreeTheme() : CXTPTreeTheme
  • ~CXTPTreeView() : CXTPTreeView
  • ~CXTPVisualStudio2005Theme() : CXTPVisualStudio2005Theme
  • ~CXTPVisualStudio2008Theme() : CXTPVisualStudio2008Theme
  • ~CXTPVisualStudio2010Theme() : CXTPVisualStudio2010Theme
  • ~CXTPWebBrowserCtrl() : CXTPWebBrowserCtrl
  • ~CXTPWebBrowserProvider() : CXTPWebBrowserProvider
  • ~CXTPWebViewProvider() : CXTPWebViewProvider
  • ~CXTPWinApp() : CXTPWinApp
  • ~CXTPWinThemeWrapper() : CXTPWinThemeWrapper
  • ~CXTPWinThread() : CXTPWinThread
  • ~EventsMapByID_T() : CXTPCalendarData::EventsMapByID_T< _TObject >
  • ~IXTPApplicationEvents() : IXTPApplicationEvents
  • ~IXTPFrameShadowManagerEvents() : IXTPFrameShadowManagerEvents
  • ~IXTPMarkupClientSite() : IXTPMarkupClientSite
  • ~IXTPMarkupDeviceDependentImageSite() : IXTPMarkupDeviceDependentImageSite
  • ~IXTPPreview() : IXTPPreview
  • ~IXTPPreviewHost() : IXTPPreviewHost
  • ~IXTPPreviewProvider() : IXTPPreviewProvider
  • ~IXTPScrollable() : IXTPScrollable
  • ~IXTPSkinManagerWindowFilter() : IXTPSkinManagerWindowFilter
  • ~IXTPWebBrowserEventSink() : IXTPWebBrowserEventSink
  • ~XTP_CALENDAR_HITTESTINFO() : XTP_CALENDAR_HITTESTINFO
  • ~XTP_CALENDAR_PATTERN_END() : XTP_CALENDAR_PATTERN_END
  • ~XTP_SLIDERTICKS() : XTP_SLIDERTICKS


Toolkit Pro: Class Members - Variables

Here is a list of all documented variables with links to the class documentation for each member:

- _ -

  • _xtpKeyboardThreadState : CXTPKeyboardManager


Toolkit Pro: Class Members - Variables

Here is a list of all documented variables with links to the class documentation for each member:

- a -

  • action : XTP_DOCKINGPANE_ACTION
  • animationType : CXTPCommandBarsOptions
  • Antialiasing : CXTPChartDiagram3DAppearance
  • Argb : CXTPChartColor
  • arr : CXTPCommandBars::KEYBOARDTIPS
  • arrInplaceButtons : CXTPGridRecordItemEditOptions
  • AxisLabelTextColor : CXTPChartAxisAppearance
  • AxisTitleTextColor : CXTPChartAxisAppearance


Toolkit Pro: Class Members - Variables

Here is a list of all documented variables with links to the class documentation for each member:

- b -

  • b24_HFormat : CXTPCalendarView::SEventTimeFormatInfo
  • bAbove : XTP_NM_GRIDDRAGDROP
  • BackgroundColor : CXTPChartContentAppearance, CXTPChartDiagram2DAppearance, CXTPChartLegendAppearance
  • BackgroundColor2 : CXTPChartDiagram2DAppearance
  • BackgroundFillStyle : CXTPChartDiagram2DAppearance
  • bAllDayEvent : XTP_CALENDAR_VIEWSELECTION
  • bAlpha : XTP_IMAGERESOURCE_INFO
  • bAltDragCustomization : CXTPCommandBarsOptions
  • bAlwaysShowFullMenus : CXTPCommandBarsOptions
  • bAutoUpdateShortcuts : CXTPCommandBarsOptions
  • bBeginRow : CXTPControlGallery::GALLERYITEM_POSITION
  • bBlockSelectionMode : CXTPSyntaxEditSelection
  • bCancel : XTP_DOCKINGPANE_ACTION, XTP_NM_GRIDPREVIEWKEYDOWN, XTP_NM_GRIDREQUESTEDIT, XTP_PROPERTYGRID_NOTIFYEDIT
  • bChecked : CXTPColorSelectorCtrl::COLOR_CELL, CXTPStatusBarSwitchPane::SWITCH
  • bCustomBar : XTP_COMMANDBARS_CREATEBAR
  • bDayView_AdditionalScaleLeftVisible : CXTPCalendarOptions
  • bDayView_AdditionalScaleRightVisible : CXTPCalendarOptions
  • bDayView_AutoResetBusyFlag : CXTPCalendarOptions
  • bDayView_DrawNowLineOverAppoinment : CXTPCalendarOptions
  • bDayView_ScaleLeftVisible : CXTPCalendarOptions
  • bDayView_ScaleRightVisible : CXTPCalendarOptions
  • bDayView_TimeScaleShowMinutes : CXTPCalendarOptions
  • bDblClickFloat : CXTPCommandBarsOptions
  • bDirtyState : CXTPCommandBarsOptions
  • bDisableCommandIfNoHandler : CXTPCommandBarsOptions
  • bEnableAddNewTooltip : CXTPCalendarOptions
  • bEnabled : CXTPStatusBarSwitchPane::SWITCH, CXTPTaskPanelScrollButton
  • bEnableInPlaceCreateEvent : CXTPCalendarOptions
  • bEnableInPlaceEditEventSubject_AfterEventResize : CXTPCalendarOptions
  • bEnableInPlaceEditEventSubject_ByF2 : CXTPCalendarOptions
  • bEnableInPlaceEditEventSubject_ByMouseClick : CXTPCalendarOptions
  • bEnableInPlaceEditEventSubject_ByTab : CXTPCalendarOptions
  • bEnablePrevNextEventButtons : CXTPCalendarOptions
  • bEveryWeekDayOnly : XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_DAILY
  • bExpandBar : XTP_COMMANDBARS_CREATEBAR
  • bExpanding : XTP_TPNGROUPEXPANDING
  • bFlatStyle : XTPPROGRESSDRAWSTRUCT
  • bFlyByStatus : CXTPCommandBarsOptions
  • bHatchAllDayViewEventsBkgnd : CXTPCalendarOptions
  • bHighlighted : CXTPStatusBarSwitchPane::SWITCH
  • bHot : CXTPTaskPanelScrollButton
  • Bias : CXTPCalendarTimeZones::REGISTRY_TIMEZONE_INFORMATION
  • bIconsWithShadow : XTP_COMMANDBARS_ICONSINFO
  • bKeyControl : XTPGridInputState
  • bKeyShift : XTPGridInputState
  • bLargeIcons : CXTPCommandBarsOptions
  • bLoadSilent : XTP_COMMANDBARS_PROPEXCHANGE_PARAM
  • bMarquee : XTPPROGRESSDRAWSTRUCT
  • bMenuShadows : CXTPAuxData
  • bModified : XTP_EDIT_NMHDR_DOCMODIFIED
  • bMonthView_CompressWeekendDays : CXTPCalendarOptions
  • bMonthView_HideTimes : CXTPCalendarOptions
  • bMonthView_ShowEndDate : CXTPCalendarOptions
  • bMonthView_ShowTimeAsClocks : CXTPCalendarOptions
  • bOfficeStyleDisabledIcons : XTP_COMMANDBARS_ICONSINFO
  • BorderColor : CXTPChartContentAppearance, CXTPChartDiagram2DAppearance, CXTPChartLegendAppearance, CXTPChartPieStyleAppearance
  • bottom : XTP_RESIZERECT
  • bPasteWillChangeExistingEvent : XTP_EVENT_PASTE_OPERATION_PARAMS
  • bPopup : XTP_COMMANDBARS_CREATEBAR
  • bPressed : CXTPStatusBarSwitchPane::SWITCH, CXTPTaskPanelScrollButton
  • bReturnValue : XTP_NM_GRIDDRAGDROP
  • bSaveOnlyCustomized : XTP_COMMANDBARS_PROPEXCHANGE_PARAM
  • bSaveOriginalControls : XTP_COMMANDBARS_PROPEXCHANGE_PARAM
  • bScrollUp : CXTPTaskPanelScrollButton
  • bSelected : XTP_CALENDAR_DAYVIEWCELL_PARAMS, XTP_CALENDAR_THEME_DAYVIEWCELL_PARAMS, XTPGridInputState
  • bSelectingRunning : CXTPSyntaxEditSelection
  • bSerializeActions : XTP_COMMANDBARS_PROPEXCHANGE_PARAM
  • bSerializeControls : XTP_COMMANDBARS_PROPEXCHANGE_PARAM
  • bSerializeDesignerControls : XTP_COMMANDBARS_PROPEXCHANGE_PARAM
  • bSerializeImages : XTP_COMMANDBARS_PROPEXCHANGE_PARAM
  • bSerializeLayout : XTP_COMMANDBARS_PROPEXCHANGE_PARAM
  • bSerializeOptions : XTP_COMMANDBARS_PROPEXCHANGE_PARAM
  • bShowAllDayExpandButton : CXTPCalendarOptions
  • bShowCategoryIcons : CXTPCalendarOptions
  • bShowContextMenuAccelerators : CXTPCommandBarsOptions
  • bShowExpandButtonAlways : CXTPCommandBarsOptions
  • bShowFullAfterDelay : CXTPCommandBarsOptions
  • bShowKeyboardTips : CXTPCommandBarsOptions
  • bShowMiniToolbarTips : CXTPCommandBarsOptions
  • bShowPopupBarToolTips : CXTPCommandBarsOptions
  • bShowPopupButtonsSelectedToolbarOnly : CXTPCommandBarsOptions
  • bShowTextBelowIcons : CXTPCommandBarsOptions
  • bSmooth : XTPPROGRESSDRAWSTRUCT
  • bSyncFloatingBars : CXTPCommandBarsOptions
  • bTearOffBar : XTP_COMMANDBARS_CREATEBAR
  • bTimeLineCompact : CXTPCalendarOptions
  • bTimeLineFocused : CXTPCalendarOptions
  • bTimePartValid : XTP_CALENDAR_HITTESTINFO
  • bToolBar : XTP_COMMANDBARS_CREATECONTROL
  • bToolBarAccelTips : CXTPCommandBarsOptions
  • bToolBarScreenTips : CXTPCommandBarsOptions
  • bTrackThumb : XTP_SCROLLBAR_TRACKINFO
  • bUseAltNumPadKeys : CXTPCommandBarsOptions
  • bUseDisabledIcons : XTP_COMMANDBARS_ICONSINFO
  • bUseFadedIcons : XTP_COMMANDBARS_ICONSINFO
  • bUseOfficeFont : CXTPAuxData
  • bUseOutlookFontGlyphs : CXTPCalendarOptions
  • bUseSolidShadows : CXTPAuxData
  • bUseSystemSaveBitsStyle : CXTPCommandBarsOptions
  • buttonStyle : XTP_COMMANDBARS_CREATECONTROL
  • bVal : CXTPSkinManagerSchemaProperty
  • bVertical : XTPPROGRESSDRAWSTRUCT
  • bVista : XTPPROGRESSDRAWSTRUCT
  • bWeekView_ShowEndDate : CXTPCalendarOptions
  • bWeekView_ShowTimeAsClocks : CXTPCalendarOptions
  • bWin2K : CXTPAuxData
  • bWin95 : CXTPAuxData
  • bWin98 : CXTPAuxData
  • bWinNT : CXTPAuxData
  • bWinXP : CXTPAuxData
  • bWordSelectionMode : CXTPSyntaxEditSelection
  • bWorkCell : XTP_CALENDAR_THEME_DAYVIEWCELL_PARAMS
  • bWrapLargePopups : CXTPCommandBarsOptions


Toolkit Pro: Class Members - Variables

Here is a list of all documented variables with links to the class documentation for each member:

- c -

  • cf : NMXTPCHARHDR
  • clr : CXTPColorSelectorCtrl::COLOR_CELL
  • clr3DDkShadow : CXTPAuxData
  • clr3DFace : CXTPAuxData
  • clr3DHilight : CXTPAuxData
  • clr3DLight : CXTPAuxData
  • clr3DShadow : CXTPAuxData
  • clrActiveCaption : CXTPAuxData
  • clrActiveCaptText : CXTPAuxData
  • clrBack : CXTPColorSetStateButton, CXTPColorSetStateCheckMark, CXTPColorSetStateComboBox, XTP_SCROLLBARINICOLORS, XTPRIBBON_HEADER_COLOR
  • clrBackChecked : CXTPColorSetStateButton
  • clrBackCheckedHighlight : CXTPColorSetStateButton
  • clrBackDisabled : CXTPColorSetStateButton, CXTPColorSetStateCheckMark, CXTPColorSetStateComboBox
  • clrBackDropped : CXTPColorSetStateComboBox
  • clrBackground : XTP_DAYITEM_METRICS, XTP_GRIDRECORDITEM_METRICS
  • clrBackgroundColor : XTP_CALENDAR_DAYVIEWCELL_PARAMS
  • clrBackHighlight : CXTPColorSetStateButton, CXTPColorSetStateCheckMark, CXTPColorSetStateComboBox
  • clrBackPushed : CXTPColorSetStateButton, CXTPColorSetStateCheckMark
  • clrBlock : XTP_EDIT_TEXTBLOCK
  • clrBorder : CXTPColorSetStateButton, CXTPColorSetStateComboBox, CXTPTabPaintManagerColorSet::COLORSET_TAB_STATEBUTTON
  • clrBorderChecked : CXTPColorSetStateButton
  • clrBorderCheckedHighlight : CXTPColorSetStateButton
  • clrBorderDisabled : CXTPColorSetStateButton, CXTPColorSetStateComboBox
  • clrBorderDropped : CXTPColorSetStateComboBox
  • clrBorderHighlight : CXTPColorSetStateButton, CXTPColorSetStateComboBox
  • clrBorderLeftHighlight : CXTPTabPaintManagerColorSet::COLORSET_TAB_PROPERTYPAGE2003
  • clrBorderPushed : CXTPColorSetStateButton
  • clrBorderTopHighlight : CXTPTabPaintManagerColorSet::COLORSET_TAB_PROPERTYPAGE2003
  • clrBtnText : CXTPAuxData
  • clrButton : XTP_PICK_BUTTON
  • clrCheck : CXTPColorSetStateCheckMark
  • clrCheckDisabled : CXTPColorSetStateCheckMark
  • clrCheckHighlight : CXTPColorSetStateCheckMark
  • clrCheckPushed : CXTPColorSetStateCheckMark
  • clrClient : XTP_TASKPANEL_GROUPCOLORS
  • clrClientBorder : XTP_TASKPANEL_GROUPCOLORS
  • clrClientLink : XTP_TASKPANEL_GROUPCOLORS
  • clrClientLinkHot : XTP_TASKPANEL_GROUPCOLORS
  • clrClientLinkSelected : XTP_TASKPANEL_GROUPCOLORS
  • clrClientText : XTP_TASKPANEL_GROUPCOLORS
  • clrDark : CXTPPaintManagerColorGradient
  • clrDarkShadow : CXTPTabPaintManagerColorSet::COLORSET_TAB_PROPERTYPAGE2003, CXTPTabPaintManagerColorSet::COLORSET_TAB_PROPERTYPAGE
  • clrDisabledIcon : CXTPColorSetStateToolbar
  • clrDropDownBack : CXTPColorSetStateComboBox
  • clrDropDownBackDisabled : CXTPColorSetStateComboBox
  • clrDropDownBackDropped : CXTPColorSetStateComboBox
  • clrDropDownBackHighlight : CXTPColorSetStateComboBox
  • clrDropDownBorder : CXTPColorSetStateComboBox
  • clrDropDownBorderDisabled : CXTPColorSetStateComboBox
  • clrDropDownBorderDropped : CXTPColorSetStateComboBox
  • clrDropDownBorderHighlight : CXTPColorSetStateComboBox
  • clrDropDownMarker : CXTPColorSetStateComboBox
  • clrDropDownMarkerDisabled : CXTPColorSetStateComboBox
  • clrDropDownMarkerDropped : CXTPColorSetStateComboBox
  • clrDropDownMarkerHighlight : CXTPColorSetStateComboBox
  • clrEdge : XTPRIBBON_HEADER_COLOR
  • clrEditBorder : CXTPColorSetStateToolbar
  • clrFace : CXTPTabPaintManagerColorSet::COLORSET_TAB_STATEBUTTON
  • clrForeground : XTP_DAYITEM_METRICS, XTP_GRIDRECORDITEM_METRICS
  • clrFrameBorder : CXTPTabPaintManagerColorSet::COLORSET_TAB_PROPERTYPAGE2003
  • clrGradActiveCapt : CXTPAuxData
  • clrGradInActiveCapt : CXTPAuxData
  • clrGrayText : CXTPAuxData
  • clrGripper : CXTPColorSetStateMenu, CXTPColorSetStateToolbar
  • clrHead : XTP_TASKPANEL_GROUPCOLORS
  • clrHeadTextHot : XTP_TASKPANEL_GROUPCOLORS
  • clrHeadTextNormal : XTP_TASKPANEL_GROUPCOLORS
  • clrHighlight : CXTPAuxData, CXTPTabPaintManagerColorSet::COLORSET_TAB_PROPERTYPAGE
  • clrHighlightText : CXTPAuxData
  • clrInActiveCaption : CXTPAuxData
  • clrInactiveCaptText : CXTPAuxData
  • clrLeftInnerBorder : CXTPTabPaintManagerColorSet::COLORSET_TAB_EXCEL
  • clrLeftOuterBorder : CXTPTabPaintManagerColorSet::COLORSET_TAB_EXCEL
  • clrLight : CXTPPaintManagerColorGradient
  • clrMenu : CXTPAuxData
  • clrMenuBack : CXTPColorSetStateMenu
  • clrMenuBorder : CXTPColorSetStateMenu
  • clrMenuText : CXTPAuxData
  • clrRightInnerBorder : CXTPTabPaintManagerColorSet::COLORSET_TAB_EXCEL
  • clrRightOuterBorder : CXTPTabPaintManagerColorSet::COLORSET_TAB_EXCEL
  • clrScrollArrow : XTP_SCROLLBARINICOLORS
  • clrScrollBack : XTP_SCROLLBARINICOLORS
  • clrScrollBorder : XTP_SCROLLBARINICOLORS
  • clrScrollDownArrow : XTP_SCROLLBARDRAWCOLORS
  • clrScrollDownBack : XTP_SCROLLBARDRAWCOLORS
  • clrScrollDownBorder : XTP_SCROLLBARDRAWCOLORS
  • clrSeparator : CXTPColorSetStateMenu, CXTPColorSetStateToolbar
  • clrShadow : CXTPTabPaintManagerColorSet::COLORSET_TAB_PROPERTYPAGE
  • clrTabBackInactive : CXTPColorSetStateRibbon
  • clrTabTextInactive : CXTPColorSetStateRibbon
  • clrText : CXTPColorSetStateButton, XTPRIBBON_HEADER_COLOR
  • clrTextChecked : CXTPColorSetStateButton
  • clrTextCheckedHighlight : CXTPColorSetStateButton
  • clrTextDisabled : CXTPColorSetStateButton
  • clrTextHighlight : CXTPColorSetStateButton
  • clrTextPushed : CXTPColorSetStateButton
  • clrThumbBack : XTP_SCROLLBARINICOLORS
  • clrThumbBorder : XTP_SCROLLBARINICOLORS
  • clrToolbarActiveBack : CXTPColorSetStateToolbar
  • clrToolbarActiveBorder : CXTPColorSetStateToolbar
  • clrToolbarBack : CXTPColorSetStateToolbar
  • clrToolbarBorder : CXTPColorSetStateToolbar
  • clrToolbarInactiveBack : CXTPColorSetStateToolbar
  • clrToolbarInactiveBorder : CXTPColorSetStateToolbar
  • clrTopInnerBorder : CXTPTabPaintManagerColorSet::COLORSET_TAB_EXCEL
  • clrTopOuterBorder : CXTPTabPaintManagerColorSet::COLORSET_TAB_EXCEL
  • clrVal : CXTPSkinManagerSchemaProperty
  • clrWindow : CXTPAuxData
  • clrWindowFrame : CXTPAuxData
  • clrWindowText : CXTPAuxData
  • clrXPBarFace : CXTPAuxData
  • clrXPBarText : CXTPAuxData
  • clrXPBarTextPushed : CXTPAuxData
  • clrXPDisabled : CXTPAuxData
  • clrXPGrayText : CXTPAuxData
  • clrXPGripper : CXTPAuxData
  • clrXPHighlight : CXTPAuxData
  • clrXPHighlightBorder : CXTPAuxData
  • clrXPHighlightChecked : CXTPAuxData
  • clrXPHighlightCheckedBorder : CXTPAuxData
  • clrXPHighlightPushed : CXTPAuxData
  • clrXPHighlightText : CXTPAuxData
  • clrXPIconShadow : CXTPAuxData
  • clrXPMenuBorder : CXTPAuxData
  • clrXPMenuExpanded : CXTPAuxData
  • clrXPMenuText : CXTPAuxData
  • clrXPMenuTextBack : CXTPAuxData
  • clrXPSeparator : CXTPAuxData
  • clrXPTabInactiveBack : CXTPAuxData
  • clrXPTabInactiveText : CXTPAuxData
  • cmdSB : XTP_SCROLLBAR_TRACKINFO
  • code : XTP_EDIT_NMHDR_PARSEEVENT
  • collBlock : XTP_EDIT_COLLAPSEDBLOCK
  • Color : CXTPChartAxisAppearance
  • color : CXTPTreeBase::CLRFONT
  • colorBack : CXTPTreeBase::CLRFONT
  • ConstantLineColor : CXTPChartAxisAppearance
  • ConstantLineTextColor : CXTPChartAxisAppearance
  • controlType : XTP_COMMANDBARS_CREATECONTROL
  • cpx : XTP_SCROLLBAR_POSINFO
  • cpxThumb : XTP_SCROLLBAR_POSINFO
  • crBack : CXTPListBase::ROWCOLOR, XTP_EDIT_COLORVALUES
  • crBreakpointBack : XTP_EDIT_COLORVALUES
  • crBreakpointText : XTP_EDIT_COLORVALUES
  • crHiliteBack : XTP_EDIT_COLORVALUES
  • crHiliteText : XTP_EDIT_COLORVALUES
  • crInactiveHiliteBack : XTP_EDIT_COLORVALUES
  • crInactiveHiliteText : XTP_EDIT_COLORVALUES
  • crLineNumberBack : XTP_EDIT_COLORVALUES
  • crLineNumberText : XTP_EDIT_COLORVALUES
  • crReadOnlyBack : XTP_EDIT_COLORVALUES
  • crTabBack : CXTPTcbItem
  • crTabSelBack : CXTPTcbItem
  • crTabSelText : CXTPTcbItem
  • crTabText : CXTPTcbItem
  • crText : CXTPListBase::ROWCOLOR, XTP_EDIT_COLORVALUES
  • cxHThumb : CXTPAuxData
  • cxSize : CXTPAuxData
  • cxSmIcon : CXTPAuxData
  • cyMenuItem : CXTPAuxData
  • cySize : CXTPAuxData
  • cySmIcon : CXTPAuxData
  • cyVThumb : CXTPAuxData


Toolkit Pro: Class Members - Variables

Here is a list of all documented variables with links to the class documentation for each member:

- d -

  • DaylightBias : CXTPCalendarTimeZones::REGISTRY_TIMEZONE_INFORMATION
  • DaylightDate : CXTPCalendarTimeZones::REGISTRY_TIMEZONE_INFORMATION
  • dayPOS : XTP_CALENDAR_HITTESTINFO
  • DefaultAntialiasing : CXTPChartDiagram3DAppearance
  • DefaultLightAmbientColor : CXTPChartDiagram3DAppearance
  • DefaultLightDiffuseColor : CXTPChartDiagram3DAppearance
  • DefaultLightModelAmbientColor : CXTPChartDiagram3DAppearance
  • DefaultLightPosition : CXTPChartDiagram3DAppearance
  • DefaultLightSpecularColor : CXTPChartDiagram3DAppearance
  • DefaultMaterialDiffuseColor : CXTPChartDiagram3DAppearance
  • DefaultMaterialEmissionColor : CXTPChartDiagram3DAppearance
  • DefaultMaterialShininess : CXTPChartDiagram3DAppearance
  • DefaultMaterialSpecularColor : CXTPChartDiagram3DAppearance
  • dHeadGradientFactor : XTP_TASKPANEL_GROUPCOLORS
  • dockDirection : XTP_DOCKINGPANE_ACTION
  • DownColor : CXTPChartFinanceStyleAppearance
  • dpxThumb : XTP_SCROLLBAR_TRACKINFO
  • dropEffect : XTP_NM_GRIDDRAGDROP
  • dt : XTP_CALENDAR_HITTESTINFO
  • dtBegin : XTP_CALENDAR_VIEWSELECTION
  • dtBeginTime : XTP_CALENDAR_DAYVIEWCELL_PARAMS, XTP_CALENDAR_THEME_DAYVIEWCELL_PARAMS, XTP_CALENDAR_THEME_DAYVIEWTIMESCALECELL_PARAMS
  • dtEnd : XTP_CALENDAR_VIEWSELECTION
  • dtScaleMaxTime : CXTPCalendarOptions
  • dtScaleMinTime : CXTPCalendarOptions
  • dtWorkDayEndTime : CXTPCalendarOptions
  • dtWorkDayStartTime : CXTPCalendarOptions
  • dwAdditionalOptions : CXTPCalendarOptions
  • dwConnectionID : CXTPNotifyConnection::CONNECTION_DESCRIPTOR, CXTPNotifySinkBase::ADVISE_DESCRIPTOR
  • dwData : CXTPSortClass::ITEMDATA
  • dwExStyle : CXTPTcbItem
  • dwKeyState : XTP_NM_GRIDDRAGDROP
  • dwNotifyCode : CXTPNotifyConnection::CONNECTION_DESCRIPTOR, CXTPNotifySinkBase::ADVISE_DESCRIPTOR
  • dwScrollBar : XTP_EDIT_NMHDR_ENABLESCROLLBAR
  • dwState : XTP_EDIT_NMHDR_ENABLESCROLLBAR
  • dwStyle : CXTPColorSelectorCtrl::COLOR_CELL, CXTPTcbItem
  • dwType : CXTPLogFont
  • dwUpdate : XTP_EDIT_NMHDR_SETSCROLLPOS


Toolkit Pro: Class Members - Variables

Here is a list of all documented variables with links to the class documentation for each member:

- e -

  • eOperation : XTP_EVENT_EDIT_OPERATION_PARAMS


Toolkit Pro: Class Members - Variables

Here is a list of all documented variables with links to the class documentation for each member:

- f -

  • fGradientFactor : CXTPPaintManagerColorGradient
  • fHitOld : XTP_SCROLLBAR_TRACKINFO
  • file : XTP_URI
  • fSizebox : XTP_SCROLLBAR_POSINFO
  • fVert : XTP_SCROLLBAR_POSINFO


Toolkit Pro: Class Members - Variables

Here is a list of all documented variables with links to the class documentation for each member:

- g -

  • grcCaption : CXTPColorManager
  • grcDockBar : CXTPColorManager
  • grcLunaChecked : CXTPColorManager
  • grcLunaPushed : CXTPColorManager
  • grcLunaSelected : CXTPColorManager
  • grcMenu : CXTPColorManager
  • grcMenuExpanded : CXTPColorManager
  • grcMenuItemPopup : CXTPColorManager
  • grcShortcutBarGripper : CXTPColorManager
  • grcToolBar : CXTPColorManager
  • GridLinesColor : CXTPChartAxisAppearance
  • GridLinesMinorColor : CXTPChartAxisAppearance


Toolkit Pro: Class Members - Variables

Here is a list of all documented variables with links to the class documentation for each member:

- h -

  • half : CXTPColorHex::CRgnCell::CTX_DATA::HEXAGON_DATA
  • hcurDragCopy : CXTPAuxData
  • hcurDragMove : CXTPAuxData
  • hcurDragNone : CXTPAuxData
  • hcurHand : CXTPAuxData
  • hcurHSplitBar : CXTPAuxData
  • hcurMove : CXTPAuxData
  • hcurVSplitBar : CXTPAuxData
  • hDC : XTP_EDIT_SENMBOOKMARK
  • hdr : NMXTPCONTROL, NMXTPSCROLL, XTP_NC_DATEPICKER_BUTTON, XTP_NM_FLOWGRAPH_CONNECTIONCHANGED, XTP_NM_FLOWGRAPH_CONNECTIONCHANGING, XTP_NM_FLOWGRAPH_ENDLABELEDIT, XTP_NM_FLOWGRAPH_NODECHANGED, XTP_NM_GRID_BEFORE_COPYPASTE, XTP_NM_GRIDCOLUMNORDERCHANGED, XTP_NM_GRIDCOLUMNRESIZE, XTP_NM_GRIDDRAGDROP, XTP_NM_GRIDITEMMETRICS, XTP_NM_GRIDPREVIEWKEYDOWN, XTP_NM_GRIDRECORDITEM, XTP_NM_GRIDROWRESIZE, XTP_NM_GRIDSTATECHANGED, XTP_NM_SELECTION_CHANGING, XTP_NM_TRACKCONTROL
  • Height : CXTPRectT< T >, CXTPSizeT< T >
  • height : CXTPColorHex::CRgnCell::CTX_DATA::HEXAGON_DATA
  • hResult : XTP_GRIDDATAMANAGER_COM_ERROR
  • ht : XTP_SCROLLBAR_POSINFO
  • hTimerSB : XTP_SCROLLBAR_TRACKINFO
  • hWndTrack : XTP_SCROLLBAR_TRACKINFO


Toolkit Pro: Class Members - Variables

Here is a list of all documented variables with links to the class documentation for each member:

- i -

  • iComCtlVersion : CXTPAuxData
  • InterlacedColor : CXTPChartAxisAppearance
  • InterlacedColor2 : CXTPChartAxisAppearance
  • InterlacedFillStyle : CXTPChartAxisAppearance
  • iRow : CXTPListBase::ROWCOLOR
  • iVal : CXTPSkinManagerSchemaProperty


Toolkit Pro: Class Members - Variables

Here is a list of all documented variables with links to the class documentation for each member:

- k -

  • keyboardCuesUse : CXTPCommandBarsOptions


Toolkit Pro: Class Members - Variables

Here is a list of all documented variables with links to the class documentation for each member:

- l -

  • lcEnd : XTP_EDIT_ROWSBLOCK
  • lcStart : XTP_EDIT_ROWSBLOCK
  • left : XTP_RESIZERECT
  • lf : XTP_EDIT_TEXTBLOCK
  • lfVal : CXTPSkinManagerSchemaProperty
  • lg : CXTPColorHex::CRgnCell::CTX_DATA
  • LightAmbientColor : CXTPChartDiagram3DAppearance
  • LightDiffuseColor : CXTPChartDiagram3DAppearance
  • LightModelAmbientColor : CXTPChartDiagram3DAppearance
  • LightSpecularColor : CXTPChartDiagram3DAppearance
  • logfont : CXTPTreeBase::CLRFONT
  • lParam : CXTPListBase::ROWCOLOR, XTP_EDIT_NMHDR_PARSEEVENT
  • lpcstrCaption : XTP_COMMANDBARS_CREATEBAR
  • lpi : XTP_LVITEMDATA, XTP_TVITEMDATA
  • lpifq : XTP_TVITEMDATA
  • lpName : XTP_URI
  • lpsfParent : XTP_LVITEMDATA, XTP_TVITEMDATA
  • lpszCaption : XTP_RESOURCEMANAGER_LANGINFO
  • lpszEncoding : XTP_RESOURCEMANAGER_LANGINFO
  • lpszLang : XTP_RESOURCEMANAGER_LANGINFO
  • lpszSubLang : XTP_RESOURCEMANAGER_LANGINFO
  • lpszVal : CXTPSkinManagerSchemaProperty
  • lpType : XTP_URI, XTP_URI_DEFAULTS


Toolkit Pro: Class Members - Variables

Here is a list of all documented variables with links to the class documentation for each member:

- m -

  • m_Across : CXTPPreviewView
  • m_afterCloseTabPosition : CXTPTabClientWnd
  • m_Alignment : CXTPGridRecordItem, CXTPGridRecordItemControl
  • m_anchorBounds : CXTPChartPieBase
  • m_aPageStart : CXTPSyntaxEditView
  • m_ar : CXTPPropExchangeArchive
  • m_arActiveReminders : CXTPCalendarRemindersDialog, CXTPCalendarRemindersManager
  • m_arBuffer : CXTPSyntaxEditTextIterator
  • m_arBusyStatusBrushes : CXTPCalendarPaintManager
  • m_arButton : CXTPEditListBoxToolBar
  • m_arCells : CXTPColorSelectorCtrl
  • m_arChecked : CXTPCalendarEventCategoryComboBox, CXTPCalendarEventColorListBox
  • m_arClipRect : CXTPEditListBoxToolBar
  • m_arColHeaderText : CXTPCalendarMonthView::CMonthViewGrid
  • m_arCollapsedTextRows : CXTPSyntaxEditCtrl
  • m_arColsLeftX : CXTPCalendarMonthView::CMonthViewGrid
  • m_arContentItems : CXTPShortcutListBox
  • m_arData : CXTPSyntaxEditCtrl::CAverageVal
  • m_arDataProviders : CXTPCalendarResourcesManager
  • m_arDayOfWeekNames : CXTPDatePickerControl
  • m_arDays : CXTPCalendarView
  • m_arElements : CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE >, CXTPCalendarPtrCollectionT< _TObject >
  • m_arEndSeps : CXTPSyntaxEditLexTokensDef
  • m_arEvents : CXTPCalendarEvents, CXTPCalendarViewGroup
  • m_arFrozenCols : CXTPHeaderCtrl
  • m_arHideCtrls : CXTPSearchOptionsCtrl
  • m_arMDIChildern : CXTPMDIWndTab
  • m_arMonthNames : CXTPDatePickerControl
  • m_arMoveCtrls : CXTPSearchOptionsCtrl
  • m_arOnScreenSchCache : CXTPSyntaxEditCtrl
  • m_arPersistentModuleCache : CXTPSkinManager
  • m_arrAccels : CXTPShortcutManagerAccelTable
  • m_arrACData : CXTPSyntaxEditAutoCompleteWnd
  • m_arrACDataFiltered : CXTPSyntaxEditAutoCompleteWnd
  • m_arrActions : CXTPControlActions
  • m_arrAlloc : CXTPImageManagerResource
  • m_arrBars : CXTPCommandBarList, CXTPCommandBars, CXTPDockBar
  • m_arrBlocks : CXTPTrackControlItem
  • m_arrButtons : CXTPDatePickerControl, CXTPMessageBar, CXTPPropertySheet, CXTPSkinObjectFrame, CXTPTabManagerNavigateButtons, CXTPTaskDialog
  • m_arrCategories : CXTPCustomizeCommandsPage, CXTPCustomizeKeyboardPage, CXTPRibbonCustomizePage, CXTPRibbonCustomizeQuickAccessPage
  • m_arrChildren : CXTPChartDeviceCommand, CXTPChartElementView
  • m_arrColor : CXTPDockingPanePaintManager, CXTPPaintManager
  • m_arrColumns : CXTPGridColumnOrder, CXTPGridColumns
  • m_arrCommandButtons : CXTPTaskDialogClient
  • m_arrConnectionPoints : CXTPFlowGraphConnectionPoints
  • m_arrConnections : CXTPFlowGraphConnections, CXTPNotifyConnection
  • m_arrConstraints : CXTPGridRecordItemConstraints
  • m_arrControls : CXTPControlAction, CXTPControls, CXTPPropertyGridInplaceControls, CXTPRibbonGroup
  • m_arrDays : CXTPDatePickerItemMonth
  • m_arrDragBlocks : CXTPTrackControl
  • m_arRecentColors : CXTPColorSelectorCtrl
  • m_arrElements : CXTPChartElementCollection
  • m_arrEntries : CXTPChartPalette
  • m_arResizeWnd : CXTPSearchOptionsView
  • m_arResources : CXTPCalendarResourcesManager
  • m_arrFilters : CXTPSkinManager
  • m_arrFrameRegions : CXTPSkinManagerSchema
  • m_arrGrid : CXTPSyntaxEditAutoCompleteWnd
  • m_arrGroups : CXTPFlowGraphNodeGroups, CXTPRibbonGroups
  • m_arrGroupStack : CXTPFlowGraphUndoManager
  • m_arrIcons : CXTPImageManagerResource
  • m_arrImages : CXTPFlowGraphImages
  • m_arrItems : CXTPChartLegendView, CXTPControlGalleryItems, CXTPGridRecord, CXTPPopupControl, CXTPResize, CXTPShortcutBar, CXTPShortcutBarPane, CXTPTabManager, CXTPTaskPanelItems
  • m_arrLinkButtons : CXTPTaskDialogClient
  • m_arrLinks : CXTPTaskDialogLinkCtrl
  • m_arrMarkers : CXTPTrackMarkers
  • m_arrMonths : CXTPDatePickerControl
  • m_arrNavigateButtons : CXTPTabManager, CXTPTabManagerItem
  • m_arrNodes : CXTPFlowGraphNodeGroup, CXTPFlowGraphNodes
  • m_arrObservers : CXTPTabPaintManager
  • m_arRowColor : CXTPListBase
  • m_arRowsTopY : CXTPCalendarMonthView::CMonthViewGrid
  • m_arrPageRedo : CXTPFlowGraphPageHistory
  • m_arrPages : CXTPFlowGraphPages, CXTPPropertySheet
  • m_arrPageUndo : CXTPFlowGraphPageHistory
  • m_arrPanes : CXTPStatusBar
  • m_arrRadioButtons : CXTPTaskDialog, CXTPTaskDialogClient
  • m_arrRecords : CXTPGridRecords
  • m_arrRects : CXTPControlGallery
  • m_arrRedoCommands : CXTPFlowGraphUndoManager, CXTPTrackUndoManager
  • m_arrSelectedBlocks : CXTPDatePickerDaysCollection
  • m_arrSelectedElements : CXTPFlowGraphSelectedElements
  • m_arrSendQueueCache : CXTPNotifyConnection
  • m_arrSeries : CXTPChartDiagram
  • m_arrSolidRects : CXTPSkinImage
  • m_arrStyles : CXTPTagCloudStyleManager
  • m_arrSwitches : CXTPStatusBarSwitchPane
  • m_arrTags : CXTPTagCloudCtrl
  • m_arrTagsSorted : CXTPTagCloudCtrl
  • m_arrTicks : CXTPChartDiagram2DAxisView, CXTPChartRadarAxisXView, CXTPChartRadarAxisYView
  • m_arrTips : CXTPTipOfTheDay
  • m_arrTools : CXTPToolTipContextToolTip
  • m_arrUndoCommands : CXTPFlowGraphUndoGroupCommand, CXTPFlowGraphUndoManager, CXTPTrackUndoGroupCommand, CXTPTrackUndoManager
  • m_arrVerbs : CXTPPropertyGridVerbs
  • m_arrWorkspace : CXTPTabClientWnd
  • m_arScheduleIDs : CXTPCalendarResource
  • m_arStandardColors : CXTPColorPicker, CXTPColorSelectorCtrl
  • m_arStartCol : CXTPCalendarPaintManager, CXTPGridPaintManager
  • m_arStartRow : CXTPCalendarPaintManager
  • m_arStartSeps : CXTPSyntaxEditLexTokensDef
  • m_arStrings : CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager, CXTPTipWindow
  • m_arStrVals : CXTPSyntaxEditLexVariant
  • m_arThemeColors : CXTPColorPicker, CXTPColorSelectorCtrl
  • m_arTokens : CXTPSyntaxEditLexTokensDef
  • m_arTrayIcons : CXTPTrayIcon
  • m_arTZInfo : CXTPCalendarTimeZones
  • m_arValidDispRows : CXTPSyntaxEditCtrl
  • m_arViewGroups : CXTPCalendarViewDay
  • m_arWaitingReminders : CXTPCalendarRemindersManager
  • m_aveRedrawScreenTime : CXTPSyntaxEditCtrl
  • m_b3SmallCal : CXTPCalendarControlViewPrintOptions
  • m_bAcceptFocus : CXTPTaskPanel
  • m_bActivated : CXTPMiniToolBar
  • m_bActivateOnFocus : CXTPSyntaxEditCtrl
  • m_bActive : CXTPCommandBarsFrameHook, CXTPDialogBar, CXTPDockingPaneTabbedContainer, CXTPSkinObjectFrame, CXTPSyntaxEditAutoCompleteWnd, CXTPTabManager, CXTPTagCloudCtrl, CXTPToolTipContextToolTip
  • m_bActiveX : CXTPSkinObject
  • m_bAddEvent : CXTPCalendarEventPropertiesDlg
  • m_bAddressIsWide : CXTPHexEdit
  • m_bAdjustLayoutRunning : CXTPGridControl
  • m_bAdjustScrollBars : CXTPFlowGraphControl
  • m_bAdvancedMode : CXTPCalendarTip
  • m_bAlignShortcut : CXTPRibbonControlSystemPopupBarListItem
  • m_bAllDayEvent : CXTPCalendarEvent, CXTPCalendarEventPropertiesDlg
  • m_bAllowAccess : CXTPGridSection
  • m_bAllowApply : CXTPPropertySheet
  • m_bAllowBlockMove : CXTPTrackControl
  • m_bAllowBlockRemove : CXTPTrackControl
  • m_bAllowBlockScale : CXTPTrackControl
  • m_bAllowCollapse : CXTPShortcutBar
  • m_bAllowColumnRemove : CXTPGridHeader
  • m_bAllowColumnReorder : CXTPGridHeader
  • m_bAllowColumnResize : CXTPGridHeader
  • m_bAllowColumnSort : CXTPGridHeader
  • m_bAllowCut : CXTPGridView
  • m_bAllowDeletes : CXTPHexEdit
  • m_bAllowDoubleKeyShortcuts : CXTPShortcutManager
  • m_bAllowDrag : CXTPGridColumn
  • m_bAllowDrop : CXTPTaskPanel, CXTPTaskPanelItem
  • m_bAllowEdit : CXTPGridRecordItemEditOptions, CXTPGridSection, CXTPPropertyGrid
  • m_bAllowEscapeShortcut : CXTPShortcutManager
  • m_bAllowFilter : CXTPGridSection
  • m_bAllowFreeResize : CXTPShortcutBar
  • m_bAllowGroup : CXTPGridSection
  • m_bAllowMergeCells : CXTPGridPaintManager
  • m_bAllowMinimize : CXTPRibbonBar
  • m_bAllowModifyConnections : CXTPFlowGraphControl
  • m_bAllowMove : CXTPPopupControl
  • m_bAllowMoveNodes : CXTPFlowGraphControl
  • m_bAllowNewToolbars : CXTPCustomizeToolbarsPage
  • m_bAllowNoncontinuousSelection : CXTPDatePickerControl
  • m_bAllowPaste : CXTPGridView
  • m_bAllowQuickAccessCustomization : CXTPRibbonBar
  • m_bAllowQuickAccessDuplicates : CXTPRibbonBar
  • m_bAllowRemove : CXTPGridColumn
  • m_bAllowReorder : CXTPTabClientWnd, CXTPTabManager
  • m_bAllowResize : CXTPShortcutBar
  • m_bAllowSort : CXTPGridSection
  • m_bAlpha : CXTPFlowGraphNode, CXTPGraphicBitmapPng, CXTPResourceImage, CXTPSkinImage
  • m_bAlphaDockingContext : CXTPDockingPaneManager
  • m_bAlwaysDrawConnectionPoints : CXTPFlowGraphPaintManager
  • m_bAnimatePopup : CXTPCommandBar
  • m_bAnimation : CXTPScrollBase, CXTPTaskPanel
  • m_bAntiAlias : CXTPChartPolygonAntialiasingDeviceCommand, CXTPChartTextAntialiasingDeviceCommand
  • m_bAntialiasing : CXTPChart3dDeviceContext, CXTPChartAxisConstantLine, CXTPChartAxisLabel, CXTPChartAxisTitle, CXTPChartLegend, CXTPChartSeriesLabel, CXTPChartTitle
  • m_bAppCaption : CXTPCaption
  • m_barPosition : CXTPCommandBar
  • m_bArrangeDirty : CXTPMarkupUIElement
  • m_bArrangeInProgress : CXTPMarkupUIElement
  • m_barType : CXTPCommandBar
  • m_bAsc : CXTPTagCloudCtrl
  • m_bAscending : CXTPHeaderCtrl, CXTPListBase
  • m_bAutoApplyThreads : CXTPSkinManager
  • m_bAutoApplyWindows : CXTPSkinManager
  • m_bAutoArrangeEditCaption : CXTPRibbonGroup
  • m_bAutoCheckItems : CXTPGridControl
  • m_bAutoColumnSizing : CXTPGridHeader
  • m_bAutoComp : CXTPComboBox
  • m_bAutoComplete : CXTPControlComboBox, CXTPPropertyGridItem
  • m_bAutoCondensing : CXTPTabBase
  • m_bAutoDelete : CXTPColorPopup, CXTPItemEdit, CXTPPopupControl, CXTPResizeItem
  • m_bAutoDelete_Custom : CXTPCalendarViewPartCustomizableValueT< _TValue >
  • m_bAutoDelete_Standard : CXTPCalendarViewPartCustomizableValueT< _TValue >
  • m_bAutoDeleteWnd : CXTPStatusBarPane
  • m_bAutoDestroy : CXTPHookManagerHookAble
  • m_bAutoDestroy_Custom : CXTPCalendarThemeCustomizableXValueT< _TValue, _TValueRef >
  • m_bAutoDestroy_Standard : CXTPCalendarThemeCustomizableXValueT< _TValue, _TValueRef >
  • m_bAutoDivider : CXTPPropertyGridView
  • m_bAutoFont : CXTPListBase
  • m_bAutoHeight : CXTPTaskPanelGroupItem
  • m_bAutoIndent : CXTPSyntaxEditOptions
  • m_bAutoInit : CXTPShellTreeCtrl
  • m_bAutoInitialUpdate : CXTPDockingPaneManager
  • m_bAutoNumbering : CXTPGridColumn
  • m_bAutoPopup : CXTPCalendarRemindersDialog
  • m_bAutoReload : CXTPSyntaxEditDoc
  • m_bAutoResample : CXTPImageManager
  • m_bAutoResizeIcons : CXTPPaintManager
  • m_bAutoSave : CXTPListBase
  • m_bAutoScaleDpi : CXTPControlGallery
  • m_bAutoScaleDpiGalleryItems : CXTPCommandBarsOptions
  • m_bAutoScaleDpiToolbarIcons : CXTPCommandBarsOptions
  • m_bAutoSize : CXTPDatePickerControl, CXTPGridColumn, CXTPHeaderCtrl, CXTPMessageBar
  • m_bAutoSortWhenGrouped : CXTPGridColumn
  • m_bAutoTheme : CXTPTabClientWnd
  • m_bAutoUpdateTabCaption : CXTPTabClientWnd
  • m_bBandLabel : CXTPTreeBase
  • m_bBaseTreeIndent : CXTPGridPaintManager
  • m_bBeginGroup : CXTPControl, CXTPStatusBarPane
  • m_bBeingDestructed : CXTPCommandBarsFrameHook
  • m_bBlockSelection : CXTPGridControl
  • m_bBlurPoints : CAppearanceSetPropertyPageFlat
  • m_bBold : CXTPPopupItem, CXTPTaskPanelGroupItem
  • m_bBoldCaption : CXTPTaskPanelPaintManager
  • m_bBoldDaysOnIdle : CXTPCalendarController
  • m_bBoldDaysWithEvents : CXTPCalendarController
  • m_bBoldFont : CXTPTabBase
  • m_bBoldItemCaptionFont : CXTPShortcutBarPaintManager
  • m_bBoldNormal : CXTPTabPaintManager
  • m_bBoldSelected : CXTPTabPaintManager
  • m_bBoldText : CXTPGridRecordItem
  • m_bBorderVisible : CXTPChartMarker
  • m_bBrowsing : CXTPBrowseEdit
  • m_bBuiltIn : CXTPToolBar
  • m_bButton : CXTPPopupItem, CXTPStatusBarPane
  • m_bButtonPressed : CXTPCommandBarsFrameHook
  • m_bButtonsReverseZOrder : CXTPTabPaintManagerTheme
  • m_bCancel : CXTPPropertyGridInplaceEdit
  • m_bCanEditCheckboxItem : CXTPGridRecordItem
  • m_bCaptionCenterAligned : CXTPFramePaintManager
  • m_bCaptionPopup : CXTPDialogBar
  • m_bCaptions : CXTPColorPicker, CXTPColorSelectorCtrl
  • m_bCaptionScrollButton : CXTPTaskPanelPaintManager
  • m_bCaptionVisible : CXTPDialogBar, CXTPTaskPanelGroup
  • m_bCaseSensitive : CXTPGridRecords, CXTPSyntaxEditCtrl
  • m_bCategories : CXTPCalendarEventColorDlg, CXTPCalendarEventColorListBox, CXTPCalendarEventColorNewDlg
  • m_bCategory : CXTPPropertyGridItem
  • m_bCenterHorz : CXTPTipWindow
  • m_bChanged : CXTPDatePickerControl, CXTPGridControl, CXTPMenuBarMDIMenuInfo
  • m_bChangeNodeColorWhenSelected : CXTPFlowGraphPaintManager
  • m_bCheckAutoComplete : CXTPPropertyGridInplaceEdit
  • m_bCheckBoxStyle : CXTPPropertyGridItemBool, CXTPPropertyGridItemOption
  • m_bChecked : CXTPButton, CXTPControl, CXTPControlAction
  • m_bChildSection : CXTPPropExchange
  • m_bClassicStyle : CXTPTipOfTheDay
  • m_bCleanTooltip : CXTPGridPaintManager
  • m_bClearHandles : CXTPImageManagerIconHandle
  • m_bClearTypeTextQuality : CXTPPaintManager, CXTPShortcutBarPaintManager, CXTPTabPaintManager
  • m_bClientPaneVisible : CXTPShortcutBar
  • m_bClipHeader : CXTPTabPaintManager
  • m_bClipItems : CXTPControlGalleryItems
  • m_bClipStyles : CXTPSplitterWnd
  • m_bClosable : CXTPTabManagerItem
  • m_bCloseable : CXTPCommandBar
  • m_bCloseActiveWindow : CXTPDockingPaneAutoHidePanel
  • m_bCloseDataProviderWhenDestroy : CXTPCalendarResource
  • m_bCloseEnabled : CXTPDockingPaneMiniWnd
  • m_bCloseGroupOnButtonClick : CXTPDockingPaneManager
  • m_bCloseItemButton : CXTPTabManager
  • m_bCloseParentKey : CXTPPropExchangeRegistry
  • m_bClosePosted : CXTPItemEdit
  • m_bCloseSubMenuOnClick : CXTPControl
  • m_bCollapsed : CXTPDockingPaneMiniWnd, CXTPDockingPaneSidePanel, CXTPPopupBar
  • m_bColorEach : CXTPChartSeriesStyle
  • m_bColorText : CXTPColorPicker
  • m_bColumnPlusMinusSign : CXTPGridPaintManager
  • m_bColumnWidthWYSIWYG : CXTPGridPaintManager
  • m_bComboBar : CXTPCommandBar
  • m_bCompactMode : CXTPPropExchangeXMLNode
  • m_bCompactText : CXTPGridPaintManager
  • m_bComposited : CXTPCommandBarEditCtrl
  • m_bConfigChangedReparceInSeparateThread : CXTPSyntaxEditLexParserSchemaOptions
  • m_bConfigFileMode : CXTPSyntaxEditConfigurationManager, CXTPSyntaxEditCtrl
  • m_bConnectorVisible : CXTPChart3dFunnelSeriesLabelView, CXTPChart3dPieSeriesLabelView, CXTPChart3dPyramidSeriesLabelView
  • m_bConstraintEdit : CXTPGridRecordItemEditOptions, CXTPPropertyGridItem
  • m_bContextMenu : CXTPPopupBar, CXTPShellListBase, CXTPShellTreeBase
  • m_bContextMenuPresent : CXTPToolBar
  • m_bControlsCentering : CXTPRibbonGroup
  • m_bControlsGrouping : CXTPRibbonGroup
  • m_bControlVisible : CXTPControlCustom
  • m_bCreated : CXTPGridControl, CXTPPropertyGridInplaceEdit
  • m_bCreateScrollbarOnParent : CXTPFlowGraphControl, CXTPSyntaxEditCtrl
  • m_bCrossAxis : CXTPChartAxisTickMarks
  • m_bCustomizable : CXTPCommandBar, CXTPStatusBar, CXTPStatusBarPane
  • m_bCustomizeAvail : CXTPCommandBars
  • m_bCustomizeDialogPresent : CXTPCommandBar
  • m_bCustomizeMode : CXTPCommandBars
  • m_bDarkTheme : CXTPTreeTheme
  • m_bDefaultItem : CXTPControl
  • m_bDefaultResetCustomizedToolbarChoice : CXTPCommandBars
  • m_bDefaultResetCustomizedToolbarChoiceEnabled : CXTPCommandBars
  • m_bDefaultValues : CXTPCalendarEventCategories, CXTPCalendarEventLabels
  • m_bDefMenuItemByPos : CXTPTrayIcon
  • m_bDelayCreate : CXTPPropertyGridInplaceEdit
  • m_bDelayDestroy : CXTPControlComboBox, CXTPControlEdit
  • m_bDelayInvalidate : CXTPDockingPaneMiniWnd
  • m_bDelayLock : CXTPTabClientWnd
  • m_bDelayReclalcLayout : CXTPCommandBarsFrameHook
  • m_bDelayRedraw : CXTPDockingPaneTabbedContainer
  • m_bDelayReposition : CXTPControlComboBox, CXTPControlEdit
  • m_bDelayTimerRunning : CXTPTipWindow
  • m_bDeleteOcurrenceEventIfNoPrompt : CXTPCalendarControl
  • m_bDeleteOnFinalRelease : CXTPCalendarControl, CXTPDatePickerControl
  • m_bDesignerMode : CXTPCommandBars
  • m_bDesktopTrackerMode : CXTPGridControl
  • m_bDestroyCustomTitleBrushes : CXTPDockingPanePaintManager
  • m_bDF_mode : CXTPCalendarControlView, CXTPCalendarDayView
  • m_bDirectionClockwise : CXTPChartRadarAxisX
  • m_bDirty : CXTPFlowGraphElement
  • m_bDisableAC : CXTPComboBox
  • m_bDisableNotificationsSending : CXTPCalendarData
  • m_bDisableOnCapture : CXTPShortcutManager
  • m_bDisableRedraw : CXTPCalendarControl, CXTPSyntaxEditCtrl
  • m_bDisableRemove : CXTPCalendarEventRecurrenceDlg
  • m_bDisplayShadow : CXTPColorPopup
  • m_bDocCreated : CXTPSyntaxEditDoc
  • m_bDoDefaultItemDrawing : CXTPTreeBase
  • m_bDotTracker : CXTPSplitterWnd
  • m_bDoubleBuffering : CXTPGridControl
  • m_bDoubleGripper : CXTPPopupBar
  • m_bDoubleHighlightedBorder : CAppearanceSetPropertyPage2003
  • m_bDoughnut : CXTPChartPieDeviceCommandImpl
  • m_bDpiBitmapScaling : CXTPHeaderCtrl
  • m_bDpiBitmapScalingModified : CXTPHeaderCtrl
  • m_bDraftMode : CXTPCalendarDayView, CXTPCalendarMonthView
  • m_bDragable : CXTPCustomizeCommandsListBox
  • m_bDragging : CXTPSyntaxEditCtrl, CXTPTrackBlock
  • m_bDraggingOver : CXTPSyntaxEditView
  • m_bDraggingStartedHere : CXTPSyntaxEditView
  • m_bDragGroupBox : CXTPGridHeader
  • m_bDragHeader : CXTPGridHeader
  • m_bDragKeyboard : CXTPDockingPaneContext
  • m_bDragMode : CXTPGridControl
  • m_bDrawCaptionIcon : CXTPDockingPanePaintManager
  • m_bDrawComposited : CXTPImageManagerIcon
  • m_bDrawDisabledText : CXTPStatusBar
  • m_bDrawFocusRect : CXTPTabPaintManager, CXTPTaskPanel, CXTPTreeTheme
  • m_bDrawFooterDivider : CXTPGridColumn
  • m_bDrawFooterRowsVGrid : CXTPGridColumn
  • m_bDrawGridForEmptySpace : CXTPGridPaintManager
  • m_bDrawGripper : CXTPDockingPaneOffice2003Theme
  • m_bDrawHeaderDivider : CXTPGridColumn
  • m_bDrawHeaderRowsVGrid : CXTPGridColumn
  • m_bDrawNodes : CXTPSyntaxEditOptions
  • m_bDrawNowLine : CXTPCalendarDayViewTimeScale
  • m_bDrawSingleTab : CXTPDockingPanePaintManager
  • m_bDrawTextEndEllipsis : CXTPTabPaintManager
  • m_bDrawTextHidePrefix : CXTPTabPaintManager
  • m_bDrawTextNoPrefix : CXTPTabPaintManager
  • m_bDrawTextPathEllipsis : CXTPTabPaintManager
  • m_bDropDown : CXTPControlComboBox
  • m_bDroppable : CXTPSyntaxEditCtrl
  • m_bDwmEnabled : CXTPCommandBarsFrameHook
  • m_bDynamicBPR : CXTPHexEdit
  • m_bDynamicLayout : CXTPPopupBar
  • m_bEcoAllDayMode : CXTPCalendarDayView
  • m_bEditable : CXTPGridColumn, CXTPGridRecord, CXTPGridRecordItem
  • m_bEditChanged : CXTPControlComboBox, CXTPControlEdit
  • m_bEditMode : CXTPPropertyGridInplaceEdit
  • m_bEditOnClick : CXTPGridControl
  • m_bEditOnDelayClick : CXTPGridControl
  • m_bEditOnDoubleClick : CXTPGridControl
  • m_bEditReparceInSeparateThread : CXTPSyntaxEditLexParserSchemaOptions
  • m_bEmbossedDisabledText : CXTPPaintManager, CXTPTaskPanelPaintManager
  • m_bEmptySection : CXTPPropExchange
  • m_bEmulateEplorerTheme : CXTPTaskPanelPaintManager
  • m_bEnableActions : CXTPCommandBars
  • m_bEnableAnimation : CXTPPaintManager
  • m_bEnabled : CXTPCalendarResourceDescription, CXTPCommandBarKeyboardTip, CXTPControl, CXTPControlAction, CXTPControlGalleryItem, CXTPDockingPane, CXTPExcelTabCtrlButtonState, CXTPFlowGraphUndoManager, CXTPGridRecordItemControl, CXTPPropertyGridItemConstraint, CXTPShortcutBarItem, CXTPShortcutListBox::CONTENT_ITEM, CXTPSkinManager, CXTPTabManagerItem, CXTPTabManagerNavigateButton, CXTPTaskPanelItem
  • m_bEnableEdit : CXTPEditListBox, CXTPEditListBoxToolBar
  • m_bEnableEditAccelerators : CXTPSyntaxEditOptions
  • m_bEnableGroups : CXTPTabClientWnd
  • m_bEnableLunaBlueForAeroTheme : CXTPColorManager
  • m_bEnableLunaBlueForRoyaleTheme : CXTPColorManager
  • m_bEnableMarkup : CXTPButton, CXTPComboBox, CXTPTaskDialogClient
  • m_bEnableMenus : CXTPHeaderCtrl
  • m_bEnableOleDrag : CXTPSyntaxEditCtrl
  • m_bEnableTheme : CXTPCalendarPaintManager, CXTPDatePickerPaintManager
  • m_bEnableTooltips : CXTPPropertyGrid
  • m_bEnableWhiteSpace : CXTPSyntaxEditOptions
  • m_bEndByParent : CXTPSyntaxEditLexTextBlock
  • m_bEnsureFocusedRowVisible : CXTPGridControl
  • m_bEnsureSelectedTab : CXTPDockingPaneTabbedContainer
  • m_bEOF : CXTPSyntaxEditTextIterator
  • m_bEscapeKey : CXTPFlowGraphEditItem, CXTPItemEdit
  • m_bEventVisible : CXTPCalendarEvent
  • m_bExecOnRButton : CXTPCommandBar
  • m_bExpandable : CXTPPropertyGridItem, CXTPShortcutBarPaneItem, CXTPTaskPanel, CXTPTaskPanelGroup
  • m_bExpandButton : CXTPShortcutBarItem
  • m_bExpandDOWN : CXTPCalendarDayViewGroup
  • m_bExpanded : CXTPControl, CXTPDockingPaneMiniWnd, CXTPDockingPaneSidePanel, CXTPGridColumn, CXTPGridRecord, CXTPGridRow, CXTPPopupBar, CXTPPropertyGridItem, CXTPSearchOptionsCtrl, CXTPShortcutBarItem, CXTPShortcutBarPaneItem, CXTPTaskDialogClient, CXTPTaskPanelGroup
  • m_bExpanding : CXTPPopupBar, CXTPTaskPanelGroup
  • m_bExpandOnSelect : CXTPGridRecordItemEditOptions
  • m_bExpandUP : CXTPCalendarDayViewGroup
  • m_bExplicit : CXTPCommandBarKeyboardTip
  • m_bExplorerStyle : CXTPShellTreeBase
  • m_bExplorerTheme : CXTPTaskPanelExplorerTheme, CXTPTaskPanelExplorerThemePlain, CXTPTreeBase
  • m_bFastDeselectMode : CXTPGridControl
  • m_bFilesDragging : CXTPSyntaxEditView
  • m_bFillBackground : CXTPTabPaintManager
  • m_bFilterable : CXTPGridColumn
  • m_bFiltered : CXTPSkinImage
  • m_bFilteredMode : CXTPSyntaxEditAutoCompleteWnd
  • m_bFilterHiddenColumns : CXTPGridControl
  • m_bFirstParseInSeparateThread : CXTPSyntaxEditLexParserSchemaOptions
  • m_bFixed : CXTPGridColumn
  • m_bFixedBottom : CXTPSyntaxEditAutoCompleteWnd
  • m_bFixedInplaceButtonHeight : CXTPGridPaintManager
  • m_bFixedRowHeight : CXTPGridPaintManager
  • m_bFlatFrame : CXTPFramePaintManager, CXTPRibbonPaintManager
  • m_bFlatMenuBar : CXTPPaintManager
  • m_bFlatMenus : CXTPCommandBarsNativeXPTheme
  • m_bFlatStyle : CXTPButton, CXTPComboBox, CXTPEditTheme, CXTPProgressCtrl
  • m_bFlatToolBar : CXTPPaintManager
  • m_bFlexibleDrag : CXTPTrackControl
  • m_bFlipped : CXTPResourceImage
  • m_bFocusable : CXTPGridRecordItem
  • m_bFocused : CXTPComboBox, CXTPControlComboBox, CXTPControlEdit, CXTPEdit, CXTPRibbonControlTab, CXTPSyntaxEditCtrl
  • m_bFocusRect : CXTPTagCloudCtrl
  • m_bFocusSubItems : CXTPGridControl
  • m_bFooterVisible : CXTPGridControl
  • m_bForceDynamicMarkupForCell : CXTPGridPaintManager
  • m_bForcePagination : CXTPCalendarControl, CXTPGridControl
  • m_bForceRecalc : CXTPControlTabWorkspace
  • m_bForceShowDropMarker : CXTPGridPaintManager
  • m_bForceShowTooltip : CXTPGridPaintManager
  • m_bForceToRecalc : CXTPTabClientWnd
  • m_bFrameStatusBar : CXTPFramePaintManager
  • m_bFreeHeightMode : CXTPGridControl
  • m_bFreeOnRelease : CXTPResourceImages
  • m_bFriday : CXTPCalendarEventRecurrenceDlg
  • m_bFrozen : CXTPGridColumn
  • m_bFullDateMode : CXTPCalendarControl
  • m_bFullDrag : CXTPSplitterWnd
  • m_bGenerateName : CXTPCalendarResourceDescription
  • m_bGrabbingFocus : CXTPTaskPanel
  • m_bGrabFocus : CXTPCommandBar
  • m_bGradientButton : CColorSetVisualStudio2005, CXTPTabColorSetVisualStudio2008, CXTPTabColorSetVisualStudio2010
  • m_bGradientCaption : CXTPDockingPaneVisualStudio2003Theme
  • m_bGrayIfDisable : CXTPGridPaintManager
  • m_bGridSpacingAuto : CXTPChartAxis
  • m_bGroupable : CXTPGridColumn
  • m_bGroupByEnabled : CXTPGridControl
  • m_bGroupInsertMode : CXTPSyntaxEditUndoRedoManager
  • m_bGroupReducedChanged : CXTPRibbonBar
  • m_bGroupRowTextBold : CXTPGridPaintManager
  • m_bGroupsVisible : CXTPRibbonBar
  • m_bHasCheckbox : CXTPGridRecordItem
  • m_bHasSelectedChilds : CXTPGridRow
  • m_bHeaderVisible : CXTPGridControl
  • m_bHelpVisible : CXTPPropertyGrid
  • m_bHidden : CXTPPropertyGridItem, CXTPShortcutBarItem, CXTPTrayIcon
  • m_bHideCaptionBar : CXTPCalendarControl
  • m_bHideCaret : CXTPSyntaxEditOptions
  • m_bHideClient : CXTPDockingPaneManager
  • m_bHideColumnAfterGroupBoxDrop : CXTPGridHeader
  • m_bHideEventTime : CXTPCalendarDayViewEvent
  • m_bHideGroupOnButtonClick : CXTPDockingPaneManager
  • m_bHideLinkContainer : CXTPCalendarControl, CXTPCalendarDayView
  • m_bHideOnFind : CXTPSyntaxEditGoToLineDlg
  • m_bHideSelection : CXTPControlGallery, CXTPGridPaintManager, CXTPPropertyGrid
  • m_bHighLight : CXTPSyntaxEditAutoCompleteWnd
  • m_bHighlight : CXTPDatePickerButton
  • m_bHighlightActiveCaption : CXTPDockingPanePaintManager
  • m_bHighlightChanged : CXTPPropertyGrid
  • m_bHighlightChangedButton : CXTPPropertyGrid
  • m_bHighlighted : CXTPComboBox, CXTPEdit
  • m_bHighlightToday : CXTPDatePickerControl
  • m_bHilight : CXTPExcelTabCtrlButtonState, CXTPShortcutListBox
  • m_bHilightItemID : CXTPShortcutListBox
  • m_bHiliteBorders : CXTPShortcutBarNativeWindows10Theme, CXTPShortcutBarNativeWindows11Theme, CXTPShortcutBarVisualStudio2015Theme, CXTPShortcutBarVisualStudio2017Theme, CXTPShortcutBarVisualStudio2019Theme, CXTPShortcutBarVisualStudio2022Theme
  • m_bHoriz : CXTPDockingPaneSplitterContainer
  • m_bHorizSplitting : CXTPTabClientWnd
  • m_bHorz : CXTPTagCloudCtrl
  • m_bHorzScrollBar : CXTPSyntaxEditCtrl
  • m_bHot : CXTPButton, CXTPMessageBarButton, CXTPSkinObjectButton
  • m_bHotTracking : CXTPGridPaintManager, CXTPTabPaintManager
  • m_bHotTrackingGroups : CXTPRibbonPaintManager
  • m_bHScrollBarVisible : CXTPGridControl
  • m_bHScrollEnabled : CXTPCalendarEventPropertiesDlg
  • m_bHyperLink : CXTPPopupItem
  • m_bIconColumnIndexNotValid : CXTPGridControl
  • m_bIconView : CXTPGridControl
  • m_bIgnoreAutoComplete : CXTPControlComboBox
  • m_bIgnoreEditChanged : CXTPPropertyGridInplaceEdit
  • m_bIgnoreShiftMenuKey : CXTPCommandBars
  • m_bIgnoreUpdateHandler : CXTPCommandBar
  • m_bIgonoreEditChanged : CXTPCommandBarEditCtrl
  • m_bImageDPIScaling : CXTPButton, CXTPToolTipContext
  • m_bImageOrientaionPreserved : CXTPResourceImage
  • m_bImeMode : CXTPCommandBarEditCtrl
  • m_bIMEsupported : CXTPSyntaxEditCtrl
  • m_bInAction : CXTPFlowGraphControl
  • m_bInitControl : CXTPShellListCtrl
  • m_bInitialized : CXTPPropExchange
  • m_bInitialPass : CXTPChart3dDeviceContext
  • m_bInitialSelectionEnable : CXTPGridControl
  • m_bInitialSize : CXTPResizeItem
  • m_bInitialUpdate : CXTPTabExBase
  • m_bInputOutPair : CXTPFlowGraphConnectionPoint
  • m_bInRecalcLayout : CXTPToolBar
  • m_bInsideCell : CXTPGridInplaceButton
  • m_bInterlaced : CXTPChartAxis
  • m_bInternalDrag : CXTPGridControl
  • m_bInternalFrameHook : CXTPCommandBars
  • m_bInternalMove : CXTPGridControl
  • m_bIntersect : CXTPCommandBarsOffice2013Theme
  • m_bInUpdateFrame : CXTPCommandBarsFrameHook
  • m_bInUpdateScrollBar : CXTPTaskPanel
  • m_bInvert : CXTPResourceImage, CXTPSkinImage
  • m_bInvertColumnOnClick : CXTPGridPaintManager
  • m_bInvertDragRect : CXTPTaskPanelPaintManager
  • m_bInvertGradient : CXTPTabPaintManager
  • m_bIs3D : CXTPChartDeviceContext
  • m_bIsActive : CXTPSyntaxEditCtrl
  • m_bIsCaptionBarInBackstageMode : CXTPRibbonBar
  • m_bIsCustomSet : CXTPCalendarThemeCustomizableXValueT< _TValue, _TValueRef >
  • m_bIsDark : CXTPStatusBarPane
  • m_bIsDateLabel : CXTPCalendarCaptionBarTheme
  • m_bIsDragging : CXTPSyntaxEditCtrl
  • m_bIsExpandButton : CXTPCalendarCaptionBarTheme
  • m_bIsGroupBox : CXTPResizeItem
  • m_bIsModal : CXTPDatePickerControl
  • m_bIsOneLine : CXTPCalendarCaptionBarTheme
  • m_bIsParserEnabled : CXTPSyntaxEditBufferManager
  • m_bIsPreviewMode : CXTPGridPaintManager
  • m_bIsResizable : CXTPGridColumn
  • m_bIsScrollDateButtons : CXTPCalendarCaptionBarTheme
  • m_bIsScrollingEndRow : CXTPSyntaxEditCtrl
  • m_bIsSmartIndent : CXTPSyntaxEditCtrl
  • m_bIsStandardSet : CXTPCalendarThemeCustomizableXValueT< _TValue, _TValueRef >
  • m_bIsSubclassed : CXTPMarqueeCtrl
  • m_bIsSwitchViewButtons : CXTPCalendarCaptionBarTheme
  • m_bItemControlUnderMouse : CXTPGridRecordItem
  • m_bitmap : CXTPAnimationDC
  • m_bKeepSelectionAfterSort : CXTPGridControl
  • m_bKeyboardCuesVisible : CXTPCommandBars
  • m_bKeyboardEnabled : CXTPDockingPaneManager
  • m_bKeyboardSelect : CXTPCommandBar
  • m_bKeyboardSelected : CXTPControlGallery
  • m_bLabel : CXTPControlEdit, CXTPControlGalleryItem
  • m_bLastColumnExpand : CXTPGridHeader
  • m_bLastColumnExpandKeep : CXTPGridHeader
  • m_bLastColumnWidthWYSIWYG : CXTPGridPaintManager
  • m_bLastItemDrawnThemed : CXTPCheckListBox
  • m_bLayoutRTL : CXTPControl
  • m_bLBtnDown : CXTPHeaderCtrl
  • m_bLeftDirected : CXTPChart3dFunnelSeriesLabelView, CXTPChart3dPieSeriesLabelView, CXTPChart3dPyramidSeriesLabelView
  • m_bLeftRoundedCorner : CXTPTaskPanelPaintManager
  • m_bLegendVisible : CXTPChartAxisConstantLine, CXTPChartAxisStrip, CXTPChartSeries
  • m_bLight : CXTPButtonThemeVisualStudio2012
  • m_bLimitMonthDaysSelection : CXTPDatePickerControl
  • m_bLineNumbers : CXTPSyntaxEditOptions
  • m_bListColor : CXTPListBase
  • m_bLoading : CXTPPropExchange
  • m_bLocalUpdate : CXTPGridDataManager
  • m_bLocked : CXTPFlowGraphConnectionPoint, CXTPFlowGraphNode, CXTPGridRecord, CXTPTrackBlock, CXTPTrackControlItem
  • m_bLockExpand : CXTPGridControl, CXTPGridRow
  • m_bLockFrameDraw : CXTPSkinObjectFrame
  • m_bLockNCPaint : CXTPCommandBarsFrameHook
  • m_bLockReposition : CXTPTabClientWnd
  • m_bLockSplitters : CXTPDockingPaneManager
  • m_bLockUpdate : CXTPTabClientWnd
  • m_bLogarithmic : CXTPChartAxis
  • m_bLunaTheme : CXTPCommandBarsOffice2003Theme, CXTPDockingPanePaintManager, CXTPPropertyGridOffice2003Theme, CXTPTabColorSetOffice2003
  • m_bMakeUpper : CXTPGridPaintManager
  • m_bManagingViews : CXTPExcelTabCtrl
  • m_bMarkerVisible : CXTPChartLegend
  • m_bMarkupEnabled : CXTPGridControl
  • m_bMarkupPartsLoaded : CXTPFrameThemeOffice2007System, CXTPRibbonMarkupFrameTheme
  • m_bMarkupPoint : CXTPFlowGraphConnectionPoint
  • m_bMatchCase : CXTPSyntaxEditFindReplaceDlg
  • m_bMatchWholeWord : CXTPSyntaxEditFindReplaceDlg
  • m_bMaximized : CXTPDockingPaneTabbedContainer
  • m_bMdiApp : CXTPMenuBar
  • m_bMDIClient : CXTPSkinObjectFrame
  • m_bMeasureDirty : CXTPMarkupUIElement
  • m_bMeasureInProgress : CXTPMarkupUIElement
  • m_bMeeting : CXTPCalendarEvent, CXTPCalendarEventPropertiesDlg
  • m_bMessageBoxStyle : CXTPTaskDialogClient
  • m_bMilitary : CXTPTimeEdit
  • m_bMinimized : CXTPRibbonBar
  • m_bMinimizeOnDblClick : CXTPRibbonBar
  • m_bMinorVisible : CXTPChartAxisGridLines, CXTPChartAxisTickMarks
  • m_bMirrorImage : CXTPSkinImage
  • m_bModeless : CXTPPropertySheet
  • m_bModified : CXTPCalendarEventColorListBox, CXTPItemEdit, CXTPMaskEditT< TBase >, CXTPPropertyPage, CXTPSyntaxEditPropertiesPageColor, CXTPSyntaxEditPropertiesPageEdit, CXTPSyntaxEditPropertiesPageFont
  • m_bMonday : CXTPCalendarEventRecurrenceDlg
  • m_bMonitoringRunning : CXTPCalendarRemindersManager
  • m_bMouseLocked : CXTPControlListBox
  • m_bMouseOver : CXTPHyperLink
  • m_bMovePivot : CXTPGridControl
  • m_bMoveScrollbarOnFixedColumnsIndent : CXTPGridPaintManager
  • m_bmpCache : CXTPChartControl, CXTPDatePickerControl, CXTPFlowGraphControl, CXTPGridControl, CXTPSyntaxEditCtrl
  • m_bmpElsewherePattern : CXTPCalendarPaintManager
  • m_bmpGrayDC : CXTPGridView
  • m_bmpGrippers : CXTPTaskPanelPaintManager
  • m_bmpPicker : CXTPColorHex, CXTPColorWnd
  • m_bmpPreview : CXTPTaskPanelGroupItem
  • m_bmpTentativePattern : CXTPCalendarPaintManager
  • m_bMultiColorScheduleMode : CXTPCalendarControl
  • m_bMultiColumn : CXTPTaskPanel
  • m_bMulticolumnsEnable : CXTPCalendarCaptionBarTheme
  • m_bMultiColumnWeekMode : CXTPCalendarControl
  • m_bMultiLine : CXTPCommandBar
  • m_bMultiline : CXTPGridTip
  • m_bMultipleSchedulesMode : CXTPCalendarControl
  • m_bMultipleSchedulesNoSelfLinks : CXTPCalendarControl
  • m_bMultiplSel : CXTPControlListBox
  • m_bMultiply : CXTPResourceImage
  • m_bMultiRowFixedSelection : CXTPTabPaintManager
  • m_bMultiRowJustified : CXTPTabPaintManager
  • m_bMultiRowTabsOptimization : CXTPTabPaintManager
  • m_bMultiSelect : CXTPPropertyGrid, CXTPTreeBase
  • m_bMultiSelectionMode : CXTPDatePickerControl, CXTPGridControl
  • m_bMultyDayTextAlign : CXTPCalendarViewEvent
  • m_bmWatermark : CXTPGridControl
  • m_bNameIgnoreCase : CXTPCalendarCustomProperties
  • m_bNavigateButton : CXTPShortcutBarItem
  • m_bNavigationButton : CXTPShortcutBarPaintManager
  • m_bNeverArranged : CXTPMarkupUIElement
  • m_bNeverMeasured : CXTPMarkupUIElement
  • m_bNewFile : CXTPSyntaxEditDoc
  • m_bNewItem : CXTPEditListBox
  • m_bNewWindowTab : CXTPTabManagerItem
  • m_bNoBorder : CXTPShortcutListBox
  • m_bNoColSizing : CXTPListBase
  • m_bNoIcons : CXTPMDIWndTab
  • m_bNoNeedSortedDragDrop : CXTPGridControl
  • m_bNoSize : CXTPSplitterWnd
  • m_bNoUnderline : CXTPShortcutListBox
  • m_bNumericOnly : CXTPControlEdit
  • m_bOccur : CXTPCalendarOccurSeriesChooseDlg
  • m_bOccurrence : CXTPCalendarEventPropertiesDlg
  • m_bOffice2007Padding : CXTPPaintManager
  • m_bOfficeBorder : CXTPTaskPanelPaintManager
  • m_bOfficeCaption : CXTPTaskPanelPaintManagerPlain
  • m_bOfficeHighlight : CXTPTaskPanelPaintManager
  • m_bOffsetPopupLabelText : CXTPPaintManager
  • m_bOleDragging : CXTPSyntaxEditView
  • m_bOneNoteColors : CXTPTabPaintManager
  • m_bOnQuickAccess : CXTPControl
  • m_bOnSizeRunning : CXTPSyntaxEditView
  • m_bOpened : CXTPCalendarData, CXTPSyntaxEditDoc
  • m_bOpenFileDialog : CXTPBrowseEdit
  • m_bOptimized : CXTPSkinImage
  • m_Borders : CXTPCalendarCaptionBarControl, CXTPCalendarControl
  • m_borderStyle : CXTPDatePickerControl
  • m_bOriginalControls : CXTPControls
  • m_bounds : CXTPChartPolygonDeviceCommand
  • m_bOver : CXTPGridInplaceButton
  • m_bOverType : CXTPMaskEditT< TBase >
  • m_bOverwrite : CXTPSyntaxEditBufferManager
  • m_bPageDirty : CXTPSyntaxEditCtrl
  • m_bPainted : CXTPExcelTabCtrl, CXTPHeaderCtrl
  • m_bPanelManager : CXTPTabPaintManager
  • m_bPassword : CXTPPropertyGridItem
  • m_bPercentCompleteDisplay : CXTPGridRecordItemPercentNumber
  • m_bPinable : CXTPRecentFileList
  • m_bPinFooterRows : CXTPGridControl
  • m_bPinFooterRowsPrinted : CXTPGridControl
  • m_bPlainSeparators : CXTPCommandBarsOffice2003Theme
  • m_bPlusMinus : CXTPGridColumn
  • m_bPopup : CXTPControlPopup
  • m_bPopupActive : CXTPColorPicker
  • m_bPreInit : CXTPEyeDropper
  • m_bPremultiplyImages : CXTPResourceImages
  • m_bPrepareDrag : CXTPGridControl
  • m_bPressed : CXTPControl, CXTPControlGallery, CXTPDatePickerButton, CXTPDockingPaneCaptionButton, CXTPExcelTabCtrlButtonState, CXTPGridInplaceButton, CXTPMessageBarButton, CXTPStatusBarPane, CXTPTabManagerNavigateButton
  • m_bPreSubclassInit : CXTPColorBase, CXTPColorHex, CXTPComboBox, CXTPEdit, CXTPHyperLink, CXTPProgressCtrl, CXTPScrollBarCtrl, CXTPSearchOptionsCtrl, CXTPSpinButtonCtrl
  • m_bPreSubclassWindow : CXTPPropertyGrid, CXTPShortcutBar, CXTPTaskPanel
  • m_bPreventAutoAllDayMode : CXTPCalendarControl
  • m_bPreventDragAllDayEventInDayView : CXTPCalendarDayView
  • m_bPrevFocusSubItems : CXTPGridControl
  • m_bPrevFooterRows : CXTPGridControl
  • m_bPrevFooterShow : CXTPGridControl
  • m_bPrevHeaderAutoSize : CXTPGridControl
  • m_bPrevHeaderRows : CXTPGridControl
  • m_bPrevHeaderShow : CXTPGridControl
  • m_bPreview : CXTPControlGallery
  • m_bPreviewAllowEdit : CXTPGridControl
  • m_bPreviewMode : CXTPToolBar
  • m_bPreviewVisible : CXTPToolBar
  • m_bPrevPreviewMode : CXTPGridControl
  • m_bPrintDateHeader : CXTPCalendarControlViewPrintOptions
  • m_bPrintDirect : CXTPCalendarControlView, CXTPGridView, CXTPSyntaxEditView
  • m_bPrintFineMode : CXTPCalendarControlView
  • m_bPrintFromToExactly : CXTPCalendarControlViewPrintOptions
  • m_bPrintFullScale : CXTPCalendarControlView, CXTPCalendarDayView
  • m_bPrintGroupRowIcon : CXTPGridPaintManager
  • m_bPrintPageRectangle : CXTPGridPaintManager
  • m_bPrintRepeatHeaderFooterMode : CXTPCalendarControlView, CXTPCalendarDayView
  • m_bPrintSelection : CXTPGridView
  • m_bPrintSortTriangle : CXTPGridPaintManager
  • m_bPrintVirtualPageNumber : CXTPGridPaintManager
  • m_bPrintWatermark : CXTPGridPaintManager
  • m_bPrivate : CXTPCalendarEvent, CXTPCalendarEventPropertiesDlg
  • m_bPromptToDeleteRecurrentEvent : CXTPCalendarControl
  • m_bPushed : CXTPButton, CXTPSkinObjectButton
  • m_bQuickCustomizeMode : CXTPCommandBars
  • m_bRClickDrag : CXTPGridControl
  • m_bReadOnly : CXTPControlEdit, CXTPPropertyGridItem, CXTPSyntaxEditOptions
  • m_bReadOnlyMode : CXTPCalendarControl
  • m_bRecalcConnectionLayoutWhenNeeded : CXTPFlowGraphPaintManager
  • m_bRecalcLayout : CXTPDockingPaneSplitterContainer
  • m_bRecOrRowNum : CXTPGridPaintManager
  • m_bRecurrenceUpdate : CXTPCalendarEventPropertiesDlg
  • m_bRecursePopup : CXTPCommandBar
  • m_bRedo : CXTPMaskEditT< TBase >
  • m_bReduced : CXTPRibbonGroup
  • m_bRefreshed : CXTPTabClientWnd
  • m_bRefreshMetrics : CXTPSkinManagerMetrics
  • m_bRegionChanged : CXTPSkinObjectFrame
  • m_bRelayWndMsg : CXTPGridControl
  • m_bReloading : CXTPSyntaxEditDoc
  • m_bReminder : CXTPCalendarEvent, CXTPCalendarEventPropertiesDlg
  • m_bRemoved : CXTPTrayIcon
  • m_bRenderingAntialiasing : CXTPChart3dDeviceContext
  • m_bRepeatFooterRows : CXTPGridViewPrintOptions
  • m_bRepeatHeaderRows : CXTPGridViewPrintOptions
  • m_bReplaceDlg : CXTPSyntaxEditFindReplaceDlg
  • m_bReposition : CXTPFlowGraphControl
  • m_bRequest : CXTPCalendarControl::CViewChanged_ContextData
  • m_bRequest_Day : CXTPCalendarView::CSelectionChanged_ContextData
  • m_bRequest_Event : CXTPCalendarView::CSelectionChanged_ContextData
  • m_bResetUndoBuffer : CXTPCalendarView
  • m_bResizable : CXTPDialogBar, CXTPPopupBar, CXTPPropertySheet
  • m_bResizeControlWithView : CXTPCalendarControlView, CXTPGridView, CXTPSyntaxEditView
  • m_bRestrictMode : CXTPDatePickerControl
  • m_bReversed : CXTPChartAxis
  • m_bRevertAlignment : CXTPGridPaintManager
  • m_bRExceptionDeleted : CXTPCalendarEvent
  • m_bRibbonBarVisible : CXTPRibbonBar
  • m_bRightButtonDrag : CXTPSyntaxEditCtrl
  • m_bRightRoundedCorner : CXTPTaskPanelPaintManager
  • m_bRightToLeft : CXTPDatePickerControl, CXTPPopupControl
  • m_bRotateImageOnVerticalDraw : CXTPTabPaintManager
  • m_bRoundedCaption : CXTPDockingPaneOffice2003Theme
  • m_bRoundedFrame : CXTPTaskPanelPaintManagerPlain
  • m_bRowColor : CXTPListBase
  • m_bRowFocusVisible : CXTPGridControl
  • m_brTheme : CXTPSkinManagerMetrics
  • m_bRTL : CXTPHeaderCtrl
  • m_bSaturday : CXTPCalendarEventRecurrenceDlg
  • m_bScaleOnResize : CXTPTrackControl
  • m_bScrollBars : CXTPSyntaxEditView
  • m_bScrollH_Disabled : CXTPCalendarView
  • m_bScrolling : CXTPSyntaxEditCtrl
  • m_bScrollTextOnEdit : CXTPGridRecordItemEditOptions
  • m_bScrollV_Disabled : CXTPCalendarView
  • m_bScrollVisible : CXTPTaskPanel
  • m_bSelected : CXTPCalendarViewEvent, CXTPControl, CXTPDockingPaneCaptionButton, CXTPFlowGraphElement, CXTPGridRecord, CXTPShortcutBarItem, CXTPTaskPanelGroupItem
  • m_bSelectImageInPopupBar : CXTPPaintManager
  • m_bSelectionEnable : CXTPGridSection
  • m_bSelectionExcludeGroupRows : CXTPGridControl
  • m_bSelectItemOnFocus : CXTPTaskPanel
  • m_bSelectLine : CXTPSyntaxEditGoToLineDlg
  • m_bSelectOnButtonDown : CXTPTabPaintManager
  • m_bSelectOnDragOver : CXTPTabPaintManager
  • m_bSelectTextOnEdit : CXTPGridRecordItemEditOptions
  • m_bSelectWeek : CXTPDatePickerControl
  • m_bSelEndOk : CXTPControlComboBox
  • m_bSelMargin : CXTPSyntaxEditOptions
  • m_bSet : CXTPResourceManager::CManageState
  • m_bSetClipboard : CXTPEyeDropper
  • m_bSetWindowText : CXTPGridInplaceEdit
  • m_bShadeGroupHeadings : CXTPGridPaintManager
  • m_bShadeSortColumn : CXTPGridPaintManager
  • m_bShellExec : CXTPHyperLink
  • m_bShowActiveItemOnTop : CXTPShortcutBar
  • m_bShowAddress : CXTPHexEdit
  • m_bShowAllDayEventsOnly : CXTPCalendarDayView
  • m_bShowArrow : CXTPCalendarDayViewEvent
  • m_bShowAscii : CXTPHexEdit
  • m_bShowBehind : CXTPChartAxisConstantLine
  • m_bShowBorder : CXTPEdit, CXTPSplitterWnd
  • m_bShowBorders : CXTPControlGallery
  • m_bShowCaption : CXTPDockingPanePaintManager, CXTPShortcutBarPane, CXTPShortcutBarPaneItem
  • m_bShowCaptionAlways : CXTPRibbonBar
  • m_bShowCaptionBar : CXTPCalendarControlView
  • m_bShowCaret : CXTPHexEdit
  • m_bShowCloseTabButton : CXTPDockingPaneManager
  • m_bShowContentsWhileDragging : CXTPDockingPaneManager
  • m_bShowDaysAfter : CXTPDatePickerItemMonth
  • m_bShowDaysBefore : CXTPDatePickerItemMonth
  • m_bShowDockingContextStickers : CXTPDockingPaneManager
  • m_bShowExpandButton : CXTPToolBar
  • m_bShowFiles : CXTPShellTreeBase
  • m_bShowFloatingMaximizeButton : CXTPDockingPaneManager
  • m_bShowFocus : CXTPButton
  • m_bShowGrid : CXTPFlowGraphPaintManager
  • m_bShowGripper : CXTPShortcutBar
  • m_bShowHex : CXTPHexEdit
  • m_bShowIcons : CXTPTabPaintManager
  • m_bShowIconWhenEditing : CXTPGridControl
  • m_bShowImage : CXTPToolTipContext
  • m_bShowInFieldChooser : CXTPGridColumn
  • m_bShowInplaceButtonsAlways : CXTPPropertyGrid
  • m_bShowInputBox : CXTPTaskDialogClient
  • m_bShowInTaskBar : CXTPCalendarRemindersDialog
  • m_bShowItemsInGroups : CXTPGridHeader
  • m_bShowKeyboardCues : CXTPPaintManager
  • m_bShowLabels : CXTPControlGallery
  • m_bShowLeftScroll : CXTPDatePickerItemMonth
  • m_bShowLines : CXTPChartSeriesLabel
  • m_bShowLinks : CXTPCalendarControl, CXTPCalendarDayView
  • m_bShowLockIcon : CXTPGridPaintManager
  • m_bShowMaximizeButton : CXTPDockingPaneManager
  • m_bShowMinutes : CXTPCalendarPaintManager
  • m_bShowNewDeleteButtons : CXTPEditListBoxToolBar
  • m_bShowNodeGroupsAlways : CXTPFlowGraphPaintManager
  • m_bShowNonActiveInPlaceButton : CXTPGridPaintManager
  • m_bShowNonMonthDays : CXTPDatePickerControl
  • m_bShowOptionButton : CXTPRibbonGroup
  • m_bShowPanelScrollButtons : CXTPDockingPaneManager
  • m_bShowPending : CXTPTrayIcon
  • m_bShowPinButton : CXTPDockingPaneMiniWnd
  • m_bShowPreview : CXTPEyeDropper
  • m_bShowQuickAccess : CXTPRibbonBar
  • m_bShowQuickAccessBelow : CXTPRibbonBar, CXTPRibbonCustomizeQuickAccessPage
  • m_bShowRadioButtons : CXTPControlWindowList
  • m_bShowRightScroll : CXTPDatePickerItemMonth
  • m_bShowRowNumber : CXTPGridView
  • m_bShowScrollBar : CXTPControlGallery
  • m_bShowShadow : CXTPControlPopup, CXTPPaintManager, CXTPPopupBar, CXTPPropertyGridInplaceList
  • m_bShowShellLinkIcons : CXTPShellPidl
  • m_bShowSizeCursorWhileDragging : CXTPDockingPaneManager
  • m_bShowSizeGripper : CXTPStatusBar
  • m_bShowSpinButtons : CXTPControlEdit
  • m_bShowTabs : CXTPTabPaintManager
  • m_bShowText : CXTPColorPicker
  • m_bShowTextBelow : CXTPChartAxisConstantLine
  • m_bShowTitleAndDescription : CXTPToolTipContext
  • m_bShowTooltipForAllDayEvents : CXTPCalendarControl
  • m_bShowTooltipForNotFocused : CXTPCalendarControl
  • m_bShowTooltips : CXTPGridControl
  • m_bShowTopBorder : CXTPSplitterWndEx
  • m_bShowTopLeftCaptionShadow : CXTPShortcutBarOffice2003Theme
  • m_bShowUpDownButtons : CXTPEditListBoxToolBar
  • m_bShowWeekNumbers : CXTPDatePickerControl
  • m_bShowWorkArea : CXTPTrackControl
  • m_bShowWorkspace : CXTPTabClientWnd
  • m_bShowWYSIWYGMarkers : CXTPGridPaintManager
  • m_bShowZeroLevel : CXTPChartAxisRange
  • m_bSideDocking : CXTPDockingPaneManager
  • m_bSideMargins : CXTPChartAxisRange
  • m_bSingleSelection : CXTPShortcutBar, CXTPTaskPanel
  • m_bSkipGroupsFocus : CXTPGridControl
  • m_bSkippingAntialiasing : CXTPChart3dDeviceContext
  • m_bSlideOut : CXTPDockingPaneMiniWnd, CXTPDockingPaneSidePanel
  • m_bSmooth3dEdges : CXTPChartSeriesStyle
  • m_bSnapToBlocks : CXTPTrackControl
  • m_bSnapToMarkers : CXTPTrackControl
  • m_bSortable : CXTPGridColumn
  • m_bSortAscending : CXTPGridSubListControl
  • m_bSortColor : CXTPListBase
  • m_bSortedDragDrop : CXTPGridControl
  • m_bSortIncreasing : CXTPGridColumn
  • m_bSortRecordChilds : CXTPGridControl
  • m_bSortTriangleOffsetFromRight : CXTPGridPaintManager
  • m_bSoundAvailable : CXTPSoundManager
  • m_bSpecial : CXTPTaskPanelGroup
  • m_bSplashScreenMode : CXTPPopupControl
  • m_bStandardFont : CXTPPaintManagerFont
  • m_bStartedClickInside : CXTPCalendarView
  • m_bStaticFrame : CXTPTabPaintManager
  • m_bStickyFloatingFrames : CXTPDockingPaneManager
  • m_bStrictBestFit : CXTPGridControl
  • m_bStrictFiltering : CXTPGridControl
  • m_bStripEllipsisFromToolTip : CXTPToolTipContext
  • m_bStyle : CXTPSkinObjectButton
  • m_bSubclassed : CXTPCaption, CXTPExcelTabCtrl, CXTPSplitterWnd, CXTPTabBase
  • m_bSunday : CXTPCalendarEventRecurrenceDlg
  • m_bSwitchMode : CXTPGridView
  • m_bSwitchToDayViewIfPickedSingleDay : CXTPCalendarControl
  • m_bSyncActiveFloatingFrames : CXTPDockingPaneManager
  • m_bSyntaxColor : CXTPSyntaxEditOptions
  • m_bSystemDrawing : CXTPTabBaseTheme
  • m_bTabCaptions : CXTPPropertyGrid
  • m_bTabColors : CXTPSplitterWndTheme
  • m_bTabItems : CXTPPropertyGrid, CXTPTaskPanel
  • m_bTabsVisible : CXTPRibbonBar
  • m_bTabWithSpace : CXTPSyntaxEditOptions
  • m_bTearOff : CXTPToolBar
  • m_bTearOffPopup : CXTPPopupBar
  • m_bTearOffSelected : CXTPPopupBar
  • m_bTearOffTracking : CXTPPopupBar
  • m_bTempFile : CXTPPropExchangeIniFile
  • m_bTemporary : CXTPControl, CXTPToolBar
  • m_bTextBelow : CXTPCommandBar
  • m_bTextOutOfBorders : CXTPCalendarViewEvent
  • m_bThemed : CXTPGridRecordItemControl
  • m_bThemedBackColor : CXTPTabClientWnd
  • m_bThemedCheckBox : CXTPPaintManager
  • m_bThemedFloatingFrames : CXTPDockingPaneManager
  • m_bThemedInplaceButtons : CXTPGridPaintManager
  • m_bThemedStatusBar : CXTPPaintManager
  • m_bThemeFrameEnabled : CXTPCommandBarsFrameHook
  • m_bThemeMetrics : CXTPGridControl
  • m_bThemeReady : CXTPTaskDialogClient
  • m_bThickCheckMark : CXTPPaintManager
  • m_bThinBorder : CXTPColorSelectorCtrlTheme
  • m_bThinSplitter : CXTPPropertyGridPaintManager
  • m_bThursday : CXTPCalendarEventRecurrenceDlg
  • m_bTimelineEnable : CXTPCalendarCaptionBarTheme
  • m_bTimelineMode : CXTPCalendarControl
  • m_bTimeLineSeparateGroup : CXTPCalendarTimeLineView
  • m_bTimerActive : CXTPShortcutListBox
  • m_bTimerGroupHover : CXTPTaskPanel
  • m_bTipEnabled : CXTPHyperLink, CXTPTagCloudCtrl
  • m_bTitleVisible : CXTPDockingPaneTabbedContainer
  • m_btnAlwaysShowFullMenus : CXTPCustomizeOptionsPage
  • m_btnBrowse : CXTPBrowseEdit
  • m_btnCaption : CXTPCaption
  • m_btnDelete : CXTPCustomizeToolbarsPage
  • m_btnLargeIcons : CXTPCustomizeOptionsPage
  • m_btnNew : CXTPCustomizeToolbarsPage
  • m_btnRename : CXTPCustomizeToolbarsPage
  • m_btnReset : CXTPCustomizeToolbarsPage
  • m_btnResetData : CXTPCustomizeOptionsPage
  • m_btnShowFullAfterDelay : CXTPCustomizeOptionsPage
  • m_btnToolBarAccelTips : CXTPCustomizeOptionsPage
  • m_btnToolBarScreenTips : CXTPCustomizeOptionsPage
  • m_bTokensLoaded : CXTPSyntaxEditCtrl
  • m_bToolBarVisible : CXTPPropertyGrid
  • m_bTooltipUnderMouse : CXTPCalendarControl
  • m_bTracking : CXTPCommandBar, CXTPExcelTabCtrl, CXTPMiniToolBar, CXTPPropertyGridView
  • m_bTrackingSize : CXTPShortcutBar
  • m_bTrackOnHover : CXTPCommandBar
  • m_bTrackSelection : CXTPPropertyGridInplaceList
  • m_bTransparent : CXTPPropertyGridPaintManager
  • m_bTrapTabKey : CXTPGridControl
  • m_bTristateCheckbox : CXTPGridRecordItem
  • m_bTuesday : CXTPCalendarEventRecurrenceDlg
  • m_bTunneling : CXTPShellTreeBase
  • m_bTwoSides : CXTPChartSolidSplinePolygonDeviceCommand
  • m_bUnderline : CXTPHyperLink, CXTPPopupItem
  • m_bUnicodeFileFormat : CXTPSyntaxEditBufferManager
  • m_bUnrestrictedDragDrop : CXTPGridControl
  • m_bUpdate : CXTPHexEdit
  • m_bUpdateContents : CXTPTabClientWnd
  • m_bUpdateUndo : CXTPMaskEditT< TBase >
  • m_bUpdateWhenEventChangedNotify : CXTPCalendarControl
  • m_bUpdateWindow : CXTPChartControl
  • m_bUseActiveViewResoucesForBold : CXTPCalendarController
  • m_bUseAlphaContext : CXTPDockingPaneContext
  • m_bUseAlternativeBackground : CXTPGridPaintManager
  • m_bUseBitmapGrippers : CXTPTaskPanelPaintManager
  • m_bUseBoldCaptionFont : CXTPDockingPanePaintManager
  • m_bUseComCtl32 : CXTPTaskDialog
  • m_bUseDefaultOnLoad : CXTPPropExchange
  • m_bUseDefaultOnSave : CXTPPropExchange
  • m_bUseDockingStickers : CXTPDockingPaneContext
  • m_bUseDropMarker : CXTPGridPaintManager
  • m_bUseEditTextAlignment : CXTPGridPaintManager
  • m_bUseGlobalPaintManager : CXTPCommandBarsFrameHook
  • m_bUseGroupRowSelectionState : CXTPGridPaintManager
  • m_bUseMask : CXTPGridColumn, CXTPMaskEditT< TBase >, CXTPPropertyGridItem
  • m_bUseMonitor : CXTPSyntaxEditConfigurationManager, CXTPSyntaxEditCtrl
  • m_bUseNewHitTestCode : CXTPCalendarDayView
  • m_bUseOfficeFont : CXTPDockingPanePaintManager, CXTPPaintManager
  • m_bUseOutputDC : CXTPSyntaxEditDrawTextProcessor
  • m_bUserColors : CXTPCaption, CXTPExcelTabCtrl
  • m_bUseResources : CXTPImageManager, CXTPImageManagerIconHandle
  • m_bUserWorkspace : CXTPTabClientWnd
  • m_bUseShellIcon : CXTPGridPaintManager
  • m_bUseSplitterTracker : CXTPDockingPaneManager, CXTPTabClientWnd
  • m_bUseStandardCaptionFont : CXTPTaskPanelPaintManager
  • m_bUseStandardFont : CXTPDockingPanePaintManager, CXTPPaintManager, CXTPShortcutBarPaintManager, CXTPTabPaintManager
  • m_bUseStandardItemsFont : CXTPTaskPanelPaintManager
  • m_bUseSysIcons : CXTPTaskDialogClient
  • m_bUseSystemDecimalSymbol : CXTPPropertyGridItemDouble
  • m_bUseSystemKeyNameText : CXTPShortcutManager
  • m_bUseSystemSaveBitsStyle : CXTPShadowManager
  • m_bUseThousandSeparator : CXTPChartNumberFormat
  • m_bUseVisualStyle : CXTPButton, CXTPComboBox, CXTPScrollBar, CXTPSpinButtonCtrl
  • m_bUseWinTheme : CXTPEditTheme, CXTPMarqueeCtrlPaintManager, CXTPProgressCtrlPaintManager
  • m_bUseWinThemes : CXTPHeaderCtrlTheme, CXTPTabBaseTheme
  • m_buttonCustomStyle : CXTPControl
  • m_buttonRibbonStyle : CXTPControl
  • m_buttons : CXTPExcelTabCtrl
  • m_buttonsStyle : CXTPPropertyGridPaintManager
  • m_buttonStyle : CXTPCommandBar, CXTPControl
  • m_buttonStyleEx : CXTPControlButton
  • m_bValid : CXTPResourceManager
  • m_bValue : CXTPPropertyGridItemBool
  • m_bVariableHelpHeight : CXTPPropertyGrid
  • m_bVariableItemsHeight : CXTPPropertyGrid
  • m_bVariableSplitterPos : CXTPPropertyGridView
  • m_bVerbsVisible : CXTPPropertyGrid
  • m_bVerification : CXTPTaskDialogClient
  • m_bVerticalMarker : CXTPCommandBar
  • m_bVerticalTextTopToBottom : CXTPTabPaintManager
  • m_bVertScrollBar : CXTPSyntaxEditCtrl
  • m_bViewOnly : CXTPSyntaxEditOptions
  • m_bViewVisible : CXTPPropertyGrid
  • m_bVirtualSpace : CXTPSyntaxEditOptions
  • m_bVisible : CXTPCalendarCaptionBarThemePart, CXTPCalendarDayViewTimeScale, CXTPChartAxis, CXTPChartAxisConstantLine, CXTPChartAxisGridLines, CXTPChartAxisLabel, CXTPChartAxisStrip, CXTPChartAxisTickMarks, CXTPChartAxisTitle, CXTPChartBorder, CXTPChartLegend, CXTPChartMarker, CXTPChartSeries, CXTPChartSeriesLabel, CXTPChartTitle, CXTPCommandBarKeyboardTip, CXTPControlAction, CXTPDatePickerButton, CXTPDatePickerItemDay, CXTPFlowGraphNode, CXTPGridColumn, CXTPGridRecord, CXTPGridRow, CXTPGridSection, CXTPPropertyGridItem, CXTPRibbonGroup, CXTPShortcutBarItem, CXTPTabManagerItem, CXTPTaskPanelItem, CXTPToolBar
  • m_bVisited : CXTPHyperLink
  • m_bVisualStudio2005Style : CAppearanceSetPropertyPageFlat
  • m_bVScrollBarVisible : CXTPGridControl
  • m_bVScrollEnabled : CXTPCalendarEventPropertiesDlg
  • m_bWasShiftKey : CXTPGridControl
  • m_bWatchSubtree : CXTPDirWatcher
  • m_bWednesday : CXTPCalendarEventRecurrenceDlg
  • m_bWideCaret : CXTPSyntaxEditOptions
  • m_bWin9x : CXTPSkinManager
  • m_bWindowsForms : CXTPSkinObject
  • m_bWndCreateInProgress : CXTPSyntaxEditCtrl
  • m_bWrap : CXTPControl
  • m_bWrapCaptionBelowText : CXTPPaintManager
  • m_bXPBorder : CXTPTabBase
  • m_bYearsTriangle : CXTPDatePickerControl
  • m_callerParam : CXTPColorPopup
  • m_cameraState : CXTPChart3dDeviceContext
  • m_Caption : CXTPCaptionPopupWnd
  • m_CaptionButton : CXTPCaptionPopupWnd
  • m_captionDirection : CXTPDockingPaneManager
  • m_center : CXTPChartBoundedCircleDeviceCommand, CXTPChartCircleDeviceCommand
  • m_cfGrid : CXTPGridControl
  • m_cfItem : CXTPTaskPanel
  • m_cfNode : CXTPFlowGraphPage
  • m_chAlpha : CXTPMarqueeCtrl
  • m_checkList : CXTPCustomizeToolbarsPage
  • m_checkListState : CXTPCheckListBox
  • m_checkState : CXTPGridRecordItem
  • m_chPrevLeadByte : CXTPSyntaxEditCtrl
  • m_chPrompt : CXTPGridColumn, CXTPMaskEditT< TBase >, CXTPPropertyGridItem
  • m_chSecondLevelCurrentChar : CXTPRibbonBackstageView
  • m_ClickArgs : CXTPGridRecordItemControlHookWnd
  • m_clientFrame : CXTPTabPaintManager
  • m_clr : CXTPControlButtonColor, CXTPGridHeaderDropWnd, CXTPGridRecordItemPercentNumber
  • m_clr3DFace : CXTPDatePickerPaintManager, CXTPExcelTabCtrlTheme
  • m_clr3DFaceHilite : CXTPExcelTabCtrlTheme
  • m_clr3DFacePushed : CXTPExcelTabCtrlTheme
  • m_clr3DHilight : CXTPExcelTabCtrlTheme
  • m_clr3DHilite : CXTPMarqueeCtrlPaintManager
  • m_clr3DLight : CXTPDatePickerPaintManager
  • m_clr3DShadow : CXTPCalendarPaintManager, CXTPCommandBarsOffice2013Theme, CXTPDatePickerPaintManager, CXTPExcelTabCtrlTheme, CXTPMarqueeCtrlPaintManager
  • m_clr3DText : CXTPDatePickerPaintManager
  • m_clrActiveBack : CXTPCommandBarsNativeWindows11Theme
  • m_clrActiveCaption : CXTPDockingPanePaintManager
  • m_clrActiveCaptionText : CXTPDockingPanePaintManager
  • m_clrActiveFilesBack : CXTPTabPaintManagerColorSet
  • m_clrActiveFilesBackHighlighted : CXTPTabPaintManagerColorSet
  • m_clrActiveFilesBackPressed : CXTPTabPaintManagerColorSet
  • m_clrActiveFilesGlyph : CXTPTabPaintManagerColorSet
  • m_clrActiveFilesGlyphHighlighted : CXTPTabPaintManagerColorSet
  • m_clrActiveFilesGlyphPressed : CXTPTabPaintManagerColorSet
  • m_clrAlternativeBackground : CXTPGridPaintManager
  • m_clrAutoHideFace : CXTPTabPaintManagerColorSet
  • m_clrBack : CXTPCommandBarsOffice2013Theme, CXTPEditTheme, CXTPGridInplaceEdit, CXTPHyperLink, CXTPListBoxThemeOffice2013, CXTPMarqueeCtrlPaintManager, CXTPMessageBarPaintManager, CXTPPopupItem, CXTPProgressCtrlPaintManager, CXTPProgressThemeOffice2013, CXTPPropertyGridInplaceEdit, CXTPPropertyGridItemMetrics, CXTPTagCloudCtrl
  • m_clrBackColor : CXTPChartSeriesLabel
  • m_clrBackDisabled : CXTPComboBoxTheme
  • m_clrBackground : CXTPCalendarPaintManager, CXTPCalendarTimeLineView, CXTPCalendarViewPart, CXTPChartContent, CXTPColorSetCaptionButton, CXTPComboBoxTheme, CXTPDatePickerThemeOffice2013, CXTPDockingPaneColorSet, CXTPDockingPanePaintManager, CXTPFlowGraphPaintManager, CXTPGridRecordItem, CXTPPopupPaintManager, CXTPStatusBarPane, CXTPTaskPanelPaintManager
  • m_clrBackground2 : CXTPCalendarPaintManager
  • m_clrBackgroundColor : CXTPChartLegend
  • m_clrBackgroundSlave : CXTPCalendarPaintManager
  • m_clrBackHighlight : CXTPComboBoxTheme
  • m_clrBackHiliteSelected : CXTPShortcutBarNativeWindows10Theme, CXTPShortcutBarNativeWindows11Theme, CXTPShortcutBarVisualStudio2015Theme, CXTPShortcutBarVisualStudio2017Theme, CXTPShortcutBarVisualStudio2019Theme, CXTPShortcutBarVisualStudio2022Theme
  • m_clrBackNonClient : CXTPEditTheme
  • m_clrBackstageSysButtonBack2013Highlighted : CXTPRibbonMarkupTheme
  • m_clrBackstageSysButtonBack2013Normal : CXTPRibbonMarkupTheme
  • m_clrBar : CXTPMarqueeCtrlPaintManager, CXTPProgressCtrlPaintManager, CXTPProgressThemeOffice2013
  • m_clrBarText : CXTPProgressCtrlPaintManager
  • m_clrBkBase : CXTPCalendarEventCategory
  • m_clrBlock : CXTPTrackBlock
  • m_clrBoldText : CXTPGridPaintManager
  • m_clrBoldTextHighlight : CXTPGridPaintManager
  • m_clrBorder : CXTPCalendarEventCategory, CXTPCaption, CXTPDockingPaneColorSet, CXTPEditTheme, CXTPListBoxThemeOffice2013, CXTPMessageBarPaintManager, CXTPPopupItem, CXTPProgressCtrlPaintManager, CXTPProgressThemeOffice2013, CXTPTagCloudCtrl, CXTPTagCloudStyle
  • m_clrBorder3DHilite : CXTPExcelTabCtrlTheme
  • m_clrBorder3DShadow : CXTPExcelTabCtrlTheme
  • m_clrBorderColor : CXTPChartMarker
  • m_clrBorderDisabled : CXTPComboBoxTheme, CXTPEditThemeOfficeXP
  • m_clrBorderHighlight : CXTPTabPaintManagerColorSet
  • m_clrBorderHilite : CXTPEditThemeOfficeXP, CXTPShortcutBarNativeWindows10Theme, CXTPShortcutBarNativeWindows11Theme, CXTPShortcutBarVisualStudio2015Theme, CXTPShortcutBarVisualStudio2017Theme, CXTPShortcutBarVisualStudio2019Theme, CXTPShortcutBarVisualStudio2022Theme
  • m_clrBorderHot : CXTPComboBoxTheme
  • m_clrBorderNormal : CXTPComboBoxTheme
  • m_clrBorders : CXTPCalendarCaptionBarPaintManager, CXTPCalendarPaintManager
  • m_clrBtnFace : CXTPCommandBarsOffice2013Theme, CXTPGridPaintManager
  • m_clrBtnFacePressed : CXTPGridPaintManager
  • m_clrBtnText : CXTPExcelTabCtrlTheme, CXTPGridPaintManager
  • m_clrBtnTextGray : CXTPExcelTabCtrlTheme
  • m_clrBtnTextHilite : CXTPExcelTabCtrlTheme
  • m_clrBtnTextPushed : CXTPExcelTabCtrlTheme
  • m_clrButtonArrowDisabled : CXTPComboBoxThemeOffice2013
  • m_clrButtonArrowHot : CXTPComboBoxTheme
  • m_clrButtonArrowNormal : CXTPComboBoxTheme
  • m_clrButtonArrowPressed : CXTPComboBoxTheme
  • m_clrButtonBack : CXTPMessageBarThemeOffice2013, CXTPStatusBarThemeOffice2013
  • m_clrButtonBackChecked : CXTPStatusBarThemeOffice2013
  • m_clrButtonBackHighlight : CXTPStatusBarThemeOffice2013
  • m_clrButtonBackHilite : CXTPMessageBarThemeOffice2013
  • m_clrButtonBackPushed : CXTPMessageBarThemeOffice2013, CXTPStatusBarThemeOffice2013
  • m_clrButtonBorder : CXTPMessageBarThemeOffice2013, CXTPTabPaintManagerColorSet
  • m_clrButtonBorderHighlighted : CXTPTabPaintManagerColorSet
  • m_clrButtonBorderHilite : CXTPMessageBarThemeOffice2013
  • m_clrButtonBorderHot : CXTPTabPaintManagerColorSet
  • m_clrButtonBorderKeyTips : CXTPTabPaintManagerColorSet
  • m_clrButtonBorderPushed : CXTPMessageBarThemeOffice2013
  • m_clrButtonBorderTabContext1 : CXTPTabPaintManagerColorSet
  • m_clrButtonBorderTabContext2 : CXTPTabPaintManagerColorSet
  • m_clrButtonDisabled : CXTPComboBoxThemeOffice2013
  • m_clrButtonFace : CXTPCalendarPaintManager, CXTPDatePickerPaintManager
  • m_clrButtonFaceText : CXTPCalendarPaintManager
  • m_clrButtonHighlighted : CXTPTabPaintManagerColorSet
  • m_clrButtonHighlightedClose : CXTPTabPaintManagerColorSet
  • m_clrButtonHot : CXTPComboBoxTheme
  • m_clrButtonNormal : CXTPComboBoxTheme, CXTPTabBaseThemeOffice2003, CXTPTabPaintManagerColorSet
  • m_clrButtonPressed : CXTPComboBoxTheme, CXTPPopupPaintManager, CXTPTabPaintManagerColorSet
  • m_clrButtonPressedBorder : CXTPPopupPaintManager
  • m_clrButtonSelected : CXTPPopupPaintManager, CXTPTabBaseThemeOffice2003, CXTPTabPaintManagerColorSet
  • m_clrButtonSelectedBorder : CXTPPopupPaintManager
  • m_clrButtonSelectedHighlighted : CXTPTabPaintManagerColorSet
  • m_clrButtonSelectedPressed : CXTPTabPaintManagerColorSet
  • m_clrButtonText : CXTPDatePickerPaintManager, CXTPTabColorSetOffice2007
  • m_clrButtonTextChecked : CXTPStatusBarThemeOffice2013
  • m_clrButtonTextHighlight : CXTPStatusBarThemeOffice2013
  • m_clrButtonTextPushed : CXTPStatusBarThemeOffice2013
  • m_clrCaption : CXTPDockingPaneColorSet, CXTPGridRecordItemControl
  • m_clrCaptionBorder : CXTPDockingPaneNativeWindows10Theme, CXTPDockingPaneNativeWindows11Theme, CXTPDockingPaneVisualStudio2005Beta2Theme, CXTPDockingPaneVisualStudio2015Theme, CXTPDockingPaneVisualStudio2017Theme, CXTPDockingPaneVisualStudio2019Theme, CXTPDockingPaneVisualStudio2022Theme
  • m_clrCaptionButtonFill : CXTPCommandBarsOffice2013Theme
  • m_clrCaptionText : CXTPGridPaintManager, CXTPShortcutBarOffice2003Theme
  • m_clrCaptionTextPressed : CXTPGridPaintManager
  • m_clrCategoryFore : CXTPPropertyGridItemMetrics
  • m_clrCategorySeparator : CXTPPropertyGridPaintManager
  • m_clrClassicUnderline : CXTPCalendarPaintManager
  • m_clrColor : CXTPCalendarEventLabel, CXTPChartAxis, CXTPChartAxisConstantLine, CXTPChartAxisGridLines, CXTPChartAxisStrip, CXTPChartBorder, CXTPChartMarker, CXTPChartSeriesStyle, CXTPColorHex, CXTPColorSelectorCtrl
  • m_clrColor2 : CXTPChartAxisStrip
  • m_clrColumnOffice2007CustomTheme : CXTPGridPaintManager
  • m_clrCommandBar : CXTPCommandBarsOffice2003Theme
  • m_clrConnection : CXTPFlowGraphConnection, CXTPFlowGraphPaintManager
  • m_clrConnector : CXTPGridPaintManager
  • m_clrControlBack : CXTPDatePickerPaintManager, CXTPGridPaintManager
  • m_clrControlDark : CXTPGridPaintManager
  • m_clrControlEditDisabledBorder : CXTPRibbonTheme
  • m_clrControlEditNormal : CXTPRibbonTheme
  • m_clrControlEditSelected : CXTPRibbonTheme
  • m_clrControlFace : CXTPTabPaintManagerColorSet
  • m_clrControlGalleryBorder : CXTPControlGalleryResourceTheme
  • m_clrControlGalleryNormal : CXTPControlGalleryResourceTheme
  • m_clrControlGallerySelected : CXTPControlGalleryResourceTheme
  • m_clrControlLightLight : CXTPGridPaintManager
  • m_clrCurrent : CXTPColorDialog, CXTPScrollBarThemeOffice2013
  • m_clrCustomValue : CXTPPaintManagerColor
  • m_clrDarkShadow : CXTPTabBaseThemeOffice2003
  • m_clrDayBack : CXTPDatePickerPaintManager
  • m_clrDaysOfWeekBack : CXTPDatePickerPaintManager
  • m_clrDaysOfWeekText : CXTPDatePickerPaintManager
  • m_clrDayText : CXTPDatePickerPaintManager
  • m_clrDefault : CXTPColorPicker, CXTPColorSelectorCtrl
  • m_clrDisableBitmapDarkest : CXTPGridPaintManager
  • m_clrDisableBitmapLightest : CXTPGridPaintManager
  • m_clrDisabled : CXTPScrollBarThemeOffice2013
  • m_clrDisabledCaptionText : CXTPDockingPanePaintManager
  • m_clrDisabledIcon : CXTPPaintManager
  • m_clrDisabledText : CXTPShortcutBarPaintManager
  • m_clrDivider : CXTPGridSection
  • m_clrDockBar : CXTPCommandBarsOffice2003Theme
  • m_clrDownColor : CXTPChartHighLowSeriesStyle
  • m_clrEdgeDkShadow : CXTPSkinManagerMetrics
  • m_clrEdgeHighLight : CXTPSkinManagerMetrics
  • m_clrEdgeHighLightColor : CXTPCommandBarsNativeXPTheme
  • m_clrEdgeLight : CXTPCaptionTheme, CXTPSkinManagerMetrics
  • m_clrEdgeShadow : CXTPCaptionTheme, CXTPSkinManagerMetrics
  • m_clrEdgeShadowColor : CXTPCommandBarsNativeXPTheme
  • m_clrEventBar : CXTPCalendarPaintManager, CXTPCalendarTimeLineView
  • m_clrEventBarLine : CXTPCalendarPaintManager, CXTPCalendarTimeLineView
  • m_clrEventBorderLine : CXTPCalendarPaintManager, CXTPCalendarTimeLineView
  • m_clrFace : CXTPCaption, CXTPPropertyGridPaintManager
  • m_clrFileButtonText : CXTPRibbonPaintManager
  • m_clrFill : CXTPColorSetCaptionButton
  • m_clrFloatingGripper : CXTPPaintManager
  • m_clrFloatingGripperText : CXTPPaintManager
  • m_clrFore : CXTPPropertyGridItemMetrics
  • m_clrFormulaSubSum : CXTPGridPaintManager
  • m_clrFormulaSum : CXTPGridPaintManager
  • m_clrFrame : CXTPPopupPaintManager
  • m_clrFrameBorder : CXTPTabPaintManagerColorSet
  • m_clrFrameCaptionActive : CXTPFramePaintManager
  • m_clrFrameCaptionInactive : CXTPFramePaintManager
  • m_clrFrameCaptionTextActive : CXTPFramePaintManager
  • m_clrFrameCaptionTextActiveBSMode : CXTPFramePaintManager
  • m_clrFrameCaptionTextActiveTitle : CXTPFramePaintManager
  • m_clrFrameCaptionTextActiveTitleBSMode : CXTPFramePaintManager
  • m_clrFrameCaptionTextInactive : CXTPFramePaintManager
  • m_clrFrameCaptionTextInactiveBSMode : CXTPFramePaintManager
  • m_clrFreezeColsDivider : CXTPGridPaintManager
  • m_clrGlyph : CXTPCommandBarsOffice2013Theme, CXTPGridThemeOffice2013, CXTPShortcutBarOffice2013Theme, CXTPTrackThemeOffice2013
  • m_clrGlyphBorder : CXTPGridThemeOffice2013, CXTPPropertyGridOffice2013Theme
  • m_clrGlyphContract : CXTPGridThemeOffice2013, CXTPPropertyGridOffice2013Theme
  • m_clrGlyphDisabled : CXTPCommandBarsOffice2013Theme
  • m_clrGlyphExpand : CXTPGridThemeOffice2013, CXTPPropertyGridOffice2013Theme
  • m_clrGlyphExpanded : CXTPShortcutBarOffice2013Theme
  • m_clrGlyphFill : CXTPShortcutBarOffice2013Theme
  • m_clrGlyphHighlight : CXTPCommandBarsOffice2013Theme, CXTPGridThemeOffice2013, CXTPTrackThemeOffice2013
  • m_clrGlyphPushed : CXTPCommandBarsOffice2013Theme, CXTPShortcutBarOffice2013Theme
  • m_clrGradientColumnSeparator : CXTPGridPaintManager
  • m_clrGradientColumnShadow : CXTPGridPaintManager
  • m_clrGridColor : CXTPFlowGraphPaintManager
  • m_clrGripper : CXTPDockingPaneColorSet, CXTPPopupThemeOffice2003
  • m_clrGroupBoxBack : CXTPGridPaintManager
  • m_clrGroupRowText : CXTPGridPaintManager
  • m_clrGroupShadeBack : CXTPGridPaintManager
  • m_clrGroupShadeBorder : CXTPGridPaintManager
  • m_clrGroupShadeText : CXTPGridPaintManager
  • m_clrHeader : CXTPRibbonOffice2013Theme
  • m_clrHeaderBottomLine : CXTPCalendarPaintManager
  • m_clrHeaderControl : CXTPGridPaintManager
  • m_clrHeaderFace : CXTPTabBaseThemeOffice2003, CXTPTabPaintManagerColorSet
  • m_clrHelpBack : CXTPPropertyGridItemMetrics
  • m_clrHelpFore : CXTPPropertyGridItemMetrics
  • m_clrHighLight : CXTPSyntaxEditAutoCompleteWnd
  • m_clrHighlight : CXTPCalendarPaintManager, CXTPCommandBarsOffice2013Theme, CXTPGridPaintManager, CXTPPropertyGridPaintManager, CXTPTabBaseThemeOffice2003
  • m_clrHighlightBorder : CXTPTaskPanelPaintManager
  • m_clrHighlightHot : CXTPTaskPanelPaintManager
  • m_clrHighlightPressed : CXTPTaskPanelPaintManager
  • m_clrHighlightSelected : CXTPTaskPanelPaintManager
  • m_clrHighLightText : CXTPSyntaxEditAutoCompleteWnd
  • m_clrHighlightText : CXTPGridPaintManager, CXTPPropertyGridPaintManager
  • m_clrHighlightToday : CXTPDatePickerPaintManager
  • m_clrHotDivider : CXTPGridPaintManager
  • m_clrHotText : CXTPPopupItem, CXTPShortcutBarPaintManager
  • m_clrHour : CXTPCalendarPaintManager
  • m_clrHover : CXTPHyperLink
  • m_clrInactiveBack : CXTPCommandBarsNativeWindows11Theme
  • m_clrIndentControl : CXTPGridPaintManager
  • m_clrInfoBack : CXTPMessageBarPaintManager
  • m_clrInterlacedColor : CXTPChartAxis
  • m_clrInterlacedColor2 : CXTPChartAxis
  • m_clrItem : CXTPTabManagerItem
  • m_clrItemBack : CXTPListBoxThemeOffice2013
  • m_clrItemBackHighlight : CXTPListBoxThemeOffice2013
  • m_clrItemBackSelected : CXTPListBoxThemeOffice2013
  • m_clrItemBorder : CXTPListBoxThemeOffice2013
  • m_clrItemBorderHighlight : CXTPListBoxThemeOffice2013
  • m_clrItemBorderSelected : CXTPListBoxThemeOffice2013
  • m_clrItemCaptionShadow : CXTPShortcutBarOffice2003Theme
  • m_clrItemCaptionText : CXTPShortcutBarOffice2003Theme
  • m_clrItemCaptionTop : CXTPShortcutBarOffice2003Theme
  • m_clrItemShade : CXTPGridPaintManager
  • m_clrItemTab : CXTPDockingPane
  • m_clrItemText : CXTPListBoxThemeOffice2013
  • m_clrItemTextHighlight : CXTPListBoxThemeOffice2013
  • m_clrItemTextSelected : CXTPListBoxThemeOffice2013
  • m_clrLightAmbientColor : CXTPChart3dDeviceContext
  • m_clrLightDiffuseColor : CXTPChart3dDeviceContext
  • m_clrLightModelAmbientColor : CXTPChart3dDeviceContext
  • m_clrLightSpecularColor : CXTPChart3dDeviceContext
  • m_clrLine : CXTPPropertyGridItemMetrics
  • m_clrLineColor : CXTPChartSeriesLabel
  • m_clrLink : CXTPHyperLink
  • m_clrListControlBack : CXTPDatePickerPaintManager
  • m_clrListControlText : CXTPDatePickerPaintManager
  • m_clrMarker : CXTPTrackPaintManager
  • m_clrMarkerBack : CXTPTrackPaintManager
  • m_clrMarkerBorder : CXTPTrackPaintManager
  • m_clrMaterialDiffuseColor : CXTPChart3dDeviceContext
  • m_clrMaterialEmissionColor : CXTPChart3dDeviceContext
  • m_clrMaterialSpecularColor : CXTPChart3dDeviceContext
  • m_clrMenuExpand : CXTPCommandBarsOffice2003Theme
  • m_clrMenuExpandedGripper : CXTPCommandBarsOffice2003Theme
  • m_clrMenuGripper : CXTPCommandBarsOffice2003Theme
  • m_clrMenuPopupGripperShadow : CXTPRibbonTheme
  • m_clrMenuPopupSeparator : CXTPRibbonTheme
  • m_clrMenuSelection : CXTPVisualStudio2008Theme
  • m_clrMenuSelectionBorder : CXTPVisualStudio2008Theme
  • m_clrMenuSelectionText : CXTPVisualStudio2008Theme
  • m_clrMessageBarText : CXTPCommandBarsOffice2013Theme, CXTPPaintManager
  • m_clrMinimizedFrameEdgeHighLight : CXTPRibbonPaintManager
  • m_clrMinimizedFrameEdgeShadow : CXTPRibbonPaintManager
  • m_clrMinorColor : CXTPChartAxisGridLines
  • m_clrMonthBorder : CXTPDatePickerPaintManager
  • m_clrMonthHeaderBack : CXTPDatePickerPaintManager
  • m_clrMonthHeaderButton : CXTPDatePickerPaintManager
  • m_clrMonthHeaderText : CXTPDatePickerPaintManager
  • m_clrMultiDayEventFrameColor : CXTPCalendarPaintManager
  • m_clrNavigateButtonBorder : CXTPTabColorSetOffice2003
  • m_clrNew : CXTPColorDialog
  • m_clrNode : CXTPFlowGraphNode
  • m_clrNodeBackground : CXTPFlowGraphPaintManager
  • m_clrNonHighlightBack : CXTPPropertyGridPaintManager
  • m_clrNonHighlightText : CXTPPropertyGridPaintManager
  • m_clrNonMonthDayBack : CXTPDatePickerPaintManager
  • m_clrNonMonthDayText : CXTPDatePickerPaintManager
  • m_clrNormal : CXTPScrollBarThemeOffice2013
  • m_clrNormalCaption : CXTPDockingPanePaintManager
  • m_clrNormalCaptionText : CXTPDockingPanePaintManager
  • m_clrNormalText : CXTPShortcutBarPaintManager, CXTPTabBaseTheme
  • m_clrOutline : CXTPColorSetCaptionButton
  • m_clrPaneFace : CXTPTabPaintManagerColorSet
  • m_clrPoint : CXTPFlowGraphConnectionPoint
  • m_clrPopupControl : CXTPCommandBarsOffice2003Theme
  • m_clrPressed : CXTPScrollBarThemeOffice2013
  • m_clrPressedText : CXTPCommandBarsNativeXPTheme
  • m_clrPreviewText : CXTPGridPaintManager
  • m_clrPushedText : CXTPShortcutBarPaintManager
  • m_clrReadOnlyFore : CXTPPropertyGridItemMetrics
  • m_clrRecentFileListEdgeHighLight : CXTPRibbonPaintManager
  • m_clrRecentFileListEdgeShadow : CXTPRibbonPaintManager
  • m_clrRibbonBorder : CXTPRibbonPaintManager
  • m_clrRibbonFace : CXTPRibbonPaintManager
  • m_clrRibbonGrayText : CXTPRibbonTheme
  • m_clrRibbonGroupCaptionText : CXTPRibbonPaintManager
  • m_clrRibbonInactiveFace : CXTPRibbonPaintManager
  • m_clrRibbonInactiveFaceState : CXTPRibbonOffice2013Theme
  • m_clrRibbonTabDelimeter : CXTPRibbonOffice2013Theme
  • m_clrRibbonText : CXTPRibbonTheme
  • m_clrScrollBarBorderDark : CXTPTrackPaintManager
  • m_clrScrollBarBorderLight : CXTPTrackPaintManager
  • m_clrScrollBarDark : CXTPTrackPaintManager
  • m_clrScrollBarLight : CXTPTrackPaintManager
  • m_clrScrollDateBarBk : CXTPCalendarCaptionBarPaintManager
  • m_clrScrollTriangleColor : CXTPCalendarCaptionBarPaintManager
  • m_clrSelected : CXTPColorPicker, CXTPScrollBarThemeOffice2013
  • m_clrSelectedArea : CXTPTrackPaintManager
  • m_clrSelectedBackground : CXTPCalendarPaintManager, CXTPCalendarTimeLineView
  • m_clrSelectedBorder : CXTPTrackThemeOffice2013
  • m_clrSelectedDayBack : CXTPDatePickerPaintManager
  • m_clrSelectedDayText : CXTPDatePickerPaintManager
  • m_clrSelectedRow : CXTPGridPaintManager
  • m_clrSelectedRowText : CXTPGridPaintManager
  • m_clrSelectedText : CXTPCalendarPaintManager, CXTPCalendarTimeLineView, CXTPCommandBarsNativeXPTheme, CXTPShortcutBarPaintManager, CXTPTaskPanelVisualStudio2012Theme
  • m_clrSelectedTextWithoutFocus : CXTPTaskPanelVisualStudio2012Theme
  • m_clrSelectedWithoutFocus : CXTPTaskPanelVisualStudio2012Theme
  • m_clrSelection : CXTPFlowGraphPaintManager
  • m_clrSelectionInactive : CXTPFlowGraphPaintManager
  • m_clrShadow : CXTPCalendarPaintManager, CXTPPropertyGridPaintManager, CXTPTabBaseThemeOffice2003
  • m_clrShortcutItemShadow : CXTPShortcutBarPaintManager, CXTPTaskPanelShortcutBarOffice2007Theme
  • m_clrSplitter : CXTPDockingPaneColorSet, CXTPDockingPanePaintManager, CXTPPropertyGridPaintManager
  • m_clrSplitterGradient : CXTPDockingPanePaintManager
  • m_clrSplitterGripper : CXTPDockingPanePaintManager
  • m_clrStandardValue : CXTPPaintManagerColor
  • m_clrStaticBorder : CXTPDatePickerPaintManager
  • m_clrSwitchViewBarBk : CXTPCalendarCaptionBarPaintManager
  • m_clrTabBackackstageLeft : CXTPRibbonOffice2013Theme
  • m_clrTabBackackstageRight : CXTPRibbonOffice2013Theme
  • m_clrTabBackInactiveState : CXTPRibbonOffice2013Theme
  • m_clrTabClientBack : CXTPTabPaintManagerColorSet
  • m_clrTabClientBorder : CXTPTabPaintManagerColorSet
  • m_clrTearOffGripper : CXTPCommandBarsOffice2003Theme
  • m_clrText : CXTPCalendarPaintManager, CXTPCalendarTimeLineView, CXTPCaption, CXTPComboBoxTheme, CXTPDockingPaneColorSet, CXTPEditTheme, CXTPGridInplaceEdit, CXTPGridRecordItem, CXTPMessageBarPaintManager, CXTPPopupItem, CXTPPopupPaintManager, CXTPProgressCtrlPaintManager, CXTPStatusBarPane, CXTPTagCloudStyle, CXTPTaskPanelGroupItem, CXTPTaskPanelVisualStudio2012Theme
  • m_clrTextColor : CXTPCalendarCaptionBarPaintManager, CXTPCalendarCaptionBarThemePart, CXTPCalendarViewPart, CXTPChartAxisConstantLine, CXTPChartAxisLabel, CXTPChartAxisTitle, CXTPChartLegend, CXTPChartSeriesLabel, CXTPChartTitle, CXTPFlowGraphPaintManager
  • m_clrTextColorSelected : CXTPFlowGraphPaintManager
  • m_clrTextDisabled : CXTPComboBoxTheme, CXTPTabPaintManagerColorSet
  • m_clrTextGray : CXTPStatusBarPane
  • m_clrTextHighlight : CXTPComboBoxTheme, CXTPTabPaintManagerColorSet
  • m_clrTextHighlightClose : CXTPTabPaintManagerColorSet
  • m_clrTextHighLightColor : CXTPCalendarPaintManager
  • m_clrTextHilite : CXTPMessageBarThemeOffice2010, CXTPMessageBarThemeOffice2013
  • m_clrTextHover : CXTPTagCloudStyle
  • m_clrTextNormal : CXTPTabPaintManagerColorSet
  • m_clrTextNormalColor : CXTPCalendarPaintManager
  • m_clrTextPressed : CXTPTabPaintManagerColorSet
  • m_clrTextReadOnly : CXTPEditTheme
  • m_clrTextSelected : CXTPTabPaintManagerColorSet
  • m_clrTextSelectedHighlighted : CXTPTabPaintManagerColorSet
  • m_clrTextSelectedPressed : CXTPTabPaintManagerColorSet
  • m_clrTheme : CXTPSkinManagerMetrics
  • m_clrTimeHeaderBorder : CXTPTrackPaintManager
  • m_clrTimeHeaderDark : CXTPTrackPaintManager
  • m_clrTimeHeaderDarkDark : CXTPTrackPaintManager
  • m_clrTimeHeaderDivider : CXTPTrackPaintManager
  • m_clrTimeLinePosition : CXTPTrackPaintManager
  • m_clrTimeLineTick : CXTPTrackPaintManager
  • m_clrTimeScaleBackground : CXTPCalendarPaintManager, CXTPCalendarTimeLineView
  • m_clrTimeScaleBorder : CXTPCalendarTimeLineView
  • m_clrTimeScaleHighlight : CXTPCalendarTimeLineView
  • m_clrTimeScaleHightlite : CXTPCalendarPaintManager
  • m_clrTimeScaleText : CXTPCalendarPaintManager, CXTPCalendarTimeLineView
  • m_clrTimeSliderBackground : CXTPTrackPaintManager
  • m_clrTipBkColor : CXTPToolTipContext
  • m_clrTipTextColor : CXTPToolTipContext
  • m_clrToolbarExpand : CXTPCommandBarsOffice2003Theme
  • m_clrToolbarShadow : CXTPCommandBarsOffice2003Theme
  • m_clrTrackHeader : CXTPTrackPaintManager
  • m_clrTrackMarkerBorder : CXTPTrackPaintManager
  • m_clrTrackMarkerText : CXTPTrackPaintManager
  • m_clrTrackMarkerTextBack : CXTPTrackPaintManager
  • m_clrTrackMarkerTextBorder : CXTPTrackPaintManager
  • m_clrTrackTimeArea : CXTPTrackPaintManager
  • m_clrUnderLineHdr : CXTPCalendarPaintManager
  • m_clrUpColor : CXTPChartHighLowSeriesStyle
  • m_clrValue : CXTPPropertyGridItemColor, CXTPPropertyGridItemFont
  • m_clrValues : CXTPSyntaxEditPaintManager
  • m_clrVerbFace : CXTPPropertyGridItemMetrics
  • m_clrVisited : CXTPHyperLink
  • m_clrWeekendBackground : CXTPCalendarPaintManager, CXTPCalendarTimeLineView
  • m_clrWeekNumbersBack : CXTPDatePickerPaintManager
  • m_clrWeekNumbersText : CXTPDatePickerPaintManager
  • m_clrWindow : CXTPCalendarPaintManager, CXTPExcelTabCtrlTheme, CXTPSyntaxEditAutoCompleteWnd
  • m_clrWindowText : CXTPCalendarPaintManager, CXTPExcelTabCtrlTheme, CXTPGridPaintManager, CXTPSyntaxEditAutoCompleteWnd
  • m_clrWorkArea : CXTPTrackPaintManager
  • m_clrWorkAreaScrollBarBorder : CXTPTrackPaintManager
  • m_clrWorkAreaScrollBarDark : CXTPTrackPaintManager
  • m_clrWorkAreaScrollBarLight : CXTPTrackPaintManager
  • m_clrWorkspace : CXTPCommandBarsOffice2013Theme
  • m_cmbCategories : CXTPRibbonCustomizePage
  • m_cmbTabGroup : CXTPRibbonCustomizePage
  • m_cntSelChanged : CXTPCalendarView
  • m_cntViewChanged : CXTPCalendarControl
  • m_Color : CXTPCalendarResource
  • m_color : CXTPChart3dLineDeviceCommand, CXTPChartBoundedCircleDeviceCommand, CXTPChartBoundedPolygonDeviceCommand, CXTPChartLineDeviceCommand, CXTPChartMarkupElementDeviceCommand, CXTPChartSolidSplinePolygonDeviceCommand, CXTPChartTextDeviceCommand, CXTPColorHex::CRgnCell, CXTPEyeDropper
  • m_colorEditor : CXTPPropertyGridItemColor
  • m_colorHex : CXTPColorPageStandard
  • m_columnStyle : CXTPGridPaintManager
  • m_comboAnimationType : CXTPCustomizeOptionsPage
  • m_comboCategory : CXTPCustomizeKeyboardPage
  • m_comboStyle : CXTPControlComboBox
  • m_CommandList : CXTPSyntaxEditBatchCommand, CXTPSyntaxEditUndoRedoManager
  • m_config : CXTPTaskDialog
  • m_controlType : CXTPControl
  • m_cr3DDkShadow : CXTPHeaderCtrlTheme
  • m_cr3DFace : CXTPHeaderCtrlTheme
  • m_cr3DHighLight : CXTPHeaderCtrlTheme, CXTPTaskDialogClient
  • m_cr3DLight : CXTPTaskDialogClient
  • m_cr3DShadow : CXTPHeaderCtrlTheme, CXTPTaskDialogClient
  • m_crArrowDisabled : CXTPSpinButtonCtrl
  • m_crArrowEnabled : CXTPSpinButtonCtrl
  • m_crArrowHilite : CXTPSpinButtonCtrl
  • m_crArrowPushed : CXTPSpinButtonCtrl
  • m_crBack : CXTPButtonTheme, CXTPColorSelectorCtrlTheme, CXTPHexEdit, CXTPScrollBarPaintManager, CXTPSpinButtonCtrl, CXTPSplitterWndTheme, CXTPTaskDialogLinkCtrl, CXTPTreeTheme
  • m_crBackChecked : CXTPButtonThemeUltraFlat, CXTPColorSelectorCtrlTheme
  • m_crBackColor : CXTPTipWindow
  • m_crBackDisabled : CXTPButtonThemeOffice2013, CXTPSpinButtonCtrl, CXTPTreeTheme
  • m_crBackHilight : CXTPColorSelectorCtrlTheme
  • m_crBackHilite : CXTPButtonThemeUltraFlat, CXTPScrollBarPaintManager, CXTPSpinButtonCtrl
  • m_crBackPressed : CXTPColorSelectorCtrlTheme
  • m_crBackPushed : CXTPButtonThemeUltraFlat, CXTPScrollBarPaintManager, CXTPSpinButtonCtrl
  • m_crBackSelected : CXTPTreeTheme
  • m_crBackSelectedDisabled : CXTPTreeTheme
  • m_crBackSelectedInactive : CXTPTreeTheme
  • m_crBorder : CXTPButtonThemeOffice2013, CXTPColorSelectorCtrlTheme, CXTPScrollBarPaintManager, CXTPSpinButtonCtrl
  • m_crBorder3DHilite : CXTPButtonTheme
  • m_crBorder3DShadow : CXTPButtonTheme
  • m_crBorderDefault : CXTPButtonThemeOffice2013
  • m_crBorderDisabled : CXTPButtonThemeOffice2013, CXTPSpinButtonCtrl
  • m_crBorderHilight : CXTPColorSelectorCtrlTheme
  • m_crBorderHilite : CXTPButtonTheme, CXTPScrollBarPaintManager, CXTPSpinButtonCtrl
  • m_crBorderInside : CXTPColorSelectorCtrlThemeOffice2013
  • m_crBorderPressed : CXTPColorSelectorCtrlTheme
  • m_crBorderPushed : CXTPButtonThemeUltraFlat, CXTPSpinButtonCtrl
  • m_crBorderShadow : CXTPButtonTheme
  • m_crBoxBack : CXTPSplitterWndTheme
  • m_crCheckMark : CXTPButtonThemeUltraFlat
  • m_crCompColor : CXTPShellSettings
  • m_crContent : CXTPTaskDialogClient
  • m_crContentText : CXTPTaskDialogClient
  • m_crDisabledBack : CXTPHexEdit
  • m_crDisabledHighlightBack : CXTPHexEdit
  • m_crDisabledHighlightText : CXTPHexEdit
  • m_crDisabledText : CXTPHexEdit
  • m_crEncrColor : CXTPShellSettings
  • m_crFooter : CXTPTaskDialogClient
  • m_crFooterText : CXTPTaskDialogClient
  • m_crgBack : CXTPHeaderCtrlThemeResource, CXTPShortcutListBoxTheme
  • m_crgBackPressed : CXTPHeaderCtrlThemeResource
  • m_crgItemBackHot : CXTPShortcutListBoxTheme
  • m_crgItemBackPressed : CXTPShortcutListBoxTheme
  • m_crgItemBorder : CXTPShortcutListBoxTheme
  • m_crHighlightBack : CXTPHexEdit
  • m_crHighlightText : CXTPHexEdit
  • m_crInnerBorder : CXTPSplitterWndTheme
  • m_crInnerBoxBorder : CXTPSplitterWndTheme
  • m_crItemText : CXTPShortcutListBoxTheme
  • m_crItemTextDisabled : CXTPShortcutListBoxTheme
  • m_crListBack : CXTPListBase
  • m_crListText : CXTPListBase
  • m_crlNoGroupByText : CXTPGridPaintManager
  • m_crMainText : CXTPTaskDialogClient
  • m_crMark : CXTPButtonThemeOffice2013
  • m_crMarkDisabled : CXTPButtonThemeOffice2013
  • m_crMarkHilite : CXTPButtonThemeOffice2013
  • m_crMarkPushed : CXTPButtonThemeOffice2013
  • m_crOuterBorder : CXTPSplitterWndTheme
  • m_crOuterBoxBorder : CXTPSplitterWndTheme
  • m_crPopupBorder : CXTPColorSelectorCtrlTheme
  • m_crSortBack : CXTPListBase
  • m_crSortText : CXTPListBase
  • m_crText : CXTPButtonTheme, CXTPColorSelectorCtrlTheme, CXTPHeaderCtrlTheme, CXTPHexEdit, CXTPTaskDialogLinkCtrl, CXTPTreeTheme
  • m_crTextCheck : CXTPButtonTheme
  • m_crTextColor : CXTPTipWindow
  • m_crTextDisabled : CXTPButtonTheme, CXTPTreeTheme
  • m_crTextHilite : CXTPButtonThemeUltraFlat
  • m_crTextLink : CXTPTaskDialogLinkCtrl
  • m_crTextPressed : CXTPColorSelectorCtrlTheme
  • m_crTextPushed : CXTPButtonThemeUltraFlat
  • m_crTextSelected : CXTPTreeTheme
  • m_crTextSelectedDisabled : CXTPTreeTheme
  • m_crTextSelectedInactive : CXTPTreeTheme
  • m_crTitleBack : CXTPColorSelectorCtrlThemeOffice2013
  • m_crTitleText : CXTPColorSelectorCtrlThemeOffice2013
  • m_cs : CXTPImageManagerResource, CXTPResourceImages
  • m_csCaptionButtonHot : CXTPDockingPaneColorSet
  • m_csCaptionButtonNormal : CXTPDockingPaneColorSet
  • m_csCaptionButtonPressed : CXTPDockingPaneColorSet
  • m_csCheckBox : CXTPCommandBarsOffice2013Theme
  • m_csCheckMark : CXTPCommandBarsOffice2013Theme
  • m_csComboBox : CXTPCommandBarsOffice2013Theme
  • m_csExcelNormal : CXTPTabPaintManagerColorSet
  • m_csExcelSelected : CXTPTabPaintManagerColorSet
  • m_csFindText : CXTPSyntaxEditFindReplaceDlg
  • m_csIncludeEXT : CXTPShellListBase
  • m_csMenu : CXTPCommandBarsOffice2013Theme
  • m_csMenuTitleBar : CXTPCommandBarsOffice2013Theme
  • m_csObjects : CXTPSkinManager
  • m_csPropertyPage : CXTPTabPaintManagerColorSet
  • m_csPropertyPage2003 : CXTPTabPaintManagerColorSet
  • m_csReplaceText : CXTPSyntaxEditFindReplaceDlg
  • m_csRibbon : CXTPCommandBarsOffice2013Theme
  • m_csStateButton : CXTPTabPaintManagerColorSet
  • m_csSymbol : CXTPFontCtrlBase
  • m_csToolbar : CXTPCommandBarsOffice2013Theme
  • m_cThumb : CXTPScrollBarPaintManager
  • m_ctrl3SmallCal : CXTPCalendarPageSetupDialog
  • m_ctrlBlackWhitePrinting : CXTPCalendarPageSetupDialog
  • m_ctrlDateHeaderFont : CXTPCalendarPageSetupDialog
  • m_ctrlDateHeaderFontButton : CXTPCalendarPageSetupDialog
  • m_ctrlDateHeaderFontLabel : CXTPCalendarPageSetupDialog
  • m_ctrlDescription : CXTPCalendarRemindersDialog
  • m_ctrlDismissAllBtn : CXTPCalendarRemindersDialog
  • m_ctrlDismissBtn : CXTPCalendarRemindersDialog
  • m_ctrlFooterFormat : CXTPCalendarPageSetupDialog
  • m_ctrlFooterFormatBtn : CXTPCalendarPageSetupDialog
  • m_ctrlHeaderFormat : CXTPCalendarPageSetupDialog
  • m_ctrlHeaderFormatBtn : CXTPCalendarPageSetupDialog
  • m_ctrlIcon : CXTPCalendarOccurSeriesChooseDlg
  • m_ctrlMessage : CXTPCalendarOccurSeriesChooseDlg
  • m_ctrlMonthViewPrintFrom : CXTPCalendarPageSetupDialog
  • m_ctrlMonthViewPrintRange : CXTPCalendarPageSetupDialog
  • m_ctrlMonthViewPrintTo : CXTPCalendarPageSetupDialog
  • m_ctrlOccur : CXTPCalendarOccurSeriesChooseDlg
  • m_ctrlOpenItemBtn : CXTPCalendarRemindersDialog
  • m_ctrlPrintDateHeader : CXTPCalendarPageSetupDialog
  • m_ctrlPrintFromCmb : CXTPCalendarPageSetupDialog
  • m_ctrlPrintFromTo : CXTPCalendarPageSetupDialog
  • m_ctrlPrintToCmb : CXTPCalendarPageSetupDialog
  • m_ctrlRemindersList : CXTPCalendarRemindersDialog
  • m_ctrlScheduleIDCB : CXTPCalendarEventPropertiesDlg
  • m_ctrlScheduleLabel : CXTPCalendarEventPropertiesDlg
  • m_ctrlScheduleSet : CXTPCalendarEventPropertiesDlg
  • m_ctrlSeries : CXTPCalendarOccurSeriesChooseDlg
  • m_ctrlSnoozeBtn : CXTPCalendarRemindersDialog
  • m_ctrlSnoozeTimeCB : CXTPCalendarRemindersDialog
  • m_CurrSystemTheme : CXTPCalendarPaintManager
  • m_cx : CXTPExcelTabCtrl
  • m_cxBorder : CXTPSkinManagerMetrics
  • m_cxChunk : CXTPMarqueeCtrl
  • m_cxEdge : CXTPSkinManagerMetrics
  • m_cxHScroll : CXTPScrollBarPaintManager, CXTPSkinManagerMetrics
  • m_cxIcon : CXTPShortcutListBoxTheme
  • m_cxOsVScroll : CXTPSkinManagerMetrics
  • m_cxPaneSpacing : CXTPStatusBar
  • m_cxPixelsPerInch : CXTPPreviewView
  • m_cxPopup : CXTPControlGalleryPaintManager
  • m_cxText : CXTPStatusBarPane
  • m_cxVScroll : CXTPScrollBarPaintManager, CXTPSkinManagerMetrics
  • m_cy : CXTPExcelTabCtrl
  • m_cyBorder : CXTPSkinManagerMetrics
  • m_cyCaption : CXTPSkinManagerMetrics
  • m_cyEdge : CXTPShortcutListBoxTheme, CXTPSkinManagerMetrics
  • m_cyHScroll : CXTPScrollBarPaintManager, CXTPSkinManagerMetrics
  • m_cyIcon : CXTPShortcutListBoxTheme
  • m_cyOsCaption : CXTPSkinManagerMetrics
  • m_cyOsSmallCaption : CXTPSkinManagerMetrics
  • m_cyPixelsPerInch : CXTPPreviewView
  • m_cyPopupDown : CXTPControlGalleryPaintManager
  • m_cyPopupUp : CXTPControlGalleryPaintManager
  • m_cyProgress : CXTPProgressPaintManager
  • m_cySmallCaption : CXTPSkinManagerMetrics
  • m_cyText : CXTPCheckListBox
  • m_cyTopBorderGap : CXTPSplitterWndEx
  • m_cyVScroll : CXTPScrollBarPaintManager, CXTPSkinManagerMetrics
  • m_Daily : XTP_CALENDAR_RECURRENCE_OPTIONS
  • m_dAnimationDelay : CXTPDockingPaneAutoHideWnd
  • m_dAnimationStep : CXTPControlGallery
  • m_dArea : CXTPChartEllipse
  • m_dArgument : CXTPChartSeriesPoint
  • m_DataLockerCS : CXTPNotifyConnectionMT
  • m_dAxisMaxValue : CXTPChartAxisStrip
  • m_dAxisMinValue : CXTPChartAxisStrip
  • m_DayPOS_LastSelected : CXTPCalendarMonthView
  • m_dc : CXTPImageManagerResource
  • m_dCorrectedDepth : CXTPChartPieDeviceCommandImpl
  • m_dDepth : CXTPChartPieDeviceCommandImpl
  • m_dDisabledAlphaFactor : CXTPImageManager
  • m_dDisabledBrightnessFactor : CXTPImageManager
  • m_dDivider : CXTPPropertyGridView
  • m_dEPS : CXTPMathUtils
  • m_depth : CXTPChartPieBase
  • m_dFacetSize : CXTPChartPieDeviceCommandImpl
  • m_dGridSpacing : CXTPChartAxis
  • m_dHeightPercent : CXTPTrackBlock
  • m_dHolePercent : CXTPChartPieDeviceCommandImpl
  • m_dInnerMajorSemiAxis : CXTPChartPieDeviceCommandImpl
  • m_dInnerMinorSemiAxis : CXTPChartPieDeviceCommandImpl
  • m_dInnerRadius : CXTPChartPieDeviceCommandImpl
  • m_dInternalArgument : CXTPChartSeriesPoint
  • m_dInternalValue : CXTPChartSeriesPointView
  • m_direction : CXTPDockingPaneAutoHidePanel, CXTPDockingPaneSidePanel
  • m_dividerPosition : CXTPGridSection
  • m_dividerStyle : CXTPGridSection
  • m_dLineAngle : CXTPChartPieSeriesLabelView
  • m_dLogarithmicBase : CXTPChartAxis
  • m_dMajorSemiAxis : CXTPChartPieDeviceCommandImpl
  • m_dMajorSemiaxis : CXTPChartEllipse
  • m_dMaxAlpha : CXTPCalendarShadowDrawer
  • m_dMaxValue : CXTPChartNumericalScaleTypeMap, CXTPChartQualitativeScaleTypeMap
  • m_dMaxWidthDivisor : CXTPPopupBar
  • m_dMaxZoom : CXTPFlowGraphControl
  • m_dMinorSemiAxis : CXTPChartPieDeviceCommandImpl
  • m_dMinorSemiaxis : CXTPChartEllipse
  • m_dMinValue : CXTPChartNumericalScaleTypeMap, CXTPChartQualitativeScaleTypeMap
  • m_dMinZoom : CXTPFlowGraphControl
  • m_dMinZoomLevelBackground : CXTPFlowGraphPaintManager
  • m_dMinZoomLevelConnectionPoints : CXTPFlowGraphPaintManager
  • m_dMinZoomLevelConnections : CXTPFlowGraphPaintManager
  • m_dMinZoomLevelGDIQuality : CXTPFlowGraphPaintManager
  • m_dNewEventID : CXTPCalendarEventPropertiesDlg
  • m_Down : CXTPPreviewView
  • m_dPI : CXTPMathUtils
  • m_dPitch : CXTPChart3dRotation
  • m_dRadius : CXTPChartPieDeviceCommandImpl
  • m_dragMode : CXTPGridHeader
  • m_dRoll : CXTPChart3dRotation
  • m_dropTarget : CXTPSyntaxEditView
  • m_dScale : CXTPCalendarCaptionBarTheme
  • m_dStartAngle : CXTPChartPieBase, CXTPChartPieDeviceCommandImpl
  • m_dSweepAngle : CXTPChartPieBase, CXTPChartPieDeviceCommandImpl
  • m_dtBeginDate : CXTPCalendarMonthView::CMonthViewGrid, CXTPCalendarWeekView
  • m_dtCreationTime : CXTPCalendarEvent
  • m_dtDate : CXTPCalendarViewDay
  • m_dtDay : CXTPDatePickerItemDay
  • m_dtEnd : CXTPCalendarEventRecurrenceDlg
  • m_dtEndDate : CXTPCalendarEventPropertiesDlg, CXTPCalendarEventRecurrenceDlg
  • m_dtEndTime : CXTPCalendarEvent, CXTPCalendarEventPropertiesDlg
  • m_dtEventStartTime : CXTPCalendarReminder
  • m_dtFirstClicked : CXTPDatePickerControl
  • m_dtFirstMonth : CXTPDatePickerControl
  • m_dtFocused : CXTPDatePickerControl
  • m_dtFSelBase : CXTPDatePickerControl
  • m_dtLastClicked : CXTPDatePickerControl
  • m_dtLastModificationTime : CXTPCalendarEvent
  • m_dtLastUpdateTime : CXTPCalendarRemindersManager
  • m_dtLightColorDateBase : CXTPCalendarMonthView
  • m_dtMaxRange : CXTPDatePickerControl
  • m_dtMiddleMonth : CXTPDatePickerList
  • m_dtMinRange : CXTPDatePickerControl
  • m_dtMonth : CXTPDatePickerItemMonth
  • m_dtMonthViewPrintBeginDate : CXTPCalendarControlViewPrintOptions
  • m_dtMonthViewPrintEndDate : CXTPCalendarControlViewPrintOptions
  • m_dtNextReminderTime : CXTPCalendarReminder
  • m_dtOccurrenceEndTime : CXTPCalendarReminder::RecurrenceEventInfo
  • m_dtOccurrenceStartTime : CXTPCalendarReminder::RecurrenceEventInfo
  • m_dtPatternEndDate : XTP_CALENDAR_PATTERN_END
  • m_dtPrintFrom : CXTPCalendarControlView, CXTPCalendarControlViewPrintOptions
  • m_dtPrintTo : CXTPCalendarControlView, CXTPCalendarControlViewPrintOptions
  • m_dtRException_EndTimeOrig : CXTPCalendarEvent
  • m_dtRException_StartTimeOrig : CXTPCalendarEvent
  • m_dtSelMonth : CXTPDatePickerList
  • m_dtStart : CXTPCalendarEventRecurrenceDlg
  • m_dtStartDate : CXTPCalendarEventPropertiesDlg, CXTPCalendarEventRecurrenceDlg
  • m_dtStartMonth : CXTPDatePickerList
  • m_dtStartTime : CXTPCalendarEvent, CXTPCalendarEventPropertiesDlg
  • m_dtStartViewDate : CXTPCalendarTimeLineViewTimeScale
  • m_dtTimeScaleMax : CXTPCalendarDayView
  • m_dtTimeScaleMin : CXTPCalendarDayView
  • m_dtTimeScaleOldMaxTime : CXTPCalendarControlView
  • m_dtTimeScaleOldMinTime : CXTPCalendarControlView
  • m_dtToday : CXTPDatePickerControl
  • m_dValue : CXTPChartAxisViewTick, CXTPChartFunnelSeriesPointViewBase, CXTPChartPyramidSeriesPointViewBase, CXTPChartRadarAxisXViewTick, CXTPChartRadarAxisYViewTick, CXTPGridRecordItemNumber
  • m_dValues : CXTPChartSeriesPoint
  • m_dwAlign : CXTPCommandBarKeyboardTip
  • m_dwApplyOptions : CXTPSkinManager
  • m_dwAskItemTextFlags : CXTPCalendarPaintManager
  • m_dwAutoScrollDirection : CXTPSyntaxEditCtrl
  • m_dwBaseAddress : CXTPHexEdit
  • m_dwBStyle : CXTPBrowseButton, CXTPBrowseEdit
  • m_dwComCtlVersion : CXTPToolTipContext
  • m_dwComCtrl : CXTPSkinManager
  • m_dwCommandBarID : CXTPControlPopup
  • m_dwData : CXTPCommandBar, CXTPControlGalleryItem, CXTPDockingPane, CXTPGridRecordItem, CXTPGridRecordItemConstraint, CXTPPropertyGridItem, CXTPPropertyGridItemConstraint, CXTPPropertyPage, CXTPPropExchange, CXTPShortcutBarItem, CXTPTabManagerItem, CXTPTaskPanelItem
  • m_dwDefaultPaneOptions : CXTPDockingPaneManager
  • m_dwDialogTexture : CXTPSkinObjectFrame
  • m_dwDragDropFlags : CXTPGridControl
  • m_dwDrawStyle : CXTPHeaderCtrlTheme
  • m_dwDropMarkerFlags : CXTPGridControl
  • m_dwEditReparceTimeout_ms : CXTPSyntaxEditLexParserSchemaOptions
  • m_dwEditStyle : CXTPControlComboBox, CXTPControlEdit, CXTPGridRecordItemEditOptions, CXTPPropertyGridItem
  • m_dwEventID : CXTPCalendarEvent
  • m_dwExStyle : CXTPCaption, CXTPSkinObjectFrame
  • m_dwFlags : CXTPBrowseEdit, CXTPCommandBar, CXTPControl, CXTPTabClientWnd, CXTPTabManagerNavigateButton
  • m_dwHideFlags : CXTPControl, CXTPStatusBarPane
  • m_dwIdx : CXTPSyntaxEditTipListBox
  • m_dwIndex : CXTPCalendarTimeZone
  • m_dwInitSignature : CXTPMDIWndTab
  • m_dwInsertPos : CXTPSyntaxEditCtrl
  • m_dwLastRedrawTime : CXTPSyntaxEditCtrl
  • m_dwLastTip : CXTPToolTipContextToolTip
  • m_dwLStyle : CXTPEditListBox
  • m_dwMasterEventID : CXTPCalendarReminder::RecurrenceEventInfo
  • m_dwMaxBackParseOffset : CXTPSyntaxEditLexParserSchemaOptions
  • m_dwMonitorEvents : CXTPDirWatcher
  • m_dwNormalEventID : CXTPCalendarReminder
  • m_dwOnScreenSchCacheLifeTime_sec : CXTPSyntaxEditLexParserSchemaOptions
  • m_dwOptions : CXTPDockingPane
  • m_dwParserThreadIdleLifeTime_ms : CXTPSyntaxEditLexParserSchemaOptions
  • m_dwPopup : CXTPColorPicker, CXTPColorSelectorCtrl
  • m_dwRecurrencePatternID : CXTPCalendarEvent
  • m_dwRecurrencePatternID_ToUse : CXTPCalendarEvent
  • m_dwRstEvent : CXTPGridDataManager
  • m_dwShellAutoCompleteFlags : CXTPControlComboBox, CXTPControlEdit
  • m_dwSliderStyle : CXTPControlSlider
  • m_dwSplitterStyle : CXTPDockingPanePaintManager
  • m_dwState : CXTPDockingPaneCaptionButton
  • m_dwStyle : CXTPColorDialog, CXTPCommandBar, CXTPDockBar, CXTPExcelTabCtrl, CXTPFontCtrlBase, CXTPSkinObjectFrame, CXTPToolTipContext
  • m_dwStyleListBox : CXTPControlFontComboBoxList
  • m_dwTag : CXTPFlowGraphNode
  • m_dwTipStyle : CXTPTipWindow
  • m_dwUpdateOptions : CXTPChartControl
  • m_dx : CXTPChart3dTranslateDeviceCommand, CXTPChartTranslateDeviceCommand
  • m_dy : CXTPChart3dTranslateDeviceCommand, CXTPChartTranslateDeviceCommand
  • m_dYaw : CXTPChart3dRotation
  • m_dz : CXTPChart3dTranslateDeviceCommand
  • m_dZoomLevel : CXTPFlowGraphPage
  • m_eAction : XTP_CALENDAR_USERACTION_PARAMS
  • m_eAnimation : CXTPTaskPanel
  • m_editGroup : CXTPEditListBox
  • m_editShortcutKey : CXTPCustomizeKeyboardPage
  • m_eDraggingMode : CXTPCalendarView
  • m_eEditMode : CXTPHexEdit
  • m_eEventType : CXTPCalendarReminder
  • m_eGripper : CXTPTaskPanelPaintManager
  • m_eHasFocus : CXTPColorBase
  • m_ellipse : CXTPChartPieBase
  • m_emptyLocker : CXTPNotifyConnection
  • m_eType : XTP_CALENDAR_TIMELINE_VIEW_SCALE
  • m_eUndoMode : CXTPCalendarView
  • m_EventTimeFormat : CXTPCalendarView
  • m_eViewType : CXTPCalendarControl
  • m_ExpandDayButton : XTP_CALENDAR_USERACTION_PARAMS
  • m_fAngle : CXTPChartRotateDeviceCommand, CXTPChartRotatedTextPainterBase
  • m_fcCollapsable : CXTPSyntaxEditCtrl
  • m_fChartBoxSize : CXTPChart3dDiagram
  • m_fcRowColors : CXTPSyntaxEditCtrl
  • m_fMaterialShininess : CXTPChart3dDeviceContext
  • m_fMaxModelDistance : CXTPChart3dDeviceContext, CXTPChart3dDiagram
  • m_fMinModelDistance : CXTPChart3dDeviceContext, CXTPChart3dDiagram
  • m_fntFrameCaption : CXTPFramePaintManager
  • m_fntScaleHeaderText : CXTPCalendarTimeLineViewTimeScalePart
  • m_fntText : CXTPCalendarViewPart
  • m_fntTextFont : CXTPCalendarCaptionBarPaintManager, CXTPDateLabelPart
  • m_fntTimeText : CXTPCalendarPaintManager
  • m_fontGroupCaption : CXTPRibbonPaintManager
  • m_fontIcon : CXTPPaintManager
  • m_fontIconBold : CXTPPaintManager
  • m_fontSmCaption : CXTPPaintManager
  • m_fontToolTip : CXTPPaintManager
  • m_fValue : CXTPPropertyGridItemDouble
  • m_grcButton : CXTPComboBoxTheme
  • m_grcButtonHilite : CXTPComboBoxTheme
  • m_grcButtonPushed : CXTPComboBoxTheme
  • m_grcCaption : CXTPShortcutBarOffice2003Theme
  • m_grcGradientColumn : CXTPGridPaintManager
  • m_grcGradientColumnHot : CXTPGridPaintManager
  • m_grcGradientColumnPushed : CXTPGridPaintManager
  • m_grcHot : CXTPShortcutBarPaintManager, CXTPTaskPanelListViewOffice2003Theme
  • m_grcItemCaption : CXTPShortcutBarOffice2003Theme
  • m_grcItemHotCaption : CXTPShortcutBarOffice2003Theme
  • m_grclrBackground : CXTPCalendarEventCategory
  • m_grclrBk : CXTPCalendarViewEventSubjectEditorColored
  • m_grclrClassicSelDay : CXTPCalendarPaintManager
  • m_grclrToday : CXTPCalendarPaintManager
  • m_grcLunaChecked : CXTPCommandBarsOffice2003Theme
  • m_grcLunaPushed : CXTPCommandBarsOffice2003Theme
  • m_grcLunaSelected : CXTPCommandBarsOffice2003Theme
  • m_grcPushed : CXTPShortcutBarPaintManager, CXTPTaskPanelListViewOffice2003Theme
  • m_grcSelected : CXTPShortcutBarPaintManager
  • m_grcShortcutBarGripper : CXTPShortcutBarPaintManager
  • m_grcShortcutItem : CXTPShortcutBarPaintManager
  • m_groupNormal : CXTPTaskPanelPaintManager
  • m_groupSpecial : CXTPTaskPanelPaintManager
  • m_hActiveChild : CXTPMDIWndTab
  • m_hBitmap : CXTPImageManagerIconHandle, CXTPSkinImage, CXTPTransparentBitmap
  • m_hbmLayer : CXTPResourceImages
  • m_hbmpImage : CXTPImageManagerResource
  • m_hbmpMask : CXTPImageManagerResource
  • m_hbmpWatermark : CXTPGridControl
  • m_hbrActiveTitleHorz : CXTPDockingPanePaintManager
  • m_hbrActiveTitleVert : CXTPDockingPanePaintManager
  • m_hbrInactiveTitleHorz : CXTPDockingPanePaintManager
  • m_hbrInactiveTitleVert : CXTPDockingPanePaintManager
  • m_hCurArrow : CXTPSyntaxEditPaintManager
  • m_hCurCopy : CXTPSyntaxEditPaintManager
  • m_hCurEyeDropper : CXTPEyeDropper
  • m_hcurHand : CXTPHyperLink, CXTPTaskDialogLinkCtrl
  • m_hCurIBeam : CXTPSyntaxEditPaintManager
  • m_hCurLine : CXTPSyntaxEditPaintManager
  • m_hCurMove : CXTPSyntaxEditPaintManager
  • m_hCurNO : CXTPSyntaxEditPaintManager
  • m_hCurPrevious : CXTPEyeDropper
  • m_hCursor : CXTPControlHyperlink, CXTPPropertyGridView, CXTPShortcutListBox, CXTPSizeIcon, CXTPTagCloudCtrl
  • m_hCursorBack : CXTPDatePickerPaintManager
  • m_hCursorDelete : CXTPTabClientWnd
  • m_hCursorHand : CXTPPropertyGrid
  • m_hCursorHoriz : CXTPTabClientWnd
  • m_hCursorNew : CXTPTabClientWnd
  • m_hCursorSplit : CXTPPropertyGrid
  • m_hCursorVert : CXTPTabClientWnd
  • m_hDC : CXTPChartDeviceContext
  • m_hDestDC : CXTPAnimationDC
  • m_hDontDropCursor : CXTPGridHeader
  • m_heightMode : CXTPGridSection
  • m_hGripperNormal : CXTPTaskPanelPaintManager
  • m_hGripperSpecial : CXTPTaskPanelPaintManager
  • m_hHandCursor : CXTPPopupControl, CXTPShortcutBar, CXTPShortcutBarPane, CXTPTaskPanel
  • m_hHookCallWndProc : CXTPKeyboardManager
  • m_hHookGetMessage : CXTPKeyboardManager
  • m_hHookKeyboard : CXTPKeyboardManager
  • m_hHookMouse : CXTPToolTipContextToolTip
  • m_hIcon : CXTPCalendarOccurSeriesChooseDlg, CXTPCaption, CXTPEyeDropper, CXTPFramePaintManager, CXTPIconHandle, CXTPImageManagerIconHandle, CXTPMenuBarMDIMenuInfo, CXTPTabManagerItem, CXTPTrayIcon, CXTPWindowList
  • m_hIconFooter : CXTPTaskDialogClient
  • m_hIconMain : CXTPTaskDialogClient
  • m_hIconOff : CXTPCaptionPopupWnd
  • m_hIconOn : CXTPCaptionPopupWnd
  • m_hInsertMark : CXTPTreeBase
  • m_hInstance : CXTPSkinManagerResourceFile
  • m_hKeyBase : CXTPRegistryManager
  • m_hMenuDefault : CXTPMenuBar
  • m_hModOldResource : CXTPResourceManager::CManageState
  • m_hModule : CXTPSkinManagerResourceFile
  • m_hModXTResource : CXTPResourceManager
  • m_hMoveCursor : CXTPTrackControl
  • m_hOldBitmap : CXTPAnimationDC
  • m_Host : CXTPWebBrowserProvider
  • m_hotTrackStyle : CXTPTaskPanel
  • m_hParentKey : CXTPPropExchangeRegistry
  • m_hResizeCursor : CXTPGridHeader, CXTPTrackControl
  • m_hResizeVCursor : CXTPGridHeader
  • m_hResource : CXTPResourceImages
  • m_hResourceFile : CXTPResourceManager
  • m_hSectionKey : CXTPPropExchangeRegistry
  • m_hSelect : CXTPTreeBase
  • m_hSizeCursor : CXTPShortcutBar
  • m_htiEdit : CXTPTreeBase
  • m_htiLast : CXTPTreeBase
  • m_hWinEventHook : CXTPSkinManager
  • m_hWnd : CXTPFlowGraphNode, CXTPTabManagerItem, CXTPTaskPanelGroupItem
  • m_hWndActiveChild : CXTPMenuBar
  • m_hWndBuddy : CXTPButton
  • m_hwndChild : CXTPDialogBar, CXTPDockingPane, CXTPShortcutBarItem
  • m_hwndClient : CXTPShortcutBar
  • m_hwndControl : CXTPControlCustom
  • m_hwndFocus : CXTPCommandBar
  • m_hWndMDIClient : CXTPWindowList
  • m_hWndNotify : CXTPTrayIcon
  • m_hWndPane : CXTPStatusBarPane
  • m_hwndSite : CXTPCommandBarsFrameHook
  • m_hwndTaskDialog : CXTPTaskDialog
  • m_iArrowPadding : CXTPHeaderCtrlTheme
  • m_iBorderGap : CXTPMDIClientWnd, CXTPMDIWndTab
  • m_iBtnEnd : CXTPExcelTabCtrl
  • m_iBtnHilight : CXTPExcelTabCtrl
  • m_iBtnHome : CXTPExcelTabCtrl
  • m_iBtnLeft : CXTPExcelTabCtrl
  • m_iBtnRight : CXTPExcelTabCtrl
  • m_iCategory : CXTPCustomizeKeyboardPage
  • m_iCell : CXTPColorHex::CRgnCell
  • m_iCharSet : CXTPSyntaxEditPropertiesPageFont
  • m_iColumnForNum : CXTPGridControl
  • m_iCommand : CXTPExcelTabCtrlButtonState
  • m_iconIndent : CXTPTreeBase
  • m_iconsInfo : CXTPPaintManager
  • m_IconType : CXTPExcelTabCtrlButtonState
  • m_icoSize : CXTPEyeDropper
  • m_iCRLFStyle : CXTPSyntaxEditBufferManager
  • m_iEdge : CXTPTabBaseTheme
  • m_iGripperPosPerCent : CXTPExcelTabCtrl
  • m_iHitTest : CXTPMDIWndTab
  • m_iHours : CXTPTimeEdit
  • m_iHScrollPos : CXTPSyntaxEditDoc
  • m_iIconHeight : CXTPGridControl
  • m_iIconHeightSpacing : CXTPGridControl
  • m_iIconNum : CXTPGridControl
  • m_iIconPropNum : CXTPGridControl
  • m_iIconViewColumn : CXTPGridControl
  • m_iIconViewRowsPerLine : CXTPGridControl
  • m_iIconWidth : CXTPGridControl
  • m_iIconWidthSpacing : CXTPGridControl
  • m_iIndex : CXTPSyntaxEditTipWnd
  • m_iLastRqstEditCol : CXTPGridControl
  • m_iLastRqstEditRow : CXTPGridControl
  • m_ilGradientCircle : CXTPCommandBarsOffice2003Theme
  • m_imageList : CXTPMDIWndTab
  • m_iMaxLineNo : CXTPSyntaxEditGoToLineDlg
  • m_iMaxSize : CXTPSearchOptionsCtrl
  • m_iMaxTipSize : CXTPTrayIcon
  • m_iMins : CXTPTimeEdit
  • m_iMinSize : CXTPHeaderCtrl, CXTPSearchOptionsCtrl
  • m_InsertMarkAfter : CXTPTreeBase
  • m_InsertMarkColor : CXTPTreeBase
  • m_iOverIndex : CXTPHeaderCtrl
  • m_iRecOrRowStart : CXTPGridPaintManager
  • m_iTabHeight : CXTPExcelTabCtrl
  • m_itemLayout : CXTPTaskPanel, CXTPTaskPanelGroup
  • m_iTopRow : CXTPSyntaxEditDoc, CXTPSyntaxEditView
  • m_LastHitInfo : CXTPCalendarView
  • m_lastInfo : CXTPToolTipContext
  • m_Layout : CXTPCalendarDayViewTimeScale, CXTPCalendarView, CXTPCalendarViewDay, CXTPCalendarViewGroup
  • m_LayoutX : CXTPCalendarDayView, CXTPCalendarDayViewGroup, CXTPCalendarWeekView
  • m_lboxCommands : CXTPCustomizeKeyboardPage
  • m_lboxKeys : CXTPCustomizeKeyboardPage
  • m_lboxWindows : CXTPWindowList
  • m_lcFrom : CXTPSyntaxEditBufferCommand
  • m_lcidDateTime : CXTPPropExchange
  • m_LCpos : CXTPSyntaxEditTextIterator
  • m_lcTo : CXTPSyntaxEditBufferCommand
  • m_lf : CXTPChartFont
  • m_lfCaption : CXTPFlowGraphPaintManager
  • m_lfDateHeader : CXTPCalendarPageSetupDialog
  • m_lfDateHeaderCalendarFont : CXTPCalendarControlViewPrintOptions
  • m_lfDateHeaderFont : CXTPCalendarControlViewPrintOptions
  • m_lfDateHeaderWeekDayFont : CXTPCalendarControlViewPrintOptions
  • m_lfPrevFont : CXTPSyntaxEditView
  • m_lfText : CXTPFlowGraphPaintManager
  • m_lfValue : CXTPPropertyGridItemFont
  • m_listeners : CXTPColorSelectorCtrl
  • m_listFonts : CXTPFontEnum
  • m_lpCurrencyFmt : CXTPGridGroupRow
  • m_lpDlgTemplate : CXTPPropertySheet
  • m_lpFolder : CXTPShellPidl::CShellSpecialFolder
  • m_lpMalloc : CXTPShellPidl::CShellMalloc
  • m_lpsfFolder : CXTPShellListBase
  • m_lpTextFile : CXTPSkinManagerResourceFile
  • m_lpTextFileEnd : CXTPSkinManagerResourceFile
  • m_lstCategories : CXTPCustomizeCommandsPage, CXTPRibbonCustomizeQuickAccessPage
  • m_lstCommands : CXTPCustomizeCommandsPage, CXTPRibbonCustomizeQuickAccessPage
  • m_lstKeyboardHooks : CXTPKeyboardManager
  • m_lstPanes : CXTPDockingPaneBaseContainer
  • m_lstQuickAccess : CXTPRibbonCustomizeQuickAccessPage
  • m_lstRects : CXTPDockingPaneTabbedContainer
  • m_lstSpliters : CXTPDockingPaneSplitterContainer
  • m_lstStickers : CXTPDockingPaneContext
  • m_lstViewParts : CXTPCalendarPaintManager
  • m_managerInstance : CXTPResourceManager
  • m_mapAdviseData : CXTPNotifySinkBase
  • m_mapCachedProperties : CXTPSkinManagerClass
  • m_mapClasses : CXTPSkinManagerSchema
  • m_mapColorFont : CXTPTreeBase
  • m_mapCustomReminderValues : CXTPCalendarControl
  • m_mapDocTemplatesAssigned : CXTPControl
  • m_mapDocTemplatesExcluded : CXTPControl
  • m_mapHiddenCommands : CXTPCommandBarsOptions
  • m_mapIcon : CXTPGridRecordItemControl
  • m_mapID2Object : CXTPCalendarData::EventsMapByID_T< _TObject >
  • m_mapImages : CXTPResourceImages, CXTPSkinImages
  • m_mapInfo : CXTPSkinObjectClassMap
  • m_mapInternalRowBkColor : CXTPSyntaxEditCtrl
  • m_mapInternalRowForeColor : CXTPSyntaxEditCtrl
  • m_mapLexClassInfo : CXTPSyntaxEditPropertiesPageColor
  • m_mapLine2Len : CXTPSyntaxEditTextIterator
  • m_mapMenus : CXTPMenuBarMDIMenus
  • m_mapObjects : CXTPSkinManager
  • m_mapProperties : CXTPCalendarCustomProperties, CXTPSkinManagerSchema
  • m_mapPropeties : CXTPResourceImages
  • m_mapRowBkColor : CXTPSyntaxEditOptions
  • m_mapRowForeColor : CXTPSyntaxEditOptions
  • m_mapState : CXTPPropertyGridUpdateContext
  • m_mapTabIcons : CXTPMDIWndTab
  • m_mapTabLabels : CXTPMDIWndTab
  • m_mapUsedCommands : CXTPCommandBarsOptions
  • m_mapWndSize : CXTPTaskDialogClient
  • m_MonthDate : CXTPCalendarEventRecurrenceDlg
  • m_Monthly : XTP_CALENDAR_RECURRENCE_OPTIONS
  • m_MonthNth : XTP_CALENDAR_RECURRENCE_OPTIONS
  • m_mouseCursorMode : CXTPTrackControl
  • m_mouseDownState : CXTPGridControl
  • m_mouseMode : CXTPCalendarControl, CXTPDatePickerControl, CXTPGridControl
  • m_nActiv_EndTags_Offset : CXTPSyntaxEditLexClass
  • m_nAlign : CXTPPopupItem
  • m_nAlignment : CXTPChartAxis, CXTPChartAxisConstantLine, CXTPChartAxisTitle, CXTPChartTitle, CXTPGridColumn, CXTPStatusBarPane
  • m_nAllDayEventSet : CXTPCalendarEventPropertiesDlg
  • m_nAllocWidth : CXTPImageManagerResource
  • m_nAllowDrag : CXTPTaskPanel, CXTPTaskPanelItem
  • m_nAllowReduce : CXTPRibbonGroup
  • m_nAlphaClipFormat : CXTPImageManager
  • m_nAngle : CXTPChartAxisLabel, CXTPChartPointSeriesLabel, CXTPChartRadarPointSeriesLabel
  • m_nAnimateTimer : CXTPTaskPanel
  • m_nAnimationDelay : CXTPFlowGraphControl
  • m_nAnimationDuration : CXTPDockingPaneAutoHideWnd
  • m_nAnimationInterval : CXTPDockingPaneAutoHideWnd, CXTPPopupControl
  • m_nAnimationStep : CXTPTaskPanel
  • m_nAnimationSteps : CXTPPaintManager
  • m_nAnimationTime : CXTPPaintManager
  • m_nAnimationType : CXTPCustomizeOptionsPage
  • m_nArgumentScaleType : CXTPChartSeries
  • m_nAutoButton : CXTPColorSelectorCtrlTheme
  • m_nAutoIndentCol : CXTPSyntaxEditCtrl
  • m_nAutoNumberingBase : CXTPGridColumn
  • m_nAutoPopTimer : CXTPToolTipContextToolTip
  • m_nAutoVScrollTimerResolution : CXTPGridControl
  • m_nAverageLineLen : CXTPSyntaxEditBufferManager, CXTPSyntaxEditCtrl
  • m_nAxisIndexX : CXTPChartDiagram2DSeriesStyle
  • m_nAxisIndexY : CXTPChartDiagram2DSeriesStyle
  • m_nBackgroundAlignemnt : CXTPTaskPanelGroup
  • m_nBackgroundBitmap : CXTPPopupControl
  • m_nBackgroundImage : CXTPTaskPanelGroup
  • m_nBackstageMenuWidth : CXTPRibbonBar
  • m_nBackstageSysButtonBottom : CXTPRibbonBar
  • m_nBackstageSysButtonTop : CXTPRibbonBar
  • m_nBarCount : CXTPChartBarSeriesView
  • m_nBarID : CXTPCommandBar
  • m_nBarIndex : CXTPChartBarSeriesView
  • m_nBaseParentRecordIndent : CXTPGridPaintManager
  • m_nBestFit : CXTPStatusBarPane
  • m_nBestFitMode : CXTPGridColumn
  • m_nBoldDaysIdleStepTime_ms : CXTPCalendarController
  • m_nBoldDaysPerIdleStep : CXTPCalendarController
  • m_nBorder : CXTPCaption
  • m_nBorderGap : CXTPButton
  • m_nBordersHeight : CXTPSyntaxEditAutoCompleteWnd
  • m_nBorderSize : CXTPSkinManagerMetrics
  • m_nBorderStyle : CXTPButton
  • m_nBorderY : CXTPSystemMetrics
  • m_nBottom : CXTPGridThickness
  • m_nBottomCalculatedRow : CXTPSyntaxEditCtrl
  • m_nBufOffsetB : CXTPSyntaxEditTextIterator
  • m_nBufOffsetB_max : CXTPSyntaxEditTextIterator
  • m_nBufOffsetB_normal : CXTPSyntaxEditTextIterator
  • m_nBufSizeB : CXTPSyntaxEditTextIterator
  • m_nBusyStatus : CXTPCalendarEvent, CXTPCalendarEventPropertiesDlg
  • m_nButtonExtraLength : CXTPTabPaintManager
  • m_nButtonHeight : CXTPTabPaintManagerTheme
  • m_nButtonLength : CXTPTabManagerItem
  • m_nBytePerRow : CXTPHexEdit
  • m_nCaption : CXTPColorSelectorCtrlTheme
  • m_nCaptionButtonStyle : CXTPDockingPanePaintManager
  • m_nCaptionFontGap : CXTPDockingPanePaintManager
  • m_nCaptionHeight : CXTPCalendarControl, CXTPDialogBar, CXTPTaskPanelGroup, CXTPTaskPanelPaintManager
  • m_nCaptionTextFormat : CXTPTaskPanelPaintManager
  • m_nCaptionY : CXTPSystemMetrics
  • m_nCategory : CXTPChartNumberFormat
  • m_nChecked : CXTPControlGallery
  • m_nCheckHotStateTimerID : CXTPCalendarCaptionBarTheme
  • m_nChildIndex : CXTPGridRow
  • m_nClassCode : CXTPSkinManagerClass
  • m_nClassPart : CXTPSkinObjectFrame::CCaptionButton
  • m_nClientHeight : CXTPExcelTabCtrl, CXTPTaskPanel
  • m_nClientWidth : CXTPExcelTabCtrl
  • m_nCodePage : CXTPSyntaxEditBufferManager
  • m_nColHeaderHeight : CXTPCalendarMonthView::CMonthViewGrid
  • m_nCollapsedTextRowsCount : CXTPSyntaxEditCtrl
  • m_nCols : CXTPColorPicker, CXTPColorSelectorCtrl
  • m_nColumn : CXTPDatePickerItemMonth
  • m_nColumnAutoWidth : CXTPGridColumn
  • m_nColumnCount : CXTPChartLegend
  • m_nColumns : CXTPDatePickerControl
  • m_nColumnStaticWidth : CXTPGridColumn
  • m_nColumnWidth : CXTPTaskPanel
  • m_nCommand : CXTPSkinObjectFrame::CCaptionButton
  • m_nConnectorType : CXTPFlowGraphPaintManager
  • m_nContentLength : CXTPTabManagerItem
  • m_nContextColor : CXTPRibbonTab
  • m_nControlID : CXTPControlCustom
  • m_nCount : CXTPPropExchangeEnumerator
  • m_nCounter : CXTPTrayIcon
  • m_nCurPage : CXTPCalendarDayView
  • m_nCurrentAddress : CXTPHexEdit
  • m_nCurrentCol : CXTPSyntaxEditCtrl
  • m_nCurrentDocumentRow : CXTPSyntaxEditCtrl
  • m_nCurrentTransparency : CXTPPopupControl
  • m_nCurrPos : CXTPCalendarWeekView
  • m_nCurSel : CXTPColorSelectorCtrl, CXTPExcelTabCtrl
  • m_nCustomClientHeight : CXTPRibbonBar
  • m_nCustomGroupsHeight : CXTPRibbonBar
  • m_nCustomHeight : CXTPMessageBar
  • m_nCustomIconId : CXTPControl
  • m_nDashStyle : CXTPChartLineStyle
  • m_nDataSize : CXTPSyntaxEditCtrl::CAverageVal
  • m_nDataSizeLimit : CXTPSyntaxEditUndoRedoManager
  • m_nDayHeaderHeight : XTP_WEEK_VIEW_LAYOUT
  • m_nDayHeaderPeriod : CXTPCalendarDayView
  • m_nDayHeight : XTP_WEEK_VIEW_LAYOUT
  • m_nDayInterval : CXTPCalendarEventRecurrenceDlg
  • m_nDayOfMonth : CXTPCalendarEventRecurrenceDlg
  • m_nDayViewPrintInterval : CXTPCalendarDayView
  • m_nDayWidth : XTP_WEEK_VIEW_LAYOUT
  • m_nDeactivationCount : CXTPDockingPaneMiniWnd, CXTPDockingPaneSidePanel
  • m_nDecimalPlaces : CXTPChartNumberFormat
  • m_nDefaultGap : CXTPBrowseEdit
  • m_nDefaultMenuID : CXTPCommandBars
  • m_nDefaultRowFreeHeight : CXTPGridControl
  • m_nDefCmd : CXTPMDIWndTab
  • m_nDelayAutoPop : CXTPToolTipContext, CXTPToolTipContextToolTip
  • m_nDelayInitial : CXTPToolTipContext, CXTPToolTipContextToolTip
  • m_nDelayReshow : CXTPToolTipContext, CXTPToolTipContextToolTip
  • m_nDelayTime : CXTPSyntaxEditToolTipCtrl
  • m_nDelayTimer : CXTPToolTipContextToolTip
  • m_nDelayTimerEventID : CXTPTipWindow
  • m_nDesiredColumns : CXTPDatePickerControl
  • m_nDesiredExpandedLinesHeight : CXTPShortcutBar
  • m_nDesiredRows : CXTPDatePickerControl
  • m_nDialogID : CXTPResizeDialog, CXTPResizePropertyPage
  • m_nDirection : CXTPChartLegend
  • m_nDisableReorderColumnsCount : CXTPGridControl
  • m_nDisableShortcuts : CXTPShortcutManager
  • m_nDispCol : CXTPSyntaxEditCtrl
  • m_nDocking : CXTPChartTitle
  • m_nDockingContextStickerStyle : CXTPDockingPaneManager
  • m_nDragSensitivityX : CXTPGridControl
  • m_nDragSensitivityY : CXTPGridControl
  • m_nDrawingRow : CXTPSyntaxEditDrawTextProcessor
  • m_nDrawTextFormat : CXTPTabPaintManager
  • m_nDropDownItemCount : CXTPControlComboBox, CXTPPropertyGridItem
  • m_nDropIndex : CXTPGridHeader, CXTPGridSubListControl
  • m_nDropPos : CXTPGridControl
  • m_nEditbarLength : CXTPSyntaxEditCtrl
  • m_nEditHeight : CXTPPaintManager
  • m_nEditIconId : CXTPControlComboBox, CXTPControlEdit
  • m_nElapseTimerEventID : CXTPTipWindow
  • m_nEllipseSize : CXTPFlowGraphPaintManager
  • m_nEnableCustomShortcutText : CXTPShortcutManager
  • m_nEndAfterOccurrences : XTP_CALENDAR_PATTERN_END
  • m_nEndChar : CXTPMaskEditT< TBase >
  • m_nEndReplacePos : CXTPSyntaxEditAutoCompleteWnd
  • m_nEndTagXLCLen : CXTPSyntaxEditLexTextBlock
  • m_nEnsureVisibleColumnIdx : CXTPGridControl
  • m_nEnsureVisibleRowIdx : CXTPGridControl
  • m_nEventCaptionFormat : CXTPCalendarMonthView
  • m_nEventDurationInPixels : CXTPCalendarTimeLineViewEvent
  • m_nEventPlaceNumber : CXTPCalendarViewEvent
  • m_nEventTimelinePlaceNumber : CXTPCalendarViewEvent
  • m_nEventTimeWidth : CXTPCalendarMonthView
  • m_newTabPosition : CXTPTabClientWnd
  • m_nExecuteOnPressInterval : CXTPControl
  • m_nExpandedClientHeight : CXTPTaskPanelGroup
  • m_nExpandedHeight : CXTPDockingPaneMiniWnd
  • m_nExpandedIconWidth : CXTPShortcutBarPaintManager
  • m_nExpandedLines : CXTPShortcutBar
  • m_nExplodedDistancePercent : CXTPChartPieSeriesStyleBase
  • m_nExtendedColors : CXTPColorPicker, CXTPColorSelectorCtrl
  • m_nFillAcrossXAxis : CXTPChartAreaSeriesStyle
  • m_nFillMode : CXTPChartFillStyle
  • m_nFirstDayOfWeek : CXTPDatePickerControl
  • m_nFirstDayOfWeekIndex : CXTPCalendarMonthView::CMonthViewGrid, CXTPCalendarWeekView
  • m_nFirstDisplayedStr : CXTPSyntaxEditAutoCompleteWnd
  • m_nFirstWeekOfYearDays : CXTPDatePickerControl
  • m_nFistMDIChild : CXTPControlWindowList
  • m_nFixedColumnsIndent : CXTPGridPaintManager
  • m_nFixedHeight : CXTPGridInplaceButton
  • m_nFixedTabWidth : CXTPTabPaintManager
  • m_nFlags : CXTPPropertyGridItem
  • m_nFlagsXX : CXTPResize
  • m_nFloatingFramesOpacity : CXTPDockingPaneManager
  • m_nFocused : CXTPTaskDialogLinkCtrl
  • m_nFocusedRow : CXTPGridRows
  • m_nFocusedVerb : CXTPPropertyGrid
  • m_nFontHeight : CXTPPaintManager
  • m_nFontSize : CXTPDockingPaneVisualStudio2012Theme
  • m_nFooterAlignment : CXTPGridColumn
  • m_nFooterHeight : CXTPGridPaintManager
  • m_nForceLayoutAdjustment : CXTPGridHeader
  • m_nFrameCaptionHeight : CXTPFramePaintManager
  • m_nFreeHeight : CXTPGridRecord, CXTPGridRow
  • m_nFreezeColsDividerStyle : CXTPGridPaintManager
  • m_nFullDrag : CXTPSplitterWnd
  • m_nGap : CXTPBrowseEdit, CXTPMarqueeCtrl
  • m_nGradientAngle : CXTPChartFillStyle
  • m_nGridColumns : XTP_WEEK_VIEW_LAYOUT
  • m_nGridLineStylePreviousH : CXTPGridPaintManager
  • m_nGridLineStylePreviousV : CXTPGridPaintManager
  • m_nGripperWidth : CXTPDockingPanePanelTheme2012
  • m_nGroupCaptionHeight : CXTPRibbonPaintManager
  • m_nGroupGridLineHeight : CXTPGridPaintManager
  • m_nGroupGridLineStyle : CXTPGridPaintManager
  • m_nGroupId : CXTPFlowGraphNode
  • m_nGroupLevel : CXTPGridRow
  • m_nGroupMinClientHeight : CXTPTaskPanel
  • m_nGroupPriority : CXTPGridRecordItem
  • m_nGroupSpacing : CXTPRibbonPaintManager, CXTPTaskPanel, CXTPTaskPanelPaintManager
  • m_nGroupsScrollPos : CXTPRibbonGroups
  • m_nHatchStyle : CXTPChartFillStyle
  • m_nHeaderAlignment : CXTPGridColumn
  • m_nHeaderHeight : CXTPGridPaintManager
  • m_nHeaderOffset : CXTPTabManager
  • m_nHeaderWidth : CXTPGridHeader
  • m_nHeight : CXTPChartTextPainterBase, CXTPControl, CXTPGridHeaderDropWnd, CXTPGridSection, CXTPPropertyGridItem, CXTPShortcutBarPaneItem
  • m_nHelpHeight : CXTPPropertyGridPaintManager
  • m_nHelpId : CXTPControl, CXTPControlAction
  • m_nHiddenCol : CXTPSplitterWnd
  • m_nHiddenRow : CXTPSplitterWnd
  • m_nHighLightLine : CXTPSyntaxEditAutoCompleteWnd
  • m_nHitTest : CXTPDockContext
  • m_nHolePercent : CXTPChartPieBase, CXTPChartPieSeriesStyleBase
  • m_nHorizontalAlignment : CXTPChartLegend
  • m_nHotButton : CXTPSpinButtonCtrl
  • m_nHotItem : CXTPListBox
  • m_nHourWidth : CXTPCalendarPaintManager
  • m_nHScrollMaxWidth : CXTPSyntaxEditCtrl
  • m_nHScrollPos : CXTPCalendarTimeLineView
  • m_nHTCode : CXTPSkinObjectFrame::CCaptionButton
  • m_nHue : CXTPColorBase
  • m_nHyperTextBegin : CXTPGridHyperlink
  • m_nHyperTextLen : CXTPGridHyperlink
  • m_nIcon : XTP_EDIT_ACDATA
  • m_nIconID : CXTPDockingPane, CXTPGridColumn, CXTPTrayIcon
  • m_nIconId : CXTPControl, CXTPControlAction, CXTPRibbonGroup, CXTPShortcutBarItem
  • m_nIconIndex : CXTPGridInplaceButton, CXTPGridRecordItem, CXTPPopupItem, CXTPStatusBarPane, CXTPTaskPanelItem
  • m_nIconTitle : CXTPToolTipContext
  • m_nIconX : CXTPSystemMetrics
  • m_nIconY : CXTPSystemMetrics
  • m_nID : CXTPBrowseButton, CXTPCalendarEventCategory, CXTPDatePickerButton, CXTPDockingPane, CXTPDockingPaneCaptionButton, CXTPFlowGraphUndoCommand, CXTPGridInplaceButton, CXTPMessageBarButton, CXTPPopupControl, CXTPPopupItem, CXTPPropertyGridItem, CXTPPropertyGridVerb, CXTPShortcutBarItem, CXTPStatusBarPane, CXTPTabManagerNavigateButton, CXTPTaskPanelItem, CXTPTrackUndoCommand
  • m_nId : CXTPControl, CXTPControlAction, CXTPControlGalleryItem, CXTPFlowGraphConnectionPoint, CXTPFlowGraphNode, CXTPFlowGraphPage, CXTPRibbonGroup, CXTPRibbonTab
  • m_niData : CXTPTrayIcon
  • m_nIDEvent : CXTPTrayIcon
  • m_nIDHelp : CXTPDockingPane
  • m_nIDHelpTracking : CXTPCommandBars
  • m_nIdleFlags : CXTPCommandBar
  • m_nIDResource : CXTPMenuBar, CXTPMenuBarMDIMenuInfo
  • m_nIDResourceCurrent : CXTPMenuBar
  • m_nIDResourceLabels : CXTPCalendarOccurSeriesChooseDlg
  • m_nImage : CXTPControlGalleryItem, CXTPPropertyGridItemConstraint, CXTPPropertyGridItemMetrics, CXTPTabManagerItem
  • m_nImageAlignment : CXTPButton
  • m_nImageBase : CXTPToolTipContext
  • m_nImageClipFormat : CXTPImageManager
  • m_nImageGap : CXTPButton
  • m_nImageIndex : CXTPFlowGraphConnectionPoint, CXTPFlowGraphNode
  • m_nImageSize : CXTPToolTipContext
  • m_nImageWidth : CXTPControlGalleryItem
  • m_nImportance : CXTPCalendarEvent
  • m_nInactiveCollapseDelay : CXTPDockingPaneAutoHideWnd
  • m_nIndent : CXTPChartTitle, CXTPPropertyGridItem
  • m_nIndentLevel : CXTPGridHeader
  • m_nIndex : CXTPChartSeriesPoint, CXTPControl, CXTPControlGalleryItem, CXTPEditListBox, CXTPGridRecord, CXTPGridRecordItemConstraint, CXTPGridRecordItemControl, CXTPGridRow, CXTPPopupItem, CXTPPropertyGridItem, CXTPPropertyGridItemConstraint, CXTPPropertyGridVerb, CXTPRibbonGroup, CXTPShortcutListBox::CONTENT_ITEM, CXTPStatusBarPane, CXTPTabManagerItem, CXTPTrackBlock
  • m_nInnerIndent : CXTPChartTitle
  • m_nInputId : CXTPFlowGraphConnection
  • m_nInputLockCount : CXTPKeyboardManager
  • m_nInsertSpaceCount : CXTPSyntaxEditCtrl
  • m_nInsertTabCount : CXTPSyntaxEditCtrl
  • m_nItemCount : CXTPControlWindowList
  • m_nItemHeight : CXTPListBox, CXTPPropertyGridView
  • m_nItemIndex : CXTPGridColumn
  • m_nItemRow : CXTPTabManagerItem
  • m_nItemsAbove : CXTPDatePickerList
  • m_nItemsBelow : CXTPDatePickerList
  • m_nItemsBorderHeight : CXTPPropertyGridPaintManager
  • m_nItemsInRow : CXTPTaskPanelGroup
  • m_nItemTextFormat : CXTPTaskPanelPaintManager
  • m_nKeyboardTipsLevel : CXTPRibbonBackstageView
  • m_nKeyStateTimerID : CXTPCalendarView
  • m_nLabelID : CXTPCalendarEvent, CXTPCalendarEventLabel
  • m_nLabelWidth : CXTPControlComboBox, CXTPControlEdit
  • m_nLastDragTime : CXTPTrackBlock
  • m_nLastSel : CXTPControlComboBox
  • m_nLeft : CXTPGridThickness
  • m_nLength : CXTPChartAxisTickMarks, CXTPChartSeriesPoint, CXTPHexEdit, CXTPTrackBlock
  • m_nLineHeight : CXTPHexEdit, CXTPSyntaxEditAutoCompleteWnd
  • m_nLineLength : CXTPChartSeriesLabel
  • m_nLineNumLength : CXTPSyntaxEditCtrl
  • m_nLines : CXTPSyntaxEditAutoCompleteWnd
  • m_nLinesCount : CXTPPropertyGridItem
  • m_nLineSpace : CXTPTipWindow
  • m_nLinesPerPage : CXTPHexEdit
  • m_nLineThickness : CXTPChartHighLowSeriesStyle
  • m_nListBoxLinesMax : CXTPControlListBox
  • m_nListBoxLinesMin : CXTPControlListBox
  • m_nLocale : CXTPChartNumberFormat
  • m_nLockCount : CXTPCalendarControl::CViewChanged_ContextData, CXTPCalendarView::CSelectionChanged_ContextData
  • m_nLockCount_Day : CXTPCalendarView::CSelectionChanged_ContextData
  • m_nLockCount_Event : CXTPCalendarView::CSelectionChanged_ContextData
  • m_nLockRedraw : CXTPCommandBar, CXTPTaskPanel
  • m_nLockReposition : CXTPDockingPaneTabbedContainer
  • m_nLockUpdate : CXTPPropertyGridView
  • m_nLockUpdateCount : CXTPDatePickerControl, CXTPGridControl
  • m_nLogPixelsX : CXTPDeviceCaps
  • m_nLogPixelsY : CXTPDeviceCaps
  • m_nLum : CXTPColorBase
  • m_nMargin : CXTPColorSelectorCtrlTheme, CXTPTagCloudCtrl
  • m_nMarginLength : CXTPSyntaxEditCtrl
  • m_nMarqueeDelay : CXTPProgressCtrl
  • m_nMarqueePos : CXTPProgressCtrl
  • m_nMax : CXTPControlScrollBar, CXTPControlSlider, CXTPProgressBase, CXTPPropertyGridInplaceSlider, CXTPPropertyGridInplaceSpinButton, CXTPStatusBarScrollBarPane
  • m_nMaxClientWidth : CXTPTaskDialogClient
  • m_nMaxColumnWidth : CXTPGridHeader
  • m_nMaxColWidth : CXTPListBase
  • m_nMaxConnections : CXTPFlowGraphConnectionPoint
  • m_nMaxHeight : CXTPPopupBar
  • m_nMaxItemWidth : CXTPGridColumn
  • m_nMaxLength : CXTPGridRecordItemEditOptions, CXTPHexEdit, CXTPPropertyGridItemMetrics, CXTPTrackBlock
  • m_nMaxPreviewLines : CXTPGridPaintManager
  • m_nMaxSelectionDays : CXTPDatePickerControl
  • m_nMaxTabWidth : CXTPTabPaintManager
  • m_nMaxTipWidth : CXTPToolTipContext
  • m_nMaxValue : CXTPChartAxisRange
  • m_nMaxWidth : CXTPGridColumn
  • m_nMenu : CXTPBrowseButton, CXTPBrowseEdit
  • m_nMergeHeight : CXTPGridRow
  • m_nMin : CXTPControlScrollBar, CXTPControlSlider, CXTPProgressBase, CXTPPropertyGridInplaceSlider, CXTPPropertyGridInplaceSpinButton, CXTPStatusBarScrollBarPane
  • m_nMinClientHeight : CXTPShortcutBar, CXTPShortcutBarPane, CXTPTaskPanelGroup
  • m_nMinClientWidth : CXTPTaskDialogClient
  • m_nMinColumnWidth : CXTPCalendarDayView
  • m_nMinColWidth : CXTPListBase
  • m_nMinHeight : CXTPStatusBar
  • m_nMinLength : CXTPTrackBlock
  • m_nMinorCount : CXTPChartAxis
  • m_nMinorLength : CXTPChartAxisTickMarks
  • m_nMinorThickness : CXTPChartAxisTickMarks
  • m_nMinTabWidth : CXTPTabPaintManager
  • m_nMinutesBeforeStart : CXTPCalendarReminder
  • m_nMinValue : CXTPChartAxisRange
  • m_nMinVisibleHeight : CXTPRibbonBar
  • m_nMinVisibleWidth : CXTPRibbonBar
  • m_nMinWidth : CXTPCalendarPaintManager, CXTPGridColumn, CXTPTabToolBar
  • m_nMonthDelta : CXTPDatePickerControl
  • m_nMonthInterval : CXTPCalendarEventRecurrenceDlg
  • m_nMonthInterval2 : CXTPCalendarEventRecurrenceDlg
  • m_nMouseHoverDelay : CXTPDockingPaneAutoHideWnd
  • m_nMRUPosition : CXTPTrackBlock
  • m_nMRUWidth : CXTPCommandBar
  • m_nMsgQueryFrameHook : CXTPCommandBarsFrameHook
  • m_nMultiDayEventFlags : CXTPCalendarViewEvent
  • m_nNameColumnWidth : CXTPShellListBase
  • m_nNearPosition : CXTPChartRotatedTextPainterNearLine
  • m_nNextIndex : CXTPSyntaxEditCtrl::CAverageVal
  • m_nNextLine : CXTPSyntaxEditTextIterator
  • m_nNextRefreshIndex : CXTPCalendarRemindersDialog
  • m_nNextRowPosX : CXTPSyntaxEditDrawTextProcessor
  • m_nNextTip : CXTPTipOfTheDay
  • m_nNextVisualBlock : CXTPGridColumn
  • m_nNodeFrameSize : CXTPFlowGraphPaintManager
  • m_nNodesWidth : CXTPSyntaxEditCtrl
  • m_nNormalIconWidth : CXTPShortcutBarPaintManager
  • m_nNullWidth : CXTPHexEdit
  • m_nObjType : CXTPSyntaxEditLexVariant
  • m_nOccurNum : CXTPCalendarEventRecurrenceDlg
  • m_nOffAddress : CXTPHexEdit
  • m_nOffAscii : CXTPHexEdit
  • m_nOffHex : CXTPHexEdit
  • m_nOffset : CXTPCaption, CXTPExcelTabCtrl
  • m_nOldClientHeight : CXTPTaskPanel
  • m_nOldLength : CXTPTrackUndoSetBlockPositionCommand
  • m_nOldMarkerPos : CXTPTrackHeader
  • m_nOldPosition : CXTPTrackUndoSetBlockPositionCommand, CXTPTrackUndoSetMarkerPositionCommand
  • m_nOldTrackViewPortRange : CXTPTrackControl
  • m_nOldTrackWidth : CXTPTrackControl
  • m_nOldViewPortMax : CXTPTrackHeader
  • m_nOldViewPortMin : CXTPTrackHeader
  • m_nOldVisibleIndex : CXTPGridColumn
  • m_nOldWorkAreaMax : CXTPTrackHeader
  • m_nOldWorkAreaMin : CXTPTrackHeader
  • m_nOLEDropMode : CXTPTaskPanel
  • m_nOpacity : CXTPMiniToolBar
  • m_nOutputId : CXTPFlowGraphConnection
  • m_nPadding : CXTPEyeDropper, CXTPTagCloudCtrl, CXTPTaskDialogClient
  • m_nPage : CXTPControlScrollBar, CXTPStatusBarScrollBarPane
  • m_nPageBorderStyle : CXTPPropertySheet
  • m_nPaintTheme : CXTPCalendarPaintManager, CXTPDatePickerPaintManager
  • m_nPaletteIndex : CXTPChartSeries, CXTPChartSeriesPoint
  • m_nPaneItemHeight : CXTPShortcutBarPaintManager
  • m_nPanelDirection : CXTPChartContent
  • m_nPanelDistance : CXTPChartContent
  • m_nParserThreadPriority_WhenActive : CXTPSyntaxEditView
  • m_nParserThreadPriority_WhenInactive : CXTPSyntaxEditView
  • m_nPartID : CXTPCalendarCaptionBarThemePart
  • m_nPointTextMargin : CXTPFlowGraphPaintManager
  • m_nPopulatedRecordsCount : CXTPGridSection
  • m_nPopupBarText : CXTPCommandBarsOffice2000Theme
  • m_nPopupBarTextPadding : CXTPPaintManager
  • m_nPopuped : CXTPCommandBar
  • m_nPopupLocation : CXTPPopupControl
  • m_nPos : CXTPControlScrollBar, CXTPControlSlider, CXTPHeaderCtrl, CXTPMarqueeCtrl, CXTPMDIWndTab, CXTPProgressBase, CXTPTabExBase
  • m_nPosition : CXTPChartFunnelSeriesLabelBase, CXTPChartPieSeriesLabelBase, CXTPChartPyramidSeriesLabelBase, CXTPTrackBlock, CXTPTrackMarker
  • m_nPressed : CXTPColorSelectorCtrl
  • m_nPressedButton : CXTPSpinButtonCtrl
  • m_nPreviewHeight : CXTPGridRow
  • m_nPrevIndex : CXTPShortcutListBox
  • m_nPrevTopRow : CXTPSyntaxEditView
  • m_nPrevTreeIndent : CXTPGridControl
  • m_nPrimitiveSize : CXTPChart3dDiagram
  • m_nPrintingRow : CXTPSyntaxEditDrawTextProcessor
  • m_nPushButtonStyle : CXTPButton
  • m_nQuickAccessHeight : CXTPRibbonBar
  • m_nRecordsTreeFilterMode : CXTPGridControl
  • m_nRecurrenceState : CXTPCalendarEvent
  • m_nRecurrenceType : XTP_CALENDAR_RECURRENCE_OPTIONS
  • m_nReminderMinutesBeforeStart : CXTPCalendarEvent
  • m_nResizable : CXTPControlGallery
  • m_nResizeCaptureRange : CXTPGridHeader
  • m_nResizingWidth : CXTPGridPaintManager
  • m_nRibbonCaptionHeight : CXTPResourceTheme
  • m_nRibbonDividerIndex : CXTPStatusBar
  • m_nRight : CXTPGridThickness
  • m_nRootFolder : CXTPShellTreeBase
  • m_nRotation : CXTPChartPieSeriesStyleBase
  • m_nRow : CXTPDatePickerItemMonth
  • m_nRowCount : CXTPRibbonGroup
  • m_nRowEnd : CXTPSyntaxEditLexOnScreenParseCnt
  • m_nRowHeight : CXTPGridPaintManager, CXTPSyntaxEditDrawTextProcessor
  • m_nRowHeightDefault : CXTPGridPaintManager
  • m_nRowIndex : CXTPGridTip
  • m_nRowLevel : CXTPGridRow
  • m_nRowMargin : CXTPTabPaintManagerTheme
  • m_nRows : CXTPDatePickerControl
  • m_nRowsPerWheel : CXTPCalendarControl, CXTPGridControl
  • m_nRowStart : CXTPSyntaxEditLexOnScreenParseCnt
  • m_nSat : CXTPColorBase
  • m_nSavedState : CXTPGridRecordItemButton
  • m_nScaleIntervalWidth_px : CXTPCalendarTLV_TimeScaleParams
  • m_nScaleType : CXTPChartAxis
  • m_nSchema : CXTPPropExchange
  • m_nScore : CXTPTagCloudStyle
  • m_nScrollDelta : CXTPTabManager
  • m_nScrollIndexV : CXTPGridSection
  • m_nScrollOffset : CXTPTaskPanelGroup
  • m_nScrollOffsetH : CXTPGridControl
  • m_nScrollOffsetV : CXTPGridSection
  • m_nScrollOffsetX : CXTPCalendarDayView
  • m_nScrollPos : CXTPControlGallery
  • m_nScrollPosTarget : CXTPControlGallery
  • m_nScrollStepH : CXTPGridControl
  • m_nScrollStepV : CXTPGridControl
  • m_nScrollXOffset : CXTPSyntaxEditDrawTextProcessor
  • m_nSearchDirection : CXTPSyntaxEditFindReplaceDlg
  • m_nSearchHistoryCountMax : CXTPSyntaxEditFindReplaceDlg
  • m_nSelButtonID : CXTPTaskDialog
  • m_nSelected : CXTPCommandBar, CXTPControlGallery, CXTPPropertyGridUpdateContext
  • m_nSelectOnDragOverDelay : CXTPTabPaintManager
  • m_nSelEnd : CXTPHexEdit
  • m_nSelRadioButtonID : CXTPTaskDialogClient
  • m_nSelStart : CXTPHexEdit
  • m_nSendQueueCacheSize : CXTPNotifyConnection
  • m_nSize : CXTPChartDiagram2DAxisView, CXTPChartMarker, CXTPChartRadarAxisXView, CXTPChartRadarAxisYView
  • m_nSizeFrameY : CXTPSystemMetrics
  • m_nSlideStep : CXTPDockingPaneMiniWnd, CXTPDockingPaneSidePanel
  • m_nSmallIconX : CXTPSystemMetrics
  • m_nSmallIconY : CXTPSystemMetrics
  • m_nSmoothingMode : CXTPFlowGraphControl
  • m_nSnapMargin : CXTPTrackControl
  • m_nSortDirection : CXTPChartLegend
  • m_nSortedCol : CXTPHeaderCtrl, CXTPListBase
  • m_nSortLocale : CXTPGridRecordItemVariant
  • m_nSortOrder : CXTPTagCloudCtrl
  • m_nSortPriority : CXTPGridRecordItem
  • m_nSpaceWidth : CXTPSyntaxEditDrawTextProcessor
  • m_nSpinIncrement : CXTPGridInplaceButton
  • m_nSpinMax : CXTPGridInplaceButton
  • m_nSpinMin : CXTPGridInplaceButton
  • m_nSpinStep : CXTPGridInplaceButton
  • m_nSplitButtonDropDownHeight : CXTPPaintManager
  • m_nSplitButtonDropDownWidth : CXTPPaintManager
  • m_nSplitButtonPopupWidth : CXTPPaintManager
  • m_nSplitterGap : CXTPDockingPaneManager
  • m_nSplitterHeight : CXTPPropertyGridPaintManager
  • m_nSplitterIndent : CXTPDockingPanePaintManager
  • m_nSplitterSize : CXTPDockingPanePaintManager, CXTPTabClientWnd
  • m_nStartChar : CXTPMaskEditT< TBase >
  • m_nStartReplacePos : CXTPSyntaxEditAutoCompleteWnd
  • m_nStartTagLen : CXTPSyntaxEditLexTextBlock
  • m_nState : CXTPCalendarCaptionBarThemePart, CXTPGridInplaceButton, CXTPGridRecordItemControl
  • m_nStateFlags : CXTPCommandBar
  • m_nStatusBarMinHeight : CXTPPaintManager
  • m_nStep : CXTPPopupControl
  • m_nStepsCount : CXTPDockingPaneMiniWnd, CXTPDockingPaneSidePanel
  • m_nStickyGap : CXTPDockingPaneManager
  • m_nStrLen : CXTPHeapString
  • m_nStyle : CXTPCheckListBox, CXTPFlowGraphConnection, CXTPFlowGraphConnectionPoint, CXTPFlowGraphNode, CXTPStatusBarPane
  • m_nSubMenuIndx : CXTPBrowseButton, CXTPBrowseEdit
  • m_nTabPositions : CXTPTipWindow
  • m_nTabsHeight : CXTPDockingPanePaintManager, CXTPRibbonPaintManager
  • m_nTabSize : CXTPSyntaxEditBufferManager, CXTPSyntaxEditDrawTextProcessor
  • m_nTag : CXTPControl, CXTPControlAction
  • m_nTearOffID : CXTPPopupBar
  • m_nTearOffTimer : CXTPPopupBar
  • m_nTearOffWidth : CXTPPopupBar
  • m_nTextFormat : CXTPTaskPanelItem
  • m_nTextHeight : CXTPPaintManager
  • m_nTextImageRelation : CXTPButton
  • m_nTextIndentForGroupRowsWithNoIcon : CXTPGridPaintManager
  • m_nTextLimit : CXTPControlComboBox, CXTPControlEdit
  • m_nTextOrientation : CXTPCommandBar
  • m_nTextPadding : CXTPListBox
  • m_nTheme : CXTPComboBoxThemeOfficeXPFlat, CXTPControlTheme, CXTPEditTheme, CXTPMarqueeCtrlPaintManager, CXTPProgressCtrlPaintManager, CXTPScrollBar, CXTPSpinButtonCtrl, CXTPTreeBase
  • m_nThickness : CXTPChart3dLineDeviceCommand, CXTPChartAxis, CXTPChartAxisTickMarks, CXTPChartBorder, CXTPChartLineDeviceCommand, CXTPChartLineStyle, CXTPChartPolylineDeviceCommand, CXTPChartSplineDeviceCommand
  • m_nThumbWidth : CXTPComboBoxTheme, CXTPControlComboBox
  • m_nTimeLineMax : CXTPTrackControl
  • m_nTimelineMaxPixelsForEvent : CXTPCalendarTimeLineView
  • m_nTimelineMaxPixelsForEvent_ScaleDay : CXTPCalendarTimeLineView
  • m_nTimelineMaxPixelsForEvent_ScaleWeek : CXTPCalendarTimeLineView
  • m_nTimeLineMin : CXTPTrackControl
  • m_nTimeLinePosition : CXTPTrackControl
  • m_nTimelineScale : CXTPCalendarControl
  • m_nTimerElapse : CXTPScrollBase
  • m_nTimerID : CXTPDatePickerControl
  • m_nTimerID_ShowToolTip : CXTPCalendarView, CXTPCalendarViewEvent
  • m_nTimerID_StartEditSubject : CXTPCalendarView
  • m_nTimeshift_min : CXTPCalendarDayViewTimeScale
  • m_nTitleHeight : CXTPDockingPanePaintManager
  • m_nTmpOffsetB : CXTPSyntaxEditTextIterator
  • m_nTmpOffsetC : CXTPSyntaxEditTextIterator
  • m_nTop : CXTPGridThickness
  • m_nTopCalculatedRow : CXTPSyntaxEditCtrl
  • m_nTopIndex : CXTPHexEdit, CXTPPropertyGridUpdateContext
  • m_nTopRow : CXTPSyntaxEditCtrl
  • m_nTotalHeight : CXTPControlGallery
  • m_nTrackColumnIndex : CXTPTrackControl
  • m_nTransparency : CXTPChartAreaSeriesStyle, CXTPChartRadarAreaSeriesStyle, CXTPChartSeriesLabel, CXTPChartSeriesStyle, CXTPPopupControl
  • m_nTreeColumnLineLength : CXTPGridPaintManager
  • m_nTreeIndent : CXTPGridPaintManager
  • m_nTreeStructureStyle : CXTPGridPaintManager
  • m_nTreeTextIndent : CXTPGridPaintManager
  • m_nTreeTextIndentGroupRow : CXTPGridPaintManager
  • m_nTreeTextIndentRowChildren : CXTPGridPaintManager
  • m_nTreeTextIndentRowParent : CXTPGridPaintManager
  • m_nType : CXTPChartMarker, CXTPFlowGraphConnectionPoint, CXTPGridRecordItemControl
  • m_nUndoContext : CXTPFlowGraphUndoManager, CXTPTrackUndoManager
  • m_nUseEnd : XTP_CALENDAR_PATTERN_END
  • m_nValue : CXTPMarkupGridLength, CXTPPropertyGridInplaceSlider, CXTPPropertyGridItemEnum, CXTPPropertyGridItemFlags, CXTPPropertyGridItemNumber, CXTPPropertyGridItemOption, CXTPStatusBarScrollBarPane, CXTPSyntaxEditLexVariant, XTP_CALENDAR_TIMELINE_VIEW_SCALE
  • m_nValueScaleType : CXTPChartSeries
  • m_nVarFlags : CXTPSyntaxEditLexVariable
  • m_nVarID : CXTPSyntaxEditLexVariable
  • m_nVerbsHeight : CXTPPropertyGridPaintManager
  • m_nVerticalAlignment : CXTPChartLegend, CXTPTrackBlock
  • m_nViewPortMax : CXTPTrackControl
  • m_nViewPortMin : CXTPTrackControl
  • m_nVirtualRecordsCount : CXTPGridRecords
  • m_nVirtualRowsCount : CXTPGridRows
  • m_nVisIndex : CXTPGridHeader
  • m_nVScrollPos : CXTPCalendarTimeLineView
  • m_nWeekDayIndex : CXTPCalendarMonthViewDay
  • m_nWeekIndex : CXTPCalendarMonthViewDay
  • m_nWeeklyInterval : CXTPCalendarEventRecurrenceDlg
  • m_nWeeksCount : CXTPCalendarMonthView::CMonthViewGrid
  • m_nWheelScroll : CXTPSyntaxEditCtrl
  • m_nWidth : CXTPChartTextPainterBase, CXTPControl, CXTPGridInplaceButton, CXTPPropertyGridInplaceControl
  • m_nWndHeight : CXTPSyntaxEditAutoCompleteWnd
  • m_nWndWidth : CXTPSyntaxEditAutoCompleteWnd
  • m_nWorkAreaMax : CXTPTrackControl
  • m_nWorkAreaMin : CXTPTrackControl
  • m_odtValue : CXTPGridRecordItemDateTime
  • m_oleDate : CXTPPropertyGridItemDate
  • m_oleValue : CXTPGridRecordItemVariant
  • m_OwnerUser : CXTPCalendarControl
  • m_p : CXTPChartPolylineDeviceCommand, CXTPChartSplineDeviceCommand
  • m_p1 : CXTPChart3dLineDeviceCommand, CXTPChartLineDeviceCommand
  • m_p2 : CXTPChart3dLineDeviceCommand, CXTPChartLineDeviceCommand
  • m_p3dPointView : CXTPChart3dFunnelSeriesLabelView, CXTPChart3dPieSeriesLabelView, CXTPChart3dPyramidSeriesLabelView
  • m_pAccelTable : CXTPShortcutManager
  • m_pAction : CXTPControl, CXTPControlGalleryItems
  • m_pActions : CXTPCommandBars, CXTPControlAction
  • m_pActiveGroup : CXTPTaskPanel
  • m_pActiveItem : CXTPGridControl
  • m_pActivePage : CXTPFlowGraphControl, CXTPPropertySheet
  • m_pActivePane : CXTPDockingPaneManager
  • m_pActiveWnd : CXTPDockingPaneAutoHidePanel
  • m_pActiveWorkspace : CXTPTabClientWnd
  • m_Page2 : CXTPSyntaxEditPropertiesDlg
  • m_Page3 : CXTPSyntaxEditPropertiesDlg
  • m_PageOffset : CXTPPreviewView
  • m_paintTheme : CXTPPopupControl, CXTPShortcutBar, CXTPTaskPanel
  • m_panelBehaviour : CXTPTaskPanel
  • m_pAnimation : CXTPCommandBar, CXTPShortcutBar, CXTPTaskPanel
  • m_pAppearance : CXTPChartContent
  • m_pAppearanceSet : CXTPTabPaintManager
  • m_parLexClassInfo : CXTPSyntaxEditPropertiesPageColor
  • m_pAutoComplete : CXTPSyntaxEditCtrl
  • m_pAutoCompleteWnd : CXTPControlComboBox, CXTPControlEdit
  • m_pAxis : CXTPChartAxisRange
  • m_pAxisAppearance : CXTPChartDiagram2DAppearance
  • m_pAxisViews : CXTPChartDiagram2DView, CXTPChartRadarDiagramView
  • m_pAxisX : CXTPChartRadarDiagram
  • m_pAxisY : CXTPChartRadarDiagram
  • m_pBar : CXTPDockContext
  • m_pBindBool : CXTPPropertyGridItemBool
  • m_pBindColor : CXTPPropertyGridItemColor
  • m_pBindDate : CXTPPropertyGridItemDate
  • m_pBindDouble : CXTPPropertyGridItemDouble
  • m_pBindEnum : CXTPPropertyGridItemEnum
  • m_pBindNumber : CXTPPropertyGridItemNumber
  • m_pBindOption : CXTPPropertyGridItemOption
  • m_pBindString : CXTPPropertyGridItem
  • m_pBits : CXTPImageManagerIconHandle, CXTPImageManagerResource, CXTPResourceImage
  • m_pBlock : CXTPTrackUndoAddBlockCommand, CXTPTrackUndoDeleteBlockCommand, CXTPTrackUndoSetBlockPositionCommand
  • m_pBoldFont : CXTPExcelTabCtrl
  • m_pBorder : CXTPChartAreaSeriesStyle, CXTPChartContent, CXTPChartLegend, CXTPChartPieSeriesStyleBase, CXTPChartRadarAreaSeriesStyle, CXTPChartSeriesLabel, CXTPGridRecordItem, CXTPGridSection
  • m_pBtnExpando : CXTPTaskDialogClient
  • m_pBtnVerify : CXTPTaskDialogClient
  • m_pBuffer : CXTPSyntaxEditCtrl
  • m_pBufferMgr : CXTPSyntaxEditBufferCommand
  • m_pButtonCaptured : CXTPDatePickerControl
  • m_pButtonHot : CXTPSkinObjectFrame
  • m_pButtonPressed : CXTPSkinObjectFrame
  • m_pButtonViewDay : CXTPCalendarCaptionBarTheme
  • m_pButtonViewMonth : CXTPCalendarCaptionBarTheme
  • m_pButtonViewWeek : CXTPCalendarCaptionBarTheme
  • m_pCalendar : CXTPCalendarCaptionBarTheme, CXTPCalendarRemindersDialog
  • m_pCalendarCtrl : CXTPCalendarController, CXTPCalendarEventColorDlg, CXTPCalendarResource
  • m_pCalendarOptions : CXTPCalendarData
  • m_pCallbackParam : CXTPDatePickerControl
  • m_pCaption : CXTPCaptionButton
  • m_pCaptionBar : CXTPCalendarCaptionBarTheme
  • m_pCaptionButtons : CXTPCommandBarsFrameHook, CXTPDockingPaneBase
  • m_pCaptionMetrics : CXTPPropertyGridItem
  • m_pCaptureView : CXTPChartControl
  • m_pCategories : CXTPCalendarEventCategoryComboBox, CXTPPropertyGridView
  • m_pCell : CXTPColorHex
  • m_pChildParent : CXTPCaptionPopupWnd
  • m_pChildren : CXTPCalendarTimeLineViewGroup, CXTPGridRecord
  • m_pChilds : CXTPGridRow, CXTPPropertyGridItem
  • m_pChildWnd : CXTPCaption, CXTPCaptionPopupWnd
  • m_pClassMap : CXTPSkinManager
  • m_pClipToBoundsProperty : CXTPMarkupUIElement
  • m_pColorDlg : CXTPColorSelectorCtrl
  • m_pColorSet : CXTPTabPaintManager
  • m_pColumn : CXTPGridHeaderDragWnd
  • m_pColumns : CXTPGridColumn, CXTPGridColumnOrder, CXTPGridControl, CXTPGridHeader
  • m_pComboBox : CXTPFontCtrlBase, CXTPShellTreeBase
  • m_pCommand : CXTPChartControl
  • m_pCommandBar : CXTPControlPopup, CXTPPreviewView
  • m_pCommandBars : CXTPCommandBar, CXTPCommandBarKeyboardTip, CXTPCommandBarList, CXTPCommandBarScrollBarCtrl, CXTPCommandBarsFrameHook, CXTPControlActions, CXTPControls, CXTPCustomizeCommandsListBox, CXTPCustomizeSheet, CXTPDockBar, CXTPMessageBar, CXTPRibbonCustomizePage, CXTPRibbonCustomizeQuickAccessPage, CXTPShortcutManager
  • m_pConfig : CXTPTaskDialogClient
  • m_pConnection : CXTPCalendarData, CXTPCalendarRemindersManager, CXTPDatePickerControl, CXTPFlowGraphUndoAddConnectionCommand, CXTPFlowGraphUndoDeleteConnectionCommand, CXTPFlowGraphUndoSetConnectionPositionCommand, CXTPGridDataManager, CXTPResourceImages, CXTPSyntaxEditBufferManager
  • m_pConnectionPoint : CXTPFlowGraphUndoAddConnectionPointCommand, CXTPFlowGraphUndoDeleteConnectionPointCommand
  • m_pConnectionPoints : CXTPFlowGraphNode
  • m_pConnections : CXTPFlowGraphPage
  • m_pConstantLines : CXTPChartAxis
  • m_pConstraints : CXTPGridRecordItemEditOptions, CXTPPropertyGridItem
  • m_pContainer : CXTPChartDeviceContext, CXTPChartElementView, CXTPPropExchangeEnumerator
  • m_pContent : CXTPChartContentView, CXTPChartControl
  • m_pContentAppearance : CXTPChartAppearance
  • m_pContentView : CXTPChartControl
  • m_pContext : CXTPDockingPaneContextStickerWnd, CXTPToolTipContextToolTip
  • m_pContextHeader : CXTPRibbonTab
  • m_pContextHeaders : CXTPRibbonBar
  • m_pContextMenu : CXTPCustomizeMenusPage, CXTPCustomizeSheet, CXTPMiniToolBar
  • m_pContextMenus : CXTPCommandBars
  • m_pControl : CXTPCalendarPaintManager, CXTPCalendarView, CXTPControlComboBoxEditCtrl, CXTPControlEditCtrl, CXTPControlSliderCtrl, CXTPDatePickerDaysCollection, CXTPDatePickerItemDay, CXTPDatePickerItemMonth, CXTPDatePickerList, CXTPFlowGraphPage, CXTPFlowGraphPageHistory, CXTPFlowGraphPages, CXTPGridColumns, CXTPGridControl::CUpdateContext, CXTPGridHeader, CXTPGridPaintManager, CXTPGridRecord, CXTPGridRecordItem, CXTPGridRecords, CXTPGridRow, CXTPGridSection, CXTPGridSections, CXTPPopupItem, CXTPTrackMarker, CXTPTrackMarkers
  • m_pControlGroupOption : CXTPRibbonGroup
  • m_pControlGroupPopup : CXTPRibbonGroup
  • m_pControlPopup : CXTPPopupBar
  • m_pControlQuickAccess : CXTPRibbonBar
  • m_pControlQuickAccessMore : CXTPRibbonBar
  • m_pControls : CXTPCommandBar, CXTPControl, CXTPMenuBarMDIMenuInfo
  • m_pControlSystemButton : CXTPRibbonBar
  • m_pControlTab : CXTPRibbonBar
  • m_pcsActive : CXTPDockingPaneVisualStudio2012Theme
  • m_pcsInactive : CXTPDockingPaneVisualStudio2012Theme
  • m_pcszString : CXTPHeapString
  • m_pCurSel : CXTPTagCloudCtrl
  • m_pCustomIcons : CXTPCustomizeSheet
  • m_pCustomIconsIDs : CXTPCalendarEvent
  • m_pCustomLabels : CXTPChartAxis
  • m_pCustomProperties : CXTPCalendarData, CXTPCalendarEvent, CXTPCalendarSchedule
  • m_pData : CXTPCalendarEventColorListBox, CXTPHexEdit, CXTPSyntaxEditTextIterator
  • m_pDataManager : CXTPGridControl
  • m_pDataProvider : CXTPCalendarEvent, CXTPCalendarOptions, CXTPCalendarResource
  • m_pDataSource : CXTPGridDataManager
  • m_pDateLabel : CXTPCalendarCaptionBarTheme
  • m_pDatePickerCtrl : CXTPCalendarController
  • m_pDayView : CXTPCalendarDayViewTimeScale
  • m_pDC : CXTPCalendarShadowDrawer
  • m_pdc : CXTPResourceImages
  • m_pDeleteRecords : CXTPGridDataManager
  • m_pDesignerControls : CXTPCommandBars
  • m_pDiagram : CXTPChartAxis, CXTPChartDiagramView, CXTPChartSeries
  • m_pDiagram2DAppearance : CXTPChartAppearance
  • m_pDiagram3DAppearance : CXTPChartAppearance
  • m_pDiagramView : CXTPChartContentView
  • m_pDirThread : CXTPShellListBase
  • m_pDisplayOptions : CXTPGridColumn
  • m_pDockBar : CXTPToolBar
  • m_pDockBarClass : CXTPCommandBars
  • m_pDockContext : CXTPToolBar
  • m_pDockingContext : CXTPDockingPaneManager
  • m_pDockingSite : CXTPDockingPaneBase
  • m_pDocks : CXTPCommandBars
  • m_pDomain : CXTPChartFunnelSeriesViewBase, CXTPChartPyramidSeriesViewBase
  • m_pDragColumn : CXTPGridHeader
  • m_pDragSelected : CXTPCommandBars
  • m_pDragWnd : CXTPGridHeader, CXTPGridSubListControl
  • m_pDrawingObjectFactory : CXTPChartDeviceContext
  • m_pDrawTextProcessor : CXTPSyntaxEditCtrl
  • m_pDrawThread : CXTPChartControl
  • m_pDropRecords : CXTPGridControl
  • m_pDropSource : CXTPCommandBars
  • m_pDropTarget : CXTPDockingPaneTabbedContainer, CXTPGridControl, CXTPTaskPanel
  • m_pEdit : CXTPControlComboBox, CXTPControlEdit
  • m_pEditCtrl : CXTPSyntaxEditFindReplaceDlg, CXTPSyntaxEditGoToLineDlg, CXTPSyntaxEditView
  • m_pEditOptions : CXTPGridColumn, CXTPGridRecordItem
  • m_pEditView : CXTPSyntaxEditPropertiesPageColor, CXTPSyntaxEditPropertiesPageEdit, CXTPSyntaxEditPropertiesPageFont
  • m_pEditWnd : CXTPBrowseButton
  • m_pElement : CXTPChartHitTestElementCommand, CXTPFlowGraphEditItem
  • m_penGray : CXTPSyntaxEditPaintManager
  • m_pErrorBar : CXTPChartSeriesStyle
  • m_pEvent : CXTPCalendarEventColorDlg, CXTPCalendarEventColorListBox
  • m_pEventCategories : CXTPCalendarData
  • m_pEventCategoryIDs : CXTPCalendarEvent
  • m_pEventDataProvider : CXTPCalendarReminder
  • m_pExpandButton : CXTPCalendarCaptionBarTheme
  • m_pExpandIcon : CXTPShortcutBarPaintManager
  • m_pExpandSigns : CXTPCalendarPaintManager
  • m_pExtendedColors : CXTPColorPicker, CXTPColorSelectorCtrl
  • m_pFileDialog : CXTPBrowseEdit
  • m_pFillStyle : CXTPChartAreaSeriesStyle, CXTPChartAxisStrip, CXTPChartLegend, CXTPChartRadarAreaSeriesStyle
  • m_pFilterEdit : CXTPGridHeader
  • m_pFinanceStyleAppearance : CXTPChartAppearance
  • m_pFindReplaceDlg : CXTPSyntaxEditView
  • m_pFirstVisibleConnection : CXTPFlowGraphPage
  • m_pFirstVisibleNode : CXTPFlowGraphPage
  • m_pfnCallback : CXTPDatePickerControl
  • m_pfnCompare : CXTPSortClass
  • m_pfnSetLayeredWindowAttributes : CXTPDockingPaneContext, CXTPDockingPaneManager, CXTPMiniToolBar, CXTPPaintManager
  • m_pfnUpdateLayeredWindow : CXTPMiniToolBar
  • m_pFocusableProperty : CXTPMarkupUIElement
  • m_pFocusedButton : CXTPPropertyGridView
  • m_pFocusedColumn : CXTPGridControl
  • m_pFocusedItemControl : CXTPGridRecordItem
  • m_pFont : CXTPCalendarTip, CXTPChartAxisConstantLine, CXTPChartAxisLabel, CXTPChartAxisTitle, CXTPChartLegend, CXTPChartMarkupElementDeviceCommand, CXTPChartSeriesLabel, CXTPChartTextDeviceCommand, CXTPChartTitle
  • m_pFontCaption : CXTPGridRecordItem
  • m_pFontTip : CXTPTipOfTheDay
  • m_pFontTitle : CXTPTipOfTheDay
  • m_pFrame : CXTPCommandBars, CXTPSkinObjectFrame::CCaptionButton
  • m_pFrameHook : CXTPCommandBars
  • m_pFramePaintManager : CXTPPaintManager
  • m_pGalleryPaintManager : CXTPPaintManager
  • m_pGlyphs : CXTPCalendarPaintManager, CXTPGridPaintManager
  • m_pGlyphsFont : CXTPCalendarPaintManager
  • m_pGrid : CXTPCalendarMonthView, CXTPGridView, CXTPPropertyGridInplaceEdit, CXTPPropertyGridItem, CXTPPropertyGridPaintManager, CXTPPropertyGridToolTip, CXTPPropertyGridVerbs, CXTPPropertyGridView
  • m_pGridControl : CXTPGridDataManager, CXTPGridNavigator, CXTPGridTip
  • m_pGridCtrl : CXTPGridFilterEditControl, CXTPGridSubListControl
  • m_pGridHeader : CXTPGridControl
  • m_pGridLines : CXTPChartAxis
  • m_pGroup : CXTPCalendarTimeLineViewEvent, CXTPFlowGraphNode
  • m_pGroups : CXTPCalendarTimeLineView, CXTPFlowGraphNodeGroup, CXTPFlowGraphPage, CXTPRibbonGroup, CXTPRibbonTab, CXTPTaskPanel
  • m_pGroupsOrder : CXTPGridColumns
  • m_pHeader : CXTPGridHeaderDragWnd
  • m_pHighlighted : CXTPShortcutBarPane, CXTPStatusBarSwitchPane, CXTPTabManager
  • m_pHighlightedNavigateButton : CXTPTabManager
  • m_pHighlightedPane : CXTPStatusBar
  • m_pHistory : CXTPFlowGraphControl
  • m_pHotButton : CXTPMessageBar, CXTPPropertyGridView
  • m_pHotExpandButtonRow : CXTPGridControl
  • m_pHotHyperlink : CXTPGridControl
  • m_pHotItem : CXTPShortcutBar
  • m_pHotRow : CXTPGridControl
  • m_pHotTrackingColumn : CXTPGridHeader
  • m_pHover : CXTPTagCloudCtrl
  • m_pHyperlinkHoverStyle : CXTPGridPaintManager
  • m_pHyperlinks : CXTPGridRecordItem
  • m_pHyperlinkStyle : CXTPGridPaintManager
  • m_pIcon : CXTPButton, CXTPFlowGraphImage, CXTPShortcutListBox::CONTENT_ITEM, CXTPToolTipContextToolTip
  • m_pIcons : CXTPRibbonControlSystemPopupBarPinableListItem
  • m_pidlINet : CXTPShellListBase
  • m_pImage : CXTPFlowGraphImage
  • m_pImageManager : CXTPCommandBar, CXTPCommandBars, CXTPControlGalleryItems, CXTPDockingPaneManager, CXTPFlowGraphImages, CXTPGridControl, CXTPHeaderCtrl, CXTPImageManagerIconHandle, CXTPImageManagerResource, CXTPPopupControl, CXTPPropertyGrid, CXTPShortcutBar, CXTPSyntaxEditAutoCompleteWnd, CXTPTaskPanel
  • m_pImages : CXTPCommandBarsModernUITheme, CXTPFlowGraphControl, CXTPResourceImage, CXTPSkinManagerClass
  • m_pImmWrapper : CXTPSyntaxEditCtrl
  • m_pIniFile : CXTPSkinManagerResourceFile
  • m_pInlines : CXTPMarkupTextBlock
  • m_pInplaceButtons : CXTPGridControl, CXTPPropertyGridItem
  • m_pInplaceControls : CXTPPropertyGridItem
  • m_pInplaceEdit : CXTPGridControl, CXTPPropertyGrid
  • m_pInplaceList : CXTPGridControl
  • m_pInplaceListBox : CXTPPropertyGrid
  • m_pInputPoint : CXTPFlowGraphConnection
  • m_pInterlacedFillStyle : CXTPChartAxis
  • m_pIsEnabledProperty : CXTPMarkupUIElement
  • m_pItem : CXTPGridTip, CXTPPropertyGridInplaceControl, CXTPPropertyGridInplaceEdit, CXTPPropertyGridInplaceMonthCal, CXTPPropertyGridItemConstraint, CXTPTabManagerNavigateButton, CXTPTrackBlock
  • m_pItemControlHookWnd : CXTPGridRecordItem
  • m_pItemControls : CXTPGridRecordItem
  • m_pItemDragging : CXTPTaskPanel
  • m_pItemDragOver : CXTPTaskPanel
  • m_pItemEdit : CXTPEditListBox
  • m_pItemFocused : CXTPTaskPanel
  • m_pItemHot : CXTPTaskPanel
  • m_pItemPressed : CXTPTaskPanel
  • m_pItems : CXTPControlGalleryItem, CXTPTaskPanelGroup, CXTPTaskPanelItem
  • m_pKeyboardManager : CXTPCommandBars
  • m_pKeyNameText : CXTPShortcutManager
  • m_pLabel : CXTPChartAxis, CXTPChartSeriesStyle
  • m_pLabelList : CXTPCalendarData
  • m_pLabelsView : CXTPChartDiagramView
  • m_pLanguageInfo : CXTPResourceManager
  • m_pLastActiveView : CXTPTabExBase
  • m_pLastEvent : CXTPCalendarView
  • m_pLastStickerPane : CXTPDockingPaneContext
  • m_pLayerBits : CXTPResourceImages
  • m_pLayout : CXTPDockingPaneBase, CXTPDockingPaneManager
  • m_pLegend : CXTPChartContent, CXTPChartLegendView
  • m_pLegendAppearance : CXTPChartContentAppearance
  • m_pLegendItem : CXTPChartSeries
  • m_pLegendView : CXTPChartContentView
  • m_pLexParser : CXTPSyntaxEditBufferManager
  • m_pLightBulbIcon : CXTPTipOfTheDay
  • m_pLineMarksManager : CXTPSyntaxEditBufferManager
  • m_pLineStyle : CXTPChartAxisConstantLine, CXTPChartAxisGridLines, CXTPChartFastLineSeriesStyle, CXTPChartLineSeriesStyle
  • m_pListBox : CXTPControlListBox, CXTPFontCtrlBase, CXTPSyntaxEditTipWnd
  • m_pListControl : CXTPDatePickerControl
  • m_pListCtrl : CXTPListBase, CXTPShellTreeCtrl, CXTPSortClass
  • m_pManager : CXTPDockingPaneContext, CXTPFlowGraphUndoGroupCommand, CXTPShortcutManagerAccelTable, CXTPSkinManagerResourceFile, CXTPSkinManagerSchema, CXTPSkinObject, CXTPTabManagerNavigateButton, CXTPTrackUndoGroupCommand
  • m_pMarker : CXTPTrackUndoAddMarkerCommand, CXTPTrackUndoDeleteMarkerCommand, CXTPTrackUndoSetMarkerPositionCommand
  • m_pMarkers : CXTPTrackControl
  • m_pMarkup : CXTPFlowGraphNode
  • m_pMarkupCaption : CXTPPropertyGridItem
  • m_pMarkupContext : CXTPButton, CXTPCalendarControl, CXTPChartContent, CXTPComboBox, CXTPCommandBarsModernUITheme, CXTPFlowGraphControl, CXTPFrameThemeOffice2007System, CXTPGridControl, CXTPGridRecords, CXTPGridSection, CXTPMessageBar, CXTPPopupControl, CXTPPropertyGrid, CXTPRibbonMarkupTheme, CXTPStatusBar, CXTPTabClientWnd, CXTPTabManager, CXTPTaskDialogClient, CXTPTaskPanel, CXTPTipOfTheDay
  • m_pMarkupDescription : CXTPPropertyGridItem
  • m_pMarkupTipText : CXTPTipOfTheDay
  • m_pMarkupUIElement : CXTPChartMarkupElementDeviceCommand, CXTPControlMarkupLabel, CXTPGridColumn, CXTPGridGroupRow, CXTPGridRecordItem, CXTPMarkupThemePart, CXTPStatusBarPane, CXTPTabManagerItem, CXTPTaskPanelItem
  • m_pMarkupUIElement_NoGroupBy : CXTPGridPaintManager
  • m_pMarkupValue : CXTPPropertyGridItem
  • m_pMasterView : CXTPCalendarViewEvent
  • m_pMDIClientWnd : CXTPMDIWndTab
  • m_pMDIFrameWnd : CXTPMDIWndTab, CXTPWindowList
  • m_pMDIMenus : CXTPMenuBar
  • m_pMDIWndTab : CXTPMDIClientWnd
  • m_pMenuBar : CXTPMenuBarMDIMenus
  • m_pMenuBarClass : CXTPCommandBars
  • m_pMenuTitleBar : CXTPCommandBarsFrameHook
  • m_pMenuTitleBarClass : CXTPCommandBars
  • m_pMetrics : CXTPPropertyGridPaintManager, CXTPSkinManagerSchema
  • m_pMinorLineStyle : CXTPChartAxisGridLines
  • m_pModuleContext : CXTPToolTipContext
  • m_pMonth : CXTPDatePickerItemDay
  • m_pMouseManager : CXTPCommandBars
  • m_pNavBtns : CXTPTabBase
  • m_pNavigator : CXTPGridControl, CXTPPropertySheet
  • m_pNextVisibleConnection : CXTPFlowGraphConnection
  • m_pNextVisibleNode : CXTPFlowGraphNode
  • m_pNode : CXTPFlowGraphConnectionPoint, CXTPFlowGraphConnectionPoints, CXTPFlowGraphUndoAddNodeCommand, CXTPFlowGraphUndoDeleteConnectionPointCommand, CXTPFlowGraphUndoDeleteNodeCommand, CXTPFlowGraphUndoSetNodeCaptionCommand, CXTPFlowGraphUndoSetNodePositionCommand, CXTPFlowGraphUndoSetNodeSizeCommand
  • m_pNodes : CXTPFlowGraphPage
  • m_pNormFont : CXTPExcelTabCtrl
  • m_pnTabStopPositions : CXTPTipWindow
  • m_pObject : CXTPSmartPtrInternalT< _TObject >
  • m_point : CXTPColorSelectorCtrl, CXTPShortcutListBox, CXTPSplitterWnd
  • m_points : CXTPChartBoundedPolygonDeviceCommand, CXTPChartPolygonDeviceCommand
  • m_pointTipOffsetPos : CXTPTipWindow
  • m_pOldItem : CXTPTrackUndoDeleteBlockCommand
  • m_pOldWndProc : CXTPSkinObject
  • m_pOpacityProperty : CXTPMarkupUIElement
  • m_pOptions : CXTPCalendarPageSetupDialog, CXTPCommandBars, CXTPGridPageSetupDialog
  • m_popupAnimation : CXTPPopupControl
  • m_popupFlags : CXTPPopupBar
  • m_popupMenuID : CXTPHeaderCtrl, CXTPMDIWndTab, CXTPTabExBase
  • m_popupState : CXTPPopupControl
  • m_pOriginalAccelTable : CXTPShortcutManager
  • m_pOriginalControls : CXTPControls
  • m_pOriginalWindowProc : CXTPFlowGraphNode
  • m_posEnd : CXTPSyntaxEditTextRegion
  • m_PosEndLC : CXTPSyntaxEditLexTextBlock
  • m_posFirstUndo : CXTPSyntaxEditUndoRedoManager
  • m_posSavedMark : CXTPSyntaxEditUndoRedoManager
  • m_posStart : CXTPSyntaxEditTextRegion
  • m_PosStartLC : CXTPSyntaxEditLexTextBlock
  • m_pOutputPoint : CXTPFlowGraphConnection
  • m_pOwner : CXTPCalendarViewEventSubjectEditor, CXTPChartFillStyle, CXTPChartLineStyle, CXTPCommandBar, CXTPCommandBarKeyboardTip, CXTPPropExchange, CXTPTaskPanelItems
  • m_pOwnerRecord : CXTPGridRecords
  • m_pOwnerWnd : CXTPCalendarEventPropertiesDlg
  • m_pPage : CXTPFlowGraphConnection, CXTPFlowGraphConnections, CXTPFlowGraphNode, CXTPFlowGraphNodeGroups, CXTPFlowGraphNodes, CXTPFlowGraphSelectedElements, CXTPFlowGraphUndoDeleteConnectionCommand, CXTPFlowGraphUndoDeleteNodeCommand
  • m_pPageCommands : CXTPCustomizeSheet
  • m_pPageInfo2 : CXTPPreviewView
  • m_pPages : CXTPFlowGraphControl
  • m_pPageToolBars : CXTPCustomizeSheet
  • m_pPaintManager : CXTPCalendarViewPart, CXTPCommandBar, CXTPCommandBars, CXTPCommandBarsFrameHook, CXTPDatePickerControl, CXTPDockingPaneManager, CXTPFlowGraphControl, CXTPFramePaintManager, CXTPGridControl, CXTPGridHeaderDragWnd, CXTPMarqueeCtrl, CXTPMessageBarPaintManager, CXTPPopupControl, CXTPProgressCtrl, CXTPProgressPaintManager, CXTPPropertyGrid, CXTPPropertyGridItemMetrics, CXTPRibbonPaintManager, CXTPShortcutBar, CXTPTabClientWnd, CXTPTabPaintManagerColorSet, CXTPTabPaintManagerTheme, CXTPTaskPanel
  • m_pPaintManeger : CXTPSyntaxEditCtrl
  • m_pPalette : CXTPChartAppearance
  • m_pPane : CXTPChartDiagram2D, CXTPDockingPaneCaptionButton, CXTPDockingPaneContext, CXTPShortcutBarPaneItem
  • m_pPanel : CXTPTaskPanelItem, CXTPTaskPanelItems
  • m_pPanelPaintManager : CXTPDockingPanePaintManager
  • m_pPanels : CXTPChartContent
  • m_pPaneView : CXTPChartDiagram2DView
  • m_pParent : CXTPControl, CXTPControls, CXTPFlowGraphImage, CXTPPropertyGridItem, CXTPRibbonGroup, CXTPRibbonTab
  • m_pParentContainer : CXTPDockingPaneBase
  • m_pParentFrame : CXTPTabClientWnd, CXTPTabExBase
  • m_pParentGroup : CXTPCalendarTimeLineViewGroup
  • m_pParentPart : CXTPCalendarViewPart
  • m_pParentRow : CXTPGridRow
  • m_pParentRows : CXTPGridRow
  • m_pParentSheet : CXTPColorPageCustom, CXTPColorPageStandard
  • m_pParentTab : CXTPRibbonGroups
  • m_pParentView : CXTPCalendarTimeLineViewTimeScale, CXTPCaption, CXTPChartElementView
  • m_pParentWnd : CXTPCalendarTip, CXTPCaptionPopupWnd, CXTPColorSelectorCtrl, CXTPEditListBox, CXTPGridTip, CXTPSyntaxEditAutoCompleteWnd, CXTPSyntaxEditCtrl, CXTPSyntaxEditToolTipCtrl, CXTPTabExBase, CXTPTipWindow
  • m_pPath : CXTPFlowGraphConnection
  • m_pPieStyleAppearance : CXTPChartAppearance
  • m_pPoint : CXTPChartSeriesPointView
  • m_pPointLegendFormat : CXTPChartSeries
  • m_pPoints : CXTPChartSeries
  • m_pPopupBar : CXTPDialogBar
  • m_pPopupBarClass : CXTPCommandBars
  • m_pPopupToolBarClass : CXTPCommandBars
  • m_pPopupWnd : CXTPCaption
  • m_pPressed : CXTPPopupControl, CXTPTabManager
  • m_pPressedItem : CXTPShortcutBar
  • m_pPrevGroupsOrder : CXTPGridControl
  • m_pPreviewItem : CXTPGridRecord
  • m_pPreviewLayout : CXTPDockingPaneManager
  • m_pPrevUndoBuffer : CXTPCalendarView
  • m_pPrevVisible : CXTPGridControl
  • m_pPrintOptions : CXTPCalendarControlView, CXTPGridView, CXTPSyntaxEditView
  • m_pProgressPaintManager : CXTPPaintManager
  • m_pPropertyAngle : CXTPMarkupRotateTransform
  • m_pPropertyAngleX : CXTPMarkupSkewTransform
  • m_pPropertyAngleY : CXTPMarkupSkewTransform
  • m_pPropertyCenterX : CXTPMarkupRotateTransform, CXTPMarkupScaleTransform, CXTPMarkupSkewTransform
  • m_pPropertyCenterY : CXTPMarkupRotateTransform, CXTPMarkupScaleTransform, CXTPMarkupSkewTransform
  • m_pPropertyScaleX : CXTPMarkupScaleTransform
  • m_pPropertyScaleY : CXTPMarkupScaleTransform
  • m_pPropertyX : CXTPMarkupTranslateTransform
  • m_pPropertyY : CXTPMarkupTranslateTransform
  • m_pQuickAccessControls : CXTPRibbonBar
  • m_pRange : CXTPChartAxis
  • m_pRecord : CXTPGridRecordItem, CXTPGridRow
  • m_pRecordItem : CXTPGridRecordItemControls
  • m_pRecords : CXTPGridRecord, CXTPGridSection
  • m_pRegExp : CXTPEdit
  • m_pRemindersMan : CXTPCalendarRemindersDialog
  • m_pRemindersManager : CXTPCalendarControl
  • m_pRenderTransformOriginProperty : CXTPMarkupUIElement
  • m_pRenderTransformProperty : CXTPMarkupUIElement
  • m_pResizeColumn : CXTPGridHeader
  • m_pResourceFile : CXTPSkinManager, CXTPSkinManagerSchema
  • m_pResources : CXTPCalendarView, CXTPCalendarViewDay, CXTPCalendarViewGroup
  • m_pResourcesNf : CXTPCalendarRemindersManager
  • m_pReturnCmd : CXTPCommandBar
  • m_pRibbonBar : CXTPCommandBarsFrameHook, CXTPRibbonGroup, CXTPRibbonTab, CXTPRibbonTabPopupToolBar
  • m_pRibbonGroup : CXTPControl
  • m_pRibbonPaintManager : CXTPPaintManager
  • m_pRibbonTab : CXTPRibbonTabPopupToolBar
  • m_pRichRender : CXTPPopupItem
  • m_pRInfo : CXTPImageManagerIconHandle
  • m_PrintPageWidth : CXTPCalendarPaintManager, CXTPGridPaintManager
  • m_properetySort : CXTPPropertyGridView
  • m_propertySort : CXTPPropertyGridUpdateContext
  • m_pRowIndexer : CXTPTabManager
  • m_pRows : CXTPGridControl, CXTPGridSection
  • m_pRowsCompareFunc : CXTPGridControl
  • m_pRstEvent : CXTPGridDataManager
  • m_pSBTrack : CXTPScrollBase, CXTPSkinObjectFrame
  • m_pScaleTypeMap : CXTPChartAxis
  • m_pSchedules : CXTPCalendarData
  • m_pSchema : CXTPSkinManager, CXTPSkinManagerClass, CXTPSkinManagerMetrics
  • m_pScreenRows : CXTPGridRows
  • m_pScrollBarHor : CXTPGridView
  • m_pScrollBarPaintManager : CXTPPaintManager
  • m_pScrollBarVer : CXTPGridView
  • m_pScrollButton : CXTPTaskPanel
  • m_pScrollNextDate : CXTPCalendarCaptionBarTheme
  • m_pScrollPrevDate : CXTPCalendarCaptionBarTheme
  • m_pSection : CXTPGridRow
  • m_pSelected : CXTPCommandBarsFrameHook, CXTPPopupControl, CXTPPropertyGridView, CXTPTabManager
  • m_pSelectedBlocks : CXTPTrackControl
  • m_pSelectedConstraint : CXTPGridInplaceEdit
  • m_pSelectedDays : CXTPDatePickerControl
  • m_pSelectedElements : CXTPFlowGraphPage
  • m_pSelectedEvents : CXTPCalendarView
  • m_pSelectedItem : CXTPShortcutBar
  • m_pSelectedPane : CXTPDockingPaneTabbedContainer
  • m_pSelectedRows : CXTPGridControl
  • m_pSelectedRowsBeforeDrag : CXTPGridControl
  • m_pSelection : CXTPSyntaxEditCtrl
  • m_pSeries : CXTPChartContent
  • m_pSeriesLabelsView : CXTPChart3dFunnelSeriesLabelsViewDeviceCommand, CXTPChart3dPieSeriesLabelsViewDeviceCommand
  • m_pSeriesView : CXTPChartDiagramView
  • m_pSetWindowTheme : CXTPSkinManager
  • m_pSetWinEventHook : CXTPSkinManager
  • m_psh : CXTPPropertySheet
  • m_pShadow : CXTPCommandBarsFrameHook
  • m_pShadowManager : CXTPColorPopup, CXTPPaintManager
  • m_pSheet : CXTPCustomizeCommandsPage, CXTPCustomizeKeyboardPage, CXTPCustomizeMenusPage, CXTPCustomizeOptionsPage, CXTPCustomizeToolbarsPage, CXTPPropertyPage, CXTPPropertyPageNavigator, CXTPRibbonCustomizePage, CXTPRibbonCustomizeQuickAccessPage
  • m_pShortcutBar : CXTPShortcutBarItem, CXTPShortcutBarPane
  • m_pShortcutManager : CXTPCommandBars
  • m_pShowFullWeek : CXTPCalendarCaptionBarTheme
  • m_pShowMcWeek : CXTPCalendarCaptionBarTheme
  • m_pShowTimeline : CXTPCalendarCaptionBarTheme
  • m_pShowWorkWeek : CXTPCalendarCaptionBarTheme
  • m_pSite : CXTPCommandBar, CXTPDockingPaneManager
  • m_pSliderCtrl : CXTPControlSlider
  • m_pSliderPaintManager : CXTPPaintManager
  • m_pSortOrder : CXTPGridColumns
  • m_pSplitterWnd : CXTPCaption
  • m_pStatusBar : CXTPStatusBarPane
  • m_pStatusBarPaintManager : CXTPPaintManager
  • m_pStickerPane : CXTPDockingPaneContext
  • m_pStorage : CXTPChartQualitativeScaleTypeMap
  • m_pStream : CXTPTipOfTheDay
  • m_pStrips : CXTPChartAxis
  • m_pStyle : CXTPChartSeries
  • m_pSubjectEditor : CXTPCalendarViewEvent
  • m_pSubList : CXTPGridHeader
  • m_pSyncWnd : CXTPShellListCtrlEx
  • m_pt : CXTPCommandBarKeyboardTip, CXTPHeaderCtrl
  • m_pTabCtrl : CXTPTabBase
  • m_pTabManager : CXTPTabManagerItem
  • m_pTabPaintManager : CXTPDockingPanePaintManager, CXTPRibbonPaintManager, CXTPTabToolBar
  • m_pTabWorkspace : CXTPTabClientWnd
  • m_pTarget : CXTPControlAction
  • m_pTaskPanel : CXTPTaskPanel::CRepositionContext
  • m_ptBasePoint : CXTPChartRotatedTextPainterBase
  • m_ptBend : CXTPChart3dFunnelSeriesLabelView, CXTPChart3dPieSeriesLabelView, CXTPChart3dPyramidSeriesLabelView
  • m_ptBorder : CXTPTaskDialogClient
  • m_ptBtnSpacing : CXTPTaskDialogClient
  • m_ptCenter : CXTPChartEllipse, CXTPChartPieDeviceCommandImpl
  • m_ptClick : CXTPPropertyGridVerb
  • m_ptContextMenu : CXTPCustomizeMenusPage
  • m_ptControlPoint : CXTPFlowGraphConnection
  • m_ptCursor : CXTPSyntaxEditTipWnd
  • m_ptDrag : CXTPGridControl
  • m_ptDropPos : CXTPSyntaxEditCtrl
  • m_pTearOffBar : CXTPPopupBar
  • m_ptEditPos : CXTPHexEdit
  • m_ptEnd : CXTPChart3dFunnelSeriesLabelView, CXTPChart3dPieSeriesLabelView, CXTPChart3dPyramidSeriesLabelView
  • m_pTextProvider : CXTPChartTextPainterBase
  • m_pTextSchemesMgr : CXTPSyntaxEditPropertiesPageColor
  • m_pTheme : CXTPButton, CXTPCalendarCaptionBarControl, CXTPCalendarCaptionBarPaintManager, CXTPCalendarCaptionBarThemePart, CXTPCalendarTip, CXTPCaption, CXTPColorSelectorCtrl, CXTPComboBox, CXTPEdit, CXTPExcelTabCtrl, CXTPHeaderCtrl, CXTPListBox, CXTPShortcutListBox, CXTPSplitterWnd, CXTPTabBase
  • m_pTickMarks : CXTPChartAxis
  • m_pTicks : CXTPScrollBase
  • m_pTimeScale : CXTPCalendarTimeLineView
  • m_pTimeScaleParams : CXTPCalendarTimeLineViewTimeScale
  • m_ptInputPoint : CXTPFlowGraphConnection
  • m_pTip : CXTPGridControl
  • m_pTitle : CXTPChartAxis
  • m_pTitleAppearance : CXTPChartContentAppearance
  • m_pTitles : CXTPChartContent
  • m_pTitlesView : CXTPChartContentView, CXTPChartDiagramView
  • m_ptLabelAnchor : CXTPChart3dFunnelSeriesLabelView, CXTPChart3dPieSeriesLabelView, CXTPChart3dPyramidSeriesLabelView
  • m_ptLabelAnchorOrigin : CXTPChart3dFunnelSeriesLabelView, CXTPChart3dPieSeriesLabelView, CXTPChart3dPyramidSeriesLabelView
  • m_ptLast : CXTPDockContext, CXTPDockingPaneContext
  • m_ptLightPosition : CXTPChart3dDeviceContext
  • m_ptLocation : CXTPFlowGraphNode
  • m_ptMargin : CXTPTaskDialogClient
  • m_ptMaxTrackSize : CXTPDockingPane
  • m_ptMinClientSize : CXTPDockingPaneManager
  • m_ptMinTrackSize : CXTPDockingPane
  • m_ptMouse : CXTPFlowGraphControl, CXTPGridHeader
  • m_ptMousePos : CXTPColorBase, CXTPTipWindow
  • m_ptMRUFloatPos : CXTPDockContext
  • m_ptNextPrintPos : CXTPSyntaxEditDrawTextProcessor
  • m_ptOffset : CXTPPopupItem
  • m_ptOldPosition : CXTPFlowGraphUndoSetConnectionPositionCommand, CXTPFlowGraphUndoSetNodePositionCommand
  • m_pToolBarClass : CXTPCommandBars
  • m_pToolTip : CXTPSyntaxEditCtrl, CXTPToolTipContext
  • m_pToolTipContext : CXTPButton, CXTPChartControl, CXTPCommandBar, CXTPCommandBars, CXTPDockingPaneManager, CXTPFlowGraphControl, CXTPGridControl, CXTPPropertyGrid, CXTPShortcutBar, CXTPTabClientWnd, CXTPTaskPanel
  • m_pTopContainer : CXTPDockingPaneMiniWnd
  • m_ptOutputPoint : CXTPFlowGraphConnection
  • m_ptPadding : CXTPTaskDialogClient
  • m_ptPopup : CXTPPopupBar, CXTPPopupControl
  • m_ptPressed : CXTPControlGallery, CXTPTaskPanel
  • m_ptPrevMouse : CXTPSyntaxEditCtrl
  • m_pTrackingPane : CXTPDockingPaneTabbedContainer
  • m_ptrClass : CXTPSyntaxEditLexVariant
  • m_ptrConfigMgr : CXTPSyntaxEditPropertiesPageColor
  • m_ptrControl : CXTPCalendarEventPropertiesDlg
  • m_ptrDataMan : CXTPSyntaxEditDoc
  • m_ptrDefaultLexConfigurationManager : CXTPSyntaxEditBufferManager
  • m_ptrDraggingEventNew : CXTPCalendarView
  • m_ptrDraggingEventOrig : CXTPCalendarView
  • m_ptrEditingEvent : CXTPCalendarEventPropertiesDlg
  • m_ptrEditingViewEvent : CXTPCalendarView
  • m_pTree : CXTPGridSection
  • m_pTreeColumn : CXTPGridColumns
  • m_pTreeCtrl : CXTPShellListCtrl
  • m_ptrEvent : CXTPCalendarViewEvent
  • m_ptrLastChild : CXTPSyntaxEditLexTextBlock
  • m_ptrLexClass : CXTPSyntaxEditLexTextBlock
  • m_ptrLexConfigurationManager : CXTPSyntaxEditBufferManager
  • m_ptrLVArrayPtr : CXTPSyntaxEditLexVariant
  • m_ptrMasterEvent : CXTPCalendarEventRecurrenceDlg
  • m_ptrNext : CXTPSyntaxEditLexTextBlock
  • m_ptRotateVector : CXTPChartRotateDeviceCommand
  • m_ptrParent : CXTPSyntaxEditLexTextBlock
  • m_ptrPattern : CXTPCalendarEventRecurrenceDlg
  • m_ptrPrev : CXTPSyntaxEditLexTextBlock
  • m_ptrResource : CXTPCalendarResourceDescription
  • m_ptrRPattern : CXTPCalendarEvent
  • m_ptrTBLast : CXTPSyntaxEditLexOnScreenParseCnt
  • m_ptrVirtualEditingRow : CXTPGridControl
  • m_pts : CXTPColorHex::CRgnCell
  • m_ptScrollOffset : CXTPFlowGraphPage
  • m_ptStart : CXTPChart3dFunnelSeriesLabelView, CXTPChart3dPieSeriesLabelView, CXTPChart3dPyramidSeriesLabelView
  • m_ptStartDrag : CXTPFlowGraphControl, CXTPTrackControl, CXTPTrackHeader
  • m_ptStartDragging : CXTPCalendarView
  • m_ptStartPoint : CXTPChartPieSeriesLabelView
  • m_ptSticky : CXTPDockingPaneContext
  • m_ptVisualOffset : CXTPMarkupVisual
  • m_ptWndPos : CXTPSyntaxEditFindReplaceDlg, CXTPSyntaxEditGoToLineDlg
  • m_pUIElement : CXTPButton, CXTPCalendarViewEvent, CXTPMessageBar, CXTPMessageBarButton, CXTPPopupItem
  • m_pUndoBuffer : CXTPCalendarView
  • m_pUndoGroup : CXTPFlowGraphUndoManager, CXTPTrackUndoManager
  • m_pUndoManager : CXTPFlowGraphControl, CXTPTrackControl
  • m_pUndoRedoManager : CXTPSyntaxEditBufferManager
  • m_pUnhookWinEvent : CXTPSkinManager
  • m_pValueCustom : CXTPCalendarViewPartCustomizableValueT< _TValue >
  • m_pValueMetrics : CXTPPropertyGridItem
  • m_pValueStandard : CXTPCalendarViewPartCustomizableValueT< _TValue >
  • m_pVerbs : CXTPPropertyGrid, CXTPPropertyGridVerb
  • m_pView : CXTPCalendarMonthView::CMonthViewGrid, CXTPCalendarViewDay, CXTPPropertyGrid
  • m_pViewDay : CXTPCalendarViewGroup
  • m_pViewEvent : CXTPCalendarViewEventSubjectEditorColored
  • m_pVirtualRow : CXTPGridRows
  • m_pVisibilityProperty : CXTPMarkupUIElement
  • m_pWindowFilter : CXTPSkinManager
  • m_pWindowSelectClass : CXTPDockingPaneManager
  • m_pWnd : CXTPResize, CXTPResizeItem
  • m_pWndClient : CXTPShortcutBarPaneItem
  • m_pWndEdit : CXTPCalendarEventColorListBox, CXTPComboBox
  • m_pWndLastFocus : CXTPExcelTabCtrl
  • m_pWndMonitor : CXTPToolTipContextToolTip
  • m_pWndParent : CXTPCustomizeSheet
  • m_radius : CXTPChartBoundedCircleDeviceCommand, CXTPChartCircleDeviceCommand
  • m_rcBlock : CXTPTrackBlock
  • m_rcBorder : CXTPTipOfTheDay
  • m_rcBorders : CXTPColorSelectorCtrl, CXTPControlCustom, CXTPDialogBar, CXTPPopupBar, CXTPSkinObjectFrame
  • m_rcBoundingRect : CXTPFlowGraphConnection
  • m_rcBoundRect : CXTPMarkupVisual
  • m_rcBounds : CXTPChart3dDeviceContext, CXTPChartContentView, CXTPChartDiagram2DAxisView, CXTPChartDiagramView, CXTPChartElementView, CXTPChartHitTestElementCommand, CXTPChartLegendView, CXTPChartPieSeriesLabelView, CXTPChartRadarAxisXView, CXTPChartRadarAxisYView, CXTPChartTextPainterBase
  • m_rcButton : CXTPDatePickerButton, CXTPDockingPaneCaptionButton, CXTPMessageBarButton, CXTPSkinObjectFrame::CCaptionButton, CXTPTabManagerNavigateButton
  • m_rcButtonMargin : CXTPPropertyPageNavigator, CXTPTabPaintManager
  • m_rcButtonTextPadding : CXTPTabPaintManager
  • m_rcCaption : CXTPRibbonBar, CXTPShortcutBarPaneItem
  • m_rcCaptionMargin : CXTPDockingPanePaintManager
  • m_rcCaptionPadding : CXTPShortcutBarPaintManager
  • m_rcCaptionText : CXTPRibbonBar
  • m_rcChild : CXTPCaption
  • m_rcClient : CXTPShortcutBar, CXTPShortcutBarPaneItem
  • m_rcClientMargin : CXTPTabPaintManager
  • m_rcClientMargins : CXTPDockingPaneManager
  • m_rcClip : CXTPChartClipDeviceCommand
  • m_rcCollapse : CXTPGridRow
  • m_rcColumn : CXTPGridColumn
  • m_rcCommandButtons : CXTPTaskDialogClient
  • m_rcContent : CXTPMessageBar, CXTPTaskDialogClient
  • m_rcControl : CXTPControl, CXTPDatePickerControl, CXTPGridRecordItemControl, CXTPTabManager
  • m_rcControlMargin : CXTPTabPaintManager
  • m_rcControlMargins : CXTPTaskPanelPaintManager
  • m_rcCurrent : CXTPColorDialog
  • m_rcDay : CXTPDatePickerItemDay
  • m_rcDaysArea : CXTPDatePickerItemMonth
  • m_rcDaysOfWeek : CXTPDatePickerItemMonth
  • m_rcDivider : CXTPGridSection
  • m_rcDragWnd : CXTPGridSubListControl
  • m_rcDropTarget1 : CXTPGridSubListControl
  • m_rcDropTarget2 : CXTPGridSubListControl
  • m_rcEndTime : CXTPCalendarViewEvent
  • m_rcEvent : CXTPCalendarViewEvent
  • m_rcEventMax : CXTPCalendarViewEvent
  • m_rcExclude : CXTPColorPopup, CXTPPopupBar
  • m_rcExpandedInformation : CXTPTaskDialogClient
  • m_rcFileButtonMargin : CXTPRibbonPaintManager
  • m_rcFinalRect : CXTPMarkupUIElement
  • m_rcFirstClock : CXTPCalendarViewEvent
  • m_rcFooter : CXTPTaskDialogClient
  • m_rcFooterArea : CXTPGridControl
  • m_rcGlyph : CXTPGridRecordItem
  • m_rcGrid : CXTPDatePickerControl
  • m_rcGripper : CXTPShortcutBar
  • m_rcGroup : CXTPRibbonGroup
  • m_rcGroupBy : CXTPGridColumn, CXTPGridHeader
  • m_rcGroupByArea : CXTPGridControl
  • m_rcGroupCurrent : CXTPTaskPanelGroup
  • m_rcGroupIconPadding : CXTPTaskPanelPaintManager
  • m_rcGroupInnerMargins : CXTPTaskPanelPaintManager
  • m_rcGroupOuterMargins : CXTPTaskPanelPaintManager
  • m_rcGroups : CXTPRibbonBar, CXTPRibbonTabPopupToolBar
  • m_rcGroupTarget : CXTPTaskPanelGroup
  • m_rcHeader : CXTPDatePickerItemMonth, CXTPGridHeader, CXTPRibbonBar
  • m_rcHeaderArea : CXTPGridControl
  • m_rcHeaderMargin : CXTPTabPaintManagerTheme
  • m_rcHeaderRect : CXTPTabManager
  • m_rcHover : CXTPCalendarTip, CXTPGridTip, CXTPSyntaxEditToolTipCtrl
  • m_rcHyperSpot : CXTPGridHyperlink
  • m_rcIconMargin : CXTPFramePaintManager
  • m_rcIconPadding : CXTPTaskPanelItem
  • m_rcImageLayoutIconPadding : CXTPTaskPanelPaintManager
  • m_rcIndent : CXTPShortcutBarPane
  • m_rcItem : CXTPPopupItem, CXTPShortcutBarItem, CXTPTabManagerItem, CXTPTaskPanelGroupItem
  • m_rcItemCaptionPadding : CXTPShortcutBarPaintManager
  • m_rcItemIconPadding : CXTPTaskPanelPaintManager
  • m_rcItemInnerMargins : CXTPTaskPanelPaintManager
  • m_rcItemOuterMargins : CXTPTaskPanelPaintManager
  • m_rcLabel : CXTPSearchOptionsCtrl
  • m_rcLastClock : CXTPCalendarViewEvent
  • m_rcLeftScroll : CXTPDatePickerItemMonth
  • m_rcLinkButtons : CXTPTaskDialogClient
  • m_rcListControl : CXTPDatePickerList
  • m_rcMainInstruction : CXTPTaskDialogClient
  • m_rcMargin : CXTPControlGallery, CXTPToolTipContext
  • m_rcMargins : CXTPStatusBarPane, CXTPTaskPanel, CXTPTaskPanelGroupItem
  • m_rcMarginsInner : CXTPTaskPanelGroup
  • m_rcMarginsOuter : CXTPTaskPanelGroup
  • m_rcMarker : CXTPCommandBar, CXTPTrackMarker
  • m_rcMaxPage : CXTPPropertySheet
  • m_rcMeetingGlyph : CXTPCalendarViewEvent
  • m_rcMessageBarMargin : CXTPPaintManager
  • m_rcMinPage : CXTPPropertySheet
  • m_rcMonth : CXTPDatePickerItemMonth
  • m_rcNavigatorMargin : CXTPPropertyPageNavigator
  • m_rcNew : CXTPColorDialog
  • m_rcPadding : CXTPControlSlider, CXTPStatusBarPane
  • m_rcPage : CXTPFlowGraphPage, CXTPPropertySheet
  • m_rcPageMargin : CXTPPropertyPageNavigator
  • m_rcPane : CXTPStatusBarPane
  • m_rcPaneBounds : CXTPChartRadarAxisYView
  • m_rcParent : CXTPCaption
  • m_rcPart : CXTPPropertyGridVerb
  • m_rcPreviewIndent : CXTPGridPaintManager
  • m_rcPrevUpdateRect : CXTPMarkupVisual
  • m_rcPrivateGlyph : CXTPCalendarViewEvent
  • m_rcQuickAccess : CXTPRibbonBar
  • m_rcRadioButtons : CXTPTaskDialogClient
  • m_rcRecentText : CXTPColorSelectorCtrlTheme
  • m_rcRect : CXTPCalendarCaptionBarTheme, CXTPCalendarCaptionBarThemePart, CXTPCalendarTimeLineViewTimeScale
  • m_rcRecurrenceGlyph : CXTPCalendarViewEvent
  • m_rcReminderGlyph : CXTPCalendarViewEvent
  • m_rcResizeGripper : CXTPPopupBar
  • m_rcRightScroll : CXTPDatePickerItemMonth
  • m_rcRoundedBounds : CXTPChartTextPainterBase
  • m_rcRow : CXTPControl, CXTPGridRow
  • m_rcScale : CXTPCalendarTimeLineViewTimeScale
  • m_rcScreenWindow : CXTPTipWindow
  • m_rcSection : CXTPGridSection
  • m_rcSections : CXTPGridSections
  • m_rcSelectedArea : CXTPFlowGraphControl, CXTPTrackControl
  • m_rcShadow : CXTPTipWindow
  • m_rcSideDockingMargin : CXTPDockingPaneManager
  • m_rcSplitter : CXTPCaption
  • m_rcStandardText : CXTPColorSelectorCtrlTheme
  • m_rcStartTime : CXTPCalendarViewEvent
  • m_rcStatusBarBorder : CXTPPaintManager
  • m_rcSubjectEditor : CXTPCalendarViewEvent
  • m_rcTabControl : CXTPRibbonBar, CXTPTabToolBar
  • m_rcTearOffGripper : CXTPPopupBar
  • m_rcText : CXTPCalendarViewEvent, CXTPTaskPanelItem
  • m_rcTextRect : CXTPSyntaxEditDrawTextProcessor
  • m_rcThemeText : CXTPColorSelectorCtrlTheme
  • m_rcTimeframe : CXTPCalendarDayViewEvent
  • m_rcTimelineArea : CXTPTrackControl
  • m_rcTipText : CXTPTipOfTheDay
  • m_rcToolTip : CXTPCalendarViewEvent, CXTPPropertyGridView
  • m_rcTooltip : CXTPCalendarView, CXTPGridTip
  • m_rcUpdateRect : CXTPMarkupVisual
  • m_rcView : CXTPCalendarView
  • m_rcWeekNumbers : CXTPDatePickerItemMonth
  • m_rcWindow : CXTPDockingPaneBase, CXTPSearchOptionsView, CXTPTipWindow
  • m_rcWnd : CXTPColorSelectorCtrl
  • m_rcWorkRect : CXTPFlowGraphNodeGroup, CXTPFlowGraphPage
  • m_RecordNumberWidth : CXTPGridPaintManager
  • m_rect : CXTPAnimationDC, CXTPChartBoundedTextDeviceCommand, CXTPChartMarkupElementDeviceCommand, CXTPChartRectangleDeviceCommand, CXTPColorHex::CRgnCell, CXTPExcelTabCtrlButtonState
  • m_rectDragDock : CXTPDockContext
  • m_rectDragFrame : CXTPDockContext, CXTPDockingPaneContext
  • m_rectDragFrameScreen : CXTPDockingPaneContext
  • m_rectGripper : CXTPExcelTabCtrl
  • m_rectMRUDockPos : CXTPDockContext
  • m_rectSB_H : CXTPExcelTabCtrl
  • m_rectStickerPane : CXTPDockingPaneContext
  • m_rectTabs : CXTPExcelTabCtrl
  • m_rectTipArea : CXTPTipWindow
  • m_rectViews : CXTPExcelTabCtrl
  • m_RecurrenceEventInfo : CXTPCalendarReminder
  • m_rgn : CXTPGridHeaderDropWnd
  • m_rgnList : CXTPColorHex
  • m_rotation : CXTPChart3dRotateDeviceCommand
  • m_Rotation3d : CXTPChartSeriesStyle
  • m_rrcInitWindow : CXTPResizeItem
  • m_rrcSizing : CXTPResizeItem
  • m_rrcWindow : CXTPResizeItem
  • m_rWindow : CXTPSyntaxEditTipWnd
  • m_scaleInterval : CXTPCalendarTLV_TimeScaleParams
  • m_scrollBarStyle : CXTPScrollBase
  • m_ScrollDayButton : XTP_CALENDAR_USERACTION_PARAMS
  • m_scrollModeH : CXTPGridControl
  • m_scrollModeV : CXTPGridControl
  • m_scrollUpdateMode : CXTPGridControl
  • m_scSizeIcon : CXTPPropertySheet, CXTPResize
  • m_sCustomFormat4Tooltip : CXTPCalendarControl
  • m_sCustomTitle : CXTPCalendarControl, CXTPGridControl
  • m_selectedBlock : CXTPCalendarView
  • m_selectedSticker : CXTPDockingPaneContextStickerWnd
  • m_shSettings : CXTPShellListBase, CXTPShellTreeBase
  • m_sIniSet : CXTPSyntaxEditConfigurationManager, CXTPSyntaxEditCtrl
  • m_sizeArrow : CXTPHeaderCtrlTheme
  • m_sizeButton : CXTPColorSelectorCtrlTheme
  • m_sizeCheck : CXTPCheckListBox::CCheckListState
  • m_sizeCheckThemed : CXTPCheckListBox::CCheckListState
  • m_sizeColor : CXTPCalendarEventColorListBox
  • m_sizeCommandButton : CXTPTaskDialogClient
  • m_sizeControl : CXTPGridRecordItemControl
  • m_sizeIcon : CXTPCaption
  • m_sizeIconFooter : CXTPTaskDialogClient
  • m_sizeIconMain : CXTPTaskDialogClient
  • m_sizeMargin : CXTPTipWindow
  • m_sizePadding : CXTPHeaderCtrlTheme
  • m_sizeTitle : CXTPTipWindow
  • m_sLineNumberFormat : CXTPSyntaxEditPaintManager
  • m_sMultipleSchedules : CXTPCalendarEvent
  • m_sPassedIniSet : CXTPSyntaxEditCtrl
  • m_spDraggingStartOffset : CXTPCalendarView
  • m_spi : CXTPScrollBase, CXTPSkinObjectFrame
  • m_spPeriod2Cache : CXTPCalendarRemindersManager
  • m_stateCurrent : CXTPPopupControl
  • m_stateTarget : CXTPPopupControl
  • m_stickers : CXTPStickerBase
  • m_strArgument : CXTPChartSeriesPoint
  • m_strAxisMaxValue : CXTPChartAxisStrip
  • m_strAxisMinValue : CXTPChartAxisStrip
  • m_strAxisValue : CXTPChartAxisConstantLine, CXTPChartAxisCustomLabel
  • m_strBody : CXTPCalendarEvent, CXTPCalendarEventPropertiesDlg
  • m_strBuffer : CXTPTaskDialogLinkCtrl
  • m_strCaption : CXTPCalendarDayViewTimeScale, CXTPCaption, CXTPCommandBarKeyboardTip, CXTPControl, CXTPControlAction, CXTPControlGalleryItem, CXTPDatePickerButton, CXTPDialogBar, CXTPFlowGraphConnection, CXTPFlowGraphConnectionPoint, CXTPFlowGraphNode, CXTPFlowGraphPage, CXTPGridRecordItem, CXTPGridRecordItemControl, CXTPMessageBarButton, CXTPPopupItem, CXTPPropertyGridItem, CXTPPropertyGridVerb, CXTPPropertySheet, CXTPRibbonGroup, CXTPShortcutBarItem, CXTPShortcutBarPane, CXTPShortcutBarPaneItem, CXTPStatusBarPane, CXTPTabManagerItem, CXTPTaskPanelItem, CXTPTrackBlock, CXTPTrackMarker
  • m_strCaptionText : CXTPRibbonBar
  • m_strCategory : CXTPControl, CXTPControlAction
  • m_strClass : CXTPSkinManagerClass
  • m_strClassName : CXTPSkinObject
  • m_strCloseTags : CXTPSyntaxEditAutoCompleteWnd
  • m_strCollapse : CXTPGridPaintManager
  • m_strCollapsedControlText : CXTPTaskDialogClient
  • m_strColorScheme : CXTPSyntaxEditCtrl
  • m_strCommandText : CXTPSyntaxEditCommand
  • m_strConnectionString : CXTPCalendarData
  • m_strConstraint : CXTPGridRecordItemConstraint, CXTPPropertyGridItemConstraint
  • m_strContent : CXTPMessageBar, CXTPTaskDialogClient
  • m_strContextCaption : CXTPRibbonTab
  • m_strContractLabel : CXTPSearchOptionsCtrl
  • m_strControlsFileName : CXTPCommandBars
  • m_strCurrencySymbol : CXTPChartNumberFormat
  • m_strCustomCaption : CXTPControl
  • m_strCustomizeCaption : CXTPRibbonTab
  • m_strCustomShortcutText : CXTPControlAction
  • m_strDayHeaderFormatDefaultLong : CXTPCalendarView
  • m_strDayHeaderFormatDefaultMiddle : CXTPCalendarView
  • m_strDayHeaderFormatDefaultShort : CXTPCalendarView
  • m_strDayHeaderFormatDefaultShortest : CXTPCalendarView
  • m_strDayHeaderFormatLong : CXTPCalendarView
  • m_strDayHeaderFormatMiddle : CXTPCalendarView
  • m_strDayHeaderFormatShort : CXTPCalendarView
  • m_strDayHeaderFormatShortest : CXTPCalendarView
  • m_strDecreasing : CXTPGridPaintManager
  • m_strDefault : CXTPListBase, CXTPMaskEditT< TBase >
  • m_strDefaultCfgFilePath : CXTPSyntaxEditCtrl
  • m_strDefaultMenu : CXTPCustomizeMenusPage
  • m_strDefaultMenuDesc : CXTPCustomizeMenusPage
  • m_strDefaultValue : CXTPPropertyGridItem
  • m_strDefExt : CXTPBrowseEdit
  • m_strDelims : CXTPSyntaxEditAutoCompleteWnd
  • m_strDesc : CXTPCustomizeKeyboardPage
  • m_strDescrip : CXTPTipWindow
  • m_strDescription : CXTPMenuBarMDIMenuInfo, CXTPPropertyGridItem, CXTPTrackBlock
  • m_strDescriptionText : CXTPControl, CXTPControlAction, CXTPControlGalleryItem
  • m_strDisplayString : CXTPCalendarTimeZone
  • m_strDllFileName : CXTPResourceImages
  • m_strDragText : CXTPTaskPanelGroupItem
  • m_strEditHint : CXTPControlAction, CXTPControlComboBox, CXTPControlEdit
  • m_strEditText : CXTPControlComboBox, CXTPControlEdit
  • m_strEncoding : CXTPPropExchangeXMLNode
  • m_strEntry : CXTPListBase
  • m_strExpand : CXTPGridPaintManager
  • m_strExpandedControlText : CXTPTaskDialogClient
  • m_strExpandedInformation : CXTPTaskDialogClient
  • m_strExpandLabel : CXTPSearchOptionsCtrl
  • m_strFalseText : CXTPPropertyGridItemBool
  • m_strFileExt : CXTPSyntaxEditBufferManager
  • m_strFileName : CXTPBrowseEdit, CXTPPropExchangeIniFile
  • m_strFilter : CXTPBrowseEdit, CXTPEditListBox
  • m_strFilterText : CXTPGridControl
  • m_strFloatingFrameCaption : CXTPDockingPaneManager
  • m_strFolderPath : CXTPDirWatcher
  • m_strFontFace : CXTPDockingPaneVisualStudio2012Theme
  • m_strFooter : CXTPTaskDialogClient
  • m_strFooterText : CXTPGridColumn
  • m_strFormat : CXTPGridGroupRow, CXTPPropertyGridItem
  • m_strFormatString : CXTPGridRecordItem
  • m_strFormula : CXTPGridGroupRow, CXTPGridRecordItem
  • m_strGroupCaption : CXTPGridRecordItem
  • m_strGroupLabel : CXTPGridGroupRow
  • m_strGroupText : CXTPGridGroupRow
  • m_strHeaderFormat : CXTPCalendarView
  • m_strHighlightedPrefix : CXTPRibbonMarkupTheme
  • m_strHint : CXTPGridFilterEditControl
  • m_strIncreasing : CXTPGridPaintManager
  • m_Strings : CXTPSyntaxEditBufferManager
  • m_strINIFileName : CXTPRegistryManager
  • m_strIniFileName : CXTPResourceImages, CXTPSkinManagerResourceFile
  • m_strInitialDir : CXTPBrowseEdit, CXTPEditListBox
  • m_strInputBoxText : CXTPTaskDialogClient
  • m_strInternalName : CXTPGridColumn
  • m_strItemDefaultText : CXTPEditListBox
  • m_strItemPath : CXTPShellListCtrlEx
  • m_strItemText : CXTPEditListBox
  • m_strKey : CXTPControlAction
  • m_strKeyboardTip : CXTPControl, CXTPControlAction, CXTPRibbonTab
  • m_strLabel : CXTPChartAxisViewTick, CXTPChartRadarAxisXViewTick, CXTPChartRadarAxisYViewTick
  • m_strLastText : CXTPControlComboBox, CXTPControlEdit
  • m_strLegendName : CXTPChartAxisConstantLine, CXTPChartAxisStrip
  • m_strLegendText : CXTPChartSeries
  • m_strLegentText : CXTPChartSeriesPoint
  • m_strLink : CXTPHyperLink
  • m_strLiteral : CXTPGridColumn, CXTPMaskEditT< TBase >, CXTPPropertyGridItem
  • m_strLocation : CXTPCalendarEvent, CXTPCalendarEventPropertiesDlg
  • m_strLongDateFormat : CXTPCalendarMonthView
  • m_strMainInstruction : CXTPTaskDialogClient
  • m_strMarkupTemplate : CXTPPropertyGridItem
  • m_strMarkupUIElement_NoGroupBy : CXTPGridPaintManager
  • m_strMask : CXTPGridColumn, CXTPMaskEditT< TBase >, CXTPPropertyGridItem
  • m_strMessage : CXTPCalendarOccurSeriesChooseDlg
  • m_strName : CXTPCalendarEventCategory, CXTPCalendarEventLabel, CXTPChartAxisStrip, CXTPChartSeries, CXTPFlowGraphConnectionPoint, CXTPGridColumn
  • m_strNoFieldsAvailable : CXTPGridPaintManager
  • m_strNoGroupBy : CXTPGridPaintManager
  • m_strNoItems : CXTPGridPaintManager
  • m_strNormalPrefix : CXTPRibbonMarkupTheme
  • m_strNullValue : CXTPPropertyGridItemDate
  • m_strOccur : CXTPCalendarOccurSeriesChooseDlg
  • m_strOfficeFont : CXTPDockingPanePaintManager, CXTPPaintManager, CXTPShortcutBarPaintManager
  • m_strOldCaption : CXTPFlowGraphUndoSetNodeCaptionCommand
  • m_strOpenTags : CXTPSyntaxEditAutoCompleteWnd
  • m_strParameter : CXTPControl
  • m_strPattern : CXTPChartNumberFormat
  • m_strPrefix : CXTPCommandBarKeyboardTip
  • m_strPreviewText : CXTPGridRecordItemPreview
  • m_strProfileName : CXTPRegistryManager
  • m_strRedoBuffer : CXTPMaskEditT< TBase >
  • m_strRedoUIText : CXTPCalendarControl
  • m_strRegistryKey : CXTPRegistryManager
  • m_strReminderSoundFile : CXTPCalendarEvent
  • m_strReplacedText : CXTPSyntaxEditReplaceStringCommand
  • m_strResourceName : CXTPCalendarResource
  • m_strResourcePath : CXTPSkinManagerResourceFile
  • m_strScheduleName : CXTPCalendarSchedule
  • m_strSchemaName : CXTPSkinManagerSchema
  • m_strSearch : CXTPSyntaxEditAutoCompleteWnd
  • m_strSection : CXTPListBase, CXTPResize
  • m_strSectionName : CXTPPropExchangeEnumerator, CXTPPropExchangeIniFile, CXTPPropExchangeRegistry, CXTPPropExchangeXMLNode
  • m_strSeries : CXTPCalendarOccurSeriesChooseDlg
  • m_strShortcutText : CXTPControl, CXTPControlAction
  • m_strShortcutTextAuto : CXTPControl
  • m_strSmallDateFormat : CXTPCalendarMonthView
  • m_strSortBy : CXTPGridPaintManager
  • m_strSubject : CXTPCalendarEvent, CXTPCalendarEventPropertiesDlg
  • m_strSyntaxScheme : CXTPSyntaxEditCtrl
  • m_strTabCaption : CXTPDockingPane
  • m_strTag : CXTPFlowGraphConnection
  • m_strTearOffCaption : CXTPPopupBar
  • m_strText : CXTPCalendarCaptionBarThemePart, CXTPChartAxisConstantLine, CXTPChartAxisCustomLabel, CXTPChartAxisTitle, CXTPChartTextDeviceCommand, CXTPChartTextPainterBase, CXTPChartTitle, CXTPGridRecordItemText, CXTPShortcutListBox::CONTENT_ITEM, CXTPStatusBarPane, CXTPSyntaxEditBufferCommand, XTP_EDIT_ACDATA
  • m_strText_prev : CXTPGridInplaceEdit
  • m_strTimeFormat : CXTPTrackControl
  • m_strTip : CXTPCommandBarKeyboardTip
  • m_strTipFile : CXTPTipOfTheDay
  • m_strTipText : CXTPHyperLink, CXTPPropertyGridView, CXTPTipOfTheDay
  • m_strTipTitle : CXTPTipOfTheDay
  • m_strTitle : CXTPBrowseEdit, CXTPCalendarOccurSeriesChooseDlg, CXTPCommandBar, CXTPDockingPane, CXTPEditListBox, CXTPMenuBarMDIMenuInfo, CXTPTipWindow, CXTPToolTipContextToolTip
  • m_strTitleCustom : CXTPColorPicker, CXTPColorSelectorCtrl
  • m_strTitleRecent : CXTPColorSelectorCtrl
  • m_strTitleStandard : CXTPColorPicker, CXTPColorSelectorCtrl
  • m_strTitleTheme : CXTPColorPicker, CXTPColorSelectorCtrl
  • m_strTitleToolTip : CXTPDockingPane
  • m_strTmpCloseTag : CXTPSyntaxEditAutoCompleteWnd
  • m_strTmpOpenTag : CXTPSyntaxEditAutoCompleteWnd
  • m_strToolTip : CXTPControlGalleryItem, CXTPMessageBarButton, CXTPStatusBarPane, CXTPTabManagerItem, CXTPTabManagerNavigateButton, CXTPTrackBlock, CXTPTrayIcon
  • m_strTooltip : CXTPButton, CXTPFlowGraphConnection, CXTPFlowGraphConnectionPoint, CXTPFlowGraphNode, CXTPGridColumn, CXTPGridRecordItem, CXTPPropertyGridItem, CXTPShortcutBarItem, CXTPTaskPanelItem
  • m_strToolTipPart : CXTPStatusBarScrollBarPane
  • m_strToolTipText : CXTPSyntaxEditToolTipCtrl
  • m_strTooltipText : CXTPCalendarTip, CXTPControl, CXTPControlAction, CXTPGridTip
  • m_strTrueText : CXTPPropertyGridItemBool
  • m_strUIElementText : CXTPCalendarViewEvent
  • m_strUndoBuffer : CXTPMaskEditT< TBase >
  • m_strUndoUIText : CXTPCalendarControl
  • m_strValue : CXTPGridInplaceEdit, CXTPPropertyGridInplaceEdit, CXTPPropertyGridItem, CXTPStatusBarPane
  • m_strVar : CXTPSyntaxEditLexVariable
  • m_strVerificationText : CXTPTaskDialogClient
  • m_strWindowText : CXTPItemEdit, CXTPMaskEditT< TBase >
  • m_strYearMonthFormat : CXTPDatePickerControl
  • m_systemTheme : CXTPDockingPanePaintManager, CXTPPaintManager
  • m_szActualSize : CXTPFlowGraphNode
  • m_szBitmap : CXTPSkinImage
  • m_szBounds : CXTPChartAxisViewTick, CXTPChartRadarAxisXViewTick, CXTPChartRadarAxisYViewTick
  • m_szButton : CXTPPropertySheet
  • m_szButtons : CXTPCommandBar
  • m_szButtonSpacing : CXTPCommandBar
  • m_szCaret : CXTPHexEdit
  • m_szClockRect : CXTPCalendarPaintManager
  • m_szControl : CXTPControlCustom
  • m_szDayMargin : CXTPDatePickerPaintManager
  • m_szDesiredSize : CXTPMarkupUIElement
  • m_szDir : CXTPSplitPath
  • m_szDocking : CXTPDockingPaneBase
  • m_szDockingClient : CXTPDialogBar
  • m_szDrive : CXTPSplitPath
  • m_szExt : CXTPSplitPath
  • m_szExtent : CXTPResourceImage
  • m_szFloatingClient : CXTPDialogBar
  • m_szFName : CXTPSplitPath
  • m_szFrameRegion : CXTPCommandBarsFrameHook, CXTPSkinObjectFrame
  • m_szGlyph : CXTPGridPaintManager
  • m_szGroupIcon : CXTPTaskPanel
  • m_szIcon : CXTPControl, CXTPFramePaintManager, CXTPImageManagerIconHandle, CXTPImageManagerResource, CXTPTabPaintManager
  • m_szIcons : CXTPCommandBar
  • m_szImage : CXTPFlowGraphImage
  • m_szInitWindow : CXTPResize
  • m_szItem : CXTPControlGalleryItem, CXTPControlGalleryItems, CXTPControlSelector, CXTPShortcutBar, CXTPTaskPanelGroupItem
  • m_szItemIcon : CXTPTaskPanel, CXTPTaskPanelGroup
  • m_szItemsActive : CXTPControlSelector
  • m_szItemsCount : CXTPControlSelector
  • m_szItemsMax : CXTPControlSelector
  • m_szItemsVisible : CXTPControlSelector
  • m_szLabel : CXTPChartAxisViewTick, CXTPChartRadarAxisXViewTick, CXTPChartRadarAxisYViewTick
  • m_szMarkerSize : CXTPChartLegend
  • m_szMax : CXTPResize
  • m_szMin : CXTPResize
  • m_szMinTrackRect : CXTPDialogBar
  • m_szNavigateButton : CXTPTabPaintManager
  • m_szOldSize : CXTPFlowGraphUndoSetNodeSizeCommand
  • m_szPage : CXTPSyntaxEditView
  • m_szPopup : CXTPPopupControl
  • m_szPreview : CXTPTaskPanelGroupItem
  • m_szPreviousAvailableSize : CXTPMarkupUIElement
  • m_szRenderSize : CXTPMarkupVisual
  • m_szResult : CXTPControlSelector
  • m_szSelPath : CXTPBrowseDialog
  • m_szTabCloseButton : CXTPTabPaintManager
  • m_szTearOffBar : CXTPPopupBar
  • m_szText : CXTPCalendarViewEvent
  • m_szTextSize : CXTPChartTextPainterBase
  • m_szUserMinSize : CXTPFlowGraphNode
  • m_szUserSize : CXTPFlowGraphNode
  • m_szVectorIcon : CXTPButton
  • m_szVectorIconLarge : CXTPToolTipContext
  • m_szVectorIconSmall : CXTPToolTipContext
  • m_szWindow : CXTPFlowGraphNode, CXTPPropertySheet, CXTPResize
  • m_tabAppearance : CXTPTabPaintManager
  • m_tabColor : CXTPTabPaintManager
  • m_tabCtrl : CXTPResizePropertySheet
  • m_tabLayout : CXTPTabPaintManager
  • m_tabPosition : CXTPTabPaintManager
  • m_tcbItems : CXTPExcelTabCtrl, CXTPTabExBase
  • m_theme : CXTPEditListBoxToolBar, CXTPListBox
  • m_themeButton : CXTPDatePickerPaintManager, CXTPDockingPanePaintManager, CXTPGridPaintManager, CXTPPaintManager, CXTPPropertyGridPaintManager
  • m_themeCombo : CXTPCommandBarsNativeXPTheme, CXTPGridPaintManager, CXTPPropertyGridPaintManager
  • m_themeComboBox : CXTPComboBoxTheme
  • m_themeCommandBars : CXTPTabClientWnd
  • m_themeCurrent : CXTPDockingPanePaintManager, CXTPGridControl, CXTPPaintManager, CXTPPropertyGrid
  • m_themeExplorer : CXTPDockingPanePaintManager
  • m_themeHeader : CXTPGridPaintManager, CXTPHeaderCtrlTheme
  • m_themeHelper : CXTPCheckListBox
  • m_themeMenu : CXTPCommandBarsNativeXPTheme
  • m_themeRebar : CXTPCommandBarsNativeXPTheme, CXTPDockingPanePaintManager, CXTPReBarPaintManager< TBase >
  • m_themeSpin : CXTPCommandBarsNativeXPTheme, CXTPGridPaintManager, CXTPSpinButtonCtrl
  • m_themeStatusBar : CXTPPaintManager
  • m_themeTab : CXTPTabBaseTheme
  • m_themeTabButton : CColorSetWinNative
  • m_themeToolbar : CColorSetWinNative, CXTPCommandBarsNativeXPTheme, CXTPDockingPanePaintManager
  • m_themeTree : CXTPPropertyGridPaintManager
  • m_themeWindow : CXTPCommandBarsNativeXPTheme, CXTPDockingPanePaintManager
  • m_themeWrapper : CXTPTagCloudCtrl
  • m_thickness : CXTPChartBoundedCircleDeviceCommand, CXTPChartBoundedPolygonDeviceCommand
  • m_tmText : CXTPSyntaxEditDrawTextProcessor
  • m_toolBehaviour : CXTPTabPaintManager
  • m_toolDelay : CXTPToolTipContextToolTip
  • m_toolDisabled : CXTPToolTipContextToolTip
  • m_toolStyle : CXTPToolTipContext
  • m_ToolTip : CXTPExcelTabCtrl
  • m_toolTip : CXTPHyperLink
  • m_tooltip : CXTPColorSelectorCtrl, CXTPEditListBoxToolBar
  • m_toolVisible : CXTPToolTipContextToolTip
  • m_treeCommands : CXTPRibbonCustomizePage
  • m_treeRibbon : CXTPRibbonCustomizePage
  • m_treeStructureStyle : CXTPGridPaintManager
  • m_tvid : CXTPDirWatcher
  • m_type : CXTPDockingPaneBase, CXTPMarkupGridLength
  • m_typeItem : CXTPTaskPanelItem
  • m_typeProvider : CXTPCalendarData
  • m_typeSticker : CXTPDockingPaneContextStickerWnd
  • m_uAnimationDelay : CXTPPopupControl
  • m_UaSorted : CXTPGridSection
  • m_uAutoScrollTimerID : CXTPGridControl
  • m_uDefMenuItemID : CXTPTrayIcon
  • m_uDrawTextFormat : CXTPPropertyGridItemMetrics
  • m_uFaceSize : CXTPSyntaxEditPropertiesPageFont
  • m_uFlags : CXTPShellListBase, CXTPShellTreeBase, CXTPTrayIcon
  • m_uiDelayEditMaxTime : CXTPGridControl
  • m_uiDelayEditTimer : CXTPGridControl
  • m_uiRefCount : CXTPDropSource
  • m_ulSFGAOFlags : CXTPShellPidl
  • m_uMRUDockPosition : CXTPDockContext
  • m_unFlags : CXTPGridRecordItemControl
  • m_unSpinTimerCnt : CXTPGridInplaceButton
  • m_unSpinTimerId : CXTPGridInplaceButton
  • m_uRqstEditTimer : CXTPGridControl
  • m_uScheduleID : CXTPCalendarEvent, CXTPCalendarSchedule
  • m_uShowDelay : CXTPPopupControl
  • m_ValueCustom : CXTPCalendarThemeCustomizableXValueT< _TValue, _TValueRef >
  • m_ValueStandard : CXTPCalendarThemeCustomizableXValueT< _TValue, _TValueRef >
  • m_Variable : CXTPSyntaxEditLexVariant
  • m_verticalOptions : CXTPControlCustom
  • m_vtBookmark : CXTPGridRecord
  • m_vtCaptionValue : CXTPGridGroupRow
  • m_WatermarkAlignment : CXTPGridControl
  • m_WatermarkTransparency : CXTPGridControl
  • m_Weekly : XTP_CALENDAR_RECURRENCE_OPTIONS
  • m_WindowToNodeHash : CXTPFlowGraphNode
  • m_winTheme : CXTPEditTheme, CXTPMarqueeCtrlPaintManager, CXTPProgressCtrlPaintManager
  • m_wndAttachedTab : CXTPDockingPaneContext
  • m_wndBusyStatusCombo : CXTPCalendarEventPropertiesDlg
  • m_wndCategoryCombo : CXTPCalendarEventPropertiesDlg
  • m_wndCbDuration : CXTPCalendarEventRecurrenceDlg
  • m_wndCbEnd : CXTPCalendarEventRecurrenceDlg
  • m_wndCbMonthDay : CXTPCalendarEventRecurrenceDlg
  • m_wndCbMonthWhich : CXTPCalendarEventRecurrenceDlg
  • m_wndCbStart : CXTPCalendarEventRecurrenceDlg
  • m_wndCbYearDay : CXTPCalendarEventRecurrenceDlg
  • m_wndCbYearWhich : CXTPCalendarEventRecurrenceDlg
  • m_wndComboYearMonth2 : CXTPCalendarEventRecurrenceDlg
  • m_wndContent : CXTPTaskDialogClient
  • m_wndContext : CXTPDockingPaneContext
  • m_wndExpandedInformation : CXTPTaskDialogClient
  • m_wndEyeDropper : CXTPColorDialog
  • m_wndFooter : CXTPTaskDialogClient
  • m_wndGrid : CXTPGridView
  • m_wndHeader : CXTPListBase
  • m_wndHexEdit : CXTPColorDialog
  • m_wndHScrollBar : CXTPExcelTabCtrl
  • m_wndIcon : CXTPCustomizeMenusPage
  • m_wndInfoTip : CXTPSyntaxEditTipListBox
  • m_wndInputBox : CXTPTaskDialogClient
  • m_wndLabelCombo : CXTPCalendarEventPropertiesDlg
  • m_wndMinimize : CXTPTrayIcon
  • m_wndOtherGroup : CXTPCustomizeOptionsPage
  • m_wndPersonalizedGroup : CXTPCustomizeOptionsPage
  • m_wndProgressBar : CXTPTaskDialogClient
  • m_wndReminderCombo : CXTPCalendarEventPropertiesDlg
  • m_wndTip : CXTPPropertyGridView
  • m_wndToolbar : CXTPPropertyGrid
  • m_wndToolTip : CXTPTagCloudCtrl
  • m_wndYearMonth : CXTPCalendarEventRecurrenceDlg
  • m_xGripperPos : CXTPExcelTabCtrl
  • m_xmlDocPtr : CXTPPropExchangeXMLNode
  • m_xmlParentNode : CXTPPropExchangeXMLNode
  • m_xmlSectionNode : CXTPPropExchangeXMLNode
  • m_xtpBrush : CXTPSearchOptionsView
  • m_xtpBrushBack : CXTPEditTheme, CXTPGridInplaceEdit, CXTPPropertyGridInplaceEdit
  • m_xtpBrushBackground : CXTPComboBoxTheme
  • m_xtpBrushDialog : CXTPSkinManagerMetrics
  • m_xtpBrushElsewhere : CXTPCalendarPaintManager
  • m_xtpBrushGroupGridLineStyle : CXTPGridPaintManager
  • m_xtpBrushHorizontalGrid : CXTPGridPaintManager
  • m_xtpBrushTabControl : CXTPSkinManagerMetrics
  • m_xtpBrushTentative : CXTPCalendarPaintManager
  • m_xtpBrushTreeStructure : CXTPGridPaintManager
  • m_xtpBrushVeriticalGrid : CXTPGridPaintManager
  • m_xtpBrushWindow : CXTPSkinManagerMetrics
  • m_xtpFont : CXTPFlowGraphEditItem, CXTPFontManager, CXTPHyperLink, CXTPPropertyGridToolTip, CXTPSyntaxEditPaintManager, CXTPTagCloudStyle, CXTPTaskDialogClient, CXTPToolTipContext
  • m_xtpFontBasic : CXTPSyntaxEditAutoCompleteWnd
  • m_xtpFontBold : CXTPFontManager, CXTPPropertyGridItemMetrics, CXTPTabPaintManager
  • m_xtpFontBoldText : CXTPGridPaintManager
  • m_xtpFontButton : CXTPDatePickerPaintManager
  • m_xtpFontCaption : CXTPGridPaintManager, CXTPGridRecordItemControl, CXTPSkinManagerMetrics, CXTPTaskPanelPaintManager
  • m_xtpFontCustomValue : CXTPCalendarViewPartFontValue
  • m_xtpFontDay : CXTPDatePickerPaintManager
  • m_xtpFontDayBold : CXTPDatePickerPaintManager
  • m_xtpFontDaysOfWeek : CXTPDatePickerPaintManager
  • m_xtpFontEdit : CXTPGridInplaceEdit, CXTPSyntaxEditPropertiesPageColor, CXTPSyntaxEditPropertiesPageFont
  • m_xtpFontFooter : CXTPGridColumn
  • m_xtpFontHeader : CXTPDatePickerPaintManager
  • m_xtpFontHex : CXTPHexEdit
  • m_xtpFontIcon : CXTPTaskPanelPaintManager
  • m_xtpFontIconBold : CXTPTaskPanelPaintManager
  • m_xtpFontIconHot : CXTPTaskPanelPaintManager
  • m_xtpFontIconHotBold : CXTPTaskPanelPaintManager
  • m_xtpFontItalic : CXTPFontManager
  • m_xtpFontItalicBold : CXTPFontManager
  • m_xtpFontItem : CXTPTaskPanelItem
  • m_xtpFontLarge : CXTPTaskDialogClient
  • m_xtpFontLineNumber : CXTPSyntaxEditPaintManager
  • m_xtpFontListControl : CXTPDatePickerPaintManager
  • m_xtpFontMenu : CXTPSkinManagerMetrics
  • m_xtpFontNonMonthDay : CXTPDatePickerPaintManager
  • m_xtpFontNormal : CXTPPropertyGridItemMetrics, CXTPPropertySheet, CXTPTabPaintManager
  • m_xtpFontPaneCaption : CXTPShortcutBarPaintManager
  • m_xtpFontPaneItemCaption : CXTPShortcutBarPaintManager
  • m_xtpFontPreview : CXTPGridPaintManager
  • m_xtpFontRegular : CXTPPaintManager
  • m_xtpFontRegularBold : CXTPPaintManager
  • m_xtpFontSmCaption : CXTPSkinManagerMetrics
  • m_xtpFontStandardValue : CXTPCalendarViewPartFontValue
  • m_xtpFontStatus : CXTPStatusBar
  • m_xtpFontText : CXTPGridPaintManager, CXTPPopupItem, CXTPPopupPaintManager, CXTPShortcutBarPaintManager, CXTPStatusBarPane, CXTPSyntaxEditPaintManager
  • m_xtpFontTip : CXTPTipOfTheDay
  • m_xtpFontTitle : CXTPDockingPanePaintManager, CXTPTipOfTheDay, CXTPToolTipContext
  • m_xtpFontTitleVertical : CXTPDockingPanePaintManager
  • m_xtpFontToolTip : CXTPGridTip, CXTPSyntaxEditPaintManager
  • m_xtpFontUL : CXTPTaskDialogLinkCtrl
  • m_xtpFontUnderline : CXTPPropertyGridItemMetrics
  • m_xtpFontVert : CXTPPaintManager
  • m_xtpFontVertBold : CXTPPaintManager
  • m_xtpFontVertical : CXTPFontManager
  • m_xtpFontVerticalBold : CXTPFontManager, CXTPTabPaintManager
  • m_xtpFontVerticalNormal : CXTPTabPaintManager
  • m_xtpFontVerticalText : CXTPShortcutBarPaintManager
  • m_xtpFontWeekNumbers : CXTPDatePickerPaintManager
  • m_xTrackingDelta : CXTPExcelTabCtrl
  • m_Yearly : XTP_CALENDAR_RECURRENCE_OPTIONS
  • m_YearNth : XTP_CALENDAR_RECURRENCE_OPTIONS
  • MaterialDiffuseColor : CXTPChartDiagram3DAppearance
  • MaterialEmissionColor : CXTPChartDiagram3DAppearance
  • MaterialShininess : CXTPChartDiagram3DAppearance
  • MaterialSpecularColor : CXTPChartDiagram3DAppearance
  • MAXPOS : XTP_EDIT_LINECOL
  • MINPOS : XTP_EDIT_LINECOL
  • ms_bDroppedHere : CXTPSyntaxEditView
  • ms_dwNextFreeTempID : CXTPCalendarData
  • ms_dwSignature : CXTPSyntaxEditView
  • ms_pTargetView : CXTPSyntaxEditView
  • ms_ptDropPos : CXTPSyntaxEditView


Toolkit Pro: Class Members - Variables

Here is a list of all documented variables with links to the class documentation for each member:

- n -

  • nAction : XTP_EDIT_NMHDR_EDITCHANGED, XTP_NM_FLOWGRAPH_CONNECTIONCHANGED
  • nBegin : XTP_NM_GRIDSTATECHANGED
  • nButton : XTP_CALENDAR_USERACTION_PARAMS::EXPANDDAYBUTTONACTION_PARAMS, XTP_CALENDAR_USERACTION_PARAMS::SCROLLDAYBUTTONACTION_PARAMS
  • nChar : XTP_NM_GRIDPREVIEWKEYDOWN
  • nCodePage : XTP_RESOURCEMANAGER_LANGINFO
  • nCol : XTP_EDIT_LINECOL, XTP_EDIT_NMHDR_ROWCOLCHANGED
  • nCol1 : XTP_EDIT_ROWCOLRECT
  • nCol2 : XTP_EDIT_ROWCOLRECT
  • nColumn : CXTPDockingPaneWindowSelect::CItem
  • nColumnAlignment : XTP_GRIDRECORDITEM_METRICS
  • nCount : XTP_SLIDERTICKS
  • nDateBegin : CXTPDatePickerDaysCollection::SELECTED_BLOCK
  • nDateEnd : CXTPDatePickerDaysCollection::SELECTED_BLOCK
  • nDay : XTP_CALENDAR_HITTESTINFO
  • nDayOfMonth : XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_MONTHLY, XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_YEARLY
  • nDayOfWeekMask : XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_WEEKLY
  • nDayView_CurrentTimeMarkVisible : CXTPCalendarOptions
  • nDayView_ScaleInterval : CXTPCalendarOptions
  • nDispRow : XTP_EDIT_NMHDR_MARGINCLICKED
  • nEnd : XTP_NM_GRIDSTATECHANGED
  • nEvent : XTP_CALENDAR_HITTESTINFO
  • nFirstDayOfTheWeek : CXTPCalendarOptions
  • nFirstItem : CXTPTabManager::ROW_ITEMS
  • nFlags : XTP_NM_GRIDPREVIEWKEYDOWN
  • nFontCharSet : XTP_RESOURCEMANAGER_LANGINFO
  • nGroup : XTP_CALENDAR_HITTESTINFO
  • nGroupIndex : XTP_CALENDAR_VIEWSELECTION
  • nGroupRowIcon : XTP_GRIDRECORDITEM_METRICS
  • nGroupRowIconAlignment : XTP_GRIDRECORDITEM_METRICS
  • nHyperlink : XTP_NM_GRIDRECORDITEM
  • nID : CXTPColorSelectorCtrl::COLOR_CELL, CXTPStatusBarSwitchPane::SWITCH, XTP_COMMANDBARS_CREATEBAR, XTP_COMMANDBARS_CREATECONTROL, XTP_NC_DATEPICKER_BUTTON
  • nIndex : CXTPColorSelectorCtrl::COLOR_CELL, CXTPDockingPaneWindowSelect::CItem, CXTPTaskDialogLinkCtrl::LINKITEM, XTP_CALENDAR_DAYVIEWCELL_PARAMS, XTP_CALENDAR_THEME_DAYVIEWCELL_PARAMS, XTP_CALENDAR_THEME_DAYVIEWTIMESCALECELL_PARAMS, XTP_COMMANDBARS_CREATECONTROL
  • nIntervalDays : XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_DAILY
  • nIntervalMonths : XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_MONTHLY, XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_MONTHNTH
  • nIntervalWeeks : XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_WEEKLY
  • nItem : XTP_CALENDAR_GETITEMTEXT_PARAMS
  • nItemIcon : XTP_GRIDRECORDITEM_METRICS
  • nKey : CXTPCommandBars::KEYBOARDTIPS
  • nLastItem : CXTPTabManager::ROW_ITEMS
  • nLevel : CXTPCommandBars::KEYBOARDTIPS
  • nLine : XTP_EDIT_LINECOL
  • nmhdr : XTP_EDIT_NMHDR_DOCMODIFIED, XTP_EDIT_NMHDR_EDITCHANGED, XTP_EDIT_NMHDR_ENABLESCROLLBAR, XTP_EDIT_NMHDR_MARGINCLICKED, XTP_EDIT_NMHDR_PARSEEVENT, XTP_EDIT_NMHDR_ROWCOLCHANGED, XTP_EDIT_NMHDR_SETSCROLLPOS, XTP_EDIT_SENMBOOKMARK
  • nMinutes : XTP_CALENDAR_THEME_DAYVIEWTIMESCALECELL_PARAMS
  • nMonthOfYear : XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_YEARLY, XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_YEARNTH
  • nNewHeight : XTP_NM_GRIDROWRESIZE
  • nNewWidth : XTP_NM_GRIDCOLUMNRESIZE
  • nNextBlockPos : XTP_EDIT_TEXTBLOCK
  • nOldLength : CXTPTrackControl::DRAGBLOCK
  • nOldPos : CXTPTrackControl::DRAGBLOCK
  • nPos : NMXTPSCROLL, XTP_EDIT_TEXTBLOCK, XTPPROGRESSDRAWSTRUCT
  • nPosition : XTP_NM_GRIDSCROLL
  • nPrevHeight : XTP_NM_GRIDROWRESIZE
  • nPrevWidth : XTP_NM_GRIDCOLUMNRESIZE
  • nPropertyCode : CXTPSkinManagerSchemaProperty
  • nReason : XTP_NM_GRIDCOLUMNORDERCHANGED
  • nRefCounter : XTP_EVENT_EDIT_OPERATION_PARAMS
  • nRepCnt : XTP_NM_GRIDPREVIEWKEYDOWN
  • nRow : CXTPDockingPaneWindowSelect::CItem, XTP_EDIT_NMHDR_MARGINCLICKED, XTP_EDIT_NMHDR_ROWCOLCHANGED, XTP_EDIT_SENMBOOKMARK, XTPGridInputState
  • nRow1 : XTP_EDIT_ROWCOLRECT
  • nRow2 : XTP_EDIT_ROWCOLRECT
  • nRowFrom : XTP_EDIT_NMHDR_EDITCHANGED
  • nRowTo : XTP_EDIT_NMHDR_EDITCHANGED
  • nSBCode : NMXTPSCROLL
  • nScore : XTP_TAGCLOUDTAG
  • nSection : XTP_NM_GRIDSCROLL
  • nSelStartTextRowFromLeftBar : CXTPSyntaxEditSelection
  • nStart : CXTPTaskDialogLinkCtrl::LINKITEM
  • nState : XTP_NM_GRIDDRAGDROP
  • nTargetRow : XTP_NM_GRIDDRAGDROP
  • nTextAlign : XTP_GRIDRECORDITEM_DRAWARGS
  • nTimeScale : XTP_CALENDAR_THEME_DAYVIEWTIMESCALECELL_PARAMS
  • nTransparency : CXTPPopupControl::POPUPSTATE
  • nType : XTP_NM_SELECTION_CHANGING
  • nVirtRowFlags : XTP_GRIDRECORDITEM_METRICS
  • nVirtRowLevel : XTP_GRIDRECORDITEM_METRICS
  • nWeekDay : XTP_CALENDAR_GETITEMTEXT_PARAMS
  • nWeekDayIndex : XTP_CALENDAR_MONTHVIEW_DAYPOS
  • nWeekIndex : XTP_CALENDAR_MONTHVIEW_DAYPOS
  • nWeekNum : XTP_CALENDAR_GETITEMTEXT_PARAMS
  • nWhichDay : XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_MONTHNTH, XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_YEARNTH
  • nWhichDayMask : XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_MONTHNTH, XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_YEARNTH
  • nWidth : CXTPStatusBarSwitchPane::SWITCH
  • nWorkWeekMask : CXTPCalendarEventRecurrenceDlg, CXTPCalendarOptions


Toolkit Pro: Class Members - Variables

Here is a list of all documented variables with links to the class documentation for each member:

- p -

  • p_sColorScheme : CXTPSyntaxEditConfigurationManager
  • p_sSyntaxScheme : CXTPSyntaxEditConfigurationManager
  • page : XTP_SCROLLBAR_POSINFO
  • parStrings : XTP_NM_GRID_BEFORE_COPYPASTE
  • pBlock : CXTPTrackControl::DRAGBLOCK, XTP_NM_TRACKCONTROL
  • pButton : XTP_NM_GRIDINPLACEBUTTON
  • pColumn : XTP_GRIDRECORDITEM_ARGS, XTP_NM_GRIDCOLUMNORDERCHANGED, XTP_NM_GRIDCOLUMNRESIZE, XTP_NM_GRIDRECORDITEM
  • pCommandBar : XTP_COMMANDBARS_CREATEBAR, XTP_COMMANDBARS_CREATECONTROL
  • pCommandBars : XTP_COMMANDBARS_PROPEXCHANGE_PARAM
  • pConnection : CXTPNotifySinkBase::ADVISE_DESCRIPTOR, XTP_NM_FLOWGRAPH_CONNECTIONCHANGED, XTP_NM_FLOWGRAPH_CONNECTIONCHANGING
  • pConstraint : XTP_NM_GRIDCONSTRAINTSELECTING
  • pContainer : XTP_DOCKINGPANE_CLICK
  • pControl : NMXTPCONTROL, XTP_COMMANDBARS_CREATECONTROL, XTP_GRIDRECORDITEM_ARGS
  • pControls : XTP_COMMANDBARS_CATEGORYINFO
  • pcszInitialSubject : XTP_EVENT_IN_PLACE_CREATE_EVENT_OPERATION_PARAMS
  • pDataObject : XTP_NM_GRIDDRAGDROP
  • pDataSource : XTP_NM_GRIDDRAGDROP
  • pDC : XTP_GRIDRECORDITEM_DRAWARGS, XTPPROGRESSDRAWSTRUCT
  • pDockContainer : XTP_DOCKINGPANE_ACTION
  • pDockingHolder : XTP_DOCKINGPANE_INFO
  • pDraggingEvent : XTP_EVENT_DRAG_OPERATION_PARAMS
  • pDraggingEventNew : XTP_EVENT_DRAG_OPERATION_PARAMS
  • pDraggingEventOriginal : XTP_EVENT_DRAG_OPERATION_PARAMS
  • pDrawArgs : XTP_NM_GRIDITEMMETRICS
  • pEvent : XTP_EVENT_PASTE_OPERATION_PARAMS
  • pEventViews : XTP_EVENT_EDIT_OPERATION_PARAMS
  • pFloatingHolder : XTP_DOCKINGPANE_INFO
  • pFont : XTP_GRIDRECORDITEM_METRICS, XTPPROGRESSDRAWSTRUCT
  • pFrom : CXTPFlowGraphPageHistoryItem
  • pGroup : XTP_TPNGROUPEXPANDING
  • pGroupCaption : CXTPTaskPanelScrollButton
  • pGroupScroll : CXTPTaskPanelScrollButton
  • pInputConnectionPoint : XTP_NM_FLOWGRAPH_CONNECTIONCHANGING
  • pItem : CXTPControlGallery::GALLERYITEM_POSITION, XTP_GRIDRECORDITEM_ARGS, XTP_NM_FLOWGRAPH_ENDLABELEDIT, XTP_NM_GRIDRECORDITEM, XTP_PROPERTYGRID_NOTIFYEDIT, XTP_TPNENDLABELEDIT
  • pItemControl : XTP_NM_GRIDITEMCONTROL
  • pItemMetrics : XTP_NM_GRIDITEMMETRICS
  • pLastHolder : XTP_DOCKINGPANE_INFO
  • pMarker : XTP_NM_TRACKCONTROL
  • pMenu : XTP_COMMANDBARS_CREATECONTROL
  • pNewMatrix : CXTPMarkupVisual::TransformationMatrices
  • pNode : XTP_NM_FLOWGRAPH_NODECHANGED
  • pOldMatrix : CXTPMarkupVisual::TransformationMatrices
  • pos : XTP_SCROLLBAR_POSINFO
  • Pos1 : XTP_EDIT_LINECOL
  • posMax : XTP_SCROLLBAR_POSINFO
  • posMin : XTP_SCROLLBAR_POSINFO
  • posNew : XTP_SCROLLBAR_TRACKINFO
  • posOld : XTP_SCROLLBAR_TRACKINFO
  • pPane : XTP_DOCKINGPANE_ACTION, XTP_DOCKINGPANE_CLICK, XTP_DOCKINGPANE_INFO
  • ppRecord : XTP_NM_GRID_BEFORE_COPYPASTE
  • pRecords : XTP_NM_GRIDDRAGDROP
  • pResource : XTP_IMAGERESOURCE_INFO
  • propType : CXTPSkinManagerSchemaProperty
  • pRow : XTP_GRIDRECORDITEM_ARGS, XTP_NM_GRIDRECORDITEM, XTP_NM_GRIDROWRESIZE, XTP_NM_SELECTION_CHANGING
  • pSBInfo : XTP_SCROLLBAR_TRACKINFO
  • pSender : NMXTPSCROLL
  • pSink : CXTPNotifyConnection::CONNECTION_DESCRIPTOR
  • pstrText : XTP_CALENDAR_GETITEMTEXT_PARAMS, XTP_NM_GRIDTOOLTIPINFO
  • pt : XTP_CALENDAR_HITTESTINFO, XTP_DOCKINGPANE_CLICK, XTP_NM_GRIDDRAGDROP, XTP_NM_GRIDRECORDITEM
  • pTab : NMXTPTABCHANGE
  • pTargetRecord : XTP_NM_GRIDDRAGDROP
  • ptClient : XTP_GRIDRECORDITEM_CLICKARGS
  • pTicks : XTP_SLIDERTICKS
  • ptMouse : XTPGridInputState
  • pTo : CXTPFlowGraphPageHistoryItem
  • pViewDay : XTP_CALENDAR_GETITEMTEXT_PARAMS, XTP_CALENDAR_HITTESTINFO, XTP_CALENDAR_USERACTION_PARAMS::EXPANDDAYBUTTONACTION_PARAMS
  • pViewEvent : XTP_CALENDAR_GETITEMTEXT_PARAMS, XTP_CALENDAR_HITTESTINFO
  • pViewGroup : XTP_CALENDAR_HITTESTINFO, XTP_CALENDAR_THEME_DAYVIEWCELL_PARAMS, XTP_CALENDAR_USERACTION_PARAMS::SCROLLDAYBUTTONACTION_PARAMS
  • pWnd : CXTPTcbItem
  • pWndCtrl : XTPPROGRESSDRAWSTRUCT
  • pxBottom : XTP_SCROLLBAR_POSINFO
  • pxDownArrow : XTP_SCROLLBAR_POSINFO
  • pxLeft : XTP_SCROLLBAR_POSINFO
  • pxMin : XTP_SCROLLBAR_POSINFO
  • pxOld : XTP_SCROLLBAR_TRACKINFO
  • pxPopup : XTP_SCROLLBAR_POSINFO
  • pxRight : XTP_SCROLLBAR_POSINFO
  • pxStart : XTP_SCROLLBAR_POSINFO
  • pxThumbBottom : XTP_SCROLLBAR_POSINFO
  • pxThumbTop : XTP_SCROLLBAR_POSINFO
  • pxTop : XTP_SCROLLBAR_POSINFO
  • pxUpArrow : XTP_SCROLLBAR_POSINFO


Toolkit Pro: Class Members - Variables

Here is a list of all documented variables with links to the class documentation for each member:

- r -

  • range : XTPPROGRESSDRAWSTRUCT
  • rc : CXTPDockingPaneWindowSelect::CItem, XTP_IMAGERESOURCE_INFO, XTP_SCROLLBAR_POSINFO
  • rcBookmark : XTP_EDIT_SENMBOOKMARK
  • rcBorder : CXTPColorSelectorCtrl::COLOR_CELL
  • rcButton : CXTPTaskPanelScrollButton
  • rcClient : XTPPROGRESSDRAWSTRUCT
  • rcCollMark : XTP_EDIT_COLLAPSEDBLOCK
  • rcExclude : XTP_DOCKINGPANE_CLICK
  • rcItem : CXTPControlGallery::GALLERYITEM_POSITION, XTP_GRIDRECORDITEM_ARGS, XTP_TAGCLOUDTAG
  • rcOrigin : CXTPTrackControl::DRAGBLOCK
  • rcPopup : CXTPPopupControl::POPUPSTATE
  • rcTrack : XTP_SCROLLBAR_TRACKINFO
  • rcVal : CXTPSkinManagerSchemaProperty
  • rect : CXTPColorSelectorCtrl::COLOR_CELL
  • rectDefault : CXTPTaskPanelPaintManager
  • res : XTP_URI
  • reserved : XTP_URI
  • right : XTP_RESIZERECT
  • roof : CXTPColorHex::CRgnCell::CTX_DATA::HEXAGON_DATA


Toolkit Pro: Class Members - Variables

Here is a list of all documented variables with links to the class documentation for each member:

- s -

  • s_bSendContextMenuForWholeHeaderArea : CXTPGridHeader
  • s_bShowItemsInGroupsPXDefault : CXTPGridHeader
  • s_bVarMapInitialized : CXTPSyntaxEditLexVariable
  • s_mapVar2ID : CXTPSyntaxEditLexVariable
  • s_nExpandDelay : CXTPCommandBar
  • s_nExpandHoverDelay : CXTPCommandBar
  • s_nHoverDelay : CXTPCommandBar
  • s_nMinAutoScrollStep : CXTPGridHeader
  • side : CXTPColorHex::CRgnCell::CTX_DATA::HEXAGON_DATA
  • sm : CXTPColorHex::CRgnCell::CTX_DATA
  • StandardBias : CXTPCalendarTimeZones::REGISTRY_TIMEZONE_INFORMATION
  • StandardDate : CXTPCalendarTimeZones::REGISTRY_TIMEZONE_INFORMATION
  • strAM : CXTPCalendarView::SEventTimeFormatInfo
  • strCaption : XTP_COMMANDBARS_CREATECONTROL
  • strCategory : XTP_COMMANDBARS_CATEGORYINFO
  • strCollapsedText : XTP_EDIT_ROWSBLOCK
  • strDayView_AdditionalScaleLabel : CXTPCalendarOptions
  • strDayView_ScaleLabel : CXTPCalendarOptions
  • strFormat : CXTPCalendarView::SEventTimeFormatInfo
  • StripColor : CXTPChartAxisAppearance
  • StripColor2 : CXTPChartAxisAppearance
  • strItem : CXTPSortClass::ITEMDATA, XTP_TAGCLOUDTAG
  • strLabel : CXTPTaskDialogLinkCtrl::LINKITEM
  • strMessage : XTP_GRIDDATAMANAGER_COM_ERROR
  • strNewString : XTP_NM_FLOWGRAPH_ENDLABELEDIT, XTP_TPNENDLABELEDIT
  • strPM : CXTPCalendarView::SEventTimeFormatInfo
  • strSource : XTP_GRIDDATAMANAGER_COM_ERROR
  • strText : XTP_GRIDRECORDITEM_METRICS, XTPPROGRESSDRAWSTRUCT
  • strToolTip : CXTPStatusBarSwitchPane::SWITCH
  • strTooltipAddNewText : CXTPCalendarOptions
  • strUrl : CXTPTaskDialogLinkCtrl::LINKITEM
  • strValue : XTP_PROPERTYGRID_NOTIFYEDIT
  • szCondensedLabel : CXTPTcbItem
  • szFilePath : XTP_URI
  • szIcons : CXTPCommandBarsOptions
  • szLargeIcons : CXTPCommandBarsOptions
  • szPopupIcons : CXTPCommandBarsOptions
  • szTabLabel : CXTPTcbItem
  • szText : CXTPColorSelectorCtrl::COLOR_CELL
  • szTip : XTP_PICK_BUTTON
  • szToolTipLabel : CXTPTcbItem
  • szVal : CXTPSkinManagerSchemaProperty


Toolkit Pro: Class Members - Variables

Here is a list of all documented variables with links to the class documentation for each member:

- t -

  • TextColor : CXTPChartLegendAppearance
  • toolTipID : XTP_PICK_BUTTON
  • top : XTP_RESIZERECT
  • type : CXTPDockingPaneWindowSelect::CItem, XTP_URI
  • tziDayView_AdditionalScaleTimeZone : CXTPCalendarOptions


Toolkit Pro: Class Members - Variables

Here is a list of all documented variables with links to the class documentation for each member:

- u -

  • uHitCode : XTP_CALENDAR_HITTESTINFO
  • uiToolTipId : CXTPTcbItem
  • ulAttribs : XTP_LVITEMDATA
  • UpColor : CXTPChartFinanceStyleAppearance


Toolkit Pro: Class Members - Variables

Here is a list of all documented variables with links to the class documentation for each member:

- w -

  • Width : CXTPRectT< T >, CXTPSizeT< T >
  • width : CXTPColorHex::CRgnCell::CTX_DATA::HEXAGON_DATA
  • wLanguage : XTP_RESOURCEMANAGER_LANGINFO
  • wParam : XTP_EDIT_NMHDR_PARSEEVENT
  • wParam1 : XTP_CALENDAR_WPARAM2
  • wParam2 : XTP_CALENDAR_WPARAM2


Toolkit Pro: Class Members - Variables

Here is a list of all documented variables with links to the class documentation for each member:

- x -

  • X : CXTPPoint2T< T >, CXTPPoint3T< T >, CXTPRectT< T >
  • x : XTP_RESIZEPOINT
  • xtpFont : CXTPAuxData
  • xtpFontBold : CXTPAuxData
  • xtpFontIconTitle : CXTPAuxData
  • xtpFontIconTitleBold : CXTPAuxData
  • xtpFontMarlettIcon : CXTPAuxData
  • xtpFontSmCaption : CXTPAuxData
  • xtpFontStatus : CXTPAuxData
  • xtpFontULine : CXTPAuxData
  • xtpFontVert : CXTPAuxData
  • xtpFontVertBold : CXTPAuxData


Toolkit Pro: Class Members - Variables

Here is a list of all documented variables with links to the class documentation for each member:

- y -

  • Y : CXTPPoint2T< T >, CXTPPoint3T< T >, CXTPRectT< T >
  • y : XTP_RESIZEPOINT


Toolkit Pro: Class Members - Variables

Here is a list of all documented variables with links to the class documentation for each member:

- z -

  • Z : CXTPPoint3T< T >


Toolkit Pro: Class Members - Typedefs

Here is a list of all documented typedefs with links to the class documentation for each member:

- c -

  • CColorCellList : CXTPColorSelectorCtrl
  • CColorFontMap : CXTPTreeBase
  • CContentItemList : CXTPShortcutListBox
  • CIconSetMap : CXTPImageManagerIconSet
  • CLineMarksListPtr : CXTPSyntaxEditLineMarksManager
  • CListenerArray : CXTPColorSelectorCtrl
  • CreateProc : CXTPThreadLocal< T >
  • Creator : CXTPSingletonPointer
  • CResizeItemArray : CXTPResize
  • CRgnCellList : CXTPColorHex
  • CRowColorList : CXTPListBase
  • CToolBarArray : CXTPDockBar

- d -

  • Destroyer : CXTPSingletonPointer
  • DestroyProc : CXTPThreadLocal< T >

- i -

  • Initializer : CXTPSingletonPointer

- l -

  • LPFNANIMATION : CXTPAnimationDC
  • LPFNUPDATELAYEREDWINDOW : CXTPMiniToolBar

- p -

  • PFNGETSYSCOLOR : CXTPColorManager
  • PFNSETLAYEREDWINDOWATTRIBUTES : CXTPMiniToolBar
  • PointList : CXTPChart3dBox

- t -

  • T_CompareFunc : CXTPCalendarEvents
  • TBase : CXTPCalendarDayView, CXTPCalendarDayViewDay, CXTPCalendarDayViewEvent, CXTPCalendarDayViewGroup, CXTPCalendarMonthView, CXTPCalendarMonthViewDay, CXTPCalendarMonthViewEvent, CXTPCalendarMonthViewGroup, CXTPCalendarTimeLineView, CXTPCalendarTimeLineViewGroup, CXTPCalendarTypedPtrAutoDeleteArray< BASE_CLASS, PTR_TYPE >, CXTPCalendarWeekView, CXTPCalendarWeekViewDay, CXTPCalendarWeekViewEvent, CXTPCalendarWeekViewGroup, CXTPSyntaxEditLexClass
  • TObject : CXTPInternalCollectionT< _TObject >
  • TObjectPtr : CXTPCalendarPtrCollectionT< _TObject >, CXTPInternalCollectionT< _TObject >
  • TObjPtr : CXTPCalendarData::EventsMapByID_T< _TObject >
  • Tthis : CXTPSmartPtrInternalT< _TObject >
  • TView : CXTPCalendarViewDayT< _TView, _TViewGroup, XTP_CALENDAR_HITTESTINFO, _TPThis >
  • TViewDay : CXTPCalendarViewGroupT< _TViewDay, _TViewEvent, _TPThis >
  • TViewEventsCollection : CXTPCalendarTimeLineViewGroup


Toolkit Pro: Class Members - Enumerations

Here is a list of all documented enums with links to the class documentation for each member:
  • DatePickerMouseMode : CXTPDatePickerControl
  • EditMode : CXTPHexEdit
  • EnumParams : CXTPCalendarMsgNotifier
  • EventType : CXTPCalendarReminder
  • FocusedControl : CXTPColorBase
  • GridDraggingMode : CXTPGridHeader
  • GridUnitType : CXTPMarkupGridLength
  • ItemType : CXTPDockingPaneWindowSelect
  • ScrollBarStyle : CXTPShellExplorerProvider
  • Units : CXTPSvgImage
  • XTPBorderPart : CXTPRibbonMarkupFrameTheme
  • XTPEnumCalendarDataProviderFlags : CXTPCalendarResourcesManager
  • XTPEnumEventGlyphs : CXTPCalendarPaintManager
  • XTPEnumExpandSigns : CXTPCalendarPaintManager
  • XTPModuleState : CXTPModuleHandle
  • XTPScrolDirection : CXTPSyntaxEditCtrl
  • XTPSyntaxEditCfgObjects : CXTPSyntaxEditConfigurationManager
  • XTPSyntaxEditLexVarFlags : CXTPSyntaxEditLexVariable
  • XTPSyntaxEditLexVarID : CXTPSyntaxEditLexVariable
  • XTPSyntaxEditUpdateTBRes : CXTPSyntaxEditLexTextSchema


Toolkit Pro: Class Members - Enumerator

Here is a list of all documented enum values with links to the class documentation for each member:

- a -

  • AlphaMask : CXTPChartColor
  • AlphaShift : CXTPChartColor

- b -

  • BlueMask : CXTPChartColor
  • BlueShift : CXTPChartColor

- d -

  • dragFieldChooser : CXTPGridHeader
  • dragInGroupBox : CXTPGridHeader
  • dragInHeader : CXTPGridHeader
  • dragInTarget : CXTPGridHeader
  • dragNothing : CXTPGridHeader
  • dragOutTarget : CXTPGridHeader

- e -

  • editAscii : CXTPHexEdit
  • editHigh : CXTPHexEdit
  • editLow : CXTPHexEdit
  • editNone : CXTPHexEdit
  • evtNormal : CXTPCalendarReminder
  • evtRecurrence : CXTPCalendarReminder

- f -

  • focusColorWheel : CXTPColorBase
  • focusLumination : CXTPColorBase
  • focusNone : CXTPColorBase

- g -

  • GreenMask : CXTPChartColor
  • GreenShift : CXTPChartColor

- i -

  • IDD : CXTPCustomizeKeyboardPage, CXTPCustomizeOptionsPage, CXTPCustomizeToolbarsPage, CXTPImageEditorDlg
  • idxExpandSignDown : CXTPCalendarPaintManager
  • idxExpandSignUp : CXTPCalendarPaintManager
  • idxMeeting : CXTPCalendarPaintManager
  • idxPrivate : CXTPCalendarPaintManager
  • idxRecurrenceException : CXTPCalendarPaintManager
  • idxRecurrenceOccurrence : CXTPCalendarPaintManager
  • idxReminder : CXTPCalendarPaintManager
  • itemMDIFrame : CXTPDockingPaneWindowSelect
  • itemPane : CXTPDockingPaneWindowSelect
  • itemSDIFrame : CXTPDockingPaneWindowSelect

- m -

  • mouseDeselecting : CXTPDatePickerControl
  • mouseNothing : CXTPDatePickerControl
  • mouseScrollingLeft : CXTPDatePickerControl
  • mouseScrollingRight : CXTPDatePickerControl
  • mouseSelecting : CXTPDatePickerControl
  • mouseTrackingHeaderList : CXTPDatePickerControl
  • msgAll : CXTPCalendarMsgNotifier

- r -

  • RedMask : CXTPChartColor
  • RedShift : CXTPChartColor

- u -

  • unitCM : CXTPSvgImage
  • unitEM : CXTPSvgImage
  • unitEX : CXTPSvgImage
  • unitIN : CXTPSvgImage
  • unitMM : CXTPSvgImage
  • unitPC : CXTPSvgImage
  • unitPercent : CXTPSvgImage
  • unitPT : CXTPSvgImage
  • unitPX : CXTPSvgImage
  • unitTypeAuto : CXTPMarkupGridLength
  • unitTypePixel : CXTPMarkupGridLength
  • unitTypeStar : CXTPMarkupGridLength

- x -

  • xtpBorderPartBottom : CXTPRibbonMarkupFrameTheme
  • xtpBorderPartCount : CXTPRibbonMarkupFrameTheme
  • xtpBorderPartLeft : CXTPRibbonMarkupFrameTheme
  • xtpBorderPartLeftCaption : CXTPRibbonMarkupFrameTheme
  • xtpBorderPartRight : CXTPRibbonMarkupFrameTheme
  • xtpBorderPartRightCaption : CXTPRibbonMarkupFrameTheme
  • xtpBorderPartTop : CXTPRibbonMarkupFrameTheme
  • xtpBottom : CXTPSyntaxEditCtrl
  • xtpCalendarDPF_CloseOnDestroy : CXTPCalendarResourcesManager
  • xtpCalendarDPF_CreateIfNotExists : CXTPCalendarResourcesManager
  • xtpCalendarDPF_SaveOnDestroy : CXTPCalendarResourcesManager
  • xtpCalendarDPFUnknown : CXTPCalendarResourcesManager
  • xtpEditCfgObjMainConfig : CXTPSyntaxEditConfigurationManager
  • xtpEditCfgObjSchMan : CXTPSyntaxEditConfigurationManager
  • xtpEditCfgObjThemeMan : CXTPSyntaxEditConfigurationManager
  • xtpEditUTBError : CXTPSyntaxEditLexTextSchema
  • xtpEditUTBNearestUpdated : CXTPSyntaxEditLexTextSchema
  • xtpEditUTBNothing : CXTPSyntaxEditLexTextSchema
  • xtpEditUTBReparse : CXTPSyntaxEditLexTextSchema
  • xtpEditVarfNot : CXTPSyntaxEditLexVariable
  • xtpEditVarID_alpha : CXTPSyntaxEditLexVariable
  • xtpEditVarID_digit : CXTPSyntaxEditLexVariable
  • xtpEditVarID_EOL : CXTPSyntaxEditLexVariable
  • xtpEditVarID_HexDigit : CXTPSyntaxEditLexVariable
  • xtpEditVarID_specs : CXTPSyntaxEditLexVariable
  • xtpEditVarID_Unknown : CXTPSyntaxEditLexVariable
  • xtpLeft : CXTPSyntaxEditCtrl
  • xtpModLoaded : CXTPModuleHandle
  • xtpModMapped : CXTPModuleHandle
  • xtpModNone : CXTPModuleHandle
  • xtpRight : CXTPSyntaxEditCtrl
  • xtpScrollBarFlat : CXTPShellExplorerProvider
  • xtpScrollBarNone : CXTPShellExplorerProvider
  • xtpScrollBarStandard : CXTPShellExplorerProvider
  • xtpTop : CXTPSyntaxEditCtrl


Toolkit Pro: Class Members - Related Symbols

Here is a list of all documented related symbols with links to the class documentation for each member:
  • XTPAuxData : CXTPAuxData
  • XTPCalendarMsgNotifier : CXTPCalendarMsgNotifier
  • XTPGetApplication : CXTPApplication
  • XTPHookManager : CXTPHookManager
  • XTPImageManager : CXTPImageManager
  • XTPInitialize : CXTPApplication
  • XTPMultiMonitor : CXTPMultiMonitor
  • XTPPaintManager : CXTPPaintManager
  • XTPShutdown : CXTPApplication
  • XTPSkinManager : CXTPSkinManager
  • XTPSoundManager : CXTPSoundManager
  • XTPSystemVersion : CXTPSystemVersion
  • XTPTabCloudStyleManager : CXTPTagCloudStyleManager
  • XTPThemeDLL : CXTPThemeDLL


Toolkit Pro: File List

File List
Here is a list of all documented files with brief descriptions:
[detail level 12345678]
▼ Source
► Calendar
► CaptionBar
► Themes
XTPCalendarCaptionBarNativeWindows10Theme.h
XTPCalendarCaptionBarNativeWindows11Theme.h
XTPCalendarCaptionBarOffice2000Theme.h
XTPCalendarCaptionBarOffice2003Theme.h
XTPCalendarCaptionBarOffice2013Theme.h
XTPCalendarCaptionBarOfficeXPTheme.h
XTPCalendarCaptionBarResourceTheme.h
XTPCalendarCaptionBarVisualStudio2015Theme.h
XTPCalendarCaptionBarVisualStudio2017Theme.h
XTPCalendarCaptionBarVisualStudio2019Theme.h
XTPCalendarCaptionBarVisualStudio2022Theme.h
XTPCalendarCaptionBarControl.h
XTPCalendarCaptionBarPaintManager.h
XTPCalendarCaptionBarTheme.h
XTPCalendarCaptionBarThemePart.h
► DatePicker
► Themes
XTPDatePickerNativeWindows10Theme.h
XTPDatePickerNativeWindows11Theme.h
XTPDatePickerOffice2000Theme.h
XTPDatePickerOffice2003Theme.h
XTPDatePickerOffice2013Theme.h
XTPDatePickerOfficeXPTheme.h
XTPDatePickerResourceTheme.h
XTPDatePickerVisualStudio2015Theme.h
XTPDatePickerVisualStudio2017Theme.h
XTPDatePickerVisualStudio2019Theme.h
XTPDatePickerVisualStudio2022Theme.h
XTPDatePickerControl.h
XTPDatePickerDaysCollection.h
XTPDatePickerItemDay.h
XTPDatePickerItemMonth.h
XTPDatePickerList.h
XTPDatePickerNotifications.h
XTPDatePickerPaintManager.h
► Themes
XTPCalendarNativeWindows10Theme.h
XTPCalendarNativeWindows11Theme.h
XTPCalendarOffice2000Theme.h
XTPCalendarOffice2003Theme.h
XTPCalendarOffice2013Theme.h
XTPCalendarOfficeXPTheme.h
XTPCalendarResourceTheme.h
XTPCalendarVisualStudio2015Theme.h
XTPCalendarVisualStudio2017Theme.h
XTPCalendarVisualStudio2019Theme.h
XTPCalendarVisualStudio2022Theme.h
XTPCalendarADO.h
XTPCalendarControl.h
XTPCalendarController.h
XTPCalendarControlView.h
XTPCalendarCustomDataProvider.h
XTPCalendarCustomProperties.h
XTPCalendarData.h
XTPCalendarDatabaseDataProvider.h
XTPCalendarDayView.h
XTPCalendarDayViewDay.h
XTPCalendarDayViewEvent.h
XTPCalendarDayViewTimeScale.h
XTPCalendarDefines.h
XTPCalendarEvent.h
XTPCalendarEventColorDlg.h
XTPCalendarEventColorListBox.h
XTPCalendarEventColorNewDlg.h
XTPCalendarEventLabel.h
XTPCalendarEventPropertiesDlg.h
XTPCalendarEventRecurrenceDlg.h
XTPCalendarEvents.h
XTPCalendarIIDs.h
XTPCalendarMAPIDataProvider.h
XTPCalendarMAPIWrapper.h
XTPCalendarMemoryDataProvider.h
XTPCalendarMonthView.h
XTPCalendarMonthViewDay.h
XTPCalendarMonthViewEvent.h
XTPCalendarMsgNotifier.h
XTPCalendarNotifications.h
XTPCalendarOccurSeriesChooseDlg.h
XTPCalendarOptions.h
XTPCalendarPaintManager.h
XTPCalendarPtrCollectionT.h
XTPCalendarRecurrencePattern.h
XTPCalendarRemindersDialog.h
XTPCalendarRemindersManager.h
XTPCalendarResource.h
XTPCalendarResourcesManager.h
XTPCalendarShadowDrawer.h
XTPCalendarTheme.h
XTPCalendarThemeOffice2007.h
XTPCalendarThemePrevNextEventButton.h
XTPCalendarThemePrevNextEventButtons.h
XTPCalendarTimeLineView.h
XTPCalendarTimeLineViewGroup.h
XTPCalendarTimeLineViewTimeScale.h
XTPCalendarTimeZoneHelper.h
XTPCalendarTip.h
XTPCalendarUtils.h
XTPCalendarView.h
XTPCalendarViewDay.h
XTPCalendarViewEvent.h
XTPCalendarViewPart.h
XTPCalendarWeekView.h
XTPCalendarWeekViewDay.h
XTPCalendarWeekViewEvent.h
► Chart
► Appearance
XTPChartAppearance.h
XTPChartBorder.h
XTPChartFillStyle.h
XTPChartLineStyle.h
XTPChartPalette.h
► Diagram
► Axis
XTPChartAxis.h
XTPChartAxisConstantLines.h
XTPChartAxisCustomLabels.h
XTPChartAxisGridLines.h
XTPChartAxisLabel.h
XTPChartAxisRange.h
XTPChartAxisStrips.h
XTPChartAxisTickMarks.h
XTPChartAxisTitle.h
XTPChartAxisView.h
XTPChartRadarAxis.h
XTPChartRadarAxisView.h
XTPChartRadarAxisXView.h
XTPChartRadarAxisYView.h
XTPChartScaleTypeMap.h
► Diagram2D
XTPChartDiagram2D.h
XTPChartDiagram2DPane.h
XTPChartDiagram2DSeriesLabel.h
XTPChartDiagram2DSeriesStyle.h
XTPChartDiagram2DSeriesView.h
XTPChartDiagram2DView.h
► RadarDiagram
XTPChartRadarDiagram.h
XTPChartRadarDiagramSeriesStyle.h
XTPChartRadarDiagramSeriesView.h
XTPChartRadarDiagramView.h
► Drawing
► Gdi
XTPChartGdiCircleDeviceCommand.h
XTPChartGdiDeviceContext.h
XTPChartGdiLineDeviceCommand.h
XTPChartGdiPieDeviceCommand.h
XTPChartGdiPolygonDeviceCommand.h
XTPChartGdiRectangleDeviceCommand.h
XTPChartGdiTextDeviceCommand.h
XTPChartGdiTransformationDeviceCommand.h
► OpenGL
XTPChartOpenGLBackgroundColorDeviceCommand.h
XTPChartOpenGLCameraDeviceCommand.h
XTPChartOpenGLDebugDeviceCommands.h
XTPChartOpenGLDeviceContext.h
XTPChartOpenGLLineDeviceCommand.h
XTPChartOpenGLShadeModelDeviceCommand.h
XTPChartOpenGLTransformationDeviceCommand.h
XTPChart3dDeviceContext.h
XTPChartCircleDeviceCommand.h
XTPChartDeviceCommand.h
XTPChartDeviceContext.h
XTPChartDrawingObjectFactory.h
XTPChartDrawThread.h
XTPChartLineDeviceCommand.h
XTPChartPieDeviceCommand.h
XTPChartPolygonDeviceCommand.h
XTPChartRectangleDeviceCommand.h
XTPChartTextDeviceCommand.h
XTPChartTransformationDeviceCommand.h
► Styles
► Area
XTPChartAreaSeriesStyle.h
XTPChartAreaSeriesView.h
XTPChartRangeAreaSeriesLabel.h
XTPChartRangeSplineAreaSeriesStyle.h
XTPChartSplineAreaSeriesStyle.h
XTPChartStackedAreaSeriesStyle.h
XTPChartStackedSplineAreaSeriesStyle.h
XTPChartStepAreaSeriesStyle.h
► Bar
XTPChartBarSeriesErrorBar.h
XTPChartBarSeriesLabel.h
XTPChartBarSeriesStyle.h
XTPChartBarSeriesView.h
XTPChartStackedBarSeriesStyle.h
► Financial
XTPChartCandleStickSeriesStyle.h
XTPChartHighLowSeriesStyle.h
► Funnel
► 2D
XTPChart2dFunnelDiagram.h
XTPChart2dFunnelDiagramView.h
XTPChart2dFunnelSeriesLabel.h
XTPChart2dFunnelSeriesPointView.h
XTPChart2dFunnelSeriesStyle.h
XTPChart2dFunnelSeriesView.h
► 3D
► Commands
► OpenGL
XTPChartOpenGLFunnelDeviceCommand.h
XTPChart3dFunnelDeviceCommandEvents.h
XTPChart3dFunnelSeriesLabelsViewDeviceCommand.h
XTPChart3dFunnelDiagram.h
XTPChart3dFunnelDiagramView.h
XTPChart3dFunnelSeriesLabel.h
XTPChart3dFunnelSeriesPointView.h
XTPChart3dFunnelSeriesStyle.h
XTPChart3dFunnelSeriesView.h
► Base
XTPChartFunnelDiagramBase.h
XTPChartFunnelSeriesLabelBase.h
XTPChartFunnelSeriesPointViewBase.h
XTPChartFunnelSeriesStyleBase.h
XTPChartFunnelSeriesViewBase.h
XTPChartFunnelDiagram.h
XTPChartFunnelDiagramView.h
XTPChartFunnelSeriesLabel.h
XTPChartFunnelSeriesPointView.h
XTPChartFunnelSeriesStyle.h
XTPChartFunnelSeriesView.h
► Line
XTPChartFastLineSeriesStyle.h
XTPChartLineSeriesErrorBar.h
XTPChartLineSeriesStyle.h
XTPChartLineSeriesView.h
XTPChartScatterLineSeriesStyle.h
XTPChartSplineSeriesStyle.h
XTPChartStepLineSeriesStyle.h
► Pie
► 2D
XTPChart2dPieDiagram.h
XTPChart2dPieDiagramView.h
XTPChart2dPieSeriesLabel.h
XTPChart2dPieSeriesPointView.h
XTPChart2dPieSeriesStyle.h
XTPChart2dPieSeriesView.h
► 3D
► Commands
► OpenGL
XTPChartOpenGLPieDeviceCommand.h
XTPChart3dPieDeviceCommandEvents.h
XTPChart3dPieSeriesLabelsViewDeviceCommand.h
XTPChart3dPieDiagram.h
XTPChart3dPieDiagramView.h
XTPChart3dPieSeriesLabel.h
XTPChart3dPieSeriesPointView.h
XTPChart3dPieSeriesStyle.h
XTPChart3dPieSeriesView.h
► Base
XTPChartPieDiagramBase.h
XTPChartPieSeriesLabelBase.h
XTPChartPieSeriesPointViewBase.h
XTPChartPieSeriesStyleBase.h
XTPChartPieSeriesViewBase.h
XTPChartPieDiagram.h
XTPChartPieDiagramView.h
XTPChartPieSeriesLabel.h
XTPChartPieSeriesPointView.h
XTPChartPieSeriesStyle.h
XTPChartPieSeriesView.h
► Point
XTPChartBubbleSeriesLabel.h
XTPChartBubbleSeriesStyle.h
XTPChartMarker.h
XTPChartPointSeriesErrorBar.h
XTPChartPointSeriesLabel.h
XTPChartPointSeriesLabelView.h
XTPChartPointSeriesStyle.h
XTPChartPointSeriesView.h
► Pyramid
► 2D
XTPChart2dPyramidDiagram.h
XTPChart2dPyramidDiagramView.h
XTPChart2dPyramidSeriesLabel.h
XTPChart2dPyramidSeriesPointView.h
XTPChart2dPyramidSeriesStyle.h
XTPChart2dPyramidSeriesView.h
► 3D
► Commands
► OpenGL
XTPChartOpenGLPyramidDeviceCommand.h
XTPChart3dPyramidDeviceCommandEvents.h
XTPChart3dPyramidSeriesLabelsViewDeviceCommand.h
XTPChart3dPyramidDiagram.h
XTPChart3dPyramidDiagramView.h
XTPChart3dPyramidSeriesLabel.h
XTPChart3dPyramidSeriesPointView.h
XTPChart3dPyramidSeriesStyle.h
XTPChart3dPyramidSeriesView.h
► Base
XTPChartPyramidDiagramBase.h
XTPChartPyramidSeriesLabelBase.h
XTPChartPyramidSeriesPointViewBase.h
XTPChartPyramidSeriesStyleBase.h
XTPChartPyramidSeriesViewBase.h
XTPChartPyramidDiagram.h
XTPChartPyramidDiagramView.h
XTPChartPyramidSeriesLabel.h
XTPChartPyramidSeriesPointView.h
XTPChartPyramidSeriesStyle.h
XTPChartPyramidSeriesView.h
► Radar
XTPChartRadarAreaSeriesStyle.h
XTPChartRadarAreaSeriesView.h
XTPChartRadarLineSeriesStyle.h
XTPChartRadarLineSeriesView.h
XTPChartRadarPointSeriesLabel.h
XTPChartRadarPointSeriesStyle.h
XTPChartRadarPointSeriesView.h
XTPChartRadarSplineAreaSeriesStyle.h
XTPChartRadarSplineSeriesStyle.h
► Range
XTPChartGanttSeriesStyle.h
XTPChartRangeBarSeriesLabel.h
XTPChartRangeBarSeriesStyle.h
XTPChartRangeBarSeriesView.h
► Types
► 2D
XTPChart2dPie.h
► 3D
XTPChart3dPie.h
XTPChartPie.h
XTPChartTypes.h
► Utils
XTPChartNumberFormat.h
XTPChartTextPainter.h
XTPChartContent.h
XTPChartContentView.h
XTPChartControl.h
XTPChartDefines.h
XTPChartDiagram.h
XTPChartDiagramView.h
XTPChartElement.h
XTPChartElementView.h
XTPChartErrorBar.h
XTPChartIIDs.h
XTPChartLegend.h
XTPChartLegendItem.h
XTPChartLegendView.h
XTPChartObjectFactory.h
XTPChartPanel.h
XTPChartSeries.h
XTPChartSeriesLabel.h
XTPChartSeriesPoint.h
XTPChartSeriesPointView.h
XTPChartSeriesStyle.h
XTPChartSeriesView.h
XTPChartTitle.h
XTPChartTitleView.h
XTPChartTrendline.h
► CommandBars
► ColorSets
XTPCommandBarsColorSetOffice2013.h
XTPCommandBarsColorSetVisualStudio2012.h
► Customize
XTPCustomizePageCommands.h
XTPCustomizePageKeyboard.h
XTPCustomizePageMenus.h
XTPCustomizePageOptions.h
XTPCustomizePageToolbars.h
XTPCustomizeSheet.h
XTPCustomizeTools.h
► Frame
XTPFrameHook.h
XTPFramePaintManager.h
XTPFrameThemeModernUI.h
XTPFrameThemeNativeWindows10.h
XTPFrameThemeNativeWindows11.h
XTPFrameThemeOffice2007.h
XTPFrameThemeOffice2007System.h
XTPFrameThemeOffice2013.h
XTPFrameThemeVisualStudio2012.h
XTPFrameThemeVisualStudio2015.h
XTPFrameThemeVisualStudio2017.h
XTPFrameThemeVisualStudio2019.h
XTPFrameThemeVisualStudio2022.h
► Gallery
XTPControlGalleryItem.h
XTPControlGalleryItems.h
XTPControlGalleryNativeWindows10Theme.h
XTPControlGalleryNativeWindows11Theme.h
XTPControlGalleryOffice2013Theme.h
XTPControlGalleryResourceTheme.h
XTPControlGalleryVisualStudio2015Theme.h
XTPControlGalleryVisualStudio2017Theme.h
XTPControlGalleryVisualStudio2019Theme.h
XTPControlGalleryVisualStudio2022Theme.h
XTPGalleryListBox.h
► MessageBar
XTPMessageBar.h
XTPMessageBarPaintManager.h
XTPMessageBarThemeNativeWindows10.h
XTPMessageBarThemeNativeWindows11.h
XTPMessageBarThemeOffice2003.h
XTPMessageBarThemeOffice2010.h
XTPMessageBarThemeOffice2013.h
XTPMessageBarThemeResource.h
XTPMessageBarThemeVisualStudio2015.h
XTPMessageBarThemeVisualStudio2017.h
XTPMessageBarThemeVisualStudio2019.h
XTPMessageBarThemeVisualStudio2022.h
► Progress
XTPProgressPaintManager.h
XTPProgressThemeNativeWindows10.h
XTPProgressThemeNativeWindows11.h
XTPProgressThemeOffice2013.h
XTPProgressThemeResource.h
XTPProgressThemeVisualStudio2015.h
XTPProgressThemeVisualStudio2017.h
XTPProgressThemeVisualStudio2019.h
XTPProgressThemeVisualStudio2022.h
XTPProgressThemeWindowsUx.h
► ScrollBar
XTPCommandBarScrollBarCtrl.h
► Slider
XTPSliderPaintManager.h
XTPSliderThemeNativeWindows10.h
XTPSliderThemeNativeWindows11.h
XTPSliderThemeOffice2007System.h
XTPSliderThemeOffice2013.h
XTPSliderThemeResource.h
XTPSliderThemeVisualStudio2015.h
XTPSliderThemeVisualStudio2017.h
XTPSliderThemeVisualStudio2019.h
XTPSliderThemeVisualStudio2022.h
► StatusBar
► Panes
XTPStatusBarPane.h
XTPStatusBarPaneProgress.h
XTPStatusBarPaneScrollBar.h
XTPStatusBarPaneSlider.h
XTPStatusBarPaneSwitch.h
XTPStatusBar.h
XTPStatusBarColorSet.h
XTPStatusBarPaintManager.h
XTPStatusBarThemeNativeWindows10.h
XTPStatusBarThemeNativeWindows11.h
XTPStatusBarThemeOffice2003.h
XTPStatusBarThemeOffice2013.h
XTPStatusBarThemeOfficeXP.h
XTPStatusBarThemeResource.h
XTPStatusBarThemeVisualStudio2010.h
XTPStatusBarThemeVisualStudio2012.h
XTPStatusBarThemeVisualStudio2015.h
XTPStatusBarThemeVisualStudio2017.h
XTPStatusBarThemeVisualStudio2019.h
XTPStatusBarThemeVisualStudio2022.h
► TabClient
XTPControlTabWorkspace.h
XTPTabClientContext.h
XTPTabClientDraggingContents.h
XTPTabClientSticker.h
XTPTearOffFrame.h
► Themes
XTPCommandBarsModernUITheme.h
XTPCommandBarsNativeWindows10Theme.h
XTPCommandBarsNativeWindows11Theme.h
XTPCommandBarsNativeXPTheme.h
XTPCommandBarsOffice2000Theme.h
XTPCommandBarsOffice2003Theme.h
XTPCommandBarsOffice2007SystemTheme.h
XTPCommandBarsOffice2013Theme.h
XTPCommandBarsOfficeXPTheme.h
XTPCommandBarsResourceTheme.h
XTPCommandBarsThemeMsMoney.h
XTPCommandBarsThemeRibbon.h
XTPCommandBarsVisualStudio2005Theme.h
XTPCommandBarsVisualStudio2008Theme.h
XTPCommandBarsVisualStudio2010Theme.h
XTPCommandBarsVisualStudio2012Theme.h
XTPCommandBarsVisualStudio2015Theme.h
XTPCommandBarsVisualStudio2017Theme.h
XTPCommandBarsVisualStudio2019Theme.h
XTPCommandBarsVisualStudio2022Theme.h
XTPCommandBarsVisualStudio6Theme.h
XTPCommandBar.h
XTPCommandBarAnimation.h
XTPCommandBarKeyboardTip.h
XTPCommandBarList.h
XTPCommandBars.h
XTPCommandBarsColorSet.h
XTPCommandBarsContextMenus.h
XTPCommandBarsDefines.h
XTPCommandBarsIIDs.h
XTPCommandBarsOptions.h
XTPControl.h
XTPControlButton.h
XTPControlComboBox.h
XTPControlComboBoxExt.h
XTPControlComboBoxGalleryPopupBar.h
XTPControlCustom.h
XTPControlEdit.h
XTPControlExt.h
XTPControlGallery.h
XTPControlListBox.h
XTPControlPopup.h
XTPControlPopupColor.h
XTPControlProgress.h
XTPControls.h
XTPControlScrollBar.h
XTPControlSlider.h
XTPDialogBar.h
XTPDialogBase.h
XTPDockBar.h
XTPDockContext.h
XTPDockState.h
XTPFrameWnd.h
XTPImageEditor.h
XTPKeyboardManager.h
XTPMenuBar.h
XTPMenuTitleBar.h
XTPMiniToolBar.h
XTPMouseManager.h
XTPPaintManager.h
XTPPopupBar.h
XTPPreviewView.h
XTPReBar.h
XTPRecentFileList.h
XTPShortcutManager.h
XTPTabClientWnd.h
XTPTabToolBar.h
XTPToolBar.h
► Common
► Base
► Diagnostic
XTPBeginAfxMap.h
XTPDisableAdvancedWarnings.h
XTPDisableNoisyWarnings.h
XTPEnableAdvancedWarnings.h
XTPEnableNoisyWarnings.h
XTPEndAfxMap.h
► Types
XTPPoint2.h
XTPPoint3.h
XTPRect.h
XTPSize.h
XTPWinApp.h
XTPWinThread.h
► Controls
► Progress
XTPProgressBase.h
► FrameShadow
XTPFrameShadow.h
XTPFrameShadowManager.h
► Hook
XTPWinEventHook.h
► IIDs
XTPColorManagerIIDs.h
XTPFrameShadowManagerIIDs.h
XTPImageManagerIIDs.h
XTPOleDragDropIIDs.h
XTPPrintingIIDs.h
XTPPropExchangeIIDs.h
XTPResourceImagesIIDs.h
XTPToolTipContextIIDs.h
► Math
XTPArcBall.h
XTPMathStats.h
XTPMathUtils.h
XTPMatrix.h
► PropExchange
XTPPropExchangeArchive.h
XTPPropExchangeEnumerator.h
XTPPropExchangeEnumeratorPtr.h
XTPPropExchangeIniFile.h
XTPPropExchangeRegistry.h
XTPPropExchangeSection.h
XTPPropExchangeXMLNode.h
► ScrollBar
► Themes
XTPScrollBarThemeFlat.h
XTPScrollBarThemeNativeWindows10.h
XTPScrollBarThemeNativeWindows11.h
XTPScrollBarThemeOffice2000.h
XTPScrollBarThemeOffice2003.h
XTPScrollBarThemeOffice2013.h
XTPScrollBarThemeOfficeXP.h
XTPScrollBarThemeResource.h
XTPScrollBarThemeUltraFlat.h
XTPScrollBarThemeVisualStudio2012.h
XTPScrollBarThemeVisualStudio2015.h
XTPScrollBarThemeVisualStudio2017.h
XTPScrollBarThemeVisualStudio2019.h
XTPScrollBarThemeVisualStudio2022.h
XTPScrollBarThemeWindowsClassic.h
XTPScrollBarThemeWindowsUx.h
XTPScrollable.h
XTPScrollBarContainer.h
XTPScrollBarCtrl.h
XTPScrollBarPaintManager.h
XTPScrollBase.h
XTPScrollInfo.h
XTPWnd.h
XTPActiveScriptEngine.h
XTPApplication.h
XTPColorManager.h
XTPCustomHeap.h
XTPDrawHelpers.h
XTPFontManager.h
XTPFramework.h
XTPGdiObjects.h
XTPHookManager.h
XTPImageList.h
XTPImageManager.h
XTPImageManagerResource.h
XTPMacros.h
XTPMarkupRender.h
XTPMarkupTheme.h
XTPMaskEditT.h
XTPNotifyConnection.h
XTPNumberFormat.h
XTPPropExchange.h
XTPRegExp.h
XTPResource.h
XTPResourceImage.h
XTPResourceImageList.h
XTPResourceManager.h
XTPRichRender.h
XTPSingleton.h
XTPSmartPtrInternalT.h
XTPSynchro.h
XTPSystemHelpers.h
XTPSystemMetrics.h
XTPTheme.h
XTPThemeDLL.h
XTPToolTipContext.h
XTPTypeId.h
XTPWinThemeWrapper.h
► Controls
► Button
► Themes
XTPButtonThemeFlat.h
XTPButtonThemeNativeWindows10.h
XTPButtonThemeNativeWindows11.h
XTPButtonThemeOffice2000.h
XTPButtonThemeOffice2003.h
XTPButtonThemeOffice2013.h
XTPButtonThemeOfficeXP.h
XTPButtonThemeResource.h
XTPButtonThemeUltraFlat.h
XTPButtonThemeVisualStudio2012.h
XTPButtonThemeVisualStudio2015.h
XTPButtonThemeVisualStudio2017.h
XTPButtonThemeVisualStudio2019.h
XTPButtonThemeVisualStudio2022.h
XTPButton.h
XTPButtonTheme.h
XTPColorPicker.h
► Combo
► Themes
XTPComboBoxThemeDefault.h
XTPComboBoxThemeNativeWindows10.h
XTPComboBoxThemeNativeWindows11.h
XTPComboBoxThemeOffice2000.h
XTPComboBoxThemeOffice2003.h
XTPComboBoxThemeOffice2013.h
XTPComboBoxThemeOfficeXPFlat.h
XTPComboBoxThemeResource.h
XTPComboBoxThemeVisualStudio.h
XTPComboBoxThemeVisualStudio2010.h
XTPComboBoxThemeVisualStudio2012.h
XTPComboBoxThemeVisualStudio2015.h
XTPComboBoxThemeVisualStudio2017.h
XTPComboBoxThemeVisualStudio2019.h
XTPComboBoxThemeVisualStudio2022.h
XTPComboBox.h
XTPComboBoxEditCtrl.h
XTPComboBoxTheme.h
XTPFontComboBox.h
XTPMarkupComboBox.h
► CoreTree
XTPCoreTreeControl.h
XTPCoreTreeItem.h
XTPCoreTreePaintManager.h
► Dialog
XTPBrowseDialog.h
XTPColorDialog.h
XTPColorPageCustom.h
XTPColorPageStandard.h
XTPDialogBase.h
XTPNewToolbarDlg.h
XTPPropertyPage.h
XTPPropertyPageNavigator.h
XTPPropertySheet.h
XTPTaskDialog.h
XTPTaskDialogAPI.h
XTPTaskDialogClient.h
XTPTaskDialogControls.h
XTPTaskDialogFrame.h
XTPTipOfTheDay.h
XTPWindowList.h
► Edit
► Themes
XTPEditThemeDefault.h
XTPEditThemeFlat.h
XTPEditThemeNativeWindows10.h
XTPEditThemeNativeWindows11.h
XTPEditThemeOffice2000.h
XTPEditThemeOffice2003.h
XTPEditThemeOffice2013.h
XTPEditThemeOfficeXP.h
XTPEditThemeResource.h
XTPEditThemeUltraFlat.h
XTPEditThemeVisualStudio2010.h
XTPEditThemeVisualStudio2012.h
XTPEditThemeVisualStudio2015.h
XTPEditThemeVisualStudio2017.h
XTPEditThemeVisualStudio2019.h
XTPEditThemeVisualStudio2022.h
XTPBrowseEdit.h
XTPEdit.h
XTPEditTheme.h
XTPHexEdit.h
XTPMaskEdit.h
XTPPasswordPeek.h
► Header
XTPHeaderCtrl.h
XTPHeaderCtrlTheme.h
► List
XTPListBase.h
XTPListCtrlView.h
XTPSortClass.h
► ListBox
► Themes
XTPListBoxThemeDefault.h
XTPListBoxThemeNativeWindows10.h
XTPListBoxThemeNativeWindows11.h
XTPListBoxThemeOffice2003.h
XTPListBoxThemeOffice2013.h
XTPListBoxThemeOfficeXP.h
XTPListBoxThemeResource.h
XTPListBoxThemeVisualStudio2015.h
XTPListBoxThemeVisualStudio2017.h
XTPListBoxThemeVisualStudio2019.h
XTPListBoxThemeVisualStudio2022.h
XTPCheckListBox.h
XTPEditListBox.h
XTPListBox.h
XTPMarkupListBox.h
XTPShortcutListBox.h
XTPShortcutListBoxTheme.h
► Popup
► Themes
XTPPopupThemeMSN.h
XTPPopupThemeOffice2000.h
XTPPopupThemeOffice2003.h
XTPPopupThemeOffice2013.h
XTPPopupThemeOfficeXP.h
XTPPopupThemeResource.h
XTPColorPopup.h
XTPColorSelectorCtrl.h
XTPPopupControl.h
XTPPopupItem.h
XTPPopupPaintManager.h
XTPTipWindow.h
► Preview
► Providers
► CommonPicture
XTPCommonPicturePreview.h
XTPCommonPicturePreviewProvider.h
► GIF
XTPGifPreview.h
XTPGifPreviewProvider.h
► MSG
XTPMsgPreview.h
XTPMsgPreviewDialog.h
XTPMsgPreviewProvider.h
► Svg
XTPSvgPreview.h
XTPSvgPreviewProvider.h
► System
XTPSystemPreview.h
XTPSystemPreviewProvider.h
► Text
XTPTextPreview.h
XTPTextPreviewProvider.h
► XAML
XTPXamlPreview.h
XTPXamlPreviewProvider.h
XTPPreviewAbstract.h
XTPPreviewCtrl.h
XTPPreviewHostWindow.h
XTPPreviewNavigatorWindow.h
► Progress
XTPMarqueeCtrl.h
XTPMarqueeCtrlPaintManager.h
XTPProgressCtrl.h
XTPProgressCtrlPaintManager.h
► Resize
XTPResize.h
XTPResizeDialog.h
XTPResizeFormView.h
XTPResizeGroupBox.h
XTPResizePoint.h
XTPResizePropertyPage.h
XTPResizePropertySheet.h
XTPResizeRect.h
► Scroll
XTPPageScroller.h
XTPScrollBar.h
► Shell
XTPDirWatcher.h
XTPDropSource.h
XTPShellListBase.h
XTPShellListCtrlView.h
XTPShellPidl.h
XTPShellSettings.h
XTPShellTreeBase.h
XTPShellTreeCtrlView.h
XTPTaskbarManager.h
XTPTrayIcon.h
► Spin
XTPSpinButtonCtrl.h
► Splitter
XTPSplitterWnd.h
XTPSplitterWndTheme.h
► Static
► Themes
XTPCaptionButtonThemeOffice2003.h
XTPCaptionButtonThemeOfficeXP.h
XTPCaption.h
XTPCaptionPopupWnd.h
XTPCaptionTheme.h
XTPHyperLink.h
XTPMarkupStatic.h
XTPSearchOptionsCtrl.h
► Tab
XTPExcelTabCtrl.h
XTPExcelTabCtrlTheme.h
XTPMDIWndTab.h
XTPTabBase.h
XTPTabBaseTheme.h
XTPTabCtrl.h
XTPTabCtrlButtons.h
XTPTabView.h
► TagCloud
XTPTagCloudCtrl.h
► Tree
XTPMarkupTreeCtrl.h
XTPTreeBase.h
XTPTreeCtrlView.h
XTPTreeTheme.h
► Util
XTPAnimationDC.h
XTPControlTheme.h
XTPFunctions.h
XTPGlobal.h
XTPHelpers.h
XTPMemFile.h
XTPRegistryManager.h
XTPUtil.h
XTPWindowPos.h
► View
XTPMarkupView.h
► WebBrowser
► Providers
► WebView2
XTPWebView2.h
XTPShellExplorerProvider.h
XTPWebBrowserControlSite.h
XTPWebBrowserProvider.h
XTPWebViewProvider.h
XTPWebBrowserAbstract.h
XTPWebBrowserCtrl.h
XTPControlsIIDs.h
► DockingPane
► ColorSets
XTPDockingPaneColorSet.h
XTPDockingPaneColorSet2012.h
XTPDockingPaneColorSet2013.h
XTPDockingPaneColorSet2015.h
XTPDockingPaneColorSet2017.h
XTPDockingPaneColorSet2019.h
XTPDockingPaneColorSet2022.h
XTPDockingPaneColorSetNativeWindows10.h
XTPDockingPaneColorSetNativeWindows11.h
► TabColorSets
XTPDockingPanePanelColorSet2012.h
XTPDockingPanePanelColorSet2013.h
XTPDockingPanePanelColorSet2015.h
XTPDockingPanePanelColorSet2017.h
XTPDockingPanePanelColorSet2019.h
XTPDockingPanePanelColorSet2022.h
XTPDockingPanePanelColorSetNativeWindows10.h
XTPDockingPanePanelColorSetNativeWindows11.h
XTPDockingPaneTabColorSet2012.h
XTPDockingPaneTabColorSet2013.h
XTPDockingPaneTabColorSet2015.h
XTPDockingPaneTabColorSet2017.h
XTPDockingPaneTabColorSet2019.h
XTPDockingPaneTabColorSet2022.h
XTPDockingPaneTabColorSetNativeWindows10.h
XTPDockingPaneTabColorSetNativeWindows11.h
XTPDockingPaneTabColorSetOfficePanel.h
XTPDockingPaneTabColorSetVisualStudio2003.h
XTPDockingPaneTabColorSetVisualStudio2005.h
► TabThemes
XTPDockingPanePanelTheme2012.h
XTPDockingPanePanelTheme2013.h
XTPDockingPanePanelTheme2015.h
XTPDockingPanePanelTheme2017.h
XTPDockingPanePanelTheme2019.h
XTPDockingPanePanelTheme2022.h
XTPDockingPanePanelThemeNativeWindows10.h
XTPDockingPanePanelThemeNativeWindows11.h
XTPDockingPaneTabTheme2012.h
XTPDockingPaneTabTheme2013.h
XTPDockingPaneTabTheme2015.h
XTPDockingPaneTabTheme2017.h
XTPDockingPaneTabTheme2019.h
XTPDockingPaneTabTheme2022.h
XTPDockingPaneTabThemeNativeWindows10.h
XTPDockingPaneTabThemeNativeWindows11.h
► Themes
XTPDockingPaneThemeDefault.h
XTPDockingPaneThemeGrippered.h
XTPDockingPaneThemeNativeWindows10.h
XTPDockingPaneThemeNativeWindows11.h
XTPDockingPaneThemeOffice2002Visio.h
XTPDockingPaneThemeOffice2003.h
XTPDockingPaneThemeOffice2003Outlook.h
XTPDockingPaneThemeOffice2003Visio.h
XTPDockingPaneThemeOffice2007.h
XTPDockingPaneThemeOffice2007Outlook.h
XTPDockingPaneThemeOffice2007Visio.h
XTPDockingPaneThemeOffice2007Word.h
XTPDockingPaneThemeOffice2013.h
XTPDockingPaneThemeVisualStudio2003.h
XTPDockingPaneThemeVisualStudio2005.h
XTPDockingPaneThemeVisualStudio2005Beta1.h
XTPDockingPaneThemeVisualStudio2005Beta2.h
XTPDockingPaneThemeVisualStudio2008.h
XTPDockingPaneThemeVisualStudio2010.h
XTPDockingPaneThemeVisualStudio2012.h
XTPDockingPaneThemeVisualStudio2015.h
XTPDockingPaneThemeVisualStudio2017.h
XTPDockingPaneThemeVisualStudio2019.h
XTPDockingPaneThemeVisualStudio2022.h
XTPDockingPaneThemeVisualStudio6.h
XTPDockingPaneThemeWinExplorer.h
XTPDockingPaneThemeWinNative.h
XTPDockingPane.h
XTPDockingPaneAutoHidePanel.h
XTPDockingPaneBase.h
XTPDockingPaneBaseContainer.h
XTPDockingPaneCaptionButton.h
XTPDockingPaneContext.h
XTPDockingPaneDefines.h
XTPDockingPaneIIDs.h
XTPDockingPaneKeyboardHook.h
XTPDockingPaneLayout.h
XTPDockingPaneManager.h
XTPDockingPaneMiniWnd.h
XTPDockingPanePaintManager.h
XTPDockingPaneSidePanel.h
XTPDockingPaneSplitterContainer.h
XTPDockingPaneTabbedContainer.h
► FlowGraph
XTPArrowDrawer.h
XTPFlowGraphConnection.h
XTPFlowGraphConnectionPoint.h
XTPFlowGraphConnectionPoints.h
XTPFlowGraphConnections.h
XTPFlowGraphControl.h
XTPFlowGraphDrawContext.h
XTPFlowGraphDrawContextGdiPlus.h
XTPFlowGraphEditItem.h
XTPFlowGraphElement.h
XTPFlowGraphIIDs.h
XTPFlowGraphImage.h
XTPFlowGraphMessages.h
XTPFlowGraphNode.h
XTPFlowGraphNodeCustom.h
XTPFlowGraphNodeGroup.h
XTPFlowGraphNodeGroups.h
XTPFlowGraphNodes.h
XTPFlowGraphPage.h
XTPFlowGraphPageHistory.h
XTPFlowGraphPages.h
XTPFlowGraphPaintManager.h
XTPFlowGraphSelectedElements.h
XTPFlowGraphSelectionRect.h
XTPFlowGraphTools.h
XTPFlowGraphUndoManager.h
XTPTextOnPath.h
► Gauge
► Types
XTPGaugeMeterType.h
XTPGaugeStateType.h
XTPGaugeBaseType.h
XTPGaugeCtrl.h
XTPGaugeTraits.h
► GraphicLibrary
► GdiPlus
XTPGdiPlus.h
► OpenGL
XTPOpenGLListPool.h
XTPOpenGLTriangleRenderList.h
XTPOpenGLUtils.h
XTPGraphicBitmapPng.h
XTPSvgImage.h
► GridControl
► Behavior
XTPGridBehavior.h
► ItemTypes
XTPGridRecordItemCheckbox.h
XTPGridRecordItemDateTime.h
XTPGridRecordItemIcon.h
XTPGridRecordItemNumber.h
XTPGridRecordItemPreview.h
XTPGridRecordItemText.h
XTPGridRecordItemVariant.h
► Themes
XTPGridThemeDefault.h
XTPGridThemeExplorer.h
XTPGridThemeNativeWindows10.h
XTPGridThemeNativeWindows11.h
XTPGridThemeOffice2003.h
XTPGridThemeOffice2003Luna.h
XTPGridThemeOffice2013.h
XTPGridThemeOfficeXP.h
XTPGridThemeResource.h
XTPGridThemeVisualStudio2012.h
XTPGridThemeVisualStudio2015.h
XTPGridThemeVisualStudio2017.h
XTPGridThemeVisualStudio2019.h
XTPGridThemeVisualStudio2022.h
► TrackControl
► Themes
XTPTrackThemeDefault.h
XTPTrackThemeExplorer.h
XTPTrackThemeNativeWindows10.h
XTPTrackThemeNativeWindows11.h
XTPTrackThemeOffice2003.h
XTPTrackThemeOffice2003Luna.h
XTPTrackThemeOffice2013.h
XTPTrackThemeOfficeXP.h
XTPTrackThemeResource.h
XTPTrackThemeVisualStudio2012.h
XTPTrackThemeVisualStudio2015.h
XTPTrackThemeVisualStudio2017.h
XTPTrackThemeVisualStudio2019.h
XTPTrackThemeVisualStudio2022.h
XTPTrackBlock.h
XTPTrackControl.h
XTPTrackControlItem.h
XTPTrackHeader.h
XTPTrackPaintManager.h
XTPTrackUndoManager.h
XTPGridADO.h
XTPGridAllocators.h
XTPGridBorder.h
XTPGridColumn.h
XTPGridColumns.h
XTPGridControl.h
XTPGridControlIIDs.h
XTPGridDataManager.h
XTPGridDefines.h
XTPGridDeprecated.h
XTPGridDragDrop.h
XTPGridFilterEditControl.h
XTPGridGroupRow.h
XTPGridHeader.h
XTPGridHitTestInfo.h
XTPGridHyperlink.h
XTPGridInplaceControls.h
XTPGridNavigator.h
XTPGridPageSetupDialog.h
XTPGridPaintManager.h
XTPGridRecord.h
XTPGridRecordItem.h
XTPGridRecordItemConstraint.h
XTPGridRecordItemControls.h
XTPGridRecordItemRange.h
XTPGridRecords.h
XTPGridRow.h
XTPGridRows.h
XTPGridSection.h
XTPGridSections.h
XTPGridSelectedRows.h
XTPGridSubListControl.h
XTPGridThickness.h
XTPGridTip.h
XTPGridView.h
► Markup
► Controls
XTPMarkupBorder.h
XTPMarkupButton.h
XTPMarkupButtonBase.h
XTPMarkupCanvas.h
XTPMarkupCheckBox.h
XTPMarkupColumnDefinition.h
XTPMarkupColumnDefinitionCollection.h
XTPMarkupContentControl.h
XTPMarkupControl.h
XTPMarkupDecorator.h
XTPMarkupDefinitionBase.h
XTPMarkupDockPanel.h
XTPMarkupGrid.h
XTPMarkupGridLength.h
XTPMarkupImage.h
XTPMarkupPage.h
XTPMarkupPanel.h
XTPMarkupRadioButton.h
XTPMarkupRowDefinition.h
XTPMarkupRowDefinitionCollection.h
XTPMarkupScrollBar.h
XTPMarkupScrollViewer.h
XTPMarkupStackPanel.h
XTPMarkupTextBlock.h
XTPMarkupToggleButton.h
XTPMarkupUIElementCollection.h
XTPMarkupUniformGrid.h
XTPMarkupViewbox.h
XTPMarkupWrapPanel.h
► DeviceContext
XTPGdiPlus.h
XTPMarkupDeviceContext.h
XTPMarkupDeviceDependentImage.h
XTPMarkupGdiImage.h
XTPMarkupGdiPlusDeviceContext.h
XTPMarkupGdiPlusImage.h
► Extensions
XTPMarkupAmbientColorsStaticExtension.h
XTPMarkupExtension.h
XTPMarkupStaticExtension.h
XTPMarkupSystemColorsStaticExtension.h
XTPMarkupXtpScript.h
► Shapes
XTPMarkupEllipse.h
XTPMarkupLine.h
XTPMarkupPath.h
XTPMarkupPathData.h
XTPMarkupPathGeometry.h
XTPMarkupPathGeometryBuilder.h
XTPMarkupPathGeometryFigures.h
XTPMarkupPolygon.h
XTPMarkupPolyline.h
XTPMarkupRectangle.h
XTPMarkupShape.h
► Text
XTPMarkupBold.h
XTPMarkupHyperlink.h
XTPMarkupInline.h
XTPMarkupInlineCollection.h
XTPMarkupInlineUIContainer.h
XTPMarkupItalic.h
XTPMarkupLineBreak.h
XTPMarkupRun.h
XTPMarkupSpan.h
XTPMarkupTextElement.h
XTPMarkupUnderline.h
► Transform
XTPMarkupGdiPlusMatrixTransform.h
XTPMarkupGdiPlusRotateTransform.h
XTPMarkupGdiPlusScaleTransform.h
XTPMarkupGdiPlusSkewTransform.h
XTPMarkupGdiPlusTransformationMatrix.h
XTPMarkupGdiPlusTransformObject.h
XTPMarkupGdiPlusTranslateTransform.h
XTPMarkupMatrixTransform.h
XTPMarkupRenderTransform.h
XTPMarkupRotateTransform.h
XTPMarkupScaleTransform.h
XTPMarkupSkewTransform.h
XTPMarkupTransform.h
XTPMarkupTransformationMatrix.h
XTPMarkupTranslateTransform.h
XTPMarkupBuilder.h
XTPMarkupContext.h
XTPMarkupDelegate.h
XTPMarkupDrawingContext.h
XTPMarkupEventHandlerMap.h
XTPMarkupFrameworkContentElement.h
XTPMarkupFrameworkElement.h
XTPMarkupIIDs.h
XTPMarkupInputElement.h
XTPMarkupKeyboardNavigation.h
XTPMarkupMouseButtonEventArgs.h
XTPMarkupMouseEventArgs.h
XTPMarkupMouseWheelEventArgs.h
XTPMarkupObject.h
XTPMarkupParser.h
XTPMarkupQueryCursorEventArgs.h
XTPMarkupResourceDictionary.h
XTPMarkupRoutedEvent.h
XTPMarkupRoutedEventArgs.h
XTPMarkupSetter.h
XTPMarkupSetterCollection.h
XTPMarkupString.h
XTPMarkupStyle.h
XTPMarkupThickness.h
XTPMarkupTools.h
XTPMarkupTrigger.h
XTPMarkupTriggerCollection.h
XTPMarkupTypedSimpleStack.h
XTPMarkupUIElement.h
► PropertyGrid
XTPPropertyGrid.h
XTPPropertyGridDefines.h
XTPPropertyGridIIDs.h
XTPPropertyGridInplaceButton.h
XTPPropertyGridInplaceEdit.h
XTPPropertyGridInplaceList.h
XTPPropertyGridItem.h
XTPPropertyGridItemBool.h
XTPPropertyGridItemColor.h
XTPPropertyGridItemExt.h
XTPPropertyGridItemFlags.h
XTPPropertyGridItemFont.h
XTPPropertyGridItemNumber.h
XTPPropertyGridItemOption.h
XTPPropertyGridItemSize.h
XTPPropertyGridPaintManager.h
XTPPropertyGridToolBar.h
XTPPropertyGridToolTip.h
XTPPropertyGridView.h
► Ribbon
► Backstage
► Pages
XTPRibbonBackstagePagePrint.h
XTPRibbonBackstagePageRecent.h
XTPRibbonBackstageButton.h
XTPRibbonBackstageButtonThemeNativeWindows10.h
XTPRibbonBackstageButtonThemeNativeWindows11.h
XTPRibbonBackstageButtonThemeOffice2013.h
XTPRibbonBackstageButtonThemeResource.h
XTPRibbonBackstageButtonThemeVisualStudio2015.h
XTPRibbonBackstageButtonThemeVisualStudio2017.h
XTPRibbonBackstageButtonThemeVisualStudio2019.h
XTPRibbonBackstageButtonThemeVisualStudio2022.h
XTPRibbonBackstageCommand.h
XTPRibbonBackstageLabel.h
XTPRibbonBackstageMenuSeparator.h
XTPRibbonBackstagePage.h
XTPRibbonBackstagePaintManager.h
XTPRibbonBackstageSeparator.h
XTPRibbonBackstageSeparatorPaintManager.h
XTPRibbonBackstageSeparatorThemeNativeWindows10.h
XTPRibbonBackstageSeparatorThemeNativeWindows11.h
XTPRibbonBackstageSeparatorThemeOffice2013.h
XTPRibbonBackstageSeparatorThemeResource.h
XTPRibbonBackstageSeparatorThemeVisualStudio2015.h
XTPRibbonBackstageSeparatorThemeVisualStudio2017.h
XTPRibbonBackstageSeparatorThemeVisualStudio2019.h
XTPRibbonBackstageSeparatorThemeVisualStudio2022.h
XTPRibbonBackstageTab.h
XTPRibbonBackstageView.h
XTPRibbonBackstageViewThemeNativeWindows10.h
XTPRibbonBackstageViewThemeNativeWindows11.h
XTPRibbonBackstageViewThemeOffice2013.h
XTPRibbonBackstageViewThemeResource.h
XTPRibbonBackstageViewThemeVisualStudio2015.h
XTPRibbonBackstageViewThemeVisualStudio2017.h
XTPRibbonBackstageViewThemeVisualStudio2019.h
XTPRibbonBackstageViewThemeVisualStudio2022.h
► Customize
XTPRibbonCustomizePage.h
XTPRibbonCustomizeQuickAccessPage.h
XTPRibbonCustomizeTreeCtrl.h
XTPRibbonRenameDialog.h
► Themes
XTPRibbonThemeNativeWindows10.h
XTPRibbonThemeNativeWindows11.h
XTPRibbonThemeOffice2007System.h
XTPRibbonThemeOffice2013.h
XTPRibbonThemeResource.h
XTPRibbonThemeVisualStudio2015.h
XTPRibbonThemeVisualStudio2017.h
XTPRibbonThemeVisualStudio2019.h
XTPRibbonThemeVisualStudio2022.h
XTPRibbonBar.h
XTPRibbonBuilder.h
XTPRibbonControlTab.h
XTPRibbonGroup.h
XTPRibbonGroups.h
XTPRibbonMarkupFrameTheme.h
XTPRibbonMarkupTheme.h
XTPRibbonPaintManager.h
XTPRibbonPopups.h
XTPRibbonQuickAccessControls.h
XTPRibbonSystemButton.h
XTPRibbonTab.h
XTPRibbonTabColorSet.h
XTPRibbonTabTheme.h
► ShortcutBar
► Themes
XTPShortcutBarNativeWindows10Theme.h
XTPShortcutBarNativeWindows11Theme.h
XTPShortcutBarNativeWinXPTheme.h
XTPShortcutBarOffice2000Theme.h
XTPShortcutBarOffice2003Theme.h
XTPShortcutBarOffice2013Theme.h
XTPShortcutBarOfficeXPTheme.h
XTPShortcutBarResourceTheme.h
XTPShortcutBarVisualStudio2015Theme.h
XTPShortcutBarVisualStudio2017Theme.h
XTPShortcutBarVisualStudio2019Theme.h
XTPShortcutBarVisualStudio2022Theme.h
XTPShortcutBar.h
XTPShortcutBarAnimation.h
XTPShortcutBarIIDs.h
XTPShortcutBarPaintManager.h
XTPShortcutBarPane.h
XTPShortcutBarPopup.h
► SkinFramework
► ApiHook
XTPSkinManagerApiHookBase.h
XTPSkinManagerApiHookConfig.h
XTPSkinManagerDetoursApiHook.h
XTPSkinManagerLegacyApiHook.h
XTPSkinDrawTools.h
XTPSkinFrameworkIIDs.h
XTPSkinImage.h
XTPSkinManager.h
XTPSkinManagerApiHook.h
XTPSkinManagerColorFilter.h
XTPSkinManagerModuleList.h
XTPSkinManagerResource.h
XTPSkinManagerSchema.h
XTPSkinManagerSchemaCodes.h
XTPSkinObject.h
XTPSkinObjectButton.h
XTPSkinObjectComboBox.h
XTPSkinObjectEdit.h
XTPSkinObjectFrame.h
XTPSkinObjectHeader.h
XTPSkinObjectListBox.h
XTPSkinObjectListView.h
XTPSkinObjectMDI.h
XTPSkinObjectMenu.h
XTPSkinObjectProgress.h
XTPSkinObjectReBar.h
XTPSkinObjectScrollBar.h
XTPSkinObjectSpin.h
XTPSkinObjectStatusBar.h
XTPSkinObjectTab.h
XTPSkinObjectToolBar.h
XTPSkinObjectTrackBar.h
XTPSkinObjectTreeView.h
► SyntaxEdit
► res
XTPSyntaxEditLexSchemas.h
XTPSyntaxEditAutoCompleteWnd.h
XTPSyntaxEditBufferManager.h
XTPSyntaxEditColorComboBox.h
XTPSyntaxEditColorSampleText.h
XTPSyntaxEditCtrl.h
XTPSyntaxEditDefines.h
XTPSyntaxEditDoc.h
XTPSyntaxEditDrawTextProcessor.h
XTPSyntaxEditFindReplaceDlg.h
XTPSyntaxEditGoToLineDlg.h
XTPSyntaxEditIIDs.h
XTPSyntaxEditLexCfgFileReader.h
XTPSyntaxEditLexClass.h
XTPSyntaxEditLexClassSubObjDef.h
XTPSyntaxEditLexClassSubObjT.h
XTPSyntaxEditLexColorFileReader.h
XTPSyntaxEditLexParser.h
XTPSyntaxEditLexPtrs.h
XTPSyntaxEditLineMarksManager.h
XTPSyntaxEditPaintManager.h
XTPSyntaxEditPropertiesDlg.h
XTPSyntaxEditPropertiesPage.h
XTPSyntaxEditSectionManager.h
XTPSyntaxEditSelection.h
XTPSyntaxEditStruct.h
XTPSyntaxEditTextIterator.h
XTPSyntaxEditToolTipCtrl.h
XTPSyntaxEditUndoManager.h
XTPSyntaxEditView.h
► TabManager
► ColorSets
XTPTabColorSetDefault.h
XTPTabColorSetNativeWindows10.h
XTPTabColorSetNativeWindows11.h
XTPTabColorSetOffice2003.h
XTPTabColorSetOffice2007.h
XTPTabColorSetOffice2007Access.h
XTPTabColorSetOffice2013.h
XTPTabColorSetVisualStudio2003.h
XTPTabColorSetVisualStudio2005.h
XTPTabColorSetVisualStudio2008.h
XTPTabColorSetVisualStudio2010.h
XTPTabColorSetVisualStudio2012.h
XTPTabColorSetVisualStudio2012Dark.h
XTPTabColorSetVisualStudio2015.h
XTPTabColorSetVisualStudio2017.h
XTPTabColorSetVisualStudio2019.h
XTPTabColorSetVisualStudio2022.h
XTPTabColorSetWinNative.h
► Themes
XTPTabThemeExcel2003.h
XTPTabThemeFlat.h
XTPTabThemeNativeWindows10.h
XTPTabThemeNativeWindows11.h
XTPTabThemeOffice2000.h
XTPTabThemeOffice2013.h
XTPTabThemePropertyPage2003.h
XTPTabThemePropertyPage2007.h
XTPTabThemePropertyPageAccess2007.h
XTPTabThemePropertyPageFlat.h
XTPTabThemePropertyPageSelected.h
XTPTabThemeStateButtons.h
XTPTabThemeVisio.h
XTPTabThemeVisualStudio2003.h
XTPTabThemeVisualStudio2005.h
XTPTabThemeVisualStudio2010.h
XTPTabThemeVisualStudio2012.h
XTPTabThemeVisualStudio2015.h
XTPTabThemeVisualStudio2017.h
XTPTabThemeVisualStudio2019.h
XTPTabThemeVisualStudio2022.h
XTPTabControl.h
XTPTabManager.h
XTPTabManagerAtom.h
XTPTabManagerDefines.h
XTPTabManagerIIDs.h
XTPTabManagerItem.h
XTPTabManagerNavigateButton.h
XTPTabManagerNavigateButtons.h
XTPTabPaintManager.h
XTPTabPaintManagerColorSet.h
XTPTabPaintManagerTheme.h
► TaskPanel
► Themes
XTPTaskPanelExplorerTheme.h
XTPTaskPanelExplorerThemePlain.h
XTPTaskPanelListViewOffice2003Theme.h
XTPTaskPanelListViewOfficeXPTheme.h
XTPTaskPanelListViewTheme.h
XTPTaskPanelNativeWindows10Theme.h
XTPTaskPanelNativeWindows11Theme.h
XTPTaskPanelOffice2003Theme.h
XTPTaskPanelOffice2003ThemePlain.h
XTPTaskPanelOffice2013Theme.h
XTPTaskPanelOfficeXPThemePlain.h
XTPTaskPanelPaintManagerPlain.h
XTPTaskPanelShortcutBarOffice2003Theme.h
XTPTaskPanelShortcutBarOffice2007Theme.h
XTPTaskPanelToolboxTheme.h
XTPTaskPanelVisualStudio2005Theme.h
XTPTaskPanelVisualStudio2010Theme.h
XTPTaskPanelVisualStudio2012Theme.h
XTPTaskPanelVisualStudio2015Theme.h
XTPTaskPanelVisualStudio2017Theme.h
XTPTaskPanelVisualStudio2019Theme.h
XTPTaskPanelVisualStudio2022Theme.h
XTPTaskPanel.h
XTPTaskPanelAnimation.h
XTPTaskPanelDefines.h
XTPTaskPanelGroup.h
XTPTaskPanelGroupItem.h
XTPTaskPanelIIDs.h
XTPTaskPanelItem.h
XTPTaskPanelItems.h
XTPTaskPanelPaintManager.h
XTPResource.h


Toolkit Pro: Source Directory Reference

  • Source
Source Directory Reference

Directories

Calendar
Chart
CommandBars
Common
Controls
DockingPane
FlowGraph
Gauge
GraphicLibrary
GridControl
Markup
PropertyGrid
Ribbon
ShortcutBar
SkinFramework
SyntaxEdit
TabManager
TaskPanel

Files

XTPResource.h


Toolkit Pro: Calendar Directory Reference

  • Source
  • Calendar
Calendar Directory Reference

Directories

CaptionBar
DatePicker
Themes

Files

XTPCalendarADO.h
XTPCalendarControl.h
XTPCalendarController.h
XTPCalendarControlView.h
XTPCalendarCustomDataProvider.h
XTPCalendarCustomProperties.h
XTPCalendarData.h
XTPCalendarDatabaseDataProvider.h
XTPCalendarDayView.h
XTPCalendarDayViewDay.h
XTPCalendarDayViewEvent.h
XTPCalendarDayViewTimeScale.h
XTPCalendarDefines.h
XTPCalendarEvent.h
XTPCalendarEventColorDlg.h
XTPCalendarEventColorListBox.h
XTPCalendarEventColorNewDlg.h
XTPCalendarEventLabel.h
XTPCalendarEventPropertiesDlg.h
XTPCalendarEventRecurrenceDlg.h
XTPCalendarEvents.h
XTPCalendarIIDs.h
XTPCalendarMAPIDataProvider.h
XTPCalendarMAPIWrapper.h
XTPCalendarMemoryDataProvider.h
XTPCalendarMonthView.h
XTPCalendarMonthViewDay.h
XTPCalendarMonthViewEvent.h
XTPCalendarMsgNotifier.h
XTPCalendarNotifications.h
XTPCalendarOccurSeriesChooseDlg.h
XTPCalendarOptions.h
XTPCalendarPaintManager.h
XTPCalendarPtrCollectionT.h
XTPCalendarRecurrencePattern.h
XTPCalendarRemindersDialog.h
XTPCalendarRemindersManager.h
XTPCalendarResource.h
XTPCalendarResourcesManager.h
XTPCalendarShadowDrawer.h
XTPCalendarTheme.h
XTPCalendarThemeOffice2007.h
XTPCalendarThemePrevNextEventButton.h
XTPCalendarThemePrevNextEventButtons.h
XTPCalendarTimeLineView.h
XTPCalendarTimeLineViewGroup.h
XTPCalendarTimeLineViewTimeScale.h
XTPCalendarTimeZoneHelper.h
XTPCalendarTip.h
XTPCalendarUtils.h
XTPCalendarView.h
XTPCalendarViewDay.h
XTPCalendarViewEvent.h
XTPCalendarViewPart.h
XTPCalendarWeekView.h
XTPCalendarWeekViewDay.h
XTPCalendarWeekViewEvent.h


Toolkit Pro: CaptionBar Directory Reference

  • Source
  • Calendar
  • CaptionBar
CaptionBar Directory Reference

Directories

Themes

Files

XTPCalendarCaptionBarControl.h
XTPCalendarCaptionBarPaintManager.h
XTPCalendarCaptionBarTheme.h
XTPCalendarCaptionBarThemePart.h


Toolkit Pro: Themes Directory Reference

  • Source
  • Calendar
  • CaptionBar
  • Themes
Themes Directory Reference

Files

XTPCalendarCaptionBarNativeWindows10Theme.h
XTPCalendarCaptionBarNativeWindows11Theme.h
XTPCalendarCaptionBarOffice2000Theme.h
XTPCalendarCaptionBarOffice2003Theme.h
XTPCalendarCaptionBarOffice2013Theme.h
XTPCalendarCaptionBarOfficeXPTheme.h
XTPCalendarCaptionBarResourceTheme.h
XTPCalendarCaptionBarVisualStudio2015Theme.h
XTPCalendarCaptionBarVisualStudio2017Theme.h
XTPCalendarCaptionBarVisualStudio2019Theme.h
XTPCalendarCaptionBarVisualStudio2022Theme.h


Toolkit Pro: XTPCalendarCaptionBarNativeWindows10Theme.h File Reference

  • Source
  • Calendar
  • CaptionBar
  • Themes
Classes
XTPCalendarCaptionBarNativeWindows10Theme.h File Reference

Go to the source code of this file.

Classes

class CXTPCalendarCaptionBarNativeWindows10Theme
CXTPCalendarCaptionBarNativeWindows10Theme is a CXTPCalendarCaptionBarOffice2013Theme derived class that represents the Native Windows 10 calendar theme. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPCalendarCaptionBarNativeWindows11Theme.h File Reference

  • Source
  • Calendar
  • CaptionBar
  • Themes
Classes
XTPCalendarCaptionBarNativeWindows11Theme.h File Reference

Go to the source code of this file.

Classes

class CXTPCalendarCaptionBarNativeWindows11Theme
CXTPCalendarCaptionBarNativeWindows11Theme is a CXTPCalendarCaptionBarOffice2013Theme derived class that represents the Native Windows 11 calendar theme. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPCalendarCaptionBarOffice2000Theme.h File Reference

  • Source
  • Calendar
  • CaptionBar
  • Themes
Classes
XTPCalendarCaptionBarOffice2000Theme.h File Reference

Go to the source code of this file.

Classes

class CXTPCalendarCaptionBarOffice2000Theme
CXTPCalendarCaptionBarOffice2000Theme is a CXTPCalendarCaptionBarPaintManager derived class thatrepresents the Office 2000 calendar theme. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPCalendarCaptionBarOffice2003Theme.h File Reference

  • Source
  • Calendar
  • CaptionBar
  • Themes
Classes
XTPCalendarCaptionBarOffice2003Theme.h File Reference

Go to the source code of this file.

Classes

class CXTPCalendarCaptionBarOffice2003Theme
CXTPCalendarCaptionBarOffice2003Theme is a CXTPCalendarCaptionBarOfficeXPTheme derived class that represents the Office 2003 calendar theme. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPCalendarCaptionBarOffice2013Theme.h File Reference

  • Source
  • Calendar
  • CaptionBar
  • Themes
Classes
XTPCalendarCaptionBarOffice2013Theme.h File Reference

Go to the source code of this file.

Classes

class CXTPCalendarCaptionBarOffice2013Theme
CXTPCalendarCaptionBarOffice2013Theme is a CXTPCalendarCaptionBarOffice2003Theme derived class that represents the Office 2013 white calendar theme. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPCalendarCaptionBarOfficeXPTheme.h File Reference

  • Source
  • Calendar
  • CaptionBar
  • Themes
Classes
XTPCalendarCaptionBarOfficeXPTheme.h File Reference

Go to the source code of this file.

Classes

class CXTPCalendarCaptionBarOfficeXPTheme
CXTPCalendarCaptionBarOfficeXPTheme is a CXTPCalendarCaptionBarOffice2000Theme derived class that represents the Office XP calendar theme. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPCalendarCaptionBarResourceTheme.h File Reference

  • Source
  • Calendar
  • CaptionBar
  • Themes
Classes
XTPCalendarCaptionBarResourceTheme.h File Reference

Go to the source code of this file.

Classes

class CXTPCalendarCaptionBarResourceTheme
CXTPCalendarCaptionBarResourceTheme is a CXTPCalendarCaptionBarOffice2013Theme derived class that represents the Resource calendar theme. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPCalendarCaptionBarVisualStudio2015Theme.h File Reference

  • Source
  • Calendar
  • CaptionBar
  • Themes
Classes
XTPCalendarCaptionBarVisualStudio2015Theme.h File Reference

Go to the source code of this file.

Classes

class CXTPCalendarCaptionBarVisualStudio2015Theme
CXTPCalendarCaptionBarVisualStudio2015Theme is a CXTPCalendarCaptionBarOffice2013Theme derived class that represents the Visual Studio 2015 white calendar theme. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPCalendarCaptionBarVisualStudio2017Theme.h File Reference

  • Source
  • Calendar
  • CaptionBar
  • Themes
Classes
XTPCalendarCaptionBarVisualStudio2017Theme.h File Reference

Go to the source code of this file.

Classes

class CXTPCalendarCaptionBarVisualStudio2017Theme
CXTPCalendarCaptionBarVisualStudio2017Theme is a CXTPCalendarCaptionBarOffice2013Theme derived class that represents the Visual Studio 2017 white calendar theme. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPCalendarCaptionBarVisualStudio2019Theme.h File Reference

  • Source
  • Calendar
  • CaptionBar
  • Themes
Classes
XTPCalendarCaptionBarVisualStudio2019Theme.h File Reference

Go to the source code of this file.

Classes

class CXTPCalendarCaptionBarVisualStudio2019Theme
CXTPCalendarCaptionBarVisualStudio2019Theme is a CXTPCalendarCaptionBarOffice2013Theme derived class that represents the Visual Studio 2019 white calendar theme. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPCalendarCaptionBarVisualStudio2022Theme.h File Reference

  • Source
  • Calendar
  • CaptionBar
  • Themes
Classes
XTPCalendarCaptionBarVisualStudio2022Theme.h File Reference

Go to the source code of this file.

Classes

class CXTPCalendarCaptionBarVisualStudio2022Theme
CXTPCalendarCaptionBarVisualStudio2022Theme is a CXTPCalendarCaptionBarOffice2013Theme derived class that represents Visual Studio 2022 white calendar theme. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPCalendarCaptionBarControl.h File Reference

  • Source
  • Calendar
  • CaptionBar
Classes | Enumerations
XTPCalendarCaptionBarControl.h File Reference

Go to the source code of this file.

Classes

class CXTPCalendarCaptionBarControl
CXTPCalendarCaptionBarControl represents CalendarCaptionBar control and used as a part of CXTPCalendarControl object. More...

Enumerations

enum XTPEnumCalendarCaptionBarThemeObject {
xtpCalendarCaptionBar_Unknown = 0 , xtpCalendarCaptionBar_ButtonViewDay = 0x00000001 , xtpCalendarCaptionBar_ButtonViewWeek = 0x00000002 , xtpCalendarCaptionBar_ButtonViewMonth = 0x00000004 ,
xtpCalendarCaptionBar_ShowWorkWeek = 0x00000010 , xtpCalendarCaptionBar_ShowFullWeek = 0x00000020 , xtpCalendarCaptionBar_ShowTimeline = 0x00000040 , xtpCalendarCaptionBar_MultiColumnsWeek = 0x00000080 ,
xtpCalendarCaptionBar_ScrollPrevDate = 0x00000100 , xtpCalendarCaptionBar_ScrollNextDate = 0x00000200 , xtpCalendarCaptionBar_DateLabel = 0x00000400 , xtpCalendarCaptionBar_ButtonExpand = 0x00000800
}
Enumerates Calendar Caption Bar graphical objects . More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Enumeration Type Documentation

◆ XTPEnumCalendarCaptionBarThemeObject

enum XTPEnumCalendarCaptionBarThemeObject

Enumerates Calendar Caption Bar graphical objects .

Enumerator
xtpCalendarCaptionBar_Unknown | Defines Unknown (NULL) value.
xtpCalendarCaptionBar_ButtonViewDay | Defines SwitchViewBar DayViewButton.
xtpCalendarCaptionBar_ButtonViewWeek | Defines SwitchViewBar WeekViewButton.
xtpCalendarCaptionBar_ButtonViewMonth | Defines SwitchViewBar MonthViewButton.
xtpCalendarCaptionBar_ShowWorkWeek | Defines SwitchViewBar ShowWorkWeek radio. button.
xtpCalendarCaptionBar_ShowFullWeek | Defines SwitchViewBar ShowFullWeek radio. button.
xtpCalendarCaptionBar_ShowTimeline | Defines SwitchViewBar ShowTimeline radio. button.
xtpCalendarCaptionBar_MultiColumnsWeek | Defines SwitchViewBar MultiColumnsWeek. radio button.
xtpCalendarCaptionBar_ScrollPrevDate | Defines ScrollDateBar PrevDateButton.
xtpCalendarCaptionBar_ScrollNextDate | Defines ScrollDateBar NextDateButton.
xtpCalendarCaptionBar_DateLabel | Defines ScrollDateBar DateLabel.
xtpCalendarCaptionBar_ButtonExpand | Defines ScrollDateBar Expand Buton.


Toolkit Pro: XTPCalendarCaptionBarPaintManager.h File Reference

  • Source
  • Calendar
  • CaptionBar
Classes
XTPCalendarCaptionBarPaintManager.h File Reference

Go to the source code of this file.

Classes

class CXTPCalendarCaptionBarPaintManager
Utility class, handles most of the drawing activities. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPCalendarCaptionBarTheme.h File Reference

  • Source
  • Calendar
  • CaptionBar
Classes
XTPCalendarCaptionBarTheme.h File Reference

Go to the source code of this file.

Classes

class CXTPCalendarCaptionBarTheme
This class CalendarCaptionBar control drawing, user interaction logic and interaction logic with attached Calendar control. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPCalendarCaptionBarThemePart.h File Reference

  • Source
  • Calendar
  • CaptionBar
Classes | Enumerations
XTPCalendarCaptionBarThemePart.h File Reference

Go to the source code of this file.

Classes

class | CXTPCalendarCaptionBarThemePart
This class used as a base class for graphical Parts of CalendarCaptionBar paint theme. More...
class | CXTPSwitchViewButtonPart
This class implements SwitchView button part of the SwitchViewBar. More...
class | CXTPRadioButtonPart
This class implements Radio button part of the SwitchViewBar. More...
class | CXTPCheckboxButtonPart
This class implements Checkbox button part of the SwitchViewBar. More...
class | CXTPScrollDateButtonPart
This class implements Scroll Date button part of the ScrollDateBar. More...
class | CXTPDateLabelPart
This class implements Date Label part of the ScrollDateBar. More...
class | CXTPExpandButtonPart
This class implements Expand button part of the ScrollDateBar. More...

Enumerations

enum EStates {
xtpBtnStateNormal = 0 , xtpBtnStateMouseOver = 0x001 , xtpBtnStatePressed = 0x002 , xtpBtnStateChecked = 0x004 ,
xtpBtnStateFocused = 0x008
}
Defines the part object states flags. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Enumeration Type Documentation

◆ EStates

enum EStates

Defines the part object states flags.

Enumerator
xtpBtnStateNormal | defines a normal state.
xtpBtnStateMouseOver | defines a mouse over state.
xtpBtnStatePressed | defines a pressed state.
xtpBtnStateChecked | defines a checked state.
xtpBtnStateFocused | defines a ficused state.


Toolkit Pro: DatePicker Directory Reference

  • Source
  • Calendar
  • DatePicker
DatePicker Directory Reference

Directories

Themes

Files

XTPDatePickerControl.h
XTPDatePickerDaysCollection.h
XTPDatePickerItemDay.h
XTPDatePickerItemMonth.h
XTPDatePickerList.h
XTPDatePickerNotifications.h
XTPDatePickerPaintManager.h


Toolkit Pro: Themes Directory Reference

  • Source
  • Calendar
  • DatePicker
  • Themes
Themes Directory Reference

Files

XTPDatePickerNativeWindows10Theme.h
XTPDatePickerNativeWindows11Theme.h
XTPDatePickerOffice2000Theme.h
XTPDatePickerOffice2003Theme.h
XTPDatePickerOffice2013Theme.h
XTPDatePickerOfficeXPTheme.h
XTPDatePickerResourceTheme.h
XTPDatePickerVisualStudio2015Theme.h
XTPDatePickerVisualStudio2017Theme.h
XTPDatePickerVisualStudio2019Theme.h
XTPDatePickerVisualStudio2022Theme.h


Toolkit Pro: XTPDatePickerNativeWindows10Theme.h File Reference

  • Source
  • Calendar
  • DatePicker
  • Themes
Classes
XTPDatePickerNativeWindows10Theme.h File Reference

Go to the source code of this file.

Classes

class CXTPDatePickerThemeNativeWindows10
Class CXTPDatePickerThemeNativeWindows10 is derived from CXTPDatePickerThemeOffice2013 for rendering an Native Windows 10 style for DatePicker control. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPDatePickerNativeWindows11Theme.h File Reference

  • Source
  • Calendar
  • DatePicker
  • Themes
Classes
XTPDatePickerNativeWindows11Theme.h File Reference

Go to the source code of this file.

Classes

class CXTPDatePickerThemeNativeWindows11
Class CXTPDatePickerThemeNativeWindows11 is derived from CXTPDatePickerThemeOffice2013 for rendering an Native Windows 11 style for DatePicker control. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPDatePickerOffice2000Theme.h File Reference

  • Source
  • Calendar
  • DatePicker
  • Themes
Classes
XTPDatePickerOffice2000Theme.h File Reference

Go to the source code of this file.

Classes

class CXTPDatePickerThemeOffice2000
Class CXTPDatePickerThemeOffice2000 is derived from CXTPDatePickerPaintManager for rendering an Office 2000 style for DatePicker control. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPDatePickerOffice2003Theme.h File Reference

  • Source
  • Calendar
  • DatePicker
  • Themes
Classes
XTPDatePickerOffice2003Theme.h File Reference

Go to the source code of this file.

Classes

class CXTPDatePickerThemeOffice2003
Class CXTPDatePickerThemeOffice2003 is derived from CXTPDatePickerPaintManager for rendering an Office 2003 style for DatePicker control. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPDatePickerOffice2013Theme.h File Reference

  • Source
  • Calendar
  • DatePicker
  • Themes
Classes
XTPDatePickerOffice2013Theme.h File Reference

Go to the source code of this file.

Classes

class CXTPDatePickerThemeOffice2013
Class CXTPDatePickerThemeOffice2013 is derived from CXTPDatePickerPaintManager for rendering an Office 2013 style for DatePicker control. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPDatePickerOfficeXPTheme.h File Reference

  • Source
  • Calendar
  • DatePicker
  • Themes
Classes
XTPDatePickerOfficeXPTheme.h File Reference

Go to the source code of this file.

Classes

class CXTPDatePickerThemeOfficeXP
Class CXTPDatePickerThemeOfficeXP is derived from CXTPDatePickerPaintManager for rendering an Office XP style for DatePicker control. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPDatePickerResourceTheme.h File Reference

  • Source
  • Calendar
  • DatePicker
  • Themes
Classes
XTPDatePickerResourceTheme.h File Reference

Go to the source code of this file.

Classes

class CXTPDatePickerThemeResource
Class CXTPDatePickerThemeResource is derived from CXTPDatePickerPaintManager for rendering a Resource DLL style for DatePicker control. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPDatePickerVisualStudio2015Theme.h File Reference

  • Source
  • Calendar
  • DatePicker
  • Themes
Classes
XTPDatePickerVisualStudio2015Theme.h File Reference

Go to the source code of this file.

Classes

class CXTPDatePickerThemeVisualStudio2015
Class CXTPDatePickerThemeVisualStudio2015 is derived from CXTPDatePickerThemeOffice2013 for rendering an Visual Studio 2015 style for DatePicker control. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPDatePickerVisualStudio2017Theme.h File Reference

  • Source
  • Calendar
  • DatePicker
  • Themes
Classes
XTPDatePickerVisualStudio2017Theme.h File Reference

Go to the source code of this file.

Classes

class CXTPDatePickerThemeVisualStudio2017
Class CXTPDatePickerThemeVisualStudio2017 is derived from CXTPDatePickerThemeOffice2013 for rendering an Visual Studio 2017 style for DatePicker control. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPDatePickerVisualStudio2019Theme.h File Reference

  • Source
  • Calendar
  • DatePicker
  • Themes
Classes
XTPDatePickerVisualStudio2019Theme.h File Reference

Go to the source code of this file.

Classes

class CXTPDatePickerThemeVisualStudio2019
Class CXTPDatePickerThemeVisualStudio2019 is derived from CXTPDatePickerThemeOffice2013 for rendering an Visual Studio 2019 style for DatePicker control. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPDatePickerVisualStudio2022Theme.h File Reference

  • Source
  • Calendar
  • DatePicker
  • Themes
Classes
XTPDatePickerVisualStudio2022Theme.h File Reference

Go to the source code of this file.

Classes

class CXTPDatePickerThemeVisualStudio2022
Class CXTPDatePickerThemeVisualStudio2022 is derived from CXTPDatePickerThemeOffice2013 for rendering an Visual Studio 2022 style for DatePicker control. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPDatePickerControl.h File Reference

  • Source
  • Calendar
  • DatePicker
Classes | Typedefs | Enumerations | Variables
XTPDatePickerControl.h File Reference

Go to the source code of this file.

Classes

struct | XTP_DAYITEM_METRICS
This structure represents a set of parameters which are used to display day items. More...
struct | XTP_NC_DATEPICKER_BUTTON
Structure used to send button notification messages. More...
class | CXTPDatePickerButton
This class represents a DatePicker button. More...
class | CXTPDatePickerButtons
Class CXTPDatePickerButtons represents a collection of buttons. More...
class | CXTPDatePickerControl
Class CXTPDatePickerControl encapsulates the functionality of a date and time picker control. More...

Typedefs

typedef void(CALLBACK * PFNITEMMETRICS) (CXTPDatePickerControl *pDatePicker, const COleDateTime &rDateTime, XTP_DAYITEM_METRICS *pDayItemMetrics, void *pUserData)
Callback function definition for the IsITEMMETRICS function.

Enumerations

enum XTPDatePickerBorderStyle { xtpDatePickerBorderNone , xtpDatePickerBorder3D , xtpDatePickerBorderOffice , xtpDatePickerBorderStatic }
Border style of Date picker control. More...

Variables

const UINT | XTP_NC_DATEPICKER_BUTTON_CLICK = (NM_FIRST - 50)
Notify ID to parent window.
const UINT | XTP_NC_DATEPICKER_SELECTION_CHANGED = (NM_FIRST - 51)
Notify ID to parent window.
const UINT | XTP_DATEPICKER_TIMERID = 255
Date picker timer ID.
const UINT | XTP_DATEPICKER_TIMER_INTERVAL = 200
Date picker timer interval.
const UINT | XTP_SELECTION_INFINITE = (UINT)-1
Infinite number of selected days.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Typedef Documentation

◆ PFNITEMMETRICS

typedef void(CALLBACK * PFNITEMMETRICS) (CXTPDatePickerControl *pDatePicker, const COleDateTime &rDateTime, XTP_DAYITEM_METRICS *pDayItemMetrics, void *pUserData)

Callback function definition for the IsITEMMETRICS function.

First three arguments are required. The pUserData can be NULL. pDatePicker - is CXTPDatePickerControl* type to provide DatePicker control pointer. rDateTime - is COleDateTime reference type to provide date time storage object. pDayItemMetrics - is XTP_DAYITEM_METRICS* pointer type to provide display metrics. pUserData - is void* pointer to any additional user's defined parameter, this value can be NULL.

Enumeration Type Documentation

◆ XTPDatePickerBorderStyle

enum XTPDatePickerBorderStyle

Border style of Date picker control.

Enumerator
xtpDatePickerBorderNone | No border.
xtpDatePickerBorder3D | 3D border.
xtpDatePickerBorderOffice | Office-like border.
xtpDatePickerBorderStatic | Static border.


Toolkit Pro: XTPDatePickerDaysCollection.h File Reference

  • Source
  • Calendar
  • DatePicker
Classes
XTPDatePickerDaysCollection.h File Reference

Go to the source code of this file.

Classes

class | CXTPDatePickerDaysCollection
struct | CXTPDatePickerDaysCollection::SELECTED_BLOCK
Selected block structure. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPDatePickerItemDay.h File Reference

  • Source
  • Calendar
  • DatePicker
Classes
XTPDatePickerItemDay.h File Reference

Go to the source code of this file.

Classes

class CXTPDatePickerItemDay
Class CXTPDatePickerItemDay represents one displayed day item in the calendar. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPDatePickerItemMonth.h File Reference

  • Source
  • Calendar
  • DatePicker
Classes | Variables
XTPDatePickerItemMonth.h File Reference

Go to the source code of this file.

Classes

class CXTPDatePickerItemMonth
Class CXTPDatePickerItemMonth represents one month inside the date picker month grid. More...

Variables

const UINT | XTP_MAX_WEEKS = (UINT)6
Maximum amount of weeks shown in one month area.
const UINT | XTP_WEEK_DAYS = (UINT)7
Number of days in the week.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPDatePickerList.h File Reference

  • Source
  • Calendar
  • DatePicker
Classes
XTPDatePickerList.h File Reference

Go to the source code of this file.

Classes

class CXTPDatePickerList
This class provides the functionality of a list control which displays month names. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPDatePickerNotifications.h File Reference

  • Source
  • Calendar
  • DatePicker
Variables
XTPDatePickerNotifications.h File Reference

Go to the source code of this file.

Variables

static const XTP_NOTIFY_CODE | XTP_NC_DATEPICKERBUTTONCLICKED = (WM_XTP_CALENDAR_BASE + 80)
This is a notification ID that is used to indicate mouse button clicks on a control.
static const XTP_NOTIFY_CODE | XTP_NC_DATEPICKERSELECTIONCHANGED = (WM_XTP_CALENDAR_BASE + 81)
This is a notification ID that is used to indicate that the selection has changed.
static const XTP_NOTIFY_CODE | XTP_NC_DATEPICKERBEFOREGOMODAL = (WM_XTP_CALENDAR_BASE + 82)
This is a notification ID that indicates that the Date Picker is about to enter modal mode (pop-up window).
static const XTP_NOTIFY_CODE | XTP_NC_DATEPICKERMOUSEMOVE = (WM_XTP_CALENDAR_BASE + 83)
This is a notification ID that is used to indicate that the mouse moved under a control.
static const XTP_NOTIFY_CODE | XTP_NC_DATEPICKERMONTHCHANGED = (WM_XTP_CALENDAR_BASE + 84)
This is a notification ID that is used to indicate that the Date Picker is populated.
static const XTP_NOTIFY_CODE | XTP_NC_DATEPICKERGETDAYMETRICS = (WM_XTP_CALENDAR_BASE + 85)
This notification is used to get day item metrics.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Variable Documentation

◆ XTP_NC_DATEPICKERBEFOREGOMODAL

const XTP_NOTIFY_CODE XTP_NC_DATEPICKERBEFOREGOMODAL = (WM_XTP_CALENDAR_BASE + 82)
static

This is a notification ID that indicates that the Date Picker is about to enter modal mode (pop-up window).

There are two DWORD parameters that are reserved for user-defined purposes.

Example:

// In the header file.
// Declare the xtp sink macro.  This creates the sink and associates the sink
// with the CXTPCalendarController object.

DECLARE_XTPSINK(CXTPCalendarController, m_Sink);

// Declare the member function that handles the event notification messages.
void OnEvent_DatePicker(XTP_NOTIFY_CODE Event, WPARAM wParam, LPARAM lParam);

// In the source file.
// Declare the message handler inside the sink macros.

m_Sink.Advise(ptrDPConn, XTP_NC_DATEPICKERBEFOREGOMODAL,
&CXTPCalendarController::OnEvent_DatePicker);

// Somewhere in your program in a function that is used to capture mouse click events.
// Send an XTP_NC_DATEPICKERSELECTIONCHANGED notification message.

SendNotification(XTP_NC_DATEPICKERBEFOREGOMODAL);
See also
DECLARE_XTPSINK;

◆ XTP_NC_DATEPICKERBUTTONCLICKED

const XTP_NOTIFY_CODE XTP_NC_DATEPICKERBUTTONCLICKED = (WM_XTP_CALENDAR_BASE + 80)
static

This is a notification ID that is used to indicate mouse button clicks on a control.

There are two DWORD parameters that are reserved for user-defined purposes. An example is to use the first user-defined parameter as a button ID. wParam = ButtonID, lParam = 0; The second parameter is not used. This example is useful for sending notifications when a button is clicked.

Example:

// In the header file.
// Declare the xtp sink macro.  This creates the sink and associates the sink
// with the CXTPCalendarController object.

DECLARE_XTPSINK(CXTPCalendarController, m_Sink);

// Declare the member function that handles the event notification messages.
void OnEvent_DatePicker(XTP_NOTIFY_CODE Event, WPARAM wParam, LPARAM lParam);

// In the source file.
// Declare the message handler inside the sink macros.

// m_Sink.Advise(ptrDPConn, XTP_NC_DATEPICKERBUTTONCLICKED,
&CXTPCalendarController::OnEvent_DatePicker);

// Somewhere in your program in a function that is used to capture mouse click events.
// Send an XTP_NC_DATEPICKERBUTTONCLICKED notification message with
// the accompanying button ID as a parameter.

XTP_NC_DATEPICKER_BUTTON nm; // Structure used to send notification messages.
nm.nID = nID;                // Get the ID of the button.

SendNotification(XTP_NC_DATEPICKERBUTTONCLICKED, nID);
See also
DECLARE_XTPSINK

◆ XTP_NC_DATEPICKERGETDAYMETRICS

const XTP_NOTIFY_CODE XTP_NC_DATEPICKERGETDAYMETRICS = (WM_XTP_CALENDAR_BASE + 85)
static

This notification is used to get day item metrics.

Sender - CXTPDatePickerControl.

It is sent before a CallBack function call.

Parameters
wParam | [in] A day date as XTP_DATE_VALUE;
lParam | [in/out] A pointer to day metrics as XTP_DAYITEM_METRICS*.
See also
CXTPDatePickerControl::GetDayMetrics
CXTPDatePickerControl::SetCallbackDayMetrics

◆ XTP_NC_DATEPICKERMONTHCHANGED

const XTP_NOTIFY_CODE XTP_NC_DATEPICKERMONTHCHANGED = (WM_XTP_CALENDAR_BASE + 84)
static

This is a notification ID that is used to indicate that the Date Picker is populated.

Returns
Date picker is populating when months scrolled, month count changed, or some other properties and settings where changed.

Example:

// In the header file.
// Declare the xtp sink macro.  This creates the sink and associates the sink
// with the CXTPCalendarController object.

DECLARE_XTPSINK(CXTPCalendarController, m_Sink);

// Declare the member function that handles the event notification messages.
void OnEvent_DatePicker(XTP_NOTIFY_CODE Event, WPARAM wParam, LPARAM lParam);

// In the source file.
// Declare the message handler inside the sink macros.

m_Sink.Advise(ptrDPConn, XTP_NC_DATEPICKERMONTHCHANGED,
&CXTPCalendarController::OnEvent_DatePicker);
See also
DECLARE_XTPSINK;

◆ XTP_NC_DATEPICKERMOUSEMOVE

const XTP_NOTIFY_CODE XTP_NC_DATEPICKERMOUSEMOVE = (WM_XTP_CALENDAR_BASE + 83)
static

This is a notification ID that is used to indicate that the mouse moved under a control.

There are two DWORD parameters that are reserved for user-defined purposes. An example is to use the first user parameters as traced coordinates. wParam = x, lParam = y; The second parameter is not used. This example is useful for sending notifications when a button is clicked.

Example:

// In the header file.
// Declare the xtp sink macro.  This creates the sink and associates the sink
// with the CXTPCalendarController object.

DECLARE_XTPSINK(CXTPCalendarController, m_Sink);

// Declare the member function that handles the event notification messages.
void OnEvent_DatePicker(XTP_NOTIFY_CODE Event, WPARAM wParam, LPARAM lParam);

// In the source file.
// Declare the message handler inside the sink macros.

// m_Sink.Advise(ptrDPConn, XTP_NC_DATEPICKERMOUSEMOVE,
&CXTPCalendarController::OnEvent_DatePicker);

// Somewhere in your program in a function that is used to capture mouse move events.
// Send an XTP_NC_DATEPICKERMOUSEMOVE notification message with
// the accompanying mouse coordinates as parameters.
See also
DECLARE_XTPSINK

◆ XTP_NC_DATEPICKERSELECTIONCHANGED

const XTP_NOTIFY_CODE XTP_NC_DATEPICKERSELECTIONCHANGED = (WM_XTP_CALENDAR_BASE + 81)
static

This is a notification ID that is used to indicate that the selection has changed.

There are two DWORD parameters that are reserved for user-defined purposes.

Example:

// In the header file.
// Declare the xtp sink macro.  This creates the sink and associates the sink
// with the CXTPCalendarController object.

DECLARE_XTPSINK(CXTPCalendarController, m_Sink);

// Declare the member function that handles the event notification messages.
void OnEvent_DatePicker(XTP_NOTIFY_CODE Event, WPARAM wParam, LPARAM lParam);

// In the source file.
// Declare the message handler inside the sink macros.

m_Sink.Advise(ptrDPConn, XTP_NC_DATEPICKERSELECTIONCHANGED,
&CXTPCalendarController::OnEvent_DatePicker);

// Somewhere in your program in a function that is used to capture mouse click events.
// Send an XTP_NC_DATEPICKERSELECTIONCHANGED notification message.

SendNotification(XTP_NC_DATEPICKERSELECTIONCHANGED);
See also
DECLARE_XTPSINK


Toolkit Pro: XTPDatePickerPaintManager.h File Reference

  • Source
  • Calendar
  • DatePicker
Classes
XTPDatePickerPaintManager.h File Reference

Go to the source code of this file.

Classes

class CXTPDatePickerPaintManager
Class CXTPDatePickerPaintManager handles most of the drawing activities for the DatePicker control. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: Themes Directory Reference

  • Source
  • Calendar
  • Themes
Themes Directory Reference

Files

XTPCalendarNativeWindows10Theme.h
XTPCalendarNativeWindows11Theme.h
XTPCalendarOffice2000Theme.h
XTPCalendarOffice2003Theme.h
XTPCalendarOffice2013Theme.h
XTPCalendarOfficeXPTheme.h
XTPCalendarResourceTheme.h
XTPCalendarVisualStudio2015Theme.h
XTPCalendarVisualStudio2017Theme.h
XTPCalendarVisualStudio2019Theme.h
XTPCalendarVisualStudio2022Theme.h


Toolkit Pro: XTPCalendarNativeWindows10Theme.h File Reference

  • Source
  • Calendar
  • Themes
Classes
XTPCalendarNativeWindows10Theme.h File Reference

Go to the source code of this file.

Classes

class CXTPCalendarNativeWindows10Theme
CXTPCalendarNativeWindows10Theme is a CXTPCalendarOffice2013Theme derived class that represents the Native Windows 10 calendar theme. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPCalendarNativeWindows11Theme.h File Reference

  • Source
  • Calendar
  • Themes
Classes
XTPCalendarNativeWindows11Theme.h File Reference

Go to the source code of this file.

Classes

class CXTPCalendarNativeWindows11Theme
CXTPCalendarNativeWindows11Theme is a CXTPCalendarOffice2013Theme derived class that represents the Native Windows 11 calendar theme. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPCalendarOffice2000Theme.h File Reference

  • Source
  • Calendar
  • Themes
Classes
XTPCalendarOffice2000Theme.h File Reference

Go to the source code of this file.

Classes

class CXTPCalendarOffice2000Theme
CXTPCalendarOffice2000Theme is a CXTPCalendarPaintManager derived class that represents the Office 2000 calendar theme. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPCalendarOffice2003Theme.h File Reference

  • Source
  • Calendar
  • Themes
Classes
XTPCalendarOffice2003Theme.h File Reference

Go to the source code of this file.

Classes

class CXTPCalendarOffice2003Theme
CXTPCalendarOffice2003Theme is a CXTPCalendarOffice2000Theme derived class that represents the Office 2003 calendar theme. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPCalendarOffice2013Theme.h File Reference

  • Source
  • Calendar
  • Themes
Classes
XTPCalendarOffice2013Theme.h File Reference

Go to the source code of this file.

Classes

class CXTPCalendarOffice2013Theme
CXTPCalendarOffice2013Theme is a CXTPCalendarOffice2000Theme derived class that represents the Office 2013 calendar theme. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPCalendarOfficeXPTheme.h File Reference

  • Source
  • Calendar
  • Themes
Classes
XTPCalendarOfficeXPTheme.h File Reference

Go to the source code of this file.

Classes

class CXTPCalendarOfficeXPTheme
CXTPCalendarOfficeXPTheme is a CXTPCalendarOffice2000Theme derived class that represents the Office XP calendar theme. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPCalendarResourceTheme.h File Reference

  • Source
  • Calendar
  • Themes
Classes
XTPCalendarResourceTheme.h File Reference

Go to the source code of this file.

Classes

class CXTPCalendarResourceTheme
CXTPCalendarResourceTheme is a CXTPCalendarPaintManager derived class that represents the Resource calendar theme. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPCalendarVisualStudio2015Theme.h File Reference

  • Source
  • Calendar
  • Themes
Classes
XTPCalendarVisualStudio2015Theme.h File Reference

Go to the source code of this file.

Classes

class CXTPCalendarVisualStudio2015Theme
CXTPCalendarVisualStudio2015Theme is a CXTPCalendarOffice2013Theme derived class that represents the Visual Studio 2015 calendar theme. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPCalendarVisualStudio2017Theme.h File Reference

  • Source
  • Calendar
  • Themes
Classes
XTPCalendarVisualStudio2017Theme.h File Reference

Go to the source code of this file.

Classes

class CXTPCalendarVisualStudio2017Theme
CXTPCalendarVisualStudio2017Theme is a CXTPCalendarOffice2013Theme derived class that represents the Visual Studio 2017 calendar theme. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPCalendarVisualStudio2019Theme.h File Reference

  • Source
  • Calendar
  • Themes
Classes
XTPCalendarVisualStudio2019Theme.h File Reference

Go to the source code of this file.

Classes

class CXTPCalendarVisualStudio2019Theme
CXTPCalendarVisualStudio2019Theme is a CXTPCalendarOffice2013Theme derived class that represents the Visual Studio 2019 calendar theme. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPCalendarVisualStudio2022Theme.h File Reference

  • Source
  • Calendar
  • Themes
Classes
XTPCalendarVisualStudio2022Theme.h File Reference

Go to the source code of this file.

Classes

class CXTPCalendarVisualStudio2022Theme
CXTPCalendarVisualStudio2022Theme is a CXTPCalendarOffice2013Theme derived class that represents the Visual Studio 2022 calendar theme. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPCalendarADO.h File Reference

  • Source
  • Calendar
XTPCalendarADO.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPCalendarControl.h File Reference

  • Source
  • Calendar
Classes
XTPCalendarControl.h File Reference

Go to the source code of this file.

Classes

class | CXTPCalendarControl
Class CXTPCalendarControl implements the calendar's view interface. More...
class | CXTPCalendarControl::CUpdateContext
Class CUpdateContext updates context and redraws control parts depending on input parameters. More...
class | CXTPCalendarControl::CViewChangedContext
Class CViewChangedContext used to avoid multiple sending of XTP_NC_CALENDARVIEWWASCHANGED notification for one action. More...
class | CXTPCalendarControl::CViewChanged_ContextData
Class CViewChanged_ContextData is used as locker context for CViewChangedContext. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPCalendarController.h File Reference

  • Source
  • Calendar
Classes
XTPCalendarController.h File Reference

Go to the source code of this file.

Classes

class CXTPCalendarController
Class CXTPCalendarController provides a connection between a CXTPCalendarControl object and a CXTPDatePickerControl object. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPCalendarControlView.h File Reference

  • Source
  • Calendar
Classes | Variables
XTPCalendarControlView.h File Reference

Go to the source code of this file.

Classes

class | CXTPCalendarControlViewPrintOptions
Describes printing options for the Calendar Control. More...
class | CXTPCalendarPageSetupDialog
Customized Calendar control page setup dialog. More...
class | CXTPCalendarControlView
The CXTPCalendarControlView class provides an implementation of the Calendar control as a view class. More...

Variables

const UINT XTP_ID_CALENDAR_CONTROL = 100
Identifier of Calendar control child window of CXTPCalendarControlView.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPCalendarCustomDataProvider.h File Reference

  • Source
  • Calendar
Classes
XTPCalendarCustomDataProvider.h File Reference

Go to the source code of this file.

Classes

class CXTPCalendarCustomDataProvider
Custom implementation of XTPCalendarData based on notifications. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPCalendarCustomProperties.h File Reference

  • Source
  • Calendar
Classes
XTPCalendarCustomProperties.h File Reference

Go to the source code of this file.

Classes

class CXTPCalendarCustomProperties
This class is used to store properties collection. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPCalendarData.h File Reference

  • Source
  • Calendar
Classes | Macros | Variables
XTPCalendarData.h File Reference

Go to the source code of this file.

Classes

class | CXTPCalendarData
This class defines an abstract representation of the Calendar control data with all necessary methods and some predefined functionality added. More...
class | CXTPCalendarData::CXTPDPCache
class | CXTPCalendarData::EventsMapByID_T< _TObject >

Macros

#define XTP_OBJECT_CACHE_HASH_TABLE_SIZE 1021
Cache table size.

Variables

static const LPCTSTR | cszProcess_RecurrenceState
String name for a corresponding property.
static const LPCTSTR | cszProcess_RecurrencePatternID
String name for a corresponding property.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Macro Definition Documentation

◆ XTP_OBJECT_CACHE_HASH_TABLE_SIZE

#define XTP_OBJECT_CACHE_HASH_TABLE_SIZE 1021

Cache table size.

Should be a prime number! like: 503, 1021, 1511, 2003, 3001, 4001, 5003, 6007, 8009, 12007, 16001, 32003, 48017, 64007


Toolkit Pro: XTPCalendarDatabaseDataProvider.h File Reference

  • Source
  • Calendar
Classes
XTPCalendarDatabaseDataProvider.h File Reference

Go to the source code of this file.

Classes

class CXTPCalendarDatabaseDataProvider
This class is the implementation of the XTPCalendarData abstract class which represents the data portion of the Calendar control. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPCalendarDayView.h File Reference

  • Source
  • Calendar
Classes
XTPCalendarDayView.h File Reference

Go to the source code of this file.

Classes

class CXTPCalendarDayView
This class implements a specific view portion of the Calendar control - called Day view. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPCalendarDayViewDay.h File Reference

  • Source
  • Calendar
Classes
XTPCalendarDayViewDay.h File Reference

Go to the source code of this file.

Classes

class | CXTPCalendarDayViewGroup
This class represents a single resource view portion of the Calendar Day View. More...
class | CXTPCalendarDayViewDay
This class represents a day view portion of the Calendar Day View. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPCalendarDayViewEvent.h File Reference

  • Source
  • Calendar
Classes
XTPCalendarDayViewEvent.h File Reference

Go to the source code of this file.

Classes

class CXTPCalendarDayViewEvent
This class represents an event view portion of the CalendarDayViewDay. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPCalendarDayViewTimeScale.h File Reference

  • Source
  • Calendar
Classes
XTPCalendarDayViewTimeScale.h File Reference

Go to the source code of this file.

Classes

struct | XTP_LC_TIMEFORMAT
Time format structure. More...
class | CXTPCalendarDayViewTimeScale
This class implements a specific view portion of the Calendar Day view - called Time scale. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPCalendarDefines.h File Reference

  • Source
  • Calendar
Classes | Macros | Typedefs | Enumerations | Variables
XTPCalendarDefines.h File Reference

Go to the source code of this file.

Classes

struct | XTP_CALENDAR_VIEWSELECTION
Structure contains the calendar day view selection block. More...
struct | XTP_CALENDAR_MONTHVIEW_DAYPOS
Defines a set of data and methods to easily manipulate with day positions in month view. More...
struct | XTP_CALENDAR_HITTESTINFO
Basic set of parameters transferred from calendar items to mouse handlers. More...
struct | XTP_CALENDAR_PATTERN_END
This structure describes parameters of the end of the recurrence pattern type. More...
struct | XTP_WEEK_VIEW_LAYOUT
This struct store a Week View layout. More...

Macros

#define | XTP_CALENDAR_UNKNOWN_EVENT_ID 0
Define unknown event ID.
#define | XTP_CALENDAR_UNKNOWN_RECURRENCE_PATTERN_ID 0
Define an unknown recurrence pattern ID.
#define | XTP_CALENDAR_UNKNOWN_SCHEDULE_ID 0
Define unknown schedule ID.
#define | XTP_CALENDAR_DRAW_EVENTITEMTEXT_MAX 255
Define maximum text length for calendar event subject, location or body which will be drawn on the screen.
#define | XTP_CALENDAR_DISABLED_COLOR_LIGHT RGB(250, 250, 250)
Define light and dark colors which are used by CXTPImageManager::DisableBitmap to draw disabled calendar window content.
#define | XTP_CALENDAR_DISABLED_COLOR_DARK RGB(128, 128, 128)
Define light and dark colors which are used by CXTPImageManager::DisableBitmap to draw disabled calendar window content.
#define | XTP_CALENDAR_SHOW_TOOLTIP_TIMEOUT_MS 400
Timeout before appearing event tool tip window.
#define | XTP_CALENDAR_SHOW_BUTTON_TIMEOUT_MS 1400
Timeout before appearing event tool tip window.
#define | XTP_CALENDAR_UNKNOWN_LABEL_ID -1
Define unknown event label ID.
#define | XTP_CALENDAR_DEFAULT_LABEL_ID 0
Define event label ID which is used by default for a new event.
#define | XTP_CALENDAR_NONE_LABEL_ID 0
Define event label ID which signifies no label.
#define | XTP_CALENDAR_DEFAULT_REMINDER_MINUTES 15
Define default reminders value minutes which is for a new event.
#define | XTP_CALENDAR_TIMEZONESKEY_NT _T("SOFTWARE\\Microsoft\\Windows NT\\CurrentVersion\\Time Zones")
The location in the registry that contains time zone information for Windows NT family (NT/2000/XP).
#define | XTP_CALENDAR_TIMEZONESKEY_9X _T("SOFTWARE\\Microsoft\\Windows\\CurrentVersion\\Time Zones")
The location in the registry that contains time zone information for Windows 9x family.
#define | XTP_CALENDAR_TZIRegValName_StandardName _T("Std")
Registry key name for a StandardName member value of TIME_ZONE_INFORMATION.
#define | XTP_CALENDAR_TZIRegValName_StandardNameW L"Std"
Registry key name for a StandardName member value of TIME_ZONE_INFORMATION.
#define | XTP_CALENDAR_TZIRegValName_DaylightName _T("Dlt")
Registry key name for a DaylightName member value of TIME_ZONE_INFORMATION.
#define | XTP_CALENDAR_TZIRegValName_DaylightNameW L"Dlt"
Registry key name for a DaylightName member value of TIME_ZONE_INFORMATION.
#define | XTP_CALENDAR_TZIRegValName_DisplayStr _T("Display")
Registry key name for a time zone display string value.
#define | XTP_CALENDAR_TZIRegValName_Index _T("Index")
Registry key name for a time zone order index value.
#define | XTP_CALENDAR_TZIRegValName_DATA _T("TZI")
Registry key name for some TIME_ZONE_INFORMATION structure members.
#define | XTP_CALENDAR_OFFICE2007_FONT_NAME _T("Segoe UI")
The font name for Office 2007 theme.

Typedefs

typedef CArray< COleDateTime, COleDateTime & > CXTPCalendarDatesArray
Type definition for an array of dates.

Enumerations

enum XTPCalendarTheme {
xtpCalendarThemeUnknown = -1 , xtpCalendarThemeOffice2000 = 0 , xtpCalendarThemeOfficeXP = 1 , xtpCalendarThemeOffice2003 = 2 ,
xtpCalendarThemeOffice2013 = 3 , xtpCalendarThemeOffice2016 = xtpCalendarThemeOffice2013 , xtpCalendarThemeResource = 4 , xtpCalendarThemeVisualStudio2015 = 5 ,
xtpCalendarThemeNativeWindows10 = 6 , xtpCalendarThemeVisualStudio2017 = 7 , xtpCalendarThemeVisualStudio2019 = 8 , xtpCalendarThemeVisualStudio2022 = 9 ,
xtpCalendarThemeNativeWindows11 = 10 , xtpCalendarThemeOffice2007 = xtpCalendarThemeResource , xtpCalendarThemeOffice2010 = xtpCalendarThemeResource
}
Paint themes used by calendar. More...
enum XTPCalendarThemeVersion {
xtpCalendarVersionUnknown = -1 , xtpCalendarVersion2000 , xtpCalendarVersionXP , xtpCalendarVersion2003 ,
xtpCalendarVersion2007 , xtpCalendarVersion2010 , xtpCalendarVersion2013 , xtpCalendarVersion2015 ,
xtpCalendarVersion10 , xtpCalendarVersion2017 , xtpCalendarVersion2019 , xtpCalendarVersion2022 ,
xtpCalendarVersion11
}
Paint theme versions used by calendar. More...
enum XTPCalendarEventBusyStatus {
xtpCalendarBusyStatusUnknown = -1 , xtpCalendarBusyStatusFree = 0 , xtpCalendarBusyStatusElsewhere = 1 , xtpCalendarBusyStatusTentative = 2 ,
xtpCalendarBusyStatusBusy = 3 , xtpCalendarBusyStatusOutOfOffice = 4
}
Enumerates busy status values. More...
enum | XTPCalendarEventImportance { xtpCalendarImportanceUnknown = -1 , xtpCalendarImportanceLow = 0 , xtpCalendarImportanceNormal = 1 , xtpCalendarImportanceHigh = 2 }
Enumerates importance level values. More...
enum XTPCalendarEventCategories {
xtpCalendarEventCategoryUnknown = 0 , xtpCalendarEventCategoryYellow = 1 , xtpCalendarEventCategoryGreen = 2 , xtpCalendarEventCategoryRed = 3 ,
xtpCalendarEventCategoryPurple = 4 , xtpCalendarEventCategoryOrange = 5 , xtpCalendarEventCategoryBlue = 6
}
Enumerates standard Event Categories for office 2007 theme. More...
enum | XTPCalendarEventRecurrenceState { xtpCalendarRecurrenceNotRecurring = 0 , xtpCalendarRecurrenceMaster = 1 , xtpCalendarRecurrenceOccurrence = 2 , xtpCalendarRecurrenceException = 3 }
Enumerates recurrence states. More...
enum | XTPCalendarPatternEnd { xtpCalendarPatternEndDate , xtpCalendarPatternEndAfterOccurrences , xtpCalendarPatternEndNoDate }
Specify the end of the recurrence pattern type. More...
enum XTPCalendarEventRecurrenceType {
xtpCalendarRecurrenceUnknown = 0 , xtpCalendarRecurrenceDaily = 1 , xtpCalendarRecurrenceWeekly = 2 , xtpCalendarRecurrenceMonthly = 3 ,
xtpCalendarRecurrenceMonthNth = 4 , xtpCalendarRecurrenceYearly = 5 , xtpCalendarRecurrenceYearNth = 6
}
Enumerates Recurrence Pattern Types. More...
enum XTPCalendarWeekDay {
xtpCalendarDaySunday = 0x001 , xtpCalendarDayMonday = 0x002 , xtpCalendarDayTuesday = 0x004 , xtpCalendarDayWednesday = 0x008 ,
xtpCalendarDayThursday = 0x010 , xtpCalendarDayFriday = 0x020 , xtpCalendarDaySaturday = 0x040 , xtpCalendarDayAllWeek ,
xtpCalendarDaySaSu , xtpCalendarDayMo_Fr = xtpCalendarDayAllWeek ^ xtpCalendarDaySaSu
}
Enumerates Day of Weeks codes. More...
enum | XTPCalendarClockAlignFlags { xtpCalendarClockAlignLeft = 0x01 , xtpCalendarClockAlignCenter = 0x02 , xtpCalendarClockAlignRight = 0x04 }
enum XTPCalendarWeek {
xtpCalendarWeekFirst = 1 , xtpCalendarWeekSecond = 2 , xtpCalendarWeekThird = 3 , xtpCalendarWeekFourth = 4 ,
xtpCalendarWeekLast = 5
}
Enumerates a sequence numbers for days. More...
enum XTPCalendarDataProvider {
xtpCalendarDataProviderUnknown = 0 , xtpCalendarDataProviderMemory = 1 , xtpCalendarDataProviderDatabase = 2 , xtpCalendarDataProviderMAPI = 3 ,
xtpCalendarDataProviderCustom = 4
}
Enumeration used to determine the calendar data provider in use. More...
enum XTPCalendarViewType {
xtpCalendarDayView , xtpCalendarWorkWeekView , xtpCalendarWeekView , xtpCalendarMonthView ,
xtpCalendarFullWeekView , xtpCalendarTimeLineView
}
Enumeration used to determine the calendar view type in use. More...
enum XTPCalendarMouseMode {
xtpCalendarMouseNothing , xtpCalendarMouseEventPreResizeV , xtpCalendarMouseEventPreResizeH , xtpCalendarMouseEventPreDrag ,
xtpCalendarMouseEventResizingV , xtpCalendarMouseEventResizingH , xtpCalendarMouseEventDragCopy , xtpCalendarMouseEventDragMove ,
xtpCalendarMouseEventDraggingOut
}
Enumeration of operational mouse modes. More...
enum XTPCalendarUpdateOptions {
xtpCalendarUpdateLayout = 0x0001 , xtpCalendarUpdateScrollBar = 0x0002 , xtpCalendarUpdateRedraw = 0x0004 , xtpCalendarUpdateAll = 0x000F ,
xtpCalendarUpdateRedrawIfNeed = 0x0010
}
Contains bit-masks for adjusting the calendar control. More...
enum | XTPCalendarViewChangedUpdateOptions { xtpCalendarViewChangedSend = 1 , xtpCalendarViewChangedLock = 2 }
This enumeration contains options for CXTPCalendarControl::CViewChangedContext. More...
enum XTPCalendarHitTestCode {
xtpCalendarHitTestUnknown = 0 , xtpCalendarHitTestDayArea = 0x000001 , xtpCalendarHitTestDayHeader = 0x000002 , xtpCalendarHitTestDayExpandButton = 0x000004 ,
xtpCalendarHitTestGroupArea = xtpCalendarHitTestDayArea , xtpCalendarHitTestGroupHeader = 0x000008 , xtpCalendarHitTestDay_Mask = 0x00000F , xtpCalendarHitTestEventDragArea = 0x000010 ,
xtpCalendarHitTestEventTextArea = 0x000020 , xtpCalendarHitTestEventResizeVArea = 0x000100 , xtpCalendarHitTestEventResizeHArea = 0x000200 , xtpCalendarHitTestEventResizeArea_Mask ,
xtpCalendarHitTestEventResizeBegin = 0x000400 , xtpCalendarHitTestEventResizeEnd = 0x000800 , xtpCalendarHitTestEvent_Mask = 0x000FF0 , xtpCalendarHitTestDayViewTimeScale = 0x001000 ,
xtpCalendarHitTestDayViewCell = 0x002000 , xtpCalendarHitTestDayViewAllDayEvent = 0x004000 , xtpCalendarHitTestDayViewScrollUp = 0x010000 , xtpCalendarHitTestDayViewScrollDown = 0x020000 ,
xtpCalendarHitTestAllDayEventsScrollUp = 0x030000 , xtpCalendarHitTestAllDayEventsScrollDown = 0x040000 , xtpCalendarHitTestDayView_Mask = 0x0FF000 , xtpCalendarHitTestPrevEventButton = 0x100000 ,
xtpCalendarHitTestNextEventButton = 0x200000 , xtpCalendarHitTestTimeLineScale = 0x400000 , xtpCalendarHitTestAllDayExpandButton
}
Enumerates allowable hit test codes. More...
enum XTPCalendarDraggingMode {
xtpCalendaDragModeUnknown = 0 , xtpCalendaDragModeCopy = 1 , xtpCalendaDragModeMove = 2 , xtpCalendaDragModeResizeBegin = 3 ,
xtpCalendaDragModeResizeEnd = 4 , xtpCalendaDragModeEditSubject = 5
}
Enumerates allowable dragging mode state codes. More...
enum | XTPCalendarEndEditSubjectAction { xtpCalendarEditSubjectUnknown = 0 , xtpCalendarEditSubjectCommit = 1 , xtpCalendarEditSubjectCancel = 2 }
Enumerates allowable flags for driving subject editors. More...
enum | XTPCalendarUndoMode { xtpCalendarUndoModeUnknown = 0 , xtpCalendarUndoModeUndo = 1 , xtpCalendarUndoModeRedo = 2 }
Enumerates flags to identify undo mode. More...
enum | XTPCalendarClipboardCopyFlags { xtpCalendarCopyFlagROccurrence2RException = 0x0001 , xtpCalendarCopyFlagKeepRException = 0x0002 , xtpCalendarCopyFlagClearCBAfterPaste = 0x0004 , xtpCalendarCopyFlagCutMask }
Enumerates additional flags used in clipboard operations. More...
enum | XTPEnumCalendarReminderForOccurrenceParameters { xtpCalendarRmdPrm_Default = LONG_MAX , xtpCalendarRmdPrm_DontChange = LONG_MIN }
Enumerates parameters used in configuring reminders for recurrence patterns occurrences. More...
enum | XTPCalendarCurrentTimeMarkFlags { xtpCalendarCurrentTimeMarkNone = 0 , xtpCalendarCurrentTimeMarkVisibleForToday = 1 , xtpCalendarCurrentTimeMarkVisibleAlways = 2 , xtpCalendarCurrentTimeMarkPrinted = 4 }
Enumerates flags to CXTPCalendarOptions.nDayView_CurrentTimeMarkVisible member. More...
enum XTPCalendarEventIconIDs {
xtpCalendarEventIconIDReminder = -1 , xtpCalendarEventIconIDOccurrence = -2 , xtpCalendarEventIconIDException = -3 , xtpCalendarEventIconIDMeeting = -4 ,
xtpCalendarEventIconIDPrivate = -5
}
Icons IDs set to be used with calendar event custom icons to customize standard event glyphs. More...
enum XTPCalendarDayViewScrollDirection {
xtpCalendarDayViewScrollUp , xtpCalendarDayViewScrollDown , xtpCalendarDayViewScrollNotNeeded , xtpCalendarDayViewScrollLeft ,
xtpCalendarDayViewScrollRight
}
Enumeration used to determine the scroll direction. More...
enum | XTPCalendarDataProviderCacheMode { xtpCalendarDPCacheModeOff = 0x000 , xtpCalendarDPCacheModeOnRepeat = 0x001 , xtpCalendarDPCacheModeOnClear = 0x002 , xtpCalendarDPCacheModeOnMask = 0x00F }
Enumerates DB Provider cache modes. More...
enum XTPEnumCalendarTimeScaleParamsID {
xtpTSPID_Unknown = 0 , xtpTSPID_Day = 1 , xtpTSPID_Week = 2 , xtpTSPID_Month = 3 ,
xtpTSPID_WorkWeek = 4
}
= More...
enum XTPCalendarEditOperation {
xtpCalendarEO_Unknown = 0 , xtpCalendarEO_DragCopy = xtpCalendaDragModeCopy , xtpCalendarEO_DragMove = xtpCalendaDragModeMove , xtpCalendarEO_DragResizeBegin = xtpCalendaDragModeResizeBegin ,
xtpCalendarEO_DragResizeEnd = xtpCalendaDragModeResizeEnd , xtpCalendarEO_EditSubject_ByF2 , xtpCalendarEO_EditSubject_ByMouseClick , xtpCalendarEO_EditSubject_ByTab ,
xtpCalendarEO_EditSubject_AfterEventResize , xtpCalendarEO_Cut , xtpCalendarEO_Copy , xtpCalendarEO_Paste ,
xtpCalendarEO_DeleteSelectedEvents , xtpCalendarEO_DeleteEvent , xtpCalendarEO_InPlaceCreateEvent
}
Enumerates customizable event edit operations. More...
enum | XTPCalendarSelectionChanged { xtpCalendarSelectionUnknown = 0 , xtpCalendarSelectionDays = 1 , xtpCalendarSelectionEvents = 2 }
Enumerates calendar selection types. More...
enum | XTPCalendarExpandDayButton { xtpCalendarExpandDayButton_MonthView = 0x01 , xtpCalendarExpandDayButton_WeekView = 0x02 }
This enum defines parameters for xtpCalendarUserAction_OnExpandDay user action. More...
enum | XTPCalendarScrollDayButton { xtpCalendarScrollDayButton_DayViewUp = xtpCalendarHitTestDayViewScrollUp , xtpCalendarScrollDayButton_DayViewDown }
This enum defines parameters for xtpCalendarUserAction_OnScrollDay user action. More...
enum XTPCalendarGetItemText {
xtpCalendarItemText_EventSubject = 0x00000001 , xtpCalendarItemText_EventLocation = 0x00000002 , xtpCalendarItemText_DayViewDayHeader = 0x00000004 , xtpCalendarItemText_WeekViewDayHeader = 0x00000008 ,
xtpCalendarItemText_MonthViewDayHeader = 0x00000010 , xtpCalendarItemText_MonthViewWeekDayHeader = 0x00000020 , xtpCalendarItemText_EventToolTipText = 0x00000040 , xtpCalendarItemText_EventStartTimeText = 0x00000100 ,
xtpCalendarItemText_EventEndTimeText = 0x00000200 , xtpCalendarItemText_CaptionBarDayViewDateLabel , xtpCalendarItemText_CaptionBarWeekViewDateLabel , xtpCalendarItemText_CaptionBarMonthViewDateLabel
}
This enum defines a set of flags which enable calendar items to send XTP_NC_CALENDAR_GETITEMTEXT notifications. More...
enum XTPCalendarGetItemTextEx {
xtpCalendarItemText_EventBody = 0x00010000 , xtpCalendarItemText_EventMarkupTemplate = 0x04000000 , xtpCalendarItemText_DayViewDayHeaderLeft = 0x00020000 , xtpCalendarItemText_DayViewDayHeaderCenter = 0x00040000 ,
xtpCalendarItemText_DayViewDayHeaderRight = 0x00080000 , xtpCalendarItemText_WeekViewDayHeaderLeft = 0x00100000 , xtpCalendarItemText_WeekViewDayHeaderCenter = 0x00200000 , xtpCalendarItemText_WeekViewDayHeaderRight = 0x00400000 ,
xtpCalendarItemText_MonthViewDayHeaderLeft = 0x00800000 , xtpCalendarItemText_MonthViewDayHeaderCenter , xtpCalendarItemText_MonthViewDayHeaderRight = 0x02000000
}
This enum defines set of flags which enable calendar items to send XTP_NC_CALENDAR_GETITEMTEXT notification. More...

Variables

const UINT | WM_XTP_CALENDAR_BASE = (WM_USER + 9600)
The WM_XTP_CALENDAR_BASE constant is used by Calendar Control to help define private messages for use by private window classes, usually of the form WM_XTP_CALENDAR_BASE+X, where X is an integer value.
static const LPCTSTR | cszEventCustProp_NextReminderTime_Snoozed
String name of the corresponding property.
static const LPCTSTR | cszEventCustProp_IconsIDs = _T("*xtp*CustomIcons")
String name of the corresponding property.
static const LPCTSTR | cszEventCustProp_CategoryIDs
String name of the corresponding property.
static const LPCTSTR | cszEventCustProp_MarkupTemplate
String name of the MarkupTemplate property.
static const LPCTSTR | cszCalendarMarkupPrm_Subject
Subject.
static const LPCTSTR | cszCalendarMarkupPrm_Location
Location.
static const LPCTSTR | cszCalendarMarkupPrm_Body = _T("/Calendar/Events/Event/Body")
Body.
static const LPCTSTR | cszCalendarMarkupPrm_EndTime
End time.
static const LPCTSTR | XTPCALENDARCTRL_CLASSNAME = _T("XTPCalendar")
Custom class name for the Calendar control window.
static const LPCTSTR | XTPCALENDARCTRL_SWITCHVIEWMSG = _T("XTPCalendarSwitchView")
String name of the calendar switch view custom message.
const UINT | xtp_wm_SwitchView = RegisterWindowMessage(XTPCALENDARCTRL_SWITCHVIEWMSG)
A message identifier of the calendar switch view custom message.
static const LPCTSTR | XTPCALENDARCTRL_USERACTION = _T("XTPCalendarUserAction")
String name of the calendar switch view custom message.
const UINT | xtp_wm_UserAction = RegisterWindowMessage(XTPCALENDARCTRL_USERACTION)
A message identifier of the Calendar User Action custom message.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Macro Definition Documentation

◆ XTP_CALENDAR_DEFAULT_LABEL_ID

#define XTP_CALENDAR_DEFAULT_LABEL_ID 0

Define event label ID which is used by default for a new event.

(Valid for default labels list only)

◆ XTP_CALENDAR_DRAW_EVENTITEMTEXT_MAX

#define XTP_CALENDAR_DRAW_EVENTITEMTEXT_MAX 255

Define maximum text length for calendar event subject, location or body which will be drawn on the screen.

Used to optimize drawing performance.

◆ XTP_CALENDAR_NONE_LABEL_ID

#define XTP_CALENDAR_NONE_LABEL_ID 0

Define event label ID which signifies no label.

(Valid for default labels list only)

◆ XTP_CALENDAR_TIMEZONESKEY_9X

#define XTP_CALENDAR_TIMEZONESKEY_9X _T("SOFTWARE\\Microsoft\\Windows\\CurrentVersion\\Time Zones")

The location in the registry that contains time zone information for Windows 9x family.

See also
Microsoft KB221542

◆ XTP_CALENDAR_TIMEZONESKEY_NT

#define XTP_CALENDAR_TIMEZONESKEY_NT _T("SOFTWARE\\Microsoft\\Windows NT\\CurrentVersion\\Time Zones")

The location in the registry that contains time zone information for Windows NT family (NT/2000/XP).

See also
Microsoft KB221542

◆ XTP_CALENDAR_TZIRegValName_DATA

#define XTP_CALENDAR_TZIRegValName_DATA _T("TZI")

Registry key name for some TIME_ZONE_INFORMATION structure members.

See also
Microsoft KB115231
CXTPCalendarTimeZones::REGISTRY_TIMEZONE_INFORMATION

◆ XTP_CALENDAR_TZIRegValName_DaylightName

#define XTP_CALENDAR_TZIRegValName_DaylightName _T("Dlt")

Registry key name for a DaylightName member value of TIME_ZONE_INFORMATION.

See also
TIME_ZONE_INFORMATION WinAPI structure

◆ XTP_CALENDAR_TZIRegValName_DaylightNameW

#define XTP_CALENDAR_TZIRegValName_DaylightNameW L"Dlt"

Registry key name for a DaylightName member value of TIME_ZONE_INFORMATION.

See also
TIME_ZONE_INFORMATION WinAPI structure

◆ XTP_CALENDAR_TZIRegValName_DisplayStr

#define XTP_CALENDAR_TZIRegValName_DisplayStr _T("Display")

Registry key name for a time zone display string value.

For example: "(GMT+02:00) Athens, Beirut, Istanbul, Minsk"

◆ XTP_CALENDAR_TZIRegValName_Index

#define XTP_CALENDAR_TZIRegValName_Index _T("Index")

Registry key name for a time zone order index value.

This index value is used to sort time zones in the right order.

◆ XTP_CALENDAR_TZIRegValName_StandardName

#define XTP_CALENDAR_TZIRegValName_StandardName _T("Std")

Registry key name for a StandardName member value of TIME_ZONE_INFORMATION.

See also
TIME_ZONE_INFORMATION WinAPI structure
XTP_CALENDAR_TZIRegValName_StandardNameW

◆ XTP_CALENDAR_TZIRegValName_StandardNameW

#define XTP_CALENDAR_TZIRegValName_StandardNameW L"Std"

Registry key name for a StandardName member value of TIME_ZONE_INFORMATION.

See also
TIME_ZONE_INFORMATION WinAPI structure
XTP_CALENDAR_TZIRegValName_StandardName

Enumeration Type Documentation

◆ XTPCalendarClipboardCopyFlags

enum XTPCalendarClipboardCopyFlags

Enumerates additional flags used in clipboard operations.

Enumerator
xtpCalendarCopyFlagROccurrence2RException | Convert recurrence Occurrence to Exception before paste.
xtpCalendarCopyFlagKeepRException | Keep recurrence Exception event state before paste.
xtpCalendarCopyFlagClearCBAfterPaste | Clear clipboard after paste.
xtpCalendarCopyFlagCutMask | Default flags for Cut operation.

◆ XTPCalendarClockAlignFlags

enum XTPCalendarClockAlignFlags

Determines allowable values for the alignment of clock images used by the DrawClock function.

Enumerator
xtpCalendarClockAlignLeft | Align to the left side of the rectangle area.
xtpCalendarClockAlignCenter | Align on the middle of the rectangle area.
xtpCalendarClockAlignRight | Align to the right side of the rectangle area.

◆ XTPCalendarCurrentTimeMarkFlags

enum XTPCalendarCurrentTimeMarkFlags

Enumerates flags to CXTPCalendarOptions.nDayView_CurrentTimeMarkVisible member.

This set of flags define when Current Time Mark on the timescale is visible.

Enumerator
xtpCalendarCurrentTimeMarkNone | Time Mark invisible.
xtpCalendarCurrentTimeMarkVisibleForToday | Time Mark visible if today day is visible.
xtpCalendarCurrentTimeMarkVisibleAlways | Time Mark always visible.
xtpCalendarCurrentTimeMarkPrinted | If this flag set - Time Mark is visible for printed calendar also, otherwise it is hidden when printing.

◆ XTPCalendarDataProvider

enum XTPCalendarDataProvider

Enumeration used to determine the calendar data provider in use.

This enumeration contains all available data provider types.

See also
CXTPCalendarData
CXTPCalendarMemoryDataProvider
CXTPCalendarDatabaseDataProvider
Enumerator
xtpCalendarDataProviderUnknown | Unknown data provider.
xtpCalendarDataProviderMemory | Memory data provider - CXTPCalendarMemoryDataProvider.
xtpCalendarDataProviderDatabase | Database data provider - CXTPCalendarDatabaseDataProvider.
xtpCalendarDataProviderMAPI | MAPI (Exchange server) data provider - CXTPCalendarMAPIDataProvider.
xtpCalendarDataProviderCustom | Custom data provider - CXTPCalendarCustomDataProvider.

◆ XTPCalendarDataProviderCacheMode

enum XTPCalendarDataProviderCacheMode

Enumerates DB Provider cache modes.

Enumerator
xtpCalendarDPCacheModeOff | Cache is not used.
xtpCalendarDPCacheModeOnRepeat | Repeat all event manipulations in cache.
xtpCalendarDPCacheModeOnClear | Clear cache after every event manipulation.
xtpCalendarDPCacheModeOnMask | Cache mode on mask.

◆ XTPCalendarDayViewScrollDirection

enum XTPCalendarDayViewScrollDirection

Enumeration used to determine the scroll direction.

The enumeration determines if scrolling is necessary based on the scroll mode (up, down, or NotNeeded.)

See also
CXTPCalendarDayView
Enumerator
xtpCalendarDayViewScrollUp | ScrollV Up.
xtpCalendarDayViewScrollDown | ScrollV Down.
xtpCalendarDayViewScrollNotNeeded | Scrolling not needed.
xtpCalendarDayViewScrollLeft | ScrollH Left.
xtpCalendarDayViewScrollRight | ScrollH Right.

◆ XTPCalendarDraggingMode

enum XTPCalendarDraggingMode

Enumerates allowable dragging mode state codes.

Enumerator
xtpCalendaDragModeUnknown | No dragging mode.
xtpCalendaDragModeCopy | Copying event.
xtpCalendaDragModeMove | Moving event.
xtpCalendaDragModeResizeBegin | Resizing event begin.
xtpCalendaDragModeResizeEnd | Resizing event end.
xtpCalendaDragModeEditSubject | Editing event subject.

◆ XTPCalendarEditOperation

enum XTPCalendarEditOperation

Enumerates customizable event edit operations.

Enumerator
xtpCalendarEO_Unknown | Unknown operation value.
xtpCalendarEO_DragCopy | Drag copy event.
xtpCalendarEO_DragMove | Drag move event.
xtpCalendarEO_DragResizeBegin | Drag Resizing event begin.
xtpCalendarEO_DragResizeEnd | Drag Resizing event end.
xtpCalendarEO_EditSubject_ByF2 | In-place edit event subject by F2.
xtpCalendarEO_EditSubject_ByMouseClick | In-place edit event subject by Mouse Click.
xtpCalendarEO_EditSubject_ByTab | In-place edit event subject by TAB.
xtpCalendarEO_EditSubject_AfterEventResize | In-place edit event subject after event resize.
xtpCalendarEO_Cut | Cut events.
xtpCalendarEO_Copy | Copy events.
xtpCalendarEO_Paste | Paste event. wParam = XTP_EVENT_PASTE_OPERATION_PARAMS*. pEventViews member is NULL.
xtpCalendarEO_DeleteSelectedEvents | Delete selected events.
xtpCalendarEO_DeleteEvent | Delete event. Sent for a single event or for each selected event.
xtpCalendarEO_InPlaceCreateEvent | In-place event creation.

◆ XTPCalendarEndEditSubjectAction

enum XTPCalendarEndEditSubjectAction

Enumerates allowable flags for driving subject editors.

Enumerator
xtpCalendarEditSubjectUnknown | Action is undefined.
xtpCalendarEditSubjectCommit | Apply and commit dragging.
xtpCalendarEditSubjectCancel | Cancel editing and dragging changes.

◆ XTPCalendarEventBusyStatus

enum XTPCalendarEventBusyStatus

Enumerates busy status values.

Example:

CXTPCalendarData* pData;
CXTPCalendarEventPtr ptrEvent = pData->CreateNewEvent();
ptrEvent->SetBusyStatus(xtpCalendarBusyStatusTentative);
VERIFY(pCalendarData->AddEvent(ptrEvent));
See also
CXTPCalendarEvent::SetBusyStatus
Enumerator
xtpCalendarBusyStatusUnknown | Typed unknown value.
xtpCalendarBusyStatusFree | Free event status.
xtpCalendarBusyStatusElsewhere | Working elsewhere event status.
xtpCalendarBusyStatusTentative | Tentative event status.
xtpCalendarBusyStatusBusy | Busy event status.
xtpCalendarBusyStatusOutOfOffice | OutOfOffice event status.

◆ XTPCalendarEventCategories

enum XTPCalendarEventCategories

Enumerates standard Event Categories for office 2007 theme.

Enumerator
xtpCalendarEventCategoryUnknown | Typed unknown value.
xtpCalendarEventCategoryYellow | The Yellow category ID.
xtpCalendarEventCategoryGreen | The Green category ID.
xtpCalendarEventCategoryRed | The Red category ID.
xtpCalendarEventCategoryPurple | The Purple category ID.
xtpCalendarEventCategoryOrange | The Orange category ID.
xtpCalendarEventCategoryBlue | The Blue category ID.

◆ XTPCalendarEventIconIDs

enum XTPCalendarEventIconIDs

Icons IDs set to be used with calendar event custom icons to customize standard event glyphs.

Enumerator
xtpCalendarEventIconIDReminder | Reminder glyph ID.
xtpCalendarEventIconIDOccurrence | Recurrence glyph ID.
xtpCalendarEventIconIDException | Recurrence exception glyph ID.
xtpCalendarEventIconIDMeeting | Meeting glyph ID.
xtpCalendarEventIconIDPrivate | Private glyph ID.

◆ XTPCalendarEventImportance

enum XTPCalendarEventImportance

Enumerates importance level values.

Example:

CXTPCalendarData* pData;
CXTPCalendarEventPtr ptrEvent = pData->CreateNewEvent();
ptrEvent->SetImportance(xtpCalendarImportanceHigh);
VERIFY(pCalendarData->AddEvent(ptrEvent));
See also
CXTPCalendarEvent::SetImportance
Enumerator
xtpCalendarImportanceUnknown | Typed unknown value.
xtpCalendarImportanceLow | Low importance level.
xtpCalendarImportanceNormal | Normal importance level.
xtpCalendarImportanceHigh | High importance level.

◆ XTPCalendarEventRecurrenceState

enum XTPCalendarEventRecurrenceState

Enumerates recurrence states.

Enumerator
xtpCalendarRecurrenceNotRecurring | Event is not recurring.
xtpCalendarRecurrenceMaster | Event is a Master (template to generate occurrences).
xtpCalendarRecurrenceOccurrence | Event is Occurrence.
xtpCalendarRecurrenceException | Event is Exception (changed occurrence).

◆ XTPCalendarEventRecurrenceType

enum XTPCalendarEventRecurrenceType

Enumerates Recurrence Pattern Types.

Enumerator
xtpCalendarRecurrenceUnknown | Typed unknown value.
xtpCalendarRecurrenceDaily | Every N days. N = { 1, 2 .. }
xtpCalendarRecurrenceWeekly | Every N weeks on specified 'DaysMask'. N = { 1, 2 .. }, DaysMask = {see enum XTPCalendarWeekDay}
xtpCalendarRecurrenceMonthly | D day of every N months. D = { 1, 2 .. 31} N = { 1, 2 .. }
xtpCalendarRecurrenceMonthNth | The first, second, ... X of every N months. first, second, ... = {see enum XTPCalendarWeek} X = {see enums XTPCalendarWeekDay} N = { 1, 2 .. }
xtpCalendarRecurrenceYearly | Every month(M) day(D). M = { 1, 2 .. 12} D = { 1, 2 .. 31}
xtpCalendarRecurrenceYearNth | The first, second, ... X of month(M). first, second, ... = {see enum XTPCalendarWeek} X = {see enums XTPCalendarWeekDay} M = { 1, 2 .. 12}

◆ XTPCalendarExpandDayButton

enum XTPCalendarExpandDayButton

This enum defines parameters for xtpCalendarUserAction_OnExpandDay user action.

See also
XTP_NC_CALENDAR_USERACTION
XTP_CALENDAR_USERACTION_PARAMS
Enumerator
xtpCalendarExpandDayButton_MonthView | Defines Month view expand button.
xtpCalendarExpandDayButton_WeekView | Defines Week view expand button.

◆ XTPCalendarGetItemText

enum XTPCalendarGetItemText

This enum defines a set of flags which enable calendar items to send XTP_NC_CALENDAR_GETITEMTEXT notifications.

See also
XTPCalendarGetItemTextEx, XTP_NC_CALENDAR_GETITEMTEXT
CXTPCalendarControl::GetAskItemTextFlags
CXTPCalendarPaintManager::GetAskItemTextFlags
CXTPCalendarPaintManager::SetAskItemTextFlags
CXTPCalendarTheme::GetAskItemTextFlags
CXTPCalendarTheme::SetAskItemTextFlags
Enumerator
xtpCalendarItemText_EventSubject | Send request to customize Event subject text before draw it.
xtpCalendarItemText_EventLocation | Send request to customize Event location text before draw it.
xtpCalendarItemText_DayViewDayHeader | Send request to customize Day view day header text. Used for office 2003 theme only.
xtpCalendarItemText_WeekViewDayHeader | Send request to customize Week view day header text. Used for office 2003 theme only.
xtpCalendarItemText_MonthViewDayHeader | Send request to customize Month view day header text. Used for office 2003 theme only.
xtpCalendarItemText_MonthViewWeekDayHeader | Send request to customize month view week day header text.
xtpCalendarItemText_EventToolTipText | Send request to customize event tooltip text.
xtpCalendarItemText_EventStartTimeText | Send request to customize event start time text.
xtpCalendarItemText_EventEndTimeText | Send request to customize event end time text.
xtpCalendarItemText_CaptionBarDayViewDateLabel | Send request to customize caption bar date label for day view.
xtpCalendarItemText_CaptionBarWeekViewDateLabel | Send request to customize caption bar date label for week view.
xtpCalendarItemText_CaptionBarMonthViewDateLabel | Send request to customize caption bar date label for month view.

◆ XTPCalendarGetItemTextEx

enum XTPCalendarGetItemTextEx

This enum defines set of flags which enable calendar items to send XTP_NC_CALENDAR_GETITEMTEXT notification.

These flags are used for office 2007 theme only.

See also
XTPCalendarGetItemText, XTP_NC_CALENDAR_GETITEMTEXT
CXTPCalendarControl::GetAskItemTextFlags
CXTPCalendarPaintManager::GetAskItemTextFlags
CXTPCalendarPaintManager::SetAskItemTextFlags
CXTPCalendarTheme::GetAskItemTextFlags
CXTPCalendarTheme::SetAskItemTextFlags
Enumerator
xtpCalendarItemText_EventBody | Send request to customize Event body text before draw it.
xtpCalendarItemText_EventMarkupTemplate | Send request to set Event Markup Template text before draw it.
xtpCalendarItemText_DayViewDayHeaderLeft | Send request to customize Day view day header text on the left.
xtpCalendarItemText_DayViewDayHeaderCenter | Send request to customize Day view day header text on the center.
xtpCalendarItemText_DayViewDayHeaderRight | Send request to customize Day view day header text on the right.
xtpCalendarItemText_WeekViewDayHeaderLeft | Send request to customize Week view day header text on the left.
xtpCalendarItemText_WeekViewDayHeaderCenter | Send request to customize Week view day header text on the center.
xtpCalendarItemText_WeekViewDayHeaderRight | Send request to customize Week view day header text on the right.
xtpCalendarItemText_MonthViewDayHeaderLeft | Send request to customize Month view day header text on the left.
xtpCalendarItemText_MonthViewDayHeaderCenter | Send request to customize Month view day header text on the center.
xtpCalendarItemText_MonthViewDayHeaderRight | Send request to customize Month view day header text on the right.

◆ XTPCalendarHitTestCode

enum XTPCalendarHitTestCode

Enumerates allowable hit test codes.

ResizeV, ResizeH flags are used together with ResizeBegin or ResizeEnd.

Enumerator
xtpCalendarHitTestUnknown | The position is unknown or does not belong to our control.
xtpCalendarHitTestDayArea | The position is inside the days area.
xtpCalendarHitTestDayHeader | The position is inside control's header.
xtpCalendarHitTestDayExpandButton | The position is over Expand day button icon.
xtpCalendarHitTestGroupArea | The position is inside a group area (formerly day).
xtpCalendarHitTestGroupHeader | The position is inside Group (resource) header.
xtpCalendarHitTestDay_Mask | The mask for any position inside days area with the header.
xtpCalendarHitTestEventDragArea | The position is on Event drag area.
xtpCalendarHitTestEventTextArea | The position is on Event text view area.
xtpCalendarHitTestEventResizeVArea | Event vertical resize area.
xtpCalendarHitTestEventResizeHArea | Event horizontal resize area.
xtpCalendarHitTestEventResizeArea_Mask | The mask for both event resize areas.
xtpCalendarHitTestEventResizeBegin | Event start resizing area.
xtpCalendarHitTestEventResizeEnd | Event end resizing area.
xtpCalendarHitTestEvent_Mask | The mask for event area at whole.
xtpCalendarHitTestDayViewTimeScale | Time scale part of the day view.
xtpCalendarHitTestDayViewCell | Day view cells - its general part.
xtpCalendarHitTestDayViewAllDayEvent | All day zone on the day view.
xtpCalendarHitTestDayViewScrollUp | DayView Scroll Up button (presents in office 2007 theme only).
xtpCalendarHitTestDayViewScrollDown | DayView Scroll Down button (presents in office 2007 theme only).
xtpCalendarHitTestAllDayEventsScrollUp | All Day Event block scroll up button.
xtpCalendarHitTestAllDayEventsScrollDown | All Day Event block scroll down button.
xtpCalendarHitTestDayView_Mask | The mask for all DayView areas.
xtpCalendarHitTestPrevEventButton | Go to Previous event button (presents in office 2007 theme only).
xtpCalendarHitTestNextEventButton | Go to Next event button (presents in office 2007 theme only).
xtpCalendarHitTestTimeLineScale | Calendar HitTest TimeLineScale.
xtpCalendarHitTestAllDayExpandButton | The position is over Expand button icon in allday header.

◆ XTPCalendarMouseMode

enum XTPCalendarMouseMode

Enumeration of operational mouse modes.

Calendar Control has several Mouse states that handled by control. This enumeration helps to clearly identify each of these Sends Notifications: Sends Messages:

Enumerator
xtpCalendarMouseNothing | User is doing nothing - just watching the control.
xtpCalendarMouseEventPreResizeV | User is moving mouse under event view vertical "resize" area.
xtpCalendarMouseEventPreResizeH | User is moving mouse under event view horizontal "resize" area.
xtpCalendarMouseEventPreDrag | User is moving mouse under event view "drag" area.
xtpCalendarMouseEventResizingV | User is resizing event vertically (holding mouse left button down).
xtpCalendarMouseEventResizingH | User is resizing event horizontally (holding mouse left button down).
xtpCalendarMouseEventDragCopy | User is dragging event view (holding left mouse button down).
xtpCalendarMouseEventDragMove | User is dragging event view (holding left mouse button down and Control key is down).
xtpCalendarMouseEventDraggingOut | User is dragging event out of dragging area.

◆ XTPCalendarPatternEnd

enum XTPCalendarPatternEnd

Specify the end of the recurrence pattern type.

Enumerator
xtpCalendarPatternEndDate | End of the recurrence pattern specified by the date.
xtpCalendarPatternEndAfterOccurrences | End of the recurrence pattern specified by the. occurrences amount.
xtpCalendarPatternEndNoDate | Recurrence pattern has no End.

◆ XTPCalendarScrollDayButton

enum XTPCalendarScrollDayButton

This enum defines parameters for xtpCalendarUserAction_OnScrollDay user action.

(valid for office 2007 theme only)

See also
XTP_NC_CALENDAR_USERACTION
XTP_CALENDAR_USERACTION_PARAMS
Enumerator
xtpCalendarScrollDayButton_DayViewUp | Defines Day view Scroll Up button.
xtpCalendarScrollDayButton_DayViewDown | Defines Day view Scroll Down button.

◆ XTPCalendarSelectionChanged

enum XTPCalendarSelectionChanged

Enumerates calendar selection types.

Enumerator
xtpCalendarSelectionUnknown | Unknown selection value.
xtpCalendarSelectionDays | Days (or day hours for day view) selection. Use GetSelection() method to retrieve current selection.
xtpCalendarSelectionEvents | Events selection. Use GetSelectedViewEvents() and GetSelectedEvents() methods to retrieve currently selected events.

◆ XTPCalendarTheme

enum XTPCalendarTheme

Paint themes used by calendar.

Enumerator
xtpCalendarThemeUnknown | Undefined theme.
xtpCalendarThemeOffice2000 | Office 2000 theme.
xtpCalendarThemeOfficeXP | Office XP theme.
xtpCalendarThemeOffice2003 | Office 2003 theme.
xtpCalendarThemeOffice2013 | Office 2013 theme.
xtpCalendarThemeOffice2016 | Office 2016 theme.
xtpCalendarThemeResource | Resource theme.
xtpCalendarThemeVisualStudio2015 | VisualStudio 2015 theme.
xtpCalendarThemeNativeWindows10 | Windows 10 theme.
xtpCalendarThemeVisualStudio2017 | VisualStudio 2017 theme.
xtpCalendarThemeVisualStudio2019 | VisualStudio 2019 theme.
xtpCalendarThemeVisualStudio2022 | VisualStudio 2022 theme.
xtpCalendarThemeNativeWindows11 | Windows 11 theme.
xtpCalendarThemeOffice2007 | Office 2007 theme.
xtpCalendarThemeOffice2010 | Office 2010 theme.

◆ XTPCalendarThemeVersion

enum XTPCalendarThemeVersion

Paint theme versions used by calendar.

Enumerator
xtpCalendarVersionUnknown | Calendar theme version uknown.
xtpCalendarVersion2000 | Calendar theme version Office 2000.
xtpCalendarVersionXP | Calendar theme version Office XP.
xtpCalendarVersion2003 | Calendar theme version Office 2003.
xtpCalendarVersion2007 | Calendar theme version Office 2007.
xtpCalendarVersion2010 | Calendar theme version Office 2010.
xtpCalendarVersion2013 | Calendar theme version Office 2013.
xtpCalendarVersion2015 | Calendar theme version Visual Studio 2015
xtpCalendarVersion10 | Calendar theme version Native Windows 10
xtpCalendarVersion2017 | Calendar theme version Visual Studio 2017.
xtpCalendarVersion2019 | Calendar theme version Visual Studio 2019.
xtpCalendarVersion2022 | Calendar theme version Visual Studio 2022.
xtpCalendarVersion11 | Calendar theme version Native Windows 11.

◆ XTPCalendarUndoMode

enum XTPCalendarUndoMode

Enumerates flags to identify undo mode.

Enumerator
xtpCalendarUndoModeUnknown | Undo mode is undefined.
xtpCalendarUndoModeUndo | Undo action is pending.
xtpCalendarUndoModeRedo | Redo action is pending.

◆ XTPCalendarUpdateOptions

enum XTPCalendarUpdateOptions

Contains bit-masks for adjusting the calendar control.

This enumeration contains bit masks for using with CXTPCalendarControl::CUpdateContext. Depending on members of this enum there will be specific redrawing functionality called on exiting adjuster's scope.

Enumerator
xtpCalendarUpdateLayout | Adjust positions of control's elements.
xtpCalendarUpdateScrollBar | Recalculate control's scrollbar positions.
xtpCalendarUpdateRedraw | Redraw control picture.
xtpCalendarUpdateAll | Redraw all portions of the control on exiting adjuster scope.
xtpCalendarUpdateRedrawIfNeed | Redraw control's picture if needed.

◆ XTPCalendarViewChangedUpdateOptions

enum XTPCalendarViewChangedUpdateOptions

This enumeration contains options for CXTPCalendarControl::CViewChangedContext.

Enumerator
xtpCalendarViewChangedSend | Set send request for XTP_NC_CALENDARVIEWWASCHANGED notification and lock sending.
xtpCalendarViewChangedLock | Lock sending only, send request for XTP_NC_CALENDARVIEWWASCHANGED notification is not set.

◆ XTPCalendarViewType

enum XTPCalendarViewType

Enumeration used to determine the calendar view type in use.

This enumeration contains all available Calendar view types.

See also
CXTPCalendarView
CXTPCalendarDayView
CXTPCalendarWeekView
CXTPCalendarMonthView
Enumerator
xtpCalendarDayView | Day view - CXTPCalendarDayView
xtpCalendarWorkWeekView | Day view - CXTPCalendarDayView. Work week days are shown.
xtpCalendarWeekView | Week view - CXTPCalendarWeekView
xtpCalendarMonthView | Month view - CXTPCalendarMonthView
xtpCalendarFullWeekView | Day view - CXTPCalendarDayView. All week days are shown.
xtpCalendarTimeLineView | TimeLine view - CXTPCalendarTimeLineView

◆ XTPCalendarWeek

enum XTPCalendarWeek

Enumerates a sequence numbers for days.

Enumerator
xtpCalendarWeekFirst | First
xtpCalendarWeekSecond | Second.
xtpCalendarWeekThird | Third
xtpCalendarWeekFourth | Fourth.
xtpCalendarWeekLast | Last

◆ XTPCalendarWeekDay

enum XTPCalendarWeekDay

Enumerates Day of Weeks codes.

Enumerator
xtpCalendarDaySunday | Sunday
xtpCalendarDayMonday | Monday
xtpCalendarDayTuesday | Tuesday.
xtpCalendarDayWednesday | Wednesday
xtpCalendarDayThursday | Thursday
xtpCalendarDayFriday | Friday
xtpCalendarDaySaturday | Saturday
xtpCalendarDayAllWeek | All week mask.
xtpCalendarDaySaSu | Saturday, Sunday mask.
xtpCalendarDayMo_Fr | Monday to Friday mask.

◆ XTPEnumCalendarReminderForOccurrenceParameters

enum XTPEnumCalendarReminderForOccurrenceParameters

Enumerates parameters used in configuring reminders for recurrence patterns occurrences.

Enumerator
xtpCalendarRmdPrm_Default | Set default reminders value.
xtpCalendarRmdPrm_DontChange | Do not change reminders time value.

◆ XTPEnumCalendarTimeScaleParamsID

enum XTPEnumCalendarTimeScaleParamsID

=

A predefined set of different scales based on time intervals.

Enumerator
xtpTSPID_Unknown | Unspecified.
xtpTSPID_Day | Day scale
xtpTSPID_Week | Week scale
xtpTSPID_Month | Month scale
xtpTSPID_WorkWeek | WorkWeek scale.

Variable Documentation

◆ WM_XTP_CALENDAR_BASE

const UINT WM_XTP_CALENDAR_BASE = (WM_USER + 9600)

The WM_XTP_CALENDAR_BASE constant is used by Calendar Control to help define private messages for use by private window classes, usually of the form WM_XTP_CALENDAR_BASE+X, where X is an integer value.

See also
WM_USER overview


Toolkit Pro: XTPCalendarEvent.h File Reference

  • Source
  • Calendar
Classes
XTPCalendarEvent.h File Reference

Go to the source code of this file.

Classes

class CXTPCalendarEvent
This class represents the data of a single Event used in the Calendar control. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPCalendarEventColorDlg.h File Reference

  • Source
  • Calendar
Classes
XTPCalendarEventColorDlg.h File Reference

Go to the source code of this file.

Classes

class CXTPCalendarEventColorDlg
This class is used to edit Calendar Event Category and Label information. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPCalendarEventColorListBox.h File Reference

  • Source
  • Calendar
Classes
XTPCalendarEventColorListBox.h File Reference

Go to the source code of this file.

Classes

class | CXTPCalendarEventColorEdit
This class is used by CXTPCalendarEventColorListBox to create an inplace edit box for renaming event categories and labels. More...
class | CXTPCalendarEventColorListBox
This class is used to display a list of Calendar Event Categories or Labels that can be edited. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPCalendarEventColorNewDlg.h File Reference

  • Source
  • Calendar
Classes
XTPCalendarEventColorNewDlg.h File Reference

Go to the source code of this file.

Classes

class CXTPCalendarEventColorNewDlg
This class is used to add new Calendar Event Categories or Labels to the existing data array. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPCalendarEventLabel.h File Reference

  • Source
  • Calendar
Classes
XTPCalendarEventLabel.h File Reference

Go to the source code of this file.

Classes

class | CXTPCalendarEventLabel
This class defines Calendar Event label properties. More...
class | CXTPCalendarEventLabels
This class is used as a collection of CXTPCalendarEventLabel objects. More...
class | CXTPCalendarEventCategory
This class defines Calendar Event Category properties. More...
class | CXTPCalendarEventCategories
This class is used as a collection of CXTPCalendarEventCategory objects. More...
class | CXTPCalendarUIntArray
This class represents the collection of UINT elements. More...
class | CXTPCalendarIconIDs
This class represents the collection of custom icons IDs. More...
class | CXTPCalendarEventCategoryIDs
This class represents the collection of event categories IDs. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPCalendarEventPropertiesDlg.h File Reference

  • Source
  • Calendar
Classes
XTPCalendarEventPropertiesDlg.h File Reference

Go to the source code of this file.

Classes

class | CXTPCalendarComboBoxBase
This class is used as the base class for all owner drawn Calendar Event comboboxes. More...
class | CXTPCalendarEventCategoryComboBox
This class implements the event category selector combobox. More...
class | CXTPCalendarEventLabelComboBox
This class implements the event label selector combobox. More...
class | CXTPCalendarBusyStatusComboBox
This class implements the busy status selector combobox. More...
class | CXTPCalendarEventPropertiesDlg
This class is used to edit calendar event properties. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPCalendarEventRecurrenceDlg.h File Reference

  • Source
  • Calendar
Classes | Variables
XTPCalendarEventRecurrenceDlg.h File Reference

Go to the source code of this file.

Classes

class CXTPCalendarEventRecurrenceDlg
This class is used for manipulations with recurrence state of the events. More...

Variables

static const int XTP_CALENDAR_DLGRESULT_REMOVE_RECURRENCE = 103
This constant defines a value which returned from CXTPCalendarEventRecurrenceDlg::DoModal() when the "Remove Recurrence" button is pressed.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Variable Documentation

◆ XTP_CALENDAR_DLGRESULT_REMOVE_RECURRENCE

const int XTP_CALENDAR_DLGRESULT_REMOVE_RECURRENCE = 103
static

This constant defines a value which returned from CXTPCalendarEventRecurrenceDlg::DoModal() when the "Remove Recurrence" button is pressed.

See also
CXTPCalendarEventRecurrenceDlg


Toolkit Pro: XTPCalendarEvents.h File Reference

  • Source
  • Calendar
Classes
XTPCalendarEvents.h File Reference

Go to the source code of this file.

Classes

class CXTPCalendarEvents
This class represents a simple array collection of CXTPCalendarEvent objects. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPCalendarIIDs.h Source File

  • Source
  • Calendar
XTPCalendarIIDs.h
1// DO NOT MODIFY MANUALLY
2// Generated on Thu 12/11/2025 at 12:46:01.62 using cj-update-iids.cmd
3
24#ifndef __XTPCalendarIIDs_H__
25# define __XTPCalendarIIDs_H__
26
27// clang-format off
28
29#define XTP_DEFINE_GUID(name,l,w1,w2,b1,b2,b3,b4,b5,b6,b7,b8) \
30 EXTERN_C __declspec(selectany) const IID XTP##name = {l,w1,w2,{b1,b2,b3,b4,b5,b6,b7,b8}}; \
31 const unsigned long XTP##name##__Data1 = (l); \
32 const unsigned short XTP##name##__Data2 = (w1); \
33 const unsigned short XTP##name##__Data3 = (w2); \
34 const unsigned char XTP##name##__Data4_0 = (b1); \
35 const unsigned char XTP##name##__Data4_1 = (b2); \
36 const unsigned char XTP##name##__Data4_2 = (b3); \
37 const unsigned char XTP##name##__Data4_3 = (b4); \
38 const unsigned char XTP##name##__Data4_4 = (b5); \
39 const unsigned char XTP##name##__Data4_5 = (b6); \
40 const unsigned char XTP##name##__Data4_6 = (b7); \
41 const unsigned char XTP##name##__Data4_7 = (b8);
42
43XTP_DEFINE_GUID(LIBID_XtremeCalendarControl,0x79EB16A5,0x917F,0x4145,0xAB,0x5F,0xD3,0xAE,0xA6,0x06,0x12,0xD8);
44XTP_DEFINE_GUID(DIID_CalendarViewGroup,0xC0DE2430,0x778B,0x4af6,0xB9,0x20,0xAE,0x78,0x97,0x12,0xCF,0x73);
45XTP_DEFINE_GUID(DIID_CalendarFlagsSet,0xC0DE2430,0x972D,0x41c0,0x93,0xDB,0x0E,0xCF,0xEB,0x85,0xD5,0x36);
46XTP_DEFINE_GUID(DIID_ICalendarThemeRect,0xC0DE2430,0xF59E,0x420B,0xAF,0x82,0xA4,0xB8,0x4D,0x1D,0xC8,0x6F);
47XTP_DEFINE_GUID(DIID_ICalendarThemeImageList,0xC0DE2430,0xE371,0x4690,0xAC,0xF6,0x53,0x8F,0x88,0xC3,0x37,0x41);
48XTP_DEFINE_GUID(DIID_CalendarThemeDayViewCellParams,0xC0DE2430,0x83F7,0x4448,0xA6,0x41,0x50,0x67,0x6D,0xC8,0x7C,0x35);
49XTP_DEFINE_GUID(DIID_CalendarThemeDayViewTimeScaleCellParams,0xC0DE2430,0x386B,0x4219,0xA3,0x4C,0x9C,0x6C,0x99,0x90,0x0B,0x85);
50XTP_DEFINE_GUID(DIID_CalendarThemeColorGradient,0xC0DE2430,0x71A3,0x4549,0xA6,0x20,0xCB,0xF2,0x03,0xB4,0x54,0x78);
51XTP_DEFINE_GUID(DIID_CalendarThemeFontColor,0xC0DE2430,0x8ABD,0x48E2,0xB1,0xE9,0x8D,0x82,0x85,0x9D,0x6E,0xC6);
52XTP_DEFINE_GUID(DIID_CalendarThemeFormulaMulDivC,0xC0DE2430,0xB877,0x419C,0x94,0x42,0xB7,0xF8,0x22,0x82,0xA2,0xB0);
53XTP_DEFINE_GUID(DIID_CalendarThemeHeaderBackground,0xC0DE2430,0x1165,0x4B99,0xAC,0xB2,0xE5,0xB4,0x72,0x10,0x8A,0x01);
54XTP_DEFINE_GUID(DIID_CalendarThemeHeaderText,0xC0DE2430,0x30A0,0x4AF5,0x92,0x39,0x85,0x18,0xF1,0x34,0xFF,0x44);
55XTP_DEFINE_GUID(DIID_CalendarThemeDayViewTimeScale,0xC0DE2430,0xDC4C,0x4B93,0x9A,0xA1,0x9A,0xB5,0x7D,0x42,0x0E,0xDF);
56XTP_DEFINE_GUID(DIID_CalendarThemeDayViewAllDayEvents,0xC0DE2430,0x6F1D,0x4C02,0xA4,0x0B,0x40,0x61,0x10,0x63,0x58,0x42);
57XTP_DEFINE_GUID(DIID_CalendarThemeDayViewCell,0xC0DE2430,0xDAFB,0x4FE2,0x9F,0x7D,0xDE,0x11,0x4E,0x7F,0x78,0x04);
58XTP_DEFINE_GUID(DIID_CalendarThemeDayViewCellColors,0xC0DE2430,0x3F5C,0x4896,0xB1,0x6D,0x89,0x8F,0x1C,0xB5,0x01,0x9F);
59XTP_DEFINE_GUID(DIID_CalendarThemeOffice2007Header,0xC0DE2430,0x9DAB,0x4DE2,0x83,0x77,0x8D,0x98,0x92,0x1C,0x30,0x2B);
60XTP_DEFINE_GUID(DIID_CalendarThemeOffice2007Event,0xC0DE2430,0x3769,0x4BBF,0x83,0x29,0xDB,0xEC,0xF9,0x2C,0xBA,0xB6);
61XTP_DEFINE_GUID(DIID_CalendarThemeOffice2007EventFontsColors,0xC0DE2430,0xF7C0,0x4142,0xB5,0x4B,0xEB,0x64,0xA2,0x4B,0xB2,0x44);
62XTP_DEFINE_GUID(DIID_CalendarThemeEventIconsToDraw,0xC0DE2430,0x8A74,0x49B8,0xB7,0x19,0x2A,0xFC,0x09,0x4A,0xD4,0xAA);
63XTP_DEFINE_GUID(DIID_CalendarThemeOffice2007PrevNextEventButtons,0xC0DE2430,0x3AEC,0x48C6,0x90,0x2A,0x6F,0xE3,0xBE,0x41,0xEB,0xF8);
64XTP_DEFINE_GUID(DIID_CalendarThemeOffice2007DayView,0xC0DE2430,0xEE51,0x4DE3,0xB8,0x20,0xD3,0x36,0xE1,0x16,0x21,0xDF);
65XTP_DEFINE_GUID(DIID_CalendarThemeOffice2007DayViewDay,0xC0DE2430,0x3A4B,0x4843,0x9D,0xE3,0x36,0x07,0x41,0x89,0x08,0x7B);
66XTP_DEFINE_GUID(DIID_CalendarThemeOffice2007DayViewDayGroup,0xC0DE2430,0x3499,0x45E1,0x84,0x13,0x2A,0xCE,0x54,0x46,0xF7,0x6F);
67XTP_DEFINE_GUID(DIID_CalendarThemeOffice2007DayViewEvent,0xC0DE2430,0x4B52,0x48B1,0x89,0x36,0x57,0xD5,0x6D,0x0F,0xC3,0x49);
68XTP_DEFINE_GUID(DIID_CalendarThemeOffice2007DayViewEventMultiDay,0xC0DE2430,0x8076,0x4C63,0xA1,0xED,0xF6,0xB2,0x9E,0x13,0x8E,0x41);
69XTP_DEFINE_GUID(DIID_CalendarThemeOffice2007DayViewEventSingleDay,0xC0DE2430,0x8C7A,0x43E4,0xB1,0x32,0x7E,0x68,0x70,0x17,0x4B,0x8C);
70XTP_DEFINE_GUID(DIID_CalendarThemeOffice2007MonthView,0xC0DE2430,0x08BB,0x409E,0x8E,0x09,0x23,0x53,0x6B,0x4F,0x3A,0xAE);
71XTP_DEFINE_GUID(DIID_CalendarThemeOffice2007MonthViewDay,0xC0DE2430,0x4A01,0x462F,0x92,0x12,0x92,0x3F,0x25,0xCB,0xCD,0x94);
72XTP_DEFINE_GUID(DIID_CalendarThemeOffice2007MonthViewEvent,0xC0DE2430,0xEB47,0x480A,0xB8,0xEA,0x73,0xD2,0x8E,0x8D,0xC9,0x44);
73XTP_DEFINE_GUID(DIID_CalendarThemeOffice2007MonthViewEventMultiDay,0xC0DE2430,0x7E94,0x4D71,0x8B,0xD9,0x1B,0x38,0x4B,0xF4,0xA0,0x8B);
74XTP_DEFINE_GUID(DIID_CalendarThemeOffice2007MonthViewEventSingleDay,0xC0DE2430,0x9BDB,0x433C,0x95,0x7E,0xA0,0xE3,0xB5,0x89,0xF0,0x84);
75XTP_DEFINE_GUID(DIID_CalendarThemeOffice2007MonthViewWeekHeader,0xC0DE2430,0x85B8,0x4846,0xA2,0xCB,0xA2,0x32,0x9B,0xE9,0x59,0x3C);
76XTP_DEFINE_GUID(DIID_CalendarThemeOffice2007WeekView,0xC0DE2430,0x71FA,0x4524,0x90,0x6C,0x1A,0x1E,0x5A,0x04,0x97,0xD4);
77XTP_DEFINE_GUID(DIID_CalendarThemeOffice2007WeekViewDay,0xC0DE2430,0x7F55,0x4A5B,0xBE,0x02,0x18,0xBF,0x6F,0xD4,0xD5,0x4A);
78XTP_DEFINE_GUID(DIID_CalendarThemeOffice2007WeekViewEvent,0xC0DE2430,0x068C,0x4F6D,0x96,0xE7,0x6B,0xA2,0x6C,0x4E,0x26,0xD5);
79XTP_DEFINE_GUID(DIID_CalendarThemeOffice2007WeekViewEventMultiDay,0xC0DE2430,0x913D,0x4350,0xB9,0x54,0x5A,0xDE,0x6D,0x65,0xBE,0xF6);
80XTP_DEFINE_GUID(DIID_CalendarThemeOffice2007WeekViewEventSingleDay,0xC0DE2430,0x98CF,0x48B4,0x98,0xC8,0x9D,0xF4,0x7F,0x2C,0xAF,0xB1);
81XTP_DEFINE_GUID(DIID_ICalendarThemeOffice2007,0xC0DE2430,0x5D67,0x4d85,0x80,0xAA,0xB5,0x44,0xF1,0xF3,0x43,0x05);
82XTP_DEFINE_GUID(CLSID_CalendarThemeOffice2007,0xC0DE2430,0x53E6,0x4486,0xA9,0xA6,0x27,0x4A,0x2D,0xB3,0xB8,0x2D);
83XTP_DEFINE_GUID(CLSID_CalendarThemeImageList,0xC0DE2430,0xDF5D,0x4434,0x96,0x90,0x78,0x8F,0xD4,0x71,0xCF,0x5C);
84XTP_DEFINE_GUID(CLSID_CalendarThemeRect,0xC0DE2430,0xB8F4,0x4204,0xAE,0xA1,0x2A,0x25,0x94,0x49,0x36,0x56);
85XTP_DEFINE_GUID(DIID__DCalendarControl,0xC0DE2430,0xAD0A,0x47AC,0x95,0xEB,0xB5,0x4A,0x21,0x8A,0x7B,0x9C);
86XTP_DEFINE_GUID(DIID__DCalendarCaptionBar,0xC0DE2430,0x0C5A,0x4DEC,0x81,0x40,0x3F,0x8E,0x7F,0x3B,0x19,0x44);
87XTP_DEFINE_GUID(DIID__DCalendarCaptionBarEvents,0xC0DE2430,0x1617,0x41DB,0xBF,0xFF,0x2F,0x84,0x2A,0xAF,0x02,0xDA);
88XTP_DEFINE_GUID(CLSID_CalendarCaptionBar,0xC0DE2430,0xE602,0x42FE,0x94,0x1F,0xFF,0x71,0xA7,0xF0,0x85,0x3A);
89XTP_DEFINE_GUID(DIID_CalendarEvent,0xC0DE2430,0x21F7,0x41CF,0x90,0x8E,0x56,0x9C,0x0B,0x11,0x78,0x5F);
90XTP_DEFINE_GUID(DIID_CalendarViewDay,0xC0DE2430,0xA582,0x48D5,0x8C,0x45,0xE8,0xE6,0x5A,0x06,0x51,0x34);
91XTP_DEFINE_GUID(DIID_CalendarView,0xC0DE2430,0x7D83,0x44B5,0xB8,0x2C,0x2A,0xA8,0xA8,0x3F,0x6C,0x0D);
92XTP_DEFINE_GUID(DIID_CalendarEvents,0xC0DE2430,0x0FDB,0x4A59,0x94,0xD3,0xDB,0xBD,0xCE,0xDF,0xE0,0x38);
93XTP_DEFINE_GUID(DIID_CalendarDataProvider,0xC0DE2430,0xA643,0x4376,0xB1,0x1D,0x2B,0x36,0x31,0x76,0x4C,0xD5);
94XTP_DEFINE_GUID(DIID_CalendarCustomProperties,0xC0DE2430,0x11DA,0x4a0c,0xBB,0x5F,0xDA,0x28,0x32,0xFC,0x22,0x72);
95XTP_DEFINE_GUID(DIID_ICalendarResources,0xC0DE2430,0x4205,0x4f0a,0xB8,0x33,0xD4,0x92,0x01,0xDF,0x22,0x83);
96XTP_DEFINE_GUID(DIID_CalendarViewEvent,0xC0DE2430,0x3767,0x4DDC,0x95,0xCC,0x98,0x64,0x98,0x2A,0x7B,0x34);
97XTP_DEFINE_GUID(DIID_CalendarViewEvents,0xC0DE2430,0x69D9,0x4b45,0xA4,0x87,0x4F,0x74,0xFC,0x46,0xCC,0x65);
98XTP_DEFINE_GUID(DIID_CalendarViewGroups,0xC0DE2430,0xE33A,0x4622,0x95,0x19,0x65,0xCA,0x98,0xD4,0xB5,0x70);
99XTP_DEFINE_GUID(DIID_CalendarHitTestInfo,0xC0DE2430,0x344D,0x4925,0xBC,0x7E,0x69,0x0D,0xDD,0xAF,0x11,0x96);
100XTP_DEFINE_GUID(DIID_CalendarSystemTime,0xC0DE2430,0x591D,0x4490,0x9A,0xA3,0xBB,0x3E,0xDC,0x27,0x4E,0x29);
101XTP_DEFINE_GUID(DIID_CalendarTimeZone,0xC0DE2430,0x4857,0x425e,0xA8,0x64,0x00,0x90,0x9C,0xD0,0xB7,0xBF);
102XTP_DEFINE_GUID(DIID_CalendarTimeZones,0xC0DE2430,0x7AAE,0x4cd8,0x97,0x8A,0x15,0xF8,0x61,0xE5,0x2D,0x14);
103XTP_DEFINE_GUID(DIID_CalendarEditOperationParameters,0xC0DE2430,0xCC9B,0x4DF0,0xB3,0x5C,0xD6,0x3A,0x2F,0x75,0xEC,0x32);
104XTP_DEFINE_GUID(DIID_CalendarSchedule,0xC0DE2430,0xA609,0x48c5,0xBF,0x08,0xC4,0xFC,0xE7,0xF4,0x2D,0xD2);
105XTP_DEFINE_GUID(DIID_CalendarSchedules,0xC0DE2430,0x6EDB,0x4518,0xA2,0x46,0x48,0xAC,0x5E,0x69,0xFB,0x7E);
106XTP_DEFINE_GUID(DIID_CalendarScheduleIDs,0xC0DE2430,0x1151,0x42ef,0x87,0xEF,0xBF,0x37,0xE2,0xA1,0x94,0x83);
107XTP_DEFINE_GUID(DIID_ICalendarResource,0xC0DE2430,0x4E72,0x468c,0x96,0xA8,0xC0,0x5F,0x96,0xED,0x71,0x3A);
108XTP_DEFINE_GUID(CLSID_CalendarResource,0xC0DE2430,0x3FA6,0x4067,0x93,0xEA,0x6E,0xC6,0x7A,0x64,0x66,0xD3);
109XTP_DEFINE_GUID(CLSID_CalendarResources,0xC0DE2430,0xB13E,0x400B,0x93,0xA8,0xC3,0x46,0x1B,0x03,0xE5,0x20);
110XTP_DEFINE_GUID(DIID_CalendarResourceDescription,0xC0DE2430,0x0E47,0x4e84,0x8C,0x33,0xFE,0x96,0x4E,0xA1,0x58,0x6E);
111XTP_DEFINE_GUID(DIID_ICalendarResourcesManager,0xC0DE2430,0x8B53,0x48d1,0x9C,0x49,0xE0,0x83,0x59,0xC4,0x78,0xDC);
112XTP_DEFINE_GUID(CLSID_CalendarResourcesManager,0xC0DE2430,0x6091,0x4CE5,0xBB,0x25,0x19,0xF7,0xBA,0xB4,0xF9,0x60);
113XTP_DEFINE_GUID(DIID_CalendarViewSelection,0xC0DE2430,0xCFC8,0x4ea9,0x8E,0x6E,0xFF,0xC1,0x9A,0x43,0x7A,0x44);
114XTP_DEFINE_GUID(DIID_CalendarDayViewCellParams,0xC0DE2430,0x1E84,0x4107,0x9E,0xA1,0x70,0xBF,0xCC,0xE2,0xDC,0x2E);
115XTP_DEFINE_GUID(DIID_CalendarGetItemTextParams,0xC0DE2430,0xDA6C,0x4012,0x8C,0x88,0x01,0x60,0x40,0x35,0x54,0xC6);
116XTP_DEFINE_GUID(DIID_CalendarDayView,0xC0DE2430,0x3914,0x44B0,0xAE,0x00,0x72,0x10,0x61,0x1D,0xEA,0xE2);
117XTP_DEFINE_GUID(DIID_CalendarWeekView,0xC0DE2430,0x6BA7,0x4DC1,0xA3,0x9E,0x00,0x89,0x12,0x51,0xE4,0xC7);
118XTP_DEFINE_GUID(DIID_CalendarMonthView,0xC0DE2430,0x0650,0x449F,0x8A,0x20,0x0C,0x5F,0x41,0x0B,0xA7,0xC3);
119XTP_DEFINE_GUID(DIID_CalendarTimeLineView,0xC0DE2430,0x4CFE,0x4f7a,0x8E,0xBC,0x13,0x13,0x5C,0x0F,0xAF,0x4F);
120XTP_DEFINE_GUID(DIID_CalendarEventLabel,0xC0DE2430,0x2327,0x49f0,0x94,0x7A,0x2B,0x36,0xFA,0xEC,0x73,0x0A);
121XTP_DEFINE_GUID(DIID_CalendarEventLabels,0xC0DE2430,0x5C8D,0x47ee,0xBE,0x61,0xFC,0x09,0xC5,0x6C,0xDD,0x3A);
122XTP_DEFINE_GUID(DIID_CalendarIconIDs,0xC0DE2430,0x6DD5,0x4f39,0xA0,0x3B,0xFD,0x05,0xED,0x5A,0xE4,0x41);
123XTP_DEFINE_GUID(DIID_ICalendarEventCategory,0xC0DE2430,0xDC14,0x4a33,0x98,0x31,0x5E,0x81,0x59,0xFB,0xF3,0xFA);
124XTP_DEFINE_GUID(CLSID_CalendarEventCategory,0xC0DE2430,0x2F70,0x4F66,0xBA,0xD7,0x22,0x41,0x80,0x73,0xF3,0x5F);
125XTP_DEFINE_GUID(DIID_ICalendarEventCategories,0xC0DE2430,0xDDFB,0x4f5e,0x8F,0xD8,0xA3,0xA1,0xC2,0xC0,0xD1,0x3D);
126XTP_DEFINE_GUID(CLSID_CalendarEventCategories,0xC0DE2430,0xF8A9,0x4BA6,0x9A,0x90,0xA4,0xF7,0xAA,0x2E,0xD1,0x91);
127XTP_DEFINE_GUID(DIID_CalendarEventCategoryIDs,0xC0DE2430,0xE8F3,0x4ed6,0x99,0x5A,0x75,0x0D,0x7C,0x4C,0x1F,0xDE);
128XTP_DEFINE_GUID(DIID_CalendarRecurrencePatternOptions,0xC0DE2430,0x84D0,0x43AB,0xB1,0x4D,0xCA,0x1D,0x81,0x51,0x12,0x1F);
129XTP_DEFINE_GUID(DIID_CalendarRecurrencePattern,0xC0DE2430,0x4840,0x41B5,0x94,0xA1,0x7B,0x52,0xC6,0x5B,0x19,0x07);
130XTP_DEFINE_GUID(DIID_CalendarOptions,0xC0DE2430,0xD641,0x4FF5,0xAE,0xC9,0x50,0x73,0xCA,0xBE,0x48,0x08);
131XTP_DEFINE_GUID(DIID_CalendarReminder,0xC0DE2430,0x3036,0x4c8c,0x9F,0x49,0xE1,0xBC,0xA9,0xE5,0xDB,0x14);
132XTP_DEFINE_GUID(DIID_CalendarReminders,0xC0DE2430,0xBACB,0x441a,0x9D,0x37,0xE1,0xB0,0x89,0xFB,0x04,0x0C);
133XTP_DEFINE_GUID(DIID_CalendarPrintOptions,0xC0DE2430,0x26C8,0x40cc,0x8B,0x85,0x45,0x39,0x09,0x8E,0x18,0xA1);
134XTP_DEFINE_GUID(DIID_CalendarUserAction,0xC0DE2430,0x6103,0x4759,0x95,0x5D,0x8E,0x83,0x75,0x50,0xA5,0xE1);
135XTP_DEFINE_GUID(DIID_ICalendarDialogs,0xC0DE2430,0x6F7A,0x459A,0x8C,0xFF,0xC0,0x95,0x6A,0xBA,0xA4,0xA8);
136XTP_DEFINE_GUID(CLSID_CalendarDialogs,0xC0DE2430,0x30E7,0x4833,0x91,0xF5,0x6F,0xC9,0xA5,0x42,0x81,0xD4);
137XTP_DEFINE_GUID(DIID__DCalendarControlEvents,0xC0DE2430,0xC1C3,0x4645,0xB6,0x40,0x65,0x12,0x1C,0xD9,0xDA,0x4C);
138XTP_DEFINE_GUID(CLSID_CalendarControl,0xC0DE2430,0x0EF8,0x4AB4,0xAF,0x68,0x4E,0x7C,0x7D,0x4E,0x53,0xF9);
139XTP_DEFINE_GUID(DIID_DatePickerSelectionBlock,0xC0DE2430,0xEF34,0x4631,0xB8,0xA5,0x7A,0xDC,0x20,0x0A,0x34,0xD8);
140XTP_DEFINE_GUID(DIID_DatePickerSelection,0xC0DE2430,0x32B8,0x485A,0x9D,0x2E,0x9B,0x7C,0x10,0xBE,0x94,0x73);
141XTP_DEFINE_GUID(DIID_IDatePickerDayMetrics,0xC0DE2430,0x40BE,0x4ce2,0xBE,0x64,0xAA,0x74,0x3B,0xBE,0x44,0xBD);
142XTP_DEFINE_GUID(CLSID_DatePickerDayMetrics,0xC0DE2430,0x7084,0x45f3,0xA4,0x35,0xE9,0xED,0xD7,0x57,0x7B,0x9B);
143XTP_DEFINE_GUID(DIID_DatePickerPaintManager,0xC0DE2430,0x3FC8,0x4cbb,0xB8,0xD6,0xA8,0x4B,0xDE,0x8A,0xB5,0x67);
144XTP_DEFINE_GUID(DIID__DDatePicker,0xC0DE2430,0x23F2,0x4a5c,0xAC,0xB7,0xFF,0x70,0x58,0xB5,0x2F,0x63);
145XTP_DEFINE_GUID(DIID__DDatePickerEvents,0xC0DE2430,0x896D,0x4B48,0xAB,0x33,0x0D,0xDE,0x41,0x81,0x5A,0x1B);
146XTP_DEFINE_GUID(CLSID_DatePicker,0xC0DE2430,0x5809,0x4D82,0x92,0x89,0x9A,0x31,0xFB,0xF7,0x11,0x34);
147XTP_DEFINE_GUID(DIID_ICalendarGlobalSettings,0xC0DE2430,0x282E,0x40C7,0xBC,0x25,0x85,0x08,0xA7,0x1C,0xD4,0x79);
148XTP_DEFINE_GUID(CLSID_CalendarGlobalSettings,0xC0DE2430,0xBECB,0x4A1B,0x88,0xC0,0x2B,0xCF,0x8C,0x0A,0x98,0x90);
149
150#undef XTP_DEFINE_GUID
151
152// clang-format on
153
154#endif // __XTPCalendarIIDs_H__


Toolkit Pro: XTPCalendarMAPIDataProvider.h File Reference

  • Source
  • Calendar
XTPCalendarMAPIDataProvider.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPCalendarMAPIWrapper.h File Reference

  • Source
  • Calendar
XTPCalendarMAPIWrapper.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPCalendarMemoryDataProvider.h File Reference

  • Source
  • Calendar
Classes | Macros
XTPCalendarMemoryDataProvider.h File Reference

Go to the source code of this file.

Classes

class CXTPCalendarMemoryDataProvider
This class implements an abstract representation of the data used in the XTPCalendarData class. More...

Macros

#define XTP_EVENTS_STORAGE_HASH_TABLE_SIZE 4001
Define events storage hash table size.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Macro Definition Documentation

◆ XTP_EVENTS_STORAGE_HASH_TABLE_SIZE

#define XTP_EVENTS_STORAGE_HASH_TABLE_SIZE 4001

Define events storage hash table size.

Should be a prime number! like: 503, 1021, 1511, 2003, 3001, 4001, 5003, 6007, 8009, 12007, 16001, 32003, 48017, 64007

See also
CXTPCalendarData::EventsMapByID_T overview
CMap overview


Toolkit Pro: XTPCalendarMonthView.h File Reference

  • Source
  • Calendar
Classes | Macros
XTPCalendarMonthView.h File Reference

Go to the source code of this file.

Classes

class | CXTPCalendarMonthView
This class implements a specific view portion of the Calendar control - called Month view. More...
class | CXTPCalendarMonthView::CMonthViewGrid

Macros

#define | XTP_CALENDAR_MONTHVIEW_SHOW_WEEKS_MIN 1
Define minimum count of weeks which can be shown in the Month View.
#define | XTP_CALENDAR_MONTHVIEW_SHOW_WEEKS_MAX 64
Define maximum count of weeks which can be shown in the Month View.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Macro Definition Documentation

◆ XTP_CALENDAR_MONTHVIEW_SHOW_WEEKS_MAX

#define XTP_CALENDAR_MONTHVIEW_SHOW_WEEKS_MAX 64

Define maximum count of weeks which can be shown in the Month View.

See also
CXTPCalendarMonthView::CMonthViewGrid::GetWeeksCount
CXTPCalendarMonthView::CMonthViewGrid::SetWeeksCount
XTP_CALENDAR_MONTHVIEW_SHOW_WEEKS_MIN

◆ XTP_CALENDAR_MONTHVIEW_SHOW_WEEKS_MIN

#define XTP_CALENDAR_MONTHVIEW_SHOW_WEEKS_MIN 1

Define minimum count of weeks which can be shown in the Month View.

See also
CXTPCalendarMonthView::CMonthViewGrid::GetWeeksCount
CXTPCalendarMonthView::CMonthViewGrid::SetWeeksCount
XTP_CALENDAR_MONTHVIEW_SHOW_WEEKS_MAX


Toolkit Pro: XTPCalendarMonthViewDay.h File Reference

  • Source
  • Calendar
Classes
XTPCalendarMonthViewDay.h File Reference

Go to the source code of this file.

Classes

class | CXTPCalendarMonthViewGroup
This class represents a single resource view portion of the Calendar Month View. More...
class | CXTPCalendarMonthViewDay
This class represents a day view portion of the CalendarMonthView. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPCalendarMonthViewEvent.h File Reference

  • Source
  • Calendar
Classes
XTPCalendarMonthViewEvent.h File Reference

Go to the source code of this file.

Classes

class CXTPCalendarMonthViewEvent
This class represents an event view portion of the CalendarMonthViewDay. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPCalendarMsgNotifier.h File Reference

  • Source
  • Calendar
Classes | Functions | Variables
XTPCalendarMsgNotifier.h File Reference

Go to the source code of this file.

Classes

class CXTPCalendarMsgNotifier
This class is used to catch windows messages, which the system sends to top-level windows, and to send them to subscribers windows. More...

Functions

_XTP_EXT_CLASS CXTPCalendarMsgNotifier *AFX_CDECL XTPCalendarMsgNotifier ()
This global function is used to get a library static common top-level window object to catch windows messages, which the system sends to top-level windows (like WM_TIMECHANGE, WM_SYSCOLORCHANGE).

Variables

UINT XTP_WM_TIME_ZONE_CHANGED
Define windows message sent by CXTPCalendarMsgNotifier when the current timezone is changed.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Function Documentation

◆ XTPCalendarMsgNotifier()

_XTP_EXT_CLASS CXTPCalendarMsgNotifier *AFX_CDECL XTPCalendarMsgNotifier ( )

This global function is used to get a library static common top-level window object to catch windows messages, which the system sends to top-level windows (like WM_TIMECHANGE, WM_SYSCOLORCHANGE).

Using CXTPCalendarMsgNotifier you can advise your non-top-level (child) windows to receive these messages.

Returns
A pointer to CXTPCalendarMsgNotifier object.


Toolkit Pro: XTPCalendarNotifications.h File Reference

  • Source
  • Calendar
Classes | Enumerations | Variables
XTPCalendarNotifications.h File Reference

Go to the source code of this file.

Classes

struct | XTP_EVENT_EDIT_OPERATION_PARAMS
This structure is used as a generic and base class for custom edit event notifications. More...
struct | XTP_EVENT_PASTE_OPERATION_PARAMS
This structure is used with notifications for custom edit event notifications when eOperation is xtpCalendarEO_Paste. More...
struct | XTP_EVENT_IN_PLACE_CREATE_EVENT_OPERATION_PARAMS
This structure is used with notifications for custom edit event notifications when eOperation is xtpCalendarEO_InPlaceCreateEvent. More...
struct | XTP_EVENT_DRAG_OPERATION_PARAMS
This structure is used with notifications for custom edit event notifications when eOperation is xtpCalendarEO_DragXXX. More...
struct | XTP_CALENDAR_WPARAM2
Doubled custom parameter for notifications. More...
struct | XTP_CALENDAR_DAYVIEWCELL_PARAMS
Set of parameters transferred from calendar items for an XTP_NC_CALENDAR_BEFORE_DRAW_DAYVIEWCELL notification. More...
struct | XTP_CALENDAR_THEME_DAYVIEWCELL_PARAMS
Set of parameters transferred from calendar items for an XTP_NC_CALENDAR_BEFORE_DRAW_THEMEOBJECT notification. More...
struct | XTP_CALENDAR_THEME_DAYVIEWTIMESCALECELL_PARAMS
Set of parameters transferred from calendar items for an XTP_NC_CALENDAR_BEFORE_DRAW_THEMEOBJECT notification. More...
struct | XTP_CALENDAR_GETITEMTEXT_PARAMS
Set of parameters transferred from calendar items for an XTP_NC_CALENDAR_GETITEMTEXT notification. More...
struct | XTP_CALENDAR_USERACTION_PARAMS
Set of parameters transferred from calendar items for an XTP_NC_CALENDAR_USERACTION notification. More...
struct | XTP_CALENDAR_USERACTION_PARAMS::EXPANDDAYBUTTONACTION_PARAMS
Defines parameters for xtpCalendarUserAction_OnExpandDay user action. More...
struct | XTP_CALENDAR_USERACTION_PARAMS::SCROLLDAYBUTTONACTION_PARAMS
Defines parameters for xtpCalendarUserAction_OnScrollDay user action. More...

Enumerations

enum XTPCalendarRemindersAction {
xtpCalendarRemindersMonitoringStarted = 1 , xtpCalendarRemindersMonitoringStopped = 2 , xtpCalendarRemindersFire = 3 , xtpCalendarReminderSnoozed = 4 ,
xtpCalendarReminderDismissed = 5 , xtpCalendarReminderDismissedAll = 6
}
Enumeration of possible Calendar Reminder notification actions. More...
enum XTPCalendarBeforeDrawThemeObject {
xtpCalendarBeforeDraw_DayViewTimeScale = 0x00000001 , xtpCalendarBeforeDraw_DayViewTimeScaleCaption = 0x00000002 , xtpCalendarBeforeDraw_DayViewTimeScaleCell , xtpCalendarBeforeDraw_DayViewDay = 0x00000010 ,
xtpCalendarBeforeDraw_DayViewDayGroup = 0x00000020 , xtpCalendarBeforeDraw_DayViewCell = 0x00000040 , xtpCalendarBeforeDraw_DayViewEvent = 0x00000080 , xtpCalendarBeforeDraw_AllDayViewEvent = 0x00000100 ,
xtpCalendarBeforeDraw_MonthViewDay = 0x00001000 , xtpCalendarBeforeDraw_MonthViewEvent = 0x00002000 , xtpCalendarBeforeDraw_MonthViewWeekDayHeader , xtpCalendarBeforeDraw_MonthViewWeekHeader = 0x00008000 ,
xtpCalendarBeforeDraw_WeekViewDay = 0x00100000 , xtpCalendarBeforeDraw_WeekViewEvent = 0x00200000
}
This enum defines a set of calendar theme items for which a XTP_NC_CALENDAR_BEFORE_DRAW_THEMEOBJECT notification is sent. More...
enum XTPCalendarUserAction { xtpCalendarUserAction_OnExpandDay = 0x80000000 , xtpCalendarUserAction_OnScrollDay = 0x40000000 , xtpCalendarUserAction_OnScrollAllDayEvensUp = 0x30000000 , xtpCalendarUserAction_OnScrollAllDayEvensDown = 0x20000000 }
This enum defines a set of user actions which can be customized. More...

Variables

static const XTP_NOTIFY_CODE | XTP_NC_CALENDAREVENTWASADDED = (WM_XTP_CALENDAR_BASE + 1)
New event has just been added to the data provider.
static const XTP_NOTIFY_CODE | XTP_NC_CALENDAREVENTWASDELETED = (WM_XTP_CALENDAR_BASE + 2)
Event has just been deleted from the data provider.
static const XTP_NOTIFY_CODE | XTP_NC_CALENDAREVENTWASCHANGED = (WM_XTP_CALENDAR_BASE + 3)
Event has just been changed in the data provider.
static const XTP_NOTIFY_CODE | XTP_NC_CALENDARPATTERNWASADDED = (WM_XTP_CALENDAR_BASE + 4)
New recurrence pattern has just been added to the data provider.
static const XTP_NOTIFY_CODE | XTP_NC_CALENDARPATTERNWASDELETED = (WM_XTP_CALENDAR_BASE + 5)
Recurrence pattern has just been deleted from the data provider.
static const XTP_NOTIFY_CODE | XTP_NC_CALENDARPATTERNWASCHANGED = (WM_XTP_CALENDAR_BASE + 6)
Recurrence pattern has just been changed in the data provider.
static const XTP_NOTIFY_CODE | XTP_NC_CALENDARVIEWWASCHANGED = (WM_XTP_CALENDAR_BASE + 7)
Current Calendar Control view type(day, week, ...) or content was changed.
static const XTP_NOTIFY_CODE | XTP_NC_CALENDARCONTEXTMENU = (WM_XTP_CALENDAR_BASE + 8)
A Context Menu should be displayed for the Calendar Control.
static const XTP_NOTIFY_CODE | XTP_NC_CALENDARLBUTTONDOWN = (WM_XTP_CALENDAR_BASE + 9)
On LButtonDown event.
static const XTP_NOTIFY_CODE | XTP_NC_CALENDARLBUTTONDBLCLICK = (WM_XTP_CALENDAR_BASE + 10)
On LButtonDblClick event.
static const XTP_NOTIFY_CODE | XTP_NC_CALENDARLBUTTONUP = (WM_XTP_CALENDAR_BASE + 11)
On LButtonUp event.
static const XTP_NOTIFY_CODE | XTP_NC_CALENDARMOUSEMOVE = (WM_XTP_CALENDAR_BASE + 12)
On MouseMove event.
static const XTP_NOTIFY_CODE | XTP_NC_CALENDARKEYDOWN = (WM_XTP_CALENDAR_BASE + 13)
On KeyDown event.
static const XTP_NOTIFY_CODE | XTP_NC_CALENDARRBUTTONDOWN = (WM_XTP_CALENDAR_BASE + 14)
On RButtonDown event.
static const XTP_NOTIFY_CODE | XTP_NC_CALENDARVIEWTIMESCALEWASCHANGED = (WM_XTP_CALENDAR_BASE + 15)
Calendar Control Day view time scale was changed.
static const XTP_NOTIFY_CODE | XTP_NC_CALENDAROPTIONSWASCHANGED = (WM_XTP_CALENDAR_BASE + 16)
Calendar Control options was changed.
static const XTP_NOTIFY_CODE | XTP_NC_CALENDARDATAPROVIDERWASCHANGED = (WM_XTP_CALENDAR_BASE + 17)
Calendar Control data provider (resources) was changed.
static const XTP_NOTIFY_CODE | XTP_NC_CALENDAR_RESOURCES_WHERE_CHANGED
alias of XTP_NC_CALENDARDATAPROVIDERWASCHANGED notification code
static const XTP_NOTIFY_CODE | XTP_NC_CALENDAR_IS_EVENT_EDIT_OPERATION_DISABLED
This notification is sent to determine if the specified editing operation is disabled.
static const XTP_NOTIFY_CODE | XTP_NC_CALENDAR_BEFORE_EVENT_EDIT_OPERATION
This notification is sent to customize or disable a specified editing operation.
static const XTP_NOTIFY_CODE | XTP_NC_CALENDAR_SELECTION_CHANGED = (WM_XTP_CALENDAR_BASE + 20)
This notification is sent when the selection is changed.
static const XTP_NOTIFY_CODE | XTP_NC_CALENDARRBUTTONUP = (WM_XTP_CALENDAR_BASE + 21)
On RButtonUp event.
static const XTP_NOTIFY_CODE | XTP_NC_CALENDAR_ON_REMINDERS = (WM_XTP_CALENDAR_BASE + 22)
On RButtonUp event.
static const XTP_NOTIFY_CODE | XTP_NC_CALENDAR_DoRetrieveDayEvents = (WM_XTP_CALENDAR_BASE + 23)
This notification is used as an analog of the overridable method CXTPCalendarData::DoRetrieveDayEvents.
static const XTP_NOTIFY_CODE | XTP_NC_CALENDAR_DoRemoveAllEvents = (WM_XTP_CALENDAR_BASE + 24)
This notification is used as an analog of the overridable method CXTPCalendarData::DoRemoveAllEvents.
static const XTP_NOTIFY_CODE | XTP_NC_CALENDAR_DoRead_Event = (WM_XTP_CALENDAR_BASE + 25)
This notification is used as an analog of the overridable method CXTPCalendarData::DoRead_Event.
static const XTP_NOTIFY_CODE | XTP_NC_CALENDAR_DoRead_RPattern = (WM_XTP_CALENDAR_BASE + 26)
This notification is used as an analog of the overridable method CXTPCalendarData::DoRead_RPattern.
static const XTP_NOTIFY_CODE | XTP_NC_CALENDAR_DoCreate_Event = (WM_XTP_CALENDAR_BASE + 27)
This notification is used as an analog of the overridable method CXTPCalendarData::DoCreate_Event.
static const XTP_NOTIFY_CODE | XTP_NC_CALENDAR_DoUpdate_Event = (WM_XTP_CALENDAR_BASE + 28)
This notification is used as an analog of the overridable method CXTPCalendarData::DoUpdate_Event.
static const XTP_NOTIFY_CODE | XTP_NC_CALENDAR_DoDelete_Event = (WM_XTP_CALENDAR_BASE + 29)
This notification is used as an analog of the overridable method CXTPCalendarData::DoDelete_Event.
static const XTP_NOTIFY_CODE | XTP_NC_CALENDAR_DoCreate_RPattern = (WM_XTP_CALENDAR_BASE + 30)
This notification is used as an analog of the overridable method CXTPCalendarData::DoCreate_RPattern.
static const XTP_NOTIFY_CODE | XTP_NC_CALENDAR_DoUpdate_RPattern = (WM_XTP_CALENDAR_BASE + 31)
This notification is used as an analog of the overridable method CXTPCalendarData::DoUpdate_RPattern.
static const XTP_NOTIFY_CODE | XTP_NC_CALENDAR_DoDelete_RPattern = (WM_XTP_CALENDAR_BASE + 32)
This notification is used as an analog of the overridable method CXTPCalendarData::DoDelete_RPattern.
static const XTP_NOTIFY_CODE | XTP_NC_CALENDAR_DoGetAllEvents_raw = (WM_XTP_CALENDAR_BASE + 33)
This notification is used as an analog of the overridable method CXTPCalendarData::DoGetAllEvents_raw.
static const XTP_NOTIFY_CODE | XTP_NC_CALENDAR_DoGetUpcomingEvents = (WM_XTP_CALENDAR_BASE + 34)
This notification is used as an analog of the overridable method CXTPCalendarData::DoGetUpcomingEvents.
static const XTP_NOTIFY_CODE | XTP_NC_CALENDAR_GETGROPVIEWCAPTION = (WM_XTP_CALENDAR_BASE + 35)
This notification is sent when the selection is changed.
static const XTP_NOTIFY_CODE | XTP_NC_CALENDAR_PREPOPULATE = (WM_XTP_CALENDAR_BASE + 36)
This notification is sent when calendar is populating.
static const XTP_NOTIFY_CODE | XTP_NC_CALENDAR_BEFORE_DRAW_DAYVIEWCELL = (WM_XTP_CALENDAR_BASE + 37)
This notification is sent for each calendar day view cell before draw.
static const XTP_NOTIFY_CODE | XTP_NC_CALENDAR_BEFORE_DRAW_THEMEOBJECT = (WM_XTP_CALENDAR_BASE + 38)
This notification is sent for calendar theme items before draw.
static const XTP_NOTIFY_CODE | XTP_NC_CALENDAR_GETITEMTEXT = (WM_XTP_CALENDAR_BASE + 39)
This notification is sent for calendar items which define an AskItemTextFlags property.
static const XTP_NOTIFY_CODE | XTP_NC_CALENDAR_USERACTION = (WM_XTP_CALENDAR_BASE + 40)
This notification is sent when a user action defined in XTPCalendarUserAction enum happens.
static const XTP_NOTIFY_CODE | XTP_NC_CALENDAR_PREPOPULATE_DAY = (WM_XTP_CALENDAR_BASE + 41)
This notification is sent when the calendar is populating.
static const XTP_NOTIFY_CODE | XTP_NC_CALENDAR_THEME_CHANGED = (WM_XTP_CALENDAR_BASE + 42)
This notification is sent when the calendar paint theme changes.
static const XTP_NOTIFY_CODE | XTP_NC_CALENDAR_CAPTIONBARPART_CLICK = (WM_XTP_CALENDAR_BASE + 43)
This notification is sent on a CaptionBar part click.
static const XTP_NOTIFY_CODE | XTP_NC_CALENDAR_CAPTIONBARPART_BEFORE_CLICK
This notification is sent before a CaptionBar part click.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Enumeration Type Documentation

◆ XTPCalendarBeforeDrawThemeObject

enum XTPCalendarBeforeDrawThemeObject

This enum defines a set of calendar theme items for which a XTP_NC_CALENDAR_BEFORE_DRAW_THEMEOBJECT notification is sent.

See also
XTP_NC_CALENDAR_BEFORE_DRAW_THEMEOBJECT
Enumerator
xtpCalendarBeforeDraw_DayViewTimeScale

dwParam2 - [in] nTimeScale = {1 - main, 2 - additional}

xtpCalendarBeforeDraw_DayViewTimeScaleCaption

dwParam2 - [in] nTimeScale = {1

  • main, 2 - additional};
xtpCalendarBeforeDraw_DayViewTimeScaleCell

dwParam2 - [in] XTP_CALENDAR_THEME_DAYVIEWTIMESCALECELL_PARAMS

xtpCalendarBeforeDraw_DayViewDay

dwParam2 - [in] CXTPCalendarDayViewDay

xtpCalendarBeforeDraw_DayViewDayGroup

dwParam2 - [in] CXTPCalendarDayViewGroup

xtpCalendarBeforeDraw_DayViewCell

dwParam2 - [in] XTP_CALENDAR_THEME_DAYVIEWCELL_PARAMS

xtpCalendarBeforeDraw_DayViewEvent

dwParam2 - [in] CXTPCalendarDayViewEvent

xtpCalendarBeforeDraw_AllDayViewEvent

dwParam2 - [in] CXTPCalendarDayViewEvent

xtpCalendarBeforeDraw_MonthViewDay

dwParam2 - [in] CXTPCalendarMonthViewDay

xtpCalendarBeforeDraw_MonthViewEvent

dwParam2 - [in] CXTPCalendarMonthViewEvent

xtpCalendarBeforeDraw_MonthViewWeekDayHeader

dwParam2 - [in] WeekDay = {1-Sun, 2-Mon, ...}, -1 for common part;

xtpCalendarBeforeDraw_MonthViewWeekHeader

dwParam2 - [in] WeekIndex={0...N}, -1 for common part;

xtpCalendarBeforeDraw_WeekViewDay

dwParam2 - [in] CXTPCalendarWeekViewDay

xtpCalendarBeforeDraw_WeekViewEvent

dwParam2 - [in] CXTPCalendarWeekViewEvent

◆ XTPCalendarRemindersAction

enum XTPCalendarRemindersAction

Enumeration of possible Calendar Reminder notification actions.

Members of this enumerations are used as an additional parameters of the XTP_NC_CALENDAR_ON_REMINDERS notification

See also
XTP_NC_CALENDAR_ON_REMINDERS notification
Enumerator
xtpCalendarRemindersMonitoringStarted | Sends after monitoring has started (end of executing CXTPCalendarRemindersManager::StartMonitoring)
xtpCalendarRemindersMonitoringStopped | Sends when monitoring has stopped (CXTPCalendarRemindersManager::StopMonitoring)
xtpCalendarRemindersFire | Main notification, when reminder is executed.
xtpCalendarReminderSnoozed | When 1 pending reminder was snoozed. lParam = CXTPCalendarReminder
xtpCalendarReminderDismissed | When 1 pending reminder was dismissed. lParam = CXTPCalendarReminder
xtpCalendarReminderDismissedAll | When all pending reminders were dismissed.

◆ XTPCalendarUserAction

enum XTPCalendarUserAction

This enum defines a set of user actions which can be customized.

See also
XTP_NC_CALENDAR_USERACTION
XTP_CALENDAR_USERACTION_PARAMS
Enumerator
xtpCalendarUserAction_OnExpandDay | Expand Day button was clicked for month or week view.
xtpCalendarUserAction_OnScrollDay | Scroll Day button was clicked for day view.
xtpCalendarUserAction_OnScrollAllDayEvensUp | Scroll All Day button up action.
xtpCalendarUserAction_OnScrollAllDayEvensDown | Scroll All Day button down action.

Variable Documentation

◆ XTP_NC_CALENDAR_BEFORE_DRAW_DAYVIEWCELL

const XTP_NOTIFY_CODE XTP_NC_CALENDAR_BEFORE_DRAW_DAYVIEWCELL = (WM_XTP_CALENDAR_BASE + 37)
static

This notification is sent for each calendar day view cell before draw.

You may customize a clrBackgroundColor member of the provided XTP_CALENDAR_DAYVIEWCELL_PARAMS structure. Sender - CXTPCalendarControl

Parameters wParam - [in] CXTPCalendarViewGroup* A pointer to Group View. lParam - [in/out] XTP_CALENDAR_DAYVIEWCELL_PARAMS* A pointer to cell parameters.

◆ XTP_NC_CALENDAR_BEFORE_DRAW_THEMEOBJECT

const XTP_NOTIFY_CODE XTP_NC_CALENDAR_BEFORE_DRAW_THEMEOBJECT = (WM_XTP_CALENDAR_BASE + 38)
static

This notification is sent for calendar theme items before draw.

You may customize the corresponding theme part for each object in this message. Any object part changes made in this notification handler will be discarded once the object draw has finished. This lets you dynamically customize each calendar item.

Sender - CXTPCalendarControl

This notification send only for theme objects defined in BeforeDrawFlags. See Also: CXTPCalendarTheme::GetBeforeDrawFlags, CXTPCalendarTheme::SetBeforeDrawFlags Parameters wParam - [in] An object ID from XTPCalendarBeforeDrawThemeObject enum. lParam - [in] An additional parameter defined for each item in XTPCalendarBeforeDrawThemeObject.

◆ XTP_NC_CALENDAR_BEFORE_EVENT_EDIT_OPERATION

const XTP_NOTIFY_CODE XTP_NC_CALENDAR_BEFORE_EVENT_EDIT_OPERATION
static
Initial value:
= (WM_XTP_CALENDAR_BASE
+ 19)
WM_XTP_CALENDAR_BASE
const UINT WM_XTP_CALENDAR_BASE
The WM_XTP_CALENDAR_BASE constant is used by Calendar Control to help define private messages for use...
Definition XTPCalendarDefines.h:1069

This notification is sent to customize or disable a specified editing operation.

Sender - CXTPCalendarControl

This notification is sent only once before an edit operation. The XTP_NC_CALENDAR_BEFORE_EVENT_EDIT_OPERATION notification is sent every time before this notification.

Parameters wParam - [in] A pointer to XTP_EVENT_EDIT_OPERATION_PARAMS structure or to derived structure depends on eOperation member value. lParam - [out] A pointer to the return result: BOOL*. Set TRUE if specified editing operation is handled, otherwise FALSE. Initial value is FALSE.

See also
XTP_NC_CALENDAR_IS_EVENT_EDIT_OPERATION_DISABLED
XTPCalendarEditOperation,
XTP_EVENT_EDIT_OPERATION_PARAMS
XTP_EVENT_PASTE_OPERATION_PARAMS,
XTP_EVENT_IN_PLACE_CREATE_EVENT_OPERATION_PARAMS

◆ XTP_NC_CALENDAR_DoCreate_Event

const XTP_NOTIFY_CODE XTP_NC_CALENDAR_DoCreate_Event = (WM_XTP_CALENDAR_BASE + 27)
static

This notification is used as an analog of the overridable method CXTPCalendarData::DoCreate_Event.

Sender - CXTPCalendarCustomDataProvider, CXTPCalendarControl.

Send by a custom data provider. Calendar control reflects this notification as well as other notifications. Parameters wParam - [in] A pointer as XTP_CALENDAR_WPARAM2* where : wParam1 - [in] A pointer to calendar event object as CXTPCalendarEvent*; wParam2 - [out] A pointer to newly created event ID as DWORD*; lParam - [out] A pointer to result of operation as BOOL*;

See also
CXTPCalendarCustomDataProvider::DoCreate_Event

◆ XTP_NC_CALENDAR_DoCreate_RPattern

const XTP_NOTIFY_CODE XTP_NC_CALENDAR_DoCreate_RPattern = (WM_XTP_CALENDAR_BASE + 30)
static

This notification is used as an analog of the overridable method CXTPCalendarData::DoCreate_RPattern.

Sender - CXTPCalendarCustomDataProvider, CXTPCalendarControl.

Send by a custom data provider. Calendar control reflects this notification as well as other notifications. Parameters wParam - [in] A pointer as XTP_CALENDAR_WPARAM2* where : wParam1 - [in] A pointer to recurrence pattern object as CXTPCalendarRecurrencePattern*; wParam2 - [out] A pointer to newly created recurrence pattern ID as DWORD*; lParam - [out] A pointer to result of operation as BOOL*;

See also
CXTPCalendarCustomDataProvider::DoCreate_RPattern

◆ XTP_NC_CALENDAR_DoDelete_Event

const XTP_NOTIFY_CODE XTP_NC_CALENDAR_DoDelete_Event = (WM_XTP_CALENDAR_BASE + 29)
static

This notification is used as an analog of the overridable method CXTPCalendarData::DoDelete_Event.

Sender - CXTPCalendarCustomDataProvider, CXTPCalendarControl.

Send by a custom data provider. Calendar control reflects this notification as well as other notifications. Parameters wParam - [in] A pointer to calendar event object as CXTPCalendarEvent*; lParam - [out] A pointer to result of operation as BOOL*;

See also
CXTPCalendarCustomDataProvider::DoDelete_Event

◆ XTP_NC_CALENDAR_DoDelete_RPattern

const XTP_NOTIFY_CODE XTP_NC_CALENDAR_DoDelete_RPattern = (WM_XTP_CALENDAR_BASE + 32)
static

This notification is used as an analog of the overridable method CXTPCalendarData::DoDelete_RPattern.

Sender - CXTPCalendarCustomDataProvider, CXTPCalendarControl.

Send by a custom data provider. Calendar control reflects this notification as well as other notifications. Parameters wParam - [in] A pointer to recurrence pattern object as CXTPCalendarRecurrencePattern*; lParam - [out] A pointer to result of operation as BOOL*;

See also
CXTPCalendarCustomDataProvider::DoDelete_RPattern

◆ XTP_NC_CALENDAR_DoGetAllEvents_raw

const XTP_NOTIFY_CODE XTP_NC_CALENDAR_DoGetAllEvents_raw = (WM_XTP_CALENDAR_BASE + 33)
static

This notification is used as an analog of the overridable method CXTPCalendarData::DoGetAllEvents_raw.

Sender - CXTPCalendarCustomDataProvider, CXTPCalendarControl.

Send by a custom data provider. Calendar control reflects this notification as well as other notifications. Parameters wParam - Unused (=0); lParam - [in/out] A pointer to pointer to events array as CXTPCalendarEventsPtr*;

See also
CXTPCalendarCustomDataProvider::DoGetAllEvents_raw

◆ XTP_NC_CALENDAR_DoGetUpcomingEvents

const XTP_NOTIFY_CODE XTP_NC_CALENDAR_DoGetUpcomingEvents = (WM_XTP_CALENDAR_BASE + 34)
static

This notification is used as an analog of the overridable method CXTPCalendarData::DoGetUpcomingEvents.

Sender - CXTPCalendarCustomDataProvider, CXTPCalendarControl.

Send by a custom data provider. Calendar control reflects this notification as well as other notifications. Parameters wParam - [in] A pointer as XTP_CALENDAR_WPARAM2* where : wParam1 - [in] As COleDateTime*; Start date and time of a specified period; wParam2 - [in] As COleDateTimeSpan*; A duration of a specified period; lParam - [in/out] A pointer to pointer to events array as CXTPCalendarEventsPtr*;

See also
CXTPCalendarCustomDataProvider::DoGetUpcomingEvents

◆ XTP_NC_CALENDAR_DoRead_Event

const XTP_NOTIFY_CODE XTP_NC_CALENDAR_DoRead_Event = (WM_XTP_CALENDAR_BASE + 25)
static

This notification is used as an analog of the overridable method CXTPCalendarData::DoRead_Event.

Sender - CXTPCalendarCustomDataProvider, CXTPCalendarControl.

Send by a custom data provider. Calendar control reflects this notification as well as other notifications. Parameters wParam - [in] An event ID to read as DWORD; lParam - [in/out] A pointer to pointer to event as CXTPCalendarEventPtr*;

See also
CXTPCalendarCustomDataProvider::DoRead_Event

◆ XTP_NC_CALENDAR_DoRead_RPattern

const XTP_NOTIFY_CODE XTP_NC_CALENDAR_DoRead_RPattern = (WM_XTP_CALENDAR_BASE + 26)
static

This notification is used as an analog of the overridable method CXTPCalendarData::DoRead_RPattern.

Sender - CXTPCalendarCustomDataProvider, CXTPCalendarControl.

Send by a custom data provider. Calendar control reflects this notification as well as other notifications. Parameters wParam - [in] An recurrence pattern ID to read as DWORD; lParam - [in/out] A pointer to pointer to recurrence pattern as CXTPCalendarRecurrencePatternPtr*;

See also
CXTPCalendarCustomDataProvider::DoRead_RPattern

◆ XTP_NC_CALENDAR_DoRemoveAllEvents

const XTP_NOTIFY_CODE XTP_NC_CALENDAR_DoRemoveAllEvents = (WM_XTP_CALENDAR_BASE + 24)
static

This notification is used as an analog of the overridable method CXTPCalendarData::DoRemoveAllEvents.

Sender - CXTPCalendarCustomDataProvider, CXTPCalendarControl.

Send by a custom data provider. Calendar control reflects this notification as well as other notifications.

See also
CXTPCalendarCustomDataProvider::DoRemoveAllEvents

◆ XTP_NC_CALENDAR_DoRetrieveDayEvents

const XTP_NOTIFY_CODE XTP_NC_CALENDAR_DoRetrieveDayEvents = (WM_XTP_CALENDAR_BASE + 23)
static

This notification is used as an analog of the overridable method CXTPCalendarData::DoRetrieveDayEvents.

Sender - CXTPCalendarCustomDataProvider, CXTPCalendarControl.

Send by a custom data provider. Calendar control reflects this notification as well as other notifications.

Parameters wParam - [in] A day date as XTP_DATE_VALUE; lParam - [in/out] A pointer to pointer to events array as CXTPCalendarEventsPtr*;

See also
CXTPCalendarCustomDataProvider::DoRetrieveDayEvents

◆ XTP_NC_CALENDAR_DoUpdate_Event

const XTP_NOTIFY_CODE XTP_NC_CALENDAR_DoUpdate_Event = (WM_XTP_CALENDAR_BASE + 28)
static

This notification is used as an analog of the overridable method CXTPCalendarData::DoUpdate_Event.

Sender - CXTPCalendarCustomDataProvider, CXTPCalendarControl.

Send by a custom data provider. Calendar control reflects this notification as well as other notifications. Parameters wParam - [in] A pointer to calendar event object as CXTPCalendarEvent*; lParam - [out] A pointer to result of operation as BOOL*;

See also
CXTPCalendarCustomDataProvider::DoUpdate_Event

◆ XTP_NC_CALENDAR_DoUpdate_RPattern

const XTP_NOTIFY_CODE XTP_NC_CALENDAR_DoUpdate_RPattern = (WM_XTP_CALENDAR_BASE + 31)
static

This notification is used as an analog of the overridable method CXTPCalendarData::DoUpdate_RPattern.

Sender - CXTPCalendarCustomDataProvider, CXTPCalendarControl.

Send by a custom data provider. Calendar control reflects this notification as well as other notifications. Parameters wParam - [in] A pointer to recurrence pattern object as CXTPCalendarRecurrencePattern*; lParam - [out] A pointer to result of operation as BOOL*;

See also
CXTPCalendarCustomDataProvider::DoUpdate_RPattern

◆ XTP_NC_CALENDAR_GETGROPVIEWCAPTION

const XTP_NOTIFY_CODE XTP_NC_CALENDAR_GETGROPVIEWCAPTION = (WM_XTP_CALENDAR_BASE + 35)
static

This notification is sent when the selection is changed.

Sender - CXTPCalendarControl

Parameters wParam - [in] CXTPCalendarViewGroup* A pointer to Group View. lParam - [in/out] CString* pointer to caption string.

See also
CXTPCalendarViewGroup::GetCaption

◆ XTP_NC_CALENDAR_GETITEMTEXT

const XTP_NOTIFY_CODE XTP_NC_CALENDAR_GETITEMTEXT = (WM_XTP_CALENDAR_BASE + 39)
static

This notification is sent for calendar items which define an AskItemTextFlags property.

Parameters wParam - [in/out] XTP_CALENDAR_GETITEMTEXT_PARAMS*. lParam - 0.

See also
XTPCalendarGetItemTextEx
XTP_CALENDAR_GETITEMTEXT_PARAMS
CXTPCalendarControl::GetAskItemTextFlags
CXTPCalendarPaintManager::GetAskItemTextFlags
CXTPCalendarPaintManager::SetAskItemTextFlags
CXTPCalendarTheme::GetAskItemTextFlags
CXTPCalendarTheme::SetAskItemTextFlags

◆ XTP_NC_CALENDAR_IS_EVENT_EDIT_OPERATION_DISABLED

const XTP_NOTIFY_CODE XTP_NC_CALENDAR_IS_EVENT_EDIT_OPERATION_DISABLED
static
Initial value:
=
(WM_XTP_CALENDAR_BASE + 18)

This notification is sent to determine if the specified editing operation is disabled.

Sender - CXTPCalendarControl

This notification may be sent several times before the edit operation to update the user interface state in the right way (set corresponding mouse cursor for example). The XTP_NC_CALENDAR_BEFORE_EVENT_EDIT_OPERATION notification is sent only once before edit operation.

Parameters wParam - [in] A pointer to XTP_EVENT_EDIT_OPERATION_PARAMS structure or to derived structure depends on eOperation member value. lParam - [out] A pointer to the return result: BOOL*. Set TRUE if to disable specified editing operation, otherwise FALSE. Initial value is FALSE.

See also
XTP_NC_CALENDAR_BEFORE_EVENT_EDIT_OPERATION
XTPCalendarEditOperation
XTP_EVENT_EDIT_OPERATION_PARAMS
XTP_EVENT_PASTE_OPERATION_PARAMS
XTP_EVENT_IN_PLACE_CREATE_EVENT_OPERATION_PARAMS

◆ XTP_NC_CALENDAR_ON_REMINDERS

const XTP_NOTIFY_CODE XTP_NC_CALENDAR_ON_REMINDERS = (WM_XTP_CALENDAR_BASE + 22)
static

On RButtonUp event.

Sender - CXTPCalendarRemindersManager

Parameters - wParam = XTPCalendarRemindersAction, lParam = 0 or CXTPCalendarReminder*. See XTPCalendarRemindersAction.

◆ XTP_NC_CALENDAR_PREPOPULATE

const XTP_NOTIFY_CODE XTP_NC_CALENDAR_PREPOPULATE = (WM_XTP_CALENDAR_BASE + 36)
static

This notification is sent when calendar is populating.

lParam contains events which will be drawn for the group specified by wParam. You may add, remove or modify some events in the CXTPCalendarEvents collection.

Sender - CXTPCalendarControl

Parameters wParam - [in] CXTPCalendarViewGroup* A pointer to Group View. lParam - [in/out] CXTPCalendarEvents* A pointer to events array to draw.

See also
CXTPCalendarControl::Populate, XTP_NC_CALENDAR_PREPOPULATE_DAY.

◆ XTP_NC_CALENDAR_PREPOPULATE_DAY

const XTP_NOTIFY_CODE XTP_NC_CALENDAR_PREPOPULATE_DAY = (WM_XTP_CALENDAR_BASE + 41)
static

This notification is sent when the calendar is populating.

lParam contains events which will be drawn for the group specified by wParam. You may add, remove or modify some events in CXTPCalendarEvents collection.

Sender - CXTPCalendarControl

Parameters wParam - [in] CXTPCalendarViewDay* A pointer to View Day. lParam - unused.

See also
CXTPCalendarControl::Populate
XTP_NC_CALENDAR_PREPOPULATE

◆ XTP_NC_CALENDAR_SELECTION_CHANGED

const XTP_NOTIFY_CODE XTP_NC_CALENDAR_SELECTION_CHANGED = (WM_XTP_CALENDAR_BASE + 20)
static

This notification is sent when the selection is changed.

Sender - CXTPCalendarControl

Parameters wParam - [in] A value from XTPCalendarSelectionChanged enum. lParam - unused

See also
XTPCalendarSelectionChanged

◆ XTP_NC_CALENDAR_THEME_CHANGED

const XTP_NOTIFY_CODE XTP_NC_CALENDAR_THEME_CHANGED = (WM_XTP_CALENDAR_BASE + 42)
static

This notification is sent when the calendar paint theme changes.

Sender - CXTPCalendarControl

Parameters wParam - unused. lParam - unused.

See also
XTP_NC_CALENDARVIEWWASCHANGED

◆ XTP_NC_CALENDAR_USERACTION

const XTP_NOTIFY_CODE XTP_NC_CALENDAR_USERACTION = (WM_XTP_CALENDAR_BASE + 40)
static

This notification is sent when a user action defined in XTPCalendarUserAction enum happens.

Parameters wParam - [in] A pointer to XTP_CALENDAR_USERACTION_PARAMS structure. lParam - [out] A pointer to the return result: BOOL*. Set TRUE if specified action is handled (to Cancel default processing) , otherwise FALSE. Initial value is FALSE.

See also
XTP_CALENDAR_USERACTION_PARAMS
XTPCalendarUserAction

◆ XTP_NC_CALENDARCONTEXTMENU

const XTP_NOTIFY_CODE XTP_NC_CALENDARCONTEXTMENU = (WM_XTP_CALENDAR_BASE + 8)
static

A Context Menu should be displayed for the Calendar Control.

Sender - CXTPCalendarControl

Parameters - wParam = 'Clicked Point', lParam = 0

◆ XTP_NC_CALENDARDATAPROVIDERWASCHANGED

const XTP_NOTIFY_CODE XTP_NC_CALENDARDATAPROVIDERWASCHANGED = (WM_XTP_CALENDAR_BASE + 17)
static

Calendar Control data provider (resources) was changed.

SetDataProvider() or SetResources() methods were called. Sender - CXTPCalendarControl, CXTPCalendarView.

Parameters wParam = 0 if Calendar control resources were changed, 1 if CalendarView resources were changed. 2 if CalendarViewDay resources were changed. lParam = NULL if wParam == 0, CXTPCalendarView* if wParam == 1, CXTPCalendarViewDay* if wParam == 2.

◆ XTP_NC_CALENDAREVENTWASADDED

const XTP_NOTIFY_CODE XTP_NC_CALENDAREVENTWASADDED = (WM_XTP_CALENDAR_BASE + 1)
static

New event has just been added to the data provider.

Sender - CXTPCalendarData, CXTPCalendarControl

Parameters - wParam = EventID, lParam = CXTPCalendarEvent*

◆ XTP_NC_CALENDAREVENTWASCHANGED

const XTP_NOTIFY_CODE XTP_NC_CALENDAREVENTWASCHANGED = (WM_XTP_CALENDAR_BASE + 3)
static

Event has just been changed in the data provider.

Sender - CXTPCalendarData, CXTPCalendarControl

Parameters - wParam = EventID, lParam = CXTPCalendarEvent*

◆ XTP_NC_CALENDAREVENTWASDELETED

const XTP_NOTIFY_CODE XTP_NC_CALENDAREVENTWASDELETED = (WM_XTP_CALENDAR_BASE + 2)
static

Event has just been deleted from the data provider.

Sender - CXTPCalendarData, CXTPCalendarControl

Parameters - wParam = EventID, lParam = CXTPCalendarEvent*

◆ XTP_NC_CALENDARKEYDOWN

const XTP_NOTIFY_CODE XTP_NC_CALENDARKEYDOWN = (WM_XTP_CALENDAR_BASE + 13)
static

On KeyDown event.

Sender - CXTPCalendarControl

Parameters - wParam = 'key was pressed', lParam = 0

◆ XTP_NC_CALENDARLBUTTONDBLCLICK

const XTP_NOTIFY_CODE XTP_NC_CALENDARLBUTTONDBLCLICK = (WM_XTP_CALENDAR_BASE + 10)
static

On LButtonDblClick event.

Sender - CXTPCalendarControl

Parameters - wParam = 'Clicked Point', lParam = 0

◆ XTP_NC_CALENDARLBUTTONDOWN

const XTP_NOTIFY_CODE XTP_NC_CALENDARLBUTTONDOWN = (WM_XTP_CALENDAR_BASE + 9)
static

On LButtonDown event.

Sender - CXTPCalendarControl

Parameters - wParam = 'Clicked Point', lParam = 0

◆ XTP_NC_CALENDARLBUTTONUP

const XTP_NOTIFY_CODE XTP_NC_CALENDARLBUTTONUP = (WM_XTP_CALENDAR_BASE + 11)
static

On LButtonUp event.

Sender - CXTPCalendarControl

Parameters - wParam = 'Clicked Point', lParam = 0

◆ XTP_NC_CALENDARMOUSEMOVE

const XTP_NOTIFY_CODE XTP_NC_CALENDARMOUSEMOVE = (WM_XTP_CALENDAR_BASE + 12)
static

On MouseMove event.

Sender - CXTPCalendarControl

Parameters - wParam = 'Clicked Point', lParam = 0

◆ XTP_NC_CALENDAROPTIONSWASCHANGED

const XTP_NOTIFY_CODE XTP_NC_CALENDAROPTIONSWASCHANGED = (WM_XTP_CALENDAR_BASE + 16)
static

Calendar Control options was changed.

Sender - CXTPCalendarControl

Parameters wParam = -1 or XTPCalendarViewType enum value. Specify global option (-1) or which kind of view changed option is related. lParam = 0

◆ XTP_NC_CALENDARPATTERNWASADDED

const XTP_NOTIFY_CODE XTP_NC_CALENDARPATTERNWASADDED = (WM_XTP_CALENDAR_BASE + 4)
static

New recurrence pattern has just been added to the data provider.

Sender - CXTPCalendarData, CXTPCalendarControl

Parameters - wParam = RatternID, lParam = 0

◆ XTP_NC_CALENDARPATTERNWASCHANGED

const XTP_NOTIFY_CODE XTP_NC_CALENDARPATTERNWASCHANGED = (WM_XTP_CALENDAR_BASE + 6)
static

Recurrence pattern has just been changed in the data provider.

Sender - CXTPCalendarData, CXTPCalendarControl

Parameters - wParam = RatternID, lParam = 0

◆ XTP_NC_CALENDARPATTERNWASDELETED

const XTP_NOTIFY_CODE XTP_NC_CALENDARPATTERNWASDELETED = (WM_XTP_CALENDAR_BASE + 5)
static

Recurrence pattern has just been deleted from the data provider.

Sender - CXTPCalendarData, CXTPCalendarControl

Parameters - wParam = RatternID, lParam = 0

◆ XTP_NC_CALENDARRBUTTONDOWN

const XTP_NOTIFY_CODE XTP_NC_CALENDARRBUTTONDOWN = (WM_XTP_CALENDAR_BASE + 14)
static

On RButtonDown event.

Sender - CXTPCalendarControl

Parameters - wParam = 'Clicked Point', lParam = 0

◆ XTP_NC_CALENDARRBUTTONUP

const XTP_NOTIFY_CODE XTP_NC_CALENDARRBUTTONUP = (WM_XTP_CALENDAR_BASE + 21)
static

On RButtonUp event.

Sender - CXTPCalendarControl

Parameters - wParam = 'Clicked Point', lParam = 0

◆ XTP_NC_CALENDARVIEWTIMESCALEWASCHANGED

const XTP_NOTIFY_CODE XTP_NC_CALENDARVIEWTIMESCALEWASCHANGED = (WM_XTP_CALENDAR_BASE + 15)
static

Calendar Control Day view time scale was changed.

Sender - CXTPCalendarControl

Parameters - wParam = 0, lParam = 0

◆ XTP_NC_CALENDARVIEWWASCHANGED

const XTP_NOTIFY_CODE XTP_NC_CALENDARVIEWWASCHANGED = (WM_XTP_CALENDAR_BASE + 7)
static

Current Calendar Control view type(day, week, ...) or content was changed.

Sender - CXTPCalendarControl

Parameters - wParam = 0, lParam = 0


Toolkit Pro: XTPCalendarOccurSeriesChooseDlg.h File Reference

  • Source
  • Calendar
Classes
XTPCalendarOccurSeriesChooseDlg.h File Reference

Go to the source code of this file.

Classes

class CXTPCalendarOccurSeriesChooseDlg
This class implements a dialog to choose between current occurrence and whole recurrence event series (or pattern). More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPCalendarOptions.h File Reference

  • Source
  • Calendar
Classes | Functions
XTPCalendarOptions.h File Reference

Go to the source code of this file.

Classes

class CXTPCalendarOptions
Structure contains all calendar options. More...

Functions

XTP_DEFINE_SMART_PTR_INTERNAL (CXTPCalendarTimeZone) enum XTPCalendarAdditionalOptions
Enumerates additional calendar options flags.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPCalendarPaintManager.h File Reference

  • Source
  • Calendar
Classes | Macros
XTPCalendarPaintManager.h File Reference

Go to the source code of this file.

Classes

class CXTPCalendarPaintManager
Utility class, handles most of the drawing activities. More...

Macros

#define | BEGIN_VIEW_PART(theClass, parentClass)
This helper macro is used to declare paint manager drawing parts.
#define | BEGIN_VIEW_PART(theClass, parentClass)
This helper macro is used to declare paint manager drawing parts.
#define | END_VIEW_PART(theClass)
This helper macro is used to declare paint manager drawing parts.
#define | END_VIEW_PART(theClass)
This helper macro is used to declare paint manager drawing parts.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Macro Definition Documentation

◆ BEGIN_VIEW_PART [1/2]

#define BEGIN_VIEW_PART | ( | theClass,
 |  | parentClass )

This helper macro is used to declare paint manager drawing parts.

theClass - Part name. parentClass - Parent part name. There are two paint manager methods available to access declared part object: CPartName* GetPartName(); void SetPartName(CPartName* pPart); Where PartName is the name of the declared part.

Example:

declaration in the paint manager class
BEGIN_VIEW_PART(PartClass1, ParentPartClass1)
...
END_VIEW_PART(PartClass1)

// in the implementation
CPaintManagerClassName::CPartClass1* pPart1 = pPainManObj->GetPartClass1();
See also
END_VIEW_PART
CXTPCalendarPaintManager

◆ BEGIN_VIEW_PART [2/2]

#define BEGIN_VIEW_PART | ( | theClass,
 |  | parentClass )
Value:
class C##theClass : public C##parentClass \
{ \
public: \
typedef C##parentClass TBase; \
C##theClass(CXTPCalendarViewPart* pParentPart = NULL) \
: C##parentClass(pParentPart) \
{ \
_Init(); \
}
CXTPCalendarViewPart
Helper base class to implement parts for calendar paint manager.
Definition XTPCalendarViewPart.h:1228

This helper macro is used to declare paint manager drawing parts.

theClass - Part name. parentClass - Parent part name. There are two paint manager methods available to access declared part object: CPartName* GetPartName(); void SetPartName(CPartName* pPart); Where PartName is the name of the declared part.

Example:

declaration in the paint manager class
BEGIN_VIEW_PART(PartClass1, ParentPartClass1)
...
END_VIEW_PART(PartClass1)

// in the implementation
CPaintManagerClassName::CPartClass1* pPart1 = pPainManObj->GetPartClass1();
See also
END_VIEW_PART
CXTPCalendarPaintManager

◆ END_VIEW_PART [1/2]

#define END_VIEW_PART ( theClass )

This helper macro is used to declare paint manager drawing parts.

theClass - Part name.

See also
BEGIN_VIEW_PART
CXTPCalendarPaintManager

◆ END_VIEW_PART [2/2]

#define END_VIEW_PART ( theClass )
Value:
} \
; \
friend class C##theClass; \
\
protected: \
C##theClass* m_p##theClass; \
\
public: \
C##theClass* Get##theClass() const \
{ \
return m_p##theClass; \
} \
void Set##theClass(C##theClass* p##theClass) \
{ \
POSITION pos = m_lstViewParts.Find(m_p##theClass); \
_ASSERTE(pos); \
m_lstViewParts.RemoveAt(pos); \
delete m_p##theClass; \
m_p##theClass = p##theClass; \
m_lstViewParts.AddTail(p##theClass); \
p##theClass->m_pPaintManager = this; \
}

This helper macro is used to declare paint manager drawing parts.

theClass - Part name.

See also
BEGIN_VIEW_PART
CXTPCalendarPaintManager


Toolkit Pro: XTPCalendarPtrCollectionT.h File Reference

  • Source
  • Calendar
Classes
XTPCalendarPtrCollectionT.h File Reference

Go to the source code of this file.

Classes

class | CXTPCalendarPtrCollectionT< _TObject >
This class represents a simple array collection of objects. More...
class | CXTPCalendarTypedPtrAutoDeleteArray< BASE_CLASS, PTR_TYPE >
This class represents a simple array collection of objects pointers. More...
class | CXTPCalendarTypedPtrAutoDeleteMap< KEY, TPtr >
This class represents a simple map of typed keys to typed objects pointers. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPCalendarRecurrencePattern.h File Reference

  • Source
  • Calendar
Classes | Functions
XTPCalendarRecurrencePattern.h File Reference

Go to the source code of this file.

Classes

class | CXTPCalendarReminderForOccurrenceArray
This class implements a collection of CXTPCalendarReminderForOccurrence objects as well as some common operations on it. More...
struct | XTP_CALENDAR_RECURRENCE_OPTIONS
This structure defines a set of Recurrence Pattern options and is used by a CXTPRecurrencePattern to easily manage and transfer recurrence pattern data. More...
struct | XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_DAILY
Defines a group of parameters to describe the Daily pattern. More...
struct | XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_WEEKLY
Defines a group of parameters to describe the Weekly pattern. More...
struct | XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_MONTHLY
Defines a group of parameters to describe the Month pattern. More...
struct | XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_MONTHNTH
Defines a group of parameters to describe the Month pattern. More...
struct | XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_YEARLY
Defines a group of parameters to describe the Year pattern. More...
struct | XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_YEARNTH
Defines a group of parameters to describe the Year pattern. More...
class | CXTPCalendarRecurrencePattern
This class represents a recurrence pattern and stores data to build a schedule for recurrence events. More...

Functions

XTP_DEFINE_SMART_PTR_INTERNAL (CXTPCalendarEvent) XTP_DEFINE_SMART_PTR_INTERNAL(CXTPCalendarEvents) XTP_DEFINE_SMART_PTR_INTERNAL(CXTPCalendarRecurrencePattern) class _XTP_EXT_CLASS CXTPCalendarReminderForOccurrence
This structure describes a reminder for an occurrence of a recurrence event.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPCalendarRemindersDialog.h File Reference

  • Source
  • Calendar
Classes
XTPCalendarRemindersDialog.h File Reference

Go to the source code of this file.

Classes

class CXTPCalendarRemindersDialog
This class used to display calendar reminders. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPCalendarRemindersManager.h File Reference

  • Source
  • Calendar
Classes
XTPCalendarRemindersManager.h File Reference

Go to the source code of this file.

Classes

class | CXTPCalendarReminder
This class describes a reminder for a calendar event and implements base properties for and operations on the reminder. More...
struct | CXTPCalendarReminder::RecurrenceEventInfo
This structure contains data members to unambiguously define related recurrence event occurrence. More...
class | CXTPCalendarReminders
This class represents a simple array collection of CXTPCalendarReminder objects. More...
class | CXTPCalendarRemindersManager
This class is used to monitor and manage calendar events reminders. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPCalendarResource.h File Reference

  • Source
  • Calendar
Classes
XTPCalendarResource.h File Reference

Go to the source code of this file.

Classes

class | CXTPCalendarSchedule
Calendar Schedule is a characteristic of the Calendar Event, which describes a belonging of the Event to a particular Schedule (which could be people schedule, common resource schedule, etc). More...
class | CXTPCalendarSchedules
This class represents a simple array collection of CXTPCalendarSchedule objects. More...
class | CXTPCalendarResource
Class CXTPCalendarResource represents a calendar for some subject like a person, a shared resource, or even a group of people or resources. More...
class | CXTPCalendarResources
This class represents a simple array collection of CXTPCalendarResource objects. More...
class | CXTPCalendarResourcesNf
This class implements CXTPCalendarResource functionality with the addition of a notifications mechanism implemented by CXTPNotifySink. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPCalendarResourcesManager.h File Reference

  • Source
  • Calendar
Classes
XTPCalendarResourcesManager.h File Reference

Go to the source code of this file.

Classes

class | CXTPCalendarResourceDescription
This class is a wrapper for CXTPCalendarResource class. More...
class | CXTPCalendarResourcesManager
This class is used as a helper to manage calendar resources (and schedules) data configurations. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPCalendarShadowDrawer.h File Reference

  • Source
  • Calendar
Classes
XTPCalendarShadowDrawer.h File Reference

Go to the source code of this file.

Classes

class CXTPCalendarShadowDrawer
This is a helper class which handles shadows drawing (for events, etc). More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPCalendarTheme.h File Reference

  • Source
  • Calendar
Macros
XTPCalendarTheme.h File Reference

Go to the source code of this file.

Macros

#define XTP_SAFE_CALL_BASE(_TBase, memberFunc)
In VS 7.1 the call TBase::memberFunc will sometimes crash.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Macro Definition Documentation

◆ XTP_SAFE_CALL_BASE

#define XTP_SAFE_CALL_BASE | ( | _TBase,
 |  | memberFunc )
Value:
_TBase::memberFunc

In VS 7.1 the call TBase::memberFunc will sometimes crash.

The Service Pack 1 for VS 7.1 fix this compiler bug. The XTP_SAFE_CALL_BASE macro helps to avoid this problem in any VS version.


Toolkit Pro: XTPCalendarThemeOffice2007.h File Reference

  • Source
  • Calendar
Functions | Variables
XTPCalendarThemeOffice2007.h File Reference

Go to the source code of this file.

Functions

virtual CTOEvent * GetThemePartForEvent (CXTPCalendarViewEvent *pViewEvent)
Thin method determine event view type (day, week, month) and return corresponding drawing part.

Variables

const CPoint * | pPoint = NULL)
return 0 or xtpCalendarHitTestDayExpandButton
CStringArray | m_arWeekDayNamesLong
0 - Sunday, 1 - Monday, ...; 7 - Sat/Sun
CStringArray | m_arWeekDayNamesShort
0 - Sunday, 1 - Monday, ...; 7 - Sat/Sun

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Function Documentation

◆ GetThemePartForEvent()

virtual CTOEvent * GetThemePartForEvent ( CXTPCalendarViewEvent * pViewEvent )
virtual

Thin method determine event view type (day, week, month) and return corresponding drawing part.

Parameters
pViewEvent A pointer to the CXTPCalendarViewEvent event view.
Returns
Theme drawing part for editing event.


Toolkit Pro: XTPCalendarThemePrevNextEventButton.h File Reference

  • Source
  • Calendar
XTPCalendarThemePrevNextEventButton.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPCalendarThemePrevNextEventButtons.h File Reference

  • Source
  • Calendar
XTPCalendarThemePrevNextEventButtons.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPCalendarTimeLineView.h File Reference

  • Source
  • Calendar
Classes
XTPCalendarTimeLineView.h File Reference

Go to the source code of this file.

Classes

struct | XTP_CALENDAR_HITTESTINFO_TIMELINE_VIEW
Set of parameters transferred from calendar items to mouse handlers. More...
class | CXTPCalendarTimeLineView
This class implements a specific view portion of the Calendar control - called Timeline view. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPCalendarTimeLineViewGroup.h File Reference

  • Source
  • Calendar
Classes
XTPCalendarTimeLineViewGroup.h File Reference

Go to the source code of this file.

Classes

class | CXTPCalendarTimeLineViewEvent
This class represents an event timeline view portion of the CXTPCalendarViewEvent. More...
class | CXTPCalendarTimeLineViewGroup
This class represents an event timeline view portion of the CalendarViewGroup. More...
class | CXTPCalendarTimeLineViewGroups
This class represents a collection of CXTPCalendarTimeLineViewGroup objects. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPCalendarTimeLineViewTimeScale.h File Reference

  • Source
  • Calendar
Classes | Enumerations
XTPCalendarTimeLineViewTimeScale.h File Reference

Go to the source code of this file.

Classes

struct | XTP_CALENDAR_TIMELINE_VIEW_SCALE
Timeline's view scale. More...
class | CXTPCalendarTimeLineViewTimeScale
This class implements a specific view portion of the Calendar control called Timeline view scale. More...
class | CXTPCalendarTLV_TimeScaleParams
This class implements Timeline scale params. More...
class | CXTPCalendarTLV_TimeScaleParams_Day
This class implements Timeline scale params for Day case. More...
class | CXTPCalendarTLV_TimeScaleParams_Week
This class implements Timeline scale params for Week case. More...
class | CXTPCalendarTLV_TimeScaleParams_WorkWeek
This class implements Timeline scale params for WorkWeek case. More...
class | CXTPCalendarTLV_TimeScaleParams_Month
This class implements Timeline scale params for Month case. More...

Enumerations

enum XTPEnumCalendarDateItem {
xtpDTScale_Unknown = 0 , xtpDTScale_Sec = 0x0001 , xtpDTScale_Min = 0x0002 , xtpDTScale_Hour = 0x0004 ,
xtpDTScale_Day = 0x0010 , xtpDTScale_WorkWeek = 0x0015 , xtpDTScale_Week = 0x0020 , xtpDTScale_Month = 0x0040 ,
xtpDTScale_Year = 0x0080
}
Predefined set of different scales based on time intervals. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Enumeration Type Documentation

◆ XTPEnumCalendarDateItem

enum XTPEnumCalendarDateItem

Predefined set of different scales based on time intervals.

Enumerator
xtpDTScale_Unknown | Typed unknown value.
xtpDTScale_Sec | Sec scale.
xtpDTScale_Min | Min scale.
xtpDTScale_Hour | Hour scale.
xtpDTScale_Day | Day scale.
xtpDTScale_WorkWeek | WorkWeek scale.
xtpDTScale_Week | Week scale.
xtpDTScale_Month | Month scale.
xtpDTScale_Year | Year scale.


Toolkit Pro: XTPCalendarTimeZoneHelper.h File Reference

  • Source
  • Calendar
Classes
XTPCalendarTimeZoneHelper.h File Reference

Go to the source code of this file.

Classes

class | CXTPCalendarTimeZone
This class extends the TIME_ZONE_INFORMATION structure. More...
class | CXTPCalendarTimeZones
This class represents a simple array collection of CXTPCalendarTimeZone objects. More...
struct | CXTPCalendarTimeZones::REGISTRY_TIMEZONE_INFORMATION
This structure represents a format of binary data stored in the "TZI" registry key. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPCalendarTip.h File Reference

  • Source
  • Calendar
Classes
XTPCalendarTip.h File Reference

Go to the source code of this file.

Classes

class CXTPCalendarTip
The CXTPCalendarTip class emulates the functionality of a "tool tip" control. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPCalendarUtils.h File Reference

  • Source
  • Calendar
Classes | Macros | Functions
XTPCalendarUtils.h File Reference

Go to the source code of this file.

Classes

class | ITimeProvider
Interface for overriding the GetCurrentTime() function in calendar control. More...
class | CXTPCalendarUtils
Helper class with static member functions to perform common tasks with dates, events and other objects. More...
class | CXTPAutoResetValue< _TValue >
Helper class template provides functionality to temporary set some to variable and reset to initial or other value on destroy. More...

Macros

#define XTP_HALF_SECOND (1.0 / 172800.0)

Functions

static const COleDateTime | xtpCalendarDateTime_min (100, 1, 1, 0, 0, 0)
Defines a lower bound of the time frame for the Calendar control.
static const COleDateTime | xtpCalendarDateTime_max (9999, 12, 31, 0, 0, 0)
Defines an upper bound of the time frame for the Calendar control.
template<class _Type >
AFX_INLINE int | XTPCompare (_Type e1, _Type e2)
This template function is used to compare operands using operator > for the operands type and return compare result from the set: {-1, 0, 1}.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Macro Definition Documentation

◆ XTP_HALF_SECOND

#define XTP_HALF_SECOND (1.0 / 172800.0)

Half a second, expressed in days.

See also
COleDateTime overview

Function Documentation

◆ xtpCalendarDateTime_max()

static const COleDateTime xtpCalendarDateTime_max | ( | 9999 | ,
 |  | 12 | ,
 |  | 31 | ,
 |  | 0 | ,
 |  | 0 | ,
 |  | 0 | )
 static

Defines an upper bound of the time frame for the Calendar control.

Returns
A COLeDateTime const
See also
xtpCalendarDateTime_min

◆ xtpCalendarDateTime_min()

static const COleDateTime xtpCalendarDateTime_min | ( | 100 | ,
 |  | 1 | ,
 |  | 1 | ,
 |  | 0 | ,
 |  | 0 | ,
 |  | 0 | )
 static

Defines a lower bound of the time frame for the Calendar control.

Returns
A COLeDateTime const
See also
xtpCalendarDateTime_max

◆ XTPCompare()

template<class _Type >
AFX_INLINE int XTPCompare | ( | _Type | e1,
 |  | _Type | e2 )

This template function is used to compare operands using operator > for the operands type and return compare result from the set: {-1, 0, 1}.

Parameters
e1 | First operand to compare.
e2 | Second operand to compare.
Returns
0 if e1 == e2; 1 if e1 > e2; -1 if e1 < e2.


Toolkit Pro: XTPCalendarView.h File Reference

  • Source
  • Calendar
Classes | Functions
XTPCalendarView.h File Reference

Go to the source code of this file.

Classes

class | CXTPCalendarWMHandler
This class helps to handle Windows messages (WM_*) processing portion of the Calendar control views. More...
class | CXTPCalendarView
This class represents the view portion of the Calendar control. More...
class | CXTPCalendarView::CSelectionChangedContext
Class CSelectionChangedContext is used to avoid multiple sending of an XTP_NC_CALENDAR_SELECTION_CHANGED notification for one selection changing operation. More...
class | CXTPCalendarView::CSelectionChanged_ContextData
This class defines an internal structure used as a counter on selection changes, which is needed to redraw a view when necessary. More...
struct | CXTPCalendarView::SEventTimeFormatInfo
class | CXTPCalendarViewT< _TViewDay >
This template class represents a view portion of the Calendar control. More...

Functions

XTP_DEFINE_SMART_PTR_INTERNAL (CXTPCalendarEvent) XTP_DEFINE_SMART_PTR_INTERNAL(CXTPCalendarEvents) XTP_DEFINE_SMART_PTR_INTERNAL(CXTPCalendarViewEvent) XTP_DEFINE_SMART_PTR_INTERNAL(CXTPCalendarViewEvents) static const LPCTSTR XTPCALENDARCTRL_CF_EVENT

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Function Documentation

◆ XTP_DEFINE_SMART_PTR_INTERNAL()

XTP_DEFINE_SMART_PTR_INTERNAL ( CXTPCalendarEvent ) const

Timeout before appearing in the event subject editor window.

Calendar events clipboard format name.


Toolkit Pro: XTPCalendarViewDay.h File Reference

  • Source
  • Calendar
Classes
XTPCalendarViewDay.h File Reference

Go to the source code of this file.

Classes

class | CXTPCalendarViewGroup
Regular schema: More...
class | CXTPCalendarViewDay
This class represents the day view portion of the CalendarView. More...
class | CXTPCalendarViewDayT< _TView, _TViewGroup, XTP_CALENDAR_HITTESTINFO, _TPThis >
This class template customizes, overrides and implements some functionality for the CXTPCalendarViewDay base class. More...
class | CXTPCalendarViewGroupT< _TViewDay, _TViewEvent, _TPThis >
This class template customizes, overrides and implements some functionality for the CXTPCalendarViewGroup base class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPCalendarViewEvent.h File Reference

  • Source
  • Calendar
Classes | Enumerations
XTPCalendarViewEvent.h File Reference

Go to the source code of this file.

Classes

class | CXTPCalendarViewEvent
This class represents an event view portion of the CalendarViewGroup. More...
class | CXTPCalendarViewEvents
This class is used as a collection of Event View objects. More...
class | CXTPCalendarViewEventT< _TViewGroup >
This class is used to build the ViewEvent layer of the DayView and ViewEvent hierarchies. More...
class | CXTPCalendarViewEventSubjectEditor
This class is used to edit an event subject. More...
class | CXTPCalendarViewEventSubjectEditorColored
This class is used to edit event subject in Office 2007 Theme. More...

Enumerations

enum XTPCalendarEventCaptionFormat { xtpCalendarCaptionFormatUnknown = 0 , xtpCalendarCaptionFormatSubject = 1 , xtpCalendarCaptionFormatStartSubject = 2 , xtpCalendarCaptionFormatStartEndSubject = 3 }
Enumerates allowable formats for event caption. More...
enum XTPCalendarMultiDayEventFlags {
xtpCalendarMultiDayUnknown = 0 , xtpCalendarMultiDayNoMultiDay = 0x01 , xtpCalendarMultiDayFirst = 0x02 , xtpCalendarMultiDayMiddle = 0x04 ,
xtpCalendarMultiDayLast = 0x08 , xtpCalendarMultiDayFMLmask , xtpCalendarMultiDayMaster = 0x10 , xtpCalendarMultiDaySlave = 0x20 ,
xtpCalendarMultiDayMSmask
}
Enumerates defined flags for multi day event states. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Enumeration Type Documentation

◆ XTPCalendarEventCaptionFormat

enum XTPCalendarEventCaptionFormat

Enumerates allowable formats for event caption.

Enumerator
xtpCalendarCaptionFormatUnknown | Undefined format.
xtpCalendarCaptionFormatSubject | Caption displays subject.
xtpCalendarCaptionFormatStartSubject | Besides subject displays start time.
xtpCalendarCaptionFormatStartEndSubject | Besides subject displays start and end time.

◆ XTPCalendarMultiDayEventFlags

enum XTPCalendarMultiDayEventFlags

Enumerates defined flags for multi day event states.

Enumerator
xtpCalendarMultiDayUnknown | Undefined multi day event.
xtpCalendarMultiDayNoMultiDay | Not a multi day event.
xtpCalendarMultiDayFirst | First portion of a multi day event. Displayed in the first (by date) day view.
xtpCalendarMultiDayMiddle | Middle portion of a multi day event. Displayed in one of a middle day view.
xtpCalendarMultiDayLast | Last portion of a multi day event. Displayed in the last (by date) day view.
xtpCalendarMultiDayFMLmask | Combined flag.
xtpCalendarMultiDayMaster | First portion of a multi day event. Displayed in the first (by date) day view.
xtpCalendarMultiDaySlave | Rest of the event views (besides Master).
xtpCalendarMultiDayMSmask | Combines flag.


Toolkit Pro: XTPCalendarViewPart.h File Reference

  • Source
  • Calendar
Classes | Functions
XTPCalendarViewPart.h File Reference

Go to the source code of this file.

Classes

class | CXTPCalendarViewPartFontValue
Helper class provides functionality to manage font settings for various graphical elements of control. More...
class | CXTPCalendarThemeCustomizableXValueT< _TValue, _TValueRef >
Helper class template provides functionality to manage customized value for the specified type. More...
class | CXTPCalendarViewPartCustomizableValueT< _TValue >
Helper class template provides functionality to manage customized values for the specified class objects. More...
class | CXTPCalendarViewPartBrushValue
Helper class provides functionality to manage brush value objects. More...
class | CXTPCalendarThemeFontValue
Helper class provides functionality to manage font value objects. More...
class | CXTPCalendarThemeStringValue
Helper class provides functionality to manage customized string value objects. More...
class | CXTPCalendarThemeIntValue
Helper class provides functionality to manage customized int value objects. More...
class | CXTPCalendarThemeBOOLValue
Helper class provides functionality to manage customized BOOL value objects. More...
class | CXTPCalendarThemeRectValue
Helper class provides functionality to manage customized CRect value objects. More...
class | CXTPCalendarViewPart
Helper base class to implement parts for calendar paint manager. More...
class | CXTPCalendarTimeLineViewTimeScalePart
Helper base class to implement parts for calendar paint manager. More...
class | CXTPCalendarTimeLineViewPart
Helper base class to implement parts for calendar paint manager objects. More...

Functions

_XTP_EXT_CLASS BOOL AFX_CDECL | PX_Color (CXTPPropExchange *pPX, LPCTSTR pcszPropName, COLORREF &refColor)
Call this function within your class's DoPropExchange member function to serialize or initialize a customized Gradient Color property.
_XTP_EXT_CLASS BOOL AFX_CDECL | PX_Color (CXTPPropExchange *pPX, LPCTSTR pcszPropName, CXTPPaintManagerColor &refColor)
Call this function within your class's DoPropExchange member function to serialize or initialize a customized Gradient Color property.
_XTP_EXT_CLASS BOOL AFX_CDECL | PX_GrColor (CXTPPropExchange *pPX, LPCTSTR psczPropName, CXTPPaintManagerColorGradient &refGrColor)
Call this function within your class's DoPropExchange member function to serialize or initialize a customized Gradient Color property.
_XTP_EXT_CLASS BOOL AFX_CDECL | PX_Font (CXTPPropExchange *pPX, LPCTSTR pcszPropName, LOGFONT &rLogFont)
Call this function within your class's DoPropExchange member function to serialize or initialize a LOGFONT property.
_XTP_EXT_CLASS BOOL AFX_CDECL | PX_Font (CXTPPropExchange *pPX, LPCTSTR pcszPropName, CXTPCalendarThemeFontValue &refFont)
Call this function within your class's DoPropExchange member function to serialize or initialize a customized Font property.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Function Documentation

◆ PX_Color() [1/2]

_XTP_EXT_CLASS BOOL AFX_CDECL PX_Color | ( | CXTPPropExchange * | pPX,
 |  | LPCTSTR | pcszPropName,
 |  | COLORREF & | refColor )

Call this function within your class's DoPropExchange member function to serialize or initialize a customized Gradient Color property.

The property's value is read from or written to the variable referenced by refGrColor, as appropriate.

Parameters
pPX | Pointer to the CXTPPropExchange object (typically passed as a parameter to DoPropExchange).
pcszPropName | The name of the property being exchanged.
refColor | Reference to the variable where the property is stored.
Returns
Nonzero if the exchange was successful; 0 if unsuccessful.

◆ PX_Color() [2/2]

_XTP_EXT_CLASS BOOL AFX_CDECL PX_Color | ( | CXTPPropExchange * | pPX,
 |  | LPCTSTR | pcszPropName,
 |  | CXTPPaintManagerColor & | refColor )

Call this function within your class's DoPropExchange member function to serialize or initialize a customized Gradient Color property.

The property's value is read from or written to the variable referenced by refGrColor, as appropriate.

Parameters
pPX | Pointer to the CXTPPropExchange object (typically passed as a parameter to DoPropExchange).
pcszPropName | The name of the property being exchanged.
refColor | Reference to the variable where the property is stored.
Returns
Nonzero if the exchange was successful; 0 if unsuccessful.

◆ PX_Font() [1/2]

_XTP_EXT_CLASS BOOL AFX_CDECL PX_Font | ( | CXTPPropExchange * | pPX,
 |  | LPCTSTR | pcszPropName,
 |  | CXTPCalendarThemeFontValue & | refFont )

Call this function within your class's DoPropExchange member function to serialize or initialize a customized Font property.

The property's value is read from or written to the variable referenced by refFont, as appropriate.

Parameters
pPX | Pointer to the CXTPPropExchange object (typically passed as a parameter to DoPropExchange).
pcszPropName | The name of the property being exchanged.
refFont | Reference to the variable where the property is stored.
Returns
Nonzero if the exchange was successful; 0 if unsuccessful.

◆ PX_Font() [2/2]

_XTP_EXT_CLASS BOOL AFX_CDECL PX_Font | ( | CXTPPropExchange * | pPX,
 |  | LPCTSTR | pcszPropName,
 |  | LOGFONT & | rLogFont )

Call this function within your class's DoPropExchange member function to serialize or initialize a LOGFONT property.

The property's value is read from or written to the variable referenced by rLogFont, as appropriate.

Parameters
pPX | Pointer to the CXTPPropExchange object (typically passed as a parameter to DoPropExchange).
pcszPropName | The name of the property being exchanged.
rLogFont | Reference to the variable where the property is stored.
Returns
Nonzero if the exchange was successful; 0 if unsuccessful.

◆ PX_GrColor()

_XTP_EXT_CLASS BOOL AFX_CDECL PX_GrColor | ( | CXTPPropExchange * | pPX,
 |  | LPCTSTR | psczPropName,
 |  | CXTPPaintManagerColorGradient & | refGrColor )

Call this function within your class's DoPropExchange member function to serialize or initialize a customized Gradient Color property.

The property's value is read from or written to the variable referenced by refGrColor, as appropriate.

Parameters
pPX | Pointer to the CXTPPropExchange object (typically passed as a parameter to DoPropExchange).
psczPropName | The name of the property being exchanged.
refGrColor | Reference to the variable where the property is stored.
Returns
Nonzero if the exchange was successful; 0 if unsuccessful.


Toolkit Pro: XTPCalendarWeekView.h File Reference

  • Source
  • Calendar
Classes
XTPCalendarWeekView.h File Reference

Go to the source code of this file.

Classes

class CXTPCalendarWeekView
This class implements a specific view portion of the Calendar control - called Week view. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPCalendarWeekViewDay.h File Reference

  • Source
  • Calendar
Classes
XTPCalendarWeekViewDay.h File Reference

Go to the source code of this file.

Classes

class | CXTPCalendarWeekViewGroup
This class represents a single resource view portion of the Calendar Week View. More...
class | CXTPCalendarWeekViewDay
This class represents a day view portion of the CalendarWeekView. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPCalendarWeekViewEvent.h File Reference

  • Source
  • Calendar
Classes
XTPCalendarWeekViewEvent.h File Reference

Go to the source code of this file.

Classes

class CXTPCalendarWeekViewEvent
This class represents an event view portion of the CalendarWeekViewDay. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: Chart Directory Reference

  • Source
  • Chart
Chart Directory Reference

Directories

Appearance
Drawing
Types
Utils

Files

XTPChartContent.h
XTPChartContentView.h
XTPChartControl.h
XTPChartDefines.h
XTPChartDiagram.h
XTPChartDiagramView.h
XTPChartElement.h
XTPChartElementView.h
XTPChartErrorBar.h
XTPChartIIDs.h
XTPChartLegend.h
XTPChartLegendItem.h
XTPChartLegendView.h
XTPChartObjectFactory.h
XTPChartPanel.h
XTPChartSeries.h
XTPChartSeriesLabel.h
XTPChartSeriesPoint.h
XTPChartSeriesPointView.h
XTPChartSeriesStyle.h
XTPChartSeriesView.h
XTPChartTitle.h
XTPChartTitleView.h
XTPChartTrendline.h


Toolkit Pro: Appearance Directory Reference

  • Source
  • Chart
  • Appearance
Appearance Directory Reference

Files

XTPChartAppearance.h
XTPChartBorder.h
XTPChartFillStyle.h
XTPChartLineStyle.h
XTPChartPalette.h


Toolkit Pro: XTPChartAppearance.h File Reference

  • Source
  • Chart
  • Appearance
Classes
XTPChartAppearance.h File Reference

Go to the source code of this file.

Classes

class | CXTPChartElementAppearance
This class represents the appearance of a chart element. More...
class | CXTPChartTitleAppearance
This class represents the appearance of a chart title. More...
class | CXTPChartLegendAppearance
This class represents the appearance of a chart legend. More...
class | CXTPChartContentAppearance
This class represents the appearance of a chart content. More...
class | CXTPChartAxisAppearance
This class represents the appearance of a chart axis.This class is is subclassed from CXTPChartElementAppearance class. More...
class | CXTPChartDiagram2DAppearance
This class represents the appearance of diagram in 2D. More...
class | CXTPChartDiagram3DAppearance
This class represents the appearance of diagram in 3D. More...
class | CXTPChartFinanceStyleAppearance
This class represents the finance series appearance of the chart. More...
class | CXTPChartPieStyleAppearance
This class represents the pie series appearance of the chart. More...
class | CXTPChartAppearance
This class represents the appearance of the chart. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartBorder.h File Reference

  • Source
  • Chart
  • Appearance
Classes
XTPChartBorder.h File Reference

Go to the source code of this file.

Classes

class CXTPChartBorder
This class abstracts the border of a chart, it is a kind of chart element. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartFillStyle.h File Reference

  • Source
  • Chart
  • Appearance
Classes
XTPChartFillStyle.h File Reference

Go to the source code of this file.

Classes

class CXTPChartFillStyle
This class abstracts a fill style used to fill the background of various chart elements. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartLineStyle.h File Reference

  • Source
  • Chart
  • Appearance
Classes
XTPChartLineStyle.h File Reference

Go to the source code of this file.

Classes

class CXTPChartLineStyle
This class represents a chart line style, which is a kind of CXTPCmdTarget. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartPalette.h File Reference

  • Source
  • Chart
  • Appearance
Classes | Typedefs
XTPChartPalette.h File Reference

Go to the source code of this file.

Classes

class | CXTPChartPaletteEntry
This class represents a palette entry, which abstracts two 32 bit color values of type ARGB. More...
class | CXTPChartPalette
This class abstracts a color palette. More...

Typedefs

typedef CArray< CXTPChartPaletteEntry, CXTPChartPaletteEntry & > CXTPChartPaletteEntries
This type represents a collection of CXTPChartPaletteEntry objects, the container here used is CArray.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: Diagram Directory Reference

  • Source
  • Chart
  • Diagram
Diagram Directory Reference

Directories

Axis
Diagram2D
RadarDiagram


Toolkit Pro: Axis Directory Reference

  • Source
  • Chart
  • Diagram
  • Axis
Axis Directory Reference

Files

XTPChartAxis.h
XTPChartAxisConstantLines.h
XTPChartAxisCustomLabels.h
XTPChartAxisGridLines.h
XTPChartAxisLabel.h
XTPChartAxisRange.h
XTPChartAxisStrips.h
XTPChartAxisTickMarks.h
XTPChartAxisTitle.h
XTPChartAxisView.h
XTPChartRadarAxis.h
XTPChartRadarAxisView.h
XTPChartRadarAxisXView.h
XTPChartRadarAxisYView.h
XTPChartScaleTypeMap.h


Toolkit Pro: XTPChartAxis.h File Reference

  • Source
  • Chart
  • Diagram
  • Axis
Classes | Enumerations
XTPChartAxis.h File Reference

Go to the source code of this file.

Classes

class | CXTPChartAxis
This abstract base class represents a chart axis as a kind of chart element. More...
class | CXTPChartAxisX
CXTPChartAxisX is a derived class from the CXTPChartAxis class and represents the X axis of a chart. More...
class | CXTPChartAxisY
CXTPChartAxisY is a derived class from the CXTPChartAxis class and represents the Y axis of a chart. More...

Enumerations

enum XTPChartAxisAlignment { xtpChartAxisNear , xtpChartAxisFar }
Enumerates the axis alignment. More...
enum XTPChartAxisDateTimeScaleUnit {
xtpChartScaleMinute , xtpChartScaleHour , xtpChartScaleDay , xtpChartScaleMonth ,
xtpChartScaleYear
}
Enumerates the axis alignment. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Enumeration Type Documentation

◆ XTPChartAxisAlignment

enum XTPChartAxisAlignment

Enumerates the axis alignment.

Enumerator
xtpChartAxisNear | For Y axis, near means left side of the chart. For X axis it is the bottom side of the chart.
xtpChartAxisFar | For Y axis, far means right side of the chart. For X axis it is the top side of the chart.

◆ XTPChartAxisDateTimeScaleUnit

enum XTPChartAxisDateTimeScaleUnit

Enumerates the axis alignment.

Enumerator
xtpChartScaleMinute | A minute scale unit.
xtpChartScaleHour | An hour scale unit.
xtpChartScaleDay | A day scale unit.
xtpChartScaleMonth | A month scale unit.
xtpChartScaleYear | A year scale unit.


Toolkit Pro: XTPChartAxisConstantLines.h File Reference

  • Source
  • Chart
  • Diagram
  • Axis
Classes
XTPChartAxisConstantLines.h File Reference

Go to the source code of this file.

Classes

class | CXTPChartAxisConstantLine
CXTPChartAxisConstantLine is a hybrid object derived from CXTPChartTextElement and CXTPChartLegendItemView. More...
class | CXTPChartAxisConstantLines
This class encapsulates a collection of CXTPChartAxisConstantLine objects. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartAxisCustomLabels.h File Reference

  • Source
  • Chart
  • Diagram
  • Axis
Classes
XTPChartAxisCustomLabels.h File Reference

Go to the source code of this file.

Classes

class | CXTPChartAxisCustomLabel
CXTPChartAxisCustomLabel is a CXTPChartElement derived class. More...
class | CXTPChartAxisCustomLabels
This class encapsulates a collection of CXTPChartAxisCustomLabel objects. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartAxisGridLines.h File Reference

  • Source
  • Chart
  • Diagram
  • Axis
Classes
XTPChartAxisGridLines.h File Reference

Go to the source code of this file.

Classes

class CXTPChartAxisGridLines
CXTPChartAxisGridLines is a kind of CXTPChartElement, This class represents the grid lines parallel to an axis. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartAxisLabel.h File Reference

  • Source
  • Chart
  • Diagram
  • Axis
Classes
XTPChartAxisLabel.h File Reference

Go to the source code of this file.

Classes

class CXTPChartAxisLabel
CXTPChartAxisLabel is a kind of CXTPChartTextElement. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartAxisRange.h File Reference

  • Source
  • Chart
  • Diagram
  • Axis
Classes
XTPChartAxisRange.h File Reference

Go to the source code of this file.

Classes

class CXTPChartAxisRange
This class represents the value range of the axis. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartAxisStrips.h File Reference

  • Source
  • Chart
  • Diagram
  • Axis
Classes
XTPChartAxisStrips.h File Reference

Go to the source code of this file.

Classes

class | CXTPChartAxisStrip
This is a hybrid object of CXTPChartElement and CXTPChartLegendItemView. More...
class | CXTPChartAxisStrips
This class encapsulates a collection of chart axis strip objects. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartAxisTickMarks.h File Reference

  • Source
  • Chart
  • Diagram
  • Axis
Classes
XTPChartAxisTickMarks.h File Reference

Go to the source code of this file.

Classes

class CXTPChartAxisTickMarks
This class represents the tick marks in an axis. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartAxisTitle.h File Reference

  • Source
  • Chart
  • Diagram
  • Axis
Classes
XTPChartAxisTitle.h File Reference

Go to the source code of this file.

Classes

class CXTPChartAxisTitle
This class represents the axis title. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartAxisView.h File Reference

  • Source
  • Chart
  • Diagram
  • Axis
Classes
XTPChartAxisView.h File Reference

Go to the source code of this file.

Classes

class | CXTPChartAxisViewTick
This class represents a tick mark in the axis. More...
class | CXTPChartDiagram2DAxisView
This class abstracts the view of a chart axis and its child items in a bounding rectangle context. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartRadarAxis.h File Reference

  • Source
  • Chart
  • Diagram
  • Axis
Classes
XTPChartRadarAxis.h File Reference

Go to the source code of this file.

Classes

class | CXTPChartRadarAxisX
CXTPChartRadarAxisX is a derived class from the CXTPChartAxis class and represents the X axis of a chart. More...
class | CXTPChartRadarAxisY
CXTPChartRadarAxisY is a derived class from the CXTPChartAxis class and represents the Y axis of a chart. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartRadarAxisView.h File Reference

  • Source
  • Chart
  • Diagram
  • Axis
Classes
XTPChartRadarAxisView.h File Reference

Go to the source code of this file.

Classes

class CXTPChartRadarAxisView
This class abstracts the view of a chart axis and its child items in a bounding rectangle context. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartRadarAxisXView.h File Reference

  • Source
  • Chart
  • Diagram
  • Axis
Classes
XTPChartRadarAxisXView.h File Reference

Go to the source code of this file.

Classes

class | CXTPChartRadarAxisXViewTick
This class represents a tick mark in the axis. More...
class | CXTPChartRadarAxisXView
This class abstracts the view of a chart axis and its child items in a bounding rectangle context. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartRadarAxisYView.h File Reference

  • Source
  • Chart
  • Diagram
  • Axis
Classes
XTPChartRadarAxisYView.h File Reference

Go to the source code of this file.

Classes

class | CXTPChartRadarAxisYViewTick
This class represents a tick mark in the axis. More...
class | CXTPChartRadarAxisYView
This class abstracts the view of a chart axis and its child items in a bounding rectangle context. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartScaleTypeMap.h File Reference

  • Source
  • Chart
  • Diagram
  • Axis
Classes
XTPChartScaleTypeMap.h File Reference

Go to the source code of this file.

Classes

class | CXTPChartScaleTypeMap
This class abstracts a scale type map. More...
class | CXTPChartNumericalScaleTypeMap
This class is a kind of CXTPChartScaleTypeMap, which abstracts a numeric scale type for an axis. More...
class | CXTPChartDateTimeScaleTypeMap
This class is a kind of CXTPChartScaleTypeMap, which abstracts a date-time scale type for an axis. More...
class | CXTPChartTimeScaleTypeMap
This class is a kind of CXTPChartScaleTypeMap, which abstracts a time scale type for an axis. More...
class | CXTPChartStrings
This class is a collection class of strings. More...
class | CXTPChartQualitativeScaleTypeMap
This class abstracts a scale type map, which represents qualitative values. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: Diagram2D Directory Reference

  • Source
  • Chart
  • Diagram
  • Diagram2D
Diagram2D Directory Reference

Files

XTPChartDiagram2D.h
XTPChartDiagram2DPane.h
XTPChartDiagram2DSeriesLabel.h
XTPChartDiagram2DSeriesStyle.h
XTPChartDiagram2DSeriesView.h
XTPChartDiagram2DView.h


Toolkit Pro: XTPChartDiagram2D.h File Reference

  • Source
  • Chart
  • Diagram
  • Diagram2D
Classes
XTPChartDiagram2D.h File Reference

Go to the source code of this file.

Classes

class CXTPChartDiagram2D
This class represents a chart 2D diagram, which is a kind of CXTPChartDiagram. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartDiagram2DPane.h File Reference

  • Source
  • Chart
  • Diagram
  • Diagram2D
XTPChartDiagram2DPane.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartDiagram2DSeriesLabel.h File Reference

  • Source
  • Chart
  • Diagram
  • Diagram2D
Classes
XTPChartDiagram2DSeriesLabel.h File Reference

Go to the source code of this file.

Classes

class | CXTPChartDiagram2DSeriesLabel
This class abstracts the label of a point series. More...
class | CXTPChartDiagram2DSeriesLabelView
This class abstracts the view of the label of a point series. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartDiagram2DSeriesStyle.h File Reference

  • Source
  • Chart
  • Diagram
  • Diagram2D
Classes
XTPChartDiagram2DSeriesStyle.h File Reference

Go to the source code of this file.

Classes

class CXTPChartDiagram2DSeriesStyle
This class represents a line series style, which is a kind of CXTPChartSeriesStyle. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartDiagram2DSeriesView.h File Reference

  • Source
  • Chart
  • Diagram
  • Diagram2D
XTPChartDiagram2DSeriesView.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartDiagram2DView.h File Reference

  • Source
  • Chart
  • Diagram
  • Diagram2D
Classes
XTPChartDiagram2DView.h File Reference

Go to the source code of this file.

Classes

class CXTPChartDiagram2DView
This class represents the view of a chart 2D diagram, which is a kind of CXTPChartDiagramView. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: RadarDiagram Directory Reference

  • Source
  • Chart
  • Diagram
  • RadarDiagram
RadarDiagram Directory Reference

Files

XTPChartRadarDiagram.h
XTPChartRadarDiagramSeriesStyle.h
XTPChartRadarDiagramSeriesView.h
XTPChartRadarDiagramView.h


Toolkit Pro: XTPChartRadarDiagram.h File Reference

  • Source
  • Chart
  • Diagram
  • RadarDiagram
Classes | Enumerations
XTPChartRadarDiagram.h File Reference

Go to the source code of this file.

Classes

class CXTPChartRadarDiagram
This class represents a chart 2D diagram, which is a kind of CXTPChartDiagram. More...

Enumerations

enum XTPChartRadarDiagramStyle { xtpChartRadarDiagramCircle , xtpChartRadarDiagramPolygon }
Radar diagram style. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Enumeration Type Documentation

◆ XTPChartRadarDiagramStyle

enum XTPChartRadarDiagramStyle

Radar diagram style.

Enumerator
xtpChartRadarDiagramCircle | A circular radar diagram style.
xtpChartRadarDiagramPolygon | A polygonal radar diagram style.


Toolkit Pro: XTPChartRadarDiagramSeriesStyle.h File Reference

  • Source
  • Chart
  • Diagram
  • RadarDiagram
Classes
XTPChartRadarDiagramSeriesStyle.h File Reference

Go to the source code of this file.

Classes

class CXTPChartRadarDiagramSeriesStyle
This class represents a base radar series style, which is a kind of CXTPChartSeriesStyle. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartRadarDiagramSeriesView.h File Reference

  • Source
  • Chart
  • Diagram
  • RadarDiagram
XTPChartRadarDiagramSeriesView.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartRadarDiagramView.h File Reference

  • Source
  • Chart
  • Diagram
  • RadarDiagram
Classes
XTPChartRadarDiagramView.h File Reference

Go to the source code of this file.

Classes

class CXTPChartRadarDiagramView
This class represents the view of a chart 2D diagram, which is a kind of CXTPChartDiagramView. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: Drawing Directory Reference

  • Source
  • Chart
  • Drawing
Drawing Directory Reference

Directories

Gdi
OpenGL

Files

XTPChart3dDeviceContext.h
XTPChartCircleDeviceCommand.h
XTPChartDeviceCommand.h
XTPChartDeviceContext.h
XTPChartDrawingObjectFactory.h
XTPChartDrawThread.h
XTPChartLineDeviceCommand.h
XTPChartPieDeviceCommand.h
XTPChartPolygonDeviceCommand.h
XTPChartRectangleDeviceCommand.h
XTPChartTextDeviceCommand.h
XTPChartTransformationDeviceCommand.h


Toolkit Pro: Gdi Directory Reference

  • Source
  • Chart
  • Drawing
  • Gdi
Gdi Directory Reference

Files

XTPChartGdiCircleDeviceCommand.h
XTPChartGdiDeviceContext.h
XTPChartGdiLineDeviceCommand.h
XTPChartGdiPieDeviceCommand.h
XTPChartGdiPolygonDeviceCommand.h
XTPChartGdiRectangleDeviceCommand.h
XTPChartGdiTextDeviceCommand.h
XTPChartGdiTransformationDeviceCommand.h


Toolkit Pro: XTPChartGdiCircleDeviceCommand.h File Reference

  • Source
  • Chart
  • Drawing
  • Gdi
XTPChartGdiCircleDeviceCommand.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartGdiDeviceContext.h File Reference

  • Source
  • Chart
  • Drawing
  • Gdi
XTPChartGdiDeviceContext.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartGdiLineDeviceCommand.h File Reference

  • Source
  • Chart
  • Drawing
  • Gdi
XTPChartGdiLineDeviceCommand.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartGdiPieDeviceCommand.h File Reference

  • Source
  • Chart
  • Drawing
  • Gdi
XTPChartGdiPieDeviceCommand.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartGdiPolygonDeviceCommand.h File Reference

  • Source
  • Chart
  • Drawing
  • Gdi
XTPChartGdiPolygonDeviceCommand.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartGdiRectangleDeviceCommand.h File Reference

  • Source
  • Chart
  • Drawing
  • Gdi
XTPChartGdiRectangleDeviceCommand.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartGdiTextDeviceCommand.h File Reference

  • Source
  • Chart
  • Drawing
  • Gdi
XTPChartGdiTextDeviceCommand.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartGdiTransformationDeviceCommand.h File Reference

  • Source
  • Chart
  • Drawing
  • Gdi
XTPChartGdiTransformationDeviceCommand.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: OpenGL Directory Reference

  • Source
  • Chart
  • Drawing
  • OpenGL
OpenGL Directory Reference

Files

XTPChartOpenGLBackgroundColorDeviceCommand.h
XTPChartOpenGLCameraDeviceCommand.h
XTPChartOpenGLDebugDeviceCommands.h
XTPChartOpenGLDeviceContext.h
XTPChartOpenGLLineDeviceCommand.h
XTPChartOpenGLShadeModelDeviceCommand.h
XTPChartOpenGLTransformationDeviceCommand.h


Toolkit Pro: XTPChartOpenGLBackgroundColorDeviceCommand.h File Reference

  • Source
  • Chart
  • Drawing
  • OpenGL
XTPChartOpenGLBackgroundColorDeviceCommand.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartOpenGLCameraDeviceCommand.h File Reference

  • Source
  • Chart
  • Drawing
  • OpenGL
XTPChartOpenGLCameraDeviceCommand.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartOpenGLDebugDeviceCommands.h File Reference

  • Source
  • Chart
  • Drawing
  • OpenGL
XTPChartOpenGLDebugDeviceCommands.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartOpenGLDeviceContext.h File Reference

  • Source
  • Chart
  • Drawing
  • OpenGL
XTPChartOpenGLDeviceContext.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartOpenGLLineDeviceCommand.h File Reference

  • Source
  • Chart
  • Drawing
  • OpenGL
XTPChartOpenGLLineDeviceCommand.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartOpenGLShadeModelDeviceCommand.h File Reference

  • Source
  • Chart
  • Drawing
  • OpenGL
XTPChartOpenGLShadeModelDeviceCommand.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartOpenGLTransformationDeviceCommand.h File Reference

  • Source
  • Chart
  • Drawing
  • OpenGL
XTPChartOpenGLTransformationDeviceCommand.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChart3dDeviceContext.h File Reference

  • Source
  • Chart
  • Drawing
Classes
XTPChart3dDeviceContext.h File Reference

Go to the source code of this file.

Classes

class CXTPChart3dDeviceContext
A base implementation of 3D device context. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartCircleDeviceCommand.h File Reference

  • Source
  • Chart
  • Drawing
Classes
XTPChartCircleDeviceCommand.h File Reference

Go to the source code of this file.

Classes

class | CXTPChartCircleDeviceCommand
This class is the base class for all circle device commands. More...
class | CXTPChartBoundedCircleDeviceCommand
This class represents a bounded circle device command, which is a kind of CXTPChartDeviceCommand. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartDeviceCommand.h File Reference

  • Source
  • Chart
  • Drawing
Classes
XTPChartDeviceCommand.h File Reference

Go to the source code of this file.

Classes

class | CXTPChartDeviceCommandEvents
Defines a callback interface for a chart device command event sink. More...
class | CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands. More...
class | CXTPChart3dDeviceCommand
Defines a common implementation interface for chart 3D drawing commands. More...
class | CXTPChartHitTestElementCommand
Defines a base class interface for a 2D hit test command. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartDeviceContext.h File Reference

  • Source
  • Chart
  • Drawing
Classes
XTPChartDeviceContext.h File Reference

Go to the source code of this file.

Classes

class CXTPChartDeviceContext
This class abstracts a device context. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartDrawingObjectFactory.h File Reference

  • Source
  • Chart
  • Drawing
Classes
XTPChartDrawingObjectFactory.h File Reference

Go to the source code of this file.

Classes

class | CXTPChartDrawingObjectFactory
Provides a set of factory methods for creating drawing device commands and a base class interface for an abstract drawing object factory. More...
class | CXTPChart2dDrawingObjectFactory
Implements a 2D drawing object factory singleton. More...
class | CXTPChart3dDrawingObjectFactory
Implements a 3D drawing object factory singleton. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartDrawThread.h File Reference

  • Source
  • Chart
  • Drawing
XTPChartDrawThread.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartLineDeviceCommand.h File Reference

  • Source
  • Chart
  • Drawing
Classes
XTPChartLineDeviceCommand.h File Reference

Go to the source code of this file.

Classes

class | CXTPChartLineDeviceCommand
Provides an interface for 2D line drawing device command. More...
class | CXTPChartPolylineDeviceCommand
Provides an interface for 2D poly-line drawing device command. More...
class | CXTPChartSplineDeviceCommand
Provides an interface for 2D spline drawing device command. More...
class | CXTPChart3dLineDeviceCommand
Provides an interface for 3D line drawing device command. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartPieDeviceCommand.h File Reference

  • Source
  • Chart
  • Drawing
Classes
XTPChartPieDeviceCommand.h File Reference

Go to the source code of this file.

Classes

class | CXTPChartPieDeviceCommandImpl
This class is a common implementation for a pie chart device command. More...
class | CXTPChartPieDeviceCommand
Base class implementation for 2D pie chart device command. More...
class | CXTPChart3dPieDeviceCommand
Base class implementation for 3D pie chart device command. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartPolygonDeviceCommand.h File Reference

  • Source
  • Chart
  • Drawing
Classes
XTPChartPolygonDeviceCommand.h File Reference

Go to the source code of this file.

Classes

class | CXTPChartPolygonDeviceCommand
Base class implementation for 2D chart polygon device command. More...
class | CXTPChartSolidSplinePolygonDeviceCommand
Base class implementation for 2D chart solid spline polygon device command. More...
class | CXTPChartBoundedPolygonDeviceCommand
Base class implementation for 2D chart bounded polygon device command. More...
class | CXTPChartPolygonAntialiasingDeviceCommand
Base class implementation for 2D chart antialiased polygon device command. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartRectangleDeviceCommand.h File Reference

  • Source
  • Chart
  • Drawing
Classes
XTPChartRectangleDeviceCommand.h File Reference

Go to the source code of this file.

Classes

class CXTPChartRectangleDeviceCommand
Base class implementation for 2D chart rectangle device command. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartTextDeviceCommand.h File Reference

  • Source
  • Chart
  • Drawing
Classes
XTPChartTextDeviceCommand.h File Reference

Go to the source code of this file.

Classes

class | CXTPChartTextDeviceCommand
This class represents a text device command, which is a kind of CXTPChartDeviceCommand. More...
class | CXTPChartTextAntialiasingDeviceCommand
This class represents a text device command, which is a kind of CXTPChartDeviceCommand. More...
class | CXTPChartBoundedTextDeviceCommand
This class represents a bounded text device command, which is a kind of CXTPChartDeviceCommand. More...
class | CXTPChartMarkupElementDeviceCommand
Implements 2D markup element drawing device command. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartTransformationDeviceCommand.h File Reference

  • Source
  • Chart
  • Drawing
Classes
XTPChartTransformationDeviceCommand.h File Reference

Go to the source code of this file.

Classes

class | CXTPChartClipDeviceCommand
Base class implementation for 2D chart clipping device command. More...
class | CXTPChartRotateDeviceCommand
Base class implementation for 2D chart rotation device command. More...
class | CXTPChart3dRotateDeviceCommand
Base class implementation for 3D chart rotation device command. More...
class | CXTPChartTranslateDeviceCommand
Base class implementation for 2D chart translation device command. More...
class | CXTPChart3dTranslateDeviceCommand
Base class implementation for 3D chart translation device command. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: Styles Directory Reference

  • Source
  • Chart
  • Styles
Styles Directory Reference

Directories

Area
Bar
Financial
Funnel
Line
Pie
Point
Pyramid
Radar
Range


Toolkit Pro: Area Directory Reference

  • Source
  • Chart
  • Styles
  • Area
Area Directory Reference

Files

XTPChartAreaSeriesStyle.h
XTPChartAreaSeriesView.h
XTPChartRangeAreaSeriesLabel.h
XTPChartRangeSplineAreaSeriesStyle.h
XTPChartSplineAreaSeriesStyle.h
XTPChartStackedAreaSeriesStyle.h
XTPChartStackedSplineAreaSeriesStyle.h
XTPChartStepAreaSeriesStyle.h


Toolkit Pro: XTPChartAreaSeriesStyle.h File Reference

  • Source
  • Chart
  • Styles
  • Area
Classes
XTPChartAreaSeriesStyle.h File Reference

Go to the source code of this file.

Classes

class CXTPChartAreaSeriesStyle
CXTPChartAreaSeriesStyle is a CXTPChartPointSeriesStyle derived class which represents the area series style. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartAreaSeriesView.h File Reference

  • Source
  • Chart
  • Styles
  • Area
Classes
XTPChartAreaSeriesView.h File Reference

Go to the source code of this file.

Classes

class CXTPChartAreaSeriesView
CXTPChartAreaSeriesView is a kind of CXTPChartSeriesView. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartRangeAreaSeriesLabel.h File Reference

  • Source
  • Chart
  • Styles
  • Area
Classes
XTPChartRangeAreaSeriesLabel.h File Reference

Go to the source code of this file.

Classes

class | CXTPChartRangeAreaSeriesLabel
This class abstracts the label of a bar series. More...
class | CXTPChartRangeAreaSeriesLabelView
This class abstracts the view of the label of a bar series. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartRangeSplineAreaSeriesStyle.h File Reference

  • Source
  • Chart
  • Styles
  • Area
Classes
XTPChartRangeSplineAreaSeriesStyle.h File Reference

Go to the source code of this file.

Classes

class | CXTPChartRangeSplineAreaSeriesStyle
CXTPChartRangeSplineAreaSeriesStyle is a CXTPChartAreaSeriesStyle derived class which represents the area series style. More...
class | CXTPChartRangeSplineAreaSeriesView
CXTPChartRangeSplineAreaSeriesView is a kind of CXTPChartAreaSeriesView. More...
class | CXTPChartRangeSplineAreaSeriesPointView
This class represents the view of a RangeBar series point, which is a kind of CXTPChartPointSeriesPointView. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartSplineAreaSeriesStyle.h File Reference

  • Source
  • Chart
  • Styles
  • Area
Classes
XTPChartSplineAreaSeriesStyle.h File Reference

Go to the source code of this file.

Classes

class | CXTPChartSplineAreaSeriesStyle
This class represents a spline area series style, which is a kind of CXTPChartAreaSeriesStyle. More...
class | CXTPChartSplineAreaSeriesView
CXTPChartSplineAreaSeriesView is a kind of CXTPChartSeriesView. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartStackedAreaSeriesStyle.h File Reference

  • Source
  • Chart
  • Styles
  • Area
Classes
XTPChartStackedAreaSeriesStyle.h File Reference

Go to the source code of this file.

Classes

class | CXTPChartStackedAreaSeriesStyle
CXTPChartStackedAreaSeriesStyle is a CXTPChartAreaSeriesStyle derived class which represents the area series style. More...
class | CXTPChartStackedAreaSeriesView
CXTPChartStackedAreaSeriesView is a kind of CXTPChartSeriesView. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartStackedSplineAreaSeriesStyle.h File Reference

  • Source
  • Chart
  • Styles
  • Area
Classes
XTPChartStackedSplineAreaSeriesStyle.h File Reference

Go to the source code of this file.

Classes

class | CXTPChartStackedSplineAreaSeriesStyle
CXTPChartStackedSplineAreaSeriesStyle is a CXTPChartStackedAreaSeriesStyle derived class which represents the area series style. More...
class | CXTPChartStackedSplineAreaSeriesView
CXTPChartStackedSplineAreaSeriesView is a kind of CXTPChartSeriesView. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartStepAreaSeriesStyle.h File Reference

  • Source
  • Chart
  • Styles
  • Area
Classes
XTPChartStepAreaSeriesStyle.h File Reference

Go to the source code of this file.

Classes

class | CXTPChartStepAreaSeriesStyle
This class represents a StepArea series style, which is a kind of CXTPChartAreaSeriesStyle. More...
class | CXTPChartStepAreaSeriesView
This class represents the view of a StepArea series, which is a kind of CXTPChartSeriesView. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: Bar Directory Reference

  • Source
  • Chart
  • Styles
  • Bar
Bar Directory Reference

Files

XTPChartBarSeriesErrorBar.h
XTPChartBarSeriesLabel.h
XTPChartBarSeriesStyle.h
XTPChartBarSeriesView.h
XTPChartStackedBarSeriesStyle.h


Toolkit Pro: XTPChartBarSeriesErrorBar.h File Reference

  • Source
  • Chart
  • Styles
  • Bar
Classes
XTPChartBarSeriesErrorBar.h File Reference

Go to the source code of this file.

Classes

class CXTPChartBarSeriesErrorBarView
This class abstracts the view of the label of a bar series. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartBarSeriesLabel.h File Reference

  • Source
  • Chart
  • Styles
  • Bar
Classes
XTPChartBarSeriesLabel.h File Reference

Go to the source code of this file.

Classes

class | CXTPChartBarSeriesLabel
This class abstracts the label of a bar series. More...
class | CXTPChartBarSeriesLabelView
This class abstracts the view of the label of a bar series. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartBarSeriesStyle.h File Reference

  • Source
  • Chart
  • Styles
  • Bar
Classes
XTPChartBarSeriesStyle.h File Reference

Go to the source code of this file.

Classes

class CXTPChartBarSeriesStyle
This class represents a bar series style for the chart, which is a kind of CXTPChartSeriesStyle. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartBarSeriesView.h File Reference

  • Source
  • Chart
  • Styles
  • Bar
Classes
XTPChartBarSeriesView.h File Reference

Go to the source code of this file.

Classes

class | CXTPChartBarSeriesView
This class represents the view of a bar series, which is a kind of CXTPChartSeriesView. More...
class | CXTPChartBarSeriesPointView
This class represents the view of a bar series point, which is a kind of CXTPChartPointSeriesPointView. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartStackedBarSeriesStyle.h File Reference

  • Source
  • Chart
  • Styles
  • Bar
Classes
XTPChartStackedBarSeriesStyle.h File Reference

Go to the source code of this file.

Classes

class | CXTPChartStackedBarSeriesStyle
This class represents a bar series style for the chart, which is a kind of CXTPChartSeriesStyle. More...
class | CXTPChartStackedBarSeriesView
This class represents the view of a bar series, which is a kind of CXTPChartSeriesView. More...
class | CXTPChartStackedBarSeriesPointView
This class represents the view of a bar series point, which is a kind of CXTPChartPointSeriesPointView. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: Financial Directory Reference

  • Source
  • Chart
  • Styles
  • Financial
Financial Directory Reference

Files

XTPChartCandleStickSeriesStyle.h
XTPChartHighLowSeriesStyle.h


Toolkit Pro: XTPChartCandleStickSeriesStyle.h File Reference

  • Source
  • Chart
  • Styles
  • Financial
Classes
XTPChartCandleStickSeriesStyle.h File Reference

Go to the source code of this file.

Classes

class | CXTPChartCandleStickSeriesStyle
This class represents a candle stick series style, which is a kind of CXTPChartHighLowSeriesStyle. More...
class | CXTPChartCandleStickSeriesView
This class represents the view of a candle stick series, which is a kind of CXTPChartSeriesView. More...
class | CXTPChartCandleStickSeriesPointView
This class represents the view of a candle stick series point, which is a kind of CXTPChartSeriesPointView. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartHighLowSeriesStyle.h File Reference

  • Source
  • Chart
  • Styles
  • Financial
Classes
XTPChartHighLowSeriesStyle.h File Reference

Go to the source code of this file.

Classes

class | CXTPChartHighLowSeriesStyle
This class represents the stock series style in the chart. More...
class | CXTPChartHighLowSeriesView
This class abstracts the view of the stock series of the chart. More...
class | CXTPChartHighLowSeriesPointView
This class abstracts the view of the stock series point of the chart. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: Funnel Directory Reference

  • Source
  • Chart
  • Styles
  • Funnel
Funnel Directory Reference

Directories

2D
3D
Base

Files

XTPChartFunnelDiagram.h
XTPChartFunnelDiagramView.h
XTPChartFunnelSeriesLabel.h
XTPChartFunnelSeriesPointView.h
XTPChartFunnelSeriesStyle.h
XTPChartFunnelSeriesView.h


Toolkit Pro: 2D Directory Reference

  • Source
  • Chart
  • Styles
  • Funnel
  • 2D
2D Directory Reference

Files

XTPChart2dFunnelDiagram.h
XTPChart2dFunnelDiagramView.h
XTPChart2dFunnelSeriesLabel.h
XTPChart2dFunnelSeriesPointView.h
XTPChart2dFunnelSeriesStyle.h
XTPChart2dFunnelSeriesView.h


Toolkit Pro: XTPChart2dFunnelDiagram.h File Reference

  • Source
  • Chart
  • Styles
  • Funnel
  • 2D
Classes
XTPChart2dFunnelDiagram.h File Reference

Go to the source code of this file.

Classes

class CXTPChartFunnelDiagram
This class abstracts the funnel diagram. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChart2dFunnelDiagramView.h File Reference

  • Source
  • Chart
  • Styles
  • Funnel
  • 2D
Classes
XTPChart2dFunnelDiagramView.h File Reference

Go to the source code of this file.

Classes

class CXTPChartFunnelDiagramView
This class abstracts the view of a funnel diagram. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChart2dFunnelSeriesLabel.h File Reference

  • Source
  • Chart
  • Styles
  • Funnel
  • 2D
Classes
XTPChart2dFunnelSeriesLabel.h File Reference

Go to the source code of this file.

Classes

class | CXTPChartFunnelSeriesLabel
CXTPChartFunnelSeriesLabel is a kind of CXTPChartSeriesLabel. More...
class | CXTPChartFunnelSeriesLabelView
Defines 2D series label view. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChart2dFunnelSeriesPointView.h File Reference

  • Source
  • Chart
  • Styles
  • Funnel
  • 2D
Classes
XTPChart2dFunnelSeriesPointView.h File Reference

Go to the source code of this file.

Classes

class CXTPChartFunnelSeriesPointView
This class abstracts the view of a funnel series point. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChart2dFunnelSeriesStyle.h File Reference

  • Source
  • Chart
  • Styles
  • Funnel
  • 2D
Classes
XTPChart2dFunnelSeriesStyle.h File Reference

Go to the source code of this file.

Classes

class CXTPChartFunnelSeriesStyle
This class abstracts the basic style of a funnel series. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChart2dFunnelSeriesView.h File Reference

  • Source
  • Chart
  • Styles
  • Funnel
  • 2D
Classes
XTPChart2dFunnelSeriesView.h File Reference

Go to the source code of this file.

Classes

class CXTPChartFunnelSeriesView
This class abstracts the view of a funnel series. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: 3D Directory Reference

  • Source
  • Chart
  • Styles
  • Funnel
  • 3D
3D Directory Reference

Directories

Commands

Files

XTPChart3dFunnelDiagram.h
XTPChart3dFunnelDiagramView.h
XTPChart3dFunnelSeriesLabel.h
XTPChart3dFunnelSeriesPointView.h
XTPChart3dFunnelSeriesStyle.h
XTPChart3dFunnelSeriesView.h


Toolkit Pro: Commands Directory Reference

  • Source
  • Chart
  • Styles
  • Funnel
  • 3D
  • Commands
Commands Directory Reference

Directories

OpenGL

Files

XTPChart3dFunnelDeviceCommandEvents.h
XTPChart3dFunnelSeriesLabelsViewDeviceCommand.h


Toolkit Pro: OpenGL Directory Reference

  • Source
  • Chart
  • Styles
  • Funnel
  • 3D
  • Commands
  • OpenGL
OpenGL Directory Reference

Files

XTPChartOpenGLFunnelDeviceCommand.h


Toolkit Pro: XTPChartOpenGLFunnelDeviceCommand.h File Reference

  • Source
  • Chart
  • Styles
  • Funnel
  • 3D
  • Commands
  • OpenGL
XTPChartOpenGLFunnelDeviceCommand.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChart3dFunnelDeviceCommandEvents.h File Reference

  • Source
  • Chart
  • Styles
  • Funnel
  • 3D
  • Commands
Classes
XTPChart3dFunnelDeviceCommandEvents.h File Reference

Go to the source code of this file.

Classes

class CXTPChart3dFunnelDeviceCommandEvents
Defines interface for 3D chart funnel device command event sink. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChart3dFunnelSeriesLabelsViewDeviceCommand.h File Reference

  • Source
  • Chart
  • Styles
  • Funnel
  • 3D
  • Commands
Classes
XTPChart3dFunnelSeriesLabelsViewDeviceCommand.h File Reference

Go to the source code of this file.

Classes

class | CXTPChart3dFunnelSeriesLabelDeviceCommand
Implements 3D chart funnel series label device command. More...
class | CXTPChart3dFunnelSeriesLabelsViewDeviceCommand
Represents device command for all funnel series labels view. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChart3dFunnelDiagram.h File Reference

  • Source
  • Chart
  • Styles
  • Funnel
  • 3D
Classes
XTPChart3dFunnelDiagram.h File Reference

Go to the source code of this file.

Classes

class CXTPChart3dFunnelDiagram
This class abstracts the funnel diagram. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChart3dFunnelDiagramView.h File Reference

  • Source
  • Chart
  • Styles
  • Funnel
  • 3D
Classes
XTPChart3dFunnelDiagramView.h File Reference

Go to the source code of this file.

Classes

class CXTPChart3dFunnelDiagramView
This class abstracts the view of a funnel diagram. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChart3dFunnelSeriesLabel.h File Reference

  • Source
  • Chart
  • Styles
  • Funnel
  • 3D
Classes
XTPChart3dFunnelSeriesLabel.h File Reference

Go to the source code of this file.

Classes

class | CXTPChart3dFunnelSeriesLabel
CXTPChartFunnelSeriesLabelBase is a kind of CXTPChart3dFunnelSeriesLabel. More...
class | CXTPChart3dFunnelSeriesLabelView
Represents a series label view object. More...
class | CXTPChart3dFunnelSeriesLabelsView
Represents a view object for all funnel series labels. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChart3dFunnelSeriesPointView.h File Reference

  • Source
  • Chart
  • Styles
  • Funnel
  • 3D
Classes
XTPChart3dFunnelSeriesPointView.h File Reference

Go to the source code of this file.

Classes

class CXTPChart3dFunnelSeriesPointView
This class abstracts the view of a funnel series point. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChart3dFunnelSeriesStyle.h File Reference

  • Source
  • Chart
  • Styles
  • Funnel
  • 3D
Classes
XTPChart3dFunnelSeriesStyle.h File Reference

Go to the source code of this file.

Classes

class CXTPChart3dFunnelSeriesStyle
This class abstracts the basic style of a funnel series. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChart3dFunnelSeriesView.h File Reference

  • Source
  • Chart
  • Styles
  • Funnel
  • 3D
Classes
XTPChart3dFunnelSeriesView.h File Reference

Go to the source code of this file.

Classes

class CXTPChart3dFunnelSeriesView
This class abstracts the view of a funnel series. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: Base Directory Reference

  • Source
  • Chart
  • Styles
  • Funnel
  • Base
Base Directory Reference

Files

XTPChartFunnelDiagramBase.h
XTPChartFunnelSeriesLabelBase.h
XTPChartFunnelSeriesPointViewBase.h
XTPChartFunnelSeriesStyleBase.h
XTPChartFunnelSeriesViewBase.h


Toolkit Pro: XTPChartFunnelDiagramBase.h File Reference

  • Source
  • Chart
  • Styles
  • Funnel
  • Base
Classes
XTPChartFunnelDiagramBase.h File Reference

Go to the source code of this file.

Classes

class CXTPChartFunnelDiagramBase< BaseDiagram >
This class abstracts the funnel diagram. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartFunnelSeriesLabelBase.h File Reference

  • Source
  • Chart
  • Styles
  • Funnel
  • Base
Classes | Enumerations
XTPChartFunnelSeriesLabelBase.h File Reference

Go to the source code of this file.

Classes

class | CXTPChartFunnelSeriesLabelBase
CXTPChartFunnelSeriesLabelBase is a kind of CXTPChartSeriesLabel. More...
class | CXTPChartFunnelSeriesLabelViewBase
This class abstracts the view of a funnel series label. More...

Enumerations

enum XTPChartFunnelLabelPosition { xtpChartFunnelLabelLeft , xtpChartFunnelLabelRight , xtpChartFunnelLabelCenter }
This enumeration tells the various positions available for the funnel label. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Enumeration Type Documentation

◆ XTPChartFunnelLabelPosition

enum XTPChartFunnelLabelPosition

This enumeration tells the various positions available for the funnel label.

Enumerator
xtpChartFunnelLabelLeft | Specifies left chart label direction.
xtpChartFunnelLabelRight | Specifies right chart label direction.
xtpChartFunnelLabelCenter | Specifies center chart label direction.


Toolkit Pro: XTPChartFunnelSeriesPointViewBase.h File Reference

  • Source
  • Chart
  • Styles
  • Funnel
  • Base
Classes
XTPChartFunnelSeriesPointViewBase.h File Reference

Go to the source code of this file.

Classes

class CXTPChartFunnelSeriesPointViewBase
This class abstracts the view of a funnel series point. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartFunnelSeriesStyleBase.h File Reference

  • Source
  • Chart
  • Styles
  • Funnel
  • Base
Classes
XTPChartFunnelSeriesStyleBase.h File Reference

Go to the source code of this file.

Classes

class CXTPChartFunnelSeriesStyleBase
This class abstracts the basic style of a funnel serie.This class is a kind of CXTPChartSeriesStyle. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartFunnelSeriesViewBase.h File Reference

  • Source
  • Chart
  • Styles
  • Funnel
  • Base
Classes
XTPChartFunnelSeriesViewBase.h File Reference

Go to the source code of this file.

Classes

class CXTPChartFunnelSeriesViewBase
This class abstracts the view of a funnel series.This class is a kind of CXTPChartSeriesView. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartFunnelDiagram.h File Reference

  • Source
  • Chart
  • Styles
  • Funnel
XTPChartFunnelDiagram.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartFunnelDiagramView.h File Reference

  • Source
  • Chart
  • Styles
  • Funnel
XTPChartFunnelDiagramView.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartFunnelSeriesLabel.h File Reference

  • Source
  • Chart
  • Styles
  • Funnel
XTPChartFunnelSeriesLabel.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartFunnelSeriesPointView.h File Reference

  • Source
  • Chart
  • Styles
  • Funnel
XTPChartFunnelSeriesPointView.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartFunnelSeriesStyle.h File Reference

  • Source
  • Chart
  • Styles
  • Funnel
XTPChartFunnelSeriesStyle.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartFunnelSeriesView.h File Reference

  • Source
  • Chart
  • Styles
  • Funnel
XTPChartFunnelSeriesView.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: Line Directory Reference

  • Source
  • Chart
  • Styles
  • Line
Line Directory Reference

Files

XTPChartFastLineSeriesStyle.h
XTPChartLineSeriesErrorBar.h
XTPChartLineSeriesStyle.h
XTPChartLineSeriesView.h
XTPChartScatterLineSeriesStyle.h
XTPChartSplineSeriesStyle.h
XTPChartStepLineSeriesStyle.h


Toolkit Pro: XTPChartFastLineSeriesStyle.h File Reference

  • Source
  • Chart
  • Styles
  • Line
Classes
XTPChartFastLineSeriesStyle.h File Reference

Go to the source code of this file.

Classes

class | CXTPChartFastLineSeriesStyle
This class represents a line series style, which is a kind of CXTPChartPointSeriesStyle. More...
class | CXTPChartFastLineSeriesView
This class represents the view of a line series, which is a kind of CXTPChartSeriesView. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartLineSeriesErrorBar.h File Reference

  • Source
  • Chart
  • Styles
  • Line
Classes
XTPChartLineSeriesErrorBar.h File Reference

Go to the source code of this file.

Classes

class CXTPChartLineSeriesErrorBarView
This class abstracts the view of the label of a bar series, it is a kind of point series label view. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartLineSeriesStyle.h File Reference

  • Source
  • Chart
  • Styles
  • Line
Classes
XTPChartLineSeriesStyle.h File Reference

Go to the source code of this file.

Classes

class | CXTPChartLineSeriesStyle
This class represents a line series style, which is a kind of CXTPChartPointSeriesStyle. More...
class | CXTPChartLineSeriesView
This class represents the view of a line series, which is a kind of CXTPChartSeriesView. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartLineSeriesView.h File Reference

  • Source
  • Chart
  • Styles
  • Line
XTPChartLineSeriesView.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartScatterLineSeriesStyle.h File Reference

  • Source
  • Chart
  • Styles
  • Line
Classes
XTPChartScatterLineSeriesStyle.h File Reference

Go to the source code of this file.

Classes

class CXTPChartScatterLineSeriesStyle
This class represents a line series style, which is a kind of CXTPChartPointSeriesStyle. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartSplineSeriesStyle.h File Reference

  • Source
  • Chart
  • Styles
  • Line
Classes
XTPChartSplineSeriesStyle.h File Reference

Go to the source code of this file.

Classes

class | CXTPChartSplineSeriesStyle
This class represents the spline series style in the chart. More...
class | CXTPChartSplineSeriesView
This class represents the view of a spline series, which is a kind of CXTPChartSeriesView. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartStepLineSeriesStyle.h File Reference

  • Source
  • Chart
  • Styles
  • Line
Classes
XTPChartStepLineSeriesStyle.h File Reference

Go to the source code of this file.

Classes

class | CXTPChartStepLineSeriesStyle
This class represents a StepLine series style, which is a kind of CXTPChartLineSeriesStyle. More...
class | CXTPChartStepLineSeriesView
This class represents the view of a StepLine series, which is a kind of CXTPChartSeriesView. More...
class | CXTPChartStepLineSeriesPointView
This class represents the view of a step line series point, which is a kind of CXTPChartSeriesPointView. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: Pie Directory Reference

  • Source
  • Chart
  • Styles
  • Pie
Pie Directory Reference

Directories

2D
3D
Base

Files

XTPChartPieDiagram.h
XTPChartPieDiagramView.h
XTPChartPieSeriesLabel.h
XTPChartPieSeriesPointView.h
XTPChartPieSeriesStyle.h
XTPChartPieSeriesView.h


Toolkit Pro: 2D Directory Reference

  • Source
  • Chart
  • Styles
  • Pie
  • 2D
2D Directory Reference

Files

XTPChart2dPieDiagram.h
XTPChart2dPieDiagramView.h
XTPChart2dPieSeriesLabel.h
XTPChart2dPieSeriesPointView.h
XTPChart2dPieSeriesStyle.h
XTPChart2dPieSeriesView.h


Toolkit Pro: XTPChart2dPieDiagram.h File Reference

  • Source
  • Chart
  • Styles
  • Pie
  • 2D
Classes
XTPChart2dPieDiagram.h File Reference

Go to the source code of this file.

Classes

class CXTPChartPieDiagram
This class abstracts the pie diagram. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChart2dPieDiagramView.h File Reference

  • Source
  • Chart
  • Styles
  • Pie
  • 2D
Classes
XTPChart2dPieDiagramView.h File Reference

Go to the source code of this file.

Classes

class CXTPChartPieDiagramView
This class abstracts the view of a pie diagram. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChart2dPieSeriesLabel.h File Reference

  • Source
  • Chart
  • Styles
  • Pie
  • 2D
Classes
XTPChart2dPieSeriesLabel.h File Reference

Go to the source code of this file.

Classes

class | CXTPChartPieSeriesLabel
CXTPChartPieSeriesLabelBase is a kind of CXTPChartPieSeriesLabel. More...
class | CXTPChartPieSeriesLabelView
Defines 2D series label view. More...
class | CXTPChartPieSeriesLabelsView
Defines 2D series label collection view. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChart2dPieSeriesPointView.h File Reference

  • Source
  • Chart
  • Styles
  • Pie
  • 2D
Classes
XTPChart2dPieSeriesPointView.h File Reference

Go to the source code of this file.

Classes

class CXTPChartPieSeriesPointView
This class abstracts the view of a pie series point. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChart2dPieSeriesStyle.h File Reference

  • Source
  • Chart
  • Styles
  • Pie
  • 2D
Classes
XTPChart2dPieSeriesStyle.h File Reference

Go to the source code of this file.

Classes

class CXTPChartPieSeriesStyle
This class abstracts the pie series style. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChart2dPieSeriesView.h File Reference

  • Source
  • Chart
  • Styles
  • Pie
  • 2D
Classes
XTPChart2dPieSeriesView.h File Reference

Go to the source code of this file.

Classes

class CXTPChartPieSeriesView
This class abstracts the view of a pie series. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: 3D Directory Reference

  • Source
  • Chart
  • Styles
  • Pie
  • 3D
3D Directory Reference

Directories

Commands

Files

XTPChart3dPieDiagram.h
XTPChart3dPieDiagramView.h
XTPChart3dPieSeriesLabel.h
XTPChart3dPieSeriesPointView.h
XTPChart3dPieSeriesStyle.h
XTPChart3dPieSeriesView.h


Toolkit Pro: Commands Directory Reference

  • Source
  • Chart
  • Styles
  • Pie
  • 3D
  • Commands
Commands Directory Reference

Directories

OpenGL

Files

XTPChart3dPieDeviceCommandEvents.h
XTPChart3dPieSeriesLabelsViewDeviceCommand.h


Toolkit Pro: OpenGL Directory Reference

  • Source
  • Chart
  • Styles
  • Pie
  • 3D
  • Commands
  • OpenGL
OpenGL Directory Reference

Files

XTPChartOpenGLPieDeviceCommand.h


Toolkit Pro: XTPChartOpenGLPieDeviceCommand.h File Reference

  • Source
  • Chart
  • Styles
  • Pie
  • 3D
  • Commands
  • OpenGL
XTPChartOpenGLPieDeviceCommand.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChart3dPieDeviceCommandEvents.h File Reference

  • Source
  • Chart
  • Styles
  • Pie
  • 3D
  • Commands
Classes
XTPChart3dPieDeviceCommandEvents.h File Reference

Go to the source code of this file.

Classes

class CXTPChart3dPieDeviceCommandEvents
Defines interface for 3D chart pie device command event sink. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChart3dPieSeriesLabelsViewDeviceCommand.h File Reference

  • Source
  • Chart
  • Styles
  • Pie
  • 3D
  • Commands
Classes
XTPChart3dPieSeriesLabelsViewDeviceCommand.h File Reference

Go to the source code of this file.

Classes

class | CXTPChart3dPieSeriesLabelDeviceCommand
Implements 3D chart pie series label device command. More...
class | CXTPChart3dPieSeriesLabelsViewDeviceCommand
Represents device command for all pie series labels view. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChart3dPieDiagram.h File Reference

  • Source
  • Chart
  • Styles
  • Pie
  • 3D
Classes
XTPChart3dPieDiagram.h File Reference

Go to the source code of this file.

Classes

class CXTPChart3dPieDiagram
This class abstracts the pie diagram. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChart3dPieDiagramView.h File Reference

  • Source
  • Chart
  • Styles
  • Pie
  • 3D
Classes
XTPChart3dPieDiagramView.h File Reference

Go to the source code of this file.

Classes

class CXTPChart3dPieDiagramView
This class abstracts the view of a pie diagram. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChart3dPieSeriesLabel.h File Reference

  • Source
  • Chart
  • Styles
  • Pie
  • 3D
Classes
XTPChart3dPieSeriesLabel.h File Reference

Go to the source code of this file.

Classes

class | CXTPChart3dPieSeriesLabel
CXTPChartPieSeriesLabelBase is a kind of CXTPChart3dPieSeriesLabel. More...
class | CXTPChart3dPieSeriesLabelView
Represents a series label view object. More...
class | CXTPChart3dPieSeriesLabelsView
Represents a view object for all pie series labels. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChart3dPieSeriesPointView.h File Reference

  • Source
  • Chart
  • Styles
  • Pie
  • 3D
Classes
XTPChart3dPieSeriesPointView.h File Reference

Go to the source code of this file.

Classes

class CXTPChart3dPieSeriesPointView
This class abstracts the view of a pie series point. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChart3dPieSeriesStyle.h File Reference

  • Source
  • Chart
  • Styles
  • Pie
  • 3D
Classes
XTPChart3dPieSeriesStyle.h File Reference

Go to the source code of this file.

Classes

class CXTPChart3dPieSeriesStyle
This class abstracts the pie series style. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChart3dPieSeriesView.h File Reference

  • Source
  • Chart
  • Styles
  • Pie
  • 3D
Classes
XTPChart3dPieSeriesView.h File Reference

Go to the source code of this file.

Classes

class CXTPChart3dPieSeriesView
This class abstracts the view of a pie series. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: Base Directory Reference

  • Source
  • Chart
  • Styles
  • Pie
  • Base
Base Directory Reference

Files

XTPChartPieDiagramBase.h
XTPChartPieSeriesLabelBase.h
XTPChartPieSeriesPointViewBase.h
XTPChartPieSeriesStyleBase.h
XTPChartPieSeriesViewBase.h


Toolkit Pro: XTPChartPieDiagramBase.h File Reference

  • Source
  • Chart
  • Styles
  • Pie
  • Base
Classes
XTPChartPieDiagramBase.h File Reference

Go to the source code of this file.

Classes

class CXTPChartPieDiagramBase< BaseDiagram >
This class abstracts the pie diagram. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartPieSeriesLabelBase.h File Reference

  • Source
  • Chart
  • Styles
  • Pie
  • Base
Classes | Enumerations
XTPChartPieSeriesLabelBase.h File Reference

Go to the source code of this file.

Classes

class | CXTPChartPieSeriesLabelBase
CXTPChartPieSeriesLabelBase is a kind of CXTPChartSeriesLabel. More...
class | CXTPChartPieSeriesLabelViewBase
Defines a base class interface for series label view. More...
class | CXTPChartPieSeriesLabelsViewBase
Defines a base class interface for series label collection view. More...

Enumerations

enum XTPChartPieLabelPosition { xtpChartPieLabelOutside , xtpChartPieLabelInside , xtpChartPieLabelRadial , xtpChartPieLabelTwoColumns }
This enumeration tells the various positions available for the pie label. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Enumeration Type Documentation

◆ XTPChartPieLabelPosition

enum XTPChartPieLabelPosition

This enumeration tells the various positions available for the pie label.

Enumerator
xtpChartPieLabelOutside | Outside the pie.
xtpChartPieLabelInside | Inside the pie.
xtpChartPieLabelRadial | Radial label.
xtpChartPieLabelTwoColumns | 2 Columns


Toolkit Pro: XTPChartPieSeriesPointViewBase.h File Reference

  • Source
  • Chart
  • Styles
  • Pie
  • Base
Classes
XTPChartPieSeriesPointViewBase.h File Reference

Go to the source code of this file.

Classes

class CXTPChartPieSeriesPointViewBase
This class abstracts the view of a pie series point. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartPieSeriesStyleBase.h File Reference

  • Source
  • Chart
  • Styles
  • Pie
  • Base
Classes
XTPChartPieSeriesStyleBase.h File Reference

Go to the source code of this file.

Classes

class CXTPChartPieSeriesStyleBase
This class abstracts the basic style of a pie serie.This class is a kind of CXTPChartSeriesStyle. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartPieSeriesViewBase.h File Reference

  • Source
  • Chart
  • Styles
  • Pie
  • Base
Classes
XTPChartPieSeriesViewBase.h File Reference

Go to the source code of this file.

Classes

class CXTPChartPieSeriesViewBase
This class abstracts the view of a pie series. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartPieDiagram.h File Reference

  • Source
  • Chart
  • Styles
  • Pie
XTPChartPieDiagram.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartPieDiagramView.h File Reference

  • Source
  • Chart
  • Styles
  • Pie
XTPChartPieDiagramView.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartPieSeriesLabel.h File Reference

  • Source
  • Chart
  • Styles
  • Pie
XTPChartPieSeriesLabel.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartPieSeriesPointView.h File Reference

  • Source
  • Chart
  • Styles
  • Pie
XTPChartPieSeriesPointView.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartPieSeriesStyle.h File Reference

  • Source
  • Chart
  • Styles
  • Pie
XTPChartPieSeriesStyle.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartPieSeriesView.h File Reference

  • Source
  • Chart
  • Styles
  • Pie
XTPChartPieSeriesView.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: Point Directory Reference

  • Source
  • Chart
  • Styles
  • Point
Point Directory Reference

Files

XTPChartBubbleSeriesLabel.h
XTPChartBubbleSeriesStyle.h
XTPChartMarker.h
XTPChartPointSeriesErrorBar.h
XTPChartPointSeriesLabel.h
XTPChartPointSeriesLabelView.h
XTPChartPointSeriesStyle.h
XTPChartPointSeriesView.h


Toolkit Pro: XTPChartBubbleSeriesLabel.h File Reference

  • Source
  • Chart
  • Styles
  • Point
Classes
XTPChartBubbleSeriesLabel.h File Reference

Go to the source code of this file.

Classes

class | CXTPChartBubbleSeriesLabel
CXTPChartBubbleSeriesLabel is a kind of CXTPChartSeriesLabel. More...
class | CXTPChartBubbleSeriesLabelView
CXTPChartBubbleSeriesLabelView is a kind of CXTPChartSeriesLabelView. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartBubbleSeriesStyle.h File Reference

  • Source
  • Chart
  • Styles
  • Point
Classes
XTPChartBubbleSeriesStyle.h File Reference

Go to the source code of this file.

Classes

class | CXTPChartBubbleSeriesStyle
This class represents a bubble series style, which is a kind of CXTPChartPointSeriesStyle. More...
class | CXTPChartBubbleSeriesView
This class represents the view of a bubble series, which is a kind of CXTPChartSeriesView. More...
class | CXTPChartBubbleSeriesPointView
This class represents the view of a bubble series point, which is a kind of CXTPChartPointSeriesPointView. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartMarker.h File Reference

  • Source
  • Chart
  • Styles
  • Point
Classes | Enumerations
XTPChartMarker.h File Reference

Go to the source code of this file.

Classes

class CXTPChartMarker
This class abstracts a marker used in marking the points in a point series style chart. More...

Enumerations

enum XTPChartMarkerType {
xtpChartMarkerCircle , xtpChartMarkerSquare , xtpChartMarkerDiamond , xtpChartMarkerTriangle ,
xtpChartMarkerPentagon , xtpChartMarkerHexagon , xtpChartMarkerStar
}
This enumeration is used for naming the various styles for the point series point marking. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Enumeration Type Documentation

◆ XTPChartMarkerType

enum XTPChartMarkerType

This enumeration is used for naming the various styles for the point series point marking.

Enumerator
xtpChartMarkerCircle | The circular style.
xtpChartMarkerSquare | Specifies square marker shape.
xtpChartMarkerDiamond | Specifies diamond marker shape.
xtpChartMarkerTriangle | Specifies triangle marker shape.
xtpChartMarkerPentagon | Specifies pentagon marker shape.
xtpChartMarkerHexagon | Specifies hexagon marker shape.
xtpChartMarkerStar | Specifies star marker shape.


Toolkit Pro: XTPChartPointSeriesErrorBar.h File Reference

  • Source
  • Chart
  • Styles
  • Point
Classes
XTPChartPointSeriesErrorBar.h File Reference

Go to the source code of this file.

Classes

class CXTPChartPointSeriesErrorBarView
This class abstracts the view of the label of a bar series. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartPointSeriesLabel.h File Reference

  • Source
  • Chart
  • Styles
  • Point
Classes
XTPChartPointSeriesLabel.h File Reference

Go to the source code of this file.

Classes

class CXTPChartPointSeriesLabel
This class abstracts the label of a point series. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartPointSeriesLabelView.h File Reference

  • Source
  • Chart
  • Styles
  • Point
Classes
XTPChartPointSeriesLabelView.h File Reference

Go to the source code of this file.

Classes

class CXTPChartPointSeriesLabelView
This class abstracts the view of the label of a point series. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartPointSeriesStyle.h File Reference

  • Source
  • Chart
  • Styles
  • Point
Classes
XTPChartPointSeriesStyle.h File Reference

Go to the source code of this file.

Classes

class CXTPChartPointSeriesStyle
This class represents a line series style, which is a kind of CXTPChartSeriesStyle. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartPointSeriesView.h File Reference

  • Source
  • Chart
  • Styles
  • Point
Classes
XTPChartPointSeriesView.h File Reference

Go to the source code of this file.

Classes

class | CXTPChartPointSeriesView
This class represents the view of a point series, which is a kind of CXTPChartSeriesView. More...
class | CXTPChartPointSeriesPointView
This class represents the view of a point series point, which is a kind of CXTPChartSeriesPointView. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: Pyramid Directory Reference

  • Source
  • Chart
  • Styles
  • Pyramid
Pyramid Directory Reference

Directories

2D
3D
Base

Files

XTPChartPyramidDiagram.h
XTPChartPyramidDiagramView.h
XTPChartPyramidSeriesLabel.h
XTPChartPyramidSeriesPointView.h
XTPChartPyramidSeriesStyle.h
XTPChartPyramidSeriesView.h


Toolkit Pro: 2D Directory Reference

  • Source
  • Chart
  • Styles
  • Pyramid
  • 2D
2D Directory Reference

Files

XTPChart2dPyramidDiagram.h
XTPChart2dPyramidDiagramView.h
XTPChart2dPyramidSeriesLabel.h
XTPChart2dPyramidSeriesPointView.h
XTPChart2dPyramidSeriesStyle.h
XTPChart2dPyramidSeriesView.h


Toolkit Pro: XTPChart2dPyramidDiagram.h File Reference

  • Source
  • Chart
  • Styles
  • Pyramid
  • 2D
Classes
XTPChart2dPyramidDiagram.h File Reference

Go to the source code of this file.

Classes

class CXTPChartPyramidDiagram
This class abstracts the pyramid diagram. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChart2dPyramidDiagramView.h File Reference

  • Source
  • Chart
  • Styles
  • Pyramid
  • 2D
Classes
XTPChart2dPyramidDiagramView.h File Reference

Go to the source code of this file.

Classes

class CXTPChartPyramidDiagramView
This class abstracts the view of a pyramid diagram. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChart2dPyramidSeriesLabel.h File Reference

  • Source
  • Chart
  • Styles
  • Pyramid
  • 2D
Classes
XTPChart2dPyramidSeriesLabel.h File Reference

Go to the source code of this file.

Classes

class | CXTPChartPyramidSeriesLabel
CXTPChartPyramidSeriesLabel is a kind of CXTPChartSeriesLabel. More...
class | CXTPChartPyramidSeriesLabelView
Defines 2D series label view. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChart2dPyramidSeriesPointView.h File Reference

  • Source
  • Chart
  • Styles
  • Pyramid
  • 2D
Classes
XTPChart2dPyramidSeriesPointView.h File Reference

Go to the source code of this file.

Classes

class CXTPChartPyramidSeriesPointView
This class abstracts the view of a pyramid series point. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChart2dPyramidSeriesStyle.h File Reference

  • Source
  • Chart
  • Styles
  • Pyramid
  • 2D
Classes
XTPChart2dPyramidSeriesStyle.h File Reference

Go to the source code of this file.

Classes

class CXTPChartPyramidSeriesStyle
This class abstracts the basic style of a pyramid series. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChart2dPyramidSeriesView.h File Reference

  • Source
  • Chart
  • Styles
  • Pyramid
  • 2D
Classes
XTPChart2dPyramidSeriesView.h File Reference

Go to the source code of this file.

Classes

class CXTPChartPyramidSeriesView
This class abstracts the view of a pyramid series. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: 3D Directory Reference

  • Source
  • Chart
  • Styles
  • Pyramid
  • 3D
3D Directory Reference

Directories

Commands

Files

XTPChart3dPyramidDiagram.h
XTPChart3dPyramidDiagramView.h
XTPChart3dPyramidSeriesLabel.h
XTPChart3dPyramidSeriesPointView.h
XTPChart3dPyramidSeriesStyle.h
XTPChart3dPyramidSeriesView.h


Toolkit Pro: Commands Directory Reference

  • Source
  • Chart
  • Styles
  • Pyramid
  • 3D
  • Commands
Commands Directory Reference

Directories

OpenGL

Files

XTPChart3dPyramidDeviceCommandEvents.h
XTPChart3dPyramidSeriesLabelsViewDeviceCommand.h


Toolkit Pro: OpenGL Directory Reference

  • Source
  • Chart
  • Styles
  • Pyramid
  • 3D
  • Commands
  • OpenGL
OpenGL Directory Reference

Files

XTPChartOpenGLPyramidDeviceCommand.h


Toolkit Pro: XTPChartOpenGLPyramidDeviceCommand.h File Reference

  • Source
  • Chart
  • Styles
  • Pyramid
  • 3D
  • Commands
  • OpenGL
XTPChartOpenGLPyramidDeviceCommand.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChart3dPyramidDeviceCommandEvents.h File Reference

  • Source
  • Chart
  • Styles
  • Pyramid
  • 3D
  • Commands
Classes
XTPChart3dPyramidDeviceCommandEvents.h File Reference

Go to the source code of this file.

Classes

class CXTPChart3dPyramidDeviceCommandEvents
Defines interface for 3D chart pyramid device command event sink. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChart3dPyramidSeriesLabelsViewDeviceCommand.h File Reference

  • Source
  • Chart
  • Styles
  • Pyramid
  • 3D
  • Commands
Classes
XTPChart3dPyramidSeriesLabelsViewDeviceCommand.h File Reference

Go to the source code of this file.

Classes

class | CXTPChart3dPyramidSeriesLabelDeviceCommand
Implements 3D chart pyramid series label device command. More...
class | CXTPChart3dPyramidSeriesLabelsViewDeviceCommand
Represents device command for all pyramid series labels view. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChart3dPyramidDiagram.h File Reference

  • Source
  • Chart
  • Styles
  • Pyramid
  • 3D
Classes
XTPChart3dPyramidDiagram.h File Reference

Go to the source code of this file.

Classes

class CXTPChart3dPyramidDiagram
This class abstracts the pyramid diagram. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChart3dPyramidDiagramView.h File Reference

  • Source
  • Chart
  • Styles
  • Pyramid
  • 3D
Classes
XTPChart3dPyramidDiagramView.h File Reference

Go to the source code of this file.

Classes

class CXTPChart3dPyramidDiagramView
This class abstracts the view of a pyramid diagram. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChart3dPyramidSeriesLabel.h File Reference

  • Source
  • Chart
  • Styles
  • Pyramid
  • 3D
Classes
XTPChart3dPyramidSeriesLabel.h File Reference

Go to the source code of this file.

Classes

class | CXTPChart3dPyramidSeriesLabel
CXTPChartPyramidSeriesLabelBase is a kind of CXTPChart3dPyramidSeriesLabel. More...
class | CXTPChart3dPyramidSeriesLabelView
Represents series label view object. More...
class | CXTPChart3dPyramidSeriesLabelsView
Represents a view object for all pyramid series labels. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChart3dPyramidSeriesPointView.h File Reference

  • Source
  • Chart
  • Styles
  • Pyramid
  • 3D
Classes
XTPChart3dPyramidSeriesPointView.h File Reference

Go to the source code of this file.

Classes

class CXTPChart3dPyramidSeriesPointView
This class abstracts the view of a pyramid series point. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChart3dPyramidSeriesStyle.h File Reference

  • Source
  • Chart
  • Styles
  • Pyramid
  • 3D
Classes
XTPChart3dPyramidSeriesStyle.h File Reference

Go to the source code of this file.

Classes

class CXTPChart3dPyramidSeriesStyle
This class abstracts the basic style of a pyramid series. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChart3dPyramidSeriesView.h File Reference

  • Source
  • Chart
  • Styles
  • Pyramid
  • 3D
Classes
XTPChart3dPyramidSeriesView.h File Reference

Go to the source code of this file.

Classes

class CXTPChart3dPyramidSeriesView
This class abstracts the view of a pyramid series. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: Base Directory Reference

  • Source
  • Chart
  • Styles
  • Pyramid
  • Base
Base Directory Reference

Files

XTPChartPyramidDiagramBase.h
XTPChartPyramidSeriesLabelBase.h
XTPChartPyramidSeriesPointViewBase.h
XTPChartPyramidSeriesStyleBase.h
XTPChartPyramidSeriesViewBase.h


Toolkit Pro: XTPChartPyramidDiagramBase.h File Reference

  • Source
  • Chart
  • Styles
  • Pyramid
  • Base
Classes
XTPChartPyramidDiagramBase.h File Reference

Go to the source code of this file.

Classes

class CXTPChartPyramidDiagramBase< BaseDiagram >
This class abstracts the pyramid diagram. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartPyramidSeriesLabelBase.h File Reference

  • Source
  • Chart
  • Styles
  • Pyramid
  • Base
Classes | Enumerations
XTPChartPyramidSeriesLabelBase.h File Reference

Go to the source code of this file.

Classes

class | CXTPChartPyramidSeriesLabelBase
This class abstracts the pyramid series label. More...
class | CXTPChartPyramidSeriesLabelViewBase
This class abstracts the view of a pyramid series label. More...

Enumerations

enum XTPChartPyramidLabelPosition { xtpChartPyramidLabelLeft , xtpChartPyramidLabelRight , xtpChartPyramidLabelCenter }
This enumeration tells the various positions available for the pyramid label. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Enumeration Type Documentation

◆ XTPChartPyramidLabelPosition

enum XTPChartPyramidLabelPosition

This enumeration tells the various positions available for the pyramid label.

Enumerator
xtpChartPyramidLabelLeft | Place label on the left side of a pyramid point.
xtpChartPyramidLabelRight | Place label on the right side of a pyramid point.
xtpChartPyramidLabelCenter | Place label in the center of a pyramid point.


Toolkit Pro: XTPChartPyramidSeriesPointViewBase.h File Reference

  • Source
  • Chart
  • Styles
  • Pyramid
  • Base
Classes
XTPChartPyramidSeriesPointViewBase.h File Reference

Go to the source code of this file.

Classes

class CXTPChartPyramidSeriesPointViewBase
This class abstracts the view of a pyramid series point. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartPyramidSeriesStyleBase.h File Reference

  • Source
  • Chart
  • Styles
  • Pyramid
  • Base
Classes
XTPChartPyramidSeriesStyleBase.h File Reference

Go to the source code of this file.

Classes

class CXTPChartPyramidSeriesStyleBase
This class abstracts the basic style of a pyramid series. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartPyramidSeriesViewBase.h File Reference

  • Source
  • Chart
  • Styles
  • Pyramid
  • Base
Classes
XTPChartPyramidSeriesViewBase.h File Reference

Go to the source code of this file.

Classes

class CXTPChartPyramidSeriesViewBase
This class abstracts the view of a pyramid series. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartPyramidDiagram.h File Reference

  • Source
  • Chart
  • Styles
  • Pyramid
Typedefs
XTPChartPyramidDiagram.h File Reference

Go to the source code of this file.

Typedefs

typedef CXTPChartPyramidDiagram CXTPChart2dPyramidDiagram
CXTPChart2dPyramidDiagram alias is necessary for naming consistency.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartPyramidDiagramView.h File Reference

  • Source
  • Chart
  • Styles
  • Pyramid
Typedefs
XTPChartPyramidDiagramView.h File Reference

Go to the source code of this file.

Typedefs

typedef CXTPChartPyramidDiagramView CXTPChart2dPyramidDiagramView
CXTPChart2dPyramidDiagramView alias is necessary for naming consistency.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartPyramidSeriesLabel.h File Reference

  • Source
  • Chart
  • Styles
  • Pyramid
Typedefs
XTPChartPyramidSeriesLabel.h File Reference

Go to the source code of this file.

Typedefs

typedef CXTPChartPyramidSeriesLabel | CXTPChart2dPyramidSeriesLabel
CXTPChart2dPyramidSeriesLabel alias is necessary for naming consistency.
typedef CXTPChartPyramidSeriesLabelView | CXTPChart2dPyramidSeriesLabelView
CXTPChart2dPyramidSeriesLabelView alias is necessary for naming consistency.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartPyramidSeriesPointView.h File Reference

  • Source
  • Chart
  • Styles
  • Pyramid
Typedefs
XTPChartPyramidSeriesPointView.h File Reference

Go to the source code of this file.

Typedefs

typedef CXTPChartPyramidSeriesPointView CXTPChart2dPyramidSeriesPointView
CXTPChart2dPyramidSeriesPointView alias is necessary for naming consistency.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartPyramidSeriesStyle.h File Reference

  • Source
  • Chart
  • Styles
  • Pyramid
Typedefs
XTPChartPyramidSeriesStyle.h File Reference

Go to the source code of this file.

Typedefs

typedef CXTPChartPyramidSeriesStyle CXTPChart2dPyramidSeriesStyle
CXTPChart2dPyramidSeriesStyle alias is necessary for naming consistency.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartPyramidSeriesView.h File Reference

  • Source
  • Chart
  • Styles
  • Pyramid
Typedefs
XTPChartPyramidSeriesView.h File Reference

Go to the source code of this file.

Typedefs

typedef CXTPChartPyramidSeriesView CXTPChart2dPyramidSeriesView
CXTPChart2dPyramidSeriesView alias is necessary for naming consistency.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: Radar Directory Reference

  • Source
  • Chart
  • Styles
  • Radar
Radar Directory Reference

Files

XTPChartRadarAreaSeriesStyle.h
XTPChartRadarAreaSeriesView.h
XTPChartRadarLineSeriesStyle.h
XTPChartRadarLineSeriesView.h
XTPChartRadarPointSeriesLabel.h
XTPChartRadarPointSeriesStyle.h
XTPChartRadarPointSeriesView.h
XTPChartRadarSplineAreaSeriesStyle.h
XTPChartRadarSplineSeriesStyle.h


Toolkit Pro: XTPChartRadarAreaSeriesStyle.h File Reference

  • Source
  • Chart
  • Styles
  • Radar
Classes
XTPChartRadarAreaSeriesStyle.h File Reference

Go to the source code of this file.

Classes

class CXTPChartRadarAreaSeriesStyle
This class represents a line series style, which is a kind of CXTPChartSeriesStyle. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartRadarAreaSeriesView.h File Reference

  • Source
  • Chart
  • Styles
  • Radar
Classes
XTPChartRadarAreaSeriesView.h File Reference

Go to the source code of this file.

Classes

class CXTPChartRadarAreaSeriesView
This class represents the view of a point series, which is a kind of CXTPChartSeriesView. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartRadarLineSeriesStyle.h File Reference

  • Source
  • Chart
  • Styles
  • Radar
Classes
XTPChartRadarLineSeriesStyle.h File Reference

Go to the source code of this file.

Classes

class CXTPChartRadarLineSeriesStyle
This class represents a line series style, which is a kind of CXTPChartSeriesStyle. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartRadarLineSeriesView.h File Reference

  • Source
  • Chart
  • Styles
  • Radar
Classes
XTPChartRadarLineSeriesView.h File Reference

Go to the source code of this file.

Classes

class CXTPChartRadarLineSeriesView
This class represents the view of a point series, which is a kind of CXTPChartSeriesView. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartRadarPointSeriesLabel.h File Reference

  • Source
  • Chart
  • Styles
  • Radar
Classes
XTPChartRadarPointSeriesLabel.h File Reference

Go to the source code of this file.

Classes

class | CXTPChartRadarPointSeriesLabel
This class abstracts the label of a point series. More...
class | CXTPChartRadarPointSeriesLabelView
This class abstracts the view of the label of a point series, it is a kind of chart series label view. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartRadarPointSeriesStyle.h File Reference

  • Source
  • Chart
  • Styles
  • Radar
Classes
XTPChartRadarPointSeriesStyle.h File Reference

Go to the source code of this file.

Classes

class CXTPChartRadarPointSeriesStyle
This class represents a line series style, which is a kind of CXTPChartSeriesStyle. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartRadarPointSeriesView.h File Reference

  • Source
  • Chart
  • Styles
  • Radar
Classes
XTPChartRadarPointSeriesView.h File Reference

Go to the source code of this file.

Classes

class | CXTPChartRadarPointSeriesView
This class represents the view of a point series, which is a kind of CXTPChartSeriesView. More...
class | CXTPChartRadarPointSeriesPointView
This class represents the view of a point series point, which is a kind of CXTPChartSeriesPointView. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartRadarSplineAreaSeriesStyle.h File Reference

  • Source
  • Chart
  • Styles
  • Radar
Classes
XTPChartRadarSplineAreaSeriesStyle.h File Reference

Go to the source code of this file.

Classes

class | CXTPChartRadarSplineAreaSeriesStyle
This class represents a spline area series style, which is a kind of CXTPChartRadarAreaSeriesStyle. More...
class | CXTPChartRadarSplineAreaSeriesView
CXTPChartRadarSplineAreaSeriesView is a kind of CXTPChartSeriesView. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartRadarSplineSeriesStyle.h File Reference

  • Source
  • Chart
  • Styles
  • Radar
Classes
XTPChartRadarSplineSeriesStyle.h File Reference

Go to the source code of this file.

Classes

class | CXTPChartRadarSplineSeriesStyle
This class represents the spline series style in the chart. More...
class | CXTPChartRadarSplineSeriesView
This class represents the view of a spline series, which is a kind of CXTPChartSeriesView. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: Range Directory Reference

  • Source
  • Chart
  • Styles
  • Range
Range Directory Reference

Files

XTPChartGanttSeriesStyle.h
XTPChartRangeBarSeriesLabel.h
XTPChartRangeBarSeriesStyle.h
XTPChartRangeBarSeriesView.h


Toolkit Pro: XTPChartGanttSeriesStyle.h File Reference

  • Source
  • Chart
  • Styles
  • Range
Classes
XTPChartGanttSeriesStyle.h File Reference

Go to the source code of this file.

Classes

class | CXTPChartGanttSeriesStyle
This class represents a Gantt series style for the chart, which is a kind of CXTPChartBarSeriesStyle. More...
class | CXTPChartGanttSeriesView
This class represents the view of a Gantt series, which is a kind of CXTPChartSeriesView. More...
class | CXTPChartGanttSeriesPointView
This class represents the view of a Gantt series point, which is a kind of CXTPChartPointSeriesPointView. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartRangeBarSeriesLabel.h File Reference

  • Source
  • Chart
  • Styles
  • Range
Classes | Enumerations
XTPChartRangeBarSeriesLabel.h File Reference

Go to the source code of this file.

Classes

class | CXTPChartRangeBarSeriesLabel
This class abstracts the label of a bar series. More...
class | CXTPChartRangeBarSeriesLabelView
This class abstracts the view of the label of a bar series. More...

Enumerations

enum | XTPChartRangeBarLabelPosition { xtpChartRangeBarLabelOutside , xtpChartRangeBarLabelInside }
Specifies range bar chart label position. More...
enum | XTPChartRangeBarLabelType { xtpChartRangeBarOneLabel , xtpChartRangeBarTwoLabels , xtpChartRangeBarMinValueLabel , xtpChartRangeBarMaxValueLabel }
Specifies range bar chart label type. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Enumeration Type Documentation

◆ XTPChartRangeBarLabelPosition

enum XTPChartRangeBarLabelPosition

Specifies range bar chart label position.

Enumerator
xtpChartRangeBarLabelOutside | A label is located outside a range bar.
xtpChartRangeBarLabelInside | A label is located inside a range bar.

◆ XTPChartRangeBarLabelType

enum XTPChartRangeBarLabelType

Specifies range bar chart label type.

Enumerator
xtpChartRangeBarOneLabel | Defines a label that contains both range values.
xtpChartRangeBarTwoLabels | Defines a two labels for each range value.
xtpChartRangeBarMinValueLabel | Defines a label with a minimum range value.
xtpChartRangeBarMaxValueLabel | Defines a label with a maximum range value.


Toolkit Pro: XTPChartRangeBarSeriesStyle.h File Reference

  • Source
  • Chart
  • Styles
  • Range
Classes
XTPChartRangeBarSeriesStyle.h File Reference

Go to the source code of this file.

Classes

class CXTPChartRangeBarSeriesStyle
This class represents a RangeBar series style for the chart, which is a kind of CXTPChartBarSeriesStyle. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartRangeBarSeriesView.h File Reference

  • Source
  • Chart
  • Styles
  • Range
Classes
XTPChartRangeBarSeriesView.h File Reference

Go to the source code of this file.

Classes

class | CXTPChartRangeBarSeriesView
This class represents the view of a RangeBar series, which is a kind of CXTPChartSeriesView. More...
class | CXTPChartRangeBarSeriesPointView
This class represents the view of a RangeBar series point, which is a kind of CXTPChartPointSeriesPointView. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: Types Directory Reference

  • Source
  • Chart
  • Types
Types Directory Reference

Directories

2D
3D

Files

XTPChartPie.h
XTPChartTypes.h


Toolkit Pro: 2D Directory Reference

  • Source
  • Chart
  • Types
  • 2D
2D Directory Reference

Files

XTPChart2dPie.h


Toolkit Pro: XTPChart2dPie.h File Reference

  • Source
  • Chart
  • Types
  • 2D
Classes
XTPChart2dPie.h File Reference

Go to the source code of this file.

Classes

class CXTPChartPie
This class abstracts a pie chart. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: 3D Directory Reference

  • Source
  • Chart
  • Types
  • 3D
3D Directory Reference

Files

XTPChart3dPie.h


Toolkit Pro: XTPChart3dPie.h File Reference

  • Source
  • Chart
  • Types
  • 3D
Classes
XTPChart3dPie.h File Reference

Go to the source code of this file.

Classes

class CXTPChart3dPie
This class abstracts a pie chart. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartPie.h File Reference

  • Source
  • Chart
  • Types
Classes
XTPChartPie.h File Reference

Go to the source code of this file.

Classes

class | CXTPChartEllipse
This class abstracts an ellipse. More...
class | CXTPChartPieBase
This class abstracts a pie chart. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartTypes.h File Reference

  • Source
  • Chart
  • Types
Classes
XTPChartTypes.h File Reference

Go to the source code of this file.

Classes

class | CXTPChartColor
This class abstracts a color entity. More...
class | CXTPChartFont
This class abstracts a font entity. More...
class | CXTPChart3dRotation
Represents a 3D rotation primitive for chart objects using Euler angles Yaw, Pitch and Roll in degrees. More...
class | CXTPChart3dBox
Represents a 3D box build around included points and provides useful and fast operations. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: Utils Directory Reference

  • Source
  • Chart
  • Utils
Utils Directory Reference

Files

XTPChartNumberFormat.h
XTPChartTextPainter.h


Toolkit Pro: XTPChartNumberFormat.h File Reference

  • Source
  • Chart
  • Utils
Classes | Enumerations
XTPChartNumberFormat.h File Reference

Go to the source code of this file.

Classes

class CXTPChartNumberFormat
This class helper is used to format number to string. More...

Enumerations

enum XTPChartNumberFormatCategory {
xtpChartGeneral , xtpChartNumber , xtpChartCurrency , xtpChartPercentage ,
xtpChartScientific
}
Format category used by CXTPChartNumberFormat. More...
enum XTPChartDateTimeFormatCategory {
xtpChartDateTimeGeneral , xtpChartDateTimeLongDate , xtpChartDateTimeShortDate , xtpChartDateTimeLongTime ,
xtpChartDateTimeShortTime , xtpChartDateTimeMonthAndDay , xtpChartDateTimeMonthAndYear , xtpChartDateTimeCustom
}
DateTime Format category used by CXTPChartNumberFormat. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Enumeration Type Documentation

◆ XTPChartDateTimeFormatCategory

enum XTPChartDateTimeFormatCategory

DateTime Format category used by CXTPChartNumberFormat.

Enumerator
xtpChartDateTimeGeneral | Specifies general date time format.
xtpChartDateTimeLongDate | Specifies long date format.
xtpChartDateTimeShortDate | Specifies short date format.
xtpChartDateTimeLongTime | Specifies long time format.
xtpChartDateTimeShortTime | Specifies short time format.
xtpChartDateTimeMonthAndDay | Specifies month and day format.
xtpChartDateTimeMonthAndYear | Specifies month and year format.
xtpChartDateTimeCustom | Specifies custom date time format.

◆ XTPChartNumberFormatCategory

enum XTPChartNumberFormatCategory

Format category used by CXTPChartNumberFormat.

Enumerator
xtpChartGeneral | General (100000.123)
xtpChartNumber | Number (10,000,000.12)
xtpChartCurrency | Currency ($10,000,000.12)
xtpChartPercentage | Percent (99.12%)
xtpChartScientific | Scientific (12.12e+005)


Toolkit Pro: XTPChartTextPainter.h File Reference

  • Source
  • Chart
  • Utils
Classes | Enumerations
XTPChartTextPainter.h File Reference

Go to the source code of this file.

Classes

class | CXTPChartTextPainterBase
This abstract class represents a text painter which is used for drawing various text elements in the chart. More...
class | CXTPChartTextPainter
This class represents a text painter which is used for drawing various text elements in the chart. More...
class | CXTPChartRotatedTextPainterBase
This abstract base class represents a rotated text painter which is used for drawing various rotated text elements in the chart. More...
class | CXTPChartRotatedTextPainterNearLine
This abstract base class renders a rotated text near a line which is used for drawing various rotated text elements near lines in the chart. More...

Enumerations

enum XTPChartTextRotation {
xtpChartTextLeftTop , xtpChartTextCenterTop , xtpChartTextRightTop , xtpChartTextLeftCenter ,
xtpChartTextCenterCenter , xtpChartTextRightCenter , xtpChartTextLeftBottom , xtpChartTextCenterBottom ,
xtpChartTextRightBottom
}
This enumeration defines the various text rotations used in the XTP chart. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Enumeration Type Documentation

◆ XTPChartTextRotation

enum XTPChartTextRotation

This enumeration defines the various text rotations used in the XTP chart.

Enumerator
xtpChartTextLeftTop | Left top.
xtpChartTextCenterTop | Center top.
xtpChartTextRightTop | Right top.
xtpChartTextLeftCenter | Left center.
xtpChartTextCenterCenter | Center center.
xtpChartTextRightCenter | Right center.
xtpChartTextLeftBottom | Left bottom.
xtpChartTextCenterBottom | Center bottom.
xtpChartTextRightBottom | Right bottom.


Toolkit Pro: XTPChartContent.h File Reference

  • Source
  • Chart
Classes | Enumerations
XTPChartContent.h File Reference

Go to the source code of this file.

Classes

class CXTPChartContent
This class represents chart content, which is a kind of CXTPChartElement. More...

Enumerations

enum XTPChartPanelDirection { xtpChartPanelVertical , xtpChartPanelHorizontal }
Specified chart panel direction. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Enumeration Type Documentation

◆ XTPChartPanelDirection

enum XTPChartPanelDirection

Specified chart panel direction.

Enumerator
xtpChartPanelVertical | Specifies vertical chart panel direction.
xtpChartPanelHorizontal | Specifies horizontal chart panel direction.


Toolkit Pro: XTPChartContentView.h File Reference

  • Source
  • Chart
Classes
XTPChartContentView.h File Reference

Go to the source code of this file.

Classes

class CXTPChartContentView
This class represents the view of the chart content, which is a kind of CXTPChartElementView. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartControl.h File Reference

  • Source
  • Chart
Classes
XTPChartControl.h File Reference

Go to the source code of this file.

Classes

class CXTPChartControl
CXTPChartControl is a CWnd derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartDefines.h Source File

  • Source
  • Chart
XTPChartDefines.h
1/* this ALWAYS GENERATED file contains the definitions for the interfaces */
2
3/* File created by MIDL compiler version 3.03.0110 */
4/* at Sat Sep 29 16:06:21 2012
5 */
6/* Compiler settings for XTPChartDefines.odl:
7 Os (OptLev=s), W1, Zp8, env=Win32, ms_ext, c_ext
8 error checks: none
9*/
10
11//{{AFX_CODEJOCK_PRIVATE
12#ifndef __XTPChartDefines_h__
13# define __XTPChartDefines_h__
14//}}AFX_CODEJOCK_PRIVATE
15
16# if _MSC_VER > 1000
17# pragma once
18# endif // _MSC_VER > 1000
19
20# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
21
22typedef /* [helpcontext][helpstring][uuid] */
23 enum XTPChartScaleType
24{
25 xtpChartScaleQualitative = 0,
26 xtpChartScaleNumerical = xtpChartScaleQualitative + 1,
27 xtpChartScaleDateTime = xtpChartScaleNumerical + 1,
28 xtpChartScaleTime = xtpChartScaleDateTime + 1
29} XTPChartScaleType;
30
31typedef XTPChartScaleType ChartScaleType;
32
33typedef /* [helpcontext][helpstring][uuid] */
34 enum XTPChartStringAlignment
35{
36 xtpChartAlignNear = 0,
37 xtpChartAlignCenter = xtpChartAlignNear + 1,
38 xtpChartAlignFar = xtpChartAlignCenter + 1
39} XTPChartStringAlignment;
40
41typedef XTPChartStringAlignment ChartStringAlignment;
42
43typedef /* [helpcontext][helpstring][uuid] */
44 enum XTPChartDashStyle
45{
46 xtpChartDashStyleEmpty = 0,
47 xtpChartDashStyleSolid = xtpChartDashStyleEmpty + 1,
48 xtpChartDashStyleDash = xtpChartDashStyleSolid + 1,
49 xtpChartDashStyleDot = xtpChartDashStyleDash + 1,
50 xtpChartDashStyleDashDot = xtpChartDashStyleDot + 1,
51 xtpChartDashStyleDashDotDot = xtpChartDashStyleDashDot + 1,
52 xtpChartDashStyleCustom = xtpChartDashStyleDashDotDot + 1
53} XTPChartDashStyle;
54
55typedef XTPChartDashStyle ChartDashStyle;
56
57typedef /* [helpcontext][helpstring][uuid] */
58 enum XTPChartFillMode
59{
60 xtpChartFillEmpty = 0,
61 xtpChartFillSolid = xtpChartFillEmpty + 1,
62 xtpChartFillGradient = xtpChartFillSolid + 1,
63 xtpChartFillHatch = xtpChartFillGradient + 1
64} XTPChartFillMode;
65
66typedef XTPChartFillMode ChartFillMode;
67
68typedef /* [helpcontext][helpstring][uuid] */
69 enum XTPChartGradientAngle
70{
71 xtpChartGradientAngle0 = 0,
72 xtpChartGradientAngle45 = 45,
73 xtpChartGradientAngle90 = 90,
74 xtpChartGradientAngle135 = 135,
75 xtpChartGradientAngle180 = 180,
76 xtpChartGradientAngle225 = 225,
77 xtpChartGradientAngle270 = 270,
78 xtpChartGradientAngle315 = 315
79} XTPChartGradientAngle;
80
81typedef XTPChartGradientAngle ChartGradientAngle;
82
83typedef /* [helpcontext][helpstring][uuid] */
84 enum XTPChartLinearGradientMode
85{
86 xtpChartLinearGradientModeHorizontal = 0,
87 xtpChartLinearGradientModeVertical = xtpChartLinearGradientModeHorizontal + 1,
88 xtpChartLinearGradientModeForwardDiagonal = xtpChartLinearGradientModeVertical + 1,
89 xtpChartLinearGradientModeBackwardDiagonal = xtpChartLinearGradientModeForwardDiagonal + 1,
90 xtpChartLinearGradientModeCenterHorizontal = xtpChartLinearGradientModeBackwardDiagonal + 1,
91 xtpChartLinearGradientModeCenterVertical = xtpChartLinearGradientModeCenterHorizontal + 1
92} XTPChartLinearGradientMode;
93
94typedef XTPChartLinearGradientMode ChartLinearGradientMode;
95
96typedef /* [helpcontext][helpstring][uuid] */
97 enum XTPChartHatchStyle
98{
99 xtpChartHatchStyleHorizontal = 0,
100 xtpChartHatchStyleVertical = xtpChartHatchStyleHorizontal + 1,
101 xtpChartHatchStyleForwardDiagonal = xtpChartHatchStyleVertical + 1,
102 xtpChartHatchStyleBackwardDiagonal = xtpChartHatchStyleForwardDiagonal + 1,
103 xtpChartHatchStyleCross = xtpChartHatchStyleBackwardDiagonal + 1,
104 xtpChartHatchStyleDiagonalCross = xtpChartHatchStyleCross + 1,
105 xtpChartHatchStyle05Percent = xtpChartHatchStyleDiagonalCross + 1,
106 xtpChartHatchStyle10Percent = xtpChartHatchStyle05Percent + 1,
107 xtpChartHatchStyle20Percent = xtpChartHatchStyle10Percent + 1,
108 xtpChartHatchStyle25Percent = xtpChartHatchStyle20Percent + 1,
109 xtpChartHatchStyle30Percent = xtpChartHatchStyle25Percent + 1,
110 xtpChartHatchStyle40Percent = xtpChartHatchStyle30Percent + 1,
111 xtpChartHatchStyle50Percent = xtpChartHatchStyle40Percent + 1,
112 xtpChartHatchStyle60Percent = xtpChartHatchStyle50Percent + 1,
113 xtpChartHatchStyle70Percent = xtpChartHatchStyle60Percent + 1,
114 xtpChartHatchStyle75Percent = xtpChartHatchStyle70Percent + 1,
115 xtpChartHatchStyle80Percent = xtpChartHatchStyle75Percent + 1,
116 xtpChartHatchStyle90Percent = xtpChartHatchStyle80Percent + 1,
117 xtpChartHatchStyleLightDownwardDiagonal = xtpChartHatchStyle90Percent + 1,
118 xtpChartHatchStyleLightUpwardDiagonal = xtpChartHatchStyleLightDownwardDiagonal + 1,
119 xtpChartHatchStyleDarkDownwardDiagonal = xtpChartHatchStyleLightUpwardDiagonal + 1,
120 xtpChartHatchStyleDarkUpwardDiagonal = xtpChartHatchStyleDarkDownwardDiagonal + 1,
121 xtpChartHatchStyleWideDownwardDiagonal = xtpChartHatchStyleDarkUpwardDiagonal + 1,
122 xtpChartHatchStyleWideUpwardDiagonal = xtpChartHatchStyleWideDownwardDiagonal + 1,
123 xtpChartHatchStyleLightVertical = xtpChartHatchStyleWideUpwardDiagonal + 1,
124 xtpChartHatchStyleLightHorizontal = xtpChartHatchStyleLightVertical + 1,
125 xtpChartHatchStyleNarrowVertical = xtpChartHatchStyleLightHorizontal + 1,
126 xtpChartHatchStyleNarrowHorizontal = xtpChartHatchStyleNarrowVertical + 1,
127 xtpChartHatchStyleDarkVertical = xtpChartHatchStyleNarrowHorizontal + 1,
128 xtpChartHatchStyleDarkHorizontal = xtpChartHatchStyleDarkVertical + 1,
129 xtpChartHatchStyleDashedDownwardDiagonal = xtpChartHatchStyleDarkHorizontal + 1,
130 xtpChartHatchStyleDashedUpwardDiagonal = xtpChartHatchStyleDashedDownwardDiagonal + 1,
131 xtpChartHatchStyleDashedHorizontal = xtpChartHatchStyleDashedUpwardDiagonal + 1,
132 xtpChartHatchStyleDashedVertical = xtpChartHatchStyleDashedHorizontal + 1,
133 xtpChartHatchStyleSmallConfetti = xtpChartHatchStyleDashedVertical + 1,
134 xtpChartHatchStyleLargeConfetti = xtpChartHatchStyleSmallConfetti + 1,
135 xtpChartHatchStyleZigZag = xtpChartHatchStyleLargeConfetti + 1,
136 xtpChartHatchStyleWave = xtpChartHatchStyleZigZag + 1,
137 xtpChartHatchStyleDiagonalBrick = xtpChartHatchStyleWave + 1,
138 xtpChartHatchStyleHorizontalBrick = xtpChartHatchStyleDiagonalBrick + 1,
139 xtpChartHatchStyleWeave = xtpChartHatchStyleHorizontalBrick + 1,
140 xtpChartHatchStylePlaid = xtpChartHatchStyleWeave + 1,
141 xtpChartHatchStyleDivot = xtpChartHatchStylePlaid + 1,
142 xtpChartHatchStyleDottedGrid = xtpChartHatchStyleDivot + 1,
143 xtpChartHatchStyleDottedDiamond = xtpChartHatchStyleDottedGrid + 1,
144 xtpChartHatchStyleShingle = xtpChartHatchStyleDottedDiamond + 1,
145 xtpChartHatchStyleTrellis = xtpChartHatchStyleShingle + 1,
146 xtpChartHatchStyleSphere = xtpChartHatchStyleTrellis + 1,
147 xtpChartHatchStyleSmallGrid = xtpChartHatchStyleSphere + 1,
148 xtpChartHatchStyleSmallCheckerBoard = xtpChartHatchStyleSmallGrid + 1,
149 xtpChartHatchStyleLargeCheckerBoard = xtpChartHatchStyleSmallCheckerBoard + 1,
150 xtpChartHatchStyleOutlinedDiamond = xtpChartHatchStyleLargeCheckerBoard + 1,
151 xtpChartHatchStyleSolidDiamond = xtpChartHatchStyleOutlinedDiamond + 1
152} XTPChartHatchStyle;
153
154typedef XTPChartHatchStyle ChartHatchStyle;
155
156typedef /* [helpcontext][helpstring][uuid] */
157 enum XTPChartNearTextPosition
158{
159 xtpChartTextNearLeft = 0,
160 xtpChartTextNearRight = xtpChartTextNearLeft + 1,
161 xtpChartTextNearTop = xtpChartTextNearRight + 1,
162 xtpChartTextNearBottom = xtpChartTextNearTop + 1
163} XTPChartNearTextPosition;
164
165typedef XTPChartNearTextPosition ChartNearTextPosition;
166
167typedef /* [helpstring][uuid] */
168 enum XTPChartErrorBarType
169{
170 xtpChartErrorBarTypeNone = 0,
171 xtpChartErrorBarTypeFixedValue = 1,
172 xtpChartErrorBarTypePercentage = 2,
173 xtpChartErrorBarTypeStandardDeviation = 3,
174 xtpChartErrorBarTypeStandardError = 4,
175 xtpChartErrorBarTypeCustom = 5
176} XTPChartErrorBarType;
177
178typedef XTPChartErrorBarType ChartErrorBarType;
179
180typedef /* [helpstring][uuid] */
181 enum XTPChartErrorBarDirection
182{
183 xtpChartErrorBarDirectionNone = 0,
184 xtpChartErrorBarDirectionPlus = 1,
185 xtpChartErrorBarDirectionMinus = 2,
186 xtpChartErrorBarDirectionBoth = 3
187} XTPChartErrorBarDirection;
188
189typedef XTPChartErrorBarDirection ChartErrorBarDirection;
190
191typedef /* [helpstring][uuid] */
192 enum XTPChartErrorBarEndStyle
193{
194 xtpChartErrorBarEndStyleNoCap = 0,
195 xtpChartErrorBarEndStyleCap = 1
196} XTPChartErrorBarEndStyle;
197
198typedef XTPChartErrorBarEndStyle ChartErrorBarEndStyle;
199
200typedef /* [helpstring][uuid] */
201 enum XTPChartErrorBarPosition
202{
203 xtpChartErrorBarPositionNone = 0,
204 xtpChartErrorBarPositionTop = 1,
205 xtpChartErrorBarPositionCenter = 2
206} XTPChartErrorBarPosition;
207
208typedef XTPChartErrorBarPosition ChartErrorBarPosition;
209
210# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
211
212//{{AFX_CODEJOCK_PRIVATE
213#endif /*__XTPChartDefines_h__*/
214//}}AFX_CODEJOCK_PRIVATE
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h


Toolkit Pro: XTPChartDiagram.h File Reference

  • Source
  • Chart
Classes
XTPChartDiagram.h File Reference

Go to the source code of this file.

Classes

class | CXTPChartDiagram
This class represents a chart diagram, which is a kind of CXTPChartElement. More...
class | CXTPChartDiagramDomain
Represents a virtual diagram rectangular domain area. More...
class | CXTPChart2dDiagram
The base class for all 2D diagrams. More...
class | CXTPChart3dDiagram
The base class for all 3D diagrams. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartDiagramView.h File Reference

  • Source
  • Chart
Classes
XTPChartDiagramView.h File Reference

Go to the source code of this file.

Classes

class | CXTPChartDiagramView
This class represents the view of a chart diagram, which is a kind of CXTPChartElementView. More...
class | CXTPChart3dDiagramView
This class represents the view of a chart diagram, which is a kind of CXTPChartElementView. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartElement.h File Reference

  • Source
  • Chart
Classes | Enumerations
XTPChartElement.h File Reference

Go to the source code of this file.

Classes

class | CXTPChartObject
A base class for all chart objects. More...
class | CXTPChartElement
This class abstracts a chart element, this class acts as a base class for all chart elements. More...
class | CXTPChartContainer
This class represents the chart container. More...
class | CXTPChartTextElement
This class abstracts a chart text element. More...
class | CXTPChartElementCollection
This class abstracts a chart collection. More...

Enumerations

enum XTPChartUpdateOptions { xtpChartUpdateView = 1 , xtpChartUpdateLayout = 2 , xtpChartUpdateRedraw = 4 }
Specifies chart update options. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Enumeration Type Documentation

◆ XTPChartUpdateOptions

enum XTPChartUpdateOptions

Specifies chart update options.

Enumerator
xtpChartUpdateView | Recreate View.
xtpChartUpdateLayout | Don't recreate View but call Calculate.
xtpChartUpdateRedraw | Rebuild Command Tree.


Toolkit Pro: XTPChartElementView.h File Reference

  • Source
  • Chart
Classes
XTPChartElementView.h File Reference

Go to the source code of this file.

Classes

class CXTPChartElementView
This class represents the view of a chart element. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartErrorBar.h File Reference

  • Source
  • Chart
XTPChartErrorBar.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartIIDs.h Source File

  • Source
  • Chart
XTPChartIIDs.h
1// DO NOT MODIFY MANUALLY
2// Generated on Thu 12/11/2025 at 12:46:09.30 using cj-update-iids.cmd
3
24#ifndef __XTPChartIIDs_H__
25# define __XTPChartIIDs_H__
26
27// clang-format off
28
29#define XTP_DEFINE_GUID(name,l,w1,w2,b1,b2,b3,b4,b5,b6,b7,b8) \
30 EXTERN_C __declspec(selectany) const IID XTP##name = {l,w1,w2,{b1,b2,b3,b4,b5,b6,b7,b8}}; \
31 const unsigned long XTP##name##__Data1 = (l); \
32 const unsigned short XTP##name##__Data2 = (w1); \
33 const unsigned short XTP##name##__Data3 = (w2); \
34 const unsigned char XTP##name##__Data4_0 = (b1); \
35 const unsigned char XTP##name##__Data4_1 = (b2); \
36 const unsigned char XTP##name##__Data4_2 = (b3); \
37 const unsigned char XTP##name##__Data4_3 = (b4); \
38 const unsigned char XTP##name##__Data4_4 = (b5); \
39 const unsigned char XTP##name##__Data4_5 = (b6); \
40 const unsigned char XTP##name##__Data4_6 = (b7); \
41 const unsigned char XTP##name##__Data4_7 = (b8);
42
43XTP_DEFINE_GUID(LIBID_XtremeChartControl,0xC215CB9A,0x0AE1,0x499F,0xA1,0x01,0x48,0xB3,0xC3,0x70,0xD3,0xDF);
44XTP_DEFINE_GUID(DIID_ChartFont,0xC0DE2430,0x27BF,0x4cb1,0x9A,0xBF,0x45,0x58,0xD9,0x83,0x52,0x23);
45XTP_DEFINE_GUID(DIID_ChartLineStyle,0xC0DE2430,0x1EA3,0x4194,0xB3,0xAF,0xEC,0xA9,0xC6,0x5E,0x81,0x9B);
46XTP_DEFINE_GUID(DIID_ChartFillStyle,0xC0DE2430,0x1853,0x40F9,0xA1,0x58,0xC0,0xF4,0x02,0x28,0xD1,0x30);
47XTP_DEFINE_GUID(DIID_ChartBorder,0xC0DE2430,0x3AF3,0x40B6,0xAE,0xB0,0x3A,0xD7,0x53,0xD1,0xA5,0x48);
48XTP_DEFINE_GUID(DIID_ChartNumberFormat,0xC0DE2430,0x265A,0x4DB7,0x8D,0x7D,0x97,0xB1,0xF9,0x0A,0x7B,0x78);
49XTP_DEFINE_GUID(DIID__DChart3dRotation,0xC0DE2430,0xCA79,0x4da9,0x8F,0xCD,0xCD,0x5E,0x06,0xDB,0x99,0x4A);
50XTP_DEFINE_GUID(CLSID_Chart3dRotation,0xC0DE2430,0x9BB1,0x463c,0x92,0x42,0x1B,0x5C,0xA0,0x25,0xB2,0x20);
51XTP_DEFINE_GUID(DIID_ChartTitle,0xC0DE2430,0x95D9,0x4E55,0x9C,0x07,0x14,0x03,0x1C,0x54,0x6F,0x96);
52XTP_DEFINE_GUID(DIID_ChartTitleCollection,0xC0DE2430,0xC489,0x41E1,0x9F,0xFF,0x5D,0x44,0xF3,0x10,0x6D,0x90);
53XTP_DEFINE_GUID(DIID_ChartDiagram,0xC0DE2430,0xA1CA,0x4629,0xAA,0x0E,0xAC,0xDF,0xF1,0xCA,0xA0,0x05);
54XTP_DEFINE_GUID(DIID_ChartAxisConstantLine,0xC0DE2430,0x846F,0x436A,0x9D,0xDF,0xDE,0x66,0x4C,0xD0,0xCF,0xB1);
55XTP_DEFINE_GUID(DIID_ChartAxisConstantLines,0xC0DE2430,0x96B5,0x4D95,0x86,0x18,0xC2,0x3B,0x93,0x8D,0xDA,0xE9);
56XTP_DEFINE_GUID(DIID_ChartAxisCustomLabel,0xC0DE2430,0x232F,0x44D0,0xA8,0x39,0x5C,0xEC,0xE6,0x36,0x5C,0x97);
57XTP_DEFINE_GUID(DIID_ChartAxisCustomLabels,0xC0DE2430,0xA05D,0x4AD5,0x8F,0x31,0x01,0x48,0xF9,0xE8,0xB2,0xA2);
58XTP_DEFINE_GUID(DIID_ChartAxisStrip,0xC0DE2430,0x0ECE,0x40A0,0xA2,0x28,0xF8,0xDC,0xE2,0x59,0x6A,0x67);
59XTP_DEFINE_GUID(DIID_ChartAxisStrips,0xC0DE2430,0xD856,0x40AC,0xBE,0x3B,0x1B,0xB5,0xD6,0xE9,0x17,0x25);
60XTP_DEFINE_GUID(DIID_ChartAxisLabel,0xC0DE2430,0x5642,0x403D,0xA4,0x3E,0xDC,0x7D,0x98,0xF0,0x93,0xD7);
61XTP_DEFINE_GUID(DIID_ChartAxisTickMarks,0xC0DE2430,0x8CBA,0x4428,0xBB,0x19,0x95,0x93,0x02,0x1C,0xB5,0x92);
62XTP_DEFINE_GUID(DIID_ChartAxisGridLines,0xC0DE2430,0xAF55,0x47DD,0x89,0x4C,0x5F,0x48,0xEB,0x8A,0x0D,0xBE);
63XTP_DEFINE_GUID(DIID_ChartAxisTitle,0xC0DE2430,0x4C9C,0x4068,0xAA,0x65,0x62,0x5B,0x11,0xB8,0x3E,0xF1);
64XTP_DEFINE_GUID(DIID_ChartAxisRange,0xC0DE2430,0xD2C1,0x4FC3,0xA1,0x48,0x40,0x3B,0x7E,0x6F,0x1B,0xFF);
65XTP_DEFINE_GUID(DIID_ChartAxis,0xC0DE2430,0x1546,0x45A2,0xA7,0x27,0xEC,0xF6,0x3D,0xEF,0x83,0x57);
66XTP_DEFINE_GUID(DIID__DChartDiagram2D,0xC0DE2430,0xC1A5,0x4CB4,0x8C,0x9A,0x23,0xE3,0x11,0x81,0xF8,0xD9);
67XTP_DEFINE_GUID(CLSID_ChartDiagram2D,0xC0DE2430,0x92B6,0x4671,0x96,0x13,0x6B,0x2A,0x0F,0xBF,0x80,0xA8);
68XTP_DEFINE_GUID(DIID__DChartRadarDiagram,0xC0DE2430,0xBC18,0x4B8B,0xB4,0xA6,0x00,0xF9,0xC8,0x15,0xA0,0x31);
69XTP_DEFINE_GUID(CLSID_ChartRadarDiagram,0xC0DE2430,0xCE70,0x4F1A,0x9F,0x16,0x0B,0xFD,0x81,0x02,0xCE,0x31);
70XTP_DEFINE_GUID(DIID__DChartFunnelDiagram,0xC0DE2430,0x2720,0x4C3A,0xAA,0xEA,0x46,0x9B,0x73,0xF3,0x29,0xF4);
71XTP_DEFINE_GUID(CLSID_ChartFunnelDiagram,0xC0DE2430,0x99DC,0x44C4,0xA6,0x1E,0xE7,0x6F,0xBE,0xB8,0xE3,0x64);
72XTP_DEFINE_GUID(DIID__DChartPyramidDiagram,0xC0DE2430,0xEDDF,0x495E,0x98,0x69,0xF8,0xB1,0xD8,0x10,0x62,0xBA);
73XTP_DEFINE_GUID(CLSID_ChartPyramidDiagram,0xC0DE2430,0x2B66,0x4CCB,0xBA,0x70,0x00,0x2D,0x50,0x8C,0x42,0x2D);
74XTP_DEFINE_GUID(DIID__DChartPieDiagram,0xC0DE2430,0x4A3C,0x44D4,0x9D,0x08,0xF4,0xF8,0xBE,0x0E,0xE4,0x59);
75XTP_DEFINE_GUID(CLSID_ChartPieDiagram,0xC0DE2430,0x4470,0x4690,0xA8,0x6C,0x02,0x16,0x89,0xFC,0x0D,0x67);
76XTP_DEFINE_GUID(CLSID_Chart3dPieDiagram,0xC0DE2430,0x2484,0x4B5F,0xA0,0xB7,0x53,0x89,0x9B,0x03,0xBC,0x72);
77XTP_DEFINE_GUID(DIID_ChartMarker,0xC0DE2430,0x41EF,0x4579,0x84,0x24,0x7F,0xFC,0xE2,0x1B,0xB7,0x92);
78XTP_DEFINE_GUID(DIID_ChartLegendItem,0xC0DE2430,0xAC91,0x472b,0x97,0x06,0xE8,0x84,0x69,0x16,0x7F,0xAD);
79XTP_DEFINE_GUID(DIID_ChartSeriesErrorBar,0xC0DE2430,0x16AE,0x488a,0x8C,0x98,0xC0,0xE7,0x28,0x6A,0x78,0xF0);
80XTP_DEFINE_GUID(DIID_ChartSeriesLabel,0xC0DE2430,0x604D,0x4DC0,0x82,0x02,0x69,0x9C,0x0B,0x72,0xC3,0x2A);
81XTP_DEFINE_GUID(DIID_ChartPieSeriesLabel,0xC0DE2430,0x32E9,0x47D1,0x9C,0x45,0x49,0x40,0x63,0xE8,0x44,0x15);
82XTP_DEFINE_GUID(DIID_ChartFunnelSeriesLabel,0xC0DE2430,0x1FDB,0x4F50,0x83,0xCF,0x54,0x13,0x3D,0x8A,0x45,0x24);
83XTP_DEFINE_GUID(DIID_ChartPyramidSeriesLabel,0xC0DE2430,0x7E56,0x4EDD,0xAE,0x1C,0x45,0x7F,0x01,0x19,0xA7,0xE2);
84XTP_DEFINE_GUID(DIID_ChartPointSeriesLabel,0xC0DE2430,0x1470,0x4704,0x82,0xD9,0xC8,0x86,0x1F,0x6C,0x40,0xA3);
85XTP_DEFINE_GUID(DIID_ChartRadarPointSeriesLabel,0xC0DE2430,0x4134,0x4DE0,0x99,0x46,0xAC,0xC7,0xD2,0xCC,0x97,0x87);
86XTP_DEFINE_GUID(DIID_ChartBarSeriesLabel,0xC0DE2430,0xDDB9,0x450C,0x8B,0x51,0x98,0x0A,0x05,0x3C,0x5E,0x36);
87XTP_DEFINE_GUID(DIID_ChartRangeBarSeriesLabel,0xC0DE2430,0xAF1A,0x4259,0x81,0x41,0xF6,0xCE,0xC7,0x4A,0xE9,0xCB);
88XTP_DEFINE_GUID(DIID_ChartSeriesStyle,0xC0DE2430,0x2179,0x4B71,0x81,0x63,0x61,0x73,0xE1,0xEA,0x0E,0x3E);
89XTP_DEFINE_GUID(DIID__DChartDiagram2DSeriesStyle,0xC0DE2430,0x457B,0x4D4E,0x9F,0x78,0x6D,0xB0,0x54,0x45,0x3A,0xAC);
90XTP_DEFINE_GUID(DIID__DChartPointSeriesStyle,0xC0DE2430,0x41BD,0x486F,0xA0,0xCB,0xC5,0x17,0x90,0xF0,0x4F,0x43);
91XTP_DEFINE_GUID(CLSID_ChartPointSeriesStyle,0xC0DE2430,0x352D,0x495A,0x8A,0xD2,0x6D,0x31,0xBA,0x5A,0x5C,0xC4);
92XTP_DEFINE_GUID(DIID__DChartRadarPointSeriesStyle,0xC0DE2430,0xF84F,0x4EA5,0xA8,0x3A,0xDC,0x73,0xAE,0x41,0x05,0xB5);
93XTP_DEFINE_GUID(CLSID_ChartRadarPointSeriesStyle,0xC0DE2430,0x028C,0x4FCB,0x8B,0xB8,0x61,0xF1,0x4C,0x1A,0xF6,0x61);
94XTP_DEFINE_GUID(DIID__DChartRadarLineSeriesStyle,0xC0DE2430,0x39C5,0x407D,0xB2,0xF8,0x5D,0xE4,0xF2,0x3C,0xB2,0x22);
95XTP_DEFINE_GUID(CLSID_ChartRadarLineSeriesStyle,0xC0DE2430,0x94DD,0x40C0,0x8B,0xC9,0x18,0x00,0x00,0xF6,0xBA,0x38);
96XTP_DEFINE_GUID(DIID__DChartRadarSplineSeriesStyle,0xC0DE2430,0x2BF4,0x43A2,0xA2,0x72,0x5A,0x05,0x20,0xF7,0xA9,0x26);
97XTP_DEFINE_GUID(CLSID_ChartRadarSplineSeriesStyle,0xC0DE2430,0x2964,0x4F18,0x93,0xD9,0x0E,0xD9,0xA8,0xD8,0xDF,0xC3);
98XTP_DEFINE_GUID(DIID__DChartRadarAreaSeriesStyle,0xC0DE2430,0x271E,0x4095,0x98,0x69,0x85,0xEF,0x7E,0x3B,0x9F,0x96);
99XTP_DEFINE_GUID(CLSID_ChartRadarAreaSeriesStyle,0xC0DE2430,0x8260,0x4257,0xBA,0x00,0x11,0x23,0x89,0x06,0x8C,0xB1);
100XTP_DEFINE_GUID(DIID__DChartRadarSplineAreaSeriesStyle,0xC0DE2430,0xFC0C,0x408F,0xAE,0x1B,0x9A,0x4F,0x62,0x79,0x4E,0x68);
101XTP_DEFINE_GUID(CLSID_ChartRadarSplineAreaSeriesStyle,0xC0DE2430,0xE8DF,0x498D,0x84,0x35,0x37,0xD9,0x73,0xF2,0x4E,0x91);
102XTP_DEFINE_GUID(DIID__DChartLineSeriesStyle,0xC0DE2430,0x5BCB,0x4779,0xB3,0x30,0x2B,0x1D,0x9A,0x40,0xCE,0x5E);
103XTP_DEFINE_GUID(CLSID_ChartLineSeriesStyle,0xC0DE2430,0x2E26,0x4B6E,0xA3,0x4A,0x51,0x64,0xFC,0x1D,0x4D,0xD3);
104XTP_DEFINE_GUID(DIID__DChartScatterLineSeriesStyle,0xC0DE2430,0x8D27,0x4AA6,0x86,0xA5,0x38,0x3B,0x8B,0x2F,0x36,0x0F);
105XTP_DEFINE_GUID(CLSID_ChartScatterLineSeriesStyle,0xC0DE2430,0xC001,0x4184,0xA7,0x98,0x74,0x35,0xEB,0x71,0x99,0x71);
106XTP_DEFINE_GUID(DIID__DChartFastLineSeriesStyle,0xC0DE2430,0x4383,0x43C0,0x91,0x13,0x8D,0x90,0x20,0x35,0xCF,0x57);
107XTP_DEFINE_GUID(CLSID_ChartFastLineSeriesStyle,0xC0DE2430,0x10F9,0x496A,0x8D,0xF1,0x57,0xBB,0xD8,0x54,0x77,0x5D);
108XTP_DEFINE_GUID(DIID__DChartStepLineSeriesStyle,0xC0DE2430,0xEA73,0x4572,0xA1,0x8B,0xDE,0x7B,0xB2,0x3E,0xF9,0xC3);
109XTP_DEFINE_GUID(CLSID_ChartStepLineSeriesStyle,0xC0DE2430,0x0D59,0x47B7,0x85,0x4D,0x37,0x80,0x03,0xF1,0x75,0x87);
110XTP_DEFINE_GUID(DIID__DChartPieSeriesStyle,0xC0DE2430,0xE779,0x4614,0xA0,0x1F,0xC4,0xEA,0xC0,0xAF,0xE9,0x7E);
111XTP_DEFINE_GUID(CLSID_ChartPieSeriesStyle,0xC0DE2430,0x4245,0x4F15,0xBA,0x71,0xA3,0x5F,0xE9,0xEA,0xBE,0x7D);
112XTP_DEFINE_GUID(DIID__DChart3dPieSeriesStyle,0xC0DE2430,0x0BE7,0x4673,0x9C,0x18,0x27,0x0A,0x41,0xED,0x8F,0x85);
113XTP_DEFINE_GUID(CLSID_Chart3dPieSeriesStyle,0xC0DE2430,0xE2C0,0x4A52,0xB0,0x78,0x1C,0x72,0xD4,0x62,0x02,0x53);
114XTP_DEFINE_GUID(DIID__DChartFunnelSeriesStyle,0xC0DE2430,0xC463,0x4754,0x96,0x9D,0xE7,0x6A,0x66,0x79,0x03,0xC3);
115XTP_DEFINE_GUID(CLSID_ChartFunnelSeriesStyle,0xC0DE2430,0x0DF9,0x4BA3,0x8F,0xE9,0xDC,0x93,0xFB,0x6F,0x5B,0x7C);
116XTP_DEFINE_GUID(DIID__DChart3dFunnelSeriesStyle,0xC0DE2430,0xAAD4,0x40B4,0xBD,0x33,0x1B,0x81,0x2F,0xDB,0x54,0xE2);
117XTP_DEFINE_GUID(CLSID_Chart3dFunnelSeriesStyle,0xC0DE2430,0x2F6F,0x48C8,0x9E,0xF7,0xAC,0x07,0x9A,0x75,0xA3,0xD8);
118XTP_DEFINE_GUID(DIID__DChartPyramidSeriesStyle,0xC0DE2430,0x8858,0x42B8,0x80,0x6C,0xE9,0x87,0xA6,0x03,0xBA,0x71);
119XTP_DEFINE_GUID(CLSID_ChartPyramidSeriesStyle,0xC0DE2430,0xCD0B,0x44CF,0xA5,0x02,0x24,0xE4,0xF4,0x7F,0x5A,0x9B);
120XTP_DEFINE_GUID(DIID__DChart3dPyramidSeriesStyle,0xC0DE2430,0x7166,0x4C41,0x9F,0xC1,0xF7,0x0A,0x14,0x06,0x9A,0xB1);
121XTP_DEFINE_GUID(CLSID_Chart3dPyramidSeriesStyle,0xC0DE2430,0xF700,0x48EE,0x82,0x06,0xE2,0x57,0xA6,0x16,0x23,0x64);
122XTP_DEFINE_GUID(DIID__DChartBarSeriesStyle,0xC0DE2430,0xE82E,0x4A5D,0x92,0xC0,0x98,0x30,0x14,0x4A,0x48,0x9E);
123XTP_DEFINE_GUID(CLSID_ChartBarSeriesStyle,0xC0DE2430,0x3755,0x480A,0x9B,0xCC,0x19,0x64,0xFF,0x16,0x69,0x87);
124XTP_DEFINE_GUID(DIID__DChartRangeBarSeriesStyle,0xC0DE2430,0x8280,0x49D3,0xB6,0xBC,0x9C,0x19,0x36,0x00,0x00,0x0C);
125XTP_DEFINE_GUID(CLSID_ChartRangeBarSeriesStyle,0xC0DE2430,0x18DB,0x493B,0xA1,0x2B,0x76,0xFA,0xE1,0x98,0x5E,0x43);
126XTP_DEFINE_GUID(DIID__DChartGanttSeriesStyle,0xC0DE2430,0x52C6,0x49F1,0xA1,0x3A,0x68,0x3F,0x6F,0x69,0xEE,0xDC);
127XTP_DEFINE_GUID(CLSID_ChartGanttSeriesStyle,0xC0DE2430,0xA5DB,0x4099,0xAA,0xB3,0xB7,0xCD,0xEC,0x06,0x1B,0x85);
128XTP_DEFINE_GUID(DIID__DChartStackedBarSeriesStyle,0xC0DE2430,0x27BF,0x4cb1,0x9A,0xBF,0x45,0x58,0xD9,0x83,0x54,0x56);
129XTP_DEFINE_GUID(CLSID_ChartStackedBarSeriesStyle,0xC0DE2430,0x92B6,0x4671,0x96,0x13,0x6B,0x2A,0x0F,0xBF,0x87,0x89);
130XTP_DEFINE_GUID(DIID__DChartSplineSeriesStyle,0xC0DE2430,0xBC80,0x4D8A,0xAE,0x97,0x35,0x11,0xE3,0xAC,0x8F,0xBC);
131XTP_DEFINE_GUID(CLSID_ChartSplineSeriesStyle,0xC0DE2430,0x7918,0x41D5,0xB5,0x54,0x8F,0x63,0xC7,0x56,0x57,0x1F);
132XTP_DEFINE_GUID(DIID__DChartStackedAreaSeriesStyle,0xC0DE2430,0x27BF,0x4cb1,0x9A,0xBF,0x45,0x58,0xD9,0x83,0x98,0x76);
133XTP_DEFINE_GUID(CLSID_ChartStackedAreaSeriesStyle,0xC0DE2430,0x92B6,0x4671,0x96,0x13,0x6B,0x2A,0x0F,0xBF,0x54,0x32);
134XTP_DEFINE_GUID(DIID__DChartStackedSplineAreaSeriesStyle,0xC0DE2430,0x624C,0x4C65,0xBA,0x57,0x06,0x6C,0xDE,0x4E,0xB4,0xE5);
135XTP_DEFINE_GUID(CLSID_ChartStackedSplineAreaSeriesStyle,0xC0DE2430,0x51E5,0x4AFC,0xAD,0x69,0x51,0x63,0xB5,0x0E,0xF9,0x9D);
136XTP_DEFINE_GUID(DIID__DChartAreaSeriesStyle,0xC0DE2430,0x5CE0,0x4382,0x9A,0xCF,0x61,0xAE,0x43,0x47,0xC6,0x9D);
137XTP_DEFINE_GUID(CLSID_ChartAreaSeriesStyle,0xC0DE2430,0x52B5,0x4D9D,0xAF,0xF1,0xAF,0xBF,0xCD,0x08,0x02,0x8E);
138XTP_DEFINE_GUID(DIID__DChartSplineAreaSeriesStyle,0xC0DE2430,0x1056,0x4877,0x9C,0xCF,0xAD,0x41,0xB1,0x99,0x96,0x53);
139XTP_DEFINE_GUID(CLSID_ChartSplineAreaSeriesStyle,0xC0DE2430,0x6A26,0x4A90,0xAE,0xF1,0x68,0x0F,0xF5,0x8E,0xB2,0xF5);
140XTP_DEFINE_GUID(DIID__DChartRangeSplineAreaSeriesStyle,0xC0DE2430,0xC76A,0x4505,0xB7,0xA3,0x5D,0xF7,0x02,0xF5,0xB2,0x33);
141XTP_DEFINE_GUID(CLSID_ChartRangeSplineAreaSeriesStyle,0xC0DE2430,0x2757,0x4192,0x87,0x88,0x21,0xD3,0x16,0x84,0xF9,0x75);
142XTP_DEFINE_GUID(DIID__DChartStepAreaSeriesStyle,0xC0DE2430,0xAFD8,0x485A,0x80,0xE6,0x25,0xE7,0x9D,0x7E,0x74,0xD6);
143XTP_DEFINE_GUID(CLSID_ChartStepAreaSeriesStyle,0xC0DE2430,0x301C,0x4B02,0xA7,0x84,0x57,0xDA,0x03,0xF6,0x4B,0xF4);
144XTP_DEFINE_GUID(DIID__DChartBubbleSeriesStyle,0xC0DE2430,0x3107,0x49CC,0x9A,0xF6,0x9F,0x16,0x85,0xB6,0x7C,0xEC);
145XTP_DEFINE_GUID(CLSID_ChartBubbleSeriesStyle,0xC0DE2430,0x9E12,0x4D12,0xBE,0x71,0xA4,0x20,0x1B,0x6A,0xD2,0xAC);
146XTP_DEFINE_GUID(DIID__DChartHighLowSeriesStyle,0xC0DE2430,0xFEC1,0x4152,0x85,0x17,0x9F,0x62,0xBD,0x8A,0xB8,0xCE);
147XTP_DEFINE_GUID(CLSID_ChartHighLowSeriesStyle,0xC0DE2430,0x69D9,0x484B,0xB8,0x73,0xBD,0x35,0x5B,0xF6,0x9D,0x49);
148XTP_DEFINE_GUID(DIID__DChartCandleStickSeriesStyle,0xC0DE2430,0xDAB8,0x4673,0x91,0x8A,0x50,0x81,0x5F,0xAE,0xF1,0x8B);
149XTP_DEFINE_GUID(CLSID_ChartCandleStickSeriesStyle,0xC0DE2430,0x0EB6,0x44F6,0x92,0x72,0x97,0xBB,0x44,0xDB,0xF8,0x7B);
150XTP_DEFINE_GUID(DIID_ChartSeriesPoint,0xC0DE2430,0x3315,0x4512,0xA7,0x51,0x3B,0x50,0xCD,0x9F,0x77,0x09);
151XTP_DEFINE_GUID(DIID_ChartSeriesPointCollection,0xC0DE2430,0xE6B6,0x4F76,0x94,0xB3,0xEA,0x02,0x03,0xD9,0x23,0x05);
152XTP_DEFINE_GUID(DIID_ChartSeries,0xC0DE2430,0x7B29,0x46F1,0xA7,0x00,0x78,0xD3,0x9A,0xCE,0xCE,0xB2);
153XTP_DEFINE_GUID(DIID__DChartSeriesTrendline,0xC0DE2430,0xE3CC,0x4a78,0xA7,0xCD,0xF4,0xD5,0xB1,0x47,0x06,0x87);
154XTP_DEFINE_GUID(CLSID_ChartSeriesTrendline,0xC0DE2430,0xB03F,0x4e60,0x9F,0xB6,0x1F,0x07,0x6E,0xD3,0xF0,0xB5);
155XTP_DEFINE_GUID(DIID_ChartSeriesCollection,0xC0DE2430,0x00E9,0x487D,0x97,0xAD,0x90,0x30,0xEE,0x5F,0x9F,0x20);
156XTP_DEFINE_GUID(DIID_ChartDiagramCollection,0xC0DE2430,0xD70F,0x455B,0x91,0x06,0xA6,0x9F,0xD8,0xB9,0xDF,0x73);
157XTP_DEFINE_GUID(DIID_ChartPalette,0xC0DE2430,0xC8A6,0x460B,0x85,0xDA,0xDA,0x02,0xAC,0x8D,0x29,0x41);
158XTP_DEFINE_GUID(DIID_ChartAxisAppearance,0xC0DE2430,0x2C18,0x4324,0x95,0xC6,0x3A,0x7F,0x6E,0xEA,0x48,0xE2);
159XTP_DEFINE_GUID(DIID_ChartDiagram2DAppearance,0xC0DE2430,0x2C3A,0x4620,0x91,0x34,0x01,0xAC,0xD1,0x90,0x61,0x52);
160XTP_DEFINE_GUID(DIID_ChartDiagram3DAppearance,0xC0DE2430,0x780F,0x4CB9,0xAC,0xE7,0x7C,0x56,0x85,0x09,0x76,0x90);
161XTP_DEFINE_GUID(DIID_ChartAppearance,0xC0DE2430,0x8766,0x4118,0x9B,0xCF,0xDA,0xE2,0x95,0x65,0x16,0xD2);
162XTP_DEFINE_GUID(DIID_ChartLegend,0xC0DE2430,0x10F1,0x44ED,0xBA,0x34,0x3D,0x4A,0x90,0x25,0x92,0x5B);
163XTP_DEFINE_GUID(DIID__DChartContent,0xC0DE2430,0x955D,0x4A75,0x9B,0x85,0x57,0xFD,0x6A,0x90,0x93,0x99);
164XTP_DEFINE_GUID(CLSID_ChartContent,0xC0DE2430,0xB617,0x4DD8,0x8F,0x30,0xB5,0x18,0x0D,0xFC,0xB6,0xFD);
165XTP_DEFINE_GUID(DIID_ChartElement,0xC0DE2430,0xCBC5,0x4FEC,0xBB,0xCC,0x7D,0xAE,0xF5,0x70,0x49,0xE1);
166XTP_DEFINE_GUID(DIID__DChartControl,0xC0DE2430,0x17E8,0x4623,0xA2,0x45,0xD6,0xD9,0x1B,0x30,0xD6,0x0F);
167XTP_DEFINE_GUID(DIID__DChartControlEvents,0xC0DE2430,0x9F75,0x41A0,0x9A,0xAE,0xA3,0x33,0x10,0x26,0xCD,0x43);
168XTP_DEFINE_GUID(CLSID_ChartControl,0xC0DE2430,0xD95D,0x4B0E,0x93,0xDD,0xAF,0x06,0x86,0xF1,0x99,0xFF);
169XTP_DEFINE_GUID(DIID_IChartControlGlobalSettings,0xC0DE2430,0xFCE6,0x41D2,0x92,0x5F,0x31,0xEC,0x81,0x72,0xF9,0x9E);
170XTP_DEFINE_GUID(CLSID_ChartControlGlobalSettings,0xC0DE2430,0x0821,0x467F,0x90,0x0D,0x38,0x76,0x4B,0x8E,0xD4,0x46);
171
172#undef XTP_DEFINE_GUID
173
174// clang-format on
175
176#endif // __XTPChartIIDs_H__


Toolkit Pro: XTPChartLegend.h File Reference

  • Source
  • Chart
Classes | Enumerations
XTPChartLegend.h File Reference

Go to the source code of this file.

Classes

class CXTPChartLegend
This class represents a chart legend as a kind of chart element. More...

Enumerations

enum XTPChartLegendDirection { xtpChartLegendTopToBottom , xtpChartLegendLeftToRight }
Enumerates the legend orientation. More...
enum XTPChartLegendAlignment {
xtpChartLegendNearOutside , xtpChartLegendNear , xtpChartLegendCenter , xtpChartLegendFar ,
xtpChartLegendFarOutside
}
Enumerates the legend alignment. More...
enum XTPChartLegendSortDirection {
xtpChartLegendNone , xtpChartLegendMinToMax , xtpChartLegendMaxToMin , xtpChartLegendAsc ,
xtpChartLegendDesc
}
Sort the legend strings. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Enumeration Type Documentation

◆ XTPChartLegendAlignment

enum XTPChartLegendAlignment

Enumerates the legend alignment.

Enumerator
xtpChartLegendNearOutside | The legend is placed out side of the chart, near the primary Y axis.
xtpChartLegendNear | The legend is placed inside of the chart, near the primary Y axis.
xtpChartLegendCenter | The legend is placed at the center of the chart.
xtpChartLegendFar | The legend is placed inside of the chart, near the secondary Y axis.
xtpChartLegendFarOutside | The legend is placed outside of the chart, near the secondary Y axis.

◆ XTPChartLegendDirection

enum XTPChartLegendDirection

Enumerates the legend orientation.

Enumerator
xtpChartLegendTopToBottom | The legend items are arranged from top to bottom.
xtpChartLegendLeftToRight | The legend items are arranged from left to right.

◆ XTPChartLegendSortDirection

enum XTPChartLegendSortDirection

Sort the legend strings.

Enumerator
xtpChartLegendNone | The legend items no sorting.
xtpChartLegendMinToMax | The legend items are sorting minimum first.
xtpChartLegendMaxToMin | The legend items are sorting maximum first.
xtpChartLegendAsc | The legend items are sorting ascending.
xtpChartLegendDesc | The legend items are sorting descending.


Toolkit Pro: XTPChartLegendItem.h File Reference

  • Source
  • Chart
Classes
XTPChartLegendItem.h File Reference

Go to the source code of this file.

Classes

class CXTPChartLegendItemView
CXTPChartLegendItemView is an abstract base class which represents a chart legend item. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartLegendView.h File Reference

  • Source
  • Chart
Classes
XTPChartLegendView.h File Reference

Go to the source code of this file.

Classes

class CXTPChartLegendView
This class abstracts the view of a legend and its child items in a bounding rectangle context. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartObjectFactory.h File Reference

  • Source
  • Chart
XTPChartObjectFactory.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartPanel.h File Reference

  • Source
  • Chart
Classes
XTPChartPanel.h File Reference

Go to the source code of this file.

Classes

class | CXTPChartPanel
This class abstracts a chart panel. More...
class | CXTPChartPanelCollection
This class abstracts a chart panel collection. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartSeries.h File Reference

  • Source
  • Chart
Classes
XTPChartSeries.h File Reference

Go to the source code of this file.

Classes

class | CXTPChartSeries
This class represents a series in the chart, which is a kind of CXTPChartElement. More...
class | CXTPChartSeriesCollection
This class represents the collection of series in the chart, which is a kind of CXTPChartElement. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartSeriesLabel.h File Reference

  • Source
  • Chart
Classes
XTPChartSeriesLabel.h File Reference

Go to the source code of this file.

Classes

class CXTPChartSeriesLabel
This class abstracts the label of a series. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartSeriesPoint.h File Reference

  • Source
  • Chart
Classes
XTPChartSeriesPoint.h File Reference

Go to the source code of this file.

Classes

class | CXTPChartSeriesPoint
CXTPChartSeriesPoint is a kind of CXTPChartElement. More...
class | CXTPChartSeriesPointCollection
CXTPChartSeriesPointCollection class represents a collection of chart series points. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartSeriesPointView.h File Reference

  • Source
  • Chart
Classes
XTPChartSeriesPointView.h File Reference

Go to the source code of this file.

Classes

class CXTPChartSeriesPointView
Represents chart series point view. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartSeriesStyle.h File Reference

  • Source
  • Chart
Classes
XTPChartSeriesStyle.h File Reference

Go to the source code of this file.

Classes

class CXTPChartSeriesStyle
CXTPChartSeriesStyle is a CXTPChartElement derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartSeriesView.h File Reference

  • Source
  • Chart
XTPChartSeriesView.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartTitle.h File Reference

  • Source
  • Chart
Classes | Enumerations
XTPChartTitle.h File Reference

Go to the source code of this file.

Classes

class | CXTPChartTitle
This class represents a chart title. More...
class | CXTPChartTitleCollection
CXTPChartTitleCollection represents a collection of chart titles. More...

Enumerations

enum XTPChartDocking { xtpChartDockTop , xtpChartDockBottom , xtpChartDockLeft , xtpChartDockRight }
Specifies chart docking direction. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Enumeration Type Documentation

◆ XTPChartDocking

enum XTPChartDocking

Specifies chart docking direction.

Enumerator
xtpChartDockTop | Specifies top docking direction.
xtpChartDockBottom | Specifies bottom docking direction.
xtpChartDockLeft | Specifies left docking direction.
xtpChartDockRight | Specifies right docking direction.


Toolkit Pro: XTPChartTitleView.h File Reference

  • Source
  • Chart
XTPChartTitleView.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPChartTrendline.h File Reference

  • Source
  • Chart
Enumerations
XTPChartTrendline.h File Reference

Go to the source code of this file.

Enumerations

enum XTPChartSeriesTrendlineType {
xtpChartSeriesTrendlineTypeNone , xtpChartSeriesTrendlineTypeLinear , xtpChartSeriesTrendlineTypeMovingAverageSimple , xtpChartSeriesTrendlineTypeMinimum ,
xtpChartSeriesTrendlineTypeMaximum
}
Defines a trendline series type. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Enumeration Type Documentation

◆ XTPChartSeriesTrendlineType

enum XTPChartSeriesTrendlineType

Defines a trendline series type.

Enumerator
xtpChartSeriesTrendlineTypeNone | No trendline.
xtpChartSeriesTrendlineTypeLinear | Specifies a linear trendline.
xtpChartSeriesTrendlineTypeMovingAverageSimple | Specifies a simple moving average trendline.
xtpChartSeriesTrendlineTypeMinimum | Specifies a minimum value trendline.
xtpChartSeriesTrendlineTypeMaximum | Specifies a maximum value trendline.


Toolkit Pro: CommandBars Directory Reference

  • Source
  • CommandBars
CommandBars Directory Reference

Directories

ColorSets
Customize
Frame
Gallery
MessageBar
Progress
ScrollBar
Slider
StatusBar
TabClient
Themes

Files

XTPCommandBar.h
XTPCommandBarAnimation.h
XTPCommandBarKeyboardTip.h
XTPCommandBarList.h
XTPCommandBars.h
XTPCommandBarsColorSet.h
XTPCommandBarsContextMenus.h
XTPCommandBarsDefines.h
XTPCommandBarsIIDs.h
XTPCommandBarsOptions.h
XTPControl.h
XTPControlButton.h
XTPControlComboBox.h
XTPControlComboBoxExt.h
XTPControlComboBoxGalleryPopupBar.h
XTPControlCustom.h
XTPControlEdit.h
XTPControlExt.h
XTPControlGallery.h
XTPControlListBox.h
XTPControlPopup.h
XTPControlPopupColor.h
XTPControlProgress.h
XTPControls.h
XTPControlScrollBar.h
XTPControlSlider.h
XTPDialogBar.h
XTPDialogBase.h
XTPDockBar.h
XTPDockContext.h
XTPDockState.h
XTPFrameWnd.h
XTPImageEditor.h
XTPKeyboardManager.h
XTPMenuBar.h
XTPMenuTitleBar.h
XTPMiniToolBar.h
XTPMouseManager.h
XTPPaintManager.h
XTPPopupBar.h
XTPPreviewView.h
XTPReBar.h
XTPRecentFileList.h
XTPShortcutManager.h
XTPTabClientWnd.h
XTPTabToolBar.h
XTPToolBar.h


Toolkit Pro: ColorSets Directory Reference

  • Source
  • CommandBars
  • ColorSets
ColorSets Directory Reference

Files

XTPCommandBarsColorSetOffice2013.h
XTPCommandBarsColorSetVisualStudio2012.h


Toolkit Pro: XTPCommandBarsColorSetOffice2013.h File Reference

  • Source
  • CommandBars
  • ColorSets
Classes
XTPCommandBarsColorSetOffice2013.h File Reference

Go to the source code of this file.

Classes

class | CXTPColorSetStateButton
Base class used to define various state colors used by command bar buttons text, background and border. More...
class | CXTPColorSetStateMenu
Color set class used to define various state colors used by command bar menus. More...
class | CXTPColorSetStateMenuTitleBar
Color set class used to define various state colors used by command bar menu title bars. More...
class | CXTPColorSetStateRibbon
Color set class used to define various state colors used by command bar ribbon. More...
class | CXTPColorSetStateToolbar
Color set class used to define various state colors used by command bar toolbars. More...
class | CXTPColorSetStateCheckMark
Helper class used to define various state colors used by command bar check marks foreground and background. More...
class | CXTPColorSetStateComboBox
Helper class used to define various state colors used by command bar glyphs. More...
class | CXTPColorSetStateCheckBox
Helper class used to define various state colors used by check box and radio button controls. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPCommandBarsColorSetVisualStudio2012.h File Reference

  • Source
  • CommandBars
  • ColorSets
XTPCommandBarsColorSetVisualStudio2012.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: Customize Directory Reference

  • Source
  • CommandBars
  • Customize
Customize Directory Reference

Files

XTPCustomizePageCommands.h
XTPCustomizePageKeyboard.h
XTPCustomizePageMenus.h
XTPCustomizePageOptions.h
XTPCustomizePageToolbars.h
XTPCustomizeSheet.h
XTPCustomizeTools.h


Toolkit Pro: XTPCustomizePageCommands.h File Reference

  • Source
  • CommandBars
  • Customize
Classes | Typedefs
XTPCustomizePageCommands.h File Reference

Go to the source code of this file.

Classes

struct | XTP_COMMANDBARS_CATEGORYINFO
This structure stores categories for CXTPCustomizeCommandsPage and CXTPCustomizeKeyboardPage option pages. More...
class | CXTPCustomizeCommandsListBox
List of the commands. More...
class | CXTPCustomizeCommandsPage
CXTPCustomizeCommandsPage is a CPropertyPage derived class. More...

Typedefs

typedef CArray< XTP_COMMANDBARS_CATEGORYINFO *, XTP_COMMANDBARS_CATEGORYINFO * > CXTPCommandBarsCategoryArray
This array is used by the CXTPCustomizeCommandsPage class for maintaining a list of XTP_COMMANDBARS_CATEGORYINFO structures.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Typedef Documentation

◆ CXTPCommandBarsCategoryArray

typedef CArray<XTP_COMMANDBARS_CATEGORYINFO*, XTP_COMMANDBARS_CATEGORYINFO*> CXTPCommandBarsCategoryArray

This array is used by the CXTPCustomizeCommandsPage class for maintaining a list of XTP_COMMANDBARS_CATEGORYINFO structures.

See also
CXTPCustomizeCommandsPage


Toolkit Pro: XTPCustomizePageKeyboard.h File Reference

  • Source
  • CommandBars
  • Customize
Classes
XTPCustomizePageKeyboard.h File Reference

Go to the source code of this file.

Classes

class CXTPCustomizeKeyboardPage
CXTPCustomizeKeyboardPage is a CPropertyPage derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPCustomizePageMenus.h File Reference

  • Source
  • CommandBars
  • Customize
Classes
XTPCustomizePageMenus.h File Reference

Go to the source code of this file.

Classes

class CXTPCustomizeMenusPage
CXTPCustomizeMenusPage is a CPropertyPage derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPCustomizePageOptions.h File Reference

  • Source
  • CommandBars
  • Customize
Classes
XTPCustomizePageOptions.h File Reference

Go to the source code of this file.

Classes

class | CXTPGroupLine
CXTPGroupLine is a CStatic derived class. More...
class | CXTPCustomizeOptionsPage
CXTPCustomizeOptionsPage is a CPropertyPage derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPCustomizePageToolbars.h File Reference

  • Source
  • CommandBars
  • Customize
Classes
XTPCustomizePageToolbars.h File Reference

Go to the source code of this file.

Classes

class CXTPCustomizeToolbarsPage
CXTPCustomizeToolbarsPage is a CPropertyPage derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPCustomizeSheet.h File Reference

  • Source
  • CommandBars
  • Customize
Classes
XTPCustomizeSheet.h File Reference

Go to the source code of this file.

Classes

class CXTPCustomizeSheet
CXTPCustomizeSheet is a CPropertySheet derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPCustomizeTools.h File Reference

  • Source
  • CommandBars
  • Customize
XTPCustomizeTools.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: Frame Directory Reference

  • Source
  • CommandBars
  • Frame
Frame Directory Reference

Files

XTPFrameHook.h
XTPFramePaintManager.h
XTPFrameThemeModernUI.h
XTPFrameThemeNativeWindows10.h
XTPFrameThemeNativeWindows11.h
XTPFrameThemeOffice2007.h
XTPFrameThemeOffice2007System.h
XTPFrameThemeOffice2013.h
XTPFrameThemeVisualStudio2012.h
XTPFrameThemeVisualStudio2015.h
XTPFrameThemeVisualStudio2017.h
XTPFrameThemeVisualStudio2019.h
XTPFrameThemeVisualStudio2022.h


Toolkit Pro: XTPFrameHook.h File Reference

  • Source
  • CommandBars
  • Frame
Classes
XTPFrameHook.h File Reference

Go to the source code of this file.

Classes

class CXTPCommandBarsFrameHook
CXTPCommandBarsFrameHook is a CXTPHookManagerHookAble derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPFramePaintManager.h File Reference

  • Source
  • CommandBars
  • Frame
Classes
XTPFramePaintManager.h File Reference

Go to the source code of this file.

Classes

class CXTPFramePaintManager
Paint manager for the Office 2007 style window frame. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPFrameThemeModernUI.h File Reference

  • Source
  • CommandBars
  • Frame
XTPFrameThemeModernUI.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPFrameThemeNativeWindows10.h File Reference

  • Source
  • CommandBars
  • Frame
XTPFrameThemeNativeWindows10.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPFrameThemeNativeWindows11.h File Reference

  • Source
  • CommandBars
  • Frame
XTPFrameThemeNativeWindows11.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPFrameThemeOffice2007.h File Reference

  • Source
  • CommandBars
  • Frame
XTPFrameThemeOffice2007.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPFrameThemeOffice2007System.h File Reference

  • Source
  • CommandBars
  • Frame
Classes
XTPFrameThemeOffice2007System.h File Reference

Go to the source code of this file.

Classes

class CXTPFrameThemeOffice2007System
The CXTPFrameThemeOffice2007System class is used to enable a system style theme for Command Bars. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPFrameThemeOffice2013.h File Reference

  • Source
  • CommandBars
  • Frame
XTPFrameThemeOffice2013.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPFrameThemeVisualStudio2012.h File Reference

  • Source
  • CommandBars
  • Frame
XTPFrameThemeVisualStudio2012.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPFrameThemeVisualStudio2015.h File Reference

  • Source
  • CommandBars
  • Frame
XTPFrameThemeVisualStudio2015.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPFrameThemeVisualStudio2017.h File Reference

  • Source
  • CommandBars
  • Frame
XTPFrameThemeVisualStudio2017.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPFrameThemeVisualStudio2019.h File Reference

  • Source
  • CommandBars
  • Frame
XTPFrameThemeVisualStudio2019.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPFrameThemeVisualStudio2022.h File Reference

  • Source
  • CommandBars
  • Frame
XTPFrameThemeVisualStudio2022.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: Gallery Directory Reference

  • Source
  • CommandBars
  • Gallery
Gallery Directory Reference

Files

XTPControlGalleryItem.h
XTPControlGalleryItems.h
XTPControlGalleryNativeWindows10Theme.h
XTPControlGalleryNativeWindows11Theme.h
XTPControlGalleryOffice2013Theme.h
XTPControlGalleryResourceTheme.h
XTPControlGalleryVisualStudio2015Theme.h
XTPControlGalleryVisualStudio2017Theme.h
XTPControlGalleryVisualStudio2019Theme.h
XTPControlGalleryVisualStudio2022Theme.h
XTPGalleryListBox.h


Toolkit Pro: XTPControlGalleryItem.h File Reference

  • Source
  • CommandBars
  • Gallery
Classes
XTPControlGalleryItem.h File Reference

Go to the source code of this file.

Classes

class CXTPControlGalleryItem
CXTPControlGalleryItem is a CXTPCmdTarget derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPControlGalleryItems.h File Reference

  • Source
  • CommandBars
  • Gallery
Classes
XTPControlGalleryItems.h File Reference

Go to the source code of this file.

Classes

class CXTPControlGalleryItems
CXTPControlGalleryItems is a CXTPCmdTarget derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPControlGalleryNativeWindows10Theme.h File Reference

  • Source
  • CommandBars
  • Gallery
Classes
XTPControlGalleryNativeWindows10Theme.h File Reference

Go to the source code of this file.

Classes

class CXTPControlGalleryNativeWindows10Theme
The CXTPControlGalleryResourceTheme class is used to enable a Gallery Native Windows 10 style theme for Command Bars. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPControlGalleryNativeWindows11Theme.h File Reference

  • Source
  • CommandBars
  • Gallery
Classes
XTPControlGalleryNativeWindows11Theme.h File Reference

Go to the source code of this file.

Classes

class CXTPControlGalleryNativeWindows11Theme
The CXTPControlGalleryResourceTheme class is used to enable a Gallery Native Windows 10 style theme for Command Bars. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPControlGalleryOffice2013Theme.h File Reference

  • Source
  • CommandBars
  • Gallery
Classes
XTPControlGalleryOffice2013Theme.h File Reference

Go to the source code of this file.

Classes

class CXTPControlGalleryOffice2013Theme
The CXTPControlGalleryResourceTheme class is used to enable a Gallery Office 2013 style theme for Command Bars. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPControlGalleryResourceTheme.h File Reference

  • Source
  • CommandBars
  • Gallery
Classes
XTPControlGalleryResourceTheme.h File Reference

Go to the source code of this file.

Classes

class CXTPControlGalleryResourceTheme
The CXTPControlGalleryResourceTheme class is used to enable a Gallery Resource style theme for Command Bars. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPControlGalleryVisualStudio2015Theme.h File Reference

  • Source
  • CommandBars
  • Gallery
Classes
XTPControlGalleryVisualStudio2015Theme.h File Reference

Go to the source code of this file.

Classes

class CXTPControlGalleryVisualStudio2015Theme
The CXTPControlGalleryResourceTheme class is used to enable a Gallery Visual Studio 2015 style theme for Command Bars. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPControlGalleryVisualStudio2017Theme.h File Reference

  • Source
  • CommandBars
  • Gallery
Classes
XTPControlGalleryVisualStudio2017Theme.h File Reference

Go to the source code of this file.

Classes

class CXTPControlGalleryVisualStudio2017Theme
The CXTPControlGalleryResourceTheme class is used to enable a Gallery Visual Studio 2017 style theme for Command Bars. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPControlGalleryVisualStudio2019Theme.h File Reference

  • Source
  • CommandBars
  • Gallery
Classes
XTPControlGalleryVisualStudio2019Theme.h File Reference

Go to the source code of this file.

Classes

class CXTPControlGalleryVisualStudio2019Theme
The CXTPControlGalleryResourceTheme class is used to enable a Gallery Visual Studio 2019 style theme for Command Bars. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPControlGalleryVisualStudio2022Theme.h File Reference

  • Source
  • CommandBars
  • Gallery
Classes
XTPControlGalleryVisualStudio2022Theme.h File Reference

Go to the source code of this file.

Classes

class CXTPControlGalleryVisualStudio2022Theme
The CXTPControlGalleryResourceTheme class is used to enable a Gallery Visual Studio 2022 style theme for Command Bars. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPGalleryListBox.h File Reference

  • Source
  • CommandBars
  • Gallery
XTPGalleryListBox.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: MessageBar Directory Reference

  • Source
  • CommandBars
  • MessageBar
MessageBar Directory Reference

Files

XTPMessageBar.h
XTPMessageBarPaintManager.h
XTPMessageBarThemeNativeWindows10.h
XTPMessageBarThemeNativeWindows11.h
XTPMessageBarThemeOffice2003.h
XTPMessageBarThemeOffice2010.h
XTPMessageBarThemeOffice2013.h
XTPMessageBarThemeResource.h
XTPMessageBarThemeVisualStudio2015.h
XTPMessageBarThemeVisualStudio2017.h
XTPMessageBarThemeVisualStudio2019.h
XTPMessageBarThemeVisualStudio2022.h


Toolkit Pro: XTPMessageBar.h File Reference

  • Source
  • CommandBars
  • MessageBar
Classes
XTPMessageBar.h File Reference

Go to the source code of this file.

Classes

class | CXTPMessageBarButton
CXTPMessageBarButton is a standalone class. More...
class | CXTPMessageBar
CXTPMessageBar is a CControlBar derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMessageBarPaintManager.h File Reference

  • Source
  • CommandBars
  • MessageBar
Classes
XTPMessageBarPaintManager.h File Reference

Go to the source code of this file.

Classes

class CXTPMessageBarPaintManager
The CXTPMessageBarPaintManager class is used by the message bar to perform standard paint routines. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMessageBarThemeNativeWindows10.h File Reference

  • Source
  • CommandBars
  • MessageBar
Classes
XTPMessageBarThemeNativeWindows10.h File Reference

Go to the source code of this file.

Classes

class CXTPMessageBarThemeNativeWindows10
The CXTPMessageBarThemeNativeWindows10 class is used by the message bar to draw a Native Windows 10 style message bar. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMessageBarThemeNativeWindows11.h File Reference

  • Source
  • CommandBars
  • MessageBar
Classes
XTPMessageBarThemeNativeWindows11.h File Reference

Go to the source code of this file.

Classes

class CXTPMessageBarThemeNativeWindows11
The CXTPMessageBarThemeNativeWindows11 class is used by the message bar to draw a Native Windows 10 style message bar. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMessageBarThemeOffice2003.h File Reference

  • Source
  • CommandBars
  • MessageBar
XTPMessageBarThemeOffice2003.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMessageBarThemeOffice2010.h File Reference

  • Source
  • CommandBars
  • MessageBar
Classes
XTPMessageBarThemeOffice2010.h File Reference

Go to the source code of this file.

Classes

class CXTPMessageBarThemeOffice2010
The CXTPMessageBarThemeOffice2010 class is used by the message bar to draw an Office 2010 style message bar. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMessageBarThemeOffice2013.h File Reference

  • Source
  • CommandBars
  • MessageBar
Classes
XTPMessageBarThemeOffice2013.h File Reference

Go to the source code of this file.

Classes

class CXTPMessageBarThemeOffice2013
The CXTPMessageBarThemeOffice2013 class is used by the message bar to draw an Office 2013 style message bar. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMessageBarThemeResource.h File Reference

  • Source
  • CommandBars
  • MessageBar
XTPMessageBarThemeResource.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMessageBarThemeVisualStudio2015.h File Reference

  • Source
  • CommandBars
  • MessageBar
Classes
XTPMessageBarThemeVisualStudio2015.h File Reference

Go to the source code of this file.

Classes

class CXTPMessageBarThemeVisualStudio2015
The CXTPMessageBarThemeVisualStudio2015 class is used by the message bar to draw a Visual Studio 2015 style message bar. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMessageBarThemeVisualStudio2017.h File Reference

  • Source
  • CommandBars
  • MessageBar
Classes
XTPMessageBarThemeVisualStudio2017.h File Reference

Go to the source code of this file.

Classes

class CXTPMessageBarThemeVisualStudio2017
The CXTPMessageBarThemeVisualStudio2017 class is used by the message bar to draw a Visual Studio 2017 style message bar. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMessageBarThemeVisualStudio2019.h File Reference

  • Source
  • CommandBars
  • MessageBar
Classes
XTPMessageBarThemeVisualStudio2019.h File Reference

Go to the source code of this file.

Classes

class CXTPMessageBarThemeVisualStudio2019
The CXTPMessageBarThemeVisualStudio2019 class is used by the message bar to draw a Visual Studio 2019 style message bar. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMessageBarThemeVisualStudio2022.h File Reference

  • Source
  • CommandBars
  • MessageBar
Classes
XTPMessageBarThemeVisualStudio2022.h File Reference

Go to the source code of this file.

Classes

class CXTPMessageBarThemeVisualStudio2022
The CXTPMessageBarThemeVisualStudio2022 class is used by the message bar to draw a Visual Studio 2022 style message bar. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: Progress Directory Reference

  • Source
  • CommandBars
  • Progress
Progress Directory Reference

Files

XTPProgressPaintManager.h
XTPProgressThemeNativeWindows10.h
XTPProgressThemeNativeWindows11.h
XTPProgressThemeOffice2013.h
XTPProgressThemeResource.h
XTPProgressThemeVisualStudio2015.h
XTPProgressThemeVisualStudio2017.h
XTPProgressThemeVisualStudio2019.h
XTPProgressThemeVisualStudio2022.h
XTPProgressThemeWindowsUx.h


Toolkit Pro: XTPProgressPaintManager.h File Reference

  • Source
  • CommandBars
  • Progress
Classes
XTPProgressPaintManager.h File Reference

Go to the source code of this file.

Classes

class CXTPProgressPaintManager
CXTPProgressPaintManager object. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPProgressThemeNativeWindows10.h File Reference

  • Source
  • CommandBars
  • Progress
Classes
XTPProgressThemeNativeWindows10.h File Reference

Go to the source code of this file.

Classes

class CXTPProgressThemeNativeWindows10
CXTPProgressThemeNativeWindows10 object. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPProgressThemeNativeWindows11.h File Reference

  • Source
  • CommandBars
  • Progress
Classes
XTPProgressThemeNativeWindows11.h File Reference

Go to the source code of this file.

Classes

class CXTPProgressThemeNativeWindows11
CXTPProgressThemeNativeWindows11 object. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPProgressThemeOffice2013.h File Reference

  • Source
  • CommandBars
  • Progress
Classes
XTPProgressThemeOffice2013.h File Reference

Go to the source code of this file.

Classes

class CXTPProgressThemeOffice2013
CXTPProgressThemeOffice2013 object. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPProgressThemeResource.h File Reference

  • Source
  • CommandBars
  • Progress
XTPProgressThemeResource.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPProgressThemeVisualStudio2015.h File Reference

  • Source
  • CommandBars
  • Progress
Classes
XTPProgressThemeVisualStudio2015.h File Reference

Go to the source code of this file.

Classes

class CXTPProgressThemeVisualStudio2015
CXTPProgressThemeVisualStudio2015 object. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPProgressThemeVisualStudio2017.h File Reference

  • Source
  • CommandBars
  • Progress
Classes
XTPProgressThemeVisualStudio2017.h File Reference

Go to the source code of this file.

Classes

class CXTPProgressThemeVisualStudio2017
CXTPProgressThemeVisualStudio2017 object. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPProgressThemeVisualStudio2019.h File Reference

  • Source
  • CommandBars
  • Progress
Classes
XTPProgressThemeVisualStudio2019.h File Reference

Go to the source code of this file.

Classes

class CXTPProgressThemeVisualStudio2019
CXTPProgressThemeVisualStudio2019 object. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPProgressThemeVisualStudio2022.h File Reference

  • Source
  • CommandBars
  • Progress
Classes
XTPProgressThemeVisualStudio2022.h File Reference

Go to the source code of this file.

Classes

class CXTPProgressThemeVisualStudio2022
CXTPProgressThemeVisualStudio2022 object. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPProgressThemeWindowsUx.h File Reference

  • Source
  • CommandBars
  • Progress
XTPProgressThemeWindowsUx.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: ScrollBar Directory Reference

  • Source
  • CommandBars
  • ScrollBar
ScrollBar Directory Reference

Files

XTPCommandBarScrollBarCtrl.h


Toolkit Pro: XTPCommandBarScrollBarCtrl.h File Reference

  • Source
  • CommandBars
  • ScrollBar
Classes
XTPCommandBarScrollBarCtrl.h File Reference

Go to the source code of this file.

Classes

class CXTPCommandBarScrollBarCtrl
CXTPCommandBarScrollBarCtrl is a CScrollBar derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: Slider Directory Reference

  • Source
  • CommandBars
  • Slider
Slider Directory Reference

Files

XTPSliderPaintManager.h
XTPSliderThemeNativeWindows10.h
XTPSliderThemeNativeWindows11.h
XTPSliderThemeOffice2007System.h
XTPSliderThemeOffice2013.h
XTPSliderThemeResource.h
XTPSliderThemeVisualStudio2015.h
XTPSliderThemeVisualStudio2017.h
XTPSliderThemeVisualStudio2019.h
XTPSliderThemeVisualStudio2022.h


Toolkit Pro: XTPSliderPaintManager.h File Reference

  • Source
  • CommandBars
  • Slider
Classes
XTPSliderPaintManager.h File Reference

Go to the source code of this file.

Classes

class CXTPSliderPaintManager
Paint manager for the slider control. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPSliderThemeNativeWindows10.h File Reference

  • Source
  • CommandBars
  • Slider
XTPSliderThemeNativeWindows10.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPSliderThemeNativeWindows11.h File Reference

  • Source
  • CommandBars
  • Slider
XTPSliderThemeNativeWindows11.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPSliderThemeOffice2007System.h File Reference

  • Source
  • CommandBars
  • Slider
XTPSliderThemeOffice2007System.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPSliderThemeOffice2013.h File Reference

  • Source
  • CommandBars
  • Slider
XTPSliderThemeOffice2013.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPSliderThemeResource.h File Reference

  • Source
  • CommandBars
  • Slider
XTPSliderThemeResource.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPSliderThemeVisualStudio2015.h File Reference

  • Source
  • CommandBars
  • Slider
XTPSliderThemeVisualStudio2015.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPSliderThemeVisualStudio2017.h File Reference

  • Source
  • CommandBars
  • Slider
XTPSliderThemeVisualStudio2017.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPSliderThemeVisualStudio2019.h File Reference

  • Source
  • CommandBars
  • Slider
XTPSliderThemeVisualStudio2019.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPSliderThemeVisualStudio2022.h File Reference

  • Source
  • CommandBars
  • Slider
XTPSliderThemeVisualStudio2022.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: StatusBar Directory Reference

  • Source
  • CommandBars
  • StatusBar
StatusBar Directory Reference

Directories

Panes

Files

XTPStatusBar.h
XTPStatusBarColorSet.h
XTPStatusBarPaintManager.h
XTPStatusBarThemeNativeWindows10.h
XTPStatusBarThemeNativeWindows11.h
XTPStatusBarThemeOffice2003.h
XTPStatusBarThemeOffice2013.h
XTPStatusBarThemeOfficeXP.h
XTPStatusBarThemeResource.h
XTPStatusBarThemeVisualStudio2010.h
XTPStatusBarThemeVisualStudio2012.h
XTPStatusBarThemeVisualStudio2015.h
XTPStatusBarThemeVisualStudio2017.h
XTPStatusBarThemeVisualStudio2019.h
XTPStatusBarThemeVisualStudio2022.h


Toolkit Pro: Panes Directory Reference

  • Source
  • CommandBars
  • StatusBar
  • Panes
Panes Directory Reference

Files

XTPStatusBarPane.h
XTPStatusBarPaneProgress.h
XTPStatusBarPaneScrollBar.h
XTPStatusBarPaneSlider.h
XTPStatusBarPaneSwitch.h


Toolkit Pro: XTPStatusBarPane.h File Reference

  • Source
  • CommandBars
  • StatusBar
  • Panes
Classes
XTPStatusBarPane.h File Reference

Go to the source code of this file.

Classes

class CXTPStatusBarPane
CXTPStatusBarPane is a CXTPCmdTarget derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPStatusBarPaneProgress.h File Reference

  • Source
  • CommandBars
  • StatusBar
  • Panes
Classes
XTPStatusBarPaneProgress.h File Reference

Go to the source code of this file.

Classes

class CXTPStatusBarProgressPane
CXTPStatusBarProgressPane is a CXTPStatusBarPane derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPStatusBarPaneScrollBar.h File Reference

  • Source
  • CommandBars
  • StatusBar
  • Panes
Classes
XTPStatusBarPaneScrollBar.h File Reference

Go to the source code of this file.

Classes

class CXTPStatusBarScrollBarPane
CXTPStatusBarScrollBarPane is a CXTPStatusBarPane derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPStatusBarPaneSlider.h File Reference

  • Source
  • CommandBars
  • StatusBar
  • Panes
Classes
XTPStatusBarPaneSlider.h File Reference

Go to the source code of this file.

Classes

class CXTPStatusBarSliderPane
CXTPStatusBarSliderPane is a CXTPStatusBarPane derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPStatusBarPaneSwitch.h File Reference

  • Source
  • CommandBars
  • StatusBar
  • Panes
Classes
XTPStatusBarPaneSwitch.h File Reference

Go to the source code of this file.

Classes

class | CXTPStatusBarSwitchPane
CXTPStatusBarSwitchPane is a CXTPStatusBarPane derived class. More...
struct | CXTPStatusBarSwitchPane::SWITCH
Holds status bar pane switch properties. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPStatusBar.h File Reference

  • Source
  • CommandBars
  • StatusBar
Classes
XTPStatusBar.h File Reference

Go to the source code of this file.

Classes

class CXTPStatusBar
CXTPStatusBar is a CControlBar derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPStatusBarColorSet.h File Reference

  • Source
  • CommandBars
  • StatusBar
XTPStatusBarColorSet.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPStatusBarPaintManager.h File Reference

  • Source
  • CommandBars
  • StatusBar
XTPStatusBarPaintManager.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPStatusBarThemeNativeWindows10.h File Reference

  • Source
  • CommandBars
  • StatusBar
Classes
XTPStatusBarThemeNativeWindows10.h File Reference

Go to the source code of this file.

Classes

class CXTPStatusBarThemeNativeWindows10
The CXTPStatusBarThemeNativeWindows10 class is used to enable the Native Windows 10 style theme for the status bar. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPStatusBarThemeNativeWindows11.h File Reference

  • Source
  • CommandBars
  • StatusBar
Classes
XTPStatusBarThemeNativeWindows11.h File Reference

Go to the source code of this file.

Classes

class CXTPStatusBarThemeNativeWindows11
The CXTPStatusBarThemeNativeWindows11 class is used to enable the Native Windows 10 style theme for the status bar. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPStatusBarThemeOffice2003.h File Reference

  • Source
  • CommandBars
  • StatusBar
XTPStatusBarThemeOffice2003.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPStatusBarThemeOffice2013.h File Reference

  • Source
  • CommandBars
  • StatusBar
Classes
XTPStatusBarThemeOffice2013.h File Reference

Go to the source code of this file.

Classes

class CXTPStatusBarThemeOffice2013
The CXTPStatusBarThemeVisualStudio2015 class is used to enable the Office 2013 style theme for the status bar. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPStatusBarThemeOfficeXP.h File Reference

  • Source
  • CommandBars
  • StatusBar
XTPStatusBarThemeOfficeXP.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPStatusBarThemeResource.h File Reference

  • Source
  • CommandBars
  • StatusBar
XTPStatusBarThemeResource.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPStatusBarThemeVisualStudio2010.h File Reference

  • Source
  • CommandBars
  • StatusBar
XTPStatusBarThemeVisualStudio2010.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPStatusBarThemeVisualStudio2012.h File Reference

  • Source
  • CommandBars
  • StatusBar
XTPStatusBarThemeVisualStudio2012.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPStatusBarThemeVisualStudio2015.h File Reference

  • Source
  • CommandBars
  • StatusBar
Classes
XTPStatusBarThemeVisualStudio2015.h File Reference

Go to the source code of this file.

Classes

class CXTPStatusBarThemeVisualStudio2015
The CXTPStatusBarThemeVisualStudio2015 class is used to enable the Visual Studio 2015 style theme for the status bar. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPStatusBarThemeVisualStudio2017.h File Reference

  • Source
  • CommandBars
  • StatusBar
Classes
XTPStatusBarThemeVisualStudio2017.h File Reference

Go to the source code of this file.

Classes

class CXTPStatusBarThemeVisualStudio2017
The CXTPStatusBarThemeVisualStudio2017 class is used to enable the Visual Studio 2017 style theme for the status bar. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPStatusBarThemeVisualStudio2019.h File Reference

  • Source
  • CommandBars
  • StatusBar
Classes
XTPStatusBarThemeVisualStudio2019.h File Reference

Go to the source code of this file.

Classes

class CXTPStatusBarThemeVisualStudio2019
The CXTPStatusBarThemeVisualStudio2019 class is used to enable the Visual Studio 2019 style theme for the status bar. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPStatusBarThemeVisualStudio2022.h File Reference

  • Source
  • CommandBars
  • StatusBar
Classes
XTPStatusBarThemeVisualStudio2022.h File Reference

Go to the source code of this file.

Classes

class CXTPStatusBarThemeVisualStudio2022
The CXTPStatusBarThemeVisualStudio2022 class is used to enable the Visual Studio 2022 style theme for the status bar. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: TabClient Directory Reference

  • Source
  • CommandBars
  • TabClient
TabClient Directory Reference

Files

XTPControlTabWorkspace.h
XTPTabClientContext.h
XTPTabClientDraggingContents.h
XTPTabClientSticker.h
XTPTearOffFrame.h


Toolkit Pro: XTPControlTabWorkspace.h File Reference

  • Source
  • CommandBars
  • TabClient
Classes
XTPControlTabWorkspace.h File Reference

Go to the source code of this file.

Classes

class CXTPControlTabWorkspace
TabWorkspace control. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTabClientContext.h File Reference

  • Source
  • CommandBars
  • TabClient
Classes
XTPTabClientContext.h File Reference

Go to the source code of this file.

Classes

class | CXTPAlphaWnd
CXTPTabClientAlphaWnd is CWnd derived class represents alpha context helper window. More...
class | CXTPTabClientContext
CXTPTabClientContext is a standalone class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTabClientDraggingContents.h File Reference

  • Source
  • CommandBars
  • TabClient
Classes
XTPTabClientDraggingContents.h File Reference

Go to the source code of this file.

Classes

class CXTPTabClientDraggingContents
Managers tab client dragging contents. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTabClientSticker.h File Reference

  • Source
  • CommandBars
  • TabClient
Classes | Enumerations
XTPTabClientSticker.h File Reference

Go to the source code of this file.

Classes

class | CXTPStickerBase
A sticker base control. More...
class | CXTPTabClientSticker
A tab client sticker control. More...

Enumerations

enum XTPTabClientStickerPart {
xtpTabClientStickerNone = 0 , xtpTabClientStickerLeft = 1 , xtpTabClientStickerRight = 2 , xtpTabClientStickerTop = 4 ,
xtpTabClientStickerBottom = 8 , xtpTabClientStickerCenter = 16
}
Identifies tab client sticker part. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Enumeration Type Documentation

◆ XTPTabClientStickerPart

enum XTPTabClientStickerPart

Identifies tab client sticker part.

Enumerator
xtpTabClientStickerNone | No docking stickers are displayed.
xtpTabClientStickerLeft | Display the docking sticker indicating the tab can be docked to the left.
xtpTabClientStickerRight | Display the docking sticker indicating the tab can be docked to the right.
xtpTabClientStickerTop | Display the docking sticker indicating the tab can be docked on the top.
xtpTabClientStickerBottom | Display the docking sticker indicating the tab can be docked on the bottom.
xtpTabClientStickerCenter | Display the docking sticker indicating the tab can be docked in the center.


Toolkit Pro: XTPTearOffFrame.h File Reference

  • Source
  • CommandBars
  • TabClient
Classes
XTPTearOffFrame.h File Reference

Go to the source code of this file.

Classes

class CXTPTearOffFrame
The class represents a floating torn off frame. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: Themes Directory Reference

  • Source
  • CommandBars
  • Themes
Themes Directory Reference

Files

XTPCommandBarsModernUITheme.h
XTPCommandBarsNativeWindows10Theme.h
XTPCommandBarsNativeWindows11Theme.h
XTPCommandBarsNativeXPTheme.h
XTPCommandBarsOffice2000Theme.h
XTPCommandBarsOffice2003Theme.h
XTPCommandBarsOffice2007SystemTheme.h
XTPCommandBarsOffice2013Theme.h
XTPCommandBarsOfficeXPTheme.h
XTPCommandBarsResourceTheme.h
XTPCommandBarsThemeMsMoney.h
XTPCommandBarsThemeRibbon.h
XTPCommandBarsVisualStudio2005Theme.h
XTPCommandBarsVisualStudio2008Theme.h
XTPCommandBarsVisualStudio2010Theme.h
XTPCommandBarsVisualStudio2012Theme.h
XTPCommandBarsVisualStudio2015Theme.h
XTPCommandBarsVisualStudio2017Theme.h
XTPCommandBarsVisualStudio2019Theme.h
XTPCommandBarsVisualStudio2022Theme.h
XTPCommandBarsVisualStudio6Theme.h


Toolkit Pro: XTPCommandBarsModernUITheme.h File Reference

  • Source
  • CommandBars
  • Themes
Classes
XTPCommandBarsModernUITheme.h File Reference

Go to the source code of this file.

Classes

class CXTPCommandBarsModernUITheme
The CXTPCommandBarsModernUITheme class is the base class for the Modern UI themes for Command Bars. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPCommandBarsNativeWindows10Theme.h File Reference

  • Source
  • CommandBars
  • Themes
Classes | Functions
XTPCommandBarsNativeWindows10Theme.h File Reference

Go to the source code of this file.

Classes

class CXTPCommandBarsNativeWindows10Theme
The CXTPCommandBarsNativeWindows10Theme class is used to enable a Native Windows 10 style theme for Command Bars. More...

Functions

_XTP_EXT_CLASS BOOL AFX_CDECL XTPSetNativeWindows10StateColor (CXTPCommandBars *pCommandBars, COLORREF clrState=COLORREF_NULL)
Call XTPSetNativeWindows10StateColor to set the border and status bar colors for this theme to indicate state changes.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Function Documentation

◆ XTPSetNativeWindows10StateColor()

_XTP_EXT_CLASS BOOL AFX_CDECL XTPSetNativeWindows10StateColor | ( | CXTPCommandBars * | pCommandBars,
 |  | COLORREF | clrState = COLORREF_NULL )

Call XTPSetNativeWindows10StateColor to set the border and status bar colors for this theme to indicate state changes.

This is similar to when Visual Studio 2015 opens a document or runs the debugger causing both the border and status bar colors to be updated.

Parameters
pCommandBars | Pointer to a valid CXTPCommandBars object.
clrState | RGB state color value to set. Use default COLORREF_NULL to reset colors to their default state.
Returns
TRUE if the colors were successfully updated, otherwise FALSE.


Toolkit Pro: XTPCommandBarsNativeWindows11Theme.h File Reference

  • Source
  • CommandBars
  • Themes
Classes | Functions
XTPCommandBarsNativeWindows11Theme.h File Reference

Go to the source code of this file.

Classes

class CXTPCommandBarsNativeWindows11Theme
The CXTPCommandBarsNativeWindows11Theme class is used to enable a Native Windows 10 style theme for Command Bars. More...

Functions

_XTP_EXT_CLASS BOOL AFX_CDECL XTPSetNativeWindows11StateColor (CXTPCommandBars *pCommandBars, COLORREF clrState=COLORREF_NULL)
Call XTPSetNativeWindows11StateColor to set the border and status bar colors for this theme to indicate state changes.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Function Documentation

◆ XTPSetNativeWindows11StateColor()

_XTP_EXT_CLASS BOOL AFX_CDECL XTPSetNativeWindows11StateColor | ( | CXTPCommandBars * | pCommandBars,
 |  | COLORREF | clrState = COLORREF_NULL )

Call XTPSetNativeWindows11StateColor to set the border and status bar colors for this theme to indicate state changes.

This is similar to when Visual Studio 2015 opens a document or runs the debugger causing both the border and status bar colors to be updated.

Parameters
pCommandBars | Pointer to a valid CXTPCommandBars object.
clrState | RGB state color value to set. Use default COLORREF_NULL to reset colors to their default state.
Returns
TRUE if the colors were successfully updated, otherwise FALSE.


Toolkit Pro: XTPCommandBarsNativeXPTheme.h File Reference

  • Source
  • CommandBars
  • Themes
Classes
XTPCommandBarsNativeXPTheme.h File Reference

Go to the source code of this file.

Classes

class CXTPCommandBarsNativeXPTheme
The CXTPCommandBarsNativeXPTheme class is used to enable a Native Windows XP style theme for Command Bars. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPCommandBarsOffice2000Theme.h File Reference

  • Source
  • CommandBars
  • Themes
Classes | Macros
XTPCommandBarsOffice2000Theme.h File Reference

Go to the source code of this file.

Classes

class CXTPCommandBarsOffice2000Theme
The CXTPCommandBarsOffice2000Theme class is used to enable an Office 2000 style theme for Command Bars. More...

Macros

#define CXTPDefaultTheme CXTPCommandBarsOffice2000Theme
Old name.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPCommandBarsOffice2003Theme.h File Reference

  • Source
  • CommandBars
  • Themes
Classes | Macros
XTPCommandBarsOffice2003Theme.h File Reference

Go to the source code of this file.

Classes

class CXTPCommandBarsOffice2003Theme
The CXTPCommandBarsOffice2003Theme class is used to enable an Office 2003 style theme for Command Bars. More...

Macros

#define CXTPOffice2003Theme CXTPCommandBarsOffice2003Theme
Old name.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPCommandBarsOffice2007SystemTheme.h File Reference

  • Source
  • CommandBars
  • Themes
XTPCommandBarsOffice2007SystemTheme.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPCommandBarsOffice2013Theme.h File Reference

  • Source
  • CommandBars
  • Themes
Classes | Enumerations
XTPCommandBarsOffice2013Theme.h File Reference

Go to the source code of this file.

Classes

class CXTPCommandBarsOffice2013Theme
The CXTPCommandBarsOffice2013Theme class is used to enable an Office 2013 style theme for Command Bars. More...

Enumerations

enum XTPBackImage {
XTPNone , XTPCalligraphy , XTPCirclesAndStripes , XTPCircuit ,
XTPClouds , XTPDoodleCircles , XTPDoodleDiamonds , XTPGeometry ,
XTPLunchBox , XTPSchoolSupplies , XTPSpring , XTPStars ,
XTPStraws , XTPTreeRings , XTPUnderWater
}
Defines a back image. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Enumeration Type Documentation

◆ XTPBackImage

enum XTPBackImage

Defines a back image.

Enumerator
XTPNone | Specifies no back image.
XTPCalligraphy | Specifies caligraphy back image.
XTPCirclesAndStripes | Specifies circle and stipes back image.
XTPCircuit | Specifies circuit back image.
XTPClouds | Specifies cluds back image.
XTPDoodleCircles | Specifies doodle circles back image.
XTPDoodleDiamonds | Specifies doodle diamonds back image.
XTPGeometry | Specifies geometry back image.
XTPLunchBox | Specifies lunch box back image.
XTPSchoolSupplies | Specifies school supplies back image.
XTPSpring | Specifies sptring back image.
XTPStars | Specifies stars back image.
XTPStraws | Specifies straws back image.
XTPTreeRings | Specifies tree rings back image.
XTPUnderWater | Specifies underwater back image.


Toolkit Pro: XTPCommandBarsOfficeXPTheme.h File Reference

  • Source
  • CommandBars
  • Themes
Classes
XTPCommandBarsOfficeXPTheme.h File Reference

Go to the source code of this file.

Classes

class CXTPCommandBarsOfficeXPTheme
The CXTPCommandBarsOfficeXPTheme class is used to enable an Office XP style theme for Command Bars. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPCommandBarsResourceTheme.h File Reference

  • Source
  • CommandBars
  • Themes
Classes
XTPCommandBarsResourceTheme.h File Reference

Go to the source code of this file.

Classes

class CXTPResourceTheme
The CXTPResourceTheme class is used to enable a resource style theme for Command Bars. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPCommandBarsThemeMsMoney.h File Reference

  • Source
  • CommandBars
  • Themes
XTPCommandBarsThemeMsMoney.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPCommandBarsThemeRibbon.h File Reference

  • Source
  • CommandBars
  • Themes
Classes
XTPCommandBarsThemeRibbon.h File Reference

Go to the source code of this file.

Classes

class CXTPRibbonTheme
The CXTPRibbonTheme class is used to enable a Ribbon style theme for Command Bars. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPCommandBarsVisualStudio2005Theme.h File Reference

  • Source
  • CommandBars
  • Themes
Classes
XTPCommandBarsVisualStudio2005Theme.h File Reference

Go to the source code of this file.

Classes

class CXTPVisualStudio2005Theme
The CXTPVisualStudio2005Theme class is used to enable a Visual Studio 2005 style theme for Command Bars. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPCommandBarsVisualStudio2008Theme.h File Reference

  • Source
  • CommandBars
  • Themes
Classes
XTPCommandBarsVisualStudio2008Theme.h File Reference

Go to the source code of this file.

Classes

class CXTPVisualStudio2008Theme
The CXTPVisualStudio2008Theme class is used to enable a Visual Studio 2008 style theme for Command Bars. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPCommandBarsVisualStudio2010Theme.h File Reference

  • Source
  • CommandBars
  • Themes
Classes
XTPCommandBarsVisualStudio2010Theme.h File Reference

Go to the source code of this file.

Classes

class CXTPVisualStudio2010Theme
The CXTPVisualStudio2010Theme class is used to enable a Visual Studio 2010 style theme for Command Bars. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPCommandBarsVisualStudio2012Theme.h File Reference

  • Source
  • CommandBars
  • Themes
Classes
XTPCommandBarsVisualStudio2012Theme.h File Reference

Go to the source code of this file.

Classes

class CXTPCommandBarsVisualStudio2012Theme
The CXTPCommandBarsVisualStudio2012Theme class is used to enable a Visual Studio 2012 theme for Command Bars. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPCommandBarsVisualStudio2015Theme.h File Reference

  • Source
  • CommandBars
  • Themes
Classes | Functions
XTPCommandBarsVisualStudio2015Theme.h File Reference

Go to the source code of this file.

Classes

class CXTPCommandBarsVisualStudio2015Theme
The CXTPCommandBarsVisualStudio2015Theme class is used to enable a Visual Studio 2015 style theme for Command Bars. More...

Functions

_XTP_EXT_CLASS BOOL AFX_CDECL XTPSetVSStateColor (CXTPCommandBars *pCommandBars, COLORREF clrState=COLORREF_NULL)
Call XTPSetVSStateColor to set the border and status bar colors for this theme to indicate state changes.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Function Documentation

◆ XTPSetVSStateColor()

_XTP_EXT_CLASS BOOL AFX_CDECL XTPSetVSStateColor | ( | CXTPCommandBars * | pCommandBars,
 |  | COLORREF | clrState = COLORREF_NULL )

Call XTPSetVSStateColor to set the border and status bar colors for this theme to indicate state changes.

This is similar to when Visual Studio 2015 opens a document or runs the debugger causing both the border and status bar colors to be updated. Unlike CXTPApplication::SetAmbientProperty, this function sets state color only for the specified command bars object and does not change the value of xtpApplicationStateColor.

Parameters
pCommandBars | Pointer to a valid CXTPCommandBars object.
clrState | RGB state color value to set. Use default COLORREF_NULL to reset colors to their default state.
Returns
TRUE if the colors were successfully updated, otherwise FALSE.
See also
CXTPApplication::SetAmbientProperty, CXTPApplication::GetAmbientProperty


Toolkit Pro: XTPCommandBarsVisualStudio2017Theme.h File Reference

  • Source
  • CommandBars
  • Themes
Classes | Functions
XTPCommandBarsVisualStudio2017Theme.h File Reference

Go to the source code of this file.

Classes

class CXTPCommandBarsVisualStudio2017Theme
The CXTPCommandBarsVisualStudio2017Theme class is used to enable a Visual Studio 2017 style theme for Command Bars. More...

Functions

_XTP_EXT_CLASS BOOL AFX_CDECL XTPSetVS2017StateColor (CXTPCommandBars *pCommandBars, COLORREF clrState=COLORREF_NULL)
Call XTPSetVS2017StateColor to set the border and status bar colors for this theme to indicate state changes.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Function Documentation

◆ XTPSetVS2017StateColor()

_XTP_EXT_CLASS BOOL AFX_CDECL XTPSetVS2017StateColor | ( | CXTPCommandBars * | pCommandBars,
 |  | COLORREF | clrState = COLORREF_NULL )

Call XTPSetVS2017StateColor to set the border and status bar colors for this theme to indicate state changes.

This is similar to when Visual Studio 2017 opens a document or runs the debugger causing both the border and status bar colors to be updated. Unlike CXTPApplication::SetAmbientProperty, this function sets state color only for the specified command bars object and does not change the value of xtpApplicationStateColor.

Parameters
pCommandBars | Pointer to a valid CXTPCommandBars object.
clrState | RGB state color value to set. Use default COLORREF_NULL to reset colors to their default state.
Returns
TRUE if the colors were successfully updated, otherwise FALSE.
See also
CXTPApplication::SetAmbientProperty, CXTPApplication::GetAmbientProperty


Toolkit Pro: XTPCommandBarsVisualStudio2019Theme.h File Reference

  • Source
  • CommandBars
  • Themes
Classes | Functions
XTPCommandBarsVisualStudio2019Theme.h File Reference

Go to the source code of this file.

Classes

class CXTPCommandBarsVisualStudio2019Theme
The CXTPCommandBarsVisualStudio2019Theme class is used to enable a Visual Studio 2019 style theme for Command Bars. More...

Functions

_XTP_EXT_CLASS BOOL AFX_CDECL XTPSetVS2019StateColor (CXTPCommandBars *pCommandBars, COLORREF clrState=COLORREF_NULL)
Call XTPSetVS2019StateColor to set the border and status bar colors for this theme to indicate state changes.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Function Documentation

◆ XTPSetVS2019StateColor()

_XTP_EXT_CLASS BOOL AFX_CDECL XTPSetVS2019StateColor | ( | CXTPCommandBars * | pCommandBars,
 |  | COLORREF | clrState = COLORREF_NULL )

Call XTPSetVS2019StateColor to set the border and status bar colors for this theme to indicate state changes.

This is similar to when Visual Studio 2019 opens a document or runs the debugger causing both the border and status bar colors to be updated. Unlike CXTPApplication::SetAmbientProperty, this function sets state color only for the specified command bars object and does not change the value of xtpApplicationStateColor.

Parameters
pCommandBars | Pointer to a valid CXTPCommandBars object.
clrState | RGB state color value to set. Use default COLORREF_NULL to reset colors to their default state.
Returns
TRUE if the colors were successfully updated, otherwise FALSE.
See also
CXTPApplication::SetAmbientProperty, CXTPApplication::GetAmbientProperty


Toolkit Pro: XTPCommandBarsVisualStudio2022Theme.h File Reference

  • Source
  • CommandBars
  • Themes
Classes | Functions
XTPCommandBarsVisualStudio2022Theme.h File Reference

Go to the source code of this file.

Classes

class CXTPCommandBarsVisualStudio2022Theme
The CXTPCommandBarsVisualStudio2022Theme class is used to enable a Visual Studio 2022 style theme for Command Bars. More...

Functions

_XTP_EXT_CLASS BOOL AFX_CDECL XTPSetVS2022StateColor (CXTPCommandBars *pCommandBars, COLORREF clrState=COLORREF_NULL)
Call XTPSetVS2022StateColor to set the border and status bar colors for this theme to indicate state changes.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Function Documentation

◆ XTPSetVS2022StateColor()

_XTP_EXT_CLASS BOOL AFX_CDECL XTPSetVS2022StateColor | ( | CXTPCommandBars * | pCommandBars,
 |  | COLORREF | clrState = COLORREF_NULL )

Call XTPSetVS2022StateColor to set the border and status bar colors for this theme to indicate state changes.

This is similar to when Visual Studio 2022 opens a document or runs the debugger causing both the border and status bar colors to be updated. Unlike CXTPApplication::SetAmbientProperty, this function sets state color only for the specified command bars object and does not change the value of xtpApplicationStateColor.

Parameters
pCommandBars | Pointer to a valid CXTPCommandBars object.
clrState | RGB state color value to set. Use default COLORREF_NULL to reset colors to their default state.
Returns
TRUE if the colors were successfully updated, otherwise FALSE.
See also
CXTPApplication::SetAmbientProperty, CXTPApplication::GetAmbientProperty


Toolkit Pro: XTPCommandBarsVisualStudio6Theme.h File Reference

  • Source
  • CommandBars
  • Themes
XTPCommandBarsVisualStudio6Theme.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPCommandBar.h File Reference

  • Source
  • CommandBars
Classes
XTPCommandBar.h File Reference

Go to the source code of this file.

Classes

class CXTPCommandBar
CXTPCommandBar is a CWnd derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPCommandBarAnimation.h File Reference

  • Source
  • CommandBars
XTPCommandBarAnimation.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPCommandBarKeyboardTip.h File Reference

  • Source
  • CommandBars
Classes
XTPCommandBarKeyboardTip.h File Reference

Go to the source code of this file.

Classes

class CXTPCommandBarKeyboardTip
CXTPCommandBarKeyboardTip is a CWnd derived class which represents a keyboard tip single window. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPCommandBarList.h File Reference

  • Source
  • CommandBars
Classes
XTPCommandBarList.h File Reference

Go to the source code of this file.

Classes

class CXTPCommandBarList
CXTPCommandBarList is a CList derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPCommandBars.h File Reference

  • Source
  • CommandBars
Classes
XTPCommandBars.h File Reference

Go to the source code of this file.

Classes

struct | XTP_COMMANDBARS_PROPEXCHANGE_PARAM
XTP_COMMANDBARS_PROPEXCHANGE_PARAM is a structure used to store the CommandBar's save settings. More...
class | CXTPCommandBars
CXTPCommandBars is a standalone class. More...
struct | CXTPCommandBars::KEYBOARDTIPS
Keyboard tips information. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPCommandBarsColorSet.h File Reference

  • Source
  • CommandBars
XTPCommandBarsColorSet.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPCommandBarsContextMenus.h File Reference

  • Source
  • CommandBars
Classes
XTPCommandBarsContextMenus.h File Reference

Go to the source code of this file.

Classes

class CXTPCommandBarsContextMenus
CXTPCommandBarsContextMenus is CXTPCommandBarList derived class which represents a collection of context menus. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPCommandBarsDefines.h File Reference

  • Source
  • CommandBars
Classes | Macros | Enumerations | Functions | Variables
XTPCommandBarsDefines.h File Reference

Go to the source code of this file.

Classes

struct | NMXTPCONTROL
This structure is passed as a parameter in CBN_XTP_EXECUTE message. More...
struct | XTP_COMMANDBARS_CREATECONTROL
Creates a control structure. More...
struct | XTP_COMMANDBARS_CREATEBAR
Creates a bar structure. More...

Macros

#define | xtpComboNormal xtpButtonAutomatic
Deprecated style for Combo control.
#define | xtpComboLabel xtpButtonCaption
Deprecated style for Combo control.
#define | ON_XTP_INITCOMMANDSPOPUP()
#define | ON_XTP_UNINITCOMMANDSPOPUP()
#define | ON_XTP_EXECUTE(id, memberFxn)
#define | ON_XTP_EXECUTE_RANGE(id, idLast, memberFxn)
#define | ON_XTP_CREATECONTROL()
#define | ON_XTP_AFTERCREATECONTROL()
#define | XTP_CN_UPDATE_CUSTOMIZE_COMMAND_UI ((UINT)(INT_MIN + 1))
XTP_CN_UPDATE_CUSTOMIZE_COMMAND_UI is sent to the command target via WM_COMMAND instead of CN_UPDATE_COMMAND_UI when it is necessary to update a Customize menu command without updating the command itself.
#define | ON_XTP_CREATECOMMANDBAR()
#define | DECLARE_XTP_CONTROL(class_name)
This macro generates the C++ header code necessary for a CXTPControl-derived class that can be serialized.
#define | IMPLEMENT_XTP_CONTROL(class_name, base_class_name)
This macro generates the C++ code necessary for a CXTPControl-derived class that can be serialized.
#define | DECLARE_XTP_COMMANDBAR(class_name)
This macro generates the C++ header code necessary for a CXTPCommandBar-derived class that can be serialized.
#define | IMPLEMENT_XTP_COMMANDBAR(class_name, base_class_name)
This macro generates the C++ code necessary for a CXTPCommandBar-derived class that can be serialized.

Enumerations

enum XTPBarPosition {
xtpBarTop = 0 , xtpBarBottom = 1 , xtpBarLeft = 2 , xtpBarRight = 3 ,
xtpBarFloating = 4 , xtpBarPopup = 5 , xtpBarListBox = 6 , xtpBarNone = 7
}
Position of the command bar. More...
enum | XTPBarType { xtpBarTypeMenuBar , xtpBarTypeNormal , xtpBarTypePopup , xtpBarTypeRibbon }
Type of the command bar. More...
enum | XTPBarTextOrientation { xtpBarTextAuto , xtpBarTextVertical , xtpBarTextHorizontal }
Command bar text orientation flags. More...
enum XTPControlType {
xtpControlError , xtpControlButton , xtpControlPopup , xtpControlButtonPopup ,
xtpControlSplitButtonPopup , xtpControlComboBox , xtpControlEdit , xtpControlCustom ,
xtpControlLabel , xtpControlCheckBox , xtpControlGallery , xtpControlRadioButton
}
Type of the control. More...
enum XTPControlFlags {
xtpFlagRightAlign = 1 , xtpFlagSkipFocus = 2 , xtpFlagLeftPopup = 4 , xtpFlagManualUpdate = 8 ,
xtpFlagNoMovable = 16 , xtpFlagControlStretched = 32 , xtpFlagShowPopupBarTip = 64 , xtpFlagWrapRow = 128 ,
xtpFlagRibbonTabBackground = 256
}
Flags of the control. More...
enum XTPControlHideFlags {
xtpNoHide = 0 , xtpHideGeneric = 1 , xtpHideWrap = 2 , xtpHideDockingPosition = 4 ,
xtpHideScroll = 8 , xtpHideCustomize = 16 , xtpHideExpand = 32 , xtpHideDocTemplate = 64 ,
xtpHideRibbonTab = 128
}
Control's hide flags, these are flags that specify why a control is hidden. More...
enum XTPButtonStyle {
xtpButtonUndefined = -1 , xtpButtonAutomatic = 0 , xtpButtonCaption = 1 , xtpButtonIcon = 2 ,
xtpButtonIconAndCaption = 3 , xtpButtonIconAndCaptionBelow = 4 , xtpButtonCaptionAndDescription = 5
}
Button's styles. More...
enum XTPPaintTheme {
xtpThemeNone = -1 , xtpThemeOffice2000 = 0 , xtpThemeOfficeXP = 1 , xtpThemeOffice2003 = 2 ,
xtpThemeNativeWinXP = 3 , xtpThemeVisualStudio2005 = 4 , xtpThemeResource = 5 , xtpThemeRibbon = 6 ,
xtpThemeVisualStudio2008 = 7 , xtpThemeVisualStudio6 = 8 , xtpThemeVisualStudio2010 = 9 , xtpThemeCustom = 10 ,
xtpThemeOffice2007System = 11 , xtpThemeOffice2013 = 12 , xtpThemeOffice2016 = xtpThemeOffice2013 , xtpThemeVisualStudio2012 = 13 ,
xtpThemeVisualStudio2012Light = 14 , xtpThemeVisualStudio2012Dark = 15 , xtpThemeVisualStudio2015 = 16 , xtpThemeNativeWindows10 = 17 ,
xtpThemeVisualStudio2017 = 18 , xtpThemeVisualStudio2019 = 19 , xtpThemeVisualStudio2022 = 20 , xtpThemeNativeWindows11 = 21
}
Paint themes used by command bars. More...
enum XTPMenuBarFlags {
xtpFlagHideMinimizeBox = 0x0100L , xtpFlagHideMaximizeBox = 0x0200L , xtpFlagIgnoreSetMenuMessage = 0x0400L , xtpFlagUseMDIMenus = 0x0800L ,
xtpFlagHideClose = 0x1000L , xtpFlagHideMDIButtons , xtpFlagAddMDISysPopup = 0x2000L
}
Menubar system button flags. More...
enum XTPToolBarFlags {
xtpFlagAlignTop = 0x000001 , xtpFlagAlignBottom = 0x000002 , xtpFlagAlignLeft = 0x000004 , xtpFlagAlignRight = 0x000008 ,
xtpFlagAlignAny , xtpFlagFloating = 0x000010 , xtpFlagHideWrap = 0x000020 , xtpFlagStretched = 0x000040 ,
xtpFlagNoBorders = 0x000080 , xtpFlagStretchedShared = 0x100000 , xtpFlagSmartLayout = 0x200000
}
Docking flags. More...
enum | XTPKeyboardCuesShow { xtpKeyboardCuesShowAlways , xtpKeyboardCuesShowNever , xtpKeyboardCuesShowWindowsDefault }
Enumerated type used to determine menu underlines. More...
enum | XTPKeyboardCuesUse { xtpKeyboardCuesUseMenuOnly = 0 , xtpKeyboardCuesUseAll = 1 , xtpKeyboardCuesUseNone = 2 , xtpKeyboardCuesUseAmpersandOnly = 4 }
Enumerated type used to determine if menu underlines execute pop-ups. More...
enum XTPAnimationType {
xtpAnimateWindowsDefault , xtpAnimateRandom , xtpAnimateUnfold , xtpAnimateSlide ,
xtpAnimateFade , xtpAnimateNone
}
Enumerated type used to determine the animation effect of pop-up bars. More...
enum | XTPPopupDirection { xtpPopupRight = 0 , xtpPopupLeft = 1 , xtpPopupDown = 2 , xtpPopupUp = 4 }
Docking direction enumerator. More...
enum XTPSpecialKey {
xtpKeyNext , xtpKeyPrev , xtpKeyBack , xtpKeyPopup ,
xtpKeyEscape , xtpKeyReturn , xtpKeyHome , xtpKeyEnd ,
xtpKeyLeft , xtpKeyRight , xtpKeySpace
}
Special keys enumerator. More...
enum | XTPIdleFlags { xtpIdleLayout = 1 , xtpIdleRedraw = 2 }
Flags for idle routine. More...

Functions

AFX_INLINE BOOL | IsDockingPosition (XTPBarPosition barPosition)
Call this member to determine if the specified bar position is left, top, right, or bottom.
AFX_INLINE BOOL | IsCaptionStyle (XTPButtonStyle buttonStyle)
Call this member to determine if the specified button style is button caption or button icon and caption.
AFX_INLINE BOOL | IsPopupControlType (XTPControlType controlType)
Call this member to determine if the specified control type is pop-up control, a button pop-up control, or a split button pop-up control.
AFX_INLINE BOOL | IsVerticalPosition (XTPBarPosition barPosition)
Call this member to determine if the specified bar position is left, right, or is a pop-up toolbar.
AFX_INLINE BOOL | IsAnimateType (XTPAnimationType animationType)
Call this member to determine if the menu animation type is set to fade, slide, or unfold.

Variables

const UINT | WM_XTP_COMMANDBARS_BASE = (WM_USER + 9300)
Base message for CommandBars.
const UINT | WM_XTP_TOOLBARVISIBLECHANGED = (WM_XTP_COMMANDBARS_BASE + 1)
The WM_XTP_TOOLBARVISIBLECHANGED is sent to the CXTPCommandBars site when the user shows/hides a toolbar object.
const UINT | WM_XTP_CONTROLSELECTED = (WM_XTP_COMMANDBARS_BASE + 2)
The WM_XTP_CONTROLSELECTED is sent to the CXTPCommandBars site when the user selects a CXTPCommandBar item.
const UINT | WM_XTP_DRAGCONTROLCHANGED = (WM_XTP_COMMANDBARS_BASE + 3)
The WM_XTP_DRAGCONTROLCHANGED is sent to the CXTPCommandBars site when the user select a button of a toolbar in customization mode.
const UINT | WM_XTP_INITMENU = (WM_XTP_COMMANDBARS_BASE + 4)
The WM_XTP_INITMENU is sent to the CXTPCommandBars site when the menu is about to become active.
const UINT | WM_XTP_CONTROLRBUTTONUP = (WM_XTP_COMMANDBARS_BASE + 5)
The WM_XTP_CONTROLRBUTTONUP is sent to the CXTPCommandBars site when the menu user presses the right button in a command bar control.
const UINT | WM_XTP_COMMANDBARKEYDOWN = (WM_XTP_COMMANDBARS_BASE + 6)
The WM_XTP_COMMANDBARKEYDOWN is sent to the CXTPCommandBars site when the user presses a key.
const UINT | WM_XTP_INITCOMMANDSPOPUP = (WM_XTP_COMMANDBARS_BASE + 7)
The WM_XTP_INITCOMMANDSPOPUP is sent to the CXTPCommandBars site when a pop-up menu is about to become active.
const UINT | WM_XTP_TOOLBARCONTEXTMENU = (WM_XTP_COMMANDBARS_BASE + 8)
The WM_XTP_TOOLBARCONTEXTMENU is sent to the CXTPCommandBars site when context menu is about to become visible.
const UINT | WM_XTP_UNINITCOMMANDSPOPUP = (WM_XTP_COMMANDBARS_BASE + 9)
The WM_XTP_UNINITCOMMANDSPOPUP is sent to the CXTPCommandBars site when a pop-up menu has been closed.
const UINT | CBN_XTP_EXECUTE = 100
The CBN_XTP_EXECUTE is sent to the CXTPCommandBars site when the user clicks an item of a CXTPCommandBar object.
const UINT | WM_XTP_BEFORECREATECONTROL = (WM_XTP_COMMANDBARS_BASE + 10)
The WM_XTP_BEFORECREATECONTROL is sent to the CXTPCommandBars site when a new CXTPControl object is created.
const UINT | WM_XTP_AFTERCREATECONTROL = (WM_XTP_COMMANDBARS_BASE + 11)
The WM_XTP_AFTERCREATECONTROL is sent to the CXTPCommandBars site after a new CXTPControl object is created.
const UINT | WM_XTP_GETTABICON = (WM_XTP_COMMANDBARS_BASE + 12)
The WM_XTP_GETTABICON message is sent to a MDI child window to retrieve the icon that will be used for the tabbed interface.
const UINT | WM_XTP_CREATECOMMANDBAR = (WM_XTP_COMMANDBARS_BASE + 13)
The WM_XTP_CREATECOMMANDBAR is sent to the CXTPCommandBars site when a new CXTPCommandBars object is created.
const UINT | WM_XTP_MESSAGEBARCLOSED = (WM_XTP_COMMANDBARS_BASE + 21)
The WM_XTP_MESSAGEBARCLOSED is sent to the CXTPCommandBars site when the user clicks the Close button on a message bar object.
const UINT | WM_XTP_SETBAKSTAGEBUTTONKEYTIP = (WM_XTP_COMMANDBARS_BASE + 31)
The WM_XTP_SETBAKSTAGEBUTTONKEYTIP is sent to the CXTPRibbonBackstageButton when the keyboard tip character for this button is changed.
const UINT | WM_XTP_SETBAKSTAGEBUTTONKEYTIPDRAWFLAG = (WM_XTP_COMMANDBARS_BASE + 32)
The WM_XTP_SETBAKSTAGEBUTTONKEYTIPDRAWFLAG is sent to the CXTPRibbonBackstageButton to show/hide the keyboard tip.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Macro Definition Documentation

◆ DECLARE_XTP_COMMANDBAR

#define DECLARE_XTP_COMMANDBAR ( class_name )

This macro generates the C++ header code necessary for a CXTPCommandBar-derived class that can be serialized.

Parameters
class_name The actual name of the class (not enclosed in quotation marks).

Use the DECLARE_XTP_COMMANDBAR macro in a .H module, then include that module in all .CPP modules that need access to objects of this class.

If DECLARE_XTP_COMMANDBAR is included in the class declaration, then IMPLEMENT_XTP_COMMANDBAR must be included in the class implementation.

The DECLARE_XTP_COMMANDBAR macro includes all the functionality of DECLARE_SERIAL, DECLARE_DYNAMIC and DECLARE_DYNCREATE.

Example:

class CToolPopupBar: public CXTPPopupBar
{
   DECLARE_XTP_COMMANDBAR(CToolPopupBar)

   public:
   CToolPopupBar();

};
See also
IMPLEMENT_XTP_COMMANDBAR, DECLARE_XTP_CONTROL

◆ DECLARE_XTP_CONTROL

#define DECLARE_XTP_CONTROL ( class_name )

This macro generates the C++ header code necessary for a CXTPControl-derived class that can be serialized.

Parameters
class_name The actual name of the class (not enclosed in quotation marks).

Use the DECLARE_XTP_CONTROL macro in a .H module, then include that module in all .CPP modules that need access to objects of this class.

If DECLARE_XTP_CONTROL is included in the class declaration, then IMPLEMENT_XTP_CONTROL must be included in the class implementation.

The DECLARE_XTP_CONTROL macro includes all the functionality of DECLARE_SERIAL, DECLARE_DYNAMIC and DECLARE_DYNCREATE.

Example:

class CBitmapControl: public CXTPControl
{
   DECLARE_XTP_CONTROL(CBitmapControl)

   public:
   CBitmapControl();

};
See also
IMPLEMENT_XTP_CONTROL, DECLARE_XTP_COMMANDBAR

◆ IMPLEMENT_XTP_COMMANDBAR

#define IMPLEMENT_XTP_COMMANDBAR | ( | class_name,
 |  | base_class_name )

This macro generates the C++ code necessary for a CXTPCommandBar-derived class that can be serialized.

Parameters
class_name | The actual name of the class (not enclosed in quotation marks).
base_class_name | The name of the base class (not enclosed in quotation marks).

Use the IMPLEMENT_XTP_COMMANDBAR macro in a .CPP module; then link the resulting object code only once.

Example:

IMPLEMENT_XTP_COMMANDBAR(CToolPopupBar, CXTPPopupBar)
...
pCommandBars->SetPopupBarClass(RUNTIME_CLASS(CToolPopupBar));
...
See also
DECLARE_XTP_COMMANDBAR, DECLARE_XTP_CONTROL

◆ IMPLEMENT_XTP_CONTROL

#define IMPLEMENT_XTP_CONTROL | ( | class_name,
 |  | base_class_name )

This macro generates the C++ code necessary for a CXTPControl-derived class that can be serialized.

Parameters
class_name | The actual name of the class (not enclosed in quotation marks).
base_class_name | The name of the base class (not enclosed in quotation marks).

Use the IMPLEMENT_XTP_CONTROL macro in a .CPP module; then link the resulting object code only once.

Example:

IMPLEMENT_XTP_CONTROL(CBitmapControl, CXTPControl)
See also
DECLARE_XTP_CONTROL, DECLARE_XTP_COMMANDBAR

◆ ON_XTP_AFTERCREATECONTROL

#define ON_XTP_AFTERCREATECONTROL ( )
See also
WM_XTP_AFTERCREATECONTROL

◆ ON_XTP_CREATECOMMANDBAR

#define ON_XTP_CREATECOMMANDBAR ( )
See also
WM_XTP_CREATECOMMANDBAR

◆ ON_XTP_CREATECONTROL

#define ON_XTP_CREATECONTROL ( )
See also
WM_XTP_BEFORECREATECONTROL

◆ ON_XTP_EXECUTE

#define ON_XTP_EXECUTE | ( | id,
 |  | memberFxn )
See also
CBN_XTP_EXECUTE

◆ ON_XTP_EXECUTE_RANGE

#define ON_XTP_EXECUTE_RANGE | ( | id,
 |  | idLast,
 |  | memberFxn )
See also
CBN_XTP_EXECUTE

◆ ON_XTP_INITCOMMANDSPOPUP

#define ON_XTP_INITCOMMANDSPOPUP ( )
See also
WM_XTP_INITCOMMANDSPOPUP

◆ ON_XTP_UNINITCOMMANDSPOPUP

#define ON_XTP_UNINITCOMMANDSPOPUP ( )
See also
WM_XTP_UNINITCOMMANDSPOPUP

◆ XTP_CN_UPDATE_CUSTOMIZE_COMMAND_UI

#define XTP_CN_UPDATE_CUSTOMIZE_COMMAND_UI ((UINT)(INT_MIN + 1))

XTP_CN_UPDATE_CUSTOMIZE_COMMAND_UI is sent to the command target via WM_COMMAND instead of CN_UPDATE_COMMAND_UI when it is necessary to update a Customize menu command without updating the command itself.

Parameters
pExtra A pointer to an array of two CXTPControl pointers where the first element is a pointer to a Customize menu control and the second element is a pointer to the control itself.

Example:

BOOL CMainFrame::OnCmdMsg(UINT nID, int nCode, void* pExtra, AFX_CMDHANDLERINFO* pHandlerInfo)
{
   BOOL bHandled = FALSE;

   if (XTP_CN_UPDATE_CUSTOMIZE_COMMAND_UI == nCode)
   {
      CXTPControl** pControls = reinterpret_cast<CXTPControl**>(pExtra);
      CXTPControl* pCustomizedMenuControl = pControls[0];
      CXTPControl* pControl = pControls[1];
      _ASSERTE(nID == pControl->GetID());
      pCustomizedMenuControl->SetEnabled(TRUE);
      bHandled = TRUE;
   }

   return bHandled ? TRUE : CXTPMDIFrameWnd::OnCmdMsg(nID, nCode, pExtra, pHandlerInfo);
}

Enumeration Type Documentation

◆ XTPAnimationType

enum XTPAnimationType

Enumerated type used to determine the animation effect of pop-up bars.

Example:

 pCommandBars->GetCommandBarsOptions()->animationType = xtpAnimateSlide;
See also
CXTPCommandBarsOptions, CXTPCommandBarsOptions::animationType, xtpAnimateWindowsDefault, xtpAnimateRandom, xtpAnimateUnfold, xtpAnimateSlide, xtpAnimateFade, xtpAnimateNone
Enumerator
xtpAnimateWindowsDefault | As defined in the "Display" settings.
xtpAnimateRandom | Any of the first three in random selection.
xtpAnimateUnfold | Unfold top to bottom.
xtpAnimateSlide | Slide in from left.
xtpAnimateFade | Fade-in.
xtpAnimateNone | No animation.

◆ XTPBarPosition

enum XTPBarPosition

Position of the command bar.

Example:

CXTPToolBar* pToolBar = pCommandBars->Add("ToolBar", xtpBarTop);
pToolBar->SetPosition(xtpBarBottom);
See also
CXTPCommandBars, CXTPToolBar, CXTPToolBar::SetPosition, xtpBarTop, xtpBarBottom, xtpBarLeft, xtpBarRight, xtpBarFloating, xtpBarPopup, xtpBarListBox, xtpBarNone
Enumerator
xtpBarTop | Docked at top.
xtpBarBottom | Docked at bottom.
xtpBarLeft | Docked at left.
xtpBarRight | Docked at right.
xtpBarFloating | Floated.
xtpBarPopup | Pop-up.
xtpBarListBox | List box.
xtpBarNone | None.

◆ XTPBarTextOrientation

enum XTPBarTextOrientation

Command bar text orientation flags.

See also
CXTPCommandBar::m_nTextOrientation
Enumerator
xtpBarTextAuto | Lets the Commandbars decide the best orientation. Horizontal bars will display text horizontally and vertical bars will display text vertically.
xtpBarTextVertical | Display text in the bar vertically, regardless of bar location.
xtpBarTextHorizontal | Display text in the bar horizontally, regardless of bar location.

◆ XTPBarType

enum XTPBarType

Type of the command bar.

Example:

CXTPCommandBar* pMenuBar = pCommandBars->GetMenuBar();
_ASSERTE(pMenuBar->GetType() == xtpBarTypeMenuBar);
See also
C XTPCommandBars, CXTPCommandBar, CXTPCommandBar::GetType, xtpBarTypeMenuBar, xtpBarTypePopup
Enumerator
xtpBarTypeMenuBar | Command bar is a CXTPMenuBar.
xtpBarTypeNormal | Command bar is a CXTPToolBar.
xtpBarTypePopup | Command bar is a CXTPPopupBar.
xtpBarTypeRibbon | Command bar is a CXTPRibbonBar.

◆ XTPButtonStyle

enum XTPButtonStyle

Button's styles.

This styles can be applied to CXTPControlButton and CXTPControlPopup derived classes.

Example:

pControl->SetStyle(xtpButtonIconAndCaption);
See also
CXTPControlButton, CXTPControl::SetStyle, CXTPControl::GetStyle, xtpButtonAutomatic, xtpButtonCaption, xtpButtonIcon, xtpButtonIconAndCaption
Enumerator
xtpButtonUndefined | Automatic style.
xtpButtonAutomatic | Automatic style.
xtpButtonCaption | Button draw only caption.
xtpButtonIcon | Button draw only icon.
xtpButtonIconAndCaption | Button draw icon and caption.
xtpButtonIconAndCaptionBelow | Button draw icon and draw caption below icon.
xtpButtonCaptionAndDescription | Button draw icon, caption and description for pop-up bar.

◆ XTPControlFlags

enum XTPControlFlags

Flags of the control.

Example:

pControl->SetFlags(xtpFlagRightAlign);
See also
CXTPControl, CXTPControl::SetFlags, xtpFlagRightAlign, xtpFlagSkipFocus, xtpFlagLeftPopup, xtpFlagManualUpdate, xtpFlagNoMovable, xtpFlagControlStretched
Enumerator
xtpFlagRightAlign | Control is right aligned.
xtpFlagSkipFocus | Control does not have focus.
xtpFlagLeftPopup | To Pop up child bar left.
xtpFlagManualUpdate | Control is manually updated.
xtpFlagNoMovable | To disable customization.
xtpFlagControlStretched | Control is stretched in parent command bar.
xtpFlagShowPopupBarTip | Show tooltip always
xtpFlagWrapRow | Wrap row for toolbar or pop-up bar.
xtpFlagRibbonTabBackground | Control is on the right side of Ribbon tabs.

◆ XTPControlHideFlags

enum XTPControlHideFlags

Control's hide flags, these are flags that specify why a control is hidden.

Example:

pControl->SetHideFlags(xtpHideGeneric);
See also
CXTPControl, CXTPControl::SetHideFlags, xtpNoHide, xtpHideGeneric, xtpHideWrap, xtpHideDockingPosition, xtpHideScroll, xtpHideCustomize, xtpHideExpand, xtpHideDocTemplate
Enumerator
xtpNoHide | Control is visible.
xtpHideGeneric | Control is hidden by generic reason. Developer set Visible = FALSE.
xtpHideWrap | Control is hidden by wrap. Toolbar is too small and the control is wrapped.
xtpHideDockingPosition | Control is hidden by docking position. If a toolbar has a combobox or edit control, when the toolbar is docked in the left or in the right side of frame, the Commandbar ComboBox and Edit controls becomes hidden.
xtpHideScroll | Control is hidden by scrolling. There are too many controls in a pop-up and the control is hidden because the pop-up is scrolled
xtpHideCustomize | Control is hidden by customize settings. User removed it. This only possible when customization is enabled. This flag is set if the user removes the control from the Add and Remove Buttons pop-up menu.
xtpHideExpand | If the control is rarely used and it is not visible because the intelligent menus option on and the command is a hidden command.
xtpHideDocTemplate | Control is hidden because active template excluded from its list.
xtpHideRibbonTab | Control is hidden because inactive ribbon tab.

◆ XTPControlType

enum XTPControlType

Type of the control.

Example:

pToolBar->GetControls()->Add(xtpControlButton, ID_FILE_NEW);
See also
CXTPControl, CXTPControl::GetType, CXTPControls, xtpControlError, xtpControlButton, xtpControlPopup, xtpControlButtonPopup, xtpControlSplitButtonPopup, xtpControlComboBox, xtpControlEdit, xtpControlCustom, xtpControlLabel
Enumerator
xtpControlError | Type is not defined.
xtpControlButton | Button type.
xtpControlPopup | Pop-up type.
xtpControlButtonPopup | Button pop-up.
xtpControlSplitButtonPopup | Split button pop-up.
xtpControlComboBox | Combobox button.
xtpControlEdit | Edit control.
xtpControlCustom | Custom control.
xtpControlLabel | Label control.
xtpControlCheckBox | CheckBox control.
xtpControlGallery | Gallery control.
xtpControlRadioButton | Radio Button control.

◆ XTPIdleFlags

enum XTPIdleFlags

Flags for idle routine.

Example:

pToolBar->DelayRedraw();
See also
CXTPCommandBar::DelayRedraw, CXTPCommandBar::DelayLayout, xtpIdleLayout, xtpIdleRedraw
Enumerator
xtpIdleLayout | Delay recalculate layout of command bar.
xtpIdleRedraw | Delay redraw of command bar.

◆ XTPKeyboardCuesShow

enum XTPKeyboardCuesShow

Enumerated type used to determine menu underlines.

Example:

pCommandBars->GetCommandBarsOptions()->ShowKeyboardCues(xtpKeyboardCuesShowWindowsDefault);

Enumerator
xtpKeyboardCuesShowAlways | Show keyboard cues always.
xtpKeyboardCuesShowNever | Never show keyboard cues.
xtpKeyboardCuesShowWindowsDefault | System defined.

◆ XTPKeyboardCuesUse

enum XTPKeyboardCuesUse

Enumerated type used to determine if menu underlines execute pop-ups.

Example:

pCommandBars->GetCommandBarsOptions()->keyboardCuesUse = xtpKeyboardCuesUseAll;

Enumerator
xtpKeyboardCuesUseMenuOnly | Activate only menu by using underlines.
xtpKeyboardCuesUseAll | Activate menu and tool bars by using underlines.
xtpKeyboardCuesUseNone | No using underlines.
xtpKeyboardCuesUseAmpersandOnly | Activates menu items with ampersand only (by default first character used if no ampersand found).

◆ XTPMenuBarFlags

enum XTPMenuBarFlags

Menubar system button flags.

Example:

CXTPMenuBar* pMenuBar = pCommandBars->SetMenu(_T("Menu Bar", IDR_MAINFRAME);
pMenuBar->SetFlags(xtpFlagIgnoreSetMenuMessage);
See also
CXTPMenuBar, CXTPCommandBar, CXTPCommandBar::SetFlags, xtpFlagHideMinimizeBox, xtpFlagHideMaximizeBox, xtpFlagIgnoreSetMenuMessage, xtpFlagUseMDIMenus, xtpFlagHideClose, xtpFlagHideMDIButtons, xtpFlagAddMDISysPopup
Enumerator
xtpFlagHideMinimizeBox | To hide minimize box.
xtpFlagHideMaximizeBox | To hide maximize box.
xtpFlagIgnoreSetMenuMessage | To ignore MDI menus.
xtpFlagUseMDIMenus | To use MDI menus. Not longer used.
xtpFlagHideClose | To hide close button.
xtpFlagHideMDIButtons | Specifies to hide all MDI buttons displayed on the Command Bar.
xtpFlagAddMDISysPopup | To add system MDI pop-up bar. Specifies to add system pop-up menu to the Menu Bar. This will appears as an icon to the far left of the Menu Bar and will display the MDI menu bar options when clicked.

◆ XTPPaintTheme

enum XTPPaintTheme

Paint themes used by command bars.

Example:

XTPPaintManager()->SetTheme(xtpThemeVisualStudio2005);
See also
CXTPCommandBars, CXTPPaintManager, xtpThemeOfficeXP, xtpThemeOffice2000, xtpThemeOffice2003, xtpThemeNativeWinXP, xtpThemeVisualStudio2005, xtpThemeCustom
Enumerator
xtpThemeNone | No theme selected.
xtpThemeOffice2000 | Office 2000 theme.
xtpThemeOfficeXP | Office XP theme.
xtpThemeOffice2003 | Office 2003 theme.
xtpThemeNativeWinXP | Windows XP and later native theme support.
xtpThemeVisualStudio2005 | Visual Studio 2005 theme.
xtpThemeResource | Office 2007 theme.
xtpThemeRibbon | Office 2007 style ribbon theme.
xtpThemeVisualStudio2008 | Visual Studio 2008 theme.
xtpThemeVisualStudio6 | Visual Studio 6 theme.
xtpThemeVisualStudio2010 | Visual Studio 2010 theme.
xtpThemeCustom | Custom theme.
xtpThemeOffice2007System | Office 2007 theme with system colors.
xtpThemeOffice2013 | Office 2013 theme.
xtpThemeOffice2016 | Office 2016 theme.
xtpThemeVisualStudio2012 | Visual Studio 2012 theme, uses INI file.
xtpThemeVisualStudio2012Light | Visual Studio 2012 light theme.
xtpThemeVisualStudio2012Dark | Visual Studio 2012 dark theme.
xtpThemeVisualStudio2015 | Visual Studio 2015 theme, uses INI file.
xtpThemeNativeWindows10 | Windows 10.
xtpThemeVisualStudio2017 | Visual Studio 2017 theme, uses INI file.
xtpThemeVisualStudio2019 | Visual Studio 2019 theme, uses INI file.
xtpThemeVisualStudio2022 | Visual Studio 2022 theme, uses INI file.
xtpThemeNativeWindows11 | Windows 11.

◆ XTPPopupDirection

enum XTPPopupDirection

Docking direction enumerator.

See also
CXTPPopupBar, CXTPPopupBar::m_popupFlags, xtpPopupRight, xtpPopupLeft, xtpPopupDown
Enumerator
xtpPopupRight | Pop-up Bar will be opened right of control.
xtpPopupLeft | Pop-up Bar will be opened left of control.
xtpPopupDown | Pop-up Bar will be opened bottom of control.
xtpPopupUp | Pop-up Bar will be opened top of control.

◆ XTPSpecialKey

enum XTPSpecialKey

Special keys enumerator.

See CXTPCommandBar::ProcessSpecialKey for details.

See also
CXTPCommandBar, CXTPCommandBar::ProcessSpecialKey, xtpKeyNext, xtpKeyPrev, xtpKeyBack, xtpKeyPopup, xtpKeyEscape, xtpKeyReturn, xtpKeyHome, xtpKeyEnd
Enumerator
xtpKeyNext | Select next key.
xtpKeyPrev | Select previous key.
xtpKeyBack | Close active pop-up key.
xtpKeyPopup | Open selected pop-up key.
xtpKeyEscape | Escape key.
xtpKeyReturn | Return key.
xtpKeyHome | Select first key.
xtpKeyEnd | Select last key.
xtpKeyLeft | Select left.
xtpKeyRight | Select right.
xtpKeySpace | Space.

◆ XTPToolBarFlags

enum XTPToolBarFlags

Docking flags.

Example:

CXTPMenuBar* pMenuBar = pCommandBars->SetMenu(_T("Menu Bar", IDR_MAINFRAME);
pMenuBar->EnableDocking(xtpFlagAlignTop | xtpFlagStretched);
See also
CXTPToolBar, CXTPToolBar::EnableDocking, xtpFlagAlignTop, xtpFlagAlignBottom, xtpFlagAlignLeft, xtpFlagAlignRight, xtpFlagAlignAny, xtpFlagFloating, xtpFlagHideWrap, xtpFlagStretched, xtpFlagNoBorders, xtpFlagStretchedShared, xtpFlagSmartLayout
Enumerator
xtpFlagAlignTop | Allows docking at the top of the client area.
xtpFlagAlignBottom | Allows docking at the bottom of the client area.
xtpFlagAlignLeft | Allows docking on the left side of the client area.
xtpFlagAlignRight | Allows docking on the right side of the client area.
xtpFlagAlignAny | Allows docking on any side of the client area.
xtpFlagFloating | Allows floating.
xtpFlagHideWrap | Allow to hide wrapped controls.
xtpFlagStretched | Bar is stretched.
xtpFlagNoBorders | Bar has no borders, this will cause CXTPPaintManager::IsFlatToolBar() to return TRUE.
xtpFlagStretchedShared | Bar is stretched, but does not fill whole row.
xtpFlagSmartLayout | Smart layout enabled.

Function Documentation

◆ IsAnimateType()

AFX_INLINE BOOL IsAnimateType ( XTPAnimationType animationType )

Call this member to determine if the menu animation type is set to fade, slide, or unfold.

Parameters
animationType Animation type.
Returns
TRUE if the animation type is set to fade, slide, or unfold.

◆ IsCaptionStyle()

AFX_INLINE BOOL IsCaptionStyle ( XTPButtonStyle buttonStyle )

Call this member to determine if the specified button style is button caption or button icon and caption.

Parameters
buttonStyle Button style.
Returns
TRUE if the specified button style is button caption or button icon and caption. FALSE otherwise.

◆ IsDockingPosition()

AFX_INLINE BOOL IsDockingPosition ( XTPBarPosition barPosition )

Call this member to determine if the specified bar position is left, top, right, or bottom.

Parameters
barPosition Bar position.
Returns
TRUE if the specified bar position is left, top, right, or bottom. FALSE if the position is anything else.

◆ IsPopupControlType()

AFX_INLINE BOOL IsPopupControlType ( XTPControlType controlType )

Call this member to determine if the specified control type is pop-up control, a button pop-up control, or a split button pop-up control.

Parameters
controlType Control type.
Returns
TRUE if the specified control type is pop-up control, a button pop-up control, or a split button pop-up control. FALSE otherwise.

◆ IsVerticalPosition()

AFX_INLINE BOOL IsVerticalPosition ( XTPBarPosition barPosition )

Call this member to determine if the specified bar position is left, right, or is a pop-up toolbar.

Parameters
barPosition Bar position.
Returns
TRUE if the specified bar position is left, right, or is a pop-up toolbar. FALSE otherwise.

Variable Documentation

◆ CBN_XTP_EXECUTE

const UINT CBN_XTP_EXECUTE = 100

The CBN_XTP_EXECUTE is sent to the CXTPCommandBars site when the user clicks an item of a CXTPCommandBar object.

Parameters
id | ID of the control that was clicked.
memberFxn | Name of member function to handle the message.

Use ON_COMMAND to map a single command to a member function if you don't need the exact control that caused the event. Use ON_COMMAND_RANGE or ON_XTP_EXECUTE_RANGE to map a range of command IDs to one member function.

If you don't set *pResult = 1 then WM_COMMAND also will be sent for this event.

Example: Here is an example of how an application would process the CBN_XTP_EXECUTE message.

BEGIN_MESSAGE_MAP(CMainFrame, CMDIFrameWnd)
    //{{AFX_MSG_MAP(CMainFrame)
    ON_XTP_EXECUTE(ID_TOOLS_TOOLITEM, OnToolsItem)
    //}}AFX_MSG_MAP
END_MESSAGE_MAP()

void CMainFrame::OnToolsItem(NMHDR* pNMHDR, LRESULT* pResult)
{
   CXTPControl* pControl = ((NMXTPCONTROL*)pNMHDR)->pControl;

   CToolRec* pTool = (CToolRec*)pControl->GetTag();

   if (!pTool)
      return;

   CString strArg = pTool->m_strArg;
   CString strDir = pTool->m_strDir;

   // launch the process.
   ShellExecute(NULL, _T("open"), pTool->m_strCmd, strArg, strDir, SW_SHOW);

   *pResult = 1;
}
See also
CXTPControl, NMXTPCONTROL

◆ WM_XTP_AFTERCREATECONTROL

const UINT WM_XTP_AFTERCREATECONTROL = (WM_XTP_COMMANDBARS_BASE + 11)

The WM_XTP_AFTERCREATECONTROL is sent to the CXTPCommandBars site after a new CXTPControl object is created.

Parameters
lpCreateControl Pointer to an XTP_COMMANDBARS_CREATECONTROL structure with information about the control to be created.
Returns
If an application processes this message, it should return TRUE.

Example: Here is an example of how an application would process the WM_XTP_AFTERCREATECONTROL message.

BEGIN_MESSAGE_MAP(CMainFrame, CMDIFrameWnd)
    //{{AFX_MSG_MAP(CMainFrame)
    ON_XTP_AFTERCREATECONTROL()
    //}}AFX_MSG_MAP
END_MESSAGE_MAP()

void CMainFrame::OnAfterCreateControl(LPCREATECONTROLSTRUCT lpCreateControl)
{
   _ASSERTE(lpCreateControl->pControl);

   if (lpCreateControl->nID == ID_BDR_NONE)
   {
      lpCreateControl->pControl->SetCaption(_T("None"));
      return;
   }
}
See also
XTP_COMMANDBARS_CREATECONTROL, CXTPControl, WM_XTP_BEFORECREATECONTROL

◆ WM_XTP_BEFORECREATECONTROL

const UINT WM_XTP_BEFORECREATECONTROL = (WM_XTP_COMMANDBARS_BASE + 10)

The WM_XTP_BEFORECREATECONTROL is sent to the CXTPCommandBars site when a new CXTPControl object is created.

Parameters
lpCreateControl Pointer to an XTP_COMMANDBARS_CREATECONTROL structure with information about the control to be created.
Returns
If an application processes this message, it should return TRUE.

Example: Here is an example of how an application would process the WM_XTP_BEFORECREATECONTROL message.

BEGIN_MESSAGE_MAP(CMainFrame, CMDIFrameWnd)
    //{{AFX_MSG_MAP(CMainFrame)
    ON_XTP_CREATECONTROL()
    //}}AFX_MSG_MAP
END_MESSAGE_MAP()

int CMainFrame::OnCreateControl(LPCREATECONTROLSTRUCT lpCreateControl)
{
   if (lpCreateControl->nID == ID_BDR_NONE)
       {
       lpCreateControl->controlType = xtpControlSplitButtonPopup;
       return TRUE;
       }
   return FALSE
}
See also
XTP_COMMANDBARS_CREATECONTROL, CXTPControl, WM_XTP_AFTERCREATECONTROL

◆ WM_XTP_COMMANDBARKEYDOWN

const UINT WM_XTP_COMMANDBARKEYDOWN = (WM_XTP_COMMANDBARS_BASE + 6)

The WM_XTP_COMMANDBARKEYDOWN is sent to the CXTPCommandBars site when the user presses a key.

Parameters
pChar | (UINT*)wParam pointer to UINT containing pressed key.
pCommandBar | (CXTPCommandBar*)lParam pointer to CXTPCommandBar object.

Example: Here is an example of how an application would process the WM_XTP_COMMANDBARKEYDOWN message.

BEGIN_MESSAGE_MAP(CMainFrame, CMDIFrameWnd)
    //{{AFX_MSG_MAP(CMainFrame)
    ON_MESSAGE(WM_XTP_COMMANDBARKEYDOWN, OnCommandBarKeyDown)
    //}}AFX_MSG_MAP
END_MESSAGE_MAP()

LRESULT CMainFrame::OnCommandBarKeyDown(WPARAM wParam, LPARAM lParam)
{
UINT* pChar = (UINT*)wParam;

return 0;
}
See also
CXTPCommandBar

◆ WM_XTP_CONTROLRBUTTONUP

const UINT WM_XTP_CONTROLRBUTTONUP = (WM_XTP_COMMANDBARS_BASE + 5)

The WM_XTP_CONTROLRBUTTONUP is sent to the CXTPCommandBars site when the menu user presses the right button in a command bar control.

Parameters
pPoint | (LPPOINT)wParam Cursor position.
pControl | (CXTPControl*)lParam Selected control.
Returns
If an application processes this message, it should return TRUE.

Example: Here is an example of how an application would process the WM_XTP_CONTROLRBUTTONUP message.

BEGIN_MESSAGE_MAP(CMainFrame, CMDIFrameWnd)
    //{{AFX_MSG_MAP(CMainFrame)
    ON_MESSAGE(WM_XTP_CONTROLRBUTTONUP, OnControlRButtonUp)
    //}}AFX_MSG_MAP
END_MESSAGE_MAP()

LRESULT CMainFrame::OnControlRButtonUp(WPARAM wParam, LPARAM lParam)
{
CXTPControl* pControl = (CXTPControl*)lParam;
if (pControl->GetID() == ID_FAVORITE_LINK)
{
CControlFavoriteLink* pLink = DYNAMIC_DOWNCAST(CControlFavoriteLink, pControl);
if (!pLink)
return FALSE;

CMenu menu;
XTPResourceManager()->LoadMenu(&menu, IDR_MENU_FAVORITE_LINK);

CPoint pt;
GetCursorPos(&pt);

UINT nReturn = CXTPCommandBars::TrackPopupMenu(menu.GetSubMenu(0), TPM_NONOTIFY |
TPM_RECURSE | TPM_RETURNCMD, pt.x, pt.y, this);

switch (nReturn)
{
....
}
return TRUE;
}
return FALSE;
}
See also
CXTPCommandBar, CXTPControl

◆ WM_XTP_CONTROLSELECTED

const UINT WM_XTP_CONTROLSELECTED = (WM_XTP_COMMANDBARS_BASE + 2)

The WM_XTP_CONTROLSELECTED is sent to the CXTPCommandBars site when the user selects a CXTPCommandBar item.

Parameters
pControl (CXTPControl*)wParam pointer to selected item.

pControl parameter is NULL when the user removes the mouse pointer from the selected item.

Example: Here is an example of how an application would process the WM_XTP_CONTROLSELECTED message.

BEGIN_MESSAGE_MAP(CMainFrame, CMDIFrameWnd)
    //{{AFX_MSG_MAP(CMainFrame)
    ON_MESSAGE(WM_XTP_CONTROLSELECTED, OnControlSelected)
    //}}AFX_MSG_MAP
END_MESSAGE_MAP()

LRESULT CMainFrame::OnControlSelected(WPARAM wParam, LPARAM lParam)
{
UNUSED_ALWAYS(lParam);
CXTPControl* pControl = (CXTPControl*)wParam;

return 0;
}
See also
CXTPControl, CXTPCommandBar

◆ WM_XTP_CREATECOMMANDBAR

const UINT WM_XTP_CREATECOMMANDBAR = (WM_XTP_COMMANDBARS_BASE + 13)

The WM_XTP_CREATECOMMANDBAR is sent to the CXTPCommandBars site when a new CXTPCommandBars object is created.

Parameters
lpCreateBar Pointer to an XTP_COMMANDBARS_CREATEBAR structure with information about a bar to be created.
Returns
If an application processes this message, it should return TRUE.

Example: Here is an example of how an application would process the WM_XTP_CREATECOMMANDBAR message.

BEGIN_MESSAGE_MAP(CMainFrame, CMDIFrameWnd)
    //{{AFX_MSG_MAP(CMainFrame)
    ON_XTP_CREATECOMMANDBAR()
    //}}AFX_MSG_MAP
END_MESSAGE_MAP()

int CMainFrame::OnCreateCommandBar(LPCREATEBARSTRUCT lpCreateBar)
{
   if (lpCreateBar->bPopup && _tcscmp(lpCreateBar->lpcstrCaption, _T("Find")) == 0)
   {

      CXTPPopupBar* pPopupBar = CXTPPopupBar::CreatePopupBar(GetCommandBars());
      pPopupBar->SetTearOffPopup(_T("Find Bar"), 1000);
      lpCreateBar->pCommandBar = pPopupBar;
      return TRUE;
   }
   return FALSE
}
See also
XTP_COMMANDBARS_CREATEBAR, CXTPCommandBar

◆ WM_XTP_DRAGCONTROLCHANGED

const UINT WM_XTP_DRAGCONTROLCHANGED = (WM_XTP_COMMANDBARS_BASE + 3)

The WM_XTP_DRAGCONTROLCHANGED is sent to the CXTPCommandBars site when the user select a button of a toolbar in customization mode.

Example: Here is an example of how an application would process the WM_XTP_DRAGCONTROLCHANGED message.

BEGIN_MESSAGE_MAP(CMainFrame, CMDIFrameWnd)
    //{{AFX_MSG_MAP(CMainFrame)
    ON_MESSAGE_VOID(WM_XTP_DRAGCONTROLCHANGED, OnDragControlChanged)
    //}}AFX_MSG_MAP
END_MESSAGE_MAP()

void CMainFrame::OnDragControlChanged()
{
CXTPControl* pControl = GetCommandBars()->GetDragControl();
}
See also
CXTPCommandBars::GetDragControl, CXTPCommandBars::SetCustomizeMode

◆ WM_XTP_GETTABICON

const UINT WM_XTP_GETTABICON = (WM_XTP_COMMANDBARS_BASE + 12)

The WM_XTP_GETTABICON message is sent to a MDI child window to retrieve the icon that will be used for the tabbed interface.

If application returns 0, CDocument::GetTitle will be used. You can override CXTPTabClientWnd::GetItemIcon instead of processing the message.

Returns
ICON handle to be used.

Example: Here is an example of how an application would process the WM_XTP_GETTABICON message.

BEGIN_MESSAGE_MAP(CChildFrame, CMDIChildWnd)
    //{{AFX_MSG_MAP(CChildFrame)
    ON_MESSAGE(WM_XTP_GETTABICON, OnGetTabIcon)
    //}}AFX_MSG_MAP
END_MESSAGE_MAP()

LRESULT CChildFrame::OnGetTabIcon(WPARAM //wParam, LPARAM //lParam)
{
   HICON hIcon = m_bLoading ? m_hIconLoading : m_hIconNormal;
   return (LRESULT)hIcon;
}
See also
CXTPTabClientWnd, WM_XTP_GETWINDOWTEXT, WM_XTP_GETWINDOWTOOLTIP

◆ WM_XTP_INITCOMMANDSPOPUP

const UINT WM_XTP_INITCOMMANDSPOPUP = (WM_XTP_COMMANDBARS_BASE + 7)

The WM_XTP_INITCOMMANDSPOPUP is sent to the CXTPCommandBars site when a pop-up menu is about to become active.

Parameters
pPopupBar Pointer to a pop-up menu.

Example: Here is an example of how an application would process the WM_XTP_INITCOMMANDSPOPUP message.

BEGIN_MESSAGE_MAP(CMainFrame, CMDIFrameWnd)
    //{{AFX_MSG_MAP(CMainFrame)
    ON_XTP_INITCOMMANDSPOPUP()
    //}}AFX_MSG_MAP
END_MESSAGE_MAP()

void CMainFrame::OnInitCommandsPopup(CXTPPopupBar* pPopupBar)
{
// get the list of commands for the pop-up.
CXTPControls* pControls = pPopupBar->GetControls();
}
See also
WM_XTP_UNINITCOMMANDSPOPUP, CXTPPopupBar

◆ WM_XTP_INITMENU

const UINT WM_XTP_INITMENU = (WM_XTP_COMMANDBARS_BASE + 4)

The WM_XTP_INITMENU is sent to the CXTPCommandBars site when the menu is about to become active.

It occurs when the user clicks an item on the menu bar or presses a menu key. This allows the application to modify the menu before it is displayed.

Parameters
pMenuBar (CXTPMenuBar*)wParam pointer to CXTPMenuBar object to be initialized.
Returns
If an application processes this message, it should return zero.

Example: Here is an example of how an application would process the WM_XTP_INITMENU message.

BEGIN_MESSAGE_MAP(CMainFrame, CMDIFrameWnd)
    //{{AFX_MSG_MAP(CMainFrame)
    ON_MESSAGE(WM_XTP_INITMENU, OnInitMenu)
    //}}AFX_MSG_MAP
END_MESSAGE_MAP()

LRESULT CMainFrame::OnInitMenu(WPARAM wParam, LPARAM lParam)
{
UNUSED_ALWAYS(lParam);
CXTPMenuBar* pMenuBar = (CXTPMenuBar*)wParam;

return 0;
}
See also
CXTPCommandBars, CXTPMenuBar

◆ WM_XTP_MESSAGEBARCLOSED

const UINT WM_XTP_MESSAGEBARCLOSED = (WM_XTP_COMMANDBARS_BASE + 21)

The WM_XTP_MESSAGEBARCLOSED is sent to the CXTPCommandBars site when the user clicks the Close button on a message bar object.

Parameters
pMessageBar (CXTPMessageBar*)lParam pointer to message bar being closed.

Example: Here is an example of how an application would process the WM_XTP_MESSAGEBARCLOSED message.

BEGIN_MESSAGE_MAP(CMainFrame, CMDIFrameWnd)
    //{{AFX_MSG_MAP(CMainFrame)
    ON_MESSAGE(WM_XTP_MESSAGEBARCLOSED, OnMessageBarClosed)
    //}}AFX_MSG_MAP
END_MESSAGE_MAP()

LRESULT CMainFrame::OnMessageBarClosed(WPARAM wParam, LPARAM lParam)
{
   UNUSED_ALWAYS(wParam);
   CXTPMessageBar* pMessageBar = (CXTPMessageBar*)lParam;

   return 0;
}
See also
CXTPToolBar

◆ WM_XTP_SETBAKSTAGEBUTTONKEYTIP

const UINT WM_XTP_SETBAKSTAGEBUTTONKEYTIP = (WM_XTP_COMMANDBARS_BASE + 31)

The WM_XTP_SETBAKSTAGEBUTTONKEYTIP is sent to the CXTPRibbonBackstageButton when the keyboard tip character for this button is changed.

Parameters
nChar (TCHAR)lParam the code of the character for the keyboard tip.

◆ WM_XTP_SETBAKSTAGEBUTTONKEYTIPDRAWFLAG

const UINT WM_XTP_SETBAKSTAGEBUTTONKEYTIPDRAWFLAG = (WM_XTP_COMMANDBARS_BASE + 32)

The WM_XTP_SETBAKSTAGEBUTTONKEYTIPDRAWFLAG is sent to the CXTPRibbonBackstageButton to show/hide the keyboard tip.

Parameters
bShow (BOOL)lParam TRUE: to show keyboard tip; FALSE: to hide keyboard tip.

◆ WM_XTP_TOOLBARCONTEXTMENU

const UINT WM_XTP_TOOLBARCONTEXTMENU = (WM_XTP_COMMANDBARS_BASE + 8)

The WM_XTP_TOOLBARCONTEXTMENU is sent to the CXTPCommandBars site when context menu is about to become visible.

Parameters
pToolBar | (CXTPToolBar*)wParam Toolbar under cursor; or NULL if clicked docking bar.
pPopup | (CXTPPopupBar*)lParam Pop-up bar with context menu.

Example: Here is an example of how an application would process the WM_XTP_TOOLBARCONTEXTMENU message.

BEGIN_MESSAGE_MAP(CMainFrame, CMDIFrameWnd)
    //{{AFX_MSG_MAP(CMainFrame)
    ON_MESSAGE(WM_XTP_TOOLBARCONTEXTMENU, OnToolbarContextMenu)
    //}}AFX_MSG_MAP
END_MESSAGE_MAP()

LRESULT CMainFrame::OnToolbarContextMenu(WPARAM wParam, LPARAM lParam)
{
CXTPToolBar* pToolBar = (CXTPToolBar*)wParam;
CXTPPopupBar* pPopup = (CXTPPopupBar*)lParam;

pPopupBar->GetControls()->RemoveAll();

return TRUE;
}
See also
CXTPPopupBar, CXTPControls

◆ WM_XTP_TOOLBARVISIBLECHANGED

const UINT WM_XTP_TOOLBARVISIBLECHANGED = (WM_XTP_COMMANDBARS_BASE + 1)

The WM_XTP_TOOLBARVISIBLECHANGED is sent to the CXTPCommandBars site when the user shows/hides a toolbar object.

Parameters
pToolBar (CXTPToolBar*)wParam pointer to toolbar.

Example: Here is an example of how an application would process the WM_XTP_TOOLBARVISIBLECHANGED message.

BEGIN_MESSAGE_MAP(CMainFrame, CMDIFrameWnd)
    //{{AFX_MSG_MAP(CMainFrame)
    ON_MESSAGE(WM_XTP_TOOLBARVISIBLECHANGED, OnToolBarVisibleChanged)
    //}}AFX_MSG_MAP
END_MESSAGE_MAP()

LRESULT CMainFrame::OnToolBarVisibleChanged(WPARAM wParam, LPARAM lParam)
{
   UNUSED_ALWAYS(lParam);
   CXTPToolBar* pToolBar = (CXTPToolBar*)wParam;

   return 0;
}
See also
CXTPToolBar

◆ WM_XTP_UNINITCOMMANDSPOPUP

const UINT WM_XTP_UNINITCOMMANDSPOPUP = (WM_XTP_COMMANDBARS_BASE + 9)

The WM_XTP_UNINITCOMMANDSPOPUP is sent to the CXTPCommandBars site when a pop-up menu has been closed.

Parameters
pPopupBar Pointer to a pop-up menu.

Example: Here is an example of how an application would process the WM_XTP_UNINITCOMMANDSPOPUP message.

BEGIN_MESSAGE_MAP(CMainFrame, CMDIFrameWnd)
    //{{AFX_MSG_MAP(CMainFrame)
    ON_XTP_UNINITCOMMANDSPOPUP()
    //}}AFX_MSG_MAP
END_MESSAGE_MAP()

void CMainFrame::OnUninitCommandsPopup(CXTPPopupBar* pPopupBar)
{
// get the list of commands for the pop-up.
CXTPControls* pControls = pPopupBar->GetControls();
}
See also
ON_XTP_INITCOMMANDSPOPUP


Toolkit Pro: XTPCommandBarsIIDs.h Source File

  • Source
  • CommandBars
XTPCommandBarsIIDs.h
1// DO NOT MODIFY MANUALLY
2// Generated on Thu 12/11/2025 at 12:46:10.31 using cj-update-iids.cmd
3
24#ifndef __XTPCommandBarsIIDs_H__
25# define __XTPCommandBarsIIDs_H__
26
27// clang-format off
28
29#define XTP_DEFINE_GUID(name,l,w1,w2,b1,b2,b3,b4,b5,b6,b7,b8) \
30 EXTERN_C __declspec(selectany) const IID XTP##name = {l,w1,w2,{b1,b2,b3,b4,b5,b6,b7,b8}}; \
31 const unsigned long XTP##name##__Data1 = (l); \
32 const unsigned short XTP##name##__Data2 = (w1); \
33 const unsigned short XTP##name##__Data3 = (w2); \
34 const unsigned char XTP##name##__Data4_0 = (b1); \
35 const unsigned char XTP##name##__Data4_1 = (b2); \
36 const unsigned char XTP##name##__Data4_2 = (b3); \
37 const unsigned char XTP##name##__Data4_3 = (b4); \
38 const unsigned char XTP##name##__Data4_4 = (b5); \
39 const unsigned char XTP##name##__Data4_5 = (b6); \
40 const unsigned char XTP##name##__Data4_6 = (b7); \
41 const unsigned char XTP##name##__Data4_7 = (b8);
42
43XTP_DEFINE_GUID(LIBID_XtremeCommandBars,0x555E8FCC,0x830E,0x45CC,0xAF,0x00,0xA0,0x12,0xD5,0xAE,0x74,0x51);
44XTP_DEFINE_GUID(DIID_MarkupContext,0xC0DE2430,0xD073,0x4043,0xAA,0x8C,0x62,0xB5,0xBD,0x8E,0x52,0x2D);
45XTP_DEFINE_GUID(DIID_ICommandBarControls,0xC0DE2430,0x27BF,0x4cb1,0x9A,0xBF,0x17,0x88,0xD9,0x83,0x52,0x23);
46XTP_DEFINE_GUID(DIID_ICommandBar,0xC0DE2430,0x0690,0x4528,0x86,0x56,0xE3,0x3E,0x61,0xF3,0x93,0x77);
47XTP_DEFINE_GUID(DIID_IImageManagerIcons,0xC0DE2430,0xCD87,0x48F0,0xAD,0x57,0x63,0x68,0x2A,0x2F,0x3F,0xCC);
48XTP_DEFINE_GUID(DIID_ICommandBarsGlobalSettings,0xC0DE2430,0xFEBF,0x4C62,0xBD,0x49,0xAC,0x65,0x56,0x03,0x51,0x54);
49XTP_DEFINE_GUID(DIID_IRibbonBar,0xC0DE2430,0xAF64,0x4A71,0x94,0xAE,0x11,0x60,0xA1,0x0E,0x48,0x7A);
50XTP_DEFINE_GUID(DIID_IRibbonGroups,0xC0DE2430,0x60E7,0x4964,0x8F,0x11,0x5D,0x62,0xD2,0x84,0x07,0xB9);
51XTP_DEFINE_GUID(DIID_IRibbonGroup,0xC0DE2430,0xD68C,0x4339,0xA2,0x84,0x4C,0x7D,0xB1,0xFB,0x29,0x03);
52XTP_DEFINE_GUID(DIID_IRibbonTab,0xC0DE2430,0x0A27,0x4B80,0x85,0x7D,0x19,0x2A,0x53,0x9A,0xE8,0x8D);
53XTP_DEFINE_GUID(DIID_ICommandBarGallery,0xC0DE2430,0x55CC,0x4D4C,0xA6,0xCF,0x26,0x0F,0x62,0x04,0x41,0x27);
54XTP_DEFINE_GUID(DIID_ICustomizeOptions,0xC0DE2430,0xD3DB,0x49F4,0xAC,0x22,0x14,0xAA,0x24,0x97,0x72,0xCB);
55XTP_DEFINE_GUID(CLSID_CustomizeOptions,0xC0DE2430,0xFD32,0x4169,0x88,0xA0,0x04,0x27,0x5E,0xAF,0x79,0xC5);
56XTP_DEFINE_GUID(DIID_IStateOptions,0xC0DE2430,0xAA66,0x4C26,0x8B,0x79,0xFF,0x0D,0xD9,0xDF,0x0E,0x68);
57XTP_DEFINE_GUID(CLSID_StateOptions,0xC0DE2430,0xA205,0x49F6,0x97,0x5D,0xF0,0x2D,0x82,0xC5,0x65,0xD1);
58XTP_DEFINE_GUID(DIID_ICommandBarAction,0xC0DE2430,0xDFBD,0x4175,0x90,0xD5,0xD8,0x4A,0xB2,0x79,0x09,0x50);
59XTP_DEFINE_GUID(CLSID_CommandBarAction,0xC0DE2430,0x61DB,0x4DC7,0x86,0xB4,0x61,0xB5,0x34,0xFE,0x96,0xBA);
60XTP_DEFINE_GUID(DIID_ICommandBarActions,0xC0DE2430,0x092D,0x462D,0x99,0x34,0x27,0x7E,0xAB,0x35,0xA2,0x7D);
61XTP_DEFINE_GUID(CLSID_CommandBarActions,0xC0DE2430,0x3543,0x4d3e,0x88,0xF9,0x4F,0x88,0x22,0x20,0x01,0x42);
62XTP_DEFINE_GUID(DIID_ICommandBarControl,0xC0DE2430,0x9E07,0x4079,0x92,0x4A,0x4C,0xB1,0xC1,0x1F,0xC7,0x00);
63XTP_DEFINE_GUID(CLSID_CommandBarControl,0xC0DE2430,0xC60A,0x4893,0xB9,0xE5,0xCD,0x2E,0xAB,0xBC,0xBF,0xF7);
64XTP_DEFINE_GUID(DIID_ICommandBarButton,0xC0DE2430,0x1E0F,0x446d,0xB9,0x2B,0xBE,0xDB,0xEF,0x77,0x30,0x2F);
65XTP_DEFINE_GUID(CLSID_CommandBarButton,0xC0DE2430,0xAACD,0x4e77,0x8B,0x1E,0x42,0xB4,0x63,0x76,0x05,0x13);
66XTP_DEFINE_GUID(DIID_ICommandBarPopup,0xC0DE2430,0xD452,0x4856,0xBA,0xA4,0x17,0xE8,0x6B,0xD0,0x8C,0xBA);
67XTP_DEFINE_GUID(CLSID_CommandBarPopup,0xC0DE2430,0xBB71,0x4f79,0x9A,0x7A,0x11,0xED,0x14,0x6C,0x38,0x7C);
68XTP_DEFINE_GUID(DIID_RibbonBarSystemButton,0xC0DE2430,0x789A,0x40d9,0xB5,0x64,0x75,0x77,0xDA,0x54,0x93,0x19);
69XTP_DEFINE_GUID(DIID_CommandBarSlider,0xC0DE2430,0xDE30,0x460B,0xB5,0x5A,0x40,0xD9,0xD5,0x22,0x9C,0x79);
70XTP_DEFINE_GUID(DIID_CommandBarProgress,0xC0DE2430,0x138E,0x4B16,0x88,0x12,0x99,0x7A,0x65,0xE8,0x4A,0xE6);
71XTP_DEFINE_GUID(DIID_CommandBarScrollBar,0xC0DE2430,0x939E,0x46A8,0xB8,0x1A,0x50,0x74,0x96,0xC3,0x0A,0x68);
72XTP_DEFINE_GUID(DIID_CommandBarPopupColor,0xC0DE2430,0xC46D,0x4A11,0xB7,0x82,0xA5,0xA3,0x68,0x41,0x89,0xA4);
73XTP_DEFINE_GUID(DIID_CommandBarControlColorSelector,0xC0DE2430,0x0835,0x494F,0x8F,0xFB,0x15,0x16,0xC2,0xD7,0xD9,0x43);
74XTP_DEFINE_GUID(DIID_ICommandBarGalleryItem,0xC0DE2430,0x06D0,0x4869,0x81,0x68,0x9C,0xCB,0xAA,0x22,0xC0,0xEB);
75XTP_DEFINE_GUID(CLSID_CommandBarGalleryItem,0xC0DE2430,0x9D8C,0x4025,0xAA,0xD4,0x73,0xD8,0xD1,0x5E,0x7F,0xED);
76XTP_DEFINE_GUID(DIID_ICommandBarGalleryItems,0xC0DE2430,0x0AFA,0x4EC8,0xA4,0x9E,0x4D,0xC7,0x67,0x1C,0x4A,0xC7);
77XTP_DEFINE_GUID(DIID_ICommandBarGalleryItemsEvents,0xC0DE2430,0x7BE8,0x42ec,0x87,0x0C,0x88,0x49,0xF5,0x54,0x0F,0x14);
78XTP_DEFINE_GUID(CLSID_CommandBarGalleryItems,0xC0DE2430,0xBA48,0x4451,0xB0,0x4D,0x53,0x04,0x90,0x9A,0xE5,0x43);
79XTP_DEFINE_GUID(CLSID_CommandBarGallery,0xC0DE2430,0xAD3D,0x450F,0xA5,0x1C,0xF3,0x92,0x8C,0xA3,0xD4,0x80);
80XTP_DEFINE_GUID(DIID_ICommandBarComboBox,0xC0DE2430,0x1A6F,0x478c,0x8C,0x8D,0x38,0xC0,0x67,0xA2,0xBC,0x1F);
81XTP_DEFINE_GUID(CLSID_CommandBarComboBox,0xC0DE2430,0xB90A,0x44f8,0x86,0xC2,0xB2,0x8D,0x45,0x40,0xAB,0xFA);
82XTP_DEFINE_GUID(DIID_ICommandBarCheckBox,0xC0DE2430,0x5C60,0x475B,0xA7,0x74,0x4B,0x22,0xFA,0xC0,0xB9,0xEC);
83XTP_DEFINE_GUID(CLSID_CommandBarCheckBox,0xC0DE2430,0x6975,0x465C,0xB1,0x9C,0xFF,0xA0,0x02,0x1A,0xAA,0x05);
84XTP_DEFINE_GUID(DIID_ICommandBarEdit,0xC0DE2430,0x7A03,0x46d9,0xB0,0x95,0x9F,0xB1,0xF8,0x25,0x53,0x0D);
85XTP_DEFINE_GUID(CLSID_CommandBarEdit,0xC0DE2430,0x45B6,0x4F4B,0xA1,0x20,0x6D,0x59,0xA6,0x9B,0x2F,0x1D);
86XTP_DEFINE_GUID(DIID_ICommandBarControlCustom,0xC0DE2430,0xCB1F,0x40fd,0xB0,0x73,0x4B,0xC1,0x51,0xA5,0x20,0x5F);
87XTP_DEFINE_GUID(CLSID_CommandBarControlCustom,0xC0DE2430,0x1B47,0x4246,0xA3,0x60,0xCC,0x5F,0x34,0xAB,0xCE,0x35);
88XTP_DEFINE_GUID(CLSID_CommandBarControls,0xC0DE2430,0xA08C,0x49CB,0x8B,0x78,0x58,0xD9,0x90,0xC0,0x0C,0x51);
89XTP_DEFINE_GUID(DIID_IKeyBindingsEvents,0xC0DE2430,0xB842,0x4945,0xA2,0xF6,0xCA,0x42,0x37,0x49,0x66,0x89);
90XTP_DEFINE_GUID(DIID_IKeyBinding,0xC0DE2430,0x0E35,0x48A5,0xBD,0xED,0x92,0x48,0x80,0xDA,0xF1,0xB2);
91XTP_DEFINE_GUID(CLSID_KeyBinding,0xC0DE2430,0xEA68,0x4e0d,0x94,0x6F,0x45,0x69,0x4C,0x26,0xF6,0xBA);
92XTP_DEFINE_GUID(DIID_IKeyBindings,0xC0DE2430,0x7369,0x4eab,0x9B,0x25,0x1D,0x5C,0x52,0x91,0x6D,0x86);
93XTP_DEFINE_GUID(CLSID_KeyBindings,0xC0DE2430,0x6BDA,0x418D,0x94,0x40,0x2D,0x14,0x1B,0x5D,0x65,0x3C);
94XTP_DEFINE_GUID(DIID_ICommandBarsOptions,0xC0DE2430,0x48B2,0x4CCF,0xB8,0xD7,0xCF,0xD6,0xA6,0x79,0xF8,0x37);
95XTP_DEFINE_GUID(CLSID_CommandBarsOptions,0xC0DE2430,0xA0EA,0x4d8e,0x8A,0x73,0x49,0xD5,0xD0,0x84,0xF5,0x27);
96XTP_DEFINE_GUID(CLSID_CommandBar,0xC0DE2430,0x231A,0x4BE6,0xAA,0x1B,0x9B,0xA4,0xB0,0x4C,0xA0,0x48);
97XTP_DEFINE_GUID(DIID_IMenuBarMDIMenu,0xC0DE2430,0xE7D2,0x4506,0x8D,0x3F,0xD9,0x86,0xE0,0xB3,0x45,0xD4);
98XTP_DEFINE_GUID(CLSID_MenuBarMDIMenu,0xC0DE2430,0xB93E,0x44AD,0xB2,0x77,0x1B,0x0F,0x84,0xA2,0x0C,0xBA);
99XTP_DEFINE_GUID(DIID_IMenuBarMDIMenus,0xC0DE2430,0x3D4B,0x41E3,0xB6,0x59,0x0F,0x8E,0x35,0x41,0x11,0xDF);
100XTP_DEFINE_GUID(CLSID_MenuBarMDIMenus,0xC0DE2430,0x84B8,0x4930,0x8B,0x30,0x5E,0x56,0xEC,0x7F,0x98,0x60);
101XTP_DEFINE_GUID(DIID_IMenuBar,0xC0DE2430,0xFED3,0x4FBC,0xB2,0x04,0x59,0xC2,0x31,0xE6,0x09,0x2B);
102XTP_DEFINE_GUID(CLSID_MenuBar,0xC0DE2430,0x603B,0x4AB7,0xB5,0x60,0xA2,0xE4,0x3A,0xDB,0x22,0xFC);
103XTP_DEFINE_GUID(DIID_IMenuTitleBar,0xC0DE2430,0xF80C,0x41F3,0xAA,0xA4,0xC7,0x1B,0x81,0x7A,0x2F,0x12);
104XTP_DEFINE_GUID(CLSID_MenuTitleBar,0xC0DE2430,0x7224,0x4B06,0xAE,0xC0,0xE8,0x87,0x6F,0xCB,0x86,0xBF);
105XTP_DEFINE_GUID(DIID_ICommandBarsContextMenus,0xC0DE2430,0x9D11,0x4373,0xB4,0x44,0xBC,0x1F,0x64,0x6D,0x2B,0x4D);
106XTP_DEFINE_GUID(CLSID_CommandBarsContextMenus,0xC0DE2430,0xE6F6,0x4FC8,0x82,0x73,0xAD,0x15,0xCC,0xF8,0xD2,0x93);
107XTP_DEFINE_GUID(DIID_ITabToolBar,0xC0DE2430,0x37BE,0x497E,0xA5,0x6D,0xD0,0xCB,0xDF,0x0B,0x3F,0x97);
108XTP_DEFINE_GUID(DIID_ITabToolBarEvents,0xC0DE2430,0x8B30,0x4FE9,0x8F,0x91,0xC1,0xB5,0x73,0xCF,0x9A,0xD5);
109XTP_DEFINE_GUID(CLSID_TabToolBar,0xC0DE2430,0x37BA,0x4711,0x93,0x4F,0xC9,0x61,0x2B,0x6E,0x00,0xE5);
110XTP_DEFINE_GUID(CLSID_RibbonGroup,0xC0DE2430,0x73F4,0x4849,0xA0,0x8C,0x8A,0x64,0x22,0x8A,0xA2,0xE3);
111XTP_DEFINE_GUID(DIID_RibbonPaintManager,0xC0DE2430,0x01E8,0x43E6,0xBC,0x94,0xA3,0x1B,0x89,0x07,0x7D,0xC4);
112XTP_DEFINE_GUID(CLSID_RibbonGroups,0xC0DE2430,0x1A42,0x4B87,0x9E,0x48,0x28,0x93,0x4A,0xC0,0x41,0xE5);
113XTP_DEFINE_GUID(CLSID_RibbonTab,0xC0DE2430,0xD924,0x4C08,0x92,0xF8,0xD2,0xB0,0x3C,0xE6,0x5E,0x1E);
114XTP_DEFINE_GUID(CLSID_RibbonBar,0xC0DE2430,0x34D1,0x4EBB,0xB5,0x8C,0x45,0x4D,0xB5,0x20,0x12,0xD9);
115XTP_DEFINE_GUID(DIID_IDialogBar,0xC0DE2430,0x46A4,0x4f99,0x83,0xD8,0xC6,0xD3,0xC2,0xB3,0x90,0xFC);
116XTP_DEFINE_GUID(CLSID_DialogBar,0xC0DE2430,0xC898,0x4A0B,0x8D,0x36,0xA9,0x56,0x62,0x03,0xA0,0x13);
117XTP_DEFINE_GUID(DIID_MiniToolBar,0xC0DE2430,0xF6FB,0x49A2,0xA8,0xC7,0xC5,0xBD,0x79,0x4C,0x3C,0x3B);
118XTP_DEFINE_GUID(DIID_IPaintManager,0xC0DE2430,0xCF7B,0x4042,0xBA,0x6F,0x20,0xF9,0xA9,0x6E,0x8A,0xD1);
119XTP_DEFINE_GUID(CLSID_PaintManager,0xC0DE2430,0x90B7,0x46EE,0x87,0x86,0xA5,0x42,0x78,0xB0,0xA5,0x59);
120XTP_DEFINE_GUID(DIID_ITabWorkspaceEvents,0xC0DE2430,0x9AF2,0x433A,0xBA,0x6D,0x8D,0x7B,0x12,0xB7,0x6E,0x12);
121XTP_DEFINE_GUID(DIID_ITabWorkspace,0xC0DE2430,0x2F2F,0x4c05,0x92,0xCF,0x6A,0xEB,0x0B,0xFA,0x0E,0x6D);
122XTP_DEFINE_GUID(CLSID_TabWorkspace,0xC0DE2430,0xC1B2,0x4583,0xB0,0x22,0x37,0x36,0x7F,0xE0,0xCF,0x90);
123XTP_DEFINE_GUID(DIID_StatusBarPane,0xC0DE2430,0xA5D8,0x4569,0x86,0x90,0x59,0x22,0x95,0xC5,0x58,0x3A);
124XTP_DEFINE_GUID(DIID_StatusBarSwitchPane,0xC0DE2430,0x80B8,0x4E1B,0x87,0x8E,0xFF,0xF8,0x34,0x7C,0x96,0xEE);
125XTP_DEFINE_GUID(DIID_StatusBarSliderPane,0xC0DE2430,0xC7DE,0x43D1,0xA3,0x6D,0x48,0xCD,0xD9,0x2D,0xA1,0xF7);
126XTP_DEFINE_GUID(DIID_StatusBarProgressPane,0xC0DE2430,0xA19C,0x4749,0xA1,0xF2,0x99,0x1D,0x33,0x61,0x80,0x81);
127XTP_DEFINE_GUID(DIID_IStatusBarEvents,0xC0DE2430,0x4037,0x4B66,0x82,0xA3,0xD9,0x48,0x40,0x9E,0x11,0xA6);
128XTP_DEFINE_GUID(DIID_IStatusBar,0xC0DE2430,0x7A0A,0x447d,0x9C,0xDC,0x8F,0x63,0xE7,0xE5,0xAF,0x55);
129XTP_DEFINE_GUID(CLSID_StatusBar,0xC0DE2430,0x0AC9,0x4997,0xB4,0xD7,0x75,0xB0,0xF2,0xE7,0xE4,0xBD);
130XTP_DEFINE_GUID(DIID_MessageBar,0xC0DE2430,0x481B,0x4769,0xAB,0xB2,0x56,0xF0,0xD7,0xF7,0xBB,0x9E);
131XTP_DEFINE_GUID(DIID_RecentFileListItem,0xC0DE2430,0x214E,0x44E4,0x85,0x4E,0xA4,0x08,0x82,0xEC,0xD0,0xFF);
132XTP_DEFINE_GUID(DIID_RecentFileList,0xC0DE2430,0xCBD0,0x4AF0,0x9D,0x33,0xEB,0x56,0xAB,0x06,0x48,0xD8);
133XTP_DEFINE_GUID(DIID__DCommandBars,0xC0DE2430,0xB997,0x432B,0xAB,0x4F,0x43,0x93,0x41,0xA7,0x69,0xE5);
134XTP_DEFINE_GUID(DIID__DCommandBarsEvents,0xC0DE2430,0x1D1A,0x4AFA,0x8D,0xFF,0x87,0x98,0xA2,0x18,0x12,0x26);
135XTP_DEFINE_GUID(CLSID_CommandBars,0xC0DE2430,0x1C4D,0x4DE8,0xBC,0x4A,0x52,0x40,0x61,0x7D,0x49,0x30);
136XTP_DEFINE_GUID(DIID__DCommandBarsFrame,0xC0DE2430,0x97D0,0x43d4,0xBE,0xE8,0x9E,0x25,0x11,0xD8,0x9F,0x64);
137XTP_DEFINE_GUID(DIID__DCommandBarsFrameEvents,0xC0DE2430,0xD2EF,0x4119,0xBB,0xBB,0x83,0x14,0xB5,0x79,0x4E,0x11);
138XTP_DEFINE_GUID(CLSID_CommandBarsFrame,0xC0DE2430,0x148B,0x45F5,0x96,0x79,0x3E,0x0D,0xBB,0xC9,0x2C,0x13);
139XTP_DEFINE_GUID(DIID__DImageManager,0xC0DE2430,0x7540,0x4926,0x8D,0x3D,0x82,0xA9,0x53,0xAE,0x7B,0x7B);
140XTP_DEFINE_GUID(DIID__DImageManagerEvents,0xC0DE2430,0xE0F3,0x48CF,0xBD,0x1D,0x53,0x05,0xA4,0xF4,0x6C,0x99);
141XTP_DEFINE_GUID(CLSID_ImageManager,0xC0DE2430,0x3949,0x47B3,0xB6,0x87,0x85,0xE8,0xDD,0xA2,0xAE,0xDB);
142XTP_DEFINE_GUID(DIID__DImageManagerPropPage,0xC0DE2430,0x41E3,0x4369,0x89,0xEF,0x1C,0x08,0x4E,0x3A,0x21,0xA8);
143XTP_DEFINE_GUID(CLSID_ImageManagerPropPage,0xC0DE2430,0x62EF,0x44E0,0x84,0x71,0x69,0xE9,0x1C,0x8B,0x02,0x6C);
144XTP_DEFINE_GUID(IID_IPrintView,0xC0DE2430,0x403B,0x41C9,0x97,0x29,0x7C,0x96,0x5E,0xCC,0xA5,0x43);
145XTP_DEFINE_GUID(DIID__DPrintPreview,0xC0DE2430,0x3B80,0x4CED,0xA4,0x41,0x19,0xE4,0x68,0xF8,0xD0,0x87);
146XTP_DEFINE_GUID(DIID__DPrintPreviewEvents,0xC0DE2430,0xDC0C,0x498B,0x9B,0x3E,0xFE,0xC9,0xF5,0xC3,0x1D,0x94);
147XTP_DEFINE_GUID(CLSID_PrintPreview,0xC0DE2430,0x7F9D,0x4B69,0x95,0xD0,0x24,0x9F,0xC1,0x0A,0xEF,0x31);
148XTP_DEFINE_GUID(DIID_RibbonBackstageView,0xC0DE2430,0x9D54,0x40A3,0xB6,0x26,0x83,0xFB,0x0F,0x80,0xB8,0xF4);
149XTP_DEFINE_GUID(DIID_RibbonBackstageCommand,0xC0DE2430,0x2F93,0x41B3,0xB0,0x97,0x2D,0xA8,0x52,0xA2,0x5B,0xFC);
150XTP_DEFINE_GUID(DIID_RibbonBackstageMenuSeparator,0xC0DE2430,0x3890,0x484C,0xA9,0xB0,0x97,0x8E,0x6A,0xA0,0xAA,0x8D);
151XTP_DEFINE_GUID(DIID_RibbonBackstageTab,0xC0DE2430,0xFCAC,0x4EF3,0xB2,0x7E,0x2E,0x8A,0x04,0xB1,0x70,0xE4);
152XTP_DEFINE_GUID(DIID__DBackstageButton,0xC0DE2430,0x7F27,0x46D2,0x91,0xA1,0x04,0x42,0xFD,0x6D,0xA0,0xDD);
153XTP_DEFINE_GUID(DIID__DBackstageButtonEvents,0xC0DE2430,0x8784,0x4B18,0x97,0x6D,0xF8,0x89,0xC1,0xF8,0xB1,0xE9);
154XTP_DEFINE_GUID(CLSID_BackstageButton,0xC0DE2430,0xADD1,0x404B,0x94,0x32,0x25,0xBE,0xCB,0xA0,0x75,0x5F);
155XTP_DEFINE_GUID(DIID__DBackstageButtonPropPage,0xC0DE2430,0xB473,0x4662,0xB8,0xAD,0xC5,0xF3,0xFB,0x64,0xC0,0x28);
156XTP_DEFINE_GUID(CLSID_BackstageButtonPropPage,0xC0DE2430,0x3CE1,0x4C9B,0xB7,0x64,0xD8,0x5C,0x63,0xDB,0xEC,0x21);
157XTP_DEFINE_GUID(DIID__DBackstageSeparator,0xC0DE2430,0xE970,0x416D,0x83,0x8B,0xAF,0xF3,0x0E,0xDC,0x1D,0x51);
158XTP_DEFINE_GUID(DIID__DBackstageSeparatorEvents,0xC0DE2430,0xA9B6,0x458C,0x8D,0xBE,0x71,0xB5,0x44,0xCD,0x06,0xB4);
159XTP_DEFINE_GUID(CLSID_BackstageSeparator,0xC0DE2430,0xC3CB,0x4192,0xB0,0x15,0xBF,0xF5,0x61,0x64,0xED,0x07);
160XTP_DEFINE_GUID(DIID__DBackstageListBox,0xC0DE2430,0x0694,0x4EE0,0x87,0x0A,0x55,0x8E,0xE7,0xDE,0x4B,0xF3);
161XTP_DEFINE_GUID(DIID__DBackstageListBoxEvents,0xC0DE2430,0xB56F,0x4C5C,0xA7,0xC1,0xBF,0xD5,0x97,0xBE,0x63,0x86);
162XTP_DEFINE_GUID(CLSID_BackstageListBox,0xC0DE2430,0x52D8,0x4364,0xBF,0xDC,0xC8,0x28,0x98,0x00,0x23,0xB0);
163XTP_DEFINE_GUID(CLSID_CommandBarsGlobalSettings,0xC0DE2430,0xD18F,0x4F58,0x86,0x47,0x38,0xF1,0xAD,0x33,0x14,0xC3);
164
165#undef XTP_DEFINE_GUID
166
167// clang-format on
168
169#endif // __XTPCommandBarsIIDs_H__


Toolkit Pro: XTPCommandBarsOptions.h File Reference

  • Source
  • CommandBars
Classes
XTPCommandBarsOptions.h File Reference

Go to the source code of this file.

Classes

class CXTPCommandBarsOptions
Options of the command bars. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPControl.h File Reference

  • Source
  • CommandBars
Classes
XTPControl.h File Reference

Go to the source code of this file.

Classes

class | CXTPControlAction
CXTPControlAction is a CXTPCmdTarget derived class. More...
class | CXTPControlActions
CXTPControlActions is a CXTPCmdTarget derived class. More...
class | CXTPControl
CXTPControl is a CXTPCmdTarget derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPControlButton.h File Reference

  • Source
  • CommandBars
Classes
XTPControlButton.h File Reference

Go to the source code of this file.

Classes

class CXTPControlButton
CXTPControlButton is a CXTPControl derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPControlComboBox.h File Reference

  • Source
  • CommandBars
Classes
XTPControlComboBox.h File Reference

Go to the source code of this file.

Classes

class | CXTPControlComboBoxPopupBar
CXTPControlComboBoxPopupBar is a CXTPPopupBar derived class. More...
class | CXTPControlComboBoxList
CXTPControlComboBoxList is a CXTPControlComboBoxPopupBar derived class. More...
class | CXTPControlComboBoxEditCtrl
Inplace Edit control of the combo. More...
class | CXTPControlComboBox
CXTPControlComboBox is a CXTPControl derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPControlComboBoxExt.h File Reference

  • Source
  • CommandBars
Classes | Variables
XTPControlComboBoxExt.h File Reference

Go to the source code of this file.

Classes

struct | NMXTPCHARHDR
Structure used as a parameter for XTP_FN_SETFORMAT and XTP_FN_GETFORMAT messages. More...
class | CXTPControlSizeComboBox
CXTPControlSizeComboBox is a CXTPControlComboBox derived class. More...
class | CXTPControlFontComboBoxList
CXTPControlFontComboBoxList is a CXTPControlComboBoxList derived class. More...
class | CXTPControlFontComboBox
CXTPControlFontComboBox is a CXTPControlComboBox derived class. More...

Variables

const UINT | XTP_FN_SETFORMAT = 0x1000
The XTP_FN_SETFORMAT notification sent by CXTPControlFontComboBox to set the current RichEdit selection format.
const UINT | XTP_FN_GETFORMAT = 0x1001
The XTP_FN_GETFORMAT notification sent by CXTPControlFontComboBox to get the current RichEdit selection format.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Variable Documentation

◆ XTP_FN_GETFORMAT

const UINT XTP_FN_GETFORMAT = 0x1001

The XTP_FN_GETFORMAT notification sent by CXTPControlFontComboBox to get the current RichEdit selection format.

Example: Here is an example of how an application would process the XTP_FN_GETFORMAT message.

BEGIN_MESSAGE_MAP(CApplicationView, CRichEditView)
    //{{AFX_MSG_MAP(CApplicationView)
    ON_NOTIFY(XTP_FN_GETFORMAT, ID_EDIT_SIZE, OnGetCharFormat)
    //}}AFX_MSG_MAP
END_MESSAGE_MAP()

void CApplicationView::OnGetCharFormat(NMHDR* pNMHDR, LRESULT* pResult)
{
   CHARFORMAT& cf = ((NMXTPCHARHDR*)pNMHDR)->cf;
   cf = GetCharFormatSelection();
   *pResult = 1;
}
See also
XTP_FN_SETFORMAT, CXTPControlFontComboBox

◆ XTP_FN_SETFORMAT

const UINT XTP_FN_SETFORMAT = 0x1000

The XTP_FN_SETFORMAT notification sent by CXTPControlFontComboBox to set the current RichEdit selection format.

Example: Here is an example of how an application would process the XTP_FN_SETFORMAT message.

BEGIN_MESSAGE_MAP(CApplicationView, CRichEditView)
    //{{AFX_MSG_MAP(CApplicationView)
    ON_NOTIFY(XTP_FN_SETFORMAT, ID_EDIT_SIZE, OnSetCharFormat)
    //}}AFX_MSG_MAP
END_MESSAGE_MAP()

void CApplicationView::OnSetCharFormat(NMHDR* pNMHDR, LRESULT* pResult)
{
   CHARFORMAT& cf = ((NMXTPCHARHDR*)pNMHDR)->cf;
   SetCharFormat(cf);
   *pResult = 1;
}
See also
XTP_FN_GETFORMAT, CXTPControlFontComboBox


Toolkit Pro: XTPControlComboBoxGalleryPopupBar.h File Reference

  • Source
  • CommandBars
Classes
XTPControlComboBoxGalleryPopupBar.h File Reference

Go to the source code of this file.

Classes

class CXTPControlComboBoxGalleryPopupBar
CXTPControlComboBoxPopupBar object. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPControlCustom.h File Reference

  • Source
  • CommandBars
Classes | Enumerations
XTPControlCustom.h File Reference

Go to the source code of this file.

Classes

class CXTPControlCustom
CXTPControlCustom is a CXTPControlButton derived class. More...

Enumerations

enum XTPControlCustomVerticalOptions { xtpVerticalHide , xtpVerticalShow , xtpVerticalButton }
Vertical options enumerator. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Enumeration Type Documentation

◆ XTPControlCustomVerticalOptions

enum XTPControlCustomVerticalOptions

Vertical options enumerator.

Example:

CXTPControlCustom* pControl = (CXTPControlCustom*)pToolBar->GetControls()->Add(xtpControlCustom,
ID_VIEW_LOGO);
pControl->SetVerticalPositionOption(xtpVerticalShow);
See also
CXTPControlCustom::SetVerticalPositionOption, xtpVerticalHide, xtpVerticalShow, xtpVerticalButton
Enumerator
xtpVerticalHide | To hide control if parent toolbar vertically docked.
xtpVerticalShow | To show control if parent toolbar vertically docked.
xtpVerticalButton | To show control as button.


Toolkit Pro: XTPControlEdit.h File Reference

  • Source
  • CommandBars
Classes | Variables
XTPControlEdit.h File Reference

Go to the source code of this file.

Classes

class | CXTPCommandBarEditCtrl
CXTPCommandBarEditCtrl is a CEdit derived class. More...
class | CXTPControlEditCtrl
Inplace Edit control of CXTPControlEdit. More...
class | CXTPControlEdit
CXTPControlEdit is a CXTPControl derived class. More...

Variables

const UINT | XTP_FN_SPINUP = 0x1008
Button is spinning up.
const UINT | XTP_FN_SPINDOWN = 0x1009
Button is spinning down.
const UINT | XTP_FN_BUDDYBUTTONCLICK = 0x100A
Buddy button down.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPControlExt.h File Reference

  • Source
  • CommandBars
Classes | Variables
XTPControlExt.h File Reference

Go to the source code of this file.

Classes

class | CXTPControlWindowList
CXTPControlWindowList is a CXTPControlButton derived class. More...
class | CXTPControlWorkspaceActions
CXTPControlWorkspaceActions is a CXTPControlButton derived class. More...
class | CXTPControlToolbars
CXTPControlToolbars is a CXTPControlButton derived class. More...
class | CXTPControlToolbars::CXTPControlToolbar
Represents a single toolbar item. More...
class | CXTPControlOleItems
CXTPControlOleItems is a CXTPControlButton derived class. More...
class | CXTPControlRecentFileList
CXTPControlRecentFileList is a CXTPControlButton derived class. More...
class | CXTPControlSelector
CXTPControlSelector is a CXTPControl derived class that represents a control selector. More...
class | CXTPControlLabel
CXTPControlLabel is a CXTPControl derived class. More...
class | CXTPControlCheckBox
CXTPControlCheckBox is a CXTPControlButton derived class. More...
class | CXTPControlRadioButton
CXTPControlRadioButton is a CXTPControlButton derived class. More...
class | CXTPControlMarkupLabel
CXTPControlMarkupLabel is a CXTPControlLabel derived class. More...
class | CXTPControlHyperlink
CXTPControlHyperlink is a CXTPControl derived class. More...
class | CXTPControlBitmap
CXTPControlBitmap is a CXTPControlLabel derived class. More...

Variables

const UINT XTP_SLN_SELCHANGE = 0x1006
XTP_SLN_SELCHANGE is sent to the parent command bar when the number of selected items has changed in the control selector.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Variable Documentation

◆ XTP_SLN_SELCHANGE

const UINT XTP_SLN_SELCHANGE = 0x1006

XTP_SLN_SELCHANGE is sent to the parent command bar when the number of selected items has changed in the control selector.

The number of selected items changes as the mouse is moved over the controls in the control selector.

XTP_SLN_SELCHANGE is sent in CXTPControlSelector::SetItemsActive.

Example: Here is an example of how an application would process the XTP_LBN_SELCHANGE message.

BEGIN_MESSAGE_MAP(CExtendedControlsView, CEditView)
    //{{AFX_MSG_MAP(CExtendedControlsView)
    ON_NOTIFY(XTP_SLN_SELCHANGE, ID_INSERT_COLUMNS, OnColumnsSelChange)
    //}}AFX_MSG_MAP
END_MESSAGE_MAP()

void CExtendedControlsView::OnColumnsSelChange(NMHDR* pNMHDR, LRESULT* pRes)
{
   _ASSERTE(pNMHDR != NULL);
   _ASSERTE(pRes != NULL);

   CControlColumns* pControlColumns = DYNAMIC_DOWNCAST(CControlColumns,
   ((NMXTPCONTROL*)pNMHDR)->pControl);
   if (pControlColumns)
   {

      CXTPControlStatic* pInfo = FindInfoControl(pControlColumns);
      if (pInfo)
      {
         int nCount = pControlColumns->m_szItemsActive.cx;

         CString str = _T("Cancel");
         if (nCount != 0)
         {
            str.Format(_T("%i Columns"), nCount);
         }

         pInfo->SetWidth(pControlColumns->m_szItem.cx *
         pControlColumns->m_szItemsVisible.cx);

         pInfo->SetCaption(str);
         pInfo->DelayRedrawParent();
      }

   *pRes = 1;
}
}
See also
CXTPControlSelector::SetItemsActive


Toolkit Pro: XTPControlGallery.h File Reference

  • Source
  • CommandBars
Classes | Variables
XTPControlGallery.h File Reference

Go to the source code of this file.

Classes

class | CXTPControlGallery
CXTPControlGallery is a CXTPControlPopup derived class. More...
struct | CXTPControlGallery::GALLERYITEM_POSITION
Structure contains item position description. More...
class | CXTPControlGalleryPaintManager
CXTPControlGalleryPaintManager is a standalone class used to draw a CXTPControlGallery object. More...

Variables

const UINT | XTP_GN_PREVIEWSTART = 0x1010
Gallery Notification - Occurs when the gallery preview is started.
const UINT | XTP_GN_PREVIEWCANCEL = 0x1011
Gallery Notification - Occurs when the gallery preview is canceled.
const UINT | XTP_GN_PREVIEWAPPLY = 0x1012
Gallery Notification - Occurs when the gallery preview is applied.
const UINT | XTP_GN_PREVIEWCHANGE = 0x1013
Gallery Notification - Occurs when the gallery preview is changed.
const UINT | XTP_GN_STARTDRAG = 0x1014
Gallery Notification - Occurs when an item is dragged in the gallery.
const UINT | XTP_GN_SELCHANGE = 0x1015
Gallery Notification - Occurs when the gallery selection has changed.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPControlListBox.h File Reference

  • Source
  • CommandBars
Classes | Variables
XTPControlListBox.h File Reference

Go to the source code of this file.

Classes

class | CXTPControlListBox
CXTPControlComboBox is a CXTPControl derived class. More...
class | CXTPControlStatic
CXTPControlStatic is a CXTPControl derived class. More...

Variables

const UINT | XTP_LBN_SELCHANGE = 0x1003
The XTP_LBN_SELCHANGE is sent to active view when the selection of CXTPControlListBox is changed.
const UINT | XTP_LBN_POPUP = 0x1004
The XTP_LBN_POPUP is sent to active view when the CXTPControlListBox is about to become visible.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Variable Documentation

◆ XTP_LBN_POPUP

const UINT XTP_LBN_POPUP = 0x1004

The XTP_LBN_POPUP is sent to active view when the CXTPControlListBox is about to become visible.

Example: Here is an example of how an application would process the XTP_LBN_POPUP message.

BEGIN_MESSAGE_MAP(CMainFrame, CMDIFrameWnd)
    //{{AFX_MSG_MAP(CMainFrame)
    ON_NOTIFY(XTP_LBN_POPUP, ID_EDIT_UNDO, OnListBoxControlPopup)
    //}}AFX_MSG_MAP
END_MESSAGE_MAP()

void CMainFrame::OnListBoxControlPopup(NMHDR* pNMHDR, LRESULT* pResult)
{
   CXTPControlListBox* pControlListBox = DYNAMIC_DOWNCAST(CXTPControlListBox,
   ((NMXTPCONTROL*)pNMHDR)->pControl); if (pControlListBox)
   {
      *pResult = 1;
   }
}
See also
CXTPControlListBox, XTP_LBN_SELCHANGE

◆ XTP_LBN_SELCHANGE

const UINT XTP_LBN_SELCHANGE = 0x1003

The XTP_LBN_SELCHANGE is sent to active view when the selection of CXTPControlListBox is changed.

Example: Here is an example of how an application would process the XTP_LBN_SELCHANGE message.

BEGIN_MESSAGE_MAP(CMainFrame, CMDIFrameWnd)
    //{{AFX_MSG_MAP(CMainFrame)
    ON_NOTIFY(XTP_LBN_SELCHANGE, ID_EDIT_UNDO, OnListBoxControlSelChange)
    //}}AFX_MSG_MAP
END_MESSAGE_MAP()

void CMainFrame::OnListBoxControlSelChange(NMHDR* pNMHDR, LRESULT* pResult)
{
   CXTPControlListBox* pControlListBox = DYNAMIC_DOWNCAST(CXTPControlListBox,
   ((NMXTPCONTROL*)pNMHDR)->pControl); if (pControlListBox)
   {
      *pResult = 1;
   }
}
See also
CXTPControlListBox, XTP_LBN_POPUP


Toolkit Pro: XTPControlPopup.h File Reference

  • Source
  • CommandBars
Classes
XTPControlPopup.h File Reference

Go to the source code of this file.

Classes

class CXTPControlPopup
CXTPControlPopup is a CXTPControl derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPControlPopupColor.h File Reference

  • Source
  • CommandBars
Classes
XTPControlPopupColor.h File Reference

Go to the source code of this file.

Classes

class | CXTPControlPopupColor
CXTPControlPopupColor is a CXTPControlPopup derived class. More...
class | CXTPControlButtonColor
CXTPControlButtonColor is a CXTPControlButton derived class. More...
class | CXTPControlColorSelector
CXTPControlColorSelector is a CXTPControl derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPControlProgress.h File Reference

  • Source
  • CommandBars
Classes
XTPControlProgress.h File Reference

Go to the source code of this file.

Classes

class CXTPControlProgress
CXTPControlProgress is a CXTPControl derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPControls.h File Reference

  • Source
  • CommandBars
Classes
XTPControls.h File Reference

Go to the source code of this file.

Classes

class | CXTPControls
CXTPControls is a CXTPCmdTarget derived class. More...
class | CXTPOriginalControls
CXTPOriginalControls object. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPControlScrollBar.h File Reference

  • Source
  • CommandBars
Classes
XTPControlScrollBar.h File Reference

Go to the source code of this file.

Classes

class CXTPControlScrollBar
CXTPControlScrollBar is a CXTPControl derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPControlSlider.h File Reference

  • Source
  • CommandBars
Classes
XTPControlSlider.h File Reference

Go to the source code of this file.

Classes

class | CXTPControlSliderCtrl
Inplace slider control of CXTPControlSlider. More...
class | CXTPControlSlider
CXTPControlSlider is a CXTPControl derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPDialogBar.h File Reference

  • Source
  • CommandBars
Classes
XTPDialogBar.h File Reference

Go to the source code of this file.

Classes

class CXTPDialogBar
CXTPDialogBar is a CXTPToolBar derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPDialogBase.h File Reference

  • Source
  • CommandBars
XTPDialogBase.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPDockBar.h File Reference

  • Source
  • CommandBars
Classes
XTPDockBar.h File Reference

Go to the source code of this file.

Classes

class CXTPDockBar
CXTPDockBar is a CWnd derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPDockContext.h File Reference

  • Source
  • CommandBars
Classes
XTPDockContext.h File Reference

Go to the source code of this file.

Classes

class CXTPDockContext
CXTPDockContext is a standalone class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPDockState.h File Reference

  • Source
  • CommandBars
Classes
XTPDockState.h File Reference

Go to the source code of this file.

Classes

class CXTPDockState
CXTPDockState is a standalone class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPFrameWnd.h File Reference

  • Source
  • CommandBars
Classes | Variables
XTPFrameWnd.h File Reference

Go to the source code of this file.

Classes

class | CXTPCommandBarsSiteBase< TBase >
CXTPCommandBarsSiteBase is a standalone class. More...
class | CXTPFrameWndBase< TBase >
CXTPFrameWndBase is a standalone class. More...
class | CXTPMDIFrameWnd
CXTPMDIFrameWnd is a CXTPFrameWndBase derived class. More...
class | CXTPMDIFrameWndEx
CXTPMDIFrameWndEx is a CXTPMDIFrameWnd derived class. More...
class | CXTPFrameWnd
CXTPFrameWnd is a CXTPFrameWndBase derived class. More...

Variables

const UINT _XTP_EXTRN XTP_WM_UPDATE_MDI_CHILD_THEME
A message that is sent to each MDI child window as a result of a call to CXTPMDIFrameWnd::UpdateMDIChildrenTheme.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPImageEditor.h File Reference

  • Source
  • CommandBars
Classes
XTPImageEditor.h File Reference

Go to the source code of this file.

Classes

class CXTPImageEditorDlg
CXTPImageEditorDlg is a CDialog derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPKeyboardManager.h File Reference

  • Source
  • CommandBars
Classes
XTPKeyboardManager.h File Reference

Go to the source code of this file.

Classes

class CXTPKeyboardManager
CXTPKeyboardManager class used to handle keyboard hooks. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMenuBar.h File Reference

  • Source
  • CommandBars
Classes
XTPMenuBar.h File Reference

Go to the source code of this file.

Classes

class | CXTPMenuBarMDIMenuInfo
CXTPMenuBarMDIMenuInfo structure used to describe the parameters of application MDI menus. More...
class | CXTPMenuBarMDIMenus
CXTPMenuBarMDIMenus represents a collection of MDI menus for CXTPMenuBar. More...
class | CXTPMenuBar
CXTPMenuBar is a CXTPToolBar derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMenuTitleBar.h Source File

  • Source
  • CommandBars
XTPMenuTitleBar.h
1// XTPMenuTitleBar.h : interface for the CXTPMenuTitleBar class.
2//
3// (c)1998-2023 Codejock Software, All Rights Reserved.
4//
5// THIS SOURCE FILE IS THE PROPERTY OF CODEJOCK SOFTWARE AND IS NOT TO BE
6// RE-DISTRIBUTED BY ANY MEANS WHATSOEVER WITHOUT THE EXPRESSED WRITTEN
7// CONSENT OF CODEJOCK SOFTWARE.
8//
9// THIS SOURCE CODE CAN ONLY BE USED UNDER THE TERMS AND CONDITIONS OUTLINED
10// IN THE XTREME TOOLKIT PRO LICENSE AGREEMENT. CODEJOCK SOFTWARE GRANTS TO
11// YOU (ONE SOFTWARE DEVELOPER) THE LIMITED RIGHT TO USE THIS SOFTWARE ON A
12// SINGLE COMPUTER.
13//
14// CONTACT INFORMATION:
15// support@codejock.com
16// http://www.codejock.com
17//
19
20//{{AFX_CODEJOCK_PRIVATE
21#if !defined(__XTPMENUTITLEBAR_H__)
22# define __XTPMENUTITLEBAR_H__
23//}}AFX_CODEJOCK_PRIVATE
24
25# if _MSC_VER >= 1000
26# pragma once
27# endif // _MSC_VER >= 1000
28
29# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
30
31class CXTPCommandBars;
32
33//===========================================================================
34// Summary:
35// CXTPMenuTitleBar is a CXTPMenuBar derived class.
36// It represents a menu bar of a frame window.
37//===========================================================================
38class _XTP_EXT_CLASS CXTPMenuTitleBar : public CXTPMenuBar
39{
40public:
41 //-----------------------------------------------------------------------
42 // Summary:
43 // Constructs a CXTPMenuTitleBar object.
44 //-----------------------------------------------------------------------
45 CXTPMenuTitleBar();
46
47 //-----------------------------------------------------------------------
48 // Summary:
49 // Destroys a CXTPMenuTitleBar object, handles cleanup and deallocation.
50 //-----------------------------------------------------------------------
51 ~CXTPMenuTitleBar();
52
53 //-----------------------------------------------------------------------
54 // Summary:
55 // Loads a menu from the resource.
56 // Parameters:
57 // nIDResource - Menu identifier to load.
58 // Returns:
59 // TRUE if successful, otherwise FALSE.
60 //-----------------------------------------------------------------------
61 virtual BOOL LoadMenuBar(UINT nIDResource);
62
63 //-----------------------------------------------------------------------
64 // Summary:
65 // Call this member function to determine if the command bar is a
66 // CXTPMenuTitleBar.
67 // Returns:
68 // TRUE if the command bar is a CXTPMenuTitleBar, otherwise FALSE.
69 // See Also:
70 // CXTPCommandBar, CXTPMenuTitleBar
71 //-----------------------------------------------------------------------
72 virtual BOOL IsMenuTitleBar() const;
73
74 //-----------------------------------------------------------------------
75 // Summary:
76 // Call this method to update the system buttons of the menu bar.
77 //-----------------------------------------------------------------------
78 virtual void RefreshSysButtons();
79
80 //-----------------------------------------------------------------------
81 // Summary:
82 // This method calculates the dimensions of a toolbar.
83 // Parameters:
84 // nLength - Length of the bar.
85 // dwMode - Mode to dock.
86 // nWidth - Width of the bar.
87 // Returns:
88 // Size of the docked toolbar.
89 //-----------------------------------------------------------------------
90 virtual CSize CalcDockingLayout(int nLength, DWORD dwMode, int nWidth = 0);
91
92 void RepositionCaptionButtons(CSize sz);
93 void AddCaptionButton(int nId, BOOL bAdd, BOOL bEnabled, CRect& rcCaption);
94 void RepositionCaptionText(CSize sz);
95
96 void SetIconID(long id);
97
98private:
99 CRect m_rcHeader; // Header bounding rectangle.
100 CRect m_rcCaptionText; // Caption text bounding rectangle.
101 CString m_strCaptionText; // Caption text.
102 int m_nIconID; // ImageManager icon id
103
104protected:
105 //{{AFX_CODEJOCK_PRIVATE
106 DECLARE_MESSAGE_MAP()
107
108 //{{AFX_MSG(CXTPMenuTitleBar)
109 afx_msg void OnLButtonDown(UINT nFlags, CPoint point);
110 afx_msg void OnRButtonDown(UINT nFlags, CPoint point);
111 afx_msg void OnLButtonDblClk(UINT nFlags, CPoint point);
112 //}}AFX_MSG
113 //}}AFX_CODEJOCK_PRIVATE
114
115# ifdef _XTP_COMMANDBARS_ACTIVEX
116 //{{AFX_CODEJOCK_PRIVATE
117
118 DECLARE_DISPATCH_MAP()
119 DECLARE_INTERFACE_MAP()
120
121 DECLARE_OLETYPELIB_EX(CXTPMenuTitleBar);
122# endif
123
124private:
125 DECLARE_XTP_COMMANDBAR(CXTPMenuTitleBar)
126};
127
128AFX_INLINE BOOL CXTPMenuTitleBar::IsMenuTitleBar() const
129{
130 return TRUE;
131}
132
133AFX_INLINE void CXTPMenuTitleBar::SetIconID(long id)
134{
135 m_nIconID = id;
136}
137
138# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
139#endif //#if !defined(__XTPMENUTITLEBAR_H__)
DECLARE_XTP_COMMANDBAR
#define DECLARE_XTP_COMMANDBAR(class_name)
This macro generates the C++ header code necessary for a CXTPCommandBar-derived class that can be ser...
Definition XTPCommandBarsDefines.h:1234
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCommandBar::IsMenuTitleBar
virtual BOOL IsMenuTitleBar() const
Call this member function to determine if the command bar is a CXTPMenuTitleBar.
Definition XTPCommandBar.h:1463
CXTPCommandBars
CXTPCommandBars is a standalone class.
Definition XTPCommandBars.h:165
CXTPMenuBar
CXTPMenuBar is a CXTPToolBar derived class.
Definition XTPMenuBar.h:141
CXTPMenuBar::LoadMenuBar
virtual BOOL LoadMenuBar(UINT nIDResource)
Loads a menu from the resource.
CXTPMenuBar::RefreshSysButtons
virtual void RefreshSysButtons()
Call this method to update the system buttons of the menu bar.
CXTPToolBar::CalcDockingLayout
virtual CSize CalcDockingLayout(int nLength, DWORD dwMode, int nWidth=0)
This method calculates the dimensions of a toolbar.


Toolkit Pro: XTPMiniToolBar.h File Reference

  • Source
  • CommandBars
Classes
XTPMiniToolBar.h File Reference

Go to the source code of this file.

Classes

class CXTPMiniToolBar
Represents a MiniToolbar object. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMouseManager.h File Reference

  • Source
  • CommandBars
Classes
XTPMouseManager.h File Reference

Go to the source code of this file.

Classes

class | CXTPMouseManager
CXTPMouseManager is standalone class. More...
class | CXTPMouseManager::CTrackArray
Array of the tracking bars. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPPaintManager.h File Reference

  • Source
  • CommandBars
Classes | Enumerations | Functions
XTPPaintManager.h File Reference

Go to the source code of this file.

Classes

struct | XTP_COMMANDBARS_ICONSINFO
This structure collect icons options for command bars. More...
class | CXTPPaintManagerFont
PaintManagers used CFont wrapper. More...
class | CXTPPaintManager
Paint manager of the command bars. More...
struct | CXTPPaintManager::CLogFont
CLogFont is a self initializing LOGFONT derived class. More...
class | CXTPReBarPaintManager< TBase >
The CXTPReBarPaintManager template class is used to enable a ReBar theme for Command Bars. More...

Enumerations

enum XTPSpecialControl { xtpButtonExpandToolbar , xtpButtonExpandMenu , xtpButtonHideFloating , xtpButtonExpandFloating }
Special control with extended drawing. More...

Functions

_XTP_EXT_CLASS CXTPPaintManager *AFX_CDECL XTPPaintManager ()
Call this function to access CXTPPaintManager members.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Enumeration Type Documentation

◆ XTPSpecialControl

enum XTPSpecialControl

Special control with extended drawing.

See also
CXTPPaintManager::DrawSpecialControl, xtpButtonExpandToolbar, xtpButtonExpandMenu, xtpButtonHideFloating, xtpButtonExpandFloating, xtpButtonCustomize
Enumerator
xtpButtonExpandToolbar | Control is option button of docking toolbar.
xtpButtonExpandMenu | Control is expand button of pop-up bar.
xtpButtonHideFloating | Control is hide button of floating toolbar.
xtpButtonExpandFloating | Control is option button of floating toolbar.

Function Documentation

◆ XTPPaintManager()

_XTP_EXT_CLASS CXTPPaintManager *AFX_CDECL XTPPaintManager ( )

Call this function to access CXTPPaintManager members.

Since this class is designed as a single instance object you can only access version info through this method. You cannot directly instantiate an object of type CXTPPaintManager. If no global paint manager has been previously set, the function enables and sets a default paint manager that corresponds to xtpThemeOffice2000.

Implementers of custom themes or other classes that access a global paint manager by a call to XTPPaintManager() must ensure they increment global paint manager's reference counter before making the call to XTPPaintManager() by calling CXTPPaintManager::GetInstanceAddRef(), and then decrement its reference counter by calling CXTPPaintManager::ReleaseInstance(). The natural places for those steps are constructors and destructor of a class from which a call to XTPPaintManager() is to be made.

Returns
A pointer to the only instance of CXTPPaintManager object.

Example:

XTPPaintManager()->GetIconsInfo()->bIconsWithShadow = FALSE;


Toolkit Pro: XTPPopupBar.h File Reference

  • Source
  • CommandBars
Classes
XTPPopupBar.h File Reference

Go to the source code of this file.

Classes

class | CXTPPopupBar
CXTPPopupBar is a CXTPCommandBar derived class. More...
class | CXTPPopupToolBar
CXTPPopupToolBar is a CXTPPopupBar derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPPreviewView.h File Reference

  • Source
  • CommandBars
Classes | Macros
XTPPreviewView.h File Reference

Go to the source code of this file.

Classes

class CXTPPreviewView
CXTPPreviewView is a CPreviewView derived class that represents a print preview window with a themed toolBar. More...

Macros

#define | XTP_ZOOM_WHOLEPAGE 0
Fit the entire preview page on the screen.
#define | XTP_ZOOM_PAGEWIDTH 1
Fit the preview page to the width of the screen.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPReBar.h File Reference

  • Source
  • CommandBars
Classes
XTPReBar.h File Reference

Go to the source code of this file.

Classes

class CXTPReBar
The CXTPReBar object extends the standard MFC CReBar class to provide extended functionality such as saving and restoring band layouts. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPRecentFileList.h File Reference

  • Source
  • CommandBars
Classes
XTPRecentFileList.h File Reference

Go to the source code of this file.

Classes

class CXTPRecentFileList
CXTPRecentFileList is a CRecentFileList derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPShortcutManager.h File Reference

  • Source
  • CommandBars
Classes
XTPShortcutManager.h File Reference

Go to the source code of this file.

Classes

class | CXTPShortcutManagerAccel
CXTPShortcutManagerAccel represents an accelerator key used in an accelerator table. More...
class | CXTPShortcutManagerAccelTable
CXTPShortcutManagerAccelTable represents an accelerator table for the CXTPShortcutManager class. More...
class | CXTPShortcutManager
CXTPShortcutManager is a standalone class used to manipulate accelerators of a frame. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTabClientWnd.h File Reference

  • Source
  • CommandBars
Classes | Enumerations | Variables
XTPTabClientWnd.h File Reference

Go to the source code of this file.

Classes

class CXTPTabClientWnd
CXTPTabClientWnd is a CWnd derived class. More...

Enumerations

enum XTPWorkspaceButtons {
xtpWorkspaceHideArrows = 1 , xtpWorkspaceHideClose = 2 , xtpWorkspaceHideAll = 3 , xtpWorkspaceShowActiveFiles = 4 ,
xtpWorkspaceHideArrowsAlways = 1 + 8 , xtpWorkspaceShowCloseTab = 16 , xtpWorkspaceShowCloseSelectedTab = 32
}
Workspace buttons enumerator. More...
enum | XTPWorkspaceNewTabPosition { xtpWorkspaceNewTabRightMost , xtpWorkspaceNewTabLeftMost , xtpWorkspaceNewTabNextToActive }
XTPWorkspaceNewTabPosition enumerator. More...
enum | XTPWorkspaceActivateTab { xtpWorkspaceActivateNextToClosed , xtpWorkspaceActivateTopmost }
XTPWorkspaceActivateTab enumerator. More...

Variables

const UINT | WM_XTP_PRETRANSLATEMOUSEMSG = (WM_XTP_COMMANDBARS_BASE + 20)
The WM_XTP_PRETRANSLATEMOUSEMSG message is sent to the owner window to pre-translate mouse messages.
const UINT | WM_XTP_GETWINDOWTEXT = (WM_XTP_COMMANDBARS_BASE + 21)
The WM_XTP_GETWINDOWTEXT message is sent to the MDI child window to retrieve the text that will be used for the tabbed interface.
const UINT | WM_XTP_GETWINDOWTOOLTIP = (WM_XTP_COMMANDBARS_BASE + 23)
The WM_XTP_GETWINDOWTOOLTIP message is sent to the MDI child window to retrieve tooltips for CXTPTabClientWnd's tabs.
const UINT | WM_XTP_NEWTABITEM = (WM_XTP_COMMANDBARS_BASE + 24)
The WM_XTP_NEWTABITEM message is sent to the owner window when a new tab is created.
const UINT | WM_XTP_TABTODOCKPANE = (WM_XTP_COMMANDBARS_BASE + 26)
The WM_XTP_TABTODOCKPANE message is sent to the owner window when a tab is being docked to Docking Panes.
const UINT | WM_XTP_PRETRANSLATEMOUSEMSG_EX = (WM_XTP_COMMANDBARS_BASE + 28)
The WM_XTP_PRETRANSLATEMOUSEMSG_EX message is sent to the main window from TearOffFrame to pre-translate mouse messages.
const UINT | WM_XTP_SETACTIVEWORKSPACE = (WM_XTP_COMMANDBARS_BASE + 29)
The WM_XTP_SETACTIVEWORKSPACE message is sent to the owner window when workspace changed.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Enumeration Type Documentation

◆ XTPWorkspaceActivateTab

enum XTPWorkspaceActivateTab

XTPWorkspaceActivateTab enumerator.

Used to determine which tab will become active after the currently active tab is closed.

See also
CXTPTabClientWnd.SetAfterCloseActiveTab, xtpWorkspaceActivateNextToClosed, xtpWorkspaceActivateTopmost
Enumerator
xtpWorkspaceActivateNextToClosed | Activate tab next to the closed tab.
xtpWorkspaceActivateTopmost | Activate the left-most tab.

◆ XTPWorkspaceButtons

enum XTPWorkspaceButtons

Workspace buttons enumerator.

Used to indicate which tab navigation buttons to display in the TabWorkspace.

Example:

m_MTIClientWnd.SetFlags(xtpWorkspaceHideClose);
See also
CXTPTabClientWnd::SetFlags, xtpWorkspaceHideArrows, xtpWorkspaceHideClose, xtpWorkspaceHideAll
Enumerator
xtpWorkspaceHideArrows | To hide arrow buttons.
xtpWorkspaceHideClose | To hide close button.
xtpWorkspaceHideAll | To hide arrow and close buttons.
xtpWorkspaceShowActiveFiles | To show active file button.
xtpWorkspaceHideArrowsAlways | To hide arrow buttons always
xtpWorkspaceShowCloseTab | To show close button for all tabs.
xtpWorkspaceShowCloseSelectedTab | To show close button for selected tabs.

◆ XTPWorkspaceNewTabPosition

enum XTPWorkspaceNewTabPosition

XTPWorkspaceNewTabPosition enumerator.

Used to determine where new tabs will appear.

Example:

m_MTIClientWnd.SetNewTabPosition(xtpWorkspaceNewTabLeftMost);
See also
CXTPTabClientWnd::SetNewTabPosition, xtpWorkspaceNewTabRightMost, xtpWorkspaceNewTabLeftMost, xtpWorkspaceNewTabNextToActive
Enumerator
xtpWorkspaceNewTabRightMost | New tab will be created after all tabs.
xtpWorkspaceNewTabLeftMost | New tab will be created before all tabs.
xtpWorkspaceNewTabNextToActive | New tab will be created after active tab.

Variable Documentation

◆ WM_XTP_GETWINDOWTEXT

const UINT WM_XTP_GETWINDOWTEXT = (WM_XTP_COMMANDBARS_BASE + 21)

The WM_XTP_GETWINDOWTEXT message is sent to the MDI child window to retrieve the text that will be used for the tabbed interface.

If application returns 0, CDocument::GetTitle will be used. You can override CXTPTabClientWnd::GetItemText instead of process the message.

Returns
Pointer to a null-terminated string that specifies the text to be used.

Example: Here is an example of how an application would process the WM_XTP_GETWINDOWTEXT message.

BEGIN_MESSAGE_MAP(CChildFrame, CMDIChildWnd)
    //{{AFX_MSG_MAP(CChildFrame)
    ON_MESSAGE(WM_XTP_GETWINDOWTEXT, OnGetTabText)
    //}}AFX_MSG_MAP
END_MESSAGE_MAP()

LRESULT CChildFrame::OnGetTabText(WPARAM //wParam//, LPARAM //lParam//)
{
   return (LPCTSTR)m_strCaption;
}
See also
CXTPTabClientWnd, WM_XTP_GETTABICON, WM_XTP_GETWINDOWTOOLTIP

◆ WM_XTP_GETWINDOWTOOLTIP

const UINT WM_XTP_GETWINDOWTOOLTIP = (WM_XTP_COMMANDBARS_BASE + 23)

The WM_XTP_GETWINDOWTOOLTIP message is sent to the MDI child window to retrieve tooltips for CXTPTabClientWnd's tabs.

You must call CXTPTabClientWnd::EnableToolTips to enable tooltips.

Returns
Pointer to a null-terminated string that specifies the tooltip to be used.

If the application returns 0, CDocument::GetPathName will be used.

Example: Here is an example of how an application would process the WM_XTP_GETWINDOWTOOLTIP message.

BEGIN_MESSAGE_MAP(CChildFrame, CMDIChildWnd)
    //{{AFX_MSG_MAP(CChildFrame)
    ON_MESSAGE(WM_XTP_GETWINDOWTOOLTIP, OnGetTabTip)
    //}}AFX_MSG_MAP
END_MESSAGE_MAP()

LRESULT CChildFrame::OnGetTabTip(WPARAM //wParam//, LPARAM //lParam//)
{
   return (LPCTSTR)m_strToolTip;
}
See also
CXTPTabClientWnd, WM_XTP_GETTABICON, WM_XTP_GETWINDOWTEXT

◆ WM_XTP_NEWTABITEM

const UINT WM_XTP_NEWTABITEM = (WM_XTP_COMMANDBARS_BASE + 24)

The WM_XTP_NEWTABITEM message is sent to the owner window when a new tab is created.

Parameters
pNewItem (CXTPTabManagerItem*)wParam. Pointer to the tab that was created.

Example: Here is an example of how an application would process the WM_XTP_NEWTABITEM message.

BEGIN_MESSAGE_MAP(CMainFrame, CMDIFrameWnd)
    //{{AFX_MSG_MAP(CMainFrame)
    ON_MESSAGE(WM_XTP_NEWTABITEM, OnTabbarNewItem)
    //}}AFX_MSG_MAP
END_MESSAGE_MAP()

LRESULT CMainFrame::OnTabbarNewItem(WPARAM wParam, LPARAM //lParam//)
{
   CXTPTabManagerItem* pItem = (CXTPTabManagerItem*)wParam;
   return 0;
}
See also
CXTPTabClientWnd

◆ WM_XTP_PRETRANSLATEMOUSEMSG

const UINT WM_XTP_PRETRANSLATEMOUSEMSG = (WM_XTP_COMMANDBARS_BASE + 20)

The WM_XTP_PRETRANSLATEMOUSEMSG message is sent to the owner window to pre-translate mouse messages.

Parameters
point | CPoint((DWORD)lParam) mouse cursor position.
wParam | mouse notification.
Returns
If the application is to process this message, the return value should be TRUE.

Example: Here is an example of how an application would process the WM_XTP_PRETRANSLATEMOUSEMSG message.

BEGIN_MESSAGE_MAP(CMainFrame, CMDIFrameWnd)
    //{{AFX_MSG_MAP(CMainFrame)
    ON_MESSAGE(WM_XTP_PRETRANSLATEMOUSEMSG, OnTabbarMouseMsg)
    //}}AFX_MSG_MAP
END_MESSAGE_MAP()

LRESULT CMainFrame::OnTabbarMouseMsg(WPARAM wParam, LPARAM lParam)
{
   CPoint point = CPoint((DWORD)lParam);

   CXTPTabManagerItem* pItem =  m_MTIClientWnd.HitTest(point);

   if (pItem)
   {
      if (wParam == WM_RBUTTONDOWN)
      {

         CWnd* pFrame = CWnd::FromHandle(pItem->GetHandle());
         MDIActivate(pFrame);

         m_MTIClientWnd.Refresh();

         CMenu menuPopup;
         VERIFY(menuPopup.LoadMenu(IDR_WORKSPACE_POPUP));

         m_MTIClientWnd.WorkspaceToScreen(&point);
         CXTPCommandBars::TrackPopupMenu(menuPopup.GetSubMenu(0), 0, point.x, point.y, this);

         m_MTIClientWnd.Refresh();

         return TRUE;
      }
   }

   return FALSE;
}
See also
CXTPTabClientWnd

◆ WM_XTP_PRETRANSLATEMOUSEMSG_EX

const UINT WM_XTP_PRETRANSLATEMOUSEMSG_EX = (WM_XTP_COMMANDBARS_BASE + 28)

The WM_XTP_PRETRANSLATEMOUSEMSG_EX message is sent to the main window from TearOffFrame to pre-translate mouse messages.

Parameters
wParam | mouse notification.
lParam | pointer to TTHITTESTINFO struct.
Returns
If the application is to process this message, the return value should be TRUE.

Example: Here is an example of how an application would process the WM_XTP_PRETRANSLATEMOUSEMSG_EX message.

BEGIN_MESSAGE_MAP(CMainFrame, CMDIFrameWnd)
    //{{AFX_MSG_MAP(CMainFrame)
    ON_MESSAGE(WM_XTP_PRETRANSLATEMOUSEMSG_EX, OnTabbarMouseMsgEx)
    //}}AFX_MSG_MAP
END_MESSAGE_MAP()

LRESULT CMainFrame::OnTabbarMouseMsgEx(WPARAM wParam, LPARAM lParam)
{
   if (wParam != WM_RBUTTONDOWN)
      return FALSE;

   TTHITTESTINFO* info = reinterpret_cast<TTHITTESTINFO*>(lParam);

   CWnd* pWnd = CWnd::FromHandle(info->hwnd);
   CXTPTabClientWnd* pTabClientWnd = DYNAMIC_DOWNCAST(CXTPTabClientWnd, pWnd);
   CXTPTabManagerItem* pItem = pTabClientWnd->HitTest(info->pt);
   if (!pItem)
      return FALSE;

   CFrameWnd* pFrame = DYNAMIC_DOWNCAST(CMDIChildWnd, CWnd::FromHandle(pItem->GetHandle()));
   if (!pFrame)
      return FALSE;

   MDIActivate(pFrame);
   pFrame->GetActiveView()->SetFocus();

   pTabClientWnd->Refresh();

   CMenu menu;
   VERIFY(XTPResourceManager()->LoadMenu(&menu, IDR_POPUP_TABS_EX));
   CMenu* pPopup = menu.GetSubMenu(0);

   pTabClientWnd->WorkspaceToScreen(&info->pt);

   CXTPPopupBar* pPopupBar = (CXTPPopupBar*)CXTPPopupBar::CreatePopupBar(GetCommandBars());
   VERIFY(pPopupBar->LoadMenu(pPopup));
   VERIFY(pPopupBar->Popup(info->pt.x, info->pt.y, NULL));

   while (pPopupBar->IsTrackingMode())
   {
      AfxGetApp()->PumpMessage();
   }
   pPopupBar->InternalRelease();

   pTabClientWnd->Refresh();
   return TRUE;
}
See also
CXTPTabClientWnd

◆ WM_XTP_SETACTIVEWORKSPACE

const UINT WM_XTP_SETACTIVEWORKSPACE = (WM_XTP_COMMANDBARS_BASE + 29)

The WM_XTP_SETACTIVEWORKSPACE message is sent to the owner window when workspace changed.

Parameters
wParam Active workspace.
Returns
If the application is to process this message, the return value should be TRUE.

◆ WM_XTP_TABTODOCKPANE

const UINT WM_XTP_TABTODOCKPANE = (WM_XTP_COMMANDBARS_BASE + 26)

The WM_XTP_TABTODOCKPANE message is sent to the owner window when a tab is being docked to Docking Panes.

Parameters
pNewItem (CXTPTabManagerItem*)wParam. Pointer to the tab that is being docking.
Returns
A new docking pane ID to be used for a new pane to be created.

Example: Here is an example of how an application would process the WM_XTP_NEWTABITEM message.

BEGIN_MESSAGE_MAP(CMainFrame, CMDIFrameWnd)
    //{{AFX_MSG_MAP(CMainFrame)
    ON_MESSAGE(WM_XTP_TABTODOCKPANE, OnTabbarDockPane)
    //}}AFX_MSG_MAP
END_MESSAGE_MAP()

LRESULT CMainFrame::OnTabbarDockPane(WPARAM wParam, LPARAM //lParam//)
{
CXTPTabManagerItem* pItem = (CXTPTabManagerItem*)wParam;
return 123;
}
See also
CXTPTabClientWnd


Toolkit Pro: XTPTabToolBar.h File Reference

  • Source
  • CommandBars
Classes
XTPTabToolBar.h File Reference

Go to the source code of this file.

Classes

class CXTPTabToolBar
CXTPTabToolBar is a CXTPToolBar derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPToolBar.h File Reference

  • Source
  • CommandBars
Classes
XTPToolBar.h File Reference

Go to the source code of this file.

Classes

class CXTPToolBar
CXTPToolBar is a CXTPCommandBar derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: Common Directory Reference

  • Source
  • Common
Common Directory Reference

Directories

Base
FrameShadow
Hook
IIDs
Math
PropExchange
ScrollBar

Files

XTPActiveScriptEngine.h
XTPApplication.h
XTPColorManager.h
XTPCustomHeap.h
XTPDrawHelpers.h
XTPFontManager.h
XTPFramework.h
XTPGdiObjects.h
XTPHookManager.h
XTPImageList.h
XTPImageManager.h
XTPImageManagerResource.h
XTPMacros.h
XTPMarkupRender.h
XTPMarkupTheme.h
XTPMaskEditT.h
XTPNotifyConnection.h
XTPNumberFormat.h
XTPPropExchange.h
XTPRegExp.h
XTPResource.h
XTPResourceImage.h
XTPResourceImageList.h
XTPResourceManager.h
XTPRichRender.h
XTPSingleton.h
XTPSmartPtrInternalT.h
XTPSynchro.h
XTPSystemHelpers.h
XTPSystemMetrics.h
XTPTheme.h
XTPThemeDLL.h
XTPToolTipContext.h
XTPTypeId.h
XTPWinThemeWrapper.h


Toolkit Pro: Base Directory Reference

  • Source
  • Common
  • Base
Base Directory Reference

Directories

Diagnostic
Types

Files

XTPWinApp.h
XTPWinThread.h


Toolkit Pro: Diagnostic Directory Reference

  • Source
  • Common
  • Base
  • Diagnostic
Diagnostic Directory Reference

Files

XTPBeginAfxMap.h
XTPDisableAdvancedWarnings.h
XTPDisableNoisyWarnings.h
XTPEnableAdvancedWarnings.h
XTPEnableNoisyWarnings.h
XTPEndAfxMap.h


Toolkit Pro: XTPBeginAfxMap.h File Reference

  • Source
  • Common
  • Base
  • Diagnostic
XTPBeginAfxMap.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPDisableAdvancedWarnings.h File Reference

  • Source
  • Common
  • Base
  • Diagnostic
XTPDisableAdvancedWarnings.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPDisableNoisyWarnings.h File Reference

  • Source
  • Common
  • Base
  • Diagnostic
XTPDisableNoisyWarnings.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPEnableAdvancedWarnings.h File Reference

  • Source
  • Common
  • Base
  • Diagnostic
XTPEnableAdvancedWarnings.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPEnableNoisyWarnings.h File Reference

  • Source
  • Common
  • Base
  • Diagnostic
XTPEnableNoisyWarnings.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPEndAfxMap.h File Reference

  • Source
  • Common
  • Base
  • Diagnostic
XTPEndAfxMap.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: Types Directory Reference

  • Source
  • Common
  • Base
  • Types
Types Directory Reference

Files

XTPPoint2.h
XTPPoint3.h
XTPRect.h
XTPSize.h


Toolkit Pro: XTPPoint2.h File Reference

  • Source
  • Common
  • Base
  • Types
Classes | Typedefs
XTPPoint2.h File Reference

Go to the source code of this file.

Classes

class CXTPPoint2T< T >
This class represents a two-dimensional point. More...

Typedefs

typedef CXTPPoint2T< int > | CXTPPoint2i
CXTPPoint2T shortcut for integer point object.
typedef CXTPPoint2T< float > | CXTPPoint2f
CXTPPoint2T shortcut for float point object.
typedef CXTPPoint2T< double > | CXTPPoint2d
CXTPPoint2T shortcut for double point object.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPPoint3.h File Reference

  • Source
  • Common
  • Base
  • Types
Classes | Typedefs
XTPPoint3.h File Reference

Go to the source code of this file.

Classes

class CXTPPoint3T< T >
This class represents a three-dimensional point. More...

Typedefs

typedef CXTPPoint3T< int > | CXTPPoint3i
CXTPPoint3T shortcut for integer point object.
typedef CXTPPoint3T< float > | CXTPPoint3f
CXTPPoint3T shortcut for float point object.
typedef CXTPPoint3T< double > | CXTPPoint3d
CXTPPoint3T shortcut for double point object.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPRect.h File Reference

  • Source
  • Common
  • Base
  • Types
Classes | Typedefs
XTPRect.h File Reference

Go to the source code of this file.

Classes

class CXTPRectT< T >
This class abstracts a rectangular entity and its operations. More...

Typedefs

typedef CXTPRectT< int > | CXTPRectI
CXTPRectT shortcut for integer rectangle object.
typedef CXTPRectT< float > | CXTPRectF
CXTPRectT shortcut for float rectangle object.
typedef CXTPRectT< double > | CXTPRectD
CXTPRectT shortcut for double rectangle object.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPSize.h File Reference

  • Source
  • Common
  • Base
  • Types
Classes | Typedefs
XTPSize.h File Reference

Go to the source code of this file.

Classes

class CXTPSizeT< T >
This class incapsulates size data. More...

Typedefs

typedef CXTPSizeT< int > | CXTPSizeI
CXTPSizeT shortcut for integer size object.
typedef CXTPSizeT< float > | CXTPSizeF
CXTPSizeT shortcut for float size object.
typedef CXTPSizeT< double > | CXTPSizeD
CXTPSizeT shortcut for double size object.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPWinApp.h File Reference

  • Source
  • Common
  • Base
Classes
XTPWinApp.h File Reference

Go to the source code of this file.

Classes

class CXTPWinApp
All XTP application classes have to derive from CXTPWinApp instead of CWinApp or CWinAppEx. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPWinThread.h File Reference

  • Source
  • Common
  • Base
Classes
XTPWinThread.h File Reference

Go to the source code of this file.

Classes

class CXTPWinThread
All XTP threads should derive from CXTPWinThread instead of CWinThread in order to ensure compatibility with the main process thread that is derived from CXTPWinApp. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: Controls Directory Reference

  • Source
  • Common
  • Controls
Controls Directory Reference

Directories

Progress


Toolkit Pro: Progress Directory Reference

  • Source
  • Common
  • Controls
  • Progress
Progress Directory Reference

Files

XTPProgressBase.h


Toolkit Pro: XTPProgressBase.h File Reference

  • Source
  • Common
  • Controls
  • Progress
Classes
XTPProgressBase.h File Reference

Go to the source code of this file.

Classes

class CXTPProgressBase
CXTPControlProgressBase is base class for all progress objects. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: FrameShadow Directory Reference

  • Source
  • Common
  • FrameShadow
FrameShadow Directory Reference

Files

XTPFrameShadow.h
XTPFrameShadowManager.h


Toolkit Pro: XTPFrameShadow.h File Reference

  • Source
  • Common
  • FrameShadow
Classes
XTPFrameShadow.h File Reference

Go to the source code of this file.

Classes

class CXTPFrameShadow
The class represents frame shadow object. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPFrameShadowManager.h File Reference

  • Source
  • Common
  • FrameShadow
Classes | Enumerations | Functions
XTPFrameShadowManager.h File Reference

Go to the source code of this file.

Classes

struct | IXTPFrameShadowManagerEvents
An interface for Frame Shadow Manager event listener. More...
class | CXTPFrameShadowManager
Provides frame shadow management functionality. More...

Enumerations

enum XTPFrameShadowManagerFlags {
xtpFrameShadowsDisabled = 1 , xtpFrameShadowsInvisible = 2 , xtpFrameShadowsNotResizeable = 4 , xtpFrameShadowsDisabledInTSS = 8 ,
xtpFrameShadowsInvisibleInTSS = 0x10
}
Global Frame Shadow Manager flags. More...

Functions

_XTP_EXT_CLASS CXTPFrameShadowManager *AFX_CDECL XTPFrameShadowManager ()
Provides access to the global frame shdow manager instance.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Enumeration Type Documentation

◆ XTPFrameShadowManagerFlags

enum XTPFrameShadowManagerFlags

Global Frame Shadow Manager flags.

Enumerator
xtpFrameShadowsDisabled | Frame shadows disabled. When this flags is set the existing shadow made invisible and not resizeable (xtpFrameShadowsInvisible | xtpFrameShadowsNotResizeable get enabled automatically) but no new shadows will be created for new windows.
xtpFrameShadowsInvisible | Frame shadows are not visible but remain resizeable.
xtpFrameShadowsNotResizeable | Frame shadows cannot be used for resizing the owner windows.
xtpFrameShadowsDisabledInTSS | Frame shadows are automatically disabled for Terminal Services sessions, e.g. Remote Desktop Connection. When it's set and a Terminal Services session is detected all existing and new shadows will be made invisible and not resizeable (xtpFrameShadowsInvisible | xtpFrameShadowsNotResizeable). Once terminal session abandoning is detected those flags will get restored to their original values.
xtpFrameShadowsInvisibleInTSS | Frame shadows are automatically invisible for Terminal Services sessions, e.g. Remote Desktop Connection, but remain resizealbe.

Function Documentation

◆ XTPFrameShadowManager()

_XTP_EXT_CLASS CXTPFrameShadowManager *AFX_CDECL XTPFrameShadowManager ( )

Provides access to the global frame shdow manager instance.

Returns
Global frame shadow instance pointer.


Toolkit Pro: Hook Directory Reference

  • Source
  • Common
  • Hook
Hook Directory Reference

Files

XTPWinEventHook.h


Toolkit Pro: XTPWinEventHook.h File Reference

  • Source
  • Common
  • Hook
XTPWinEventHook.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: IIDs Directory Reference

  • Source
  • Common
  • IIDs
IIDs Directory Reference

Files

XTPColorManagerIIDs.h
XTPFrameShadowManagerIIDs.h
XTPImageManagerIIDs.h
XTPOleDragDropIIDs.h
XTPPrintingIIDs.h
XTPPropExchangeIIDs.h
XTPResourceImagesIIDs.h
XTPToolTipContextIIDs.h


Toolkit Pro: XTPColorManagerIIDs.h Source File

  • Source
  • Common
  • IIDs
XTPColorManagerIIDs.h
1// DO NOT MODIFY MANUALLY
2// Generated on Thu 12/11/2025 at 12:46:03.17 using cj-update-iids.cmd
3
24#ifndef __XTPColorManagerIIDs_H__
25# define __XTPColorManagerIIDs_H__
26
27// clang-format off
28
29#define XTP_DEFINE_GUID(name,l,w1,w2,b1,b2,b3,b4,b5,b6,b7,b8) \
30 EXTERN_C __declspec(selectany) const IID XTP##name = {l,w1,w2,{b1,b2,b3,b4,b5,b6,b7,b8}}; \
31 const unsigned long XTP##name##__Data1 = (l); \
32 const unsigned short XTP##name##__Data2 = (w1); \
33 const unsigned short XTP##name##__Data3 = (w2); \
34 const unsigned char XTP##name##__Data4_0 = (b1); \
35 const unsigned char XTP##name##__Data4_1 = (b2); \
36 const unsigned char XTP##name##__Data4_2 = (b3); \
37 const unsigned char XTP##name##__Data4_3 = (b4); \
38 const unsigned char XTP##name##__Data4_4 = (b5); \
39 const unsigned char XTP##name##__Data4_5 = (b6); \
40 const unsigned char XTP##name##__Data4_6 = (b7); \
41 const unsigned char XTP##name##__Data4_7 = (b8);
42
43XTP_DEFINE_GUID(DIID_IColorManager,0xC0DE2430,0xDE43,0x4b56,0xBC,0xEB,0xE1,0x4B,0x82,0x5C,0xF2,0x45);
44XTP_DEFINE_GUID(CLSID_ColorManager,0xC0DE2430,0xF3FE,0x46E7,0xBB,0x64,0xDB,0x03,0x3F,0x43,0x9F,0x8B);
45
46#undef XTP_DEFINE_GUID
47
48// clang-format on
49
50#endif // __XTPColorManagerIIDs_H__


Toolkit Pro: XTPFrameShadowManagerIIDs.h Source File

  • Source
  • Common
  • IIDs
XTPFrameShadowManagerIIDs.h
1// DO NOT MODIFY MANUALLY
2// Generated on Thu 12/11/2025 at 12:46:03.93 using cj-update-iids.cmd
3
24#ifndef __XTPFrameShadowManagerIIDs_H__
25# define __XTPFrameShadowManagerIIDs_H__
26
27// clang-format off
28
29#define XTP_DEFINE_GUID(name,l,w1,w2,b1,b2,b3,b4,b5,b6,b7,b8) \
30 EXTERN_C __declspec(selectany) const IID XTP##name = {l,w1,w2,{b1,b2,b3,b4,b5,b6,b7,b8}}; \
31 const unsigned long XTP##name##__Data1 = (l); \
32 const unsigned short XTP##name##__Data2 = (w1); \
33 const unsigned short XTP##name##__Data3 = (w2); \
34 const unsigned char XTP##name##__Data4_0 = (b1); \
35 const unsigned char XTP##name##__Data4_1 = (b2); \
36 const unsigned char XTP##name##__Data4_2 = (b3); \
37 const unsigned char XTP##name##__Data4_3 = (b4); \
38 const unsigned char XTP##name##__Data4_4 = (b5); \
39 const unsigned char XTP##name##__Data4_5 = (b6); \
40 const unsigned char XTP##name##__Data4_6 = (b7); \
41 const unsigned char XTP##name##__Data4_7 = (b8);
42
43XTP_DEFINE_GUID(DIID_IFrameShadow,0xC0DE2430,0x87E4,0x460A,0x84,0x91,0x32,0xBD,0x8D,0xE3,0x26,0x9C);
44XTP_DEFINE_GUID(CLSID_FrameShadow,0xC0DE2430,0x5B81,0x4C3C,0xA6,0x8E,0x3F,0x0F,0xF3,0x77,0x1B,0x6E);
45XTP_DEFINE_GUID(DIID_IFrameShadows,0xC0DE2430,0xF2DA,0x4617,0xAD,0x07,0xFE,0x7F,0x08,0xC1,0x6C,0x0B);
46XTP_DEFINE_GUID(CLSID_FrameShadows,0xC0DE2430,0xB4D6,0x492D,0x93,0x1A,0x9A,0x39,0xD2,0x07,0xDE,0x99);
47XTP_DEFINE_GUID(DIID_IFrameShadowManager,0xC0DE2430,0x9BF8,0x4337,0x95,0x9A,0x46,0x29,0xC9,0x28,0x6C,0x7A);
48XTP_DEFINE_GUID(CLSID_FrameShadowManager,0xC0DE2430,0xDDA7,0x45FD,0x8A,0xE8,0xB1,0xA8,0x83,0x91,0x34,0x4D);
49
50#undef XTP_DEFINE_GUID
51
52// clang-format on
53
54#endif // __XTPFrameShadowManagerIIDs_H__


Toolkit Pro: XTPImageManagerIIDs.h Source File

  • Source
  • Common
  • IIDs
XTPImageManagerIIDs.h
1// DO NOT MODIFY MANUALLY
2// Generated on Thu 12/11/2025 at 12:46:04.68 using cj-update-iids.cmd
3
24#ifndef __XTPImageManagerIIDs_H__
25# define __XTPImageManagerIIDs_H__
26
27// clang-format off
28
29#define XTP_DEFINE_GUID(name,l,w1,w2,b1,b2,b3,b4,b5,b6,b7,b8) \
30 EXTERN_C __declspec(selectany) const IID XTP##name = {l,w1,w2,{b1,b2,b3,b4,b5,b6,b7,b8}}; \
31 const unsigned long XTP##name##__Data1 = (l); \
32 const unsigned short XTP##name##__Data2 = (w1); \
33 const unsigned short XTP##name##__Data3 = (w2); \
34 const unsigned char XTP##name##__Data4_0 = (b1); \
35 const unsigned char XTP##name##__Data4_1 = (b2); \
36 const unsigned char XTP##name##__Data4_2 = (b3); \
37 const unsigned char XTP##name##__Data4_3 = (b4); \
38 const unsigned char XTP##name##__Data4_4 = (b5); \
39 const unsigned char XTP##name##__Data4_5 = (b6); \
40 const unsigned char XTP##name##__Data4_6 = (b7); \
41 const unsigned char XTP##name##__Data4_7 = (b8);
42
43XTP_DEFINE_GUID(DIID_ImageManagerIcon,0xC0DE2430,0xAE6D,0x46a8,0xBC,0x77,0xCE,0xE7,0xD5,0xCE,0x9E,0xD7);
44XTP_DEFINE_GUID(DIID_ImageManagerIconSet,0xC0DE2430,0x374B,0x4AED,0x93,0x06,0x0B,0x7A,0xC4,0x34,0x3B,0xCC);
45XTP_DEFINE_GUID(DIID_IImageManagerIcons,0xC0DE2430,0xCD87,0x48F0,0xAD,0x57,0x63,0x68,0x2A,0x2F,0x3F,0xCC);
46XTP_DEFINE_GUID(CLSID_ImageManagerIcons,0xC0DE2430,0x4290,0x47A7,0x8B,0x05,0x90,0xAC,0x97,0x9F,0x12,0xD5);
47XTP_DEFINE_GUID(DIID_IResourceImageList,0xC0DE2430,0xF9CE,0x44F1,0x89,0x91,0x0F,0x6B,0x7C,0x19,0x33,0x6B);
48
49#undef XTP_DEFINE_GUID
50
51// clang-format on
52
53#endif // __XTPImageManagerIIDs_H__


Toolkit Pro: XTPOleDragDropIIDs.h Source File

  • Source
  • Common
  • IIDs
XTPOleDragDropIIDs.h
1// DO NOT MODIFY MANUALLY
2// Generated on Thu 12/11/2025 at 12:46:05.45 using cj-update-iids.cmd
3
24#ifndef __XTPOleDragDropIIDs_H__
25# define __XTPOleDragDropIIDs_H__
26
27// clang-format off
28
29#define XTP_DEFINE_GUID(name,l,w1,w2,b1,b2,b3,b4,b5,b6,b7,b8) \
30 EXTERN_C __declspec(selectany) const IID XTP##name = {l,w1,w2,{b1,b2,b3,b4,b5,b6,b7,b8}}; \
31 const unsigned long XTP##name##__Data1 = (l); \
32 const unsigned short XTP##name##__Data2 = (w1); \
33 const unsigned short XTP##name##__Data3 = (w2); \
34 const unsigned char XTP##name##__Data4_0 = (b1); \
35 const unsigned char XTP##name##__Data4_1 = (b2); \
36 const unsigned char XTP##name##__Data4_2 = (b3); \
37 const unsigned char XTP##name##__Data4_3 = (b4); \
38 const unsigned char XTP##name##__Data4_4 = (b5); \
39 const unsigned char XTP##name##__Data4_5 = (b6); \
40 const unsigned char XTP##name##__Data4_6 = (b7); \
41 const unsigned char XTP##name##__Data4_7 = (b8);
42
43XTP_DEFINE_GUID(DIID_DataObjectFiles,0xC0DE2430,0x604D,0x4242,0x95,0x4B,0xDF,0x38,0xBB,0xFA,0x8B,0xE3);
44XTP_DEFINE_GUID(DIID_DataObject,0xC0DE2430,0x300E,0x4EB2,0xAE,0x9B,0x6F,0x1B,0xA0,0x25,0xDF,0x31);
45
46#undef XTP_DEFINE_GUID
47
48// clang-format on
49
50#endif // __XTPOleDragDropIIDs_H__


Toolkit Pro: XTPPrintingIIDs.h Source File

  • Source
  • Common
  • IIDs
XTPPrintingIIDs.h
1// DO NOT MODIFY MANUALLY
2// Generated on Thu 12/11/2025 at 12:46:06.18 using cj-update-iids.cmd
3
24#ifndef __XTPPrintingIIDs_H__
25# define __XTPPrintingIIDs_H__
26
27// clang-format off
28
29#define XTP_DEFINE_GUID(name,l,w1,w2,b1,b2,b3,b4,b5,b6,b7,b8) \
30 EXTERN_C __declspec(selectany) const IID XTP##name = {l,w1,w2,{b1,b2,b3,b4,b5,b6,b7,b8}}; \
31 const unsigned long XTP##name##__Data1 = (l); \
32 const unsigned short XTP##name##__Data2 = (w1); \
33 const unsigned short XTP##name##__Data3 = (w2); \
34 const unsigned char XTP##name##__Data4_0 = (b1); \
35 const unsigned char XTP##name##__Data4_1 = (b2); \
36 const unsigned char XTP##name##__Data4_2 = (b3); \
37 const unsigned char XTP##name##__Data4_3 = (b4); \
38 const unsigned char XTP##name##__Data4_4 = (b5); \
39 const unsigned char XTP##name##__Data4_5 = (b6); \
40 const unsigned char XTP##name##__Data4_6 = (b7); \
41 const unsigned char XTP##name##__Data4_7 = (b8);
42
43XTP_DEFINE_GUID(DIID_XtremePrinterInfo,0xC0DE2430,0xED8F,0x4ce1,0x9E,0x36,0x40,0x38,0x76,0xBE,0xE5,0x57);
44XTP_DEFINE_GUID(DIID_XtremePrintPreviewOptions,0xC0DE2430,0x8BC5,0x4677,0x99,0x99,0x0A,0x29,0xB4,0x4F,0x3B,0x23);
45XTP_DEFINE_GUID(DIID_PrintPageHeaderFooter,0xC0DE2430,0xE75C,0x4a50,0xA9,0x08,0xF3,0x6D,0x35,0xF0,0x98,0xD2);
46XTP_DEFINE_GUID(DIID_PrintInfo,0xC0DE2430,0x0E2C,0x47FC,0xBF,0xB7,0x46,0xE7,0x0C,0x56,0x1A,0xA8);
47
48#undef XTP_DEFINE_GUID
49
50// clang-format on
51
52#endif // __XTPPrintingIIDs_H__


Toolkit Pro: XTPPropExchangeIIDs.h Source File

  • Source
  • Common
  • IIDs
XTPPropExchangeIIDs.h
1// DO NOT MODIFY MANUALLY
2// Generated on Thu 12/11/2025 at 12:46:02.42 using cj-update-iids.cmd
3
24#ifndef __XTPPropExchangeIIDs_H__
25# define __XTPPropExchangeIIDs_H__
26
27// clang-format off
28
29#define XTP_DEFINE_GUID(name,l,w1,w2,b1,b2,b3,b4,b5,b6,b7,b8) \
30 EXTERN_C __declspec(selectany) const IID XTP##name = {l,w1,w2,{b1,b2,b3,b4,b5,b6,b7,b8}}; \
31 const unsigned long XTP##name##__Data1 = (l); \
32 const unsigned short XTP##name##__Data2 = (w1); \
33 const unsigned short XTP##name##__Data3 = (w2); \
34 const unsigned char XTP##name##__Data4_0 = (b1); \
35 const unsigned char XTP##name##__Data4_1 = (b2); \
36 const unsigned char XTP##name##__Data4_2 = (b3); \
37 const unsigned char XTP##name##__Data4_3 = (b4); \
38 const unsigned char XTP##name##__Data4_4 = (b5); \
39 const unsigned char XTP##name##__Data4_5 = (b6); \
40 const unsigned char XTP##name##__Data4_6 = (b7); \
41 const unsigned char XTP##name##__Data4_7 = (b8);
42
43XTP_DEFINE_GUID(DIID_PropExchange,0xC0DE2430,0x1659,0x4A68,0xB8,0x26,0xDA,0xFC,0xAB,0x16,0xE8,0x24);
44XTP_DEFINE_GUID(CLSID_PropExchangeCtrl,0xC0DE2430,0x4A9A,0x4DBE,0xB4,0x9F,0x6F,0xF7,0x7F,0xB6,0x2C,0x30);
45
46#undef XTP_DEFINE_GUID
47
48// clang-format on
49
50#endif // __XTPPropExchangeIIDs_H__


Toolkit Pro: XTPResourceImagesIIDs.h Source File

  • Source
  • Common
  • IIDs
XTPResourceImagesIIDs.h
1// DO NOT MODIFY MANUALLY
2// Generated on Thu 12/11/2025 at 12:46:06.93 using cj-update-iids.cmd
3
24#ifndef __XTPResourceImagesIIDs_H__
25# define __XTPResourceImagesIIDs_H__
26
27// clang-format off
28
29#define XTP_DEFINE_GUID(name,l,w1,w2,b1,b2,b3,b4,b5,b6,b7,b8) \
30 EXTERN_C __declspec(selectany) const IID XTP##name = {l,w1,w2,{b1,b2,b3,b4,b5,b6,b7,b8}}; \
31 const unsigned long XTP##name##__Data1 = (l); \
32 const unsigned short XTP##name##__Data2 = (w1); \
33 const unsigned short XTP##name##__Data3 = (w2); \
34 const unsigned char XTP##name##__Data4_0 = (b1); \
35 const unsigned char XTP##name##__Data4_1 = (b2); \
36 const unsigned char XTP##name##__Data4_2 = (b3); \
37 const unsigned char XTP##name##__Data4_3 = (b4); \
38 const unsigned char XTP##name##__Data4_4 = (b5); \
39 const unsigned char XTP##name##__Data4_5 = (b6); \
40 const unsigned char XTP##name##__Data4_6 = (b7); \
41 const unsigned char XTP##name##__Data4_7 = (b8);
42
43XTP_DEFINE_GUID(DIID_ResourceImages,0xC0DE2430,0xFDDA,0x45CE,0xBB,0xFB,0xC5,0xE3,0xEE,0x3C,0x4E,0x7B);
44
45#undef XTP_DEFINE_GUID
46
47// clang-format on
48
49#endif // __XTPResourceImagesIIDs_H__


Toolkit Pro: XTPToolTipContextIIDs.h Source File

  • Source
  • Common
  • IIDs
XTPToolTipContextIIDs.h
1// DO NOT MODIFY MANUALLY
2// Generated on Thu 12/11/2025 at 12:46:08.46 using cj-update-iids.cmd
3
24#ifndef __XTPToolTipContextIIDs_H__
25# define __XTPToolTipContextIIDs_H__
26
27// clang-format off
28
29#define XTP_DEFINE_GUID(name,l,w1,w2,b1,b2,b3,b4,b5,b6,b7,b8) \
30 EXTERN_C __declspec(selectany) const IID XTP##name = {l,w1,w2,{b1,b2,b3,b4,b5,b6,b7,b8}}; \
31 const unsigned long XTP##name##__Data1 = (l); \
32 const unsigned short XTP##name##__Data2 = (w1); \
33 const unsigned short XTP##name##__Data3 = (w2); \
34 const unsigned char XTP##name##__Data4_0 = (b1); \
35 const unsigned char XTP##name##__Data4_1 = (b2); \
36 const unsigned char XTP##name##__Data4_2 = (b3); \
37 const unsigned char XTP##name##__Data4_3 = (b4); \
38 const unsigned char XTP##name##__Data4_4 = (b5); \
39 const unsigned char XTP##name##__Data4_5 = (b6); \
40 const unsigned char XTP##name##__Data4_6 = (b7); \
41 const unsigned char XTP##name##__Data4_7 = (b8);
42
43XTP_DEFINE_GUID(DIID_IToolTipContext,0xC0DE2430,0xBFB7,0x4925,0x9B,0xB5,0xD3,0xA0,0xDD,0xA4,0x69,0xAF);
44XTP_DEFINE_GUID(CLSID_ToolTipContext,0xC0DE2430,0x8C00,0x4f05,0xAF,0x87,0x9F,0x05,0xBC,0xB5,0x54,0x75);
45
46#undef XTP_DEFINE_GUID
47
48// clang-format on
49
50#endif // __XTPToolTipContextIIDs_H__


Toolkit Pro: Math Directory Reference

  • Source
  • Common
  • Math
Math Directory Reference

Files

XTPArcBall.h
XTPMathStats.h
XTPMathUtils.h
XTPMatrix.h


Toolkit Pro: XTPArcBall.h File Reference

  • Source
  • Common
  • Math
Classes
XTPArcBall.h File Reference

Go to the source code of this file.

Classes

class CXTPArcBall
Implements natural object rotation computation using quaternions. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMathStats.h File Reference

  • Source
  • Common
  • Math
XTPMathStats.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMathUtils.h File Reference

  • Source
  • Common
  • Math
Classes | Macros
XTPMathUtils.h File Reference

Go to the source code of this file.

Classes

class CXTPMathUtils
This class provide some mathematical utility functions. More...

Macros

#define | XTP_NAN CXTPMathUtils::GetNaN()
Evaluates to a double Not-A-Number value.
#define | XTP_ISNAN(v)
Returns TRUE if the value provided is double Not-A-Number value.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMatrix.h File Reference

  • Source
  • Common
  • Math
Classes
XTPMatrix.h File Reference

Go to the source code of this file.

Classes

class CXTPMatrix< T >
Represents a matrix object built upon a continuos array of elements and provides basic algorithms for it. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: PropExchange Directory Reference

  • Source
  • Common
  • PropExchange
PropExchange Directory Reference

Files

XTPPropExchangeArchive.h
XTPPropExchangeEnumerator.h
XTPPropExchangeEnumeratorPtr.h
XTPPropExchangeIniFile.h
XTPPropExchangeRegistry.h
XTPPropExchangeSection.h
XTPPropExchangeXMLNode.h


Toolkit Pro: XTPPropExchangeArchive.h File Reference

  • Source
  • Common
  • PropExchange
Classes
XTPPropExchangeArchive.h File Reference

Go to the source code of this file.

Classes

class CXTPPropExchangeArchive
CXTPPropExchangeArchive is CXTPPropExchange derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPPropExchangeEnumerator.h File Reference

  • Source
  • Common
  • PropExchange
Classes
XTPPropExchangeEnumerator.h File Reference

Go to the source code of this file.

Classes

class CXTPPropExchangeEnumerator
CXTPPropExchangeEnumerator is standalone class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPPropExchangeEnumeratorPtr.h File Reference

  • Source
  • Common
  • PropExchange
XTPPropExchangeEnumeratorPtr.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPPropExchangeIniFile.h File Reference

  • Source
  • Common
  • PropExchange
Classes
XTPPropExchangeIniFile.h File Reference

Go to the source code of this file.

Classes

class CXTPPropExchangeIniFile
CXTPPropExchangeIniFile is CXTPPropExchange derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPPropExchangeRegistry.h File Reference

  • Source
  • Common
  • PropExchange
Classes
XTPPropExchangeRegistry.h File Reference

Go to the source code of this file.

Classes

class CXTPPropExchangeRegistry
CXTPPropExchangeRegistry is CXTPPropExchange derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPPropExchangeSection.h File Reference

  • Source
  • Common
  • PropExchange
Classes
XTPPropExchangeSection.h File Reference

Go to the source code of this file.

Classes

class CXTPPropExchangeSection
CXTPPropExchangeSection is standalone class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPPropExchangeXMLNode.h File Reference

  • Source
  • Common
  • PropExchange
Classes
XTPPropExchangeXMLNode.h File Reference

Go to the source code of this file.

Classes

class CXTPPropExchangeXMLNode
CXTPPropExchangeXMLNode is CXTPPropExchange derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: ScrollBar Directory Reference

  • Source
  • Common
  • ScrollBar
ScrollBar Directory Reference

Directories

Themes

Files

XTPScrollable.h
XTPScrollBarContainer.h
XTPScrollBarCtrl.h
XTPScrollBarPaintManager.h
XTPScrollBase.h
XTPScrollInfo.h
XTPWnd.h


Toolkit Pro: Themes Directory Reference

  • Source
  • Common
  • ScrollBar
  • Themes
Themes Directory Reference

Files

XTPScrollBarThemeFlat.h
XTPScrollBarThemeNativeWindows10.h
XTPScrollBarThemeNativeWindows11.h
XTPScrollBarThemeOffice2000.h
XTPScrollBarThemeOffice2003.h
XTPScrollBarThemeOffice2013.h
XTPScrollBarThemeOfficeXP.h
XTPScrollBarThemeResource.h
XTPScrollBarThemeUltraFlat.h
XTPScrollBarThemeVisualStudio2012.h
XTPScrollBarThemeVisualStudio2015.h
XTPScrollBarThemeVisualStudio2017.h
XTPScrollBarThemeVisualStudio2019.h
XTPScrollBarThemeVisualStudio2022.h
XTPScrollBarThemeWindowsClassic.h
XTPScrollBarThemeWindowsUx.h


Toolkit Pro: XTPScrollBarThemeFlat.h File Reference

  • Source
  • Common
  • ScrollBar
  • Themes
Classes
XTPScrollBarThemeFlat.h File Reference

Go to the source code of this file.

Classes

class CXTPScrollBarThemeFlat
Scrollbar paint manager used to draw flat scrollbars. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPScrollBarThemeNativeWindows10.h File Reference

  • Source
  • Common
  • ScrollBar
  • Themes
Classes
XTPScrollBarThemeNativeWindows10.h File Reference

Go to the source code of this file.

Classes

class CXTPScrollBarThemeNativeWindows10
Scrollbar paint manager used to draw Native Windows 10 like scrollbars. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPScrollBarThemeNativeWindows11.h File Reference

  • Source
  • Common
  • ScrollBar
  • Themes
Classes
XTPScrollBarThemeNativeWindows11.h File Reference

Go to the source code of this file.

Classes

class CXTPScrollBarThemeNativeWindows11
Scrollbar paint manager used to draw Native Windows 10 like scrollbars. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPScrollBarThemeOffice2000.h File Reference

  • Source
  • Common
  • ScrollBar
  • Themes
Classes
XTPScrollBarThemeOffice2000.h File Reference

Go to the source code of this file.

Classes

class CXTPScrollBarThemeOffice2000
Scrollbar paint manager used to draw Office 200 like scrollbars. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPScrollBarThemeOffice2003.h File Reference

  • Source
  • Common
  • ScrollBar
  • Themes
Classes
XTPScrollBarThemeOffice2003.h File Reference

Go to the source code of this file.

Classes

class CXTPScrollBarThemeOffice2003
Scrollbar paint manager used to draw Office 2003 like scrollbars. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPScrollBarThemeOffice2013.h File Reference

  • Source
  • Common
  • ScrollBar
  • Themes
Classes
XTPScrollBarThemeOffice2013.h File Reference

Go to the source code of this file.

Classes

struct | XTP_SCROLLBARINICOLORS
Used by paint manager to retrieve color settings from the loaded resource INI file. More...
struct | XTP_SCROLLBARDRAWCOLORS
Used by paint manager to retrieve the current state color settings when drawing scrollbars. More...
class | CXTPScrollBarThemeOffice2013
The CXTPScrollBarThemeOffice2013 class is used to enable a Gallery Office 2013 style theme for Command Bars. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPScrollBarThemeOfficeXP.h File Reference

  • Source
  • Common
  • ScrollBar
  • Themes
Classes
XTPScrollBarThemeOfficeXP.h File Reference

Go to the source code of this file.

Classes

class CXTPScrollBarThemeOfficeXP
Scrollbar paint manager used to draw Office XP like scrollbars. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPScrollBarThemeResource.h File Reference

  • Source
  • Common
  • ScrollBar
  • Themes
Classes
XTPScrollBarThemeResource.h File Reference

Go to the source code of this file.

Classes

class CXTPScrollBarThemeResource
Scrollbar paint manager used to draw scrollbars from the currently loaded resource image data. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPScrollBarThemeUltraFlat.h File Reference

  • Source
  • Common
  • ScrollBar
  • Themes
Classes
XTPScrollBarThemeUltraFlat.h File Reference

Go to the source code of this file.

Classes

class CXTPScrollBarThemeUltraFlat
Scrollbar paint manager used to draw ultra flat scrollbars. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPScrollBarThemeVisualStudio2012.h File Reference

  • Source
  • Common
  • ScrollBar
  • Themes
Classes
XTPScrollBarThemeVisualStudio2012.h File Reference

Go to the source code of this file.

Classes

class CXTPScrollBarThemeVisualStudio2012
Scrollbar paint manager used to draw Visual Studio 2012 like scrollbars. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPScrollBarThemeVisualStudio2015.h File Reference

  • Source
  • Common
  • ScrollBar
  • Themes
Classes
XTPScrollBarThemeVisualStudio2015.h File Reference

Go to the source code of this file.

Classes

class CXTPScrollBarThemeVisualStudio2015
Scrollbar paint manager used to draw Visual Studio 2015 like scrollbars. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPScrollBarThemeVisualStudio2017.h File Reference

  • Source
  • Common
  • ScrollBar
  • Themes
Classes
XTPScrollBarThemeVisualStudio2017.h File Reference

Go to the source code of this file.

Classes

class CXTPScrollBarThemeVisualStudio2017
Scrollbar paint manager used to draw Visual Studio 2017 like scrollbars. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPScrollBarThemeVisualStudio2019.h File Reference

  • Source
  • Common
  • ScrollBar
  • Themes
Classes
XTPScrollBarThemeVisualStudio2019.h File Reference

Go to the source code of this file.

Classes

class CXTPScrollBarThemeVisualStudio2019
Scrollbar paint manager used to draw Visual Studio 2019 like scrollbars. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPScrollBarThemeVisualStudio2022.h File Reference

  • Source
  • Common
  • ScrollBar
  • Themes
Classes
XTPScrollBarThemeVisualStudio2022.h File Reference

Go to the source code of this file.

Classes

class CXTPScrollBarThemeVisualStudio2022
Scrollbar paint manager used to draw Visual Studio 2022 like scrollbars. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPScrollBarThemeWindowsClassic.h File Reference

  • Source
  • Common
  • ScrollBar
  • Themes
Classes
XTPScrollBarThemeWindowsClassic.h File Reference

Go to the source code of this file.

Classes

class CXTPScrollBarThemeWindowsClassic
Scrollbar paint manager used to draw classic Windows scrollbars. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPScrollBarThemeWindowsUx.h File Reference

  • Source
  • Common
  • ScrollBar
  • Themes
Classes
XTPScrollBarThemeWindowsUx.h File Reference

Go to the source code of this file.

Classes

class CXTPScrollBarThemeWindowsUx
Scrollbar paint manager used to draw scrollbars that use current Windows theme. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPScrollable.h File Reference

  • Source
  • Common
  • ScrollBar
Classes
XTPScrollable.h File Reference

Go to the source code of this file.

Classes

struct | IXTPScrollable
This interface is to be implemented only by special scrollable controls that require overriding of scroll bars using CXTPScrollable adaptor and for which the default implementation of this interface by CXTPScrollable does not work. More...
class | CXTPScrollable< Base >
The adaptor class for a scrollable control for which standard scroll bars have to be overriden. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPScrollBarContainer.h File Reference

  • Source
  • Common
  • ScrollBar
Classes
XTPScrollBarContainer.h File Reference

Go to the source code of this file.

Classes

class | CXTPScrollBarContainer< Parent >
CXTPScrollBarContainer class adds XTP scroll bars to a class derived from CWnd. More...
class | CXTPDialogScrollBarContainer< Parent >
CXTPDialogScrollBarContainer class adds XTP scroll bars to a class derived from CDialog. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPScrollBarCtrl.h File Reference

  • Source
  • Common
  • ScrollBar
Classes
XTPScrollBarCtrl.h File Reference

Go to the source code of this file.

Classes

class CXTPScrollBarCtrl
Scrollbar control. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPScrollBarPaintManager.h File Reference

  • Source
  • Common
  • ScrollBar
Classes
XTPScrollBarPaintManager.h File Reference

Go to the source code of this file.

Classes

class CXTPScrollBarPaintManager
CXTPScrollBarPaintManager is standalone class used to draw CXTPCommandBarScrollBarCtrl object. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPScrollBase.h File Reference

  • Source
  • Common
  • ScrollBar
Classes | Macros | Enumerations
XTPScrollBase.h File Reference

Go to the source code of this file.

Classes

struct | NMXTPSCROLL
The NMXTPSCROLL structure contains information about the scroll bar. More...
struct | XTP_SCROLLBAR_POSINFO
The XTP_SCROLLBAR_POSINFO structure contains scroll bar information. More...
struct | XTP_SCROLLBAR_TRACKINFO
The XTP_SCROLLBAR_TRACKINFO structure contains tracking information. More...
struct | XTP_SLIDERTICKS
The XTP_SLIDERTICKS structure contains slider ticks. More...
class | CXTPScrollBase
CXTPScrollBase is the base class for all scrollable objects. More...

Macros

#define | XTP_HTSCROLLUP 60
Scroll up hit test.
#define | XTP_HTSCROLLDOWN 61
Scroll down hit test.
#define | XTP_HTSCROLLLEFT 60
Scroll left hit test.
#define | XTP_HTSCROLLRIGHT 61
Scroll right hit test.
#define | XTP_HTSCROLLUPPAGE 62
Scroll up page hit test.
#define | XTP_HTSCROLLDOWNPAGE 63
Scroll down page hit test.
#define | XTP_HTSCROLLTHUMB 64
Scroll thumb hit test.
#define | XTP_HTSCROLLPOPUP 65
Scroll popup hit test.

Enumerations

enum XTPScrollBarStyle {
xtpScrollStyleDefault , xtpScrollStyleStandard , xtpScrollStyleFlat , xtpScrollStyleSystem ,
xtpScrollStyleOffice , xtpScrollStyleOffice2007Light , xtpScrollStyleOffice2007Dark , xtpScrollStyleSlider ,
xtpScrollStyleVisualStudio2012Light , xtpScrollStyleVisualStudio2012Dark , xtpScrollStyleVisualStudio2015 , xtpScrollStyleNativeWindows10 ,
xtpScrollStyleVisualStudio2017 , xtpScrollStyleVisualStudio2019 , xtpScrollStyleVisualStudio2022 , xtpScrollStyleNativeWindows11
}
Scrollbar style. More...
enum XTPScrollBarTheme {
xtpScrollBarThemeWindowsClassic , xtpScrollBarThemeWindowsDefault , xtpScrollBarThemeFlat , xtpScrollBarThemeUltraFlat ,
xtpScrollBarThemeResource , xtpScrollBarThemeOffice2000 , xtpScrollBarThemeOfficeXP , xtpScrollBarThemeOffice2003 ,
xtpScrollBarThemeOffice2007Light , xtpScrollBarThemeOffice2007Dark , xtpScrollBarThemeOffice2010 , xtpScrollBarThemeOffice2013 ,
xtpScrollBarThemeOffice2016 = xtpScrollBarThemeOffice2013 , xtpScrollBarThemeVisualStudio2012Light , xtpScrollBarThemeVisualStudio2012Dark , xtpScrollBarThemeVisualStudio2015 ,
xtpScrollBarThemeVisualStudio2017 , xtpScrollBarThemeVisualStudio2019 , xtpScrollBarThemeVisualStudio2022 , xtpScrollBarThemeNativeWindows10 ,
xtpScrollBarThemeNativeWindows11 , xtpScrollBarThemeVisualStudio6 = xtpScrollBarThemeWindowsClassic , xtpScrollBarThemeVisualStudio2002 = xtpScrollBarThemeWindowsDefault , xtpScrollBarThemeVisualStudio2003 = xtpScrollBarThemeWindowsDefault ,
xtpScrollBarThemeVisualStudio2005 = xtpScrollBarThemeWindowsDefault , xtpScrollBarThemeVisualStudio2008 = xtpScrollBarThemeWindowsDefault , xtpScrollBarThemeVisualStudio2010 = xtpScrollBarThemeWindowsDefault
}
Scrollbar theme identifier enum. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Macro Definition Documentation

◆ XTP_HTSCROLLDOWN

#define XTP_HTSCROLLDOWN 61

Scroll down hit test.

See also
CXTPScrollBase::HitTestScrollBar \ \ \ \

◆ XTP_HTSCROLLDOWNPAGE

#define XTP_HTSCROLLDOWNPAGE 63

Scroll down page hit test.

See also
CXTPScrollBase::HitTestScrollBar

◆ XTP_HTSCROLLLEFT

#define XTP_HTSCROLLLEFT 60

Scroll left hit test.

See also
CXTPScrollBase::HitTestScrollBar \ \ \ \

◆ XTP_HTSCROLLPOPUP

#define XTP_HTSCROLLPOPUP 65

Scroll popup hit test.

See also
CXTPScrollBase::HitTestScrollBar

◆ XTP_HTSCROLLRIGHT

#define XTP_HTSCROLLRIGHT 61

Scroll right hit test.

See also
CXTPScrollBase::HitTestScrollBar

◆ XTP_HTSCROLLTHUMB

#define XTP_HTSCROLLTHUMB 64

Scroll thumb hit test.

See also
CXTPScrollBase::HitTestScrollBar

◆ XTP_HTSCROLLUP

#define XTP_HTSCROLLUP 60

Scroll up hit test.

See also
CXTPScrollBase::HitTestScrollBar

◆ XTP_HTSCROLLUPPAGE

#define XTP_HTSCROLLUPPAGE 62

Scroll up page hit test.

See also
CXTPScrollBase::HitTestScrollBar

Enumeration Type Documentation

◆ XTPScrollBarStyle

enum XTPScrollBarStyle

Scrollbar style.

See also
CXTPScrollBase::SetScrollBarStyle
Enumerator
xtpScrollStyleDefault | Default style.
xtpScrollStyleStandard | standard window theme
xtpScrollStyleFlat | Flat scrollbar style.
xtpScrollStyleSystem | WinXP themed style.
xtpScrollStyleOffice | Office scrollbar style.
xtpScrollStyleOffice2007Light | Office 2007 light style.
xtpScrollStyleOffice2007Dark | Office 2007 dark style.
xtpScrollStyleSlider | Makes the scrollbar look like a slider control.
xtpScrollStyleVisualStudio2012Light | Visual Studio 2012 Light.
xtpScrollStyleVisualStudio2012Dark | Visual Studio 2012 Dark.
xtpScrollStyleVisualStudio2015 | Visual Studio 2015.
xtpScrollStyleNativeWindows10 | Native Windows 10.
xtpScrollStyleVisualStudio2017 | Visual Studio 2017.
xtpScrollStyleVisualStudio2019 | Visual Studio 2019.
xtpScrollStyleVisualStudio2022 | Visual Studio 2022.
xtpScrollStyleNativeWindows11 | Native Windows 11.

◆ XTPScrollBarTheme

enum XTPScrollBarTheme

Scrollbar theme identifier enum.

Enumerator
xtpScrollBarThemeWindowsClassic | Windows classic style theme.
xtpScrollBarThemeWindowsDefault | Windows default style theme.
xtpScrollBarThemeFlat | Flat appearance style theme.
xtpScrollBarThemeUltraFlat | Ultra flat appearance style theme.
xtpScrollBarThemeResource | Resource defined theme.
xtpScrollBarThemeOffice2000 | Office 2000 theme.
xtpScrollBarThemeOfficeXP | Office XP theme.
xtpScrollBarThemeOffice2003 | Office 2003 theme.
xtpScrollBarThemeOffice2007Light | Office 2007 light theme.
xtpScrollBarThemeOffice2007Dark | Office 2007 dark theme.
xtpScrollBarThemeOffice2010 | Office 2010 theme.
xtpScrollBarThemeOffice2013 | Office 2013 theme.
xtpScrollBarThemeOffice2016 | Office 2016 theme.
xtpScrollBarThemeVisualStudio2012Light | Visual Studio 2012 light theme.
xtpScrollBarThemeVisualStudio2012Dark | Visual Studio 2012 dark theme.
xtpScrollBarThemeVisualStudio2015 | Visual Studio 2015 theme.
xtpScrollBarThemeVisualStudio2017 | Visual Studio 2017 theme.
xtpScrollBarThemeVisualStudio2019 | Visual Studio 2019 theme.
xtpScrollBarThemeVisualStudio2022 | Visual Studio 2022 theme.
xtpScrollBarThemeNativeWindows10 | Native Windows 10 theme.
xtpScrollBarThemeNativeWindows11 | Native Windows 11 theme.
xtpScrollBarThemeVisualStudio6 | Visual Studio 6 theme.
xtpScrollBarThemeVisualStudio2002 | Visual Studio 2002 theme.
xtpScrollBarThemeVisualStudio2003 | Visual Studio 2003 theme.
xtpScrollBarThemeVisualStudio2005 | Visual Studio 2005 theme.
xtpScrollBarThemeVisualStudio2008 | Visual Studio 2008 theme.
xtpScrollBarThemeVisualStudio2010 | Visual Studio 2010 theme.


Toolkit Pro: XTPScrollInfo.h File Reference

  • Source
  • Common
  • ScrollBar
XTPScrollInfo.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPWnd.h File Reference

  • Source
  • Common
  • ScrollBar
XTPWnd.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPActiveScriptEngine.h File Reference

  • Source
  • Common
Classes
XTPActiveScriptEngine.h File Reference

Go to the source code of this file.

Classes

class | CXTPActiveScriptObjectContext
Wrapper around scriptable object. More...
class | CXTPActiveScriptEngine
Implements ActiveScript engine component. More...
class | CXTPActiveScriptStdRuntime
Implements standard scripting runtime library. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPApplication.h File Reference

  • Source
  • Common
Classes | Enumerations | Functions
XTPApplication.h File Reference

Go to the source code of this file.

Classes

struct | IXTPApplicationEvents
Defines a callback interface for XTP application event sink. More...
class | CXTPApplication
Defines a global XTP application object interface. More...

Enumerations

enum XTPApplicationAmbientProperty { xtpApplicationAccentColor , xtpApplicationStateColor , xtpApplicationUseSystemAccentColor }
Global ambient property identifiers. More...

Functions

_XTP_EXT_CLASS BOOL AFX_CDECL | XTPInitialize (int xtpComInit=xtpComInitAppDefault)
Initializes XTP framework.
_XTP_EXT_CLASS CXTPApplication *AFX_CDECL | XTPGetApplication ()
Obtains the only XTP application instance pointer.
_XTP_EXT_CLASS void AFX_CDECL | XTPShutdown ()
Performs XTP application shutting down with releasing all internal XTP pointers and resources but not terminating the calling thread.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Enumeration Type Documentation

◆ XTPApplicationAmbientProperty

enum XTPApplicationAmbientProperty

Global ambient property identifiers.

Enumerator
xtpApplicationAccentColor

Ambient accent color value.

A COLORREF value determined by VT_I4 variant field. COLORREF_NULL should be used to specify a default accent color value determined individually by each suscribed client.

xtpApplicationStateColor

Ambient state color value.

A COLORREF value determined by VT_I4 variant field. COLORREF_NULL should be used to specify a default state color value determined individually by each suscribed client.

See also
XTPSetVSStateColor
xtpApplicationUseSystemAccentColor

A long boolean value that enables use of the current system accent/colorization color used instead applicable.

The default value is 0.

Function Documentation

◆ XTPGetApplication()

_XTP_EXT_CLASS CXTPApplication *AFX_CDECL XTPGetApplication ( )

Obtains the only XTP application instance pointer.

Must be called between XTPInitialize and XTPShutdown calls.

Returns
The only XTP application instance pointer.
See also
XTPInitialize, XTPShutdown

◆ XTPInitialize()

_XTP_EXT_CLASS BOOL AFX_CDECL XTPInitialize ( int xtpComInit = xtpComInitAppDefault )

Initializes XTP framework.

Must not be called after XTPShutdown call. For backward compatibility the call is optional, however future versions may require it to be called before any other call to XTP framework. CXTPWinApp calls it automatically in InitInstance.

Parameters
xtpComInit Global COM/OLE initialization method.
Returns
TRUE if XTP framework is initialized successfully.

If extended COM initialization flags are being used bu CoInitializeEx function is not available then xtpComInitSTA is assumed, all other flags get ignored and the legacy CoInitialize gets called.

See also
XTPGetApplication, XTPShutdown, CXTPWinApp

◆ XTPShutdown()

_XTP_EXT_CLASS void AFX_CDECL XTPShutdown ( )

Performs XTP application shutting down with releasing all internal XTP pointers and resources but not terminating the calling thread.

The call to XTPShutdown must happen as late as possible at runtime but no later than returning from WinMain or DllMain. For backward compatibility it still is called by framework automatically on static storage destruction but the order of this operation is not guaranteed. CXTPWinApp calls it automatically in ExitInstance.

See also
XTPInitialize, XTPGetApplication, CXTPWinApp


Toolkit Pro: XTPColorManager.h File Reference

  • Source
  • Common
Classes | Enumerations | Functions | Variables
XTPColorManager.h File Reference

Go to the source code of this file.

Classes

class | CXTPPaintManagerColor
The CXTPPaintManagerColor class is used to manage COLORREF values for determining default and application defined colors. More...
class | CXTPPaintManagerColorGradient
The CXTPPaintManagerColorGradient class is used to manage COLORREF values for determining light and dark gradient colors. More...
class | CXTPColorManager
CXTPColorManager is a stand alone class. More...

Enumerations

enum XTPCurrentSystemTheme {
xtpSystemThemeUnknown , xtpSystemThemeBlue , xtpSystemThemeOlive , xtpSystemThemeSilver ,
xtpSystemThemeRoyale , xtpSystemThemeAero , xtpSystemThemeAuto , xtpSystemThemeDefault
}
Enumeration used to determine the current Windows XP theme in use. More...
enum XTPPaintManagerAccentColor {
xtpPaintManagerAccentColor , xtpPaintManagerNormalBackAccentColor , xtpPaintManagerHighlightBackAccentColor , xtpPaintManagerPressedBackAccentColor ,
xtpPaintManagerNormalTextAccentColor , xtpPaintManagerHighlightTextAccentColor , xtpPaintManagerPressedTextAccentColor
}
Defines a set of accent related colors. More...

Functions

_XTP_EXT_CLASS CXTPColorManager *AFX_CDECL | XTPColorManager ()
Call this function to access CXTPColorManager members.
_XTP_EXT_CLASS COLORREF AFX_CDECL | GetXtremeColor (UINT nIndex)
Call this member as a convenient way to call XTPColorManager()->GetColor, see CXTPColorManager::GetColor for more details.
_XTP_EXT_CLASS COLORREF AFX_CDECL | GetMSO2003Color (UINT nIndex)
Call this function to get the MS Office color represented by nIndex.
_XTP_EXT_CLASS void AFX_CDECL | RefreshXtremeColors (BOOL bResetCustomColors=TRUE)
This global function will refresh the display element colors defined in the CXTPColorManager class.
_XTP_EXT_CLASS COLORREF AFX_CDECL | XTPGetAccentColor (XTPPaintManagerAccentColor nColor)
Calculate the specified accent color value.
_XTP_EXT_CLASS COLORREF AFX_CDECL | XTPGetColorizationColor ()
Retrieves the current color used for Desktop Window Manager (DWM) glass composition.

Variables

const int | XPCOLOR_BASE = 30
const int | XPCOLOR_TOOLBAR_FACE = XPCOLOR_BASE
const int | XPCOLOR_HIGHLIGHT = 31
const int | XPCOLOR_HIGHLIGHT_BORDER = 32
const int | XPCOLOR_HIGHLIGHT_PUSHED = 33
const int | XPCOLOR_ICONSHADDOW = 34
const int | XPCOLOR_MENUBAR_GRAYTEXT = 35
const int | XPCOLOR_GRAYTEXT = XPCOLOR_MENUBAR_GRAYTEXT
const int | XPCOLOR_HIGHLIGHT_CHECKED = 36
const int | XPCOLOR_HIGHLIGHT_CHECKED_BORDER = 37
const int | XPCOLOR_TOOLBAR_GRIPPER = 38
const int | XPCOLOR_SEPARATOR = 39
const int | XPCOLOR_DISABLED = 40
const int | XPCOLOR_MENUBAR_FACE = 41
const int | XPCOLOR_MENUBAR_EXPANDED = 42
const int | XPCOLOR_MENUBAR_BORDER = 43
const int | XPCOLOR_MENUBAR_TEXT = 44
const int | XPCOLOR_HIGHLIGHT_TEXT = 45
const int | XPCOLOR_CHECKED_TEXT = XPCOLOR_HIGHLIGHT_TEXT
const int | XPCOLOR_TOOLBAR_TEXT = 46
const int | XPCOLOR_PUSHED_TEXT = 47
const int | XPCOLOR_TAB_INACTIVE_BACK = 48
const int | XPCOLOR_TAB_INACTIVE_TEXT = 49
const int | XPCOLOR_HIGHLIGHT_PUSHED_BORDER = 50
const int | XPCOLOR_3DFACE = 51
const int | XPCOLOR_3DSHADOW = 52
const int | XPCOLOR_EDITCTRLBORDER = 53
const int | XPCOLOR_FRAME = 54
const int | XPCOLOR_SPLITTER_FACE = 55
const int | XPCOLOR_LABEL = 56
const int | XPCOLOR_STATICFRAME = 57
const int | XPCOLOR_HIGHLIGHT_DISABLED_BORDER = 58
const int | XPCOLOR_SHADOW_FACTOR = 59
const int | XPCOLOR_TOOLBAR_GRAYTEXT = 60
const int | XPCOLOR_FLOATBAR_BORDER = 61
const int | XPCOLOR_LAST = 62

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Enumeration Type Documentation

◆ XTPCurrentSystemTheme

enum XTPCurrentSystemTheme

Enumeration used to determine the current Windows XP theme in use.

Example:

XTPCurrentSystemTheme systemTheme = XTPColorManager()->GetCurrentSystemTheme();
See also
xtpSystemThemeUnknown, xtpSystemThemeBlue, xtpSystemThemeOlive, xtpSystemThemeSilver, xtpSystemThemeAuto, xtpSystemThemeDefault, CXTPColorManager::GetCurrentSystemTheme
Enumerator
xtpSystemThemeUnknown | No known theme in use.
xtpSystemThemeBlue | Luna Blue Windows XP theme in use.
xtpSystemThemeOlive | Luna Olive Windows XP theme in use.
xtpSystemThemeSilver | Luna Silver Windows XP theme in use.
xtpSystemThemeRoyale | Royale Windows XP theme in use.
xtpSystemThemeAero | Aero Vista theme in use.
xtpSystemThemeAuto | Use OS theme.
xtpSystemThemeDefault | Default theme (xtpSystemThemeAuto)

◆ XTPPaintManagerAccentColor

enum XTPPaintManagerAccentColor

Defines a set of accent related colors.

Enumerator
xtpPaintManagerAccentColor | The actual accent color.
xtpPaintManagerNormalBackAccentColor | The background accent color in normal state.
xtpPaintManagerHighlightBackAccentColor | The background accent color in highlighted state.
xtpPaintManagerPressedBackAccentColor | The background accent color in pressed state.
xtpPaintManagerNormalTextAccentColor | The text accent color in normal state.
xtpPaintManagerHighlightTextAccentColor | The text accent color in highlighted state.
xtpPaintManagerPressedTextAccentColor | The text accent color in pressed state.

Function Documentation

◆ GetMSO2003Color()

_XTP_EXT_CLASS COLORREF AFX_CDECL GetMSO2003Color ( UINT nIndex )

Call this function to get the MS Office color represented by nIndex.

Parameters
nIndex Specifies the display element whose color is to be retrieved.
Returns
An RGB color value representing the color value of the MS Office color.

Example:

switch (XTPColorManager()->GetCurrentSystemTheme())
{
     case xtpSystemThemeBlue:
     case xtpSystemThemeOlive:
     case xtpSystemThemeSilver:
          m_clr3DFacePushed.SetStandardValue(GetMSO2003Color(XPCOLOR_HIGHLIGHT_PUSHED));
          m_clr3DFaceHilite.SetStandardValue(GetMSO2003Color(XPCOLOR_HIGHLIGHT));
          m_clrBtnTextPushed.SetStandardValue(GetMSO2003Color(XPCOLOR_PUSHED_TEXT));
          m_clrBtnTextHilite.SetStandardValue(GetMSO2003Color(XPCOLOR_HIGHLIGHT_TEXT));
          m_clrBorder3DShadow.SetStandardValue(GetMSO2003Color(XPCOLOR_HIGHLIGHT_BORDER));
          m_clrBorder3DHilite.SetStandardValue(GetMSO2003Color(XPCOLOR_HIGHLIGHT_BORDER));
          break;
}
See also
CXTPColorManager::GetColor

◆ GetXtremeColor()

_XTP_EXT_CLASS COLORREF AFX_CDECL GetXtremeColor ( UINT nIndex )

Call this member as a convenient way to call XTPColorManager()->GetColor, see CXTPColorManager::GetColor for more details.

Parameters
nIndex Specifies the display element whose color is to be retrieved.
Returns
The red, green, blue (RGB) color value of the given element.

Example:

if (eState == xtMouseNormal)
{
   pDC->Draw3dRect(rcItem,
   GetXtremeColor(COLOR_3DFACE),
   GetXtremeColor(COLOR_3DFACE));
}
See also
CXTPColorManager::GetColor

◆ RefreshXtremeColors()

_XTP_EXT_CLASS void AFX_CDECL RefreshXtremeColors ( BOOL bResetCustomColors = TRUE )

This global function will refresh the display element colors defined in the CXTPColorManager class.

Parameters
bResetCustomColors If FALSE, all custom colors will remain unchanged.
Returns
See also
CXTPColorManager::RefreshColors

◆ XTPColorManager()

_XTP_EXT_CLASS CXTPColorManager *AFX_CDECL XTPColorManager ( )

Call this function to access CXTPColorManager members.

Since this class is designed as a single instance object you can only access version info through this method. You cannot directly instantiate an object of type CXTPColorManager.

Example:

COLORREF cr = XTPColorManager()->GetColor(nIndex);
Returns
A global color manager object pointer.

◆ XTPGetAccentColor()

_XTP_EXT_CLASS COLORREF AFX_CDECL XTPGetAccentColor ( XTPPaintManagerAccentColor nColor )

Calculate the specified accent color value.

Parameters
nColor Accent color identifier.
Returns
Returns accent color value

◆ XTPGetColorizationColor()

_XTP_EXT_CLASS COLORREF AFX_CDECL XTPGetColorizationColor ( )

Retrieves the current color used for Desktop Window Manager (DWM) glass composition.

This value is based on the current color scheme and can be modified by the user. Applications can listen for color changes by handling the WM_DWMCOLORIZATIONCOLORCHANGED notification.

Returns
The current color used for glass composition or COLORREF_NULL if unable to obtain the value.

Variable Documentation

◆ XPCOLOR_3DFACE

const int XPCOLOR_3DFACE = 51
See also
CXTPColorManager::GetColor>

◆ XPCOLOR_3DSHADOW

const int XPCOLOR_3DSHADOW = 52
See also
CXTPColorManager::GetColor>

◆ XPCOLOR_BASE

const int XPCOLOR_BASE = 30
See also
CXTPColorManager::GetColor>

◆ XPCOLOR_CHECKED_TEXT

const int XPCOLOR_CHECKED_TEXT = XPCOLOR_HIGHLIGHT_TEXT
See also
CXTPColorManager::GetColor>

◆ XPCOLOR_DISABLED

const int XPCOLOR_DISABLED = 40
See also
CXTPColorManager::GetColor>

◆ XPCOLOR_EDITCTRLBORDER

const int XPCOLOR_EDITCTRLBORDER = 53
See also
CXTPColorManager::GetColor>

◆ XPCOLOR_FLOATBAR_BORDER

const int XPCOLOR_FLOATBAR_BORDER = 61
See also
CXTPColorManager::GetColor>

◆ XPCOLOR_FRAME

const int XPCOLOR_FRAME = 54
See also
CXTPColorManager::GetColor>

◆ XPCOLOR_GRAYTEXT

const int XPCOLOR_GRAYTEXT = XPCOLOR_MENUBAR_GRAYTEXT
See also
CXTPColorManager::GetColor>

◆ XPCOLOR_HIGHLIGHT

const int XPCOLOR_HIGHLIGHT = 31
See also
CXTPColorManager::GetColor>

◆ XPCOLOR_HIGHLIGHT_BORDER

const int XPCOLOR_HIGHLIGHT_BORDER = 32
See also
CXTPColorManager::GetColor>

◆ XPCOLOR_HIGHLIGHT_CHECKED

const int XPCOLOR_HIGHLIGHT_CHECKED = 36
See also
CXTPColorManager::GetColor>

◆ XPCOLOR_HIGHLIGHT_CHECKED_BORDER

const int XPCOLOR_HIGHLIGHT_CHECKED_BORDER = 37
See also
CXTPColorManager::GetColor>

◆ XPCOLOR_HIGHLIGHT_DISABLED_BORDER

const int XPCOLOR_HIGHLIGHT_DISABLED_BORDER = 58
See also
CXTPColorManager::GetColor>

◆ XPCOLOR_HIGHLIGHT_PUSHED

const int XPCOLOR_HIGHLIGHT_PUSHED = 33
See also
CXTPColorManager::GetColor>

◆ XPCOLOR_HIGHLIGHT_PUSHED_BORDER

const int XPCOLOR_HIGHLIGHT_PUSHED_BORDER = 50
See also
CXTPColorManager::GetColor>

◆ XPCOLOR_HIGHLIGHT_TEXT

const int XPCOLOR_HIGHLIGHT_TEXT = 45
See also
CXTPColorManager::GetColor>

◆ XPCOLOR_ICONSHADDOW

const int XPCOLOR_ICONSHADDOW = 34
See also
CXTPColorManager::GetColor>

◆ XPCOLOR_LABEL

const int XPCOLOR_LABEL = 56
See also
CXTPColorManager::GetColor>

◆ XPCOLOR_LAST

const int XPCOLOR_LAST = 62
See also
CXTPColorManager::GetColor>

◆ XPCOLOR_MENUBAR_BORDER

const int XPCOLOR_MENUBAR_BORDER = 43
See also
CXTPColorManager::GetColor>

◆ XPCOLOR_MENUBAR_EXPANDED

const int XPCOLOR_MENUBAR_EXPANDED = 42
See also
CXTPColorManager::GetColor>

◆ XPCOLOR_MENUBAR_FACE

const int XPCOLOR_MENUBAR_FACE = 41
See also
CXTPColorManager::GetColor>

◆ XPCOLOR_MENUBAR_GRAYTEXT

const int XPCOLOR_MENUBAR_GRAYTEXT = 35
See also
CXTPColorManager::GetColor>

◆ XPCOLOR_MENUBAR_TEXT

const int XPCOLOR_MENUBAR_TEXT = 44
See also
CXTPColorManager::GetColor>

◆ XPCOLOR_PUSHED_TEXT

const int XPCOLOR_PUSHED_TEXT = 47
See also
CXTPColorManager::GetColor>

◆ XPCOLOR_SEPARATOR

const int XPCOLOR_SEPARATOR = 39
See also
CXTPColorManager::GetColor>

◆ XPCOLOR_SHADOW_FACTOR

const int XPCOLOR_SHADOW_FACTOR = 59
See also
CXTPColorManager::GetColor>

◆ XPCOLOR_SPLITTER_FACE

const int XPCOLOR_SPLITTER_FACE = 55
See also
CXTPColorManager::GetColor>

◆ XPCOLOR_STATICFRAME

const int XPCOLOR_STATICFRAME = 57
See also
CXTPColorManager::GetColor>

◆ XPCOLOR_TAB_INACTIVE_BACK

const int XPCOLOR_TAB_INACTIVE_BACK = 48
See also
CXTPColorManager::GetColor>

◆ XPCOLOR_TAB_INACTIVE_TEXT

const int XPCOLOR_TAB_INACTIVE_TEXT = 49
See also
CXTPColorManager::GetColor>

◆ XPCOLOR_TOOLBAR_FACE

const int XPCOLOR_TOOLBAR_FACE = XPCOLOR_BASE
See also
CXTPColorManager::GetColor>

◆ XPCOLOR_TOOLBAR_GRAYTEXT

const int XPCOLOR_TOOLBAR_GRAYTEXT = 60
See also
CXTPColorManager::GetColor>

◆ XPCOLOR_TOOLBAR_GRIPPER

const int XPCOLOR_TOOLBAR_GRIPPER = 38
See also
CXTPColorManager::GetColor>

◆ XPCOLOR_TOOLBAR_TEXT

const int XPCOLOR_TOOLBAR_TEXT = 46
See also
CXTPColorManager::GetColor>


Toolkit Pro: XTPCustomHeap.h File Reference

  • Source
  • Common
Classes | Macros | Functions
XTPCustomHeap.h File Reference

Go to the source code of this file.

Classes

class | CXTPHeapAllocatorT< _TData >
This template class used as a base class for allocators which can use a custom (separate) heap. More...
class | CXTPHeapObjectT< _TObject, _TAllocator >
This template class used as a helper class to override new/delete operators and use custom heap allocators inside them. More...
class | CXTPHeapString
This class used to store strings. More...
class | CXTPHeapStringT< _TAllocator >
This template used to store strings using different allocators. More...
class | CXTPBatchAllocObjT< _TObject, _TBatchAllocData, _TAllocator >
This template class used as a helper class to override new/delete operators and use batch allocation inside them. More...

Macros

#define | XTP_DECLARE_HEAP_ALLOCATOR(allocatorClass)
This macros used to declare allocator class derived from CXTPHeapAllocatorT which can use default or custom (separate) heap.
#define | XTP_IMPLEMENT_HEAP_ALLOCATOR(allocatorClass, bUseCustomHeap)
This macros used to implement allocator class previously declared by XTP_DECLARE_HEAP_ALLOCATOR macro.
#define | XTP_DECLARE_BATCH_ALLOC_OBJ_DATA(dataClass)
This macros used to declare Batch allocation data which used with CXTPBatchAllocObjT template.
#define | XTP_IMPLEMENT_BATCH_ALLOC_OBJ_DATA(dataClass, objClass, batchAllocEnabled)
This macros used to declare Batch allocation data which used with CXTPBatchAllocObjT template.

Functions

_XTP_EXT_CLASS BOOL AFX_CDECL | XTPHeapSetCompatibilityInformation (HANDLE hHeapHandle, PVOID pHeapInformation, ULONG_PTR nHeapInformationLength)
This function enables features for a specified heap.
_XTP_EXT_CLASS BOOL AFX_CDECL | XTPHeapSetLowFragmentation (HANDLE hHeapHandle)
Call this member to enable "Low-fragmentation Heap" (LFH) feature for a given heap.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Macro Definition Documentation

◆ XTP_DECLARE_BATCH_ALLOC_OBJ_DATA

#define XTP_DECLARE_BATCH_ALLOC_OBJ_DATA ( dataClass )
Value:
XTP_DECLARE_BATCH_ALLOC_OBJ_DATA_(dataClass, XTP_EXPORT_PARAMS_NO)

This macros used to declare Batch allocation data which used with CXTPBatchAllocObjT template.

Parameters
dataClass [in] Name of the Batch allocation data class.

Used together with XTP_IMPLEMENT_BATCH_ALLOC_OBJ_DATA macro.

Example:

XTP_DECLARE_BATCH_ALLOC_OBJ_DATA(CBatchGridRecord_Data);
class CBatchGridRecord : public CXTPBatchAllocObjT<CXTPGridRecord, CBatchGridRecord_Data>
{
   // ...
};

// in implementation (*.cpp) file:
XTP_IMPLEMENT_BATCH_ALLOC_OBJ_DATA(CBatchGridRecord_Data, CBatchGridRecord, TRUE);
See also
XTP_IMPLEMENT_HEAP_ALLOCATOR, CXTPHeapAllocatorT, CXTPBatchAllocObjT

◆ XTP_DECLARE_HEAP_ALLOCATOR

#define XTP_DECLARE_HEAP_ALLOCATOR ( allocatorClass )
Value:
XTP_DECLARE_HEAP_ALLOCATOR_(allocatorClass, XTP_EXPORT_PARAMS_NO)

This macros used to declare allocator class derived from CXTPHeapAllocatorT which can use default or custom (separate) heap.

Such allocator can be used as parameter for CXTPHeapObjectT template or for other cases.

Parameters
allocatorClass [in] Name of the allocator class.

Used together with XTP_IMPLEMENT_HEAP_ALLOCATOR macro.

Example:

// probably in header (*.h) file:
XTP_DECLARE_HEAP_ALLOCATOR(CXTPGridRowAllocator)

// in implementation (*.cpp) file:
XTP_IMPLEMENT_HEAP_ALLOCATOR(CXTPGridRowAllocator)
See also
XTP_IMPLEMENT_HEAP_ALLOCATOR, CXTPHeapAllocatorT, CXTPHeapObjectT

◆ XTP_IMPLEMENT_BATCH_ALLOC_OBJ_DATA

#define XTP_IMPLEMENT_BATCH_ALLOC_OBJ_DATA | ( | dataClass,
 |  | objClass,
 |  | batchAllocEnabled )
Value:
BOOL dataClass::m_bBatchAllocationEnabled = batchAllocEnabled; \
LONG dataClass::m_dwAllocatedObjects = 0; \
int dataClass::m_nBlockSize = 1024; \
BOOL dataClass::m_bDestroyEmptyBlocksOnFree = FALSE; \
BOOL dataClass::m_bDestroyLastEmptyBlockOnFree = FALSE; \
XTP_BATCHALLOC_BLOCK_HEADER* dataClass::m_pFreeBlocks = NULL; \
XTP_BATCHALLOC_BLOCK_HEADER* dataClass::m_pBusyBlocks = NULL; \
objClass::TBlockMan gs_##objClass##_BlocksManager;

This macros used to declare Batch allocation data which used with CXTPBatchAllocObjT template.

Parameters
dataClass | [in] Name of the Batch allocation data class.
objClass | [in] Name of the object class for Batch allocation.
batchAllocEnabled | [in] Set as TRUE to enable Batch allocation by default for this object and FALSE to disable.

Used together with XTP_DECLARE_BATCH_ALLOC_OBJ_DATA macro.

Example:

XTP_DECLARE_BATCH_ALLOC_OBJ_DATA(CBatchGridRecord_Data);
class CBatchGridRecord : public CXTPBatchAllocObjT<CXTPGridRecord, CBatchGridRecord_Data>
{
   // ...
};

// in implementation (*.cpp) file:
XTP_IMPLEMENT_BATCH_ALLOC_OBJ_DATA(CBatchGridRecord_Data, CBatchGridRecord, TRUE);
See also
XTP_DECLARE_BATCH_ALLOC_OBJ_DATA, CXTPHeapAllocatorT, CXTPBatchAllocObjT

◆ XTP_IMPLEMENT_HEAP_ALLOCATOR

#define XTP_IMPLEMENT_HEAP_ALLOCATOR | ( | allocatorClass,
 |  | bUseCustomHeap )
Value:
HANDLE allocatorClass##Data::ms_hCustomHeap = NULL; \
LONG allocatorClass##Data::ms_dwRefs = 0; \
BOOL allocatorClass##Data::ms_bLFHEnabled = FALSE; \
BOOL allocatorClass##Data::ms_bUseCustomHeap = bUseCustomHeap; \
allocatorClass g_obj##allocatorClass;

This macros used to implement allocator class previously declared by XTP_DECLARE_HEAP_ALLOCATOR macro.

Such allocator can be used as parameter for CXTPHeapObjectT template or for other cases.

Parameters
allocatorClass | [in] Name of the allocator class.
bUseCustomHeap | [in] Set as TRUE to enable custom heap by default for this allocator and FALSE to disable.

Used together with XTP_DECLARE_HEAP_ALLOCATOR macro.

Example:

// probably in header (*.h) file:
XTP_DECLARE_HEAP_ALLOCATOR(CXTPGridRowAllocator)

// in implementation (*.cpp) file:
XTP_IMPLEMENT_HEAP_ALLOCATOR(CXTPGridRowAllocator)
See also
XTP_DECLARE_HEAP_ALLOCATOR, CXTPHeapAllocatorT, CXTPHeapObjectT

Function Documentation

◆ XTPHeapSetCompatibilityInformation()

_XTP_EXT_CLASS BOOL AFX_CDECL XTPHeapSetCompatibilityInformation | ( | HANDLE | hHeapHandle,
 |  | PVOID | pHeapInformation,
 |  | ULONG_PTR | nHeapInformationLength )

This function enables features for a specified heap.

Parameters
hHeapHandle | [in] Handle to the heap where information is to be set. This handle is returned by either the HeapCreate or GetProcessHeap function.
pHeapInformation | [in] Heap information buffer. The format of this data depends on the HeapCompatibilityInformation class.
nHeapInformationLength | [in] Size of the pHeapInformation buffer, in bytes.

This function is a wrapper to HeapSetInformation windows API function. If HeapSetInformation is not supported by windows, this function exits without any actions.

Returns
If the function succeeds, the return value is nonzero If the function fails, the return value is 0 (zero). To get extended error information, call GetLastError. If HeapSetInformation is not supported by windows return value is also TRUE.
See also
HeapSetInformation, XTPHeapSetLowFragmentation

◆ XTPHeapSetLowFragmentation()

_XTP_EXT_CLASS BOOL AFX_CDECL XTPHeapSetLowFragmentation ( HANDLE hHeapHandle )

Call this member to enable "Low-fragmentation Heap" (LFH) feature for a given heap.

Parameters
hHeapHandle [in] Handle to the heap where information is to be set. This handle is returned by either the HeapCreate or GetProcessHeap function.

This function is a wrapper to HeapSetInformation windows API function. If HeapSetInformation is not supported by windows, this function exits without any actions.

Returns
If the function succeeds, the return value is nonzero If the function fails, the return value is 0 (zero). To get extended error information, call GetLastError. If HeapSetInformation is not supported by windows return value is also TRUE.
See also
HeapSetInformation, XTPHeapSetCompatibilityInformation


Toolkit Pro: XTPDrawHelpers.h File Reference

  • Source
  • Common
Classes
XTPDrawHelpers.h File Reference

Go to the source code of this file.

Classes

class | CXTPTransparentBitmap
CXTPTransparentBitmap is a helper class used to extract the transparent color from a transparent BitMap. More...
class | CXTPClientCursorPos
CXTPClientCursorPos is a helper class used to retrieve the cursor position in client coordinates. More...
class | CXTPEmptyRect
CXTPEmptyRect is a helper class used to instantiate an empty CRect object. More...
class | CXTPEmptySize
CXTPEmptySize is a helper class used to instantiate an empty CSize object. More...
class | CXTPWindowRect
CXTPWindowRect is a helper class used to retrieve the screen size for a specified window. More...
class | CXTPClientRect
CXTPClientRect is a helper class used to retrieve the client area for a specified window. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPFontManager.h File Reference

  • Source
  • Common
Classes | Functions
XTPFontManager.h File Reference

Go to the source code of this file.

Classes

class CXTPFontManager
Singleton class to manage fonts used by library windows and controls. More...

Functions

_XTP_EXT_CLASS CXTPFontManager *AFX_CDECL XTPFontManager ()
Call this function to access CXTPFontManager members.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Function Documentation

◆ XTPFontManager()

_XTP_EXT_CLASS CXTPFontManager *AFX_CDECL XTPFontManager ( )

Call this function to access CXTPFontManager members.

Since this class is designed as a single instance object you can only access its members through this method. You cannot directly instantiate an object of type CXTPFontManager.

Example:

SetFont(&CXTPFontManager()->GetNormalFont());
Returns
A global font manager object pointer.


Toolkit Pro: XTPFramework.h File Reference

  • Source
  • Common
Classes | Macros
XTPFramework.h File Reference

Go to the source code of this file.

Classes

class CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issues and limitations of CCmdTarget. More...

Macros

#define | XTP_DECLARE_CMDTARGETPROVIDER_INTERFACE()
When deriving from CXTPCmdTarget is not possible this macro can be used in addition to standard DECLARE_INTERFACE_MAP for declaring IXTPCmdTargetProvider interface.
#define | XTP_DECLARE_CMDTARGETPROVIDER_INTERFACE_PART(className)
When deriving from CXTPCmdTarget is not possible this macro can be used in addition to standard DECLARE_INTERFACE_MAP for declaring IXTPCmdTargetProvider interface part.
#define | XTP_IMPLEMENT_CMDTARGETPROVIDER_INTERFACE(className)
When deriving from CXTPCmdTarget is not possible this macro can be used in addition to standard DECLARE_INTERFACE_MAP for implementing IXTPCmdTargetProvider interface.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Macro Definition Documentation

◆ XTP_DECLARE_CMDTARGETPROVIDER_INTERFACE_PART

#define XTP_DECLARE_CMDTARGETPROVIDER_INTERFACE_PART ( className )
Value:
INTERFACE_PART(className, IID_IXTPCmdTargetProvider, CmdTargetProvider)

When deriving from CXTPCmdTarget is not possible this macro can be used in addition to standard DECLARE_INTERFACE_MAP for declaring IXTPCmdTargetProvider interface part.

Parameters
className Class name that implements IXTPCmdTargetProvider interface.

◆ XTP_IMPLEMENT_CMDTARGETPROVIDER_INTERFACE

#define XTP_IMPLEMENT_CMDTARGETPROVIDER_INTERFACE ( className )
Value:
XTP_IMPLEMENT_IUNKNOWN(className, CmdTargetProvider) \
CCmdTarget* className::XCmdTargetProvider::GetCmdTarget() \
{ \
METHOD_PROLOGUE(className, CmdTargetProvider); \
return pThis; \
}
XTP_IMPLEMENT_IUNKNOWN
#define XTP_IMPLEMENT_IUNKNOWN(theClass, localClass)
Provides standard IUnknown implementation for a class derived from CCmdTarget.
Definition XTPMacros.h:853

When deriving from CXTPCmdTarget is not possible this macro can be used in addition to standard DECLARE_INTERFACE_MAP for implementing IXTPCmdTargetProvider interface.

Parameters
className Class name that implements IXTPCmdTargetProvider interface.


Toolkit Pro: XTPGdiObjects.h File Reference

  • Source
  • Common
Classes
XTPGdiObjects.h File Reference

Go to the source code of this file.

Classes

class | CXTPGdiObject
Implements common functionality for all XTP GDI object. More...
class | CXTPFont
Provides a convenient object oriented interface for HFONT GDI object and uses GDI handle caching. More...
class | CXTPBrush
Provides a convenient object oriented interface for HBRUSH GDI object and uses GDI handle caching. More...
class | CXTPPen
Provides a convenient object oriented interface for HPEN GDI object and uses GDI handle caching. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPHookManager.h File Reference

  • Source
  • Common
Classes | Enumerations | Functions
XTPHookManager.h File Reference

Go to the source code of this file.

Classes

class | CXTPHookManagerHookAble
HookAble interface. More...
class | CXTPHookManager
CXTPHookManager is standalone class. More...
class | CXTPShadowManager
CXTPShadowManager is standalone class used to manage CommandBars' shadows. More...

Enumerations

enum XTPShadowOptions { xtpShadowOfficeAlpha = 1 , xtpShadowShowPopupControl = 2 }
Shadow options of selected paint manager. More...

Functions

_XTP_EXT_CLASS CXTPHookManager *AFX_CDECL XTPHookManager ()
Call this function to access CXTPHookManager members.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Enumeration Type Documentation

◆ XTPShadowOptions

enum XTPShadowOptions

Shadow options of selected paint manager.

See also
CXTPPaintManager::GetShadowOptions()
Enumerator
xtpShadowOfficeAlpha | Office alpha shadow.
xtpShadowShowPopupControl | Draw shadow for popup controls.

Function Documentation

◆ XTPHookManager()

_XTP_EXT_CLASS CXTPHookManager *AFX_CDECL XTPHookManager ( )

Call this function to access CXTPHookManager members.

Since this class is designed as a single instance object you can only access version info through this method. You cannot directly instantiate an object of type CXTPHookManager.

Example:

XTPHookManager()->SetHook(hWnd, this);
Returns
A global hook manager object pointer.


Toolkit Pro: XTPImageList.h File Reference

  • Source
  • Common
Classes
XTPImageList.h File Reference

Go to the source code of this file.

Classes

class CXTPImageList
CXTPImageList extends CImageList with add additional functionality for images resizing that depends on DPI. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPImageManager.h File Reference

  • Source
  • Common
Classes | Enumerations | Functions
XTPImageManager.h File Reference

Go to the source code of this file.

Classes

class | CXTPImageManagerVectorImageHandle
Represents a generic interface for a vector image of any possible format to be used with CXTPImageManager. More...
struct | XTP_IMAGERESOURCE_INFO
This structure is used to define the position and style of the icon in resources. More...
class | CXTPImageManagerIconHandle
CXTPImageManagerIconHandle is a HICON wrapper class. More...
class | CXTPImageManagerIcon
Icons holder class. More...
class | CXTPImageManagerIconSet
CXTPImageManagerIconSet represents the collection of icons for a specified identifier. More...
class | CXTPImageManagerImageList
This class is used to connect ImageManager with specified HIMAGELIST. More...
class | CXTPImageManager
CXTPImageManager is a standalone class. More...
class | CXTPTempColorMask
The CXTPTempColorMask class can be used to temporarily set the color mask used by XTPImageManager when using images with different color masks. More...

Enumerations

enum XTPImageState {
xtpImageNormal , xtpImageDisabled , xtpImageHot , xtpImageChecked ,
xtpImagePressed
}
Image state enumerators. More...
enum XTPIconSizeMatching { xtpIconSizeExact , xtpIconSizeAtLeast , xtpIconSizeAtMost }
Icon size matching enumerators. More...

Functions

_XTP_EXT_CLASS CXTPImageManager *AFX_CDECL | XTPImageManager ()
XTPImageManager returns a pointer to the common CXTPImageManager class.
_XTP_EXT_CLASS BOOL AFX_CDECL | XTPScaleBitmap (CBitmap *src, CBitmap *dst)
Scales bitmap image to the current DPI level.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Enumeration Type Documentation

◆ XTPIconSizeMatching

enum XTPIconSizeMatching

Icon size matching enumerators.

Enumerator
xtpIconSizeExact | Requires an icon to have size the same as requested.
xtpIconSizeAtLeast | Requires an icon to have size the same or larger than requested.
xtpIconSizeAtMost | Requires an icon to have size no more than requested.

◆ XTPImageState

enum XTPImageState

Image state enumerators.

Example:

// Set Icons
pCommandBars->GetImageManager()->SetIcons(IDR_MAINFRAME, xtpImageNormal);
pCommandBars->GetImageManager()->SetIcons(IDR_MAINFRAME, IDR_MAINFRAME_HOT, xtpImageHot);
See also
CXTPImageManager::SetIcon, CXTPImageManager::SetIcons
Enumerator
xtpImageNormal | Normal image.
xtpImageDisabled | Disabled image.
xtpImageHot | Hot image.
xtpImageChecked | Checked (selected) image.
xtpImagePressed | Pressed image.

Function Documentation

◆ XTPImageManager()

_XTP_EXT_CLASS CXTPImageManager *AFX_CDECL XTPImageManager ( )

XTPImageManager returns a pointer to the common CXTPImageManager class.

Returns
A pointer to the common CXTPImageManager class.
See also
CXTPImageManager

◆ XTPScaleBitmap()

_XTP_EXT_CLASS BOOL AFX_CDECL XTPScaleBitmap | ( | CBitmap * | src,
 |  | CBitmap * | dst )

Scales bitmap image to the current DPI level.

Parameters
src | Source bitmap pointer.
dst | Destination bitmap pointer.
Returns
TRUE if the source bitmap was successfully scaled to the destination bitmap object.


Toolkit Pro: XTPImageManagerResource.h File Reference

  • Source
  • Common
Classes
XTPImageManagerResource.h File Reference

Go to the source code of this file.

Classes

class CXTPImageManagerResource

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMacros.h File Reference

  • Source
  • Common
Macros | Functions
XTPMacros.h File Reference

Go to the source code of this file.

Macros

#define | XTP_WIDE(str)
Makes a wide string.
#define | SAFE_DELETE(ptr)
Frees dynamically allocated memory.
#define | SAFE_DELETE_AR(ptr)
Frees dynamically allocated memory for an array.
#define | SAFE_RELEASE(comPointer)
Decrements the reference count for the specified object.
#define | SAFE_CALLPTR(classPointer, functionName)
Checks object pointer and if not NULL calls a specified function.
#define | SAFE_DELETE_HICON(hIcon)
Destroys an icon and frees any memory the icon occupied.
#define | SAFE_DELETE_OBJ(obj)
Destroys a GDI object and frees the handle.
#define | XT_ASSERT_MSG(exp, msg)
XT_ASSERT_MSG is similar to _ASSERTE, except that it allows a custom message to be specified.
#define | XTP_ASSERT_CHECK(expr)
XTP_ASSERT_CHECK acts the same way as _ASSERTE but it also returns a boolean result from the evaluated expression which can be immediately used in the code.
#define | XTP_ASSERT_CHECK_NOT_NULL(expr)
XTP_ASSERT_CHECK_NOT_NULL acts the same way as _ASSERTE but it also returns the value an object passed as an argument to the evaluated expression, which can be immediately used in the code.
#define | XTP_IMPLEMENT_IUNKNOWN(theClass, localClass)
Provides standard IUnknown implementation for a class derived from CCmdTarget.
#define | XTP_DECLARE_IDISPATCH()
Provides standard IDispatch implementation for a class derived from CCmdTarget.
#define | XTP_IMPLEMENT_IDISPATCH(theClass, localClass)
Provides standard IDispatch implementation for a class derived from CCmdTarget.
#define | XTP_UNUSED(name)
The macro should be used instead of UNUSED and UNREFERENCED_PARAMETER in order to address cross version compatibility issues in Visual Studio.
#define | XTP_UNUSED_PARAMETER(name)
The macro should be used instead of UNUSED and UNREFERENCED_PARAMETER in order to address cross version compatibility issues in Visual Studio.

Functions

AFX_INLINE void AFX_CDECL XTPDebugBreak ()
Triggers debugger exception.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Macro Definition Documentation

◆ SAFE_CALLPTR

#define SAFE_CALLPTR | ( | classPointer,
 |  | functionName )

Checks object pointer and if not NULL calls a specified function.

Parameters
classPointer | Pointer to the class that contains the function to call.
functionName | Name of the function to call.

This macro will first check to see if the class specified by classPointer is NULL. If the class is not NULL, the macro calls the function specified by functionName.

Example:

SAFE_CALLPTR(m_pItem, OnConstraintsChanged());

◆ SAFE_DELETE

#define SAFE_DELETE ( ptr )

Frees dynamically allocated memory.

Parameters
ptr Points to the memory to free.

This macro will first check to see if the block of memory specified by ptr is NULL. If ptr is not NULL, SAFE_DELETE will deallocate the block of memory and set its value to NULL. The pointer argument must refer to a block of memory previously allocated for an object created with the new operator.

Example:

CName* pName = new CName;          // Allocate memory for the object
pName->SetName("Firstname", "Lastname");
SAFE_DELETE(pName);                // Deallocate memory for the object
_ASSERTE(pName == NULL);

◆ SAFE_DELETE_AR

#define SAFE_DELETE_AR ( ptr )

Frees dynamically allocated memory for an array.

Parameters
ptr Points to the memory array to free.

This macro will first check to see if the block of memory specified by ptr is NULL. If ptr is not NULL, SAFE_DELETE_AR will deallocate the block of memory and set its value to NULL. The pointer argument must refer to a block of memory previously allocated for an object created with the new operator.

Example:

char* pCharArray = new char[256];  // Allocate memory for the array
strcpy(pCharArray, "Array of characters");
SAFE_DELETE_AR(pCharArray);        // Deallocate memory for the array
_ASSERTE(pCharArray == NULL);

◆ SAFE_DELETE_HICON

#define SAFE_DELETE_HICON ( hIcon )

Destroys an icon and frees any memory the icon occupied.

Parameters
hIcon Handle to the icon to free.

This macro will first check to see if the icon handle specified by hIcon is NULL. If hIcon is not NULL, SAFE_DELETE_HICON will destroy the icon handle and set its value to NULL.

Example:

HICON hIcon = XTPResourceManager()->LoadIcon(
MAKEINTRESOURCE(dwID), item.size);
DrawIconEx(pDC->GetSafeHdc(), point.x, point.y, hIcon,
size.cx, size.cy, 0, NULL, DI_NORMAL);
SAFE_DELETE_HICON(hIcon);
_ASSERTE(hIcon == NULL);

◆ SAFE_DELETE_OBJ

#define SAFE_DELETE_OBJ ( obj )

Destroys a GDI object and frees the handle.

Parameters
obj Handle to the GDI object free.

This macro will first check to see if the GDI object specified by obj is NULL. If obj is not NULL, SAFE_DELETE_OBJ will delete the GDI object and set its value to NULL.

Example:

extern CFont m_font;
extern LOGFONT lf;
SAFE_DELETE_OBJ(m_font);
m_font.CreateFontIndirect(&lf);

◆ SAFE_RELEASE

#define SAFE_RELEASE ( comPointer )

Decrements the reference count for the specified object.

Parameters
comPointer Points to the COM object to release.

This macro will first check to see if the COM object specified by comPointer is NULL. If the object is not NULL, the macro calls IUnknown::Release COM object specified by comPointer and set its value to NULL.

See also
IUnknown::Release

◆ XT_ASSERT_MSG

#define XT_ASSERT_MSG | ( | exp,
 |  | msg )

XT_ASSERT_MSG is similar to _ASSERTE, except that it allows a custom message to be specified.

Parameters
exp | Specifies an expression (including pointer values) that evaluates to nonzero or 0.
msg | Specifies a NULL-terminated user-defined string of the message to display to the user.

Evaluates its argument. If the result is 0, the macro prints a diagnostic message and aborts the program. If the condition is nonzero, it does nothing.

The diagnostic message has the form "assertion failed in file name in line num.

where name is the name of the source file, and num is the line number of the assertion that failed in the source file.

In the Release version of MFC, XT_ASSERT_MSG does not evaluate the expression and thus will not interrupt the program. If the expression must be evaluated regardless of environment, use the VERIFY macro in place of XT_ASSERT_MSG.

Note This function is available only in the Debug version of MFC.

Example:

CAge* pAge = new CAge(21);
XT_ASSERT_MSG(pAge, _T(“Failed to allocate memory.”);
See also
_ASSERTE, VERIFY

◆ XTP_ASSERT_CHECK

#define XTP_ASSERT_CHECK ( expr )
Value:
(expr)

XTP_ASSERT_CHECK acts the same way as _ASSERTE but it also returns a boolean result from the evaluated expression which can be immediately used in the code.

Unlike _ASSERTE the expression is evaluate in non-Debug configurations and its result gets cast to boolean and returned.

Parameters
expr Any expression that will be evaluated exactly on time and its result cast to boolean and asserted as true.

◆ XTP_ASSERT_CHECK_NOT_NULL

#define XTP_ASSERT_CHECK_NOT_NULL ( expr )
Value:
(expr)

XTP_ASSERT_CHECK_NOT_NULL acts the same way as _ASSERTE but it also returns the value an object passed as an argument to the evaluated expression, which can be immediately used in the code.

Unlike _ASSERTE the expression is evaluate in non-Debug configurations and its result is returned.

Parameters
expr Any expression that will be evaluated and tested for NULL equality.

◆ XTP_IMPLEMENT_IDISPATCH

#define XTP_IMPLEMENT_IDISPATCH | ( | theClass,
 |  | localClass )
Value:
XTP_STDMETHODIMP theClass::X##localClass::GetTypeInfoCount(UINT* pctinfo) \
{ \
METHOD_PROLOGUE(theClass, localClass); \
return pThis->GetIDispatch(FALSE)->GetTypeInfoCount(pctinfo); \
} \
XTP_STDMETHODIMP theClass::X##localClass::GetTypeInfo(UINT iTInfo, LCID lcid, \
ITypeInfo** ppTInfo) \
{ \
METHOD_PROLOGUE(theClass, localClass); \
return pThis->GetIDispatch(FALSE)->GetTypeInfo(iTInfo, lcid, ppTInfo); \
} \
XTP_STDMETHODIMP theClass::X##localClass::GetIDsOfNames(REFIID riid, LPOLESTR* rgszNames, \
UINT cNames, LCID lcid, \
DISPID* rgDispId) \
{ \
METHOD_PROLOGUE(theClass, localClass); \
return pThis->GetIDispatch(FALSE)->GetIDsOfNames(riid, rgszNames, cNames, lcid, \
rgDispId); \
} \
XTP_STDMETHODIMP theClass::X##localClass::Invoke(DISPID dispIdMember, REFIID riid, \
LCID lcid, WORD wFlags, \
DISPPARAMS* pDispParams, \
VARIANT* pVarResult, \
EXCEPINFO* pExcepInfo, UINT* puArgErr) \
{ \
METHOD_PROLOGUE(theClass, localClass); \
return pThis->GetIDispatch(FALSE)->Invoke(dispIdMember, riid, lcid, wFlags, \
pDispParams, pVarResult, pExcepInfo, \
puArgErr); \
}

Provides standard IDispatch implementation for a class derived from CCmdTarget.

Parameters
theClass | The name of the class derived from CCmdTarget.
localClass | The name of the interface specific class.

◆ XTP_IMPLEMENT_IUNKNOWN

#define XTP_IMPLEMENT_IUNKNOWN | ( | theClass,
 |  | localClass )
Value:
XTP_STDMETHODIMP_(ULONG) theClass::X##localClass::AddRef() \
{ \
METHOD_PROLOGUE(theClass, localClass) \
return pThis->ExternalAddRef(); \
} \
XTP_STDMETHODIMP_(ULONG) theClass::X##localClass::Release() \
{ \
METHOD_PROLOGUE(theClass, localClass) \
return pThis->ExternalRelease(); \
} \
XTP_STDMETHODIMP theClass::X##localClass::QueryInterface(REFIID riid, LPVOID* ppvObj) \
{ \
METHOD_PROLOGUE(theClass, localClass) \
HRESULT hr = (HRESULT)pThis->ExternalQueryInterface(&riid, ppvObj); \
return hr; \
}

Provides standard IUnknown implementation for a class derived from CCmdTarget.

Parameters
theClass | The name of the class derived from CCmdTarget.
localClass | The name of the interface specific class.

◆ XTP_WIDE

#define XTP_WIDE ( str )
Value:
XTP_WIDE_(str)

Makes a wide string.

Parameters
str String literal to made a wide string from.

Function Documentation

◆ XTPDebugBreak()

AFX_INLINE void AFX_CDECL XTPDebugBreak ( )

Triggers debugger exception.

Returns


Toolkit Pro: XTPMarkupRender.h File Reference

  • Source
  • Common
Functions | Variables
XTPMarkupRender.h File Reference

Go to the source code of this file.

Functions

_XTP_EXT_CLASS CXTPMarkupContext *AFX_CDECL | XTPMarkupCreateContext (HWND hWnd=NULL, BOOL bDpiAware=FALSE)
XTPMarkupCreateContext is part of Markup API that creates new CXTPMarkupContext object.
_XTP_EXT_CLASS CXTPMarkupContext *AFX_CDECL | XTPMarkupCreateContext (HWND hWnd, RECT rcUpdate, BOOL bDpiAware)
XTPMarkupCreateContext is part of Markup API that creates new CXTPMarkupContext object.
_XTP_EXT_CLASS void AFX_CDECL | XTPMarkupAssignHandle (CXTPMarkupContext *pContext, HWND hWnd)
Assigns handle to using the items specified by pContext and hWnd.
_XTP_EXT_CLASS void AFX_CDECL | XTPMarkupAssignHandle (CXTPMarkupContext *pContext, HWND hWnd, CRect rcUpdate)
Assigns handle to using the items specified by pContext and hWnd.
_XTP_EXT_CLASS void AFX_CDECL | XTPMarkupReleaseContext (CXTPMarkupContext *&pContext)
XTPMarkupReleaseContext is part of Markup API that destroys CXTPMarkupContext object.
_XTP_EXT_CLASS void AFX_CDECL | XTPMarkupReleaseContext (CXTPMarkupContext *&pContext, BOOL bShutdown)
XTPMarkupReleaseContext is part of Markup API that destroys CXTPMarkupContext object.
_XTP_EXT_CLASS CXTPMarkupUIElement *AFX_CDECL | XTPMarkupParseText (CXTPMarkupContext *pContext, LPCSTR lpszMarkup)
XTPMarkupParseText is part of Markup API that creates new Markup elements using Markup string.
_XTP_EXT_CLASS CXTPMarkupUIElement *AFX_CDECL | XTPMarkupParseText (CXTPMarkupContext *pContext, LPCWSTR lpszMarkup)
XTPMarkupParseText is part of Markup API that creates new Markup elements using Markup string.
_XTP_EXT_CLASS CXTPMarkupUIElement *AFX_CDECL | XTPMarkupParseText (CXTPMarkupContext *pContext, LPCSTR lpszMarkup, INT_PTR nLength)
XTPMarkupParseText is part of Markup API that creates new Markup elements using Markup string.
_XTP_EXT_CLASS CXTPMarkupUIElement *AFX_CDECL | XTPMarkupParseText (CXTPMarkupContext *pContext, LPCWSTR lpszMarkup, INT_PTR nLength)
XTPMarkupParseText is part of Markup API that creates new Markup elements using Markup string.
_XTP_EXT_CLASS CXTPMarkupUIElement *AFX_CDECL | XTPMarkupParseText (CXTPMarkupContext *pContext, IStream *pStream)
XTPMarkupParseText is part of Markup API that creates new Markup elements using Markup string.
_XTP_EXT_CLASS void AFX_CDECL | XTPMarkupReleaseElement (CXTPMarkupUIElement *&pElement)
XTPMarkupReleaseElement is part of Markup API that destroys CXTPMarkupUIElement object.
_XTP_EXT_CLASS CSize AFX_CDECL | XTPMarkupMeasureElement (CXTPMarkupUIElement *pElement, int cxAvail=INT_MAX, int cyAvail=INT_MAX)
XTPMarkupMeasureElement is part of Markup API that calculates dimensions of Markup element.
_XTP_EXT_CLASS void AFX_CDECL | XTPMarkupRenderElement (CXTPMarkupUIElement *pElement, HDC hDC, LPCRECT rc)
XTPMarkupRenderElement is part of Markup API that draws Markup element to device context.
_XTP_EXT_CLASS void AFX_CDECL | XTPMarkupSetDefaultFont (CXTPMarkupContext *pContext, HFONT hFont, COLORREF clrText)
XTPMarkupSetDefaultFont is part of Markup API.
_XTP_EXT_CLASS BOOL AFX_CDECL | XTPMarkupRelayMessage (CXTPMarkupUIElement *pElement, UINT message, WPARAM wParam, LPARAM lParam, LRESULT *pResult)
XTPMarkupRelayMessage is part of Markup API.
_XTP_EXT_CLASS BOOL AFX_CDECL | XTPMarkupRelayMessage (CXTPMarkupContext *pContext, UINT message, WPARAM wParam, LPARAM lParam, LRESULT *pResult)
XTPMarkupRelayMessage is part of Markup API.
_XTP_EXT_CLASS CXTPMarkupContext *AFX_CDECL | XTPMarkupElementContext (CXTPMarkupUIElement *pElement)
XTPMarkupElementContext is part of Markup API that returns Markup contrext of Markup element.

Variables

const UINT XTP_WM_MARKUPREDRAW = (WM_USER + 9820)
Notifies Markup context window about Markup redraw event.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Function Documentation

◆ XTPMarkupAssignHandle() [1/2]

_XTP_EXT_CLASS void AFX_CDECL XTPMarkupAssignHandle | ( | CXTPMarkupContext * | pContext,
 |  | HWND | hWnd )

Assigns handle to using the items specified by pContext and hWnd.

Parameters
pContext | Points to a CXTPMarkupContext object.
hWnd | Window handle to link context with.
Returns

◆ XTPMarkupAssignHandle() [2/2]

_XTP_EXT_CLASS void AFX_CDECL XTPMarkupAssignHandle | ( | CXTPMarkupContext * | pContext,
 |  | HWND | hWnd,
 |  | CRect | rcUpdate )

Assigns handle to using the items specified by pContext and hWnd.

Parameters
pContext | Points to a CXTPMarkupContext object.
hWnd | Window handle to link context with.
rcUpdate | Target update rectangle
Returns

◆ XTPMarkupCreateContext() [1/2]

_XTP_EXT_CLASS CXTPMarkupContext *AFX_CDECL XTPMarkupCreateContext | ( | HWND | hWnd,
 |  | RECT | rcUpdate,
 |  | BOOL | bDpiAware )

XTPMarkupCreateContext is part of Markup API that creates new CXTPMarkupContext object.

Parameters
hWnd | Window handle to link context with
rcUpdate | Target update rectangle
bDpiAware | TRUE to enable DPI awarness.

XTPMarkupCreateContext creates new CXTPMarkupContext that holds common properties of Markup Elements like default font, default text color, current selected element, etc.

Example:

CXTPMarkupContext* pContext = XTPMarkupCreateContext(NULL, TRUE);
pContext->SetDpiAware();
CXTPMarkupUIElement* pElement = XTPMarkupParseText(pContext, "<Ellipse Fill='Red' Width='100'
Height='100'/>"); CSize sz = XTPMarkupMeasureElement(pElement);
XTPMarkupRenderElement(pElement, pDC->GetSafeHdc(), CRect(CPoint(0), sz));
XTPMarkupReleaseElement(pElement);
XTPMarkupReleaseContext(pContext, TRUE);
Returns
Returns new CXTPMarkupContext object pointer
See also
XTPMarkupReleaseContext, XTPMarkupParseText, XTPMarkupReleaseElement, XTP_WM_MARKUPREDRAW

◆ XTPMarkupCreateContext() [2/2]

_XTP_EXT_CLASS CXTPMarkupContext *AFX_CDECL XTPMarkupCreateContext | ( | HWND | hWnd = NULL,
 |  | BOOL | bDpiAware = FALSE )

XTPMarkupCreateContext is part of Markup API that creates new CXTPMarkupContext object.

Parameters
hWnd | Window handle to link context with
bDpiAware | TRUE to enable DPI awarness.

XTPMarkupCreateContext creates new CXTPMarkupContext that holds common properties of Markup Elements like default font, default text color, current selected element, etc.

Example:

CXTPMarkupContext* pContext = XTPMarkupCreateContext(NULL, TRUE);
pContext->SetDpiAware();
CXTPMarkupUIElement* pElement = XTPMarkupParseText(pContext, "<Ellipse Fill='Red' Width='100'
Height='100'/>"); CSize sz = XTPMarkupMeasureElement(pElement);
XTPMarkupRenderElement(pElement, pDC->GetSafeHdc(), CRect(CPoint(0), sz));
XTPMarkupReleaseElement(pElement);
XTPMarkupReleaseContext(pContext, TRUE);
Returns
Returns new CXTPMarkupContext object pointer
See also
XTPMarkupReleaseContext, XTPMarkupParseText, XTPMarkupReleaseElement, XTP_WM_MARKUPREDRAW

◆ XTPMarkupElementContext()

_XTP_EXT_CLASS CXTPMarkupContext *AFX_CDECL XTPMarkupElementContext ( CXTPMarkupUIElement * pElement )

XTPMarkupElementContext is part of Markup API that returns Markup contrext of Markup element.

Parameters
pElement Pointer to Markup element that context need to know
Returns
Pointer of associated CXTPMarkupContext
See also
XTPMarkupCreateContext

◆ XTPMarkupMeasureElement()

_XTP_EXT_CLASS CSize AFX_CDECL XTPMarkupMeasureElement | ( | CXTPMarkupUIElement * | pElement,
 |  | int | cxAvail = INT_MAX,
 |  | int | cyAvail = INT_MAX )

XTPMarkupMeasureElement is part of Markup API that calculates dimensions of Markup element.

Parameters
pElement | Pointer to CXTPMarkupUIElement that size need to calculate
cxAvail | Available width
cyAvail | Available height

Example: See Example for XTPMarkupCreateContext function

Returns
Returns the dimensions of the CXTPMarkupUIElement
See also
XTPMarkupCreateContext, XTPMarkupParseText, XTPMarkupRenderElement

◆ XTPMarkupParseText() [1/5]

_XTP_EXT_CLASS CXTPMarkupUIElement *AFX_CDECL XTPMarkupParseText | ( | CXTPMarkupContext * | pContext,
 |  | IStream * | pStream )

XTPMarkupParseText is part of Markup API that creates new Markup elements using Markup string.

Parameters
pContext | Pointer to CXTPMarkupContext. All new elements will be part of this context.
pStream | Points to an IStream object.

Example: See Example for XTPMarkupCreateContext function

Returns
A root markup UI element pointer or NULL if there is an error.
See also
XTPMarkupCreateContext, XTPMarkupReleaseElement, XTPMarkupMeasureElement, XTPMarkupRenderElement

◆ XTPMarkupParseText() [2/5]

_XTP_EXT_CLASS CXTPMarkupUIElement *AFX_CDECL XTPMarkupParseText | ( | CXTPMarkupContext * | pContext,
 |  | LPCSTR | lpszMarkup )

XTPMarkupParseText is part of Markup API that creates new Markup elements using Markup string.

Parameters
pContext | Pointer to CXTPMarkupContext. All new elements will be part of this context.
lpszMarkup | String to parse

Example: See Example for XTPMarkupCreateContext function

Returns
A root markup UI element pointer or NULL if there is an error.
See also
XTPMarkupCreateContext, XTPMarkupReleaseElement, XTPMarkupMeasureElement, XTPMarkupRenderElement

◆ XTPMarkupParseText() [3/5]

_XTP_EXT_CLASS CXTPMarkupUIElement *AFX_CDECL XTPMarkupParseText | ( | CXTPMarkupContext * | pContext,
 |  | LPCSTR | lpszMarkup,
 |  | INT_PTR | nLength )

XTPMarkupParseText is part of Markup API that creates new Markup elements using Markup string.

Parameters
pContext | Pointer to CXTPMarkupContext. All new elements will be part of this context.
lpszMarkup | String to parse
nLength | Length of string to parse.

Example: See Example for XTPMarkupCreateContext function

Returns
A root markup UI element pointer or NULL if there is an error.
See also
XTPMarkupCreateContext, XTPMarkupReleaseElement, XTPMarkupMeasureElement, XTPMarkupRenderElement

◆ XTPMarkupParseText() [4/5]

_XTP_EXT_CLASS CXTPMarkupUIElement *AFX_CDECL XTPMarkupParseText | ( | CXTPMarkupContext * | pContext,
 |  | LPCWSTR | lpszMarkup )

XTPMarkupParseText is part of Markup API that creates new Markup elements using Markup string.

Parameters
pContext | Pointer to CXTPMarkupContext. All new elements will be part of this context.
lpszMarkup | String to parse

Example: See Example for XTPMarkupCreateContext function

Returns
A root markup UI element pointer or NULL if there is an error.
See also
XTPMarkupCreateContext, XTPMarkupReleaseElement, XTPMarkupMeasureElement, XTPMarkupRenderElement

◆ XTPMarkupParseText() [5/5]

_XTP_EXT_CLASS CXTPMarkupUIElement *AFX_CDECL XTPMarkupParseText | ( | CXTPMarkupContext * | pContext,
 |  | LPCWSTR | lpszMarkup,
 |  | INT_PTR | nLength )

XTPMarkupParseText is part of Markup API that creates new Markup elements using Markup string.

Parameters
pContext | Pointer to CXTPMarkupContext. All new elements will be part of this context.
lpszMarkup | String to parse
nLength | Length of string to parse.

Example: See Example for XTPMarkupCreateContext function

Returns
A root markup UI element pointer or NULL if there is an error.
See also
XTPMarkupCreateContext, XTPMarkupReleaseElement, XTPMarkupMeasureElement, XTPMarkupRenderElement

◆ XTPMarkupRelayMessage() [1/2]

_XTP_EXT_CLASS BOOL AFX_CDECL XTPMarkupRelayMessage | ( | CXTPMarkupContext * | pContext,
 |  | UINT | message,
 |  | WPARAM | wParam,
 |  | LPARAM | lParam,
 |  | LRESULT * | pResult )

XTPMarkupRelayMessage is part of Markup API.

It used to notify Markup element about events of associated window.

Parameters
pContext | Pointer to CXTPMarkupContext object.
message | Specifies the message to be sent.
wParam | Specifies additional message-dependent information
lParam | Specifies additional message-dependent information
pResult | The return value of WindowProc. Depends on the message
Returns
Nonzero if message was handled; otherwise 0.
See also
XTPMarkupCreateContext

◆ XTPMarkupRelayMessage() [2/2]

_XTP_EXT_CLASS BOOL AFX_CDECL XTPMarkupRelayMessage | ( | CXTPMarkupUIElement * | pElement,
 |  | UINT | message,
 |  | WPARAM | wParam,
 |  | LPARAM | lParam,
 |  | LRESULT * | pResult )

XTPMarkupRelayMessage is part of Markup API.

It used to notify Markup element about events of associated window.

Parameters
pElement | Pointer to Markup element that need to notify
message | Specifies the message to be sent.
wParam | Specifies additional message-dependent information
lParam | Specifies additional message-dependent information
pResult | The return value of WindowProc. Depends on the message
Returns
Nonzero if message was handled; otherwise 0.
See also
XTPMarkupCreateContext

◆ XTPMarkupReleaseContext() [1/2]

_XTP_EXT_CLASS void AFX_CDECL XTPMarkupReleaseContext ( CXTPMarkupContext *& pContext )

XTPMarkupReleaseContext is part of Markup API that destroys CXTPMarkupContext object.

Parameters
pContext Pointer to CXTPMarkupContext that will be released

Example: See Example for XTPMarkupCreateContext function

XTPMarkupReleaseContext without bShutdown argument does not perform context shutdown and simply decrements context reference counter.

Returns
See also
XTPMarkupCreateContext

◆ XTPMarkupReleaseContext() [2/2]

_XTP_EXT_CLASS void AFX_CDECL XTPMarkupReleaseContext | ( | CXTPMarkupContext *& | pContext,
 |  | BOOL | bShutdown )

XTPMarkupReleaseContext is part of Markup API that destroys CXTPMarkupContext object.

Parameters
pContext | Pointer to CXTPMarkupContext that will be released
bShutdown | If TRUE then the context will be shutdown, i.e. all data and states will be reset. Otherwise it simply decrements context reference counter.

Example: See Example for XTPMarkupCreateContext function

XTPMarkupReleaseContext without bShutdown argument does not perform context shutdown and simply decrements context reference counter.

Returns
See also
XTPMarkupCreateContext

◆ XTPMarkupReleaseElement()

_XTP_EXT_CLASS void AFX_CDECL XTPMarkupReleaseElement ( CXTPMarkupUIElement *& pElement )

XTPMarkupReleaseElement is part of Markup API that destroys CXTPMarkupUIElement object.

Parameters
pElement Pointer to CXTPMarkupUIElement that will be released

Example: See Example for XTPMarkupCreateContext function

Returns
See also
XTPMarkupCreateContext, XTPMarkupParseText, XTPMarkupMeasureElement, XTPMarkupRenderElement

◆ XTPMarkupRenderElement()

_XTP_EXT_CLASS void AFX_CDECL XTPMarkupRenderElement | ( | CXTPMarkupUIElement * | pElement,
 |  | HDC | hDC,
 |  | LPCRECT | rc )

XTPMarkupRenderElement is part of Markup API that draws Markup element to device context.

Parameters
pElement | CXTPMarkupUIElement object to draw
hDC | Handle to the device context
rc | Pointer to a RECT structure that contains the rectangle in which the element is to be formatted

Example: See Example for XTPMarkupCreateContext function

Returns
See also
XTPMarkupCreateContext, XTPMarkupParseText, XTPMarkupMeasureElement

◆ XTPMarkupSetDefaultFont()

_XTP_EXT_CLASS void AFX_CDECL XTPMarkupSetDefaultFont | ( | CXTPMarkupContext * | pContext,
 |  | HFONT | hFont,
 |  | COLORREF | clrText )

XTPMarkupSetDefaultFont is part of Markup API.

Call it to set default font and text color for Markup elements

Parameters
pContext | Pointer to a CXTPMarkupContext object.
hFont | Handle to default font.
clrText | Default text color.

Example:

CXTPMarkupContext* pContext = XTPMarkupCreateContext(NULL, TRUE);
pContext->SetDpiAware();
CXTPMarkupUIElement* pElement = XTPMarkupParseText(pContext,
“<TextBlock Text='Hello, world'/>”);
XTPMarkupSetDefaultFont(pContext, 0, RGB(255, 0, 0));

CSize sz = XTPMarkupMeasureElement(pElement);
XTPMarkupRenderElement(pElement, pDC->GetSafeHdc(), CRect(CPoint(0), sz));
XTPMarkupReleaseElement(pElement);
XTPMarkupReleaseContext(pContext, TRUE);
Returns
See also
XTPMarkupCreateContext, XTPMarkupParseText, XTPMarkupMeasureElement

Variable Documentation

◆ XTP_WM_MARKUPREDRAW

const UINT XTP_WM_MARKUPREDRAW = (WM_USER + 9820)

Notifies Markup context window about Markup redraw event.

Parameters
wParam | Not used.
lParam | Points to the update rectangle of type RECT or NULL if the entire window must be updated.
Returns
TRUE if application handles the request and no default processing is required. Returning FALSE will invalidate and update the affected rectangle by default.
See also
XTPMarkupCreateContext


Toolkit Pro: XTPMarkupTheme.h File Reference

  • Source
  • Common
Classes
XTPMarkupTheme.h File Reference

Go to the source code of this file.

Classes

class CXTPMarkupThemePart
The CXTPMarkupThemePart class is used to create a theme part object used for rendering. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMaskEditT.h File Reference

  • Source
  • Common
Classes
XTPMaskEditT.h File Reference

Go to the source code of this file.

Classes

class CXTPMaskEditT< TBase >
CXTPMaskEditT is a template class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPNotifyConnection.h File Reference

  • Source
  • Common
Classes | Macros | Enumerations | Variables
XTPNotifyConnection.h File Reference

Go to the source code of this file.

Classes

class | CXTPNotifyConnection
This class is used as implementation of Connection interface in a XTPNotification mechanism. More...
struct | CXTPNotifyConnection::CONNECTION_DESCRIPTOR
This struct is used in the implementation of the class CXTPNotifyConnection to store connection between a Connection object, Notification code and the sink object. More...
class | CXTPNotifyConnection::CEmptySyncObject
This struct is derived from CSyncObject and should be used instead of CCriticalSection to improve performance and to provide compatibility. More...
class | CXTPNotifyConnectionMT
This class is used as thread-safety implementation of Connection interface in a XTPNotification mechanism. More...
class | CXTPNotifySinkBase
This class is used as implementation of Sink interface in a XTPNotification mechanism. More...
struct | CXTPNotifySinkBase::ADVISE_DESCRIPTOR
This struct is used in to store connection between a Connection object(s), Notification code and the sink object. More...

Macros

#define DECLARE_XTP_SINK(ownerClassName, MemberName)
This macro is used as implementation of Sink object in the events receiver class.

Enumerations

enum XTPNotifyFlags { xtpNotifyPostMessage = 0x80000000 , xtpNotifyGuarantyPost = 0x40000000 , xtpNotifyDirectCallForOneThread = 0x20000000 }
RANGE for WM_XTP_COMMON_BASE {+ 1 ... + 49}. More...

Variables

const UINT WM_XTP_COMMON_BASE = (WM_USER + 9550)
Defines a base ID for common notifications.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Macro Definition Documentation

◆ DECLARE_XTP_SINK

#define DECLARE_XTP_SINK | ( | ownerClassName,
 |  | MemberName )
Value:
DECLARE_XTP_SINKEX(ownerClassName, MemberName, CXTPNotifySinkBaseImpl) \
friend class CXTPNotifySinkBaseImpl<ownerClassName, C_##MemberName##_Informator>;

This macro is used as implementation of Sink object in the events receiver class.

Parameters
ownerClassName | Name of the class where DECLARE_XTPSINK macro is placed.
MemberName | Name of the sink class member.

Example: class CMyObjectEventsReceiver : public CXTPCmdTarget { protected: // Declare sink object DECLARE_XTPSINK(CMyObjectEventsReceiver, m_Sink)

// Declare Event handlers methods void NotificationHandler1(XTP_NOTIFY_CODE Event, WPARAM wParam , LPARAM lParam); void NotificationHandler2(XTP_NOTIFY_CODE Event, WPARAM wParam , LPARAM lParam); // ... };

See also
CXTPNotifySinkBase overview, CXTPNotifyConnection overview,

Enumeration Type Documentation

◆ XTPNotifyFlags

enum XTPNotifyFlags

RANGE for WM_XTP_COMMON_BASE {+ 1 ... + 49}.

Next free COMMON ID = (WM_XTP_COMMON_BASE + 2)

Notify flags options

Enumerator
xtpNotifyPostMessage | Event will be posted.
xtpNotifyGuarantyPost | Used together with nofPostMessage. Event will be guaranty posted. (Wait untill PostMessage returns TRUE)
xtpNotifyDirectCallForOneThread | Event handler will be called directly if sender and receiver are in one thread.


Toolkit Pro: XTPNumberFormat.h File Reference

  • Source
  • Common
XTPNumberFormat.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPPropExchange.h File Reference

  • Source
  • Common
Classes | Functions
XTPPropExchange.h File Reference

Go to the source code of this file.

Classes

class CXTPPropExchange
CXTPPropExchange is standalone pure class. More...

Functions

_XTP_EXT_CLASS BOOL AFX_CDECL | PX_Byte (CXTPPropExchange *pPX, LPCTSTR pszPropName, BYTE &nValue, BYTE nDefault)
Call this function within your class's DoPropExchange member function to serialize or initialize a property of type BYTE.
_XTP_EXT_CLASS BOOL AFX_CDECL | PX_Short (CXTPPropExchange *pPX, LPCTSTR pszPropName, short &sValue)
Call this function within your class's DoPropExchange member function to serialize or initialize a property of type short.
_XTP_EXT_CLASS BOOL AFX_CDECL | PX_Short (CXTPPropExchange *pPX, LPCTSTR pszPropName, short &sValue, short sDefault)
Call this function within your class's DoPropExchange member function to serialize or initialize a property of type short.
_XTP_EXT_CLASS BOOL AFX_CDECL | PX_UShort (CXTPPropExchange *pPX, LPCTSTR pszPropName, USHORT &usValue)
Call this function within your class's DoPropExchange member function to serialize or initialize a property of type USHORT.
_XTP_EXT_CLASS BOOL AFX_CDECL | PX_UShort (CXTPPropExchange *pPX, LPCTSTR pszPropName, USHORT &usValue, USHORT usDefault)
Call this function within your class's DoPropExchange member function to serialize or initialize a property of type USHORT.
_XTP_EXT_CLASS BOOL AFX_CDECL | PX_Long (CXTPPropExchange *pPX, LPCTSTR pszPropName, long &lValue)
Call this function within your class's DoPropExchange member function to serialize or initialize a property of type long.
_XTP_EXT_CLASS BOOL AFX_CDECL | PX_Long (CXTPPropExchange *pPX, LPCTSTR pszPropName, long &lValue, long lDefault)
Call this function within your class's DoPropExchange member function to serialize or initialize a property of type long.
_XTP_EXT_CLASS BOOL AFX_CDECL | PX_DPI_X_Long (CXTPPropExchange *pPX, LPCTSTR pszPropName, long &lValue)
Call this function within your class's DoPropExchange member function to serialize or initialize a property of type long.
_XTP_EXT_CLASS BOOL AFX_CDECL | PX_DPI_X_Long (CXTPPropExchange *pPX, LPCTSTR pszPropName, long &lValue, long lDefault)
Call this function within your class's DoPropExchange member function to serialize or initialize a property of type long.
_XTP_EXT_CLASS BOOL AFX_CDECL | PX_DPI_Y_Long (CXTPPropExchange *pPX, LPCTSTR pszPropName, long &lValue)
Call this function within your class's DoPropExchange member function to serialize or initialize a property of type long.
_XTP_EXT_CLASS BOOL AFX_CDECL | PX_DPI_Y_Long (CXTPPropExchange *pPX, LPCTSTR pszPropName, long &lValue, long lDefault)
Call this function within your class's DoPropExchange member function to serialize or initialize a property of type long.
_XTP_EXT_CLASS BOOL AFX_CDECL | PX_DWord (CXTPPropExchange *pPX, LPCTSTR pszPropName, DWORD &dwValue)
Call this function within your class's DoPropExchange member function to serialize or initialize a property of type DWORD.
_XTP_EXT_CLASS BOOL AFX_CDECL | PX_DWord (CXTPPropExchange *pPX, LPCTSTR pszPropName, DWORD &dwValue, DWORD dwDefault)
Call this function within your class's DoPropExchange member function to serialize or initialize a property of type DWORD.
_XTP_EXT_CLASS BOOL AFX_CDECL | PX_UI8 (CXTPPropExchange *pPX, LPCTSTR pszPropName, ULONGLONG &ullValue, ULONGLONG ullDefault)
Call this function within your class's DoPropExchange member function to serialize or initialize a property of type ULONGLONG.
_XTP_EXT_CLASS BOOL AFX_CDECL | PX_Int (CXTPPropExchange *pPX, LPCTSTR pszPropName, int &nValue)
Call this function within your class's DoPropExchange member function to serialize or initialize a property of type int.
_XTP_EXT_CLASS BOOL AFX_CDECL | PX_Int (CXTPPropExchange *pPX, LPCTSTR pszPropName, int &nValue, int nDefault)
Call this function within your class's DoPropExchange member function to serialize or initialize a property of type DWORD.
_XTP_EXT_CLASS BOOL AFX_CDECL | PX_DPI_X_Int (CXTPPropExchange *pPX, LPCTSTR pszPropName, int &nValue)
Call this function within your class's DoPropExchange member function to serialize or initialize a property of type DWORD.
_XTP_EXT_CLASS BOOL AFX_CDECL | PX_DPI_X_Int (CXTPPropExchange *pPX, LPCTSTR pszPropName, int &nValue, int nDefault)
Call this function within your class's DoPropExchange member function to serialize or initialize a property of type DWORD.
_XTP_EXT_CLASS BOOL AFX_CDECL | PX_DPI_Y_Int (CXTPPropExchange *pPX, LPCTSTR pszPropName, int &nValue)
Call this function within your class's DoPropExchange member function to serialize or initialize a property of type DWORD.
_XTP_EXT_CLASS BOOL AFX_CDECL | PX_DPI_Y_Int (CXTPPropExchange *pPX, LPCTSTR pszPropName, int &nValue, int nDefault)
Call this function within your class's DoPropExchange member function to serialize or initialize a property of type DWORD.
_XTP_EXT_CLASS BOOL AFX_CDECL | PX_ULong (CXTPPropExchange *pPX, LPCTSTR pszPropName, ULONG &ulValue)
Call this function within your class's DoPropExchange member function to serialize or initialize a property of type ULONG.
_XTP_EXT_CLASS BOOL AFX_CDECL | PX_ULong (CXTPPropExchange *pPX, LPCTSTR pszPropName, ULONG &ulValue, ULONG ulDefault)
Call this function within your class's DoPropExchange member function to serialize or initialize a property of type ULONG.
_XTP_EXT_CLASS BOOL AFX_CDECL | PX_Bool (CXTPPropExchange *pPX, LPCTSTR pszPropName, BOOL &bValue)
Call this function within your class's DoPropExchange member function to serialize or initialize a property of type BOOL.
_XTP_EXT_CLASS BOOL AFX_CDECL | PX_Bool (CXTPPropExchange *pPX, LPCTSTR pszPropName, BOOL &bValue, BOOL bDefault)
Call this function within your class's DoPropExchange member function to serialize or initialize a property of type BOOL.
_XTP_EXT_CLASS BOOL AFX_CDECL | PX_String (CXTPPropExchange *pPX, LPCTSTR pszPropName, CString &strValue)
Call this function within your class's DoPropExchange member function to serialize or initialize a character string property.
_XTP_EXT_CLASS BOOL AFX_CDECL | PX_String (CXTPPropExchange *pPX, LPCTSTR pszPropName, CString &strValue, LPCTSTR lpszDefault)
Call this function within your class's DoPropExchange member function to serialize or initialize a character string property.
_XTP_EXT_CLASS BOOL AFX_CDECL | PX_Bstr (CXTPPropExchange *pPX, LPCTSTR pszPropName, BSTR &bstrValue, BSTR bstrDefault)
Call this function within your class's DoPropExchange member function to serialize or initialize a character string property.
_XTP_EXT_CLASS BOOL AFX_CDECL | PX_Float (CXTPPropExchange *pPX, LPCTSTR pszPropName, float &floatValue)
Call this function within your class's DoPropExchange member function to serialize or initialize a property of type float.
_XTP_EXT_CLASS BOOL AFX_CDECL | PX_Float (CXTPPropExchange *pPX, LPCTSTR pszPropName, float &floatValue, float floatDefault)
Call this function within your class's DoPropExchange member function to serialize or initialize a property of type float.
_XTP_EXT_CLASS BOOL AFX_CDECL | PX_Double (CXTPPropExchange *pPX, LPCTSTR pszPropName, double &doubleValue)
Call this function within your class's DoPropExchange member function to serialize or initialize a property of type double.
_XTP_EXT_CLASS BOOL AFX_CDECL | PX_Double (CXTPPropExchange *pPX, LPCTSTR pszPropName, double &doubleValue, double doubleDefault)
Call this function within your class's DoPropExchange member function to serialize or initialize a property of type double.
_XTP_EXT_CLASS BOOL AFX_CDECL | PX_Size (CXTPPropExchange *pPX, LPCTSTR pszPropName, SIZE &szValue, SIZE szDefault)
Call this function within your class's DoPropExchange member function to serialize or initialize a property of type SIZE.
_XTP_EXT_CLASS BOOL AFX_CDECL | PX_DPI_Size (CXTPPropExchange *pPX, LPCTSTR pszPropName, SIZE &szValue, SIZE szDefault)
Call this function within your class's DoPropExchange member function to serialize or initialize a property of type SIZE.
_XTP_EXT_CLASS BOOL AFX_CDECL | PX_Rect (CXTPPropExchange *pPX, LPCTSTR pszPropName, RECT &rcValue, RECT rcDefault)
Call this function within your class's DoPropExchange member function to serialize or initialize a property of type RECT.
_XTP_EXT_CLASS BOOL AFX_CDECL | PX_DPI_Rect (CXTPPropExchange *pPX, LPCTSTR pszPropName, RECT &rcValue, RECT rcDefault)
Call this function within your class's DoPropExchange member function to serialize or initialize a property of type RECT.
_XTP_EXT_CLASS BOOL AFX_CDECL | PX_Point (CXTPPropExchange *pPX, LPCTSTR pszPropName, POINT &ptValue, POINT ptDefault)
Call this function within your class's DoPropExchange member function to serialize or initialize a property of type POINT.
_XTP_EXT_CLASS BOOL AFX_CDECL | PX_DPI_Point (CXTPPropExchange *pPX, LPCTSTR pszPropName, POINT &ptValue, POINT ptDefault)
Call this function within your class's DoPropExchange member function to serialize or initialize a property of type POINT.
_XTP_EXT_CLASS BOOL AFX_CDECL | PX_Point (CXTPPropExchange *pPX, LPCTSTR pszPropName, CXTPPoint3T< float > &ptValue, CXTPPoint3T< float > ptDefault)
Call this function within your class's DoPropExchange member function to serialize or initialize a property of type POINT.
_XTP_EXT_CLASS BOOL AFX_CDECL | PX_Point (CXTPPropExchange *pPX, LPCTSTR pszPropName, CXTPPoint3T< double > &ptValue, CXTPPoint3T< double > ptDefault)
Call this function within your class's DoPropExchange member function to serialize or initialize a property of type POINT.
_XTP_EXT_CLASS BOOL AFX_CDECL | PX_Point (CXTPPropExchange *pPX, LPCTSTR pszPropName, CXTPPoint3T< int > &ptValue, CXTPPoint3T< int > ptDefault)
Call this function within your class's DoPropExchange member function to serialize or initialize a property of type POINT.
_XTP_EXT_CLASS BOOL AFX_CDECL | PX_DateTime (CXTPPropExchange *pPX, LPCTSTR pszPropName, COleDateTime &dtValue)
Call this function within your class's DoPropExchange member function to serialize or initialize a property of type COleDateTime.
_XTP_EXT_CLASS BOOL AFX_CDECL | PX_RuntimeClass (CXTPPropExchange *pPX, LPCTSTR pszPropName, CRuntimeClass *&pClass, CRuntimeClass *pDefaultClass)
Call this function within your class's DoPropExchange member function to serialize or initialize a property of type CRuntimeClass.
_XTP_EXT_CLASS BOOL AFX_CDECL | PX_Serialize (CXTPPropExchange *pPX, LPCTSTR pszPropName, CObject *pObject)
Call this function within your class's DoPropExchange member function to serialize an object.
_XTP_EXT_CLASS BOOL AFX_CDECL | PX_Blob (CXTPPropExchange *pPX, LPCTSTR pszPropName, BYTE *&pData, DWORD &nBytes)
Call this function within your class's DoPropExchange member function to serialize a BYTE array.
_XTP_EXT_CLASS BOOL AFX_CDECL | PX_Variant (CXTPPropExchange *pPX, LPCTSTR pszPropName, COleVariant &variant, COleVariant variantDefault)
Call this function within your class's DoPropExchange member function to serialize or initialize a property of type COleVariant.
template<class TEnum >
AFX_INLINE BOOL AFX_CDECL | PX_Enum (CXTPPropExchange *pPX, LPCTSTR pszPropName, TEnum &nValue, TEnum nDefault)
Call this function within your class's DoPropExchange member function to serialize or initialize an enum property.
template<class TObject >
AFX_INLINE BOOL AFX_CDECL | PX_Object (CXTPPropExchange *pPX, LPCTSTR pszPropName, TObject *&pObject, CRuntimeClass *pObjectRuntime)
Call this function within your class's DoPropExchange member function to serialize any class that has the DoPropExchange method.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Function Documentation

◆ PX_Blob()

_XTP_EXT_CLASS BOOL AFX_CDECL PX_Blob | ( | CXTPPropExchange * | pPX,
 |  | LPCTSTR | pszPropName,
 |  | BYTE *& | pData,
 |  | DWORD & | nBytes )

Call this function within your class's DoPropExchange member function to serialize a BYTE array.

Parameters
pPX | Pointer to the CXTPPropExchange object (typically passed as a parameter to DoPropExchange).
pszPropName | The name of the property being exchanged.
pData | Byte array.
nBytes | Size of Byte array.
Returns
Nonzero if the exchange was successful, 0 if unsuccessful.

◆ PX_Bool() [1/2]

_XTP_EXT_CLASS BOOL AFX_CDECL PX_Bool | ( | CXTPPropExchange * | pPX,
 |  | LPCTSTR | pszPropName,
 |  | BOOL & | bValue )

Call this function within your class's DoPropExchange member function to serialize or initialize a property of type BOOL.

The property's value is read from or written to the variable referenced by bValue, as appropriate. If bDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.

Parameters
pPX | Pointer to the CXTPPropExchange object (typically passed as a parameter to DoPropExchange).
pszPropName | The name of the property being exchanged.
bValue | Reference to the variable where the property is stored (typically a member variable of your class).
Returns
Nonzero if the exchange was successful, 0 if unsuccessful.

◆ PX_Bool() [2/2]

_XTP_EXT_CLASS BOOL AFX_CDECL PX_Bool | ( | CXTPPropExchange * | pPX,
 |  | LPCTSTR | pszPropName,
 |  | BOOL & | bValue,
 |  | BOOL | bDefault )

Call this function within your class's DoPropExchange member function to serialize or initialize a property of type BOOL.

The property's value is read from or written to the variable referenced by bValue, as appropriate. If bDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.

Parameters
pPX | Pointer to the CXTPPropExchange object (typically passed as a parameter to DoPropExchange).
pszPropName | The name of the property being exchanged.
bValue | Reference to the variable where the property is stored (typically a member variable of your class).
bDefault | Default value for the property.
Returns
Nonzero if the exchange was successful, 0 if unsuccessful.

◆ PX_Bstr()

_XTP_EXT_CLASS BOOL AFX_CDECL PX_Bstr | ( | CXTPPropExchange * | pPX,
 |  | LPCTSTR | pszPropName,
 |  | BSTR & | bstrValue,
 |  | BSTR | bstrDefault )

Call this function within your class's DoPropExchange member function to serialize or initialize a character string property.

The property's value is read from or written to the variable referenced by strValue, as appropriate. If lpszDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.

Parameters
pPX | Pointer to the CXTPPropExchange object (typically passed as a parameter to DoPropExchange).
pszPropName | The name of the property being exchanged.
bstrValue | Reference to the variable where the property is stored (typically a member variable of your class).
bstrDefault | Default value for the property.
Returns
Nonzero if the exchange was successful, 0 if unsuccessful.

◆ PX_Byte()

_XTP_EXT_CLASS BOOL AFX_CDECL PX_Byte | ( | CXTPPropExchange * | pPX,
 |  | LPCTSTR | pszPropName,
 |  | BYTE & | nValue,
 |  | BYTE | nDefault )

Call this function within your class's DoPropExchange member function to serialize or initialize a property of type BYTE.

The property's value is read from or written to the variable referenced by nValue, as appropriate. If nDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.

Parameters
pPX | Pointer to the CXTPPropExchange object (typically passed as a parameter to DoPropExchange).
pszPropName | The name of the property being exchanged.
nValue | Reference to the variable where the property is stored (typically a member variable of your class).
nDefault | Default value for the property.
Returns
Nonzero if the exchange was successful, 0 if unsuccessful.

◆ PX_DateTime()

_XTP_EXT_CLASS BOOL AFX_CDECL PX_DateTime | ( | CXTPPropExchange * | pPX,
 |  | LPCTSTR | pszPropName,
 |  | COleDateTime & | dtValue )

Call this function within your class's DoPropExchange member function to serialize or initialize a property of type COleDateTime.

The property's value is read from or written to the variable referenced by dtValue, as appropriate.

Parameters
pPX | Pointer to the CXTPPropExchange object (typically passed as a parameter to DoPropExchange).
pszPropName | The name of the property being exchanged.
dtValue | Reference to the variable where the property is stored (typically a member variable of your class).
Returns
Nonzero if the exchange was successful, 0 if unsuccessful.

◆ PX_Double() [1/2]

_XTP_EXT_CLASS BOOL AFX_CDECL PX_Double | ( | CXTPPropExchange * | pPX,
 |  | LPCTSTR | pszPropName,
 |  | double & | doubleValue )

Call this function within your class's DoPropExchange member function to serialize or initialize a property of type double.

The property's value is read from or written to the variable referenced by doubleValue, as appropriate. If doubleDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.

Parameters
pPX | Pointer to the CXTPPropExchange object (typically passed as a parameter to DoPropExchange).
pszPropName | The name of the property being exchanged.
doubleValue | Reference to the variable where the property is stored (typically a member variable of your class).
Returns
Nonzero if the exchange was successful, 0 if unsuccessful.

◆ PX_Double() [2/2]

_XTP_EXT_CLASS BOOL AFX_CDECL PX_Double | ( | CXTPPropExchange * | pPX,
 |  | LPCTSTR | pszPropName,
 |  | double & | doubleValue,
 |  | double | doubleDefault )

Call this function within your class's DoPropExchange member function to serialize or initialize a property of type double.

The property's value is read from or written to the variable referenced by doubleValue, as appropriate. If doubleDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.

Parameters
pPX | Pointer to the CXTPPropExchange object (typically passed as a parameter to DoPropExchange).
pszPropName | The name of the property being exchanged.
doubleValue | Reference to the variable where the property is stored (typically a member variable of your class).
doubleDefault | Default value for the property.
Returns
Nonzero if the exchange was successful, 0 if unsuccessful.

◆ PX_DPI_Point()

_XTP_EXT_CLASS BOOL AFX_CDECL PX_DPI_Point | ( | CXTPPropExchange * | pPX,
 |  | LPCTSTR | pszPropName,
 |  | POINT & | ptValue,
 |  | POINT | ptDefault )

Call this function within your class's DoPropExchange member function to serialize or initialize a property of type POINT.

The property's value is read from or written to the variable referenced by ptValue, as appropriate. If ptDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails. The DPI version of the function stores the value as a DPI independent value.

Parameters
pPX | Pointer to the CXTPPropExchange object (typically passed as a parameter to DoPropExchange).
pszPropName | The name of the property being exchanged.
ptValue | Reference to the variable where the property is stored (typically a member variable of your class).
ptDefault | Default value for the property.
Returns
Nonzero if the exchange was successful, 0 if unsuccessful.

◆ PX_DPI_Rect()

_XTP_EXT_CLASS BOOL AFX_CDECL PX_DPI_Rect | ( | CXTPPropExchange * | pPX,
 |  | LPCTSTR | pszPropName,
 |  | RECT & | rcValue,
 |  | RECT | rcDefault )

Call this function within your class's DoPropExchange member function to serialize or initialize a property of type RECT.

The property's value is read from or written to the variable referenced by rcValue, as appropriate. If rcDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails. The DPI version of the function stores the value as a DPI independent value.

Parameters
pPX | Pointer to the CXTPPropExchange object (typically passed as a parameter to DoPropExchange).
pszPropName | The name of the property being exchanged.
rcValue | Reference to the variable where the property is stored (typically a member variable of your class).
rcDefault | Default value for the property.
Returns
Nonzero if the exchange was successful, 0 if unsuccessful.

◆ PX_DPI_Size()

_XTP_EXT_CLASS BOOL AFX_CDECL PX_DPI_Size | ( | CXTPPropExchange * | pPX,
 |  | LPCTSTR | pszPropName,
 |  | SIZE & | szValue,
 |  | SIZE | szDefault )

Call this function within your class's DoPropExchange member function to serialize or initialize a property of type SIZE.

The property's value is read from or written to the variable referenced by szValue, as appropriate. If szDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails. The DPI version of the function stores the value as a DPI independent value.

Parameters
pPX | Pointer to the CXTPPropExchange object (typically passed as a parameter to DoPropExchange).
pszPropName | The name of the property being exchanged.
szValue | Reference to the variable where the property is stored (typically a member variable of your class).
szDefault | Default value for the property.
Returns
Nonzero if the exchange was successful, 0 if unsuccessful.

◆ PX_DPI_X_Int() [1/2]

_XTP_EXT_CLASS BOOL AFX_CDECL PX_DPI_X_Int | ( | CXTPPropExchange * | pPX,
 |  | LPCTSTR | pszPropName,
 |  | int & | nValue )

Call this function within your class's DoPropExchange member function to serialize or initialize a property of type DWORD.

The property's value is read from or written to the variable referenced by dwValue, as appropriate. If dwDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.

Parameters
pPX | Pointer to the CXTPPropExchange object (typically passed as a parameter to DoPropExchange).
pszPropName | The name of the property being exchanged.
nValue | Reference to the variable where the property is stored
Returns
Nonzero if the exchange was successful, 0 if unsuccessful.

◆ PX_DPI_X_Int() [2/2]

_XTP_EXT_CLASS BOOL AFX_CDECL PX_DPI_X_Int | ( | CXTPPropExchange * | pPX,
 |  | LPCTSTR | pszPropName,
 |  | int & | nValue,
 |  | int | nDefault )

Call this function within your class's DoPropExchange member function to serialize or initialize a property of type DWORD.

The property's value is read from or written to the variable referenced by dwValue, as appropriate. If dwDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.

Parameters
pPX | Pointer to the CXTPPropExchange object (typically passed as a parameter to DoPropExchange).
pszPropName | The name of the property being exchanged.
nValue | Reference to the variable where the property is stored
nDefault | Default value for the property.
Returns
Nonzero if the exchange was successful, 0 if unsuccessful.

◆ PX_DPI_X_Long() [1/2]

_XTP_EXT_CLASS BOOL AFX_CDECL PX_DPI_X_Long | ( | CXTPPropExchange * | pPX,
 |  | LPCTSTR | pszPropName,
 |  | long & | lValue )

Call this function within your class's DoPropExchange member function to serialize or initialize a property of type long.

The property's value is read from or written to the variable referenced by lValue, as appropriate. If lDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.

Parameters
pPX | Pointer to the CXTPPropExchange object (typically passed as a parameter to DoPropExchange).
pszPropName | The name of the property being exchanged.
lValue | Reference to the variable where the property is stored (typically a member variable of your class).
Returns
Nonzero if the exchange was successful, 0 if unsuccessful.

◆ PX_DPI_X_Long() [2/2]

_XTP_EXT_CLASS BOOL AFX_CDECL PX_DPI_X_Long | ( | CXTPPropExchange * | pPX,
 |  | LPCTSTR | pszPropName,
 |  | long & | lValue,
 |  | long | lDefault )

Call this function within your class's DoPropExchange member function to serialize or initialize a property of type long.

The property's value is read from or written to the variable referenced by lValue, as appropriate. If lDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.

Parameters
pPX | Pointer to the CXTPPropExchange object (typically passed as a parameter to DoPropExchange).
pszPropName | The name of the property being exchanged.
lValue | Reference to the variable where the property is stored (typically a member variable of your class).
lDefault | Default value for the property.
Returns
Nonzero if the exchange was successful, 0 if unsuccessful.

◆ PX_DPI_Y_Int() [1/2]

_XTP_EXT_CLASS BOOL AFX_CDECL PX_DPI_Y_Int | ( | CXTPPropExchange * | pPX,
 |  | LPCTSTR | pszPropName,
 |  | int & | nValue )

Call this function within your class's DoPropExchange member function to serialize or initialize a property of type DWORD.

The property's value is read from or written to the variable referenced by dwValue, as appropriate. If dwDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.

Parameters
pPX | Pointer to the CXTPPropExchange object (typically passed as a parameter to DoPropExchange).
pszPropName | The name of the property being exchanged.
nValue | Reference to the variable where the property is stored
Returns
Nonzero if the exchange was successful, 0 if unsuccessful.

◆ PX_DPI_Y_Int() [2/2]

_XTP_EXT_CLASS BOOL AFX_CDECL PX_DPI_Y_Int | ( | CXTPPropExchange * | pPX,
 |  | LPCTSTR | pszPropName,
 |  | int & | nValue,
 |  | int | nDefault )

Call this function within your class's DoPropExchange member function to serialize or initialize a property of type DWORD.

The property's value is read from or written to the variable referenced by dwValue, as appropriate. If dwDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.

Parameters
pPX | Pointer to the CXTPPropExchange object (typically passed as a parameter to DoPropExchange).
pszPropName | The name of the property being exchanged.
nValue | Reference to the variable where the property is stored
nDefault | Default value for the property.
Returns
Nonzero if the exchange was successful, 0 if unsuccessful.

◆ PX_DPI_Y_Long() [1/2]

_XTP_EXT_CLASS BOOL AFX_CDECL PX_DPI_Y_Long | ( | CXTPPropExchange * | pPX,
 |  | LPCTSTR | pszPropName,
 |  | long & | lValue )

Call this function within your class's DoPropExchange member function to serialize or initialize a property of type long.

The property's value is read from or written to the variable referenced by lValue, as appropriate. If lDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.

Parameters
pPX | Pointer to the CXTPPropExchange object (typically passed as a parameter to DoPropExchange).
pszPropName | The name of the property being exchanged.
lValue | Reference to the variable where the property is stored (typically a member variable of your class).
Returns
Nonzero if the exchange was successful, 0 if unsuccessful.

◆ PX_DPI_Y_Long() [2/2]

_XTP_EXT_CLASS BOOL AFX_CDECL PX_DPI_Y_Long | ( | CXTPPropExchange * | pPX,
 |  | LPCTSTR | pszPropName,
 |  | long & | lValue,
 |  | long | lDefault )

Call this function within your class's DoPropExchange member function to serialize or initialize a property of type long.

The property's value is read from or written to the variable referenced by lValue, as appropriate. If lDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.

Parameters
pPX | Pointer to the CXTPPropExchange object (typically passed as a parameter to DoPropExchange).
pszPropName | The name of the property being exchanged.
lValue | Reference to the variable where the property is stored (typically a member variable of your class).
lDefault | Default value for the property.
Returns
Nonzero if the exchange was successful, 0 if unsuccessful.

◆ PX_DWord() [1/2]

_XTP_EXT_CLASS BOOL AFX_CDECL PX_DWord | ( | CXTPPropExchange * | pPX,
 |  | LPCTSTR | pszPropName,
 |  | DWORD & | dwValue )

Call this function within your class's DoPropExchange member function to serialize or initialize a property of type DWORD.

The property's value is read from or written to the variable referenced by dwValue, as appropriate. If dwDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.

Parameters
pPX | Pointer to the CXTPPropExchange object (typically passed as a parameter to DoPropExchange).
pszPropName | The name of the property being exchanged.
dwValue | Reference to the variable where the property is stored (typically a member variable of your class).
Returns
Nonzero if the exchange was successful, 0 if unsuccessful.

◆ PX_DWord() [2/2]

_XTP_EXT_CLASS BOOL AFX_CDECL PX_DWord | ( | CXTPPropExchange * | pPX,
 |  | LPCTSTR | pszPropName,
 |  | DWORD & | dwValue,
 |  | DWORD | dwDefault )

Call this function within your class's DoPropExchange member function to serialize or initialize a property of type DWORD.

The property's value is read from or written to the variable referenced by dwValue, as appropriate. If dwDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.

Parameters
pPX | Pointer to the CXTPPropExchange object (typically passed as a parameter to DoPropExchange).
pszPropName | The name of the property being exchanged.
dwValue | Reference to the variable where the property is stored (typically a member variable of your class).
dwDefault | Default value for the property.
Returns
Nonzero if the exchange was successful, 0 if unsuccessful.

◆ PX_Enum()

template<class TEnum >
AFX_INLINE BOOL AFX_CDECL PX_Enum | ( | CXTPPropExchange * | pPX,
 |  | LPCTSTR | pszPropName,
 |  | TEnum & | nValue,
 |  | TEnum | nDefault )

Call this function within your class's DoPropExchange member function to serialize or initialize an enum property.

The property's value is read from or written to the variable referenced by nValue, as appropriate. If nDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.

Parameters
pPX | Pointer to the CXTPPropExchange object (typically passed as a parameter to DoPropExchange).
pszPropName | The name of the property being exchanged.
nValue | Reference to the variable where the property is stored (typically a member variable of your class).
nDefault | Default value for the property.
Returns
Nonzero if the exchange was successful, 0 if unsuccessful.

◆ PX_Float() [1/2]

_XTP_EXT_CLASS BOOL AFX_CDECL PX_Float | ( | CXTPPropExchange * | pPX,
 |  | LPCTSTR | pszPropName,
 |  | float & | floatValue )

Call this function within your class's DoPropExchange member function to serialize or initialize a property of type float.

The property's value is read from or written to the variable referenced by floatValue, as appropriate. If floatDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.

Parameters
pPX | Pointer to the CXTPPropExchange object (typically passed as a parameter to DoPropExchange).
pszPropName | The name of the property being exchanged.
floatValue | Reference to the variable where the property is stored (typically a member variable of your class).
Returns
Nonzero if the exchange was successful, 0 if unsuccessful.

◆ PX_Float() [2/2]

_XTP_EXT_CLASS BOOL AFX_CDECL PX_Float | ( | CXTPPropExchange * | pPX,
 |  | LPCTSTR | pszPropName,
 |  | float & | floatValue,
 |  | float | floatDefault )

Call this function within your class's DoPropExchange member function to serialize or initialize a property of type float.

The property's value is read from or written to the variable referenced by floatValue, as appropriate. If floatDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.

Parameters
pPX | Pointer to the CXTPPropExchange object (typically passed as a parameter to DoPropExchange).
pszPropName | The name of the property being exchanged.
floatValue | Reference to the variable where the property is stored (typically a member variable of your class).
floatDefault | Default value for the property.
Returns
Nonzero if the exchange was successful, 0 if unsuccessful.

◆ PX_Int() [1/2]

_XTP_EXT_CLASS BOOL AFX_CDECL PX_Int | ( | CXTPPropExchange * | pPX,
 |  | LPCTSTR | pszPropName,
 |  | int & | nValue )

Call this function within your class's DoPropExchange member function to serialize or initialize a property of type int.

The property's value is read from or written to the variable referenced by nValue, as appropriate. If nDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails. The DPI version of the function stores the value as a DPI independent value.

Parameters
pPX | Pointer to the CXTPPropExchange object (typically passed as a parameter to DoPropExchange).
pszPropName | The name of the property being exchanged.
nValue | Reference to the variable where the property is stored (typically a member variable of your class).
Returns
Nonzero if the exchange was successful, 0 if unsuccessful.

◆ PX_Int() [2/2]

_XTP_EXT_CLASS BOOL AFX_CDECL PX_Int | ( | CXTPPropExchange * | pPX,
 |  | LPCTSTR | pszPropName,
 |  | int & | nValue,
 |  | int | nDefault )

Call this function within your class's DoPropExchange member function to serialize or initialize a property of type DWORD.

The property's value is read from or written to the variable referenced by dwValue, as appropriate. If dwDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.

Parameters
pPX | Pointer to the CXTPPropExchange object (typically passed as a parameter to DoPropExchange).
pszPropName | The name of the property being exchanged.
nValue | Reference to the variable where the property is stored
nDefault | Default value for the property.
Returns
Nonzero if the exchange was successful, 0 if unsuccessful.

◆ PX_Long() [1/2]

_XTP_EXT_CLASS BOOL AFX_CDECL PX_Long | ( | CXTPPropExchange * | pPX,
 |  | LPCTSTR | pszPropName,
 |  | long & | lValue )

Call this function within your class's DoPropExchange member function to serialize or initialize a property of type long.

The property's value is read from or written to the variable referenced by lValue, as appropriate. If lDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.

Parameters
pPX | Pointer to the CXTPPropExchange object (typically passed as a parameter to DoPropExchange).
pszPropName | The name of the property being exchanged.
lValue | Reference to the variable where the property is stored (typically a member variable of your class).
Returns
Nonzero if the exchange was successful, 0 if unsuccessful.

◆ PX_Long() [2/2]

_XTP_EXT_CLASS BOOL AFX_CDECL PX_Long | ( | CXTPPropExchange * | pPX,
 |  | LPCTSTR | pszPropName,
 |  | long & | lValue,
 |  | long | lDefault )

Call this function within your class's DoPropExchange member function to serialize or initialize a property of type long.

The property's value is read from or written to the variable referenced by lValue, as appropriate. If lDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.

Parameters
pPX | Pointer to the CXTPPropExchange object (typically passed as a parameter to DoPropExchange).
pszPropName | The name of the property being exchanged.
lValue | Reference to the variable where the property is stored (typically a member variable of your class).
lDefault | Default value for the property.
Returns
Nonzero if the exchange was successful, 0 if unsuccessful.

◆ PX_Object()

template<class TObject >
AFX_INLINE BOOL AFX_CDECL PX_Object | ( | CXTPPropExchange * | pPX,
 |  | LPCTSTR | pszPropName,
 |  | TObject *& | pObject,
 |  | CRuntimeClass * | pObjectRuntime )

Call this function within your class's DoPropExchange member function to serialize any class that has the DoPropExchange method.

Parameters
pPX | Pointer to the CXTPPropExchange object (typically passed as a parameter to DoPropExchange).
pszPropName | The name of the property being exchanged.
pObject | Reference to the object.
pObjectRuntime | Default runtime class of object.
Returns
Nonzero if the exchange was successful, 0 if unsuccessful.

◆ PX_Point() [1/4]

_XTP_EXT_CLASS BOOL AFX_CDECL PX_Point | ( | CXTPPropExchange * | pPX,
 |  | LPCTSTR | pszPropName,
 |  | CXTPPoint3T< double > & | ptValue,
 |  | CXTPPoint3T< double > | ptDefault )

Call this function within your class's DoPropExchange member function to serialize or initialize a property of type POINT.

The property's value is read from or written to the variable referenced by ptValue, as appropriate. If ptDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails. The DPI version of the function stores the value as a DPI independent value.

Parameters
pPX | Pointer to the CXTPPropExchange object (typically passed as a parameter to DoPropExchange).
pszPropName | The name of the property being exchanged.
ptValue | Reference to the variable where the property is stored (typically a member variable of your class).
ptDefault | Default value for the property.
Returns
Nonzero if the exchange was successful, 0 if unsuccessful.

◆ PX_Point() [2/4]

_XTP_EXT_CLASS BOOL AFX_CDECL PX_Point | ( | CXTPPropExchange * | pPX,
 |  | LPCTSTR | pszPropName,
 |  | CXTPPoint3T< float > & | ptValue,
 |  | CXTPPoint3T< float > | ptDefault )

Call this function within your class's DoPropExchange member function to serialize or initialize a property of type POINT.

The property's value is read from or written to the variable referenced by ptValue, as appropriate. If ptDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails. The DPI version of the function stores the value as a DPI independent value.

Parameters
pPX | Pointer to the CXTPPropExchange object (typically passed as a parameter to DoPropExchange).
pszPropName | The name of the property being exchanged.
ptValue | Reference to the variable where the property is stored (typically a member variable of your class).
ptDefault | Default value for the property.
Returns
Nonzero if the exchange was successful, 0 if unsuccessful.

◆ PX_Point() [3/4]

_XTP_EXT_CLASS BOOL AFX_CDECL PX_Point | ( | CXTPPropExchange * | pPX,
 |  | LPCTSTR | pszPropName,
 |  | CXTPPoint3T< int > & | ptValue,
 |  | CXTPPoint3T< int > | ptDefault )

Call this function within your class's DoPropExchange member function to serialize or initialize a property of type POINT.

The property's value is read from or written to the variable referenced by ptValue, as appropriate. If ptDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails. The DPI version of the function stores the value as a DPI independent value.

Parameters
pPX | Pointer to the CXTPPropExchange object (typically passed as a parameter to DoPropExchange).
pszPropName | The name of the property being exchanged.
ptValue | Reference to the variable where the property is stored (typically a member variable of your class).
ptDefault | Default value for the property.
Returns
Nonzero if the exchange was successful, 0 if unsuccessful.

◆ PX_Point() [4/4]

_XTP_EXT_CLASS BOOL AFX_CDECL PX_Point | ( | CXTPPropExchange * | pPX,
 |  | LPCTSTR | pszPropName,
 |  | POINT & | ptValue,
 |  | POINT | ptDefault )

Call this function within your class's DoPropExchange member function to serialize or initialize a property of type POINT.

The property's value is read from or written to the variable referenced by ptValue, as appropriate. If ptDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails. The DPI version of the function stores the value as a DPI independent value.

Parameters
pPX | Pointer to the CXTPPropExchange object (typically passed as a parameter to DoPropExchange).
pszPropName | The name of the property being exchanged.
ptValue | Reference to the variable where the property is stored (typically a member variable of your class).
ptDefault | Default value for the property.
Returns
Nonzero if the exchange was successful, 0 if unsuccessful.

◆ PX_Rect()

_XTP_EXT_CLASS BOOL AFX_CDECL PX_Rect | ( | CXTPPropExchange * | pPX,
 |  | LPCTSTR | pszPropName,
 |  | RECT & | rcValue,
 |  | RECT | rcDefault )

Call this function within your class's DoPropExchange member function to serialize or initialize a property of type RECT.

The property's value is read from or written to the variable referenced by rcValue, as appropriate. If rcDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails. The DPI version of the function stores the value as a DPI independent value.

Parameters
pPX | Pointer to the CXTPPropExchange object (typically passed as a parameter to DoPropExchange).
pszPropName | The name of the property being exchanged.
rcValue | Reference to the variable where the property is stored (typically a member variable of your class).
rcDefault | Default value for the property.
Returns
Nonzero if the exchange was successful, 0 if unsuccessful.

◆ PX_RuntimeClass()

_XTP_EXT_CLASS BOOL AFX_CDECL PX_RuntimeClass | ( | CXTPPropExchange * | pPX,
 |  | LPCTSTR | pszPropName,
 |  | CRuntimeClass *& | pClass,
 |  | CRuntimeClass * | pDefaultClass )

Call this function within your class's DoPropExchange member function to serialize or initialize a property of type CRuntimeClass.

The property's value is read from or written to the variable referenced by pClass, as appropriate. If pDefaultClass is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.

Parameters
pPX | Pointer to the CXTPPropExchange object (typically passed as a parameter to DoPropExchange).
pszPropName | The name of the property being exchanged.
pClass | Reference to the variable where the property is stored (typically a member variable of your class).
pDefaultClass | Default value for the property.
Returns
Nonzero if the exchange was successful, 0 if unsuccessful.

◆ PX_Serialize()

_XTP_EXT_CLASS BOOL AFX_CDECL PX_Serialize | ( | CXTPPropExchange * | pPX,
 |  | LPCTSTR | pszPropName,
 |  | CObject * | pObject )

Call this function within your class's DoPropExchange member function to serialize an object.

Parameters
pPX | Pointer to the CXTPPropExchange object (typically passed as a parameter to DoPropExchange).
pszPropName | The name of the property being exchanged.
pObject | Object you need to serialize.
Returns
Nonzero if the exchange was successful, 0 if unsuccessful.

◆ PX_Short() [1/2]

_XTP_EXT_CLASS BOOL AFX_CDECL PX_Short | ( | CXTPPropExchange * | pPX,
 |  | LPCTSTR | pszPropName,
 |  | short & | sValue )

Call this function within your class's DoPropExchange member function to serialize or initialize a property of type short.

The property's value is read from or written to the variable referenced by sValue, as appropriate. If sDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.

Parameters
pPX | Pointer to the CXTPPropExchange object (typically passed as a parameter to DoPropExchange).
pszPropName | The name of the property being exchanged.
sValue | Reference to the variable where the property is stored (typically a member variable of your class).
Returns
Nonzero if the exchange was successful, 0 if unsuccessful.

◆ PX_Short() [2/2]

_XTP_EXT_CLASS BOOL AFX_CDECL PX_Short | ( | CXTPPropExchange * | pPX,
 |  | LPCTSTR | pszPropName,
 |  | short & | sValue,
 |  | short | sDefault )

Call this function within your class's DoPropExchange member function to serialize or initialize a property of type short.

The property's value is read from or written to the variable referenced by sValue, as appropriate. If sDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.

Parameters
pPX | Pointer to the CXTPPropExchange object (typically passed as a parameter to DoPropExchange).
pszPropName | The name of the property being exchanged.
sValue | Reference to the variable where the property is stored (typically a member variable of your class).
sDefault | Default value for the property.
Returns
Nonzero if the exchange was successful, 0 if unsuccessful.

◆ PX_Size()

_XTP_EXT_CLASS BOOL AFX_CDECL PX_Size | ( | CXTPPropExchange * | pPX,
 |  | LPCTSTR | pszPropName,
 |  | SIZE & | szValue,
 |  | SIZE | szDefault )

Call this function within your class's DoPropExchange member function to serialize or initialize a property of type SIZE.

The property's value is read from or written to the variable referenced by szValue, as appropriate. If szDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails. The DPI version of the function stores the value as a DPI independent value.

Parameters
pPX | Pointer to the CXTPPropExchange object (typically passed as a parameter to DoPropExchange).
pszPropName | The name of the property being exchanged.
szValue | Reference to the variable where the property is stored (typically a member variable of your class).
szDefault | Default value for the property.
Returns
Nonzero if the exchange was successful, 0 if unsuccessful.

◆ PX_String() [1/2]

_XTP_EXT_CLASS BOOL AFX_CDECL PX_String | ( | CXTPPropExchange * | pPX,
 |  | LPCTSTR | pszPropName,
 |  | CString & | strValue )

Call this function within your class's DoPropExchange member function to serialize or initialize a character string property.

The property's value is read from or written to the variable referenced by strValue, as appropriate. If lpszDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.

Parameters
pPX | Pointer to the CXTPPropExchange object (typically passed as a parameter to DoPropExchange).
pszPropName | The name of the property being exchanged.
strValue | Reference to the variable where the property is stored (typically a member variable of your class).
Returns
Nonzero if the exchange was successful, 0 if unsuccessful.

◆ PX_String() [2/2]

_XTP_EXT_CLASS BOOL AFX_CDECL PX_String | ( | CXTPPropExchange * | pPX,
 |  | LPCTSTR | pszPropName,
 |  | CString & | strValue,
 |  | LPCTSTR | lpszDefault )

Call this function within your class's DoPropExchange member function to serialize or initialize a character string property.

The property's value is read from or written to the variable referenced by strValue, as appropriate. If lpszDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.

Parameters
pPX | Pointer to the CXTPPropExchange object (typically passed as a parameter to DoPropExchange).
pszPropName | The name of the property being exchanged.
strValue | Reference to the variable where the property is stored (typically a member variable of your class).
lpszDefault | Default value for the property.
Returns
Nonzero if the exchange was successful, 0 if unsuccessful.

◆ PX_UI8()

_XTP_EXT_CLASS BOOL AFX_CDECL PX_UI8 | ( | CXTPPropExchange * | pPX,
 |  | LPCTSTR | pszPropName,
 |  | ULONGLONG & | ullValue,
 |  | ULONGLONG | ullDefault )

Call this function within your class's DoPropExchange member function to serialize or initialize a property of type ULONGLONG.

The property's value is read from or written to the variable referenced by ullValue, as appropriate. If ullDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.

Parameters
pPX | Pointer to the CXTPPropExchange object (typically passed as a parameter to DoPropExchange).
pszPropName | The name of the property being exchanged.
ullValue | Reference to the variable where the property is stored (typically a member variable of your class).
ullDefault | Default value for the property.
Returns
Nonzero if the exchange was successful, 0 if unsuccessful.

◆ PX_ULong() [1/2]

_XTP_EXT_CLASS BOOL AFX_CDECL PX_ULong | ( | CXTPPropExchange * | pPX,
 |  | LPCTSTR | pszPropName,
 |  | ULONG & | ulValue )

Call this function within your class's DoPropExchange member function to serialize or initialize a property of type ULONG.

The property's value is read from or written to the variable referenced by ulValue, as appropriate. If ulDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.

Parameters
pPX | Pointer to the CXTPPropExchange object (typically passed as a parameter to DoPropExchange).
pszPropName | The name of the property being exchanged.
ulValue | Reference to the variable where the property is stored (typically a member variable of your class).
Returns
Nonzero if the exchange was successful, 0 if unsuccessful.

◆ PX_ULong() [2/2]

_XTP_EXT_CLASS BOOL AFX_CDECL PX_ULong | ( | CXTPPropExchange * | pPX,
 |  | LPCTSTR | pszPropName,
 |  | ULONG & | ulValue,
 |  | ULONG | ulDefault )

Call this function within your class's DoPropExchange member function to serialize or initialize a property of type ULONG.

The property's value is read from or written to the variable referenced by ulValue, as appropriate. If ulDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.

Parameters
pPX | Pointer to the CXTPPropExchange object (typically passed as a parameter to DoPropExchange).
pszPropName | The name of the property being exchanged.
ulValue | Reference to the variable where the property is stored (typically a member variable of your class).
ulDefault | Default value for the property.
Returns
Nonzero if the exchange was successful, 0 if unsuccessful.

◆ PX_UShort() [1/2]

_XTP_EXT_CLASS BOOL AFX_CDECL PX_UShort | ( | CXTPPropExchange * | pPX,
 |  | LPCTSTR | pszPropName,
 |  | USHORT & | usValue )

Call this function within your class's DoPropExchange member function to serialize or initialize a property of type USHORT.

The property's value is read from or written to the variable referenced by usValue, as appropriate. If usDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.

Parameters
pPX | Pointer to the CXTPPropExchange object (typically passed as a parameter to DoPropExchange).
pszPropName | The name of the property being exchanged.
usValue | Reference to the variable where the property is stored (typically a member variable of your class).
Returns
Nonzero if the exchange was successful, 0 if unsuccessful.

◆ PX_UShort() [2/2]

_XTP_EXT_CLASS BOOL AFX_CDECL PX_UShort | ( | CXTPPropExchange * | pPX,
 |  | LPCTSTR | pszPropName,
 |  | USHORT & | usValue,
 |  | USHORT | usDefault )

Call this function within your class's DoPropExchange member function to serialize or initialize a property of type USHORT.

The property's value is read from or written to the variable referenced by usValue, as appropriate. If usDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.

Parameters
pPX | Pointer to the CXTPPropExchange object (typically passed as a parameter to DoPropExchange).
pszPropName | The name of the property being exchanged.
usValue | Reference to the variable where the property is stored (typically a member variable of your class).
usDefault | Default value for the property.
Returns
Nonzero if the exchange was successful, 0 if unsuccessful.

◆ PX_Variant()

_XTP_EXT_CLASS BOOL AFX_CDECL PX_Variant | ( | CXTPPropExchange * | pPX,
 |  | LPCTSTR | pszPropName,
 |  | COleVariant & | variant,
 |  | COleVariant | variantDefault )

Call this function within your class's DoPropExchange member function to serialize or initialize a property of type COleVariant.

The property's value is read from or written to the variable referenced by variant, as appropriate. If variantDefault is specified, it will be used as the property's default value. This value is used if, for any reason, the serialization process fails.

Parameters
pPX | Pointer to the CXTPPropExchange object (typically passed as a parameter to DoPropExchange).
pszPropName | The name of the property being exchanged.
variant | Reference to the variable where the property is stored (typically a member variable of your class).
variantDefault | Default value for the property.
Returns
Nonzero if the exchange was successful, 0 if unsuccessful.


Toolkit Pro: XTPRegExp.h File Reference

  • Source
  • Common
XTPRegExp.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPResource.h File Reference

  • Source
  • Common
XTPResource.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPResourceImage.h File Reference

  • Source
  • Common
Classes | Macros | Functions
XTPResourceImage.h File Reference

Go to the source code of this file.

Classes

class | CXTPResourceImage
Represent a resource image and provides basic images functions. More...
class | CXTPResourceImages
Implements resource image collection and its operations. More...

Macros

#define | xtpIniOffice2007Aqua _T("OFFICE2007AQUA_INI")
Use with CXTPResourceImages::SetHandle(), specifies Office \ \ \ \ 2007 Aqua settings file.
#define | xtpIniOffice2007Blue _T("OFFICE2007BLUE_INI")
Use with CXTPResourceImages::SetHandle(), specifies Office \ \ \ \ 2007 Blue settings file.
#define | xtpIniOffice2007Black _T("OFFICE2007BLACK_INI")
Use with CXTPResourceImages::SetHandle(), specifies Office \ \ \ \ 2007 Black settings file.
#define | xtpIniOffice2007Silver _T("OFFICE2007SILVER_INI")
Use with CXTPResourceImages::SetHandle(), specifies Office \ \ \ \ 2007 Silver settings file.
#define | xtpIniOffice2010Blue _T("OFFICE2010BLUE_INI")
Use with CXTPResourceImages::SetHandle(), specifies Office \ \ \ \ 2010 Blue settings file.
#define | xtpIniOffice2010Black _T("OFFICE2010BLACK_INI")
Use with CXTPResourceImages::SetHandle(), specifies Office \ \ \ \ 2010 Black settings file.
#define | xtpIniOffice2010Silver _T("OFFICE2010SILVER_INI")
Use with CXTPResourceImages::SetHandle(), specifies Office \ \ \ \ 2010 Silver settings file.
#define | xtpIniOffice2013Access _T("OFFICE2013ACCESS_INI")
Use with CXTPResourceImages::SetHandle(), specifies Office \ \ \ \ 2013 Access settings file.
#define | xtpIniOffice2013AccessGrayDark _T("OFFICE2013ACCESSGRAYDARK_INI")
Use with CXTPResourceImages::SetHandle(), \ \ \ \ specifies Office 2013 Access Dark Gray settings \ \ \ \ file.
#define | xtpIniOffice2013AccessGrayLight _T("OFFICE2013ACCESSGRAYLIGHT_INI")
Use with CXTPResourceImages::SetHandle(), \ \ \ \ specifies Office 2013 Access Light Gray settings \ \ \ \ file.
#define | xtpIniOffice2013Excel _T("OFFICE2013EXCEL_INI")
Use with CXTPResourceImages::SetHandle(), specifies Office \ \ \ \ 2013 Excel settings file.
#define | xtpIniOffice2013ExcelGrayDark _T("OFFICE2013EXCELGRAYDARK_INI")
Use with CXTPResourceImages::SetHandle(), specifies \ \ \ \ Office 2013 Excel Dark Gray settings file.
#define | xtpIniOffice2013ExcelGrayLight _T("OFFICE2013EXCELGRAYLIGHT_INI")
Use with CXTPResourceImages::SetHandle(), \ \ \ \ specifies Office 2013 Excel Light Gray settings \ \ \ \ file.
#define | xtpIniOffice2013OneNote _T("OFFICE2013ONENOTE_INI")
Use with CXTPResourceImages::SetHandle(), specifies \ \ \ \ Office 2013 OneNote settings file.
#define | xtpIniOffice2013OneNoteGrayDark _T("OFFICE2013ONENOTEGRAYDARK_INI")
Use with CXTPResourceImages::SetHandle(), \ \ \ \ specifies Office 2013 OneNote Dark Gray settings \ \ \ \ file.
#define | xtpIniOffice2013OneNoteGrayLight _T("OFFICE2013ONENOTEGRAYLIGHT_INI")
Use with CXTPResourceImages::SetHandle(), \ \ \ \ specifies Office 2013 OneNote Light Gray settings \ \ \ \ file.
#define | xtpIniOffice2013Outlook _T("OFFICE2013OUTLOOK_INI")
Use with CXTPResourceImages::SetHandle(), specifies \ \ \ \ Office 2013 Outlook settings file.
#define | xtpIniOffice2013OutlookGrayDark _T("OFFICE2013OUTLOOKGRAYDARK_INI")
Use with CXTPResourceImages::SetHandle(), \ \ \ \ specifies Office 2013 Outlook Dark Gray settings \ \ \ \ file.
#define | xtpIniOffice2013OutlookGrayLight _T("OFFICE2013OUTLOOKGRAYLIGHT_INI")
Use with CXTPResourceImages::SetHandle(), \ \ \ \ specifies Office 2013 Outlook Light Gray settings \ \ \ \ file.
#define | xtpIniOffice2013Publisher _T("OFFICE2013PUBLISHER_INI")
Use with CXTPResourceImages::SetHandle(), specifies \ \ \ \ Office 2013 Publisher settings file.
#define | xtpIniOffice2013PublisherGrayDark _T("OFFICE2013PUBLISHERGRAYDARK_INI")
Use with CXTPResourceImages::SetHandle(), \ \ \ \ specifies Office 2013 Publisher Dark Gray \ \ \ \ settings file.
#define | xtpIniOffice2013PublisherGrayLight _T("OFFICE2013PUBLISHERGRAYLIGHT_INI")
Use with CXTPResourceImages::SetHandle(), \ \ \ \ \ specifies Office 2013 Publisher Light Gray \ \ \ \ settings file.
#define | xtpIniOffice2013PowerPoint _T("OFFICE2013POWERPOINT_INI")
Use with CXTPResourceImages::SetHandle(), specifies \ \ \ \ Office 2013 PowerPoint settings file.
#define | xtpIniOffice2013PowerPointGrayDark _T("OFFICE2013POWERPOINTGRAYDARK_INI")
Use with CXTPResourceImages::SetHandle(), \ \ \ \ \ specifies Office 2013 PowerPoint Dark Gray \ \ \ \ settings file.
#define | xtpIniOffice2013PowerPointGrayLight _T("OFFICE2013POWERPOINTGRAYLIGHT_INI")
Use with CXTPResourceImages::SetHandle(), \ \ \ \ \ specifies Office 2013 PowerPoint Light Gray \ \ \ \ settings file.
#define | xtpIniOffice2013Word _T("OFFICE2013WORD_INI")
Use with CXTPResourceImages::SetHandle(), specifies Office \ \ \ \ 2013 Word settings file.
#define | xtpIniOffice2013WordGrayDark _T("OFFICE2013WORDGRAYDARK_INI")
Use with CXTPResourceImages::SetHandle(), specifies \ \ \ \ Office 2013 Word Dark Gray settings file.
#define | xtpIniOffice2013WordGrayLight _T("OFFICE2013WORDGRAYLIGHT_INI")
Use with CXTPResourceImages::SetHandle(), specifies \ \ \ \ Office 2013 Word Light Gray settings file.
#define | xtpIniOffice2016AccessBlack _T("OFFICE2016ACCESSBLACK_INI")
Use with CXTPResourceImages::SetHandle(), specifies \ \ \ \ Office 2016 Access Black settings file.
#define | xtpIniOffice2016AccessColorful _T("OFFICE2016ACCESSCOLORFUL_INI")
Use with CXTPResourceImages::SetHandle(), \ \ \ \ specifies Office 2016 Access Colorful settings file.
#define | xtpIniOffice2016AccessDarkGray _T("OFFICE2016ACCESSDARKGRAY_INI")
Use with CXTPResourceImages::SetHandle(), \ \ \ \ specifies Office 2016 Access Dark Gray settings \ \ \ \ file.
#define | xtpIniOffice2016AccessWhite _T("OFFICE2016ACCESSWHITE_INI")
Use with CXTPResourceImages::SetHandle(), specifies \ \ \ \ Office 2016 Access White settings file.
#define | xtpIniOffice2016ExcelBlack _T("OFFICE2016EXCELBLACK_INI")
Use with CXTPResourceImages::SetHandle(), specifies \ \ \ \ Office 2016 Excel Black settings file.
#define | xtpIniOffice2016ExcelColorful _T("OFFICE2016EXCELCOLORFUL_INI")
Use with CXTPResourceImages::SetHandle(), specifies \ \ \ \ Office 2016 Excel Colorful settings file.
#define | xtpIniOffice2016ExcelDarkGray _T("OFFICE2016EXCELDARKGRAY_INI")
Use with CXTPResourceImages::SetHandle(), specifies \ \ \ \ Office 2016 Excel Dark Gray settings file.
#define | xtpIniOffice2016ExcelWhite _T("OFFICE2016EXCELWHITE_INI")
Use with CXTPResourceImages::SetHandle(), specifies \ \ \ \ Office 2016 Excel White settings file.
#define | xtpIniOffice2016OneNoteBlack _T("OFFICE2016ONENOTEBLACK_INI")
Use with CXTPResourceImages::SetHandle(), specifies \ \ \ \ Office 2016 OneNote Black settings file.
#define | xtpIniOffice2016OneNoteColorful _T("OFFICE2016ONENOTECOLORFUL_INI")
Use with CXTPResourceImages::SetHandle(), \ \ \ \ specifies Office 2016 OneNote Colorful settings \ \ \ \ file.
#define | xtpIniOffice2016OneNoteDarkGray _T("OFFICE2016ONENOTEDARKGRAY_INI")
Use with CXTPResourceImages::SetHandle(), \ \ \ \ specifies Office 2016 OneNote Dark Gray settings \ \ \ \ file.
#define | xtpIniOffice2016OneNoteWhite _T("OFFICE2016ONENOTEWHITE_INI")
Use with CXTPResourceImages::SetHandle(), specifies \ \ \ \ Office 2016 OneNote White settings file.
#define | xtpIniOffice2016OutlookBlack _T("OFFICE2016OUTLOOKBLACK_INI")
Use with CXTPResourceImages::SetHandle(), specifies \ \ \ \ Office 2016 Outlook Black settings file.
#define | xtpIniOffice2016OutlookColorful _T("OFFICE2016OUTLOOKCOLORFUL_INI")
Use with CXTPResourceImages::SetHandle(), \ \ \ \ specifies Office 2016 Outlook Colorful settings \ \ \ \ file.
#define | xtpIniOffice2016OutlookDarkGray _T("OFFICE2016OUTLOOKDARKGRAY_INI")
Use with CXTPResourceImages::SetHandle(), \ \ \ \ specifies Office 2016 Outlook Dark Gray settings \ \ \ \ file.
#define | xtpIniOffice2016OutlookWhite _T("OFFICE2016OUTLOOKWHITE_INI")
Use with CXTPResourceImages::SetHandle(), specifies \ \ \ \ Office 2016 Outlook White settings file.
#define | xtpIniOffice2016PublisherBlack _T("OFFICE2016PUBLISHERBLACK_INI")
Use with CXTPResourceImages::SetHandle(), \ \ \ \ specifies Office 2016 Publisher Black settings file.
#define | xtpIniOffice2016PublisherColorful _T("OFFICE2016PUBLISHERCOLORFUL_INI")
Use with CXTPResourceImages::SetHandle(), \ \ \ \ specifies Office 2016 Publisher Colorful settings \ \ \ \ file.
#define | xtpIniOffice2016PublisherDarkGray _T("OFFICE2016PUBLISHERDARKGRAY_INI")
Use with CXTPResourceImages::SetHandle(), \ \ \ \ specifies Office 2016 Publisher Dark Gray \ \ \ \ settings file.
#define | xtpIniOffice2016PublisherWhite _T("OFFICE2016PUBLISHERWHITE_INI")
Use with CXTPResourceImages::SetHandle(), \ \ \ \ specifies Office 2016 Publisher White settings file.
#define | xtpIniOffice2016PowerPointBlack _T("OFFICE2016POWERPOINTBLACK_INI")
Use with CXTPResourceImages::SetHandle(), \ \ \ \ specifies Office 2016 PowerPoint Black settings \ \ \ \ file.
#define | xtpIniOffice2016PowerPointColorful _T("OFFICE2016POWERPOINTCOLORFUL_INI")
Use with CXTPResourceImages::SetHandle(), \ \ \ \ \ specifies Office 2016 PowerPoint Colorful \ \ \ \ settings file.
#define | xtpIniOffice2016PowerPointDarkGray _T("OFFICE2016POWERPOINTDARKGRAY_INI")
Use with CXTPResourceImages::SetHandle(), \ \ \ \ \ specifies Office 2016 PowerPoint Dark Gray \ \ \ \ settings file.
#define | xtpIniOffice2016PowerPointWhite _T("OFFICE2016POWERPOINTWHITE_INI")
Use with CXTPResourceImages::SetHandle(), \ \ \ \ specifies Office 2016 PowerPoint White settings \ \ \ \ file.
#define | xtpIniOffice2016WordBlack _T("OFFICE2016WORDBLACK_INI")
Use with CXTPResourceImages::SetHandle(), specifies \ \ \ \ Office 2016 Word Black settings file.
#define | xtpIniOffice2016WordColorful _T("OFFICE2016WORDCOLORFUL_INI")
Use with CXTPResourceImages::SetHandle(), specifies \ \ \ \ Office 2016 Word Colorful settings file.
#define | xtpIniOffice2016WordDarkGray _T("OFFICE2016WORDDARKGRAY_INI")
Use with CXTPResourceImages::SetHandle(), specifies \ \ \ \ Office 2016 Word Dark Gray settings file.
#define | xtpIniOffice2016WordWhite _T("OFFICE2016WORDWHITE_INI")
Use with CXTPResourceImages::SetHandle(), specifies \ \ \ \ Office 2016 Word White settings file.
#define | xtpIniVisualStudio2012Dark _T("VISUALSTUDIO2012DARK_INI")
Use with CXTPResourceImages::SetHandle(), specifies \ \ \ \ Visual Studio 2012 Dark settings file.
#define | xtpIniVisualStudio2012Light _T("VISUALSTUDIO2012LIGHT_INI")
Use with CXTPResourceImages::SetHandle(), specifies \ \ \ \ Visual Studio 2012 Light settings file.
#define | xtpIniVisualStudio2015Blue _T("VISUALSTUDIO2015BLUE_INI")
Use with CXTPResourceImages::SetHandle(), specifies \ \ \ \ Visual Studio 2015 Blue settings file.
#define | xtpIniVisualStudio2015Dark _T("VISUALSTUDIO2015DARK_INI")
Use with CXTPResourceImages::SetHandle(), specifies \ \ \ \ Visual Studio 2015 Dark settings file.
#define | xtpIniVisualStudio2015Light _T("VISUALSTUDIO2015LIGHT_INI")
Use with CXTPResourceImages::SetHandle(), specifies \ \ \ \ Visual Studio 2015 Light settings file.
#define | xtpIniVisualStudio2017Blue _T("VISUALSTUDIO2017BLUE_INI")
Use with CXTPResourceImages::SetHandle(), specifies \ \ \ \ Visual Studio 2017 Blue settings file.
#define | xtpIniVisualStudio2017BlueExtra _T("VISUALSTUDIO2017BLUEEXTRA_INI")
Use with CXTPResourceImages::SetHandle(), \ \ \ \ specifies Visual Studio 2017 Blue Extra settings \ \ \ \ file.
#define | xtpIniVisualStudio2017Dark _T("VISUALSTUDIO2017DARK_INI")
Use with CXTPResourceImages::SetHandle(), specifies \ \ \ \ Visual Studio 2017 Dark settings file.
#define | xtpIniVisualStudio2017Light _T("VISUALSTUDIO2017LIGHT_INI")
Use with CXTPResourceImages::SetHandle(), specifies \ \ \ \ Visual Studio 2017 Light settings file.
#define | xtpIniVisualStudio2019Blue _T("VISUALSTUDIO2019BLUE_INI")
Use with CXTPResourceImages::SetHandle(), specifies \ \ \ \ Visual Studio 2019 Blue settings file.
#define | xtpIniVisualStudio2019BlueExtra _T("VISUALSTUDIO2019BLUEEXTRA_INI")
Use with CXTPResourceImages::SetHandle(), \ \ \ \ specifies Visual Studio 2019 Blue Extra settings \ \ \ \ file.
#define | xtpIniVisualStudio2019Dark _T("VISUALSTUDIO2019DARK_INI")
Use with CXTPResourceImages::SetHandle(), specifies \ \ \ \ Visual Studio 2019 Dark settings file.
#define | xtpIniVisualStudio2019Light _T("VISUALSTUDIO2019LIGHT_INI")
Use with CXTPResourceImages::SetHandle(), specifies \ \ \ \ Visual Studio 2019 Light settings file.
#define | xtpIniVisualStudio2022Blue _T("VISUALSTUDIO2022BLUE_INI")
Use with CXTPResourceImages::SetHandle(), specifies \ \ \ \ Visual Studio 2022 Blue settings file.
#define | xtpIniVisualStudio2022BlueExtra _T("VISUALSTUDIO2022BLUEEXTRA_INI")
Use with CXTPResourceImages::SetHandle(), \ \ \ \ specifies Visual Studio 2022 Blue Extra settings \ \ \ \ file.
#define | xtpIniVisualStudio2022Dark _T("VISUALSTUDIO2022DARK_INI")
Use with CXTPResourceImages::SetHandle(), specifies \ \ \ \ Visual Studio 2022 Dark settings file.
#define | xtpIniVisualStudio2022Light _T("VISUALSTUDIO2022LIGHT_INI")
Use with CXTPResourceImages::SetHandle(), specifies \ \ \ \ Visual Studio 2022 Light settings file.
#define | xtpIniWindows7Blue _T("WINDOWS7BLUE_INI")
Use with CXTPResourceImages::SetHandle(), specifies Windows 7 \ \ \ \ Blue settings file.
#define | xtpIniWindows10Light _T("WINDOWS10LIGHT_INI")
Use with CXTPResourceImages::SetHandle(), specifies Windows \ \ \ \ 10 Light settings file.
#define | xtpIniWindows10Dark _T("WINDOWS10DARK_INI")
Use with CXTPResourceImages::SetHandle(), specifies Windows \ \ \ \ 10 Dark settings file.
#define | xtpIniWindows11Light _T("WINDOWS11LIGHT_INI")
Use with CXTPResourceImages::SetHandle(), specifies Windows \ \ \ \ 11 Light settings file.
#define | xtpIniWindows11Dark _T("WINDOWS11DARK_INI")
Use with CXTPResourceImages::SetHandle(), specifies Windows \ \ \ \ 11 Dark settings file.

Functions

_XTP_EXT_CLASS CXTPResourceImages *AFX_CDECL | XTPResourceImages ()
Call to access members of the CXTPResourceImages class.
_XTP_EXT_CLASS CXTPResourceImage *AFX_CDECL | XTPLoadImage (LPCTSTR lpszImageFile)
Call to access members of the CXTPResourceImage class.
_XTP_EXT_CLASS COLORREF AFX_CDECL | XTPIniColor (LPCTSTR lpszSection, LPCTSTR lpszKey, COLORREF clrDef)
Call to get the color value specified by lpszKey from the current theme.
_XTP_EXT_CLASS int AFX_CDECL | XTPIniInt (LPCTSTR lpszSection, LPCTSTR lpszKey, int nDef)
Call to get the int value specified by lpszKey from the current theme.
_XTP_EXT_CLASS CRect AFX_CDECL | XTPIniRect (LPCTSTR lpszSection, LPCTSTR lpszKey, CRect rcDef)
Call to get the CRect value specified by lpszKey from the current theme.
_XTP_EXT_CLASS CSize AFX_CDECL | XTPIniSize (LPCTSTR lpszSection, LPCTSTR lpszKey, CSize szDef)
Call to get the CSize value specified by lpszKey from the current theme.
_XTP_EXT_CLASS CString AFX_CDECL | XTPIniString (LPCTSTR lpszSection, LPCTSTR lpszKey, LPCTSTR lpszDef)
Call to get the CString value specified by lpszKey from the current theme.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Macro Definition Documentation

◆ xtpIniOffice2016AccessColorful

#define xtpIniOffice2016AccessColorful _T("OFFICE2016ACCESSCOLORFUL_INI")

Use with CXTPResourceImages::SetHandle(), \ \ \ \ specifies Office 2016 Access Colorful settings file.

\ \ \ \ \ \ \ \ \ \

◆ xtpIniOffice2016PublisherBlack

#define xtpIniOffice2016PublisherBlack _T("OFFICE2016PUBLISHERBLACK_INI")

Use with CXTPResourceImages::SetHandle(), \ \ \ \ specifies Office 2016 Publisher Black settings file.

\ \ \ \ \ \ \ \ \ \

◆ xtpIniOffice2016PublisherWhite

#define xtpIniOffice2016PublisherWhite _T("OFFICE2016PUBLISHERWHITE_INI")

Use with CXTPResourceImages::SetHandle(), \ \ \ \ specifies Office 2016 Publisher White settings file.

\ \ \ \ \ \ \ \ \ \

Function Documentation

◆ XTPIniColor()

_XTP_EXT_CLASS COLORREF AFX_CDECL XTPIniColor | ( | LPCTSTR | lpszSection,
 |  | LPCTSTR | lpszKey,
 |  | COLORREF | clrDef )

Call to get the color value specified by lpszKey from the current theme.

Parameters
lpszSection | Name of the section in the theme INI file.
lpszKey | Name of the value that defines the specified value.
clrDef | Default value returned if lpszKey was not found.
Returns
A value representing the color defined by lpszKey.

◆ XTPIniInt()

_XTP_EXT_CLASS int AFX_CDECL XTPIniInt | ( | LPCTSTR | lpszSection,
 |  | LPCTSTR | lpszKey,
 |  | int | nDef )

Call to get the int value specified by lpszKey from the current theme.

Parameters
lpszSection | Name of the section in the theme INI file.
lpszKey | Name of the value that defines the specified value.
nDef | Default value returned if lpszKey was not found.
Returns
A value representing the int defined by lpszKey.

◆ XTPIniRect()

_XTP_EXT_CLASS CRect AFX_CDECL XTPIniRect | ( | LPCTSTR | lpszSection,
 |  | LPCTSTR | lpszKey,
 |  | CRect | rcDef )

Call to get the CRect value specified by lpszKey from the current theme.

Parameters
lpszSection | Name of the section in the theme INI file.
lpszKey | Name of the value that defines the specified value.
rcDef | Default value returned if lpszKey was not found.
Returns
A value representing the CRect defined by lpszKey.

◆ XTPIniSize()

_XTP_EXT_CLASS CSize AFX_CDECL XTPIniSize | ( | LPCTSTR | lpszSection,
 |  | LPCTSTR | lpszKey,
 |  | CSize | szDef )

Call to get the CSize value specified by lpszKey from the current theme.

Parameters
lpszSection | Name of the section in the theme INI file.
lpszKey | Name of the value that defines the specified value.
szDef | Default value returned if lpszKey was not found.
Returns
A value representing the CSize defined by lpszKey.

◆ XTPIniString()

_XTP_EXT_CLASS CString AFX_CDECL XTPIniString | ( | LPCTSTR | lpszSection,
 |  | LPCTSTR | lpszKey,
 |  | LPCTSTR | lpszDef )

Call to get the CString value specified by lpszKey from the current theme.

Parameters
lpszSection | Name of the section in the theme INI file.
lpszKey | Name of the value that defines the specified value.
lpszDef | Default value returned if lpszKey was not found.
Returns
A value representing the CString defined by lpszKey.

◆ XTPLoadImage()

_XTP_EXT_CLASS CXTPResourceImage *AFX_CDECL XTPLoadImage ( LPCTSTR lpszImageFile )

Call to access members of the CXTPResourceImage class.

Parameters
lpszImageFile Name of the image file to load specified in the theme INI.
Returns
Returns the a pointer to the single instance of the CXTPResourceImage class.

◆ XTPResourceImages()

_XTP_EXT_CLASS CXTPResourceImages *AFX_CDECL XTPResourceImages ( )

Call to access members of the CXTPResourceImages class.

Returns
Returns the a pointer to the single instance of the CXTPResourceImages class.


Toolkit Pro: XTPResourceImageList.h File Reference

  • Source
  • Common
XTPResourceImageList.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPResourceManager.h File Reference

  • Source
  • Common
Classes | Functions
XTPResourceManager.h File Reference

Go to the source code of this file.

Classes

struct | XTP_RESOURCEMANAGER_LANGINFO
Standalone structure used to manage Language Info. More...
class | CXTPResourceManager
Standalone class used to managed toolkit resources. More...
class | CXTPResourceManager::CManageState
CManageState is used internally by the toolkit to switch module states. More...
class | CXTPResourceManagerXML
Class used to managed toolkit resources from an XML file. More...

Functions

AFX_INLINE HMODULE | XTPGetInstanceHandle ()
Call this member to safely return an instance handle of the current application.
_XTP_EXT_CLASS CXTPResourceManager *AFX_CDECL | XTPResourceManager ()
Call this function to access CXTPResourceManager members.
_XTP_EXT_CLASS LPCTSTR AFX_CDECL | XTPGetDefaultResourceTypeFromPath (LPCTSTR lpszPath)
Obtains a default resource type name depending on the file extension specified by the full path to the resource.
_XTP_EXT_CLASS CString AFX_CDECL | XTPFindResourceType (HMODULE hModule, LPCTSTR lpszName)
Tries to find a resource type name in a provided module by looking up through all resource directories for a default culture.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Function Documentation

◆ XTPFindResourceType()

_XTP_EXT_CLASS CString AFX_CDECL XTPFindResourceType | ( | HMODULE | hModule,
 |  | LPCTSTR | lpszName )

Tries to find a resource type name in a provided module by looking up through all resource directories for a default culture.

The first matching resource type is then returned.

Parameters
hModule | Module handle in which resource lookup should be done.
lpszName | Resource name or INT-resource value to find type name for.
Returns
Resource type name for the first match for the name provided, or an empty string if no resource type is found.

◆ XTPGetDefaultResourceTypeFromPath()

_XTP_EXT_CLASS LPCTSTR AFX_CDECL XTPGetDefaultResourceTypeFromPath ( LPCTSTR lpszPath )

Obtains a default resource type name depending on the file extension specified by the full path to the resource.

Parameters
lpszPath Full path to the resource.
Returns
A pointer to a string or integer resource that indicates a default resource type for the resource specified, or NULL if no association is found.

◆ XTPGetInstanceHandle()

AFX_INLINE HMODULE XTPGetInstanceHandle ( )

Call this member to safely return an instance handle of the current application.

Returns
An HINSTANCE to the current instance of the application if available. Otherwise returns a handle to the file used to create the calling process (.exe file).

◆ XTPResourceManager()

_XTP_EXT_CLASS CXTPResourceManager *AFX_CDECL XTPResourceManager ( )

Call this function to access CXTPResourceManager members.

Since this class is designed as a single instance object, you can only access version info through this method. You cannot directly instantiate an object of type CXTPResourceManager.

Example:

XTPResourceManager()->LoadString(&m_strNoFieldsAvailable,
XTP_IDS_GRID_NOFIELDSAVAILABLE);
Returns
A global resource manager object pointer.


Toolkit Pro: XTPRichRender.h File Reference

  • Source
  • Common
XTPRichRender.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPSingleton.h File Reference

  • Source
  • Common
Classes
XTPSingleton.h File Reference

Go to the source code of this file.

Classes

class | CXTPSingletonPointer
Implements Singleton design pattern for a pointer of unspecified type that is to be allocated, created and destroyed by a client. More...
class | CXTPSingletonDependencies< Singleton1, Singleton2, Singleton3, Singleton4, Singleton5, Singleton6, Singleton7, Singleton8, Singleton9, Singleton10 >
Describes the list of up to 10 optional singleton dependencies. More...
class | CXTPSingleton< T, Dependencies >
Implements Singleton design pattern. More...
class | CXTPSingletonBase< Derived, Parent >
Implements Singleton design pattern for a derived class with possibility of providing a parent class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPSmartPtrInternalT.h File Reference

  • Source
  • Common
Classes | Macros
XTPSmartPtrInternalT.h File Reference

Go to the source code of this file.

Classes

class | CXTPSmartPtrInternalT< _TObject >
class | CXTPInternalCollectionT< _TObject >
class | CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE >
This class represents a simple array of typed elements. More...

Macros

#define | XTP_DEFINE_SMART_PTR_INTERNAL(ClassName)
Define smart pointer for the specified class as ClassNamePtr.
#define | XTP_DEFINE_SMART_PTR_ARRAY_INTERNAL(ClassName)
Define smart pointers array for the specified class as ClassNamePtrArray.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Macro Definition Documentation

◆ XTP_DEFINE_SMART_PTR_ARRAY_INTERNAL

#define XTP_DEFINE_SMART_PTR_ARRAY_INTERNAL ( ClassName )
Value:
typedef CXTPInternalCollectionT<ClassName> ClassName##PtrArray; \
typedef CXTPSmartPtrInternalT<ClassName> ClassName##PtrArrayPtr;
CXTPInternalCollectionT
Definition XTPSmartPtrInternalT.h:387
CXTPSmartPtrInternalT
Definition XTPSmartPtrInternalT.h:72

Define smart pointers array for the specified class as ClassNamePtrArray.

CXTPInternalCollectionT is used for this purpose. Also define smart pointer for array as ClassNamePtrArrayPtr.

Parameters
ClassName Name of the class used to define the array of smart pointers.

◆ XTP_DEFINE_SMART_PTR_INTERNAL

#define XTP_DEFINE_SMART_PTR_INTERNAL ( ClassName )
Value:
typedef CXTPSmartPtrInternalT<ClassName> ClassName##Ptr;

Define smart pointer for the specified class as ClassNamePtr.

CXTPSmartPtrInternalT is used for this purpose. For example XTP_DEFINE_SMART_PTR_INTERNAL(CXTPCmdTarget) will be replaced with typedef CXTPSmartPtrInternalT<CXTPCmdTarget> CCmdTargetPtr;

Parameters
ClassName Name of the class used to define the smart pointer.


Toolkit Pro: XTPSynchro.h File Reference

  • Source
  • Common
Classes | Macros | Functions
XTPSynchro.h File Reference

Go to the source code of this file.

Classes

class | CXTPSimpleEvent
Implements no-named simple and lightweight synchronization event primitive. More...
class | CXTPSimpleCriticalSection
Implements simple and lightweight synchronization critical section primitive. More...
class | CXTPSimpleCriticalSection::CLock
A helper class for locking a scope or providing exception safe locking. More...
class | CXTPRWCriticalSection
Implements recursive read-write lock synchronization pattern. More...
class | CXTPRWCriticalSection::CSharedLock
A convenience class for obtaining shared lock for a scope. More...
class | CXTPRWCriticalSection::CExclusiveLock
A convenience class for obtaining exclusive lock for a scope. More...
class | CXTPAsyncGuard< Adaptee, RWLock >
A convenience class for guarding an adapted object reference by a RW-lock provided. More...
class | CXTPSynchronized
A base class for a synchronized object. More...

Macros

#define | XTP_RWCS_LOCK_SHARED_SCOPE(cs)
Obtains shared lock for the current scope.
#define | XTP_RWCS_LOCK_EXCLUSIVE_SCOPE(cs)
Obtains exclusive lock for the current scope.
#define | XTP_GUARD_SHARED_(Type, Object, Guard)
Creates a shared-lock guarded scope for an object specified.
#define | XTP_GUARD_SHARED_COND_(Type, Object, Guard, ConditionCounter)
Creates a shared-lock guarded scope for an object specified.
#define | XTP_GUARD_SHARED(Type, Object)
Creates a shared-lock guarded scope for an object specified.
#define | XTP_GUARD_SHARED_COND(Type, Object, ConditionCounter)
Creates a shared-lock guarded scope for an object specified.
#define | XTP_GUARD_SHARED_CONST_(Type, Object, Guard)
Creates a shared-lock guarded scope for an object specified.
#define | XTP_GUARD_SHARED_COND_CONST_(Type, Object, Guard, ConditionCounter)
Creates a shared-lock guarded scope for an object specified.
#define | XTP_GUARD_SHARED_CONST(Type, Object)
Creates a shared-lock guarded scope for an object specified.
#define | XTP_GUARD_SHARED_COND_CONST(Type, Object, ConditionCounter)
Creates a shared-lock guarded scope for an object specified.
#define | XTP_GUARD_EXCLUSIVE_(Type, Object, Guard)
Creates an exclusive-lock guarded scope for an object specified.
#define | XTP_GUARD_EXCLUSIVE_COND_(Type, Object, Guard, ConditionCounter)
Creates an exclusive-lock guarded scope for an object specified.
#define | XTP_GUARD_EXCLUSIVE(Type, Object)
Creates an exclusive-lock guarded scope for an object specified.
#define | XTP_GUARD_EXCLUSIVE_COND(Type, Object, ConditionCounter)
Creates an exclusive-lock guarded scope for an object specified.
#define | XTP_GUARD_EXCLUSIVE_CONST_(Type, Object, Guard)
Creates an exclusive-lock guarded scope for an object specified.
#define | XTP_GUARD_EXCLUSIVE_CONST_COND_(Type, Object, Guard, ConditionCounter)
Creates an exclusive-lock guarded scope for an object specified.
#define | XTP_GUARD_EXCLUSIVE_CONST(Type, Object)
Creates an exclusive-lock guarded scope for an object specified.
#define | XTP_GUARD_EXCLUSIVE_COND_CONST(Type, Object, ConditionCounter)
Creates an exclusive-lock guarded scope for an object specified.

Functions

template<class T >
AFX_INLINE CXTPAsyncGuard< T, CXTPRWCriticalSection::CSharedLock > | XTPAccessShared (T *pObject)
A convenience function for building a shared-lock guard for an object specified.
template<class T >
AFX_INLINE CXTPAsyncGuard< T, CXTPRWCriticalSection::CSharedLock > | XTPAccessShared (T *pObject, long &nConditionCounter)
A convenience function for building a shared-lock guard for an object specified.
template<class T >
AFX_INLINE CXTPAsyncGuard< T, CXTPRWCriticalSection::CExclusiveLock > | XTPAccessExclusive (T *pObject)
A convenience function for building an exclusive-lock guard for an object specified.
template<class T >
AFX_INLINE CXTPAsyncGuard< T, CXTPRWCriticalSection::CExclusiveLock > | XTPAccessExclusive (T *pObject, long &nConditionCounter)
A convenience function for building an exclusive-lock guard for an object specified.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Macro Definition Documentation

◆ XTP_GUARD_EXCLUSIVE

#define XTP_GUARD_EXCLUSIVE | ( | Type,
 |  | Object )
Value:
XTP_GUARD_EXCLUSIVE_(Type, Object, $__xtpGuard)
XTP_GUARD_EXCLUSIVE_
#define XTP_GUARD_EXCLUSIVE_(Type, Object, Guard)
Creates an exclusive-lock guarded scope for an object specified.
Definition XTPSynchro.h:795

Creates an exclusive-lock guarded scope for an object specified.

Parameters
Type | Object type
Object | Synchronized object pointer

◆ XTP_GUARD_EXCLUSIVE_

#define XTP_GUARD_EXCLUSIVE_ | ( | Type,
 |  | Object,
 |  | Guard )
Value:
XTP_BLOCKSTATEMENT(::XTPDetails::XTPAsyncGuardShortcut<Type>::XTPAsyncExclusiveGuard, \
Guard, XTPAccessExclusive(Object))
XTPAccessExclusive
AFX_INLINE CXTPAsyncGuard< T, CXTPRWCriticalSection::CExclusiveLock > XTPAccessExclusive(T *pObject)
A convenience function for building an exclusive-lock guard for an object specified.
Definition XTPSynchro.h:671

Creates an exclusive-lock guarded scope for an object specified.

Parameters
Type | Object type
Object | Synchronized object pointer
Guard | Guard variable name

◆ XTP_GUARD_EXCLUSIVE_COND

#define XTP_GUARD_EXCLUSIVE_COND | ( | Type,
 |  | Object,
 |  | ConditionCounter )
Value:
XTP_GUARD_EXCLUSIVE_COND_(Type, Object, $__xtpGuard, ConditionCounter)
XTP_GUARD_EXCLUSIVE_COND_
#define XTP_GUARD_EXCLUSIVE_COND_(Type, Object, Guard, ConditionCounter)
Creates an exclusive-lock guarded scope for an object specified.
Definition XTPSynchro.h:809

Creates an exclusive-lock guarded scope for an object specified.

Parameters
Type | Object type
Object | Synchronized object pointer
ConditionCounter | If zero, the guard will lock the critical section and increment the counter until the critical section is unlocked. Otherwise critical section does not get locked.

◆ XTP_GUARD_EXCLUSIVE_COND_

#define XTP_GUARD_EXCLUSIVE_COND_ | ( | Type,
 |  | Object,
 |  | Guard,
 |  | ConditionCounter )
Value:
XTP_BLOCKSTATEMENT(::XTPDetails::XTPAsyncGuardShortcut<Type>::XTPAsyncExclusiveGuard, \
Guard, XTPAccessExclusive(Object, ConditionCounter))

Creates an exclusive-lock guarded scope for an object specified.

Parameters
Type | Object type
Object | Synchronized object pointer
Guard | Guard variable name
ConditionCounter | If zero, the guard will lock the critical section and increment the counter until the critical section is unlocked. Otherwise critical section does not get locked.

◆ XTP_GUARD_EXCLUSIVE_COND_CONST

#define XTP_GUARD_EXCLUSIVE_COND_CONST | ( | Type,
 |  | Object,
 |  | ConditionCounter )
Value:
XTP_GUARD_EXCLUSIVE_COND_CONST_(Type, Object, $__xtpGuard, ConditionCounter)

Creates an exclusive-lock guarded scope for an object specified.

Parameters
Type | Object type
Object | Synchronized object pointer
ConditionCounter | If zero, the guard will lock the critical section and increment the counter until the critical section is unlocked. Otherwise critical section does not get locked.

◆ XTP_GUARD_EXCLUSIVE_CONST

#define XTP_GUARD_EXCLUSIVE_CONST | ( | Type,
 |  | Object )
Value:
XTP_GUARD_EXCLUSIVE_CONST_(Type, Object, $__xtpGuard)
XTP_GUARD_EXCLUSIVE_CONST_
#define XTP_GUARD_EXCLUSIVE_CONST_(Type, Object, Guard)
Creates an exclusive-lock guarded scope for an object specified.
Definition XTPSynchro.h:840

Creates an exclusive-lock guarded scope for an object specified.

Parameters
Type | Object type
Object | Synchronized object pointer

◆ XTP_GUARD_EXCLUSIVE_CONST_

#define XTP_GUARD_EXCLUSIVE_CONST_ | ( | Type,
 |  | Object,
 |  | Guard )
Value:
XTP_BLOCKSTATEMENT(::XTPDetails::XTPAsyncGuardShortcut<Type>::XTPAsyncConstExclusiveGuard, \
Guard, XTPAccessExclusive(Object))

Creates an exclusive-lock guarded scope for an object specified.

Parameters
Type | Object type
Object | Synchronized object pointer
Guard | Guard variable name

◆ XTP_GUARD_EXCLUSIVE_CONST_COND_

#define XTP_GUARD_EXCLUSIVE_CONST_COND_ | ( | Type,
 |  | Object,
 |  | Guard,
 |  | ConditionCounter )
Value:
XTP_BLOCKSTATEMENT(::XTPDetails::XTPAsyncGuardShortcut<Type>::XTPAsyncConstExclusiveGuard, \
Guard, XTPAccessExclusive(Object, ConditionCounter))

Creates an exclusive-lock guarded scope for an object specified.

Parameters
Type | Object type
Object | Synchronized object pointer
Guard | Guard variable name
ConditionCounter | If zero, the guard will lock the critical section and increment the counter until the critical section is unlocked. Otherwise critical section does not get locked.

◆ XTP_GUARD_SHARED

#define XTP_GUARD_SHARED | ( | Type,
 |  | Object )
Value:
XTP_GUARD_SHARED_(Type, Object, $__xtpGuard)
XTP_GUARD_SHARED_
#define XTP_GUARD_SHARED_(Type, Object, Guard)
Creates a shared-lock guarded scope for an object specified.
Definition XTPSynchro.h:705

Creates a shared-lock guarded scope for an object specified.

Parameters
Type | Object type
Object | Synchronized object pointer

◆ XTP_GUARD_SHARED_

#define XTP_GUARD_SHARED_ | ( | Type,
 |  | Object,
 |  | Guard )
Value:
XTP_BLOCKSTATEMENT(::XTPDetails::XTPAsyncGuardShortcut<Type>::XTPAsyncSharedGuard, Guard, \
XTPAccessShared(Object))
XTPAccessShared
AFX_INLINE CXTPAsyncGuard< T, CXTPRWCriticalSection::CSharedLock > XTPAccessShared(T *pObject)
A convenience function for building a shared-lock guard for an object specified.
Definition XTPSynchro.h:635

Creates a shared-lock guarded scope for an object specified.

Parameters
Type | Object type
Object | Synchronized object pointer
Guard | Guard variable name

◆ XTP_GUARD_SHARED_COND

#define XTP_GUARD_SHARED_COND | ( | Type,
 |  | Object,
 |  | ConditionCounter )
Value:
XTP_GUARD_SHARED_COND_(Type, Object, $__xtpGuard, ConditionCounter)
XTP_GUARD_SHARED_COND_
#define XTP_GUARD_SHARED_COND_(Type, Object, Guard, ConditionCounter)
Creates a shared-lock guarded scope for an object specified.
Definition XTPSynchro.h:719

Creates a shared-lock guarded scope for an object specified.

Parameters
Type | Object type
Object | Synchronized object pointer
ConditionCounter | If zero, the guard will lock the critical section and increment the counter until the critical section is unlocked. Otherwise critical section does not get locked.

◆ XTP_GUARD_SHARED_COND_

#define XTP_GUARD_SHARED_COND_ | ( | Type,
 |  | Object,
 |  | Guard,
 |  | ConditionCounter )
Value:
XTP_BLOCKSTATEMENT(::XTPDetails::XTPAsyncGuardShortcut<Type>::XTPAsyncSharedGuard, Guard, \
XTPAccessShared(Object, ConditionCounter))

Creates a shared-lock guarded scope for an object specified.

Parameters
Type | Object type
Object | Synchronized object pointer
Guard | Guard variable name
ConditionCounter | If zero, the guard will lock the critical section and increment the counter until the critical section is unlocked. Otherwise critical section does not get locked.

◆ XTP_GUARD_SHARED_COND_CONST

#define XTP_GUARD_SHARED_COND_CONST | ( | Type,
 |  | Object,
 |  | ConditionCounter )
Value:
XTP_GUARD_SHARED_COND_CONST_(Type, Object, $__xtpGuard, ConditionCounter)
XTP_GUARD_SHARED_COND_CONST_
#define XTP_GUARD_SHARED_COND_CONST_(Type, Object, Guard, ConditionCounter)
Creates a shared-lock guarded scope for an object specified.
Definition XTPSynchro.h:764

Creates a shared-lock guarded scope for an object specified.

Parameters
Type | Object type
Object | Synchronized object pointer
ConditionCounter | If zero, the guard will lock the critical section and increment the counter until the critical section is unlocked. Otherwise critical section does not get locked.

◆ XTP_GUARD_SHARED_COND_CONST_

#define XTP_GUARD_SHARED_COND_CONST_ | ( | Type,
 |  | Object,
 |  | Guard,
 |  | ConditionCounter )
Value:
XTP_BLOCKSTATEMENT(::XTPDetails::XTPAsyncGuardShortcut<Type>::XTPAsyncConstSharedGuard, \
Guard, XTPAccessShared(Object, ConditionCounter))

Creates a shared-lock guarded scope for an object specified.

Parameters
Type | Object type
Object | Synchronized object pointer
Guard | Guard variable name
ConditionCounter | If zero, the guard will lock the critical section and increment the counter until the critical section is unlocked. Otherwise critical section does not get locked.

◆ XTP_GUARD_SHARED_CONST

#define XTP_GUARD_SHARED_CONST | ( | Type,
 |  | Object )
Value:
XTP_GUARD_SHARED_CONST_(Type, Object, $__xtpGuard)
XTP_GUARD_SHARED_CONST_
#define XTP_GUARD_SHARED_CONST_(Type, Object, Guard)
Creates a shared-lock guarded scope for an object specified.
Definition XTPSynchro.h:750

Creates a shared-lock guarded scope for an object specified.

Parameters
Type | Object type
Object | Synchronized object pointer

◆ XTP_GUARD_SHARED_CONST_

#define XTP_GUARD_SHARED_CONST_ | ( | Type,
 |  | Object,
 |  | Guard )
Value:
XTP_BLOCKSTATEMENT(::XTPDetails::XTPAsyncGuardShortcut<Type>::XTPAsyncConstSharedGuard, \
Guard, XTPAccessShared(Object))

Creates a shared-lock guarded scope for an object specified.

Parameters
Type | Object type
Object | Synchronized object pointer
Guard | Guard variable name

◆ XTP_RWCS_LOCK_EXCLUSIVE_SCOPE

#define XTP_RWCS_LOCK_EXCLUSIVE_SCOPE ( cs )
Value:
CXTPRWCriticalSection::CExclusiveLock $__xtpRWCSExclusiveLock(cs)
CXTPRWCriticalSection::CExclusiveLock
A convenience class for obtaining exclusive lock for a scope.
Definition XTPSynchro.h:351

Obtains exclusive lock for the current scope.

Parameters
cs Critical section for which to obtain exclusive lock.

◆ XTP_RWCS_LOCK_SHARED_SCOPE

#define XTP_RWCS_LOCK_SHARED_SCOPE ( cs )
Value:
CXTPRWCriticalSection::CSharedLock $__xtpRWCSSharedLock(cs)
CXTPRWCriticalSection::CSharedLock
A convenience class for obtaining shared lock for a scope.
Definition XTPSynchro.h:301

Obtains shared lock for the current scope.

Parameters
cs Critical section for which to obtain shared lock.

Function Documentation

◆ XTPAccessExclusive() [1/2]

template<class T >
AFX_INLINE CXTPAsyncGuard< T, CXTPRWCriticalSection::CExclusiveLock > XTPAccessExclusive ( T * pObject )

A convenience function for building an exclusive-lock guard for an object specified.

Parameters
pObject A pointer to a synchronized object to be guarded.
Returns
An exclusive-lock guard for an object provided.

◆ XTPAccessExclusive() [2/2]

template<class T >
AFX_INLINE CXTPAsyncGuard< T, CXTPRWCriticalSection::CExclusiveLock > XTPAccessExclusive | ( | T * | pObject,
 |  | long & | nConditionCounter )

A convenience function for building an exclusive-lock guard for an object specified.

Parameters
pObject | A pointer to a synchronized object to be guarded.
nConditionCounter | If zero, the guard will lock the critical section and increment the counter until the critical section is unlocked. Otherwise critical section does not get locked.
Returns
An exclusive-lock guard for an object provided.

◆ XTPAccessShared() [1/2]

template<class T >
AFX_INLINE CXTPAsyncGuard< T, CXTPRWCriticalSection::CSharedLock > XTPAccessShared ( T * pObject )

A convenience function for building a shared-lock guard for an object specified.

Parameters
pObject A pointer to a synchronized object to be guarded.
Returns
A shared-lock guard for an object provided.

◆ XTPAccessShared() [2/2]

template<class T >
AFX_INLINE CXTPAsyncGuard< T, CXTPRWCriticalSection::CSharedLock > XTPAccessShared | ( | T * | pObject,
 |  | long & | nConditionCounter )

A convenience function for building a shared-lock guard for an object specified.

Parameters
pObject | A pointer to a synchronized object to be guarded.
nConditionCounter | If zero, the guard will lock the critical section and increment the counter until the critical section is unlocked. Otherwise critical section does not get locked.
Returns
A shared-lock guard for an object provided.


Toolkit Pro: XTPSystemHelpers.h File Reference

  • Source
  • Common
Classes | Macros | Enumerations | Functions
XTPSystemHelpers.h File Reference

Go to the source code of this file.

Classes

class | CXTPModuleHandle
CXTPModuleHandle class is helper for LoadLibray/GetModuleHandle methods. More...
class | CXTPSystemVersion
CXTPSystemVersion is used to get the current Windows OS version. More...
class | CXTPMultiMonitor
MultiMonitor API wrapper class. More...
class | CXTPCriticalSection
Critical Section Wrapper. More...
class | CXTPLockGuard
Critical Sections Lock/Unlock helper. More...
class | CXTPSoundManager
CXTPSoundManager is a standalone class. More...
class | CXTPZipMemFile
Zipped memory file. More...
struct | XTP_URI
Parse URI information. More...
struct | XTP_URI_DEFAULTS
Default URI values. More...
class | CXTPThreadLocal< T >
Implements thread local variable adapter. More...
class | CXTPExcludedMemberPadding< Type >
The CXTPExcludedMemberPadding type is used for declaring padding members for the members that were excluded by conditional compilation in order to preserve the layout of the compiled classes. More...
class | CXTPComInitializer
Initializes COM and increments and holds COM initialization reference counter for the thread where constructed. More...
class | CXTPSubscriptionList< Observable, Observer >
Holds a list of observable objects to which an oberser is subscribed. More...
class | CXTPObservable< Owner, Observer >
Provides a basic implementation of the Observable design pattern. More...
class | CXTPNonClientMetrics
CXTPNonClientMetrics is a self-initializing NONCLIENTMETRICS derived class. More...
class | CXTPToolhelpApi
A wrapper around the Toolhelp32 API. More...
class | CXTPGlobalAtom
A helper class for handling a global atom primitive. More...

Macros

#define | XTP_INVALID_TLS_SLOT (~DWORD_PTR(0))
Defines an invalid TLS slot value specific to XTP TLS pool.
#define | XTP_DYNAMIC_DOWNCAST_REMOTE(className, pObject)
Provides a handy way to cast a pointer to a pointer to a class object while checking to see if the cast is legal.

Enumerations

enum | XTPSoundManagerState { xtpSoundNone , xtpSoundMenuCommand , xtpSoundMenuPopup }
Enumeration used to play system sound. More...
enum | XTPUriType { xtpUriFile , xtpUriRes }
URI type identifier. More...
enum | XTPWindowClass { xtpWindowClassRichEdit }
Defines known global window classes IDs. More...
enum | XTPWindowClassVersionSelectionVerb { xtpWindowClassVersionExact , xtpWindowClassVersionAtLeast , xtpWindowClassVersionHighest }
Defines rules of how window class version has to be selected. More...
enum XTPRichEditWindowClassVersion {
xtpRichEditWindowClassVersion10 , xtpRichEditWindowClassVersion20 , xtpRichEditWindowClassVersion30 , xtpRichEditWindowClassVersion31 ,
xtpRichEditWindowClassVersion40 , xtpRichEditWindowClassVersion41 , xtpRichEditWindowClassVersion50 , xtpRichEditWindowClassVersion60 ,
xtpRichEditWindowClassVersion70 , xtpRichEditWindowClassDefault = xtpRichEditWindowClassVersion20
}
Defines supported RichEdit versions. More...
enum XTPComInit {
xtpComInitInvalid = -1 , xtpComInitAppDefault , xtpComInitSTA = 0x1 , xtpComInitMTA = 0x2 ,
xtpComInitDisableOle1DDE = 0x4 , xtpComInitSpeedOverMemory = 0x8 , xtpComInitOle = 0x10 , xtpComInitAfxOle = 0x20 ,
xtpComInitModuleAfxOle = 0x40 , xtpComInitUserDefined = 0x10000000
}
Defines a set of COM/OLE initialization methods. More...

Functions

_XTP_EXT_CLASS CXTPSystemVersion *AFXAPI | XTPSystemVersion ()
The XTPSystemVersion function is used for access to the CXTPSystemVersion class.
_XTP_EXT_CLASS CXTPMultiMonitor *AFX_CDECL | XTPMultiMonitor ()
Call this function to access CXTPMultiMonitor members.
_XTP_EXT_CLASS CXTPSoundManager *AFX_CDECL | XTPSoundManager ()
Call this function to access CXTPSoundManager members.
_XTP_EXT_CLASS HRESULT AFX_CDECL | XTPParseUri (LPCTSTR lpszUri, XTP_URI *pUri, const XTP_URI_DEFAULTS *pDefaults=NULL)
Parses URI, Sample valid file URIs:
_XTP_EXT_CLASS HRESULT AFX_CDECL | XTPCreateReadOnlyStreamOnUri (const XTP_URI *pUri, IStream **ppStream)
Creates a read-only stream on object identified by the specified URI.
_XTP_EXT_CLASS HRESULT AFX_CDECL | XTPCreateReadOnlyStreamOnUri (LPCTSTR lpszUri, IStream **ppStream, const XTP_URI_DEFAULTS *pDefaults=NULL)
Creates a read-only stream on object identified by the specified URI.
_XTP_EXT_CLASS BOOL AFX_CDECL | XTPLoadUnicodeText (const void *pRawData, UINT cbRawData, LPWSTR lpUnicodeText, UINT *pchUnicodeText)
Attempts to load a Unicode text from a binary buffer.
_XTP_EXT_CLASS BOOL AFX_CDECL | XTPLoadText (const void *pRawData, UINT cbRawData, LPTSTR lpText, UINT *pchText)
Attempts to load text from a binary buffer.
_XTP_EXT_CLASS BOOL AFX_CDECL | XTPLoadText (const void *pRawData, UINT cbRawData, CString &strText)
Attempts to load text from a binary buffer.
_XTP_EXT_CLASS BOOL AFX_CDECL | XTPLoadFileText (LPCTSTR lpPath, CString &strText)
Attempts to load text from a specified file.
_XTP_EXT_CLASS HRESULT AFX_CDECL | XTPCreateReadOnlyMemoryStream (const void *pData, UINT cbData, BOOL bClone, IStream **ppStream)
Creates a read-only stream on a block of memory.
_XTP_EXT_CLASS HRESULT AFX_CDECL | XTPCreateFileStream (LPCTSTR lpPath, DWORD grfMode, IStream **ppStream)
Creates a stream on the file specified.
_XTP_EXT_CLASS HRESULT AFX_CDECL | XTPCreateReadOnlyFileStream (LPCTSTR lpPath, IStream **ppStream)
Creates a read-only stream on the file specified.
_XTP_EXT_CLASS HRESULT AFX_CDECL | XTPCreateReadOnlyResourceStream (HMODULE hModule, LPCTSTR lpResource, LPCTSTR lpResourceType, BOOL bClone, IStream **ppStream)
Creates a read-only stream on a resource.
_XTP_EXT_CLASS HRESULT AFX_CDECL | XTPReadStreamData (IStream *pStream, LPVOID &pData, SIZE_T &cbData, ULONG cbSizeNeeded=ULONG_MAX, STREAM_SEEK nSeek=STREAM_SEEK_CUR, LONG nOffset=0)
Reads data from the specified stream starting at the specified position.
_XTP_EXT_CLASS void AFX_CDECL | XTPReleaseReadStreamData (LPVOID pData)
Releases a memory buffer allocated by XTPReadStreamData.
_XTP_EXT_CLASS DWORD_PTR AFX_CDECL | XTPTlsAllocate (PVOID pValue=NULL)
Allocates a new slot in XTP TLS pool and assigns an initial value if provided.
_XTP_EXT_CLASS BOOL AFX_CDECL | XTPTlsSetValue (DWORD_PTR dwSlot, PVOID pValue)
Sets a new value to the previously allocated XTP TLS slot.
_XTP_EXT_CLASS PVOID AFX_CDECL | XTPTlsGetValue (DWORD_PTR dwSlot)
Obtains an assigned XTP TLS slot value.
_XTP_EXT_CLASS BOOL AFX_CDECL | XTPTlsFree (DWORD_PTR dwSlot)
Releases a previously assigned XTP TLS slot.
_XTP_EXT_CLASS BOOL AFX_CDECL | XTPLoadWindowClass (XTPWindowClass nClass, XTPWindowClassVersionSelectionVerb nVerb, int *pnVersion, LPWNDCLASS pWndClass=NULL)
Loads and verifies a window class module of a specified version according to version selection rule.
AFX_INLINE BOOL AFX_CDECL | XTPLoadWindowClass (XTPWindowClass nClass, XTPWindowClassVersionSelectionVerb nVerb, int nVersion, LPWNDCLASS pWndClass=NULL)
Loads and verifies a window class module of a specified version according to version selection rule.
_XTP_EXT_CLASS BOOL AFX_CDECL | XTPIsDerivedFromRemote (const CRuntimeClass *pBaseClass, const CRuntimeClass *pClassThis)
Call this function to determine if the class specified by pClassThis is derived from the class specified in the pBaseClass parameter.
_XTP_EXT_CLASS BOOL AFX_CDECL | XTPIsKindOfRemote (const CRuntimeClass *pClass, const CObject *pObject)
Tests this object's relationship to a given class.
_XTP_EXT_CLASS CObject *AFX_CDECL | XTPDynamicDownCastRemote (CRuntimeClass *pClass, CObject *pObject)
Provides a handy way to cast a pointer to a pointer to a class object while checking to see if the cast is legal.
_XTP_EXT_CLASS BOOL AFX_CDECL | XTPVariantEqual (const VARIANT &v1, const VARIANT &v2)
Perform a shallow comparison of two variants.
_XTP_EXT_CLASS double | XTPParseDouble (LPCSTR pStr, int *pEndPos=NULL)
Attempts to parse a floating point value from the beginning of the provided string.
_XTP_EXT_CLASS double | XTPParseDouble (LPCWSTR pStr, int *pEndPos=NULL)

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Macro Definition Documentation

◆ XTP_DYNAMIC_DOWNCAST_REMOTE

#define XTP_DYNAMIC_DOWNCAST_REMOTE | ( | className,
 |  | pObject )
Value:
static_cast<className*>(XTPDynamicDownCastRemote(RUNTIME_CLASS(className), pObject))
XTPDynamicDownCastRemote
_XTP_EXT_CLASS CObject *AFX_CDECL XTPDynamicDownCastRemote(CRuntimeClass *pClass, CObject *pObject)
Provides a handy way to cast a pointer to a pointer to a class object while checking to see if the ca...

Provides a handy way to cast a pointer to a pointer to a class object while checking to see if the cast is legal.

Unlike DYNAMIC_DOWNCAST, this macro compares actual class information which allows using it for casting of the classes declared in different physical modules.

Parameters
className | Class name to which an object is to be casted.
pObject | Derived class object pointer.
Returns
If the object referenced by the pointer is a "kind of" the identified class, then the macro returns the appropriate pointer. If it is not a legal cast, then the macro returns NULL.
See also
XTPDynamicDownCastRemote,XTPIsKindOfRemote,XTPIsDerivedFromRemote

Enumeration Type Documentation

◆ XTPComInit

enum XTPComInit

Defines a set of COM/OLE initialization methods.

Enumerator
xtpComInitInvalid

Used internally.

xtpComInitAppDefault

If passed to CXTPWinApp constructor or to XTPInitialize then uses xtpComInitAfxOle, otherwise uses the previously used method for CXTPWinApp constructor or to XTPInitialize.

xtpComInitSTA

Causes extended COM initialization to be used.

Initializes the thread for apartment-threaded object concurrency. Must not be combined with xtpComInitMTA.

xtpComInitMTA

Causes extended COM initialization to be used.

Initializes the thread for multithreaded object concurrency. Must not be combined with xtpComInitSTA.

xtpComInitDisableOle1DDE

Causes extended COM initialization to be used.

Disables DDE for OLE1 support. Can be combined with xtpComInitSTA, xtpComInitMTA, xtpComInitAfxOle and xtpComInitModuleAfxOle.

xtpComInitSpeedOverMemory

Causes extended COM initialization to be used.

Increase memory usage in an attempt to increase performance. Can be combined with xtpComInitSTA, xtpComInitMTA, xtpComInitAfxOle and xtpComInitModuleAfxOle.

xtpComInitOle

Causes OLE initialization to be used.

Must not be combined with other flags.

xtpComInitAfxOle

Causes default AFX OLE initialization to be used for the main application thread, all other threads will initialized COM using xtpComInitSTA.

This is the default and preferred initialization method determined by xtpComInitAppDefault. Can be combined with xtpComInitDisableOle1DDE and xtpComInitSpeedOverMemory.

xtpComInitModuleAfxOle

Causes default AFX OLE initialization to be used during MFC extension DLL initialization.

Use of _AFXDLL macro is required. All threads started from the DLL will initialized COM using xtpComInitSTA. This is the default and preferred initialization method determined by xtpComInitAppDefault. Can be combined with xtpComInitDisableOle1DDE and xtpComInitSpeedOverMemory.

xtpComInitUserDefined

No COM/OLE initialization will be performed.

The user takes the whole responsibility of managing COM/OLE initialization and accepts the risks of potential incompatibilities with the framework. Must not be combined with other flags.

◆ XTPRichEditWindowClassVersion

enum XTPRichEditWindowClassVersion

Defines supported RichEdit versions.

Enumerator
xtpRichEditWindowClassVersion10 | Specifies RichEdit control version 10.
xtpRichEditWindowClassVersion20 | Specifies RichEdit control version 20.
xtpRichEditWindowClassVersion30 | Specifies RichEdit control version 30.
xtpRichEditWindowClassVersion31 | Specifies RichEdit control version 31.
xtpRichEditWindowClassVersion40 | Specifies RichEdit control version 40.
xtpRichEditWindowClassVersion41 | Specifies RichEdit control version 41.
xtpRichEditWindowClassVersion50 | Specifies RichEdit control version 50.
xtpRichEditWindowClassVersion60 | Specifies RichEdit control version 60.
xtpRichEditWindowClassVersion70 | Specifies RichEdit control version 70.
xtpRichEditWindowClassDefault | Specifies RichEdit control version 20.

◆ XTPSoundManagerState

enum XTPSoundManagerState

Enumeration used to play system sound.

Example:

XTPSoundManager()->PlaySystemSound(xtpSoundMenuCommand);
See also
CXTPSoundManager, xtpSoundNone, xtpSoundMenuCommand, xtpSoundMenuPopup
Enumerator
xtpSoundNone | No Sound (default)
xtpSoundMenuCommand | Menu command system sound.
xtpSoundMenuPopup | Menu pop-up system sound

◆ XTPUriType

enum XTPUriType

URI type identifier.

Enumerator
xtpUriFile | Local file URI.
xtpUriRes | Resource in a local file URI.

◆ XTPWindowClass

enum XTPWindowClass

Defines known global window classes IDs.

One ID represents a whole family of the control including all its verions. Should not be confused with a particular window class.

Enumerator
xtpWindowClassRichEdit

RichEdit window class family.

◆ XTPWindowClassVersionSelectionVerb

enum XTPWindowClassVersionSelectionVerb

Defines rules of how window class version has to be selected.

Enumerator
xtpWindowClassVersionExact | The window class version is matched exactly.
xtpWindowClassVersionAtLeast | At least the specified window class version should be available. The largest available is selected in result.
xtpWindowClassVersionHighest | The largest available is selected.

Function Documentation

◆ XTPCreateFileStream()

_XTP_EXT_CLASS HRESULT AFX_CDECL XTPCreateFileStream | ( | LPCTSTR | lpPath,
 |  | DWORD | grfMode,
 |  | IStream ** | ppStream )

Creates a stream on the file specified.

Parameters
lpPath | File path.
grfMode | A combination of STGM flags from Windows SDK.
ppStream | Output pointer that receives stream pointer.
Returns
S_OK if successful, or a standard COM error code.

◆ XTPCreateReadOnlyFileStream()

_XTP_EXT_CLASS HRESULT AFX_CDECL XTPCreateReadOnlyFileStream | ( | LPCTSTR | lpPath,
 |  | IStream ** | ppStream )

Creates a read-only stream on the file specified.

Parameters
lpPath | File path.
ppStream | Output pointer that receives stream pointer.
Returns
S_OK if successful, or a standard COM error code.

◆ XTPCreateReadOnlyMemoryStream()

_XTP_EXT_CLASS HRESULT AFX_CDECL XTPCreateReadOnlyMemoryStream | ( | const void * | pData,
 |  | UINT | cbData,
 |  | BOOL | bClone,
 |  | IStream ** | ppStream )

Creates a read-only stream on a block of memory.

Parameters
pData | Pointer to the beginning of a memory block.
cbData | Memory block size in bytes.
bClone | If TRUE, the block will be cloned for exclusive stream use and released when the returned stream is destructed.
ppStream | Output pointer that receives stream pointer.
Returns
S_OK if successful, or a standard COM error code.

◆ XTPCreateReadOnlyResourceStream()

_XTP_EXT_CLASS HRESULT AFX_CDECL XTPCreateReadOnlyResourceStream | ( | HMODULE | hModule,
 |  | LPCTSTR | lpResource,
 |  | LPCTSTR | lpResourceType,
 |  | BOOL | bClone,
 |  | IStream ** | ppStream )

Creates a read-only stream on a resource.

Parameters
hModule | Module handle where to look for the resource specified.
lpResource | Resource name pointer or identifier.
lpResourceType | Resource type name pointer or identifier.
bClone | If TRUE, the block will be cloned for exclusive stream use and released when the returned stream is destructed.
ppStream | Output pointer that receives stream pointer.
Returns
S_OK if successful, or a standard COM error code.

◆ XTPCreateReadOnlyStreamOnUri() [1/2]

_XTP_EXT_CLASS HRESULT AFX_CDECL XTPCreateReadOnlyStreamOnUri | ( | const XTP_URI * | pUri,
 |  | IStream ** | ppStream )

Creates a read-only stream on object identified by the specified URI.

Parameters
pUri | Pointer to an object URI structure.
ppStream | Output pointer that receives stream pointer.
Returns
S_OK if successful, or a standard COM error code.

◆ XTPCreateReadOnlyStreamOnUri() [2/2]

_XTP_EXT_CLASS HRESULT AFX_CDECL XTPCreateReadOnlyStreamOnUri | ( | LPCTSTR | lpszUri,
 |  | IStream ** | ppStream,
 |  | const XTP_URI_DEFAULTS * | pDefaults = NULL )

Creates a read-only stream on object identified by the specified URI.

Parameters
lpszUri | Object URI string.
ppStream | Output pointer that receives stream pointer.
pDefaults | Optional pointer to default URI values.
Returns
S_OK if successful, or a standard COM error code.

◆ XTPDynamicDownCastRemote()

_XTP_EXT_CLASS CObject *AFX_CDECL XTPDynamicDownCastRemote | ( | CRuntimeClass * | pClass,
 |  | CObject * | pObject )

Provides a handy way to cast a pointer to a pointer to a class object while checking to see if the cast is legal.

Unlike AfxDynamicDowncast, this function compares actual class information which allows using it for casting of the classes declared in different physical modules.

Parameters
pClass | Class information pointer.
pObject | Derived class object pointer.
Returns
If the object referenced by the pointer is a "kind of" the identified class, then the function returns the appropriate pointer. If it is not a legal cast, then the function returns NULL.
See also
XTP_DYNAMIC_DOWNCAST_REMOTE,XTPIsKindOfRemote,XTPIsDerivedFromRemote

◆ XTPIsDerivedFromRemote()

_XTP_EXT_CLASS BOOL AFX_CDECL XTPIsDerivedFromRemote | ( | const CRuntimeClass * | pBaseClass,
 |  | const CRuntimeClass * | pClassThis )

Call this function to determine if the class specified by pClassThis is derived from the class specified in the pBaseClass parameter.

Unlike CRuntimeClass::IsDerivedFrom, this function compares actual class information which allows using it for comparison of the classes declared in different physical modules.

Parameters
pBaseClass | Base class information pointer.
pClassThis | Derived class information pointer.
Returns
TRUE if the derived class has the same base class as its parent.
See also
XTP_DYNAMIC_DOWNCAST_REMOTE,XTPDynamicDownCastRemote,XTPIsKindOfRemote

◆ XTPIsKindOfRemote()

_XTP_EXT_CLASS BOOL AFX_CDECL XTPIsKindOfRemote | ( | const CRuntimeClass * | pClass,
 |  | const CObject * | pObject )

Tests this object's relationship to a given class.

Unlike CObject::IsKindOf, this function compares actual class information which allows using it for comparison of the classes declared in different physical modules.

Parameters
pClass | Class information pointer.
pObject | Derived class object pointer.
Returns
TRUE if the object corresponds to the class, otherwise FALSE.
See also
XTP_DYNAMIC_DOWNCAST_REMOTE,XTPDynamicDownCastRemote,XTPIsDerivedFromRemote

◆ XTPLoadFileText()

_XTP_EXT_CLASS BOOL AFX_CDECL XTPLoadFileText | ( | LPCTSTR | lpPath,
 |  | CString & | strText )

Attempts to load text from a specified file.

Depending on the active charset the text will be converted from the source encoding into the active charset. Supported encodings: ANSI, UTF-8, Unicode.

Parameters
pRawData | Pointer to raw text data to load.
cbRawData | Size of raw text data in bytes.
strText | Upon successful execution contains loaded text data.
Returns
TRUE if the text is successully loaded from a file, FALSE otherwise.

◆ XTPLoadText() [1/2]

_XTP_EXT_CLASS BOOL AFX_CDECL XTPLoadText | ( | const void * | pRawData,
 |  | UINT | cbRawData,
 |  | CString & | strText )

Attempts to load text from a binary buffer.

Depending on the active charset the text will be converted from the source encoding into the active charset. Supported encodings: ANSI, UTF-8, Unicode.

Parameters
pRawData | Pointer to raw text data to load.
cbRawData | Size of raw text data in bytes.
strText | Upon successful execution contains loaded text data.
Returns
TRUE if the text is successully loaded from a binary buffer, FALSE otherwise.

◆ XTPLoadText() [2/2]

_XTP_EXT_CLASS BOOL AFX_CDECL XTPLoadText | ( | const void * | pRawData,
 |  | UINT | cbRawData,
 |  | LPTSTR | lpText,
 |  | UINT * | pchText )

Attempts to load text from a binary buffer.

Depending on the active charset the text will be converted from the source encoding into the active charset. Supported encodings: ANSI, UTF-8, Unicode.

Parameters
pRawData | Pointer to raw text data to load.
cbRawData | Size of raw text data in bytes.
lpText | Pointer to a buffer large enough to hold text after being converted to Unicode.
pchText | On input, contains number of TCHARs available in lpText buffer including terminating 0. On output, contains number of TCHARs placed to the buffer excluding terminating 0.
Returns
TRUE if the text is successully loaded from a binary buffer, FALSE otherwise.

◆ XTPLoadUnicodeText()

_XTP_EXT_CLASS BOOL AFX_CDECL XTPLoadUnicodeText | ( | const void * | pRawData,
 |  | UINT | cbRawData,
 |  | LPWSTR | lpUnicodeText,
 |  | UINT * | pchUnicodeText )

Attempts to load a Unicode text from a binary buffer.

If source text is not in Unicode format, converts to Unicode depending on detected text encoding. Supported encodings: ANSI, UTF-8, Unicode.

Parameters
pRawData | Pointer to raw text data to load.
cbRawData | Size of raw text data in bytes.
lpUnicodeText | Pointer to a buffer large enough to hold text after being converted to Unicode.
pchUnicodeText | On input, contains number of WCHARs available in lpUnicodeText buffer including terminating 0. On output, contains number of WCHARs placed to the buffer excluding terminating 0.
Returns
TRUE if the Unicode text is successully loaded from a binary buffer, FALSE otherwise.

◆ XTPLoadWindowClass() [1/2]

_XTP_EXT_CLASS BOOL AFX_CDECL XTPLoadWindowClass | ( | XTPWindowClass | nClass,
 |  | XTPWindowClassVersionSelectionVerb | nVerb,
 |  | int * | pnVersion,
 |  | LPWNDCLASS | pWndClass = NULL )

Loads and verifies a window class module of a specified version according to version selection rule.

Parameters
nClass | One of the predefined window class identifiers.
nVerb | Determines how windows class version is selected.
pnVersion | On input, must contain a valid window class specific version identified. In case of success on return, it contains the actual value of the window class version selected. Ignored if nVerb == xtpWindowClassVersionHighest.
pWndClass | Optional. If not NULL and succeeded, then it gets filled with window class specific information.
Returns
TRUE if the class specified has been loaded and verified.

◆ XTPLoadWindowClass() [2/2]

AFX_INLINE BOOL AFX_CDECL XTPLoadWindowClass | ( | XTPWindowClass | nClass,
 |  | XTPWindowClassVersionSelectionVerb | nVerb,
 |  | int | nVersion,
 |  | LPWNDCLASS | pWndClass = NULL )

Loads and verifies a window class module of a specified version according to version selection rule.

Parameters
nClass | One of the predefined window class identifiers.
nVerb | Determines how windows class version is selected.
nVersion | Same as pnVersion, but not changed on return.
pWndClass | Optional. If not NULL and succeeded, then it gets filled with window class specific information.
Returns
TRUE if the class specified has been loaded and verified.

◆ XTPMultiMonitor()

_XTP_EXT_CLASS CXTPMultiMonitor *AFX_CDECL XTPMultiMonitor ( )

Call this function to access CXTPMultiMonitor members.

Since this class is designed as a single instance object you can only access its members through this method. You cannot directly instantiate an object of type CXTPMultiMonitor.

Example:

CRect rcWork = XTPMultiMonitor()->GetWorkArea();
Returns
A global multi monitor helper object pointer.

◆ XTPParseDouble() [1/2]

_XTP_EXT_CLASS double XTPParseDouble | ( | LPCSTR | pStr,
 |  | int * | pEndPos = NULL )

Attempts to parse a floating point value from the beginning of the provided string.

Parameters
pStr | String pointer to parse a floating point value from.
pEndPos | An optional pointer to a value that receives the character position after the last parsed character in the source string.
Returns
A parsed floating point value or XTP_NAN in case of an error.

◆ XTPParseDouble() [2/2]

_XTP_EXT_CLASS double XTPParseDouble | ( | LPCWSTR | pStr,
 |  | int * | pEndPos = NULL )

◆ XTPParseUri()

_XTP_EXT_CLASS HRESULT AFX_CDECL XTPParseUri | ( | LPCTSTR | lpszUri,
 |  | XTP_URI * | pUri,
 |  | const XTP_URI_DEFAULTS * | pDefaults = NULL )

Parses URI, Sample valid file URIs:

file://C:/Windows/data.txt - absolute file URI
C:/Windows/data.txt - absolute file URI
file://data.txt - relative to executable module file URI.
data.txt - relative to executable module file URI.
file://../../bin/data.txt - relative to executable module file URI.
data.txt - relative to executable module file URI.

Resource URI format:

res://[absolute or relative path|.][/(type name|type ID)/](name|#ID)

If optional resource type is not specified and no default values passed, the default value return by XTPGetDefaultResourceTypeFromPath will be used. A special '.' symbol must be used as file name for referring to current executable resource directory.

Sample valid resource URIs:

res://C:/Windows/System32/mydll.dll/24/1
res://C:/Windows/System32/mydll.dll/test.html
res://../../bin/mydll.dll/2/101
res://./2/101
res://./1000
res://./1000.html
res://#1000
res://1000.html
Parameters
lpszUri | Pointer to a NULL-terminated URI.
pUri | Pointer to XTP_URI structure that will be filled with valid values on successful return.
pDefaults | Optional pointer to default URI values.
Returns
S_OK if successful, otherwise a standard error code that indicates the problem that occured.

◆ XTPReadStreamData()

_XTP_EXT_CLASS HRESULT AFX_CDECL XTPReadStreamData | ( | IStream * | pStream,
 |  | LPVOID & | pData,
 |  | SIZE_T & | cbData,
 |  | ULONG | cbSizeNeeded = ULONG_MAX,
 |  | STREAM_SEEK | nSeek = STREAM_SEEK_CUR,
 |  | LONG | nOffset = 0 )

Reads data from the specified stream starting at the specified position.

Parameters
pStream | Stream pointer to read data from
pData | Upon successful completion contains a pointer to a memory buffer filled with data read
cbData | Upon successful completion contains the size of the data block read
cbSizeNeeded | The maximum number to read from the stream.
nSeek | Seek position
nOffset | Offset from the specified seek position.

The allocated returned buffer must be released by a caller using XTPReleaseReadStreamData call.

Returns
S_OK if successful, or a standard COM error code.
See also
XTPReleaseReadStreamData

◆ XTPReleaseReadStreamData()

_XTP_EXT_CLASS void AFX_CDECL XTPReleaseReadStreamData ( LPVOID pData )

Releases a memory buffer allocated by XTPReadStreamData.

Parameters
pData Memory buffer pointer.
Returns
See also
XTPReleaseReadStreamData

◆ XTPSoundManager()

_XTP_EXT_CLASS CXTPSoundManager *AFX_CDECL XTPSoundManager ( )

Call this function to access CXTPSoundManager members.

Since this class is designed as a single instance object you can only access version info through this method. You cannot directly instantiate an object of type CXTPSoundManager.

Example:

XTPSoundManager()->PlaySystemSound(xtpSoundMenuCommand);
Returns
A global sound manager object pointer.

◆ XTPSystemVersion()

_XTP_EXT_CLASS CXTPSystemVersion *AFXAPI XTPSystemVersion ( )

The XTPSystemVersion function is used for access to the CXTPSystemVersion class.

Call this function to access CXTPSystemVersion members. Since this class is designed as a single instance object you can only access its members through this method. You cannot directly instantiate an object of type CXTPSystemVersion.

Returns
A pointer to the one and only CXTPSystemVersion instance.

Example: The following example demonstrates the use of XTPSystemVersion.

bool bIsWinNT = XTPSystemVersion()->IsWinNT4();
See also
CXTPSystemVersion

◆ XTPTlsAllocate()

_XTP_EXT_CLASS DWORD_PTR AFX_CDECL XTPTlsAllocate ( PVOID pValue = NULL )

Allocates a new slot in XTP TLS pool and assigns an initial value if provided.

Parameters
pValue An optional initial value of the newly allocated XTP TLS slot.
Returns
A valid XTP TLS slot or XTP_INVALID_TLS_SLOT if unable to allocate a new XTP TLS slot.
See also
XTPTlsSetValue, XTPTlsGetValue, XTPTlsFree, CXTPThreadLocal

◆ XTPTlsFree()

_XTP_EXT_CLASS BOOL AFX_CDECL XTPTlsFree ( DWORD_PTR dwSlot )

Releases a previously assigned XTP TLS slot.

Parameters
dwSlot XTP TLS slot.
Returns
TRUE if the slot is release or FALSE otherwise.
See also
XTPTlsAllocate, XTPTlsSetValue, XTPTlsGetValue, CXTPThreadLocal

◆ XTPTlsGetValue()

_XTP_EXT_CLASS PVOID AFX_CDECL XTPTlsGetValue ( DWORD_PTR dwSlot )

Obtains an assigned XTP TLS slot value.

Parameters
dwSlot XTP TLS slot.
Returns
An assigned XTP TLS slot value or NULL in case of an error or if no value is assigned.
See also
XTPTlsAllocate, XTPTlsSetValue, XTPTlsFree, CXTPThreadLocal

◆ XTPTlsSetValue()

_XTP_EXT_CLASS BOOL AFX_CDECL XTPTlsSetValue | ( | DWORD_PTR | dwSlot,
 |  | PVOID | pValue )

Sets a new value to the previously allocated XTP TLS slot.

Parameters
dwSlot | XTP TLS slot.
pValue | New XTP TLS slot value.
Returns
TRUE if the new XTP TLS slot value is assined or FALSE otherwise.
See also
XTPTlsAllocate, XTPTlsGetValue, XTPTlsFree, CXTPThreadLocal

◆ XTPVariantEqual()

_XTP_EXT_CLASS BOOL AFX_CDECL XTPVariantEqual | ( | const VARIANT & | v1,
 |  | const VARIANT & | v2 )

Perform a shallow comparison of two variants.

Value objects and strings get compared in full, while object references, arrays and vectors compared only by their reference values.

Parameters
v1 | The first variant object to compare.
v2 | The second variant object to compare.
Returns
TRUE if provided variant objects are identical, FALSE otherwise.


Toolkit Pro: XTPSystemMetrics.h File Reference

  • Source
  • Common
Classes
XTPSystemMetrics.h File Reference

Go to the source code of this file.

Classes

class | CXTPSystemMetrics
The CXTPSystemMetrics class is used to store and update sytem information. More...
class | CXTPDeviceCaps
The CXTPDeviceCaps class is used to store and update sytem information. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTheme.h File Reference

  • Source
  • Common
Classes
XTPTheme.h File Reference

Go to the source code of this file.

Classes

class CXTPColorSetCaptionButton
Default theme caption button color set. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPThemeDLL.h File Reference

  • Source
  • Common
Classes | Functions
XTPThemeDLL.h File Reference

Go to the source code of this file.

Classes

class CXTPThemeDLL
CXTPThemeDLL is a helper class used to load Codejock theme resource DLLs. More...

Functions

_XTP_EXT_CLASS CXTPThemeDLL *AFX_CDECL XTPThemeDLL ()
XTPThemeDLL returns pointer to common CXTPThemeDLL class.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Function Documentation

◆ XTPThemeDLL()

_XTP_EXT_CLASS CXTPThemeDLL *AFX_CDECL XTPThemeDLL ( )

XTPThemeDLL returns pointer to common CXTPThemeDLL class.

Returns
Returns pointer to common CXTPThemeDLL class
See also
CXTPThemeDLL


Toolkit Pro: XTPToolTipContext.h File Reference

  • Source
  • Common
Classes | Enumerations
XTPToolTipContext.h File Reference

Go to the source code of this file.

Classes

class | CXTPToolTipContextToolTip
CXTPToolTipContextToolTip is CWnd derived class, the base class for custom tool tips. More...
class | CXTPToolTipContext
CXTPToolTipContext is a CXTPCmdTarget derived class. More...

Enumerations

enum XTPToolTipStyle {
xtpToolTipStandard , xtpToolTipBalloon , xtpToolTipOffice , xtpToolTipRTF ,
xtpToolTipLuna , xtpToolTipResource , xtpToolTipHTML , xtpToolTipMarkup ,
xtpToolTipOffice2013 , xtpToolTipOffice2016 = xtpToolTipOffice2013
}
Enumeration used to determine styles for tooltips. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Enumeration Type Documentation

◆ XTPToolTipStyle

enum XTPToolTipStyle

Enumeration used to determine styles for tooltips.

Example:

pCommandBars->GetToolTipContext()->SetStyle(xtpToolTipBalloon);
See also
CXTPToolTipContext::SetStyle, xtpToolTipBalloon, xtpToolTipBalloon, xtpToolTipOffice
Enumerator
xtpToolTipStandard | Standard tooltip window style
xtpToolTipBalloon | Balloon tooltip window style
xtpToolTipOffice | Office tooltip window style
xtpToolTipRTF | RTF tooltip window style
xtpToolTipLuna | Luna tooltip window style
xtpToolTipResource | Office 2007 window style
xtpToolTipHTML | HTML tooltip style
xtpToolTipMarkup | HTML tooltip style
xtpToolTipOffice2013 | Office 2013 tooltip window style.
xtpToolTipOffice2016 | Office 2016 tooltip window style.


Toolkit Pro: XTPTypeId.h File Reference

  • Source
  • Common
XTPTypeId.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPWinThemeWrapper.h File Reference

  • Source
  • Common
Classes
XTPWinThemeWrapper.h File Reference

Go to the source code of this file.

Classes

class CXTPWinThemeWrapper
The CXTPWinThemeWrapper class wraps the UxTheme.dll visual theme API. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: Controls Directory Reference

  • Source
  • Controls
Controls Directory Reference

Directories

Button
Combo
CoreTree
Dialog
Edit
Header
List
ListBox
Popup
Preview
Progress
Resize
Scroll
Shell
Spin
Splitter
Static
Tab
TagCloud
Tree
Util
View
WebBrowser

Files

XTPControlsIIDs.h


Toolkit Pro: Button Directory Reference

  • Source
  • Controls
  • Button
Button Directory Reference

Directories

Themes

Files

XTPButton.h
XTPButtonTheme.h
XTPColorPicker.h


Toolkit Pro: Themes Directory Reference

  • Source
  • Controls
  • Button
  • Themes
Themes Directory Reference

Files

XTPButtonThemeFlat.h
XTPButtonThemeNativeWindows10.h
XTPButtonThemeNativeWindows11.h
XTPButtonThemeOffice2000.h
XTPButtonThemeOffice2003.h
XTPButtonThemeOffice2013.h
XTPButtonThemeOfficeXP.h
XTPButtonThemeResource.h
XTPButtonThemeUltraFlat.h
XTPButtonThemeVisualStudio2012.h
XTPButtonThemeVisualStudio2015.h
XTPButtonThemeVisualStudio2017.h
XTPButtonThemeVisualStudio2019.h
XTPButtonThemeVisualStudio2022.h


Toolkit Pro: XTPButtonThemeFlat.h File Reference

  • Source
  • Controls
  • Button
  • Themes
Classes
XTPButtonThemeFlat.h File Reference

Go to the source code of this file.

Classes

class CXTPButtonThemeFlat
CXTPButtonThemeFlat is a class used to perform Flat Theme drawing tasks. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPButtonThemeNativeWindows10.h File Reference

  • Source
  • Controls
  • Button
  • Themes
Classes
XTPButtonThemeNativeWindows10.h File Reference

Go to the source code of this file.

Classes

class CXTPButtonThemeNativeWindows10
CXTPButtonThemeNativeWindows10 is a class used to perform Visual Studio 2015 theme drawing tasks. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPButtonThemeNativeWindows11.h File Reference

  • Source
  • Controls
  • Button
  • Themes
Classes
XTPButtonThemeNativeWindows11.h File Reference

Go to the source code of this file.

Classes

class CXTPButtonThemeNativeWindows11
CXTPButtonThemeNativeWindows11 is a class used to perform Visual Studio 2015 theme drawing tasks. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPButtonThemeOffice2000.h File Reference

  • Source
  • Controls
  • Button
  • Themes
Classes
XTPButtonThemeOffice2000.h File Reference

Go to the source code of this file.

Classes

class CXTPButtonThemeOffice2000
CXTPButtonThemeOffice2000 is a class used to perform Office 2000 Theme drawing tasks. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPButtonThemeOffice2003.h File Reference

  • Source
  • Controls
  • Button
  • Themes
Classes
XTPButtonThemeOffice2003.h File Reference

Go to the source code of this file.

Classes

class CXTPButtonThemeOffice2003
CXTPButtonThemeOffice2003 is a class used to perform Office 2003 Theme drawing tasks. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPButtonThemeOffice2013.h File Reference

  • Source
  • Controls
  • Button
  • Themes
Classes
XTPButtonThemeOffice2013.h File Reference

Go to the source code of this file.

Classes

class CXTPButtonThemeOffice2013
CXTPButtonThemeOffice2013 is a class used to perform Office 2013 theme drawing tasks. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPButtonThemeOfficeXP.h File Reference

  • Source
  • Controls
  • Button
  • Themes
Classes
XTPButtonThemeOfficeXP.h File Reference

Go to the source code of this file.

Classes

class CXTPButtonThemeOfficeXP
CXTPButtonThemeOfficeXP is a class used to perform Office XP Theme drawing tasks. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPButtonThemeResource.h File Reference

  • Source
  • Controls
  • Button
  • Themes
Classes
XTPButtonThemeResource.h File Reference

Go to the source code of this file.

Classes

class CXTPButtonThemeResource
CXTPButtonThemeResource is a class used to perform Office 2007 Theme drawing tasks. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPButtonThemeUltraFlat.h File Reference

  • Source
  • Controls
  • Button
  • Themes
Classes
XTPButtonThemeUltraFlat.h File Reference

Go to the source code of this file.

Classes

class CXTPButtonThemeUltraFlat
CXTPButtonThemeUltraFlat is a class used to perform Ultra Flat Theme drawing tasks. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPButtonThemeVisualStudio2012.h File Reference

  • Source
  • Controls
  • Button
  • Themes
Classes
XTPButtonThemeVisualStudio2012.h File Reference

Go to the source code of this file.

Classes

class CXTPButtonThemeVisualStudio2012
CXTPButtonThemeVisualStudio2012 is a class used to perform Visual Studio 2012 theme drawing tasks. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPButtonThemeVisualStudio2015.h File Reference

  • Source
  • Controls
  • Button
  • Themes
Classes
XTPButtonThemeVisualStudio2015.h File Reference

Go to the source code of this file.

Classes

class CXTPButtonThemeVisualStudio2015
CXTPButtonThemeVisualStudio2015 is a class used to perform Visual Studio 2015 theme drawing tasks. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPButtonThemeVisualStudio2017.h File Reference

  • Source
  • Controls
  • Button
  • Themes
Classes
XTPButtonThemeVisualStudio2017.h File Reference

Go to the source code of this file.

Classes

class CXTPButtonThemeVisualStudio2017
CXTPButtonThemeVisualStudio2017 is a class used to perform Visual Studio 2017 theme drawing tasks. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPButtonThemeVisualStudio2019.h File Reference

  • Source
  • Controls
  • Button
  • Themes
Classes
XTPButtonThemeVisualStudio2019.h File Reference

Go to the source code of this file.

Classes

class CXTPButtonThemeVisualStudio2019
CXTPButtonThemeVisualStudio2019 is a class used to perform Visual Studio 2019 theme drawing tasks. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPButtonThemeVisualStudio2022.h File Reference

  • Source
  • Controls
  • Button
  • Themes
Classes
XTPButtonThemeVisualStudio2022.h File Reference

Go to the source code of this file.

Classes

class CXTPButtonThemeVisualStudio2022
CXTPButtonThemeVisualStudio2022 is a class used to perform Visual Studio 2022 theme drawing tasks. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPButton.h File Reference

  • Source
  • Controls
  • Button
Classes | Enumerations
XTPButton.h File Reference

Go to the source code of this file.

Classes

class CXTPButton
Push Button control. More...

Enumerations

enum XTPButtonTextImageRelation {
xtpButtonOverlay , xtpButtonImageAboveText , xtpButtonTextAboveImage , xtpButtonImageBeforeText ,
xtpButtonTextBeforeImage
}
Image and text relationship settings for a push button control. More...
enum XTPPushButtonStyle {
xtpButtonNormal , xtpButtonDropDown , xtpButtonDropDownRight , xtpButtonSplitDropDown ,
xtpButtonDropDownNoGlyph
}
PushButton styles. More...
enum XTPGroupBoxBorderStyle { xtpGroupBoxBorder , xtpGroupBoxSingleLine , xtpGroupBoxNone }
Determines the group box border style for the control. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Enumeration Type Documentation

◆ XTPButtonTextImageRelation

enum XTPButtonTextImageRelation

Image and text relationship settings for a push button control.

The CXTPButton::SetTextImageRelation method uses flags from the XTPButtonTextImageRelation enumeration to set the text and image relationship inside the button control.

Enumerator
xtpButtonOverlay | Image is displayed over top of the text.
xtpButtonImageAboveText | Image is displayed above the text.
xtpButtonTextAboveImage | Text is displayed above the image.
xtpButtonImageBeforeText | Image is displayed before/to the left of the text.
xtpButtonTextBeforeImage | Text is displayed before/to the left of the image.

◆ XTPGroupBoxBorderStyle

enum XTPGroupBoxBorderStyle

Determines the group box border style for the control.

There are 3 different border styles for the control which are single line with caption, complete border with caption, and no border or caption. CXTPButton::SetBorderStyle method stores a value from the XTPGroupBoxBorderStyle enumeration to specify the border style of the control.

Enumerator
xtpGroupBoxBorder | Complete frame with caption.
xtpGroupBoxSingleLine | Single line with caption.
xtpGroupBoxNone | No frame or caption.

◆ XTPPushButtonStyle

enum XTPPushButtonStyle

PushButton styles.

The CXTPButton::SetPushButtonStyle method uses flags from the XTPPushButtonStyle enumeration to set the style of the button.

Enumerator
xtpButtonNormal | Normal push button.
xtpButtonDropDown | Dropdown button. Button will have an arrow indicating it has a dropdown. The dropdown will appear under the button.
xtpButtonDropDownRight | Dropdown button. Button will have an arrow indicating it has a dropdown. The dropdown will appear to the right of the button.
xtpButtonSplitDropDown | Split button. Button will be split into a "button" part and "arrow" part. The "arrow" part will have an arrow indicating it has a dropdown. The dropdown will appear under the button when the "arrow" part is clicked.
xtpButtonDropDownNoGlyph | Do not display the drop down arrow.


Toolkit Pro: XTPButtonTheme.h File Reference

  • Source
  • Controls
  • Button
Classes
XTPButtonTheme.h File Reference

Go to the source code of this file.

Classes

class CXTPButtonTheme
CXTPButtonTheme is a class used to perform Button Theme drawing tasks. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPColorPicker.h File Reference

  • Source
  • Controls
  • Button
Classes | Functions
XTPColorPicker.h File Reference

Go to the source code of this file.

Classes

class CXTPColorPicker
CXTPColorPicker is a CXTPButton derived class. More...

Functions

_XTP_EXT_CLASS void AFXAPI DDX_XTPColorPicker (CDataExchange *pDX, int nIDC, COLORREF &value)
The DDX_XTPColorPicker function manages the transfer of integer data between a color picker control in a dialog box, form view, or control view object and a COLORREF data member of the dialog box, form view, or control view object.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Function Documentation

◆ DDX_XTPColorPicker()

_XTP_EXT_CLASS void AFXAPI DDX_XTPColorPicker | ( | CDataExchange * | pDX,
 |  | int | nIDC,
 |  | COLORREF & | value )

The DDX_XTPColorPicker function manages the transfer of integer data between a color picker control in a dialog box, form view, or control view object and a COLORREF data member of the dialog box, form view, or control view object.

When DDX_XTPColorPicker is called, 'value' is set to the current state of the color picker control.

Parameters
pDX | A pointer to a CDataExchange object. The framework supplies this object to establish the context of the data exchange, including its direction.
nIDC | The resource ID of the color picker control associated with the control property.
value | A reference to a member variable of the dialog box, form view, or control view object with which data is exchanged.
Returns
See also
CXTPColorPicker


Toolkit Pro: Combo Directory Reference

  • Source
  • Controls
  • Combo
Combo Directory Reference

Directories

Themes

Files

XTPComboBox.h
XTPComboBoxEditCtrl.h
XTPComboBoxTheme.h
XTPFontComboBox.h
XTPMarkupComboBox.h


Toolkit Pro: Themes Directory Reference

  • Source
  • Controls
  • Combo
  • Themes
Themes Directory Reference

Files

XTPComboBoxThemeDefault.h
XTPComboBoxThemeNativeWindows10.h
XTPComboBoxThemeNativeWindows11.h
XTPComboBoxThemeOffice2000.h
XTPComboBoxThemeOffice2003.h
XTPComboBoxThemeOffice2013.h
XTPComboBoxThemeOfficeXPFlat.h
XTPComboBoxThemeResource.h
XTPComboBoxThemeVisualStudio.h
XTPComboBoxThemeVisualStudio2010.h
XTPComboBoxThemeVisualStudio2012.h
XTPComboBoxThemeVisualStudio2015.h
XTPComboBoxThemeVisualStudio2017.h
XTPComboBoxThemeVisualStudio2019.h
XTPComboBoxThemeVisualStudio2022.h


Toolkit Pro: XTPComboBoxThemeDefault.h File Reference

  • Source
  • Controls
  • Combo
  • Themes
Classes
XTPComboBoxThemeDefault.h File Reference

Go to the source code of this file.

Classes

class CXTPComboBoxThemeDefault
Used as the paint manager for a combobox control to render a default appearance. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPComboBoxThemeNativeWindows10.h File Reference

  • Source
  • Controls
  • Combo
  • Themes
Classes
XTPComboBoxThemeNativeWindows10.h File Reference

Go to the source code of this file.

Classes

class CXTPComboBoxThemeNativeWindows10
Used as the paint manager for a combobox control to render a Native Windows 10 appearance. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPComboBoxThemeNativeWindows11.h File Reference

  • Source
  • Controls
  • Combo
  • Themes
Classes
XTPComboBoxThemeNativeWindows11.h File Reference

Go to the source code of this file.

Classes

class CXTPComboBoxThemeNativeWindows11
Used as the paint manager for a combobox control to render a Native Windows 10 appearance. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPComboBoxThemeOffice2000.h File Reference

  • Source
  • Controls
  • Combo
  • Themes
Classes
XTPComboBoxThemeOffice2000.h File Reference

Go to the source code of this file.

Classes

class CXTPComboBoxThemeOffice2000
Used as the paint manager for a combobox control to render an Office 2000 appearance. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPComboBoxThemeOffice2003.h File Reference

  • Source
  • Controls
  • Combo
  • Themes
Classes
XTPComboBoxThemeOffice2003.h File Reference

Go to the source code of this file.

Classes

class CXTPComboBoxThemeOffice2003
Used as the paint manager for a combobox control to render an Office 2003 appearance. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPComboBoxThemeOffice2013.h File Reference

  • Source
  • Controls
  • Combo
  • Themes
Classes
XTPComboBoxThemeOffice2013.h File Reference

Go to the source code of this file.

Classes

class CXTPComboBoxThemeOffice2013
Used as the paint manager for a combobox control to render an Office 2013 appearance. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPComboBoxThemeOfficeXPFlat.h File Reference

  • Source
  • Controls
  • Combo
  • Themes
Classes
XTPComboBoxThemeOfficeXPFlat.h File Reference

Go to the source code of this file.

Classes

class CXTPComboBoxThemeOfficeXPFlat
Used as the paint manager for a combobox control to render an Office XP Flat appearance. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPComboBoxThemeResource.h File Reference

  • Source
  • Controls
  • Combo
  • Themes
Classes
XTPComboBoxThemeResource.h File Reference

Go to the source code of this file.

Classes

class CXTPComboBoxThemeResource
Used as the paint manager for a combobox control to render a resource appearance. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPComboBoxThemeVisualStudio.h File Reference

  • Source
  • Controls
  • Combo
  • Themes
Classes
XTPComboBoxThemeVisualStudio.h File Reference

Go to the source code of this file.

Classes

class CXTPComboBoxThemeVisualStudio
Used as the paint manager for a combobox control to render a Visual Studio appearance. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPComboBoxThemeVisualStudio2010.h File Reference

  • Source
  • Controls
  • Combo
  • Themes
Classes
XTPComboBoxThemeVisualStudio2010.h File Reference

Go to the source code of this file.

Classes

class CXTPComboBoxThemeVisualStudio2010
Used as the paint manager for a combobox control to render a Visual Studio 2010 appearance. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPComboBoxThemeVisualStudio2012.h File Reference

  • Source
  • Controls
  • Combo
  • Themes
Classes
XTPComboBoxThemeVisualStudio2012.h File Reference

Go to the source code of this file.

Classes

class CXTPComboBoxThemeVisualStudio2012
Used as the paint manager for a combobox control to render a Visual Studio 2012 appearance. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPComboBoxThemeVisualStudio2015.h File Reference

  • Source
  • Controls
  • Combo
  • Themes
Classes
XTPComboBoxThemeVisualStudio2015.h File Reference

Go to the source code of this file.

Classes

class CXTPComboBoxThemeVisualStudio2015
Used as the paint manager for a combobox control to render a Visual Studio 2015 appearance. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPComboBoxThemeVisualStudio2017.h File Reference

  • Source
  • Controls
  • Combo
  • Themes
Classes
XTPComboBoxThemeVisualStudio2017.h File Reference

Go to the source code of this file.

Classes

class CXTPComboBoxThemeVisualStudio2017
Used as the paint manager for a combobox control to render a Visual Studio 2017 appearance. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPComboBoxThemeVisualStudio2019.h File Reference

  • Source
  • Controls
  • Combo
  • Themes
Classes
XTPComboBoxThemeVisualStudio2019.h File Reference

Go to the source code of this file.

Classes

class CXTPComboBoxThemeVisualStudio2019
Used as the paint manager for a combobox control to render a Visual Studio 2019 appearance. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPComboBoxThemeVisualStudio2022.h File Reference

  • Source
  • Controls
  • Combo
  • Themes
Classes
XTPComboBoxThemeVisualStudio2022.h File Reference

Go to the source code of this file.

Classes

class CXTPComboBoxThemeVisualStudio2022
Used as the paint manager for a combobox control to render a Visual Studio 2022 appearance. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPComboBox.h File Reference

  • Source
  • Controls
  • Combo
Classes
XTPComboBox.h File Reference

Go to the source code of this file.

Classes

class CXTPComboBox
The CXTPComboBox class provides the functionality of a themed Windows combobox. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPComboBoxEditCtrl.h File Reference

  • Source
  • Controls
  • Combo
Classes
XTPComboBoxEditCtrl.h File Reference

Go to the source code of this file.

Classes

class CXTPComboBoxEditCtrl
Used by the CXTPComboBox object to subclass the edit-box portion of the control. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPComboBoxTheme.h File Reference

  • Source
  • Controls
  • Combo
Classes
XTPComboBoxTheme.h File Reference

Go to the source code of this file.

Classes

class CXTPComboBoxTheme
CXTPComboBoxTheme is a class used to perform ComboBox Theme drawing tasks. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPFontComboBox.h File Reference

  • Source
  • Controls
  • Combo
Classes | Typedefs | Enumerations
XTPFontComboBox.h File Reference

Go to the source code of this file.

Classes

class | CXTPFontEnum
CXTPFontEnum is a standalone singleton font enumeration class. More...
class | CXTPFontCtrlBase
CXTPFontCtrlBase is a base class used by CXTPFontListBox and CXTPFontComboBox controls to perform common drawing routines. More...
class | CXTPFontListBox
CXTPFontListBox is a CXTPListBox derived class. More...
class | CXTPFontComboBox
CXTPFontComboBox is a CXTPComboBox derived class. More...

Typedefs

typedef CList< CXTPLogFont, CXTPLogFont & > CXTPFontList
List used for enumerating CXTPLogFont structures.

Enumerations

enum XTPFontStyle { xtpFontUnknown = 0x00 , xtpFontGUI = 0x01 , xtpFontSample = 0x02 , xtpFontBoth = 0x03 }
Enumeration used to determine font display. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Typedef Documentation

◆ CXTPFontList

typedef CList<CXTPLogFont, CXTPLogFont&> CXTPFontList

List used for enumerating CXTPLogFont structures.

CList definition used by the CXTPFontEnum class to maintain a list of CXTPLogFont objects representing each font displayed for a CXTPFontListBox control.

See also
CXTPFontEnum::GetFontList

Enumeration Type Documentation

◆ XTPFontStyle

enum XTPFontStyle

Enumeration used to determine font display.

XTPFontStyle type defines the constants used by the CXTPFontListBox class to determine how the fonts will be displayed in the CXTPFontListBox control.

See also
CXTPFontListBox, CXTPFontListBox::SetListStyle
xtpFontGUI, xtpFontSample, xtpFontBoth>
Enumerator
xtpFontUnknown | Display type not defined.
xtpFontGUI | Display font name with GUI font style.
xtpFontSample | Display font name with its own font style.
xtpFontBoth | Display font name with GUI font style, then a sample display to the right.


Toolkit Pro: XTPMarkupComboBox.h File Reference

  • Source
  • Controls
  • Combo
XTPMarkupComboBox.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: CoreTree Directory Reference

  • Source
  • Controls
  • CoreTree
CoreTree Directory Reference

Files

XTPCoreTreeControl.h
XTPCoreTreeItem.h
XTPCoreTreePaintManager.h


Toolkit Pro: XTPCoreTreeControl.h File Reference

  • Source
  • Controls
  • CoreTree
XTPCoreTreeControl.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPCoreTreeItem.h File Reference

  • Source
  • Controls
  • CoreTree
XTPCoreTreeItem.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPCoreTreePaintManager.h File Reference

  • Source
  • Controls
  • CoreTree
XTPCoreTreePaintManager.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: Dialog Directory Reference

  • Source
  • Controls
  • Dialog
Dialog Directory Reference

Files

XTPBrowseDialog.h
XTPColorDialog.h
XTPColorPageCustom.h
XTPColorPageStandard.h
XTPDialogBase.h
XTPNewToolbarDlg.h
XTPPropertyPage.h
XTPPropertyPageNavigator.h
XTPPropertySheet.h
XTPTaskDialog.h
XTPTaskDialogAPI.h
XTPTaskDialogClient.h
XTPTaskDialogControls.h
XTPTaskDialogFrame.h
XTPTipOfTheDay.h
XTPWindowList.h


Toolkit Pro: XTPBrowseDialog.h File Reference

  • Source
  • Controls
  • Dialog
Classes
XTPBrowseDialog.h File Reference

Go to the source code of this file.

Classes

class CXTPBrowseDialog
CXTPBrowseDialog is derived from the BROWSEINFO structure. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPColorDialog.h File Reference

  • Source
  • Controls
  • Dialog
Classes
XTPColorDialog.h File Reference

Go to the source code of this file.

Classes

class | CXTPEyeDropper
Creates an eye dropper control that can be used to select any color that is displayed anywhere on the screen. More...
class | CXTPColorDialog
CXTPColorDialog is a CPropertySheet derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPColorPageCustom.h File Reference

  • Source
  • Controls
  • Dialog
Classes
XTPColorPageCustom.h File Reference

Go to the source code of this file.

Classes

class | CXTPColorBase
CXTPColorBase is a CStatic derived base class. More...
class | CXTPColorWnd
CXTPColorWnd is a CXTPColorBase derived class. More...
class | CXTPColorLum
CXTPColorLum is a CXTPColorBase derived class. More...
class | CXTPColorPageCustom
CXTPColorPageCustom is derived from CPropertyPage. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPColorPageStandard.h File Reference

  • Source
  • Controls
  • Dialog
Classes
XTPColorPageStandard.h File Reference

Go to the source code of this file.

Classes

class | CXTPColorHex
CXTPColorHex is a CStatic derived class. More...
class | CXTPColorHex::CRgnCell
CRgnCell is a CRgn derived class used by the CXTPColorHex to create individual color cells. More...
struct | CXTPColorHex::CRgnCell::CTX_DATA
Contains pre-computed hexagon data for both small and big hexagons. More...
struct | CXTPColorHex::CRgnCell::CTX_DATA::HEXAGON_DATA
Describes pre-computed hexagon data. More...
class | CXTPColorPageStandard
CXTPColorPageStandard is derived from CPropertyPage. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPDialogBase.h File Reference

  • Source
  • Controls
  • Dialog
Classes
XTPDialogBase.h File Reference

Go to the source code of this file.

Classes

class | CXTPDialogBase< TBase >
CXTPDialogBase is a TBase derived class. More...
class | CXTPDialogEx
CXTPDialogEx is a CXTPDialogBase derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPNewToolbarDlg.h File Reference

  • Source
  • Controls
  • Dialog
XTPNewToolbarDlg.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPPropertyPage.h File Reference

  • Source
  • Controls
  • Dialog
Classes
XTPPropertyPage.h File Reference

Go to the source code of this file.

Classes

class CXTPPropertyPage
CXTPPropertyPage is a CPropertyPage derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPPropertyPageNavigator.h File Reference

  • Source
  • Controls
  • Dialog
Classes
XTPPropertyPageNavigator.h File Reference

Go to the source code of this file.

Classes

class | CXTPPropertyPageNavigator
CXTPPropertyPageNavigator is a standalone class. More...
class | CXTPPropertyPageControlNavigator
CXTPPropertyPageControlNavigator is a CXTPPropertyPageNavigator derived class. More...
class | CXTPPropertyPageListNavigator
CXTPPropertyPageListNavigator is a CXTPListBox and CXTPPropertyPageControlNavigator derived class. More...
class | CXTPPropertyPageTreeNavigator
CXTPPropertyPageTreeNavigator is a CTreeCtrl and CXTPPropertyPageControlNavigator derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPPropertySheet.h File Reference

  • Source
  • Controls
  • Dialog
Classes | Enumerations
XTPPropertySheet.h File Reference

Go to the source code of this file.

Classes

class CXTPPropertySheet
CXTPPropertySheet is a CXTPDialogEx derived class. More...

Enumerations

enum XTPPropertyPageBorder { xtpPageBorderNone , xtpPageBorderBottomLine , xtpPageBorderFrame }
XTPPropertyPageBorder is an enumeration used to set the client frame style drawn around the client of tabs. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Enumeration Type Documentation

◆ XTPPropertyPageBorder

enum XTPPropertyPageBorder

XTPPropertyPageBorder is an enumeration used to set the client frame style drawn around the client of tabs.

Example:

wndSheet.SetPageBorderStyle(xtpPageBorderFrame);
See also
CXTPPropertySheet
xtpPageBorderNone, xtpPageBorderBottomLine, xtpPageBorderFrame>
Enumerator
xtpPageBorderNone | No page boarder.
xtpPageBorderBottomLine | Draw a bottom border.
xtpPageBorderFrame | Draw a page boarder.


Toolkit Pro: XTPTaskDialog.h File Reference

  • Source
  • Controls
  • Dialog
Classes
XTPTaskDialog.h File Reference

Go to the source code of this file.

Classes

class CXTPTaskDialog
The CXTPTaskDialog class creates, displays, and operates a task dialog. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTaskDialogAPI.h File Reference

  • Source
  • Controls
  • Dialog
XTPTaskDialogAPI.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTaskDialogClient.h File Reference

  • Source
  • Controls
  • Dialog
Classes
XTPTaskDialogClient.h File Reference

Go to the source code of this file.

Classes

class CXTPTaskDialogClient
CXTPTaskDialogClient window. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTaskDialogControls.h File Reference

  • Source
  • Controls
  • Dialog
Classes
XTPTaskDialogControls.h File Reference

Go to the source code of this file.

Classes

class | CXTPTaskDialogLinkCtrl
CXTPTaskDialogLinkCtrl is a CStatic derived class that is used to display a text block that contains clickable links. More...
struct | CXTPTaskDialogLinkCtrl::LINKITEM
LINKITEM is used to set and retrieve information about a link item. More...
class | CXTPTaskButtonTheme
CXTPTaskButtonTheme. More...
class | CXTPTaskButtonThemeExpando
CXTPTaskButtonThemeExpando. More...
class | CXTPTaskDialogProgressCtrl
CXTPTaskDialogProgressCtrl. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTaskDialogFrame.h File Reference

  • Source
  • Controls
  • Dialog
XTPTaskDialogFrame.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTipOfTheDay.h File Reference

  • Source
  • Controls
  • Dialog
Classes
XTPTipOfTheDay.h File Reference

Go to the source code of this file.

Classes

class CXTPTipOfTheDay
CXTPTipOfTheDay is a CDialog derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPWindowList.h File Reference

  • Source
  • Controls
  • Dialog
Classes
XTPWindowList.h File Reference

Go to the source code of this file.

Classes

class CXTPWindowList
CXTPWindowList dialog. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: Edit Directory Reference

  • Source
  • Controls
  • Edit
Edit Directory Reference

Directories

Themes

Files

XTPBrowseEdit.h
XTPEdit.h
XTPEditTheme.h
XTPHexEdit.h
XTPMaskEdit.h
XTPPasswordPeek.h


Toolkit Pro: Themes Directory Reference

  • Source
  • Controls
  • Edit
  • Themes
Themes Directory Reference

Files

XTPEditThemeDefault.h
XTPEditThemeFlat.h
XTPEditThemeNativeWindows10.h
XTPEditThemeNativeWindows11.h
XTPEditThemeOffice2000.h
XTPEditThemeOffice2003.h
XTPEditThemeOffice2013.h
XTPEditThemeOfficeXP.h
XTPEditThemeResource.h
XTPEditThemeUltraFlat.h
XTPEditThemeVisualStudio2010.h
XTPEditThemeVisualStudio2012.h
XTPEditThemeVisualStudio2015.h
XTPEditThemeVisualStudio2017.h
XTPEditThemeVisualStudio2019.h
XTPEditThemeVisualStudio2022.h


Toolkit Pro: XTPEditThemeDefault.h File Reference

  • Source
  • Controls
  • Edit
  • Themes
Classes
XTPEditThemeDefault.h File Reference

Go to the source code of this file.

Classes

class CXTPEditThemeDefault
CXTPEditThemeDefault is a class used to perform theme drawing tasks. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPEditThemeFlat.h File Reference

  • Source
  • Controls
  • Edit
  • Themes
Classes
XTPEditThemeFlat.h File Reference

Go to the source code of this file.

Classes

class CXTPEditThemeFlat
CXTPEditThemeFlat is a class used to perform theme drawing tasks. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPEditThemeNativeWindows10.h File Reference

  • Source
  • Controls
  • Edit
  • Themes
Classes
XTPEditThemeNativeWindows10.h File Reference

Go to the source code of this file.

Classes

class CXTPEditThemeNativeWindows10
CXTPEditThemeNativeWindows10 is a class used to perform theme drawing tasks. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPEditThemeNativeWindows11.h File Reference

  • Source
  • Controls
  • Edit
  • Themes
Classes
XTPEditThemeNativeWindows11.h File Reference

Go to the source code of this file.

Classes

class CXTPEditThemeNativeWindows11
CXTPEditThemeNativeWindows11 is a class used to perform theme drawing tasks. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPEditThemeOffice2000.h File Reference

  • Source
  • Controls
  • Edit
  • Themes
Classes
XTPEditThemeOffice2000.h File Reference

Go to the source code of this file.

Classes

class CXTPEditThemeOffice2000
CXTPEditThemeOffice2000 is a class used to perform theme drawing tasks. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPEditThemeOffice2003.h File Reference

  • Source
  • Controls
  • Edit
  • Themes
Classes
XTPEditThemeOffice2003.h File Reference

Go to the source code of this file.

Classes

class CXTPEditThemeOffice2003
CXTPEditThemeOffice2003 is a class used to perform theme drawing tasks. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPEditThemeOffice2013.h File Reference

  • Source
  • Controls
  • Edit
  • Themes
Classes
XTPEditThemeOffice2013.h File Reference

Go to the source code of this file.

Classes

class CXTPEditThemeOffice2013
CXTPEditThemeOffice2013 is a class used to perform theme drawing tasks. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPEditThemeOfficeXP.h File Reference

  • Source
  • Controls
  • Edit
  • Themes
Classes
XTPEditThemeOfficeXP.h File Reference

Go to the source code of this file.

Classes

class CXTPEditThemeOfficeXP
CXTPEditThemeOfficeXP is a class used to perform theme drawing tasks. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPEditThemeResource.h File Reference

  • Source
  • Controls
  • Edit
  • Themes
Classes
XTPEditThemeResource.h File Reference

Go to the source code of this file.

Classes

class CXTPEditThemeResource
CXTPEditThemeResource is a class used to perform theme drawing tasks. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPEditThemeUltraFlat.h File Reference

  • Source
  • Controls
  • Edit
  • Themes
Classes
XTPEditThemeUltraFlat.h File Reference

Go to the source code of this file.

Classes

class CXTPEditThemeUltraFlat
CXTPEditThemeUltraFlat is a class used to perform theme drawing tasks. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPEditThemeVisualStudio2010.h File Reference

  • Source
  • Controls
  • Edit
  • Themes
Classes
XTPEditThemeVisualStudio2010.h File Reference

Go to the source code of this file.

Classes

class CXTPEditThemeVisualStudio2010
CXTPEditThemeVisualStudio2010 is a class used to perform theme drawing tasks. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPEditThemeVisualStudio2012.h File Reference

  • Source
  • Controls
  • Edit
  • Themes
Classes
XTPEditThemeVisualStudio2012.h File Reference

Go to the source code of this file.

Classes

class CXTPEditThemeVisualStudio2012
CXTPEditThemeVisualStudio2012 is a class used to perform theme drawing tasks. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPEditThemeVisualStudio2015.h File Reference

  • Source
  • Controls
  • Edit
  • Themes
Classes
XTPEditThemeVisualStudio2015.h File Reference

Go to the source code of this file.

Classes

class CXTPEditThemeVisualStudio2015
CXTPEditThemeVisualStudio2015 is a class used to perform theme drawing tasks. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPEditThemeVisualStudio2017.h File Reference

  • Source
  • Controls
  • Edit
  • Themes
Classes
XTPEditThemeVisualStudio2017.h File Reference

Go to the source code of this file.

Classes

class CXTPEditThemeVisualStudio2017
CXTPEditThemeVisualStudio2017 is a class used to perform theme drawing tasks. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPEditThemeVisualStudio2019.h File Reference

  • Source
  • Controls
  • Edit
  • Themes
Classes
XTPEditThemeVisualStudio2019.h File Reference

Go to the source code of this file.

Classes

class CXTPEditThemeVisualStudio2019
CXTPEditThemeVisualStudio2019 is a class used to perform theme drawing tasks. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPEditThemeVisualStudio2022.h File Reference

  • Source
  • Controls
  • Edit
  • Themes
Classes
XTPEditThemeVisualStudio2022.h File Reference

Go to the source code of this file.

Classes

class CXTPEditThemeVisualStudio2022
CXTPEditThemeVisualStudio2022 is a class used to perform theme drawing tasks. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPBrowseEdit.h File Reference

  • Source
  • Controls
  • Edit
Classes | Variables
XTPBrowseEdit.h File Reference

Go to the source code of this file.

Classes

class | CXTPBrowseButton
CXTPBrowseButton is a CXTPButton derived class. More...
class | CXTPBrowseEdit
CXTPBrowseEdit is a CXTPEdit derived class. More...
class | CXTPItemEdit
CXTPItemEdit is a CXTPBrowseEdit derived class. More...

Variables

const DWORD | BES_XTP_CHOOSEDIR = 0x0001
Display a choose directory dialog.
const DWORD | BES_XTP_CHOOSEFILE = 0x0002
Display a choose file dialog.
const DWORD | BES_XTP_POPUPMENU = 0x0004
Display a popup menu for the dialog.
const DWORD | BES_XTP_BROWSE = 0x0010
Display a user-defined dialog for browsing.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Variable Documentation

◆ BES_XTP_BROWSE

const DWORD BES_XTP_BROWSE = 0x0010

Display a user-defined dialog for browsing.

Note: this must match the LBS_XTP_BROWSE define.

See also
CXTPBrowseEdit::Initialize

◆ BES_XTP_CHOOSEDIR

const DWORD BES_XTP_CHOOSEDIR = 0x0001

Display a choose directory dialog.

See also
CXTPBrowseEdit::Initialize

◆ BES_XTP_CHOOSEFILE

const DWORD BES_XTP_CHOOSEFILE = 0x0002

Display a choose file dialog.

See also
CXTPBrowseEdit::Initialize

◆ BES_XTP_POPUPMENU

const DWORD BES_XTP_POPUPMENU = 0x0004

Display a popup menu for the dialog.

See also
CXTPBrowseEdit::Initialize


Toolkit Pro: XTPEdit.h File Reference

  • Source
  • Controls
  • Edit
Classes | Typedefs
XTPEdit.h File Reference

Go to the source code of this file.

Classes

class | CXTPEdit
CXTPEdit is a CEdit derived class. More...
class | CXTPScrollableEditT< EditBase >
An adaptor for any CEdit derived control that overrides standard scrollbars with custom scrollbars. More...

Typedefs

typedef CXTPScrollableEditT< CXTPEdit > CXTPScrollableEdit
Type alias for a CXTPEdit derived scrollable control.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPEditTheme.h File Reference

  • Source
  • Controls
  • Edit
Classes
XTPEditTheme.h File Reference

Go to the source code of this file.

Classes

class CXTPEditTheme
CXTPEditTheme is the base class for all edit themes used to perform drawing tasks. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPHexEdit.h File Reference

  • Source
  • Controls
  • Edit
Classes
XTPHexEdit.h File Reference

Go to the source code of this file.

Classes

class CXTPHexEdit
CXTPHexEdit is a CEdit derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMaskEdit.h File Reference

  • Source
  • Controls
  • Edit
Classes | Functions
XTPMaskEdit.h File Reference

Go to the source code of this file.

Classes

class | CXTPMaskEdit
CXTPMaskEdit is a CXTPEdit derived class. More...
class | CXTPDateEdit
CXTPDateEdit is a CXTPMaskEdit derived class. More...
class | CXTPTimeEdit
CXTPTimeEdit is a CXTPDateEdit derived class. More...

Functions

_XTP_EXT_CLASS void AFXAPI DDX_XTPOleDateTime (CDataExchange *pDX, int nIDC, CXTPDateEdit &rControl, COleDateTime &rDateTime)
The DDX_XTPOleDateTime function manages the transfer of integer data between a date edit control, in a dialog box, form view, or control view object, and a COleDateTime data member of the dialog box, form view, or control view object.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Function Documentation

◆ DDX_XTPOleDateTime()

_XTP_EXT_CLASS void AFXAPI DDX_XTPOleDateTime | ( | CDataExchange * | pDX,
 |  | int | nIDC,
 |  | CXTPDateEdit & | rControl,
 |  | COleDateTime & | rDateTime )

The DDX_XTPOleDateTime function manages the transfer of integer data between a date edit control, in a dialog box, form view, or control view object, and a COleDateTime data member of the dialog box, form view, or control view object.

When DDX_XTPOleDateTime is called, 'value' is set to the current state of the date edit control.

Parameters
pDX | A pointer to a CDataExchange object. The framework supplies this object to establish the context of the data exchange, including its direction.
nIDC | The resource ID of the date edit control associated with the control property.
rControl | A reference to a member variable of the dialog box, form view, or control view object with which data is exchanged.
rDateTime | A reference to a member variable of the dialog box, form view, or control view object with which data is exchanged.
Returns
See also
CXTPDateEdit


Toolkit Pro: XTPPasswordPeek.h File Reference

  • Source
  • Controls
  • Edit
Classes
XTPPasswordPeek.h File Reference

Go to the source code of this file.

Classes

class CXTPPasswordPeek
CXTPPasswordPeek is a CXTPEdit derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: Header Directory Reference

  • Source
  • Controls
  • Header
Header Directory Reference

Files

XTPHeaderCtrl.h
XTPHeaderCtrlTheme.h


Toolkit Pro: XTPHeaderCtrl.h File Reference

  • Source
  • Controls
  • Header
Classes
XTPHeaderCtrl.h File Reference

Go to the source code of this file.

Classes

class CXTPHeaderCtrl
CXTPHeaderCtrl is a CHeaderCtrl derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPHeaderCtrlTheme.h File Reference

  • Source
  • Controls
  • Header
Classes | Variables
XTPHeaderCtrlTheme.h File Reference

Go to the source code of this file.

Classes

class | CXTPHeaderCtrlTheme
CXTPHeaderCtrlTheme is a theme class used to draw a Windows classic style theme for the header control. More...
class | CXTPHeaderCtrlThemeOfficeXP
CXTPHeaderCtrlThemeOfficeXP is a CXTPHeaderCtrlTheme derived theme class used to draw an Office XP style theme for the header control. More...
class | CXTPHeaderCtrlThemeOffice2003
CXTPHeaderCtrlThemeOffice2003 is a CXTPHeaderCtrlTheme derived theme class used to draw an Office 2003 style theme for the header control. More...
class | CXTPHeaderCtrlThemeExplorer
CXTPHeaderCtrlThemeExplorer is a CXTPHeaderCtrlThemeOffice2003 derived theme class used to draw an Office XP style theme for the header control. More...
class | CXTPHeaderCtrlThemeResource
CXTPHeaderCtrlThemeResource is a CXTPHeaderCtrlThemeOfficeXP derived theme class used to draw a resource .dll style theme for the header control. More...

Variables

const DWORD | HDR_XTP_WINDEF = 0x0001
const DWORD | HDR_XTP_HOTTRACKING = 0x0002
const DWORD | HDR_XTP_SORTARROW = 0x0004

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Variable Documentation

◆ HDR_XTP_HOTTRACKING

const DWORD HDR_XTP_HOTTRACKING = 0x0002
See also
CXTPHeaderCtrlTheme::SetDrawStyle

◆ HDR_XTP_SORTARROW

const DWORD HDR_XTP_SORTARROW = 0x0004
See also
CXTPHeaderCtrlTheme::SetDrawStyle

◆ HDR_XTP_WINDEF

const DWORD HDR_XTP_WINDEF = 0x0001
See also
CXTPHeaderCtrlTheme::SetDrawStyle


Toolkit Pro: List Directory Reference

  • Source
  • Controls
  • List
List Directory Reference

Files

XTPListBase.h
XTPListCtrlView.h
XTPSortClass.h


Toolkit Pro: XTPListBase.h File Reference

  • Source
  • Controls
  • List
Classes
XTPListBase.h File Reference

Go to the source code of this file.

Classes

class | CXTPListBase
CXTPListBase is a non-inherited class. More...
struct | CXTPListBase::ROWCOLOR
ROWCOLOR structure is used by the CXTPListBase class to store user-defined background and text color settings for a particular row in a list control. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPListCtrlView.h File Reference

  • Source
  • Controls
  • List
Classes | Typedefs
XTPListCtrlView.h File Reference

Go to the source code of this file.

Classes

class | CXTPListView
CXTPListView is a multiple inheritance class derived from CListView and CXTPListBase. More...
class | CXTPListCtrl
CXTPListCtrl is a multiple inheritance class derived from CListCtrl and CXTPListBase. More...
class | CXTPScrollableListCtrlT< ListBase >
An adaptor for any CListCtrl derived control that overrides standard scrollbars with custom scrollbars. More...

Typedefs

typedef CXTPScrollableListCtrlT< CXTPListCtrl > CXTPScrollableListCtrl
Type alias for a CXTPListCtrl derived scrollable control.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPSortClass.h File Reference

  • Source
  • Controls
  • List
Classes | Enumerations
XTPSortClass.h File Reference

Go to the source code of this file.

Classes

class | CXTPSortClass
CXTPSortClass is a standalone class. More...
struct | CXTPSortClass::ITEMDATA
This structure is used by the CXTPSortClass for storing a temporary item data pointer that contains each list item's name (used for sorting) and original item data (if any). More...

Enumerations

enum XTPSortType { xtpSortInt = 1 , xtpSortString , xtpSortDateTime , xtpSortDecimal }
Enumeration used to determine sort type. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Enumeration Type Documentation

◆ XTPSortType

enum XTPSortType

Enumeration used to determine sort type.

XTPSortType type defines the constants used by the CXTPSortClass to determine what type of sorting to perform.

See also
CXTPSortClass::Sort
xtpSortInt, xtpSortString, xtpSortDateTime, xtpSortDecimal>
Enumerator
xtpSortInt | Sort type integer.
xtpSortString | Sort type string.
xtpSortDateTime | Sort type date/time.
xtpSortDecimal | Sort type decimal.


Toolkit Pro: ListBox Directory Reference

  • Source
  • Controls
  • ListBox
ListBox Directory Reference

Directories

Themes

Files

XTPCheckListBox.h
XTPEditListBox.h
XTPListBox.h
XTPMarkupListBox.h
XTPShortcutListBox.h
XTPShortcutListBoxTheme.h


Toolkit Pro: Themes Directory Reference

  • Source
  • Controls
  • ListBox
  • Themes
Themes Directory Reference

Files

XTPListBoxThemeDefault.h
XTPListBoxThemeNativeWindows10.h
XTPListBoxThemeNativeWindows11.h
XTPListBoxThemeOffice2003.h
XTPListBoxThemeOffice2013.h
XTPListBoxThemeOfficeXP.h
XTPListBoxThemeResource.h
XTPListBoxThemeVisualStudio2015.h
XTPListBoxThemeVisualStudio2017.h
XTPListBoxThemeVisualStudio2019.h
XTPListBoxThemeVisualStudio2022.h


Toolkit Pro: XTPListBoxThemeDefault.h File Reference

  • Source
  • Controls
  • ListBox
  • Themes
Classes
XTPListBoxThemeDefault.h File Reference

Go to the source code of this file.

Classes

class CXTPListBoxThemeDefault
CXTPListBoxThemeDefault is used by CXTPListBox to draw a default style list box. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPListBoxThemeNativeWindows10.h File Reference

  • Source
  • Controls
  • ListBox
  • Themes
Classes
XTPListBoxThemeNativeWindows10.h File Reference

Go to the source code of this file.

Classes

class CXTPListBoxThemeNativeWindows10
CXTPListBoxThemeNativeWindows10 is used by CXTPListBox to draw a Native Windows 10 style list box. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPListBoxThemeNativeWindows11.h File Reference

  • Source
  • Controls
  • ListBox
  • Themes
Classes
XTPListBoxThemeNativeWindows11.h File Reference

Go to the source code of this file.

Classes

class CXTPListBoxThemeNativeWindows11
CXTPListBoxThemeNativeWindows11 is used by CXTPListBox to draw a Native Windows 10 style list box. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPListBoxThemeOffice2003.h File Reference

  • Source
  • Controls
  • ListBox
  • Themes
Classes
XTPListBoxThemeOffice2003.h File Reference

Go to the source code of this file.

Classes

class CXTPListBoxThemeOffice2003
CXTPListBoxThemeOffice2003 is used by CXTPListBox to draw an Office 2003 style list box. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPListBoxThemeOffice2013.h File Reference

  • Source
  • Controls
  • ListBox
  • Themes
Classes
XTPListBoxThemeOffice2013.h File Reference

Go to the source code of this file.

Classes

class CXTPListBoxThemeOffice2013
CXTPListBoxThemeOffice2013 is used by CXTPListBox to draw an Office 2013 style list box. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPListBoxThemeOfficeXP.h File Reference

  • Source
  • Controls
  • ListBox
  • Themes
Classes
XTPListBoxThemeOfficeXP.h File Reference

Go to the source code of this file.

Classes

class CXTPListBoxThemeOfficeXP
CXTPListBoxThemeOfficeXP is used by CXTPListBox to draw an Office XP style list box. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPListBoxThemeResource.h File Reference

  • Source
  • Controls
  • ListBox
  • Themes
Classes
XTPListBoxThemeResource.h File Reference

Go to the source code of this file.

Classes

class CXTPListBoxThemeResource
CXTPListBoxThemeResource is used by CXTPListBox to draw a resource style list box. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPListBoxThemeVisualStudio2015.h File Reference

  • Source
  • Controls
  • ListBox
  • Themes
Classes
XTPListBoxThemeVisualStudio2015.h File Reference

Go to the source code of this file.

Classes

class CXTPListBoxThemeVisualStudio2015
CXTPListBoxThemeVisualStudio2015 is used by CXTPListBox to draw a Visual Studio 2015 style list box. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPListBoxThemeVisualStudio2017.h File Reference

  • Source
  • Controls
  • ListBox
  • Themes
Classes
XTPListBoxThemeVisualStudio2017.h File Reference

Go to the source code of this file.

Classes

class CXTPListBoxThemeVisualStudio2017
CXTPListBoxThemeVisualStudio2017 is used by CXTPListBox to draw a Visual Studio 2017 style list box. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPListBoxThemeVisualStudio2019.h File Reference

  • Source
  • Controls
  • ListBox
  • Themes
Classes
XTPListBoxThemeVisualStudio2019.h File Reference

Go to the source code of this file.

Classes

class CXTPListBoxThemeVisualStudio2019
CXTPListBoxThemeVisualStudio2019 is used by CXTPListBox to draw a Visual Studio 2019 style list box. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPListBoxThemeVisualStudio2022.h File Reference

  • Source
  • Controls
  • ListBox
  • Themes
Classes
XTPListBoxThemeVisualStudio2022.h File Reference

Go to the source code of this file.

Classes

class CXTPListBoxThemeVisualStudio2022
CXTPListBoxThemeVisualStudio2022 is used by CXTPListBox to draw a Visual Studio 2022 style list box. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPCheckListBox.h File Reference

  • Source
  • Controls
  • ListBox
Classes
XTPCheckListBox.h File Reference

Go to the source code of this file.

Classes

class | CXTPCheckListBox
The CXTPCheckListBox class is a CXTPListBox derived class. More...
class | CXTPCheckListBox::CCheckListState
CCheckListState is a helper class used by CXTPCheckListBox that contains information about the checkbox image that is used by the check list box. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPEditListBox.h File Reference

  • Source
  • Controls
  • ListBox
Classes | Variables
XTPEditListBox.h File Reference

Go to the source code of this file.

Classes

class | CXTPEditListBoxToolBar
CXTPEditListBoxToolBar is a CStatic derived class. More...
class | CXTPEditListBox
CXTPEditListBox is a CXTPListBox derived class. More...

Variables

const DWORD | LBS_XTP_DEFAULT = 0x0000
const DWORD | LBS_XTP_CHOOSEDIR = 0x0001
const DWORD | LBS_XTP_CHOOSEFILE = 0x0002
const DWORD | LBS_XTP_NOTOOLBAR = 0x0008
const DWORD | LBS_XTP_BROWSE = 0x0010
Browse button.
const DWORD | LBS_XTP_HIDE_UP_DOWN = 0x0020
Hide Up/Down buttons.
const DWORD | LBS_XTP_ONLY_UP_DOWN = 0x0040
Only Up/Down buttons.
const DWORD | LBS_XTP_BROWSE_ONLY = 0x0080
Browse button.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Variable Documentation

◆ LBS_XTP_CHOOSEDIR

const DWORD LBS_XTP_CHOOSEDIR = 0x0001
See also
CXTPEditListBox::SetListEditStyle

◆ LBS_XTP_CHOOSEFILE

const DWORD LBS_XTP_CHOOSEFILE = 0x0002
See also
CXTPEditListBox::SetListEditStyle

◆ LBS_XTP_DEFAULT

const DWORD LBS_XTP_DEFAULT = 0x0000
See also
CXTPEditListBox::SetListEditStyle

◆ LBS_XTP_NOTOOLBAR

const DWORD LBS_XTP_NOTOOLBAR = 0x0008
See also
CXTPEditListBox::SetListEditStyle


Toolkit Pro: XTPListBox.h File Reference

  • Source
  • Controls
  • ListBox
Classes | Typedefs | Enumerations
XTPListBox.h File Reference

Go to the source code of this file.

Classes

class | CXTPListBoxTheme
CXTPListBoxTheme is the base class used by CXTPListBox themes to draw the list box control. More...
class | CXTPListBox
CXTPListBox is a CListBox derived class. More...
class | CXTPScrollableListBoxT< ListBoxBase >
An adaptor for any CListBox derived control that overrides standard scrollbars with custom scrollbars. More...

Typedefs

typedef CXTPScrollableListBoxT< CXTPListBox > CXTPScrollableListBox
Type alias for a CXTPListBox derived scrollable control.

Enumerations

enum XTPListBoxStyle {
xtpListBoxStandard , xtpListBoxOfficeXP , xtpListBoxOffice2007 , xtpListBoxOffice2013 ,
xtpListBoxOffice2016 = xtpListBoxOffice2013 , xtpListBoxVisualStudio2015 , xtpListBoxVisualStudio2017 , xtpListBoxVisualStudio2019 ,
xtpListBoxVisualStudio2022 , xtpListBoxNativeWindows10 , xtpListBoxNativeWindows11
}
Constants used by the CXTPListBox control to determine the current theme style that has been set. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Enumeration Type Documentation

◆ XTPListBoxStyle

enum XTPListBoxStyle

Constants used by the CXTPListBox control to determine the current theme style that has been set.

Enumerator
xtpListBoxStandard | Default theme.
xtpListBoxOfficeXP | Office XP style theme.
xtpListBoxOffice2007 | Office 2007 style theme.
xtpListBoxOffice2013 | Office 2013 style theme.
xtpListBoxOffice2016 | Office 2016 style theme.
xtpListBoxVisualStudio2015 | Visual Studio 2015 style theme.
xtpListBoxVisualStudio2017 | Visual Studio 2017 style theme.
xtpListBoxVisualStudio2019 | Visual Studio 2019 style theme.
xtpListBoxVisualStudio2022 | Visual Studio 2022 style theme.
xtpListBoxNativeWindows10 | Native Windows 10 style theme.
xtpListBoxNativeWindows11 | Native Windows 11 style theme.


Toolkit Pro: XTPMarkupListBox.h File Reference

  • Source
  • Controls
  • ListBox
XTPMarkupListBox.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPShortcutListBox.h File Reference

  • Source
  • Controls
  • ListBox
Classes
XTPShortcutListBox.h File Reference

Go to the source code of this file.

Classes

class | CXTPShortcutListBox
CCXTPShortcutListBox is a CListBox derived class. More...
struct | CXTPShortcutListBox::CONTENT_ITEM
CONTENT_ITEM structure is used by the CXTPShortcutListBox class to maintain information about a particular menu item. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPShortcutListBoxTheme.h File Reference

  • Source
  • Controls
  • ListBox
Classes
XTPShortcutListBoxTheme.h File Reference

Go to the source code of this file.

Classes

class | CXTPShortcutListBoxTheme
CXTPShortcutListBoxTheme is used to draw the CXTPShortcutListBox object. More...
class | CXTPShortcutListBoxThemeOfficeXP
Class CXTPShortcutListBoxThemeOfficeXP is derived from CXTPShortcutListBoxTheme. More...
class | CXTPShortcutListBoxThemeOffice2003
Class CXTPShortcutListBoxThemeOffice2003 is derived from CXTPShortcutListBoxThemeXP. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: Popup Directory Reference

  • Source
  • Controls
  • Popup
Popup Directory Reference

Directories

Themes

Files

XTPColorPopup.h
XTPColorSelectorCtrl.h
XTPPopupControl.h
XTPPopupItem.h
XTPPopupPaintManager.h
XTPTipWindow.h


Toolkit Pro: Themes Directory Reference

  • Source
  • Controls
  • Popup
  • Themes
Themes Directory Reference

Files

XTPPopupThemeMSN.h
XTPPopupThemeOffice2000.h
XTPPopupThemeOffice2003.h
XTPPopupThemeOffice2013.h
XTPPopupThemeOfficeXP.h
XTPPopupThemeResource.h


Toolkit Pro: XTPPopupThemeMSN.h File Reference

  • Source
  • Controls
  • Popup
  • Themes
Classes
XTPPopupThemeMSN.h File Reference

Go to the source code of this file.

Classes

class CXTPPopupThemeMSN
CXTPPopupThemeMSN is a class used to perform MSN Messenger drawing tasks. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPPopupThemeOffice2000.h File Reference

  • Source
  • Controls
  • Popup
  • Themes
Classes
XTPPopupThemeOffice2000.h File Reference

Go to the source code of this file.

Classes

class CXTPPopupThemeOffice2000
CXTPPopupThemeOffice2000 is a class used to perform Office 2000 drawing tasks. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPPopupThemeOffice2003.h File Reference

  • Source
  • Controls
  • Popup
  • Themes
Classes
XTPPopupThemeOffice2003.h File Reference

Go to the source code of this file.

Classes

class CXTPPopupThemeOffice2003
CXTPPopupThemeOffice2003 is a class used to perform Office 2003 drawing tasks. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPPopupThemeOffice2013.h File Reference

  • Source
  • Controls
  • Popup
  • Themes
Classes
XTPPopupThemeOffice2013.h File Reference

Go to the source code of this file.

Classes

class CXTPPopupThemeOffice2013
CXTPPopupThemeOffice2013 is a class used to perform Office 2013 drawing tasks. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPPopupThemeOfficeXP.h File Reference

  • Source
  • Controls
  • Popup
  • Themes
Classes
XTPPopupThemeOfficeXP.h File Reference

Go to the source code of this file.

Classes

class CXTPPopupThemeOfficeXP
CXTPPopupThemeOfficeXP is a class used to perform Office XP drawing tasks. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPPopupThemeResource.h File Reference

  • Source
  • Controls
  • Popup
  • Themes
Classes
XTPPopupThemeResource.h File Reference

Go to the source code of this file.

Classes

class CXTPPopupThemeResource
CXTPPopupThemeResource is a class used to perform resource drawing tasks. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPColorPopup.h File Reference

  • Source
  • Controls
  • Popup
Classes
XTPColorPopup.h File Reference

Go to the source code of this file.

Classes

class CXTPColorPopup
CXTPColorPopup is a CXTPColorSelectorCtrl derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPColorSelectorCtrl.h File Reference

  • Source
  • Controls
  • Popup
Classes | Typedefs
XTPColorSelectorCtrl.h File Reference

Go to the source code of this file.

Classes

struct | XTP_PICK_BUTTON
XTP_PICK_BUTTON structure is used by the CXTPColorSelectorCtrl class to support a user-defined color list. More...
class | CXTPColorSelectorCtrl
CXTPColorSelectorCtrl is a CWnd derived class. More...
struct | CXTPColorSelectorCtrl::COLOR_CELL
COLOR_CELL structure is used by the CXTPColorSelectorCtrl class to maintain information about a particular color cell. More...
class | CXTPColorSelectorCtrlTheme
CXTPColorSelectorCtrlTheme is derived from CXTPControlThemeManagerStyle to handle theme specific visualizations for the CXTPColorSelectorCtrl class. More...
class | CXTPColorSelectorCtrlThemeOfficeXP
CXTPColorSelectorCtrlThemeOfficeXP is derived from CXTPColorSelectorCtrlTheme to handle theme specific visualizations for the CXTPColorSelectorCtrl class. More...
class | CXTPColorSelectorCtrlThemeOffice2003
CXTPColorSelectorCtrlThemeOffice2003 is derived from CXTPColorSelectorCtrlThemeOfficeXP to handle theme specific visualizations for the CXTPColorSelectorCtrl class. More...
class | CXTPColorSelectorCtrlThemeResource
CXTPColorSelectorCtrlThemeResource is derived from CXTPColorSelectorCtrlThemeOfficeXP to handle theme specific visualizations for the CXTPColorSelectorCtrl class. More...
class | CXTPColorSelectorCtrlThemeOffice2013
CXTPColorSelectorCtrlThemeOffice2013 is derived from CXTPColorSelectorCtrlTheme to handle theme specific visualizations for the CXTPColorSelectorCtrl class. More...
class | CXTPColorSelectorCtrlThemeVisualStudio2015
CXTPColorSelectorCtrlThemeVisualStudio2015 is derived from CXTPColorSelectorCtrlThemeOffice2013 to handle theme specific visualizations for the CXTPColorSelectorCtrl class. More...
class | CXTPColorSelectorCtrlThemeVisualStudio2017
CXTPColorSelectorCtrlThemeVisualStudio2017 is derived from CXTPColorSelectorCtrlThemeVisualStudio2015 to handle theme specific visualizations for the CXTPColorSelectorCtrl class. More...
class | CXTPColorSelectorCtrlThemeVisualStudio2019
CXTPColorSelectorCtrlThemeVisualStudio2019 is derived from CXTPColorSelectorCtrlThemeVisualStudio2015 to handle theme specific visualizations for the CXTPColorSelectorCtrl class. More...
class | CXTPColorSelectorCtrlThemeVisualStudio2022
CXTPColorSelectorCtrlThemeVisualStudio2022 is derived from CXTPColorSelectorCtrlThemeVisualStudio2015 to handle theme specific visualizations for the CXTPColorSelectorCtrl class. More...
class | CXTPColorSelectorCtrlThemeNativeWindows10
CXTPColorSelectorCtrlThemeNativeWindows10 is derived from CXTPColorSelectorCtrlThemeVisualStudio2015 to handle theme specific visualizations for the CXTPColorSelectorCtrl class. More...
class | CXTPColorSelectorCtrlThemeNativeWindows11
CXTPColorSelectorCtrlThemeNativeWindows11 is derived from CXTPColorSelectorCtrlThemeVisualStudio2015 to handle theme specific visualizations for the CXTPColorSelectorCtrl class. More...

Typedefs

typedef CArray< XTP_PICK_BUTTON, XTP_PICK_BUTTON & > CXTPPickBtnArray
CXTPPickBtnArray is used to manage a collection of XTP_PICK_BUTTON objects.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPPopupControl.h File Reference

  • Source
  • Controls
  • Popup
Classes | Enumerations | Variables
XTPPopupControl.h File Reference

Go to the source code of this file.

Classes

class | CXTPPopupControl
CXTPPopupControl is a class for control of a pop-up window. More...
struct | CXTPPopupControl::POPUPSTATE
Pop-up state descriptor. More...

Enumerations

enum XTPPopupPaintTheme {
xtpPopupThemeOffice2000 , xtpPopupThemeOfficeXP , xtpPopupThemeOffice2003 , xtpPopupThemeMSN ,
xtpPopupThemeResource , xtpPopupThemeCustom , xtpPopupThemeOffice2013 , xtpPopupThemeOffice2016 = xtpPopupThemeOffice2013
}
Enumeration used to determine the pop-up window theme in use. More...
enum | XTPPopupLocation { xtpPopupLocationNearTaskBar , xtpPopupLocationBottomRight , xtpPopupLocationCenter }
Enumeration used to determine the location where the pop-up control is displayed. More...
enum | XTPPopupAnimation { xtpPopupAnimationNone , xtpPopupAnimationFade , xtpPopupAnimationSlide , xtpPopupAnimationUnfold }
Enumeration used to determine the pop-up window animation in use. More...
enum | XTPPopupState { xtpPopupStateClosed , xtpPopupStateExpanding , xtpPopupStateShow , xtpPopupStateCollapsing }
Enumeration used to determine the current pop-up window state. More...

Variables

const UINT | XTPWM_POPUPCONTROL_NOTIFY = (WM_XTP_CONTROLS_BASE + 37)
The XTPWM_POPUPCONTROL_NOTIFY message is sent to the CXTPPopupControl owner window whenever an action occurs within the CXTPPopupControl.
const UINT | XTP_PCN_ITEMCLICK = 1
XTP_PCN_ITEMCLICK is used to indicate that the user clicked on a pop-up control item.
const UINT | XTP_PCN_STATECHANGED = 2
XTP_PCN_STATECHANGED is used to indicate that the state of the pop-up control has changed.
const UINT | XTP_PCN_POSCHANGED = 3
XTP_PCN_POSCHANGED is used to indicate that the user moved the pop-up control with the mouse.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Enumeration Type Documentation

◆ XTPPopupAnimation

enum XTPPopupAnimation

Enumeration used to determine the pop-up window animation in use.

Example:

m_wndPopupControl.SetPopupAnimation(xtpPopupAnimationFade);
See also
CXTPPopupControl::SetPopupAnimation, CXTPPopupControl::GetPopupAnimation
xtpPopupAnimationNone, xtpPopupAnimationFade, xtpPopupAnimationSlide, xtpPopupAnimationUnfold>
Enumerator
xtpPopupAnimationNone | Animation is not used.
xtpPopupAnimationFade | Fade method animation.
xtpPopupAnimationSlide | Slide method animation.
xtpPopupAnimationUnfold | Unfold method animation.

◆ XTPPopupLocation

enum XTPPopupLocation

Enumeration used to determine the location where the pop-up control is displayed.

Enumerator
xtpPopupLocationNearTaskBar | Displays in the bottom right of the screen right above the taskbar.
xtpPopupLocationBottomRight | Displays in the bottom right of the screen.
xtpPopupLocationCenter | Displays in the center of the screen.

◆ XTPPopupPaintTheme

enum XTPPopupPaintTheme

Enumeration used to determine the pop-up window theme in use.

Example:

m_wndPopupControl.SetTheme(xtpPopupThemeOffice2000);
See also
CXTPPopupControl::SetTheme, CXTPPopupControl::GetTheme
xtpPopupThemeOffice2000, xtpPopupThemeOfficeXP, xtpPopupThemeOffice2003, xtpPopupThemeMSN, xtpPopupThemeCustom, xtpPopupThemeOffice2013, xtpPopupThemeOffice2016>
Enumerator
xtpPopupThemeOffice2000 | Office 2000 pop-up theme.
xtpPopupThemeOfficeXP | Office XP pop-up theme.
xtpPopupThemeOffice2003 | Office 2003 pop-up theme.
xtpPopupThemeMSN | MSN Messenger pop-up theme.
xtpPopupThemeResource | A resource based theme.
xtpPopupThemeCustom | Custom pop-up theme.
xtpPopupThemeOffice2013 | Office 2013 pop-up theme.
xtpPopupThemeOffice2016 | Office 2016 pop-up theme.

◆ XTPPopupState

enum XTPPopupState

Enumeration used to determine the current pop-up window state.

Example:

if (pControl->GetPopupState() == xtpPopupStateClosed)
{
   EnableItems(TRUE);
}
See also
CXTPPopupControl::GetPopupState, CXTPPopupControl::SetPopupState
xtpPopupStateClosed, xtpPopupStateExpanding, xtpPopupStateShow, xtpPopupStateCollapsing>
Enumerator
xtpPopupStateClosed | The pop-up window is closed.
xtpPopupStateExpanding | The pop-up window is expanding.
xtpPopupStateShow | The pop-up window is shown.
xtpPopupStateCollapsing | The pop-up window is collapsing.

Variable Documentation

◆ XTP_PCN_ITEMCLICK

const UINT XTP_PCN_ITEMCLICK = 1

XTP_PCN_ITEMCLICK is used to indicate that the user clicked on a pop-up control item.

XTP_PCN_ITEMCLICK is sent in the XTPWM_POPUPCONTROL_NOTIFY message to the owner window when the user has clicked on a pop-up control item. Example: See example of XTPWM_POPUPCONTROL_NOTIFY.

See also
XTPWM_POPUPCONTROL_NOTIFY, XTP_PCN_STATECHANGED

◆ XTP_PCN_POSCHANGED

const UINT XTP_PCN_POSCHANGED = 3

XTP_PCN_POSCHANGED is used to indicate that the user moved the pop-up control with the mouse.

See also
XTPWM_POPUPCONTROL_NOTIFY

◆ XTP_PCN_STATECHANGED

const UINT XTP_PCN_STATECHANGED = 2

XTP_PCN_STATECHANGED is used to indicate that the state of the pop-up control has changed.

XTP_PCN_STATECHANGED is sent in the XTPWM_POPUPCONTROL_NOTIFY message to the owner window when the state of the pop-up control has changed. It can be one of the following states: xtpPopupStateClosed: Indicates that the pop-up window is closed. xtpPopupStateExpanding: Indicates that the pop-up window is expanding. xtpPopupStateShow: Indicates that the pop-up window is shown. xtpPopupStateCollapsing: Indicates that the pop-up window is collapsing. Example: See example of XTPWM_POPUPCONTROL_NOTIFY.

See also
XTPWM_POPUPCONTROL_NOTIFY, XTP_PCN_ITEMCLICK

◆ XTPWM_POPUPCONTROL_NOTIFY

const UINT XTPWM_POPUPCONTROL_NOTIFY = (WM_XTP_CONTROLS_BASE + 37)

The XTPWM_POPUPCONTROL_NOTIFY message is sent to the CXTPPopupControl owner window whenever an action occurs within the CXTPPopupControl.

Parameters
nAction Value of wParam specifies a pop-up control value that indicates the user's request. Can be any of the values listed in the Remarks section.

nAction parameter can be one of the following: XTP_PCN_ITEMCLICK: Indicates that the user clicked on the pop-up control item. XTP_PCN_STATECHANGED: Indicates that the state of the control changed.

Returns
If the application is to process this message, then the return value should be TRUE. Otherwise, the return value is FALSE. Example: Here is an example of how an application would process the XTPWM_POPUPCONTROL_NOTIFY message:

BEGIN_MESSAGE_MAP(CMainFrame, CFrameWnd)
   //{{AFX_MSG_MAP(CMainFrame)
   ON_MESSAGE(XTPWM_POPUPCONTROL_NOTIFY, OnPopUpNotify)
   //}}AFX_MSG_MAP
END_MESSAGE_MAP()

LRESULT CMainFrame::OnPopUpNotify(WPARAM wParam, LPARAM lParam)
{
   if (wParam == XTP_PCN_ITEMCLICK)
   {
      CXTPPopupItem* pItem = (CXTPPopupItem*)lParam;
      _ASSERTE(pItem);

      m_wndPopupControl.Close();

      if (pItem->GetID() == ID_GOTO_SITE)
      {
         ShellExecute(NULL, _T("open"), _T("http://www.codejock.com/"), NULL, NULL,
            SW_SHOW);
      }
   }
   else if (wParam == XTP_PCN_STATECHANGED)
   {
      CXTPPopupControl* pControl = (CXTPPopupControl*)lParam;
      _ASSERTE(pControl);

      if (pControl->GetPopupState() == xtpPopupStateClosed)
      {
         EnableItems(TRUE);
      }
   }
   return TRUE;
}
See also
XTP_PCN_ITEMCLICK, XTP_PCN_STATECHANGED, CXTPPopupControl


Toolkit Pro: XTPPopupItem.h File Reference

  • Source
  • Controls
  • Popup
Classes | Macros | Enumerations
XTPPopupItem.h File Reference

Go to the source code of this file.

Classes

class CXTPPopupItem
CXTPPopupItem is a class used to manage a pop-up item object. More...

Macros

#define XTP_ID_POPUP_CLOSE -1
Special ID for close item.

Enumerations

enum XTPPopupItemIcon { xtpPopupItemIconNormal = 1 , xtpPopupItemIconSelected = 2 , xtpPopupItemIconPressed = 4 }
Enumeration used to determine the icon type of CXTPPopupItem. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Enumeration Type Documentation

◆ XTPPopupItemIcon

enum XTPPopupItemIcon

Enumeration used to determine the icon type of CXTPPopupItem.

Example:

CXTPPopupItem* pItemIcon = m_wndPopupControl.AddItem(
new CXTPPopupItem(CRect(14, 40, 20, 49)));
pItemIcon->SetIcons(IDB_LOGOOFFICE, 0, xtpPopupItemIconNormal);
See also
CXTPPopupItem::SetIcon, CXTPPopupItem::SetIcons
xtpPopupItemIconNormal, xtpPopupItemIconSelected, xtpPopupItemIconPressed
Enumerator
xtpPopupItemIconNormal | Normal icon handler.
xtpPopupItemIconSelected | Selected icon handler.
xtpPopupItemIconPressed | Pressed icon handler.


Toolkit Pro: XTPPopupPaintManager.h File Reference

  • Source
  • Controls
  • Popup
Classes
XTPPopupPaintManager.h File Reference

Go to the source code of this file.

Classes

class CXTPPopupPaintManager
CXTPPopupPaintManager is a class used to perform specialized drawing tasks. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTipWindow.h File Reference

  • Source
  • Controls
  • Popup
Classes | Variables
XTPTipWindow.h File Reference

Go to the source code of this file.

Classes

class CXTPTipWindow
CXTPTipWindow is a CWnd derived class. More...

Variables

const DWORD | TWS_XTP_THICKBORDER = 0x0001
const DWORD | TWS_XTP_DROPSHADOW = 0x0002
const DWORD | TWS_XTP_ALPHASHADOW = 0x0004

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Variable Documentation

◆ TWS_XTP_ALPHASHADOW

const DWORD TWS_XTP_ALPHASHADOW = 0x0004
See also
CXTPTipWindow::ShowTipWindow

◆ TWS_XTP_DROPSHADOW

const DWORD TWS_XTP_DROPSHADOW = 0x0002
See also
CXTPTipWindow::ShowTipWindow

◆ TWS_XTP_THICKBORDER

const DWORD TWS_XTP_THICKBORDER = 0x0001
See also
CXTPTipWindow::ShowTipWindow


Toolkit Pro: Preview Directory Reference

  • Source
  • Controls
  • Preview
Preview Directory Reference

Files

XTPPreviewAbstract.h
XTPPreviewCtrl.h
XTPPreviewHostWindow.h
XTPPreviewNavigatorWindow.h


Toolkit Pro: Providers Directory Reference

  • Source
  • Controls
  • Preview
  • Providers
Providers Directory Reference

Directories

CommonPicture
GIF
MSG
Svg
System
Text
XAML


Toolkit Pro: CommonPicture Directory Reference

  • Source
  • Controls
  • Preview
  • Providers
  • CommonPicture
CommonPicture Directory Reference

Files

XTPCommonPicturePreview.h
XTPCommonPicturePreviewProvider.h


Toolkit Pro: XTPCommonPicturePreview.h File Reference

  • Source
  • Controls
  • Preview
  • Providers
  • CommonPicture
XTPCommonPicturePreview.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPCommonPicturePreviewProvider.h File Reference

  • Source
  • Controls
  • Preview
  • Providers
  • CommonPicture
Classes
XTPCommonPicturePreviewProvider.h File Reference

Go to the source code of this file.

Classes

class CXTPCommonPicturePreviewProvider
Provides a preview handler for the common picture file types: BMP, PNG, TIF, TIFF, ICO, JPEG, JPG, EXIF, WMF, EMF. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: GIF Directory Reference

  • Source
  • Controls
  • Preview
  • Providers
  • GIF
GIF Directory Reference

Files

XTPGifPreview.h
XTPGifPreviewProvider.h


Toolkit Pro: XTPGifPreview.h File Reference

  • Source
  • Controls
  • Preview
  • Providers
  • GIF
XTPGifPreview.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPGifPreviewProvider.h File Reference

  • Source
  • Controls
  • Preview
  • Providers
  • GIF
Classes
XTPGifPreviewProvider.h File Reference

Go to the source code of this file.

Classes

class CXTPGifPreviewProvider
Provides a preview handler for static and animated GIF files. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: MSG Directory Reference

  • Source
  • Controls
  • Preview
  • Providers
  • MSG
MSG Directory Reference

Files

XTPMsgPreview.h
XTPMsgPreviewDialog.h
XTPMsgPreviewProvider.h


Toolkit Pro: XTPMsgPreview.h File Reference

  • Source
  • Controls
  • Preview
  • Providers
  • MSG
XTPMsgPreview.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMsgPreviewDialog.h File Reference

  • Source
  • Controls
  • Preview
  • Providers
  • MSG
XTPMsgPreviewDialog.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMsgPreviewProvider.h File Reference

  • Source
  • Controls
  • Preview
  • Providers
  • MSG
Classes
XTPMsgPreviewProvider.h File Reference

Go to the source code of this file.

Classes

class CXTPMsgPreviewProvider
Provides a preview handler for the Outlook Message (MSG) file type. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: Svg Directory Reference

  • Source
  • Controls
  • Preview
  • Providers
  • Svg
Svg Directory Reference

Files

XTPSvgPreview.h
XTPSvgPreviewProvider.h


Toolkit Pro: XTPSvgPreview.h File Reference

  • Source
  • Controls
  • Preview
  • Providers
  • Svg
XTPSvgPreview.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPSvgPreviewProvider.h File Reference

  • Source
  • Controls
  • Preview
  • Providers
  • Svg
Classes
XTPSvgPreviewProvider.h File Reference

Go to the source code of this file.

Classes

class CXTPSvgPreviewProvider
Provides a preview handler for XAML files that uses Markup components for rendering file contents. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: System Directory Reference

  • Source
  • Controls
  • Preview
  • Providers
  • System
System Directory Reference

Files

XTPSystemPreview.h
XTPSystemPreviewProvider.h


Toolkit Pro: XTPSystemPreview.h File Reference

  • Source
  • Controls
  • Preview
  • Providers
  • System
XTPSystemPreview.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPSystemPreviewProvider.h File Reference

  • Source
  • Controls
  • Preview
  • Providers
  • System
Classes
XTPSystemPreviewProvider.h File Reference

Go to the source code of this file.

Classes

class CXTPSystemPreviewProvider
Provides a preview handler that uses supported system means for previewing files. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: Text Directory Reference

  • Source
  • Controls
  • Preview
  • Providers
  • Text
Text Directory Reference

Files

XTPTextPreview.h
XTPTextPreviewProvider.h


Toolkit Pro: XTPTextPreview.h File Reference

  • Source
  • Controls
  • Preview
  • Providers
  • Text
XTPTextPreview.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTextPreviewProvider.h File Reference

  • Source
  • Controls
  • Preview
  • Providers
  • Text
Classes
XTPTextPreviewProvider.h File Reference

Go to the source code of this file.

Classes

class CXTPTextPreviewProvider
Provides a preview handler for the text file type (TXT). More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XAML Directory Reference

  • Source
  • Controls
  • Preview
  • Providers
  • XAML
XAML Directory Reference

Files

XTPXamlPreview.h
XTPXamlPreviewProvider.h


Toolkit Pro: XTPXamlPreview.h File Reference

  • Source
  • Controls
  • Preview
  • Providers
  • XAML
XTPXamlPreview.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPXamlPreviewProvider.h File Reference

  • Source
  • Controls
  • Preview
  • Providers
  • XAML
Classes
XTPXamlPreviewProvider.h File Reference

Go to the source code of this file.

Classes

class CXTPXamlPreviewProvider
Provides a preview handler for XAML files that uses Markup components for rendering file contents. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPPreviewAbstract.h File Reference

  • Source
  • Controls
  • Preview
Classes
XTPPreviewAbstract.h File Reference

Go to the source code of this file.

Classes

struct | IXTPPreview
The base interface for a preview handler implementation. More...
struct | IXTPPreviewHost
Interface implemented by the preview host control. More...
struct | IXTPPreviewProvider
Interface to be implemented by a preview provider. More...
class | CXTPPreviewProviderBase
Base class for a preview provider which implements common behavior to be exposed by a preview provider. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPPreviewCtrl.h File Reference

  • Source
  • Controls
  • Preview
Classes
XTPPreviewCtrl.h File Reference

Go to the source code of this file.

Classes

class CXTPPreviewCtrl
Implements the preview control that can display visual preview data provided by the best matching preview provider registered to the control. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPPreviewHostWindow.h File Reference

  • Source
  • Controls
  • Preview
XTPPreviewHostWindow.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPPreviewNavigatorWindow.h File Reference

  • Source
  • Controls
  • Preview
XTPPreviewNavigatorWindow.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: Progress Directory Reference

  • Source
  • Controls
  • Progress
Progress Directory Reference

Files

XTPMarqueeCtrl.h
XTPMarqueeCtrlPaintManager.h
XTPProgressCtrl.h
XTPProgressCtrlPaintManager.h


Toolkit Pro: XTPMarqueeCtrl.h File Reference

  • Source
  • Controls
  • Progress
Classes
XTPMarqueeCtrl.h File Reference

Go to the source code of this file.

Classes

class CXTPMarqueeCtrl
CXTPMarqueeCtrl is a CProgressCtrl derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMarqueeCtrlPaintManager.h File Reference

  • Source
  • Controls
  • Progress
Classes
XTPMarqueeCtrlPaintManager.h File Reference

Go to the source code of this file.

Classes

class | CXTPMarqueeCtrlPaintManager
The CXTPMarqueeCtrlPaintManager class is derived from CCmdTarget and is used by the progress bar to perform all default drawing routines. More...
class | CXTPMarqueeCtrlThemeFlat
The CXTPMarqueeCtrlThemeFlat class is derived from CXTPMarqueeCtrlPaintManager and is used by the progress bar to draw a flat style progress bar. More...
class | CXTPMarqueeCtrlThemeUltraFlat
The CXTPMarqueeCtrlThemeUltraFlat class is derived from CXTPMarqueeCtrlThemeFlat and is used by the progress bar to draw a flat style progress bar with no borders. More...
class | CXTPMarqueeCtrlThemeOffice2000
The CXTPMarqueeCtrlThemeFlat class is derived from CXTPMarqueeCtrlPaintManager and is used by the progress bar to draw an Office 2000 style progress bar. More...
class | CXTPMarqueeCtrlThemeOfficeXP
The CXTPMarqueeCtrlThemeXP class is derived from CXTPMarqueeCtrlThemeFlat and is used by the progress bar to draw an Office XP style progress bar. More...
class | CXTPMarqueeCtrlThemeOffice2003
The CXTPMarqueeCtrlThemeFlat class is derived from CXTPMarqueeCtrlPaintManager and is used by the progress bar to draw an Office 2003 style progress bar. More...
class | CXTPMarqueeCtrlThemeResource
The CXTPMarqueeCtrlThemeFlat class is derived from CXTPMarqueeCtrlPaintManager and is used by the progress bar to draw an progress bar using a resource DLL. More...
class | CXTPMarqueeCtrlThemeOffice2013
The CXTPMarqueeCtrlThemeFlat class is derived from CXTPMarqueeCtrlPaintManager and is used by the progress bar to draw an Office 2013 style progress bar. More...
class | CXTPMarqueeCtrlThemeVisualStudio2015
The CXTPMarqueeCtrlThemeFlat class is derived from CXTPMarqueeCtrlPaintManager and is used by the progress bar to draw a Visual Studio 2015 style progress bar. More...
class | CXTPMarqueeCtrlThemeVisualStudio2017
The CXTPMarqueeCtrlThemeFlat class is derived from CXTPMarqueeCtrlPaintManager and is used by the progress bar to draw a Visual Studio 2017 style progress bar. More...
class | CXTPMarqueeCtrlThemeVisualStudio2019
The CXTPMarqueeCtrlThemeFlat class is derived from CXTPMarqueeCtrlPaintManager and is used by the progress bar to draw a Visual Studio 2019 style progress bar. More...
class | CXTPMarqueeCtrlThemeVisualStudio2022
The CXTPMarqueeCtrlThemeFlat class is derived from CXTPMarqueeCtrlPaintManager and is used by the progress bar to draw a Visual Studio 2022 style progress bar. More...
class | CXTPMarqueeCtrlThemeNativeWinXP
The CXTPMarqueeCtrlThemeNativeWinXP class is derived from CXTPMarqueeCtrlPaintManager and is used by the progress bar to draw a native Windows style progress bar. More...
class | CXTPMarqueeCtrlThemeNativeWindows
The CXTPMarqueeCtrlThemeNativeWindows class is derived from CXTPMarqueeCtrlPaintManager and is used by the progress bar to draw a native Windows style progress bar. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPProgressCtrl.h File Reference

  • Source
  • Controls
  • Progress
Classes
XTPProgressCtrl.h File Reference

Go to the source code of this file.

Classes

class CXTPProgressCtrl
The ProgressBar control shows the progress of a lengthy operation by filling a rectangle with chunks from left to right. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPProgressCtrlPaintManager.h File Reference

  • Source
  • Controls
  • Progress
Classes
XTPProgressCtrlPaintManager.h File Reference

Go to the source code of this file.

Classes

struct | XTPPROGRESSDRAWSTRUCT
Struct used by the progress bar during paint operations. More...
class | CXTPProgressCtrlPaintManager
The CXTPProgressCtrlPaintManager class is derived from CXTPCmdTarget and is used by the progress bar to perform all default drawing routines. More...
class | CXTPProgressCtrlThemeFlat
The CXTPProgressCtrlThemeFlat class is derived from CXTPProgressCtrlPaintManager and is used by the progress bar to draw a flat style progress bar. More...
class | CXTPProgressCtrlThemeUltraFlat
The CXTPProgressCtrlThemeUltraFlat class is derived from CXTPProgressCtrlThemeFlat and is used by the progress bar to draw a flat style progress bar with no borders. More...
class | CXTPProgressCtrlThemeOffice2000
The CXTPProgressCtrlThemeFlat class is derived from CXTPProgressCtrlPaintManager and is used by the progress bar to draw an Office 2000 style progress bar. More...
class | CXTPProgressCtrlThemeOfficeXP
The CXTPProgressCtrlThemeXP class is derived from CXTPProgressCtrlThemeFlat and is used by the progress bar to draw an Office XP style progress bar. More...
class | CXTPProgressCtrlThemeOffice2003
The CXTPProgressCtrlThemeFlat class is derived from CXTPProgressCtrlPaintManager and is used by the progress bar to draw an Office 2003 style progress bar. More...
class | CXTPProgressCtrlThemeResource
The CXTPProgressCtrlThemeFlat class is derived from CXTPProgressCtrlPaintManager and is used by the progress bar to draw an progress bar using a resource DLL. More...
class | CXTPProgressCtrlThemeOffice2013
The CXTPProgressCtrlThemeFlat class is derived from CXTPProgressCtrlPaintManager and is used by the progress bar to draw an Office 2013 style progress bar. More...
class | CXTPProgressCtrlThemeVisualStudio2015
The CXTPProgressCtrlThemeFlat class is derived from CXTPProgressCtrlPaintManager and is used by the progress bar to draw a Visual Studio 2015 style progress bar. More...
class | CXTPProgressCtrlThemeNativeWinXP
The CXTPProgressCtrlThemeNativeWinXP class is derived from CXTPProgressCtrlPaintManager and is used by the progress bar to draw a native Windows style progress bar. More...
class | CXTPProgressCtrlThemeNativeWindows
The CXTPProgressCtrlThemeNativeWindows class is derived from CXTPProgressCtrlPaintManager and is used by the progress bar to draw a native Windows style progress bar. More...
class | CXTPProgressCtrlThemeVisualStudio2017
The CXTPProgressCtrlThemeVisualStudio2017 class is derived from CXTPProgressCtrlThemeOffice2013 and is used by the progress bar to draw a Visual Studio 2017 style progress bar. More...
class | CXTPProgressCtrlThemeVisualStudio2019
The CXTPProgressCtrlThemeVisualStudio2019 class is derived from CXTPProgressCtrlThemeOffice2013 and is used by the progress bar to draw a Visual Studio 2019 style progress bar. More...
class | CXTPProgressCtrlThemeVisualStudio2022
The CXTPProgressCtrlThemeVisualStudio2022 class is derived from CXTPProgressCtrlThemeOffice2013 and is used by the progress bar to draw a Visual Studio 2022 style progress bar. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: Resize Directory Reference

  • Source
  • Controls
  • Resize
Resize Directory Reference

Files

XTPResize.h
XTPResizeDialog.h
XTPResizeFormView.h
XTPResizeGroupBox.h
XTPResizePoint.h
XTPResizePropertyPage.h
XTPResizePropertySheet.h
XTPResizeRect.h


Toolkit Pro: XTPResize.h File Reference

  • Source
  • Controls
  • Resize
Classes | Enumerations
XTPResize.h File Reference

Go to the source code of this file.

Classes

class | CXTPResizeItem
CXTPResizeItem is a standalone helper class. More...
class | CXTPSizeIcon
The CXTPSizeIcon class is a CStatic derived helper class. More...
class | CXTPResize
CXTPResize is a base class. More...

Enumerations

enum XTPResize {
xtpResizeNoSizeIcon = 0x01 , xtpResizeNoHorizontal = 0x02 , xtpResizeNoVertical = 0x04 , xtpResizeNoMinsize = 0x08 ,
xtpResizeNoClipChildren = 0x10 , xtpResizeNoTransparentGroup = 0x20
}
Enumeration used to determine attributes for resizing windows. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Enumeration Type Documentation

◆ XTPResize

enum XTPResize

Enumeration used to determine attributes for resizing windows.

XTPResize type defines the constants used by the CXTPResize class to determine how a window will appear when it is resized.

See also
CXTPResize
xtpResizeNoSizeIcon, xtpResizeNoHorizontal, xtpResizeNoVertical, xtpResizeNoMinsize, xtpResizeNoClipChildren, xtpResizeNoTransparentGroup
Enumerator
xtpResizeNoSizeIcon | Do not add size icon.
xtpResizeNoHorizontal | No horizontal resizing.
xtpResizeNoVertical | No vertical resizing.
xtpResizeNoMinsize | Do not require a minimum size.
xtpResizeNoClipChildren | Do not set clip children style.
xtpResizeNoTransparentGroup | Do not set transparent style for group boxes.


Toolkit Pro: XTPResizeDialog.h File Reference

  • Source
  • Controls
  • Resize
Classes
XTPResizeDialog.h File Reference

Go to the source code of this file.

Classes

class CXTPResizeDialog
CXTPResizeDialog is a multiple inheritance class derived from CDialog and CXTPResize. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPResizeFormView.h File Reference

  • Source
  • Controls
  • Resize
Classes
XTPResizeFormView.h File Reference

Go to the source code of this file.

Classes

class CXTPResizeFormView
CXTPResizeFormView is a multiple inheritance class derived from CFormView and CXTPResize. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPResizeGroupBox.h File Reference

  • Source
  • Controls
  • Resize
Classes
XTPResizeGroupBox.h File Reference

Go to the source code of this file.

Classes

class CXTPResizeGroupBox
CXTPResizeGroupBox is a CButton derived class that can be used to display a flicker free group box while resizing. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPResizePoint.h File Reference

  • Source
  • Controls
  • Resize
Classes | Macros
XTPResizePoint.h File Reference

Go to the source code of this file.

Classes

struct | XTP_RESIZEPOINT
The XTP_RESIZEPOINT structure is used by the CXTPResizePoint class for defining single-precision floating point x- and y- coordinates of a point. More...
class | CXTPResizePoint
CXTPResizePoint is an XTP_RESIZEPOINT structure derived class. More...

Macros

#define | XTP_ANCHOR_BOTTOMCENTER CXTPResizePoint(.5, 1)
CXTPResizePoint constants used by the CXTPResize class for defining the anchor position for a child in a resizable window.
#define | XTP_ANCHOR_BOTTOMLEFT CXTPResizePoint(0, 1)
CXTPResizePoint constants used by the CXTPResize class for defining the anchor position for a child in a resizable window.
#define | XTP_ANCHOR_BOTTOMRIGHT CXTPResizePoint(1, 1)
CXTPResizePoint constants used by the CXTPResize class for defining the anchor position for a child in a resizable window.
#define | XTP_ANCHOR_MIDDLECENTER CXTPResizePoint(.5, .5)
CXTPResizePoint constants used by the CXTPResize class for defining the anchor position for a child in a resizable window.
#define | XTP_ANCHOR_MIDDLELEFT CXTPResizePoint(0, .5)
CXTPResizePoint constants used by the CXTPResize class for defining the anchor position for a child in a resizable window.
#define | XTP_ANCHOR_MIDDLERIGHT CXTPResizePoint(1, .5)
CXTPResizePoint constants used by the CXTPResize class for defining the anchor position for a child in a resizable window.
#define | XTP_ANCHOR_TOPLEFT CXTPResizePoint(0, 0)
CXTPResizePoint constants used by the CXTPResize class for defining the anchor position for a child in a resizable window.
#define | XTP_ANCHOR_TOPRIGHT CXTPResizePoint(1, 0)
CXTPResizePoint constants used by the CXTPResize class for defining the anchor position for a child in a resizable window.
#define | XTP_ANCHOR_TOPCENTER CXTPResizePoint(.5, 0)
CXTPResizePoint constants used by the CXTPResize class for defining the anchor position for a child in a resizable window.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Macro Definition Documentation

◆ XTP_ANCHOR_BOTTOMCENTER

#define XTP_ANCHOR_BOTTOMCENTER CXTPResizePoint(.5, 1)

CXTPResizePoint constants used by the CXTPResize class for defining the anchor position for a child in a resizable window.

XTP_ANCHOR_TOPLEFT Specifies a top left position. XTP_ANCHOR_TOPCENTER Specifies a top center position. XTP_ANCHOR_TOPRIGHT Specifies a top right position. XTP_ANCHOR_MIDDLELEFT Specifies a middle left position. XTP_ANCHOR_MIDDLECENTER Specifies a middle center position. XTP_ANCHOR_MIDDLERIGHT Specifies a middle right position. XTP_ANCHOR_BOTTOMLEFT Specifies a bottom left position. XTP_ANCHOR_BOTTOMCENTER Specifies a bottom center position. XTP_ANCHOR_BOTTOMRIGHT Specifies a bottom right position. Example: The following example demonstrates the use of CXTPResizePoint:

// Set control resizing.
SetResize(IDC_EDIT_MASKEDIT,   XTP_ANCHOR_TOPLEFT,     XTP_ANCHOR_TOPRIGHT);
SetResize(IDC_TXT_MASK,        XTP_ANCHOR_TOPCENTER,   XTP_ANCHOR_TOPRIGHT);
SetResize(IDC_LBOX_MASK,       XTP_ANCHOR_TOPCENTER,   XTP_ANCHOR_TOPRIGHT);
SetResize(IDC_BTN_UPDATE,      XTP_ANCHOR_TOPCENTER,   XTP_ANCHOR_TOPCENTER);
SetResize(IDC_EDIT_MASK,       XTP_ANCHOR_TOPLEFT,     XTP_ANCHOR_TOPCENTER);
SetResize(IDC_EDIT_PROMPT,     XTP_ANCHOR_TOPLEFT,     XTP_ANCHOR_TOPCENTER);
SetResize(IDC_EDIT_LITERAL,    XTP_ANCHOR_TOPLEFT,     XTP_ANCHOR_TOPCENTER);
SetResize(IDC_EDIT_DEFAULT,    XTP_ANCHOR_TOPLEFT,     XTP_ANCHOR_TOPCENTER);
SetResize(IDC_GBOX_PROPERTIES, XTP_ANCHOR_TOPLEFT,     XTP_ANCHOR_TOPCENTER);
SetResize(IDCANCEL,            XTP_ANCHOR_BOTTOMRIGHT, XTP_ANCHOR_BOTTOMRIGHT);
SetResize(IDOK,                XTP_ANCHOR_BOTTOMRIGHT, XTP_ANCHOR_BOTTOMRIGHT);
See also
CXTPResize, CXTPResizeDialog, CXTPResizeFormView, CXTPResizeGroupBox, CXTPResizePropertyPage, CXTPResizePropertySheet, CXTPResizePoint, CXTPResizeRect

◆ XTP_ANCHOR_BOTTOMLEFT

#define XTP_ANCHOR_BOTTOMLEFT CXTPResizePoint(0, 1)

CXTPResizePoint constants used by the CXTPResize class for defining the anchor position for a child in a resizable window.

XTP_ANCHOR_TOPLEFT Specifies a top left position. XTP_ANCHOR_TOPCENTER Specifies a top center position. XTP_ANCHOR_TOPRIGHT Specifies a top right position. XTP_ANCHOR_MIDDLELEFT Specifies a middle left position. XTP_ANCHOR_MIDDLECENTER Specifies a middle center position. XTP_ANCHOR_MIDDLERIGHT Specifies a middle right position. XTP_ANCHOR_BOTTOMLEFT Specifies a bottom left position. XTP_ANCHOR_BOTTOMCENTER Specifies a bottom center position. XTP_ANCHOR_BOTTOMRIGHT Specifies a bottom right position. Example: The following example demonstrates the use of CXTPResizePoint:

// Set control resizing.
SetResize(IDC_EDIT_MASKEDIT,   XTP_ANCHOR_TOPLEFT,     XTP_ANCHOR_TOPRIGHT);
SetResize(IDC_TXT_MASK,        XTP_ANCHOR_TOPCENTER,   XTP_ANCHOR_TOPRIGHT);
SetResize(IDC_LBOX_MASK,       XTP_ANCHOR_TOPCENTER,   XTP_ANCHOR_TOPRIGHT);
SetResize(IDC_BTN_UPDATE,      XTP_ANCHOR_TOPCENTER,   XTP_ANCHOR_TOPCENTER);
SetResize(IDC_EDIT_MASK,       XTP_ANCHOR_TOPLEFT,     XTP_ANCHOR_TOPCENTER);
SetResize(IDC_EDIT_PROMPT,     XTP_ANCHOR_TOPLEFT,     XTP_ANCHOR_TOPCENTER);
SetResize(IDC_EDIT_LITERAL,    XTP_ANCHOR_TOPLEFT,     XTP_ANCHOR_TOPCENTER);
SetResize(IDC_EDIT_DEFAULT,    XTP_ANCHOR_TOPLEFT,     XTP_ANCHOR_TOPCENTER);
SetResize(IDC_GBOX_PROPERTIES, XTP_ANCHOR_TOPLEFT,     XTP_ANCHOR_TOPCENTER);
SetResize(IDCANCEL,            XTP_ANCHOR_BOTTOMRIGHT, XTP_ANCHOR_BOTTOMRIGHT);
SetResize(IDOK,                XTP_ANCHOR_BOTTOMRIGHT, XTP_ANCHOR_BOTTOMRIGHT);
See also
CXTPResize, CXTPResizeDialog, CXTPResizeFormView, CXTPResizeGroupBox, CXTPResizePropertyPage, CXTPResizePropertySheet, CXTPResizePoint, CXTPResizeRect

◆ XTP_ANCHOR_BOTTOMRIGHT

#define XTP_ANCHOR_BOTTOMRIGHT CXTPResizePoint(1, 1)

CXTPResizePoint constants used by the CXTPResize class for defining the anchor position for a child in a resizable window.

XTP_ANCHOR_TOPLEFT Specifies a top left position. XTP_ANCHOR_TOPCENTER Specifies a top center position. XTP_ANCHOR_TOPRIGHT Specifies a top right position. XTP_ANCHOR_MIDDLELEFT Specifies a middle left position. XTP_ANCHOR_MIDDLECENTER Specifies a middle center position. XTP_ANCHOR_MIDDLERIGHT Specifies a middle right position. XTP_ANCHOR_BOTTOMLEFT Specifies a bottom left position. XTP_ANCHOR_BOTTOMCENTER Specifies a bottom center position. XTP_ANCHOR_BOTTOMRIGHT Specifies a bottom right position. Example: The following example demonstrates the use of CXTPResizePoint:

// Set control resizing.
SetResize(IDC_EDIT_MASKEDIT,   XTP_ANCHOR_TOPLEFT,     XTP_ANCHOR_TOPRIGHT);
SetResize(IDC_TXT_MASK,        XTP_ANCHOR_TOPCENTER,   XTP_ANCHOR_TOPRIGHT);
SetResize(IDC_LBOX_MASK,       XTP_ANCHOR_TOPCENTER,   XTP_ANCHOR_TOPRIGHT);
SetResize(IDC_BTN_UPDATE,      XTP_ANCHOR_TOPCENTER,   XTP_ANCHOR_TOPCENTER);
SetResize(IDC_EDIT_MASK,       XTP_ANCHOR_TOPLEFT,     XTP_ANCHOR_TOPCENTER);
SetResize(IDC_EDIT_PROMPT,     XTP_ANCHOR_TOPLEFT,     XTP_ANCHOR_TOPCENTER);
SetResize(IDC_EDIT_LITERAL,    XTP_ANCHOR_TOPLEFT,     XTP_ANCHOR_TOPCENTER);
SetResize(IDC_EDIT_DEFAULT,    XTP_ANCHOR_TOPLEFT,     XTP_ANCHOR_TOPCENTER);
SetResize(IDC_GBOX_PROPERTIES, XTP_ANCHOR_TOPLEFT,     XTP_ANCHOR_TOPCENTER);
SetResize(IDCANCEL,            XTP_ANCHOR_BOTTOMRIGHT, XTP_ANCHOR_BOTTOMRIGHT);
SetResize(IDOK,                XTP_ANCHOR_BOTTOMRIGHT, XTP_ANCHOR_BOTTOMRIGHT);
See also
CXTPResize, CXTPResizeDialog, CXTPResizeFormView, CXTPResizeGroupBox, CXTPResizePropertyPage, CXTPResizePropertySheet, CXTPResizePoint, CXTPResizeRect

◆ XTP_ANCHOR_MIDDLECENTER

#define XTP_ANCHOR_MIDDLECENTER CXTPResizePoint(.5, .5)

CXTPResizePoint constants used by the CXTPResize class for defining the anchor position for a child in a resizable window.

XTP_ANCHOR_TOPLEFT Specifies a top left position. XTP_ANCHOR_TOPCENTER Specifies a top center position. XTP_ANCHOR_TOPRIGHT Specifies a top right position. XTP_ANCHOR_MIDDLELEFT Specifies a middle left position. XTP_ANCHOR_MIDDLECENTER Specifies a middle center position. XTP_ANCHOR_MIDDLERIGHT Specifies a middle right position. XTP_ANCHOR_BOTTOMLEFT Specifies a bottom left position. XTP_ANCHOR_BOTTOMCENTER Specifies a bottom center position. XTP_ANCHOR_BOTTOMRIGHT Specifies a bottom right position. Example: The following example demonstrates the use of CXTPResizePoint:

// Set control resizing.
SetResize(IDC_EDIT_MASKEDIT,   XTP_ANCHOR_TOPLEFT,     XTP_ANCHOR_TOPRIGHT);
SetResize(IDC_TXT_MASK,        XTP_ANCHOR_TOPCENTER,   XTP_ANCHOR_TOPRIGHT);
SetResize(IDC_LBOX_MASK,       XTP_ANCHOR_TOPCENTER,   XTP_ANCHOR_TOPRIGHT);
SetResize(IDC_BTN_UPDATE,      XTP_ANCHOR_TOPCENTER,   XTP_ANCHOR_TOPCENTER);
SetResize(IDC_EDIT_MASK,       XTP_ANCHOR_TOPLEFT,     XTP_ANCHOR_TOPCENTER);
SetResize(IDC_EDIT_PROMPT,     XTP_ANCHOR_TOPLEFT,     XTP_ANCHOR_TOPCENTER);
SetResize(IDC_EDIT_LITERAL,    XTP_ANCHOR_TOPLEFT,     XTP_ANCHOR_TOPCENTER);
SetResize(IDC_EDIT_DEFAULT,    XTP_ANCHOR_TOPLEFT,     XTP_ANCHOR_TOPCENTER);
SetResize(IDC_GBOX_PROPERTIES, XTP_ANCHOR_TOPLEFT,     XTP_ANCHOR_TOPCENTER);
SetResize(IDCANCEL,            XTP_ANCHOR_BOTTOMRIGHT, XTP_ANCHOR_BOTTOMRIGHT);
SetResize(IDOK,                XTP_ANCHOR_BOTTOMRIGHT, XTP_ANCHOR_BOTTOMRIGHT);
See also
CXTPResize, CXTPResizeDialog, CXTPResizeFormView, CXTPResizeGroupBox, CXTPResizePropertyPage, CXTPResizePropertySheet, CXTPResizePoint, CXTPResizeRect

◆ XTP_ANCHOR_MIDDLELEFT

#define XTP_ANCHOR_MIDDLELEFT CXTPResizePoint(0, .5)

CXTPResizePoint constants used by the CXTPResize class for defining the anchor position for a child in a resizable window.

XTP_ANCHOR_TOPLEFT Specifies a top left position. XTP_ANCHOR_TOPCENTER Specifies a top center position. XTP_ANCHOR_TOPRIGHT Specifies a top right position. XTP_ANCHOR_MIDDLELEFT Specifies a middle left position. XTP_ANCHOR_MIDDLECENTER Specifies a middle center position. XTP_ANCHOR_MIDDLERIGHT Specifies a middle right position. XTP_ANCHOR_BOTTOMLEFT Specifies a bottom left position. XTP_ANCHOR_BOTTOMCENTER Specifies a bottom center position. XTP_ANCHOR_BOTTOMRIGHT Specifies a bottom right position. Example: The following example demonstrates the use of CXTPResizePoint:

// Set control resizing.
SetResize(IDC_EDIT_MASKEDIT,   XTP_ANCHOR_TOPLEFT,     XTP_ANCHOR_TOPRIGHT);
SetResize(IDC_TXT_MASK,        XTP_ANCHOR_TOPCENTER,   XTP_ANCHOR_TOPRIGHT);
SetResize(IDC_LBOX_MASK,       XTP_ANCHOR_TOPCENTER,   XTP_ANCHOR_TOPRIGHT);
SetResize(IDC_BTN_UPDATE,      XTP_ANCHOR_TOPCENTER,   XTP_ANCHOR_TOPCENTER);
SetResize(IDC_EDIT_MASK,       XTP_ANCHOR_TOPLEFT,     XTP_ANCHOR_TOPCENTER);
SetResize(IDC_EDIT_PROMPT,     XTP_ANCHOR_TOPLEFT,     XTP_ANCHOR_TOPCENTER);
SetResize(IDC_EDIT_LITERAL,    XTP_ANCHOR_TOPLEFT,     XTP_ANCHOR_TOPCENTER);
SetResize(IDC_EDIT_DEFAULT,    XTP_ANCHOR_TOPLEFT,     XTP_ANCHOR_TOPCENTER);
SetResize(IDC_GBOX_PROPERTIES, XTP_ANCHOR_TOPLEFT,     XTP_ANCHOR_TOPCENTER);
SetResize(IDCANCEL,            XTP_ANCHOR_BOTTOMRIGHT, XTP_ANCHOR_BOTTOMRIGHT);
SetResize(IDOK,                XTP_ANCHOR_BOTTOMRIGHT, XTP_ANCHOR_BOTTOMRIGHT);
See also
CXTPResize, CXTPResizeDialog, CXTPResizeFormView, CXTPResizeGroupBox, CXTPResizePropertyPage, CXTPResizePropertySheet, CXTPResizePoint, CXTPResizeRect

◆ XTP_ANCHOR_MIDDLERIGHT

#define XTP_ANCHOR_MIDDLERIGHT CXTPResizePoint(1, .5)

CXTPResizePoint constants used by the CXTPResize class for defining the anchor position for a child in a resizable window.

XTP_ANCHOR_TOPLEFT Specifies a top left position. XTP_ANCHOR_TOPCENTER Specifies a top center position. XTP_ANCHOR_TOPRIGHT Specifies a top right position. XTP_ANCHOR_MIDDLELEFT Specifies a middle left position. XTP_ANCHOR_MIDDLECENTER Specifies a middle center position. XTP_ANCHOR_MIDDLERIGHT Specifies a middle right position. XTP_ANCHOR_BOTTOMLEFT Specifies a bottom left position. XTP_ANCHOR_BOTTOMCENTER Specifies a bottom center position. XTP_ANCHOR_BOTTOMRIGHT Specifies a bottom right position. Example: The following example demonstrates the use of CXTPResizePoint:

// Set control resizing.
SetResize(IDC_EDIT_MASKEDIT,   XTP_ANCHOR_TOPLEFT,     XTP_ANCHOR_TOPRIGHT);
SetResize(IDC_TXT_MASK,        XTP_ANCHOR_TOPCENTER,   XTP_ANCHOR_TOPRIGHT);
SetResize(IDC_LBOX_MASK,       XTP_ANCHOR_TOPCENTER,   XTP_ANCHOR_TOPRIGHT);
SetResize(IDC_BTN_UPDATE,      XTP_ANCHOR_TOPCENTER,   XTP_ANCHOR_TOPCENTER);
SetResize(IDC_EDIT_MASK,       XTP_ANCHOR_TOPLEFT,     XTP_ANCHOR_TOPCENTER);
SetResize(IDC_EDIT_PROMPT,     XTP_ANCHOR_TOPLEFT,     XTP_ANCHOR_TOPCENTER);
SetResize(IDC_EDIT_LITERAL,    XTP_ANCHOR_TOPLEFT,     XTP_ANCHOR_TOPCENTER);
SetResize(IDC_EDIT_DEFAULT,    XTP_ANCHOR_TOPLEFT,     XTP_ANCHOR_TOPCENTER);
SetResize(IDC_GBOX_PROPERTIES, XTP_ANCHOR_TOPLEFT,     XTP_ANCHOR_TOPCENTER);
SetResize(IDCANCEL,            XTP_ANCHOR_BOTTOMRIGHT, XTP_ANCHOR_BOTTOMRIGHT);
SetResize(IDOK,                XTP_ANCHOR_BOTTOMRIGHT, XTP_ANCHOR_BOTTOMRIGHT);
See also
CXTPResize, CXTPResizeDialog, CXTPResizeFormView, CXTPResizeGroupBox, CXTPResizePropertyPage, CXTPResizePropertySheet, CXTPResizePoint, CXTPResizeRect

◆ XTP_ANCHOR_TOPCENTER

#define XTP_ANCHOR_TOPCENTER CXTPResizePoint(.5, 0)

CXTPResizePoint constants used by the CXTPResize class for defining the anchor position for a child in a resizable window.

XTP_ANCHOR_TOPLEFT Specifies a top left position. XTP_ANCHOR_TOPCENTER Specifies a top center position. XTP_ANCHOR_TOPRIGHT Specifies a top right position. XTP_ANCHOR_MIDDLELEFT Specifies a middle left position. XTP_ANCHOR_MIDDLECENTER Specifies a middle center position. XTP_ANCHOR_MIDDLERIGHT Specifies a middle right position. XTP_ANCHOR_BOTTOMLEFT Specifies a bottom left position. XTP_ANCHOR_BOTTOMCENTER Specifies a bottom center position. XTP_ANCHOR_BOTTOMRIGHT Specifies a bottom right position. Example: The following example demonstrates the use of CXTPResizePoint:

// Set control resizing.
SetResize(IDC_EDIT_MASKEDIT,   XTP_ANCHOR_TOPLEFT,     XTP_ANCHOR_TOPRIGHT);
SetResize(IDC_TXT_MASK,        XTP_ANCHOR_TOPCENTER,   XTP_ANCHOR_TOPRIGHT);
SetResize(IDC_LBOX_MASK,       XTP_ANCHOR_TOPCENTER,   XTP_ANCHOR_TOPRIGHT);
SetResize(IDC_BTN_UPDATE,      XTP_ANCHOR_TOPCENTER,   XTP_ANCHOR_TOPCENTER);
SetResize(IDC_EDIT_MASK,       XTP_ANCHOR_TOPLEFT,     XTP_ANCHOR_TOPCENTER);
SetResize(IDC_EDIT_PROMPT,     XTP_ANCHOR_TOPLEFT,     XTP_ANCHOR_TOPCENTER);
SetResize(IDC_EDIT_LITERAL,    XTP_ANCHOR_TOPLEFT,     XTP_ANCHOR_TOPCENTER);
SetResize(IDC_EDIT_DEFAULT,    XTP_ANCHOR_TOPLEFT,     XTP_ANCHOR_TOPCENTER);
SetResize(IDC_GBOX_PROPERTIES, XTP_ANCHOR_TOPLEFT,     XTP_ANCHOR_TOPCENTER);
SetResize(IDCANCEL,            XTP_ANCHOR_BOTTOMRIGHT, XTP_ANCHOR_BOTTOMRIGHT);
SetResize(IDOK,                XTP_ANCHOR_BOTTOMRIGHT, XTP_ANCHOR_BOTTOMRIGHT);
See also
CXTPResize, CXTPResizeDialog, CXTPResizeFormView, CXTPResizeGroupBox, CXTPResizePropertyPage, CXTPResizePropertySheet, CXTPResizePoint, CXTPResizeRect

◆ XTP_ANCHOR_TOPLEFT

#define XTP_ANCHOR_TOPLEFT CXTPResizePoint(0, 0)

CXTPResizePoint constants used by the CXTPResize class for defining the anchor position for a child in a resizable window.

XTP_ANCHOR_TOPLEFT Specifies a top left position. XTP_ANCHOR_TOPCENTER Specifies a top center position. XTP_ANCHOR_TOPRIGHT Specifies a top right position. XTP_ANCHOR_MIDDLELEFT Specifies a middle left position. XTP_ANCHOR_MIDDLECENTER Specifies a middle center position. XTP_ANCHOR_MIDDLERIGHT Specifies a middle right position. XTP_ANCHOR_BOTTOMLEFT Specifies a bottom left position. XTP_ANCHOR_BOTTOMCENTER Specifies a bottom center position. XTP_ANCHOR_BOTTOMRIGHT Specifies a bottom right position. Example: The following example demonstrates the use of CXTPResizePoint:

// Set control resizing.
SetResize(IDC_EDIT_MASKEDIT,   XTP_ANCHOR_TOPLEFT,     XTP_ANCHOR_TOPRIGHT);
SetResize(IDC_TXT_MASK,        XTP_ANCHOR_TOPCENTER,   XTP_ANCHOR_TOPRIGHT);
SetResize(IDC_LBOX_MASK,       XTP_ANCHOR_TOPCENTER,   XTP_ANCHOR_TOPRIGHT);
SetResize(IDC_BTN_UPDATE,      XTP_ANCHOR_TOPCENTER,   XTP_ANCHOR_TOPCENTER);
SetResize(IDC_EDIT_MASK,       XTP_ANCHOR_TOPLEFT,     XTP_ANCHOR_TOPCENTER);
SetResize(IDC_EDIT_PROMPT,     XTP_ANCHOR_TOPLEFT,     XTP_ANCHOR_TOPCENTER);
SetResize(IDC_EDIT_LITERAL,    XTP_ANCHOR_TOPLEFT,     XTP_ANCHOR_TOPCENTER);
SetResize(IDC_EDIT_DEFAULT,    XTP_ANCHOR_TOPLEFT,     XTP_ANCHOR_TOPCENTER);
SetResize(IDC_GBOX_PROPERTIES, XTP_ANCHOR_TOPLEFT,     XTP_ANCHOR_TOPCENTER);
SetResize(IDCANCEL,            XTP_ANCHOR_BOTTOMRIGHT, XTP_ANCHOR_BOTTOMRIGHT);
SetResize(IDOK,                XTP_ANCHOR_BOTTOMRIGHT, XTP_ANCHOR_BOTTOMRIGHT);
See also
CXTPResize, CXTPResizeDialog, CXTPResizeFormView, CXTPResizeGroupBox, CXTPResizePropertyPage, CXTPResizePropertySheet, CXTPResizePoint, CXTPResizeRect

◆ XTP_ANCHOR_TOPRIGHT

#define XTP_ANCHOR_TOPRIGHT CXTPResizePoint(1, 0)

CXTPResizePoint constants used by the CXTPResize class for defining the anchor position for a child in a resizable window.

XTP_ANCHOR_TOPLEFT Specifies a top left position. XTP_ANCHOR_TOPCENTER Specifies a top center position. XTP_ANCHOR_TOPRIGHT Specifies a top right position. XTP_ANCHOR_MIDDLELEFT Specifies a middle left position. XTP_ANCHOR_MIDDLECENTER Specifies a middle center position. XTP_ANCHOR_MIDDLERIGHT Specifies a middle right position. XTP_ANCHOR_BOTTOMLEFT Specifies a bottom left position. XTP_ANCHOR_BOTTOMCENTER Specifies a bottom center position. XTP_ANCHOR_BOTTOMRIGHT Specifies a bottom right position. Example: The following example demonstrates the use of CXTPResizePoint:

// Set control resizing.
SetResize(IDC_EDIT_MASKEDIT,   XTP_ANCHOR_TOPLEFT,     XTP_ANCHOR_TOPRIGHT);
SetResize(IDC_TXT_MASK,        XTP_ANCHOR_TOPCENTER,   XTP_ANCHOR_TOPRIGHT);
SetResize(IDC_LBOX_MASK,       XTP_ANCHOR_TOPCENTER,   XTP_ANCHOR_TOPRIGHT);
SetResize(IDC_BTN_UPDATE,      XTP_ANCHOR_TOPCENTER,   XTP_ANCHOR_TOPCENTER);
SetResize(IDC_EDIT_MASK,       XTP_ANCHOR_TOPLEFT,     XTP_ANCHOR_TOPCENTER);
SetResize(IDC_EDIT_PROMPT,     XTP_ANCHOR_TOPLEFT,     XTP_ANCHOR_TOPCENTER);
SetResize(IDC_EDIT_LITERAL,    XTP_ANCHOR_TOPLEFT,     XTP_ANCHOR_TOPCENTER);
SetResize(IDC_EDIT_DEFAULT,    XTP_ANCHOR_TOPLEFT,     XTP_ANCHOR_TOPCENTER);
SetResize(IDC_GBOX_PROPERTIES, XTP_ANCHOR_TOPLEFT,     XTP_ANCHOR_TOPCENTER);
SetResize(IDCANCEL,            XTP_ANCHOR_BOTTOMRIGHT, XTP_ANCHOR_BOTTOMRIGHT);
SetResize(IDOK,                XTP_ANCHOR_BOTTOMRIGHT, XTP_ANCHOR_BOTTOMRIGHT);
See also
CXTPResize, CXTPResizeDialog, CXTPResizeFormView, CXTPResizeGroupBox, CXTPResizePropertyPage, CXTPResizePropertySheet, CXTPResizePoint, CXTPResizeRect


Toolkit Pro: XTPResizePropertyPage.h File Reference

  • Source
  • Controls
  • Resize
Classes
XTPResizePropertyPage.h File Reference

Go to the source code of this file.

Classes

class CXTPResizePropertyPage
CXTPResizePropertyPage is a multiple inheritance class derived from CPropertyPage and CXTPResize. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPResizePropertySheet.h File Reference

  • Source
  • Controls
  • Resize
Classes
XTPResizePropertySheet.h File Reference

Go to the source code of this file.

Classes

class CXTPResizePropertySheet
CXTPResizePropertySheet is a multiple inheritance class derived from CPropertySheet and CXTPResize. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPResizeRect.h File Reference

  • Source
  • Controls
  • Resize
Classes | Macros | Typedefs
XTPResizeRect.h File Reference

Go to the source code of this file.

Classes

struct | XTP_RESIZERECT
XTP_RESIZERECT structure is used by the CXTPResizeRect class for defining single-precision floating point coordinates of the upper-left and lower-right corners of a rectangle. More...
class | CXTPResizeRect
CXTPResizeRect is an XTP_RESIZERECT structure derived class. More...

Macros

#define | XTP_ATTR_RESIZE(x)
CXTPResizeRect constants used by the CXTPResize class for defining the resize attributes for a child in a resizable window.
#define | XTP_ATTR_REPOS(x)
CXTPResizeRect constants used by the CXTPResize class for defining the resize attributes for a child in a resizable window.
#define | XTP_ATTR_HORRESIZE(x)
CXTPResizeRect constants used by the CXTPResize class for defining the resize attributes for a child in a resizable window.
#define | XTP_ATTR_HORREPOS(x)
CXTPResizeRect constants used by the CXTPResize class for defining the resize attributes for a child in a resizable window.
#define | XTP_ATTR_VERRESIZE(x)
CXTPResizeRect constants used by the CXTPResize class for defining the resize attributes for a child in a resizable window.
#define | XTP_ATTR_VERREPOS(x)
CXTPResizeRect constants used by the CXTPResize class for defining the resize attributes for a child in a resizable window.

Typedefs

typedef float XTP_RESIZE
The XTP_RESIZE data type is defined as a float and is used for storing single-precision floating point x- and y- window coordinates.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Macro Definition Documentation

◆ XTP_ATTR_HORREPOS

#define XTP_ATTR_HORREPOS ( x )
Value:
CXTPResizeRect(x, 0, x, 0)
CXTPResizeRect
CXTPResizeRect is an XTP_RESIZERECT structure derived class.
Definition XTPResizeRect.h:81

CXTPResizeRect constants used by the CXTPResize class for defining the resize attributes for a child in a resizable window.

XTP_ATTR_RESIZE Resize. XTP_ATTR_REPOS Reposition. XTP_ATTR_HORRESIZE Horizontal resize. XTP_ATTR_HORREPOS Horizontal reposition. XTP_ATTR_VERRESIZE Vertical resize. XTP_ATTR_VERREPOS Vertical reposition. Example: The following example demonstrates how to use CXTPResizeRect.

// Set control resizing.
SetResize(ID_WIZBACK, XTP_ATTR_REPOS(1));
SetResize(ID_WIZNEXT, XTP_ATTR_REPOS(1));
SetResize(ID_WIZFINISH, XTP_ATTR_REPOS(1));
SetResize(ID_WIZLINE, XTP_ANCHOR_BOTTOMLEFT, XTP_ANCHOR_BOTTOMRIGHT);
See also
CXTPResize, CXTPResizeDialog, CXTPResizeFormView, CXTPResizeGroupBox, CXTPResizePropertyPage, CXTPResizePropertySheet, CXTPResizePoint, CXTPResizeRect

◆ XTP_ATTR_HORRESIZE

#define XTP_ATTR_HORRESIZE ( x )
Value:
CXTPResizeRect(0, 0, x, 0)

CXTPResizeRect constants used by the CXTPResize class for defining the resize attributes for a child in a resizable window.

XTP_ATTR_RESIZE Resize. XTP_ATTR_REPOS Reposition. XTP_ATTR_HORRESIZE Horizontal resize. XTP_ATTR_HORREPOS Horizontal reposition. XTP_ATTR_VERRESIZE Vertical resize. XTP_ATTR_VERREPOS Vertical reposition. Example: The following example demonstrates how to use CXTPResizeRect.

// Set control resizing.
SetResize(ID_WIZBACK, XTP_ATTR_REPOS(1));
SetResize(ID_WIZNEXT, XTP_ATTR_REPOS(1));
SetResize(ID_WIZFINISH, XTP_ATTR_REPOS(1));
SetResize(ID_WIZLINE, XTP_ANCHOR_BOTTOMLEFT, XTP_ANCHOR_BOTTOMRIGHT);
See also
CXTPResize, CXTPResizeDialog, CXTPResizeFormView, CXTPResizeGroupBox, CXTPResizePropertyPage, CXTPResizePropertySheet, CXTPResizePoint, CXTPResizeRect

◆ XTP_ATTR_REPOS

#define XTP_ATTR_REPOS ( x )
Value:
CXTPResizeRect(x, x, x, x)

CXTPResizeRect constants used by the CXTPResize class for defining the resize attributes for a child in a resizable window.

XTP_ATTR_RESIZE Resize. XTP_ATTR_REPOS Reposition. XTP_ATTR_HORRESIZE Horizontal resize. XTP_ATTR_HORREPOS Horizontal reposition. XTP_ATTR_VERRESIZE Vertical resize. XTP_ATTR_VERREPOS Vertical reposition. Example: The following example demonstrates how to use CXTPResizeRect.

// Set control resizing.
SetResize(ID_WIZBACK, XTP_ATTR_REPOS(1));
SetResize(ID_WIZNEXT, XTP_ATTR_REPOS(1));
SetResize(ID_WIZFINISH, XTP_ATTR_REPOS(1));
SetResize(ID_WIZLINE, XTP_ANCHOR_BOTTOMLEFT, XTP_ANCHOR_BOTTOMRIGHT);
See also
CXTPResize, CXTPResizeDialog, CXTPResizeFormView, CXTPResizeGroupBox, CXTPResizePropertyPage, CXTPResizePropertySheet, CXTPResizePoint, CXTPResizeRect

◆ XTP_ATTR_RESIZE

#define XTP_ATTR_RESIZE ( x )
Value:
CXTPResizeRect(0, 0, x, x)

CXTPResizeRect constants used by the CXTPResize class for defining the resize attributes for a child in a resizable window.

XTP_ATTR_RESIZE Resize. XTP_ATTR_REPOS Reposition. XTP_ATTR_HORRESIZE Horizontal resize. XTP_ATTR_HORREPOS Horizontal reposition. XTP_ATTR_VERRESIZE Vertical resize. XTP_ATTR_VERREPOS Vertical reposition. Example: The following example demonstrates how to use CXTPResizeRect.

// Set control resizing.
SetResize(ID_WIZBACK, XTP_ATTR_REPOS(1));
SetResize(ID_WIZNEXT, XTP_ATTR_REPOS(1));
SetResize(ID_WIZFINISH, XTP_ATTR_REPOS(1));
SetResize(ID_WIZLINE, XTP_ANCHOR_BOTTOMLEFT, XTP_ANCHOR_BOTTOMRIGHT);
See also
CXTPResize, CXTPResizeDialog, CXTPResizeFormView, CXTPResizeGroupBox, CXTPResizePropertyPage, CXTPResizePropertySheet, CXTPResizePoint, CXTPResizeRect

◆ XTP_ATTR_VERREPOS

#define XTP_ATTR_VERREPOS ( x )
Value:
CXTPResizeRect(0, x, 0, x)

CXTPResizeRect constants used by the CXTPResize class for defining the resize attributes for a child in a resizable window.

XTP_ATTR_RESIZE Resize. XTP_ATTR_REPOS Reposition. XTP_ATTR_HORRESIZE Horizontal resize. XTP_ATTR_HORREPOS Horizontal reposition. XTP_ATTR_VERRESIZE Vertical resize. XTP_ATTR_VERREPOS Vertical reposition. Example: The following example demonstrates how to use CXTPResizeRect.

// Set control resizing.
SetResize(ID_WIZBACK, XTP_ATTR_REPOS(1));
SetResize(ID_WIZNEXT, XTP_ATTR_REPOS(1));
SetResize(ID_WIZFINISH, XTP_ATTR_REPOS(1));
SetResize(ID_WIZLINE, XTP_ANCHOR_BOTTOMLEFT, XTP_ANCHOR_BOTTOMRIGHT);
See also
CXTPResize, CXTPResizeDialog, CXTPResizeFormView, CXTPResizeGroupBox, CXTPResizePropertyPage, CXTPResizePropertySheet, CXTPResizePoint, CXTPResizeRect

◆ XTP_ATTR_VERRESIZE

#define XTP_ATTR_VERRESIZE ( x )
Value:
CXTPResizeRect(0, 0, 0, x)

CXTPResizeRect constants used by the CXTPResize class for defining the resize attributes for a child in a resizable window.

XTP_ATTR_RESIZE Resize. XTP_ATTR_REPOS Reposition. XTP_ATTR_HORRESIZE Horizontal resize. XTP_ATTR_HORREPOS Horizontal reposition. XTP_ATTR_VERRESIZE Vertical resize. XTP_ATTR_VERREPOS Vertical reposition. Example: The following example demonstrates how to use CXTPResizeRect.

// Set control resizing.
SetResize(ID_WIZBACK, XTP_ATTR_REPOS(1));
SetResize(ID_WIZNEXT, XTP_ATTR_REPOS(1));
SetResize(ID_WIZFINISH, XTP_ATTR_REPOS(1));
SetResize(ID_WIZLINE, XTP_ANCHOR_BOTTOMLEFT, XTP_ANCHOR_BOTTOMRIGHT);
See also
CXTPResize, CXTPResizeDialog, CXTPResizeFormView, CXTPResizeGroupBox, CXTPResizePropertyPage, CXTPResizePropertySheet, CXTPResizePoint, CXTPResizeRect

Typedef Documentation

◆ XTP_RESIZE

typedef float XTP_RESIZE

The XTP_RESIZE data type is defined as a float and is used for storing single-precision floating point x- and y- window coordinates.

See also
CXTPResizeRect, XTP_RESIZERECT, CXTPResizePoint, XTP_RESIZEPOINT


Toolkit Pro: Scroll Directory Reference

  • Source
  • Controls
  • Scroll
Scroll Directory Reference

Files

XTPPageScroller.h
XTPScrollBar.h


Toolkit Pro: XTPPageScroller.h File Reference

  • Source
  • Controls
  • Scroll
Classes
XTPPageScroller.h File Reference

Go to the source code of this file.

Classes

class CXTPPageScroller
CXTPPageScroller is a CWnd derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPScrollBar.h File Reference

  • Source
  • Controls
  • Scroll
Classes
XTPScrollBar.h File Reference

Go to the source code of this file.

Classes

class CXTPScrollBar
Scrollbar control. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: Shell Directory Reference

  • Source
  • Controls
  • Shell
Shell Directory Reference

Files

XTPDirWatcher.h
XTPDropSource.h
XTPShellListBase.h
XTPShellListCtrlView.h
XTPShellPidl.h
XTPShellSettings.h
XTPShellTreeBase.h
XTPShellTreeCtrlView.h
XTPTaskbarManager.h
XTPTrayIcon.h


Toolkit Pro: XTPDirWatcher.h File Reference

  • Source
  • Controls
  • Shell
Classes
XTPDirWatcher.h File Reference

Go to the source code of this file.

Classes

class CXTPDirWatcher
The CXTPDirWatcher is a thread class that will monitor a specified path for file and directory changes to occur. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPDropSource.h File Reference

  • Source
  • Controls
  • Shell
Classes
XTPDropSource.h File Reference

Go to the source code of this file.

Classes

class CXTPDropSource
The CXTPDropSource class is derived from IDropSource. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPShellListBase.h File Reference

  • Source
  • Controls
  • Shell
Classes
XTPShellListBase.h File Reference

Go to the source code of this file.

Classes

class CXTPShellListBase
CXTPShellListBase is a multiple inheritance class derived from CXTPListView and CXTPShellPidl. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPShellListCtrlView.h File Reference

  • Source
  • Controls
  • Shell
Classes
XTPShellListCtrlView.h File Reference

Go to the source code of this file.

Classes

class | CXTPShellListView
CXTPShellListView is a multiple inheritance class derived from CXTPListView and CXTPShellPidl. More...
class | CXTPShellListCtrl
CXTPShellListCtrl is a multiple inheritance class derived from CXTPListCtrl and CXTPShellPidl. More...
class | CXTPShellListCtrlEx
CXTPShellListCtrlEx is a CXTPShellListCtrl derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPShellPidl.h File Reference

  • Source
  • Controls
  • Shell
Classes
XTPShellPidl.h File Reference

Go to the source code of this file.

Classes

struct | XTP_LVITEMDATA
The XTP_LVITEMDATA structure is used to maintain information for a particular list item in a CXTPShellListCtrl or CXTPShellListView window. More...
struct | XTP_TVITEMDATA
The XTP_TVITEMDATA structure is used to maintain information for a particular tree item in a CXTPShellTreeCtrl or CXTPShellTreeView window. More...
class | CXTPShellPidl
CXTPShellPidl is a standalone base class. More...
class | CXTPShellPidl::CShellMalloc
CXTPShellPidl::CShellMalloc is a helper class that is used by CXTPShellPidl to initialize a pointer to the Shell's IMalloc interface used for allocating memory blocks. More...
class | CXTPShellPidl::CShellSpecialFolder
CXTPShellPidl::CShellSpecialFolder is a helper class that is used by CXTPShellPidl to initialize a pointer to an ITEMIDLIST structure of a special folder. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPShellSettings.h File Reference

  • Source
  • Controls
  • Shell
Classes
XTPShellSettings.h File Reference

Go to the source code of this file.

Classes

class CXTPShellSettings
CXTPShellSettings is a SHELLFLAGSTATE struct derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPShellTreeBase.h File Reference

  • Source
  • Controls
  • Shell
Classes | Macros | Enumerations
XTPShellTreeBase.h File Reference

Go to the source code of this file.

Classes

class CXTPShellTreeBase
CXTPShellTreeBase is a multiple inheritance class derived from CXTPTreeView and CXTPShellPidl. More...

Macros

#define DECLARE_SHELLTREE_BASE(ClassName, Tree, Base)
The DECLARE_SHELLTREE_BASE class is a template class used by the CXTPShellTreeView and CXTPShellTreeCtrl classes to declare a multiple inheritance base class so that both classes can share a common code base.

Enumerations

enum XTPFindType { xtpFindTypeDrive , xtpFindTypeFolder , xtpFindTypeRoot , xtpFindTypeShare }
Enumeration used to determine folder or drive type. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Macro Definition Documentation

◆ DECLARE_SHELLTREE_BASE

#define DECLARE_SHELLTREE_BASE | ( | ClassName,
 |  | Tree,
 |  | Base )

The DECLARE_SHELLTREE_BASE class is a template class used by the CXTPShellTreeView and CXTPShellTreeCtrl classes to declare a multiple inheritance base class so that both classes can share a common code base.

Parameters
ClassName | Name of the object to be declared as the base class.
Tree | Existing class that this object will be derived from.
Base | Existing shared class that this object will be derived from.

Tree must be an existing class that is derived from either CTreeCtrl or CTreeView. Example: The following example demonstrates how to use DECLARE_SHELLTREE_BASE:

DECLARE_SHELLTREE_BASE(CXTPShellTreeViewBase, CTreeView, CXTPShellTreeBase)

class _XTP_EXT_CLASS CXTPShellTreeView : public CXTPShellTreeViewBase
{
   public:
   CXTPShellTreeView();
};

Enumeration Type Documentation

◆ XTPFindType

enum XTPFindType

Enumeration used to determine folder or drive type.

XTPFindType type defines the constants used by the CXTPShellTreeBase class to determine the type of object enumerated (either folder or drive).

See also
CXTPFontListBox, CXTPFontListBox::SetListStyle
xtpFindTypeDrive, xtpFindTypeFolder
Enumerator
xtpFindTypeDrive | The object type is a drive.
xtpFindTypeFolder | The object type is a folder.
xtpFindTypeRoot | The object type is a root folder.
xtpFindTypeShare | The object is a UNC share.


Toolkit Pro: XTPShellTreeCtrlView.h File Reference

  • Source
  • Controls
  • Shell
Classes
XTPShellTreeCtrlView.h File Reference

Go to the source code of this file.

Classes

class | CXTPShellTreeView
CXTPShellTreeView is a multiple inheritance class derived from CXTPTreeView and CXTPShellPidl. More...
class | CXTPShellTreeCtrl
CXTPShellTreeCtrl is a multiple inheritance class derived from CXTPTreeCtrl and CXTPShellPidl. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTaskbarManager.h File Reference

  • Source
  • Controls
  • Shell
XTPTaskbarManager.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTrayIcon.h File Reference

  • Source
  • Controls
  • Shell
Classes
XTPTrayIcon.h File Reference

Go to the source code of this file.

Classes

class CXTPTrayIcon
CXTPTrayIcon is a CWnd derived class of the NOTIFYICONDATA structure. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: Spin Directory Reference

  • Source
  • Controls
  • Spin
Spin Directory Reference

Files

XTPSpinButtonCtrl.h


Toolkit Pro: XTPSpinButtonCtrl.h File Reference

  • Source
  • Controls
  • Spin
Classes
XTPSpinButtonCtrl.h File Reference

Go to the source code of this file.

Classes

class CXTPSpinButtonCtrl
The CXTPSpinButtonCtrl class provides the functionality of a themed Windows spin button control. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: Splitter Directory Reference

  • Source
  • Controls
  • Splitter
Splitter Directory Reference

Files

XTPSplitterWnd.h
XTPSplitterWndTheme.h


Toolkit Pro: XTPSplitterWnd.h File Reference

  • Source
  • Controls
  • Splitter
Classes
XTPSplitterWnd.h File Reference

Go to the source code of this file.

Classes

class | CXTPSplitterWnd
CXTPSplitterWnd is a CSplitterWnd derived class. More...
class | CXTPSplitterWndEx
CXTPSplitterWndEx is a CXTPSplitterWnd derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPSplitterWndTheme.h File Reference

  • Source
  • Controls
  • Splitter
Classes
XTPSplitterWndTheme.h File Reference

Go to the source code of this file.

Classes

class | CXTPSplitterWndTheme
Class CXTPSplitterWndTheme is derived from CXTPControlTheme. More...
class | CXTPSplitterWndThemeOfficeXP
Class CXTPSplitterWndThemeOfficeXP is derived from CXTPSplitterWndTheme. More...
class | CXTPSplitterWndThemeOffice2003
Class CXTPSplitterWndThemeOffice2003 is derived from CXTPSplitterWndTheme. More...
class | CXTPSplitterWndThemeResource
Class CXTPSplitterWndThemeResource is derived from CXTPSplitterWndTheme. More...
class | CXTPSplitterWndThemeVisualStudio2010
Class CXTPSplitterWndThemeVisualStudio2010 is derived from CXTPSplitterWndTheme. More...
class | CXTPSplitterWndThemeOffice2013
Class CXTPSplitterWndThemeOffice2013 is derived from CXTPSplitterWndThemeOfficeXP. More...
class | CXTPSplitterWndThemeVisualStudio2015
Class CXTPSplitterWndThemeVisualStudio2015 is derived from CXTPSplitterWndThemeOffice2013. More...
class | CXTPSplitterWndThemeVisualStudio2017
Class CXTPSplitterWndThemeVisualStudio2017 is derived from CXTPSplitterWndThemeOffice2013. More...
class | CXTPSplitterWndThemeVisualStudio2019
Class CXTPSplitterWndThemeVisualStudio2019 is derived from CXTPSplitterWndThemeOffice2013. More...
class | CXTPSplitterWndThemeVisualStudio2022
Class CXTPSplitterWndThemeVisualStudio2022 is derived from CXTPSplitterWndThemeOffice2013. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: Static Directory Reference

  • Source
  • Controls
  • Static
Static Directory Reference

Directories

Themes

Files

XTPCaption.h
XTPCaptionPopupWnd.h
XTPCaptionTheme.h
XTPHyperLink.h
XTPMarkupStatic.h
XTPSearchOptionsCtrl.h


Toolkit Pro: Themes Directory Reference

  • Source
  • Controls
  • Static
  • Themes
Themes Directory Reference

Files

XTPCaptionButtonThemeOffice2003.h
XTPCaptionButtonThemeOfficeXP.h


Toolkit Pro: XTPCaptionButtonThemeOffice2003.h File Reference

  • Source
  • Controls
  • Static
  • Themes
Classes
XTPCaptionButtonThemeOffice2003.h File Reference

Go to the source code of this file.

Classes

class CXTPCaptionButtonThemeOffice2003
Class CXTPCaptionButtonThemeOffice2003 is a CXTPButtonOffice2003Theme derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPCaptionButtonThemeOfficeXP.h File Reference

  • Source
  • Controls
  • Static
  • Themes
Classes
XTPCaptionButtonThemeOfficeXP.h File Reference

Go to the source code of this file.

Classes

class CXTPCaptionButtonThemeOfficeXP
Class CXTPCaptionButtonThemeOfficeXP is a CXTPButtonOfficeXPTheme derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPCaption.h File Reference

  • Source
  • Controls
  • Static
Classes | Variables
XTPCaption.h File Reference

Go to the source code of this file.

Classes

class | CXTPCaptionButton
CXTPCaptionButton is a CXTPButton derived class. More...
class | CXTPCaption
CXTPCaption is a CStatic derived class. More...

Variables

const DWORD | CPWS_EX_GROOVE_EDGE = 0x0001
const DWORD | CPWS_EX_RAISED_EDGE = 0x0002
const DWORD | CPWS_EX_CLOSEBUTTON = 0x0004

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Variable Documentation

◆ CPWS_EX_CLOSEBUTTON

const DWORD CPWS_EX_CLOSEBUTTON = 0x0004
See also
CXTPCaption::Create

◆ CPWS_EX_GROOVE_EDGE

const DWORD CPWS_EX_GROOVE_EDGE = 0x0001
See also
CXTPCaption::Create

◆ CPWS_EX_RAISED_EDGE

const DWORD CPWS_EX_RAISED_EDGE = 0x0002
See also
CXTPCaption::Create


Toolkit Pro: XTPCaptionPopupWnd.h File Reference

  • Source
  • Controls
  • Static
Classes
XTPCaptionPopupWnd.h File Reference

Go to the source code of this file.

Classes

class CXTPCaptionPopupWnd
CXTPCaptionPopupWnd is a CWnd derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPCaptionTheme.h File Reference

  • Source
  • Controls
  • Static
Classes
XTPCaptionTheme.h File Reference

Go to the source code of this file.

Classes

class | CXTPCaptionTheme
CXTPCaptionTheme is a CXTPControlTheme derived class used to control caption themes. More...
class | CXTPCaptionThemeOfficeXP
CXTPCaptionThemeOfficeXP is derived from CXTPCaptionTheme. More...
class | CXTPCaptionThemeOffice2003
CXTPCaptionThemeOffice2003 is derived from CXTPCaptionTheme. More...
class | CXTPCaptionButtonTheme
CXTPCaptionButtonTheme is derived from CXTPButtonTheme. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPHyperLink.h File Reference

  • Source
  • Controls
  • Static
Classes
XTPHyperLink.h File Reference

Go to the source code of this file.

Classes

class CXTPHyperLink
CXTPHyperLink is a CStatic derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMarkupStatic.h File Reference

  • Source
  • Controls
  • Static
XTPMarkupStatic.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPSearchOptionsCtrl.h File Reference

  • Source
  • Controls
  • Static
Classes
XTPSearchOptionsCtrl.h File Reference

Go to the source code of this file.

Classes

class | CXTPSearchOptionsCtrl
CXTPSearchOptionsCtrl is a CStatic derived class. More...
class | CXTPSearchOptionsView
CXTPSearchOptionsView is a CFormView derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: Tab Directory Reference

  • Source
  • Controls
  • Tab
Tab Directory Reference

Files

XTPExcelTabCtrl.h
XTPExcelTabCtrlTheme.h
XTPMDIWndTab.h
XTPTabBase.h
XTPTabBaseTheme.h
XTPTabCtrl.h
XTPTabCtrlButtons.h
XTPTabView.h


Toolkit Pro: XTPExcelTabCtrl.h File Reference

  • Source
  • Controls
  • Tab
Classes | Enumerations | Variables
XTPExcelTabCtrl.h File Reference

Go to the source code of this file.

Classes

class | CXTPExcelTabCtrlButtonState
The CXTPExcelTabCtrlButtonState class is used by the CXTPExcelTabCtrl class to manage navigation button information. More...
class | CXTPExcelTabCtrl
CXTPExcelTabCtrl is a CWnd derived class. More...

Enumerations

enum XTPArrowIcon { xtpArrowIconLeft = 0x0200 , xtpArrowIconLeftHome = 0x0201 , xtpArrowIconRight = 0x0000 , xtpArrowIconRightHome = 0x0001 }
Enumeration used to determine arrow button display. More...

Variables

const DWORD | FTS_XTP_BOTTOM = 0x0001
const DWORD | FTS_XTP_HASARROWS = 0x0002
const DWORD | FTS_XTP_HASHOMEEND = 0x0004
const DWORD | FTS_XTP_TOOLTIPS = 0x0008
const DWORD | FTS_XTP_DEFAULT = 0x000F
const DWORD | FTS_XTP_HSCROLL = 0x0010
const DWORD | FTS_XTP_SQUARETABS = 0X0020
const DWORD | FTS_XTP_MASK = 0x003F

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Enumeration Type Documentation

◆ XTPArrowIcon

enum XTPArrowIcon

Enumeration used to determine arrow button display.

XTPArrowIcon type defines constants used by the CXTPExcelTabCtrlButtonState to determine which arrow is to be displayed for a particular tab button.

See also
CXTPExcelTabCtrlButtonState, CXTPExcelTabCtrl
xtpArrowIconLeft, xtpArrowIconLeftHome, xtpArrowIconRight, xtpArrowIconRightHome
Enumerator
xtpArrowIconLeft | Left arrow display.
xtpArrowIconLeftHome | Left home arrow display.
xtpArrowIconRight | Right arrow display.
xtpArrowIconRightHome | Right home arrow display.

Variable Documentation

◆ FTS_XTP_BOTTOM

const DWORD FTS_XTP_BOTTOM = 0x0001
See also
CXTPExcelTabCtrl::Create

◆ FTS_XTP_DEFAULT

const DWORD FTS_XTP_DEFAULT = 0x000F
See also
CXTPExcelTabCtrl::Create

◆ FTS_XTP_HASARROWS

const DWORD FTS_XTP_HASARROWS = 0x0002
See also
CXTPExcelTabCtrl::Create

◆ FTS_XTP_HASHOMEEND

const DWORD FTS_XTP_HASHOMEEND = 0x0004
See also
CXTPExcelTabCtrl::Create

◆ FTS_XTP_HSCROLL

const DWORD FTS_XTP_HSCROLL = 0x0010
See also
CXTPExcelTabCtrl::Create

◆ FTS_XTP_MASK

const DWORD FTS_XTP_MASK = 0x003F
See also
CXTPExcelTabCtrl::Create

◆ FTS_XTP_SQUARETABS

const DWORD FTS_XTP_SQUARETABS = 0X0020
See also
CXTPExcelTabCtrl::Create

◆ FTS_XTP_TOOLTIPS

const DWORD FTS_XTP_TOOLTIPS = 0x0008
See also
CXTPExcelTabCtrl::Create


Toolkit Pro: XTPExcelTabCtrlTheme.h File Reference

  • Source
  • Controls
  • Tab
Classes
XTPExcelTabCtrlTheme.h File Reference

Go to the source code of this file.

Classes

class | CXTPExcelTabCtrlTheme
CXTPExcelTabCtrlTheme is used to draw the CXTPExcelTabCtrl object. More...
class | CXTPExcelTabCtrlThemeOfficeXP
This class is used to draw a CXTPTabCtrl object using Excel Office XP theme. More...
class | CXTPExcelTabCtrlThemeOffice2003
This class is used to draw a CXTPTabCtrl object using Excel Office 2003 theme. More...
class | CXTPExcelTabCtrlThemeOffice2013
This class is used to draw a CXTPTabCtrl object using Excel Office 2013 theme. More...
class | CXTPExcelTabCtrlThemeVisualStudio2015
This class is used to draw a CXTPExcelTabCtrlThemeVisualStudio2015 object using Excel Visual Studio 2015 theme. More...
class | CXTPExcelTabCtrlThemeVisualStudio2017
This class is used to draw a CXTPExcelTabCtrlThemeVisualStudio2017 object using Excel Visual Studio 2017 theme. More...
class | CXTPExcelTabCtrlThemeVisualStudio2019
This class is used to draw a CXTPExcelTabCtrlThemeVisualStudio2019 object using Excel Visual Studio 2019 theme. More...
class | CXTPExcelTabCtrlThemeVisualStudio2022
This class is used to draw a CXTPExcelTabCtrlThemeVisualStudio2022 object using Excel Visual Studio 2022 theme. More...
class | CXTPExcelTabCtrlThemeNativeWindows10
This class is used to draw a CXTPTabCtrl object using Excel Native Windows 10 theme. More...
class | CXTPExcelTabCtrlThemeNativeWindows11
This class is used to draw a CXTPTabCtrl object using Excel Native Windows 11 theme. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMDIWndTab.h File Reference

  • Source
  • Controls
  • Tab
Classes
XTPMDIWndTab.h File Reference

Go to the source code of this file.

Classes

class | CXTPMDIClientWnd
CXTPMDIClientWnd is a CWnd derived helper class for the CXTPMDIWndTab tab control. More...
class | CXTPMDIWndTab
The CXTPMDIWndTab class is used for creating a tabbed MDI document interface. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTabBase.h File Reference

  • Source
  • Controls
  • Tab
Classes | Enumerations
XTPTabBase.h File Reference

Go to the source code of this file.

Classes

class | CXTPTabBase
CXTPTabBase is a standalone base class. More...
class | CXTPTabExBase
CXTPTabExBase is a standalone base class. More...

Enumerations

enum XTPNavBtnState { xtpNavBtnArrows = 1 , xtpNavBtnClose = 2 , xtpNavBtnShowAll = 3 }
Enumeration used to determine the navigation button display for a CXTPTabCtrl object. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Enumeration Type Documentation

◆ XTPNavBtnState

enum XTPNavBtnState

Enumeration used to determine the navigation button display for a CXTPTabCtrl object.

XTPNavBtnState type defines the constants used by the CXTPTabCtrl class to determine which navigation buttons to display.

See also
CXTPTabCtrl
xtpNavBtnArrows, xtpNavBtnClose, xtpNavBtnShowAll>
Enumerator
xtpNavBtnArrows | Display arrow buttons.
xtpNavBtnClose | Display close button.
xtpNavBtnShowAll | Display arrow and close buttons.


Toolkit Pro: XTPTabBaseTheme.h File Reference

  • Source
  • Controls
  • Tab
Classes
XTPTabBaseTheme.h File Reference

Go to the source code of this file.

Classes

class | CXTPTabBaseTheme
CXTPTabBaseTheme is used to draw the CXTPTabBase object. More...
class | CXTPTabBaseThemeOfficeXP
Class CXTPTabBaseThemeOfficeXP is derived from CXTPTabBaseTheme. More...
class | CXTPTabBaseThemeOffice2003
Class CXTPTabBaseThemeOffice2003 is derived from CXTPTabBaseThemeOfficeXP. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTabCtrl.h File Reference

  • Source
  • Controls
  • Tab
Classes
XTPTabCtrl.h File Reference

Go to the source code of this file.

Classes

class CXTPTabCtrl
CXTPTabCtrl is a multiple inheritance class derived from CTabCtrl and CXTPTabCtrlBase. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTabCtrlButtons.h File Reference

  • Source
  • Controls
  • Tab
Classes
XTPTabCtrlButtons.h File Reference

Go to the source code of this file.

Classes

class | CXTPTabCtrlButton
CXTPTabCtrlButton is a standalone structure class. More...
class | CXTPTabCtrlButtons
CXTPTabCtrlButtons is a CWnd derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTabView.h File Reference

  • Source
  • Controls
  • Tab
Classes
XTPTabView.h File Reference

Go to the source code of this file.

Classes

class CXTPTabView
CXTPTabView is a multiple inheritance class derived from CCtrlView and CXTPTabCtrlBaseEx. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: TagCloud Directory Reference

  • Source
  • Controls
  • TagCloud
TagCloud Directory Reference

Files

XTPTagCloudCtrl.h


Toolkit Pro: XTPTagCloudCtrl.h File Reference

  • Source
  • Controls
  • TagCloud
Classes | Typedefs | Enumerations | Functions
XTPTagCloudCtrl.h File Reference

Go to the source code of this file.

Classes

class | CXTPTagCloudStyle
CXTPTagCloudStyle is a helper class used by CXTPTagCloudStyleManager to manage styles for the CXTPTagCloudCtrl class. More...
class | CXTPTagCloudStyleManager
CXTPTagCloudStyleManager is a singleton class used to manage CXTPTagCloudStyle structs that identify each tag style used by CXTPTagCloudCtrl. More...
struct | XTP_TAGCLOUDTAG
Manages the attributes for each tag element such as weight, font, background and foreground color. More...
class | CXTPTagCloudTagArray
CXTPTagCloudTagArray is a CArray derived class used to manage XTP_TAGCLOUDTAG objects for the CXTPTagCloudCtrl class. More...
class | CXTPTagCloudCtrl
The CXTPTagCloudCtrl class is used to create a tag cloud control representing a visual depiction of generated tags identified by color and font size to represent the prominence or frequency of the tags depicted. More...

Typedefs

typedef CArray< CXTPTagCloudStyle *, CXTPTagCloudStyle * > CXTPTagCloudStyleArray
CArray based object used for storing CXTPTagCloudStyle structs.

Enumerations

enum XTPTagCloudSort { xtpTagCloudNone , xtpTagCloudAlpha , xtpTagCloudNumeric }
XTPTagCloudSort is an enumeration used by the CXTPTagCloudTagArray class to perform sorting operations. More...

Functions

_XTP_EXT_CLASS CXTPTagCloudStyleManager *AFX_CDECL XTPTabCloudStyleManager ()
Use the XTPTabCloudStyleManager() function for access to the singleton class CXTPTagCloudStyleManager.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Enumeration Type Documentation

◆ XTPTagCloudSort

enum XTPTagCloudSort

XTPTagCloudSort is an enumeration used by the CXTPTagCloudTagArray class to perform sorting operations.

Enumerator
xtpTagCloudNone | No sorting.
xtpTagCloudAlpha | Sort by tag name.
xtpTagCloudNumeric | Sort by tag score.

Function Documentation

◆ XTPTabCloudStyleManager()

_XTP_EXT_CLASS CXTPTagCloudStyleManager *AFX_CDECL XTPTabCloudStyleManager ( )

Use the XTPTabCloudStyleManager() function for access to the singleton class CXTPTagCloudStyleManager.

Returns
A global tab cloud style manager object pointer.


Toolkit Pro: Tree Directory Reference

  • Source
  • Controls
  • Tree
Tree Directory Reference

Files

XTPMarkupTreeCtrl.h
XTPTreeBase.h
XTPTreeCtrlView.h
XTPTreeTheme.h


Toolkit Pro: XTPMarkupTreeCtrl.h File Reference

  • Source
  • Controls
  • Tree
Classes
XTPMarkupTreeCtrl.h File Reference

Go to the source code of this file.

Classes

class CXTPMarkupTreeCtrl
Tree control class that allows for adding markup items. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTreeBase.h File Reference

  • Source
  • Controls
  • Tree
Classes | Variables
XTPTreeBase.h File Reference

Go to the source code of this file.

Classes

class | CXTPTreeBase
CXTPTreeBase is a CTreeView derived class. More...
struct | CXTPTreeBase::CLRFONT
CLRFONT structure is used to by the CXTPShellTreeCtrl and CXTPShellTreeView classes to maintain font information for a particular tree item. More...

Variables

const DWORD TVIS_FOCUSED = 0x0001

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Variable Documentation

◆ TVIS_FOCUSED

const DWORD TVIS_FOCUSED = 0x0001
See also
CXTPTreeBase::SetItemState


Toolkit Pro: XTPTreeCtrlView.h File Reference

  • Source
  • Controls
  • Tree
Classes | Typedefs
XTPTreeCtrlView.h File Reference

Go to the source code of this file.

Classes

class | CXTPTreeView
CXTPTreeView is a CTreeView derived class. More...
class | CXTPTreeCtrl
CXTPTreeCtrl is a CTreeCtrl derived class. More...
class | CXTPScrollableTreeCtrlT< TreeBase >
An adaptor for any CTreeCtrl derived control that overrides standard scrollbars with custom scrollbars. More...

Typedefs

typedef CXTPScrollableTreeCtrlT< CXTPTreeCtrl > CXTPScrollableTreeCtrl
Type alias for a CXTPTreeCtrl derived scrollable control.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTreeTheme.h File Reference

  • Source
  • Controls
  • Tree
Classes
XTPTreeTheme.h File Reference

Go to the source code of this file.

Classes

class | CXTPTreeTheme
CXTPTreeTheme is a class used to perform tree control theme drawing tasks. More...
class | CXTPTreeVisualStudio2012Theme
CXTPTreeVisualStudio2012Theme is a CXTPTreeTheme derived class used to render a Visual Studio 2012 style tree. More...
class | CXTPTreeOffice2013Theme
CXTPTreeOffice2013Theme is a CXTPTreeTheme derived class used to render a Office 2013 style tree. More...
class | CXTPTreeVisualStudio2015Theme
CXTPTreeVisualStudio2015Theme is a CXTPTreeTheme derived class used to render a Visual Studio 2015 style tree. More...
class | CXTPTreeVisualStudio2017Theme
CXTPTreeVisualStudio2017Theme is a CXTPTreeTheme derived class used to render a Visual Studio 2017 style tree. More...
class | CXTPTreeVisualStudio2019Theme
CXTPTreeVisualStudio2019Theme is a CXTPTreeTheme derived class used to render a Visual Studio 2019 style tree. More...
class | CXTPTreeVisualStudio2022Theme
CXTPTreeVisualStudio2022Theme is a CXTPTreeTheme derived class used to render a Visual Studio 2022 style tree. More...
class | CXTPTreeNativeWindows10Theme
CXTPTreeNativeWindows10Theme is a CXTPTreeTheme derived class used to render a Native Windows 10 style tree. More...
class | CXTPTreeNativeWindows11Theme
CXTPTreeNativeWindows11Theme is a CXTPTreeTheme derived class used to render a Native Windows 11 style tree. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: Util Directory Reference

  • Source
  • Controls
  • Util
Util Directory Reference

Files

XTPAnimationDC.h
XTPControlTheme.h
XTPFunctions.h
XTPGlobal.h
XTPHelpers.h
XTPMemFile.h
XTPRegistryManager.h
XTPUtil.h
XTPWindowPos.h


Toolkit Pro: XTPAnimationDC.h File Reference

  • Source
  • Controls
  • Util
Classes | Enumerations
XTPAnimationDC.h File Reference

Go to the source code of this file.

Classes

class CXTPAnimationDC
CXTPAnimationDC is a CXTPBufferDC derived class. More...

Enumerations

enum XTPAnimationDCType {
xtpAniDefault , xtpAniRandom , xtpAniUnfold , xtpAniSlide ,
xtpAniFade , xtpAniNone
}
Enumeration used to determine animation style. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Enumeration Type Documentation

◆ XTPAnimationDCType

enum XTPAnimationDCType

Enumeration used to determine animation style.

XTPAnimationDCType type defines constants used by the CXTPAnimationDC class to determine the animation effect for the current device context.

See also
CXTPAnimationDC, CXTPAnimationDC::Animate, CXTPAnimationDC::SetCustomAnimation
xtpAniDefault, xtpAniRandom, xtpAniUnfold, xtpAniSlide, xtpAniFade, xtpAniNone
Enumerator
xtpAniDefault | Uses Windows default animation settings.
xtpAniRandom | Animates a window with a random animation type.
xtpAniUnfold | Animates a window to unfold top to bottom.
xtpAniSlide | Animates a window to slide in from the left.
xtpAniFade | Animates a window with a fade-in effect.
xtpAniNone | No animation.


Toolkit Pro: XTPControlTheme.h File Reference

  • Source
  • Controls
  • Util
Classes | Enumerations
XTPControlTheme.h File Reference

Go to the source code of this file.

Classes

class CXTPControlTheme
CXTPControlTheme can be used as a base class for user defined themes. More...

Enumerations

enum XTPControlTheme {
xtpControlThemeDefault , xtpControlThemeFlat , xtpControlThemeUltraFlat , xtpControlThemeOffice2000 ,
xtpControlThemeOfficeXP , xtpControlThemeOffice2003 , xtpControlThemeNativeWinXP , xtpControlThemeResource ,
xtpControlThemeVisualStudio2005 , xtpControlThemeVisualStudio2008 , xtpControlThemeVisualStudio2010 , xtpControlThemeCustom ,
xtpControlThemeOffice2013 , xtpControlThemeOffice2016 = xtpControlThemeOffice2013 , xtpControlThemeVisualStudio2012 , xtpControlThemeVisualStudio2012Light ,
xtpControlThemeVisualStudio2012Dark , xtpControlThemeVisualStudio2015 , xtpControlThemeNativeWindows10 , xtpControlThemeVisualStudio2017 ,
xtpControlThemeVisualStudio2019 , xtpControlThemeVisualStudio2022 , xtpControlThemeNativeWindows11
}
Enumeration used to determine the active theme style. More...
enum XTPControlDrawState {
xtpControlDrawStateNormal = 0x0000 , xtpControlDrawStateDisabled = 0x0001 , xtpControlDrawStateHotLight = 0x0002 , xtpControlDrawStateHotButton = 0x0004 ,
xtpControlDrawStateSelected = 0x0008 , xtpControlDrawStatePushed = 0x0010 , xtpControlDrawStateFocus = 0x0020
}
Enumeration used to determine the display state for a themed window. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Enumeration Type Documentation

◆ XTPControlDrawState

enum XTPControlDrawState

Enumeration used to determine the display state for a themed window.

The XTPControlDrawState enumeration type defines the constants that indicate the display state for a particular window.

Enumerator
xtpControlDrawStateNormal | The window should be drawn normal.
xtpControlDrawStateDisabled | The window should be drawn disabled.
xtpControlDrawStateHotLight | The window has the mouse cursor hovering.
xtpControlDrawStateHotButton | The window has the mouse cursor hovering over a drop button.
xtpControlDrawStateSelected | The window has an item selected.
xtpControlDrawStatePushed | The window has an item selected and the left mouse button is pressed.
xtpControlDrawStateFocus | The window has keyboard focus.

◆ XTPControlTheme

enum XTPControlTheme

Enumeration used to determine the active theme style.

The XTPControlTheme enumeration type defines the constants that indicate the theme for a particular window or application.

Enumerator
xtpControlThemeDefault | Default Windows classic theme.
xtpControlThemeFlat | Flat appearance style.
xtpControlThemeUltraFlat | Ultra flat appearance style.
xtpControlThemeOffice2000 | Office 2000 style theme.
xtpControlThemeOfficeXP | Office XP style theme.
xtpControlThemeOffice2003 | Office 2003 style theme.
xtpControlThemeNativeWinXP | Windows XP and later native theme support.
xtpControlThemeResource | Office 2007/Office 2010/Windows7 external resource .DLL.
xtpControlThemeVisualStudio2005 | Visual Studio 2005 style theme.
xtpControlThemeVisualStudio2008 | Visual Studio 2008 style theme.
xtpControlThemeVisualStudio2010 | Visual Studio 2010 style theme.
xtpControlThemeCustom | User defined custom theme.
xtpControlThemeOffice2013 | Office 2013 control theme.
xtpControlThemeOffice2016 | Office 2016 control theme.
xtpControlThemeVisualStudio2012 | VS 2012 style theme.
xtpControlThemeVisualStudio2012Light | VS 2012 Light style theme.
xtpControlThemeVisualStudio2012Dark | VS 2012 Dark style theme.
xtpControlThemeVisualStudio2015 | VS 2015 style theme.
xtpControlThemeNativeWindows10 | Native Windows 10 theme support.
xtpControlThemeVisualStudio2017 | VS 2017 style theme.
xtpControlThemeVisualStudio2019 | VS 2019 style theme.
xtpControlThemeVisualStudio2022 | VS 2022 style theme.
xtpControlThemeNativeWindows11 | Native Windows 11 theme support.


Toolkit Pro: XTPFunctions.h File Reference

  • Source
  • Controls
  • Util
Functions
XTPFunctions.h File Reference

Go to the source code of this file.

Functions

_XTP_EXT_CLASS void AFXAPI | XTPChangeWindowFont (CWnd *pWnd, CFont *pFont)
The XTPChangeWindowFont function will set the font for the window specified by pWnd and all of the child windows owned by pWnd.
_XTP_EXT_CLASS void AFXAPI | XTPDrawEmbossed (CDC *pDC, CImageList &imageList, int nIndex, CPoint point, BOOL bInColor)
The XTPDrawEmbossed function will draw an embossed icon onto the specified device context from the image list imageList.
_XTP_EXT_CLASS void AFXAPI | XTPDrawShadedRect (CDC *pDC, CRect &rect)
Renders a shadow onto the specified device context.
_XTP_EXT_CLASS HWND AFXAPI | XTPChildWindowFromPoint (HWND hWnd, POINT point)
The XTPChildWindowFromPoint function will retrieve an HWND handle for the child window (if any) located directly under the cursor position specified by point.
_XTP_EXT_CLASS BOOL AFXAPI | XTPPathExists (LPCTSTR lpszFileName)
The XTPPathExists function searches a directory for a file or sub-directory whose name matches the specified name.
_XTP_EXT_CLASS CWnd *AFXAPI | XTPCreateView (CWnd *pParentWnd, CRuntimeClass *pViewClass, CDocument *pDocument=NULL, CCreateContext *pContext=NULL, DWORD dwStyle=AFX_WS_DEFAULT_VIEW, CWnd *pOwnerWnd=NULL, UINT nID=AFX_IDW_PANE_FIRST)
Creates a view based on a CRuntimeClass object.
_XTP_EXT_CLASS BOOL AFXAPI | XTPContextMenu (CMenu *pPopup, UINT nFlags, int xPos, int yPos, CWnd *pWnd, int nIDBitmap, BOOL bNoNotify=TRUE)
Call this member function to display a context menu that is compatible with both pro and standard versions.
_XTP_EXT_CLASS BOOL AFXAPI | XTPContextMenu (CMenu *pPopup, UINT nFlags, int xPos, int yPos, CWnd *pWnd, CXTPImageManager *pImageManager, BOOL bNoNotify=TRUE)
Call this member function to display a context menu that is compatible with both pro and standard versions.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Function Documentation

◆ XTPChangeWindowFont()

_XTP_EXT_CLASS void AFXAPI XTPChangeWindowFont | ( | CWnd * | pWnd,
 |  | CFont * | pFont )

The XTPChangeWindowFont function will set the font for the window specified by pWnd and all of the child windows owned by pWnd.

Parameters
pWnd | Pointer to a valid CWnd object.
pFont | Pointer to the new font to set for the window.
Returns

◆ XTPChildWindowFromPoint()

_XTP_EXT_CLASS HWND AFXAPI XTPChildWindowFromPoint | ( | HWND | hWnd,
 |  | POINT | point )

The XTPChildWindowFromPoint function will retrieve an HWND handle for the child window (if any) located directly under the cursor position specified by point.

Parameters
hWnd | HWND handle of the parent window to find the child for.
point | Current cursor position.
Returns
An HWND handle for the child window at point.

◆ XTPContextMenu() [1/2]

_XTP_EXT_CLASS BOOL AFXAPI XTPContextMenu | ( | CMenu * | pPopup,
 |  | UINT | nFlags,
 |  | int | xPos,
 |  | int | yPos,
 |  | CWnd * | pWnd,
 |  | CXTPImageManager * | pImageManager,
 |  | BOOL | bNoNotify = TRUE )

Call this member function to display a context menu that is compatible with both pro and standard versions.

Parameters
pPopup | Pointer to a valid CMenu object.
nFlags | Specifies a screen-position flag and a mouse-button flag. The screen-position flag can be one of the following: TPM_CENTERALIGN: Centers the pop-up menu horizontally relative to the coordinate specified by x. TPM_LEFTALIGN: Positions the pop-up menu so that its left side is aligned with the coordinate specified by x. TPM_RIGHTALIGN: Positions the pop-up menu so that its right side is aligned with the coordinate specified by x. The mouse-button flag can be either of the following: TPM_LEFTBUTTON: Causes the pop-up menu to track the left mouse button. TPM_RIGHTBUTTON: Causes the pop-up menu to track the right mouse button.
xPos | Specifies the horizontal position in screen coordinates of the pop-up menu. Depending on the value of the nFlags parameter, the menu can be left-aligned, right-aligned, or centered relative to this position.
yPos | Specifies the vertical position in screen coordinates of the top of the menu on the screen.
pWnd | Identifies the window that owns the pop-up menu. This window receives all WM_COMMAND messages from the menu. In Windows versions 3.1 and later, the window does not receive WM_COMMAND messages until TrackPopupMenu returns. In Windows 3.0, the window receives WM_COMMAND messages before TrackPopupMenu returns.
pImageManager | Points to a CXTPImageManager object.
bNoNotify | TRUE to notify the control.

A floating pop-up menu can appear anywhere on the screen.

See also
CXTPCommandBars::TrackPopupMenu

Example: The following example demonstrates using XTPContextMenu:

CPoint pt = point;
ClientToScreen(&pt);

CMenu menu;
VERIFY(XTPResourceManager()->LoadMenu(&menu, XTP_IDM_POPUP));

CMenu* pPopup = menu.GetSubMenu(0);
_ASSERTE(pPopup != NULL);
CWnd* pWndPopupOwner = this;

XTPContextMenu(pPopup, TPM_LEFTALIGN | TPM_RIGHTBUTTON,
   pt.x, pt.y, pWndPopupOwner, XTP_IDR_TBAR_OUT);
Returns
True to display a context menu

◆ XTPContextMenu() [2/2]

_XTP_EXT_CLASS BOOL AFXAPI XTPContextMenu | ( | CMenu * | pPopup,
 |  | UINT | nFlags,
 |  | int | xPos,
 |  | int | yPos,
 |  | CWnd * | pWnd,
 |  | int | nIDBitmap,
 |  | BOOL | bNoNotify = TRUE )

Call this member function to display a context menu that is compatible with both pro and standard versions.

Parameters
pPopup | Pointer to a valid CMenu object.
nFlags | Specifies a screen-position flag and a mouse-button flag. The screen-position flag can be one of the following: TPM_CENTERALIGN: Centers the pop-up menu horizontally relative to the coordinate specified by x. TPM_LEFTALIGN: Positions the pop-up menu so that its left side is aligned with the coordinate specified by x. TPM_RIGHTALIGN: Positions the pop-up menu so that its right side is aligned with the coordinate specified by x. The mouse-button flag can be either of the following: TPM_LEFTBUTTON: Causes the pop-up menu to track the left mouse button. TPM_RIGHTBUTTON: Causes the pop-up menu to track the right mouse button.
xPos | Specifies the horizontal position in screen coordinates of the pop-up menu. Depending on the value of the nFlags parameter, the menu can be left-aligned, right-aligned, or centered relative to this position.
yPos | Specifies the vertical position in screen coordinates of the top of the menu on the screen.
pWnd | Identifies the window that owns the pop-up menu. This window receives all WM_COMMAND messages from the menu. In Windows versions 3.1 and later, the window does not receive WM_COMMAND messages until TrackPopupMenu returns. In Windows 3.0, the window receives WM_COMMAND messages before TrackPopupMenu returns.
nIDBitmap | Toolbar resource ID that contains images to be displayed with menu commands.
bNoNotify | TRUE to notify the control.

A floating pop-up menu can appear anywhere on the screen.

See also
CXTPCommandBars::TrackPopupMenu

Example: The following example demonstrates using XTPContextMenu:

CPoint pt = point;
ClientToScreen(&pt);

CMenu menu;
VERIFY(XTPResourceManager()->LoadMenu(&menu, XTP_IDM_POPUP));

CMenu* pPopup = menu.GetSubMenu(0);
_ASSERTE(pPopup != NULL);
CWnd* pWndPopupOwner = this;

XTPContextMenu(pPopup, TPM_LEFTALIGN | TPM_RIGHTBUTTON,
   pt.x, pt.y, pWndPopupOwner, XTP_IDR_TBAR_OUT);
Returns
True to display a context menu

◆ XTPCreateView()

_XTP_EXT_CLASS CWnd *AFXAPI XTPCreateView | ( | CWnd * | pParentWnd,
 |  | CRuntimeClass * | pViewClass,
 |  | CDocument * | pDocument = NULL,
 |  | CCreateContext * | pContext = NULL,
 |  | DWORD | dwStyle = AFX_WS_DEFAULT_VIEW,
 |  | CWnd * | pOwnerWnd = NULL,
 |  | UINT | nID = AFX_IDW_PANE_FIRST )

Creates a view based on a CRuntimeClass object.

Parameters
pParentWnd | Pointer to the parent of the view to be created. The parent must be valid.
pViewClass | Specifies the CRuntimeClass of the new view.
pDocument | CDocument associated with the view. It can be NULL.
pContext | Create context for the view. It can be NULL.
dwStyle | Default style for the view.
pOwnerWnd | Owner of the view. If NULL, then 'pParentWnd' is used.
nID | Control ID of the view.

The XTPCreateView function will create a view based on the CRuntimeClass pViewClass.

Returns
A CWnd* pointer to the newly created view if successful, otherwise NULL. Example:
CView* pView = (CView*)XTPCreateView(this, RUNTIME_CLASS(CMyView));
_ASSERTE(pView);

◆ XTPDrawEmbossed()

_XTP_EXT_CLASS void AFXAPI XTPDrawEmbossed | ( | CDC * | pDC,
 |  | CImageList & | imageList,
 |  | int | nIndex,
 |  | CPoint | point,
 |  | BOOL | bInColor )

The XTPDrawEmbossed function will draw an embossed icon onto the specified device context from the image list imageList.

It is typically used by toolbars and menus to draw a disabled icon in color.

Parameters
pDC | Pointer to the current device context.
imageList | Address of an image list.
nIndex | Index of the image in the image list.
point | XY location of where to draw the icon.
bInColor | TRUE to draw the item in color; otherwise the icon will be drawn with the default disabled look.
Returns

◆ XTPDrawShadedRect()

_XTP_EXT_CLASS void AFXAPI XTPDrawShadedRect | ( | CDC * | pDC,
 |  | CRect & | rect )

Renders a shadow onto the specified device context.

Parameters
pDC | Pointer to the current device context.
rect | Size of the area to draw.

The XTPDrawShadedRect function will render a shaded or 'shadow' rectangle onto the the device context specified by pDC.

Returns

◆ XTPPathExists()

_XTP_EXT_CLASS BOOL AFXAPI XTPPathExists ( LPCTSTR lpszFileName )

The XTPPathExists function searches a directory for a file or sub-directory whose name matches the specified name.

Parameters
lpszFileName [in] A pointer to a NULL-terminated string that specifies a valid directory or path and file name, which can contain wild card characters (* and ?). If the string ends with a wild card, a period, or a directory name, then the user must have access to the root and all sub-directories on the path.
Returns
TRUE if the file or sub-directory exists, otherwise FALSE.


Toolkit Pro: XTPGlobal.h File Reference

  • Source
  • Controls
  • Util
Classes | Functions
XTPGlobal.h File Reference

Go to the source code of this file.

Classes

class | CXTPTcbItem
The CXTPTcbItem class is used to maintain information for a particular tab item in a CXTPExcelTabCtrl, CXTPTabCtrl, or CXTPTabView object. More...
class | CXTPLogFont
CXTPLogFont is a self initializing LOGFONT derived class. More...
class | CXTPAuxData
CXTPAuxData is a standalone global item data structure class. More...

Functions

_XTP_EXT_CLASS CXTPAuxData &AFXAPI XTPAuxData ()
The XTPAuxData function is used for access to the CXTPAuxData class.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Function Documentation

◆ XTPAuxData()

_XTP_EXT_CLASS CXTPAuxData &AFXAPI XTPAuxData ( )

The XTPAuxData function is used for access to the CXTPAuxData class.

Call this function to access CXTPAuxData members. Since this class is designed as a single instance object, you can only access its members through this method. You cannot directly instantiate an object of type CXTPAuxData.

Returns
A pointer to the one and only CXTPAuxData instance. Example: The following example demonstrates the use of XTPAuxData:
bool bIsWinNT = XTPAuxData().bWinNT;
See also
CXTPAuxData


Toolkit Pro: XTPHelpers.h File Reference

  • Source
  • Controls
  • Util
XTPHelpers.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMemFile.h File Reference

  • Source
  • Controls
  • Util
Classes
XTPMemFile.h File Reference

Go to the source code of this file.

Classes

class CXTPMemFile
CXTPMemFile is a CMemFile derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPRegistryManager.h File Reference

  • Source
  • Controls
  • Util
Classes
XTPRegistryManager.h File Reference

Go to the source code of this file.

Classes

class CXTPRegistryManager
CXTPRegistryManager is a standalone registry management class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPUtil.h File Reference

  • Source
  • Controls
  • Util
Classes
XTPUtil.h File Reference

Go to the source code of this file.

Classes

class | CXTPIconHandle
CXTPIconHandle is a standalone helper class. More...
class | CXTPSplitPath
CXTPSplitPath conveniently wraps the _splitpath API for easier access to path components such as file name and extension. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPWindowPos.h File Reference

  • Source
  • Controls
  • Util
Classes
XTPWindowPos.h File Reference

Go to the source code of this file.

Classes

class CXTPWindowPos
CXTPWindowPos is a WINDOWPLACEMENT structure derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: View Directory Reference

  • Source
  • Controls
  • View
View Directory Reference

Files

XTPMarkupView.h


Toolkit Pro: XTPMarkupView.h File Reference

  • Source
  • Controls
  • View
XTPMarkupView.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: WebBrowser Directory Reference

  • Source
  • Controls
  • WebBrowser
WebBrowser Directory Reference

Directories

Providers

Files

XTPWebBrowserAbstract.h
XTPWebBrowserCtrl.h


Toolkit Pro: Providers Directory Reference

  • Source
  • Controls
  • WebBrowser
  • Providers
Providers Directory Reference

Directories

WebView2

Files

XTPShellExplorerProvider.h
XTPWebBrowserControlSite.h
XTPWebBrowserProvider.h
XTPWebViewProvider.h


Toolkit Pro: WebView2 Directory Reference

  • Source
  • Controls
  • WebBrowser
  • Providers
  • WebView2
WebView2 Directory Reference

Files

XTPWebView2.h


Toolkit Pro: XTPWebView2.h File Reference

  • Source
  • Controls
  • WebBrowser
  • Providers
  • WebView2
Macros
XTPWebView2.h File Reference

Go to the source code of this file.

Macros

#define XTP_BROWSER_WEBVIEW_MIN_VC_VERSION 1900
Defines the minimum supported _MSC_VER value that corresponds to Visual Studio 2015 for WebView2 web browser provider to be enabled.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPShellExplorerProvider.h File Reference

  • Source
  • Controls
  • WebBrowser
  • Providers
Classes
XTPShellExplorerProvider.h File Reference

Go to the source code of this file.

Classes

class CXTPShellExplorerProvider
Implements ShellExplorer WebBrowser provider and gives access to ShellExplorer specific functionality. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPWebBrowserControlSite.h File Reference

  • Source
  • Controls
  • WebBrowser
  • Providers
XTPWebBrowserControlSite.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPWebBrowserProvider.h File Reference

  • Source
  • Controls
  • WebBrowser
  • Providers
Classes
XTPWebBrowserProvider.h File Reference

Go to the source code of this file.

Classes

class CXTPWebBrowserProvider
Implements the base class for a WebBrowser provider. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPWebViewProvider.h File Reference

  • Source
  • Controls
  • WebBrowser
  • Providers
Classes
XTPWebViewProvider.h File Reference

Go to the source code of this file.

Classes

class CXTPWebViewProvider
Implements WebView2 WebBrowser provider and gives access to WebView2 specific functionality. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPWebBrowserAbstract.h File Reference

  • Source
  • Controls
  • WebBrowser
Classes
XTPWebBrowserAbstract.h File Reference

Go to the source code of this file.

Classes

struct IXTPWebBrowserEventSink
Describes default WebBrowser control event sink interface and providers default implementation of the event handlers. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPWebBrowserCtrl.h File Reference

  • Source
  • Controls
  • WebBrowser
Classes | Enumerations
XTPWebBrowserCtrl.h File Reference

Go to the source code of this file.

Classes

class CXTPWebBrowserCtrl
Implements the WebBrowser control that is capable of hosting different supported Web browsers. More...

Enumerations

enum XTPWebBrowserProvider { xtpWebBrowserInvalid = -1 , xtpWebBrowserShellExplorer , xtpWebBrowserWebView , xtpWebBrowserLatest = xtpWebBrowserWebView }
Defines possible WebBrowser providers. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Enumeration Type Documentation

◆ XTPWebBrowserProvider

enum XTPWebBrowserProvider

Defines possible WebBrowser providers.

Enumerator
xtpWebBrowserInvalid | Specifies an invalid WebBrowser provider.
xtpWebBrowserShellExplorer | Specifies the ShellExplorer WebBrowser provider, which is also used by the Microsoft Internet Explorer browser.
xtpWebBrowserWebView | Specifies the WebView2 WebBrowser provider, which is also used by the Microsoft Edge browser.
xtpWebBrowserLatest | Specifies the latest supported WebBrowser provider.


Toolkit Pro: XTPControlsIIDs.h Source File

  • Source
  • Controls
XTPControlsIIDs.h
1// DO NOT MODIFY MANUALLY
2// Generated on Thu 12/11/2025 at 12:46:11.27 using cj-update-iids.cmd
3
24#ifndef __XTPControlsIIDs_H__
25# define __XTPControlsIIDs_H__
26
27// clang-format off
28
29#define XTP_DEFINE_GUID(name,l,w1,w2,b1,b2,b3,b4,b5,b6,b7,b8) \
30 EXTERN_C __declspec(selectany) const IID XTP##name = {l,w1,w2,{b1,b2,b3,b4,b5,b6,b7,b8}}; \
31 const unsigned long XTP##name##__Data1 = (l); \
32 const unsigned short XTP##name##__Data2 = (w1); \
33 const unsigned short XTP##name##__Data3 = (w2); \
34 const unsigned char XTP##name##__Data4_0 = (b1); \
35 const unsigned char XTP##name##__Data4_1 = (b2); \
36 const unsigned char XTP##name##__Data4_2 = (b3); \
37 const unsigned char XTP##name##__Data4_3 = (b4); \
38 const unsigned char XTP##name##__Data4_4 = (b5); \
39 const unsigned char XTP##name##__Data4_5 = (b6); \
40 const unsigned char XTP##name##__Data4_6 = (b7); \
41 const unsigned char XTP##name##__Data4_7 = (b8);
42
43XTP_DEFINE_GUID(LIBID_XtremeSuiteControls,0xA8E5842E,0x102B,0x4289,0x9D,0x57,0x3B,0x3F,0x5B,0x5E,0x15,0xD3);
44XTP_DEFINE_GUID(DIID_MarkupContext,0xC0DE2430,0xD073,0x4043,0xAA,0x8C,0x62,0xB5,0xBD,0x8E,0x52,0x2D);
45XTP_DEFINE_GUID(DIID__DButton,0xC0DE2430,0xF036,0x40C6,0x85,0x89,0x63,0xF3,0xE8,0xE8,0x88,0x0B);
46XTP_DEFINE_GUID(CLSID_Button,0xC0DE2430,0x8AA3,0x49E1,0x87,0x5E,0x58,0x24,0x67,0xD5,0x70,0xBE);
47XTP_DEFINE_GUID(DIID__DPushButton,0xC0DE2430,0xBCC5,0x4968,0x83,0x1B,0x81,0x07,0xFB,0x93,0xDA,0xF8);
48XTP_DEFINE_GUID(DIID__DPushButtonEvents,0xC0DE2430,0xF943,0x48EE,0xAE,0x76,0xB8,0xA1,0x24,0xD9,0xB7,0x01);
49XTP_DEFINE_GUID(CLSID_PushButton,0xC0DE2430,0x589B,0x49D9,0x90,0x8F,0xE4,0x0E,0x13,0x5F,0x82,0xC0);
50XTP_DEFINE_GUID(DIID__DPushButtonPropPage,0xC0DE2430,0x3D4C,0x44F9,0xB3,0xF1,0xFB,0xF1,0xD4,0x85,0xAA,0x82);
51XTP_DEFINE_GUID(CLSID_PushButtonPropPage,0xC0DE2430,0xB8DD,0x4D4F,0x85,0xD6,0xA7,0xC1,0x55,0x82,0x9B,0x18);
52XTP_DEFINE_GUID(DIID__DRadioButton,0xC0DE2430,0x20FB,0x4390,0x81,0x52,0x48,0xE5,0x0D,0xD2,0xE0,0x0D);
53XTP_DEFINE_GUID(DIID__DRadioButtonEvents,0xC0DE2430,0x7963,0x418D,0x9F,0x13,0x13,0xD0,0x86,0x2D,0xF6,0x47);
54XTP_DEFINE_GUID(CLSID_RadioButton,0xC0DE2430,0x6CF3,0x4E62,0x84,0xE0,0x3A,0x29,0x43,0x84,0xBE,0xFC);
55XTP_DEFINE_GUID(DIID__DCheckBox,0xC0DE2430,0xE671,0x4AE7,0x9D,0x30,0x7F,0xCC,0x69,0x1B,0x24,0xFC);
56XTP_DEFINE_GUID(DIID__DCheckBoxEvents,0xC0DE2430,0x08CC,0x4B3D,0x82,0xEA,0x3B,0x7B,0xE0,0xCF,0x11,0x17);
57XTP_DEFINE_GUID(CLSID_CheckBox,0xC0DE2430,0xF43F,0x4510,0x9E,0xE7,0x94,0x84,0x5C,0x66,0x75,0xDF);
58XTP_DEFINE_GUID(DIID__DGroupBox,0xC0DE2430,0xA1F7,0x4397,0x8C,0xE5,0xB6,0x17,0x47,0xD5,0x6B,0x8E);
59XTP_DEFINE_GUID(DIID__DGroupBoxEvents,0xC0DE2430,0xDF35,0x44EC,0xBD,0xBD,0x94,0xCD,0x0B,0x3B,0xF4,0xD8);
60XTP_DEFINE_GUID(CLSID_GroupBox,0xC0DE2430,0x85F1,0x47D9,0xA2,0x37,0x01,0xBE,0x92,0x03,0xBB,0x36);
61XTP_DEFINE_GUID(DIID__DColorPicker,0xC0DE2430,0x4AE7,0x47F4,0xBE,0xA6,0x8F,0x37,0x6D,0x79,0x47,0xB2);
62XTP_DEFINE_GUID(DIID__DColorPickerEvents,0xC0DE2430,0xD2C0,0x4C36,0xA3,0xC5,0x97,0x39,0xEA,0x1B,0x78,0x31);
63XTP_DEFINE_GUID(CLSID_ColorPicker,0xC0DE2430,0x000D,0x4CB4,0xA9,0x24,0xD0,0x0A,0x64,0x0A,0x91,0x7D);
64XTP_DEFINE_GUID(DIID__DFlatEdit,0xC0DE2430,0x31B8,0x4F06,0x99,0xA6,0x17,0xA1,0x50,0xA6,0xFB,0xE2);
65XTP_DEFINE_GUID(DIID__DFlatEditEvents,0xC0DE2430,0xB654,0x4763,0xA1,0x03,0xA3,0x83,0x0E,0x7E,0x3B,0x2D);
66XTP_DEFINE_GUID(CLSID_FlatEdit,0xC0DE2430,0x1080,0x4CA0,0xAE,0x3C,0xFB,0x01,0x7B,0x98,0xAD,0xB2);
67XTP_DEFINE_GUID(DIID__DLabel,0xC0DE2430,0xA03D,0x4B53,0x8C,0x43,0xAA,0x02,0xC1,0xAA,0xFE,0xA9);
68XTP_DEFINE_GUID(DIID__DLabelEvents,0xC0DE2430,0xFC32,0x47BE,0xAC,0x0C,0xB5,0xF7,0xE9,0xD9,0xFF,0xCF);
69XTP_DEFINE_GUID(CLSID_Label,0xC0DE2430,0x8422,0x4D30,0x85,0xAC,0xFB,0x0B,0x65,0x5D,0x40,0x0F);
70XTP_DEFINE_GUID(DIID__DListBox,0xC0DE2430,0xF4CD,0x42E1,0xA6,0x34,0x1B,0xC1,0xC1,0xED,0xBB,0xE6);
71XTP_DEFINE_GUID(DIID__DListBoxEvents,0xC0DE2430,0x4B44,0x4BEE,0xA7,0xA8,0x8F,0x59,0x54,0x39,0x0D,0x95);
72XTP_DEFINE_GUID(CLSID_ListBox,0xC0DE2430,0x3417,0x4473,0x86,0x83,0x60,0x26,0x2B,0x0C,0x84,0x85);
73XTP_DEFINE_GUID(DIID__DComboBox,0xC0DE2430,0x4B48,0x4867,0xA5,0xCB,0x96,0x65,0x32,0x04,0x14,0x92);
74XTP_DEFINE_GUID(DIID__DComboBoxEvents,0xC0DE2430,0x63FA,0x4657,0x95,0xD5,0xF8,0xC2,0xB2,0x5B,0xBD,0x4B);
75XTP_DEFINE_GUID(CLSID_ComboBox,0xC0DE2430,0x7279,0x4FEB,0x86,0x73,0x68,0x16,0xB6,0xC9,0xFE,0x24);
76XTP_DEFINE_GUID(DIID__DResizer,0xC0DE2430,0x39C1,0x424F,0x9D,0x94,0xFC,0xA6,0x11,0x22,0x60,0xB9);
77XTP_DEFINE_GUID(DIID__DResizerEvents,0xC0DE2430,0x9731,0x436F,0x8D,0x92,0xC9,0x49,0xD2,0x00,0xAD,0xA1);
78XTP_DEFINE_GUID(CLSID_Resizer,0xC0DE2430,0x9C06,0x4328,0xAD,0x29,0x26,0x03,0xCF,0x89,0x38,0x82);
79XTP_DEFINE_GUID(DIID__DResizerGeneralPropPage,0xC0DE2430,0xBC84,0x4743,0x9C,0xB4,0xFD,0xC6,0x28,0xDE,0x2B,0x35);
80XTP_DEFINE_GUID(CLSID_ResizerGeneralPropPage,0xC0DE2430,0x6A65,0x432B,0x83,0xB0,0x17,0xD0,0x3E,0x48,0xAF,0xEF);
81XTP_DEFINE_GUID(DIID__DResizerControlsPropPage,0xC0DE2430,0x371C,0x4CEB,0x88,0x82,0x1D,0x4D,0xFC,0x11,0x3F,0xE7);
82XTP_DEFINE_GUID(CLSID_ResizerControlsPropPage,0xC0DE2430,0x7A60,0x4B27,0xA5,0x94,0xD1,0xE0,0x45,0xBB,0xA3,0xD3);
83XTP_DEFINE_GUID(DIID__DTabControl,0xC0DE2430,0x451B,0x4D9D,0x83,0xE0,0xCD,0xD3,0xB5,0x89,0x17,0x8D);
84XTP_DEFINE_GUID(DIID__DTabControlEvents,0xC0DE2430,0xC2DC,0x4C83,0x88,0x40,0x87,0x9B,0x3C,0x33,0xE6,0xBD);
85XTP_DEFINE_GUID(CLSID_TabControl,0xC0DE2430,0xC16F,0x427D,0x91,0xD1,0xD9,0x0B,0x7E,0x3A,0x34,0x1E);
86XTP_DEFINE_GUID(DIID__DTabControlPage,0xC0DE2430,0xC2E4,0x43DF,0x85,0x5C,0x08,0x55,0xAB,0x5A,0x1D,0x7A);
87XTP_DEFINE_GUID(DIID__DTabControlPageEvents,0xC0DE2430,0x4866,0x4C45,0xAF,0x97,0xE4,0xF9,0x5E,0x2B,0xA5,0x5A);
88XTP_DEFINE_GUID(CLSID_TabControlPage,0xC0DE2430,0x2FB1,0x4365,0xBD,0x0C,0xAE,0xC7,0x88,0x98,0xE6,0x07);
89XTP_DEFINE_GUID(DIID__DTabControlPropPage,0xC0DE2430,0x1281,0x4828,0xBA,0xE0,0x5E,0x5D,0x62,0x5A,0x5D,0x60);
90XTP_DEFINE_GUID(CLSID_TabControlPropPage,0xC0DE2430,0xC4B0,0x4042,0x91,0x24,0x45,0x30,0x6C,0xDA,0xBA,0xCB);
91XTP_DEFINE_GUID(DIID__DTabMarginsPropPage,0xC0DE2430,0x1FB4,0x45D8,0x89,0xBD,0x02,0x54,0x62,0x69,0x17,0xB9);
92XTP_DEFINE_GUID(CLSID_TabMarginsPropPage,0xC0DE2430,0x607A,0x4DB1,0x93,0x92,0xFC,0x8F,0xE2,0xC8,0xCE,0x94);
93XTP_DEFINE_GUID(DIID__DTabPaintManagerPropPage,0xC0DE2430,0x3433,0x4835,0x9C,0xFE,0x22,0x08,0x9B,0x86,0xE3,0xDC);
94XTP_DEFINE_GUID(CLSID_TabPaintManagerPropPage,0xC0DE2430,0x5F3F,0x4975,0x92,0x80,0xAC,0xE1,0x20,0x44,0x12,0xE4);
95XTP_DEFINE_GUID(DIID_IPopupControlItem,0xC0DE2430,0xE2D7,0x4ae7,0xAC,0xCF,0xEC,0x22,0x09,0x05,0x8C,0x15);
96XTP_DEFINE_GUID(CLSID_PopupControlItem,0xC0DE2430,0xB94D,0x4848,0x95,0x5C,0x1D,0x0A,0xFD,0xD2,0x86,0x2F);
97XTP_DEFINE_GUID(DIID__DPopupControl,0xC0DE2430,0x034B,0x4EFA,0xA7,0xD8,0x94,0xE4,0x09,0xB7,0xF8,0xF1);
98XTP_DEFINE_GUID(DIID__DPopupControlEvents,0xC0DE2430,0x7787,0x44CF,0xAD,0x0F,0x59,0xD3,0xD2,0x73,0x7E,0x5E);
99XTP_DEFINE_GUID(CLSID_PopupControl,0xC0DE2430,0x3F65,0x453D,0x91,0xA6,0xAA,0xCC,0xAA,0xD1,0x34,0xBF);
100XTP_DEFINE_GUID(DIID_TreeViewNode,0xC0DE2430,0xF14B,0x4FF2,0x8E,0x37,0xC6,0x7F,0x7A,0xA4,0x98,0x64);
101XTP_DEFINE_GUID(DIID_TreeViewNodes,0xC0DE2430,0x2A24,0x4F9F,0xAF,0x58,0x3B,0x3D,0xCE,0x4B,0xD4,0x77);
102XTP_DEFINE_GUID(DIID__DTreeView,0xC0DE2430,0x459D,0x4285,0x9E,0x64,0x36,0xC0,0x1E,0x36,0x59,0xA4);
103XTP_DEFINE_GUID(DIID__DTreeViewEvents,0xC0DE2430,0xAB5E,0x4C8E,0x97,0xA7,0xE0,0x2F,0x99,0xAC,0xDA,0x71);
104XTP_DEFINE_GUID(CLSID_TreeView,0xC0DE2430,0xF612,0x4B9F,0xA9,0xF0,0x04,0x12,0x21,0xFE,0x48,0xB0);
105XTP_DEFINE_GUID(DIID_ListViewColumnHeader,0xC0DE2430,0xB593,0x483B,0x9C,0x46,0x50,0xDB,0xD9,0xFE,0x3B,0x8D);
106XTP_DEFINE_GUID(DIID_ListViewColumnHeaders,0xC0DE2430,0x24D8,0x4527,0xA2,0x26,0x06,0x2E,0xF0,0xF5,0xF5,0x39);
107XTP_DEFINE_GUID(DIID_ListViewSubItem,0xC0DE2430,0xE965,0x4094,0x97,0xF3,0x90,0xB0,0xE2,0xA3,0xD2,0xCF);
108XTP_DEFINE_GUID(DIID_ListViewSubItems,0xC0DE2430,0x342F,0x41F0,0xA4,0x5D,0x4F,0x1C,0x1B,0xB2,0xED,0x22);
109XTP_DEFINE_GUID(DIID_ListViewItem,0xC0DE2430,0x248E,0x4DC2,0x97,0x09,0x85,0x9A,0xBE,0x42,0x38,0x9E);
110XTP_DEFINE_GUID(DIID_ListViewItems,0xC0DE2430,0x1F0D,0x4E27,0xA3,0x36,0xA8,0xE3,0x89,0x6D,0x0A,0xDC);
111XTP_DEFINE_GUID(DIID__DListView,0xC0DE2430,0x6D42,0x4DA0,0x94,0x9A,0xC3,0x61,0xA8,0xDF,0x50,0x62);
112XTP_DEFINE_GUID(DIID__DListViewEvents,0xC0DE2430,0x945A,0x473F,0x85,0x34,0x1F,0x37,0x81,0xDE,0xEE,0x7D);
113XTP_DEFINE_GUID(CLSID_ListView,0xC0DE2430,0x31D2,0x4B4A,0x85,0xB8,0x14,0xC2,0x46,0x5A,0xDA,0x30);
114XTP_DEFINE_GUID(DIID__DProgressBar,0xC0DE2430,0x73D8,0x4ADF,0x8E,0xFA,0xCB,0x27,0x57,0xCA,0x1C,0x22);
115XTP_DEFINE_GUID(DIID__DProgressBarEvents,0xC0DE2430,0xD6F7,0x4A60,0xBC,0x80,0x6B,0x4D,0x58,0x11,0x2A,0x97);
116XTP_DEFINE_GUID(CLSID_ProgressBar,0xC0DE2430,0xF3BE,0x4610,0x92,0xE7,0xE7,0xBF,0x40,0x15,0x68,0x59);
117XTP_DEFINE_GUID(DIID__DScrollBar,0xC0DE2430,0xEC4A,0x4D21,0x90,0xB9,0xE6,0x3C,0x79,0xE0,0x49,0xEB);
118XTP_DEFINE_GUID(DIID__DScrollBarEvents,0xC0DE2430,0xFBBC,0x40DB,0x84,0x6D,0x05,0xB2,0xCE,0x33,0x08,0x88);
119XTP_DEFINE_GUID(CLSID_ScrollBar,0xC0DE2430,0x53A3,0x4B3E,0xBF,0xF4,0x44,0xDF,0xFB,0xA0,0x39,0x97);
120XTP_DEFINE_GUID(DIID__DUpDown,0xC0DE2430,0x5E7D,0x43C1,0xB9,0xB7,0x8B,0x08,0x2F,0x07,0xA2,0xB1);
121XTP_DEFINE_GUID(DIID__DUpDownEvents,0xC0DE2430,0x2981,0x4FB2,0xA6,0x2C,0xAC,0x14,0x22,0x20,0x55,0x90);
122XTP_DEFINE_GUID(CLSID_UpDown,0xC0DE2430,0x0499,0x429C,0x8F,0xAF,0x12,0xAC,0x08,0xE8,0x01,0xBE);
123XTP_DEFINE_GUID(DIID__DSlider,0xC0DE2430,0xCF42,0x4D20,0xAA,0x31,0x4A,0x44,0x11,0x10,0x28,0x6D);
124XTP_DEFINE_GUID(DIID__DSliderEvents,0xC0DE2430,0x2797,0x45D9,0xB8,0x8D,0xA1,0x4E,0x50,0x1C,0xDB,0x71);
125XTP_DEFINE_GUID(CLSID_Slider,0xC0DE2430,0x6549,0x4F7F,0xBF,0x37,0xCC,0xE3,0x8B,0x15,0x7F,0xFB);
126XTP_DEFINE_GUID(DIID__DTaskDialog,0xC0DE2430,0xFAF9,0x4CE9,0x97,0x8C,0x17,0xE5,0x8F,0x2C,0x04,0x6D);
127XTP_DEFINE_GUID(DIID__DTaskDialogEvents,0xC0DE2430,0xA70B,0x4266,0x91,0xCE,0x44,0x75,0xE8,0xA4,0x55,0xB9);
128XTP_DEFINE_GUID(CLSID_TaskDialog,0xC0DE2430,0x73AF,0x48E7,0x91,0x6F,0xF7,0x59,0xFA,0x2A,0xA9,0x3A);
129XTP_DEFINE_GUID(DIID__DCommonDialog,0xC0DE2430,0xD274,0x417F,0x92,0x52,0x4A,0x58,0x36,0xD0,0xA0,0xC9);
130XTP_DEFINE_GUID(DIID__DCommonDialogEvents,0xC0DE2430,0xDF8B,0x492C,0x82,0x23,0x15,0x16,0xF0,0x59,0x31,0xA2);
131XTP_DEFINE_GUID(CLSID_CommonDialog,0xC0DE2430,0xFE61,0x4788,0xBB,0x33,0xC1,0x06,0xE1,0x74,0x62,0xDD);
132XTP_DEFINE_GUID(DIID__DDateTimePicker,0xC0DE2430,0xD0DC,0x4E43,0x8B,0x92,0x55,0x94,0x6D,0x1A,0x8D,0xFE);
133XTP_DEFINE_GUID(DIID__DDateTimePickerEvents,0xC0DE2430,0x7A7E,0x43B6,0x84,0x68,0x0B,0x74,0xAD,0xBA,0x11,0x68);
134XTP_DEFINE_GUID(CLSID_DateTimePicker,0xC0DE2430,0x40D2,0x42F1,0xAA,0xD8,0x2E,0xE2,0xCA,0xB5,0x4C,0x6E);
135XTP_DEFINE_GUID(DIID__DMonthCalendar,0xC0DE2430,0xDFF0,0x4E26,0xAA,0x07,0x8E,0x6A,0x8A,0x2F,0xBC,0x68);
136XTP_DEFINE_GUID(DIID__DMonthCalendarEvents,0xC0DE2430,0x5C4B,0x40AD,0x91,0x6B,0x5F,0x7D,0x03,0xA1,0x72,0xFC);
137XTP_DEFINE_GUID(CLSID_MonthCalendar,0xC0DE2430,0xCFE9,0x4705,0x82,0x60,0x22,0xCA,0xD3,0xAA,0x45,0x54);
138XTP_DEFINE_GUID(DIID__DWebBrowser,0xC0DE2430,0x0B8A,0x4298,0x83,0x96,0x81,0xF0,0xF3,0x13,0x26,0xCB);
139XTP_DEFINE_GUID(DIID__DWebBrowserEvents,0xC0DE2430,0xD91C,0x4911,0xAD,0xA7,0x3A,0x1E,0xB6,0xEB,0x00,0x3B);
140XTP_DEFINE_GUID(CLSID_WebBrowser,0xC0DE2430,0x32A9,0x4CF3,0xBC,0x6B,0xAF,0x5D,0x96,0x01,0x24,0xC2);
141XTP_DEFINE_GUID(DIID__DTrayIcon,0xC0DE2430,0xA2ED,0x489C,0x98,0x3A,0xA5,0x4B,0x4C,0x40,0xB9,0x9F);
142XTP_DEFINE_GUID(DIID__DTrayIconEvents,0xC0DE2430,0x077E,0x414F,0xBD,0xB7,0xC0,0x7C,0xC5,0x82,0xAA,0xA4);
143XTP_DEFINE_GUID(CLSID_TrayIcon,0xC0DE2430,0x6CA4,0x494F,0xB1,0xDF,0x0F,0x5D,0x25,0x7B,0xFD,0xBD);
144XTP_DEFINE_GUID(DIID__DHexEdit,0xC0DE2430,0x7F70,0x434B,0x96,0x79,0xBE,0xAB,0x0B,0x8E,0xC2,0x4A);
145XTP_DEFINE_GUID(DIID__DHexEditEvents,0xC0DE2430,0xEF36,0x4585,0x94,0x1C,0x9F,0xCC,0x90,0xA1,0x53,0xB1);
146XTP_DEFINE_GUID(CLSID_HexEdit,0xC0DE2430,0xB7EF,0x4125,0xA8,0x70,0x11,0x3F,0x05,0x18,0xA5,0x83);
147XTP_DEFINE_GUID(DIID__DFormExtender,0xC0DE2430,0x771D,0x4652,0x8C,0x75,0x7B,0xE4,0x14,0xCE,0xA1,0xE3);
148XTP_DEFINE_GUID(DIID__DFormExtenderEvents,0xC0DE2430,0xB768,0x43F0,0xB9,0xAF,0xC3,0x1C,0xD2,0x10,0x37,0x24);
149XTP_DEFINE_GUID(CLSID_FormExtender,0xC0DE2430,0x9796,0x4F31,0x8E,0xCF,0x20,0x87,0x41,0xCB,0x4E,0x49);
150XTP_DEFINE_GUID(DIID_TaskbarManagerJumpList,0xC0DE2430,0xE400,0x4DA2,0xAE,0xF5,0xCF,0x1D,0xD5,0x9D,0xCD,0x3B);
151XTP_DEFINE_GUID(DIID__DTaskbarManager,0xC0DE2430,0xFEED,0x472A,0x85,0xC9,0xA3,0x67,0x5C,0x34,0xDC,0x95);
152XTP_DEFINE_GUID(DIID__DTaskbarManagerEvents,0xC0DE2430,0x8925,0x425D,0x86,0x3D,0x98,0x66,0x36,0xC7,0xF3,0x3A);
153XTP_DEFINE_GUID(CLSID_TaskbarManager,0xC0DE2430,0x2A14,0x45F4,0x92,0x0A,0xC0,0x2C,0x89,0x3A,0x4C,0x1C);
154XTP_DEFINE_GUID(DIID_ITagCloudTag,0xC0DE2430,0x0689,0x4F92,0xBB,0x4F,0xB2,0xA7,0x95,0x21,0x2C,0x10);
155XTP_DEFINE_GUID(CLSID_TagCloudTag,0xC0DE2430,0x7AB1,0x4FC8,0x86,0x42,0x48,0xC6,0xAB,0x20,0xFE,0xEA);
156XTP_DEFINE_GUID(DIID__DTagCloud,0xC0DE2430,0x4EAC,0x4DE2,0xB3,0xD6,0x06,0x05,0x5F,0x6E,0x88,0xB8);
157XTP_DEFINE_GUID(DIID__DTagCloudEvents,0xC0DE2430,0x26A3,0x4D06,0x98,0xB0,0x43,0xE6,0x52,0xE8,0x51,0x1B);
158XTP_DEFINE_GUID(CLSID_TagCloud,0xC0DE2430,0x9159,0x461C,0xB5,0x14,0xB6,0x99,0x32,0x02,0x02,0x21);
159XTP_DEFINE_GUID(DIID__DTagCloudPropPage,0xC0DE2430,0x670D,0x4EC4,0xA9,0x88,0x4C,0xC2,0x9D,0x4E,0x17,0x4E);
160XTP_DEFINE_GUID(CLSID_TagCloudPropPage,0xC0DE2430,0x9842,0x4F93,0xAC,0x54,0x69,0x3B,0x54,0xAE,0x66,0x8E);
161XTP_DEFINE_GUID(DIID_ITagCloudStyle,0xC0DE2430,0xECA3,0x4483,0x99,0x50,0xBB,0xA7,0x87,0x93,0x20,0x22);
162XTP_DEFINE_GUID(CLSID_TagCloudStyle,0xC0DE2430,0xF99F,0x4413,0xB8,0xA2,0x1E,0x93,0x3F,0x9F,0xD7,0x15);
163XTP_DEFINE_GUID(DIID_ITagCloudsStyles,0xC0DE2430,0x1697,0x4D67,0xB6,0x1A,0x0C,0x23,0xE6,0xF8,0xA0,0xEE);
164XTP_DEFINE_GUID(CLSID_TagCloudsStyles,0xC0DE2430,0x5D54,0x417D,0xA6,0xB5,0x9D,0x28,0x32,0xEA,0x10,0x49);
165XTP_DEFINE_GUID(DIID__DPreview,0xC0DE2430,0xADAD,0x4796,0x88,0x31,0x63,0xD1,0xC7,0xEC,0x07,0xAE);
166XTP_DEFINE_GUID(DIID__DPreviewEvents,0xC0DE2430,0x4F28,0x4D0D,0x8C,0xC4,0x9A,0x35,0x2A,0xF4,0x7B,0x2C);
167XTP_DEFINE_GUID(CLSID_Preview,0xC0DE2430,0x82E6,0x4D76,0x86,0xDD,0xBD,0xB0,0x97,0x1C,0x43,0x27);
168XTP_DEFINE_GUID(DIID_ISuiteControlsGlobalSettings,0xC0DE2430,0xAF44,0x4604,0x8B,0xD9,0xFA,0xC9,0x72,0x2A,0x4C,0x93);
169XTP_DEFINE_GUID(CLSID_SuiteControlsGlobalSettings,0xC0DE2430,0xFB64,0x432E,0x84,0xAA,0x2F,0x29,0x02,0x21,0x44,0x02);
170XTP_DEFINE_GUID(DIID__DPasswordPeek,0xC0DE2430,0xD4EA,0x4E70,0xBB,0x30,0x94,0x26,0x6E,0xD6,0xA9,0x57);
171XTP_DEFINE_GUID(DIID__DPasswordPeekEvents,0xC0DE2430,0xCCA2,0x45A9,0xA8,0x05,0x17,0x1A,0x47,0x8C,0x22,0x60);
172XTP_DEFINE_GUID(CLSID_PasswordPeek,0xC0DE2430,0x250C,0x4A4F,0xA4,0x24,0xE5,0x2A,0x2F,0x7A,0x9D,0x4A);
173
174#undef XTP_DEFINE_GUID
175
176// clang-format on
177
178#endif // __XTPControlsIIDs_H__


Toolkit Pro: DockingPane Directory Reference

  • Source
  • DockingPane
DockingPane Directory Reference

Directories

ColorSets
TabColorSets
TabThemes
Themes

Files

XTPDockingPane.h
XTPDockingPaneAutoHidePanel.h
XTPDockingPaneBase.h
XTPDockingPaneBaseContainer.h
XTPDockingPaneCaptionButton.h
XTPDockingPaneContext.h
XTPDockingPaneDefines.h
XTPDockingPaneIIDs.h
XTPDockingPaneKeyboardHook.h
XTPDockingPaneLayout.h
XTPDockingPaneManager.h
XTPDockingPaneMiniWnd.h
XTPDockingPanePaintManager.h
XTPDockingPaneSidePanel.h
XTPDockingPaneSplitterContainer.h
XTPDockingPaneTabbedContainer.h


Toolkit Pro: ColorSets Directory Reference

  • Source
  • DockingPane
  • ColorSets
ColorSets Directory Reference

Files

XTPDockingPaneColorSet.h
XTPDockingPaneColorSet2012.h
XTPDockingPaneColorSet2013.h
XTPDockingPaneColorSet2015.h
XTPDockingPaneColorSet2017.h
XTPDockingPaneColorSet2019.h
XTPDockingPaneColorSet2022.h
XTPDockingPaneColorSetNativeWindows10.h
XTPDockingPaneColorSetNativeWindows11.h


Toolkit Pro: XTPDockingPaneColorSet.h File Reference

  • Source
  • DockingPane
  • ColorSets
Classes
XTPDockingPaneColorSet.h File Reference

Go to the source code of this file.

Classes

class CXTPDockingPaneColorSet
Helper class used to initialize default colors for a theme from an .INI resource. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPDockingPaneColorSet2012.h File Reference

  • Source
  • DockingPane
  • ColorSets
Classes
XTPDockingPaneColorSet2012.h File Reference

Go to the source code of this file.

Classes

class CXTPDockingPaneColorSet2012
Helper class used to initialize default colors for a theme from an .INI resource. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPDockingPaneColorSet2013.h File Reference

  • Source
  • DockingPane
  • ColorSets
Classes
XTPDockingPaneColorSet2013.h File Reference

Go to the source code of this file.

Classes

class CXTPDockingPaneColorSet2013
Helper class used to initialize default colors for a theme from an .INI resource. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPDockingPaneColorSet2015.h File Reference

  • Source
  • DockingPane
  • ColorSets
Classes
XTPDockingPaneColorSet2015.h File Reference

Go to the source code of this file.

Classes

class CXTPDockingPaneColorSet2015
Helper class used to initialize default colors for a theme from an .INI resource. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPDockingPaneColorSet2017.h File Reference

  • Source
  • DockingPane
  • ColorSets
Classes
XTPDockingPaneColorSet2017.h File Reference

Go to the source code of this file.

Classes

class CXTPDockingPaneColorSet2017
Helper class used to initialize default colors for a theme from an .INI resource. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPDockingPaneColorSet2019.h File Reference

  • Source
  • DockingPane
  • ColorSets
Classes
XTPDockingPaneColorSet2019.h File Reference

Go to the source code of this file.

Classes

class CXTPDockingPaneColorSet2019
Helper class used to initialize default colors for a theme from an .INI resource. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPDockingPaneColorSet2022.h File Reference

  • Source
  • DockingPane
  • ColorSets
Classes
XTPDockingPaneColorSet2022.h File Reference

Go to the source code of this file.

Classes

class CXTPDockingPaneColorSet2022
Helper class used to initialize default colors for a theme from an .INI resource. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPDockingPaneColorSetNativeWindows10.h File Reference

  • Source
  • DockingPane
  • ColorSets
Classes
XTPDockingPaneColorSetNativeWindows10.h File Reference

Go to the source code of this file.

Classes

class CXTPDockingPaneColorSetNativeWindows10
Helper class used to initialize default colors for a theme from an .INI resource. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPDockingPaneColorSetNativeWindows11.h File Reference

  • Source
  • DockingPane
  • ColorSets
Classes
XTPDockingPaneColorSetNativeWindows11.h File Reference

Go to the source code of this file.

Classes

class CXTPDockingPaneColorSetNativeWindows11
Helper class used to initialize default colors for a theme from an .INI resource. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: TabColorSets Directory Reference

  • Source
  • DockingPane
  • TabColorSets
TabColorSets Directory Reference

Files

XTPDockingPanePanelColorSet2012.h
XTPDockingPanePanelColorSet2013.h
XTPDockingPanePanelColorSet2015.h
XTPDockingPanePanelColorSet2017.h
XTPDockingPanePanelColorSet2019.h
XTPDockingPanePanelColorSet2022.h
XTPDockingPanePanelColorSetNativeWindows10.h
XTPDockingPanePanelColorSetNativeWindows11.h
XTPDockingPaneTabColorSet2012.h
XTPDockingPaneTabColorSet2013.h
XTPDockingPaneTabColorSet2015.h
XTPDockingPaneTabColorSet2017.h
XTPDockingPaneTabColorSet2019.h
XTPDockingPaneTabColorSet2022.h
XTPDockingPaneTabColorSetNativeWindows10.h
XTPDockingPaneTabColorSetNativeWindows11.h
XTPDockingPaneTabColorSetOfficePanel.h
XTPDockingPaneTabColorSetVisualStudio2003.h
XTPDockingPaneTabColorSetVisualStudio2005.h


Toolkit Pro: XTPDockingPanePanelColorSet2012.h File Reference

  • Source
  • DockingPane
  • TabColorSets
Classes
XTPDockingPanePanelColorSet2012.h File Reference

Go to the source code of this file.

Classes

class CXTPDockingPanePanelColorSet2012
Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPDockingPanePanelColorSet2013.h File Reference

  • Source
  • DockingPane
  • TabColorSets
Classes
XTPDockingPanePanelColorSet2013.h File Reference

Go to the source code of this file.

Classes

class CXTPDockingPanePanelColorSet2013
Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPDockingPanePanelColorSet2015.h File Reference

  • Source
  • DockingPane
  • TabColorSets
Classes
XTPDockingPanePanelColorSet2015.h File Reference

Go to the source code of this file.

Classes

class CXTPDockingPanePanelColorSet2015
Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPDockingPanePanelColorSet2017.h File Reference

  • Source
  • DockingPane
  • TabColorSets
Classes
XTPDockingPanePanelColorSet2017.h File Reference

Go to the source code of this file.

Classes

class CXTPDockingPanePanelColorSet2017
Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPDockingPanePanelColorSet2019.h File Reference

  • Source
  • DockingPane
  • TabColorSets
Classes
XTPDockingPanePanelColorSet2019.h File Reference

Go to the source code of this file.

Classes

class CXTPDockingPanePanelColorSet2019
Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPDockingPanePanelColorSet2022.h File Reference

  • Source
  • DockingPane
  • TabColorSets
Classes
XTPDockingPanePanelColorSet2022.h File Reference

Go to the source code of this file.

Classes

class CXTPDockingPanePanelColorSet2022
Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPDockingPanePanelColorSetNativeWindows10.h File Reference

  • Source
  • DockingPane
  • TabColorSets
Classes
XTPDockingPanePanelColorSetNativeWindows10.h File Reference

Go to the source code of this file.

Classes

class CXTPDockingPanePanelColorSetNativeWindows10
Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPDockingPanePanelColorSetNativeWindows11.h File Reference

  • Source
  • DockingPane
  • TabColorSets
Classes
XTPDockingPanePanelColorSetNativeWindows11.h File Reference

Go to the source code of this file.

Classes

class CXTPDockingPanePanelColorSetNativeWindows11
Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPDockingPaneTabColorSet2012.h File Reference

  • Source
  • DockingPane
  • TabColorSets
Classes
XTPDockingPaneTabColorSet2012.h File Reference

Go to the source code of this file.

Classes

class CXTPDockingPaneTabColorSet2012
Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPDockingPaneTabColorSet2013.h File Reference

  • Source
  • DockingPane
  • TabColorSets
Classes
XTPDockingPaneTabColorSet2013.h File Reference

Go to the source code of this file.

Classes

class CXTPDockingPaneTabColorSet2013
Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPDockingPaneTabColorSet2015.h File Reference

  • Source
  • DockingPane
  • TabColorSets
Classes
XTPDockingPaneTabColorSet2015.h File Reference

Go to the source code of this file.

Classes

class CXTPDockingPaneTabColorSet2015
Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPDockingPaneTabColorSet2017.h File Reference

  • Source
  • DockingPane
  • TabColorSets
Classes
XTPDockingPaneTabColorSet2017.h File Reference

Go to the source code of this file.

Classes

class CXTPDockingPaneTabColorSet2017
Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPDockingPaneTabColorSet2019.h File Reference

  • Source
  • DockingPane
  • TabColorSets
Classes
XTPDockingPaneTabColorSet2019.h File Reference

Go to the source code of this file.

Classes

class CXTPDockingPaneTabColorSet2019
Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPDockingPaneTabColorSet2022.h File Reference

  • Source
  • DockingPane
  • TabColorSets
Classes
XTPDockingPaneTabColorSet2022.h File Reference

Go to the source code of this file.

Classes

class CXTPDockingPaneTabColorSet2022
Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPDockingPaneTabColorSetNativeWindows10.h File Reference

  • Source
  • DockingPane
  • TabColorSets
Classes
XTPDockingPaneTabColorSetNativeWindows10.h File Reference

Go to the source code of this file.

Classes

class CXTPDockingPaneTabColorSetNativeWindows10
Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPDockingPaneTabColorSetNativeWindows11.h File Reference

  • Source
  • DockingPane
  • TabColorSets
Classes
XTPDockingPaneTabColorSetNativeWindows11.h File Reference

Go to the source code of this file.

Classes

class CXTPDockingPaneTabColorSetNativeWindows11
Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPDockingPaneTabColorSetOfficePanel.h File Reference

  • Source
  • DockingPane
  • TabColorSets
Classes
XTPDockingPaneTabColorSetOfficePanel.h File Reference

Go to the source code of this file.

Classes

class CXTPDockingPaneTabColorSetOfficePanel
Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPDockingPaneTabColorSetVisualStudio2003.h File Reference

  • Source
  • DockingPane
  • TabColorSets
Classes
XTPDockingPaneTabColorSetVisualStudio2003.h File Reference

Go to the source code of this file.

Classes

class CXTPDockingPaneTabColorSetVisualStudio2003
Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPDockingPaneTabColorSetVisualStudio2005.h File Reference

  • Source
  • DockingPane
  • TabColorSets
Classes
XTPDockingPaneTabColorSetVisualStudio2005.h File Reference

Go to the source code of this file.

Classes

class CXTPDockingPaneTabColorSetVisualStudio2005
Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: TabThemes Directory Reference

  • Source
  • DockingPane
  • TabThemes
TabThemes Directory Reference

Files

XTPDockingPanePanelTheme2012.h
XTPDockingPanePanelTheme2013.h
XTPDockingPanePanelTheme2015.h
XTPDockingPanePanelTheme2017.h
XTPDockingPanePanelTheme2019.h
XTPDockingPanePanelTheme2022.h
XTPDockingPanePanelThemeNativeWindows10.h
XTPDockingPanePanelThemeNativeWindows11.h
XTPDockingPaneTabTheme2012.h
XTPDockingPaneTabTheme2013.h
XTPDockingPaneTabTheme2015.h
XTPDockingPaneTabTheme2017.h
XTPDockingPaneTabTheme2019.h
XTPDockingPaneTabTheme2022.h
XTPDockingPaneTabThemeNativeWindows10.h
XTPDockingPaneTabThemeNativeWindows11.h


Toolkit Pro: XTPDockingPanePanelTheme2012.h File Reference

  • Source
  • DockingPane
  • TabThemes
Classes
XTPDockingPanePanelTheme2012.h File Reference

Go to the source code of this file.

Classes

class CXTPDockingPanePanelTheme2012
Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPDockingPanePanelTheme2013.h File Reference

  • Source
  • DockingPane
  • TabThemes
Classes
XTPDockingPanePanelTheme2013.h File Reference

Go to the source code of this file.

Classes

class CXTPDockingPanePanelTheme2013
Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPDockingPanePanelTheme2015.h File Reference

  • Source
  • DockingPane
  • TabThemes
Classes
XTPDockingPanePanelTheme2015.h File Reference

Go to the source code of this file.

Classes

class CXTPDockingPanePanelTheme2015
Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPDockingPanePanelTheme2017.h File Reference

  • Source
  • DockingPane
  • TabThemes
Classes
XTPDockingPanePanelTheme2017.h File Reference

Go to the source code of this file.

Classes

class CXTPDockingPanePanelTheme2017
Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPDockingPanePanelTheme2019.h File Reference

  • Source
  • DockingPane
  • TabThemes
Classes
XTPDockingPanePanelTheme2019.h File Reference

Go to the source code of this file.

Classes

class CXTPDockingPanePanelTheme2019
Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPDockingPanePanelTheme2022.h File Reference

  • Source
  • DockingPane
  • TabThemes
Classes
XTPDockingPanePanelTheme2022.h File Reference

Go to the source code of this file.

Classes

class CXTPDockingPanePanelTheme2022
Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPDockingPanePanelThemeNativeWindows10.h File Reference

  • Source
  • DockingPane
  • TabThemes
Classes
XTPDockingPanePanelThemeNativeWindows10.h File Reference

Go to the source code of this file.

Classes

class CXTPDockingPanePanelThemeNativeWindows10
Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPDockingPanePanelThemeNativeWindows11.h File Reference

  • Source
  • DockingPane
  • TabThemes
Classes
XTPDockingPanePanelThemeNativeWindows11.h File Reference

Go to the source code of this file.

Classes

class CXTPDockingPanePanelThemeNativeWindows11
Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPDockingPaneTabTheme2012.h File Reference

  • Source
  • DockingPane
  • TabThemes
Classes
XTPDockingPaneTabTheme2012.h File Reference

Go to the source code of this file.

Classes

class CXTPDockingPaneTabTheme2012
Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPDockingPaneTabTheme2013.h File Reference

  • Source
  • DockingPane
  • TabThemes
Classes
XTPDockingPaneTabTheme2013.h File Reference

Go to the source code of this file.

Classes

class CXTPDockingPaneTabTheme2013
Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPDockingPaneTabTheme2015.h File Reference

  • Source
  • DockingPane
  • TabThemes
Classes
XTPDockingPaneTabTheme2015.h File Reference

Go to the source code of this file.

Classes

class CXTPDockingPaneTabTheme2015
Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPDockingPaneTabTheme2017.h File Reference

  • Source
  • DockingPane
  • TabThemes
Classes
XTPDockingPaneTabTheme2017.h File Reference

Go to the source code of this file.

Classes

class CXTPDockingPaneTabTheme2017
Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPDockingPaneTabTheme2019.h File Reference

  • Source
  • DockingPane
  • TabThemes
Classes
XTPDockingPaneTabTheme2019.h File Reference

Go to the source code of this file.

Classes

class CXTPDockingPaneTabTheme2019
Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPDockingPaneTabTheme2022.h File Reference

  • Source
  • DockingPane
  • TabThemes
Classes
XTPDockingPaneTabTheme2022.h File Reference

Go to the source code of this file.

Classes

class CXTPDockingPaneTabTheme2022
Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPDockingPaneTabThemeNativeWindows10.h File Reference

  • Source
  • DockingPane
  • TabThemes
Classes
XTPDockingPaneTabThemeNativeWindows10.h File Reference

Go to the source code of this file.

Classes

class CXTPDockingPaneTabThemeNativeWindows10
Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPDockingPaneTabThemeNativeWindows11.h File Reference

  • Source
  • DockingPane
  • TabThemes
Classes
XTPDockingPaneTabThemeNativeWindows11.h File Reference

Go to the source code of this file.

Classes

class CXTPDockingPaneTabThemeNativeWindows11
Helper class used to initialize default colors for a theme from an .INI resource and handle drawing routines. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: Themes Directory Reference

  • Source
  • DockingPane
  • Themes
Themes Directory Reference

Files

XTPDockingPaneThemeDefault.h
XTPDockingPaneThemeGrippered.h
XTPDockingPaneThemeNativeWindows10.h
XTPDockingPaneThemeNativeWindows11.h
XTPDockingPaneThemeOffice2002Visio.h
XTPDockingPaneThemeOffice2003.h
XTPDockingPaneThemeOffice2003Outlook.h
XTPDockingPaneThemeOffice2003Visio.h
XTPDockingPaneThemeOffice2007.h
XTPDockingPaneThemeOffice2007Outlook.h
XTPDockingPaneThemeOffice2007Visio.h
XTPDockingPaneThemeOffice2007Word.h
XTPDockingPaneThemeOffice2013.h
XTPDockingPaneThemeVisualStudio2003.h
XTPDockingPaneThemeVisualStudio2005.h
XTPDockingPaneThemeVisualStudio2005Beta1.h
XTPDockingPaneThemeVisualStudio2005Beta2.h
XTPDockingPaneThemeVisualStudio2008.h
XTPDockingPaneThemeVisualStudio2010.h
XTPDockingPaneThemeVisualStudio2012.h
XTPDockingPaneThemeVisualStudio2015.h
XTPDockingPaneThemeVisualStudio2017.h
XTPDockingPaneThemeVisualStudio2019.h
XTPDockingPaneThemeVisualStudio2022.h
XTPDockingPaneThemeVisualStudio6.h
XTPDockingPaneThemeWinExplorer.h
XTPDockingPaneThemeWinNative.h


Toolkit Pro: XTPDockingPaneThemeDefault.h File Reference

  • Source
  • DockingPane
  • Themes
Classes
XTPDockingPaneThemeDefault.h File Reference

Go to the source code of this file.

Classes

class CXTPDockingPaneDefaultTheme
CXTPDockingPaneDefaultTheme is a CXTPDockingPanePaintManager derived class that represents a classic theme for docking panes. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPDockingPaneThemeGrippered.h File Reference

  • Source
  • DockingPane
  • Themes
Classes
XTPDockingPaneThemeGrippered.h File Reference

Go to the source code of this file.

Classes

class CXTPDockingPaneGripperedTheme
CXTPDockingPaneGripperedTheme is a CXTPDockingPaneDefaultTheme derived class that represents a gripper theme for docking panes. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPDockingPaneThemeNativeWindows10.h File Reference

  • Source
  • DockingPane
  • Themes
Classes
XTPDockingPaneThemeNativeWindows10.h File Reference

Go to the source code of this file.

Classes

class CXTPDockingPaneNativeWindows10Theme
CXTPDockingPaneNativeWindows10Theme is used to define drawing routines specific to a Native Windows 10 docking pane theme. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPDockingPaneThemeNativeWindows11.h File Reference

  • Source
  • DockingPane
  • Themes
Classes
XTPDockingPaneThemeNativeWindows11.h File Reference

Go to the source code of this file.

Classes

class CXTPDockingPaneNativeWindows11Theme
CXTPDockingPaneNativeWindows11Theme is used to define drawing routines specific to a Native Windows 10 docking pane theme. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPDockingPaneThemeOffice2002Visio.h File Reference

  • Source
  • DockingPane
  • Themes
Classes
XTPDockingPaneThemeOffice2002Visio.h File Reference

Go to the source code of this file.

Classes

class CXTPDockingPaneOffice2002VisioTheme
CXTPDockingPaneOffice2002VisioTheme is a CXTPDockingPaneVisualStudio2003Theme derived class that represents a Visio theme for docking panes. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPDockingPaneThemeOffice2003.h File Reference

  • Source
  • DockingPane
  • Themes
Classes
XTPDockingPaneThemeOffice2003.h File Reference

Go to the source code of this file.

Classes

class CXTPDockingPaneOffice2003Theme
CXTPDockingPaneOffice2003Theme is a CXTPDockingPaneVisualStudio2003Theme derived class that represents an Office 2003 theme for docking panes. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPDockingPaneThemeOffice2003Outlook.h File Reference

  • Source
  • DockingPane
  • Themes
Classes
XTPDockingPaneThemeOffice2003Outlook.h File Reference

Go to the source code of this file.

Classes

class CXTPDockingPaneOffice2003OutlookTheme
CXTPDockingPaneOffice2003OutlookTheme is a CXTPDockingPaneOffice2003Theme derived class that represents an Office 2003 theme for docking panes. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPDockingPaneThemeOffice2003Visio.h File Reference

  • Source
  • DockingPane
  • Themes
Classes
XTPDockingPaneThemeOffice2003Visio.h File Reference

Go to the source code of this file.

Classes

class CXTPDockingPaneOffice2003VisioTheme
CXTPDockingPaneOffice2003VisioTheme is a CXTPDockingPaneOffice2002VisioTheme derived class that represents an Office 2003 Visio theme for docking panes. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPDockingPaneThemeOffice2007.h File Reference

  • Source
  • DockingPane
  • Themes
Classes
XTPDockingPaneThemeOffice2007.h File Reference

Go to the source code of this file.

Classes

class CXTPDockingPaneOffice2007Theme
CXTPDockingPaneOffice2007Theme is a CXTPDockingPaneOffice2003Theme derived class that represents an Office 2007 theme for docking panes. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPDockingPaneThemeOffice2007Outlook.h File Reference

  • Source
  • DockingPane
  • Themes
Classes
XTPDockingPaneThemeOffice2007Outlook.h File Reference

Go to the source code of this file.

Classes

class CXTPDockingPaneOffice2007OutlookTheme
CXTPDockingPaneOffice2007OutlookTheme is CXTPDockingPaneOffice2007Theme derived class that represents an Outlook 2007 theme for docking panes. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPDockingPaneThemeOffice2007Visio.h File Reference

  • Source
  • DockingPane
  • Themes
Classes
XTPDockingPaneThemeOffice2007Visio.h File Reference

Go to the source code of this file.

Classes

class CXTPDockingPaneOffice2007VisioTheme
CXTPDockingPaneOffice2007VisioTheme is a CXTPDockingPaneOffice2003VisioTheme derived class that represents an Office 2007 Visio theme for docking panes. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPDockingPaneThemeOffice2007Word.h File Reference

  • Source
  • DockingPane
  • Themes
Classes
XTPDockingPaneThemeOffice2007Word.h File Reference

Go to the source code of this file.

Classes

class CXTPDockingPaneOffice2007WordTheme
CXTPDockingPaneOffice2007WordTheme is a CXTPDockingPaneOffice2003Theme derived class that represents an Office Word 2007 theme for docking panes. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPDockingPaneThemeOffice2013.h File Reference

  • Source
  • DockingPane
  • Themes
Classes
XTPDockingPaneThemeOffice2013.h File Reference

Go to the source code of this file.

Classes

class CXTPDockingPaneOffice2013Theme
CXTPDockingPaneOffice2013Theme is used to define drawing routines specific to an Office 2013 docking pane theme. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPDockingPaneThemeVisualStudio2003.h File Reference

  • Source
  • DockingPane
  • Themes
Classes
XTPDockingPaneThemeVisualStudio2003.h File Reference

Go to the source code of this file.

Classes

class CXTPDockingPaneVisualStudio2003Theme
CXTPDockingPaneVisualStudio2003Theme is a CXTPDockingPaneGripperedTheme derived class that represents a Visual Studio 2003 theme for docking panes. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPDockingPaneThemeVisualStudio2005.h File Reference

  • Source
  • DockingPane
  • Themes
Classes
XTPDockingPaneThemeVisualStudio2005.h File Reference

Go to the source code of this file.

Classes

class CXTPDockingPaneVisualStudio2005Theme
CXTPDockingPaneVisualStudio2005Theme is a CXTPDockingPaneVisualStudio2005Beta2Theme derived class that represents a Visual Studio 2005 theme for docking panes. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPDockingPaneThemeVisualStudio2005Beta1.h File Reference

  • Source
  • DockingPane
  • Themes
Classes
XTPDockingPaneThemeVisualStudio2005Beta1.h File Reference

Go to the source code of this file.

Classes

class CXTPDockingPaneVisualStudio2005Beta1Theme
CXTPDockingPaneVisualStudio2005Beta1Theme is CXTPDockingPaneVisualStudio2003Theme derived class that represents a Visual Studio 2005 Beta 1 theme for docking panes. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPDockingPaneThemeVisualStudio2005Beta2.h File Reference

  • Source
  • DockingPane
  • Themes
Classes
XTPDockingPaneThemeVisualStudio2005Beta2.h File Reference

Go to the source code of this file.

Classes

class CXTPDockingPaneVisualStudio2005Beta2Theme
CXTPDockingPaneVisualStudio2005Beta2Theme is CXTPDockingPaneVisualStudio2005Beta1Theme derived class that represents a Visual Studio 2005 Beta 2 theme for docking panes. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPDockingPaneThemeVisualStudio2008.h File Reference

  • Source
  • DockingPane
  • Themes
Classes
XTPDockingPaneThemeVisualStudio2008.h File Reference

Go to the source code of this file.

Classes

class CXTPDockingPaneVisualStudio2008Theme
CXTPDockingPaneVisualStudio2008Theme is a CXTPDockingPaneVisualStudio2005Theme derived class that represents a Visual Studio 2008 theme for docking panes. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPDockingPaneThemeVisualStudio2010.h File Reference

  • Source
  • DockingPane
  • Themes
Classes
XTPDockingPaneThemeVisualStudio2010.h File Reference

Go to the source code of this file.

Classes

class CXTPDockingPaneVisualStudio2010Theme
CXTPDockingPaneVisualStudio2010Theme is a CXTPDockingPaneVisualStudio2008Theme derived class that represents a Visual Studio 2010 theme for docking panes. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPDockingPaneThemeVisualStudio2012.h File Reference

  • Source
  • DockingPane
  • Themes
Classes
XTPDockingPaneThemeVisualStudio2012.h File Reference

Go to the source code of this file.

Classes

class CXTPDockingPaneVisualStudio2012Theme
CXTPDockingPaneVisualStudio2012Theme is used to define drawing routines specific to a Visual Studio 2012 docking pane theme. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPDockingPaneThemeVisualStudio2015.h File Reference

  • Source
  • DockingPane
  • Themes
Classes
XTPDockingPaneThemeVisualStudio2015.h File Reference

Go to the source code of this file.

Classes

class CXTPDockingPaneVisualStudio2015Theme
CXTPDockingPaneVisualStudio2015Theme is used to define drawing routines specific to a Visual Studio 2015 docking pane theme. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPDockingPaneThemeVisualStudio2017.h File Reference

  • Source
  • DockingPane
  • Themes
Classes
XTPDockingPaneThemeVisualStudio2017.h File Reference

Go to the source code of this file.

Classes

class CXTPDockingPaneVisualStudio2017Theme
CXTPDockingPaneVisualStudio2017Theme is used to define drawing routines specific to a Visual Studio 2017 docking pane theme. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPDockingPaneThemeVisualStudio2019.h File Reference

  • Source
  • DockingPane
  • Themes
Classes
XTPDockingPaneThemeVisualStudio2019.h File Reference

Go to the source code of this file.

Classes

class CXTPDockingPaneVisualStudio2019Theme
CXTPDockingPaneVisualStudio2019Theme is used to define drawing routines specific to a Visual Studio 2019 docking pane theme. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPDockingPaneThemeVisualStudio2022.h File Reference

  • Source
  • DockingPane
  • Themes
Classes
XTPDockingPaneThemeVisualStudio2022.h File Reference

Go to the source code of this file.

Classes

class CXTPDockingPaneVisualStudio2022Theme
CXTPDockingPaneVisualStudio2022Theme is used to define drawing routines specific to a Visual Studio 2022 docking pane theme. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPDockingPaneThemeVisualStudio6.h File Reference

  • Source
  • DockingPane
  • Themes
Classes
XTPDockingPaneThemeVisualStudio6.h File Reference

Go to the source code of this file.

Classes

class CXTPDockingPaneVisualStudio6Theme
CXTPDockingPaneVisualStudio6Theme is a CXTPDockingPaneGripperedTheme derived class that represents a Visual Studio 6 theme for docking panes. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPDockingPaneThemeWinExplorer.h File Reference

  • Source
  • DockingPane
  • Themes
Classes
XTPDockingPaneThemeWinExplorer.h File Reference

Go to the source code of this file.

Classes

class CXTPDockingPaneWinExplorerTheme
CXTPDockingPaneWinExplorerTheme is a CXTPDockingPaneDefaultTheme derived class that represents an Explorer theme for docking panes. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPDockingPaneThemeWinNative.h File Reference

  • Source
  • DockingPane
  • Themes
Classes
XTPDockingPaneThemeWinNative.h File Reference

Go to the source code of this file.

Classes

class CXTPDockingPaneWinNativeTheme
CXTPDockingPaneWinNativeTheme is a CXTPDockingPaneVisualStudio2003Theme derived class that represents a Win Native theme for docking panes. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPDockingPane.h File Reference

  • Source
  • DockingPane
Classes
XTPDockingPane.h File Reference

Go to the source code of this file.

Classes

class CXTPDockingPane
CXTPDockingPane is a CXTPDockingPaneBase derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPDockingPaneAutoHidePanel.h File Reference

  • Source
  • DockingPane
Classes
XTPDockingPaneAutoHidePanel.h File Reference

Go to the source code of this file.

Classes

class | CXTPDockingPaneAutoHideWnd
CXTPDockingPaneAutoHideWnd is a CMiniFrameWnd derived class. More...
class | CXTPDockingPaneAutoHidePanel
CXTPDockingPaneAutoHidePanel is a multiple inheritance class derived from CWnd and CXTPDockingPaneBase. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPDockingPaneBase.h File Reference

  • Source
  • DockingPane
Classes
XTPDockingPaneBase.h File Reference

Go to the source code of this file.

Classes

class | CXTPDockingPaneCaptionButtons
CXTPDockingPaneCaptionButtons is a CArray derived class used to manipulate Caption Buttons. More...
class | CXTPDockingPaneBase
CXTPDockingPaneBase is a standalone class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPDockingPaneBaseContainer.h File Reference

  • Source
  • DockingPane
Classes
XTPDockingPaneBaseContainer.h File Reference

Go to the source code of this file.

Classes

class CXTPDockingPaneBaseContainer
CXTPDockingPaneBaseContainer is a CXTPDockingPaneBase derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPDockingPaneCaptionButton.h File Reference

  • Source
  • DockingPane
Classes
XTPDockingPaneCaptionButton.h File Reference

Go to the source code of this file.

Classes

class CXTPDockingPaneCaptionButton
CXTPDockingPaneCaptionButton is a standalone internal class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPDockingPaneContext.h File Reference

  • Source
  • DockingPane
Classes
XTPDockingPaneContext.h File Reference

Go to the source code of this file.

Classes

class | CXTPDockingPaneContextAlphaWnd
CXTPDockingPaneContextAlphaWnd is a CWnd derived class that represents an alpha context helper window. More...
class | CXTPDockingPaneContextStickerWnd
CXTPDockingPaneContextStickerWnd is a CWnd derived class that represents a sticker window. More...
class | CXTPDockingPaneContext
CXTPDockingPaneContext is a standalone class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPDockingPaneDefines.h File Reference

  • Source
  • DockingPane
Classes | Macros | Typedefs | Enumerations | Variables
XTPDockingPaneDefines.h File Reference

Go to the source code of this file.

Classes

struct | XTP_DOCKINGPANE_CLICK
The XTP_DOCKINGPANE_CLICK structure contains information about the pane that was used in an XTP_DPN_PANEMENUCLICK message. More...
struct | XTP_DOCKINGPANE_ACTION
The XTP_DOCKINGPANE_ACTION structure contains information about the action performed by the user with docking panes. More...
struct | XTP_DOCKINGPANE_INFO
Internal structure used by the Layout manager. More...

Macros

#define XTPWM_DOCKINGPANE_NOTIFY (WM_XTP_DOCKINGPANE_BASE + 1)
The XTPWM_DOCKINGPANE_NOTIFY message is sent to the Docking Pane Manager owner window whenever an action occurs within the DockingPanes.

Typedefs

typedef CList< CXTPDockingPane *, CXTPDockingPane * > | CXTPDockingPaneList
This list is used by the CXTPDockingPaneTabbedContainer class for maintaining a CXTPDockingPane collection.
typedef CList< CXTPDockingPaneBase *, CXTPDockingPaneBase * > | CXTPDockingPaneBaseList
This list is used for maintaining a CXTPDockingPaneBase collection.
typedef CList< XTP_DOCKINGPANE_INFO, XTP_DOCKINGPANE_INFO & > | CXTPDockingPaneInfoList
This list is used by the CXTPDockingPaneLayout class for maintaining an XTP_DOCKINGPANE_INFO collection.
typedef CMap< CXTPDockingPaneBase *, CXTPDockingPaneBase *, CXTPDockingPaneBase *, CXTPDockingPaneBase * > | CXTPPaneToPaneMap
This map is used for mapping CXTPDockingPaneBase objects.
typedef CMap< int, int, CXTPDockingPaneBase *, CXTPDockingPaneBase * > | CXTPPaneIndexToPaneMap
This map is used for mapping index to CXTPDockingPaneBase objects.

Enumerations

enum XTPDockingPaneDirection {
xtpPaneDockUndefined = -1 , xtpPaneDockLeft , xtpPaneDockRight , xtpPaneDockTop ,
xtpPaneDockBottom , xtpPaneDockMiniWnd
}
Docking direction enumeration. More...
enum XTPDockingPaneType {
xtpPaneTypeDockingPane , xtpPaneTypeTabbedContainer , xtpPaneTypeSplitterContainer , xtpPaneTypeMiniWnd ,
xtpPaneTypeClient , xtpPaneTypeAutoHidePanel , xtpPaneTypeSidePanel
}
Docking pane type. More...
enum XTPDockingPanePaintTheme {
xtpPaneThemeDefault , xtpPaneThemeVisualStudio2003 , xtpPaneThemeOffice2003 , xtpPaneThemeWinNative ,
xtpPaneThemeGrippered , xtpPaneThemeOffice2002Visio , xtpPaneThemeVisualStudio2005Beta1 , xtpPaneThemeOffice2003Outlook ,
xtpPaneThemeWinExplorer , xtpPaneThemeVisualStudio2005 , xtpPaneThemeResource , xtpPaneThemeOffice2007Word ,
xtpPaneThemeOffice2007Outlook , xtpPaneThemeVisualStudio6 , xtpPaneThemeVisualStudio2005Beta2 , xtpPaneThemeVisualStudio2008 ,
xtpPaneThemeVisualStudio2010 , xtpPaneThemeOffice2003Visio , xtpPaneThemeOffice2007Visio , xtpPaneThemeOffice2013 ,
xtpPaneThemeOffice2016 = xtpPaneThemeOffice2013 , xtpPaneThemeVisualStudio2012 , xtpPaneThemeVisualStudio2015 , xtpPaneThemeCustom ,
xtpPaneThemeNativeWindows10 , xtpPaneThemeVisualStudio2017 , xtpPaneThemeVisualStudio2019 , xtpPaneThemeVisualStudio2022 ,
xtpPaneThemeNativeWindows11
}
Visual theme enumeration. More...
enum XTPDockingContextStickerStyle {
xtpPaneStickerStyleVisualStudio2005Beta , xtpPaneStickerStyleVisualStudio2005 , xtpPaneStickerStyleVisualStudio2008 , xtpPaneStickerStyleVisualStudio2010 ,
xtpPaneStickerStyleVisualStudio2012Light , xtpPaneStickerStyleVisualStudio2012Dark , xtpPaneStickerStyleVisualStudio2015Light , xtpPaneStickerStyleVisualStudio2015Blue ,
xtpPaneStickerStyleVisualStudio2015Dark , xtpPaneStickerStyleVisualStudio2017Light , xtpPaneStickerStyleVisualStudio2017Blue , xtpPaneStickerStyleVisualStudio2017BlueExtra ,
xtpPaneStickerStyleVisualStudio2017Dark , xtpPaneStickerStyleVisualStudio2019Light , xtpPaneStickerStyleVisualStudio2019Blue , xtpPaneStickerStyleVisualStudio2019BlueExtra ,
xtpPaneStickerStyleVisualStudio2019Dark , xtpPaneStickerStyleVisualStudio2022Light , xtpPaneStickerStyleVisualStudio2022Blue , xtpPaneStickerStyleVisualStudio2022BlueExtra ,
xtpPaneStickerStyleVisualStudio2022Dark , xtpPaneStickerStyleNativeWindows10Light , xtpPaneStickerStyleNativeWindows10Dark , xtpPaneStickerStyleNativeWindows11Light ,
xtpPaneStickerStyleNativeWindows11Dark
}
Docking Panes sticker style enumeration. More...
enum XTPDockingPaneOptions {
xtpPaneNoCloseable = 1 , xtpPaneNoHideable = 2 , xtpPaneNoFloatable = 4 , xtpPaneNoCaption = 8 ,
xtpPaneHasMenuButton = 16 , xtpPaneNoDockable = 32 , xtpPaneNoFloatableByTabDoubleClick = 64 , xtpPaneNoFloatableByCaptionDoubleClick = 128 ,
xtpPaneNoHoverShow = 1024
}
Docking Pane Options enumeration. More...
enum XTPDockingPaneCaptionDirection { xtpPaneCaptionHorizontal , xtpPaneCaptionVertical , xtpPaneCaptionAutoByPosition , xtpPaneCaptionAutoBySize }
Docking Pane Caption direction enumeration. More...
enum XTPDockingPaneAction {
xtpPaneActionFloating , xtpPaneActionFloated , xtpPaneActionClosing , xtpPaneActionClosed ,
xtpPaneActionDocking , xtpPaneActionDocked , xtpPaneActionAttaching , xtpPaneActionAttached ,
xtpPaneActionPinning , xtpPaneActionPinned , xtpPaneActionCollapsing , xtpPaneActionCollapsed ,
xtpPaneActionExpanding , xtpPaneActionExpanded , xtpPaneActionActivated , xtpPaneActionDeactivated ,
xtpPaneActionDetaching , xtpPaneActionDragging , xtpPaneActionUnpinning , xtpPaneActionUnpinned ,
xtpPaneActionSplitterResizing , xtpPaneActionSplitterResized
}
Actions a docking pane is currently performing. More...
enum XTPDockingPaneEnableOptions {
xtpPaneDisabled = 0 , xtpPaneEnableClient = 1 , xtpPaneEnableActions = 2 , xtpPaneEnabled = 3 ,
xtpPaneEnabledAuto = 4 + 3
}
Enable options of the pane. More...
enum XTPDockingPaneKeyboardNavigate {
xtpPaneKeyboardUnused = 0 , xtpPaneKeyboardUseAltMinus = 1 , xtpPaneKeyboardUseAltF6 = 2 , xtpPaneKeyboardUseAltF7 = 4 ,
xtpPaneKeyboardUseCtrlTab = 8 , xtpPaneKeyboardUseAll = 15
}
Keyboard options indicates which key can be used to navigate panes. More...
enum XTPDockingPaneStickerType {
xtpPaneStickerNone = 0 , xtpPaneStickerLeft = 1 , xtpPaneStickerRight = 2 , xtpPaneStickerTop = 4 ,
xtpPaneStickerBottom = 8 , xtpPaneStickerCenter = 16 , xtpPaneStickerClient = 32
}
XTPDockingPaneStickerType is an enumeration that is used to indicate which docking stickers are to be drawn on the screen when a docking pane is dragged. More...

Variables

const UINT | WM_XTP_DOCKINGPANE_BASE = (WM_USER + 9900)
Base for all docking pane messages.
const int | XTP_DPN_SHOWWINDOW = 1
const int | XTP_DPN_RCLICK = 2
const int | XTP_DPN_CLOSEPANE = 3
const int | XTP_DPN_ACTION = 4
const int | XTP_DPN_CONTEXTMENU = 5
const int | XTP_ACTION_NOCLOSE = -1

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Macro Definition Documentation

◆ XTPWM_DOCKINGPANE_NOTIFY

#define XTPWM_DOCKINGPANE_NOTIFY (WM_XTP_DOCKINGPANE_BASE + 1)

The XTPWM_DOCKINGPANE_NOTIFY message is sent to the Docking Pane Manager owner window whenever an action occurs within the DockingPanes.

The XTPWM_DOCKINGPANE_NOTIFY notification message is sent to inform the owner window that an action occured within the DockingPanes. The owner window of the color picker receives this notification through the WM_COMMAND message.

XTPWM_DOCKINGPANE_NOTIFY
CXTPDockingPane* pPane = (CXTPDockingPane*)lParam; // pointer to an CXTPDockingPane object

wParam can be one of the following: XTP_DPN_SHOWWINDOW: The docking pane is just a virtual container for a user window. The best place to associate them is after the pane becomes visible because, initially, it can be created, closed, hidden, or as a non-active tab. You can create your user window in this handler. Process this message to attach an existing window to the Docking Pane container using the Attach member function. XTP_DPN_RCLICK: User pressed the right mouse button on the docking pane container. XTP_DPN_CLOSEPANE: User closed the Pane. You can return XTP_ACTION_NOCLOSE while processing the XTP_DPN_CLOSEPANE notification to disable closing docking pane windows. XTP_DPN_ACTION: Extended action occurred (see XTPDockingPaneAction). XTP_DPN_CONTEXTMENU: User pressed the menu button or right clicked to show the context menu.

Parameters
pPane The value of lParam points to a CXTPDockingPane object that becomes visible. For XTP_DPN_SHOWWINDOW, this pointer should never be NULL.

Example: Here is an example of how an application would process the XTPWM_DOCKINGPANE_NOTIFY message:

BEGIN_MESSAGE_MAP(CMainFrame, CFrameWnd)
ON_MESSAGE(XTPWM_DOCKINGPANE_NOTIFY, OnDockingPaneNotify)
END_MESSAGE_MAP()

LRESULT CMainFrame::OnDockingPaneNotify(WPARAM wParam, LPARAM lParam)
{
   switch ((int)wParam)
   {
      case XTP_DPN_SHOWWINDOW:
      {
         CXTPDockingPane* pPane = (CXTPDockingPane*)lParam;

         // check if the Pane hasn't been attached yet.
         if (!pPane->IsValid())
         {
            // check if the user window hasn't been created.
            if (!m_wndPane.m_hWnd)
            {
               // create it.
               m_wndPane.CreateEx(WS_EX_STATICEDGE, _T("EDIT"), _T(""),
               WS_CHILD | ES_AUTOVSCROLL | ES_MULTILINE,
               CRect(0, 0, 200, 120), this, 0);
            }
         // attach it to the Pane.
         pPane->Attach(&m_wndPane);
         }
         return TRUE;
      }
         case XTP_DPN_CLOSEPANE:
      {
      // Disable the user from closing docking panes.
      return XTP_ACTION_NOCLOSE;
      }
   }

   return FALSE;
}
Returns
TRUE if the application should process this message, otherwise FALSE.

Typedef Documentation

◆ CXTPDockingPaneBaseList

typedef CList<CXTPDockingPaneBase*, CXTPDockingPaneBase*> CXTPDockingPaneBaseList

This list is used for maintaining a CXTPDockingPaneBase collection.

See also
CXTPDockingPaneBase::FindPane, CXTPDockingPaneAutoHidePanel::GetPanes

◆ CXTPDockingPaneInfoList

typedef CList<XTP_DOCKINGPANE_INFO, XTP_DOCKINGPANE_INFO&> CXTPDockingPaneInfoList

This list is used by the CXTPDockingPaneLayout class for maintaining an XTP_DOCKINGPANE_INFO collection.

See also
CXTPDockingPaneLayout::GetPaneList, CXTPDockingPaneManager::GetPaneList

◆ CXTPDockingPaneList

typedef CList<CXTPDockingPane*, CXTPDockingPane*> CXTPDockingPaneList

This list is used by the CXTPDockingPaneTabbedContainer class for maintaining a CXTPDockingPane collection.

See also
CXTPDockingPaneTabbedContainer::GetPanes

◆ CXTPPaneToPaneMap

typedef CMap<CXTPDockingPaneBase*, CXTPDockingPaneBase*, CXTPDockingPaneBase*, CXTPDockingPaneBase*> CXTPPaneToPaneMap

This map is used for mapping CXTPDockingPaneBase objects.

Example:

CXTPDockingPaneBase* CXTPDockingPaneBase::Clone(
CXTPDockingPaneLayout* pLayout,
CXTPPaneToPaneMap* pMap,
DWORD dwIgnoredOptions)
{
   _ASSERTE(pMap);
   CXTPDockingPaneBase* pClone = new CXTPDockingPaneBase(m_type, pLayout);
   pMap->SetAt(this, pClone);
   return pClone;
}
See also
CXTPDockingPaneBase::Clone, CXTPDockingPane::Clone

Enumeration Type Documentation

◆ XTPDockingContextStickerStyle

enum XTPDockingContextStickerStyle

Docking Panes sticker style enumeration.

Example:

m_paneManager.SetStickerStyle(xtpPaneStickerStyleVisualStudio2005);
See also
xtpPaneStickerStyleVisualStudio2005Beta, xtpPaneStickerStyleVisualStudio2005>
Enumerator
xtpPaneStickerStyleVisualStudio2005Beta | Visual Studio 2005 Beta stickers.
xtpPaneStickerStyleVisualStudio2005 | Visual Studio 2005 stickers.
xtpPaneStickerStyleVisualStudio2008 | Visual Studio 2008 stickers.
xtpPaneStickerStyleVisualStudio2010 | Visual Studio 2010 stickers.
xtpPaneStickerStyleVisualStudio2012Light | Visual Studio 2012 light stickers.
xtpPaneStickerStyleVisualStudio2012Dark | Visual Studio 2012 dark stickers.
xtpPaneStickerStyleVisualStudio2015Light | Visual Studio 2015 light stickers.
xtpPaneStickerStyleVisualStudio2015Blue | Visual Studio 2015 blue stickers.
xtpPaneStickerStyleVisualStudio2015Dark | Visual Studio 2015 dark stickers.
xtpPaneStickerStyleVisualStudio2017Light | Visual Studio 2017 light stickers.
xtpPaneStickerStyleVisualStudio2017Blue | Visual Studio 2017 blue stickers.
xtpPaneStickerStyleVisualStudio2017BlueExtra | Visual Studio 2017 blue extra stickers.
xtpPaneStickerStyleVisualStudio2017Dark | Visual Studio 2017 dark stickers.
xtpPaneStickerStyleVisualStudio2019Light | Visual Studio 2019 light stickers.
xtpPaneStickerStyleVisualStudio2019Blue | Visual Studio 2019 blue stickers.
xtpPaneStickerStyleVisualStudio2019BlueExtra | Visual Studio 2019 blue extra stickers.
xtpPaneStickerStyleVisualStudio2019Dark | Visual Studio 2019 dark stickers.
xtpPaneStickerStyleVisualStudio2022Light | Visual Studio 2022 light stickers.
xtpPaneStickerStyleVisualStudio2022Blue | Visual Studio 2022 blue stickers.
xtpPaneStickerStyleVisualStudio2022BlueExtra | Visual Studio 2022 blue extra stickers.
xtpPaneStickerStyleVisualStudio2022Dark | Visual Studio 2022 dark stickers.
xtpPaneStickerStyleNativeWindows10Light | Native Windows 10 light stickers.
xtpPaneStickerStyleNativeWindows10Dark | Native Windows 10 dark stickers.
xtpPaneStickerStyleNativeWindows11Light | Native Windows 11 light stickers.
xtpPaneStickerStyleNativeWindows11Dark | Native Windows 11 dark stickers.

◆ XTPDockingPaneAction

enum XTPDockingPaneAction

Actions a docking pane is currently performing.

Example:

BEGIN_MESSAGE_MAP(CMainFrame, CFrameWnd)
ON_MESSAGE(XTPWM_DOCKINGPANE_NOTIFY, OnDockingPaneNotify)
END_MESSAGE_MAP()

LRESULT CMainFrame::OnDockingPaneNotify(WPARAM wParam, LPARAM lParam)
{
   if (wParam == XTP_DPN_ACTION)
   {
      XTP_DOCKINGPANE_ACTION* pAction = (XTP_DOCKINGPANE_ACTION*)lParam;
      TRACE("Action %i\n", pAction->action);
      return TRUE;
   }
   return FALSE;
}
See also
XTP_DOCKINGPANE_ACTION, XTP_DPN_ACTION, xtpPaneActionFloating, xtpPaneActionFloated, xtpPaneActionClosing, xtpPaneActionClosed, xtpPaneActionDocking, xtpPaneActionDocked, xtpPaneActionAttaching, xtpPaneActionAttached, xtpPaneActionPinning, xtpPaneActionPinned, xtpPaneActionCollapsing, xtpPaneActionCollapsed, xtpPaneActionExpanding, xtpPaneActionExpanded
Enumerator
xtpPaneActionFloating | Docking pane is currently floating. This occurs when the user clicks on the title bar of a docking pane and drags the pane to another location. When this occurs, the pane is said to be "floating."
xtpPaneActionFloated | Docking pane has been docked, and is currently floating.
xtpPaneActionClosing | Docking pane is currently closing. This occurs when the close button of the pane is clicked.
xtpPaneActionClosed | Docking pane has been closed. This occurs when the docking pane has finished closing.
xtpPaneActionDocking | Docking pane is in the process of docking.
xtpPaneActionDocked | Docking pane has been docked. This occurs when the docking pane has finished docking.
xtpPaneActionAttaching | Docking pane is in the process of attaching to another pane.
xtpPaneActionAttached | Docking pane has been attached. This occurs when the docking pane has finished attaching to another pane.
xtpPaneActionPinning | Docking pane is currently pinning (hiding). This occurs when the "pin" button is clicked.
xtpPaneActionPinned | Docking pane has been pinned. This occurs when the docking pane has finished pinning.
xtpPaneActionCollapsing | Docking pane is currently collapsing (hiding). This occurs when pane is going back to its auto-hide position. If a pane is hidden and the mouse is positioned over the tab to display the pane, then the pane is expanding. When the mouse is moved off of the pane, it begins to collapse.
xtpPaneActionCollapsed | Docking Pane has been collapsed. This occurs when the docking pane has finished collapsing.
xtpPaneActionExpanding | Docking pane is currently expanding. This occurs when a pane is being displayed from its auto-hide position. If a pane is hidden and the mouse is positioned over the tab to display the pane, then the pane is expanding. When the mouse is moved off of the pane, it begins to collapse.
xtpPaneActionExpanded | Docking pane is expanded; this is when the pane is fully shown from the auto-hide position.
xtpPaneActionActivated | Docking pane activated.
xtpPaneActionDeactivated | Docking pane deactivated.
xtpPaneActionDetaching | Docking pane is being removed from tabbed container.
xtpPaneActionDragging | Docking pane is being dragged.
xtpPaneActionUnpinning | Docking pane is currently docked. This occurs when the "pin" button is clicked.
xtpPaneActionUnpinned | Docking pane has been unpinned. This occurs when the docking pane has finished pinning.
xtpPaneActionSplitterResizing | Docking pane splitter resizing.
xtpPaneActionSplitterResized | Docking pane splitter resized.

◆ XTPDockingPaneCaptionDirection

enum XTPDockingPaneCaptionDirection

Docking Pane Caption direction enumeration.

Example:

m_paneManager.SetCaptionDirection(xtpPaneCaptionAutoBySize);
See also
CXTPDockingPaneManager::SetCaptionDirection, xtpPaneCaptionHorizontal, xtpPaneCaptionVertical, xtpPaneCaptionAutoByPosition, xtpPaneCaptionAutoBySize
Enumerator
xtpPaneCaptionHorizontal | Show caption on top.
xtpPaneCaptionVertical | Show caption on left.
xtpPaneCaptionAutoByPosition | Automatically.
xtpPaneCaptionAutoBySize | Automatically.

◆ XTPDockingPaneDirection

enum XTPDockingPaneDirection

Docking direction enumeration.

Example:

CXTPDockingPane* pwndPane1 = GetDockingPaneManager()->CreatePane(
IDR_PANE1, CRect(0, 0, 200, 120), xtpPaneDockTop);
See also
CXTPDockingPaneManager::CreatePane, CXTPDockingPaneManager, xtpPaneDockLeft, xtpPaneDockRight, xtpPaneDockTop, xtpPaneDockBottom
Enumerator
xtpPaneDockUndefined | Docking pane direction is unspecified.
xtpPaneDockLeft | To dock the pane to the left of the pane or frame.
xtpPaneDockRight | To dock the pane to the right of the pane or frame.
xtpPaneDockTop | To dock the pane to the top of the pane or frame.
xtpPaneDockBottom | To dock the pane to the bottom of the pane or frame.
xtpPaneDockMiniWnd | Docking pane is floating mini-frame window.

◆ XTPDockingPaneEnableOptions

enum XTPDockingPaneEnableOptions

Enable options of the pane.

Enumerator
xtpPaneDisabled | Pane is disabled.
xtpPaneEnableClient | Client is enabled.
xtpPaneEnableActions | All actions are enabled.
xtpPaneEnabled | Pane is enabled.
xtpPaneEnabledAuto | Pane is automatically enabled.

◆ XTPDockingPaneKeyboardNavigate

enum XTPDockingPaneKeyboardNavigate

Keyboard options indicates which key can be used to navigate panes.

Example:

m_paneManager.EnableKeyboardNavigate(xtpPaneKeyboardUseAll);
See also
CXTPDockingPaneManager::EnableKeyboardNavigate
Enumerator
xtpPaneKeyboardUnused | Don't use the keyboard.
xtpPaneKeyboardUseAltMinus | To use Alt+'-' to show the context menu.
xtpPaneKeyboardUseAltF6 | To use Alt+F6 to select the next pane.
xtpPaneKeyboardUseAltF7 | To use Alt+F7 to show the window select dialog.
xtpPaneKeyboardUseCtrlTab | To use Ctrl+Tab to show the window select dialog.
xtpPaneKeyboardUseAll | To use all keys.

◆ XTPDockingPaneOptions

enum XTPDockingPaneOptions

Docking Pane Options enumeration.

Example:

// Remove Hide button for all panes
m_paneManager.SetDefaultPaneOptions(xtpPaneNoHideable);
// Remove close button for pPane
pPane->SetOptions(xtpPaneNoCloseable);
See also
CXTPDockingPaneManager::SetDefaultPaneOptions, CXTPDockingPane::SetOptions, xtpPaneNoCloseable, xtpPaneNoHideable, xtpPaneNoFloatable, xtpPaneNoCaption
Enumerator
xtpPaneNoCloseable | A Pane can't be closed.
xtpPaneNoHideable | A Pane can't be hidden.
xtpPaneNoFloatable | A Pane can't be floated.
xtpPaneNoCaption | A Pane has no caption.
xtpPaneHasMenuButton | A Pane has menu button.
xtpPaneNoDockable | A Pane can't be docked.
xtpPaneNoFloatableByTabDoubleClick | A Pane can't be floated by a double-click on the tab button.
xtpPaneNoFloatableByCaptionDoubleClick | Pane can't be floated by a double-click on the pane caption.
xtpPaneNoHoverShow | A pane won't be shown on hoverusing a mouse.

◆ XTPDockingPanePaintTheme

enum XTPDockingPanePaintTheme

Visual theme enumeration.

Example:

m_paneManager.SetTheme(xtpPaneThemeVisualStudio2005Beta1);
See also
CXTPDockingPaneManager, CXTPDockingPaneManager::SetTheme, xtpPaneThemeDefault, xtpPaneThemeVisualStudio2003, xtpPaneThemeGrippered, xtpPaneThemeOffice2002Visio, xtpPaneThemeCustom, xtpPaneThemeOffice2003, xtpPaneThemeWinNative, xtpPaneThemeVisualStudio2005Beta1
Enumerator
xtpPaneThemeDefault | Default theme.
xtpPaneThemeVisualStudio2003 | Visual Studio 2003 theme.
xtpPaneThemeOffice2003 | Office 2003 theme.
xtpPaneThemeWinNative | Windows Native theme.
xtpPaneThemeGrippered | Gripper theme.
xtpPaneThemeOffice2002Visio | Office 2002 Visio theme.
xtpPaneThemeVisualStudio2005Beta1 | Visual Studio 2005 Beta 1 theme.
xtpPaneThemeOffice2003Outlook | Office 2003 Outlook theme.
xtpPaneThemeWinExplorer | Windows Explorer theme.
xtpPaneThemeVisualStudio2005 | Visual Studio 2005 theme.
xtpPaneThemeResource | Office 2007/2010 theme.
xtpPaneThemeOffice2007Word | Office 2007 Word theme.
xtpPaneThemeOffice2007Outlook | Office 2007 Outlook theme.
xtpPaneThemeVisualStudio6 | Visual Studio 6 theme.
xtpPaneThemeVisualStudio2005Beta2 | Visual Studio 2005 Beta 2 theme.
xtpPaneThemeVisualStudio2008 | Visual Studio 2008 theme.
xtpPaneThemeVisualStudio2010 | Visual Studio 2010 theme.
xtpPaneThemeOffice2003Visio | Office 2003 Visio theme.
xtpPaneThemeOffice2007Visio | Office 2007 Visio theme.
xtpPaneThemeOffice2013 | Office 2013 pane theme.
xtpPaneThemeOffice2016 | Office 2016 pane theme.
xtpPaneThemeVisualStudio2012 | Visual Studio 2012 theme.
xtpPaneThemeVisualStudio2015 | Visual Studio 2015 theme.
xtpPaneThemeCustom | Custom User Defined Theme.
xtpPaneThemeNativeWindows10 | Native Windows 10 theme.
xtpPaneThemeVisualStudio2017 | Visual Studio 2017 theme.
xtpPaneThemeVisualStudio2019 | Visual Studio 2019 theme.
xtpPaneThemeVisualStudio2022 | Visual Studio 2022 theme.
xtpPaneThemeNativeWindows11 | Native Windows 11 theme.

◆ XTPDockingPaneStickerType

enum XTPDockingPaneStickerType

XTPDockingPaneStickerType is an enumeration that is used to indicate which docking stickers are to be drawn on the screen when a docking pane is dragged.

m_bUseAlphaContext must be TRUE to display docking stickers.

See also
CXTPDockingPaneContext::CreateNewSticker, CXTPDockingPaneContextStickerWnd::m_typeSticker, CXTPDockingPaneContextStickerWnd::m_selectedSticker, xtpPaneStickerNone, xtpPaneStickerLeft, xtpPaneStickerRight, xtpPaneStickerTop, xtpPaneStickerBottom, xtpPaneStickerCenter, xtpPaneStickerClient, xtpPaneStickerPane
Enumerator
xtpPaneStickerNone | No docking stickers are displayed.
xtpPaneStickerLeft | Display the docking sticker indicating the pane can be docked to the left.
xtpPaneStickerRight | Display the docking sticker indicating the pane can be docked to the right.
xtpPaneStickerTop | Display the docking sticker indicating the pane can be docked on the top.
xtpPaneStickerBottom | Display the docking sticker indicating the pane can be docked on the bottom.
xtpPaneStickerCenter | Display the docking sticker indicating the pane can be docked in the center.
xtpPaneStickerClient | Display the left, top, bottom, and right docking stickers on client frame.

◆ XTPDockingPaneType

enum XTPDockingPaneType

Docking pane type.

Example:

if (pPane->GetType() == xtpPaneTypeDockingPane)
{
   // This is CXTPDockingPane object
}
See also
CXTPDockingPaneBase::GetType, CXTPDockingPaneBase, xtpPaneTypeDockingPane, xtpPaneTypeTabbedContainer, xtpPaneTypeSplitterContainer, xtpPaneTypeMiniWnd, xtpPaneTypeClient, xtpPaneTypeAutoHidePanel
Enumerator
xtpPaneTypeDockingPane | Object is the docking pane.
xtpPaneTypeTabbedContainer | Object is the tabbed container.
xtpPaneTypeSplitterContainer | Object is the splitter container.
xtpPaneTypeMiniWnd | Object is the mini-window container.
xtpPaneTypeClient | Object is the pane contained client area.
xtpPaneTypeAutoHidePanel | Object is the auto-hide panel.
xtpPaneTypeSidePanel | Object is the side panel.

Variable Documentation

◆ XTP_ACTION_NOCLOSE

const int XTP_ACTION_NOCLOSE = -1
See also
XTPWM_DOCKINGPANE_NOTIFY

◆ XTP_DPN_ACTION

const int XTP_DPN_ACTION = 4
See also
XTPWM_DOCKINGPANE_NOTIFY

◆ XTP_DPN_CLOSEPANE

const int XTP_DPN_CLOSEPANE = 3
See also
XTPWM_DOCKINGPANE_NOTIFY

◆ XTP_DPN_CONTEXTMENU

const int XTP_DPN_CONTEXTMENU = 5
See also
XTPWM_DOCKINGPANE_NOTIFY

◆ XTP_DPN_RCLICK

const int XTP_DPN_RCLICK = 2
See also
XTPWM_DOCKINGPANE_NOTIFY

◆ XTP_DPN_SHOWWINDOW

const int XTP_DPN_SHOWWINDOW = 1
See also
XTPWM_DOCKINGPANE_NOTIFY


Toolkit Pro: XTPDockingPaneIIDs.h Source File

  • Source
  • DockingPane
XTPDockingPaneIIDs.h
1// DO NOT MODIFY MANUALLY
2// Generated on Thu 12/11/2025 at 12:46:12.12 using cj-update-iids.cmd
3
24#ifndef __XTPDockingPaneIIDs_H__
25# define __XTPDockingPaneIIDs_H__
26
27// clang-format off
28
29#define XTP_DEFINE_GUID(name,l,w1,w2,b1,b2,b3,b4,b5,b6,b7,b8) \
30 EXTERN_C __declspec(selectany) const IID XTP##name = {l,w1,w2,{b1,b2,b3,b4,b5,b6,b7,b8}}; \
31 const unsigned long XTP##name##__Data1 = (l); \
32 const unsigned short XTP##name##__Data2 = (w1); \
33 const unsigned short XTP##name##__Data3 = (w2); \
34 const unsigned char XTP##name##__Data4_0 = (b1); \
35 const unsigned char XTP##name##__Data4_1 = (b2); \
36 const unsigned char XTP##name##__Data4_2 = (b3); \
37 const unsigned char XTP##name##__Data4_3 = (b4); \
38 const unsigned char XTP##name##__Data4_4 = (b5); \
39 const unsigned char XTP##name##__Data4_5 = (b6); \
40 const unsigned char XTP##name##__Data4_6 = (b7); \
41 const unsigned char XTP##name##__Data4_7 = (b8);
42
43XTP_DEFINE_GUID(LIBID_XtremeDockingPane,0x945E8FCC,0x830E,0x45CC,0xAF,0x00,0xA0,0x12,0xD5,0xAE,0x74,0x51);
44XTP_DEFINE_GUID(DIID_IPane,0xC0DE2430,0x61BC,0x4172,0x89,0x3C,0xCD,0x34,0x63,0xCF,0x2E,0x01);
45XTP_DEFINE_GUID(DIID_IPaneContainer,0xC0DE2430,0x2E69,0x4810,0xB1,0xEB,0xC9,0xD7,0x51,0x12,0xEC,0xC5);
46XTP_DEFINE_GUID(DIID_IDockingPaneLayout,0xC0DE2430,0xB860,0x4B3D,0xB4,0xC5,0x11,0x5A,0xD6,0x9A,0x82,0x35);
47XTP_DEFINE_GUID(CLSID_DockingPaneLayout,0xC0DE2430,0x93E7,0x42CA,0x9F,0xFD,0x73,0x48,0x32,0x8F,0xDD,0xF0);
48XTP_DEFINE_GUID(DIID_IDockingPaneTrackSize,0xC0DE2430,0x2228,0x4D03,0xA6,0xB5,0xE0,0x20,0x4C,0xB3,0x1D,0xC3);
49XTP_DEFINE_GUID(CLSID_DockingPaneTrackSize,0xC0DE2430,0x6804,0x4153,0xB4,0x5E,0xE3,0x49,0x37,0x1F,0xFB,0x3E);
50XTP_DEFINE_GUID(CLSID_PaneContainer,0xC0DE2430,0x310C,0x42A2,0x8E,0x33,0x41,0x27,0xCA,0xB9,0x75,0x9E);
51XTP_DEFINE_GUID(CLSID_Pane,0xC0DE2430,0x0D8F,0x451D,0x8C,0x74,0x36,0xD4,0xAB,0xB6,0x4E,0x5E);
52XTP_DEFINE_GUID(DIID_IDockingPanePaintManager,0xC0DE2430,0x5B83,0x4371,0xAA,0x36,0xE4,0x5E,0x7C,0xD8,0x6B,0x3B);
53XTP_DEFINE_GUID(CLSID_DockingPanePaintManager,0xC0DE2430,0xFA19,0x43FC,0x84,0xF3,0x45,0x63,0x4D,0x1E,0x79,0x0D);
54XTP_DEFINE_GUID(DIID_IDockingPaneOptions,0xC0DE2430,0xE16F,0x4EE6,0x9C,0x6C,0xF8,0x97,0xF2,0xB7,0x06,0xAA);
55XTP_DEFINE_GUID(CLSID_DockingPaneOptions,0xC0DE2430,0x065B,0x43BF,0x81,0x75,0x26,0x6F,0x50,0xEA,0xC4,0xB1);
56XTP_DEFINE_GUID(DIID_IPaneActionContainer,0xC0DE2430,0x20ED,0x4FEB,0xA0,0xC0,0x04,0x2A,0x23,0xF3,0x87,0xB2);
57XTP_DEFINE_GUID(CLSID_PaneActionContainer,0xC0DE2430,0x5773,0x4E88,0x86,0xD6,0x09,0x12,0x8D,0xE3,0xDF,0x2C);
58XTP_DEFINE_GUID(DIID__DDockingPane,0xC0DE2430,0xE939,0x4555,0xB3,0xF6,0xFA,0xD1,0xE6,0x3C,0x10,0xE4);
59XTP_DEFINE_GUID(DIID__DDockingPaneEvents,0xC0DE2430,0xD406,0x4B24,0x8B,0x76,0xA0,0x48,0xA2,0x31,0xF2,0xB1);
60XTP_DEFINE_GUID(CLSID_DockingPane,0xC0DE2430,0xD9CB,0x4B48,0x82,0xFB,0x38,0xA5,0x7D,0x81,0xF4,0x8A);
61XTP_DEFINE_GUID(DIID__DDockingPaneFrame,0xC0DE2430,0x4947,0x4D1A,0xB4,0xBB,0x5D,0xEC,0x96,0x5C,0x17,0xA7);
62XTP_DEFINE_GUID(DIID__DDockingPaneFrameEvents,0xC0DE2430,0xB0A3,0x4DB3,0xA9,0x51,0x8E,0x52,0xDD,0xE8,0x88,0xA7);
63XTP_DEFINE_GUID(CLSID_DockingPaneFrame,0xC0DE2430,0x1D63,0x41A5,0x85,0x2A,0x34,0xFF,0x6C,0x9E,0xA7,0xA9);
64XTP_DEFINE_GUID(DIID_IDockingPaneGlobalSettings,0xC0DE2430,0xF12D,0x4505,0xA0,0x24,0xBE,0xD9,0xCF,0xE5,0x8E,0x50);
65XTP_DEFINE_GUID(CLSID_DockingPaneGlobalSettings,0xC0DE2430,0x1C32,0x4FCF,0xAD,0x92,0x0A,0xBC,0x82,0x02,0xDD,0xD9);
66
67#undef XTP_DEFINE_GUID
68
69// clang-format on
70
71#endif // __XTPDockingPaneIIDs_H__


Toolkit Pro: XTPDockingPaneKeyboardHook.h File Reference

  • Source
  • DockingPane
Classes
XTPDockingPaneKeyboardHook.h File Reference

Go to the source code of this file.

Classes

class | CXTPDockingPaneWindowSelect
CXTPDockingPaneWindowSelect is a CMiniFrameWnd derived class used to show a window selector for Ctrl+F9 and Alt+F7 handlers. More...
struct | CXTPDockingPaneWindowSelect::CItem
Item description. More...
struct | CXTPDockingPaneWindowSelect::CColumn
Column description. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPDockingPaneLayout.h File Reference

  • Source
  • DockingPane
Classes
XTPDockingPaneLayout.h File Reference

Go to the source code of this file.

Classes

class CXTPDockingPaneLayout
CXTPDockingPaneLayout is a standalone class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPDockingPaneManager.h File Reference

  • Source
  • DockingPane
Classes
XTPDockingPaneManager.h File Reference

Go to the source code of this file.

Classes

class CXTPDockingPaneManager
CXTPDockingPaneManager is a CWnd derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPDockingPaneMiniWnd.h File Reference

  • Source
  • DockingPane
Classes
XTPDockingPaneMiniWnd.h File Reference

Go to the source code of this file.

Classes

class CXTPDockingPaneMiniWnd
CXTPDockingPaneMiniWnd is a multiple inheritance class derived from CMiniFrameWnd and CXTPDockingPaneBase. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPDockingPanePaintManager.h File Reference

  • Source
  • DockingPane
Classes | Enumerations
XTPDockingPanePaintManager.h File Reference

Go to the source code of this file.

Classes

class | CXTPDockingPaneTabPaintManager
CXTPDockingPaneTabPaintManager is a CXTPTabPaintManager derived class that is used to store the color and appearance information of the tabs in the tab manager. More...
class | CXTPDockingPanePanelPaintManager
CXTPDockingPanePanelPaintManager is a CXTPTabPaintManager derived class that is used to store the color and appearance information of the tabs in the tab manager. More...
class | CXTPDockingPanePaintManager
CXTPDockingPanePaintManager is a standalone class. More...

Enumerations

enum XTPDockingPanePinState { xtpPanePinVisible = 1 , xtpPanePinPushed = 2 }
Enumeration of the pin button state. More...
enum XTPDockingPaneSplitterStyle {
xtpPaneSplitterFlat = 0 , xtpPaneSplitter3D = 1 , xtpPaneSplitterSoft3D = 2 , xtpPaneSplitterGradient = 4 ,
xtpPaneSplitterGradientVert = 8 , xtpPaneSplitterGripperOfficeXP = 0x100 , xtpPaneSplitterGripperOffice2003 = 0x200
}
Enumeration of the splitter styles. More...
enum XTPDockingPaneCaptionButtonStyle {
xtpPaneCaptionButtonDefault , xtpPaneCaptionButtonOffice , xtpPaneCaptionButtonOffice2003 , xtpPaneCaptionButtonThemedExplorerBar ,
xtpPaneCaptionButtonThemedButton , xtpPaneCaptionButtonThemedToolBar , xtpPaneCaptionButtonThemedToolWindow
}
Enumeration of the caption button styles. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Enumeration Type Documentation

◆ XTPDockingPaneCaptionButtonStyle

enum XTPDockingPaneCaptionButtonStyle

Enumeration of the caption button styles.

Example: m_paneManager.GetPaintManager()->SetCaptionButtonStyle(xtpPaneCaptionButtonThemedExplorerBar);

See also
CXTPDockingPanePaintManager::SetCaptionButtonStyle
Enumerator
xtpPaneCaptionButtonDefault | Default caption button style.
xtpPaneCaptionButtonOffice | Office XP caption button style.
xtpPaneCaptionButtonOffice2003 | Office 2003 caption button style.
xtpPaneCaptionButtonThemedExplorerBar | Explorer button style.
xtpPaneCaptionButtonThemedButton | Windows XP Button style.
xtpPaneCaptionButtonThemedToolBar | Windows XP Toolbar style.
xtpPaneCaptionButtonThemedToolWindow | Window XP Tool Window style.

◆ XTPDockingPanePinState

enum XTPDockingPanePinState

Enumeration of the pin button state.

See also
CXTPDockingPaneCaptionButton::GetState, CXTPDockingPaneCaptionButton::SetState, xtpPanePinVisible, xtpPanePinPushed
Enumerator
xtpPanePinVisible | Pin button is visible.
xtpPanePinPushed | Pin button is pushed.

◆ XTPDockingPaneSplitterStyle

enum XTPDockingPaneSplitterStyle

Enumeration of the splitter styles.

Example: m_paneManager.GetPaintManager()->SetSplitterStyle(xtpPaneSplitterSoft3D + xtpPaneSplitterGripperOffice2003);

See also
CXTPDockingPanePaintManager::SetSplitterStyle, xtpPaneSplitterFlat, xtpPaneSplitter3D, xtpPaneSplitterSoft3D, xtpPaneSplitterGripperOfficeXP, xtpPaneSplitterGripperOffice2003
Enumerator
xtpPaneSplitterFlat | Flat splitter style.
xtpPaneSplitter3D | 3D splitter style.
xtpPaneSplitterSoft3D | Soft splitter style.
xtpPaneSplitterGradient | Gradient splitter style.
xtpPaneSplitterGradientVert | Gradient splitter style.
xtpPaneSplitterGripperOfficeXP | Splitter has an Office XP gripper.
xtpPaneSplitterGripperOffice2003 | Splitter has an Office 2003 gripper.


Toolkit Pro: XTPDockingPaneSidePanel.h File Reference

  • Source
  • DockingPane
Classes
XTPDockingPaneSidePanel.h File Reference

Go to the source code of this file.

Classes

class CXTPDockingPaneSidePanel
CXTPDockingPaneSidePanel is a multiple inheritance class derived from CWnd and CXTPDockingPaneBase. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPDockingPaneSplitterContainer.h File Reference

  • Source
  • DockingPane
Classes
XTPDockingPaneSplitterContainer.h File Reference

Go to the source code of this file.

Classes

class | CXTPDockingPaneSplitterWnd
CXTPDockingPaneSplitterWnd is a CWnd derived class. More...
class | CXTPDockingPaneSplitterContainer
CXTPDockingPaneSplitterContainer is a CXTPDockingPaneBase derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPDockingPaneTabbedContainer.h File Reference

  • Source
  • DockingPane
Classes
XTPDockingPaneTabbedContainer.h File Reference

Go to the source code of this file.

Classes

class CXTPDockingPaneTabbedContainer
CXTPDockingPaneTabbedContainer is a multiple inheritance class derived from CWnd and CXTPDockingPaneBase. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: FlowGraph Directory Reference

  • Source
  • FlowGraph
FlowGraph Directory Reference

Files

XTPArrowDrawer.h
XTPFlowGraphConnection.h
XTPFlowGraphConnectionPoint.h
XTPFlowGraphConnectionPoints.h
XTPFlowGraphConnections.h
XTPFlowGraphControl.h
XTPFlowGraphDrawContext.h
XTPFlowGraphDrawContextGdiPlus.h
XTPFlowGraphEditItem.h
XTPFlowGraphElement.h
XTPFlowGraphIIDs.h
XTPFlowGraphImage.h
XTPFlowGraphMessages.h
XTPFlowGraphNode.h
XTPFlowGraphNodeCustom.h
XTPFlowGraphNodeGroup.h
XTPFlowGraphNodeGroups.h
XTPFlowGraphNodes.h
XTPFlowGraphPage.h
XTPFlowGraphPageHistory.h
XTPFlowGraphPages.h
XTPFlowGraphPaintManager.h
XTPFlowGraphSelectedElements.h
XTPFlowGraphSelectionRect.h
XTPFlowGraphTools.h
XTPFlowGraphUndoManager.h
XTPTextOnPath.h


Toolkit Pro: XTPArrowDrawer.h File Reference

  • Source
  • FlowGraph
XTPArrowDrawer.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPFlowGraphConnection.h File Reference

  • Source
  • FlowGraph
Classes
XTPFlowGraphConnection.h File Reference

Go to the source code of this file.

Classes

class CXTPFlowGraphConnection
Represents a connection. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPFlowGraphConnectionPoint.h File Reference

  • Source
  • FlowGraph
Classes
XTPFlowGraphConnectionPoint.h File Reference

Go to the source code of this file.

Classes

class CXTPFlowGraphConnectionPoint
Represents a connection point for a node. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPFlowGraphConnectionPoints.h File Reference

  • Source
  • FlowGraph
Classes
XTPFlowGraphConnectionPoints.h File Reference

Go to the source code of this file.

Classes

class CXTPFlowGraphConnectionPoints
Represents a collection of connection points for a Node. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPFlowGraphConnections.h File Reference

  • Source
  • FlowGraph
Classes
XTPFlowGraphConnections.h File Reference

Go to the source code of this file.

Classes

class CXTPFlowGraphConnections
Represents a collection of connections for a Node. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPFlowGraphControl.h File Reference

  • Source
  • FlowGraph
Classes | Enumerations
XTPFlowGraphControl.h File Reference

Go to the source code of this file.

Classes

class CXTPFlowGraphControl
Flow Graph Control. More...

Enumerations

enum | XTPFlowGraphResize { xtpFlowGraphResizeNone = 0 , xtpFlowGraphResizeHorizontal = 1 , xtpFlowGraphResizeVertical = 2 , xtpFlowGraphResizeBoth = 3 }
Node resizing options (drag/drop size of Nodes). More...
enum | XTPFlowGraphSmoothingMode { xtpFlowGraphSmoothingModeHighQuality , xtpFlowGraphSmoothingModeHighSpeed , xtpFlowGraphSmoothingModeGDI , xtpFlowGraphSmoothingModeAuto }
Draw quality options for the flow graph. More...
enum XTPFlowGraphCustomProperty {
xtpFlowGraphPropertyConnectionPoint = 0 , xtpFlowGraphPropertyConnectionPointType = 1 , xtpFlowGraphPropertyCanSetColor = 2 , xtpFlowGraphPropertyConnectionPointIn ,
xtpFlowGraphPropertyResizable = 4
}
Custom XAML properties used in CXTPFlowGraphNode and CXTPFlowGraphNodeCustom. More...
enum XTPFlowGraphDefaultXAMLTemplate {
xtpFlowGraphTemplateNode = 0 , xtpFlowGraphTemplateNodePointNone = 1 , xtpFlowGraphTemplateNodePointIn = 2 , xtpFlowGraphTemplateNodePointOut = 3 ,
xtpFlowGraphTemplateNodePointInOut = 4
}
Default XAML templates for a default node and its table rows with connection points. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Enumeration Type Documentation

◆ XTPFlowGraphCustomProperty

enum XTPFlowGraphCustomProperty

Custom XAML properties used in CXTPFlowGraphNode and CXTPFlowGraphNodeCustom.

Enumerator
xtpFlowGraphPropertyConnectionPoint | Applied to default nodes only. Tells the control that a given [Rectangle] is a connection point.
xtpFlowGraphPropertyConnectionPointType | Applied to default nodes only. Tells the control that a given XAML element can have a color.
xtpFlowGraphPropertyCanSetColor | Applied to default nodes only. Tells the control that a given XAML element can have a color.
xtpFlowGraphPropertyConnectionPointIn | Applied to custom nodes only. Tells the control of how to place connection points within the given XAML shape can be applied to canvas on custom markup nodes when the markup doesn't contain a path.
xtpFlowGraphPropertyResizable | Applied to custom Nodes only. Tells the control that a given shape is resizable or not. A shape is resizable when this property is omitted.

◆ XTPFlowGraphDefaultXAMLTemplate

enum XTPFlowGraphDefaultXAMLTemplate

Default XAML templates for a default node and its table rows with connection points.

Enumerator
xtpFlowGraphTemplateNode | A Node.
xtpFlowGraphTemplateNodePointNone | Node table row with no connection points.
xtpFlowGraphTemplateNodePointIn | Node table row with input connection point.
xtpFlowGraphTemplateNodePointOut | Node table row with output connection point.
xtpFlowGraphTemplateNodePointInOut | Node table row with input & output connection points.

◆ XTPFlowGraphResize

enum XTPFlowGraphResize

Node resizing options (drag/drop size of Nodes).

To resize a Node, you must click the border of the Node and drag it to the desired width/height. Set AllowResizeNodes to TRUE to enable resizable Nodes. You can set the Lock property of a single Node if you don't want it moved and resized.

See also
CXTPFlowGraphControl::SetAllowResizeNodes
Enumerator
xtpFlowGraphResizeNone | Resizing is disabled.
xtpFlowGraphResizeHorizontal | Nodes can be resized horizontally only.
xtpFlowGraphResizeVertical | Nodes can be resized vertically only.
xtpFlowGraphResizeBoth | Nodes can be resized both vertically and horizontally.

◆ XTPFlowGraphSmoothingMode

enum XTPFlowGraphSmoothingMode

Draw quality options for the flow graph.

Set SmoothingMode to the setting that best matches your systems capabilities.

These option greatly affect the performance of the control and will in part be affected by the graphics capability of the machine that uses the control. xtpFlowGraphSmoothingModeHighQuality is recommended when you do not intend for the nodes to be dragged by the user. If dragging is enabled, then this setting is most affected by the systems graphic capabilities.

See also
CXTPFlowGraphControl::SetSmoothingMode
Enumerator
xtpFlowGraphSmoothingModeHighQuality | Uses GDI+ to draw the flow graph for the highest quality picture. This option looks the best, but might be slow when performing drag operations on lower end graphic cards.
xtpFlowGraphSmoothingModeHighSpeed | Uses GDI+ to draw the flow graph with slightly lower quality to improve speed over the High Quality option.
xtpFlowGraphSmoothingModeGDI | Uses GDI Standard to draw the flow graph. Performance will be good on lower end graphic cards; however, the quality does not look as good as the GDI+ options.
xtpFlowGraphSmoothingModeAuto | Will combine the various quality modes to get the best performance and quality. It will draw with a higher quality mode for viewing and then switch to a lower quality mode when performing drag operations.


Toolkit Pro: XTPFlowGraphDrawContext.h File Reference

  • Source
  • FlowGraph
XTPFlowGraphDrawContext.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPFlowGraphDrawContextGdiPlus.h File Reference

  • Source
  • FlowGraph
XTPFlowGraphDrawContextGdiPlus.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPFlowGraphEditItem.h File Reference

  • Source
  • FlowGraph
Classes
XTPFlowGraphEditItem.h File Reference

Go to the source code of this file.

Classes

class CXTPFlowGraphEditItem
Represents an edit control used to edit captions for elements in the flow graph. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPFlowGraphElement.h File Reference

  • Source
  • FlowGraph
Classes
XTPFlowGraphElement.h File Reference

Go to the source code of this file.

Classes

class CXTPFlowGraphElement
Base class for all elements in the flow graph. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPFlowGraphIIDs.h Source File

  • Source
  • FlowGraph
XTPFlowGraphIIDs.h
1// DO NOT MODIFY MANUALLY
2// Generated on Thu 12/11/2025 at 12:46:12.92 using cj-update-iids.cmd
3
24#ifndef __XTPFlowGraphIIDs_H__
25# define __XTPFlowGraphIIDs_H__
26
27// clang-format off
28
29#define XTP_DEFINE_GUID(name,l,w1,w2,b1,b2,b3,b4,b5,b6,b7,b8) \
30 EXTERN_C __declspec(selectany) const IID XTP##name = {l,w1,w2,{b1,b2,b3,b4,b5,b6,b7,b8}}; \
31 const unsigned long XTP##name##__Data1 = (l); \
32 const unsigned short XTP##name##__Data2 = (w1); \
33 const unsigned short XTP##name##__Data3 = (w2); \
34 const unsigned char XTP##name##__Data4_0 = (b1); \
35 const unsigned char XTP##name##__Data4_1 = (b2); \
36 const unsigned char XTP##name##__Data4_2 = (b3); \
37 const unsigned char XTP##name##__Data4_3 = (b4); \
38 const unsigned char XTP##name##__Data4_4 = (b5); \
39 const unsigned char XTP##name##__Data4_5 = (b6); \
40 const unsigned char XTP##name##__Data4_6 = (b7); \
41 const unsigned char XTP##name##__Data4_7 = (b8);
42
43XTP_DEFINE_GUID(LIBID_XtremeFlowGraph,0xBC70F81F,0x1155,0x41DF,0x88,0x10,0x26,0x6A,0xB2,0x91,0xB5,0x13);
44XTP_DEFINE_GUID(DIID_FlowGraphNode,0xC0DE2430,0x79C9,0x462B,0xA5,0xCF,0xC4,0x85,0x7B,0xA0,0x18,0x26);
45XTP_DEFINE_GUID(DIID_FlowGraphPage,0xC0DE2430,0xC977,0x43BF,0x86,0xDE,0x0B,0xC7,0xFB,0x62,0x6E,0x81);
46XTP_DEFINE_GUID(DIID_FlowGraphConnection,0xC0DE2430,0xD6ED,0x41B5,0xB9,0x80,0x4F,0x22,0x97,0x07,0xD9,0xD5);
47XTP_DEFINE_GUID(DIID_FlowGraphConnectionPoint,0xC0DE2430,0x0AF3,0x41B8,0xBC,0x87,0x01,0x14,0xB5,0x23,0x1B,0x97);
48XTP_DEFINE_GUID(DIID_FlowGraphConnectionPoints,0xC0DE2430,0x0996,0x42E3,0x84,0xA7,0xA7,0x7F,0xBE,0xD8,0x40,0x61);
49XTP_DEFINE_GUID(DIID_FlowGraphNodeGroup,0xC0DE2430,0x625F,0x48C1,0x8D,0x74,0x9C,0x5C,0x24,0x22,0xE2,0xB4);
50XTP_DEFINE_GUID(DIID_FlowGraphNodeCustom,0xC0DE2430,0xC44E,0x47CC,0x9B,0x5D,0xC2,0xD7,0xED,0x17,0x83,0x53);
51XTP_DEFINE_GUID(DIID_FlowGraphNodes,0xC0DE2430,0x2FF9,0x4371,0xB7,0x2B,0x4F,0xB7,0x24,0xB3,0x34,0x62);
52XTP_DEFINE_GUID(DIID_FlowGraphNodeGroups,0xC0DE2430,0xFC83,0x4E86,0xBD,0x36,0x25,0xF8,0x4C,0x36,0xB7,0x7F);
53XTP_DEFINE_GUID(DIID_FlowGraphConnections,0xC0DE2430,0x059C,0x47BA,0xBA,0xB8,0xDA,0x52,0xF8,0x16,0xE3,0xE8);
54XTP_DEFINE_GUID(DIID_FlowGraphElement,0xC0DE2430,0x9791,0x4092,0x83,0x60,0x42,0xCF,0x72,0xAA,0x48,0x27);
55XTP_DEFINE_GUID(DIID_FlowGraphSelectedElements,0xC0DE2430,0xA5F1,0x460B,0x91,0xA4,0x4D,0x79,0x41,0x2B,0x33,0xBA);
56XTP_DEFINE_GUID(DIID_FlowGraphPages,0xC0DE2430,0x6B2A,0x43FF,0x86,0x52,0xA7,0xD1,0x31,0x13,0x90,0x00);
57XTP_DEFINE_GUID(DIID_FlowGraphImage,0xC0DE2430,0xECE2,0x4792,0xAA,0x05,0x20,0x36,0x13,0xC4,0xBD,0x29);
58XTP_DEFINE_GUID(DIID_FlowGraphImages,0xC0DE2430,0x066B,0x48FD,0x90,0x5F,0x5A,0xBF,0xE7,0xF5,0x53,0x54);
59XTP_DEFINE_GUID(DIID_FlowGraphUndoManager,0xC0DE2430,0xD2FC,0x4930,0x8B,0x4A,0xA2,0x4F,0x6A,0xB6,0x75,0x0A);
60XTP_DEFINE_GUID(DIID_FlowGraphPageHistory,0xC0DE2430,0xFAB3,0x4948,0x9E,0xDB,0xB9,0x6F,0xB4,0xC6,0x70,0xBF);
61XTP_DEFINE_GUID(DIID_FlowGraphPaintManager,0xC0DE2430,0x013D,0x41B7,0x98,0x9A,0x84,0x35,0x1D,0x10,0x28,0x11);
62XTP_DEFINE_GUID(DIID__DFlowGraph,0xC0DE2430,0x9E29,0x4AF0,0x90,0x85,0x94,0x8D,0x59,0x7F,0x38,0xE0);
63XTP_DEFINE_GUID(DIID__DFlowGraphEvents,0xC0DE2430,0x2BFB,0x472D,0x83,0x8F,0x31,0x97,0x31,0x20,0x6C,0x8F);
64XTP_DEFINE_GUID(CLSID_FlowGraph,0xC0DE2430,0xC12A,0x49A3,0x8D,0x95,0x94,0xC2,0xAE,0x4E,0x8B,0xA6);
65XTP_DEFINE_GUID(DIID_IFlowGraphGlobalSettings,0xC0DE2430,0xCEEC,0x4E21,0x93,0x73,0x07,0xE8,0x99,0x8F,0x92,0x14);
66XTP_DEFINE_GUID(CLSID_FlowGraphGlobalSettings,0xC0DE2430,0xE2C0,0x443C,0x85,0x99,0x82,0x03,0x87,0x43,0xDF,0xD6);
67
68#undef XTP_DEFINE_GUID
69
70// clang-format on
71
72#endif // __XTPFlowGraphIIDs_H__


Toolkit Pro: XTPFlowGraphImage.h File Reference

  • Source
  • FlowGraph
Classes
XTPFlowGraphImage.h File Reference

Go to the source code of this file.

Classes

class | CXTPFlowGraphImage
Object used to represent an image displayed in a Node or connection point. More...
class | CXTPFlowGraphImages
Collection of images that can be used in the flow graph. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPFlowGraphMessages.h File Reference

  • Source
  • FlowGraph
Classes | Variables
XTPFlowGraphMessages.h File Reference

Go to the source code of this file.

Classes

struct | XTP_NM_FLOWGRAPH_ENDLABELEDIT
Information about the label whose editing has ended. More...
struct | XTP_NM_FLOWGRAPH_CONNECTIONCHANGED
Information about the connection that has changed. More...
struct | XTP_NM_FLOWGRAPH_NODECHANGED
Information about the node that has changed. More...
struct | XTP_NM_FLOWGRAPH_CONNECTIONCHANGING
Information about the connection that is currently changing. More...

Variables

const UINT | XTP_FGN_ENDLABELEDIT = (NM_FIRST - 61)
This notification is sent when editing is ended for a label.
const UINT | XTP_FGN_ACTIVEPAGECHANGED = (NM_FIRST - 62)
This notification is sent when a page is set to active.
const UINT | XTP_FGN_CONNECTIONCHANGED = (NM_FIRST - 63)
This notification is sent when a connection is added or removed.
const UINT | XTP_FGN_SELECTIONCHANGED = (NM_FIRST - 64)
This notification is sent when the selection is changed.
const UINT | XTP_FGN_PAGEZOOMLEVELCHANGED = (NM_FIRST - 65)
This notification is sent when the page zoom level is changed.
const UINT | XTP_FGN_NODELOCATIONCHANGED = (NM_FIRST - 66)
This notification is sent when the location of a node is changed.
const UINT | XTP_FGN_PAGESCROLLOFFSETCHANGED = (NM_FIRST - 67)
This notification is sent when the offset of the page is changed.
const UINT | XTP_FGN_CONNECTIONCHANGING = (NM_FIRST - 68)
This notification is sent when a connection is changing.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Variable Documentation

◆ XTP_FGN_CONNECTIONCHANGED

const UINT XTP_FGN_CONNECTIONCHANGED = (NM_FIRST - 63)

This notification is sent when a connection is added or removed.

An XTP_NM_FLOWGRAPH_CONNECTIONCHANGED structure is sent containing information about the connection that changed.

◆ XTP_FGN_CONNECTIONCHANGING

const UINT XTP_FGN_CONNECTIONCHANGING = (NM_FIRST - 68)

This notification is sent when a connection is changing.

An XTP_NM_FLOWGRAPH_CONNECTIONCHANGING structure is sent containing information about the connection that is changing. This notification is sent during a call to CXTPFlowGraphControl::StartDragConnectionPoint.

◆ XTP_FGN_ENDLABELEDIT

const UINT XTP_FGN_ENDLABELEDIT = (NM_FIRST - 61)

This notification is sent when editing is ended for a label.

The information about the edited item is sent in an XTP_NM_FLOWGRAPH_ENDLABELEDIT structure.

◆ XTP_FGN_NODELOCATIONCHANGED

const UINT XTP_FGN_NODELOCATIONCHANGED = (NM_FIRST - 66)

This notification is sent when the location of a node is changed.

The XTP_NM_FLOWGRAPH_NODECHANGED structure is sent with information about the node that changed.

◆ XTP_FGN_PAGESCROLLOFFSETCHANGED

const UINT XTP_FGN_PAGESCROLLOFFSETCHANGED = (NM_FIRST - 67)

This notification is sent when the offset of the page is changed.

This can occur when the mouse wheel is scrolled, when the screen is dragged, during page animation transitions, during zooming, and during page arrangement.

◆ XTP_FGN_SELECTIONCHANGED

const UINT XTP_FGN_SELECTIONCHANGED = (NM_FIRST - 64)

This notification is sent when the selection is changed.

This happens when the selection is cleared, set, added, or removed.


Toolkit Pro: XTPFlowGraphNode.h File Reference

  • Source
  • FlowGraph
Classes | Enumerations
XTPFlowGraphNode.h File Reference

Go to the source code of this file.

Classes

class CXTPFlowGraphNode
Represents a Node object. More...

Enumerations

enum XTPFlowGraphConnectionPointType {
xtpFlowGraphPointNone = 0 , xtpFlowGraphPointInput = 1 , xtpFlowGraphPointOutput = 2 , xtpFlowGraphPointInputAndOutput = 3 ,
xtpFlowGraphPointBoth = 4
}
Node connection point types (input/output). More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Enumeration Type Documentation

◆ XTPFlowGraphConnectionPointType

enum XTPFlowGraphConnectionPointType

Node connection point types (input/output).

The xtpFlowGraphConnectionPointType is used to specify whether a CXTPFlowGraphConnection will have any connection points. Connection points are used to make connections between connections in different Nodes.

See also
CXTPFlowGraphConnectionPoint::SetType
Enumerator
xtpFlowGraphPointNone | Connection has no connection points.
xtpFlowGraphPointInput | Connection only has an input point.
xtpFlowGraphPointOutput | Connection only has an output point.
xtpFlowGraphPointInputAndOutput | Connection has both input and output points. For the default node type. When iterating connection points, you will never find a connection point of this type. It is used to add a table row with actual 2 connection points: xtpFlowGraphPointInput and xtpFlowGraphPointOutput.
xtpFlowGraphPointBoth | A new connection point type for other shapes.


Toolkit Pro: XTPFlowGraphNodeCustom.h File Reference

  • Source
  • FlowGraph
Classes | Enumerations
XTPFlowGraphNodeCustom.h File Reference

Go to the source code of this file.

Classes

class CXTPFlowGraphNodeCustom
Represents a Node object defined by custom XAML markup. More...

Enumerations

enum XTPFlowGraphCustomNodeCaptionPosition { xtpFlowGraphCustomNodeCaptionCenter = 0 , xtpFlowGraphCustomNodeCaptionBelow }
Defines the position for a caption of a custom markup node. More...
enum XTPFlowGraphCustomNodeFillType {
xtpFlowGraphCustomNodeFillSolid = 0 , xtpFlowGraphCustomNodeFillGradientHorizontal , xtpFlowGraphCustomNodeFillGradientVertical , xtpFlowGraphCustomNodeFillGradientDiagonalLeft ,
xtpFlowGraphCustomNodeFillGradientDiagonalRight , xtpFlowGraphCustomNodeFillGradientCenterHorizontal , xtpFlowGraphCustomNodeFillGradientCenterVertical
}
Path (figure) fill type. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Enumeration Type Documentation

◆ XTPFlowGraphCustomNodeCaptionPosition

enum XTPFlowGraphCustomNodeCaptionPosition

Defines the position for a caption of a custom markup node.

See also
CXTPFlowGraphNodeCustom::SetCaptionPosition
Enumerator
xtpFlowGraphCustomNodeCaptionCenter | Center of the shape; default behavior.
xtpFlowGraphCustomNodeCaptionBelow | Below the shape.

◆ XTPFlowGraphCustomNodeFillType

enum XTPFlowGraphCustomNodeFillType

Path (figure) fill type.

Enumerator
xtpFlowGraphCustomNodeFillSolid | Specifies a solid fill type.
xtpFlowGraphCustomNodeFillGradientHorizontal | Specifies a horizontal gradient fill type.
xtpFlowGraphCustomNodeFillGradientVertical | Specifies a vertical gradient fill type.
xtpFlowGraphCustomNodeFillGradientDiagonalLeft | Specifies a left diagonal gradient fill type.
xtpFlowGraphCustomNodeFillGradientDiagonalRight | Specifies a right diagonal gradient fill type.
xtpFlowGraphCustomNodeFillGradientCenterHorizontal | Specifies a center horizontal gradient fill type.
xtpFlowGraphCustomNodeFillGradientCenterVertical | Specifies a center verticl gradient fill type.


Toolkit Pro: XTPFlowGraphNodeGroup.h File Reference

  • Source
  • FlowGraph
Classes
XTPFlowGraphNodeGroup.h File Reference

Go to the source code of this file.

Classes

class CXTPFlowGraphNodeGroup
Represents a group of Nodes. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPFlowGraphNodeGroups.h File Reference

  • Source
  • FlowGraph
Classes
XTPFlowGraphNodeGroups.h File Reference

Go to the source code of this file.

Classes

class CXTPFlowGraphNodeGroups
Represents a collection of groups in a page. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPFlowGraphNodes.h File Reference

  • Source
  • FlowGraph
Classes
XTPFlowGraphNodes.h File Reference

Go to the source code of this file.

Classes

class CXTPFlowGraphNodes
Represents a collection of Nodes in a page or group. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPFlowGraphPage.h File Reference

  • Source
  • FlowGraph
Classes
XTPFlowGraphPage.h File Reference

Go to the source code of this file.

Classes

class CXTPFlowGraphPage
Represents a page in the flow graph. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPFlowGraphPageHistory.h File Reference

  • Source
  • FlowGraph
Classes
XTPFlowGraphPageHistory.h File Reference

Go to the source code of this file.

Classes

struct | CXTPFlowGraphPageHistoryItem
Used internally to store Node history for history operations. More...
class | CXTPFlowGraphPageHistory
Object that contains page transition history for the flow graph. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPFlowGraphPages.h File Reference

  • Source
  • FlowGraph
Classes
XTPFlowGraphPages.h File Reference

Go to the source code of this file.

Classes

class CXTPFlowGraphPages
Represents a collection of pages in the flow graph. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPFlowGraphPaintManager.h File Reference

  • Source
  • FlowGraph
Classes | Enumerations
XTPFlowGraphPaintManager.h File Reference

Go to the source code of this file.

Classes

class CXTPFlowGraphPaintManager
Handles most of the drawing activities of the flow graph. More...

Enumerations

enum XTPFlowGraphConnectorType {
xtpFlowGraphConnectorStraight = 0 , xtpFlowGraphConnectorStraightArrow = 1 , xtpFlowGraphConnectorStraightDoubleArrow = 3 , xtpFlowGraphConnectorCurved = 4 ,
xtpFlowGraphConnectorCurvedArrow = 5 , xtpFlowGraphConnectorCurvedDoubleArrow = 7 , xtpFlowGraphConnectorElbow = 8 , xtpFlowGraphConnectorElbowArrow = 9 ,
xtpFlowGraphConnectorElbowDoubleArrow = 11
}
Node connector styles. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Enumeration Type Documentation

◆ XTPFlowGraphConnectorType

enum XTPFlowGraphConnectorType

Node connector styles.

The xtpFlowGraphConnectorType specifies the style of the lines that "connect" the connections of a Node.

See also
CXTPFlowGraphPaintManager::m_nConnectorType
Enumerator
xtpFlowGraphConnectorStraight | 00000000
xtpFlowGraphConnectorStraightArrow | 00000001
xtpFlowGraphConnectorStraightDoubleArrow | 00000011
xtpFlowGraphConnectorCurved | 00000100
xtpFlowGraphConnectorCurvedArrow | 00000101
xtpFlowGraphConnectorCurvedDoubleArrow | 00000111
xtpFlowGraphConnectorElbow | 00001000
xtpFlowGraphConnectorElbowArrow | 00001001
xtpFlowGraphConnectorElbowDoubleArrow | 00001011


Toolkit Pro: XTPFlowGraphSelectedElements.h File Reference

  • Source
  • FlowGraph
Classes
XTPFlowGraphSelectedElements.h File Reference

Go to the source code of this file.

Classes

class CXTPFlowGraphSelectedElements
Collection of selected elements in the flow graph. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPFlowGraphSelectionRect.h File Reference

  • Source
  • FlowGraph
Enumerations
XTPFlowGraphSelectionRect.h File Reference

Go to the source code of this file.

Enumerations

enum SelectionRectHitTest {
SelectionRectHitTestTopLeft = 0 , SelectionRectHitTestTopCenter , SelectionRectHitTestTopRight , SelectionRectHitTestMiddleRight ,
SelectionRectHitTestBottomRight , SelectionRectHitTestBottomCenter , SelectionRectHitTestBottomLeft , SelectionRectHitTestMiddleLeft ,
SelectionRectHitTestNone
}
Defines selection rectangle hit test codes. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Enumeration Type Documentation

◆ SelectionRectHitTest

enum SelectionRectHitTest

Defines selection rectangle hit test codes.

Enumerator
SelectionRectHitTestTopLeft | Specifies top left rectangle area.
SelectionRectHitTestTopCenter | Specifies top center rectangle area.
SelectionRectHitTestTopRight | Specifies top right rectangle area.
SelectionRectHitTestMiddleRight | Specifies middle right rectangle area.
SelectionRectHitTestBottomRight | Specifies bottom right rectangle area.
SelectionRectHitTestBottomCenter | Specifies bottom center rectangle area.
SelectionRectHitTestBottomLeft | Specifies bottom left rectangle area.
SelectionRectHitTestMiddleLeft | Specifies middle left rectangle area.
SelectionRectHitTestNone | No rectangle area is hit.


Toolkit Pro: XTPFlowGraphTools.h File Reference

  • Source
  • FlowGraph
XTPFlowGraphTools.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPFlowGraphUndoManager.h File Reference

  • Source
  • FlowGraph
Classes | Variables
XTPFlowGraphUndoManager.h File Reference

Go to the source code of this file.

Classes

class | CXTPFlowGraphUndoCommand
This class abstracts the undo command. More...
class | CXTPFlowGraphUndoGroupCommand
This class abstracts the undo commands in a group. More...
class | CXTPFlowGraphUndoDeleteNodeCommand
This class abstracts the undo delete Node command. More...
class | CXTPFlowGraphUndoDeleteConnectionPointCommand
This class abstracts the undo delete connection point command. More...
class | CXTPFlowGraphUndoDeleteConnectionCommand
This class abstracts the undo delete connection command. More...
class | CXTPFlowGraphUndoAddNodeCommand
This class abstracts the undo add Node command. More...
class | CXTPFlowGraphUndoAddConnectionPointCommand
This class abstracts the undo add connection point command. More...
class | CXTPFlowGraphUndoAddConnectionCommand
This class abstracts the undo add connection command. More...
class | CXTPFlowGraphUndoSetNodePositionCommand
This class abstracts the undo set Node position command. More...
class | CXTPFlowGraphUndoSetNodeSizeCommand
This class abstracts the undo set Node size command. More...
class | CXTPFlowGraphUndoSetNodeCaptionCommand
This class abstracts the undo set Node caption command. More...
class | CXTPFlowGraphUndoSetConnectionPositionCommand
This class abstracts the undo set connection position command. More...
class | CXTPFlowGraphUndoManager
This class abstracts an undo manager. More...

Variables

const int | XTP_ID_FLOWGRAPHUNDO_GROUP = -1
The undo group command.
const int | XTP_ID_FLOWGRAPHUNDO_ADDNODE = 1003
The undo add Node command.
const int | XTP_ID_FLOWGRAPHUNDO_DELETENODE = 1004
The undo delete Node command.
const int | XTP_ID_FLOWGRAPHUNDO_SETNODEPOSITION = 1005
The undo set Node position command.
const int | XTP_ID_FLOWGRAPHUNDO_DELETECONNECTION = 1006
The undo delete connection command.
const int | XTP_ID_FLOWGRAPHUNDO_SETCONNECTIONPOSITION = 1007
The undo set connection position command.
const int | XTP_ID_FLOWGRAPHUNDO_ADDCONNECTION = 1008
The undo add connection command.
const int | XTP_ID_FLOWGRAPHUNDO_SETNODECAPTION = 1009
The undo set Node caption command.
const int | XTP_ID_FLOWGRAPHUNDO_SETNODESIZE = 1010
The undo set Node size command.
const int | XTP_ID_FLOWGRAPHUNDO_DELETECONNECTIONPOINT = 1011
The undo delete point command.
const int | XTP_ID_FLOWGRAPHUNDO_ADDCONNECTIONPOINT = 1012
The undo add point command.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTextOnPath.h File Reference

  • Source
  • FlowGraph
Classes
XTPTextOnPath.h File Reference

Go to the source code of this file.

Classes

class CXTPTextOnPath
GDI+ drawing of text on path. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: Gauge Directory Reference

  • Source
  • Gauge
Gauge Directory Reference

Directories

Types

Files

XTPGaugeBaseType.h
XTPGaugeCtrl.h
XTPGaugeTraits.h


Toolkit Pro: Types Directory Reference

  • Source
  • Gauge
  • Types
Types Directory Reference

Files

XTPGaugeMeterType.h
XTPGaugeStateType.h


Toolkit Pro: XTPGaugeMeterType.h File Reference

  • Source
  • Gauge
  • Types
Classes
XTPGaugeMeterType.h File Reference

Go to the source code of this file.

Classes

class CXTPGaugeMeterType
Implements a Meter gauge type. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPGaugeStateType.h File Reference

  • Source
  • Gauge
  • Types
Classes
XTPGaugeStateType.h File Reference

Go to the source code of this file.

Classes

class CXTPGaugeStateType
Implements a State gauge type. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPGaugeBaseType.h File Reference

  • Source
  • Gauge
Classes
XTPGaugeBaseType.h File Reference

Go to the source code of this file.

Classes

class CXTPGaugeBaseType
A base class for all gauge types. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPGaugeCtrl.h File Reference

  • Source
  • Gauge
Classes | Macros
XTPGaugeCtrl.h File Reference

Go to the source code of this file.

Classes

struct | IXTPGaugeClientSite
Provides a client site interface for a gauge control owner. More...
class | CXTPGaugeCtrl
Gauge control hosts a JavaScript and Markup based gauge implementation of a certain type and provides a bidirectional data and event exchange between native and script implementation. More...

Macros

#define | XTP_WM_GAUGEUPDATE CXTPGaugeCtrl::m_XTP_WM_GAUGEUPDATE
The message gets sent to the gauge parent window when gauge state gets updated from the Gauge control in the result of Gauge.update JavaScript call.
#define | ON_XTP_WM_GAUGEUPDATE(member)
Adds XTP_WM_GAUGEUPDATE message handler to a message map.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Macro Definition Documentation

◆ ON_XTP_WM_GAUGEUPDATE

#define ON_XTP_WM_GAUGEUPDATE ( member )
Value:
ON_REGISTERED_MESSAGE(XTP_WM_GAUGEUPDATE, member)
XTP_WM_GAUGEUPDATE
#define XTP_WM_GAUGEUPDATE
The message gets sent to the gauge parent window when gauge state gets updated from the Gauge control...
Definition XTPGaugeCtrl.h:45

Adds XTP_WM_GAUGEUPDATE message handler to a message map.

See also
XTP_WM_GAUGEUPDATE

◆ XTP_WM_GAUGEUPDATE

#define XTP_WM_GAUGEUPDATE CXTPGaugeCtrl::m_XTP_WM_GAUGEUPDATE

The message gets sent to the gauge parent window when gauge state gets updated from the Gauge control in the result of Gauge.update JavaScript call.

Parameters
wParam | Not used.
lParam | Pointer to CXTPGaugeBaseType object of the gauge that has triggered the event.
Returns
Return value is not used.


Toolkit Pro: XTPGaugeTraits.h File Reference

  • Source
  • Gauge
Classes
XTPGaugeTraits.h File Reference

Go to the source code of this file.

Classes

class CXTPGaugeTraits
Defines a set of loaded gauge traits. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: GraphicLibrary Directory Reference

  • Source
  • GraphicLibrary
GraphicLibrary Directory Reference

Directories

GdiPlus
OpenGL

Files

XTPGraphicBitmapPng.h
XTPSvgImage.h


Toolkit Pro: GdiPlus Directory Reference

  • Source
  • GraphicLibrary
  • GdiPlus
GdiPlus Directory Reference

Files

XTPGdiPlus.h


Toolkit Pro: XTPGdiPlus.h File Reference

  • Source
  • GraphicLibrary
  • GdiPlus
XTPGdiPlus.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: OpenGL Directory Reference

  • Source
  • GraphicLibrary
  • OpenGL
OpenGL Directory Reference

Files

XTPOpenGLListPool.h
XTPOpenGLTriangleRenderList.h
XTPOpenGLUtils.h


Toolkit Pro: XTPOpenGLListPool.h File Reference

  • Source
  • GraphicLibrary
  • OpenGL
Classes | Functions
XTPOpenGLListPool.h File Reference

Go to the source code of this file.

Classes

class CXTPOpenGLListPool
Provides a convenient API around an OpenGL list for reliable list management. More...

Functions

_XTP_EXT_CLASS CXTPOpenGLListPool *AFX_CDECL XTPOpenGLListPool ()
Provides access to the global instance of an OpenGL list pool object.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Function Documentation

◆ XTPOpenGLListPool()

_XTP_EXT_CLASS CXTPOpenGLListPool *AFX_CDECL XTPOpenGLListPool ( )

Provides access to the global instance of an OpenGL list pool object.

Returns
A pointer to the global instance of an OpenGL list pool object.


Toolkit Pro: XTPOpenGLTriangleRenderList.h File Reference

  • Source
  • GraphicLibrary
  • OpenGL
XTPOpenGLTriangleRenderList.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPOpenGLUtils.h File Reference

  • Source
  • GraphicLibrary
  • OpenGL
Classes
XTPOpenGLUtils.h File Reference

Go to the source code of this file.

Classes

class CXTPOpenGLUtils
Provides a set of common OpenGL utilities. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPGraphicBitmapPng.h File Reference

  • Source
  • GraphicLibrary
Classes | Enumerations | Functions
XTPGraphicBitmapPng.h File Reference

Go to the source code of this file.

Classes

class CXTPGraphicBitmapPng
CXTPGraphicBitmapPng is a CBitmap derived class used to load .PNG files from files and resources. More...

Enumerations

enum XTPZlibCompressionLevel { xtpZLibNoCompression = 0 , xtpZLibBestSpeed = 1 , xtpZLibBestCompression = 9 , xtpZLibDefaultCompression = -1 }
Possible ZLib compression levels. More...

Functions

_XTP_EXT_CLASS int AFX_CDECL | ZLibCompress (BYTE *dest, ULONG *destLen, const BYTE *source, ULONG sourceLen, XTPZlibCompressionLevel level=xtpZLibDefaultCompression)
Compresses a source buffer into a target buffer using the ZLib library.
_XTP_EXT_CLASS ULONG AFX_CDECL | ZLibCompressBound (ULONG sourceLen)
Used before a ZLibCompress call to allocate the destination buffer.
_XTP_EXT_CLASS int AFX_CDECL | ZLibUncompress (BYTE *dest, ULONG *destLen, const BYTE *source, ULONG sourceLen)
Decompresses a source buffer into a target buffer, using the ZLib library.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Enumeration Type Documentation

◆ XTPZlibCompressionLevel

enum XTPZlibCompressionLevel

Possible ZLib compression levels.

See also
ZLibCompressWithLevel
Enumerator
xtpZLibNoCompression | No compression.
xtpZLibBestSpeed | Best speed.
xtpZLibBestCompression | Best compression.
xtpZLibDefaultCompression | Default compression.

Function Documentation

◆ ZLibCompress()

_XTP_EXT_CLASS int AFX_CDECL ZLibCompress | ( | BYTE * | dest,
 |  | ULONG * | destLen,
 |  | const BYTE * | source,
 |  | ULONG | sourceLen,
 |  | XTPZlibCompressionLevel | level = xtpZLibDefaultCompression )

Compresses a source buffer into a target buffer using the ZLib library.

Parameters
dest | Pointer to the target buffer.
destLen | Size of the target buffer; must be at least 0.1% larger than source_size plus 12 bytes.
source | Pointer to the source buffer.
sourceLen | Size of the source buffer.
level | Optional compression level; one of the XTPZlibCompressionLevel constants.
Returns
The actual size of the compressed buffer, or 0 if an error occurred.
See also
XTPZlibCompressionLevel

◆ ZLibCompressBound()

_XTP_EXT_CLASS ULONG AFX_CDECL ZLibCompressBound ( ULONG sourceLen )

Used before a ZLibCompress call to allocate the destination buffer.

Parameters
sourceLen Size of the source buffer.
Returns
An upper bound on the compressed size after ZLibCompress on sourceLen bytes.

◆ ZLibUncompress()

_XTP_EXT_CLASS int AFX_CDECL ZLibUncompress | ( | BYTE * | dest,
 |  | ULONG * | destLen,
 |  | const BYTE * | source,
 |  | ULONG | sourceLen )

Decompresses a source buffer into a target buffer, using the ZLib library.

Parameters
dest | Pointer to the target buffer.
destLen | Size of the target buffer; must be at least 0.1% larger than source_size plus 12 bytes.
source | Pointer to the source buffer.
sourceLen | Size of the source buffer.
Returns
The actual size of the uncompressed buffer, or 0 if an error occurred.


Toolkit Pro: XTPSvgImage.h File Reference

  • Source
  • GraphicLibrary
Classes
XTPSvgImage.h File Reference

Go to the source code of this file.

Classes

class CXTPSvgImage
Implements basic SVG image format support. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: GridControl Directory Reference

  • Source
  • GridControl
GridControl Directory Reference

Directories

Behavior
ItemTypes
Themes
TrackControl

Files

XTPGridADO.h
XTPGridAllocators.h
XTPGridBorder.h
XTPGridColumn.h
XTPGridColumns.h
XTPGridControl.h
XTPGridControlIIDs.h
XTPGridDataManager.h
XTPGridDefines.h
XTPGridDeprecated.h
XTPGridDragDrop.h
XTPGridFilterEditControl.h
XTPGridGroupRow.h
XTPGridHeader.h
XTPGridHitTestInfo.h
XTPGridHyperlink.h
XTPGridInplaceControls.h
XTPGridNavigator.h
XTPGridPageSetupDialog.h
XTPGridPaintManager.h
XTPGridRecord.h
XTPGridRecordItem.h
XTPGridRecordItemConstraint.h
XTPGridRecordItemControls.h
XTPGridRecordItemRange.h
XTPGridRecords.h
XTPGridRow.h
XTPGridRows.h
XTPGridSection.h
XTPGridSections.h
XTPGridSelectedRows.h
XTPGridSubListControl.h
XTPGridThickness.h
XTPGridTip.h
XTPGridView.h


Toolkit Pro: Behavior Directory Reference

  • Source
  • GridControl
  • Behavior
Behavior Directory Reference

Files

XTPGridBehavior.h


Toolkit Pro: XTPGridBehavior.h File Reference

  • Source
  • GridControl
  • Behavior
Enumerations
XTPGridBehavior.h File Reference

Go to the source code of this file.

Enumerations

enum | XTPGridMouseButton { xtpGridMouseButtonNone , xtpGridMouseButtonLeft , xtpGridMouseButtonMiddle , xtpGridMouseButtonRight }
Defines a mouse button. More...
enum | XTPGridMouseEvent { xtpGridMouseEventButtonDown , xtpGridMouseEventButtonUp }
Defines a mouse event. More...
enum XTPGridBehavior {
xtpGridBehaviorOutlook2003 = 0x00001100 , xtpGridBehaviorOutlook2007 = 0x00001200 , xtpGridBehaviorOutlook2010 = 0x00001400 , xtpGridBehaviorExcel2003 = 0x10001100 ,
xtpGridBehaviorExcel2007 = 0x10001200 , xtpGridBehaviorExcel2010 = 0x10001400 , xtpGridBehaviorCodejock1340 = 0x20001340 , xtpGridBehaviorCodejock1341 = 0x20001341 ,
xtpGridBehaviorCodejock1342 = 0x20001342 , xtpGridBehaviorCodejock1501 = 0x20001501 , xtpGridBehaviorCodejock1502 = 0x20001502 , xtpGridBehaviorCodejockDefault = 0x20000000
}
Defines grid behavior. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Enumeration Type Documentation

◆ XTPGridBehavior

enum XTPGridBehavior

Defines grid behavior.

Enumerator
xtpGridBehaviorOutlook2003 | Specifies behavior similar to Outlook 2003 that was the default behavior of the control's version 11.0.
xtpGridBehaviorOutlook2007 | Specifies behavior similar to Outlook 2007 that was the default behavior of the control's version 12.0.
xtpGridBehaviorOutlook2010 | Specifies behavior similar to Outlook 2010 that was the default behavior of the control's version 14.0.
xtpGridBehaviorExcel2003 | Specifies behavior similar to Excel 2003 that was the default behavior of the control's version 11.0.
xtpGridBehaviorExcel2007 | Specifies behavior similar to Excel 2007 that was the default behavior of the control's version 12.0.
xtpGridBehaviorExcel2010 | Specifies behavior similar to Excel 2010 that was the default behavior of the control's version 14.0.
xtpGridBehaviorCodejock1340 | The default behavior of the control's version 13.4.0.
xtpGridBehaviorCodejock1341 | The default behavior of the control's version 13.4.1.
xtpGridBehaviorCodejock1342 | The default behavior of the control's version 13.4.2.
xtpGridBehaviorCodejock1501 | The default behavior of the control's version 15.0.1.
xtpGridBehaviorCodejock1502 | The default behavior of the control's version 15.0.2.
xtpGridBehaviorCodejockDefault | The latest default behavior.

◆ XTPGridMouseButton

enum XTPGridMouseButton

Defines a mouse button.

Enumerator
xtpGridMouseButtonNone | No mouse button.
xtpGridMouseButtonLeft | Specifies a left mouse button.
xtpGridMouseButtonMiddle | Specifies a middle mouse button.
xtpGridMouseButtonRight | Specifies a right mouse button.

◆ XTPGridMouseEvent

enum XTPGridMouseEvent

Defines a mouse event.

Enumerator
xtpGridMouseEventButtonDown | Specifies a mouse button down mouse event.
xtpGridMouseEventButtonUp | Specifies a mouse button up event.


Toolkit Pro: ItemTypes Directory Reference

  • Source
  • GridControl
  • ItemTypes
ItemTypes Directory Reference

Files

XTPGridRecordItemCheckbox.h
XTPGridRecordItemDateTime.h
XTPGridRecordItemIcon.h
XTPGridRecordItemNumber.h
XTPGridRecordItemPreview.h
XTPGridRecordItemText.h
XTPGridRecordItemVariant.h


Toolkit Pro: XTPGridRecordItemCheckbox.h File Reference

  • Source
  • GridControl
  • ItemTypes
Classes
XTPGridRecordItemCheckbox.h File Reference

Go to the source code of this file.

Classes

class CXTPGridRecordItemCheckbox
This class represents a checkbox-only cell and inherits basic functionality from the CXTPGridRecordItem class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPGridRecordItemDateTime.h File Reference

  • Source
  • GridControl
  • ItemTypes
Classes
XTPGridRecordItemDateTime.h File Reference

Go to the source code of this file.

Classes

class CXTPGridRecordItemDateTime
Represents a time cell and inherits basic functionality from the CXTPGridRecordItem class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPGridRecordItemIcon.h File Reference

  • Source
  • GridControl
  • ItemTypes
XTPGridRecordItemIcon.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPGridRecordItemNumber.h File Reference

  • Source
  • GridControl
  • ItemTypes
Classes
XTPGridRecordItemNumber.h File Reference

Go to the source code of this file.

Classes

class | CXTPGridRecordItemNumber
This class represents a numeric cell and inherits basic functionality from the CXTPGridRecordItem class. More...
class | CXTPGridRecordItemPercentNumber
This class represents a numeric percent cell and inherits basic functionality from the CXTPGridRecordItemNumber class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPGridRecordItemPreview.h File Reference

  • Source
  • GridControl
  • ItemTypes
Classes
XTPGridRecordItemPreview.h File Reference

Go to the source code of this file.

Classes

class CXTPGridRecordItemPreview
This represents a preview cell and inherits basic functionality from the CXTPGridRecordItem class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPGridRecordItemText.h File Reference

  • Source
  • GridControl
  • ItemTypes
Classes
XTPGridRecordItemText.h File Reference

Go to the source code of this file.

Classes

class CXTPGridRecordItemText
This class represents a text-only cell and inherits basic functionality from the CXTPGridRecordItem class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPGridRecordItemVariant.h File Reference

  • Source
  • GridControl
  • ItemTypes
Classes
XTPGridRecordItemVariant.h File Reference

Go to the source code of this file.

Classes

class CXTPGridRecordItemVariant
Represents a variant item and inherits basic functionality from the CXTPGridRecordItem class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: Themes Directory Reference

  • Source
  • GridControl
  • Themes
Themes Directory Reference

Files

XTPGridThemeDefault.h
XTPGridThemeExplorer.h
XTPGridThemeNativeWindows10.h
XTPGridThemeNativeWindows11.h
XTPGridThemeOffice2003.h
XTPGridThemeOffice2003Luna.h
XTPGridThemeOffice2013.h
XTPGridThemeOfficeXP.h
XTPGridThemeResource.h
XTPGridThemeVisualStudio2012.h
XTPGridThemeVisualStudio2015.h
XTPGridThemeVisualStudio2017.h
XTPGridThemeVisualStudio2019.h
XTPGridThemeVisualStudio2022.h


Toolkit Pro: XTPGridThemeDefault.h File Reference

  • Source
  • GridControl
  • Themes
Classes
XTPGridThemeDefault.h File Reference

Go to the source code of this file.

Classes

class CXTPGridThemeDefault
CXTPGridThemeDefault is a CXTPGridPaintManager derived class that represents an Office 97 style theme. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPGridThemeExplorer.h File Reference

  • Source
  • GridControl
  • Themes
Classes
XTPGridThemeExplorer.h File Reference

Go to the source code of this file.

Classes

class CXTPGridThemeExplorer
CXTPGridThemeExplorer is a CXTPGridPaintManager derived class that represents an Explorer style theme. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPGridThemeNativeWindows10.h File Reference

  • Source
  • GridControl
  • Themes
Classes
XTPGridThemeNativeWindows10.h File Reference

Go to the source code of this file.

Classes

class CXTPGridThemeNativeWindows10
CXTPGridThemeNativeWindows10 is a CXTPGridThemeOffice2013 derived class that represents a Native Windows 10 style theme. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPGridThemeNativeWindows11.h File Reference

  • Source
  • GridControl
  • Themes
Classes
XTPGridThemeNativeWindows11.h File Reference

Go to the source code of this file.

Classes

class CXTPGridThemeNativeWindows11
CXTPGridThemeNativeWindows11 is a CXTPGridThemeOffice2013 derived class that represents a Native Windows 10 style theme. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPGridThemeOffice2003.h File Reference

  • Source
  • GridControl
  • Themes
Classes
XTPGridThemeOffice2003.h File Reference

Go to the source code of this file.

Classes

class CXTPGridThemeOffice2003
CXTPGridThemeOffice2003 is a CXTPGridPaintManager derived class that represents an Office 2003 style theme. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPGridThemeOffice2003Luna.h File Reference

  • Source
  • GridControl
  • Themes
Classes
XTPGridThemeOffice2003Luna.h File Reference

Go to the source code of this file.

Classes

class CXTPGridThemeOffice2003Luna
CXTPGridThemeOffice2003Luna is a CXTPGridPaintManager derived class that represents an Office 2003 Luna style theme. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPGridThemeOffice2013.h File Reference

  • Source
  • GridControl
  • Themes
Classes
XTPGridThemeOffice2013.h File Reference

Go to the source code of this file.

Classes

class CXTPGridThemeOffice2013
CXTPGridThemeOffice2013 is a CXTPGridPaintManager derived class that represents an Office 2013 style theme. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPGridThemeOfficeXP.h File Reference

  • Source
  • GridControl
  • Themes
Classes
XTPGridThemeOfficeXP.h File Reference

Go to the source code of this file.

Classes

class CXTPGridThemeOfficeXP
CXTPGridThemeOfficeXP is a CXTPGridPaintManager derived class that represents an Office XP style theme. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPGridThemeResource.h File Reference

  • Source
  • GridControl
  • Themes
Classes
XTPGridThemeResource.h File Reference

Go to the source code of this file.

Classes

class CXTPGridThemeResource
CXTPGridThemeResource is a CXTPGridPaintManager derived class that represents a Resource style theme. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPGridThemeVisualStudio2012.h File Reference

  • Source
  • GridControl
  • Themes
Classes
XTPGridThemeVisualStudio2012.h File Reference

Go to the source code of this file.

Classes

class | CXTPGridThemeVisualStudio2012Light
CXTPGridThemeVisualStudio2012Light is a CXTPGridThemeOffice2013 derived class that represents a Visual Studio 2012 Light style theme. More...
class | CXTPGridThemeVisualStudio2012Dark
CXTPGridThemeVisualStudio2012Dark is a CXTPGridThemeOffice2013 derived class that represents a Visual Studio 2012 Dark style theme. More...
class | CXTPGridThemeVisualStudio2012Blue
CXTPGridThemeVisualStudio2012Blue is a CXTPGridThemeOffice2013 derived class that represents a Visual Studio 2012 Blue style theme. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPGridThemeVisualStudio2015.h File Reference

  • Source
  • GridControl
  • Themes
Classes
XTPGridThemeVisualStudio2015.h File Reference

Go to the source code of this file.

Classes

class CXTPGridThemeVisualStudio2015
CXTPGridThemeVisualStudio2015 is a CXTPGridThemeOffice2013 derived class that represents a Visual Studio 2015 style theme. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPGridThemeVisualStudio2017.h File Reference

  • Source
  • GridControl
  • Themes
Classes
XTPGridThemeVisualStudio2017.h File Reference

Go to the source code of this file.

Classes

class CXTPGridThemeVisualStudio2017
CXTPGridThemeVisualStudio2017 is a CXTPGridThemeOffice2013 derived class that represents a Visual Studio 2017 style theme. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPGridThemeVisualStudio2019.h File Reference

  • Source
  • GridControl
  • Themes
Classes
XTPGridThemeVisualStudio2019.h File Reference

Go to the source code of this file.

Classes

class CXTPGridThemeVisualStudio2019
CXTPGridThemeVisualStudio2019 is a CXTPGridThemeOffice2013 derived class that represents a Visual Studio 2019 style theme. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPGridThemeVisualStudio2022.h File Reference

  • Source
  • GridControl
  • Themes
Classes
XTPGridThemeVisualStudio2022.h File Reference

Go to the source code of this file.

Classes

class CXTPGridThemeVisualStudio2022
CXTPGridThemeVisualStudio2022 is a CXTPGridThemeOffice2013 derived class that represents a Visual Studio 2022 style theme. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: TrackControl Directory Reference

  • Source
  • GridControl
  • TrackControl
TrackControl Directory Reference

Directories

Themes

Files

XTPTrackBlock.h
XTPTrackControl.h
XTPTrackControlItem.h
XTPTrackHeader.h
XTPTrackPaintManager.h
XTPTrackUndoManager.h


Toolkit Pro: Themes Directory Reference

  • Source
  • GridControl
  • TrackControl
  • Themes
Themes Directory Reference

Files

XTPTrackThemeDefault.h
XTPTrackThemeExplorer.h
XTPTrackThemeNativeWindows10.h
XTPTrackThemeNativeWindows11.h
XTPTrackThemeOffice2003.h
XTPTrackThemeOffice2003Luna.h
XTPTrackThemeOffice2013.h
XTPTrackThemeOfficeXP.h
XTPTrackThemeResource.h
XTPTrackThemeVisualStudio2012.h
XTPTrackThemeVisualStudio2015.h
XTPTrackThemeVisualStudio2017.h
XTPTrackThemeVisualStudio2019.h
XTPTrackThemeVisualStudio2022.h


Toolkit Pro: XTPTrackThemeDefault.h File Reference

  • Source
  • GridControl
  • TrackControl
  • Themes
Classes
XTPTrackThemeDefault.h File Reference

Go to the source code of this file.

Classes

class CXTPTrackThemeDefault
CXTPTrackThemeDefault is a CXTPTrackPaintManager derived class that represents an Office 97 style theme. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTrackThemeExplorer.h File Reference

  • Source
  • GridControl
  • TrackControl
  • Themes
Classes
XTPTrackThemeExplorer.h File Reference

Go to the source code of this file.

Classes

class CXTPTrackThemeExplorer
CXTPTrackThemeExplorer is a CXTPTrackPaintManager derived class that represents an Explorer style theme. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTrackThemeNativeWindows10.h File Reference

  • Source
  • GridControl
  • TrackControl
  • Themes
Classes
XTPTrackThemeNativeWindows10.h File Reference

Go to the source code of this file.

Classes

class CXTPTrackThemeNativeWindows10
CXTPTrackThemeNativeWindows10 is a CXTPTrackThemeOffice2013 derived class that represents a Native Windows 10 style theme. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTrackThemeNativeWindows11.h File Reference

  • Source
  • GridControl
  • TrackControl
  • Themes
Classes
XTPTrackThemeNativeWindows11.h File Reference

Go to the source code of this file.

Classes

class CXTPTrackThemeNativeWindows11
CXTPTrackThemeNativeWindows11 is a CXTPTrackThemeOffice2013 derived class that represents a Native Windows 10 style theme. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTrackThemeOffice2003.h File Reference

  • Source
  • GridControl
  • TrackControl
  • Themes
Classes
XTPTrackThemeOffice2003.h File Reference

Go to the source code of this file.

Classes

class CXTPTrackThemeOffice2003
CXTPTrackThemeOffice2003 is a CXTPTrackPaintManager derived class that represents an Office 2003 style theme. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTrackThemeOffice2003Luna.h File Reference

  • Source
  • GridControl
  • TrackControl
  • Themes
Classes
XTPTrackThemeOffice2003Luna.h File Reference

Go to the source code of this file.

Classes

class CXTPTrackThemeOffice2003Luna
CXTPTrackThemeOffice2003Luna is a CXTPTrackPaintManager derived class that represents an Office 2003 Luna style theme. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTrackThemeOffice2013.h File Reference

  • Source
  • GridControl
  • TrackControl
  • Themes
Classes
XTPTrackThemeOffice2013.h File Reference

Go to the source code of this file.

Classes

class CXTPTrackThemeOffice2013
CXTPTrackThemeOffice2013 is a CXTPTrackPaintManager derived class that represents an Office 2013 style theme. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTrackThemeOfficeXP.h File Reference

  • Source
  • GridControl
  • TrackControl
  • Themes
Classes
XTPTrackThemeOfficeXP.h File Reference

Go to the source code of this file.

Classes

class CXTPTrackThemeOfficeXP
CXTPTrackThemeOfficeXP is a CXTPTrackPaintManager derived class that represents an Office XP style theme. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTrackThemeResource.h File Reference

  • Source
  • GridControl
  • TrackControl
  • Themes
Classes
XTPTrackThemeResource.h File Reference

Go to the source code of this file.

Classes

class CXTPTrackThemeResource
CXTPTrackThemeResource is a CXTPTrackPaintManager derived class that represents a Resource style theme. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTrackThemeVisualStudio2012.h File Reference

  • Source
  • GridControl
  • TrackControl
  • Themes
Classes
XTPTrackThemeVisualStudio2012.h File Reference

Go to the source code of this file.

Classes

class | CXTPTrackThemeVisualStudio2012Light
CXTPTrackThemeVisualStudio2012Light is a CXTPTrackThemeOffice2013 derived class that represents a Visual Studio 2012 Light style theme. More...
class | CXTPTrackThemeVisualStudio2012Dark
CXTPTrackThemeVisualStudio2012Dark is a CXTPTrackThemeOffice2013 derived class that represents a Visual Studio 2012 Dark style theme. More...
class | CXTPTrackThemeVisualStudio2012Blue
CXTPTrackThemeVisualStudio2012Blue is a CXTPTrackThemeOffice2013 derived class that represents a Visual Studio 2012 Blue style theme. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTrackThemeVisualStudio2015.h File Reference

  • Source
  • GridControl
  • TrackControl
  • Themes
Classes
XTPTrackThemeVisualStudio2015.h File Reference

Go to the source code of this file.

Classes

class CXTPTrackThemeVisualStudio2015
CXTPTrackThemeVisualStudio2015 is a CXTPTrackThemeOffice2013 derived class that represents a Visual Studio 2015 style theme. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTrackThemeVisualStudio2017.h File Reference

  • Source
  • GridControl
  • TrackControl
  • Themes
Classes
XTPTrackThemeVisualStudio2017.h File Reference

Go to the source code of this file.

Classes

class CXTPTrackThemeVisualStudio2017
CXTPTrackThemeVisualStudio2017 is a CXTPTrackThemeOffice2013 derived class that represents a Visual Studio 2017 style theme. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTrackThemeVisualStudio2019.h File Reference

  • Source
  • GridControl
  • TrackControl
  • Themes
Classes
XTPTrackThemeVisualStudio2019.h File Reference

Go to the source code of this file.

Classes

class CXTPTrackThemeVisualStudio2019
CXTPTrackThemeVisualStudio2019 is a CXTPTrackThemeOffice2013 derived class that represents a Visual Studio 2019 style theme. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTrackThemeVisualStudio2022.h File Reference

  • Source
  • GridControl
  • TrackControl
  • Themes
Classes
XTPTrackThemeVisualStudio2022.h File Reference

Go to the source code of this file.

Classes

class CXTPTrackThemeVisualStudio2022
CXTPTrackThemeVisualStudio2022 is a CXTPTrackThemeOffice2013 derived class that represents a Visual Studio 2022 style theme. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTrackBlock.h File Reference

  • Source
  • GridControl
  • TrackControl
Classes
XTPTrackBlock.h File Reference

Go to the source code of this file.

Classes

class | CXTPTrackBlock
This class represents a track control block. More...
class | CXTPTrackKey
This class represents a track control key. More...
class | CXTPTrackMarker
This class represents a track control marker. More...
class | CXTPTrackMarkers
This class abstracts the track control markers. More...
class | CXTPTrackSelectedBlocks
This class abstracts the selected blocks of the track control. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTrackControl.h File Reference

  • Source
  • GridControl
  • TrackControl
Classes | Macros | Enumerations
XTPTrackControl.h File Reference

Go to the source code of this file.

Classes

struct | XTP_NM_TRACKCONTROL
This structure contains notification details. More...
class | CXTPTrackControl
This class represents a track control. More...
struct | CXTPTrackControl::DRAGBLOCK
This structure abstracts the state of block being dragged. More...

Macros

#define | XTP_NM_TRACK_SLIDERCHANGED (NM_FIRST - 200)
This notification is sent to the parent, when the track slider is changed.
#define | XTP_NM_TRACK_TIMELINECHANGED (NM_FIRST - 201)
This notification is sent to the parent, when the track time line is changed.
#define | XTP_NM_TRACK_MARKERCHANGED (NM_FIRST - 202)
This notification is sent to the parent, when the track marker is changed.
#define | XTP_NM_TRACK_BLOCKCHANGED (NM_FIRST - 203)
This notification is sent to the parent, when the track block position is changed.
#define | XTP_NM_TRACK_SELECTEDBLOCKSCHANGED (NM_FIRST - 204)
This notification is sent to the parent, when the selected blocks position is changed.

Enumerations

enum XTPTrackMouseCursorMode { xtpTrackCursorNothing , xtpTrackCursorDrag , xtpTrackCursorResize }
Enumeration of operational mouse cursor modes. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Enumeration Type Documentation

◆ XTPTrackMouseCursorMode

enum XTPTrackMouseCursorMode

Enumeration of operational mouse cursor modes.

TrackControl has several mouse cursor states that are handled by the control. This enumeration helps to clearly identify each of these.

See also
CXTPTrackControl::SetMouseCursorMode, CXTPTrackControl::GetMouseCursorMode, CXTPGridControl::XTPGridMouseMode, xtpTrackCursorNothing, xtpTrackCursorDrag, xtpTrackCursorResize
Enumerator
xtpTrackCursorNothing | User is just watching.
xtpTrackCursorDrag | User is dragging something.
xtpTrackCursorResize | User is resizing something.


Toolkit Pro: XTPTrackControlItem.h File Reference

  • Source
  • GridControl
  • TrackControl
Classes
XTPTrackControlItem.h File Reference

Go to the source code of this file.

Classes

class CXTPTrackControlItem
This class represents a container cell for a set of blocks and keys and inherits basic functionality from the CXTPGridRecordItem class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTrackHeader.h File Reference

  • Source
  • GridControl
  • TrackControl
Classes
XTPTrackHeader.h File Reference

Go to the source code of this file.

Classes

class CXTPTrackHeader
This class represents a track control header. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTrackPaintManager.h File Reference

  • Source
  • GridControl
  • TrackControl
Classes
XTPTrackPaintManager.h File Reference

Go to the source code of this file.

Classes

class CXTPTrackPaintManager
This class represents a track control paint manager. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTrackUndoManager.h File Reference

  • Source
  • GridControl
  • TrackControl
Classes | Variables
XTPTrackUndoManager.h File Reference

Go to the source code of this file.

Classes

class | CXTPTrackUndoCommand
This class abstracts the undo command. More...
class | CXTPTrackUndoGroupCommand
This class abstracts the undo commands in a group. More...
class | CXTPTrackUndoDeleteMarkerCommand
This class abstracts the undo delete marker command. More...
class | CXTPTrackUndoAddMarkerCommand
This class abstracts the undo add marker command. More...
class | CXTPTrackUndoSetMarkerPositionCommand
This class abstracts the undo set marker position command. More...
class | CXTPTrackUndoDeleteBlockCommand
This class abstracts the undo delete block command. More...
class | CXTPTrackUndoAddBlockCommand
This class abstracts the undo add block command. More...
class | CXTPTrackUndoSetBlockPositionCommand
This class abstracts the undo set block position command. More...
class | CXTPTrackUndoManager
This class abstracts an undo manager. More...

Variables

const int | XTP_ID_TRACKUNDO_GROUP = -1
The undo group command.
const int | XTP_ID_TRACKUNDO_SETMARKERPOSITION = 1000
The undo set marker position command.
const int | XTP_ID_TRACKUNDO_ADDMARKER = 1001
The undo add marker command.
const int | XTP_ID_TRACKUNDO_DELETEMARKER = 1002
The undo delete marker command.
const int | XTP_ID_TRACKUNDO_ADDBLOCK = 1003
The undo add block command.
const int | XTP_ID_TRACKUNDO_DELETEBLOCK = 1004
The undo delete block command.
const int | XTP_ID_TRACKUNDO_SETBLOCKPOSITION = 1005
The undo set block position command.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPGridADO.h File Reference

  • Source
  • GridControl
XTPGridADO.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPGridAllocators.h File Reference

  • Source
  • GridControl
XTPGridAllocators.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPGridBorder.h File Reference

  • Source
  • GridControl
Enumerations
XTPGridBorder.h File Reference

Go to the source code of this file.

Enumerations

enum XTPGridBorderEdge {
xtpGridBorderEdgeLeft , xtpGridBorderEdgeTop , xtpGridBorderEdgeRight , xtpGridBorderEdgeBottom ,
xtpGridBorderEdgeCount
}
Defines a grid border edge. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Enumeration Type Documentation

◆ XTPGridBorderEdge

enum XTPGridBorderEdge

Defines a grid border edge.

Enumerator
xtpGridBorderEdgeLeft | Specifies a left grid border edge.
xtpGridBorderEdgeTop | Specifies a top grid border edge.
xtpGridBorderEdgeRight | Specifies a right grid border edge.
xtpGridBorderEdgeBottom | Specifies a bottom grid border edge.
xtpGridBorderEdgeCount | Specifies the number of grid border edges.


Toolkit Pro: XTPGridColumn.h File Reference

  • Source
  • GridControl
Classes | Enumerations
XTPGridColumn.h File Reference

Go to the source code of this file.

Classes

class CXTPGridColumn
Represents a grid column item with its properties and operations. More...

Enumerations

enum XTPGridColumnBestFitMode { xtpColumnBestFitModeVisibleData = 0 , xtpColumnBestFitModeAllData = 1 }
This enum defines the best fit mode. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Enumeration Type Documentation

◆ XTPGridColumnBestFitMode

enum XTPGridColumnBestFitMode

This enum defines the best fit mode.

Enumerator
xtpColumnBestFitModeVisibleData | Fit by visible column data.
xtpColumnBestFitModeAllData | Fit by all column data.


Toolkit Pro: XTPGridColumns.h File Reference

  • Source
  • GridControl
Classes
XTPGridColumns.h File Reference

Go to the source code of this file.

Classes

class | CXTPGridColumns
This class is a collection of grid column objects. More...
class | CXTPGridColumnOrder
Represents the column order, used for sorting and grouping. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPGridControl.h File Reference

  • Source
  • GridControl
Classes | Enumerations
XTPGridControl.h File Reference

Go to the source code of this file.

Classes

struct | XTP_NM_GRIDITEMMETRICS
This structure is sent to the Main window in a WM_NOTIFY message from Item and provides all parameters required by the Main window to process control specific notifications. More...
struct | XTP_NM_GRIDDRAGDROP
This structure is sent to the Main window in a WM_NOTIFY message from Grid Control to determine if records are dragged or dropped. More...
struct | XTP_NM_GRIDPREVIEWKEYDOWN
This structure is sent to the Main window in a WM_NOTIFY message before processing the OnKeyDown event. More...
struct | XTPGridInputState
Stores the mouse and key states. More...
class | CXTPGridControl
The CXTPGridControl class provides an implementation of the Grid control. More...
class | CXTPGridControl::CUpdateContext
Internal grid update helper. More...
class | CXTPGridControlLocale
Helper class with static member functions used to control active locale for Grid control and perform some locale dependent tasks. More...

Enumerations

enum XTPGridMouseMode {
xtpGridMouseNothing , xtpGridMouseOverColumnDivide , xtpGridMousePrepareDragColumn , xtpGridMouseDraggingColumn ,
xtpGridMouseOverRowDivide
}
Enumeration of operational mouse modes. More...
enum XTPGridDragDrop {
xtpGridAllowDrop = 1 , xtpGridAllowDragCopy = 2 , xtpGridAllowDragMove = 4 , xtpGridAllowDrag = 6 ,
xtpGridDontDropAsText = 8
}
Enumeration of drag and drop flags. More...
enum | XTPGridDropMarker { xtpGridDropBetween = 1 , xtpGridDropSelect = 2 }
Enumeration describes the drop marker. More...
enum XTPGridWatermarkAlignment {
xtpGridWatermarkUnknown = 0 , xtpGridWatermarkLeft = 0x0001 , xtpGridWatermarkCenter = 0x0002 , xtpGridWatermarkRight = 0x0004 ,
xtpGridWatermarkHmask = 0x000F , xtpGridWatermarkTop = 0x0010 , xtpGridWatermarkVCenter = 0x0020 , xtpGridWatermarkBottom = 0x0040 ,
xtpGridWatermarkVmask = 0x00F0 , xtpGridWatermarkStretch = 0x0100 , xtpGridWatermarkEnlargeOnly = 0x0200 , xtpGridWatermarkShrinkOnly = 0x0400 ,
xtpGridWatermarkPreserveRatio = 0x0800
}
Enumeration of watermark alignment flags. More...
enum XTPGridElementRect {
xtpGridElementRectGridArea = 0 , xtpGridElementRectGroupByArea , xtpGridElementRectHeaderArea , xtpGridElementRectFooterArea ,
xtpGridElementRectHeaderRecordsArea , xtpGridElementRectFooterRecordsArea , xtpGridElementRectHeaderRecordsDividerArea , xtpGridElementRectFooterRecordsDividerArea
}
Enumeration of GetElementRect flags. More...
enum | XTPGridFilterMode { xtpGridFilterTreeSimple = 0 , xtpGridFilterTreeByParentAndChildren = 1 , xtpGridFilterTreeByEndChildrenOnly = 2 }
Enumeration of options for the SetRecordsTreeFilterMode method. More...
enum | XTPGridScrollUpdateMode { xtpGridScrollUpdateModeImmediate , xtpGridScrollUpdateModeDeferred }
Enumeration of scroll update modes. More...
enum XTPGridScrollMode {
xtpGridScrollModeNone = 0 , xtpGridScrollModeBlockCount = 1 , xtpGridScrollModeBlockSize = 3 , xtpGridScrollModeSmooth = 2 ,
xtpGridScrollModeBlock = xtpGridScrollModeBlockCount
}
Enumeration of scroll modes. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Enumeration Type Documentation

◆ XTPGridDragDrop

enum XTPGridDragDrop

Enumeration of drag and drop flags.

Call CXTPGridControl::EnableDragDrop to allow drag/drop operations.

Example:

m_wndGrid.EnableDragDrop("MyApplication", xtpGridAllowDrop |
xtpGridAllowDrag);
See also
CXTPGridControl::EnableDragDrop
Enumerator
xtpGridAllowDrop | Allow drop records to grid.
xtpGridAllowDragCopy | Allow copy records from grid.
xtpGridAllowDragMove | Allow move records from grid.
xtpGridAllowDrag | Allow copy and move records from grid.
xtpGridDontDropAsText | Do not drag record as plain text.

◆ XTPGridDropMarker

enum XTPGridDropMarker

Enumeration describes the drop marker.

Enumerator
xtpGridDropBetween | Drop the row between two rows.
xtpGridDropSelect | Drop the selected rows.

◆ XTPGridElementRect

enum XTPGridElementRect

Enumeration of GetElementRect flags.

Call CXTPGridControl::GetElementRect to get grid element rectangle.

Example:

CRect rcElement = m_wndGrid.GetElementRect(xtpGridRectGroupByArea);
See also
CXTPGridControl::GetElementRect
Enumerator
xtpGridElementRectGridArea | The area occupied by the records.
xtpGridElementRectGroupByArea | The area occupied by Group By item.
xtpGridElementRectHeaderArea | The area occupied by the header.
xtpGridElementRectFooterArea | The area occupied by the footer.
xtpGridElementRectHeaderRecordsArea | The area occupied by the header records.
xtpGridElementRectFooterRecordsArea | The area occupied by the footer records.
xtpGridElementRectHeaderRecordsDividerArea | The area occupied by the header records divider.
xtpGridElementRectFooterRecordsDividerArea | The area occupied by the footer records divider.

◆ XTPGridFilterMode

enum XTPGridFilterMode

Enumeration of options for the SetRecordsTreeFilterMode method.

Call CXTPGridControl::SetRecordsTreeFilterMode to set options for the filtering tree.

Example:

m_wndGrid.SetRecordsTreeFilterMode(xtpGridFilterTreeSimple);
See also
CXTPGridControl::SetRecordsTreeFilterMode
Enumerator
xtpGridFilterTreeSimple | Specifies a simple tree grid filter mode.
xtpGridFilterTreeByParentAndChildren | Specifies a parent-children tree grid filter mode.
xtpGridFilterTreeByEndChildrenOnly | Specifies a end children only tree grid filter mode.

◆ XTPGridMouseMode

enum XTPGridMouseMode

Enumeration of operational mouse modes.

GridControl has several mouse states handled by the control. This enumeration helps to clearly identify each of these: Sends Notifications. Sends Messages.

See also
CXTPGridControl::SetMouseMode, CXTPGridControl::GetMouseMode, xtpGridMouseNothing, xtpGridMouseOverColumnDivide, xtpGridMousePrepareDragColumn, xtpGridMouseDraggingColumn
Enumerator
xtpGridMouseNothing | User is just watching to the list.
xtpGridMouseOverColumnDivide | User watching, but mouse is under column divider.
xtpGridMousePrepareDragColumn | User holds mouse button pressed on the column header.
xtpGridMouseDraggingColumn | User is dragging column header.
xtpGridMouseOverRowDivide | User watching, but mouse is under row divider.

◆ XTPGridScrollMode

enum XTPGridScrollMode

Enumeration of scroll modes.

Enumerator
xtpGridScrollModeNone | No scrolling.
xtpGridScrollModeBlockCount | Scrolls an entire row or column.
xtpGridScrollModeBlockSize | Scrolls an entire row or column.
xtpGridScrollModeSmooth | Smooth scrolling.
xtpGridScrollModeBlock | Deprecated, same as xtpGridScrollModeBlockCount.

◆ XTPGridScrollUpdateMode

enum XTPGridScrollUpdateMode

Enumeration of scroll update modes.

Enumerator
xtpGridScrollUpdateModeImmediate | Immediately updates the scroll position.
xtpGridScrollUpdateModeDeferred | Updates the scroll position deferred.

◆ XTPGridWatermarkAlignment

enum XTPGridWatermarkAlignment

Enumeration of watermark alignment flags.

Call CXTPGridControl::SetWatermarkAlignment to modify watermark alignment.

Example:

m_wndGrid.SetWatermarkAlignment(xtpWatermarkCenter | xtpWatermarkBottom);
See also
CXTPGridControl::SetWatermarkAlignment, GetWatermarkAlignment
Enumerator
xtpGridWatermarkUnknown | Unknown (empty) value.
xtpGridWatermarkLeft | Horizontal alignment: left side of Grid control client rect.
xtpGridWatermarkCenter | Horizontal alignment: center of Grid control client rect.
xtpGridWatermarkRight | Horizontal alignment: right side of Grid control client rect.
xtpGridWatermarkHmask | A mask for horizontal alignment flags.
xtpGridWatermarkTop | Vertical alignment: top side of Grid control client rect.
xtpGridWatermarkVCenter | Vertical alignment: center of Grid control client rect.
xtpGridWatermarkBottom | Vertical alignment: bottom side of Grid control client rect.
xtpGridWatermarkVmask | A mask for vertical alignment flags.
xtpGridWatermarkStretch | Stretch watermark to entire Grid control client rect.
xtpGridWatermarkEnlargeOnly | Watermark can be enlarged only, shrinking is disabled.
xtpGridWatermarkShrinkOnly | Watermark can be shrinked only, enlarging is disabled.
xtpGridWatermarkPreserveRatio | Watermark aspect ratio is preserved.


Toolkit Pro: XTPGridControlIIDs.h Source File

  • Source
  • GridControl
XTPGridControlIIDs.h
1// DO NOT MODIFY MANUALLY
2// Generated on Thu 12/11/2025 at 12:46:15.63 using cj-update-iids.cmd
3
24#ifndef __XTPGridControlIIDs_H__
25# define __XTPGridControlIIDs_H__
26
27// clang-format off
28
29#define XTP_DEFINE_GUID(name,l,w1,w2,b1,b2,b3,b4,b5,b6,b7,b8) \
30 EXTERN_C __declspec(selectany) const IID XTP##name = {l,w1,w2,{b1,b2,b3,b4,b5,b6,b7,b8}}; \
31 const unsigned long XTP##name##__Data1 = (l); \
32 const unsigned short XTP##name##__Data2 = (w1); \
33 const unsigned short XTP##name##__Data3 = (w2); \
34 const unsigned char XTP##name##__Data4_0 = (b1); \
35 const unsigned char XTP##name##__Data4_1 = (b2); \
36 const unsigned char XTP##name##__Data4_2 = (b3); \
37 const unsigned char XTP##name##__Data4_3 = (b4); \
38 const unsigned char XTP##name##__Data4_4 = (b5); \
39 const unsigned char XTP##name##__Data4_5 = (b6); \
40 const unsigned char XTP##name##__Data4_6 = (b7); \
41 const unsigned char XTP##name##__Data4_7 = (b8);
42
43XTP_DEFINE_GUID(LIBID_XtremeGridControl,0x7CAC59E5,0xB703,0x4CCF,0xB3,0x26,0x8B,0x95,0x6D,0x96,0x2F,0x27);
44XTP_DEFINE_GUID(DIID_IGridBehaviorRowModifier,0xC0DE2430,0x0DEE,0x437e,0x99,0xBC,0xAE,0x74,0x5A,0x3A,0xD9,0x2E);
45XTP_DEFINE_GUID(DIID_IGridBehaviorRowMouseButton,0xC0DE2430,0x3EBE,0x44e6,0x8E,0xA0,0x6A,0x32,0x92,0x4E,0x7D,0x97);
46XTP_DEFINE_GUID(CLSID_GridBehaviorRowMouseButton,0xC0DE2430,0xADFE,0x401c,0x90,0x1C,0xE0,0x96,0x79,0x7E,0x0E,0xD8);
47XTP_DEFINE_GUID(DIID_IGridBehaviorRowMouse,0xC0DE2430,0xCBD4,0x4fe7,0x8E,0x43,0xE0,0x08,0x82,0xA1,0x17,0xE8);
48XTP_DEFINE_GUID(CLSID_GridBehaviorRowMouse,0xC0DE2430,0x918D,0x4627,0xB6,0x18,0x0F,0xCE,0x31,0x44,0x16,0x21);
49XTP_DEFINE_GUID(DIID_IGridBehaviorRow,0xC0DE2430,0x34C9,0x42ec,0x85,0x7D,0xE6,0x4D,0x2F,0x25,0x8F,0xCE);
50XTP_DEFINE_GUID(CLSID_GridBehaviorRow,0xC0DE2430,0xC94C,0x4ed3,0x98,0x17,0x65,0x26,0xA3,0x21,0x6E,0xC7);
51XTP_DEFINE_GUID(DIID_IGridNotificationsRow,0xC0DE2430,0x34C9,0x42ec,0x85,0x7D,0xE6,0x4D,0x2F,0x25,0x8F,0xBB);
52XTP_DEFINE_GUID(CLSID_GridNotificationsRow,0xC0DE2430,0x34C9,0x42ec,0x85,0x7D,0x65,0x26,0xA3,0x21,0x6E,0xC7);
53XTP_DEFINE_GUID(DIID_IGridNotificationsSelectedRows,0xC0DE2430,0x1F9E,0x4CDA,0xA5,0x89,0xC8,0x64,0x42,0xA0,0xD0,0x46);
54XTP_DEFINE_GUID(CLSID_GridNotificationsSelectedRows,0xC0DE2430,0x2D99,0x462D,0xBC,0x67,0xE9,0x00,0x0F,0x5A,0x57,0xC7);
55XTP_DEFINE_GUID(DIID_IGridNotificationsPopulate,0xC0DE2430,0x34C9,0x42ec,0x85,0x7D,0xE6,0x4D,0x2F,0x25,0x8F,0xDD);
56XTP_DEFINE_GUID(CLSID_GridNotificationsPopulate,0xC0DE2430,0x34C9,0x42ec,0x85,0x7D,0x65,0x26,0xA3,0x21,0x6E,0xDD);
57XTP_DEFINE_GUID(DIID_IGridNotifications,0xC0DE2430,0x34C9,0x42ec,0x85,0x7D,0xE6,0x4D,0x2F,0x25,0x8F,0xAC);
58XTP_DEFINE_GUID(CLSID_GridNotifications,0xC0DE2430,0x34C9,0x42ec,0x85,0x7D,0xBA,0x78,0x26,0x70,0x20,0x88);
59XTP_DEFINE_GUID(DIID_IGridBehavior,0xC0DE2430,0x4014,0x46a1,0xBA,0xDA,0x83,0x24,0x78,0xD8,0x0C,0x8B);
60XTP_DEFINE_GUID(CLSID_GridBehavior,0xC0DE2430,0xD6D2,0x4102,0x91,0x7B,0xBA,0x78,0x26,0x70,0x20,0x88);
61XTP_DEFINE_GUID(DIID_IGridHyperlinkStyle,0xC0DE2430,0x50F7,0x4163,0x9D,0xA2,0x59,0x3C,0xB4,0x6A,0x39,0x4F);
62XTP_DEFINE_GUID(CLSID_GridHyperlinkStyle,0xC0DE2430,0x375C,0x4144,0x9A,0xE6,0x48,0xD1,0x58,0xEF,0x0B,0x11);
63XTP_DEFINE_GUID(DIID_IGridRecords,0xC0DE2430,0x3549,0x4AAD,0x94,0x90,0xEB,0x0E,0x5A,0x4C,0xA0,0xF8);
64XTP_DEFINE_GUID(DIID_IGridRecord,0xC0DE2430,0xE975,0x4E69,0xBB,0x3B,0x71,0x7C,0xB0,0xF3,0xE5,0xD5);
65XTP_DEFINE_GUID(DIID_IGridRows,0xC0DE2430,0x5511,0x4EBD,0xA0,0x3A,0x94,0x5B,0xB2,0x30,0x77,0x77);
66XTP_DEFINE_GUID(DIID_IGridColumn,0xC0DE2430,0xB4A5,0x492f,0xAD,0xA0,0x56,0xE1,0xB0,0x77,0x2A,0x53);
67XTP_DEFINE_GUID(DIID_IGridRecordItem,0xC0DE2430,0xE015,0x4f87,0x88,0x5D,0xDE,0x33,0x26,0xA6,0x3B,0xEA);
68XTP_DEFINE_GUID(DIID__DFieldChooser,0xC0DE2430,0x39A7,0x4D1E,0x86,0x8A,0x58,0x9E,0x7E,0xBF,0x15,0x8C);
69XTP_DEFINE_GUID(DIID_IGridRecordItemMetrics,0xC0DE2430,0xA90D,0x4CE9,0xBF,0x0C,0xF7,0x3D,0xDF,0xFE,0x65,0x09);
70XTP_DEFINE_GUID(CLSID_GridRecordItemMetrics,0xC0DE2430,0x2B57,0x495F,0xA1,0x0E,0x9B,0x0E,0xD8,0xCB,0xD6,0xB4);
71XTP_DEFINE_GUID(DIID_IGridRow,0xC0DE2430,0x27CF,0x4F7E,0xAF,0xA3,0x43,0xF6,0x71,0x14,0xD3,0xA5);
72XTP_DEFINE_GUID(DIID_IGridGroupRow,0xC0DE2430,0xF4CE,0x42CF,0x9D,0xAB,0xEA,0x5E,0xBC,0x76,0x88,0x0D);
73XTP_DEFINE_GUID(CLSID_GridGroupRow,0xC0DE2430,0x6516,0x4E94,0x8E,0x97,0x51,0x3D,0xE5,0x55,0x0B,0x77);
74XTP_DEFINE_GUID(DIID_IGridSection,0xC0DE2430,0x7DFC,0x4ab3,0x88,0xCD,0xF5,0x92,0x30,0x4C,0xF6,0x59);
75XTP_DEFINE_GUID(CLSID_GridSection,0xC0DE2430,0x967F,0x43ed,0x98,0x63,0xF5,0x66,0x70,0xD7,0x32,0x81);
76XTP_DEFINE_GUID(DIID_IGridSections,0xC0DE2430,0x422B,0x44ee,0xA8,0x9C,0x9A,0x76,0x78,0x77,0xF7,0x94);
77XTP_DEFINE_GUID(CLSID_GridSections,0xC0DE2430,0xE028,0x4d25,0xA6,0x9D,0x31,0x84,0x9D,0x3C,0x0E,0x90);
78XTP_DEFINE_GUID(CLSID_GridRow,0xC0DE2430,0xF10D,0x4B50,0xBE,0xEF,0x12,0xBA,0x83,0x2C,0x35,0xDB);
79XTP_DEFINE_GUID(DIID_IGridColumnOrder,0xC0DE2430,0xB183,0x4574,0x97,0xCE,0x6E,0xE5,0xB6,0xF1,0xDD,0xF8);
80XTP_DEFINE_GUID(CLSID_GridColumnOrder,0xC0DE2430,0xDA0B,0x45E4,0x9F,0x20,0xCA,0x29,0xC6,0x26,0xA1,0xC8);
81XTP_DEFINE_GUID(DIID_IGridSelectedRows,0xC0DE2430,0x27BF,0x4cb1,0x9A,0xBF,0x17,0x88,0xD9,0x83,0x51,0x13);
82XTP_DEFINE_GUID(CLSID_GridSelectedRows,0xC0DE2430,0x0FE1,0x456E,0xB7,0xC9,0x39,0x5F,0x81,0x44,0x63,0xE0);
83XTP_DEFINE_GUID(CLSID_GridRows,0xC0DE2430,0x584C,0x40CC,0x83,0x27,0x3B,0xAF,0x69,0x07,0xA5,0x67);
84XTP_DEFINE_GUID(DIID_IGridPaintManager,0xC0DE2430,0xE765,0x4788,0x9E,0x62,0x0B,0xFE,0x77,0x28,0xB5,0x5B);
85XTP_DEFINE_GUID(CLSID_GridPaintManager,0xC0DE2430,0x6D68,0x4666,0xBD,0x23,0x12,0x78,0xB6,0x04,0x62,0xFC);
86XTP_DEFINE_GUID(DIID_IGridRecordItemConstraint,0xC0DE2430,0x3449,0x461F,0xAF,0x43,0xD5,0xDD,0xA1,0xBC,0xAA,0x96);
87XTP_DEFINE_GUID(CLSID_GridRecordItemConstraint,0xC0DE2430,0xC4FC,0x4A29,0x9F,0x3F,0xA6,0xA4,0x98,0xA7,0x6A,0xE6);
88XTP_DEFINE_GUID(DIID_IGridRecordItemConstraints,0xC0DE2430,0xF19C,0x4651,0x93,0xB4,0xBD,0xFE,0x02,0xB0,0xE1,0x5C);
89XTP_DEFINE_GUID(CLSID_GridRecordItemConstraints,0xC0DE2430,0x0D27,0x4FC2,0xB4,0xFD,0x4E,0x81,0xF7,0x89,0x1F,0xE0);
90XTP_DEFINE_GUID(DIID_IGridInplaceButton,0xC0DE2430,0x08EF,0x489E,0x89,0xAB,0x5C,0xEB,0xA4,0x37,0x65,0xE3);
91XTP_DEFINE_GUID(CLSID_GridInplaceButton,0xC0DE2430,0x3555,0x4d3a,0x88,0xF9,0x8D,0x88,0x22,0x20,0x91,0x46);
92XTP_DEFINE_GUID(DIID_IGridRecordItemEditOptions,0xC0DE2430,0x78A4,0x42D6,0xAE,0x6A,0x36,0x2F,0x90,0xDA,0x6A,0x70);
93XTP_DEFINE_GUID(CLSID_GridRecordItemEditOptions,0xC0DE2430,0xCBD1,0x4A93,0xB5,0xC4,0xA5,0xE8,0x4E,0x5E,0x01,0x6E);
94XTP_DEFINE_GUID(DIID_IGridHyperlink,0xC0DE2430,0x51EA,0x4c67,0xAB,0x9B,0xE6,0xB1,0xA4,0x46,0x95,0x3D);
95XTP_DEFINE_GUID(CLSID_GridHyperlink,0xC0DE2430,0xD005,0x4f90,0x85,0x30,0xAB,0x27,0x6A,0xFD,0x84,0x00);
96XTP_DEFINE_GUID(DIID_IGridHyperlinks,0xC0DE2430,0x0C85,0x41dd,0x8A,0x5B,0xDD,0xF4,0x86,0xAF,0x03,0xF8);
97XTP_DEFINE_GUID(CLSID_GridHyperlinks,0xC0DE2430,0x72F2,0x40df,0x93,0x3E,0x18,0x1E,0x73,0x09,0xCE,0x31);
98XTP_DEFINE_GUID(DIID_IGridItemControl,0xC0DE2430,0x31B6,0x47e4,0xA0,0xEA,0xAC,0x89,0x52,0x58,0x85,0x73);
99XTP_DEFINE_GUID(CLSID_GridItemControl,0xC0DE2430,0xBFC4,0x4b2c,0xA0,0xFF,0xF7,0x87,0x09,0x7A,0x47,0xF3);
100XTP_DEFINE_GUID(DIID_IGridItemButton,0xC0DE2430,0x193B,0x41ce,0x82,0x6B,0xB5,0xA3,0x9E,0xEE,0x90,0xD5);
101XTP_DEFINE_GUID(CLSID_GridItemButton,0xC0DE2430,0xF172,0x46a4,0xA3,0xAB,0x70,0xE7,0xE4,0x7A,0x61,0x99);
102XTP_DEFINE_GUID(DIID_IGridItemControls,0xC0DE2430,0x0A2A,0x42d7,0x99,0x82,0xBF,0x52,0x4C,0x62,0xC4,0x13);
103XTP_DEFINE_GUID(CLSID_GridItemControls,0xC0DE2430,0x9D7B,0x49d7,0xA9,0x12,0xC9,0x9F,0xCD,0x6D,0x5A,0x89);
104XTP_DEFINE_GUID(CLSID_GridRecordItem,0xC0DE2430,0x9C10,0x47C9,0xB3,0x80,0xA9,0x9A,0x4B,0x44,0x40,0x6C);
105XTP_DEFINE_GUID(CLSID_GridRecord,0xC0DE2430,0x17A6,0x427A,0x97,0x2A,0x53,0xBA,0xE2,0xD9,0x68,0xC7);
106XTP_DEFINE_GUID(CLSID_GridRecords,0xC0DE2430,0x7382,0x4FF5,0x82,0x3A,0x3E,0x7A,0xB1,0xBB,0x43,0x21);
107XTP_DEFINE_GUID(CLSID_GridColumn,0xC0DE2430,0x1C8E,0x4DF7,0xB3,0x26,0x4C,0x67,0x84,0xE8,0xD6,0x14);
108XTP_DEFINE_GUID(DIID_IGridColumns,0xC0DE2430,0x3BC3,0x43C8,0x89,0xD2,0xC0,0x2F,0xAF,0xA0,0x7D,0xA5);
109XTP_DEFINE_GUID(CLSID_GridColumns,0xC0DE2430,0x5CD3,0x484B,0xA0,0xB7,0x3B,0x68,0xFA,0x8A,0xBC,0x42);
110XTP_DEFINE_GUID(DIID_IGridNavigator,0xC0DE2430,0xE540,0x4f68,0x8B,0x20,0xDD,0xC0,0xE2,0xFE,0x8F,0xA4);
111XTP_DEFINE_GUID(CLSID_GridNavigator,0xC0DE2430,0x23D6,0x4ad6,0x9B,0xF6,0x8F,0x8A,0xD6,0x8E,0x41,0x90);
112XTP_DEFINE_GUID(DIID_TrackBlock,0xC0DE2430,0xF905,0x40B7,0xBD,0x9D,0xB4,0x3B,0x26,0x8A,0x80,0xEA);
113XTP_DEFINE_GUID(DIID_IGridHitTestInfo,0xC0DE2430,0xFCDB,0x450A,0xBB,0x97,0x49,0x4D,0x7A,0x4F,0x62,0xDF);
114XTP_DEFINE_GUID(CLSID_GridHitTestInfo,0xC0DE2430,0xD030,0x4CDC,0x86,0x1E,0xA2,0xDE,0x4F,0xC0,0xC2,0x3D);
115XTP_DEFINE_GUID(DIID_IGridToolTipInfo,0xC0DE2430,0xD5B7,0x44C8,0xB5,0xBC,0x98,0x4C,0xD3,0x16,0x9A,0xDF);
116XTP_DEFINE_GUID(CLSID_GridToolTipInfo,0xC0DE2430,0x6D65,0x4070,0xA9,0x1E,0x93,0xD8,0x61,0x8B,0xE8,0x53);
117XTP_DEFINE_GUID(DIID_GridPrintOptions,0xC0DE2430,0xCAFC,0x4285,0xAF,0x96,0xDC,0xAF,0x75,0x75,0x9C,0x25);
118XTP_DEFINE_GUID(DIID_IGridDataManager,0xC0DE2430,0x27ED,0x44d7,0x97,0x0B,0x9F,0x52,0x6E,0x97,0x7C,0x3C);
119XTP_DEFINE_GUID(CLSID_GridDataManager,0xC0DE2430,0x2C06,0x4929,0xA9,0xED,0xF3,0x11,0x6D,0x5B,0xC3,0xAE);
120XTP_DEFINE_GUID(DIID__DGridControl,0xC0DE2430,0x123F,0x4C52,0xA0,0xD5,0xA9,0xBD,0x3A,0x26,0xBE,0xDA);
121XTP_DEFINE_GUID(DIID__DGridControlEvents,0xC0DE2430,0xF631,0x4608,0xA4,0xE7,0xEF,0x00,0xA9,0x64,0x8B,0x53);
122XTP_DEFINE_GUID(CLSID_GridControl,0xC0DE2430,0xE1B5,0x41B0,0xB1,0x9B,0x81,0xAA,0x67,0x6D,0xB5,0xD4);
123XTP_DEFINE_GUID(DIID_TrackUndoManager,0xC0DE2430,0xCB68,0x4C40,0xBC,0x9A,0x1C,0xB8,0x8E,0xCD,0x15,0x19);
124XTP_DEFINE_GUID(DIID_TrackMarker,0xC0DE2430,0xBD61,0x4928,0x97,0x00,0x17,0xE2,0x3B,0x90,0xD2,0x3D);
125XTP_DEFINE_GUID(DIID_TrackMarkers,0xC0DE2430,0xDB44,0x4DC3,0x86,0x19,0xCF,0x3E,0xE6,0xFB,0x14,0x00);
126XTP_DEFINE_GUID(DIID_TrackControlItem,0xC0DE2430,0x7B6D,0x4AFA,0x9F,0xC5,0x26,0x93,0xA5,0x06,0x9E,0xD9);
127XTP_DEFINE_GUID(DIID_SelectedTrackBlocks,0xC0DE2430,0x8CB4,0x4E3C,0x93,0x62,0x50,0x69,0x4E,0xB6,0x35,0x1E);
128XTP_DEFINE_GUID(DIID_ITrackPaintManager,0xC0DE2430,0xE015,0x4f87,0x88,0x5D,0xDE,0x33,0x26,0xA6,0x3B,0xDE);
129XTP_DEFINE_GUID(DIID__DTrackControl,0xC0DE2430,0x08C5,0x4E99,0xBD,0x14,0xCF,0xB7,0x69,0xCD,0xDF,0x09);
130XTP_DEFINE_GUID(DIID__DTrackControlEvents,0xC0DE2430,0xB010,0x4B1F,0x97,0x13,0xB4,0x26,0xEE,0xDD,0x55,0xE0);
131XTP_DEFINE_GUID(CLSID_TrackControl,0xC0DE2430,0x51C1,0x4139,0x99,0x4D,0xC1,0x6D,0xFB,0x8F,0x7D,0x9E);
132XTP_DEFINE_GUID(CLSID_TrackPaintManager,0xC0DE2430,0x3096,0x4792,0xB1,0x80,0xD4,0x04,0xD5,0x5E,0x86,0x98);
133XTP_DEFINE_GUID(DIID__DFieldChooserEvents,0xC0DE2430,0x2BD3,0x4361,0x8F,0x99,0xF1,0x05,0xC2,0x89,0xE0,0x3A);
134XTP_DEFINE_GUID(CLSID_FieldChooser,0xC0DE2430,0x4B8C,0x4830,0xB7,0x7F,0x4C,0xDF,0xCF,0x11,0xA5,0xF4);
135XTP_DEFINE_GUID(DIID_IGridControlGlobalSettings,0xC0DE2430,0x09F5,0x4E50,0xA6,0xE4,0xA8,0xB5,0xA1,0x93,0xC8,0xD1);
136XTP_DEFINE_GUID(CLSID_GridControlGlobalSettings,0xC0DE2430,0x9015,0x4D9A,0x9F,0xE2,0xD6,0x92,0x1A,0xAC,0xF4,0x12);
137
138#undef XTP_DEFINE_GUID
139
140// clang-format on
141
142#endif // __XTPGridControlIIDs_H__


Toolkit Pro: XTPGridDataManager.h File Reference

  • Source
  • GridControl
Classes
XTPGridDataManager.h File Reference

Go to the source code of this file.

Classes

struct | XTP_GRIDDATAMANAGER_COM_ERROR
Basic set of parameters transferred to item handlers. More...
class | CXTPGridDataManager
Represents a grid data manager. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPGridDefines.h File Reference

  • Source
  • GridControl
Macros | Typedefs | Enumerations | Variables
XTPGridDefines.h File Reference

Go to the source code of this file.

Macros

#define | XTP_NM_GRID_HEADER_RCLICK (NM_FIRST - 51)
Defines the message for the column right clicked event.
#define | XTP_NM_GRID_SELCHANGED (NM_FIRST - 52)
Defines the message for the row selection changed event.
#define | XTP_NM_GRID_CHECKED (NM_FIRST - 53)
Defines the message for the item checked event.
#define | XTP_NM_GRID_HYPERLINK (NM_FIRST - 54)
Defines the message for the hyperlink clicked event.
#define | XTP_NM_GRID_COLUMNORDERCHANGED (NM_FIRST - 55)
Defines the message for the column order changed event.
#define | XTP_NM_GRID_SORTORDERCHANGED (NM_FIRST - 56)
#define | XTP_NM_GRID_PRESORTORDERCHANGED (NM_FIRST - 67)
Defines the message when a column header has been clicked and the sort order has changed, but CXTPGridControl::Populate has NOT yet been called.
#define | XTP_NM_GRID_VALUECHANGED (NM_FIRST - 57)
Defines the message for the value changed event.
#define | XTP_NM_GRID_INPLACEBUTTONDOWN (NM_FIRST - 58)
Defines the message for the in-place button clicked event.
#define | XTP_NM_GRID_ROWEXPANDED (NM_FIRST - 59)
Defines the message for the row expand changed event.
#define | XTP_NM_GRID_LBUTTONDOWN (NM_FIRST - 60)
Defines the message for the left mouse button clicked event.
#define | XTP_NM_GRID_GETITEMMETRICS (NM_FIRST - 61)
Defines the message for handling the CXTPGridControl::GetItemMetrics() method.
#define | XTP_NM_GRID_REQUESTEDIT (NM_FIRST - 62)
Defines the message for handling the CXTPGridControl::OnRequestEdit() method.
#define | XTP_NM_GRID_BEFORE_COPY_TOTEXT (NM_FIRST - 63)
Defines the message for handling the CXTPGridControl::OnBeforeCopyToText() method.
#define | XTP_NM_GRID_BEFORE_PASTE_FROMTEXT (NM_FIRST - 64)
Defines the message for handling the CXTPGridControl::OnBeforePasteFromText() method.
#define | XTP_NM_GRID_BEFORE_PASTE (NM_FIRST - 65)
Defines the message for handling the CXTPGridControl::OnBeforePaste() method.
#define | XTP_NM_GRID_COLUMNWIDTHCHANGED (NM_FIRST - 68)
Defines the message for handling the CXTPGridHeader::AdjustColumnsWidth() method.
#define | XTP_NM_GRID_PREVIEWKEYDOWN (NM_FIRST - 69)
Defines the message for handling the CXTPGridControl::OnPreviewKeyDown() method.
#define | XTP_NM_GRID_BEGINDRAG (NM_FIRST - 70)
Indicates that the user started dragging records.
#define | XTP_NM_GRID_DROP (NM_FIRST - 71)
Indicates that the user dropped records to the Grid control.
#define | XTP_NM_GRID_EDIT_CANCELED (NM_FIRST - 72)
Defines the message for the in-place editing has been canceled and the value has not been changed event.
#define | XTP_NM_GRID_CONSTRAINT_SELECTING (NM_FIRST - 73)
Indicates that the user changed a selected item in a combobox.
#define | XTP_NM_GRID_GETTOOLTIPINFO (NM_FIRST - 74)
Indicates that a tooltip will be drawn.
#define | XTP_NM_GRID_RECORDS_DROPPED (NM_FIRST - 75)
Indicates that records were dropped to the Grid control.
#define | XTP_NM_GRID_FOCUS_CHANGING (NM_FIRST - 76)
Defines the message for handling the focus changing event.
#define | XTP_NM_GRID_DRAGDROP_COMPLETED (NM_FIRST - 77)
Indicates that the user completed a drag-and-drop operation.
#define | XTP_NM_GRID_BEGINEDIT (NM_FIRST - 78)
Defines the message for starting in-place editing.
#define | XTP_NM_GRID_SELCHANGING (NM_FIRST - 80)
Defines the message for changing the selected rows collection.
#define | XTP_NM_GRID_DRAGOVER (NM_FIRST - 81)
Indicates that the user is dragging records over a control.
#define | XTP_NM_GRID_GROUPORDERCHANGED (NM_FIRST - 82)
Defines the message for the column group order changed event.
#define | XTP_NM_GRID_ITEMBUTTONCLICK (NM_FIRST - 83)
Defines the message for the item button click event.
#define | XTP_NM_GRID_PLUSMINUSCLICK (NM_FIRST - 84)
Defines the message for the header column click on PlusMinus icon event.
#define | XTP_NM_GRID_STATECHANGED (NM_FIRST - 88)
This message is sent by the Grid control when the state of an item or range of items has changed.
#define | XTP_NM_GRID_HSCROLL (NM_FIRST - 90)
The XTP_NM_GRID_HSCROLL message is sent when the horizontal scrolling position has changed.
#define | XTP_NM_GRID_VSCROLL (NM_FIRST - 91)
The XTP_NM_GRID_VSCROLL message is sent when the vertical scrolling position has changed.
#define | XTP_NM_GRID_MOUSEMOVE (NM_FIRST - 92)
The XTP_NM_GRID_MOUSEMOVE message is sent when the mouse is moved over the control.
#define | XTP_NM_GRID_ROWHEIGHTCHANGED (NM_FIRST - 94)
The XTP_NM_GRID_ROWHEIGHTCHANGED notification message is sent when the height of a row has changed.
#define | XTP_GRID_DEPRECATED()
Enables deprecated Grid control methods.

Typedefs

typedef int(AFX_CDECL * XTPGridRowsCompareFunc) (const CXTPGridRow **pRow1, const CXTPGridRow **pRow2)
Defines a function pointer for comparing events.

Enumerations

enum | XTPGridShellIcon { xtpGridShellIconLock = 47 }
This enum defines the shell icons. More...
enum XTPGridGlyph {
xtpGridGlyphInvalid = -1 , xtpGridGlyphRowCollapse = 0 , xtpGridGlyphRowExpand = 1 , xtpGridGlyphEnabledUnchecked = 2 ,
xtpGridGlyphEnabledChecked = 3 , xtpGridGlyphDisabledUnchecked = 4 , xtpGridGlyphDisabledChecked = 5 , xtpGridGlyphColumnExpand = 6 ,
xtpGridGlyphColumnRestore = 7 , xtpGridGlyphEnabledTristate = 8 , xtpGridGlyphItemLocked = 9 , xtpGridGlyphItemUnlocked = 10 ,
xtpGridGlyphCount
}
This enum defines the index of the glyphs. More...
enum XTPGridCheckState {
xtpGridCheckStateInvalid = -1 , xtpGridCheckStateUnchecked = 0 , xtpGridCheckStateChecked = 1 , xtpGridCheckStateIndeterminate = 2 ,
xtpGridCheckStateCount = 3
}
This enum defines the possible checkbox states. More...
enum | XTPGridRowType { xtpRowTypeInvalid = -1 , xtpRowTypeBody = 0 , xtpRowTypeHeader = 1 , xtpRowTypeFooter = 2 }
This enum defines body, header, and footer rows. More...
enum | XTPGridOrientation { xtpGridOrientationHorizontal = 0 , xtpGridOrientationVertical = 1 , xtpGridOrientationAll = 2 }
Enumeration of orientations. More...
enum XTPGridLineStyle {
xtpGridLineStyleNone = 0 , xtpGridLineStyleDotSmall = 1 , xtpGridLineStyleDotLarge = 2 , xtpGridLineStyleDash = 3 ,
xtpGridLineStyleSolid = 4 , xtpGridLineStyleCount = 5 , xtpGridGridNoLines = xtpGridLineStyleNone , xtpGridGridSmallDots = xtpGridLineStyleDotSmall ,
xtpGridGridLargeDots = xtpGridLineStyleDotLarge , xtpGridGridDashes = xtpGridLineStyleDash , xtpGridGridSolid = xtpGridLineStyleSolid
}
Represents predefined grid line styles. More...
enum XTPGridFreezeColsDividerStyle {
xtpGridFreezeColsDividerThin = 0x01 , xtpGridFreezeColsDividerBold = 0x02 , xtpGridFreezeColsDividerHeader = 0x04 , xtpGridFreezeColsDividerShade = 0x08 ,
xtpGridFreezeColsDividerShowAlways = 0x10
}
Represents predefined freeze column line styles. More...
enum XTPGridColumnStyle {
xtpGridColumnShaded , xtpGridColumnFlat , xtpGridColumnExplorer , xtpGridColumnOffice2003 ,
xtpGridColumnResource
}
Represents predefined column styles. More...
enum | XTPGridTreeStructureStyle { xtpGridTreeStructureNone , xtpGridTreeStructureSolid , xtpGridTreeStructureDots }
Represent the style of lines used to draw a hierarchical tree structure. More...
enum XTPGridSectionDividerStyle {
xtpGridSectionDividerStyleNone = 0x00 , xtpGridSectionDividerStyleThin = 0x01 , xtpGridSectionDividerStyleBold = 0x02 , xtpGridSectionDividerStyleShade = 0x04 ,
xtpGridSectionDividerStyleOutlook = 0x08
}
Represent the header/footer rows divider style. More...
enum | XTPGridSectionDividerPosition { xtpGridSectionDividerPositionTop = 0 , xtpGridSectionDividerPositionBottom = 1 }
Section divider position. More...
enum | XTPGridDrawSortTriangleStyle { xtpGridDrawSortTriangleDefault = 0 , xtpGridDrawSortTriangleAlways = 1 , xtpGridDrawSortTriangleNever = 2 }
Represent the Grid Draw Sort Triangle logic. More...
enum | XTPGridTextDecoration { xtpGridTextDecorationNone = 0 , xtpGridTextDecorationUnderline = 1 }
Enumeration of hyperlink text decorations. More...
enum XTPGridPaintTheme {
xtpGridThemeDefault , xtpGridThemeOfficeXP , xtpGridThemeOffice2003 , xtpGridThemeOffice2003Luna ,
xtpGridThemeOffice2013 , xtpGridThemeOffice2016 = xtpGridThemeOffice2013 , xtpGridThemeVisualStudio2012Light , xtpGridThemeVisualStudio2012Dark ,
xtpGridThemeVisualStudio2012Blue , xtpGridThemeVisualStudio2015 , xtpGridThemeExplorer , xtpGridThemeResource ,
xtpGridThemeNativeWindows10 , xtpGridThemeVisualStudio2017 , xtpGridThemeVisualStudio2019 , xtpGridThemeVisualStudio2022 ,
xtpGridThemeNativeWindows11
}
Visual theme enumeration. More...

Variables

const TCHAR | XTPGRIDCTRL_CLASSNAME [] = _T("XTPGrid")
A NULL-terminated string used by CXTPGridControl which specifies the window class name for the Grid control.
static const LPCTSTR | XTPGRIDCTRL_CF_RECORDS = _T("XTPGrid_CF_Records")
Grid control records clipboard format name.
const COLORREF | XTP_GRID_COLOR_DEFAULT = (COLORREF)-1
This constant indicates that a COLORREF is not defined.
const int | XTP_GRID_NOICON = (int)-1
This constant indicates that an icon ID is not defined.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Macro Definition Documentation

◆ XTP_NM_GRID_BEFORE_COPY_TOTEXT

#define XTP_NM_GRID_BEFORE_COPY_TOTEXT (NM_FIRST - 63)

Defines the message for handling the CXTPGridControl::OnBeforeCopyToText() method.

Parameters
id | Resource ID for the control.
memberFxn | Name of member function to handle the message.

The XTP_NM_GRID_BEFORE_COPY_TOTEXT notification message is sent to allow the owner window to customize copy/paste operations.

Example: Here is an example of how an application would handle this message.

BEGIN_MESSAGE_MAP(CGridSampleView, CXTPGridView)
ON_NOTIFY(XTP_NM_GRID_BEFORE_COPY_TOTEXT, XTP_ID_GRID_CONTROL, OnBeforeCopyToText)
END_MESSAGE_MAP()

void CGridSampleView::OnBeforeCopyToText(NMHDR*  pNotifyStruct, LRESULT* result)
{
        _ASSERTE(pNotifyStruct);

        XTP_NM_GRID_BEFORE_COPYPASTE* pnmCopyPaste = (XTP_NM_GRID_BEFORE_COPYPASTE*)pNotifyStruct;

        if (!pnmCopyPaste || !pnmCopyPaste->ppRecord || !*pnmCopyPaste->ppRecord ||
            !pnmCopyPaste->parStrings)
                {
                    _ASSERTE(FALSE);
                    return;
                }

        // customize data provided by pnmCopyPaste->parStrings
        // you can use source record object: (*pnmCopyPaste->ppRecord)->Member()

        // set result to not zero to cancel operation:
        // *result = (LRESULT)TRUE;
}
See also
CXTPGridControl, CXTPGridControl::OnBeforeCopyToText()

◆ XTP_NM_GRID_BEFORE_PASTE

#define XTP_NM_GRID_BEFORE_PASTE (NM_FIRST - 65)

Defines the message for handling the CXTPGridControl::OnBeforePaste() method.

Parameters
id | Resource ID for the control.
memberFxn | Name of member function to handle the message.

The XTP_NM_GRID_BEFORE_PASTE notification message is sent to allow the owner window to customize copy/paste operations.

Example: Here is an example of how an application would handle this message.

BEGIN_MESSAGE_MAP(CGridSampleView, CXTPGridView)
ON_NOTIFY(XTP_NM_GRID_BEFORE_PASTE, XTP_ID_GRID_CONTROL, OnBeforePaste)
END_MESSAGE_MAP()

void CGridSampleView::OnBeforePaste(NMHDR*  pNotifyStruct, LRESULT* result)
{
   _ASSERTE(pNotifyStruct);

   XTP_NM_GRID_BEFORE_COPYPASTE* pnmCopyPaste = (XTP_NM_GRID_BEFORE_COPYPASTE*)pNotifyStruct;
   _ASSERTE(pnmCopyPaste && pnmCopyPaste->parStrings == NULL);

   if (!pnmCopyPaste || !pnmCopyPaste->ppRecord || !*pnmCopyPaste->ppRecord) {
      _ASSERTE(FALSE);
      return;
   }

   // you can create new or change provided record using pnmCopyPaste->ppRecord

   // set result to not zero to cancel operation:
   // *result = (LRESULT)TRUE;
}
See also
CXTPGridControl, CXTPGridControl::OnBeforePaste()

◆ XTP_NM_GRID_BEFORE_PASTE_FROMTEXT

#define XTP_NM_GRID_BEFORE_PASTE_FROMTEXT (NM_FIRST - 64)

Defines the message for handling the CXTPGridControl::OnBeforePasteFromText() method.

Parameters
id | Resource ID for the control.
memberFxn | Name of member function to handle the message.

The XTP_NM_GRID_BEFORE_PASTE_FROMTEXT notification message is sent to allow the owner window to customize copy/paste operations.

Example: Here is an example of how an application would handle this message.

BEGIN_MESSAGE_MAP(CGridSampleView, CXTPGridView)
ON_NOTIFY(XTP_NM_GRID_BEFORE_PASTE_FROMTEXT, XTP_ID_GRID_CONTROL,
OnGridBeforePasteFromText)
END_MESSAGE_MAP()

void CGridSampleView::OnGridBeforePasteFromText(NMHDR*  pNotifyStruct, LRESULT* result)
{
    _ASSERTE(pNotifyStruct);

    XTP_NM_GRID_BEFORE_COPYPASTE* pnmCopyPaste =
    (XTP_NM_GRID_BEFORE_COPYPASTE*)pNotifyStruct;

    if (!pnmCopyPaste || !pnmCopyPaste->ppRecord || !pnmCopyPaste->parStrings) {
        _ASSERTE(FALSE);
        return;
        }

    CMessageRecord* pRecord = new CMessageRecord();
    if (!pRecord) {
        return;
            }

        *pnmCopyPaste->ppRecord = pRecord;

        CXTPGridColumns* pColumns = GetGridCtrl().GetColumns();
        _ASSERTE(pColumns);
        if (!pColumns) {
            return;
        }

        int nDataCount = pnmCopyPaste->parStrings->GetSize();

        const int nColumnCount = pColumns->GetVisibleColumnsCount();
        for (int nCol = 0; nCol < nColumnCount; nCol++)
        {
            CXTPGridColumn* pColumn = pColumns->GetVisibleAt(nCol);
            CXTPGridRecordItem* pItem = pRecord->GetItem(pColumn);
            _ASSERTE(pItem);
            if (NULL == pItem)
                continue;

            if (nCol < nDataCount)
                {
                CString strItem = pnmCopyPaste->parStrings->GetAt(nCol);
                pItem->SetCaption(strItem);
                }
        }
        // set result to not zero to cancel operation:
        // *result = (LRESULT)TRUE;
}
See also
CXTPGridControl, CXTPGridControl::OnBeforePasteFromText()

◆ XTP_NM_GRID_BEGINDRAG

#define XTP_NM_GRID_BEGINDRAG (NM_FIRST - 70)

Indicates that the user started dragging records.

Parameters
id | Resource ID for the control.
memberFxn | Name of member function to handle the message.

An XTP_NM_GRIDDRAGDROP structure is passed with this message.

See also
XTP_NM_GRIDDRAGDROP, XTP_NM_GRID_BEGINDRAG, XTP_NM_GRID_DROP, XTP_NM_GRID_RECORDS_DROPPED, XTP_NM_GRID_DRAGDROP_COMPLETED

◆ XTP_NM_GRID_BEGINEDIT

#define XTP_NM_GRID_BEGINEDIT (NM_FIRST - 78)

Defines the message for starting in-place editing.

Sent after XTP_NM_GRID_REQUESTEDIT and when the in-place editor has been created.

Parameters
id | Resource ID for the control.
memberFxn | Name of member function to handle the message.

An XTP_NM_GRIDRECORDITEM structure is passed with this message.

See also
XTP_NM_GRIDRECORDITEM, XTP_NM_GRID_VALUECHANGED, XTP_NM_GRID_REQUESTEDIT, CXTPGridRecordItem::OnEditCanceled

◆ XTP_NM_GRID_CHECKED

#define XTP_NM_GRID_CHECKED (NM_FIRST - 53)

Defines the message for the item checked event.

Parameters
id | Resource ID for the control.
memberFxn | Name of member function to handle the message.

The XTP_NM_GRID_CHECKED notification message is sent to inform the owner window that the user clicked the check box of an item of the Grid control. The owner window of the Grid control receives this notification through the WM_COMMAND message.

Example: Here is an example of how an application would handle this message.

BEGIN_MESSAGE_MAP(CGridSampleView, CXTPGridView)
ON_NOTIFY(XTP_NM_GRID_CHECKED, XTP_ID_GRID_CONTROL, OnGridCheckItem)
END_MESSAGE_MAP()

void CGridSampleView::OnGridCheckItem(NMHDR*  pNotifyStruct, LRESULT* result)
{
   XTP_NM_GRIDRECORDITEM* pItemNotify = (XTP_NM_GRIDRECORDITEM*) pNotifyStruct;
   _ASSERTE(pItemNotify != NULL);

   // Handle command.
}
See also
XTP_NM_GRID_COLUMNORDERCHANGED, XTP_NM_GRID_HEADER_RCLICK, XTP_NM_GRID_HYPERLINK, XTP_NM_GRID_INPLACEBUTTONDOWN, XTP_NM_GRID_SELCHANGED, XTP_NM_GRID_SORTORDERCHANGED, XTP_NM_GRID_VALUECHANGED, CXTPGridControl, CXTPGridHeader

◆ XTP_NM_GRID_COLUMNORDERCHANGED

#define XTP_NM_GRID_COLUMNORDERCHANGED (NM_FIRST - 55)

Defines the message for the column order changed event.

Parameters
id | Resource ID for the control.
memberFxn | Name of member function to handle the message.

The XTP_NM_GRID_COLUMNORDERCHANGED notification message is sent to inform the owner window that the user changed the order of columns of the Grid control. The owner window of the Grid control receives this notification through the WM_COMMAND message.

Example: Here is an example of how an application would handle this message.

BEGIN_MESSAGE_MAP(CGridSampleView, CXTPGridView)
ON_NOTIFY(XTP_NM_GRID_COLUMNORDERCHANGED, XTP_ID_GRID_CONTROL,
OnGridColumnOrderChanged)
END_MESSAGE_MAP()

void CGridSampleView::OnGridColumnOrderChanged(NMHDR*  pNotifyStruct, LRESULT* result)
{
        XTP_NM_GRIDCOLUMNORDERCHANGED* pItemNotify = (XTP_NM_GRIDCOLUMNORDERCHANGED*)
        pNotifyStruct; _ASSERTE(pItemNotify != NULL);

        // Handle command.
    }
See also
XTP_NM_GRID_CHECKED, XTP_NM_GRID_HEADER_RCLICK, XTP_NM_GRID_HYPERLINK, XTP_NM_GRID_INPLACEBUTTONDOWN, XTP_NM_GRID_SELCHANGED, XTP_NM_GRID_GROUPORDERCHANGED, XTP_NM_GRID_SORTORDERCHANGED, XTP_NM_GRID_VALUECHANGED, CXTPGridControl, CXTPGridHeader

◆ XTP_NM_GRID_COLUMNWIDTHCHANGED

#define XTP_NM_GRID_COLUMNWIDTHCHANGED (NM_FIRST - 68)

Defines the message for handling the CXTPGridHeader::AdjustColumnsWidth() method.

Parameters
id | Resource ID for the control.
memberFxn | Name of member function to handle the message.

The XTP_NM_GRID_COLUMNWIDTHCHANGED notification message is sent when the width of a column is changed. This can happen when the user changes the width or when the Grid control automatically changes the width.

See also
CXTPGridHeader, CXTPGridHeader::AdjustColumnsWidth

◆ XTP_NM_GRID_CONSTRAINT_SELECTING

#define XTP_NM_GRID_CONSTRAINT_SELECTING (NM_FIRST - 73)

Indicates that the user changed a selected item in a combobox.

Parameters
id | Resource ID for the control.
memberFxn | Name of member function to handle the message.
See also
CXTPGridControl::OnConstraintSelecting()

◆ XTP_NM_GRID_DRAGDROP_COMPLETED

#define XTP_NM_GRID_DRAGDROP_COMPLETED (NM_FIRST - 77)

Indicates that the user completed a drag-and-drop operation.

Parameters
id | Resource ID for the control.
memberFxn | Name of member function to handle the message.

An XTP_NM_GRIDDRAGDROP structure is passed with this message.

See also
XTP_NM_GRIDDRAGDROP, XTP_NM_GRID_BEGINDRAG, XTP_NM_GRID_DROP, XTP_NM_GRID_RECORDS_DROPPED

◆ XTP_NM_GRID_DRAGOVER

#define XTP_NM_GRID_DRAGOVER (NM_FIRST - 81)

Indicates that the user is dragging records over a control.

Parameters
id | Resource ID for the control.
memberFxn | Name of member function to handle the message.

An XTP_NM_GRIDDRAGDROP structure is passed with this message.

See also
XTP_NM_GRIDDRAGDROP, XTP_NM_GRID_BEGINDRAG, XTP_NM_GRID_DROP, XTP_NM_GRID_RECORDS_DROPPED, XTP_NM_GRID_DRAGDROP_COMPLETED

◆ XTP_NM_GRID_DROP

#define XTP_NM_GRID_DROP (NM_FIRST - 71)

Indicates that the user dropped records to the Grid control.

Parameters
id | Resource ID for the control.
memberFxn | Name of member function to handle the message.

An XTP_NM_GRIDDRAGDROP structure is passed with this message.

See also
XTP_NM_GRIDDRAGDROP, XTP_NM_GRID_BEGINDRAG, XTP_NM_GRID_RECORDS_DROPPED, XTP_NM_GRID_DRAGDROP_COMPLETED

◆ XTP_NM_GRID_EDIT_CANCELED

#define XTP_NM_GRID_EDIT_CANCELED (NM_FIRST - 72)

Defines the message for the in-place editing has been canceled and the value has not been changed event.

Parameters
id | Resource ID for the control.
memberFxn | Name of member function to handle the message.

An XTP_NM_GRIDRECORDITEM structure is passed with this message.

See also
XTP_NM_GRIDRECORDITEM, XTP_NM_GRID_VALUECHANGED, CXTPGridRecordItem::OnEditCanceled

◆ XTP_NM_GRID_FOCUS_CHANGING

#define XTP_NM_GRID_FOCUS_CHANGING (NM_FIRST - 76)

Defines the message for handling the focus changing event.

Parameters
id | Resource ID for the control.
memberFxn | Name of member function to handle the message.

The XTP_NM_GRID_FOCUS_CHANGING notification message is sent to inform the owner window that the focused row or column is about to be changed. The owner window of the Grid control receives this notification through the WM_COMMAND message.

Example: Here is an example of how an application would handle this message.

BEGIN_MESSAGE_MAP(CGridSampleView, CXTPGridView)
ON_NOTIFY(XTP_NM_GRID_FOCUS_CHANGING, XTP_ID_GRID_CONTROL, OnGridFocusChanging)
END_MESSAGE_MAP()

void CGridSampleView::OnGridFocusChanging(NMHDR* pNMHDR, LRESULT* result)
{
   // Handle command.
}
See also
XTP_NM_GRID_CHECKED, XTP_NM_GRID_COLUMNORDERCHANGED, XTP_NM_GRID_HEADER_RCLICK, XTP_NM_GRID_HYPERLINK, XTP_NM_GRID_INPLACEBUTTONDOWN, XTP_NM_GRID_SORTORDERCHANGED, XTP_NM_GRID_VALUECHANGED, XTP_NM_GRID_SELCHANGED, XTP_NM_GRID_FOCUS_CHANGED CXTPGridControl, CXTPGridHeader

◆ XTP_NM_GRID_GETITEMMETRICS

#define XTP_NM_GRID_GETITEMMETRICS (NM_FIRST - 61)

Defines the message for handling the CXTPGridControl::GetItemMetrics() method.

Parameters
id | Resource ID for the control.
memberFxn | Name of member function to handle the message.

The XTP_NM_GRID_GETITEMMETRICS notification message is sent to allow the owner window to customize item drawing. The owner window of the Grid control receives this notification through the WM_COMMAND message.

Example: Here is an example of how an application would handle this message.

BEGIN_MESSAGE_MAP(CGridSampleView, CXTPGridView)
ON_NOTIFY(XTP_NM_GRID_GETITEMMETRICS, XTP_ID_GRID_CONTROL, OnGridGetItemMetrics)
END_MESSAGE_MAP()

void CGridSampleView::OnGridGetItemMetrics(NMHDR*  pNotifyStruct, LRESULT* result)
{
        XTP_NM_GRIDITEMMETRICS* pItemNotify = (XTP_NM_GRIDITEMMETRICS*)pNotifyStruct;

        _ASSERTE(pItemNotify->pDrawArgs);
        _ASSERTE(pItemNotify->pDrawArgs->pControl);
        _ASSERTE(pItemNotify->pDrawArgs->pRow);

        //     pItemNotify->pDrawArgs->pColumn   may be NULL (for a group row)
        //     pItemNotify->pDrawArgs->pItem     may be NULL (for a group row)

        _ASSERTE(pItemNotify->pItemMetrics);

        // customize members of pItemNotify->pItemMetrics.
}
See also
CXTPGridControl, CXTPGridControl::GetItemMetrics()

◆ XTP_NM_GRID_GETTOOLTIPINFO

#define XTP_NM_GRID_GETTOOLTIPINFO (NM_FIRST - 74)

Indicates that a tooltip will be drawn.

Parameters
id | Resource ID for the control.
memberFxn | Name of member function to handle the message.
See also
CXTPGridControl::OnGetToolTipInfo()

◆ XTP_NM_GRID_GROUPORDERCHANGED

#define XTP_NM_GRID_GROUPORDERCHANGED (NM_FIRST - 82)

Defines the message for the column group order changed event.

Parameters
id | Resource ID for the control.
memberFxn | Name of member function to handle the message.

The XTP_NM_GRID_GROUPORDERCHANGED notification message is sent to inform the owner window that the user changed the columns group order of the Grid control. The owner window of the Grid control receives this notification through the WM_COMMAND message.

Example: Here is an example of how an application would handle this message.

BEGIN_MESSAGE_MAP(CGridSampleView, CXTPGridView)
ON_NOTIFY(XTP_NM_GRID_GROUPORDERCHANGED, XTP_ID_GRID_CONTROL, OnGridGroupOrderChanged)
END_MESSAGE_MAP()

void CGridSampleView::OnGridGroupOrderChanged(NMHDR*  pNotifyStruct, LRESULT* result)
{
   XTP_NM_GRIDCOLUMNORDERCHANGED* pItemNotify = (XTP_NM_GRIDCOLUMNORDERCHANGED*)
   pNotifyStruct; _ASSERTE(pItemNotify != NULL);

   // Handle command.
}
See also
XTP_NM_GRID_CHECKED, XTP_NM_GRID_HEADER_RCLICK, XTP_NM_GRID_HYPERLINK, XTP_NM_GRID_INPLACEBUTTONDOWN, XTP_NM_GRID_SELCHANGED, XTP_NM_GRID_COLUMNORDERCHANGED, XTP_NM_GRID_SORTORDERCHANGED, XTP_NM_GRID_VALUECHANGED, CXTPGridControl, CXTPGridHeader

◆ XTP_NM_GRID_HEADER_RCLICK

#define XTP_NM_GRID_HEADER_RCLICK (NM_FIRST - 51)

Defines the message for the column right clicked event.

Parameters
id | Resource ID for the control.
memberFxn | Name of member function to handle the message.

The XTP_NM_GRID_HEADER_RCLICK notification message is sent to inform the owner window that the user right clicked a column of the Grid control. The owner window of the Grid control receives this notification through the WM_COMMAND message.

Example: Here is an example of how an application would handle this message.

BEGIN_MESSAGE_MAP(CGridSampleView, CXTPGridView)
ON_NOTIFY(XTP_NM_GRID_HEADER_RCLICK, XTP_ID_GRID_CONTROL, OnGridColumnRClick)
END_MESSAGE_MAP()

void CGridSampleView::OnGridColumnRClick(NMHDR*  pNotifyStruct, LRESULT* result)
{
   XTP_NM_GRIDRECORDITEM* pItemNotify = (XTP_NM_GRIDRECORDITEM*)pNotifyStruct;
   _ASSERTE(pItemNotify->pColumn);
   CPoint ptClick = pItemNotify->pt;

   // Handle command.
}
See also
XTP_NM_GRID_CHECKED, XTP_NM_GRID_COLUMNORDERCHANGED, XTP_NM_GRID_HYPERLINK, XTP_NM_GRID_INPLACEBUTTONDOWN, XTP_NM_GRID_SELCHANGED, XTP_NM_GRID_SORTORDERCHANGED, XTP_NM_GRID_VALUECHANGED, CXTPGridControl, CXTPGridHeader

◆ XTP_NM_GRID_HYPERLINK

#define XTP_NM_GRID_HYPERLINK (NM_FIRST - 54)

Defines the message for the hyperlink clicked event.

Parameters
id | Resource ID for the control.
memberFxn | Name of member function to handle the message.

The XTP_NM_GRID_HYPERLINK notification message is sent to inform the owner window that the user clicked the hyperlink of an item. The owner window of the Grid control receives this notification through the WM_COMMAND message.

Example: Here is an example of how an application would handle this message.

BEGIN_MESSAGE_MAP(CGridSampleView, CXTPGridView)
ON_NOTIFY(XTP_NM_GRID_HYPERLINK, XTP_ID_GRID_CONTROL, OnGridHyperlinkClick)
END_MESSAGE_MAP()

void CGridSampleView::OnGridHyperlinkClick(NMHDR*  pNotifyStruct, LRESULT* result)
{
        XTP_NM_GRIDRECORDITEM* pItemNotify = (XTP_NM_GRIDRECORDITEM*) pNotifyStruct;

        if (!pItemNotify->pRow || !pItemNotify->pColumn)
            return;

        // if click on Hyperlink in Item
        if (pItemNotify->nHyperlink >= 0)
            {
            TRACE(_T("Hyperlink Click : \n row %d \n col %d \n Hyperlink %d.\n"),
            pItemNotify->pRow->GetIndex(),
            pItemNotify->pColumn->GetItemIndex(),
            pItemNotify->nHyperlink);
            }
}
See also
XTP_NM_GRID_CHECKED, XTP_NM_GRID_COLUMNORDERCHANGED, XTP_NM_GRID_HEADER_RCLICK, XTP_NM_GRID_INPLACEBUTTONDOWN, XTP_NM_GRID_SELCHANGED, XTP_NM_GRID_SORTORDERCHANGED, XTP_NM_GRID_VALUECHANGED, CXTPGridControl, CXTPGridHeader

◆ XTP_NM_GRID_INPLACEBUTTONDOWN

#define XTP_NM_GRID_INPLACEBUTTONDOWN (NM_FIRST - 58)

Defines the message for the in-place button clicked event.

Parameters
id | Resource ID for the control.
memberFxn | Name of member function to handle the message.

The XTP_NM_GRID_INPLACEBUTTONDOWN notification message is sent to inform the owner window that the user clicked the in-place button of the Grid control. The owner window of the Grid control receives this notification through the WM_COMMAND message.

Returns
TRUE if this message was processed, FALSE for default process.

Example: Here is an example of how an application would handle this message.

BEGIN_MESSAGE_MAP(CGridSampleView, CXTPGridView)
ON_NOTIFY(XTP_NM_GRID_INPLACEBUTTONDOWN, XTP_ID_GRID_CONTROL, OnGridButtonClick)
END_MESSAGE_MAP()

void CGridSampleView::OnGridButtonClick(NMHDR*  pNotifyStruct, LRESULT* result)
{
        XTP_NM_GRIDINPLACEBUTTON* pItemNotify = (XTP_NM_GRIDINPLACEBUTTON*) pNotifyStruct;
        _ASSERTE(pItemNotify->pButton);

        // Handle command.
}
See also
XTP_NM_GRID_CHECKED, XTP_NM_GRID_COLUMNORDERCHANGED, XTP_NM_GRID_HEADER_RCLICK, XTP_NM_GRID_HYPERLINK, XTP_NM_GRID_SELCHANGED, XTP_NM_GRID_SORTORDERCHANGED, XTP_NM_GRID_VALUECHANGED, CXTPGridControl, CXTPGridHeader

◆ XTP_NM_GRID_ITEMBUTTONCLICK

#define XTP_NM_GRID_ITEMBUTTONCLICK (NM_FIRST - 83)

Defines the message for the item button click event.

Parameters
id | Resource ID for the control.
memberFxn | Name of member function to handle the message.

The XTP_NM_GRID_ITEMBUTTONCLICK notification message is sent to inform the owner window that the user clicked an item button of the Grid control. The owner window of the Grid control receives this notification through the WM_COMMAND message.

Returns
TRUE if this message was processed, FALSE for default process.

Example: Here is an example of how an application would handle this message.

BEGIN_MESSAGE_MAP(CGridSampleView, CXTPGridView)
ON_NOTIFY(XTP_NM_GRID_ITEMBUTTONCLICK, XTP_ID_GRID_CONTROL, OnGridItemButtonClick)
END_MESSAGE_MAP()

void CGridSampleView::OnGridItemButtonClick(NMHDR*  pNotifyStruct, LRESULT* result)
{
    XTP_NM_GRIDITEMCONTROL* pItemNotify = (XTP_NM_GRIDITEMCONTROL*) pNotifyStruct;
    _ASSERTE(pItemNotify->pItemControl);

    // Handle command.
}
See also
XTP_NM_GRIDITEMCONTROL CXTPGridRecordItemControl, CXTPGridRecordItemButton

◆ XTP_NM_GRID_LBUTTONDOWN

#define XTP_NM_GRID_LBUTTONDOWN (NM_FIRST - 60)

Defines the message for the left mouse button clicked event.

Parameters
id | Resource ID for the control.
memberFxn | Name of member function to handle the message.

The XTP_NM_GRID_LBUTTONDOWN notification message is sent to inform the owner window that the user left clicked a row.

Example: Here is an example of how an application would handle this message.

BEGIN_MESSAGE_MAP(CGridSampleView, CXTPGridView)
ON_NOTIFY(XTP_NM_GRID_LBUTTONDOWN, XTP_ID_GRID_CONTROL, OnGridLButtonDown)
END_MESSAGE_MAP()

void CGridSampleView::OnGridLButtonDown(NMHDR*  pNotifyStruct, LRESULT* result)
{
        XTP_NM_GRIDRECORDITEM* pItemNotify = (XTP_NM_GRIDRECORDITEM*) pNotifyStruct;
        _ASSERTE(pItemNotify != NULL);

        // Handle command.
}
See also
XTP_NM_GRID_CHECKED, XTP_NM_GRID_HEADER_RCLICK, XTP_NM_GRID_HYPERLINK, XTP_NM_GRID_INPLACEBUTTONDOWN, XTP_NM_GRID_SELCHANGED, XTP_NM_GRID_SORTORDERCHANGED, XTP_NM_GRID_VALUECHANGED, CXTPGridControl, CXTPGridHeader

◆ XTP_NM_GRID_PLUSMINUSCLICK

#define XTP_NM_GRID_PLUSMINUSCLICK (NM_FIRST - 84)

Defines the message for the header column click on PlusMinus icon event.

Parameters
id | Resource ID for the control.
memberFxn | Name of member function to handle the message.

The XTP_NM_GRID_PLUSMINUSCLICK notification message is sent to inform the owner window that the user clicked a header column PlusMinus icon of the Grid control. The owner window of the Grid control receives this notification through the WM_COMMAND message.

Returns
TRUE if this message was processed, FALSE for default process.

Example: Here is an example of how an application would handle this message.

BEGIN_MESSAGE_MAP(CGridSampleView, CXTPGridView)
ON_NOTIFY(XTP_NM_GRID_PLUSMINUSCLICK, XTP_ID_GRID_CONTROL, OnGridPlusMinusClick)
END_MESSAGE_MAP()

void CGridSampleView::OnGridPlusMinusClick(NMHDR*  pNotifyStruct, LRESULT* result)
{
   XTP_NM_GRIDITEMCONTROL* pItemNotify = (XTP_NM_GRIDITEMCONTROL*) pNotifyStruct;
   _ASSERTE(pItemNotify->pItemControl);
   _ASSERTE(pItemNotify->pColumn);
   CPoint ptClick = pItemNotify->pt;

   // Handle command.
}

◆ XTP_NM_GRID_PRESORTORDERCHANGED

#define XTP_NM_GRID_PRESORTORDERCHANGED (NM_FIRST - 67)

Defines the message when a column header has been clicked and the sort order has changed, but CXTPGridControl::Populate has NOT yet been called.

Parameters
id | Resource ID for the control.
memberFxn | Name of member function to handle the message.

The XTP_NM_GRID_PRESORTORDERCHANGED notification message is sent to inform the owner window that the user clicked the header of the Grid control and that the sort order will change. XTP_NM_GRID_PRESORTORDERCHANGED is sent before the CXTPGridControl::Populate method has been called. As such, the order of rows has not been visibly changed yet. After the CXTPGridControl:Populate method is called, the XTP_NM_GRID_SORTORDERCHANGED notification is sent to inform the owner window that the visible order of rows has actually changed. The owner window of the Grid control receives this notification through the WM_COMMAND message.

See also
XTP_NM_GRID_CHECKED, XTP_NM_GRID_COLUMNORDERCHANGED, XTP_NM_GRID_HEADER_RCLICK, XTP_NM_GRID_HYPERLINK, XTP_NM_GRID_INPLACEBUTTONDOWN, XTP_NM_GRID_SELCHANGED, XTP_NM_GRID_VALUECHANGED, XTP_NM_GRID_SORTORDERCHANGED CXTPGridControl, CXTPGridHeader

◆ XTP_NM_GRID_PREVIEWKEYDOWN

#define XTP_NM_GRID_PREVIEWKEYDOWN (NM_FIRST - 69)

Defines the message for handling the CXTPGridControl::OnPreviewKeyDown() method.

Parameters
id | Resource ID for the control.
memberFxn | Name of member function to handle the message.

This notification is sent to the Main window in a WM_NOTIFY message before processing the OnKeyDown event.

See also
CXTPGridControl::OnPreviewKeyDown, XTP_NM_GRIDPREVIEWKEYDOWN, CXTPGridControl::OnKeyDown, CWnd::OnKeyDown.

◆ XTP_NM_GRID_RECORDS_DROPPED

#define XTP_NM_GRID_RECORDS_DROPPED (NM_FIRST - 75)

Indicates that records were dropped to the Grid control.

Parameters
id | Resource ID for the control.
memberFxn | Name of member function to handle the message.

An XTP_NM_GRIDDRAGDROP structure is passed with this message.

See also
XTP_NM_GRIDDRAGDROP, XTP_NM_GRID_BEGINDRAG, XTP_NM_GRID_DROP, XTP_NM_GRID_DRAGDROP_COMPLETED

◆ XTP_NM_GRID_REQUESTEDIT

#define XTP_NM_GRID_REQUESTEDIT (NM_FIRST - 62)

Defines the message for handling the CXTPGridControl::OnRequestEdit() method.

Parameters
id | Resource ID for the control.
memberFxn | Name of member function to handle the message.

The XTP_NM_GRID_REQUESTEDIT notification message is sent to notify the owner window that an item has entered edit mode. This message is send when an editable item starts to be edited or when a check box item is checked/unchecked.

See also
CXTPGridControl, CXTPGridControl::OnRequestEdit()

◆ XTP_NM_GRID_ROWEXPANDED

#define XTP_NM_GRID_ROWEXPANDED (NM_FIRST - 59)

Defines the message for the row expand changed event.

Parameters
id | Resource ID for the control.
memberFxn | Name of member function to handle the message.

The XTP_NM_GRID_ROWEXPANDED notification message is sent to inform the owner window that the user expanded or collapsed a row of the Grid control.

Example: Here is an example of how an application would handle this message.

BEGIN_MESSAGE_MAP(CGridSampleView, CXTPGridView)
ON_NOTIFY(XTP_NM_GRID_ROWEXPANDED, XTP_ID_GRID_CONTROL, OnGridRowExpandChanged)
END_MESSAGE_MAP()

void CGridSampleView::OnGridRowExpandChanged(NMHDR*  pNotifyStruct, LRESULT* result)
{
        XTP_NM_GRIDRECORDITEM* pItemNotify = (XTP_NM_GRIDRECORDITEM*) pNotifyStruct;
        _ASSERTE(pItemNotify != NULL);

        // Handle command.
}
See also
XTP_NM_GRID_CHECKED, XTP_NM_GRID_HEADER_RCLICK, XTP_NM_GRID_HYPERLINK, XTP_NM_GRID_INPLACEBUTTONDOWN, XTP_NM_GRID_SELCHANGED, XTP_NM_GRID_SORTORDERCHANGED, XTP_NM_GRID_VALUECHANGED, CXTPGridControl, CXTPGridHeader

◆ XTP_NM_GRID_ROWHEIGHTCHANGED

#define XTP_NM_GRID_ROWHEIGHTCHANGED (NM_FIRST - 94)

The XTP_NM_GRID_ROWHEIGHTCHANGED notification message is sent when the height of a row has changed.

This can happen when the user changes the height.

◆ XTP_NM_GRID_SELCHANGED

#define XTP_NM_GRID_SELCHANGED (NM_FIRST - 52)

Defines the message for the row selection changed event.

Parameters
id | Resource ID for the control.
memberFxn | Name of member function to handle the message.

The XTP_NM_GRID_SELCHANGED notification message is sent to inform the owner window that the user selected a row of the Grid control. The owner window of the Grid control receives this notification through the WM_COMMAND message.

Example: Here is an example of how an application would handle this message.

BEGIN_MESSAGE_MAP(CGridSampleView, CXTPGridView)
ON_NOTIFY(XTP_NM_GRID_SELCHANGED, XTP_ID_GRID_CONTROL, OnGridSelChanged)
END_MESSAGE_MAP()

void CGridSampleView::OnGridSelChanged(NMHDR* pNMHDR, LRESULT* result)
{
   // Handle command.
}
See also
XTP_NM_GRID_CHECKED, XTP_NM_GRID_COLUMNORDERCHANGED, XTP_NM_GRID_HEADER_RCLICK, XTP_NM_GRID_HYPERLINK, XTP_NM_GRID_INPLACEBUTTONDOWN, XTP_NM_GRID_SORTORDERCHANGED, XTP_NM_GRID_VALUECHANGED, CXTPGridControl, CXTPGridHeader

◆ XTP_NM_GRID_SELCHANGING

#define XTP_NM_GRID_SELCHANGING (NM_FIRST - 80)

Defines the message for changing the selected rows collection.

Sent for each row when it is added/removed.

Parameters
id | Resource ID for the control.
memberFxn | Name of member function to handle the message.

An XTP_NM_SELECTION_CHANGING structure is passed with this message.

See also
XTP_NM_SELECTION_CHANGING

◆ XTP_NM_GRID_SORTORDERCHANGED

#define XTP_NM_GRID_SORTORDERCHANGED (NM_FIRST - 56)
@brief
Defines the message for the sort order changed event.
@param id         Resource ID for the control.
@param memberFxn  Name of member function to handle the message.
@details
The XTP_NM_GRID_SORTORDERCHANGED notification message is sent to inform the
owner window that the user clicked the header of the Grid control
and changed the sort order.
The owner window of the Grid control receives this notification through
the WM_COMMAND message.

Example: Here is an example of how an application would handle this message.

    BEGIN_MESSAGE_MAP(CGridSampleView, CXTPGridView)
    ON_NOTIFY(XTP_NM_GRID_SORTORDERCHANGED, XTP_ID_GRID_CONTROL, OnGridSortOrderChanged)
    END_MESSAGE_MAP()

    void CGridSampleView::OnGridSortOrderChanged(NMHDR*  pNotifyStruct, LRESULT* result)
    {
        //pNotifyStruct doesn't consist information about column which was clicked.
        //To get column use XTP_NM_GRID_COLUMNORDERCHANGED notification.

        // Handle command.
}
See also
XTP_NM_GRID_CHECKED, XTP_NM_GRID_COLUMNORDERCHANGED, XTP_NM_GRID_HEADER_RCLICK, XTP_NM_GRID_HYPERLINK, XTP_NM_GRID_INPLACEBUTTONDOWN, XTP_NM_GRID_SELCHANGED, XTP_NM_GRID_VALUECHANGED, CXTPGridControl, CXTPGridHeader

◆ XTP_NM_GRID_STATECHANGED

#define XTP_NM_GRID_STATECHANGED (NM_FIRST - 88)

This message is sent by the Grid control when the state of an item or range of items has changed.

It is sent in the form of a WM_NOTIFY message.

Parameters
lpStateChange Long pointer to an XTP_NM_GRIDSTATECHANGED structure that contains data about the item or items that have changed.

The XTP_NM_GRID_STATECHANGED notification message is sent to inform the owner window that the state of an item or range of items has changed.

Returns
The application receiving this message must return zero.

Example: Here is an example of how an application would handle this message.

BEGIN_MESSAGE_MAP(CGridSampleView, CXTPGridView)
ON_NOTIFY(XTP_NM_GRID_STATECHANGED, XTP_ID_GRID_CONTROL, OnGridStateChanged)
END_MESSAGE_MAP()

void CGridSampleView::OnGridStateChanged(NMHDR*  pNotifyStruct, LRESULT* result)
{
        XTP_NM_GRIDSTATECHANGED* pItemNotify = (XTP_NM_GRIDSTATECHANGED*)pNotifyStruct;
        int nBegin = nm.nBegin; // first item in the range
        int nEnd = nm.nEnd; // last item in the range

        // Handle command.
}

◆ XTP_NM_GRID_VALUECHANGED

#define XTP_NM_GRID_VALUECHANGED (NM_FIRST - 57)

Defines the message for the value changed event.

Parameters
id | Resource ID for the control.
memberFxn | Name of member function to handle the message.

The XTP_NM_GRID_VALUECHANGED notification message is sent to inform the owner window that the user changed a value of a grid cell. The owner window of the Grid control receives this notification through the WM_COMMAND message.

BEGIN_MESSAGE_MAP(CPropertiesView, CXTPGridView)
ON_NOTIFY(XTP_NM_GRID_VALUECHANGED, ID_GRID_CONTROL, OnGridValueChanged)
END_MESSAGE_MAP()

void CPropertiesView::OnGridValueChanged(NMHDR*  pNotifyStruct, LRESULT* result)
{
   XTP_NM_GRIDRECORDITEM* pItemNotify = (XTP_NM_GRIDRECORDITEM*) pNotifyStruct;
   _ASSERTE(pItemNotify != NULL);

   switch (pItemNotify->pItem->GetItemData())
   {
      case ID_PROPERTY_MULTIPLESELECTION:
         GetTargetGrid()->SetMultipleSelection(
         CRecordPropertyBool::GetValue(pItemNotify));
         break;
      case ID_PROPERTY_PREVIEWMODE:
         GetTargetGrid()->EnablePreviewMode(
         CRecordPropertyBool::GetValue(pItemNotify));
         GetTargetGrid()->Populate();
         break;
      case ID_PROPERTY_GROUPBOXVISIBLE:
         GetTargetGrid()->ShowGroupBy(
         CRecordPropertyBool::GetValue(pItemNotify));
         break;
      case ID_PROPERTY_FOCUSSUBITEMS:
         GetTargetGrid()->FocusSubItems(
         CRecordPropertyBool::GetValue(pItemNotify));
         break;
      case ID_PROPERTY_ALLOWCOLUMNREMOVE:
         GetTargetGrid()->GetGridHeader()->AllowColumnRemove(
         CRecordPropertyBool::GetValue(pItemNotify));
         break;
      case ID_PROPERTY_ALLOWCOLUMNREORDER:
         GetTargetGrid()->GetGridHeader()->AllowColumnReorder(
         CRecordPropertyBool::GetValue(pItemNotify));
         break;
      case ID_PROPERTY_ALLOWCOLUMNRESIZE:
         GetTargetGrid()->GetGridHeader()->AllowColumnResize(
         CRecordPropertyBool::GetValue(pItemNotify));
         break;
      case ID_PROPERTY_FLATHEADER:
         GetTargetGrid()->GetPaintManager()->m_columnStyle =
         (CRecordPropertyBool::GetValue(pItemNotify)) ? xtpGridColumnFlat :
         xtpGridColumnShaded;
         break;
      case ID_PROPERTY_HIDESELECTION:
         GetTargetGrid()->GetPaintManager()->m_bHideSelection =
      (CRecordPropertyBool::GetValue(pItemNotify));
         break;
      case ID_PROPERTY_TREEINDENT:
         GetTargetGrid()->GetPaintManager()->m_nTreeIndent =
         CRecordPropertyInt::GetValue(pItemNotify);
      GetTargetGrid()->RedrawControl();
         break;
   }
}
See also
XTP_NM_GRID_CHECKED, XTP_NM_GRID_COLUMNORDERCHANGED, XTP_NM_GRID_HEADER_RCLICK, XTP_NM_GRID_HYPERLINK, XTP_NM_GRID_INPLACEBUTTONDOWN, XTP_NM_GRID_SELCHANGED, XTP_NM_GRID_SORTORDERCHANGED, CXTPGridControl, CXTPGridHeader

Typedef Documentation

◆ XTPGridRowsCompareFunc

typedef int(AFX_CDECL * XTPGridRowsCompareFunc) (const CXTPGridRow **pRow1, const CXTPGridRow **pRow2)

Defines a function pointer for comparing events.

This function pointer is used in the SortEx method.

See also
Sort, SortEx, CXTPGridControl::SetRowsCompareFunc

Enumeration Type Documentation

◆ XTPGridCheckState

enum XTPGridCheckState

This enum defines the possible checkbox states.

Enumerator
xtpGridCheckStateInvalid | The checkbox state is invalid.
xtpGridCheckStateUnchecked | The checkbox is in an unchecked state.
xtpGridCheckStateChecked | The checkbox is in a checked state.
xtpGridCheckStateIndeterminate | The checkbox is in an indeterminate state.
xtpGridCheckStateCount | Number of checkbox states.

◆ XTPGridColumnStyle

enum XTPGridColumnStyle

Represents predefined column styles.

Example:

m_wndGrid.GetPaintManager()->m_columnStyle = xtpGridColumnFlat;
See also
CXTPGridPaintManager::m_columnStyle, CXTPGridPaintManager, xtpGridColumnShaded, xtpGridColumnFlat
Enumerator
xtpGridColumnShaded | Columns are gray shaded.
xtpGridColumnFlat | Flat style for drawing columns.
xtpGridColumnExplorer | Explorer column style.
xtpGridColumnOffice2003 | Gradient column style.
xtpGridColumnResource | Office 2007/2010 column style.

◆ XTPGridDrawSortTriangleStyle

enum XTPGridDrawSortTriangleStyle

Represent the Grid Draw Sort Triangle logic.

Enumerator
xtpGridDrawSortTriangleDefault | The triangle will be removed when the column size is too small to display the full caption and triangle.
xtpGridDrawSortTriangleAlways | The sort triangle displayed in column header when a column is sorted and the caption will be cut with ellipsis.
xtpGridDrawSortTriangleNever | Never draw the triangle.

◆ XTPGridFreezeColsDividerStyle

enum XTPGridFreezeColsDividerStyle

Represents predefined freeze column line styles.

Enumerator
xtpGridFreezeColsDividerThin | Thin line style.
xtpGridFreezeColsDividerBold | Bold line style.
xtpGridFreezeColsDividerHeader | Header line style.
xtpGridFreezeColsDividerShade | Shade line style.
xtpGridFreezeColsDividerShowAlways | Show event if AutoColumnSizing is On.

◆ XTPGridGlyph

enum XTPGridGlyph

This enum defines the index of the glyphs.

Enumerator
xtpGridGlyphInvalid | Specifies an invalid glyph.
xtpGridGlyphRowCollapse | Specifies a row collapse glyph.
xtpGridGlyphRowExpand | Specifies a row expand glyph.
xtpGridGlyphEnabledUnchecked | Specifies an enabled unchecked glyph.
xtpGridGlyphEnabledChecked | Specifies an enabled checked glyph.
xtpGridGlyphDisabledUnchecked | Specifies a disabled unchecked glyph.
xtpGridGlyphDisabledChecked | Specifies a disabled checked glyph.
xtpGridGlyphColumnExpand | Specifies a column expand glyph.
xtpGridGlyphColumnRestore | Specifies a column restore glyph.
xtpGridGlyphEnabledTristate | Specifies an enabled tristate glyph.
xtpGridGlyphItemLocked | Specifies a locked item glyph.
xtpGridGlyphItemUnlocked | Specifies an unlocked item glyph.
xtpGridGlyphCount | The number of the glyphs.

◆ XTPGridLineStyle

enum XTPGridLineStyle

Represents predefined grid line styles.

Example:

m_wndGrid.SetGridStyle(FALSE, xtpGridGridLargeDots);
See also
CXTPGridControl::SetGridStyle, xtpGridGridNoLines, xtpGridGridSmallDots, xtpGridGridLargeDots, xtpGridGridDashes, xtpGridGridSolid
Enumerator
xtpGridLineStyleNone | No line.
xtpGridLineStyleDotSmall | Line is drawn with small dots.
xtpGridLineStyleDotLarge | Line is drawn with large dots.
xtpGridLineStyleDash | Line is drawn with dashes.
xtpGridLineStyleSolid | Solid line.
xtpGridLineStyleCount | Number of line styles.
xtpGridGridNoLines | Deprecated. Same as xtpGridLineStyleNone
xtpGridGridSmallDots | Deprecated. Same as xtpGridLineStyleDotSmall
xtpGridGridLargeDots | Deprecated. Same as xtpGridLineStyleDotLarge
xtpGridGridDashes | Deprecated. Same as xtpGridLineStyleDash
xtpGridGridSolid | Deprecated. Same as xtpGridLineStyleSolid

◆ XTPGridOrientation

enum XTPGridOrientation

Enumeration of orientations.

See also
SetGridStyle
Enumerator
xtpGridOrientationHorizontal | Specifies horizontal grid orientation.
xtpGridOrientationVertical | Specifies vertical grid orientation.
xtpGridOrientationAll | Specifies both horizontal and vertical grid orientations.

◆ XTPGridPaintTheme

enum XTPGridPaintTheme

Visual theme enumeration.

Example:

 m_wndGridControl.SetTheme(xtpGridThemeOffice2013);
See also
CXTPGridControl::SetTheme, CXTPGridControl::GetCurrentTheme
Enumerator
xtpGridThemeDefault | Default theme.
xtpGridThemeOfficeXP | Office XP style theme.
xtpGridThemeOffice2003 | Office 2003 style theme.
xtpGridThemeOffice2003Luna | Office 2003 style theme with luna colors.
xtpGridThemeOffice2013 | Office 2013 style theme.
xtpGridThemeOffice2016 | Office 2016 style theme.
xtpGridThemeVisualStudio2012Light | Visual Studio 2012 Light style theme.
xtpGridThemeVisualStudio2012Dark | Visual Studio 2012 Dark style theme.
xtpGridThemeVisualStudio2012Blue | Visual Studio 2012 Blue style theme.
xtpGridThemeVisualStudio2015 | Visual Studio 2015 style theme.
xtpGridThemeExplorer | Windows Explorer theme.
xtpGridThemeResource | Resource .DLL style theme.
xtpGridThemeNativeWindows10 | Windows 10 style theme.
xtpGridThemeVisualStudio2017 | Visual Studio 2017 style theme.
xtpGridThemeVisualStudio2019 | Visual Studio 2019 style theme.
xtpGridThemeVisualStudio2022 | Visual Studio 2022 style theme.
xtpGridThemeNativeWindows11 | Windows 11 style theme.

◆ XTPGridRowType

enum XTPGridRowType

This enum defines body, header, and footer rows.

See also
CXTPGridRow::m_nRowType
Enumerator
xtpRowTypeInvalid | Indicates an invalid row type.
xtpRowTypeBody | The row is in the body rows collection.
xtpRowTypeHeader | The row is in the header rows collection.
xtpRowTypeFooter | The row is in the footer rows collection.

◆ XTPGridSectionDividerPosition

enum XTPGridSectionDividerPosition

Section divider position.

Enumerator
xtpGridSectionDividerPositionTop | Divider above the section.
xtpGridSectionDividerPositionBottom | Divider below the section.

◆ XTPGridSectionDividerStyle

enum XTPGridSectionDividerStyle

Represent the header/footer rows divider style.

Enumerator
xtpGridSectionDividerStyleNone | No line.
xtpGridSectionDividerStyleThin | Thin style.
xtpGridSectionDividerStyleBold | Bold style.
xtpGridSectionDividerStyleShade | Shaded line style.
xtpGridSectionDividerStyleOutlook | Outlook line style.

◆ XTPGridShellIcon

enum XTPGridShellIcon

This enum defines the shell icons.

Enumerator
xtpGridShellIconLock

Specifies a Lock icon.

◆ XTPGridTextDecoration

enum XTPGridTextDecoration

Enumeration of hyperlink text decorations.

See also
xtpGridTextDecorationNone, xtpGridTextDecorationUnderline>
Enumerator
xtpGridTextDecorationNone | Text has no decoration.
xtpGridTextDecorationUnderline | Text is underlined.

◆ XTPGridTreeStructureStyle

enum XTPGridTreeStructureStyle

Represent the style of lines used to draw a hierarchical tree structure.

Example:

m_wndGrid.GetPaintManager()->m_treeStructureStyle =
xtpGridTreeStructureSolid;
See also
CXTPGridPaintManager::m_treeStructureStyle, CXTPGridPaintManager, xtpGridTreeStructureNone, xtpGridTreeStructureSolid
Enumerator
xtpGridTreeStructureNone | No lines will be drawn from the parent node to each child node.
xtpGridTreeStructureSolid | Lines will be drawn from the parent node to each child node at the next level.
xtpGridTreeStructureDots | Dots will be drawn from the parent node to each child node at the next level.

Variable Documentation

◆ XTP_GRID_COLOR_DEFAULT

const COLORREF XTP_GRID_COLOR_DEFAULT = (COLORREF)-1

This constant indicates that a COLORREF is not defined.

Example:

void CXTPGridRecordItem::GetItemMetrics(
XTP_GRIDRECORDITEM_DRAWARGS* pDrawArgs,
XTP_GRIDRECORDITEM_METRICS* pItemMetrics)
{
   if (m_clrBackground != XTP_GRID_COLOR_DEFAULT)
      pItemMetrics->clrBackground = m_clrBackground;

   if (m_clrText != XTP_GRID_COLOR_DEFAULT)
      pItemMetrics->clrForeground = m_clrText;

   if (m_pFontCaption != NULL)
      pItemMetrics->pFont = m_pFontCaption;

   else if (m_bBoldText)
      pItemMetrics->pFont =
      &pDrawArgs->pControl->GetPaintManager()->m_fontBoldText;
}
See also
CXTPGridRecordItem, CXTPGridRow

◆ XTP_GRID_NOICON

const int XTP_GRID_NOICON = (int)-1

This constant indicates that an icon ID is not defined.

Example:

m_wndGrid.AddColumn(new CXTPGridColumn(COLUMN_PRICE, _T("Price"),
80, TRUE, XTP_GRID_NOICON, TRUE, FALSE));
See also
CXTPGridColumn

◆ XTPGRIDCTRL_CLASSNAME

const TCHAR XTPGRIDCTRL_CLASSNAME[] = _T("XTPGrid")

A NULL-terminated string used by CXTPGridControl which specifies the window class name for the Grid control.

Example:

BOOL CXTPGridControl::RegisterWindowClass()
{
   WNDCLASS wndcls;
   HINSTANCE hInst = XTPGetInstanceHandle();

   if (!(GetClassInfo(hInst, XTPGRIDCTRL_CLASSNAME, &wndcls)))
   {
      // otherwise we need to register a new class
      wndcls.style            = CS_DBLCLKS | CS_HREDRAW | CS_VREDRAW;
      wndcls.lpfnWndProc      = DefWindowProc;
      wndcls.cbClsExtra       = wndcls.cbWndExtra = 0;
      wndcls.hInstance        = hInst;
      wndcls.hIcon            = NULL;
      wndcls.hCursor          = AfxGetApp()->LoadStandardCursor(IDC_ARROW);
      wndcls.hbrBackground    = (HBRUSH) (COLOR_3DFACE + 1);
      wndcls.lpszMenuName     = NULL;
      wndcls.lpszClassName    = XTPGRIDCTRL_CLASSNAME;

      if (!AfxRegisterClass(&wndcls))
      {
         AfxThrowResourceException();
         return FALSE;
      }
   }

   return TRUE;
}
See also
CXTPGridControl::RegisterWindowClass


Toolkit Pro: XTPGridDeprecated.h File Reference

  • Source
  • GridControl
XTPGridDeprecated.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPGridDragDrop.h File Reference

  • Source
  • GridControl
Classes
XTPGridDragDrop.h File Reference

Go to the source code of this file.

Classes

class | CXTPGridHeaderDragWnd
CXTPGridHeaderDragWnd is a CWnd derived class. More...
class | CXTPGridHeaderDropWnd
CXTPGridHeaderDropWnd is a CWnd derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPGridFilterEditControl.h File Reference

  • Source
  • GridControl
Classes
XTPGridFilterEditControl.h File Reference

Go to the source code of this file.

Classes

class CXTPGridFilterEditControl
The CXTPGridFilterEditControl class provides the functionality of the filter string edit control associated to the main Grid control window. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPGridGroupRow.h File Reference

  • Source
  • GridControl
Classes
XTPGridGroupRow.h File Reference

Go to the source code of this file.

Classes

class CXTPGridGroupRow
This class represents a 'group row' of the Grid control view. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPGridHeader.h File Reference

  • Source
  • GridControl
Classes | Enumerations
XTPGridHeader.h File Reference

Go to the source code of this file.

Classes

struct | XTP_NM_GRIDSCROLL
NM_GRIDSCROLL notification data. More...
struct | XTP_NM_GRIDGIVEFEEDBACK
NM_GRIDGIVEFEEDBACK notification data. More...
struct | XTP_NM_GRIDCOLUMNRESIZE
This structure is sent to the main window in a WM_NOTIFY message after a column is resized. More...
struct | XTP_NM_GRIDROWRESIZE
This structure is sent to the main window in a WM_NOTIFY message after a row is resized. More...
struct | XTP_NM_GRIDCOLUMNORDERCHANGED
This structure is sent to the main window in a WM_NOTIFY message after columns order or group order is changed. More...
class | CXTPGridHeader
A grid header is a part of the grid window positioned above columns of text or numbers. More...

Enumerations

enum XTPGridColumnOrderChangedReason {
xtpGridColumnChangeOther = 0x0000 , xtpGridColumnOrderChanged = 0x0001 , xtpGridColumnGroupOrderChanged = 0x0002 , xtpGridColumnOrderChangedMask = 0x000F ,
xtpGridColumnAdded = 0x0010 , xtpGridColumnRemoved = 0x0020 , xtpGridColumnPropExchange = 0x0040 , xtpGridColumnCaptionChanged = 0x0080 ,
xtpGridColumnWidthChanged = 0x0100 , xtpGridColumnShown = 0x0200 , xtpGridColumnHidden = 0x0400 , xtpGridColumnMoved = 0x0800 ,
xtpGridColumnAddedToGroupby = 0x1000 , xtpGridColumnRemovedFromGroupby = 0x2000 , xtpGridColumnAddedToFieldChooser = 0x4000 , xtpGridColumnRemovedFromFieldChooser = 0x8000 ,
xtpGridColumnChangeMask = 0xFFF0
}
Enumeration of OnColumnsChanged event reasons. More...
enum XTPGridColumnDirection { xtpGridColumnDirectionLeft = -1 , xtpGridColumnDirectionRight = +1 }
Defines a grid column direction. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Enumeration Type Documentation

◆ XTPGridColumnDirection

enum XTPGridColumnDirection

Defines a grid column direction.

Enumerator
xtpGridColumnDirectionLeft | Specifies a left grid column direction.
xtpGridColumnDirectionRight | Specifies a right grid column direction.

◆ XTPGridColumnOrderChangedReason

enum XTPGridColumnOrderChangedReason

Enumeration of OnColumnsChanged event reasons.

See also
CXTPGridHeader::OnColumnsChanged
Enumerator
xtpGridColumnChangeOther | Neither column order nor group order is changed.
xtpGridColumnOrderChanged | Column order changed.
xtpGridColumnGroupOrderChanged | Group order changed.
xtpGridColumnOrderChangedMask | A mask for order change flags.
xtpGridColumnAdded | A column is added to the column list.
xtpGridColumnRemoved | A column is removed from the column list.
xtpGridColumnPropExchange | The column properties changed during properties exchange procedure.
xtpGridColumnCaptionChanged | The column caption is changed.
xtpGridColumnWidthChanged | The column width is changed.
xtpGridColumnShown | A column visibility property is changed to "visible".
xtpGridColumnHidden | A column visibility property is changed to "hidden".
xtpGridColumnMoved | A column is moved.
xtpGridColumnAddedToGroupby | A column is added to the Group By box.
xtpGridColumnRemovedFromGroupby | A column is removed from the Group By box.
xtpGridColumnAddedToFieldChooser | A column is added to the field chooser.
xtpGridColumnRemovedFromFieldChooser | A column is removed from the field chooser.
xtpGridColumnChangeMask | A mask for column change flags.


Toolkit Pro: XTPGridHitTestInfo.h File Reference

  • Source
  • GridControl
XTPGridHitTestInfo.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPGridHyperlink.h File Reference

  • Source
  • GridControl
Classes | Typedefs
XTPGridHyperlink.h File Reference

Go to the source code of this file.

Classes

class | CXTPGridHyperlinkStyle
This class stores the anchor styles. More...
class | CXTPGridHyperlink
This class represents hyperlinks. More...
class | CXTPGridHyperlinks
This class represents an array of pointers to CXTPGridHyperlink objects. More...

Typedefs

typedef CXTPArrayT< CXTPGridHyperlink *, CXTPGridHyperlink *, LPDISPATCH > CXTPGridHyperlinks_base
This typedef is used to declare a base class for CXTPGridHyperlinks.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPGridInplaceControls.h File Reference

  • Source
  • GridControl
Classes | Variables
XTPGridInplaceControls.h File Reference

Go to the source code of this file.

Classes

class | CXTPGridInplaceControl
CXTPGridInplaceControl is the base class for all in-place controls of the Grid control item. More...
class | CXTPGridInplaceEdit
CXTPGridInplaceEdit is a CXTPGridInplaceControl derived class that represents an edit control to allow users to change a cell of a Grid control. More...
class | CXTPGridInplaceButton
CXTPGridInplaceButton is a CXTPGridInplaceControl derived class that represents a combo button and expand button of a grid cell. More...
class | CXTPGridInplaceList
CXTPGridInplaceList is a CXTPGridInplaceControl derived class that represents a list box with item constraints. More...

Variables

const UINT | XTP_ID_GRID_EXPANDBUTTON = 100
const UINT | XTP_ID_GRID_COMBOBUTTON = 101
const UINT | XTP_ID_GRID_SPINBUTTON = 102

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Variable Documentation

◆ XTP_ID_GRID_COMBOBUTTON

const UINT XTP_ID_GRID_COMBOBUTTON = 101
See also
CXTPGridInplaceButton::CXTPGridInplaceButton

◆ XTP_ID_GRID_EXPANDBUTTON

const UINT XTP_ID_GRID_EXPANDBUTTON = 100
See also
CXTPGridInplaceButton::CXTPGridInplaceButton

◆ XTP_ID_GRID_SPINBUTTON

const UINT XTP_ID_GRID_SPINBUTTON = 102
See also
CXTPGridInplaceButton::CXTPGridInplaceButton


Toolkit Pro: XTPGridNavigator.h File Reference

  • Source
  • GridControl
Classes
XTPGridNavigator.h File Reference

Go to the source code of this file.

Classes

class | CXTPGridNavigator
Utility class, handles Grid control item navigation. More...
class | CXTPGridIconNavigator
Utility class, handles Grid control icon navigation. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPGridPageSetupDialog.h File Reference

  • Source
  • GridControl
Classes
XTPGridPageSetupDialog.h File Reference

Go to the source code of this file.

Classes

class | CXTPGridViewPrintOptions
This class is used to store printing options. More...
class | CXTPGridPageSetupDialog
Customized Grid control page setup dialog. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPGridPaintManager.h File Reference

  • Source
  • GridControl
Classes
XTPGridPaintManager.h File Reference

Go to the source code of this file.

Classes

class CXTPGridPaintManager
Utility class that handles most drawing activities. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPGridRecord.h File Reference

  • Source
  • GridControl
Classes
XTPGridRecord.h File Reference

Go to the source code of this file.

Classes

class CXTPGridRecord
CXTPGridRecord represents a collection of CXTPGridRecordItem objects or objects of classes that are children of CXTPGridRecordItem. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPGridRecordItem.h File Reference

  • Source
  • GridControl
Classes | Enumerations
XTPGridRecordItem.h File Reference

Go to the source code of this file.

Classes

struct | XTP_GRIDRECORDITEM_ARGS
Basic set of parameters transferred to item handlers. More...
struct | XTP_GRIDRECORDITEM_DRAWARGS
A set of parameters transferred to the Draw item handler. More...
struct | XTP_GRIDRECORDITEM_CLICKARGS
A set of parameters transferred to mouse click item handlers. More...
struct | XTP_NM_GRIDRECORDITEM
This structure is sent to the Main window in a WM_NOTIFY message from Item and provides all parameters required by the Main window to process control specific notifications. More...
struct | XTP_NM_GRIDREQUESTEDIT
A set of parameters transferred with an XTP_NM_GRID_REQUESTEDIT message. More...
struct | XTP_NM_GRIDINPLACEBUTTON
This structure is sent to the Main window in a WM_NOTIFY message from Item and provides all parameters required by the Main window to process control specific notifications. More...
struct | XTP_NM_GRID_BEFORE_COPYPASTE
This structure is sent to the Main window in a WM_NOTIFY message from Item and provides all parameters required by the Main window to process control specific notifications. More...
struct | XTP_NM_GRIDCONSTRAINTSELECTING
This structure is sent to the Main window in a WM_NOTIFY message from Item and provides all parameters required by the Main window to process control specific notifications. More...
struct | XTP_NM_GRIDTOOLTIPINFO
This structure is sent to the Main window in a WM_NOTIFY message from Item and provides all parameters required by the Main window to process control specific notifications. More...
struct | XTP_GRIDRECORDITEM_METRICS
Record item drawing metrics. More...
class | CXTPGridInplaceButtons
This class represents a collection of in-place buttons for a single item of the Grid control. More...
class | CXTPGridRecordItemEditOptions
This class represents edit options for a single item or column. More...
class | CXTPGridRecordItem
Class for working with single list cell. More...

Enumerations

enum XTPGridColumnIconAlignment {
xtpColumnTextLeft = DT_LEFT , xtpColumnTextCenter = DT_CENTER , xtpColumnTextRight = DT_RIGHT , xtpColumnTextVCenter = DT_VCENTER ,
xtpColumnTextWordBreak = DT_WORDBREAK , xtpColumnTextMask = 0xFF , xtpColumnIconLeft = 0x00100000 , xtpColumnIconCenter = 0x00200000 ,
xtpColumnIconRight = 0x00400000 , xtpColumnIconTop = 0x01000000 , xtpColumnIconVCenter = 0x02000000 , xtpColumnIconBottom = 0x04000000 ,
xtpColumnIconMask = 0x0FF00000
}
This enum defines the alignment style for the column icon and text. More...
enum XTPGridGroupRowIconAlignment {
xtpGroupRowIconUnknown = 0 , xtpGroupRowIconLeft = 0x001 , xtpGroupRowIconBeforeText = 0x002 , xtpGroupRowIconAfterText = 0x004 ,
xtpGroupRowIconRight = 0x008 , xtpGroupRowIconHmask = 0x00F , xtpGroupRowIconVTop = 0x100 , xtpGroupRowIconVCenter = 0x200 ,
xtpGroupRowIconVCenterToText = 0x400 , xtpGroupRowIconVBottom = 0x800 , xtpGroupRowIconVmask = 0xF00
}
This enum defines alignment style for the group row custom icon. More...
enum XTPGridVirtualRowFlags { xtpVirtRowUnknown = 0 , xtpVirtRowHasChildren = 0x001 , xtpVirtRowLastChild = 0x002 }
This enum defines flags for virtual row metrics. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Enumeration Type Documentation

◆ XTPGridColumnIconAlignment

enum XTPGridColumnIconAlignment

This enum defines the alignment style for the column icon and text.

Enumerator
xtpColumnTextLeft | Aligns text to the left.
xtpColumnTextCenter | Centers text horizontally in the column.
xtpColumnTextRight | Aligns text to the right.
xtpColumnTextVCenter | Centers text vertically.
xtpColumnTextWordBreak | Breaks words. Lines are automatically broken between words if a word would extend past the edge of the rectangle. A carriage return-line feed sequence also breaks the line.
xtpColumnTextMask | A mask for text alignment styles.
xtpColumnIconLeft | Aligns icon to the left.
xtpColumnIconCenter | Centers icon horizontally in the column.
xtpColumnIconRight | Aligns icon to the right.
xtpColumnIconTop | Aligns icon to the top.
xtpColumnIconVCenter | Aligns icon to the center.
xtpColumnIconBottom | Aligns icon to the bottom.
xtpColumnIconMask | A mask for icon alignment styles.

◆ XTPGridGroupRowIconAlignment

enum XTPGridGroupRowIconAlignment

This enum defines alignment style for the group row custom icon.

See also
XTP_GRIDRECORDITEM_METRICS::nGroupRowIconAlignment
Enumerator
xtpGroupRowIconUnknown | Unknown (empty) value.
xtpGroupRowIconLeft | Draw icon at the left side of group row rect.
xtpGroupRowIconBeforeText | Draw icon before caption text (between Expand/Collapse icon and text).
xtpGroupRowIconAfterText | Draw icon after caption text.
xtpGroupRowIconRight | Draw icon at the right side of group row rect.
xtpGroupRowIconHmask | A mask for horizontal alignment flags.
xtpGroupRowIconVTop | Vertical alignment: top of group row rect.
xtpGroupRowIconVCenter | Vertical alignment: center of group row rect.
xtpGroupRowIconVCenterToText | Vertical alignment: center of caption text rect.
xtpGroupRowIconVBottom | Vertical alignment: bottom of group row rect.
xtpGroupRowIconVmask | A mask for vertical alignment flags.

◆ XTPGridVirtualRowFlags

enum XTPGridVirtualRowFlags

This enum defines flags for virtual row metrics.

See also
XTP_GRIDRECORDITEM_METRICS::nVirtRowFlags
Enumerator
xtpVirtRowUnknown | Unknown (empty) value.
xtpVirtRowHasChildren | A row has children.
xtpVirtRowLastChild | A row is the last child of its parent.


Toolkit Pro: XTPGridRecordItemConstraint.h File Reference

  • Source
  • GridControl
Classes
XTPGridRecordItemConstraint.h File Reference

Go to the source code of this file.

Classes

class | CXTPGridRecordItemConstraint
CXTPGridRecordItemConstraint is a CXTPCmdTarget derived class. More...
class | CXTPGridRecordItemConstraints
CXTPGridRecordItemConstraints is a CXTPCmdTarget derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPGridRecordItemControls.h File Reference

  • Source
  • GridControl
Classes | Typedefs | Enumerations
XTPGridRecordItemControls.h File Reference

Go to the source code of this file.

Classes

struct | XTP_NM_GRIDITEMCONTROL
This structure is sent to the Main window in a WM_NOTIFY message from the item control and provides all parameters needed to process control specific notifications by the main window. More...
class | CXTPGridRecordItemControl
This class represents a generic item control and handles control's behaviour, common for all derived item controls. More...
class | CXTPGridRecordItemButton
This class represents an item button and inherits basic functionality from the CXTPGridRecordItemControl class. More...
class | CXTPGridRecordItemControls
This class represents the inplace controls of a single item. More...
class | CXTPGridRecordItemControlHookWnd
This class represents an item control hook window. More...

Typedefs

typedef CXTPArrayT< CXTPGridRecordItemControl *, CXTPGridRecordItemControl *, LPDISPATCH > CXTPGridRecordItemControls_base
This typedef is used to declare a base class for CXTPGridRecordItemControls.

Enumerations

enum | XTPGridItemControlType { xtpItemControlTypeUndefined = 0 , xtpItemControlTypeButton = 1 }
This enum defines types for the item control. More...
enum | XTPGridItemControlAlignment { xtpItemControlUnknown = 0 , xtpItemControlLeft = 0x001 , xtpItemControlRight = 0x002 }
This enum defines alignment styles for the item control. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Enumeration Type Documentation

◆ XTPGridItemControlAlignment

enum XTPGridItemControlAlignment

This enum defines alignment styles for the item control.

Enumerator
xtpItemControlUnknown | Unknown (empty) value.
xtpItemControlLeft | Aligns control to the left.
xtpItemControlRight | Aligns control to the right.

◆ XTPGridItemControlType

enum XTPGridItemControlType

This enum defines types for the item control.

Enumerator
xtpItemControlTypeUndefined | Undefined type.
xtpItemControlTypeButton | Button.


Toolkit Pro: XTPGridRecordItemRange.h File Reference

  • Source
  • GridControl
XTPGridRecordItemRange.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPGridRecords.h File Reference

  • Source
  • GridControl
Classes | Enumerations
XTPGridRecords.h File Reference

Go to the source code of this file.

Classes

class CXTPGridRecords
This class represents a grid records collection. More...

Enumerations

enum XTPGridTextSearchParms { xtpGridTextSearchExactPhrase = 1 , xtpGridTextSearchMatchCase = 2 , xtpGridTextSearchBackward = 4 , xtpGridTextSearchExactStart = 8 }
Enumeration of text search parameters. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Enumeration Type Documentation

◆ XTPGridTextSearchParms

enum XTPGridTextSearchParms

Enumeration of text search parameters.

Call CXTPGridRecords::FindRecordItem to search for a record item by text.

Example:

m_wndGrid.GetRecords()->FindRecordItem(... , xtpGridTextSearchWholeWord |
xtpGridTextSearchBackward);
See also
CXTPGridRecords::FindRecordItem
Enumerator
xtpGridTextSearchExactPhrase | Search exact phrase.
xtpGridTextSearchMatchCase | Match case during search.
xtpGridTextSearchBackward | Search backward.
xtpGridTextSearchExactStart | Search phrase starting in the beginning of the item caption.


Toolkit Pro: XTPGridRow.h File Reference

  • Source
  • GridControl
Classes
XTPGridRow.h File Reference

Go to the source code of this file.

Classes

class CXTPGridRow
CXTPGridRow class represents a row of the Grid control window. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPGridRows.h File Reference

  • Source
  • GridControl
Classes | Enumerations
XTPGridRows.h File Reference

Go to the source code of this file.

Classes

struct | XTP_NM_SELECTION_CHANGING
This struct defines data for an XTP_NM_GRID_SELCHANGING notification. More...
struct | XTP_NM_GRIDSTATECHANGED
This structure contains information for use in processing an XTP_NM_GRID_STATECHANGED message. More...
class | CXTPGridRows
This class represents a rows collection class. More...

Enumerations

enum XTPGridSelectionChangeType { xtpGridSelectionAdd , xtpGridSelectionRemove , xtpGridSelectionClear }
This enumeration defines the selection change action. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Enumeration Type Documentation

◆ XTPGridSelectionChangeType

enum XTPGridSelectionChangeType

This enumeration defines the selection change action.

See also
XTP_NM_GRID_SELCHANGING, XTP_NM_SELECTION_CHANGING
Enumerator
xtpGridSelectionAdd | Row will be added to the selected rows collection.
xtpGridSelectionRemove | Row will be removed from the selected rows collection.
xtpGridSelectionClear | The selected rows collection will be cleared.


Toolkit Pro: XTPGridSection.h File Reference

  • Source
  • GridControl
Classes | Enumerations
XTPGridSection.h File Reference

Go to the source code of this file.

Classes

class CXTPGridSection
Represents a grid section. More...

Enumerations

enum XTPGridSectionHeightMode {
xtpGridSectionHeightModeFixed , xtpGridSectionHeightModeRelative , xtpGridSectionHeightModeAuto , xtpGridSectionHeightModeExpand ,
xtpGridSectionHeightModeAutoExpand , xtpGridSectionHeightModeAutoShrink
}
Section height algorithm. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Enumeration Type Documentation

◆ XTPGridSectionHeightMode

enum XTPGridSectionHeightMode

Section height algorithm.

Enumerator
xtpGridSectionHeightModeFixed | Equal to 'px' in HTML.
xtpGridSectionHeightModeRelative | Equal to '' in HTML.
xtpGridSectionHeightModeAuto | Equal to 'auto' in HTML.
xtpGridSectionHeightModeExpand | Equal to '*' in HTML.
xtpGridSectionHeightModeAutoExpand | Minimum auto size.
xtpGridSectionHeightModeAutoShrink | Maximum auto size.


Toolkit Pro: XTPGridSections.h File Reference

  • Source
  • GridControl
Classes | Enumerations
XTPGridSections.h File Reference

Go to the source code of this file.

Classes

class CXTPGridSections
Collection of sections. More...

Enumerations

enum XTPGridSection { xtpGridSectionHeader = 0 , xtpGridSectionBody = 1 , xtpGridSectionFooter = 2 , xtpGridSectionCount = 3 }
Defines a grid section. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Enumeration Type Documentation

◆ XTPGridSection

enum XTPGridSection

Defines a grid section.

Enumerator
xtpGridSectionHeader | Index of header section.
xtpGridSectionBody | Index of body section.
xtpGridSectionFooter | Index of footer section.
xtpGridSectionCount | Number of default sections.


Toolkit Pro: XTPGridSelectedRows.h File Reference

  • Source
  • GridControl
Classes
XTPGridSelectedRows.h File Reference

Go to the source code of this file.

Classes

class CXTPGridSelectedRows
Encapsulates a collection of CXTPGridRow pointers that represent the selected rows in a Grid control. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPGridSubListControl.h File Reference

  • Source
  • GridControl
Classes
XTPGridSubListControl.h File Reference

Go to the source code of this file.

Classes

class CXTPGridSubListControl
Field chooser list box control. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPGridThickness.h File Reference

  • Source
  • GridControl
Classes
XTPGridThickness.h File Reference

Go to the source code of this file.

Classes

class CXTPGridThickness
The CXTPGridThickness class describes the thickness of the left, top, right, and bottom sides of a rectangle. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPGridTip.h File Reference

  • Source
  • GridControl
Classes
XTPGridTip.h File Reference

Go to the source code of this file.

Classes

class CXTPGridTip
The CXTPGridTip class encapsulates the functionality of a "tip control", a small pop-up window that displays a single line of text describing the hidden text when hovering an item on the grid area. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPGridView.h File Reference

  • Source
  • GridControl
Classes | Variables
XTPGridView.h File Reference

Go to the source code of this file.

Classes

class CXTPGridView
The CXTPGridView class provides an implementation of the Grid control as a view class. More...

Variables

const UINT XTP_ID_GRID_CONTROL = 100
Identifier for a Grid control child window of CXTPGridView.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Variable Documentation

◆ XTP_ID_GRID_CONTROL

const UINT XTP_ID_GRID_CONTROL = 100

Identifier for a Grid control child window of CXTPGridView.

Example:

int CXTPGridView::OnCreate(LPCREATESTRUCT lpCreateStruct)
{
   if (CView::OnCreate(lpCreateStruct) == -1)
      return -1;

   if (!m_wndGrid.Create(WS_CHILD | WS_TABSTOP | WS_VISIBLE | WM_VSCROLL,
   CRect(0, 0, 0, 0), this, XTP_ID_GRID_CONTROL))
   {
      TRACE(_T("Failed to create tab control window\n"));
      return -1;
   }
   return 0;
}
See also
XTP_NM_GRID_CHECKED, XTP_NM_GRID_COLUMNORDERCHANGED, XTP_NM_GRID_HEADER_RCLICK, XTP_NM_GRID_HYPERLINK, XTP_NM_GRID_INPLACEBUTTONDOWN, XTP_NM_GRID_SELCHANGED XTP_NM_GRID_SORTORDERCHANGED, XTP_NM_GRID_VALUECHANGED CXTPGridView, CXTPGridControl, CXTPGridHeader


Toolkit Pro: Markup Directory Reference

  • Source
  • Markup
Markup Directory Reference

Directories

Controls
DeviceContext
Extensions
Shapes
Text
Transform

Files

XTPMarkupBuilder.h
XTPMarkupContext.h
XTPMarkupDelegate.h
XTPMarkupDrawingContext.h
XTPMarkupEventHandlerMap.h
XTPMarkupFrameworkContentElement.h
XTPMarkupFrameworkElement.h
XTPMarkupIIDs.h
XTPMarkupInputElement.h
XTPMarkupKeyboardNavigation.h
XTPMarkupMouseButtonEventArgs.h
XTPMarkupMouseEventArgs.h
XTPMarkupMouseWheelEventArgs.h
XTPMarkupObject.h
XTPMarkupParser.h
XTPMarkupQueryCursorEventArgs.h
XTPMarkupResourceDictionary.h
XTPMarkupRoutedEvent.h
XTPMarkupRoutedEventArgs.h
XTPMarkupSetter.h
XTPMarkupSetterCollection.h
XTPMarkupString.h
XTPMarkupStyle.h
XTPMarkupThickness.h
XTPMarkupTools.h
XTPMarkupTrigger.h
XTPMarkupTriggerCollection.h
XTPMarkupTypedSimpleStack.h
XTPMarkupUIElement.h


Toolkit Pro: Controls Directory Reference

  • Source
  • Markup
  • Controls
Controls Directory Reference

Files

XTPMarkupBorder.h
XTPMarkupButton.h
XTPMarkupButtonBase.h
XTPMarkupCanvas.h
XTPMarkupCheckBox.h
XTPMarkupColumnDefinition.h
XTPMarkupColumnDefinitionCollection.h
XTPMarkupContentControl.h
XTPMarkupControl.h
XTPMarkupDecorator.h
XTPMarkupDefinitionBase.h
XTPMarkupDockPanel.h
XTPMarkupGrid.h
XTPMarkupGridLength.h
XTPMarkupImage.h
XTPMarkupPage.h
XTPMarkupPanel.h
XTPMarkupRadioButton.h
XTPMarkupRowDefinition.h
XTPMarkupRowDefinitionCollection.h
XTPMarkupScrollBar.h
XTPMarkupScrollViewer.h
XTPMarkupStackPanel.h
XTPMarkupTextBlock.h
XTPMarkupToggleButton.h
XTPMarkupUIElementCollection.h
XTPMarkupUniformGrid.h
XTPMarkupViewbox.h
XTPMarkupWrapPanel.h


Toolkit Pro: XTPMarkupBorder.h File Reference

  • Source
  • Markup
  • Controls
Classes
XTPMarkupBorder.h File Reference

Go to the source code of this file.

Classes

class CXTPMarkupBorder
CXTPMarkupBorder is a CXTPMarkupDecorator derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMarkupButton.h File Reference

  • Source
  • Markup
  • Controls
Classes
XTPMarkupButton.h File Reference

Go to the source code of this file.

Classes

class CXTPMarkupButton
CXTPMarkupButton is a CXTPMarkupButtonBase derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMarkupButtonBase.h File Reference

  • Source
  • Markup
  • Controls
Classes
XTPMarkupButtonBase.h File Reference

Go to the source code of this file.

Classes

class CXTPMarkupButtonBase
CXTPMarkupButtonBase is a CXTPMarkupContentControl derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMarkupCanvas.h File Reference

  • Source
  • Markup
  • Controls
XTPMarkupCanvas.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMarkupCheckBox.h File Reference

  • Source
  • Markup
  • Controls
Classes
XTPMarkupCheckBox.h File Reference

Go to the source code of this file.

Classes

class CXTPMarkupCheckBox
CXTPMarkupCheckBox is a CXTPMarkupToggleButton derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMarkupColumnDefinition.h File Reference

  • Source
  • Markup
  • Controls
Classes
XTPMarkupColumnDefinition.h File Reference

Go to the source code of this file.

Classes

class CXTPMarkupColumnDefinition
CXTPMarkupColumnDefinition is a CXTPMarkupDefinitionBase derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMarkupColumnDefinitionCollection.h File Reference

  • Source
  • Markup
  • Controls
Classes
XTPMarkupColumnDefinitionCollection.h File Reference

Go to the source code of this file.

Classes

class CXTPMarkupColumnDefinitionCollection
CXTPMarkupColumnDefinitionCollection is a CXTPMarkupDefinitionCollection derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMarkupContentControl.h File Reference

  • Source
  • Markup
  • Controls
Classes
XTPMarkupContentControl.h File Reference

Go to the source code of this file.

Classes

class CXTPMarkupContentControl
CXTPMarkupContentControl is a CXTPMarkupControl derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMarkupControl.h File Reference

  • Source
  • Markup
  • Controls
Classes
XTPMarkupControl.h File Reference

Go to the source code of this file.

Classes

class CXTPMarkupControl
CXTPMarkupControl is a CXTPMarkupFrameworkElement derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMarkupDecorator.h File Reference

  • Source
  • Markup
  • Controls
Classes
XTPMarkupDecorator.h File Reference

Go to the source code of this file.

Classes

class CXTPMarkupDecorator
CXTPMarkupDecorator is a CXTPMarkupFrameworkElement derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMarkupDefinitionBase.h File Reference

  • Source
  • Markup
  • Controls
Classes
XTPMarkupDefinitionBase.h File Reference

Go to the source code of this file.

Classes

class CXTPMarkupDefinitionBase
CXTPMarkupDefinitionBase is the base class for CXTPMarkupColumnDefinition and CXTPMarkupRowDefinition that defines constraints and definitions for grid rows and columns. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMarkupDockPanel.h File Reference

  • Source
  • Markup
  • Controls
Classes | Enumerations
XTPMarkupDockPanel.h File Reference

Go to the source code of this file.

Classes

class CXTPMarkupDockPanel
CXTPMarkupDockPanel is a CXTPMarkupPanel derived class. More...

Enumerations

enum XTPMarkupDock { xtpMarkupDockLeft , xtpMarkupDockTop , xtpMarkupDockRight , xtpMarkupDockBottom }
Defines markup docking direction. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Enumeration Type Documentation

◆ XTPMarkupDock

enum XTPMarkupDock

Defines markup docking direction.

Enumerator
xtpMarkupDockLeft | Specifies docking to the left.
xtpMarkupDockTop | Specifies docking to the top.
xtpMarkupDockRight | Specifies docking to the right.
xtpMarkupDockBottom | Specifies docking to the bottom.


Toolkit Pro: XTPMarkupGrid.h File Reference

  • Source
  • Markup
  • Controls
Classes
XTPMarkupGrid.h File Reference

Go to the source code of this file.

Classes

class | CXTPMarkupDefinitionCollection
CXTPMarkupDefinitionCollection is the base class for CXTPMarkupDefinitionCollection and CXTPMarkupDefinitionCollection. More...
class | CXTPMarkupGrid
CXTPMarkupGrid is a CXTPMarkupPanel derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMarkupGridLength.h File Reference

  • Source
  • Markup
  • Controls
Classes
XTPMarkupGridLength.h File Reference

Go to the source code of this file.

Classes

class CXTPMarkupGridLength
CXTPMarkupGridLength is a class defined length of grid rows and columns. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMarkupImage.h File Reference

  • Source
  • Markup
  • Controls
Classes
XTPMarkupImage.h File Reference

Go to the source code of this file.

Classes

class CXTPMarkupImage
CXTPMarkupImage is a CXTPMarkupFrameworkElement derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMarkupPage.h File Reference

  • Source
  • Markup
  • Controls
Classes
XTPMarkupPage.h File Reference

Go to the source code of this file.

Classes

class CXTPMarkupPage
CXTPMarkupPage is a CXTPMarkupFrameworkElement derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMarkupPanel.h File Reference

  • Source
  • Markup
  • Controls
Classes
XTPMarkupPanel.h File Reference

Go to the source code of this file.

Classes

class CXTPMarkupPanel
CXTPMarkupPanel is a CXTPMarkupFrameworkElement derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMarkupRadioButton.h File Reference

  • Source
  • Markup
  • Controls
Classes
XTPMarkupRadioButton.h File Reference

Go to the source code of this file.

Classes

class CXTPMarkupRadioButton
CXTPMarkupRadioButton is a CXTPMarkupToggleButton derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMarkupRowDefinition.h File Reference

  • Source
  • Markup
  • Controls
Classes
XTPMarkupRowDefinition.h File Reference

Go to the source code of this file.

Classes

class CXTPMarkupRowDefinition
CXTPMarkupRowDefinition is a CXTPMarkupDefinitionBase derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMarkupRowDefinitionCollection.h File Reference

  • Source
  • Markup
  • Controls
Classes
XTPMarkupRowDefinitionCollection.h File Reference

Go to the source code of this file.

Classes

class CXTPMarkupRowDefinitionCollection
CXTPMarkupRowDefinitionCollection is a CXTPMarkupDefinitionCollection derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMarkupScrollBar.h File Reference

  • Source
  • Markup
  • Controls
XTPMarkupScrollBar.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMarkupScrollViewer.h File Reference

  • Source
  • Markup
  • Controls
XTPMarkupScrollViewer.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMarkupStackPanel.h File Reference

  • Source
  • Markup
  • Controls
Classes
XTPMarkupStackPanel.h File Reference

Go to the source code of this file.

Classes

class CXTPMarkupStackPanel
CXTPMarkupStackPanel is a CXTPMarkupPanel derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMarkupTextBlock.h File Reference

  • Source
  • Markup
  • Controls
Classes | Enumerations
XTPMarkupTextBlock.h File Reference

Go to the source code of this file.

Classes

class CXTPMarkupTextBlock
CXTPMarkupTextBlock is a CXTPMarkupFrameworkElement derived class. More...

Enumerations

enum | XTPMarkupTextTrimming { xtpMarkupTextTrimmingNone , xtpMarkupTextTrimmingCharacterEllipsis , xtpMarkupTextTrimmingWordEllipsis }
Text trimming type. More...
enum | XTPMarkupTextWrapping { xtpMarkupTextNoWrap , xtpMarkupTextWrap , xtpMarkupTextWrapWithOverflow }
Text wrapping type. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Enumeration Type Documentation

◆ XTPMarkupTextTrimming

enum XTPMarkupTextTrimming

Text trimming type.

Example:

pTexBlock->SetTextTrimming(xtpMarkupTextTrimmingCharacterEllipsis)
See also
CXTPMarkupTextBlock
Enumerator
xtpMarkupTextTrimmingNone | Drawing without trimming.
xtpMarkupTextTrimmingCharacterEllipsis | Replaces part of the given string with ellipses, if necessary.
xtpMarkupTextTrimmingWordEllipsis | Replaces last word of the given string with ellipses, if necessary.

◆ XTPMarkupTextWrapping

enum XTPMarkupTextWrapping

Text wrapping type.

Example:

pTexBlock->SetTextWrapping(xtpMarkupTextWrap)
See also
CXTPMarkupTextBlock
Enumerator
xtpMarkupTextNoWrap | No line wrapping is performed.
xtpMarkupTextWrap | Line-breaking occurs if the line overflows beyond the available block width, even if the standard line breaking algorithm cannot determine any line break opportunity.
xtpMarkupTextWrapWithOverflow | Line-breaking occurs if the line overflows beyond the available block width. However, a line may overflow beyond the block width if the line breaking algorithm cannot determine a line break opportunity.


Toolkit Pro: XTPMarkupToggleButton.h File Reference

  • Source
  • Markup
  • Controls
Classes
XTPMarkupToggleButton.h File Reference

Go to the source code of this file.

Classes

class CXTPMarkupToggleButton
CXTPMarkupToggleButton is a CXTPMarkupButtonBase derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMarkupUIElementCollection.h File Reference

  • Source
  • Markup
  • Controls
Classes
XTPMarkupUIElementCollection.h File Reference

Go to the source code of this file.

Classes

class CXTPMarkupUIElementCollection
CXTPMarkupUIElementCollection is a CXTPMarkupCollection derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMarkupUniformGrid.h File Reference

  • Source
  • Markup
  • Controls
Classes
XTPMarkupUniformGrid.h File Reference

Go to the source code of this file.

Classes

class CXTPMarkupUniformGrid
CXTPMarkupUniformGrid is a CXTPMarkupPanel derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMarkupViewbox.h File Reference

  • Source
  • Markup
  • Controls
Classes
XTPMarkupViewbox.h File Reference

Go to the source code of this file.

Classes

class CXTPMarkupViewbox
CXTPMarkupViewbox is a CXTPMarkupDecorator derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMarkupWrapPanel.h File Reference

  • Source
  • Markup
  • Controls
Classes
XTPMarkupWrapPanel.h File Reference

Go to the source code of this file.

Classes

class CXTPMarkupWrapPanel
CXTPMarkupWrapPanel is a CXTPMarkupPanel derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: DeviceContext Directory Reference

  • Source
  • Markup
  • DeviceContext
DeviceContext Directory Reference

Files

XTPGdiPlus.h
XTPMarkupDeviceContext.h
XTPMarkupDeviceDependentImage.h
XTPMarkupGdiImage.h
XTPMarkupGdiPlusDeviceContext.h
XTPMarkupGdiPlusImage.h


Toolkit Pro: XTPGdiPlus.h File Reference

  • Source
  • Markup
  • DeviceContext
XTPGdiPlus.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMarkupDeviceContext.h File Reference

  • Source
  • Markup
  • DeviceContext
XTPMarkupDeviceContext.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMarkupDeviceDependentImage.h File Reference

  • Source
  • Markup
  • DeviceContext
Classes
XTPMarkupDeviceDependentImage.h File Reference

Go to the source code of this file.

Classes

struct | IXTPMarkupDeviceDependentImageSite
Describes an image site interface. More...
class | CXTPMarkupDeviceDependentImage
Implements an abstract device dependent image. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMarkupGdiImage.h File Reference

  • Source
  • Markup
  • DeviceContext
Classes
XTPMarkupGdiImage.h File Reference

Go to the source code of this file.

Classes

class CXTPMarkupGdiImage
Implements an abstract GDI device dependent image. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMarkupGdiPlusDeviceContext.h File Reference

  • Source
  • Markup
  • DeviceContext
XTPMarkupGdiPlusDeviceContext.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMarkupGdiPlusImage.h File Reference

  • Source
  • Markup
  • DeviceContext
Classes
XTPMarkupGdiPlusImage.h File Reference

Go to the source code of this file.

Classes

class CXTPMarkupGdiPlusImage
Implements an abstract GDI+ device dependent image. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: Extensions Directory Reference

  • Source
  • Markup
  • Extensions
Extensions Directory Reference

Files

XTPMarkupAmbientColorsStaticExtension.h
XTPMarkupExtension.h
XTPMarkupStaticExtension.h
XTPMarkupSystemColorsStaticExtension.h
XTPMarkupXtpScript.h


Toolkit Pro: XTPMarkupAmbientColorsStaticExtension.h File Reference

  • Source
  • Markup
  • Extensions
XTPMarkupAmbientColorsStaticExtension.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMarkupExtension.h File Reference

  • Source
  • Markup
  • Extensions
Classes
XTPMarkupExtension.h File Reference

Go to the source code of this file.

Classes

class CXTPMarkupExtension
Base class for all markup extension objects. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMarkupStaticExtension.h File Reference

  • Source
  • Markup
  • Extensions
Classes
XTPMarkupStaticExtension.h File Reference

Go to the source code of this file.

Classes

class | CXTPMarkupStaticExtension
A base class for a markup static extension composite object. More...
class | CXTPMarkupStaticExtensionProperty
A convenience base class for all static extension properties. More...
class | CXTPMarkupStaticExtensionStringProperty
A convenience class that represents a string static extension property. More...
class | CXTPMarkupStaticExtensionIntegerProperty
A convenience class that represents an integer static extension property. More...
class | CXTPMarkupStaticExtensionBooleanProperty
A convenience class that represents a boolean static extension property. More...
class | CXTPMarkupStaticExtensionDoubleProperty
A convenience class that represents a double static extension property. More...
class | CXTPMarkupStaticExtensionColorProperty
A convenience class that represents an RGB color static extension property. More...
class | CXTPMarkupStaticExtensionBrushProperty
A convenience class that represents a brush static extension property. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMarkupSystemColorsStaticExtension.h File Reference

  • Source
  • Markup
  • Extensions
Classes
XTPMarkupSystemColorsStaticExtension.h File Reference

Go to the source code of this file.

Classes

class | CXTPMarkupSystemColorStaticExtension
A property static extension object that represents a system color. More...
class | CXTPMarkupSystemColorKeyStaticExtension
A property static extension object that represents a system color key. More...
class | CXTPMarkupSystemBrushStaticExtension
A property static extension object that represents a system brush. More...
class | CXTPMarkupSystemBrushKeyStaticExtension
A property static extension object that represents a system brush key. More...
class | CXTPMarkupSystemColorsStaticExtension
A composite static extension object that represents system colors. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMarkupXtpScript.h File Reference

  • Source
  • Markup
  • Extensions
Classes
XTPMarkupXtpScript.h File Reference

Go to the source code of this file.

Classes

class CXTPMarkupXtpScript
Contains a code in the script language chosen. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: Shapes Directory Reference

  • Source
  • Markup
  • Shapes
Shapes Directory Reference

Files

XTPMarkupEllipse.h
XTPMarkupLine.h
XTPMarkupPath.h
XTPMarkupPathData.h
XTPMarkupPathGeometry.h
XTPMarkupPathGeometryBuilder.h
XTPMarkupPathGeometryFigures.h
XTPMarkupPolygon.h
XTPMarkupPolyline.h
XTPMarkupRectangle.h
XTPMarkupShape.h


Toolkit Pro: XTPMarkupEllipse.h File Reference

  • Source
  • Markup
  • Shapes
XTPMarkupEllipse.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMarkupLine.h File Reference

  • Source
  • Markup
  • Shapes
XTPMarkupLine.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMarkupPath.h File Reference

  • Source
  • Markup
  • Shapes
XTPMarkupPath.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMarkupPathData.h File Reference

  • Source
  • Markup
  • Shapes
XTPMarkupPathData.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMarkupPathGeometry.h File Reference

  • Source
  • Markup
  • Shapes
XTPMarkupPathGeometry.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMarkupPathGeometryBuilder.h File Reference

  • Source
  • Markup
  • Shapes
Enumerations
XTPMarkupPathGeometryBuilder.h File Reference

Go to the source code of this file.

Enumerations

enum XTPMarkupPathPointType { xtpMarkupPathPointTypeStart = 0 , xtpMarkupPathPointTypeLine = 1 , xtpMarkupPathPointTypeBezier = 3 , xtpMarkupPathPointTypeCloseSubpath = 0x80 }
Defines a markup path point type. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Enumeration Type Documentation

◆ XTPMarkupPathPointType

enum XTPMarkupPathPointType

Defines a markup path point type.

Enumerator
xtpMarkupPathPointTypeStart | move
xtpMarkupPathPointTypeLine | line
xtpMarkupPathPointTypeBezier | default Bezier (= cubic Bezier)
xtpMarkupPathPointTypeCloseSubpath | closed flag


Toolkit Pro: XTPMarkupPathGeometryFigures.h File Reference

  • Source
  • Markup
  • Shapes
XTPMarkupPathGeometryFigures.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMarkupPolygon.h File Reference

  • Source
  • Markup
  • Shapes
XTPMarkupPolygon.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMarkupPolyline.h File Reference

  • Source
  • Markup
  • Shapes
XTPMarkupPolyline.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMarkupRectangle.h File Reference

  • Source
  • Markup
  • Shapes
XTPMarkupRectangle.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMarkupShape.h File Reference

  • Source
  • Markup
  • Shapes
XTPMarkupShape.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: Text Directory Reference

  • Source
  • Markup
  • Text
Text Directory Reference

Files

XTPMarkupBold.h
XTPMarkupHyperlink.h
XTPMarkupInline.h
XTPMarkupInlineCollection.h
XTPMarkupInlineUIContainer.h
XTPMarkupItalic.h
XTPMarkupLineBreak.h
XTPMarkupRun.h
XTPMarkupSpan.h
XTPMarkupTextElement.h
XTPMarkupUnderline.h


Toolkit Pro: XTPMarkupBold.h File Reference

  • Source
  • Markup
  • Text
XTPMarkupBold.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMarkupHyperlink.h File Reference

  • Source
  • Markup
  • Text
XTPMarkupHyperlink.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMarkupInline.h File Reference

  • Source
  • Markup
  • Text
XTPMarkupInline.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMarkupInlineCollection.h File Reference

  • Source
  • Markup
  • Text
XTPMarkupInlineCollection.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMarkupInlineUIContainer.h File Reference

  • Source
  • Markup
  • Text
XTPMarkupInlineUIContainer.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMarkupItalic.h File Reference

  • Source
  • Markup
  • Text
XTPMarkupItalic.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMarkupLineBreak.h File Reference

  • Source
  • Markup
  • Text
XTPMarkupLineBreak.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMarkupRun.h File Reference

  • Source
  • Markup
  • Text
XTPMarkupRun.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMarkupSpan.h File Reference

  • Source
  • Markup
  • Text
XTPMarkupSpan.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMarkupTextElement.h File Reference

  • Source
  • Markup
  • Text
XTPMarkupTextElement.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMarkupUnderline.h File Reference

  • Source
  • Markup
  • Text
XTPMarkupUnderline.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: Transform Directory Reference

  • Source
  • Markup
  • Transform
Transform Directory Reference

Files

XTPMarkupGdiPlusMatrixTransform.h
XTPMarkupGdiPlusRotateTransform.h
XTPMarkupGdiPlusScaleTransform.h
XTPMarkupGdiPlusSkewTransform.h
XTPMarkupGdiPlusTransformationMatrix.h
XTPMarkupGdiPlusTransformObject.h
XTPMarkupGdiPlusTranslateTransform.h
XTPMarkupMatrixTransform.h
XTPMarkupRenderTransform.h
XTPMarkupRotateTransform.h
XTPMarkupScaleTransform.h
XTPMarkupSkewTransform.h
XTPMarkupTransform.h
XTPMarkupTransformationMatrix.h
XTPMarkupTranslateTransform.h


Toolkit Pro: XTPMarkupGdiPlusMatrixTransform.h File Reference

  • Source
  • Markup
  • Transform
Classes
XTPMarkupGdiPlusMatrixTransform.h File Reference

Go to the source code of this file.

Classes

class CXTPMarkupGdiPlusMatrixTransform
GDI+ MatrixTransform implementation. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMarkupGdiPlusRotateTransform.h File Reference

  • Source
  • Markup
  • Transform
Classes
XTPMarkupGdiPlusRotateTransform.h File Reference

Go to the source code of this file.

Classes

class CXTPMarkupGdiPlusRotateTransform
GDI+ RotateTransform implementation. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMarkupGdiPlusScaleTransform.h File Reference

  • Source
  • Markup
  • Transform
Classes
XTPMarkupGdiPlusScaleTransform.h File Reference

Go to the source code of this file.

Classes

class CXTPMarkupGdiPlusScaleTransform
GDI+ ScaleTransform implementation. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMarkupGdiPlusSkewTransform.h File Reference

  • Source
  • Markup
  • Transform
Classes
XTPMarkupGdiPlusSkewTransform.h File Reference

Go to the source code of this file.

Classes

class CXTPMarkupGdiPlusSkewTransform
GDI+ SkewTransform implementation. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMarkupGdiPlusTransformationMatrix.h File Reference

  • Source
  • Markup
  • Transform
Classes
XTPMarkupGdiPlusTransformationMatrix.h File Reference

Go to the source code of this file.

Classes

class CXTPMarkupGdiPlusTransformationMatrix
Encapsulates GDI+ transformation matrix access. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMarkupGdiPlusTransformObject.h File Reference

  • Source
  • Markup
  • Transform
Classes
XTPMarkupGdiPlusTransformObject.h File Reference

Go to the source code of this file.

Classes

class | CXTPMarkupGdiPlusTransformObjectImpl
Implements GDI+ markup matrix access and delegates the actual transformation to a derived class. More...
class | CXTPMarkupGdiPlusTransformObject< BaseTransform >
Base class for all GDI+ markup transformation objects. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMarkupGdiPlusTranslateTransform.h File Reference

  • Source
  • Markup
  • Transform
Classes
XTPMarkupGdiPlusTranslateTransform.h File Reference

Go to the source code of this file.

Classes

class CXTPMarkupGdiPlusTranslateTransform
GDI+ TranslateTransform implementation. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMarkupMatrixTransform.h File Reference

  • Source
  • Markup
  • Transform
Classes
XTPMarkupMatrixTransform.h File Reference

Go to the source code of this file.

Classes

class CXTPMarkupMatrixTransform
Default MatrixTransform implementation. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMarkupRenderTransform.h File Reference

  • Source
  • Markup
  • Transform
XTPMarkupRenderTransform.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMarkupRotateTransform.h File Reference

  • Source
  • Markup
  • Transform
Classes
XTPMarkupRotateTransform.h File Reference

Go to the source code of this file.

Classes

class CXTPMarkupRotateTransform
Default RotateTransform implementation. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMarkupScaleTransform.h File Reference

  • Source
  • Markup
  • Transform
Classes
XTPMarkupScaleTransform.h File Reference

Go to the source code of this file.

Classes

class CXTPMarkupScaleTransform
Default ScaleTransform implementation. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMarkupSkewTransform.h File Reference

  • Source
  • Markup
  • Transform
Classes
XTPMarkupSkewTransform.h File Reference

Go to the source code of this file.

Classes

class CXTPMarkupSkewTransform
Default SkewTransform implementation. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMarkupTransform.h File Reference

  • Source
  • Markup
  • Transform
Classes
XTPMarkupTransform.h File Reference

Go to the source code of this file.

Classes

class CXTPMarkupTransform
Base class for all markup transformation objects. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMarkupTransformationMatrix.h File Reference

  • Source
  • Markup
  • Transform
Classes
XTPMarkupTransformationMatrix.h File Reference

Go to the source code of this file.

Classes

class CXTPMarkupTransformationMatrix
An abstract class for device context transformation matrix. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMarkupTranslateTransform.h File Reference

  • Source
  • Markup
  • Transform
Classes
XTPMarkupTranslateTransform.h File Reference

Go to the source code of this file.

Classes

class CXTPMarkupTranslateTransform
Default TranslateTransform implementation. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMarkupBuilder.h File Reference

  • Source
  • Markup
XTPMarkupBuilder.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMarkupContext.h File Reference

  • Source
  • Markup
Classes | Enumerations
XTPMarkupContext.h File Reference

Go to the source code of this file.

Classes

struct | IXTPMarkupClientSite
Defines default implementation of the markup client site interface. More...
class | CXTPMarkupContext
CXTPMarkupContext is a standalone class used to provide common settings for Markup objects. More...

Enumerations

enum XTPMarkupSmoothingMode {
xtpMarkupSmoothingDefault , xtpMarkupSmoothingNone , xtpMarkupSmoothingHighSpeed , xtpMarkupSmoothingHighQuality ,
xtpMarkupSmoothingAntiAlias
}
Defines markup smoothing mode. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Enumeration Type Documentation

◆ XTPMarkupSmoothingMode

enum XTPMarkupSmoothingMode

Defines markup smoothing mode.

Enumerator
xtpMarkupSmoothingDefault | Default implementation defined smoothing.
xtpMarkupSmoothingNone | Smoothing is disabled for best performance.
xtpMarkupSmoothingHighSpeed | Smoothing is enabled but with trade-offs for better performance.
xtpMarkupSmoothingHighQuality | High quality smoothing is enabled.
xtpMarkupSmoothingAntiAlias | Anti-aliasing smoothing is enabled.


Toolkit Pro: XTPMarkupDelegate.h File Reference

  • Source
  • Markup
XTPMarkupDelegate.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMarkupDrawingContext.h File Reference

  • Source
  • Markup
XTPMarkupDrawingContext.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMarkupEventHandlerMap.h File Reference

  • Source
  • Markup
XTPMarkupEventHandlerMap.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMarkupFrameworkContentElement.h File Reference

  • Source
  • Markup
XTPMarkupFrameworkContentElement.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMarkupFrameworkElement.h File Reference

  • Source
  • Markup
Classes
XTPMarkupFrameworkElement.h File Reference

Go to the source code of this file.

Classes

class CXTPMarkupFrameworkElement
This class represents the provided framework-level implementation built on CXTPMarkupUIElement. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMarkupIIDs.h Source File

  • Source
  • Markup
XTPMarkupIIDs.h
1// DO NOT MODIFY MANUALLY
2// Generated on Thu 12/11/2025 at 12:46:13.82 using cj-update-iids.cmd
3
24#ifndef __XTPMarkupIIDs_H__
25# define __XTPMarkupIIDs_H__
26
27// clang-format off
28
29#define XTP_DEFINE_GUID(name,l,w1,w2,b1,b2,b3,b4,b5,b6,b7,b8) \
30 EXTERN_C __declspec(selectany) const IID XTP##name = {l,w1,w2,{b1,b2,b3,b4,b5,b6,b7,b8}}; \
31 const unsigned long XTP##name##__Data1 = (l); \
32 const unsigned short XTP##name##__Data2 = (w1); \
33 const unsigned short XTP##name##__Data3 = (w2); \
34 const unsigned char XTP##name##__Data4_0 = (b1); \
35 const unsigned char XTP##name##__Data4_1 = (b2); \
36 const unsigned char XTP##name##__Data4_2 = (b3); \
37 const unsigned char XTP##name##__Data4_3 = (b4); \
38 const unsigned char XTP##name##__Data4_4 = (b5); \
39 const unsigned char XTP##name##__Data4_5 = (b6); \
40 const unsigned char XTP##name##__Data4_6 = (b7); \
41 const unsigned char XTP##name##__Data4_7 = (b8);
42
43XTP_DEFINE_GUID(LIBID_XtremeMarkup,0xC981544E,0x1A65,0x45D5,0xB8,0x0E,0x28,0x74,0x6D,0xFE,0x80,0x55);
44XTP_DEFINE_GUID(DIID_MarkupObject,0xC0DE2430,0x95CD,0x4ADF,0xAF,0xEB,0xAD,0x45,0x6A,0xF1,0x2D,0x4D);
45XTP_DEFINE_GUID(DIID_MarkupRoutedEvent,0xC0DE2430,0xE834,0x4573,0x9B,0x17,0x9B,0x00,0x6C,0xB5,0x1E,0xFF);
46XTP_DEFINE_GUID(DIID_MarkupRoutedEventArgs,0xC0DE2430,0xCBF6,0x4150,0x91,0x44,0x5A,0xAF,0x73,0x1D,0x3A,0x96);
47XTP_DEFINE_GUID(DIID_MarkupThickness,0xC0DE2430,0x6C1F,0x4462,0xA4,0x09,0xA0,0xB1,0xD5,0xE2,0xB9,0xBF);
48XTP_DEFINE_GUID(DIID_MarkupBrush,0xC0DE2430,0xD6D4,0x43D8,0xA1,0x8E,0x0D,0x9F,0xAB,0x3E,0x71,0xEF);
49XTP_DEFINE_GUID(DIID_MarkupSolidColorBrush,0xC0DE2430,0x42D2,0x4FA0,0xA6,0xE7,0xF3,0x4D,0xD8,0xD6,0xD6,0xF4);
50XTP_DEFINE_GUID(DIID_MarkupInputElement,0xC0DE2430,0x149B,0x43C3,0xB7,0xB9,0xCC,0x4F,0xFF,0x6C,0x82,0xF6);
51XTP_DEFINE_GUID(DIID_MarkupVisual,0xC0DE2430,0xA2A5,0x4797,0x8B,0xC6,0x67,0x01,0xDF,0xD4,0xDB,0x69);
52XTP_DEFINE_GUID(DIID_MarkupUIElement,0xC0DE2430,0xC1E5,0x4B60,0xB5,0x70,0xE3,0x93,0xA1,0x1E,0x0F,0x48);
53XTP_DEFINE_GUID(DIID_MarkupFrameworkElement,0xC0DE2430,0x82A8,0x45E5,0xB0,0x2C,0xEB,0xD4,0x6D,0x43,0xEE,0xE7);
54XTP_DEFINE_GUID(DIID_MarkupBorder,0xC0DE2430,0xE1A3,0x420E,0x94,0x64,0xA1,0x23,0x7B,0xA8,0x11,0x17);
55XTP_DEFINE_GUID(DIID_MarkupViewbox,0xC0DE2430,0xE60A,0x4A41,0xB3,0x49,0x9D,0x15,0xF7,0xB5,0xF8,0x7C);
56XTP_DEFINE_GUID(DIID_MarkupTextElement,0xC0DE2430,0xCC3F,0x45EC,0xAD,0xDA,0xA2,0x54,0x1E,0x20,0x55,0x39);
57XTP_DEFINE_GUID(DIID_MarkupInline,0xC0DE2430,0x3739,0x4D25,0x9A,0xA9,0x29,0x7C,0x24,0x55,0x8F,0x37);
58XTP_DEFINE_GUID(DIID_MarkupInlineCollection,0xC0DE2430,0x6372,0x47E0,0xB2,0xB5,0xB6,0x3C,0x44,0x1A,0x36,0x71);
59XTP_DEFINE_GUID(DIID_MarkupInlineUIContainer,0xC0DE2430,0x8C61,0x46AD,0xA5,0xA2,0xC4,0x80,0x9D,0xDA,0x72,0x6E);
60XTP_DEFINE_GUID(DIID_MarkupRun,0xC0DE2430,0xDCDB,0x460F,0xB9,0xDD,0xF8,0x7A,0xA8,0x97,0x1B,0x83);
61XTP_DEFINE_GUID(DIID_MarkupSpan,0xC0DE2430,0x7CD7,0x4B0C,0x8A,0xC1,0x1E,0x1E,0xC3,0xDC,0x60,0x2E);
62XTP_DEFINE_GUID(DIID_MarkupBold,0xC0DE2430,0x0BDB,0x4C3C,0xB8,0xB2,0x35,0xD9,0x28,0x8D,0xD3,0x02);
63XTP_DEFINE_GUID(DIID_MarkupHyperlink,0xC0DE2430,0x6603,0x4B3F,0xB7,0x05,0xC2,0x6C,0xE7,0xDA,0x1C,0xAF);
64XTP_DEFINE_GUID(DIID_MarkupItalic,0xC0DE2430,0x3119,0x4DDB,0xB1,0x24,0xDB,0xFF,0xB4,0xC1,0x3A,0x37);
65XTP_DEFINE_GUID(DIID_MarkupUnderline,0xC0DE2430,0x61E4,0x4890,0xB7,0x77,0xBE,0x2F,0xD5,0x06,0xE4,0x82);
66XTP_DEFINE_GUID(DIID_MarkupTextBlock,0xC0DE2430,0x9FB0,0x4B92,0xA8,0xEF,0x73,0x94,0x1D,0xC5,0x74,0xBF);
67XTP_DEFINE_GUID(DIID_MarkupUIElementCollection,0xC0DE2430,0xD852,0x41BC,0xB4,0xC5,0xBD,0xE0,0x3C,0x46,0x06,0x9E);
68XTP_DEFINE_GUID(DIID_MarkupPanel,0xC0DE2430,0xA60D,0x4440,0x9A,0x9C,0xA6,0xFC,0x4B,0xFF,0xDD,0xB0);
69XTP_DEFINE_GUID(DIID_MarkupStackPanel,0xC0DE2430,0xC411,0x48C8,0x9B,0x14,0x6C,0x5A,0x24,0xFC,0x8F,0x9B);
70XTP_DEFINE_GUID(DIID_MarkupCanvas,0xC0DE2430,0xE554,0x4081,0x98,0x2D,0xB5,0xA0,0x65,0x9E,0x30,0x3C);
71XTP_DEFINE_GUID(DIID_MarkupDefinitionBase,0xC0DE2430,0x4AE0,0x4DA5,0x83,0x47,0x28,0xA9,0x9C,0xF6,0xCA,0x49);
72XTP_DEFINE_GUID(DIID_MarkupColumnDefinition,0xC0DE2430,0x2BCA,0x4796,0xA0,0x05,0x96,0x44,0xF6,0x6D,0x95,0xFE);
73XTP_DEFINE_GUID(DIID_MarkupRowDefinition,0xC0DE2430,0xEBD5,0x43FC,0xA9,0x62,0xB3,0xD6,0x59,0xE3,0xC1,0x6E);
74XTP_DEFINE_GUID(DIID_MarkupDefinitionCollection,0xC0DE2430,0xCE44,0x43A8,0x84,0x62,0xDD,0x46,0x97,0x7C,0x77,0xC6);
75XTP_DEFINE_GUID(DIID_MarkupGrid,0xC0DE2430,0x7D6B,0x4E85,0x93,0x0B,0x84,0x0A,0xA6,0xFB,0x83,0xA9);
76XTP_DEFINE_GUID(DIID_MarkupImage,0xC0DE2430,0xA568,0x4351,0xBD,0xD1,0x34,0xCB,0x01,0x9A,0xAB,0xB8);
77XTP_DEFINE_GUID(DIID_MarkupPage,0xC0DE2430,0x3979,0x407D,0xB2,0x00,0x2F,0x7E,0x5C,0x81,0xA8,0xC6);
78XTP_DEFINE_GUID(DIID_MarkupWindowContainer,0xC0DE2430,0x6CE8,0x49D2,0x8B,0x1A,0x95,0x1B,0xC8,0x76,0x26,0x39);
79XTP_DEFINE_GUID(DIID_MarkupDockPanel,0xC0DE2430,0x799C,0x4D00,0xA0,0x32,0x31,0xA6,0xB0,0x89,0x07,0x5D);
80XTP_DEFINE_GUID(DIID_MarkupWrapPanel,0xC0DE2430,0xF52F,0x4D6C,0xA9,0x10,0xC0,0x1D,0xDC,0x17,0x8D,0xD6);
81XTP_DEFINE_GUID(DIID_MarkupDoubleCollection,0xC0DE2430,0x8026,0x4052,0x94,0x1F,0xDC,0x32,0xF1,0x61,0x86,0x39);
82XTP_DEFINE_GUID(DIID_MarkupShape,0xC0DE2430,0x60CF,0x4041,0xB1,0x07,0x27,0x45,0xDC,0x5F,0x20,0x91);
83XTP_DEFINE_GUID(DIID_MarkupRectangle,0xC0DE2430,0x0E82,0x4E75,0x84,0x1B,0x02,0x26,0x5D,0xA4,0x50,0x53);
84XTP_DEFINE_GUID(DIID_MarkupEllipse,0xC0DE2430,0x421F,0x4D14,0x84,0xCF,0x3F,0x87,0x97,0x18,0xD7,0xC7);
85XTP_DEFINE_GUID(DIID_MarkupPolygon,0xC0DE2430,0xD58F,0x4C15,0x91,0xB3,0xFB,0xF3,0xCE,0x45,0xBB,0x65);
86XTP_DEFINE_GUID(DIID_MarkupPolyline,0xC0DE2430,0x88D7,0x44EF,0xA3,0x95,0x46,0x42,0x47,0xFD,0x60,0x6C);
87XTP_DEFINE_GUID(DIID_MarkupPath,0xC0DE2430,0x3B43,0x44E6,0xA8,0x7F,0x7F,0x29,0xAD,0x48,0xBD,0xD5);
88XTP_DEFINE_GUID(DIID_MarkupLine,0xC0DE2430,0x67CA,0x403A,0xA9,0xCE,0x43,0x43,0x74,0xBA,0x2F,0x5E);
89XTP_DEFINE_GUID(DIID_MarkupControl,0xC0DE2430,0xF8CD,0x443A,0xB2,0xA0,0xC2,0xD4,0x7E,0x42,0x18,0x18);
90XTP_DEFINE_GUID(DIID_MarkupContentControl,0xC0DE2430,0xC812,0x4210,0xA5,0x5D,0x3A,0x49,0x9E,0xD5,0xB7,0x3E);
91XTP_DEFINE_GUID(DIID_MarkupButtonBase,0xC0DE2430,0x7E30,0x4E1E,0xAE,0xC3,0xCA,0x7E,0x6B,0x16,0x84,0x12);
92XTP_DEFINE_GUID(DIID_MarkupButton,0xC0DE2430,0xBBE5,0x4E16,0xB0,0x9F,0xB2,0x1E,0x99,0xBD,0x49,0x2C);
93XTP_DEFINE_GUID(DIID_MarkupToggleButton,0xC0DE2430,0x0DC0,0x418D,0xBC,0x27,0xF4,0x1A,0x07,0x3A,0x6B,0x5D);
94XTP_DEFINE_GUID(DIID_MarkupRadioButton,0xC0DE2430,0x8A29,0x4263,0x9C,0x49,0x3E,0x5E,0x05,0xFB,0x7C,0xB3);
95XTP_DEFINE_GUID(DIID_MarkupCheckBox,0xC0DE2430,0xF745,0x494F,0x82,0xD0,0xED,0xD6,0x50,0x59,0xA9,0xDF);
96XTP_DEFINE_GUID(DIID_MarkupScrollViewer,0xC0DE2430,0xDCCA,0x4E00,0x97,0x13,0x39,0xCC,0x4B,0x08,0x7E,0xA4);
97XTP_DEFINE_GUID(DIID_MarkupUniformGrid,0xC0DE2430,0x79B9,0x4E07,0x9E,0x9E,0x90,0x89,0xB9,0x5E,0x6C,0x43);
98XTP_DEFINE_GUID(DIID_MarkupContext,0xC0DE2430,0xD073,0x4043,0xAA,0x8C,0x62,0xB5,0xBD,0x8E,0x52,0x2D);
99XTP_DEFINE_GUID(DIID__DMarkupLabel,0xC0DE2430,0x217A,0x4C64,0xAA,0x9F,0x8B,0x3B,0x49,0xEB,0x81,0x95);
100XTP_DEFINE_GUID(DIID__DMarkupLabelEvents,0xC0DE2430,0x6B68,0x4E54,0xBC,0x24,0x2F,0x89,0x1C,0x6C,0x21,0x67);
101XTP_DEFINE_GUID(CLSID_MarkupLabel,0xC0DE2430,0x0E2F,0x473A,0xB7,0x20,0xBC,0x79,0xAB,0xCC,0x74,0xFF);
102XTP_DEFINE_GUID(DIID__DMarkupLabelPropPage,0xC0DE2430,0xB209,0x4495,0x96,0xD8,0xDD,0xB0,0xE8,0xBA,0x3D,0x9A);
103XTP_DEFINE_GUID(CLSID_MarkupLabelPropPage,0xC0DE2430,0x1D82,0x405C,0x9A,0x99,0xE9,0xC3,0xBD,0x5B,0xBB,0x6A);
104XTP_DEFINE_GUID(DIID_IMarkupGlobalSettings,0xC0DE2430,0x5809,0x45B7,0x9B,0x61,0x9A,0x04,0x81,0x90,0xAE,0xDB);
105XTP_DEFINE_GUID(CLSID_MarkupGlobalSettings,0xC0DE2430,0xECC9,0x46BD,0x8A,0x7F,0x1F,0x9D,0x4C,0x30,0x76,0x2A);
106
107#undef XTP_DEFINE_GUID
108
109// clang-format on
110
111#endif // __XTPMarkupIIDs_H__


Toolkit Pro: XTPMarkupInputElement.h File Reference

  • Source
  • Markup
Classes
XTPMarkupInputElement.h File Reference

Go to the source code of this file.

Classes

class | CXTPMarkupVisual
Provides rendering support for XML Markup, which includes hit testing, coordinate transformation, and bounding box calculations. More...
struct | CXTPMarkupVisual::TransformationMatrices
A structure that optionally describes the previous and the new transformation matrices. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMarkupKeyboardNavigation.h File Reference

  • Source
  • Markup
XTPMarkupKeyboardNavigation.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMarkupMouseButtonEventArgs.h File Reference

  • Source
  • Markup
XTPMarkupMouseButtonEventArgs.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMarkupMouseEventArgs.h File Reference

  • Source
  • Markup
XTPMarkupMouseEventArgs.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMarkupMouseWheelEventArgs.h File Reference

  • Source
  • Markup
XTPMarkupMouseWheelEventArgs.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMarkupObject.h File Reference

  • Source
  • Markup
XTPMarkupObject.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMarkupParser.h File Reference

  • Source
  • Markup
XTPMarkupParser.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMarkupQueryCursorEventArgs.h File Reference

  • Source
  • Markup
XTPMarkupQueryCursorEventArgs.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMarkupResourceDictionary.h File Reference

  • Source
  • Markup
XTPMarkupResourceDictionary.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMarkupRoutedEvent.h File Reference

  • Source
  • Markup
XTPMarkupRoutedEvent.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMarkupRoutedEventArgs.h File Reference

  • Source
  • Markup
XTPMarkupRoutedEventArgs.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMarkupSetter.h File Reference

  • Source
  • Markup
XTPMarkupSetter.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMarkupSetterCollection.h File Reference

  • Source
  • Markup
XTPMarkupSetterCollection.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMarkupString.h File Reference

  • Source
  • Markup
XTPMarkupString.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMarkupStyle.h File Reference

  • Source
  • Markup
XTPMarkupStyle.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMarkupThickness.h File Reference

  • Source
  • Markup
Classes
XTPMarkupThickness.h File Reference

Go to the source code of this file.

Classes

class CXTPMarkupThickness
The CXTPMarkupThickness class describes the thickness of the left, top, right, and bottom sides of a rectangle. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMarkupTools.h File Reference

  • Source
  • Markup
XTPMarkupTools.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMarkupTrigger.h File Reference

  • Source
  • Markup
XTPMarkupTrigger.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMarkupTriggerCollection.h File Reference

  • Source
  • Markup
XTPMarkupTriggerCollection.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMarkupTypedSimpleStack.h File Reference

  • Source
  • Markup
XTPMarkupTypedSimpleStack.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPMarkupUIElement.h File Reference

  • Source
  • Markup
Classes
XTPMarkupUIElement.h File Reference

Go to the source code of this file.

Classes

class CXTPMarkupUIElement
Base class for XML Markup core level implementations. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: PropertyGrid Directory Reference

  • Source
  • PropertyGrid
PropertyGrid Directory Reference

Files

XTPPropertyGrid.h
XTPPropertyGridDefines.h
XTPPropertyGridIIDs.h
XTPPropertyGridInplaceButton.h
XTPPropertyGridInplaceEdit.h
XTPPropertyGridInplaceList.h
XTPPropertyGridItem.h
XTPPropertyGridItemBool.h
XTPPropertyGridItemColor.h
XTPPropertyGridItemExt.h
XTPPropertyGridItemFlags.h
XTPPropertyGridItemFont.h
XTPPropertyGridItemNumber.h
XTPPropertyGridItemOption.h
XTPPropertyGridItemSize.h
XTPPropertyGridPaintManager.h
XTPPropertyGridToolBar.h
XTPPropertyGridToolTip.h
XTPPropertyGridView.h


Toolkit Pro: XTPPropertyGrid.h File Reference

  • Source
  • PropertyGrid
Classes | Macros | Enumerations
XTPPropertyGrid.h File Reference

Go to the source code of this file.

Classes

class | CXTPPropertyGridUpdateContext
CXTPPropertyGridUpdateContext is a CXTPCmdTarget derived class used to save the state of the property grid such as the currently selected item, XTPPropertyGridSortOrder preference, and the expanding state of each item in the grid. More...
class | CXTPPropertyGridVerb
CXTPPropertyGridVerb is used to create a verb link similar to what is seen in Visual Studio .NET. More...
class | CXTPPropertyGridVerbs
A collection of CXTPPropertyGridVerb objects that are displayed in the verb panel. More...
class | CXTPPropertyGrid
CXTPPropertyGrid is a CWnd derived class. More...

Macros

#define XTP_PROPERTY_GRID_DISABLE_SCROLLBAR_THEMES
Starting from version 19.2, PropertyGrid supports scrollbar themes.

Enumerations

enum XTPPropertyGridUI {
xtpPropertyGridUIParentPrev = -2 , xtpPropertyGridUIViewPrev = -1 , xtpPropertyGridUIView = 0 , xtpPropertyGridUIInplaceEdit = 1 ,
xtpPropertyGridUIInplaceControl = 2 , xtpPropertyGridUIInplaceButton = 3 , xtpPropertyGridUIViewNext = 4 , xtpPropertyGridUIVerb = 5 ,
xtpPropertyGridUIParentNext = 6
}
XTPPropertyGridUI is an enumeration used by CXTPPropertyGrid during navigation of the Property Grid, items, and verbs that specifies which object should receive focus. More...
enum XTPPropertyGridHitCode { xtpPropertyGridHitError = -1 , xtpPropertyGridHitHelpSplitter = 1 , xtpPropertyGridHitVerbsSplitter = 2 , xtpPropertyGridHitFirstVerb = 3 }
XTPPropertyGridHitCode is an enumeration used by CXTPPropertyGrid to determine which part of the property grid is located at a specific point. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Macro Definition Documentation

◆ XTP_PROPERTY_GRID_DISABLE_SCROLLBAR_THEMES

#define XTP_PROPERTY_GRID_DISABLE_SCROLLBAR_THEMES

Starting from version 19.2, PropertyGrid supports scrollbar themes.

However, due to technical challenges, having scrollbar themes enabled has also introduced a number of issues for various use cases. If you are affected by any of those issues and would prefer to fallback to pre-19.2 behavior at the price of disabling scrollbar themes, then you can either uncomment the XTP_PROPERTY_GRID_DISABLE_SCROLLBAR_THEMES macro at the beginning of the XTPPropertyGrid.h file or specify that macro as defined in either the C++ compiler properties of the ToolkitPro or PropertyGrid library project for selected configurations and then re-build either the ToolkitPro or PropertyGrid project in order for the change to take effect.

Enumeration Type Documentation

◆ XTPPropertyGridHitCode

enum XTPPropertyGridHitCode

XTPPropertyGridHitCode is an enumeration used by CXTPPropertyGrid to determine which part of the property grid is located at a specific point.

CXTPPropertyGrid::HitTest is used to test a point when the user clicks on the property grid.

Example: See CXTPPropertyGrid::HitTest.

See also
CXTPPropertyGrid::HitTest, xtpPropertyGridHitError, xtpPropertyGridHitHelpSplitter, xtpPropertyGridHitVerbsSplitter, xtpPropertyGridHitFirstVerb>
Enumerator
xtpPropertyGridHitError | Indicates that neither the help splitter, the verb splitter, or a verb was clicked.
xtpPropertyGridHitHelpSplitter | Indicates that the help splitter was clicked.
xtpPropertyGridHitVerbsSplitter | Indicates that the verb splitter was clicked.
xtpPropertyGridHitFirstVerb | Indicates that a verb was clicked.

◆ XTPPropertyGridUI

enum XTPPropertyGridUI

XTPPropertyGridUI is an enumeration used by CXTPPropertyGrid during navigation of the Property Grid, items, and verbs that specifies which object should receive focus.

After the Tab key or Shift+Tab key combinations are pressed, focus will be given to the object specified in the XTPPropertyGridUI enumeration (i.e. if xtpPropertyGridUIViewNext is passed into OnNavigate when an item in the grid has focus, then the next item will receive focus.

See also
CXTPPropertyGrid::OnNavigate, CXTPPropertyGrid::NavigateItems, xtpPropertyGridUIParentPrev, xtpPropertyGridUIViewPrev, xtpPropertyGridUIView, xtpPropertyGridUIInplaceEdit, xtpPropertyGridUIInplaceButton, xtpPropertyGridUIViewNext, xtpPropertyGridUIVerb, xtpPropertyGridUIParentNext
Enumerator
xtpPropertyGridUIParentPrev | Used to indicate that focus should be given to the previous object in the tab order.
xtpPropertyGridUIViewPrev | If m_bTabItems is TRUE, used to indicate that focus should be given to the previous item in the grid. This occurs when an item has focus and Shift+Tab is pressed.
xtpPropertyGridUIView | Used to indicate that focus should be given to the Property Grid.
xtpPropertyGridUIInplaceEdit | Used to indicate that the Tab key is pressed while an in-place edit box has focus.
xtpPropertyGridUIInplaceControl | Used to indicate that the Tab key is pressed while an in-place edit box has focus.
xtpPropertyGridUIInplaceButton | Used to indicate that the Tab key is pressed while an in-place button has focus.
xtpPropertyGridUIViewNext | If m_bTabItems is TRUE, used to indicate that focus should be given to the next item in the grid. This occurs when an item has focus and the Tab key is pressed.
xtpPropertyGridUIVerb | Used to indicate that the Tab key is pressed while a verb has focus.
xtpPropertyGridUIParentNext | Used to indicate that focus should be given to the next object in the tab order.


Toolkit Pro: XTPPropertyGridDefines.h File Reference

  • Source
  • PropertyGrid
Classes | Enumerations | Variables
XTPPropertyGridDefines.h File Reference

Go to the source code of this file.

Classes

struct XTP_PROPERTYGRID_NOTIFYEDIT
This struct is passed with XTP_PGN_REQUESTEDIT, XTP_PGN_AFTEREDIT, and XTP_PGN_CANCELEDIT notifications to determine the item and its new value. More...

Enumerations

enum | XTPPropertyGridSortOrder { xtpPropertyGridSortCategorized , xtpPropertyGridSortAlphabetical , xtpPropertyGridSortNoSort }
XTPPropertyGridSortOrder is an enumeration used by CXTPPropertyGrid to determine the grouping style. More...
enum XTPPropertyGridPaintTheme {
xtpPropertyGridThemeDefault , xtpPropertyGridThemeOfficeXP , xtpPropertyGridThemeOffice2003 , xtpPropertyGridThemeOffice2013 ,
xtpPropertyGridThemeOffice2016 = xtpPropertyGridThemeOffice2013 , xtpPropertyGridThemeVisualStudio2012Light , xtpPropertyGridThemeVisualStudio2012Dark , xtpPropertyGridThemeVisualStudio2015 ,
xtpPropertyGridThemeResource , xtpPropertyGridThemeNativeWindows10 , xtpPropertyGridThemeVisualStudio2017 , xtpPropertyGridThemeVisualStudio2019 ,
xtpPropertyGridThemeVisualStudio2022 , xtpPropertyGridThemeNativeWindows11 , xtpPropertyGridThemeNativeWinXP = 100 , xtpPropertyGridThemeCool ,
xtpPropertyGridThemeSimple , xtpPropertyGridThemeDelphi , xtpPropertyGridThemeVisualStudio2005 , xtpPropertyGridThemeVisualStudio2010
}
Visual Theme enumeration. More...
enum | XTPPropertyGridBorderStyle { xtpPropertyGridBorderNone , xtpPropertyGridBorderFlat , xtpPropertyGridBorderStaticEdge , xtpPropertyGridBorderClientEdge }
Border Style enumeration. More...
enum | XTPPropertyGridInplaceButtonsStyle { xtpPropertyGridButtonsDefault , xtpPropertyGridButtonsThemed , xtpPropertyGridButtonsOfficeXP }
In-place Button Style enumeration. More...

Variables

const UINT | XTP_PGN_SORTORDER_CHANGED = 1
const UINT | XTP_PGN_SELECTION_CHANGED = 2
const UINT | XTP_PGN_ITEMVALUE_CHANGED = 3
const UINT | XTP_PGN_EDIT_CHANGED = 4
const UINT | XTP_PGN_INPLACEBUTTONDOWN = 5
const UINT | XTP_PGN_DRAWITEM = 6
const UINT | XTP_PGN_ITEMEXPANDCHANGED = 7
const UINT | XTP_PGN_DBLCLICK = 8
const UINT | XTP_PGN_RCLICK = 9
const UINT | XTP_PGN_VERB_CLICK = 10
const UINT | XTP_PGN_REQUESTEDIT = 11
const UINT | XTP_PGN_AFTEREDIT = 12
const UINT | XTP_PGN_CANCELEDIT = 13
const UINT | XTP_PGN_VSCROLL = 14
const UINT | XTP_PGN_USER = 15
const UINT | XTP_PGS_OWNERDRAW = 0x0010L
Apply this style to the property grid to use the owner draw feature.
const TCHAR | XTPPROPERTYGRID_CLASSNAME [] = _T("XTPPropertyGrid")
A NULL-terminated string used by CXTPPropertyGrid which specifies the window class name for the property grid.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Enumeration Type Documentation

◆ XTPPropertyGridBorderStyle

enum XTPPropertyGridBorderStyle

Border Style enumeration.

Example:

m_wndPropertyGrid.SetBorderStyle(xtpPropertyGridBorderClientEdge);
See also
CXTPPropertyGrid::SetBorderStyle
Enumerator
xtpPropertyGridBorderNone | Without borders.
xtpPropertyGridBorderFlat | Black flat borders.
xtpPropertyGridBorderStaticEdge | Static edge.
xtpPropertyGridBorderClientEdge | Client edge.

◆ XTPPropertyGridInplaceButtonsStyle

enum XTPPropertyGridInplaceButtonsStyle

In-place Button Style enumeration.

Example: pPaintManager->m_buttonsStyle = xtpPropertyGridButtonsOfficeXP;

See also
CXTPPropertyGrid::SetTheme, CXTPPropertyGrid::GetCurrentTheme
Enumerator
xtpPropertyGridButtonsDefault | Default button style.
xtpPropertyGridButtonsThemed | Themed button style.
xtpPropertyGridButtonsOfficeXP | Office XP button style.

◆ XTPPropertyGridPaintTheme

enum XTPPropertyGridPaintTheme

Visual Theme enumeration.

Example:

 m_wndPropertyGrid.SetTheme(xtpPropertyGridThemeVisualStudio2005);
See also
CXTPPropertyGrid::SetTheme, CXTPPropertyGrid::GetCurrentTheme
Enumerator
xtpPropertyGridThemeDefault | Default theme.
xtpPropertyGridThemeOfficeXP | Office XP style theme.
xtpPropertyGridThemeOffice2003 | Office 2003 style theme.
xtpPropertyGridThemeOffice2013 | Office 2013 style theme.
xtpPropertyGridThemeOffice2016 | Office 2016 style theme.
xtpPropertyGridThemeVisualStudio2012Light | Visual Studio 2012 Light style theme.
xtpPropertyGridThemeVisualStudio2012Dark | Visual Studio 2012 Dark style theme.
xtpPropertyGridThemeVisualStudio2015 | Visual Studio 2015 Light style theme.
xtpPropertyGridThemeResource | Office 2007 / 2010 style theme.
xtpPropertyGridThemeNativeWindows10 | Native Windows 10 style theme.
xtpPropertyGridThemeVisualStudio2017 | Visual Studio 2017 style theme.
xtpPropertyGridThemeVisualStudio2019 | Visual Studio 2019 style theme.
xtpPropertyGridThemeVisualStudio2022 | Visual Studio 2022 style theme.
xtpPropertyGridThemeNativeWindows11 | Native Windows 11 style theme.
xtpPropertyGridThemeNativeWinXP | WinXP style theme.
xtpPropertyGridThemeCool | Cool theme.
xtpPropertyGridThemeSimple | Visual Basic style theme.
xtpPropertyGridThemeDelphi | Delphi style theme.
xtpPropertyGridThemeVisualStudio2005 | Visual Studio 2005 style theme.
xtpPropertyGridThemeVisualStudio2010 | Visual Studio 2010 style theme.

◆ XTPPropertyGridSortOrder

enum XTPPropertyGridSortOrder

XTPPropertyGridSortOrder is an enumeration used by CXTPPropertyGrid to determine the grouping style.

This will specify how the items in the grid are displayed (i.e. alphabetical, not sorted, and grouped by category).

See also
CXTPPropertyGrid::SetPropertySort, CXTPPropertyGrid::GetPropertySort

Example:

XTPPropertyGridSortOrder sort = m_wndPropertyGrid.GetPropertySort();
Enumerator
xtpPropertyGridSortCategorized | Group items by category.
xtpPropertyGridSortAlphabetical | Sort items alphabetically.
xtpPropertyGridSortNoSort | Disable sorting and grouping; all items are displayed in the order that they are added to the grid.

Variable Documentation

◆ XTP_PGN_AFTEREDIT

const UINT XTP_PGN_AFTEREDIT = 12
See also
XTPWM_PROPERTYGRID_NOTIFY>

◆ XTP_PGN_CANCELEDIT

const UINT XTP_PGN_CANCELEDIT = 13
See also
XTPWM_PROPERTYGRID_NOTIFY>

◆ XTP_PGN_DBLCLICK

const UINT XTP_PGN_DBLCLICK = 8
See also
XTPWM_PROPERTYGRID_NOTIFY>

◆ XTP_PGN_DRAWITEM

const UINT XTP_PGN_DRAWITEM = 6
See also
XTPWM_PROPERTYGRID_NOTIFY>

◆ XTP_PGN_EDIT_CHANGED

const UINT XTP_PGN_EDIT_CHANGED = 4
See also
XTPWM_PROPERTYGRID_NOTIFY>

◆ XTP_PGN_INPLACEBUTTONDOWN

const UINT XTP_PGN_INPLACEBUTTONDOWN = 5
See also
XTPWM_PROPERTYGRID_NOTIFY>

◆ XTP_PGN_ITEMEXPANDCHANGED

const UINT XTP_PGN_ITEMEXPANDCHANGED = 7
See also
XTPWM_PROPERTYGRID_NOTIFY>

◆ XTP_PGN_ITEMVALUE_CHANGED

const UINT XTP_PGN_ITEMVALUE_CHANGED = 3
See also
XTPWM_PROPERTYGRID_NOTIFY>

◆ XTP_PGN_RCLICK

const UINT XTP_PGN_RCLICK = 9
See also
XTPWM_PROPERTYGRID_NOTIFY>

◆ XTP_PGN_REQUESTEDIT

const UINT XTP_PGN_REQUESTEDIT = 11
See also
XTPWM_PROPERTYGRID_NOTIFY>

◆ XTP_PGN_SELECTION_CHANGED

const UINT XTP_PGN_SELECTION_CHANGED = 2
See also
XTPWM_PROPERTYGRID_NOTIFY>

◆ XTP_PGN_SORTORDER_CHANGED

const UINT XTP_PGN_SORTORDER_CHANGED = 1
See also
XTPWM_PROPERTYGRID_NOTIFY>

◆ XTP_PGN_USER

const UINT XTP_PGN_USER = 15
See also
XTPWM_PROPERTYGRID_NOTIFY>

◆ XTP_PGN_VERB_CLICK

const UINT XTP_PGN_VERB_CLICK = 10
See also
XTPWM_PROPERTYGRID_NOTIFY>

◆ XTP_PGN_VSCROLL

const UINT XTP_PGN_VSCROLL = 14
See also
XTPWM_PROPERTYGRID_NOTIFY>

◆ XTP_PGS_OWNERDRAW

const UINT XTP_PGS_OWNERDRAW = 0x0010L

Apply this style to the property grid to use the owner draw feature.

See also
CXTPPropertyGrid::Create

Example: The following example illustrates using XTP_PGS_OWNERDRAW:

m_wndPropertyGrid.ModifyStyle(0, XTP_PGS_OWNERDRAW);

◆ XTPPROPERTYGRID_CLASSNAME

const TCHAR XTPPROPERTYGRID_CLASSNAME[] = _T("XTPPropertyGrid")

A NULL-terminated string used by CXTPPropertyGrid which specifies the window class name for the property grid.

Example:

BOOL CXTPPropertyGrid::RegisterWindowClass()
{
   WNDCLASS wndcls;
   HINSTANCE hInst = XTPGetInstanceHandle();

   if (!(GetClassInfo(hInst, XTPPROPERTYGRIDCTRL_CLASSNAME, &wndcls)))
   {
      // otherwise we need to register a new class
      wndcls.style            = CS_DBLCLKS | CS_HREDRAW | CS_VREDRAW;
      wndcls.lpfnWndProc      = DefWindowProc;
      wndcls.cbClsExtra       = wndcls.cbWndExtra = 0;
      wndcls.hInstance        = hInst;
      wndcls.hIcon            = NULL;
      wndcls.hCursor          = AfxGetApp()->LoadStandardCursor(IDC_ARROW);
      wndcls.hbrBackground    = (HBRUSH) (COLOR_3DFACE + 1);
      wndcls.lpszMenuName     = NULL;
      wndcls.lpszClassName    = XTPPROPERTYGRIDCTRL_CLASSNAME;

      if (!AfxRegisterClass(&wndcls))
      {
         AfxThrowResourceException();
         return FALSE;
      }
   }

   return TRUE;
}
See also
CXTPPropertyGrid::RegisterWindowClass


Toolkit Pro: XTPPropertyGridIIDs.h Source File

  • Source
  • PropertyGrid
XTPPropertyGridIIDs.h
1// DO NOT MODIFY MANUALLY
2// Generated on Thu 12/11/2025 at 12:46:14.68 using cj-update-iids.cmd
3
24#ifndef __XTPPropertyGridIIDs_H__
25# define __XTPPropertyGridIIDs_H__
26
27// clang-format off
28
29#define XTP_DEFINE_GUID(name,l,w1,w2,b1,b2,b3,b4,b5,b6,b7,b8) \
30 EXTERN_C __declspec(selectany) const IID XTP##name = {l,w1,w2,{b1,b2,b3,b4,b5,b6,b7,b8}}; \
31 const unsigned long XTP##name##__Data1 = (l); \
32 const unsigned short XTP##name##__Data2 = (w1); \
33 const unsigned short XTP##name##__Data3 = (w2); \
34 const unsigned char XTP##name##__Data4_0 = (b1); \
35 const unsigned char XTP##name##__Data4_1 = (b2); \
36 const unsigned char XTP##name##__Data4_2 = (b3); \
37 const unsigned char XTP##name##__Data4_3 = (b4); \
38 const unsigned char XTP##name##__Data4_4 = (b5); \
39 const unsigned char XTP##name##__Data4_5 = (b6); \
40 const unsigned char XTP##name##__Data4_6 = (b7); \
41 const unsigned char XTP##name##__Data4_7 = (b8);
42
43XTP_DEFINE_GUID(LIBID_XtremePropertyGrid,0x5B44EC52,0xB95B,0x45CF,0x98,0xFF,0xA4,0x9D,0xFE,0xED,0x5A,0x92);
44XTP_DEFINE_GUID(DIID_IPropertyGridItem,0xC0DE2430,0x29DC,0x4605,0xA5,0x17,0x4B,0x43,0x7E,0xFB,0x9B,0xB8);
45XTP_DEFINE_GUID(DIID_IPropertyGridInplaceButton,0xC0DE2430,0xA6D3,0x4538,0x95,0x30,0x91,0xCC,0xAD,0x9C,0xE5,0xA9);
46XTP_DEFINE_GUID(CLSID_PropertyGridInplaceButton,0xC0DE2430,0xD1CB,0x46E5,0xB7,0x90,0x2E,0xBC,0xD3,0xD0,0x94,0x98);
47XTP_DEFINE_GUID(DIID_IPropertyGridInplaceSliderControl,0xC0DE2430,0xD6CF,0x452D,0xA0,0x06,0x67,0x99,0x1E,0x35,0xCD,0x95);
48XTP_DEFINE_GUID(CLSID_PropertyGridInplaceSliderControl,0xC0DE2430,0x5EF7,0x4DF2,0x8C,0x7C,0x1E,0x9C,0x9D,0xF7,0xF4,0x93);
49XTP_DEFINE_GUID(DIID_IPropertyGridInplaceSpinButton,0xC0DE2430,0x2D3C,0x4DAF,0x99,0x25,0x83,0xCB,0x5A,0xAA,0xFC,0xF7);
50XTP_DEFINE_GUID(CLSID_PropertyGridInplaceSpinButton,0xC0DE2430,0x0E30,0x4A82,0x9D,0x46,0x2C,0x57,0x67,0xB9,0x8F,0x09);
51XTP_DEFINE_GUID(DIID_IPropertyGridInplaceButtons,0xC0DE2430,0xF60F,0x4729,0xB7,0x10,0x9B,0x98,0xF3,0xB0,0xB7,0x43);
52XTP_DEFINE_GUID(CLSID_PropertyGridInplaceButtons,0xC0DE2430,0xA872,0x493A,0xBE,0x1B,0xDE,0x32,0x3C,0xB9,0x87,0x50);
53XTP_DEFINE_GUID(DIID_IPropertyGridItemConstraint,0xC0DE2430,0xFE51,0x4e7e,0xB3,0xC0,0xA7,0x98,0xDD,0xD1,0x74,0xE9);
54XTP_DEFINE_GUID(CLSID_PropertyGridItemConstraint,0xC0DE2430,0x7E83,0x4DC7,0x86,0x4F,0x53,0xD5,0xD8,0xD5,0xA4,0xFE);
55XTP_DEFINE_GUID(DIID_IPropertyGridItemMetrics,0xC0DE2430,0x00A6,0x4ED5,0x92,0x61,0x8D,0x35,0x6D,0x45,0x4D,0xF6);
56XTP_DEFINE_GUID(CLSID_PropertyGridItemMetrics,0xC0DE2430,0x2D10,0x412D,0x9C,0x62,0x7B,0xAD,0xC3,0x14,0x2A,0x14);
57XTP_DEFINE_GUID(DIID_IPropertyGridItemConstraints,0xC0DE2430,0x30A2,0x44EC,0x80,0xAB,0x2E,0xD1,0x1D,0xD3,0xD9,0x98);
58XTP_DEFINE_GUID(CLSID_PropertyGridItemConstraints,0xC0DE2430,0xDFA4,0x456B,0xAC,0x35,0xC4,0x28,0xB5,0x3B,0xFD,0x12);
59XTP_DEFINE_GUID(DIID_IPropertyGridItems,0xC0DE2430,0x71D6,0x40E8,0x81,0x3D,0x81,0x28,0xA8,0xA2,0x0C,0x83);
60XTP_DEFINE_GUID(DIID_IPropertyGridItemFont,0xC0DE2430,0x62A8,0x4d96,0xB1,0x65,0xEE,0x28,0x4F,0x8A,0xB1,0x88);
61XTP_DEFINE_GUID(CLSID_PropertyGridItemFont,0xC0DE2430,0xCECD,0x496e,0x8B,0xEE,0x9A,0x49,0xF1,0xAB,0xB8,0xAC);
62XTP_DEFINE_GUID(DIID_IPropertyGridItemPicture,0xC0DE2430,0x55AC,0x4CC5,0xB3,0x54,0xE3,0x25,0x2E,0x9A,0xEF,0x9D);
63XTP_DEFINE_GUID(CLSID_PropertyGridItemPicture,0xC0DE2430,0x7F43,0x4DD0,0xBA,0x47,0xA2,0xD2,0x14,0x9D,0xF6,0x55);
64XTP_DEFINE_GUID(DIID_IPropertyGridItemDate,0xC0DE2430,0x6750,0x4257,0xA8,0x0A,0xA3,0x3F,0x44,0x02,0x23,0x95);
65XTP_DEFINE_GUID(CLSID_PropertyGridItemDate,0xC0DE2430,0xB638,0x4d37,0x81,0x5C,0xC1,0x32,0x88,0x9B,0x89,0x82);
66XTP_DEFINE_GUID(DIID_IPropertyGridItemDouble,0xC0DE2430,0x58EE,0x4502,0x8B,0x66,0x1E,0xFA,0xE9,0x42,0x6E,0x18);
67XTP_DEFINE_GUID(CLSID_PropertyGridItemDouble,0xC0DE2430,0xB960,0x47AF,0x96,0xF5,0x07,0xB6,0x57,0x3B,0x6B,0x51);
68XTP_DEFINE_GUID(DIID_IPropertyGridItemColor,0xC0DE2430,0x5932,0x4F54,0xAD,0x80,0x99,0xE1,0x4E,0x09,0xE7,0xE7);
69XTP_DEFINE_GUID(CLSID_PropertyGridItemColor,0xC0DE2430,0xC744,0x4A8C,0xB4,0xD8,0xBB,0x13,0xC0,0x33,0xF9,0x6B);
70XTP_DEFINE_GUID(DIID_IPropertyGridItemBool,0xC0DE2430,0x2D53,0x4CAA,0xA4,0x04,0x66,0xA2,0xD8,0x7C,0xCC,0x61);
71XTP_DEFINE_GUID(CLSID_PropertyGridItemBool,0xC0DE2430,0x2E7B,0x43C2,0x9E,0xFB,0xE9,0x64,0x13,0x47,0x6D,0xC1);
72XTP_DEFINE_GUID(DIID_PropertyGridItemOption,0xC0DE2430,0x395C,0x4BB0,0xB7,0x70,0x2C,0x5A,0xF9,0x59,0x7C,0xF9);
73XTP_DEFINE_GUID(CLSID_PropertyGridItem,0xC0DE2430,0xC660,0x4D3D,0xA8,0x48,0x16,0xCE,0x23,0x2A,0x4F,0x42);
74XTP_DEFINE_GUID(CLSID_PropertyGridItems,0xC0DE2430,0xE0A7,0x479C,0x97,0xD1,0x5E,0x7F,0xA1,0x52,0xD7,0x81);
75XTP_DEFINE_GUID(DIID_IPropertyGridVerb,0xC0DE2430,0x9426,0x4D53,0xA3,0x53,0x0C,0xE1,0xAA,0x1C,0x2E,0x52);
76XTP_DEFINE_GUID(CLSID_PropertyGridVerb,0xC0DE2430,0x05D8,0x4A90,0x96,0xFF,0xE4,0xE2,0x66,0x88,0x09,0xFE);
77XTP_DEFINE_GUID(DIID_IPropertyGridVerbs,0xC0DE2430,0xD1C6,0x42A2,0x8E,0x58,0x4F,0x53,0xA6,0x5D,0xEB,0xD8);
78XTP_DEFINE_GUID(CLSID_PropertyGridVerbs,0xC0DE2430,0x0B7A,0x4B38,0x88,0x87,0x02,0x75,0xBE,0x98,0x30,0x81);
79XTP_DEFINE_GUID(DIID_IPropertyGridUpdateContext,0xC0DE2430,0x42EF,0x4901,0x99,0x9B,0x1F,0xAF,0xBC,0xA1,0x26,0x53);
80XTP_DEFINE_GUID(CLSID_PropertyGridUpdateContext,0xC0DE2430,0x8FBA,0x45EA,0x81,0x7A,0x3F,0xDC,0xFE,0x56,0xE3,0xCD);
81XTP_DEFINE_GUID(DIID_PropertyGridPaintManager,0xC0DE2430,0xEBEA,0x4FC7,0x81,0x8F,0xD6,0x04,0x2A,0x01,0xDA,0x55);
82XTP_DEFINE_GUID(DIID__DPropertyGrid,0xC0DE2430,0xF160,0x4F93,0x89,0x88,0x25,0x66,0xB2,0x9C,0x7D,0x4F);
83XTP_DEFINE_GUID(DIID__DPropertyGridEvents,0xC0DE2430,0x9C8A,0x488B,0x8D,0x2D,0x3B,0x44,0x5A,0x8F,0xEA,0x60);
84XTP_DEFINE_GUID(CLSID_PropertyGrid,0xC0DE2430,0x864C,0x460A,0xBF,0x43,0x31,0xC6,0x16,0xC0,0xCA,0x12);
85XTP_DEFINE_GUID(DIID_IPropertyGridGlobalSettings,0xC0DE2430,0x136A,0x4923,0x91,0xA2,0x24,0x75,0x2F,0x24,0x9A,0xBC);
86XTP_DEFINE_GUID(CLSID_PropertyGridGlobalSettings,0xC0DE2430,0xFA65,0x4013,0xB6,0x73,0xCF,0x33,0x31,0xEC,0x7D,0xFB);
87
88#undef XTP_DEFINE_GUID
89
90// clang-format on
91
92#endif // __XTPPropertyGridIIDs_H__


Toolkit Pro: XTPPropertyGridInplaceButton.h File Reference

  • Source
  • PropertyGrid
Classes | Variables
XTPPropertyGridInplaceButton.h File Reference

Go to the source code of this file.

Classes

class | CXTPPropertyGridInplaceButton
CXTPPropertyGridInplaceButton is a CXTPCmdTarget derived class. More...
class | CXTPPropertyGridInplaceButtons
CXTPPropertyGridInplaceButtons is a CXTPCmdTarget derived class. More...

Variables

const UINT | XTP_ID_PROPERTYGRID_EXPANDBUTTON
const UINT | XTP_ID_PROPERTYGRID_COMBOBUTTON

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Variable Documentation

◆ XTP_ID_PROPERTYGRID_COMBOBUTTON

const UINT XTP_ID_PROPERTYGRID_COMBOBUTTON
Initial value:
=
101
See also
CXTPPropertyGridInplaceButton::CXTPPropertyGridInplaceButton(UINT)

◆ XTP_ID_PROPERTYGRID_EXPANDBUTTON

const UINT XTP_ID_PROPERTYGRID_EXPANDBUTTON
Initial value:
=
100
See also
CXTPPropertyGridInplaceButton::CXTPPropertyGridInplaceButton(UINT)


Toolkit Pro: XTPPropertyGridInplaceEdit.h File Reference

  • Source
  • PropertyGrid
Classes
XTPPropertyGridInplaceEdit.h File Reference

Go to the source code of this file.

Classes

class | CXTPPropertyGridInplaceEdit
CXTPPropertyGridInplaceEdit is a CEdit derived class. More...
class | CXTPPropertyGridInplaceControl
CXTPPropertyGridInplaceControl is a CWnd derived class that represents the base class for all items with in-place controls. More...
class | CXTPPropertyGridInplaceSlider
CXTPPropertyGridInplaceSlider is a CXTPPropertyGridInplaceControl derived class. More...
class | CXTPPropertyGridInplaceSpinButton
CXTPPropertyGridInplaceSpinButton is a CXTPPropertyGridInplaceControl derived class. More...
class | CXTPPropertyGridInplaceControls
CXTPPropertyGridInplaceControls is a standalone class that represents a collection of CXTPPropertyGridInplaceControl classes. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPPropertyGridInplaceList.h File Reference

  • Source
  • PropertyGrid
Classes
XTPPropertyGridInplaceList.h File Reference

Go to the source code of this file.

Classes

class | CXTPPropertyGridInplaceList
CXTPPropertyGridInplaceList is a CListBox derived class. More...
class | CXTPPropertyGridInplaceMultilineEdit
CXTPPropertyGridInplaceMultilineEdit is a CEdit derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPPropertyGridItem.h File Reference

  • Source
  • PropertyGrid
Classes | Enumerations | Variables
XTPPropertyGridItem.h File Reference

Go to the source code of this file.

Classes

class | CXTPPropertyGridItems
CXTPPropertyGridItems is a CList derived class. More...
class | CXTPPropertyGridItemConstraint
CXTPPropertyGridItemConstraint is a CXTPCmdTarget derived class. More...
class | CXTPPropertyGridItemConstraints
CXTPPropertyGridItemConstraints is a CXTPCmdTarget derived class. More...
class | CXTPPropertyGridItem
CXTPPropertyGridItem is the base class representing an item of the Property Grid control. More...
class | CXTPPropertyGridItemCategory
CXTPPropertyGridItemCategory is a CXTPPropertyGridItem derived class. More...

Enumerations

enum XTPPropertyGridItemFlags { xtpPropertyGridItemHasEdit = 1 , xtpPropertyGridItemHasExpandButton = 2 , xtpPropertyGridItemHasComboButton = 4 }
Flags that indicate which styles to set for the grid item. More...

Variables

_XTP_EXT_CLASS const int XTP_PGI_EXPAND_BORDER
This constant is used to determine the "gutter" width of the property grid.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Enumeration Type Documentation

◆ XTPPropertyGridItemFlags

enum XTPPropertyGridItemFlags

Flags that indicate which styles to set for the grid item.

Example:

pItem->SetFlags(xtpPropertyGridItemHasEdit | xtpPropertyGridItemHasComboButton);
See also
CXTPPropertyGridItem::SetFlags, OnInplaceButtonDown, xtpPropertyGridItemHasEdit, xtpPropertyGridItemHasExpandButton, xtpPropertyGridItemHasComboButton
Enumerator
xtpPropertyGridItemHasEdit | Item has an edit control.
xtpPropertyGridItemHasExpandButton | Item has an expand button.
xtpPropertyGridItemHasComboButton | Item has a combo button.

Variable Documentation

◆ XTP_PGI_EXPAND_BORDER

_XTP_EXT_CLASS const int XTP_PGI_EXPAND_BORDER
extern

This constant is used to determine the "gutter" width of the property grid.

This is the area on the left side of the grid that the expand buttons are drawn in.

This is useful when drawing owner drawn controls such as buttons and drop-down menus.

Example: The following example illustrates using XTP_PGI_EXPAND_BORDER:

void CDelphiGridPage::DrawItem(LPDRAWITEMSTRUCT lpDrawItemStruct)
{
   // code snip ...

   CRect rcText(rc);
   rcText.left = max(1, pItem->GetIndent()) * XTP_DPI_X(XTP_PGI_EXPAND_BORDER) + 3;
   rcText.right = rcCaption.right - 1;
   rcText.bottom -= 1;
   dc.DrawText(pItem->GetCaption(), rcText, DT_SINGLELINE | DT_VCENTER);
}


Toolkit Pro: XTPPropertyGridItemBool.h File Reference

  • Source
  • PropertyGrid
Classes
XTPPropertyGridItemBool.h File Reference

Go to the source code of this file.

Classes

class | CXTPPropertyGridItemBool
CXTPPropertyGridItemBool is a CXTPPropertyGridItem derived class. More...
class | CXTPPropertyGridItemEnum
CXTPPropertyGridItemEnum is a CXTPPropertyGridItem derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPPropertyGridItemColor.h File Reference

  • Source
  • PropertyGrid
Classes | Enumerations
XTPPropertyGridItemColor.h File Reference

Go to the source code of this file.

Classes

class CXTPPropertyGridItemColor
CXTPPropertyGridItemColor is a CXTPPropertyGridItem derived class. More...

Enumerations

enum XTPPropertyGridItemColorEditor { xtpPropertyGridItemColorPopup , xtpPropertyGridItemColorStandardDialog , xtpPropertyGridItemColorExtendedDialog }
Editor type for CXTPPropertyGridItemColor item. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Enumeration Type Documentation

◆ XTPPropertyGridItemColorEditor

enum XTPPropertyGridItemColorEditor

Editor type for CXTPPropertyGridItemColor item.

See also
CXTPPropertyGridItemColor, CXTPPropertyGridItemColor::SetEditorStyle

Example:

pItem->SetEditorStyle(xtpPropertyGridItemColorExtendedDialog);
Enumerator
xtpPropertyGridItemColorPopup | Color pop-up editor.
xtpPropertyGridItemColorStandardDialog | Standard color dialog editor.
xtpPropertyGridItemColorExtendedDialog | Extended color Editor editor.


Toolkit Pro: XTPPropertyGridItemExt.h File Reference

  • Source
  • PropertyGrid
Classes
XTPPropertyGridItemExt.h File Reference

Go to the source code of this file.

Classes

class | CXTPPropertyGridInplaceMonthCal
Month calendar pop-up used for CXTPPropertyGridItemDate item. More...
class | CXTPPropertyGridItemDate
CXTPPropertyGridItemDate is a CXTPPropertyGridItem derived class. More...
class | CXTPPropertyGridItemMultilineString
CXTPPropertyGridItemMultilineString is a CXTPPropertyGridItem derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPPropertyGridItemFlags.h File Reference

  • Source
  • PropertyGrid
Classes
XTPPropertyGridItemFlags.h File Reference

Go to the source code of this file.

Classes

class CXTPPropertyGridItemFlags
CXTPPropertyGridItemFlags is a CXTPPropertyGridItem derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPPropertyGridItemFont.h File Reference

  • Source
  • PropertyGrid
Classes
XTPPropertyGridItemFont.h File Reference

Go to the source code of this file.

Classes

class CXTPPropertyGridItemFont
CXTPPropertyGridItemFont is a CXTPPropertyGridItem derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPPropertyGridItemNumber.h File Reference

  • Source
  • PropertyGrid
Classes
XTPPropertyGridItemNumber.h File Reference

Go to the source code of this file.

Classes

class | CXTPPropertyGridItemNumber
CXTPPropertyGridItemNumber is a CXTPPropertyGridItem derived class. More...
class | CXTPPropertyGridItemDouble
CXTPPropertyGridItemDouble is a CXTPPropertyGridItem derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPPropertyGridItemOption.h File Reference

  • Source
  • PropertyGrid
Classes
XTPPropertyGridItemOption.h File Reference

Go to the source code of this file.

Classes

class CXTPPropertyGridItemOption
CXTPPropertyGridItemOption is a CXTPPropertyGridItem derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPPropertyGridItemSize.h File Reference

  • Source
  • PropertyGrid
Classes
XTPPropertyGridItemSize.h File Reference

Go to the source code of this file.

Classes

class | CXTPPropertyGridItemSize
CXTPPropertyGridItemSize is a CXTPPropertyGridItem derived class. More...
class | CXTPPropertyGridItemPoint
CXTPPropertyGridItemPoint is a CXTPPropertyGridItem derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPPropertyGridPaintManager.h File Reference

  • Source
  • PropertyGrid
Classes | Enumerations
XTPPropertyGridPaintManager.h File Reference

Go to the source code of this file.

Classes

class | CXTPPropertyGridItemMetrics
Standalone class used by CXTPPropertyGridPaintManager to store item metrics. More...
class | CXTPPropertyGridPaintManager
Standalone class used by CXTPPropertyGrid as the paint manager. More...
class | CXTPPropertyGridOffice2003Theme
CXTPPropertyGridOffice2003Theme is a CXTPPropertyGridPaintManager derived class. More...
class | CXTPPropertyGridOffice2007Theme
CXTPPropertyGridOffice2007Theme is a CXTPPropertyGridOffice2003Theme derived class. More...
class | CXTPPropertyGridNativeXPTheme
CXTPPropertyGridNativeXPTheme is a CXTPPropertyGridPaintManager derived class. More...
class | CXTPPropertyGridOfficeXPTheme
CXTPPropertyGridOfficeXPTheme is a CXTPPropertyGridPaintManager derived class. More...
class | CXTPPropertyGridCoolTheme
CXTPPropertyGridCoolTheme is a CXTPPropertyGridPaintManager derived class. More...
class | CXTPPropertyGridSimpleTheme
CXTPPropertyGridSimpleTheme is a CXTPPropertyGridPaintManager derived class. More...
class | CXTPPropertyGridDelphiTheme
CXTPPropertyGridDelphiTheme is a CXTPPropertyGridPaintManager derived class. More...
class | CXTPPropertyGridVisualStudio2005Theme
CXTPPropertyGridVisualStudio2005Theme is a CXTPPropertyGridPaintManager derived class. More...
class | CXTPPropertyGridVisualStudio2010Theme
CXTPPropertyGridVisualStudio2010Theme is a CXTPPropertyGridPaintManager derived class. More...
class | CXTPPropertyGridVisualStudio2012Theme
CXTPPropertyGridVisualStudio2012Theme is a CXTPPropertyGridVisualStudio2010Theme derived class. More...
class | CXTPPropertyGridOffice2013Theme
CXTPPropertyGridOffice2013Theme is a CXTPPropertyGridPaintManager derived class. More...
class | CXTPPropertyGridVisualStudio2015Theme
CXTPPropertyGridVisualStudio2015Theme is a CXTPPropertyGridVisualStudio2010Theme derived class. More...
class | CXTPPropertyGridVisualStudio2017Theme
CXTPPropertyGridVisualStudio2017Theme is a CXTPPropertyGridVisualStudio2010Theme derived class. More...
class | CXTPPropertyGridVisualStudio2019Theme
CXTPPropertyGridVisualStudio2019Theme is a CXTPPropertyGridVisualStudio2010Theme derived class. More...
class | CXTPPropertyGridVisualStudio2022Theme
CXTPPropertyGridVisualStudio2022Theme is a CXTPPropertyGridVisualStudio2010Theme derived class. More...
class | CXTPPropertyGridNativeWindows10Theme
CXTPPropertyGridNativeWindows10Theme is a CXTPPropertyGridVisualStudio2010Theme derived class. More...
class | CXTPPropertyGridNativeWindows11Theme
CXTPPropertyGridNativeWindows11Theme is a CXTPPropertyGridVisualStudio2010Theme derived class. More...

Enumerations

enum XTPPropertyGridWindow { xtpPropertyGridVerbWindow , xtpPropertyGridGridWindow , xtpPropertyGridHelpWindow }
Window identifier enumeration. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Enumeration Type Documentation

◆ XTPPropertyGridWindow

enum XTPPropertyGridWindow

Window identifier enumeration.

See also
CXTPPropertyGridPaintManager::DrawPropertyGridBorder
Enumerator
xtpPropertyGridVerbWindow | Verb window.
xtpPropertyGridGridWindow | Grid window.
xtpPropertyGridHelpWindow | Help window.


Toolkit Pro: XTPPropertyGridToolBar.h File Reference

  • Source
  • PropertyGrid
Classes
XTPPropertyGridToolBar.h File Reference

Go to the source code of this file.

Classes

class CXTPPropertyGridToolBar
CXTPPropertyGridToolBar is a CToolBar derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPPropertyGridToolTip.h File Reference

  • Source
  • PropertyGrid
Classes
XTPPropertyGridToolTip.h File Reference

Go to the source code of this file.

Classes

class CXTPPropertyGridToolTip
CXTPPropertyGridToolTip is a CWnd derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPPropertyGridView.h File Reference

  • Source
  • PropertyGrid
Classes
XTPPropertyGridView.h File Reference

Go to the source code of this file.

Classes

class CXTPPropertyGridView
CXTPPropertyGridView is a CListBox derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: Ribbon Directory Reference

  • Source
  • Ribbon
Ribbon Directory Reference

Directories

Backstage
Customize
Themes

Files

XTPRibbonBar.h
XTPRibbonBuilder.h
XTPRibbonControlTab.h
XTPRibbonGroup.h
XTPRibbonGroups.h
XTPRibbonMarkupFrameTheme.h
XTPRibbonMarkupTheme.h
XTPRibbonPaintManager.h
XTPRibbonPopups.h
XTPRibbonQuickAccessControls.h
XTPRibbonSystemButton.h
XTPRibbonTab.h
XTPRibbonTabColorSet.h
XTPRibbonTabTheme.h


Toolkit Pro: Backstage Directory Reference

  • Source
  • Ribbon
  • Backstage
Backstage Directory Reference

Directories

Pages

Files

XTPRibbonBackstageButton.h
XTPRibbonBackstageButtonThemeNativeWindows10.h
XTPRibbonBackstageButtonThemeNativeWindows11.h
XTPRibbonBackstageButtonThemeOffice2013.h
XTPRibbonBackstageButtonThemeResource.h
XTPRibbonBackstageButtonThemeVisualStudio2015.h
XTPRibbonBackstageButtonThemeVisualStudio2017.h
XTPRibbonBackstageButtonThemeVisualStudio2019.h
XTPRibbonBackstageButtonThemeVisualStudio2022.h
XTPRibbonBackstageCommand.h
XTPRibbonBackstageLabel.h
XTPRibbonBackstageMenuSeparator.h
XTPRibbonBackstagePage.h
XTPRibbonBackstagePaintManager.h
XTPRibbonBackstageSeparator.h
XTPRibbonBackstageSeparatorPaintManager.h
XTPRibbonBackstageSeparatorThemeNativeWindows10.h
XTPRibbonBackstageSeparatorThemeNativeWindows11.h
XTPRibbonBackstageSeparatorThemeOffice2013.h
XTPRibbonBackstageSeparatorThemeResource.h
XTPRibbonBackstageSeparatorThemeVisualStudio2015.h
XTPRibbonBackstageSeparatorThemeVisualStudio2017.h
XTPRibbonBackstageSeparatorThemeVisualStudio2019.h
XTPRibbonBackstageSeparatorThemeVisualStudio2022.h
XTPRibbonBackstageTab.h
XTPRibbonBackstageView.h
XTPRibbonBackstageViewThemeNativeWindows10.h
XTPRibbonBackstageViewThemeNativeWindows11.h
XTPRibbonBackstageViewThemeOffice2013.h
XTPRibbonBackstageViewThemeResource.h
XTPRibbonBackstageViewThemeVisualStudio2015.h
XTPRibbonBackstageViewThemeVisualStudio2017.h
XTPRibbonBackstageViewThemeVisualStudio2019.h
XTPRibbonBackstageViewThemeVisualStudio2022.h


Toolkit Pro: Pages Directory Reference

  • Source
  • Ribbon
  • Backstage
  • Pages
Pages Directory Reference

Files

XTPRibbonBackstagePagePrint.h
XTPRibbonBackstagePageRecent.h


Toolkit Pro: XTPRibbonBackstagePagePrint.h File Reference

  • Source
  • Ribbon
  • Backstage
  • Pages
XTPRibbonBackstagePagePrint.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPRibbonBackstagePageRecent.h File Reference

  • Source
  • Ribbon
  • Backstage
  • Pages
XTPRibbonBackstagePageRecent.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPRibbonBackstageButton.h File Reference

  • Source
  • Ribbon
  • Backstage
XTPRibbonBackstageButton.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPRibbonBackstageButtonThemeNativeWindows10.h File Reference

  • Source
  • Ribbon
  • Backstage
XTPRibbonBackstageButtonThemeNativeWindows10.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPRibbonBackstageButtonThemeNativeWindows11.h File Reference

  • Source
  • Ribbon
  • Backstage
XTPRibbonBackstageButtonThemeNativeWindows11.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPRibbonBackstageButtonThemeOffice2013.h File Reference

  • Source
  • Ribbon
  • Backstage
XTPRibbonBackstageButtonThemeOffice2013.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPRibbonBackstageButtonThemeResource.h File Reference

  • Source
  • Ribbon
  • Backstage
XTPRibbonBackstageButtonThemeResource.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPRibbonBackstageButtonThemeVisualStudio2015.h File Reference

  • Source
  • Ribbon
  • Backstage
XTPRibbonBackstageButtonThemeVisualStudio2015.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPRibbonBackstageButtonThemeVisualStudio2017.h File Reference

  • Source
  • Ribbon
  • Backstage
XTPRibbonBackstageButtonThemeVisualStudio2017.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPRibbonBackstageButtonThemeVisualStudio2019.h File Reference

  • Source
  • Ribbon
  • Backstage
XTPRibbonBackstageButtonThemeVisualStudio2019.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPRibbonBackstageButtonThemeVisualStudio2022.h File Reference

  • Source
  • Ribbon
  • Backstage
XTPRibbonBackstageButtonThemeVisualStudio2022.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPRibbonBackstageCommand.h File Reference

  • Source
  • Ribbon
  • Backstage
XTPRibbonBackstageCommand.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPRibbonBackstageLabel.h File Reference

  • Source
  • Ribbon
  • Backstage
XTPRibbonBackstageLabel.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPRibbonBackstageMenuSeparator.h File Reference

  • Source
  • Ribbon
  • Backstage
XTPRibbonBackstageMenuSeparator.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPRibbonBackstagePage.h File Reference

  • Source
  • Ribbon
  • Backstage
XTPRibbonBackstagePage.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPRibbonBackstagePaintManager.h File Reference

  • Source
  • Ribbon
  • Backstage
XTPRibbonBackstagePaintManager.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPRibbonBackstageSeparator.h File Reference

  • Source
  • Ribbon
  • Backstage
XTPRibbonBackstageSeparator.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPRibbonBackstageSeparatorPaintManager.h File Reference

  • Source
  • Ribbon
  • Backstage
XTPRibbonBackstageSeparatorPaintManager.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPRibbonBackstageSeparatorThemeNativeWindows10.h File Reference

  • Source
  • Ribbon
  • Backstage
XTPRibbonBackstageSeparatorThemeNativeWindows10.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPRibbonBackstageSeparatorThemeNativeWindows11.h File Reference

  • Source
  • Ribbon
  • Backstage
XTPRibbonBackstageSeparatorThemeNativeWindows11.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPRibbonBackstageSeparatorThemeOffice2013.h File Reference

  • Source
  • Ribbon
  • Backstage
XTPRibbonBackstageSeparatorThemeOffice2013.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPRibbonBackstageSeparatorThemeResource.h File Reference

  • Source
  • Ribbon
  • Backstage
XTPRibbonBackstageSeparatorThemeResource.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPRibbonBackstageSeparatorThemeVisualStudio2015.h File Reference

  • Source
  • Ribbon
  • Backstage
XTPRibbonBackstageSeparatorThemeVisualStudio2015.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPRibbonBackstageSeparatorThemeVisualStudio2017.h File Reference

  • Source
  • Ribbon
  • Backstage
XTPRibbonBackstageSeparatorThemeVisualStudio2017.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPRibbonBackstageSeparatorThemeVisualStudio2019.h File Reference

  • Source
  • Ribbon
  • Backstage
XTPRibbonBackstageSeparatorThemeVisualStudio2019.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPRibbonBackstageSeparatorThemeVisualStudio2022.h File Reference

  • Source
  • Ribbon
  • Backstage
XTPRibbonBackstageSeparatorThemeVisualStudio2022.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPRibbonBackstageTab.h File Reference

  • Source
  • Ribbon
  • Backstage
XTPRibbonBackstageTab.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPRibbonBackstageView.h File Reference

  • Source
  • Ribbon
  • Backstage
Classes | Enumerations
XTPRibbonBackstageView.h File Reference

Go to the source code of this file.

Classes

class CXTPRibbonBackstageView
CXTPRibbonBackstageView is a CDialog derived class used for a Backstage parent frame. More...

Enumerations

enum XTPRibbonBackstageStyle { xtpRibbonBackstageOffice2010Style , xtpRibbonBackstageOffice2013Style , xtpRibbonBackstageOffice2016Style = xtpRibbonBackstageOffice2013Style }
The backstage style. More...
enum XTPRibbonBackstageKeyboardTipResult {
xtpNoActionForThisLevel = -3 , xtpExecuteCommand = -2 , xtpHideTips = -1 , xtpShowSecondLevel = 2 ,
xtpSelectTab = 3
}
This enum defines what should be done for certain pressed key and the current tip level. More...
enum XTPRibbonBackstageKeyboardTipLevel {
xtpNoTips = -1 , xtpUserHoldAltKey = 0 , xtpFirstLevel = 1 , xtpSecondLevel = 2 ,
xtpTipsOnTabPane = 3
}
Defines the current keyboard tip show level. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Enumeration Type Documentation

◆ XTPRibbonBackstageKeyboardTipLevel

enum XTPRibbonBackstageKeyboardTipLevel

Defines the current keyboard tip show level.

Enumerator
xtpNoTips | Tips are not shown.
xtpUserHoldAltKey | User pressed and hold ALT key and previous level was xtpNoTips.
xtpFirstLevel | Show tips of first level (commands and tabs).
xtpSecondLevel | Show tips with two letters with the same first letter (commands and tabs).
xtpTipsOnTabPane | Show tips for buttons on the currently active tab.

◆ XTPRibbonBackstageKeyboardTipResult

enum XTPRibbonBackstageKeyboardTipResult

This enum defines what should be done for certain pressed key and the current tip level.

Enumerator
xtpNoActionForThisLevel | Nothing to do for the current level.
xtpExecuteCommand | Pressed key corresponds to a command and tips of first level are shown.
xtpHideTips | Hide all tips.
xtpShowSecondLevel | Show tips with two letters with the same first letter.
xtpSelectTab | Pressed key corresponds to a tab and tips of first level are shown.

◆ XTPRibbonBackstageStyle

enum XTPRibbonBackstageStyle

The backstage style.

Enumerator
xtpRibbonBackstageOffice2010Style | Office 2010 like style.
xtpRibbonBackstageOffice2013Style | Office 2013 and Office 2016 like style.
xtpRibbonBackstageOffice2016Style | Office 2016 like style.


Toolkit Pro: XTPRibbonBackstageViewThemeNativeWindows10.h File Reference

  • Source
  • Ribbon
  • Backstage
XTPRibbonBackstageViewThemeNativeWindows10.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPRibbonBackstageViewThemeNativeWindows11.h File Reference

  • Source
  • Ribbon
  • Backstage
XTPRibbonBackstageViewThemeNativeWindows11.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPRibbonBackstageViewThemeOffice2013.h File Reference

  • Source
  • Ribbon
  • Backstage
XTPRibbonBackstageViewThemeOffice2013.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPRibbonBackstageViewThemeResource.h File Reference

  • Source
  • Ribbon
  • Backstage
XTPRibbonBackstageViewThemeResource.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPRibbonBackstageViewThemeVisualStudio2015.h File Reference

  • Source
  • Ribbon
  • Backstage
XTPRibbonBackstageViewThemeVisualStudio2015.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPRibbonBackstageViewThemeVisualStudio2017.h File Reference

  • Source
  • Ribbon
  • Backstage
XTPRibbonBackstageViewThemeVisualStudio2017.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPRibbonBackstageViewThemeVisualStudio2019.h File Reference

  • Source
  • Ribbon
  • Backstage
XTPRibbonBackstageViewThemeVisualStudio2019.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPRibbonBackstageViewThemeVisualStudio2022.h File Reference

  • Source
  • Ribbon
  • Backstage
XTPRibbonBackstageViewThemeVisualStudio2022.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: Customize Directory Reference

  • Source
  • Ribbon
  • Customize
Customize Directory Reference

Files

XTPRibbonCustomizePage.h
XTPRibbonCustomizeQuickAccessPage.h
XTPRibbonCustomizeTreeCtrl.h
XTPRibbonRenameDialog.h


Toolkit Pro: XTPRibbonCustomizePage.h File Reference

  • Source
  • Ribbon
  • Customize
Classes
XTPRibbonCustomizePage.h File Reference

Go to the source code of this file.

Classes

class CXTPRibbonCustomizePage
CXTPRibbonCustomizePage is a CPropertyPage derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPRibbonCustomizeQuickAccessPage.h File Reference

  • Source
  • Ribbon
  • Customize
Classes
XTPRibbonCustomizeQuickAccessPage.h File Reference

Go to the source code of this file.

Classes

class CXTPRibbonCustomizeQuickAccessPage
CXTPRibbonCustomizeQuickAccessPage is a CPropertyPage derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPRibbonCustomizeTreeCtrl.h File Reference

  • Source
  • Ribbon
  • Customize
XTPRibbonCustomizeTreeCtrl.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPRibbonRenameDialog.h File Reference

  • Source
  • Ribbon
  • Customize
XTPRibbonRenameDialog.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: Themes Directory Reference

  • Source
  • Ribbon
  • Themes
Themes Directory Reference

Files

XTPRibbonThemeNativeWindows10.h
XTPRibbonThemeNativeWindows11.h
XTPRibbonThemeOffice2007System.h
XTPRibbonThemeOffice2013.h
XTPRibbonThemeResource.h
XTPRibbonThemeVisualStudio2015.h
XTPRibbonThemeVisualStudio2017.h
XTPRibbonThemeVisualStudio2019.h
XTPRibbonThemeVisualStudio2022.h


Toolkit Pro: XTPRibbonThemeNativeWindows10.h File Reference

  • Source
  • Ribbon
  • Themes
Classes
XTPRibbonThemeNativeWindows10.h File Reference

Go to the source code of this file.

Classes

class CXTPRibbonThemeNativeWindows10
CXTPRibbonThemeNativeWindows10 is a CXTPRibbonOffice2013Theme derived class used to represent a Native Windows 10 ribbon theme. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPRibbonThemeNativeWindows11.h File Reference

  • Source
  • Ribbon
  • Themes
Classes
XTPRibbonThemeNativeWindows11.h File Reference

Go to the source code of this file.

Classes

class CXTPRibbonThemeNativeWindows11
CXTPRibbonThemeNativeWindows11 is a CXTPRibbonOffice2013Theme derived class used to represent a Native Windows 10 ribbon theme. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPRibbonThemeOffice2007System.h File Reference

  • Source
  • Ribbon
  • Themes
Classes
XTPRibbonThemeOffice2007System.h File Reference

Go to the source code of this file.

Classes

class CXTPRibbonThemeOffice2007System
CXTPRibbonThemeOffice2007System is a CXTPRibbonMarkupTheme derived class used to represent an Office 2007 ribbon theme. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPRibbonThemeOffice2013.h File Reference

  • Source
  • Ribbon
  • Themes
Classes
XTPRibbonThemeOffice2013.h File Reference

Go to the source code of this file.

Classes

struct | XTPRIBBON_HEADER_COLOR
Struct used to define context tab colors for the ribbon control. More...
class | CXTPRibbonOffice2013Theme
CXTPRibbonOffice2013Theme is a CXTPRibbonMarkupTheme derived class used to represent an Office 2013 ribbon theme. More...
class | CXTPRibbonOffice2013Theme::CThemeStaticExtension
Helper class used to define variables to be used by XAML Markup code. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPRibbonThemeResource.h File Reference

  • Source
  • Ribbon
  • Themes
Classes
XTPRibbonThemeResource.h File Reference

Go to the source code of this file.

Classes

class CXTPRibbonThemeResource
CXTPRibbonThemeResource is a CXTPRibbonPaintManager derived class used to represent a Resource .DLL ribbon theme. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPRibbonThemeVisualStudio2015.h File Reference

  • Source
  • Ribbon
  • Themes
Classes
XTPRibbonThemeVisualStudio2015.h File Reference

Go to the source code of this file.

Classes

class CXTPRibbonThemeVisualStudio2015
CXTPRibbonThemeVisualStudio2015 is a CXTPRibbonOffice2013Theme derived class used to represent a Visual Studio 2015 ribbon theme. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPRibbonThemeVisualStudio2017.h File Reference

  • Source
  • Ribbon
  • Themes
Classes
XTPRibbonThemeVisualStudio2017.h File Reference

Go to the source code of this file.

Classes

class CXTPRibbonThemeVisualStudio2017
CXTPRibbonThemeVisualStudio2017 is a CXTPRibbonOffice2013Theme derived class used to represent a Visual Studio 2017 ribbon theme. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPRibbonThemeVisualStudio2019.h File Reference

  • Source
  • Ribbon
  • Themes
Classes
XTPRibbonThemeVisualStudio2019.h File Reference

Go to the source code of this file.

Classes

class CXTPRibbonThemeVisualStudio2019
CXTPRibbonThemeVisualStudio2019 is a CXTPRibbonOffice2013Theme derived class used to represent a Visual Studio 2019 ribbon theme. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPRibbonThemeVisualStudio2022.h File Reference

  • Source
  • Ribbon
  • Themes
Classes
XTPRibbonThemeVisualStudio2022.h File Reference

Go to the source code of this file.

Classes

class CXTPRibbonThemeVisualStudio2022
CXTPRibbonThemeVisualStudio2022 is a CXTPRibbonOffice2013Theme derived class used to represent a Visual Studio 2022 ribbon theme. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPRibbonBar.h File Reference

  • Source
  • Ribbon
Classes | Macros
XTPRibbonBar.h File Reference

Go to the source code of this file.

Classes

class CXTPRibbonBar
CXTPRibbonBar is a CXTPMenuBar derived class. More...

Macros

#define WM_XTP_RIBBONMINIMIZE (WM_XTP_COMMANDBARS_BASE + 25)
The WM_XTP_RIBBONMINIMIZE message is sent to the CXTPCommandBars site when the user minimizes the ribbon bar.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPRibbonBuilder.h File Reference

  • Source
  • Ribbon
XTPRibbonBuilder.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPRibbonControlTab.h File Reference

  • Source
  • Ribbon
Classes
XTPRibbonControlTab.h File Reference

Go to the source code of this file.

Classes

struct | NMXTPTABCHANGE
Structure used as a parameter for TCN_SELCHANGING and TCN_SELCHANGE messages when a Ribbon tab is changed. More...
class | CXTPRibbonControlTab
CXTPRibbonControlTab is a CXTPTabManager derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPRibbonGroup.h File Reference

  • Source
  • Ribbon
Classes | Enumerations
XTPRibbonGroup.h File Reference

Go to the source code of this file.

Classes

class CXTPRibbonGroup
Represents a single group that is added to a CXTPRibbonTab. More...

Enumerations

enum XTPRibbonGroupReductionLevels { xtpRibbonGroupReductionDisabled = 1 , xtpRibbonGroupFullCaptionDontHide = 2 , xtpRibbonGroupReduceCaptionDontHide = 3 , xtpRibbonGroupFullReduction = 4 }
Defines ribbon group reduction levels. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Enumeration Type Documentation

◆ XTPRibbonGroupReductionLevels

enum XTPRibbonGroupReductionLevels

Defines ribbon group reduction levels.

Enumerator
xtpRibbonGroupReductionDisabled | Do not reduce.
xtpRibbonGroupFullCaptionDontHide | Do not hide captions and do not allow hiding at all when reduced.
xtpRibbonGroupReduceCaptionDontHide | Hide captions, but do not allow hiding at all when reduced.
xtpRibbonGroupFullReduction | Hide captions and allow hiding when reduced.


Toolkit Pro: XTPRibbonGroups.h File Reference

  • Source
  • Ribbon
Classes
XTPRibbonGroups.h File Reference

Go to the source code of this file.

Classes

class CXTPRibbonGroups
Represents a collection of CXTPRibbonGroup objects. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPRibbonMarkupFrameTheme.h File Reference

  • Source
  • Ribbon
Classes
XTPRibbonMarkupFrameTheme.h File Reference

Go to the source code of this file.

Classes

class CXTPRibbonMarkupFrameTheme
The CXTPRibbonMarkupFrameTheme class is used to enable a system style theme for Command Bars. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPRibbonMarkupTheme.h File Reference

  • Source
  • Ribbon
Classes | Enumerations
XTPRibbonMarkupTheme.h File Reference

Go to the source code of this file.

Classes

class CXTPRibbonMarkupTheme
CXTPRibbonMarkupTheme class. More...

Enumerations

enum XTPRibbonThemePart {
xtpRibbonFrameCaptionActive , xtpRibbonFrameCaptionInactive , xtpRibbonFrameSystemButtonNormal , xtpRibbonFrameSystemButtonPopuped ,
xtpRibbonFrameSystemButtonSelected , xtpRibbonGroupControlEntry , xtpRibbonGroupControlEntryLeft , xtpRibbonGroupControlEntryLeftRight ,
xtpRibbonGroupControlEntryRight , xtpRibbonGroupRect , xtpRibbonGroupRectBlue , xtpRibbonGroupRectCyan ,
xtpRibbonGroupRectGreen , xtpRibbonGroupRectOrange , xtpRibbonGroupRectPurple , xtpRibbonGroupRectRed ,
xtpRibbonGroupRectYellow , xtpRibbonScrollButtonLeft , xtpRibbonScrollButtonRight , xtpRibbonTabHighlighted ,
xtpRibbonTabSelected , xtpRibbonTabSelectedFocused , xtpRibbonTabSelectedHighlighted , xtpRibbonContextTabBlue ,
xtpRibbonContextTabCyan , xtpRibbonContextTabGreen , xtpRibbonContextTabOrange , xtpRibbonContextTabPurple ,
xtpRibbonContextTabRed , xtpRibbonContextTabYellow , xtpRibbonTabSelectedBlue , xtpRibbonTabSelectedFocusedBlue ,
xtpRibbonTabSelectedHighlightedBlue , xtpRibbonTabSelectedCyan , xtpRibbonTabSelectedFocusedCyan , xtpRibbonTabSelectedHighlightedCyan ,
xtpRibbonTabSelectedGreen , xtpRibbonTabSelectedFocusedGreen , xtpRibbonTabSelectedHighlightedGreen , xtpRibbonTabSelectedOrange ,
xtpRibbonTabSelectedFocusedOrange , xtpRibbonTabSelectedHighlightedOrange , xtpRibbonTabSelectedPurple , xtpRibbonTabSelectedFocusedPurple ,
xtpRibbonTabSelectedHighlightedPurple , xtpRibbonTabSelectedRed , xtpRibbonTabSelectedFocusedRed , xtpRibbonTabSelectedHighlightedRed ,
xtpRibbonTabSelectedYellow , xtpRibbonTabSelectedFocusedYellow , xtpRibbonTabSelectedHighlightedYellow , xtpRibbonFrameCaptionBackstageLeft ,
xtpRibbonFrameCaptionBackstageRight , xtpRibbonThemePartCount
}
Defines ribbon theme parts. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Enumeration Type Documentation

◆ XTPRibbonThemePart

enum XTPRibbonThemePart

Defines ribbon theme parts.

Enumerator
xtpRibbonFrameCaptionActive | Specifies an active frame caption ribbon theme part.
xtpRibbonFrameCaptionInactive | Specifies an inactive frame caption ribbon theme part.
xtpRibbonFrameSystemButtonNormal | Specifies a normal frame system button ribbon theme part.
xtpRibbonFrameSystemButtonPopuped | Specifies a popup frame system button ribbon theme part.
xtpRibbonFrameSystemButtonSelected | Specifies a selected frame system button ribbon theme part.
xtpRibbonGroupControlEntry | Specifies a group control entry ribbon theme part.
xtpRibbonGroupControlEntryLeft | Specifies a group control entry left ribbon theme part.
xtpRibbonGroupControlEntryLeftRight | Specifies a group control entry left-right ribbon theme part.
xtpRibbonGroupControlEntryRight | Specifies a group control entry right ribbon theme part.
xtpRibbonGroupRect | Specifies a group rectangle ribbon theme part.
xtpRibbonGroupRectBlue | Specifies a blue group rectangle ribbon theme part.
xtpRibbonGroupRectCyan | Specifies a cyan group rectangle ribbon theme part.
xtpRibbonGroupRectGreen | Specifies a green group rectangle ribbon theme part.
xtpRibbonGroupRectOrange | Specifies an orange group rectangle ribbon theme part.
xtpRibbonGroupRectPurple | Specifies a purple group rectangle ribbon theme part.
xtpRibbonGroupRectRed | Specifies a red group rectangle ribbon theme part.
xtpRibbonGroupRectYellow | Specifies a yellow group rectangle ribbon theme part.
xtpRibbonScrollButtonLeft | Specifies a left scroll button ribbon theme part.
xtpRibbonScrollButtonRight | Specifies a right scroll button ribbon theme part.
xtpRibbonTabHighlighted | Specifies a highlighted tab ribbon theme part.
xtpRibbonTabSelected | Specifies a selected tab ribbon theme part.
xtpRibbonTabSelectedFocused | Specifies a focused selected tab ribbon theme part.
xtpRibbonTabSelectedHighlighted | Specifies a highlighted selected tab ribbon theme part.
xtpRibbonContextTabBlue | Specifies a blue context tab ribbon theme part.
xtpRibbonContextTabCyan | Specifies a cyan context tab ribbon theme part.
xtpRibbonContextTabGreen | Specifies a green context tab ribbon theme part.
xtpRibbonContextTabOrange | Specifies an orange context tab ribbon theme part.
xtpRibbonContextTabPurple | Specifies a purple context tab ribbon theme part.
xtpRibbonContextTabRed | Specifies a red context tab ribbon theme part.
xtpRibbonContextTabYellow | Specifies a yellow context tab ribbon theme part.
xtpRibbonTabSelectedBlue | Specifies a selected blue tab ribbon theme part.
xtpRibbonTabSelectedFocusedBlue | Specifies a selected focuse blue tab ribbon theme part.
xtpRibbonTabSelectedHighlightedBlue | Specifies a selected highlighted blue tab ribbon theme part.
xtpRibbonTabSelectedCyan | Specifies a selected cyan tab ribbon theme part.
xtpRibbonTabSelectedFocusedCyan | Specifies a selected focused cyan tab ribbon theme part.
xtpRibbonTabSelectedHighlightedCyan | Specifies a selected highlighted cyan tab ribbon theme part.
xtpRibbonTabSelectedGreen | Specifies a selected green tab ribbon theme part.
xtpRibbonTabSelectedFocusedGreen | Specifies a selected focused green tab ribbon theme part.
xtpRibbonTabSelectedHighlightedGreen | Specifies a selected highlighted green tab ribbon theme part.
xtpRibbonTabSelectedOrange | Specifies a selected orange tab ribbon theme part.
xtpRibbonTabSelectedFocusedOrange | Specifies a selected focused orange tab ribbon theme part.
xtpRibbonTabSelectedHighlightedOrange | Specifies a selected highlighted orange tab ribbon theme part.
xtpRibbonTabSelectedPurple | Specifies a selected purple tab ribbon theme part.
xtpRibbonTabSelectedFocusedPurple | Specifies a selected focused purple tab ribbon theme part.
xtpRibbonTabSelectedHighlightedPurple | Specifies a selected highlighted purple tab ribbon theme part.
xtpRibbonTabSelectedRed | Specifies a selected red tab ribbon theme part.
xtpRibbonTabSelectedFocusedRed | Specifies a selected focused red tab ribbon theme part.
xtpRibbonTabSelectedHighlightedRed | Specifies a selected highlighted red tab ribbon theme part.
xtpRibbonTabSelectedYellow | Specifies a selected yellow tab ribbon theme part.
xtpRibbonTabSelectedFocusedYellow | Specifies a selected focused yellow tab ribbon theme part.
xtpRibbonTabSelectedHighlightedYellow | Specifies a selected highlighted yellow tab ribbon theme part.
xtpRibbonFrameCaptionBackstageLeft | Specifies a frame caption backstage left ribbon theme part.
xtpRibbonFrameCaptionBackstageRight | Specifies a frame caption backstage right ribbon theme part.
xtpRibbonThemePartCount | The number of theme parts.


Toolkit Pro: XTPRibbonPaintManager.h File Reference

  • Source
  • Ribbon
Classes
XTPRibbonPaintManager.h File Reference

Go to the source code of this file.

Classes

class CXTPRibbonPaintManager
Standalone class used by CXTPRibbonBar as a paint manager. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPRibbonPopups.h File Reference

  • Source
  • Ribbon
Classes
XTPRibbonPopups.h File Reference

Go to the source code of this file.

Classes

class CXTPRibbonTabPopupToolBar
Implements a pop-up when the Ribbon is in minimzed mode. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPRibbonQuickAccessControls.h File Reference

  • Source
  • Ribbon
Classes
XTPRibbonQuickAccessControls.h File Reference

Go to the source code of this file.

Classes

class | CXTPRibbonControls
CXTPRibbonControls is a CXTPControls derived class. More...
class | CXTPRibbonQuickAccessControls
CXTPRibbonQuickAccessControls is a CXTPControls derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPRibbonSystemButton.h File Reference

  • Source
  • Ribbon
Classes
XTPRibbonSystemButton.h File Reference

Go to the source code of this file.

Classes

class | CXTPRibbonControlSystemButton
CXTPRibbonControlSystemButton is a CXTPControlPopup derived class used as a system button for a Ribbon Bar. More...
class | CXTPRibbonControlSystemPopupBarButton
CXTPRibbonControlSystemPopupBarButton is a CXTPControlButton derived class used in a system pop-up bar for bottom option buttons. More...
class | CXTPRibbonSystemPopupBar
CXTPRibbonSystemPopupBar is a CXTPPopupBar derived class used as a system pop-up bar for a Ribbon Bar. More...
class | CXTPRibbonSystemPopupBarPage
CXTPRibbonSystemPopupBarPage is a CXTPPopupBar derived class used as a system pop-up bar page of a Ribbon Bar. More...
class | CXTPRibbonControlSystemPopupBarListCaption
CXTPRibbonControlSystemPopupBarListCaption is a CXTPControl derived class used in a Ribbon system pop-up to draw captions of enumerable controls. More...
class | CXTPRibbonControlSystemPopupBarListItem
CXTPRibbonControlSystemPopupBarListItem is a CXTPControlButton derived class used in a Ribbon system pop-up to draw buttons of enumerable controls. More...
class | CXTPRibbonControlSystemPopupBarPinableListItem
CXTPRibbonControlSystemPopupBarPinableListItem is a CXTPRibbonControlSystemPopupBarListItem derived class used in a Ribbon system pop-up to draw recent file list items. More...
class | CXTPRibbonControlSystemRecentFileList
CXTPRibbonControlSystemRecentFileList is a CXTPRibbonControlSystemPopupBarListCaption derived class used in a Ribbon system pop-up to draw recent file list controls. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPRibbonTab.h File Reference

  • Source
  • Ribbon
Classes | Enumerations
XTPRibbonTab.h File Reference

Go to the source code of this file.

Classes

class CXTPRibbonTab
Represents a tab in the Ribbon Bar. More...

Enumerations

enum XTPRibbonTabContextColor {
xtpRibbonTabContextColorNone , xtpRibbonTabContextColorBlue , xtpRibbonTabContextColorYellow , xtpRibbonTabContextColorGreen ,
xtpRibbonTabContextColorRed , xtpRibbonTabContextColorPurple , xtpRibbonTabContextColorCyan , xtpRibbonTabContextColorOrange
}
Ribbon tab context color. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Enumeration Type Documentation

◆ XTPRibbonTabContextColor

enum XTPRibbonTabContextColor

Ribbon tab context color.

Example:

pTab = pRibbonBar->AddTab(ID_TAB_CHARTFORMAT);
pTab->SetContextTab(xtpRibbonTabContextColorGreen, ID_TAB_CONTEXTCHART);
See also
CXTPRibbonTab, CXTPRibbonTab::SetContextColor
Enumerator
xtpRibbonTabContextColorNone | Default color.
xtpRibbonTabContextColorBlue | Blue context color.
xtpRibbonTabContextColorYellow | Yellow context color.
xtpRibbonTabContextColorGreen | Green context color.
xtpRibbonTabContextColorRed | Red context color.
xtpRibbonTabContextColorPurple | Purple context color.
xtpRibbonTabContextColorCyan | Cyan context color.
xtpRibbonTabContextColorOrange | Orange context color.


Toolkit Pro: XTPRibbonTabColorSet.h File Reference

  • Source
  • Ribbon
XTPRibbonTabColorSet.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPRibbonTabTheme.h File Reference

  • Source
  • Ribbon
XTPRibbonTabTheme.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: ShortcutBar Directory Reference

  • Source
  • ShortcutBar
ShortcutBar Directory Reference

Directories

Themes

Files

XTPShortcutBar.h
XTPShortcutBarAnimation.h
XTPShortcutBarIIDs.h
XTPShortcutBarPaintManager.h
XTPShortcutBarPane.h
XTPShortcutBarPopup.h


Toolkit Pro: Themes Directory Reference

  • Source
  • ShortcutBar
  • Themes
Themes Directory Reference

Files

XTPShortcutBarNativeWindows10Theme.h
XTPShortcutBarNativeWindows11Theme.h
XTPShortcutBarNativeWinXPTheme.h
XTPShortcutBarOffice2000Theme.h
XTPShortcutBarOffice2003Theme.h
XTPShortcutBarOffice2013Theme.h
XTPShortcutBarOfficeXPTheme.h
XTPShortcutBarResourceTheme.h
XTPShortcutBarVisualStudio2015Theme.h
XTPShortcutBarVisualStudio2017Theme.h
XTPShortcutBarVisualStudio2019Theme.h
XTPShortcutBarVisualStudio2022Theme.h


Toolkit Pro: XTPShortcutBarNativeWindows10Theme.h File Reference

  • Source
  • ShortcutBar
  • Themes
Classes
XTPShortcutBarNativeWindows10Theme.h File Reference

Go to the source code of this file.

Classes

class CXTPShortcutBarNativeWindows10Theme
CXTPShortcutBarNativeWindows10Theme is a CXTPShortcutBarOffice2013Theme derived class that represents a Native Windows 10 shortcut bar theme. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPShortcutBarNativeWindows11Theme.h File Reference

  • Source
  • ShortcutBar
  • Themes
Classes
XTPShortcutBarNativeWindows11Theme.h File Reference

Go to the source code of this file.

Classes

class CXTPShortcutBarNativeWindows11Theme
CXTPShortcutBarNativeWindows11Theme is a CXTPShortcutBarOffice2013Theme derived class that represents a Native Windows 10 shortcut bar theme. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPShortcutBarNativeWinXPTheme.h File Reference

  • Source
  • ShortcutBar
  • Themes
Classes
XTPShortcutBarNativeWinXPTheme.h File Reference

Go to the source code of this file.

Classes

class CXTPShortcutBarNativeWinXPTheme
CXTPShortcutBarNativeWinXPTheme is a CXTPShortcutBarOffice2003Theme derived class that represents a Native Windows XP shortcut bar theme. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPShortcutBarOffice2000Theme.h File Reference

  • Source
  • ShortcutBar
  • Themes
Classes
XTPShortcutBarOffice2000Theme.h File Reference

Go to the source code of this file.

Classes

class CXTPShortcutBarOffice2000Theme
CXTPShortcutBarOffice2000Theme is a CXTPShortcutBarPaintManager derived class that represents an Office 2000 shortcut bar theme. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPShortcutBarOffice2003Theme.h File Reference

  • Source
  • ShortcutBar
  • Themes
Classes
XTPShortcutBarOffice2003Theme.h File Reference

Go to the source code of this file.

Classes

class CXTPShortcutBarOffice2003Theme
CXTPShortcutBarOffice2003Theme is a CXTPShortcutBarPaintManager derived class that represents an Office 2003 shortcut bar theme. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPShortcutBarOffice2013Theme.h File Reference

  • Source
  • ShortcutBar
  • Themes
Classes
XTPShortcutBarOffice2013Theme.h File Reference

Go to the source code of this file.

Classes

class CXTPShortcutBarOffice2013Theme
CXTPShortcutBarOffice2013Theme is a CXTPShortcutBarResourceTheme derived class that represents an Office 2013 shortcut bar theme. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPShortcutBarOfficeXPTheme.h File Reference

  • Source
  • ShortcutBar
  • Themes
Classes
XTPShortcutBarOfficeXPTheme.h File Reference

Go to the source code of this file.

Classes

class CXTPShortcutBarOfficeXPTheme
CXTPShortcutBarOfficeXPTheme is a CXTPShortcutBarPaintManager derived class that represents an Office XP shortcut bar theme. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPShortcutBarResourceTheme.h File Reference

  • Source
  • ShortcutBar
  • Themes
Classes
XTPShortcutBarResourceTheme.h File Reference

Go to the source code of this file.

Classes

class CXTPShortcutBarResourceTheme
CXTPShortcutBarResourceTheme is a CXTPShortcutBarOffice2003Theme derived class that represents the Office 2007, 2010 and 2012 shortcut bar themes. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPShortcutBarVisualStudio2015Theme.h File Reference

  • Source
  • ShortcutBar
  • Themes
Classes
XTPShortcutBarVisualStudio2015Theme.h File Reference

Go to the source code of this file.

Classes

class CXTPShortcutBarVisualStudio2015Theme
CXTPShortcutBarVisualStudio2015Theme is a CXTPShortcutBarOffice2013Theme derived class that represents a Visual Studio 2015 shortcut bar theme. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPShortcutBarVisualStudio2017Theme.h File Reference

  • Source
  • ShortcutBar
  • Themes
Classes
XTPShortcutBarVisualStudio2017Theme.h File Reference

Go to the source code of this file.

Classes

class CXTPShortcutBarVisualStudio2017Theme
CXTPShortcutBarVisualStudio2017Theme is a CXTPShortcutBarOffice2013Theme derived class that represents a Visual Studio 2017 shortcut bar theme. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPShortcutBarVisualStudio2019Theme.h File Reference

  • Source
  • ShortcutBar
  • Themes
Classes
XTPShortcutBarVisualStudio2019Theme.h File Reference

Go to the source code of this file.

Classes

class CXTPShortcutBarVisualStudio2019Theme
CXTPShortcutBarVisualStudio2019Theme is a CXTPShortcutBarOffice2013Theme derived class that represents a Visual Studio 2019 shortcut bar theme. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPShortcutBarVisualStudio2022Theme.h File Reference

  • Source
  • ShortcutBar
  • Themes
Classes
XTPShortcutBarVisualStudio2022Theme.h File Reference

Go to the source code of this file.

Classes

class CXTPShortcutBarVisualStudio2022Theme
CXTPShortcutBarVisualStudio2022Theme is a CXTPShortcutBarOffice2013Theme derived class that represents a Visual Studio 2022 shortcut bar theme. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPShortcutBar.h File Reference

  • Source
  • ShortcutBar
Classes | Variables
XTPShortcutBar.h File Reference

Go to the source code of this file.

Classes

class | CXTPShortcutBarItem
CXTPShortcutBarItem is a base class that represents an item for a shortcut bar control. More...
class | CXTPShortcutBar
CXTPShortcutBar is a CWnd derived class used to implement an Outlook 2003 shortcut bar control style. More...

Variables

const UINT | XTP_SBN_SELECTION_CHANGING = 1
XTP_SBN_SELECTION_CHANGED is used to indicate that the selection has changed in the shortcut bar.
const UINT | XTP_SBN_SELECTION_CHANGED = 3
XTP_SBN_SELECTION_CHANGING is used to indicate that the value for the selection is currently changing.
const UINT | XTP_SBN_RCLICK = 2
XTP_SBN_RCLICK is used to indicate that the user has pressed the right mouse button on a shortcut bar item.
const UINT | XTP_SBN_MINIMIZEBUTTONCLICKED = 4
XTP_SBN_MINIMIZEBUTTONCLICKED is used to indicate that the user has pressed the minimize button inside a pane caption.
const UINT | XTPWM_SHORTCUTBAR_NOTIFY = (WM_USER + 9190 + 1)
The XTPWM_SHORTCUTBAR_NOTIFY message is sent to the CXTPShortcutBar owner window whenever an action occurs within the shortcut bar.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Variable Documentation

◆ XTP_SBN_MINIMIZEBUTTONCLICKED

const UINT XTP_SBN_MINIMIZEBUTTONCLICKED = 4

XTP_SBN_MINIMIZEBUTTONCLICKED is used to indicate that the user has pressed the minimize button inside a pane caption.

XTP_SBN_MINIMIZEBUTTONCLICKED is sent in an XTPWM_SHORTCUTBAR_NOTIFY message to the owner window when the user clicks the minimize button.

Example: See example of XTPWM_SHORTCUTBAR_NOTIFY

See also
XTPWM_SHORTCUTBAR_NOTIFY, XTP_SBN_SELECTION_CHANGING, CXTPShortcutBar::ShowMinimizeButton

◆ XTP_SBN_RCLICK

const UINT XTP_SBN_RCLICK = 2

XTP_SBN_RCLICK is used to indicate that the user has pressed the right mouse button on a shortcut bar item.

XTP_SBN_RCLICK is sent in an XTPWM_SHORTCUTBAR_NOTIFY message to the owner window when the user right clicks on a shortcut bar item.

Example: See example of XTPWM_SHORTCUTBAR_NOTIFY

See also
XTPWM_SHORTCUTBAR_NOTIFY, XTP_SBN_SELECTION_CHANGING

◆ XTP_SBN_SELECTION_CHANGED

const UINT XTP_SBN_SELECTION_CHANGED = 3

XTP_SBN_SELECTION_CHANGING is used to indicate that the value for the selection is currently changing.

XTP_SBN_SELECTION_CHANGING is sent in an XTPWM_SHORTCUTBAR_NOTIFY message to the owner window when the selection is in the process of changing.

The selection changes either when a user clicks on a shortcut bar item or when the items are navigated with the arrow keys.

See also
XTPWM_SHORTCUTBAR_NOTIFY, XTP_SBN_RCLICK

◆ XTP_SBN_SELECTION_CHANGING

const UINT XTP_SBN_SELECTION_CHANGING = 1

XTP_SBN_SELECTION_CHANGED is used to indicate that the selection has changed in the shortcut bar.

XTP_SBN_SELECTION_CHANGED is sent in an XTPWM_SHORTCUTBAR_NOTIFY message to the owner window when the selection has changed.

The selection changes either when a user clicks on a shortcut bar item or when the items are navigated with the arrow keys.

Example: See example of XTPWM_SHORTCUTBAR_NOTIFY

See also
XTPWM_SHORTCUTBAR_NOTIFY, XTP_SBN_RCLICK

◆ XTPWM_SHORTCUTBAR_NOTIFY

const UINT XTPWM_SHORTCUTBAR_NOTIFY = (WM_USER + 9190 + 1)

The XTPWM_SHORTCUTBAR_NOTIFY message is sent to the CXTPShortcutBar owner window whenever an action occurs within the shortcut bar.

Parameters
nAction | wParam value that specifies a shortcut bar value that indicates the user's request.
pItem | lParam value that points to a CXTPShortcutBarItem object that contains information about the specified item. This pointer should never be NULL.

nAction parameter can be one of the following values: XTP_SBN_SELECTION_CHANGING: Indicates that the selection has changed in the shortcut bar. XTP_SBN_RCLICK: Indicates the user pressed the right mouse button on the shortcut bar item.

Returns
TRUE if the application should process this message, otherwise FALSE.

Example: Here is an example of how an application would process an XTPWM_SHORTCUTBAR_NOTIFY message:

BEGIN_MESSAGE_MAP(CMainFrame, CFrameWnd)
    //{{AFX_MSG_MAP(CMainFrame)
    ON_MESSAGE(XTPWM_SHORTCUTBAR_NOTIFY, OnShortcutBarNotify)
    //}}AFX_MSG_MAP
END_MESSAGE_MAP()

LRESULT CMainFrame::OnShortcutBarNotify(WPARAM wParam, LPARAM lParam)
{
   switch (wParam)
   {
      case XTP_SBN_SELECTION_CHANGING:
      {
         CXTPShortcutBarItem* pItem = (CXTPShortcutBarItem*)lParam;
         TRACE(_T("Selection Changing. Item.Caption = %s\n"), pItem->GetCaption());

         // TODO You can return -1 to ignore changing

      }
      return TRUE;
      case XTP_SBN_RCLICK:
         {
         CXTPShortcutBarItem* pItem =
         m_wndShortcutBar.HitTest(XTP_POINT_FROM_LPARAM(lParam)); if (pItem)
         {
            TRACE(_T("RClick. Item.ID = %i\n"), pItem->GetID());

            CMenu mnu;
            mnu.LoadMenu(IDR_POPUP_MENU);

            m_wndShortcutBar.ClientToScreen(&point);

            CXTPCommandBars::TrackPopupMenu(mnu.GetSubMenu(0), 0, point.x, point.y,
            AfxGetMainWnd());

         }
      }
      return TRUE;

   }
   return 0;
}
See also
XTP_SBN_SELECTION_CHANGING, XTP_SBN_RCLICK, CXTPShortcutBar


Toolkit Pro: XTPShortcutBarAnimation.h File Reference

  • Source
  • ShortcutBar
XTPShortcutBarAnimation.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPShortcutBarIIDs.h Source File

  • Source
  • ShortcutBar
XTPShortcutBarIIDs.h
1// DO NOT MODIFY MANUALLY
2// Generated on Thu 12/11/2025 at 12:46:16.44 using cj-update-iids.cmd
3
24#ifndef __XTPShortcutBarIIDs_H__
25# define __XTPShortcutBarIIDs_H__
26
27// clang-format off
28
29#define XTP_DEFINE_GUID(name,l,w1,w2,b1,b2,b3,b4,b5,b6,b7,b8) \
30 EXTERN_C __declspec(selectany) const IID XTP##name = {l,w1,w2,{b1,b2,b3,b4,b5,b6,b7,b8}}; \
31 const unsigned long XTP##name##__Data1 = (l); \
32 const unsigned short XTP##name##__Data2 = (w1); \
33 const unsigned short XTP##name##__Data3 = (w2); \
34 const unsigned char XTP##name##__Data4_0 = (b1); \
35 const unsigned char XTP##name##__Data4_1 = (b2); \
36 const unsigned char XTP##name##__Data4_2 = (b3); \
37 const unsigned char XTP##name##__Data4_3 = (b4); \
38 const unsigned char XTP##name##__Data4_4 = (b5); \
39 const unsigned char XTP##name##__Data4_5 = (b6); \
40 const unsigned char XTP##name##__Data4_6 = (b7); \
41 const unsigned char XTP##name##__Data4_7 = (b8);
42
43XTP_DEFINE_GUID(LIBID_XtremeShortcutBar,0xC8E5842E,0x102B,0x4289,0x9D,0x57,0x3B,0x3F,0x5B,0x5E,0x15,0xD3);
44XTP_DEFINE_GUID(DIID_IShortcutBarItem,0xC0DE2430,0x9CD0,0x4dbc,0x8B,0xDD,0x91,0xA7,0x3D,0x4B,0xB4,0xF6);
45XTP_DEFINE_GUID(CLSID_ShortcutBarItem,0xC0DE2430,0x75A3,0x4c24,0xA2,0x38,0xA2,0xD3,0x0D,0x11,0x1B,0xC9);
46XTP_DEFINE_GUID(DIID_IShortcutBarColorSet,0xC0DE2430,0xF506,0x468F,0xAB,0x95,0x8B,0x98,0x4B,0xBB,0x50,0x9B);
47XTP_DEFINE_GUID(CLSID_ShortcutBarColorSet,0xC0DE2430,0x92F4,0x4af7,0x92,0x31,0xF1,0x58,0xD1,0xA0,0x35,0xC3);
48XTP_DEFINE_GUID(DIID_IShortcutBarPaintManager,0xC0DE2430,0x39E2,0x4C24,0x81,0xED,0xB4,0x46,0x3B,0xE2,0x4B,0x0E);
49XTP_DEFINE_GUID(CLSID_ShortcutBarPaintManager,0xC0DE2430,0x36FB,0x4302,0xA6,0x06,0x03,0x89,0xC4,0x6D,0x91,0xF6);
50XTP_DEFINE_GUID(DIID__DShortcutBar,0xC0DE2430,0xFE32,0x4F5F,0x9E,0xB4,0x39,0x1C,0x2E,0x91,0xE5,0x6D);
51XTP_DEFINE_GUID(DIID__DShortcutBarEvents,0xC0DE2430,0xC48C,0x4F2D,0x95,0x56,0x81,0x96,0x8D,0xE6,0xCB,0x8F);
52XTP_DEFINE_GUID(CLSID_ShortcutBar,0xC0DE2430,0xEFB8,0x41DD,0x82,0xCC,0x96,0x1B,0x34,0x0D,0xE4,0x9D);
53XTP_DEFINE_GUID(DIID__DShortcutCaption,0xC0DE2430,0xF9F8,0x4f8f,0x85,0xEF,0x6D,0x7C,0x69,0x19,0xFC,0x55);
54XTP_DEFINE_GUID(DIID__DShortcutCaptionEvents,0xC0DE2430,0xCFAE,0x4354,0x85,0x51,0xB8,0xDC,0x49,0x38,0xE5,0x43);
55XTP_DEFINE_GUID(CLSID_ShortcutCaption,0xC0DE2430,0x9140,0x450E,0xB5,0x1B,0x89,0xEF,0x63,0xD2,0xDD,0x2E);
56XTP_DEFINE_GUID(DIID_IShortcutBarGlobalSettings,0xC0DE2430,0x5D90,0x4892,0x95,0x7E,0xBB,0x22,0x01,0xEB,0xF0,0x1D);
57XTP_DEFINE_GUID(CLSID_ShortcutBarGlobalSettings,0xC0DE2430,0x2460,0x41B0,0x89,0xA3,0xE3,0x64,0x2D,0xF2,0x10,0xDC);
58
59#undef XTP_DEFINE_GUID
60
61// clang-format on
62
63#endif // __XTPShortcutBarIIDs_H__


Toolkit Pro: XTPShortcutBarPaintManager.h File Reference

  • Source
  • ShortcutBar
Classes | Enumerations
XTPShortcutBarPaintManager.h File Reference

Go to the source code of this file.

Classes

class CXTPShortcutBarPaintManager
CXTPShortcutBarPaintManager is a standalone class used as a paint manager for a shortcut bar control. More...

Enumerations

enum XTPShortcutBarPaintTheme {
xtpShortcutThemeResource = 3 , xtpShortcutThemeOffice2000 = 0 , xtpShortcutThemeOfficeXP = 1 , xtpShortcutThemeOffice2003 = 2 ,
xtpShortcutThemeOffice2007 = 3 , xtpShortcutThemeOffice2010 = 3 , xtpShortcutThemeNativeWinXP = 4 , xtpShortcutThemeOffice2013 = 5 ,
xtpShortcutThemeOffice2016 = xtpShortcutThemeOffice2013 , xtpShortcutThemeVisualStudio2015 = 6 , xtpShortcutThemeNativeWindows10 = 7 , xtpShortcutThemeVisualStudio2017 = 8 ,
xtpShortcutThemeVisualStudio2019 = 9 , xtpShortcutThemeVisualStudio2022 = 10 , xtpShortcutThemeNativeWindows11 = 11
}
XTPShortcutBarPaintTheme is an enumeration used by CXTPShortcutBar to set the theme of the control. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Enumeration Type Documentation

◆ XTPShortcutBarPaintTheme

enum XTPShortcutBarPaintTheme

XTPShortcutBarPaintTheme is an enumeration used by CXTPShortcutBar to set the theme of the control.

Example:

m_wndShortcutBar.SetTheme(xtpShortcutThemeOffice2003);
See also
CXTPShortcutBar::GetCurrentTheme, CXTPShortcutBar::SetTheme, CXTPShortcutBar::SetCustomTheme, xtpShortcutThemeOffice2000, xtpShortcutThemeOfficeXP, xtpShortcutThemeOffice2003
Enumerator
xtpShortcutThemeResource | Office 2007/2010 style theme.
xtpShortcutThemeOffice2000 | Office 2000 style theme.
xtpShortcutThemeOfficeXP | Office XP style theme.
xtpShortcutThemeOffice2003 | Office 2003 style theme.
xtpShortcutThemeOffice2007 | Office 2007 style theme.
xtpShortcutThemeOffice2010 | Office 2010 style theme.
xtpShortcutThemeNativeWinXP | Native Windows XP theme.
xtpShortcutThemeOffice2013 | Office 2013 style theme.
xtpShortcutThemeOffice2016 | Office 2016 style theme.
xtpShortcutThemeVisualStudio2015 | Visual Studio 2015 style theme.
xtpShortcutThemeNativeWindows10 | Native Windows 10 theme.
xtpShortcutThemeVisualStudio2017 | Visual Studio 2017 style theme.
xtpShortcutThemeVisualStudio2019 | Visual Studio 2019 style theme.
xtpShortcutThemeVisualStudio2022 | Visual Studio 2022 style theme.
xtpShortcutThemeNativeWindows11 | Native Windows 11 theme.


Toolkit Pro: XTPShortcutBarPane.h File Reference

  • Source
  • ShortcutBar
Classes
XTPShortcutBarPane.h File Reference

Go to the source code of this file.

Classes

class | CXTPShortcutBarPaneItem
CXTPShortcutBarPaneItem is a base class that represents an item for a shortcut bar pane. More...
class | CXTPShortcutBarPane
CXTPShortcutBarPane is a CWnd derived class used as a client area for a shortcut bar control. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPShortcutBarPopup.h File Reference

  • Source
  • ShortcutBar
XTPShortcutBarPopup.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: SkinFramework Directory Reference

  • Source
  • SkinFramework
SkinFramework Directory Reference

Directories

ApiHook

Files

XTPSkinDrawTools.h
XTPSkinFrameworkIIDs.h
XTPSkinImage.h
XTPSkinManager.h
XTPSkinManagerApiHook.h
XTPSkinManagerColorFilter.h
XTPSkinManagerModuleList.h
XTPSkinManagerResource.h
XTPSkinManagerSchema.h
XTPSkinManagerSchemaCodes.h
XTPSkinObject.h
XTPSkinObjectButton.h
XTPSkinObjectComboBox.h
XTPSkinObjectEdit.h
XTPSkinObjectFrame.h
XTPSkinObjectHeader.h
XTPSkinObjectListBox.h
XTPSkinObjectListView.h
XTPSkinObjectMDI.h
XTPSkinObjectMenu.h
XTPSkinObjectProgress.h
XTPSkinObjectReBar.h
XTPSkinObjectScrollBar.h
XTPSkinObjectSpin.h
XTPSkinObjectStatusBar.h
XTPSkinObjectTab.h
XTPSkinObjectToolBar.h
XTPSkinObjectTrackBar.h
XTPSkinObjectTreeView.h


Toolkit Pro: ApiHook Directory Reference

  • Source
  • SkinFramework
  • ApiHook
ApiHook Directory Reference

Files

XTPSkinManagerApiHookBase.h
XTPSkinManagerApiHookConfig.h
XTPSkinManagerDetoursApiHook.h
XTPSkinManagerLegacyApiHook.h


Toolkit Pro: XTPSkinManagerApiHookBase.h File Reference

  • Source
  • SkinFramework
  • ApiHook
XTPSkinManagerApiHookBase.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPSkinManagerApiHookConfig.h File Reference

  • Source
  • SkinFramework
  • ApiHook
XTPSkinManagerApiHookConfig.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPSkinManagerDetoursApiHook.h File Reference

  • Source
  • SkinFramework
  • ApiHook
XTPSkinManagerDetoursApiHook.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPSkinManagerLegacyApiHook.h File Reference

  • Source
  • SkinFramework
  • ApiHook
XTPSkinManagerLegacyApiHook.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPSkinDrawTools.h File Reference

  • Source
  • SkinFramework
XTPSkinDrawTools.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPSkinFrameworkIIDs.h Source File

  • Source
  • SkinFramework
XTPSkinFrameworkIIDs.h
1// DO NOT MODIFY MANUALLY
2// Generated on Thu 12/11/2025 at 12:46:17.21 using cj-update-iids.cmd
3
24#ifndef __XTPSkinFrameworkIIDs_H__
25# define __XTPSkinFrameworkIIDs_H__
26
27// clang-format off
28
29#define XTP_DEFINE_GUID(name,l,w1,w2,b1,b2,b3,b4,b5,b6,b7,b8) \
30 EXTERN_C __declspec(selectany) const IID XTP##name = {l,w1,w2,{b1,b2,b3,b4,b5,b6,b7,b8}}; \
31 const unsigned long XTP##name##__Data1 = (l); \
32 const unsigned short XTP##name##__Data2 = (w1); \
33 const unsigned short XTP##name##__Data3 = (w2); \
34 const unsigned char XTP##name##__Data4_0 = (b1); \
35 const unsigned char XTP##name##__Data4_1 = (b2); \
36 const unsigned char XTP##name##__Data4_2 = (b3); \
37 const unsigned char XTP##name##__Data4_3 = (b4); \
38 const unsigned char XTP##name##__Data4_4 = (b5); \
39 const unsigned char XTP##name##__Data4_5 = (b6); \
40 const unsigned char XTP##name##__Data4_6 = (b7); \
41 const unsigned char XTP##name##__Data4_7 = (b8);
42
43XTP_DEFINE_GUID(LIBID_XtremeSkinFramework,0xBD0C1912,0x66C3,0x49CC,0x8B,0x12,0x7B,0x34,0x7B,0xF6,0xC8,0x46);
44XTP_DEFINE_GUID(DIID_SkinIniFile,0xC0DE2430,0x1038,0x498E,0xA9,0x36,0x36,0x1F,0x08,0xB4,0xC4,0xAA);
45XTP_DEFINE_GUID(DIID_SkinDescription,0xC0DE2430,0x4834,0x499E,0x95,0xB4,0x30,0xE0,0xC3,0xF4,0x3A,0x10);
46XTP_DEFINE_GUID(DIID_SkinDescriptions,0xC0DE2430,0xFB37,0x4B08,0xA2,0xB9,0xF6,0xF8,0xB2,0x53,0xD6,0x97);
47XTP_DEFINE_GUID(DIID_SkinSchema,0xC0DE2430,0xC56F,0x43C0,0xBC,0xF1,0x81,0x93,0xB3,0x5F,0xE4,0xC4);
48XTP_DEFINE_GUID(DIID__DSkinFramework,0xC0DE2430,0x28D7,0x4F2C,0x87,0xA7,0x72,0x66,0x36,0x7B,0x46,0x55);
49XTP_DEFINE_GUID(DIID__DSkinFrameworkEvents,0xC0DE2430,0x4463,0x4030,0xB3,0x24,0xAC,0x6A,0x80,0x75,0xFE,0xC8);
50XTP_DEFINE_GUID(CLSID_SkinFramework,0xC0DE2430,0x2217,0x42EE,0xB1,0xB0,0x82,0xC8,0x90,0x43,0x1F,0x17);
51XTP_DEFINE_GUID(DIID_ISkinFrameworkGlobalSettings,0xC0DE2430,0xCA9A,0x4AA9,0x86,0x01,0x0A,0xB7,0xF5,0x51,0xAA,0x3D);
52XTP_DEFINE_GUID(CLSID_SkinFrameworkGlobalSettings,0xC0DE2430,0xF744,0x4373,0xB3,0x8D,0x29,0xCE,0x83,0xEF,0x0E,0xE5);
53
54#undef XTP_DEFINE_GUID
55
56// clang-format on
57
58#endif // __XTPSkinFrameworkIIDs_H__


Toolkit Pro: XTPSkinImage.h File Reference

  • Source
  • SkinFramework
Classes
XTPSkinImage.h File Reference

Go to the source code of this file.

Classes

class | CXTPSkinImage
The CXTPSkinImage class represents a simple bitmap holder and draw operations for Skin Framework. More...
class | CXTPSkinImages
CXTPSkinImages represents a cached collection of CXTPSkinImage classes. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPSkinManager.h File Reference

  • Source
  • SkinFramework
Classes | Enumerations | Functions
XTPSkinManager.h File Reference

Go to the source code of this file.

Classes

class | CXTPSkinManagerClass
CXTPSkinManagerClass is a standalone class that represents a single visual class of the skin manager. More...
struct | IXTPSkinManagerWindowFilter
Implement this interface in order to provide custom configured window filter functionality. More...
class | CXTPSkinManagerMetrics
CXTPSkinManagerMetrics is a standalone class that represents a collection of metrics of the current skin. More...
class | CXTPSkinManager
CXTPSkinManager is a standalone class that represents a global object that manages skins. More...

Enumerations

enum XTPSkinApplyOptions {
xtpSkinApplyMetrics = 1 , xtpSkinApplyFrame = 2 , xtpSkinApplyColors = 4 , xtpSkinApplyMenus = 8 ,
xtpSkinApplyDCs = 0x10 , xtpSkinApplyCommandBarsFrame = 0x20
}
Applied options of the selected skin. More...
enum XTPSkinManagerProperty {
XTP_SKINPROPERTY_UNKNOWN , XTP_SKINPROPERTY_STRING , XTP_SKINPROPERTY_INT , XTP_SKINPROPERTY_BOOL ,
XTP_SKINPROPERTY_COLOR , XTP_SKINPROPERTY_RECT , XTP_SKINPROPERTY_FONT , XTP_SKINPROPERTY_INTLIST ,
XTP_SKINPROPERTY_ENUM , XTP_SKINPROPERTY_POSITION , XTP_SKINPROPERTY_FILENAME = XTP_SKINPROPERTY_STRING , XTP_SKINPROPERTY_MARGINS = XTP_SKINPROPERTY_RECT ,
XTP_SKINPROPERTY_SIZE = XTP_SKINPROPERTY_INT
}
Available properties for the CXTPSkinManagerSchemaProperty class. More...

Functions

_XTP_EXT_CLASS CXTPSkinManager *AFX_CDECL XTPSkinManager ()
Call this function to access CXTPSkinManager members.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Enumeration Type Documentation

◆ XTPSkinApplyOptions

enum XTPSkinApplyOptions

Applied options of the selected skin.

Example:

XTPSkinManager()->SetApplyOptions(xtpSkinApplyMetrics | xtpSkinApplyFrame | xtpSkinApplyColors);
See also
CXTPSkinManager, CXTPSkinManager::SetApplyOptions, xtpSkinApplyMetrics, xtpSkinApplyFrame, xtpSkinApplyColors
Enumerator
xtpSkinApplyMetrics | TRUE to use skin provided metrics.
xtpSkinApplyFrame | TRUE to apply frame skins.
xtpSkinApplyColors | TRUE to use skin provided colors.
xtpSkinApplyMenus | TRUE to apply skin for pop-up menus.
xtpSkinApplyDCs | TRUE to apply skin to device context that have no associated window handles.
xtpSkinApplyCommandBarsFrame | TRUE to apply skin frame with CommandBars.

◆ XTPSkinManagerProperty

enum XTPSkinManagerProperty

Available properties for the CXTPSkinManagerSchemaProperty class.

Example:

XTPSkinManager()->GetProperty(XTP_SKINPROPERTY_BOOL, iPartId, iStateId, TMT_TRANSPARENT);
See also
CXTPSkinManagerSchemaProperty
Enumerator
XTP_SKINPROPERTY_UNKNOWN | Not defined.
XTP_SKINPROPERTY_STRING | CString property.
XTP_SKINPROPERTY_INT | int property.
XTP_SKINPROPERTY_BOOL | BOOL property.
XTP_SKINPROPERTY_COLOR | COLORREF property.
XTP_SKINPROPERTY_RECT | CRect property.
XTP_SKINPROPERTY_FONT | LOGFONT property.
XTP_SKINPROPERTY_INTLIST | CIntArray property.
XTP_SKINPROPERTY_ENUM | enum property.
XTP_SKINPROPERTY_POSITION | int property.
XTP_SKINPROPERTY_FILENAME | FileName property.
XTP_SKINPROPERTY_MARGINS | Margins property.
XTP_SKINPROPERTY_SIZE | Size property.

Function Documentation

◆ XTPSkinManager()

_XTP_EXT_CLASS CXTPSkinManager *AFX_CDECL XTPSkinManager ( )

Call this function to access CXTPSkinManager members.

Since this class is designed as a single instance object, you can only access version info through this method. You cannot directly instantiate an object of type CXTPSkinManager.

Example:

XTPSkinManager()->SetApplyOptions(xtpSkinApplyMetrics | xtpSkinApplyFrame | xtpSkinApplyColors);
Returns
A global skin manager object pointer.


Toolkit Pro: XTPSkinManagerApiHook.h File Reference

  • Source
  • SkinFramework
XTPSkinManagerApiHook.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPSkinManagerColorFilter.h File Reference

  • Source
  • SkinFramework
Classes
XTPSkinManagerColorFilter.h File Reference

Go to the source code of this file.

Classes

class CXTPSkinManagerColorFilter
CXTPSkinManagerColorFilter represents the parent class for all color filters of skin manager. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPSkinManagerModuleList.h File Reference

  • Source
  • SkinFramework
XTPSkinManagerModuleList.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPSkinManagerResource.h File Reference

  • Source
  • SkinFramework
Classes
XTPSkinManagerResource.h File Reference

Go to the source code of this file.

Classes

class CXTPSkinManagerResourceFile
CXTPSkinManagerResourceFile is a standalone class that represents a manager of visual style resources. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPSkinManagerSchema.h File Reference

  • Source
  • SkinFramework
Classes
XTPSkinManagerSchema.h File Reference

Go to the source code of this file.

Classes

class | CXTPSkinManagerSchemaProperty
CXTPSkinManagerSchemaProperty is a standalone class representing a single property of a visual styles .ini file. More...
class | CXTPSkinManagerSchema
CXTPSkinManagerSchema is a standalone class used to read a visual styles schema file. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPSkinManagerSchemaCodes.h File Reference

  • Source
  • SkinFramework
XTPSkinManagerSchemaCodes.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPSkinObject.h File Reference

  • Source
  • SkinFramework
Classes
XTPSkinObject.h File Reference

Go to the source code of this file.

Classes

class | CXTPSkinObject
CXTPSkinObject is a CWnd derived class. More...
class | CXTPSkinObjectClassMap
CXTPSkinObjectClassMap is a standalone class that helps map windows controls to skin framework classes. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPSkinObjectButton.h File Reference

  • Source
  • SkinFramework
Classes
XTPSkinObjectButton.h File Reference

Go to the source code of this file.

Classes

class CXTPSkinObjectButton
CXTPSkinObjectButton is a CXTPSkinObjectFrame derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPSkinObjectComboBox.h File Reference

  • Source
  • SkinFramework
Classes
XTPSkinObjectComboBox.h File Reference

Go to the source code of this file.

Classes

class | CXTPSkinObjectComboBox
CXTPSkinObjectComboBox is a CXTPSkinObjectFrame derived class. More...
class | CXTPSkinObjectDateTime
CXTPSkinObjectDateTime is a CXTPSkinObjectComboBox derived class. More...
class | CXTPSkinObjectMonthCal
CXTPSkinObjectMonthCal is a CXTPSkinObjectFrame derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPSkinObjectEdit.h File Reference

  • Source
  • SkinFramework
Classes
XTPSkinObjectEdit.h File Reference

Go to the source code of this file.

Classes

class CXTPSkinObjectEdit
CXTPSkinObjectEdit is a CXTPSkinObjectUser32Control derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPSkinObjectFrame.h File Reference

  • Source
  • SkinFramework
Classes
XTPSkinObjectFrame.h File Reference

Go to the source code of this file.

Classes

class | CXTPSkinObjectFrame
CXTPSkinObjectFrame is a CXTPSkinObject derived class. More...
class | CXTPSkinObjectFrame::CCaptionButton
Caption button class. More...
class | CXTPSkinObjectUser32Control
CXTPSkinObjectUser32Control is a CXTPSkinObjectFrame derived class. More...
class | CXTPSkinObjectComCtl32Control
CXTPSkinObjectComCtl32Control is a CXTPSkinObjectUser32Control derived class. More...
class | CXTPSkinObjectSolidFilled
CXTPSkinObjectSolidFilled is a CXTPSkinObjectFrame derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPSkinObjectHeader.h File Reference

  • Source
  • SkinFramework
Classes
XTPSkinObjectHeader.h File Reference

Go to the source code of this file.

Classes

class CXTPSkinObjectHeader
CXTPSkinObjectHeader is a CXTPSkinObjectFrame derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPSkinObjectListBox.h File Reference

  • Source
  • SkinFramework
Classes
XTPSkinObjectListBox.h File Reference

Go to the source code of this file.

Classes

class CXTPSkinObjectListBox
CXTPSkinObjectListBox is a CXTPSkinObjectUser32Control derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPSkinObjectListView.h File Reference

  • Source
  • SkinFramework
Classes
XTPSkinObjectListView.h File Reference

Go to the source code of this file.

Classes

class CXTPSkinObjectListView
CXTPSkinObjectListView is a CXTPSkinObjectComCtl32Control derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPSkinObjectMDI.h File Reference

  • Source
  • SkinFramework
XTPSkinObjectMDI.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPSkinObjectMenu.h File Reference

  • Source
  • SkinFramework
XTPSkinObjectMenu.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPSkinObjectProgress.h File Reference

  • Source
  • SkinFramework
Classes
XTPSkinObjectProgress.h File Reference

Go to the source code of this file.

Classes

class CXTPSkinObjectProgress
CXTPSkinObjectProgress is a CXTPSkinObjectFrame derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPSkinObjectReBar.h File Reference

  • Source
  • SkinFramework
Classes
XTPSkinObjectReBar.h File Reference

Go to the source code of this file.

Classes

class CXTPSkinObjectReBar
CXTPSkinObjectReBar is a CXTPSkinObjectFrame derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPSkinObjectScrollBar.h File Reference

  • Source
  • SkinFramework
Classes
XTPSkinObjectScrollBar.h File Reference

Go to the source code of this file.

Classes

class CXTPSkinObjectScrollBar
CXTPSkinObjectScrollBar is a CXTPSkinObjectFrame derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPSkinObjectSpin.h File Reference

  • Source
  • SkinFramework
Classes
XTPSkinObjectSpin.h File Reference

Go to the source code of this file.

Classes

class CXTPSkinObjectSpin
CXTPSkinObjectSpin is a CXTPSkinObjectFrame derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPSkinObjectStatusBar.h File Reference

  • Source
  • SkinFramework
Classes
XTPSkinObjectStatusBar.h File Reference

Go to the source code of this file.

Classes

class CXTPSkinObjectStatusBar
CXTPSkinObjectStatusBar is a CXTPSkinObjectFrame derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPSkinObjectTab.h File Reference

  • Source
  • SkinFramework
Classes
XTPSkinObjectTab.h File Reference

Go to the source code of this file.

Classes

class CXTPSkinObjectTab
CXTPSkinObjectTab is a CXTPSkinObjectFrame derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPSkinObjectToolBar.h File Reference

  • Source
  • SkinFramework
Classes
XTPSkinObjectToolBar.h File Reference

Go to the source code of this file.

Classes

class CXTPSkinObjectToolBar
CXTPSkinObjectToolBar is a CXTPSkinObjectFrame derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPSkinObjectTrackBar.h File Reference

  • Source
  • SkinFramework
Classes
XTPSkinObjectTrackBar.h File Reference

Go to the source code of this file.

Classes

class CXTPSkinObjectTrackBar
CXTPSkinObjectTrackBar is a CXTPSkinObjectFrame derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPSkinObjectTreeView.h File Reference

  • Source
  • SkinFramework
Classes
XTPSkinObjectTreeView.h File Reference

Go to the source code of this file.

Classes

class CXTPSkinObjectTreeView
CXTPSkinObjectTreeView is a CXTPSkinObjectComCtl32Control derived class. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: SyntaxEdit Directory Reference

  • Source
  • SyntaxEdit
SyntaxEdit Directory Reference

Directories

res

Files

XTPSyntaxEditAutoCompleteWnd.h
XTPSyntaxEditBufferManager.h
XTPSyntaxEditColorComboBox.h
XTPSyntaxEditColorSampleText.h
XTPSyntaxEditCtrl.h
XTPSyntaxEditDefines.h
XTPSyntaxEditDoc.h
XTPSyntaxEditDrawTextProcessor.h
XTPSyntaxEditFindReplaceDlg.h
XTPSyntaxEditGoToLineDlg.h
XTPSyntaxEditIIDs.h
XTPSyntaxEditLexCfgFileReader.h
XTPSyntaxEditLexClass.h
XTPSyntaxEditLexClassSubObjDef.h
XTPSyntaxEditLexClassSubObjT.h
XTPSyntaxEditLexColorFileReader.h
XTPSyntaxEditLexParser.h
XTPSyntaxEditLexPtrs.h
XTPSyntaxEditLineMarksManager.h
XTPSyntaxEditPaintManager.h
XTPSyntaxEditPropertiesDlg.h
XTPSyntaxEditPropertiesPage.h
XTPSyntaxEditSectionManager.h
XTPSyntaxEditSelection.h
XTPSyntaxEditStruct.h
XTPSyntaxEditTextIterator.h
XTPSyntaxEditToolTipCtrl.h
XTPSyntaxEditUndoManager.h
XTPSyntaxEditView.h


Toolkit Pro: res Directory Reference

  • Source
  • SyntaxEdit
  • res
res Directory Reference

Files

XTPSyntaxEditLexSchemas.h


Toolkit Pro: XTPSyntaxEditLexSchemas.h Source File

  • Source
  • SyntaxEdit
  • res
XTPSyntaxEditLexSchemas.h
1//<title Lex Schemas>
2//<toctitle LexSchemas>
3//<keywords lexClass>
4//
5// Summary:
6// * Lex class description *
7//
8// <B>lexClass</B> object is a block of text with defined begin and end sequence;
9// for which can be specified some font and colors attributes.
10// One lex class can contain others inside itself;
11// also it can have some relations to other classes.
12//
13// lex schema is defined as a set of lexClasses.
14// It contains a root class with parent type 'file'
15// (which defines a files extensions to apply this schema to,
16// and some global schema attributes).
17//
18// - Lex schemes -
19//
20// Lex schemes are defined in *.schclass files.
21// Lex class properties (attributes) can be compound, like:
22// <P><C>parent:dyn, previous:tag:separators.</C>
23//
24// - Multiple values -
25//
26// For multiple value properties the following syntax is allowed:
27//
28// <P><C> propertyX = value1, value2, value3, .... </C>
29// <P><C> propertyX = valueA1, valueA2, ... </C>
30// <P><C> propertyX = valueN1 </C>
31// <P><C> propertyX = valueN2 </C>
32// <P><C> .... </C>
33//
34// - String values -
35//
36// String(character) values are defined in single quotation marks:
37// <P>'stringValue'<P>
38// There are a few special chars (as in C++):
39// <P>'\\', '\'', '\t', '\r', '\n'
40//
41// And predefined constants:
42//
43// <P><C> @alpha = a-z, A-Z </C>
44// <P><C> @digit = 0-9 </C>
45// <P><C> @HexDdigit = 0-9, a-f, A-F </C>
46// <P><C> @specs = ~!@#$%^&*()_-+=\|{}[];:'",.<>/? </C>
47// <P><C> @EOL = End Of Line </C>
48//
49// <P><P>NOT operation supported for constants comparisons,
50// <P>like: <C> @alpha:not </C>
51//
52// - Comments -
53// <B> <COLOR 00c000> // </COLOR> </B>
54// <P>Two slashes are used to define a single line comment in Lex schema files.
55// (same as in C++)
56//
57// - Lex Class Section -
58// <P>
59// <B>lexClass:</B>
60// <P>This keyword begins a lex class section.
61//
62// - name \- Property (required) -
63//
64// Define a lexClass name. Must be unique withing same lex schema (*.schclass file).
65// <PRE>
66// lexClass:
67// name = c_CPPString
68// </PRE>
69// <P>
70//
71// - parent \- Property (required) -
72//
73// <B>parent </B>
74// <P>Defines a direct parent of lex class. (parent class name)
75//
76// <P><B>parent:dyn</B>
77// <P>Defines a dynamic parent of lex class. (parent class name)
78// Dynamic means that parent class can be not only direct parent,
79// but parent of its parent [of parent ...] until the top class/block.
80//
81// <P><B>parent:file</B>
82// <P>Defines a top schema class. (as file extensions list <*.ext1|*.ext2>)
83// <P>
84// <P>Only one of mentioned above 'parent' properties can be used for each class.
85//
86// <PRE>
87// parent:file = <*.c|*.cpp|*.h|*.inl|*.tli|*.tlh|*.rc|*.rc2>
88// parent = c_CPP
89// parent:dyn = c_CPP
90// </PRE>
91//
92// - children \- Property (optional) -
93//
94// <B>children</B>
95// <P>Defines an allowed direct children for lex class
96// (as comma separated class names or zero to restrict any child).
97//
98// <P>Parent-child relation is defined by 'parent' property. This property helps
99// to restrict create parent-child relation for classes other than specified
100// or define that class has no children.
101//
102// <PRE>
103// children = 0 // has no children
104// children = class1, class2, ...
105// </PRE>
106//
107// - RecurrenceDepth \- Property (optional) -
108//
109// <B>RecurrenceDepth</B>
110// <P>Defines maximum depth of nested classes (blocks).
111// <P>(as a number, default value 1).
112// <P>
113// <P>Class A can be parent for class B. And Class B can be parent for class A.
114// Possible situation when A=B. (for example '{}' block in C++)
115// This property defines maximum depth of A->B->A->B->... nested construction.
116//
117// <PRE>
118// RecurrenceDepth = 32
119// </PRE>
120//
121// - previous \- Property (optional) -
122//
123// 'previous' property used to set condition to start lex class as previous
124// tag or class. The difference from 'start' property that objects specified
125// in this property is not included in class(block).
126// Can be used alone or together with 'start' property.
127//
128// <P><B>previous:class</B>
129// <P>This class is started only if previous determined class name in collection
130// specified in this property.
131// <P>(as one or more class names)
132//
133// <P><B>previous:tag</B>
134// <P>This class is started only if start condition is true and previous tag is
135// in collection specified in this property.
136// <P>(as one or more tags)
137//
138// <P><B>previous:tag:separators</B>
139// <P>separators set for previous:tag values.
140//
141// <P>Previous 'tag' and 'class' conditions can be specified separately or together.
142//
143// <PRE>
144// previous:class = c_HTMLelement_SCRIPT_lang_VB, c_HTMLelement_SCRIPT_lang_JS
145// previous:tag = '='
146// previous:tag:separators = ' ', '\t', @eol
147// </PRE>
148//
149// - start \- Property (optional) -
150//
151// 'start' property used to set condition to start lex class as tag or class.
152// The difference from 'previous' property that objects specified in this
153// property is included in class(block).
154// <P>Can be used alone or together with 'previous' property.
155//
156// <P><B>start:class</B>
157// <P>This class is started only if previous determined class name in collection
158// specified in this property.
159// <P>(as one or more class names)
160//
161// <P><B>start:Tag</B>
162// <P>This class is started if current tag is in collection specified in this property.
163// <P>(as one or more tags)
164//
165// <P>Start 'tag' and 'class' conditions can be specified separately or together.
166//
167// - end \- Property (optional) -
168//
169// 'end' property used to set end lex class condition as tag or class.
170//
171// <P><B>end:class</B>
172// <P>This class is ended if previous determined class name in collection
173// specified in this property.
174// <P>(as one or more class names)
175//
176// <P><B>end:Tag</B>
177// <P>This class is ended if current tag is in collection specified in this property.
178// <P>(as one or more tags)
179//
180// <P><B>end:separators</B>
181// <P>This class is ended if tag after current position is in collection specified
182// in this property. Difference from end:Tag is that end:Tag specify tags before
183// current position and end:Tag included in this block but end:separators not
184// included.
185// <P>(as one or more tags)
186//
187// <P>End 'class', 'tag' and 'separators' conditions can be specified separately or together.
188//
189// - skip \- Property (optional) -
190//
191// <B>skip:Tag</B>
192// <P>Used to skip some tags from parsing. Useful to support special tags
193// part of which can be a begin of end tag.
194// <P>(as one or more tags)
195//
196// <PRE>
197// EXAMPLES (for start, end, skip):
198//
199// start:Tag ='/*'
200// end:Tag ='*/'
201//
202// //-------------------------------------------
203// start:Tag = '"'
204// skip:Tag = '\\"', '\\\r\n', '\\\n\r', '\\\n', '\\\r'
205// end:Tag = '"', @eol
206//
207// //-------------------------------------------
208// start:tag = @alpha
209// skip:tag = @digit
210// end:separators = @alpha:not
211//
212// //-------------------------------------------
213// start:CLASS = c_CPPAfxInsertBlock_Start
214// end:CLASS = c_CPPAfxInsertBlock_End
215// </PRE>
216//
217// - token \- Property (optional) -
218//
219// 'token' property is used to set lex class as some token(s).
220// It could be useful to define keywords.
221// Can be used alone or together with 'previous' property.
222// It must not be used together with 'start'-'end' condition.
223//
224// <P><B>token:tag</B>
225// <P>This class is a word from this collection.
226// <P>(as one or more tags)
227//
228// <P><B>Token:start:separators</B>
229// <P>Start separators set for token:tag values.
230//
231// <P><B>Token:end:separators</B>
232// <P>End separators set for token:tag values.
233//
234// <P>Token 'tag' is main condition. Token 'separators' additional conditions.
235// <P>'separators' without 'tag' have no sense.
236//
237// <PRE>
238// token:start:separators = ' ', '\t', '<%=', '<%', @specs, @eol
239// token:end:separators = ' ', '\t', '%>', @specs, @eol
240//
241// token:tag = 'if', 'for', 'while', 'do'
242// token:tag = 'break'
243// token:tag = 'case'
244// token:tag = 'catch'
245// </PRE>
246// <P>
247//
248// * TEXT Attributes *
249//
250// txt:XXX defines a few text properties for lex class (block of text).
251// All of them are optional and if some text attribute is not specified -
252// it is inherited from parent class or set to default value for a top (file) lex class.
253//
254// <P><B>txt:colorFG</B>
255// <P>Fore color value in hex format (like 0xffc0c0).
256// <P>default: black
257//
258// <P><B>txt:colorBK</B>
259// <P>Background color value in hex format (like 0xffFFff).
260// <P>default: white
261//
262// <P><B>txt:colorSelFG</B>
263// <P>Selected text fore color value in hex format (like 0xffFFff).
264// <P>default: white
265//
266// <P><B>txt:colorSelBK</B>
267// <P>Selected text background color value in hex format (like 0xab0077).
268// <P>default: black
269//
270// <P><B>txt:Bold</B>
271// <P>Bold font attribute. Values {1, 0}
272// <P>default: 0
273//
274// <P><B>txt:Italic</B>
275// <P>Italic font attribute. Values {1, 0}
276// <P>default: 0
277//
278// <P><B>txt:Underline</B>
279// <P>Underline font attribute. Values {1, 0}
280// <P>default: 0
281//
282// <PRE>
283// txt:colorFG = 0x0fc0c0
284// txt:colorBK = 0xffffff
285//
286// txt:colorSelFG = 0xffffff
287// txt:colorSelBK = 0x0fc0c0
288//
289// txt:Bold = 1
290// txt:Italic = 0
291// txt:Underline = 1
292// </PRE>
293//
294// * caseSensitive \- Property (optional) *
295//
296// <B>caseSensitive</B>
297// <P>Define compare method for this lex class tags: case sensitive or insensitive.
298// <P>Inheritable from parent class.
299// <P>Values {1, 0}
300// <P>default: 0
301//
302// * Collapsable \- Property (optional) *
303//
304// <B>Collapsable</B>
305// <P>Define is this block Collapsable or not. Inheritable from parent class.
306// <P>Values {1, 0}
307// <P>default: 0
308//
309// * CollapsedText \- Property (optional) *
310//
311// <B>CollapsedText</B>
312// <P>Collapsed block string (as quoted string value).
313// <P>default: '[..]'
314//
315// * ParseOnScreen \- Property (optional) *
316//
317// <B>ParseOnScreen</B>
318// <P>Values {1, 0}
319// <P>default: 0
320// <P>If set to 1 - lex class will be parsed only before drawing on the screen in
321// the main thread. Useful for keywords and other single line text blocks, which
322// are parsed very fast.
323//
324// - \*\*\* Global attributes \*\*\* -
325//
326// 'global' attributes let to adjust some common parser parameters for each
327// lex schema separately. They can be used only in top layer lex class
328// (parent type file).
329//
330// <P><B>global:FirstParseInSeparateThread</B>
331// <P>Values {1, 0}
332// <P>default: 1
333// <P>Define is first parse (when file opening) will run in the main or
334// additional thread.
335//
336// <P><B>global:EditReparceInSeparateThread</B>
337// <P>Values {1, 0}
338// <P>default: 1
339// <P>Define is reparse after text edited will run in the main or
340// additional thread.
341//
342// <P><B>global:ConfigChangedReparceInSeparateThread</B>
343// <P>Values {1, 0}
344// <P>default: 1
345// <P>Define is reparse text after schema file (*.schclass) will run
346// in the main or additional thread.
347//
348// <P><B>global:EditReparceTimeout_ms</B>
349// <P>as time in milliseconds;
350// <P>default: 500
351// <P>Time out to start reparse after last key was pressed.
352//
353// <P><B>global:MaxBackParseOffset</B>
354// <P>as number (chars);
355// <P>default: 100
356// <P>Some times parser look back for the text from current position.
357// This parameter define maximum back buffer size.
358//
359// <P><B>global:OnScreenSchCacheLifeTime_sec</B>
360// <P>as time in seconds; -1 and 0 means infinite;
361// <P>default= 180
362// <P>When piece of text is displayed, edit control run parser to parse
363// lexClasses with 'ParseOnScreen' attribute set and cache this
364// information to do not run parser every time for this lines. For each
365// entry in this cache last access time is stored.
366// This parameter define time period from last access time after which
367// cached entries will be removed (for memory using optimization).
368//
369// <P><B>global:ParserThreadIdleLifeTime_sec</B>
370// <P>as time in seconds; -1 and 0 means infinite;
371// <P>default: 60
372// <P>Idle time out for parser thread. If no parse requests (no editing operations)
373// additional parser thread will be exited. It will be recreated again
374// when necessary (to system resources optimization).


Toolkit Pro: XTPSyntaxEditAutoCompleteWnd.h File Reference

  • Source
  • SyntaxEdit
Classes | Typedefs
XTPSyntaxEditAutoCompleteWnd.h File Reference

Go to the source code of this file.

Classes

struct | XTP_EDIT_ACDATA
The XTP_EDIT_ACDATA structure defines items' displayed data and provides text and icons for each displayed line in the auto-complete window. More...
class | CXTPSyntaxEditAutoCompleteWnd
This class implements the auto-complete window. More...

Typedefs

typedef CArray< XTP_EDIT_ACDATA *, XTP_EDIT_ACDATA * > | CXTPSyntaxEditACDataArray
The CXTPSyntaxEditACDataArray type defines a custom array to store auto-complete items' displayed data.
typedef CArray< CRect, CRect > | CXTPSyntaxEditACGrid
The CXTPSyntaxEditACGrid type defines a custom array to store and manage visible rectangle arrays that represent lines of data in the auto-complete window.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Typedef Documentation

◆ CXTPSyntaxEditACDataArray

typedef CArray<XTP_EDIT_ACDATA*, XTP_EDIT_ACDATA*> CXTPSyntaxEditACDataArray

The CXTPSyntaxEditACDataArray type defines a custom array to store auto-complete items' displayed data.

See also
PXTP_EDIT_ACDATA


Toolkit Pro: XTPSyntaxEditBufferManager.h File Reference

  • Source
  • SyntaxEdit
Classes | Typedefs
XTPSyntaxEditBufferManager.h File Reference

Go to the source code of this file.

Classes

class | CXTPSyntaxEditBufferManager
This class is the main class for buffer management. More...
class | CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager
This is helper class designed to manage a set of strings. More...
class | CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager::CStringPtrArray
Internal class, implements a collection of strings. More...

Typedefs

typedef XTPSyntaxEditLexAnalyser::CXTPSyntaxEditLexTextSchema CXTPSyntaxEditTextSchema
namespace XTPSyntaxEditLexAnalyser

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPSyntaxEditColorComboBox.h File Reference

  • Source
  • SyntaxEdit
Classes | Functions
XTPSyntaxEditColorComboBox.h File Reference

Go to the source code of this file.

Classes

class CXTPSyntaxEditColorComboBox
This class allows for colors to be edited by using a combobox control. More...

Functions

_XTP_EXT_CLASS void AFXAPI DDX_CBSyntaxColor (CDataExchange *pDX, int nIDC, COLORREF &value)
Exchanges the currently selected color for a CXTPSyntaxEditColorComboBox control.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Function Documentation

◆ DDX_CBSyntaxColor()

_XTP_EXT_CLASS void AFXAPI DDX_CBSyntaxColor | ( | CDataExchange * | pDX,
 |  | int | nIDC,
 |  | COLORREF & | value )

Exchanges the currently selected color for a CXTPSyntaxEditColorComboBox control.

Parameters
pDX | Pointer to a CDataExchange object.
nIDC | Control ID.
value | Reference to the color value.


Toolkit Pro: XTPSyntaxEditColorSampleText.h File Reference

  • Source
  • SyntaxEdit
Classes
XTPSyntaxEditColorSampleText.h File Reference

Go to the source code of this file.

Classes

class CXTPSyntaxEditColorSampleText
This class, derived from CStatic, is used to display a sample of colored text. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPSyntaxEditCtrl.h File Reference

  • Source
  • SyntaxEdit
Classes
XTPSyntaxEditCtrl.h File Reference

Go to the source code of this file.

Classes

class | CXTPSyntaxEditOptions
Shared Options of SyntaxEdit. More...
class | CXTPSyntaxEditCtrl
This class is the main CWnd-based editor class. More...
class | CXTPSyntaxEditCtrl::CAverageVal
CXTPSyntaxEditCtrl::CAverageVal. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPSyntaxEditDefines.h File Reference

  • Source
  • SyntaxEdit
Macros | Enumerations
XTPSyntaxEditDefines.h File Reference

Go to the source code of this file.

Macros

#define | XTP_EDIT_EDITACTION_INSERTROW 0x01
Insert row.
#define | XTP_EDIT_EDITACTION_DELETEROW 0x02
Delete row.
#define | XTP_EDIT_EDITACTION_MODIFYROW 0x04
Modify row.
#define | XTP_EDIT_EDITACTION_INSERTTEXT 0x100
Generic insert text action.
#define | XTP_EDIT_EDITACTION_DELETETEXT 0x200
Generic delete text action.
#define | XTP_EDIT_DISABLED_COLOR_LIGHT RGB(250, 250, 250)
Defines light and dark colors which are used by CXTPImageManager::DisableBitmap to draw disabled calendar window content.
#define | XTP_EDIT_DISABLED_COLOR_DARK RGB(128, 128, 128)
Defines light and dark colors which are used by CXTPImageManager::DisableBitmap to draw disabled calendar window content.
#define | XTP_EDIT_NM_FIRST (0U - 951U)
First notification ID for SyntaxEdit.
#define | XTP_EDIT_NM_LAST (0U - 979U)
Last notification ID for SyntaxEdit.
#define | XTP_EDIT_NM_EDITCHANGING (XTP_EDIT_NM_FIRST + 0)
Edit changing will be called before changing content.
#define | XTP_EDIT_NM_EDITCHANGED (XTP_EDIT_NM_FIRST + 1)
This will be called if content has been changed.
#define | XTP_EDIT_NM_SETDOCMODIFIED (XTP_EDIT_NM_FIRST + 2)
Indicates if the document is modified.
#define | XTP_EDIT_NM_DRAWBOOKMARK (XTP_EDIT_NM_FIRST + 3)
This will be called while drawing the bookmarks.
#define | XTP_EDIT_NM_ROWCOLCHANGED (XTP_EDIT_NM_FIRST + 4)
This will be fired if row or col has been changed.
#define | XTP_EDIT_NM_INSERTKEY (XTP_EDIT_NM_FIRST + 8)
Update all of the vertical panes.
#define | XTP_EDIT_NM_SELINIT (XTP_EDIT_NM_FIRST + 9)
Updates all the selections while one pane initiates one.
#define | XTP_EDIT_NM_STARTOLEDRAG (XTP_EDIT_NM_FIRST + 10)
Start OLE drag.
#define | XTP_EDIT_NM_MARGINCLICKED (XTP_EDIT_NM_FIRST + 11)
Left mouse button was clicked in the gutter area.
#define | XTP_EDIT_NM_UPDATESCROLLPOS (XTP_EDIT_NM_FIRST + 12)
Edit control scroll positions changed.
#define | XTP_EDIT_NM_PARSEEVENT (XTP_EDIT_NM_FIRST + 13)
This notification used to reflect parser events.
#define | XTP_EDIT_NM_LBUTTONDOWN (XTP_EDIT_NM_FIRST + 14)
Notify mouse Left button down.
#define | XTP_EDIT_NM_LBUTTONDBLCLICK (XTP_EDIT_NM_FIRST + 15)
Notify mouse Left button double click.
#define | XTP_EDIT_NM_LBUTTONUP (XTP_EDIT_NM_FIRST + 16)
Notify mouse Left button up.
#define | XTP_EDIT_NM_RBUTTONDOWN (XTP_EDIT_NM_FIRST + 17)
Notify mouse Right button down.
#define | XTP_EDIT_NM_RBUTTONUP (XTP_EDIT_NM_FIRST + 18)
Notify mouse Right button up.
#define | XTP_EDIT_NM_MOUSEMOVE
Notify mouse movement.
#define | XTP_EDIT_NM_ENABLESCROLLBAR (XTP_EDIT_NM_FIRST + 20)
Edit control scroll bar(s) state changed.
#define | XTP_EDIT_FINDWORD_PREV 0x01
Find start of the previous word.
#define | XTP_EDIT_FINDWORD_NEXT 0x02
Find start of the next word.
#define | XTP_EDIT_AVELINELEN 30
Average length of line.
#define | XTP_EDIT_RGB_GETRED(rgb)
Get red color value for raw RGB color like "0xAABBCC".
#define | XTP_EDIT_RGB_GETGREEN(rgb)
Get green color value for raw RGB color like "0xAABBCC".
#define | XTP_EDIT_RGB_GETBLUE(rgb)
Get blue color value for raw RGB color like "0xAABBCC".
#define | XTP_EDIT_RGB_INT2CLR(rgb)
Convert raw RGB color value like "0xAABBCC" to COLORREF.

Enumerations

enum | XTPSyntaxEditCRLFStyle { xtpEditCRLFStyleUnknown = -1 , xtpEditCRLFStyleDos = 0 , xtpEditCRLFStyleUnix = 1 , xtpEditCRLFStyleMac = 2 }
Line ending types. More...
enum | XTPSyntaxEditDeletePos { xtpEditDelPosAfter , xtpEditDelPosBefore }
Edit delete position. More...
enum | XTPSyntaxEditOnParseEvent { xtpEditOnParserStarted = 1 , xtpEditOnTextBlockParsed = 2 , xtpEditOnParserEnded = 3 }
These events are sent from different threads. More...
enum | XTPSyntaxEditOnCfgChangedEvent { xtpEditClassSchWasChanged = 10 , xtpEditThemeWasChanged = 11 , xtpEditAllConfigWasChanged = 12 }
These events are sent from different threads. More...
enum XTPSyntaxEditUpdateViewHint {
xtpEditHintUnknown , xtpEditHintRefreshView , xtpEditHintInitView , xtpEditHintSetFont ,
xtpEditHintSetLineNum , xtpEditHintSetSelMargin , xtpEditHintSetAutoIndent , xtpEditHintSetSyntaxColor ,
xtpEditHintUpdateScrollPos , xtpEditHintLast , xtpEditHintInvalidate
}
View update actions. More...
enum | XTPSyntaxEditEditAction { xtpEditActInsert = 1 , xtpEditActDelete = 2 }
Edit actions. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Macro Definition Documentation

◆ XTP_EDIT_AVELINELEN

#define XTP_EDIT_AVELINELEN 30

Average length of line.

Used as default value for \ \ \ \ CXTPSyntaxEditCtrl::m_nAverageLineLen.

◆ XTP_EDIT_NM_LBUTTONDBLCLICK

#define XTP_EDIT_NM_LBUTTONDBLCLICK (XTP_EDIT_NM_FIRST + 15)

Notify mouse Left button double click.

NMMOUSE structure \ \ \ \ passed with this notification.

◆ XTP_EDIT_NM_LBUTTONDOWN

#define XTP_EDIT_NM_LBUTTONDOWN (XTP_EDIT_NM_FIRST + 14)

Notify mouse Left button down.

NMMOUSE structure passed with \ \ \ \ this notification.

◆ XTP_EDIT_NM_LBUTTONUP

#define XTP_EDIT_NM_LBUTTONUP (XTP_EDIT_NM_FIRST + 16)

Notify mouse Left button up.

NMMOUSE structure passed with \ \ \ \ this notification.

◆ XTP_EDIT_NM_MOUSEMOVE

#define XTP_EDIT_NM_MOUSEMOVE
Value:
(XTP_EDIT_NM_FIRST \
+ 19)
XTP_EDIT_NM_FIRST
#define XTP_EDIT_NM_FIRST
First notification ID for SyntaxEdit.
Definition XTPSyntaxEditDefines.h:63

Notify mouse movement.

NMMOUSE structure passed with this notification.

◆ XTP_EDIT_NM_PARSEEVENT

#define XTP_EDIT_NM_PARSEEVENT (XTP_EDIT_NM_FIRST + 13)

This notification used to reflect parser events.

See \ \ \ \ XTPSyntaxEditOnParseEvent enum.

◆ XTP_EDIT_NM_RBUTTONDOWN

#define XTP_EDIT_NM_RBUTTONDOWN (XTP_EDIT_NM_FIRST + 17)

Notify mouse Right button down.

NMMOUSE structure passed \ \ \ \ with this notification.

◆ XTP_EDIT_NM_RBUTTONUP

#define XTP_EDIT_NM_RBUTTONUP (XTP_EDIT_NM_FIRST + 18)

Notify mouse Right button up.

NMMOUSE structure passed with \ \ \ \ this notification.

Enumeration Type Documentation

◆ XTPSyntaxEditCRLFStyle

enum XTPSyntaxEditCRLFStyle

Line ending types.

Enumerator
xtpEditCRLFStyleUnknown | Used to indicate unknown or error value.
xtpEditCRLFStyleDos | DOS style CRLF (0x0d0a).
xtpEditCRLFStyleUnix | UNIX style CRLF (0x0a0d).
xtpEditCRLFStyleMac | MAC style CRLF (0x0a).

◆ XTPSyntaxEditDeletePos

enum XTPSyntaxEditDeletePos

Edit delete position.

Enumerator
xtpEditDelPosAfter | Delete char(s) after specified position.
xtpEditDelPosBefore | Delete char(s) before specified position.

◆ XTPSyntaxEditEditAction

enum XTPSyntaxEditEditAction

Edit actions.

Enumerator
xtpEditActInsert | Edit action insert text.
xtpEditActDelete | Edit action delete text.

◆ XTPSyntaxEditOnCfgChangedEvent

enum XTPSyntaxEditOnCfgChangedEvent

These events are sent from different threads.

Its receiver must be thread-safe.

Enumerator
xtpEditClassSchWasChanged | dwParam1 = LPCTSTR - Schema name; dwParam2 = CXTPSyntaxEditLexTextSchema* New text schema pointer, or NULL if it was removed.
xtpEditThemeWasChanged | dwParam1 = LPCTSTR - Theme name; dwParam2 = CXTPSyntaxEditColorTheme* New theme pointer, or NULL if it was removed.
xtpEditAllConfigWasChanged | dwParam1 - unused, dwParam2 - unused

◆ XTPSyntaxEditOnParseEvent

enum XTPSyntaxEditOnParseEvent

These events are sent from different threads.

Its receiver must be thread-safe.

Enumerator
xtpEditOnParserStarted | dwParam1 - unused
xtpEditOnTextBlockParsed | dwParam1 = Text Block ID
xtpEditOnParserEnded | dwParam1 = status flags : xtpEditLPR_RunFinished, xtpEditLPR_RunBreaked, xtpEditLPR_Error;

◆ XTPSyntaxEditUpdateViewHint

enum XTPSyntaxEditUpdateViewHint

View update actions.

Defines the way in which the view should be updated.

Enumerator
xtpEditHintUnknown | Updating action is unknown.
xtpEditHintRefreshView | The view should be refreshed.
xtpEditHintInitView | The view should be initialized.
xtpEditHintSetFont | The view should update the display font.
xtpEditHintSetLineNum | The view should update line number display.
xtpEditHintSetSelMargin | The view should update the selection margin display.
xtpEditHintSetAutoIndent | The view should update the auto-indent setting.
xtpEditHintSetSyntaxColor | The view should update the syntax color setting.
xtpEditHintUpdateScrollPos | The view should update scrollbars positions.
xtpEditHintLast | The last update code.
xtpEditHintInvalidate | Invalidates the view.


Toolkit Pro: XTPSyntaxEditDoc.h File Reference

  • Source
  • SyntaxEdit
Classes
XTPSyntaxEditDoc.h File Reference

Go to the source code of this file.

Classes

class CXTPSyntaxEditDoc
This class represents the Document portion of an Edit control. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPSyntaxEditDrawTextProcessor.h File Reference

  • Source
  • SyntaxEdit
Classes
XTPSyntaxEditDrawTextProcessor.h File Reference

Go to the source code of this file.

Classes

class CXTPSyntaxEditDrawTextProcessor
This helper class is used by CXTPSyntaxEditCtrl as the Draw Text Processor. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPSyntaxEditFindReplaceDlg.h File Reference

  • Source
  • SyntaxEdit
Classes
XTPSyntaxEditFindReplaceDlg.h File Reference

Go to the source code of this file.

Classes

class CXTPSyntaxEditFindReplaceDlg
This class implements the "Find and Replace" and "Find" dialogs for a SyntaxEdit control. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPSyntaxEditGoToLineDlg.h File Reference

  • Source
  • SyntaxEdit
Classes
XTPSyntaxEditGoToLineDlg.h File Reference

Go to the source code of this file.

Classes

class CXTPSyntaxEditGoToLineDlg
This class implements the "GoToLine" dialog for a SyntaxEdit control. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPSyntaxEditIIDs.h Source File

  • Source
  • SyntaxEdit
XTPSyntaxEditIIDs.h
1// DO NOT MODIFY MANUALLY
2// Generated on Thu 12/11/2025 at 12:46:18.00 using cj-update-iids.cmd
3
24#ifndef __XTPSyntaxEditIIDs_H__
25# define __XTPSyntaxEditIIDs_H__
26
27// clang-format off
28
29#define XTP_DEFINE_GUID(name,l,w1,w2,b1,b2,b3,b4,b5,b6,b7,b8) \
30 EXTERN_C __declspec(selectany) const IID XTP##name = {l,w1,w2,{b1,b2,b3,b4,b5,b6,b7,b8}}; \
31 const unsigned long XTP##name##__Data1 = (l); \
32 const unsigned short XTP##name##__Data2 = (w1); \
33 const unsigned short XTP##name##__Data3 = (w2); \
34 const unsigned char XTP##name##__Data4_0 = (b1); \
35 const unsigned char XTP##name##__Data4_1 = (b2); \
36 const unsigned char XTP##name##__Data4_2 = (b3); \
37 const unsigned char XTP##name##__Data4_3 = (b4); \
38 const unsigned char XTP##name##__Data4_4 = (b5); \
39 const unsigned char XTP##name##__Data4_5 = (b6); \
40 const unsigned char XTP##name##__Data4_6 = (b7); \
41 const unsigned char XTP##name##__Data4_7 = (b8);
42
43XTP_DEFINE_GUID(LIBID_XtremeSyntaxEdit,0xCA73588D,0x282F,0x4592,0x93,0x69,0xA6,0x1C,0xC2,0x44,0xFA,0xDA);
44XTP_DEFINE_GUID(DIID_ISyntaxEditGlobalSettings,0xC0DE2430,0xC45B,0x4319,0xA3,0x8F,0x9F,0x92,0x97,0xAC,0x56,0xEF);
45XTP_DEFINE_GUID(DIID_SyntaxEditTextPosition,0xC0DE2430,0x9B37,0x4919,0x98,0x53,0xF8,0xC7,0x1A,0xC1,0x31,0x70);
46XTP_DEFINE_GUID(DIID_SyntaxEditTextSelection,0xC0DE2430,0x1E28,0x4880,0x9D,0x4E,0x97,0x06,0x9B,0x34,0x58,0x99);
47XTP_DEFINE_GUID(DIID_SyntaxEditPrintOptions,0xC0DE2430,0xF565,0x4076,0x95,0x30,0x5B,0x63,0x86,0x39,0x96,0x4D);
48XTP_DEFINE_GUID(DIID_SyntaxEditDataManager,0xC0DE2430,0x4EF1,0x4ea0,0x9C,0x0C,0xF2,0xFF,0x65,0x18,0xA0,0x0E);
49XTP_DEFINE_GUID(DIID_SyntaxEditPaintManager,0xC0DE2430,0xE55D,0x40e1,0xA0,0xE5,0x4A,0xFF,0x47,0x8A,0x70,0x42);
50XTP_DEFINE_GUID(DIID_SyntaxEditLineMarksManager,0xC0DE2430,0x04D4,0x4770,0xB8,0x5B,0x72,0x3E,0xA0,0xF2,0x71,0x36);
51XTP_DEFINE_GUID(DIID_SyntaxEditAutoCompleteWnd,0xC0DE2430,0x4CB8,0x48E7,0xAA,0x9B,0x1E,0x27,0xCB,0xE0,0x56,0xAE);
52XTP_DEFINE_GUID(DIID__DSyntaxEdit,0xC0DE2430,0xCC75,0x4462,0xAA,0xBB,0x21,0x18,0x09,0x2E,0x0E,0x1A);
53XTP_DEFINE_GUID(DIID__DSyntaxEditEvents,0xC0DE2430,0x13B2,0x4eeb,0xB4,0xB8,0xDB,0x0D,0x5E,0x3F,0x7B,0x24);
54XTP_DEFINE_GUID(CLSID_SyntaxEdit,0xC0DE2430,0x1557,0x497D,0xB5,0x22,0x62,0xBC,0x13,0x29,0xA5,0xA7);
55XTP_DEFINE_GUID(DIID__DSyntaxEditFrame,0xC0DE2430,0x49DD,0x423A,0xA4,0x81,0x5F,0x37,0x07,0x4C,0xD2,0xB7);
56XTP_DEFINE_GUID(DIID__DSyntaxEditFrameEvents,0xC0DE2430,0xAE1F,0x4ECC,0x81,0x1C,0xE2,0x3F,0xD6,0xC4,0xA5,0xBA);
57XTP_DEFINE_GUID(CLSID_SyntaxEditFrame,0xC0DE2430,0x4E21,0x4EE0,0xAE,0x53,0x0C,0x2C,0x36,0x4C,0x51,0xDD);
58XTP_DEFINE_GUID(CLSID_SyntaxEditGlobalSettings,0xC0DE2430,0x48B3,0x4DD2,0xA4,0xC6,0x1F,0xAB,0xA9,0xAC,0x06,0x41);
59
60#undef XTP_DEFINE_GUID
61
62// clang-format on
63
64#endif // __XTPSyntaxEditIIDs_H__


Toolkit Pro: XTPSyntaxEditLexCfgFileReader.h File Reference

  • Source
  • SyntaxEdit
Classes | Functions
XTPSyntaxEditLexCfgFileReader.h File Reference

Go to the source code of this file.

Classes

class CXTPSyntaxEditFileChangesMonitor
this class monitors files changes More...

Functions

AFX_INLINE CXTPSyntaxEditLexCfgFileReader *AFX_CDECL XTPSyntaxEditLexConfig ()
Gets the CXTPSyntaxEditLexCfgFileReader global object.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Function Documentation

◆ XTPSyntaxEditLexConfig()

AFX_INLINE CXTPSyntaxEditLexCfgFileReader *AFX_CDECL XTPSyntaxEditLexConfig ( )

Gets the CXTPSyntaxEditLexCfgFileReader global object.

Returns
A pointer to a CXTPSyntaxEditLexCfgFileReader object.


Toolkit Pro: XTPSyntaxEditLexClass.h File Reference

  • Source
  • SyntaxEdit
Classes | Enumerations | Variables
XTPSyntaxEditLexClass.h File Reference

Go to the source code of this file.

Classes

class | CXTPSyntaxEditLexVariable
XTPSyntaxEditLexAnalyser namespace is used group text parser classes, separate them from others and to make class names shorter without risk to be duplicated. More...
class | CXTPSyntaxEditLexVariant
CXTPSyntaxEditLexVariant provides functionality to manipulate Lexical Analyzer's related variant type. More...
class | CXTPSyntaxEditLexOnScreenParseCnt
CXTPSyntaxEditLexOnScreenParseCnt provides context data storage for OnScreen iterated parsing process. More...
class | CXTPSyntaxEditLexClass
CXTPSyntaxEditLexClass class is used to represent lexical block of text definition and to parse text. More...

Enumerations

enum XTPSyntaxEditLexVariantType {
xtpEditLVT_Unknown = 0 , xtpEditLVT_className = 0x0001 , xtpEditLVT_classPtr = 0x0002 , xtpEditLVT_LVArrayPtr = 0x0004 ,
xtpEditLVT_valInt = 0x0100 , xtpEditLVT_valStr = 0x0200 , xtpEditLVT_valVar = 0x0400
}
Enumerates types of values which supported by CXTPSyntaxEditLexVariant class. More...
enum XTPSyntaxEditLexClass_OptParent {
xtpEditOptParent_Unknown = 0 , xtpEditOptParent_Default = -1 , xtpEditOptParent_file = 1 , xtpEditOptParent_direct = 2 ,
xtpEditOptParent_dyn = 3
}
Enumerates parent class relation for the Lex Class object. More...
enum XTPSyntaxEditLexClass_OptChildren { xtpEditOptChildren_Unknown = 0 , xtpEditOptChildren_No = 1 , xtpEditOptChildren_Any , xtpEditOptChildren_List = 3 }
Enumerates children classes relation for the Lex Class object. More...

Variables

static const TCHAR | XTPLEX_ATTR_TXTPREFIX [] = _T("txt:")
Class schema (public) attributes.
static const TCHAR | XTPLEX_ATTR_COLORPREFIX [] = _T("txt:color")
Prefix of properties which value is color.
static const TCHAR | XTPLEX_ATTR_TXT_COLORFG [] = _T("txt:colorFG")
Text color.
static const TCHAR | XTPLEX_ATTR_TXT_COLORBK [] = _T("txt:colorBK")
Text back ground color.
static const TCHAR | XTPLEX_ATTR_TXT_COLORSELFG [] = _T("txt:colorSelFG")
Selected text color.
static const TCHAR | XTPLEX_ATTR_TXT_COLORSELBK [] = _T("txt:colorSelBK")
Selected text back ground color.
static const TCHAR | XTPLEX_ATTR_TXT_BOLD [] = _T("txt:Bold")
Text font Bold flag.
static const TCHAR | XTPLEX_ATTR_TXT_ITALIC [] = _T("txt:Italic")
Text font Italic flag.
static const TCHAR | XTPLEX_ATTR_TXT_UNDERLINE [] = _T("txt:Underline")
Text font Underline flag.
static const TCHAR | XTPLEX_ATTR_CASESENSITIVE [] = _T("CaseSensitive")
Lex Class CaseSensitive flag.
static const TCHAR | XTPLEX_ATTR_COLLAPSABLE [] = _T("Collapsable")
Lex Class Collapsable flag.
static const TCHAR | XTPLEX_ATTR_COLLAPSEDTEXT [] = _T("CollapsedText")
Collapsed Lex Class mark text.
static const TCHAR | XTPLEX_ATTR_PARSEONSCREEN [] = _T("ParseOnScreen")
Parse Lex Class only for screen drawing.
static const TCHAR | XTPLEX_ATTR_RESTARTRUNLOOP []
if set to 1 - run children loop will be restarted from the beginning when class ended, otherwise next child class will run.
static const TCHAR | XTPLEX_ATTR_ENDCLASSPARENT []
if set to 'this' the end block must have this class as parent.
static const TCHAR | XTPLEX_ATTR_RECURRENCEDEPTH [] = _T("RecurrenceDepth")
define depth of the recurrence blocks.
static const TCHAR | XTPLEX_ATTR_DISPLAYNAME [] = _T("DisplayName")
Friendly name to display in options dialog.
static const TCHAR | XTPLEX_ATTRG_FIRSTPARSEINSEPARATETHREAD []
{0,1} default=1
static const TCHAR | XTPLEX_ATTRG_EDITREPARCEINSEPARATETHREAD []
{0,1} default=1
static const TCHAR | XTPLEX_ATTRG_CONFIGCHANGEDREPARCEINSEPARATETHREAD []
{0,1} default=1
static const TCHAR | XTPLEX_ATTRG_EDITREPARCETIMEOUT_MS []
time out for start reparse after last key was pressed.
static const TCHAR | XTPLEX_ATTRG_MAXBACKPARSEOFFSET []
maximum back buffer size.
static const TCHAR | XTPLEX_ATTRG_ONSCREENSCHCACHELIFETIME_SEC []
default= 180 sec; -1 and 0 means infinite; time out for on screen parsed pieces of text.
static const TCHAR | XTPLEX_ATTRG_PARSERTHREADIDLELIFETIME_SEC []
default=60 sec; -1 and 0 means infinite; time out for existing of parser thread when parser idle (no parse requests).
static const TCHAR | XTPLEX_ATTRCLASSID [] = _T("ClassID")
Lex Class ID, unique for the classes tree.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Enumeration Type Documentation

◆ XTPSyntaxEditLexClass_OptChildren

enum XTPSyntaxEditLexClass_OptChildren

Enumerates children classes relation for the Lex Class object.

See also
CXTPSyntaxEditLexClass::CXTPSyntaxEditChildren
Enumerator
xtpEditOptChildren_Unknown | Undefined value.
xtpEditOptChildren_No | Lex Class cannot have children.
xtpEditOptChildren_Any | Lex Class have children specified by their 'parent' property
xtpEditOptChildren_List | Lex Class can have only children from list and specified by their 'parent' property.

◆ XTPSyntaxEditLexClass_OptParent

enum XTPSyntaxEditLexClass_OptParent

Enumerates parent class relation for the Lex Class object.

See also
CXTPSyntaxEditLexClass::CXTPSyntaxEditParent.
Enumerator
xtpEditOptParent_Unknown | Undefined value.
xtpEditOptParent_Default | Use default relation value.
xtpEditOptParent_file | Lex Class is the top in classes hierarchy: level file.
xtpEditOptParent_direct | Lex Class can be child of specified parent class only directly.
xtpEditOptParent_dyn | Lex Class can be child of specified parent class dynamically. (no only directly, but child of child of child ...)

◆ XTPSyntaxEditLexVariantType

enum XTPSyntaxEditLexVariantType

Enumerates types of values which supported by CXTPSyntaxEditLexVariant class.

See also
CXTPSyntaxEditLexVariant
Enumerator
xtpEditLVT_Unknown | designates unknown type of value
xtpEditLVT_className | designates value of lex class name (or class names array) type
xtpEditLVT_classPtr | designates value of lex class Pointer type
xtpEditLVT_LVArrayPtr | designates value of LexVariants array Pointer type
xtpEditLVT_valInt | designates value of integer type
xtpEditLVT_valStr | designates value of character string (or string array) type
xtpEditLVT_valVar | designates value of lex variable

Variable Documentation

◆ XTPLEX_ATTR_COLLAPSEDTEXT

const TCHAR XTPLEX_ATTR_COLLAPSEDTEXT[] = _T("CollapsedText")
static

Collapsed Lex Class mark text.

(like [..])

◆ XTPLEX_ATTR_TXTPREFIX

const TCHAR XTPLEX_ATTR_TXTPREFIX[] = _T("txt:")
static

Class schema (public) attributes.

Text properties (like color, bold, ...) attributes prefix.

◆ XTPLEX_ATTRG_MAXBACKPARSEOFFSET

const TCHAR XTPLEX_ATTRG_MAXBACKPARSEOFFSET[]
static
Initial value:
=
_T("global:MaxBackParseOffset")

maximum back buffer size.

Some times parser look back for the text from current position.

◆ XTPLEX_ATTRG_ONSCREENSCHCACHELIFETIME_SEC

const TCHAR XTPLEX_ATTRG_ONSCREENSCHCACHELIFETIME_SEC[]
static
Initial value:
=
_T("global:OnScreenSchCacheLifeTime_sec")

default= 180 sec; -1 and 0 means infinite; time out for on screen parsed pieces of text.

for memory using optimization.


Toolkit Pro: XTPSyntaxEditLexClassSubObjDef.h File Reference

  • Source
  • SyntaxEdit
XTPSyntaxEditLexClassSubObjDef.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPSyntaxEditLexClassSubObjT.h File Reference

  • Source
  • SyntaxEdit
Functions
XTPSyntaxEditLexClassSubObjT.h File Reference

Go to the source code of this file.

Functions

XTP_DEFINE_SMART_PTR_INTERNAL (CXTPSyntaxEditLexAutomatWordsMap) class _XTP_EXT_CLASS CXTPSyntaxEditLexTagsAutomat
This class helps to automate the lexical tags.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPSyntaxEditLexColorFileReader.h File Reference

  • Source
  • SyntaxEdit
Classes | Enumerations
XTPSyntaxEditLexColorFileReader.h File Reference

Go to the source code of this file.

Classes

class | CXTPSyntaxEditColorInfo
This storage class is designed to contain information from the color settings file section. More...
class | CXTPSyntaxEditColorInfoArray
This collection class stores the color info objects. More...
class | CXTPSyntaxEditColorTheme
This class provides the functionality to read configuration information from configuration files with a predefined structure. More...
class | CXTPSyntaxEditColorThemesManager
This class provides the functionality to store the set of all color themes that would be written from configuration files. More...
class | CXTPSyntaxEditTextSchemesManager
This class provides the functionality to store the set of all text schemes that would be written from configuration files. More...
class | CXTPSyntaxEditConfigurationManager
This class manages all configuration parameters of the control. More...

Enumerations

enum XTPSyntaxEditCfgFlags { xtpEditCfgFileAdd = 0x0001 , xtpEditCfgFileRemove = 0x0002 }
This enumeration describes allowable configuration managers flags. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Enumeration Type Documentation

◆ XTPSyntaxEditCfgFlags

enum XTPSyntaxEditCfgFlags

This enumeration describes allowable configuration managers flags.

Enumerator
xtpEditCfgFileAdd | File should be added.
xtpEditCfgFileRemove | File should be removed.


Toolkit Pro: XTPSyntaxEditLexParser.h File Reference

  • Source
  • SyntaxEdit
Classes | Enumerations
XTPSyntaxEditLexParser.h File Reference

Go to the source code of this file.

Classes

class | CXTPSyntaxEditTextRegion
This class is designed to store the coordinates of a text region. More...
class | CXTPSyntaxEditLexTokensDef
This class stores tokens definition: a list of tokens and corresponding lists of start and end tokens separators. More...
class | CXTPSyntaxEditLexParserSchemaOptions
This class is designed to easily manipulate parser options. More...
class | CXTPSyntaxEditLexTextBlock
The CXTPSyntaxEditLexTextBlock class represents a block of text which corresponds to a lex class in a text schema. More...
class | CXTPSyntaxEditLexTextSchema
The CXTPSyntaxEditLexTextSchema class is used to store data which is necessary to parse a text and parsing results. More...
class | CXTPSyntaxEditLexParser
This class used to 'run' lex schema parsing in a separate thread. More...

Enumerations

enum XTPSyntaxEditLexParseResult {
xtpEditLPR_Unknown = 0 , xtpEditLPR_StartFound = 0x001 , xtpEditLPR_EndFound = 0x002 , xtpEditLPR_Iterated = 0x010 ,
xtpEditLPR_TBpop1 = 0x020 , xtpEditLPR_Error = 0x100 , xtpEditLPR_RunFinished = 0x200 , xtpEditLPR_RunBreaked = 0x400 ,
xtpEditLPR_RunRestart = 0x800
}
Enumerates flags which indicate the results of parse function calls. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Enumeration Type Documentation

◆ XTPSyntaxEditLexParseResult

enum XTPSyntaxEditLexParseResult

Enumerates flags which indicate the results of parse function calls.

See also
CXTPSyntaxEditLexClass, CXTPSyntaxEditLexTextSchema
Enumerator
xtpEditLPR_Unknown | Undefined value.
xtpEditLPR_StartFound | Start text block was found.
xtpEditLPR_EndFound | End text block was found.
xtpEditLPR_Iterated | Indicates that the current text position has already moved to the next char inside a function call.
xtpEditLPR_TBpop1 | Indicates that the new found text block should be inserted before the previous one and as a parent of it.
xtpEditLPR_Error | Iterated parse process breaked due to some error. See trace for details.
xtpEditLPR_RunFinished | Run iterated parse process (or some big part of it) has finished.
xtpEditLPR_RunBreaked | Run iterated parse process (or some big part of it) has breaked.
xtpEditLPR_RunRestart | Restart run children from the beginning.


Toolkit Pro: XTPSyntaxEditLexPtrs.h File Reference

  • Source
  • SyntaxEdit
XTPSyntaxEditLexPtrs.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPSyntaxEditLineMarksManager.h File Reference

  • Source
  • SyntaxEdit
Classes | Enumerations
XTPSyntaxEditLineMarksManager.h File Reference

Go to the source code of this file.

Classes

class CXTPSyntaxEditLineMarksManager
The CXTPSyntaxEditLineMarksManager class provides functionality to manipulate marks on text lines. More...

Enumerations

enum XTPSyntaxEditLineMarksRefreshType {
xtpEditLMRefresh_Unknown = 0 , xtpEditLMRefresh_Insert = 0x01 , xtpEditLMRefresh_Delete = 0x02 , xtpEditLMRefresh_Delete_only1 = 0x10 ,
xtpEditLMRefresh_Delete_only2 = 0x20 , xtpEditLMRefresh_InsertAt0 = 0x40
}
Enumerates types of mark refreshing. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Enumeration Type Documentation

◆ XTPSyntaxEditLineMarksRefreshType

enum XTPSyntaxEditLineMarksRefreshType

Enumerates types of mark refreshing.

Enumerator
xtpEditLMRefresh_Unknown | Unknown refresh state.
xtpEditLMRefresh_Insert | Mark inserted.
xtpEditLMRefresh_Delete | Mark deleted.
xtpEditLMRefresh_Delete_only1 | Delete mark for first row of deleted text block.
xtpEditLMRefresh_Delete_only2 | Delete mark for last row of deleted text block.
xtpEditLMRefresh_InsertAt0 | Move mark for first row of inserted text block.


Toolkit Pro: XTPSyntaxEditPaintManager.h File Reference

  • Source
  • SyntaxEdit
Classes
XTPSyntaxEditPaintManager.h File Reference

Go to the source code of this file.

Classes

class CXTPSyntaxEditPaintManager
This class is used by CXTPSyntaxEditCtrl as the paint manager. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPSyntaxEditPropertiesDlg.h File Reference

  • Source
  • SyntaxEdit
Classes
XTPSyntaxEditPropertiesDlg.h File Reference

Go to the source code of this file.

Classes

class CXTPSyntaxEditPropertiesDlg
This class provides a default dialog to edit SyntaxEdit control settings. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPSyntaxEditPropertiesPage.h File Reference

  • Source
  • SyntaxEdit
Classes
XTPSyntaxEditPropertiesPage.h File Reference

Go to the source code of this file.

Classes

class | CXTPSyntaxEditTipWnd
CXTPSyntaxEditTipWnd implements a tooltip window for the CXTPSyntaxEditTipListBox class. More...
class | CXTPSyntaxEditTipListBox
This class implements a list box with a tooltip. More...
class | CXTPSyntaxEditTipComboBox
This class implements a combo box with a tooltip. More...
class | CXTPSyntaxEditPropertiesPageEdit
This class implements a property page for common edit options. More...
class | CXTPSyntaxEditPropertiesPageFont
This class implements property page font options. More...
class | CXTPSyntaxEditPropertiesPageColor
This class implements property page colors options. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPSyntaxEditSectionManager.h File Reference

  • Source
  • SyntaxEdit
XTPSyntaxEditSectionManager.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPSyntaxEditSelection.h File Reference

  • Source
  • SyntaxEdit
Classes
XTPSyntaxEditSelection.h File Reference

Go to the source code of this file.

Classes

class CXTPSyntaxEditSelection
This class is used to represent syntax edit text selection and allows for selection properties to be get and set in two measurements: string and display. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPSyntaxEditStruct.h File Reference

  • Source
  • SyntaxEdit
Classes | Macros | Variables
XTPSyntaxEditStruct.h File Reference

Go to the source code of this file.

Classes

struct | XTP_EDIT_LINECOL
The XTP_EDIT_LINECOL structure represents the coordinates of text items on the displaying context in terms of line/column. More...
struct | XTP_EDIT_COLORVALUES
Stores the colors for different phrases. More...
struct | XTP_EDIT_ROWSBLOCK
XTP_EDIT_ROWSBLOCK structure. More...
struct | XTP_EDIT_COLLAPSEDBLOCK
Stores collapsed block parameters. More...
struct | XTP_EDIT_FONTOPTIONS
The XTP_EDIT_FONTOPTIONS structure is a self-initializing LOGFONT structure that initializes all values equal to XTP_EDIT_FONTOPTIONS_UNSPEC_OPTION except for lfFaceName which is set to zero length. More...
struct | XTP_EDIT_TEXTBLOCK
Summary The XTP_EDIT_TEXTBLOCK structure stores the text blocks after parsing. More...
struct | XTP_EDIT_ROWCOLRECT
The XTP_EDIT_ROWCOLRECT structure is used to define a row and column selection rectangle. More...
struct | XTP_EDIT_SENMBOOKMARK
Bookmark notification structure. More...
struct | XTP_EDIT_NMHDR_ROWCOLCHANGED
Row column notification structure. More...
struct | XTP_EDIT_NMHDR_DOCMODIFIED
Document notification structure. More...
struct | XTP_EDIT_NMHDR_EDITCHANGED
Structure to notify "Edit changed" event. More...
struct | XTP_EDIT_NMHDR_MARGINCLICKED
Structure to notify XTP_EDIT_NM_MARGINCLICKED event. More...
struct | XTP_EDIT_NMHDR_SETSCROLLPOS
Structure to notify XTP_EDIT_NM_UPDATESCROLLPOS event. More...
struct | XTP_EDIT_NMHDR_ENABLESCROLLBAR
Structure to notify XTP_EDIT_NM_ENABLESCROLLBAR event. More...
struct | XTP_EDIT_NMHDR_PARSEEVENT
Structure to notify XTP_EDIT_NM_PARSEEVENT event. More...

Macros

#define | XTP_EDIT_XLC(nL, nC)
max line: 1 048 575 max col: 4 095
#define | XTP_EDIT_FONTOPTIONS_UNSPEC_OPTION (BYTE) - 1
Used with XTP_EDIT_FONTOPTIONS struct and define unspecified member value.

Variables

const UINT | XTP_EDIT_ROWNODE_NOTHING = 0x00
Define that row has no node mark.
const UINT | XTP_EDIT_ROWNODE_COLLAPSED = 0x01
Define that row has collapsed node mark.
const UINT | XTP_EDIT_ROWNODE_EXPANDED = 0x02
Define that row has expanded node mark.
const UINT | XTP_EDIT_ROWNODE_ENDMARK = 0x04
Define that row has end node mark.
const UINT | XTP_EDIT_ROWNODE_NODEUP = 0x10
Define that row has up-line node mark.
const UINT | XTP_EDIT_ROWNODE_NODEDOWN = 0x20
Define that row has down-line node mark.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Macro Definition Documentation

◆ XTP_EDIT_FONTOPTIONS_UNSPEC_OPTION

#define XTP_EDIT_FONTOPTIONS_UNSPEC_OPTION (BYTE) - 1

Used with XTP_EDIT_FONTOPTIONS struct and define unspecified member value.

See also
XTP_EDIT_FONTOPTIONS


Toolkit Pro: XTPSyntaxEditTextIterator.h File Reference

  • Source
  • SyntaxEdit
Classes
XTPSyntaxEditTextIterator.h File Reference

Go to the source code of this file.

Classes

class CXTPSyntaxEditTextIterator
This class provides functionality to navigate text in the data buffer, seek forward/backward, retrieve text by lines, and determine control symbols like CRLF. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPSyntaxEditToolTipCtrl.h File Reference

  • Source
  • SyntaxEdit
Classes
XTPSyntaxEditToolTipCtrl.h File Reference

Go to the source code of this file.

Classes

class CXTPSyntaxEditToolTipCtrl
The CXTPSyntaxEditToolTipCtrl class encapsulates the functionality of a "tip control," a small pop-up window that displays a single line of text describing the hidden text when hovering over an item on the report area. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPSyntaxEditUndoManager.h File Reference

  • Source
  • SyntaxEdit
Classes
XTPSyntaxEditUndoManager.h File Reference

Go to the source code of this file.

Classes

class | CXTPSyntaxEditCommand
This class represents an abstract Edit Control command interface. More...
class | CXTPSyntaxEditBatchCommand
This class represents a pack of commands in one. More...
class | CXTPSyntaxEditBufferCommand
The base class for all edit commands related to CXTPSyntaxEditBufferManager. More...
class | CXTPSyntaxEditBufferCommand::CXTPSyntaxEditBufferKeepOverwriteSettings
Keeps the buffer overwrite flag for the specified buffer manager from class construction until destruction, and resets this flag to FALSE during class lifetime. More...
class | CXTPSyntaxEditInsertStringCommand
This class represents the insert string command. More...
class | CXTPSyntaxEditDeleteStringCommand
This class represents the delete string command. More...
class | CXTPSyntaxEditReplaceStringCommand
This class represents the replace string command. More...
class | CXTPSyntaxEditUndoRedoManager
This class maintains the list of undo/redo commands. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPSyntaxEditView.h File Reference

  • Source
  • SyntaxEdit
Classes
XTPSyntaxEditView.h File Reference

Go to the source code of this file.

Classes

class | CXTPSyntaxEditViewPrintOptions
Describes printing options for the Calendar control. More...
class | CXTPSyntaxEditView
This class represents a View portion of the Edit Control. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: TabManager Directory Reference

  • Source
  • TabManager
TabManager Directory Reference

Directories

ColorSets
Themes

Files

XTPTabControl.h
XTPTabManager.h
XTPTabManagerAtom.h
XTPTabManagerDefines.h
XTPTabManagerIIDs.h
XTPTabManagerItem.h
XTPTabManagerNavigateButton.h
XTPTabManagerNavigateButtons.h
XTPTabPaintManager.h
XTPTabPaintManagerColorSet.h
XTPTabPaintManagerTheme.h


Toolkit Pro: ColorSets Directory Reference

  • Source
  • TabManager
  • ColorSets
ColorSets Directory Reference

Files

XTPTabColorSetDefault.h
XTPTabColorSetNativeWindows10.h
XTPTabColorSetNativeWindows11.h
XTPTabColorSetOffice2003.h
XTPTabColorSetOffice2007.h
XTPTabColorSetOffice2007Access.h
XTPTabColorSetOffice2013.h
XTPTabColorSetVisualStudio2003.h
XTPTabColorSetVisualStudio2005.h
XTPTabColorSetVisualStudio2008.h
XTPTabColorSetVisualStudio2010.h
XTPTabColorSetVisualStudio2012.h
XTPTabColorSetVisualStudio2012Dark.h
XTPTabColorSetVisualStudio2015.h
XTPTabColorSetVisualStudio2017.h
XTPTabColorSetVisualStudio2019.h
XTPTabColorSetVisualStudio2022.h
XTPTabColorSetWinNative.h


Toolkit Pro: XTPTabColorSetDefault.h File Reference

  • Source
  • TabManager
  • ColorSets
Classes
XTPTabColorSetDefault.h File Reference

Go to the source code of this file.

Classes

class CXTPTabColorSetDefault
CXTPTabColorSetDefault implements a default tab color set. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTabColorSetNativeWindows10.h File Reference

  • Source
  • TabManager
  • ColorSets
Classes
XTPTabColorSetNativeWindows10.h File Reference

Go to the source code of this file.

Classes

class CXTPTabColorSetNativeWindows10
CXTPTabColorSetNativeWindows10 implements a Native Windows 10 tab color set. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTabColorSetNativeWindows11.h File Reference

  • Source
  • TabManager
  • ColorSets
Classes
XTPTabColorSetNativeWindows11.h File Reference

Go to the source code of this file.

Classes

class CXTPTabColorSetNativeWindows11
CXTPTabColorSetNativeWindows11 implements a Native Windows 10 tab color set. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTabColorSetOffice2003.h File Reference

  • Source
  • TabManager
  • ColorSets
Classes
XTPTabColorSetOffice2003.h File Reference

Go to the source code of this file.

Classes

class CXTPTabColorSetOffice2003
CXTPTabColorSetOffice2003 implements an Office 2003 tab color set. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTabColorSetOffice2007.h File Reference

  • Source
  • TabManager
  • ColorSets
Classes
XTPTabColorSetOffice2007.h File Reference

Go to the source code of this file.

Classes

class CXTPTabColorSetOffice2007
CXTPTabColorSetOffice2007 implements an Office 2007 tab color set. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTabColorSetOffice2007Access.h File Reference

  • Source
  • TabManager
  • ColorSets
Classes
XTPTabColorSetOffice2007Access.h File Reference

Go to the source code of this file.

Classes

class CXTPTabColorSetOffice2007Access
CXTPTabColorSetOffice2007Access implements an Office 2007 Access tab color set. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTabColorSetOffice2013.h File Reference

  • Source
  • TabManager
  • ColorSets
Classes
XTPTabColorSetOffice2013.h File Reference

Go to the source code of this file.

Classes

class CXTPTabColorSetOffice2013
CXTPTabColorSetOffice2013 implements an Office 2013 tab color set. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTabColorSetVisualStudio2003.h File Reference

  • Source
  • TabManager
  • ColorSets
Classes
XTPTabColorSetVisualStudio2003.h File Reference

Go to the source code of this file.

Classes

class CColorSetVisualStudio2003
CColorSetVisualStudio2003 implements a Visual Studio 2003 tab color set. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTabColorSetVisualStudio2005.h File Reference

  • Source
  • TabManager
  • ColorSets
Classes
XTPTabColorSetVisualStudio2005.h File Reference

Go to the source code of this file.

Classes

class CColorSetVisualStudio2005
CColorSetVisualStudio2005 implements a Visual Studio 2005 tab color set. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTabColorSetVisualStudio2008.h File Reference

  • Source
  • TabManager
  • ColorSets
Classes
XTPTabColorSetVisualStudio2008.h File Reference

Go to the source code of this file.

Classes

class CXTPTabColorSetVisualStudio2008
CXTPTabColorSetVisualStudio2008 implements a Visual Studio 2008 tab color set. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTabColorSetVisualStudio2010.h File Reference

  • Source
  • TabManager
  • ColorSets
Classes
XTPTabColorSetVisualStudio2010.h File Reference

Go to the source code of this file.

Classes

class CXTPTabColorSetVisualStudio2010
CXTPTabColorSetVisualStudio2010 implements a Visual Studio 2010 tab color set. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTabColorSetVisualStudio2012.h File Reference

  • Source
  • TabManager
  • ColorSets
Classes
XTPTabColorSetVisualStudio2012.h File Reference

Go to the source code of this file.

Classes

class CXTPTabColorSetVisualStudio2012
CXTPTabColorSetVisualStudio2012 implements a Visual Studio 2012 tab color set. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTabColorSetVisualStudio2012Dark.h File Reference

  • Source
  • TabManager
  • ColorSets
Classes
XTPTabColorSetVisualStudio2012Dark.h File Reference

Go to the source code of this file.

Classes

class CXTPTabColorSetVisualStudio2012Dark
CXTPTabColorSetVisualStudio2012Dark implements a Visual Studio 2012 Dark tab color set. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTabColorSetVisualStudio2015.h File Reference

  • Source
  • TabManager
  • ColorSets
Classes
XTPTabColorSetVisualStudio2015.h File Reference

Go to the source code of this file.

Classes

class CXTPTabColorSetVisualStudio2015
CXTPTabColorSetVisualStudio2015 implements a Visual Studio 2015 tab color set. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTabColorSetVisualStudio2017.h File Reference

  • Source
  • TabManager
  • ColorSets
Classes
XTPTabColorSetVisualStudio2017.h File Reference

Go to the source code of this file.

Classes

class CXTPTabColorSetVisualStudio2017
CXTPTabColorSetVisualStudio2017 implements a Visual Studio 2017 tab color set. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTabColorSetVisualStudio2019.h File Reference

  • Source
  • TabManager
  • ColorSets
Classes
XTPTabColorSetVisualStudio2019.h File Reference

Go to the source code of this file.

Classes

class CXTPTabColorSetVisualStudio2019
CXTPTabColorSetVisualStudio2019 implements a Visual Studio 2019 tab color set. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTabColorSetVisualStudio2022.h File Reference

  • Source
  • TabManager
  • ColorSets
Classes
XTPTabColorSetVisualStudio2022.h File Reference

Go to the source code of this file.

Classes

class CXTPTabColorSetVisualStudio2022
CXTPTabColorSetVisualStudio2022 implements a Visual Studio 2022 tab color set. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTabColorSetWinNative.h File Reference

  • Source
  • TabManager
  • ColorSets
Classes
XTPTabColorSetWinNative.h File Reference

Go to the source code of this file.

Classes

class CColorSetWinNative
CColorSetWinNative implements a Windows XP tab color set. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: Themes Directory Reference

  • Source
  • TabManager
  • Themes
Themes Directory Reference

Files

XTPTabThemeExcel2003.h
XTPTabThemeFlat.h
XTPTabThemeNativeWindows10.h
XTPTabThemeNativeWindows11.h
XTPTabThemeOffice2000.h
XTPTabThemeOffice2013.h
XTPTabThemePropertyPage2003.h
XTPTabThemePropertyPage2007.h
XTPTabThemePropertyPageAccess2007.h
XTPTabThemePropertyPageFlat.h
XTPTabThemePropertyPageSelected.h
XTPTabThemeStateButtons.h
XTPTabThemeVisio.h
XTPTabThemeVisualStudio2003.h
XTPTabThemeVisualStudio2005.h
XTPTabThemeVisualStudio2010.h
XTPTabThemeVisualStudio2012.h
XTPTabThemeVisualStudio2015.h
XTPTabThemeVisualStudio2017.h
XTPTabThemeVisualStudio2019.h
XTPTabThemeVisualStudio2022.h


Toolkit Pro: XTPTabThemeExcel2003.h File Reference

  • Source
  • TabManager
  • Themes
Classes
XTPTabThemeExcel2003.h File Reference

Go to the source code of this file.

Classes

class CXTPTabThemeExcel2003
CXTPTabThemeExcel2003 implements an Excel tab appearance. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTabThemeFlat.h File Reference

  • Source
  • TabManager
  • Themes
Classes
XTPTabThemeFlat.h File Reference

Go to the source code of this file.

Classes

class CXTPTabThemeFlat
CXTPTabThemeFlat implements a "Flat" tab appearance. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTabThemeNativeWindows10.h File Reference

  • Source
  • TabManager
  • Themes
Classes
XTPTabThemeNativeWindows10.h File Reference

Go to the source code of this file.

Classes

class CXTPTabThemeNativeWindows10
CXTPTabThemeNativeWindows10 implements a Native Windows 10 tab appearance. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTabThemeNativeWindows11.h File Reference

  • Source
  • TabManager
  • Themes
Classes
XTPTabThemeNativeWindows11.h File Reference

Go to the source code of this file.

Classes

class CXTPTabThemeNativeWindows11
CXTPTabThemeNativeWindows11 implements a Native Windows 10 tab appearance. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTabThemeOffice2000.h File Reference

  • Source
  • TabManager
  • Themes
Classes
XTPTabThemeOffice2000.h File Reference

Go to the source code of this file.

Classes

class CXTPTabThemeOffice2000
CXTPTabThemeOffice2000 implements an Office 2000 tab appearance. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTabThemeOffice2013.h File Reference

  • Source
  • TabManager
  • Themes
Classes
XTPTabThemeOffice2013.h File Reference

Go to the source code of this file.

Classes

class CXTPTabThemeOffice2013
CXTPTabThemeOffice2013 implements an Office 2013 tab appearance. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTabThemePropertyPage2003.h File Reference

  • Source
  • TabManager
  • Themes
Classes
XTPTabThemePropertyPage2003.h File Reference

Go to the source code of this file.

Classes

class CAppearanceSetPropertyPage2003
CAppearanceSetPropertyPage2003 implements an Office 2003 tab appearance. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTabThemePropertyPage2007.h File Reference

  • Source
  • TabManager
  • Themes
Classes
XTPTabThemePropertyPage2007.h File Reference

Go to the source code of this file.

Classes

class CAppearanceSetPropertyPage2007
CAppearanceSetPropertyPage2007 implements an Office 2007 tab appearance. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTabThemePropertyPageAccess2007.h File Reference

  • Source
  • TabManager
  • Themes
Classes
XTPTabThemePropertyPageAccess2007.h File Reference

Go to the source code of this file.

Classes

class CAppearanceSetPropertyPageAccess2007
CAppearanceSetPropertyPageAccess2007 implements an Office 2007 tab appearance. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTabThemePropertyPageFlat.h File Reference

  • Source
  • TabManager
  • Themes
Classes
XTPTabThemePropertyPageFlat.h File Reference

Go to the source code of this file.

Classes

class CAppearanceSetPropertyPageFlat
CAppearanceSetPropertyPageFlat implements an Office 2000 Flat tab appearance. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTabThemePropertyPageSelected.h File Reference

  • Source
  • TabManager
  • Themes
Classes
XTPTabThemePropertyPageSelected.h File Reference

Go to the source code of this file.

Classes

class CAppearanceSetPropertyPageSelected
CAppearanceSetPropertyPageSelected implements an "Office 2000 Selected" tab appearance. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTabThemeStateButtons.h File Reference

  • Source
  • TabManager
  • Themes
Classes
XTPTabThemeStateButtons.h File Reference

Go to the source code of this file.

Classes

class CAppearanceSetStateButtons
CAppearanceSetStateButtons implements a "State Button" tab appearance. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTabThemeVisio.h File Reference

  • Source
  • TabManager
  • Themes
Classes
XTPTabThemeVisio.h File Reference

Go to the source code of this file.

Classes

class CAppearanceSetVisio
CAppearanceSetVisio implements a Visio tab appearance. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTabThemeVisualStudio2003.h File Reference

  • Source
  • TabManager
  • Themes
Classes
XTPTabThemeVisualStudio2003.h File Reference

Go to the source code of this file.

Classes

class CXTPTabThemeVisualStudio2003
CXTPTabThemeVisualStudio2003 implements a Visual Studio 2003 tab appearance. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTabThemeVisualStudio2005.h File Reference

  • Source
  • TabManager
  • Themes
Classes
XTPTabThemeVisualStudio2005.h File Reference

Go to the source code of this file.

Classes

class CAppearanceSetVisualStudio2005
CAppearanceSetVisualStudio2005 implements a Visual Studio 2005 tab appearance. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTabThemeVisualStudio2010.h File Reference

  • Source
  • TabManager
  • Themes
Classes
XTPTabThemeVisualStudio2010.h File Reference

Go to the source code of this file.

Classes

class CXTPTabThemeVisualStudio2010
CXTPTabThemeVisualStudio2010 implements a Visual Studio 2010 tab appearance. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTabThemeVisualStudio2012.h File Reference

  • Source
  • TabManager
  • Themes
Classes
XTPTabThemeVisualStudio2012.h File Reference

Go to the source code of this file.

Classes

class CXTPTabThemeVisualStudio2012
CXTPTabThemeVisualStudio2012 implements a Visual Studio 2012 tab appearance. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTabThemeVisualStudio2015.h File Reference

  • Source
  • TabManager
  • Themes
Classes
XTPTabThemeVisualStudio2015.h File Reference

Go to the source code of this file.

Classes

class CXTPTabThemeVisualStudio2015
CXTPTabThemeVisualStudio2015 implements a Visual Studio 2015 tab appearance. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTabThemeVisualStudio2017.h File Reference

  • Source
  • TabManager
  • Themes
Classes
XTPTabThemeVisualStudio2017.h File Reference

Go to the source code of this file.

Classes

class CXTPTabThemeVisualStudio2017
CXTPTabThemeVisualStudio2017 implements a Visual Studio 2017 tab appearance. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTabThemeVisualStudio2019.h File Reference

  • Source
  • TabManager
  • Themes
Classes
XTPTabThemeVisualStudio2019.h File Reference

Go to the source code of this file.

Classes

class CXTPTabThemeVisualStudio2019
CXTPTabThemeVisualStudio2019 implements a Visual Studio 2019 tab appearance. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTabThemeVisualStudio2022.h File Reference

  • Source
  • TabManager
  • Themes
Classes
XTPTabThemeVisualStudio2022.h File Reference

Go to the source code of this file.

Classes

class CXTPTabThemeVisualStudio2022
CXTPTabThemeVisualStudio2022 implements a Visual Studio 2022 tab appearance. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTabControl.h File Reference

  • Source
  • TabManager
Classes
XTPTabControl.h File Reference

Go to the source code of this file.

Classes

class CXTPTabControl
CXTPTabControl is used to draw an enhanced tab control with Office 2003, Visual Studio, or Win XP tabs. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTabManager.h File Reference

  • Source
  • TabManager
Classes | Variables
XTPTabManager.h File Reference

Go to the source code of this file.

Classes

class | CXTPTabManager
CXTPTabManager is the base class for docking pane tabs, tab control tabs, and MDI client tabs. More...
struct | CXTPTabManager::ROW_ITEMS
Helper structure that contains the first and last item indices of rows of the tab manager. More...
class | CXTPTabManager::CRowIndexer
Helper class used to collect the indices of rows for a multi-row tab manager. More...

Variables

const UINT WM_XTP_GETTABCOLOR = (WM_USER + 9400 + 1)
The WM_XTP_GETTABCOLOR message is sent to an MDI child window to retrieve the color that will be used for a tabbed interface with enabled OneNote colors.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Variable Documentation

◆ WM_XTP_GETTABCOLOR

const UINT WM_XTP_GETTABCOLOR = (WM_USER + 9400 + 1)

The WM_XTP_GETTABCOLOR message is sent to an MDI child window to retrieve the color that will be used for a tabbed interface with enabled OneNote colors.

You can override CXTPTabClientWnd::GetItemColor instead of processing this message.

Returns
The color that will be used for a tabbed interface with enabled OneNote colors.

Example: Here is an example of how an application would process the WM_XTP_GETTABCOLOR message:

BEGIN_MESSAGE_MAP(CChildFrame, CMDIChildWnd)
    //{{AFX_MSG_MAP(CChildFrame)
    ON_MESSAGE(WM_XTP_GETTABCOLOR, OnGetTabColor)
    //}}AFX_MSG_MAP
END_MESSAGE_MAP()

LRESULT CChildFrame::OnGetTabColor(WPARAM, LPARAM)
{
    return CXTPTabPaintManager::GetOneNoteColor(xtpTabColorOrange);
}
See also
CXTPTabPaintManager::GetOneNoteColor, CXTPTabClientWnd, WM_XTP_GETWINDOWTEXT, WM_XTP_GETTABICON, WM_XTP_GETWINDOWTOOLTIP


Toolkit Pro: XTPTabManagerAtom.h File Reference

  • Source
  • TabManager
Classes
XTPTabManagerAtom.h File Reference

Go to the source code of this file.

Classes

class CXTPTabManagerAtom
CXTPTabManagerAtom is a class that has only one purpose; to catch the event when a property of the PaintManager is changed. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTabManagerDefines.h File Reference

  • Source
  • TabManager
Enumerations | Variables
XTPTabManagerDefines.h File Reference

Go to the source code of this file.

Enumerations

enum | XTPTabNavigateButtonFlags { xtpTabNavigateButtonNone , xtpTabNavigateButtonAutomatic , xtpTabNavigateButtonAlways }
XTPTabNavigateButtonFlags is an enumeration used to indicate when a navigate button will be displayed. More...
enum XTPTabAppearanceStyle {
xtpTabAppearancePropertyPage = 0 , xtpTabAppearancePropertyPageSelected = 1 , xtpTabAppearancePropertyPageFlat = 2 , xtpTabAppearancePropertyPage2003 = 3 ,
xtpTabAppearanceStateButtons = 4 , xtpTabAppearanceFlat = 6 , xtpTabAppearanceExcel2003 = 7 , xtpTabAppearanceVisio = 8 ,
xtpTabAppearancePropertyPage2007 = 10 , xtpTabAppearancePropertyPageAccess2007 = 11 , xtpTabAppearanceVisualStudio2003 = 5 , xtpTabAppearanceVisualStudio2005 = 9 ,
xtpTabAppearanceVisualStudio2010 = 12 , xtpTabAppearanceVisualStudio2012 = 13 , xtpTabAppearanceVisualStudio2015 = 15 , xtpTabAppearanceVisualStudio2017 = 17 ,
xtpTabAppearanceVisualStudio2019 = 18 , xtpTabAppearanceVisualStudio2022 = 19 , xtpTabAppearanceOffice2013 = 14 , xtpTabAppearanceOffice2016 = xtpTabAppearanceOffice2013 ,
xtpTabAppearanceNativeWindows10 = 16 , xtpTabAppearanceNativeWindows11 = 20
}
XTPTabAppearanceStyle is an enumeration used to set the appearance of tabs. More...
enum XTPTabColorStyle {
xtpTabColorDefault = 0x0001 , xtpTabColorOffice2003 = 0x0004 , xtpTabColorWinNative = 0x0008 , xtpTabColorResource = 0x0020 ,
xtpTabColorOffice2007Access = 0x0080 , xtpTabColorVisualStudio2003 = 0x0002 , xtpTabColorVisualStudio2005 = 0x0010 , xtpTabColorVisualStudio2008 = 0x0040 ,
xtpTabColorVisualStudio2010 = 0x0100 , xtpTabColorVisualStudio2012 = 0x0200 , xtpTabColorVisualStudio2012Dark = 0x0400 , xtpTabColorOffice2013 = 0x0800 ,
xtpTabColorOffice2016 = xtpTabColorOffice2013 , xtpTabColorVisualStudio2015 = 0x1000 , xtpTabColorNativeWindows10 = 0x2000 , xtpTabColorVisualStudio2017 = 0x4000 ,
xtpTabColorVisualStudio2019 = 0x8000 , xtpTabColorVisualStudio2022 = 0x00010000 , xtpTabColorNativeWindows11 = 0x00020000 , xtpTabColorAll = 0xFFFFFFFF
}
XTPTabColorStyle is an enumeration used to set the color style of tabs. More...
enum | XTPTabPosition { xtpTabPositionTop , xtpTabPositionLeft , xtpTabPositionBottom , xtpTabPositionRight }
XTPTabPosition is an enumeration used to set the position of tabs. More...
enum XTPTabLayoutStyle {
xtpTabLayoutAutoSize , xtpTabLayoutSizeToFit , xtpTabLayoutFixed , xtpTabLayoutCompressed ,
xtpTabLayoutMultiRow , xtpTabLayoutRotated
}
XTPTabLayoutStyle is an enumeration used to set the layout of tabs. More...
enum | XTPTabToolTipBehaviour { xtpTabToolTipNever , xtpTabToolTipAlways , xtpTabToolTipShrinkedOnly }
XTPTabToolTipBehaviour is an enumeration used to set the tooltip behaviour for tabs. More...
enum XTPTabOneNoteColor {
xtpTabColorBlue = 0x1000000 , xtpTabColorYellow = 0x1000001 , xtpTabColorGreen = 0x1000002 , xtpTabColorRed = 0x1000003 ,
xtpTabColorPurple = 0x1000004 , xtpTabColorCyan = 0x1000005 , xtpTabColorOrange = 0x1000006 , xtpTabColorMagenta = 0x1000007
}
XTPTabOneNoteColor is an enumeration used to indicate which OneNote RGB color value to retrieve. More...
enum XTPTabWorkspacePart {
xtpTabWorkspacePartBorder , xtpTabWorkspacePartWidth , xtpTabWorkspacePartVSplitter , xtpTabWorkspacePartHSplitter ,
xtpTabWorkspacePartBack
}
XTPTabWorkspacePart is an enumeration used to indicate which part of the MDI TabWorkspace must be redrawn. More...
enum | XTPTabClientFrame { xtpTabFrameBorder , xtpTabFrameSingleLine , xtpTabFrameNone }
XTPTabClientFrame is an enumeration used to set the client frame style drawn around the client of tabs. More...
enum | XTPTabNavigateButton { xtpTabNavigateButtonLeft , xtpTabNavigateButtonRight , xtpTabNavigateButtonClose , xtpTabNavigateButtonActiveFiles }
XTPTabNavigateButton is an enumeration used to identify navigation buttons within a tab control. More...

Variables

const COLORREF | XTP_TABMANAGER_COLOR_NONE = (COLORREF)(-1)
Indicates that a transparent color should be used.
const COLORREF | XTP_TABMANAGER_COLOR_SHADED = (COLORREF)(-2)
Indicates a special "shaded" fill type.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Enumeration Type Documentation

◆ XTPTabAppearanceStyle

enum XTPTabAppearanceStyle

XTPTabAppearanceStyle is an enumeration used to set the appearance of tabs.

Example:

m_wndTabControl.SetAppearance(xtpTabAppearancePropertyPage2003);
See also
CXTPTabManager::SetAppearance, CXTPTabPaintManager::SetAppearance
Enumerator
xtpTabAppearancePropertyPage | Gives your tabs an Office 2000 appearance.
xtpTabAppearancePropertyPageSelected | Gives your tabs an Office 2000 selected appearance.
xtpTabAppearancePropertyPageFlat | Gives your tabs an Office 2000 Flat appearance.
xtpTabAppearancePropertyPage2003 | Gives your tabs an Office 2003 appearance.
xtpTabAppearanceStateButtons | Gives your tabs a State Button appearance.
xtpTabAppearanceFlat | Gives your tabs a Flat appearance.
xtpTabAppearanceExcel2003 | Gives your tabs an Excel 2003 appearance.
xtpTabAppearanceVisio | Gives your tabs a Visio appearance.
xtpTabAppearancePropertyPage2007 | Gives your tabs an Office 2007 appearance.
xtpTabAppearancePropertyPageAccess2007 | Gives your tabs an Office 2007 appearance.
xtpTabAppearanceVisualStudio2003 | Gives your tabs a Visual Studio 2003 appearance.
xtpTabAppearanceVisualStudio2005 | Gives your tabs a Visual Studio 2005 appearance.
xtpTabAppearanceVisualStudio2010 | Gives your tabs a Visual Studio 2010 appearance.
xtpTabAppearanceVisualStudio2012 | Gives your tabs a Visual Studio 2012 appearance.
xtpTabAppearanceVisualStudio2015 | Gives your tabs a Visual Studio 2015 appearance.
xtpTabAppearanceVisualStudio2017 | Gives your tabs a Visual Studio 2017 appearance.
xtpTabAppearanceVisualStudio2019 | Gives your tabs a Visual Studio 2019 appearance.
xtpTabAppearanceVisualStudio2022 | Gives your tabs a Visual Studio 2022 appearance.
xtpTabAppearanceOffice2013 | Office 2013 appearance.
xtpTabAppearanceOffice2016 | Office 2016 appearance.
xtpTabAppearanceNativeWindows10 | Gives your tabs a Native Windows 10 appearance.
xtpTabAppearanceNativeWindows11 | Gives your tabs a Native Windows 11 appearance.

◆ XTPTabClientFrame

enum XTPTabClientFrame

XTPTabClientFrame is an enumeration used to set the client frame style drawn around the client of tabs.

Example:

m_wndTabControl.GetPaintManager()->m_clientFrame = xtpTabFrameBorder;
See also
CXTPTabManager, CXTPTabPaintManager
Enumerator
xtpTabFrameBorder | With this flag set, a border will appear around the client area.
xtpTabFrameSingleLine | With this flag set, only a single line is used as a border around the client area.
xtpTabFrameNone | With this flag set, no border will appear around the client area.

◆ XTPTabColorStyle

enum XTPTabColorStyle

XTPTabColorStyle is an enumeration used to set the color style of tabs.

Example:

m_wndTabControl.SetColor(xtpTabColorVisualStudio2005);
See also
CXTPTabManager::SetColor, CXTPTabPaintManager::SetColor, CXTPTabManager::GetColor, CXTPTabPaintManager::GetColor
Enumerator
xtpTabColorDefault | Tabs will use the default color for the currently set Appearance.
xtpTabColorOffice2003 | Tabs will use the Office 2003 color style for the currently set Appearance.
xtpTabColorWinNative | Tabs will use the Windows XP color style for the currently set Appearance.
xtpTabColorResource | Tabs will use the Office 2007 color style for the currently set Appearance.
xtpTabColorOffice2007Access | Tabs will use the Office 2007 Access color style for the currently set Appearance.
xtpTabColorVisualStudio2003 | Tabs will use the Visual Studio 2003 color style for the currently set Appearance.
xtpTabColorVisualStudio2005 | Tabs will use the Visual Studio 2005 color style for the currently set Appearance.
xtpTabColorVisualStudio2008 | Tabs will use the Visual Studio 2008 color style for the currently set Appearance.
xtpTabColorVisualStudio2010 | Tabs will use the Visual Studio 2010 color style for the currently set Appearance.
xtpTabColorVisualStudio2012 | Tabs will use the Visual Studio 2012 color style for the currently set Appearance.
xtpTabColorVisualStudio2012Dark | Tabs will use the Visual Studio 2012 Dark color style for the currently set Appearance.
xtpTabColorOffice2013 | Tabs will use the Office 2013 style for the currently set Appearance.
xtpTabColorOffice2016 | Tabs will use the Office 2016 style for the currently set Appearance.
xtpTabColorVisualStudio2015 | Tabs will use the Visual Studio 2015 color style for the currently set Appearance.
xtpTabColorNativeWindows10 | Tabs will use the Native Windows 10 color style for the currently set Appearance.
xtpTabColorVisualStudio2017 | Tabs will use the Visual Studio 2017 color style for the currently set Appearance.
xtpTabColorVisualStudio2019 | Tabs will use the Visual Studio 2019 color style for the currently set Appearance.
xtpTabColorVisualStudio2022 | Tabs will use the Visual Studio 2022 color style for the currently set Appearance.
xtpTabColorNativeWindows11 | Tabs will use the Native Windows 11 color style for the currently set Appearance.
xtpTabColorAll | A mask for all tab colors.

◆ XTPTabLayoutStyle

enum XTPTabLayoutStyle

XTPTabLayoutStyle is an enumeration used to set the layout of tabs.

Example:

m_wndTabControl.SetLayoutStyle(xtpTabLayoutCompressed);
See also
CXTPTabManager::SetLayoutStyle, CXTPTabManager::GetLayout
Enumerator
xtpTabLayoutAutoSize | Tabs will be automatically sized based on the caption and image size. With this flag set, tabs will appear in their normal size.
xtpTabLayoutSizeToFit | Tabs are sized to fit within the tab panel. All tabs will be compressed and forced to fit into the tab panel.
xtpTabLayoutFixed | All tabs will be set to a fixed size within the tab panel.
xtpTabLayoutCompressed | Tabs will be compressed within the tab panel. This will compress the size of the tabs, but all tabs will not be forced into the tab panel.
xtpTabLayoutMultiRow | Causes a tab control to display multiple rows of tabs.
xtpTabLayoutRotated | Rotated tab layout (i.e. all tabs will be rotated to 90 degrees).

◆ XTPTabNavigateButton

enum XTPTabNavigateButton

XTPTabNavigateButton is an enumeration used to identify navigation buttons within a tab control.

This enumerator is used by the CXTPTabManagerNavigateButton class to identify navigation buttons.

Example: See XTPTabNavigateButtonFlags for an example.

See also
XTPTabNavigateButtonFlags, CXTPTabManager, CXTPTabManagerNavigateButton
Enumerator
xtpTabNavigateButtonLeft | Left tab navigation button.
xtpTabNavigateButtonRight | Right tab navigation button.
xtpTabNavigateButtonClose | Close tab navigation button.
xtpTabNavigateButtonActiveFiles | Active Files button (used in XTPTabClientWnd only).

◆ XTPTabNavigateButtonFlags

enum XTPTabNavigateButtonFlags

XTPTabNavigateButtonFlags is an enumeration used to indicate when a navigate button will be displayed.

This style is applied to one button. Navigate buttons include the left, right, and close buttons that appear in the tab header area.

If the xtpTabNavigateButtonAutomatic flag is used, then buttons will only appear when needed (e.g. when there are too many tabs to be displayed in the tab header, the arrow buttons will appear).

Example: This example code illustrates how to specify when the tab navigation buttons are displayed:

//Gets a reference to the tab manager
CXTPTabManager* pManager = GetManager();
if (pManager)
{
   //Finds the left navigation button and specifies that it is always displayed
   pManager->FindNavigateButton(xtpTabNavigateButtonLeft)->SetFlags(xtpTabNavigateButtonAlways);
   //Finds the right navigation button and specifies that it is never displayed
   pManager->FindNavigateButton(xtpTabNavigateButtonRight)->SetFlags(xtpTabNavigateButtonNone);
   //Finds the close navigation button and specifies that it is always displayed
   pManager->FindNavigateButton(xtpTabNavigateButtonClose)->SetFlags(xtpTabNavigateButtonAlways);
}
//Called to recalculate tab area and reposition components
pManager->Reposition();
See also
CXTPTabManagerNavigateButton, CXTPTabManagerNavigateButton::SetFlags, CXTPTabManagerNavigateButton::GetFlags, xtpTabNavigateButtonNone, xtpTabNavigateButtonAutomatic, xtpTabNavigateButtonAlways
Enumerator
xtpTabNavigateButtonNone | Never display the navigate button.
xtpTabNavigateButtonAutomatic | Automatically display the navigate button.
xtpTabNavigateButtonAlways | Always display the navigate button.

◆ XTPTabOneNoteColor

enum XTPTabOneNoteColor

XTPTabOneNoteColor is an enumeration used to indicate which OneNote RGB color value to retrieve.

This enumerator is used by CXTPTabPaintManager::GetOneNoteColor to retrieve a specified OneNote RGB color value.

Example: See WM_XTP_GETTABCOLOR for an example.

See also
CXTPTabPaintManager::GetOneNoteColor, CXTPTabManager::GetItemColor, CXTPDockingPane::GetItemColor
Enumerator
xtpTabColorBlue | Blue tab color used when OneNote colors enabled.
xtpTabColorYellow | Yellow tab color used when OneNote colors enabled.
xtpTabColorGreen | Green tab color used when OneNote colors enabled.
xtpTabColorRed | Red tab color used when OneNote colors enabled.
xtpTabColorPurple | Purple tab color used when OneNote colors enabled.
xtpTabColorCyan | Cyan tab color used when OneNote colors enabled.
xtpTabColorOrange | Orange tab color used when OneNote colors enabled.
xtpTabColorMagenta | Magenta tab color used when OneNote colors enabled.

◆ XTPTabPosition

enum XTPTabPosition

XTPTabPosition is an enumeration used to set the position of tabs.

Example:

m_wndTabControl.SetPosition(xtpTabPositionBottom);
See also
CXTPTabManager::SetPosition, CXTPTabManager::GetPosition
Enumerator
xtpTabPositionTop | Tabs will be drawn on the Top.
xtpTabPositionLeft | Tabs will be drawn on the Left.
xtpTabPositionBottom | Tabs will be drawn on the Bottom.
xtpTabPositionRight | Tabs will be drawn on the Right.

◆ XTPTabToolTipBehaviour

enum XTPTabToolTipBehaviour

XTPTabToolTipBehaviour is an enumeration used to set the tooltip behaviour for tabs.

Example:

m_wndTabControl.GetPaintManager()->EnableToolTips(xtpTabToolTipAlways);
See also
CXTPTabPaintManager::EnableToolTips, XTPTabLayoutStyle
Enumerator
xtpTabToolTipNever | Never show tooltips for tabs.
xtpTabToolTipAlways | Always show tooltips for tabs.
xtpTabToolTipShrinkedOnly | Only show tooltips if the tab was shrinked (see xtpTabLayoutSizeToFit layout).

◆ XTPTabWorkspacePart

enum XTPTabWorkspacePart

XTPTabWorkspacePart is an enumeration used to indicate which part of the MDI TabWorkspace must be redrawn.

The enumerators are used by CXTPTabPaintManagerTheme::DrawWorkspacePart when redrawing the MDITabClient TabWorkspace when grouping is enabled.

See also
CXTPTabPaintManagerTheme::DrawWorkspacePart
Enumerator
xtpTabWorkspacePartBorder | Indicates the border of the MDITabClient TabWorkspace should be drawn.
xtpTabWorkspacePartWidth | Indicates the border width of the MDITabClient TabWorkspace should be recalculated (i.e. when adding or removing a static frame).
xtpTabWorkspacePartVSplitter | Indicates the vertical splitter of the MDITabClient TabWorkspace should be drawn.
xtpTabWorkspacePartHSplitter | Indicates the horizontal splitter of the MDITabClient TabWorkspace should be drawn.
xtpTabWorkspacePartBack | Indicates the background of the MDITabClient TabWorkspace should be drawn.

Variable Documentation

◆ XTP_TABMANAGER_COLOR_NONE

const COLORREF XTP_TABMANAGER_COLOR_NONE = (COLORREF)(-1)

Indicates that a transparent color should be used.

If the RGB color value of an object is XTP_TABMANAGER_COLOR_NONE, then this indicates that the object should not be drawn. This is used in the tab appearance and color function to indicate when tab borders, highlighting, shadowing, etc. should be drawn.

Setting a member of CXTPTabPaintManagerColorSet to XTP_TABMANAGER_COLOR_NONE will indicate that the member should not be drawn.

See also
CXTPTabPaintManagerColorSet

◆ XTP_TABMANAGER_COLOR_SHADED

const COLORREF XTP_TABMANAGER_COLOR_SHADED = (COLORREF)(-2)

Indicates a special "shaded" fill type.

To get the "shaded" effect, the object will be filled with one pixel COLOR_3DFACE, then one pixel COLOR_3DHIGHLIGHT, then one pixel COLOR_3DFACE, then one pixel COLOR_3DHIGHLIGHT, and so on.

Setting the clrLight parameter to XTP_TABMANAGER_COLOR_SHADED in the used in CXTPTabPaintManagerColorSet::GradientFill member will cause the object to be filled with the special shaded fill. Note: The special fill is used to colorize the currently selected tab and within xtpTabAppearanceStateButtons to colorize the button face. The special fill can be applied to any color member.

See also
CXTPTabPaintManagerColorSet::GradientFill


Toolkit Pro: XTPTabManagerIIDs.h Source File

  • Source
  • TabManager
XTPTabManagerIIDs.h
1// DO NOT MODIFY MANUALLY
2// Generated on Thu 12/11/2025 at 12:46:07.69 using cj-update-iids.cmd
3
24#ifndef __XTPTabManagerIIDs_H__
25# define __XTPTabManagerIIDs_H__
26
27// clang-format off
28
29#define XTP_DEFINE_GUID(name,l,w1,w2,b1,b2,b3,b4,b5,b6,b7,b8) \
30 EXTERN_C __declspec(selectany) const IID XTP##name = {l,w1,w2,{b1,b2,b3,b4,b5,b6,b7,b8}}; \
31 const unsigned long XTP##name##__Data1 = (l); \
32 const unsigned short XTP##name##__Data2 = (w1); \
33 const unsigned short XTP##name##__Data3 = (w2); \
34 const unsigned char XTP##name##__Data4_0 = (b1); \
35 const unsigned char XTP##name##__Data4_1 = (b2); \
36 const unsigned char XTP##name##__Data4_2 = (b3); \
37 const unsigned char XTP##name##__Data4_3 = (b4); \
38 const unsigned char XTP##name##__Data4_4 = (b5); \
39 const unsigned char XTP##name##__Data4_5 = (b6); \
40 const unsigned char XTP##name##__Data4_6 = (b7); \
41 const unsigned char XTP##name##__Data4_7 = (b8);
42
43XTP_DEFINE_GUID(DIID_ITabManagerMargin,0xC0DE2430,0xB4E9,0x45c7,0xAA,0xF6,0xEF,0x34,0x0E,0x78,0x55,0x90);
44XTP_DEFINE_GUID(CLSID_TabManagerMargin,0xC0DE2430,0x90EE,0x4D24,0x8F,0x7A,0xDA,0x71,0xBD,0xEC,0x35,0xA8);
45XTP_DEFINE_GUID(DIID_ITabPaintManagerColorSet,0xC0DE2430,0xED71,0x4B4E,0x91,0xCF,0x84,0x44,0xD6,0x24,0x4F,0x56);
46XTP_DEFINE_GUID(CLSID_TabPaintManagerColorSet,0xC0DE2430,0x494B,0x4521,0xB7,0x09,0xC3,0x24,0xC2,0xC0,0x95,0x78);
47XTP_DEFINE_GUID(DIID_ITabPaintManager,0xC0DE2430,0x9CE6,0x4D40,0xB6,0xC5,0x3B,0x94,0x25,0xFB,0xB5,0x5A);
48XTP_DEFINE_GUID(CLSID_TabPaintManager,0xC0DE2430,0xBDD4,0x4257,0x8C,0xF4,0xA2,0xAB,0x16,0x74,0xC5,0x1E);
49XTP_DEFINE_GUID(DIID_ITabControlItem,0xC0DE2430,0x9479,0x48D5,0xA1,0x4D,0x07,0x7A,0x9F,0xD5,0xD2,0x76);
50XTP_DEFINE_GUID(CLSID_TabControlItem,0xC0DE2430,0x9808,0x4CBF,0xBA,0xC2,0xF2,0x45,0x5C,0x8C,0x8A,0x46);
51
52#undef XTP_DEFINE_GUID
53
54// clang-format on
55
56#endif // __XTPTabManagerIIDs_H__


Toolkit Pro: XTPTabManagerItem.h File Reference

  • Source
  • TabManager
Classes
XTPTabManagerItem.h File Reference

Go to the source code of this file.

Classes

class CXTPTabManagerItem
CXTPTabManagerItem is the base class for the tabs that appear in the command bars tab workspace, docking panes, and tab control. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTabManagerNavigateButton.h File Reference

  • Source
  • TabManager
Classes
XTPTabManagerNavigateButton.h File Reference

Go to the source code of this file.

Classes

class CXTPTabManagerNavigateButton
CXTPTabManagerNavigateButton is a class used to represent a tab navigation button. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTabManagerNavigateButtons.h File Reference

  • Source
  • TabManager
Classes
XTPTabManagerNavigateButtons.h File Reference

Go to the source code of this file.

Classes

class CXTPTabManagerNavigateButtons
CXTPTabManagerNavigateButtons is a class used to represent a collection of tab navigation buttons. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTabPaintManager.h File Reference

  • Source
  • TabManager
Classes
XTPTabPaintManager.h File Reference

Go to the source code of this file.

Classes

class CXTPTabPaintManager
CXTPTabPaintManager is used to store the color and appearance information of the tabs in the tab manager. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTabPaintManagerColorSet.h File Reference

  • Source
  • TabManager
Classes
XTPTabPaintManagerColorSet.h File Reference

Go to the source code of this file.

Classes

class | CXTPTabPaintManagerColorSet
CXTPTabPaintManagerColorSet represents the colors for all of the components of the tab manager (e.g. More...
struct | CXTPTabPaintManagerColorSet::COLORSET_TAB_EXCEL
Colors used for Excel tab button colorization. More...
struct | CXTPTabPaintManagerColorSet::COLORSET_TAB_PROPERTYPAGE
Colors used for Office 2000 tab button colorization. More...
struct | CXTPTabPaintManagerColorSet::COLORSET_TAB_PROPERTYPAGE2003
Colors used for Office 2003 tab button colorization. More...
struct | CXTPTabPaintManagerColorSet::COLORSET_TAB_STATEBUTTON
Colors used for "State Button" tab button colorization. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTabPaintManagerTheme.h File Reference

  • Source
  • TabManager
Classes
XTPTabPaintManagerTheme.h File Reference

Go to the source code of this file.

Classes

class CXTPTabPaintManagerTheme
CXTPTabPaintManagerTheme is a class that represents the appearance of all components of the tab manager (e.g. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: TaskPanel Directory Reference

  • Source
  • TaskPanel
TaskPanel Directory Reference

Directories

Themes

Files

XTPTaskPanel.h
XTPTaskPanelAnimation.h
XTPTaskPanelDefines.h
XTPTaskPanelGroup.h
XTPTaskPanelGroupItem.h
XTPTaskPanelIIDs.h
XTPTaskPanelItem.h
XTPTaskPanelItems.h
XTPTaskPanelPaintManager.h


Toolkit Pro: Themes Directory Reference

  • Source
  • TaskPanel
  • Themes
Themes Directory Reference

Files

XTPTaskPanelExplorerTheme.h
XTPTaskPanelExplorerThemePlain.h
XTPTaskPanelListViewOffice2003Theme.h
XTPTaskPanelListViewOfficeXPTheme.h
XTPTaskPanelListViewTheme.h
XTPTaskPanelNativeWindows10Theme.h
XTPTaskPanelNativeWindows11Theme.h
XTPTaskPanelOffice2003Theme.h
XTPTaskPanelOffice2003ThemePlain.h
XTPTaskPanelOffice2013Theme.h
XTPTaskPanelOfficeXPThemePlain.h
XTPTaskPanelPaintManagerPlain.h
XTPTaskPanelShortcutBarOffice2003Theme.h
XTPTaskPanelShortcutBarOffice2007Theme.h
XTPTaskPanelToolboxTheme.h
XTPTaskPanelVisualStudio2005Theme.h
XTPTaskPanelVisualStudio2010Theme.h
XTPTaskPanelVisualStudio2012Theme.h
XTPTaskPanelVisualStudio2015Theme.h
XTPTaskPanelVisualStudio2017Theme.h
XTPTaskPanelVisualStudio2019Theme.h
XTPTaskPanelVisualStudio2022Theme.h


Toolkit Pro: XTPTaskPanelExplorerTheme.h File Reference

  • Source
  • TaskPanel
  • Themes
Classes
XTPTaskPanelExplorerTheme.h File Reference

Go to the source code of this file.

Classes

class CXTPTaskPanelExplorerTheme
CXTPTaskPanelExplorerTheme represents an Explorer style theme. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTaskPanelExplorerThemePlain.h File Reference

  • Source
  • TaskPanel
  • Themes
Classes
XTPTaskPanelExplorerThemePlain.h File Reference

Go to the source code of this file.

Classes

class CXTPTaskPanelExplorerThemePlain
CXTPTaskPanelExplorerThemePlain represents a classic Explorer style theme. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTaskPanelListViewOffice2003Theme.h File Reference

  • Source
  • TaskPanel
  • Themes
Classes
XTPTaskPanelListViewOffice2003Theme.h File Reference

Go to the source code of this file.

Classes

class CXTPTaskPanelListViewOffice2003Theme
CXTPTaskPanelListViewOffice2003Theme represents a List View Office 2003 style theme. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTaskPanelListViewOfficeXPTheme.h File Reference

  • Source
  • TaskPanel
  • Themes
Classes
XTPTaskPanelListViewOfficeXPTheme.h File Reference

Go to the source code of this file.

Classes

class CXTPTaskPanelListViewOfficeXPTheme
CXTPTaskPanelListViewOfficeXPTheme represents a List View Office XP style theme. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTaskPanelListViewTheme.h File Reference

  • Source
  • TaskPanel
  • Themes
Classes
XTPTaskPanelListViewTheme.h File Reference

Go to the source code of this file.

Classes

class CXTPTaskPanelListViewTheme
CXTPTaskPanelListViewTheme class represents a List View style theme. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTaskPanelNativeWindows10Theme.h File Reference

  • Source
  • TaskPanel
  • Themes
Classes
XTPTaskPanelNativeWindows10Theme.h File Reference

Go to the source code of this file.

Classes

class CXTPTaskPanelNativeWindows10Theme
CXTPTaskPanelNativeWindows10Theme represents a Native Windows 10 style theme. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTaskPanelNativeWindows11Theme.h File Reference

  • Source
  • TaskPanel
  • Themes
Classes
XTPTaskPanelNativeWindows11Theme.h File Reference

Go to the source code of this file.

Classes

class CXTPTaskPanelNativeWindows11Theme
CXTPTaskPanelNativeWindows11Theme represents a Native Windows 10 style theme. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTaskPanelOffice2003Theme.h File Reference

  • Source
  • TaskPanel
  • Themes
Classes
XTPTaskPanelOffice2003Theme.h File Reference

Go to the source code of this file.

Classes

class CXTPTaskPanelOffice2003Theme
CXTPTaskPanelOffice2003Theme represents an Office 2003 style theme. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTaskPanelOffice2003ThemePlain.h File Reference

  • Source
  • TaskPanel
  • Themes
Classes
XTPTaskPanelOffice2003ThemePlain.h File Reference

Go to the source code of this file.

Classes

class CXTPTaskPanelOffice2003ThemePlain
CXTPTaskPanelOffice2003ThemePlain represents a classic Office 2003 style theme. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTaskPanelOffice2013Theme.h File Reference

  • Source
  • TaskPanel
  • Themes
Classes
XTPTaskPanelOffice2013Theme.h File Reference

Go to the source code of this file.

Classes

class CXTPTaskPanelOffice2013Theme
CXTPTaskPanelOffice2013Theme represents an Office 2013 style theme. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTaskPanelOfficeXPThemePlain.h File Reference

  • Source
  • TaskPanel
  • Themes
Classes
XTPTaskPanelOfficeXPThemePlain.h File Reference

Go to the source code of this file.

Classes

class CXTPTaskPanelOfficeXPThemePlain
CXTPTaskPanelOfficeXPThemePlain represents a classic Office XP style theme. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTaskPanelPaintManagerPlain.h File Reference

  • Source
  • TaskPanel
  • Themes
Classes
XTPTaskPanelPaintManagerPlain.h File Reference

Go to the source code of this file.

Classes

class CXTPTaskPanelPaintManagerPlain
Base class theme that all other themes are derived from. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTaskPanelShortcutBarOffice2003Theme.h File Reference

  • Source
  • TaskPanel
  • Themes
Classes
XTPTaskPanelShortcutBarOffice2003Theme.h File Reference

Go to the source code of this file.

Classes

class CXTPTaskPanelShortcutBarOffice2003Theme
CXTPTaskPanelShortcutBarOffice2003Theme represents an Office 2003 ShortcutBar style theme. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTaskPanelShortcutBarOffice2007Theme.h File Reference

  • Source
  • TaskPanel
  • Themes
Classes
XTPTaskPanelShortcutBarOffice2007Theme.h File Reference

Go to the source code of this file.

Classes

class CXTPTaskPanelShortcutBarOffice2007Theme
CXTPTaskPanelShortcutBarOffice2007Theme represents an Office 2007 ShortcutBar style theme. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTaskPanelToolboxTheme.h File Reference

  • Source
  • TaskPanel
  • Themes
Classes
XTPTaskPanelToolboxTheme.h File Reference

Go to the source code of this file.

Classes

class CXTPTaskPanelToolboxTheme
CXTPTaskPanelToolboxTheme represents a Toolbox style theme. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTaskPanelVisualStudio2005Theme.h File Reference

  • Source
  • TaskPanel
  • Themes
Classes
XTPTaskPanelVisualStudio2005Theme.h File Reference

Go to the source code of this file.

Classes

class CXTPTaskPanelVisualStudio2005Theme
CXTPTaskPanelVisualStudio2005Theme represents a Visual Studio 2005 style theme. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTaskPanelVisualStudio2010Theme.h File Reference

  • Source
  • TaskPanel
  • Themes
Classes
XTPTaskPanelVisualStudio2010Theme.h File Reference

Go to the source code of this file.

Classes

class CXTPTaskPanelVisualStudio2010Theme
CXTPTaskPanelVisualStudio2010Theme represents a VS.NET 2010 style theme. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTaskPanelVisualStudio2012Theme.h File Reference

  • Source
  • TaskPanel
  • Themes
Classes
XTPTaskPanelVisualStudio2012Theme.h File Reference

Go to the source code of this file.

Classes

class CXTPTaskPanelVisualStudio2012Theme
CXTPTaskPanelVisualStudio2012Theme represents a VS.NET 2012 style theme. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTaskPanelVisualStudio2015Theme.h File Reference

  • Source
  • TaskPanel
  • Themes
Classes
XTPTaskPanelVisualStudio2015Theme.h File Reference

Go to the source code of this file.

Classes

class CXTPTaskPanelVisualStudio2015Theme
CXTPTaskPanelVisualStudio2015Theme represents a Visutal Studio 2015 style theme. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTaskPanelVisualStudio2017Theme.h File Reference

  • Source
  • TaskPanel
  • Themes
Classes
XTPTaskPanelVisualStudio2017Theme.h File Reference

Go to the source code of this file.

Classes

class CXTPTaskPanelVisualStudio2017Theme
CXTPTaskPanelVisualStudio2017Theme represents a Visutal Studio 2017 style theme. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTaskPanelVisualStudio2019Theme.h File Reference

  • Source
  • TaskPanel
  • Themes
Classes
XTPTaskPanelVisualStudio2019Theme.h File Reference

Go to the source code of this file.

Classes

class CXTPTaskPanelVisualStudio2019Theme
CXTPTaskPanelVisualStudio2019Theme represents a Visutal Studio 2019 style theme. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTaskPanelVisualStudio2022Theme.h File Reference

  • Source
  • TaskPanel
  • Themes
Classes
XTPTaskPanelVisualStudio2022Theme.h File Reference

Go to the source code of this file.

Classes

class CXTPTaskPanelVisualStudio2022Theme
CXTPTaskPanelVisualStudio2022Theme represents a Visutal Studio 2022 style theme. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTaskPanel.h File Reference

  • Source
  • TaskPanel
Classes
XTPTaskPanel.h File Reference

Go to the source code of this file.

Classes

class | CXTPTaskPanelScrollButton
CXTPTaskPanelScrollButton is a standalone class that represents a task panel scroll button. More...
class | CXTPTaskPanel
CXTPTaskPanel is used to implement an Explorer and Office-like Task Panel control. More...
class | CXTPTaskPanel::CRepositionContext
CRepositionContext is a helper class used to lock/unlock redraw for the Task Panel. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTaskPanelAnimation.h File Reference

  • Source
  • TaskPanel
XTPTaskPanelAnimation.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTaskPanelDefines.h File Reference

  • Source
  • TaskPanel
Classes | Enumerations | Variables
XTPTaskPanelDefines.h File Reference

Go to the source code of this file.

Classes

struct | XTP_TPNGROUPEXPANDING
This structure is passed as a parameter when an XTP_TPN_GROUPEXPANDING event occurs. More...
struct | XTP_TPNENDLABELEDIT
This structure is passed as a parameter when an XTP_TPN_ENDLABELEDIT event occurs. More...

Enumerations

enum | XTPTaskPanelItemType { xtpTaskItemTypeGroup , xtpTaskItemTypeLink , xtpTaskItemTypeText , xtpTaskItemTypeControl }
XTPTaskPanelItemType is an enumeration used by CXTPTaskPanelItem to specify the type of the item. More...
enum XTPTaskPanelItemAllowDrag {
xtpTaskItemAllowDragNone = 0x00 , xtpTaskItemAllowDragDefault = 0x01 , xtpTaskItemAllowDragCopyWithinGroup = 0x02 , xtpTaskItemAllowDragCopyWithinControl = 0x04 ,
xtpTaskItemAllowDragCopyOutsideControl = 0x08 , xtpTaskItemAllowDragCopy = 0x04 + 0x08 , xtpTaskItemAllowDragMoveWithinGroup = 0x20 , xtpTaskItemAllowDragMoveWithinControl = 0x40 ,
xtpTaskItemAllowDragMoveOutsideControl = 0x80 , xtpTaskItemAllowDragMove = 0x40 + 0x80 , xtpTaskItemAllowDragWithinGroup = 0x02 + 0x20 , xtpTaskItemAllowDragWithinControl = 0x04 + 0x40 ,
xtpTaskItemAllowDrag = 0x04 + 0x08 + 0x40 + 0x80
}
XTPTaskPanelItemAllowDrag is an enumeration used by CXTPTaskPanel to specify the drag options. More...
enum | XTPTaskPanelItemLayout { xtpTaskItemLayoutDefault , xtpTaskItemLayoutImages , xtpTaskItemLayoutImagesWithText , xtpTaskItemLayoutImagesWithTextBelow }
XTPTaskPanelItemLayout is an enumeration used by CXTPTaskpanel and CXTPTaskPanelGroup to set how the items are laid out in the group(s). More...
enum XTPTaskPanelHotTrackStyle {
xtpTaskPanelHighlightDefault , xtpTaskPanelHighlightText , xtpTaskPanelHighlightImage , xtpTaskPanelHighlightItem ,
xtpTaskPanelHighlightNone
}
XTPTaskPanelHotTrackStyle is an enumeration used by CXTPTaskPanel to set the hot tracking style used for CXTPTaskPanelItems. More...
enum | XTPTaskPanelBehaviour { xtpTaskPanelBehaviourExplorer , xtpTaskPanelBehaviourList , xtpTaskPanelBehaviourToolbox }
XTPTaskPanelBehaviour is an enumeration used by CXTPTaskPanel and CXTPTaskPanelGroup to set the behavior of the groups in the TaskPanel. More...
enum XTPTaskPanelPaintTheme {
xtpTaskPanelThemeOffice2000 , xtpTaskPanelThemeOffice2003 , xtpTaskPanelThemeNativeWinXP , xtpTaskPanelThemeOffice2000Plain ,
xtpTaskPanelThemeOfficeXPPlain , xtpTaskPanelThemeOffice2003Plain , xtpTaskPanelThemeNativeWinXPPlain , xtpTaskPanelThemeVisualStudio2003 ,
xtpTaskPanelThemeVisualStudio2005 , xtpTaskPanelThemeListView , xtpTaskPanelThemeListViewOfficeXP , xtpTaskPanelThemeListViewOffice2003 ,
xtpTaskPanelThemeShortcutBarOffice2003 , xtpTaskPanelThemeResource , xtpTaskPanelThemeVisualStudio2010 , xtpTaskPanelThemeVisualStudio2012Light ,
xtpTaskPanelThemeVisualStudio2012Dark , xtpTaskPanelThemeOffice2013 , xtpTaskPanelThemeOffice2016 = xtpTaskPanelThemeOffice2013 , xtpTaskPanelThemeVisualStudio2015 ,
xtpTaskPanelThemeVisualStudio2017 , xtpTaskPanelThemeVisualStudio2019 , xtpTaskPanelThemeVisualStudio2022 , xtpTaskPanelThemeCustom ,
xtpTaskPanelThemeNativeWindows10 , xtpTaskPanelThemeNativeWindows11
}
XTPTaskPanelPaintTheme is an enumeration used by CXTPTaskPanel to set the theme of the control. More...
enum | XTPTaskPanelAnimation { xtpTaskPanelAnimationYes , xtpTaskPanelAnimationNo , xtpTaskPanelAnimationSystem }
XTPTaskPanelAnimation is an enumeration used by CXTPTaskPanel to set the animation of the control. More...

Variables

const UINT | XTPWM_TASKPANEL_NOTIFY = (WM_USER + 9195 + 1)
The XTPWM_TASKPANEL_NOTIFY message is sent to the CXTPTaskPanel owner window whenever an action occurs within the CXTPTaskPanel.
const UINT | XTP_TPN_CLICK = 1
const UINT | XTP_TPN_RCLICK = 2
const UINT | XTP_TPN_STARTDRAG = 3
const UINT | XTP_TPN_ENDLABELEDIT = 4
const UINT | XTP_TPN_ITEMDROP = 5
const UINT | XTP_TPN_GROUPEXPANDING = 6
const UINT | XTP_TPN_GROUPEXPANDED = 7
const UINT | XTP_TPN_DBLCLICK = 8
const UINT | XTP_TPN_FOCUSEDITEMCHANGED = 9
const UINT | XTP_TPN_ITEMREMOVED = 10
const UINT | XTP_TPN_HOTITEMCHANGED = 11
const UINT | XTP_TPN_GROUPMOVE = 12
const int | XTP_ACTION_CANCEL = -1

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Enumeration Type Documentation

◆ XTPTaskPanelAnimation

enum XTPTaskPanelAnimation

XTPTaskPanelAnimation is an enumeration used by CXTPTaskPanel to set the animation of the control.

Example:

m_wndTaskPanel.SetAnimation(xtpTaskPanelAnimationYes);
See also
CXTPTaskPanel::SetAnimation, CXTPTaskPanel::GetAnimation, xtpTaskPanelAnimationYes, xtpTaskPanelAnimationNo, xtpTaskPanelAnimationSystem
Enumerator
xtpTaskPanelAnimationYes | Enable animation.
xtpTaskPanelAnimationNo | Disable animation.
xtpTaskPanelAnimationSystem | Use system settings to determine animation.

◆ XTPTaskPanelBehaviour

enum XTPTaskPanelBehaviour

XTPTaskPanelBehaviour is an enumeration used by CXTPTaskPanel and CXTPTaskPanelGroup to set the behavior of the groups in the TaskPanel.

Example:

m_wndTaskPanel.SetBehaviour(xtpTaskPanelBehaviourToolbox);
See also
CXTPTaskPanel::SetBehaviour, CXTPTaskPanelGroup::GetBehaviour, xtpTaskPanelBehaviourExplorer, xtpTaskPanelBehaviourList, xtpTaskPanelBehaviourToolbox
Enumerator
xtpTaskPanelBehaviourExplorer | Task Panel will behave like Windows Explorer.
xtpTaskPanelBehaviourList | Task Panel will behave like Windows List Box.
xtpTaskPanelBehaviourToolbox | Task Panel will behave like VS. NET Toolbox.

◆ XTPTaskPanelHotTrackStyle

enum XTPTaskPanelHotTrackStyle

XTPTaskPanelHotTrackStyle is an enumeration used by CXTPTaskPanel to set the hot tracking style used for CXTPTaskPanelItems.

Hot tracking is how the items look as you move the mouse pointer over them.

Example:

m_wndTaskPanel.SetHotTrackStyle(xtpTaskPanelHighlightItem);
See also
CXTPTaskPanel::SetHotTrackStyle, CXTPTaskPanel::GetHotTrackStyle, CXTPTaskPanelItem::IsItemHot, xtpTaskPanelHighlightDefault, xtpTaskPanelHighlightText, xtpTaskPanelHighlightImage, xtpTaskPanelHighlightItem, xtpTaskPanelHighlightNone
Enumerator
xtpTaskPanelHighlightDefault | Uses the default hot tracking style.
xtpTaskPanelHighlightText | Only text is highlighted on mouse over.
xtpTaskPanelHighlightImage | Only images are highlighted on mouse over.
xtpTaskPanelHighlightItem | The entire item is highlighted on mouse over.
xtpTaskPanelHighlightNone | No hot tracking is used, nothing will happen on mouse over.

◆ XTPTaskPanelItemAllowDrag

enum XTPTaskPanelItemAllowDrag

XTPTaskPanelItemAllowDrag is an enumeration used by CXTPTaskPanel to specify the drag options.

Example:

m_wndTaskPanel.AllowDrag(xtpTaskItemAllowDragCopyWithinGroup);
See also
CXTPTaskPanel::AllowDrag, xtpTaskItemAllowDragNone, xtpTaskItemAllowDragDefault, xtpTaskItemAllowDragCopy, xtpTaskItemAllowDragMove, xtpTaskItemAllowDragAll
Enumerator
xtpTaskItemAllowDragNone | Disable drag.
xtpTaskItemAllowDragDefault | Default drag options (xtpTaskItemAllowDragAll).
xtpTaskItemAllowDragCopyWithinGroup | Allow copy within group only.
xtpTaskItemAllowDragCopyWithinControl | Allow copy within task panel only.
xtpTaskItemAllowDragCopyOutsideControl | Allow copy outside task panel only.
xtpTaskItemAllowDragCopy | Allow copy operation.
xtpTaskItemAllowDragMoveWithinGroup | Allow move within group only.
xtpTaskItemAllowDragMoveWithinControl | Allow move within task panel only.
xtpTaskItemAllowDragMoveOutsideControl | Allow move outside task panel only.
xtpTaskItemAllowDragMove | Allow move operation.
xtpTaskItemAllowDragWithinGroup | Allow drag within group only.
xtpTaskItemAllowDragWithinControl | Allow drag within task panel only.
xtpTaskItemAllowDrag | Allow all drag operations.

◆ XTPTaskPanelItemLayout

enum XTPTaskPanelItemLayout

XTPTaskPanelItemLayout is an enumeration used by CXTPTaskpanel and CXTPTaskPanelGroup to set how the items are laid out in the group(s).

Each group can have a different layout or they can all be the same.

Example:

pGroup->SetItemLayout(xtpTaskItemLayoutImagesWithText);
See also
CXTPTaskPanel::SetItemLayout, CXTPTaskPanel::GetItemLayout, CXTPTaskPanelGroup::SetItemLayout, CXTPTaskPanelGroup::GetItemLayout, xtpTaskItemLayoutDefault, xtpTaskItemLayoutImages, xtpTaskItemLayoutImagesWithText, xtpTaskItemLayoutImagesWithTextBelow
Enumerator
xtpTaskItemLayoutDefault | Default Layout.
xtpTaskItemLayoutImages | Only images are shown.
xtpTaskItemLayoutImagesWithText | Both images and text are shown.
xtpTaskItemLayoutImagesWithTextBelow | Both images and text are shown, text is shown below images.

◆ XTPTaskPanelItemType

enum XTPTaskPanelItemType

XTPTaskPanelItemType is an enumeration used by CXTPTaskPanelItem to specify the type of the item.

Example:

CXTPTaskPanelGroup* pGroupSystem = m_wndTaskPanel.AddGroup(ID_TASKGROUP_SYSTEM);
pGroupSystem->AddLinkItem(ID_TASKITEM_HIDECONTENTS, 0);
_ASSERTE(pGroupSystem->GetType() == xtpTaskItemTypeLink);
See also
CXTPTaskPanelItem::SetType, CXTPTaskPanelItem::GetType, xtpTaskItemTypeGroup, xtpTaskItemTypeLink, xtpTaskItemTypeText, xtpTaskItemTypeControl
Enumerator
xtpTaskItemTypeGroup | Item is a group.
xtpTaskItemTypeLink | Item is a link.
xtpTaskItemTypeText | Item is a text.
xtpTaskItemTypeControl | Item is a control.

◆ XTPTaskPanelPaintTheme

enum XTPTaskPanelPaintTheme

XTPTaskPanelPaintTheme is an enumeration used by CXTPTaskPanel to set the theme of the control.

Example:

m_wndTaskPanel.SetTheme(xtpTaskPanelThemeOffice2000Plain);
See also
CXTPTaskPanel::SetTheme, CXTPTaskPanel::GetCurrentTheme, xtpTaskPanelThemeOffice2000, xtpTaskPanelThemeOffice2003, xtpTaskPanelThemeNativeWinXP, xtpTaskPanelThemeOffice2000Plain, xtpTaskPanelThemeOfficeXPPlain, xtpTaskPanelThemeOffice2003Plain, xtpTaskPanelThemeNativeWinXPPlain, xtpTaskPanelThemeVisualStudio2003, xtpTaskPanelThemeVisualStudio2005, xtpTaskPanelThemeListView, xtpTaskPanelThemeListViewOfficeXP, xtpTaskPanelThemeListViewOffice2003, xtpTaskPanelThemeShortcutBarOffice2003, xtpTaskPanelThemeCustom
Enumerator
xtpTaskPanelThemeOffice2000 | Office 2000 theme.
xtpTaskPanelThemeOffice2003 | Office 2003 theme.
xtpTaskPanelThemeNativeWinXP | Win XP theme.
xtpTaskPanelThemeOffice2000Plain | Office 2000 classic theme.
xtpTaskPanelThemeOfficeXPPlain | Office XP classic theme.
xtpTaskPanelThemeOffice2003Plain | Office 2003 classic theme.
xtpTaskPanelThemeNativeWinXPPlain | Win XP classic theme.
xtpTaskPanelThemeVisualStudio2003 | VS 2003 style Toolbox theme.
xtpTaskPanelThemeVisualStudio2005 | VS 2005 style Toolbox theme.
xtpTaskPanelThemeListView | Standard List View theme.
xtpTaskPanelThemeListViewOfficeXP | Office XP List View theme.
xtpTaskPanelThemeListViewOffice2003 | Office 2003 List View theme.
xtpTaskPanelThemeShortcutBarOffice2003 | Shortcut Bar Office 2003 theme.
xtpTaskPanelThemeResource | Shortcut Bar Office 2007/2010 theme.
xtpTaskPanelThemeVisualStudio2010 | VS 2010 style Toolbox theme.
xtpTaskPanelThemeVisualStudio2012Light | VS 2012 Light style Toolbox theme.
xtpTaskPanelThemeVisualStudio2012Dark | VS 2012 Dark style Toolbox theme.
xtpTaskPanelThemeOffice2013 | Office 2013 style Toolbox theme.
xtpTaskPanelThemeOffice2016 | Office 2016 style Toolbox theme.
xtpTaskPanelThemeVisualStudio2015 | VS 2015 style Toolbox theme.
xtpTaskPanelThemeVisualStudio2017 | VS 2017 style Toolbox theme.
xtpTaskPanelThemeVisualStudio2019 | VS 2019 style Toolbox theme.
xtpTaskPanelThemeVisualStudio2022 | VS 2022 style Toolbox theme.
xtpTaskPanelThemeCustom | User defined Custom theme is used.
xtpTaskPanelThemeNativeWindows10 | Win 10 theme.
xtpTaskPanelThemeNativeWindows11 | Win 11 theme.

Variable Documentation

◆ XTP_ACTION_CANCEL

const int XTP_ACTION_CANCEL = -1
See also
XTPWM_TASKPANEL_NOTIFY

◆ XTP_TPN_CLICK

const UINT XTP_TPN_CLICK = 1
See also
XTPWM_TASKPANEL_NOTIFY

◆ XTP_TPN_DBLCLICK

const UINT XTP_TPN_DBLCLICK = 8
See also
XTPWM_TASKPANEL_NOTIFY

◆ XTP_TPN_ENDLABELEDIT

const UINT XTP_TPN_ENDLABELEDIT = 4
See also
XTPWM_TASKPANEL_NOTIFY

◆ XTP_TPN_FOCUSEDITEMCHANGED

const UINT XTP_TPN_FOCUSEDITEMCHANGED = 9
See also
XTPWM_TASKPANEL_NOTIFY

◆ XTP_TPN_GROUPEXPANDED

const UINT XTP_TPN_GROUPEXPANDED = 7
See also
XTPWM_TASKPANEL_NOTIFY

◆ XTP_TPN_GROUPEXPANDING

const UINT XTP_TPN_GROUPEXPANDING = 6
See also
XTPWM_TASKPANEL_NOTIFY

◆ XTP_TPN_GROUPMOVE

const UINT XTP_TPN_GROUPMOVE = 12
See also
XTPWM_TASKPANEL_NOTIFY

◆ XTP_TPN_HOTITEMCHANGED

const UINT XTP_TPN_HOTITEMCHANGED = 11
See also
XTPWM_TASKPANEL_NOTIFY

◆ XTP_TPN_ITEMDROP

const UINT XTP_TPN_ITEMDROP = 5
See also
XTPWM_TASKPANEL_NOTIFY

◆ XTP_TPN_ITEMREMOVED

const UINT XTP_TPN_ITEMREMOVED = 10
See also
XTPWM_TASKPANEL_NOTIFY

◆ XTP_TPN_RCLICK

const UINT XTP_TPN_RCLICK = 2
See also
XTPWM_TASKPANEL_NOTIFY

◆ XTP_TPN_STARTDRAG

const UINT XTP_TPN_STARTDRAG = 3
See also
XTPWM_TASKPANEL_NOTIFY

◆ XTPWM_TASKPANEL_NOTIFY

const UINT XTPWM_TASKPANEL_NOTIFY = (WM_USER + 9195 + 1)

The XTPWM_TASKPANEL_NOTIFY message is sent to the CXTPTaskPanel owner window whenever an action occurs within the CXTPTaskPanel.

Parameters
nAction | wParam value that specifies a Task Panel value that indicates the user's request.
pItem | lParam value that points to an CXTPTaskPanelItem object that contains information for the specified item. This pointer should never be NULL.
XTPWM_SHORTCUTBAR_NOTIFY
nAction = (int) wParam;             // TaskPanel action
pItem = (CXTPTaskPanelItem*) lParam;  // pointer to an CXTPTaskPanelItem object

nAction parameter can be one of the following values: XTP_TPN_CLICK: Indicates that the user clicked an item. XTP_TPN_RCLICK: Indicates that the user pressed the right mouse button on an item. XTP_TPN_STARTDRAG: Indicates that the user started dragging an item. XTP_TPN_ENDLABELEDIT: Indicates that the user applied an item rename. XTP_TPN_ITEMDROP: Indicates that the user dropped an item to the Task Panel XTP_TPN_GROUPEXPANDING: Indicates that a group is about to be expanded. lParam contains an XTP_TPNGROUPEXPANDING pointer. You can return XTP_ACTION_CANCEL to ignore expanding. XTP_TPN_GROUPEXPANDED: Indicates that the user expanded a group. XTP_TPN_DBLCLICK: Indicates that the user double-clicked an item. XTP_TPN_FOCUSEDITEMCHANGED: Indicates that the focused item of the control has changed.

Returns
TRUE if the application should process this message, otherwise FALSE.

Example:

BEGIN_MESSAGE_MAP(CMainFrame, CFrameWnd)
    //{{AFX_MSG_MAP(CMainFrame)
    ON_MESSAGE(XTPWM_TASKPANEL_NOTIFY, OnTaskPanelNotify)
    //}}AFX_MSG_MAP
END_MESSAGE_MAP()

LRESULT CMainFrame::OnTaskPanelNotify(WPARAM wParam, LPARAM lParam)
{
   switch (wParam)
   {
      case XTP_TPN_CLICK:
      {
         CXTPTaskPanelGroupItem* pItem = (CXTPTaskPanelGroupItem*)lParam;
         TRACE(_T("Click Event: pItem.Caption = %s, pItem.ID = %i\n"),
         pItem->GetCaption(), pItem->GetID());

         if (IsToggleButtons())
         {
            pItem->SetItemSelected(!pItem->IsItemSelected());
         }
      }
      break;

      case XTP_TPN_RCLICK:

      OnTaskPanelRButtonDown((CXTPTaskPanelItem*)lParam);
      return TRUE;

   }
   return 0;
}
See also
CXTPTaskPanel::NotifyOwner


Toolkit Pro: XTPTaskPanelGroup.h File Reference

  • Source
  • TaskPanel
Classes
XTPTaskPanelGroup.h File Reference

Go to the source code of this file.

Classes

class CXTPTaskPanelGroup
CXTPTaskPanelGroup is used in a Task Panel control to represent a group. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTaskPanelGroupItem.h File Reference

  • Source
  • TaskPanel
Classes
XTPTaskPanelGroupItem.h File Reference

Go to the source code of this file.

Classes

class CXTPTaskPanelGroupItem
CXTPTaskPanelGroupItem is used in a TaskPanel control to represent a single item of a group. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTaskPanelIIDs.h Source File

  • Source
  • TaskPanel
XTPTaskPanelIIDs.h
1// DO NOT MODIFY MANUALLY
2// Generated on Thu 12/11/2025 at 12:46:18.80 using cj-update-iids.cmd
3
24#ifndef __XTPTaskPanelIIDs_H__
25# define __XTPTaskPanelIIDs_H__
26
27// clang-format off
28
29#define XTP_DEFINE_GUID(name,l,w1,w2,b1,b2,b3,b4,b5,b6,b7,b8) \
30 EXTERN_C __declspec(selectany) const IID XTP##name = {l,w1,w2,{b1,b2,b3,b4,b5,b6,b7,b8}}; \
31 const unsigned long XTP##name##__Data1 = (l); \
32 const unsigned short XTP##name##__Data2 = (w1); \
33 const unsigned short XTP##name##__Data3 = (w2); \
34 const unsigned char XTP##name##__Data4_0 = (b1); \
35 const unsigned char XTP##name##__Data4_1 = (b2); \
36 const unsigned char XTP##name##__Data4_2 = (b3); \
37 const unsigned char XTP##name##__Data4_3 = (b4); \
38 const unsigned char XTP##name##__Data4_4 = (b5); \
39 const unsigned char XTP##name##__Data4_5 = (b6); \
40 const unsigned char XTP##name##__Data4_6 = (b7); \
41 const unsigned char XTP##name##__Data4_7 = (b8);
42
43XTP_DEFINE_GUID(LIBID_XtremeTaskPanel,0xB8E5842E,0x102B,0x4289,0x9D,0x57,0x3B,0x3F,0x5B,0x5E,0x15,0xD3);
44XTP_DEFINE_GUID(DIID_ITaskPanelGroup,0xC0DE2430,0x42C4,0x4cc1,0x9B,0x7C,0x04,0x34,0x5B,0x9B,0xA5,0x91);
45XTP_DEFINE_GUID(DIID_ITaskPanelGroupItems,0xC0DE2430,0x9128,0x4258,0x84,0xDD,0xAF,0xCB,0x00,0xC2,0xC0,0xD4);
46XTP_DEFINE_GUID(DIID_ITaskPanelItems,0xC0DE2430,0x3C54,0x4AF1,0x96,0x09,0x55,0x3D,0xC1,0xD2,0xB5,0x6F);
47XTP_DEFINE_GUID(DIID_ITaskPanelGroups,0xC0DE2430,0x84F6,0x418c,0xA9,0x52,0x33,0xB0,0x9E,0xA4,0xC9,0x9C);
48XTP_DEFINE_GUID(DIID_ITaskPanelItem,0xC0DE2430,0x302B,0x4777,0xB1,0x01,0xB6,0x62,0x49,0xE1,0x67,0x13);
49XTP_DEFINE_GUID(CLSID_TaskPanelItem,0xC0DE2430,0x796F,0x406c,0xA5,0x3F,0xEF,0x86,0xBE,0x97,0x54,0xEC);
50XTP_DEFINE_GUID(DIID_ITaskPanelGroupItem,0xC0DE2430,0x60D3,0x4529,0x99,0x73,0x3D,0xEF,0xE0,0xF4,0xEC,0xC6);
51XTP_DEFINE_GUID(CLSID_TaskPanelGroupItem,0xC0DE2430,0x8F21,0x4B16,0xA9,0xCF,0x50,0x49,0xAF,0x06,0x36,0x91);
52XTP_DEFINE_GUID(CLSID_TaskPanelGroupItems,0xC0DE2430,0x3E99,0x4501,0x87,0x25,0xFF,0xE6,0x2D,0x9E,0xE0,0xB1);
53XTP_DEFINE_GUID(CLSID_TaskPanelGroup,0xC0DE2430,0x56B4,0x46E0,0x84,0x11,0x88,0x62,0xB3,0x08,0x17,0xB4);
54XTP_DEFINE_GUID(CLSID_TaskPanelGroups,0xC0DE2430,0xE618,0x4563,0xBC,0x00,0x69,0xC7,0x02,0x10,0x47,0x2A);
55XTP_DEFINE_GUID(CLSID_TaskPanelItems,0xC0DE2430,0x5919,0x4238,0x97,0x0E,0x75,0x76,0x56,0xB9,0x4E,0x90);
56XTP_DEFINE_GUID(DIID_ITaskPanelColorSet,0xC0DE2430,0x7D67,0x42FF,0xA9,0xAE,0x10,0x80,0x42,0xBE,0x36,0x05);
57XTP_DEFINE_GUID(CLSID_TaskPanelColorSet,0xC0DE2430,0xBABE,0x48CE,0xBC,0x3F,0x5E,0x09,0xE2,0x49,0x46,0xA5);
58XTP_DEFINE_GUID(DIID__DTaskPanel,0xC0DE2430,0x4A99,0x4A75,0xA1,0x1F,0xD3,0xAE,0x80,0xEC,0xD4,0x53);
59XTP_DEFINE_GUID(DIID__DTaskPanelEvents,0xC0DE2430,0xDC51,0x46E1,0x84,0x84,0x90,0x14,0x3C,0x19,0x94,0x41);
60XTP_DEFINE_GUID(CLSID_TaskPanel,0xC0DE2430,0xC84E,0x4C2E,0xBF,0x15,0x8E,0x5A,0xB5,0x3C,0xA1,0xA8);
61XTP_DEFINE_GUID(DIID_ITaskPanelGlobalSettings,0xC0DE2430,0x792F,0x4218,0x86,0x77,0x3B,0x4D,0x74,0x43,0xD0,0x12);
62XTP_DEFINE_GUID(CLSID_TaskPanelGlobalSettings,0xC0DE2430,0x2218,0x47C2,0xBC,0x02,0x5D,0x3F,0x31,0x14,0x67,0xD7);
63
64#undef XTP_DEFINE_GUID
65
66// clang-format on
67
68#endif // __XTPTaskPanelIIDs_H__


Toolkit Pro: XTPTaskPanelItem.h File Reference

  • Source
  • TaskPanel
Classes
XTPTaskPanelItem.h File Reference

Go to the source code of this file.

Classes

class CXTPTaskPanelItem
CXTPTaskPanelItem is used in a Task Panel control to represent a single item. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTaskPanelItems.h File Reference

  • Source
  • TaskPanel
Classes
XTPTaskPanelItems.h File Reference

Go to the source code of this file.

Classes

class | CXTPTaskPanelItems
CXTPTaskPanelItems is used in a Task Panel control to represent a collection of items. More...
class | CXTPTaskPanelGroupItems
CXTPTaskPanelGroupItems represents a collection of items in a group. More...
class | CXTPTaskPanelGroups
CXTPTaskPanelGroups represents a collection of groups in a Task Panel control. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: XTPTaskPanelPaintManager.h File Reference

  • Source
  • TaskPanel
Classes | Enumerations
XTPTaskPanelPaintManager.h File Reference

Go to the source code of this file.

Classes

struct | XTP_TASKPANEL_GROUPCOLORS
Structure used to store task panel group colorization information for various parts of the group. More...
class | CXTPTaskPanelPaintManager
CXTPTaskPanelPaintManager is a standalone class used by CXTPTaskPanel as a paint manager. More...

Enumerations

enum XTPTaskPanelGripper { xtpTaskPanelGripperNone , xtpTaskPanelGripperBitmap , xtpTaskPanelGripperPlain , xtpTaskPanelGripperTriangle }
Enumeration used to indicate which type of gripper is drawn on task panel group headers. More...

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com

Enumeration Type Documentation

◆ XTPTaskPanelGripper

enum XTPTaskPanelGripper

Enumeration used to indicate which type of gripper is drawn on task panel group headers.

This can be used when creating custom themes or you can override the predefined themes to change the grippers if drawn in the group headers.

Depending on the theme and XTPTaskPanelGripper selection, the gripper can appear "hot" on mouse over and display a different gripper than when the group is expanded and closed.

Example:

m_wndTaskPanel.GetPaintManager()->m_eGripper = xtpTaskPanelGripperTriangle;
See also
CXTPTaskPanelPaintManager::m_eGripper, xtpTaskPanelGripperNone, xtpTaskPanelGripperBitmap, xtpTaskPanelGripperPlain, xtpTaskPanelGripperTriangle
Enumerator
xtpTaskPanelGripperNone | Do not draw a gripper in task panel group headers.
xtpTaskPanelGripperBitmap | Display a bitmap in task panel group headers (i.e. arrows in WinXP theme).
xtpTaskPanelGripperPlain | Display the default "classic" gripper in task panel group headers.
xtpTaskPanelGripperTriangle | Display a triangle gripper in task panel group headers.


Toolkit Pro: XTPResource.h File Reference

  • Source
XTPResource.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(c) 1998-2025 Codejock Software, All Rights Reserved.

This source file is the property of Codejock Software and must not be redistributed by any means without the explicit written permission of Codejock Software.

The use of this source code is governed by the terms and conditions specified in the Toolkit Pro license agreement. Codejock Software grants you, as a single software developer, the limited right to use this software on one computer only.

Contact Information: suppo.nosp@m.rt@c.nosp@m.odejo.nosp@m.ck.c.nosp@m.om http://www.codejock.com


Toolkit Pro: File Members

Here is a list of all documented file members with links to the documentation:

- b -

  • BEGIN_VIEW_PART : XTPCalendarPaintManager.h
  • BES_XTP_BROWSE : XTPBrowseEdit.h
  • BES_XTP_CHOOSEDIR : XTPBrowseEdit.h
  • BES_XTP_CHOOSEFILE : XTPBrowseEdit.h
  • BES_XTP_POPUPMENU : XTPBrowseEdit.h


Toolkit Pro: File Members

Here is a list of all documented file members with links to the documentation:

- c -

  • CBN_XTP_EXECUTE : XTPCommandBarsDefines.h
  • CPWS_EX_CLOSEBUTTON : XTPCaption.h
  • CPWS_EX_GROOVE_EDGE : XTPCaption.h
  • CPWS_EX_RAISED_EDGE : XTPCaption.h
  • cszCalendarMarkupPrm_Body : XTPCalendarDefines.h
  • cszCalendarMarkupPrm_EndTime : XTPCalendarDefines.h
  • cszCalendarMarkupPrm_Location : XTPCalendarDefines.h
  • cszCalendarMarkupPrm_Subject : XTPCalendarDefines.h
  • cszEventCustProp_CategoryIDs : XTPCalendarDefines.h
  • cszEventCustProp_IconsIDs : XTPCalendarDefines.h
  • cszEventCustProp_MarkupTemplate : XTPCalendarDefines.h
  • cszEventCustProp_NextReminderTime_Snoozed : XTPCalendarDefines.h
  • cszProcess_RecurrencePatternID : XTPCalendarData.h
  • cszProcess_RecurrenceState : XTPCalendarData.h
  • CXTPCalendarDatesArray : XTPCalendarDefines.h
  • CXTPChart2dPyramidDiagram : XTPChartPyramidDiagram.h
  • CXTPChart2dPyramidDiagramView : XTPChartPyramidDiagramView.h
  • CXTPChart2dPyramidSeriesLabel : XTPChartPyramidSeriesLabel.h
  • CXTPChart2dPyramidSeriesLabelView : XTPChartPyramidSeriesLabel.h
  • CXTPChart2dPyramidSeriesPointView : XTPChartPyramidSeriesPointView.h
  • CXTPChart2dPyramidSeriesStyle : XTPChartPyramidSeriesStyle.h
  • CXTPChart2dPyramidSeriesView : XTPChartPyramidSeriesView.h
  • CXTPChartPaletteEntries : XTPChartPalette.h
  • CXTPCommandBarsCategoryArray : XTPCustomizePageCommands.h
  • CXTPDefaultTheme : XTPCommandBarsOffice2000Theme.h
  • CXTPDockingPaneBaseList : XTPDockingPaneDefines.h
  • CXTPDockingPaneInfoList : XTPDockingPaneDefines.h
  • CXTPDockingPaneList : XTPDockingPaneDefines.h
  • CXTPFontList : XTPFontComboBox.h
  • CXTPGridHyperlinks_base : XTPGridHyperlink.h
  • CXTPGridRecordItemControls_base : XTPGridRecordItemControls.h
  • CXTPOffice2003Theme : XTPCommandBarsOffice2003Theme.h
  • CXTPPaneIndexToPaneMap : XTPDockingPaneDefines.h
  • CXTPPaneToPaneMap : XTPDockingPaneDefines.h
  • CXTPPickBtnArray : XTPColorSelectorCtrl.h
  • CXTPPoint2d : XTPPoint2.h
  • CXTPPoint2f : XTPPoint2.h
  • CXTPPoint2i : XTPPoint2.h
  • CXTPPoint3d : XTPPoint3.h
  • CXTPPoint3f : XTPPoint3.h
  • CXTPPoint3i : XTPPoint3.h
  • CXTPRectD : XTPRect.h
  • CXTPRectF : XTPRect.h
  • CXTPRectI : XTPRect.h
  • CXTPScrollableEdit : XTPEdit.h
  • CXTPScrollableListBox : XTPListBox.h
  • CXTPScrollableListCtrl : XTPListCtrlView.h
  • CXTPScrollableTreeCtrl : XTPTreeCtrlView.h
  • CXTPSizeD : XTPSize.h
  • CXTPSizeF : XTPSize.h
  • CXTPSizeI : XTPSize.h
  • CXTPSyntaxEditACDataArray : XTPSyntaxEditAutoCompleteWnd.h
  • CXTPSyntaxEditACGrid : XTPSyntaxEditAutoCompleteWnd.h
  • CXTPSyntaxEditTextSchema : XTPSyntaxEditBufferManager.h
  • CXTPTagCloudStyleArray : XTPTagCloudCtrl.h


Toolkit Pro: File Members

Here is a list of all documented file members with links to the documentation:

- d -

  • DDX_CBSyntaxColor() : XTPSyntaxEditColorComboBox.h
  • DDX_XTPColorPicker() : XTPColorPicker.h
  • DDX_XTPOleDateTime() : XTPMaskEdit.h
  • DECLARE_SHELLTREE_BASE : XTPShellTreeBase.h
  • DECLARE_XTP_COMMANDBAR : XTPCommandBarsDefines.h
  • DECLARE_XTP_CONTROL : XTPCommandBarsDefines.h
  • DECLARE_XTP_SINK : XTPNotifyConnection.h


Toolkit Pro: File Members

Here is a list of all documented file members with links to the documentation:

- e -

  • END_VIEW_PART : XTPCalendarPaintManager.h
  • EStates : XTPCalendarCaptionBarThemePart.h


Toolkit Pro: File Members

Here is a list of all documented file members with links to the documentation:

- f -

  • FTS_XTP_BOTTOM : XTPExcelTabCtrl.h
  • FTS_XTP_DEFAULT : XTPExcelTabCtrl.h
  • FTS_XTP_HASARROWS : XTPExcelTabCtrl.h
  • FTS_XTP_HASHOMEEND : XTPExcelTabCtrl.h
  • FTS_XTP_HSCROLL : XTPExcelTabCtrl.h
  • FTS_XTP_MASK : XTPExcelTabCtrl.h
  • FTS_XTP_SQUARETABS : XTPExcelTabCtrl.h
  • FTS_XTP_TOOLTIPS : XTPExcelTabCtrl.h


Toolkit Pro: File Members

Here is a list of all documented file members with links to the documentation:

- g -

  • GetMSO2003Color() : XTPColorManager.h
  • GetThemePartForEvent() : XTPCalendarThemeOffice2007.h
  • GetXtremeColor() : XTPColorManager.h


Toolkit Pro: File Members

Here is a list of all documented file members with links to the documentation:

- h -

  • HDR_XTP_HOTTRACKING : XTPHeaderCtrlTheme.h
  • HDR_XTP_SORTARROW : XTPHeaderCtrlTheme.h
  • HDR_XTP_WINDEF : XTPHeaderCtrlTheme.h


Toolkit Pro: File Members

Here is a list of all documented file members with links to the documentation:

- i -

  • IMPLEMENT_XTP_COMMANDBAR : XTPCommandBarsDefines.h
  • IMPLEMENT_XTP_CONTROL : XTPCommandBarsDefines.h
  • IsAnimateType() : XTPCommandBarsDefines.h
  • IsCaptionStyle() : XTPCommandBarsDefines.h
  • IsDockingPosition() : XTPCommandBarsDefines.h
  • IsPopupControlType() : XTPCommandBarsDefines.h
  • IsVerticalPosition() : XTPCommandBarsDefines.h


Toolkit Pro: File Members

Here is a list of all documented file members with links to the documentation:

- l -

  • LBS_XTP_BROWSE : XTPEditListBox.h
  • LBS_XTP_BROWSE_ONLY : XTPEditListBox.h
  • LBS_XTP_CHOOSEDIR : XTPEditListBox.h
  • LBS_XTP_CHOOSEFILE : XTPEditListBox.h
  • LBS_XTP_DEFAULT : XTPEditListBox.h
  • LBS_XTP_HIDE_UP_DOWN : XTPEditListBox.h
  • LBS_XTP_NOTOOLBAR : XTPEditListBox.h
  • LBS_XTP_ONLY_UP_DOWN : XTPEditListBox.h


Toolkit Pro: File Members

Here is a list of all documented file members with links to the documentation:

- m -

  • m_arWeekDayNamesLong : XTPCalendarThemeOffice2007.h
  • m_arWeekDayNamesShort : XTPCalendarThemeOffice2007.h


Toolkit Pro: File Members

Here is a list of all documented file members with links to the documentation:

- o -

  • ON_XTP_AFTERCREATECONTROL : XTPCommandBarsDefines.h
  • ON_XTP_CREATECOMMANDBAR : XTPCommandBarsDefines.h
  • ON_XTP_CREATECONTROL : XTPCommandBarsDefines.h
  • ON_XTP_EXECUTE : XTPCommandBarsDefines.h
  • ON_XTP_EXECUTE_RANGE : XTPCommandBarsDefines.h
  • ON_XTP_INITCOMMANDSPOPUP : XTPCommandBarsDefines.h
  • ON_XTP_UNINITCOMMANDSPOPUP : XTPCommandBarsDefines.h
  • ON_XTP_WM_GAUGEUPDATE : XTPGaugeCtrl.h


Toolkit Pro: File Members

Here is a list of all documented file members with links to the documentation:

- p -

  • PFNITEMMETRICS : XTPDatePickerControl.h
  • pPoint : XTPCalendarThemeOffice2007.h
  • PX_Blob() : XTPPropExchange.h
  • PX_Bool() : XTPPropExchange.h
  • PX_Bstr() : XTPPropExchange.h
  • PX_Byte() : XTPPropExchange.h
  • PX_Color() : XTPCalendarViewPart.h
  • PX_DateTime() : XTPPropExchange.h
  • PX_Double() : XTPPropExchange.h
  • PX_DPI_Point() : XTPPropExchange.h
  • PX_DPI_Rect() : XTPPropExchange.h
  • PX_DPI_Size() : XTPPropExchange.h
  • PX_DPI_X_Int() : XTPPropExchange.h
  • PX_DPI_X_Long() : XTPPropExchange.h
  • PX_DPI_Y_Int() : XTPPropExchange.h
  • PX_DPI_Y_Long() : XTPPropExchange.h
  • PX_DWord() : XTPPropExchange.h
  • PX_Enum() : XTPPropExchange.h
  • PX_Float() : XTPPropExchange.h
  • PX_Font() : XTPCalendarViewPart.h
  • PX_GrColor() : XTPCalendarViewPart.h
  • PX_Int() : XTPPropExchange.h
  • PX_Long() : XTPPropExchange.h
  • PX_Object() : XTPPropExchange.h
  • PX_Point() : XTPPropExchange.h
  • PX_Rect() : XTPPropExchange.h
  • PX_RuntimeClass() : XTPPropExchange.h
  • PX_Serialize() : XTPPropExchange.h
  • PX_Short() : XTPPropExchange.h
  • PX_Size() : XTPPropExchange.h
  • PX_String() : XTPPropExchange.h
  • PX_UI8() : XTPPropExchange.h
  • PX_ULong() : XTPPropExchange.h
  • PX_UShort() : XTPPropExchange.h
  • PX_Variant() : XTPPropExchange.h


Toolkit Pro: File Members

Here is a list of all documented file members with links to the documentation:

- r -

  • RefreshXtremeColors() : XTPColorManager.h


Toolkit Pro: File Members

Here is a list of all documented file members with links to the documentation:

- s -

  • SAFE_CALLPTR : XTPMacros.h
  • SAFE_DELETE : XTPMacros.h
  • SAFE_DELETE_AR : XTPMacros.h
  • SAFE_DELETE_HICON : XTPMacros.h
  • SAFE_DELETE_OBJ : XTPMacros.h
  • SAFE_RELEASE : XTPMacros.h
  • SelectionRectHitTest : XTPFlowGraphSelectionRect.h
  • SelectionRectHitTestBottomCenter : XTPFlowGraphSelectionRect.h
  • SelectionRectHitTestBottomLeft : XTPFlowGraphSelectionRect.h
  • SelectionRectHitTestBottomRight : XTPFlowGraphSelectionRect.h
  • SelectionRectHitTestMiddleLeft : XTPFlowGraphSelectionRect.h
  • SelectionRectHitTestMiddleRight : XTPFlowGraphSelectionRect.h
  • SelectionRectHitTestNone : XTPFlowGraphSelectionRect.h
  • SelectionRectHitTestTopCenter : XTPFlowGraphSelectionRect.h
  • SelectionRectHitTestTopLeft : XTPFlowGraphSelectionRect.h
  • SelectionRectHitTestTopRight : XTPFlowGraphSelectionRect.h


Toolkit Pro: File Members

Here is a list of all documented file members with links to the documentation:

- t -

  • TVIS_FOCUSED : XTPTreeBase.h
  • TWS_XTP_ALPHASHADOW : XTPTipWindow.h
  • TWS_XTP_DROPSHADOW : XTPTipWindow.h
  • TWS_XTP_THICKBORDER : XTPTipWindow.h


Toolkit Pro: File Members

Here is a list of all documented file members with links to the documentation:

- w -

  • WM_XTP_AFTERCREATECONTROL : XTPCommandBarsDefines.h
  • WM_XTP_BEFORECREATECONTROL : XTPCommandBarsDefines.h
  • WM_XTP_CALENDAR_BASE : XTPCalendarDefines.h
  • WM_XTP_COMMANDBARKEYDOWN : XTPCommandBarsDefines.h
  • WM_XTP_COMMANDBARS_BASE : XTPCommandBarsDefines.h
  • WM_XTP_COMMON_BASE : XTPNotifyConnection.h
  • WM_XTP_CONTROLRBUTTONUP : XTPCommandBarsDefines.h
  • WM_XTP_CONTROLSELECTED : XTPCommandBarsDefines.h
  • WM_XTP_CREATECOMMANDBAR : XTPCommandBarsDefines.h
  • WM_XTP_DOCKINGPANE_BASE : XTPDockingPaneDefines.h
  • WM_XTP_DRAGCONTROLCHANGED : XTPCommandBarsDefines.h
  • WM_XTP_GETTABCOLOR : XTPTabManager.h
  • WM_XTP_GETTABICON : XTPCommandBarsDefines.h
  • WM_XTP_GETWINDOWTEXT : XTPTabClientWnd.h
  • WM_XTP_GETWINDOWTOOLTIP : XTPTabClientWnd.h
  • WM_XTP_INITCOMMANDSPOPUP : XTPCommandBarsDefines.h
  • WM_XTP_INITMENU : XTPCommandBarsDefines.h
  • WM_XTP_MESSAGEBARCLOSED : XTPCommandBarsDefines.h
  • WM_XTP_NEWTABITEM : XTPTabClientWnd.h
  • WM_XTP_PRETRANSLATEMOUSEMSG : XTPTabClientWnd.h
  • WM_XTP_PRETRANSLATEMOUSEMSG_EX : XTPTabClientWnd.h
  • WM_XTP_RIBBONMINIMIZE : XTPRibbonBar.h
  • WM_XTP_SETACTIVEWORKSPACE : XTPTabClientWnd.h
  • WM_XTP_SETBAKSTAGEBUTTONKEYTIP : XTPCommandBarsDefines.h
  • WM_XTP_SETBAKSTAGEBUTTONKEYTIPDRAWFLAG : XTPCommandBarsDefines.h
  • WM_XTP_TABTODOCKPANE : XTPTabClientWnd.h
  • WM_XTP_TOOLBARCONTEXTMENU : XTPCommandBarsDefines.h
  • WM_XTP_TOOLBARVISIBLECHANGED : XTPCommandBarsDefines.h
  • WM_XTP_UNINITCOMMANDSPOPUP : XTPCommandBarsDefines.h


Toolkit Pro: File Members

Here is a list of all documented file members with links to the documentation:

- x -

  • XPCOLOR_3DFACE : XTPColorManager.h
  • XPCOLOR_3DSHADOW : XTPColorManager.h
  • XPCOLOR_BASE : XTPColorManager.h
  • XPCOLOR_CHECKED_TEXT : XTPColorManager.h
  • XPCOLOR_DISABLED : XTPColorManager.h
  • XPCOLOR_EDITCTRLBORDER : XTPColorManager.h
  • XPCOLOR_FLOATBAR_BORDER : XTPColorManager.h
  • XPCOLOR_FRAME : XTPColorManager.h
  • XPCOLOR_GRAYTEXT : XTPColorManager.h
  • XPCOLOR_HIGHLIGHT : XTPColorManager.h
  • XPCOLOR_HIGHLIGHT_BORDER : XTPColorManager.h
  • XPCOLOR_HIGHLIGHT_CHECKED : XTPColorManager.h
  • XPCOLOR_HIGHLIGHT_CHECKED_BORDER : XTPColorManager.h
  • XPCOLOR_HIGHLIGHT_DISABLED_BORDER : XTPColorManager.h
  • XPCOLOR_HIGHLIGHT_PUSHED : XTPColorManager.h
  • XPCOLOR_HIGHLIGHT_PUSHED_BORDER : XTPColorManager.h
  • XPCOLOR_HIGHLIGHT_TEXT : XTPColorManager.h
  • XPCOLOR_ICONSHADDOW : XTPColorManager.h
  • XPCOLOR_LABEL : XTPColorManager.h
  • XPCOLOR_LAST : XTPColorManager.h
  • XPCOLOR_MENUBAR_BORDER : XTPColorManager.h
  • XPCOLOR_MENUBAR_EXPANDED : XTPColorManager.h
  • XPCOLOR_MENUBAR_FACE : XTPColorManager.h
  • XPCOLOR_MENUBAR_GRAYTEXT : XTPColorManager.h
  • XPCOLOR_MENUBAR_TEXT : XTPColorManager.h
  • XPCOLOR_PUSHED_TEXT : XTPColorManager.h
  • XPCOLOR_SEPARATOR : XTPColorManager.h
  • XPCOLOR_SHADOW_FACTOR : XTPColorManager.h
  • XPCOLOR_SPLITTER_FACE : XTPColorManager.h
  • XPCOLOR_STATICFRAME : XTPColorManager.h
  • XPCOLOR_TAB_INACTIVE_BACK : XTPColorManager.h
  • XPCOLOR_TAB_INACTIVE_TEXT : XTPColorManager.h
  • XPCOLOR_TOOLBAR_FACE : XTPColorManager.h
  • XPCOLOR_TOOLBAR_GRAYTEXT : XTPColorManager.h
  • XPCOLOR_TOOLBAR_GRIPPER : XTPColorManager.h
  • XPCOLOR_TOOLBAR_TEXT : XTPColorManager.h
  • XT_ASSERT_MSG : XTPMacros.h
  • XTP_ACTION_CANCEL : XTPTaskPanelDefines.h
  • XTP_ACTION_NOCLOSE : XTPDockingPaneDefines.h
  • XTP_ANCHOR_BOTTOMCENTER : XTPResizePoint.h
  • XTP_ANCHOR_BOTTOMLEFT : XTPResizePoint.h
  • XTP_ANCHOR_BOTTOMRIGHT : XTPResizePoint.h
  • XTP_ANCHOR_MIDDLECENTER : XTPResizePoint.h
  • XTP_ANCHOR_MIDDLELEFT : XTPResizePoint.h
  • XTP_ANCHOR_MIDDLERIGHT : XTPResizePoint.h
  • XTP_ANCHOR_TOPCENTER : XTPResizePoint.h
  • XTP_ANCHOR_TOPLEFT : XTPResizePoint.h
  • XTP_ANCHOR_TOPRIGHT : XTPResizePoint.h
  • XTP_ASSERT_CHECK : XTPMacros.h
  • XTP_ASSERT_CHECK_NOT_NULL : XTPMacros.h
  • XTP_ATTR_HORREPOS : XTPResizeRect.h
  • XTP_ATTR_HORRESIZE : XTPResizeRect.h
  • XTP_ATTR_REPOS : XTPResizeRect.h
  • XTP_ATTR_RESIZE : XTPResizeRect.h
  • XTP_ATTR_VERREPOS : XTPResizeRect.h
  • XTP_ATTR_VERRESIZE : XTPResizeRect.h
  • XTP_BROWSER_WEBVIEW_MIN_VC_VERSION : XTPWebView2.h
  • XTP_CALENDAR_DEFAULT_LABEL_ID : XTPCalendarDefines.h
  • XTP_CALENDAR_DEFAULT_REMINDER_MINUTES : XTPCalendarDefines.h
  • XTP_CALENDAR_DISABLED_COLOR_DARK : XTPCalendarDefines.h
  • XTP_CALENDAR_DISABLED_COLOR_LIGHT : XTPCalendarDefines.h
  • XTP_CALENDAR_DLGRESULT_REMOVE_RECURRENCE : XTPCalendarEventRecurrenceDlg.h
  • XTP_CALENDAR_DRAW_EVENTITEMTEXT_MAX : XTPCalendarDefines.h
  • XTP_CALENDAR_MONTHVIEW_SHOW_WEEKS_MAX : XTPCalendarMonthView.h
  • XTP_CALENDAR_MONTHVIEW_SHOW_WEEKS_MIN : XTPCalendarMonthView.h
  • XTP_CALENDAR_NONE_LABEL_ID : XTPCalendarDefines.h
  • XTP_CALENDAR_OFFICE2007_FONT_NAME : XTPCalendarDefines.h
  • XTP_CALENDAR_SHOW_BUTTON_TIMEOUT_MS : XTPCalendarDefines.h
  • XTP_CALENDAR_SHOW_TOOLTIP_TIMEOUT_MS : XTPCalendarDefines.h
  • XTP_CALENDAR_TIMEZONESKEY_9X : XTPCalendarDefines.h
  • XTP_CALENDAR_TIMEZONESKEY_NT : XTPCalendarDefines.h
  • XTP_CALENDAR_TZIRegValName_DATA : XTPCalendarDefines.h
  • XTP_CALENDAR_TZIRegValName_DaylightName : XTPCalendarDefines.h
  • XTP_CALENDAR_TZIRegValName_DaylightNameW : XTPCalendarDefines.h
  • XTP_CALENDAR_TZIRegValName_DisplayStr : XTPCalendarDefines.h
  • XTP_CALENDAR_TZIRegValName_Index : XTPCalendarDefines.h
  • XTP_CALENDAR_TZIRegValName_StandardName : XTPCalendarDefines.h
  • XTP_CALENDAR_TZIRegValName_StandardNameW : XTPCalendarDefines.h
  • XTP_CALENDAR_UNKNOWN_EVENT_ID : XTPCalendarDefines.h
  • XTP_CALENDAR_UNKNOWN_LABEL_ID : XTPCalendarDefines.h
  • XTP_CALENDAR_UNKNOWN_RECURRENCE_PATTERN_ID : XTPCalendarDefines.h
  • XTP_CALENDAR_UNKNOWN_SCHEDULE_ID : XTPCalendarDefines.h
  • XTP_CN_UPDATE_CUSTOMIZE_COMMAND_UI : XTPCommandBarsDefines.h
  • XTP_DATEPICKER_TIMER_INTERVAL : XTPDatePickerControl.h
  • XTP_DATEPICKER_TIMERID : XTPDatePickerControl.h
  • XTP_DECLARE_BATCH_ALLOC_OBJ_DATA : XTPCustomHeap.h
  • XTP_DECLARE_CMDTARGETPROVIDER_INTERFACE : XTPFramework.h
  • XTP_DECLARE_CMDTARGETPROVIDER_INTERFACE_PART : XTPFramework.h
  • XTP_DECLARE_HEAP_ALLOCATOR : XTPCustomHeap.h
  • XTP_DECLARE_IDISPATCH : XTPMacros.h
  • XTP_DEFINE_SMART_PTR_ARRAY_INTERNAL : XTPSmartPtrInternalT.h
  • XTP_DEFINE_SMART_PTR_INTERNAL : XTPSmartPtrInternalT.h, XTPCalendarOptions.h, XTPCalendarRecurrencePattern.h, XTPCalendarView.h, XTPSyntaxEditLexClassSubObjT.h
  • XTP_DPN_ACTION : XTPDockingPaneDefines.h
  • XTP_DPN_CLOSEPANE : XTPDockingPaneDefines.h
  • XTP_DPN_CONTEXTMENU : XTPDockingPaneDefines.h
  • XTP_DPN_RCLICK : XTPDockingPaneDefines.h
  • XTP_DPN_SHOWWINDOW : XTPDockingPaneDefines.h
  • XTP_DYNAMIC_DOWNCAST_REMOTE : XTPSystemHelpers.h
  • XTP_EDIT_AVELINELEN : XTPSyntaxEditDefines.h
  • XTP_EDIT_DISABLED_COLOR_DARK : XTPSyntaxEditDefines.h
  • XTP_EDIT_DISABLED_COLOR_LIGHT : XTPSyntaxEditDefines.h
  • XTP_EDIT_EDITACTION_DELETEROW : XTPSyntaxEditDefines.h
  • XTP_EDIT_EDITACTION_DELETETEXT : XTPSyntaxEditDefines.h
  • XTP_EDIT_EDITACTION_INSERTROW : XTPSyntaxEditDefines.h
  • XTP_EDIT_EDITACTION_INSERTTEXT : XTPSyntaxEditDefines.h
  • XTP_EDIT_EDITACTION_MODIFYROW : XTPSyntaxEditDefines.h
  • XTP_EDIT_FINDWORD_NEXT : XTPSyntaxEditDefines.h
  • XTP_EDIT_FINDWORD_PREV : XTPSyntaxEditDefines.h
  • XTP_EDIT_FONTOPTIONS_UNSPEC_OPTION : XTPSyntaxEditStruct.h
  • XTP_EDIT_NM_DRAWBOOKMARK : XTPSyntaxEditDefines.h
  • XTP_EDIT_NM_EDITCHANGED : XTPSyntaxEditDefines.h
  • XTP_EDIT_NM_EDITCHANGING : XTPSyntaxEditDefines.h
  • XTP_EDIT_NM_ENABLESCROLLBAR : XTPSyntaxEditDefines.h
  • XTP_EDIT_NM_FIRST : XTPSyntaxEditDefines.h
  • XTP_EDIT_NM_INSERTKEY : XTPSyntaxEditDefines.h
  • XTP_EDIT_NM_LAST : XTPSyntaxEditDefines.h
  • XTP_EDIT_NM_LBUTTONDBLCLICK : XTPSyntaxEditDefines.h
  • XTP_EDIT_NM_LBUTTONDOWN : XTPSyntaxEditDefines.h
  • XTP_EDIT_NM_LBUTTONUP : XTPSyntaxEditDefines.h
  • XTP_EDIT_NM_MARGINCLICKED : XTPSyntaxEditDefines.h
  • XTP_EDIT_NM_MOUSEMOVE : XTPSyntaxEditDefines.h
  • XTP_EDIT_NM_PARSEEVENT : XTPSyntaxEditDefines.h
  • XTP_EDIT_NM_RBUTTONDOWN : XTPSyntaxEditDefines.h
  • XTP_EDIT_NM_RBUTTONUP : XTPSyntaxEditDefines.h
  • XTP_EDIT_NM_ROWCOLCHANGED : XTPSyntaxEditDefines.h
  • XTP_EDIT_NM_SELINIT : XTPSyntaxEditDefines.h
  • XTP_EDIT_NM_SETDOCMODIFIED : XTPSyntaxEditDefines.h
  • XTP_EDIT_NM_STARTOLEDRAG : XTPSyntaxEditDefines.h
  • XTP_EDIT_NM_UPDATESCROLLPOS : XTPSyntaxEditDefines.h
  • XTP_EDIT_RGB_GETBLUE : XTPSyntaxEditDefines.h
  • XTP_EDIT_RGB_GETGREEN : XTPSyntaxEditDefines.h
  • XTP_EDIT_RGB_GETRED : XTPSyntaxEditDefines.h
  • XTP_EDIT_RGB_INT2CLR : XTPSyntaxEditDefines.h
  • XTP_EDIT_ROWNODE_COLLAPSED : XTPSyntaxEditStruct.h
  • XTP_EDIT_ROWNODE_ENDMARK : XTPSyntaxEditStruct.h
  • XTP_EDIT_ROWNODE_EXPANDED : XTPSyntaxEditStruct.h
  • XTP_EDIT_ROWNODE_NODEDOWN : XTPSyntaxEditStruct.h
  • XTP_EDIT_ROWNODE_NODEUP : XTPSyntaxEditStruct.h
  • XTP_EDIT_ROWNODE_NOTHING : XTPSyntaxEditStruct.h
  • XTP_EDIT_XLC : XTPSyntaxEditStruct.h
  • XTP_EVENTS_STORAGE_HASH_TABLE_SIZE : XTPCalendarMemoryDataProvider.h
  • XTP_FGN_ACTIVEPAGECHANGED : XTPFlowGraphMessages.h
  • XTP_FGN_CONNECTIONCHANGED : XTPFlowGraphMessages.h
  • XTP_FGN_CONNECTIONCHANGING : XTPFlowGraphMessages.h
  • XTP_FGN_ENDLABELEDIT : XTPFlowGraphMessages.h
  • XTP_FGN_NODELOCATIONCHANGED : XTPFlowGraphMessages.h
  • XTP_FGN_PAGESCROLLOFFSETCHANGED : XTPFlowGraphMessages.h
  • XTP_FGN_PAGEZOOMLEVELCHANGED : XTPFlowGraphMessages.h
  • XTP_FGN_SELECTIONCHANGED : XTPFlowGraphMessages.h
  • XTP_FN_BUDDYBUTTONCLICK : XTPControlEdit.h
  • XTP_FN_GETFORMAT : XTPControlComboBoxExt.h
  • XTP_FN_SETFORMAT : XTPControlComboBoxExt.h
  • XTP_FN_SPINDOWN : XTPControlEdit.h
  • XTP_FN_SPINUP : XTPControlEdit.h
  • XTP_GN_PREVIEWAPPLY : XTPControlGallery.h
  • XTP_GN_PREVIEWCANCEL : XTPControlGallery.h
  • XTP_GN_PREVIEWCHANGE : XTPControlGallery.h
  • XTP_GN_PREVIEWSTART : XTPControlGallery.h
  • XTP_GN_SELCHANGE : XTPControlGallery.h
  • XTP_GN_STARTDRAG : XTPControlGallery.h
  • XTP_GRID_COLOR_DEFAULT : XTPGridDefines.h
  • XTP_GRID_DEPRECATED : XTPGridDefines.h
  • XTP_GRID_NOICON : XTPGridDefines.h
  • XTP_GUARD_EXCLUSIVE : XTPSynchro.h
  • XTP_GUARD_EXCLUSIVE_ : XTPSynchro.h
  • XTP_GUARD_EXCLUSIVE_COND : XTPSynchro.h
  • XTP_GUARD_EXCLUSIVE_COND_ : XTPSynchro.h
  • XTP_GUARD_EXCLUSIVE_COND_CONST : XTPSynchro.h
  • XTP_GUARD_EXCLUSIVE_CONST : XTPSynchro.h
  • XTP_GUARD_EXCLUSIVE_CONST_ : XTPSynchro.h
  • XTP_GUARD_EXCLUSIVE_CONST_COND_ : XTPSynchro.h
  • XTP_GUARD_SHARED : XTPSynchro.h
  • XTP_GUARD_SHARED_ : XTPSynchro.h
  • XTP_GUARD_SHARED_COND : XTPSynchro.h
  • XTP_GUARD_SHARED_COND_ : XTPSynchro.h
  • XTP_GUARD_SHARED_COND_CONST : XTPSynchro.h
  • XTP_GUARD_SHARED_COND_CONST_ : XTPSynchro.h
  • XTP_GUARD_SHARED_CONST : XTPSynchro.h
  • XTP_GUARD_SHARED_CONST_ : XTPSynchro.h
  • XTP_HALF_SECOND : XTPCalendarUtils.h
  • XTP_HTSCROLLDOWN : XTPScrollBase.h
  • XTP_HTSCROLLDOWNPAGE : XTPScrollBase.h
  • XTP_HTSCROLLLEFT : XTPScrollBase.h
  • XTP_HTSCROLLPOPUP : XTPScrollBase.h
  • XTP_HTSCROLLRIGHT : XTPScrollBase.h
  • XTP_HTSCROLLTHUMB : XTPScrollBase.h
  • XTP_HTSCROLLUP : XTPScrollBase.h
  • XTP_HTSCROLLUPPAGE : XTPScrollBase.h
  • XTP_ID_CALENDAR_CONTROL : XTPCalendarControlView.h
  • XTP_ID_FLOWGRAPHUNDO_ADDCONNECTION : XTPFlowGraphUndoManager.h
  • XTP_ID_FLOWGRAPHUNDO_ADDCONNECTIONPOINT : XTPFlowGraphUndoManager.h
  • XTP_ID_FLOWGRAPHUNDO_ADDNODE : XTPFlowGraphUndoManager.h
  • XTP_ID_FLOWGRAPHUNDO_DELETECONNECTION : XTPFlowGraphUndoManager.h
  • XTP_ID_FLOWGRAPHUNDO_DELETECONNECTIONPOINT : XTPFlowGraphUndoManager.h
  • XTP_ID_FLOWGRAPHUNDO_DELETENODE : XTPFlowGraphUndoManager.h
  • XTP_ID_FLOWGRAPHUNDO_GROUP : XTPFlowGraphUndoManager.h
  • XTP_ID_FLOWGRAPHUNDO_SETCONNECTIONPOSITION : XTPFlowGraphUndoManager.h
  • XTP_ID_FLOWGRAPHUNDO_SETNODECAPTION : XTPFlowGraphUndoManager.h
  • XTP_ID_FLOWGRAPHUNDO_SETNODEPOSITION : XTPFlowGraphUndoManager.h
  • XTP_ID_FLOWGRAPHUNDO_SETNODESIZE : XTPFlowGraphUndoManager.h
  • XTP_ID_GRID_COMBOBUTTON : XTPGridInplaceControls.h
  • XTP_ID_GRID_CONTROL : XTPGridView.h
  • XTP_ID_GRID_EXPANDBUTTON : XTPGridInplaceControls.h
  • XTP_ID_GRID_SPINBUTTON : XTPGridInplaceControls.h
  • XTP_ID_POPUP_CLOSE : XTPPopupItem.h
  • XTP_ID_PROPERTYGRID_COMBOBUTTON : XTPPropertyGridInplaceButton.h
  • XTP_ID_PROPERTYGRID_EXPANDBUTTON : XTPPropertyGridInplaceButton.h
  • XTP_ID_TRACKUNDO_ADDBLOCK : XTPTrackUndoManager.h
  • XTP_ID_TRACKUNDO_ADDMARKER : XTPTrackUndoManager.h
  • XTP_ID_TRACKUNDO_DELETEBLOCK : XTPTrackUndoManager.h
  • XTP_ID_TRACKUNDO_DELETEMARKER : XTPTrackUndoManager.h
  • XTP_ID_TRACKUNDO_GROUP : XTPTrackUndoManager.h
  • XTP_ID_TRACKUNDO_SETBLOCKPOSITION : XTPTrackUndoManager.h
  • XTP_ID_TRACKUNDO_SETMARKERPOSITION : XTPTrackUndoManager.h
  • XTP_IMPLEMENT_BATCH_ALLOC_OBJ_DATA : XTPCustomHeap.h
  • XTP_IMPLEMENT_CMDTARGETPROVIDER_INTERFACE : XTPFramework.h
  • XTP_IMPLEMENT_HEAP_ALLOCATOR : XTPCustomHeap.h
  • XTP_IMPLEMENT_IDISPATCH : XTPMacros.h
  • XTP_IMPLEMENT_IUNKNOWN : XTPMacros.h
  • XTP_INVALID_TLS_SLOT : XTPSystemHelpers.h
  • XTP_ISNAN : XTPMathUtils.h
  • XTP_LBN_POPUP : XTPControlListBox.h
  • XTP_LBN_SELCHANGE : XTPControlListBox.h
  • XTP_MAX_WEEKS : XTPDatePickerItemMonth.h
  • XTP_NAN : XTPMathUtils.h
  • XTP_NC_CALENDAR_BEFORE_DRAW_DAYVIEWCELL : XTPCalendarNotifications.h
  • XTP_NC_CALENDAR_BEFORE_DRAW_THEMEOBJECT : XTPCalendarNotifications.h
  • XTP_NC_CALENDAR_BEFORE_EVENT_EDIT_OPERATION : XTPCalendarNotifications.h
  • XTP_NC_CALENDAR_CAPTIONBARPART_BEFORE_CLICK : XTPCalendarNotifications.h
  • XTP_NC_CALENDAR_CAPTIONBARPART_CLICK : XTPCalendarNotifications.h
  • XTP_NC_CALENDAR_DoCreate_Event : XTPCalendarNotifications.h
  • XTP_NC_CALENDAR_DoCreate_RPattern : XTPCalendarNotifications.h
  • XTP_NC_CALENDAR_DoDelete_Event : XTPCalendarNotifications.h
  • XTP_NC_CALENDAR_DoDelete_RPattern : XTPCalendarNotifications.h
  • XTP_NC_CALENDAR_DoGetAllEvents_raw : XTPCalendarNotifications.h
  • XTP_NC_CALENDAR_DoGetUpcomingEvents : XTPCalendarNotifications.h
  • XTP_NC_CALENDAR_DoRead_Event : XTPCalendarNotifications.h
  • XTP_NC_CALENDAR_DoRead_RPattern : XTPCalendarNotifications.h
  • XTP_NC_CALENDAR_DoRemoveAllEvents : XTPCalendarNotifications.h
  • XTP_NC_CALENDAR_DoRetrieveDayEvents : XTPCalendarNotifications.h
  • XTP_NC_CALENDAR_DoUpdate_Event : XTPCalendarNotifications.h
  • XTP_NC_CALENDAR_DoUpdate_RPattern : XTPCalendarNotifications.h
  • XTP_NC_CALENDAR_GETGROPVIEWCAPTION : XTPCalendarNotifications.h
  • XTP_NC_CALENDAR_GETITEMTEXT : XTPCalendarNotifications.h
  • XTP_NC_CALENDAR_IS_EVENT_EDIT_OPERATION_DISABLED : XTPCalendarNotifications.h
  • XTP_NC_CALENDAR_ON_REMINDERS : XTPCalendarNotifications.h
  • XTP_NC_CALENDAR_PREPOPULATE : XTPCalendarNotifications.h
  • XTP_NC_CALENDAR_PREPOPULATE_DAY : XTPCalendarNotifications.h
  • XTP_NC_CALENDAR_RESOURCES_WHERE_CHANGED : XTPCalendarNotifications.h
  • XTP_NC_CALENDAR_SELECTION_CHANGED : XTPCalendarNotifications.h
  • XTP_NC_CALENDAR_THEME_CHANGED : XTPCalendarNotifications.h
  • XTP_NC_CALENDAR_USERACTION : XTPCalendarNotifications.h
  • XTP_NC_CALENDARCONTEXTMENU : XTPCalendarNotifications.h
  • XTP_NC_CALENDARDATAPROVIDERWASCHANGED : XTPCalendarNotifications.h
  • XTP_NC_CALENDAREVENTWASADDED : XTPCalendarNotifications.h
  • XTP_NC_CALENDAREVENTWASCHANGED : XTPCalendarNotifications.h
  • XTP_NC_CALENDAREVENTWASDELETED : XTPCalendarNotifications.h
  • XTP_NC_CALENDARKEYDOWN : XTPCalendarNotifications.h
  • XTP_NC_CALENDARLBUTTONDBLCLICK : XTPCalendarNotifications.h
  • XTP_NC_CALENDARLBUTTONDOWN : XTPCalendarNotifications.h
  • XTP_NC_CALENDARLBUTTONUP : XTPCalendarNotifications.h
  • XTP_NC_CALENDARMOUSEMOVE : XTPCalendarNotifications.h
  • XTP_NC_CALENDAROPTIONSWASCHANGED : XTPCalendarNotifications.h
  • XTP_NC_CALENDARPATTERNWASADDED : XTPCalendarNotifications.h
  • XTP_NC_CALENDARPATTERNWASCHANGED : XTPCalendarNotifications.h
  • XTP_NC_CALENDARPATTERNWASDELETED : XTPCalendarNotifications.h
  • XTP_NC_CALENDARRBUTTONDOWN : XTPCalendarNotifications.h
  • XTP_NC_CALENDARRBUTTONUP : XTPCalendarNotifications.h
  • XTP_NC_CALENDARVIEWTIMESCALEWASCHANGED : XTPCalendarNotifications.h
  • XTP_NC_CALENDARVIEWWASCHANGED : XTPCalendarNotifications.h
  • XTP_NC_DATEPICKER_BUTTON_CLICK : XTPDatePickerControl.h
  • XTP_NC_DATEPICKER_SELECTION_CHANGED : XTPDatePickerControl.h
  • XTP_NC_DATEPICKERBEFOREGOMODAL : XTPDatePickerNotifications.h
  • XTP_NC_DATEPICKERBUTTONCLICKED : XTPDatePickerNotifications.h
  • XTP_NC_DATEPICKERGETDAYMETRICS : XTPDatePickerNotifications.h
  • XTP_NC_DATEPICKERMONTHCHANGED : XTPDatePickerNotifications.h
  • XTP_NC_DATEPICKERMOUSEMOVE : XTPDatePickerNotifications.h
  • XTP_NC_DATEPICKERSELECTIONCHANGED : XTPDatePickerNotifications.h
  • XTP_NM_GRID_BEFORE_COPY_TOTEXT : XTPGridDefines.h
  • XTP_NM_GRID_BEFORE_PASTE : XTPGridDefines.h
  • XTP_NM_GRID_BEFORE_PASTE_FROMTEXT : XTPGridDefines.h
  • XTP_NM_GRID_BEGINDRAG : XTPGridDefines.h
  • XTP_NM_GRID_BEGINEDIT : XTPGridDefines.h
  • XTP_NM_GRID_CHECKED : XTPGridDefines.h
  • XTP_NM_GRID_COLUMNORDERCHANGED : XTPGridDefines.h
  • XTP_NM_GRID_COLUMNWIDTHCHANGED : XTPGridDefines.h
  • XTP_NM_GRID_CONSTRAINT_SELECTING : XTPGridDefines.h
  • XTP_NM_GRID_DRAGDROP_COMPLETED : XTPGridDefines.h
  • XTP_NM_GRID_DRAGOVER : XTPGridDefines.h
  • XTP_NM_GRID_DROP : XTPGridDefines.h
  • XTP_NM_GRID_EDIT_CANCELED : XTPGridDefines.h
  • XTP_NM_GRID_FOCUS_CHANGING : XTPGridDefines.h
  • XTP_NM_GRID_GETITEMMETRICS : XTPGridDefines.h
  • XTP_NM_GRID_GETTOOLTIPINFO : XTPGridDefines.h
  • XTP_NM_GRID_GROUPORDERCHANGED : XTPGridDefines.h
  • XTP_NM_GRID_HEADER_RCLICK : XTPGridDefines.h
  • XTP_NM_GRID_HSCROLL : XTPGridDefines.h
  • XTP_NM_GRID_HYPERLINK : XTPGridDefines.h
  • XTP_NM_GRID_INPLACEBUTTONDOWN : XTPGridDefines.h
  • XTP_NM_GRID_ITEMBUTTONCLICK : XTPGridDefines.h
  • XTP_NM_GRID_LBUTTONDOWN : XTPGridDefines.h
  • XTP_NM_GRID_MOUSEMOVE : XTPGridDefines.h
  • XTP_NM_GRID_PLUSMINUSCLICK : XTPGridDefines.h
  • XTP_NM_GRID_PRESORTORDERCHANGED : XTPGridDefines.h
  • XTP_NM_GRID_PREVIEWKEYDOWN : XTPGridDefines.h
  • XTP_NM_GRID_RECORDS_DROPPED : XTPGridDefines.h
  • XTP_NM_GRID_REQUESTEDIT : XTPGridDefines.h
  • XTP_NM_GRID_ROWEXPANDED : XTPGridDefines.h
  • XTP_NM_GRID_ROWHEIGHTCHANGED : XTPGridDefines.h
  • XTP_NM_GRID_SELCHANGED : XTPGridDefines.h
  • XTP_NM_GRID_SELCHANGING : XTPGridDefines.h
  • XTP_NM_GRID_SORTORDERCHANGED : XTPGridDefines.h
  • XTP_NM_GRID_STATECHANGED : XTPGridDefines.h
  • XTP_NM_GRID_VALUECHANGED : XTPGridDefines.h
  • XTP_NM_GRID_VSCROLL : XTPGridDefines.h
  • XTP_NM_TRACK_BLOCKCHANGED : XTPTrackControl.h
  • XTP_NM_TRACK_MARKERCHANGED : XTPTrackControl.h
  • XTP_NM_TRACK_SELECTEDBLOCKSCHANGED : XTPTrackControl.h
  • XTP_NM_TRACK_SLIDERCHANGED : XTPTrackControl.h
  • XTP_NM_TRACK_TIMELINECHANGED : XTPTrackControl.h
  • XTP_OBJECT_CACHE_HASH_TABLE_SIZE : XTPCalendarData.h
  • XTP_PCN_ITEMCLICK : XTPPopupControl.h
  • XTP_PCN_POSCHANGED : XTPPopupControl.h
  • XTP_PCN_STATECHANGED : XTPPopupControl.h
  • XTP_PGI_EXPAND_BORDER : XTPPropertyGridItem.h
  • XTP_PGN_AFTEREDIT : XTPPropertyGridDefines.h
  • XTP_PGN_CANCELEDIT : XTPPropertyGridDefines.h
  • XTP_PGN_DBLCLICK : XTPPropertyGridDefines.h
  • XTP_PGN_DRAWITEM : XTPPropertyGridDefines.h
  • XTP_PGN_EDIT_CHANGED : XTPPropertyGridDefines.h
  • XTP_PGN_INPLACEBUTTONDOWN : XTPPropertyGridDefines.h
  • XTP_PGN_ITEMEXPANDCHANGED : XTPPropertyGridDefines.h
  • XTP_PGN_ITEMVALUE_CHANGED : XTPPropertyGridDefines.h
  • XTP_PGN_RCLICK : XTPPropertyGridDefines.h
  • XTP_PGN_REQUESTEDIT : XTPPropertyGridDefines.h
  • XTP_PGN_SELECTION_CHANGED : XTPPropertyGridDefines.h
  • XTP_PGN_SORTORDER_CHANGED : XTPPropertyGridDefines.h
  • XTP_PGN_USER : XTPPropertyGridDefines.h
  • XTP_PGN_VERB_CLICK : XTPPropertyGridDefines.h
  • XTP_PGN_VSCROLL : XTPPropertyGridDefines.h
  • XTP_PGS_OWNERDRAW : XTPPropertyGridDefines.h
  • XTP_PROPERTY_GRID_DISABLE_SCROLLBAR_THEMES : XTPPropertyGrid.h
  • XTP_RESIZE : XTPResizeRect.h
  • XTP_RWCS_LOCK_EXCLUSIVE_SCOPE : XTPSynchro.h
  • XTP_RWCS_LOCK_SHARED_SCOPE : XTPSynchro.h
  • XTP_SAFE_CALL_BASE : XTPCalendarTheme.h
  • XTP_SBN_MINIMIZEBUTTONCLICKED : XTPShortcutBar.h
  • XTP_SBN_RCLICK : XTPShortcutBar.h
  • XTP_SBN_SELECTION_CHANGED : XTPShortcutBar.h
  • XTP_SBN_SELECTION_CHANGING : XTPShortcutBar.h
  • XTP_SELECTION_INFINITE : XTPDatePickerControl.h
  • XTP_SKINPROPERTY_BOOL : XTPSkinManager.h
  • XTP_SKINPROPERTY_COLOR : XTPSkinManager.h
  • XTP_SKINPROPERTY_ENUM : XTPSkinManager.h
  • XTP_SKINPROPERTY_FILENAME : XTPSkinManager.h
  • XTP_SKINPROPERTY_FONT : XTPSkinManager.h
  • XTP_SKINPROPERTY_INT : XTPSkinManager.h
  • XTP_SKINPROPERTY_INTLIST : XTPSkinManager.h
  • XTP_SKINPROPERTY_MARGINS : XTPSkinManager.h
  • XTP_SKINPROPERTY_POSITION : XTPSkinManager.h
  • XTP_SKINPROPERTY_RECT : XTPSkinManager.h
  • XTP_SKINPROPERTY_SIZE : XTPSkinManager.h
  • XTP_SKINPROPERTY_STRING : XTPSkinManager.h
  • XTP_SKINPROPERTY_UNKNOWN : XTPSkinManager.h
  • XTP_SLN_SELCHANGE : XTPControlExt.h
  • XTP_TABMANAGER_COLOR_NONE : XTPTabManagerDefines.h
  • XTP_TABMANAGER_COLOR_SHADED : XTPTabManagerDefines.h
  • XTP_TPN_CLICK : XTPTaskPanelDefines.h
  • XTP_TPN_DBLCLICK : XTPTaskPanelDefines.h
  • XTP_TPN_ENDLABELEDIT : XTPTaskPanelDefines.h
  • XTP_TPN_FOCUSEDITEMCHANGED : XTPTaskPanelDefines.h
  • XTP_TPN_GROUPEXPANDED : XTPTaskPanelDefines.h
  • XTP_TPN_GROUPEXPANDING : XTPTaskPanelDefines.h
  • XTP_TPN_GROUPMOVE : XTPTaskPanelDefines.h
  • XTP_TPN_HOTITEMCHANGED : XTPTaskPanelDefines.h
  • XTP_TPN_ITEMDROP : XTPTaskPanelDefines.h
  • XTP_TPN_ITEMREMOVED : XTPTaskPanelDefines.h
  • XTP_TPN_RCLICK : XTPTaskPanelDefines.h
  • XTP_TPN_STARTDRAG : XTPTaskPanelDefines.h
  • XTP_UNUSED : XTPMacros.h
  • XTP_UNUSED_PARAMETER : XTPMacros.h
  • XTP_WEEK_DAYS : XTPDatePickerItemMonth.h
  • XTP_WIDE : XTPMacros.h
  • XTP_WM_GAUGEUPDATE : XTPGaugeCtrl.h
  • XTP_WM_MARKUPREDRAW : XTPMarkupRender.h
  • xtp_wm_SwitchView : XTPCalendarDefines.h
  • XTP_WM_TIME_ZONE_CHANGED : XTPCalendarMsgNotifier.h
  • XTP_WM_UPDATE_MDI_CHILD_THEME : XTPFrameWnd.h
  • xtp_wm_UserAction : XTPCalendarDefines.h
  • XTP_ZOOM_PAGEWIDTH : XTPPreviewView.h
  • XTP_ZOOM_WHOLEPAGE : XTPPreviewView.h
  • XTPAccessExclusive() : XTPSynchro.h
  • XTPAccessShared() : XTPSynchro.h
  • xtpAniDefault : XTPAnimationDC.h
  • xtpAniFade : XTPAnimationDC.h
  • xtpAnimateFade : XTPCommandBarsDefines.h
  • xtpAnimateNone : XTPCommandBarsDefines.h
  • xtpAnimateRandom : XTPCommandBarsDefines.h
  • xtpAnimateSlide : XTPCommandBarsDefines.h
  • xtpAnimateUnfold : XTPCommandBarsDefines.h
  • xtpAnimateWindowsDefault : XTPCommandBarsDefines.h
  • XTPAnimationDCType : XTPAnimationDC.h
  • XTPAnimationType : XTPCommandBarsDefines.h
  • xtpAniNone : XTPAnimationDC.h
  • xtpAniRandom : XTPAnimationDC.h
  • xtpAniSlide : XTPAnimationDC.h
  • xtpAniUnfold : XTPAnimationDC.h
  • xtpApplicationAccentColor : XTPApplication.h
  • XTPApplicationAmbientProperty : XTPApplication.h
  • xtpApplicationStateColor : XTPApplication.h
  • xtpApplicationUseSystemAccentColor : XTPApplication.h
  • XTPArrowIcon : XTPExcelTabCtrl.h
  • xtpArrowIconLeft : XTPExcelTabCtrl.h
  • xtpArrowIconLeftHome : XTPExcelTabCtrl.h
  • xtpArrowIconRight : XTPExcelTabCtrl.h
  • xtpArrowIconRightHome : XTPExcelTabCtrl.h
  • XTPAuxData() : XTPGlobal.h
  • XTPBackImage : XTPCommandBarsOffice2013Theme.h
  • xtpBarBottom : XTPCommandBarsDefines.h
  • xtpBarFloating : XTPCommandBarsDefines.h
  • xtpBarLeft : XTPCommandBarsDefines.h
  • xtpBarListBox : XTPCommandBarsDefines.h
  • xtpBarNone : XTPCommandBarsDefines.h
  • xtpBarPopup : XTPCommandBarsDefines.h
  • XTPBarPosition : XTPCommandBarsDefines.h
  • xtpBarRight : XTPCommandBarsDefines.h
  • xtpBarTextAuto : XTPCommandBarsDefines.h
  • xtpBarTextHorizontal : XTPCommandBarsDefines.h
  • XTPBarTextOrientation : XTPCommandBarsDefines.h
  • xtpBarTextVertical : XTPCommandBarsDefines.h
  • xtpBarTop : XTPCommandBarsDefines.h
  • XTPBarType : XTPCommandBarsDefines.h
  • xtpBarTypeMenuBar : XTPCommandBarsDefines.h
  • xtpBarTypeNormal : XTPCommandBarsDefines.h
  • xtpBarTypePopup : XTPCommandBarsDefines.h
  • xtpBarTypeRibbon : XTPCommandBarsDefines.h
  • xtpBtnStateChecked : XTPCalendarCaptionBarThemePart.h
  • xtpBtnStateFocused : XTPCalendarCaptionBarThemePart.h
  • xtpBtnStateMouseOver : XTPCalendarCaptionBarThemePart.h
  • xtpBtnStateNormal : XTPCalendarCaptionBarThemePart.h
  • xtpBtnStatePressed : XTPCalendarCaptionBarThemePart.h
  • xtpButtonAutomatic : XTPCommandBarsDefines.h
  • xtpButtonCaption : XTPCommandBarsDefines.h
  • xtpButtonCaptionAndDescription : XTPCommandBarsDefines.h
  • xtpButtonDropDown : XTPButton.h
  • xtpButtonDropDownNoGlyph : XTPButton.h
  • xtpButtonDropDownRight : XTPButton.h
  • xtpButtonExpandFloating : XTPPaintManager.h
  • xtpButtonExpandMenu : XTPPaintManager.h
  • xtpButtonExpandToolbar : XTPPaintManager.h
  • xtpButtonHideFloating : XTPPaintManager.h
  • xtpButtonIcon : XTPCommandBarsDefines.h
  • xtpButtonIconAndCaption : XTPCommandBarsDefines.h
  • xtpButtonIconAndCaptionBelow : XTPCommandBarsDefines.h
  • xtpButtonImageAboveText : XTPButton.h
  • xtpButtonImageBeforeText : XTPButton.h
  • xtpButtonNormal : XTPButton.h
  • xtpButtonOverlay : XTPButton.h
  • xtpButtonSplitDropDown : XTPButton.h
  • XTPButtonStyle : XTPCommandBarsDefines.h
  • xtpButtonTextAboveImage : XTPButton.h
  • xtpButtonTextBeforeImage : XTPButton.h
  • XTPButtonTextImageRelation : XTPButton.h
  • xtpButtonUndefined : XTPCommandBarsDefines.h
  • xtpCalendaDragModeCopy : XTPCalendarDefines.h
  • xtpCalendaDragModeEditSubject : XTPCalendarDefines.h
  • xtpCalendaDragModeMove : XTPCalendarDefines.h
  • xtpCalendaDragModeResizeBegin : XTPCalendarDefines.h
  • xtpCalendaDragModeResizeEnd : XTPCalendarDefines.h
  • xtpCalendaDragModeUnknown : XTPCalendarDefines.h
  • xtpCalendarBeforeDraw_AllDayViewEvent : XTPCalendarNotifications.h
  • xtpCalendarBeforeDraw_DayViewCell : XTPCalendarNotifications.h
  • xtpCalendarBeforeDraw_DayViewDay : XTPCalendarNotifications.h
  • xtpCalendarBeforeDraw_DayViewDayGroup : XTPCalendarNotifications.h
  • xtpCalendarBeforeDraw_DayViewEvent : XTPCalendarNotifications.h
  • xtpCalendarBeforeDraw_DayViewTimeScale : XTPCalendarNotifications.h
  • xtpCalendarBeforeDraw_DayViewTimeScaleCaption : XTPCalendarNotifications.h
  • xtpCalendarBeforeDraw_DayViewTimeScaleCell : XTPCalendarNotifications.h
  • xtpCalendarBeforeDraw_MonthViewDay : XTPCalendarNotifications.h
  • xtpCalendarBeforeDraw_MonthViewEvent : XTPCalendarNotifications.h
  • xtpCalendarBeforeDraw_MonthViewWeekDayHeader : XTPCalendarNotifications.h
  • xtpCalendarBeforeDraw_MonthViewWeekHeader : XTPCalendarNotifications.h
  • xtpCalendarBeforeDraw_WeekViewDay : XTPCalendarNotifications.h
  • xtpCalendarBeforeDraw_WeekViewEvent : XTPCalendarNotifications.h
  • XTPCalendarBeforeDrawThemeObject : XTPCalendarNotifications.h
  • xtpCalendarBusyStatusBusy : XTPCalendarDefines.h
  • xtpCalendarBusyStatusElsewhere : XTPCalendarDefines.h
  • xtpCalendarBusyStatusFree : XTPCalendarDefines.h
  • xtpCalendarBusyStatusOutOfOffice : XTPCalendarDefines.h
  • xtpCalendarBusyStatusTentative : XTPCalendarDefines.h
  • xtpCalendarBusyStatusUnknown : XTPCalendarDefines.h
  • xtpCalendarCaptionBar_ButtonExpand : XTPCalendarCaptionBarControl.h
  • xtpCalendarCaptionBar_ButtonViewDay : XTPCalendarCaptionBarControl.h
  • xtpCalendarCaptionBar_ButtonViewMonth : XTPCalendarCaptionBarControl.h
  • xtpCalendarCaptionBar_ButtonViewWeek : XTPCalendarCaptionBarControl.h
  • xtpCalendarCaptionBar_DateLabel : XTPCalendarCaptionBarControl.h
  • xtpCalendarCaptionBar_MultiColumnsWeek : XTPCalendarCaptionBarControl.h
  • xtpCalendarCaptionBar_ScrollNextDate : XTPCalendarCaptionBarControl.h
  • xtpCalendarCaptionBar_ScrollPrevDate : XTPCalendarCaptionBarControl.h
  • xtpCalendarCaptionBar_ShowFullWeek : XTPCalendarCaptionBarControl.h
  • xtpCalendarCaptionBar_ShowTimeline : XTPCalendarCaptionBarControl.h
  • xtpCalendarCaptionBar_ShowWorkWeek : XTPCalendarCaptionBarControl.h
  • xtpCalendarCaptionBar_Unknown : XTPCalendarCaptionBarControl.h
  • xtpCalendarCaptionFormatStartEndSubject : XTPCalendarViewEvent.h
  • xtpCalendarCaptionFormatStartSubject : XTPCalendarViewEvent.h
  • xtpCalendarCaptionFormatSubject : XTPCalendarViewEvent.h
  • xtpCalendarCaptionFormatUnknown : XTPCalendarViewEvent.h
  • XTPCalendarClipboardCopyFlags : XTPCalendarDefines.h
  • xtpCalendarClockAlignCenter : XTPCalendarDefines.h
  • XTPCalendarClockAlignFlags : XTPCalendarDefines.h
  • xtpCalendarClockAlignLeft : XTPCalendarDefines.h
  • xtpCalendarClockAlignRight : XTPCalendarDefines.h
  • xtpCalendarCopyFlagClearCBAfterPaste : XTPCalendarDefines.h
  • xtpCalendarCopyFlagCutMask : XTPCalendarDefines.h
  • xtpCalendarCopyFlagKeepRException : XTPCalendarDefines.h
  • xtpCalendarCopyFlagROccurrence2RException : XTPCalendarDefines.h
  • XTPCALENDARCTRL_CLASSNAME : XTPCalendarDefines.h
  • XTPCALENDARCTRL_SWITCHVIEWMSG : XTPCalendarDefines.h
  • XTPCALENDARCTRL_USERACTION : XTPCalendarDefines.h
  • XTPCalendarCurrentTimeMarkFlags : XTPCalendarDefines.h
  • xtpCalendarCurrentTimeMarkNone : XTPCalendarDefines.h
  • xtpCalendarCurrentTimeMarkPrinted : XTPCalendarDefines.h
  • xtpCalendarCurrentTimeMarkVisibleAlways : XTPCalendarDefines.h
  • xtpCalendarCurrentTimeMarkVisibleForToday : XTPCalendarDefines.h
  • XTPCalendarDataProvider : XTPCalendarDefines.h
  • XTPCalendarDataProviderCacheMode : XTPCalendarDefines.h
  • xtpCalendarDataProviderCustom : XTPCalendarDefines.h
  • xtpCalendarDataProviderDatabase : XTPCalendarDefines.h
  • xtpCalendarDataProviderMAPI : XTPCalendarDefines.h
  • xtpCalendarDataProviderMemory : XTPCalendarDefines.h
  • xtpCalendarDataProviderUnknown : XTPCalendarDefines.h
  • xtpCalendarDateTime_max() : XTPCalendarUtils.h
  • xtpCalendarDateTime_min() : XTPCalendarUtils.h
  • xtpCalendarDayAllWeek : XTPCalendarDefines.h
  • xtpCalendarDayFriday : XTPCalendarDefines.h
  • xtpCalendarDayMo_Fr : XTPCalendarDefines.h
  • xtpCalendarDayMonday : XTPCalendarDefines.h
  • xtpCalendarDaySaSu : XTPCalendarDefines.h
  • xtpCalendarDaySaturday : XTPCalendarDefines.h
  • xtpCalendarDaySunday : XTPCalendarDefines.h
  • xtpCalendarDayThursday : XTPCalendarDefines.h
  • xtpCalendarDayTuesday : XTPCalendarDefines.h
  • xtpCalendarDayView : XTPCalendarDefines.h
  • XTPCalendarDayViewScrollDirection : XTPCalendarDefines.h
  • xtpCalendarDayViewScrollDown : XTPCalendarDefines.h
  • xtpCalendarDayViewScrollLeft : XTPCalendarDefines.h
  • xtpCalendarDayViewScrollNotNeeded : XTPCalendarDefines.h
  • xtpCalendarDayViewScrollRight : XTPCalendarDefines.h
  • xtpCalendarDayViewScrollUp : XTPCalendarDefines.h
  • xtpCalendarDayWednesday : XTPCalendarDefines.h
  • xtpCalendarDPCacheModeOff : XTPCalendarDefines.h
  • xtpCalendarDPCacheModeOnClear : XTPCalendarDefines.h
  • xtpCalendarDPCacheModeOnMask : XTPCalendarDefines.h
  • xtpCalendarDPCacheModeOnRepeat : XTPCalendarDefines.h
  • XTPCalendarDraggingMode : XTPCalendarDefines.h
  • XTPCalendarEditOperation : XTPCalendarDefines.h
  • xtpCalendarEditSubjectCancel : XTPCalendarDefines.h
  • xtpCalendarEditSubjectCommit : XTPCalendarDefines.h
  • xtpCalendarEditSubjectUnknown : XTPCalendarDefines.h
  • XTPCalendarEndEditSubjectAction : XTPCalendarDefines.h
  • xtpCalendarEO_Copy : XTPCalendarDefines.h
  • xtpCalendarEO_Cut : XTPCalendarDefines.h
  • xtpCalendarEO_DeleteEvent : XTPCalendarDefines.h
  • xtpCalendarEO_DeleteSelectedEvents : XTPCalendarDefines.h
  • xtpCalendarEO_DragCopy : XTPCalendarDefines.h
  • xtpCalendarEO_DragMove : XTPCalendarDefines.h
  • xtpCalendarEO_DragResizeBegin : XTPCalendarDefines.h
  • xtpCalendarEO_DragResizeEnd : XTPCalendarDefines.h
  • xtpCalendarEO_EditSubject_AfterEventResize : XTPCalendarDefines.h
  • xtpCalendarEO_EditSubject_ByF2 : XTPCalendarDefines.h
  • xtpCalendarEO_EditSubject_ByMouseClick : XTPCalendarDefines.h
  • xtpCalendarEO_EditSubject_ByTab : XTPCalendarDefines.h
  • xtpCalendarEO_InPlaceCreateEvent : XTPCalendarDefines.h
  • xtpCalendarEO_Paste : XTPCalendarDefines.h
  • xtpCalendarEO_Unknown : XTPCalendarDefines.h
  • XTPCalendarEventBusyStatus : XTPCalendarDefines.h
  • XTPCalendarEventCaptionFormat : XTPCalendarViewEvent.h
  • XTPCalendarEventCategories : XTPCalendarDefines.h
  • xtpCalendarEventCategoryBlue : XTPCalendarDefines.h
  • xtpCalendarEventCategoryGreen : XTPCalendarDefines.h
  • xtpCalendarEventCategoryOrange : XTPCalendarDefines.h
  • xtpCalendarEventCategoryPurple : XTPCalendarDefines.h
  • xtpCalendarEventCategoryRed : XTPCalendarDefines.h
  • xtpCalendarEventCategoryUnknown : XTPCalendarDefines.h
  • xtpCalendarEventCategoryYellow : XTPCalendarDefines.h
  • xtpCalendarEventIconIDException : XTPCalendarDefines.h
  • xtpCalendarEventIconIDMeeting : XTPCalendarDefines.h
  • xtpCalendarEventIconIDOccurrence : XTPCalendarDefines.h
  • xtpCalendarEventIconIDPrivate : XTPCalendarDefines.h
  • xtpCalendarEventIconIDReminder : XTPCalendarDefines.h
  • XTPCalendarEventIconIDs : XTPCalendarDefines.h
  • XTPCalendarEventImportance : XTPCalendarDefines.h
  • XTPCalendarEventRecurrenceState : XTPCalendarDefines.h
  • XTPCalendarEventRecurrenceType : XTPCalendarDefines.h
  • XTPCalendarExpandDayButton : XTPCalendarDefines.h
  • xtpCalendarExpandDayButton_MonthView : XTPCalendarDefines.h
  • xtpCalendarExpandDayButton_WeekView : XTPCalendarDefines.h
  • xtpCalendarFullWeekView : XTPCalendarDefines.h
  • XTPCalendarGetItemText : XTPCalendarDefines.h
  • XTPCalendarGetItemTextEx : XTPCalendarDefines.h
  • xtpCalendarHitTestAllDayEventsScrollDown : XTPCalendarDefines.h
  • xtpCalendarHitTestAllDayEventsScrollUp : XTPCalendarDefines.h
  • xtpCalendarHitTestAllDayExpandButton : XTPCalendarDefines.h
  • XTPCalendarHitTestCode : XTPCalendarDefines.h
  • xtpCalendarHitTestDay_Mask : XTPCalendarDefines.h
  • xtpCalendarHitTestDayArea : XTPCalendarDefines.h
  • xtpCalendarHitTestDayExpandButton : XTPCalendarDefines.h
  • xtpCalendarHitTestDayHeader : XTPCalendarDefines.h
  • xtpCalendarHitTestDayView_Mask : XTPCalendarDefines.h
  • xtpCalendarHitTestDayViewAllDayEvent : XTPCalendarDefines.h
  • xtpCalendarHitTestDayViewCell : XTPCalendarDefines.h
  • xtpCalendarHitTestDayViewScrollDown : XTPCalendarDefines.h
  • xtpCalendarHitTestDayViewScrollUp : XTPCalendarDefines.h
  • xtpCalendarHitTestDayViewTimeScale : XTPCalendarDefines.h
  • xtpCalendarHitTestEvent_Mask : XTPCalendarDefines.h
  • xtpCalendarHitTestEventDragArea : XTPCalendarDefines.h
  • xtpCalendarHitTestEventResizeArea_Mask : XTPCalendarDefines.h
  • xtpCalendarHitTestEventResizeBegin : XTPCalendarDefines.h
  • xtpCalendarHitTestEventResizeEnd : XTPCalendarDefines.h
  • xtpCalendarHitTestEventResizeHArea : XTPCalendarDefines.h
  • xtpCalendarHitTestEventResizeVArea : XTPCalendarDefines.h
  • xtpCalendarHitTestEventTextArea : XTPCalendarDefines.h
  • xtpCalendarHitTestGroupArea : XTPCalendarDefines.h
  • xtpCalendarHitTestGroupHeader : XTPCalendarDefines.h
  • xtpCalendarHitTestNextEventButton : XTPCalendarDefines.h
  • xtpCalendarHitTestPrevEventButton : XTPCalendarDefines.h
  • xtpCalendarHitTestTimeLineScale : XTPCalendarDefines.h
  • xtpCalendarHitTestUnknown : XTPCalendarDefines.h
  • xtpCalendarImportanceHigh : XTPCalendarDefines.h
  • xtpCalendarImportanceLow : XTPCalendarDefines.h
  • xtpCalendarImportanceNormal : XTPCalendarDefines.h
  • xtpCalendarImportanceUnknown : XTPCalendarDefines.h
  • xtpCalendarItemText_CaptionBarDayViewDateLabel : XTPCalendarDefines.h
  • xtpCalendarItemText_CaptionBarMonthViewDateLabel : XTPCalendarDefines.h
  • xtpCalendarItemText_CaptionBarWeekViewDateLabel : XTPCalendarDefines.h
  • xtpCalendarItemText_DayViewDayHeader : XTPCalendarDefines.h
  • xtpCalendarItemText_DayViewDayHeaderCenter : XTPCalendarDefines.h
  • xtpCalendarItemText_DayViewDayHeaderLeft : XTPCalendarDefines.h
  • xtpCalendarItemText_DayViewDayHeaderRight : XTPCalendarDefines.h
  • xtpCalendarItemText_EventBody : XTPCalendarDefines.h
  • xtpCalendarItemText_EventEndTimeText : XTPCalendarDefines.h
  • xtpCalendarItemText_EventLocation : XTPCalendarDefines.h
  • xtpCalendarItemText_EventMarkupTemplate : XTPCalendarDefines.h
  • xtpCalendarItemText_EventStartTimeText : XTPCalendarDefines.h
  • xtpCalendarItemText_EventSubject : XTPCalendarDefines.h
  • xtpCalendarItemText_EventToolTipText : XTPCalendarDefines.h
  • xtpCalendarItemText_MonthViewDayHeader : XTPCalendarDefines.h
  • xtpCalendarItemText_MonthViewDayHeaderCenter : XTPCalendarDefines.h
  • xtpCalendarItemText_MonthViewDayHeaderLeft : XTPCalendarDefines.h
  • xtpCalendarItemText_MonthViewDayHeaderRight : XTPCalendarDefines.h
  • xtpCalendarItemText_MonthViewWeekDayHeader : XTPCalendarDefines.h
  • xtpCalendarItemText_WeekViewDayHeader : XTPCalendarDefines.h
  • xtpCalendarItemText_WeekViewDayHeaderCenter : XTPCalendarDefines.h
  • xtpCalendarItemText_WeekViewDayHeaderLeft : XTPCalendarDefines.h
  • xtpCalendarItemText_WeekViewDayHeaderRight : XTPCalendarDefines.h
  • xtpCalendarMonthView : XTPCalendarDefines.h
  • xtpCalendarMouseEventDragCopy : XTPCalendarDefines.h
  • xtpCalendarMouseEventDraggingOut : XTPCalendarDefines.h
  • xtpCalendarMouseEventDragMove : XTPCalendarDefines.h
  • xtpCalendarMouseEventPreDrag : XTPCalendarDefines.h
  • xtpCalendarMouseEventPreResizeH : XTPCalendarDefines.h
  • xtpCalendarMouseEventPreResizeV : XTPCalendarDefines.h
  • xtpCalendarMouseEventResizingH : XTPCalendarDefines.h
  • xtpCalendarMouseEventResizingV : XTPCalendarDefines.h
  • XTPCalendarMouseMode : XTPCalendarDefines.h
  • xtpCalendarMouseNothing : XTPCalendarDefines.h
  • XTPCalendarMsgNotifier() : XTPCalendarMsgNotifier.h
  • XTPCalendarMultiDayEventFlags : XTPCalendarViewEvent.h
  • xtpCalendarMultiDayFirst : XTPCalendarViewEvent.h
  • xtpCalendarMultiDayFMLmask : XTPCalendarViewEvent.h
  • xtpCalendarMultiDayLast : XTPCalendarViewEvent.h
  • xtpCalendarMultiDayMaster : XTPCalendarViewEvent.h
  • xtpCalendarMultiDayMiddle : XTPCalendarViewEvent.h
  • xtpCalendarMultiDayMSmask : XTPCalendarViewEvent.h
  • xtpCalendarMultiDayNoMultiDay : XTPCalendarViewEvent.h
  • xtpCalendarMultiDaySlave : XTPCalendarViewEvent.h
  • xtpCalendarMultiDayUnknown : XTPCalendarViewEvent.h
  • XTPCalendarPatternEnd : XTPCalendarDefines.h
  • xtpCalendarPatternEndAfterOccurrences : XTPCalendarDefines.h
  • xtpCalendarPatternEndDate : XTPCalendarDefines.h
  • xtpCalendarPatternEndNoDate : XTPCalendarDefines.h
  • xtpCalendarRecurrenceDaily : XTPCalendarDefines.h
  • xtpCalendarRecurrenceException : XTPCalendarDefines.h
  • xtpCalendarRecurrenceMaster : XTPCalendarDefines.h
  • xtpCalendarRecurrenceMonthly : XTPCalendarDefines.h
  • xtpCalendarRecurrenceMonthNth : XTPCalendarDefines.h
  • xtpCalendarRecurrenceNotRecurring : XTPCalendarDefines.h
  • xtpCalendarRecurrenceOccurrence : XTPCalendarDefines.h
  • xtpCalendarRecurrenceUnknown : XTPCalendarDefines.h
  • xtpCalendarRecurrenceWeekly : XTPCalendarDefines.h
  • xtpCalendarRecurrenceYearly : XTPCalendarDefines.h
  • xtpCalendarRecurrenceYearNth : XTPCalendarDefines.h
  • xtpCalendarReminderDismissed : XTPCalendarNotifications.h
  • xtpCalendarReminderDismissedAll : XTPCalendarNotifications.h
  • XTPCalendarRemindersAction : XTPCalendarNotifications.h
  • xtpCalendarRemindersFire : XTPCalendarNotifications.h
  • xtpCalendarRemindersMonitoringStarted : XTPCalendarNotifications.h
  • xtpCalendarRemindersMonitoringStopped : XTPCalendarNotifications.h
  • xtpCalendarReminderSnoozed : XTPCalendarNotifications.h
  • xtpCalendarRmdPrm_Default : XTPCalendarDefines.h
  • xtpCalendarRmdPrm_DontChange : XTPCalendarDefines.h
  • XTPCalendarScrollDayButton : XTPCalendarDefines.h
  • xtpCalendarScrollDayButton_DayViewDown : XTPCalendarDefines.h
  • xtpCalendarScrollDayButton_DayViewUp : XTPCalendarDefines.h
  • XTPCalendarSelectionChanged : XTPCalendarDefines.h
  • xtpCalendarSelectionDays : XTPCalendarDefines.h
  • xtpCalendarSelectionEvents : XTPCalendarDefines.h
  • xtpCalendarSelectionUnknown : XTPCalendarDefines.h
  • XTPCalendarTheme : XTPCalendarDefines.h
  • xtpCalendarThemeNativeWindows10 : XTPCalendarDefines.h
  • xtpCalendarThemeNativeWindows11 : XTPCalendarDefines.h
  • xtpCalendarThemeOffice2000 : XTPCalendarDefines.h
  • xtpCalendarThemeOffice2003 : XTPCalendarDefines.h
  • xtpCalendarThemeOffice2007 : XTPCalendarDefines.h
  • xtpCalendarThemeOffice2010 : XTPCalendarDefines.h
  • xtpCalendarThemeOffice2013 : XTPCalendarDefines.h
  • xtpCalendarThemeOffice2016 : XTPCalendarDefines.h
  • xtpCalendarThemeOfficeXP : XTPCalendarDefines.h
  • xtpCalendarThemeResource : XTPCalendarDefines.h
  • xtpCalendarThemeUnknown : XTPCalendarDefines.h
  • XTPCalendarThemeVersion : XTPCalendarDefines.h
  • xtpCalendarThemeVisualStudio2015 : XTPCalendarDefines.h
  • xtpCalendarThemeVisualStudio2017 : XTPCalendarDefines.h
  • xtpCalendarThemeVisualStudio2019 : XTPCalendarDefines.h
  • xtpCalendarThemeVisualStudio2022 : XTPCalendarDefines.h
  • xtpCalendarTimeLineView : XTPCalendarDefines.h
  • XTPCalendarUndoMode : XTPCalendarDefines.h
  • xtpCalendarUndoModeRedo : XTPCalendarDefines.h
  • xtpCalendarUndoModeUndo : XTPCalendarDefines.h
  • xtpCalendarUndoModeUnknown : XTPCalendarDefines.h
  • xtpCalendarUpdateAll : XTPCalendarDefines.h
  • xtpCalendarUpdateLayout : XTPCalendarDefines.h
  • XTPCalendarUpdateOptions : XTPCalendarDefines.h
  • xtpCalendarUpdateRedraw : XTPCalendarDefines.h
  • xtpCalendarUpdateRedrawIfNeed : XTPCalendarDefines.h
  • xtpCalendarUpdateScrollBar : XTPCalendarDefines.h
  • XTPCalendarUserAction : XTPCalendarNotifications.h
  • xtpCalendarUserAction_OnExpandDay : XTPCalendarNotifications.h
  • xtpCalendarUserAction_OnScrollAllDayEvensDown : XTPCalendarNotifications.h
  • xtpCalendarUserAction_OnScrollAllDayEvensUp : XTPCalendarNotifications.h
  • xtpCalendarUserAction_OnScrollDay : XTPCalendarNotifications.h
  • xtpCalendarVersion10 : XTPCalendarDefines.h
  • xtpCalendarVersion11 : XTPCalendarDefines.h
  • xtpCalendarVersion2000 : XTPCalendarDefines.h
  • xtpCalendarVersion2003 : XTPCalendarDefines.h
  • xtpCalendarVersion2007 : XTPCalendarDefines.h
  • xtpCalendarVersion2010 : XTPCalendarDefines.h
  • xtpCalendarVersion2013 : XTPCalendarDefines.h
  • xtpCalendarVersion2015 : XTPCalendarDefines.h
  • xtpCalendarVersion2017 : XTPCalendarDefines.h
  • xtpCalendarVersion2019 : XTPCalendarDefines.h
  • xtpCalendarVersion2022 : XTPCalendarDefines.h
  • xtpCalendarVersionUnknown : XTPCalendarDefines.h
  • xtpCalendarVersionXP : XTPCalendarDefines.h
  • xtpCalendarViewChangedLock : XTPCalendarDefines.h
  • xtpCalendarViewChangedSend : XTPCalendarDefines.h
  • XTPCalendarViewChangedUpdateOptions : XTPCalendarDefines.h
  • XTPCalendarViewType : XTPCalendarDefines.h
  • XTPCalendarWeek : XTPCalendarDefines.h
  • XTPCalendarWeekDay : XTPCalendarDefines.h
  • xtpCalendarWeekFirst : XTPCalendarDefines.h
  • xtpCalendarWeekFourth : XTPCalendarDefines.h
  • xtpCalendarWeekLast : XTPCalendarDefines.h
  • xtpCalendarWeekSecond : XTPCalendarDefines.h
  • xtpCalendarWeekThird : XTPCalendarDefines.h
  • xtpCalendarWeekView : XTPCalendarDefines.h
  • xtpCalendarWorkWeekView : XTPCalendarDefines.h
  • XTPCalligraphy : XTPCommandBarsOffice2013Theme.h
  • XTPChangeWindowFont() : XTPFunctions.h
  • XTPChartAxisAlignment : XTPChartAxis.h
  • XTPChartAxisDateTimeScaleUnit : XTPChartAxis.h
  • xtpChartAxisFar : XTPChartAxis.h
  • xtpChartAxisNear : XTPChartAxis.h
  • xtpChartCurrency : XTPChartNumberFormat.h
  • xtpChartDateTimeCustom : XTPChartNumberFormat.h
  • XTPChartDateTimeFormatCategory : XTPChartNumberFormat.h
  • xtpChartDateTimeGeneral : XTPChartNumberFormat.h
  • xtpChartDateTimeLongDate : XTPChartNumberFormat.h
  • xtpChartDateTimeLongTime : XTPChartNumberFormat.h
  • xtpChartDateTimeMonthAndDay : XTPChartNumberFormat.h
  • xtpChartDateTimeMonthAndYear : XTPChartNumberFormat.h
  • xtpChartDateTimeShortDate : XTPChartNumberFormat.h
  • xtpChartDateTimeShortTime : XTPChartNumberFormat.h
  • xtpChartDockBottom : XTPChartTitle.h
  • XTPChartDocking : XTPChartTitle.h
  • xtpChartDockLeft : XTPChartTitle.h
  • xtpChartDockRight : XTPChartTitle.h
  • xtpChartDockTop : XTPChartTitle.h
  • xtpChartFunnelLabelCenter : XTPChartFunnelSeriesLabelBase.h
  • xtpChartFunnelLabelLeft : XTPChartFunnelSeriesLabelBase.h
  • XTPChartFunnelLabelPosition : XTPChartFunnelSeriesLabelBase.h
  • xtpChartFunnelLabelRight : XTPChartFunnelSeriesLabelBase.h
  • xtpChartGeneral : XTPChartNumberFormat.h
  • XTPChartLegendAlignment : XTPChartLegend.h
  • xtpChartLegendAsc : XTPChartLegend.h
  • xtpChartLegendCenter : XTPChartLegend.h
  • xtpChartLegendDesc : XTPChartLegend.h
  • XTPChartLegendDirection : XTPChartLegend.h
  • xtpChartLegendFar : XTPChartLegend.h
  • xtpChartLegendFarOutside : XTPChartLegend.h
  • xtpChartLegendLeftToRight : XTPChartLegend.h
  • xtpChartLegendMaxToMin : XTPChartLegend.h
  • xtpChartLegendMinToMax : XTPChartLegend.h
  • xtpChartLegendNear : XTPChartLegend.h
  • xtpChartLegendNearOutside : XTPChartLegend.h
  • xtpChartLegendNone : XTPChartLegend.h
  • XTPChartLegendSortDirection : XTPChartLegend.h
  • xtpChartLegendTopToBottom : XTPChartLegend.h
  • xtpChartMarkerCircle : XTPChartMarker.h
  • xtpChartMarkerDiamond : XTPChartMarker.h
  • xtpChartMarkerHexagon : XTPChartMarker.h
  • xtpChartMarkerPentagon : XTPChartMarker.h
  • xtpChartMarkerSquare : XTPChartMarker.h
  • xtpChartMarkerStar : XTPChartMarker.h
  • xtpChartMarkerTriangle : XTPChartMarker.h
  • XTPChartMarkerType : XTPChartMarker.h
  • xtpChartNumber : XTPChartNumberFormat.h
  • XTPChartNumberFormatCategory : XTPChartNumberFormat.h
  • XTPChartPanelDirection : XTPChartContent.h
  • xtpChartPanelHorizontal : XTPChartContent.h
  • xtpChartPanelVertical : XTPChartContent.h
  • xtpChartPercentage : XTPChartNumberFormat.h
  • xtpChartPieLabelInside : XTPChartPieSeriesLabelBase.h
  • xtpChartPieLabelOutside : XTPChartPieSeriesLabelBase.h
  • XTPChartPieLabelPosition : XTPChartPieSeriesLabelBase.h
  • xtpChartPieLabelRadial : XTPChartPieSeriesLabelBase.h
  • xtpChartPieLabelTwoColumns : XTPChartPieSeriesLabelBase.h
  • xtpChartPyramidLabelCenter : XTPChartPyramidSeriesLabelBase.h
  • xtpChartPyramidLabelLeft : XTPChartPyramidSeriesLabelBase.h
  • XTPChartPyramidLabelPosition : XTPChartPyramidSeriesLabelBase.h
  • xtpChartPyramidLabelRight : XTPChartPyramidSeriesLabelBase.h
  • xtpChartRadarDiagramCircle : XTPChartRadarDiagram.h
  • xtpChartRadarDiagramPolygon : XTPChartRadarDiagram.h
  • XTPChartRadarDiagramStyle : XTPChartRadarDiagram.h
  • xtpChartRangeBarLabelInside : XTPChartRangeBarSeriesLabel.h
  • xtpChartRangeBarLabelOutside : XTPChartRangeBarSeriesLabel.h
  • XTPChartRangeBarLabelPosition : XTPChartRangeBarSeriesLabel.h
  • XTPChartRangeBarLabelType : XTPChartRangeBarSeriesLabel.h
  • xtpChartRangeBarMaxValueLabel : XTPChartRangeBarSeriesLabel.h
  • xtpChartRangeBarMinValueLabel : XTPChartRangeBarSeriesLabel.h
  • xtpChartRangeBarOneLabel : XTPChartRangeBarSeriesLabel.h
  • xtpChartRangeBarTwoLabels : XTPChartRangeBarSeriesLabel.h
  • xtpChartScaleDay : XTPChartAxis.h
  • xtpChartScaleHour : XTPChartAxis.h
  • xtpChartScaleMinute : XTPChartAxis.h
  • xtpChartScaleMonth : XTPChartAxis.h
  • xtpChartScaleYear : XTPChartAxis.h
  • xtpChartScientific : XTPChartNumberFormat.h
  • XTPChartSeriesTrendlineType : XTPChartTrendline.h
  • xtpChartSeriesTrendlineTypeLinear : XTPChartTrendline.h
  • xtpChartSeriesTrendlineTypeMaximum : XTPChartTrendline.h
  • xtpChartSeriesTrendlineTypeMinimum : XTPChartTrendline.h
  • xtpChartSeriesTrendlineTypeMovingAverageSimple : XTPChartTrendline.h
  • xtpChartSeriesTrendlineTypeNone : XTPChartTrendline.h
  • xtpChartTextCenterBottom : XTPChartTextPainter.h
  • xtpChartTextCenterCenter : XTPChartTextPainter.h
  • xtpChartTextCenterTop : XTPChartTextPainter.h
  • xtpChartTextLeftBottom : XTPChartTextPainter.h
  • xtpChartTextLeftCenter : XTPChartTextPainter.h
  • xtpChartTextLeftTop : XTPChartTextPainter.h
  • xtpChartTextRightBottom : XTPChartTextPainter.h
  • xtpChartTextRightCenter : XTPChartTextPainter.h
  • xtpChartTextRightTop : XTPChartTextPainter.h
  • XTPChartTextRotation : XTPChartTextPainter.h
  • xtpChartUpdateLayout : XTPChartElement.h
  • XTPChartUpdateOptions : XTPChartElement.h
  • xtpChartUpdateRedraw : XTPChartElement.h
  • xtpChartUpdateView : XTPChartElement.h
  • XTPChildWindowFromPoint() : XTPFunctions.h
  • XTPCirclesAndStripes : XTPCommandBarsOffice2013Theme.h
  • XTPCircuit : XTPCommandBarsOffice2013Theme.h
  • XTPClouds : XTPCommandBarsOffice2013Theme.h
  • XTPColorManager() : XTPColorManager.h
  • xtpColumnBestFitModeAllData : XTPGridColumn.h
  • xtpColumnBestFitModeVisibleData : XTPGridColumn.h
  • xtpColumnIconBottom : XTPGridRecordItem.h
  • xtpColumnIconCenter : XTPGridRecordItem.h
  • xtpColumnIconLeft : XTPGridRecordItem.h
  • xtpColumnIconMask : XTPGridRecordItem.h
  • xtpColumnIconRight : XTPGridRecordItem.h
  • xtpColumnIconTop : XTPGridRecordItem.h
  • xtpColumnIconVCenter : XTPGridRecordItem.h
  • xtpColumnTextCenter : XTPGridRecordItem.h
  • xtpColumnTextLeft : XTPGridRecordItem.h
  • xtpColumnTextMask : XTPGridRecordItem.h
  • xtpColumnTextRight : XTPGridRecordItem.h
  • xtpColumnTextVCenter : XTPGridRecordItem.h
  • xtpColumnTextWordBreak : XTPGridRecordItem.h
  • xtpComboLabel : XTPCommandBarsDefines.h
  • xtpComboNormal : XTPCommandBarsDefines.h
  • XTPComInit : XTPSystemHelpers.h
  • xtpComInitAfxOle : XTPSystemHelpers.h
  • xtpComInitAppDefault : XTPSystemHelpers.h
  • xtpComInitDisableOle1DDE : XTPSystemHelpers.h
  • xtpComInitInvalid : XTPSystemHelpers.h
  • xtpComInitModuleAfxOle : XTPSystemHelpers.h
  • xtpComInitMTA : XTPSystemHelpers.h
  • xtpComInitOle : XTPSystemHelpers.h
  • xtpComInitSpeedOverMemory : XTPSystemHelpers.h
  • xtpComInitSTA : XTPSystemHelpers.h
  • xtpComInitUserDefined : XTPSystemHelpers.h
  • XTPCompare() : XTPCalendarUtils.h
  • XTPContextMenu() : XTPFunctions.h
  • xtpControlButton : XTPCommandBarsDefines.h
  • xtpControlButtonPopup : XTPCommandBarsDefines.h
  • xtpControlCheckBox : XTPCommandBarsDefines.h
  • xtpControlComboBox : XTPCommandBarsDefines.h
  • xtpControlCustom : XTPCommandBarsDefines.h
  • XTPControlCustomVerticalOptions : XTPControlCustom.h
  • XTPControlDrawState : XTPControlTheme.h
  • xtpControlDrawStateDisabled : XTPControlTheme.h
  • xtpControlDrawStateFocus : XTPControlTheme.h
  • xtpControlDrawStateHotButton : XTPControlTheme.h
  • xtpControlDrawStateHotLight : XTPControlTheme.h
  • xtpControlDrawStateNormal : XTPControlTheme.h
  • xtpControlDrawStatePushed : XTPControlTheme.h
  • xtpControlDrawStateSelected : XTPControlTheme.h
  • xtpControlEdit : XTPCommandBarsDefines.h
  • xtpControlError : XTPCommandBarsDefines.h
  • XTPControlFlags : XTPCommandBarsDefines.h
  • xtpControlGallery : XTPCommandBarsDefines.h
  • XTPControlHideFlags : XTPCommandBarsDefines.h
  • xtpControlLabel : XTPCommandBarsDefines.h
  • xtpControlPopup : XTPCommandBarsDefines.h
  • xtpControlRadioButton : XTPCommandBarsDefines.h
  • xtpControlSplitButtonPopup : XTPCommandBarsDefines.h
  • XTPControlTheme : XTPControlTheme.h
  • xtpControlThemeCustom : XTPControlTheme.h
  • xtpControlThemeDefault : XTPControlTheme.h
  • xtpControlThemeFlat : XTPControlTheme.h
  • xtpControlThemeNativeWindows10 : XTPControlTheme.h
  • xtpControlThemeNativeWindows11 : XTPControlTheme.h
  • xtpControlThemeNativeWinXP : XTPControlTheme.h
  • xtpControlThemeOffice2000 : XTPControlTheme.h
  • xtpControlThemeOffice2003 : XTPControlTheme.h
  • xtpControlThemeOffice2013 : XTPControlTheme.h
  • xtpControlThemeOffice2016 : XTPControlTheme.h
  • xtpControlThemeOfficeXP : XTPControlTheme.h
  • xtpControlThemeResource : XTPControlTheme.h
  • xtpControlThemeUltraFlat : XTPControlTheme.h
  • xtpControlThemeVisualStudio2005 : XTPControlTheme.h
  • xtpControlThemeVisualStudio2008 : XTPControlTheme.h
  • xtpControlThemeVisualStudio2010 : XTPControlTheme.h
  • xtpControlThemeVisualStudio2012 : XTPControlTheme.h
  • xtpControlThemeVisualStudio2012Dark : XTPControlTheme.h
  • xtpControlThemeVisualStudio2012Light : XTPControlTheme.h
  • xtpControlThemeVisualStudio2015 : XTPControlTheme.h
  • xtpControlThemeVisualStudio2017 : XTPControlTheme.h
  • xtpControlThemeVisualStudio2019 : XTPControlTheme.h
  • xtpControlThemeVisualStudio2022 : XTPControlTheme.h
  • XTPControlType : XTPCommandBarsDefines.h
  • XTPCreateFileStream() : XTPSystemHelpers.h
  • XTPCreateReadOnlyFileStream() : XTPSystemHelpers.h
  • XTPCreateReadOnlyMemoryStream() : XTPSystemHelpers.h
  • XTPCreateReadOnlyResourceStream() : XTPSystemHelpers.h
  • XTPCreateReadOnlyStreamOnUri() : XTPSystemHelpers.h
  • XTPCreateView() : XTPFunctions.h
  • XTPCurrentSystemTheme : XTPColorManager.h
  • xtpDatePickerBorder3D : XTPDatePickerControl.h
  • xtpDatePickerBorderNone : XTPDatePickerControl.h
  • xtpDatePickerBorderOffice : XTPDatePickerControl.h
  • xtpDatePickerBorderStatic : XTPDatePickerControl.h
  • XTPDatePickerBorderStyle : XTPDatePickerControl.h
  • XTPDebugBreak() : XTPMacros.h
  • XTPDockingContextStickerStyle : XTPDockingPaneDefines.h
  • XTPDockingPaneAction : XTPDockingPaneDefines.h
  • XTPDockingPaneCaptionButtonStyle : XTPDockingPanePaintManager.h
  • XTPDockingPaneCaptionDirection : XTPDockingPaneDefines.h
  • XTPDockingPaneDirection : XTPDockingPaneDefines.h
  • XTPDockingPaneEnableOptions : XTPDockingPaneDefines.h
  • XTPDockingPaneKeyboardNavigate : XTPDockingPaneDefines.h
  • XTPDockingPaneOptions : XTPDockingPaneDefines.h
  • XTPDockingPanePaintTheme : XTPDockingPaneDefines.h
  • XTPDockingPanePinState : XTPDockingPanePaintManager.h
  • XTPDockingPaneSplitterStyle : XTPDockingPanePaintManager.h
  • XTPDockingPaneStickerType : XTPDockingPaneDefines.h
  • XTPDockingPaneType : XTPDockingPaneDefines.h
  • XTPDoodleCircles : XTPCommandBarsOffice2013Theme.h
  • XTPDoodleDiamonds : XTPCommandBarsOffice2013Theme.h
  • XTPDrawEmbossed() : XTPFunctions.h
  • XTPDrawShadedRect() : XTPFunctions.h
  • xtpDTScale_Day : XTPCalendarTimeLineViewTimeScale.h
  • xtpDTScale_Hour : XTPCalendarTimeLineViewTimeScale.h
  • xtpDTScale_Min : XTPCalendarTimeLineViewTimeScale.h
  • xtpDTScale_Month : XTPCalendarTimeLineViewTimeScale.h
  • xtpDTScale_Sec : XTPCalendarTimeLineViewTimeScale.h
  • xtpDTScale_Unknown : XTPCalendarTimeLineViewTimeScale.h
  • xtpDTScale_Week : XTPCalendarTimeLineViewTimeScale.h
  • xtpDTScale_WorkWeek : XTPCalendarTimeLineViewTimeScale.h
  • xtpDTScale_Year : XTPCalendarTimeLineViewTimeScale.h
  • XTPDynamicDownCastRemote() : XTPSystemHelpers.h
  • xtpEditActDelete : XTPSyntaxEditDefines.h
  • xtpEditActInsert : XTPSyntaxEditDefines.h
  • xtpEditAllConfigWasChanged : XTPSyntaxEditDefines.h
  • xtpEditCfgFileAdd : XTPSyntaxEditLexColorFileReader.h
  • xtpEditCfgFileRemove : XTPSyntaxEditLexColorFileReader.h
  • xtpEditClassSchWasChanged : XTPSyntaxEditDefines.h
  • xtpEditCRLFStyleDos : XTPSyntaxEditDefines.h
  • xtpEditCRLFStyleMac : XTPSyntaxEditDefines.h
  • xtpEditCRLFStyleUnix : XTPSyntaxEditDefines.h
  • xtpEditCRLFStyleUnknown : XTPSyntaxEditDefines.h
  • xtpEditDelPosAfter : XTPSyntaxEditDefines.h
  • xtpEditDelPosBefore : XTPSyntaxEditDefines.h
  • xtpEditHintInitView : XTPSyntaxEditDefines.h
  • xtpEditHintInvalidate : XTPSyntaxEditDefines.h
  • xtpEditHintLast : XTPSyntaxEditDefines.h
  • xtpEditHintRefreshView : XTPSyntaxEditDefines.h
  • xtpEditHintSetAutoIndent : XTPSyntaxEditDefines.h
  • xtpEditHintSetFont : XTPSyntaxEditDefines.h
  • xtpEditHintSetLineNum : XTPSyntaxEditDefines.h
  • xtpEditHintSetSelMargin : XTPSyntaxEditDefines.h
  • xtpEditHintSetSyntaxColor : XTPSyntaxEditDefines.h
  • xtpEditHintUnknown : XTPSyntaxEditDefines.h
  • xtpEditHintUpdateScrollPos : XTPSyntaxEditDefines.h
  • xtpEditLMRefresh_Delete : XTPSyntaxEditLineMarksManager.h
  • xtpEditLMRefresh_Delete_only1 : XTPSyntaxEditLineMarksManager.h
  • xtpEditLMRefresh_Delete_only2 : XTPSyntaxEditLineMarksManager.h
  • xtpEditLMRefresh_Insert : XTPSyntaxEditLineMarksManager.h
  • xtpEditLMRefresh_InsertAt0 : XTPSyntaxEditLineMarksManager.h
  • xtpEditLMRefresh_Unknown : XTPSyntaxEditLineMarksManager.h
  • xtpEditLPR_EndFound : XTPSyntaxEditLexParser.h
  • xtpEditLPR_Error : XTPSyntaxEditLexParser.h
  • xtpEditLPR_Iterated : XTPSyntaxEditLexParser.h
  • xtpEditLPR_RunBreaked : XTPSyntaxEditLexParser.h
  • xtpEditLPR_RunFinished : XTPSyntaxEditLexParser.h
  • xtpEditLPR_RunRestart : XTPSyntaxEditLexParser.h
  • xtpEditLPR_StartFound : XTPSyntaxEditLexParser.h
  • xtpEditLPR_TBpop1 : XTPSyntaxEditLexParser.h
  • xtpEditLPR_Unknown : XTPSyntaxEditLexParser.h
  • xtpEditLVT_className : XTPSyntaxEditLexClass.h
  • xtpEditLVT_classPtr : XTPSyntaxEditLexClass.h
  • xtpEditLVT_LVArrayPtr : XTPSyntaxEditLexClass.h
  • xtpEditLVT_Unknown : XTPSyntaxEditLexClass.h
  • xtpEditLVT_valInt : XTPSyntaxEditLexClass.h
  • xtpEditLVT_valStr : XTPSyntaxEditLexClass.h
  • xtpEditLVT_valVar : XTPSyntaxEditLexClass.h
  • xtpEditOnParserEnded : XTPSyntaxEditDefines.h
  • xtpEditOnParserStarted : XTPSyntaxEditDefines.h
  • xtpEditOnTextBlockParsed : XTPSyntaxEditDefines.h
  • xtpEditOptChildren_Any : XTPSyntaxEditLexClass.h
  • xtpEditOptChildren_List : XTPSyntaxEditLexClass.h
  • xtpEditOptChildren_No : XTPSyntaxEditLexClass.h
  • xtpEditOptChildren_Unknown : XTPSyntaxEditLexClass.h
  • xtpEditOptParent_Default : XTPSyntaxEditLexClass.h
  • xtpEditOptParent_direct : XTPSyntaxEditLexClass.h
  • xtpEditOptParent_dyn : XTPSyntaxEditLexClass.h
  • xtpEditOptParent_file : XTPSyntaxEditLexClass.h
  • xtpEditOptParent_Unknown : XTPSyntaxEditLexClass.h
  • xtpEditThemeWasChanged : XTPSyntaxEditDefines.h
  • XTPEnumCalendarCaptionBarThemeObject : XTPCalendarCaptionBarControl.h
  • XTPEnumCalendarDateItem : XTPCalendarTimeLineViewTimeScale.h
  • XTPEnumCalendarReminderForOccurrenceParameters : XTPCalendarDefines.h
  • XTPEnumCalendarTimeScaleParamsID : XTPCalendarDefines.h
  • xtpExecuteCommand : XTPRibbonBackstageView.h
  • XTPFindResourceType() : XTPResourceManager.h
  • XTPFindType : XTPShellTreeBase.h
  • xtpFindTypeDrive : XTPShellTreeBase.h
  • xtpFindTypeFolder : XTPShellTreeBase.h
  • xtpFindTypeRoot : XTPShellTreeBase.h
  • xtpFindTypeShare : XTPShellTreeBase.h
  • xtpFirstLevel : XTPRibbonBackstageView.h
  • xtpFlagAddMDISysPopup : XTPCommandBarsDefines.h
  • xtpFlagAlignAny : XTPCommandBarsDefines.h
  • xtpFlagAlignBottom : XTPCommandBarsDefines.h
  • xtpFlagAlignLeft : XTPCommandBarsDefines.h
  • xtpFlagAlignRight : XTPCommandBarsDefines.h
  • xtpFlagAlignTop : XTPCommandBarsDefines.h
  • xtpFlagControlStretched : XTPCommandBarsDefines.h
  • xtpFlagFloating : XTPCommandBarsDefines.h
  • xtpFlagHideClose : XTPCommandBarsDefines.h
  • xtpFlagHideMaximizeBox : XTPCommandBarsDefines.h
  • xtpFlagHideMDIButtons : XTPCommandBarsDefines.h
  • xtpFlagHideMinimizeBox : XTPCommandBarsDefines.h
  • xtpFlagHideWrap : XTPCommandBarsDefines.h
  • xtpFlagIgnoreSetMenuMessage : XTPCommandBarsDefines.h
  • xtpFlagLeftPopup : XTPCommandBarsDefines.h
  • xtpFlagManualUpdate : XTPCommandBarsDefines.h
  • xtpFlagNoBorders : XTPCommandBarsDefines.h
  • xtpFlagNoMovable : XTPCommandBarsDefines.h
  • xtpFlagRibbonTabBackground : XTPCommandBarsDefines.h
  • xtpFlagRightAlign : XTPCommandBarsDefines.h
  • xtpFlagShowPopupBarTip : XTPCommandBarsDefines.h
  • xtpFlagSkipFocus : XTPCommandBarsDefines.h
  • xtpFlagSmartLayout : XTPCommandBarsDefines.h
  • xtpFlagStretched : XTPCommandBarsDefines.h
  • xtpFlagStretchedShared : XTPCommandBarsDefines.h
  • xtpFlagUseMDIMenus : XTPCommandBarsDefines.h
  • xtpFlagWrapRow : XTPCommandBarsDefines.h
  • XTPFlowGraphConnectionPointType : XTPFlowGraphNode.h
  • xtpFlowGraphConnectorCurved : XTPFlowGraphPaintManager.h
  • xtpFlowGraphConnectorCurvedArrow : XTPFlowGraphPaintManager.h
  • xtpFlowGraphConnectorCurvedDoubleArrow : XTPFlowGraphPaintManager.h
  • xtpFlowGraphConnectorElbow : XTPFlowGraphPaintManager.h
  • xtpFlowGraphConnectorElbowArrow : XTPFlowGraphPaintManager.h
  • xtpFlowGraphConnectorElbowDoubleArrow : XTPFlowGraphPaintManager.h
  • xtpFlowGraphConnectorStraight : XTPFlowGraphPaintManager.h
  • xtpFlowGraphConnectorStraightArrow : XTPFlowGraphPaintManager.h
  • xtpFlowGraphConnectorStraightDoubleArrow : XTPFlowGraphPaintManager.h
  • XTPFlowGraphConnectorType : XTPFlowGraphPaintManager.h
  • xtpFlowGraphCustomNodeCaptionBelow : XTPFlowGraphNodeCustom.h
  • xtpFlowGraphCustomNodeCaptionCenter : XTPFlowGraphNodeCustom.h
  • XTPFlowGraphCustomNodeCaptionPosition : XTPFlowGraphNodeCustom.h
  • xtpFlowGraphCustomNodeFillGradientCenterHorizontal : XTPFlowGraphNodeCustom.h
  • xtpFlowGraphCustomNodeFillGradientCenterVertical : XTPFlowGraphNodeCustom.h
  • xtpFlowGraphCustomNodeFillGradientDiagonalLeft : XTPFlowGraphNodeCustom.h
  • xtpFlowGraphCustomNodeFillGradientDiagonalRight : XTPFlowGraphNodeCustom.h
  • xtpFlowGraphCustomNodeFillGradientHorizontal : XTPFlowGraphNodeCustom.h
  • xtpFlowGraphCustomNodeFillGradientVertical : XTPFlowGraphNodeCustom.h
  • xtpFlowGraphCustomNodeFillSolid : XTPFlowGraphNodeCustom.h
  • XTPFlowGraphCustomNodeFillType : XTPFlowGraphNodeCustom.h
  • XTPFlowGraphCustomProperty : XTPFlowGraphControl.h
  • XTPFlowGraphDefaultXAMLTemplate : XTPFlowGraphControl.h
  • xtpFlowGraphPointBoth : XTPFlowGraphNode.h
  • xtpFlowGraphPointInput : XTPFlowGraphNode.h
  • xtpFlowGraphPointInputAndOutput : XTPFlowGraphNode.h
  • xtpFlowGraphPointNone : XTPFlowGraphNode.h
  • xtpFlowGraphPointOutput : XTPFlowGraphNode.h
  • xtpFlowGraphPropertyCanSetColor : XTPFlowGraphControl.h
  • xtpFlowGraphPropertyConnectionPoint : XTPFlowGraphControl.h
  • xtpFlowGraphPropertyConnectionPointIn : XTPFlowGraphControl.h
  • xtpFlowGraphPropertyConnectionPointType : XTPFlowGraphControl.h
  • xtpFlowGraphPropertyResizable : XTPFlowGraphControl.h
  • XTPFlowGraphResize : XTPFlowGraphControl.h
  • xtpFlowGraphResizeBoth : XTPFlowGraphControl.h
  • xtpFlowGraphResizeHorizontal : XTPFlowGraphControl.h
  • xtpFlowGraphResizeNone : XTPFlowGraphControl.h
  • xtpFlowGraphResizeVertical : XTPFlowGraphControl.h
  • XTPFlowGraphSmoothingMode : XTPFlowGraphControl.h
  • xtpFlowGraphSmoothingModeAuto : XTPFlowGraphControl.h
  • xtpFlowGraphSmoothingModeGDI : XTPFlowGraphControl.h
  • xtpFlowGraphSmoothingModeHighQuality : XTPFlowGraphControl.h
  • xtpFlowGraphSmoothingModeHighSpeed : XTPFlowGraphControl.h
  • xtpFlowGraphTemplateNode : XTPFlowGraphControl.h
  • xtpFlowGraphTemplateNodePointIn : XTPFlowGraphControl.h
  • xtpFlowGraphTemplateNodePointInOut : XTPFlowGraphControl.h
  • xtpFlowGraphTemplateNodePointNone : XTPFlowGraphControl.h
  • xtpFlowGraphTemplateNodePointOut : XTPFlowGraphControl.h
  • xtpFontBoth : XTPFontComboBox.h
  • xtpFontGUI : XTPFontComboBox.h
  • XTPFontManager() : XTPFontManager.h
  • xtpFontSample : XTPFontComboBox.h
  • XTPFontStyle : XTPFontComboBox.h
  • xtpFontUnknown : XTPFontComboBox.h
  • XTPFrameShadowManager() : XTPFrameShadowManager.h
  • XTPFrameShadowManagerFlags : XTPFrameShadowManager.h
  • xtpFrameShadowsDisabled : XTPFrameShadowManager.h
  • xtpFrameShadowsDisabledInTSS : XTPFrameShadowManager.h
  • xtpFrameShadowsInvisible : XTPFrameShadowManager.h
  • xtpFrameShadowsInvisibleInTSS : XTPFrameShadowManager.h
  • xtpFrameShadowsNotResizeable : XTPFrameShadowManager.h
  • XTPGeometry : XTPCommandBarsOffice2013Theme.h
  • XTPGetAccentColor() : XTPColorManager.h
  • XTPGetApplication() : XTPApplication.h
  • XTPGetColorizationColor() : XTPColorManager.h
  • XTPGetDefaultResourceTypeFromPath() : XTPResourceManager.h
  • XTPGetInstanceHandle() : XTPResourceManager.h
  • xtpGridAllowDrag : XTPGridControl.h
  • xtpGridAllowDragCopy : XTPGridControl.h
  • xtpGridAllowDragMove : XTPGridControl.h
  • xtpGridAllowDrop : XTPGridControl.h
  • XTPGridBehavior : XTPGridBehavior.h
  • xtpGridBehaviorCodejock1340 : XTPGridBehavior.h
  • xtpGridBehaviorCodejock1341 : XTPGridBehavior.h
  • xtpGridBehaviorCodejock1342 : XTPGridBehavior.h
  • xtpGridBehaviorCodejock1501 : XTPGridBehavior.h
  • xtpGridBehaviorCodejock1502 : XTPGridBehavior.h
  • xtpGridBehaviorCodejockDefault : XTPGridBehavior.h
  • xtpGridBehaviorExcel2003 : XTPGridBehavior.h
  • xtpGridBehaviorExcel2007 : XTPGridBehavior.h
  • xtpGridBehaviorExcel2010 : XTPGridBehavior.h
  • xtpGridBehaviorOutlook2003 : XTPGridBehavior.h
  • xtpGridBehaviorOutlook2007 : XTPGridBehavior.h
  • xtpGridBehaviorOutlook2010 : XTPGridBehavior.h
  • XTPGridBorderEdge : XTPGridBorder.h
  • xtpGridBorderEdgeBottom : XTPGridBorder.h
  • xtpGridBorderEdgeCount : XTPGridBorder.h
  • xtpGridBorderEdgeLeft : XTPGridBorder.h
  • xtpGridBorderEdgeRight : XTPGridBorder.h
  • xtpGridBorderEdgeTop : XTPGridBorder.h
  • XTPGridCheckState : XTPGridDefines.h
  • xtpGridCheckStateChecked : XTPGridDefines.h
  • xtpGridCheckStateCount : XTPGridDefines.h
  • xtpGridCheckStateIndeterminate : XTPGridDefines.h
  • xtpGridCheckStateInvalid : XTPGridDefines.h
  • xtpGridCheckStateUnchecked : XTPGridDefines.h
  • xtpGridColumnAdded : XTPGridHeader.h
  • xtpGridColumnAddedToFieldChooser : XTPGridHeader.h
  • xtpGridColumnAddedToGroupby : XTPGridHeader.h
  • XTPGridColumnBestFitMode : XTPGridColumn.h
  • xtpGridColumnCaptionChanged : XTPGridHeader.h
  • xtpGridColumnChangeMask : XTPGridHeader.h
  • xtpGridColumnChangeOther : XTPGridHeader.h
  • XTPGridColumnDirection : XTPGridHeader.h
  • xtpGridColumnDirectionLeft : XTPGridHeader.h
  • xtpGridColumnDirectionRight : XTPGridHeader.h
  • xtpGridColumnExplorer : XTPGridDefines.h
  • xtpGridColumnFlat : XTPGridDefines.h
  • xtpGridColumnGroupOrderChanged : XTPGridHeader.h
  • xtpGridColumnHidden : XTPGridHeader.h
  • XTPGridColumnIconAlignment : XTPGridRecordItem.h
  • xtpGridColumnMoved : XTPGridHeader.h
  • xtpGridColumnOffice2003 : XTPGridDefines.h
  • xtpGridColumnOrderChanged : XTPGridHeader.h
  • xtpGridColumnOrderChangedMask : XTPGridHeader.h
  • XTPGridColumnOrderChangedReason : XTPGridHeader.h
  • xtpGridColumnPropExchange : XTPGridHeader.h
  • xtpGridColumnRemoved : XTPGridHeader.h
  • xtpGridColumnRemovedFromFieldChooser : XTPGridHeader.h
  • xtpGridColumnRemovedFromGroupby : XTPGridHeader.h
  • xtpGridColumnResource : XTPGridDefines.h
  • xtpGridColumnShaded : XTPGridDefines.h
  • xtpGridColumnShown : XTPGridHeader.h
  • XTPGridColumnStyle : XTPGridDefines.h
  • xtpGridColumnWidthChanged : XTPGridHeader.h
  • XTPGRIDCTRL_CF_RECORDS : XTPGridDefines.h
  • XTPGRIDCTRL_CLASSNAME : XTPGridDefines.h
  • xtpGridDontDropAsText : XTPGridControl.h
  • XTPGridDragDrop : XTPGridControl.h
  • xtpGridDrawSortTriangleAlways : XTPGridDefines.h
  • xtpGridDrawSortTriangleDefault : XTPGridDefines.h
  • xtpGridDrawSortTriangleNever : XTPGridDefines.h
  • XTPGridDrawSortTriangleStyle : XTPGridDefines.h
  • xtpGridDropBetween : XTPGridControl.h
  • XTPGridDropMarker : XTPGridControl.h
  • xtpGridDropSelect : XTPGridControl.h
  • XTPGridElementRect : XTPGridControl.h
  • xtpGridElementRectFooterArea : XTPGridControl.h
  • xtpGridElementRectFooterRecordsArea : XTPGridControl.h
  • xtpGridElementRectFooterRecordsDividerArea : XTPGridControl.h
  • xtpGridElementRectGridArea : XTPGridControl.h
  • xtpGridElementRectGroupByArea : XTPGridControl.h
  • xtpGridElementRectHeaderArea : XTPGridControl.h
  • xtpGridElementRectHeaderRecordsArea : XTPGridControl.h
  • xtpGridElementRectHeaderRecordsDividerArea : XTPGridControl.h
  • XTPGridFilterMode : XTPGridControl.h
  • xtpGridFilterTreeByEndChildrenOnly : XTPGridControl.h
  • xtpGridFilterTreeByParentAndChildren : XTPGridControl.h
  • xtpGridFilterTreeSimple : XTPGridControl.h
  • xtpGridFreezeColsDividerBold : XTPGridDefines.h
  • xtpGridFreezeColsDividerHeader : XTPGridDefines.h
  • xtpGridFreezeColsDividerShade : XTPGridDefines.h
  • xtpGridFreezeColsDividerShowAlways : XTPGridDefines.h
  • XTPGridFreezeColsDividerStyle : XTPGridDefines.h
  • xtpGridFreezeColsDividerThin : XTPGridDefines.h
  • XTPGridGlyph : XTPGridDefines.h
  • xtpGridGlyphColumnExpand : XTPGridDefines.h
  • xtpGridGlyphColumnRestore : XTPGridDefines.h
  • xtpGridGlyphCount : XTPGridDefines.h
  • xtpGridGlyphDisabledChecked : XTPGridDefines.h
  • xtpGridGlyphDisabledUnchecked : XTPGridDefines.h
  • xtpGridGlyphEnabledChecked : XTPGridDefines.h
  • xtpGridGlyphEnabledTristate : XTPGridDefines.h
  • xtpGridGlyphEnabledUnchecked : XTPGridDefines.h
  • xtpGridGlyphInvalid : XTPGridDefines.h
  • xtpGridGlyphItemLocked : XTPGridDefines.h
  • xtpGridGlyphItemUnlocked : XTPGridDefines.h
  • xtpGridGlyphRowCollapse : XTPGridDefines.h
  • xtpGridGlyphRowExpand : XTPGridDefines.h
  • xtpGridGridDashes : XTPGridDefines.h
  • xtpGridGridLargeDots : XTPGridDefines.h
  • xtpGridGridNoLines : XTPGridDefines.h
  • xtpGridGridSmallDots : XTPGridDefines.h
  • xtpGridGridSolid : XTPGridDefines.h
  • XTPGridGroupRowIconAlignment : XTPGridRecordItem.h
  • XTPGridItemControlAlignment : XTPGridRecordItemControls.h
  • XTPGridItemControlType : XTPGridRecordItemControls.h
  • XTPGridLineStyle : XTPGridDefines.h
  • xtpGridLineStyleCount : XTPGridDefines.h
  • xtpGridLineStyleDash : XTPGridDefines.h
  • xtpGridLineStyleDotLarge : XTPGridDefines.h
  • xtpGridLineStyleDotSmall : XTPGridDefines.h
  • xtpGridLineStyleNone : XTPGridDefines.h
  • xtpGridLineStyleSolid : XTPGridDefines.h
  • XTPGridMouseButton : XTPGridBehavior.h
  • xtpGridMouseButtonLeft : XTPGridBehavior.h
  • xtpGridMouseButtonMiddle : XTPGridBehavior.h
  • xtpGridMouseButtonNone : XTPGridBehavior.h
  • xtpGridMouseButtonRight : XTPGridBehavior.h
  • xtpGridMouseDraggingColumn : XTPGridControl.h
  • XTPGridMouseEvent : XTPGridBehavior.h
  • xtpGridMouseEventButtonDown : XTPGridBehavior.h
  • xtpGridMouseEventButtonUp : XTPGridBehavior.h
  • XTPGridMouseMode : XTPGridControl.h
  • xtpGridMouseNothing : XTPGridControl.h
  • xtpGridMouseOverColumnDivide : XTPGridControl.h
  • xtpGridMouseOverRowDivide : XTPGridControl.h
  • xtpGridMousePrepareDragColumn : XTPGridControl.h
  • XTPGridOrientation : XTPGridDefines.h
  • xtpGridOrientationAll : XTPGridDefines.h
  • xtpGridOrientationHorizontal : XTPGridDefines.h
  • xtpGridOrientationVertical : XTPGridDefines.h
  • XTPGridPaintTheme : XTPGridDefines.h
  • XTPGridRowsCompareFunc : XTPGridDefines.h
  • XTPGridRowType : XTPGridDefines.h
  • XTPGridScrollMode : XTPGridControl.h
  • xtpGridScrollModeBlock : XTPGridControl.h
  • xtpGridScrollModeBlockCount : XTPGridControl.h
  • xtpGridScrollModeBlockSize : XTPGridControl.h
  • xtpGridScrollModeNone : XTPGridControl.h
  • xtpGridScrollModeSmooth : XTPGridControl.h
  • XTPGridScrollUpdateMode : XTPGridControl.h
  • xtpGridScrollUpdateModeDeferred : XTPGridControl.h
  • xtpGridScrollUpdateModeImmediate : XTPGridControl.h
  • XTPGridSection : XTPGridSections.h
  • xtpGridSectionBody : XTPGridSections.h
  • xtpGridSectionCount : XTPGridSections.h
  • XTPGridSectionDividerPosition : XTPGridDefines.h
  • xtpGridSectionDividerPositionBottom : XTPGridDefines.h
  • xtpGridSectionDividerPositionTop : XTPGridDefines.h
  • XTPGridSectionDividerStyle : XTPGridDefines.h
  • xtpGridSectionDividerStyleBold : XTPGridDefines.h
  • xtpGridSectionDividerStyleNone : XTPGridDefines.h
  • xtpGridSectionDividerStyleOutlook : XTPGridDefines.h
  • xtpGridSectionDividerStyleShade : XTPGridDefines.h
  • xtpGridSectionDividerStyleThin : XTPGridDefines.h
  • xtpGridSectionFooter : XTPGridSections.h
  • xtpGridSectionHeader : XTPGridSections.h
  • XTPGridSectionHeightMode : XTPGridSection.h
  • xtpGridSectionHeightModeAuto : XTPGridSection.h
  • xtpGridSectionHeightModeAutoExpand : XTPGridSection.h
  • xtpGridSectionHeightModeAutoShrink : XTPGridSection.h
  • xtpGridSectionHeightModeExpand : XTPGridSection.h
  • xtpGridSectionHeightModeFixed : XTPGridSection.h
  • xtpGridSectionHeightModeRelative : XTPGridSection.h
  • xtpGridSelectionAdd : XTPGridRows.h
  • XTPGridSelectionChangeType : XTPGridRows.h
  • xtpGridSelectionClear : XTPGridRows.h
  • xtpGridSelectionRemove : XTPGridRows.h
  • XTPGridShellIcon : XTPGridDefines.h
  • xtpGridShellIconLock : XTPGridDefines.h
  • XTPGridTextDecoration : XTPGridDefines.h
  • xtpGridTextDecorationNone : XTPGridDefines.h
  • xtpGridTextDecorationUnderline : XTPGridDefines.h
  • xtpGridTextSearchBackward : XTPGridRecords.h
  • xtpGridTextSearchExactPhrase : XTPGridRecords.h
  • xtpGridTextSearchExactStart : XTPGridRecords.h
  • xtpGridTextSearchMatchCase : XTPGridRecords.h
  • XTPGridTextSearchParms : XTPGridRecords.h
  • xtpGridThemeDefault : XTPGridDefines.h
  • xtpGridThemeExplorer : XTPGridDefines.h
  • xtpGridThemeNativeWindows10 : XTPGridDefines.h
  • xtpGridThemeNativeWindows11 : XTPGridDefines.h
  • xtpGridThemeOffice2003 : XTPGridDefines.h
  • xtpGridThemeOffice2003Luna : XTPGridDefines.h
  • xtpGridThemeOffice2013 : XTPGridDefines.h
  • xtpGridThemeOffice2016 : XTPGridDefines.h
  • xtpGridThemeOfficeXP : XTPGridDefines.h
  • xtpGridThemeResource : XTPGridDefines.h
  • xtpGridThemeVisualStudio2012Blue : XTPGridDefines.h
  • xtpGridThemeVisualStudio2012Dark : XTPGridDefines.h
  • xtpGridThemeVisualStudio2012Light : XTPGridDefines.h
  • xtpGridThemeVisualStudio2015 : XTPGridDefines.h
  • xtpGridThemeVisualStudio2017 : XTPGridDefines.h
  • xtpGridThemeVisualStudio2019 : XTPGridDefines.h
  • xtpGridThemeVisualStudio2022 : XTPGridDefines.h
  • xtpGridTreeStructureDots : XTPGridDefines.h
  • xtpGridTreeStructureNone : XTPGridDefines.h
  • xtpGridTreeStructureSolid : XTPGridDefines.h
  • XTPGridTreeStructureStyle : XTPGridDefines.h
  • XTPGridVirtualRowFlags : XTPGridRecordItem.h
  • XTPGridWatermarkAlignment : XTPGridControl.h
  • xtpGridWatermarkBottom : XTPGridControl.h
  • xtpGridWatermarkCenter : XTPGridControl.h
  • xtpGridWatermarkEnlargeOnly : XTPGridControl.h
  • xtpGridWatermarkHmask : XTPGridControl.h
  • xtpGridWatermarkLeft : XTPGridControl.h
  • xtpGridWatermarkPreserveRatio : XTPGridControl.h
  • xtpGridWatermarkRight : XTPGridControl.h
  • xtpGridWatermarkShrinkOnly : XTPGridControl.h
  • xtpGridWatermarkStretch : XTPGridControl.h
  • xtpGridWatermarkTop : XTPGridControl.h
  • xtpGridWatermarkUnknown : XTPGridControl.h
  • xtpGridWatermarkVCenter : XTPGridControl.h
  • xtpGridWatermarkVmask : XTPGridControl.h
  • xtpGroupBoxBorder : XTPButton.h
  • XTPGroupBoxBorderStyle : XTPButton.h
  • xtpGroupBoxNone : XTPButton.h
  • xtpGroupBoxSingleLine : XTPButton.h
  • xtpGroupRowIconAfterText : XTPGridRecordItem.h
  • xtpGroupRowIconBeforeText : XTPGridRecordItem.h
  • xtpGroupRowIconHmask : XTPGridRecordItem.h
  • xtpGroupRowIconLeft : XTPGridRecordItem.h
  • xtpGroupRowIconRight : XTPGridRecordItem.h
  • xtpGroupRowIconUnknown : XTPGridRecordItem.h
  • xtpGroupRowIconVBottom : XTPGridRecordItem.h
  • xtpGroupRowIconVCenter : XTPGridRecordItem.h
  • xtpGroupRowIconVCenterToText : XTPGridRecordItem.h
  • xtpGroupRowIconVmask : XTPGridRecordItem.h
  • xtpGroupRowIconVTop : XTPGridRecordItem.h
  • XTPHeapSetCompatibilityInformation() : XTPCustomHeap.h
  • XTPHeapSetLowFragmentation() : XTPCustomHeap.h
  • xtpHideCustomize : XTPCommandBarsDefines.h
  • xtpHideDockingPosition : XTPCommandBarsDefines.h
  • xtpHideDocTemplate : XTPCommandBarsDefines.h
  • xtpHideExpand : XTPCommandBarsDefines.h
  • xtpHideGeneric : XTPCommandBarsDefines.h
  • xtpHideRibbonTab : XTPCommandBarsDefines.h
  • xtpHideScroll : XTPCommandBarsDefines.h
  • xtpHideTips : XTPRibbonBackstageView.h
  • xtpHideWrap : XTPCommandBarsDefines.h
  • XTPHookManager() : XTPHookManager.h
  • xtpIconSizeAtLeast : XTPImageManager.h
  • xtpIconSizeAtMost : XTPImageManager.h
  • xtpIconSizeExact : XTPImageManager.h
  • XTPIconSizeMatching : XTPImageManager.h
  • XTPIdleFlags : XTPCommandBarsDefines.h
  • xtpIdleLayout : XTPCommandBarsDefines.h
  • xtpIdleRedraw : XTPCommandBarsDefines.h
  • xtpImageChecked : XTPImageManager.h
  • xtpImageDisabled : XTPImageManager.h
  • xtpImageHot : XTPImageManager.h
  • XTPImageManager() : XTPImageManager.h
  • xtpImageNormal : XTPImageManager.h
  • xtpImagePressed : XTPImageManager.h
  • XTPImageState : XTPImageManager.h
  • XTPIniColor() : XTPResourceImage.h
  • XTPIniInt() : XTPResourceImage.h
  • xtpIniOffice2007Aqua : XTPResourceImage.h
  • xtpIniOffice2007Black : XTPResourceImage.h
  • xtpIniOffice2007Blue : XTPResourceImage.h
  • xtpIniOffice2007Silver : XTPResourceImage.h
  • xtpIniOffice2010Black : XTPResourceImage.h
  • xtpIniOffice2010Blue : XTPResourceImage.h
  • xtpIniOffice2010Silver : XTPResourceImage.h
  • xtpIniOffice2013Access : XTPResourceImage.h
  • xtpIniOffice2013AccessGrayDark : XTPResourceImage.h
  • xtpIniOffice2013AccessGrayLight : XTPResourceImage.h
  • xtpIniOffice2013Excel : XTPResourceImage.h
  • xtpIniOffice2013ExcelGrayDark : XTPResourceImage.h
  • xtpIniOffice2013ExcelGrayLight : XTPResourceImage.h
  • xtpIniOffice2013OneNote : XTPResourceImage.h
  • xtpIniOffice2013OneNoteGrayDark : XTPResourceImage.h
  • xtpIniOffice2013OneNoteGrayLight : XTPResourceImage.h
  • xtpIniOffice2013Outlook : XTPResourceImage.h
  • xtpIniOffice2013OutlookGrayDark : XTPResourceImage.h
  • xtpIniOffice2013OutlookGrayLight : XTPResourceImage.h
  • xtpIniOffice2013PowerPoint : XTPResourceImage.h
  • xtpIniOffice2013PowerPointGrayDark : XTPResourceImage.h
  • xtpIniOffice2013PowerPointGrayLight : XTPResourceImage.h
  • xtpIniOffice2013Publisher : XTPResourceImage.h
  • xtpIniOffice2013PublisherGrayDark : XTPResourceImage.h
  • xtpIniOffice2013PublisherGrayLight : XTPResourceImage.h
  • xtpIniOffice2013Word : XTPResourceImage.h
  • xtpIniOffice2013WordGrayDark : XTPResourceImage.h
  • xtpIniOffice2013WordGrayLight : XTPResourceImage.h
  • xtpIniOffice2016AccessBlack : XTPResourceImage.h
  • xtpIniOffice2016AccessColorful : XTPResourceImage.h
  • xtpIniOffice2016AccessDarkGray : XTPResourceImage.h
  • xtpIniOffice2016AccessWhite : XTPResourceImage.h
  • xtpIniOffice2016ExcelBlack : XTPResourceImage.h
  • xtpIniOffice2016ExcelColorful : XTPResourceImage.h
  • xtpIniOffice2016ExcelDarkGray : XTPResourceImage.h
  • xtpIniOffice2016ExcelWhite : XTPResourceImage.h
  • xtpIniOffice2016OneNoteBlack : XTPResourceImage.h
  • xtpIniOffice2016OneNoteColorful : XTPResourceImage.h
  • xtpIniOffice2016OneNoteDarkGray : XTPResourceImage.h
  • xtpIniOffice2016OneNoteWhite : XTPResourceImage.h
  • xtpIniOffice2016OutlookBlack : XTPResourceImage.h
  • xtpIniOffice2016OutlookColorful : XTPResourceImage.h
  • xtpIniOffice2016OutlookDarkGray : XTPResourceImage.h
  • xtpIniOffice2016OutlookWhite : XTPResourceImage.h
  • xtpIniOffice2016PowerPointBlack : XTPResourceImage.h
  • xtpIniOffice2016PowerPointColorful : XTPResourceImage.h
  • xtpIniOffice2016PowerPointDarkGray : XTPResourceImage.h
  • xtpIniOffice2016PowerPointWhite : XTPResourceImage.h
  • xtpIniOffice2016PublisherBlack : XTPResourceImage.h
  • xtpIniOffice2016PublisherColorful : XTPResourceImage.h
  • xtpIniOffice2016PublisherDarkGray : XTPResourceImage.h
  • xtpIniOffice2016PublisherWhite : XTPResourceImage.h
  • xtpIniOffice2016WordBlack : XTPResourceImage.h
  • xtpIniOffice2016WordColorful : XTPResourceImage.h
  • xtpIniOffice2016WordDarkGray : XTPResourceImage.h
  • xtpIniOffice2016WordWhite : XTPResourceImage.h
  • XTPIniRect() : XTPResourceImage.h
  • XTPIniSize() : XTPResourceImage.h
  • XTPIniString() : XTPResourceImage.h
  • XTPInitialize() : XTPApplication.h
  • xtpIniVisualStudio2012Dark : XTPResourceImage.h
  • xtpIniVisualStudio2012Light : XTPResourceImage.h
  • xtpIniVisualStudio2015Blue : XTPResourceImage.h
  • xtpIniVisualStudio2015Dark : XTPResourceImage.h
  • xtpIniVisualStudio2015Light : XTPResourceImage.h
  • xtpIniVisualStudio2017Blue : XTPResourceImage.h
  • xtpIniVisualStudio2017BlueExtra : XTPResourceImage.h
  • xtpIniVisualStudio2017Dark : XTPResourceImage.h
  • xtpIniVisualStudio2017Light : XTPResourceImage.h
  • xtpIniVisualStudio2019Blue : XTPResourceImage.h
  • xtpIniVisualStudio2019BlueExtra : XTPResourceImage.h
  • xtpIniVisualStudio2019Dark : XTPResourceImage.h
  • xtpIniVisualStudio2019Light : XTPResourceImage.h
  • xtpIniVisualStudio2022Blue : XTPResourceImage.h
  • xtpIniVisualStudio2022BlueExtra : XTPResourceImage.h
  • xtpIniVisualStudio2022Dark : XTPResourceImage.h
  • xtpIniVisualStudio2022Light : XTPResourceImage.h
  • xtpIniWindows10Dark : XTPResourceImage.h
  • xtpIniWindows10Light : XTPResourceImage.h
  • xtpIniWindows11Dark : XTPResourceImage.h
  • xtpIniWindows11Light : XTPResourceImage.h
  • xtpIniWindows7Blue : XTPResourceImage.h
  • XTPIsDerivedFromRemote() : XTPSystemHelpers.h
  • XTPIsKindOfRemote() : XTPSystemHelpers.h
  • xtpItemControlLeft : XTPGridRecordItemControls.h
  • xtpItemControlRight : XTPGridRecordItemControls.h
  • xtpItemControlTypeButton : XTPGridRecordItemControls.h
  • xtpItemControlTypeUndefined : XTPGridRecordItemControls.h
  • xtpItemControlUnknown : XTPGridRecordItemControls.h
  • xtpKeyBack : XTPCommandBarsDefines.h
  • XTPKeyboardCuesShow : XTPCommandBarsDefines.h
  • xtpKeyboardCuesShowAlways : XTPCommandBarsDefines.h
  • xtpKeyboardCuesShowNever : XTPCommandBarsDefines.h
  • xtpKeyboardCuesShowWindowsDefault : XTPCommandBarsDefines.h
  • XTPKeyboardCuesUse : XTPCommandBarsDefines.h
  • xtpKeyboardCuesUseAll : XTPCommandBarsDefines.h
  • xtpKeyboardCuesUseAmpersandOnly : XTPCommandBarsDefines.h
  • xtpKeyboardCuesUseMenuOnly : XTPCommandBarsDefines.h
  • xtpKeyboardCuesUseNone : XTPCommandBarsDefines.h
  • xtpKeyEnd : XTPCommandBarsDefines.h
  • xtpKeyEscape : XTPCommandBarsDefines.h
  • xtpKeyHome : XTPCommandBarsDefines.h
  • xtpKeyLeft : XTPCommandBarsDefines.h
  • xtpKeyNext : XTPCommandBarsDefines.h
  • xtpKeyPopup : XTPCommandBarsDefines.h
  • xtpKeyPrev : XTPCommandBarsDefines.h
  • xtpKeyReturn : XTPCommandBarsDefines.h
  • xtpKeyRight : XTPCommandBarsDefines.h
  • xtpKeySpace : XTPCommandBarsDefines.h
  • XTPLEX_ATTR_CASESENSITIVE : XTPSyntaxEditLexClass.h
  • XTPLEX_ATTR_COLLAPSABLE : XTPSyntaxEditLexClass.h
  • XTPLEX_ATTR_COLLAPSEDTEXT : XTPSyntaxEditLexClass.h
  • XTPLEX_ATTR_COLORPREFIX : XTPSyntaxEditLexClass.h
  • XTPLEX_ATTR_DISPLAYNAME : XTPSyntaxEditLexClass.h
  • XTPLEX_ATTR_ENDCLASSPARENT : XTPSyntaxEditLexClass.h
  • XTPLEX_ATTR_PARSEONSCREEN : XTPSyntaxEditLexClass.h
  • XTPLEX_ATTR_RECURRENCEDEPTH : XTPSyntaxEditLexClass.h
  • XTPLEX_ATTR_RESTARTRUNLOOP : XTPSyntaxEditLexClass.h
  • XTPLEX_ATTR_TXT_BOLD : XTPSyntaxEditLexClass.h
  • XTPLEX_ATTR_TXT_COLORBK : XTPSyntaxEditLexClass.h
  • XTPLEX_ATTR_TXT_COLORFG : XTPSyntaxEditLexClass.h
  • XTPLEX_ATTR_TXT_COLORSELBK : XTPSyntaxEditLexClass.h
  • XTPLEX_ATTR_TXT_COLORSELFG : XTPSyntaxEditLexClass.h
  • XTPLEX_ATTR_TXT_ITALIC : XTPSyntaxEditLexClass.h
  • XTPLEX_ATTR_TXT_UNDERLINE : XTPSyntaxEditLexClass.h
  • XTPLEX_ATTR_TXTPREFIX : XTPSyntaxEditLexClass.h
  • XTPLEX_ATTRCLASSID : XTPSyntaxEditLexClass.h
  • XTPLEX_ATTRG_CONFIGCHANGEDREPARCEINSEPARATETHREAD : XTPSyntaxEditLexClass.h
  • XTPLEX_ATTRG_EDITREPARCEINSEPARATETHREAD : XTPSyntaxEditLexClass.h
  • XTPLEX_ATTRG_EDITREPARCETIMEOUT_MS : XTPSyntaxEditLexClass.h
  • XTPLEX_ATTRG_FIRSTPARSEINSEPARATETHREAD : XTPSyntaxEditLexClass.h
  • XTPLEX_ATTRG_MAXBACKPARSEOFFSET : XTPSyntaxEditLexClass.h
  • XTPLEX_ATTRG_ONSCREENSCHCACHELIFETIME_SEC : XTPSyntaxEditLexClass.h
  • XTPLEX_ATTRG_PARSERTHREADIDLELIFETIME_SEC : XTPSyntaxEditLexClass.h
  • xtpListBoxNativeWindows10 : XTPListBox.h
  • xtpListBoxNativeWindows11 : XTPListBox.h
  • xtpListBoxOffice2007 : XTPListBox.h
  • xtpListBoxOffice2013 : XTPListBox.h
  • xtpListBoxOffice2016 : XTPListBox.h
  • xtpListBoxOfficeXP : XTPListBox.h
  • xtpListBoxStandard : XTPListBox.h
  • XTPListBoxStyle : XTPListBox.h
  • xtpListBoxVisualStudio2015 : XTPListBox.h
  • xtpListBoxVisualStudio2017 : XTPListBox.h
  • xtpListBoxVisualStudio2019 : XTPListBox.h
  • xtpListBoxVisualStudio2022 : XTPListBox.h
  • XTPLoadFileText() : XTPSystemHelpers.h
  • XTPLoadImage() : XTPResourceImage.h
  • XTPLoadText() : XTPSystemHelpers.h
  • XTPLoadUnicodeText() : XTPSystemHelpers.h
  • XTPLoadWindowClass() : XTPSystemHelpers.h
  • XTPLunchBox : XTPCommandBarsOffice2013Theme.h
  • XTPMarkupAssignHandle() : XTPMarkupRender.h
  • XTPMarkupCreateContext() : XTPMarkupRender.h
  • XTPMarkupDock : XTPMarkupDockPanel.h
  • xtpMarkupDockBottom : XTPMarkupDockPanel.h
  • xtpMarkupDockLeft : XTPMarkupDockPanel.h
  • xtpMarkupDockRight : XTPMarkupDockPanel.h
  • xtpMarkupDockTop : XTPMarkupDockPanel.h
  • XTPMarkupElementContext() : XTPMarkupRender.h
  • XTPMarkupMeasureElement() : XTPMarkupRender.h
  • XTPMarkupParseText() : XTPMarkupRender.h
  • XTPMarkupPathPointType : XTPMarkupPathGeometryBuilder.h
  • xtpMarkupPathPointTypeBezier : XTPMarkupPathGeometryBuilder.h
  • xtpMarkupPathPointTypeCloseSubpath : XTPMarkupPathGeometryBuilder.h
  • xtpMarkupPathPointTypeLine : XTPMarkupPathGeometryBuilder.h
  • xtpMarkupPathPointTypeStart : XTPMarkupPathGeometryBuilder.h
  • XTPMarkupRelayMessage() : XTPMarkupRender.h
  • XTPMarkupReleaseContext() : XTPMarkupRender.h
  • XTPMarkupReleaseElement() : XTPMarkupRender.h
  • XTPMarkupRenderElement() : XTPMarkupRender.h
  • XTPMarkupSetDefaultFont() : XTPMarkupRender.h
  • xtpMarkupSmoothingAntiAlias : XTPMarkupContext.h
  • xtpMarkupSmoothingDefault : XTPMarkupContext.h
  • xtpMarkupSmoothingHighQuality : XTPMarkupContext.h
  • xtpMarkupSmoothingHighSpeed : XTPMarkupContext.h
  • XTPMarkupSmoothingMode : XTPMarkupContext.h
  • xtpMarkupSmoothingNone : XTPMarkupContext.h
  • xtpMarkupTextNoWrap : XTPMarkupTextBlock.h
  • XTPMarkupTextTrimming : XTPMarkupTextBlock.h
  • xtpMarkupTextTrimmingCharacterEllipsis : XTPMarkupTextBlock.h
  • xtpMarkupTextTrimmingNone : XTPMarkupTextBlock.h
  • xtpMarkupTextTrimmingWordEllipsis : XTPMarkupTextBlock.h
  • xtpMarkupTextWrap : XTPMarkupTextBlock.h
  • XTPMarkupTextWrapping : XTPMarkupTextBlock.h
  • xtpMarkupTextWrapWithOverflow : XTPMarkupTextBlock.h
  • XTPMenuBarFlags : XTPCommandBarsDefines.h
  • XTPMultiMonitor() : XTPSystemHelpers.h
  • xtpNavBtnArrows : XTPTabBase.h
  • xtpNavBtnClose : XTPTabBase.h
  • xtpNavBtnShowAll : XTPTabBase.h
  • XTPNavBtnState : XTPTabBase.h
  • xtpNoActionForThisLevel : XTPRibbonBackstageView.h
  • xtpNoHide : XTPCommandBarsDefines.h
  • XTPNone : XTPCommandBarsOffice2013Theme.h
  • xtpNotifyDirectCallForOneThread : XTPNotifyConnection.h
  • XTPNotifyFlags : XTPNotifyConnection.h
  • xtpNotifyGuarantyPost : XTPNotifyConnection.h
  • xtpNotifyPostMessage : XTPNotifyConnection.h
  • xtpNoTips : XTPRibbonBackstageView.h
  • XTPOpenGLListPool() : XTPOpenGLListPool.h
  • xtpPageBorderBottomLine : XTPPropertySheet.h
  • xtpPageBorderFrame : XTPPropertySheet.h
  • xtpPageBorderNone : XTPPropertySheet.h
  • XTPPaintManager() : XTPPaintManager.h
  • XTPPaintManagerAccentColor : XTPColorManager.h
  • xtpPaintManagerAccentColor : XTPColorManager.h
  • xtpPaintManagerHighlightBackAccentColor : XTPColorManager.h
  • xtpPaintManagerHighlightTextAccentColor : XTPColorManager.h
  • xtpPaintManagerNormalBackAccentColor : XTPColorManager.h
  • xtpPaintManagerNormalTextAccentColor : XTPColorManager.h
  • xtpPaintManagerPressedBackAccentColor : XTPColorManager.h
  • xtpPaintManagerPressedTextAccentColor : XTPColorManager.h
  • XTPPaintTheme : XTPCommandBarsDefines.h
  • xtpPaneActionActivated : XTPDockingPaneDefines.h
  • xtpPaneActionAttached : XTPDockingPaneDefines.h
  • xtpPaneActionAttaching : XTPDockingPaneDefines.h
  • xtpPaneActionClosed : XTPDockingPaneDefines.h
  • xtpPaneActionClosing : XTPDockingPaneDefines.h
  • xtpPaneActionCollapsed : XTPDockingPaneDefines.h
  • xtpPaneActionCollapsing : XTPDockingPaneDefines.h
  • xtpPaneActionDeactivated : XTPDockingPaneDefines.h
  • xtpPaneActionDetaching : XTPDockingPaneDefines.h
  • xtpPaneActionDocked : XTPDockingPaneDefines.h
  • xtpPaneActionDocking : XTPDockingPaneDefines.h
  • xtpPaneActionDragging : XTPDockingPaneDefines.h
  • xtpPaneActionExpanded : XTPDockingPaneDefines.h
  • xtpPaneActionExpanding : XTPDockingPaneDefines.h
  • xtpPaneActionFloated : XTPDockingPaneDefines.h
  • xtpPaneActionFloating : XTPDockingPaneDefines.h
  • xtpPaneActionPinned : XTPDockingPaneDefines.h
  • xtpPaneActionPinning : XTPDockingPaneDefines.h
  • xtpPaneActionSplitterResized : XTPDockingPaneDefines.h
  • xtpPaneActionSplitterResizing : XTPDockingPaneDefines.h
  • xtpPaneActionUnpinned : XTPDockingPaneDefines.h
  • xtpPaneActionUnpinning : XTPDockingPaneDefines.h
  • xtpPaneCaptionAutoByPosition : XTPDockingPaneDefines.h
  • xtpPaneCaptionAutoBySize : XTPDockingPaneDefines.h
  • xtpPaneCaptionButtonDefault : XTPDockingPanePaintManager.h
  • xtpPaneCaptionButtonOffice : XTPDockingPanePaintManager.h
  • xtpPaneCaptionButtonOffice2003 : XTPDockingPanePaintManager.h
  • xtpPaneCaptionButtonThemedButton : XTPDockingPanePaintManager.h
  • xtpPaneCaptionButtonThemedExplorerBar : XTPDockingPanePaintManager.h
  • xtpPaneCaptionButtonThemedToolBar : XTPDockingPanePaintManager.h
  • xtpPaneCaptionButtonThemedToolWindow : XTPDockingPanePaintManager.h
  • xtpPaneCaptionHorizontal : XTPDockingPaneDefines.h
  • xtpPaneCaptionVertical : XTPDockingPaneDefines.h
  • xtpPaneDisabled : XTPDockingPaneDefines.h
  • xtpPaneDockBottom : XTPDockingPaneDefines.h
  • xtpPaneDockLeft : XTPDockingPaneDefines.h
  • xtpPaneDockMiniWnd : XTPDockingPaneDefines.h
  • xtpPaneDockRight : XTPDockingPaneDefines.h
  • xtpPaneDockTop : XTPDockingPaneDefines.h
  • xtpPaneDockUndefined : XTPDockingPaneDefines.h
  • xtpPaneEnableActions : XTPDockingPaneDefines.h
  • xtpPaneEnableClient : XTPDockingPaneDefines.h
  • xtpPaneEnabled : XTPDockingPaneDefines.h
  • xtpPaneEnabledAuto : XTPDockingPaneDefines.h
  • xtpPaneHasMenuButton : XTPDockingPaneDefines.h
  • xtpPaneKeyboardUnused : XTPDockingPaneDefines.h
  • xtpPaneKeyboardUseAll : XTPDockingPaneDefines.h
  • xtpPaneKeyboardUseAltF6 : XTPDockingPaneDefines.h
  • xtpPaneKeyboardUseAltF7 : XTPDockingPaneDefines.h
  • xtpPaneKeyboardUseAltMinus : XTPDockingPaneDefines.h
  • xtpPaneKeyboardUseCtrlTab : XTPDockingPaneDefines.h
  • xtpPaneNoCaption : XTPDockingPaneDefines.h
  • xtpPaneNoCloseable : XTPDockingPaneDefines.h
  • xtpPaneNoDockable : XTPDockingPaneDefines.h
  • xtpPaneNoFloatable : XTPDockingPaneDefines.h
  • xtpPaneNoFloatableByCaptionDoubleClick : XTPDockingPaneDefines.h
  • xtpPaneNoFloatableByTabDoubleClick : XTPDockingPaneDefines.h
  • xtpPaneNoHideable : XTPDockingPaneDefines.h
  • xtpPaneNoHoverShow : XTPDockingPaneDefines.h
  • xtpPanePinPushed : XTPDockingPanePaintManager.h
  • xtpPanePinVisible : XTPDockingPanePaintManager.h
  • xtpPaneSplitter3D : XTPDockingPanePaintManager.h
  • xtpPaneSplitterFlat : XTPDockingPanePaintManager.h
  • xtpPaneSplitterGradient : XTPDockingPanePaintManager.h
  • xtpPaneSplitterGradientVert : XTPDockingPanePaintManager.h
  • xtpPaneSplitterGripperOffice2003 : XTPDockingPanePaintManager.h
  • xtpPaneSplitterGripperOfficeXP : XTPDockingPanePaintManager.h
  • xtpPaneSplitterSoft3D : XTPDockingPanePaintManager.h
  • xtpPaneStickerBottom : XTPDockingPaneDefines.h
  • xtpPaneStickerCenter : XTPDockingPaneDefines.h
  • xtpPaneStickerClient : XTPDockingPaneDefines.h
  • xtpPaneStickerLeft : XTPDockingPaneDefines.h
  • xtpPaneStickerNone : XTPDockingPaneDefines.h
  • xtpPaneStickerRight : XTPDockingPaneDefines.h
  • xtpPaneStickerStyleNativeWindows10Dark : XTPDockingPaneDefines.h
  • xtpPaneStickerStyleNativeWindows10Light : XTPDockingPaneDefines.h
  • xtpPaneStickerStyleNativeWindows11Dark : XTPDockingPaneDefines.h
  • xtpPaneStickerStyleNativeWindows11Light : XTPDockingPaneDefines.h
  • xtpPaneStickerStyleVisualStudio2005 : XTPDockingPaneDefines.h
  • xtpPaneStickerStyleVisualStudio2005Beta : XTPDockingPaneDefines.h
  • xtpPaneStickerStyleVisualStudio2008 : XTPDockingPaneDefines.h
  • xtpPaneStickerStyleVisualStudio2010 : XTPDockingPaneDefines.h
  • xtpPaneStickerStyleVisualStudio2012Dark : XTPDockingPaneDefines.h
  • xtpPaneStickerStyleVisualStudio2012Light : XTPDockingPaneDefines.h
  • xtpPaneStickerStyleVisualStudio2015Blue : XTPDockingPaneDefines.h
  • xtpPaneStickerStyleVisualStudio2015Dark : XTPDockingPaneDefines.h
  • xtpPaneStickerStyleVisualStudio2015Light : XTPDockingPaneDefines.h
  • xtpPaneStickerStyleVisualStudio2017Blue : XTPDockingPaneDefines.h
  • xtpPaneStickerStyleVisualStudio2017BlueExtra : XTPDockingPaneDefines.h
  • xtpPaneStickerStyleVisualStudio2017Dark : XTPDockingPaneDefines.h
  • xtpPaneStickerStyleVisualStudio2017Light : XTPDockingPaneDefines.h
  • xtpPaneStickerStyleVisualStudio2019Blue : XTPDockingPaneDefines.h
  • xtpPaneStickerStyleVisualStudio2019BlueExtra : XTPDockingPaneDefines.h
  • xtpPaneStickerStyleVisualStudio2019Dark : XTPDockingPaneDefines.h
  • xtpPaneStickerStyleVisualStudio2019Light : XTPDockingPaneDefines.h
  • xtpPaneStickerStyleVisualStudio2022Blue : XTPDockingPaneDefines.h
  • xtpPaneStickerStyleVisualStudio2022BlueExtra : XTPDockingPaneDefines.h
  • xtpPaneStickerStyleVisualStudio2022Dark : XTPDockingPaneDefines.h
  • xtpPaneStickerStyleVisualStudio2022Light : XTPDockingPaneDefines.h
  • xtpPaneStickerTop : XTPDockingPaneDefines.h
  • xtpPaneThemeCustom : XTPDockingPaneDefines.h
  • xtpPaneThemeDefault : XTPDockingPaneDefines.h
  • xtpPaneThemeGrippered : XTPDockingPaneDefines.h
  • xtpPaneThemeNativeWindows10 : XTPDockingPaneDefines.h
  • xtpPaneThemeNativeWindows11 : XTPDockingPaneDefines.h
  • xtpPaneThemeOffice2002Visio : XTPDockingPaneDefines.h
  • xtpPaneThemeOffice2003 : XTPDockingPaneDefines.h
  • xtpPaneThemeOffice2003Outlook : XTPDockingPaneDefines.h
  • xtpPaneThemeOffice2003Visio : XTPDockingPaneDefines.h
  • xtpPaneThemeOffice2007Outlook : XTPDockingPaneDefines.h
  • xtpPaneThemeOffice2007Visio : XTPDockingPaneDefines.h
  • xtpPaneThemeOffice2007Word : XTPDockingPaneDefines.h
  • xtpPaneThemeOffice2013 : XTPDockingPaneDefines.h
  • xtpPaneThemeOffice2016 : XTPDockingPaneDefines.h
  • xtpPaneThemeResource : XTPDockingPaneDefines.h
  • xtpPaneThemeVisualStudio2003 : XTPDockingPaneDefines.h
  • xtpPaneThemeVisualStudio2005 : XTPDockingPaneDefines.h
  • xtpPaneThemeVisualStudio2005Beta1 : XTPDockingPaneDefines.h
  • xtpPaneThemeVisualStudio2005Beta2 : XTPDockingPaneDefines.h
  • xtpPaneThemeVisualStudio2008 : XTPDockingPaneDefines.h
  • xtpPaneThemeVisualStudio2010 : XTPDockingPaneDefines.h
  • xtpPaneThemeVisualStudio2012 : XTPDockingPaneDefines.h
  • xtpPaneThemeVisualStudio2015 : XTPDockingPaneDefines.h
  • xtpPaneThemeVisualStudio2017 : XTPDockingPaneDefines.h
  • xtpPaneThemeVisualStudio2019 : XTPDockingPaneDefines.h
  • xtpPaneThemeVisualStudio2022 : XTPDockingPaneDefines.h
  • xtpPaneThemeVisualStudio6 : XTPDockingPaneDefines.h
  • xtpPaneThemeWinExplorer : XTPDockingPaneDefines.h
  • xtpPaneThemeWinNative : XTPDockingPaneDefines.h
  • xtpPaneTypeAutoHidePanel : XTPDockingPaneDefines.h
  • xtpPaneTypeClient : XTPDockingPaneDefines.h
  • xtpPaneTypeDockingPane : XTPDockingPaneDefines.h
  • xtpPaneTypeMiniWnd : XTPDockingPaneDefines.h
  • xtpPaneTypeSidePanel : XTPDockingPaneDefines.h
  • xtpPaneTypeSplitterContainer : XTPDockingPaneDefines.h
  • xtpPaneTypeTabbedContainer : XTPDockingPaneDefines.h
  • XTPParseDouble() : XTPSystemHelpers.h
  • XTPParseUri() : XTPSystemHelpers.h
  • XTPPathExists() : XTPFunctions.h
  • XTPPopupAnimation : XTPPopupControl.h
  • xtpPopupAnimationFade : XTPPopupControl.h
  • xtpPopupAnimationNone : XTPPopupControl.h
  • xtpPopupAnimationSlide : XTPPopupControl.h
  • xtpPopupAnimationUnfold : XTPPopupControl.h
  • XTPPopupDirection : XTPCommandBarsDefines.h
  • xtpPopupDown : XTPCommandBarsDefines.h
  • XTPPopupItemIcon : XTPPopupItem.h
  • xtpPopupItemIconNormal : XTPPopupItem.h
  • xtpPopupItemIconPressed : XTPPopupItem.h
  • xtpPopupItemIconSelected : XTPPopupItem.h
  • xtpPopupLeft : XTPCommandBarsDefines.h
  • XTPPopupLocation : XTPPopupControl.h
  • xtpPopupLocationBottomRight : XTPPopupControl.h
  • xtpPopupLocationCenter : XTPPopupControl.h
  • xtpPopupLocationNearTaskBar : XTPPopupControl.h
  • XTPPopupPaintTheme : XTPPopupControl.h
  • xtpPopupRight : XTPCommandBarsDefines.h
  • XTPPopupState : XTPPopupControl.h
  • xtpPopupStateClosed : XTPPopupControl.h
  • xtpPopupStateCollapsing : XTPPopupControl.h
  • xtpPopupStateExpanding : XTPPopupControl.h
  • xtpPopupStateShow : XTPPopupControl.h
  • xtpPopupThemeCustom : XTPPopupControl.h
  • xtpPopupThemeMSN : XTPPopupControl.h
  • xtpPopupThemeOffice2000 : XTPPopupControl.h
  • xtpPopupThemeOffice2003 : XTPPopupControl.h
  • xtpPopupThemeOffice2013 : XTPPopupControl.h
  • xtpPopupThemeOffice2016 : XTPPopupControl.h
  • xtpPopupThemeOfficeXP : XTPPopupControl.h
  • xtpPopupThemeResource : XTPPopupControl.h
  • xtpPopupUp : XTPCommandBarsDefines.h
  • XTPPROPERTYGRID_CLASSNAME : XTPPropertyGridDefines.h
  • xtpPropertyGridBorderClientEdge : XTPPropertyGridDefines.h
  • xtpPropertyGridBorderFlat : XTPPropertyGridDefines.h
  • xtpPropertyGridBorderNone : XTPPropertyGridDefines.h
  • xtpPropertyGridBorderStaticEdge : XTPPropertyGridDefines.h
  • XTPPropertyGridBorderStyle : XTPPropertyGridDefines.h
  • xtpPropertyGridButtonsDefault : XTPPropertyGridDefines.h
  • xtpPropertyGridButtonsOfficeXP : XTPPropertyGridDefines.h
  • xtpPropertyGridButtonsThemed : XTPPropertyGridDefines.h
  • xtpPropertyGridGridWindow : XTPPropertyGridPaintManager.h
  • xtpPropertyGridHelpWindow : XTPPropertyGridPaintManager.h
  • XTPPropertyGridHitCode : XTPPropertyGrid.h
  • xtpPropertyGridHitError : XTPPropertyGrid.h
  • xtpPropertyGridHitFirstVerb : XTPPropertyGrid.h
  • xtpPropertyGridHitHelpSplitter : XTPPropertyGrid.h
  • xtpPropertyGridHitVerbsSplitter : XTPPropertyGrid.h
  • XTPPropertyGridInplaceButtonsStyle : XTPPropertyGridDefines.h
  • XTPPropertyGridItemColorEditor : XTPPropertyGridItemColor.h
  • xtpPropertyGridItemColorExtendedDialog : XTPPropertyGridItemColor.h
  • xtpPropertyGridItemColorPopup : XTPPropertyGridItemColor.h
  • xtpPropertyGridItemColorStandardDialog : XTPPropertyGridItemColor.h
  • XTPPropertyGridItemFlags : XTPPropertyGridItem.h
  • xtpPropertyGridItemHasComboButton : XTPPropertyGridItem.h
  • xtpPropertyGridItemHasEdit : XTPPropertyGridItem.h
  • xtpPropertyGridItemHasExpandButton : XTPPropertyGridItem.h
  • XTPPropertyGridPaintTheme : XTPPropertyGridDefines.h
  • xtpPropertyGridSortAlphabetical : XTPPropertyGridDefines.h
  • xtpPropertyGridSortCategorized : XTPPropertyGridDefines.h
  • xtpPropertyGridSortNoSort : XTPPropertyGridDefines.h
  • XTPPropertyGridSortOrder : XTPPropertyGridDefines.h
  • xtpPropertyGridThemeCool : XTPPropertyGridDefines.h
  • xtpPropertyGridThemeDefault : XTPPropertyGridDefines.h
  • xtpPropertyGridThemeDelphi : XTPPropertyGridDefines.h
  • xtpPropertyGridThemeNativeWindows10 : XTPPropertyGridDefines.h
  • xtpPropertyGridThemeNativeWindows11 : XTPPropertyGridDefines.h
  • xtpPropertyGridThemeNativeWinXP : XTPPropertyGridDefines.h
  • xtpPropertyGridThemeOffice2003 : XTPPropertyGridDefines.h
  • xtpPropertyGridThemeOffice2013 : XTPPropertyGridDefines.h
  • xtpPropertyGridThemeOffice2016 : XTPPropertyGridDefines.h
  • xtpPropertyGridThemeOfficeXP : XTPPropertyGridDefines.h
  • xtpPropertyGridThemeResource : XTPPropertyGridDefines.h
  • xtpPropertyGridThemeSimple : XTPPropertyGridDefines.h
  • xtpPropertyGridThemeVisualStudio2005 : XTPPropertyGridDefines.h
  • xtpPropertyGridThemeVisualStudio2010 : XTPPropertyGridDefines.h
  • xtpPropertyGridThemeVisualStudio2012Dark : XTPPropertyGridDefines.h
  • xtpPropertyGridThemeVisualStudio2012Light : XTPPropertyGridDefines.h
  • xtpPropertyGridThemeVisualStudio2015 : XTPPropertyGridDefines.h
  • xtpPropertyGridThemeVisualStudio2017 : XTPPropertyGridDefines.h
  • xtpPropertyGridThemeVisualStudio2019 : XTPPropertyGridDefines.h
  • xtpPropertyGridThemeVisualStudio2022 : XTPPropertyGridDefines.h
  • XTPPropertyGridUI : XTPPropertyGrid.h
  • xtpPropertyGridUIInplaceButton : XTPPropertyGrid.h
  • xtpPropertyGridUIInplaceControl : XTPPropertyGrid.h
  • xtpPropertyGridUIInplaceEdit : XTPPropertyGrid.h
  • xtpPropertyGridUIParentNext : XTPPropertyGrid.h
  • xtpPropertyGridUIParentPrev : XTPPropertyGrid.h
  • xtpPropertyGridUIVerb : XTPPropertyGrid.h
  • xtpPropertyGridUIView : XTPPropertyGrid.h
  • xtpPropertyGridUIViewNext : XTPPropertyGrid.h
  • xtpPropertyGridUIViewPrev : XTPPropertyGrid.h
  • xtpPropertyGridVerbWindow : XTPPropertyGridPaintManager.h
  • XTPPropertyGridWindow : XTPPropertyGridPaintManager.h
  • XTPPropertyPageBorder : XTPPropertySheet.h
  • XTPPushButtonStyle : XTPButton.h
  • XTPReadStreamData() : XTPSystemHelpers.h
  • XTPReleaseReadStreamData() : XTPSystemHelpers.h
  • XTPResize : XTPResize.h
  • xtpResizeNoClipChildren : XTPResize.h
  • xtpResizeNoHorizontal : XTPResize.h
  • xtpResizeNoMinsize : XTPResize.h
  • xtpResizeNoSizeIcon : XTPResize.h
  • xtpResizeNoTransparentGroup : XTPResize.h
  • xtpResizeNoVertical : XTPResize.h
  • XTPResourceImages() : XTPResourceImage.h
  • XTPResourceManager() : XTPResourceManager.h
  • XTPRibbonBackstageKeyboardTipLevel : XTPRibbonBackstageView.h
  • XTPRibbonBackstageKeyboardTipResult : XTPRibbonBackstageView.h
  • xtpRibbonBackstageOffice2010Style : XTPRibbonBackstageView.h
  • xtpRibbonBackstageOffice2013Style : XTPRibbonBackstageView.h
  • xtpRibbonBackstageOffice2016Style : XTPRibbonBackstageView.h
  • XTPRibbonBackstageStyle : XTPRibbonBackstageView.h
  • xtpRibbonContextTabBlue : XTPRibbonMarkupTheme.h
  • xtpRibbonContextTabCyan : XTPRibbonMarkupTheme.h
  • xtpRibbonContextTabGreen : XTPRibbonMarkupTheme.h
  • xtpRibbonContextTabOrange : XTPRibbonMarkupTheme.h
  • xtpRibbonContextTabPurple : XTPRibbonMarkupTheme.h
  • xtpRibbonContextTabRed : XTPRibbonMarkupTheme.h
  • xtpRibbonContextTabYellow : XTPRibbonMarkupTheme.h
  • xtpRibbonFrameCaptionActive : XTPRibbonMarkupTheme.h
  • xtpRibbonFrameCaptionBackstageLeft : XTPRibbonMarkupTheme.h
  • xtpRibbonFrameCaptionBackstageRight : XTPRibbonMarkupTheme.h
  • xtpRibbonFrameCaptionInactive : XTPRibbonMarkupTheme.h
  • xtpRibbonFrameSystemButtonNormal : XTPRibbonMarkupTheme.h
  • xtpRibbonFrameSystemButtonPopuped : XTPRibbonMarkupTheme.h
  • xtpRibbonFrameSystemButtonSelected : XTPRibbonMarkupTheme.h
  • xtpRibbonGroupControlEntry : XTPRibbonMarkupTheme.h
  • xtpRibbonGroupControlEntryLeft : XTPRibbonMarkupTheme.h
  • xtpRibbonGroupControlEntryLeftRight : XTPRibbonMarkupTheme.h
  • xtpRibbonGroupControlEntryRight : XTPRibbonMarkupTheme.h
  • xtpRibbonGroupFullCaptionDontHide : XTPRibbonGroup.h
  • xtpRibbonGroupFullReduction : XTPRibbonGroup.h
  • xtpRibbonGroupRect : XTPRibbonMarkupTheme.h
  • xtpRibbonGroupRectBlue : XTPRibbonMarkupTheme.h
  • xtpRibbonGroupRectCyan : XTPRibbonMarkupTheme.h
  • xtpRibbonGroupRectGreen : XTPRibbonMarkupTheme.h
  • xtpRibbonGroupRectOrange : XTPRibbonMarkupTheme.h
  • xtpRibbonGroupRectPurple : XTPRibbonMarkupTheme.h
  • xtpRibbonGroupRectRed : XTPRibbonMarkupTheme.h
  • xtpRibbonGroupRectYellow : XTPRibbonMarkupTheme.h
  • xtpRibbonGroupReduceCaptionDontHide : XTPRibbonGroup.h
  • xtpRibbonGroupReductionDisabled : XTPRibbonGroup.h
  • XTPRibbonGroupReductionLevels : XTPRibbonGroup.h
  • xtpRibbonScrollButtonLeft : XTPRibbonMarkupTheme.h
  • xtpRibbonScrollButtonRight : XTPRibbonMarkupTheme.h
  • XTPRibbonTabContextColor : XTPRibbonTab.h
  • xtpRibbonTabContextColorBlue : XTPRibbonTab.h
  • xtpRibbonTabContextColorCyan : XTPRibbonTab.h
  • xtpRibbonTabContextColorGreen : XTPRibbonTab.h
  • xtpRibbonTabContextColorNone : XTPRibbonTab.h
  • xtpRibbonTabContextColorOrange : XTPRibbonTab.h
  • xtpRibbonTabContextColorPurple : XTPRibbonTab.h
  • xtpRibbonTabContextColorRed : XTPRibbonTab.h
  • xtpRibbonTabContextColorYellow : XTPRibbonTab.h
  • xtpRibbonTabHighlighted : XTPRibbonMarkupTheme.h
  • xtpRibbonTabSelected : XTPRibbonMarkupTheme.h
  • xtpRibbonTabSelectedBlue : XTPRibbonMarkupTheme.h
  • xtpRibbonTabSelectedCyan : XTPRibbonMarkupTheme.h
  • xtpRibbonTabSelectedFocused : XTPRibbonMarkupTheme.h
  • xtpRibbonTabSelectedFocusedBlue : XTPRibbonMarkupTheme.h
  • xtpRibbonTabSelectedFocusedCyan : XTPRibbonMarkupTheme.h
  • xtpRibbonTabSelectedFocusedGreen : XTPRibbonMarkupTheme.h
  • xtpRibbonTabSelectedFocusedOrange : XTPRibbonMarkupTheme.h
  • xtpRibbonTabSelectedFocusedPurple : XTPRibbonMarkupTheme.h
  • xtpRibbonTabSelectedFocusedRed : XTPRibbonMarkupTheme.h
  • xtpRibbonTabSelectedFocusedYellow : XTPRibbonMarkupTheme.h
  • xtpRibbonTabSelectedGreen : XTPRibbonMarkupTheme.h
  • xtpRibbonTabSelectedHighlighted : XTPRibbonMarkupTheme.h
  • xtpRibbonTabSelectedHighlightedBlue : XTPRibbonMarkupTheme.h
  • xtpRibbonTabSelectedHighlightedCyan : XTPRibbonMarkupTheme.h
  • xtpRibbonTabSelectedHighlightedGreen : XTPRibbonMarkupTheme.h
  • xtpRibbonTabSelectedHighlightedOrange : XTPRibbonMarkupTheme.h
  • xtpRibbonTabSelectedHighlightedPurple : XTPRibbonMarkupTheme.h
  • xtpRibbonTabSelectedHighlightedRed : XTPRibbonMarkupTheme.h
  • xtpRibbonTabSelectedHighlightedYellow : XTPRibbonMarkupTheme.h
  • xtpRibbonTabSelectedOrange : XTPRibbonMarkupTheme.h
  • xtpRibbonTabSelectedPurple : XTPRibbonMarkupTheme.h
  • xtpRibbonTabSelectedRed : XTPRibbonMarkupTheme.h
  • xtpRibbonTabSelectedYellow : XTPRibbonMarkupTheme.h
  • XTPRibbonThemePart : XTPRibbonMarkupTheme.h
  • xtpRibbonThemePartCount : XTPRibbonMarkupTheme.h
  • xtpRichEditWindowClassDefault : XTPSystemHelpers.h
  • XTPRichEditWindowClassVersion : XTPSystemHelpers.h
  • xtpRichEditWindowClassVersion10 : XTPSystemHelpers.h
  • xtpRichEditWindowClassVersion20 : XTPSystemHelpers.h
  • xtpRichEditWindowClassVersion30 : XTPSystemHelpers.h
  • xtpRichEditWindowClassVersion31 : XTPSystemHelpers.h
  • xtpRichEditWindowClassVersion40 : XTPSystemHelpers.h
  • xtpRichEditWindowClassVersion41 : XTPSystemHelpers.h
  • xtpRichEditWindowClassVersion50 : XTPSystemHelpers.h
  • xtpRichEditWindowClassVersion60 : XTPSystemHelpers.h
  • xtpRichEditWindowClassVersion70 : XTPSystemHelpers.h
  • xtpRowTypeBody : XTPGridDefines.h
  • xtpRowTypeFooter : XTPGridDefines.h
  • xtpRowTypeHeader : XTPGridDefines.h
  • xtpRowTypeInvalid : XTPGridDefines.h
  • XTPScaleBitmap() : XTPImageManager.h
  • XTPSchoolSupplies : XTPCommandBarsOffice2013Theme.h
  • XTPScrollBarStyle : XTPScrollBase.h
  • XTPScrollBarTheme : XTPScrollBase.h
  • xtpScrollBarThemeFlat : XTPScrollBase.h
  • xtpScrollBarThemeNativeWindows10 : XTPScrollBase.h
  • xtpScrollBarThemeNativeWindows11 : XTPScrollBase.h
  • xtpScrollBarThemeOffice2000 : XTPScrollBase.h
  • xtpScrollBarThemeOffice2003 : XTPScrollBase.h
  • xtpScrollBarThemeOffice2007Dark : XTPScrollBase.h
  • xtpScrollBarThemeOffice2007Light : XTPScrollBase.h
  • xtpScrollBarThemeOffice2010 : XTPScrollBase.h
  • xtpScrollBarThemeOffice2013 : XTPScrollBase.h
  • xtpScrollBarThemeOffice2016 : XTPScrollBase.h
  • xtpScrollBarThemeOfficeXP : XTPScrollBase.h
  • xtpScrollBarThemeResource : XTPScrollBase.h
  • xtpScrollBarThemeUltraFlat : XTPScrollBase.h
  • xtpScrollBarThemeVisualStudio2002 : XTPScrollBase.h
  • xtpScrollBarThemeVisualStudio2003 : XTPScrollBase.h
  • xtpScrollBarThemeVisualStudio2005 : XTPScrollBase.h
  • xtpScrollBarThemeVisualStudio2008 : XTPScrollBase.h
  • xtpScrollBarThemeVisualStudio2010 : XTPScrollBase.h
  • xtpScrollBarThemeVisualStudio2012Dark : XTPScrollBase.h
  • xtpScrollBarThemeVisualStudio2012Light : XTPScrollBase.h
  • xtpScrollBarThemeVisualStudio2015 : XTPScrollBase.h
  • xtpScrollBarThemeVisualStudio2017 : XTPScrollBase.h
  • xtpScrollBarThemeVisualStudio2019 : XTPScrollBase.h
  • xtpScrollBarThemeVisualStudio2022 : XTPScrollBase.h
  • xtpScrollBarThemeVisualStudio6 : XTPScrollBase.h
  • xtpScrollBarThemeWindowsClassic : XTPScrollBase.h
  • xtpScrollBarThemeWindowsDefault : XTPScrollBase.h
  • xtpScrollStyleDefault : XTPScrollBase.h
  • xtpScrollStyleFlat : XTPScrollBase.h
  • xtpScrollStyleNativeWindows10 : XTPScrollBase.h
  • xtpScrollStyleNativeWindows11 : XTPScrollBase.h
  • xtpScrollStyleOffice : XTPScrollBase.h
  • xtpScrollStyleOffice2007Dark : XTPScrollBase.h
  • xtpScrollStyleOffice2007Light : XTPScrollBase.h
  • xtpScrollStyleSlider : XTPScrollBase.h
  • xtpScrollStyleStandard : XTPScrollBase.h
  • xtpScrollStyleSystem : XTPScrollBase.h
  • xtpScrollStyleVisualStudio2012Dark : XTPScrollBase.h
  • xtpScrollStyleVisualStudio2012Light : XTPScrollBase.h
  • xtpScrollStyleVisualStudio2015 : XTPScrollBase.h
  • xtpScrollStyleVisualStudio2017 : XTPScrollBase.h
  • xtpScrollStyleVisualStudio2019 : XTPScrollBase.h
  • xtpScrollStyleVisualStudio2022 : XTPScrollBase.h
  • xtpSecondLevel : XTPRibbonBackstageView.h
  • xtpSelectTab : XTPRibbonBackstageView.h
  • XTPSetNativeWindows10StateColor() : XTPCommandBarsNativeWindows10Theme.h
  • XTPSetNativeWindows11StateColor() : XTPCommandBarsNativeWindows11Theme.h
  • XTPSetVS2017StateColor() : XTPCommandBarsVisualStudio2017Theme.h
  • XTPSetVS2019StateColor() : XTPCommandBarsVisualStudio2019Theme.h
  • XTPSetVS2022StateColor() : XTPCommandBarsVisualStudio2022Theme.h
  • XTPSetVSStateColor() : XTPCommandBarsVisualStudio2015Theme.h
  • xtpShadowOfficeAlpha : XTPHookManager.h
  • XTPShadowOptions : XTPHookManager.h
  • xtpShadowShowPopupControl : XTPHookManager.h
  • XTPShortcutBarPaintTheme : XTPShortcutBarPaintManager.h
  • xtpShortcutThemeNativeWindows10 : XTPShortcutBarPaintManager.h
  • xtpShortcutThemeNativeWindows11 : XTPShortcutBarPaintManager.h
  • xtpShortcutThemeNativeWinXP : XTPShortcutBarPaintManager.h
  • xtpShortcutThemeOffice2000 : XTPShortcutBarPaintManager.h
  • xtpShortcutThemeOffice2003 : XTPShortcutBarPaintManager.h
  • xtpShortcutThemeOffice2007 : XTPShortcutBarPaintManager.h
  • xtpShortcutThemeOffice2010 : XTPShortcutBarPaintManager.h
  • xtpShortcutThemeOffice2013 : XTPShortcutBarPaintManager.h
  • xtpShortcutThemeOffice2016 : XTPShortcutBarPaintManager.h
  • xtpShortcutThemeOfficeXP : XTPShortcutBarPaintManager.h
  • xtpShortcutThemeResource : XTPShortcutBarPaintManager.h
  • xtpShortcutThemeVisualStudio2015 : XTPShortcutBarPaintManager.h
  • xtpShortcutThemeVisualStudio2017 : XTPShortcutBarPaintManager.h
  • xtpShortcutThemeVisualStudio2019 : XTPShortcutBarPaintManager.h
  • xtpShortcutThemeVisualStudio2022 : XTPShortcutBarPaintManager.h
  • xtpShowSecondLevel : XTPRibbonBackstageView.h
  • XTPShutdown() : XTPApplication.h
  • xtpSkinApplyColors : XTPSkinManager.h
  • xtpSkinApplyCommandBarsFrame : XTPSkinManager.h
  • xtpSkinApplyDCs : XTPSkinManager.h
  • xtpSkinApplyFrame : XTPSkinManager.h
  • xtpSkinApplyMenus : XTPSkinManager.h
  • xtpSkinApplyMetrics : XTPSkinManager.h
  • XTPSkinApplyOptions : XTPSkinManager.h
  • XTPSkinManager() : XTPSkinManager.h
  • XTPSkinManagerProperty : XTPSkinManager.h
  • xtpSortDateTime : XTPSortClass.h
  • xtpSortDecimal : XTPSortClass.h
  • xtpSortInt : XTPSortClass.h
  • xtpSortString : XTPSortClass.h
  • XTPSortType : XTPSortClass.h
  • XTPSoundManager() : XTPSystemHelpers.h
  • XTPSoundManagerState : XTPSystemHelpers.h
  • xtpSoundMenuCommand : XTPSystemHelpers.h
  • xtpSoundMenuPopup : XTPSystemHelpers.h
  • xtpSoundNone : XTPSystemHelpers.h
  • XTPSpecialControl : XTPPaintManager.h
  • XTPSpecialKey : XTPCommandBarsDefines.h
  • XTPSpring : XTPCommandBarsOffice2013Theme.h
  • XTPStars : XTPCommandBarsOffice2013Theme.h
  • XTPStraws : XTPCommandBarsOffice2013Theme.h
  • XTPSyntaxEditCfgFlags : XTPSyntaxEditLexColorFileReader.h
  • XTPSyntaxEditCRLFStyle : XTPSyntaxEditDefines.h
  • XTPSyntaxEditDeletePos : XTPSyntaxEditDefines.h
  • XTPSyntaxEditEditAction : XTPSyntaxEditDefines.h
  • XTPSyntaxEditLexClass_OptChildren : XTPSyntaxEditLexClass.h
  • XTPSyntaxEditLexClass_OptParent : XTPSyntaxEditLexClass.h
  • XTPSyntaxEditLexConfig() : XTPSyntaxEditLexCfgFileReader.h
  • XTPSyntaxEditLexParseResult : XTPSyntaxEditLexParser.h
  • XTPSyntaxEditLexVariantType : XTPSyntaxEditLexClass.h
  • XTPSyntaxEditLineMarksRefreshType : XTPSyntaxEditLineMarksManager.h
  • XTPSyntaxEditOnCfgChangedEvent : XTPSyntaxEditDefines.h
  • XTPSyntaxEditOnParseEvent : XTPSyntaxEditDefines.h
  • XTPSyntaxEditUpdateViewHint : XTPSyntaxEditDefines.h
  • xtpSystemThemeAero : XTPColorManager.h
  • xtpSystemThemeAuto : XTPColorManager.h
  • xtpSystemThemeBlue : XTPColorManager.h
  • xtpSystemThemeDefault : XTPColorManager.h
  • xtpSystemThemeOlive : XTPColorManager.h
  • xtpSystemThemeRoyale : XTPColorManager.h
  • xtpSystemThemeSilver : XTPColorManager.h
  • xtpSystemThemeUnknown : XTPColorManager.h
  • XTPSystemVersion() : XTPSystemHelpers.h
  • xtpTabAppearanceExcel2003 : XTPTabManagerDefines.h
  • xtpTabAppearanceFlat : XTPTabManagerDefines.h
  • xtpTabAppearanceNativeWindows10 : XTPTabManagerDefines.h
  • xtpTabAppearanceNativeWindows11 : XTPTabManagerDefines.h
  • xtpTabAppearanceOffice2013 : XTPTabManagerDefines.h
  • xtpTabAppearanceOffice2016 : XTPTabManagerDefines.h
  • xtpTabAppearancePropertyPage : XTPTabManagerDefines.h
  • xtpTabAppearancePropertyPage2003 : XTPTabManagerDefines.h
  • xtpTabAppearancePropertyPage2007 : XTPTabManagerDefines.h
  • xtpTabAppearancePropertyPageAccess2007 : XTPTabManagerDefines.h
  • xtpTabAppearancePropertyPageFlat : XTPTabManagerDefines.h
  • xtpTabAppearancePropertyPageSelected : XTPTabManagerDefines.h
  • xtpTabAppearanceStateButtons : XTPTabManagerDefines.h
  • XTPTabAppearanceStyle : XTPTabManagerDefines.h
  • xtpTabAppearanceVisio : XTPTabManagerDefines.h
  • xtpTabAppearanceVisualStudio2003 : XTPTabManagerDefines.h
  • xtpTabAppearanceVisualStudio2005 : XTPTabManagerDefines.h
  • xtpTabAppearanceVisualStudio2010 : XTPTabManagerDefines.h
  • xtpTabAppearanceVisualStudio2012 : XTPTabManagerDefines.h
  • xtpTabAppearanceVisualStudio2015 : XTPTabManagerDefines.h
  • xtpTabAppearanceVisualStudio2017 : XTPTabManagerDefines.h
  • xtpTabAppearanceVisualStudio2019 : XTPTabManagerDefines.h
  • xtpTabAppearanceVisualStudio2022 : XTPTabManagerDefines.h
  • XTPTabClientFrame : XTPTabManagerDefines.h
  • xtpTabClientStickerBottom : XTPTabClientSticker.h
  • xtpTabClientStickerCenter : XTPTabClientSticker.h
  • xtpTabClientStickerLeft : XTPTabClientSticker.h
  • xtpTabClientStickerNone : XTPTabClientSticker.h
  • XTPTabClientStickerPart : XTPTabClientSticker.h
  • xtpTabClientStickerRight : XTPTabClientSticker.h
  • xtpTabClientStickerTop : XTPTabClientSticker.h
  • XTPTabCloudStyleManager() : XTPTagCloudCtrl.h
  • xtpTabColorAll : XTPTabManagerDefines.h
  • xtpTabColorBlue : XTPTabManagerDefines.h
  • xtpTabColorCyan : XTPTabManagerDefines.h
  • xtpTabColorDefault : XTPTabManagerDefines.h
  • xtpTabColorGreen : XTPTabManagerDefines.h
  • xtpTabColorMagenta : XTPTabManagerDefines.h
  • xtpTabColorNativeWindows10 : XTPTabManagerDefines.h
  • xtpTabColorNativeWindows11 : XTPTabManagerDefines.h
  • xtpTabColorOffice2003 : XTPTabManagerDefines.h
  • xtpTabColorOffice2007Access : XTPTabManagerDefines.h
  • xtpTabColorOffice2013 : XTPTabManagerDefines.h
  • xtpTabColorOffice2016 : XTPTabManagerDefines.h
  • xtpTabColorOrange : XTPTabManagerDefines.h
  • xtpTabColorPurple : XTPTabManagerDefines.h
  • xtpTabColorRed : XTPTabManagerDefines.h
  • xtpTabColorResource : XTPTabManagerDefines.h
  • XTPTabColorStyle : XTPTabManagerDefines.h
  • xtpTabColorVisualStudio2003 : XTPTabManagerDefines.h
  • xtpTabColorVisualStudio2005 : XTPTabManagerDefines.h
  • xtpTabColorVisualStudio2008 : XTPTabManagerDefines.h
  • xtpTabColorVisualStudio2010 : XTPTabManagerDefines.h
  • xtpTabColorVisualStudio2012 : XTPTabManagerDefines.h
  • xtpTabColorVisualStudio2012Dark : XTPTabManagerDefines.h
  • xtpTabColorVisualStudio2015 : XTPTabManagerDefines.h
  • xtpTabColorVisualStudio2017 : XTPTabManagerDefines.h
  • xtpTabColorVisualStudio2019 : XTPTabManagerDefines.h
  • xtpTabColorVisualStudio2022 : XTPTabManagerDefines.h
  • xtpTabColorWinNative : XTPTabManagerDefines.h
  • xtpTabColorYellow : XTPTabManagerDefines.h
  • xtpTabFrameBorder : XTPTabManagerDefines.h
  • xtpTabFrameNone : XTPTabManagerDefines.h
  • xtpTabFrameSingleLine : XTPTabManagerDefines.h
  • xtpTabLayoutAutoSize : XTPTabManagerDefines.h
  • xtpTabLayoutCompressed : XTPTabManagerDefines.h
  • xtpTabLayoutFixed : XTPTabManagerDefines.h
  • xtpTabLayoutMultiRow : XTPTabManagerDefines.h
  • xtpTabLayoutRotated : XTPTabManagerDefines.h
  • xtpTabLayoutSizeToFit : XTPTabManagerDefines.h
  • XTPTabLayoutStyle : XTPTabManagerDefines.h
  • XTPTabNavigateButton : XTPTabManagerDefines.h
  • xtpTabNavigateButtonActiveFiles : XTPTabManagerDefines.h
  • xtpTabNavigateButtonAlways : XTPTabManagerDefines.h
  • xtpTabNavigateButtonAutomatic : XTPTabManagerDefines.h
  • xtpTabNavigateButtonClose : XTPTabManagerDefines.h
  • XTPTabNavigateButtonFlags : XTPTabManagerDefines.h
  • xtpTabNavigateButtonLeft : XTPTabManagerDefines.h
  • xtpTabNavigateButtonNone : XTPTabManagerDefines.h
  • xtpTabNavigateButtonRight : XTPTabManagerDefines.h
  • XTPTabOneNoteColor : XTPTabManagerDefines.h
  • XTPTabPosition : XTPTabManagerDefines.h
  • xtpTabPositionBottom : XTPTabManagerDefines.h
  • xtpTabPositionLeft : XTPTabManagerDefines.h
  • xtpTabPositionRight : XTPTabManagerDefines.h
  • xtpTabPositionTop : XTPTabManagerDefines.h
  • xtpTabToolTipAlways : XTPTabManagerDefines.h
  • XTPTabToolTipBehaviour : XTPTabManagerDefines.h
  • xtpTabToolTipNever : XTPTabManagerDefines.h
  • xtpTabToolTipShrinkedOnly : XTPTabManagerDefines.h
  • XTPTabWorkspacePart : XTPTabManagerDefines.h
  • xtpTabWorkspacePartBack : XTPTabManagerDefines.h
  • xtpTabWorkspacePartBorder : XTPTabManagerDefines.h
  • xtpTabWorkspacePartHSplitter : XTPTabManagerDefines.h
  • xtpTabWorkspacePartVSplitter : XTPTabManagerDefines.h
  • xtpTabWorkspacePartWidth : XTPTabManagerDefines.h
  • xtpTagCloudAlpha : XTPTagCloudCtrl.h
  • xtpTagCloudNone : XTPTagCloudCtrl.h
  • xtpTagCloudNumeric : XTPTagCloudCtrl.h
  • XTPTagCloudSort : XTPTagCloudCtrl.h
  • xtpTaskItemAllowDrag : XTPTaskPanelDefines.h
  • xtpTaskItemAllowDragCopy : XTPTaskPanelDefines.h
  • xtpTaskItemAllowDragCopyOutsideControl : XTPTaskPanelDefines.h
  • xtpTaskItemAllowDragCopyWithinControl : XTPTaskPanelDefines.h
  • xtpTaskItemAllowDragCopyWithinGroup : XTPTaskPanelDefines.h
  • xtpTaskItemAllowDragDefault : XTPTaskPanelDefines.h
  • xtpTaskItemAllowDragMove : XTPTaskPanelDefines.h
  • xtpTaskItemAllowDragMoveOutsideControl : XTPTaskPanelDefines.h
  • xtpTaskItemAllowDragMoveWithinControl : XTPTaskPanelDefines.h
  • xtpTaskItemAllowDragMoveWithinGroup : XTPTaskPanelDefines.h
  • xtpTaskItemAllowDragNone : XTPTaskPanelDefines.h
  • xtpTaskItemAllowDragWithinControl : XTPTaskPanelDefines.h
  • xtpTaskItemAllowDragWithinGroup : XTPTaskPanelDefines.h
  • xtpTaskItemLayoutDefault : XTPTaskPanelDefines.h
  • xtpTaskItemLayoutImages : XTPTaskPanelDefines.h
  • xtpTaskItemLayoutImagesWithText : XTPTaskPanelDefines.h
  • xtpTaskItemLayoutImagesWithTextBelow : XTPTaskPanelDefines.h
  • xtpTaskItemTypeControl : XTPTaskPanelDefines.h
  • xtpTaskItemTypeGroup : XTPTaskPanelDefines.h
  • xtpTaskItemTypeLink : XTPTaskPanelDefines.h
  • xtpTaskItemTypeText : XTPTaskPanelDefines.h
  • XTPTaskPanelAnimation : XTPTaskPanelDefines.h
  • xtpTaskPanelAnimationNo : XTPTaskPanelDefines.h
  • xtpTaskPanelAnimationSystem : XTPTaskPanelDefines.h
  • xtpTaskPanelAnimationYes : XTPTaskPanelDefines.h
  • XTPTaskPanelBehaviour : XTPTaskPanelDefines.h
  • xtpTaskPanelBehaviourExplorer : XTPTaskPanelDefines.h
  • xtpTaskPanelBehaviourList : XTPTaskPanelDefines.h
  • xtpTaskPanelBehaviourToolbox : XTPTaskPanelDefines.h
  • XTPTaskPanelGripper : XTPTaskPanelPaintManager.h
  • xtpTaskPanelGripperBitmap : XTPTaskPanelPaintManager.h
  • xtpTaskPanelGripperNone : XTPTaskPanelPaintManager.h
  • xtpTaskPanelGripperPlain : XTPTaskPanelPaintManager.h
  • xtpTaskPanelGripperTriangle : XTPTaskPanelPaintManager.h
  • xtpTaskPanelHighlightDefault : XTPTaskPanelDefines.h
  • xtpTaskPanelHighlightImage : XTPTaskPanelDefines.h
  • xtpTaskPanelHighlightItem : XTPTaskPanelDefines.h
  • xtpTaskPanelHighlightNone : XTPTaskPanelDefines.h
  • xtpTaskPanelHighlightText : XTPTaskPanelDefines.h
  • XTPTaskPanelHotTrackStyle : XTPTaskPanelDefines.h
  • XTPTaskPanelItemAllowDrag : XTPTaskPanelDefines.h
  • XTPTaskPanelItemLayout : XTPTaskPanelDefines.h
  • XTPTaskPanelItemType : XTPTaskPanelDefines.h
  • XTPTaskPanelPaintTheme : XTPTaskPanelDefines.h
  • xtpTaskPanelThemeCustom : XTPTaskPanelDefines.h
  • xtpTaskPanelThemeListView : XTPTaskPanelDefines.h
  • xtpTaskPanelThemeListViewOffice2003 : XTPTaskPanelDefines.h
  • xtpTaskPanelThemeListViewOfficeXP : XTPTaskPanelDefines.h
  • xtpTaskPanelThemeNativeWindows10 : XTPTaskPanelDefines.h
  • xtpTaskPanelThemeNativeWindows11 : XTPTaskPanelDefines.h
  • xtpTaskPanelThemeNativeWinXP : XTPTaskPanelDefines.h
  • xtpTaskPanelThemeNativeWinXPPlain : XTPTaskPanelDefines.h
  • xtpTaskPanelThemeOffice2000 : XTPTaskPanelDefines.h
  • xtpTaskPanelThemeOffice2000Plain : XTPTaskPanelDefines.h
  • xtpTaskPanelThemeOffice2003 : XTPTaskPanelDefines.h
  • xtpTaskPanelThemeOffice2003Plain : XTPTaskPanelDefines.h
  • xtpTaskPanelThemeOffice2013 : XTPTaskPanelDefines.h
  • xtpTaskPanelThemeOffice2016 : XTPTaskPanelDefines.h
  • xtpTaskPanelThemeOfficeXPPlain : XTPTaskPanelDefines.h
  • xtpTaskPanelThemeResource : XTPTaskPanelDefines.h
  • xtpTaskPanelThemeShortcutBarOffice2003 : XTPTaskPanelDefines.h
  • xtpTaskPanelThemeVisualStudio2003 : XTPTaskPanelDefines.h
  • xtpTaskPanelThemeVisualStudio2005 : XTPTaskPanelDefines.h
  • xtpTaskPanelThemeVisualStudio2010 : XTPTaskPanelDefines.h
  • xtpTaskPanelThemeVisualStudio2012Dark : XTPTaskPanelDefines.h
  • xtpTaskPanelThemeVisualStudio2012Light : XTPTaskPanelDefines.h
  • xtpTaskPanelThemeVisualStudio2015 : XTPTaskPanelDefines.h
  • xtpTaskPanelThemeVisualStudio2017 : XTPTaskPanelDefines.h
  • xtpTaskPanelThemeVisualStudio2019 : XTPTaskPanelDefines.h
  • xtpTaskPanelThemeVisualStudio2022 : XTPTaskPanelDefines.h
  • xtpThemeCustom : XTPCommandBarsDefines.h
  • XTPThemeDLL() : XTPThemeDLL.h
  • xtpThemeNativeWindows10 : XTPCommandBarsDefines.h
  • xtpThemeNativeWindows11 : XTPCommandBarsDefines.h
  • xtpThemeNativeWinXP : XTPCommandBarsDefines.h
  • xtpThemeNone : XTPCommandBarsDefines.h
  • xtpThemeOffice2000 : XTPCommandBarsDefines.h
  • xtpThemeOffice2003 : XTPCommandBarsDefines.h
  • xtpThemeOffice2007System : XTPCommandBarsDefines.h
  • xtpThemeOffice2013 : XTPCommandBarsDefines.h
  • xtpThemeOffice2016 : XTPCommandBarsDefines.h
  • xtpThemeOfficeXP : XTPCommandBarsDefines.h
  • xtpThemeResource : XTPCommandBarsDefines.h
  • xtpThemeRibbon : XTPCommandBarsDefines.h
  • xtpThemeVisualStudio2005 : XTPCommandBarsDefines.h
  • xtpThemeVisualStudio2008 : XTPCommandBarsDefines.h
  • xtpThemeVisualStudio2010 : XTPCommandBarsDefines.h
  • xtpThemeVisualStudio2012 : XTPCommandBarsDefines.h
  • xtpThemeVisualStudio2012Dark : XTPCommandBarsDefines.h
  • xtpThemeVisualStudio2012Light : XTPCommandBarsDefines.h
  • xtpThemeVisualStudio2015 : XTPCommandBarsDefines.h
  • xtpThemeVisualStudio2017 : XTPCommandBarsDefines.h
  • xtpThemeVisualStudio2019 : XTPCommandBarsDefines.h
  • xtpThemeVisualStudio2022 : XTPCommandBarsDefines.h
  • xtpThemeVisualStudio6 : XTPCommandBarsDefines.h
  • xtpTipsOnTabPane : XTPRibbonBackstageView.h
  • XTPTlsAllocate() : XTPSystemHelpers.h
  • XTPTlsFree() : XTPSystemHelpers.h
  • XTPTlsGetValue() : XTPSystemHelpers.h
  • XTPTlsSetValue() : XTPSystemHelpers.h
  • XTPToolBarFlags : XTPCommandBarsDefines.h
  • xtpToolTipBalloon : XTPToolTipContext.h
  • xtpToolTipHTML : XTPToolTipContext.h
  • xtpToolTipLuna : XTPToolTipContext.h
  • xtpToolTipMarkup : XTPToolTipContext.h
  • xtpToolTipOffice : XTPToolTipContext.h
  • xtpToolTipOffice2013 : XTPToolTipContext.h
  • xtpToolTipOffice2016 : XTPToolTipContext.h
  • xtpToolTipResource : XTPToolTipContext.h
  • xtpToolTipRTF : XTPToolTipContext.h
  • xtpToolTipStandard : XTPToolTipContext.h
  • XTPToolTipStyle : XTPToolTipContext.h
  • xtpTrackCursorDrag : XTPTrackControl.h
  • xtpTrackCursorNothing : XTPTrackControl.h
  • xtpTrackCursorResize : XTPTrackControl.h
  • XTPTrackMouseCursorMode : XTPTrackControl.h
  • XTPTreeRings : XTPCommandBarsOffice2013Theme.h
  • xtpTSPID_Day : XTPCalendarDefines.h
  • xtpTSPID_Month : XTPCalendarDefines.h
  • xtpTSPID_Unknown : XTPCalendarDefines.h
  • xtpTSPID_Week : XTPCalendarDefines.h
  • xtpTSPID_WorkWeek : XTPCalendarDefines.h
  • XTPUnderWater : XTPCommandBarsOffice2013Theme.h
  • xtpUriFile : XTPSystemHelpers.h
  • xtpUriRes : XTPSystemHelpers.h
  • XTPUriType : XTPSystemHelpers.h
  • xtpUserHoldAltKey : XTPRibbonBackstageView.h
  • XTPVariantEqual() : XTPSystemHelpers.h
  • xtpVerticalButton : XTPControlCustom.h
  • xtpVerticalHide : XTPControlCustom.h
  • xtpVerticalShow : XTPControlCustom.h
  • xtpVirtRowHasChildren : XTPGridRecordItem.h
  • xtpVirtRowLastChild : XTPGridRecordItem.h
  • xtpVirtRowUnknown : XTPGridRecordItem.h
  • xtpWebBrowserInvalid : XTPWebBrowserCtrl.h
  • xtpWebBrowserLatest : XTPWebBrowserCtrl.h
  • XTPWebBrowserProvider : XTPWebBrowserCtrl.h
  • xtpWebBrowserShellExplorer : XTPWebBrowserCtrl.h
  • xtpWebBrowserWebView : XTPWebBrowserCtrl.h
  • XTPWindowClass : XTPSystemHelpers.h
  • xtpWindowClassRichEdit : XTPSystemHelpers.h
  • xtpWindowClassVersionAtLeast : XTPSystemHelpers.h
  • xtpWindowClassVersionExact : XTPSystemHelpers.h
  • xtpWindowClassVersionHighest : XTPSystemHelpers.h
  • XTPWindowClassVersionSelectionVerb : XTPSystemHelpers.h
  • XTPWM_DOCKINGPANE_NOTIFY : XTPDockingPaneDefines.h
  • XTPWM_POPUPCONTROL_NOTIFY : XTPPopupControl.h
  • XTPWM_SHORTCUTBAR_NOTIFY : XTPShortcutBar.h
  • XTPWM_TASKPANEL_NOTIFY : XTPTaskPanelDefines.h
  • xtpWorkspaceActivateNextToClosed : XTPTabClientWnd.h
  • XTPWorkspaceActivateTab : XTPTabClientWnd.h
  • xtpWorkspaceActivateTopmost : XTPTabClientWnd.h
  • XTPWorkspaceButtons : XTPTabClientWnd.h
  • xtpWorkspaceHideAll : XTPTabClientWnd.h
  • xtpWorkspaceHideArrows : XTPTabClientWnd.h
  • xtpWorkspaceHideArrowsAlways : XTPTabClientWnd.h
  • xtpWorkspaceHideClose : XTPTabClientWnd.h
  • xtpWorkspaceNewTabLeftMost : XTPTabClientWnd.h
  • xtpWorkspaceNewTabNextToActive : XTPTabClientWnd.h
  • XTPWorkspaceNewTabPosition : XTPTabClientWnd.h
  • xtpWorkspaceNewTabRightMost : XTPTabClientWnd.h
  • xtpWorkspaceShowActiveFiles : XTPTabClientWnd.h
  • xtpWorkspaceShowCloseSelectedTab : XTPTabClientWnd.h
  • xtpWorkspaceShowCloseTab : XTPTabClientWnd.h
  • xtpZLibBestCompression : XTPGraphicBitmapPng.h
  • xtpZLibBestSpeed : XTPGraphicBitmapPng.h
  • XTPZlibCompressionLevel : XTPGraphicBitmapPng.h
  • xtpZLibDefaultCompression : XTPGraphicBitmapPng.h
  • xtpZLibNoCompression : XTPGraphicBitmapPng.h


Toolkit Pro: File Members

Here is a list of all documented file members with links to the documentation:

- z -

  • ZLibCompress() : XTPGraphicBitmapPng.h
  • ZLibCompressBound() : XTPGraphicBitmapPng.h
  • ZLibUncompress() : XTPGraphicBitmapPng.h


Toolkit Pro: File Members

Here is a list of all documented functions with links to the documentation:

- d -

  • DDX_CBSyntaxColor() : XTPSyntaxEditColorComboBox.h
  • DDX_XTPColorPicker() : XTPColorPicker.h
  • DDX_XTPOleDateTime() : XTPMaskEdit.h

- g -

  • GetMSO2003Color() : XTPColorManager.h
  • GetThemePartForEvent() : XTPCalendarThemeOffice2007.h
  • GetXtremeColor() : XTPColorManager.h

- i -

  • IsAnimateType() : XTPCommandBarsDefines.h
  • IsCaptionStyle() : XTPCommandBarsDefines.h
  • IsDockingPosition() : XTPCommandBarsDefines.h
  • IsPopupControlType() : XTPCommandBarsDefines.h
  • IsVerticalPosition() : XTPCommandBarsDefines.h

- p -

  • PX_Blob() : XTPPropExchange.h
  • PX_Bool() : XTPPropExchange.h
  • PX_Bstr() : XTPPropExchange.h
  • PX_Byte() : XTPPropExchange.h
  • PX_Color() : XTPCalendarViewPart.h
  • PX_DateTime() : XTPPropExchange.h
  • PX_Double() : XTPPropExchange.h
  • PX_DPI_Point() : XTPPropExchange.h
  • PX_DPI_Rect() : XTPPropExchange.h
  • PX_DPI_Size() : XTPPropExchange.h
  • PX_DPI_X_Int() : XTPPropExchange.h
  • PX_DPI_X_Long() : XTPPropExchange.h
  • PX_DPI_Y_Int() : XTPPropExchange.h
  • PX_DPI_Y_Long() : XTPPropExchange.h
  • PX_DWord() : XTPPropExchange.h
  • PX_Enum() : XTPPropExchange.h
  • PX_Float() : XTPPropExchange.h
  • PX_Font() : XTPCalendarViewPart.h
  • PX_GrColor() : XTPCalendarViewPart.h
  • PX_Int() : XTPPropExchange.h
  • PX_Long() : XTPPropExchange.h
  • PX_Object() : XTPPropExchange.h
  • PX_Point() : XTPPropExchange.h
  • PX_Rect() : XTPPropExchange.h
  • PX_RuntimeClass() : XTPPropExchange.h
  • PX_Serialize() : XTPPropExchange.h
  • PX_Short() : XTPPropExchange.h
  • PX_Size() : XTPPropExchange.h
  • PX_String() : XTPPropExchange.h
  • PX_UI8() : XTPPropExchange.h
  • PX_ULong() : XTPPropExchange.h
  • PX_UShort() : XTPPropExchange.h
  • PX_Variant() : XTPPropExchange.h

- r -

  • RefreshXtremeColors() : XTPColorManager.h

- x -

  • XTP_DEFINE_SMART_PTR_INTERNAL() : XTPCalendarOptions.h, XTPCalendarRecurrencePattern.h, XTPCalendarView.h, XTPSyntaxEditLexClassSubObjT.h
  • XTPAccessExclusive() : XTPSynchro.h
  • XTPAccessShared() : XTPSynchro.h
  • XTPAuxData() : XTPGlobal.h
  • xtpCalendarDateTime_max() : XTPCalendarUtils.h
  • xtpCalendarDateTime_min() : XTPCalendarUtils.h
  • XTPCalendarMsgNotifier() : XTPCalendarMsgNotifier.h
  • XTPChangeWindowFont() : XTPFunctions.h
  • XTPChildWindowFromPoint() : XTPFunctions.h
  • XTPColorManager() : XTPColorManager.h
  • XTPCompare() : XTPCalendarUtils.h
  • XTPContextMenu() : XTPFunctions.h
  • XTPCreateFileStream() : XTPSystemHelpers.h
  • XTPCreateReadOnlyFileStream() : XTPSystemHelpers.h
  • XTPCreateReadOnlyMemoryStream() : XTPSystemHelpers.h
  • XTPCreateReadOnlyResourceStream() : XTPSystemHelpers.h
  • XTPCreateReadOnlyStreamOnUri() : XTPSystemHelpers.h
  • XTPCreateView() : XTPFunctions.h
  • XTPDebugBreak() : XTPMacros.h
  • XTPDrawEmbossed() : XTPFunctions.h
  • XTPDrawShadedRect() : XTPFunctions.h
  • XTPDynamicDownCastRemote() : XTPSystemHelpers.h
  • XTPFindResourceType() : XTPResourceManager.h
  • XTPFontManager() : XTPFontManager.h
  • XTPFrameShadowManager() : XTPFrameShadowManager.h
  • XTPGetAccentColor() : XTPColorManager.h
  • XTPGetApplication() : XTPApplication.h
  • XTPGetColorizationColor() : XTPColorManager.h
  • XTPGetDefaultResourceTypeFromPath() : XTPResourceManager.h
  • XTPGetInstanceHandle() : XTPResourceManager.h
  • XTPHeapSetCompatibilityInformation() : XTPCustomHeap.h
  • XTPHeapSetLowFragmentation() : XTPCustomHeap.h
  • XTPHookManager() : XTPHookManager.h
  • XTPImageManager() : XTPImageManager.h
  • XTPIniColor() : XTPResourceImage.h
  • XTPIniInt() : XTPResourceImage.h
  • XTPIniRect() : XTPResourceImage.h
  • XTPIniSize() : XTPResourceImage.h
  • XTPIniString() : XTPResourceImage.h
  • XTPInitialize() : XTPApplication.h
  • XTPIsDerivedFromRemote() : XTPSystemHelpers.h
  • XTPIsKindOfRemote() : XTPSystemHelpers.h
  • XTPLoadFileText() : XTPSystemHelpers.h
  • XTPLoadImage() : XTPResourceImage.h
  • XTPLoadText() : XTPSystemHelpers.h
  • XTPLoadUnicodeText() : XTPSystemHelpers.h
  • XTPLoadWindowClass() : XTPSystemHelpers.h
  • XTPMarkupAssignHandle() : XTPMarkupRender.h
  • XTPMarkupCreateContext() : XTPMarkupRender.h
  • XTPMarkupElementContext() : XTPMarkupRender.h
  • XTPMarkupMeasureElement() : XTPMarkupRender.h
  • XTPMarkupParseText() : XTPMarkupRender.h
  • XTPMarkupRelayMessage() : XTPMarkupRender.h
  • XTPMarkupReleaseContext() : XTPMarkupRender.h
  • XTPMarkupReleaseElement() : XTPMarkupRender.h
  • XTPMarkupRenderElement() : XTPMarkupRender.h
  • XTPMarkupSetDefaultFont() : XTPMarkupRender.h
  • XTPMultiMonitor() : XTPSystemHelpers.h
  • XTPOpenGLListPool() : XTPOpenGLListPool.h
  • XTPPaintManager() : XTPPaintManager.h
  • XTPParseDouble() : XTPSystemHelpers.h
  • XTPParseUri() : XTPSystemHelpers.h
  • XTPPathExists() : XTPFunctions.h
  • XTPReadStreamData() : XTPSystemHelpers.h
  • XTPReleaseReadStreamData() : XTPSystemHelpers.h
  • XTPResourceImages() : XTPResourceImage.h
  • XTPResourceManager() : XTPResourceManager.h
  • XTPScaleBitmap() : XTPImageManager.h
  • XTPSetNativeWindows10StateColor() : XTPCommandBarsNativeWindows10Theme.h
  • XTPSetNativeWindows11StateColor() : XTPCommandBarsNativeWindows11Theme.h
  • XTPSetVS2017StateColor() : XTPCommandBarsVisualStudio2017Theme.h
  • XTPSetVS2019StateColor() : XTPCommandBarsVisualStudio2019Theme.h
  • XTPSetVS2022StateColor() : XTPCommandBarsVisualStudio2022Theme.h
  • XTPSetVSStateColor() : XTPCommandBarsVisualStudio2015Theme.h
  • XTPShutdown() : XTPApplication.h
  • XTPSkinManager() : XTPSkinManager.h
  • XTPSoundManager() : XTPSystemHelpers.h
  • XTPSyntaxEditLexConfig() : XTPSyntaxEditLexCfgFileReader.h
  • XTPSystemVersion() : XTPSystemHelpers.h
  • XTPTabCloudStyleManager() : XTPTagCloudCtrl.h
  • XTPThemeDLL() : XTPThemeDLL.h
  • XTPTlsAllocate() : XTPSystemHelpers.h
  • XTPTlsFree() : XTPSystemHelpers.h
  • XTPTlsGetValue() : XTPSystemHelpers.h
  • XTPTlsSetValue() : XTPSystemHelpers.h
  • XTPVariantEqual() : XTPSystemHelpers.h

- z -

  • ZLibCompress() : XTPGraphicBitmapPng.h
  • ZLibCompressBound() : XTPGraphicBitmapPng.h
  • ZLibUncompress() : XTPGraphicBitmapPng.h


Toolkit Pro: File Members

Here is a list of all documented variables with links to the documentation:

- b -

  • BES_XTP_BROWSE : XTPBrowseEdit.h
  • BES_XTP_CHOOSEDIR : XTPBrowseEdit.h
  • BES_XTP_CHOOSEFILE : XTPBrowseEdit.h
  • BES_XTP_POPUPMENU : XTPBrowseEdit.h


Toolkit Pro: File Members

Here is a list of all documented variables with links to the documentation:

- c -

  • CBN_XTP_EXECUTE : XTPCommandBarsDefines.h
  • CPWS_EX_CLOSEBUTTON : XTPCaption.h
  • CPWS_EX_GROOVE_EDGE : XTPCaption.h
  • CPWS_EX_RAISED_EDGE : XTPCaption.h
  • cszCalendarMarkupPrm_Body : XTPCalendarDefines.h
  • cszCalendarMarkupPrm_EndTime : XTPCalendarDefines.h
  • cszCalendarMarkupPrm_Location : XTPCalendarDefines.h
  • cszCalendarMarkupPrm_Subject : XTPCalendarDefines.h
  • cszEventCustProp_CategoryIDs : XTPCalendarDefines.h
  • cszEventCustProp_IconsIDs : XTPCalendarDefines.h
  • cszEventCustProp_MarkupTemplate : XTPCalendarDefines.h
  • cszEventCustProp_NextReminderTime_Snoozed : XTPCalendarDefines.h
  • cszProcess_RecurrencePatternID : XTPCalendarData.h
  • cszProcess_RecurrenceState : XTPCalendarData.h


Toolkit Pro: File Members

Here is a list of all documented variables with links to the documentation:

- f -

  • FTS_XTP_BOTTOM : XTPExcelTabCtrl.h
  • FTS_XTP_DEFAULT : XTPExcelTabCtrl.h
  • FTS_XTP_HASARROWS : XTPExcelTabCtrl.h
  • FTS_XTP_HASHOMEEND : XTPExcelTabCtrl.h
  • FTS_XTP_HSCROLL : XTPExcelTabCtrl.h
  • FTS_XTP_MASK : XTPExcelTabCtrl.h
  • FTS_XTP_SQUARETABS : XTPExcelTabCtrl.h
  • FTS_XTP_TOOLTIPS : XTPExcelTabCtrl.h


Toolkit Pro: File Members

Here is a list of all documented variables with links to the documentation:

- h -

  • HDR_XTP_HOTTRACKING : XTPHeaderCtrlTheme.h
  • HDR_XTP_SORTARROW : XTPHeaderCtrlTheme.h
  • HDR_XTP_WINDEF : XTPHeaderCtrlTheme.h


Toolkit Pro: File Members

Here is a list of all documented variables with links to the documentation:

- l -

  • LBS_XTP_BROWSE : XTPEditListBox.h
  • LBS_XTP_BROWSE_ONLY : XTPEditListBox.h
  • LBS_XTP_CHOOSEDIR : XTPEditListBox.h
  • LBS_XTP_CHOOSEFILE : XTPEditListBox.h
  • LBS_XTP_DEFAULT : XTPEditListBox.h
  • LBS_XTP_HIDE_UP_DOWN : XTPEditListBox.h
  • LBS_XTP_NOTOOLBAR : XTPEditListBox.h
  • LBS_XTP_ONLY_UP_DOWN : XTPEditListBox.h


Toolkit Pro: File Members

Here is a list of all documented variables with links to the documentation:

- m -

  • m_arWeekDayNamesLong : XTPCalendarThemeOffice2007.h
  • m_arWeekDayNamesShort : XTPCalendarThemeOffice2007.h


Toolkit Pro: File Members

Here is a list of all documented variables with links to the documentation:

- p -

  • pPoint : XTPCalendarThemeOffice2007.h


Toolkit Pro: File Members

Here is a list of all documented variables with links to the documentation:

- t -

  • TVIS_FOCUSED : XTPTreeBase.h
  • TWS_XTP_ALPHASHADOW : XTPTipWindow.h
  • TWS_XTP_DROPSHADOW : XTPTipWindow.h
  • TWS_XTP_THICKBORDER : XTPTipWindow.h


Toolkit Pro: File Members

Here is a list of all documented variables with links to the documentation:

- w -

  • WM_XTP_AFTERCREATECONTROL : XTPCommandBarsDefines.h
  • WM_XTP_BEFORECREATECONTROL : XTPCommandBarsDefines.h
  • WM_XTP_CALENDAR_BASE : XTPCalendarDefines.h
  • WM_XTP_COMMANDBARKEYDOWN : XTPCommandBarsDefines.h
  • WM_XTP_COMMANDBARS_BASE : XTPCommandBarsDefines.h
  • WM_XTP_COMMON_BASE : XTPNotifyConnection.h
  • WM_XTP_CONTROLRBUTTONUP : XTPCommandBarsDefines.h
  • WM_XTP_CONTROLSELECTED : XTPCommandBarsDefines.h
  • WM_XTP_CREATECOMMANDBAR : XTPCommandBarsDefines.h
  • WM_XTP_DOCKINGPANE_BASE : XTPDockingPaneDefines.h
  • WM_XTP_DRAGCONTROLCHANGED : XTPCommandBarsDefines.h
  • WM_XTP_GETTABCOLOR : XTPTabManager.h
  • WM_XTP_GETTABICON : XTPCommandBarsDefines.h
  • WM_XTP_GETWINDOWTEXT : XTPTabClientWnd.h
  • WM_XTP_GETWINDOWTOOLTIP : XTPTabClientWnd.h
  • WM_XTP_INITCOMMANDSPOPUP : XTPCommandBarsDefines.h
  • WM_XTP_INITMENU : XTPCommandBarsDefines.h
  • WM_XTP_MESSAGEBARCLOSED : XTPCommandBarsDefines.h
  • WM_XTP_NEWTABITEM : XTPTabClientWnd.h
  • WM_XTP_PRETRANSLATEMOUSEMSG : XTPTabClientWnd.h
  • WM_XTP_PRETRANSLATEMOUSEMSG_EX : XTPTabClientWnd.h
  • WM_XTP_SETACTIVEWORKSPACE : XTPTabClientWnd.h
  • WM_XTP_SETBAKSTAGEBUTTONKEYTIP : XTPCommandBarsDefines.h
  • WM_XTP_SETBAKSTAGEBUTTONKEYTIPDRAWFLAG : XTPCommandBarsDefines.h
  • WM_XTP_TABTODOCKPANE : XTPTabClientWnd.h
  • WM_XTP_TOOLBARCONTEXTMENU : XTPCommandBarsDefines.h
  • WM_XTP_TOOLBARVISIBLECHANGED : XTPCommandBarsDefines.h
  • WM_XTP_UNINITCOMMANDSPOPUP : XTPCommandBarsDefines.h


Toolkit Pro: File Members

Here is a list of all documented variables with links to the documentation:

- x -

  • XPCOLOR_3DFACE : XTPColorManager.h
  • XPCOLOR_3DSHADOW : XTPColorManager.h
  • XPCOLOR_BASE : XTPColorManager.h
  • XPCOLOR_CHECKED_TEXT : XTPColorManager.h
  • XPCOLOR_DISABLED : XTPColorManager.h
  • XPCOLOR_EDITCTRLBORDER : XTPColorManager.h
  • XPCOLOR_FLOATBAR_BORDER : XTPColorManager.h
  • XPCOLOR_FRAME : XTPColorManager.h
  • XPCOLOR_GRAYTEXT : XTPColorManager.h
  • XPCOLOR_HIGHLIGHT : XTPColorManager.h
  • XPCOLOR_HIGHLIGHT_BORDER : XTPColorManager.h
  • XPCOLOR_HIGHLIGHT_CHECKED : XTPColorManager.h
  • XPCOLOR_HIGHLIGHT_CHECKED_BORDER : XTPColorManager.h
  • XPCOLOR_HIGHLIGHT_DISABLED_BORDER : XTPColorManager.h
  • XPCOLOR_HIGHLIGHT_PUSHED : XTPColorManager.h
  • XPCOLOR_HIGHLIGHT_PUSHED_BORDER : XTPColorManager.h
  • XPCOLOR_HIGHLIGHT_TEXT : XTPColorManager.h
  • XPCOLOR_ICONSHADDOW : XTPColorManager.h
  • XPCOLOR_LABEL : XTPColorManager.h
  • XPCOLOR_LAST : XTPColorManager.h
  • XPCOLOR_MENUBAR_BORDER : XTPColorManager.h
  • XPCOLOR_MENUBAR_EXPANDED : XTPColorManager.h
  • XPCOLOR_MENUBAR_FACE : XTPColorManager.h
  • XPCOLOR_MENUBAR_GRAYTEXT : XTPColorManager.h
  • XPCOLOR_MENUBAR_TEXT : XTPColorManager.h
  • XPCOLOR_PUSHED_TEXT : XTPColorManager.h
  • XPCOLOR_SEPARATOR : XTPColorManager.h
  • XPCOLOR_SHADOW_FACTOR : XTPColorManager.h
  • XPCOLOR_SPLITTER_FACE : XTPColorManager.h
  • XPCOLOR_STATICFRAME : XTPColorManager.h
  • XPCOLOR_TAB_INACTIVE_BACK : XTPColorManager.h
  • XPCOLOR_TAB_INACTIVE_TEXT : XTPColorManager.h
  • XPCOLOR_TOOLBAR_FACE : XTPColorManager.h
  • XPCOLOR_TOOLBAR_GRAYTEXT : XTPColorManager.h
  • XPCOLOR_TOOLBAR_GRIPPER : XTPColorManager.h
  • XPCOLOR_TOOLBAR_TEXT : XTPColorManager.h
  • XTP_ACTION_CANCEL : XTPTaskPanelDefines.h
  • XTP_ACTION_NOCLOSE : XTPDockingPaneDefines.h
  • XTP_CALENDAR_DLGRESULT_REMOVE_RECURRENCE : XTPCalendarEventRecurrenceDlg.h
  • XTP_DATEPICKER_TIMER_INTERVAL : XTPDatePickerControl.h
  • XTP_DATEPICKER_TIMERID : XTPDatePickerControl.h
  • XTP_DPN_ACTION : XTPDockingPaneDefines.h
  • XTP_DPN_CLOSEPANE : XTPDockingPaneDefines.h
  • XTP_DPN_CONTEXTMENU : XTPDockingPaneDefines.h
  • XTP_DPN_RCLICK : XTPDockingPaneDefines.h
  • XTP_DPN_SHOWWINDOW : XTPDockingPaneDefines.h
  • XTP_EDIT_ROWNODE_COLLAPSED : XTPSyntaxEditStruct.h
  • XTP_EDIT_ROWNODE_ENDMARK : XTPSyntaxEditStruct.h
  • XTP_EDIT_ROWNODE_EXPANDED : XTPSyntaxEditStruct.h
  • XTP_EDIT_ROWNODE_NODEDOWN : XTPSyntaxEditStruct.h
  • XTP_EDIT_ROWNODE_NODEUP : XTPSyntaxEditStruct.h
  • XTP_EDIT_ROWNODE_NOTHING : XTPSyntaxEditStruct.h
  • XTP_FGN_ACTIVEPAGECHANGED : XTPFlowGraphMessages.h
  • XTP_FGN_CONNECTIONCHANGED : XTPFlowGraphMessages.h
  • XTP_FGN_CONNECTIONCHANGING : XTPFlowGraphMessages.h
  • XTP_FGN_ENDLABELEDIT : XTPFlowGraphMessages.h
  • XTP_FGN_NODELOCATIONCHANGED : XTPFlowGraphMessages.h
  • XTP_FGN_PAGESCROLLOFFSETCHANGED : XTPFlowGraphMessages.h
  • XTP_FGN_PAGEZOOMLEVELCHANGED : XTPFlowGraphMessages.h
  • XTP_FGN_SELECTIONCHANGED : XTPFlowGraphMessages.h
  • XTP_FN_BUDDYBUTTONCLICK : XTPControlEdit.h
  • XTP_FN_GETFORMAT : XTPControlComboBoxExt.h
  • XTP_FN_SETFORMAT : XTPControlComboBoxExt.h
  • XTP_FN_SPINDOWN : XTPControlEdit.h
  • XTP_FN_SPINUP : XTPControlEdit.h
  • XTP_GN_PREVIEWAPPLY : XTPControlGallery.h
  • XTP_GN_PREVIEWCANCEL : XTPControlGallery.h
  • XTP_GN_PREVIEWCHANGE : XTPControlGallery.h
  • XTP_GN_PREVIEWSTART : XTPControlGallery.h
  • XTP_GN_SELCHANGE : XTPControlGallery.h
  • XTP_GN_STARTDRAG : XTPControlGallery.h
  • XTP_GRID_COLOR_DEFAULT : XTPGridDefines.h
  • XTP_GRID_NOICON : XTPGridDefines.h
  • XTP_ID_CALENDAR_CONTROL : XTPCalendarControlView.h
  • XTP_ID_FLOWGRAPHUNDO_ADDCONNECTION : XTPFlowGraphUndoManager.h
  • XTP_ID_FLOWGRAPHUNDO_ADDCONNECTIONPOINT : XTPFlowGraphUndoManager.h
  • XTP_ID_FLOWGRAPHUNDO_ADDNODE : XTPFlowGraphUndoManager.h
  • XTP_ID_FLOWGRAPHUNDO_DELETECONNECTION : XTPFlowGraphUndoManager.h
  • XTP_ID_FLOWGRAPHUNDO_DELETECONNECTIONPOINT : XTPFlowGraphUndoManager.h
  • XTP_ID_FLOWGRAPHUNDO_DELETENODE : XTPFlowGraphUndoManager.h
  • XTP_ID_FLOWGRAPHUNDO_GROUP : XTPFlowGraphUndoManager.h
  • XTP_ID_FLOWGRAPHUNDO_SETCONNECTIONPOSITION : XTPFlowGraphUndoManager.h
  • XTP_ID_FLOWGRAPHUNDO_SETNODECAPTION : XTPFlowGraphUndoManager.h
  • XTP_ID_FLOWGRAPHUNDO_SETNODEPOSITION : XTPFlowGraphUndoManager.h
  • XTP_ID_FLOWGRAPHUNDO_SETNODESIZE : XTPFlowGraphUndoManager.h
  • XTP_ID_GRID_COMBOBUTTON : XTPGridInplaceControls.h
  • XTP_ID_GRID_CONTROL : XTPGridView.h
  • XTP_ID_GRID_EXPANDBUTTON : XTPGridInplaceControls.h
  • XTP_ID_GRID_SPINBUTTON : XTPGridInplaceControls.h
  • XTP_ID_PROPERTYGRID_COMBOBUTTON : XTPPropertyGridInplaceButton.h
  • XTP_ID_PROPERTYGRID_EXPANDBUTTON : XTPPropertyGridInplaceButton.h
  • XTP_ID_TRACKUNDO_ADDBLOCK : XTPTrackUndoManager.h
  • XTP_ID_TRACKUNDO_ADDMARKER : XTPTrackUndoManager.h
  • XTP_ID_TRACKUNDO_DELETEBLOCK : XTPTrackUndoManager.h
  • XTP_ID_TRACKUNDO_DELETEMARKER : XTPTrackUndoManager.h
  • XTP_ID_TRACKUNDO_GROUP : XTPTrackUndoManager.h
  • XTP_ID_TRACKUNDO_SETBLOCKPOSITION : XTPTrackUndoManager.h
  • XTP_ID_TRACKUNDO_SETMARKERPOSITION : XTPTrackUndoManager.h
  • XTP_LBN_POPUP : XTPControlListBox.h
  • XTP_LBN_SELCHANGE : XTPControlListBox.h
  • XTP_MAX_WEEKS : XTPDatePickerItemMonth.h
  • XTP_NC_CALENDAR_BEFORE_DRAW_DAYVIEWCELL : XTPCalendarNotifications.h
  • XTP_NC_CALENDAR_BEFORE_DRAW_THEMEOBJECT : XTPCalendarNotifications.h
  • XTP_NC_CALENDAR_BEFORE_EVENT_EDIT_OPERATION : XTPCalendarNotifications.h
  • XTP_NC_CALENDAR_CAPTIONBARPART_BEFORE_CLICK : XTPCalendarNotifications.h
  • XTP_NC_CALENDAR_CAPTIONBARPART_CLICK : XTPCalendarNotifications.h
  • XTP_NC_CALENDAR_DoCreate_Event : XTPCalendarNotifications.h
  • XTP_NC_CALENDAR_DoCreate_RPattern : XTPCalendarNotifications.h
  • XTP_NC_CALENDAR_DoDelete_Event : XTPCalendarNotifications.h
  • XTP_NC_CALENDAR_DoDelete_RPattern : XTPCalendarNotifications.h
  • XTP_NC_CALENDAR_DoGetAllEvents_raw : XTPCalendarNotifications.h
  • XTP_NC_CALENDAR_DoGetUpcomingEvents : XTPCalendarNotifications.h
  • XTP_NC_CALENDAR_DoRead_Event : XTPCalendarNotifications.h
  • XTP_NC_CALENDAR_DoRead_RPattern : XTPCalendarNotifications.h
  • XTP_NC_CALENDAR_DoRemoveAllEvents : XTPCalendarNotifications.h
  • XTP_NC_CALENDAR_DoRetrieveDayEvents : XTPCalendarNotifications.h
  • XTP_NC_CALENDAR_DoUpdate_Event : XTPCalendarNotifications.h
  • XTP_NC_CALENDAR_DoUpdate_RPattern : XTPCalendarNotifications.h
  • XTP_NC_CALENDAR_GETGROPVIEWCAPTION : XTPCalendarNotifications.h
  • XTP_NC_CALENDAR_GETITEMTEXT : XTPCalendarNotifications.h
  • XTP_NC_CALENDAR_IS_EVENT_EDIT_OPERATION_DISABLED : XTPCalendarNotifications.h
  • XTP_NC_CALENDAR_ON_REMINDERS : XTPCalendarNotifications.h
  • XTP_NC_CALENDAR_PREPOPULATE : XTPCalendarNotifications.h
  • XTP_NC_CALENDAR_PREPOPULATE_DAY : XTPCalendarNotifications.h
  • XTP_NC_CALENDAR_RESOURCES_WHERE_CHANGED : XTPCalendarNotifications.h
  • XTP_NC_CALENDAR_SELECTION_CHANGED : XTPCalendarNotifications.h
  • XTP_NC_CALENDAR_THEME_CHANGED : XTPCalendarNotifications.h
  • XTP_NC_CALENDAR_USERACTION : XTPCalendarNotifications.h
  • XTP_NC_CALENDARCONTEXTMENU : XTPCalendarNotifications.h
  • XTP_NC_CALENDARDATAPROVIDERWASCHANGED : XTPCalendarNotifications.h
  • XTP_NC_CALENDAREVENTWASADDED : XTPCalendarNotifications.h
  • XTP_NC_CALENDAREVENTWASCHANGED : XTPCalendarNotifications.h
  • XTP_NC_CALENDAREVENTWASDELETED : XTPCalendarNotifications.h
  • XTP_NC_CALENDARKEYDOWN : XTPCalendarNotifications.h
  • XTP_NC_CALENDARLBUTTONDBLCLICK : XTPCalendarNotifications.h
  • XTP_NC_CALENDARLBUTTONDOWN : XTPCalendarNotifications.h
  • XTP_NC_CALENDARLBUTTONUP : XTPCalendarNotifications.h
  • XTP_NC_CALENDARMOUSEMOVE : XTPCalendarNotifications.h
  • XTP_NC_CALENDAROPTIONSWASCHANGED : XTPCalendarNotifications.h
  • XTP_NC_CALENDARPATTERNWASADDED : XTPCalendarNotifications.h
  • XTP_NC_CALENDARPATTERNWASCHANGED : XTPCalendarNotifications.h
  • XTP_NC_CALENDARPATTERNWASDELETED : XTPCalendarNotifications.h
  • XTP_NC_CALENDARRBUTTONDOWN : XTPCalendarNotifications.h
  • XTP_NC_CALENDARRBUTTONUP : XTPCalendarNotifications.h
  • XTP_NC_CALENDARVIEWTIMESCALEWASCHANGED : XTPCalendarNotifications.h
  • XTP_NC_CALENDARVIEWWASCHANGED : XTPCalendarNotifications.h
  • XTP_NC_DATEPICKER_BUTTON_CLICK : XTPDatePickerControl.h
  • XTP_NC_DATEPICKER_SELECTION_CHANGED : XTPDatePickerControl.h
  • XTP_NC_DATEPICKERBEFOREGOMODAL : XTPDatePickerNotifications.h
  • XTP_NC_DATEPICKERBUTTONCLICKED : XTPDatePickerNotifications.h
  • XTP_NC_DATEPICKERGETDAYMETRICS : XTPDatePickerNotifications.h
  • XTP_NC_DATEPICKERMONTHCHANGED : XTPDatePickerNotifications.h
  • XTP_NC_DATEPICKERMOUSEMOVE : XTPDatePickerNotifications.h
  • XTP_NC_DATEPICKERSELECTIONCHANGED : XTPDatePickerNotifications.h
  • XTP_PCN_ITEMCLICK : XTPPopupControl.h
  • XTP_PCN_POSCHANGED : XTPPopupControl.h
  • XTP_PCN_STATECHANGED : XTPPopupControl.h
  • XTP_PGI_EXPAND_BORDER : XTPPropertyGridItem.h
  • XTP_PGN_AFTEREDIT : XTPPropertyGridDefines.h
  • XTP_PGN_CANCELEDIT : XTPPropertyGridDefines.h
  • XTP_PGN_DBLCLICK : XTPPropertyGridDefines.h
  • XTP_PGN_DRAWITEM : XTPPropertyGridDefines.h
  • XTP_PGN_EDIT_CHANGED : XTPPropertyGridDefines.h
  • XTP_PGN_INPLACEBUTTONDOWN : XTPPropertyGridDefines.h
  • XTP_PGN_ITEMEXPANDCHANGED : XTPPropertyGridDefines.h
  • XTP_PGN_ITEMVALUE_CHANGED : XTPPropertyGridDefines.h
  • XTP_PGN_RCLICK : XTPPropertyGridDefines.h
  • XTP_PGN_REQUESTEDIT : XTPPropertyGridDefines.h
  • XTP_PGN_SELECTION_CHANGED : XTPPropertyGridDefines.h
  • XTP_PGN_SORTORDER_CHANGED : XTPPropertyGridDefines.h
  • XTP_PGN_USER : XTPPropertyGridDefines.h
  • XTP_PGN_VERB_CLICK : XTPPropertyGridDefines.h
  • XTP_PGN_VSCROLL : XTPPropertyGridDefines.h
  • XTP_PGS_OWNERDRAW : XTPPropertyGridDefines.h
  • XTP_SBN_MINIMIZEBUTTONCLICKED : XTPShortcutBar.h
  • XTP_SBN_RCLICK : XTPShortcutBar.h
  • XTP_SBN_SELECTION_CHANGED : XTPShortcutBar.h
  • XTP_SBN_SELECTION_CHANGING : XTPShortcutBar.h
  • XTP_SELECTION_INFINITE : XTPDatePickerControl.h
  • XTP_SLN_SELCHANGE : XTPControlExt.h
  • XTP_TABMANAGER_COLOR_NONE : XTPTabManagerDefines.h
  • XTP_TABMANAGER_COLOR_SHADED : XTPTabManagerDefines.h
  • XTP_TPN_CLICK : XTPTaskPanelDefines.h
  • XTP_TPN_DBLCLICK : XTPTaskPanelDefines.h
  • XTP_TPN_ENDLABELEDIT : XTPTaskPanelDefines.h
  • XTP_TPN_FOCUSEDITEMCHANGED : XTPTaskPanelDefines.h
  • XTP_TPN_GROUPEXPANDED : XTPTaskPanelDefines.h
  • XTP_TPN_GROUPEXPANDING : XTPTaskPanelDefines.h
  • XTP_TPN_GROUPMOVE : XTPTaskPanelDefines.h
  • XTP_TPN_HOTITEMCHANGED : XTPTaskPanelDefines.h
  • XTP_TPN_ITEMDROP : XTPTaskPanelDefines.h
  • XTP_TPN_ITEMREMOVED : XTPTaskPanelDefines.h
  • XTP_TPN_RCLICK : XTPTaskPanelDefines.h
  • XTP_TPN_STARTDRAG : XTPTaskPanelDefines.h
  • XTP_WEEK_DAYS : XTPDatePickerItemMonth.h
  • XTP_WM_MARKUPREDRAW : XTPMarkupRender.h
  • xtp_wm_SwitchView : XTPCalendarDefines.h
  • XTP_WM_TIME_ZONE_CHANGED : XTPCalendarMsgNotifier.h
  • XTP_WM_UPDATE_MDI_CHILD_THEME : XTPFrameWnd.h
  • xtp_wm_UserAction : XTPCalendarDefines.h
  • XTPCALENDARCTRL_CLASSNAME : XTPCalendarDefines.h
  • XTPCALENDARCTRL_SWITCHVIEWMSG : XTPCalendarDefines.h
  • XTPCALENDARCTRL_USERACTION : XTPCalendarDefines.h
  • XTPGRIDCTRL_CF_RECORDS : XTPGridDefines.h
  • XTPGRIDCTRL_CLASSNAME : XTPGridDefines.h
  • XTPLEX_ATTR_CASESENSITIVE : XTPSyntaxEditLexClass.h
  • XTPLEX_ATTR_COLLAPSABLE : XTPSyntaxEditLexClass.h
  • XTPLEX_ATTR_COLLAPSEDTEXT : XTPSyntaxEditLexClass.h
  • XTPLEX_ATTR_COLORPREFIX : XTPSyntaxEditLexClass.h
  • XTPLEX_ATTR_DISPLAYNAME : XTPSyntaxEditLexClass.h
  • XTPLEX_ATTR_ENDCLASSPARENT : XTPSyntaxEditLexClass.h
  • XTPLEX_ATTR_PARSEONSCREEN : XTPSyntaxEditLexClass.h
  • XTPLEX_ATTR_RECURRENCEDEPTH : XTPSyntaxEditLexClass.h
  • XTPLEX_ATTR_RESTARTRUNLOOP : XTPSyntaxEditLexClass.h
  • XTPLEX_ATTR_TXT_BOLD : XTPSyntaxEditLexClass.h
  • XTPLEX_ATTR_TXT_COLORBK : XTPSyntaxEditLexClass.h
  • XTPLEX_ATTR_TXT_COLORFG : XTPSyntaxEditLexClass.h
  • XTPLEX_ATTR_TXT_COLORSELBK : XTPSyntaxEditLexClass.h
  • XTPLEX_ATTR_TXT_COLORSELFG : XTPSyntaxEditLexClass.h
  • XTPLEX_ATTR_TXT_ITALIC : XTPSyntaxEditLexClass.h
  • XTPLEX_ATTR_TXT_UNDERLINE : XTPSyntaxEditLexClass.h
  • XTPLEX_ATTR_TXTPREFIX : XTPSyntaxEditLexClass.h
  • XTPLEX_ATTRCLASSID : XTPSyntaxEditLexClass.h
  • XTPLEX_ATTRG_CONFIGCHANGEDREPARCEINSEPARATETHREAD : XTPSyntaxEditLexClass.h
  • XTPLEX_ATTRG_EDITREPARCEINSEPARATETHREAD : XTPSyntaxEditLexClass.h
  • XTPLEX_ATTRG_EDITREPARCETIMEOUT_MS : XTPSyntaxEditLexClass.h
  • XTPLEX_ATTRG_FIRSTPARSEINSEPARATETHREAD : XTPSyntaxEditLexClass.h
  • XTPLEX_ATTRG_MAXBACKPARSEOFFSET : XTPSyntaxEditLexClass.h
  • XTPLEX_ATTRG_ONSCREENSCHCACHELIFETIME_SEC : XTPSyntaxEditLexClass.h
  • XTPLEX_ATTRG_PARSERTHREADIDLELIFETIME_SEC : XTPSyntaxEditLexClass.h
  • XTPPROPERTYGRID_CLASSNAME : XTPPropertyGridDefines.h
  • XTPWM_POPUPCONTROL_NOTIFY : XTPPopupControl.h
  • XTPWM_SHORTCUTBAR_NOTIFY : XTPShortcutBar.h
  • XTPWM_TASKPANEL_NOTIFY : XTPTaskPanelDefines.h


Toolkit Pro: File Members

Here is a list of all documented typedefs with links to the documentation:

- c -

  • CXTPCalendarDatesArray : XTPCalendarDefines.h
  • CXTPChart2dPyramidDiagram : XTPChartPyramidDiagram.h
  • CXTPChart2dPyramidDiagramView : XTPChartPyramidDiagramView.h
  • CXTPChart2dPyramidSeriesLabel : XTPChartPyramidSeriesLabel.h
  • CXTPChart2dPyramidSeriesLabelView : XTPChartPyramidSeriesLabel.h
  • CXTPChart2dPyramidSeriesPointView : XTPChartPyramidSeriesPointView.h
  • CXTPChart2dPyramidSeriesStyle : XTPChartPyramidSeriesStyle.h
  • CXTPChart2dPyramidSeriesView : XTPChartPyramidSeriesView.h
  • CXTPChartPaletteEntries : XTPChartPalette.h
  • CXTPCommandBarsCategoryArray : XTPCustomizePageCommands.h
  • CXTPDockingPaneBaseList : XTPDockingPaneDefines.h
  • CXTPDockingPaneInfoList : XTPDockingPaneDefines.h
  • CXTPDockingPaneList : XTPDockingPaneDefines.h
  • CXTPFontList : XTPFontComboBox.h
  • CXTPGridHyperlinks_base : XTPGridHyperlink.h
  • CXTPGridRecordItemControls_base : XTPGridRecordItemControls.h
  • CXTPPaneIndexToPaneMap : XTPDockingPaneDefines.h
  • CXTPPaneToPaneMap : XTPDockingPaneDefines.h
  • CXTPPickBtnArray : XTPColorSelectorCtrl.h
  • CXTPPoint2d : XTPPoint2.h
  • CXTPPoint2f : XTPPoint2.h
  • CXTPPoint2i : XTPPoint2.h
  • CXTPPoint3d : XTPPoint3.h
  • CXTPPoint3f : XTPPoint3.h
  • CXTPPoint3i : XTPPoint3.h
  • CXTPRectD : XTPRect.h
  • CXTPRectF : XTPRect.h
  • CXTPRectI : XTPRect.h
  • CXTPScrollableEdit : XTPEdit.h
  • CXTPScrollableListBox : XTPListBox.h
  • CXTPScrollableListCtrl : XTPListCtrlView.h
  • CXTPScrollableTreeCtrl : XTPTreeCtrlView.h
  • CXTPSizeD : XTPSize.h
  • CXTPSizeF : XTPSize.h
  • CXTPSizeI : XTPSize.h
  • CXTPSyntaxEditACDataArray : XTPSyntaxEditAutoCompleteWnd.h
  • CXTPSyntaxEditACGrid : XTPSyntaxEditAutoCompleteWnd.h
  • CXTPSyntaxEditTextSchema : XTPSyntaxEditBufferManager.h
  • CXTPTagCloudStyleArray : XTPTagCloudCtrl.h

- p -

  • PFNITEMMETRICS : XTPDatePickerControl.h

- x -

  • XTP_RESIZE : XTPResizeRect.h
  • XTPGridRowsCompareFunc : XTPGridDefines.h


Toolkit Pro: File Members

Here is a list of all documented enums with links to the documentation:

- e -

  • EStates : XTPCalendarCaptionBarThemePart.h


Toolkit Pro: File Members

Here is a list of all documented enums with links to the documentation:

- s -

  • SelectionRectHitTest : XTPFlowGraphSelectionRect.h


Toolkit Pro: File Members

Here is a list of all documented enums with links to the documentation:

- x -

  • XTPAnimationDCType : XTPAnimationDC.h
  • XTPAnimationType : XTPCommandBarsDefines.h
  • XTPApplicationAmbientProperty : XTPApplication.h
  • XTPArrowIcon : XTPExcelTabCtrl.h
  • XTPBackImage : XTPCommandBarsOffice2013Theme.h
  • XTPBarPosition : XTPCommandBarsDefines.h
  • XTPBarTextOrientation : XTPCommandBarsDefines.h
  • XTPBarType : XTPCommandBarsDefines.h
  • XTPButtonStyle : XTPCommandBarsDefines.h
  • XTPButtonTextImageRelation : XTPButton.h
  • XTPCalendarBeforeDrawThemeObject : XTPCalendarNotifications.h
  • XTPCalendarClipboardCopyFlags : XTPCalendarDefines.h
  • XTPCalendarClockAlignFlags : XTPCalendarDefines.h
  • XTPCalendarCurrentTimeMarkFlags : XTPCalendarDefines.h
  • XTPCalendarDataProvider : XTPCalendarDefines.h
  • XTPCalendarDataProviderCacheMode : XTPCalendarDefines.h
  • XTPCalendarDayViewScrollDirection : XTPCalendarDefines.h
  • XTPCalendarDraggingMode : XTPCalendarDefines.h
  • XTPCalendarEditOperation : XTPCalendarDefines.h
  • XTPCalendarEndEditSubjectAction : XTPCalendarDefines.h
  • XTPCalendarEventBusyStatus : XTPCalendarDefines.h
  • XTPCalendarEventCaptionFormat : XTPCalendarViewEvent.h
  • XTPCalendarEventCategories : XTPCalendarDefines.h
  • XTPCalendarEventIconIDs : XTPCalendarDefines.h
  • XTPCalendarEventImportance : XTPCalendarDefines.h
  • XTPCalendarEventRecurrenceState : XTPCalendarDefines.h
  • XTPCalendarEventRecurrenceType : XTPCalendarDefines.h
  • XTPCalendarExpandDayButton : XTPCalendarDefines.h
  • XTPCalendarGetItemText : XTPCalendarDefines.h
  • XTPCalendarGetItemTextEx : XTPCalendarDefines.h
  • XTPCalendarHitTestCode : XTPCalendarDefines.h
  • XTPCalendarMouseMode : XTPCalendarDefines.h
  • XTPCalendarMultiDayEventFlags : XTPCalendarViewEvent.h
  • XTPCalendarPatternEnd : XTPCalendarDefines.h
  • XTPCalendarRemindersAction : XTPCalendarNotifications.h
  • XTPCalendarScrollDayButton : XTPCalendarDefines.h
  • XTPCalendarSelectionChanged : XTPCalendarDefines.h
  • XTPCalendarTheme : XTPCalendarDefines.h
  • XTPCalendarThemeVersion : XTPCalendarDefines.h
  • XTPCalendarUndoMode : XTPCalendarDefines.h
  • XTPCalendarUpdateOptions : XTPCalendarDefines.h
  • XTPCalendarUserAction : XTPCalendarNotifications.h
  • XTPCalendarViewChangedUpdateOptions : XTPCalendarDefines.h
  • XTPCalendarViewType : XTPCalendarDefines.h
  • XTPCalendarWeek : XTPCalendarDefines.h
  • XTPCalendarWeekDay : XTPCalendarDefines.h
  • XTPChartAxisAlignment : XTPChartAxis.h
  • XTPChartAxisDateTimeScaleUnit : XTPChartAxis.h
  • XTPChartDateTimeFormatCategory : XTPChartNumberFormat.h
  • XTPChartDocking : XTPChartTitle.h
  • XTPChartFunnelLabelPosition : XTPChartFunnelSeriesLabelBase.h
  • XTPChartLegendAlignment : XTPChartLegend.h
  • XTPChartLegendDirection : XTPChartLegend.h
  • XTPChartLegendSortDirection : XTPChartLegend.h
  • XTPChartMarkerType : XTPChartMarker.h
  • XTPChartNumberFormatCategory : XTPChartNumberFormat.h
  • XTPChartPanelDirection : XTPChartContent.h
  • XTPChartPieLabelPosition : XTPChartPieSeriesLabelBase.h
  • XTPChartPyramidLabelPosition : XTPChartPyramidSeriesLabelBase.h
  • XTPChartRadarDiagramStyle : XTPChartRadarDiagram.h
  • XTPChartRangeBarLabelPosition : XTPChartRangeBarSeriesLabel.h
  • XTPChartRangeBarLabelType : XTPChartRangeBarSeriesLabel.h
  • XTPChartSeriesTrendlineType : XTPChartTrendline.h
  • XTPChartTextRotation : XTPChartTextPainter.h
  • XTPChartUpdateOptions : XTPChartElement.h
  • XTPComInit : XTPSystemHelpers.h
  • XTPControlCustomVerticalOptions : XTPControlCustom.h
  • XTPControlDrawState : XTPControlTheme.h
  • XTPControlFlags : XTPCommandBarsDefines.h
  • XTPControlHideFlags : XTPCommandBarsDefines.h
  • XTPControlTheme : XTPControlTheme.h
  • XTPControlType : XTPCommandBarsDefines.h
  • XTPCurrentSystemTheme : XTPColorManager.h
  • XTPDatePickerBorderStyle : XTPDatePickerControl.h
  • XTPDockingContextStickerStyle : XTPDockingPaneDefines.h
  • XTPDockingPaneAction : XTPDockingPaneDefines.h
  • XTPDockingPaneCaptionButtonStyle : XTPDockingPanePaintManager.h
  • XTPDockingPaneCaptionDirection : XTPDockingPaneDefines.h
  • XTPDockingPaneDirection : XTPDockingPaneDefines.h
  • XTPDockingPaneEnableOptions : XTPDockingPaneDefines.h
  • XTPDockingPaneKeyboardNavigate : XTPDockingPaneDefines.h
  • XTPDockingPaneOptions : XTPDockingPaneDefines.h
  • XTPDockingPanePaintTheme : XTPDockingPaneDefines.h
  • XTPDockingPanePinState : XTPDockingPanePaintManager.h
  • XTPDockingPaneSplitterStyle : XTPDockingPanePaintManager.h
  • XTPDockingPaneStickerType : XTPDockingPaneDefines.h
  • XTPDockingPaneType : XTPDockingPaneDefines.h
  • XTPEnumCalendarCaptionBarThemeObject : XTPCalendarCaptionBarControl.h
  • XTPEnumCalendarDateItem : XTPCalendarTimeLineViewTimeScale.h
  • XTPEnumCalendarReminderForOccurrenceParameters : XTPCalendarDefines.h
  • XTPEnumCalendarTimeScaleParamsID : XTPCalendarDefines.h
  • XTPFindType : XTPShellTreeBase.h
  • XTPFlowGraphConnectionPointType : XTPFlowGraphNode.h
  • XTPFlowGraphConnectorType : XTPFlowGraphPaintManager.h
  • XTPFlowGraphCustomNodeCaptionPosition : XTPFlowGraphNodeCustom.h
  • XTPFlowGraphCustomNodeFillType : XTPFlowGraphNodeCustom.h
  • XTPFlowGraphCustomProperty : XTPFlowGraphControl.h
  • XTPFlowGraphDefaultXAMLTemplate : XTPFlowGraphControl.h
  • XTPFlowGraphResize : XTPFlowGraphControl.h
  • XTPFlowGraphSmoothingMode : XTPFlowGraphControl.h
  • XTPFontStyle : XTPFontComboBox.h
  • XTPFrameShadowManagerFlags : XTPFrameShadowManager.h
  • XTPGridBehavior : XTPGridBehavior.h
  • XTPGridBorderEdge : XTPGridBorder.h
  • XTPGridCheckState : XTPGridDefines.h
  • XTPGridColumnBestFitMode : XTPGridColumn.h
  • XTPGridColumnDirection : XTPGridHeader.h
  • XTPGridColumnIconAlignment : XTPGridRecordItem.h
  • XTPGridColumnOrderChangedReason : XTPGridHeader.h
  • XTPGridColumnStyle : XTPGridDefines.h
  • XTPGridDragDrop : XTPGridControl.h
  • XTPGridDrawSortTriangleStyle : XTPGridDefines.h
  • XTPGridDropMarker : XTPGridControl.h
  • XTPGridElementRect : XTPGridControl.h
  • XTPGridFilterMode : XTPGridControl.h
  • XTPGridFreezeColsDividerStyle : XTPGridDefines.h
  • XTPGridGlyph : XTPGridDefines.h
  • XTPGridGroupRowIconAlignment : XTPGridRecordItem.h
  • XTPGridItemControlAlignment : XTPGridRecordItemControls.h
  • XTPGridItemControlType : XTPGridRecordItemControls.h
  • XTPGridLineStyle : XTPGridDefines.h
  • XTPGridMouseButton : XTPGridBehavior.h
  • XTPGridMouseEvent : XTPGridBehavior.h
  • XTPGridMouseMode : XTPGridControl.h
  • XTPGridOrientation : XTPGridDefines.h
  • XTPGridPaintTheme : XTPGridDefines.h
  • XTPGridRowType : XTPGridDefines.h
  • XTPGridScrollMode : XTPGridControl.h
  • XTPGridScrollUpdateMode : XTPGridControl.h
  • XTPGridSection : XTPGridSections.h
  • XTPGridSectionDividerPosition : XTPGridDefines.h
  • XTPGridSectionDividerStyle : XTPGridDefines.h
  • XTPGridSectionHeightMode : XTPGridSection.h
  • XTPGridSelectionChangeType : XTPGridRows.h
  • XTPGridShellIcon : XTPGridDefines.h
  • XTPGridTextDecoration : XTPGridDefines.h
  • XTPGridTextSearchParms : XTPGridRecords.h
  • XTPGridTreeStructureStyle : XTPGridDefines.h
  • XTPGridVirtualRowFlags : XTPGridRecordItem.h
  • XTPGridWatermarkAlignment : XTPGridControl.h
  • XTPGroupBoxBorderStyle : XTPButton.h
  • XTPIconSizeMatching : XTPImageManager.h
  • XTPIdleFlags : XTPCommandBarsDefines.h
  • XTPImageState : XTPImageManager.h
  • XTPKeyboardCuesShow : XTPCommandBarsDefines.h
  • XTPKeyboardCuesUse : XTPCommandBarsDefines.h
  • XTPListBoxStyle : XTPListBox.h
  • XTPMarkupDock : XTPMarkupDockPanel.h
  • XTPMarkupPathPointType : XTPMarkupPathGeometryBuilder.h
  • XTPMarkupSmoothingMode : XTPMarkupContext.h
  • XTPMarkupTextTrimming : XTPMarkupTextBlock.h
  • XTPMarkupTextWrapping : XTPMarkupTextBlock.h
  • XTPMenuBarFlags : XTPCommandBarsDefines.h
  • XTPNavBtnState : XTPTabBase.h
  • XTPNotifyFlags : XTPNotifyConnection.h
  • XTPPaintManagerAccentColor : XTPColorManager.h
  • XTPPaintTheme : XTPCommandBarsDefines.h
  • XTPPopupAnimation : XTPPopupControl.h
  • XTPPopupDirection : XTPCommandBarsDefines.h
  • XTPPopupItemIcon : XTPPopupItem.h
  • XTPPopupLocation : XTPPopupControl.h
  • XTPPopupPaintTheme : XTPPopupControl.h
  • XTPPopupState : XTPPopupControl.h
  • XTPPropertyGridBorderStyle : XTPPropertyGridDefines.h
  • XTPPropertyGridHitCode : XTPPropertyGrid.h
  • XTPPropertyGridInplaceButtonsStyle : XTPPropertyGridDefines.h
  • XTPPropertyGridItemColorEditor : XTPPropertyGridItemColor.h
  • XTPPropertyGridItemFlags : XTPPropertyGridItem.h
  • XTPPropertyGridPaintTheme : XTPPropertyGridDefines.h
  • XTPPropertyGridSortOrder : XTPPropertyGridDefines.h
  • XTPPropertyGridUI : XTPPropertyGrid.h
  • XTPPropertyGridWindow : XTPPropertyGridPaintManager.h
  • XTPPropertyPageBorder : XTPPropertySheet.h
  • XTPPushButtonStyle : XTPButton.h
  • XTPResize : XTPResize.h
  • XTPRibbonBackstageKeyboardTipLevel : XTPRibbonBackstageView.h
  • XTPRibbonBackstageKeyboardTipResult : XTPRibbonBackstageView.h
  • XTPRibbonBackstageStyle : XTPRibbonBackstageView.h
  • XTPRibbonGroupReductionLevels : XTPRibbonGroup.h
  • XTPRibbonTabContextColor : XTPRibbonTab.h
  • XTPRibbonThemePart : XTPRibbonMarkupTheme.h
  • XTPRichEditWindowClassVersion : XTPSystemHelpers.h
  • XTPScrollBarStyle : XTPScrollBase.h
  • XTPScrollBarTheme : XTPScrollBase.h
  • XTPShadowOptions : XTPHookManager.h
  • XTPShortcutBarPaintTheme : XTPShortcutBarPaintManager.h
  • XTPSkinApplyOptions : XTPSkinManager.h
  • XTPSkinManagerProperty : XTPSkinManager.h
  • XTPSortType : XTPSortClass.h
  • XTPSoundManagerState : XTPSystemHelpers.h
  • XTPSpecialControl : XTPPaintManager.h
  • XTPSpecialKey : XTPCommandBarsDefines.h
  • XTPSyntaxEditCfgFlags : XTPSyntaxEditLexColorFileReader.h
  • XTPSyntaxEditCRLFStyle : XTPSyntaxEditDefines.h
  • XTPSyntaxEditDeletePos : XTPSyntaxEditDefines.h
  • XTPSyntaxEditEditAction : XTPSyntaxEditDefines.h
  • XTPSyntaxEditLexClass_OptChildren : XTPSyntaxEditLexClass.h
  • XTPSyntaxEditLexClass_OptParent : XTPSyntaxEditLexClass.h
  • XTPSyntaxEditLexParseResult : XTPSyntaxEditLexParser.h
  • XTPSyntaxEditLexVariantType : XTPSyntaxEditLexClass.h
  • XTPSyntaxEditLineMarksRefreshType : XTPSyntaxEditLineMarksManager.h
  • XTPSyntaxEditOnCfgChangedEvent : XTPSyntaxEditDefines.h
  • XTPSyntaxEditOnParseEvent : XTPSyntaxEditDefines.h
  • XTPSyntaxEditUpdateViewHint : XTPSyntaxEditDefines.h
  • XTPTabAppearanceStyle : XTPTabManagerDefines.h
  • XTPTabClientFrame : XTPTabManagerDefines.h
  • XTPTabClientStickerPart : XTPTabClientSticker.h
  • XTPTabColorStyle : XTPTabManagerDefines.h
  • XTPTabLayoutStyle : XTPTabManagerDefines.h
  • XTPTabNavigateButton : XTPTabManagerDefines.h
  • XTPTabNavigateButtonFlags : XTPTabManagerDefines.h
  • XTPTabOneNoteColor : XTPTabManagerDefines.h
  • XTPTabPosition : XTPTabManagerDefines.h
  • XTPTabToolTipBehaviour : XTPTabManagerDefines.h
  • XTPTabWorkspacePart : XTPTabManagerDefines.h
  • XTPTagCloudSort : XTPTagCloudCtrl.h
  • XTPTaskPanelAnimation : XTPTaskPanelDefines.h
  • XTPTaskPanelBehaviour : XTPTaskPanelDefines.h
  • XTPTaskPanelGripper : XTPTaskPanelPaintManager.h
  • XTPTaskPanelHotTrackStyle : XTPTaskPanelDefines.h
  • XTPTaskPanelItemAllowDrag : XTPTaskPanelDefines.h
  • XTPTaskPanelItemLayout : XTPTaskPanelDefines.h
  • XTPTaskPanelItemType : XTPTaskPanelDefines.h
  • XTPTaskPanelPaintTheme : XTPTaskPanelDefines.h
  • XTPToolBarFlags : XTPCommandBarsDefines.h
  • XTPToolTipStyle : XTPToolTipContext.h
  • XTPTrackMouseCursorMode : XTPTrackControl.h
  • XTPUriType : XTPSystemHelpers.h
  • XTPWebBrowserProvider : XTPWebBrowserCtrl.h
  • XTPWindowClass : XTPSystemHelpers.h
  • XTPWindowClassVersionSelectionVerb : XTPSystemHelpers.h
  • XTPWorkspaceActivateTab : XTPTabClientWnd.h
  • XTPWorkspaceButtons : XTPTabClientWnd.h
  • XTPWorkspaceNewTabPosition : XTPTabClientWnd.h
  • XTPZlibCompressionLevel : XTPGraphicBitmapPng.h


Toolkit Pro: File Members

Here is a list of all documented enum values with links to the documentation:

- s -

  • SelectionRectHitTestBottomCenter : XTPFlowGraphSelectionRect.h
  • SelectionRectHitTestBottomLeft : XTPFlowGraphSelectionRect.h
  • SelectionRectHitTestBottomRight : XTPFlowGraphSelectionRect.h
  • SelectionRectHitTestMiddleLeft : XTPFlowGraphSelectionRect.h
  • SelectionRectHitTestMiddleRight : XTPFlowGraphSelectionRect.h
  • SelectionRectHitTestNone : XTPFlowGraphSelectionRect.h
  • SelectionRectHitTestTopCenter : XTPFlowGraphSelectionRect.h
  • SelectionRectHitTestTopLeft : XTPFlowGraphSelectionRect.h
  • SelectionRectHitTestTopRight : XTPFlowGraphSelectionRect.h


Toolkit Pro: File Members

Here is a list of all documented enum values with links to the documentation:

- x -

  • XTP_SKINPROPERTY_BOOL : XTPSkinManager.h
  • XTP_SKINPROPERTY_COLOR : XTPSkinManager.h
  • XTP_SKINPROPERTY_ENUM : XTPSkinManager.h
  • XTP_SKINPROPERTY_FILENAME : XTPSkinManager.h
  • XTP_SKINPROPERTY_FONT : XTPSkinManager.h
  • XTP_SKINPROPERTY_INT : XTPSkinManager.h
  • XTP_SKINPROPERTY_INTLIST : XTPSkinManager.h
  • XTP_SKINPROPERTY_MARGINS : XTPSkinManager.h
  • XTP_SKINPROPERTY_POSITION : XTPSkinManager.h
  • XTP_SKINPROPERTY_RECT : XTPSkinManager.h
  • XTP_SKINPROPERTY_SIZE : XTPSkinManager.h
  • XTP_SKINPROPERTY_STRING : XTPSkinManager.h
  • XTP_SKINPROPERTY_UNKNOWN : XTPSkinManager.h
  • xtpAniDefault : XTPAnimationDC.h
  • xtpAniFade : XTPAnimationDC.h
  • xtpAnimateFade : XTPCommandBarsDefines.h
  • xtpAnimateNone : XTPCommandBarsDefines.h
  • xtpAnimateRandom : XTPCommandBarsDefines.h
  • xtpAnimateSlide : XTPCommandBarsDefines.h
  • xtpAnimateUnfold : XTPCommandBarsDefines.h
  • xtpAnimateWindowsDefault : XTPCommandBarsDefines.h
  • xtpAniNone : XTPAnimationDC.h
  • xtpAniRandom : XTPAnimationDC.h
  • xtpAniSlide : XTPAnimationDC.h
  • xtpAniUnfold : XTPAnimationDC.h
  • xtpApplicationAccentColor : XTPApplication.h
  • xtpApplicationStateColor : XTPApplication.h
  • xtpApplicationUseSystemAccentColor : XTPApplication.h
  • xtpArrowIconLeft : XTPExcelTabCtrl.h
  • xtpArrowIconLeftHome : XTPExcelTabCtrl.h
  • xtpArrowIconRight : XTPExcelTabCtrl.h
  • xtpArrowIconRightHome : XTPExcelTabCtrl.h
  • xtpBarBottom : XTPCommandBarsDefines.h
  • xtpBarFloating : XTPCommandBarsDefines.h
  • xtpBarLeft : XTPCommandBarsDefines.h
  • xtpBarListBox : XTPCommandBarsDefines.h
  • xtpBarNone : XTPCommandBarsDefines.h
  • xtpBarPopup : XTPCommandBarsDefines.h
  • xtpBarRight : XTPCommandBarsDefines.h
  • xtpBarTextAuto : XTPCommandBarsDefines.h
  • xtpBarTextHorizontal : XTPCommandBarsDefines.h
  • xtpBarTextVertical : XTPCommandBarsDefines.h
  • xtpBarTop : XTPCommandBarsDefines.h
  • xtpBarTypeMenuBar : XTPCommandBarsDefines.h
  • xtpBarTypeNormal : XTPCommandBarsDefines.h
  • xtpBarTypePopup : XTPCommandBarsDefines.h
  • xtpBarTypeRibbon : XTPCommandBarsDefines.h
  • xtpBtnStateChecked : XTPCalendarCaptionBarThemePart.h
  • xtpBtnStateFocused : XTPCalendarCaptionBarThemePart.h
  • xtpBtnStateMouseOver : XTPCalendarCaptionBarThemePart.h
  • xtpBtnStateNormal : XTPCalendarCaptionBarThemePart.h
  • xtpBtnStatePressed : XTPCalendarCaptionBarThemePart.h
  • xtpButtonAutomatic : XTPCommandBarsDefines.h
  • xtpButtonCaption : XTPCommandBarsDefines.h
  • xtpButtonCaptionAndDescription : XTPCommandBarsDefines.h
  • xtpButtonDropDown : XTPButton.h
  • xtpButtonDropDownNoGlyph : XTPButton.h
  • xtpButtonDropDownRight : XTPButton.h
  • xtpButtonExpandFloating : XTPPaintManager.h
  • xtpButtonExpandMenu : XTPPaintManager.h
  • xtpButtonExpandToolbar : XTPPaintManager.h
  • xtpButtonHideFloating : XTPPaintManager.h
  • xtpButtonIcon : XTPCommandBarsDefines.h
  • xtpButtonIconAndCaption : XTPCommandBarsDefines.h
  • xtpButtonIconAndCaptionBelow : XTPCommandBarsDefines.h
  • xtpButtonImageAboveText : XTPButton.h
  • xtpButtonImageBeforeText : XTPButton.h
  • xtpButtonNormal : XTPButton.h
  • xtpButtonOverlay : XTPButton.h
  • xtpButtonSplitDropDown : XTPButton.h
  • xtpButtonTextAboveImage : XTPButton.h
  • xtpButtonTextBeforeImage : XTPButton.h
  • xtpButtonUndefined : XTPCommandBarsDefines.h
  • xtpCalendaDragModeCopy : XTPCalendarDefines.h
  • xtpCalendaDragModeEditSubject : XTPCalendarDefines.h
  • xtpCalendaDragModeMove : XTPCalendarDefines.h
  • xtpCalendaDragModeResizeBegin : XTPCalendarDefines.h
  • xtpCalendaDragModeResizeEnd : XTPCalendarDefines.h
  • xtpCalendaDragModeUnknown : XTPCalendarDefines.h
  • xtpCalendarBeforeDraw_AllDayViewEvent : XTPCalendarNotifications.h
  • xtpCalendarBeforeDraw_DayViewCell : XTPCalendarNotifications.h
  • xtpCalendarBeforeDraw_DayViewDay : XTPCalendarNotifications.h
  • xtpCalendarBeforeDraw_DayViewDayGroup : XTPCalendarNotifications.h
  • xtpCalendarBeforeDraw_DayViewEvent : XTPCalendarNotifications.h
  • xtpCalendarBeforeDraw_DayViewTimeScale : XTPCalendarNotifications.h
  • xtpCalendarBeforeDraw_DayViewTimeScaleCaption : XTPCalendarNotifications.h
  • xtpCalendarBeforeDraw_DayViewTimeScaleCell : XTPCalendarNotifications.h
  • xtpCalendarBeforeDraw_MonthViewDay : XTPCalendarNotifications.h
  • xtpCalendarBeforeDraw_MonthViewEvent : XTPCalendarNotifications.h
  • xtpCalendarBeforeDraw_MonthViewWeekDayHeader : XTPCalendarNotifications.h
  • xtpCalendarBeforeDraw_MonthViewWeekHeader : XTPCalendarNotifications.h
  • xtpCalendarBeforeDraw_WeekViewDay : XTPCalendarNotifications.h
  • xtpCalendarBeforeDraw_WeekViewEvent : XTPCalendarNotifications.h
  • xtpCalendarBusyStatusBusy : XTPCalendarDefines.h
  • xtpCalendarBusyStatusElsewhere : XTPCalendarDefines.h
  • xtpCalendarBusyStatusFree : XTPCalendarDefines.h
  • xtpCalendarBusyStatusOutOfOffice : XTPCalendarDefines.h
  • xtpCalendarBusyStatusTentative : XTPCalendarDefines.h
  • xtpCalendarBusyStatusUnknown : XTPCalendarDefines.h
  • xtpCalendarCaptionBar_ButtonExpand : XTPCalendarCaptionBarControl.h
  • xtpCalendarCaptionBar_ButtonViewDay : XTPCalendarCaptionBarControl.h
  • xtpCalendarCaptionBar_ButtonViewMonth : XTPCalendarCaptionBarControl.h
  • xtpCalendarCaptionBar_ButtonViewWeek : XTPCalendarCaptionBarControl.h
  • xtpCalendarCaptionBar_DateLabel : XTPCalendarCaptionBarControl.h
  • xtpCalendarCaptionBar_MultiColumnsWeek : XTPCalendarCaptionBarControl.h
  • xtpCalendarCaptionBar_ScrollNextDate : XTPCalendarCaptionBarControl.h
  • xtpCalendarCaptionBar_ScrollPrevDate : XTPCalendarCaptionBarControl.h
  • xtpCalendarCaptionBar_ShowFullWeek : XTPCalendarCaptionBarControl.h
  • xtpCalendarCaptionBar_ShowTimeline : XTPCalendarCaptionBarControl.h
  • xtpCalendarCaptionBar_ShowWorkWeek : XTPCalendarCaptionBarControl.h
  • xtpCalendarCaptionBar_Unknown : XTPCalendarCaptionBarControl.h
  • xtpCalendarCaptionFormatStartEndSubject : XTPCalendarViewEvent.h
  • xtpCalendarCaptionFormatStartSubject : XTPCalendarViewEvent.h
  • xtpCalendarCaptionFormatSubject : XTPCalendarViewEvent.h
  • xtpCalendarCaptionFormatUnknown : XTPCalendarViewEvent.h
  • xtpCalendarClockAlignCenter : XTPCalendarDefines.h
  • xtpCalendarClockAlignLeft : XTPCalendarDefines.h
  • xtpCalendarClockAlignRight : XTPCalendarDefines.h
  • xtpCalendarCopyFlagClearCBAfterPaste : XTPCalendarDefines.h
  • xtpCalendarCopyFlagCutMask : XTPCalendarDefines.h
  • xtpCalendarCopyFlagKeepRException : XTPCalendarDefines.h
  • xtpCalendarCopyFlagROccurrence2RException : XTPCalendarDefines.h
  • xtpCalendarCurrentTimeMarkNone : XTPCalendarDefines.h
  • xtpCalendarCurrentTimeMarkPrinted : XTPCalendarDefines.h
  • xtpCalendarCurrentTimeMarkVisibleAlways : XTPCalendarDefines.h
  • xtpCalendarCurrentTimeMarkVisibleForToday : XTPCalendarDefines.h
  • xtpCalendarDataProviderCustom : XTPCalendarDefines.h
  • xtpCalendarDataProviderDatabase : XTPCalendarDefines.h
  • xtpCalendarDataProviderMAPI : XTPCalendarDefines.h
  • xtpCalendarDataProviderMemory : XTPCalendarDefines.h
  • xtpCalendarDataProviderUnknown : XTPCalendarDefines.h
  • xtpCalendarDayAllWeek : XTPCalendarDefines.h
  • xtpCalendarDayFriday : XTPCalendarDefines.h
  • xtpCalendarDayMo_Fr : XTPCalendarDefines.h
  • xtpCalendarDayMonday : XTPCalendarDefines.h
  • xtpCalendarDaySaSu : XTPCalendarDefines.h
  • xtpCalendarDaySaturday : XTPCalendarDefines.h
  • xtpCalendarDaySunday : XTPCalendarDefines.h
  • xtpCalendarDayThursday : XTPCalendarDefines.h
  • xtpCalendarDayTuesday : XTPCalendarDefines.h
  • xtpCalendarDayView : XTPCalendarDefines.h
  • xtpCalendarDayViewScrollDown : XTPCalendarDefines.h
  • xtpCalendarDayViewScrollLeft : XTPCalendarDefines.h
  • xtpCalendarDayViewScrollNotNeeded : XTPCalendarDefines.h
  • xtpCalendarDayViewScrollRight : XTPCalendarDefines.h
  • xtpCalendarDayViewScrollUp : XTPCalendarDefines.h
  • xtpCalendarDayWednesday : XTPCalendarDefines.h
  • xtpCalendarDPCacheModeOff : XTPCalendarDefines.h
  • xtpCalendarDPCacheModeOnClear : XTPCalendarDefines.h
  • xtpCalendarDPCacheModeOnMask : XTPCalendarDefines.h
  • xtpCalendarDPCacheModeOnRepeat : XTPCalendarDefines.h
  • xtpCalendarEditSubjectCancel : XTPCalendarDefines.h
  • xtpCalendarEditSubjectCommit : XTPCalendarDefines.h
  • xtpCalendarEditSubjectUnknown : XTPCalendarDefines.h
  • xtpCalendarEO_Copy : XTPCalendarDefines.h
  • xtpCalendarEO_Cut : XTPCalendarDefines.h
  • xtpCalendarEO_DeleteEvent : XTPCalendarDefines.h
  • xtpCalendarEO_DeleteSelectedEvents : XTPCalendarDefines.h
  • xtpCalendarEO_DragCopy : XTPCalendarDefines.h
  • xtpCalendarEO_DragMove : XTPCalendarDefines.h
  • xtpCalendarEO_DragResizeBegin : XTPCalendarDefines.h
  • xtpCalendarEO_DragResizeEnd : XTPCalendarDefines.h
  • xtpCalendarEO_EditSubject_AfterEventResize : XTPCalendarDefines.h
  • xtpCalendarEO_EditSubject_ByF2 : XTPCalendarDefines.h
  • xtpCalendarEO_EditSubject_ByMouseClick : XTPCalendarDefines.h
  • xtpCalendarEO_EditSubject_ByTab : XTPCalendarDefines.h
  • xtpCalendarEO_InPlaceCreateEvent : XTPCalendarDefines.h
  • xtpCalendarEO_Paste : XTPCalendarDefines.h
  • xtpCalendarEO_Unknown : XTPCalendarDefines.h
  • xtpCalendarEventCategoryBlue : XTPCalendarDefines.h
  • xtpCalendarEventCategoryGreen : XTPCalendarDefines.h
  • xtpCalendarEventCategoryOrange : XTPCalendarDefines.h
  • xtpCalendarEventCategoryPurple : XTPCalendarDefines.h
  • xtpCalendarEventCategoryRed : XTPCalendarDefines.h
  • xtpCalendarEventCategoryUnknown : XTPCalendarDefines.h
  • xtpCalendarEventCategoryYellow : XTPCalendarDefines.h
  • xtpCalendarEventIconIDException : XTPCalendarDefines.h
  • xtpCalendarEventIconIDMeeting : XTPCalendarDefines.h
  • xtpCalendarEventIconIDOccurrence : XTPCalendarDefines.h
  • xtpCalendarEventIconIDPrivate : XTPCalendarDefines.h
  • xtpCalendarEventIconIDReminder : XTPCalendarDefines.h
  • xtpCalendarExpandDayButton_MonthView : XTPCalendarDefines.h
  • xtpCalendarExpandDayButton_WeekView : XTPCalendarDefines.h
  • xtpCalendarFullWeekView : XTPCalendarDefines.h
  • xtpCalendarHitTestAllDayEventsScrollDown : XTPCalendarDefines.h
  • xtpCalendarHitTestAllDayEventsScrollUp : XTPCalendarDefines.h
  • xtpCalendarHitTestAllDayExpandButton : XTPCalendarDefines.h
  • xtpCalendarHitTestDay_Mask : XTPCalendarDefines.h
  • xtpCalendarHitTestDayArea : XTPCalendarDefines.h
  • xtpCalendarHitTestDayExpandButton : XTPCalendarDefines.h
  • xtpCalendarHitTestDayHeader : XTPCalendarDefines.h
  • xtpCalendarHitTestDayView_Mask : XTPCalendarDefines.h
  • xtpCalendarHitTestDayViewAllDayEvent : XTPCalendarDefines.h
  • xtpCalendarHitTestDayViewCell : XTPCalendarDefines.h
  • xtpCalendarHitTestDayViewScrollDown : XTPCalendarDefines.h
  • xtpCalendarHitTestDayViewScrollUp : XTPCalendarDefines.h
  • xtpCalendarHitTestDayViewTimeScale : XTPCalendarDefines.h
  • xtpCalendarHitTestEvent_Mask : XTPCalendarDefines.h
  • xtpCalendarHitTestEventDragArea : XTPCalendarDefines.h
  • xtpCalendarHitTestEventResizeArea_Mask : XTPCalendarDefines.h
  • xtpCalendarHitTestEventResizeBegin : XTPCalendarDefines.h
  • xtpCalendarHitTestEventResizeEnd : XTPCalendarDefines.h
  • xtpCalendarHitTestEventResizeHArea : XTPCalendarDefines.h
  • xtpCalendarHitTestEventResizeVArea : XTPCalendarDefines.h
  • xtpCalendarHitTestEventTextArea : XTPCalendarDefines.h
  • xtpCalendarHitTestGroupArea : XTPCalendarDefines.h
  • xtpCalendarHitTestGroupHeader : XTPCalendarDefines.h
  • xtpCalendarHitTestNextEventButton : XTPCalendarDefines.h
  • xtpCalendarHitTestPrevEventButton : XTPCalendarDefines.h
  • xtpCalendarHitTestTimeLineScale : XTPCalendarDefines.h
  • xtpCalendarHitTestUnknown : XTPCalendarDefines.h
  • xtpCalendarImportanceHigh : XTPCalendarDefines.h
  • xtpCalendarImportanceLow : XTPCalendarDefines.h
  • xtpCalendarImportanceNormal : XTPCalendarDefines.h
  • xtpCalendarImportanceUnknown : XTPCalendarDefines.h
  • xtpCalendarItemText_CaptionBarDayViewDateLabel : XTPCalendarDefines.h
  • xtpCalendarItemText_CaptionBarMonthViewDateLabel : XTPCalendarDefines.h
  • xtpCalendarItemText_CaptionBarWeekViewDateLabel : XTPCalendarDefines.h
  • xtpCalendarItemText_DayViewDayHeader : XTPCalendarDefines.h
  • xtpCalendarItemText_DayViewDayHeaderCenter : XTPCalendarDefines.h
  • xtpCalendarItemText_DayViewDayHeaderLeft : XTPCalendarDefines.h
  • xtpCalendarItemText_DayViewDayHeaderRight : XTPCalendarDefines.h
  • xtpCalendarItemText_EventBody : XTPCalendarDefines.h
  • xtpCalendarItemText_EventEndTimeText : XTPCalendarDefines.h
  • xtpCalendarItemText_EventLocation : XTPCalendarDefines.h
  • xtpCalendarItemText_EventMarkupTemplate : XTPCalendarDefines.h
  • xtpCalendarItemText_EventStartTimeText : XTPCalendarDefines.h
  • xtpCalendarItemText_EventSubject : XTPCalendarDefines.h
  • xtpCalendarItemText_EventToolTipText : XTPCalendarDefines.h
  • xtpCalendarItemText_MonthViewDayHeader : XTPCalendarDefines.h
  • xtpCalendarItemText_MonthViewDayHeaderCenter : XTPCalendarDefines.h
  • xtpCalendarItemText_MonthViewDayHeaderLeft : XTPCalendarDefines.h
  • xtpCalendarItemText_MonthViewDayHeaderRight : XTPCalendarDefines.h
  • xtpCalendarItemText_MonthViewWeekDayHeader : XTPCalendarDefines.h
  • xtpCalendarItemText_WeekViewDayHeader : XTPCalendarDefines.h
  • xtpCalendarItemText_WeekViewDayHeaderCenter : XTPCalendarDefines.h
  • xtpCalendarItemText_WeekViewDayHeaderLeft : XTPCalendarDefines.h
  • xtpCalendarItemText_WeekViewDayHeaderRight : XTPCalendarDefines.h
  • xtpCalendarMonthView : XTPCalendarDefines.h
  • xtpCalendarMouseEventDragCopy : XTPCalendarDefines.h
  • xtpCalendarMouseEventDraggingOut : XTPCalendarDefines.h
  • xtpCalendarMouseEventDragMove : XTPCalendarDefines.h
  • xtpCalendarMouseEventPreDrag : XTPCalendarDefines.h
  • xtpCalendarMouseEventPreResizeH : XTPCalendarDefines.h
  • xtpCalendarMouseEventPreResizeV : XTPCalendarDefines.h
  • xtpCalendarMouseEventResizingH : XTPCalendarDefines.h
  • xtpCalendarMouseEventResizingV : XTPCalendarDefines.h
  • xtpCalendarMouseNothing : XTPCalendarDefines.h
  • xtpCalendarMultiDayFirst : XTPCalendarViewEvent.h
  • xtpCalendarMultiDayFMLmask : XTPCalendarViewEvent.h
  • xtpCalendarMultiDayLast : XTPCalendarViewEvent.h
  • xtpCalendarMultiDayMaster : XTPCalendarViewEvent.h
  • xtpCalendarMultiDayMiddle : XTPCalendarViewEvent.h
  • xtpCalendarMultiDayMSmask : XTPCalendarViewEvent.h
  • xtpCalendarMultiDayNoMultiDay : XTPCalendarViewEvent.h
  • xtpCalendarMultiDaySlave : XTPCalendarViewEvent.h
  • xtpCalendarMultiDayUnknown : XTPCalendarViewEvent.h
  • xtpCalendarPatternEndAfterOccurrences : XTPCalendarDefines.h
  • xtpCalendarPatternEndDate : XTPCalendarDefines.h
  • xtpCalendarPatternEndNoDate : XTPCalendarDefines.h
  • xtpCalendarRecurrenceDaily : XTPCalendarDefines.h
  • xtpCalendarRecurrenceException : XTPCalendarDefines.h
  • xtpCalendarRecurrenceMaster : XTPCalendarDefines.h
  • xtpCalendarRecurrenceMonthly : XTPCalendarDefines.h
  • xtpCalendarRecurrenceMonthNth : XTPCalendarDefines.h
  • xtpCalendarRecurrenceNotRecurring : XTPCalendarDefines.h
  • xtpCalendarRecurrenceOccurrence : XTPCalendarDefines.h
  • xtpCalendarRecurrenceUnknown : XTPCalendarDefines.h
  • xtpCalendarRecurrenceWeekly : XTPCalendarDefines.h
  • xtpCalendarRecurrenceYearly : XTPCalendarDefines.h
  • xtpCalendarRecurrenceYearNth : XTPCalendarDefines.h
  • xtpCalendarReminderDismissed : XTPCalendarNotifications.h
  • xtpCalendarReminderDismissedAll : XTPCalendarNotifications.h
  • xtpCalendarRemindersFire : XTPCalendarNotifications.h
  • xtpCalendarRemindersMonitoringStarted : XTPCalendarNotifications.h
  • xtpCalendarRemindersMonitoringStopped : XTPCalendarNotifications.h
  • xtpCalendarReminderSnoozed : XTPCalendarNotifications.h
  • xtpCalendarRmdPrm_Default : XTPCalendarDefines.h
  • xtpCalendarRmdPrm_DontChange : XTPCalendarDefines.h
  • xtpCalendarScrollDayButton_DayViewDown : XTPCalendarDefines.h
  • xtpCalendarScrollDayButton_DayViewUp : XTPCalendarDefines.h
  • xtpCalendarSelectionDays : XTPCalendarDefines.h
  • xtpCalendarSelectionEvents : XTPCalendarDefines.h
  • xtpCalendarSelectionUnknown : XTPCalendarDefines.h
  • xtpCalendarThemeNativeWindows10 : XTPCalendarDefines.h
  • xtpCalendarThemeNativeWindows11 : XTPCalendarDefines.h
  • xtpCalendarThemeOffice2000 : XTPCalendarDefines.h
  • xtpCalendarThemeOffice2003 : XTPCalendarDefines.h
  • xtpCalendarThemeOffice2007 : XTPCalendarDefines.h
  • xtpCalendarThemeOffice2010 : XTPCalendarDefines.h
  • xtpCalendarThemeOffice2013 : XTPCalendarDefines.h
  • xtpCalendarThemeOffice2016 : XTPCalendarDefines.h
  • xtpCalendarThemeOfficeXP : XTPCalendarDefines.h
  • xtpCalendarThemeResource : XTPCalendarDefines.h
  • xtpCalendarThemeUnknown : XTPCalendarDefines.h
  • xtpCalendarThemeVisualStudio2015 : XTPCalendarDefines.h
  • xtpCalendarThemeVisualStudio2017 : XTPCalendarDefines.h
  • xtpCalendarThemeVisualStudio2019 : XTPCalendarDefines.h
  • xtpCalendarThemeVisualStudio2022 : XTPCalendarDefines.h
  • xtpCalendarTimeLineView : XTPCalendarDefines.h
  • xtpCalendarUndoModeRedo : XTPCalendarDefines.h
  • xtpCalendarUndoModeUndo : XTPCalendarDefines.h
  • xtpCalendarUndoModeUnknown : XTPCalendarDefines.h
  • xtpCalendarUpdateAll : XTPCalendarDefines.h
  • xtpCalendarUpdateLayout : XTPCalendarDefines.h
  • xtpCalendarUpdateRedraw : XTPCalendarDefines.h
  • xtpCalendarUpdateRedrawIfNeed : XTPCalendarDefines.h
  • xtpCalendarUpdateScrollBar : XTPCalendarDefines.h
  • xtpCalendarUserAction_OnExpandDay : XTPCalendarNotifications.h
  • xtpCalendarUserAction_OnScrollAllDayEvensDown : XTPCalendarNotifications.h
  • xtpCalendarUserAction_OnScrollAllDayEvensUp : XTPCalendarNotifications.h
  • xtpCalendarUserAction_OnScrollDay : XTPCalendarNotifications.h
  • xtpCalendarVersion10 : XTPCalendarDefines.h
  • xtpCalendarVersion11 : XTPCalendarDefines.h
  • xtpCalendarVersion2000 : XTPCalendarDefines.h
  • xtpCalendarVersion2003 : XTPCalendarDefines.h
  • xtpCalendarVersion2007 : XTPCalendarDefines.h
  • xtpCalendarVersion2010 : XTPCalendarDefines.h
  • xtpCalendarVersion2013 : XTPCalendarDefines.h
  • xtpCalendarVersion2015 : XTPCalendarDefines.h
  • xtpCalendarVersion2017 : XTPCalendarDefines.h
  • xtpCalendarVersion2019 : XTPCalendarDefines.h
  • xtpCalendarVersion2022 : XTPCalendarDefines.h
  • xtpCalendarVersionUnknown : XTPCalendarDefines.h
  • xtpCalendarVersionXP : XTPCalendarDefines.h
  • xtpCalendarViewChangedLock : XTPCalendarDefines.h
  • xtpCalendarViewChangedSend : XTPCalendarDefines.h
  • xtpCalendarWeekFirst : XTPCalendarDefines.h
  • xtpCalendarWeekFourth : XTPCalendarDefines.h
  • xtpCalendarWeekLast : XTPCalendarDefines.h
  • xtpCalendarWeekSecond : XTPCalendarDefines.h
  • xtpCalendarWeekThird : XTPCalendarDefines.h
  • xtpCalendarWeekView : XTPCalendarDefines.h
  • xtpCalendarWorkWeekView : XTPCalendarDefines.h
  • XTPCalligraphy : XTPCommandBarsOffice2013Theme.h
  • xtpChartAxisFar : XTPChartAxis.h
  • xtpChartAxisNear : XTPChartAxis.h
  • xtpChartCurrency : XTPChartNumberFormat.h
  • xtpChartDateTimeCustom : XTPChartNumberFormat.h
  • xtpChartDateTimeGeneral : XTPChartNumberFormat.h
  • xtpChartDateTimeLongDate : XTPChartNumberFormat.h
  • xtpChartDateTimeLongTime : XTPChartNumberFormat.h
  • xtpChartDateTimeMonthAndDay : XTPChartNumberFormat.h
  • xtpChartDateTimeMonthAndYear : XTPChartNumberFormat.h
  • xtpChartDateTimeShortDate : XTPChartNumberFormat.h
  • xtpChartDateTimeShortTime : XTPChartNumberFormat.h
  • xtpChartDockBottom : XTPChartTitle.h
  • xtpChartDockLeft : XTPChartTitle.h
  • xtpChartDockRight : XTPChartTitle.h
  • xtpChartDockTop : XTPChartTitle.h
  • xtpChartFunnelLabelCenter : XTPChartFunnelSeriesLabelBase.h
  • xtpChartFunnelLabelLeft : XTPChartFunnelSeriesLabelBase.h
  • xtpChartFunnelLabelRight : XTPChartFunnelSeriesLabelBase.h
  • xtpChartGeneral : XTPChartNumberFormat.h
  • xtpChartLegendAsc : XTPChartLegend.h
  • xtpChartLegendCenter : XTPChartLegend.h
  • xtpChartLegendDesc : XTPChartLegend.h
  • xtpChartLegendFar : XTPChartLegend.h
  • xtpChartLegendFarOutside : XTPChartLegend.h
  • xtpChartLegendLeftToRight : XTPChartLegend.h
  • xtpChartLegendMaxToMin : XTPChartLegend.h
  • xtpChartLegendMinToMax : XTPChartLegend.h
  • xtpChartLegendNear : XTPChartLegend.h
  • xtpChartLegendNearOutside : XTPChartLegend.h
  • xtpChartLegendNone : XTPChartLegend.h
  • xtpChartLegendTopToBottom : XTPChartLegend.h
  • xtpChartMarkerCircle : XTPChartMarker.h
  • xtpChartMarkerDiamond : XTPChartMarker.h
  • xtpChartMarkerHexagon : XTPChartMarker.h
  • xtpChartMarkerPentagon : XTPChartMarker.h
  • xtpChartMarkerSquare : XTPChartMarker.h
  • xtpChartMarkerStar : XTPChartMarker.h
  • xtpChartMarkerTriangle : XTPChartMarker.h
  • xtpChartNumber : XTPChartNumberFormat.h
  • xtpChartPanelHorizontal : XTPChartContent.h
  • xtpChartPanelVertical : XTPChartContent.h
  • xtpChartPercentage : XTPChartNumberFormat.h
  • xtpChartPieLabelInside : XTPChartPieSeriesLabelBase.h
  • xtpChartPieLabelOutside : XTPChartPieSeriesLabelBase.h
  • xtpChartPieLabelRadial : XTPChartPieSeriesLabelBase.h
  • xtpChartPieLabelTwoColumns : XTPChartPieSeriesLabelBase.h
  • xtpChartPyramidLabelCenter : XTPChartPyramidSeriesLabelBase.h
  • xtpChartPyramidLabelLeft : XTPChartPyramidSeriesLabelBase.h
  • xtpChartPyramidLabelRight : XTPChartPyramidSeriesLabelBase.h
  • xtpChartRadarDiagramCircle : XTPChartRadarDiagram.h
  • xtpChartRadarDiagramPolygon : XTPChartRadarDiagram.h
  • xtpChartRangeBarLabelInside : XTPChartRangeBarSeriesLabel.h
  • xtpChartRangeBarLabelOutside : XTPChartRangeBarSeriesLabel.h
  • xtpChartRangeBarMaxValueLabel : XTPChartRangeBarSeriesLabel.h
  • xtpChartRangeBarMinValueLabel : XTPChartRangeBarSeriesLabel.h
  • xtpChartRangeBarOneLabel : XTPChartRangeBarSeriesLabel.h
  • xtpChartRangeBarTwoLabels : XTPChartRangeBarSeriesLabel.h
  • xtpChartScaleDay : XTPChartAxis.h
  • xtpChartScaleHour : XTPChartAxis.h
  • xtpChartScaleMinute : XTPChartAxis.h
  • xtpChartScaleMonth : XTPChartAxis.h
  • xtpChartScaleYear : XTPChartAxis.h
  • xtpChartScientific : XTPChartNumberFormat.h
  • xtpChartSeriesTrendlineTypeLinear : XTPChartTrendline.h
  • xtpChartSeriesTrendlineTypeMaximum : XTPChartTrendline.h
  • xtpChartSeriesTrendlineTypeMinimum : XTPChartTrendline.h
  • xtpChartSeriesTrendlineTypeMovingAverageSimple : XTPChartTrendline.h
  • xtpChartSeriesTrendlineTypeNone : XTPChartTrendline.h
  • xtpChartTextCenterBottom : XTPChartTextPainter.h
  • xtpChartTextCenterCenter : XTPChartTextPainter.h
  • xtpChartTextCenterTop : XTPChartTextPainter.h
  • xtpChartTextLeftBottom : XTPChartTextPainter.h
  • xtpChartTextLeftCenter : XTPChartTextPainter.h
  • xtpChartTextLeftTop : XTPChartTextPainter.h
  • xtpChartTextRightBottom : XTPChartTextPainter.h
  • xtpChartTextRightCenter : XTPChartTextPainter.h
  • xtpChartTextRightTop : XTPChartTextPainter.h
  • xtpChartUpdateLayout : XTPChartElement.h
  • xtpChartUpdateRedraw : XTPChartElement.h
  • xtpChartUpdateView : XTPChartElement.h
  • XTPCirclesAndStripes : XTPCommandBarsOffice2013Theme.h
  • XTPCircuit : XTPCommandBarsOffice2013Theme.h
  • XTPClouds : XTPCommandBarsOffice2013Theme.h
  • xtpColumnBestFitModeAllData : XTPGridColumn.h
  • xtpColumnBestFitModeVisibleData : XTPGridColumn.h
  • xtpColumnIconBottom : XTPGridRecordItem.h
  • xtpColumnIconCenter : XTPGridRecordItem.h
  • xtpColumnIconLeft : XTPGridRecordItem.h
  • xtpColumnIconMask : XTPGridRecordItem.h
  • xtpColumnIconRight : XTPGridRecordItem.h
  • xtpColumnIconTop : XTPGridRecordItem.h
  • xtpColumnIconVCenter : XTPGridRecordItem.h
  • xtpColumnTextCenter : XTPGridRecordItem.h
  • xtpColumnTextLeft : XTPGridRecordItem.h
  • xtpColumnTextMask : XTPGridRecordItem.h
  • xtpColumnTextRight : XTPGridRecordItem.h
  • xtpColumnTextVCenter : XTPGridRecordItem.h
  • xtpColumnTextWordBreak : XTPGridRecordItem.h
  • xtpComInitAfxOle : XTPSystemHelpers.h
  • xtpComInitAppDefault : XTPSystemHelpers.h
  • xtpComInitDisableOle1DDE : XTPSystemHelpers.h
  • xtpComInitInvalid : XTPSystemHelpers.h
  • xtpComInitModuleAfxOle : XTPSystemHelpers.h
  • xtpComInitMTA : XTPSystemHelpers.h
  • xtpComInitOle : XTPSystemHelpers.h
  • xtpComInitSpeedOverMemory : XTPSystemHelpers.h
  • xtpComInitSTA : XTPSystemHelpers.h
  • xtpComInitUserDefined : XTPSystemHelpers.h
  • xtpControlButton : XTPCommandBarsDefines.h
  • xtpControlButtonPopup : XTPCommandBarsDefines.h
  • xtpControlCheckBox : XTPCommandBarsDefines.h
  • xtpControlComboBox : XTPCommandBarsDefines.h
  • xtpControlCustom : XTPCommandBarsDefines.h
  • xtpControlDrawStateDisabled : XTPControlTheme.h
  • xtpControlDrawStateFocus : XTPControlTheme.h
  • xtpControlDrawStateHotButton : XTPControlTheme.h
  • xtpControlDrawStateHotLight : XTPControlTheme.h
  • xtpControlDrawStateNormal : XTPControlTheme.h
  • xtpControlDrawStatePushed : XTPControlTheme.h
  • xtpControlDrawStateSelected : XTPControlTheme.h
  • xtpControlEdit : XTPCommandBarsDefines.h
  • xtpControlError : XTPCommandBarsDefines.h
  • xtpControlGallery : XTPCommandBarsDefines.h
  • xtpControlLabel : XTPCommandBarsDefines.h
  • xtpControlPopup : XTPCommandBarsDefines.h
  • xtpControlRadioButton : XTPCommandBarsDefines.h
  • xtpControlSplitButtonPopup : XTPCommandBarsDefines.h
  • xtpControlThemeCustom : XTPControlTheme.h
  • xtpControlThemeDefault : XTPControlTheme.h
  • xtpControlThemeFlat : XTPControlTheme.h
  • xtpControlThemeNativeWindows10 : XTPControlTheme.h
  • xtpControlThemeNativeWindows11 : XTPControlTheme.h
  • xtpControlThemeNativeWinXP : XTPControlTheme.h
  • xtpControlThemeOffice2000 : XTPControlTheme.h
  • xtpControlThemeOffice2003 : XTPControlTheme.h
  • xtpControlThemeOffice2013 : XTPControlTheme.h
  • xtpControlThemeOffice2016 : XTPControlTheme.h
  • xtpControlThemeOfficeXP : XTPControlTheme.h
  • xtpControlThemeResource : XTPControlTheme.h
  • xtpControlThemeUltraFlat : XTPControlTheme.h
  • xtpControlThemeVisualStudio2005 : XTPControlTheme.h
  • xtpControlThemeVisualStudio2008 : XTPControlTheme.h
  • xtpControlThemeVisualStudio2010 : XTPControlTheme.h
  • xtpControlThemeVisualStudio2012 : XTPControlTheme.h
  • xtpControlThemeVisualStudio2012Dark : XTPControlTheme.h
  • xtpControlThemeVisualStudio2012Light : XTPControlTheme.h
  • xtpControlThemeVisualStudio2015 : XTPControlTheme.h
  • xtpControlThemeVisualStudio2017 : XTPControlTheme.h
  • xtpControlThemeVisualStudio2019 : XTPControlTheme.h
  • xtpControlThemeVisualStudio2022 : XTPControlTheme.h
  • xtpDatePickerBorder3D : XTPDatePickerControl.h
  • xtpDatePickerBorderNone : XTPDatePickerControl.h
  • xtpDatePickerBorderOffice : XTPDatePickerControl.h
  • xtpDatePickerBorderStatic : XTPDatePickerControl.h
  • XTPDoodleCircles : XTPCommandBarsOffice2013Theme.h
  • XTPDoodleDiamonds : XTPCommandBarsOffice2013Theme.h
  • xtpDTScale_Day : XTPCalendarTimeLineViewTimeScale.h
  • xtpDTScale_Hour : XTPCalendarTimeLineViewTimeScale.h
  • xtpDTScale_Min : XTPCalendarTimeLineViewTimeScale.h
  • xtpDTScale_Month : XTPCalendarTimeLineViewTimeScale.h
  • xtpDTScale_Sec : XTPCalendarTimeLineViewTimeScale.h
  • xtpDTScale_Unknown : XTPCalendarTimeLineViewTimeScale.h
  • xtpDTScale_Week : XTPCalendarTimeLineViewTimeScale.h
  • xtpDTScale_WorkWeek : XTPCalendarTimeLineViewTimeScale.h
  • xtpDTScale_Year : XTPCalendarTimeLineViewTimeScale.h
  • xtpEditActDelete : XTPSyntaxEditDefines.h
  • xtpEditActInsert : XTPSyntaxEditDefines.h
  • xtpEditAllConfigWasChanged : XTPSyntaxEditDefines.h
  • xtpEditCfgFileAdd : XTPSyntaxEditLexColorFileReader.h
  • xtpEditCfgFileRemove : XTPSyntaxEditLexColorFileReader.h
  • xtpEditClassSchWasChanged : XTPSyntaxEditDefines.h
  • xtpEditCRLFStyleDos : XTPSyntaxEditDefines.h
  • xtpEditCRLFStyleMac : XTPSyntaxEditDefines.h
  • xtpEditCRLFStyleUnix : XTPSyntaxEditDefines.h
  • xtpEditCRLFStyleUnknown : XTPSyntaxEditDefines.h
  • xtpEditDelPosAfter : XTPSyntaxEditDefines.h
  • xtpEditDelPosBefore : XTPSyntaxEditDefines.h
  • xtpEditHintInitView : XTPSyntaxEditDefines.h
  • xtpEditHintInvalidate : XTPSyntaxEditDefines.h
  • xtpEditHintLast : XTPSyntaxEditDefines.h
  • xtpEditHintRefreshView : XTPSyntaxEditDefines.h
  • xtpEditHintSetAutoIndent : XTPSyntaxEditDefines.h
  • xtpEditHintSetFont : XTPSyntaxEditDefines.h
  • xtpEditHintSetLineNum : XTPSyntaxEditDefines.h
  • xtpEditHintSetSelMargin : XTPSyntaxEditDefines.h
  • xtpEditHintSetSyntaxColor : XTPSyntaxEditDefines.h
  • xtpEditHintUnknown : XTPSyntaxEditDefines.h
  • xtpEditHintUpdateScrollPos : XTPSyntaxEditDefines.h
  • xtpEditLMRefresh_Delete : XTPSyntaxEditLineMarksManager.h
  • xtpEditLMRefresh_Delete_only1 : XTPSyntaxEditLineMarksManager.h
  • xtpEditLMRefresh_Delete_only2 : XTPSyntaxEditLineMarksManager.h
  • xtpEditLMRefresh_Insert : XTPSyntaxEditLineMarksManager.h
  • xtpEditLMRefresh_InsertAt0 : XTPSyntaxEditLineMarksManager.h
  • xtpEditLMRefresh_Unknown : XTPSyntaxEditLineMarksManager.h
  • xtpEditLPR_EndFound : XTPSyntaxEditLexParser.h
  • xtpEditLPR_Error : XTPSyntaxEditLexParser.h
  • xtpEditLPR_Iterated : XTPSyntaxEditLexParser.h
  • xtpEditLPR_RunBreaked : XTPSyntaxEditLexParser.h
  • xtpEditLPR_RunFinished : XTPSyntaxEditLexParser.h
  • xtpEditLPR_RunRestart : XTPSyntaxEditLexParser.h
  • xtpEditLPR_StartFound : XTPSyntaxEditLexParser.h
  • xtpEditLPR_TBpop1 : XTPSyntaxEditLexParser.h
  • xtpEditLPR_Unknown : XTPSyntaxEditLexParser.h
  • xtpEditLVT_className : XTPSyntaxEditLexClass.h
  • xtpEditLVT_classPtr : XTPSyntaxEditLexClass.h
  • xtpEditLVT_LVArrayPtr : XTPSyntaxEditLexClass.h
  • xtpEditLVT_Unknown : XTPSyntaxEditLexClass.h
  • xtpEditLVT_valInt : XTPSyntaxEditLexClass.h
  • xtpEditLVT_valStr : XTPSyntaxEditLexClass.h
  • xtpEditLVT_valVar : XTPSyntaxEditLexClass.h
  • xtpEditOnParserEnded : XTPSyntaxEditDefines.h
  • xtpEditOnParserStarted : XTPSyntaxEditDefines.h
  • xtpEditOnTextBlockParsed : XTPSyntaxEditDefines.h
  • xtpEditOptChildren_Any : XTPSyntaxEditLexClass.h
  • xtpEditOptChildren_List : XTPSyntaxEditLexClass.h
  • xtpEditOptChildren_No : XTPSyntaxEditLexClass.h
  • xtpEditOptChildren_Unknown : XTPSyntaxEditLexClass.h
  • xtpEditOptParent_Default : XTPSyntaxEditLexClass.h
  • xtpEditOptParent_direct : XTPSyntaxEditLexClass.h
  • xtpEditOptParent_dyn : XTPSyntaxEditLexClass.h
  • xtpEditOptParent_file : XTPSyntaxEditLexClass.h
  • xtpEditOptParent_Unknown : XTPSyntaxEditLexClass.h
  • xtpEditThemeWasChanged : XTPSyntaxEditDefines.h
  • xtpExecuteCommand : XTPRibbonBackstageView.h
  • xtpFindTypeDrive : XTPShellTreeBase.h
  • xtpFindTypeFolder : XTPShellTreeBase.h
  • xtpFindTypeRoot : XTPShellTreeBase.h
  • xtpFindTypeShare : XTPShellTreeBase.h
  • xtpFirstLevel : XTPRibbonBackstageView.h
  • xtpFlagAddMDISysPopup : XTPCommandBarsDefines.h
  • xtpFlagAlignAny : XTPCommandBarsDefines.h
  • xtpFlagAlignBottom : XTPCommandBarsDefines.h
  • xtpFlagAlignLeft : XTPCommandBarsDefines.h
  • xtpFlagAlignRight : XTPCommandBarsDefines.h
  • xtpFlagAlignTop : XTPCommandBarsDefines.h
  • xtpFlagControlStretched : XTPCommandBarsDefines.h
  • xtpFlagFloating : XTPCommandBarsDefines.h
  • xtpFlagHideClose : XTPCommandBarsDefines.h
  • xtpFlagHideMaximizeBox : XTPCommandBarsDefines.h
  • xtpFlagHideMDIButtons : XTPCommandBarsDefines.h
  • xtpFlagHideMinimizeBox : XTPCommandBarsDefines.h
  • xtpFlagHideWrap : XTPCommandBarsDefines.h
  • xtpFlagIgnoreSetMenuMessage : XTPCommandBarsDefines.h
  • xtpFlagLeftPopup : XTPCommandBarsDefines.h
  • xtpFlagManualUpdate : XTPCommandBarsDefines.h
  • xtpFlagNoBorders : XTPCommandBarsDefines.h
  • xtpFlagNoMovable : XTPCommandBarsDefines.h
  • xtpFlagRibbonTabBackground : XTPCommandBarsDefines.h
  • xtpFlagRightAlign : XTPCommandBarsDefines.h
  • xtpFlagShowPopupBarTip : XTPCommandBarsDefines.h
  • xtpFlagSkipFocus : XTPCommandBarsDefines.h
  • xtpFlagSmartLayout : XTPCommandBarsDefines.h
  • xtpFlagStretched : XTPCommandBarsDefines.h
  • xtpFlagStretchedShared : XTPCommandBarsDefines.h
  • xtpFlagUseMDIMenus : XTPCommandBarsDefines.h
  • xtpFlagWrapRow : XTPCommandBarsDefines.h
  • xtpFlowGraphConnectorCurved : XTPFlowGraphPaintManager.h
  • xtpFlowGraphConnectorCurvedArrow : XTPFlowGraphPaintManager.h
  • xtpFlowGraphConnectorCurvedDoubleArrow : XTPFlowGraphPaintManager.h
  • xtpFlowGraphConnectorElbow : XTPFlowGraphPaintManager.h
  • xtpFlowGraphConnectorElbowArrow : XTPFlowGraphPaintManager.h
  • xtpFlowGraphConnectorElbowDoubleArrow : XTPFlowGraphPaintManager.h
  • xtpFlowGraphConnectorStraight : XTPFlowGraphPaintManager.h
  • xtpFlowGraphConnectorStraightArrow : XTPFlowGraphPaintManager.h
  • xtpFlowGraphConnectorStraightDoubleArrow : XTPFlowGraphPaintManager.h
  • xtpFlowGraphCustomNodeCaptionBelow : XTPFlowGraphNodeCustom.h
  • xtpFlowGraphCustomNodeCaptionCenter : XTPFlowGraphNodeCustom.h
  • xtpFlowGraphCustomNodeFillGradientCenterHorizontal : XTPFlowGraphNodeCustom.h
  • xtpFlowGraphCustomNodeFillGradientCenterVertical : XTPFlowGraphNodeCustom.h
  • xtpFlowGraphCustomNodeFillGradientDiagonalLeft : XTPFlowGraphNodeCustom.h
  • xtpFlowGraphCustomNodeFillGradientDiagonalRight : XTPFlowGraphNodeCustom.h
  • xtpFlowGraphCustomNodeFillGradientHorizontal : XTPFlowGraphNodeCustom.h
  • xtpFlowGraphCustomNodeFillGradientVertical : XTPFlowGraphNodeCustom.h
  • xtpFlowGraphCustomNodeFillSolid : XTPFlowGraphNodeCustom.h
  • xtpFlowGraphPointBoth : XTPFlowGraphNode.h
  • xtpFlowGraphPointInput : XTPFlowGraphNode.h
  • xtpFlowGraphPointInputAndOutput : XTPFlowGraphNode.h
  • xtpFlowGraphPointNone : XTPFlowGraphNode.h
  • xtpFlowGraphPointOutput : XTPFlowGraphNode.h
  • xtpFlowGraphPropertyCanSetColor : XTPFlowGraphControl.h
  • xtpFlowGraphPropertyConnectionPoint : XTPFlowGraphControl.h
  • xtpFlowGraphPropertyConnectionPointIn : XTPFlowGraphControl.h
  • xtpFlowGraphPropertyConnectionPointType : XTPFlowGraphControl.h
  • xtpFlowGraphPropertyResizable : XTPFlowGraphControl.h
  • xtpFlowGraphResizeBoth : XTPFlowGraphControl.h
  • xtpFlowGraphResizeHorizontal : XTPFlowGraphControl.h
  • xtpFlowGraphResizeNone : XTPFlowGraphControl.h
  • xtpFlowGraphResizeVertical : XTPFlowGraphControl.h
  • xtpFlowGraphSmoothingModeAuto : XTPFlowGraphControl.h
  • xtpFlowGraphSmoothingModeGDI : XTPFlowGraphControl.h
  • xtpFlowGraphSmoothingModeHighQuality : XTPFlowGraphControl.h
  • xtpFlowGraphSmoothingModeHighSpeed : XTPFlowGraphControl.h
  • xtpFlowGraphTemplateNode : XTPFlowGraphControl.h
  • xtpFlowGraphTemplateNodePointIn : XTPFlowGraphControl.h
  • xtpFlowGraphTemplateNodePointInOut : XTPFlowGraphControl.h
  • xtpFlowGraphTemplateNodePointNone : XTPFlowGraphControl.h
  • xtpFlowGraphTemplateNodePointOut : XTPFlowGraphControl.h
  • xtpFontBoth : XTPFontComboBox.h
  • xtpFontGUI : XTPFontComboBox.h
  • xtpFontSample : XTPFontComboBox.h
  • xtpFontUnknown : XTPFontComboBox.h
  • xtpFrameShadowsDisabled : XTPFrameShadowManager.h
  • xtpFrameShadowsDisabledInTSS : XTPFrameShadowManager.h
  • xtpFrameShadowsInvisible : XTPFrameShadowManager.h
  • xtpFrameShadowsInvisibleInTSS : XTPFrameShadowManager.h
  • xtpFrameShadowsNotResizeable : XTPFrameShadowManager.h
  • XTPGeometry : XTPCommandBarsOffice2013Theme.h
  • xtpGridAllowDrag : XTPGridControl.h
  • xtpGridAllowDragCopy : XTPGridControl.h
  • xtpGridAllowDragMove : XTPGridControl.h
  • xtpGridAllowDrop : XTPGridControl.h
  • xtpGridBehaviorCodejock1340 : XTPGridBehavior.h
  • xtpGridBehaviorCodejock1341 : XTPGridBehavior.h
  • xtpGridBehaviorCodejock1342 : XTPGridBehavior.h
  • xtpGridBehaviorCodejock1501 : XTPGridBehavior.h
  • xtpGridBehaviorCodejock1502 : XTPGridBehavior.h
  • xtpGridBehaviorCodejockDefault : XTPGridBehavior.h
  • xtpGridBehaviorExcel2003 : XTPGridBehavior.h
  • xtpGridBehaviorExcel2007 : XTPGridBehavior.h
  • xtpGridBehaviorExcel2010 : XTPGridBehavior.h
  • xtpGridBehaviorOutlook2003 : XTPGridBehavior.h
  • xtpGridBehaviorOutlook2007 : XTPGridBehavior.h
  • xtpGridBehaviorOutlook2010 : XTPGridBehavior.h
  • xtpGridBorderEdgeBottom : XTPGridBorder.h
  • xtpGridBorderEdgeCount : XTPGridBorder.h
  • xtpGridBorderEdgeLeft : XTPGridBorder.h
  • xtpGridBorderEdgeRight : XTPGridBorder.h
  • xtpGridBorderEdgeTop : XTPGridBorder.h
  • xtpGridCheckStateChecked : XTPGridDefines.h
  • xtpGridCheckStateCount : XTPGridDefines.h
  • xtpGridCheckStateIndeterminate : XTPGridDefines.h
  • xtpGridCheckStateInvalid : XTPGridDefines.h
  • xtpGridCheckStateUnchecked : XTPGridDefines.h
  • xtpGridColumnAdded : XTPGridHeader.h
  • xtpGridColumnAddedToFieldChooser : XTPGridHeader.h
  • xtpGridColumnAddedToGroupby : XTPGridHeader.h
  • xtpGridColumnCaptionChanged : XTPGridHeader.h
  • xtpGridColumnChangeMask : XTPGridHeader.h
  • xtpGridColumnChangeOther : XTPGridHeader.h
  • xtpGridColumnDirectionLeft : XTPGridHeader.h
  • xtpGridColumnDirectionRight : XTPGridHeader.h
  • xtpGridColumnExplorer : XTPGridDefines.h
  • xtpGridColumnFlat : XTPGridDefines.h
  • xtpGridColumnGroupOrderChanged : XTPGridHeader.h
  • xtpGridColumnHidden : XTPGridHeader.h
  • xtpGridColumnMoved : XTPGridHeader.h
  • xtpGridColumnOffice2003 : XTPGridDefines.h
  • xtpGridColumnOrderChanged : XTPGridHeader.h
  • xtpGridColumnOrderChangedMask : XTPGridHeader.h
  • xtpGridColumnPropExchange : XTPGridHeader.h
  • xtpGridColumnRemoved : XTPGridHeader.h
  • xtpGridColumnRemovedFromFieldChooser : XTPGridHeader.h
  • xtpGridColumnRemovedFromGroupby : XTPGridHeader.h
  • xtpGridColumnResource : XTPGridDefines.h
  • xtpGridColumnShaded : XTPGridDefines.h
  • xtpGridColumnShown : XTPGridHeader.h
  • xtpGridColumnWidthChanged : XTPGridHeader.h
  • xtpGridDontDropAsText : XTPGridControl.h
  • xtpGridDrawSortTriangleAlways : XTPGridDefines.h
  • xtpGridDrawSortTriangleDefault : XTPGridDefines.h
  • xtpGridDrawSortTriangleNever : XTPGridDefines.h
  • xtpGridDropBetween : XTPGridControl.h
  • xtpGridDropSelect : XTPGridControl.h
  • xtpGridElementRectFooterArea : XTPGridControl.h
  • xtpGridElementRectFooterRecordsArea : XTPGridControl.h
  • xtpGridElementRectFooterRecordsDividerArea : XTPGridControl.h
  • xtpGridElementRectGridArea : XTPGridControl.h
  • xtpGridElementRectGroupByArea : XTPGridControl.h
  • xtpGridElementRectHeaderArea : XTPGridControl.h
  • xtpGridElementRectHeaderRecordsArea : XTPGridControl.h
  • xtpGridElementRectHeaderRecordsDividerArea : XTPGridControl.h
  • xtpGridFilterTreeByEndChildrenOnly : XTPGridControl.h
  • xtpGridFilterTreeByParentAndChildren : XTPGridControl.h
  • xtpGridFilterTreeSimple : XTPGridControl.h
  • xtpGridFreezeColsDividerBold : XTPGridDefines.h
  • xtpGridFreezeColsDividerHeader : XTPGridDefines.h
  • xtpGridFreezeColsDividerShade : XTPGridDefines.h
  • xtpGridFreezeColsDividerShowAlways : XTPGridDefines.h
  • xtpGridFreezeColsDividerThin : XTPGridDefines.h
  • xtpGridGlyphColumnExpand : XTPGridDefines.h
  • xtpGridGlyphColumnRestore : XTPGridDefines.h
  • xtpGridGlyphCount : XTPGridDefines.h
  • xtpGridGlyphDisabledChecked : XTPGridDefines.h
  • xtpGridGlyphDisabledUnchecked : XTPGridDefines.h
  • xtpGridGlyphEnabledChecked : XTPGridDefines.h
  • xtpGridGlyphEnabledTristate : XTPGridDefines.h
  • xtpGridGlyphEnabledUnchecked : XTPGridDefines.h
  • xtpGridGlyphInvalid : XTPGridDefines.h
  • xtpGridGlyphItemLocked : XTPGridDefines.h
  • xtpGridGlyphItemUnlocked : XTPGridDefines.h
  • xtpGridGlyphRowCollapse : XTPGridDefines.h
  • xtpGridGlyphRowExpand : XTPGridDefines.h
  • xtpGridGridDashes : XTPGridDefines.h
  • xtpGridGridLargeDots : XTPGridDefines.h
  • xtpGridGridNoLines : XTPGridDefines.h
  • xtpGridGridSmallDots : XTPGridDefines.h
  • xtpGridGridSolid : XTPGridDefines.h
  • xtpGridLineStyleCount : XTPGridDefines.h
  • xtpGridLineStyleDash : XTPGridDefines.h
  • xtpGridLineStyleDotLarge : XTPGridDefines.h
  • xtpGridLineStyleDotSmall : XTPGridDefines.h
  • xtpGridLineStyleNone : XTPGridDefines.h
  • xtpGridLineStyleSolid : XTPGridDefines.h
  • xtpGridMouseButtonLeft : XTPGridBehavior.h
  • xtpGridMouseButtonMiddle : XTPGridBehavior.h
  • xtpGridMouseButtonNone : XTPGridBehavior.h
  • xtpGridMouseButtonRight : XTPGridBehavior.h
  • xtpGridMouseDraggingColumn : XTPGridControl.h
  • xtpGridMouseEventButtonDown : XTPGridBehavior.h
  • xtpGridMouseEventButtonUp : XTPGridBehavior.h
  • xtpGridMouseNothing : XTPGridControl.h
  • xtpGridMouseOverColumnDivide : XTPGridControl.h
  • xtpGridMouseOverRowDivide : XTPGridControl.h
  • xtpGridMousePrepareDragColumn : XTPGridControl.h
  • xtpGridOrientationAll : XTPGridDefines.h
  • xtpGridOrientationHorizontal : XTPGridDefines.h
  • xtpGridOrientationVertical : XTPGridDefines.h
  • xtpGridScrollModeBlock : XTPGridControl.h
  • xtpGridScrollModeBlockCount : XTPGridControl.h
  • xtpGridScrollModeBlockSize : XTPGridControl.h
  • xtpGridScrollModeNone : XTPGridControl.h
  • xtpGridScrollModeSmooth : XTPGridControl.h
  • xtpGridScrollUpdateModeDeferred : XTPGridControl.h
  • xtpGridScrollUpdateModeImmediate : XTPGridControl.h
  • xtpGridSectionBody : XTPGridSections.h
  • xtpGridSectionCount : XTPGridSections.h
  • xtpGridSectionDividerPositionBottom : XTPGridDefines.h
  • xtpGridSectionDividerPositionTop : XTPGridDefines.h
  • xtpGridSectionDividerStyleBold : XTPGridDefines.h
  • xtpGridSectionDividerStyleNone : XTPGridDefines.h
  • xtpGridSectionDividerStyleOutlook : XTPGridDefines.h
  • xtpGridSectionDividerStyleShade : XTPGridDefines.h
  • xtpGridSectionDividerStyleThin : XTPGridDefines.h
  • xtpGridSectionFooter : XTPGridSections.h
  • xtpGridSectionHeader : XTPGridSections.h
  • xtpGridSectionHeightModeAuto : XTPGridSection.h
  • xtpGridSectionHeightModeAutoExpand : XTPGridSection.h
  • xtpGridSectionHeightModeAutoShrink : XTPGridSection.h
  • xtpGridSectionHeightModeExpand : XTPGridSection.h
  • xtpGridSectionHeightModeFixed : XTPGridSection.h
  • xtpGridSectionHeightModeRelative : XTPGridSection.h
  • xtpGridSelectionAdd : XTPGridRows.h
  • xtpGridSelectionClear : XTPGridRows.h
  • xtpGridSelectionRemove : XTPGridRows.h
  • xtpGridShellIconLock : XTPGridDefines.h
  • xtpGridTextDecorationNone : XTPGridDefines.h
  • xtpGridTextDecorationUnderline : XTPGridDefines.h
  • xtpGridTextSearchBackward : XTPGridRecords.h
  • xtpGridTextSearchExactPhrase : XTPGridRecords.h
  • xtpGridTextSearchExactStart : XTPGridRecords.h
  • xtpGridTextSearchMatchCase : XTPGridRecords.h
  • xtpGridThemeDefault : XTPGridDefines.h
  • xtpGridThemeExplorer : XTPGridDefines.h
  • xtpGridThemeNativeWindows10 : XTPGridDefines.h
  • xtpGridThemeNativeWindows11 : XTPGridDefines.h
  • xtpGridThemeOffice2003 : XTPGridDefines.h
  • xtpGridThemeOffice2003Luna : XTPGridDefines.h
  • xtpGridThemeOffice2013 : XTPGridDefines.h
  • xtpGridThemeOffice2016 : XTPGridDefines.h
  • xtpGridThemeOfficeXP : XTPGridDefines.h
  • xtpGridThemeResource : XTPGridDefines.h
  • xtpGridThemeVisualStudio2012Blue : XTPGridDefines.h
  • xtpGridThemeVisualStudio2012Dark : XTPGridDefines.h
  • xtpGridThemeVisualStudio2012Light : XTPGridDefines.h
  • xtpGridThemeVisualStudio2015 : XTPGridDefines.h
  • xtpGridThemeVisualStudio2017 : XTPGridDefines.h
  • xtpGridThemeVisualStudio2019 : XTPGridDefines.h
  • xtpGridThemeVisualStudio2022 : XTPGridDefines.h
  • xtpGridTreeStructureDots : XTPGridDefines.h
  • xtpGridTreeStructureNone : XTPGridDefines.h
  • xtpGridTreeStructureSolid : XTPGridDefines.h
  • xtpGridWatermarkBottom : XTPGridControl.h
  • xtpGridWatermarkCenter : XTPGridControl.h
  • xtpGridWatermarkEnlargeOnly : XTPGridControl.h
  • xtpGridWatermarkHmask : XTPGridControl.h
  • xtpGridWatermarkLeft : XTPGridControl.h
  • xtpGridWatermarkPreserveRatio : XTPGridControl.h
  • xtpGridWatermarkRight : XTPGridControl.h
  • xtpGridWatermarkShrinkOnly : XTPGridControl.h
  • xtpGridWatermarkStretch : XTPGridControl.h
  • xtpGridWatermarkTop : XTPGridControl.h
  • xtpGridWatermarkUnknown : XTPGridControl.h
  • xtpGridWatermarkVCenter : XTPGridControl.h
  • xtpGridWatermarkVmask : XTPGridControl.h
  • xtpGroupBoxBorder : XTPButton.h
  • xtpGroupBoxNone : XTPButton.h
  • xtpGroupBoxSingleLine : XTPButton.h
  • xtpGroupRowIconAfterText : XTPGridRecordItem.h
  • xtpGroupRowIconBeforeText : XTPGridRecordItem.h
  • xtpGroupRowIconHmask : XTPGridRecordItem.h
  • xtpGroupRowIconLeft : XTPGridRecordItem.h
  • xtpGroupRowIconRight : XTPGridRecordItem.h
  • xtpGroupRowIconUnknown : XTPGridRecordItem.h
  • xtpGroupRowIconVBottom : XTPGridRecordItem.h
  • xtpGroupRowIconVCenter : XTPGridRecordItem.h
  • xtpGroupRowIconVCenterToText : XTPGridRecordItem.h
  • xtpGroupRowIconVmask : XTPGridRecordItem.h
  • xtpGroupRowIconVTop : XTPGridRecordItem.h
  • xtpHideCustomize : XTPCommandBarsDefines.h
  • xtpHideDockingPosition : XTPCommandBarsDefines.h
  • xtpHideDocTemplate : XTPCommandBarsDefines.h
  • xtpHideExpand : XTPCommandBarsDefines.h
  • xtpHideGeneric : XTPCommandBarsDefines.h
  • xtpHideRibbonTab : XTPCommandBarsDefines.h
  • xtpHideScroll : XTPCommandBarsDefines.h
  • xtpHideTips : XTPRibbonBackstageView.h
  • xtpHideWrap : XTPCommandBarsDefines.h
  • xtpIconSizeAtLeast : XTPImageManager.h
  • xtpIconSizeAtMost : XTPImageManager.h
  • xtpIconSizeExact : XTPImageManager.h
  • xtpIdleLayout : XTPCommandBarsDefines.h
  • xtpIdleRedraw : XTPCommandBarsDefines.h
  • xtpImageChecked : XTPImageManager.h
  • xtpImageDisabled : XTPImageManager.h
  • xtpImageHot : XTPImageManager.h
  • xtpImageNormal : XTPImageManager.h
  • xtpImagePressed : XTPImageManager.h
  • xtpItemControlLeft : XTPGridRecordItemControls.h
  • xtpItemControlRight : XTPGridRecordItemControls.h
  • xtpItemControlTypeButton : XTPGridRecordItemControls.h
  • xtpItemControlTypeUndefined : XTPGridRecordItemControls.h
  • xtpItemControlUnknown : XTPGridRecordItemControls.h
  • xtpKeyBack : XTPCommandBarsDefines.h
  • xtpKeyboardCuesShowAlways : XTPCommandBarsDefines.h
  • xtpKeyboardCuesShowNever : XTPCommandBarsDefines.h
  • xtpKeyboardCuesShowWindowsDefault : XTPCommandBarsDefines.h
  • xtpKeyboardCuesUseAll : XTPCommandBarsDefines.h
  • xtpKeyboardCuesUseAmpersandOnly : XTPCommandBarsDefines.h
  • xtpKeyboardCuesUseMenuOnly : XTPCommandBarsDefines.h
  • xtpKeyboardCuesUseNone : XTPCommandBarsDefines.h
  • xtpKeyEnd : XTPCommandBarsDefines.h
  • xtpKeyEscape : XTPCommandBarsDefines.h
  • xtpKeyHome : XTPCommandBarsDefines.h
  • xtpKeyLeft : XTPCommandBarsDefines.h
  • xtpKeyNext : XTPCommandBarsDefines.h
  • xtpKeyPopup : XTPCommandBarsDefines.h
  • xtpKeyPrev : XTPCommandBarsDefines.h
  • xtpKeyReturn : XTPCommandBarsDefines.h
  • xtpKeyRight : XTPCommandBarsDefines.h
  • xtpKeySpace : XTPCommandBarsDefines.h
  • xtpListBoxNativeWindows10 : XTPListBox.h
  • xtpListBoxNativeWindows11 : XTPListBox.h
  • xtpListBoxOffice2007 : XTPListBox.h
  • xtpListBoxOffice2013 : XTPListBox.h
  • xtpListBoxOffice2016 : XTPListBox.h
  • xtpListBoxOfficeXP : XTPListBox.h
  • xtpListBoxStandard : XTPListBox.h
  • xtpListBoxVisualStudio2015 : XTPListBox.h
  • xtpListBoxVisualStudio2017 : XTPListBox.h
  • xtpListBoxVisualStudio2019 : XTPListBox.h
  • xtpListBoxVisualStudio2022 : XTPListBox.h
  • XTPLunchBox : XTPCommandBarsOffice2013Theme.h
  • xtpMarkupDockBottom : XTPMarkupDockPanel.h
  • xtpMarkupDockLeft : XTPMarkupDockPanel.h
  • xtpMarkupDockRight : XTPMarkupDockPanel.h
  • xtpMarkupDockTop : XTPMarkupDockPanel.h
  • xtpMarkupPathPointTypeBezier : XTPMarkupPathGeometryBuilder.h
  • xtpMarkupPathPointTypeCloseSubpath : XTPMarkupPathGeometryBuilder.h
  • xtpMarkupPathPointTypeLine : XTPMarkupPathGeometryBuilder.h
  • xtpMarkupPathPointTypeStart : XTPMarkupPathGeometryBuilder.h
  • xtpMarkupSmoothingAntiAlias : XTPMarkupContext.h
  • xtpMarkupSmoothingDefault : XTPMarkupContext.h
  • xtpMarkupSmoothingHighQuality : XTPMarkupContext.h
  • xtpMarkupSmoothingHighSpeed : XTPMarkupContext.h
  • xtpMarkupSmoothingNone : XTPMarkupContext.h
  • xtpMarkupTextNoWrap : XTPMarkupTextBlock.h
  • xtpMarkupTextTrimmingCharacterEllipsis : XTPMarkupTextBlock.h
  • xtpMarkupTextTrimmingNone : XTPMarkupTextBlock.h
  • xtpMarkupTextTrimmingWordEllipsis : XTPMarkupTextBlock.h
  • xtpMarkupTextWrap : XTPMarkupTextBlock.h
  • xtpMarkupTextWrapWithOverflow : XTPMarkupTextBlock.h
  • xtpNavBtnArrows : XTPTabBase.h
  • xtpNavBtnClose : XTPTabBase.h
  • xtpNavBtnShowAll : XTPTabBase.h
  • xtpNoActionForThisLevel : XTPRibbonBackstageView.h
  • xtpNoHide : XTPCommandBarsDefines.h
  • XTPNone : XTPCommandBarsOffice2013Theme.h
  • xtpNotifyDirectCallForOneThread : XTPNotifyConnection.h
  • xtpNotifyGuarantyPost : XTPNotifyConnection.h
  • xtpNotifyPostMessage : XTPNotifyConnection.h
  • xtpNoTips : XTPRibbonBackstageView.h
  • xtpPageBorderBottomLine : XTPPropertySheet.h
  • xtpPageBorderFrame : XTPPropertySheet.h
  • xtpPageBorderNone : XTPPropertySheet.h
  • xtpPaintManagerAccentColor : XTPColorManager.h
  • xtpPaintManagerHighlightBackAccentColor : XTPColorManager.h
  • xtpPaintManagerHighlightTextAccentColor : XTPColorManager.h
  • xtpPaintManagerNormalBackAccentColor : XTPColorManager.h
  • xtpPaintManagerNormalTextAccentColor : XTPColorManager.h
  • xtpPaintManagerPressedBackAccentColor : XTPColorManager.h
  • xtpPaintManagerPressedTextAccentColor : XTPColorManager.h
  • xtpPaneActionActivated : XTPDockingPaneDefines.h
  • xtpPaneActionAttached : XTPDockingPaneDefines.h
  • xtpPaneActionAttaching : XTPDockingPaneDefines.h
  • xtpPaneActionClosed : XTPDockingPaneDefines.h
  • xtpPaneActionClosing : XTPDockingPaneDefines.h
  • xtpPaneActionCollapsed : XTPDockingPaneDefines.h
  • xtpPaneActionCollapsing : XTPDockingPaneDefines.h
  • xtpPaneActionDeactivated : XTPDockingPaneDefines.h
  • xtpPaneActionDetaching : XTPDockingPaneDefines.h
  • xtpPaneActionDocked : XTPDockingPaneDefines.h
  • xtpPaneActionDocking : XTPDockingPaneDefines.h
  • xtpPaneActionDragging : XTPDockingPaneDefines.h
  • xtpPaneActionExpanded : XTPDockingPaneDefines.h
  • xtpPaneActionExpanding : XTPDockingPaneDefines.h
  • xtpPaneActionFloated : XTPDockingPaneDefines.h
  • xtpPaneActionFloating : XTPDockingPaneDefines.h
  • xtpPaneActionPinned : XTPDockingPaneDefines.h
  • xtpPaneActionPinning : XTPDockingPaneDefines.h
  • xtpPaneActionSplitterResized : XTPDockingPaneDefines.h
  • xtpPaneActionSplitterResizing : XTPDockingPaneDefines.h
  • xtpPaneActionUnpinned : XTPDockingPaneDefines.h
  • xtpPaneActionUnpinning : XTPDockingPaneDefines.h
  • xtpPaneCaptionAutoByPosition : XTPDockingPaneDefines.h
  • xtpPaneCaptionAutoBySize : XTPDockingPaneDefines.h
  • xtpPaneCaptionButtonDefault : XTPDockingPanePaintManager.h
  • xtpPaneCaptionButtonOffice : XTPDockingPanePaintManager.h
  • xtpPaneCaptionButtonOffice2003 : XTPDockingPanePaintManager.h
  • xtpPaneCaptionButtonThemedButton : XTPDockingPanePaintManager.h
  • xtpPaneCaptionButtonThemedExplorerBar : XTPDockingPanePaintManager.h
  • xtpPaneCaptionButtonThemedToolBar : XTPDockingPanePaintManager.h
  • xtpPaneCaptionButtonThemedToolWindow : XTPDockingPanePaintManager.h
  • xtpPaneCaptionHorizontal : XTPDockingPaneDefines.h
  • xtpPaneCaptionVertical : XTPDockingPaneDefines.h
  • xtpPaneDisabled : XTPDockingPaneDefines.h
  • xtpPaneDockBottom : XTPDockingPaneDefines.h
  • xtpPaneDockLeft : XTPDockingPaneDefines.h
  • xtpPaneDockMiniWnd : XTPDockingPaneDefines.h
  • xtpPaneDockRight : XTPDockingPaneDefines.h
  • xtpPaneDockTop : XTPDockingPaneDefines.h
  • xtpPaneDockUndefined : XTPDockingPaneDefines.h
  • xtpPaneEnableActions : XTPDockingPaneDefines.h
  • xtpPaneEnableClient : XTPDockingPaneDefines.h
  • xtpPaneEnabled : XTPDockingPaneDefines.h
  • xtpPaneEnabledAuto : XTPDockingPaneDefines.h
  • xtpPaneHasMenuButton : XTPDockingPaneDefines.h
  • xtpPaneKeyboardUnused : XTPDockingPaneDefines.h
  • xtpPaneKeyboardUseAll : XTPDockingPaneDefines.h
  • xtpPaneKeyboardUseAltF6 : XTPDockingPaneDefines.h
  • xtpPaneKeyboardUseAltF7 : XTPDockingPaneDefines.h
  • xtpPaneKeyboardUseAltMinus : XTPDockingPaneDefines.h
  • xtpPaneKeyboardUseCtrlTab : XTPDockingPaneDefines.h
  • xtpPaneNoCaption : XTPDockingPaneDefines.h
  • xtpPaneNoCloseable : XTPDockingPaneDefines.h
  • xtpPaneNoDockable : XTPDockingPaneDefines.h
  • xtpPaneNoFloatable : XTPDockingPaneDefines.h
  • xtpPaneNoFloatableByCaptionDoubleClick : XTPDockingPaneDefines.h
  • xtpPaneNoFloatableByTabDoubleClick : XTPDockingPaneDefines.h
  • xtpPaneNoHideable : XTPDockingPaneDefines.h
  • xtpPaneNoHoverShow : XTPDockingPaneDefines.h
  • xtpPanePinPushed : XTPDockingPanePaintManager.h
  • xtpPanePinVisible : XTPDockingPanePaintManager.h
  • xtpPaneSplitter3D : XTPDockingPanePaintManager.h
  • xtpPaneSplitterFlat : XTPDockingPanePaintManager.h
  • xtpPaneSplitterGradient : XTPDockingPanePaintManager.h
  • xtpPaneSplitterGradientVert : XTPDockingPanePaintManager.h
  • xtpPaneSplitterGripperOffice2003 : XTPDockingPanePaintManager.h
  • xtpPaneSplitterGripperOfficeXP : XTPDockingPanePaintManager.h
  • xtpPaneSplitterSoft3D : XTPDockingPanePaintManager.h
  • xtpPaneStickerBottom : XTPDockingPaneDefines.h
  • xtpPaneStickerCenter : XTPDockingPaneDefines.h
  • xtpPaneStickerClient : XTPDockingPaneDefines.h
  • xtpPaneStickerLeft : XTPDockingPaneDefines.h
  • xtpPaneStickerNone : XTPDockingPaneDefines.h
  • xtpPaneStickerRight : XTPDockingPaneDefines.h
  • xtpPaneStickerStyleNativeWindows10Dark : XTPDockingPaneDefines.h
  • xtpPaneStickerStyleNativeWindows10Light : XTPDockingPaneDefines.h
  • xtpPaneStickerStyleNativeWindows11Dark : XTPDockingPaneDefines.h
  • xtpPaneStickerStyleNativeWindows11Light : XTPDockingPaneDefines.h
  • xtpPaneStickerStyleVisualStudio2005 : XTPDockingPaneDefines.h
  • xtpPaneStickerStyleVisualStudio2005Beta : XTPDockingPaneDefines.h
  • xtpPaneStickerStyleVisualStudio2008 : XTPDockingPaneDefines.h
  • xtpPaneStickerStyleVisualStudio2010 : XTPDockingPaneDefines.h
  • xtpPaneStickerStyleVisualStudio2012Dark : XTPDockingPaneDefines.h
  • xtpPaneStickerStyleVisualStudio2012Light : XTPDockingPaneDefines.h
  • xtpPaneStickerStyleVisualStudio2015Blue : XTPDockingPaneDefines.h
  • xtpPaneStickerStyleVisualStudio2015Dark : XTPDockingPaneDefines.h
  • xtpPaneStickerStyleVisualStudio2015Light : XTPDockingPaneDefines.h
  • xtpPaneStickerStyleVisualStudio2017Blue : XTPDockingPaneDefines.h
  • xtpPaneStickerStyleVisualStudio2017BlueExtra : XTPDockingPaneDefines.h
  • xtpPaneStickerStyleVisualStudio2017Dark : XTPDockingPaneDefines.h
  • xtpPaneStickerStyleVisualStudio2017Light : XTPDockingPaneDefines.h
  • xtpPaneStickerStyleVisualStudio2019Blue : XTPDockingPaneDefines.h
  • xtpPaneStickerStyleVisualStudio2019BlueExtra : XTPDockingPaneDefines.h
  • xtpPaneStickerStyleVisualStudio2019Dark : XTPDockingPaneDefines.h
  • xtpPaneStickerStyleVisualStudio2019Light : XTPDockingPaneDefines.h
  • xtpPaneStickerStyleVisualStudio2022Blue : XTPDockingPaneDefines.h
  • xtpPaneStickerStyleVisualStudio2022BlueExtra : XTPDockingPaneDefines.h
  • xtpPaneStickerStyleVisualStudio2022Dark : XTPDockingPaneDefines.h
  • xtpPaneStickerStyleVisualStudio2022Light : XTPDockingPaneDefines.h
  • xtpPaneStickerTop : XTPDockingPaneDefines.h
  • xtpPaneThemeCustom : XTPDockingPaneDefines.h
  • xtpPaneThemeDefault : XTPDockingPaneDefines.h
  • xtpPaneThemeGrippered : XTPDockingPaneDefines.h
  • xtpPaneThemeNativeWindows10 : XTPDockingPaneDefines.h
  • xtpPaneThemeNativeWindows11 : XTPDockingPaneDefines.h
  • xtpPaneThemeOffice2002Visio : XTPDockingPaneDefines.h
  • xtpPaneThemeOffice2003 : XTPDockingPaneDefines.h
  • xtpPaneThemeOffice2003Outlook : XTPDockingPaneDefines.h
  • xtpPaneThemeOffice2003Visio : XTPDockingPaneDefines.h
  • xtpPaneThemeOffice2007Outlook : XTPDockingPaneDefines.h
  • xtpPaneThemeOffice2007Visio : XTPDockingPaneDefines.h
  • xtpPaneThemeOffice2007Word : XTPDockingPaneDefines.h
  • xtpPaneThemeOffice2013 : XTPDockingPaneDefines.h
  • xtpPaneThemeOffice2016 : XTPDockingPaneDefines.h
  • xtpPaneThemeResource : XTPDockingPaneDefines.h
  • xtpPaneThemeVisualStudio2003 : XTPDockingPaneDefines.h
  • xtpPaneThemeVisualStudio2005 : XTPDockingPaneDefines.h
  • xtpPaneThemeVisualStudio2005Beta1 : XTPDockingPaneDefines.h
  • xtpPaneThemeVisualStudio2005Beta2 : XTPDockingPaneDefines.h
  • xtpPaneThemeVisualStudio2008 : XTPDockingPaneDefines.h
  • xtpPaneThemeVisualStudio2010 : XTPDockingPaneDefines.h
  • xtpPaneThemeVisualStudio2012 : XTPDockingPaneDefines.h
  • xtpPaneThemeVisualStudio2015 : XTPDockingPaneDefines.h
  • xtpPaneThemeVisualStudio2017 : XTPDockingPaneDefines.h
  • xtpPaneThemeVisualStudio2019 : XTPDockingPaneDefines.h
  • xtpPaneThemeVisualStudio2022 : XTPDockingPaneDefines.h
  • xtpPaneThemeVisualStudio6 : XTPDockingPaneDefines.h
  • xtpPaneThemeWinExplorer : XTPDockingPaneDefines.h
  • xtpPaneThemeWinNative : XTPDockingPaneDefines.h
  • xtpPaneTypeAutoHidePanel : XTPDockingPaneDefines.h
  • xtpPaneTypeClient : XTPDockingPaneDefines.h
  • xtpPaneTypeDockingPane : XTPDockingPaneDefines.h
  • xtpPaneTypeMiniWnd : XTPDockingPaneDefines.h
  • xtpPaneTypeSidePanel : XTPDockingPaneDefines.h
  • xtpPaneTypeSplitterContainer : XTPDockingPaneDefines.h
  • xtpPaneTypeTabbedContainer : XTPDockingPaneDefines.h
  • xtpPopupAnimationFade : XTPPopupControl.h
  • xtpPopupAnimationNone : XTPPopupControl.h
  • xtpPopupAnimationSlide : XTPPopupControl.h
  • xtpPopupAnimationUnfold : XTPPopupControl.h
  • xtpPopupDown : XTPCommandBarsDefines.h
  • xtpPopupItemIconNormal : XTPPopupItem.h
  • xtpPopupItemIconPressed : XTPPopupItem.h
  • xtpPopupItemIconSelected : XTPPopupItem.h
  • xtpPopupLeft : XTPCommandBarsDefines.h
  • xtpPopupLocationBottomRight : XTPPopupControl.h
  • xtpPopupLocationCenter : XTPPopupControl.h
  • xtpPopupLocationNearTaskBar : XTPPopupControl.h
  • xtpPopupRight : XTPCommandBarsDefines.h
  • xtpPopupStateClosed : XTPPopupControl.h
  • xtpPopupStateCollapsing : XTPPopupControl.h
  • xtpPopupStateExpanding : XTPPopupControl.h
  • xtpPopupStateShow : XTPPopupControl.h
  • xtpPopupThemeCustom : XTPPopupControl.h
  • xtpPopupThemeMSN : XTPPopupControl.h
  • xtpPopupThemeOffice2000 : XTPPopupControl.h
  • xtpPopupThemeOffice2003 : XTPPopupControl.h
  • xtpPopupThemeOffice2013 : XTPPopupControl.h
  • xtpPopupThemeOffice2016 : XTPPopupControl.h
  • xtpPopupThemeOfficeXP : XTPPopupControl.h
  • xtpPopupThemeResource : XTPPopupControl.h
  • xtpPopupUp : XTPCommandBarsDefines.h
  • xtpPropertyGridBorderClientEdge : XTPPropertyGridDefines.h
  • xtpPropertyGridBorderFlat : XTPPropertyGridDefines.h
  • xtpPropertyGridBorderNone : XTPPropertyGridDefines.h
  • xtpPropertyGridBorderStaticEdge : XTPPropertyGridDefines.h
  • xtpPropertyGridButtonsDefault : XTPPropertyGridDefines.h
  • xtpPropertyGridButtonsOfficeXP : XTPPropertyGridDefines.h
  • xtpPropertyGridButtonsThemed : XTPPropertyGridDefines.h
  • xtpPropertyGridGridWindow : XTPPropertyGridPaintManager.h
  • xtpPropertyGridHelpWindow : XTPPropertyGridPaintManager.h
  • xtpPropertyGridHitError : XTPPropertyGrid.h
  • xtpPropertyGridHitFirstVerb : XTPPropertyGrid.h
  • xtpPropertyGridHitHelpSplitter : XTPPropertyGrid.h
  • xtpPropertyGridHitVerbsSplitter : XTPPropertyGrid.h
  • xtpPropertyGridItemColorExtendedDialog : XTPPropertyGridItemColor.h
  • xtpPropertyGridItemColorPopup : XTPPropertyGridItemColor.h
  • xtpPropertyGridItemColorStandardDialog : XTPPropertyGridItemColor.h
  • xtpPropertyGridItemHasComboButton : XTPPropertyGridItem.h
  • xtpPropertyGridItemHasEdit : XTPPropertyGridItem.h
  • xtpPropertyGridItemHasExpandButton : XTPPropertyGridItem.h
  • xtpPropertyGridSortAlphabetical : XTPPropertyGridDefines.h
  • xtpPropertyGridSortCategorized : XTPPropertyGridDefines.h
  • xtpPropertyGridSortNoSort : XTPPropertyGridDefines.h
  • xtpPropertyGridThemeCool : XTPPropertyGridDefines.h
  • xtpPropertyGridThemeDefault : XTPPropertyGridDefines.h
  • xtpPropertyGridThemeDelphi : XTPPropertyGridDefines.h
  • xtpPropertyGridThemeNativeWindows10 : XTPPropertyGridDefines.h
  • xtpPropertyGridThemeNativeWindows11 : XTPPropertyGridDefines.h
  • xtpPropertyGridThemeNativeWinXP : XTPPropertyGridDefines.h
  • xtpPropertyGridThemeOffice2003 : XTPPropertyGridDefines.h
  • xtpPropertyGridThemeOffice2013 : XTPPropertyGridDefines.h
  • xtpPropertyGridThemeOffice2016 : XTPPropertyGridDefines.h
  • xtpPropertyGridThemeOfficeXP : XTPPropertyGridDefines.h
  • xtpPropertyGridThemeResource : XTPPropertyGridDefines.h
  • xtpPropertyGridThemeSimple : XTPPropertyGridDefines.h
  • xtpPropertyGridThemeVisualStudio2005 : XTPPropertyGridDefines.h
  • xtpPropertyGridThemeVisualStudio2010 : XTPPropertyGridDefines.h
  • xtpPropertyGridThemeVisualStudio2012Dark : XTPPropertyGridDefines.h
  • xtpPropertyGridThemeVisualStudio2012Light : XTPPropertyGridDefines.h
  • xtpPropertyGridThemeVisualStudio2015 : XTPPropertyGridDefines.h
  • xtpPropertyGridThemeVisualStudio2017 : XTPPropertyGridDefines.h
  • xtpPropertyGridThemeVisualStudio2019 : XTPPropertyGridDefines.h
  • xtpPropertyGridThemeVisualStudio2022 : XTPPropertyGridDefines.h
  • xtpPropertyGridUIInplaceButton : XTPPropertyGrid.h
  • xtpPropertyGridUIInplaceControl : XTPPropertyGrid.h
  • xtpPropertyGridUIInplaceEdit : XTPPropertyGrid.h
  • xtpPropertyGridUIParentNext : XTPPropertyGrid.h
  • xtpPropertyGridUIParentPrev : XTPPropertyGrid.h
  • xtpPropertyGridUIVerb : XTPPropertyGrid.h
  • xtpPropertyGridUIView : XTPPropertyGrid.h
  • xtpPropertyGridUIViewNext : XTPPropertyGrid.h
  • xtpPropertyGridUIViewPrev : XTPPropertyGrid.h
  • xtpPropertyGridVerbWindow : XTPPropertyGridPaintManager.h
  • xtpResizeNoClipChildren : XTPResize.h
  • xtpResizeNoHorizontal : XTPResize.h
  • xtpResizeNoMinsize : XTPResize.h
  • xtpResizeNoSizeIcon : XTPResize.h
  • xtpResizeNoTransparentGroup : XTPResize.h
  • xtpResizeNoVertical : XTPResize.h
  • xtpRibbonBackstageOffice2010Style : XTPRibbonBackstageView.h
  • xtpRibbonBackstageOffice2013Style : XTPRibbonBackstageView.h
  • xtpRibbonBackstageOffice2016Style : XTPRibbonBackstageView.h
  • xtpRibbonContextTabBlue : XTPRibbonMarkupTheme.h
  • xtpRibbonContextTabCyan : XTPRibbonMarkupTheme.h
  • xtpRibbonContextTabGreen : XTPRibbonMarkupTheme.h
  • xtpRibbonContextTabOrange : XTPRibbonMarkupTheme.h
  • xtpRibbonContextTabPurple : XTPRibbonMarkupTheme.h
  • xtpRibbonContextTabRed : XTPRibbonMarkupTheme.h
  • xtpRibbonContextTabYellow : XTPRibbonMarkupTheme.h
  • xtpRibbonFrameCaptionActive : XTPRibbonMarkupTheme.h
  • xtpRibbonFrameCaptionBackstageLeft : XTPRibbonMarkupTheme.h
  • xtpRibbonFrameCaptionBackstageRight : XTPRibbonMarkupTheme.h
  • xtpRibbonFrameCaptionInactive : XTPRibbonMarkupTheme.h
  • xtpRibbonFrameSystemButtonNormal : XTPRibbonMarkupTheme.h
  • xtpRibbonFrameSystemButtonPopuped : XTPRibbonMarkupTheme.h
  • xtpRibbonFrameSystemButtonSelected : XTPRibbonMarkupTheme.h
  • xtpRibbonGroupControlEntry : XTPRibbonMarkupTheme.h
  • xtpRibbonGroupControlEntryLeft : XTPRibbonMarkupTheme.h
  • xtpRibbonGroupControlEntryLeftRight : XTPRibbonMarkupTheme.h
  • xtpRibbonGroupControlEntryRight : XTPRibbonMarkupTheme.h
  • xtpRibbonGroupFullCaptionDontHide : XTPRibbonGroup.h
  • xtpRibbonGroupFullReduction : XTPRibbonGroup.h
  • xtpRibbonGroupRect : XTPRibbonMarkupTheme.h
  • xtpRibbonGroupRectBlue : XTPRibbonMarkupTheme.h
  • xtpRibbonGroupRectCyan : XTPRibbonMarkupTheme.h
  • xtpRibbonGroupRectGreen : XTPRibbonMarkupTheme.h
  • xtpRibbonGroupRectOrange : XTPRibbonMarkupTheme.h
  • xtpRibbonGroupRectPurple : XTPRibbonMarkupTheme.h
  • xtpRibbonGroupRectRed : XTPRibbonMarkupTheme.h
  • xtpRibbonGroupRectYellow : XTPRibbonMarkupTheme.h
  • xtpRibbonGroupReduceCaptionDontHide : XTPRibbonGroup.h
  • xtpRibbonGroupReductionDisabled : XTPRibbonGroup.h
  • xtpRibbonScrollButtonLeft : XTPRibbonMarkupTheme.h
  • xtpRibbonScrollButtonRight : XTPRibbonMarkupTheme.h
  • xtpRibbonTabContextColorBlue : XTPRibbonTab.h
  • xtpRibbonTabContextColorCyan : XTPRibbonTab.h
  • xtpRibbonTabContextColorGreen : XTPRibbonTab.h
  • xtpRibbonTabContextColorNone : XTPRibbonTab.h
  • xtpRibbonTabContextColorOrange : XTPRibbonTab.h
  • xtpRibbonTabContextColorPurple : XTPRibbonTab.h
  • xtpRibbonTabContextColorRed : XTPRibbonTab.h
  • xtpRibbonTabContextColorYellow : XTPRibbonTab.h
  • xtpRibbonTabHighlighted : XTPRibbonMarkupTheme.h
  • xtpRibbonTabSelected : XTPRibbonMarkupTheme.h
  • xtpRibbonTabSelectedBlue : XTPRibbonMarkupTheme.h
  • xtpRibbonTabSelectedCyan : XTPRibbonMarkupTheme.h
  • xtpRibbonTabSelectedFocused : XTPRibbonMarkupTheme.h
  • xtpRibbonTabSelectedFocusedBlue : XTPRibbonMarkupTheme.h
  • xtpRibbonTabSelectedFocusedCyan : XTPRibbonMarkupTheme.h
  • xtpRibbonTabSelectedFocusedGreen : XTPRibbonMarkupTheme.h
  • xtpRibbonTabSelectedFocusedOrange : XTPRibbonMarkupTheme.h
  • xtpRibbonTabSelectedFocusedPurple : XTPRibbonMarkupTheme.h
  • xtpRibbonTabSelectedFocusedRed : XTPRibbonMarkupTheme.h
  • xtpRibbonTabSelectedFocusedYellow : XTPRibbonMarkupTheme.h
  • xtpRibbonTabSelectedGreen : XTPRibbonMarkupTheme.h
  • xtpRibbonTabSelectedHighlighted : XTPRibbonMarkupTheme.h
  • xtpRibbonTabSelectedHighlightedBlue : XTPRibbonMarkupTheme.h
  • xtpRibbonTabSelectedHighlightedCyan : XTPRibbonMarkupTheme.h
  • xtpRibbonTabSelectedHighlightedGreen : XTPRibbonMarkupTheme.h
  • xtpRibbonTabSelectedHighlightedOrange : XTPRibbonMarkupTheme.h
  • xtpRibbonTabSelectedHighlightedPurple : XTPRibbonMarkupTheme.h
  • xtpRibbonTabSelectedHighlightedRed : XTPRibbonMarkupTheme.h
  • xtpRibbonTabSelectedHighlightedYellow : XTPRibbonMarkupTheme.h
  • xtpRibbonTabSelectedOrange : XTPRibbonMarkupTheme.h
  • xtpRibbonTabSelectedPurple : XTPRibbonMarkupTheme.h
  • xtpRibbonTabSelectedRed : XTPRibbonMarkupTheme.h
  • xtpRibbonTabSelectedYellow : XTPRibbonMarkupTheme.h
  • xtpRibbonThemePartCount : XTPRibbonMarkupTheme.h
  • xtpRichEditWindowClassDefault : XTPSystemHelpers.h
  • xtpRichEditWindowClassVersion10 : XTPSystemHelpers.h
  • xtpRichEditWindowClassVersion20 : XTPSystemHelpers.h
  • xtpRichEditWindowClassVersion30 : XTPSystemHelpers.h
  • xtpRichEditWindowClassVersion31 : XTPSystemHelpers.h
  • xtpRichEditWindowClassVersion40 : XTPSystemHelpers.h
  • xtpRichEditWindowClassVersion41 : XTPSystemHelpers.h
  • xtpRichEditWindowClassVersion50 : XTPSystemHelpers.h
  • xtpRichEditWindowClassVersion60 : XTPSystemHelpers.h
  • xtpRichEditWindowClassVersion70 : XTPSystemHelpers.h
  • xtpRowTypeBody : XTPGridDefines.h
  • xtpRowTypeFooter : XTPGridDefines.h
  • xtpRowTypeHeader : XTPGridDefines.h
  • xtpRowTypeInvalid : XTPGridDefines.h
  • XTPSchoolSupplies : XTPCommandBarsOffice2013Theme.h
  • xtpScrollBarThemeFlat : XTPScrollBase.h
  • xtpScrollBarThemeNativeWindows10 : XTPScrollBase.h
  • xtpScrollBarThemeNativeWindows11 : XTPScrollBase.h
  • xtpScrollBarThemeOffice2000 : XTPScrollBase.h
  • xtpScrollBarThemeOffice2003 : XTPScrollBase.h
  • xtpScrollBarThemeOffice2007Dark : XTPScrollBase.h
  • xtpScrollBarThemeOffice2007Light : XTPScrollBase.h
  • xtpScrollBarThemeOffice2010 : XTPScrollBase.h
  • xtpScrollBarThemeOffice2013 : XTPScrollBase.h
  • xtpScrollBarThemeOffice2016 : XTPScrollBase.h
  • xtpScrollBarThemeOfficeXP : XTPScrollBase.h
  • xtpScrollBarThemeResource : XTPScrollBase.h
  • xtpScrollBarThemeUltraFlat : XTPScrollBase.h
  • xtpScrollBarThemeVisualStudio2002 : XTPScrollBase.h
  • xtpScrollBarThemeVisualStudio2003 : XTPScrollBase.h
  • xtpScrollBarThemeVisualStudio2005 : XTPScrollBase.h
  • xtpScrollBarThemeVisualStudio2008 : XTPScrollBase.h
  • xtpScrollBarThemeVisualStudio2010 : XTPScrollBase.h
  • xtpScrollBarThemeVisualStudio2012Dark : XTPScrollBase.h
  • xtpScrollBarThemeVisualStudio2012Light : XTPScrollBase.h
  • xtpScrollBarThemeVisualStudio2015 : XTPScrollBase.h
  • xtpScrollBarThemeVisualStudio2017 : XTPScrollBase.h
  • xtpScrollBarThemeVisualStudio2019 : XTPScrollBase.h
  • xtpScrollBarThemeVisualStudio2022 : XTPScrollBase.h
  • xtpScrollBarThemeVisualStudio6 : XTPScrollBase.h
  • xtpScrollBarThemeWindowsClassic : XTPScrollBase.h
  • xtpScrollBarThemeWindowsDefault : XTPScrollBase.h
  • xtpScrollStyleDefault : XTPScrollBase.h
  • xtpScrollStyleFlat : XTPScrollBase.h
  • xtpScrollStyleNativeWindows10 : XTPScrollBase.h
  • xtpScrollStyleNativeWindows11 : XTPScrollBase.h
  • xtpScrollStyleOffice : XTPScrollBase.h
  • xtpScrollStyleOffice2007Dark : XTPScrollBase.h
  • xtpScrollStyleOffice2007Light : XTPScrollBase.h
  • xtpScrollStyleSlider : XTPScrollBase.h
  • xtpScrollStyleStandard : XTPScrollBase.h
  • xtpScrollStyleSystem : XTPScrollBase.h
  • xtpScrollStyleVisualStudio2012Dark : XTPScrollBase.h
  • xtpScrollStyleVisualStudio2012Light : XTPScrollBase.h
  • xtpScrollStyleVisualStudio2015 : XTPScrollBase.h
  • xtpScrollStyleVisualStudio2017 : XTPScrollBase.h
  • xtpScrollStyleVisualStudio2019 : XTPScrollBase.h
  • xtpScrollStyleVisualStudio2022 : XTPScrollBase.h
  • xtpSecondLevel : XTPRibbonBackstageView.h
  • xtpSelectTab : XTPRibbonBackstageView.h
  • xtpShadowOfficeAlpha : XTPHookManager.h
  • xtpShadowShowPopupControl : XTPHookManager.h
  • xtpShortcutThemeNativeWindows10 : XTPShortcutBarPaintManager.h
  • xtpShortcutThemeNativeWindows11 : XTPShortcutBarPaintManager.h
  • xtpShortcutThemeNativeWinXP : XTPShortcutBarPaintManager.h
  • xtpShortcutThemeOffice2000 : XTPShortcutBarPaintManager.h
  • xtpShortcutThemeOffice2003 : XTPShortcutBarPaintManager.h
  • xtpShortcutThemeOffice2007 : XTPShortcutBarPaintManager.h
  • xtpShortcutThemeOffice2010 : XTPShortcutBarPaintManager.h
  • xtpShortcutThemeOffice2013 : XTPShortcutBarPaintManager.h
  • xtpShortcutThemeOffice2016 : XTPShortcutBarPaintManager.h
  • xtpShortcutThemeOfficeXP : XTPShortcutBarPaintManager.h
  • xtpShortcutThemeResource : XTPShortcutBarPaintManager.h
  • xtpShortcutThemeVisualStudio2015 : XTPShortcutBarPaintManager.h
  • xtpShortcutThemeVisualStudio2017 : XTPShortcutBarPaintManager.h
  • xtpShortcutThemeVisualStudio2019 : XTPShortcutBarPaintManager.h
  • xtpShortcutThemeVisualStudio2022 : XTPShortcutBarPaintManager.h
  • xtpShowSecondLevel : XTPRibbonBackstageView.h
  • xtpSkinApplyColors : XTPSkinManager.h
  • xtpSkinApplyCommandBarsFrame : XTPSkinManager.h
  • xtpSkinApplyDCs : XTPSkinManager.h
  • xtpSkinApplyFrame : XTPSkinManager.h
  • xtpSkinApplyMenus : XTPSkinManager.h
  • xtpSkinApplyMetrics : XTPSkinManager.h
  • xtpSortDateTime : XTPSortClass.h
  • xtpSortDecimal : XTPSortClass.h
  • xtpSortInt : XTPSortClass.h
  • xtpSortString : XTPSortClass.h
  • xtpSoundMenuCommand : XTPSystemHelpers.h
  • xtpSoundMenuPopup : XTPSystemHelpers.h
  • xtpSoundNone : XTPSystemHelpers.h
  • XTPSpring : XTPCommandBarsOffice2013Theme.h
  • XTPStars : XTPCommandBarsOffice2013Theme.h
  • XTPStraws : XTPCommandBarsOffice2013Theme.h
  • xtpSystemThemeAero : XTPColorManager.h
  • xtpSystemThemeAuto : XTPColorManager.h
  • xtpSystemThemeBlue : XTPColorManager.h
  • xtpSystemThemeDefault : XTPColorManager.h
  • xtpSystemThemeOlive : XTPColorManager.h
  • xtpSystemThemeRoyale : XTPColorManager.h
  • xtpSystemThemeSilver : XTPColorManager.h
  • xtpSystemThemeUnknown : XTPColorManager.h
  • xtpTabAppearanceExcel2003 : XTPTabManagerDefines.h
  • xtpTabAppearanceFlat : XTPTabManagerDefines.h
  • xtpTabAppearanceNativeWindows10 : XTPTabManagerDefines.h
  • xtpTabAppearanceNativeWindows11 : XTPTabManagerDefines.h
  • xtpTabAppearanceOffice2013 : XTPTabManagerDefines.h
  • xtpTabAppearanceOffice2016 : XTPTabManagerDefines.h
  • xtpTabAppearancePropertyPage : XTPTabManagerDefines.h
  • xtpTabAppearancePropertyPage2003 : XTPTabManagerDefines.h
  • xtpTabAppearancePropertyPage2007 : XTPTabManagerDefines.h
  • xtpTabAppearancePropertyPageAccess2007 : XTPTabManagerDefines.h
  • xtpTabAppearancePropertyPageFlat : XTPTabManagerDefines.h
  • xtpTabAppearancePropertyPageSelected : XTPTabManagerDefines.h
  • xtpTabAppearanceStateButtons : XTPTabManagerDefines.h
  • xtpTabAppearanceVisio : XTPTabManagerDefines.h
  • xtpTabAppearanceVisualStudio2003 : XTPTabManagerDefines.h
  • xtpTabAppearanceVisualStudio2005 : XTPTabManagerDefines.h
  • xtpTabAppearanceVisualStudio2010 : XTPTabManagerDefines.h
  • xtpTabAppearanceVisualStudio2012 : XTPTabManagerDefines.h
  • xtpTabAppearanceVisualStudio2015 : XTPTabManagerDefines.h
  • xtpTabAppearanceVisualStudio2017 : XTPTabManagerDefines.h
  • xtpTabAppearanceVisualStudio2019 : XTPTabManagerDefines.h
  • xtpTabAppearanceVisualStudio2022 : XTPTabManagerDefines.h
  • xtpTabClientStickerBottom : XTPTabClientSticker.h
  • xtpTabClientStickerCenter : XTPTabClientSticker.h
  • xtpTabClientStickerLeft : XTPTabClientSticker.h
  • xtpTabClientStickerNone : XTPTabClientSticker.h
  • xtpTabClientStickerRight : XTPTabClientSticker.h
  • xtpTabClientStickerTop : XTPTabClientSticker.h
  • xtpTabColorAll : XTPTabManagerDefines.h
  • xtpTabColorBlue : XTPTabManagerDefines.h
  • xtpTabColorCyan : XTPTabManagerDefines.h
  • xtpTabColorDefault : XTPTabManagerDefines.h
  • xtpTabColorGreen : XTPTabManagerDefines.h
  • xtpTabColorMagenta : XTPTabManagerDefines.h
  • xtpTabColorNativeWindows10 : XTPTabManagerDefines.h
  • xtpTabColorNativeWindows11 : XTPTabManagerDefines.h
  • xtpTabColorOffice2003 : XTPTabManagerDefines.h
  • xtpTabColorOffice2007Access : XTPTabManagerDefines.h
  • xtpTabColorOffice2013 : XTPTabManagerDefines.h
  • xtpTabColorOffice2016 : XTPTabManagerDefines.h
  • xtpTabColorOrange : XTPTabManagerDefines.h
  • xtpTabColorPurple : XTPTabManagerDefines.h
  • xtpTabColorRed : XTPTabManagerDefines.h
  • xtpTabColorResource : XTPTabManagerDefines.h
  • xtpTabColorVisualStudio2003 : XTPTabManagerDefines.h
  • xtpTabColorVisualStudio2005 : XTPTabManagerDefines.h
  • xtpTabColorVisualStudio2008 : XTPTabManagerDefines.h
  • xtpTabColorVisualStudio2010 : XTPTabManagerDefines.h
  • xtpTabColorVisualStudio2012 : XTPTabManagerDefines.h
  • xtpTabColorVisualStudio2012Dark : XTPTabManagerDefines.h
  • xtpTabColorVisualStudio2015 : XTPTabManagerDefines.h
  • xtpTabColorVisualStudio2017 : XTPTabManagerDefines.h
  • xtpTabColorVisualStudio2019 : XTPTabManagerDefines.h
  • xtpTabColorVisualStudio2022 : XTPTabManagerDefines.h
  • xtpTabColorWinNative : XTPTabManagerDefines.h
  • xtpTabColorYellow : XTPTabManagerDefines.h
  • xtpTabFrameBorder : XTPTabManagerDefines.h
  • xtpTabFrameNone : XTPTabManagerDefines.h
  • xtpTabFrameSingleLine : XTPTabManagerDefines.h
  • xtpTabLayoutAutoSize : XTPTabManagerDefines.h
  • xtpTabLayoutCompressed : XTPTabManagerDefines.h
  • xtpTabLayoutFixed : XTPTabManagerDefines.h
  • xtpTabLayoutMultiRow : XTPTabManagerDefines.h
  • xtpTabLayoutRotated : XTPTabManagerDefines.h
  • xtpTabLayoutSizeToFit : XTPTabManagerDefines.h
  • xtpTabNavigateButtonActiveFiles : XTPTabManagerDefines.h
  • xtpTabNavigateButtonAlways : XTPTabManagerDefines.h
  • xtpTabNavigateButtonAutomatic : XTPTabManagerDefines.h
  • xtpTabNavigateButtonClose : XTPTabManagerDefines.h
  • xtpTabNavigateButtonLeft : XTPTabManagerDefines.h
  • xtpTabNavigateButtonNone : XTPTabManagerDefines.h
  • xtpTabNavigateButtonRight : XTPTabManagerDefines.h
  • xtpTabPositionBottom : XTPTabManagerDefines.h
  • xtpTabPositionLeft : XTPTabManagerDefines.h
  • xtpTabPositionRight : XTPTabManagerDefines.h
  • xtpTabPositionTop : XTPTabManagerDefines.h
  • xtpTabToolTipAlways : XTPTabManagerDefines.h
  • xtpTabToolTipNever : XTPTabManagerDefines.h
  • xtpTabToolTipShrinkedOnly : XTPTabManagerDefines.h
  • xtpTabWorkspacePartBack : XTPTabManagerDefines.h
  • xtpTabWorkspacePartBorder : XTPTabManagerDefines.h
  • xtpTabWorkspacePartHSplitter : XTPTabManagerDefines.h
  • xtpTabWorkspacePartVSplitter : XTPTabManagerDefines.h
  • xtpTabWorkspacePartWidth : XTPTabManagerDefines.h
  • xtpTagCloudAlpha : XTPTagCloudCtrl.h
  • xtpTagCloudNone : XTPTagCloudCtrl.h
  • xtpTagCloudNumeric : XTPTagCloudCtrl.h
  • xtpTaskItemAllowDrag : XTPTaskPanelDefines.h
  • xtpTaskItemAllowDragCopy : XTPTaskPanelDefines.h
  • xtpTaskItemAllowDragCopyOutsideControl : XTPTaskPanelDefines.h
  • xtpTaskItemAllowDragCopyWithinControl : XTPTaskPanelDefines.h
  • xtpTaskItemAllowDragCopyWithinGroup : XTPTaskPanelDefines.h
  • xtpTaskItemAllowDragDefault : XTPTaskPanelDefines.h
  • xtpTaskItemAllowDragMove : XTPTaskPanelDefines.h
  • xtpTaskItemAllowDragMoveOutsideControl : XTPTaskPanelDefines.h
  • xtpTaskItemAllowDragMoveWithinControl : XTPTaskPanelDefines.h
  • xtpTaskItemAllowDragMoveWithinGroup : XTPTaskPanelDefines.h
  • xtpTaskItemAllowDragNone : XTPTaskPanelDefines.h
  • xtpTaskItemAllowDragWithinControl : XTPTaskPanelDefines.h
  • xtpTaskItemAllowDragWithinGroup : XTPTaskPanelDefines.h
  • xtpTaskItemLayoutDefault : XTPTaskPanelDefines.h
  • xtpTaskItemLayoutImages : XTPTaskPanelDefines.h
  • xtpTaskItemLayoutImagesWithText : XTPTaskPanelDefines.h
  • xtpTaskItemLayoutImagesWithTextBelow : XTPTaskPanelDefines.h
  • xtpTaskItemTypeControl : XTPTaskPanelDefines.h
  • xtpTaskItemTypeGroup : XTPTaskPanelDefines.h
  • xtpTaskItemTypeLink : XTPTaskPanelDefines.h
  • xtpTaskItemTypeText : XTPTaskPanelDefines.h
  • xtpTaskPanelAnimationNo : XTPTaskPanelDefines.h
  • xtpTaskPanelAnimationSystem : XTPTaskPanelDefines.h
  • xtpTaskPanelAnimationYes : XTPTaskPanelDefines.h
  • xtpTaskPanelBehaviourExplorer : XTPTaskPanelDefines.h
  • xtpTaskPanelBehaviourList : XTPTaskPanelDefines.h
  • xtpTaskPanelBehaviourToolbox : XTPTaskPanelDefines.h
  • xtpTaskPanelGripperBitmap : XTPTaskPanelPaintManager.h
  • xtpTaskPanelGripperNone : XTPTaskPanelPaintManager.h
  • xtpTaskPanelGripperPlain : XTPTaskPanelPaintManager.h
  • xtpTaskPanelGripperTriangle : XTPTaskPanelPaintManager.h
  • xtpTaskPanelHighlightDefault : XTPTaskPanelDefines.h
  • xtpTaskPanelHighlightImage : XTPTaskPanelDefines.h
  • xtpTaskPanelHighlightItem : XTPTaskPanelDefines.h
  • xtpTaskPanelHighlightNone : XTPTaskPanelDefines.h
  • xtpTaskPanelHighlightText : XTPTaskPanelDefines.h
  • xtpTaskPanelThemeCustom : XTPTaskPanelDefines.h
  • xtpTaskPanelThemeListView : XTPTaskPanelDefines.h
  • xtpTaskPanelThemeListViewOffice2003 : XTPTaskPanelDefines.h
  • xtpTaskPanelThemeListViewOfficeXP : XTPTaskPanelDefines.h
  • xtpTaskPanelThemeNativeWindows10 : XTPTaskPanelDefines.h
  • xtpTaskPanelThemeNativeWindows11 : XTPTaskPanelDefines.h
  • xtpTaskPanelThemeNativeWinXP : XTPTaskPanelDefines.h
  • xtpTaskPanelThemeNativeWinXPPlain : XTPTaskPanelDefines.h
  • xtpTaskPanelThemeOffice2000 : XTPTaskPanelDefines.h
  • xtpTaskPanelThemeOffice2000Plain : XTPTaskPanelDefines.h
  • xtpTaskPanelThemeOffice2003 : XTPTaskPanelDefines.h
  • xtpTaskPanelThemeOffice2003Plain : XTPTaskPanelDefines.h
  • xtpTaskPanelThemeOffice2013 : XTPTaskPanelDefines.h
  • xtpTaskPanelThemeOffice2016 : XTPTaskPanelDefines.h
  • xtpTaskPanelThemeOfficeXPPlain : XTPTaskPanelDefines.h
  • xtpTaskPanelThemeResource : XTPTaskPanelDefines.h
  • xtpTaskPanelThemeShortcutBarOffice2003 : XTPTaskPanelDefines.h
  • xtpTaskPanelThemeVisualStudio2003 : XTPTaskPanelDefines.h
  • xtpTaskPanelThemeVisualStudio2005 : XTPTaskPanelDefines.h
  • xtpTaskPanelThemeVisualStudio2010 : XTPTaskPanelDefines.h
  • xtpTaskPanelThemeVisualStudio2012Dark : XTPTaskPanelDefines.h
  • xtpTaskPanelThemeVisualStudio2012Light : XTPTaskPanelDefines.h
  • xtpTaskPanelThemeVisualStudio2015 : XTPTaskPanelDefines.h
  • xtpTaskPanelThemeVisualStudio2017 : XTPTaskPanelDefines.h
  • xtpTaskPanelThemeVisualStudio2019 : XTPTaskPanelDefines.h
  • xtpTaskPanelThemeVisualStudio2022 : XTPTaskPanelDefines.h
  • xtpThemeCustom : XTPCommandBarsDefines.h
  • xtpThemeNativeWindows10 : XTPCommandBarsDefines.h
  • xtpThemeNativeWindows11 : XTPCommandBarsDefines.h
  • xtpThemeNativeWinXP : XTPCommandBarsDefines.h
  • xtpThemeNone : XTPCommandBarsDefines.h
  • xtpThemeOffice2000 : XTPCommandBarsDefines.h
  • xtpThemeOffice2003 : XTPCommandBarsDefines.h
  • xtpThemeOffice2007System : XTPCommandBarsDefines.h
  • xtpThemeOffice2013 : XTPCommandBarsDefines.h
  • xtpThemeOffice2016 : XTPCommandBarsDefines.h
  • xtpThemeOfficeXP : XTPCommandBarsDefines.h
  • xtpThemeResource : XTPCommandBarsDefines.h
  • xtpThemeRibbon : XTPCommandBarsDefines.h
  • xtpThemeVisualStudio2005 : XTPCommandBarsDefines.h
  • xtpThemeVisualStudio2008 : XTPCommandBarsDefines.h
  • xtpThemeVisualStudio2010 : XTPCommandBarsDefines.h
  • xtpThemeVisualStudio2012 : XTPCommandBarsDefines.h
  • xtpThemeVisualStudio2012Dark : XTPCommandBarsDefines.h
  • xtpThemeVisualStudio2012Light : XTPCommandBarsDefines.h
  • xtpThemeVisualStudio2015 : XTPCommandBarsDefines.h
  • xtpThemeVisualStudio2017 : XTPCommandBarsDefines.h
  • xtpThemeVisualStudio2019 : XTPCommandBarsDefines.h
  • xtpThemeVisualStudio2022 : XTPCommandBarsDefines.h
  • xtpThemeVisualStudio6 : XTPCommandBarsDefines.h
  • xtpTipsOnTabPane : XTPRibbonBackstageView.h
  • xtpToolTipBalloon : XTPToolTipContext.h
  • xtpToolTipHTML : XTPToolTipContext.h
  • xtpToolTipLuna : XTPToolTipContext.h
  • xtpToolTipMarkup : XTPToolTipContext.h
  • xtpToolTipOffice : XTPToolTipContext.h
  • xtpToolTipOffice2013 : XTPToolTipContext.h
  • xtpToolTipOffice2016 : XTPToolTipContext.h
  • xtpToolTipResource : XTPToolTipContext.h
  • xtpToolTipRTF : XTPToolTipContext.h
  • xtpToolTipStandard : XTPToolTipContext.h
  • xtpTrackCursorDrag : XTPTrackControl.h
  • xtpTrackCursorNothing : XTPTrackControl.h
  • xtpTrackCursorResize : XTPTrackControl.h
  • XTPTreeRings : XTPCommandBarsOffice2013Theme.h
  • xtpTSPID_Day : XTPCalendarDefines.h
  • xtpTSPID_Month : XTPCalendarDefines.h
  • xtpTSPID_Unknown : XTPCalendarDefines.h
  • xtpTSPID_Week : XTPCalendarDefines.h
  • xtpTSPID_WorkWeek : XTPCalendarDefines.h
  • XTPUnderWater : XTPCommandBarsOffice2013Theme.h
  • xtpUriFile : XTPSystemHelpers.h
  • xtpUriRes : XTPSystemHelpers.h
  • xtpUserHoldAltKey : XTPRibbonBackstageView.h
  • xtpVerticalButton : XTPControlCustom.h
  • xtpVerticalHide : XTPControlCustom.h
  • xtpVerticalShow : XTPControlCustom.h
  • xtpVirtRowHasChildren : XTPGridRecordItem.h
  • xtpVirtRowLastChild : XTPGridRecordItem.h
  • xtpVirtRowUnknown : XTPGridRecordItem.h
  • xtpWebBrowserInvalid : XTPWebBrowserCtrl.h
  • xtpWebBrowserLatest : XTPWebBrowserCtrl.h
  • xtpWebBrowserShellExplorer : XTPWebBrowserCtrl.h
  • xtpWebBrowserWebView : XTPWebBrowserCtrl.h
  • xtpWindowClassRichEdit : XTPSystemHelpers.h
  • xtpWindowClassVersionAtLeast : XTPSystemHelpers.h
  • xtpWindowClassVersionExact : XTPSystemHelpers.h
  • xtpWindowClassVersionHighest : XTPSystemHelpers.h
  • xtpWorkspaceActivateNextToClosed : XTPTabClientWnd.h
  • xtpWorkspaceActivateTopmost : XTPTabClientWnd.h
  • xtpWorkspaceHideAll : XTPTabClientWnd.h
  • xtpWorkspaceHideArrows : XTPTabClientWnd.h
  • xtpWorkspaceHideArrowsAlways : XTPTabClientWnd.h
  • xtpWorkspaceHideClose : XTPTabClientWnd.h
  • xtpWorkspaceNewTabLeftMost : XTPTabClientWnd.h
  • xtpWorkspaceNewTabNextToActive : XTPTabClientWnd.h
  • xtpWorkspaceNewTabRightMost : XTPTabClientWnd.h
  • xtpWorkspaceShowActiveFiles : XTPTabClientWnd.h
  • xtpWorkspaceShowCloseSelectedTab : XTPTabClientWnd.h
  • xtpWorkspaceShowCloseTab : XTPTabClientWnd.h
  • xtpZLibBestCompression : XTPGraphicBitmapPng.h
  • xtpZLibBestSpeed : XTPGraphicBitmapPng.h
  • xtpZLibDefaultCompression : XTPGraphicBitmapPng.h
  • xtpZLibNoCompression : XTPGraphicBitmapPng.h


Toolkit Pro: File Members

Here is a list of all documented macros with links to the documentation:

- b -

  • BEGIN_VIEW_PART : XTPCalendarPaintManager.h


Toolkit Pro: File Members

Here is a list of all documented macros with links to the documentation:

- c -

  • CXTPDefaultTheme : XTPCommandBarsOffice2000Theme.h
  • CXTPOffice2003Theme : XTPCommandBarsOffice2003Theme.h


Toolkit Pro: File Members

Here is a list of all documented macros with links to the documentation:

- d -

  • DECLARE_SHELLTREE_BASE : XTPShellTreeBase.h
  • DECLARE_XTP_COMMANDBAR : XTPCommandBarsDefines.h
  • DECLARE_XTP_CONTROL : XTPCommandBarsDefines.h
  • DECLARE_XTP_SINK : XTPNotifyConnection.h


Toolkit Pro: File Members

Here is a list of all documented macros with links to the documentation:

- e -

  • END_VIEW_PART : XTPCalendarPaintManager.h


Toolkit Pro: File Members

Here is a list of all documented macros with links to the documentation:

- i -

  • IMPLEMENT_XTP_COMMANDBAR : XTPCommandBarsDefines.h
  • IMPLEMENT_XTP_CONTROL : XTPCommandBarsDefines.h


Toolkit Pro: File Members

Here is a list of all documented macros with links to the documentation:

- o -

  • ON_XTP_AFTERCREATECONTROL : XTPCommandBarsDefines.h
  • ON_XTP_CREATECOMMANDBAR : XTPCommandBarsDefines.h
  • ON_XTP_CREATECONTROL : XTPCommandBarsDefines.h
  • ON_XTP_EXECUTE : XTPCommandBarsDefines.h
  • ON_XTP_EXECUTE_RANGE : XTPCommandBarsDefines.h
  • ON_XTP_INITCOMMANDSPOPUP : XTPCommandBarsDefines.h
  • ON_XTP_UNINITCOMMANDSPOPUP : XTPCommandBarsDefines.h
  • ON_XTP_WM_GAUGEUPDATE : XTPGaugeCtrl.h


Toolkit Pro: File Members

Here is a list of all documented macros with links to the documentation:

- s -

  • SAFE_CALLPTR : XTPMacros.h
  • SAFE_DELETE : XTPMacros.h
  • SAFE_DELETE_AR : XTPMacros.h
  • SAFE_DELETE_HICON : XTPMacros.h
  • SAFE_DELETE_OBJ : XTPMacros.h
  • SAFE_RELEASE : XTPMacros.h


Toolkit Pro: File Members

Here is a list of all documented macros with links to the documentation:

- w -

  • WM_XTP_RIBBONMINIMIZE : XTPRibbonBar.h


Toolkit Pro: File Members

Here is a list of all documented macros with links to the documentation:

- x -

  • XT_ASSERT_MSG : XTPMacros.h
  • XTP_ANCHOR_BOTTOMCENTER : XTPResizePoint.h
  • XTP_ANCHOR_BOTTOMLEFT : XTPResizePoint.h
  • XTP_ANCHOR_BOTTOMRIGHT : XTPResizePoint.h
  • XTP_ANCHOR_MIDDLECENTER : XTPResizePoint.h
  • XTP_ANCHOR_MIDDLELEFT : XTPResizePoint.h
  • XTP_ANCHOR_MIDDLERIGHT : XTPResizePoint.h
  • XTP_ANCHOR_TOPCENTER : XTPResizePoint.h
  • XTP_ANCHOR_TOPLEFT : XTPResizePoint.h
  • XTP_ANCHOR_TOPRIGHT : XTPResizePoint.h
  • XTP_ASSERT_CHECK : XTPMacros.h
  • XTP_ASSERT_CHECK_NOT_NULL : XTPMacros.h
  • XTP_ATTR_HORREPOS : XTPResizeRect.h
  • XTP_ATTR_HORRESIZE : XTPResizeRect.h
  • XTP_ATTR_REPOS : XTPResizeRect.h
  • XTP_ATTR_RESIZE : XTPResizeRect.h
  • XTP_ATTR_VERREPOS : XTPResizeRect.h
  • XTP_ATTR_VERRESIZE : XTPResizeRect.h
  • XTP_BROWSER_WEBVIEW_MIN_VC_VERSION : XTPWebView2.h
  • XTP_CALENDAR_DEFAULT_LABEL_ID : XTPCalendarDefines.h
  • XTP_CALENDAR_DEFAULT_REMINDER_MINUTES : XTPCalendarDefines.h
  • XTP_CALENDAR_DISABLED_COLOR_DARK : XTPCalendarDefines.h
  • XTP_CALENDAR_DISABLED_COLOR_LIGHT : XTPCalendarDefines.h
  • XTP_CALENDAR_DRAW_EVENTITEMTEXT_MAX : XTPCalendarDefines.h
  • XTP_CALENDAR_MONTHVIEW_SHOW_WEEKS_MAX : XTPCalendarMonthView.h
  • XTP_CALENDAR_MONTHVIEW_SHOW_WEEKS_MIN : XTPCalendarMonthView.h
  • XTP_CALENDAR_NONE_LABEL_ID : XTPCalendarDefines.h
  • XTP_CALENDAR_OFFICE2007_FONT_NAME : XTPCalendarDefines.h
  • XTP_CALENDAR_SHOW_BUTTON_TIMEOUT_MS : XTPCalendarDefines.h
  • XTP_CALENDAR_SHOW_TOOLTIP_TIMEOUT_MS : XTPCalendarDefines.h
  • XTP_CALENDAR_TIMEZONESKEY_9X : XTPCalendarDefines.h
  • XTP_CALENDAR_TIMEZONESKEY_NT : XTPCalendarDefines.h
  • XTP_CALENDAR_TZIRegValName_DATA : XTPCalendarDefines.h
  • XTP_CALENDAR_TZIRegValName_DaylightName : XTPCalendarDefines.h
  • XTP_CALENDAR_TZIRegValName_DaylightNameW : XTPCalendarDefines.h
  • XTP_CALENDAR_TZIRegValName_DisplayStr : XTPCalendarDefines.h
  • XTP_CALENDAR_TZIRegValName_Index : XTPCalendarDefines.h
  • XTP_CALENDAR_TZIRegValName_StandardName : XTPCalendarDefines.h
  • XTP_CALENDAR_TZIRegValName_StandardNameW : XTPCalendarDefines.h
  • XTP_CALENDAR_UNKNOWN_EVENT_ID : XTPCalendarDefines.h
  • XTP_CALENDAR_UNKNOWN_LABEL_ID : XTPCalendarDefines.h
  • XTP_CALENDAR_UNKNOWN_RECURRENCE_PATTERN_ID : XTPCalendarDefines.h
  • XTP_CALENDAR_UNKNOWN_SCHEDULE_ID : XTPCalendarDefines.h
  • XTP_CN_UPDATE_CUSTOMIZE_COMMAND_UI : XTPCommandBarsDefines.h
  • XTP_DECLARE_BATCH_ALLOC_OBJ_DATA : XTPCustomHeap.h
  • XTP_DECLARE_CMDTARGETPROVIDER_INTERFACE : XTPFramework.h
  • XTP_DECLARE_CMDTARGETPROVIDER_INTERFACE_PART : XTPFramework.h
  • XTP_DECLARE_HEAP_ALLOCATOR : XTPCustomHeap.h
  • XTP_DECLARE_IDISPATCH : XTPMacros.h
  • XTP_DEFINE_SMART_PTR_ARRAY_INTERNAL : XTPSmartPtrInternalT.h
  • XTP_DEFINE_SMART_PTR_INTERNAL : XTPSmartPtrInternalT.h
  • XTP_DYNAMIC_DOWNCAST_REMOTE : XTPSystemHelpers.h
  • XTP_EDIT_AVELINELEN : XTPSyntaxEditDefines.h
  • XTP_EDIT_DISABLED_COLOR_DARK : XTPSyntaxEditDefines.h
  • XTP_EDIT_DISABLED_COLOR_LIGHT : XTPSyntaxEditDefines.h
  • XTP_EDIT_EDITACTION_DELETEROW : XTPSyntaxEditDefines.h
  • XTP_EDIT_EDITACTION_DELETETEXT : XTPSyntaxEditDefines.h
  • XTP_EDIT_EDITACTION_INSERTROW : XTPSyntaxEditDefines.h
  • XTP_EDIT_EDITACTION_INSERTTEXT : XTPSyntaxEditDefines.h
  • XTP_EDIT_EDITACTION_MODIFYROW : XTPSyntaxEditDefines.h
  • XTP_EDIT_FINDWORD_NEXT : XTPSyntaxEditDefines.h
  • XTP_EDIT_FINDWORD_PREV : XTPSyntaxEditDefines.h
  • XTP_EDIT_FONTOPTIONS_UNSPEC_OPTION : XTPSyntaxEditStruct.h
  • XTP_EDIT_NM_DRAWBOOKMARK : XTPSyntaxEditDefines.h
  • XTP_EDIT_NM_EDITCHANGED : XTPSyntaxEditDefines.h
  • XTP_EDIT_NM_EDITCHANGING : XTPSyntaxEditDefines.h
  • XTP_EDIT_NM_ENABLESCROLLBAR : XTPSyntaxEditDefines.h
  • XTP_EDIT_NM_FIRST : XTPSyntaxEditDefines.h
  • XTP_EDIT_NM_INSERTKEY : XTPSyntaxEditDefines.h
  • XTP_EDIT_NM_LAST : XTPSyntaxEditDefines.h
  • XTP_EDIT_NM_LBUTTONDBLCLICK : XTPSyntaxEditDefines.h
  • XTP_EDIT_NM_LBUTTONDOWN : XTPSyntaxEditDefines.h
  • XTP_EDIT_NM_LBUTTONUP : XTPSyntaxEditDefines.h
  • XTP_EDIT_NM_MARGINCLICKED : XTPSyntaxEditDefines.h
  • XTP_EDIT_NM_MOUSEMOVE : XTPSyntaxEditDefines.h
  • XTP_EDIT_NM_PARSEEVENT : XTPSyntaxEditDefines.h
  • XTP_EDIT_NM_RBUTTONDOWN : XTPSyntaxEditDefines.h
  • XTP_EDIT_NM_RBUTTONUP : XTPSyntaxEditDefines.h
  • XTP_EDIT_NM_ROWCOLCHANGED : XTPSyntaxEditDefines.h
  • XTP_EDIT_NM_SELINIT : XTPSyntaxEditDefines.h
  • XTP_EDIT_NM_SETDOCMODIFIED : XTPSyntaxEditDefines.h
  • XTP_EDIT_NM_STARTOLEDRAG : XTPSyntaxEditDefines.h
  • XTP_EDIT_NM_UPDATESCROLLPOS : XTPSyntaxEditDefines.h
  • XTP_EDIT_RGB_GETBLUE : XTPSyntaxEditDefines.h
  • XTP_EDIT_RGB_GETGREEN : XTPSyntaxEditDefines.h
  • XTP_EDIT_RGB_GETRED : XTPSyntaxEditDefines.h
  • XTP_EDIT_RGB_INT2CLR : XTPSyntaxEditDefines.h
  • XTP_EDIT_XLC : XTPSyntaxEditStruct.h
  • XTP_EVENTS_STORAGE_HASH_TABLE_SIZE : XTPCalendarMemoryDataProvider.h
  • XTP_GRID_DEPRECATED : XTPGridDefines.h
  • XTP_GUARD_EXCLUSIVE : XTPSynchro.h
  • XTP_GUARD_EXCLUSIVE_ : XTPSynchro.h
  • XTP_GUARD_EXCLUSIVE_COND : XTPSynchro.h
  • XTP_GUARD_EXCLUSIVE_COND_ : XTPSynchro.h
  • XTP_GUARD_EXCLUSIVE_COND_CONST : XTPSynchro.h
  • XTP_GUARD_EXCLUSIVE_CONST : XTPSynchro.h
  • XTP_GUARD_EXCLUSIVE_CONST_ : XTPSynchro.h
  • XTP_GUARD_EXCLUSIVE_CONST_COND_ : XTPSynchro.h
  • XTP_GUARD_SHARED : XTPSynchro.h
  • XTP_GUARD_SHARED_ : XTPSynchro.h
  • XTP_GUARD_SHARED_COND : XTPSynchro.h
  • XTP_GUARD_SHARED_COND_ : XTPSynchro.h
  • XTP_GUARD_SHARED_COND_CONST : XTPSynchro.h
  • XTP_GUARD_SHARED_COND_CONST_ : XTPSynchro.h
  • XTP_GUARD_SHARED_CONST : XTPSynchro.h
  • XTP_GUARD_SHARED_CONST_ : XTPSynchro.h
  • XTP_HALF_SECOND : XTPCalendarUtils.h
  • XTP_HTSCROLLDOWN : XTPScrollBase.h
  • XTP_HTSCROLLDOWNPAGE : XTPScrollBase.h
  • XTP_HTSCROLLLEFT : XTPScrollBase.h
  • XTP_HTSCROLLPOPUP : XTPScrollBase.h
  • XTP_HTSCROLLRIGHT : XTPScrollBase.h
  • XTP_HTSCROLLTHUMB : XTPScrollBase.h
  • XTP_HTSCROLLUP : XTPScrollBase.h
  • XTP_HTSCROLLUPPAGE : XTPScrollBase.h
  • XTP_ID_POPUP_CLOSE : XTPPopupItem.h
  • XTP_IMPLEMENT_BATCH_ALLOC_OBJ_DATA : XTPCustomHeap.h
  • XTP_IMPLEMENT_CMDTARGETPROVIDER_INTERFACE : XTPFramework.h
  • XTP_IMPLEMENT_HEAP_ALLOCATOR : XTPCustomHeap.h
  • XTP_IMPLEMENT_IDISPATCH : XTPMacros.h
  • XTP_IMPLEMENT_IUNKNOWN : XTPMacros.h
  • XTP_INVALID_TLS_SLOT : XTPSystemHelpers.h
  • XTP_ISNAN : XTPMathUtils.h
  • XTP_NAN : XTPMathUtils.h
  • XTP_NM_GRID_BEFORE_COPY_TOTEXT : XTPGridDefines.h
  • XTP_NM_GRID_BEFORE_PASTE : XTPGridDefines.h
  • XTP_NM_GRID_BEFORE_PASTE_FROMTEXT : XTPGridDefines.h
  • XTP_NM_GRID_BEGINDRAG : XTPGridDefines.h
  • XTP_NM_GRID_BEGINEDIT : XTPGridDefines.h
  • XTP_NM_GRID_CHECKED : XTPGridDefines.h
  • XTP_NM_GRID_COLUMNORDERCHANGED : XTPGridDefines.h
  • XTP_NM_GRID_COLUMNWIDTHCHANGED : XTPGridDefines.h
  • XTP_NM_GRID_CONSTRAINT_SELECTING : XTPGridDefines.h
  • XTP_NM_GRID_DRAGDROP_COMPLETED : XTPGridDefines.h
  • XTP_NM_GRID_DRAGOVER : XTPGridDefines.h
  • XTP_NM_GRID_DROP : XTPGridDefines.h
  • XTP_NM_GRID_EDIT_CANCELED : XTPGridDefines.h
  • XTP_NM_GRID_FOCUS_CHANGING : XTPGridDefines.h
  • XTP_NM_GRID_GETITEMMETRICS : XTPGridDefines.h
  • XTP_NM_GRID_GETTOOLTIPINFO : XTPGridDefines.h
  • XTP_NM_GRID_GROUPORDERCHANGED : XTPGridDefines.h
  • XTP_NM_GRID_HEADER_RCLICK : XTPGridDefines.h
  • XTP_NM_GRID_HSCROLL : XTPGridDefines.h
  • XTP_NM_GRID_HYPERLINK : XTPGridDefines.h
  • XTP_NM_GRID_INPLACEBUTTONDOWN : XTPGridDefines.h
  • XTP_NM_GRID_ITEMBUTTONCLICK : XTPGridDefines.h
  • XTP_NM_GRID_LBUTTONDOWN : XTPGridDefines.h
  • XTP_NM_GRID_MOUSEMOVE : XTPGridDefines.h
  • XTP_NM_GRID_PLUSMINUSCLICK : XTPGridDefines.h
  • XTP_NM_GRID_PRESORTORDERCHANGED : XTPGridDefines.h
  • XTP_NM_GRID_PREVIEWKEYDOWN : XTPGridDefines.h
  • XTP_NM_GRID_RECORDS_DROPPED : XTPGridDefines.h
  • XTP_NM_GRID_REQUESTEDIT : XTPGridDefines.h
  • XTP_NM_GRID_ROWEXPANDED : XTPGridDefines.h
  • XTP_NM_GRID_ROWHEIGHTCHANGED : XTPGridDefines.h
  • XTP_NM_GRID_SELCHANGED : XTPGridDefines.h
  • XTP_NM_GRID_SELCHANGING : XTPGridDefines.h
  • XTP_NM_GRID_SORTORDERCHANGED : XTPGridDefines.h
  • XTP_NM_GRID_STATECHANGED : XTPGridDefines.h
  • XTP_NM_GRID_VALUECHANGED : XTPGridDefines.h
  • XTP_NM_GRID_VSCROLL : XTPGridDefines.h
  • XTP_NM_TRACK_BLOCKCHANGED : XTPTrackControl.h
  • XTP_NM_TRACK_MARKERCHANGED : XTPTrackControl.h
  • XTP_NM_TRACK_SELECTEDBLOCKSCHANGED : XTPTrackControl.h
  • XTP_NM_TRACK_SLIDERCHANGED : XTPTrackControl.h
  • XTP_NM_TRACK_TIMELINECHANGED : XTPTrackControl.h
  • XTP_OBJECT_CACHE_HASH_TABLE_SIZE : XTPCalendarData.h
  • XTP_PROPERTY_GRID_DISABLE_SCROLLBAR_THEMES : XTPPropertyGrid.h
  • XTP_RWCS_LOCK_EXCLUSIVE_SCOPE : XTPSynchro.h
  • XTP_RWCS_LOCK_SHARED_SCOPE : XTPSynchro.h
  • XTP_SAFE_CALL_BASE : XTPCalendarTheme.h
  • XTP_UNUSED : XTPMacros.h
  • XTP_UNUSED_PARAMETER : XTPMacros.h
  • XTP_WIDE : XTPMacros.h
  • XTP_WM_GAUGEUPDATE : XTPGaugeCtrl.h
  • XTP_ZOOM_PAGEWIDTH : XTPPreviewView.h
  • XTP_ZOOM_WHOLEPAGE : XTPPreviewView.h
  • xtpComboLabel : XTPCommandBarsDefines.h
  • xtpComboNormal : XTPCommandBarsDefines.h
  • xtpIniOffice2007Aqua : XTPResourceImage.h
  • xtpIniOffice2007Black : XTPResourceImage.h
  • xtpIniOffice2007Blue : XTPResourceImage.h
  • xtpIniOffice2007Silver : XTPResourceImage.h
  • xtpIniOffice2010Black : XTPResourceImage.h
  • xtpIniOffice2010Blue : XTPResourceImage.h
  • xtpIniOffice2010Silver : XTPResourceImage.h
  • xtpIniOffice2013Access : XTPResourceImage.h
  • xtpIniOffice2013AccessGrayDark : XTPResourceImage.h
  • xtpIniOffice2013AccessGrayLight : XTPResourceImage.h
  • xtpIniOffice2013Excel : XTPResourceImage.h
  • xtpIniOffice2013ExcelGrayDark : XTPResourceImage.h
  • xtpIniOffice2013ExcelGrayLight : XTPResourceImage.h
  • xtpIniOffice2013OneNote : XTPResourceImage.h
  • xtpIniOffice2013OneNoteGrayDark : XTPResourceImage.h
  • xtpIniOffice2013OneNoteGrayLight : XTPResourceImage.h
  • xtpIniOffice2013Outlook : XTPResourceImage.h
  • xtpIniOffice2013OutlookGrayDark : XTPResourceImage.h
  • xtpIniOffice2013OutlookGrayLight : XTPResourceImage.h
  • xtpIniOffice2013PowerPoint : XTPResourceImage.h
  • xtpIniOffice2013PowerPointGrayDark : XTPResourceImage.h
  • xtpIniOffice2013PowerPointGrayLight : XTPResourceImage.h
  • xtpIniOffice2013Publisher : XTPResourceImage.h
  • xtpIniOffice2013PublisherGrayDark : XTPResourceImage.h
  • xtpIniOffice2013PublisherGrayLight : XTPResourceImage.h
  • xtpIniOffice2013Word : XTPResourceImage.h
  • xtpIniOffice2013WordGrayDark : XTPResourceImage.h
  • xtpIniOffice2013WordGrayLight : XTPResourceImage.h
  • xtpIniOffice2016AccessBlack : XTPResourceImage.h
  • xtpIniOffice2016AccessColorful : XTPResourceImage.h
  • xtpIniOffice2016AccessDarkGray : XTPResourceImage.h
  • xtpIniOffice2016AccessWhite : XTPResourceImage.h
  • xtpIniOffice2016ExcelBlack : XTPResourceImage.h
  • xtpIniOffice2016ExcelColorful : XTPResourceImage.h
  • xtpIniOffice2016ExcelDarkGray : XTPResourceImage.h
  • xtpIniOffice2016ExcelWhite : XTPResourceImage.h
  • xtpIniOffice2016OneNoteBlack : XTPResourceImage.h
  • xtpIniOffice2016OneNoteColorful : XTPResourceImage.h
  • xtpIniOffice2016OneNoteDarkGray : XTPResourceImage.h
  • xtpIniOffice2016OneNoteWhite : XTPResourceImage.h
  • xtpIniOffice2016OutlookBlack : XTPResourceImage.h
  • xtpIniOffice2016OutlookColorful : XTPResourceImage.h
  • xtpIniOffice2016OutlookDarkGray : XTPResourceImage.h
  • xtpIniOffice2016OutlookWhite : XTPResourceImage.h
  • xtpIniOffice2016PowerPointBlack : XTPResourceImage.h
  • xtpIniOffice2016PowerPointColorful : XTPResourceImage.h
  • xtpIniOffice2016PowerPointDarkGray : XTPResourceImage.h
  • xtpIniOffice2016PowerPointWhite : XTPResourceImage.h
  • xtpIniOffice2016PublisherBlack : XTPResourceImage.h
  • xtpIniOffice2016PublisherColorful : XTPResourceImage.h
  • xtpIniOffice2016PublisherDarkGray : XTPResourceImage.h
  • xtpIniOffice2016PublisherWhite : XTPResourceImage.h
  • xtpIniOffice2016WordBlack : XTPResourceImage.h
  • xtpIniOffice2016WordColorful : XTPResourceImage.h
  • xtpIniOffice2016WordDarkGray : XTPResourceImage.h
  • xtpIniOffice2016WordWhite : XTPResourceImage.h
  • xtpIniVisualStudio2012Dark : XTPResourceImage.h
  • xtpIniVisualStudio2012Light : XTPResourceImage.h
  • xtpIniVisualStudio2015Blue : XTPResourceImage.h
  • xtpIniVisualStudio2015Dark : XTPResourceImage.h
  • xtpIniVisualStudio2015Light : XTPResourceImage.h
  • xtpIniVisualStudio2017Blue : XTPResourceImage.h
  • xtpIniVisualStudio2017BlueExtra : XTPResourceImage.h
  • xtpIniVisualStudio2017Dark : XTPResourceImage.h
  • xtpIniVisualStudio2017Light : XTPResourceImage.h
  • xtpIniVisualStudio2019Blue : XTPResourceImage.h
  • xtpIniVisualStudio2019BlueExtra : XTPResourceImage.h
  • xtpIniVisualStudio2019Dark : XTPResourceImage.h
  • xtpIniVisualStudio2019Light : XTPResourceImage.h
  • xtpIniVisualStudio2022Blue : XTPResourceImage.h
  • xtpIniVisualStudio2022BlueExtra : XTPResourceImage.h
  • xtpIniVisualStudio2022Dark : XTPResourceImage.h
  • xtpIniVisualStudio2022Light : XTPResourceImage.h
  • xtpIniWindows10Dark : XTPResourceImage.h
  • xtpIniWindows10Light : XTPResourceImage.h
  • xtpIniWindows11Dark : XTPResourceImage.h
  • xtpIniWindows11Light : XTPResourceImage.h
  • xtpIniWindows7Blue : XTPResourceImage.h
  • XTPWM_DOCKINGPANE_NOTIFY : XTPDockingPaneDefines.h


Toolkit Pro: Graph Legend

Graph Legend

This page explains how to interpret the graphs that are generated by doxygen.

Consider the following example:

/*! Invisible class because of truncation */
class Invisible { };
/*! Truncated class, inheritance relation is hidden */
class Truncated : public Invisible { };
/* Class not documented with doxygen comments */
class Undocumented { };
/*! Class that is inherited using public inheritance */
class PublicBase : public Truncated { };
/*! A template class */
template<class T> class Templ { };
/*! Class that is inherited using protected inheritance */
class ProtectedBase { };
/*! Class that is inherited using private inheritance */
class PrivateBase { };
/*! Class that is used by the Inherited class */
class Used { };
/*! Super class that inherits a number of other classes */
class Inherited : public PublicBase,
protected ProtectedBase,
private PrivateBase,
public Undocumented,
public Templ<int>
{
private:
Used *m_usedClass;
};

This will result in the following graph:

The boxes in the above graph have the following meaning:

  • A filled gray box represents the struct or class for which the graph is generated.
  • A box with a black border denotes a documented struct or class.
  • A box with a gray border denotes an undocumented struct or class.
  • A box with a red border denotes a documented struct or class forwhich not all inheritance/containment relations are shown. A graph is truncated if it does not fit within the specified boundaries.

The arrows have the following meaning:

  • A blue arrow is used to visualize a public inheritance relation between two classes.
  • A dark green arrow is used for protected inheritance.
  • A dark red arrow is used for private inheritance.
  • A purple dashed arrow is used if a class is contained or used by another class. The arrow is labelled with the variable(s) through which the pointed class or struct is accessible.
  • A yellow dashed arrow denotes a relation between a template instance and the template class it was instantiated from. The arrow is labelled with the template parameters of the instance.


Toolkit Pro: Class Hierarchy

Class Hierarchy

Go to the textual class hierarchy


Toolkit Pro: Related Pages

Related Pages
Here is a list of all related documentation pages:
Gauge Overview


Toolkit Pro: XTPResource.h Source File

  • Source
XTPResource.h
Go to the documentation of this file.
1
22#include "Common/Resource.h"
23#include "CommandBars/Resource.h" // _XTP_INCLUDE_COMMANDBARS
24#include "Ribbon/Resource.h" // _XTP_INCLUDE_RIBBON
25#include "PropertyGrid/Resource.h" // _XTP_INCLUDE_PROPERTYGRID
26#include "DockingPane/Resource.h" // _XTP_INCLUDE_DOCKINGPANE
27#include "Controls/Resource.h" // _XTP_INCLUDE_CONTROLS
28#include "TaskPanel/Resource.h" // _XTP_INCLUDE_TASKPANEL
29#include "ShortcutBar/Resource.h" // _XTP_INCLUDE_SHORTCUTBAR
30#include "GridControl/Resource.h" // _XTP_INCLUDE_GRIDCONTROL
31#include "Calendar/Resource.h" // _XTP_INCLUDE_CALENDAR
32#include "SyntaxEdit/Resource.h" // _XTP_INCLUDE_SYNTAXEDIT


Toolkit Pro: Member List

CXTPDockingPaneTabColorSet2015 Member List

This is the complete list of members for CXTPDockingPaneTabColorSet2015, including all inherited members.

CXTPDockingPaneTabColorSet2012() | CXTPDockingPaneTabColorSet2012 |
CXTPDockingPaneTabColorSet2015() | CXTPDockingPaneTabColorSet2015 |
CXTPTabPaintManagerColorSet() | CXTPTabPaintManagerColorSet |
FillClient(CDC *pDC, CRect rc, CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
FillHeader(CDC *pDC, CRect rc, CXTPTabManager *pTabManager) | CXTPDockingPaneTabColorSet2015 | virtual
FillNavigateButton(CDC *pDC, CXTPTabManagerNavigateButton *pButton, CRect &rc) | CXTPDockingPaneTabColorSet2012 | virtual
FillPropertyButton(CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerColorSet | virtual
FillStateButton(CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerColorSet | virtual
GetClientColor(CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
GetItemColor(CXTPTabManagerItem *pItem) | CXTPDockingPaneTabColorSet2012 | virtual
GradientFill(CDC *pDC, CRect rc, COLORREF clrLight, COLORREF clrDark, XTPTabPosition position) | CXTPTabPaintManagerColorSet |
IsAppThemed() const | CXTPTabPaintManagerColorSet | virtual
m_clrActiveFilesBack | CXTPTabPaintManagerColorSet |
m_clrActiveFilesBackHighlighted | CXTPTabPaintManagerColorSet |
m_clrActiveFilesBackPressed | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyph | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyphHighlighted | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyphPressed | CXTPTabPaintManagerColorSet |
m_clrAutoHideFace | CXTPTabPaintManagerColorSet |
m_clrBorderHighlight | CXTPTabPaintManagerColorSet |
m_clrButtonBorder | CXTPTabPaintManagerColorSet |
m_clrButtonBorderHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonBorderHot | CXTPTabPaintManagerColorSet |
m_clrButtonBorderKeyTips | CXTPTabPaintManagerColorSet |
m_clrButtonBorderTabContext1 | CXTPTabPaintManagerColorSet |
m_clrButtonBorderTabContext2 | CXTPTabPaintManagerColorSet |
m_clrButtonHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonHighlightedClose | CXTPTabPaintManagerColorSet |
m_clrButtonNormal | CXTPTabPaintManagerColorSet |
m_clrButtonPressed | CXTPTabPaintManagerColorSet |
m_clrButtonSelected | CXTPTabPaintManagerColorSet |
m_clrButtonSelectedHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonSelectedPressed | CXTPTabPaintManagerColorSet |
m_clrControlFace | CXTPTabPaintManagerColorSet |
m_clrFrameBorder | CXTPTabPaintManagerColorSet |
m_clrHeaderFace | CXTPTabPaintManagerColorSet |
m_clrPaneFace | CXTPTabPaintManagerColorSet |
m_clrTabClientBack | CXTPTabPaintManagerColorSet |
m_clrTabClientBorder | CXTPTabPaintManagerColorSet |
m_clrTextDisabled | CXTPTabPaintManagerColorSet |
m_clrTextHighlight | CXTPTabPaintManagerColorSet |
m_clrTextHighlightClose | CXTPTabPaintManagerColorSet |
m_clrTextNormal | CXTPTabPaintManagerColorSet |
m_clrTextPressed | CXTPTabPaintManagerColorSet |
m_clrTextSelected | CXTPTabPaintManagerColorSet |
m_clrTextSelectedHighlighted | CXTPTabPaintManagerColorSet |
m_clrTextSelectedPressed | CXTPTabPaintManagerColorSet |
m_csExcelNormal | CXTPTabPaintManagerColorSet |
m_csExcelSelected | CXTPTabPaintManagerColorSet |
m_csPropertyPage | CXTPTabPaintManagerColorSet |
m_csPropertyPage2003 | CXTPTabPaintManagerColorSet |
m_csStateButton | CXTPTabPaintManagerColorSet |
m_pPaintManager | CXTPTabPaintManagerColorSet | protected
RefreshMetrics() | CXTPDockingPaneTabColorSet2012 | virtual
SelectClipRgn(CDC *pDC, CRect rcClient, CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
SetTextColor(CDC *pDC, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerColorSet | virtual
~CXTPTabPaintManagerColorSet() | CXTPTabPaintManagerColorSet | virtual


Toolkit Pro: XTPMarkupResourceDictionary.h Source File

  • Source
  • Markup
XTPMarkupResourceDictionary.h
Go to the documentation of this file.
1
23#if !defined(__XTPMARKUPRESOURCEDICTIONARY_H__)
24# define __XTPMARKUPRESOURCEDICTIONARY_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPMarkupObject;
34class CXTPMarkupBuilder;
35
36class _XTP_EXT_CLASS CXTPMarkupResourceDictionary : public CXTPMarkupObject
37{
38 DECLARE_MARKUPCLASS(CXTPMarkupResourceDictionary);
39
40public:
41 CXTPMarkupResourceDictionary();
42 virtual ~CXTPMarkupResourceDictionary();
43
44public:
45 void Add(CXTPMarkupObject* pKey, CXTPMarkupObject* pValue);
46
47 CXTPMarkupObject* operator[](LPCWSTR lpszKey) const;
48 CXTPMarkupObject* Lookup(LPCWSTR lpszKey) const;
49 CXTPMarkupObject* Lookup(const CXTPMarkupObject* pKey) const;
50
51 static CXTPMarkupObject* AFX_CDECL FindResource(const CXTPMarkupObject* pElement,
52 const CXTPMarkupObject* pKey);
53
54protected:
55 void SetContentObject(CXTPMarkupBuilder* pBuilder, CXTPMarkupObject* pContent);
56 CXTPMarkupObject* GetObjectKey(CXTPMarkupObject* pContent) const;
57
58protected:
59 CMap<CXTPMarkupObjectPtr, CXTPMarkupObjectPtr, CXTPMarkupObjectPtr, CXTPMarkupObjectPtr>
60 m_mapDictionary;
61};
62
63# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
65#endif // !defined(__XTPMARKUPRESOURCEDICTIONARY_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h


Toolkit Pro: XTPMarkupUIElementCollection.h Source File

  • Source
  • Markup
  • Controls
XTPMarkupUIElementCollection.h
Go to the documentation of this file.
1
23#if !defined(__XTPMARKUPUIELEMENTCOLLECTION_H__)
24# define __XTPMARKUPUIELEMENTCOLLECTION_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPMarkupUIElement;
34
40class _XTP_EXT_CLASS CXTPMarkupUIElementCollection : public CXTPMarkupCollection
41{
42public:
47 CXTPMarkupUIElementCollection();
48
53 ~CXTPMarkupUIElementCollection();
54
55public:
63 CXTPMarkupUIElement* GetItem(int nIndex) const;
64
65protected:
70 void OnChanged();
71
72protected:
74public:
75 DECLARE_DISPATCH_MAP()
76# ifdef _XTP_ACTIVEX
77 DECLARE_INTERFACE_MAP()
78 DECLARE_OLETYPELIB_EX(CXTPMarkupUIElementCollection);
79# endif
80
81 DECLARE_ENUM_VARIANT(CXTPMarkupUIElementCollection);
82
83 long OleGetItemCount();
84 LPDISPATCH OleGetItem(long nIndex);
85 void OleAdd(LPDISPATCH lpElementDisp);
86 void OleInsert(long Index, LPDISPATCH lpElementDisp);
88};
89
90AFX_INLINE CXTPMarkupUIElement* CXTPMarkupUIElementCollection::GetItem(int nIndex) const
91{
92 return nIndex >= 0 && nIndex < m_arrItems.GetSize() ? (CXTPMarkupUIElement*)m_arrItems[nIndex]
93 : NULL;
94}
95
96# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
98#endif // !defined(__XTPMARKUPUIELEMENTCOLLECTION_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPMarkupUIElementCollection
CXTPMarkupUIElementCollection is a CXTPMarkupCollection derived class.
Definition XTPMarkupUIElementCollection.h:41
CXTPMarkupUIElementCollection::~CXTPMarkupUIElementCollection
~CXTPMarkupUIElementCollection()
Destroys a CXTPMarkupUIElementCollection object, handles cleanup and deallocation.
CXTPMarkupUIElementCollection::OnChanged
void OnChanged()
This method is called when the collection is changed.
CXTPMarkupUIElementCollection::CXTPMarkupUIElementCollection
CXTPMarkupUIElementCollection()
Constructs a CXTPMarkupUIElementCollection object.
CXTPMarkupUIElementCollection::GetItem
CXTPMarkupUIElement * GetItem(int nIndex) const
Retrieves a CXTPMarkupUIElement object by its index.
Definition XTPMarkupUIElementCollection.h:90
CXTPMarkupUIElement
Base class for XML Markup core level implementations.
Definition XTPMarkupUIElement.h:43


Toolkit Pro: Member List

CXTPCalendarCaptionBarControl Member List

This is the complete list of members for CXTPCalendarCaptionBarControl, including all inherited members.

AdjustLayout(CDC *pDC=NULL, const CRect *prcWnd=NULL) | CXTPCalendarCaptionBarControl | virtual
CalcMinRect(BOOL bExactSize=FALSE) | CXTPCalendarCaptionBarControl | virtual
Create(DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID) | CXTPCalendarCaptionBarControl | virtual
CXTPCalendarCaptionBarControl() | CXTPCalendarCaptionBarControl |
EnableMulticolumns(BOOL bEnable) | CXTPCalendarCaptionBarControl |
EnableTimeline(BOOL bEnable) | CXTPCalendarCaptionBarControl |
GetBorders() const | CXTPCalendarCaptionBarControl |
GetTheme() const | CXTPCalendarCaptionBarControl |
IsMulticolumnsEnable() | CXTPCalendarCaptionBarControl |
IsTimelineEnable() | CXTPCalendarCaptionBarControl |
IsUseOneLine() | CXTPCalendarCaptionBarControl |
m_Borders | CXTPCalendarCaptionBarControl | protected
m_pTheme | CXTPCalendarCaptionBarControl | protected
RegisterWindowClass(HINSTANCE hInstance=NULL) | CXTPCalendarCaptionBarControl |
SetBorders(int nLeft, int nTop, int nRight, int nBottom) | CXTPCalendarCaptionBarControl | virtual
SetButtonText(int iButtonNumber, CString sButtonText) | CXTPCalendarCaptionBarControl |
SetTheme(CXTPCalendarCaptionBarTheme *pTheme) | CXTPCalendarCaptionBarControl |
UpdateBorders() | CXTPCalendarCaptionBarControl | virtual
UseOneLine(BOOL bSet) | CXTPCalendarCaptionBarControl |
~CXTPCalendarCaptionBarControl() | CXTPCalendarCaptionBarControl | virtual


Toolkit Pro: Member List

CXTPDockingPanePanelColorSet2017 Member List

This is the complete list of members for CXTPDockingPanePanelColorSet2017, including all inherited members.

CXTPDockingPanePanelColorSet2012() | CXTPDockingPanePanelColorSet2012 |
CXTPDockingPanePanelColorSet2017() | CXTPDockingPanePanelColorSet2017 |
CXTPTabPaintManagerColorSet() | CXTPTabPaintManagerColorSet |
FillClient(CDC *pDC, CRect rc, CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
FillHeader(CDC *pDC, CRect rc, CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
FillNavigateButton(CDC *pDC, CXTPTabManagerNavigateButton *pButton, CRect &rc) | CXTPDockingPanePanelColorSet2012 | virtual
FillPropertyButton(CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerColorSet | virtual
FillStateButton(CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerColorSet | virtual
GetClientColor(CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
GetItemColor(CXTPTabManagerItem *pItem) | CXTPDockingPanePanelColorSet2012 | virtual
GradientFill(CDC *pDC, CRect rc, COLORREF clrLight, COLORREF clrDark, XTPTabPosition position) | CXTPTabPaintManagerColorSet |
IsAppThemed() const | CXTPTabPaintManagerColorSet | virtual
m_clrActiveFilesBack | CXTPTabPaintManagerColorSet |
m_clrActiveFilesBackHighlighted | CXTPTabPaintManagerColorSet |
m_clrActiveFilesBackPressed | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyph | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyphHighlighted | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyphPressed | CXTPTabPaintManagerColorSet |
m_clrAutoHideFace | CXTPTabPaintManagerColorSet |
m_clrBorderHighlight | CXTPTabPaintManagerColorSet |
m_clrButtonBorder | CXTPTabPaintManagerColorSet |
m_clrButtonBorderHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonBorderHot | CXTPTabPaintManagerColorSet |
m_clrButtonBorderKeyTips | CXTPTabPaintManagerColorSet |
m_clrButtonBorderTabContext1 | CXTPTabPaintManagerColorSet |
m_clrButtonBorderTabContext2 | CXTPTabPaintManagerColorSet |
m_clrButtonHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonHighlightedClose | CXTPTabPaintManagerColorSet |
m_clrButtonNormal | CXTPTabPaintManagerColorSet |
m_clrButtonPressed | CXTPTabPaintManagerColorSet |
m_clrButtonSelected | CXTPTabPaintManagerColorSet |
m_clrButtonSelectedHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonSelectedPressed | CXTPTabPaintManagerColorSet |
m_clrControlFace | CXTPTabPaintManagerColorSet |
m_clrFrameBorder | CXTPTabPaintManagerColorSet |
m_clrHeaderFace | CXTPTabPaintManagerColorSet |
m_clrPaneFace | CXTPTabPaintManagerColorSet |
m_clrTabClientBack | CXTPTabPaintManagerColorSet |
m_clrTabClientBorder | CXTPTabPaintManagerColorSet |
m_clrTextDisabled | CXTPTabPaintManagerColorSet |
m_clrTextHighlight | CXTPTabPaintManagerColorSet |
m_clrTextHighlightClose | CXTPTabPaintManagerColorSet |
m_clrTextNormal | CXTPTabPaintManagerColorSet |
m_clrTextPressed | CXTPTabPaintManagerColorSet |
m_clrTextSelected | CXTPTabPaintManagerColorSet |
m_clrTextSelectedHighlighted | CXTPTabPaintManagerColorSet |
m_clrTextSelectedPressed | CXTPTabPaintManagerColorSet |
m_csExcelNormal | CXTPTabPaintManagerColorSet |
m_csExcelSelected | CXTPTabPaintManagerColorSet |
m_csPropertyPage | CXTPTabPaintManagerColorSet |
m_csPropertyPage2003 | CXTPTabPaintManagerColorSet |
m_csStateButton | CXTPTabPaintManagerColorSet |
m_pPaintManager | CXTPTabPaintManagerColorSet | protected
RefreshMetrics() | CXTPDockingPanePanelColorSet2017 | virtual
SelectClipRgn(CDC *pDC, CRect rcClient, CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
SetTextColor(CDC *pDC, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerColorSet | virtual
~CXTPTabPaintManagerColorSet() | CXTPTabPaintManagerColorSet | virtual


Toolkit Pro: XTPDockingPanePanelColorSet2019.h Source File

  • Source
  • DockingPane
  • TabColorSets
XTPDockingPanePanelColorSet2019.h
Go to the documentation of this file.
1
23#if !defined(__XTPDOCKINGPANEPANELCOLORSET2019_H__)
24# define __XTPDOCKINGPANEPANELCOLORSET2019_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPDockingPanePanelColorSet2019 : public CXTPDockingPanePanelColorSet2012
39{
40public:
45 CXTPDockingPanePanelColorSet2019();
46
52 virtual void RefreshMetrics();
53};
54
55# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
57#endif // !defined(__XTPDOCKINGPANEPANELCOLORSET2019_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPDockingPanePanelColorSet2012
Helper class used to initialize default colors for a theme from an .INI resource and handle drawing r...
Definition XTPDockingPanePanelColorSet2012.h:39
CXTPDockingPanePanelColorSet2019
Helper class used to initialize default colors for a theme from an .INI resource and handle drawing r...
Definition XTPDockingPanePanelColorSet2019.h:39
CXTPDockingPanePanelColorSet2019::CXTPDockingPanePanelColorSet2019
CXTPDockingPanePanelColorSet2019()
Default class constructor.
CXTPDockingPanePanelColorSet2019::RefreshMetrics
virtual void RefreshMetrics()
This member function is used to initialize default colors for a theme from an .INI resource.


Toolkit Pro: Member List

CXTPPopupThemeResource Member List

This is the complete list of members for CXTPPopupThemeResource, including all inherited members.

CXTPPopupPaintManager() | CXTPPopupPaintManager |
CXTPPopupThemeOffice2000() | CXTPPopupThemeOffice2000 |
CXTPPopupThemeOffice2003() | CXTPPopupThemeOffice2003 |
CXTPPopupThemeOfficeXP() | CXTPPopupThemeOfficeXP |
CXTPPopupThemeResource() | CXTPPopupThemeResource |
DrawBackground(CDC *pDC, CXTPPopupControl *pControl, CRect rcClient) | CXTPPopupThemeOffice2003 | virtual
DrawButton(CDC *pDC, CXTPPopupItem *pItem) | CXTPPopupPaintManager | virtual
DrawItem(CDC *pDC, CXTPPopupItem *pItem) | CXTPPopupPaintManager |
DrawItemIcon(CDC *pDC, CXTPPopupItem *pItem) | CXTPPopupPaintManager | virtual
m_clrBackground | CXTPPopupPaintManager |
m_clrButtonPressed | CXTPPopupPaintManager |
m_clrButtonPressedBorder | CXTPPopupPaintManager |
m_clrButtonSelected | CXTPPopupPaintManager |
m_clrButtonSelectedBorder | CXTPPopupPaintManager |
m_clrFrame | CXTPPopupPaintManager |
m_clrGripper | CXTPPopupThemeOffice2003 |
m_clrText | CXTPPopupPaintManager |
m_xtpFontText | CXTPPopupPaintManager |
RefreshMetrics() | CXTPPopupThemeResource | virtual
SetFont(HFONT hFont) | CXTPPopupPaintManager |
~CXTPPopupPaintManager() | CXTPPopupPaintManager | virtual
~CXTPPopupThemeOffice2000() | CXTPPopupThemeOffice2000 | virtual
~CXTPPopupThemeOffice2003() | CXTPPopupThemeOffice2003 | virtual
~CXTPPopupThemeOfficeXP() | CXTPPopupThemeOfficeXP | virtual


Toolkit Pro: XTPRibbonCustomizeTreeCtrl.h Source File

  • Source
  • Ribbon
  • Customize
XTPRibbonCustomizeTreeCtrl.h
Go to the documentation of this file.
1
23#if !defined(__XTPRIBBONCUSTOMIZETREECTRL_H__)
24# define __XTPRIBBONCUSTOMIZETREECTRL_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPCoreTreeItem;
34class CXTPCommandBars;
35
36class _XTP_EXT_CLASS CXTPRibbonCustomizeTreeCtrl : public CXTPCoreTreeControl
37{
38public:
39 CXTPRibbonCustomizeTreeCtrl();
40
41protected:
42 virtual void StartDragItem(CXTPCoreTreeItem* pItem);
43 virtual BOOL OnDrop(COleDataObject* pDataObject, DROPEFFECT dropEffect, CPoint point);
44 virtual DROPEFFECT OnDragOver(COleDataObject* pDataObject, DWORD dwKeyState, CPoint point);
45
46 int GetItemLevel(CXTPCoreTreeItem* pItem) const;
47
48public:
49 void UpdateCommandBars();
50
51public:
52 BOOL m_bItemsTree;
53 CXTPCommandBars* m_pCommandBars;
54};
55
58# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
59#endif // __XTPRIBBONCUSTOMIZETREECTRL_H__
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCommandBars
CXTPCommandBars is a standalone class.
Definition XTPCommandBars.h:165


Toolkit Pro: XTPSkinObjectToolBar.h Source File

  • Source
  • SkinFramework
XTPSkinObjectToolBar.h
Go to the documentation of this file.
1
23#if !defined(__XTPSKINOBJECTTOOLBAR_H__)
24# define __XTPSKINOBJECTTOOLBAR_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPSkinObjectToolBar : public CXTPSkinObjectFrame
39{
41 DECLARE_DYNCREATE(CXTPSkinObjectToolBar)
43public:
48 CXTPSkinObjectToolBar();
49
54 virtual ~CXTPSkinObjectToolBar();
55
56protected:
57 void FillBackOfViewControlClass();
58 void DrawToolbarH(CDC* pDC);
59 void DrawToolbarV(CDC* pDC);
60 void DrawButton(CDC* pDC, int nIndex);
61 HIMAGELIST GetImageList(int iMode, int iIndex);
62
63 BOOL HasDropDownArrow(LPTBBUTTON ptbb);
64 BOOL HasSplitDropDown(LPTBBUTTON ptbb);
65 void DrawButtonImage(CDC* pDC, int x, int y, int nIndex);
66 BOOL HasButtonImage(LPTBBUTTON ptbb);
67 BOOL IsHorizontal();
68 BOOL IsAlphaImageList(HIMAGELIST himl);
69 void UpdateToolTipsPos();
70
71private:
72 int GetToolbarButtonCount() const;
73 BOOL GetToolbarButton(int nIndex, LPTBBUTTON lpButton) const;
74 BOOL GetToolbarItemRect(int nIndex, LPRECT lpRect) const;
75 int GetToolbarHotItem() const;
76
77protected:
79 DECLARE_MESSAGE_MAP()
80
81 LRESULT CustomDrawNotify(DWORD dwDrawStage, NMCUSTOMDRAW* pnmcd);
82 virtual BOOL CheckDrawingEnabled();
83
84 //{{AFX_VIRTUAL(CXTPSkinObjectToolBar)
85 //}}AFX_VIRTUAL
86
87 //{{AFX_MSG(CXTPSkinObjectToolBar)
88 void OnPaint();
89 BOOL OnEraseBkgnd(CDC* pDC);
90 //}}AFX_MSG
91 BOOL IsSpecialSystemToolbar();
92 int m_nSpecialToolbar;
93
94 CMap<HIMAGELIST, HIMAGELIST, BOOL, BOOL> m_mapAlphaImageList;
95
97};
98
99# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
101#endif // !defined(__XTPSKINOBJECTTOOLBAR_H__)
XTPDisableNoisyWarnings.h
CXTPSkinObjectFrame
CXTPSkinObjectFrame is a CXTPSkinObject derived class.
Definition XTPSkinObjectFrame.h:75
CXTPSkinObjectToolBar
CXTPSkinObjectToolBar is a CXTPSkinObjectFrame derived class.
Definition XTPSkinObjectToolBar.h:39
CXTPSkinObjectToolBar::~CXTPSkinObjectToolBar
virtual ~CXTPSkinObjectToolBar()
Destroys a CXTPSkinObjectToolBar object, handles cleanup and deallocation.
CXTPSkinObjectToolBar::CXTPSkinObjectToolBar
CXTPSkinObjectToolBar()
Constructs a CXTPSkinObjectToolBar object.


Toolkit Pro: Member List

XTP_GRIDRECORDITEM_ARGS Member List

This is the complete list of members for XTP_GRIDRECORDITEM_ARGS, including all inherited members.

pColumn | XTP_GRIDRECORDITEM_ARGS
pControl | XTP_GRIDRECORDITEM_ARGS
pItem | XTP_GRIDRECORDITEM_ARGS
pRow | XTP_GRIDRECORDITEM_ARGS
rcItem | XTP_GRIDRECORDITEM_ARGS


Toolkit Pro: Member List

CXTPMaskEdit Member List

This is the complete list of members for CXTPMaskEdit, including all inherited members.

AdjustBuddyRect(CWnd *pBuddy, CRect &rcUpDown, int nAlignment) | CXTPEdit |
CanOverType() const | CXTPMaskEditT< CEdit > | inline
CanPaste() | CXTPEdit | virtual
CanUseMask() const | CXTPMaskEditT< CEdit > | inline
CheckChar(TCHAR &nChar, int nPos) | CXTPMaskEditT< CEdit > | inlinevirtual
ConvertUnicodeAlpha(TCHAR nChar, BOOL bUpperCase) const | CXTPMaskEditT< CEdit > | inline
CopyToClipboard(const CString &strText) | CXTPMaskEditT< CEdit > | inline
CXTPEdit() | CXTPEdit |
CXTPMaskEdit() | CXTPMaskEdit |
CXTPMaskEditT() | CXTPMaskEditT< CEdit > | inline
DeleteCharAt(int iPos) | CXTPMaskEditT< CEdit > | inline
DrawBuddyBorders(CWnd *pBuddy, CDC *pDC, CRect rc, int nAlignment) | CXTPEdit |
GetClientBrush(CDC *pDC) | CXTPEdit | protected
GetFlatStyle() const | CXTPEdit |
GetMaskedText(int nStartPos=0, int nEndPos=-1) const | CXTPMaskEditT< CEdit > | inline
GetPromptChar() const | CXTPMaskEditT< CEdit > | inline
GetPromptString(int nLength) const | CXTPMaskEditT< CEdit > | inline
GetTheme() | CXTPEdit |
GetThemeID() | CXTPEdit |
GetUseVisualStyle() const | CXTPEdit |
HasSelection() const | CXTPEdit |
Initialize(CWnd *pParentWnd) | CXTPMaskEdit | virtual
InsertCharAt(int iPos, TCHAR nChar) | CXTPMaskEditT< CEdit > | inline
IsFlatStyle() const | CXTPEdit |
IsFocused() const | CXTPEdit |
IsHighlighted() const | CXTPEdit |
IsModified() const | CXTPMaskEditT< CEdit > | inline
IsPatternValid() | CXTPEdit |
m_bFocused | CXTPEdit | protected
m_bHighlighted | CXTPEdit | protected
m_bModified | CXTPMaskEditT< CEdit > | protected
m_bOverType | CXTPMaskEditT< CEdit > | protected
m_bPreSubclassInit | CXTPEdit | protected
m_bRedo | CXTPMaskEditT< CEdit > | protected
m_bShowBorder | CXTPEdit | protected
m_bUpdateUndo | CXTPMaskEditT< CEdit > | protected
m_bUseMask | CXTPMaskEditT< CEdit > | protected
m_chPrompt | CXTPMaskEditT< CEdit > | protected
m_nEndChar | CXTPMaskEditT< CEdit > | protected
m_nStartChar | CXTPMaskEditT< CEdit > | protected
m_pRegExp | CXTPEdit | protected
m_pTheme | CXTPEdit | protected
m_strDefault | CXTPMaskEditT< CEdit > | protected
m_strLiteral | CXTPMaskEditT< CEdit > | protected
m_strMask | CXTPMaskEditT< CEdit > | protected
m_strRedoBuffer | CXTPMaskEditT< CEdit > | protected
m_strUndoBuffer | CXTPMaskEditT< CEdit > | protected
m_strWindowText | CXTPMaskEditT< CEdit > | protected
MaskClear() | CXTPMaskEditT< CEdit > | inline
MaskCopy() | CXTPMaskEditT< CEdit > | inline
MaskCut() | CXTPMaskEditT< CEdit > | inline
MaskDeleteSel() | CXTPMaskEditT< CEdit > | inline
MaskPaste() | CXTPMaskEditT< CEdit > | inline
MaskReplaceSel(LPCTSTR lpszNewText) | CXTPMaskEditT< CEdit > | inline
MaskSelectAll() | CXTPMaskEditT< CEdit > | inline
MaskUndo() | CXTPMaskEditT< CEdit > | inline
OnCommand(WPARAM wParam, LPARAM lParam) | CXTPMaskEditT< CEdit > | inlineprotectedvirtual
PosInRange(int iPos) const | CXTPMaskEditT< CEdit > | inline
PreTranslateMessage(MSG *pMsg) | CXTPMaskEditT< CEdit > | inlinevirtual
ProcessMask(TCHAR &nChar, int nEndPos) | CXTPMaskEditT< CEdit > | inlinevirtual
RedrawEdit() | CXTPEdit | protected
RedrawFocusedFrame() | CXTPEdit | protected
RefreshMetrics() | CXTPEdit | virtual
SetEditMask(LPCTSTR lpszMask, LPCTSTR lpszLiteral, LPCTSTR lpszDefault=NULL) | CXTPEdit | virtual
SetFlatStyle(BOOL bFlatStyle=TRUE) | CXTPEdit |
SetMaskedText(LPCTSTR lpszMaskedText, int iPos=0, BOOL bUpdateWindow=TRUE) | CXTPMaskEditT< CEdit > | inline
SetOverType(BOOL bOverType) | CXTPMaskEditT< CEdit > | inline
SetPattern(LPCTSTR lpszPattern) | CXTPEdit |
SetPromptChar(TCHAR ch, BOOL bAutoReplace=TRUE) | CXTPMaskEditT< CEdit > | inline
SetTheme(XTPControlTheme nTheme) | CXTPEdit | virtual
SetUseMask(BOOL bUseMask) | CXTPMaskEditT< CEdit > | inline
SetUseVisualStyle(BOOL bUseVisualStyle=TRUE) | CXTPEdit |
ShowBorder() const | CXTPEdit |
ShowThemedBorder(BOOL bShowThemedBorder) | CXTPEdit |
~CXTPEdit() | CXTPEdit | virtual


Toolkit Pro: Member List

CXTPChartStackedBarSeriesView Member List

This is the complete list of members for CXTPChartStackedBarSeriesView, including all inherited members.

AddChildView(CXTPChartElementView *pChildView) | CXTPChartElementView |
BeforeUpdateRange(CXTPChartDeviceContext *pDC) | CXTPChartBarSeriesView | protected
CreateDeviceCommand(CXTPChartDeviceContext *pDC) | CXTPChartElementView | virtual
CreateLegendDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcBounds) | CXTPChartBarSeriesView | protectedvirtual
CreateSeriesPointView(CXTPChartDeviceContext *pDC, CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView) | CXTPChartStackedBarSeriesView | protected
CXTPChartBarSeriesView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView) | CXTPChartBarSeriesView |
CXTPChartElementView(CXTPChartElementView *pParentView) | CXTPChartElementView |
CXTPChartElementView(CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartElementView |
CXTPChartElementView(CXTPChartContainer *pContainer) | CXTPChartElementView |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartStackedBarSeriesView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView) | CXTPChartStackedBarSeriesView |
GetAt(int nIndex) const | CXTPChartElementView |
GetBounds() const | CXTPChartElementView |
GetBounds(BOOL bIncludingChildren) const | CXTPChartElementView |
GetChildren() | CXTPChartElementView |
GetCount() const | CXTPChartElementView |
GetParentView() const | CXTPChartElementView |
Is3D() const | CXTPChartObject |
m_arrChildren | CXTPChartElementView | protected
m_nBarCount | CXTPChartBarSeriesView | protected
m_nBarIndex | CXTPChartBarSeriesView | protected
m_pContainer | CXTPChartElementView | protected
m_pParentView | CXTPChartElementView | protected
m_rcBounds | CXTPChartElementView | protected
UpdateRange(CXTPChartDeviceContext *pDC) | CXTPChartStackedBarSeriesView | protected
~CXTPChartElementView() | CXTPChartElementView | protectedvirtual
~CXTPChartLegendItemView() | CXTPChartLegendItemView | inlinevirtual


Toolkit Pro: Member List

CXTPTabColorSetNativeWindows10 Member List

This is the complete list of members for CXTPTabColorSetNativeWindows10, including all inherited members.

CXTPTabPaintManagerColorSet() | CXTPTabPaintManagerColorSet |
FillClient(CDC *pDC, CRect rc, CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
FillHeader(CDC *pDC, CRect rc, CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
FillNavigateButton(CDC *pDC, CXTPTabManagerNavigateButton *pButton, CRect &rc) | CXTPTabColorSetVisualStudio2012 | virtual
FillPropertyButton(CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerColorSet | virtual
FillStateButton(CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerColorSet | virtual
GetClientColor(CXTPTabManager *pTabManager) | CXTPTabColorSetVisualStudio2012 | virtual
GetItemColor(CXTPTabManagerItem *pItem) | CXTPTabColorSetVisualStudio2012 | virtual
GradientFill(CDC *pDC, CRect rc, COLORREF clrLight, COLORREF clrDark, XTPTabPosition position) | CXTPTabPaintManagerColorSet |
IsAppThemed() const | CXTPTabPaintManagerColorSet | virtual
m_clrActiveFilesBack | CXTPTabPaintManagerColorSet |
m_clrActiveFilesBackHighlighted | CXTPTabPaintManagerColorSet |
m_clrActiveFilesBackPressed | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyph | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyphHighlighted | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyphPressed | CXTPTabPaintManagerColorSet |
m_clrAutoHideFace | CXTPTabPaintManagerColorSet |
m_clrBorderHighlight | CXTPTabPaintManagerColorSet |
m_clrButtonBorder | CXTPTabPaintManagerColorSet |
m_clrButtonBorderHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonBorderHot | CXTPTabPaintManagerColorSet |
m_clrButtonBorderKeyTips | CXTPTabPaintManagerColorSet |
m_clrButtonBorderTabContext1 | CXTPTabPaintManagerColorSet |
m_clrButtonBorderTabContext2 | CXTPTabPaintManagerColorSet |
m_clrButtonHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonHighlightedClose | CXTPTabPaintManagerColorSet |
m_clrButtonNormal | CXTPTabPaintManagerColorSet |
m_clrButtonPressed | CXTPTabPaintManagerColorSet |
m_clrButtonSelected | CXTPTabPaintManagerColorSet |
m_clrButtonSelectedHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonSelectedPressed | CXTPTabPaintManagerColorSet |
m_clrControlFace | CXTPTabPaintManagerColorSet |
m_clrFrameBorder | CXTPTabPaintManagerColorSet |
m_clrHeaderFace | CXTPTabPaintManagerColorSet |
m_clrPaneFace | CXTPTabPaintManagerColorSet |
m_clrTabClientBack | CXTPTabPaintManagerColorSet |
m_clrTabClientBorder | CXTPTabPaintManagerColorSet |
m_clrTextDisabled | CXTPTabPaintManagerColorSet |
m_clrTextHighlight | CXTPTabPaintManagerColorSet |
m_clrTextHighlightClose | CXTPTabPaintManagerColorSet |
m_clrTextNormal | CXTPTabPaintManagerColorSet |
m_clrTextPressed | CXTPTabPaintManagerColorSet |
m_clrTextSelected | CXTPTabPaintManagerColorSet |
m_clrTextSelectedHighlighted | CXTPTabPaintManagerColorSet |
m_clrTextSelectedPressed | CXTPTabPaintManagerColorSet |
m_csExcelNormal | CXTPTabPaintManagerColorSet |
m_csExcelSelected | CXTPTabPaintManagerColorSet |
m_csPropertyPage | CXTPTabPaintManagerColorSet |
m_csPropertyPage2003 | CXTPTabPaintManagerColorSet |
m_csStateButton | CXTPTabPaintManagerColorSet |
m_pPaintManager | CXTPTabPaintManagerColorSet | protected
RefreshMetrics() | CXTPTabColorSetNativeWindows10 | virtual
SelectClipRgn(CDC *pDC, CRect rcClient, CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
SetTextColor(CDC *pDC, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerColorSet | virtual
~CXTPTabPaintManagerColorSet() | CXTPTabPaintManagerColorSet | virtual


Toolkit Pro: Member List

XTP_NM_FLOWGRAPH_CONNECTIONCHANGING Member List

This is the complete list of members for XTP_NM_FLOWGRAPH_CONNECTIONCHANGING, including all inherited members.

hdr | XTP_NM_FLOWGRAPH_CONNECTIONCHANGING
pConnection | XTP_NM_FLOWGRAPH_CONNECTIONCHANGING
pInputConnectionPoint | XTP_NM_FLOWGRAPH_CONNECTIONCHANGING


Toolkit Pro: XTPRibbonThemeVisualStudio2022.h Source File

  • Source
  • Ribbon
  • Themes
XTPRibbonThemeVisualStudio2022.h
Go to the documentation of this file.
1
23#if !defined(__XTPRIBBONVISUALSTUDIO2022THEME_H__)
24# define __XTPRIBBONVISUALSTUDIO2022THEME_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPRibbonThemeVisualStudio2022 : public CXTPRibbonOffice2013Theme
39{
40public:
46 CXTPRibbonThemeVisualStudio2022(CXTPPaintManager* pPaintManager);
47
52 virtual ~CXTPRibbonThemeVisualStudio2022();
53};
54
55# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
57#endif // !defined(__XTPRIBBONVISUALSTUDIO2022THEME_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPPaintManager
Paint manager of the command bars.
Definition XTPPaintManager.h:199
CXTPRibbonOffice2013Theme
CXTPRibbonOffice2013Theme is a CXTPRibbonMarkupTheme derived class used to represent an Office 2013 r...
Definition XTPRibbonThemeOffice2013.h:50
CXTPRibbonThemeVisualStudio2022
CXTPRibbonThemeVisualStudio2022 is a CXTPRibbonOffice2013Theme derived class used to represent a Visu...
Definition XTPRibbonThemeVisualStudio2022.h:39
CXTPRibbonThemeVisualStudio2022::CXTPRibbonThemeVisualStudio2022
CXTPRibbonThemeVisualStudio2022(CXTPPaintManager *pPaintManager)
Constructs a CXTPRibbonThemeVisualStudio2022 object.
CXTPRibbonThemeVisualStudio2022::~CXTPRibbonThemeVisualStudio2022
virtual ~CXTPRibbonThemeVisualStudio2022()
Destroys a CXTPRibbonThemeVisualStudio2022 object, handles cleanup and deallocation.


Toolkit Pro: Member List

CXTPTipOfTheDay Member List

This is the complete list of members for CXTPTipOfTheDay, including all inherited members.

AddTip(LPCTSTR lpszTip) | CXTPTipOfTheDay |
CXTPTipOfTheDay(LPCTSTR lpszTipFile=NULL, CWnd *pParent=NULL) | CXTPTipOfTheDay |
EnableMarkup(BOOL bEnable) | CXTPTipOfTheDay |
GetMarkupContext() const | CXTPTipOfTheDay |
GetNextTipString(CString &strNext) | CXTPTipOfTheDay | virtual
m_arrTips | CXTPTipOfTheDay | protected
m_bClassicStyle | CXTPTipOfTheDay |
m_nNextTip | CXTPTipOfTheDay | protected
m_pFontTip | CXTPTipOfTheDay | protected
m_pFontTitle | CXTPTipOfTheDay | protected
m_pLightBulbIcon | CXTPTipOfTheDay | protected
m_pMarkupContext | CXTPTipOfTheDay | protected
m_pMarkupTipText | CXTPTipOfTheDay | protected
m_pStream | CXTPTipOfTheDay | protected
m_rcBorder | CXTPTipOfTheDay | protected
m_rcTipText | CXTPTipOfTheDay | protected
m_strTipFile | CXTPTipOfTheDay | protected
m_strTipText | CXTPTipOfTheDay | protected
m_strTipTitle | CXTPTipOfTheDay | protected
m_xtpFontTip | CXTPTipOfTheDay | protected
m_xtpFontTitle | CXTPTipOfTheDay | protected
SetDefaultFonts(CFont *pFontTitle, CFont *pFontTip) | CXTPTipOfTheDay | virtual
SetDefaultTitle(LPCTSTR lpszTitle) | CXTPTipOfTheDay | virtual
SetTipsFilePath(LPCTSTR lpszTipFile) | CXTPTipOfTheDay | virtual
SetTipText(LPCTSTR lpszText) | CXTPTipOfTheDay |
~CXTPTipOfTheDay() | CXTPTipOfTheDay | virtual


Toolkit Pro: Member List

CXTPGraphicBitmapPng Member List

This is the complete list of members for CXTPGraphicBitmapPng, including all inherited members.

CXTPGraphicBitmapPng() | CXTPGraphicBitmapPng |
IsAlpha() const | CXTPGraphicBitmapPng |
LoadFromFile(LPCTSTR lpszFileName) | CXTPGraphicBitmapPng |
LoadFromFile(CFile *pFile) | CXTPGraphicBitmapPng |
LoadFromResource(HMODULE hModule, HRSRC hRes) | CXTPGraphicBitmapPng |
m_bAlpha | CXTPGraphicBitmapPng | protected


Toolkit Pro: XTPCommandBarsNativeWindows10Theme.h Source File

  • Source
  • CommandBars
  • Themes
XTPCommandBarsNativeWindows10Theme.h
Go to the documentation of this file.
1
23#if !defined(__XTPCOMMANDBARSNATIVEWINDOWS10THEME_H__)
24# define __XTPCOMMANDBARSNATIVEWINDOWS10THEME_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
40class _XTP_EXT_CLASS CXTPCommandBarsNativeWindows10Theme : public CXTPCommandBarsOffice2013Theme
41{
43 DECLARE_DYNAMIC(CXTPCommandBarsNativeWindows10Theme)
45public:
50 CXTPCommandBarsNativeWindows10Theme();
51
57 virtual ~CXTPCommandBarsNativeWindows10Theme();
58
66 virtual void SetStateColor(COLORREF clrState = COLORREF_NULL);
67
74 virtual COLORREF GetStateColor() const;
75
76protected:
84 virtual void DrawSplitButtonFrame(CDC* pDC, CXTPControl* pButton, CRect rc);
85
99 virtual void DrawRectangle(CDC* pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled,
100 BOOL bChecked, BOOL bPopuped, XTPBarType barType,
101 XTPBarPosition barPosition);
102
117 virtual void DrawRectangle(CDC* pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled,
118 BOOL bChecked, BOOL bPopuped, XTPBarType barType,
119 XTPBarPosition barPosition, int nID);
120
129 virtual BOOL DrawRectangle(CDC* pDC, CXTPControl* pButton);
130
137 virtual COLORREF GetControlTextColor(CXTPControl* pButton);
138
150 virtual void DrawGalleryItemBack(CDC* pDC, CRect rcItem, BOOL bEnabled, BOOL bSelected,
151 BOOL bPressed, BOOL bChecked, XTPBarType barType);
152
162 virtual void DrawCheckRect(CDC* pDC, CRect rc, COLORREF clrFore, COLORREF clrBack);
163
173 virtual CSize DrawCommandBarGripper(CDC* pDC, CXTPCommandBar* pBar, BOOL bDraw = TRUE);
174
184 virtual CSize DrawControlComboBox(CDC* pDC, CXTPControlComboBox* pComboBox, BOOL bDraw);
185};
186
199_XTP_EXT_CLASS BOOL AFX_CDECL XTPSetNativeWindows10StateColor(CXTPCommandBars* pCommandBars,
200 COLORREF clrState = COLORREF_NULL);
201
203# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
204#endif // !defined(__XTPCOMMANDBARSNATIVEWINDOWS10THEME_H__)
XTPBarType
XTPBarType
Type of the command bar.
Definition XTPCommandBarsDefines.h:77
XTPBarPosition
XTPBarPosition
Position of the command bar.
Definition XTPCommandBarsDefines.h:52
XTPSetNativeWindows10StateColor
_XTP_EXT_CLASS BOOL AFX_CDECL XTPSetNativeWindows10StateColor(CXTPCommandBars *pCommandBars, COLORREF clrState=COLORREF_NULL)
Call XTPSetNativeWindows10StateColor to set the border and status bar colors for this theme to indica...
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCommandBar
CXTPCommandBar is a CWnd derived class.
Definition XTPCommandBar.h:66
CXTPCommandBars
CXTPCommandBars is a standalone class.
Definition XTPCommandBars.h:165
CXTPCommandBarsNativeWindows10Theme
The CXTPCommandBarsNativeWindows10Theme class is used to enable a Native Windows 10 style theme for C...
Definition XTPCommandBarsNativeWindows10Theme.h:41
CXTPCommandBarsNativeWindows10Theme::DrawCheckRect
virtual void DrawCheckRect(CDC *pDC, CRect rc, COLORREF clrFore, COLORREF clrBack)
Helper class called by DrawRectangle to render a checkmark background and border.
CXTPCommandBarsNativeWindows10Theme::DrawCommandBarGripper
virtual CSize DrawCommandBarGripper(CDC *pDC, CXTPCommandBar *pBar, BOOL bDraw=TRUE)
This method is called to draw the command bar's gripper.
CXTPCommandBarsNativeWindows10Theme::DrawControlComboBox
virtual CSize DrawControlComboBox(CDC *pDC, CXTPControlComboBox *pComboBox, BOOL bDraw)
This method is called to draw the control.
CXTPCommandBarsNativeWindows10Theme::DrawSplitButtonFrame
virtual void DrawSplitButtonFrame(CDC *pDC, CXTPControl *pButton, CRect rc)
This method is called to draw the frame for the SplitButton control.
CXTPCommandBarsNativeWindows10Theme::DrawGalleryItemBack
virtual void DrawGalleryItemBack(CDC *pDC, CRect rcItem, BOOL bEnabled, BOOL bSelected, BOOL bPressed, BOOL bChecked, XTPBarType barType)
This method is called to draw the background for a gallery menu item.
CXTPCommandBarsNativeWindows10Theme::SetStateColor
virtual void SetStateColor(COLORREF clrState=COLORREF_NULL)
Call this member function to set the application state color for the frame border and status bar.
CXTPCommandBarsNativeWindows10Theme::DrawRectangle
virtual BOOL DrawRectangle(CDC *pDC, CXTPControl *pButton)
This method is called to fill the control's face.
CXTPCommandBarsNativeWindows10Theme::GetControlTextColor
virtual COLORREF GetControlTextColor(CXTPControl *pButton)
This method returns the control text color to draw.
CXTPCommandBarsNativeWindows10Theme::~CXTPCommandBarsNativeWindows10Theme
virtual ~CXTPCommandBarsNativeWindows10Theme()
Destroys a CXTPCommandBarsNativeWindows10Theme object, handles cleanup and deallocation.
CXTPCommandBarsNativeWindows10Theme::CXTPCommandBarsNativeWindows10Theme
CXTPCommandBarsNativeWindows10Theme()
Constructs a CXTPCommandBarsNativeWindows10Theme object.
CXTPCommandBarsNativeWindows10Theme::GetStateColor
virtual COLORREF GetStateColor() const
Call this member function to gets the application state color for the frame border and status bar.
CXTPCommandBarsNativeWindows10Theme::DrawRectangle
virtual void DrawRectangle(CDC *pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition)
This method is called to fill the control's face.
CXTPCommandBarsNativeWindows10Theme::DrawRectangle
virtual void DrawRectangle(CDC *pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition, int nID)
This method is called to fill the control's face.
CXTPCommandBarsOffice2013Theme
The CXTPCommandBarsOffice2013Theme class is used to enable an Office 2013 style theme for Command Bar...
Definition XTPCommandBarsOffice2013Theme.h:63
CXTPControlComboBox
CXTPControlComboBox is a CXTPControl derived class.
Definition XTPControlComboBox.h:381
CXTPControl
CXTPControl is a CXTPCmdTarget derived class.
Definition XTPControl.h:841


Toolkit Pro: XTPRibbonBackstageButtonThemeVisualStudio2015.h Source File

  • Source
  • Ribbon
  • Backstage
XTPRibbonBackstageButtonThemeVisualStudio2015.h
Go to the documentation of this file.
1
23#if !defined(__XTPRIBBONBACKSTAGEBUTTONTHEMEVISUALSTUDIO2015T_H__)
24# define __XTPRIBBONBACKSTAGEBUTTONTHEMEVISUALSTUDIO2015T_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class _XTP_EXT_CLASS CXTPRibbonBackstageButtonThemeVisualStudio2015
34 : public CXTPButtonThemeVisualStudio2015
35{
36public:
37 CXTPRibbonBackstageButtonThemeVisualStudio2015();
38
39public:
40 void DrawButtonBackground(CDC* pDC, CXTPButton* pButton);
41
42protected:
43 friend class CBackstageButtonCtrl;
44};
45
46# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
48#endif // !defined(__XTPRIBBONBACKSTAGEBUTTONTHEMEVISUALSTUDIO2015T_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPButton
Push Button control.
Definition XTPButton.h:109
CXTPButtonThemeOffice2013::DrawButtonBackground
virtual void DrawButtonBackground(CDC *pDC, CXTPButton *pButton)
This member function is called to draw the background for the button.
CXTPButtonThemeVisualStudio2015
CXTPButtonThemeVisualStudio2015 is a class used to perform Visual Studio 2015 theme drawing tasks.
Definition XTPButtonThemeVisualStudio2015.h:39


Toolkit Pro: Member List

XTP_EDIT_NMHDR_PARSEEVENT Member List

This is the complete list of members for XTP_EDIT_NMHDR_PARSEEVENT, including all inherited members.

code | XTP_EDIT_NMHDR_PARSEEVENT
lParam | XTP_EDIT_NMHDR_PARSEEVENT
nmhdr | XTP_EDIT_NMHDR_PARSEEVENT
wParam | XTP_EDIT_NMHDR_PARSEEVENT


Toolkit Pro: XTPChart3dPyramidSeriesLabel.h Source File

  • Source
  • Chart
  • Styles
  • Pyramid
  • 3D
XTPChart3dPyramidSeriesLabel.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHART3DPYRAMIDSERIESLABEL_H__)
24# define __XTPCHART3DPYRAMIDSERIESLABEL_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartSeriesView;
34class CXTPChartPyramidSeriesPointViewBase;
35class CXTPChartPyramidSeriesStyleBase;
36class CXTPChart3dPyramidSeriesPointView;
37class CXTPChart3dPyramidSeriesStyle;
38
44class _XTP_EXT_CLASS CXTPChart3dPyramidSeriesLabel : public CXTPChartPyramidSeriesLabelBase
45{
46 DECLARE_SERIAL(CXTPChart3dPyramidSeriesLabel);
47
48public:
53 CXTPChart3dPyramidSeriesLabel();
54
55protected:
67 virtual CXTPChartElementView* CreateView(CXTPChartDeviceContext* pDC,
68 CXTPChartSeriesPointView* pPointView,
69 CXTPChartElementView* pParentView);
70};
71
76class _XTP_EXT_CLASS CXTPChart3dPyramidSeriesLabelView : public CXTPChartPyramidSeriesLabelViewBase
77{
78 DECLARE_DYNAMIC(CXTPChart3dPyramidSeriesLabelView);
79
80public:
89 CXTPChart3dPyramidSeriesLabelView(CXTPChartSeriesLabel* pLabel,
90 CXTPChartSeriesPointView* pPointView,
91 CXTPChartElementView* pParentView);
92
97 ~CXTPChart3dPyramidSeriesLabelView();
98
108 virtual CXTPChartDeviceCommand* CreateTranspositionDeviceCommand(CXTPChartDeviceContext* pDC);
109
119 virtual CXTPChartDeviceCommand* CreateDeviceCommand(CXTPChartDeviceContext* pDC);
120
130 virtual CXTPChartDeviceCommand* CreateConnectorDeviceCommand(CXTPChartDeviceContext* pDC);
131
142 const CXTPPoint3d* GetConnectorStartPoint() const;
143
153 void SetConnectorStartPoint(const CXTPPoint3d& point);
154
165 const CXTPPoint3d* GetConnectorBendPoint() const;
166
176 void SetConnectorBendPoint(const CXTPPoint3d& point);
177
188 const CXTPPoint3d* GetConnectorEndPoint() const;
189
199 void SetConnectorEndPoint(const CXTPPoint3d& point);
200
211 const CPoint* GetLabelAnchorPoint() const;
212
222 void SetLabelAnchorPoint(CPoint ptAnchor);
223
234 const CPoint* GetLabelAnchorOrigin() const;
235
245 void SetLabelAnchorOrigin(CPoint ptAnchorOrigin);
246
254 void SetLeftDirected();
255
266 BOOL IsLeftDirected() const;
267
275 void SetRightDirected();
276
287 BOOL IsRightDirected() const;
288
299 BOOL IsConnectorVisible() const;
300
310 void SetConnectorVisible(BOOL bVisible = TRUE);
311
312protected:
313 CXTPPoint3d* m_ptStart;
314 CXTPPoint3d* m_ptBend;
315 CXTPPoint3d* m_ptEnd;
316 CPoint m_ptLabelAnchor;
317 CPoint m_ptLabelAnchorOrigin;
318 CXTPChart3dPyramidSeriesPointView* m_p3dPointView;
319 BOOL m_bLeftDirected;
320 BOOL m_bConnectorVisible;
322 friend class CXTPChart3dPyramidSeriesLabelsView;
323};
324
325AFX_INLINE const CXTPPoint3d* CXTPChart3dPyramidSeriesLabelView::GetConnectorStartPoint() const
326{
327 return m_ptStart;
328}
329
330AFX_INLINE const CXTPPoint3d* CXTPChart3dPyramidSeriesLabelView::GetConnectorBendPoint() const
331{
332 return m_ptBend;
333}
334
335AFX_INLINE const CXTPPoint3d* CXTPChart3dPyramidSeriesLabelView::GetConnectorEndPoint() const
336{
337 return m_ptEnd;
338}
339
340AFX_INLINE void CXTPChart3dPyramidSeriesLabelView::SetLabelAnchorPoint(CPoint ptAnchor)
341{
342 m_ptLabelAnchor = ptAnchor;
343}
344
345AFX_INLINE void CXTPChart3dPyramidSeriesLabelView::SetLabelAnchorOrigin(CPoint ptAnchorOrigin)
346{
347 m_ptLabelAnchorOrigin = ptAnchorOrigin;
348}
349
350AFX_INLINE void CXTPChart3dPyramidSeriesLabelView::SetLeftDirected()
351{
352 m_bLeftDirected = TRUE;
353}
354
355AFX_INLINE BOOL CXTPChart3dPyramidSeriesLabelView::IsLeftDirected() const
356{
357 return m_bLeftDirected;
358}
359
360AFX_INLINE void CXTPChart3dPyramidSeriesLabelView::SetRightDirected()
361{
362 m_bLeftDirected = FALSE;
363}
364
365AFX_INLINE BOOL CXTPChart3dPyramidSeriesLabelView::IsRightDirected() const
366{
367 return !m_bLeftDirected;
368}
369
370AFX_INLINE BOOL CXTPChart3dPyramidSeriesLabelView::IsConnectorVisible() const
371{
372 return m_bConnectorVisible;
373}
374
375AFX_INLINE void CXTPChart3dPyramidSeriesLabelView::SetConnectorVisible(BOOL bVisible /*= TRUE*/)
376{
377 m_bConnectorVisible = bVisible;
378}
379
384class _XTP_EXT_CLASS CXTPChart3dPyramidSeriesLabelsView : public CXTPChartElementView
385{
386 DECLARE_DYNAMIC(CXTPChart3dPyramidSeriesLabelsView);
387
388public:
395 CXTPChart3dPyramidSeriesLabelsView(CXTPChartElementView* pParentView);
396
397public:
408 virtual CXTPChartDeviceCommand* CreateDeviceCommand(CXTPChartDeviceContext* pDC);
409
414 void ResolveOverlapping();
415
416private:
417 CXTPChart3dPyramidSeriesStyle* GetStyle() const;
418};
420# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
421#endif //#if !defined(__XTPCHART3DPYRAMIDSERIESLABEL_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChart3dPyramidSeriesLabel
CXTPChartPyramidSeriesLabelBase is a kind of CXTPChart3dPyramidSeriesLabel.
Definition XTPChart3dPyramidSeriesLabel.h:45
CXTPChart3dPyramidSeriesLabel::CXTPChart3dPyramidSeriesLabel
CXTPChart3dPyramidSeriesLabel()
Constructs a CXTPChart3dPyramidSeriesLabel object.
CXTPChart3dPyramidSeriesLabel::CreateView
virtual CXTPChartElementView * CreateView(CXTPChartDeviceContext *pDC, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView)
This function creates the view of the pyramid series.
CXTPChart3dPyramidSeriesLabelView
Represents series label view object.
Definition XTPChart3dPyramidSeriesLabel.h:77
CXTPChart3dPyramidSeriesLabelView::m_p3dPointView
CXTPChart3dPyramidSeriesPointView * m_p3dPointView
Point view.
Definition XTPChart3dPyramidSeriesLabel.h:318
CXTPChart3dPyramidSeriesLabelView::SetLeftDirected
void SetLeftDirected()
Makes the label left directed.
Definition XTPChart3dPyramidSeriesLabel.h:350
CXTPChart3dPyramidSeriesLabelView::IsConnectorVisible
BOOL IsConnectorVisible() const
Determines if the connector is visible.
Definition XTPChart3dPyramidSeriesLabel.h:370
CXTPChart3dPyramidSeriesLabelView::SetConnectorBendPoint
void SetConnectorBendPoint(const CXTPPoint3d &point)
Sets the connector bend point.
CXTPChart3dPyramidSeriesLabelView::IsRightDirected
BOOL IsRightDirected() const
Determies if the label is right directed.
Definition XTPChart3dPyramidSeriesLabel.h:365
CXTPChart3dPyramidSeriesLabelView::CXTPChart3dPyramidSeriesLabelView
CXTPChart3dPyramidSeriesLabelView(CXTPChartSeriesLabel *pLabel, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView)
Constructs a view object.
CXTPChart3dPyramidSeriesLabelView::m_ptLabelAnchor
CPoint m_ptLabelAnchor
Label anchor point.
Definition XTPChart3dPyramidSeriesLabel.h:316
CXTPChart3dPyramidSeriesLabelView::m_ptEnd
CXTPPoint3d * m_ptEnd
Connector end point or NULL if not set.
Definition XTPChart3dPyramidSeriesLabel.h:315
CXTPChart3dPyramidSeriesLabelView::SetLabelAnchorOrigin
void SetLabelAnchorOrigin(CPoint ptAnchorOrigin)
Sets the label anchor origin point.
Definition XTPChart3dPyramidSeriesLabel.h:345
CXTPChart3dPyramidSeriesLabelView::SetLabelAnchorPoint
void SetLabelAnchorPoint(CPoint ptAnchor)
Sets the label anchor point.
Definition XTPChart3dPyramidSeriesLabel.h:340
CXTPChart3dPyramidSeriesLabelView::m_ptStart
CXTPPoint3d * m_ptStart
Connector start point or NULL if not set.
Definition XTPChart3dPyramidSeriesLabel.h:313
CXTPChart3dPyramidSeriesLabelView::SetConnectorStartPoint
void SetConnectorStartPoint(const CXTPPoint3d &point)
Sets the connector start point.
CXTPChart3dPyramidSeriesLabelView::CreateConnectorDeviceCommand
virtual CXTPChartDeviceCommand * CreateConnectorDeviceCommand(CXTPChartDeviceContext *pDC)
Creates a label connector drawing device command object.
CXTPChart3dPyramidSeriesLabelView::CreateTranspositionDeviceCommand
virtual CXTPChartDeviceCommand * CreateTranspositionDeviceCommand(CXTPChartDeviceContext *pDC)
Creates a label transposition device command object.
CXTPChart3dPyramidSeriesLabelView::IsLeftDirected
BOOL IsLeftDirected() const
Determies if the label is left directed.
Definition XTPChart3dPyramidSeriesLabel.h:355
CXTPChart3dPyramidSeriesLabelView::GetLabelAnchorOrigin
const CPoint * GetLabelAnchorOrigin() const
Obtains a previously set label anchor origin point.
CXTPChart3dPyramidSeriesLabelView::CreateDeviceCommand
virtual CXTPChartDeviceCommand * CreateDeviceCommand(CXTPChartDeviceContext *pDC)
Creates a label drawing device command object.
CXTPChart3dPyramidSeriesLabelView::SetConnectorEndPoint
void SetConnectorEndPoint(const CXTPPoint3d &point)
Sets the connector end point.
CXTPChart3dPyramidSeriesLabelView::GetLabelAnchorPoint
const CPoint * GetLabelAnchorPoint() const
Obtains a previously set label anchor point.
CXTPChart3dPyramidSeriesLabelView::SetConnectorVisible
void SetConnectorVisible(BOOL bVisible=TRUE)
Sets connector visibility.
Definition XTPChart3dPyramidSeriesLabel.h:375
CXTPChart3dPyramidSeriesLabelView::m_bConnectorVisible
BOOL m_bConnectorVisible
TRUE if connector is visible.
Definition XTPChart3dPyramidSeriesLabel.h:320
CXTPChart3dPyramidSeriesLabelView::GetConnectorEndPoint
const CXTPPoint3d * GetConnectorEndPoint() const
Obtains a previously set connector end point.
Definition XTPChart3dPyramidSeriesLabel.h:335
CXTPChart3dPyramidSeriesLabelView::SetRightDirected
void SetRightDirected()
Makes the label right directed.
Definition XTPChart3dPyramidSeriesLabel.h:360
CXTPChart3dPyramidSeriesLabelView::m_ptBend
CXTPPoint3d * m_ptBend
Connector bend point or NULL if not set.
Definition XTPChart3dPyramidSeriesLabel.h:314
CXTPChart3dPyramidSeriesLabelView::GetConnectorStartPoint
const CXTPPoint3d * GetConnectorStartPoint() const
Obtains a previously set connector start point.
Definition XTPChart3dPyramidSeriesLabel.h:325
CXTPChart3dPyramidSeriesLabelView::~CXTPChart3dPyramidSeriesLabelView
~CXTPChart3dPyramidSeriesLabelView()
Handles view object destruction.
CXTPChart3dPyramidSeriesLabelView::m_bLeftDirected
BOOL m_bLeftDirected
TRUE if label is to be left directed.
Definition XTPChart3dPyramidSeriesLabel.h:319
CXTPChart3dPyramidSeriesLabelView::m_ptLabelAnchorOrigin
CPoint m_ptLabelAnchorOrigin
Label anchor point origin.
Definition XTPChart3dPyramidSeriesLabel.h:317
CXTPChart3dPyramidSeriesLabelView::GetConnectorBendPoint
const CXTPPoint3d * GetConnectorBendPoint() const
Obtains a previously set connector bend point.
Definition XTPChart3dPyramidSeriesLabel.h:330
CXTPChart3dPyramidSeriesLabelsView
Represents a view object for all pyramid series labels.
Definition XTPChart3dPyramidSeriesLabel.h:385
CXTPChart3dPyramidSeriesLabelsView::CreateDeviceCommand
virtual CXTPChartDeviceCommand * CreateDeviceCommand(CXTPChartDeviceContext *pDC)
Creates view drawing device command for the device context specified.
CXTPChart3dPyramidSeriesLabelsView::CXTPChart3dPyramidSeriesLabelsView
CXTPChart3dPyramidSeriesLabelsView(CXTPChartElementView *pParentView)
Constructs view object.
CXTPChart3dPyramidSeriesLabelsView::ResolveOverlapping
void ResolveOverlapping()
Resolves label overlapping in an implementation specific way.
CXTPChart3dPyramidSeriesPointView
This class abstracts the view of a pyramid series point.
Definition XTPChart3dPyramidSeriesPointView.h:47
CXTPChart3dPyramidSeriesStyle
This class abstracts the basic style of a pyramid series.
Definition XTPChart3dPyramidSeriesStyle.h:49
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartElementView
This class represents the view of a chart element.
Definition XTPChartElementView.h:47
CXTPChartPyramidSeriesLabelBase
This class abstracts the pyramid series label.
Definition XTPChartPyramidSeriesLabelBase.h:55
CXTPChartPyramidSeriesLabelBase::GetStyle
CXTPChartPyramidSeriesStyleBase * GetStyle() const
Call this function to get the basic style of the pyramid series.
CXTPChartPyramidSeriesLabelViewBase
This class abstracts the view of a pyramid series label.
Definition XTPChartPyramidSeriesLabelBase.h:166
CXTPChartPyramidSeriesPointViewBase
This class abstracts the view of a pyramid series point.
Definition XTPChartPyramidSeriesPointViewBase.h:46
CXTPChartPyramidSeriesStyleBase
This class abstracts the basic style of a pyramid series.
Definition XTPChartPyramidSeriesStyleBase.h:45
CXTPChartSeriesLabel
This class abstracts the label of a series.
Definition XTPChartSeriesLabel.h:49
CXTPChartSeriesPointView
Represents chart series point view.
Definition XTPChartSeriesPointView.h:48
CXTPPoint3T< double >


Toolkit Pro: Member List

CXTPDockingPaneTabColorSetNativeWindows11 Member List

This is the complete list of members for CXTPDockingPaneTabColorSetNativeWindows11, including all inherited members.

CXTPDockingPaneTabColorSet2012() | CXTPDockingPaneTabColorSet2012 |
CXTPDockingPaneTabColorSetNativeWindows11() | CXTPDockingPaneTabColorSetNativeWindows11 |
CXTPTabPaintManagerColorSet() | CXTPTabPaintManagerColorSet |
FillClient(CDC *pDC, CRect rc, CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
FillHeader(CDC *pDC, CRect rc, CXTPTabManager *pTabManager) | CXTPDockingPaneTabColorSetNativeWindows11 | virtual
FillNavigateButton(CDC *pDC, CXTPTabManagerNavigateButton *pButton, CRect &rc) | CXTPDockingPaneTabColorSet2012 | virtual
FillPropertyButton(CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerColorSet | virtual
FillStateButton(CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerColorSet | virtual
GetClientColor(CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
GetItemColor(CXTPTabManagerItem *pItem) | CXTPDockingPaneTabColorSet2012 | virtual
GradientFill(CDC *pDC, CRect rc, COLORREF clrLight, COLORREF clrDark, XTPTabPosition position) | CXTPTabPaintManagerColorSet |
IsAppThemed() const | CXTPTabPaintManagerColorSet | virtual
m_clrActiveFilesBack | CXTPTabPaintManagerColorSet |
m_clrActiveFilesBackHighlighted | CXTPTabPaintManagerColorSet |
m_clrActiveFilesBackPressed | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyph | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyphHighlighted | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyphPressed | CXTPTabPaintManagerColorSet |
m_clrAutoHideFace | CXTPTabPaintManagerColorSet |
m_clrBorderHighlight | CXTPTabPaintManagerColorSet |
m_clrButtonBorder | CXTPTabPaintManagerColorSet |
m_clrButtonBorderHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonBorderHot | CXTPTabPaintManagerColorSet |
m_clrButtonBorderKeyTips | CXTPTabPaintManagerColorSet |
m_clrButtonBorderTabContext1 | CXTPTabPaintManagerColorSet |
m_clrButtonBorderTabContext2 | CXTPTabPaintManagerColorSet |
m_clrButtonHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonHighlightedClose | CXTPTabPaintManagerColorSet |
m_clrButtonNormal | CXTPTabPaintManagerColorSet |
m_clrButtonPressed | CXTPTabPaintManagerColorSet |
m_clrButtonSelected | CXTPTabPaintManagerColorSet |
m_clrButtonSelectedHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonSelectedPressed | CXTPTabPaintManagerColorSet |
m_clrControlFace | CXTPTabPaintManagerColorSet |
m_clrFrameBorder | CXTPTabPaintManagerColorSet |
m_clrHeaderFace | CXTPTabPaintManagerColorSet |
m_clrPaneFace | CXTPTabPaintManagerColorSet |
m_clrTabClientBack | CXTPTabPaintManagerColorSet |
m_clrTabClientBorder | CXTPTabPaintManagerColorSet |
m_clrTextDisabled | CXTPTabPaintManagerColorSet |
m_clrTextHighlight | CXTPTabPaintManagerColorSet |
m_clrTextHighlightClose | CXTPTabPaintManagerColorSet |
m_clrTextNormal | CXTPTabPaintManagerColorSet |
m_clrTextPressed | CXTPTabPaintManagerColorSet |
m_clrTextSelected | CXTPTabPaintManagerColorSet |
m_clrTextSelectedHighlighted | CXTPTabPaintManagerColorSet |
m_clrTextSelectedPressed | CXTPTabPaintManagerColorSet |
m_csExcelNormal | CXTPTabPaintManagerColorSet |
m_csExcelSelected | CXTPTabPaintManagerColorSet |
m_csPropertyPage | CXTPTabPaintManagerColorSet |
m_csPropertyPage2003 | CXTPTabPaintManagerColorSet |
m_csStateButton | CXTPTabPaintManagerColorSet |
m_pPaintManager | CXTPTabPaintManagerColorSet | protected
RefreshMetrics() | CXTPDockingPaneTabColorSet2012 | virtual
SelectClipRgn(CDC *pDC, CRect rcClient, CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
SetTextColor(CDC *pDC, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerColorSet | virtual
~CXTPTabPaintManagerColorSet() | CXTPTabPaintManagerColorSet | virtual


Toolkit Pro: Member List

CXTPChart3dFunnelDiagram Member List

This is the complete list of members for CXTPChart3dFunnelDiagram, including all inherited members.

CalculateSeriesLayout(CXTPChartDeviceContext *pDC, CXTPChartDiagramView *pView) | CXTPChartFunnelDiagramBase< BaseDiagram > | virtual
CreateView(CXTPChartDeviceContext *pDC, CXTPChartElementView *pParent) | CXTPChart3dFunnelDiagram | virtual
CXTPChart3dFunnelDiagram() | CXTPChart3dFunnelDiagram |
CXTPChartFunnelDiagramBase() | CXTPChartFunnelDiagramBase< BaseDiagram > |


Toolkit Pro: XTPPropExchangeXMLNode.h Source File

  • Source
  • Common
  • PropExchange
XTPPropExchangeXMLNode.h
Go to the documentation of this file.
1
23#if !defined(__XTPPROPEXCHANGEXMLNODE_H__)
24# define __XTPPROPEXCHANGEXMLNODE_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# ifndef _XTP_EXCLUDE_XML
32# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
33
51class _XTP_EXT_CLASS CXTPPropExchangeXMLNode : public CXTPPropExchange
52{
53 class CXMLEnumerator;
55 DECLARE_DYNAMIC(CXTPPropExchangeXMLNode)
57public:
66 CXTPPropExchangeXMLNode(BOOL bLoading, CXTPDOMNodePtr xmlParentNode, LPCTSTR lpszSection);
67
68public:
74 static BOOL AFX_CDECL IsXMLSupported();
75
76public:
101 virtual BOOL ExchangeProp(LPCTSTR pszPropName, VARTYPE vtProp, void* pvProp,
102 const void* pvDefault = NULL);
103
119 virtual CXTPPropExchange* GetSection(LPCTSTR lpszSection);
120
125 virtual void EmptySection();
126
148 virtual CXTPPropExchangeEnumerator* GetEnumerator(LPCTSTR lpszSection);
149
150public:
157 BOOL IsPropertyExists(LPCTSTR pszPropName);
158
165 BOOL IsSectionExists(LPCTSTR lpszSection);
166
173 CString GetSectionName();
174
180 void SetCompactMode(BOOL bCompactMode);
181
190 BOOL LoadFromFile(LPCTSTR lpszFileName);
191
199 BOOL LoadFromString(LPCSTR lpszState);
200
208 BOOL LoadFromString(LPCWSTR lpszState);
209
217 BOOL LoadFromString(BSTR bstrState);
218
226 BOOL LoadFromEncodedString(LPCSTR lpszState);
227
235 BOOL LoadFromEncodedString(LPCWSTR lpszState);
236
246 BOOL LoadFromResource(HINSTANCE hInstance, LPCTSTR lpszResourceName, LPCTSTR lpszResourceType);
247
255 CString GetXML(BOOL bFormatted = FALSE);
256
264 CString GetEncodedXML(BOOL bFormatted = FALSE);
265
273 HRESULT SaveToFile(LPCTSTR lpszFileName, BOOL bFormatted = TRUE);
274
281 virtual BOOL OnBeforeExchange();
282
289 void SetLoading(BOOL bLoading);
290
297 BOOL PutSection(CXTPPropExchangeXMLNode* pNode);
298
305 CXTPPropExchangeXMLNode* Clone(BOOL bRecursive);
306
317 void SetEncoding(LPCTSTR lpszEncoding);
318
324 CXTPDOMNodePtr GetSectionNode() const
325 {
326 return m_xmlSectionNode;
327 }
328
336 CXTPPropExchangeXMLNode* CreateSection(LPCTSTR pszSection);
337
338public:
339 CXTPDOMDocumentPtr GetDocumentPtr() const;
340 CString GetEncoding() const;
341
342protected:
350 CXTPDOMNodePtr GetProfileNode(LPCTSTR lpszSection);
351
360 CXTPDOMNodePtr GetEntryNode(LPCTSTR lpszEntry, BOOL bCreate);
361
362private:
363 void UpdateDocumentEncoding();
364 BOOL CreateDocumentInstance();
365 void FormatFile(LPCTSTR lpszFileName);
366 void TraceParseError();
367 CString BstrToString(BSTR bstrVal);
368 void FormatString(CString& str);
369
370protected:
371 CXTPDOMDocumentPtr m_xmlDocPtr;
372 CXTPDOMNodePtr m_xmlParentNode;
373 CXTPDOMNodePtr m_xmlSectionNode;
374 CString m_strSectionName;
375 CString m_strEncoding;
376 BOOL m_bCompactMode;
377 friend class CXMLEnumerator;
378 friend class CPropExchangeCtrl;
379};
381AFX_INLINE CXTPDOMDocumentPtr CXTPPropExchangeXMLNode::GetDocumentPtr() const
382{
383 return m_xmlDocPtr;
384}
385
386AFX_INLINE CString CXTPPropExchangeXMLNode::GetEncoding() const
387{
388 return m_strEncoding;
389}
391# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
392# endif // _XTP_EXCLUDE_XML
394#endif // !defined(__XTPPROPEXCHANGEXMLNODE_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPPropExchangeEnumerator
CXTPPropExchangeEnumerator is standalone class.
Definition XTPPropExchangeEnumerator.h:56
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72
CXTPPropExchangeXMLNode
CXTPPropExchangeXMLNode is CXTPPropExchange derived class.
Definition XTPPropExchangeXMLNode.h:52
CXTPPropExchangeXMLNode::GetXML
CString GetXML(BOOL bFormatted=FALSE)
Retrieves the XML representation of the node and all its descendants.
CXTPPropExchangeXMLNode::m_strSectionName
CString m_strSectionName
Section name.
Definition XTPPropExchangeXMLNode.h:374
CXTPPropExchangeXMLNode::IsXMLSupported
static BOOL AFX_CDECL IsXMLSupported()
Determines if XML installed in System (IE 4.0)
CXTPPropExchangeXMLNode::GetSection
virtual CXTPPropExchange * GetSection(LPCTSTR lpszSection)
This method creates new section for text base storages (CXTPPropExchangeXMLNode and CXTPPropExchangeR...
CXTPPropExchangeXMLNode::m_xmlDocPtr
CXTPDOMDocumentPtr m_xmlDocPtr
XML Document pointer.
Definition XTPPropExchangeXMLNode.h:371
CXTPPropExchangeXMLNode::IsPropertyExists
BOOL IsPropertyExists(LPCTSTR pszPropName)
Call this method to check if property entry exists.
CXTPPropExchangeXMLNode::LoadFromString
BOOL LoadFromString(BSTR bstrState)
Loads the contents of string to XML.
CXTPPropExchangeXMLNode::LoadFromEncodedString
BOOL LoadFromEncodedString(LPCSTR lpszState)
Loads the contents of the encoded string to XML.
CXTPPropExchangeXMLNode::SetCompactMode
void SetCompactMode(BOOL bCompactMode)
Call this method to store data in compact mode (To use node attributes instead nodes)
CXTPPropExchangeXMLNode::LoadFromString
BOOL LoadFromString(LPCSTR lpszState)
Loads the contents of string to XML.
CXTPPropExchangeXMLNode::m_xmlSectionNode
CXTPDOMNodePtr m_xmlSectionNode
XML Section node pointer.
Definition XTPPropExchangeXMLNode.h:373
CXTPPropExchangeXMLNode::GetEncodedXML
CString GetEncodedXML(BOOL bFormatted=FALSE)
Retrieves the encoded XML representation of the node and all its descendants.
CXTPPropExchangeXMLNode::EmptySection
virtual void EmptySection()
Call this method to free section information before storing.
CXTPPropExchangeXMLNode::SetLoading
void SetLoading(BOOL bLoading)
Call this member to change loading flag.
CXTPPropExchangeXMLNode::CreateSection
CXTPPropExchangeXMLNode * CreateSection(LPCTSTR pszSection)
Creates new XML node and put it as Child.
CXTPPropExchangeXMLNode::LoadFromFile
BOOL LoadFromFile(LPCTSTR lpszFileName)
Loads the contents of an existing file into a XML.
CXTPPropExchangeXMLNode::m_bCompactMode
BOOL m_bCompactMode
TRUE to use compact mode.
Definition XTPPropExchangeXMLNode.h:376
CXTPPropExchangeXMLNode::CXTPPropExchangeXMLNode
CXTPPropExchangeXMLNode(BOOL bLoading, CXTPDOMNodePtr xmlParentNode, LPCTSTR lpszSection)
Constructs CXTPPropExchangeXMLNode a object.
CXTPPropExchangeXMLNode::IsSectionExists
BOOL IsSectionExists(LPCTSTR lpszSection)
Call this method to check if section exists.
CXTPPropExchangeXMLNode::PutSection
BOOL PutSection(CXTPPropExchangeXMLNode *pNode)
Call this member to append one section to another.
CXTPPropExchangeXMLNode::GetSectionNode
CXTPDOMNodePtr GetSectionNode() const
Call this member to get access to dom xml node for current section.
Definition XTPPropExchangeXMLNode.h:324
CXTPPropExchangeXMLNode::LoadFromString
BOOL LoadFromString(LPCWSTR lpszState)
Loads the contents of string to XML.
CXTPPropExchangeXMLNode::SetEncoding
void SetEncoding(LPCTSTR lpszEncoding)
Call this method to set encoding for XML output.
CXTPPropExchangeXMLNode::OnBeforeExchange
virtual BOOL OnBeforeExchange()
This method is called before exchange properties.
CXTPPropExchangeXMLNode::GetEntryNode
CXTPDOMNodePtr GetEntryNode(LPCTSTR lpszEntry, BOOL bCreate)
Retrieves entry node which the value is to be written.
CXTPPropExchangeXMLNode::GetProfileNode
CXTPDOMNodePtr GetProfileNode(LPCTSTR lpszSection)
Retrieves profile node.
CXTPPropExchangeXMLNode::LoadFromEncodedString
BOOL LoadFromEncodedString(LPCWSTR lpszState)
Loads the contents of the encoded string to XML.
CXTPPropExchangeXMLNode::Clone
CXTPPropExchangeXMLNode * Clone(BOOL bRecursive)
Creates cloned version of the section.
CXTPPropExchangeXMLNode::GetEnumerator
virtual CXTPPropExchangeEnumerator * GetEnumerator(LPCTSTR lpszSection)
Call this method to enumerate child sections.
CXTPPropExchangeXMLNode::m_xmlParentNode
CXTPDOMNodePtr m_xmlParentNode
XML Parent node pointer.
Definition XTPPropExchangeXMLNode.h:372
CXTPPropExchangeXMLNode::SaveToFile
HRESULT SaveToFile(LPCTSTR lpszFileName, BOOL bFormatted=TRUE)
Saves an XML document to the specified location.
CXTPPropExchangeXMLNode::ExchangeProp
virtual BOOL ExchangeProp(LPCTSTR pszPropName, VARTYPE vtProp, void *pvProp, const void *pvDefault=NULL)
Exchanges a property between a storage medium and the control.
CXTPPropExchangeXMLNode::LoadFromResource
BOOL LoadFromResource(HINSTANCE hInstance, LPCTSTR lpszResourceName, LPCTSTR lpszResourceType)
Loads the resource by the specified type.
CXTPPropExchangeXMLNode::GetSectionName
CString GetSectionName()
Retrieves section name of the XML node.
CXTPPropExchangeXMLNode::m_strEncoding
CString m_strEncoding
XML encoding.
Definition XTPPropExchangeXMLNode.h:375


Toolkit Pro: XTPTaskPanelExplorerTheme.h Source File

  • Source
  • TaskPanel
  • Themes
XTPTaskPanelExplorerTheme.h
Go to the documentation of this file.
1
23#ifndef XTPTaskPanelExplorerTheme_h__
24# define XTPTaskPanelExplorerTheme_h__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
39class _XTP_EXT_CLASS CXTPTaskPanelExplorerTheme : public CXTPTaskPanelPaintManager
40{
41public:
46 CXTPTaskPanelExplorerTheme();
47
52 void RefreshMetrics();
53
54 BOOL m_bExplorerTheme;
56};
58# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
59#endif // XTPTaskPanelExplorerTheme_h__
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPTaskPanelExplorerTheme
CXTPTaskPanelExplorerTheme represents an Explorer style theme.
Definition XTPTaskPanelExplorerTheme.h:40
CXTPTaskPanelExplorerTheme::m_bExplorerTheme
BOOL m_bExplorerTheme
TRUE to use Explorer theme under WinXP and to use Office 2000 under older OSes.
Definition XTPTaskPanelExplorerTheme.h:54
CXTPTaskPanelExplorerTheme::RefreshMetrics
void RefreshMetrics()
Refreshes the visual metrics of the task panel.
CXTPTaskPanelExplorerTheme::CXTPTaskPanelExplorerTheme
CXTPTaskPanelExplorerTheme()
Constructs a CXTPTaskPanelExplorerTheme object.
CXTPTaskPanelPaintManager
CXTPTaskPanelPaintManager is a standalone class used by CXTPTaskPanel as a paint manager.
Definition XTPTaskPanelPaintManager.h:115


Toolkit Pro: XTPSkinManagerModuleList.h Source File

  • Source
  • SkinFramework
XTPSkinManagerModuleList.h
Go to the documentation of this file.
1
23#if !defined(__XTPSKINMANAGERMODULELIST_H__)
24# define __XTPSKINMANAGERMODULELIST_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableAdvancedWarnings.h"
32# include <stddef.h>
33# include "Common/Base/Diagnostic/XTPEnableAdvancedWarnings.h"
34
35# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
36
39struct XTP_MODULEINFO
40{
41 LPVOID lpBaseOfDll;
42 DWORD SizeOfImage;
43 LPVOID EntryPoint;
44 HMODULE hModule;
45 UINT nLockCount;
46 BOOL bUnacceptable;
47};
48
49class CXTPSkinManagerModuleListSharedData
50{
51 friend class CXTPSingleton<CXTPSkinManagerModuleListSharedData>;
52
53private:
54 CXTPSkinManagerModuleListSharedData();
55
56public:
57 ~CXTPSkinManagerModuleListSharedData();
58
59 const CXTPModuleHandle& GetPsapiDllHandle() const;
60 BOOL Exists() const;
61
62private:
63 void Init();
64
65 CXTPModuleHandle m_hPsapiDll;
66 BOOL m_bExists;
67 BOOL m_bInitialized;
68};
69
70# define XTP_WIN32SDK_MODULEINFO_SIZE offsetof(XTP_MODULEINFO, hModule)
71
72class _XTP_EXT_CLASS CXTPSkinManagerModuleList
73{
74 class CModuleEnumerator;
75 class CPsapiModuleEnumerator;
76 class CToolHelpModuleEnumerator;
77
78public:
79 CXTPSkinManagerModuleList(DWORD dwProcessId, BOOL bUseCache = FALSE);
80 virtual ~CXTPSkinManagerModuleList();
81
82public:
84 _XTP_DEPRECATED_IN_FAVOR(CXTPSkinManagerModuleListSharedData)
86 typedef CXTPSkinManagerModuleListSharedData CSharedData;
87
88 static BOOL AFX_CDECL DoesEnumeratorExist();
89 static CXTPSkinManagerModuleListSharedData& AFX_CDECL GetSharedData();
90
91public:
92 void PreLoad(BOOL bThreadSafe);
93
94 HMODULE GetFirstModule();
95 HMODULE GetNextModule();
96
97 BOOL GetModuleInformation(HMODULE hModule, XTP_MODULEINFO* lpmodinfo);
98
99protected:
100 CModuleEnumerator* m_pEnumerator;
101};
102
105# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
107#endif // !defined(__XTPSKINMANAGERMODULELIST_H__)
XTPDisableAdvancedWarnings.h
XTPDisableNoisyWarnings.h
XTPEnableAdvancedWarnings.h
XTPEnableNoisyWarnings.h
CXTPModuleHandle
CXTPModuleHandle class is helper for LoadLibray/GetModuleHandle methods.
Definition XTPSystemHelpers.h:80
CXTPSingleton
Implements Singleton design pattern.
Definition XTPSingleton.h:215


Toolkit Pro: Member List

CXTPChartSeriesPoint Member List

This is the complete list of members for CXTPChartSeriesPoint, including all inherited members.

CommonConstruct() | CXTPChartSeriesPoint | protected
CXTPChartElement() | CXTPChartElement |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartSeriesPoint() | CXTPChartSeriesPoint |
CXTPChartSeriesPoint(const CXTPChartString &strArgument, double dValue) | CXTPChartSeriesPoint |
CXTPChartSeriesPoint(double dArgument, double dValue) | CXTPChartSeriesPoint |
CXTPChartSeriesPoint(double dArgument, double dValue1, double dValue2) | CXTPChartSeriesPoint |
CXTPChartSeriesPoint(const CXTPChartString &strArgument, double dValue1, double dValue2) | CXTPChartSeriesPoint |
CXTPChartSeriesPoint(const CXTPChartString &strArgument, double dValue1, double dValue2, double dValue3, double dValue4) | CXTPChartSeriesPoint |
CXTPChartSeriesPoint(double dArgument, double dValue1, double dValue2, double dValue3, double dValue4) | CXTPChartSeriesPoint |
DoPropExchange(CXTPPropExchange *pPX) | CXTPChartSeriesPoint | virtual
GetAppearance() const | CXTPChartElement |
GetArgument() const | CXTPChartSeriesPoint |
GetArgumentValue() const | CXTPChartSeriesPoint |
GetContent() const | CXTPChartElement |
GetInternalArgumentValue() const | CXTPChartSeriesPoint |
GetLabelText() const | CXTPChartSeriesPoint |
GetLegendText() const | CXTPChartSeriesPoint |
GetNextPoint() const | CXTPChartSeriesPoint |
GetOwner() const | CXTPChartElement |
GetPaletteIndex() const | CXTPChartSeriesPoint |
GetPreviousPoint() const | CXTPChartSeriesPoint |
GetTooltipText() const | CXTPChartSeriesPoint |
GetValue(int nIndex) const | CXTPChartSeriesPoint |
GetValueLength() const | CXTPChartSeriesPoint |
Is3D() const | CXTPChartObject |
m_dArgument | CXTPChartSeriesPoint | protected
m_dInternalArgument | CXTPChartSeriesPoint | protected
m_dValues | CXTPChartSeriesPoint | protected
m_nIndex | CXTPChartSeriesPoint | protected
m_nLength | CXTPChartSeriesPoint | protected
m_nPaletteIndex | CXTPChartSeriesPoint | protected
m_strArgument | CXTPChartSeriesPoint | protected
m_strLegentText | CXTPChartSeriesPoint | protected
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartElement | virtual
Release() | CXTPChartElement | virtual
SetArgumentValue(double dArgument) | CXTPChartSeriesPoint |
SetInternalArgumentValue(double dInternalArgument) | CXTPChartSeriesPoint |
SetLabelText(LPCTSTR lpszLabelText) | CXTPChartSeriesPoint |
SetLegendText(LPCTSTR lpszLegendText) | CXTPChartSeriesPoint |
SetTooltipText(LPCTSTR lpszTooltip) | CXTPChartSeriesPoint |
SetValue(int nIndex, double dValue) | CXTPChartSeriesPoint |
SetValueLength(int nLength) | CXTPChartSeriesPoint |
~CXTPChartElement() | CXTPChartElement | virtual
~CXTPChartSeriesPoint() | CXTPChartSeriesPoint | virtual


Toolkit Pro: Member List

IXTPSkinManagerWindowFilter Member List

This is the complete list of members for IXTPSkinManagerWindowFilter, including all inherited members.

FilterWindow(HWND hWnd, LPCTSTR lpszClassName, LPCREATESTRUCT lpcs)=0 | IXTPSkinManagerWindowFilter | pure virtual
FilterWindowClass(LPCSTR lpszClassName)=0 | IXTPSkinManagerWindowFilter | pure virtual
FilterWindowClass(LPCWSTR lpszClassName)=0 | IXTPSkinManagerWindowFilter | pure virtual
~IXTPSkinManagerWindowFilter() | IXTPSkinManagerWindowFilter | inlinevirtual


Toolkit Pro: XTPChartSplineAreaSeriesStyle.h Source File

  • Source
  • Chart
  • Styles
  • Area
XTPChartSplineAreaSeriesStyle.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTSPLINEAREASERIESSTYLE_H__)
24# define __XTPCHARTSPLINEAREASERIESSTYLE_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartSeriesView;
34class CXTPChartBorder;
35class CXTPChartFillStyle;
36
47class _XTP_EXT_CLASS CXTPChartSplineAreaSeriesStyle : public CXTPChartAreaSeriesStyle
48{
50 DECLARE_SERIAL(CXTPChartSplineAreaSeriesStyle)
52public:
57 CXTPChartSplineAreaSeriesStyle();
58
63 virtual ~CXTPChartSplineAreaSeriesStyle();
64
65protected:
80 virtual CXTPChartSeriesView* CreateView(CXTPChartSeries* pSeries,
81 CXTPChartDiagramView* pDiagramView);
82
83# ifdef _XTP_ACTIVEX
84public:
86 DECLARE_DISPATCH_MAP()
87 DECLARE_INTERFACE_MAP()
88 DECLARE_OLETYPELIB_EX(CXTPChartSplineAreaSeriesStyle);
89 DECLARE_OLECREATE_EX(CXTPChartSplineAreaSeriesStyle)
91# endif
92
93protected:
94};
95
106class _XTP_EXT_CLASS CXTPChartSplineAreaSeriesView : public CXTPChartAreaSeriesView
107{
108public:
116 CXTPChartSplineAreaSeriesView(CXTPChartSeries* pSeries, CXTPChartDiagramView* pDiagramView);
117
118protected:
133 CXTPChartSeriesPointView* CreateSeriesPointView(CXTPChartDeviceContext* pDC,
134 CXTPChartSeriesPoint* pPoint,
135 CXTPChartElementView* pParentView);
136
148 virtual CXTPChartDeviceCommand* CreateDeviceCommand(CXTPChartDeviceContext* pDC);
149};
151# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
152#endif //#if !defined(__XTPCHARTSPLINEAREASERIESSTYLE_H__)
pPoint
const CPoint * pPoint
return 0 or xtpCalendarHitTestDayExpandButton
Definition XTPCalendarThemeOffice2007.h:150
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartAreaSeriesStyle
CXTPChartAreaSeriesStyle is a CXTPChartPointSeriesStyle derived class which represents the area serie...
Definition XTPChartAreaSeriesStyle.h:48
CXTPChartAreaSeriesView
CXTPChartAreaSeriesView is a kind of CXTPChartSeriesView.
Definition XTPChartAreaSeriesView.h:48
CXTPChartBorder
This class abstracts the border of a chart, it is a kind of chart element.
Definition XTPChartBorder.h:42
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartDiagramView
This class represents the view of a chart diagram, which is a kind of CXTPChartElementView.
Definition XTPChartDiagramView.h:49
CXTPChartElementView
This class represents the view of a chart element.
Definition XTPChartElementView.h:47
CXTPChartFillStyle
This class abstracts a fill style used to fill the background of various chart elements.
Definition XTPChartFillStyle.h:43
CXTPChartSeries
This class represents a series in the chart, which is a kind of CXTPChartElement.
Definition XTPChartSeries.h:50
CXTPChartSeriesPoint
CXTPChartSeriesPoint is a kind of CXTPChartElement.
Definition XTPChartSeriesPoint.h:43
CXTPChartSeriesPointView
Represents chart series point view.
Definition XTPChartSeriesPointView.h:48
CXTPChartSplineAreaSeriesStyle
This class represents a spline area series style, which is a kind of CXTPChartAreaSeriesStyle.
Definition XTPChartSplineAreaSeriesStyle.h:48
CXTPChartSplineAreaSeriesStyle::~CXTPChartSplineAreaSeriesStyle
virtual ~CXTPChartSplineAreaSeriesStyle()
Destroys a CXTPChartSplineAreaSeriesStyle object, handles cleanup.
CXTPChartSplineAreaSeriesStyle::CreateView
virtual CXTPChartSeriesView * CreateView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Use this function to create a spline area series view object.
CXTPChartSplineAreaSeriesStyle::CXTPChartSplineAreaSeriesStyle
CXTPChartSplineAreaSeriesStyle()
Constructs a CXTPChartSplineAreaSeriesStyle object.
CXTPChartSplineAreaSeriesView
CXTPChartSplineAreaSeriesView is a kind of CXTPChartSeriesView.
Definition XTPChartSplineAreaSeriesStyle.h:107
CXTPChartSplineAreaSeriesView::CreateDeviceCommand
virtual CXTPChartDeviceCommand * CreateDeviceCommand(CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
CXTPChartSplineAreaSeriesView::CreateSeriesPointView
CXTPChartSeriesPointView * CreateSeriesPointView(CXTPChartDeviceContext *pDC, CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Call this function to create a spline area series point view object.
CXTPChartSplineAreaSeriesView::CXTPChartSplineAreaSeriesView
CXTPChartSplineAreaSeriesView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Constructs a CXTPChartSplineAreaSeriesView object.


Toolkit Pro: XTPCalendarCaptionBarTheme.h Source File

  • Source
  • Calendar
  • CaptionBar
XTPCalendarCaptionBarTheme.h
Go to the documentation of this file.
1
22#if !defined(__XTPCALENDARCAPTIONBARTHEME_H__)
23# define __XTPCALENDARCAPTIONBARTHEME_H__
24
25# if _MSC_VER >= 1000
26# pragma once
27# endif // _MSC_VER >= 1000
28
29# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
30
31class CXTPCalendarCaptionBarPaintManager;
32class CXTPSwitchViewButtonPart;
33class CXTPExpandButtonPart;
34class CXTPDateLabelPart;
35class CXTPScrollDateButtonPart;
36class CXTPRadioButtonPart;
37class CXTPCheckboxButtonPart;
38
47class _XTP_EXT_CLASS CXTPCalendarCaptionBarTheme : public CXTPCalendarWMHandler
48{
49 DECLARE_DYNCREATE(CXTPCalendarCaptionBarTheme)
50
51 friend class CXTPCalendarCaptionBarControl;
52 friend class CXTPCalendarCaptionBarThemePart;
53
54public:
61 CXTPCalendarCaptionBarTheme();
62
69 virtual ~CXTPCalendarCaptionBarTheme();
70
71 double m_dScale;
73public:
87 virtual CRect CalcMinRect(CDC* pDC = NULL, BOOL bExactSize = FALSE);
88
98 virtual void AdjustLayout(CDC* pDC, const CRect& rcRect);
99
105 virtual void RefreshMetrics();
106
118 virtual void Redraw(BOOL bUpdateNow = FALSE);
119
130 BOOL IsSwitchViewButtons() const;
131
138 BOOL IsScrollDateButtons() const;
139
146 BOOL IsDateLabel() const;
147
154 BOOL IsExpandButton() const;
155
164 void SetSwitchViewButtons(BOOL bVisible);
165
172 void SetScrollDateButtons(BOOL bVisible);
173
180 void SetDateLabel(BOOL bVisible);
181
188 void SetExpandButton(BOOL bVisible);
189
196 void SetExpandButtonCheck(BOOL bCheck);
197
204 BOOL GetExpandButtonCheck();
205
212 virtual XTPCalendarTheme GetPaintTheme() const;
213
220 virtual void SetPaintTheme(XTPCalendarTheme nTheme);
221
228 virtual void SetPaintTheme(CXTPCalendarCaptionBarPaintManager* pPaintManager);
229
236 CXTPNotifyConnection* GetConnection();
237
238public:
246 virtual void Draw(CDC* pDC);
247
256 virtual void DrawBorders(CDC* pDC, const CRect& rcRect, const CRect& rcBorders);
257
264 virtual const CRect& GetRect();
265
272 CWnd* GetOwnerWnd() const;
273
282 virtual void SetOwner(CXTPCalendarCaptionBarControl* pCaptionBar);
283
294 virtual void AttachCalendar(CXTPCalendarControl* pCalendar);
295
302 virtual CXTPCalendarControl* GetCalendarCtrl() const;
303
309 virtual void UpdateControlsState();
310
318 virtual void OnPartClick(int nPartID);
319
326 CXTPCalendarCaptionBarPaintManager* GetPaintManager() const;
327
328 BOOL m_bTimelineEnable;
329 BOOL m_bMulticolumnsEnable;
331 CXTPCalendarCaptionBarControl* m_pCaptionBar;
333protected:
334 virtual int GetChildHandlersCount() const;
335 virtual CXTPCalendarWMHandler* GetChildHandlerAt(int nIndex) const;
336
337 virtual void OnBeforeDestroy();
338 virtual void OnMouseMove(UINT nFlags, CPoint point);
339 virtual BOOL OnTimer(UINT_PTR uTimerID);
340
341 virtual void OnKillFocus(CWnd* pNewWnd);
342 virtual BOOL _UpdateControlsHotState(BOOL* pbMouseLeave = NULL);
343
344protected:
345 CXTPCalendarCaptionBarPaintManager* m_pPaintManager;
346 CXTPCalendarControl* m_pCalendar;
348 CRect m_rcRect;
349 UINT_PTR m_nCheckHotStateTimerID;
351protected:
352 CXTPSwitchViewButtonPart* m_pButtonViewDay;
353 CXTPSwitchViewButtonPart* m_pButtonViewWeek;
354 CXTPSwitchViewButtonPart* m_pButtonViewMonth;
357 CXTPRadioButtonPart* m_pShowWorkWeek;
358 CXTPRadioButtonPart* m_pShowFullWeek;
359 CXTPCheckboxButtonPart* m_pShowMcWeek;
361 CXTPCheckboxButtonPart* m_pShowTimeline;
362 //---------------------------------
363 CXTPScrollDateButtonPart* m_pScrollPrevDate;
364 CXTPScrollDateButtonPart* m_pScrollNextDate;
365 CXTPDateLabelPart* m_pDateLabel;
367 CXTPExpandButtonPart* m_pExpandButton;
369 //---------------------------------
370 BOOL m_bIsSwitchViewButtons;
371 BOOL m_bIsScrollDateButtons;
372 BOOL m_bIsDateLabel;
373 BOOL m_bIsExpandButton;
375 BOOL m_bIsOneLine;
377public:
378 int m_nScrollDateButtonsMargin;
379
386 BOOL IsOneLine()
387 {
388 return m_bIsOneLine;
389 }
390
397 void SetOneLine(BOOL bSet)
398 {
399 m_bIsOneLine = bSet;
400 }
401
402public:
403 typedef CXTPCalendarPtrCollectionT<CXTPCalendarCaptionBarThemePart> CThemePartsArray;
404 CThemePartsArray m_arMembers;
405
406protected:
407 CXTPNotifyConnection* m_pConnection;
408
409 CXTPNotifySink* m_pSink;
410
411 virtual void OnEvent_Calendar(XTP_NOTIFY_CODE Event, WPARAM wParam, LPARAM lParam);
412 virtual void OnEvent_ResourceImagesChanged(XTP_NOTIFY_CODE Event, WPARAM wParam, LPARAM lParam);
413
414 friend class CCalendarCaptionBarCtrl;
415 friend class CXTPCalendarCaptionBarPaintManager;
416};
417
419
420AFX_INLINE CXTPCalendarControl* CXTPCalendarCaptionBarTheme::GetCalendarCtrl() const
421{
422 return m_pCalendar;
423}
424AFX_INLINE const CRect& CXTPCalendarCaptionBarTheme::GetRect()
425{
426 return m_rcRect;
427}
428AFX_INLINE BOOL CXTPCalendarCaptionBarTheme::IsSwitchViewButtons() const
429{
430 return m_bIsSwitchViewButtons;
431}
432AFX_INLINE BOOL CXTPCalendarCaptionBarTheme::IsScrollDateButtons() const
433{
434 return m_bIsScrollDateButtons;
435}
436AFX_INLINE BOOL CXTPCalendarCaptionBarTheme::IsDateLabel() const
437{
438 return m_bIsDateLabel;
439}
440AFX_INLINE BOOL CXTPCalendarCaptionBarTheme::IsExpandButton() const
441{
442 return m_bIsExpandButton;
443}
444AFX_INLINE void CXTPCalendarCaptionBarTheme::SetSwitchViewButtons(BOOL bVisible)
445{
446 m_bIsSwitchViewButtons = bVisible;
447 AdjustLayout(NULL, GetRect());
448 Redraw();
449}
450AFX_INLINE void CXTPCalendarCaptionBarTheme::SetScrollDateButtons(BOOL bVisible)
451{
452 m_bIsScrollDateButtons = bVisible;
453 AdjustLayout(NULL, GetRect());
454 Redraw();
455}
456AFX_INLINE void CXTPCalendarCaptionBarTheme::SetExpandButton(BOOL bVisible)
457{
458 m_bIsExpandButton = bVisible;
459 AdjustLayout(NULL, GetRect());
460 Redraw();
461}
462AFX_INLINE void CXTPCalendarCaptionBarTheme::SetDateLabel(BOOL bVisible)
463{
464 m_bIsDateLabel = bVisible;
465 AdjustLayout(NULL, GetRect());
466 Redraw();
467}
468AFX_INLINE CXTPCalendarCaptionBarPaintManager* CXTPCalendarCaptionBarTheme::GetPaintManager() const
469{
470 return m_pPaintManager;
471}
472
473# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
474#endif // !defined(__XTPCALENDARCAPTIONBARTHEME_H__)
XTPCalendarTheme
XTPCalendarTheme
Paint themes used by calendar.
Definition XTPCalendarDefines.h:62
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCalendarCaptionBarControl
CXTPCalendarCaptionBarControl represents CalendarCaptionBar control and used as a part of CXTPCalenda...
Definition XTPCalendarCaptionBarControl.h:106
CXTPCalendarCaptionBarPaintManager
Utility class, handles most of the drawing activities.
Definition XTPCalendarCaptionBarPaintManager.h:49
CXTPCalendarCaptionBarTheme
This class CalendarCaptionBar control drawing, user interaction logic and interaction logic with atta...
Definition XTPCalendarCaptionBarTheme.h:48
CXTPCalendarCaptionBarTheme::SetPaintTheme
virtual void SetPaintTheme(CXTPCalendarCaptionBarPaintManager *pPaintManager)
This member function is used to set current paint theme.
CXTPCalendarCaptionBarTheme::IsOneLine
BOOL IsOneLine()
This member functions is used to get is CaptionBar layout use 1-line shape.
Definition XTPCalendarCaptionBarTheme.h:386
CXTPCalendarCaptionBarTheme::m_bIsDateLabel
BOOL m_bIsDateLabel
Store option is date Label visible.
Definition XTPCalendarCaptionBarTheme.h:372
CXTPCalendarCaptionBarTheme::CXTPCalendarCaptionBarTheme
CXTPCalendarCaptionBarTheme()
Default object constructor.
CXTPCalendarCaptionBarTheme::m_pShowFullWeek
CXTPRadioButtonPart * m_pShowFullWeek
Store Show Full Week radio button part object.
Definition XTPCalendarCaptionBarTheme.h:358
CXTPCalendarCaptionBarTheme::SetExpandButton
void SetExpandButton(BOOL bVisible)
This member functions is used to set Expand Button object visible or not.
Definition XTPCalendarCaptionBarTheme.h:456
CXTPCalendarCaptionBarTheme::m_pCaptionBar
CXTPCalendarCaptionBarControl * m_pCaptionBar
Store pointer owner CaptionBar control.
Definition XTPCalendarCaptionBarTheme.h:331
CXTPCalendarCaptionBarTheme::m_pDateLabel
CXTPDateLabelPart * m_pDateLabel
Store Date Label part object.
Definition XTPCalendarCaptionBarTheme.h:365
CXTPCalendarCaptionBarTheme::m_pButtonViewWeek
CXTPSwitchViewButtonPart * m_pButtonViewWeek
Store Switch to WeekView button part object.
Definition XTPCalendarCaptionBarTheme.h:353
CXTPCalendarCaptionBarTheme::SetScrollDateButtons
void SetScrollDateButtons(BOOL bVisible)
This member functions is used to set Scroll Date Buttons object visible or not.
Definition XTPCalendarCaptionBarTheme.h:450
CXTPCalendarCaptionBarTheme::m_rcRect
CRect m_rcRect
Store object rect.
Definition XTPCalendarCaptionBarTheme.h:348
CXTPCalendarCaptionBarTheme::SetSwitchViewButtons
void SetSwitchViewButtons(BOOL bVisible)
This member function is used to set visible Switch View Buttons object's state.
Definition XTPCalendarCaptionBarTheme.h:444
CXTPCalendarCaptionBarTheme::OnPartClick
virtual void OnPartClick(int nPartID)
This member function is called when user click on the caption bar element (part).
CXTPCalendarCaptionBarTheme::IsExpandButton
BOOL IsExpandButton() const
This member functions is used to get is Expand Button object visible.
Definition XTPCalendarCaptionBarTheme.h:440
CXTPCalendarCaptionBarTheme::m_nCheckHotStateTimerID
UINT_PTR m_nCheckHotStateTimerID
Store timer ID to refresh controls hot state.
Definition XTPCalendarCaptionBarTheme.h:349
CXTPCalendarCaptionBarTheme::GetOwnerWnd
CWnd * GetOwnerWnd() const
This member function is used to obtain an owner (parent, host) window.
CXTPCalendarCaptionBarTheme::m_pShowWorkWeek
CXTPRadioButtonPart * m_pShowWorkWeek
Store Show Work Week radio button part object.
Definition XTPCalendarCaptionBarTheme.h:357
CXTPCalendarCaptionBarTheme::m_pShowMcWeek
CXTPCheckboxButtonPart * m_pShowMcWeek
Store Show Multicolumns Week check box part object.
Definition XTPCalendarCaptionBarTheme.h:359
CXTPCalendarCaptionBarTheme::IsSwitchViewButtons
BOOL IsSwitchViewButtons() const
This member functions is used to get is CaptionBar object visible.
Definition XTPCalendarCaptionBarTheme.h:428
CXTPCalendarCaptionBarTheme::m_pScrollNextDate
CXTPScrollDateButtonPart * m_pScrollNextDate
Store Scroll Date Next button part object.
Definition XTPCalendarCaptionBarTheme.h:364
CXTPCalendarCaptionBarTheme::SetOneLine
void SetOneLine(BOOL bSet)
This member functions is used to set CaptionBar layout to use 1-line shape.
Definition XTPCalendarCaptionBarTheme.h:397
CXTPCalendarCaptionBarTheme::m_bIsScrollDateButtons
BOOL m_bIsScrollDateButtons
Store option is ScrollDate buttons visible.
Definition XTPCalendarCaptionBarTheme.h:371
CXTPCalendarCaptionBarTheme::CalcMinRect
virtual CRect CalcMinRect(CDC *pDC=NULL, BOOL bExactSize=FALSE)
This member function retrieves the minimum size required to show a CaptionBar control.
CXTPCalendarCaptionBarTheme::Draw
virtual void Draw(CDC *pDC)
This member function is used to draw the object content utilizing the specified device context.
CXTPCalendarCaptionBarTheme::GetChildHandlersCount
virtual int GetChildHandlersCount() const
This member function is used to obtain the number of CXTPCalendarWMHandler elements in the descendant...
CXTPCalendarCaptionBarTheme::m_bIsOneLine
BOOL m_bIsOneLine
flag to present 1-line (if TRUE) or 2-lines object layout
Definition XTPCalendarCaptionBarTheme.h:375
CXTPCalendarCaptionBarTheme::m_bIsExpandButton
BOOL m_bIsExpandButton
Store option is Expand button visible.
Definition XTPCalendarCaptionBarTheme.h:373
CXTPCalendarCaptionBarTheme::GetPaintManager
CXTPCalendarCaptionBarPaintManager * GetPaintManager() const
Gives access to theme paint manager.
Definition XTPCalendarCaptionBarTheme.h:468
CXTPCalendarCaptionBarTheme::AttachCalendar
virtual void AttachCalendar(CXTPCalendarControl *pCalendar)
This member function is used to attach to CalendarControl to interact as a single control.
CXTPCalendarCaptionBarTheme::UpdateControlsState
virtual void UpdateControlsState()
This member function is called to update CaptionBar controls states correspondingly to attached calen...
CXTPCalendarCaptionBarTheme::m_pButtonViewMonth
CXTPSwitchViewButtonPart * m_pButtonViewMonth
Store Switch to MonthView button part object.
Definition XTPCalendarCaptionBarTheme.h:354
CXTPCalendarCaptionBarTheme::m_pCalendar
CXTPCalendarControl * m_pCalendar
Store pointer attached calendar control.
Definition XTPCalendarCaptionBarTheme.h:346
CXTPCalendarCaptionBarTheme::IsDateLabel
BOOL IsDateLabel() const
This member functions is used to get is Date Label object visible.
Definition XTPCalendarCaptionBarTheme.h:436
CXTPCalendarCaptionBarTheme::m_pButtonViewDay
CXTPSwitchViewButtonPart * m_pButtonViewDay
Store Switch to DayView button part object.
Definition XTPCalendarCaptionBarTheme.h:352
CXTPCalendarCaptionBarTheme::SetPaintTheme
virtual void SetPaintTheme(XTPCalendarTheme nTheme)
This member function is used to set current paint theme.
CXTPCalendarCaptionBarTheme::SetOwner
virtual void SetOwner(CXTPCalendarCaptionBarControl *pCaptionBar)
This member function is used to set owner (parent, host) window.
CXTPCalendarCaptionBarTheme::Redraw
virtual void Redraw(BOOL bUpdateNow=FALSE)
This member function initiates the CalendarCaptionBar control's redrawing.
CXTPCalendarCaptionBarTheme::~CXTPCalendarCaptionBarTheme
virtual ~CXTPCalendarCaptionBarTheme()
Default object destructor.
CXTPCalendarCaptionBarTheme::GetRect
virtual const CRect & GetRect()
This member function is used to obtain an object rectangle.
Definition XTPCalendarCaptionBarTheme.h:424
CXTPCalendarCaptionBarTheme::m_bTimelineEnable
BOOL m_bTimelineEnable
Flag to show (and able to use) button to toggle TimeLine mode.
Definition XTPCalendarCaptionBarTheme.h:328
CXTPCalendarCaptionBarTheme::m_bMulticolumnsEnable
BOOL m_bMulticolumnsEnable
Flag to show (and able to use) button to toggle Multi-Column / 2-Column Week modes.
Definition XTPCalendarCaptionBarTheme.h:329
CXTPCalendarCaptionBarTheme::GetChildHandlerAt
virtual CXTPCalendarWMHandler * GetChildHandlerAt(int nIndex) const
Call this method to get a handler object at the specified numeric index.
CXTPCalendarCaptionBarTheme::IsScrollDateButtons
BOOL IsScrollDateButtons() const
This member functions is used to get is Scroll Date Buttons object visible.
Definition XTPCalendarCaptionBarTheme.h:432
CXTPCalendarCaptionBarTheme::AdjustLayout
virtual void AdjustLayout(CDC *pDC, const CRect &rcRect)
This member function is used to adjust the object's layout depending on the provided bounding rectang...
CXTPCalendarCaptionBarTheme::m_dScale
double m_dScale
The scale.
Definition XTPCalendarCaptionBarTheme.h:71
CXTPCalendarCaptionBarTheme::OnMouseMove
virtual void OnMouseMove(UINT nFlags, CPoint point)
This member function is used to process mouse movement events.
CXTPCalendarCaptionBarTheme::GetCalendarCtrl
virtual CXTPCalendarControl * GetCalendarCtrl() const
This member function is used to obtain attached calendar control.
Definition XTPCalendarCaptionBarTheme.h:420
CXTPCalendarCaptionBarTheme::GetPaintTheme
virtual XTPCalendarTheme GetPaintTheme() const
This member function is used to obtain current paint theme.
CXTPCalendarCaptionBarTheme::OnBeforeDestroy
virtual void OnBeforeDestroy()
This member function is called by the framework before destroying the view.
CXTPCalendarCaptionBarTheme::m_pExpandButton
CXTPExpandButtonPart * m_pExpandButton
Store Expand button part object.
Definition XTPCalendarCaptionBarTheme.h:367
CXTPCalendarCaptionBarTheme::m_pShowTimeline
CXTPCheckboxButtonPart * m_pShowTimeline
Store Show Timeline check box part object.
Definition XTPCalendarCaptionBarTheme.h:361
CXTPCalendarCaptionBarTheme::DrawBorders
virtual void DrawBorders(CDC *pDC, const CRect &rcRect, const CRect &rcBorders)
This member function is used to draw the object borders.
CXTPCalendarCaptionBarTheme::OnTimer
virtual BOOL OnTimer(UINT_PTR uTimerID)
The framework calls this member function after each interval specified in the SetTimer member functio...
CXTPCalendarCaptionBarTheme::RefreshMetrics
virtual void RefreshMetrics()
Performs refreshing of graphical related parameters from system settings.
CXTPCalendarCaptionBarTheme::m_pScrollPrevDate
CXTPScrollDateButtonPart * m_pScrollPrevDate
Store Scroll Date Prev button part object.
Definition XTPCalendarCaptionBarTheme.h:363
CXTPCalendarCaptionBarTheme::GetExpandButtonCheck
BOOL GetExpandButtonCheck()
This member functions is used to get is Expand Button object checked.
CXTPCalendarCaptionBarTheme::SetDateLabel
void SetDateLabel(BOOL bVisible)
This member functions is used to set Date Label object visible or not.
Definition XTPCalendarCaptionBarTheme.h:462
CXTPCalendarCaptionBarTheme::SetExpandButtonCheck
void SetExpandButtonCheck(BOOL bCheck)
This member functions is used to set Expand Button Checked state.
CXTPCalendarCaptionBarTheme::GetConnection
CXTPNotifyConnection * GetConnection()
This member function is used to get Notify Connection object.
CXTPCalendarCaptionBarTheme::m_bIsSwitchViewButtons
BOOL m_bIsSwitchViewButtons
Store option is SwitchViewBar visible.
Definition XTPCalendarCaptionBarTheme.h:370
CXTPCalendarCaptionBarThemePart
This class used as a base class for graphical Parts of CalendarCaptionBar paint theme.
Definition XTPCalendarCaptionBarThemePart.h:54
CXTPCalendarControl
Class CXTPCalendarControl implements the calendar's view interface.
Definition XTPCalendarControl.h:126
CXTPCalendarPtrCollectionT
This class represents a simple array collection of objects.
Definition XTPCalendarPtrCollectionT.h:48
CXTPCalendarWMHandler
This class helps to handle Windows messages (WM_*) processing portion of the Calendar control views.
Definition XTPCalendarView.h:100
CXTPCheckboxButtonPart
This class implements Checkbox button part of the SwitchViewBar.
Definition XTPCalendarCaptionBarThemePart.h:367
CXTPDateLabelPart
This class implements Date Label part of the ScrollDateBar.
Definition XTPCalendarCaptionBarThemePart.h:407
CXTPExpandButtonPart
This class implements Expand button part of the ScrollDateBar.
Definition XTPCalendarCaptionBarThemePart.h:429
CXTPNotifyConnection
This class is used as implementation of Connection interface in a XTPNotification mechanism.
Definition XTPNotifyConnection.h:88
CXTPRadioButtonPart
This class implements Radio button part of the SwitchViewBar.
Definition XTPCalendarCaptionBarThemePart.h:350
CXTPScrollDateButtonPart
This class implements Scroll Date button part of the ScrollDateBar.
Definition XTPCalendarCaptionBarThemePart.h:383
CXTPSwitchViewButtonPart
This class implements SwitchView button part of the SwitchViewBar.
Definition XTPCalendarCaptionBarThemePart.h:333


Toolkit Pro: Member List

CXTPShortcutBarOfficeXPTheme Member List

This is the complete list of members for CXTPShortcutBarOfficeXPTheme, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPShortcutBarPaintManager() | CXTPShortcutBarPaintManager |
DrawExpandButton(CDC *pDC, CRect rc) | CXTPShortcutBarPaintManager | virtual
DrawGripper(CDC *pDC, CXTPShortcutBar *pShortcutBar, BOOL bDraw) | CXTPShortcutBarOfficeXPTheme | virtual
DrawImage(CDC *pDC, CPoint pt, CSize sz, CXTPImageManagerIcon *pImage, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled) | CXTPShortcutBarOfficeXPTheme | virtual
DrawNavigationItem(CDC *pDC, CXTPShortcutBarItem *pItem) | CXTPShortcutBarPaintManager | virtual
DrawPaneCaption(CDC *pDC, CXTPShortcutBarPane *pPane, BOOL bDraw) | CXTPShortcutBarPaintManager | virtual
DrawPaneItemCaption(CDC *pDC, CXTPShortcutBarPaneItem *pItem, BOOL bDraw) | CXTPShortcutBarPaintManager | virtual
DrawShortcutBarFrame(CDC *pDC, CXTPShortcutBar *pShortcutBar) | CXTPShortcutBarOfficeXPTheme | virtual
DrawShortcutItem(CDC *pDC, CXTPShortcutBarItem *pItem) | CXTPShortcutBarPaintManager | virtual
FillNavigationItemEntry(CDC *pDC, CXTPShortcutBarItem *pItem) | CXTPShortcutBarPaintManager | virtual
FillShortcutBar(CDC *pDC, CXTPShortcutBar *pShortcutBar) | CXTPShortcutBarOfficeXPTheme | virtual
FillShortcutItemEntry(CDC *pDC, CXTPShortcutBarItem *pItem) | CXTPShortcutBarOfficeXPTheme | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
IsShortcutItemTruncated(CDC *pDC, CXTPShortcutBarItem *pItem) | CXTPShortcutBarPaintManager |
Line(CDC *pDC, int x0, int y0, int x1, int y1, int nPen) | CXTPShortcutBarPaintManager |
m_bBoldItemCaptionFont | CXTPShortcutBarPaintManager |
m_bClearTypeTextQuality | CXTPShortcutBarPaintManager |
m_bNavigationButton | CXTPShortcutBarPaintManager |
m_bUseStandardFont | CXTPShortcutBarPaintManager |
m_clrDisabledText | CXTPShortcutBarPaintManager |
m_clrHotText | CXTPShortcutBarPaintManager |
m_clrNormalText | CXTPShortcutBarPaintManager |
m_clrPushedText | CXTPShortcutBarPaintManager |
m_clrSelectedText | CXTPShortcutBarPaintManager |
m_clrShortcutItemShadow | CXTPShortcutBarPaintManager |
m_grcHot | CXTPShortcutBarPaintManager |
m_grcPushed | CXTPShortcutBarPaintManager |
m_grcSelected | CXTPShortcutBarPaintManager |
m_grcShortcutBarGripper | CXTPShortcutBarPaintManager |
m_grcShortcutItem | CXTPShortcutBarPaintManager |
m_nExpandedIconWidth | CXTPShortcutBarPaintManager |
m_nNormalIconWidth | CXTPShortcutBarPaintManager |
m_nPaneItemHeight | CXTPShortcutBarPaintManager |
m_pExpandIcon | CXTPShortcutBarPaintManager |
m_rcCaptionPadding | CXTPShortcutBarPaintManager |
m_rcItemCaptionPadding | CXTPShortcutBarPaintManager |
m_strOfficeFont | CXTPShortcutBarPaintManager |
m_xtpFontPaneCaption | CXTPShortcutBarPaintManager |
m_xtpFontPaneItemCaption | CXTPShortcutBarPaintManager |
m_xtpFontText | CXTPShortcutBarPaintManager |
m_xtpFontVerticalText | CXTPShortcutBarPaintManager |
Rectangle(CDC *pDC, CRect rc, int nPen, int nBrush) | CXTPShortcutBarPaintManager |
RefreshMetrics() | CXTPShortcutBarPaintManager | virtual
~CXTPShortcutBarPaintManager() | CXTPShortcutBarPaintManager | virtual


Toolkit Pro: XTPFlowGraphControl.h Source File

  • Source
  • FlowGraph
XTPFlowGraphControl.h
Go to the documentation of this file.
1
23#if !defined(__XTPFLOWGRAPHCONTROL_H__)
24# define __XTPFLOWGRAPHCONTROL_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPFlowGraphPaintManager;
34class CXTPFlowGraphPage;
35class CXTPFlowGraphPages;
36class CXTPFlowGraphDrawContext;
37class CXTPFlowGraphNode;
38class CXTPFlowGraphNodeCustom;
39class CXTPPropExchange;
40class CXTPFlowGraphSelectedElements;
41class CXTPFlowGraphConnection;
42class CXTPFlowGraphElement;
43class CXTPFlowGraphConnectionPoint;
44class CXTPFlowGraphUndoManager;
45class CXTPFlowGraphImages;
46class CXTPToolTipContext;
47class CXTPFlowGraphPageHistory;
48class CXTPMarkupContext;
49
50class CXTPMarkupDependencyProperty;
51
64enum XTPFlowGraphResize
65{
66 xtpFlowGraphResizeNone = 0,
67 xtpFlowGraphResizeHorizontal = 1,
68 xtpFlowGraphResizeVertical = 2,
69 xtpFlowGraphResizeBoth = 3
70};
71
88enum XTPFlowGraphSmoothingMode
89{
90 xtpFlowGraphSmoothingModeHighQuality,
94 xtpFlowGraphSmoothingModeHighSpeed,
96 xtpFlowGraphSmoothingModeGDI,
100 xtpFlowGraphSmoothingModeAuto,
105};
106
111enum XTPFlowGraphCustomProperty
112{
113 xtpFlowGraphPropertyConnectionPoint = 0,
115 xtpFlowGraphPropertyConnectionPointType = 1,
118 xtpFlowGraphPropertyCanSetColor = 2,
120 xtpFlowGraphPropertyConnectionPointIn =
121 3,
124 xtpFlowGraphPropertyResizable = 4
127};
128
133enum XTPFlowGraphDefaultXAMLTemplate
134{
135 xtpFlowGraphTemplateNode = 0,
136 xtpFlowGraphTemplateNodePointNone = 1,
137 xtpFlowGraphTemplateNodePointIn = 2,
138 xtpFlowGraphTemplateNodePointOut = 3,
139 xtpFlowGraphTemplateNodePointInOut = 4
141};
142
172class _XTP_EXT_CLASS CXTPFlowGraphControl : public CWnd
173{
175 DECLARE_DYNAMIC(CXTPFlowGraphControl)
177public:
182 CXTPFlowGraphControl();
188 virtual ~CXTPFlowGraphControl();
189
190public:
200 void SetActivePage(CXTPFlowGraphPage* pPage);
201
214 CXTPFlowGraphPages* GetPages() const;
215
225 virtual void OnGraphChanged();
226
227public:
238 CXTPFlowGraphPaintManager* GetPaintManager() const;
239
250 void SetPaintManager(CXTPFlowGraphPaintManager* pPaintManager);
251
260 CXTPFlowGraphImages* GetImages() const;
261
262public:
274 virtual void DoPropExchange(CXTPPropExchange* pPX);
275
276public:
285 virtual void OnDraw(CXTPFlowGraphDrawContext* pDC);
286
294 virtual void Reposition();
295
303 virtual void RedrawControl();
304
315 CXTPFlowGraphPage* GetActivePage() const;
316
324 CXTPFlowGraphPageHistory* GetHistory() const;
325
347 CXTPFlowGraphUndoManager* GetUndoManager() const;
348
356 BOOL RegisterWindowClass(HINSTANCE hInstance = NULL);
357
367 BOOL Create(DWORD dwStyle, const RECT& rect, CWnd* pParentWnd, UINT nID);
368
369 using CWnd::Create;
370
371public:
380 double GetZoomLevel() const;
381
389 void SetZoomLevel(double dZoomLevel);
390
400 CPoint GetScrollOffset() const;
401
411 void SetZoomRange(double dMinZoom, double dMaxZoom);
412
421 CPoint TransformPoint(CPoint pt) const;
422
429 virtual void ZoomToSelection();
430
438 virtual void ZoomFitToWindow();
439
448 virtual void ZoomToRect(LPCRECT lpRect, BOOL bAnimate = TRUE);
449
459 virtual void AnimateTo(CPoint ptScrollOffset, double dZoomLevel);
460
472 virtual void AnimatePageTransition(CXTPFlowGraphNode* pNodeFrom, CXTPFlowGraphNode* pNodeTo);
473
480 void SetAnimationDelay(int nDelay);
481
489 int GetAnimationDelay() const;
490
491public:
497 void SetAllowMoveNodes(BOOL bAllow);
498
505 BOOL GetAllowMoveNodes() const;
506
516 void SetAllowResizeNodes(XTPFlowGraphResize nResizeMode);
517
528 XTPFlowGraphResize GetAllowResizeNodes() const;
529
537 void SetAllowModifyConnections(BOOL bAllowModifyConnections);
538
546 BOOL GetAllowModifyConnections() const;
547
565 void SetSmoothingMode(XTPFlowGraphSmoothingMode nSmoothingMode);
566
581 XTPFlowGraphSmoothingMode GetSmoothingMode() const;
582
583public:
592 virtual void SelectAll();
593
601 virtual void Arrange();
602
609 virtual void RenameNode(CXTPFlowGraphNode* pNode);
610
618 virtual void RenameConnectionPoint(CXTPFlowGraphConnectionPoint* pConnectionPoint);
619
629 CXTPFlowGraphNodeCustom* AddCustomNodeFromToolkitResource(UINT uResShapeID,
630 CXTPFlowGraphPage* pPage = NULL);
631
632public:
642 virtual CXTPFlowGraphNode* HitTestNode(CPoint point) const;
643
653 virtual CXTPFlowGraphConnection* HitTestConnection(CPoint point) const;
654
664 virtual CXTPFlowGraphConnectionPoint* HitTestConnectionArea(CPoint point) const;
665
666public:
676 virtual void OnEndLabelEdit(CXTPFlowGraphElement* pItem, LPCTSTR str);
677
685 void CancelLabelEdit();
686
687public:
694 CXTPToolTipContext* GetToolTipContext() const;
695
703 BOOL SaveToFile(LPCTSTR szFile);
704
705public:
712 void EnableMarkup(BOOL bEnable = TRUE);
713
725 void EnableScrollBarCtrl(int nBar, BOOL bEnable = TRUE);
726
727 BOOL GetScrollInfo(int nBar, LPSCROLLINFO lpScrollInfo, UINT nMask = SIF_ALL);
728
729 BOOL SetScrollInfo(int nBar, LPSCROLLINFO lpScrollInfo, BOOL bRedraw = TRUE);
730
745 int GetScrollLimit(int nBar);
746
764 virtual CScrollBar* GetScrollBarCtrl(int nBar) const;
765
772 CXTPMarkupContext* GetMarkupContext() const;
773
782 CXTPMarkupDependencyProperty* GetCustomMarkupProperty(XTPFlowGraphCustomProperty property) const;
783
791 CString GetDefaultMarkupTemplate(XTPFlowGraphDefaultXAMLTemplate tmpl) const;
792
797 void RegisterCustomMarkupProperties();
798
804 void SetupDefaultMarkupTemplates();
805
813 static CString AFX_CDECL LoadXamlTemplate(LPCTSTR szTemplate);
814
815public:
824 virtual LRESULT SendNotifyMessage(UINT nMessage, NMHDR* pNMHDR = NULL) const;
825
826protected:
832 virtual void AdjustScrollBars();
833
834protected:
840 virtual void StartDragNodes();
841
849 virtual void StartResizeNode(CXTPFlowGraphNode* pNode, UINT hitTest);
850
856 virtual void StartDragScreen();
857
863 virtual void StartDragSelection();
864
872 virtual void StartDragConnection(CXTPFlowGraphConnection* pConnection);
873
881 virtual void StartDragConnectionPoint(CXTPFlowGraphConnectionPoint* pPoint);
882
888 virtual void OnMoveSelection(CPoint pt);
889
906 virtual void GetZoomParam(LPCRECT lpRect, CPoint& ptScrollOffset, double& dZoomLevel);
907
921 virtual CXTPFlowGraphDrawContext* CreateDrawContext(CDC& dc);
922
923 // returns true when at least node was reset
924
925 bool ResetSelectedNodes(CXTPFlowGraphNode* pNodeToSkip = NULL);
926
927 void UpdateActiveNodeAtPoint(CPoint pt, CXTPFlowGraphNode* pNodeToSkip = NULL);
928
929 CXTPFlowGraphNode* IsPointInSizeRectOfSelectedNode(CPoint point, UINT& uHitTest) const;
930
932protected:
933 DECLARE_MESSAGE_MAP()
934
935 virtual INT_PTR OnToolHitTest(CPoint point, TOOLINFO* pTI) const;
936 virtual BOOL OnWndMsg(UINT message, WPARAM wParam, LPARAM lParam, LRESULT* pResult);
937
940 // custom scrollbars related:
941
942 void RepositionCustomScrollBars();
943
944 void DeleteCustomScrollBars();
945
946public:
947 void GetClientRect(LPRECT lpRect) const;
948 void SetScrollbarTheme(XTPScrollBarTheme theme);
949
952 // end
953
954protected:
955 afx_msg void OnPaint();
956 afx_msg void OnSize(UINT nType, int cx, int cy);
957 afx_msg void OnHScroll(UINT nSBCode, UINT nPos, CScrollBar* pScrollBar);
958 afx_msg void OnVScroll(UINT nSBCode, UINT nPos, CScrollBar* pScrollBar);
959 afx_msg void OnLButtonDown(UINT nFlags, CPoint point);
960 afx_msg void OnMouseMove(UINT nFlags, CPoint point);
961 afx_msg BOOL OnSetCursor(CWnd* pWnd, UINT nHitTest, UINT message);
962 afx_msg void OnMButtonDown(UINT nFlags, CPoint point);
963 afx_msg BOOL OnMouseWheel(UINT nFlags, short zDelta, CPoint pt);
964 afx_msg void OnLButtonDblClk(UINT nFlags, CPoint point);
965 afx_msg void OnRButtonUp(UINT nFlags, CPoint point);
966 afx_msg void OnRButtonDown(UINT nFlags, CPoint point);
967 afx_msg void OnLButtonUp(UINT nFlags, CPoint point);
970protected:
971 CBitmap m_bmpCache;
972 BOOL m_bReposition;
973 CXTPFlowGraphPaintManager* m_pPaintManager;
975 CXTPFlowGraphPage* m_pActivePage;
976 CXTPFlowGraphPages* m_pPages;
977 BOOL m_bAdjustScrollBars;
979 CPoint m_ptStartDrag;
980 CPoint m_ptMouse;
982 CRect m_rcSelectedArea;
984 CXTPFlowGraphUndoManager* m_pUndoManager;
986 CXTPFlowGraphImages* m_pImages;
988 double m_dMinZoom;
989 double m_dMaxZoom;
991 CXTPToolTipContext* m_pToolTipContext;
993 int m_nAnimationDelay;
995 CXTPFlowGraphPageHistory* m_pHistory;
998 BOOL m_bAllowMoveNodes;
1000 XTPFlowGraphResize m_nAllowResizeNodes; // Node resizing options (drag/drop size of Nodes).
1001 BOOL m_bAllowModifyConnections;
1005 BOOL m_bInAction;
1008 XTPFlowGraphSmoothingMode m_nSmoothingMode;
1010 CXTPMarkupContext* m_pMarkupContext;
1012 static CMap<XTPFlowGraphCustomProperty, XTPFlowGraphCustomProperty,
1013 CXTPMarkupDependencyProperty*, CXTPMarkupDependencyProperty*&>
1014 m_mapCustomProperties;
1015
1016 // Map of Nodes and its table rows markup templates (default connection points) that depend on a
1017 // connection point type.
1018
1019 CMap<XTPFlowGraphDefaultXAMLTemplate, XTPFlowGraphDefaultXAMLTemplate, CString, CString&>
1020 m_mapDefaultXamlTemplates;
1021
1022 BOOL m_bCreateScrollbarOnParent;
1025 CScrollBar* m_pCustomScrollBars[2];
1026
1027private:
1029 struct DRAGNODE
1030 {
1031 CPoint ptOrigin;
1032 CXTPFlowGraphElement* pElement;
1033 BOOL bNode;
1034 };
1035 CArray<DRAGNODE, DRAGNODE&> m_arrDragNodes;
1038 friend class CFlowGraphCtrl;
1039};
1040
1041AFX_INLINE CXTPFlowGraphPaintManager* CXTPFlowGraphControl::GetPaintManager() const
1042{
1043 return m_pPaintManager;
1044}
1045AFX_INLINE CXTPFlowGraphPages* CXTPFlowGraphControl::GetPages() const
1046{
1047 return m_pPages;
1048}
1049AFX_INLINE CXTPFlowGraphPage* CXTPFlowGraphControl::GetActivePage() const
1050{
1051 return m_pActivePage;
1052}
1053AFX_INLINE CXTPFlowGraphUndoManager* CXTPFlowGraphControl::GetUndoManager() const
1054{
1055 return m_pUndoManager;
1056}
1057AFX_INLINE void CXTPFlowGraphControl::SetZoomRange(double dMinZoom, double dMaxZoom)
1058{
1059 m_dMinZoom = dMinZoom;
1060 m_dMaxZoom = dMaxZoom;
1061}
1062AFX_INLINE CXTPToolTipContext* CXTPFlowGraphControl::GetToolTipContext() const
1063{
1064 return m_pToolTipContext;
1065}
1066AFX_INLINE void CXTPFlowGraphControl::SetAnimationDelay(int nDelay)
1067{
1068 m_nAnimationDelay = nDelay;
1069}
1070AFX_INLINE int CXTPFlowGraphControl::GetAnimationDelay() const
1071{
1072 return m_nAnimationDelay;
1073}
1074AFX_INLINE CXTPFlowGraphImages* CXTPFlowGraphControl::GetImages() const
1075{
1076 return m_pImages;
1077}
1078AFX_INLINE CXTPFlowGraphPageHistory* CXTPFlowGraphControl::GetHistory() const
1079{
1080 return m_pHistory;
1081}
1082AFX_INLINE void CXTPFlowGraphControl::SetAllowMoveNodes(BOOL bAllow)
1083{
1084 m_bAllowMoveNodes = bAllow;
1085}
1086AFX_INLINE BOOL CXTPFlowGraphControl::GetAllowMoveNodes() const
1087{
1088 return m_bAllowMoveNodes;
1089}
1090AFX_INLINE void CXTPFlowGraphControl::SetAllowResizeNodes(XTPFlowGraphResize nResizeMode)
1091{
1092 m_nAllowResizeNodes = nResizeMode;
1093}
1094AFX_INLINE XTPFlowGraphResize CXTPFlowGraphControl::GetAllowResizeNodes() const
1095{
1096 return m_nAllowResizeNodes;
1097}
1098AFX_INLINE void CXTPFlowGraphControl::SetAllowModifyConnections(BOOL bAllowModifyConnections)
1099{
1100 m_bAllowModifyConnections = bAllowModifyConnections;
1101}
1102AFX_INLINE BOOL CXTPFlowGraphControl::GetAllowModifyConnections() const
1103{
1104 return m_bAllowModifyConnections;
1105}
1106AFX_INLINE XTPFlowGraphSmoothingMode CXTPFlowGraphControl::GetSmoothingMode() const
1107{
1108 return m_nSmoothingMode;
1109}
1110AFX_INLINE CXTPMarkupContext* CXTPFlowGraphControl::GetMarkupContext() const
1111{
1112 return m_pMarkupContext;
1113}
1115# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
1116#endif //#if !defined(__XTPFLOWGRAPHCONTROL_H__)
pPoint
const CPoint * pPoint
return 0 or xtpCalendarHitTestDayExpandButton
Definition XTPCalendarThemeOffice2007.h:150
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPFlowGraphDefaultXAMLTemplate
XTPFlowGraphDefaultXAMLTemplate
Default XAML templates for a default node and its table rows with connection points.
Definition XTPFlowGraphControl.h:134
xtpFlowGraphTemplateNode
@ xtpFlowGraphTemplateNode
A Node.
Definition XTPFlowGraphControl.h:135
xtpFlowGraphTemplateNodePointOut
@ xtpFlowGraphTemplateNodePointOut
Node table row with output connection point.
Definition XTPFlowGraphControl.h:138
xtpFlowGraphTemplateNodePointInOut
@ xtpFlowGraphTemplateNodePointInOut
Node table row with input & output connection points.
Definition XTPFlowGraphControl.h:139
xtpFlowGraphTemplateNodePointNone
@ xtpFlowGraphTemplateNodePointNone
Node table row with no connection points.
Definition XTPFlowGraphControl.h:136
xtpFlowGraphTemplateNodePointIn
@ xtpFlowGraphTemplateNodePointIn
Node table row with input connection point.
Definition XTPFlowGraphControl.h:137
XTPFlowGraphCustomProperty
XTPFlowGraphCustomProperty
Custom XAML properties used in CXTPFlowGraphNode and CXTPFlowGraphNodeCustom.
Definition XTPFlowGraphControl.h:112
xtpFlowGraphPropertyConnectionPoint
@ xtpFlowGraphPropertyConnectionPoint
Applied to default nodes only.
Definition XTPFlowGraphControl.h:113
xtpFlowGraphPropertyConnectionPointIn
@ xtpFlowGraphPropertyConnectionPointIn
Applied to custom nodes only.
Definition XTPFlowGraphControl.h:120
xtpFlowGraphPropertyResizable
@ xtpFlowGraphPropertyResizable
Applied to custom Nodes only.
Definition XTPFlowGraphControl.h:124
xtpFlowGraphPropertyConnectionPointType
@ xtpFlowGraphPropertyConnectionPointType
Applied to default nodes only.
Definition XTPFlowGraphControl.h:115
xtpFlowGraphPropertyCanSetColor
@ xtpFlowGraphPropertyCanSetColor
Applied to default nodes only.
Definition XTPFlowGraphControl.h:118
XTPFlowGraphResize
XTPFlowGraphResize
Node resizing options (drag/drop size of Nodes).
Definition XTPFlowGraphControl.h:65
xtpFlowGraphResizeNone
@ xtpFlowGraphResizeNone
Resizing is disabled.
Definition XTPFlowGraphControl.h:66
xtpFlowGraphResizeVertical
@ xtpFlowGraphResizeVertical
Nodes can be resized vertically only.
Definition XTPFlowGraphControl.h:68
xtpFlowGraphResizeHorizontal
@ xtpFlowGraphResizeHorizontal
Nodes can be resized horizontally only.
Definition XTPFlowGraphControl.h:67
xtpFlowGraphResizeBoth
@ xtpFlowGraphResizeBoth
Nodes can be resized both vertically and horizontally.
Definition XTPFlowGraphControl.h:69
XTPFlowGraphSmoothingMode
XTPFlowGraphSmoothingMode
Draw quality options for the flow graph.
Definition XTPFlowGraphControl.h:89
xtpFlowGraphSmoothingModeAuto
@ xtpFlowGraphSmoothingModeAuto
Will combine the various quality modes to get the best performance and quality.
Definition XTPFlowGraphControl.h:100
xtpFlowGraphSmoothingModeHighQuality
@ xtpFlowGraphSmoothingModeHighQuality
Uses GDI+ to draw the flow graph for the highest quality picture.
Definition XTPFlowGraphControl.h:90
xtpFlowGraphSmoothingModeGDI
@ xtpFlowGraphSmoothingModeGDI
Uses GDI Standard to draw the flow graph.
Definition XTPFlowGraphControl.h:96
xtpFlowGraphSmoothingModeHighSpeed
@ xtpFlowGraphSmoothingModeHighSpeed
Uses GDI+ to draw the flow graph with slightly lower quality to improve speed over the High Quality o...
Definition XTPFlowGraphControl.h:94
XTPScrollBarTheme
XTPScrollBarTheme
Scrollbar theme identifier enum.
Definition XTPScrollBase.h:87
CXTPFlowGraphConnection
Represents a connection.
Definition XTPFlowGraphConnection.h:49
CXTPFlowGraphConnectionPoint
Represents a connection point for a node.
Definition XTPFlowGraphConnectionPoint.h:46
CXTPFlowGraphControl
Flow Graph Control.
Definition XTPFlowGraphControl.h:173
CXTPFlowGraphControl::HitTestNode
virtual CXTPFlowGraphNode * HitTestNode(CPoint point) const
Call this method to determine if there is a CXTPFlowGraphNode at the specified point.
CXTPFlowGraphControl::DoPropExchange
virtual void DoPropExchange(CXTPPropExchange *pPX)
Exchanges layout and state information to/from a PropExchange object.
CXTPFlowGraphControl::StartDragSelection
virtual void StartDragSelection()
Internal method that is called when the selection starts to get dragged.
CXTPFlowGraphControl::SetAllowMoveNodes
void SetAllowMoveNodes(BOOL bAllow)
Specifies whether the user can drag/move Nodes.
Definition XTPFlowGraphControl.h:1082
CXTPFlowGraphControl::StartDragScreen
virtual void StartDragScreen()
Internal method that is called when the screen has begun to get dragged.
CXTPFlowGraphControl::HitTestConnection
virtual CXTPFlowGraphConnection * HitTestConnection(CPoint point) const
Call this method to determine if there is a CXTPFlowGraphConnection at the specified point.
CXTPFlowGraphControl::GetAnimationDelay
int GetAnimationDelay() const
Gets the delay used between animation steps when animation is used (zooming/scrolling).
Definition XTPFlowGraphControl.h:1070
CXTPFlowGraphControl::m_pUndoManager
CXTPFlowGraphUndoManager * m_pUndoManager
The pointer to the undo manager object.
Definition XTPFlowGraphControl.h:984
CXTPFlowGraphControl::RenameConnectionPoint
virtual void RenameConnectionPoint(CXTPFlowGraphConnectionPoint *pConnectionPoint)
Call this method to place a connection point into edit mode so the user can edit the text.
CXTPFlowGraphControl::GetHistory
CXTPFlowGraphPageHistory * GetHistory() const
Gets an object that keeps track of page history and allows for the history to be navigated.
Definition XTPFlowGraphControl.h:1078
CXTPFlowGraphControl::CreateDrawContext
virtual CXTPFlowGraphDrawContext * CreateDrawContext(CDC &dc)
Creates a CXTPFlowGraphDrawContext object that will use the specified dc to draw.
CXTPFlowGraphControl::GetZoomLevel
double GetZoomLevel() const
Gets the current zoom level of the control.
CXTPFlowGraphControl::RegisterWindowClass
BOOL RegisterWindowClass(HINSTANCE hInstance=NULL)
Registers the window class if it has not already been registered.
CXTPFlowGraphControl::GetImages
CXTPFlowGraphImages * GetImages() const
Retrieves a reference to all the images that the flow graph can use.
Definition XTPFlowGraphControl.h:1074
CXTPFlowGraphControl::AddCustomNodeFromToolkitResource
CXTPFlowGraphNodeCustom * AddCustomNodeFromToolkitResource(UINT uResShapeID, CXTPFlowGraphPage *pPage=NULL)
Helper method to load a custom XAML shape from toolkit using its resource ID.
CXTPFlowGraphControl::m_pHistory
CXTPFlowGraphPageHistory * m_pHistory
Object that keeps track of page history and allows the history to be navigated.
Definition XTPFlowGraphControl.h:995
CXTPFlowGraphControl::GetAllowMoveNodes
BOOL GetAllowMoveNodes() const
Gets whether the user can drag/move Nodes.
Definition XTPFlowGraphControl.h:1086
CXTPFlowGraphControl::EnableMarkup
void EnableMarkup(BOOL bEnable=TRUE)
Enables/disables markup for the flow graph.
CXTPFlowGraphControl::GetScrollBarCtrl
virtual CScrollBar * GetScrollBarCtrl(int nBar) const
Call this member function to obtain a pointer to the specified sibling scroll bar.
CXTPFlowGraphControl::m_dMinZoom
double m_dMinZoom
Minimum zoom level allowed for the flow graph control.
Definition XTPFlowGraphControl.h:988
CXTPFlowGraphControl::GetZoomParam
virtual void GetZoomParam(LPCRECT lpRect, CPoint &ptScrollOffset, double &dZoomLevel)
Calculates the correct ScrollOffset and ZoomLevel needed for a given rectangle.
CXTPFlowGraphControl::m_nAnimationDelay
int m_nAnimationDelay
Delay between animation steps used when zooming or scrolling.
Definition XTPFlowGraphControl.h:993
CXTPFlowGraphControl::GetUndoManager
CXTPFlowGraphUndoManager * GetUndoManager() const
Gets the manager used to Undo and Redo edit operations in the flow graph.
Definition XTPFlowGraphControl.h:1053
CXTPFlowGraphControl::OnDraw
virtual void OnDraw(CXTPFlowGraphDrawContext *pDC)
Called by the framework to draw the flow graph control.
CXTPFlowGraphControl::RegisterCustomMarkupProperties
void RegisterCustomMarkupProperties()
Attaches custom properties to a control.
CXTPFlowGraphControl::~CXTPFlowGraphControl
virtual ~CXTPFlowGraphControl()
Destroys a CXTPFlowGraphControl object, handles cleanup and deallocation.
CXTPFlowGraphControl::ZoomToRect
virtual void ZoomToRect(LPCRECT lpRect, BOOL bAnimate=TRUE)
Zooms the view to a specific set of coordinates on the active page.
CXTPFlowGraphControl::GetSmoothingMode
XTPFlowGraphSmoothingMode GetSmoothingMode() const
Gets the draw quality options used for the flow graph.
Definition XTPFlowGraphControl.h:1106
CXTPFlowGraphControl::SetAllowModifyConnections
void SetAllowModifyConnections(BOOL bAllowModifyConnections)
Specifies whether the user is allowed to drag/move/add/delete connections.
Definition XTPFlowGraphControl.h:1098
CXTPFlowGraphControl::m_dMaxZoom
double m_dMaxZoom
Maximum zoom level allowed for the flow graph control.
Definition XTPFlowGraphControl.h:989
CXTPFlowGraphControl::m_bAllowModifyConnections
BOOL m_bAllowModifyConnections
Specifies whether the user can drag/move/add/delete connections.
Definition XTPFlowGraphControl.h:1001
CXTPFlowGraphControl::RedrawControl
virtual void RedrawControl()
Redraws the control.
CXTPFlowGraphControl::GetAllowResizeNodes
XTPFlowGraphResize GetAllowResizeNodes() const
Gets Node resizing options (drag/drop size of nodes).
Definition XTPFlowGraphControl.h:1094
CXTPFlowGraphControl::AdjustScrollBars
virtual void AdjustScrollBars()
Adjusts scrollbars depending on currently visible elements (nodes, connections, etc....
CXTPFlowGraphControl::OnGraphChanged
virtual void OnGraphChanged()
This method is called whenever the flow graph or any of its elements have changed.
CXTPFlowGraphControl::SetupDefaultMarkupTemplates
void SetupDefaultMarkupTemplates()
Sets up default Node's markup templates for a Node and its rows (used to be names connection points).
CXTPFlowGraphControl::HitTestConnectionArea
virtual CXTPFlowGraphConnectionPoint * HitTestConnectionArea(CPoint point) const
Call this method to determine if there is a CXTPFlowGraphConnectionPoint at the specified point.
CXTPFlowGraphControl::GetCustomMarkupProperty
CXTPMarkupDependencyProperty * GetCustomMarkupProperty(XTPFlowGraphCustomProperty property) const
Call this method to retrieve a custom markup property from the custom properties map.
CXTPFlowGraphControl::StartResizeNode
virtual void StartResizeNode(CXTPFlowGraphNode *pNode, UINT hitTest)
Internal method that is called when a Node starts to get resized.
CXTPFlowGraphControl::m_bAllowMoveNodes
BOOL m_bAllowMoveNodes
Specifies whether the user can drag/move Nodes.
Definition XTPFlowGraphControl.h:998
CXTPFlowGraphControl::SetZoomRange
void SetZoomRange(double dMinZoom, double dMaxZoom)
Call this method to set the minimum and maximum zoom percentages that are allowed when using the vari...
Definition XTPFlowGraphControl.h:1057
CXTPFlowGraphControl::m_pPaintManager
CXTPFlowGraphPaintManager * m_pPaintManager
Pointer to the paint manager used to draw the flow graph.
Definition XTPFlowGraphControl.h:973
CXTPFlowGraphControl::GetScrollLimit
int GetScrollLimit(int nBar)
Call this member function to retrieve the maximum scrolling position of the scroll bar.
CXTPFlowGraphControl::m_pActivePage
CXTPFlowGraphPage * m_pActivePage
Pointer to the currently active page.
Definition XTPFlowGraphControl.h:975
CXTPFlowGraphControl::ZoomFitToWindow
virtual void ZoomFitToWindow()
Fits all the Nodes in the active page to the window.
CXTPFlowGraphControl::GetPaintManager
CXTPFlowGraphPaintManager * GetPaintManager() const
Retrieves the FlowGraphPaintManager object used for drawing the flow graph.
Definition XTPFlowGraphControl.h:1041
CXTPFlowGraphControl::Arrange
virtual void Arrange()
Auto-arranges the Nodes in the active page.
CXTPFlowGraphControl::GetActivePage
CXTPFlowGraphPage * GetActivePage() const
Retrieves a reference to the currently active page.
Definition XTPFlowGraphControl.h:1049
CXTPFlowGraphControl::m_pToolTipContext
CXTPToolTipContext * m_pToolTipContext
Tooltip Context.
Definition XTPFlowGraphControl.h:991
CXTPFlowGraphControl::OnMoveSelection
virtual void OnMoveSelection(CPoint pt)
Called when the selection has changed.
CXTPFlowGraphControl::TransformPoint
CPoint TransformPoint(CPoint pt) const
This method uses the current zoom level and scroll offset to transform a point in logical coordinates...
CXTPFlowGraphControl::SelectAll
virtual void SelectAll()
Selects all Nodes in the graph.
CXTPFlowGraphControl::GetMarkupContext
CXTPMarkupContext * GetMarkupContext() const
Retrieves a pointer to the markup context.
Definition XTPFlowGraphControl.h:1110
CXTPFlowGraphControl::SetActivePage
void SetActivePage(CXTPFlowGraphPage *pPage)
Sets the active page.
CXTPFlowGraphControl::m_pMarkupContext
CXTPMarkupContext * m_pMarkupContext
Markup context of flow graph.
Definition XTPFlowGraphControl.h:1010
CXTPFlowGraphControl::SetZoomLevel
void SetZoomLevel(double dZoomLevel)
Sets the current zoom level for the control.
CXTPFlowGraphControl::m_pImages
CXTPFlowGraphImages * m_pImages
Image collection for the flow graph control.
Definition XTPFlowGraphControl.h:986
CXTPFlowGraphControl::Reposition
virtual void Reposition()
Updates the position of elements in the graph.
CXTPFlowGraphControl::SendNotifyMessage
virtual LRESULT SendNotifyMessage(UINT nMessage, NMHDR *pNMHDR=NULL) const
Sends the specified message to the window.
CXTPFlowGraphControl::GetPages
CXTPFlowGraphPages * GetPages() const
Collection of all pages in the flow graph.
Definition XTPFlowGraphControl.h:1045
CXTPFlowGraphControl::AnimatePageTransition
virtual void AnimatePageTransition(CXTPFlowGraphNode *pNodeFrom, CXTPFlowGraphNode *pNodeTo)
This method will transition from a Node on the current page to a Node on a different page.
CXTPFlowGraphControl::StartDragConnection
virtual void StartDragConnection(CXTPFlowGraphConnection *pConnection)
Internal method that is called when a connection starts to get dragged.
CXTPFlowGraphControl::ZoomToSelection
virtual void ZoomToSelection()
Zooms to the currently selected Nodes.
CXTPFlowGraphControl::SetPaintManager
void SetPaintManager(CXTPFlowGraphPaintManager *pPaintManager)
Sets the FlowGraphPaintManager object used for drawing the flow graph.
CXTPFlowGraphControl::GetAllowModifyConnections
BOOL GetAllowModifyConnections() const
Checks whether the user is allowed to drag/move/add/delete connections.
Definition XTPFlowGraphControl.h:1102
CXTPFlowGraphControl::CancelLabelEdit
void CancelLabelEdit()
Call this method to cancel a label edit.
CXTPFlowGraphControl::StartDragConnectionPoint
virtual void StartDragConnectionPoint(CXTPFlowGraphConnectionPoint *pPoint)
Internal method that is called when a connection point starts to get dragged.
CXTPFlowGraphControl::SetAnimationDelay
void SetAnimationDelay(int nDelay)
Sets the delay to use between animation steps when animation is used (zooming/scrolling).
Definition XTPFlowGraphControl.h:1066
CXTPFlowGraphControl::GetScrollOffset
CPoint GetScrollOffset() const
Gets the scroll offset (how much the page has been scrolled).
CXTPFlowGraphControl::m_pPages
CXTPFlowGraphPages * m_pPages
Pointer to the flow graph's collection of pages.
Definition XTPFlowGraphControl.h:976
CXTPFlowGraphControl::SetSmoothingMode
void SetSmoothingMode(XTPFlowGraphSmoothingMode nSmoothingMode)
Sets the draw quality options for the flow graph.
CXTPFlowGraphControl::LoadXamlTemplate
static CString AFX_CDECL LoadXamlTemplate(LPCTSTR szTemplate)
Loads a markup XAML template from a resource.
CXTPFlowGraphControl::GetToolTipContext
CXTPToolTipContext * GetToolTipContext() const
Call this method to get a pointer to the tooltip context.
Definition XTPFlowGraphControl.h:1062
CXTPFlowGraphControl::Create
BOOL Create(DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID)
Call this method to create a flow graph control.
CXTPFlowGraphControl::SaveToFile
BOOL SaveToFile(LPCTSTR szFile)
Save the picture to a specified file.
CXTPFlowGraphControl::CXTPFlowGraphControl
CXTPFlowGraphControl()
Constructs a CXTPFlowGraphControl object.
CXTPFlowGraphControl::AnimateTo
virtual void AnimateTo(CPoint ptScrollOffset, double dZoomLevel)
Call this method to use animation to scroll to the specified offset in the control.
CXTPFlowGraphControl::SetAllowResizeNodes
void SetAllowResizeNodes(XTPFlowGraphResize nResizeMode)
Sets Node resizing options (drag/drop size of nodes).
Definition XTPFlowGraphControl.h:1090
CXTPFlowGraphControl::GetDefaultMarkupTemplate
CString GetDefaultMarkupTemplate(XTPFlowGraphDefaultXAMLTemplate tmpl) const
Call this method to retrieve a default markup template.
CXTPFlowGraphControl::RenameNode
virtual void RenameNode(CXTPFlowGraphNode *pNode)
Call this method to place a Node into edit mode so the user can edit the text.
CXTPFlowGraphControl::StartDragNodes
virtual void StartDragNodes()
Internal method that is called when Nodes are starting to get dragged.
CXTPFlowGraphControl::EnableScrollBarCtrl
void EnableScrollBarCtrl(int nBar, BOOL bEnable=TRUE)
Enables/disables the scrollbar.
CXTPFlowGraphControl::m_nSmoothingMode
XTPFlowGraphSmoothingMode m_nSmoothingMode
Draw quality options for the flow graph.
Definition XTPFlowGraphControl.h:1008
CXTPFlowGraphControl::OnEndLabelEdit
virtual void OnEndLabelEdit(CXTPFlowGraphElement *pItem, LPCTSTR str)
Called after a label has been edited.
CXTPFlowGraphElement
Base class for all elements in the flow graph.
Definition XTPFlowGraphElement.h:46
CXTPFlowGraphImages
Collection of images that can be used in the flow graph.
Definition XTPFlowGraphImage.h:177
CXTPFlowGraphNodeCustom
Represents a Node object defined by custom XAML markup.
Definition XTPFlowGraphNodeCustom.h:94
CXTPFlowGraphNode
Represents a Node object.
Definition XTPFlowGraphNode.h:116
CXTPFlowGraphPageHistory
Object that contains page transition history for the flow graph.
Definition XTPFlowGraphPageHistory.h:57
CXTPFlowGraphPage
Represents a page in the flow graph.
Definition XTPFlowGraphPage.h:54
CXTPFlowGraphPages
Represents a collection of pages in the flow graph.
Definition XTPFlowGraphPages.h:47
CXTPFlowGraphPaintManager
Handles most of the drawing activities of the flow graph.
Definition XTPFlowGraphPaintManager.h:80
CXTPFlowGraphSelectedElements
Collection of selected elements in the flow graph.
Definition XTPFlowGraphSelectedElements.h:46
CXTPFlowGraphUndoManager
This class abstracts an undo manager.
Definition XTPFlowGraphUndoManager.h:544
CXTPMarkupContext
CXTPMarkupContext is a standalone class used to provide common settings for Markup objects.
Definition XTPMarkupContext.h:128
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72
CXTPToolTipContext
CXTPToolTipContext is a CXTPCmdTarget derived class.
Definition XTPToolTipContext.h:291


Toolkit Pro: XTPMessageBarPaintManager.h Source File

  • Source
  • CommandBars
  • MessageBar
XTPMessageBarPaintManager.h
Go to the documentation of this file.
1
23#if !defined(__XTPMESSAGEBARPAINTMANAGER_H__)
24# define __XTPMESSAGEBARPAINTMANAGER_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPMessageBarPaintManager : public CObject
39{
40 DECLARE_DYNAMIC(CXTPMessageBarPaintManager);
41
42public:
48 CXTPMessageBarPaintManager(CXTPPaintManager* pPaintManager);
49
54 virtual ~CXTPMessageBarPaintManager()
55 {
56 }
57
61 virtual void RefreshMetrics();
62
69 virtual void FillMessageBar(CDC* pDC, CXTPMessageBar* pBar);
70
77 virtual void DrawMessageBarButton(CDC* pDC, CXTPMessageBarButton* pButton);
78
88 virtual CRect GetCloseButtonRect(int x, int y, int cy);
89
94 virtual CSize GetDefaultButtonSize() const;
95
100 virtual int GetHeight() const;
101
106 virtual CRect GetPadding() const;
107
108protected:
109 CXTPPaintManagerColor m_clrBack;
110 CXTPPaintManagerColor m_clrText;
111 CXTPPaintManagerColor m_clrBorder;
112 CXTPPaintManagerColor m_clrInfoBack;
113 CXTPPaintManager* m_pPaintManager;
115private:
116 friend class CXTPPaintManager;
117};
118
120# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
121#endif // !defined(__XTPMESSAGEBARPAINTMANAGER_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPMessageBarButton
CXTPMessageBarButton is a standalone class.
Definition XTPMessageBar.h:48
CXTPMessageBar
CXTPMessageBar is a CControlBar derived class.
Definition XTPMessageBar.h:88
CXTPMessageBarPaintManager
The CXTPMessageBarPaintManager class is used by the message bar to perform standard paint routines.
Definition XTPMessageBarPaintManager.h:39
CXTPMessageBarPaintManager::GetPadding
virtual CRect GetPadding() const
CXTPMessageBarPaintManager::m_clrInfoBack
CXTPPaintManagerColor m_clrInfoBack
Message bar info background color.
Definition XTPMessageBarPaintManager.h:112
CXTPMessageBarPaintManager::m_clrBorder
CXTPPaintManagerColor m_clrBorder
Message bar border color.
Definition XTPMessageBarPaintManager.h:111
CXTPMessageBarPaintManager::m_pPaintManager
CXTPPaintManager * m_pPaintManager
Pointer to the owner paint manager.
Definition XTPMessageBarPaintManager.h:113
CXTPMessageBarPaintManager::m_clrText
CXTPPaintManagerColor m_clrText
Message bar text color.
Definition XTPMessageBarPaintManager.h:110
CXTPMessageBarPaintManager::GetDefaultButtonSize
virtual CSize GetDefaultButtonSize() const
CXTPMessageBarPaintManager::DrawMessageBarButton
virtual void DrawMessageBarButton(CDC *pDC, CXTPMessageBarButton *pButton)
Call this member to draw a button in the message bar.
CXTPMessageBarPaintManager::GetCloseButtonRect
virtual CRect GetCloseButtonRect(int x, int y, int cy)
Call this member to retrieve the close button coordinates.
CXTPMessageBarPaintManager::CXTPMessageBarPaintManager
CXTPMessageBarPaintManager(CXTPPaintManager *pPaintManager)
Message bar constructor.
CXTPMessageBarPaintManager::FillMessageBar
virtual void FillMessageBar(CDC *pDC, CXTPMessageBar *pBar)
Draws the message bar.
CXTPMessageBarPaintManager::~CXTPMessageBarPaintManager
virtual ~CXTPMessageBarPaintManager()
Handles object destruction.
Definition XTPMessageBarPaintManager.h:54
CXTPMessageBarPaintManager::RefreshMetrics
virtual void RefreshMetrics()
Call to update class colors and settings.
CXTPMessageBarPaintManager::GetHeight
virtual int GetHeight() const
CXTPMessageBarPaintManager::m_clrBack
CXTPPaintManagerColor m_clrBack
Message bar background color.
Definition XTPMessageBarPaintManager.h:109
CXTPPaintManagerColor
The CXTPPaintManagerColor class is used to manage COLORREF values for determining default and applica...
Definition XTPColorManager.h:117
CXTPPaintManager
Paint manager of the command bars.
Definition XTPPaintManager.h:199


Toolkit Pro: Member List

CXTPProgressBase Member List

This is the complete list of members for CXTPProgressBase, including all inherited members.

CXTPProgressBase() | CXTPProgressBase |
GetPos() const | CXTPProgressBase |
GetProgressPaintManager() const =0 | CXTPProgressBase | protectedpure virtual
GetProgressRect()=0 | CXTPProgressBase | pure virtual
GetRange(int &nLower, int &nUpper) const | CXTPProgressBase |
m_nMax | CXTPProgressBase | protected
m_nMin | CXTPProgressBase | protected
m_nPos | CXTPProgressBase | protected
RedrawProgress()=0 | CXTPProgressBase | protectedpure virtual
SetPos(int nPos) | CXTPProgressBase |
SetRange(int nLower, int nUpper) | CXTPProgressBase |
~CXTPProgressBase() | CXTPProgressBase | virtual


Toolkit Pro: Member List

CXTPChartAxis Member List

This is the complete list of members for CXTPChartAxis, including all inherited members.

CalcSideMarginsValue(double nMinValue, double nMaxValue) const =0 | CXTPChartAxis | pure virtual
CreateView(CXTPChartDeviceContext *pDC, CXTPChartElementView *pParentView) | CXTPChartAxis | virtual
CXTPChartAxis(CXTPChartDiagram *pDiagram) | CXTPChartAxis |
CXTPChartElement() | CXTPChartElement |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
DoPropExchange(CXTPPropExchange *pPX) | CXTPChartAxis | virtual
GetActualColor() const | CXTPChartAxis |
GetActualInterlacedColor() const | CXTPChartAxis |
GetActualInterlacedColor2() const | CXTPChartAxis |
GetAlignment() const | CXTPChartAxis |
GetAppearance() const | CXTPChartAxis |
GetColor() const | CXTPChartAxis |
GetConstantLines() const | CXTPChartAxis |
GetContent() const | CXTPChartElement |
GetCustomLabels() const | CXTPChartAxis |
GetDiagram() const | CXTPChartAxis |
GetGridLines() const | CXTPChartAxis |
GetGridSpacing() const | CXTPChartAxis |
GetIndex() const | CXTPChartAxis |
GetInterlacedColor() const | CXTPChartAxis |
GetInterlacedColor2() const | CXTPChartAxis |
GetInterlacedFillStyle() const | CXTPChartAxis |
GetLabel() const | CXTPChartAxis |
GetMinorCount() const | CXTPChartAxis |
GetOwner() const | CXTPChartElement |
GetRange() const | CXTPChartAxis |
GetScaleType() const | CXTPChartAxis |
GetScaleTypeMap() const | CXTPChartAxis |
GetStrips() const | CXTPChartAxis |
GetThickness() const | CXTPChartAxis |
GetTickMarks() const | CXTPChartAxis |
GetTitle() const | CXTPChartAxis |
Is3D() const | CXTPChartObject |
IsInterlaced() const | CXTPChartAxis |
IsReversed() const | CXTPChartAxis |
IsValuesAxis() const =0 | CXTPChartAxis | pure virtual
IsVertical() const =0 | CXTPChartAxis | pure virtual
IsVisible() const | CXTPChartAxis |
m_bGridSpacingAuto | CXTPChartAxis | protected
m_bInterlaced | CXTPChartAxis | protected
m_bLogarithmic | CXTPChartAxis | protected
m_bReversed | CXTPChartAxis | protected
m_bVisible | CXTPChartAxis | protected
m_clrColor | CXTPChartAxis | protected
m_clrInterlacedColor | CXTPChartAxis | protected
m_clrInterlacedColor2 | CXTPChartAxis | protected
m_dGridSpacing | CXTPChartAxis | protected
m_dLogarithmicBase | CXTPChartAxis | protected
m_nAlignment | CXTPChartAxis | protected
m_nMinorCount | CXTPChartAxis | protected
m_nScaleType | CXTPChartAxis | protected
m_nThickness | CXTPChartAxis | protected
m_pConstantLines | CXTPChartAxis | protected
m_pCustomLabels | CXTPChartAxis | protected
m_pDiagram | CXTPChartAxis | protected
m_pGridLines | CXTPChartAxis | protected
m_pInterlacedFillStyle | CXTPChartAxis | protected
m_pLabel | CXTPChartAxis | protected
m_pRange | CXTPChartAxis | protected
m_pScaleTypeMap | CXTPChartAxis | protected
m_pStrips | CXTPChartAxis | protected
m_pTickMarks | CXTPChartAxis | protected
m_pTitle | CXTPChartAxis | protected
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartElement | virtual
Release() | CXTPChartElement | virtual
SetAlignment(XTPChartAxisAlignment nAlignment) | CXTPChartAxis |
SetColor(const CXTPChartColor &color) | CXTPChartAxis |
SetDateTimeScaleUnit(XTPChartAxisDateTimeScaleUnit unit) | CXTPChartAxis |
SetGridSpacing(double dGridSpacing) | CXTPChartAxis |
SetGridSpacingAuto(BOOL bGridSpacingAuto) | CXTPChartAxis |
SetIndex(int nIndex) | CXTPChartAxis |
SetInterlaced(BOOL bInterlaced) | CXTPChartAxis |
SetInterlacedColor(const CXTPChartColor &color) | CXTPChartAxis |
SetInterlacedColor2(const CXTPChartColor &color) | CXTPChartAxis |
SetLogarithmic(BOOL bLogarithmic) | CXTPChartAxis |
SetLogarithmicBase(double dLogarithmicBase) | CXTPChartAxis |
SetMinorCount(int nMinorCount) | CXTPChartAxis |
SetReversed(BOOL bRevered) | CXTPChartAxis |
SetThickness(int nThicknes) | CXTPChartAxis |
SetVisible(BOOL bVisible) | CXTPChartAxis |
UpdateRange(CXTPChartDeviceContext *pDC, CXTPChartAxisView *pView) | CXTPChartAxis |
~CXTPChartAxis() | CXTPChartAxis | virtual
~CXTPChartElement() | CXTPChartElement | virtual


Toolkit Pro: Member List

CXTPRecentFileList Member List

This is the complete list of members for CXTPRecentFileList, including all inherited members.

Add(LPCTSTR lpszPathName) | CXTPRecentFileList | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPRecentFileList(UINT nStart, LPCTSTR lpszSection, LPCTSTR lpszEntryFormat, int nSize, int nMaxDispLen=AFX_ABBREV_FILENAME_LEN) | CXTPRecentFileList |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
m_bPinable | CXTPRecentFileList |
ReadList() | CXTPRecentFileList | virtual
Remove(int nIndex) | CXTPRecentFileList | virtual
WriteList() | CXTPRecentFileList | virtual
~CXTPRecentFileList() | CXTPRecentFileList |


Toolkit Pro: XTPShellTreeCtrlView.h Source File

  • Source
  • Controls
  • Shell
XTPShellTreeCtrlView.h
Go to the documentation of this file.
1
23#if !defined(__XTPSHELLTREECTRL_H__)
24# define __XTPSHELLTREECTRL_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33 DECLARE_SHELLTREE_BASE(CXTPShellTreeViewBase, CTreeView, CXTPShellTreeBase)
34 DECLARE_SHELLTREE_BASE(CXTPShellTreeCtrlBase, CTreeCtrl, CXTPShellTreeBase)
35
36
41class _XTP_EXT_CLASS CXTPShellTreeView : public CXTPShellTreeViewBase
42{
44 DECLARE_DYNCREATE(CXTPShellTreeView)
46public:
51 CXTPShellTreeView();
52
57 virtual ~CXTPShellTreeView();
58
59protected:
72 virtual void SelectionChanged(HTREEITEM hItem, CString strFolderPath);
73
75 DECLARE_MESSAGE_MAP()
76
77 //{{AFX_VIRTUAL(CXTPShellTreeView)
78public:
79 virtual void OnInitialUpdate();
80
81protected:
82 virtual void OnUpdate(CView* pSender, LPARAM lHint, CObject* pHint);
83 //}}AFX_VIRTUAL
86protected:
87};
88
96class _XTP_EXT_CLASS CXTPShellTreeCtrl : public CXTPShellTreeCtrlBase
97{
99 DECLARE_DYNAMIC(CXTPShellTreeCtrl)
101public:
106 CXTPShellTreeCtrl();
107
112 virtual ~CXTPShellTreeCtrl();
113
114public:
122 virtual bool Init();
123
130 void EnableAutoInit(BOOL bEnable);
131
137 virtual void AssociateList(CWnd* pWnd);
138
145 virtual void AssociateCombo(CWnd* pWnd);
146
147protected:
160 virtual void SelectionChanged(HTREEITEM hItem, CString strFolderPath);
161
162protected:
164 DECLARE_MESSAGE_MAP()
165
166 //{{AFX_VIRTUAL(CXTPShellTreeCtrl)
167 //}}AFX_VIRTUAL
168
169 //{{AFX_MSG(CXTPShellTreeCtrl)
170 afx_msg LRESULT OnUpdateShell(WPARAM wParam, LPARAM lParam);
171 //}}AFX_MSG
174protected:
175 BOOL m_bAutoInit;
176 CWnd* m_pListCtrl;
178};
179
181# define CXTPShellTree CXTPShellTreeCtrl
185
186AFX_INLINE void CXTPShellTreeCtrl::EnableAutoInit(BOOL bEnable)
187{
188 m_bAutoInit = bEnable;
189}
191# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
193#endif // !defined(__XTPSHELLTREECTRL_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
DECLARE_SHELLTREE_BASE
#define DECLARE_SHELLTREE_BASE(ClassName, Tree, Base)
The DECLARE_SHELLTREE_BASE class is a template class used by the CXTPShellTreeView and CXTPShellTreeC...
Definition XTPShellTreeBase.h:460
CXTPShellTreeBase
CXTPShellTreeBase is a multiple inheritance class derived from CXTPTreeView and CXTPShellPidl.
Definition XTPShellTreeBase.h:60
CXTPShellTreeCtrl
CXTPShellTreeCtrl is a multiple inheritance class derived from CXTPTreeCtrl and CXTPShellPidl.
Definition XTPShellTreeCtrlView.h:97
CXTPShellTreeCtrl::~CXTPShellTreeCtrl
virtual ~CXTPShellTreeCtrl()
Destroys a CXTPShellTreeCtrl object, handles cleanup and deallocation.
CXTPShellTreeCtrl::m_bAutoInit
BOOL m_bAutoInit
TRUE if the tree control is to automatically initialize when created.
Definition XTPShellTreeCtrlView.h:175
CXTPShellTreeCtrl::CXTPShellTreeCtrl
CXTPShellTreeCtrl()
Constructs a CXTPShellTreeCtrl object.
CXTPShellTreeCtrl::SelectionChanged
virtual void SelectionChanged(HTREEITEM hItem, CString strFolderPath)
Called after a user makes a new tree selection.
CXTPShellTreeCtrl::EnableAutoInit
void EnableAutoInit(BOOL bEnable)
Call this member function to enable/disable auto-initialization of the shell tree control.
CXTPShellTreeCtrl::AssociateList
virtual void AssociateList(CWnd *pWnd)
Call this member function to associate a list control with the tree.
CXTPShellTreeCtrl::AssociateCombo
virtual void AssociateCombo(CWnd *pWnd)
This member function is used to associate a CComboBox object with the control.
CXTPShellTreeCtrl::Init
virtual bool Init()
This member function is called by the CInitialize class to perform initialization when the window is ...
CXTPShellTreeView
CXTPShellTreeView is a multiple inheritance class derived from CXTPTreeView and CXTPShellPidl.
Definition XTPShellTreeCtrlView.h:42
CXTPShellTreeView::~CXTPShellTreeView
virtual ~CXTPShellTreeView()
Destroys a CXTPShellTreeView object, handles cleanup and deallocation.
CXTPShellTreeView::SelectionChanged
virtual void SelectionChanged(HTREEITEM hItem, CString strFolderPath)
Called after a user makes a new tree selection.
CXTPShellTreeView::CXTPShellTreeView
CXTPShellTreeView()
Constructs a CXTPShellTreeView object.


Toolkit Pro: Member List

XTP_NM_GRIDTOOLTIPINFO Member List

This is the complete list of members for XTP_NM_GRIDTOOLTIPINFO, including all inherited members.

hdr | XTP_NM_GRIDRECORDITEM
nHyperlink | XTP_NM_GRIDRECORDITEM
pColumn | XTP_NM_GRIDRECORDITEM
pItem | XTP_NM_GRIDRECORDITEM
pRow | XTP_NM_GRIDRECORDITEM
pstrText | XTP_NM_GRIDTOOLTIPINFO
pt | XTP_NM_GRIDRECORDITEM


Toolkit Pro: XTPChartAxisTitle.h Source File

  • Source
  • Chart
  • Diagram
  • Axis
XTPChartAxisTitle.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTAXISTITLE_H__)
24# define __XTPCHARTAXISTITLE_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartAxis;
34
39class _XTP_EXT_CLASS CXTPChartAxisTitle : public CXTPChartTextElement
40{
42 DECLARE_DYNAMIC(CXTPChartAxisTitle)
44public:
52 CXTPChartAxisTitle(CXTPChartAxis* pAxis);
53
58 virtual ~CXTPChartAxisTitle();
59
60public:
68 CXTPChartAxis* GetAxis() const;
69
76 void SetText(LPCTSTR lpszTitle);
77
84 CXTPChartString GetText() const;
85
92 void SetTextColor(const CXTPChartColor& clrTextColor);
93
100 CXTPChartColor GetTextColor() const;
101
108 CXTPChartColor GetActualTextColor() const;
109
116 CXTPChartFont* GetFont() const;
117
124 void SetFont(CXTPChartFont* pFont);
125
135 void SetAlignment(XTPChartStringAlignment nAlignment);
136
146 XTPChartStringAlignment GetAlignment() const;
147
154 BOOL IsVisible() const;
155
163 void SetVisible(BOOL bVisible);
164
173 void SetAntialiasing(BOOL bAntialiasing);
174
182 BOOL GetAntialiasing() const;
183
184public:
185 void DoPropExchange(CXTPPropExchange* pPX);
186
187# ifdef _XTP_ACTIVEX
188public:
190 DECLARE_DISPATCH_MAP()
191 DECLARE_INTERFACE_MAP()
192 DECLARE_OLETYPELIB_EX(CXTPChartAxisTitle);
193
194 BSTR OleGetText();
195 void OleSetText(LPCTSTR lpszText);
196 LPDISPATCH OleGetFont();
198# endif
199
200protected:
201 CXTPChartString m_strText;
202 CXTPChartColor m_clrTextColor;
203 BOOL m_bVisible;
204 CXTPChartFont* m_pFont;
205 BOOL m_bAntialiasing;
206 XTPChartStringAlignment m_nAlignment;
207};
208
209AFX_INLINE CXTPChartAxis* CXTPChartAxisTitle::GetAxis() const
210{
211 return (CXTPChartAxis*)m_pOwner;
212}
213
214AFX_INLINE CXTPChartString CXTPChartAxisTitle::GetText() const
215{
216 return m_strText;
217}
218AFX_INLINE CXTPChartFont* CXTPChartAxisTitle::GetFont() const
219{
220 return m_pFont;
221}
222AFX_INLINE XTPChartStringAlignment CXTPChartAxisTitle::GetAlignment() const
223{
224 return m_nAlignment;
225}
226AFX_INLINE BOOL CXTPChartAxisTitle::IsVisible() const
227{
228 return m_bVisible;
229}
230AFX_INLINE void CXTPChartAxisTitle::SetAntialiasing(BOOL bAntialiasing)
231{
232 m_bAntialiasing = bAntialiasing;
233 OnChartChanged();
234}
235AFX_INLINE BOOL CXTPChartAxisTitle::GetAntialiasing() const
236{
237 return m_bAntialiasing;
238}
240# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
241#endif //#if !defined(__XTPCHARTAXISTITLE_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartAxis
This abstract base class represents a chart axis as a kind of chart element.
Definition XTPChartAxis.h:86
CXTPChartAxisTitle
This class represents the axis title.
Definition XTPChartAxisTitle.h:40
CXTPChartAxisTitle::SetAlignment
void SetAlignment(XTPChartStringAlignment nAlignment)
Call this function to set the alignment of the title.
CXTPChartAxisTitle::m_pFont
CXTPChartFont * m_pFont
Pointer to the associated font object.
Definition XTPChartAxisTitle.h:204
CXTPChartAxisTitle::~CXTPChartAxisTitle
virtual ~CXTPChartAxisTitle()
Destroys a CXTPChartAxisTitle object, handles cleanup.
CXTPChartAxisTitle::GetAxis
CXTPChartAxis * GetAxis() const
This function returns a pointer to the CXTPChartAxis object associated with the axis title object.
Definition XTPChartAxisTitle.h:209
CXTPChartAxisTitle::DoPropExchange
void DoPropExchange(CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
CXTPChartAxisTitle::GetActualTextColor
CXTPChartColor GetActualTextColor() const
Call this function to get the actual text color of the axis title.
CXTPChartAxisTitle::GetTextColor
CXTPChartColor GetTextColor() const
Call this function to get the apparent axis title text color.
CXTPChartAxisTitle::m_strText
CXTPChartString m_strText
The axis title value.
Definition XTPChartAxisTitle.h:201
CXTPChartAxisTitle::GetAlignment
XTPChartStringAlignment GetAlignment() const
Call this function to get the alignment of the axis title.
Definition XTPChartAxisTitle.h:222
CXTPChartAxisTitle::GetFont
CXTPChartFont * GetFont() const
Call this function to get the font of the axis title.
Definition XTPChartAxisTitle.h:218
CXTPChartAxisTitle::SetTextColor
void SetTextColor(const CXTPChartColor &clrTextColor)
Call this function to set the axis title text color.
CXTPChartAxisTitle::SetVisible
void SetVisible(BOOL bVisible)
Call this function to set the visibility of the axis title.
CXTPChartAxisTitle::SetFont
void SetFont(CXTPChartFont *pFont)
Call this function to set the font of the title.
CXTPChartAxisTitle::m_nAlignment
XTPChartStringAlignment m_nAlignment
The axis title alignment.
Definition XTPChartAxisTitle.h:206
CXTPChartAxisTitle::IsVisible
BOOL IsVisible() const
Call this function to check the visibility of the axis title.
Definition XTPChartAxisTitle.h:226
CXTPChartAxisTitle::GetText
CXTPChartString GetText() const
Call this function to get the axis title text.
Definition XTPChartAxisTitle.h:214
CXTPChartAxisTitle::SetAntialiasing
void SetAntialiasing(BOOL bAntialiasing)
Call this function to set anti-aliasing ON or OFF.
Definition XTPChartAxisTitle.h:230
CXTPChartAxisTitle::SetText
void SetText(LPCTSTR lpszTitle)
Call this function to set the axis title text.
CXTPChartAxisTitle::m_bVisible
BOOL m_bVisible
TRUE if the axis title is visible and FALSE if invisible.
Definition XTPChartAxisTitle.h:203
CXTPChartAxisTitle::CXTPChartAxisTitle
CXTPChartAxisTitle(CXTPChartAxis *pAxis)
Constructs a CXTPChartAxisTitle object.
CXTPChartAxisTitle::m_clrTextColor
CXTPChartColor m_clrTextColor
The text color.
Definition XTPChartAxisTitle.h:202
CXTPChartAxisTitle::m_bAntialiasing
BOOL m_bAntialiasing
TRUE if the antialiasing ON and FALSE if antialiasing OFF.
Definition XTPChartAxisTitle.h:205
CXTPChartAxisTitle::GetAntialiasing
BOOL GetAntialiasing() const
Call this function to check if anti-aliasing is ON or OFF.
Definition XTPChartAxisTitle.h:235
CXTPChartColor
This class abstracts a color entity.
Definition XTPChartTypes.h:51
CXTPChartElement::OnChartChanged
virtual void OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic propertie...
CXTPChartFont
This class abstracts a font entity.
Definition XTPChartTypes.h:540
CXTPChartTextElement
This class abstracts a chart text element.
Definition XTPChartElement.h:323
CXTPChartTextElement::GetFont
virtual CXTPChartFont * GetFont() const =0
Call this function to get the font of the text element.
CXTPChartTextElement::GetAntialiasing
virtual BOOL GetAntialiasing() const =0
Call this function to check if anti-aliasing is ON or OFF.
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72


Toolkit Pro: Member List

CXTPCheckboxButtonPart Member List

This is the complete list of members for CXTPCheckboxButtonPart, including all inherited members.

AdjustLayout(CDC *pDC, const CRect &rcRect) | CXTPCheckboxButtonPart | virtual
CXTPCalendarCaptionBarThemePart(CXTPCalendarCaptionBarTheme *pTheme, int nPartID) | CXTPCalendarCaptionBarThemePart |
CXTPCalendarWMHandler() | CXTPCalendarWMHandler |
CXTPCmdTarget() | CXTPCmdTarget |
Draw(CDC *pDC) | CXTPCheckboxButtonPart | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCheck() const | CXTPCalendarCaptionBarThemePart | virtual
GetChildHandlerAt(int nIndex) const | CXTPCalendarWMHandler | virtual
GetChildHandlersCount() const | CXTPCalendarWMHandler | virtual
GetPaintManager() const | CXTPCalendarCaptionBarThemePart |
GetPaintTheme() const | CXTPCalendarCaptionBarThemePart | virtual
GetPartID() const | CXTPCalendarCaptionBarThemePart | virtual
GetRect() const | CXTPCalendarCaptionBarThemePart | virtual
GetState() const | CXTPCalendarCaptionBarThemePart |
GetText() const | CXTPCalendarCaptionBarThemePart | virtual
GetTextColor() | CXTPCalendarCaptionBarThemePart | virtual
GetTheme() const | CXTPCalendarCaptionBarThemePart | virtual
HitTest(const CPoint &pt) const | CXTPCalendarCaptionBarThemePart | virtual
IsVisible() const | CXTPCalendarCaptionBarThemePart | virtual
m_bVisible | CXTPCalendarCaptionBarThemePart | protected
m_clrTextColor | CXTPCalendarCaptionBarThemePart |
m_nPartID | CXTPCalendarCaptionBarThemePart | protected
m_nState | CXTPCalendarCaptionBarThemePart |
m_pTheme | CXTPCalendarCaptionBarThemePart | protected
m_rcRect | CXTPCalendarCaptionBarThemePart |
m_strText | CXTPCalendarCaptionBarThemePart |
OnBeforeDestroy() | CXTPCalendarWMHandler | virtual
OnChar(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnKeyUp(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnLButtonDblClk(UINT nFlags, CPoint point) | CXTPCalendarWMHandler | virtual
OnLButtonDown(UINT nFlags, CPoint point) | CXTPCalendarCaptionBarThemePart | virtual
OnLButtonUp(UINT nFlags, CPoint point) | CXTPCalendarCaptionBarThemePart | virtual
OnMouseMove(UINT nFlags, CPoint point) | CXTPCalendarCaptionBarThemePart | virtual
OnPostAdjustLayout() | CXTPCalendarWMHandler | virtual
OnSysKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnTimer(UINT_PTR uTimerID) | CXTPCalendarWMHandler | virtual
OnWndMsg(UINT message, WPARAM wParam, LPARAM lParam, LRESULT *pResult) | CXTPCalendarWMHandler | virtual
Redraw(BOOL bUpdateNow=FALSE) | CXTPCalendarCaptionBarThemePart | virtual
RefreshMetrics() | CXTPCheckboxButtonPart | virtual
SetCheck(int nCheck) | CXTPCalendarCaptionBarThemePart | virtual
SetState(int nState) | CXTPCalendarCaptionBarThemePart | virtual
SetText(LPCTSTR pcszText) | CXTPCalendarCaptionBarThemePart | virtual
SetVisible(BOOL bVisible) | CXTPCalendarCaptionBarThemePart | virtual
~CXTPCalendarCaptionBarThemePart() | CXTPCalendarCaptionBarThemePart | virtual


Toolkit Pro: Member List

CXTPEyeDropper Member List

This is the complete list of members for CXTPEyeDropper, including all inherited members.

Create(DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID) | CXTPEyeDropper | virtual
CXTPEyeDropper() | CXTPEyeDropper |
DrawColor(CDC *pDC) | CXTPEyeDropper | protectedvirtual
DrawDropper(CDC *pDC) | CXTPEyeDropper | protectedvirtual
GetColorRect() | CXTPEyeDropper | protected
GetDropperRect() | CXTPEyeDropper | protected
Init() | CXTPEyeDropper | protectedvirtual
m_bPreInit | CXTPEyeDropper | protected
m_bSetClipboard | CXTPEyeDropper | protected
m_bShowPreview | CXTPEyeDropper | protected
m_color | CXTPEyeDropper | protected
m_hCurEyeDropper | CXTPEyeDropper | protected
m_hCurPrevious | CXTPEyeDropper | protected
m_hIcon | CXTPEyeDropper | protected
m_icoSize | CXTPEyeDropper | protected
m_nPadding | CXTPEyeDropper | protected
SetClipboard(BOOL bSetClipboard) | CXTPEyeDropper |
SetClipboardText(LPCTSTR lpszClipText) | CXTPEyeDropper | protected
ShowPreview(BOOL bShowPreview) | CXTPEyeDropper |
~CXTPEyeDropper() | CXTPEyeDropper | virtual


Toolkit Pro: XTPPropertyGridItemFont.h Source File

  • Source
  • PropertyGrid
XTPPropertyGridItemFont.h
Go to the documentation of this file.
1
23#if !defined(__XTPPROPERTYGRIDITEMFONT_H__)
24# define __XTPPROPERTYGRIDITEMFONT_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPPropertyGridItemFont : public CXTPPropertyGridItem
39{
40public:
47 CXTPPropertyGridItemFont(LPCTSTR strCaption, LOGFONT& font);
48
55 CXTPPropertyGridItemFont(UINT nID, LOGFONT& font);
56
61 virtual ~CXTPPropertyGridItemFont();
62
63public:
69 virtual void SetFont(LOGFONT& font);
70
77 virtual void GetFont(LOGFONT* lf);
78
84 virtual void SetColor(COLORREF clr);
85
92 virtual COLORREF GetColor();
93
94protected:
104 virtual void OnInplaceButtonDown(CXTPPropertyGridInplaceButton* pButton);
105
116 virtual BOOL OnDrawItemValue(CDC& dc, CRect rcValue);
117
125 virtual CRect GetValueRect();
126
135 virtual CString FontToString(const LOGFONT& lfValue);
136
137private:
138 static UINT_PTR CALLBACK FontDlgProc(HWND hWnd, UINT message, WPARAM wParam, LPARAM lParam);
139
140protected:
141 LOGFONT m_lfValue;
142 COLORREF m_clrValue;
144protected:
145 DECLARE_DYNAMIC(CXTPPropertyGridItemFont)
146
147# ifdef _XTP_ACTIVEX
149 DECLARE_DISPATCH_MAP()
150 DECLARE_INTERFACE_MAP()
151
152 DECLARE_OLETYPELIB_EX(CXTPPropertyGridItemFont)
153
154 afx_msg void OleSetValue(const VARIANT* varValue);
155 afx_msg const VARIANT OleGetValue();
156 BSTR OleGetFaceName();
157 void OleSetFaceName(LPCTSTR lpszFaceName);
158 int OleGetSize();
159 void OleSetSize(int nHeigth);
160 int OleGetWeight();
161 void OleSetWeight(int nWeight);
162 BOOL OleGetBold();
163 void OleSetBold(BOOL bBold);
164 BOOL OleGetItalic();
165 void OleSetItalic(BOOL bItalic);
166 BOOL OleGetUnderline();
167 void OleSetUnderline(BOOL bUnderline);
168 BOOL OleGetStrikeOut();
169 void OleSetStrikeOut(BOOL bStrikeOut);
170
172# endif
173};
174
176
178# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
179#endif // #if !defined(__XTPPROPERTYGRIDITEMFONT_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPPropertyGridInplaceButton
CXTPPropertyGridInplaceButton is a CXTPCmdTarget derived class.
Definition XTPPropertyGridInplaceButton.h:50
CXTPPropertyGridItemFont
CXTPPropertyGridItemFont is a CXTPPropertyGridItem derived class.
Definition XTPPropertyGridItemFont.h:39
CXTPPropertyGridItemFont::m_lfValue
LOGFONT m_lfValue
LOGFONT value of the item.
Definition XTPPropertyGridItemFont.h:141
CXTPPropertyGridItemFont::GetColor
virtual COLORREF GetColor()
Gets the COLORREF value of the item.
CXTPPropertyGridItemFont::FontToString
virtual CString FontToString(const LOGFONT &lfValue)
Converts a specified LOGFONT to a string that contains the name and pt of the font.
CXTPPropertyGridItemFont::SetColor
virtual void SetColor(COLORREF clr)
Sets the COLORREF value for the item.
CXTPPropertyGridItemFont::SetFont
virtual void SetFont(LOGFONT &font)
Sets the LOGFONT value for the item.
CXTPPropertyGridItemFont::OnDrawItemValue
virtual BOOL OnDrawItemValue(CDC &dc, CRect rcValue)
This method is called when an item is drawn.
CXTPPropertyGridItemFont::CXTPPropertyGridItemFont
CXTPPropertyGridItemFont(UINT nID, LOGFONT &font)
Constructs a CXTPPropertyGridItemFont object.
CXTPPropertyGridItemFont::m_clrValue
COLORREF m_clrValue
Font color.
Definition XTPPropertyGridItemFont.h:142
CXTPPropertyGridItemFont::GetFont
virtual void GetFont(LOGFONT *lf)
Gets the LOGFONT value of the item.
CXTPPropertyGridItemFont::CXTPPropertyGridItemFont
CXTPPropertyGridItemFont(LPCTSTR strCaption, LOGFONT &font)
Constructs a CXTPPropertyGridItemFont object.
CXTPPropertyGridItemFont::GetValueRect
virtual CRect GetValueRect()
Gets the bounding rectangle of the item value's text.
CXTPPropertyGridItemFont::~CXTPPropertyGridItemFont
virtual ~CXTPPropertyGridItemFont()
Destroys a CXTPPropertyGridItemFont object.
CXTPPropertyGridItemFont::OnInplaceButtonDown
virtual void OnInplaceButtonDown(CXTPPropertyGridInplaceButton *pButton)
This method is called when the user presses the in-place button.
CXTPPropertyGridItem
CXTPPropertyGridItem is the base class representing an item of the Property Grid control.
Definition XTPPropertyGridItem.h:523


Toolkit Pro: Member List

CXTPTaskPanelVisualStudio2012Theme Member List

This is the complete list of members for CXTPTaskPanelVisualStudio2012Theme, including all inherited members.

BlendColor(COLORREF clrFrom, COLORREF clrTo, int nAlpha) | CXTPTaskPanelPaintManager | protected
CreateGripperBitmaps() | CXTPTaskPanelPaintManager | protected
CreateGripperIcon(HICON &hIcon, UINT nIDResource, COLORREF clrGripperBack) | CXTPTaskPanelPaintManager | protected
CXTPTaskPanelPaintManager() | CXTPTaskPanelPaintManager |
CXTPTaskPanelPaintManagerPlain() | CXTPTaskPanelPaintManagerPlain |
CXTPTaskPanelToolboxTheme() | CXTPTaskPanelToolboxTheme |
CXTPTaskPanelVisualStudio2005Theme() | CXTPTaskPanelVisualStudio2005Theme |
CXTPTaskPanelVisualStudio2012Theme(BOOL bLight=TRUE) | CXTPTaskPanelVisualStudio2012Theme |
DrawCaptionGripper(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelPaintManager | protectedvirtual
DrawCaptionGripperBitmap(CDC *pDC, CXTPTaskPanelGroup *pGroup, BOOL bExpanded, BOOL bHot, CRect rc) | CXTPTaskPanelPaintManager | protected
DrawCaptionGripperSigns(CDC *pDC, CPoint pt, COLORREF clr, BOOL bExpanded) | CXTPTaskPanelPaintManager | protected
DrawDragArrow(CDC *pDC, CXTPTaskPanelItem *pItem, CRect rc, BOOL bAfter=FALSE) | CXTPTaskPanelPaintManager | protectedvirtual
DrawFocusRect(CDC *pDC, CRect rc) | CXTPTaskPanelPaintManager | protectedvirtual
DrawGroupCaption(CDC *pDC, CXTPTaskPanelGroup *pGroup, BOOL bDraw) | CXTPTaskPanelToolboxTheme | virtual
DrawGroupCaptionBackground(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelVisualStudio2012Theme | virtual
DrawGroupClient(CDC *pDC, CXTPTaskPanelGroup *pGroup) | CXTPTaskPanelPaintManager | virtual
DrawGroupClientFace(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelVisualStudio2012Theme | virtual
DrawGroupClientItems(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelPaintManager | protectedvirtual
DrawGroupItem(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw) | CXTPTaskPanelPaintManager | virtual
DrawGroupItemFrame(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc) | CXTPTaskPanelVisualStudio2012Theme | virtual
DrawGroupItemImage(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw) | CXTPTaskPanelPaintManager | protected
DrawGroupItemImageWithText(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw) | CXTPTaskPanelPaintManager | protected
DrawGroupItemImageWithTextBelow(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw) | CXTPTaskPanelPaintManager | protected
DrawItemCaption(CDC *pDC, CXTPTaskPanelItem *pItem, CRect rcText, UINT nFormat) | CXTPTaskPanelVisualStudio2012Theme | virtual
DrawItemImage(CDC *pDC, CXTPTaskPanelItem *pItem, CPoint ptIcon, CXTPImageManagerIcon *pImage, CSize szIcon) | CXTPTaskPanelPaintManager | protectedvirtual
DrawScrollButton(CDC *pDC, CXTPTaskPanelScrollButton *pScrollButton) | CXTPTaskPanelPaintManager | virtual
FillGroupClientFace(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelVisualStudio2012Theme | virtual
FillTaskPanel(CDC *pDC, CXTPTaskPanel *pTaskPanel) | CXTPTaskPanelVisualStudio2012Theme | virtual
FreeBitmaps() | CXTPTaskPanelPaintManager | protected
GetCaptionGripperWidth(CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelPaintManager | protectedvirtual
GetControlMargins(const CXTPTaskPanel *pPanel) | CXTPTaskPanelPaintManager | virtual
GetGroupColors(BOOL bSpecial) | CXTPTaskPanelPaintManager |
GetGroupColors(CXTPTaskPanelGroup *pGroup) | CXTPTaskPanelPaintManager | virtual
GetGroupInnerMargins(const CXTPTaskPanelGroup *pGroup) | CXTPTaskPanelPaintManager | virtual
GetGroupOuterMargins(const CXTPTaskPanelGroup *pGroup) | CXTPTaskPanelPaintManager | virtual
GetGroupSpacing(const CXTPTaskPanel *pPanel) | CXTPTaskPanelPaintManager | virtual
GetHighlightOffset(CXTPTaskPanelGroupItem *pItem) | CXTPTaskPanelPaintManager | protectedvirtual
GetItemFont(CXTPTaskPanelItem *pItem) | CXTPTaskPanelPaintManager | virtual
GetItemIconPadding(const CXTPTaskPanelItem *pItem) | CXTPTaskPanelPaintManager | virtual
GetItemInnerMargins(const CXTPTaskPanelGroupItem *pItem) | CXTPTaskPanelPaintManager | virtual
GetItemOuterMargins(const CXTPTaskPanelGroupItem *pItem) | CXTPTaskPanelPaintManager | virtual
m_bBoldCaption | CXTPTaskPanelPaintManager |
m_bCaptionScrollButton | CXTPTaskPanelPaintManager |
m_bEmbossedDisabledText | CXTPTaskPanelPaintManager |
m_bEmulateEplorerTheme | CXTPTaskPanelPaintManager |
m_bInvertDragRect | CXTPTaskPanelPaintManager |
m_bLeftRoundedCorner | CXTPTaskPanelPaintManager | protected
m_bmpGrippers | CXTPTaskPanelPaintManager | protected
m_bOfficeBorder | CXTPTaskPanelPaintManager | protected
m_bOfficeCaption | CXTPTaskPanelPaintManagerPlain | protected
m_bOfficeHighlight | CXTPTaskPanelPaintManager |
m_bRightRoundedCorner | CXTPTaskPanelPaintManager | protected
m_bRoundedFrame | CXTPTaskPanelPaintManagerPlain | protected
m_bUseBitmapGrippers | CXTPTaskPanelPaintManager | protected
m_bUseStandardCaptionFont | CXTPTaskPanelPaintManager | protected
m_bUseStandardItemsFont | CXTPTaskPanelPaintManager | protected
m_clrBackground | CXTPTaskPanelPaintManager | protected
m_clrHighlightBorder | CXTPTaskPanelPaintManager | protected
m_clrHighlightHot | CXTPTaskPanelPaintManager | protected
m_clrHighlightPressed | CXTPTaskPanelPaintManager | protected
m_clrHighlightSelected | CXTPTaskPanelPaintManager | protected
m_clrSelectedText | CXTPTaskPanelVisualStudio2012Theme | protected
m_clrSelectedTextWithoutFocus | CXTPTaskPanelVisualStudio2012Theme | protected
m_clrSelectedWithoutFocus | CXTPTaskPanelVisualStudio2012Theme | protected
m_clrText | CXTPTaskPanelVisualStudio2012Theme | protected
m_eGripper | CXTPTaskPanelPaintManager |
m_groupNormal | CXTPTaskPanelPaintManager | protected
m_groupSpecial | CXTPTaskPanelPaintManager | protected
m_hGripperNormal | CXTPTaskPanelPaintManager | protected
m_hGripperSpecial | CXTPTaskPanelPaintManager | protected
m_nCaptionHeight | CXTPTaskPanelPaintManager | protected
m_nCaptionTextFormat | CXTPTaskPanelPaintManager | protected
m_nGroupSpacing | CXTPTaskPanelPaintManager |
m_nItemTextFormat | CXTPTaskPanelPaintManager | protected
m_rcControlMargins | CXTPTaskPanelPaintManager |
m_rcGroupIconPadding | CXTPTaskPanelPaintManager |
m_rcGroupInnerMargins | CXTPTaskPanelPaintManager |
m_rcGroupOuterMargins | CXTPTaskPanelPaintManager |
m_rcImageLayoutIconPadding | CXTPTaskPanelPaintManager |
m_rcItemIconPadding | CXTPTaskPanelPaintManager |
m_rcItemInnerMargins | CXTPTaskPanelPaintManager |
m_rcItemOuterMargins | CXTPTaskPanelPaintManager |
m_xtpFontCaption | CXTPTaskPanelPaintManager | protected
m_xtpFontIcon | CXTPTaskPanelPaintManager | protected
m_xtpFontIconBold | CXTPTaskPanelPaintManager | protected
m_xtpFontIconHot | CXTPTaskPanelPaintManager | protected
m_xtpFontIconHotBold | CXTPTaskPanelPaintManager | protected
Rectangle(CDC *pDC, CRect rc, COLORREF clrPen, COLORREF clrBrush) | CXTPTaskPanelPaintManager | protected
rectDefault | CXTPTaskPanelPaintManager | static
RefreshMetrics() | CXTPTaskPanelVisualStudio2012Theme | virtual
SetCaptionFontIndirect(LOGFONT *pLogFont, BOOL bUseStandardCaptionFont=FALSE) | CXTPTaskPanelPaintManager |
SetItemsFontIndirect(LOGFONT *pLogFont, BOOL bUseStandardItemsFont=FALSE) | CXTPTaskPanelPaintManager |
SetTextFormat(int nTextFormat, BOOL bCaption=FALSE) | CXTPTaskPanelPaintManager |
~CXTPTaskPanelPaintManager() | CXTPTaskPanelPaintManager | virtual
~CXTPTaskPanelVisualStudio2012Theme() | CXTPTaskPanelVisualStudio2012Theme | virtual


Toolkit Pro: Member List

CXTPPropExchangeArchive Member List

This is the complete list of members for CXTPPropExchangeArchive, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPPropExchange() | CXTPPropExchange |
CXTPPropExchangeArchive(CArchive &ar) | CXTPPropExchangeArchive |
EmptySection() | CXTPPropExchange | virtual
ExchangeBlobProp(LPCTSTR pszPropName, BYTE *&pData, DWORD &nBytes) | CXTPPropExchangeArchive | virtual
ExchangeLocale() | CXTPPropExchange |
ExchangeObjectInstance(CObject *&pObject, CRuntimeClass *pObjectRuntime) | CXTPPropExchangeArchive | virtual
ExchangeProp(LPCTSTR pszPropName, VARTYPE vtProp, void *pvProp, const void *pvDefault=NULL) | CXTPPropExchangeArchive | virtual
ExchangeRuntimeClass(LPCTSTR pszPropName, CRuntimeClass *&pClass, CRuntimeClass *pDefaultClass) | CXTPPropExchangeArchive | virtual
ExchangeSchema() | CXTPPropExchange |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetArchive(LPCTSTR pszPropName) | CXTPPropExchangeArchive | virtual
GetEnumerator(LPCTSTR lpszSection) | CXTPPropExchange | virtual
GetSchema() const | CXTPPropExchange |
GetSection(LPCTSTR lpszSection) | CXTPPropExchangeArchive | virtual
InitSection(CXTPPropExchange *pRootSection) | CXTPPropExchange | protected
IsAllowBlobValues() const | CXTPPropExchangeArchive | virtual
IsAllowDefaultValues() const | CXTPPropExchangeArchive | virtual
IsLoading() const | CXTPPropExchange |
IsRootSection() const | CXTPPropExchange |
IsStoring() const | CXTPPropExchange |
m_ar | CXTPPropExchangeArchive | protected
m_bChildSection | CXTPPropExchange | protected
m_bEmptySection | CXTPPropExchange | protected
m_bInitialized | CXTPPropExchange | protected
m_bLoading | CXTPPropExchange | protected
m_bUseDefaultOnLoad | CXTPPropExchange | protected
m_bUseDefaultOnSave | CXTPPropExchange | protected
m_dwData | CXTPPropExchange |
m_lcidDateTime | CXTPPropExchange | static
m_nSchema | CXTPPropExchange | protected
m_pOwner | CXTPPropExchange |
OnBeforeExchange() | CXTPPropExchange | virtual
Read(LPCTSTR pszPropName, void *lpBuf, UINT nCount) | CXTPPropExchangeArchive | virtual
ReadCount() | CXTPPropExchangeArchive | virtual
ReleaseArchive(LPCTSTR pszPropName, CArchive *pArchive) | CXTPPropExchangeArchive | virtual
SetSchema(UINT nSchemaVersion) | CXTPPropExchange |
UseDefaultOnLoad(BOOL bUseDefaultOnLoad=TRUE) | CXTPPropExchange |
UseDefaultOnSave(BOOL bUseDefaultOnSave=TRUE) | CXTPPropExchange |
Write(LPCTSTR pszPropName, const void *lpBuf, UINT nCount) | CXTPPropExchangeArchive | virtual
WriteCount(DWORD dwCount) | CXTPPropExchangeArchive | virtual
~CXTPPropExchange() | CXTPPropExchange | virtual


Toolkit Pro: XTPCalendarEvents.h Source File

  • Source
  • Calendar
XTPCalendarEvents.h
Go to the documentation of this file.
1
22#if !defined(_XTPCALENDAREVENTS_H__)
23# define _XTPCALENDAREVENTS_H__
24
25# if _MSC_VER > 1000
26# pragma once
27# endif // _MSC_VER > 1000
28
29# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
30
31class CXTPCalendarEvent;
32
54class _XTP_EXT_CLASS CXTPCalendarEvents : public CXTPCmdTarget
55{
57 DECLARE_DYNAMIC(CXTPCalendarEvents)
59public:
66 CXTPCalendarEvents();
67
78 virtual ~CXTPCalendarEvents();
79
127 void Add(CXTPCalendarEvent* pNewEvent, BOOL bWithAddRef = TRUE);
128
162 void Append(CXTPCalendarEvents* pEventsArray);
163
186 CXTPCalendarEvent* GetAt(int nIndex, BOOL bWithAddRef = FALSE) const;
187
227 void SetAt(int nIndex, CXTPCalendarEvent* pEvent, BOOL bWithAddRef = TRUE);
228
248 void InsertAt(int nIndex, CXTPCalendarEvent* pEvent, BOOL bWithAddRef = TRUE);
249
263 void RemoveAt(int nIndex);
264
282 int GetCount() const;
283
296 void SetSize(int nNewSize, int nGrowBy = -1);
297
311 void RemoveAll();
312
354 int Find(CXTPCalendarEvent* pFEvent) const;
355
396 int Find(DWORD dwEventID) const;
397
440 CXTPCalendarEvent* FindEvent(DWORD dwEventID) const;
441
485 CXTPCalendarEvent* FindEvent(CXTPCalendarEvent* pFEvent) const;
486
520 BOOL RemoveByID(DWORD dwEventID);
521
533 void CloneEvents();
534
549 typedef int(AFX_CDECL* T_CompareFunc)(const CXTPCalendarEvent** ppEv1,
550 const CXTPCalendarEvent** ppEv2);
551
581 void Sort(T_CompareFunc pCompareFunc);
582
599 static int AFX_CDECL CompareEvents_ForView(const CXTPCalendarEvent** ppEv1,
600 const CXTPCalendarEvent** ppEv2);
601
619 static int AFX_CDECL CompareEvents_ForViewByStart(const CXTPCalendarEvent** ppEv1,
620 const CXTPCalendarEvent** ppEv2);
621
641 static int AFX_CDECL CompareEvents_ByID(const CXTPCalendarEvent** ppEv1,
642 const CXTPCalendarEvent** ppEv2);
643
644protected:
645 CArray<CXTPCalendarEvent*, CXTPCalendarEvent*> m_arEvents;
648# ifdef _XTP_ACTIVEX
649
650 DECLARE_DISPATCH_MAP()
651 DECLARE_INTERFACE_MAP()
652
653 DECLARE_OLETYPELIB_EX(CXTPCalendarEvents);
654 DECLARE_ENUM_VARIANT(CXTPCalendarEvents)
655
656 LPDISPATCH OleGetItem(long nIndex);
657 int OleGetItemCount();
658
659 void OleAdd(LPDISPATCH pEventDisp);
660 void OleRemove(long nIndex);
661
662# endif
663};
664
666
667AFX_INLINE int CXTPCalendarEvents::GetCount() const
668{
669 return (int)m_arEvents.GetSize();
670}
671AFX_INLINE void CXTPCalendarEvents::SetSize(int nNewSize, int nGrowBy)
672{
673 m_arEvents.SetSize(nNewSize, nGrowBy);
674}
675AFX_INLINE BOOL CXTPCalendarEvents::RemoveByID(DWORD dwEventID)
676{
677 int nFIndex = Find(dwEventID);
678 if (nFIndex >= 0)
679 {
680 RemoveAt(nFIndex);
681 }
682 return (nFIndex >= 0);
683}
684
685# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
686#endif // !defined(_XTPCALENDAREVENTS_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCalendarEvent
This class represents the data of a single Event used in the Calendar control.
Definition XTPCalendarEvent.h:77
CXTPCalendarEvents
This class represents a simple array collection of CXTPCalendarEvent objects.
Definition XTPCalendarEvents.h:55
CXTPCalendarEvents::CompareEvents_ForView
static int AFX_CDECL CompareEvents_ForView(const CXTPCalendarEvent **ppEv1, const CXTPCalendarEvent **ppEv2)
This member function is used to compare specified events so that the events are displayed properly in...
CXTPCalendarEvents::GetCount
int GetCount() const
This member function is used to obtain the number of CXTPCalendarEvent elements in this collection.
Definition XTPCalendarEvents.h:667
CXTPCalendarEvents::~CXTPCalendarEvents
virtual ~CXTPCalendarEvents()
Default collection destructor.
CXTPCalendarEvents::CompareEvents_ByID
static int AFX_CDECL CompareEvents_ByID(const CXTPCalendarEvent **ppEv1, const CXTPCalendarEvent **ppEv2)
This member function is used to compare specified events by the event's IDs.
CXTPCalendarEvents::Find
int Find(CXTPCalendarEvent *pFEvent) const
This method is used to find an event using the EventID in this array.
CXTPCalendarEvents::Find
int Find(DWORD dwEventID) const
This method is used to find an event using the EventID in this array.
CXTPCalendarEvents::CloneEvents
void CloneEvents()
Clone events in the collection.
CXTPCalendarEvents::Sort
void Sort(T_CompareFunc pCompareFunc)
This member function is used to sort events in this array.
CXTPCalendarEvents::Append
void Append(CXTPCalendarEvents *pEventsArray)
Adds a new events element to the end of an array.
CXTPCalendarEvents::InsertAt
void InsertAt(int nIndex, CXTPCalendarEvent *pEvent, BOOL bWithAddRef=TRUE)
Inserts an element at a specified index.
CXTPCalendarEvents::CXTPCalendarEvents
CXTPCalendarEvents()
Default collection constructor.
CXTPCalendarEvents::SetAt
void SetAt(int nIndex, CXTPCalendarEvent *pEvent, BOOL bWithAddRef=TRUE)
This member function is used to set a new event element to the position specified in the nIndex param...
CXTPCalendarEvents::CompareEvents_ForViewByStart
static int AFX_CDECL CompareEvents_ForViewByStart(const CXTPCalendarEvent **ppEv1, const CXTPCalendarEvent **ppEv2)
This member function is used to compare specified events so that the events are displayed properly in...
CXTPCalendarEvents::SetSize
void SetSize(int nNewSize, int nGrowBy=-1)
Set size of the array.
Definition XTPCalendarEvents.h:671
CXTPCalendarEvents::RemoveByID
BOOL RemoveByID(DWORD dwEventID)
This member function is used to find and remove an event using the EventID in this array.
Definition XTPCalendarEvents.h:675
CXTPCalendarEvents::FindEvent
CXTPCalendarEvent * FindEvent(CXTPCalendarEvent *pFEvent) const
This member function is used to find an event using the EventID in this array.
CXTPCalendarEvents::RemoveAll
void RemoveAll()
This function is used to remove all of the elements from this array.
CXTPCalendarEvents::m_arEvents
CArray< CXTPCalendarEvent *, CXTPCalendarEvent * > m_arEvents
An internal storage for CXTPCalendarEvent pointers.
Definition XTPCalendarEvents.h:645
CXTPCalendarEvents::GetAt
CXTPCalendarEvent * GetAt(int nIndex, BOOL bWithAddRef=FALSE) const
Call this method to get an event at the specified numeric index.
CXTPCalendarEvents::RemoveAt
void RemoveAt(int nIndex)
Removes an element of the specified index from this array.
CXTPCalendarEvents::FindEvent
CXTPCalendarEvent * FindEvent(DWORD dwEventID) const
This member function is used to find an event using the EventID in this array.
CXTPCalendarEvents::Add
void Add(CXTPCalendarEvent *pNewEvent, BOOL bWithAddRef=TRUE)
This member function is used to add a new event element to the end of an array.
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122


Toolkit Pro: Member List

CXTPScrollBarThemeOffice2000 Member List

This is the complete list of members for CXTPScrollBarThemeOffice2000, including all inherited members.

CalcHScroll(CXTPScrollBase *pScroll, XTPScrollMetricsH *pHScroll) | CXTPScrollBarPaintManager | protectedstatic
CalcVScroll(CXTPScrollBase *pScroll, XTPScrollMetricsV *pVScroll) | CXTPScrollBarPaintManager | protectedstatic
CXTPScrollBarPaintManager() | CXTPScrollBarPaintManager |
CXTPScrollBarThemeWindowsUx() | CXTPScrollBarThemeWindowsUx |
DrawArrowGlyph(CDC *pDC, CRect rcArrow, XTPArrowGlyph glyph, BOOL bEnabled, COLORREF clrText=COLORREF_NULL) | CXTPScrollBarPaintManager | protected
DrawArrows(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics) | CXTPScrollBarThemeOffice2000 | protectedvirtual
DrawArrows(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics) | CXTPScrollBarThemeOffice2000 | protectedvirtual
DrawBackground(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics) | CXTPScrollBarPaintManager | protectedvirtual
DrawBackground(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics) | CXTPScrollBarPaintManager | protectedvirtual
DrawButtons(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics) | CXTPScrollBarThemeOffice2000 | protectedvirtual
DrawButtons(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics) | CXTPScrollBarThemeOffice2000 | protectedvirtual
DrawGripper(CDC *pDC, CXTPScrollBase *pScroll) | CXTPScrollBarThemeWindowsUx | protectedvirtual
DrawScrollBar(CDC *pDC, CXTPScrollBase *pScrollBar) | CXTPScrollBarPaintManager | virtual
DrawThumbButton(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics) | CXTPScrollBarThemeWindowsUx | protectedvirtual
DrawThumbButton(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics) | CXTPScrollBarThemeWindowsUx | protectedvirtual
DrawTracker(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics) | CXTPScrollBarThemeWindowsUx | protectedvirtual
DrawTracker(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics) | CXTPScrollBarThemeWindowsUx | protectedvirtual
m_crBack | CXTPScrollBarPaintManager |
m_crBackHilite | CXTPScrollBarPaintManager |
m_crBackPushed | CXTPScrollBarPaintManager |
m_crBorder | CXTPScrollBarPaintManager |
m_crBorderHilite | CXTPScrollBarPaintManager |
m_cThumb | CXTPScrollBarPaintManager |
m_cxHScroll | CXTPScrollBarPaintManager |
m_cxVScroll | CXTPScrollBarPaintManager |
m_cyHScroll | CXTPScrollBarPaintManager |
m_cyVScroll | CXTPScrollBarPaintManager |
RefreshMetrics() | CXTPScrollBarThemeWindowsUx | protectedvirtual
~CXTPScrollBarThemeWindowsUx() | CXTPScrollBarThemeWindowsUx | virtual


Toolkit Pro: XTPGridRecordItemNumber.h Source File

  • Source
  • GridControl
  • ItemTypes
XTPGridRecordItemNumber.h
Go to the documentation of this file.
1
23#if !defined(__XTPGRIDRECORDITEMNUMBER_H__)
24# define __XTPGRIDRECORDITEMNUMBER_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
46class _XTP_EXT_CLASS CXTPGridRecordItemNumber : public CXTPGridRecordItem
47{
49 DECLARE_SERIAL(CXTPGridRecordItemNumber)
51public:
57 CXTPGridRecordItemNumber(double dValue = 0);
58
70 CXTPGridRecordItemNumber(double dValue, LPCTSTR strFormat);
71
72public:
82 virtual CString GetCaption(CXTPGridColumn* pColumn);
83
84 using CXTPGridRecordItem::GetCaption;
85
92 double GetValue();
93
99 void SetValue(double dValue);
100
108 virtual void OnEditChanged(XTP_GRIDRECORDITEM_ARGS* pItemArgs, LPCTSTR szText);
109
122 virtual int Compare(CXTPGridColumn* pColumn, CXTPGridRecordItem* pItem);
123
131 virtual COleVariant GetGroupCaptionValue(CXTPGridColumn* pColumn);
132
148 virtual int CompareGroupCaption(CXTPGridColumn* pColumn, CXTPGridGroupRow* pGroupRow);
149
150 using CXTPGridRecordItem::CompareGroupCaption;
151
158 virtual void DoPropExchange(CXTPPropExchange* pPX);
159
160private:
161 static int CompareValues(double v1, double v2);
162
163protected:
164 double m_dValue;
165};
166
174class _XTP_EXT_CLASS CXTPGridRecordItemPercentNumber : public CXTPGridRecordItemNumber
175{
177 DECLARE_SERIAL(CXTPGridRecordItemPercentNumber)
179public:
188 CXTPGridRecordItemPercentNumber(double dValue = 0, COLORREF clr = RGB(224, 224, 224),
189 BOOL bPercentCompleteDisplay = TRUE);
190
199 void OnDrawCaption(XTP_GRIDRECORDITEM_DRAWARGS* pDrawArgs,
200 XTP_GRIDRECORDITEM_METRICS* pMetrics);
201
202public:
203 COLORREF m_clr;
204 BOOL m_bPercentCompleteDisplay;
205};
206
207AFX_INLINE void CXTPGridRecordItemNumber::SetValue(double dValue)
208{
209 m_dValue = dValue;
210}
211
212AFX_INLINE double CXTPGridRecordItemNumber::GetValue()
213{
214 return m_dValue;
215}
216
217# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
219#endif // !defined(__XTPGRIDRECORDITEMNUMBER_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPGridColumn
Represents a grid column item with its properties and operations.
Definition XTPGridColumn.h:107
CXTPGridGroupRow
This class represents a 'group row' of the Grid control view.
Definition XTPGridGroupRow.h:49
CXTPGridRecordItem
Class for working with single list cell.
Definition XTPGridRecordItem.h:600
CXTPGridRecordItem::GetCaption
virtual CString GetCaption()
Gets the text caption of the item.
CXTPGridRecordItem::CompareGroupCaption
virtual int CompareGroupCaption(CXTPGridColumn *pColumn, CXTPGridRecordItem *pItem)
Compares the group caption of the current record item with the group caption of a provided record ite...
CXTPGridRecordItemNumber
This class represents a numeric cell and inherits basic functionality from the CXTPGridRecordItem cla...
Definition XTPGridRecordItemNumber.h:47
CXTPGridRecordItemNumber::DoPropExchange
virtual void DoPropExchange(CXTPPropExchange *pPX)
Call this member function to store/load a grid record item using the specified data object.
CXTPGridRecordItemNumber::Compare
virtual int Compare(CXTPGridColumn *pColumn, CXTPGridRecordItem *pItem)
Compares the current record item with a provided record item.
CXTPGridRecordItemNumber::OnEditChanged
virtual void OnEditChanged(XTP_GRIDRECORDITEM_ARGS *pItemArgs, LPCTSTR szText)
This method is called when the value of the in-place edit control is changed.
CXTPGridRecordItemNumber::GetValue
double GetValue()
Gets the value of the item.
Definition XTPGridRecordItemNumber.h:212
CXTPGridRecordItemNumber::CXTPGridRecordItemNumber
CXTPGridRecordItemNumber(double dValue=0)
Creates a record numeric item with default formatting.
CXTPGridRecordItemNumber::CXTPGridRecordItemNumber
CXTPGridRecordItemNumber(double dValue, LPCTSTR strFormat)
Creates a record numeric item with specified formatting.
CXTPGridRecordItemNumber::GetCaption
virtual CString GetCaption(CXTPGridColumn *pColumn)
Retrieves the text caption of the current item.
CXTPGridRecordItemNumber::CompareGroupCaption
virtual int CompareGroupCaption(CXTPGridColumn *pColumn, CXTPGridGroupRow *pGroupRow)
Compares the group caption of the current record item with the group caption of a provided group row.
CXTPGridRecordItemNumber::GetGroupCaptionValue
virtual COleVariant GetGroupCaptionValue(CXTPGridColumn *pColumn)
Retrieves the group caption native value.
CXTPGridRecordItemNumber::SetValue
void SetValue(double dValue)
Sets the value for the item.
Definition XTPGridRecordItemNumber.h:207
CXTPGridRecordItemNumber::m_dValue
double m_dValue
Cell value.
Definition XTPGridRecordItemNumber.h:164
CXTPGridRecordItemPercentNumber
This class represents a numeric percent cell and inherits basic functionality from the CXTPGridRecord...
Definition XTPGridRecordItemNumber.h:175
CXTPGridRecordItemPercentNumber::OnDrawCaption
void OnDrawCaption(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics)
Should be overridden by descendants for drawing itself.
CXTPGridRecordItemPercentNumber::m_clr
COLORREF m_clr
Color.
Definition XTPGridRecordItemNumber.h:203
CXTPGridRecordItemPercentNumber::m_bPercentCompleteDisplay
BOOL m_bPercentCompleteDisplay
Flag.
Definition XTPGridRecordItemNumber.h:204
CXTPGridRecordItemPercentNumber::CXTPGridRecordItemPercentNumber
CXTPGridRecordItemPercentNumber(double dValue=0, COLORREF clr=RGB(224, 224, 224), BOOL bPercentCompleteDisplay=TRUE)
Constructs a CXTPGridRecordItemPercentNumber object using specified percentage and color values.
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72
XTP_GRIDRECORDITEM_ARGS
Basic set of parameters transferred to item handlers.
Definition XTPGridRecordItem.h:69
XTP_GRIDRECORDITEM_DRAWARGS
A set of parameters transferred to the Draw item handler.
Definition XTPGridRecordItem.h:125
XTP_GRIDRECORDITEM_METRICS
Record item drawing metrics.
Definition XTPGridRecordItem.h:356


Toolkit Pro: XTPTaskPanelVisualStudio2010Theme.h Source File

  • Source
  • TaskPanel
  • Themes
XTPTaskPanelVisualStudio2010Theme.h
Go to the documentation of this file.
1
23#ifndef XTPTaskPanelVisualStudio2010Theme_h__
24# define XTPTaskPanelVisualStudio2010Theme_h__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
39class _XTP_EXT_CLASS CXTPTaskPanelVisualStudio2010Theme : public CXTPTaskPanelVisualStudio2005Theme
40{
41public:
46 CXTPTaskPanelVisualStudio2010Theme();
47
53 ~CXTPTaskPanelVisualStudio2010Theme();
54
64 CRect DrawGroupCaptionBackground(CDC* pDC, CXTPTaskPanelGroup* pGroup, CRect rc);
65
73 void DrawGroupClientFace(CDC* pDC, CXTPTaskPanelGroup* pGroup, CRect rc);
74
84 void FillGroupClientFace(CDC* pDC, CXTPTaskPanelGroup* pGroup, CRect rc);
85
92 void FillTaskPanel(CDC* pDC, CXTPTaskPanel* pTaskPanel);
93
98 void RefreshMetrics();
99
100protected:
101 virtual CRect DrawExpandButton(CDC* pDC, CXTPTaskPanelGroup* pGroup, CRect rc);
102
103protected:
104 CXTPWinThemeWrapper* m_themeTreeExplorer;
105};
107# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
108#endif // XTPTaskPanelVisualStudio2010Theme_h__
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPTaskPanelGroup
CXTPTaskPanelGroup is used in a Task Panel control to represent a group.
Definition XTPTaskPanelGroup.h:45
CXTPTaskPanel
CXTPTaskPanel is used to implement an Explorer and Office-like Task Panel control.
Definition XTPTaskPanel.h:107
CXTPTaskPanelVisualStudio2005Theme
CXTPTaskPanelVisualStudio2005Theme represents a Visual Studio 2005 style theme.
Definition XTPTaskPanelVisualStudio2005Theme.h:40
CXTPTaskPanelVisualStudio2010Theme
CXTPTaskPanelVisualStudio2010Theme represents a VS.NET 2010 style theme.
Definition XTPTaskPanelVisualStudio2010Theme.h:40
CXTPTaskPanelVisualStudio2010Theme::FillTaskPanel
void FillTaskPanel(CDC *pDC, CXTPTaskPanel *pTaskPanel)
Fills the background of a specified task panel.
CXTPTaskPanelVisualStudio2010Theme::~CXTPTaskPanelVisualStudio2010Theme
~CXTPTaskPanelVisualStudio2010Theme()
Destroys a CXTPTaskPanelVisualStudio2010Theme object, handles cleanup and deallocation.
CXTPTaskPanelVisualStudio2010Theme::CXTPTaskPanelVisualStudio2010Theme
CXTPTaskPanelVisualStudio2010Theme()
Constructs a CXTPTaskPanelVisualStudio2010Theme object.
CXTPTaskPanelVisualStudio2010Theme::FillGroupClientFace
void FillGroupClientFace(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Fills the client face of a specified group.
CXTPTaskPanelVisualStudio2010Theme::DrawGroupCaptionBackground
CRect DrawGroupCaptionBackground(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Draws the group caption background of a specified group.
CXTPTaskPanelVisualStudio2010Theme::RefreshMetrics
void RefreshMetrics()
Refreshes the visual metrics of the task panel.
CXTPTaskPanelVisualStudio2010Theme::DrawGroupClientFace
void DrawGroupClientFace(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Draws the client face of a specified group.
CXTPWinThemeWrapper
The CXTPWinThemeWrapper class wraps the UxTheme.dll visual theme API.
Definition XTPWinThemeWrapper.h:188


Toolkit Pro: Member List

CXTPDockingPaneWinExplorerTheme Member List

This is the complete list of members for CXTPDockingPaneWinExplorerTheme, including all inherited members.

AdjustCaptionRect(const CXTPDockingPaneSidePanel *pPane, CRect &rc) | CXTPDockingPanePaintManager | virtual
AdjustCaptionRect(const CXTPDockingPaneTabbedContainer *pPane, CRect &rc) | CXTPDockingPanePaintManager | virtual
AdjustClientRect(CXTPDockingPaneSidePanel *pPane, CRect &rect) | CXTPDockingPanePaintManager | virtual
AdjustClientRect(CXTPDockingPaneTabbedContainer *pPane, CRect &rect, BOOL bApply) | CXTPDockingPanePaintManager | virtual
ClipAndAddEllipsisIfNeeded(CDC *pDC, CString &strTitle, int nCaptionWidth) const | CXTPDockingPanePaintManager | protected
CXTPCmdTarget() | CXTPCmdTarget |
CXTPDockingPaneDefaultTheme() | CXTPDockingPaneDefaultTheme |
CXTPDockingPaneGripperedTheme() | CXTPDockingPaneGripperedTheme |
CXTPDockingPanePaintManager() | CXTPDockingPanePaintManager | protected
CXTPDockingPaneWinExplorerTheme() | CXTPDockingPaneWinExplorerTheme |
DrawAutoHidePanel(CDC *pDC, CRect rc, XTPDockingPaneDirection direction) | CXTPDockingPanePaintManager | virtual
DrawCaption(CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc) | CXTPDockingPaneGripperedTheme | virtual
DrawCaptionButton(CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton) | CXTPDockingPanePaintManager | virtual
DrawCaptionButtonEntry(CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton, CSize szOffset) | CXTPDockingPanePaintManager | protectedvirtual
DrawCaptionButtonEntry(CDC *pDC, CXTPDockingPaneCaptionButton *pButton, CPoint pt, COLORREF clrButton) | CXTPDockingPanePaintManager | protectedvirtual
DrawCaptionButtons(CDC *pDC, CXTPDockingPaneCaptionButtons *pButtons, CRect &rcCaption, COLORREF clr, int nButtonSize, int nButtonGap, BOOL bVertical=FALSE) | CXTPDockingPanePaintManager | virtual
DrawCaptionPart(CDC *pDC, CXTPDockingPaneBase *pPane, CRect rcCaption, const CString &strTitle, BOOL bActive, BOOL bVertical) | CXTPDockingPaneWinExplorerTheme | protectedvirtual
DrawCaptionText(CDC *pDC, const CString &strTitle, CRect rc, BOOL bVertical, BOOL bCalcWidth=FALSE) | CXTPDockingPanePaintManager |
DrawFloatingFrame(CDC *pDC, CXTPDockingPaneMiniWnd *pPane, CRect rc) | CXTPDockingPaneGripperedTheme | virtual
DrawPane(CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc) | CXTPDockingPanePaintManager | virtual
DrawSidePanel(CDC *pDC, CXTPDockingPaneSidePanel *pPane, CRect rc) | CXTPDockingPaneDefaultTheme | virtual
DrawSplitter(CDC *pDC, CXTPDockingPaneSplitterWnd *pSplitter) | CXTPDockingPanePaintManager | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCaptionButtonStyle() const | CXTPDockingPanePaintManager |
GetCaptionGripperRect(const CXTPDockingPaneTabbedContainer *pPane) | CXTPDockingPanePaintManager | virtual
GetCaptionHeight() const | CXTPDockingPanePaintManager |
GetCaptionRect(const CXTPDockingPaneTabbedContainer *pPane, CRect &rc) | CXTPDockingPanePaintManager | virtual
GetCurrentSystemTheme() const | CXTPDockingPanePaintManager |
GetCustomTitleBrush(BOOL bActive, BOOL bVertical) const | CXTPDockingPanePaintManager |
GetPaneCaptionRect(const CXTPDockingPaneSidePanel *pPane) | CXTPDockingPanePaintManager | virtual
GetPanelPaintManager() const | CXTPDockingPanePaintManager |
GetSplitterStyle() const | CXTPDockingPanePaintManager |
GetTabPaintManager() const | CXTPDockingPanePaintManager |
GetTabsHeight() const | CXTPDockingPanePaintManager |
GetXtremeColor(UINT nIndex) | CXTPDockingPanePaintManager |
Line(CDC *pDC, int x0, int y0, int x1, int y1, int nPen) | CXTPDockingPanePaintManager |
Line(CDC *pDC, int x0, int y0, int x1, int y1) | CXTPDockingPanePaintManager |
m_arrColor | CXTPDockingPanePaintManager | protected
m_bDestroyCustomTitleBrushes | CXTPDockingPanePaintManager | protected
m_bDrawCaptionIcon | CXTPDockingPanePaintManager |
m_bDrawSingleTab | CXTPDockingPanePaintManager |
m_bHighlightActiveCaption | CXTPDockingPanePaintManager |
m_bLunaTheme | CXTPDockingPanePaintManager | protected
m_bShowCaption | CXTPDockingPanePaintManager |
m_bUseBoldCaptionFont | CXTPDockingPanePaintManager |
m_bUseOfficeFont | CXTPDockingPanePaintManager | protected
m_bUseStandardFont | CXTPDockingPanePaintManager | protected
m_clrActiveCaption | CXTPDockingPanePaintManager |
m_clrActiveCaptionText | CXTPDockingPanePaintManager |
m_clrBackground | CXTPDockingPanePaintManager |
m_clrDisabledCaptionText | CXTPDockingPanePaintManager |
m_clrNormalCaption | CXTPDockingPanePaintManager |
m_clrNormalCaptionText | CXTPDockingPanePaintManager |
m_clrSplitter | CXTPDockingPanePaintManager |
m_clrSplitterGradient | CXTPDockingPanePaintManager |
m_clrSplitterGripper | CXTPDockingPanePaintManager |
m_dwSplitterStyle | CXTPDockingPanePaintManager | protected
m_hbrActiveTitleHorz | CXTPDockingPanePaintManager | protected
m_hbrActiveTitleVert | CXTPDockingPanePaintManager | protected
m_hbrInactiveTitleHorz | CXTPDockingPanePaintManager | protected
m_hbrInactiveTitleVert | CXTPDockingPanePaintManager | protected
m_nCaptionButtonStyle | CXTPDockingPanePaintManager | protected
m_nCaptionFontGap | CXTPDockingPanePaintManager | protected
m_nSplitterIndent | CXTPDockingPanePaintManager |
m_nSplitterSize | CXTPDockingPanePaintManager |
m_nTabsHeight | CXTPDockingPanePaintManager | protected
m_nTitleHeight | CXTPDockingPanePaintManager | protected
m_pPanelPaintManager | CXTPDockingPanePaintManager | protected
m_pTabPaintManager | CXTPDockingPanePaintManager | protected
m_rcCaptionMargin | CXTPDockingPanePaintManager | protected
m_strOfficeFont | CXTPDockingPanePaintManager | protected
m_systemTheme | CXTPDockingPanePaintManager | protected
m_themeButton | CXTPDockingPanePaintManager | protected
m_themeCurrent | CXTPDockingPanePaintManager | protected
m_themeExplorer | CXTPDockingPanePaintManager | protected
m_themeRebar | CXTPDockingPanePaintManager | protected
m_themeToolbar | CXTPDockingPanePaintManager | protected
m_themeWindow | CXTPDockingPanePaintManager | protected
m_xtpFontTitle | CXTPDockingPanePaintManager | protected
m_xtpFontTitleVertical | CXTPDockingPanePaintManager | protected
Pixel(CDC *pDC, int xPos, int yPos, int nPen) | CXTPDockingPanePaintManager |
Rectangle(CDC *pDC, CRect rc, int nPenEntry, int nPenBorder) | CXTPDockingPanePaintManager |
RefreshMetrics() | CXTPDockingPaneWinExplorerTheme | virtual
SetCaptionButtonStyle(XTPDockingPaneCaptionButtonStyle nStyle) | CXTPDockingPanePaintManager |
SetCaptionFontIndirect(LOGFONT *pLogFont, BOOL bUseStandardFont=FALSE) | CXTPDockingPanePaintManager |
SetColors(int cElements, CONST INT *lpaElements, CONST COLORREF *lpaRgbValues) | CXTPDockingPanePaintManager |
SetCustomTitleBrushes(HBRUSH hbrActiveTitleHorz, HBRUSH hbrInactiveTitleHorz=NULL, HBRUSH hbrActiveTitleVert=NULL, HBRUSH hbrInactiveTitleVert=NULL, BOOL bDestroyOnCleanup=FALSE) | CXTPDockingPanePaintManager |
SetLunaTheme(XTPCurrentSystemTheme systemTheme) | CXTPDockingPanePaintManager |
SetPanelPaintManager(CXTPTabPaintManager *pManager) | CXTPDockingPanePaintManager |
SetSplitterStyle(DWORD dwStyle) | CXTPDockingPanePaintManager |
SetTabPaintManager(CXTPTabPaintManager *pManager) | CXTPDockingPanePaintManager |
UseOfficeFont(BOOL bUseOfficeFont) | CXTPDockingPanePaintManager |
~CXTPDockingPanePaintManager() | CXTPDockingPanePaintManager | protectedvirtual


Toolkit Pro: XTPDockingPaneColorSetNativeWindows10.h Source File

  • Source
  • DockingPane
  • ColorSets
XTPDockingPaneColorSetNativeWindows10.h
Go to the documentation of this file.
1
23#if !defined(__XTPDOCKINGPANECOLORSETNATIVEWINDOWS10_H__)
24# define __XTPDOCKINGPANECOLORSETNATIVEWINDOWS10_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPDockingPaneColorSetNativeWindows10 : public CXTPDockingPaneColorSet
39{
40public:
47 virtual void RefreshMetrics(CString strSection);
48};
49
50# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
52#endif // !defined(__XTPDOCKINGPANECOLORSETNATIVEWINDOWS10_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPDockingPaneColorSet
Helper class used to initialize default colors for a theme from an .INI resource.
Definition XTPDockingPaneColorSet.h:39
CXTPDockingPaneColorSetNativeWindows10
Helper class used to initialize default colors for a theme from an .INI resource.
Definition XTPDockingPaneColorSetNativeWindows10.h:39
CXTPDockingPaneColorSetNativeWindows10::RefreshMetrics
virtual void RefreshMetrics(CString strSection)
This member function is used to initialize default colors for a theme from an .INI resource.


Toolkit Pro: Member List

CXTPMarkupTranslateTransform Member List

This is the complete list of members for CXTPMarkupTranslateTransform, including all inherited members.

ApplyTransform(const CXTPMarkupTransformationMatrix *pMatrix) | CXTPMarkupTranslateTransform | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPMarkupTransform() | CXTPMarkupTransform | protected
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetX() const | CXTPMarkupTranslateTransform |
GetY() const | CXTPMarkupTranslateTransform |
m_pPropertyX | CXTPMarkupTranslateTransform | static
m_pPropertyY | CXTPMarkupTranslateTransform | static
SetX(double x) | CXTPMarkupTranslateTransform |
SetY(double y) | CXTPMarkupTranslateTransform |


Toolkit Pro: Member List

CXTPGridNavigator Member List

This is the complete list of members for CXTPGridNavigator, including all inherited members.

BeginEdit() | CXTPGridNavigator | virtual
CheckDeadEnd(BOOL bMoveDown) | CXTPGridNavigator | protected
CXTPCmdTarget() | CXTPCmdTarget |
CXTPGridNavigator(CXTPGridControl *pGridControl) | CXTPGridNavigator |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCurrentFocusInFootersRows() | CXTPGridNavigator |
GetCurrentFocusInHeadersRows() | CXTPGridNavigator |
m_pGridControl | CXTPGridNavigator | protected
MoveDown(BOOL bShiftKey=FALSE, BOOL bControlKey=FALSE) | CXTPGridNavigator | virtual
MoveDownStep(BOOL bShiftKey=FALSE, BOOL bControlKey=FALSE) | CXTPGridNavigator | virtual
MoveFirstColumn() | CXTPGridNavigator |
MoveFirstRow(BOOL bShiftKey=FALSE, BOOL bControlKey=FALSE) | CXTPGridNavigator |
MoveFirstVisibleRow(XTPGridRowType RowType) | CXTPGridNavigator | protected
MoveLastColumn() | CXTPGridNavigator |
MoveLastRow(BOOL bShiftKey=FALSE, BOOL bControlKey=FALSE) | CXTPGridNavigator |
MoveLastVisibleRow(XTPGridRowType RowType) | CXTPGridNavigator | protected
MoveLeft(BOOL bShiftKey=FALSE, BOOL bControlKey=FALSE) | CXTPGridNavigator |
MoveLeftRight(BOOL bBack, BOOL bShiftKey=FALSE, BOOL bControlKey=FALSE) | CXTPGridNavigator | protectedvirtual
MovePageDown(BOOL bShiftKey=FALSE, BOOL bControlKey=FALSE) | CXTPGridNavigator | virtual
MovePageUp(BOOL bShiftKey=FALSE, BOOL bControlKey=FALSE) | CXTPGridNavigator | virtual
MoveRight(BOOL bShiftKey=FALSE, BOOL bControlKey=FALSE) | CXTPGridNavigator |
MoveToColumn(int nColumnIndex, BOOL bClearIfNonFocusable=FALSE) | CXTPGridNavigator |
MoveToRow(int nRowIndex, BOOL bShiftKey=FALSE, BOOL bControlKey=FALSE) | CXTPGridNavigator |
MoveUp(BOOL bShiftKey=FALSE, BOOL bControlKey=FALSE) | CXTPGridNavigator | virtual
MoveUpStep(BOOL bShiftKey=FALSE, BOOL bControlKey=FALSE) | CXTPGridNavigator | virtual
SetCurrentFocusInFootersRows(BOOL bCurrentFocusInFootersRows) | CXTPGridNavigator |
SetCurrentFocusInHeadersRows(BOOL bCurrentFocusInHeadersRows) | CXTPGridNavigator |
~CXTPGridNavigator() | CXTPGridNavigator | virtual


Toolkit Pro: XTPChart3dFunnelDeviceCommandEvents.h Source File

  • Source
  • Chart
  • Styles
  • Funnel
  • 3D
  • Commands
XTPChart3dFunnelDeviceCommandEvents.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHART3DFUNNELDEVICECOMMANDEVENTS_H__)
24# define __XTPCHART3DFUNNELDEVICECOMMANDEVENTS_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartDeviceCommand;
34
39class _XTP_EXT_CLASS CXTPChart3dFunnelDeviceCommandEvents
40 : public CXTPChartDeviceCommandEvents
41 , public CXTPTypeIdProvider<CXTPChart3dFunnelDeviceCommandEvents, CXTPChartDeviceCommandEvents>
42{
43protected:
48 CXTPChart3dFunnelDeviceCommandEvents();
49
50public:
59 virtual void OnSetConnectorPoints(CXTPChartDeviceCommand* pCommand, CXTPPoint3d ptShapeCenter,
60 CXTPPoint3d ptOuterCenter);
61};
63# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
64#endif //#if !defined(__XTPCHART3DFUNNELDEVICECOMMANDEVENTS_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChart3dFunnelDeviceCommandEvents
Defines interface for 3D chart funnel device command event sink.
Definition XTPChart3dFunnelDeviceCommandEvents.h:42
CXTPChart3dFunnelDeviceCommandEvents::CXTPChart3dFunnelDeviceCommandEvents
CXTPChart3dFunnelDeviceCommandEvents()
Constructs a CXTPChart3dFunnelDeviceCommandEvents object.
CXTPChart3dFunnelDeviceCommandEvents::OnSetConnectorPoints
virtual void OnSetConnectorPoints(CXTPChartDeviceCommand *pCommand, CXTPPoint3d ptShapeCenter, CXTPPoint3d ptOuterCenter)
Gets called when funnel connector points are computed.
CXTPChartDeviceCommandEvents
Defines a callback interface for a chart device command event sink.
Definition XTPChartDeviceCommand.h:48
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPPoint3T< double >


Toolkit Pro: XTPCommandBarsOffice2007SystemTheme.h Source File

  • Source
  • CommandBars
  • Themes
XTPCommandBarsOffice2007SystemTheme.h
Go to the documentation of this file.
1
23#if !defined(__XTPCOMMANDBARSOFFICE2007SYSTEMTHEME_H__)
24# define __XTPCOMMANDBARSOFFICE2007SYSTEMTHEME_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class _XTP_EXT_CLASS CXTPCommandBarsOffice2007SystemTheme : public CXTPCommandBarsOfficeXPTheme
34{
36 DECLARE_DYNAMIC(CXTPCommandBarsOffice2007SystemTheme)
38public:
43 CXTPCommandBarsOffice2007SystemTheme();
44
50 virtual ~CXTPCommandBarsOffice2007SystemTheme();
51
52public:
59 virtual CXTPFramePaintManager* GetFramePaintManager();
60
67 virtual CXTPRibbonPaintManager* GetRibbonPaintManager();
68
69protected:
74 virtual void RefreshMetrics();
75
76protected:
77 CXTPMarkupContext* m_pMarkupContext;
78};
79
81# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
82#endif // !defined(__XTPCOMMANDBARSOFFICE2007SYSTEMTHEME_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCommandBarsOfficeXPTheme
The CXTPCommandBarsOfficeXPTheme class is used to enable an Office XP style theme for Command Bars.
Definition XTPCommandBarsOfficeXPTheme.h:41
CXTPFramePaintManager
Paint manager for the Office 2007 style window frame.
Definition XTPFramePaintManager.h:41
CXTPMarkupContext
CXTPMarkupContext is a standalone class used to provide common settings for Markup objects.
Definition XTPMarkupContext.h:128
CXTPPaintManager::GetFramePaintManager
virtual CXTPFramePaintManager * GetFramePaintManager()
Retrieves paint manager used to draw frames.
CXTPPaintManager::GetRibbonPaintManager
virtual CXTPRibbonPaintManager * GetRibbonPaintManager()
Retrieves the ribbon paint manager.
CXTPPaintManager::RefreshMetrics
virtual void RefreshMetrics()
This method is called to refresh the visual metrics of the manager.
CXTPRibbonPaintManager
Standalone class used by CXTPRibbonBar as a paint manager.
Definition XTPRibbonPaintManager.h:51


Toolkit Pro: Member List

XTP_NM_GRIDGIVEFEEDBACK Member List

This is the complete list of members for XTP_NM_GRIDGIVEFEEDBACK, including all inherited members.


Toolkit Pro: Member List

CXTPDockContext Member List

This is the complete list of members for CXTPDockContext, including all inherited members.

CXTPDockContext(CXTPToolBar *pBar) | CXTPDockContext |
m_nHitTest | CXTPDockContext | protected
m_pBar | CXTPDockContext | protected
m_ptLast | CXTPDockContext | protected
m_ptMRUFloatPos | CXTPDockContext | protected
m_rectDragDock | CXTPDockContext | protected
m_rectDragFrame | CXTPDockContext | protected
m_rectMRUDockPos | CXTPDockContext | protected
m_uMRUDockPosition | CXTPDockContext | protected
Move(CPoint pt) | CXTPDockContext | protected
Resize(CPoint pt) | CXTPDockContext | protected
StartDrag(CPoint pt) | CXTPDockContext | virtual
StartResize(int nHitTest, CPoint pt) | CXTPDockContext | virtual
Stretch(CPoint pt) | CXTPDockContext | protected
ToggleDocking() | CXTPDockContext | virtual
Track() | CXTPDockContext | protectedvirtual
~CXTPDockContext() | CXTPDockContext | virtual


Toolkit Pro: XTPGridThemeNativeWindows11.h Source File

  • Source
  • GridControl
  • Themes
XTPGridThemeNativeWindows11.h
Go to the documentation of this file.
1
23#if !defined(__XTPGRIDTHEMENATIVEWINDOWS11_H__)
24# define __XTPGRIDTHEMENATIVEWINDOWS11_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPGridThemeNativeWindows11 : public CXTPGridThemeOffice2013
39{
40public:
45 CXTPGridThemeNativeWindows11();
46
52 virtual void RefreshMetrics();
53};
55# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
56#endif //#if !defined(__XTPGRIDTHEMENATIVEWINDOWS11_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPGridThemeNativeWindows11
CXTPGridThemeNativeWindows11 is a CXTPGridThemeOffice2013 derived class that represents a Native Wind...
Definition XTPGridThemeNativeWindows11.h:39
CXTPGridThemeNativeWindows11::CXTPGridThemeNativeWindows11
CXTPGridThemeNativeWindows11()
Default paint manager constructor, handles properties initialization.
CXTPGridThemeNativeWindows11::RefreshMetrics
virtual void RefreshMetrics()
This method is called to refresh the visual metrics of the Grid control.
CXTPGridThemeOffice2013
CXTPGridThemeOffice2013 is a CXTPGridPaintManager derived class that represents an Office 2013 style ...
Definition XTPGridThemeOffice2013.h:39


Toolkit Pro: Member List

CXTPDockingPaneOffice2003VisioTheme Member List

This is the complete list of members for CXTPDockingPaneOffice2003VisioTheme, including all inherited members.

AdjustCaptionRect(const CXTPDockingPaneTabbedContainer *pPane, CRect &rc) | CXTPDockingPaneOffice2002VisioTheme | virtual
CXTPDockingPaneVisualStudio2003Theme::AdjustCaptionRect(const CXTPDockingPaneSidePanel *pPane, CRect &rc) | CXTPDockingPanePaintManager | virtual
AdjustClientRect(CXTPDockingPaneSidePanel *pPane, CRect &rect) | CXTPDockingPanePaintManager | virtual
AdjustClientRect(CXTPDockingPaneTabbedContainer *pPane, CRect &rect, BOOL bApply) | CXTPDockingPanePaintManager | virtual
ClipAndAddEllipsisIfNeeded(CDC *pDC, CString &strTitle, int nCaptionWidth) const | CXTPDockingPanePaintManager | protected
CXTPCmdTarget() | CXTPCmdTarget |
CXTPDockingPaneDefaultTheme() | CXTPDockingPaneDefaultTheme |
CXTPDockingPaneGripperedTheme() | CXTPDockingPaneGripperedTheme |
CXTPDockingPaneOffice2002VisioTheme() | CXTPDockingPaneOffice2002VisioTheme |
CXTPDockingPaneOffice2003VisioTheme() | CXTPDockingPaneOffice2003VisioTheme |
CXTPDockingPanePaintManager() | CXTPDockingPanePaintManager | protected
CXTPDockingPaneVisualStudio2003Theme() | CXTPDockingPaneVisualStudio2003Theme |
DrawAutoHidePanel(CDC *pDC, CRect rc, XTPDockingPaneDirection direction) | CXTPDockingPanePaintManager | virtual
DrawCaption(CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc) | CXTPDockingPaneOffice2002VisioTheme | virtual
DrawCaptionButton(CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton) | CXTPDockingPanePaintManager | virtual
DrawCaptionButtonEntry(CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton, CSize szOffset) | CXTPDockingPanePaintManager | protectedvirtual
DrawCaptionButtonEntry(CDC *pDC, CXTPDockingPaneCaptionButton *pButton, CPoint pt, COLORREF clrButton) | CXTPDockingPanePaintManager | protectedvirtual
DrawCaptionButtons(CDC *pDC, CXTPDockingPaneCaptionButtons *pButtons, CRect &rcCaption, COLORREF clr, int nButtonSize, int nButtonGap, BOOL bVertical=FALSE) | CXTPDockingPanePaintManager | virtual
DrawCaptionPart(CDC *pDC, CXTPDockingPaneBase *pPane, CRect rcCaption, const CString &strTitle, BOOL bActive, BOOL bVertical) | CXTPDockingPaneVisualStudio2003Theme | protectedvirtual
DrawCaptionText(CDC *pDC, const CString &strTitle, CRect rc, BOOL bVertical, BOOL bCalcWidth=FALSE) | CXTPDockingPanePaintManager |
DrawFloatingFrame(CDC *pDC, CXTPDockingPaneMiniWnd *pPane, CRect rc) | CXTPDockingPaneOffice2002VisioTheme | virtual
DrawPane(CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc) | CXTPDockingPaneOffice2002VisioTheme | virtual
DrawSidePanel(CDC *pDC, CXTPDockingPaneSidePanel *pPane, CRect rc) | CXTPDockingPaneDefaultTheme | virtual
DrawSplitter(CDC *pDC, CXTPDockingPaneSplitterWnd *pSplitter) | CXTPDockingPanePaintManager | virtual
FillCaptionPart(CDC *pDC, CXTPDockingPaneBase *pPane, CRect rcCaption, BOOL bActive, BOOL bVertical) | CXTPDockingPaneVisualStudio2003Theme | protectedvirtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCaptionButtonStyle() const | CXTPDockingPanePaintManager |
GetCaptionGripperRect(const CXTPDockingPaneTabbedContainer *pPane) | CXTPDockingPanePaintManager | virtual
GetCaptionHeight() const | CXTPDockingPanePaintManager |
GetCaptionRect(const CXTPDockingPaneTabbedContainer *pPane, CRect &rc) | CXTPDockingPanePaintManager | virtual
GetCurrentSystemTheme() const | CXTPDockingPanePaintManager |
GetCustomTitleBrush(BOOL bActive, BOOL bVertical) const | CXTPDockingPanePaintManager |
GetPaneCaptionRect(const CXTPDockingPaneSidePanel *pPane) | CXTPDockingPanePaintManager | virtual
GetPanelPaintManager() const | CXTPDockingPanePaintManager |
GetSplitterStyle() const | CXTPDockingPanePaintManager |
GetTabPaintManager() const | CXTPDockingPanePaintManager |
GetTabsHeight() const | CXTPDockingPanePaintManager |
GetXtremeColor(UINT nIndex) | CXTPDockingPanePaintManager |
Line(CDC *pDC, int x0, int y0, int x1, int y1, int nPen) | CXTPDockingPanePaintManager |
Line(CDC *pDC, int x0, int y0, int x1, int y1) | CXTPDockingPanePaintManager |
m_arrColor | CXTPDockingPanePaintManager | protected
m_bDestroyCustomTitleBrushes | CXTPDockingPanePaintManager | protected
m_bDrawCaptionIcon | CXTPDockingPanePaintManager |
m_bDrawSingleTab | CXTPDockingPanePaintManager |
m_bGradientCaption | CXTPDockingPaneVisualStudio2003Theme | protected
m_bHighlightActiveCaption | CXTPDockingPanePaintManager |
m_bLunaTheme | CXTPDockingPanePaintManager | protected
m_bShowCaption | CXTPDockingPanePaintManager |
m_bUseBoldCaptionFont | CXTPDockingPanePaintManager |
m_bUseOfficeFont | CXTPDockingPanePaintManager | protected
m_bUseStandardFont | CXTPDockingPanePaintManager | protected
m_clrActiveCaption | CXTPDockingPanePaintManager |
m_clrActiveCaptionText | CXTPDockingPanePaintManager |
m_clrBackground | CXTPDockingPanePaintManager |
m_clrDisabledCaptionText | CXTPDockingPanePaintManager |
m_clrNormalCaption | CXTPDockingPanePaintManager |
m_clrNormalCaptionText | CXTPDockingPanePaintManager |
m_clrSplitter | CXTPDockingPanePaintManager |
m_clrSplitterGradient | CXTPDockingPanePaintManager |
m_clrSplitterGripper | CXTPDockingPanePaintManager |
m_dwSplitterStyle | CXTPDockingPanePaintManager | protected
m_hbrActiveTitleHorz | CXTPDockingPanePaintManager | protected
m_hbrActiveTitleVert | CXTPDockingPanePaintManager | protected
m_hbrInactiveTitleHorz | CXTPDockingPanePaintManager | protected
m_hbrInactiveTitleVert | CXTPDockingPanePaintManager | protected
m_nCaptionButtonStyle | CXTPDockingPanePaintManager | protected
m_nCaptionFontGap | CXTPDockingPanePaintManager | protected
m_nSplitterIndent | CXTPDockingPanePaintManager |
m_nSplitterSize | CXTPDockingPanePaintManager |
m_nTabsHeight | CXTPDockingPanePaintManager | protected
m_nTitleHeight | CXTPDockingPanePaintManager | protected
m_pPanelPaintManager | CXTPDockingPanePaintManager | protected
m_pTabPaintManager | CXTPDockingPanePaintManager | protected
m_rcCaptionMargin | CXTPDockingPanePaintManager | protected
m_strOfficeFont | CXTPDockingPanePaintManager | protected
m_systemTheme | CXTPDockingPanePaintManager | protected
m_themeButton | CXTPDockingPanePaintManager | protected
m_themeCurrent | CXTPDockingPanePaintManager | protected
m_themeExplorer | CXTPDockingPanePaintManager | protected
m_themeRebar | CXTPDockingPanePaintManager | protected
m_themeToolbar | CXTPDockingPanePaintManager | protected
m_themeWindow | CXTPDockingPanePaintManager | protected
m_xtpFontTitle | CXTPDockingPanePaintManager | protected
m_xtpFontTitleVertical | CXTPDockingPanePaintManager | protected
Pixel(CDC *pDC, int xPos, int yPos, int nPen) | CXTPDockingPanePaintManager |
Rectangle(CDC *pDC, CRect rc, int nPenEntry, int nPenBorder) | CXTPDockingPanePaintManager |
RefreshMetrics() | CXTPDockingPaneOffice2002VisioTheme | virtual
SetCaptionButtonStyle(XTPDockingPaneCaptionButtonStyle nStyle) | CXTPDockingPanePaintManager |
SetCaptionFontIndirect(LOGFONT *pLogFont, BOOL bUseStandardFont=FALSE) | CXTPDockingPanePaintManager |
SetColors(int cElements, CONST INT *lpaElements, CONST COLORREF *lpaRgbValues) | CXTPDockingPanePaintManager |
SetCustomTitleBrushes(HBRUSH hbrActiveTitleHorz, HBRUSH hbrInactiveTitleHorz=NULL, HBRUSH hbrActiveTitleVert=NULL, HBRUSH hbrInactiveTitleVert=NULL, BOOL bDestroyOnCleanup=FALSE) | CXTPDockingPanePaintManager |
SetLunaTheme(XTPCurrentSystemTheme systemTheme) | CXTPDockingPanePaintManager |
SetPanelPaintManager(CXTPTabPaintManager *pManager) | CXTPDockingPanePaintManager |
SetSplitterStyle(DWORD dwStyle) | CXTPDockingPanePaintManager |
SetTabPaintManager(CXTPTabPaintManager *pManager) | CXTPDockingPanePaintManager |
UseOfficeFont(BOOL bUseOfficeFont) | CXTPDockingPanePaintManager |
~CXTPDockingPanePaintManager() | CXTPDockingPanePaintManager | protectedvirtual


Toolkit Pro: Member List

CXTPControlRecentFileList Member List

This is the complete list of members for CXTPControlRecentFileList, including all inherited members.

AssignDocTemplate(UINT nIDResource) | CXTPControl |
ClickToolBarButton(CRect rcActiveRect=CRect(0, 0, 0, 0)) | CXTPControl | protected
Compare(CXTPControl *pOther) | CXTPControl | virtual
Copy(CXTPControl *pControl, BOOL bRecursive=FALSE) | CXTPControlButton | protectedvirtual
CustomizeStartDrag(CPoint point) | CXTPControl | protectedvirtual
CustomizeStartResize(CPoint point) | CXTPControl | protectedvirtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPControl() | CXTPControl | protected
CXTPControlButton() | CXTPControlButton |
DelayLayoutParent() | CXTPControl |
DelayRedrawParent() | CXTPControl |
DoCustomDragOver(CXTPCommandBar *pCommandBar, CPoint point, DROPEFFECT &dropEffect) | CXTPControlRecentFileList | protectedvirtual
DoPropExchange(CXTPPropExchange *pPX) | CXTPControlButton | virtual
Draw(CDC *pDC) | CXTPControl | virtual
ExcludeDocTemplate(UINT nIDResource) | CXTPControl |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
FromUI(CCmdUI *pCmdUI) | CXTPControl | static
GenerateCommandBarList(DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam) | CXTPControl | protectedvirtual
GetAction() const | CXTPControl |
GetBeginGroup() const | CXTPControl |
GetButtonSize() const | CXTPControl | virtual
GetCaption() const | CXTPControl | virtual
GetCategory() const | CXTPControl |
GetChecked() const | CXTPControl |
GetCloseSubMenuOnClick() const | CXTPControl |
GetCommandBar() const | CXTPControl | virtual
GetControls() const | CXTPControl |
GetCustomizeMinHeight() const | CXTPControl | protectedvirtual
GetCustomizeMinWidth() const | CXTPControl | protectedvirtual
GetCustomShortcutText() const | CXTPControl |
GetDescription() const | CXTPControl | virtual
GetEnabled() const | CXTPControl |
GetExecuteOnPressInterval() const | CXTPControl |
GetExpanded() const | CXTPControl |
GetFirstMruID() | CXTPControlRecentFileList | protectedvirtual
GetFlags() const | CXTPControl |
GetHeight() const | CXTPControl |
GetHelpId() const | CXTPControl |
GetHideFlags() const | CXTPControl |
GetIconId() const | CXTPControl |
GetIconSize() const | CXTPControl | virtual
GetID() const | CXTPControl |
GetImage(int nWidth=16) const | CXTPControl | virtual
GetImageManager() const | CXTPControl |
GetIndex() const | CXTPControl |
GetKeyboardTip() const | CXTPControl |
GetPaintManager() const | CXTPControl |
GetParameter() const | CXTPControl |
GetParent() const | CXTPControl |
GetPopuped() const | CXTPControl | virtual
GetPressed() const | CXTPControl | virtual
GetRecentFileList() | CXTPControlRecentFileList | protectedvirtual
GetRect() const | CXTPControl |
GetRibbonGroup() const | CXTPControl |
GetRowRect() const | CXTPControl |
GetSelected() const | CXTPControl | virtual
GetShortcutText() const | CXTPControl |
GetSize(CDC *pDC) | CXTPControl | virtual
GetStyle() const | CXTPControl |
GetStyleEx() const | CXTPControlButton |
GetTag() const | CXTPControl |
GetTooltip() const | CXTPControl | virtual
GetType() const | CXTPControl |
GetWidth() const | CXTPControl |
GetWrap() const | CXTPControl |
HasDwmCompositedRect() const | CXTPControl |
IsCaptionVisible() const | CXTPControl | virtual
IsCursorOver() const | CXTPControl |
IsCustomizeMode() const | CXTPControl | protected
IsCustomizeMovable() const | CXTPControl | virtual
IsCustomizeResizeAllow() const | CXTPControl | protectedvirtual
IsFocusable() const | CXTPControl | protectedvirtual
IsFocused() const | CXTPControl | virtual
IsItemDefault() const | CXTPControl |
IsLayoutChanged() | CXTPControl | protected
IsLayoutRTL() const | CXTPControl | protected
IsOnQuickAccess() const | CXTPControl |
IsTemporary() const | CXTPControl |
IsTransparent() const | CXTPControl | inlinevirtual
IsVisible(DWORD dwSkipFlags=0) const | CXTPControl | virtual
m_bBeginGroup | CXTPControl | protected
m_bChecked | CXTPControl | protected
m_bCloseSubMenuOnClick | CXTPControl | protected
m_bDefaultItem | CXTPControl | protected
m_bEnabled | CXTPControl | protected
m_bExpanded | CXTPControl | protected
m_bLayoutRTL | CXTPControl | protected
m_bOnQuickAccess | CXTPControl | protected
m_bPressed | CXTPControl | protected
m_bSelected | CXTPControl | protected
m_bTemporary | CXTPControl | protected
m_buttonCustomStyle | CXTPControl | protected
m_buttonRibbonStyle | CXTPControl | protected
m_buttonStyle | CXTPControl | protected
m_buttonStyleEx | CXTPControlButton | protected
m_bWrap | CXTPControl | protected
m_controlType | CXTPControl | protected
m_dwFlags | CXTPControl | protected
m_dwHideFlags | CXTPControl | protected
m_mapDocTemplatesAssigned | CXTPControl | protected
m_mapDocTemplatesExcluded | CXTPControl | protected
m_nCustomIconId | CXTPControl | protected
m_nExecuteOnPressInterval | CXTPControl | protected
m_nHeight | CXTPControl | protected
m_nHelpId | CXTPControl | protected
m_nIconId | CXTPControl | protected
m_nId | CXTPControl | protected
m_nIndex | CXTPControl | protected
m_nTag | CXTPControl | protected
m_nWidth | CXTPControl | protected
m_pAction | CXTPControl | protected
m_pControls | CXTPControl | protected
m_pParent | CXTPControl | protected
m_pRibbonGroup | CXTPControl | protected
m_rcControl | CXTPControl | protected
m_rcRow | CXTPControl | protected
m_strCaption | CXTPControl | protected
m_strCategory | CXTPControl | protected
m_strCustomCaption | CXTPControl | protected
m_strDescriptionText | CXTPControl | protected
m_strKeyboardTip | CXTPControl | protected
m_strParameter | CXTPControl | protected
m_strShortcutText | CXTPControl | protected
m_strShortcutTextAuto | CXTPControl | protected
m_strTooltipText | CXTPControl | protected
m_szIcon | CXTPControl | protected
NotifySite(UINT code) | CXTPControl |
NotifySite(UINT code, NMXTPCONTROL *pNM) | CXTPControl |
NotifySite(CWnd *pSite, UINT code, NMXTPCONTROL *pNM) | CXTPControl |
OnActionChanged(int nProperty) | CXTPControl | protectedvirtual
OnActionChanging(int nProperty) | CXTPControl | protectedvirtual
OnCalcDynamicSize(DWORD dwMode) | CXTPControlRecentFileList | protectedvirtual
OnCaptionChanged() | CXTPControl | protectedvirtual
OnClick(BOOL bKeyboard=FALSE, CPoint pt=CPoint(0, 0)) | CXTPControlButton | protectedvirtual
OnCustomizeDragOver(CXTPControl *pDataObject, CPoint point, DROPEFFECT &dropEffect) | CXTPControl | protectedvirtual
OnCustomizeMouseMove(CPoint point) | CXTPControl | protected
OnEnabledChanged() | CXTPControl | virtual
OnExecute() | CXTPControl | virtual
OnHookKeyDown(UINT nChar, LPARAM lParam) | CXTPControl | protectedvirtual
OnHookMouseWheel(UINT nFlags, short zDelta, CPoint point) | CXTPControl | protectedvirtual
OnIdleUpdate() | CXTPControl | protectedvirtual
OnLButtonDblClk(CPoint point) | CXTPControl | protectedvirtual
OnLButtonDown(CPoint point) | CXTPControl | protectedvirtual
OnLButtonUp(CPoint point) | CXTPControlButton | protectedvirtual
OnMouseHover() | CXTPControl | protectedvirtual
OnMouseMove(CPoint point) | CXTPControl | protectedvirtual
OnRButtonDown(CPoint point) | CXTPControl | protectedvirtual
OnRButtonUp(CPoint point) | CXTPControl | protectedvirtual
OnRemoved() | CXTPControl | protectedvirtual
OnSetPopup(BOOL bPopup) | CXTPControl | protectedvirtual
OnSetSelected(int bSelected) | CXTPControl | protectedvirtual
OnThemeChanged() | CXTPControl | virtual
OnToolHitTest(CPoint point, TOOLINFO *pTI) const | CXTPControl | protectedvirtual
OnUnderlineActivate() | CXTPControl | virtual
RedrawParent(BOOL bAnimate=TRUE) | CXTPControl |
Reset() | CXTPControl |
RestoreCommandBarList(CXTPCommandBarList *pCommandBarList) | CXTPControl | protectedvirtual
ScreenToClient(CPoint *point) | CXTPControl | protected
SetAction(CXTPControlAction *pAction) | CXTPControl | virtual
SetBeginGroup(BOOL bBeginGroup) | CXTPControl | virtual
SetCaption(LPCTSTR lpszCaption) | CXTPControl |
SetCaption(UINT nIDCaption) | CXTPControl |
SetCategory(LPCTSTR lpszCategory) | CXTPControl |
SetChecked(BOOL bChecked) | CXTPControl | virtual
SetCloseSubMenuOnClick(BOOL bCloseOnClick) | CXTPControl |
SetCustomIcon(HICON hIcon) | CXTPControl |
SetCustomShortcutText(LPCTSTR lpszCustomShortcutText) | CXTPControl |
SetDescription(LPCTSTR lpszDescription) | CXTPControl |
SetEnabled(BOOL bEnabled) | CXTPControl | virtual
SetExecuteOnPressInterval(int nExecuteOnPressInterval) | CXTPControl |
SetExpanded(BOOL bExpanded) | CXTPControl | protected
SetFlags(DWORD dwFlags) | CXTPControl |
SetFocused(BOOL bFocused) | CXTPControl | virtual
SetHeight(int nHeight) | CXTPControl | virtual
SetHelpId(int nId) | CXTPControl |
SetHideFlag(XTPControlHideFlags dwFlag, BOOL bSet) | CXTPControl |
SetHideFlags(DWORD dwFlags) | CXTPControl | virtual
SetHideWrap(BOOL bHide) | CXTPControl |
SetIconId(int nId) | CXTPControl |
SetIconSize(CSize szIcon) | CXTPControl |
SetID(int nId) | CXTPControl |
SetIndex(int nIndex) | CXTPControl | inlineprotected
SetItemDefault(BOOL bDefault) | CXTPControl |
SetKeyboardTip(LPCTSTR lpszKeyboardTip) | CXTPControl |
SetOnQuickAccess(BOOL bOnQuicAccess=FALSE) | CXTPControl |
SetParameter(LPCTSTR lpszParameter) | CXTPControl |
SetParent(CXTPCommandBar *pParent) | CXTPControl | inlineprotectedvirtual
SetPressed(BOOL bPressed) | CXTPControl |
SetPrompt(LPCTSTR lpszPrompt) | CXTPControl |
SetRect(CRect rcControl) | CXTPControl | virtual
SetRowRect(CRect rcRow) | CXTPControl |
SetShortcutText(LPCTSTR lpszShortcutText) | CXTPControl |
SetStyle(XTPButtonStyle buttonStyle) | CXTPControl |
SetStyleEx(XTPButtonStyle buttonStyle) | CXTPControlButton |
SetTag(DWORD_PTR dwTag) | CXTPControl |
SetTooltip(LPCTSTR lpszTooltip) | CXTPControl |
SetVisible(BOOL bVisible) | CXTPControl |
SetWidth(int nWidth) | CXTPControl | virtual
SetWrap(BOOL bWrap) | CXTPControl |
~CXTPControl() | CXTPControl | protectedvirtual
~CXTPControlButton() | CXTPControlButton | virtual


Toolkit Pro: Member List

CXTPPropertyGridOffice2013Theme Member List

This is the complete list of members for CXTPPropertyGridOffice2013Theme, including all inherited members.

AdjustItemCaptionRect(CXTPPropertyGridItem *pItem, CRect &rcCaption) | CXTPPropertyGridPaintManager | virtual
AdjustItemValueRect(CXTPPropertyGridItem *pItem, CRect &rcValue) | CXTPPropertyGridPaintManager | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPPropertyGridOffice2013Theme(CXTPPropertyGrid *pGrid) | CXTPPropertyGridOffice2013Theme |
CXTPPropertyGridPaintManager(CXTPPropertyGrid *pGrid) | CXTPPropertyGridPaintManager |
DrawCategoryCaptionBackground(CDC *pDC, CXTPPropertyGridItem *pItem, CRect rc) | CXTPPropertyGridPaintManager | virtual
DrawCheckBox(CDC *pDC, CXTPPropertyGridItemBool *pButton) | CXTPPropertyGridPaintManager | virtual
DrawCheckMark(CDC *pDC, CRect rc, BOOL bEnabled, BOOL bChecked) | CXTPPropertyGridPaintManager | virtual
DrawExpandButton(CDC &dc, CXTPPropertyGridItem *pItem, CRect rcCaption) | CXTPPropertyGridOffice2013Theme | virtual
DrawInplaceButtons(CDC *pDC, PDRAWITEMSTRUCT lpDrawItemStruct, CXTPPropertyGridItem *pItem, CRect rcValue) | CXTPPropertyGridPaintManager | virtual
DrawInplaceListItem(CDC *pDC, CXTPPropertyGridItemConstraint *pConstraint, CRect rc, BOOL bSelected) | CXTPPropertyGridPaintManager | virtual
DrawItem(PDRAWITEMSTRUCT lpDrawItemStruct) | CXTPPropertyGridPaintManager | virtual
DrawItemCaption(CDC *pDC, CXTPPropertyGridItem *pItem, CRect rcCaption) | CXTPPropertyGridPaintManager | virtual
DrawItemValue(CDC *pDC, CXTPPropertyGridItem *pItem, CRect rcValue) | CXTPPropertyGridPaintManager | virtual
DrawPropertyGridBorder(CDC *pDC, RECT &rcBorder, XTPPropertyGridWindow nWindow) | CXTPPropertyGridPaintManager | virtual
DrawRadioMark(CDC *pDC, CRect rc, BOOL bEnabled, BOOL bChecked) | CXTPPropertyGridPaintManager | virtual
FillInplaceButton(CDC *pDC, CXTPPropertyGridInplaceButton *pButton) | CXTPPropertyGridPaintManager | virtual
FillPropertyGrid(CDC *pDC) | CXTPPropertyGridPaintManager | virtual
FillPropertyGridView(CDC *pDC) | CXTPPropertyGridPaintManager | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetItemBackColor(CXTPPropertyGridItem *pItem, BOOL bValuePart) | CXTPPropertyGridPaintManager | virtual
GetItemFont(CXTPPropertyGridItem *pItem, BOOL bValuePart) | CXTPPropertyGridPaintManager | virtual
GetItemMetrics() const | CXTPPropertyGridPaintManager |
GetItemsBorderHeight() const | CXTPPropertyGridPaintManager | virtual
GetItemTextColor(CXTPPropertyGridItem *pItem, BOOL bValuePart) | CXTPPropertyGridPaintManager | virtual
GetScrollBarTheme() const | CXTPPropertyGridOffice2013Theme | virtual
GetSplitterRect(CRect rc, BOOL bIsHelp) | CXTPPropertyGridPaintManager |
HitTestVerbs(CDC *pDC, CRect rcVerbs, CPoint pt) | CXTPPropertyGridPaintManager |
m_bThinSplitter | CXTPPropertyGridPaintManager | protected
m_bTransparent | CXTPPropertyGridPaintManager |
m_buttonsStyle | CXTPPropertyGridPaintManager |
m_clrCategorySeparator | CXTPPropertyGridPaintManager |
m_clrFace | CXTPPropertyGridPaintManager |
m_clrGlyphBorder | CXTPPropertyGridOffice2013Theme |
m_clrGlyphContract | CXTPPropertyGridOffice2013Theme |
m_clrGlyphExpand | CXTPPropertyGridOffice2013Theme |
m_clrHighlight | CXTPPropertyGridPaintManager |
m_clrHighlightText | CXTPPropertyGridPaintManager |
m_clrNonHighlightBack | CXTPPropertyGridPaintManager |
m_clrNonHighlightText | CXTPPropertyGridPaintManager |
m_clrShadow | CXTPPropertyGridPaintManager |
m_clrSplitter | CXTPPropertyGridPaintManager |
m_nHelpHeight | CXTPPropertyGridPaintManager | protected
m_nItemsBorderHeight | CXTPPropertyGridPaintManager | protected
m_nSplitterHeight | CXTPPropertyGridPaintManager | protected
m_nVerbsHeight | CXTPPropertyGridPaintManager | protected
m_pGrid | CXTPPropertyGridPaintManager | protected
m_pMetrics | CXTPPropertyGridPaintManager | protected
m_themeButton | CXTPPropertyGridPaintManager |
m_themeCombo | CXTPPropertyGridPaintManager |
m_themeTree | CXTPPropertyGridPaintManager |
MeasureItem(LPMEASUREITEMSTRUCT lpMeasureItemStruct) | CXTPPropertyGridPaintManager | virtual
OnNcCalcSize(RECT &rc) | CXTPPropertyGridPaintManager | virtual
RefreshMetrics() | CXTPPropertyGridOffice2013Theme | virtual
SetItemsBorderHeight(int nHeight) | CXTPPropertyGridPaintManager | virtual
SetThinSplitter(BOOL bThinSplitter) | CXTPPropertyGridPaintManager | virtual
~CXTPPropertyGridPaintManager() | CXTPPropertyGridPaintManager | virtual


Toolkit Pro: XTPStatusBarThemeOfficeXP.h Source File

  • Source
  • CommandBars
  • StatusBar
XTPStatusBarThemeOfficeXP.h
Go to the documentation of this file.
1
23#if !defined(__XTPSTATUSBARTHEMEOFFICEXP_H__)
24# define __XTPSTATUSBARTHEMEOFFICEXP_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPPaintManager;
34class CXTPStatusBarPane;
35
36class _XTP_EXT_CLASS CXTPStatusBarThemeOfficeXP : public CXTPStatusBarPaintManager
37{
38public:
39 CXTPStatusBarThemeOfficeXP(CXTPPaintManager* pPaintManager);
40
49 virtual void DrawStatusBarPaneBorder(CDC* pDC, CRect rc, CXTPStatusBarPane* pPane,
50 BOOL bGripperPane);
51
59 virtual void DrawStatusBarPaneSeparator(CDC* pDC, CRect rc, CXTPStatusBarPane* pPane);
60};
61
63# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
64#endif // !defined(__XTPSTATUSBARTHEMEOFFICEXP_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPPaintManager
Paint manager of the command bars.
Definition XTPPaintManager.h:199
CXTPStatusBarPane
CXTPStatusBarPane is a CXTPCmdTarget derived class.
Definition XTPStatusBarPane.h:39


Toolkit Pro: Member List

CXTPChart3dFunnelDiagramView Member List

This is the complete list of members for CXTPChart3dFunnelDiagramView, including all inherited members.

AddChildView(CXTPChartElementView *pChildView) | CXTPChartElementView |
CalculateView(CXTPChartDeviceContext *pDC, CRect rcBounds) | CXTPChartDiagramView | virtual
CreateDeviceCommand(CXTPChartDeviceContext *pDC) | CXTPChart3dDiagramView | virtual
CreateView(CXTPChartDeviceContext *pDC) | CXTPChartDiagramView | virtual
CXTPChart3dDiagramView(CXTPChartDiagram *pDiagram, CXTPChartElementView *pParentView) | CXTPChart3dDiagramView |
CXTPChart3dFunnelDiagramView(CXTPChartDiagram *pDiagram, CXTPChartElementView *pParent) | CXTPChart3dFunnelDiagramView |
CXTPChartDiagramView(CXTPChartDiagram *pDiagram, CXTPChartElementView *pParentView) | CXTPChartDiagramView |
CXTPChartElementView(CXTPChartElementView *pParentView) | CXTPChartElementView |
CXTPChartElementView(CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartElementView |
CXTPChartElementView(CXTPChartContainer *pContainer) | CXTPChartElementView |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
GetAt(int nIndex) const | CXTPChartElementView |
GetBounds() const | CXTPChartDiagramView |
CXTPChartElementView::GetBounds(BOOL bIncludingChildren) const | CXTPChartElementView |
GetChildren() | CXTPChartElementView |
GetCount() const | CXTPChartElementView |
GetDiagram() const | CXTPChartDiagramView |
GetLabelsView() const | CXTPChartDiagramView |
GetParentView() const | CXTPChartElementView |
GetSeriesView() const | CXTPChartDiagramView |
Is3D() const | CXTPChartObject |
m_arrChildren | CXTPChartElementView | protected
m_pContainer | CXTPChartElementView | protected
m_pDiagram | CXTPChartDiagramView | protected
m_pLabelsView | CXTPChartDiagramView | protected
m_pParentView | CXTPChartElementView | protected
m_pSeriesView | CXTPChartDiagramView | protected
m_pTitlesView | CXTPChartDiagramView | protected
m_rcBounds | CXTPChartDiagramView | protected
OnMouseWheel(UINT nFlags, short zDelta, CPoint pt) | CXTPChartDiagramView | virtual
UpdateRange(CXTPChartDeviceContext *pDC) | CXTPChartDiagramView | virtual
~CXTPChartElementView() | CXTPChartElementView | protectedvirtual


Toolkit Pro: Member List

CXTPHeaderCtrlThemeExplorer Member List

This is the complete list of members for CXTPHeaderCtrlThemeExplorer, including all inherited members.

CleanUp(CXTPHeaderCtrl *pHeaderCtrl) | CXTPHeaderCtrlTheme | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPControlTheme() | CXTPControlTheme |
CXTPHeaderCtrlTheme() | CXTPHeaderCtrlTheme |
CXTPHeaderCtrlThemeExplorer() | CXTPHeaderCtrlThemeExplorer |
CXTPHeaderCtrlThemeOffice2003() | CXTPHeaderCtrlThemeOffice2003 |
DrawHeader(CDC *pDC, CXTPHeaderCtrl *pHeaderCtrl) | CXTPHeaderCtrlTheme | virtual
DrawSortArrow(CDC *pDC, LPPOINT ptsArrow, BOOL bAscending) | CXTPHeaderCtrlThemeExplorer | protectedvirtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetDrawStyle() const | CXTPHeaderCtrlTheme | virtual
GetThemeStyle() const | CXTPControlTheme |
GetThemeWrapper() | CXTPHeaderCtrlTheme |
HasSortArrow() | CXTPHeaderCtrlTheme |
Layout(LPHDLAYOUT lpHDL, CXTPHeaderCtrl *pHeaderCtrl) | CXTPHeaderCtrlThemeExplorer | virtual
m_bUseWinThemes | CXTPHeaderCtrlTheme | protected
m_cr3DDkShadow | CXTPHeaderCtrlTheme | protected
m_cr3DFace | CXTPHeaderCtrlTheme | protected
m_cr3DHighLight | CXTPHeaderCtrlTheme | protected
m_cr3DShadow | CXTPHeaderCtrlTheme | protected
m_crText | CXTPHeaderCtrlTheme | protected
m_dwDrawStyle | CXTPHeaderCtrlTheme | protected
m_iArrowPadding | CXTPHeaderCtrlTheme | protected
m_nTheme | CXTPControlTheme | protected
m_sizeArrow | CXTPHeaderCtrlTheme | protected
m_sizePadding | CXTPHeaderCtrlTheme | protected
m_themeHeader | CXTPHeaderCtrlTheme | protected
OnDrawBackground(LPDRAWITEMSTRUCT lpDIS) | CXTPHeaderCtrlThemeExplorer | protectedvirtual
OnDrawBackgroundWinThemed(LPDRAWITEMSTRUCT lpDIS) | CXTPHeaderCtrlTheme | protectedvirtual
OnDrawItemBackground(LPDRAWITEMSTRUCT lpDIS) | CXTPHeaderCtrlThemeOffice2003 | protectedvirtual
OnDrawItemBackgroundWinThemed(LPDRAWITEMSTRUCT lpDIS) | CXTPHeaderCtrlThemeExplorer | protectedvirtual
OnDrawItemBitmap(LPDRAWITEMSTRUCT lpDIS, CRect &rcText, CXTPHeaderCtrl *pHeaderCtrl) | CXTPHeaderCtrlTheme | protectedvirtual
OnDrawItemSortArrow(LPDRAWITEMSTRUCT lpDIS, BOOL bAscending) | CXTPHeaderCtrlTheme | protectedvirtual
OnDrawItemText(LPDRAWITEMSTRUCT lpDIS, CXTPHeaderCtrl *pHeaderCtrl) | CXTPHeaderCtrlTheme | protectedvirtual
RefreshMetrics(CXTPHeaderCtrl *pHeader) | CXTPHeaderCtrlTheme | virtual
SetBitmap(int iCol, UINT uBitmapID, BOOL bRemove, COLORREF crMask, CXTPHeaderCtrl *pHeaderCtrl) | CXTPHeaderCtrlTheme | virtual
SetDrawStyle(DWORD dwDrawStyle, CXTPHeaderCtrl *pHeaderCtrl) | CXTPHeaderCtrlTheme | virtual
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static
UseWinXPThemes(CXTPHeaderCtrl *pHeaderCtrl) | CXTPHeaderCtrlTheme | virtual
~CXTPHeaderCtrlTheme() | CXTPHeaderCtrlTheme | virtual
~CXTPHeaderCtrlThemeExplorer() | CXTPHeaderCtrlThemeExplorer | virtual
~CXTPHeaderCtrlThemeOffice2003() | CXTPHeaderCtrlThemeOffice2003 | virtual


Toolkit Pro: Member List

CAppearanceSetPropertyPageAccess2007 Member List

This is the complete list of members for CAppearanceSetPropertyPageAccess2007, including all inherited members.

AdjustClientRect(CXTPTabManager *pTabManager, CRect &rcClient) | CXTPTabPaintManagerTheme | virtual
CAppearanceSetPropertyPage2007() | CAppearanceSetPropertyPage2007 | inline
CAppearanceSetPropertyPageAccess2007() | CAppearanceSetPropertyPageAccess2007 | inline
CXTPTabPaintManagerTheme() | CXTPTabPaintManagerTheme |
DrawSingleButton(CDC *pDC, CXTPTabManagerItem *pItem) | CAppearanceSetPropertyPageAccess2007 | protectedvirtual
DrawTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl) | CXTPTabPaintManagerTheme | virtual
DrawText(CDC *pDC, CXTPTabManager *pManager, const CString &str, LPRECT lpRect, UINT nFormat) | CXTPTabPaintManagerTheme | virtual
DrawWorkspacePart(CDC *pDC, LPRECT lpRect, XTPTabWorkspacePart workspacePart) | CXTPTabPaintManagerTheme | virtual
FillButton(CDC *pDC, CXTPTabManagerItem *pItem, LPPOINT pts, int nCount, XTPTabPosition tabPosition, BOOL bAbsolute=FALSE) | CXTPTabPaintManagerTheme |
FillTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl) | CAppearanceSetPropertyPageAccess2007 | protectedvirtual
GetButtonDrawRect(const CXTPTabManagerItem *pItem) | CAppearanceSetPropertyPageAccess2007 | protectedvirtual
GetButtonHeight(const CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetButtonLength(CDC *pDC, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerTheme | virtual
GetClientMargin() | CXTPTabPaintManagerTheme | virtual
GetClientRect(CRect rcControl, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetColorSet() const | CXTPTabPaintManagerTheme |
GetDefaultColorSet() | CAppearanceSetPropertyPageAccess2007 | inlineprotectedvirtual
GetHeaderClipBox(CDC *pDC, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetHeaderHeight(CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme |
GetHeaderMargin() | CAppearanceSetPropertyPageAccess2007 | inlineprotectedvirtual
GetHeaderRect(CRect rcControl, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetSupportedColorSets() | CXTPTabPaintManagerTheme | inlinevirtual
m_bButtonsReverseZOrder | CXTPTabPaintManagerTheme | protected
m_nButtonHeight | CXTPTabPaintManagerTheme | protected
m_nRowMargin | CXTPTabPaintManagerTheme |
m_pPaintManager | CXTPTabPaintManagerTheme | protected
m_rcHeaderMargin | CXTPTabPaintManagerTheme |
RefreshMetrics() | CAppearanceSetPropertyPageAccess2007 | protectedvirtual
RepositionTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcClient) | CXTPTabPaintManagerTheme | virtual
~CXTPTabPaintManagerTheme() | CXTPTabPaintManagerTheme | virtual


Toolkit Pro: XTPMessageBarThemeOffice2003.h Source File

  • Source
  • CommandBars
  • MessageBar
XTPMessageBarThemeOffice2003.h
Go to the documentation of this file.
1
23#if !defined(__XTPMESSAGEBARTHEMEOFFICE2003_H__)
24# define __XTPMESSAGEBARTHEMEOFFICE2003_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class _XTP_EXT_CLASS CXTPMessageBarThemeOffice2003 : public CXTPMessageBarPaintManager
34{
35public:
36 CXTPMessageBarThemeOffice2003(CXTPCommandBarsOffice2003Theme* pTheme);
37
44 virtual void FillMessageBar(CDC* pDC, CXTPMessageBar* pBar);
45
46protected:
47 CXTPCommandBarsOffice2003Theme* m_pTheme;
48};
49
51# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
52#endif // !defined(__XTPMESSAGEBARTHEMEOFFICE2003_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCommandBarsOffice2003Theme
The CXTPCommandBarsOffice2003Theme class is used to enable an Office 2003 style theme for Command Bar...
Definition XTPCommandBarsOffice2003Theme.h:41
CXTPMessageBar
CXTPMessageBar is a CControlBar derived class.
Definition XTPMessageBar.h:88
CXTPMessageBarPaintManager
The CXTPMessageBarPaintManager class is used by the message bar to perform standard paint routines.
Definition XTPMessageBarPaintManager.h:39
CXTPMessageBarPaintManager::FillMessageBar
virtual void FillMessageBar(CDC *pDC, CXTPMessageBar *pBar)
Draws the message bar.


Toolkit Pro: Member List

CXTPCalendarResourcesManager Member List

This is the complete list of members for CXTPCalendarResourcesManager, including all inherited members.

_Load(CXTPPropExchange *pPX) | CXTPCalendarResourcesManager | protected
_Save(CXTPPropExchange *pPX) | CXTPCalendarResourcesManager | protected
_SaveCloseDPifNeed(CXTPCalendarData *pData) | CXTPCalendarResourcesManager | protected
AddDataProvider(LPCTSTR pcszConnectionString, int eDPFlags=xtpCalendarDPF_CreateIfNotExists) | CXTPCalendarResourcesManager |
AddResource(LPCTSTR pcszName, BOOL bEnabled) | CXTPCalendarResourcesManager |
ApplyToCalendar(CXTPCalendarControl *pCalendar) | CXTPCalendarResourcesManager |
CXTPCalendarResourcesManager() | CXTPCalendarResourcesManager |
CXTPCmdTarget() | CXTPCmdTarget |
DoExchangeCfg(CXTPPropExchange *pPX) | CXTPCalendarResourcesManager |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetDataProvider(int nIndex) const | CXTPCalendarResourcesManager |
GetDataProvider(LPCTSTR pcszConnectionString, int *pnIndex=NULL) const | CXTPCalendarResourcesManager |
GetDataProvider_ConnStr(int nIndex) const | CXTPCalendarResourcesManager |
GetDataProvidersCount() const | CXTPCalendarResourcesManager |
GetResource(int nIndex) const | CXTPCalendarResourcesManager |
GetResourcesCount() const | CXTPCalendarResourcesManager |
LoadCfg(LPCTSTR pcszFile) | CXTPCalendarResourcesManager |
m_arDataProviders | CXTPCalendarResourcesManager | protected
m_arResources | CXTPCalendarResourcesManager | protected
MoveResource(int nIndex, int nNewIndex) | CXTPCalendarResourcesManager |
RemoveAll() | CXTPCalendarResourcesManager |
RemoveDataProvider(int nIndex) | CXTPCalendarResourcesManager |
RemoveResource(int nIndex) | CXTPCalendarResourcesManager |
SaveCfg(LPCTSTR pcszFile) | CXTPCalendarResourcesManager |
SetDataProvider(int nIndex, LPCTSTR pcszConnectionString, int eDPFlags=xtpCalendarDPF_CreateIfNotExists) | CXTPCalendarResourcesManager |
xtpCalendarDPF_CloseOnDestroy enum value | CXTPCalendarResourcesManager |
xtpCalendarDPF_CreateIfNotExists enum value | CXTPCalendarResourcesManager |
xtpCalendarDPF_SaveOnDestroy enum value | CXTPCalendarResourcesManager |
xtpCalendarDPFUnknown enum value | CXTPCalendarResourcesManager |
XTPEnumCalendarDataProviderFlags enum name | CXTPCalendarResourcesManager |
~CXTPCalendarResourcesManager() | CXTPCalendarResourcesManager | virtual


Toolkit Pro: Member List

CXTPChart3dTranslateDeviceCommand Member List

This is the complete list of members for CXTPChart3dTranslateDeviceCommand, including all inherited members.

AddChildCommand(CXTPChartDeviceCommand *pCommand) | CXTPChartDeviceCommand |
AfterExecute(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
ApplySeriesStyle(CXTPChartSeriesStyle *pStyle) | CXTPChartDeviceCommand | virtual
BeforeExecute(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
BindView(CXTPChartElementView *pView) | CXTPChartDeviceCommand |
Commit() | CXTPChartDeviceCommand |
CXTPChart3dDeviceCommand(XTPChart3dAntialiasingPolicy nAntialiasingPolicy) | CXTPChart3dDeviceCommand | protected
CXTPChart3dTranslateDeviceCommand(double dx, double dy, double dz) | CXTPChart3dTranslateDeviceCommand |
CXTPChartDeviceCommand() | CXTPChartDeviceCommand |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPObservable() | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | protected
Execute(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
ExecuteOverride(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
GetBoundView() const | CXTPChartDeviceCommand |
GetChildCommand(int nIndex) const | CXTPChartDeviceCommand |
GetChildCommandCount() const | CXTPChartDeviceCommand |
GetCurrentDC() const | CXTPChartDeviceCommand |
GetPassNumber() const | CXTPChartDeviceCommand |
HitTest(CPoint point, CXTPChartElement *pParent) const | CXTPChartDeviceCommand | virtual
Is3D() const | CXTPChartObject |
IsCommitted() const | CXTPChartDeviceCommand |
IsEnabled() const | CXTPChart3dDeviceCommand | virtual
m_arrChildren | CXTPChartDeviceCommand | protected
m_dx | CXTPChart3dTranslateDeviceCommand | protected
m_dy | CXTPChart3dTranslateDeviceCommand | protected
m_dz | CXTPChart3dTranslateDeviceCommand | protected
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Prepare(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
PrepareOverride(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
SetEnabled(BOOL bEnabled=TRUE) | CXTPChartDeviceCommand |
Subscribe(CXTPChartDeviceCommandEvents *pObserver, CXTPSubscriptionList< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > *pSubcriptionList=NULL) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > |
Unsubscribe(CXTPChartDeviceCommandEvents *pObserver) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > |
~CXTPChartDeviceCommand() | CXTPChartDeviceCommand | virtual
~CXTPObservable() | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | protected


Toolkit Pro: Member List

CXTPChartDiagram2DView Member List

This is the complete list of members for CXTPChartDiagram2DView, including all inherited members.

AddAxisView(CXTPChartDeviceContext *pDC, CXTPChartElementView *pParentView, CXTPChartAxis *pAxis) | CXTPChartDiagram2DView |
AddChildView(CXTPChartElementView *pChildView) | CXTPChartElementView |
CalculateView(CXTPChartDeviceContext *pDC, CRect rcBounds) | CXTPChartDiagram2DView | virtual
CreateDeviceCommand(CXTPChartDeviceContext *pDC) | CXTPChartDiagram2DView | virtual
CreateView(CXTPChartDeviceContext *pDC) | CXTPChartDiagram2DView | virtual
CXTPChartDiagram2DView(CXTPChartDiagram *pDiagram, CXTPChartElementView *pParent) | CXTPChartDiagram2DView |
CXTPChartDiagramView(CXTPChartDiagram *pDiagram, CXTPChartElementView *pParentView) | CXTPChartDiagramView |
CXTPChartElementView(CXTPChartElementView *pParentView) | CXTPChartElementView |
CXTPChartElementView(CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartElementView |
CXTPChartElementView(CXTPChartContainer *pContainer) | CXTPChartElementView |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
GetAt(int nIndex) const | CXTPChartElementView |
GetAxisView(CXTPChartAxis *pAxis) const | CXTPChartDiagram2DView |
GetBounds() const | CXTPChartDiagramView |
CXTPChartElementView::GetBounds(BOOL bIncludingChildren) const | CXTPChartElementView |
GetChildren() | CXTPChartElementView |
GetCount() const | CXTPChartElementView |
GetDiagram() const | CXTPChartDiagramView |
GetLabelsView() const | CXTPChartDiagramView |
GetPaneView() const | CXTPChartDiagram2DView |
GetParentView() const | CXTPChartElementView |
GetSeriesView() const | CXTPChartDiagramView |
Is3D() const | CXTPChartObject |
m_arrChildren | CXTPChartElementView | protected
m_pAxisViews | CXTPChartDiagram2DView |
m_pContainer | CXTPChartElementView | protected
m_pDiagram | CXTPChartDiagramView | protected
m_pLabelsView | CXTPChartDiagramView | protected
m_pPaneView | CXTPChartDiagram2DView |
m_pParentView | CXTPChartElementView | protected
m_pSeriesView | CXTPChartDiagramView | protected
m_pTitlesView | CXTPChartDiagramView | protected
m_rcBounds | CXTPChartDiagramView | protected
OnMouseWheel(UINT nFlags, short zDelta, CPoint pt) | CXTPChartDiagram2DView | virtual
UpdateRange(CXTPChartDeviceContext *pDC) | CXTPChartDiagram2DView | virtual
~CXTPChartElementView() | CXTPChartElementView | protectedvirtual


Toolkit Pro: Member List

CXTPChartPyramidSeriesLabelViewBase Member List

This is the complete list of members for CXTPChartPyramidSeriesLabelViewBase, including all inherited members.

AddChildView(CXTPChartElementView *pChildView) | CXTPChartElementView |
CreateDeviceCommand(CXTPChartDeviceContext *pDC)=0 | CXTPChartPyramidSeriesLabelViewBase | pure virtual
CXTPChartElementView(CXTPChartElementView *pParentView) | CXTPChartElementView |
CXTPChartElementView(CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartElementView |
CXTPChartElementView(CXTPChartContainer *pContainer) | CXTPChartElementView |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartPyramidSeriesLabelViewBase(CXTPChartSeriesLabel *pLabel, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView) | CXTPChartPyramidSeriesLabelViewBase | protected
GetAt(int nIndex) const | CXTPChartElementView |
GetBounds() const | CXTPChartElementView |
GetBounds(BOOL bIncludingChildren) const | CXTPChartElementView |
GetChildren() | CXTPChartElementView |
GetCount() const | CXTPChartElementView |
GetParentView() const | CXTPChartElementView |
GetPosition() const | CXTPChartPyramidSeriesLabelViewBase |
Is3D() const | CXTPChartObject |
m_arrChildren | CXTPChartElementView | protected
m_pContainer | CXTPChartElementView | protected
m_pParentView | CXTPChartElementView | protected
m_rcBounds | CXTPChartElementView | protected
~CXTPChartElementView() | CXTPChartElementView | protectedvirtual


Toolkit Pro: XTPMarkupControl.h Source File

  • Source
  • Markup
  • Controls
XTPMarkupControl.h
Go to the documentation of this file.
1
23#if !defined(__XTPMARKUPCONTROL_H__)
24# define __XTPMARKUPCONTROL_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPMarkupThickness;
34class CXTPMarkupBrush;
35class CXTPMarkupDrawingContext;
36class CXTPMarkupDependencyProperty;
37
43class _XTP_EXT_CLASS CXTPMarkupControl : public CXTPMarkupFrameworkElement
44{
46 DECLARE_MARKUPCLASS(CXTPMarkupControl);
48public:
59 void SetPadding(int nLeft, int nTop, int nRight, int nBottom);
60
68 void SetPadding(int nPadding);
69
82 CXTPMarkupThickness* GetPadding() const;
83
89 void SetBackground(CXTPMarkupBrush* pBrush);
90
97 CXTPMarkupBrush* GetBackground() const;
98
104 void SetForeground(CXTPMarkupBrush* pBrush);
105
112 CXTPMarkupBrush* GetForeground() const;
113
114protected:
116 // Implementation
117 CSize ArrangeOverride(CSize szFinalSize);
118 CSize MeasureOverride(CXTPMarkupDrawingContext* pDC, CSize szAvailableSize);
119
120public:
121 static CXTPMarkupDependencyProperty* m_pPaddingProperty;
122 static CXTPMarkupDependencyProperty* m_pBackgroundProperty;
123 static CXTPMarkupDependencyProperty* m_pForegroundProperty;
127public:
128 DECLARE_DISPATCH_MAP()
129# ifdef _XTP_ACTIVEX
130 DECLARE_INTERFACE_MAP()
131 DECLARE_OLETYPELIB_EX(CXTPMarkupControl);
132# endif
133
134 afx_msg LPDISPATCH OleGetBackground();
135 afx_msg void OleSetBackground(LPDISPATCH lpBackground);
136 afx_msg LPDISPATCH OleGetForeground();
137 afx_msg void OleSetForeground(LPDISPATCH lpBackground);
138 afx_msg LPDISPATCH OleGetPadding();
139 afx_msg void OleSetPadding(LPDISPATCH lpThickness);
140
142};
143
144# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
146#endif // !defined(__XTPMARKUPCONTROL_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPMarkupControl
CXTPMarkupControl is a CXTPMarkupFrameworkElement derived class.
Definition XTPMarkupControl.h:44
CXTPMarkupControl::SetPadding
void SetPadding(int nLeft, int nTop, int nRight, int nBottom)
Sets a value that indicates the thickness of the padding space between the boundaries of the content ...
CXTPMarkupControl::GetBackground
CXTPMarkupBrush * GetBackground() const
Gets the background brush of the control object.
CXTPMarkupControl::GetPadding
CXTPMarkupThickness * GetPadding() const
Retrieves a value that indicates the thickness of the padding space between the boundaries of the con...
CXTPMarkupControl::GetForeground
CXTPMarkupBrush * GetForeground() const
Gets the default text brush of the control object.
CXTPMarkupControl::SetPadding
void SetPadding(int nPadding)
Sets a value that indicates the thickness of the padding space between the boundaries of the content ...
CXTPMarkupControl::SetBackground
void SetBackground(CXTPMarkupBrush *pBrush)
Sets the background brush for the control object.
CXTPMarkupControl::SetForeground
void SetForeground(CXTPMarkupBrush *pBrush)
Sets the default text brush for the control object.
CXTPMarkupFrameworkElement
This class represents the provided framework-level implementation built on CXTPMarkupUIElement.
Definition XTPMarkupFrameworkElement.h:44
CXTPMarkupThickness
The CXTPMarkupThickness class describes the thickness of the left, top, right, and bottom sides of a ...
Definition XTPMarkupThickness.h:42


Toolkit Pro: XTPGridDefines.h Source File

  • Source
  • GridControl
XTPGridDefines.h
Go to the documentation of this file.
1
23#if !defined(__XTPGRIDDEFINES_H__)
24# define __XTPGRIDDEFINES_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33# ifdef _XTP_ACTIVEX
34enum XTPEnumGridCustomDraw
35{
36 xtpCustomDrawItem = 0x01,
37 xtpCustomMeasureRow = 0x02,
38 xtpCustomBeforeDrawRow = 0x04,
39 xtpCustomDrawPreviewItem = 0x08,
40 xtpCustomMeasurePreviewItem = 0x10,
41};
42# endif
43
48enum XTPGridShellIcon
49{
50 xtpGridShellIconLock = 47
51};
52
57enum XTPGridGlyph
58{
59 xtpGridGlyphInvalid = -1,
60 xtpGridGlyphRowCollapse = 0,
61 xtpGridGlyphRowExpand = 1,
62 xtpGridGlyphEnabledUnchecked = 2,
63 xtpGridGlyphEnabledChecked = 3,
64 xtpGridGlyphDisabledUnchecked = 4,
65 xtpGridGlyphDisabledChecked = 5,
66 xtpGridGlyphColumnExpand = 6,
67 xtpGridGlyphColumnRestore = 7,
68 xtpGridGlyphEnabledTristate = 8,
69 xtpGridGlyphItemLocked = 9,
70 xtpGridGlyphItemUnlocked = 10,
71 xtpGridGlyphCount
72};
73
78enum XTPGridCheckState
79{
80 xtpGridCheckStateInvalid = -1,
81 xtpGridCheckStateUnchecked = 0,
82 xtpGridCheckStateChecked = 1,
83 xtpGridCheckStateIndeterminate = 2,
84 xtpGridCheckStateCount = 3
85};
86
93enum XTPGridRowType
94{
95 xtpRowTypeInvalid = -1,
96 xtpRowTypeBody = 0,
97 xtpRowTypeHeader = 1,
98 xtpRowTypeFooter = 2
99};
100
107enum XTPGridOrientation
108{
109 xtpGridOrientationHorizontal = 0,
110 xtpGridOrientationVertical = 1,
111 xtpGridOrientationAll = 2
112};
113
125enum XTPGridLineStyle
126{
127 xtpGridLineStyleNone = 0,
128 xtpGridLineStyleDotSmall = 1,
129 xtpGridLineStyleDotLarge = 2,
130 xtpGridLineStyleDash = 3,
131 xtpGridLineStyleSolid = 4,
132 xtpGridLineStyleCount = 5,
134 // Old names
135
136 xtpGridGridNoLines = xtpGridLineStyleNone,
137 xtpGridGridSmallDots = xtpGridLineStyleDotSmall,
139 xtpGridGridLargeDots = xtpGridLineStyleDotLarge,
141 xtpGridGridDashes = xtpGridLineStyleDash,
142 xtpGridGridSolid = xtpGridLineStyleSolid
143};
144
145typedef XTPGridLineStyle XTPGridGridStyle;
146
151enum XTPGridFreezeColsDividerStyle
152{
153 xtpGridFreezeColsDividerThin = 0x01,
154 xtpGridFreezeColsDividerBold = 0x02,
155 xtpGridFreezeColsDividerHeader = 0x04,
156 xtpGridFreezeColsDividerShade = 0x08,
157 xtpGridFreezeColsDividerShowAlways = 0x10,
158};
159
162// deprecated
163
164# define xtpGridNoLines xtpGridGridNoLines
165# define xtpGridSmallDots xtpGridGridSmallDots
166# define xtpGridLargeDots xtpGridGridLargeDots
167# define xtpGridDashes xtpGridGridDashes
168# define xtpGridSolid xtpGridGridSolid
169
182enum XTPGridColumnStyle
183{
184 xtpGridColumnShaded,
185 xtpGridColumnFlat,
186 xtpGridColumnExplorer,
187 xtpGridColumnOffice2003,
188 xtpGridColumnResource
189};
190
193// deprecated
194
195# define xtpColumnShaded xtpGridColumnShaded
196# define xtpColumnFlat xtpGridColumnFlat
197# define xtpGridColumnOffice2007 xtpGridColumnResource
198
212enum XTPGridTreeStructureStyle
213{
214 xtpGridTreeStructureNone,
216 xtpGridTreeStructureSolid,
218 xtpGridTreeStructureDots
220};
221
226enum XTPGridSectionDividerStyle
227{
228 xtpGridSectionDividerStyleNone = 0x00,
229 xtpGridSectionDividerStyleThin = 0x01,
230 xtpGridSectionDividerStyleBold = 0x02,
231 xtpGridSectionDividerStyleShade = 0x04,
232 xtpGridSectionDividerStyleOutlook = 0x08,
236 // Deprecated
237
238 xtpGridFixedRowsDividerNone = xtpGridSectionDividerStyleNone,
239 xtpGridFixedRowsDividerThin = xtpGridSectionDividerStyleThin,
240 xtpGridFixedRowsDividerBold = xtpGridSectionDividerStyleBold,
241 xtpGridFixedRowsDividerShade = xtpGridSectionDividerStyleShade,
242 xtpGridFixedRowsDividerOutlook = xtpGridSectionDividerStyleOutlook
244};
245
248// Old enum name
249
250typedef XTPGridSectionDividerStyle XTPGridFixedRowsDividerStyle;
257enum XTPGridSectionDividerPosition
258{
259 xtpGridSectionDividerPositionTop = 0,
260 xtpGridSectionDividerPositionBottom = 1
261};
262
267enum XTPGridDrawSortTriangleStyle
268{
269 xtpGridDrawSortTriangleDefault = 0,
271 xtpGridDrawSortTriangleAlways = 1,
274 xtpGridDrawSortTriangleNever = 2
275};
276
283enum XTPGridTextDecoration
284{
285 xtpGridTextDecorationNone = 0,
286 xtpGridTextDecorationUnderline = 1
287};
288
298enum XTPGridPaintTheme
299{
300 xtpGridThemeDefault,
301 xtpGridThemeOfficeXP,
302 xtpGridThemeOffice2003,
303 xtpGridThemeOffice2003Luna,
304 xtpGridThemeOffice2013,
305 xtpGridThemeOffice2016 = xtpGridThemeOffice2013,
306 xtpGridThemeVisualStudio2012Light,
307 xtpGridThemeVisualStudio2012Dark,
308 xtpGridThemeVisualStudio2012Blue,
309 xtpGridThemeVisualStudio2015,
310 xtpGridThemeExplorer,
311 xtpGridThemeResource,
312 xtpGridThemeNativeWindows10,
313 xtpGridThemeVisualStudio2017,
314 xtpGridThemeVisualStudio2019,
315 xtpGridThemeVisualStudio2022,
316 xtpGridThemeNativeWindows11,
317};
318
359const TCHAR XTPGRIDCTRL_CLASSNAME[] = _T("XTPGrid");
360const TCHAR XTPTRACKCTRL_CLASSNAME[] = _T("XTPTrackControl");
361
366static const LPCTSTR XTPGRIDCTRL_CF_RECORDS = _T("XTPGrid_CF_Records");
367
395const COLORREF XTP_GRID_COLOR_DEFAULT = (COLORREF)-1;
396
409const int XTP_GRID_NOICON = (int)-1;
410
444# define XTP_NM_GRID_HEADER_RCLICK (NM_FIRST - 51)
445
475# define XTP_NM_GRID_SELCHANGED (NM_FIRST - 52)
476
509# define XTP_NM_GRID_CHECKED (NM_FIRST - 53)
510
552# define XTP_NM_GRID_HYPERLINK (NM_FIRST - 54)
553
587# define XTP_NM_GRID_COLUMNORDERCHANGED (NM_FIRST - 55)
588
622# define XTP_NM_GRID_SORTORDERCHANGED (NM_FIRST - 56)
623
646# define XTP_NM_GRID_PRESORTORDERCHANGED (NM_FIRST - 67)
647
722# define XTP_NM_GRID_VALUECHANGED (NM_FIRST - 57)
723
758# define XTP_NM_GRID_INPLACEBUTTONDOWN (NM_FIRST - 58)
759
790# define XTP_NM_GRID_ROWEXPANDED (NM_FIRST - 59)
791
822# define XTP_NM_GRID_LBUTTONDOWN (NM_FIRST - 60)
823# define XTP_NM_GRID_LBUTTONUP (NM_FIRST - 89)
824
864# define XTP_NM_GRID_GETITEMMETRICS (NM_FIRST - 61)
865
879# define XTP_NM_GRID_REQUESTEDIT (NM_FIRST - 62)
880
920# define XTP_NM_GRID_BEFORE_COPY_TOTEXT (NM_FIRST - 63)
921
988# define XTP_NM_GRID_BEFORE_PASTE_FROMTEXT (NM_FIRST - 64)
989
1027# define XTP_NM_GRID_BEFORE_PASTE (NM_FIRST - 65)
1028
1030// Internal Trace operation
1031# define XTP_TRACE
1034# ifdef _XTP_ACTIVEX
1036# define XTP_NM_GRID_VALUECHANGING (NM_FIRST - 66)
1038# endif
1039
1052# define XTP_NM_GRID_COLUMNWIDTHCHANGED (NM_FIRST - 68)
1053
1066# define XTP_NM_GRID_PREVIEWKEYDOWN (NM_FIRST - 69)
1067
1079# define XTP_NM_GRID_BEGINDRAG (NM_FIRST - 70)
1080
1092# define XTP_NM_GRID_DROP (NM_FIRST - 71)
1093# define XTP_NM_GRID_HASVALIDDROPTYPE (NM_FIRST - 85)
1094# define XTP_NM_GRID_VALIDDROPTARGET (NM_FIRST - 86)
1095
1108# define XTP_NM_GRID_EDIT_CANCELED (NM_FIRST - 72)
1109
1118# define XTP_NM_GRID_CONSTRAINT_SELECTING (NM_FIRST - 73)
1119
1128# define XTP_NM_GRID_GETTOOLTIPINFO (NM_FIRST - 74)
1129
1141# define XTP_NM_GRID_RECORDS_DROPPED (NM_FIRST - 75)
1142
1173# define XTP_NM_GRID_FOCUS_CHANGING (NM_FIRST - 76)
1174
1186# define XTP_NM_GRID_DRAGDROP_COMPLETED (NM_FIRST - 77)
1187
1202# define XTP_NM_GRID_BEGINEDIT (NM_FIRST - 78)
1203
1204# ifdef _XTP_ACTIVEX
1206# define XTP_NM_GRID_EDIT_CHANGING (NM_FIRST - 79)
1208# endif
1209
1221# define XTP_NM_GRID_SELCHANGING (NM_FIRST - 80)
1222
1234# define XTP_NM_GRID_DRAGOVER (NM_FIRST - 81)
1235
1268# define XTP_NM_GRID_GROUPORDERCHANGED (NM_FIRST - 82)
1269
1302# define XTP_NM_GRID_ITEMBUTTONCLICK (NM_FIRST - 83)
1303
1336# define XTP_NM_GRID_PLUSMINUSCLICK (NM_FIRST - 84)
1337
1367# define XTP_NM_GRID_STATECHANGED (NM_FIRST - 88)
1368
1374# define XTP_NM_GRID_HSCROLL (NM_FIRST - 90)
1375
1381# define XTP_NM_GRID_VSCROLL (NM_FIRST - 91)
1382
1388# define XTP_NM_GRID_MOUSEMOVE (NM_FIRST - 92)
1389
1390# define XTP_NM_GRID_GIVEFEEDBACK (NM_FIRST - 93)
1391
1398# define XTP_NM_GRID_ROWHEIGHTCHANGED (NM_FIRST - 94)
1399
1401# define XTP_NM_GRID_ROWHEIHGTCHANGED XTP_NM_GRID_ROWHEIGHTCHANGED
1408# define XTP_GRID_DEPRECATED() (1)
1409
1410class CXTPGridRow;
1411
1420typedef int(AFX_CDECL* XTPGridRowsCompareFunc)(const CXTPGridRow** pRow1,
1421 const CXTPGridRow** pRow2);
1422
1423# define XTP_DECLARE_PROPERTY(property, type) \
1424 afx_msg type OleGet##property(); \
1425 afx_msg void OleSet##property(type);
1426
1427# define XTP_DISP_PROPERTY_EX_ID(theClass, szExternalName, dispid, vtPropType) \
1428 DISP_PROPERTY_EX_ID(theClass, #szExternalName, dispid, OleGet##szExternalName, \
1429 OleSet##szExternalName, vtPropType)
1430
1431# define XTP_IMPLEMENT_PROPERTY(theClass, theProperty, theMember, theType) \
1432 theType theClass::OleGet##theProperty() \
1433 { \
1434 return theMember; \
1435 } \
1436 void theClass::OleSet##theProperty(theType set) \
1437 { \
1438 theMember = set; \
1439 }
1440
1441# define XTP_IMPLEMENT_PROPERTY_COLOR(theClass, theProperty, theMember) \
1442 COLORREF theClass::OleGet##theProperty() \
1443 { \
1444 return theMember; \
1445 } \
1446 void theClass::OleSet##theProperty(COLORREF oleColor) \
1447 { \
1448 theMember = AxTranslateColor(oleColor); \
1449 }
1451# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
1452#endif //#if !defined(__XTPGRIDDEFINES_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPGridShellIcon
XTPGridShellIcon
This enum defines the shell icons.
Definition XTPGridDefines.h:49
xtpGridShellIconLock
@ xtpGridShellIconLock
Specifies a Lock icon.
Definition XTPGridDefines.h:50
XTPGridTextDecoration
XTPGridTextDecoration
Enumeration of hyperlink text decorations.
Definition XTPGridDefines.h:284
xtpGridTextDecorationUnderline
@ xtpGridTextDecorationUnderline
Text is underlined.
Definition XTPGridDefines.h:286
xtpGridTextDecorationNone
@ xtpGridTextDecorationNone
Text has no decoration.
Definition XTPGridDefines.h:285
XTPGridTreeStructureStyle
XTPGridTreeStructureStyle
Represent the style of lines used to draw a hierarchical tree structure.
Definition XTPGridDefines.h:213
xtpGridTreeStructureDots
@ xtpGridTreeStructureDots
Dots will be drawn from the parent node to each child node at the next level.
Definition XTPGridDefines.h:218
xtpGridTreeStructureSolid
@ xtpGridTreeStructureSolid
Lines will be drawn from the parent node to each child node at the next level.
Definition XTPGridDefines.h:216
xtpGridTreeStructureNone
@ xtpGridTreeStructureNone
No lines will be drawn from the parent node to each child node.
Definition XTPGridDefines.h:214
XTPGRIDCTRL_CLASSNAME
const TCHAR XTPGRIDCTRL_CLASSNAME[]
A NULL-terminated string used by CXTPGridControl which specifies the window class name for the Grid c...
Definition XTPGridDefines.h:359
XTP_GRID_NOICON
const int XTP_GRID_NOICON
This constant indicates that an icon ID is not defined.
Definition XTPGridDefines.h:409
XTPGridLineStyle
XTPGridLineStyle
Represents predefined grid line styles.
Definition XTPGridDefines.h:126
xtpGridLineStyleDotLarge
@ xtpGridLineStyleDotLarge
Line is drawn with large dots.
Definition XTPGridDefines.h:129
xtpGridLineStyleDash
@ xtpGridLineStyleDash
Line is drawn with dashes.
Definition XTPGridDefines.h:130
xtpGridGridLargeDots
@ xtpGridGridLargeDots
Deprecated.
Definition XTPGridDefines.h:139
xtpGridLineStyleCount
@ xtpGridLineStyleCount
Number of line styles.
Definition XTPGridDefines.h:132
xtpGridLineStyleDotSmall
@ xtpGridLineStyleDotSmall
Line is drawn with small dots.
Definition XTPGridDefines.h:128
xtpGridLineStyleNone
@ xtpGridLineStyleNone
No line.
Definition XTPGridDefines.h:127
xtpGridGridSolid
@ xtpGridGridSolid
Deprecated.
Definition XTPGridDefines.h:142
xtpGridGridSmallDots
@ xtpGridGridSmallDots
Deprecated.
Definition XTPGridDefines.h:137
xtpGridLineStyleSolid
@ xtpGridLineStyleSolid
Solid line.
Definition XTPGridDefines.h:131
xtpGridGridDashes
@ xtpGridGridDashes
Deprecated.
Definition XTPGridDefines.h:141
xtpGridGridNoLines
@ xtpGridGridNoLines
Deprecated.
Definition XTPGridDefines.h:136
XTPGridDrawSortTriangleStyle
XTPGridDrawSortTriangleStyle
Represent the Grid Draw Sort Triangle logic.
Definition XTPGridDefines.h:268
xtpGridDrawSortTriangleDefault
@ xtpGridDrawSortTriangleDefault
The triangle will be removed when the column size is too small to display the full caption and triang...
Definition XTPGridDefines.h:269
xtpGridDrawSortTriangleNever
@ xtpGridDrawSortTriangleNever
Never draw the triangle.
Definition XTPGridDefines.h:274
xtpGridDrawSortTriangleAlways
@ xtpGridDrawSortTriangleAlways
The sort triangle displayed in column header when a column is sorted and the caption will be cut with...
Definition XTPGridDefines.h:271
XTPGridRowsCompareFunc
int(AFX_CDECL * XTPGridRowsCompareFunc)(const CXTPGridRow **pRow1, const CXTPGridRow **pRow2)
Defines a function pointer for comparing events.
Definition XTPGridDefines.h:1420
XTPGridColumnStyle
XTPGridColumnStyle
Represents predefined column styles.
Definition XTPGridDefines.h:183
xtpGridColumnShaded
@ xtpGridColumnShaded
Columns are gray shaded.
Definition XTPGridDefines.h:184
xtpGridColumnOffice2003
@ xtpGridColumnOffice2003
Gradient column style.
Definition XTPGridDefines.h:187
xtpGridColumnExplorer
@ xtpGridColumnExplorer
Explorer column style.
Definition XTPGridDefines.h:186
xtpGridColumnResource
@ xtpGridColumnResource
Office 2007/2010 column style.
Definition XTPGridDefines.h:188
xtpGridColumnFlat
@ xtpGridColumnFlat
Flat style for drawing columns.
Definition XTPGridDefines.h:185
XTPGridOrientation
XTPGridOrientation
Enumeration of orientations.
Definition XTPGridDefines.h:108
xtpGridOrientationHorizontal
@ xtpGridOrientationHorizontal
Specifies horizontal grid orientation.
Definition XTPGridDefines.h:109
xtpGridOrientationAll
@ xtpGridOrientationAll
Specifies both horizontal and vertical grid orientations.
Definition XTPGridDefines.h:111
xtpGridOrientationVertical
@ xtpGridOrientationVertical
Specifies vertical grid orientation.
Definition XTPGridDefines.h:110
XTP_GRID_COLOR_DEFAULT
const COLORREF XTP_GRID_COLOR_DEFAULT
This constant indicates that a COLORREF is not defined.
Definition XTPGridDefines.h:395
XTPGRIDCTRL_CF_RECORDS
static const LPCTSTR XTPGRIDCTRL_CF_RECORDS
Grid control records clipboard format name.
Definition XTPGridDefines.h:366
XTPGridRowType
XTPGridRowType
This enum defines body, header, and footer rows.
Definition XTPGridDefines.h:94
xtpRowTypeBody
@ xtpRowTypeBody
The row is in the body rows collection.
Definition XTPGridDefines.h:96
xtpRowTypeInvalid
@ xtpRowTypeInvalid
Indicates an invalid row type.
Definition XTPGridDefines.h:95
xtpRowTypeFooter
@ xtpRowTypeFooter
The row is in the footer rows collection.
Definition XTPGridDefines.h:98
xtpRowTypeHeader
@ xtpRowTypeHeader
The row is in the header rows collection.
Definition XTPGridDefines.h:97
XTPGridSectionDividerPosition
XTPGridSectionDividerPosition
Section divider position.
Definition XTPGridDefines.h:258
xtpGridSectionDividerPositionTop
@ xtpGridSectionDividerPositionTop
Divider above the section.
Definition XTPGridDefines.h:259
xtpGridSectionDividerPositionBottom
@ xtpGridSectionDividerPositionBottom
Divider below the section.
Definition XTPGridDefines.h:260
XTPGridPaintTheme
XTPGridPaintTheme
Visual theme enumeration.
Definition XTPGridDefines.h:299
xtpGridThemeVisualStudio2017
@ xtpGridThemeVisualStudio2017
Visual Studio 2017 style theme.
Definition XTPGridDefines.h:313
xtpGridThemeOffice2013
@ xtpGridThemeOffice2013
Office 2013 style theme.
Definition XTPGridDefines.h:304
xtpGridThemeVisualStudio2012Blue
@ xtpGridThemeVisualStudio2012Blue
Visual Studio 2012 Blue style theme.
Definition XTPGridDefines.h:308
xtpGridThemeExplorer
@ xtpGridThemeExplorer
Windows Explorer theme.
Definition XTPGridDefines.h:310
xtpGridThemeResource
@ xtpGridThemeResource
Resource .DLL style theme.
Definition XTPGridDefines.h:311
xtpGridThemeOfficeXP
@ xtpGridThemeOfficeXP
Office XP style theme.
Definition XTPGridDefines.h:301
xtpGridThemeVisualStudio2022
@ xtpGridThemeVisualStudio2022
Visual Studio 2022 style theme.
Definition XTPGridDefines.h:315
xtpGridThemeOffice2016
@ xtpGridThemeOffice2016
Office 2016 style theme.
Definition XTPGridDefines.h:305
xtpGridThemeNativeWindows10
@ xtpGridThemeNativeWindows10
Windows 10 style theme.
Definition XTPGridDefines.h:312
xtpGridThemeVisualStudio2019
@ xtpGridThemeVisualStudio2019
Visual Studio 2019 style theme.
Definition XTPGridDefines.h:314
xtpGridThemeVisualStudio2015
@ xtpGridThemeVisualStudio2015
Visual Studio 2015 style theme.
Definition XTPGridDefines.h:309
xtpGridThemeOffice2003
@ xtpGridThemeOffice2003
Office 2003 style theme.
Definition XTPGridDefines.h:302
xtpGridThemeVisualStudio2012Light
@ xtpGridThemeVisualStudio2012Light
Visual Studio 2012 Light style theme.
Definition XTPGridDefines.h:306
xtpGridThemeNativeWindows11
@ xtpGridThemeNativeWindows11
Windows 11 style theme.
Definition XTPGridDefines.h:316
xtpGridThemeOffice2003Luna
@ xtpGridThemeOffice2003Luna
Office 2003 style theme with luna colors.
Definition XTPGridDefines.h:303
xtpGridThemeVisualStudio2012Dark
@ xtpGridThemeVisualStudio2012Dark
Visual Studio 2012 Dark style theme.
Definition XTPGridDefines.h:307
xtpGridThemeDefault
@ xtpGridThemeDefault
Default theme.
Definition XTPGridDefines.h:300
XTPGridCheckState
XTPGridCheckState
This enum defines the possible checkbox states.
Definition XTPGridDefines.h:79
xtpGridCheckStateIndeterminate
@ xtpGridCheckStateIndeterminate
The checkbox is in an indeterminate state.
Definition XTPGridDefines.h:83
xtpGridCheckStateCount
@ xtpGridCheckStateCount
Number of checkbox states.
Definition XTPGridDefines.h:84
xtpGridCheckStateUnchecked
@ xtpGridCheckStateUnchecked
The checkbox is in an unchecked state.
Definition XTPGridDefines.h:81
xtpGridCheckStateInvalid
@ xtpGridCheckStateInvalid
The checkbox state is invalid.
Definition XTPGridDefines.h:80
xtpGridCheckStateChecked
@ xtpGridCheckStateChecked
The checkbox is in a checked state.
Definition XTPGridDefines.h:82
XTPGridGlyph
XTPGridGlyph
This enum defines the index of the glyphs.
Definition XTPGridDefines.h:58
xtpGridGlyphItemUnlocked
@ xtpGridGlyphItemUnlocked
Specifies an unlocked item glyph.
Definition XTPGridDefines.h:70
xtpGridGlyphCount
@ xtpGridGlyphCount
The number of the glyphs.
Definition XTPGridDefines.h:71
xtpGridGlyphRowCollapse
@ xtpGridGlyphRowCollapse
Specifies a row collapse glyph.
Definition XTPGridDefines.h:60
xtpGridGlyphEnabledChecked
@ xtpGridGlyphEnabledChecked
Specifies an enabled checked glyph.
Definition XTPGridDefines.h:63
xtpGridGlyphColumnRestore
@ xtpGridGlyphColumnRestore
Specifies a column restore glyph.
Definition XTPGridDefines.h:67
xtpGridGlyphDisabledChecked
@ xtpGridGlyphDisabledChecked
Specifies a disabled checked glyph.
Definition XTPGridDefines.h:65
xtpGridGlyphItemLocked
@ xtpGridGlyphItemLocked
Specifies a locked item glyph.
Definition XTPGridDefines.h:69
xtpGridGlyphRowExpand
@ xtpGridGlyphRowExpand
Specifies a row expand glyph.
Definition XTPGridDefines.h:61
xtpGridGlyphColumnExpand
@ xtpGridGlyphColumnExpand
Specifies a column expand glyph.
Definition XTPGridDefines.h:66
xtpGridGlyphInvalid
@ xtpGridGlyphInvalid
Specifies an invalid glyph.
Definition XTPGridDefines.h:59
xtpGridGlyphDisabledUnchecked
@ xtpGridGlyphDisabledUnchecked
Specifies a disabled unchecked glyph.
Definition XTPGridDefines.h:64
xtpGridGlyphEnabledUnchecked
@ xtpGridGlyphEnabledUnchecked
Specifies an enabled unchecked glyph.
Definition XTPGridDefines.h:62
xtpGridGlyphEnabledTristate
@ xtpGridGlyphEnabledTristate
Specifies an enabled tristate glyph.
Definition XTPGridDefines.h:68
XTPGridFreezeColsDividerStyle
XTPGridFreezeColsDividerStyle
Represents predefined freeze column line styles.
Definition XTPGridDefines.h:152
xtpGridFreezeColsDividerShowAlways
@ xtpGridFreezeColsDividerShowAlways
Show event if AutoColumnSizing is On.
Definition XTPGridDefines.h:157
xtpGridFreezeColsDividerBold
@ xtpGridFreezeColsDividerBold
Bold line style.
Definition XTPGridDefines.h:154
xtpGridFreezeColsDividerHeader
@ xtpGridFreezeColsDividerHeader
Header line style.
Definition XTPGridDefines.h:155
xtpGridFreezeColsDividerShade
@ xtpGridFreezeColsDividerShade
Shade line style.
Definition XTPGridDefines.h:156
xtpGridFreezeColsDividerThin
@ xtpGridFreezeColsDividerThin
Thin line style.
Definition XTPGridDefines.h:153
XTPGridSectionDividerStyle
XTPGridSectionDividerStyle
Represent the header/footer rows divider style.
Definition XTPGridDefines.h:227
xtpGridSectionDividerStyleNone
@ xtpGridSectionDividerStyleNone
No line.
Definition XTPGridDefines.h:228
xtpGridSectionDividerStyleThin
@ xtpGridSectionDividerStyleThin
Thin style.
Definition XTPGridDefines.h:229
xtpGridSectionDividerStyleOutlook
@ xtpGridSectionDividerStyleOutlook
Outlook line style.
Definition XTPGridDefines.h:232
xtpGridSectionDividerStyleBold
@ xtpGridSectionDividerStyleBold
Bold style.
Definition XTPGridDefines.h:230
xtpGridSectionDividerStyleShade
@ xtpGridSectionDividerStyleShade
Shaded line style.
Definition XTPGridDefines.h:231
CXTPGridRow
CXTPGridRow class represents a row of the Grid control window.
Definition XTPGridRow.h:71


Toolkit Pro: Member List

CXTPProgressThemeNativeWindows10 Member List

This is the complete list of members for CXTPProgressThemeNativeWindows10, including all inherited members.

CXTPProgressPaintManager(CXTPPaintManager *pPaintManager) | CXTPProgressPaintManager |
CXTPProgressThemeNativeWindows10(CXTPPaintManager *pPaintManager) | CXTPProgressThemeNativeWindows10 |
CXTPProgressThemeOffice2013(CXTPPaintManager *pPaintManager) | CXTPProgressThemeOffice2013 |
DrawProgress(CDC *pDC, CXTPProgressBase *pProgressBar) | CXTPProgressThemeOffice2013 | virtual
GetPaintManager() const | CXTPProgressPaintManager |
m_clrBack | CXTPProgressThemeOffice2013 | protected
m_clrBar | CXTPProgressThemeOffice2013 | protected
m_clrBorder | CXTPProgressThemeOffice2013 | protected
m_cyProgress | CXTPProgressPaintManager |
m_pPaintManager | CXTPProgressPaintManager | protected
RefreshMetrics() | CXTPProgressThemeOffice2013 | virtual
~CXTPProgressPaintManager() | CXTPProgressPaintManager | virtual
~CXTPProgressThemeNativeWindows10() | CXTPProgressThemeNativeWindows10 | virtual
~CXTPProgressThemeOffice2013() | CXTPProgressThemeOffice2013 | virtual


Toolkit Pro: XTPMarkupInlineCollection.h Source File

  • Source
  • Markup
  • Text
XTPMarkupInlineCollection.h
Go to the documentation of this file.
1
23#if !defined(__XTPMARKUPINLINECOLLECTION_H__)
24# define __XTPMARKUPINLINECOLLECTION_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPMarkupInline;
34class CXTPMarkupSpan;
35class CXTPMarkupTextBlock;
36class CXTPMarkupObject;
37class CXTPMarkupBuilder;
38
39class _XTP_EXT_CLASS CXTPMarkupInlineCollection : public CXTPMarkupCollection
40{
42 DECLARE_MARKUPCLASS(CXTPMarkupInlineCollection);
44public:
45 CXTPMarkupInlineCollection();
46 ~CXTPMarkupInlineCollection();
47
48public:
49 CXTPMarkupInline* GetInline(int nIndex) const;
50
51protected:
52 virtual void SetContentObject(CXTPMarkupBuilder* pBuilder, CXTPMarkupObject* pContent);
53 virtual void OnItemAdded(CXTPMarkupObject* pItem, int nIndex);
54
55protected:
57public:
58 DECLARE_DISPATCH_MAP()
59# ifdef _XTP_ACTIVEX
60 DECLARE_INTERFACE_MAP()
61 DECLARE_OLETYPELIB_EX(CXTPMarkupInlineCollection);
62# endif
63 DECLARE_ENUM_VARIANT(CXTPMarkupInlineCollection);
64
65 long OleGetItemCount();
66 LPDISPATCH OleGetItem(long nIndex);
67 void OleAdd(LPDISPATCH lpElementDisp);
68 void OleInsert(long Index, LPDISPATCH lpElementDisp);
71private:
72 friend class CXTPMarkupInline;
73 friend class CXTPMarkupSpan;
74 friend class CXTPMarkupTextBlock;
75};
76
77AFX_INLINE CXTPMarkupInline* CXTPMarkupInlineCollection::GetInline(int nIndex) const
78{
79 return nIndex >= 0 && nIndex < m_arrItems.GetSize() ? (CXTPMarkupInline*)m_arrItems[nIndex]
80 : NULL;
81}
82
83# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
85#endif // !defined(__XTPMARKUPINLINECOLLECTION_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPMarkupTextBlock
CXTPMarkupTextBlock is a CXTPMarkupFrameworkElement derived class.
Definition XTPMarkupTextBlock.h:86


Toolkit Pro: XTPChartDiagram2DSeriesLabel.h Source File

  • Source
  • Chart
  • Diagram
  • Diagram2D
XTPChartDiagram2DSeriesLabel.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTDIAGRAM2DSERIESLABEL_H__)
24# define __XTPCHARTDIAGRAM2DSERIESLABEL_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartSeriesView;
34
40class _XTP_EXT_CLASS CXTPChartDiagram2DSeriesLabel : public CXTPChartSeriesLabel
41{
42 DECLARE_DYNAMIC(CXTPChartDiagram2DSeriesLabel);
43
44public:
49 CXTPChartDiagram2DSeriesLabel();
50
55 virtual ~CXTPChartDiagram2DSeriesLabel();
56
57public:
58 void DoPropExchange(CXTPPropExchange* pPX);
59
60protected:
61};
62
68class _XTP_EXT_CLASS CXTPChartDiagram2DSeriesLabelView : public CXTPChartSeriesLabelView
69{
70public:
79 CXTPChartDiagram2DSeriesLabelView(CXTPChartSeriesLabel* pLabel,
80 CXTPChartSeriesPointView* pPointView,
81 CXTPChartElementView* pParentView);
82
94 virtual CXTPChartDeviceCommand* CreateDeviceCommand(CXTPChartDeviceContext* pDC);
95
108 virtual CXTPChartDeviceCommand* CreateDeviceCommand(CXTPChartDeviceContext* pDC,
109 CXTPChartPointF ptCenterPoint);
110
124 virtual CXTPChartDeviceCommand* CreateDeviceCommand(CXTPChartDeviceContext* pDC,
125 CXTPChartPointF ptCenterPoint,
126 const CXTPChartString& text);
127
142 virtual CXTPChartDeviceCommand* CreateDeviceCommand(CXTPChartDeviceContext* pDC,
143 const CXTPChartPointF& ptAnchorPoint,
144 double dAnchorAngle,
145 const CXTPChartString& text);
146
153 virtual CXTPChartPointF GetAnchorPoint() const;
154 virtual double GetAnchorAngle() const;
155
156 virtual void CalculateLayout(CXTPChartDeviceContext* pDC);
157 void CalculateLayout(CXTPChartDeviceContext* pDC, CXTPChartPointF ptCenterPoint);
158
159 void CalculateLayout(CXTPChartDeviceContext* pDC, const CXTPChartPointF& ptAnchorPoint,
160 double dAnchorAngle, const CXTPChartString& text);
161 void CalculateLayout(CXTPChartDeviceContext* pDC, CXTPChartPointF ptCenterPoint,
162 const CXTPChartString& text);
163
164protected:
165 CRect GetPaneRect() const;
166};
168# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
169#endif //#if !defined(__XTPCHARTDIAGRAM2DSERIESLABEL_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartDiagram2DSeriesLabel
This class abstracts the label of a point series.
Definition XTPChartDiagram2DSeriesLabel.h:41
CXTPChartDiagram2DSeriesLabel::CXTPChartDiagram2DSeriesLabel
CXTPChartDiagram2DSeriesLabel()
Constructs a CXTPChartDiagram2DSeriesLabel object.
CXTPChartDiagram2DSeriesLabel::DoPropExchange
void DoPropExchange(CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
CXTPChartDiagram2DSeriesLabel::~CXTPChartDiagram2DSeriesLabel
virtual ~CXTPChartDiagram2DSeriesLabel()
Destroys a CXTPChartDiagram2DSeriesLabel object, handles cleanup.
CXTPChartDiagram2DSeriesLabelView
This class abstracts the view of the label of a point series.
Definition XTPChartDiagram2DSeriesLabel.h:69
CXTPChartDiagram2DSeriesLabelView::CXTPChartDiagram2DSeriesLabelView
CXTPChartDiagram2DSeriesLabelView(CXTPChartSeriesLabel *pLabel, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView)
Constructs a CXTPChartDiagram2DSeriesLabelView object.
CXTPChartDiagram2DSeriesLabelView::CreateDeviceCommand
virtual CXTPChartDeviceCommand * CreateDeviceCommand(CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
CXTPChartDiagram2DSeriesLabelView::CreateDeviceCommand
virtual CXTPChartDeviceCommand * CreateDeviceCommand(CXTPChartDeviceContext *pDC, CXTPChartPointF ptCenterPoint, const CXTPChartString &text)
This function creates a CXTPChartDeviceCommand object.
CXTPChartDiagram2DSeriesLabelView::GetAnchorPoint
virtual CXTPChartPointF GetAnchorPoint() const
This function calculates the anchor point of the label stem.
CXTPChartDiagram2DSeriesLabelView::CreateDeviceCommand
virtual CXTPChartDeviceCommand * CreateDeviceCommand(CXTPChartDeviceContext *pDC, const CXTPChartPointF &ptAnchorPoint, double dAnchorAngle, const CXTPChartString &text)
This function creates a CXTPChartDeviceCommand object.
CXTPChartDiagram2DSeriesLabelView::CreateDeviceCommand
virtual CXTPChartDeviceCommand * CreateDeviceCommand(CXTPChartDeviceContext *pDC, CXTPChartPointF ptCenterPoint)
This function creates a CXTPChartDeviceCommand object.
CXTPChartElementView
This class represents the view of a chart element.
Definition XTPChartElementView.h:47
CXTPChartSeriesLabel
This class abstracts the label of a series.
Definition XTPChartSeriesLabel.h:49
CXTPChartSeriesPointView
Represents chart series point view.
Definition XTPChartSeriesPointView.h:48
CXTPPoint2T< float >
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72


Toolkit Pro: Member List

IXTPMarkupDeviceDependentImageSite Member List

This is the complete list of members for IXTPMarkupDeviceDependentImageSite, including all inherited members.

GetMarkupContext()=0 | IXTPMarkupDeviceDependentImageSite | pure virtual
OnImageUpdateRequired()=0 | IXTPMarkupDeviceDependentImageSite | pure virtual
~IXTPMarkupDeviceDependentImageSite() | IXTPMarkupDeviceDependentImageSite | inlinevirtual


Toolkit Pro: Member List

CXTPAlphaWnd Member List

This is the complete list of members for CXTPAlphaWnd, including all inherited members.

CXTPAlphaWnd() | CXTPAlphaWnd |
~CXTPAlphaWnd() | CXTPAlphaWnd | virtual


Toolkit Pro: Member List

CXTPListBoxThemeOfficeXP Member List

This is the complete list of members for CXTPListBoxThemeOfficeXP, including all inherited members.

DrawItem(CDC *pDC, CXTPListBox *pListBox, LPDRAWITEMSTRUCT lpDIS) | CXTPListBoxThemeOfficeXP | virtual
DrawItemText(CDC *pDC, CRect rcText, CXTPListBox *pListBox, LPDRAWITEMSTRUCT lpDIS) | CXTPListBoxTheme | virtual
DrawNcBorders(CDC *pDC, CRect rc) | CXTPListBoxTheme | virtual
GetBackColor() | CXTPListBoxTheme | virtual
RefreshMetrics() | CXTPListBoxThemeOfficeXP | virtual
~CXTPListBoxTheme() | CXTPListBoxTheme | inlinevirtual


Toolkit Pro: Member List

  • CXTPCalendarControl
  • CUpdateContext
CXTPCalendarControl::CUpdateContext Member List

This is the complete list of members for CXTPCalendarControl::CUpdateContext, including all inherited members.

CUpdateContext(CXTPCalendarControl *pControl, int nOptions=xtpCalendarUpdateLayout|xtpCalendarUpdateRedraw) | CXTPCalendarControl::CUpdateContext | inline
~CUpdateContext() | CXTPCalendarControl::CUpdateContext | inline


Toolkit Pro: Member List

CXTPPropertyGridVerb Member List

This is the complete list of members for CXTPPropertyGridVerb, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPPropertyGridVerb() | CXTPPropertyGridVerb |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCaption() const | CXTPPropertyGridVerb |
GetClickPoint() const | CXTPPropertyGridVerb |
GetID() const | CXTPPropertyGridVerb |
GetIndex() const | CXTPPropertyGridVerb |
GetPart() const | CXTPPropertyGridVerb |
IsFocused() const | CXTPPropertyGridVerb |
m_nID | CXTPPropertyGridVerb | protected
m_nIndex | CXTPPropertyGridVerb | protected
m_ptClick | CXTPPropertyGridVerb | protected
m_pVerbs | CXTPPropertyGridVerb | protected
m_rcPart | CXTPPropertyGridVerb | protected
m_strCaption | CXTPPropertyGridVerb | protected
SetPart(CRect rc) | CXTPPropertyGridVerb |


Toolkit Pro: Member List

CXTPTabManager Member List

This is the complete list of members for CXTPTabManager, including all inherited members.

AddItem(int nItem, CXTPTabManagerItem *pItem=NULL) | CXTPTabManager | protected
CXTPTabManager() | CXTPTabManager |
DeleteAllItems() | CXTPTabManager |
DeleteItem(int nItem) | CXTPTabManager |
DrawIcon(CDC *pDC, CPoint pt, CXTPTabManagerItem *pItem, BOOL bDraw, CSize &szIcon) const =0 | CXTPTabManager | pure virtual
DrawParentBackground(CDC *pDC, CRect rc) | CXTPTabManager | virtual
EnableMarkup(BOOL bEnable=TRUE) | CXTPTabManager |
EnableTabThemeTexture(HWND hWnd, BOOL bEnable=TRUE) | CXTPTabManager |
EnsureVisible(CXTPTabManagerItem *pItem) | CXTPTabManager |
FindNavigateButton(UINT nID) const | CXTPTabManager |
FindNextFocusable(int nIndex, int nDirection) const | CXTPTabManager |
GetAppearance() const | CXTPTabManager |
GetAppearanceSet() const | CXTPTabManager |
GetClientRect() const | CXTPTabManager |
GetColor() const | CXTPTabManager |
GetColorSet() const | CXTPTabManager |
GetControlRect() const | CXTPTabManager |
GetCurSel() const | CXTPTabManager |
GetHeaderOffset() const | CXTPTabManager |
GetHeaderRect() const | CXTPTabManager |
GetItem(int nIndex) const | CXTPTabManager |
GetItemCaption(const CXTPTabManagerItem *pItem) const | CXTPTabManager | virtual
GetItemColor(const CXTPTabManagerItem *pItem) const | CXTPTabManager | virtual
GetItemCount() const | CXTPTabManager |
GetItemIcon(const CXTPTabManagerItem *pItem) const | CXTPTabManager | virtual
GetItemMetrics(CSize *szNormal, CSize *szMin=NULL, CSize *szMax=NULL) const | CXTPTabManager | virtual
GetItemsLength() const | CXTPTabManager | virtual
GetItemTooltip(const CXTPTabManagerItem *pItem) const | CXTPTabManager | virtual
GetLayout() const | CXTPTabManager |
GetMarkupContext() const | CXTPTabManager | virtual
GetNavigateButton(int nIndex) const | CXTPTabManager |
GetNavigateButtonCount() const | CXTPTabManager |
GetNavigateButtons() | CXTPTabManager |
GetPaintManager() const =0 | CXTPTabManager | pure virtual
GetPosition() const | CXTPTabManager | virtual
GetRectLength(CRect rc) const | CXTPTabManager |
GetRowCount() const | CXTPTabManager |
GetSelectedItem() const | CXTPTabManager |
HeaderHasFocus() const | CXTPTabManager | protectedvirtual
HitTest(CPoint point) const | CXTPTabManager |
HitTestNavigateButton(CPoint point, BOOL bHeaderOnly, int *pnIndex=NULL) const | CXTPTabManager |
IsActive() const | CXTPTabManager |
IsAllowReorder() const | CXTPTabManager | virtual
IsDrawStaticFrame() const | CXTPTabManager | virtual
IsHorizontalPosition() const | CXTPTabManager |
IsMouseLocked() const | CXTPTabManager | protectedvirtual
IsNavigateButtonAutomaticVisible(CXTPTabManagerNavigateButton *pButton) | CXTPTabManager | protectedvirtual
IsNavigateButtonVisible(CXTPTabManagerNavigateButton *pButton) | CXTPTabManager | protectedvirtual
m_arrItems | CXTPTabManager | protected
m_arrNavigateButtons | CXTPTabManager | protected
m_bActive | CXTPTabManager | protected
m_bAllowReorder | CXTPTabManager | protected
m_bCloseItemButton | CXTPTabManager | protected
m_nHeaderOffset | CXTPTabManager | protected
m_nScrollDelta | CXTPTabManager | protected
m_pHighlighted | CXTPTabManager | protected
m_pHighlightedNavigateButton | CXTPTabManager | protected
m_pMarkupContext | CXTPTabManager | protected
m_pPressed | CXTPTabManager | protected
m_pRowIndexer | CXTPTabManager | protected
m_pSelected | CXTPTabManager | protected
m_rcControl | CXTPTabManager | protected
m_rcHeaderRect | CXTPTabManager | protected
MoveItem(CXTPTabManagerItem *pItem, int nIndex) | CXTPTabManager |
OnBeforeItemClick(CXTPTabManagerItem *pItem) | CXTPTabManager | protectedvirtual
OnItemClick(CXTPTabManagerItem *pItem) | CXTPTabManager | protectedvirtual
OnItemHandleChanged(CXTPTabManagerItem *pItem, HWND hwndOld, HWND hwndNew) | CXTPTabManager | protectedvirtual
OnItemOrderChanged(CXTPTabManagerItem *pItem, int nOldIndex, int nNewIndex) | CXTPTabManager | protectedvirtual
OnItemsChanged() | CXTPTabManager | virtual
OnNavigateButtonClick(CXTPTabManagerNavigateButton *pButton) | CXTPTabManager | protectedvirtual
OnNavigateButtonClick(UINT nID) | CXTPTabManager | protectedvirtual
OnPropertyChanged() | CXTPTabManagerAtom | inlinevirtual
OnScrollHeader(BOOL bRight) | CXTPTabManager | virtual
OnSwitchItem(CXTPTabManagerItem *pItem1, CXTPTabManagerItem *pItem2) | CXTPTabManager | protectedvirtual
PerformClick(HWND hWnd, CPoint pt, BOOL bNoItemClick=FALSE) | CXTPTabManager |
PerformKeyDown(HWND hWnd, UINT nChar) | CXTPTabManager | virtual
PerformMouseMove(HWND hWnd, CPoint pt) | CXTPTabManager |
PerformToolHitTest(HWND hWnd, CPoint point, TOOLINFO *pTI) const | CXTPTabManager | virtual
RedrawControl(LPCRECT lpRect, BOOL bAnimate)=0 | CXTPTabManager | pure virtual
ReOrder(HWND hWnd, CPoint pt, CXTPTabManagerItem *pItem) | CXTPTabManager | protectedvirtual
Reposition()=0 | CXTPTabManagerAtom | pure virtual
SetActive(BOOL bActive) | CXTPTabManager |
SetAllowReorder(BOOL bAllowReorder) | CXTPTabManager | virtual
SetAppearance(XTPTabAppearanceStyle tabAppearance) | CXTPTabManager |
SetAppearanceSet(CXTPTabPaintManagerTheme *pAppearanceSet) | CXTPTabManager |
SetColor(XTPTabColorStyle tabColor) | CXTPTabManager |
SetColorSet(CXTPTabPaintManagerColorSet *pColorSet) | CXTPTabManager |
SetCurSel(int nIndex) | CXTPTabManager |
SetFocusedItem(CXTPTabManagerItem *pItem) | CXTPTabManager | virtual
SetHeaderOffset(int nOffset) | CXTPTabManager |
SetItemMetrics(CSize szNormal, CSize szMin=CSize(0, 0), CSize szMax=CSize(0, 0)) | CXTPTabManager |
SetLayoutStyle(XTPTabLayoutStyle tabLayout) | CXTPTabManager |
SetPaintManager(CXTPTabPaintManager *pPaintManager) | CXTPTabManager | virtual
SetPosition(XTPTabPosition tabPosition) | CXTPTabManager |
SetSelectedItem(CXTPTabManagerItem *pItem) | CXTPTabManager | virtual
ShowCloseItemButton(XTPTabNavigateButtonFlags bCloseItemButton=xtpTabNavigateButtonAlways) | CXTPTabManager |
ShowIcons(BOOL bShowIcons) | CXTPTabManager |
TrackClick(HWND hWnd, CPoint pt, CXTPTabManagerItem *pItem) | CXTPTabManager | protected
~CXTPTabManager() | CXTPTabManager | virtual
~CXTPTabManagerAtom() | CXTPTabManagerAtom | inlineprotectedvirtual


Toolkit Pro: Member List

XTP_NM_FLOWGRAPH_CONNECTIONCHANGED Member List

This is the complete list of members for XTP_NM_FLOWGRAPH_CONNECTIONCHANGED, including all inherited members.

hdr | XTP_NM_FLOWGRAPH_CONNECTIONCHANGED
nAction | XTP_NM_FLOWGRAPH_CONNECTIONCHANGED
pConnection | XTP_NM_FLOWGRAPH_CONNECTIONCHANGED


Toolkit Pro: Member List

CXTPPageScroller Member List

This is the complete list of members for CXTPPageScroller, including all inherited members.

Create(DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID) | CXTPPageScroller | virtual
CXTPPageScroller() | CXTPPageScroller |
ForwardMouse(BOOL bForward) | CXTPPageScroller |
GetBkColor() | CXTPPageScroller |
GetBorder() | CXTPPageScroller |
GetButtonSize() | CXTPPageScroller |
GetButtonState(int iButton) | CXTPPageScroller |
GetDropTarget(IDropTarget **ppdt) | CXTPPageScroller |
GetPos() | CXTPPageScroller |
RecalcSize() | CXTPPageScroller |
SetBkColor(COLORREF clr) | CXTPPageScroller |
SetBorder(int iBorder) | CXTPPageScroller |
SetButtonSize(int iSize) | CXTPPageScroller |
SetChild(HWND hwndChild) | CXTPPageScroller |
SetPos(int iPos) | CXTPPageScroller |
~CXTPPageScroller() | CXTPPageScroller | virtual


Toolkit Pro: Member List

CXTPScrollBarThemeVisualStudio2019 Member List

This is the complete list of members for CXTPScrollBarThemeVisualStudio2019, including all inherited members.

CalcHScroll(CXTPScrollBase *pScroll, XTPScrollMetricsH *pHScroll) | CXTPScrollBarPaintManager | protectedstatic
CalcVScroll(CXTPScrollBase *pScroll, XTPScrollMetricsV *pVScroll) | CXTPScrollBarPaintManager | protectedstatic
CXTPScrollBarPaintManager() | CXTPScrollBarPaintManager |
DrawArrowGlyph(CDC *pDC, CRect rcArrow, XTPArrowGlyph glyph, BOOL bEnabled, COLORREF clrText=COLORREF_NULL) | CXTPScrollBarPaintManager | protected
DrawArrows(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics) | CXTPScrollBarThemeVisualStudio2012 | protectedvirtual
DrawArrows(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics) | CXTPScrollBarThemeVisualStudio2012 | protectedvirtual
DrawBackground(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics) | CXTPScrollBarThemeVisualStudio2012 | protectedvirtual
DrawBackground(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics) | CXTPScrollBarThemeVisualStudio2012 | protectedvirtual
DrawButtons(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics) | CXTPScrollBarThemeVisualStudio2012 | protectedvirtual
DrawButtons(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics) | CXTPScrollBarThemeVisualStudio2012 | protectedvirtual
DrawGripper(CDC *pDC, CXTPScrollBase *pScroll) | CXTPScrollBarThemeVisualStudio2012 | protectedvirtual
DrawScrollBar(CDC *pDC, CXTPScrollBase *pScrollBar) | CXTPScrollBarThemeVisualStudio2019 | protectedvirtual
DrawThumbButton(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics) | CXTPScrollBarThemeVisualStudio2012 | protectedvirtual
DrawThumbButton(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics) | CXTPScrollBarThemeVisualStudio2012 | protectedvirtual
DrawTracker(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics) | CXTPScrollBarPaintManager | protectedvirtual
DrawTracker(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics) | CXTPScrollBarPaintManager | protectedvirtual
m_crBack | CXTPScrollBarPaintManager |
m_crBackHilite | CXTPScrollBarPaintManager |
m_crBackPushed | CXTPScrollBarPaintManager |
m_crBorder | CXTPScrollBarPaintManager |
m_crBorderHilite | CXTPScrollBarPaintManager |
m_cThumb | CXTPScrollBarPaintManager |
m_cxHScroll | CXTPScrollBarPaintManager |
m_cxVScroll | CXTPScrollBarPaintManager |
m_cyHScroll | CXTPScrollBarPaintManager |
m_cyVScroll | CXTPScrollBarPaintManager |
RefreshMetrics() | CXTPScrollBarPaintManager | virtual


Toolkit Pro: XTPDockingPane.h Source File

  • Source
  • DockingPane
XTPDockingPane.h
Go to the documentation of this file.
1
23#if !defined(__XTPDOCKINGPANE_H__)
24# define __XTPDOCKINGPANE_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPImageManagerIcon;
34
40class _XTP_EXT_CLASS CXTPDockingPane
41 : public CXTPCmdTarget
42 , public CXTPDockingPaneBase
43 , public CXTPAccessible
44{
45protected:
52 CXTPDockingPane(CXTPDockingPaneLayout* pLayout);
53
58 virtual ~CXTPDockingPane();
59
60public:
66 void SetTitle(LPCTSTR lpszTitle);
67
72 virtual void SetFocus();
73
80 int GetID() const;
81
88 virtual CString GetTitle() const;
89
96 virtual CString GetTabCaption() const;
97
103 void SetTabCaption(LPCTSTR lpszTabCaption);
104
111 virtual CString GetTitleToolTip() const;
112
118 void SetTitleToolTip(LPCTSTR lpszTitleToolTip);
119
124 void Close();
125
130 void Hide();
131
138 BOOL IsValid() const;
139
146 BOOL IsClosed() const;
147
154 BOOL IsHidden() const;
155
162 BOOL IsSelected() const;
163
170 BOOL IsFloating() const;
171
178 BOOL IsSidePanel() const;
179
186 BOOL IsTabsVisible() const;
187
197 void Attach(CWnd* pWnd);
198
215 CWnd* AttachView(CWnd* pParentWnd, CRuntimeClass* pViewClass, CDocument* pDocument = NULL,
216 CCreateContext* pContext = NULL);
217
222 void Detach();
223
228 void Select();
229
237 int GetIconID() const;
238
246 virtual CXTPImageManagerIcon* GetIcon(int nWidth = 16) const;
247
253 void SetIconID(UINT nID);
254
261 CWnd* GetChild() const;
262
279 void SetOptions(DWORD dwOptions);
280
289 DWORD GetOptions() const;
290
298 void SetPaneData(DWORD_PTR dwData);
299
309 DWORD_PTR GetPaneData() const;
310
319 virtual COLORREF GetItemColor() const;
320
326 void SetItemColor(COLORREF clr);
327
337 virtual void GetMinMaxInfo(LPMINMAXINFO pMinMaxInfo) const;
338
345 BOOL IsFocus() const;
346
353 CSize SetMinTrackSize(CSize sz);
354
361 CSize SetMaxTrackSize(CSize sz);
362
368 void SetHelpID(int nIDR);
369
379 CFrameWnd* GetParentFrame() const;
380
387 CWnd* GetDockingSite() const;
388
397 XTPDockingPaneEnableOptions GetEnabled() const;
398
406 void SetEnabled(XTPDockingPaneEnableOptions nState);
407
408protected:
416 virtual void Copy(CXTPDockingPane* pPane);
417
425 virtual void OnSizeParent(CWnd* pParent, CRect rect, LPVOID lParam);
426
432 virtual void SetParentContainer(CXTPDockingPaneBase* pContainer);
433
441 virtual BOOL DoPropExchange(CXTPPropExchange* pPX);
442
448 void ShowWindow(BOOL bShow);
449
455 void SetID(int nID);
456
462 void SetWindowRect(CRect rc);
463
468 virtual void DeletePane();
469
470private:
471 virtual void Copy(CXTPDockingPaneBase* pClone, CXTPPaneToPaneMap* pMap, DWORD dwIgnoredOptions);
472
473protected:
475 virtual HRESULT GetAccessibleParent(IDispatch** ppdispParent);
476 virtual HRESULT GetAccessibleDescription(VARIANT varChild, BSTR* pszDescription);
477 virtual HRESULT GetAccessibleChildCount(long* pcountChildren);
478 virtual HRESULT GetAccessibleChild(VARIANT varChild, IDispatch** ppdispChild);
479 virtual HRESULT GetAccessibleName(VARIANT varChild, BSTR* pszName);
480 virtual HRESULT GetAccessibleRole(VARIANT varChild, VARIANT* pvarRole);
481 virtual HRESULT AccessibleLocation(long* pxLeft, long* pyTop, long* pcxWidth, long* pcyHeight,
482 VARIANT varChild);
483 virtual HRESULT AccessibleHitTest(long xLeft, long yTop, VARIANT* pvarChild);
484 virtual HRESULT GetAccessibleState(VARIANT varChild, VARIANT* pvarState);
485 virtual CCmdTarget* GetAccessible();
486 virtual HRESULT GetAccessibleDefaultAction(VARIANT varChild, BSTR* pszDefaultAction);
487 virtual HRESULT AccessibleDoDefaultAction(VARIANT varChild);
488 virtual HRESULT AccessibleSelect(long flagsSelect, VARIANT varChild);
489
490 DECLARE_INTERFACE_MAP()
493protected:
494 HWND m_hwndChild;
495 int m_nID;
496 int m_nIconID;
497 CString m_strTitle;
498 CString m_strTabCaption;
499 CString m_strTitleToolTip;
501 DWORD m_dwOptions;
502 DWORD_PTR m_dwData;
503 CPoint m_ptMinTrackSize;
504 CPoint m_ptMaxTrackSize;
505 COLORREF m_clrItemTab;
506 int m_nIDHelp;
507 XTPDockingPaneEnableOptions m_bEnabled;
509# ifdef _XTP_ACTIVEX
511private:
512 DECLARE_DYNAMIC(CXTPDockingPane)
513 DECLARE_DISPATCH_MAP()
514
515 DECLARE_OLETYPELIB_EX(CXTPDockingPane);
516
517 afx_msg void OleSetHandle(long nHandle);
518 afx_msg long OleGetHandle();
519 afx_msg void OleAttachTo(LPDISPATCH pNeighbourDisp);
520 afx_msg void OleSetHidden(BOOL bHidden);
521 afx_msg void OleSetClosed(BOOL bClosed);
522 afx_msg void OleSetSelected(BOOL bSelected);
523 afx_msg void OleSetFloating(BOOL bFloating);
524 afx_msg LPDISPATCH OleGetMinTrackSize();
525 afx_msg LPDISPATCH OleGetMaxTrackSize();
526 afx_msg BOOL OleGetHidden();
527 DECLARE_PROPERTY(TabColor, COLORREF);
528 DECLARE_PROPERTY(Maximized, BOOL);
529 afx_msg LPDISPATCH OleGetContainer();
530 afx_msg int OleGetType();
531 afx_msg LPDISPATCH OleGetDispatch(BOOL bAddRef);
532 afx_msg int OleGetPosition();
533 afx_msg void OleGetClientRect(long* pLeft, long* pTop, long* pRight, long* pBottom);
534 afx_msg BSTR OleGetTabCaption();
535 afx_msg BSTR OleGetTitleToolTip();
536
537 afx_msg BSTR OleGetTitle();
538 afx_msg void OleSetTitle(LPCTSTR sTitle);
539
540 enum
541 {
542 dispidTitle = 1L,
543 dispidId = 2L,
544 dispidIconId = 3L,
545 dispidHidden = 4L,
546 dispidClosed = 5L,
547 dispidSelected = 6L,
548 dispidOptions = 7L,
549 dispidFloating = 8L,
550 dispidHide = 10L,
551 dispidClose = 11L,
552 dispidSelect = 12L,
553 dispidAttachTo = 13L,
554 dispidTag = 14L,
555 };
556
557 static CXTPDockingPane* AFX_CDECL FromDispatch(LPDISPATCH pDisp);
558
560# endif /*_XTP_ACTIVEX*/
561
562private:
563 friend class CXTPDockingPaneMiniWnd;
564 friend class CXTPDockingPaneManager;
565 friend class CXTPDockingPaneTabbedContainer;
566 friend class CXTPDockingPaneLayout;
567 friend class CDockingPaneCtrl;
568};
569
570# ifdef _XTP_ACTIVEX
573class _XTP_EXT_CLASS CXTPDockingPaneTrackSize : public CXTPCmdTarget
574{
575public:
576 CXTPDockingPaneTrackSize(CPoint*);
577
578public:
579 void OnPropertyChanged();
580
581protected:
582 DECLARE_DISPATCH_MAP()
583 DECLARE_INTERFACE_MAP()
584 DECLARE_OLETYPELIB_EX(CXTPDockingPaneTrackSize);
585 afx_msg void OleSetSize(long nWidth, long nHeight);
586
587protected:
588 CPoint* m_pPoint;
589 long m_nWidth;
590 long m_nHeight;
591};
593# endif
594
595AFX_INLINE int CXTPDockingPane::GetID() const
596{
597 return m_nID;
598}
599AFX_INLINE void CXTPDockingPane::SetOptions(DWORD dwOptions)
600{
601 m_dwOptions = dwOptions;
602}
603AFX_INLINE DWORD_PTR CXTPDockingPane::GetPaneData() const
604{
605 return m_dwData;
606}
607AFX_INLINE void CXTPDockingPane::SetPaneData(DWORD_PTR dwData)
608{
609 m_dwData = dwData;
610}
611AFX_INLINE void CXTPDockingPane::SetHelpID(int nIDR)
612{
613 m_nIDHelp = nIDR;
614}
616# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
617#endif // #if !defined(__XTPDOCKINGPANE_H__)
XTPDisableNoisyWarnings.h
XTPDockingPaneEnableOptions
XTPDockingPaneEnableOptions
Enable options of the pane.
Definition XTPDockingPaneDefines.h:318
CXTPPaneToPaneMap
CMap< CXTPDockingPaneBase *, CXTPDockingPaneBase *, CXTPDockingPaneBase *, CXTPDockingPaneBase * > CXTPPaneToPaneMap
This map is used for mapping CXTPDockingPaneBase objects.
Definition XTPDockingPaneDefines.h:514
XTPEnableNoisyWarnings.h
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPDockingPaneBase
CXTPDockingPaneBase is a standalone class.
Definition XTPDockingPaneBase.h:69
CXTPDockingPaneBase::Copy
virtual void Copy(CXTPDockingPaneBase *pClone, CXTPPaneToPaneMap *pMap, DWORD dwIgnoredOptions)
This member is called to copy a pane.
CXTPDockingPane
CXTPDockingPane is a CXTPDockingPaneBase derived class.
Definition XTPDockingPane.h:44
CXTPDockingPane::ShowWindow
void ShowWindow(BOOL bShow)
Sets the visibility state of the window.
CXTPDockingPane::GetOptions
DWORD GetOptions() const
Call this member to get the options of the pane.
CXTPDockingPane::GetIconID
int GetIconID() const
Retrieves the identifier of the icon.
CXTPDockingPane::SetParentContainer
virtual void SetParentContainer(CXTPDockingPaneBase *pContainer)
Call this method to set the parent container of the pane.
CXTPDockingPane::Hide
void Hide()
Call this member to hide the pane.
CXTPDockingPane::GetPaneData
DWORD_PTR GetPaneData() const
This method retrieves the application-supplied, 32-bit value associated with the tab item.
Definition XTPDockingPane.h:603
CXTPDockingPane::SetOptions
void SetOptions(DWORD dwOptions)
Call this member to set options for the pane.
Definition XTPDockingPane.h:599
CXTPDockingPane::GetItemColor
virtual COLORREF GetItemColor() const
This member function retrieves the RGB value for the referenced item tab color, or (COLORREF)-1 if th...
CXTPDockingPane::SetTitle
void SetTitle(LPCTSTR lpszTitle)
Call this member to set a title for this object.
CXTPDockingPane::SetHelpID
void SetHelpID(int nIDR)
Sets a context-sensitive help ID for the child pane.
Definition XTPDockingPane.h:611
CXTPDockingPane::IsSelected
BOOL IsSelected() const
Call this member to check if the pane is selected.
CXTPDockingPane::IsSidePanel
BOOL IsSidePanel() const
Call this member to check if the pane is a side panel.
CXTPDockingPane::IsTabsVisible
BOOL IsTabsVisible() const
Call this member to check if the tab bar is visible.
CXTPDockingPane::DoPropExchange
virtual BOOL DoPropExchange(CXTPPropExchange *pPX)
Call this member function to save/restore the settings of the pane.
CXTPDockingPane::DeletePane
virtual void DeletePane()
This method is called to the destroy the pane.
CXTPDockingPane::GetChild
CWnd * GetChild() const
Call this member to get the associated user window.
CXTPDockingPane::GetID
int GetID() const
Call this member to get the pane's identifier.
Definition XTPDockingPane.h:595
CXTPDockingPane::SetID
void SetID(int nID)
Call this member to set the identifier of the item.
CXTPDockingPane::GetTabCaption
virtual CString GetTabCaption() const
Call this member to get the tab caption of the pane.
CXTPDockingPane::GetTitleToolTip
virtual CString GetTitleToolTip() const
Call this member to get the title tooltip text of the pane.
CXTPDockingPane::GetTitle
virtual CString GetTitle() const
Call this member to get the title of the pane.
CXTPDockingPane::Copy
virtual void Copy(CXTPDockingPane *pPane)
Copies self data from another pane.
CXTPDockingPane::GetIcon
virtual CXTPImageManagerIcon * GetIcon(int nWidth=16) const
Retrieves the icon associated with the pane.
CXTPDockingPane::GetDockingSite
CWnd * GetDockingSite() const
Call this member function to retrieve the parent window for the pane.
CXTPDockingPane::SetTabCaption
void SetTabCaption(LPCTSTR lpszTabCaption)
Call this member to set the tab caption of the pane.
CXTPDockingPane::AttachView
CWnd * AttachView(CWnd *pParentWnd, CRuntimeClass *pViewClass, CDocument *pDocument=NULL, CCreateContext *pContext=NULL)
This member function dynamically creates a view based on a CRuntimeClass object and attaches it to th...
CXTPDockingPane::SetMinTrackSize
CSize SetMinTrackSize(CSize sz)
Call this method to set the minimum size for the pane.
CXTPDockingPane::IsFocus
BOOL IsFocus() const
Retrieves the state of the child window.
CXTPDockingPane::GetEnabled
XTPDockingPaneEnableOptions GetEnabled() const
Determines the pane's enabled state.
CXTPDockingPane::CXTPDockingPane
CXTPDockingPane(CXTPDockingPaneLayout *pLayout)
Constructs a CXTPDockingPane object.
CXTPDockingPane::SetTitleToolTip
void SetTitleToolTip(LPCTSTR lpszTitleToolTip)
Call this member to set the title tooltip text for the pane.
CXTPDockingPane::SetEnabled
void SetEnabled(XTPDockingPaneEnableOptions nState)
Call this method to set the pane's enabled state.
CXTPDockingPane::SetIconID
void SetIconID(UINT nID)
Call this member to set the identifier of the icon.
CXTPDockingPane::GetMinMaxInfo
virtual void GetMinMaxInfo(LPMINMAXINFO pMinMaxInfo) const
Call this member to fill the pMinMaxInfo structure with the minimum and maximum width and height of t...
CXTPDockingPane::SetItemColor
void SetItemColor(COLORREF clr)
Call this member to set the RGB value for the item tab.
CXTPDockingPane::SetWindowRect
void SetWindowRect(CRect rc)
Call this member to set the bounding rectangle.
CXTPDockingPane::Close
void Close()
Call this member to close the pane.
CXTPDockingPane::Attach
void Attach(CWnd *pWnd)
Call this member to associate the pane with a user window.
CXTPDockingPane::GetParentFrame
CFrameWnd * GetParentFrame() const
Call this member function to retrieve the parent frame window.
CXTPDockingPane::IsClosed
BOOL IsClosed() const
Call this member to check if the pane is closed.
CXTPDockingPane::~CXTPDockingPane
virtual ~CXTPDockingPane()
Destroys a CXTPDockingPane object, handles cleanup and deallocation.
CXTPDockingPane::IsFloating
BOOL IsFloating() const
Call this member to check if the pane is floating.
CXTPDockingPane::SetMaxTrackSize
CSize SetMaxTrackSize(CSize sz)
Call this method to set the maximum size for the pane.
CXTPDockingPane::IsValid
BOOL IsValid() const
Call this member to check if the pane is associated with a user window.
CXTPDockingPane::Select
void Select()
Call this member to select the pane.
CXTPDockingPane::Detach
void Detach()
Call this member to disassociate the pane from a user window.
CXTPDockingPane::IsHidden
BOOL IsHidden() const
Call this member to check if the pane is hidden.
CXTPDockingPane::OnSizeParent
virtual void OnSizeParent(CWnd *pParent, CRect rect, LPVOID lParam)
This method is called to set the position of the pane.
CXTPDockingPane::SetFocus
virtual void SetFocus()
Call this member to set the focus of the pane.
CXTPDockingPane::SetPaneData
void SetPaneData(DWORD_PTR dwData)
Call this method to set the 32-bit value associated with the pane.
Definition XTPDockingPane.h:607
CXTPDockingPaneLayout
CXTPDockingPaneLayout is a standalone class.
Definition XTPDockingPaneLayout.h:54
CXTPDockingPaneManager
CXTPDockingPaneManager is a CWnd derived class.
Definition XTPDockingPaneManager.h:58
CXTPDockingPaneMiniWnd
CXTPDockingPaneMiniWnd is a multiple inheritance class derived from CMiniFrameWnd and CXTPDockingPane...
Definition XTPDockingPaneMiniWnd.h:42
CXTPDockingPaneTabbedContainer
CXTPDockingPaneTabbedContainer is a multiple inheritance class derived from CWnd and CXTPDockingPaneB...
Definition XTPDockingPaneTabbedContainer.h:47
CXTPImageManagerIcon
Icons holder class.
Definition XTPImageManager.h:622
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72


Toolkit Pro: Member List

CXTPSyntaxEditGoToLineDlg Member List

This is the complete list of members for CXTPSyntaxEditGoToLineDlg, including all inherited members.

CXTPSyntaxEditGoToLineDlg(CWnd *pParent=NULL) | CXTPSyntaxEditGoToLineDlg |
LoadPos() | CXTPSyntaxEditGoToLineDlg | protectedvirtual
m_bHideOnFind | CXTPSyntaxEditGoToLineDlg | protected
m_bSelectLine | CXTPSyntaxEditGoToLineDlg | protected
m_iMaxLineNo | CXTPSyntaxEditGoToLineDlg | protected
m_pEditCtrl | CXTPSyntaxEditGoToLineDlg | protected
m_ptWndPos | CXTPSyntaxEditGoToLineDlg | protected
SavePos() | CXTPSyntaxEditGoToLineDlg | protectedvirtual
ShowDialog(CXTPSyntaxEditCtrl *pEditCtrl, BOOL bSelectLine=FALSE, BOOL bHideOnFind=FALSE) | CXTPSyntaxEditGoToLineDlg |


Toolkit Pro: Member List

CXTPDockingPaneVisualStudio6Theme Member List

This is the complete list of members for CXTPDockingPaneVisualStudio6Theme, including all inherited members.

AdjustCaptionRect(const CXTPDockingPaneSidePanel *pPane, CRect &rc) | CXTPDockingPanePaintManager | virtual
AdjustCaptionRect(const CXTPDockingPaneTabbedContainer *pPane, CRect &rc) | CXTPDockingPanePaintManager | virtual
AdjustClientRect(CXTPDockingPaneSidePanel *pPane, CRect &rect) | CXTPDockingPanePaintManager | virtual
AdjustClientRect(CXTPDockingPaneTabbedContainer *pPane, CRect &rect, BOOL bApply) | CXTPDockingPanePaintManager | virtual
ClipAndAddEllipsisIfNeeded(CDC *pDC, CString &strTitle, int nCaptionWidth) const | CXTPDockingPanePaintManager | protected
CXTPCmdTarget() | CXTPCmdTarget |
CXTPDockingPaneDefaultTheme() | CXTPDockingPaneDefaultTheme |
CXTPDockingPaneGripperedTheme() | CXTPDockingPaneGripperedTheme |
CXTPDockingPanePaintManager() | CXTPDockingPanePaintManager | protected
CXTPDockingPaneVisualStudio6Theme() | CXTPDockingPaneVisualStudio6Theme |
DrawAutoHidePanel(CDC *pDC, CRect rc, XTPDockingPaneDirection direction) | CXTPDockingPanePaintManager | virtual
DrawCaption(CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc) | CXTPDockingPaneGripperedTheme | virtual
DrawCaptionButton(CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton) | CXTPDockingPanePaintManager | virtual
DrawCaptionButtonEntry(CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton, CSize szOffset) | CXTPDockingPanePaintManager | protectedvirtual
DrawCaptionButtonEntry(CDC *pDC, CXTPDockingPaneCaptionButton *pButton, CPoint pt, COLORREF clrButton) | CXTPDockingPanePaintManager | protectedvirtual
DrawCaptionButtons(CDC *pDC, CXTPDockingPaneCaptionButtons *pButtons, CRect &rcCaption, COLORREF clr, int nButtonSize, int nButtonGap, BOOL bVertical=FALSE) | CXTPDockingPanePaintManager | virtual
DrawCaptionPart(CDC *pDC, CXTPDockingPaneBase *pPane, CRect rcCaption, const CString &strTitle, BOOL bActive, BOOL bVertical) | CXTPDockingPaneVisualStudio6Theme | protectedvirtual
DrawCaptionText(CDC *pDC, const CString &strTitle, CRect rc, BOOL bVertical, BOOL bCalcWidth=FALSE) | CXTPDockingPanePaintManager |
DrawFloatingFrame(CDC *pDC, CXTPDockingPaneMiniWnd *pPane, CRect rc) | CXTPDockingPaneGripperedTheme | virtual
DrawPane(CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc) | CXTPDockingPanePaintManager | virtual
DrawSidePanel(CDC *pDC, CXTPDockingPaneSidePanel *pPane, CRect rc) | CXTPDockingPaneDefaultTheme | virtual
DrawSplitter(CDC *pDC, CXTPDockingPaneSplitterWnd *pSplitter) | CXTPDockingPanePaintManager | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCaptionButtonStyle() const | CXTPDockingPanePaintManager |
GetCaptionGripperRect(const CXTPDockingPaneTabbedContainer *pPane) | CXTPDockingPanePaintManager | virtual
GetCaptionHeight() const | CXTPDockingPanePaintManager |
GetCaptionRect(const CXTPDockingPaneTabbedContainer *pPane, CRect &rc) | CXTPDockingPanePaintManager | virtual
GetCurrentSystemTheme() const | CXTPDockingPanePaintManager |
GetCustomTitleBrush(BOOL bActive, BOOL bVertical) const | CXTPDockingPanePaintManager |
GetPaneCaptionRect(const CXTPDockingPaneSidePanel *pPane) | CXTPDockingPanePaintManager | virtual
GetPanelPaintManager() const | CXTPDockingPanePaintManager |
GetSplitterStyle() const | CXTPDockingPanePaintManager |
GetTabPaintManager() const | CXTPDockingPanePaintManager |
GetTabsHeight() const | CXTPDockingPanePaintManager |
GetXtremeColor(UINT nIndex) | CXTPDockingPanePaintManager |
Line(CDC *pDC, int x0, int y0, int x1, int y1, int nPen) | CXTPDockingPanePaintManager |
Line(CDC *pDC, int x0, int y0, int x1, int y1) | CXTPDockingPanePaintManager |
m_arrColor | CXTPDockingPanePaintManager | protected
m_bDestroyCustomTitleBrushes | CXTPDockingPanePaintManager | protected
m_bDrawCaptionIcon | CXTPDockingPanePaintManager |
m_bDrawSingleTab | CXTPDockingPanePaintManager |
m_bHighlightActiveCaption | CXTPDockingPanePaintManager |
m_bLunaTheme | CXTPDockingPanePaintManager | protected
m_bShowCaption | CXTPDockingPanePaintManager |
m_bUseBoldCaptionFont | CXTPDockingPanePaintManager |
m_bUseOfficeFont | CXTPDockingPanePaintManager | protected
m_bUseStandardFont | CXTPDockingPanePaintManager | protected
m_clrActiveCaption | CXTPDockingPanePaintManager |
m_clrActiveCaptionText | CXTPDockingPanePaintManager |
m_clrBackground | CXTPDockingPanePaintManager |
m_clrDisabledCaptionText | CXTPDockingPanePaintManager |
m_clrNormalCaption | CXTPDockingPanePaintManager |
m_clrNormalCaptionText | CXTPDockingPanePaintManager |
m_clrSplitter | CXTPDockingPanePaintManager |
m_clrSplitterGradient | CXTPDockingPanePaintManager |
m_clrSplitterGripper | CXTPDockingPanePaintManager |
m_dwSplitterStyle | CXTPDockingPanePaintManager | protected
m_hbrActiveTitleHorz | CXTPDockingPanePaintManager | protected
m_hbrActiveTitleVert | CXTPDockingPanePaintManager | protected
m_hbrInactiveTitleHorz | CXTPDockingPanePaintManager | protected
m_hbrInactiveTitleVert | CXTPDockingPanePaintManager | protected
m_nCaptionButtonStyle | CXTPDockingPanePaintManager | protected
m_nCaptionFontGap | CXTPDockingPanePaintManager | protected
m_nSplitterIndent | CXTPDockingPanePaintManager |
m_nSplitterSize | CXTPDockingPanePaintManager |
m_nTabsHeight | CXTPDockingPanePaintManager | protected
m_nTitleHeight | CXTPDockingPanePaintManager | protected
m_pPanelPaintManager | CXTPDockingPanePaintManager | protected
m_pTabPaintManager | CXTPDockingPanePaintManager | protected
m_rcCaptionMargin | CXTPDockingPanePaintManager | protected
m_strOfficeFont | CXTPDockingPanePaintManager | protected
m_systemTheme | CXTPDockingPanePaintManager | protected
m_themeButton | CXTPDockingPanePaintManager | protected
m_themeCurrent | CXTPDockingPanePaintManager | protected
m_themeExplorer | CXTPDockingPanePaintManager | protected
m_themeRebar | CXTPDockingPanePaintManager | protected
m_themeToolbar | CXTPDockingPanePaintManager | protected
m_themeWindow | CXTPDockingPanePaintManager | protected
m_xtpFontTitle | CXTPDockingPanePaintManager | protected
m_xtpFontTitleVertical | CXTPDockingPanePaintManager | protected
Pixel(CDC *pDC, int xPos, int yPos, int nPen) | CXTPDockingPanePaintManager |
Rectangle(CDC *pDC, CRect rc, int nPenEntry, int nPenBorder) | CXTPDockingPanePaintManager |
RefreshMetrics() | CXTPDockingPaneGripperedTheme | virtual
SetCaptionButtonStyle(XTPDockingPaneCaptionButtonStyle nStyle) | CXTPDockingPanePaintManager |
SetCaptionFontIndirect(LOGFONT *pLogFont, BOOL bUseStandardFont=FALSE) | CXTPDockingPanePaintManager |
SetColors(int cElements, CONST INT *lpaElements, CONST COLORREF *lpaRgbValues) | CXTPDockingPanePaintManager |
SetCustomTitleBrushes(HBRUSH hbrActiveTitleHorz, HBRUSH hbrInactiveTitleHorz=NULL, HBRUSH hbrActiveTitleVert=NULL, HBRUSH hbrInactiveTitleVert=NULL, BOOL bDestroyOnCleanup=FALSE) | CXTPDockingPanePaintManager |
SetLunaTheme(XTPCurrentSystemTheme systemTheme) | CXTPDockingPanePaintManager |
SetPanelPaintManager(CXTPTabPaintManager *pManager) | CXTPDockingPanePaintManager |
SetSplitterStyle(DWORD dwStyle) | CXTPDockingPanePaintManager |
SetTabPaintManager(CXTPTabPaintManager *pManager) | CXTPDockingPanePaintManager |
UseOfficeFont(BOOL bUseOfficeFont) | CXTPDockingPanePaintManager |
~CXTPDockingPanePaintManager() | CXTPDockingPanePaintManager | protectedvirtual


Toolkit Pro: XTPCalendarThemePrevNextEventButton.h Source File

  • Source
  • Calendar
XTPCalendarThemePrevNextEventButton.h
Go to the documentation of this file.
1
22#if !defined(__XTPCALENDARTHEMEPREVNEXTEVENTBUTTON_H__)
23# define __XTPCALENDARTHEMEPREVNEXTEVENTBUTTON_H__
24
25# if _MSC_VER > 1000
26# pragma once
27# endif // _MSC_VER > 1000
28
29# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
30
31class CTOPrevNextEventButtons;
32
33DECLARE_THEMEPART(CTOPrevNextEventButton, CXTPCalendarThemePart)
34
35 CXTPCalendarThemeIntValue m_nBitmapID;
36 CXTPCalendarThemeRectValue m_rcBitmapBorder;
37
38CXTPCalendarTheme::CThemeFontColorSetValue m_fcsetText;
39 CXTPPaintManagerColor m_clrDisabledText;
40 CXTPCalendarThemeStringValue m_strText;
41
42virtual void RefreshMetrics(BOOL bRefreshChildren = TRUE);
43
44virtual void DoPropExchange(CXTPPropExchange*){};
45virtual void Serialize(CArchive&){};
46
47virtual void AdjustLayout(CXTPCalendarView* pObject, CDC* pDC, const CRect& rcRect);
48virtual void Draw(CXTPCalendarView* pObject, CDC* pDC);
49using TBase::Draw;
50
51virtual int HitTest(const CPoint* pPoint = NULL)
52 const; // return 0, xtpCalendarHitTestPrevEventButton or xtpCalendarHitTestNextEventButton
53
54virtual void OnMouseMove(CCmdTarget* pObject, UINT nFlags, CPoint point);
55virtual BOOL OnLButtonDown(CCmdTarget* pObject, UINT nFlags, CPoint point,
56 CTOPrevNextEventButtons* pButtons);
57using TBase::OnLButtonDown;
58
59virtual CRect GetRect();
60
61CTOPrevNextEventButton();
62virtual ~CTOPrevNextEventButton();
63
64protected:
65CSize GetSize(const CRect* prcRect = NULL);
66BOOL m_bPrev;
67CRect m_rcRect;
68
69public:
70BOOL m_bHot;
71BOOL m_bDisabled;
72BOOL m_bVisible;
73}
74;
75
76# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
77
78#endif // __XTPCALENDARTHEMEPREVNEXTEVENTBUTTON_H__
pPoint
const CPoint * pPoint
return 0 or xtpCalendarHitTestDayExpandButton
Definition XTPCalendarThemeOffice2007.h:150
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCalendarThemeIntValue
Helper class provides functionality to manage customized int value objects.
Definition XTPCalendarViewPart.h:1070
CXTPCalendarThemeRectValue
Helper class provides functionality to manage customized CRect value objects.
Definition XTPCalendarViewPart.h:1176
CXTPCalendarThemeStringValue
Helper class provides functionality to manage customized string value objects.
Definition XTPCalendarViewPart.h:983
CXTPCalendarView
This class represents the view portion of the Calendar control.
Definition XTPCalendarView.h:360
CXTPPaintManagerColor
The CXTPPaintManagerColor class is used to manage COLORREF values for determining default and applica...
Definition XTPColorManager.h:117
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72


Toolkit Pro: Member List

CXTPCommandBarList Member List

This is the complete list of members for CXTPCommandBarList, including all inherited members.

Add(CXTPCommandBar *pCommandBar) | CXTPCommandBarList | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPCommandBarList(CXTPCommandBars *pCommandBars) | CXTPCommandBarList | inline
FindCommandBar(UINT nBarID) const | CXTPCommandBarList |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAt(int nIndex) const | CXTPCommandBarList |
GetCommandBars() const | CXTPCommandBarList | inline
GetCount() const | CXTPCommandBarList |
Lookup(CXTPCommandBar *pCommandBar) const | CXTPCommandBarList |
m_arrBars | CXTPCommandBarList | protected
m_pCommandBars | CXTPCommandBarList | protected
Remove(CXTPCommandBar *pCommandBar) | CXTPCommandBarList |
RemoveAll() | CXTPCommandBarList |
~CXTPCommandBarList() | CXTPCommandBarList | virtual


Toolkit Pro: XTPCalendarCaptionBarVisualStudio2017Theme.h Source File

  • Source
  • Calendar
  • CaptionBar
  • Themes
XTPCalendarCaptionBarVisualStudio2017Theme.h
Go to the documentation of this file.
1
22#if !defined(__XTPCALENDARCAPTIONBARVISUALSTUDIO2017THEME_H__)
23# define __XTPCALENDARCAPTIONBARVISUALSTUDIO2017THEME_H__
24
25# if _MSC_VER > 1000
26# pragma once
27# endif // _MSC_VER > 1000
28
29# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
30
36class _XTP_EXT_CLASS CXTPCalendarCaptionBarVisualStudio2017Theme
37 : public CXTPCalendarCaptionBarOffice2013Theme
38{
39public:
48 CXTPCalendarCaptionBarVisualStudio2017Theme(CXTPCalendarCaptionBarTheme* pTheme = NULL);
49
56 virtual ~CXTPCalendarCaptionBarVisualStudio2017Theme();
57};
58
59# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
60#endif // !defined(__XTPCALENDARCAPTIONBARVISUALSTUDIO2017THEME_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCalendarCaptionBarOffice2013Theme
CXTPCalendarCaptionBarOffice2013Theme is a CXTPCalendarCaptionBarOffice2003Theme derived class that r...
Definition XTPCalendarCaptionBarOffice2013Theme.h:38
CXTPCalendarCaptionBarTheme
This class CalendarCaptionBar control drawing, user interaction logic and interaction logic with atta...
Definition XTPCalendarCaptionBarTheme.h:48
CXTPCalendarCaptionBarVisualStudio2017Theme
CXTPCalendarCaptionBarVisualStudio2017Theme is a CXTPCalendarCaptionBarOffice2013Theme derived class ...
Definition XTPCalendarCaptionBarVisualStudio2017Theme.h:38
CXTPCalendarCaptionBarVisualStudio2017Theme::~CXTPCalendarCaptionBarVisualStudio2017Theme
virtual ~CXTPCalendarCaptionBarVisualStudio2017Theme()
Default paint manager destructor.
CXTPCalendarCaptionBarVisualStudio2017Theme::CXTPCalendarCaptionBarVisualStudio2017Theme
CXTPCalendarCaptionBarVisualStudio2017Theme(CXTPCalendarCaptionBarTheme *pTheme=NULL)
Default paint manager constructor.


Toolkit Pro: XTPResizePoint.h Source File

  • Source
  • Controls
  • Resize
XTPResizePoint.h
Go to the documentation of this file.
1
23#if !defined(__XTPRESIZEPOINT_H__)
24# define __XTPRESIZEPOINT_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
41struct XTP_RESIZEPOINT
42{
43 XTP_RESIZE x;
44 XTP_RESIZE y;
45};
46
55class _XTP_EXT_CLASS CXTPResizePoint : public XTP_RESIZEPOINT
56{
57public:
62 CXTPResizePoint();
63
70 CXTPResizePoint(XTP_RESIZE cx, XTP_RESIZE cy);
71};
72
106# define XTP_ANCHOR_BOTTOMCENTER CXTPResizePoint(.5, 1)
140# define XTP_ANCHOR_BOTTOMLEFT CXTPResizePoint(0, 1)
174# define XTP_ANCHOR_BOTTOMRIGHT CXTPResizePoint(1, 1)
208# define XTP_ANCHOR_MIDDLECENTER CXTPResizePoint(.5, .5)
242# define XTP_ANCHOR_MIDDLELEFT CXTPResizePoint(0, .5)
276# define XTP_ANCHOR_MIDDLERIGHT CXTPResizePoint(1, .5)
310# define XTP_ANCHOR_TOPLEFT CXTPResizePoint(0, 0)
344# define XTP_ANCHOR_TOPRIGHT CXTPResizePoint(1, 0)
378# define XTP_ANCHOR_TOPCENTER CXTPResizePoint(.5, 0)
379
380# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
382#endif // !defined(__XTPRESIZEPOINT_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTP_RESIZE
float XTP_RESIZE
The XTP_RESIZE data type is defined as a float and is used for storing single-precision floating poin...
Definition XTPResizeRect.h:41
CXTPResizePoint
CXTPResizePoint is an XTP_RESIZEPOINT structure derived class.
Definition XTPResizePoint.h:56
CXTPResizePoint::CXTPResizePoint
CXTPResizePoint(XTP_RESIZE cx, XTP_RESIZE cy)
Constructs a CXTPResizePoint object.
CXTPResizePoint::CXTPResizePoint
CXTPResizePoint()
Constructs a CXTPResizePoint object.
XTP_RESIZEPOINT
The XTP_RESIZEPOINT structure is used by the CXTPResizePoint class for defining single-precision floa...
Definition XTPResizePoint.h:42
XTP_RESIZEPOINT::y
XTP_RESIZE y
Specifies the y-coordinate of a point.
Definition XTPResizePoint.h:44
XTP_RESIZEPOINT::x
XTP_RESIZE x
Specifies the x-coordinate of a point.
Definition XTPResizePoint.h:43


Toolkit Pro: Member List

CXTPColorSelectorCtrlThemeVisualStudio2017 Member List

This is the complete list of members for CXTPColorSelectorCtrlThemeVisualStudio2017, including all inherited members.

CalcSize(CXTPColorSelectorCtrl *pOwner) | CXTPColorSelectorCtrlThemeOffice2013 | virtual
CreateAutoButton(CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked) | CXTPColorSelectorCtrlThemeOffice2013 | virtual
CreateColorButtons(CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked) | CXTPColorSelectorCtrlTheme | virtual
CreateExtendedButtons(CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked) | CXTPColorSelectorCtrlThemeOffice2013 | virtual
CreateMoreButton(CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked) | CXTPColorSelectorCtrlThemeOffice2013 | virtual
CreateRecentColorButtons(CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked) | CXTPColorSelectorCtrlThemeOffice2013 | virtual
CreateThemeButtons(CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked) | CXTPColorSelectorCtrlThemeOffice2013 | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPColorSelectorCtrlTheme() | CXTPColorSelectorCtrlTheme |
CXTPColorSelectorCtrlThemeOffice2013() | CXTPColorSelectorCtrlThemeOffice2013 |
CXTPColorSelectorCtrlThemeVisualStudio2015() | CXTPColorSelectorCtrlThemeVisualStudio2015 |
CXTPColorSelectorCtrlThemeVisualStudio2017() | CXTPColorSelectorCtrlThemeVisualStudio2017 |
CXTPControlTheme() | CXTPControlTheme |
DrawBorder(CDC *pDC, CRect rcItem, CRect rcBorder, COLORREF crBorder) | CXTPColorSelectorCtrlThemeOffice2013 | virtual
DrawColor(CDC *pDC, CXTPColorSelectorCtrl *pOwner, CXTPColorSelectorCtrl::COLOR_CELL *pColorCell, CRect rcItem, BOOL bChecked, BOOL bHighlight, BOOL bPressed) | CXTPColorSelectorCtrlThemeOffice2013 | virtual
DrawColorCell(CDC *pDC, CXTPColorSelectorCtrl *pOwner, CXTPColorSelectorCtrl::COLOR_CELL *pColorCell, BOOL bHighlight, BOOL bPressed) | CXTPColorSelectorCtrlThemeVisualStudio2015 | virtual
DrawColorSelector(CDC *pDC, CXTPColorSelectorCtrl *pOwner) | CXTPColorSelectorCtrlThemeOffice2013 | virtual
FillBackground(CDC *pDC, CXTPColorSelectorCtrl *pOwner, const CRect &rect) | CXTPColorSelectorCtrlTheme | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetButtonSize() const | CXTPColorSelectorCtrlTheme | virtual
GetThemeStyle() const | CXTPControlTheme |
m_bThinBorder | CXTPColorSelectorCtrlTheme |
m_crBack | CXTPColorSelectorCtrlTheme |
m_crBackChecked | CXTPColorSelectorCtrlTheme |
m_crBackHilight | CXTPColorSelectorCtrlTheme |
m_crBackPressed | CXTPColorSelectorCtrlTheme |
m_crBorder | CXTPColorSelectorCtrlTheme |
m_crBorderHilight | CXTPColorSelectorCtrlTheme |
m_crBorderInside | CXTPColorSelectorCtrlThemeOffice2013 | protected
m_crBorderPressed | CXTPColorSelectorCtrlTheme |
m_crPopupBorder | CXTPColorSelectorCtrlTheme |
m_crText | CXTPColorSelectorCtrlTheme |
m_crTextPressed | CXTPColorSelectorCtrlTheme |
m_crTitleBack | CXTPColorSelectorCtrlThemeOffice2013 | protected
m_crTitleText | CXTPColorSelectorCtrlThemeOffice2013 | protected
m_nAutoButton | CXTPColorSelectorCtrlTheme |
m_nCaption | CXTPColorSelectorCtrlTheme |
m_nMargin | CXTPColorSelectorCtrlTheme |
m_nTheme | CXTPControlTheme | protected
m_rcRecentText | CXTPColorSelectorCtrlTheme |
m_rcStandardText | CXTPColorSelectorCtrlTheme |
m_rcThemeText | CXTPColorSelectorCtrlTheme |
m_sizeButton | CXTPColorSelectorCtrlTheme |
RefreshMetrics(CXTPColorSelectorCtrl *pOwner) | CXTPColorSelectorCtrlThemeVisualStudio2015 | virtual
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static


Toolkit Pro: Member List

CXTPComboBoxThemeVisualStudio2019 Member List

This is the complete list of members for CXTPComboBoxThemeVisualStudio2019, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPComboBoxTheme() | CXTPComboBoxTheme |
CXTPComboBoxThemeOffice2003() | CXTPComboBoxThemeOffice2003 |
CXTPComboBoxThemeOffice2013() | CXTPComboBoxThemeOffice2013 |
CXTPComboBoxThemeVisualStudio() | CXTPComboBoxThemeVisualStudio |
CXTPComboBoxThemeVisualStudio2019() | CXTPComboBoxThemeVisualStudio2019 |
CXTPControlTheme() | CXTPControlTheme |
DrawBackground(CDC *pDC, CXTPComboBox *pComboBox) | CXTPComboBoxThemeOffice2013 | virtual
DrawButton(CDC *pDC, CXTPComboBox *pComboBox, CRect rcBtn) | CXTPComboBoxThemeVisualStudio2019 | virtual
DrawButtonTriangle(CDC *pDC, CXTPComboBox *pComboBox, CRect rcBtn) | CXTPComboBoxThemeOffice2013 | virtual
DrawComboBox(CDC *pDC, CXTPComboBox *pComboBox) | CXTPComboBoxTheme | virtual
DrawFrame(HDC hdc, LPRECT lprc, int nSize, HBRUSH hBrush) | CXTPComboBoxTheme | virtual
FillSolidRect(HDC hdc, int x, int y, int cx, int cy, HBRUSH hBrush) | CXTPComboBoxTheme | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetBackColor() const | CXTPComboBoxTheme |
GetBackgroundBrush() const | CXTPComboBoxTheme |
GetTextColor() const | CXTPComboBoxTheme |
GetThemeStyle() const | CXTPControlTheme |
m_clrBackDisabled | CXTPComboBoxTheme |
m_clrBackground | CXTPComboBoxTheme |
m_clrBackHighlight | CXTPComboBoxTheme |
m_clrBorderDisabled | CXTPComboBoxTheme |
m_clrBorderHot | CXTPComboBoxTheme |
m_clrBorderNormal | CXTPComboBoxTheme |
m_clrButtonArrowDisabled | CXTPComboBoxThemeOffice2013 | protected
m_clrButtonArrowHot | CXTPComboBoxTheme |
m_clrButtonArrowNormal | CXTPComboBoxTheme |
m_clrButtonArrowPressed | CXTPComboBoxTheme |
m_clrButtonDisabled | CXTPComboBoxThemeOffice2013 | protected
m_clrButtonHot | CXTPComboBoxTheme |
m_clrButtonNormal | CXTPComboBoxTheme |
m_clrButtonPressed | CXTPComboBoxTheme |
m_clrText | CXTPComboBoxTheme |
m_clrTextDisabled | CXTPComboBoxTheme |
m_clrTextHighlight | CXTPComboBoxTheme |
m_grcButton | CXTPComboBoxTheme |
m_grcButtonHilite | CXTPComboBoxTheme |
m_grcButtonPushed | CXTPComboBoxTheme |
m_nTheme | CXTPControlTheme | protected
m_nThumbWidth | CXTPComboBoxTheme | protected
m_themeComboBox | CXTPComboBoxTheme | protected
m_xtpBrushBackground | CXTPComboBoxTheme | protected
RefreshMetrics(CXTPComboBox *pComboBox) | CXTPComboBoxThemeVisualStudio2019 | virtual
ResetBackColor() | CXTPComboBoxTheme |
ResetTextColor() | CXTPComboBoxTheme |
SetBackColor(COLORREF clrBackground) | CXTPComboBoxTheme |
SetTextColor(COLORREF clrText) | CXTPComboBoxTheme |
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static
UpdateBackgroundBrush() | CXTPComboBoxTheme | protected
~CXTPComboBoxTheme() | CXTPComboBoxTheme | virtual
~CXTPComboBoxThemeOffice2003() | CXTPComboBoxThemeOffice2003 | virtual
~CXTPComboBoxThemeOffice2013() | CXTPComboBoxThemeOffice2013 | virtual
~CXTPComboBoxThemeVisualStudio() | CXTPComboBoxThemeVisualStudio | virtual
~CXTPComboBoxThemeVisualStudio2019() | CXTPComboBoxThemeVisualStudio2019 | virtual


Toolkit Pro: Member List

CXTPGridRecordItemEditOptions Member List

This is the complete list of members for CXTPGridRecordItemEditOptions, including all inherited members.

AddComboButton(BOOL bInside=FALSE) | CXTPGridRecordItemEditOptions |
AddConstraint(LPCTSTR lpszConstraint, DWORD_PTR dwData=0) | CXTPGridRecordItemEditOptions |
AddExpandButton(BOOL bInside=FALSE) | CXTPGridRecordItemEditOptions |
AddSpinButton(BOOL bInside=FALSE) | CXTPGridRecordItemEditOptions |
arrInplaceButtons | CXTPGridRecordItemEditOptions |
CXTPCmdTarget() | CXTPCmdTarget |
CXTPGridRecordItemEditOptions() | CXTPGridRecordItemEditOptions |
FindConstraint(DWORD_PTR dwData) | CXTPGridRecordItemEditOptions |
FindConstraint(LPCTSTR lpszConstraint) | CXTPGridRecordItemEditOptions |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetButton(int nIndex) | CXTPGridRecordItemEditOptions |
GetConstraints() | CXTPGridRecordItemEditOptions | inline
m_bAllowEdit | CXTPGridRecordItemEditOptions |
m_bConstraintEdit | CXTPGridRecordItemEditOptions |
m_bExpandOnSelect | CXTPGridRecordItemEditOptions |
m_bScrollTextOnEdit | CXTPGridRecordItemEditOptions |
m_bSelectTextOnEdit | CXTPGridRecordItemEditOptions |
m_dwEditStyle | CXTPGridRecordItemEditOptions |
m_nMaxLength | CXTPGridRecordItemEditOptions |
m_pConstraints | CXTPGridRecordItemEditOptions |
RemoveButtons() | CXTPGridRecordItemEditOptions |
~CXTPGridRecordItemEditOptions() | CXTPGridRecordItemEditOptions |


Toolkit Pro: Member List

CXTPTabManagerNavigateButtons Member List

This is the complete list of members for CXTPTabManagerNavigateButtons, including all inherited members.

Add(CXTPTabManagerNavigateButton *pButton) | CXTPTabManagerNavigateButtons |
CXTPTabManagerNavigateButtons() | CXTPTabManagerNavigateButtons |
GetAt(int nIndex) const | CXTPTabManagerNavigateButtons |
GetSize() const | CXTPTabManagerNavigateButtons |
InsertAt(int nIndex, CXTPTabManagerNavigateButton *pButton) | CXTPTabManagerNavigateButtons |
m_arrButtons | CXTPTabManagerNavigateButtons | protected
operator[](int nIndex) const | CXTPTabManagerNavigateButtons |
RemoveAll() | CXTPTabManagerNavigateButtons |
RemoveAt(int nIndex) | CXTPTabManagerNavigateButtons |
~CXTPTabManagerNavigateButtons() | CXTPTabManagerNavigateButtons | virtual


Toolkit Pro: Member List

CXTPChartDeviceCommandEvents Member List

This is the complete list of members for CXTPChartDeviceCommandEvents, including all inherited members.

CXTPChartDeviceCommandEvents() | CXTPChartDeviceCommandEvents | protected
OnAfterExecute(CXTPChartDeviceCommand *pCommand, CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommandEvents | virtual
OnBeforeExecute(CXTPChartDeviceCommand *pCommand, CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommandEvents | virtual
OnUnsubscribe(CXTPChartDeviceCommand *pCommand) | CXTPChartDeviceCommandEvents |
OnUpdateBounds(CXTPChartDeviceCommand *pCommand, CRect rcBounds) | CXTPChartDeviceCommandEvents | virtual


Toolkit Pro: Member List

CXTPChart3dPieSeriesView Member List

This is the complete list of members for CXTPChart3dPieSeriesView, including all inherited members.

AddChildView(CXTPChartElementView *pChildView) | CXTPChartElementView |
CalculateLabelLayout(CXTPChartDeviceContext *pDC) | CXTPChartPieSeriesViewBase | virtual
CalculatePointLayout(CXTPChartDeviceContext *pDC, CRect rcBounds) | CXTPChart3dPieSeriesView | virtual
CreateDeviceCommand(CXTPChartDeviceContext *pDC) | CXTPChart3dPieSeriesView | protectedvirtual
CreateDiagramDomain(CXTPChartDeviceContext *pDC, CRect rcBounds) | CXTPChartPieSeriesViewBase | virtual
CreateLegendDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcBounds) | CXTPChart3dPieSeriesView | protectedvirtual
CreateSeriesPointView(CXTPChartDeviceContext *pDC, CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView) | CXTPChart3dPieSeriesView | protectedvirtual
CXTPChart3dPieSeriesView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView) | CXTPChart3dPieSeriesView |
CXTPChartElementView(CXTPChartElementView *pParentView) | CXTPChartElementView |
CXTPChartElementView(CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartElementView |
CXTPChartElementView(CXTPChartContainer *pContainer) | CXTPChartElementView |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartPieSeriesViewBase(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView) | CXTPChartPieSeriesViewBase | protected
GetAt(int nIndex) const | CXTPChartElementView |
GetBounds() const | CXTPChartElementView |
GetBounds(BOOL bIncludingChildren) const | CXTPChartElementView |
GetChildren() | CXTPChartElementView |
GetCount() const | CXTPChartElementView |
GetDomain() const | CXTPChartPieSeriesViewBase |
GetInnerBounds() const | CXTPChartPieSeriesViewBase |
GetMaxLabelWidth() const | CXTPChartPieSeriesViewBase |
GetParentView() const | CXTPChartElementView |
Is3D() const | CXTPChartObject |
m_arrChildren | CXTPChartElementView | protected
m_pContainer | CXTPChartElementView | protected
m_pParentView | CXTPChartElementView | protected
m_rcBounds | CXTPChartElementView | protected
~CXTPChartElementView() | CXTPChartElementView | protectedvirtual
~CXTPChartLegendItemView() | CXTPChartLegendItemView | inlinevirtual
~CXTPChartPieSeriesViewBase() | CXTPChartPieSeriesViewBase | virtual


Toolkit Pro: Member List

CXTPControlGallery Member List

This is the complete list of members for CXTPControlGallery, including all inherited members.

AdjustExcludeRect(CRect &rc, BOOL bVertical) | CXTPControlPopup | virtual
AssignDocTemplate(UINT nIDResource) | CXTPControl |
ClickToolBarButton(CRect rcActiveRect=CRect(0, 0, 0, 0)) | CXTPControl | protected
Compare(CXTPControl *pOther) | CXTPControlPopup | protectedvirtual
ContainsPopup(CXTPControlPopup *pControlPopup) | CXTPControlPopup | protected
Copy(CXTPControl *pControl, BOOL bRecursive=FALSE) | CXTPControlGallery | protectedvirtual
CreateControlPopup(XTPControlType controlType) | CXTPControlPopup | static
CustomizeStartDrag(CPoint point) | CXTPControl | protectedvirtual
CustomizeStartResize(CPoint point) | CXTPControl | protectedvirtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPControl() | CXTPControl | protected
CXTPControlButton() | CXTPControlButton |
CXTPControlGallery() | CXTPControlGallery |
CXTPControlPopup() | CXTPControlPopup |
CXTPScrollBase() | CXTPScrollBase |
DelayLayoutParent() | CXTPControl |
DelayRedrawParent() | CXTPControl |
DoCustomDragOver(CXTPCommandBar *pCommandBar, CPoint point, DROPEFFECT &dropEffect) | CXTPControlPopup | protectedvirtual
DoPropExchange(CXTPPropExchange *pPX) | CXTPControlGallery | protectedvirtual
Draw(CDC *pDC) | CXTPControl | virtual
DrawItems(CDC *pDC) | CXTPControlGallery | protected
EnsureVisible(int nIndex) | CXTPControlGallery |
ExcludeDocTemplate(UINT nIDResource) | CXTPControl |
ExpandCommandBar() | CXTPControlPopup | protected
FindItem(int nStartAfter, LPCTSTR lpszItem, BOOL bExact) const | CXTPControlGallery |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
FromUI(CCmdUI *pCmdUI) | CXTPControl | static
GenerateCommandBarList(DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam) | CXTPControl | protectedvirtual
GetAction() const | CXTPControl |
GetBeginGroup() const | CXTPControl |
GetBorders() const | CXTPControlGallery | virtual
GetButtonSize() const | CXTPControl | virtual
GetCaption() const | CXTPControlPopup | virtual
GetCategory() const | CXTPControl |
GetChecked() const | CXTPControl |
GetCheckedItem() const | CXTPControlGallery |
GetCloseSubMenuOnClick() const | CXTPControl |
GetCltColor(CDC *pDC) const | CXTPScrollBase |
GetCommandBar() const | CXTPControlPopup | virtual
GetControls() const | CXTPControl |
GetCustomizeMinHeight() const | CXTPControl | protectedvirtual
GetCustomizeMinWidth() const | CXTPControl | protectedvirtual
GetCustomShortcutText() const | CXTPControl |
GetDescription() const | CXTPControl | virtual
GetEnabled() const | CXTPControl |
GetExecuteOnPressInterval() const | CXTPControl |
GetExpanded() const | CXTPControl |
GetFlags() const | CXTPControl |
GetGalleryPaintManager() const | CXTPControlGallery |
GetHeight() const | CXTPControl |
GetHelpId() const | CXTPControl |
GetHideFlags() const | CXTPControl |
GetIconId() const | CXTPControl |
GetIconSize() const | CXTPControl | virtual
GetID() const | CXTPControl |
GetImage(int nWidth=16) const | CXTPControl | virtual
GetImageManager() const | CXTPControl |
GetIndex() const | CXTPControl |
GetItem(int nIndex) const | CXTPControlGallery |
GetItemCaption(int nIndex) | CXTPControlGallery |
GetItemCount() const | CXTPControlGallery |
GetItemDrawRect(int nIndex) | CXTPControlGallery |
GetItems() const | CXTPControlGallery | virtual
GetItemsRect() const | CXTPControlGallery |
GetKeyboardTip() const | CXTPControl |
GetNext(long nIndex, int nDirection) const | CXTPControlGallery |
GetNextInColumn(long nIndex, int nDirection) const | CXTPControlGallery |
GetNextInPage(long nIndex, int nDirection) const | CXTPControlGallery |
GetNextInRow(long nIndex, int nDirection) const | CXTPControlGallery |
GetPaintManager() const | CXTPControl |
GetParameter() const | CXTPControl |
GetParent() const | CXTPControl |
GetParentWindow() const =0 | CXTPScrollBase | pure virtual
GetPopuped() const | CXTPControlPopup | virtual
GetPressed() const | CXTPControl | virtual
GetRect() const | CXTPControl |
GetRibbonGroup() const | CXTPControl |
GetRowRect() const | CXTPControl |
GetScrollBarPaintManager() const | CXTPControlGallery | virtual
GetScrollBarPartRect(int nPart) const | CXTPScrollBase |
GetScrollBarPosInfo() | CXTPScrollBase |
GetScrollBarRect()=0 | CXTPScrollBase | pure virtual
GetScrollBarStyle() const | CXTPScrollBase |
GetScrollBarTrackInfo() const | CXTPScrollBase |
GetScrollInfo(SCROLLINFO *psi)=0 | CXTPScrollBase | pure virtual
GetScrollPos() const | CXTPControlGallery |
GetSelected() const | CXTPControl | virtual
GetSelectedItem() const | CXTPControlGallery |
GetShortcutText() const | CXTPControl |
GetSize(CDC *pDC) | CXTPControl | virtual
GetStyle() const | CXTPControl |
GetStyleEx() const | CXTPControlButton |
GetTag() const | CXTPControl |
GetTicks() const | CXTPScrollBase |
GetTooltip() const | CXTPControl | virtual
GetType() const | CXTPControl |
GetWidth() const | CXTPControl |
GetWrap() const | CXTPControl |
HasBottomSeparator() const | CXTPControlGallery |
HasDwmCompositedRect() const | CXTPControl |
HideSelection() | CXTPControlGallery |
HitTestItem(CPoint point, LPRECT lpRect=NULL) const | CXTPControlGallery |
HitTestScrollBar(POINT pt) const | CXTPScrollBase |
InvalidateItems(LPCRECT lpRect=NULL, BOOL bAnimate=TRUE) | CXTPControlGallery |
IsCaptionVisible() const | CXTPControl | virtual
IsCursorOver() const | CXTPControl |
IsCustomizeMode() const | CXTPControl | protected
IsCustomizeMovable() const | CXTPControl | virtual
IsCustomizeResizeAllow() const | CXTPControl | protectedvirtual
IsFocusable() const | CXTPControl | protectedvirtual
IsFocused() const | CXTPControl | virtual
IsItemChecked(CXTPControlGalleryItem *pItem) const | CXTPControlGallery | virtual
IsItemDefault() const | CXTPControl |
IsItemSelected() const | CXTPControlGallery |
IsLayoutChanged() | CXTPControl | protected
IsLayoutRTL() const | CXTPControl | protected
IsOnQuickAccess() const | CXTPControl |
IsResizable() const | CXTPControlGallery |
IsScrollBarAuto() const | CXTPControlGallery |
IsScrollBarEnabled() const | CXTPControlGallery | virtual
IsScrollBarVisible() const | CXTPControlGallery |
IsScrollButtonEnabled(int ht) | CXTPControlGallery |
IsShowBorders() const | CXTPControlGallery |
IsShownAsButton() const | CXTPControlGallery |
IsSlider() const | CXTPScrollBase |
IsTemporary() const | CXTPControl |
IsTransparent() const | CXTPControlGallery | virtual
IsVisible(DWORD dwSkipFlags=0) const | CXTPControl | virtual
m_arrRects | CXTPControlGallery | protected
m_bAnimation | CXTPScrollBase | protected
m_bAutoScaleDpi | CXTPControlGallery | static
m_bBeginGroup | CXTPControl | protected
m_bChecked | CXTPControl | protected
m_bCloseSubMenuOnClick | CXTPControl | protected
m_bDefaultItem | CXTPControl | protected
m_bEnabled | CXTPControl | protected
m_bExpanded | CXTPControl | protected
m_bHideSelection | CXTPControlGallery | protected
m_bKeyboardSelected | CXTPControlGallery | protected
m_bLayoutRTL | CXTPControl | protected
m_bOnQuickAccess | CXTPControl | protected
m_bPopup | CXTPControlPopup | protected
m_bPressed | CXTPControlGallery | protected
m_bPreview | CXTPControlGallery | protected
m_bSelected | CXTPControl | protected
m_bShowBorders | CXTPControlGallery | protected
m_bShowLabels | CXTPControlGallery | protected
m_bShowScrollBar | CXTPControlGallery | protected
m_bShowShadow | CXTPControlPopup | protected
m_bTemporary | CXTPControl | protected
m_buttonCustomStyle | CXTPControl | protected
m_buttonRibbonStyle | CXTPControl | protected
m_buttonStyle | CXTPControl | protected
m_buttonStyleEx | CXTPControlButton | protected
m_bWrap | CXTPControl | protected
m_controlType | CXTPControl | protected
m_dAnimationStep | CXTPControlGallery | protected
m_dwCommandBarID | CXTPControlPopup | protected
m_dwFlags | CXTPControl | protected
m_dwHideFlags | CXTPControl | protected
m_mapDocTemplatesAssigned | CXTPControl | protected
m_mapDocTemplatesExcluded | CXTPControl | protected
m_nChecked | CXTPControlGallery | protected
m_nCustomIconId | CXTPControl | protected
m_nExecuteOnPressInterval | CXTPControl | protected
m_nHeight | CXTPControl | protected
m_nHelpId | CXTPControl | protected
m_nIconId | CXTPControl | protected
m_nId | CXTPControl | protected
m_nIndex | CXTPControl | protected
m_nResizable | CXTPControlGallery | protected
m_nScrollPos | CXTPControlGallery | protected
m_nScrollPosTarget | CXTPControlGallery | protected
m_nSelected | CXTPControlGallery | protected
m_nTag | CXTPControl | protected
m_nTimerElapse | CXTPScrollBase | protected
m_nTotalHeight | CXTPControlGallery | protected
m_nWidth | CXTPControl | protected
m_pAction | CXTPControl | protected
m_pCommandBar | CXTPControlPopup | protected
m_pControls | CXTPControl | protected
m_pParent | CXTPControl | protected
m_pRibbonGroup | CXTPControl | protected
m_pSBTrack | CXTPScrollBase | protected
m_pTicks | CXTPScrollBase | protected
m_ptPressed | CXTPControlGallery | protected
m_rcControl | CXTPControl | protected
m_rcMargin | CXTPControlGallery | protected
m_rcRow | CXTPControl | protected
m_scrollBarStyle | CXTPScrollBase | protected
m_spi | CXTPScrollBase | protected
m_strCaption | CXTPControl | protected
m_strCategory | CXTPControl | protected
m_strCustomCaption | CXTPControl | protected
m_strDescriptionText | CXTPControl | protected
m_strKeyboardTip | CXTPControl | protected
m_strParameter | CXTPControl | protected
m_strShortcutText | CXTPControl | protected
m_strShortcutTextAuto | CXTPControl | protected
m_strTooltipText | CXTPControl | protected
m_szIcon | CXTPControl | protected
NotifySite(UINT code) | CXTPControl |
NotifySite(UINT code, NMXTPCONTROL *pNM) | CXTPControl |
NotifySite(CWnd *pSite, UINT code, NMXTPCONTROL *pNM) | CXTPControl |
OnActionChanged(int nProperty) | CXTPControl | protectedvirtual
OnActionChanging(int nProperty) | CXTPControl | protectedvirtual
OnCalcDynamicSize(DWORD dwMode) | CXTPControlGallery | protectedvirtual
OnCaptionChanged() | CXTPControl | protectedvirtual
OnClick(BOOL bKeyboard=FALSE, CPoint pt=CPoint(0, 0)) | CXTPControlPopup | protectedvirtual
OnCustomizeDragOver(CXTPControl *pDataObject, CPoint point, DROPEFFECT &dropEffect) | CXTPControlPopup | protectedvirtual
OnCustomizeMouseMove(CPoint point) | CXTPControl | protected
OnEnabledChanged() | CXTPControl | virtual
OnExecute() | CXTPControl | virtual
OnHookKeyDown(UINT nChar, LPARAM lParam) | CXTPControl | protectedvirtual
OnHookMouseWheel(UINT nFlags, short zDelta, CPoint point) | CXTPControl | protectedvirtual
OnIdleUpdate() | CXTPControl | protectedvirtual
OnLButtonDblClk(CPoint point) | CXTPControlPopup | protectedvirtual
OnLButtonDown(CPoint point) | CXTPControl | protectedvirtual
OnLButtonUp(CPoint point) | CXTPControlPopup | protectedvirtual
OnMouseHover() | CXTPControlPopup | protectedvirtual
OnMouseMove(CPoint point) | CXTPControlPopup | protectedvirtual
OnRButtonDown(CPoint point) | CXTPControl | protectedvirtual
OnRButtonUp(CPoint point) | CXTPControl | protectedvirtual
OnRemoved() | CXTPControl | protectedvirtual
OnSelectedItemChanged() | CXTPControlGallery | virtual
OnSetPopup(BOOL bPopup) | CXTPControlPopup | protectedvirtual
OnSetSelected(int bSelected) | CXTPControlPopup | protectedvirtual
OnThemeChanged() | CXTPControl | virtual
OnToolHitTest(CPoint point, TOOLINFO *pTI) const | CXTPControl | protectedvirtual
OnUnderlineActivate() | CXTPControlPopup | virtual
PerformTrackInit(HWND hWnd, CPoint point, XTP_SCROLLBAR_POSINFO *pSBInfo, BOOL bDirect) | CXTPScrollBase |
RedrawParent(BOOL bAnimate=TRUE) | CXTPControl |
RedrawScrollBar()=0 | CXTPScrollBase | pure virtual
Reposition() | CXTPControlGallery | protected
Reset() | CXTPControl |
RestoreCommandBarList(CXTPCommandBarList *pCommandBarList) | CXTPControlPopup | protectedvirtual
ScreenToClient(CPoint *point) | CXTPControl | protected
SetAction(CXTPControlAction *pAction) | CXTPControl | virtual
SetBeginGroup(BOOL bBeginGroup) | CXTPControl | virtual
SetCaption(LPCTSTR lpszCaption) | CXTPControl |
SetCaption(UINT nIDCaption) | CXTPControl |
SetCategory(LPCTSTR lpszCategory) | CXTPControl |
SetChecked(BOOL bChecked) | CXTPControl | virtual
SetCheckedItem(int nId) | CXTPControlGallery |
SetCloseSubMenuOnClick(BOOL bCloseOnClick) | CXTPControl |
SetCommandBar(CMenu *pMenu) | CXTPControlPopup |
SetCommandBar(CXTPCommandBar *pBar) | CXTPControlPopup |
SetControlSize(CSize szControl) | CXTPControlGallery |
SetControlSize(int nColumns, int nRows, CSize szItem) | CXTPControlGallery |
SetCustomIcon(HICON hIcon) | CXTPControl |
SetCustomShortcutText(LPCTSTR lpszCustomShortcutText) | CXTPControl |
SetDescription(LPCTSTR lpszDescription) | CXTPControl |
SetEnabled(BOOL bEnabled) | CXTPControl | virtual
SetExecuteOnPressInterval(int nExecuteOnPressInterval) | CXTPControl |
SetExpanded(BOOL bExpanded) | CXTPControl | protected
SetFlags(DWORD dwFlags) | CXTPControl |
SetFocused(BOOL bFocused) | CXTPControl | virtual
SetHeight(int nHeight) | CXTPControl | virtual
SetHelpId(int nId) | CXTPControl |
SetHideFlag(XTPControlHideFlags dwFlag, BOOL bSet) | CXTPControl |
SetHideFlags(DWORD dwFlags) | CXTPControl | virtual
SetHideWrap(BOOL bHide) | CXTPControl |
SetIconId(int nId) | CXTPControl |
SetIconSize(CSize szIcon) | CXTPControl |
SetID(int nId) | CXTPControl |
SetIndex(int nIndex) | CXTPControl | inlineprotected
SetItemDefault(BOOL bDefault) | CXTPControl |
SetItems(CXTPControlGalleryItems *pItems) | CXTPControlGallery |
SetItemsMargin(int nLeft, int nTop, int nRight, int nBottom) | CXTPControlGallery |
SetKeyboardTip(LPCTSTR lpszKeyboardTip) | CXTPControl |
SetOnQuickAccess(BOOL bOnQuicAccess=FALSE) | CXTPControl |
SetParameter(LPCTSTR lpszParameter) | CXTPControl |
SetParent(CXTPCommandBar *pParent) | CXTPControl | inlineprotectedvirtual
SetPressed(BOOL bPressed) | CXTPControl |
SetPrompt(LPCTSTR lpszPrompt) | CXTPControl |
SetRect(CRect rcControl) | CXTPControl | virtual
SetResizable(BOOL bResizeWidth=TRUE, BOOL bResizeHeight=TRUE) | CXTPControlGallery |
SetRowRect(CRect rcRow) | CXTPControl |
SetScrollBarAuto(BOOL bScrollBarAuto) | CXTPControlGallery |
SetScrollBarStyle(XTPScrollBarStyle scrollStyle) | CXTPScrollBase |
SetScrollPos(int nScrollPos) | CXTPControlGallery |
SetSelectedItem(int nSelected) | CXTPControlGallery |
SetShortcutText(LPCTSTR lpszShortcutText) | CXTPControl |
SetStyle(XTPButtonStyle buttonStyle) | CXTPControl |
SetStyleEx(XTPButtonStyle buttonStyle) | CXTPControlButton |
SetTag(DWORD_PTR dwTag) | CXTPControl |
SetTicks(double *pTicks, int nCount) | CXTPScrollBase |
SetTooltip(LPCTSTR lpszTooltip) | CXTPControl |
SetTopIndex(int nIndex) | CXTPControlGallery |
SetVisible(BOOL bVisible) | CXTPControl |
SetWidth(int nWidth) | CXTPControl | virtual
SetWrap(BOOL bWrap) | CXTPControl |
ShowBorders(BOOL bShowBorders) | CXTPControlGallery |
ShowLabels(BOOL bShowLabels) | CXTPControlGallery |
ShowScrollBar(BOOL bShowScrollBar) | CXTPControlGallery |
UpdateShadow() | CXTPControlPopup | protectedvirtual
~CXTPControl() | CXTPControl | protectedvirtual
~CXTPControlButton() | CXTPControlButton | virtual
~CXTPControlGallery() | CXTPControlGallery |
~CXTPControlPopup() | CXTPControlPopup | virtual
~CXTPScrollBase() | CXTPScrollBase | virtual


Toolkit Pro: Member List

CXTPCalendarResourceTheme Member List

This is the complete list of members for CXTPCalendarResourceTheme, including all inherited members.

_GetAtGrow_BusyStatusBrushValue(int eBusyStatus, BOOL bGrow) | CXTPCalendarPaintManager | protected
_Init() | CXTPCalendarPaintManager | virtual
AddViewPart(CXTPCalendarViewPart *pPart) | CXTPCalendarPaintManager | protected
AdjustTimeFont(CDC *pDC, CRect rcCell) | CXTPCalendarPaintManager |
BEGIN_VIEW_PART(ControlPart, XTPCalendarViewPart) virtual void RefreshMetrics() | CXTPCalendarPaintManager |
CalcEventSize(CDC *c, CXTPCalendarTimeLineViewEvent *pViewEvent) | CXTPCalendarPaintManager | virtual
CalcWidth(CDC *pDC, const CString &strHour, const CString &strMin, int nHourHeight, int &nWidth) | CXTPCalendarPaintManager |
CXTPCalendarPaintManager() | CXTPCalendarPaintManager |
CXTPCalendarResourceTheme() | CXTPCalendarResourceTheme |
CXTPCmdTarget() | CXTPCmdTarget |
DrawBigHourCell(CDC *pDC, CRect rc, CString strHour, CString strMin, int nRowPerHour, BOOL bFillBackground=TRUE, BOOL bCurrentTime=FALSE) | CXTPCalendarPaintManager | virtual
DrawBitmap(CImageList *pImageList, CDC *pDC, CRect rcView, int iIcon, UINT uFlags=0) | CXTPCalendarPaintManager | virtual
DrawBitmap(UINT nIDResource, CDC *pDC, CRect rcBitmap) | CXTPCalendarPaintManager | virtual
DrawBorder(CDC *pDC, CRect rcView, CXTPCalendarWeekViewEvent *pWeekViewEvent) | CXTPCalendarPaintManager | virtual
DrawBusyStatus(CDC *pDC, CRect &rcRect, int eBusyStatus) | CXTPCalendarPaintManager | virtual
DrawBusyStatus(CDC *pDC, CRgn &rgnBusy, int eBusyStatus) | CXTPCalendarPaintManager | virtual
DrawClock(CDC *pDC, COleDateTime dtClockTime, CRect rcView, COLORREF clrBackground, XTPCalendarClockAlignFlags cafAlign) | CXTPCalendarPaintManager | virtual
DrawDayHeader(CDC *pDC, CRect rcDay, int nHeaderHeight, CString strHeader, BOOL bIsCurrent=FALSE, BOOL bIsSelected=FALSE) | CXTPCalendarPaintManager | virtual
DrawEvent(CDC *pDC, const CRect &rcEvents, CXTPCalendarTimeLineViewEvent *pViewEvent) | CXTPCalendarPaintManager | virtual
DrawExpandSigns(CDC *pDC, CXTPCalendarDayView *pView, const CRect &rcTSHours) | CXTPCalendarPaintManager | virtual
DrawGroup(CDC *pDC, const CRect &rcRect, CXTPCalendarTimeLineViewGroup *pGroup) | CXTPCalendarPaintManager | virtual
DrawHeader(CDC *pDC, CRect &rcHeader, BOOL bIsSelected, BOOL bIsCurrent) | CXTPCalendarPaintManager | virtual
DrawHeader(CDC *pDC, CRect &rcHeader, BOOL bIsSelected, BOOL bIsCurrent, const CXTPPaintManagerColorGradient &grclr, COLORREF clrUnderLineHdr) | CXTPCalendarPaintManager | virtual
DrawHorizontalLine(CDC *pDC, int xPos, int yPos, int cx) | CXTPCalendarPaintManager | virtual
DrawHourCell(CDC *pDC, CRect rc, CString strText, BOOL bFillBackground=TRUE, BOOL bCurrentTime=FALSE) | CXTPCalendarPaintManager | virtual
DrawIconChar(CDC *pDC, CRect rc, TCHAR ch) | CXTPCalendarPaintManager | virtual
DrawIcons(CDC *pDC, CXTPCalendarViewEvent *pViewEvent) | CXTPCalendarPaintManager | virtual
DrawLine(CDC *pDC, int xPos, int yPos, int cx, int cy) | CXTPCalendarPaintManager | virtual
DrawNowLine(CDC *pDC, CXTPCalendarDayView *pView, CRect rc, int y, BOOL bDrawBk=FALSE) | CXTPCalendarPaintManager | virtual
DrawNowLine(CDC *pDC, CXTPCalendarDayView *pView, CXTPCalendarDayViewTimeScale *pScale, CRect rc, int y, BOOL bDrawBk=FALSE) | CXTPCalendarPaintManager | virtual
DrawShadow(CDC *pDC, const CRect &rcRect) | CXTPCalendarPaintManager | virtual
DrawSubj(CDC *pDC, CXTPCalendarWeekViewEvent *pWeekViewEvent) | CXTPCalendarPaintManager | virtual
DrawTimes(CDC *pDC, CXTPCalendarWeekViewEvent *pWeekViewEvent) | CXTPCalendarPaintManager | virtual
DrawVerticalLine(CDC *pDC, int xPos, int yPos, int cy) | CXTPCalendarPaintManager | virtual
EnableTheme(BOOL bEnableTheme) | CXTPCalendarPaintManager |
END_VIEW_PART(ControlPart) BEGIN_VIEW_PART(DayViewTimeScaleHeaderPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewTimeScaleHeaderPart) BEGIN_VIEW_PART(DayViewTimeScaleCellPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewTimeScaleCellPart) BEGIN_VIEW_PART(DayViewCellPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewCellPart) BEGIN_VIEW_PART(DayViewWorkCellPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewWorkCellPart) BEGIN_VIEW_PART(DayViewNonworkCellPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewNonworkCellPart) BEGIN_VIEW_PART(DayMonthViewHeaderPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayMonthViewHeaderPart) BEGIN_VIEW_PART(DayViewHeaderPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewHeaderPart) BEGIN_VIEW_PART(DayViewGroupHeaderPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewGroupHeaderPart) BEGIN_VIEW_PART(DayViewAllDayEventsPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewAllDayEventsPart) BEGIN_VIEW_PART(DayViewAllDayEventScrollIconsPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewAllDayEventScrollIconsPart) BEGIN_VIEW_PART(DayViewEventPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewEventPart) BEGIN_VIEW_PART(MonthViewGridPart | CXTPCalendarPaintManager |
END_VIEW_PART(MonthViewGridPart) BEGIN_VIEW_PART(MonthViewHeaderPart | CXTPCalendarPaintManager |
END_VIEW_PART(MonthViewHeaderPart) BEGIN_VIEW_PART(MonthViewEventPart | CXTPCalendarPaintManager |
END_VIEW_PART(MonthViewEventPart) BEGIN_VIEW_PART(WeekViewPart | CXTPCalendarPaintManager |
END_VIEW_PART(WeekViewPart) BEGIN_VIEW_PART(WeekViewEventPart | CXTPCalendarPaintManager |
END_VIEW_PART(WeekViewEventPart) BEGIN_VIEW_PART(TimeLineViewTimeScalePart_Day | CXTPCalendarPaintManager |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAskItemTextFlags() const | CXTPCalendarPaintManager |
GetBusyStatusBrush(int nBusyStatus) | CXTPCalendarPaintManager |
GetClockSize() | CXTPCalendarPaintManager | virtual
GetCurrentSystemTheme() | CXTPCalendarPaintManager |
GetEventBackColor(CXTPCalendarEvent *pEvent, COLORREF crDefault) | CXTPCalendarPaintManager | virtual
GetExpandSignSize() | CXTPCalendarPaintManager | virtual
GetPaintTheme() const | CXTPCalendarPaintManager | virtual
GetParams(CXTPCalendarDayViewGroup *pViewGroup, XTP_CALENDAR_DAYVIEWCELL_PARAMS *rCellParams) | CXTPCalendarPaintManager | virtual
idxExpandSignDown enum value | CXTPCalendarPaintManager | protected
idxExpandSignUp enum value | CXTPCalendarPaintManager | protected
idxMeeting enum value | CXTPCalendarPaintManager | protected
idxPrivate enum value | CXTPCalendarPaintManager | protected
idxRecurrenceException enum value | CXTPCalendarPaintManager | protected
idxRecurrenceOccurrence enum value | CXTPCalendarPaintManager | protected
idxReminder enum value | CXTPCalendarPaintManager | protected
InitBusyStatusDefaultColors() | CXTPCalendarPaintManager | protectedvirtual
IsThemeEnabled() | CXTPCalendarPaintManager |
m_arBusyStatusBrushes | CXTPCalendarPaintManager | protected
m_arStartCol | CXTPCalendarPaintManager |
m_arStartRow | CXTPCalendarPaintManager |
m_bEnableTheme | CXTPCalendarPaintManager | protected
m_bmpElsewherePattern | CXTPCalendarPaintManager | protected
m_bmpTentativePattern | CXTPCalendarPaintManager | protected
m_bShowMinutes | CXTPCalendarPaintManager |
m_clr3DShadow | CXTPCalendarPaintManager |
m_clrBackground | CXTPCalendarPaintManager |
m_clrBackground2 | CXTPCalendarPaintManager |
m_clrBackgroundSlave | CXTPCalendarPaintManager |
m_clrBorders | CXTPCalendarPaintManager |
m_clrButtonFace | CXTPCalendarPaintManager |
m_clrButtonFaceText | CXTPCalendarPaintManager |
m_clrClassicUnderline | CXTPCalendarPaintManager |
m_clrEventBar | CXTPCalendarPaintManager |
m_clrEventBarLine | CXTPCalendarPaintManager |
m_clrEventBorderLine | CXTPCalendarPaintManager |
m_clrHeaderBottomLine | CXTPCalendarPaintManager |
m_clrHighlight | CXTPCalendarPaintManager |
m_clrHour | CXTPCalendarPaintManager |
m_clrMultiDayEventFrameColor | CXTPCalendarPaintManager |
m_clrSelectedBackground | CXTPCalendarPaintManager |
m_clrSelectedText | CXTPCalendarPaintManager |
m_clrShadow | CXTPCalendarPaintManager |
m_clrText | CXTPCalendarPaintManager |
m_clrTextHighLightColor | CXTPCalendarPaintManager |
m_clrTextNormalColor | CXTPCalendarPaintManager |
m_clrTimeScaleBackground | CXTPCalendarPaintManager |
m_clrTimeScaleHightlite | CXTPCalendarPaintManager |
m_clrTimeScaleText | CXTPCalendarPaintManager |
m_clrUnderLineHdr | CXTPCalendarPaintManager | protected
m_clrWeekendBackground | CXTPCalendarPaintManager |
m_clrWindow | CXTPCalendarPaintManager |
m_clrWindowText | CXTPCalendarPaintManager |
m_CurrSystemTheme | CXTPCalendarPaintManager | protected
m_dwAskItemTextFlags | CXTPCalendarPaintManager | protected
m_fntTimeText | CXTPCalendarPaintManager |
m_grclrClassicSelDay | CXTPCalendarPaintManager |
m_grclrToday | CXTPCalendarPaintManager |
m_lstViewParts | CXTPCalendarPaintManager | protected
m_nHourWidth | CXTPCalendarPaintManager |
m_nMinWidth | CXTPCalendarPaintManager |
m_nPaintTheme | CXTPCalendarPaintManager | protected
m_pControl | CXTPCalendarPaintManager | protected
m_pExpandSigns | CXTPCalendarPaintManager | protected
m_pGlyphs | CXTPCalendarPaintManager | protected
m_pGlyphsFont | CXTPCalendarPaintManager | protected
m_PrintPageWidth | CXTPCalendarPaintManager |
m_szClockRect | CXTPCalendarPaintManager | protected
m_xtpBrushElsewhere | CXTPCalendarPaintManager | protected
m_xtpBrushTentative | CXTPCalendarPaintManager | protected
OnDraw(CDC *pDC, CXTPCalendarDayView *pView, CRect rc, CString strText) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarDayViewGroup *pViewGroup, CRect rc, const XTP_CALENDAR_DAYVIEWCELL_PARAMS &cellParams) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarDayViewDay *pViewDay, CRect rc, CString strText) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarDayViewGroup *pViewGroup, CRect rc, CString strText) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarDayViewGroup *pViewGroup, CRect rc, BOOL bSelected) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarDayViewGroup *pViewGroup, BOOL bDrawUp, BOOL bDrawDown, const CRect &rcIconUp, const CRect &rcIconDown, BOOL bHighlightUp, BOOL bHighlightDown) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarDayViewEvent *pViewEvent) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarMonthView *pMonthView, CRect rc, int nCollIndex, CString strText) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarWeekView *pWeekView) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarWeekViewEvent *pWeekViewEvent) | CXTPCalendarPaintManager | virtual
OnDrawDayDate(CDC *pDC, CRect rc, BOOL bToday, BOOL bSelected, BOOL bFirstMonthDay, CString strText) | CXTPCalendarPaintManager | virtual
OnDrawEvent(CDC *pDC, CXTPCalendarMonthViewEvent *pViewEvent) | CXTPCalendarPaintManager | virtual
OnDrawGrid(CDC *pDC, CXTPCalendarMonthView *pMonthView) | CXTPCalendarPaintManager | virtual
RefreshMetrics() | CXTPCalendarResourceTheme | virtual
SetAskItemTextFlags(DWORD dwFlags) | CXTPCalendarPaintManager |
SetBusyStatusBrush(int nBusyStatus, CBrush *pBrush, BOOL bAutodeleteBrush) | CXTPCalendarPaintManager |
SetControl(CXTPCalendarControl *pControl) | CXTPCalendarPaintManager | virtual
SetPaintTheme(XTPCalendarTheme ePaintTheme) | CXTPCalendarPaintManager | virtual
UpdateEventCategoriesDefaultColors() | CXTPCalendarPaintManager | virtual
UpdateEventLabelsDefaultColors() | CXTPCalendarPaintManager | virtual
UpdateGlyphs() | CXTPCalendarPaintManager | virtual
XTPEnumEventGlyphs enum name | CXTPCalendarPaintManager | protected
XTPEnumExpandSigns enum name | CXTPCalendarPaintManager | protected
~CTimeLineViewPart() | CXTPCalendarPaintManager | virtual
~CXTPCalendarPaintManager() | CXTPCalendarPaintManager | virtual
~CXTPCalendarResourceTheme() | CXTPCalendarResourceTheme | virtual


Toolkit Pro: Member List

CXTPExcelTabCtrlTheme Member List

This is the complete list of members for CXTPExcelTabCtrlTheme, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPControlTheme() | CXTPControlTheme |
CXTPExcelTabCtrlTheme() | CXTPExcelTabCtrlTheme |
DrawButton(CDC *pDC, CXTPExcelTabCtrl *pTabCtrl, const CXTPExcelTabCtrlButtonState &state) | CXTPExcelTabCtrlTheme | virtual
DrawButtonBack(CDC *pDC, CRect &rect, const CXTPExcelTabCtrlButtonState &state) | CXTPExcelTabCtrlTheme | virtual
DrawGripper(CDC *pDC, CRect rect) | CXTPExcelTabCtrlTheme | virtual
DrawTab(CDC *pDC, CXTPExcelTabCtrl *pTabCtrl, const CPoint &pt, bool bSelected, CXTPTcbItem *pTcbItem) | CXTPExcelTabCtrlTheme | virtual
FillBackground(CDC *pDC, CRect &rect, BOOL bBottom) | CXTPExcelTabCtrlTheme | virtual
FillTabsBackground(CDC *pDC, int cx, int cy) | CXTPExcelTabCtrlTheme | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetSelTabBackColor(CXTPTcbItem *pTcbItem) const | CXTPExcelTabCtrlTheme | virtual
GetSelTabTextColor(CXTPTcbItem *pTcbItem) const | CXTPExcelTabCtrlTheme | virtual
GetTabBackColor(CXTPTcbItem *pTcbItem) const | CXTPExcelTabCtrlTheme | virtual
GetTabTextColor(CXTPTcbItem *pTcbItem) const | CXTPExcelTabCtrlTheme | virtual
GetThemeStyle() const | CXTPControlTheme |
m_clr3DFace | CXTPExcelTabCtrlTheme |
m_clr3DFaceHilite | CXTPExcelTabCtrlTheme |
m_clr3DFacePushed | CXTPExcelTabCtrlTheme |
m_clr3DHilight | CXTPExcelTabCtrlTheme |
m_clr3DShadow | CXTPExcelTabCtrlTheme |
m_clrBorder3DHilite | CXTPExcelTabCtrlTheme |
m_clrBorder3DShadow | CXTPExcelTabCtrlTheme |
m_clrBtnText | CXTPExcelTabCtrlTheme |
m_clrBtnTextGray | CXTPExcelTabCtrlTheme |
m_clrBtnTextHilite | CXTPExcelTabCtrlTheme |
m_clrBtnTextPushed | CXTPExcelTabCtrlTheme |
m_clrWindow | CXTPExcelTabCtrlTheme |
m_clrWindowText | CXTPExcelTabCtrlTheme |
m_nTheme | CXTPControlTheme | protected
RefreshMetrics(CXTPExcelTabCtrl *pTab) | CXTPExcelTabCtrlTheme | virtual
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static
~CXTPExcelTabCtrlTheme() | CXTPExcelTabCtrlTheme |


Toolkit Pro: Member List

CXTPProgressCtrlThemeVisualStudio2019 Member List

This is the complete list of members for CXTPProgressCtrlThemeVisualStudio2019, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPProgressCtrlPaintManager() | CXTPProgressCtrlPaintManager |
CXTPProgressCtrlThemeOffice2000() | CXTPProgressCtrlThemeOffice2000 |
CXTPProgressCtrlThemeOffice2013() | CXTPProgressCtrlThemeOffice2013 |
CXTPProgressCtrlThemeVisualStudio2019() | CXTPProgressCtrlThemeVisualStudio2019 |
DeflateRect(XTPPROGRESSDRAWSTRUCT &ds) | CXTPProgressCtrlPaintManager | protectedvirtual
Draw(XTPPROGRESSDRAWSTRUCT &ds) | CXTPProgressCtrlThemeOffice2013 | virtual
DrawNcBorders(CDC *pDC, CRect rc) | CXTPProgressCtrlThemeOffice2013 | virtual
DrawText(XTPPROGRESSDRAWSTRUCT &ds) | CXTPProgressCtrlPaintManager | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetBackColor() | CXTPProgressCtrlPaintManager |
GetBarColor() | CXTPProgressCtrlPaintManager |
GetBorderColor() | CXTPProgressCtrlPaintManager |
GetTextColor() | CXTPProgressCtrlPaintManager |
m_bUseWinTheme | CXTPProgressCtrlPaintManager | protected
m_clrBack | CXTPProgressCtrlPaintManager | protected
m_clrBar | CXTPProgressCtrlPaintManager | protected
m_clrBarText | CXTPProgressCtrlPaintManager | protected
m_clrBorder | CXTPProgressCtrlPaintManager | protected
m_clrText | CXTPProgressCtrlPaintManager | protected
m_nTheme | CXTPProgressCtrlPaintManager | protected
m_winTheme | CXTPProgressCtrlPaintManager | protected
RefreshMetrics() | CXTPProgressCtrlThemeOffice2013 | virtual
SetBackColor(COLORREF clrNew) | CXTPProgressCtrlPaintManager |
SetBarColor(COLORREF clrNew) | CXTPProgressCtrlPaintManager |
SetBorderColor(COLORREF clrNew) | CXTPProgressCtrlPaintManager |
SetTextColor(COLORREF clrNew) | CXTPProgressCtrlPaintManager |
UseWinThemes(BOOL bUseWinThemes=TRUE) | CXTPProgressCtrlPaintManager |
UsingWinThemes(BOOL bCheckReady=FALSE) | CXTPProgressCtrlPaintManager |
~CXTPProgressCtrlPaintManager() | CXTPProgressCtrlPaintManager | virtual


Toolkit Pro: Member List

CXTPCalendarViewPartBrushValue Member List

This is the complete list of members for CXTPCalendarViewPartBrushValue, including all inherited members.

CopySettings(const CXTPCalendarViewPartCustomizableValueT< CBrush > &refSrc) | CXTPCalendarViewPartCustomizableValueT< CBrush > | inline
CXTPCalendarViewPartCustomizableValueT() | CXTPCalendarViewPartCustomizableValueT< CBrush > | inline
GetStandardValue() const | CXTPCalendarViewPartCustomizableValueT< CBrush > | inlinevirtual
GetValue() const | CXTPCalendarViewPartCustomizableValueT< CBrush > | inlinevirtual
IsCustomValue() const | CXTPCalendarViewPartCustomizableValueT< CBrush > | inlinevirtual
IsDefaultValue() const | CXTPCalendarViewPartCustomizableValueT< CBrush > | inlinevirtual
IsStandardValue() const | CXTPCalendarViewPartCustomizableValueT< CBrush > | inlinevirtual
m_bAutoDelete_Custom | CXTPCalendarViewPartCustomizableValueT< CBrush > | protected
m_bAutoDelete_Standard | CXTPCalendarViewPartCustomizableValueT< CBrush > | protected
m_pValueCustom | CXTPCalendarViewPartCustomizableValueT< CBrush > | protected
m_pValueStandard | CXTPCalendarViewPartCustomizableValueT< CBrush > | protected
operator CBrush *() const | CXTPCalendarViewPartCustomizableValueT< CBrush > | inline
operator->() | CXTPCalendarViewPartCustomizableValueT< CBrush > | inline
SetCustomValue(CBrush *pValue, BOOL bAutoDelete) | CXTPCalendarViewPartCustomizableValueT< CBrush > | inlinevirtual
SetDefaultValue() | CXTPCalendarViewPartCustomizableValueT< CBrush > | inlinevirtual
SetStandardValue(CBrush *pValue, BOOL bAutoDelete) | CXTPCalendarViewPartCustomizableValueT< CBrush > | inlinevirtual
~CXTPCalendarViewPartBrushValue() | CXTPCalendarViewPartBrushValue |
~CXTPCalendarViewPartCustomizableValueT() | CXTPCalendarViewPartCustomizableValueT< CBrush > | inlinevirtual


Toolkit Pro: Member List

CXTPMarqueeCtrlThemeFlat Member List

This is the complete list of members for CXTPMarqueeCtrlThemeFlat, including all inherited members.

CXTPMarqueeCtrlPaintManager() | CXTPMarqueeCtrlPaintManager |
CXTPMarqueeCtrlThemeFlat() | CXTPMarqueeCtrlThemeFlat |
DeflateRect(CDC *pDC, CRect &rcClient) | CXTPMarqueeCtrlThemeFlat | protectedvirtual
DrawBackground(CXTPMarqueeCtrl *pWndCtrl, CDC *pDC, CRect &rcClient) | CXTPMarqueeCtrlPaintManager | virtual
DrawChunk(CXTPMarqueeCtrl *pWndCtrl, CDC *pDC, CXTPCompatibleDC &dcChunk, int i, int &x, int &y, int cx, int cy) | CXTPMarqueeCtrlPaintManager | protectedvirtual
DrawMarquee(CXTPMarqueeCtrl *pWndCtrl, CDC *pDC, CRect &rcClient) | CXTPMarqueeCtrlThemeFlat | protectedvirtual
GetBackColor() | CXTPMarqueeCtrlPaintManager |
GetBarColor() | CXTPMarqueeCtrlPaintManager |
GetBorderColor() | CXTPMarqueeCtrlPaintManager |
m_bUseWinTheme | CXTPMarqueeCtrlPaintManager | protected
m_clr3DHilite | CXTPMarqueeCtrlPaintManager | protected
m_clr3DShadow | CXTPMarqueeCtrlPaintManager | protected
m_clrBack | CXTPMarqueeCtrlPaintManager | protected
m_clrBar | CXTPMarqueeCtrlPaintManager | protected
m_nTheme | CXTPMarqueeCtrlPaintManager | protected
m_winTheme | CXTPMarqueeCtrlPaintManager | protected
RefreshMetrics() | CXTPMarqueeCtrlThemeFlat | virtual
SetBackColor(COLORREF clrNew) | CXTPMarqueeCtrlPaintManager |
SetBarColor(COLORREF clrNew) | CXTPMarqueeCtrlPaintManager |
SetBorderColor(COLORREF clrNew) | CXTPMarqueeCtrlPaintManager |
UseWinThemes(BOOL bUseWinThemes=TRUE) | CXTPMarqueeCtrlPaintManager |
UsingWinThemes(BOOL bCheckReady=FALSE) | CXTPMarqueeCtrlPaintManager |
~CXTPMarqueeCtrlPaintManager() | CXTPMarqueeCtrlPaintManager | virtual


Toolkit Pro: Member List

CXTPProgressCtrl Member List

This is the complete list of members for CXTPProgressCtrl, including all inherited members.

CXTPProgressCtrl() | CXTPProgressCtrl |
DoPaint(CDC *pDC) | CXTPProgressCtrl | protected
DrawNcBorders(CDC *pDC, CRect rc) | CXTPProgressCtrl | protected
GetBackColor() | CXTPProgressCtrl | protected
GetBarColor() | CXTPProgressCtrl | protected
GetBorderColor() | CXTPProgressCtrl | protected
GetFlatStyle() const | CXTPProgressCtrl |
GetPaintManager() const | CXTPProgressCtrl |
GetTextColor() | CXTPProgressCtrl | protected
GetUseVisualStyle() const | CXTPProgressCtrl |
HasText() | CXTPProgressCtrl | protected
m_bFlatStyle | CXTPProgressCtrl | protected
m_bPreSubclassInit | CXTPProgressCtrl | protected
m_nMarqueeDelay | CXTPProgressCtrl | protected
m_nMarqueePos | CXTPProgressCtrl | protected
m_pPaintManager | CXTPProgressCtrl | protected
RefreshMetrics() | CXTPProgressCtrl | protected
SetBarColor(COLORREF clrNew) | CXTPProgressCtrl |
SetBkColor(COLORREF clrNew) | CXTPProgressCtrl |
SetBorderColor(COLORREF clrNew) | CXTPProgressCtrl |
SetFlatStyle(BOOL bFlatStyle=TRUE) | CXTPProgressCtrl |
SetMarquee(BOOL fMarqueeMode, int nInterval) | CXTPProgressCtrl |
SetTextColor(COLORREF clrNew) | CXTPProgressCtrl |
SetTheme(CXTPProgressCtrlPaintManager *pPaintManager=NULL) | CXTPProgressCtrl |
SetTheme(XTPControlTheme nTheme) | CXTPProgressCtrl |
SetUseVisualStyle(BOOL bUseVisualStyle=TRUE) | CXTPProgressCtrl |
~CXTPProgressCtrl() | CXTPProgressCtrl | virtual


Toolkit Pro: Member List

CXTPChart3dDeviceCommand Member List

This is the complete list of members for CXTPChart3dDeviceCommand, including all inherited members.

AddChildCommand(CXTPChartDeviceCommand *pCommand) | CXTPChartDeviceCommand |
AfterExecute(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
ApplySeriesStyle(CXTPChartSeriesStyle *pStyle) | CXTPChartDeviceCommand | virtual
BeforeExecute(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
BindView(CXTPChartElementView *pView) | CXTPChartDeviceCommand |
Commit() | CXTPChartDeviceCommand |
CXTPChart3dDeviceCommand(XTPChart3dAntialiasingPolicy nAntialiasingPolicy) | CXTPChart3dDeviceCommand | protected
CXTPChartDeviceCommand() | CXTPChartDeviceCommand |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPObservable() | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | protected
Execute(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
ExecuteOverride(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
GetBoundView() const | CXTPChartDeviceCommand |
GetChildCommand(int nIndex) const | CXTPChartDeviceCommand |
GetChildCommandCount() const | CXTPChartDeviceCommand |
GetCurrentDC() const | CXTPChartDeviceCommand |
GetPassNumber() const | CXTPChartDeviceCommand |
HitTest(CPoint point, CXTPChartElement *pParent) const | CXTPChartDeviceCommand | virtual
Is3D() const | CXTPChartObject |
IsCommitted() const | CXTPChartDeviceCommand |
IsEnabled() const | CXTPChart3dDeviceCommand | virtual
m_arrChildren | CXTPChartDeviceCommand | protected
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Prepare(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
PrepareOverride(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
SetEnabled(BOOL bEnabled=TRUE) | CXTPChartDeviceCommand |
Subscribe(CXTPChartDeviceCommandEvents *pObserver, CXTPSubscriptionList< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > *pSubcriptionList=NULL) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > |
Unsubscribe(CXTPChartDeviceCommandEvents *pObserver) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > |
~CXTPChartDeviceCommand() | CXTPChartDeviceCommand | virtual
~CXTPObservable() | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | protected


Toolkit Pro: Member List

CXTPChart3dPieDiagramView Member List

This is the complete list of members for CXTPChart3dPieDiagramView, including all inherited members.

AddChildView(CXTPChartElementView *pChildView) | CXTPChartElementView |
CalculateView(CXTPChartDeviceContext *pDC, CRect rcBounds) | CXTPChartDiagramView | virtual
CreateDeviceCommand(CXTPChartDeviceContext *pDC) | CXTPChart3dDiagramView | virtual
CreateView(CXTPChartDeviceContext *pDC) | CXTPChartDiagramView | virtual
CXTPChart3dDiagramView(CXTPChartDiagram *pDiagram, CXTPChartElementView *pParentView) | CXTPChart3dDiagramView |
CXTPChart3dPieDiagramView(CXTPChartDiagram *pDiagram, CXTPChartElementView *pParent) | CXTPChart3dPieDiagramView |
CXTPChartDiagramView(CXTPChartDiagram *pDiagram, CXTPChartElementView *pParentView) | CXTPChartDiagramView |
CXTPChartElementView(CXTPChartElementView *pParentView) | CXTPChartElementView |
CXTPChartElementView(CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartElementView |
CXTPChartElementView(CXTPChartContainer *pContainer) | CXTPChartElementView |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
GetAt(int nIndex) const | CXTPChartElementView |
GetBounds() const | CXTPChartDiagramView |
CXTPChartElementView::GetBounds(BOOL bIncludingChildren) const | CXTPChartElementView |
GetChildren() | CXTPChartElementView |
GetCount() const | CXTPChartElementView |
GetDiagram() const | CXTPChartDiagramView |
GetLabelsView() const | CXTPChartDiagramView |
GetParentView() const | CXTPChartElementView |
GetSeriesView() const | CXTPChartDiagramView |
Is3D() const | CXTPChartObject |
m_arrChildren | CXTPChartElementView | protected
m_pContainer | CXTPChartElementView | protected
m_pDiagram | CXTPChartDiagramView | protected
m_pLabelsView | CXTPChartDiagramView | protected
m_pParentView | CXTPChartElementView | protected
m_pSeriesView | CXTPChartDiagramView | protected
m_pTitlesView | CXTPChartDiagramView | protected
m_rcBounds | CXTPChartDiagramView | protected
OnMouseWheel(UINT nFlags, short zDelta, CPoint pt) | CXTPChartDiagramView | virtual
UpdateRange(CXTPChartDeviceContext *pDC) | CXTPChartDiagramView | virtual
~CXTPChartElementView() | CXTPChartElementView | protectedvirtual


Toolkit Pro: Member List

CXTPMarkupGdiPlusImage Member List

This is the complete list of members for CXTPMarkupGdiPlusImage, including all inherited members.

CXTPMarkupDeviceDependentImage(IXTPMarkupDeviceDependentImageSite *pSite) | CXTPMarkupDeviceDependentImage | explicitprotected
CXTPMarkupGdiPlusImage(CXTPGdiPlus *pReserved, IXTPMarkupDeviceDependentImageSite *pSite) | CXTPMarkupGdiPlusImage |
GetGpImage() | CXTPMarkupGdiPlusImage |
GetIcon() | CXTPMarkupGdiPlusImage |
GetSite() const | CXTPMarkupDeviceDependentImage |
GetSize() const | CXTPMarkupDeviceDependentImage |
IsIcon() const | CXTPMarkupDeviceDependentImage |
IsLoaded() const | CXTPMarkupDeviceDependentImage |
Load(LPCWSTR lpszSource, int nWidth, int nHeight=0) | CXTPMarkupGdiPlusImage | virtual
~CXTPMarkupDeviceDependentImage() | CXTPMarkupDeviceDependentImage | virtual
~CXTPMarkupGdiPlusImage() | CXTPMarkupGdiPlusImage | virtual


Toolkit Pro: XTPChartAppearance.h Source File

  • Source
  • Chart
  • Appearance
XTPChartAppearance.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTAPPEARANCE_H__)
24# define __XTPCHARTAPPEARANCE_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartPalette;
34class CXTPChartElement;
35class CXTPChartFillStyle;
36class CXTPPropExchange;
37
42class _XTP_EXT_CLASS CXTPChartElementAppearance : public CXTPChartElement
43{
44public:
51 CXTPChartElementAppearance(CXTPChartElement* pOwner);
52
57 virtual ~CXTPChartElementAppearance();
58
66 virtual void ApplyToDeviceContext(CXTPChartDeviceContext* pDC);
67};
68
73class _XTP_EXT_CLASS CXTPChartTitleAppearance : public CXTPChartElementAppearance
74{
75public:
82 CXTPChartTitleAppearance(CXTPChartElement* pOwner);
83
84public:
96 void DoPropExchange(CXTPPropExchange* pPX);
97
98public:
99 CXTPChartColor TextColor; // The text color of chart title.
100};
101
106class _XTP_EXT_CLASS CXTPChartLegendAppearance : public CXTPChartElementAppearance
107{
108public:
115 CXTPChartLegendAppearance(CXTPChartElement* pOwner);
116
117public:
129 void DoPropExchange(CXTPPropExchange* pPX);
130
131public:
132 CXTPChartColor TextColor;
133 CXTPChartColor BackgroundColor;
134 CXTPChartColor BorderColor;
135};
136
142class _XTP_EXT_CLASS CXTPChartContentAppearance : public CXTPChartElementAppearance
143{
144public:
151 CXTPChartContentAppearance(CXTPChartElement* pOwner);
152
157 virtual ~CXTPChartContentAppearance();
158
159public:
171 void DoPropExchange(CXTPPropExchange* pPX);
172
173public:
180 CXTPChartTitleAppearance* GetTitleAppearance() const;
181
188 CXTPChartLegendAppearance* GetLegendAppearance() const;
189
190public:
191 CXTPChartColor BackgroundColor;
192 CXTPChartColor BorderColor;
194protected:
195 CXTPChartTitleAppearance* m_pTitleAppearance;
197 CXTPChartLegendAppearance* m_pLegendAppearance;
198};
199
205class _XTP_EXT_CLASS CXTPChartAxisAppearance : public CXTPChartElementAppearance
206{
207public:
214 CXTPChartAxisAppearance(CXTPChartElement* pOwner);
215
220 virtual ~CXTPChartAxisAppearance();
221
222public:
234 void DoPropExchange(CXTPPropExchange* pPX);
235
236public:
237 CXTPChartColor Color;
238 CXTPChartColor InterlacedColor;
239 CXTPChartColor InterlacedColor2;
240 CXTPChartFillStyle* InterlacedFillStyle;
242 CXTPChartColor GridLinesColor;
243 CXTPChartColor GridLinesMinorColor;
244 CXTPChartColor AxisLabelTextColor;
245 CXTPChartColor AxisTitleTextColor;
247 CXTPChartColor ConstantLineColor;
248 CXTPChartColor ConstantLineTextColor;
250 CXTPChartColor StripColor;
251 CXTPChartColor StripColor2;
253# ifdef _XTP_ACTIVEX
254public:
255 DECLARE_DISPATCH_MAP()
256 DECLARE_INTERFACE_MAP()
257 DECLARE_OLETYPELIB_EX(CXTPChartAxisAppearance);
258
259 afx_msg OLE_COLOR OleGetColor();
260 afx_msg void OleSetColor(OLE_COLOR clr);
261 afx_msg OLE_COLOR OleGetInterlacedColor();
262 afx_msg void OleSetInterlacedColor(OLE_COLOR clr);
263 afx_msg OLE_COLOR OleGetInterlacedColor2();
264 afx_msg void OleSetInterlacedColor2(OLE_COLOR clr);
265 afx_msg LPDISPATCH OleGetInterlacedFillStyle();
266 afx_msg OLE_COLOR OleGetGridLinesColor();
267 afx_msg void OleSetGridLinesColor(OLE_COLOR clr);
268 afx_msg OLE_COLOR OleGetGridLinesMinorColor();
269 afx_msg void OleSetGridLinesMinorColor(OLE_COLOR clr);
270 afx_msg OLE_COLOR OleGetAxisLabelTextColor();
271 afx_msg void OleSetAxisLabelTextColor(OLE_COLOR clr);
272 afx_msg OLE_COLOR OleGetAxisTitleTextColor();
273 afx_msg void OleSetAxisTitleTextColor(OLE_COLOR clr);
274 afx_msg OLE_COLOR OleGetConstantLineColor();
275 afx_msg void OleSetConstantLineColor(OLE_COLOR clr);
276 afx_msg OLE_COLOR OleGetConstantLineTextColor();
277 afx_msg void OleSetConstantLineTextColor(OLE_COLOR clr);
278 afx_msg OLE_COLOR OleGetStripColor();
279 afx_msg void OleSetStripColor(OLE_COLOR clr);
280 afx_msg OLE_COLOR OleGetStripColor2();
281 afx_msg void OleSetStripColor2(OLE_COLOR clr);
282
283# endif
284};
285
291class _XTP_EXT_CLASS CXTPChartDiagram2DAppearance : public CXTPChartElementAppearance
292{
293public:
300 CXTPChartDiagram2DAppearance(CXTPChartElement* pOwner);
301
306 virtual ~CXTPChartDiagram2DAppearance();
307
308public:
320 void DoPropExchange(CXTPPropExchange* pPX);
321
328 CXTPChartAxisAppearance* GetAxisAppearance() const;
329
330public:
331 CXTPChartColor BackgroundColor;
332 CXTPChartColor BackgroundColor2;
333 CXTPChartColor BorderColor;
334 CXTPChartFillStyle* BackgroundFillStyle;
336protected:
337 CXTPChartAxisAppearance* m_pAxisAppearance;
339# ifdef _XTP_ACTIVEX
340public:
341 DECLARE_DISPATCH_MAP()
342 DECLARE_INTERFACE_MAP()
343 DECLARE_OLETYPELIB_EX(CXTPChartDiagram2DAppearance);
344
345 afx_msg OLE_COLOR OleGetBackgroundColor();
346 afx_msg void OleSetBackgroundColor(OLE_COLOR clr);
347 afx_msg OLE_COLOR OleGetBackgroundColor2();
348 afx_msg void OleSetBackgroundColor2(OLE_COLOR clr);
349 afx_msg OLE_COLOR OleGetBorderColor();
350 afx_msg void OleSetBorderColor(OLE_COLOR clr);
351 afx_msg LPDISPATCH OleGetBackgroundFillStyle();
352 afx_msg LPDISPATCH OleGetAxisAppearance();
353
354# endif
355};
356
362class _XTP_EXT_CLASS CXTPChartDiagram3DAppearance : public CXTPChartElementAppearance
363{
364public:
371 CXTPChartDiagram3DAppearance(CXTPChartElement* pOwner);
372
377 virtual ~CXTPChartDiagram3DAppearance();
378
379public:
391 void DoPropExchange(CXTPPropExchange* pPX);
392
400 virtual void ApplyToDeviceContext(CXTPChartDeviceContext* pDC);
401
402public:
403 CXTPPoint3f LightPosition; // Light position vector, each component is a normalized value in
404 // range [0..1].*/
405 CXTPChartColor LightAmbientColor;
406 CXTPChartColor LightDiffuseColor;
407 CXTPChartColor LightSpecularColor;
408 CXTPChartColor LightModelAmbientColor;
409 CXTPChartColor MaterialEmissionColor;
410 CXTPChartColor MaterialDiffuseColor;
411 CXTPChartColor MaterialSpecularColor;
412 float MaterialShininess;
413 BOOL Antialiasing;
415 static const CXTPPoint3f DefaultLightPosition;
418 static const CXTPChartColor DefaultLightAmbientColor;
419 static const CXTPChartColor DefaultLightDiffuseColor;
420 static const CXTPChartColor DefaultLightSpecularColor;
421 static const CXTPChartColor DefaultLightModelAmbientColor;
423 static const CXTPChartColor DefaultMaterialEmissionColor;
425 static const CXTPChartColor DefaultMaterialDiffuseColor;
426 static const CXTPChartColor DefaultMaterialSpecularColor;
428 static const float DefaultMaterialShininess;
430 static const BOOL DefaultAntialiasing;
432# ifdef _XTP_ACTIVEX
433public:
434 DECLARE_DISPATCH_MAP()
435 DECLARE_INTERFACE_MAP()
436 DECLARE_OLETYPELIB_EX(CXTPChartDiagram3DAppearance);
437
438 afx_msg double OleGetLightPositionX();
439 afx_msg void OleSetLightPositionX(double dValue);
440 afx_msg double OleGetLightPositionY();
441 afx_msg void OleSetLightPositionY(double dValue);
442 afx_msg double OleGetLightPositionZ();
443 afx_msg void OleSetLightPositionZ(double dValue);
444 afx_msg OLE_COLOR OleGetLightAmbientColor();
445 afx_msg void OleSetLightAmbientColor(OLE_COLOR clr);
446 afx_msg OLE_COLOR OleGetLightDiffuseColor();
447 afx_msg void OleSetLightDiffuseColor(OLE_COLOR clr);
448 afx_msg OLE_COLOR OleGetLightSpecularColor();
449 afx_msg void OleSetLightSpecularColor(OLE_COLOR clr);
450 afx_msg OLE_COLOR OleGetLightModelAmbientColor();
451 afx_msg void OleSetLightModelAmbientColor(OLE_COLOR clr);
452 afx_msg OLE_COLOR OleGetMaterialEmissionColor();
453 afx_msg void OleSetMaterialEmissionColor(OLE_COLOR clr);
454 afx_msg OLE_COLOR OleGetMaterialDiffuseColor();
455 afx_msg void OleSetMaterialDiffuseColor(OLE_COLOR clr);
456 afx_msg OLE_COLOR OleGetMaterialSpecularColor();
457 afx_msg void OleSetMaterialSpecularColor(OLE_COLOR clr);
458 afx_msg double OleGetMaterialShininess();
459 afx_msg void OleSetMaterialShininess(double dValue);
460 afx_msg BOOL OleGetAntialiasing();
461 afx_msg void OleSetAntialiasing(BOOL bValue);
462
463# endif
464};
465
466class _XTP_EXT_CLASS CXTPChartSeriesLabelAppearance : public CXTPChartElementAppearance
467{
468public:
475 CXTPChartSeriesLabelAppearance(CXTPChartElement* pOwner);
476
481 virtual ~CXTPChartSeriesLabelAppearance();
482
483public:
495 void DoPropExchange(CXTPPropExchange* pPX);
496
497public:
498 CXTPChartColor BackgroundColor;
499 CXTPChartColor TextColor;
500 CXTPChartColor BorderColor;
501 CXTPChartColor ConnectorColor;
502};
503
504class _XTP_EXT_CLASS CXTPChartSeriesStyleAppearance : public CXTPChartElementAppearance
505{
506public:
513 CXTPChartSeriesStyleAppearance(CXTPChartElement* pOwner);
514
519 virtual ~CXTPChartSeriesStyleAppearance();
520
521public:
533 void DoPropExchange(CXTPPropExchange* pPX);
534
535public:
536 CXTPChartSeriesLabelAppearance* GetLabelAppearance() const;
537
538protected:
539 CXTPChartSeriesLabelAppearance* m_pLabelAppearance;
540};
541
547class _XTP_EXT_CLASS CXTPChartFinanceStyleAppearance : public CXTPChartSeriesStyleAppearance
548{
549public:
556 CXTPChartFinanceStyleAppearance(CXTPChartElement* pOwner);
557
562 virtual ~CXTPChartFinanceStyleAppearance();
563
564public:
576 void DoPropExchange(CXTPPropExchange* pPX);
577
578public:
579 CXTPChartColor UpColor;
580 CXTPChartColor DownColor;
581};
582
588class _XTP_EXT_CLASS CXTPChartPieStyleAppearance : public CXTPChartSeriesStyleAppearance
589{
590public:
597 CXTPChartPieStyleAppearance(CXTPChartElement* pOwner);
598
603 virtual ~CXTPChartPieStyleAppearance();
604
605public:
617 void DoPropExchange(CXTPPropExchange* pPX);
618
619public:
620 CXTPChartColor BorderColor;
621};
622
628class _XTP_EXT_CLASS CXTPChartAppearance : public CXTPChartElementAppearance
629{
630public:
637 CXTPChartAppearance(CXTPChartElement* pOwner);
638
643 virtual ~CXTPChartAppearance();
644
645public:
652 CXTPChartDiagram2DAppearance* GetDiagram2DAppearance() const;
653
660 CXTPChartDiagram3DAppearance* GetDiagram3DAppearance() const;
661
668 CXTPChartContentAppearance* GetContentAppearance() const;
669
676 CXTPChartFinanceStyleAppearance* GetFinanceStyleAppearance() const;
677
684 CXTPChartSeriesStyleAppearance* GetSeriesStyleAppearance() const;
685
692 CXTPChartPieStyleAppearance* GetPieStyleAppearance() const;
693
700 CXTPChartPalette* GetPalette() const;
701
714 void DoPropExchange(CXTPPropExchange* pPX);
715
722 static CXTPChartAppearance* AFX_CDECL GetAppearance(const CXTPChartElement* pElement);
723
724public:
732 BOOL LoadAppearance(LPCTSTR lpszAppearance);
733
741 BOOL LoadPalette(LPCTSTR lpszPallete);
742
743public:
744 static CXTPChartColor AFX_CDECL GetLightColor(const CXTPChartColor& clr);
745
746# ifdef _XTP_ACTIVEX
747public:
749 DECLARE_DISPATCH_MAP()
750 DECLARE_INTERFACE_MAP()
751
752 DECLARE_OLETYPELIB_EX(CXTPChartAppearance);
753 afx_msg void OleSetAppearance(LPCTSTR lpszName);
754 afx_msg void OleSetPalette(LPCTSTR lpszName);
755 afx_msg void OleLoadAppearance(LPDISPATCH lpPropExchage);
756 afx_msg void OleLoadPalette(LPDISPATCH lpPropExchage);
757 afx_msg LPDISPATCH OleGetPalette();
758 afx_msg LPDISPATCH OleGetDiagram2DAppearance();
759 afx_msg LPDISPATCH OleGetDiagram3DAppearance();
761# endif
762
763protected:
764 CXTPChartDiagram2DAppearance* m_pDiagram2DAppearance;
766 CXTPChartDiagram3DAppearance* m_pDiagram3DAppearance;
768 CXTPChartContentAppearance* m_pContentAppearance;
770 CXTPChartPalette* m_pPalette;
772 CXTPChartSeriesStyleAppearance* m_pSeriesStyleAppearance;
773 CXTPChartFinanceStyleAppearance* m_pFinanceStyleAppearance;
775 CXTPChartPieStyleAppearance* m_pPieStyleAppearance;
777};
778
779AFX_INLINE CXTPChartDiagram2DAppearance* CXTPChartAppearance::GetDiagram2DAppearance() const
780{
781 return m_pDiagram2DAppearance;
782}
783AFX_INLINE CXTPChartDiagram3DAppearance* CXTPChartAppearance::GetDiagram3DAppearance() const
784{
785 return m_pDiagram3DAppearance;
786}
787AFX_INLINE CXTPChartContentAppearance* CXTPChartAppearance::GetContentAppearance() const
788{
789 return m_pContentAppearance;
790}
791
792AFX_INLINE CXTPChartAxisAppearance* CXTPChartDiagram2DAppearance::GetAxisAppearance() const
793{
794 return m_pAxisAppearance;
795}
796AFX_INLINE CXTPChartPalette* CXTPChartAppearance::GetPalette() const
797{
798 return m_pPalette;
799}
800AFX_INLINE CXTPChartTitleAppearance* CXTPChartContentAppearance::GetTitleAppearance() const
801{
802 return m_pTitleAppearance;
803}
804AFX_INLINE CXTPChartLegendAppearance* CXTPChartContentAppearance::GetLegendAppearance() const
805{
806 return m_pLegendAppearance;
807}
808AFX_INLINE CXTPChartFinanceStyleAppearance* CXTPChartAppearance::GetFinanceStyleAppearance() const
809{
810 return m_pFinanceStyleAppearance;
811}
812AFX_INLINE CXTPChartSeriesStyleAppearance* CXTPChartAppearance::GetSeriesStyleAppearance() const
813{
814 return m_pSeriesStyleAppearance;
815}
816AFX_INLINE CXTPChartPieStyleAppearance* CXTPChartAppearance::GetPieStyleAppearance() const
817{
818 return m_pPieStyleAppearance;
819}
820AFX_INLINE CXTPChartSeriesLabelAppearance* CXTPChartSeriesStyleAppearance::GetLabelAppearance() const
821{
822 return m_pLabelAppearance;
823}
825# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
826#endif //#if !defined(__XTPCHARTAPPEARANCE_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartAppearance
This class represents the appearance of the chart.
Definition XTPChartAppearance.h:629
CXTPChartAppearance::~CXTPChartAppearance
virtual ~CXTPChartAppearance()
Destroys a CXTPChartAppearance object, handles cleanup.
CXTPChartAppearance::DoPropExchange
void DoPropExchange(CXTPPropExchange *pPX)
Call this member function to Store/Load the properties related to the appearance of a chart,...
CXTPChartAppearance::m_pFinanceStyleAppearance
CXTPChartFinanceStyleAppearance * m_pFinanceStyleAppearance
Pointer to chart financial content appearance object.
Definition XTPChartAppearance.h:773
CXTPChartAppearance::LoadAppearance
BOOL LoadAppearance(LPCTSTR lpszAppearance)
Call this function to load the properties from a resource XML.
CXTPChartAppearance::m_pPalette
CXTPChartPalette * m_pPalette
Pointer to chart palette object.
Definition XTPChartAppearance.h:770
CXTPChartAppearance::GetDiagram2DAppearance
CXTPChartDiagram2DAppearance * GetDiagram2DAppearance() const
Call this function to get the 2D digram appearance object pointer of the chart.
Definition XTPChartAppearance.h:779
CXTPChartAppearance::LoadPalette
BOOL LoadPalette(LPCTSTR lpszPallete)
Call this function to load the chart palette values from a resource XML.
CXTPChartAppearance::m_pPieStyleAppearance
CXTPChartPieStyleAppearance * m_pPieStyleAppearance
Pointer to chart Pie content appearance object.
Definition XTPChartAppearance.h:775
CXTPChartAppearance::m_pDiagram2DAppearance
CXTPChartDiagram2DAppearance * m_pDiagram2DAppearance
Pointer to chart diagram 2d appearance object.
Definition XTPChartAppearance.h:764
CXTPChartAppearance::m_pDiagram3DAppearance
CXTPChartDiagram3DAppearance * m_pDiagram3DAppearance
Pointer to chart diagram 3d appearance object.
Definition XTPChartAppearance.h:766
CXTPChartAppearance::GetContentAppearance
CXTPChartContentAppearance * GetContentAppearance() const
Call this function to get the content appearance object pointer of the chart.
Definition XTPChartAppearance.h:787
CXTPChartAppearance::CXTPChartAppearance
CXTPChartAppearance(CXTPChartElement *pOwner)
Constructs a CXTPChartAppearance object.
CXTPChartAppearance::GetDiagram3DAppearance
CXTPChartDiagram3DAppearance * GetDiagram3DAppearance() const
Call this function to get the 3D digram appearance object pointer of the chart.
Definition XTPChartAppearance.h:783
CXTPChartAppearance::GetFinanceStyleAppearance
CXTPChartFinanceStyleAppearance * GetFinanceStyleAppearance() const
Call this function to get the finance series appearance object pointer of the chart.
Definition XTPChartAppearance.h:808
CXTPChartAppearance::GetAppearance
static CXTPChartAppearance *AFX_CDECL GetAppearance(const CXTPChartElement *pElement)
Call this function to get the pointer to the chart appeance object.
CXTPChartAppearance::GetPieStyleAppearance
CXTPChartPieStyleAppearance * GetPieStyleAppearance() const
Call this function to get the pie style appearance object pointer of the chart.
Definition XTPChartAppearance.h:816
CXTPChartAppearance::m_pContentAppearance
CXTPChartContentAppearance * m_pContentAppearance
Pointer to chart content appearance object.
Definition XTPChartAppearance.h:768
CXTPChartAppearance::GetPalette
CXTPChartPalette * GetPalette() const
Call this function to get the color palette object pointer of the chart.
Definition XTPChartAppearance.h:796
CXTPChartAppearance::GetSeriesStyleAppearance
CXTPChartSeriesStyleAppearance * GetSeriesStyleAppearance() const
Call this function to get the series style appearance object pointer of the chart.
Definition XTPChartAppearance.h:812
CXTPChartAxisAppearance
This class represents the appearance of a chart axis.This class is is subclassed from CXTPChartElemen...
Definition XTPChartAppearance.h:206
CXTPChartAxisAppearance::DoPropExchange
void DoPropExchange(CXTPPropExchange *pPX)
Call this member function to Store/Load the properties related to the appearance of a chart axis usin...
CXTPChartAxisAppearance::GridLinesMinorColor
CXTPChartColor GridLinesMinorColor
The minor color of the grid lines.
Definition XTPChartAppearance.h:243
CXTPChartAxisAppearance::AxisTitleTextColor
CXTPChartColor AxisTitleTextColor
The text color of the axis title.
Definition XTPChartAppearance.h:245
CXTPChartAxisAppearance::InterlacedFillStyle
CXTPChartFillStyle * InterlacedFillStyle
The fill style used for interlacing.
Definition XTPChartAppearance.h:240
CXTPChartAxisAppearance::ConstantLineColor
CXTPChartColor ConstantLineColor
The color of the contant line parallal to the axis.
Definition XTPChartAppearance.h:247
CXTPChartAxisAppearance::ConstantLineTextColor
CXTPChartColor ConstantLineTextColor
The text color of the contant color.
Definition XTPChartAppearance.h:248
CXTPChartAxisAppearance::InterlacedColor2
CXTPChartColor InterlacedColor2
The secondary interlaced color.
Definition XTPChartAppearance.h:239
CXTPChartAxisAppearance::Color
CXTPChartColor Color
The color of the axis.
Definition XTPChartAppearance.h:237
CXTPChartAxisAppearance::~CXTPChartAxisAppearance
virtual ~CXTPChartAxisAppearance()
Destroys a CXTPChartAxisAppearance object, handles cleanup.
CXTPChartAxisAppearance::InterlacedColor
CXTPChartColor InterlacedColor
The primary interlaced color.
Definition XTPChartAppearance.h:238
CXTPChartAxisAppearance::CXTPChartAxisAppearance
CXTPChartAxisAppearance(CXTPChartElement *pOwner)
Constructs a CXTPChartAxisAppearance object.
CXTPChartAxisAppearance::StripColor
CXTPChartColor StripColor
The strip color.
Definition XTPChartAppearance.h:250
CXTPChartAxisAppearance::GridLinesColor
CXTPChartColor GridLinesColor
The color of the grid lines.
Definition XTPChartAppearance.h:242
CXTPChartAxisAppearance::AxisLabelTextColor
CXTPChartColor AxisLabelTextColor
The text color of the axis label.
Definition XTPChartAppearance.h:244
CXTPChartAxisAppearance::StripColor2
CXTPChartColor StripColor2
The strip gradient color.
Definition XTPChartAppearance.h:251
CXTPChartColor
This class abstracts a color entity.
Definition XTPChartTypes.h:51
CXTPChartContentAppearance
This class represents the appearance of a chart content.
Definition XTPChartAppearance.h:143
CXTPChartContentAppearance::GetLegendAppearance
CXTPChartLegendAppearance * GetLegendAppearance() const
Call this function to get the legend appearance object pointer.
Definition XTPChartAppearance.h:804
CXTPChartContentAppearance::DoPropExchange
void DoPropExchange(CXTPPropExchange *pPX)
Call this member function to Store/Load the properties related to the appearance of a chart content u...
CXTPChartContentAppearance::~CXTPChartContentAppearance
virtual ~CXTPChartContentAppearance()
Destroys a CXTPChartContentAppearance object, handles cleanup.
CXTPChartContentAppearance::GetTitleAppearance
CXTPChartTitleAppearance * GetTitleAppearance() const
Call this function to get the title appearance object pointer.
Definition XTPChartAppearance.h:800
CXTPChartContentAppearance::m_pTitleAppearance
CXTPChartTitleAppearance * m_pTitleAppearance
Pointer to the chart title appearance object.
Definition XTPChartAppearance.h:195
CXTPChartContentAppearance::BackgroundColor
CXTPChartColor BackgroundColor
The background color of the chart.
Definition XTPChartAppearance.h:191
CXTPChartContentAppearance::CXTPChartContentAppearance
CXTPChartContentAppearance(CXTPChartElement *pOwner)
Constructs a CXTPChartContentAppearance object.
CXTPChartContentAppearance::m_pLegendAppearance
CXTPChartLegendAppearance * m_pLegendAppearance
Pointer to the legend appearance object.
Definition XTPChartAppearance.h:197
CXTPChartContentAppearance::BorderColor
CXTPChartColor BorderColor
The border color of the chart.
Definition XTPChartAppearance.h:192
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartDiagram2DAppearance
This class represents the appearance of diagram in 2D.
Definition XTPChartAppearance.h:292
CXTPChartDiagram2DAppearance::CXTPChartDiagram2DAppearance
CXTPChartDiagram2DAppearance(CXTPChartElement *pOwner)
Constructs a CXTPChartDiagram2DAppearance object.
CXTPChartDiagram2DAppearance::DoPropExchange
void DoPropExchange(CXTPPropExchange *pPX)
Call this member function to Store/Load the properties related to the appearance of a diagram in 2D,...
CXTPChartDiagram2DAppearance::~CXTPChartDiagram2DAppearance
virtual ~CXTPChartDiagram2DAppearance()
Destroys a CXTPChartDiagram2DAppearance object, handles cleanup.
CXTPChartDiagram2DAppearance::m_pAxisAppearance
CXTPChartAxisAppearance * m_pAxisAppearance
Pointer to the chart axis appearance object.
Definition XTPChartAppearance.h:337
CXTPChartDiagram2DAppearance::BackgroundColor2
CXTPChartColor BackgroundColor2
The second background color of the diagram.
Definition XTPChartAppearance.h:332
CXTPChartDiagram2DAppearance::GetAxisAppearance
CXTPChartAxisAppearance * GetAxisAppearance() const
Obtains axis appearance object pointer.
Definition XTPChartAppearance.h:792
CXTPChartDiagram2DAppearance::BackgroundFillStyle
CXTPChartFillStyle * BackgroundFillStyle
The background fill style of the diagram.
Definition XTPChartAppearance.h:334
CXTPChartDiagram2DAppearance::BackgroundColor
CXTPChartColor BackgroundColor
The first background color of the diagram.
Definition XTPChartAppearance.h:331
CXTPChartDiagram2DAppearance::BorderColor
CXTPChartColor BorderColor
The border color of the diagram.
Definition XTPChartAppearance.h:333
CXTPChartDiagram3DAppearance
This class represents the appearance of diagram in 3D.
Definition XTPChartAppearance.h:363
CXTPChartDiagram3DAppearance::LightSpecularColor
CXTPChartColor LightSpecularColor
Light specular color.
Definition XTPChartAppearance.h:407
CXTPChartDiagram3DAppearance::DoPropExchange
void DoPropExchange(CXTPPropExchange *pPX)
Call this member function to Store/Load the properties related to the appearance of a diagram in 3D,...
CXTPChartDiagram3DAppearance::Antialiasing
BOOL Antialiasing
Antialiasing enable flag.
Definition XTPChartAppearance.h:413
CXTPChartDiagram3DAppearance::DefaultMaterialDiffuseColor
static const CXTPChartColor DefaultMaterialDiffuseColor
Default material diffuse color.
Definition XTPChartAppearance.h:425
CXTPChartDiagram3DAppearance::DefaultLightModelAmbientColor
static const CXTPChartColor DefaultLightModelAmbientColor
Default light model ambient color.
Definition XTPChartAppearance.h:421
CXTPChartDiagram3DAppearance::DefaultMaterialSpecularColor
static const CXTPChartColor DefaultMaterialSpecularColor
Default material specular color.
Definition XTPChartAppearance.h:426
CXTPChartDiagram3DAppearance::LightAmbientColor
CXTPChartColor LightAmbientColor
Light ambient color.
Definition XTPChartAppearance.h:405
CXTPChartDiagram3DAppearance::LightDiffuseColor
CXTPChartColor LightDiffuseColor
Light diffuse color.
Definition XTPChartAppearance.h:406
CXTPChartDiagram3DAppearance::DefaultLightDiffuseColor
static const CXTPChartColor DefaultLightDiffuseColor
Default light diffuse color.
Definition XTPChartAppearance.h:419
CXTPChartDiagram3DAppearance::MaterialShininess
float MaterialShininess
Material shininess factor in range [0..1].
Definition XTPChartAppearance.h:412
CXTPChartDiagram3DAppearance::MaterialDiffuseColor
CXTPChartColor MaterialDiffuseColor
Material diffuse color.
Definition XTPChartAppearance.h:410
CXTPChartDiagram3DAppearance::MaterialSpecularColor
CXTPChartColor MaterialSpecularColor
Material specular color.
Definition XTPChartAppearance.h:411
CXTPChartDiagram3DAppearance::DefaultAntialiasing
static const BOOL DefaultAntialiasing
Default antialiasing enable flag.
Definition XTPChartAppearance.h:430
CXTPChartDiagram3DAppearance::CXTPChartDiagram3DAppearance
CXTPChartDiagram3DAppearance(CXTPChartElement *pOwner)
Constructs a CXTPChartDiagram3DAppearance object.
CXTPChartDiagram3DAppearance::DefaultLightPosition
static const CXTPPoint3f DefaultLightPosition
Default light position vector, each component is a normalized value in range [0..1].
Definition XTPChartAppearance.h:415
CXTPChartDiagram3DAppearance::DefaultLightSpecularColor
static const CXTPChartColor DefaultLightSpecularColor
Default light specular color.
Definition XTPChartAppearance.h:420
CXTPChartDiagram3DAppearance::ApplyToDeviceContext
virtual void ApplyToDeviceContext(CXTPChartDeviceContext *pDC)
Applies implementation specific appearance settings to the device context provided.
CXTPChartDiagram3DAppearance::DefaultMaterialShininess
static const float DefaultMaterialShininess
Default material shininess factor in range [0..1].
Definition XTPChartAppearance.h:428
CXTPChartDiagram3DAppearance::~CXTPChartDiagram3DAppearance
virtual ~CXTPChartDiagram3DAppearance()
Destroys a CXTPChartDiagram3DAppearance object, handles cleanup.
CXTPChartDiagram3DAppearance::DefaultMaterialEmissionColor
static const CXTPChartColor DefaultMaterialEmissionColor
Default material emission color.
Definition XTPChartAppearance.h:423
CXTPChartDiagram3DAppearance::LightModelAmbientColor
CXTPChartColor LightModelAmbientColor
Light model ambient color.
Definition XTPChartAppearance.h:408
CXTPChartDiagram3DAppearance::DefaultLightAmbientColor
static const CXTPChartColor DefaultLightAmbientColor
Default light ambient color.
Definition XTPChartAppearance.h:418
CXTPChartDiagram3DAppearance::MaterialEmissionColor
CXTPChartColor MaterialEmissionColor
Material emission color.
Definition XTPChartAppearance.h:409
CXTPChartElementAppearance
This class represents the appearance of a chart element.
Definition XTPChartAppearance.h:43
CXTPChartElementAppearance::~CXTPChartElementAppearance
virtual ~CXTPChartElementAppearance()
Destroys a CXTPChartElementAppearance object, handles cleanup.
CXTPChartElementAppearance::ApplyToDeviceContext
virtual void ApplyToDeviceContext(CXTPChartDeviceContext *pDC)
Applies implementation specific appearance settings to the device context provided.
CXTPChartElementAppearance::CXTPChartElementAppearance
CXTPChartElementAppearance(CXTPChartElement *pOwner)
Constructs a CXTPChartElementAppearance object.
CXTPChartElement
This class abstracts a chart element, this class acts as a base class for all chart elements.
Definition XTPChartElement.h:131
CXTPChartElement::DoPropExchange
virtual void DoPropExchange(CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
CXTPChartFillStyle
This class abstracts a fill style used to fill the background of various chart elements.
Definition XTPChartFillStyle.h:43
CXTPChartFinanceStyleAppearance
This class represents the finance series appearance of the chart.
Definition XTPChartAppearance.h:548
CXTPChartFinanceStyleAppearance::DoPropExchange
void DoPropExchange(CXTPPropExchange *pPX)
Call this member function to Store/Load the properties related to the appearance of a diagram in 2D,...
CXTPChartFinanceStyleAppearance::CXTPChartFinanceStyleAppearance
CXTPChartFinanceStyleAppearance(CXTPChartElement *pOwner)
Constructs a CXTPChartFinanceStyleAppearance object.
CXTPChartFinanceStyleAppearance::UpColor
CXTPChartColor UpColor
Up day line color.
Definition XTPChartAppearance.h:579
CXTPChartFinanceStyleAppearance::~CXTPChartFinanceStyleAppearance
virtual ~CXTPChartFinanceStyleAppearance()
Destroys a CXTPChartFinanceStyleAppearance object, handles cleanup.
CXTPChartFinanceStyleAppearance::DownColor
CXTPChartColor DownColor
Down day line Color.
Definition XTPChartAppearance.h:580
CXTPChartLegendAppearance
This class represents the appearance of a chart legend.
Definition XTPChartAppearance.h:107
CXTPChartLegendAppearance::DoPropExchange
void DoPropExchange(CXTPPropExchange *pPX)
Call this member function to Store/Load the properties related to the appearance of a chart legend us...
CXTPChartLegendAppearance::TextColor
CXTPChartColor TextColor
The legend text color.
Definition XTPChartAppearance.h:132
CXTPChartLegendAppearance::BackgroundColor
CXTPChartColor BackgroundColor
The legend background color.
Definition XTPChartAppearance.h:133
CXTPChartLegendAppearance::CXTPChartLegendAppearance
CXTPChartLegendAppearance(CXTPChartElement *pOwner)
Constructs a CXTPChartLegendAppearance object.
CXTPChartLegendAppearance::BorderColor
CXTPChartColor BorderColor
The legend border color.
Definition XTPChartAppearance.h:134
CXTPChartPalette
This class abstracts a color palette.
Definition XTPChartPalette.h:57
CXTPChartPieStyleAppearance
This class represents the pie series appearance of the chart.
Definition XTPChartAppearance.h:589
CXTPChartPieStyleAppearance::~CXTPChartPieStyleAppearance
virtual ~CXTPChartPieStyleAppearance()
Destroys a CXTPChartPieStyleAppearance object, handles cleanup.
CXTPChartPieStyleAppearance::DoPropExchange
void DoPropExchange(CXTPPropExchange *pPX)
Call this member function to Store/Load the properties related to the appearance of a diagram in 2D,...
CXTPChartPieStyleAppearance::CXTPChartPieStyleAppearance
CXTPChartPieStyleAppearance(CXTPChartElement *pOwner)
Constructs a CXTPChartPieStyleAppearance object.
CXTPChartPieStyleAppearance::BorderColor
CXTPChartColor BorderColor
Border color.
Definition XTPChartAppearance.h:620
CXTPChartTitleAppearance
This class represents the appearance of a chart title.
Definition XTPChartAppearance.h:74
CXTPChartTitleAppearance::DoPropExchange
void DoPropExchange(CXTPPropExchange *pPX)
Call this member function to Store/Load the properties related to the appearance of a chart title usi...
CXTPChartTitleAppearance::CXTPChartTitleAppearance
CXTPChartTitleAppearance(CXTPChartElement *pOwner)
Constructs a CXTPChartTitleAppearance object.
CXTPPoint3T< float >
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72


Toolkit Pro: Member List

CXTPChartTextElement Member List

This is the complete list of members for CXTPChartTextElement, including all inherited members.

CXTPChartElement() | CXTPChartElement |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
DoPropExchange(CXTPPropExchange *pPX) | CXTPChartElement | virtual
GetAntialiasing() const =0 | CXTPChartTextElement | pure virtual
GetAppearance() const | CXTPChartElement |
GetContent() const | CXTPChartElement |
GetFont() const =0 | CXTPChartTextElement | pure virtual
GetOwner() const | CXTPChartElement |
Is3D() const | CXTPChartObject |
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartElement | virtual
Release() | CXTPChartElement | virtual
~CXTPChartElement() | CXTPChartElement | virtual


Toolkit Pro: Member List

CXTPPropertyPageNavigator Member List

This is the complete list of members for CXTPPropertyPageNavigator, including all inherited members.

Create()=0 | CXTPPropertyPageNavigator | pure virtual
CXTPPropertyPageNavigator() | CXTPPropertyPageNavigator |
GetPageBrush(CDC *pDC, CXTPPropertyPage *pPage)=0 | CXTPPropertyPageNavigator | pure virtual
GetPageColor()=0 | CXTPPropertyPageNavigator | pure virtual
GetSafeHwnd() const =0 | CXTPPropertyPageNavigator | pure virtual
m_pSheet | CXTPPropertyPageNavigator | protected
m_rcButtonMargin | CXTPPropertyPageNavigator |
m_rcNavigatorMargin | CXTPPropertyPageNavigator |
m_rcPageMargin | CXTPPropertyPageNavigator |
OnPageSelected(CXTPPropertyPage *pPage)=0 | CXTPPropertyPageNavigator | pure virtual
PageToSize(AFX_SIZEPARENTPARAMS *pLayout, CSize szPage, CRect &rcPage, CSize &szClient)=0 | CXTPPropertyPageNavigator | pure virtual
SetTheme(XTPControlTheme theme) | CXTPPropertyPageNavigator | virtual
SizeToPage(AFX_SIZEPARENTPARAMS *pLayout, CSize szClient, CRect &rcPage)=0 | CXTPPropertyPageNavigator | pure virtual
~CXTPPropertyPageNavigator() | CXTPPropertyPageNavigator | virtual


Toolkit Pro: XTPRibbonBackstagePagePrint.h Source File

  • Source
  • Ribbon
  • Backstage
  • Pages
XTPRibbonBackstagePagePrint.h
Go to the documentation of this file.
1
23#if !defined(__XTPRIBBONBACKSTAGEPAGEPRINT_H__)
24# define __XTPRIBBONBACKSTAGEPAGEPRINT_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
34// CXTPRibbonBackstagePagePrint dialog
35
36class _XTP_EXT_CLASS CXTPRibbonBackstagePagePrint : public CXTPRibbonBackstagePage
37{
39 DECLARE_DYNCREATE(CXTPRibbonBackstagePagePrint)
42 // Construction/Destruction
43public:
44 CXTPRibbonBackstagePagePrint();
45 virtual ~CXTPRibbonBackstagePagePrint();
46
47 //{{AFX_DATA(CXTPRibbonBackstagePagePrint)
48 enum
49 {
50 IDD = XTP_IDD_RIBBONBACKSTAGEPAGE_PRINT
51 };
52 int m_nCopies;
53 //}}AFX_DATA
54
55 virtual void SetTheme(const XTPControlTheme nTheme);
56
57public:
58 CXTPRibbonBackstageButton m_btnPrint;
59 CXTPRibbonBackstageSeparator m_lblSeparator4;
60 CXTPRibbonBackstageSeparator m_lblSeparator1;
61 void InitButton(UINT nID);
62
63 CXTPRibbonBackstageLabel m_lblPrint;
64
65 BOOL OnSetActive();
66 BOOL OnKillActive();
67
68 class CBackstagePreviewView : public CXTPPreviewView
69 {
70 friend class CXTPRibbonBackstagePagePrint;
71 };
72
73 class CBackstagePrintView : CView
74 {
75 friend class CXTPRibbonBackstagePagePrint;
76 };
77
78 CBackstagePreviewView* m_pPreviewView;
79 CFrameWnd* m_pFrameWnd;
80 CBackstagePrintView* m_pView;
81
82 void UpdateCopies(BOOL bSaveAndValidate);
83
84 BOOL CreatePrintPreview();
85
86 //{{AFX_VIRTUAL(CXTPRibbonBackstagePagePrint)
87protected:
88 virtual BOOL OnInitDialog();
89 virtual void DoDataExchange(CDataExchange* pDX);
90 //}}AFX_VIRTUAL
91
92protected:
93 //{{AFX_MSG(CXTPRibbonBackstagePagePrint)
94 afx_msg void OnButtonPrint();
95 //}}AFX_MSG
96 DECLARE_MESSAGE_MAP()
97
98 CXTPImageManager m_imgMgr;
99};
100
101//{{AFX_INSERT_LOCATION}}
102
103# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
105#endif // !defined(__XTPRIBBONBACKSTAGEPAGEPRINT_H__)
XTPControlTheme
XTPControlTheme
Enumeration used to determine the active theme style.
Definition XTPControlTheme.h:43
XTPDisableNoisyWarnings.h
CXTPImageManager
CXTPImageManager is a standalone class.
Definition XTPImageManager.h:1898
CXTPPreviewView
CXTPPreviewView is a CPreviewView derived class that represents a print preview window with a themed ...
Definition XTPPreviewView.h:45


Toolkit Pro: Member List

CXTPImageManagerImageList Member List

This is the complete list of members for CXTPImageManagerImageList, including all inherited members.

CXTPImageManagerImageList() | CXTPImageManagerImageList
Draw(CDC *pDC, CPoint pt, CXTPImageManagerIcon *pIcon, CSize szIcon, COLORREF clrBK=CLR_NONE, COLORREF clrFG=CLR_NONE, UINT uiFlags=0) | CXTPImageManagerImageList
GetBitmapHandle(UINT nCommand) const | CXTPImageManagerImageList
GetIcon(UINT nCommand) | CXTPImageManagerImageList
GetIconHandle(UINT nCommand) const | CXTPImageManagerImageList
GetIconSize() const | CXTPImageManagerImageList
Lookup(UINT nCommand) | CXTPImageManagerImageList
RemoveAll() | CXTPImageManagerImageList
~CXTPImageManagerImageList() | CXTPImageManagerImageList


Toolkit Pro: XTPComboBoxThemeNativeWindows11.h Source File

  • Source
  • Controls
  • Combo
  • Themes
XTPComboBoxThemeNativeWindows11.h
Go to the documentation of this file.
1
23#if !defined(__XTPCOMBOBOXTHEMENATIVEWINDOWS11_H__)
24# define __XTPCOMBOBOXTHEMENATIVEWINDOWS11_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPComboBoxThemeNativeWindows11 : public CXTPComboBoxThemeOffice2013
39{
40public:
45 CXTPComboBoxThemeNativeWindows11();
46
51 virtual ~CXTPComboBoxThemeNativeWindows11();
52
59 virtual void RefreshMetrics(CXTPComboBox* pComboBox);
60
69 virtual void DrawButton(CDC* pDC, CXTPComboBox* pComboBox, CRect rcBtn);
70};
71
72# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
74#endif // __XTPCOMBOBOXTHEMENATIVEWINDOWS11_H__
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPComboBox
The CXTPComboBox class provides the functionality of a themed Windows combobox.
Definition XTPComboBox.h:42
CXTPComboBoxThemeNativeWindows11
Used as the paint manager for a combobox control to render a Native Windows 10 appearance.
Definition XTPComboBoxThemeNativeWindows11.h:39
CXTPComboBoxThemeNativeWindows11::RefreshMetrics
virtual void RefreshMetrics(CXTPComboBox *pComboBox)
This member function is called by the theme manager to refresh the visual styles used by each compone...
CXTPComboBoxThemeNativeWindows11::CXTPComboBoxThemeNativeWindows11
CXTPComboBoxThemeNativeWindows11()
Default constructor.
CXTPComboBoxThemeNativeWindows11::~CXTPComboBoxThemeNativeWindows11
virtual ~CXTPComboBoxThemeNativeWindows11()
Destructor handles cleanup and deallocation.
CXTPComboBoxThemeNativeWindows11::DrawButton
virtual void DrawButton(CDC *pDC, CXTPComboBox *pComboBox, CRect rcBtn)
Called by the paint manager to draw the button portion of the combobox control.
CXTPComboBoxThemeOffice2013
Used as the paint manager for a combobox control to render an Office 2013 appearance.
Definition XTPComboBoxThemeOffice2013.h:39


Toolkit Pro: XTPPropExchangeIniFile.h Source File

  • Source
  • Common
  • PropExchange
XTPPropExchangeIniFile.h
Go to the documentation of this file.
1
23#if !defined(__XTPPROPEXCHANGEINIFILE_H__)
24# define __XTPPROPEXCHANGEINIFILE_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
50class _XTP_EXT_CLASS CXTPPropExchangeIniFile : public CXTPPropExchange
51{
53 DECLARE_DYNAMIC(CXTPPropExchangeIniFile)
55public:
65 CXTPPropExchangeIniFile(BOOL bLoading, LPCTSTR lpszParentSection, LPCTSTR lpszSection);
66
72 ~CXTPPropExchangeIniFile();
73
98 virtual BOOL ExchangeProp(LPCTSTR pszPropName, VARTYPE vtProp, void* pvProp,
99 const void* pvDefault = NULL);
100
116 virtual CXTPPropExchange* GetSection(LPCTSTR lpszSection);
117
124 virtual BOOL OnBeforeExchange();
125
131 void SaveToFile(LPCTSTR strFileName);
132
140 BOOL LoadFromFile(LPCTSTR lpszFileName);
141
147 void AssignFile(LPCTSTR lpszFileName);
148
153 virtual void EmptySection();
154
155protected:
156 CString m_strSectionName;
157 CString m_strFileName;
158 BOOL m_bTempFile;
159};
160
161# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
163#endif // !defined(__XTPPROPEXCHANGEINIFILE_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72
CXTPPropExchangeIniFile
CXTPPropExchangeIniFile is CXTPPropExchange derived class.
Definition XTPPropExchangeIniFile.h:51
CXTPPropExchangeIniFile::m_strSectionName
CString m_strSectionName
Section name.
Definition XTPPropExchangeIniFile.h:156
CXTPPropExchangeIniFile::GetSection
virtual CXTPPropExchange * GetSection(LPCTSTR lpszSection)
This method creates new section for text base storages (CXTPPropExchangeXMLNode and CXTPPropExchangeR...
CXTPPropExchangeIniFile::m_bTempFile
BOOL m_bTempFile
TRUE if temporary file was created.
Definition XTPPropExchangeIniFile.h:158
CXTPPropExchangeIniFile::CXTPPropExchangeIniFile
CXTPPropExchangeIniFile(BOOL bLoading, LPCTSTR lpszParentSection, LPCTSTR lpszSection)
Constructs CXTPPropExchangeIniFile a object.
CXTPPropExchangeIniFile::SaveToFile
void SaveToFile(LPCTSTR strFileName)
Saves an ini file to the specified location.
CXTPPropExchangeIniFile::EmptySection
virtual void EmptySection()
Call this method to free section information before storing.
CXTPPropExchangeIniFile::LoadFromFile
BOOL LoadFromFile(LPCTSTR lpszFileName)
Loads the contents of an existing ini file.
CXTPPropExchangeIniFile::m_strFileName
CString m_strFileName
Temporary file name.
Definition XTPPropExchangeIniFile.h:157
CXTPPropExchangeIniFile::AssignFile
void AssignFile(LPCTSTR lpszFileName)
Assign ini file to CXTPPropExchangeIniFile class.
CXTPPropExchangeIniFile::OnBeforeExchange
virtual BOOL OnBeforeExchange()
This method is called before exchange properties.
CXTPPropExchangeIniFile::~CXTPPropExchangeIniFile
~CXTPPropExchangeIniFile()
Destroys a CXTPPropExchangeIniFile object, handles cleanup and deallocation.
CXTPPropExchangeIniFile::ExchangeProp
virtual BOOL ExchangeProp(LPCTSTR pszPropName, VARTYPE vtProp, void *pvProp, const void *pvDefault=NULL)
Exchanges a property between a storage medium and the control.


Toolkit Pro: XTPShellPidl.h Source File

  • Source
  • Controls
  • Shell
XTPShellPidl.h
Go to the documentation of this file.
1
23#if !defined(__XTPSHELLPIDL_H__)
24# define __XTPSHELLPIDL_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
41struct XTP_LVITEMDATA
42{
43 ULONG ulAttribs;
44 LPITEMIDLIST lpi;
45 LPSHELLFOLDER lpsfParent;
46};
47
56struct XTP_TVITEMDATA
57{
58 LPITEMIDLIST lpi;
59 LPITEMIDLIST lpifq;
60 LPSHELLFOLDER lpsfParent;
61};
62
68class _XTP_EXT_CLASS CXTPShellPidl
69{
70public:
77 class _XTP_EXT_CLASS CShellMalloc
78 {
79 public:
85 CShellMalloc()
86 {
87 m_lpMalloc = NULL;
88
89 if (FAILED(::SHGetMalloc(&m_lpMalloc)))
90 {
91 m_lpMalloc = NULL;
92 }
93 }
94
100 virtual ~CShellMalloc()
101 {
102 if (m_lpMalloc)
103 {
104 m_lpMalloc->Release();
105 }
106 }
107
116 void* Alloc(DWORD nBytes)
117 {
118 _ASSERTE(m_lpMalloc != NULL);
119 return m_lpMalloc ? m_lpMalloc->Alloc(nBytes) : NULL;
120 }
121
128 void Free(void* lpMem)
129 {
130 _ASSERTE(m_lpMalloc != NULL);
131 if (m_lpMalloc)
132 {
133 m_lpMalloc->Free(lpMem);
134 }
135 }
136
143 operator LPMALLOC()
144 {
145 return m_lpMalloc;
146 }
147
148 protected:
149 LPMALLOC m_lpMalloc;
150 };
151
158 class _XTP_EXT_CLASS CShellSpecialFolder
159 {
160 public:
170 CShellSpecialFolder(int nFolder = CSIDL_DESKTOP);
171
177 virtual ~CShellSpecialFolder()
178 {
179 if (m_lpFolder)
180 {
181 m_lpFolder->Release();
182 }
183 }
184
192 operator LPSHELLFOLDER()
193 {
194 return m_lpFolder;
195 }
196
197 protected:
198 LPSHELLFOLDER m_lpFolder;
199 };
200
205 CXTPShellPidl();
206
211 virtual ~CXTPShellPidl();
212
220 LPITEMIDLIST IDLFromPath(LPCTSTR path);
221
229 LPITEMIDLIST OneUpPIDL(LPITEMIDLIST pidlPath);
230
238 CString OneUpPATH(const CString& path);
239
247 LPITEMIDLIST GetLastITEM(LPITEMIDLIST pidl);
248
257 LPITEMIDLIST CopyIDList(LPITEMIDLIST pidl);
258
267 LPITEMIDLIST ConcatPidls(LPCITEMIDLIST pidl1, LPCITEMIDLIST pidl2);
268
278 LPITEMIDLIST ConcatPidls(LPMALLOC lpMalloc, LPCITEMIDLIST pidl1, LPCITEMIDLIST pidl2);
279
289 LPITEMIDLIST GetFullyQualPidl(LPSHELLFOLDER lpsf, LPITEMIDLIST lpi);
290
299 LPITEMIDLIST DuplicateItem(LPMALLOC lpMalloc, LPITEMIDLIST lpi);
300
312 BOOL GetName(LPSHELLFOLDER lpsf, LPITEMIDLIST lpi, DWORD dwFlags, CString& lpFriendlyName);
313
322 LPITEMIDLIST CreatePidl(LPMALLOC lpMalloc, UINT cbSize);
323
332 UINT GetPidlItemCount(LPCITEMIDLIST pidl);
333
341 LPITEMIDLIST GetNextPidlItem(LPCITEMIDLIST pidl);
342
354 BOOL ShowContextMenu(HWND hwnd, LPSHELLFOLDER lpsfParent, LPITEMIDLIST lpi, LPPOINT lppt);
355
368 BOOL ShowContextMenu(HWND hwnd, LPSHELLFOLDER lpsfParent, LPCITEMIDLIST* lppi, int nCount,
369 LPPOINT lppt);
370
387 int GetItemIcon(LPITEMIDLIST lpi, UINT uFlags) const;
388
402 HIMAGELIST GetSystemImageList(UINT uFlags) const;
403
414 ULONG GetAttributes(LPSHELLFOLDER lpsf, LPITEMIDLIST lpi, ULONG uFlags) const;
415
429 HRESULT GetSHContextMenu(LPSHELLFOLDER psfFolder, LPCITEMIDLIST* localPidl, int nCount,
430 void** ppCM, int* pcmType);
431
450 static int CALLBACK TreeViewCompareProc(LPARAM lparam1, LPARAM lparam2, LPARAM lparamSort);
451
470 static int CALLBACK ListViewCompareProc(LPARAM lparam1, LPARAM lparam2, LPARAM lparamSort);
471
477 void ShowShellLinkIcons(BOOL bShowLinkIcons = TRUE);
478
486 UINT GetPidlCount(LPCITEMIDLIST pidl);
487
493 void FreePidl(LPITEMIDLIST pidl);
494
504 LPITEMIDLIST CopyPidlItem(LPITEMIDLIST pidl, UINT nItem);
505
516 BOOL ComparePidls(LPCITEMIDLIST pidl1, LPCITEMIDLIST pidl2, LPSHELLFOLDER pShellFolder = NULL);
517
518protected:
526 virtual void OnShowContextMenu(int idCmd, CMINVOKECOMMANDINFO& cmi);
527
535 virtual void MapShellFlagsToItemAttributes(CListCtrl* pListCtrl, int iItem, DWORD dwAttributes);
536
544 virtual void MapShellFlagsToItemAttributes(CTreeCtrl* pTreeCtrl, HTREEITEM hItem,
545 DWORD dwAttributes);
546
547protected:
548 ULONG m_ulSFGAOFlags;
549 BOOL m_bShowShellLinkIcons;
551private:
552 static WNDPROC m_pOldWndProc;
553 static LPCONTEXTMENU2 m_pIContext2;
554 static LRESULT CALLBACK HookWndProc(HWND hWnd, UINT msg, WPARAM wp, LPARAM lp);
555};
556
558AFX_INLINE void CXTPShellPidl::ShowShellLinkIcons(BOOL bShowLinkIcons /*= TRUE*/)
559{
560 m_bShowShellLinkIcons = bShowLinkIcons;
561}
562
563# ifndef CSIDL_MYPICTURES
564# define CSIDL_MYPICTURES 0x0027
565# endif
566
567# ifndef SFGAO_STREAM
568# define SFGAO_STREAM 0x00400000L
569# endif
570
571# ifndef SFGAO_ENCRYPTED
572# define SFGAO_ENCRYPTED 0x00002000L
573# endif
574
575# ifndef SHCIDS_ALLFIELDS
576# define SHCIDS_ALLFIELDS 0x80000000L
577# endif
579# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
581#endif // __XTPSHELLPIDL_H__
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPShellPidl::CShellMalloc
CXTPShellPidl::CShellMalloc is a helper class that is used by CXTPShellPidl to initialize a pointer t...
Definition XTPShellPidl.h:78
CXTPShellPidl::CShellMalloc::Free
void Free(void *lpMem)
Call this member function to free a block of previously allocated memory.
Definition XTPShellPidl.h:128
CXTPShellPidl::CShellMalloc::Alloc
void * Alloc(DWORD nBytes)
Call this member function to allocate a block of memory.
Definition XTPShellPidl.h:116
CXTPShellPidl::CShellMalloc::CShellMalloc
CShellMalloc()
Constructs a CXTPShellPidl::CShellMalloc object and initializes a pointer to the Shell's IMalloc inte...
Definition XTPShellPidl.h:85
CXTPShellPidl::CShellMalloc::~CShellMalloc
virtual ~CShellMalloc()
Destroys a CXTPShellPidl::CShellMalloc object, handles cleanup and deallocation.
Definition XTPShellPidl.h:100
CXTPShellPidl::CShellMalloc::m_lpMalloc
LPMALLOC m_lpMalloc
Pointer to Shell's IMalloc interface for this object.
Definition XTPShellPidl.h:149
CXTPShellPidl::CShellSpecialFolder
CXTPShellPidl::CShellSpecialFolder is a helper class that is used by CXTPShellPidl to initialize a po...
Definition XTPShellPidl.h:159
CXTPShellPidl::CShellSpecialFolder::~CShellSpecialFolder
virtual ~CShellSpecialFolder()
Destroys a CXTPShellPidl::CShellSpecialFolder object, handles cleanup and deallocation.
Definition XTPShellPidl.h:177
CXTPShellPidl::CShellSpecialFolder::CShellSpecialFolder
CShellSpecialFolder(int nFolder=CSIDL_DESKTOP)
Constructs a CXTPShellPidl::CShellSpecialFolder object and initializes a pointer to the ITEMIDLIST st...
CXTPShellPidl::CShellSpecialFolder::m_lpFolder
LPSHELLFOLDER m_lpFolder
Pointer to the interface for the desktop folder.
Definition XTPShellPidl.h:198
CXTPShellPidl
CXTPShellPidl is a standalone base class.
Definition XTPShellPidl.h:69
CXTPShellPidl::CreatePidl
LPITEMIDLIST CreatePidl(LPMALLOC lpMalloc, UINT cbSize)
This member function allocates a PIDL.
CXTPShellPidl::~CXTPShellPidl
virtual ~CXTPShellPidl()
Destroys a CXTPShellPidl object, handles cleanup and deallocation.
CXTPShellPidl::m_bShowShellLinkIcons
BOOL m_bShowShellLinkIcons
Set to FALSE to override shortcut link display.
Definition XTPShellPidl.h:549
CXTPShellPidl::TreeViewCompareProc
static int CALLBACK TreeViewCompareProc(LPARAM lparam1, LPARAM lparam2, LPARAM lparamSort)
CXTPShellTreeCtrl callback sort function.
CXTPShellPidl::CopyIDList
LPITEMIDLIST CopyIDList(LPITEMIDLIST pidl)
This member function copies a whole ITEMIDLIST.
CXTPShellPidl::GetPidlCount
UINT GetPidlCount(LPCITEMIDLIST pidl)
Calculates the number of item IDs in the list.
CXTPShellPidl::ShowContextMenu
BOOL ShowContextMenu(HWND hwnd, LPSHELLFOLDER lpsfParent, LPITEMIDLIST lpi, LPPOINT lppt)
This member function displays a pop-up context menu if given a parent shell folder,...
CXTPShellPidl::ComparePidls
BOOL ComparePidls(LPCITEMIDLIST pidl1, LPCITEMIDLIST pidl2, LPSHELLFOLDER pShellFolder=NULL)
This member function compares two PIDLs to determine if they match.
CXTPShellPidl::ShowShellLinkIcons
void ShowShellLinkIcons(BOOL bShowLinkIcons=TRUE)
Call this member function to override the shortcut link display for each item.
CXTPShellPidl::CXTPShellPidl
CXTPShellPidl()
Constructs a CXTPShellPidl object.
CXTPShellPidl::OneUpPATH
CString OneUpPATH(const CString &path)
This member function gets the parent folder using PIDLs.
CXTPShellPidl::ConcatPidls
LPITEMIDLIST ConcatPidls(LPCITEMIDLIST pidl1, LPCITEMIDLIST pidl2)
This member function concatenates two PIDLs.
CXTPShellPidl::ConcatPidls
LPITEMIDLIST ConcatPidls(LPMALLOC lpMalloc, LPCITEMIDLIST pidl1, LPCITEMIDLIST pidl2)
This member function concatenates two PIDLs.
CXTPShellPidl::OneUpPIDL
LPITEMIDLIST OneUpPIDL(LPITEMIDLIST pidlPath)
This member function performs the OneUp or back function.
CXTPShellPidl::GetFullyQualPidl
LPITEMIDLIST GetFullyQualPidl(LPSHELLFOLDER lpsf, LPITEMIDLIST lpi)
This member function gets the fully qualified PIDLs for the specified folder.
CXTPShellPidl::MapShellFlagsToItemAttributes
virtual void MapShellFlagsToItemAttributes(CListCtrl *pListCtrl, int iItem, DWORD dwAttributes)
This function translates shell attributes into a tree item state.
CXTPShellPidl::DuplicateItem
LPITEMIDLIST DuplicateItem(LPMALLOC lpMalloc, LPITEMIDLIST lpi)
This member function copies the ITEMID.
CXTPShellPidl::MapShellFlagsToItemAttributes
virtual void MapShellFlagsToItemAttributes(CTreeCtrl *pTreeCtrl, HTREEITEM hItem, DWORD dwAttributes)
This function translates shell attributes into a tree item state.
CXTPShellPidl::GetLastITEM
LPITEMIDLIST GetLastITEM(LPITEMIDLIST pidl)
This member function walks an ITEMIDLIST and points to the last one.
CXTPShellPidl::GetSHContextMenu
HRESULT GetSHContextMenu(LPSHELLFOLDER psfFolder, LPCITEMIDLIST *localPidl, int nCount, void **ppCM, int *pcmType)
This member function retrieves the IContextMenu, IContextMenu2 or IContextMenu3 interface.
CXTPShellPidl::GetNextPidlItem
LPITEMIDLIST GetNextPidlItem(LPCITEMIDLIST pidl)
This member function retrieves the next PIDL in the list.
CXTPShellPidl::GetPidlItemCount
UINT GetPidlItemCount(LPCITEMIDLIST pidl)
This member function calculates the number of item IDs in an item ID list.
CXTPShellPidl::FreePidl
void FreePidl(LPITEMIDLIST pidl)
This member function frees memory allocated for a PIDL.
CXTPShellPidl::m_ulSFGAOFlags
ULONG m_ulSFGAOFlags
SFGAO flags used to retrieve shell item attributes.
Definition XTPShellPidl.h:548
CXTPShellPidl::CopyPidlItem
LPITEMIDLIST CopyPidlItem(LPITEMIDLIST pidl, UINT nItem)
This member function copies a single PIDL out of a list.
CXTPShellPidl::GetAttributes
ULONG GetAttributes(LPSHELLFOLDER lpsf, LPITEMIDLIST lpi, ULONG uFlags) const
Retrieves the attributes of one or more file objects or subfolders.
CXTPShellPidl::GetItemIcon
int GetItemIcon(LPITEMIDLIST lpi, UINT uFlags) const
This member function gets the index for the current icon.
CXTPShellPidl::OnShowContextMenu
virtual void OnShowContextMenu(int idCmd, CMINVOKECOMMANDINFO &cmi)
This method is called when an item of a context menu is executed.
CXTPShellPidl::GetName
BOOL GetName(LPSHELLFOLDER lpsf, LPITEMIDLIST lpi, DWORD dwFlags, CString &lpFriendlyName)
This member function gets the friendly name for the folder or file.
CXTPShellPidl::IDLFromPath
LPITEMIDLIST IDLFromPath(LPCTSTR path)
This member function gets the fully qualified PIDL for the path string.
CXTPShellPidl::GetSystemImageList
HIMAGELIST GetSystemImageList(UINT uFlags) const
Call this member function to retrieve a string that describes the type of file specified by lpi from ...
CXTPShellPidl::ListViewCompareProc
static int CALLBACK ListViewCompareProc(LPARAM lparam1, LPARAM lparam2, LPARAM lparamSort)
CXTPShellListCtrl callback sort function.
CXTPShellPidl::ShowContextMenu
BOOL ShowContextMenu(HWND hwnd, LPSHELLFOLDER lpsfParent, LPCITEMIDLIST *lppi, int nCount, LPPOINT lppt)
This member function displays a pop-up context menu if given a parent shell folder,...
XTP_LVITEMDATA
The XTP_LVITEMDATA structure is used to maintain information for a particular list item in a CXTPShel...
Definition XTPShellPidl.h:42
XTP_LVITEMDATA::lpsfParent
LPSHELLFOLDER lpsfParent
Pointer to the parent shell folder item.
Definition XTPShellPidl.h:45
XTP_LVITEMDATA::ulAttribs
ULONG ulAttribs
Shell item attributes.
Definition XTPShellPidl.h:43
XTP_LVITEMDATA::lpi
LPITEMIDLIST lpi
Pointer to an item ID list.
Definition XTPShellPidl.h:44
XTP_TVITEMDATA
The XTP_TVITEMDATA structure is used to maintain information for a particular tree item in a CXTPShel...
Definition XTPShellPidl.h:57
XTP_TVITEMDATA::lpsfParent
LPSHELLFOLDER lpsfParent
Pointer to the parent shell folder item.
Definition XTPShellPidl.h:60
XTP_TVITEMDATA::lpi
LPITEMIDLIST lpi
Pointer to an item ID list.
Definition XTPShellPidl.h:58
XTP_TVITEMDATA::lpifq
LPITEMIDLIST lpifq
Pointer to an item ID list.
Definition XTPShellPidl.h:59


Toolkit Pro: XTPGridThemeOfficeXP.h Source File

  • Source
  • GridControl
  • Themes
XTPGridThemeOfficeXP.h
Go to the documentation of this file.
1
23#if !defined(__XTPGridThemeOfficeXP_H__)
24# define __XTPGridThemeOfficeXP_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPGridThemeOfficeXP : public CXTPGridPaintManager
39{
40public:
45 CXTPGridThemeOfficeXP();
46
58 virtual void DrawColumnBackground(CDC* pDC, CXTPGridColumn* pColumn, CRect rcColumn,
59 BOOL& bColumnPressed, BOOL& bDraggingFromHeader,
60 CXTPGridHeader* pHeader = NULL);
61};
63# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
64#endif //#if !defined(__XTPGridThemeOfficeXP_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPGridColumn
Represents a grid column item with its properties and operations.
Definition XTPGridColumn.h:107
CXTPGridHeader
A grid header is a part of the grid window positioned above columns of text or numbers.
Definition XTPGridHeader.h:173
CXTPGridPaintManager
Utility class that handles most drawing activities.
Definition XTPGridPaintManager.h:76
CXTPGridThemeOfficeXP
CXTPGridThemeOfficeXP is a CXTPGridPaintManager derived class that represents an Office XP style them...
Definition XTPGridThemeOfficeXP.h:39
CXTPGridThemeOfficeXP::CXTPGridThemeOfficeXP
CXTPGridThemeOfficeXP()
Default paint manager constructor, handles properties initialization.
CXTPGridThemeOfficeXP::DrawColumnBackground
virtual void DrawColumnBackground(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, BOOL &bColumnPressed, BOOL &bDraggingFromHeader, CXTPGridHeader *pHeader=NULL)
This method is called to draw the background of a column using the current column style.


Toolkit Pro: XTPRibbonBackstageSeparatorThemeNativeWindows10.h Source File

  • Source
  • Ribbon
  • Backstage
XTPRibbonBackstageSeparatorThemeNativeWindows10.h
Go to the documentation of this file.
1
23#if !defined(__XTPRIBBONBACKSTAGESEPARATORTHEMENATIVEWINDOWS10_H__)
24# define __XTPRIBBONBACKSTAGESEPARATORTHEMENATIVEWINDOWS10_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPRibbonBackstageSeparator;
34
35class _XTP_EXT_CLASS CXTPRibbonBackstageSeparatorThemeNativeWindows10
36 : public CXTPRibbonBackstageSeparatorThemeOffice2013
37{
38public:
39 CXTPRibbonBackstageSeparatorThemeNativeWindows10();
40};
41
42# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
44#endif // !defined(__XTPRIBBONBACKSTAGESEPARATORTHEMENATIVEWINDOWS10_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h


Toolkit Pro: XTPPropertyGridItemNumber.h Source File

  • Source
  • PropertyGrid
XTPPropertyGridItemNumber.h
Go to the documentation of this file.
1
23#if !defined(__XTPPROPERTYGRIDITEMNUMBER_H__)
24# define __XTPPROPERTYGRIDITEMNUMBER_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPPropertyGridItemNumber : public CXTPPropertyGridItem
39{
40public:
76 CXTPPropertyGridItemNumber(LPCTSTR strCaption, long nValue = 0, long* pBindNumber = NULL);
77
113 CXTPPropertyGridItemNumber(UINT nID, long nValue = 0, long* pBindNumber = NULL);
114
119 virtual ~CXTPPropertyGridItemNumber();
120
121public:
127 virtual void SetNumber(long nValue);
128
135 virtual long GetNumber() const;
136
160 virtual void BindToNumber(long* pBindNumber);
161
162protected:
170 virtual void SetValue(CString strValue);
171
185 virtual void OnBeforeInsert();
186
187protected:
188 long m_nValue;
189 long* m_pBindNumber;
191private:
192# ifdef _XTP_ACTIVEX
194 afx_msg void OleSetValue(const VARIANT* varValue);
195 afx_msg const VARIANT OleGetValue();
196
197 void BindDispatch();
199# endif
200 DECLARE_DYNAMIC(CXTPPropertyGridItemNumber)
201};
202
208class _XTP_EXT_CLASS CXTPPropertyGridItemDouble : public CXTPPropertyGridItem
209{
210public:
249 CXTPPropertyGridItemDouble(LPCTSTR strCaption, double fValue = 0, LPCTSTR strFormat = NULL,
250 double* pBindNumber = NULL);
251
290 CXTPPropertyGridItemDouble(UINT nID, double fValue = 0, LPCTSTR strFormat = NULL,
291 double* pBindNumber = NULL);
292
297 virtual ~CXTPPropertyGridItemDouble();
298
299public:
305 virtual void SetDouble(double fValue);
306
313 virtual double GetDouble() const;
314
338 virtual void BindToDouble(double* pBindDouble);
339
355 void UseSystemDecimalSymbol(BOOL bUseSystemDecimalSymbol);
356
357protected:
365 virtual void SetValue(CString strValue);
366
380 virtual void OnBeforeInsert();
381
382protected:
392 virtual double StringToDouble(LPCTSTR lpszValue);
393
403 virtual CString DoubleToString(double dValue);
404
405protected:
406 double m_fValue;
407 double* m_pBindDouble;
408 BOOL m_bUseSystemDecimalSymbol;
411private:
412 DECLARE_DYNAMIC(CXTPPropertyGridItemDouble)
413
414# ifdef _XTP_ACTIVEX
416 afx_msg void OleSetValue(const VARIANT* varValue);
417 afx_msg const VARIANT OleGetValue();
418
419 DECLARE_DISPATCH_MAP()
420 DECLARE_INTERFACE_MAP()
421
422 DECLARE_OLETYPELIB_EX(CXTPPropertyGridItemDouble)
423
424 void BindDispatch();
426# endif
427};
428
430
431AFX_INLINE long CXTPPropertyGridItemNumber::GetNumber() const
432{
433 return m_nValue;
434}
435
437
438AFX_INLINE double CXTPPropertyGridItemDouble::GetDouble() const
439{
440 return m_fValue;
441}
442AFX_INLINE void CXTPPropertyGridItemDouble::UseSystemDecimalSymbol(BOOL bUseSystemDecimalSymbol)
443{
444 m_bUseSystemDecimalSymbol = bUseSystemDecimalSymbol;
445 m_strValue = DoubleToString(m_fValue);
446}
447
449# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
450#endif // #if !defined(__XTPPROPERTYGRIDITEMNUMBER_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPPropertyGridItemDouble
CXTPPropertyGridItemDouble is a CXTPPropertyGridItem derived class.
Definition XTPPropertyGridItemNumber.h:209
CXTPPropertyGridItemDouble::m_bUseSystemDecimalSymbol
BOOL m_bUseSystemDecimalSymbol
TRUE to use the system defined decimal symbol, FALSE to always use a decimal point "....
Definition XTPPropertyGridItemNumber.h:408
CXTPPropertyGridItemDouble::SetDouble
virtual void SetDouble(double fValue)
Sets the double value for the item.
CXTPPropertyGridItemDouble::OnBeforeInsert
virtual void OnBeforeInsert()
This method is called before the item becomes visible in the property grid.
CXTPPropertyGridItemDouble::GetDouble
virtual double GetDouble() const
Gets the double value of the item.
Definition XTPPropertyGridItemNumber.h:438
CXTPPropertyGridItemDouble::StringToDouble
virtual double StringToDouble(LPCTSTR lpszValue)
Converts a specified string to a double.
CXTPPropertyGridItemDouble::UseSystemDecimalSymbol
void UseSystemDecimalSymbol(BOOL bUseSystemDecimalSymbol)
Specifies which type of symbol should be used to divide the whole and decimal parts of numbers.
Definition XTPPropertyGridItemNumber.h:442
CXTPPropertyGridItemDouble::CXTPPropertyGridItemDouble
CXTPPropertyGridItemDouble(UINT nID, double fValue=0, LPCTSTR strFormat=NULL, double *pBindNumber=NULL)
Constructs a CXTPPropertyGridItemDouble object.
CXTPPropertyGridItemDouble::m_pBindDouble
double * m_pBindDouble
Pointer to the variable bound to this item.
Definition XTPPropertyGridItemNumber.h:407
CXTPPropertyGridItemDouble::SetValue
virtual void SetValue(CString strValue)
Sets the value of the item.
CXTPPropertyGridItemDouble::~CXTPPropertyGridItemDouble
virtual ~CXTPPropertyGridItemDouble()
Destroys a CXTPPropertyGridItemDouble object.
CXTPPropertyGridItemDouble::DoubleToString
virtual CString DoubleToString(double dValue)
Converts a specified double to a string.
CXTPPropertyGridItemDouble::BindToDouble
virtual void BindToDouble(double *pBindDouble)
Binds the item to a specified double value.
CXTPPropertyGridItemDouble::m_fValue
double m_fValue
Double value of the item.
Definition XTPPropertyGridItemNumber.h:406
CXTPPropertyGridItemDouble::CXTPPropertyGridItemDouble
CXTPPropertyGridItemDouble(LPCTSTR strCaption, double fValue=0, LPCTSTR strFormat=NULL, double *pBindNumber=NULL)
Constructs a CXTPPropertyGridItemDouble object.
CXTPPropertyGridItem
CXTPPropertyGridItem is the base class representing an item of the Property Grid control.
Definition XTPPropertyGridItem.h:523
CXTPPropertyGridItem::m_strValue
CString m_strValue
Value of the item.
Definition XTPPropertyGridItem.h:1759
CXTPPropertyGridItemNumber
CXTPPropertyGridItemNumber is a CXTPPropertyGridItem derived class.
Definition XTPPropertyGridItemNumber.h:39
CXTPPropertyGridItemNumber::OnBeforeInsert
virtual void OnBeforeInsert()
This method is called before the item becomes visible in the property grid.
CXTPPropertyGridItemNumber::CXTPPropertyGridItemNumber
CXTPPropertyGridItemNumber(UINT nID, long nValue=0, long *pBindNumber=NULL)
Constructs a CXTPPropertyGridItemNumber object.
CXTPPropertyGridItemNumber::SetValue
virtual void SetValue(CString strValue)
Sets the value of the item.
CXTPPropertyGridItemNumber::m_pBindNumber
long * m_pBindNumber
Pointer to the variable bound to this item.
Definition XTPPropertyGridItemNumber.h:189
CXTPPropertyGridItemNumber::GetNumber
virtual long GetNumber() const
Gets the long value of the item.
Definition XTPPropertyGridItemNumber.h:431
CXTPPropertyGridItemNumber::CXTPPropertyGridItemNumber
CXTPPropertyGridItemNumber(LPCTSTR strCaption, long nValue=0, long *pBindNumber=NULL)
Constructs a CXTPPropertyGridItemNumber object.
CXTPPropertyGridItemNumber::~CXTPPropertyGridItemNumber
virtual ~CXTPPropertyGridItemNumber()
Destroys a CXTPPropertyGridItemNumber object.
CXTPPropertyGridItemNumber::m_nValue
long m_nValue
Value of the item.
Definition XTPPropertyGridItemNumber.h:188
CXTPPropertyGridItemNumber::SetNumber
virtual void SetNumber(long nValue)
Sets the long value for the item.
CXTPPropertyGridItemNumber::BindToNumber
virtual void BindToNumber(long *pBindNumber)
Binds the item to a specified long value.


Toolkit Pro: XTPScrollInfo.h Source File

  • Source
  • Common
  • ScrollBar
XTPScrollInfo.h
Go to the documentation of this file.
1
23#if !defined(__XTPSCROLLINFO_H__)
24# define __XTPSCROLLINFO_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33# define XTP_TID_HOVERUP 5001
34# define XTP_TID_HOVERDOWN 5002
35
36class _XTP_EXT_CLASS XTP_SCROLLINFO
37{
38public:
39 class XTP_BTNSCROLL
40 {
41 public:
42 void Init(CWnd* pParent, UINT nID)
43 {
44 m_pParent = pParent;
45 m_nID = nID;
46 m_rc.SetRectEmpty();
47 m_nTimer = 0;
48 }
49
50 UINT m_nID;
51 UINT m_nTimer;
52 CRect m_rc;
53 CWnd* m_pParent;
54
55 void KillTimer()
56 {
57 if (0 != m_nTimer)
58 {
59 m_pParent->KillTimer(m_nTimer);
60 m_nTimer = 0;
61 }
62 }
63
64 void SetTimer()
65 {
66 if (m_nTimer == 0)
67 {
68 m_nTimer = (UINT)m_pParent->SetTimer(m_nID, 200, 0);
69 }
70 }
71
72 BOOL OnMouseMove(CPoint point)
73 {
74 if (m_rc.PtInRect(point))
75 {
76 SetTimer();
77 return TRUE;
78 }
79 else if (m_nTimer)
80 {
81 KillTimer();
82 }
83 return FALSE;
84 }
85 };
86
87 BOOL bScroll;
88 int nScrollFirst, nScrollLast;
89 XTP_BTNSCROLL btnUp;
90 XTP_BTNSCROLL btnDown;
91
92 void Init(CWnd* pWnd, UINT nIDUp, UINT nIDDown)
93 {
94 btnUp.Init(pWnd, nIDUp);
95 btnDown.Init(pWnd, nIDDown);
96 bScroll = nScrollFirst = nScrollLast = 0;
97 }
98};
99
100# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
102#endif // #if !defined(__XTPSCROLLINFO_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h


Toolkit Pro: Member List

  • CXTPDockingPaneWindowSelect
  • CItem
CXTPDockingPaneWindowSelect::CItem Member List

This is the complete list of members for CXTPDockingPaneWindowSelect::CItem, including all inherited members.

nColumn | CXTPDockingPaneWindowSelect::CItem
nIndex | CXTPDockingPaneWindowSelect::CItem
nRow | CXTPDockingPaneWindowSelect::CItem
rc | CXTPDockingPaneWindowSelect::CItem
type | CXTPDockingPaneWindowSelect::CItem


Toolkit Pro: XTPCoreTreeItem.h Source File

  • Source
  • Controls
  • CoreTree
XTPCoreTreeItem.h
Go to the documentation of this file.
1
23#if !defined(__XTPCORETREEITEM_H__)
24# define __XTPCORETREEITEM_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPCoreTreeItems;
34class CXTPCoreTreeControl;
35class CXTPImageManagerIcon;
36class CXTPPropExchange;
37class CXTPMarkupUIElement;
38
39class _XTP_EXT_CLASS CXTPCoreTreeItem : public CObject
40{
41 DECLARE_SERIAL(CXTPCoreTreeItem);
42
43public:
44 CXTPCoreTreeItem();
45
46protected:
47 virtual ~CXTPCoreTreeItem();
48
49public:
50 void SetCaption(LPCTSTR lpszCaption);
51 void SetLabel(BOOL bLabel = TRUE);
52
53 CString GetCaption() const;
54 BOOL IsLabel() const;
55
56 CRect GetRect() const;
57 CRect GetScreenRect() const;
58
59 void SetExpanded(BOOL bExpanded = TRUE);
60 BOOL IsExpanded() const;
61
62 BOOL IsSelected() const;
63
64 void ShowCheckbox(BOOL bHasCheckbox = TRUE);
65 BOOL IsCheckboxVisible() const;
66
67 void SetChecked(int nChecked);
68 int IsChecked() const;
69
70 void SetIconId(int nIconId);
71 int GetIconId() const;
72
73 void SetEnabled(BOOL bEnabled);
74 BOOL IsEnabled() const;
75
76 CXTPImageManagerIcon* GetImage() const;
77
78 CRect GetButtonRect() const;
79 CRect GetCheckboxRect() const;
80 CRect GetCaptionRect() const;
81
82 void Remove();
83
84 virtual void DoPropExchange(CXTPPropExchange* pPX);
85
92 DWORD_PTR GetItemData() const;
93
99 void SetItemData(DWORD_PTR dwData);
100
107 CXTPMarkupUIElement* GetMarkupUIElement() const;
108
109public:
110 DWORD AddRef();
111 DWORD Release();
112
113public:
114 void Invalidate();
115
116public:
117 BOOL HasChildren() const;
118 CXTPCoreTreeItems* GetChildren() const;
119 CXTPCoreTreeItems* GetParentItems() const;
120
121public:
122 CXTPCoreTreeItem* GetNextSiblingItem() const;
123 CXTPCoreTreeItem* GetPrevSiblingItem() const;
124
125 CXTPCoreTreeItem* GetParentItem() const;
126 CXTPCoreTreeItem* GetFirstChildItem() const;
127
128 BOOL IsParent(CXTPCoreTreeItem* pItem) const;
129 CXTPCoreTreeControl* GetTreeControl() const;
130
131public:
132 virtual CSize CalcSize(CDC* pDC, int nWidth) const;
133 virtual void Draw(CDC* pDC);
134
135public:
136 void SetRect(CRect rc);
137
138public:
139 static CXTPCoreTreeItem* AFX_CDECL CreateFromOleData(COleDataObject* pDataObject);
140 static CXTPCoreTreeItem* AFX_CDECL CreateFromOleFile(CFile* pFile);
141 HGLOBAL CacheGlobalData();
142 BOOL PrepareDrag(COleDataSource& srcItem);
143
144protected:
145 CString m_strCaption;
146 BOOL m_bLabel;
147 mutable CXTPCoreTreeItems* m_pChildren;
148 CXTPCoreTreeItem* m_pNextItem;
149 CXTPCoreTreeItem* m_pPrevItem;
150 CXTPCoreTreeItems* m_pParentItems;
151 CRect m_rcItem;
152 BOOL m_bExpanded;
153 CXTPCoreTreeControl* m_pControl;
154 BOOL m_bHasCheckBox;
155 int m_nChecked;
156 int m_nIconId;
157 BOOL m_bEnabled;
158 DWORD_PTR m_dwData;
159 long m_dwRef;
160 CXTPMarkupUIElement* m_pMarkupUIElement;
162 friend class CXTPCoreTreeItems;
163};
164
165class _XTP_EXT_CLASS CXTPCoreTreeItems
166{
167public:
168 CXTPCoreTreeItems();
169
170protected:
171 virtual ~CXTPCoreTreeItems();
172
173public:
174 CXTPCoreTreeItem* AddItem(LPCTSTR lpszCaption);
175
176 CXTPCoreTreeItem* AddItemAfter(CXTPCoreTreeItem* pItem, CXTPCoreTreeItem* pPrevItem = NULL);
177 CXTPCoreTreeItem* AddItemBefore(CXTPCoreTreeItem* pItem, CXTPCoreTreeItem* pNextItem = NULL);
178
179 void MoveItemAfter(CXTPCoreTreeItem* pItem, CXTPCoreTreeItem* pPrevItem = NULL);
180 void MoveItemBefore(CXTPCoreTreeItem* pItem, CXTPCoreTreeItem* pPrevItem = NULL);
181
182public:
183 int GetCount() const;
184
185public:
186 void RemoveAll();
187 void RemoveItem(CXTPCoreTreeItem* pItem);
188
189public:
190 POSITION GetHeadPosition() const;
191 CXTPCoreTreeItem* GetNext(POSITION& rPosition) const;
192
193public:
194 CXTPCoreTreeItem* GetFirstItem() const;
195 CXTPCoreTreeItem* GetLastItem() const;
196
197 CXTPCoreTreeItem* GetNextItem(const CXTPCoreTreeItem* pItem) const;
198 CXTPCoreTreeItem* GetPrevItem(const CXTPCoreTreeItem* pItem) const;
199
200protected:
201 CXTPCoreTreeItem* m_pFirstItem;
202 CXTPCoreTreeItem* m_pLastItem;
203 CXTPCoreTreeItem* m_pOwnerItem;
204 CXTPCoreTreeControl* m_pControl;
205 int m_nCount;
206
207 friend class CXTPCoreTreeItem;
208 friend class CXTPCoreTreeControl;
209};
211AFX_INLINE CString CXTPCoreTreeItem::GetCaption() const
212{
213 return m_strCaption;
214}
215AFX_INLINE BOOL CXTPCoreTreeItem::IsLabel() const
216{
217 return m_bLabel;
218}
219AFX_INLINE void CXTPCoreTreeItem::SetLabel(BOOL bLabel)
220{
221 m_bLabel = bLabel;
222 Invalidate();
223}
224AFX_INLINE CXTPCoreTreeItems* CXTPCoreTreeItem::GetParentItems() const
225{
226 return m_pParentItems;
227}
228AFX_INLINE void CXTPCoreTreeItem::ShowCheckbox(BOOL bHasCheckbox)
229{
230 m_bHasCheckBox = bHasCheckbox;
231}
232AFX_INLINE BOOL CXTPCoreTreeItem::IsCheckboxVisible() const
233{
234 return m_bHasCheckBox;
235}
236AFX_INLINE void CXTPCoreTreeItem::SetChecked(int nChecked)
237{
238 m_nChecked = nChecked;
239 Invalidate();
240}
241AFX_INLINE int CXTPCoreTreeItem::IsChecked() const
242{
243 return m_nChecked;
244}
245AFX_INLINE void CXTPCoreTreeItem::SetIconId(int nIconId)
246{
247 m_nIconId = nIconId;
248 Invalidate();
249}
250AFX_INLINE int CXTPCoreTreeItem::GetIconId() const
251{
252 return m_nIconId;
253}
254AFX_INLINE BOOL CXTPCoreTreeItem::IsEnabled() const
255{
256 return m_bEnabled;
257}
258AFX_INLINE DWORD_PTR CXTPCoreTreeItem::GetItemData() const
259{
260 return m_dwData;
261}
262AFX_INLINE void CXTPCoreTreeItem::SetItemData(DWORD_PTR dwData)
263{
264 m_dwData = dwData;
265}
266AFX_INLINE CXTPMarkupUIElement* CXTPCoreTreeItem::GetMarkupUIElement() const
267{
268 return m_pMarkupUIElement;
269}
270AFX_INLINE CXTPCoreTreeControl* CXTPCoreTreeItem::GetTreeControl() const
271{
272 return m_pControl;
273}
274AFX_INLINE int CXTPCoreTreeItems::GetCount() const
275{
276 return m_nCount;
277}
278AFX_INLINE CXTPCoreTreeItem* CXTPCoreTreeItems::GetFirstItem() const
279{
280 return m_pFirstItem;
281}
282AFX_INLINE CXTPCoreTreeItem* CXTPCoreTreeItems::GetLastItem() const
283{
284 return m_pLastItem;
285}
287# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
289#endif // !defined(__XTPCORETREEITEM_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPImageManagerIcon
Icons holder class.
Definition XTPImageManager.h:622
CXTPMarkupUIElement
Base class for XML Markup core level implementations.
Definition XTPMarkupUIElement.h:43
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72


Toolkit Pro: XTPSkinObjectTreeView.h Source File

  • Source
  • SkinFramework
XTPSkinObjectTreeView.h
Go to the documentation of this file.
1
23#if !defined(__XTPSKINOBJECTTREEVIEW_H__)
24# define __XTPSKINOBJECTTREEVIEW_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPSkinObjectTreeView : public CXTPSkinObjectComCtl32Control
39{
41 DECLARE_DYNCREATE(CXTPSkinObjectTreeView)
43public:
48 CXTPSkinObjectTreeView();
49
54 virtual ~CXTPSkinObjectTreeView();
55
56protected:
58 //{{AFX_VIRTUAL(CXTPSkinObjectTreeView)
59 virtual void OnSkinChanged(BOOL bPrevState, BOOL bNewState);
60 //}}AFX_VIRTUAL
61
62 //{{AFX_MSG(CXTPSkinObjectTreeView)
63 int OnCreate(LPCREATESTRUCT lpCreateStruct);
64 //}}AFX_MSG
65
66 DECLARE_MESSAGE_MAP()
68};
69
70# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
72#endif // !defined(__XTPSKINOBJECTTREEVIEW_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPSkinObjectComCtl32Control
CXTPSkinObjectComCtl32Control is a CXTPSkinObjectUser32Control derived class.
Definition XTPSkinObjectFrame.h:444
CXTPSkinObjectFrame::OnSkinChanged
virtual void OnSkinChanged(BOOL bPrevState, BOOL bNewState)
This method is called when the skin is changed.
CXTPSkinObjectTreeView
CXTPSkinObjectTreeView is a CXTPSkinObjectComCtl32Control derived class.
Definition XTPSkinObjectTreeView.h:39
CXTPSkinObjectTreeView::~CXTPSkinObjectTreeView
virtual ~CXTPSkinObjectTreeView()
Destroys a CXTPSkinObjectTreeView object, handles cleanup and deallocation.
CXTPSkinObjectTreeView::CXTPSkinObjectTreeView
CXTPSkinObjectTreeView()
Constructs a CXTPSkinObjectTreeView object.


Toolkit Pro: XTPTaskPanelVisualStudio2012Theme.h Source File

  • Source
  • TaskPanel
  • Themes
XTPTaskPanelVisualStudio2012Theme.h
Go to the documentation of this file.
1
23#ifndef XTPTaskPanelVisualStudio2012Theme_h__
24# define XTPTaskPanelVisualStudio2012Theme_h__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
39class _XTP_EXT_CLASS CXTPTaskPanelVisualStudio2012Theme : public CXTPTaskPanelVisualStudio2005Theme
40{
41protected:
42 void Triangle(CDC* pDC, POINT* pPoints, COLORREF clr, BOOL bFilled);
43
44public:
50 CXTPTaskPanelVisualStudio2012Theme(BOOL bLight = TRUE);
51
57 virtual ~CXTPTaskPanelVisualStudio2012Theme();
58
68 CRect DrawGroupCaptionBackground(CDC* pDC, CXTPTaskPanelGroup* pGroup, CRect rc);
69
77 void DrawGroupClientFace(CDC* pDC, CXTPTaskPanelGroup* pGroup, CRect rc);
78
87 virtual void DrawGroupItemFrame(CDC* pDC, CXTPTaskPanelGroupItem* pItem, CRect rc);
88
98 void FillGroupClientFace(CDC* pDC, CXTPTaskPanelGroup* pGroup, CRect rc);
99
106 void FillTaskPanel(CDC* pDC, CXTPTaskPanel* pTaskPanel);
107
122 virtual void DrawItemCaption(CDC* pDC, CXTPTaskPanelItem* pItem, CRect rcText, UINT nFormat);
123
128 virtual void RefreshMetrics();
129
130protected:
131 virtual CXTPPaintManagerColor GetTriangleColorAndState(CXTPTaskPanelGroup* pGroup,
132 BOOL& bFilled);
133
134 virtual CRect DrawExpandButton(CDC* pDC, CXTPTaskPanelGroup* pGroup, CRect rc);
135
136protected:
137 CXTPPaintManagerColor m_clrSelectedWithoutFocus;
140 CXTPPaintManagerColor m_clrText;
141 CXTPPaintManagerColor m_clrSelectedText;
142 CXTPPaintManagerColor m_clrSelectedTextWithoutFocus;
145 CXTPPaintManagerColor m_clrTriangle;
146 CXTPPaintManagerColor m_clrTriangleFocused;
147 CXTPPaintManagerColor m_clrTriangleHot;
148
149 BOOL m_bLight;
150};
152# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
153#endif // XTPTaskPanelVisualStudio2012Theme_h__
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPPaintManagerColor
The CXTPPaintManagerColor class is used to manage COLORREF values for determining default and applica...
Definition XTPColorManager.h:117
CXTPTaskPanelGroup
CXTPTaskPanelGroup is used in a Task Panel control to represent a group.
Definition XTPTaskPanelGroup.h:45
CXTPTaskPanelGroupItem
CXTPTaskPanelGroupItem is used in a TaskPanel control to represent a single item of a group.
Definition XTPTaskPanelGroupItem.h:39
CXTPTaskPanel
CXTPTaskPanel is used to implement an Explorer and Office-like Task Panel control.
Definition XTPTaskPanel.h:107
CXTPTaskPanelItem
CXTPTaskPanelItem is used in a Task Panel control to represent a single item.
Definition XTPTaskPanelItem.h:49
CXTPTaskPanelVisualStudio2005Theme
CXTPTaskPanelVisualStudio2005Theme represents a Visual Studio 2005 style theme.
Definition XTPTaskPanelVisualStudio2005Theme.h:40
CXTPTaskPanelVisualStudio2012Theme
CXTPTaskPanelVisualStudio2012Theme represents a VS.NET 2012 style theme.
Definition XTPTaskPanelVisualStudio2012Theme.h:40
CXTPTaskPanelVisualStudio2012Theme::DrawGroupItemFrame
virtual void DrawGroupItemFrame(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc)
Draws a rectangle around a group item when it is selected, pressed or highlighted.
CXTPTaskPanelVisualStudio2012Theme::FillTaskPanel
void FillTaskPanel(CDC *pDC, CXTPTaskPanel *pTaskPanel)
Fills the background of a specified task panel.
CXTPTaskPanelVisualStudio2012Theme::m_clrSelectedWithoutFocus
CXTPPaintManagerColor m_clrSelectedWithoutFocus
Color of the selected item when the Task Panel does not have focus.
Definition XTPTaskPanelVisualStudio2012Theme.h:137
CXTPTaskPanelVisualStudio2012Theme::m_clrText
CXTPPaintManagerColor m_clrText
Normal text color.
Definition XTPTaskPanelVisualStudio2012Theme.h:140
CXTPTaskPanelVisualStudio2012Theme::m_clrSelectedTextWithoutFocus
CXTPPaintManagerColor m_clrSelectedTextWithoutFocus
Text color of the selected item when the Task Panel does not have focus.
Definition XTPTaskPanelVisualStudio2012Theme.h:142
CXTPTaskPanelVisualStudio2012Theme::DrawItemCaption
virtual void DrawItemCaption(CDC *pDC, CXTPTaskPanelItem *pItem, CRect rcText, UINT nFormat)
Draws the text caption of a specified item.
CXTPTaskPanelVisualStudio2012Theme::FillGroupClientFace
void FillGroupClientFace(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Fills the client face of a specified group.
CXTPTaskPanelVisualStudio2012Theme::DrawGroupCaptionBackground
CRect DrawGroupCaptionBackground(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Draws the group caption background of a specified group.
CXTPTaskPanelVisualStudio2012Theme::CXTPTaskPanelVisualStudio2012Theme
CXTPTaskPanelVisualStudio2012Theme(BOOL bLight=TRUE)
Constructs a CXTPTaskPanelVisualStudio2012Theme object.
CXTPTaskPanelVisualStudio2012Theme::~CXTPTaskPanelVisualStudio2012Theme
virtual ~CXTPTaskPanelVisualStudio2012Theme()
Destroys a CXTPTaskPanelVisualStudio2012Theme object, handles cleanup and deallocation.
CXTPTaskPanelVisualStudio2012Theme::RefreshMetrics
virtual void RefreshMetrics()
Refreshes the visual metrics of the task panel.
CXTPTaskPanelVisualStudio2012Theme::DrawGroupClientFace
void DrawGroupClientFace(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Draws the client face of a specified group.
CXTPTaskPanelVisualStudio2012Theme::m_clrSelectedText
CXTPPaintManagerColor m_clrSelectedText
Text color of the selected item.
Definition XTPTaskPanelVisualStudio2012Theme.h:141


Toolkit Pro: Member List

CXTPButtonThemeVisualStudio2015 Member List

This is the complete list of members for CXTPButtonThemeVisualStudio2015, including all inherited members.

CXTPButtonTheme() | CXTPButtonTheme |
CXTPButtonThemeUltraFlat() | CXTPButtonThemeUltraFlat |
CXTPButtonThemeVisualStudio2015() | CXTPButtonThemeVisualStudio2015 |
CXTPCmdTarget() | CXTPCmdTarget |
CXTPControlTheme() | CXTPControlTheme |
DrawButton(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
DrawButtonBackground(CDC *pDC, CXTPButton *pButton) | CXTPButtonThemeOffice2013 | virtual
DrawButtonText(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme |
DrawButtonVisualStyleBackground(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
DrawCheckBoxMark(CDC *pDC, CXTPButton *pButton) | CXTPButtonThemeOffice2013 | virtual
DrawFocusRect(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
DrawGroupBox(CDC *pDC, CXTPButton *pButton) | CXTPButtonThemeOffice2013 | virtual
DrawPushButtonDropDown(CDC *pDC, CXTPButton *pButton) | CXTPButtonThemeOffice2013 | virtual
DrawPushButtonIcon(CDC *pDC, CXTPButton *pButton) | CXTPButtonThemeOffice2013 | virtual
DrawPushButtonText(CDC *pDC, CXTPButton *pButton) | CXTPButtonThemeOffice2013 | virtual
DrawRadioButtonMark(CDC *pDC, CXTPButton *pButton) | CXTPButtonThemeOffice2013 | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetTextColor(CXTPButton *pButton) | CXTPButtonThemeOffice2013 | virtual
GetThemeStyle() const | CXTPControlTheme |
m_crBack | CXTPButtonTheme |
m_crBackChecked | CXTPButtonThemeUltraFlat |
m_crBackDisabled | CXTPButtonThemeOffice2013 | protected
m_crBackHilite | CXTPButtonThemeUltraFlat |
m_crBackPushed | CXTPButtonThemeUltraFlat |
m_crBorder | CXTPButtonThemeOffice2013 | protected
m_crBorder3DHilite | CXTPButtonTheme |
m_crBorder3DShadow | CXTPButtonTheme |
m_crBorderDefault | CXTPButtonThemeOffice2013 | protected
m_crBorderDisabled | CXTPButtonThemeOffice2013 | protected
m_crBorderHilite | CXTPButtonTheme |
m_crBorderPushed | CXTPButtonThemeUltraFlat |
m_crBorderShadow | CXTPButtonTheme |
m_crCheckMark | CXTPButtonThemeUltraFlat |
m_crMark | CXTPButtonThemeOffice2013 | protected
m_crMarkDisabled | CXTPButtonThemeOffice2013 | protected
m_crMarkHilite | CXTPButtonThemeOffice2013 | protected
m_crMarkPushed | CXTPButtonThemeOffice2013 | protected
m_crText | CXTPButtonTheme |
m_crTextCheck | CXTPButtonTheme |
m_crTextDisabled | CXTPButtonTheme |
m_crTextHilite | CXTPButtonThemeUltraFlat |
m_crTextPushed | CXTPButtonThemeUltraFlat |
m_nTheme | CXTPControlTheme | protected
RefreshMetrics(CXTPButton *pButton) | CXTPButtonThemeVisualStudio2015 | virtual
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static
~CXTPButtonTheme() | CXTPButtonTheme | virtual


Toolkit Pro: XTPChartPieDiagramView.h Source File

  • Source
  • Chart
  • Styles
  • Pie
XTPChartPieDiagramView.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTPIEDIAGRAMVIEW_H__)
24# define __XTPCHARTPIEDIAGRAMVIEW_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Chart/Styles/Pie/2D/XTPChart2dPieDiagramView.h"
32
33// CXTPChart2dPieDiagramView alias is necessary for naming consistency.
34typedef CXTPChartPieDiagramView CXTPChart2dPieDiagramView;
36#endif //#if !defined(__XTPCHARTPIEDIAGRAMVIEW_H__)
XTPChart2dPieDiagramView.h
CXTPChartPieDiagramView
This class abstracts the view of a pie diagram.
Definition XTPChart2dPieDiagramView.h:48


Toolkit Pro: XTPMarkupStaticExtension.h Source File

  • Source
  • Markup
  • Extensions
XTPMarkupStaticExtension.h
Go to the documentation of this file.
1
23#if !defined(__XTPMARKUPSTATICEXTENSION_H__)
24# define __XTPMARKUPSTATICEXTENSION_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPMarkupObject;
34class CXTPMarkupColor;
35
40class _XTP_EXT_CLASS CXTPMarkupStaticExtension
41{
42protected:
51 CXTPMarkupStaticExtension(LPCWSTR lpzName, BOOL bProperty);
52
53public:
59 CXTPMarkupStaticExtension(LPCWSTR lpzName);
60
65 virtual ~CXTPMarkupStaticExtension();
66
77 static BOOL AFX_CDECL Parse(LPCWSTR lpzValue, LPCWSTR& lpzSubValue);
78
85 LPCWSTR GetName() const;
86
93 BOOL IsProperty() const;
94
104 void Extend(CXTPMarkupStaticExtension* pExtension, BOOL bReplace = FALSE);
105
115 CXTPMarkupStaticExtension* FindExtension(LPCWSTR lpzName) const;
116
126 virtual CXTPMarkupObject* ProvideValue(LPCWSTR lpzValue);
127
136 virtual CXTPMarkupObject* ProvideValue();
137
138protected:
143 virtual void OnPrepareValue()
144 {
145 }
146
147private:
148 static BOOL AFX_CDECL ValidateExtensionName(LPCWSTR lpzBegin, LPCWSTR lpzEnd);
149
150private:
151 BOOL m_bProperty;
152 LPWSTR m_lpzName;
153 CMap<LPCWSTR, LPCWSTR, CXTPMarkupStaticExtension*, CXTPMarkupStaticExtension*> m_mapExtensions;
154};
155
156AFX_INLINE LPCWSTR CXTPMarkupStaticExtension::GetName() const
157{
158 return m_lpzName;
159}
160
161AFX_INLINE BOOL CXTPMarkupStaticExtension::IsProperty() const
162{
163 return m_bProperty;
164}
165
170class _XTP_EXT_CLASS CXTPMarkupStaticExtensionProperty : public CXTPMarkupStaticExtension
171{
172public:
181 CXTPMarkupStaticExtensionProperty(LPCWSTR lpzName, CXTPMarkupObject* pObject = NULL);
182
188 ~CXTPMarkupStaticExtensionProperty();
189
195 CXTPMarkupObject* GetValue();
196
203 void SetValue(CXTPMarkupObject* pObject);
204
213 virtual CXTPMarkupObject* ProvideValue();
214
224 virtual CXTPMarkupObject* ProvideValue(LPCWSTR lpzValue);
225
226protected:
227 CXTPMarkupObject* m_pObject;
228};
229
230AFX_INLINE CXTPMarkupObject* CXTPMarkupStaticExtensionProperty::GetValue()
231{
232 return m_pObject;
233}
234
239class _XTP_EXT_CLASS CXTPMarkupStaticExtensionStringProperty
240 : public CXTPMarkupStaticExtensionProperty
241{
242public:
250 CXTPMarkupStaticExtensionStringProperty(LPCWSTR lpzName, LPCWSTR lpzValue = NULL);
251
259 CXTPMarkupStaticExtensionStringProperty(LPCWSTR lpzName, LPCSTR lpzValue = NULL);
260
266 void SetValue(LPCWSTR lpzValue);
267
273 void SetValue(LPCSTR lpzValue);
274
281 LPCWSTR GetRawValue() const;
282};
283
288class _XTP_EXT_CLASS CXTPMarkupStaticExtensionIntegerProperty
289 : public CXTPMarkupStaticExtensionProperty
290{
291public:
299 CXTPMarkupStaticExtensionIntegerProperty(LPCWSTR lpzName, int nValue = 0);
300
306 void SetValue(int nValue);
307
314 int GetRawValue() const;
315};
316
321class _XTP_EXT_CLASS CXTPMarkupStaticExtensionBooleanProperty
322 : public CXTPMarkupStaticExtensionProperty
323{
324public:
332 CXTPMarkupStaticExtensionBooleanProperty(LPCWSTR lpzName, BOOL bValue = FALSE);
333
339 void SetValue(BOOL bValue);
340
347 BOOL GetRawValue() const;
348};
349
354class _XTP_EXT_CLASS CXTPMarkupStaticExtensionDoubleProperty
355 : public CXTPMarkupStaticExtensionProperty
356{
357public:
365 CXTPMarkupStaticExtensionDoubleProperty(LPCWSTR lpzName, double dblValue = 0);
366
372 void SetValue(double dblValue);
373
380 double GetRawValue() const;
381};
382
387class _XTP_EXT_CLASS CXTPMarkupStaticExtensionColorProperty
388 : public CXTPMarkupStaticExtensionProperty
389{
390public:
398 CXTPMarkupStaticExtensionColorProperty(LPCWSTR lpzName, COLORREF crValue = RGB(0, 0, 0));
399
408 CXTPMarkupStaticExtensionColorProperty(LPCWSTR lpzName, COLORREF crValue, BYTE bAlpha);
409
415 void SetValue(COLORREF crValue);
416
423 void SetValue(COLORREF crValue, BYTE bAlpha);
424
431 COLORREF GetRawValue() const;
432};
433
438class _XTP_EXT_CLASS CXTPMarkupStaticExtensionBrushProperty
439 : public CXTPMarkupStaticExtensionProperty
440{
441public:
449 CXTPMarkupStaticExtensionBrushProperty(LPCWSTR lpzName, COLORREF crValue = RGB(0, 0, 0));
450
459 CXTPMarkupStaticExtensionBrushProperty(LPCWSTR lpzName, COLORREF crValue, BYTE bAlpha);
460
466 void SetValue(COLORREF crValue);
467
474 void SetValue(COLORREF crValue, BYTE bAlpha);
475
482 COLORREF GetRawValue() const;
483};
484
485# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
487#endif // !defined(__XTPMARKUPSTATICEXTENSION_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPMarkupStaticExtensionBooleanProperty
A convenience class that represents a boolean static extension property.
Definition XTPMarkupStaticExtension.h:323
CXTPMarkupStaticExtensionBooleanProperty::GetRawValue
BOOL GetRawValue() const
Gets the property value.
CXTPMarkupStaticExtensionBooleanProperty::CXTPMarkupStaticExtensionBooleanProperty
CXTPMarkupStaticExtensionBooleanProperty(LPCWSTR lpzName, BOOL bValue=FALSE)
Constructs a CXTPMarkupStaticExtensionBooleanProperty with an optional initial property value.
CXTPMarkupStaticExtensionBooleanProperty::SetValue
void SetValue(BOOL bValue)
Sets the property value.
CXTPMarkupStaticExtensionBrushProperty
A convenience class that represents a brush static extension property.
Definition XTPMarkupStaticExtension.h:440
CXTPMarkupStaticExtensionBrushProperty::GetRawValue
COLORREF GetRawValue() const
Gets the property value.
CXTPMarkupStaticExtensionBrushProperty::SetValue
void SetValue(COLORREF crValue, BYTE bAlpha)
Sets the property value.
CXTPMarkupStaticExtensionBrushProperty::CXTPMarkupStaticExtensionBrushProperty
CXTPMarkupStaticExtensionBrushProperty(LPCWSTR lpzName, COLORREF crValue=RGB(0, 0, 0))
Constructs a CXTPMarkupStaticExtensionBrushProperty with an optional initial property value.
CXTPMarkupStaticExtensionBrushProperty::CXTPMarkupStaticExtensionBrushProperty
CXTPMarkupStaticExtensionBrushProperty(LPCWSTR lpzName, COLORREF crValue, BYTE bAlpha)
Constructs a CXTPMarkupStaticExtensionBrushProperty with an optional initial property value.
CXTPMarkupStaticExtensionBrushProperty::SetValue
void SetValue(COLORREF crValue)
Sets the property value.
CXTPMarkupStaticExtensionColorProperty
A convenience class that represents an RGB color static extension property.
Definition XTPMarkupStaticExtension.h:389
CXTPMarkupStaticExtensionColorProperty::CXTPMarkupStaticExtensionColorProperty
CXTPMarkupStaticExtensionColorProperty(LPCWSTR lpzName, COLORREF crValue=RGB(0, 0, 0))
Constructs a CXTPMarkupStaticExtensionColorProperty with an optional initial property value.
CXTPMarkupStaticExtensionColorProperty::GetRawValue
COLORREF GetRawValue() const
Gets the property value.
CXTPMarkupStaticExtensionColorProperty::CXTPMarkupStaticExtensionColorProperty
CXTPMarkupStaticExtensionColorProperty(LPCWSTR lpzName, COLORREF crValue, BYTE bAlpha)
Constructs a CXTPMarkupStaticExtensionColorProperty with an optional initial property value.
CXTPMarkupStaticExtensionColorProperty::SetValue
void SetValue(COLORREF crValue, BYTE bAlpha)
Sets the property value.
CXTPMarkupStaticExtensionColorProperty::SetValue
void SetValue(COLORREF crValue)
Sets the property value.
CXTPMarkupStaticExtensionDoubleProperty
A convenience class that represents a double static extension property.
Definition XTPMarkupStaticExtension.h:356
CXTPMarkupStaticExtensionDoubleProperty::GetRawValue
double GetRawValue() const
Gets the property value.
CXTPMarkupStaticExtensionDoubleProperty::CXTPMarkupStaticExtensionDoubleProperty
CXTPMarkupStaticExtensionDoubleProperty(LPCWSTR lpzName, double dblValue=0)
Constructs a CXTPMarkupStaticExtensionDoubleProperty with an optional initial property value.
CXTPMarkupStaticExtensionDoubleProperty::SetValue
void SetValue(double dblValue)
Sets the property value.
CXTPMarkupStaticExtension
A base class for a markup static extension composite object.
Definition XTPMarkupStaticExtension.h:41
CXTPMarkupStaticExtension::Parse
static BOOL AFX_CDECL Parse(LPCWSTR lpzValue, LPCWSTR &lpzSubValue)
Parses a static extension expression of form Name.Value[.Value[...]].
CXTPMarkupStaticExtension::Extend
void Extend(CXTPMarkupStaticExtension *pExtension, BOOL bReplace=FALSE)
Extends the current extension object with another sub-extension.
CXTPMarkupStaticExtension::ProvideValue
virtual CXTPMarkupObject * ProvideValue()
Provides the value of a property extension object.
CXTPMarkupStaticExtension::~CXTPMarkupStaticExtension
virtual ~CXTPMarkupStaticExtension()
Destroys a CXTPMarkupStaticExtension object, handles cleanup and deallocation.
CXTPMarkupStaticExtension::CXTPMarkupStaticExtension
CXTPMarkupStaticExtension(LPCWSTR lpzName, BOOL bProperty)
Constructs a composite or property CXTPMarkupStaticExtension instance.
CXTPMarkupStaticExtension::OnPrepareValue
virtual void OnPrepareValue()
A derived implementation can override this method for preparing a property value.
Definition XTPMarkupStaticExtension.h:143
CXTPMarkupStaticExtension::CXTPMarkupStaticExtension
CXTPMarkupStaticExtension(LPCWSTR lpzName)
Constructs a composite CXTPMarkupStaticExtension instance.
CXTPMarkupStaticExtension::FindExtension
CXTPMarkupStaticExtension * FindExtension(LPCWSTR lpzName) const
Tries to find an extension by its name or relative path.
CXTPMarkupStaticExtension::IsProperty
BOOL IsProperty() const
Determines if the current extension is a property extension.
Definition XTPMarkupStaticExtension.h:161
CXTPMarkupStaticExtension::GetName
LPCWSTR GetName() const
Gets the name of the current extension.
Definition XTPMarkupStaticExtension.h:156
CXTPMarkupStaticExtension::ProvideValue
virtual CXTPMarkupObject * ProvideValue(LPCWSTR lpzValue)
Provides the value of a composite extension object.
CXTPMarkupStaticExtensionIntegerProperty
A convenience class that represents an integer static extension property.
Definition XTPMarkupStaticExtension.h:290
CXTPMarkupStaticExtensionIntegerProperty::GetRawValue
int GetRawValue() const
Gets the property value.
CXTPMarkupStaticExtensionIntegerProperty::CXTPMarkupStaticExtensionIntegerProperty
CXTPMarkupStaticExtensionIntegerProperty(LPCWSTR lpzName, int nValue=0)
Constructs a CXTPMarkupStaticExtensionIntegerProperty with an optional initial property value.
CXTPMarkupStaticExtensionIntegerProperty::SetValue
void SetValue(int nValue)
Sets the property value.
CXTPMarkupStaticExtensionProperty
A convenience base class for all static extension properties.
Definition XTPMarkupStaticExtension.h:171
CXTPMarkupStaticExtensionProperty::ProvideValue
virtual CXTPMarkupObject * ProvideValue()
Provides the value of a property extension object.
CXTPMarkupStaticExtensionProperty::GetValue
CXTPMarkupObject * GetValue()
Obtains the property value.
Definition XTPMarkupStaticExtension.h:230
CXTPMarkupStaticExtensionProperty::SetValue
void SetValue(CXTPMarkupObject *pObject)
Sets the property value.
CXTPMarkupStaticExtensionProperty::~CXTPMarkupStaticExtensionProperty
~CXTPMarkupStaticExtensionProperty()
Destroys a CXTPMarkupStaticExtensionProperty object, handles cleanup and deallocation.
CXTPMarkupStaticExtensionProperty::ProvideValue
virtual CXTPMarkupObject * ProvideValue(LPCWSTR lpzValue)
Provides the value of a composite extension object.
CXTPMarkupStaticExtensionProperty::CXTPMarkupStaticExtensionProperty
CXTPMarkupStaticExtensionProperty(LPCWSTR lpzName, CXTPMarkupObject *pObject=NULL)
Constructs a CXTPMarkupStaticExtensionProperty with an optional initial property value.
CXTPMarkupStaticExtensionStringProperty
A convenience class that represents a string static extension property.
Definition XTPMarkupStaticExtension.h:241
CXTPMarkupStaticExtensionStringProperty::CXTPMarkupStaticExtensionStringProperty
CXTPMarkupStaticExtensionStringProperty(LPCWSTR lpzName, LPCSTR lpzValue=NULL)
Constructs a CXTPMarkupStaticExtensionStringProperty with an optional initial property value.
CXTPMarkupStaticExtensionStringProperty::CXTPMarkupStaticExtensionStringProperty
CXTPMarkupStaticExtensionStringProperty(LPCWSTR lpzName, LPCWSTR lpzValue=NULL)
Constructs a CXTPMarkupStaticExtensionStringProperty with an optional initial property value.
CXTPMarkupStaticExtensionStringProperty::GetRawValue
LPCWSTR GetRawValue() const
Obtains a pointer to a raw object value.
CXTPMarkupStaticExtensionStringProperty::SetValue
void SetValue(LPCWSTR lpzValue)
Sets the property value.
CXTPMarkupStaticExtensionStringProperty::SetValue
void SetValue(LPCSTR lpzValue)
Sets the property value.


Toolkit Pro: Member List

CXTPPropertyGridItemDate Member List

This is the complete list of members for CXTPPropertyGridItemDate, including all inherited members.

AddChildItem(CXTPPropertyGridItem *pItem) | CXTPPropertyGridItem |
AddComboButton() | CXTPPropertyGridItem |
AddExpandButton() | CXTPPropertyGridItem |
AddSliderControl() | CXTPPropertyGridItem |
AddSpinButton() | CXTPPropertyGridItem |
AllowNullDate(LPCTSTR lpszNullValue) | CXTPPropertyGridItemDate |
BindToDate(COleDateTime *pBindDate) | CXTPPropertyGridItemDate |
BindToString(CString *pBindString) | CXTPPropertyGridItem |
Collapse() | CXTPPropertyGridItem |
CXTPCmdTarget() | CXTPCmdTarget |
CXTPPropertyGridItem(LPCTSTR lpszCaption, LPCTSTR strValue=NULL, CString *pBindString=NULL) | CXTPPropertyGridItem |
CXTPPropertyGridItem(UINT nID, LPCTSTR strValue=NULL, CString *pBindString=NULL) | CXTPPropertyGridItem |
CXTPPropertyGridItemDate(LPCTSTR strCaption, const COleDateTime &oleDate, COleDateTime *pBindDate=NULL) | CXTPPropertyGridItemDate |
CXTPPropertyGridItemDate(UINT nID, const COleDateTime &oleDate, COleDateTime *pBindDate=NULL) | CXTPPropertyGridItemDate |
EnsureVisible() | CXTPPropertyGridItem |
Expand() | CXTPPropertyGridItem |
Format(const COleDateTime &oleDate) | CXTPPropertyGridItemDate | protectedvirtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAllowNullDateString() const | CXTPPropertyGridItemDate |
GetAsSystemTime(SYSTEMTIME &sysTime) | CXTPPropertyGridItemDate | virtual
GetCaption() const | CXTPPropertyGridItem |
GetCaptionMetrics() const | CXTPPropertyGridItem |
GetChilds() const | CXTPPropertyGridItem |
GetConstraintEdit() const | CXTPPropertyGridItem |
GetConstraints() const | CXTPPropertyGridItem |
GetDate() const | CXTPPropertyGridItemDate | virtual
GetDay() | CXTPPropertyGridItemDate | virtual
GetDefaultValue() const | CXTPPropertyGridItem |
GetDescription() const | CXTPPropertyGridItem |
GetDropDownItemCount() const | CXTPPropertyGridItem |
GetEditStyle() const | CXTPPropertyGridItem | virtual
GetFlags() const | CXTPPropertyGridItem |
GetGrid() const | CXTPPropertyGridItem |
GetHeight() const | CXTPPropertyGridItem |
GetID() const | CXTPPropertyGridItem |
GetIndent() const | CXTPPropertyGridItem |
GetIndex() const | CXTPPropertyGridItem |
GetInplaceButtons() const | CXTPPropertyGridItem |
GetInplaceControls() const | CXTPPropertyGridItem |
GetInPlacedEditValue() | CXTPPropertyGridItem | inlineprotectedvirtual
GetInplaceEdit() | CXTPPropertyGridItem | virtual
GetInplaceList() | CXTPPropertyGridItem | protectedvirtual
GetItemData() const | CXTPPropertyGridItem |
GetItemRect() const | CXTPPropertyGridItem |
GetMarkupCaption() const | CXTPPropertyGridItem |
GetMarkupDescription() const | CXTPPropertyGridItem |
GetMarkupTemplate() const | CXTPPropertyGridItem | virtual
GetMarkupValue() const | CXTPPropertyGridItem |
GetMaskedText() const | CXTPPropertyGridItem |
GetMetrics(BOOL bValueMetrics, BOOL bCreate=TRUE) const | CXTPPropertyGridItem |
GetMonth() | CXTPPropertyGridItemDate | virtual
GetMultiLinesCount() const | CXTPPropertyGridItem |
GetParentItem() const | CXTPPropertyGridItem |
GetReadOnly() const | CXTPPropertyGridItem | virtual
GetTooltip() const | CXTPPropertyGridItem |
GetValue() const | CXTPPropertyGridItem |
GetValueMetrics() const | CXTPPropertyGridItem |
GetValueRect() | CXTPPropertyGridItem | virtual
GetViewValue() | CXTPPropertyGridItem | virtual
GetYear() | CXTPPropertyGridItemDate | virtual
HasChilds() const | CXTPPropertyGridItem |
HasParent(CXTPPropertyGridItem *pParent) | CXTPPropertyGridItem |
HasVisibleChilds() const | CXTPPropertyGridItem |
InsertChildItem(int nIndex, CXTPPropertyGridItem *pItem) | CXTPPropertyGridItem |
IsAllowEdit() const | CXTPPropertyGridItem | virtual
IsCategory() const | CXTPPropertyGridItem |
IsExpandable() const | CXTPPropertyGridItem |
IsExpanded() const | CXTPPropertyGridItem |
IsHidden() const | CXTPPropertyGridItem |
IsInplaceButtonVisible(CXTPPropertyGridInplaceButton *pButton) const | CXTPPropertyGridItem | virtual
IsMultiLine() const | CXTPPropertyGridItem |
IsSelected() const | CXTPPropertyGridItem |
IsValueChanged() const | CXTPPropertyGridItem | virtual
IsVisible() const | CXTPPropertyGridItem |
m_bAutoComplete | CXTPPropertyGridItem | protected
m_bCategory | CXTPPropertyGridItem | protected
m_bConstraintEdit | CXTPPropertyGridItem | protected
m_bExpandable | CXTPPropertyGridItem | protected
m_bExpanded | CXTPPropertyGridItem | protected
m_bHidden | CXTPPropertyGridItem | protected
m_bPassword | CXTPPropertyGridItem | protected
m_bReadOnly | CXTPPropertyGridItem | protected
m_bUseMask | CXTPPropertyGridItem | protected
m_bVisible | CXTPPropertyGridItem | protected
m_chPrompt | CXTPPropertyGridItem | protected
m_dwData | CXTPPropertyGridItem | protected
m_dwEditStyle | CXTPPropertyGridItem | protected
m_nDropDownItemCount | CXTPPropertyGridItem | protected
m_nFlags | CXTPPropertyGridItem | protected
m_nHeight | CXTPPropertyGridItem | protected
m_nID | CXTPPropertyGridItem | protected
m_nIndent | CXTPPropertyGridItem | protected
m_nIndex | CXTPPropertyGridItem | protected
m_nLinesCount | CXTPPropertyGridItem | protected
m_oleDate | CXTPPropertyGridItemDate | protected
m_pBindDate | CXTPPropertyGridItemDate | protected
m_pBindString | CXTPPropertyGridItem | protected
m_pCaptionMetrics | CXTPPropertyGridItem | mutableprotected
m_pChilds | CXTPPropertyGridItem | protected
m_pConstraints | CXTPPropertyGridItem | protected
m_pGrid | CXTPPropertyGridItem | protected
m_pInplaceButtons | CXTPPropertyGridItem | protected
m_pInplaceControls | CXTPPropertyGridItem | protected
m_pMarkupCaption | CXTPPropertyGridItem | protected
m_pMarkupDescription | CXTPPropertyGridItem | protected
m_pMarkupValue | CXTPPropertyGridItem | protected
m_pParent | CXTPPropertyGridItem | protected
m_pValueMetrics | CXTPPropertyGridItem | mutableprotected
m_strCaption | CXTPPropertyGridItem | protected
m_strDefaultValue | CXTPPropertyGridItem | protected
m_strDescription | CXTPPropertyGridItem | protected
m_strFormat | CXTPPropertyGridItem | protected
m_strLiteral | CXTPPropertyGridItem | protected
m_strMarkupTemplate | CXTPPropertyGridItem | protected
m_strMask | CXTPPropertyGridItem | protected
m_strNullValue | CXTPPropertyGridItemDate | protected
m_strTooltip | CXTPPropertyGridItem | protected
m_strValue | CXTPPropertyGridItem | protected
MeasureItem(LPMEASUREITEMSTRUCT lpMeasureItemStruct) | CXTPPropertyGridItem | virtual
Move(CXTPPropertyGridItem *pParent, int nIndex=-1) | CXTPPropertyGridItem |
NotifyValueChanged() | CXTPPropertyGridItem | protected
OnAddChildItem() | CXTPPropertyGridItem | protectedvirtual
OnAfterEdit(CString &strValue) | CXTPPropertyGridItem | virtual
OnBeforeInsert() | CXTPPropertyGridItemDate | protectedvirtual
OnCancelEdit() | CXTPPropertyGridItem | virtual
OnCaptionChanged() | CXTPPropertyGridItem | protectedvirtual
OnChar(UINT nChar) | CXTPPropertyGridItem | protectedvirtual
OnConstraintsChanged() | CXTPPropertyGridItem | protectedvirtual
OnDeselect() | CXTPPropertyGridItem | protectedvirtual
OnDrawItemConstraint(CDC *pDC, CXTPPropertyGridItemConstraint *pConstraint, CRect rc, BOOL bSelected) | CXTPPropertyGridItem | virtual
OnDrawItemValue(CDC &dc, CRect rcValue) | CXTPPropertyGridItem | virtual
OnIndexChanged() | CXTPPropertyGridItem | protectedvirtual
OnInpaceControlFocus(BOOL bForward) | CXTPPropertyGridItem | protectedvirtual
OnInplaceButtonDown(CXTPPropertyGridInplaceButton *pButton) | CXTPPropertyGridItemDate | protectedvirtual
OnKeyDown(UINT nChar) | CXTPPropertyGridItem | protectedvirtual
OnLButtonDblClk(UINT nFlags, CPoint point) | CXTPPropertyGridItem | protectedvirtual
OnLButtonDown(UINT nFlags, CPoint point) | CXTPPropertyGridItem | protectedvirtual
OnLButtonUp(UINT nFlags, CPoint point) | CXTPPropertyGridItem | protectedvirtual
OnMarkupChanged() | CXTPPropertyGridItem | virtual
OnMergeItemConstraint(CDC *pDC, CXTPPropertyGridItemConstraint *pConstraint) | CXTPPropertyGridItem | virtual
OnRButtonDown(UINT nFlags, CPoint point) | CXTPPropertyGridItem | protectedvirtual
OnRequestEdit() | CXTPPropertyGridItem | virtual
OnSelect() | CXTPPropertyGridItem | protectedvirtual
OnValidateEdit() | CXTPPropertyGridItem | virtual
OnValueChanged(CString strValue) | CXTPPropertyGridItemDate | protectedvirtual
ParseDateTime(COleDateTime &dt, LPCTSTR strValue) | CXTPPropertyGridItemDate | virtual
PtInValueRect(CPoint point) | CXTPPropertyGridItem | protected
RedrawItem() | CXTPPropertyGridItem |
Remove() | CXTPPropertyGridItem |
ResetValue() | CXTPPropertyGridItem | virtual
Select() | CXTPPropertyGridItem |
SelectNextConstraint() | CXTPPropertyGridItem | protected
SetAutoComplete(BOOL bAutoComplete=TRUE) | CXTPPropertyGridItem |
SetCaption(LPCTSTR lpszCaption) | CXTPPropertyGridItem |
SetConstraintEdit(BOOL bConstraintEdit=TRUE) | CXTPPropertyGridItem |
SetDate(const COleDateTime &oleDate) | CXTPPropertyGridItemDate | virtual
SetDateFormat(LPCTSTR strFormat) | CXTPPropertyGridItemDate | virtual
SetDay(long nDay) | CXTPPropertyGridItemDate | virtual
SetDefaultValue(LPCTSTR lpszDefaultValue) | CXTPPropertyGridItem |
SetDescription(LPCTSTR lpszDescription) | CXTPPropertyGridItem |
SetDropDownItemCount(int nDropDownItemCount) | CXTPPropertyGridItem |
SetEditStyle(DWORD dwEditStyle) | CXTPPropertyGridItem |
SetEditText(const CString &str) | CXTPPropertyGridItem | protectedvirtual
SetExpandable(BOOL bExpandable) | CXTPPropertyGridItem |
SetFlags(UINT nFlags) | CXTPPropertyGridItem |
SetFocusToInplaceControl() | CXTPPropertyGridItem | virtual
SetHeight(int nHeight) | CXTPPropertyGridItem |
SetHidden(BOOL bHidden) | CXTPPropertyGridItem |
SetID(UINT nID) | CXTPPropertyGridItem |
SetItemData(DWORD_PTR dwData) | CXTPPropertyGridItem |
SetMarkupTemplate(LPCTSTR lpstrMarkupTemplate) | CXTPPropertyGridItem |
SetMask(LPCTSTR strMask, LPCTSTR strLiteral, TCHAR chPrompt=_T('_')) | CXTPPropertyGridItem |
SetMaskedText(LPCTSTR lpszMaskedText) | CXTPPropertyGridItem |
SetMonth(long nMonth) | CXTPPropertyGridItemDate | virtual
SetMultiLinesCount(int nLinesCount) | CXTPPropertyGridItem |
SetPasswordMask(TCHAR chMask=_T(' *')) | CXTPPropertyGridItem |
SetPrompt(LPCTSTR lpszPrompt) | CXTPPropertyGridItem |
SetReadOnly(BOOL bReadOnly=TRUE) | CXTPPropertyGridItem | virtual
SetTooltip(LPCTSTR lpstrTooltip) | CXTPPropertyGridItem |
SetValue(CString strValue) | CXTPPropertyGridItemDate | protectedvirtual
SetVisible(BOOL bVisible) | CXTPPropertyGridItem | protectedvirtual
SetYear(long nYear) | CXTPPropertyGridItemDate | virtual
~CXTPPropertyGridItem() | CXTPPropertyGridItem | virtual


Toolkit Pro: Member List

XTP_DOCKINGPANE_ACTION Member List

This is the complete list of members for XTP_DOCKINGPANE_ACTION, including all inherited members.

action | XTP_DOCKINGPANE_ACTION
bCancel | XTP_DOCKINGPANE_ACTION
dockDirection | XTP_DOCKINGPANE_ACTION
pDockContainer | XTP_DOCKINGPANE_ACTION
pPane | XTP_DOCKINGPANE_ACTION


Toolkit Pro: XTPCalendarEventPropertiesDlg.h Source File

  • Source
  • Calendar
XTPCalendarEventPropertiesDlg.h
Go to the documentation of this file.
1
22#if !defined(_XTP_CALENDAR_EVENT_PROPERTIS_DLG_H__)
23# define _XTP_CALENDAR_EVENT_PROPERTIS_DLG_H__
24
25# if _MSC_VER > 1000
26# pragma once
27# endif // _MSC_VER > 1000
28
29# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
30
31class CXTPCalendarViewEvent;
32class CXTPCalendarControl;
33class CXTPCalendarEventCategories;
34class CXTPCalendarEventCategoryIDs;
35
41class _XTP_EXT_CLASS CXTPCalendarComboBoxBase : public CComboBox
42{
43public:
48 CXTPCalendarComboBoxBase();
49
54 virtual ~CXTPCalendarComboBoxBase();
55
65 virtual BOOL Init(CXTPCalendarEvent* pEvent, XTPCalendarTheme nTheme);
66
67protected:
74 virtual void MeasureItem(LPMEASUREITEMSTRUCT lpMIS);
75
85 virtual CRect CalcColorRect(CRect rItem);
86
87protected:
88 CSize m_sizeColor; // Size in pixels of the color selection box.
89 XTPCalendarTheme m_nTheme; // Current Calendar theme.
90 CXTPCalendarEvent* m_pEvent; // Pointer to the selected calendar event.
91};
92
97class _XTP_EXT_CLASS CXTPCalendarEventCategoryComboBox : public CXTPCalendarComboBoxBase
98{
99public:
104 CXTPCalendarEventCategoryComboBox();
105
110 virtual ~CXTPCalendarEventCategoryComboBox();
111
121 virtual BOOL Init(CXTPCalendarEvent* pEvent, XTPCalendarTheme nTheme);
122
132 virtual void GetChecked(CXTPCalendarEventCategoryIDs* pChecked, BOOL* pbChanged);
133
141 CXTPCalendarEventCategoryIDs& GetCategoryArray();
142
143protected:
150 virtual void DrawItem(LPDRAWITEMSTRUCT lpDIS);
151
162 virtual void DrawCollapsed(CDC* pDC, CRect rcItem, BOOL bFocused, BOOL bDisabled);
163
174 virtual void DrawExpanded(CDC* pDC, CRect rcItem, BOOL bSelected, UINT uItemID);
175
183 virtual int GetLBCurSel() const;
184
193 virtual void RedrawLB(BOOL bUpdateNow = FALSE);
194
195 afx_msg void OnSelChange();
196 afx_msg void OnDropDown();
197 afx_msg void OnKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags);
198 virtual void _OnSelChange(int nItemIndex);
199
200protected:
201 CXTPCalendarEventCategories* m_pCategories;
202 CXTPCalendarEventCategoryIDs m_arChecked;
204private:
205 UINT m_nLastKey;
206
207 DECLARE_MESSAGE_MAP()
208};
209
210AFX_INLINE CXTPCalendarEventCategoryIDs& CXTPCalendarEventCategoryComboBox::GetCategoryArray()
211{
212 return m_arChecked;
213}
214
219class _XTP_EXT_CLASS CXTPCalendarEventLabelComboBox : public CXTPCalendarComboBoxBase
220{
221public:
231 virtual BOOL Init(CXTPCalendarEvent* pEvent, XTPCalendarTheme nTheme);
232
239 virtual int GetLabelID() const;
248 virtual int GetLabelID(int nID) const;
249
256 virtual void SetLabelID(int nID);
257
258protected:
265 virtual void DrawItem(LPDRAWITEMSTRUCT lpDIS);
266
267protected:
268 //{{AFX_MSG(CXTPCalendarEventLabelComboBox)
269 //}}AFX_MSG
270 DECLARE_MESSAGE_MAP()
271};
272
277class _XTP_EXT_CLASS CXTPCalendarBusyStatusComboBox : public CXTPCalendarComboBoxBase
278{
279public:
289 virtual BOOL Init(CXTPCalendarEvent* pEvent, XTPCalendarTheme nTheme);
290
291protected:
298 virtual void DrawItem(LPDRAWITEMSTRUCT lpDIS);
299};
300
311class _XTP_EXT_CLASS CXTPCalendarEventPropertiesDlg : public CDialog
312{
314 DECLARE_DYNAMIC(CXTPCalendarEventPropertiesDlg)
316public:
317 enum
318 {
319 IDD = XTP_IDD_CALENDAR_EVENT_PROPERTIES
320 };
321
363 CXTPCalendarEventPropertiesDlg(CXTPCalendarControl* pControl, BOOL bAddEvent,
364 CWnd* pParent = NULL, CXTPCalendarEvent* pEditingEvent = NULL,
365 UINT nIDTemplate = CXTPCalendarEventPropertiesDlg::IDD,
366 COleDateTime dtInitial = COleDateTime::GetCurrentTime());
371 virtual ~CXTPCalendarEventPropertiesDlg(){};
372
373protected:
378 virtual void UpdateControlsFromEvent();
379
385 virtual void UpdateControlsState();
386
394 virtual void InitReminderComboBox();
395
396 virtual void RepairCheckedEvent();
397
398 // Generated message map functions
399
400 virtual void DoDataExchange(CDataExchange* pDX); // DDX/DDV support
401 virtual BOOL OnInitDialog();
402 virtual void OnOK();
403 virtual void OnCancel();
404 afx_msg void OnCheckReminder();
405 afx_msg void OnBnClickedButtonRecurrecnce();
406 afx_msg int OnCreate(LPCREATESTRUCT lpCreateStruct);
407 afx_msg void OnBnClickedCheckAlldayEvent();
408 afx_msg void OnScheduleIdChanged();
409 afx_msg void OnSelChangeEventCategory();
410
411 virtual CString LoadString(UINT nIDResource) const;
412 virtual void AddEndDate_ResetTime(COleDateTime dtStartDate, COleDateTime& rdtEndDate,
413 int nDays);
415 DECLARE_MESSAGE_MAP()
418public:
419 DWORD GetLastEventID();
420 BOOL m_bOccurrence;
422 BOOL m_bRecurrenceUpdate;
424protected:
425 void OnStartDateChanged(NMHDR* pNMHDR, LRESULT* pResult);
426 void OnStartTimeChanged(NMHDR* pNMHDR, LRESULT* pResult);
427 void OnEndDateChanged(NMHDR* pNMHDR, LRESULT* pResult);
428 void OnEndTimeChanged(NMHDR* pNMHDR, LRESULT* pResult);
429
430protected:
431 CXTPCalendarEventPtr m_ptrEditingEvent;
432 CXTPCalendarControl* m_ptrControl;
433 CWnd* m_pOwnerWnd;
434 BOOL m_bAddEvent;
435 DWORD m_dNewEventID;
436 BOOL m_bHScrollEnabled;
437 BOOL m_bVScrollEnabled;
439protected:
440 //------------------------------------------------------------------------
441 CString m_strSubject;
443 CString m_strLocation;
445 CString m_strBody;
447 COleDateTime m_dtStartDate;
449 COleDateTime m_dtStartTime;
451 COleDateTime m_dtEndDate;
453 COleDateTime m_dtEndTime;
456 int m_nBusyStatus;
459 BOOL m_bAllDayEvent;
461 BOOL m_bPrivate;
463 BOOL m_bMeeting;
465 BOOL m_bReminder;
468 int m_nAllDayEventSet;
471 CXTPCalendarEventCategoryComboBox m_wndCategoryCombo;
473 CXTPCalendarEventLabelComboBox m_wndLabelCombo;
475 CComboBox m_wndReminderCombo;
476 CXTPCalendarBusyStatusComboBox m_wndBusyStatusCombo;
479 CComboBox m_ctrlScheduleIDCB;
480 CStatic m_ctrlScheduleLabel;
481 CCheckListBox m_ctrlScheduleSet;
482 XTPCalendarTheme m_nTheme;
483};
484
485# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
486#endif // !defined(_XTP_CALENDAR_EVENT_PROPERTIS_DLG_H__)
XTPCalendarTheme
XTPCalendarTheme
Paint themes used by calendar.
Definition XTPCalendarDefines.h:62
XTPDisableNoisyWarnings.h
CXTPCalendarBusyStatusComboBox
This class implements the busy status selector combobox.
Definition XTPCalendarEventPropertiesDlg.h:278
CXTPCalendarBusyStatusComboBox::DrawItem
virtual void DrawItem(LPDRAWITEMSTRUCT lpDIS)
This function implements custom draw combobox items.
CXTPCalendarBusyStatusComboBox::Init
virtual BOOL Init(CXTPCalendarEvent *pEvent, XTPCalendarTheme nTheme)
Call this member function to initialize the combobox.
CXTPCalendarComboBoxBase
This class is used as the base class for all owner drawn Calendar Event comboboxes.
Definition XTPCalendarEventPropertiesDlg.h:42
CXTPCalendarComboBoxBase::MeasureItem
virtual void MeasureItem(LPMEASUREITEMSTRUCT lpMIS)
This function implements measure items for custom draw.
CXTPCalendarComboBoxBase::CalcColorRect
virtual CRect CalcColorRect(CRect rItem)
This member function is called to calculate the size for the color rectangle displayed for each item.
CXTPCalendarComboBoxBase::~CXTPCalendarComboBoxBase
virtual ~CXTPCalendarComboBoxBase()
Standard object destructor.
CXTPCalendarComboBoxBase::CXTPCalendarComboBoxBase
CXTPCalendarComboBoxBase()
Standard object constructor.
CXTPCalendarComboBoxBase::Init
virtual BOOL Init(CXTPCalendarEvent *pEvent, XTPCalendarTheme nTheme)
Call this member function to initialize the combobox.
CXTPCalendarControl
Class CXTPCalendarControl implements the calendar's view interface.
Definition XTPCalendarControl.h:126
CXTPCalendarEventCategories
This class is used as a collection of CXTPCalendarEventCategory objects.
Definition XTPCalendarEventLabel.h:440
CXTPCalendarEventCategoryComboBox
This class implements the event category selector combobox.
Definition XTPCalendarEventPropertiesDlg.h:98
CXTPCalendarEventCategoryComboBox::GetCategoryArray
CXTPCalendarEventCategoryIDs & GetCategoryArray()
Call this member function to retrieve a reference to the combobox category array.
Definition XTPCalendarEventPropertiesDlg.h:210
CXTPCalendarEventCategoryComboBox::DrawItem
virtual void DrawItem(LPDRAWITEMSTRUCT lpDIS)
This function implements custom draw combobox items.
CXTPCalendarEventCategoryComboBox::m_pCategories
CXTPCalendarEventCategories * m_pCategories
Pointer to categories array.
Definition XTPCalendarEventPropertiesDlg.h:201
CXTPCalendarEventCategoryComboBox::m_arChecked
CXTPCalendarEventCategoryIDs m_arChecked
Array which stores checked item IDs.
Definition XTPCalendarEventPropertiesDlg.h:202
CXTPCalendarEventCategoryComboBox::RedrawLB
virtual void RedrawLB(BOOL bUpdateNow=FALSE)
Use this member function to redraw the list box (works for dropped state only).
CXTPCalendarEventCategoryComboBox::GetChecked
virtual void GetChecked(CXTPCalendarEventCategoryIDs *pChecked, BOOL *pbChanged)
Use this member to get selected categories.
CXTPCalendarEventCategoryComboBox::~CXTPCalendarEventCategoryComboBox
virtual ~CXTPCalendarEventCategoryComboBox()
Standard object destructor.
CXTPCalendarEventCategoryComboBox::DrawExpanded
virtual void DrawExpanded(CDC *pDC, CRect rcItem, BOOL bSelected, UINT uItemID)
Called to draw an event category item when the combobox is expanded.
CXTPCalendarEventCategoryComboBox::CXTPCalendarEventCategoryComboBox
CXTPCalendarEventCategoryComboBox()
Standard object constructor.
CXTPCalendarEventCategoryComboBox::Init
virtual BOOL Init(CXTPCalendarEvent *pEvent, XTPCalendarTheme nTheme)
Call this member function to initialize the combobox.
CXTPCalendarEventCategoryComboBox::GetLBCurSel
virtual int GetLBCurSel() const
Use this member function to get the list box selected item (works for dropped state only).
CXTPCalendarEventCategoryComboBox::DrawCollapsed
virtual void DrawCollapsed(CDC *pDC, CRect rcItem, BOOL bFocused, BOOL bDisabled)
Called to draw an event category item when the combobox is collapsed.
CXTPCalendarEventCategoryIDs
This class represents the collection of event categories IDs.
Definition XTPCalendarEventLabel.h:692
CXTPCalendarEvent
This class represents the data of a single Event used in the Calendar control.
Definition XTPCalendarEvent.h:77
CXTPCalendarEventLabelComboBox
This class implements the event label selector combobox.
Definition XTPCalendarEventPropertiesDlg.h:220
CXTPCalendarEventLabelComboBox::DrawItem
virtual void DrawItem(LPDRAWITEMSTRUCT lpDIS)
This function implements the custom draw combobox items.
CXTPCalendarEventLabelComboBox::GetLabelID
virtual int GetLabelID() const
Use this member to get the selected label ID.
CXTPCalendarEventLabelComboBox::SetLabelID
virtual void SetLabelID(int nID)
Use this member to set the selected label ID.
CXTPCalendarEventLabelComboBox::Init
virtual BOOL Init(CXTPCalendarEvent *pEvent, XTPCalendarTheme nTheme)
Call this member function to initialize the combobox.
CXTPCalendarEventLabelComboBox::GetLabelID
virtual int GetLabelID(int nID) const
Use this member to get the selected label ID.
CXTPCalendarEventPropertiesDlg
This class is used to edit calendar event properties.
Definition XTPCalendarEventPropertiesDlg.h:312
CXTPCalendarEventPropertiesDlg::CXTPCalendarEventPropertiesDlg
CXTPCalendarEventPropertiesDlg(CXTPCalendarControl *pControl, BOOL bAddEvent, CWnd *pParent=NULL, CXTPCalendarEvent *pEditingEvent=NULL, UINT nIDTemplate=CXTPCalendarEventPropertiesDlg::IDD, COleDateTime dtInitial=COleDateTime::GetCurrentTime())
Constructor with extra COleDateTime parameter - initial Dialog setting - user can change it if needed...
CXTPCalendarEventPropertiesDlg::UpdateControlsFromEvent
virtual void UpdateControlsFromEvent()
Update dialog controls values using editing event properties.
CXTPCalendarEventPropertiesDlg::InitReminderComboBox
virtual void InitReminderComboBox()
Initialize Reminder combobox.
CXTPCalendarEventPropertiesDlg::UpdateControlsState
virtual void UpdateControlsState()
Update dialog controls state (enabled and visible) using editing event properties.
CXTPCalendarEventPropertiesDlg::~CXTPCalendarEventPropertiesDlg
virtual ~CXTPCalendarEventPropertiesDlg()
Default object destructor.
Definition XTPCalendarEventPropertiesDlg.h:371
CXTPCalendarViewEvent
This class represents an event view portion of the CalendarViewGroup.
Definition XTPCalendarViewEvent.h:106


Toolkit Pro: XTPControlGallery.h Source File

  • Source
  • CommandBars
XTPControlGallery.h
Go to the documentation of this file.
1
23#if !defined(__XTPCONTROLGALLERY_H__)
24# define __XTPCONTROLGALLERY_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPControlGalleryItems;
34class CXTPControlGallery;
35class CXTPControlGalleryPaintManager;
36class CXTPImageManagerIcon;
37class CXTPMarkupUIElement;
38class CXTPMarkupContext;
39
40const UINT XTP_GN_PREVIEWSTART = 0x1010;
42const UINT XTP_GN_PREVIEWCANCEL = 0x1011;
44const UINT XTP_GN_PREVIEWAPPLY = 0x1012;
46const UINT XTP_GN_PREVIEWCHANGE = 0x1013;
48const UINT XTP_GN_STARTDRAG = 0x1014;
50const UINT XTP_GN_SELCHANGE = 0x1015;
53class CXTPControlGalleryItem;
54
60class _XTP_EXT_CLASS CXTPControlGallery
61 : public CXTPControlPopup
62 , public CXTPScrollBase
63{
65 DECLARE_XTP_CONTROL(CXTPControlGallery)
67public:
72 struct GALLERYITEM_POSITION
73 {
74 RECT rcItem;
75 CXTPControlGalleryItem* pItem;
76 BOOL bBeginRow;
77 };
78
79public:
84 CXTPControlGallery();
85
90 ~CXTPControlGallery();
91
92public:
98 void SetItems(CXTPControlGalleryItems* pItems);
99
108 void SetItemsMargin(int nLeft, int nTop, int nRight, int nBottom);
109
115 void SetControlSize(CSize szControl);
116
125 void SetControlSize(int nColumns, int nRows, CSize szItem);
126
127public:
136 int GetItemCount() const;
137
147 CXTPControlGalleryItem* GetItem(int nIndex) const;
148
156 virtual CXTPControlGalleryItems* GetItems() const;
157
165 void SetSelectedItem(int nSelected);
166
175 int GetSelectedItem() const;
176
184 void SetCheckedItem(int nId);
185
195 virtual BOOL IsItemChecked(CXTPControlGalleryItem* pItem) const;
196
205 int GetCheckedItem() const;
206
215 BOOL IsItemSelected() const;
216
217public:
218 static BOOL m_bAutoScaleDpi;
221public:
229 void ShowBorders(BOOL bShowBorders);
230
239 BOOL IsShowBorders() const;
240
246 void ShowLabels(BOOL bShowLabels);
247
255 void ShowScrollBar(BOOL bShowScrollBar);
256
265 BOOL IsScrollBarVisible() const;
266
272 void SetScrollBarAuto(BOOL bScrollBarAuto);
273
280 BOOL IsScrollBarAuto() const;
281
282public:
289 virtual CRect GetBorders() const;
290
298 CRect GetItemDrawRect(int nIndex);
299
309 int HitTestItem(CPoint point, LPRECT lpRect = NULL) const;
310
317 CRect GetItemsRect() const;
318
325 void InvalidateItems(LPCRECT lpRect = NULL, BOOL bAnimate = TRUE);
326
333 CXTPControlGalleryPaintManager* GetGalleryPaintManager() const;
334
341 CXTPScrollBarPaintManager* GetScrollBarPaintManager() const;
342
349 void EnsureVisible(int nIndex);
350
358 void SetScrollPos(int nScrollPos);
359
368 int GetScrollPos() const;
369
380 int SetTopIndex(int nIndex);
381
390 void SetResizable(BOOL bResizeWidth = TRUE, BOOL bResizeHeight = TRUE);
391
400 BOOL IsResizable() const;
401
406 virtual void OnSelectedItemChanged();
407
408public:
415 BOOL HasBottomSeparator() const;
416
425 long GetNext(long nIndex, int nDirection) const;
426
435 long GetNextInRow(long nIndex, int nDirection) const;
436
445 long GetNextInColumn(long nIndex, int nDirection) const;
446
455 long GetNextInPage(long nIndex, int nDirection) const;
456
467 int FindItem(int nStartAfter, LPCTSTR lpszItem, BOOL bExact) const;
468
476 CString GetItemCaption(int nIndex);
477
485 BOOL IsScrollButtonEnabled(int ht);
486
493 BOOL IsScrollBarEnabled() const;
494
501 BOOL IsShownAsButton() const;
502
504 _XTP_DEPRECATED_IN_FAVOR(IsShownAsButton)
505 BOOL IsShowAsButton() const
506 {
507 return IsShownAsButton();
508 }
515 void HideSelection();
516
517 void SetTransparent(BOOL bTransparent = TRUE);
518 BOOL IsTransparent() const;
519
520protected:
525 void Reposition();
526
532 void DrawItems(CDC* pDC);
533
534protected:
541 void Copy(CXTPControl* pControl, BOOL bRecursive = FALSE);
542
548 void DoPropExchange(CXTPPropExchange* pPX);
549
557 void OnCalcDynamicSize(DWORD dwMode);
558
560public:
561 virtual void SetRect(CRect rcControl);
562 virtual void OnItemsChanged();
563 BOOL OnHookMouseWheel(UINT nFlags, short zDelta, CPoint pt);
564
565protected:
566 virtual CSize GetSize(CDC* pDC);
567 virtual void Draw(CDC* pDC);
568
569 virtual void OnMouseMove(CPoint point);
570
571 virtual void OnClick(BOOL bKeyboard = FALSE, CPoint pt = CPoint(0, 0));
572 virtual void OnLButtonUp(CPoint point);
573 virtual BOOL OnSetSelected(int bSelected);
574 void DoScroll(int cmd, int pos);
575 void GetScrollInfo(SCROLLINFO* pSI);
576 void PerformMouseMove(CPoint point);
577 void PerformMouseDown(CPoint point);
578 void PerformMouseUp(CPoint point);
579 virtual void FillControl(CDC* pDC, CRect rcControl);
580 virtual void SetAction(CXTPControlAction* pAction);
581 virtual int GetCustomizeMinWidth() const;
582 virtual int GetCustomizeMinHeight() const;
583 virtual BOOL IsCustomizeResizeAllow() const;
584
585protected:
586 void DrawScrollBar(CDC* pDC);
587 CRect GetScrollBarRect();
588 void CalcScrollBarInfo(LPRECT lprc, XTP_SCROLLBAR_POSINFO* pSBInfo, SCROLLINFO* pSI);
589
590 BOOL IsFocused() const;
591 BOOL OnHookKeyDown(UINT nChar, LPARAM lParam);
592 virtual void OnScrollChanged();
593 virtual INT_PTR OnToolHitTest(CPoint point, TOOLINFO* pTI) const;
594 void OnExecute();
595 BOOL OnSetPopup(BOOL bPopup);
596 void OnMouseHover();
597
598protected:
599 CWnd* GetParentWindow() const;
600 virtual void AdjustExcludeRect(CRect& rc, BOOL /*bVertical*/);
601 virtual void RedrawScrollBar();
602 void DoAnimate();
603 void StartAnimation(int nScrollPos);
604 void RepositionCore();
605
608protected:
610 virtual HRESULT GetAccessibleChildCount(long* pcountChildren);
611 virtual HRESULT GetAccessibleChild(VARIANT varChild, IDispatch** ppdispChild);
612 virtual HRESULT GetAccessibleName(VARIANT varChild, BSTR* pszName);
613 virtual HRESULT GetAccessibleRole(VARIANT varChild, VARIANT* pvarRole);
614 virtual HRESULT AccessibleLocation(long* pxLeft, long* pyTop, long* pcxWidth, long* pcyHeight,
615 VARIANT varChild);
616 virtual HRESULT AccessibleHitTest(long xLeft, long yTop, VARIANT* pvarChild);
617 virtual HRESULT GetAccessibleState(VARIANT varChild, VARIANT* pvarState);
618 virtual HRESULT GetAccessibleDefaultAction(VARIANT varChild, BSTR* pszDefaultAction);
619 virtual HRESULT AccessibleDoDefaultAction(VARIANT varChild);
620 virtual HRESULT AccessibleSelect(long flagsSelect, VARIANT varChild);
623# ifdef _XTP_COMMANDBARS_ACTIVEX
626 DECLARE_DISPATCH_MAP()
627 DECLARE_INTERFACE_MAP()
628
629 DECLARE_OLETYPELIB_EX(CXTPControlGallery);
630
631 void OleSetItems(LPDISPATCH lpDispatch);
632 LPDISPATCH OleGetItems();
633
634 DECLARE_PROPERTY(SelectedItem, LPDISPATCH);
635 DECLARE_PROPERTY(CheckedItem, int);
636
638# endif
639
640protected:
641 int m_nChecked;
642 int m_nSelected;
643 BOOL m_bHideSelection;
644 BOOL m_bPressed;
645 CPoint m_ptPressed;
646 int m_nScrollPos;
647 int m_nScrollPosTarget;
648 double m_dAnimationStep;
650 BOOL m_bKeyboardSelected;
652 int m_nTotalHeight;
654 BOOL m_bShowLabels;
656 BOOL m_bShowScrollBar;
657 BOOL m_bShowBorders;
658 CRect m_rcMargin;
659 BOOL m_bPreview;
660 int m_nResizable;
662 BOOL m_bScrollBarAuto;
663 BOOL m_bTransparent;
664
665 CArray<GALLERYITEM_POSITION, GALLERYITEM_POSITION&> m_arrRects;
667 friend class CXTPControlGalleryItems;
668};
669
670# define GETPARTSTATE3(ht, bEnabled) \
671 (!bEnabled ? 4 : nPressedHt == ht ? 3 : nHotHt == ht ? 2 : 0)
672# define IS_PART_SELECTED(nState) (nState == 2)
673# define IS_PART_PRESSED(nState) (nState == 3)
674# define IS_PART_ENABLED(nState) (nState != 4)
675
681class _XTP_EXT_CLASS CXTPControlGalleryPaintManager : public CObject
682{
683 DECLARE_DYNAMIC(CXTPControlGalleryPaintManager);
684
685public:
691 CXTPControlGalleryPaintManager(CXTPPaintManager* pPaintManager);
692
693 //-----------------------------------------------------------------------
694 // Handles object destruction
695 //-----------------------------------------------------------------------
696 virtual ~CXTPControlGalleryPaintManager()
697 {
698 }
699
700public:
708 virtual void DrawLabel(CDC* pDC, CXTPControlGalleryItem* pLabel, CRect rc);
709
717 virtual void FillControl(CDC* pDC, CXTPControlGallery* pGallery, CRect rc);
718
719 virtual void DrawItem(CDC* pDC, CRect rcItem, BOOL bEnabled, BOOL bSelected, BOOL bPressed,
720 BOOL bChecked, CXTPControlGalleryItem* pGalleryItem,
721 CXTPControlGallery* pGallery);
722
723 virtual void DrawItemBack(CDC* pDC, CRect rcItem, BOOL bEnabled, BOOL bSelected, BOOL bPressed,
724 BOOL bChecked, XTPBarType barType);
725
726 virtual COLORREF GetItemTextColor(BOOL bEnabled, BOOL bSelected, BOOL bPressed, BOOL bChecked,
727 XTPBarType barType);
728
737 virtual void DrawPopupScrollBar(CDC* pDC, CXTPControlGallery* pGallery);
738
743 virtual void RefreshMetrics();
744
745public:
746 int m_cyPopupUp;
747 int m_cyPopupDown;
748 int m_cxPopup;
750 COLORREF m_clrBorder;
751
752 CXTPPaintManager* m_pPaintManager;
753};
754
755AFX_INLINE BOOL CXTPControlGallery::IsShowBorders() const
756{
757 return m_bShowBorders;
758}
759AFX_INLINE void CXTPControlGallery::ShowLabels(BOOL bShowLabels)
760{
761 m_bShowLabels = bShowLabels;
762}
763AFX_INLINE void CXTPControlGallery::ShowScrollBar(BOOL bShowScrollBar)
764{
765 m_bShowScrollBar = bShowScrollBar;
766}
767AFX_INLINE void CXTPControlGallery::ShowBorders(BOOL bShowBorders)
768{
769 m_bShowBorders = bShowBorders;
770}
771AFX_INLINE BOOL CXTPControlGallery::IsItemSelected() const
772{
773 return !m_bHideSelection && GetSelectedItem() != -1;
774}
775AFX_INLINE BOOL CXTPControlGallery::IsResizable() const
776{
777 return !IsShownAsButton() && GetItems() ? m_nResizable : FALSE;
778}
780AFX_INLINE BOOL CXTPControlGallery::IsCustomizeResizeAllow() const
781{
782 return IsResizable();
783}
785AFX_INLINE void CXTPControlGallery::SetScrollBarAuto(BOOL bScrollBarAuto)
786{
787 m_bScrollBarAuto = bScrollBarAuto;
788}
789AFX_INLINE BOOL CXTPControlGallery::IsScrollBarVisible() const
790{
791 return m_bShowScrollBar;
792}
793AFX_INLINE BOOL CXTPControlGallery::IsScrollBarAuto() const
794{
795 return m_bScrollBarAuto;
796}
797AFX_INLINE void CXTPControlGallery::SetTransparent(BOOL bTransparent)
798{
799 m_bTransparent = bTransparent;
800}
801AFX_INLINE BOOL CXTPControlGallery::IsTransparent() const
802{
803 return m_bTransparent;
804}
806# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
807#endif // #if !defined(__XTPCONTROLGALLERY_H__)
XTPBarType
XTPBarType
Type of the command bar.
Definition XTPCommandBarsDefines.h:77
DECLARE_XTP_CONTROL
#define DECLARE_XTP_CONTROL(class_name)
This macro generates the C++ header code necessary for a CXTPControl-derived class that can be serial...
Definition XTPCommandBarsDefines.h:1169
XTP_GN_PREVIEWAPPLY
const UINT XTP_GN_PREVIEWAPPLY
Gallery Notification - Occurs when the gallery preview is applied.
Definition XTPControlGallery.h:44
XTP_GN_PREVIEWCANCEL
const UINT XTP_GN_PREVIEWCANCEL
Gallery Notification - Occurs when the gallery preview is canceled.
Definition XTPControlGallery.h:42
XTP_GN_PREVIEWSTART
const UINT XTP_GN_PREVIEWSTART
Gallery Notification - Occurs when the gallery preview is started.
Definition XTPControlGallery.h:40
XTP_GN_SELCHANGE
const UINT XTP_GN_SELCHANGE
Gallery Notification - Occurs when the gallery selection has changed.
Definition XTPControlGallery.h:50
XTP_GN_STARTDRAG
const UINT XTP_GN_STARTDRAG
Gallery Notification - Occurs when an item is dragged in the gallery.
Definition XTPControlGallery.h:48
XTP_GN_PREVIEWCHANGE
const UINT XTP_GN_PREVIEWCHANGE
Gallery Notification - Occurs when the gallery preview is changed.
Definition XTPControlGallery.h:46
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPControlAction
CXTPControlAction is a CXTPCmdTarget derived class.
Definition XTPControl.h:53
CXTPControlGallery
CXTPControlGallery is a CXTPControlPopup derived class.
Definition XTPControlGallery.h:63
CXTPControlGallery::m_nSelected
int m_nSelected
Index of selected item.
Definition XTPControlGallery.h:642
CXTPControlGallery::CXTPControlGallery
CXTPControlGallery()
Constructs a CXTPControlGallery object.
CXTPControlGallery::DrawItems
void DrawItems(CDC *pDC)
This method is called to draw all items.
CXTPControlGallery::m_arrRects
CArray< GALLERYITEM_POSITION, GALLERYITEM_POSITION & > m_arrRects
bounding rectangles
Definition XTPControlGallery.h:665
CXTPControlGallery::m_dAnimationStep
double m_dAnimationStep
Number of steps to complete animation.
Definition XTPControlGallery.h:648
CXTPControlGallery::ShowBorders
void ShowBorders(BOOL bShowBorders)
Call this method to show/hide borders around the gallery.
Definition XTPControlGallery.h:767
CXTPControlGallery::Copy
void Copy(CXTPControl *pControl, BOOL bRecursive=FALSE)
This method is called to copy the control.
CXTPControlGallery::m_nTotalHeight
int m_nTotalHeight
Total height of items.
Definition XTPControlGallery.h:652
CXTPControlGallery::SetTopIndex
int SetTopIndex(int nIndex)
Call this method to scroll gallery to the specified top item.
CXTPControlGallery::GetItemCount
int GetItemCount() const
Call this method to get the count of items in the gallery.
CXTPControlGallery::GetBorders
virtual CRect GetBorders() const
Call this method to get the border margins for the gallery.
CXTPControlGallery::IsScrollButtonEnabled
BOOL IsScrollButtonEnabled(int ht)
Determines if the scrollbar button is enabled.
CXTPControlGallery::DoPropExchange
void DoPropExchange(CXTPPropExchange *pPX)
Either reads this object from or writes this object to an archive.
CXTPControlGallery::SetControlSize
void SetControlSize(int nColumns, int nRows, CSize szItem)
Call this method to the set size of the control depending on the number of rows, columns,...
CXTPControlGallery::m_ptPressed
CPoint m_ptPressed
Position of pressed item.
Definition XTPControlGallery.h:645
CXTPControlGallery::SetSelectedItem
void SetSelectedItem(int nSelected)
Call this method to set the selected item in the gallery.
CXTPControlGallery::m_bHideSelection
BOOL m_bHideSelection
TRUE to hide selection.
Definition XTPControlGallery.h:643
CXTPControlGallery::m_nResizable
int m_nResizable
TRUE if the pop-up galley is resizable, see XTPGalleryResizable.
Definition XTPControlGallery.h:660
CXTPControlGallery::IsItemSelected
BOOL IsItemSelected() const
Determines if any item in the gallery is selected.
Definition XTPControlGallery.h:771
CXTPControlGallery::OnSelectedItemChanged
virtual void OnSelectedItemChanged()
This method is called when the selection is changed by the user.
CXTPControlGallery::m_nScrollPosTarget
int m_nScrollPosTarget
Scroll position.
Definition XTPControlGallery.h:647
CXTPControlGallery::m_bShowBorders
BOOL m_bShowBorders
TRUE to show borders.
Definition XTPControlGallery.h:657
CXTPControlGallery::~CXTPControlGallery
~CXTPControlGallery()
Destroys a CXTPControlGallery object, handles cleanup and deallocation.
CXTPControlGallery::HasBottomSeparator
BOOL HasBottomSeparator() const
Call this function to check if the gallery has a bottom separator.
CXTPControlGallery::ShowLabels
void ShowLabels(BOOL bShowLabels)
Call this method to show/hide labels for the gallery.
Definition XTPControlGallery.h:759
CXTPControlGallery::m_bShowScrollBar
BOOL m_bShowScrollBar
TRUE to show scrollbars.
Definition XTPControlGallery.h:656
CXTPControlGallery::SetCheckedItem
void SetCheckedItem(int nId)
Call this method to set the checked item identifier for the gallery.
CXTPControlGallery::GetNextInPage
long GetNextInPage(long nIndex, int nDirection) const
Call this method to get the index of the next focusable item in the same page.
CXTPControlGallery::IsResizable
BOOL IsResizable() const
Call this method to check if the gallery can be resized by the user.
Definition XTPControlGallery.h:775
CXTPControlGallery::m_bShowLabels
BOOL m_bShowLabels
TRUE to show labels.
Definition XTPControlGallery.h:654
CXTPControlGallery::m_nScrollPos
int m_nScrollPos
Scroll position.
Definition XTPControlGallery.h:646
CXTPControlGallery::HideSelection
void HideSelection()
Call this method to hide the selection.
CXTPControlGallery::Reposition
void Reposition()
This method is called to set the position of all items.
CXTPControlGallery::m_nChecked
int m_nChecked
Checked ID.
Definition XTPControlGallery.h:641
CXTPControlGallery::FindItem
int FindItem(int nStartAfter, LPCTSTR lpszItem, BOOL bExact) const
Call this method to search for an item.
CXTPControlGallery::IsScrollBarEnabled
BOOL IsScrollBarEnabled() const
Call this member to check if the scrollbar is enabled.
CXTPControlGallery::IsItemChecked
virtual BOOL IsItemChecked(CXTPControlGalleryItem *pItem) const
Call this method to determine if an item is checked.
CXTPControlGallery::m_bPreview
BOOL m_bPreview
TRUE if control is in preview mode.
Definition XTPControlGallery.h:659
CXTPControlGallery::GetSelectedItem
int GetSelectedItem() const
Call this method to get the selected item in the gallery.
CXTPControlGallery::OnCalcDynamicSize
void OnCalcDynamicSize(DWORD dwMode)
This method is called before recalculating the parent command bar size to calculate the dimensions of...
CXTPControlGallery::GetItemCaption
CString GetItemCaption(int nIndex)
Call this method to get the caption of an item.
CXTPControlGallery::SetResizable
void SetResizable(BOOL bResizeWidth=TRUE, BOOL bResizeHeight=TRUE)
Call this method to allow the user to resize the gallery.
CXTPControlGallery::GetItemDrawRect
CRect GetItemDrawRect(int nIndex)
Determines the bounding rectangle of the item.
CXTPControlGallery::HitTestItem
int HitTestItem(CPoint point, LPRECT lpRect=NULL) const
This method determines where a point lies in a specified item.
CXTPControlGallery::GetNextInColumn
long GetNextInColumn(long nIndex, int nDirection) const
Call this method to get the index of the next focusable item in the same column.
CXTPControlGallery::GetGalleryPaintManager
CXTPControlGalleryPaintManager * GetGalleryPaintManager() const
Retrieves CXTPControlGalleryPaintManager pointer to draw gallery.
CXTPControlGallery::InvalidateItems
void InvalidateItems(LPCRECT lpRect=NULL, BOOL bAnimate=TRUE)
Call this method to redraw items.
CXTPControlGallery::SetItems
void SetItems(CXTPControlGalleryItems *pItems)
Call this method to set items for the gallery.
CXTPControlGallery::GetItem
CXTPControlGalleryItem * GetItem(int nIndex) const
Call this method to retrieve an item by its index.
CXTPControlGallery::SetScrollPos
void SetScrollPos(int nScrollPos)
Call this method to set the scrollbar position for the gallery.
CXTPControlGallery::SetScrollBarAuto
void SetScrollBarAuto(BOOL bScrollBarAuto)
Call this method to automatically show/hide the scrollbar for the gallery.
Definition XTPControlGallery.h:785
CXTPControlGallery::EnsureVisible
void EnsureVisible(int nIndex)
Call this member to ensure that a specified item is visible in the gallery.
CXTPControlGallery::GetNextInRow
long GetNextInRow(long nIndex, int nDirection) const
Call this method to get the index of the next focusable item in the same row.
CXTPControlGallery::IsShowBorders
BOOL IsShowBorders() const
Call this method to determine if borders are visible around the gallery.
Definition XTPControlGallery.h:755
CXTPControlGallery::GetItems
virtual CXTPControlGalleryItems * GetItems() const
Call this method to get items associated with the gallery.
CXTPControlGallery::IsScrollBarAuto
BOOL IsScrollBarAuto() const
Determines if the scrollbar for the gallery is automatically shown/hidden.
Definition XTPControlGallery.h:793
CXTPControlGallery::IsShownAsButton
BOOL IsShownAsButton() const
Determines if the gallery is shown as a button.
CXTPControlGallery::m_rcMargin
CRect m_rcMargin
Margins of gallery items.
Definition XTPControlGallery.h:658
CXTPControlGallery::IsTransparent
BOOL IsTransparent() const
Determines if the control needs to draw its background.
Definition XTPControlGallery.h:801
CXTPControlGallery::m_bKeyboardSelected
BOOL m_bKeyboardSelected
TRUE if item was selected using keyboard.
Definition XTPControlGallery.h:650
CXTPControlGallery::GetNext
long GetNext(long nIndex, int nDirection) const
Call this method to get the index of the next focusable item.
CXTPControlGallery::m_bPressed
BOOL m_bPressed
TRUE if item is pressed.
Definition XTPControlGallery.h:644
CXTPControlGallery::GetScrollBarPaintManager
CXTPScrollBarPaintManager * GetScrollBarPaintManager() const
Retrieves CXTPScrollBarPaintManager pointer to draw ScrollBar.
CXTPControlGallery::GetCheckedItem
int GetCheckedItem() const
Call this method to get the checked item identifier for the gallery.
CXTPControlGallery::ShowScrollBar
void ShowScrollBar(BOOL bShowScrollBar)
Call this method to show/hide the scrollbar for the gallery.
Definition XTPControlGallery.h:763
CXTPControlGallery::m_bAutoScaleDpi
static BOOL m_bAutoScaleDpi
TRUE by default.
Definition XTPControlGallery.h:218
CXTPControlGallery::SetControlSize
void SetControlSize(CSize szControl)
Call this method to set the size of the control.
CXTPControlGallery::GetScrollPos
int GetScrollPos() const
Call this method to get the scrollbar position for the gallery.
CXTPControlGallery::IsScrollBarVisible
BOOL IsScrollBarVisible() const
Call this method to check if the scrollbar for the gallery is visible.
Definition XTPControlGallery.h:789
CXTPControlGallery::GetItemsRect
CRect GetItemsRect() const
Determines the bounding rectangle of the items.
CXTPControlGallery::SetItemsMargin
void SetItemsMargin(int nLeft, int nTop, int nRight, int nBottom)
Call this method to set margins around items.
CXTPControlGalleryItem
CXTPControlGalleryItem is a CXTPCmdTarget derived class.
Definition XTPControlGalleryItem.h:39
CXTPControlGalleryItems
CXTPControlGalleryItems is a CXTPCmdTarget derived class.
Definition XTPControlGalleryItems.h:39
CXTPControlGalleryPaintManager
CXTPControlGalleryPaintManager is a standalone class used to draw a CXTPControlGallery object.
Definition XTPControlGallery.h:682
CXTPControlGalleryPaintManager::m_cyPopupUp
int m_cyPopupUp
Height of up arrow of in-place scrollbar.
Definition XTPControlGallery.h:746
CXTPControlGalleryPaintManager::m_cxPopup
int m_cxPopup
Width of arrows of in-place scrollbar.
Definition XTPControlGallery.h:748
CXTPControlGalleryPaintManager::DrawPopupScrollBar
virtual void DrawPopupScrollBar(CDC *pDC, CXTPControlGallery *pGallery)
This method is called to draw the scrollbar for an in-place gallery.
CXTPControlGalleryPaintManager::FillControl
virtual void FillControl(CDC *pDC, CXTPControlGallery *pGallery, CRect rc)
This method is called to draw the background of the gallery.
CXTPControlGalleryPaintManager::RefreshMetrics
virtual void RefreshMetrics()
Recalculates gallery metrics.
CXTPControlGalleryPaintManager::m_cyPopupDown
int m_cyPopupDown
Height of down arrow of in-place scrollbar.
Definition XTPControlGallery.h:747
CXTPControlGalleryPaintManager::DrawLabel
virtual void DrawLabel(CDC *pDC, CXTPControlGalleryItem *pLabel, CRect rc)
This method is called to draw a label control.
CXTPControlGalleryPaintManager::CXTPControlGalleryPaintManager
CXTPControlGalleryPaintManager(CXTPPaintManager *pPaintManager)
Constructs a CXTPControlGalleryPaintManager object.
CXTPControl
CXTPControl is a CXTPCmdTarget derived class.
Definition XTPControl.h:841
CXTPControl::IsCustomizeResizeAllow
virtual BOOL IsCustomizeResizeAllow() const
This member checks if the user can resize the control.
CXTPControl::OnExecute
virtual void OnExecute()
This method is called when the control is executed.
CXTPControl::OnHookKeyDown
virtual BOOL OnHookKeyDown(UINT nChar, LPARAM lParam)
This method is called when a non-system key is pressed.
Definition XTPControl.h:2726
CXTPControl::Draw
virtual void Draw(CDC *pDC)
This method is called to draw the control.
CXTPControl::OnToolHitTest
virtual INT_PTR OnToolHitTest(CPoint point, TOOLINFO *pTI) const
The framework calls this member function to determine whether a point is in the bounding rectangle of...
Definition XTPControl.h:2813
CXTPControl::SetRect
virtual void SetRect(CRect rcControl)
This member is called to set the bounding rectangle of the control.
Definition XTPControl.h:2580
CXTPControl::IsTransparent
virtual BOOL IsTransparent() const
Determines if the control needs to draw its background.
Definition XTPControl.h:1383
CXTPControl::GetCustomizeMinWidth
virtual int GetCustomizeMinWidth() const
Retrieves the available minimum width of control.
Definition XTPControl.h:2702
CXTPControl::GetCustomizeMinHeight
virtual int GetCustomizeMinHeight() const
Retrieves available minimum height of the control.
Definition XTPControl.h:2706
CXTPControl::GetSize
virtual CSize GetSize(CDC *pDC)
This method is called to determine the size of the control.
CXTPControl::SetAction
virtual void SetAction(CXTPControlAction *pAction)
Call this method to manually assign an action for control.
CXTPControl::IsFocused
virtual BOOL IsFocused() const
Call this member to check the focused state of the control.
Definition XTPControl.h:2755
CXTPControl::OnHookMouseWheel
virtual BOOL OnHookMouseWheel(UINT nFlags, short zDelta, CPoint point)
This method is called when the user rotates the mouse wheel.
Definition XTPControl.h:2767
CXTPControlPopup
CXTPControlPopup is a CXTPControl derived class.
Definition XTPControlPopup.h:42
CXTPControlPopup::OnMouseHover
void OnMouseHover()
This method is called after the mouse hovers over the control.
CXTPControlPopup::OnSetSelected
BOOL OnSetSelected(int bSelected)
This method is called when the control becomes selected.
CXTPControlPopup::OnLButtonUp
virtual void OnLButtonUp(CPoint point)
This member is called when the user releases the left mouse button.
CXTPControlPopup::OnClick
void OnClick(BOOL bKeyboard=FALSE, CPoint pt=CPoint(0, 0))
This method is called when the user clicks the control.
CXTPControlPopup::AdjustExcludeRect
virtual void AdjustExcludeRect(CRect &rc, BOOL bVertical)
Updates rectangle to set the position where the child pop-up bar becomes visible.
CXTPControlPopup::OnSetPopup
virtual BOOL OnSetPopup(BOOL bPopup)
This method is called to pop-up the control.
CXTPControlPopup::OnMouseMove
virtual void OnMouseMove(CPoint point)
This member is called when the mouse cursor moves.
CXTPImageManagerIcon
Icons holder class.
Definition XTPImageManager.h:622
CXTPMarkupContext
CXTPMarkupContext is a standalone class used to provide common settings for Markup objects.
Definition XTPMarkupContext.h:128
CXTPMarkupUIElement
Base class for XML Markup core level implementations.
Definition XTPMarkupUIElement.h:43
CXTPPaintManager
Paint manager of the command bars.
Definition XTPPaintManager.h:199
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72
CXTPScrollBarPaintManager
CXTPScrollBarPaintManager is standalone class used to draw CXTPCommandBarScrollBarCtrl object.
Definition XTPScrollBarPaintManager.h:40
CXTPScrollBase
CXTPScrollBase is the base class for all scrollable objects.
Definition XTPScrollBase.h:222
CXTPScrollBase::GetParentWindow
virtual CWnd * GetParentWindow() const =0
Retrieves parent window of scrollbar.
CXTPScrollBase::GetScrollInfo
virtual void GetScrollInfo(SCROLLINFO *psi)=0
The GetScrollInfo function retrieves the parameters of a scroll bar, including the minimum and maximu...
CXTPScrollBase::GetScrollBarRect
virtual CRect GetScrollBarRect()=0
Obtains the rectangle occupied by the scrollbar in client coordinates.
CXTPScrollBase::RedrawScrollBar
virtual void RedrawScrollBar()=0
Forces the scrollbar to redraw itself.
CXTPControlGallery::GALLERYITEM_POSITION
Structure contains item position description.
Definition XTPControlGallery.h:73
CXTPControlGallery::GALLERYITEM_POSITION::bBeginRow
BOOL bBeginRow
TRUE if the item starts a new row.
Definition XTPControlGallery.h:76
CXTPControlGallery::GALLERYITEM_POSITION::pItem
CXTPControlGalleryItem * pItem
Item pointer.
Definition XTPControlGallery.h:75
CXTPControlGallery::GALLERYITEM_POSITION::rcItem
RECT rcItem
Bounding rectangle of the item.
Definition XTPControlGallery.h:74
XTP_SCROLLBAR_POSINFO
The XTP_SCROLLBAR_POSINFO structure contains scroll bar information.
Definition XTPScrollBase.h:143


Toolkit Pro: Member List

CXTPMarkupWrapPanel Member List

This is the complete list of members for CXTPMarkupWrapPanel, including all inherited members.

ApplyRenderTransform(CXTPMarkupDrawingContext *pContext) | CXTPMarkupUIElement | protectedvirtual
Arrange(CRect rcFinalRect) | CXTPMarkupUIElement |
ArrangeCore(CRect rcFinalRect) | CXTPMarkupUIElement | protectedvirtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPMarkupFrameworkElement() | CXTPMarkupFrameworkElement | protected
CXTPMarkupPanel() | CXTPMarkupPanel | protected
CXTPMarkupUIElement() | CXTPMarkupUIElement | protected
CXTPMarkupVisual() | CXTPMarkupVisual |
CXTPMarkupWrapPanel() | CXTPMarkupWrapPanel | protected
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAbsoluteVisualOffset() const | CXTPMarkupVisual | protected
GetActualSize() const | CXTPMarkupFrameworkElement |
GetBackground() const | CXTPMarkupPanel |
GetBoundRect() const | CXTPMarkupVisual |
GetChildren() const | CXTPMarkupPanel |
GetClipToBounds() const | CXTPMarkupFrameworkElement |
GetDesiredSize() const | CXTPMarkupUIElement |
GetFinalRect() const | CXTPMarkupUIElement |
GetHeight() const | CXTPMarkupFrameworkElement |
GetHorizontalAlignment() const | CXTPMarkupFrameworkElement |
GetLayoutClip(CRect &rc) const | CXTPMarkupUIElement | protectedvirtual
GetLogicalChild(int nIndex) const | CXTPMarkupVisual | virtual
GetLogicalChildrenCount() const | CXTPMarkupVisual | virtual
GetMargin() const | CXTPMarkupFrameworkElement |
GetMaxHeight() const | CXTPMarkupFrameworkElement |
GetMaxWidth() const | CXTPMarkupFrameworkElement |
GetMinHeight() const | CXTPMarkupFrameworkElement |
GetMinWidth() const | CXTPMarkupFrameworkElement |
GetOpacity() const | CXTPMarkupUIElement | protectedvirtual
GetOrientation() const | CXTPMarkupWrapPanel |
GetRenderSize() const | CXTPMarkupVisual |
GetRenderTransform() const | CXTPMarkupUIElement | protected
GetStyle() const | CXTPMarkupFrameworkElement |
GetTag() const | CXTPMarkupFrameworkElement |
GetUpdateRect() const | CXTPMarkupVisual |
GetVerticalAlignment() const | CXTPMarkupFrameworkElement |
GetVisibility() const | CXTPMarkupUIElement |
GetVisualChild(int nIndex) const | CXTPMarkupVisual | virtual
GetVisualChildrenCount() const | CXTPMarkupVisual | virtual
GetVisualOffset() const | CXTPMarkupVisual |
GetVisualParent() const | CXTPMarkupVisual |
GetWidth() const | CXTPMarkupFrameworkElement |
InputHitTest(CPoint point) const | CXTPMarkupVisual |
InputHitTestOverride(CPoint point) const | CXTPMarkupVisual | protectedvirtual
InvalidateArrange() | CXTPMarkupUIElement | virtual
InvalidateMeasure() | CXTPMarkupUIElement | virtual
InvalidateMeasureOverride(CXTPMarkupDrawingContext *pDC) | CXTPMarkupUIElement | protectedvirtual
InvalidateVisual() | CXTPMarkupUIElement | virtual
IsEnabled() const | CXTPMarkupUIElement |
IsFocusable() const | CXTPMarkupUIElement |
IsVisible() const | CXTPMarkupUIElement | virtual
m_bArrangeDirty | CXTPMarkupUIElement | protected
m_bArrangeInProgress | CXTPMarkupUIElement | protected
m_bMeasureDirty | CXTPMarkupUIElement | protected
m_bMeasureInProgress | CXTPMarkupUIElement | protected
m_bNeverArranged | CXTPMarkupUIElement | protected
m_bNeverMeasured | CXTPMarkupUIElement | protected
m_pClipToBoundsProperty | CXTPMarkupUIElement | static
m_pFocusableProperty | CXTPMarkupUIElement | static
m_pIsEnabledProperty | CXTPMarkupUIElement | static
m_pOpacityProperty | CXTPMarkupUIElement | static
m_pRenderTransformOriginProperty | CXTPMarkupUIElement | static
m_pRenderTransformProperty | CXTPMarkupUIElement | static
m_ptVisualOffset | CXTPMarkupVisual | protected
m_pVisibilityProperty | CXTPMarkupUIElement | static
m_rcBoundRect | CXTPMarkupVisual | protected
m_rcFinalRect | CXTPMarkupUIElement | protected
m_rcPrevUpdateRect | CXTPMarkupVisual | protected
m_rcUpdateRect | CXTPMarkupVisual | protected
m_szDesiredSize | CXTPMarkupUIElement | protected
m_szPreviousAvailableSize | CXTPMarkupUIElement | protected
m_szRenderSize | CXTPMarkupVisual | protected
Measure(CXTPMarkupDrawingContext *pDC, CSize szAvailableSize) | CXTPMarkupUIElement |
MeasureCore(CXTPMarkupDrawingContext *pDC, CSize szAvailableSize) | CXTPMarkupUIElement | protectedvirtual
OnRender(CXTPMarkupDrawingContext *drawingContext) | CXTPMarkupVisual | protectedvirtual
OnRenderFocusVisual(CXTPMarkupDrawingContext *drawingContext) | CXTPMarkupVisual | protectedvirtual
PtInRectTransform(const RECT &rect, const POINT &point) const | CXTPMarkupVisual | protected
Render(CXTPMarkupDrawingContext *drawingContext) | CXTPMarkupVisual |
RenderClipped(CXTPMarkupDrawingContext *drawingContext) | CXTPMarkupVisual | protectedvirtual
RestoreRenderTransform(CXTPMarkupDrawingContext *pContext, TransformationMatrices &matrices) | CXTPMarkupUIElement | protectedvirtual
SetBackground(CXTPMarkupBrush *pBrush) | CXTPMarkupPanel |
SetClipToBounds(BOOL bClipToBounds) | CXTPMarkupFrameworkElement |
SetHeight(int nHeight) | CXTPMarkupFrameworkElement |
SetHorizontalAlignment(XTPMarkupHorizontalAlignment alignment) | CXTPMarkupFrameworkElement |
SetMargin(int nLeft, int nTop, int nRight, int nBottom) | CXTPMarkupFrameworkElement |
SetMargin(int nMargin) | CXTPMarkupFrameworkElement |
SetMaxHeight(int nHeight) | CXTPMarkupFrameworkElement |
SetMaxWidth(int nWidth) | CXTPMarkupFrameworkElement |
SetMinHeight(int nHeight) | CXTPMarkupFrameworkElement |
SetMinWidth(int nWidth) | CXTPMarkupFrameworkElement |
SetOrientation(XTPMarkupOrientation orientation) | CXTPMarkupWrapPanel |
SetTag(CXTPMarkupObject *pTag) | CXTPMarkupFrameworkElement |
SetVerticalAlignment(XTPMarkupVerticalAlignment alignment) | CXTPMarkupFrameworkElement |
SetVisibility(XTPMarkupVisibility visibility) | CXTPMarkupUIElement |
SetWidth(int nWidth) | CXTPMarkupFrameworkElement |
~CXTPMarkupFrameworkElement() | CXTPMarkupFrameworkElement | protectedvirtual
~CXTPMarkupPanel() | CXTPMarkupPanel | protectedvirtual
~CXTPMarkupUIElement() | CXTPMarkupUIElement | protectedvirtual
~CXTPMarkupVisual() | CXTPMarkupVisual | virtual
~CXTPMarkupWrapPanel() | CXTPMarkupWrapPanel | protectedvirtual


Toolkit Pro: XTPWnd.h Source File

  • Source
  • Common
  • ScrollBar
XTPWnd.h
Go to the documentation of this file.
1
23#if !defined(__XTPWND_H__)
24# define __XTPWND_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPScrollBarCtrl;
34
35class _XTP_EXT_CLASS CXTPWnd : public CWnd
36{
38 DECLARE_DYNAMIC(CXTPWnd)
41public:
46 CXTPWnd();
47
52 virtual ~CXTPWnd();
53
54public:
55 //{{AFX_VIRTUAL(CXTPWnd)
56 virtual CScrollBar* GetScrollBarCtrl(int nBar) const;
57 virtual BOOL PreCreateWindow(CREATESTRUCT& cs);
58 virtual void PreSubclassWindow();
59 virtual LRESULT WindowProc(UINT message, WPARAM wParam, LPARAM lParam);
60 //}}AFX_VIRTUAL
61
62 DECLARE_MESSAGE_MAP()
63 //{{AFX_MSG(CXTPWnd)
64 afx_msg int OnCreate(LPCREATESTRUCT lpCreateStruct);
65 afx_msg void OnSize(UINT nType, int cx, int cy);
66 afx_msg void OnNcCalcSize(BOOL bCalcValidRects, NCCALCSIZE_PARAMS* lpncsp);
67 //}}AFX_MSG
68
69protected:
70 void SetScrollBarTheme(XTPScrollBarTheme theme);
71
72 BOOL m_bEnableThemedScrollBar;
73
74 CXTPScrollBarCtrl* m_pwndScrollBar[2];
75};
76
77# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
79#endif // !defined(__XTPWND_H__)
XTPDisableNoisyWarnings.h
XTPScrollBarTheme
XTPScrollBarTheme
Scrollbar theme identifier enum.
Definition XTPScrollBase.h:87
CXTPScrollBarCtrl
Scrollbar control.
Definition XTPScrollBarCtrl.h:48


Toolkit Pro: Member List

CXTPChartBubbleSeriesLabelView Member List

This is the complete list of members for CXTPChartBubbleSeriesLabelView, including all inherited members.

AddChildView(CXTPChartElementView *pChildView) | CXTPChartElementView |
CreateDeviceCommand(CXTPChartDeviceContext *pDC) | CXTPChartBubbleSeriesLabelView | virtual
CreateDeviceCommand(CXTPChartDeviceContext *pDC, CXTPChartPointF ptCenterPoint) | CXTPChartBubbleSeriesLabelView | virtual
CreateDeviceCommand(CXTPChartDeviceContext *pDC, CXTPChartPointF ptCenterPoint, const CXTPChartString &text) | CXTPChartBubbleSeriesLabelView | virtual
CreateDeviceCommand(CXTPChartDeviceContext *pDC, const CXTPChartPointF &ptAnchorPoint, double dAnchorAngle, const CXTPChartString &text) | CXTPChartBubbleSeriesLabelView | virtual
CXTPChartBubbleSeriesLabelView(CXTPChartSeriesLabel *pLabel, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView) | CXTPChartBubbleSeriesLabelView |
CXTPChartDiagram2DSeriesLabelView(CXTPChartSeriesLabel *pLabel, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView) | CXTPChartDiagram2DSeriesLabelView |
CXTPChartElementView(CXTPChartElementView *pParentView) | CXTPChartElementView |
CXTPChartElementView(CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartElementView |
CXTPChartElementView(CXTPChartContainer *pContainer) | CXTPChartElementView |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
GetAnchorPoint() const | CXTPChartDiagram2DSeriesLabelView | virtual
GetAt(int nIndex) const | CXTPChartElementView |
GetBounds() const | CXTPChartElementView |
GetBounds(BOOL bIncludingChildren) const | CXTPChartElementView |
GetChildren() | CXTPChartElementView |
GetCount() const | CXTPChartElementView |
GetParentView() const | CXTPChartElementView |
Is3D() const | CXTPChartObject |
m_arrChildren | CXTPChartElementView | protected
m_pContainer | CXTPChartElementView | protected
m_pParentView | CXTPChartElementView | protected
m_rcBounds | CXTPChartElementView | protected
~CXTPChartElementView() | CXTPChartElementView | protectedvirtual


Toolkit Pro: Member List

CXTPPropExchangeSection Member List

This is the complete list of members for CXTPPropExchangeSection, including all inherited members.

CXTPPropExchangeSection(CXTPPropExchange *pPX) | CXTPPropExchangeSection | explicit
CXTPPropExchangeSection(BOOL bLoading, LPCTSTR lpszSection) | CXTPPropExchangeSection |
~CXTPPropExchangeSection() | CXTPPropExchangeSection | virtual


Toolkit Pro: Member List

CXTPDockingPaneWinNativeTheme Member List

This is the complete list of members for CXTPDockingPaneWinNativeTheme, including all inherited members.

AdjustCaptionRect(const CXTPDockingPaneSidePanel *pPane, CRect &rc) | CXTPDockingPanePaintManager | virtual
AdjustCaptionRect(const CXTPDockingPaneTabbedContainer *pPane, CRect &rc) | CXTPDockingPanePaintManager | virtual
AdjustClientRect(CXTPDockingPaneSidePanel *pPane, CRect &rect) | CXTPDockingPanePaintManager | virtual
AdjustClientRect(CXTPDockingPaneTabbedContainer *pPane, CRect &rect, BOOL bApply) | CXTPDockingPanePaintManager | virtual
ClipAndAddEllipsisIfNeeded(CDC *pDC, CString &strTitle, int nCaptionWidth) const | CXTPDockingPanePaintManager | protected
CXTPCmdTarget() | CXTPCmdTarget |
CXTPDockingPaneDefaultTheme() | CXTPDockingPaneDefaultTheme |
CXTPDockingPaneGripperedTheme() | CXTPDockingPaneGripperedTheme |
CXTPDockingPanePaintManager() | CXTPDockingPanePaintManager | protected
CXTPDockingPaneVisualStudio2003Theme() | CXTPDockingPaneVisualStudio2003Theme |
CXTPDockingPaneWinNativeTheme() | CXTPDockingPaneWinNativeTheme |
DrawAutoHidePanel(CDC *pDC, CRect rc, XTPDockingPaneDirection direction) | CXTPDockingPanePaintManager | virtual
DrawCaption(CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc) | CXTPDockingPaneWinNativeTheme | virtual
DrawCaptionButton(CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton) | CXTPDockingPanePaintManager | virtual
DrawCaptionButtonEntry(CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton, CSize szOffset) | CXTPDockingPanePaintManager | protectedvirtual
DrawCaptionButtonEntry(CDC *pDC, CXTPDockingPaneCaptionButton *pButton, CPoint pt, COLORREF clrButton) | CXTPDockingPanePaintManager | protectedvirtual
DrawCaptionButtons(CDC *pDC, CXTPDockingPaneCaptionButtons *pButtons, CRect &rcCaption, COLORREF clr, int nButtonSize, int nButtonGap, BOOL bVertical=FALSE) | CXTPDockingPanePaintManager | virtual
DrawCaptionPart(CDC *pDC, CXTPDockingPaneBase *pPane, CRect rcCaption, const CString &strTitle, BOOL bActive, BOOL bVertical) | CXTPDockingPaneWinNativeTheme | protectedvirtual
DrawCaptionText(CDC *pDC, const CString &strTitle, CRect rc, BOOL bVertical, BOOL bCalcWidth=FALSE) | CXTPDockingPanePaintManager |
DrawFloatingFrame(CDC *pDC, CXTPDockingPaneMiniWnd *pPane, CRect rc) | CXTPDockingPaneWinNativeTheme | virtual
DrawPane(CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc) | CXTPDockingPanePaintManager | virtual
DrawSidePanel(CDC *pDC, CXTPDockingPaneSidePanel *pPane, CRect rc) | CXTPDockingPaneWinNativeTheme | virtual
DrawSplitter(CDC *pDC, CXTPDockingPaneSplitterWnd *pSplitter) | CXTPDockingPanePaintManager | virtual
FillCaptionPart(CDC *pDC, CXTPDockingPaneBase *pPane, CRect rcCaption, BOOL bActive, BOOL bVertical) | CXTPDockingPaneVisualStudio2003Theme | protectedvirtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCaptionButtonStyle() const | CXTPDockingPanePaintManager |
GetCaptionGripperRect(const CXTPDockingPaneTabbedContainer *pPane) | CXTPDockingPanePaintManager | virtual
GetCaptionHeight() const | CXTPDockingPanePaintManager |
GetCaptionRect(const CXTPDockingPaneTabbedContainer *pPane, CRect &rc) | CXTPDockingPanePaintManager | virtual
GetCurrentSystemTheme() const | CXTPDockingPanePaintManager |
GetCustomTitleBrush(BOOL bActive, BOOL bVertical) const | CXTPDockingPanePaintManager |
GetPaneCaptionRect(const CXTPDockingPaneSidePanel *pPane) | CXTPDockingPanePaintManager | virtual
GetPanelPaintManager() const | CXTPDockingPanePaintManager |
GetSplitterStyle() const | CXTPDockingPanePaintManager |
GetTabPaintManager() const | CXTPDockingPanePaintManager |
GetTabsHeight() const | CXTPDockingPanePaintManager |
GetXtremeColor(UINT nIndex) | CXTPDockingPanePaintManager |
Line(CDC *pDC, int x0, int y0, int x1, int y1, int nPen) | CXTPDockingPanePaintManager |
Line(CDC *pDC, int x0, int y0, int x1, int y1) | CXTPDockingPanePaintManager |
m_arrColor | CXTPDockingPanePaintManager | protected
m_bDestroyCustomTitleBrushes | CXTPDockingPanePaintManager | protected
m_bDrawCaptionIcon | CXTPDockingPanePaintManager |
m_bDrawSingleTab | CXTPDockingPanePaintManager |
m_bGradientCaption | CXTPDockingPaneVisualStudio2003Theme | protected
m_bHighlightActiveCaption | CXTPDockingPanePaintManager |
m_bLunaTheme | CXTPDockingPanePaintManager | protected
m_bShowCaption | CXTPDockingPanePaintManager |
m_bUseBoldCaptionFont | CXTPDockingPanePaintManager |
m_bUseOfficeFont | CXTPDockingPanePaintManager | protected
m_bUseStandardFont | CXTPDockingPanePaintManager | protected
m_clrActiveCaption | CXTPDockingPanePaintManager |
m_clrActiveCaptionText | CXTPDockingPanePaintManager |
m_clrBackground | CXTPDockingPanePaintManager |
m_clrDisabledCaptionText | CXTPDockingPanePaintManager |
m_clrNormalCaption | CXTPDockingPanePaintManager |
m_clrNormalCaptionText | CXTPDockingPanePaintManager |
m_clrSplitter | CXTPDockingPanePaintManager |
m_clrSplitterGradient | CXTPDockingPanePaintManager |
m_clrSplitterGripper | CXTPDockingPanePaintManager |
m_dwSplitterStyle | CXTPDockingPanePaintManager | protected
m_hbrActiveTitleHorz | CXTPDockingPanePaintManager | protected
m_hbrActiveTitleVert | CXTPDockingPanePaintManager | protected
m_hbrInactiveTitleHorz | CXTPDockingPanePaintManager | protected
m_hbrInactiveTitleVert | CXTPDockingPanePaintManager | protected
m_nCaptionButtonStyle | CXTPDockingPanePaintManager | protected
m_nCaptionFontGap | CXTPDockingPanePaintManager | protected
m_nSplitterIndent | CXTPDockingPanePaintManager |
m_nSplitterSize | CXTPDockingPanePaintManager |
m_nTabsHeight | CXTPDockingPanePaintManager | protected
m_nTitleHeight | CXTPDockingPanePaintManager | protected
m_pPanelPaintManager | CXTPDockingPanePaintManager | protected
m_pTabPaintManager | CXTPDockingPanePaintManager | protected
m_rcCaptionMargin | CXTPDockingPanePaintManager | protected
m_strOfficeFont | CXTPDockingPanePaintManager | protected
m_systemTheme | CXTPDockingPanePaintManager | protected
m_themeButton | CXTPDockingPanePaintManager | protected
m_themeCurrent | CXTPDockingPanePaintManager | protected
m_themeExplorer | CXTPDockingPanePaintManager | protected
m_themeRebar | CXTPDockingPanePaintManager | protected
m_themeToolbar | CXTPDockingPanePaintManager | protected
m_themeWindow | CXTPDockingPanePaintManager | protected
m_xtpFontTitle | CXTPDockingPanePaintManager | protected
m_xtpFontTitleVertical | CXTPDockingPanePaintManager | protected
Pixel(CDC *pDC, int xPos, int yPos, int nPen) | CXTPDockingPanePaintManager |
Rectangle(CDC *pDC, CRect rc, int nPenEntry, int nPenBorder) | CXTPDockingPanePaintManager |
RefreshMetrics() | CXTPDockingPaneWinNativeTheme | virtual
SetCaptionButtonStyle(XTPDockingPaneCaptionButtonStyle nStyle) | CXTPDockingPanePaintManager |
SetCaptionFontIndirect(LOGFONT *pLogFont, BOOL bUseStandardFont=FALSE) | CXTPDockingPanePaintManager |
SetColors(int cElements, CONST INT *lpaElements, CONST COLORREF *lpaRgbValues) | CXTPDockingPanePaintManager |
SetCustomTitleBrushes(HBRUSH hbrActiveTitleHorz, HBRUSH hbrInactiveTitleHorz=NULL, HBRUSH hbrActiveTitleVert=NULL, HBRUSH hbrInactiveTitleVert=NULL, BOOL bDestroyOnCleanup=FALSE) | CXTPDockingPanePaintManager |
SetLunaTheme(XTPCurrentSystemTheme systemTheme) | CXTPDockingPanePaintManager |
SetPanelPaintManager(CXTPTabPaintManager *pManager) | CXTPDockingPanePaintManager |
SetSplitterStyle(DWORD dwStyle) | CXTPDockingPanePaintManager |
SetTabPaintManager(CXTPTabPaintManager *pManager) | CXTPDockingPanePaintManager |
UseOfficeFont(BOOL bUseOfficeFont) | CXTPDockingPanePaintManager |
~CXTPDockingPanePaintManager() | CXTPDockingPanePaintManager | protectedvirtual


Toolkit Pro: XTPChartLegend.h Source File

  • Source
  • Chart
XTPChartLegend.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTLEGEND_H__)
24# define __XTPCHARTLEGEND_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartFont;
34class CXTPChartElementView;
35class CXTPChartDeviceContext;
36class CXTPChartLegend;
37class CXTPChartLegendView;
38class CXTPChartDeviceContext;
39class CXTPChartDeviceCommand;
40class CXTPChartBorder;
41class CXTPChartFillStyle;
42class CXTPPropExchange;
43
48enum XTPChartLegendDirection
49{
50 xtpChartLegendTopToBottom,
51 xtpChartLegendLeftToRight,
52};
53
58enum XTPChartLegendAlignment
59{
60 xtpChartLegendNearOutside,
62 xtpChartLegendNear,
63 xtpChartLegendCenter,
64 xtpChartLegendFar,
65 xtpChartLegendFarOutside,
67};
68
73enum XTPChartLegendSortDirection
74{
75 xtpChartLegendNone,
76 xtpChartLegendMinToMax,
77 xtpChartLegendMaxToMin,
78 xtpChartLegendAsc,
79 xtpChartLegendDesc,
80};
81
87class _XTP_EXT_CLASS CXTPChartLegend : public CXTPChartTextElement
88{
90 DECLARE_DYNAMIC(CXTPChartLegend)
92public:
99 CXTPChartLegend(CXTPChartContent* pOwner);
100
105 virtual ~CXTPChartLegend();
106
107public:
115 BOOL IsVisible() const;
116
124 void SetVisible(BOOL bVisible);
125
134 CXTPChartFont* GetFont() const;
135
142 void SetFont(CXTPChartFont* pFont);
143
151 BOOL IsMarkerVisible() const;
152
160 void SetMarkerVisible(BOOL bVisible);
161
169 CSize GetMarkerSize() const;
170
178 void SetMarkerSize(CSize sz);
179
187 void SetTextColor(const CXTPChartColor& clrTextColor);
188
197 CXTPChartColor GetTextColor() const;
198
207 CXTPChartColor GetActualTextColor() const;
208
216 void SetBackgroundColor(const CXTPChartColor& clrBackgroundColor);
217
226 CXTPChartColor GetBackgroundColor() const;
227
236 CXTPChartColor GetActualBackgroundColor() const;
237
246 CXTPChartColor GetActualBorderColor() const;
247
256 void SetAntialiasing(BOOL bAntialiasing);
257
266 BOOL GetAntialiasing() const;
267
276 CXTPChartFillStyle* GetFillStyle() const;
277
286 CXTPChartBorder* GetBorder() const;
287
294 void SetHorizontalAlignment(XTPChartLegendAlignment nAlignment);
295
304 XTPChartLegendAlignment GetHorizontalAlignment() const;
305
312 void SetVerticalAlignment(XTPChartLegendAlignment nAlignment);
313
322 XTPChartLegendAlignment GetVerticalAlignment() const;
323
331 void SetDirection(XTPChartLegendDirection nDirection);
332
342 XTPChartLegendDirection GetDirection() const;
343
344 void SetColumnCount(int nColumnCount);
345 int GetColumnCount() const;
346
347 void SetOffset(CPoint ptOffset);
348 CPoint GetOffset() const;
349
350public:
361 virtual CXTPChartLegendView* CreateView(CXTPChartDeviceContext* pDC,
362 CXTPChartElementView* pParentView);
363
370 void SetSortDirection(XTPChartLegendSortDirection value);
371
379 XTPChartLegendSortDirection GetSortDirection() const;
380
381protected:
393 virtual void DoPropExchange(CXTPPropExchange* pPX);
394
395# ifdef _XTP_ACTIVEX
396public:
398 DECLARE_DISPATCH_MAP()
399 DECLARE_INTERFACE_MAP()
400 DECLARE_OLETYPELIB_EX(CXTPChartLegend);
401
402 afx_msg OLE_COLOR OleGetTextColor();
403 afx_msg void OleSetTextColor(OLE_COLOR clr);
404 afx_msg OLE_COLOR OleGetBackgroundColor();
405 afx_msg void OleSetBackgroundColor(OLE_COLOR clr);
406 afx_msg int OleGetMarkerWidth();
407 afx_msg void OleSetMarkerWidth(int sz);
408 afx_msg int OleGetMarkerHeight();
409 afx_msg void OleSetMarkerHeight(int sz);
410 afx_msg LPDISPATCH OleGetFillStyle();
411 afx_msg LPDISPATCH OleGetBorder();
412 afx_msg int OleGetOffsetX();
413 afx_msg int OleGetOffsetY();
414 afx_msg void OleSetOffsetY(int val);
415 afx_msg void OleSetOffsetX(int val);
416 afx_msg void OleSetSortDirection(XTPChartLegendSortDirection val);
417 afx_msg XTPChartLegendSortDirection OleGetSortDirection();
418 afx_msg LPDISPATCH CXTPChartLegend::OleGetFont();
420# endif
421
422public:
423 BOOL m_bVisible;
424 BOOL m_bAntialiasing;
425 CXTPChartBorder* m_pBorder;
426 CXTPChartFillStyle* m_pFillStyle;
427 CXTPChartFont* m_pFont;
428 CSize m_szMarkerSize;
430 CXTPChartColor m_clrBackgroundColor;
431 CXTPChartColor m_clrTextColor;
432 BOOL m_bMarkerVisible;
434 int m_nColumnCount;
436 XTPChartLegendAlignment m_nHorizontalAlignment;
437 XTPChartLegendAlignment m_nVerticalAlignment;
438 XTPChartLegendDirection m_nDirection;
439 XTPChartLegendSortDirection m_nSortDirection;
441 CPoint m_ptOffset;
442
443 friend class CXTPChartContent;
444};
445
446AFX_INLINE BOOL CXTPChartLegend::IsVisible() const
447{
448 return m_bVisible;
449}
450
451AFX_INLINE void CXTPChartLegend::SetVisible(BOOL bVisible)
452{
453 m_bVisible = bVisible;
454 OnChartChanged();
455}
456
457AFX_INLINE CXTPChartFont* CXTPChartLegend::GetFont() const
458{
459 return m_pFont;
460}
461
462AFX_INLINE CSize CXTPChartLegend::GetMarkerSize() const
463{
464 return m_szMarkerSize;
465}
466
467AFX_INLINE void CXTPChartLegend::SetMarkerSize(CSize sz)
468{
469 m_szMarkerSize = sz;
470 OnChartChanged();
471}
472
473AFX_INLINE BOOL CXTPChartLegend::IsMarkerVisible() const
474{
475 return m_bMarkerVisible;
476}
477
478AFX_INLINE void CXTPChartLegend::SetMarkerVisible(BOOL bVisible)
479{
480 m_bMarkerVisible = bVisible;
481 OnChartChanged();
482}
483
484AFX_INLINE void CXTPChartLegend::SetAntialiasing(BOOL bAntialiasing)
485{
486 m_bAntialiasing = bAntialiasing;
487 OnChartChanged();
488}
489
490AFX_INLINE BOOL CXTPChartLegend::GetAntialiasing() const
491{
492 return m_bAntialiasing;
493}
494
495AFX_INLINE CXTPChartFillStyle* CXTPChartLegend::GetFillStyle() const
496{
497 return m_pFillStyle;
498}
499
500AFX_INLINE CXTPChartBorder* CXTPChartLegend::GetBorder() const
501{
502 return m_pBorder;
503}
504
505AFX_INLINE void CXTPChartLegend::SetHorizontalAlignment(XTPChartLegendAlignment nAlignment)
506{
507 m_nHorizontalAlignment = nAlignment;
508 OnChartChanged();
509}
510
511AFX_INLINE XTPChartLegendAlignment CXTPChartLegend::GetHorizontalAlignment() const
512{
513 return m_nHorizontalAlignment;
514}
515
516AFX_INLINE void CXTPChartLegend::SetVerticalAlignment(XTPChartLegendAlignment nAlignment)
517{
518 m_nVerticalAlignment = nAlignment;
519 OnChartChanged();
520}
521
522AFX_INLINE XTPChartLegendAlignment CXTPChartLegend::GetVerticalAlignment() const
523{
524 return m_nVerticalAlignment;
525}
526
527AFX_INLINE void CXTPChartLegend::SetDirection(XTPChartLegendDirection nDirection)
528{
529 m_nDirection = nDirection;
530 OnChartChanged();
531}
532
533AFX_INLINE XTPChartLegendDirection CXTPChartLegend::GetDirection() const
534{
535 return m_nDirection;
536}
537
538AFX_INLINE void CXTPChartLegend::SetColumnCount(int nColumnCount)
539{
540 m_nColumnCount = nColumnCount;
541 OnChartChanged();
542}
543
544AFX_INLINE int CXTPChartLegend::GetColumnCount() const
545{
546 return m_nColumnCount;
547}
548
549AFX_INLINE void CXTPChartLegend::SetOffset(CPoint ptOffset)
550{
551 m_ptOffset = ptOffset;
552 OnChartChanged();
553}
554
555AFX_INLINE CPoint CXTPChartLegend::GetOffset() const
556{
557 return m_ptOffset;
558}
559
560AFX_INLINE void CXTPChartLegend::SetSortDirection(XTPChartLegendSortDirection value)
561{
562 m_nSortDirection = value;
563 OnChartChanged();
564}
565
566AFX_INLINE XTPChartLegendSortDirection CXTPChartLegend::GetSortDirection() const
567{
568 return m_nSortDirection;
569}
571# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
572#endif //#if !defined(__XTPCHARTLEGEND_H__)
XTPChartLegendDirection
XTPChartLegendDirection
Enumerates the legend orientation.
Definition XTPChartLegend.h:49
xtpChartLegendTopToBottom
@ xtpChartLegendTopToBottom
The legend items are arranged from top to bottom.
Definition XTPChartLegend.h:50
xtpChartLegendLeftToRight
@ xtpChartLegendLeftToRight
The legend items are arranged from left to right.
Definition XTPChartLegend.h:51
XTPChartLegendSortDirection
XTPChartLegendSortDirection
Sort the legend strings.
Definition XTPChartLegend.h:74
xtpChartLegendMinToMax
@ xtpChartLegendMinToMax
The legend items are sorting minimum first.
Definition XTPChartLegend.h:76
xtpChartLegendMaxToMin
@ xtpChartLegendMaxToMin
The legend items are sorting maximum first.
Definition XTPChartLegend.h:77
xtpChartLegendDesc
@ xtpChartLegendDesc
The legend items are sorting descending.
Definition XTPChartLegend.h:79
xtpChartLegendNone
@ xtpChartLegendNone
The legend items no sorting.
Definition XTPChartLegend.h:75
xtpChartLegendAsc
@ xtpChartLegendAsc
The legend items are sorting ascending.
Definition XTPChartLegend.h:78
XTPChartLegendAlignment
XTPChartLegendAlignment
Enumerates the legend alignment.
Definition XTPChartLegend.h:59
xtpChartLegendNearOutside
@ xtpChartLegendNearOutside
The legend is placed out side of the chart, near the primary Y axis.
Definition XTPChartLegend.h:60
xtpChartLegendFarOutside
@ xtpChartLegendFarOutside
The legend is placed outside of the chart, near the secondary Y axis.
Definition XTPChartLegend.h:65
xtpChartLegendFar
@ xtpChartLegendFar
The legend is placed inside of the chart, near the secondary Y axis.
Definition XTPChartLegend.h:64
xtpChartLegendCenter
@ xtpChartLegendCenter
The legend is placed at the center of the chart.
Definition XTPChartLegend.h:63
xtpChartLegendNear
@ xtpChartLegendNear
The legend is placed inside of the chart, near the primary Y axis.
Definition XTPChartLegend.h:62
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartBorder
This class abstracts the border of a chart, it is a kind of chart element.
Definition XTPChartBorder.h:42
CXTPChartColor
This class abstracts a color entity.
Definition XTPChartTypes.h:51
CXTPChartContent
This class represents chart content, which is a kind of CXTPChartElement.
Definition XTPChartContent.h:66
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartElement::OnChartChanged
virtual void OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic propertie...
CXTPChartElementView
This class represents the view of a chart element.
Definition XTPChartElementView.h:47
CXTPChartFillStyle
This class abstracts a fill style used to fill the background of various chart elements.
Definition XTPChartFillStyle.h:43
CXTPChartFont
This class abstracts a font entity.
Definition XTPChartTypes.h:540
CXTPChartLegend
This class represents a chart legend as a kind of chart element.
Definition XTPChartLegend.h:88
CXTPChartLegend::m_pFont
CXTPChartFont * m_pFont
Pointer to font object.
Definition XTPChartLegend.h:427
CXTPChartLegend::DoPropExchange
virtual void DoPropExchange(CXTPPropExchange *pPX)
Call this member function to Store/Load the properties of a legend object using the specified data ob...
CXTPChartLegend::CreateView
virtual CXTPChartLegendView * CreateView(CXTPChartDeviceContext *pDC, CXTPChartElementView *pParentView)
This function creates the view (CXTPChartLegendView) of the legend.
CXTPChartLegend::SetMarkerVisible
void SetMarkerVisible(BOOL bVisible)
Call this function to set the marker visible/invisible.
Definition XTPChartLegend.h:478
CXTPChartLegend::SetVerticalAlignment
void SetVerticalAlignment(XTPChartLegendAlignment nAlignment)
Call this function to set the legend's vertical alignment.
Definition XTPChartLegend.h:516
CXTPChartLegend::CXTPChartLegend
CXTPChartLegend(CXTPChartContent *pOwner)
Constructs a CXTPChartLegend object.
CXTPChartLegend::GetActualTextColor
CXTPChartColor GetActualTextColor() const
Call this function to get the actual text color.
CXTPChartLegend::GetDirection
XTPChartLegendDirection GetDirection() const
Call this function to get the legend's direction.
Definition XTPChartLegend.h:533
CXTPChartLegend::GetTextColor
CXTPChartColor GetTextColor() const
Call this function to get the current text color.
CXTPChartLegend::SetVisible
void SetVisible(BOOL bVisible)
Call this function to set the legend visible/invisible.
Definition XTPChartLegend.h:451
CXTPChartLegend::m_clrBackgroundColor
CXTPChartColor m_clrBackgroundColor
Chart background color.
Definition XTPChartLegend.h:430
CXTPChartLegend::SetMarkerSize
void SetMarkerSize(CSize sz)
Call this function to set the marker size.
Definition XTPChartLegend.h:467
CXTPChartLegend::GetHorizontalAlignment
XTPChartLegendAlignment GetHorizontalAlignment() const
Call this function to get the legend's horizontal alignment.
Definition XTPChartLegend.h:511
CXTPChartLegend::SetSortDirection
void SetSortDirection(XTPChartLegendSortDirection value)
This function sets sort direction of legend.
Definition XTPChartLegend.h:560
CXTPChartLegend::GetFont
CXTPChartFont * GetFont() const
This function returns the CXTPChartFont object pointer associated with the CXTPChartLegend object.
Definition XTPChartLegend.h:457
CXTPChartLegend::GetVerticalAlignment
XTPChartLegendAlignment GetVerticalAlignment() const
Call this function to get the legend's vertical alignment.
Definition XTPChartLegend.h:522
CXTPChartLegend::GetFillStyle
CXTPChartFillStyle * GetFillStyle() const
Call this function to get the fill style.
Definition XTPChartLegend.h:495
CXTPChartLegend::GetSortDirection
XTPChartLegendSortDirection GetSortDirection() const
This function return sort direction of legend.
Definition XTPChartLegend.h:566
CXTPChartLegend::SetTextColor
void SetTextColor(const CXTPChartColor &clrTextColor)
Call this function to set the text color of the legend.
CXTPChartLegend::GetMarkerSize
CSize GetMarkerSize() const
Call this function to get the marker size (width and height).
Definition XTPChartLegend.h:462
CXTPChartLegend::SetFont
void SetFont(CXTPChartFont *pFont)
Call this function, to set the font for the legend.
CXTPChartLegend::m_nSortDirection
XTPChartLegendSortDirection m_nSortDirection
Legend sorting direction.
Definition XTPChartLegend.h:439
CXTPChartLegend::IsMarkerVisible
BOOL IsMarkerVisible() const
This function returns whether the marker is visible.
Definition XTPChartLegend.h:473
CXTPChartLegend::IsVisible
BOOL IsVisible() const
Call this function to see whether the legend is visible.
Definition XTPChartLegend.h:446
CXTPChartLegend::m_pBorder
CXTPChartBorder * m_pBorder
Pointer to chart border object.
Definition XTPChartLegend.h:425
CXTPChartLegend::m_nColumnCount
int m_nColumnCount
Column Count.
Definition XTPChartLegend.h:434
CXTPChartLegend::SetAntialiasing
void SetAntialiasing(BOOL bAntialiasing)
Call this function to set anti-aliasing ON or OFF.
Definition XTPChartLegend.h:484
CXTPChartLegend::GetActualBackgroundColor
CXTPChartColor GetActualBackgroundColor() const
Call this function to get the actual background color of the legend.
CXTPChartLegend::m_nHorizontalAlignment
XTPChartLegendAlignment m_nHorizontalAlignment
Legend horizontal alignment.
Definition XTPChartLegend.h:436
CXTPChartLegend::m_nVerticalAlignment
XTPChartLegendAlignment m_nVerticalAlignment
Legend vertical alignment.
Definition XTPChartLegend.h:437
CXTPChartLegend::GetBorder
CXTPChartBorder * GetBorder() const
Call this function to get the legend border.
Definition XTPChartLegend.h:500
CXTPChartLegend::m_bVisible
BOOL m_bVisible
TRUE if the legend is visible.
Definition XTPChartLegend.h:423
CXTPChartLegend::~CXTPChartLegend
virtual ~CXTPChartLegend()
Destroys a CXTPChartLegend object, handles cleanup.
CXTPChartLegend::SetDirection
void SetDirection(XTPChartLegendDirection nDirection)
Call this function to set the legend's direction.
Definition XTPChartLegend.h:527
CXTPChartLegend::m_szMarkerSize
CSize m_szMarkerSize
Size of the marker.
Definition XTPChartLegend.h:428
CXTPChartLegend::m_pFillStyle
CXTPChartFillStyle * m_pFillStyle
Pointer to chart fill style object.
Definition XTPChartLegend.h:426
CXTPChartLegend::m_bMarkerVisible
BOOL m_bMarkerVisible
TRUE if marker is visible.
Definition XTPChartLegend.h:432
CXTPChartLegend::SetHorizontalAlignment
void SetHorizontalAlignment(XTPChartLegendAlignment nAlignment)
Call this function to set the legend's horizontal alignment.
Definition XTPChartLegend.h:505
CXTPChartLegend::SetBackgroundColor
void SetBackgroundColor(const CXTPChartColor &clrBackgroundColor)
Call this function to set the background color of the legend.
CXTPChartLegend::m_clrTextColor
CXTPChartColor m_clrTextColor
Chart text color.
Definition XTPChartLegend.h:431
CXTPChartLegend::GetBackgroundColor
CXTPChartColor GetBackgroundColor() const
Call this function to get the current background color.
CXTPChartLegend::m_bAntialiasing
BOOL m_bAntialiasing
TRUE if antialiasing is turned ON.
Definition XTPChartLegend.h:424
CXTPChartLegend::GetActualBorderColor
CXTPChartColor GetActualBorderColor() const
Call this function to get the actual border color of the legend.
CXTPChartLegend::GetAntialiasing
BOOL GetAntialiasing() const
Call this function to check if anti-aliasing is ON or OFF.
Definition XTPChartLegend.h:490
CXTPChartLegend::m_nDirection
XTPChartLegendDirection m_nDirection
Legend orientation.
Definition XTPChartLegend.h:438
CXTPChartLegendView
This class abstracts the view of a legend and its child items in a bounding rectangle context.
Definition XTPChartLegendView.h:49
CXTPChartTextElement
This class abstracts a chart text element.
Definition XTPChartElement.h:323
CXTPChartTextElement::GetFont
virtual CXTPChartFont * GetFont() const =0
Call this function to get the font of the text element.
CXTPChartTextElement::GetAntialiasing
virtual BOOL GetAntialiasing() const =0
Call this function to check if anti-aliasing is ON or OFF.
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72


Toolkit Pro: Member List

CXTPZipMemFile Member List

This is the complete list of members for CXTPZipMemFile, including all inherited members.


Toolkit Pro: XTPNewToolbarDlg.h Source File

  • Source
  • Controls
  • Dialog
XTPNewToolbarDlg.h
Go to the documentation of this file.
1
23#if !defined(__XTPNEWTOOLBARDLG_H__)
24# define __XTPNEWTOOLBARDLG_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPCommandBar;
34
35# ifdef _XTP_INCLUDE_COMMANDBARS
36
41class _XTP_EXT_CLASS CXTPNewToolbarDlg : public CXTPDialogEx
42{
43public:
51 CXTPNewToolbarDlg(CWnd* pParent, CXTPCommandBars* pCommandBars,
52 CXTPCommandBar* pCommandBar = NULL);
53
64 void SetTheme(XTPControlTheme theme);
65
66private:
67 void SetSuggestedName();
68
69 CXTPCommandBar* m_pCommandBar;
70 CXTPCommandBars* m_pCommandBars;
71 CXTPButton m_btnOk;
72 CXTPButton m_btnCancel;
73 CXTPEdit m_edit;
74 COLORREF m_clrText;
75 XTPControlTheme m_theme;
76 CXTPBrush m_brBack;
77
78protected:
80 DECLARE_MESSAGE_MAP()
81
82 //{{AFX_VIRTUAL(CXTPNewToolbarDlg)
83 virtual void DoDataExchange(CDataExchange* pDX);
84 virtual BOOL OnInitDialog();
85 void OnOK();
86 //}}AFX_VIRTUAL
87
88 //{{AFX_MSG(CXTPNewToolbarDlg)
89 afx_msg BOOL OnEraseBkgnd(CDC* pDC);
90 afx_msg HBRUSH OnCtlColor(CDC* pDC, CWnd* pWnd, UINT nCtlColor);
91 //}}AFX_MSG
94public:
95 enum
96 {
97 IDD = XTP_IDD_NEWTOOLBAR
98 };
99 UINT m_nNewID;
100 CString m_strToolbar;
101};
102
103# endif
104
105# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
107#endif // !defined(__XTPNEWTOOLBARDLG_H__)
XTPControlTheme
XTPControlTheme
Enumeration used to determine the active theme style.
Definition XTPControlTheme.h:43
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPBrush
Provides a convenient object oriented interface for HBRUSH GDI object and uses GDI handle caching.
Definition XTPGdiObjects.h:653
CXTPButton
Push Button control.
Definition XTPButton.h:109
CXTPCommandBar
CXTPCommandBar is a CWnd derived class.
Definition XTPCommandBar.h:66
CXTPCommandBars
CXTPCommandBars is a standalone class.
Definition XTPCommandBars.h:165
CXTPDialogEx
CXTPDialogEx is a CXTPDialogBase derived class.
Definition Controls/Dialog/XTPDialogBase.h:358
CXTPEdit
CXTPEdit is a CEdit derived class.
Definition XTPEdit.h:129


Toolkit Pro: Member List

CXTPTaskPanelItem Member List

This is the complete list of members for CXTPTaskPanelItem, including all inherited members.

AllowDrag(long nAllowDrag=xtpTaskItemAllowDragDefault) | CXTPTaskPanelItem |
AllowDrop(BOOL bAllowDrop) | CXTPTaskPanelItem |
CacheGlobalData() | CXTPTaskPanelItem |
CopyToClipboard() | CXTPTaskPanelItem |
CreateFromOleData(COleDataObject *pDataObject) | CXTPTaskPanelItem | static
CreateFromOleFile(CFile *pDataObject) | CXTPTaskPanelItem | static
CXTPCmdTarget() | CXTPCmdTarget |
CXTPTaskPanelItem() | CXTPTaskPanelItem | protected
DoPropExchange(CXTPPropExchange *pPX) | CXTPTaskPanelItem | virtual
DrawCaptionText(CDC *pDC, CRect rc, UINT nFormat) | CXTPTaskPanelItem | virtual
EnsureVisible() | CXTPTaskPanelItem |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCaption() const | CXTPTaskPanelItem |
GetCaptionTextSize(CDC *pDC, CRect rc, UINT nFormat) | CXTPTaskPanelItem | virtual
GetEnabled() const | CXTPTaskPanelItem |
GetHitTestRect() const | CXTPTaskPanelItem | virtual
GetIconIndex() const | CXTPTaskPanelItem |
GetIconPadding() | CXTPTaskPanelItem |
GetID() const | CXTPTaskPanelItem |
GetImage(int nWidth) const | CXTPTaskPanelItem |
GetIndex() const | CXTPTaskPanelItem |
GetInvalidateRect() const | CXTPTaskPanelItem | virtual
GetItemData() const | CXTPTaskPanelItem |
GetItemFont() const | CXTPTaskPanelItem |
GetItemGroup() const | CXTPTaskPanelItem | virtual
GetMarkupUIElement() const | CXTPTaskPanelItem |
GetPaintManager() const | CXTPTaskPanelItem |
GetParentItems() const | CXTPTaskPanelItem |
GetTaskPanel() const | CXTPTaskPanelItem |
GetTextRect(UINT *pFormat=0) const | CXTPTaskPanelItem |
GetTooltip() const | CXTPTaskPanelItem |
GetType() const | CXTPTaskPanelItem |
IsAcceptFocus() const | CXTPTaskPanelItem | virtual
IsAllowDrag() const | CXTPTaskPanelItem |
IsAllowDrop() const | CXTPTaskPanelItem |
IsDroppedOff() const | CXTPTaskPanelItem |
IsGroup() const | CXTPTaskPanelItem |
IsItemDragging() const | CXTPTaskPanelItem |
IsItemDragOver() const | CXTPTaskPanelItem |
IsItemFocused() const | CXTPTaskPanelItem |
IsItemHot() const | CXTPTaskPanelItem |
IsItemPressed() const | CXTPTaskPanelItem |
IsVisible() const | CXTPTaskPanelItem |
m_bAllowDrop | CXTPTaskPanelItem | protected
m_bEnabled | CXTPTaskPanelItem | protected
m_bVisible | CXTPTaskPanelItem | protected
m_dwData | CXTPTaskPanelItem | protected
m_nAllowDrag | CXTPTaskPanelItem | protected
m_nIconIndex | CXTPTaskPanelItem | protected
m_nID | CXTPTaskPanelItem | protected
m_nTextFormat | CXTPTaskPanelItem | protected
m_pItems | CXTPTaskPanelItem | protected
m_pMarkupUIElement | CXTPTaskPanelItem | protected
m_pPanel | CXTPTaskPanelItem | protected
m_rcIconPadding | CXTPTaskPanelItem | protected
m_rcText | CXTPTaskPanelItem | protected
m_strCaption | CXTPTaskPanelItem | protected
m_strTooltip | CXTPTaskPanelItem | protected
m_typeItem | CXTPTaskPanelItem | protected
m_xtpFontItem | CXTPTaskPanelItem | protected
OnInserted() | CXTPTaskPanelItem | protectedvirtual
OnRemoved() | CXTPTaskPanelItem | protectedvirtual
PasteFromClipboard() | CXTPTaskPanelItem | static
RedrawPanel(BOOL bAnimate=FALSE) const | CXTPTaskPanelItem |
Remove() | CXTPTaskPanelItem |
RepositionPanel() const | CXTPTaskPanelItem |
SetCaption(LPCTSTR lpszCaption) | CXTPTaskPanelItem |
SetEnabled(BOOL bEnabled) | CXTPTaskPanelItem |
SetIconIndex(int nIndex) | CXTPTaskPanelItem |
SetID(UINT nID) | CXTPTaskPanelItem |
SetID(UINT nID, LPCTSTR lpCaption, LPCTSTR lpTooltip=NULL) | CXTPTaskPanelItem |
SetItemData(DWORD_PTR dwData) | CXTPTaskPanelItem |
SetItemFont(LOGFONT *pLogFont) | CXTPTaskPanelItem |
SetTextRect(CDC *pDC, CRect rc, UINT nFormat) | CXTPTaskPanelItem |
SetTooltip(LPCTSTR lpszTooltip) | CXTPTaskPanelItem |
SetType(XTPTaskPanelItemType typeItem) | CXTPTaskPanelItem |
SetVisible(BOOL bVisible) | CXTPTaskPanelItem |
~CXTPTaskPanelItem() | CXTPTaskPanelItem | virtual


Toolkit Pro: XTPTrackThemeDefault.h Source File

  • Source
  • GridControl
  • TrackControl
  • Themes
XTPTrackThemeDefault.h
Go to the documentation of this file.
1
23#if !defined(__XTPTRACKTHEMEDEFAULT_H__)
24# define __XTPTRACKTHEMEDEFAULT_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPTrackThemeDefault : public CXTPTrackPaintManager
39{
40public:
45 CXTPTrackThemeDefault();
46
58 virtual void DrawColumnBackground(CDC* pDC, CXTPGridColumn* pColumn, CRect rcColumn,
59 BOOL& bColumnPressed, BOOL& bDraggingFromHeader,
60 CXTPGridHeader* pHeader = NULL);
61};
63# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
64#endif //#if !defined(__XTPTRACKTHEMEDEFAULT_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPGridColumn
Represents a grid column item with its properties and operations.
Definition XTPGridColumn.h:107
CXTPGridHeader
A grid header is a part of the grid window positioned above columns of text or numbers.
Definition XTPGridHeader.h:173
CXTPTrackPaintManager
This class represents a track control paint manager.
Definition XTPTrackPaintManager.h:41
CXTPTrackThemeDefault
CXTPTrackThemeDefault is a CXTPTrackPaintManager derived class that represents an Office 97 style the...
Definition XTPTrackThemeDefault.h:39
CXTPTrackThemeDefault::DrawColumnBackground
virtual void DrawColumnBackground(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, BOOL &bColumnPressed, BOOL &bDraggingFromHeader, CXTPGridHeader *pHeader=NULL)
This method is called to draw the background of a column using the current column style.
CXTPTrackThemeDefault::CXTPTrackThemeDefault
CXTPTrackThemeDefault()
Default paint manager constructor, handles properties initialization.


Toolkit Pro: XTPStatusBarThemeNativeWindows10.h Source File

  • Source
  • CommandBars
  • StatusBar
XTPStatusBarThemeNativeWindows10.h
Go to the documentation of this file.
1
23#if !defined(__XTPXTPSTATUSBARTHEMENATIVEWINDOWS10_H__)
24# define __XTPXTPSTATUSBARTHEMENATIVEWINDOWS10_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPStatusBarThemeNativeWindows10 : public CXTPStatusBarThemeOffice2013
39{
40public:
46 CXTPStatusBarThemeNativeWindows10(CXTPPaintManager* pPaintManager);
47
54 virtual void DrawStatusBarGripper(CDC* pDC, CRect rcClient);
55
61 virtual void RefreshMetrics();
62
70 virtual void SetStateColor(COLORREF clrState);
71
78 virtual COLORREF GetStateColor() const;
79};
80
82# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
83#endif // !defined(__XTPXTPSTATUSBARTHEMENATIVEWINDOWS10_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPPaintManager
Paint manager of the command bars.
Definition XTPPaintManager.h:199
CXTPStatusBarThemeNativeWindows10
The CXTPStatusBarThemeNativeWindows10 class is used to enable the Native Windows 10 style theme for t...
Definition XTPStatusBarThemeNativeWindows10.h:39
CXTPStatusBarThemeNativeWindows10::CXTPStatusBarThemeNativeWindows10
CXTPStatusBarThemeNativeWindows10(CXTPPaintManager *pPaintManager)
Constructs a CXTPStatusBarThemeNativeWindows10 object.
CXTPStatusBarThemeNativeWindows10::DrawStatusBarGripper
virtual void DrawStatusBarGripper(CDC *pDC, CRect rcClient)
This method is called to draw the status bar's gripper.
CXTPStatusBarThemeNativeWindows10::SetStateColor
virtual void SetStateColor(COLORREF clrState)
Call this member function to set the application state color for the status bar.
CXTPStatusBarThemeNativeWindows10::RefreshMetrics
virtual void RefreshMetrics()
This method is called to refresh colors and other theme specific metrics for the paint manager.
CXTPStatusBarThemeNativeWindows10::GetStateColor
virtual COLORREF GetStateColor() const
Call this member function to get the application state color for the status bar.
CXTPStatusBarThemeOffice2013
The CXTPStatusBarThemeVisualStudio2015 class is used to enable the Office 2013 style theme for the st...
Definition XTPStatusBarThemeOffice2013.h:39


Toolkit Pro: Member List

CXTPMemFile Member List

This is the complete list of members for CXTPMemFile, including all inherited members.

Append(CFile *fApp) | CXTPMemFile | protectedvirtual
Close() | CXTPMemFile | virtual
CXTPMemFile(UINT nGrowBytes=1024) | CXTPMemFile |
CXTPMemFile(BYTE *lpBuffer, UINT nBufferSize, UINT nGrowBytes=0) | CXTPMemFile |
CXTPMemFile(LPCTSTR lpszFileName, UINT uiOpenFlags) | CXTPMemFile |
Discard() | CXTPMemFile | virtual
Duplicate(CFile *fDuplicate) | CXTPMemFile | virtual
Duplicate(LPCTSTR strDup) | CXTPMemFile | virtual
Extract(CFile *fDest, DWORD dwStartPos, DWORD dwBytes) | CXTPMemFile | virtual
Extract(LPCTSTR strDest, DWORD dwStartPos, DWORD dwBytes) | CXTPMemFile | virtual
FindData(void *pData, DWORD dwDataLen, LONG lStartPos) | CXTPMemFile |
Flush() | CXTPMemFile | virtual
Import(CFile *fImp) | CXTPMemFile | protectedvirtual
Insert(CFile *fSrc, DWORD dwSourcePos, DWORD dwDestPos, DWORD dwBytes) | CXTPMemFile | virtual
Insert(LPCTSTR strSrc, DWORD dwSourcePos, DWORD dwDestPos, DWORD dwBytes) | CXTPMemFile | virtual
Load() | CXTPMemFile | protectedvirtual
Open(LPCTSTR lpszFileName, UINT nOpenFlags, CFileException *pError=NULL) | CXTPMemFile | virtual
operator+=(CFile *fApp) | CXTPMemFile |
operator+=(CString strApp) | CXTPMemFile |
operator=(CFile *fDup) | CXTPMemFile |
operator=(CString strDup) | CXTPMemFile |
operator=(DWORD dwFilePos) | CXTPMemFile |
operator[](DWORD dwFilePos) | CXTPMemFile |
ReadString(CString &rString) | CXTPMemFile | virtual
Save() | CXTPMemFile | protectedvirtual
WriteString(LPCTSTR lpsz) | CXTPMemFile | virtual
~CXTPMemFile() | CXTPMemFile | virtual


Toolkit Pro: Member List

CAppearanceSetPropertyPageFlat Member List

This is the complete list of members for CAppearanceSetPropertyPageFlat, including all inherited members.

AdjustClientRect(CXTPTabManager *pTabManager, CRect &rcClient) | CXTPTabPaintManagerTheme | virtual
CAppearanceSetPropertyPageFlat() | CAppearanceSetPropertyPageFlat | inline
CXTPTabPaintManagerTheme() | CXTPTabPaintManagerTheme |
CXTPTabThemeFlat() | CXTPTabThemeFlat | inline
DrawSingleButton(CDC *pDC, CXTPTabManagerItem *pItem) | CAppearanceSetPropertyPageFlat | virtual
DrawTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl) | CXTPTabPaintManagerTheme | virtual
DrawText(CDC *pDC, CXTPTabManager *pManager, const CString &str, LPRECT lpRect, UINT nFormat) | CXTPTabPaintManagerTheme | virtual
DrawWorkspacePart(CDC *pDC, LPRECT lpRect, XTPTabWorkspacePart workspacePart) | CXTPTabPaintManagerTheme | virtual
FillButton(CDC *pDC, CXTPTabManagerItem *pItem, LPPOINT pts, int nCount, XTPTabPosition tabPosition, BOOL bAbsolute=FALSE) | CXTPTabPaintManagerTheme |
FillTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl) | CXTPTabThemeFlat | virtual
GetButtonDrawRect(const CXTPTabManagerItem *pItem) | CXTPTabPaintManagerTheme | virtual
GetButtonHeight(const CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetButtonLength(CDC *pDC, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerTheme | virtual
GetClientMargin() | CXTPTabPaintManagerTheme | virtual
GetClientRect(CRect rcControl, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetColorSet() const | CXTPTabPaintManagerTheme |
GetDefaultColorSet() | CAppearanceSetPropertyPageFlat | inlinevirtual
GetHeaderClipBox(CDC *pDC, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetHeaderHeight(CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme |
GetHeaderMargin() | CXTPTabPaintManagerTheme | virtual
GetHeaderRect(CRect rcControl, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetSupportedColorSets() | CXTPTabPaintManagerTheme | inlinevirtual
m_bBlurPoints | CAppearanceSetPropertyPageFlat |
m_bButtonsReverseZOrder | CXTPTabPaintManagerTheme | protected
m_bVisualStudio2005Style | CAppearanceSetPropertyPageFlat |
m_nButtonHeight | CXTPTabPaintManagerTheme | protected
m_nRowMargin | CXTPTabPaintManagerTheme |
m_pPaintManager | CXTPTabPaintManagerTheme | protected
m_rcHeaderMargin | CXTPTabPaintManagerTheme |
RefreshMetrics() | CXTPTabPaintManagerTheme | virtual
RepositionTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcClient) | CXTPTabPaintManagerTheme | virtual
~CXTPTabPaintManagerTheme() | CXTPTabPaintManagerTheme | virtual


Toolkit Pro: Member List

CXTPHeaderCtrlThemeResource Member List

This is the complete list of members for CXTPHeaderCtrlThemeResource, including all inherited members.

CleanUp(CXTPHeaderCtrl *pHeaderCtrl) | CXTPHeaderCtrlTheme | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPControlTheme() | CXTPControlTheme |
CXTPHeaderCtrlTheme() | CXTPHeaderCtrlTheme |
CXTPHeaderCtrlThemeOfficeXP() | CXTPHeaderCtrlThemeOfficeXP |
CXTPHeaderCtrlThemeResource() | CXTPHeaderCtrlThemeResource |
DrawHeader(CDC *pDC, CXTPHeaderCtrl *pHeaderCtrl) | CXTPHeaderCtrlTheme | virtual
DrawSortArrow(CDC *pDC, LPPOINT ptsArrow, BOOL bAscending) | CXTPHeaderCtrlThemeResource | protectedvirtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetDrawStyle() const | CXTPHeaderCtrlTheme | virtual
GetThemeStyle() const | CXTPControlTheme |
GetThemeWrapper() | CXTPHeaderCtrlTheme |
HasSortArrow() | CXTPHeaderCtrlTheme |
Layout(LPHDLAYOUT lpHDL, CXTPHeaderCtrl *pHeaderCtrl) | CXTPHeaderCtrlTheme | virtual
m_bUseWinThemes | CXTPHeaderCtrlTheme | protected
m_cr3DDkShadow | CXTPHeaderCtrlTheme | protected
m_cr3DFace | CXTPHeaderCtrlTheme | protected
m_cr3DHighLight | CXTPHeaderCtrlTheme | protected
m_cr3DShadow | CXTPHeaderCtrlTheme | protected
m_crgBack | CXTPHeaderCtrlThemeResource | protected
m_crgBackPressed | CXTPHeaderCtrlThemeResource | protected
m_crText | CXTPHeaderCtrlTheme | protected
m_dwDrawStyle | CXTPHeaderCtrlTheme | protected
m_iArrowPadding | CXTPHeaderCtrlTheme | protected
m_nTheme | CXTPControlTheme | protected
m_sizeArrow | CXTPHeaderCtrlTheme | protected
m_sizePadding | CXTPHeaderCtrlTheme | protected
m_themeHeader | CXTPHeaderCtrlTheme | protected
OnDrawBackground(LPDRAWITEMSTRUCT lpDIS) | CXTPHeaderCtrlThemeResource | protectedvirtual
OnDrawBackgroundWinThemed(LPDRAWITEMSTRUCT lpDIS) | CXTPHeaderCtrlTheme | protectedvirtual
OnDrawItemBackground(LPDRAWITEMSTRUCT lpDIS) | CXTPHeaderCtrlThemeResource | protectedvirtual
OnDrawItemBackgroundWinThemed(LPDRAWITEMSTRUCT lpDIS) | CXTPHeaderCtrlTheme | protectedvirtual
OnDrawItemBitmap(LPDRAWITEMSTRUCT lpDIS, CRect &rcText, CXTPHeaderCtrl *pHeaderCtrl) | CXTPHeaderCtrlTheme | protectedvirtual
OnDrawItemSortArrow(LPDRAWITEMSTRUCT lpDIS, BOOL bAscending) | CXTPHeaderCtrlThemeResource | protectedvirtual
OnDrawItemText(LPDRAWITEMSTRUCT lpDIS, CXTPHeaderCtrl *pHeaderCtrl) | CXTPHeaderCtrlThemeResource | protectedvirtual
RefreshMetrics(CXTPHeaderCtrl *pHeader) | CXTPHeaderCtrlThemeResource | virtual
SetBitmap(int iCol, UINT uBitmapID, BOOL bRemove, COLORREF crMask, CXTPHeaderCtrl *pHeaderCtrl) | CXTPHeaderCtrlTheme | virtual
SetDrawStyle(DWORD dwDrawStyle, CXTPHeaderCtrl *pHeaderCtrl) | CXTPHeaderCtrlTheme | virtual
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static
UseWinXPThemes(CXTPHeaderCtrl *pHeaderCtrl) | CXTPHeaderCtrlTheme | virtual
~CXTPHeaderCtrlTheme() | CXTPHeaderCtrlTheme | virtual
~CXTPHeaderCtrlThemeOfficeXP() | CXTPHeaderCtrlThemeOfficeXP | virtual


Toolkit Pro: XTPPropertyGridItemExt.h Source File

  • Source
  • PropertyGrid
XTPPropertyGridItemExt.h
Go to the documentation of this file.
1
23#if !defined(__XTPPROPERTYGRIDITEMEXT_H__)
24# define __XTPPROPERTYGRIDITEMEXT_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPPropertyGridItemDate;
34
39class _XTP_EXT_CLASS CXTPPropertyGridInplaceMonthCal : public CWnd
40{
41public:
47 CXTPPropertyGridInplaceMonthCal(CXTPPropertyGridItemDate* pItem)
48 {
49 m_pItem = pItem;
50 }
51
64 BOOL GetMinReqRect(RECT* pRect) const;
65
66protected:
75 void OnAccept();
76
85 void OnCancel();
86
88 virtual void PostNcDestroy();
89 virtual BOOL OnWndMsg(UINT message, WPARAM wParam, LPARAM lParam, LRESULT* pResult);
90 afx_msg void OnSelect(NMHDR* pNMHDR, LRESULT* pResult);
91
92 DECLARE_MESSAGE_MAP()
95protected:
96 CXTPPropertyGridItemDate* m_pItem;
97};
98
137class _XTP_EXT_CLASS CXTPPropertyGridItemDate : public CXTPPropertyGridItem
138{
139public:
149 CXTPPropertyGridItemDate(LPCTSTR strCaption, const COleDateTime& oleDate,
150 COleDateTime* pBindDate = NULL);
151
161 CXTPPropertyGridItemDate(UINT nID, const COleDateTime& oleDate, COleDateTime* pBindDate = NULL);
162
163public:
200 virtual void SetDate(const COleDateTime& oleDate);
201
238 virtual BOOL GetAsSystemTime(SYSTEMTIME& sysTime);
239
246 virtual const COleDateTime& GetDate() const;
247
254 virtual long GetDay();
255
261 virtual void SetDay(long nDay);
262
269 virtual long GetMonth();
270
276 virtual void SetMonth(long nMonth);
277
284 virtual long GetYear();
285
291 virtual void SetYear(long nYear);
292
307 virtual BOOL ParseDateTime(COleDateTime& dt, LPCTSTR strValue);
308
336 virtual void SetDateFormat(LPCTSTR strFormat);
337
343 void AllowNullDate(LPCTSTR lpszNullValue);
344
351 CString GetAllowNullDateString() const;
352
376 void BindToDate(COleDateTime* pBindDate);
377
378protected:
383 virtual CString Format(const COleDateTime& oleDate);
384
394 virtual void OnInplaceButtonDown(CXTPPropertyGridInplaceButton* pButton);
395
403 virtual void SetValue(CString strValue);
404
411 void OnValueChanged(CString strValue);
412
426 virtual void OnBeforeInsert();
427
428private:
429 void Init(const COleDateTime& oleDate);
430
431protected:
432 COleDateTime m_oleDate;
433 CString m_strNullValue;
435 COleDateTime* m_pBindDate;
437# ifdef _XTP_ACTIVEX
439 DECLARE_DISPATCH_MAP()
440 DECLARE_INTERFACE_MAP()
441
442 DECLARE_OLETYPELIB_EX(CXTPPropertyGridItemDate)
443
444 void OleSetValue(const VARIANT* varValue);
445 const VARIANT OleGetValue();
446 void BindDispatch();
447
448 afx_msg void OleSetDateFormat(LPCTSTR pcszFormat);
449
451# endif
452 friend class CXTPPropertyGridInplaceMonthCal;
453
454 DECLARE_DYNAMIC(CXTPPropertyGridItemDate)
455};
456
457AFX_INLINE const COleDateTime& CXTPPropertyGridItemDate::GetDate() const
458{
459 return m_oleDate;
460}
461
462# ifdef __AFXCTL_H__
469class _XTP_EXT_CLASS CXTPPropertyGridItemPicture : public CXTPPropertyGridItem
470{
471public:
479 CXTPPropertyGridItemPicture(LPCTSTR strCaption);
480
481public:
482 virtual CPictureHolder& GetPicture();
483 virtual void SetPicturePath(LPCTSTR lpszPath);
484
485protected:
495 virtual void OnInplaceButtonDown(CXTPPropertyGridInplaceButton* pButton);
496
507 virtual BOOL OnDrawItemValue(CDC& dc, CRect rcValue);
508
509protected:
510 CPictureHolder m_olePicture;
511 CString m_strPicturePath;
512 int m_nPreviewWidth;
513
514# ifdef _XTP_ACTIVEX
515 DECLARE_DISPATCH_MAP()
516 DECLARE_INTERFACE_MAP()
517
518 DECLARE_OLETYPELIB_EX(CXTPPropertyGridItemPicture)
519
520 afx_msg void OleSetValue(const VARIANT* varValue);
521 afx_msg const VARIANT OleGetValue();
522 BSTR OleGetPicturePath();
523# endif
524};
525
526AFX_INLINE CPictureHolder& CXTPPropertyGridItemPicture::GetPicture()
527{
528 return m_olePicture;
529}
531# endif
532
538class _XTP_EXT_CLASS CXTPPropertyGridItemMultilineString : public CXTPPropertyGridItem
539{
540public:
549 CXTPPropertyGridItemMultilineString(LPCTSTR lpszCaption, LPCTSTR strValue = NULL,
550 CString* pBindString = NULL);
551
560 CXTPPropertyGridItemMultilineString(UINT nID, LPCTSTR strValue = NULL,
561 CString* pBindString = NULL);
562
563protected:
573 virtual void OnInplaceButtonDown(CXTPPropertyGridInplaceButton* pButton);
574};
575
576AFX_INLINE BOOL CXTPPropertyGridInplaceMonthCal::GetMinReqRect(RECT* pRect) const
577{
578 _ASSERTE(::IsWindow(m_hWnd));
579 return (BOOL)::SendMessage(m_hWnd, MCM_GETMINREQRECT, 0, (LPARAM)pRect);
580}
582# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
583#endif // #if !defined(__XTPPROPERTYGRIDITEMEXT_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPPropertyGridInplaceButton
CXTPPropertyGridInplaceButton is a CXTPCmdTarget derived class.
Definition XTPPropertyGridInplaceButton.h:50
CXTPPropertyGridInplaceMonthCal
Month calendar pop-up used for CXTPPropertyGridItemDate item.
Definition XTPPropertyGridItemExt.h:40
CXTPPropertyGridInplaceMonthCal::GetMinReqRect
BOOL GetMinReqRect(RECT *pRect) const
Gets the minimal size required to display one month.
Definition XTPPropertyGridItemExt.h:576
CXTPPropertyGridInplaceMonthCal::OnCancel
void OnCancel()
This method is called if the user hits the Escape Key or clicks either another part of the property g...
CXTPPropertyGridInplaceMonthCal::OnAccept
void OnAccept()
This method is called if the user hits the Enter/Return key while an in-place calendar is displayed o...
CXTPPropertyGridInplaceMonthCal::CXTPPropertyGridInplaceMonthCal
CXTPPropertyGridInplaceMonthCal(CXTPPropertyGridItemDate *pItem)
Constructs a CXTPPropertyGridInplaceMonthCal object.
Definition XTPPropertyGridItemExt.h:47
CXTPPropertyGridItemDate
CXTPPropertyGridItemDate is a CXTPPropertyGridItem derived class.
Definition XTPPropertyGridItemExt.h:138
CXTPPropertyGridItemDate::GetMonth
virtual long GetMonth()
Gets the month of the date value of the item.
CXTPPropertyGridItemDate::CXTPPropertyGridItemDate
CXTPPropertyGridItemDate(UINT nID, const COleDateTime &oleDate, COleDateTime *pBindDate=NULL)
Constructs a CXTPPropertyGridItemDate object.
CXTPPropertyGridItemDate::BindToDate
void BindToDate(COleDateTime *pBindDate)
Binds the item to a specified COleDateTime object.
CXTPPropertyGridItemDate::OnBeforeInsert
virtual void OnBeforeInsert()
This method is called before the item becomes visible in the property grid.
CXTPPropertyGridItemDate::GetAllowNullDateString
CString GetAllowNullDateString() const
Gets the displayed text for a NULL date.
CXTPPropertyGridItemDate::m_strNullValue
CString m_strNullValue
String value to be displayed for the Date item when the current date is NULL.
Definition XTPPropertyGridItemExt.h:433
CXTPPropertyGridItemDate::SetValue
virtual void SetValue(CString strValue)
Sets the value of the item.
CXTPPropertyGridItemDate::GetYear
virtual long GetYear()
Gets the year of the date value of the item.
CXTPPropertyGridItemDate::SetDay
virtual void SetDay(long nDay)
Sets the day for the date value of the item.
CXTPPropertyGridItemDate::GetDay
virtual long GetDay()
Gets the day of the date value of the item.
CXTPPropertyGridItemDate::AllowNullDate
void AllowNullDate(LPCTSTR lpszNullValue)
Sets the displayed text for a NULL date.
CXTPPropertyGridItemDate::GetAsSystemTime
virtual BOOL GetAsSystemTime(SYSTEMTIME &sysTime)
Converts the time in the COleDateTime object to be represented as a SYSTEMTIME data structure.
CXTPPropertyGridItemDate::m_oleDate
COleDateTime m_oleDate
Currently selected date.
Definition XTPPropertyGridItemExt.h:432
CXTPPropertyGridItemDate::Format
virtual CString Format(const COleDateTime &oleDate)
CXTPPropertyGridItemDate::SetDateFormat
virtual void SetDateFormat(LPCTSTR strFormat)
Changes the date format.
CXTPPropertyGridItemDate::m_pBindDate
COleDateTime * m_pBindDate
Pointer to the variable bound to this item.
Definition XTPPropertyGridItemExt.h:435
CXTPPropertyGridItemDate::GetDate
virtual const COleDateTime & GetDate() const
Gets the date value of the item.
Definition XTPPropertyGridItemExt.h:457
CXTPPropertyGridItemDate::OnValueChanged
void OnValueChanged(CString strValue)
This method is called when the value of the item is changed.
CXTPPropertyGridItemDate::CXTPPropertyGridItemDate
CXTPPropertyGridItemDate(LPCTSTR strCaption, const COleDateTime &oleDate, COleDateTime *pBindDate=NULL)
Constructs a CXTPPropertyGridItemDate object.
CXTPPropertyGridItemDate::SetYear
virtual void SetYear(long nYear)
Sets the year for the date value of the item.
CXTPPropertyGridItemDate::SetDate
virtual void SetDate(const COleDateTime &oleDate)
Sets the date value for the item.
CXTPPropertyGridItemDate::OnInplaceButtonDown
virtual void OnInplaceButtonDown(CXTPPropertyGridInplaceButton *pButton)
This method is called when the user presses the in-place button.
CXTPPropertyGridItemDate::ParseDateTime
virtual BOOL ParseDateTime(COleDateTime &dt, LPCTSTR strValue)
Parses the month, day, and year from a specified COleDateTime object.
CXTPPropertyGridItemDate::SetMonth
virtual void SetMonth(long nMonth)
Sets the month for the date value of the item.
CXTPPropertyGridItem
CXTPPropertyGridItem is the base class representing an item of the Property Grid control.
Definition XTPPropertyGridItem.h:523
CXTPPropertyGridItemMultilineString
CXTPPropertyGridItemMultilineString is a CXTPPropertyGridItem derived class.
Definition XTPPropertyGridItemExt.h:539
CXTPPropertyGridItemMultilineString::CXTPPropertyGridItemMultilineString
CXTPPropertyGridItemMultilineString(LPCTSTR lpszCaption, LPCTSTR strValue=NULL, CString *pBindString=NULL)
Constructs a CXTPPropertyGridItemMultilineString object.
CXTPPropertyGridItemMultilineString::CXTPPropertyGridItemMultilineString
CXTPPropertyGridItemMultilineString(UINT nID, LPCTSTR strValue=NULL, CString *pBindString=NULL)
Constructs a CXTPPropertyGridItemMultilineString object.
CXTPPropertyGridItemMultilineString::OnInplaceButtonDown
virtual void OnInplaceButtonDown(CXTPPropertyGridInplaceButton *pButton)
This method is called when the user presses the in-place button.


Toolkit Pro: Member List

  • CXTPCalendarControl
  • CViewChangedContext
CXTPCalendarControl::CViewChangedContext Member List

This is the complete list of members for CXTPCalendarControl::CViewChangedContext, including all inherited members.

CViewChangedContext(CXTPCalendarView *pView, int eType=xtpCalendarViewChangedSend) | CXTPCalendarControl::CViewChangedContext |
CViewChangedContext(CXTPCalendarControl *pControl, int eType=xtpCalendarViewChangedSend) | CXTPCalendarControl::CViewChangedContext |
~CViewChangedContext() | CXTPCalendarControl::CViewChangedContext | virtual


Toolkit Pro: XTPTrackThemeVisualStudio2022.h Source File

  • Source
  • GridControl
  • TrackControl
  • Themes
XTPTrackThemeVisualStudio2022.h
Go to the documentation of this file.
1
23#if !defined(__XTPTRACKTHEMEVISUALSTUDIO2022_H__)
24# define __XTPTRACKTHEMEVISUALSTUDIO2022_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPTrackThemeVisualStudio2022 : public CXTPTrackThemeOffice2013
39{
40public:
45 CXTPTrackThemeVisualStudio2022();
46
52 virtual void RefreshMetrics();
53};
55# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
56#endif //#if !defined(__XTPTRACKTHEMEVISUALSTUDIO2022_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPTrackThemeOffice2013
CXTPTrackThemeOffice2013 is a CXTPTrackPaintManager derived class that represents an Office 2013 styl...
Definition XTPTrackThemeOffice2013.h:39
CXTPTrackThemeVisualStudio2022
CXTPTrackThemeVisualStudio2022 is a CXTPTrackThemeOffice2013 derived class that represents a Visual S...
Definition XTPTrackThemeVisualStudio2022.h:39
CXTPTrackThemeVisualStudio2022::CXTPTrackThemeVisualStudio2022
CXTPTrackThemeVisualStudio2022()
Default paint manager constructor, handles properties initialization.
CXTPTrackThemeVisualStudio2022::RefreshMetrics
virtual void RefreshMetrics()
This method is called to refresh the visual metrics of the track control.


Toolkit Pro: XTPChartRadarPointSeriesView.h Source File

  • Source
  • Chart
  • Styles
  • Radar
XTPChartRadarPointSeriesView.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTRADARPOINTSERIESVIEW_H__)
24# define __XTPCHARTRADARPOINTSERIESVIEW_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartSeriesView;
34class CXTPChartMarker;
35
41class _XTP_EXT_CLASS CXTPChartRadarPointSeriesView : public CXTPChartRadarDiagramSeriesView
42{
43public:
51 CXTPChartRadarPointSeriesView(CXTPChartSeries* pSeries, CXTPChartDiagramView* pDiagramView);
52
53protected:
65 CXTPChartSeriesPointView* CreateSeriesPointView(CXTPChartDeviceContext* pDC,
66 CXTPChartSeriesPoint* pPoint,
67 CXTPChartElementView* pParentView);
68
69public:
80 virtual CXTPChartDeviceCommand* CreateLegendDeviceCommand(CXTPChartDeviceContext* pDC,
81 CRect rcBounds);
82};
83
89class _XTP_EXT_CLASS CXTPChartRadarPointSeriesPointView : public CXTPChartSeriesPointView
90{
91public:
99 CXTPChartRadarPointSeriesPointView(CXTPChartSeriesPoint* pPoint,
100 CXTPChartElementView* pParentView);
101
102public:
115 virtual CXTPChartDeviceCommand* CreateDeviceCommand(CXTPChartDeviceContext* pDC);
116
127 virtual CXTPChartDeviceCommand* CreateLegendDeviceCommand(CXTPChartDeviceContext* pDC,
128 CRect rcBounds);
129
130public:
138 CXTPChartPointF GetScreenPoint() const;
139};
141# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
142#endif //#if !defined(__XTPCHARTRADARPOINTSERIESVIEW_H__)
pPoint
const CPoint * pPoint
return 0 or xtpCalendarHitTestDayExpandButton
Definition XTPCalendarThemeOffice2007.h:150
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartDiagramView
This class represents the view of a chart diagram, which is a kind of CXTPChartElementView.
Definition XTPChartDiagramView.h:49
CXTPChartElementView
This class represents the view of a chart element.
Definition XTPChartElementView.h:47
CXTPChartMarker
This class abstracts a marker used in marking the points in a point series style chart.
Definition XTPChartMarker.h:64
CXTPChartRadarPointSeriesPointView
This class represents the view of a point series point, which is a kind of CXTPChartSeriesPointView.
Definition XTPChartRadarPointSeriesView.h:90
CXTPChartRadarPointSeriesPointView::CXTPChartRadarPointSeriesPointView
CXTPChartRadarPointSeriesPointView(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Constructs a CXTPChartPointSeriesPointView object.
CXTPChartRadarPointSeriesPointView::CreateDeviceCommand
virtual CXTPChartDeviceCommand * CreateDeviceCommand(CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
CXTPChartRadarPointSeriesPointView::CreateLegendDeviceCommand
virtual CXTPChartDeviceCommand * CreateLegendDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcBounds)
This function creates a label view drawing command object.
CXTPChartRadarPointSeriesPointView::GetScreenPoint
CXTPChartPointF GetScreenPoint() const
Call this function to get the screen point from the series point.
CXTPChartRadarPointSeriesView
This class represents the view of a point series, which is a kind of CXTPChartSeriesView.
Definition XTPChartRadarPointSeriesView.h:42
CXTPChartRadarPointSeriesView::CXTPChartRadarPointSeriesView
CXTPChartRadarPointSeriesView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Constructs a CXTPChartPointSeriesView object.
CXTPChartRadarPointSeriesView::CreateLegendDeviceCommand
virtual CXTPChartDeviceCommand * CreateLegendDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcBounds)
This function creates a label view drawing command object.
CXTPChartRadarPointSeriesView::CreateSeriesPointView
CXTPChartSeriesPointView * CreateSeriesPointView(CXTPChartDeviceContext *pDC, CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Call this function to create a view of the series point.
CXTPChartSeries
This class represents a series in the chart, which is a kind of CXTPChartElement.
Definition XTPChartSeries.h:50
CXTPChartSeriesPoint
CXTPChartSeriesPoint is a kind of CXTPChartElement.
Definition XTPChartSeriesPoint.h:43
CXTPChartSeriesPointView
Represents chart series point view.
Definition XTPChartSeriesPointView.h:48
CXTPPoint2T< float >


Toolkit Pro: XTPSmartPtrInternalT.h Source File

  • Source
  • Common
XTPSmartPtrInternalT.h
Go to the documentation of this file.
1
23#if !defined(_XtpSmartPtrInternal_H__)
24# define _XtpSmartPtrInternal_H__
25
26# if _MSC_VER > 1000
27# pragma once
28# endif // _MSC_VER > 1000
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
34// template: CXTPSmartPtrInternalT
35// macro: XTP_DEFINE_SMART_PTR_INTERNAL(_TClassName)
36// XTP_DEFINE_SMART_PTR_ARRAY_INTERNAL(_TClassName)
38
47# define XTP_DEFINE_SMART_PTR_INTERNAL(ClassName) \
48 typedef CXTPSmartPtrInternalT<ClassName> ClassName##Ptr;
49
57# define XTP_DEFINE_SMART_PTR_ARRAY_INTERNAL(ClassName) \
58 typedef CXTPInternalCollectionT<ClassName> ClassName##PtrArray; \
59 typedef CXTPSmartPtrInternalT<ClassName> ClassName##PtrArrayPtr;
60
70template<class _TObject>
71class CXTPSmartPtrInternalT
72{
73protected:
78 typedef CXTPSmartPtrInternalT<_TObject> Tthis;
79
80 _TObject* m_pObject;
81public:
93 CXTPSmartPtrInternalT(_TObject* pObject = NULL, BOOL bCallInternalAddRef = FALSE)
94 {
95 m_pObject = pObject;
96
97 if (bCallInternalAddRef && m_pObject)
98 {
99 ((CCmdTarget*)m_pObject)->InternalAddRef();
100 }
101 };
102
110 CXTPSmartPtrInternalT(const Tthis& rSrc)
111 {
112 m_pObject = (_TObject*)rSrc;
113 if (m_pObject)
114 {
115 ((CCmdTarget*)m_pObject)->InternalAddRef();
116 }
117 };
118
127 virtual ~CXTPSmartPtrInternalT()
128 {
129 if (m_pObject)
130 {
131 ((CCmdTarget*)m_pObject)->InternalRelease();
132 }
133 };
134
150 void SetPtr(_TObject* pObject, BOOL bCallInternalAddRef = FALSE)
151 {
152 _TObject* pObjOld = m_pObject;
153
154 if (bCallInternalAddRef && pObject)
155 {
156 ((CCmdTarget*)pObject)->InternalAddRef();
157 }
158 m_pObject = pObject;
159
160 if (pObjOld)
161 {
162 ((CCmdTarget*)pObjOld)->InternalRelease();
163 }
164 };
165
173 _TObject* Detach()
174 {
175 _TObject* pObj = m_pObject;
176 m_pObject = NULL;
177 return pObj;
178 };
179
188 _TObject* GetInterface(BOOL bWithAddRef = TRUE)
189 {
190 if (bWithAddRef && m_pObject)
191 {
192 ((CCmdTarget*)m_pObject)->InternalAddRef();
193 }
194 return m_pObject;
195 };
196
207 _TObject* operator=(_TObject* pNewObj)
208 {
209 _TObject* pObjOld = m_pObject;
210 m_pObject = pNewObj;
211
212 if (pObjOld)
213 {
214 ((CCmdTarget*)pObjOld)->InternalRelease();
215 }
216
217 return pNewObj;
218 };
219
231 const Tthis& operator=(const Tthis& rSrc)
232 {
233 _TObject* pObjOld = m_pObject;
234
235 m_pObject = rSrc;
236
237 if (m_pObject)
238 {
239 ((CCmdTarget*)m_pObject)->InternalAddRef();
240 }
241
242 if (pObjOld)
243 {
244 ((CCmdTarget*)pObjOld)->InternalRelease();
245 }
246
247 return rSrc;
248 };
249
256 _TObject* operator->() const
257 {
258 _ASSERTE(m_pObject);
259 return m_pObject;
260 };
261
268 _TObject& operator*() const
269 {
270 _ASSERTE(m_pObject);
271 return *m_pObject;
272 };
273
280 operator _TObject*() const
281 {
282 return m_pObject;
283 }
284 operator const _TObject*() const
285 {
286 return m_pObject;
287 }
288
295 bool operator!() const
296 {
297 return (m_pObject == NULL);
298 }
299
306 operator bool() const
307 {
308 return (m_pObject != NULL);
309 }
310
321 bool operator==(const Tthis& ptr2) const
322 {
323 return m_pObject == (_TObject*)ptr2;
324 }
325 bool operator==(const _TObject* pObj) const
326 {
327 return pObj == m_pObject;
328 }
329
340 bool operator!=(const Tthis& ptr2) const
341 {
342 return m_pObject != (_TObject*)ptr2;
343 }
344 bool operator!=(const _TObject* pObj) const
345 {
346 return pObj != m_pObject;
347 }
348};
350template<class _TObject>
351AFX_INLINE bool operator==(const CXTPSmartPtrInternalT<_TObject>& ptr1, const _TObject* ptr2)
352{
353 return ptr1 == ptr2;
354}
355
356template<class _TObject>
357AFX_INLINE bool operator==(const _TObject* ptr1, const CXTPSmartPtrInternalT<_TObject>& ptr2)
358{
359 return ptr2 == ptr1;
360}
361
362template<class _TObject>
363AFX_INLINE bool operator!=(const CXTPSmartPtrInternalT<_TObject>& ptr1, const _TObject* ptr2)
364{
365 return ptr1 != ptr2;
366}
367
368template<class _TObject>
369AFX_INLINE bool operator!=(const _TObject* ptr1, const CXTPSmartPtrInternalT<_TObject>& ptr2)
370{
371 return ptr2 != ptr1;
372}
384template<class _TObject>
385class CXTPInternalCollectionT
386 : public CArray<CXTPSmartPtrInternalT<_TObject>, const CXTPSmartPtrInternalT<_TObject>&>
387{
388public:
393 typedef _TObject TObject;
394
399 typedef CXTPSmartPtrInternalT<_TObject> TObjectPtr;
400
405 CXTPInternalCollectionT(){};
406
411 virtual ~CXTPInternalCollectionT(){};
426 /*
427 CXTPInternalCollectionT<_TObject>* GetInterface(BOOL bWithAddRef = TRUE) {
428 if(bWithAddRef) {
429 InternalAddRef();
430 }
431 return this;
432 };
433 */
450 virtual _TObject* GetAt(int nIndex, BOOL bWithAddRef = TRUE)
451 {
452 TObjectPtr& rPtr = CXTPInternalCollectionT::ElementAt(nIndex);
453 _TObject* pObj = rPtr.GetInterface(bWithAddRef);
454 return pObj;
455 }
456
471 virtual int AddPtr(_TObject* pObj, BOOL bCallAddRef = FALSE)
472 {
473 TObjectPtr ptrObj(pObj, bCallAddRef);
474 return static_cast<int>(CXTPInternalCollectionT::Add(ptrObj));
475 }
476};
477
488template<class TYPE, class ARG_TYPE, class OLE_TYPE = long>
489class CXTPArrayT : public CXTPCmdTarget
490{
491public:
496 CXTPArrayT();
497
502 virtual ~CXTPArrayT();
503
515 virtual int GetSize() const;
516
527 virtual void SetSize(int nNewSize, int nGrowBy = -1);
528
540 virtual TYPE GetAt(int nIndex) const;
541
556 virtual void SetAt(int nIndex, ARG_TYPE newElement);
557
567 virtual TYPE& ElementAt(int nIndex);
568
576 virtual const TYPE* GetData() const;
577
585 virtual TYPE* GetData();
586
602 virtual void SetAtGrow(int nIndex, ARG_TYPE newElement);
603
611 virtual int Add(ARG_TYPE newElement);
612
623 virtual int Append(const CXTPArrayT& src);
624
633 virtual void Copy(const CXTPArrayT& src);
634
644 TYPE operator[](int nIndex) const;
645
655 TYPE& operator[](int nIndex);
656
668 virtual void InsertAt(int nIndex, ARG_TYPE newElement, int nCount = 1);
669
680 virtual void RemoveAt(int nIndex, int nCount = 1);
681
689 virtual void RemoveAll();
690
700 virtual void InsertAt(int nStartIndex, CXTPArrayT* pNewArray);
701
710 virtual int FindElement(ARG_TYPE nElement) const;
711
723 virtual void AddIfNeed(ARG_TYPE newElement);
724
735 virtual BOOL RemoveElement(ARG_TYPE nElement);
736
737protected:
738 CArray<TYPE, ARG_TYPE> m_arElements;
740protected:
741 // OLE collection implementation helpers for macros DECLARE_ENUM_VARIANT_EX(derived-class,
742 // long);
743
745 virtual long OleGetItemCount();
746 virtual OLE_TYPE OleGetItem(long nIndex);
747
748 virtual void OleSetItem(long nIndex, OLE_TYPE oleValue);
749
750 virtual void OleAdd(OLE_TYPE otElement);
751 virtual void OleRemove(long nIndex);
752 virtual void OleRemoveAll();
754};
755
757
758template<class TYPE, class ARG_TYPE, class OLE_TYPE>
759AFX_INLINE CXTPArrayT<TYPE, ARG_TYPE, OLE_TYPE>::CXTPArrayT()
760{
761}
762
763template<class TYPE, class ARG_TYPE, class OLE_TYPE>
764AFX_INLINE CXTPArrayT<TYPE, ARG_TYPE, OLE_TYPE>::~CXTPArrayT()
765{
766}
767
768template<class TYPE, class ARG_TYPE, class OLE_TYPE>
769AFX_INLINE int CXTPArrayT<TYPE, ARG_TYPE, OLE_TYPE>::GetSize() const
770{
771 return (int)m_arElements.GetSize();
772}
773
774template<class TYPE, class ARG_TYPE, class OLE_TYPE>
775AFX_INLINE void CXTPArrayT<TYPE, ARG_TYPE, OLE_TYPE>::SetSize(int nNewSize, int nGrowBy)
776{
777 m_arElements.SetSize(nNewSize, nGrowBy);
778}
779
780template<class TYPE, class ARG_TYPE, class OLE_TYPE>
781AFX_INLINE void CXTPArrayT<TYPE, ARG_TYPE, OLE_TYPE>::RemoveAll()
782{
783 m_arElements.RemoveAll();
784}
785
786template<class TYPE, class ARG_TYPE, class OLE_TYPE>
787AFX_INLINE TYPE CXTPArrayT<TYPE, ARG_TYPE, OLE_TYPE>::GetAt(int nIndex) const
788{
789 return m_arElements.GetAt(nIndex);
790}
791
792template<class TYPE, class ARG_TYPE, class OLE_TYPE>
793AFX_INLINE void CXTPArrayT<TYPE, ARG_TYPE, OLE_TYPE>::SetAt(int nIndex, ARG_TYPE newElement)
794{
795 m_arElements.SetAt(nIndex, newElement);
796}
797
798template<class TYPE, class ARG_TYPE, class OLE_TYPE>
799AFX_INLINE TYPE& CXTPArrayT<TYPE, ARG_TYPE, OLE_TYPE>::ElementAt(int nIndex)
800{
801 return m_arElements.ElementAt(nIndex);
802}
803
804template<class TYPE, class ARG_TYPE, class OLE_TYPE>
805AFX_INLINE const TYPE* CXTPArrayT<TYPE, ARG_TYPE, OLE_TYPE>::GetData() const
806{
807 return m_arElements.GetData();
808}
809
810template<class TYPE, class ARG_TYPE, class OLE_TYPE>
811AFX_INLINE TYPE* CXTPArrayT<TYPE, ARG_TYPE, OLE_TYPE>::GetData()
812{
813 return m_arElements.GetData();
814}
815
816template<class TYPE, class ARG_TYPE, class OLE_TYPE>
817AFX_INLINE void CXTPArrayT<TYPE, ARG_TYPE, OLE_TYPE>::SetAtGrow(int nIndex, ARG_TYPE newElement)
818{
819 m_arElements.SetAtGrow(nIndex, newElement);
820}
821
822template<class TYPE, class ARG_TYPE, class OLE_TYPE>
823AFX_INLINE int CXTPArrayT<TYPE, ARG_TYPE, OLE_TYPE>::Add(ARG_TYPE newElement)
824{
825 return (int)m_arElements.Add(newElement);
826}
827
828template<class TYPE, class ARG_TYPE, class OLE_TYPE>
829AFX_INLINE int CXTPArrayT<TYPE, ARG_TYPE, OLE_TYPE>::Append(const CXTPArrayT& src)
830{
831 return (int)m_arElements.Append(src.m_arElements);
832}
833
834template<class TYPE, class ARG_TYPE, class OLE_TYPE>
835AFX_INLINE void CXTPArrayT<TYPE, ARG_TYPE, OLE_TYPE>::Copy(const CXTPArrayT& src)
836{
837 m_arElements.Copy(src.m_arElements);
838}
839
840template<class TYPE, class ARG_TYPE, class OLE_TYPE>
841AFX_INLINE TYPE CXTPArrayT<TYPE, ARG_TYPE, OLE_TYPE>::operator[](int nIndex) const
842{
843 return m_arElements[nIndex];
844}
845
846template<class TYPE, class ARG_TYPE, class OLE_TYPE>
847AFX_INLINE TYPE& CXTPArrayT<TYPE, ARG_TYPE, OLE_TYPE>::operator[](int nIndex)
848{
849 return m_arElements[nIndex];
850}
851
852template<class TYPE, class ARG_TYPE, class OLE_TYPE>
853AFX_INLINE void CXTPArrayT<TYPE, ARG_TYPE, OLE_TYPE>::InsertAt(int nIndex, ARG_TYPE newElement,
854 int nCount)
855{
856 m_arElements.InsertAt(nIndex, newElement, nCount);
857}
858
859template<class TYPE, class ARG_TYPE, class OLE_TYPE>
860AFX_INLINE void CXTPArrayT<TYPE, ARG_TYPE, OLE_TYPE>::RemoveAt(int nIndex, int nCount)
861{
862 m_arElements.RemoveAt(nIndex, nCount);
863}
864
865template<class TYPE, class ARG_TYPE, class OLE_TYPE>
866AFX_INLINE void CXTPArrayT<TYPE, ARG_TYPE, OLE_TYPE>::InsertAt(int nStartIndex,
867 CXTPArrayT* pNewArray)
868{
869 _ASSERTE(pNewArray);
870 if (pNewArray)
871 m_arElements.InsertAt(nStartIndex, &(pNewArray->m_arElements));
872}
873
874template<class TYPE, class ARG_TYPE, class OLE_TYPE>
875AFX_INLINE int CXTPArrayT<TYPE, ARG_TYPE, OLE_TYPE>::FindElement(ARG_TYPE nElement) const
876{
877 int nCount = GetSize();
878 for (int i = 0; i < nCount; i++)
879 {
880 if (GetAt(i) == nElement)
881 return i;
882 }
883 return -1;
884}
885
886template<class TYPE, class ARG_TYPE, class OLE_TYPE>
887AFX_INLINE BOOL CXTPArrayT<TYPE, ARG_TYPE, OLE_TYPE>::RemoveElement(ARG_TYPE nElement)
888{
889 BOOL bResult = FALSE;
890
891 int nCount = GetSize();
892 for (int i = nCount - 1; i >= 0; i--)
893 {
894 if (GetAt(i) == nElement)
895 {
896 RemoveAt(i);
897 bResult = TRUE;
898 }
899 }
900
901 return bResult;
902}
903
904template<class TYPE, class ARG_TYPE, class OLE_TYPE>
905AFX_INLINE void CXTPArrayT<TYPE, ARG_TYPE, OLE_TYPE>::AddIfNeed(ARG_TYPE newElement)
906{
907 if (FindElement(newElement) < 0)
908 {
909 Add(newElement);
910 }
911}
912
913template<class TYPE, class ARG_TYPE, class OLE_TYPE>
914AFX_INLINE OLE_TYPE CXTPArrayT<TYPE, ARG_TYPE, OLE_TYPE>::OleGetItem(long nIndex)
915{
916 if (nIndex < 0 || nIndex >= (long)GetSize())
917 AfxThrowOleException(DISP_E_BADINDEX);
918
919 return (OLE_TYPE)GetAt(nIndex);
920}
921
922template<class TYPE, class ARG_TYPE, class OLE_TYPE>
923AFX_INLINE void CXTPArrayT<TYPE, ARG_TYPE, OLE_TYPE>::OleSetItem(long nIndex, OLE_TYPE oleValue)
924{
925 if (nIndex < 0 || nIndex >= (long)GetSize())
926 AfxThrowOleException(DISP_E_BADINDEX);
927
928 SetAt(nIndex, (ARG_TYPE)oleValue);
929}
930
931template<class TYPE, class ARG_TYPE, class OLE_TYPE>
932AFX_INLINE long CXTPArrayT<TYPE, ARG_TYPE, OLE_TYPE>::OleGetItemCount()
933{
934 return (long)m_arElements.GetSize();
935}
936
937template<class TYPE, class ARG_TYPE, class OLE_TYPE>
938AFX_INLINE void CXTPArrayT<TYPE, ARG_TYPE, OLE_TYPE>::OleAdd(OLE_TYPE otElement)
939{
940 Add((TYPE)otElement);
941}
942
943template<class TYPE, class ARG_TYPE, class OLE_TYPE>
944AFX_INLINE void CXTPArrayT<TYPE, ARG_TYPE, OLE_TYPE>::OleRemove(long nIndex)
945{
946 if (nIndex < 0 || nIndex >= (long)GetSize())
947 AfxThrowOleException(DISP_E_BADINDEX);
948
949 RemoveAt(nIndex);
950}
951
952template<class TYPE, class ARG_TYPE, class OLE_TYPE>
953AFX_INLINE void CXTPArrayT<TYPE, ARG_TYPE, OLE_TYPE>::OleRemoveAll()
954{
955 RemoveAll();
956}
959# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
961#endif // !defined(_XtpSmartPtrInternal_H__)
XTPEnableNoisyWarnings.h
CXTPArrayT
This class represents a simple array of typed elements.
Definition XTPSmartPtrInternalT.h:490
CXTPArrayT::InsertAt
virtual void InsertAt(int nIndex, ARG_TYPE newElement, int nCount=1)
This member function is used to insert a number of copies of an element, specified by the nCount para...
CXTPArrayT::SetAt
virtual void SetAt(int nIndex, ARG_TYPE newElement)
This member function is used to set a new element to the position specified in the nIndex parameter.
CXTPArrayT::InsertAt
virtual void InsertAt(int nStartIndex, CXTPArrayT *pNewArray)
This member function is used to insert an array of elements to the array starting at the position spe...
CXTPArrayT::Add
virtual int Add(ARG_TYPE newElement)
This member function adds a new element to the end of the array.
CXTPArrayT::GetAt
virtual TYPE GetAt(int nIndex) const
This member function returns an element at the specified numeric index.
CXTPArrayT::FindElement
virtual int FindElement(ARG_TYPE nElement) const
Call this member function to find an element in the collection.
CXTPArrayT::GetData
virtual TYPE * GetData()
This member function is used to Direct Access to the element data.
CXTPArrayT::m_arElements
CArray< TYPE, ARG_TYPE > m_arElements
Elements storage.
Definition XTPSmartPtrInternalT.h:738
CXTPArrayT::CXTPArrayT
CXTPArrayT()
Default object constructor.
CXTPArrayT::operator[]
TYPE operator[](int nIndex) const
This operator returns the array element at a specified numeric index.
CXTPArrayT::Copy
virtual void Copy(const CXTPArrayT &src)
This member function overwrites the contents of this array with the contents of a specified array.
CXTPArrayT::~CXTPArrayT
virtual ~CXTPArrayT()
Default object destructor.
CXTPArrayT::RemoveElement
virtual BOOL RemoveElement(ARG_TYPE nElement)
Call this member function to remove all elements with a specified value from the collection.
CXTPArrayT::RemoveAt
virtual void RemoveAt(int nIndex, int nCount=1)
This member function is used to remove a number of array elements, specified by the nCount parameter,...
CXTPArrayT::RemoveAll
virtual void RemoveAll()
This member function is used to remove all array elements from the array.
CXTPArrayT::GetSize
virtual int GetSize() const
This member function is used to obtain the number of elements in the collection.
CXTPArrayT::operator[]
TYPE & operator[](int nIndex)
This operator returns a reference to the array element at a specified numeric index.
CXTPArrayT::Append
virtual int Append(const CXTPArrayT &src)
This member function adds the elements from a specified array to the end of this array.
CXTPArrayT::ElementAt
virtual TYPE & ElementAt(int nIndex)
This member function returns a reference to element at the specified numeric index.
CXTPArrayT::SetAtGrow
virtual void SetAtGrow(int nIndex, ARG_TYPE newElement)
This member function is used to set a new element to the position specified in the nIndex parameter.
CXTPArrayT::SetSize
virtual void SetSize(int nNewSize, int nGrowBy=-1)
This member function is used to change the array size.
CXTPArrayT::GetData
virtual const TYPE * GetData() const
This member function is used to Direct Access to the element data.
CXTPArrayT::AddIfNeed
virtual void AddIfNeed(ARG_TYPE newElement)
Call this member function to add a specified element to the collection if it is not present already.
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPInternalCollectionT
Definition XTPSmartPtrInternalT.h:387
CXTPInternalCollectionT::TObject
_TObject TObject
Stored objects type definition.
Definition XTPSmartPtrInternalT.h:393
CXTPInternalCollectionT::TObjectPtr
CXTPSmartPtrInternalT< _TObject > TObjectPtr
Stored objects smart-pointer type definition.
Definition XTPSmartPtrInternalT.h:399
CXTPInternalCollectionT::AddPtr
virtual int AddPtr(_TObject *pObj, BOOL bCallAddRef=FALSE)
Add object pointer to the array.
Definition XTPSmartPtrInternalT.h:471
CXTPInternalCollectionT::~CXTPInternalCollectionT
virtual ~CXTPInternalCollectionT()
Default object destructor.
Definition XTPSmartPtrInternalT.h:411
CXTPInternalCollectionT::GetAt
virtual _TObject * GetAt(int nIndex, BOOL bWithAddRef=TRUE)
Get one of stored objects by index.
Definition XTPSmartPtrInternalT.h:450
CXTPInternalCollectionT::CXTPInternalCollectionT
CXTPInternalCollectionT()
Default object constructor.
Definition XTPSmartPtrInternalT.h:405
CXTPSmartPtrInternalT
Definition XTPSmartPtrInternalT.h:72
CXTPSmartPtrInternalT::operator=
const Tthis & operator=(const Tthis &rSrc)
Set new handled object.
Definition XTPSmartPtrInternalT.h:231
CXTPSmartPtrInternalT::Detach
_TObject * Detach()
Get a handled object and set internal object member to NULL without call InternalRelease().
Definition XTPSmartPtrInternalT.h:173
CXTPSmartPtrInternalT::CXTPSmartPtrInternalT
CXTPSmartPtrInternalT(_TObject *pObject=NULL, BOOL bCallInternalAddRef=FALSE)
Default class constructor.
Definition XTPSmartPtrInternalT.h:93
CXTPSmartPtrInternalT::Tthis
CXTPSmartPtrInternalT< _TObject > Tthis
Definition XTPSmartPtrInternalT.h:78
CXTPSmartPtrInternalT::operator->
_TObject * operator->() const
Get a handled object.
Definition XTPSmartPtrInternalT.h:256
CXTPSmartPtrInternalT::operator!=
bool operator!=(const Tthis &ptr2) const
Not-equal-to operator.
Definition XTPSmartPtrInternalT.h:340
CXTPSmartPtrInternalT::operator=
_TObject * operator=(_TObject *pNewObj)
Set new handled object.
Definition XTPSmartPtrInternalT.h:207
CXTPSmartPtrInternalT::operator!
bool operator!() const
Checks is handled object equal NULL.
Definition XTPSmartPtrInternalT.h:295
CXTPSmartPtrInternalT::SetPtr
void SetPtr(_TObject *pObject, BOOL bCallInternalAddRef=FALSE)
Set new handled object.
Definition XTPSmartPtrInternalT.h:150
CXTPSmartPtrInternalT::operator==
bool operator==(const Tthis &ptr2) const
Equal-to operator.
Definition XTPSmartPtrInternalT.h:321
CXTPSmartPtrInternalT::m_pObject
_TObject * m_pObject
A pointer to a handled object.
Definition XTPSmartPtrInternalT.h:80
CXTPSmartPtrInternalT::CXTPSmartPtrInternalT
CXTPSmartPtrInternalT(const Tthis &rSrc)
Copy class constructor.
Definition XTPSmartPtrInternalT.h:110
CXTPSmartPtrInternalT::~CXTPSmartPtrInternalT
virtual ~CXTPSmartPtrInternalT()
Default class destructor.
Definition XTPSmartPtrInternalT.h:127
CXTPSmartPtrInternalT::GetInterface
_TObject * GetInterface(BOOL bWithAddRef=TRUE)
Get a handled object and set internal object member to NULL without call InternalRelease().
Definition XTPSmartPtrInternalT.h:188
CXTPSmartPtrInternalT::operator*
_TObject & operator*() const
Get a handled object.
Definition XTPSmartPtrInternalT.h:268


Toolkit Pro: XTPTabColorSetVisualStudio2015.h Source File

  • Source
  • TabManager
  • ColorSets
XTPTabColorSetVisualStudio2015.h
Go to the documentation of this file.
1
23#if !defined(__XTPTABCOLORSETVISUALSTUDIO2015_H__)
24# define __XTPTABCOLORSETVISUALSTUDIO2015_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
37class _XTP_EXT_CLASS CXTPTabColorSetVisualStudio2015 : public CXTPTabPaintManagerColorSet
38{
39public:
40 CXTPTabColorSetVisualStudio2015();
41
49 virtual void RefreshMetrics();
50
64 virtual COLORREF GetItemColor(CXTPTabManagerItem* pItem);
65
66 virtual COLORREF GetItemBorderColor(CXTPTabManagerItem* pItem);
67 virtual CRect GetItemBorderRect(CXTPTabManagerItem* pItem);
68
75 virtual void SetTextColor(CDC* pDC, CXTPTabManagerItem* pItem);
76
84 virtual COLORREF GetClientColor(CXTPTabManager* pTabManager);
85
101 virtual COLORREF FillPropertyButton(CDC* pDC, CRect rcItem, CXTPTabManagerItem* pItem);
102
119 virtual void FillNavigateButton(CDC* pDC, CXTPTabManagerNavigateButton* pButton, CRect& rc);
120
121protected:
122 struct NAVIGATE_BUTTON_COLOR
123 {
124 CXTPPaintManagerColor clrBack;
125 CXTPPaintManagerColor clrBorder;
126 CXTPPaintManagerColor clrText;
127 };
128
129 struct NAVIGATE_BUTTON
130 {
131 NAVIGATE_BUTTON_COLOR Normal;
132 NAVIGATE_BUTTON_COLOR Highlighted;
133 NAVIGATE_BUTTON_COLOR Pressed;
134 };
135
136 struct TAB_BUTTON
137 {
138 struct State
139 {
140 CXTPPaintManagerColor clrBack;
141 CXTPPaintManagerColor clrBorder;
142 CXTPPaintManagerColor clrText;
143 CRect rcBorder;
144 NAVIGATE_BUTTON Navigate;
145 };
146
147 State Normal;
148 State Highlighted;
149 State Selected;
150 };
151
152 CXTPPaintManagerColor m_clrActiveClientBack;
153 CXTPPaintManagerColor m_clrInactiveClientBack;
154
155 NAVIGATE_BUTTON m_NavigationButton;
156 TAB_BUTTON m_ActiveTabButton;
157 TAB_BUTTON m_InactiveTabButton;
158
159 void FillNavigateButton(CDC* pDC, CXTPTabManagerNavigateButton* pButton, CRect& rc,
160 NAVIGATE_BUTTON_COLOR clr);
161};
162
163# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
165#endif // !defined(__XTPTABCOLORSETVISUALSTUDIO2015_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPPaintManagerColor
The CXTPPaintManagerColor class is used to manage COLORREF values for determining default and applica...
Definition XTPColorManager.h:117
CXTPTabColorSetVisualStudio2015
CXTPTabColorSetVisualStudio2015 implements a Visual Studio 2015 tab color set.
Definition XTPTabColorSetVisualStudio2015.h:38
CXTPTabColorSetVisualStudio2015::GetItemColor
virtual COLORREF GetItemColor(CXTPTabManagerItem *pItem)
Retrieves the color of a specified tab.
CXTPTabColorSetVisualStudio2015::FillNavigateButton
virtual void FillNavigateButton(CDC *pDC, CXTPTabManagerNavigateButton *pButton, CRect &rc)
Fills a specified tab naGroupOuterMarginvigation button.
CXTPTabColorSetVisualStudio2015::RefreshMetrics
virtual void RefreshMetrics()
Refreshes the visual metrics of the tabs.
CXTPTabColorSetVisualStudio2015::GetClientColor
virtual COLORREF GetClientColor(CXTPTabManager *pTabManager)
Obtains client background color.
CXTPTabColorSetVisualStudio2015::SetTextColor
virtual void SetTextColor(CDC *pDC, CXTPTabManagerItem *pItem)
Sets the text color for the tab.
CXTPTabColorSetVisualStudio2015::FillPropertyButton
virtual COLORREF FillPropertyButton(CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem)
Fills a specified tab button.
CXTPTabManager
CXTPTabManager is the base class for docking pane tabs, tab control tabs, and MDI client tabs.
Definition XTPTabManager.h:87
CXTPTabManagerItem
CXTPTabManagerItem is the base class for the tabs that appear in the command bars tab workspace,...
Definition XTPTabManagerItem.h:44
CXTPTabManagerNavigateButton
CXTPTabManagerNavigateButton is a class used to represent a tab navigation button.
Definition XTPTabManagerNavigateButton.h:74
CXTPTabPaintManagerColorSet
CXTPTabPaintManagerColorSet represents the colors for all of the components of the tab manager (e....
Definition XTPTabPaintManagerColorSet.h:50
CXTPTabPaintManagerColorSet::FillNavigateButton
virtual void FillNavigateButton(CDC *pDC, CXTPTabManagerNavigateButton *pButton, CRect &rc)=0
Fills a specified tab navigation button.


Toolkit Pro: Member List

CXTPNotifyConnectionMT Member List

This is the complete list of members for CXTPNotifyConnectionMT, including all inherited members.

Advise(XTP_NOTIFY_CODE dwNotifyCode, CXTPNotifySinkBase *pSink) | CXTPNotifyConnection |
CXTPCmdTarget() | CXTPCmdTarget |
CXTPNotifyConnection() | CXTPNotifyConnection |
CXTPNotifyConnectionMT() | CXTPNotifyConnectionMT |
FindConnection(XTP_CONNECTION_ID ConnectionID) | CXTPNotifyConnection | protected
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetDataLock() | CXTPNotifyConnectionMT | protectedvirtual
m_arrConnections | CXTPNotifyConnection | protected
m_arrSendQueueCache | CXTPNotifyConnection | protected
m_DataLockerCS | CXTPNotifyConnectionMT | protected
m_emptyLocker | CXTPNotifyConnection | protected
m_nSendQueueCacheSize | CXTPNotifyConnection | protected
PostEvent(XTP_NOTIFY_CODE dwNotifyCode, WPARAM wParam, LPARAM lParam, DWORD dwFlags=0) | CXTPNotifyConnectionMT |
RemoveAll() | CXTPNotifyConnection |
SendEvent(XTP_NOTIFY_CODE dwNotifyCode, WPARAM wParam, LPARAM lParam, DWORD dwFlags=0) | CXTPNotifyConnection |
Unadvise(XTP_CONNECTION_ID ConnectionID) | CXTPNotifyConnection |
~CXTPNotifyConnection() | CXTPNotifyConnection | virtual
~CXTPNotifyConnectionMT() | CXTPNotifyConnectionMT | virtual


Toolkit Pro: Member List

CXTPXamlPreviewProvider Member List

This is the complete list of members for CXTPXamlPreviewProvider, including all inherited members.

BindHost(IXTPPreviewHost &host) | CXTPPreviewProviderBase | protectedvirtual
CXTPPreviewProviderBase() | CXTPPreviewProviderBase | protected
GetHost() const | CXTPPreviewProviderBase | protected
~IXTPPreviewProvider() | IXTPPreviewProvider | inlinevirtual


Toolkit Pro: Member List

CXTPCalendarBusyStatusComboBox Member List

This is the complete list of members for CXTPCalendarBusyStatusComboBox, including all inherited members.

CalcColorRect(CRect rItem) | CXTPCalendarComboBoxBase | protectedvirtual
CXTPCalendarComboBoxBase() | CXTPCalendarComboBoxBase |
DrawItem(LPDRAWITEMSTRUCT lpDIS) | CXTPCalendarBusyStatusComboBox | protectedvirtual
Init(CXTPCalendarEvent *pEvent, XTPCalendarTheme nTheme) | CXTPCalendarBusyStatusComboBox | virtual
MeasureItem(LPMEASUREITEMSTRUCT lpMIS) | CXTPCalendarComboBoxBase | protectedvirtual
~CXTPCalendarComboBoxBase() | CXTPCalendarComboBoxBase | virtual


Toolkit Pro: XTPTabThemeExcel2003.h Source File

  • Source
  • TabManager
  • Themes
XTPTabThemeExcel2003.h
Go to the documentation of this file.
1
23#if !defined(__XTPTABTHEMEEXCEL2003_H__)
24# define __XTPTABTHEMEEXCEL2003_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
48class _XTP_EXT_CLASS CXTPTabThemeExcel2003 : public CXTPTabThemeFlat
49{
50public:
55 CXTPTabThemeExcel2003()
56 {
57 m_rcHeaderMargin.SetRect(2, 3, 2, 0);
58 }
59
71 virtual CRect GetHeaderMargin()
72 {
73 return CRect(m_rcHeaderMargin.left + m_nButtonHeight / 2, m_rcHeaderMargin.top,
74 m_rcHeaderMargin.right + m_nButtonHeight / 2, m_rcHeaderMargin.bottom);
75 }
76
92 virtual void DrawSingleButton(CDC* pDC, CXTPTabManagerItem* pItem);
93
104 virtual CRect GetButtonDrawRect(const CXTPTabManagerItem* pItem);
105};
106
107# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
109#endif // !defined(__XTPTABTHEMEEXCEL2003_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPTabManagerItem
CXTPTabManagerItem is the base class for the tabs that appear in the command bars tab workspace,...
Definition XTPTabManagerItem.h:44
CXTPTabThemeExcel2003
CXTPTabThemeExcel2003 implements an Excel tab appearance.
Definition XTPTabThemeExcel2003.h:49
CXTPTabThemeExcel2003::CXTPTabThemeExcel2003
CXTPTabThemeExcel2003()
Constructs a CXTPTabThemeExcel2003 object.
Definition XTPTabThemeExcel2003.h:55
CXTPTabThemeExcel2003::GetButtonDrawRect
virtual CRect GetButtonDrawRect(const CXTPTabManagerItem *pItem)
Retrieves the bounding rectangle of a specified drawing item.
CXTPTabThemeExcel2003::GetHeaderMargin
virtual CRect GetHeaderMargin()
Gets the top, left, right, and bottom margins of the tab header.
Definition XTPTabThemeExcel2003.h:71
CXTPTabThemeExcel2003::DrawSingleButton
virtual void DrawSingleButton(CDC *pDC, CXTPTabManagerItem *pItem)
Draws a single tab button in the tab client header area.
CXTPTabThemeFlat
CXTPTabThemeFlat implements a "Flat" tab appearance.
Definition XTPTabThemeFlat.h:49


Toolkit Pro: Member List

CXTPEditListBox Member List

This is the complete list of members for CXTPEditListBox, including all inherited members.

CreateEditControl(CRect rcItem) | CXTPEditListBox | protectedvirtual
CreateEditGroup(bool bAutoFont=true) | CXTPEditListBox | protectedvirtual
CXTPEditListBox() | CXTPEditListBox |
CXTPListBox() | CXTPListBox |
DeleteItem() | CXTPEditListBox | protectedvirtual
EditItem(int iItem) | CXTPEditListBox |
EditListItem(BOOL bNewItem) | CXTPEditListBox | protectedvirtual
EnableEdit(bool bEnable) | CXTPEditListBox |
GetBackColor() | CXTPListBox | virtual
GetCurrentIndex() | CXTPEditListBox |
GetEditGroup() | CXTPEditListBox |
GetEditItemText() | CXTPEditListBox | virtual
GetListStyle() const | CXTPListBox |
HasFocus() const | CXTPListBox |
HasToolbar() | CXTPEditListBox |
Initialize(bool bAutoFont=true) | CXTPEditListBox | virtual
m_bEnableEdit | CXTPEditListBox | protected
m_bNewItem | CXTPEditListBox | protected
m_dwLStyle | CXTPEditListBox | protected
m_editGroup | CXTPEditListBox | protected
m_nHotItem | CXTPListBox |
m_nIndex | CXTPEditListBox | protected
m_nItemHeight | CXTPListBox |
m_nTextPadding | CXTPListBox |
m_pItemEdit | CXTPEditListBox | protected
m_pParentWnd | CXTPEditListBox | protected
m_pTheme | CXTPListBox |
m_strFilter | CXTPEditListBox | protected
m_strInitialDir | CXTPEditListBox | protected
m_strItemDefaultText | CXTPEditListBox | protected
m_strItemText | CXTPEditListBox | protected
m_strTitle | CXTPEditListBox | protected
m_theme | CXTPListBox |
MoveItemDown(int nIndex) | CXTPEditListBox | virtual
MoveItemUp(int nIndex) | CXTPEditListBox | virtual
RecalcLayout() | CXTPEditListBox | virtual
RefreshMetrics() | CXTPEditListBox | virtual
SetDlgFilter(LPCTSTR lpszFilter=NULL) | CXTPEditListBox |
SetDlgInitialDir(LPCTSTR lpszInitialDir) | CXTPEditListBox |
SetEditText(LPCTSTR pcszText) | CXTPEditListBox |
SetListEditStyle(UINT nTitle, DWORD dwLStyle=LBS_XTP_DEFAULT) | CXTPEditListBox |
SetListEditStyle(LPCTSTR lpszTitle, DWORD dwLStyle=LBS_XTP_DEFAULT) | CXTPEditListBox |
SetListStyle(XTPListBoxStyle style) | CXTPListBox |
SetNewItemDefaultText(LPCTSTR lpszItemDefaultText) | CXTPEditListBox |
SetTheme(XTPControlTheme nTheme) | CXTPListBox |
TryItemFromPoint(CPoint pt, BOOL &bOutside, int &nIndex) const | CXTPListBox | protected
~CXTPEditListBox() | CXTPEditListBox | virtual
~CXTPListBox() | CXTPListBox | virtual


Toolkit Pro: XTPCommandBarsModernUITheme.h Source File

  • Source
  • CommandBars
  • Themes
XTPCommandBarsModernUITheme.h
Go to the documentation of this file.
1
23#if !defined(__XTPCOMMANDBARSMODERNUITHEME_H__)
24# define __XTPCOMMANDBARSMODERNUITHEME_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
40class _XTP_EXT_CLASS CXTPCommandBarsModernUITheme : public CXTPCommandBarsOfficeXPTheme
41{
43 DECLARE_DYNAMIC(CXTPCommandBarsModernUITheme)
45public:
50 CXTPCommandBarsModernUITheme();
51
56 virtual ~CXTPCommandBarsModernUITheme();
57
64 virtual CXTPFramePaintManager* GetFramePaintManager();
65
72 virtual CXTPRibbonPaintManager* GetRibbonPaintManager();
73
80 virtual CXTPMarkupContext* GetMarkupContext();
81
82protected:
87 virtual void RefreshMetrics();
88
89 CXTPMarkupContext* m_pMarkupContext;
90 CXTPResourceImages* m_pImages;
91};
92
94
95AFX_INLINE CXTPFramePaintManager* CXTPCommandBarsModernUITheme::GetFramePaintManager()
96{
97 return m_pFramePaintManager;
98}
99# ifdef _XTP_INCLUDE_RIBBON
100AFX_INLINE CXTPRibbonPaintManager* CXTPCommandBarsModernUITheme::GetRibbonPaintManager()
101{
102 return m_pRibbonPaintManager;
103}
104# else
105AFX_INLINE CXTPRibbonPaintManager* CXTPCommandBarsModernUITheme::GetRibbonPaintManager()
106{
107 return NULL;
108}
109# endif
110AFX_INLINE CXTPMarkupContext* CXTPCommandBarsModernUITheme::GetMarkupContext()
111{
112 return m_pMarkupContext;
113}
114
116# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
117#endif // !defined(__XTPCOMMANDBARSMODERNUITHEME_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCommandBarsModernUITheme
The CXTPCommandBarsModernUITheme class is the base class for the Modern UI themes for Command Bars.
Definition XTPCommandBarsModernUITheme.h:41
CXTPCommandBarsModernUITheme::CXTPCommandBarsModernUITheme
CXTPCommandBarsModernUITheme()
Constructs a CXTPCommandBarsModernUITheme object.
CXTPCommandBarsModernUITheme::m_pImages
CXTPResourceImages * m_pImages
Points to a valid resource images object.
Definition XTPCommandBarsModernUITheme.h:90
CXTPCommandBarsModernUITheme::m_pMarkupContext
CXTPMarkupContext * m_pMarkupContext
Points to a valid markup context object.
Definition XTPCommandBarsModernUITheme.h:89
CXTPCommandBarsModernUITheme::GetFramePaintManager
virtual CXTPFramePaintManager * GetFramePaintManager()
Returns paint manager used to draw frames.
Definition XTPCommandBarsModernUITheme.h:95
CXTPCommandBarsModernUITheme::GetRibbonPaintManager
virtual CXTPRibbonPaintManager * GetRibbonPaintManager()
Retrieves the ribbon paint manager.
Definition XTPCommandBarsModernUITheme.h:105
CXTPCommandBarsModernUITheme::RefreshMetrics
virtual void RefreshMetrics()
This method is called to refresh the visual metrics of the manager.
CXTPCommandBarsModernUITheme::GetMarkupContext
virtual CXTPMarkupContext * GetMarkupContext()
Retrieves a pointer to the markup context.
Definition XTPCommandBarsModernUITheme.h:110
CXTPCommandBarsModernUITheme::~CXTPCommandBarsModernUITheme
virtual ~CXTPCommandBarsModernUITheme()
Destroys a CXTPCommandBarsModernUITheme object, handles cleanup and deallocation.
CXTPCommandBarsOfficeXPTheme
The CXTPCommandBarsOfficeXPTheme class is used to enable an Office XP style theme for Command Bars.
Definition XTPCommandBarsOfficeXPTheme.h:41
CXTPFramePaintManager
Paint manager for the Office 2007 style window frame.
Definition XTPFramePaintManager.h:41
CXTPMarkupContext
CXTPMarkupContext is a standalone class used to provide common settings for Markup objects.
Definition XTPMarkupContext.h:128
CXTPPaintManager::GetFramePaintManager
virtual CXTPFramePaintManager * GetFramePaintManager()
Retrieves paint manager used to draw frames.
CXTPPaintManager::GetRibbonPaintManager
virtual CXTPRibbonPaintManager * GetRibbonPaintManager()
Retrieves the ribbon paint manager.
CXTPPaintManager::m_pFramePaintManager
CXTPFramePaintManager * m_pFramePaintManager
Frame paint manager.
Definition XTPPaintManager.h:1514
CXTPPaintManager::m_pRibbonPaintManager
CXTPRibbonPaintManager * m_pRibbonPaintManager
Ribbon paint Manager.
Definition XTPPaintManager.h:1516
CXTPResourceImages
Implements resource image collection and its operations.
Definition XTPResourceImage.h:257
CXTPRibbonPaintManager
Standalone class used by CXTPRibbonBar as a paint manager.
Definition XTPRibbonPaintManager.h:51


Toolkit Pro: XTPPropertyGridDefines.h Source File

  • Source
  • PropertyGrid
XTPPropertyGridDefines.h
Go to the documentation of this file.
1
23#if !defined(__XTPPROPERTYGRIDDEFINES_H__)
24# define __XTPPROPERTYGRIDDEFINES_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31// Added for Grid theme constants backward compatibility
32# include "GridControl/XTPGridDefines.h"
33
34# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
35
47enum XTPPropertyGridSortOrder
48{
49 xtpPropertyGridSortCategorized,
50 xtpPropertyGridSortAlphabetical,
51 xtpPropertyGridSortNoSort,
54};
55
57_XTP_DEPRECATED_IN_FAVOR(xtpPropertyGridSortCategorized)
58const XTPPropertyGridSortOrder xtpGridSortCategorized = xtpPropertyGridSortCategorized;
59
60_XTP_DEPRECATED_IN_FAVOR(xtpPropertyGridSortAlphabetical)
61const XTPPropertyGridSortOrder xtpGridSortAlphabetical = xtpPropertyGridSortAlphabetical;
62
63_XTP_DEPRECATED_IN_FAVOR(xtpPropertyGridSortNoSort)
64const XTPPropertyGridSortOrder xtpGridSortNoSort = xtpPropertyGridSortNoSort;
76enum XTPPropertyGridPaintTheme
77{
78 xtpPropertyGridThemeDefault,
79 xtpPropertyGridThemeOfficeXP,
80 xtpPropertyGridThemeOffice2003,
81 xtpPropertyGridThemeOffice2013,
82 xtpPropertyGridThemeOffice2016 = xtpPropertyGridThemeOffice2013,
84 xtpPropertyGridThemeVisualStudio2012Light,
85 xtpPropertyGridThemeVisualStudio2012Dark,
86 xtpPropertyGridThemeVisualStudio2015,
87 xtpPropertyGridThemeResource,
88 xtpPropertyGridThemeNativeWindows10,
89 xtpPropertyGridThemeVisualStudio2017,
90 xtpPropertyGridThemeVisualStudio2019,
91 xtpPropertyGridThemeVisualStudio2022,
92 xtpPropertyGridThemeNativeWindows11,
94 xtpPropertyGridThemeNativeWinXP = 100,
95 xtpPropertyGridThemeCool,
96 xtpPropertyGridThemeSimple,
97 xtpPropertyGridThemeDelphi,
98 xtpPropertyGridThemeVisualStudio2005,
99 xtpPropertyGridThemeVisualStudio2010,
102 xtpPropertyGridThemeWhidbey = xtpPropertyGridThemeVisualStudio2005,
103 xtpPropertyGridThemeOffice2007 = xtpPropertyGridThemeResource,
105};
106
108_XTP_DEPRECATED_IN_FAVOR(xtpPropertyGridThemeNativeWinXP)
109const XTPPropertyGridPaintTheme xtpGridThemeNativeWinXP = xtpPropertyGridThemeNativeWinXP;
110
111_XTP_DEPRECATED_IN_FAVOR(xtpPropertyGridThemeCool)
112const XTPPropertyGridPaintTheme xtpGridThemeCool = xtpPropertyGridThemeCool;
113
114_XTP_DEPRECATED_IN_FAVOR(xtpPropertyGridThemeSimple)
115const XTPPropertyGridPaintTheme xtpGridThemeSimple = xtpPropertyGridThemeSimple;
116
117_XTP_DEPRECATED_IN_FAVOR(xtpPropertyGridThemeDelphi)
118const XTPPropertyGridPaintTheme xtpGridThemeDelphi = xtpPropertyGridThemeDelphi;
119
120_XTP_DEPRECATED_IN_FAVOR(xtpPropertyGridThemeVisualStudio2005)
121const XTPPropertyGridPaintTheme xtpGridThemeVisualStudio2005 = xtpPropertyGridThemeVisualStudio2005;
122
123_XTP_DEPRECATED_IN_FAVOR(xtpPropertyGridThemeVisualStudio2010)
124const XTPPropertyGridPaintTheme xtpGridThemeVisualStudio2010 = xtpPropertyGridThemeVisualStudio2010;
125
126_XTP_DEPRECATED_IN_FAVOR(xtpPropertyGridThemeVisualStudio2005)
127const XTPPropertyGridPaintTheme xtpGridThemeWhidbey = xtpPropertyGridThemeVisualStudio2005;
128
129_XTP_DEPRECATED_IN_FAVOR(xtpPropertyGridThemeResource)
130const XTPPropertyGridPaintTheme xtpGridThemeOffice2007 = xtpPropertyGridThemeResource;
142enum XTPPropertyGridBorderStyle
143{
144 xtpPropertyGridBorderNone,
145 xtpPropertyGridBorderFlat,
146 xtpPropertyGridBorderStaticEdge,
147 xtpPropertyGridBorderClientEdge,
148};
149
151_XTP_DEPRECATED_IN_FAVOR(xtpPropertyGridBorderNone)
152const XTPPropertyGridBorderStyle xtpGridBorderNone = xtpPropertyGridBorderNone;
153
154_XTP_DEPRECATED_IN_FAVOR(xtpPropertyGridBorderFlat)
155const XTPPropertyGridBorderStyle xtpGridBorderFlat = xtpPropertyGridBorderFlat;
156
157_XTP_DEPRECATED_IN_FAVOR(xtpPropertyGridBorderStaticEdge)
158const XTPPropertyGridBorderStyle xtpGridBorderStaticEdge = xtpPropertyGridBorderStaticEdge;
159
160_XTP_DEPRECATED_IN_FAVOR(xtpPropertyGridBorderClientEdge)
161const XTPPropertyGridBorderStyle xtpGridBorderClientEdge = xtpPropertyGridBorderClientEdge;
173enum XTPPropertyGridInplaceButtonsStyle
174{
175 xtpPropertyGridButtonsDefault,
176 xtpPropertyGridButtonsThemed,
177 xtpPropertyGridButtonsOfficeXP,
178};
179
181_XTP_DEPRECATED_IN_FAVOR(xtpPropertyGridButtonsDefault)
182const XTPPropertyGridInplaceButtonsStyle xtpGridButtonsDefault = xtpPropertyGridButtonsDefault;
183
184_XTP_DEPRECATED_IN_FAVOR(xtpPropertyGridButtonsThemed)
185const XTPPropertyGridInplaceButtonsStyle xtpGridButtonsThemed = xtpPropertyGridButtonsThemed;
186
187_XTP_DEPRECATED_IN_FAVOR(xtpPropertyGridButtonsOfficeXP)
188const XTPPropertyGridInplaceButtonsStyle xtpGridButtonsOfficeXP = xtpPropertyGridButtonsOfficeXP;
191class CXTPPropertyGridItem;
192
193//-----------------------------------------------------------------------
194// Summary:
195// The XTPWM_PROPERTYGRID_NOTIFY message is sent to the CXTPPropertyGrid
196// owner window whenever an action occurs within the CXTPPropertyGrid.
197//
198// <code>XTPWM_PROPERTYGRID_NOTIFY
199// nGridAction = (int) wParam; // Property grid action
200// pItem = (CXTPPropertyGridItem*) lParam; // pointer to a CXTPPropertyGridItem object</code>
201//
202// When the user performs an action in the property grid, the XTPWM_PROPERTYGRID_NOTIFY
203// message is sent to the property grid's owner window.
204// Parameters:
205// nGridAction - Value of wParam that specifies a value that indicates the user's request.
206// pItem - Value of lParam that points to a CXTPPropertyGridItem object
207// that contains information for the specified item.
208// This pointer should <b>never</b> be NULL.
209// Returns:
210// If the application is to process this message, the return value should be TRUE.
211// Otherwise, the return value should be FALSE.
212// Remarks:
213// The nGridAction parameter can be one of the following values:
214// * <b>XTP_PGN_SORTORDER_CHANGED</b>: The sort order has changed in the property grid.
215// * <b>XTP_PGN_SELECTION_CHANGED</b>: The selection has changed in the property grid.
216// * <b>XTP_PGN_ITEMVALUE_CHANGED</b>: The value has changed for pItem in the
217// property grid.
218// * <b>XTP_PGN_EDIT_CHANGED</b>: The edit value has changed in the property grid.
219// * <b>XTP_PGN_INPLACEBUTTONDOWN</b>: The item's in-place button (combo/expand) is down.
220// * <b>XTP_PGN_ITEMEXPANDCHANGED</b>: The user expanded or collapsed the item.
221// * <b>XTP_PGN_DBLCLICK</b>: The user double-clicked the left mouse button in the
222// property grid.
223// * <b>XTP_PGN_RCLICK</b>: The user pressed the right mouse button in the property grid.
224// * <b>XTP_PGN_VERB_CLICK</b>: The user clicked a verb in the property grid.
225// * <b>XTP_PGN_REQUESTEDIT</b>: The user is changing the value of the item.
226//
227// Example:
228// Here is an example of how an application would process the
229// XTPWM_PROPERTYGRID_NOTIFY message:
230//
231// <code>
232// int nGridAction = (int)wParam;
233//
234//
235// switch (nGridAction)
236// {
237// case XTP_PGN_SORTORDER_CHANGED:
238// {
239// m_nSort = m_wndXTPPropertyGrid.GetPropertySort();
240// UpdateData(FALSE);
241// }
242// break;
243// case XTP_PGN_ITEMVALUE_CHANGED:
244// {
245// CXTPPropertyGridItem* pItem = (CXTPPropertyGridItem*)lParam;
246// TRACE(_T("Value Changed. Caption = %s, ID = %i, Value = %s\n"),
247// pItem->GetCaption(), pItem->GetID(), pItem->GetValue());
248// }
249// break;
250// case XTP_PGN_SELECTION_CHANGED:
251// {
252// CXTPPropertyGridItem* pItem = (CXTPPropertyGridItem*)lParam;
253// TRACE(_T("Selection Changed. Item = %s\n"), pItem->GetCaption());
254// }
255// case XTP_PGN_INPLACEBUTTONDOWN:
256// {
257// CXTPPropertyGridInplaceButton* pButton = (CXTPPropertyGridInplaceButton*)lParam;
258// }
259// break;
260// }
261// return FALSE;
262// </code>
263//-----------------------------------------------------------------------
264const UINT XTPWM_PROPERTYGRID_NOTIFY = (WM_USER + 9950 + 1);
265
266const UINT XTP_PGN_SORTORDER_CHANGED = 1;
267const UINT XTP_PGN_SELECTION_CHANGED = 2;
268const UINT XTP_PGN_ITEMVALUE_CHANGED = 3;
269const UINT XTP_PGN_EDIT_CHANGED = 4;
270const UINT XTP_PGN_INPLACEBUTTONDOWN = 5;
271const UINT XTP_PGN_DRAWITEM = 6;
272const UINT XTP_PGN_ITEMEXPANDCHANGED = 7;
273const UINT XTP_PGN_DBLCLICK = 8;
274const UINT XTP_PGN_RCLICK = 9;
275const UINT XTP_PGN_VERB_CLICK = 10;
277const UINT XTP_PGN_REQUESTEDIT = 11;
278const UINT XTP_PGN_AFTEREDIT = 12;
279const UINT XTP_PGN_CANCELEDIT = 13;
280const UINT XTP_PGN_VSCROLL = 14;
281const UINT XTP_PGN_USER = 15;
290struct XTP_PROPERTYGRID_NOTIFYEDIT
291{
292 BOOL bCancel;
293 CString strValue;
294 CXTPPropertyGridItem* pItem;
295};
296
309const UINT XTP_PGS_OWNERDRAW = 0x0010L;
310
349const TCHAR XTPPROPERTYGRID_CLASSNAME[] = _T("XTPPropertyGrid");
351# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
352#endif //#define __XTPPROPERTYGRIDDEFINES_H__
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPGridDefines.h
XTP_PGN_USER
const UINT XTP_PGN_USER
Definition XTPPropertyGridDefines.h:281
XTPPropertyGridSortOrder
XTPPropertyGridSortOrder
XTPPropertyGridSortOrder is an enumeration used by CXTPPropertyGrid to determine the grouping style.
Definition XTPPropertyGridDefines.h:48
xtpPropertyGridSortNoSort
@ xtpPropertyGridSortNoSort
Disable sorting and grouping; all items are displayed in the order that they are added to the grid.
Definition XTPPropertyGridDefines.h:51
xtpPropertyGridSortCategorized
@ xtpPropertyGridSortCategorized
Group items by category.
Definition XTPPropertyGridDefines.h:49
xtpPropertyGridSortAlphabetical
@ xtpPropertyGridSortAlphabetical
Sort items alphabetically.
Definition XTPPropertyGridDefines.h:50
XTP_PGN_SELECTION_CHANGED
const UINT XTP_PGN_SELECTION_CHANGED
Definition XTPPropertyGridDefines.h:267
XTP_PGN_AFTEREDIT
const UINT XTP_PGN_AFTEREDIT
Definition XTPPropertyGridDefines.h:278
XTP_PGN_VERB_CLICK
const UINT XTP_PGN_VERB_CLICK
Definition XTPPropertyGridDefines.h:275
XTP_PGN_ITEMEXPANDCHANGED
const UINT XTP_PGN_ITEMEXPANDCHANGED
Definition XTPPropertyGridDefines.h:272
XTP_PGN_DRAWITEM
const UINT XTP_PGN_DRAWITEM
Definition XTPPropertyGridDefines.h:271
XTPPropertyGridBorderStyle
XTPPropertyGridBorderStyle
Border Style enumeration.
Definition XTPPropertyGridDefines.h:143
xtpPropertyGridBorderClientEdge
@ xtpPropertyGridBorderClientEdge
Client edge.
Definition XTPPropertyGridDefines.h:147
xtpPropertyGridBorderNone
@ xtpPropertyGridBorderNone
Without borders.
Definition XTPPropertyGridDefines.h:144
xtpPropertyGridBorderStaticEdge
@ xtpPropertyGridBorderStaticEdge
Static edge.
Definition XTPPropertyGridDefines.h:146
xtpPropertyGridBorderFlat
@ xtpPropertyGridBorderFlat
Black flat borders.
Definition XTPPropertyGridDefines.h:145
XTP_PGN_ITEMVALUE_CHANGED
const UINT XTP_PGN_ITEMVALUE_CHANGED
Definition XTPPropertyGridDefines.h:268
XTPPROPERTYGRID_CLASSNAME
const TCHAR XTPPROPERTYGRID_CLASSNAME[]
A NULL-terminated string used by CXTPPropertyGrid which specifies the window class name for the prope...
Definition XTPPropertyGridDefines.h:349
XTP_PGS_OWNERDRAW
const UINT XTP_PGS_OWNERDRAW
Apply this style to the property grid to use the owner draw feature.
Definition XTPPropertyGridDefines.h:309
XTP_PGN_DBLCLICK
const UINT XTP_PGN_DBLCLICK
Definition XTPPropertyGridDefines.h:273
XTPPropertyGridInplaceButtonsStyle
XTPPropertyGridInplaceButtonsStyle
In-place Button Style enumeration.
Definition XTPPropertyGridDefines.h:174
xtpPropertyGridButtonsDefault
@ xtpPropertyGridButtonsDefault
Default button style.
Definition XTPPropertyGridDefines.h:175
xtpPropertyGridButtonsThemed
@ xtpPropertyGridButtonsThemed
Themed button style.
Definition XTPPropertyGridDefines.h:176
xtpPropertyGridButtonsOfficeXP
@ xtpPropertyGridButtonsOfficeXP
Office XP button style.
Definition XTPPropertyGridDefines.h:177
XTP_PGN_REQUESTEDIT
const UINT XTP_PGN_REQUESTEDIT
Definition XTPPropertyGridDefines.h:277
XTP_PGN_VSCROLL
const UINT XTP_PGN_VSCROLL
Definition XTPPropertyGridDefines.h:280
XTP_PGN_EDIT_CHANGED
const UINT XTP_PGN_EDIT_CHANGED
Definition XTPPropertyGridDefines.h:269
XTP_PGN_CANCELEDIT
const UINT XTP_PGN_CANCELEDIT
Definition XTPPropertyGridDefines.h:279
XTP_PGN_INPLACEBUTTONDOWN
const UINT XTP_PGN_INPLACEBUTTONDOWN
Definition XTPPropertyGridDefines.h:270
XTP_PGN_SORTORDER_CHANGED
const UINT XTP_PGN_SORTORDER_CHANGED
Definition XTPPropertyGridDefines.h:266
XTP_PGN_RCLICK
const UINT XTP_PGN_RCLICK
Definition XTPPropertyGridDefines.h:274
XTPPropertyGridPaintTheme
XTPPropertyGridPaintTheme
Visual Theme enumeration.
Definition XTPPropertyGridDefines.h:77
xtpPropertyGridThemeCool
@ xtpPropertyGridThemeCool
Cool theme.
Definition XTPPropertyGridDefines.h:95
xtpPropertyGridThemeVisualStudio2005
@ xtpPropertyGridThemeVisualStudio2005
Visual Studio 2005 style theme.
Definition XTPPropertyGridDefines.h:98
xtpPropertyGridThemeSimple
@ xtpPropertyGridThemeSimple
Visual Basic style theme.
Definition XTPPropertyGridDefines.h:96
xtpPropertyGridThemeNativeWindows10
@ xtpPropertyGridThemeNativeWindows10
Native Windows 10 style theme.
Definition XTPPropertyGridDefines.h:88
xtpPropertyGridThemeVisualStudio2022
@ xtpPropertyGridThemeVisualStudio2022
Visual Studio 2022 style theme.
Definition XTPPropertyGridDefines.h:91
xtpPropertyGridThemeOffice2013
@ xtpPropertyGridThemeOffice2013
Office 2013 style theme.
Definition XTPPropertyGridDefines.h:81
xtpPropertyGridThemeVisualStudio2019
@ xtpPropertyGridThemeVisualStudio2019
Visual Studio 2019 style theme.
Definition XTPPropertyGridDefines.h:90
xtpPropertyGridThemeVisualStudio2015
@ xtpPropertyGridThemeVisualStudio2015
Visual Studio 2015 Light style theme.
Definition XTPPropertyGridDefines.h:86
xtpPropertyGridThemeNativeWindows11
@ xtpPropertyGridThemeNativeWindows11
Native Windows 11 style theme.
Definition XTPPropertyGridDefines.h:92
xtpPropertyGridThemeVisualStudio2010
@ xtpPropertyGridThemeVisualStudio2010
Visual Studio 2010 style theme.
Definition XTPPropertyGridDefines.h:99
xtpPropertyGridThemeVisualStudio2012Light
@ xtpPropertyGridThemeVisualStudio2012Light
Visual Studio 2012 Light style theme.
Definition XTPPropertyGridDefines.h:84
xtpPropertyGridThemeResource
@ xtpPropertyGridThemeResource
Office 2007 / 2010 style theme.
Definition XTPPropertyGridDefines.h:87
xtpPropertyGridThemeOffice2016
@ xtpPropertyGridThemeOffice2016
Office 2016 style theme.
Definition XTPPropertyGridDefines.h:82
xtpPropertyGridThemeDelphi
@ xtpPropertyGridThemeDelphi
Delphi style theme.
Definition XTPPropertyGridDefines.h:97
xtpPropertyGridThemeOffice2003
@ xtpPropertyGridThemeOffice2003
Office 2003 style theme.
Definition XTPPropertyGridDefines.h:80
xtpPropertyGridThemeVisualStudio2012Dark
@ xtpPropertyGridThemeVisualStudio2012Dark
Visual Studio 2012 Dark style theme.
Definition XTPPropertyGridDefines.h:85
xtpPropertyGridThemeOfficeXP
@ xtpPropertyGridThemeOfficeXP
Office XP style theme.
Definition XTPPropertyGridDefines.h:79
xtpPropertyGridThemeDefault
@ xtpPropertyGridThemeDefault
Default theme.
Definition XTPPropertyGridDefines.h:78
xtpPropertyGridThemeVisualStudio2017
@ xtpPropertyGridThemeVisualStudio2017
Visual Studio 2017 style theme.
Definition XTPPropertyGridDefines.h:89
xtpPropertyGridThemeNativeWinXP
@ xtpPropertyGridThemeNativeWinXP
WinXP style theme.
Definition XTPPropertyGridDefines.h:94
CXTPPropertyGridItem
CXTPPropertyGridItem is the base class representing an item of the Property Grid control.
Definition XTPPropertyGridItem.h:523
XTP_PROPERTYGRID_NOTIFYEDIT
This struct is passed with XTP_PGN_REQUESTEDIT, XTP_PGN_AFTEREDIT, and XTP_PGN_CANCELEDIT notificatio...
Definition XTPPropertyGridDefines.h:291
XTP_PROPERTYGRID_NOTIFYEDIT::bCancel
BOOL bCancel
TRUE to cancel user edit.
Definition XTPPropertyGridDefines.h:292
XTP_PROPERTYGRID_NOTIFYEDIT::pItem
CXTPPropertyGridItem * pItem
Item to be edited.
Definition XTPPropertyGridDefines.h:294
XTP_PROPERTYGRID_NOTIFYEDIT::strValue
CString strValue
New caption value to be set.
Definition XTPPropertyGridDefines.h:293


Toolkit Pro: Member List

CXTPColorSetStateButton Member List

This is the complete list of members for CXTPColorSetStateButton, including all inherited members.

clrBack | CXTPColorSetStateButton |
clrBackChecked | CXTPColorSetStateButton |
clrBackCheckedHighlight | CXTPColorSetStateButton |
clrBackDisabled | CXTPColorSetStateButton |
clrBackHighlight | CXTPColorSetStateButton |
clrBackPushed | CXTPColorSetStateButton |
clrBorder | CXTPColorSetStateButton |
clrBorderChecked | CXTPColorSetStateButton |
clrBorderCheckedHighlight | CXTPColorSetStateButton |
clrBorderDisabled | CXTPColorSetStateButton |
clrBorderHighlight | CXTPColorSetStateButton |
clrBorderPushed | CXTPColorSetStateButton |
clrText | CXTPColorSetStateButton |
clrTextChecked | CXTPColorSetStateButton |
clrTextCheckedHighlight | CXTPColorSetStateButton |
clrTextDisabled | CXTPColorSetStateButton |
clrTextHighlight | CXTPColorSetStateButton |
clrTextPushed | CXTPColorSetStateButton |
CXTPCmdTarget() | CXTPCmdTarget |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
RefreshColors()=0 | CXTPColorSetStateButton | pure virtual


Toolkit Pro: Member List

CXTPFrameThemeOffice2007System Member List

This is the complete list of members for CXTPFrameThemeOffice2007System, including all inherited members.

CalcFrameBorder(const CXTPCommandBarsFrameHook *pFrameHook) const | CXTPFrameThemeOffice2007System | virtual
CalcFrameCaption(const CXTPCommandBarsFrameHook *pFrameHook) const | CXTPFramePaintManager | virtual
CalcFrameRegion(CXTPCommandBarsFrameHook *pFrameHook, CSize sz) const | CXTPFrameThemeOffice2007System | virtual
CreateShadow(CWnd *pFrame) | CXTPFramePaintManager | virtual
CXTPFramePaintManager(CXTPPaintManager *pPaintManager) | CXTPFramePaintManager |
CXTPFrameThemeOffice2007System(CXTPPaintManager *pPaintManager) | CXTPFrameThemeOffice2007System |
CXTPRibbonMarkupFrameTheme(CXTPPaintManager *pPaintManager) | CXTPRibbonMarkupFrameTheme |
DrawCaptionBar(CDC *pDC, CRect rcCaptionBar, CWnd *pSite, BOOL bActive) | CXTPFrameThemeOffice2007System | virtual
DrawCaptionText(CDC *pDC, CRect rcCaptionText, CWnd *pSite, BOOL bActive) | CXTPFramePaintManager | virtual
DrawCaptionText(CDC *pDC, CRect rcCaptionText, CWnd *pSite, BOOL bActive, CXTPRibbonBar *pRibbonBar) | CXTPFramePaintManager | virtual
DrawFrame(CDC *pDC, CXTPCommandBarsFrameHook *pFrameHook) | CXTPRibbonMarkupFrameTheme | virtual
DrawFrameBorder(CDC *pDC, CXTPCommandBarsFrameHook *pFrameHook) | CXTPRibbonMarkupFrameTheme | virtual
DrawFrameCaptionButton(CDC *pDC, CRect rc, int nId, BOOL bSelected, BOOL bPressed, BOOL bActive) | CXTPFrameThemeOffice2007System | virtual
DrawFrameCaptionButton(CDC *pDC, CRect rc, int nId, BOOL bSelected, BOOL bPressed, BOOL bActive, CXTPRibbonBar *pRibbonBar) | CXTPFrameThemeOffice2007System | virtual
GetFrameBorder(int nId, BOOL bActive) | CXTPFrameThemeOffice2007System | virtual
GetFrameCaptionAccentTextColor(BOOL bActive) const | CXTPFramePaintManager | virtual
GetFrameCaptionActiveColor() const | CXTPFramePaintManager |
GetFrameCaptionHeight() const | CXTPFramePaintManager | virtual
GetFrameLargeIcon(CWnd *pFrame) | CXTPFramePaintManager |
GetFrameSmallIcon(CWnd *pFrame) | CXTPFramePaintManager |
GetImages() const | CXTPFramePaintManager |
IsUseSystemAccentColorEnabled() const | CXTPFramePaintManager |
LoadImage(LPCTSTR lpszFileName) | CXTPFramePaintManager |
LoadParts(HZIP hZip, CXTPMarkupContext *pMarkupContext) | CXTPFrameThemeOffice2007System | virtual
LoadParts(BOOL bReload=FALSE) | CXTPFrameThemeOffice2007System | virtual
m_bCaptionCenterAligned | CXTPFramePaintManager |
m_bFlatFrame | CXTPFramePaintManager |
m_bFrameStatusBar | CXTPFramePaintManager |
m_bMarkupPartsLoaded | CXTPFrameThemeOffice2007System | protected
m_clrFrameCaptionActive | CXTPFramePaintManager | protected
m_clrFrameCaptionInactive | CXTPFramePaintManager | protected
m_clrFrameCaptionTextActive | CXTPFramePaintManager | protected
m_clrFrameCaptionTextActiveBSMode | CXTPFramePaintManager | protected
m_clrFrameCaptionTextActiveTitle | CXTPFramePaintManager | protected
m_clrFrameCaptionTextActiveTitleBSMode | CXTPFramePaintManager | protected
m_clrFrameCaptionTextInactive | CXTPFramePaintManager | protected
m_clrFrameCaptionTextInactiveBSMode | CXTPFramePaintManager | protected
m_fntFrameCaption | CXTPFramePaintManager |
m_hIcon | CXTPFramePaintManager | protected
m_nFrameCaptionHeight | CXTPFramePaintManager |
m_pMarkupContext | CXTPFrameThemeOffice2007System | protected
m_pPaintManager | CXTPFramePaintManager |
m_rcIconMargin | CXTPFramePaintManager | protected
m_szIcon | CXTPFramePaintManager | protected
OnShadowedFrameActiveStateChanged(BOOL bActive, CWnd *pFrame, CXTPFrameShadow *pShadow) | CXTPFramePaintManager | virtual
RefreshMetrics() | CXTPFrameThemeOffice2007System | virtual
ReloadMarkupParts(HZIP hZip, CXTPMarkupContext *pMarkupContext) | CXTPRibbonMarkupFrameTheme |
SetIcon(HICON hIcon, CSize szIcon) | CXTPFramePaintManager |
XTPBorderPart enum name | CXTPRibbonMarkupFrameTheme | protected
xtpBorderPartBottom enum value | CXTPRibbonMarkupFrameTheme | protected
xtpBorderPartCount enum value | CXTPRibbonMarkupFrameTheme | protected
xtpBorderPartLeft enum value | CXTPRibbonMarkupFrameTheme | protected
xtpBorderPartLeftCaption enum value | CXTPRibbonMarkupFrameTheme | protected
xtpBorderPartRight enum value | CXTPRibbonMarkupFrameTheme | protected
xtpBorderPartRightCaption enum value | CXTPRibbonMarkupFrameTheme | protected
xtpBorderPartTop enum value | CXTPRibbonMarkupFrameTheme | protected
~CXTPFramePaintManager() | CXTPFramePaintManager | virtual
~CXTPFrameThemeOffice2007System() | CXTPFrameThemeOffice2007System | virtual
~CXTPRibbonMarkupFrameTheme() | CXTPRibbonMarkupFrameTheme | virtual


Toolkit Pro: Member List

CXTPMarkupStaticExtensionBrushProperty Member List

This is the complete list of members for CXTPMarkupStaticExtensionBrushProperty, including all inherited members.

CXTPMarkupStaticExtension(LPCWSTR lpzName, BOOL bProperty) | CXTPMarkupStaticExtension | protected
CXTPMarkupStaticExtension(LPCWSTR lpzName) | CXTPMarkupStaticExtension |
CXTPMarkupStaticExtensionBrushProperty(LPCWSTR lpzName, COLORREF crValue=RGB(0, 0, 0)) | CXTPMarkupStaticExtensionBrushProperty |
CXTPMarkupStaticExtensionBrushProperty(LPCWSTR lpzName, COLORREF crValue, BYTE bAlpha) | CXTPMarkupStaticExtensionBrushProperty |
CXTPMarkupStaticExtensionProperty(LPCWSTR lpzName, CXTPMarkupObject *pObject=NULL) | CXTPMarkupStaticExtensionProperty |
Extend(CXTPMarkupStaticExtension *pExtension, BOOL bReplace=FALSE) | CXTPMarkupStaticExtension |
FindExtension(LPCWSTR lpzName) const | CXTPMarkupStaticExtension |
GetName() const | CXTPMarkupStaticExtension |
GetRawValue() const | CXTPMarkupStaticExtensionBrushProperty |
GetValue() | CXTPMarkupStaticExtensionProperty |
IsProperty() const | CXTPMarkupStaticExtension |
OnPrepareValue() | CXTPMarkupStaticExtension | inlineprotectedvirtual
Parse(LPCWSTR lpzValue, LPCWSTR &lpzSubValue) | CXTPMarkupStaticExtension | static
ProvideValue() | CXTPMarkupStaticExtensionProperty | virtual
ProvideValue(LPCWSTR lpzValue) | CXTPMarkupStaticExtensionProperty | virtual
SetValue(COLORREF crValue) | CXTPMarkupStaticExtensionBrushProperty |
SetValue(COLORREF crValue, BYTE bAlpha) | CXTPMarkupStaticExtensionBrushProperty |
CXTPMarkupStaticExtensionProperty::SetValue(CXTPMarkupObject *pObject) | CXTPMarkupStaticExtensionProperty |
~CXTPMarkupStaticExtension() | CXTPMarkupStaticExtension | virtual
~CXTPMarkupStaticExtensionProperty() | CXTPMarkupStaticExtensionProperty |


Toolkit Pro: XTPCommandBarsVisualStudio2010Theme.h Source File

  • Source
  • CommandBars
  • Themes
XTPCommandBarsVisualStudio2010Theme.h
Go to the documentation of this file.
1
23#if !defined(__XTPCOMMANDBARSVISUALSTUDIO2010THEME_H__)
24# define __XTPCOMMANDBARSVISUALSTUDIO2010THEME_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
40class _XTP_EXT_CLASS CXTPVisualStudio2010Theme : public CXTPCommandBarsOffice2003Theme
41{
42public:
47 CXTPVisualStudio2010Theme();
48
53 virtual ~CXTPVisualStudio2010Theme();
54
59 void RefreshMetrics();
60
61public:
69 virtual CRect GetCommandBarBorders(CXTPCommandBar* pBar);
70
83 virtual void DrawPopupBarGripper(CDC* pDC, int xPos, int yPos, int cx, int cy, BOOL bExpanded);
84
98 virtual void DrawRectangle(CDC* pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled,
99 BOOL bChecked, BOOL bPopuped, XTPBarType barType,
100 XTPBarPosition barPosition);
101
116 virtual void DrawRectangle(CDC* pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled,
117 BOOL bChecked, BOOL bPopuped, XTPBarType barType,
118 XTPBarPosition barPosition, int nID);
119
128 virtual BOOL DrawRectangle(CDC* pDC, CXTPControl* pButton);
129
143 virtual COLORREF GetRectangleTextColor(BOOL bSelected, BOOL bPressed, BOOL bEnabled,
144 BOOL bChecked, BOOL bPopuped, XTPBarType barType,
145 XTPBarPosition barPosition);
146
154 virtual void AdjustExcludeRect(CRect& rc, CXTPControl* pControl, BOOL bVertical);
155
166 virtual CSize DrawCommandBarSeparator(CDC* pDC, CXTPCommandBar* pBar, CXTPControl* pControl,
167 BOOL bDraw);
168
169 virtual void FillCommandBarEntry(CDC* pDC, CXTPCommandBar* pBar);
170
171protected:
172public:
179 virtual XTPPaintTheme BaseTheme()
180 {
181 return xtpThemeVisualStudio2010;
182 }
183
184public:
185 CXTPPaintManagerColor m_clrMenuSeparator;
186};
187
189# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
190#endif // !defined(__XTPCOMMANDBARSVISUALSTUDIO2010THEME_H__)
XTPBarType
XTPBarType
Type of the command bar.
Definition XTPCommandBarsDefines.h:77
XTPBarPosition
XTPBarPosition
Position of the command bar.
Definition XTPCommandBarsDefines.h:52
XTPPaintTheme
XTPPaintTheme
Paint themes used by command bars.
Definition XTPCommandBarsDefines.h:233
xtpThemeVisualStudio2010
@ xtpThemeVisualStudio2010
Visual Studio 2010 theme.
Definition XTPCommandBarsDefines.h:244
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCommandBar
CXTPCommandBar is a CWnd derived class.
Definition XTPCommandBar.h:66
CXTPCommandBarsOffice2003Theme
The CXTPCommandBarsOffice2003Theme class is used to enable an Office 2003 style theme for Command Bar...
Definition XTPCommandBarsOffice2003Theme.h:41
CXTPControl
CXTPControl is a CXTPCmdTarget derived class.
Definition XTPControl.h:841
CXTPPaintManagerColor
The CXTPPaintManagerColor class is used to manage COLORREF values for determining default and applica...
Definition XTPColorManager.h:117
CXTPVisualStudio2010Theme
The CXTPVisualStudio2010Theme class is used to enable a Visual Studio 2010 style theme for Command Ba...
Definition XTPCommandBarsVisualStudio2010Theme.h:41
CXTPVisualStudio2010Theme::DrawPopupBarGripper
virtual void DrawPopupBarGripper(CDC *pDC, int xPos, int yPos, int cx, int cy, BOOL bExpanded)
This method is called to draw a pop-up bar's right gripper.
CXTPVisualStudio2010Theme::~CXTPVisualStudio2010Theme
virtual ~CXTPVisualStudio2010Theme()
Destroys a CXTPVisualStudio2008Theme object, handles cleanup and deallocation.
CXTPVisualStudio2010Theme::DrawCommandBarSeparator
virtual CSize DrawCommandBarSeparator(CDC *pDC, CXTPCommandBar *pBar, CXTPControl *pControl, BOOL bDraw)
This method is called to draw a command bar's separator.
CXTPVisualStudio2010Theme::GetCommandBarBorders
virtual CRect GetCommandBarBorders(CXTPCommandBar *pBar)
This method is called to retrieve the command bar's borders.
CXTPVisualStudio2010Theme::GetRectangleTextColor
virtual COLORREF GetRectangleTextColor(BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition)
This method retrieves a button's text color.
CXTPVisualStudio2010Theme::DrawRectangle
virtual BOOL DrawRectangle(CDC *pDC, CXTPControl *pButton)
This method is called to fill the control's face.
CXTPVisualStudio2010Theme::AdjustExcludeRect
virtual void AdjustExcludeRect(CRect &rc, CXTPControl *pControl, BOOL bVertical)
This method is called to determine the offset of a pop-up bar.
CXTPVisualStudio2010Theme::FillCommandBarEntry
virtual void FillCommandBarEntry(CDC *pDC, CXTPCommandBar *pBar)
This method is called to fill the command bar's face.
CXTPVisualStudio2010Theme::CXTPVisualStudio2010Theme
CXTPVisualStudio2010Theme()
Constructs a CXTPVisualStudio2008Theme object.
CXTPVisualStudio2010Theme::BaseTheme
virtual XTPPaintTheme BaseTheme()
Retrieves the base theme of the manager.
Definition XTPCommandBarsVisualStudio2010Theme.h:179
CXTPVisualStudio2010Theme::RefreshMetrics
void RefreshMetrics()
This method is called to refresh the visual metrics of the manager.
CXTPVisualStudio2010Theme::DrawRectangle
virtual void DrawRectangle(CDC *pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition)
This method is called to fill the control's face.
CXTPVisualStudio2010Theme::DrawRectangle
virtual void DrawRectangle(CDC *pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition, int nID)
This method is called to fill the control's face.


Toolkit Pro: Member List

CXTPExcelTabCtrlButtonState Member List

This is the complete list of members for CXTPExcelTabCtrlButtonState, including all inherited members.

CXTPExcelTabCtrlButtonState() | CXTPExcelTabCtrlButtonState
m_bEnabled | CXTPExcelTabCtrlButtonState
m_bHilight | CXTPExcelTabCtrlButtonState
m_bPressed | CXTPExcelTabCtrlButtonState
m_iCommand | CXTPExcelTabCtrlButtonState
m_IconType | CXTPExcelTabCtrlButtonState
m_rect | CXTPExcelTabCtrlButtonState
SetInfo(CRect rect, int iCommand, XTPArrowIcon iconType) | CXTPExcelTabCtrlButtonState


Toolkit Pro: Member List

CXTPTrackMarkers Member List

This is the complete list of members for CXTPTrackMarkers, including all inherited members.

Add(int nPosition, LPCTSTR lpszCaption) | CXTPTrackMarkers |
Add(CXTPTrackMarker *pMarker) | CXTPTrackMarkers |
CXTPCmdTarget() | CXTPCmdTarget |
CXTPTrackMarkers(CXTPTrackControl *pControl) | CXTPTrackMarkers | protected
DoPropExchange(CXTPPropExchange *pPX) | CXTPTrackMarkers |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAt(int nIndex) const | CXTPTrackMarkers |
GetCount() const | CXTPTrackMarkers |
HitTest(CPoint pt) const | CXTPTrackMarkers |
IndexOf(CXTPTrackMarker *pMarker) | CXTPTrackMarkers |
m_arrMarkers | CXTPTrackMarkers | protected
m_pControl | CXTPTrackMarkers | protected
Remove(CXTPTrackMarker *pMarker) | CXTPTrackMarkers |
RemoveAll() | CXTPTrackMarkers |
RemoveAt(int nIndex) | CXTPTrackMarkers |
~CXTPTrackMarkers() | CXTPTrackMarkers | protected


Toolkit Pro: Member List

CXTPRWCriticalSection Member List

This is the complete list of members for CXTPRWCriticalSection, including all inherited members.

CXTPRWCriticalSection() | CXTPRWCriticalSection
IsLockedExclusively() const volatile | CXTPRWCriticalSection
IsLockedSharedly() const volatile | CXTPRWCriticalSection
LockExclusive() | CXTPRWCriticalSection
LockShared() | CXTPRWCriticalSection
UnlockExclusive() | CXTPRWCriticalSection
UnlockShared() | CXTPRWCriticalSection
~CXTPRWCriticalSection() | CXTPRWCriticalSection


Toolkit Pro: XTPControlGalleryVisualStudio2015Theme.h Source File

  • Source
  • CommandBars
  • Gallery
XTPControlGalleryVisualStudio2015Theme.h
Go to the documentation of this file.
1
23#if !defined(__XTPCONTROLGALLERYVISUALSTUDIO2015THEME_H__)
24# define __XTPCONTROLGALLERYVISUALSTUDIO2015THEME_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
40class _XTP_EXT_CLASS CXTPControlGalleryVisualStudio2015Theme
41 : public CXTPControlGalleryOffice2013Theme
42{
43public:
49 CXTPControlGalleryVisualStudio2015Theme(CXTPPaintManager* pPaintManager);
50};
51
53# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
54#endif // !defined(__XTPCONTROLGALLERYVISUALSTUDIO2015THEME_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPControlGalleryOffice2013Theme
The CXTPControlGalleryResourceTheme class is used to enable a Gallery Office 2013 style theme for Com...
Definition XTPControlGalleryOffice2013Theme.h:41
CXTPControlGalleryVisualStudio2015Theme
The CXTPControlGalleryResourceTheme class is used to enable a Gallery Visual Studio 2015 style theme ...
Definition XTPControlGalleryVisualStudio2015Theme.h:42
CXTPControlGalleryVisualStudio2015Theme::CXTPControlGalleryVisualStudio2015Theme
CXTPControlGalleryVisualStudio2015Theme(CXTPPaintManager *pPaintManager)
Constructs a CXTPControlGalleryVisualStudio2015Theme object.
CXTPPaintManager
Paint manager of the command bars.
Definition XTPPaintManager.h:199


Toolkit Pro: XTPFlowGraphNodeGroups.h Source File

  • Source
  • FlowGraph
XTPFlowGraphNodeGroups.h
Go to the documentation of this file.
1
23#if !defined(__XTPFLOWGRAPHNODEGROUPS_H__)
24# define __XTPFLOWGRAPHNODEGROUPS_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPFlowGraphPage;
34class CXTPFlowGraphNode;
35
45class _XTP_EXT_CLASS CXTPFlowGraphNodeGroups : public CXTPCmdTarget
46{
47protected:
53 CXTPFlowGraphNodeGroups(CXTPFlowGraphPage* pPage);
59 virtual ~CXTPFlowGraphNodeGroups();
60
61public:
66 void RemoveAll();
73 CXTPFlowGraphNodeGroup* AddGroup();
74
81 int GetCount() const;
89 CXTPFlowGraphNodeGroup* GetAt(int nIndex) const;
90
96 void Remove(CXTPFlowGraphNodeGroup* pGroup);
97
106 CXTPFlowGraphPage* GetPage() const;
107
108protected:
109 CXTPFlowGraphPage* m_pPage;
112 CArray<CXTPFlowGraphNodeGroup*, CXTPFlowGraphNodeGroup*> m_arrGroups;
115 friend class CXTPFlowGraphPage;
116
117# ifdef _XTP_ACTIVEX
120 DECLARE_DISPATCH_MAP()
121 DECLARE_INTERFACE_MAP()
122
123 DECLARE_OLETYPELIB_EX(CXTPFlowGraphNodeGroups)
124 DECLARE_ENUM_VARIANT(CXTPFlowGraphNodeGroups)
125
126 afx_msg LPDISPATCH OleGetItem(int nIndex);
127 afx_msg int OleGetItemCount();
128
129 afx_msg LPDISPATCH OleAddGroup();
130 afx_msg void OleRemoveGroup(LPDISPATCH Group);
131
133# endif
134};
135
136AFX_INLINE CXTPFlowGraphPage* CXTPFlowGraphNodeGroups::GetPage() const
137{
138 return m_pPage;
139}
140AFX_INLINE int CXTPFlowGraphNodeGroups::GetCount() const
141{
142 return (int)m_arrGroups.GetSize();
143}
144AFX_INLINE CXTPFlowGraphNodeGroup* CXTPFlowGraphNodeGroups::GetAt(int nIndex) const
145{
146 return nIndex >= 0 && nIndex < m_arrGroups.GetSize() ? m_arrGroups[nIndex] : NULL;
147}
149# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
150#endif //#if !defined(__XTPFLOWGRAPHNODEGROUPS_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPFlowGraphNodeGroup
Represents a group of Nodes.
Definition XTPFlowGraphNodeGroup.h:47
CXTPFlowGraphNodeGroups
Represents a collection of groups in a page.
Definition XTPFlowGraphNodeGroups.h:46
CXTPFlowGraphNodeGroups::GetCount
int GetCount() const
Retrieves the total number of groups in the collection.
Definition XTPFlowGraphNodeGroups.h:140
CXTPFlowGraphNodeGroups::m_arrGroups
CArray< CXTPFlowGraphNodeGroup *, CXTPFlowGraphNodeGroup * > m_arrGroups
Collection of groups.
Definition XTPFlowGraphNodeGroups.h:112
CXTPFlowGraphNodeGroups::m_pPage
CXTPFlowGraphPage * m_pPage
Pointer to the page that this collection of groups is displayed on.
Definition XTPFlowGraphNodeGroups.h:109
CXTPFlowGraphNodeGroups::GetAt
CXTPFlowGraphNodeGroup * GetAt(int nIndex) const
Gets the group at a specified index in the collection.
Definition XTPFlowGraphNodeGroups.h:144
CXTPFlowGraphNodeGroups::RemoveAll
void RemoveAll()
Removes all groups from the collection.
CXTPFlowGraphNodeGroups::CXTPFlowGraphNodeGroups
CXTPFlowGraphNodeGroups(CXTPFlowGraphPage *pPage)
Constructs a CXTPFlowGraphNodeGroups object.
CXTPFlowGraphNodeGroups::GetPage
CXTPFlowGraphPage * GetPage() const
Retrieves a reference to the flow graph page that this collection of groups are displayed on.
Definition XTPFlowGraphNodeGroups.h:136
CXTPFlowGraphNodeGroups::AddGroup
CXTPFlowGraphNodeGroup * AddGroup()
Adds a group to the page's collection of groups.
CXTPFlowGraphNodeGroups::Remove
void Remove(CXTPFlowGraphNodeGroup *pGroup)
Removes a specific group from the collection.
CXTPFlowGraphNodeGroups::~CXTPFlowGraphNodeGroups
virtual ~CXTPFlowGraphNodeGroups()
Destroys a CXTPFlowGraphNodeGroups object, handles cleanup and deallocation.
CXTPFlowGraphNode
Represents a Node object.
Definition XTPFlowGraphNode.h:116
CXTPFlowGraphPage
Represents a page in the flow graph.
Definition XTPFlowGraphPage.h:54


Toolkit Pro: Member List

CXTPMessageBarThemeNativeWindows11 Member List

This is the complete list of members for CXTPMessageBarThemeNativeWindows11, including all inherited members.

CXTPMessageBarPaintManager(CXTPPaintManager *pPaintManager) | CXTPMessageBarPaintManager |
CXTPMessageBarThemeNativeWindows11(CXTPPaintManager *pPaintManager) | CXTPMessageBarThemeNativeWindows11 |
CXTPMessageBarThemeOffice2013(CXTPPaintManager *pPaintManager) | CXTPMessageBarThemeOffice2013 |
DrawMessageBarButton(CDC *pDC, CXTPMessageBarButton *pButton) | CXTPMessageBarThemeOffice2013 | virtual
FillMessageBar(CDC *pDC, CXTPMessageBar *pBar) | CXTPMessageBarThemeOffice2013 | virtual
GetCloseButtonRect(int x, int y, int cy) | CXTPMessageBarThemeOffice2013 | virtual
GetDefaultButtonSize() const | CXTPMessageBarPaintManager | virtual
GetHeight() const | CXTPMessageBarPaintManager | virtual
GetPadding() const | CXTPMessageBarPaintManager | virtual
m_clrBack | CXTPMessageBarPaintManager | protected
m_clrBorder | CXTPMessageBarPaintManager | protected
m_clrButtonBack | CXTPMessageBarThemeOffice2013 | protected
m_clrButtonBackHilite | CXTPMessageBarThemeOffice2013 | protected
m_clrButtonBackPushed | CXTPMessageBarThemeOffice2013 | protected
m_clrButtonBorder | CXTPMessageBarThemeOffice2013 | protected
m_clrButtonBorderHilite | CXTPMessageBarThemeOffice2013 | protected
m_clrButtonBorderPushed | CXTPMessageBarThemeOffice2013 | protected
m_clrInfoBack | CXTPMessageBarPaintManager | protected
m_clrText | CXTPMessageBarPaintManager | protected
m_clrTextHilite | CXTPMessageBarThemeOffice2013 | protected
m_pPaintManager | CXTPMessageBarPaintManager | protected
RefreshMetrics() | CXTPMessageBarThemeOffice2013 | virtual
~CXTPMessageBarPaintManager() | CXTPMessageBarPaintManager | inlinevirtual


Toolkit Pro: XTPStatusBarPaneSlider.h Source File

  • Source
  • CommandBars
  • StatusBar
  • Panes
XTPStatusBarPaneSlider.h
Go to the documentation of this file.
1
23#if !defined(__XTPSTATUSBARPANESLIDER_H__)
24# define __XTPSTATUSBARPANESLIDER_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
39class _XTP_EXT_CLASS CXTPStatusBarSliderPane : public CXTPStatusBarScrollBarPane
40{
42 DECLARE_DYNAMIC(CXTPStatusBarSliderPane)
44public:
49 CXTPStatusBarSliderPane();
50
56 ~CXTPStatusBarSliderPane();
57
58protected:
64 virtual CXTPScrollBarPaintManager* GetScrollBarPaintManager() const;
65
66public:
73 void SetTicks(double* pTicks, int nCount);
74
75# ifdef _XTP_COMMANDBARS_ACTIVEX
77 DECLARE_DISPATCH_MAP()
78 DECLARE_INTERFACE_MAP()
79 DECLARE_OLETYPELIB_EX(CXTPStatusBarSliderPane);
80 void OleSetTooltipPart(int nPart, LPCTSTR lpszTooltip);
81 void OleSetTicks(const VARIANT& Ticks);
83# endif
84};
85
87# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
88#endif // !defined(__XTPSTATUSBARPANESLIDER_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPScrollBarPaintManager
CXTPScrollBarPaintManager is standalone class used to draw CXTPCommandBarScrollBarCtrl object.
Definition XTPScrollBarPaintManager.h:40
CXTPStatusBarScrollBarPane
CXTPStatusBarScrollBarPane is a CXTPStatusBarPane derived class.
Definition XTPStatusBarPaneScrollBar.h:42
CXTPStatusBarSliderPane
CXTPStatusBarSliderPane is a CXTPStatusBarPane derived class.
Definition XTPStatusBarPaneSlider.h:40
CXTPStatusBarSliderPane::CXTPStatusBarSliderPane
CXTPStatusBarSliderPane()
Constructs a CXTPStatusBarSliderPane object.
CXTPStatusBarSliderPane::SetTicks
void SetTicks(double *pTicks, int nCount)
Call this method to set ticks for the slider.
CXTPStatusBarSliderPane::~CXTPStatusBarSliderPane
~CXTPStatusBarSliderPane()
Destroys a CXTPStatusBarSliderPane object, handles cleanup and deallocation.
CXTPStatusBarSliderPane::GetScrollBarPaintManager
virtual CXTPScrollBarPaintManager * GetScrollBarPaintManager() const
This method is called to retrieve a pointer to CXTPScrollBarPaintManager.


Toolkit Pro: XTPSyntaxEditSectionManager.h Source File

  • Source
  • SyntaxEdit
XTPSyntaxEditSectionManager.h
Go to the documentation of this file.
1
23#if !defined(__XTPSYNTAXEDITSECTIONMANAGER_H__)
24# define __XTPSYNTAXEDITSECTIONMANAGER_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
37struct _XTP_EXT_CLASS XTP_EDIT_SCHEMAFILEINFO
38{
39 XTP_EDIT_SCHEMAFILEINFO();
40
41 XTP_EDIT_SCHEMAFILEINFO(const XTP_EDIT_SCHEMAFILEINFO& info);
42
43 XTP_EDIT_SCHEMAFILEINFO(const CString& srcName, const CString& srcValue);
44
45 const XTP_EDIT_SCHEMAFILEINFO& operator=(const XTP_EDIT_SCHEMAFILEINFO& info);
46
47 BOOL operator==(const XTP_EDIT_SCHEMAFILEINFO& info) const;
48
49public:
50 CString csName;
51 CString csValue;
52 CString csDesc;
53 UINT uValue;
54};
55
59class _XTP_EXT_CLASS CXTPSyntaxEditSchemaFileInfoList
60 : public CList<XTP_EDIT_SCHEMAFILEINFO, XTP_EDIT_SCHEMAFILEINFO&>
61{
62public:
63 POSITION LookupName(const CString& csName, XTP_EDIT_SCHEMAFILEINFO& info) const;
64
65 POSITION LookupValue(const CString& csValue, XTP_EDIT_SCHEMAFILEINFO& info) const;
66
67 POSITION LookupValue(const UINT& uValue, XTP_EDIT_SCHEMAFILEINFO& info) const;
68
69 POSITION LookupDesc(const CString& csDesc, XTP_EDIT_SCHEMAFILEINFO& info) const;
70};
71
75class _XTP_EXT_CLASS CXTPSyntaxEditSectionManager
76{
77public:
78 CXTPSyntaxEditSectionManager();
79
80 virtual ~CXTPSyntaxEditSectionManager();
81
82public:
83 // used for file based settings
84 int GetSectionNames(CStringArray& arSections, LPCTSTR lpszFilePath) const;
85 int GetSectionKeyList(CXTPSyntaxEditSchemaFileInfoList& infoList, LPCTSTR lpszFilePath,
86 LPCTSTR lpszSectionName) const;
87 // used for non-file based settings
88 int GetSectionNames(CStringArray& arSections, CStringArray& arPassedString) const;
89 int GetSectionKeyList(CXTPSyntaxEditSchemaFileInfoList& infoList, CStringArray& arPassedString,
90 CString sSectionName) const;
91
92 BOOL ParseSectionKey(XTP_EDIT_SCHEMAFILEINFO& info, const CString& csBuffer) const;
93
94 BOOL SplitString(CString& csLeft, CString& csRight, const CString& csBuffer, TCHAR chSep) const;
95};
96
99
100# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
102#endif // !defined(__XTPSYNTAXEDITSECTIONMANAGER_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h


Toolkit Pro: Member List

IXTPPreview Member List

This is the complete list of members for IXTPPreview, including all inherited members.

Activate()=0 | IXTPPreview | pure virtual
Draw(HDC dc, SIZE clientSize, RECT updateRect)=0 | IXTPPreview | pure virtual
GetNumberOfPages() const =0 | IXTPPreview | pure virtual
GetPreferredPageSize() const =0 | IXTPPreview | pure virtual
GoToPage(UINT page)=0 | IXTPPreview | pure virtual
HasOwnNavigator() const =0 | IXTPPreview | pure virtual
IsAvailable() const =0 | IXTPPreview | pure virtual
IsReady() const =0 | IXTPPreview | pure virtual
OnHostWndMsg(LPMSG msg, LRESULT *result)=0 | IXTPPreview | pure virtual
SupportsCompositedParent() const =0 | IXTPPreview | pure virtual
~IXTPPreview() | IXTPPreview | inlinevirtual


Toolkit Pro: Member List

CXTPTaskPanelNativeWindows10Theme Member List

This is the complete list of members for CXTPTaskPanelNativeWindows10Theme, including all inherited members.

BlendColor(COLORREF clrFrom, COLORREF clrTo, int nAlpha) | CXTPTaskPanelPaintManager | protected
CreateGripperBitmaps() | CXTPTaskPanelPaintManager | protected
CreateGripperIcon(HICON &hIcon, UINT nIDResource, COLORREF clrGripperBack) | CXTPTaskPanelPaintManager | protected
CXTPTaskPanelNativeWindows10Theme() | CXTPTaskPanelNativeWindows10Theme |
CXTPTaskPanelPaintManager() | CXTPTaskPanelPaintManager |
CXTPTaskPanelPaintManagerPlain() | CXTPTaskPanelPaintManagerPlain |
CXTPTaskPanelToolboxTheme() | CXTPTaskPanelToolboxTheme |
CXTPTaskPanelVisualStudio2005Theme() | CXTPTaskPanelVisualStudio2005Theme |
CXTPTaskPanelVisualStudio2012Theme(BOOL bLight=TRUE) | CXTPTaskPanelVisualStudio2012Theme |
DrawCaptionGripper(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelPaintManager | protectedvirtual
DrawCaptionGripperBitmap(CDC *pDC, CXTPTaskPanelGroup *pGroup, BOOL bExpanded, BOOL bHot, CRect rc) | CXTPTaskPanelPaintManager | protected
DrawCaptionGripperSigns(CDC *pDC, CPoint pt, COLORREF clr, BOOL bExpanded) | CXTPTaskPanelPaintManager | protected
DrawDragArrow(CDC *pDC, CXTPTaskPanelItem *pItem, CRect rc, BOOL bAfter=FALSE) | CXTPTaskPanelPaintManager | protectedvirtual
DrawFocusRect(CDC *pDC, CRect rc) | CXTPTaskPanelPaintManager | protectedvirtual
DrawGroupCaption(CDC *pDC, CXTPTaskPanelGroup *pGroup, BOOL bDraw) | CXTPTaskPanelToolboxTheme | virtual
DrawGroupCaptionBackground(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelVisualStudio2012Theme | virtual
DrawGroupClient(CDC *pDC, CXTPTaskPanelGroup *pGroup) | CXTPTaskPanelPaintManager | virtual
DrawGroupClientFace(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelVisualStudio2012Theme | virtual
DrawGroupClientItems(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelPaintManager | protectedvirtual
DrawGroupItem(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw) | CXTPTaskPanelPaintManager | virtual
DrawGroupItemFrame(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc) | CXTPTaskPanelVisualStudio2012Theme | virtual
DrawGroupItemImage(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw) | CXTPTaskPanelPaintManager | protected
DrawGroupItemImageWithText(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw) | CXTPTaskPanelPaintManager | protected
DrawGroupItemImageWithTextBelow(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw) | CXTPTaskPanelPaintManager | protected
DrawItemCaption(CDC *pDC, CXTPTaskPanelItem *pItem, CRect rcText, UINT nFormat) | CXTPTaskPanelVisualStudio2012Theme | virtual
DrawItemImage(CDC *pDC, CXTPTaskPanelItem *pItem, CPoint ptIcon, CXTPImageManagerIcon *pImage, CSize szIcon) | CXTPTaskPanelPaintManager | protectedvirtual
DrawScrollButton(CDC *pDC, CXTPTaskPanelScrollButton *pScrollButton) | CXTPTaskPanelPaintManager | virtual
FillGroupClientFace(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelVisualStudio2012Theme | virtual
FillTaskPanel(CDC *pDC, CXTPTaskPanel *pTaskPanel) | CXTPTaskPanelVisualStudio2012Theme | virtual
FreeBitmaps() | CXTPTaskPanelPaintManager | protected
GetCaptionGripperWidth(CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelPaintManager | protectedvirtual
GetControlMargins(const CXTPTaskPanel *pPanel) | CXTPTaskPanelPaintManager | virtual
GetGroupColors(BOOL bSpecial) | CXTPTaskPanelPaintManager |
GetGroupColors(CXTPTaskPanelGroup *pGroup) | CXTPTaskPanelPaintManager | virtual
GetGroupInnerMargins(const CXTPTaskPanelGroup *pGroup) | CXTPTaskPanelPaintManager | virtual
GetGroupOuterMargins(const CXTPTaskPanelGroup *pGroup) | CXTPTaskPanelPaintManager | virtual
GetGroupSpacing(const CXTPTaskPanel *pPanel) | CXTPTaskPanelPaintManager | virtual
GetHighlightOffset(CXTPTaskPanelGroupItem *pItem) | CXTPTaskPanelPaintManager | protectedvirtual
GetItemFont(CXTPTaskPanelItem *pItem) | CXTPTaskPanelPaintManager | virtual
GetItemIconPadding(const CXTPTaskPanelItem *pItem) | CXTPTaskPanelPaintManager | virtual
GetItemInnerMargins(const CXTPTaskPanelGroupItem *pItem) | CXTPTaskPanelPaintManager | virtual
GetItemOuterMargins(const CXTPTaskPanelGroupItem *pItem) | CXTPTaskPanelPaintManager | virtual
m_bBoldCaption | CXTPTaskPanelPaintManager |
m_bCaptionScrollButton | CXTPTaskPanelPaintManager |
m_bEmbossedDisabledText | CXTPTaskPanelPaintManager |
m_bEmulateEplorerTheme | CXTPTaskPanelPaintManager |
m_bInvertDragRect | CXTPTaskPanelPaintManager |
m_bLeftRoundedCorner | CXTPTaskPanelPaintManager | protected
m_bmpGrippers | CXTPTaskPanelPaintManager | protected
m_bOfficeBorder | CXTPTaskPanelPaintManager | protected
m_bOfficeCaption | CXTPTaskPanelPaintManagerPlain | protected
m_bOfficeHighlight | CXTPTaskPanelPaintManager |
m_bRightRoundedCorner | CXTPTaskPanelPaintManager | protected
m_bRoundedFrame | CXTPTaskPanelPaintManagerPlain | protected
m_bUseBitmapGrippers | CXTPTaskPanelPaintManager | protected
m_bUseStandardCaptionFont | CXTPTaskPanelPaintManager | protected
m_bUseStandardItemsFont | CXTPTaskPanelPaintManager | protected
m_clrBackground | CXTPTaskPanelPaintManager | protected
m_clrHighlightBorder | CXTPTaskPanelPaintManager | protected
m_clrHighlightHot | CXTPTaskPanelPaintManager | protected
m_clrHighlightPressed | CXTPTaskPanelPaintManager | protected
m_clrHighlightSelected | CXTPTaskPanelPaintManager | protected
m_clrSelectedText | CXTPTaskPanelVisualStudio2012Theme | protected
m_clrSelectedTextWithoutFocus | CXTPTaskPanelVisualStudio2012Theme | protected
m_clrSelectedWithoutFocus | CXTPTaskPanelVisualStudio2012Theme | protected
m_clrText | CXTPTaskPanelVisualStudio2012Theme | protected
m_eGripper | CXTPTaskPanelPaintManager |
m_groupNormal | CXTPTaskPanelPaintManager | protected
m_groupSpecial | CXTPTaskPanelPaintManager | protected
m_hGripperNormal | CXTPTaskPanelPaintManager | protected
m_hGripperSpecial | CXTPTaskPanelPaintManager | protected
m_nCaptionHeight | CXTPTaskPanelPaintManager | protected
m_nCaptionTextFormat | CXTPTaskPanelPaintManager | protected
m_nGroupSpacing | CXTPTaskPanelPaintManager |
m_nItemTextFormat | CXTPTaskPanelPaintManager | protected
m_rcControlMargins | CXTPTaskPanelPaintManager |
m_rcGroupIconPadding | CXTPTaskPanelPaintManager |
m_rcGroupInnerMargins | CXTPTaskPanelPaintManager |
m_rcGroupOuterMargins | CXTPTaskPanelPaintManager |
m_rcImageLayoutIconPadding | CXTPTaskPanelPaintManager |
m_rcItemIconPadding | CXTPTaskPanelPaintManager |
m_rcItemInnerMargins | CXTPTaskPanelPaintManager |
m_rcItemOuterMargins | CXTPTaskPanelPaintManager |
m_xtpFontCaption | CXTPTaskPanelPaintManager | protected
m_xtpFontIcon | CXTPTaskPanelPaintManager | protected
m_xtpFontIconBold | CXTPTaskPanelPaintManager | protected
m_xtpFontIconHot | CXTPTaskPanelPaintManager | protected
m_xtpFontIconHotBold | CXTPTaskPanelPaintManager | protected
Rectangle(CDC *pDC, CRect rc, COLORREF clrPen, COLORREF clrBrush) | CXTPTaskPanelPaintManager | protected
rectDefault | CXTPTaskPanelPaintManager | static
RefreshMetrics() | CXTPTaskPanelNativeWindows10Theme | virtual
SetCaptionFontIndirect(LOGFONT *pLogFont, BOOL bUseStandardCaptionFont=FALSE) | CXTPTaskPanelPaintManager |
SetItemsFontIndirect(LOGFONT *pLogFont, BOOL bUseStandardItemsFont=FALSE) | CXTPTaskPanelPaintManager |
SetTextFormat(int nTextFormat, BOOL bCaption=FALSE) | CXTPTaskPanelPaintManager |
~CXTPTaskPanelNativeWindows10Theme() | CXTPTaskPanelNativeWindows10Theme | virtual
~CXTPTaskPanelPaintManager() | CXTPTaskPanelPaintManager | virtual
~CXTPTaskPanelVisualStudio2012Theme() | CXTPTaskPanelVisualStudio2012Theme | virtual


Toolkit Pro: Member List

XTP_COMMANDBARS_CATEGORYINFO Member List

This is the complete list of members for XTP_COMMANDBARS_CATEGORYINFO, including all inherited members.

pControls | XTP_COMMANDBARS_CATEGORYINFO
strCategory | XTP_COMMANDBARS_CATEGORYINFO


Toolkit Pro: Member List

CXTPChartRangeSplineAreaSeriesPointView Member List

This is the complete list of members for CXTPChartRangeSplineAreaSeriesPointView, including all inherited members.

AddChildView(CXTPChartElementView *pChildView) | CXTPChartElementView |
CreateDeviceCommand(CXTPChartDeviceContext *pDC) | CXTPChartRangeSplineAreaSeriesPointView | virtual
CreateLegendDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcBounds) | CXTPChartPointSeriesPointView | virtual
CXTPChartElementView(CXTPChartElementView *pParentView) | CXTPChartElementView |
CXTPChartElementView(CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartElementView |
CXTPChartElementView(CXTPChartContainer *pContainer) | CXTPChartElementView |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartPointSeriesPointView(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView) | CXTPChartPointSeriesPointView |
CXTPChartRangeSplineAreaSeriesPointView(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView) | CXTPChartRangeSplineAreaSeriesPointView |
CXTPChartSeriesPointView(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView) | CXTPChartSeriesPointView |
CXTPChartSeriesPointView(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartSeriesPointView |
GetAt(int nIndex) const | CXTPChartElementView |
GetBounds() const | CXTPChartElementView |
GetBounds(BOOL bIncludingChildren) const | CXTPChartElementView |
GetChildren() | CXTPChartElementView |
GetColor() const | CXTPChartSeriesPointView |
GetColor2() const | CXTPChartSeriesPointView |
GetCount() const | CXTPChartElementView |
GetInternalValue() const | CXTPChartSeriesPointView |
GetLegendName() const | CXTPChartSeriesPointView | virtual
GetParentView() const | CXTPChartElementView |
GetPoint() const | CXTPChartSeriesPointView |
GetScreenPoint() const | CXTPChartPointSeriesPointView |
GetSeriesView() const | CXTPChartSeriesPointView |
Is3D() const | CXTPChartObject |
m_arrChildren | CXTPChartElementView | protected
m_dInternalValue | CXTPChartSeriesPointView |
m_pContainer | CXTPChartElementView | protected
m_pParentView | CXTPChartElementView | protected
m_pPoint | CXTPChartSeriesPointView | protected
m_rcBounds | CXTPChartElementView | protected
UpdateMinMaxRange(double &nMinValue, double &nMaxValue) const | CXTPChartRangeSplineAreaSeriesPointView | virtual
~CXTPChartElementView() | CXTPChartElementView | protectedvirtual
~CXTPChartLegendItemView() | CXTPChartLegendItemView | inlinevirtual


Toolkit Pro: XTPRibbonBackstagePage.h Source File

  • Source
  • Ribbon
  • Backstage
XTPRibbonBackstagePage.h
Go to the documentation of this file.
1
23#if !defined(__XTPRIBBONBACKSTAGEPAGE_H__)
24# define __XTPRIBBONBACKSTAGEPAGE_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class _XTP_EXT_CLASS CXTPRibbonBackstagePage : public CXTPResizePropertyPage
34{
36 DECLARE_DYNAMIC(CXTPRibbonBackstagePage)
38public:
39 CXTPRibbonBackstagePage(UINT nID);
40
41 ~CXTPRibbonBackstagePage();
42
43 virtual XTPControlTheme GetTheme() const;
44 virtual void SetTheme(const XTPControlTheme nTheme);
45 virtual void PreSubclassWindow();
46
47 BOOL IsRightToLeft() const;
48 void SetRightToLeft(BOOL bRTL = TRUE);
49
50protected:
51 DECLARE_MESSAGE_MAP()
52 //{{AFX_MSG(CXTPRibbonBackstagePage)
53 afx_msg HBRUSH OnCtlColor(CDC* pDC, CWnd* pWnd, UINT nCtlColor);
54 //}}AFX_MSG
55
56protected:
57 XTPControlTheme m_nTheme;
58
59 CXTPFont m_xtpFontCaption;
60 CXTPFont m_xtpFontTitle;
61
62 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CFont, m_fntCaption, m_xtpFontCaption,
63 GetCaptionFontHandle);
64 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CFont, m_fntTitle, m_xtpFontTitle, GetTitleFontHandle);
65
66 CXTPBrush m_xtpBrushBack;
67 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CBrush, m_brBack, m_xtpBrushBack, GetBackBrushHandle);
68
69 COLORREF m_clrBack;
70 COLORREF m_clrText;
71 BOOL m_bRightToLeft;
72};
73
74AFX_INLINE BOOL CXTPRibbonBackstagePage::IsRightToLeft() const
75{
76 return m_bRightToLeft;
77}
78
79AFX_INLINE void CXTPRibbonBackstagePage::SetRightToLeft(BOOL bRTL /*= TRUE*/)
80{
81 m_bRightToLeft = bRTL;
82}
83
84# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
86#endif // !defined(__XTPRIBBONBACKSTAGEPAGE_H__)
XTPControlTheme
XTPControlTheme
Enumeration used to determine the active theme style.
Definition XTPControlTheme.h:43
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPBrush
Provides a convenient object oriented interface for HBRUSH GDI object and uses GDI handle caching.
Definition XTPGdiObjects.h:653
CXTPFont
Provides a convenient object oriented interface for HFONT GDI object and uses GDI handle caching.
Definition XTPGdiObjects.h:414
CXTPResizePropertyPage
CXTPResizePropertyPage is a multiple inheritance class derived from CPropertyPage and CXTPResize.
Definition XTPResizePropertyPage.h:43


Toolkit Pro: XTPCalendarCustomProperties.h Source File

  • Source
  • Calendar
XTPCalendarCustomProperties.h
Go to the documentation of this file.
1
22#if !defined(_XTP_CALENDAR_CUSTOM_PROPERTIES_H__)
23# define _XTP_CALENDAR_CUSTOM_PROPERTIES_H__
24
25# if _MSC_VER > 1000
26# pragma once
27# endif // _MSC_VER > 1000
28
29# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
30
32class CXTPPropExchange;
33
43class _XTP_EXT_CLASS CXTPCalendarCustomProperties : public CXTPCmdTarget
44{
46 DECLARE_DYNAMIC(CXTPCalendarCustomProperties)
48public:
56 CXTPCalendarCustomProperties(BOOL bNameIgnoreCase = TRUE);
57
62 virtual ~CXTPCalendarCustomProperties();
63
82 virtual BOOL GetProperty(LPCTSTR pcszName, COleVariant& rVarValue) const;
83
98 virtual BOOL SetProperty(LPCTSTR pcszName, const COleVariant& varValue);
99
112 virtual BOOL RemoveProperty(LPCTSTR pcszName);
113
122 virtual void RemoveAll();
123
135 virtual int GetCount();
136
147 POSITION GetStartPosition() const;
148
165 void GetNextProperty(POSITION& rPos, CString& rStrName, COleVariant& rVarValue) const;
166
178 virtual void DoPropExchange(CXTPPropExchange* pPX);
179
180public:
194 BOOL LoadFromXML(LPCTSTR pcszXMLData);
195
207 BOOL SaveToXML(CString& rstrXMLData);
208
222 void CopyTo(CXTPCalendarCustomProperties* pDest);
223
224protected:
232 void _Load(CXTPPropExchange* pPX);
233
241 void _Save(CXTPPropExchange* pPX);
242
256 CString PrepareName(LPCTSTR pcszName) const;
257
258 typedef CMap<CString, LPCTSTR, COleVariant, COleVariant&> CXTPOleVariantMap;
259
260 CXTPOleVariantMap m_mapProperties;
261 BOOL m_bNameIgnoreCase;
263# ifdef _XTP_ACTIVEX
264
265 afx_msg VARIANT OleGetProperty(LPCTSTR strName);
266 afx_msg void OleSetProperty(LPCTSTR strName, VARIANT& Value);
267
268 afx_msg long OleGetCount();
269
270 afx_msg void OleRemove(LPCTSTR strName);
271 afx_msg void OleRemoveAll();
272
273 afx_msg void OleLoadFromString(LPCTSTR strData);
274 afx_msg BSTR OleSaveToString();
275
276 DECLARE_DISPATCH_MAP()
277 DECLARE_INTERFACE_MAP()
278
279 DECLARE_OLETYPELIB_EX(CXTPCalendarCustomProperties);
280
281 DECLARE_ENUM_VARIANTLIST(CXTPCalendarCustomProperties);
282
283# endif
284};
285
286# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
287#endif // !defined(_XTP_CALENDAR_CUSTOM_PROPERTIES_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCalendarCustomProperties
This class is used to store properties collection.
Definition XTPCalendarCustomProperties.h:44
CXTPCalendarCustomProperties::GetNextProperty
void GetNextProperty(POSITION &rPos, CString &rStrName, COleVariant &rVarValue) const
Retrieves the properties collection element at rPos, then updates rPos to refer to the next element i...
CXTPCalendarCustomProperties::DoPropExchange
virtual void DoPropExchange(CXTPPropExchange *pPX)
Call this member function to Store/Load a properties collection using the specified data object.
CXTPCalendarCustomProperties::CXTPCalendarCustomProperties
CXTPCalendarCustomProperties(BOOL bNameIgnoreCase=TRUE)
Default object constructor.
CXTPCalendarCustomProperties::GetProperty
virtual BOOL GetProperty(LPCTSTR pcszName, COleVariant &rVarValue) const
This member function is used to get property value using the specified name.
CXTPCalendarCustomProperties::~CXTPCalendarCustomProperties
virtual ~CXTPCalendarCustomProperties()
Default object destructor.
CXTPCalendarCustomProperties::LoadFromXML
BOOL LoadFromXML(LPCTSTR pcszXMLData)
This helper function is used to load a properties collection from a XML string source.
CXTPCalendarCustomProperties::_Load
void _Load(CXTPPropExchange *pPX)
Call this member function to Load a properties collection using the specified data object.
CXTPCalendarCustomProperties::RemoveProperty
virtual BOOL RemoveProperty(LPCTSTR pcszName)
This member function is used to remove property with the specified name.
CXTPCalendarCustomProperties::m_bNameIgnoreCase
BOOL m_bNameIgnoreCase
if TRUE - properties names are not case sensitive.
Definition XTPCalendarCustomProperties.h:261
CXTPCalendarCustomProperties::PrepareName
CString PrepareName(LPCTSTR pcszName) const
Call this member function to prepare a property name before passing it to the map access functions.
CXTPCalendarCustomProperties::CopyTo
void CopyTo(CXTPCalendarCustomProperties *pDest)
This helper function is used to copy properties from a source collection object to a destination coll...
CXTPCalendarCustomProperties::RemoveAll
virtual void RemoveAll()
This member function is used to remove all properties.
CXTPCalendarCustomProperties::m_mapProperties
CXTPOleVariantMap m_mapProperties
Properties storage map.
Definition XTPCalendarCustomProperties.h:260
CXTPCalendarCustomProperties::GetCount
virtual int GetCount()
This member function is to get properties count in the collection.
CXTPCalendarCustomProperties::GetStartPosition
POSITION GetStartPosition() const
Starts a properties collection iteration by returning a POSITION value that can be passed to a GetNex...
CXTPCalendarCustomProperties::SaveToXML
BOOL SaveToXML(CString &rstrXMLData)
This helper function is used to store a properties collection to a XML string.
CXTPCalendarCustomProperties::SetProperty
virtual BOOL SetProperty(LPCTSTR pcszName, const COleVariant &varValue)
This member function is used to set property value with the specified name.
CXTPCalendarCustomProperties::_Save
void _Save(CXTPPropExchange *pPX)
Call this member function to Store a properties collection using the specified data object.
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72


Toolkit Pro: Member List

CXTPControlComboBoxPopupBar Member List

This is the complete list of members for CXTPControlComboBoxPopupBar, including all inherited members.

AdjustExcludeRect(CRect &rc, BOOL bVertical) | CXTPPopupBar | protectedvirtual
Animate() | CXTPPopupBar | protectedvirtual
CalcDynamicLayout(int nLength, DWORD dwMode) | CXTPPopupBar | virtual
CalculatePopupRect(CPoint ptPopup, CSize sz) | CXTPPopupBar | virtual
Copy(CXTPCommandBar *pCommandBar, BOOL bRecursive=FALSE) | CXTPPopupBar | protectedvirtual
Create() | CXTPPopupBar | virtual
CreateKeyboardTips() | CXTPCommandBar | virtual
CreatePopupBar(CXTPCommandBars *pCommandBars) | CXTPPopupBar | static
CXTPCommandBar() | CXTPCommandBar | protected
CXTPControlComboBoxPopupBar() | CXTPControlComboBoxPopupBar |
CXTPHookManagerHookAble() | CXTPHookManagerHookAble |
CXTPPopupBar() | CXTPPopupBar | protected
DelayLayout() | CXTPCommandBar |
DelayRedraw() | CXTPPopupBar | inlineprotectedvirtual
DestroyWindow() | CXTPPopupBar |
DisableShadow() | CXTPPopupBar |
DoPropExchange(CXTPPropExchange *pPX) | CXTPPopupBar | protectedvirtual
DrawCommandBar(CDC *pDC, CRect rcClipBox) | CXTPPopupBar | protectedvirtual
EnableAnimation(BOOL bEnable=TRUE) | CXTPCommandBar |
EnableCustomization(BOOL bEnable=TRUE) | CXTPCommandBar |
EnableDoubleBuffer(BOOL bEnable=TRUE) | CXTPCommandBar |
EnsureVisible(CXTPControl *pControl) | CXTPCommandBar | virtual
ExpandBar() | CXTPPopupBar |
FillCommandBarEntry(CDC *pDC) | CXTPCommandBar | virtual
FindAccel(TCHAR chAccel) const | CXTPCommandBar |
FindAccelEx(UINT chAccel, BOOL &bSelectOnly) const | CXTPCommandBar |
GenerateCommandBarList(DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam) | CXTPCommandBar | protectedvirtual
GetActiveDocTemplate() const | CXTPCommandBar | protected
GetBarID() const | CXTPCommandBar |
GetBorders() | CXTPPopupBar | virtual
GetButtonSize() const | CXTPCommandBar | virtual
GetCommandBarData() const | CXTPCommandBar |
GetCommandBars() const | CXTPCommandBar |
GetControl(int nIndex) const | CXTPCommandBar |
GetControlCount() const | CXTPCommandBar |
GetControlPopup() const | CXTPPopupBar |
GetControls() const | CXTPCommandBar |
GetDefaultButtonStyle() const | CXTPCommandBar |
GetDefaultItem(UINT gmdiFlags, BOOL fByPos=FALSE) | CXTPPopupBar |
GetFlags() const | CXTPCommandBar |
GetFrameSite() const | CXTPCommandBar |
GetIconSize() const | CXTPCommandBar | virtual
GetImageManager() const | CXTPCommandBar |
GetLargeIconSize(BOOL bAutoSize) const | CXTPCommandBar |
GetOwnerSite() const | CXTPCommandBar |
GetPaintManager() const | CXTPCommandBar |
GetParentCommandBar() const | CXTPPopupBar | protectedvirtual
GetPosition() const | CXTPCommandBar |
GetRootParent() const | CXTPCommandBar |
GetSelected() const | CXTPCommandBar |
GetShowGripper() const | CXTPCommandBar |
GetSite() const | CXTPCommandBar |
GetTextOrientation() const | CXTPCommandBar |
GetTitle() const | CXTPCommandBar |
GetTrackFocus() const | CXTPCommandBar |
GetType() const | CXTPCommandBar |
GetWidth() const | CXTPCommandBar |
HideKeyboardTips() | CXTPCommandBar |
InvalidateParents() | CXTPCommandBar |
IsAnimationEnabled() const | CXTPCommandBar |
IsContextMenu() const | CXTPPopupBar |
IsCustomizable() const | CXTPCommandBar | virtual
IsCustomizeDialogPresent() const | CXTPCommandBar |
IsCustomizeMode() const | CXTPCommandBar |
IsDialogBar() const | CXTPCommandBar | virtual
IsDoubleGripper() const | CXTPPopupBar |
IsHelpMode() const | CXTPCommandBar | protected
IsKeyboardCuesVisible() const | CXTPCommandBar | virtual
IsKeyboardTipsVisible() const | CXTPCommandBar |
IsLayoutRTL() const | CXTPCommandBar |
IsMenuTitleBar() const | CXTPCommandBar | virtual
IsPopupBar() const | CXTPPopupBar | virtual
IsResizable() const | CXTPPopupBar | virtual
IsRibbonBar() const | CXTPCommandBar | virtual
IsTearOffPopup(CString &strCaption, UINT &nID, int &nWidth) | CXTPPopupBar |
IsTextBelowIcons() const | CXTPCommandBar |
IsTrackingMode() const | CXTPCommandBar |
IsVisible() const | CXTPPopupBar | virtual
LoadMenu(CMenu *pMenu, BOOL bRemoveControls=TRUE) | CXTPCommandBar | virtual
LoadToolBar(UINT nIDResource, BOOL bLoadIcons=TRUE) | CXTPCommandBar | virtual
LockMouseMove(CXTPControl *pControl) | CXTPCommandBar |
LockRedraw() | CXTPCommandBar |
m_bAnimatePopup | CXTPCommandBar | protected
m_barPosition | CXTPCommandBar | protected
m_barType | CXTPCommandBar | protected
m_bAutoDestroy | CXTPHookManagerHookAble |
m_bCloseable | CXTPCommandBar | protected
m_bCollapsed | CXTPPopupBar | protected
m_bComboBar | CXTPCommandBar |
m_bContextMenu | CXTPPopupBar | protected
m_bCustomizable | CXTPCommandBar | protected
m_bCustomizeDialogPresent | CXTPCommandBar | protected
m_bDoubleGripper | CXTPPopupBar | protected
m_bDynamicLayout | CXTPPopupBar | protected
m_bExecOnRButton | CXTPCommandBar | protected
m_bExpanded | CXTPPopupBar | protected
m_bExpanding | CXTPPopupBar | protected
m_bGrabFocus | CXTPCommandBar | protected
m_bIgnoreUpdateHandler | CXTPCommandBar | protected
m_bKeyboardSelect | CXTPCommandBar | protected
m_bMultiLine | CXTPCommandBar | protected
m_bRecursePopup | CXTPCommandBar | protected
m_bResizable | CXTPPopupBar | protected
m_bShowShadow | CXTPPopupBar | protected
m_bTearOffPopup | CXTPPopupBar | protected
m_bTearOffSelected | CXTPPopupBar | protected
m_bTearOffTracking | CXTPPopupBar | protected
m_bTextBelow | CXTPCommandBar | protected
m_bTracking | CXTPCommandBar | protected
m_bTrackOnHover | CXTPCommandBar |
m_buttonStyle | CXTPCommandBar | protected
m_bVerticalMarker | CXTPCommandBar | protected
m_dMaxWidthDivisor | CXTPPopupBar | static
m_dwData | CXTPCommandBar | protected
m_dwFlags | CXTPCommandBar | protected
m_dwStyle | CXTPCommandBar | protected
m_hwndFocus | CXTPCommandBar | protected
m_nBarID | CXTPCommandBar | protected
m_nIdleFlags | CXTPCommandBar | protected
m_nLockRedraw | CXTPCommandBar | protected
m_nMaxHeight | CXTPPopupBar | protected
m_nMRUWidth | CXTPCommandBar | protected
m_nPopuped | CXTPCommandBar | protected
m_nSelected | CXTPCommandBar | protected
m_nStateFlags | CXTPCommandBar |
m_nTearOffID | CXTPPopupBar | protected
m_nTearOffTimer | CXTPPopupBar | protected
m_nTearOffWidth | CXTPPopupBar | protected
m_nTextOrientation | CXTPCommandBar | protected
m_pAnimation | CXTPCommandBar | protected
m_pCommandBars | CXTPCommandBar | protected
m_pControlPopup | CXTPPopupBar | protected
m_pControls | CXTPCommandBar | protected
m_pImageManager | CXTPCommandBar | protected
m_popupFlags | CXTPPopupBar | protected
m_pOwner | CXTPCommandBar | protected
m_pPaintManager | CXTPCommandBar | protected
m_pReturnCmd | CXTPCommandBar | protected
m_pSite | CXTPCommandBar | protected
m_pTearOffBar | CXTPPopupBar | protected
m_pToolTipContext | CXTPCommandBar | protected
m_ptPopup | CXTPPopupBar | protected
m_rcBorders | CXTPPopupBar | protected
m_rcExclude | CXTPPopupBar | protected
m_rcMarker | CXTPCommandBar | protected
m_rcResizeGripper | CXTPPopupBar | protected
m_rcTearOffGripper | CXTPPopupBar | protected
m_strTearOffCaption | CXTPPopupBar | protected
m_strTitle | CXTPCommandBar | protected
m_szButtons | CXTPCommandBar | protected
m_szButtonSpacing | CXTPCommandBar | protected
m_szIcons | CXTPCommandBar | protected
m_szTearOffBar | CXTPPopupBar | protected
OnControlsChanged() | CXTPPopupBar | protectedvirtual
OnControlSelected(BOOL bSelected, CXTPControl *pControl) | CXTPCommandBar | virtual
OnCustomizeDragEnter(CXTPControl *pDataObject, CPoint point) | CXTPCommandBar | virtual
OnCustomizeDragLeave() | CXTPCommandBar | virtual
OnCustomizeDragOver(CXTPControl *pDataObject, CPoint point) | CXTPCommandBar | virtual
OnCustomizeDrop(CXTPControl *pDataObject, DROPEFFECT &dropEffect, CPoint ptDrop, CPoint ptDrag) | CXTPCommandBar | virtual
OnHookAttached(HWND hWnd) | CXTPHookManagerHookAble | virtual
OnHookDetached() | CXTPHookManagerHookAble | virtual
OnHookKeyDown(UINT nChar, LPARAM lParam) | CXTPPopupBar | protectedvirtual
OnHookMessage(HWND hWnd, UINT nMessage, WPARAM &wParam, LPARAM &lParam, LRESULT &lResult) | CXTPCommandBar | virtual
OnKeyboardTip(CXTPCommandBarKeyboardTip *pTip) | CXTPCommandBar | virtual
OnKeyboardTipChar(UINT chAccel) | CXTPCommandBar |
OnMouseHitTest(CPoint pt) | CXTPCommandBar | protectedvirtual
OnPostHookMessage(HWND hWnd, UINT nMessage, WPARAM &wParam, LPARAM &lParam, LRESULT &lResult) | CXTPHookManagerHookAble | virtual
OnRecalcLayout() | CXTPPopupBar | protectedvirtual
OnRemoved() | CXTPCommandBar | protectedvirtual
OnTrackEnter() | CXTPCommandBar | virtual
OnTrackLost() | CXTPCommandBar | virtual
Popup(int xPos, int yPos, LPCRECT rcExclude) | CXTPPopupBar |
Popup(CXTPControlPopup *pControlPopup, BOOL bSelectFirst=FALSE) | CXTPPopupBar | virtual
ProcessSpecialKey(XTPSpecialKey key) | CXTPCommandBar | protectedvirtual
PumpMessage() | CXTPPopupBar |
Redraw(LPCRECT lpRect=0, BOOL bAnimate=TRUE) | CXTPCommandBar | virtual
RestoreCommandBarList(CXTPCommandBarList *pCommandBarList) | CXTPCommandBar | protectedvirtual
s_nExpandDelay | CXTPCommandBar | static
s_nExpandHoverDelay | CXTPCommandBar | static
s_nHoverDelay | CXTPCommandBar | static
SetBarID(UINT nID) | CXTPCommandBar |
SetBorders(CRect rcBorders) | CXTPPopupBar |
SetButtons(UINT *pButtons, int nCount) | CXTPCommandBar |
SetButtonSize(CSize size) | CXTPCommandBar |
SetCommandBarData(DWORD_PTR dwData) | CXTPCommandBar |
SetCommandBars(CXTPCommandBars *pCommandBars) | CXTPCommandBar |
SetControls(CXTPControls *pControls) | CXTPCommandBar |
SetDefaultButtonStyle(XTPButtonStyle buttonStyle) | CXTPCommandBar |
SetDefaultItem(UINT uItem, BOOL fByPos=FALSE) | CXTPPopupBar |
SetDoubleGripper(BOOL bDoubleGripper=TRUE) | CXTPPopupBar |
SetFlags(DWORD dwFlagsAdd, DWORD dwFlagsRemove=0) | CXTPCommandBar |
SetGrabFocus(BOOL bGrabFocus) | CXTPCommandBar |
SetIconSize(CSize size) | CXTPCommandBar |
SetImageManager(CXTPImageManager *pImageManager) | CXTPCommandBar |
SetPaintManager(CXTPPaintManager *pPaintManager) | CXTPCommandBar |
SetPopuped(int nPopuped, BOOL bKeyboard=FALSE) | CXTPCommandBar |
SetPopupFlags(DWORD dwPopupFlags) | CXTPPopupBar |
SetPopupToolBar(BOOL bToolBarType) | CXTPPopupBar |
SetPosition(XTPBarPosition barPosition) | CXTPCommandBar | virtual
SetSelected(int nSelected, BOOL bKeyboard=FALSE) | CXTPPopupBar | protectedvirtual
SetShowGripper(BOOL bShow) | CXTPCommandBar |
SetStatusText(const CString &strDescription) | CXTPCommandBar |
SetTearOffPopup(LPCTSTR lpszCaption, UINT nID, int nWidth=400) | CXTPPopupBar |
SetTextOrientation(XTPBarTextOrientation nTextOrientation) | CXTPCommandBar |
SetTitle(LPCTSTR lpszTitle) | CXTPCommandBar |
SetTrackFocus(HWND hwnd) | CXTPCommandBar |
SetTrackingMode(int bMode, BOOL bSelectFirst=TRUE, BOOL bKeyboard=FALSE) | CXTPPopupBar | virtual
SetVisible(BOOL bVisible) | CXTPCommandBar | virtual
SetWidth(int nWidth) | CXTPCommandBar |
ShowTextBelowIcons(BOOL bTextBelow=TRUE) | CXTPCommandBar |
UnlockMouseMove() | CXTPCommandBar |
UnlockRedraw() | CXTPCommandBar |
UpdateExpandingState() | CXTPPopupBar | protected
UpdateFlags() | CXTPPopupBar | protectedvirtual
UpdateLocation(CSize sz) | CXTPPopupBar | protected
UpdateShortcuts() | CXTPCommandBar | protectedvirtual
~CXTPCommandBar() | CXTPCommandBar | protectedvirtual
~CXTPHookManagerHookAble() | CXTPHookManagerHookAble | virtual
~CXTPPopupBar() | CXTPPopupBar | protectedvirtual


Toolkit Pro: Member List

CXTPChartPointSeriesView Member List

This is the complete list of members for CXTPChartPointSeriesView, including all inherited members.

AddChildView(CXTPChartElementView *pChildView) | CXTPChartElementView |
CreateDeviceCommand(CXTPChartDeviceContext *pDC) | CXTPChartElementView | virtual
CreateLegendDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcBounds) | CXTPChartPointSeriesView | virtual
CreateSeriesPointView(CXTPChartDeviceContext *pDC, CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView) | CXTPChartPointSeriesView | protected
CXTPChartElementView(CXTPChartElementView *pParentView) | CXTPChartElementView |
CXTPChartElementView(CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartElementView |
CXTPChartElementView(CXTPChartContainer *pContainer) | CXTPChartElementView |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartPointSeriesView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView) | CXTPChartPointSeriesView |
GetAt(int nIndex) const | CXTPChartElementView |
GetBounds() const | CXTPChartElementView |
GetBounds(BOOL bIncludingChildren) const | CXTPChartElementView |
GetChildren() | CXTPChartElementView |
GetCount() const | CXTPChartElementView |
GetParentView() const | CXTPChartElementView |
Is3D() const | CXTPChartObject |
m_arrChildren | CXTPChartElementView | protected
m_pContainer | CXTPChartElementView | protected
m_pParentView | CXTPChartElementView | protected
m_rcBounds | CXTPChartElementView | protected
~CXTPChartElementView() | CXTPChartElementView | protectedvirtual
~CXTPChartLegendItemView() | CXTPChartLegendItemView | inlinevirtual


Toolkit Pro: Member List

CXTPScrollDateButtonPart Member List

This is the complete list of members for CXTPScrollDateButtonPart, including all inherited members.

AdjustLayout(CDC *pDC, const CRect &rcRect) | CXTPScrollDateButtonPart | virtual
CXTPCalendarCaptionBarThemePart(CXTPCalendarCaptionBarTheme *pTheme, int nPartID) | CXTPCalendarCaptionBarThemePart |
CXTPCalendarWMHandler() | CXTPCalendarWMHandler |
CXTPCmdTarget() | CXTPCmdTarget |
Draw(CDC *pDC) | CXTPScrollDateButtonPart | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCheck() const | CXTPCalendarCaptionBarThemePart | virtual
GetChildHandlerAt(int nIndex) const | CXTPCalendarWMHandler | virtual
GetChildHandlersCount() const | CXTPCalendarWMHandler | virtual
GetPaintManager() const | CXTPCalendarCaptionBarThemePart |
GetPaintTheme() const | CXTPCalendarCaptionBarThemePart | virtual
GetPartID() const | CXTPCalendarCaptionBarThemePart | virtual
GetRect() const | CXTPCalendarCaptionBarThemePart | virtual
GetState() const | CXTPCalendarCaptionBarThemePart |
GetText() const | CXTPCalendarCaptionBarThemePart | virtual
GetTextColor() | CXTPCalendarCaptionBarThemePart | virtual
GetTheme() const | CXTPCalendarCaptionBarThemePart | virtual
HitTest(const CPoint &pt) const | CXTPCalendarCaptionBarThemePart | virtual
IsVisible() const | CXTPCalendarCaptionBarThemePart | virtual
m_bVisible | CXTPCalendarCaptionBarThemePart | protected
m_clrTextColor | CXTPCalendarCaptionBarThemePart |
m_nPartID | CXTPCalendarCaptionBarThemePart | protected
m_nState | CXTPCalendarCaptionBarThemePart |
m_pTheme | CXTPCalendarCaptionBarThemePart | protected
m_rcRect | CXTPCalendarCaptionBarThemePart |
m_strText | CXTPCalendarCaptionBarThemePart |
OnBeforeDestroy() | CXTPCalendarWMHandler | virtual
OnChar(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPScrollDateButtonPart | virtual
OnKeyUp(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPScrollDateButtonPart | virtual
OnLButtonDblClk(UINT nFlags, CPoint point) | CXTPCalendarWMHandler | virtual
OnLButtonDown(UINT nFlags, CPoint point) | CXTPScrollDateButtonPart | virtual
OnLButtonUp(UINT nFlags, CPoint point) | CXTPCalendarCaptionBarThemePart | virtual
OnMouseMove(UINT nFlags, CPoint point) | CXTPCalendarCaptionBarThemePart | virtual
OnPostAdjustLayout() | CXTPCalendarWMHandler | virtual
OnSysKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnTimer(UINT_PTR uTimerID) | CXTPCalendarWMHandler | virtual
OnWndMsg(UINT message, WPARAM wParam, LPARAM lParam, LRESULT *pResult) | CXTPCalendarWMHandler | virtual
Redraw(BOOL bUpdateNow=FALSE) | CXTPCalendarCaptionBarThemePart | virtual
RefreshMetrics() | CXTPCalendarCaptionBarThemePart | inlinevirtual
SetCheck(int nCheck) | CXTPCalendarCaptionBarThemePart | virtual
SetState(int nState) | CXTPCalendarCaptionBarThemePart | virtual
SetText(LPCTSTR pcszText) | CXTPCalendarCaptionBarThemePart | virtual
SetVisible(BOOL bVisible) | CXTPCalendarCaptionBarThemePart | virtual
~CXTPCalendarCaptionBarThemePart() | CXTPCalendarCaptionBarThemePart | virtual


Toolkit Pro: Member List

CXTPTaskPanelVisualStudio2010Theme Member List

This is the complete list of members for CXTPTaskPanelVisualStudio2010Theme, including all inherited members.

BlendColor(COLORREF clrFrom, COLORREF clrTo, int nAlpha) | CXTPTaskPanelPaintManager | protected
CreateGripperBitmaps() | CXTPTaskPanelPaintManager | protected
CreateGripperIcon(HICON &hIcon, UINT nIDResource, COLORREF clrGripperBack) | CXTPTaskPanelPaintManager | protected
CXTPTaskPanelPaintManager() | CXTPTaskPanelPaintManager |
CXTPTaskPanelPaintManagerPlain() | CXTPTaskPanelPaintManagerPlain |
CXTPTaskPanelToolboxTheme() | CXTPTaskPanelToolboxTheme |
CXTPTaskPanelVisualStudio2005Theme() | CXTPTaskPanelVisualStudio2005Theme |
CXTPTaskPanelVisualStudio2010Theme() | CXTPTaskPanelVisualStudio2010Theme |
DrawCaptionGripper(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelPaintManager | protectedvirtual
DrawCaptionGripperBitmap(CDC *pDC, CXTPTaskPanelGroup *pGroup, BOOL bExpanded, BOOL bHot, CRect rc) | CXTPTaskPanelPaintManager | protected
DrawCaptionGripperSigns(CDC *pDC, CPoint pt, COLORREF clr, BOOL bExpanded) | CXTPTaskPanelPaintManager | protected
DrawDragArrow(CDC *pDC, CXTPTaskPanelItem *pItem, CRect rc, BOOL bAfter=FALSE) | CXTPTaskPanelPaintManager | protectedvirtual
DrawFocusRect(CDC *pDC, CRect rc) | CXTPTaskPanelPaintManager | protectedvirtual
DrawGroupCaption(CDC *pDC, CXTPTaskPanelGroup *pGroup, BOOL bDraw) | CXTPTaskPanelToolboxTheme | virtual
DrawGroupCaptionBackground(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelVisualStudio2010Theme | virtual
DrawGroupClient(CDC *pDC, CXTPTaskPanelGroup *pGroup) | CXTPTaskPanelPaintManager | virtual
DrawGroupClientFace(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelVisualStudio2010Theme | virtual
DrawGroupClientItems(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelPaintManager | protectedvirtual
DrawGroupItem(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw) | CXTPTaskPanelPaintManager | virtual
DrawGroupItemFrame(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc) | CXTPTaskPanelPaintManager | virtual
DrawGroupItemImage(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw) | CXTPTaskPanelPaintManager | protected
DrawGroupItemImageWithText(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw) | CXTPTaskPanelPaintManager | protected
DrawGroupItemImageWithTextBelow(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw) | CXTPTaskPanelPaintManager | protected
DrawItemCaption(CDC *pDC, CXTPTaskPanelItem *pItem, CRect rcText, UINT nFormat) | CXTPTaskPanelPaintManager | protectedvirtual
DrawItemImage(CDC *pDC, CXTPTaskPanelItem *pItem, CPoint ptIcon, CXTPImageManagerIcon *pImage, CSize szIcon) | CXTPTaskPanelPaintManager | protectedvirtual
DrawScrollButton(CDC *pDC, CXTPTaskPanelScrollButton *pScrollButton) | CXTPTaskPanelPaintManager | virtual
FillGroupClientFace(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelVisualStudio2010Theme | virtual
FillTaskPanel(CDC *pDC, CXTPTaskPanel *pTaskPanel) | CXTPTaskPanelVisualStudio2010Theme | virtual
FreeBitmaps() | CXTPTaskPanelPaintManager | protected
GetCaptionGripperWidth(CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelPaintManager | protectedvirtual
GetControlMargins(const CXTPTaskPanel *pPanel) | CXTPTaskPanelPaintManager | virtual
GetGroupColors(BOOL bSpecial) | CXTPTaskPanelPaintManager |
GetGroupColors(CXTPTaskPanelGroup *pGroup) | CXTPTaskPanelPaintManager | virtual
GetGroupInnerMargins(const CXTPTaskPanelGroup *pGroup) | CXTPTaskPanelPaintManager | virtual
GetGroupOuterMargins(const CXTPTaskPanelGroup *pGroup) | CXTPTaskPanelPaintManager | virtual
GetGroupSpacing(const CXTPTaskPanel *pPanel) | CXTPTaskPanelPaintManager | virtual
GetHighlightOffset(CXTPTaskPanelGroupItem *pItem) | CXTPTaskPanelPaintManager | protectedvirtual
GetItemFont(CXTPTaskPanelItem *pItem) | CXTPTaskPanelPaintManager | virtual
GetItemIconPadding(const CXTPTaskPanelItem *pItem) | CXTPTaskPanelPaintManager | virtual
GetItemInnerMargins(const CXTPTaskPanelGroupItem *pItem) | CXTPTaskPanelPaintManager | virtual
GetItemOuterMargins(const CXTPTaskPanelGroupItem *pItem) | CXTPTaskPanelPaintManager | virtual
m_bBoldCaption | CXTPTaskPanelPaintManager |
m_bCaptionScrollButton | CXTPTaskPanelPaintManager |
m_bEmbossedDisabledText | CXTPTaskPanelPaintManager |
m_bEmulateEplorerTheme | CXTPTaskPanelPaintManager |
m_bInvertDragRect | CXTPTaskPanelPaintManager |
m_bLeftRoundedCorner | CXTPTaskPanelPaintManager | protected
m_bmpGrippers | CXTPTaskPanelPaintManager | protected
m_bOfficeBorder | CXTPTaskPanelPaintManager | protected
m_bOfficeCaption | CXTPTaskPanelPaintManagerPlain | protected
m_bOfficeHighlight | CXTPTaskPanelPaintManager |
m_bRightRoundedCorner | CXTPTaskPanelPaintManager | protected
m_bRoundedFrame | CXTPTaskPanelPaintManagerPlain | protected
m_bUseBitmapGrippers | CXTPTaskPanelPaintManager | protected
m_bUseStandardCaptionFont | CXTPTaskPanelPaintManager | protected
m_bUseStandardItemsFont | CXTPTaskPanelPaintManager | protected
m_clrBackground | CXTPTaskPanelPaintManager | protected
m_clrHighlightBorder | CXTPTaskPanelPaintManager | protected
m_clrHighlightHot | CXTPTaskPanelPaintManager | protected
m_clrHighlightPressed | CXTPTaskPanelPaintManager | protected
m_clrHighlightSelected | CXTPTaskPanelPaintManager | protected
m_eGripper | CXTPTaskPanelPaintManager |
m_groupNormal | CXTPTaskPanelPaintManager | protected
m_groupSpecial | CXTPTaskPanelPaintManager | protected
m_hGripperNormal | CXTPTaskPanelPaintManager | protected
m_hGripperSpecial | CXTPTaskPanelPaintManager | protected
m_nCaptionHeight | CXTPTaskPanelPaintManager | protected
m_nCaptionTextFormat | CXTPTaskPanelPaintManager | protected
m_nGroupSpacing | CXTPTaskPanelPaintManager |
m_nItemTextFormat | CXTPTaskPanelPaintManager | protected
m_rcControlMargins | CXTPTaskPanelPaintManager |
m_rcGroupIconPadding | CXTPTaskPanelPaintManager |
m_rcGroupInnerMargins | CXTPTaskPanelPaintManager |
m_rcGroupOuterMargins | CXTPTaskPanelPaintManager |
m_rcImageLayoutIconPadding | CXTPTaskPanelPaintManager |
m_rcItemIconPadding | CXTPTaskPanelPaintManager |
m_rcItemInnerMargins | CXTPTaskPanelPaintManager |
m_rcItemOuterMargins | CXTPTaskPanelPaintManager |
m_xtpFontCaption | CXTPTaskPanelPaintManager | protected
m_xtpFontIcon | CXTPTaskPanelPaintManager | protected
m_xtpFontIconBold | CXTPTaskPanelPaintManager | protected
m_xtpFontIconHot | CXTPTaskPanelPaintManager | protected
m_xtpFontIconHotBold | CXTPTaskPanelPaintManager | protected
Rectangle(CDC *pDC, CRect rc, COLORREF clrPen, COLORREF clrBrush) | CXTPTaskPanelPaintManager | protected
rectDefault | CXTPTaskPanelPaintManager | static
RefreshMetrics() | CXTPTaskPanelVisualStudio2010Theme | virtual
SetCaptionFontIndirect(LOGFONT *pLogFont, BOOL bUseStandardCaptionFont=FALSE) | CXTPTaskPanelPaintManager |
SetItemsFontIndirect(LOGFONT *pLogFont, BOOL bUseStandardItemsFont=FALSE) | CXTPTaskPanelPaintManager |
SetTextFormat(int nTextFormat, BOOL bCaption=FALSE) | CXTPTaskPanelPaintManager |
~CXTPTaskPanelPaintManager() | CXTPTaskPanelPaintManager | virtual
~CXTPTaskPanelVisualStudio2010Theme() | CXTPTaskPanelVisualStudio2010Theme |


Toolkit Pro: XTPChartFunnelSeriesStyleBase.h Source File

  • Source
  • Chart
  • Styles
  • Funnel
  • Base
XTPChartFunnelSeriesStyleBase.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTFUNNELSERIESSTYLEBASE_H__)
24# define __XTPCHARTFUNNELSERIESSTYLEBASE_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartSeriesView;
34class CXTPChartBorder;
35class CXTPChartFillStyle;
36
48class _XTP_EXT_CLASS CXTPChartFunnelSeriesStyleBase : public CXTPChartSeriesStyle
49{
51 DECLARE_DYNAMIC(CXTPChartFunnelSeriesStyleBase)
53public:
58 CXTPChartFunnelSeriesStyleBase();
59
64 virtual ~CXTPChartFunnelSeriesStyleBase();
65
66public:
74 int GetPointDistance() const;
75
82 void SetPointDistance(int nPointDistance);
83
91 double GetHeightToWidthRatio() const;
92
99 void SetHeightToWidthRatio(double dRatio);
100
107 void SetEqualHeight(BOOL bEqualHeight);
108
116 BOOL IsEqualHeight() const;
117
126 CXTPChartFillStyle* GetFillStyle() const;
127
135 CXTPChartBorder* GetBorder() const;
136
143 void DoPropExchange(CXTPPropExchange* pPX);
144
145protected:
153 CXTPChartDiagram* CreateDiagram() = 0;
154
165 CXTPChartSeriesView* CreateView(CXTPChartSeries* pSeries,
166 CXTPChartDiagramView* pDiagramView) = 0;
167
177 BOOL IsStyleDiagram(CXTPChartDiagram* pDiagram) const;
178
180# ifdef _XTP_ACTIVEX
181public:
182 DECLARE_DISPATCH_MAP()
183 DECLARE_INTERFACE_MAP()
184# endif
187protected:
189 double m_dHeightToWidthRatio;
190 int m_nPointDistance;
191 CXTPChartBorder* m_pBorder;
192 CXTPChartFillStyle* m_pFillStyle;
193 BOOL m_bEqualHeight;
195};
196
197AFX_INLINE int CXTPChartFunnelSeriesStyleBase::GetPointDistance() const
198{
199 return m_nPointDistance;
200}
201AFX_INLINE void CXTPChartFunnelSeriesStyleBase::SetPointDistance(int nPointDistance)
202{
203 m_nPointDistance = nPointDistance;
204 OnChartChanged();
205}
206AFX_INLINE CXTPChartFillStyle* CXTPChartFunnelSeriesStyleBase::GetFillStyle() const
207{
208 return m_pFillStyle;
209}
210AFX_INLINE CXTPChartBorder* CXTPChartFunnelSeriesStyleBase::GetBorder() const
211{
212 return m_pBorder;
213}
214AFX_INLINE void CXTPChartFunnelSeriesStyleBase::SetHeightToWidthRatio(double dRatio)
215{
216 m_dHeightToWidthRatio = dRatio;
217 OnChartChanged();
218}
219AFX_INLINE double CXTPChartFunnelSeriesStyleBase::GetHeightToWidthRatio() const
220{
221 return m_dHeightToWidthRatio;
222}
223AFX_INLINE void CXTPChartFunnelSeriesStyleBase::SetEqualHeight(BOOL bEqualHeight)
224{
225 m_bEqualHeight = bEqualHeight;
226 OnChartChanged();
227}
228AFX_INLINE BOOL CXTPChartFunnelSeriesStyleBase::IsEqualHeight() const
229{
230 return m_bEqualHeight;
231}
233# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
234#endif //#if !defined(__XTPCHARTFUNNELSERIESSTYLEBASE_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartBorder
This class abstracts the border of a chart, it is a kind of chart element.
Definition XTPChartBorder.h:42
CXTPChartDiagram
This class represents a chart diagram, which is a kind of CXTPChartElement.
Definition XTPChartDiagram.h:48
CXTPChartDiagramView
This class represents the view of a chart diagram, which is a kind of CXTPChartElementView.
Definition XTPChartDiagramView.h:49
CXTPChartElement::OnChartChanged
virtual void OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic propertie...
CXTPChartFillStyle
This class abstracts a fill style used to fill the background of various chart elements.
Definition XTPChartFillStyle.h:43
CXTPChartFunnelSeriesStyleBase
This class abstracts the basic style of a funnel serie.This class is a kind of CXTPChartSeriesStyle.
Definition XTPChartFunnelSeriesStyleBase.h:49
CXTPChartFunnelSeriesStyleBase::~CXTPChartFunnelSeriesStyleBase
virtual ~CXTPChartFunnelSeriesStyleBase()
Destroys a CXTPChartFunnelSeriesStyleBase object, handle cleanup.
CXTPChartFunnelSeriesStyleBase::IsEqualHeight
BOOL IsEqualHeight() const
Gets equal height flag.
Definition XTPChartFunnelSeriesStyleBase.h:228
CXTPChartFunnelSeriesStyleBase::DoPropExchange
void DoPropExchange(CXTPPropExchange *pPX)
Reads or writes this object from or to an archive.
CXTPChartFunnelSeriesStyleBase::CreateView
CXTPChartSeriesView * CreateView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)=0
This virtual method is called to create new view associated with current style.
CXTPChartFunnelSeriesStyleBase::SetEqualHeight
void SetEqualHeight(BOOL bEqualHeight)
Sets equal height flag.
Definition XTPChartFunnelSeriesStyleBase.h:223
CXTPChartFunnelSeriesStyleBase::GetFillStyle
CXTPChartFillStyle * GetFillStyle() const
Call this function to get the background fill style.
Definition XTPChartFunnelSeriesStyleBase.h:206
CXTPChartFunnelSeriesStyleBase::IsStyleDiagram
BOOL IsStyleDiagram(CXTPChartDiagram *pDiagram) const
This method is called to ask style if series can be inserted in existing diagram.
CXTPChartFunnelSeriesStyleBase::SetPointDistance
void SetPointDistance(int nPointDistance)
Sets point distance value.
Definition XTPChartFunnelSeriesStyleBase.h:201
CXTPChartFunnelSeriesStyleBase::GetPointDistance
int GetPointDistance() const
Gets point distance value.
Definition XTPChartFunnelSeriesStyleBase.h:197
CXTPChartFunnelSeriesStyleBase::CreateDiagram
CXTPChartDiagram * CreateDiagram()=0
This method is called to allow style create diagram object.
CXTPChartFunnelSeriesStyleBase::GetHeightToWidthRatio
double GetHeightToWidthRatio() const
Gets height to width ratio of the funnel.
Definition XTPChartFunnelSeriesStyleBase.h:219
CXTPChartFunnelSeriesStyleBase::SetHeightToWidthRatio
void SetHeightToWidthRatio(double dRatio)
Sets height to width ratio of the funnel.
Definition XTPChartFunnelSeriesStyleBase.h:214
CXTPChartFunnelSeriesStyleBase::CXTPChartFunnelSeriesStyleBase
CXTPChartFunnelSeriesStyleBase()
Constructs a CXTPChartFunnelSeriesStyleBase object.
CXTPChartFunnelSeriesStyleBase::GetBorder
CXTPChartBorder * GetBorder() const
Call this function to get the border object.
Definition XTPChartFunnelSeriesStyleBase.h:210
CXTPChartSeries
This class represents a series in the chart, which is a kind of CXTPChartElement.
Definition XTPChartSeries.h:50
CXTPChartSeriesStyle
CXTPChartSeriesStyle is a CXTPChartElement derived class.
Definition XTPChartSeriesStyle.h:49
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72


Toolkit Pro: XTPDockingPaneTabColorSet2012.h Source File

  • Source
  • DockingPane
  • TabColorSets
XTPDockingPaneTabColorSet2012.h
Go to the documentation of this file.
1
23#if !defined(__XTPDOCKINGPANETABCOLORSET2012_H__)
24# define __XTPDOCKINGPANETABCOLORSET2012_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPDockingPaneTabColorSet2012 : public CXTPTabPaintManagerColorSet
39{
40public:
45 CXTPDockingPaneTabColorSet2012();
46
52 virtual void RefreshMetrics();
53
62 virtual COLORREF GetItemColor(CXTPTabManagerItem* pItem);
63
80 virtual void FillNavigateButton(CDC* pDC, CXTPTabManagerNavigateButton* pButton, CRect& rc);
81
96 virtual void FillHeader(CDC* pDC, CRect rc, CXTPTabManager* pTabManager);
97};
98
99# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
101#endif // !defined(__XTPDOCKINGPANETABCOLORSET2012_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPDockingPaneTabColorSet2012
Helper class used to initialize default colors for a theme from an .INI resource and handle drawing r...
Definition XTPDockingPaneTabColorSet2012.h:39
CXTPDockingPaneTabColorSet2012::FillHeader
virtual void FillHeader(CDC *pDC, CRect rc, CXTPTabManager *pTabManager)
This member is called to fill the header of the TabClient of the tab manager.
CXTPDockingPaneTabColorSet2012::GetItemColor
virtual COLORREF GetItemColor(CXTPTabManagerItem *pItem)
Call this member function to retrieve the color for the tab specified by pItem.
CXTPDockingPaneTabColorSet2012::CXTPDockingPaneTabColorSet2012
CXTPDockingPaneTabColorSet2012()
Default class constructor.
CXTPDockingPaneTabColorSet2012::FillNavigateButton
virtual void FillNavigateButton(CDC *pDC, CXTPTabManagerNavigateButton *pButton, CRect &rc)
This member is called to fill the tab navigation buttons.
CXTPDockingPaneTabColorSet2012::RefreshMetrics
virtual void RefreshMetrics()
This member function is used to initialize default colors for a theme from an .INI resource.
CXTPTabManager
CXTPTabManager is the base class for docking pane tabs, tab control tabs, and MDI client tabs.
Definition XTPTabManager.h:87
CXTPTabManagerItem
CXTPTabManagerItem is the base class for the tabs that appear in the command bars tab workspace,...
Definition XTPTabManagerItem.h:44
CXTPTabManagerNavigateButton
CXTPTabManagerNavigateButton is a class used to represent a tab navigation button.
Definition XTPTabManagerNavigateButton.h:74
CXTPTabPaintManagerColorSet
CXTPTabPaintManagerColorSet represents the colors for all of the components of the tab manager (e....
Definition XTPTabPaintManagerColorSet.h:50


Toolkit Pro: XTPMarkupPage.h Source File

  • Source
  • Markup
  • Controls
XTPMarkupPage.h
Go to the documentation of this file.
1
23#if !defined(__XTPMARKUPPAGE_H__)
24# define __XTPMARKUPPAGE_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPMarkupUIElement;
34class CXTPMarkupVisual;
35class CXTPMarkupDrawingContext;
36class CXTPMarkupBuilder;
37class CXTPMarkupObject;
38class CXTPMarkupInputElement;
39class CXTPMarkupUIElement;
40
46class _XTP_EXT_CLASS CXTPMarkupPage : public CXTPMarkupFrameworkElement
47{
49 DECLARE_MARKUPCLASS(CXTPMarkupPage);
51protected:
56 CXTPMarkupPage();
57
62 virtual ~CXTPMarkupPage();
63
64public:
72 void SetContent(CXTPMarkupUIElement* pContent);
73
82 CXTPMarkupUIElement* GetContent() const;
83
84public:
87 // Implementation
88 virtual int GetVisualChildrenCount() const;
89 virtual CXTPMarkupVisual* GetVisualChild(int nIndex) const;
90
91protected:
92 virtual CSize MeasureOverride(CXTPMarkupDrawingContext* pDC, CSize szAvailableSize);
93 virtual CSize ArrangeOverride(CSize szFinalSize);
94 virtual void SetContentObject(CXTPMarkupBuilder* pBuilder, CXTPMarkupObject* pContent);
95 virtual BOOL HasContentObject() const;
96
97 CXTPMarkupInputElement* InputHitTestOverride(CPoint /*point*/) const;
98
99protected:
100 CXTPMarkupUIElement* m_pContent;
104public:
105 DECLARE_DISPATCH_MAP()
106# ifdef _XTP_ACTIVEX
107 DECLARE_INTERFACE_MAP()
108 DECLARE_OLETYPELIB_EX(CXTPMarkupPage);
109# endif
110
111 afx_msg LPDISPATCH OleGetChild();
112 afx_msg void OleSetChild(LPDISPATCH lpDisp);
114};
115
116class _XTP_EXT_CLASS CXTPMarkupWindowContainer : public CXTPMarkupFrameworkElement
117{
118 DECLARE_MARKUPCLASS(CXTPMarkupWindowContainer);
119
120protected:
125 CXTPMarkupWindowContainer();
126
131 virtual ~CXTPMarkupWindowContainer();
132
133public:
141 void SetChild(HWND hwndContent);
142
151 HWND GetChild() const;
152
153public:
156 // Implementation
157
158protected:
159 virtual CSize MeasureOverride(CXTPMarkupDrawingContext* pDC, CSize szAvailableSize);
160 virtual CSize ArrangeOverride(CSize szFinalSize);
161 void OnRender(CXTPMarkupDrawingContext* pDC);
162 void RenderClipped(CXTPMarkupDrawingContext* pDC);
163
164protected:
165 HWND m_hWndChild;
166 CSize m_szChild;
170public:
171 DECLARE_DISPATCH_MAP()
172# ifdef _XTP_ACTIVEX
173 DECLARE_INTERFACE_MAP()
174 DECLARE_OLETYPELIB_EX(CXTPMarkupWindowContainer);
175# endif
176
177 afx_msg HWND OleGetChild();
178 afx_msg void OleSetChild(HWND hWnd);
180};
182AFX_INLINE int CXTPMarkupPage::GetVisualChildrenCount() const
183{
184 return m_pContent != NULL ? 1 : 0;
185}
186AFX_INLINE CXTPMarkupVisual* CXTPMarkupPage::GetVisualChild(int nIndex) const
187{
188 return nIndex == 0 ? m_pContent : NULL;
189}
191# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
193#endif // !defined(__XTPMARKUPPAGE_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPMarkupFrameworkElement
This class represents the provided framework-level implementation built on CXTPMarkupUIElement.
Definition XTPMarkupFrameworkElement.h:44
CXTPMarkupPage
CXTPMarkupPage is a CXTPMarkupFrameworkElement derived class.
Definition XTPMarkupPage.h:47
CXTPMarkupPage::CXTPMarkupPage
CXTPMarkupPage()
Constructs a CXTPMarkupPage object.
CXTPMarkupPage::GetContent
CXTPMarkupUIElement * GetContent() const
Retrieves the child object for the page element.
CXTPMarkupPage::SetContent
void SetContent(CXTPMarkupUIElement *pContent)
Sets the child object for the page element.
CXTPMarkupPage::~CXTPMarkupPage
virtual ~CXTPMarkupPage()
Destroys a CXTPMarkupPage object, handles cleanup and deallocation.
CXTPMarkupUIElement
Base class for XML Markup core level implementations.
Definition XTPMarkupUIElement.h:43
CXTPMarkupVisual
Provides rendering support for XML Markup, which includes hit testing, coordinate transformation,...
Definition XTPMarkupInputElement.h:223
CXTPMarkupVisual::InputHitTestOverride
virtual CXTPMarkupInputElement * InputHitTestOverride(CPoint point) const
Override this method in the derived class to provide visual hit testing of a child object.
CXTPMarkupVisual::RenderClipped
virtual void RenderClipped(CXTPMarkupDrawingContext *drawingContext)
Called by the framework when an element is clipped and no rendering will occur.
CXTPMarkupVisual::GetVisualChild
virtual CXTPMarkupVisual * GetVisualChild(int nIndex) const
Retrieves the child Visual object located at a specified index within the parent VisualCollection.
CXTPMarkupVisual::OnRender
virtual void OnRender(CXTPMarkupDrawingContext *drawingContext)
When overridden in a derived class, participates in rendering operations that are directed by the lay...
Definition XTPMarkupInputElement.h:515
CXTPMarkupVisual::GetVisualChildrenCount
virtual int GetVisualChildrenCount() const
Gets the number of child elements for the Visual.


Toolkit Pro: Member List

CXTPMarkupDockPanel Member List

This is the complete list of members for CXTPMarkupDockPanel, including all inherited members.

ApplyRenderTransform(CXTPMarkupDrawingContext *pContext) | CXTPMarkupUIElement | protectedvirtual
Arrange(CRect rcFinalRect) | CXTPMarkupUIElement |
ArrangeCore(CRect rcFinalRect) | CXTPMarkupUIElement | protectedvirtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPMarkupDockPanel() | CXTPMarkupDockPanel | protected
CXTPMarkupFrameworkElement() | CXTPMarkupFrameworkElement | protected
CXTPMarkupPanel() | CXTPMarkupPanel | protected
CXTPMarkupUIElement() | CXTPMarkupUIElement | protected
CXTPMarkupVisual() | CXTPMarkupVisual |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAbsoluteVisualOffset() const | CXTPMarkupVisual | protected
GetActualSize() const | CXTPMarkupFrameworkElement |
GetBackground() const | CXTPMarkupPanel |
GetBoundRect() const | CXTPMarkupVisual |
GetChildren() const | CXTPMarkupPanel |
GetClipToBounds() const | CXTPMarkupFrameworkElement |
GetDesiredSize() const | CXTPMarkupUIElement |
GetDock(CXTPMarkupUIElement *pElement) | CXTPMarkupDockPanel | static
GetFinalRect() const | CXTPMarkupUIElement |
GetHeight() const | CXTPMarkupFrameworkElement |
GetHorizontalAlignment() const | CXTPMarkupFrameworkElement |
GetLastChildFill() const | CXTPMarkupDockPanel |
GetLayoutClip(CRect &rc) const | CXTPMarkupUIElement | protectedvirtual
GetLogicalChild(int nIndex) const | CXTPMarkupVisual | virtual
GetLogicalChildrenCount() const | CXTPMarkupVisual | virtual
GetMargin() const | CXTPMarkupFrameworkElement |
GetMaxHeight() const | CXTPMarkupFrameworkElement |
GetMaxWidth() const | CXTPMarkupFrameworkElement |
GetMinHeight() const | CXTPMarkupFrameworkElement |
GetMinWidth() const | CXTPMarkupFrameworkElement |
GetOpacity() const | CXTPMarkupUIElement | protectedvirtual
GetRenderSize() const | CXTPMarkupVisual |
GetRenderTransform() const | CXTPMarkupUIElement | protected
GetStyle() const | CXTPMarkupFrameworkElement |
GetTag() const | CXTPMarkupFrameworkElement |
GetUpdateRect() const | CXTPMarkupVisual |
GetVerticalAlignment() const | CXTPMarkupFrameworkElement |
GetVisibility() const | CXTPMarkupUIElement |
GetVisualChild(int nIndex) const | CXTPMarkupVisual | virtual
GetVisualChildrenCount() const | CXTPMarkupVisual | virtual
GetVisualOffset() const | CXTPMarkupVisual |
GetVisualParent() const | CXTPMarkupVisual |
GetWidth() const | CXTPMarkupFrameworkElement |
InputHitTest(CPoint point) const | CXTPMarkupVisual |
InputHitTestOverride(CPoint point) const | CXTPMarkupVisual | protectedvirtual
InvalidateArrange() | CXTPMarkupUIElement | virtual
InvalidateMeasure() | CXTPMarkupUIElement | virtual
InvalidateMeasureOverride(CXTPMarkupDrawingContext *pDC) | CXTPMarkupUIElement | protectedvirtual
InvalidateVisual() | CXTPMarkupUIElement | virtual
IsEnabled() const | CXTPMarkupUIElement |
IsFocusable() const | CXTPMarkupUIElement |
IsVisible() const | CXTPMarkupUIElement | virtual
m_bArrangeDirty | CXTPMarkupUIElement | protected
m_bArrangeInProgress | CXTPMarkupUIElement | protected
m_bMeasureDirty | CXTPMarkupUIElement | protected
m_bMeasureInProgress | CXTPMarkupUIElement | protected
m_bNeverArranged | CXTPMarkupUIElement | protected
m_bNeverMeasured | CXTPMarkupUIElement | protected
m_pClipToBoundsProperty | CXTPMarkupUIElement | static
m_pFocusableProperty | CXTPMarkupUIElement | static
m_pIsEnabledProperty | CXTPMarkupUIElement | static
m_pOpacityProperty | CXTPMarkupUIElement | static
m_pRenderTransformOriginProperty | CXTPMarkupUIElement | static
m_pRenderTransformProperty | CXTPMarkupUIElement | static
m_ptVisualOffset | CXTPMarkupVisual | protected
m_pVisibilityProperty | CXTPMarkupUIElement | static
m_rcBoundRect | CXTPMarkupVisual | protected
m_rcFinalRect | CXTPMarkupUIElement | protected
m_rcPrevUpdateRect | CXTPMarkupVisual | protected
m_rcUpdateRect | CXTPMarkupVisual | protected
m_szDesiredSize | CXTPMarkupUIElement | protected
m_szPreviousAvailableSize | CXTPMarkupUIElement | protected
m_szRenderSize | CXTPMarkupVisual | protected
Measure(CXTPMarkupDrawingContext *pDC, CSize szAvailableSize) | CXTPMarkupUIElement |
MeasureCore(CXTPMarkupDrawingContext *pDC, CSize szAvailableSize) | CXTPMarkupUIElement | protectedvirtual
OnRender(CXTPMarkupDrawingContext *drawingContext) | CXTPMarkupVisual | protectedvirtual
OnRenderFocusVisual(CXTPMarkupDrawingContext *drawingContext) | CXTPMarkupVisual | protectedvirtual
PtInRectTransform(const RECT &rect, const POINT &point) const | CXTPMarkupVisual | protected
Render(CXTPMarkupDrawingContext *drawingContext) | CXTPMarkupVisual |
RenderClipped(CXTPMarkupDrawingContext *drawingContext) | CXTPMarkupVisual | protectedvirtual
RestoreRenderTransform(CXTPMarkupDrawingContext *pContext, TransformationMatrices &matrices) | CXTPMarkupUIElement | protectedvirtual
SetBackground(CXTPMarkupBrush *pBrush) | CXTPMarkupPanel |
SetClipToBounds(BOOL bClipToBounds) | CXTPMarkupFrameworkElement |
SetDock(CXTPMarkupUIElement *pElement, XTPMarkupDock dock) | CXTPMarkupDockPanel | static
SetHeight(int nHeight) | CXTPMarkupFrameworkElement |
SetHorizontalAlignment(XTPMarkupHorizontalAlignment alignment) | CXTPMarkupFrameworkElement |
SetLastChildFill(BOOL bLastChildFill) | CXTPMarkupDockPanel |
SetMargin(int nLeft, int nTop, int nRight, int nBottom) | CXTPMarkupFrameworkElement |
SetMargin(int nMargin) | CXTPMarkupFrameworkElement |
SetMaxHeight(int nHeight) | CXTPMarkupFrameworkElement |
SetMaxWidth(int nWidth) | CXTPMarkupFrameworkElement |
SetMinHeight(int nHeight) | CXTPMarkupFrameworkElement |
SetMinWidth(int nWidth) | CXTPMarkupFrameworkElement |
SetTag(CXTPMarkupObject *pTag) | CXTPMarkupFrameworkElement |
SetVerticalAlignment(XTPMarkupVerticalAlignment alignment) | CXTPMarkupFrameworkElement |
SetVisibility(XTPMarkupVisibility visibility) | CXTPMarkupUIElement |
SetWidth(int nWidth) | CXTPMarkupFrameworkElement |
~CXTPMarkupDockPanel() | CXTPMarkupDockPanel | protectedvirtual
~CXTPMarkupFrameworkElement() | CXTPMarkupFrameworkElement | protectedvirtual
~CXTPMarkupPanel() | CXTPMarkupPanel | protectedvirtual
~CXTPMarkupUIElement() | CXTPMarkupUIElement | protectedvirtual
~CXTPMarkupVisual() | CXTPMarkupVisual | virtual


Toolkit Pro: Member List

CXTPTrackUndoDeleteMarkerCommand Member List

This is the complete list of members for CXTPTrackUndoDeleteMarkerCommand, including all inherited members.

CXTPTrackUndoCommand(int nID) | CXTPTrackUndoCommand | protected
CXTPTrackUndoDeleteMarkerCommand(CXTPTrackMarker *pMarker) | CXTPTrackUndoDeleteMarkerCommand |
GetID() const | CXTPTrackUndoCommand |
m_nID | CXTPTrackUndoCommand | protected
m_pMarker | CXTPTrackUndoDeleteMarkerCommand | protected
Undo() | CXTPTrackUndoDeleteMarkerCommand | protectedvirtual
~CXTPTrackUndoCommand() | CXTPTrackUndoCommand | protectedvirtual
~CXTPTrackUndoDeleteMarkerCommand() | CXTPTrackUndoDeleteMarkerCommand | virtual


Toolkit Pro: XTPRect.h Source File

  • Source
  • Common
  • Base
  • Types
XTPRect.h
Go to the documentation of this file.
1
23#if !defined(__XTPRECT_H__)
24# define __XTPRECT_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
34template<class T>
35class CXTPEpsilon
36{
37public:
38 static const T Epsilon;
39};
49template<class T>
50class CXTPRectT
51{
52public:
58 CXTPRectT()
59 : X(T(0))
60 , Y(T(0))
61 , Width(T(0))
62 , Height(T(0))
63 {
64 }
65
71 CXTPRectT(const CXTPRectT& other)
72 : X(other.X)
73 , Y(other.Y)
74 , Width(other.Width)
75 , Height(other.Height)
76 {
77 }
78
85 CXTPRectT(const CRect& rc)
86 : X(T(rc.left))
87 , Y(T(rc.top))
88 , Width(T(rc.Width()))
89 , Height(T(rc.Height()))
90 {
91 }
92
101 CXTPRectT(T x, T y, T width, T height)
102 : X(x)
103 , Y(y)
104 , Width(width)
105 , Height(height)
106 {
107 }
108
116 CXTPRectT(const CXTPPoint2T<T>& location, const CXTPSizeT<T>& size)
117 : X(location.X)
118 , Y(location.Y)
119 , Width(size.Width)
120 , Height(size.Height)
121 {
122 }
123
131 CXTPRectT(const CXTPPoint2T<T>& ptTopLeft, const CXTPPoint2T<T>& ptBottomRight)
132 : X(ptTopLeft.X)
133 , Y(ptTopLeft.Y)
134 , Width(ptBottomRight.X - ptTopLeft.X)
135 , Height(ptBottomRight.Y - ptTopLeft.Y)
136 {
137 Normalize();
138 }
139
146 void SetRect(const CRect& rc)
147 {
148 X = T(rc.left);
149 Y = T(rc.top);
150 Width = T(rc.Width());
151 Height = T(rc.Height());
152 }
153
162 void SetRect(T x, T y, T width, T height)
163 {
164 X = x;
165 Y = y;
166 Width = width;
167 Height = height;
168 }
169
176 void SetRect(const CXTPPoint2T<T>& location, const CXTPSizeT<T>& size)
177 {
178 X = location.X;
179 Y = location.Y;
180 Width = size.Width;
181 Height = size.Height;
182 }
183
190 void SetRect(const CXTPPoint2T<T>& ptTopLeft, const CXTPPoint2T<T>& ptBottomRight)
191 {
192 X = ptTopLeft.X;
193 Y = ptTopLeft.Y;
194 Width = ptBottomRight.X - ptTopLeft.X;
195 Height = ptBottomRight.Y - ptTopLeft.Y;
196 Normalize();
197 }
198
205 void Normalize()
206 {
207 if (Width < T(0))
208 {
209 X += Width;
210 Width = -Width;
211 }
212
213 if (Height < T(0))
214 {
215 Y += Height;
216 Height = -Height;
217 }
218 }
219
227 CXTPPoint2T<T> GetLocation() const
228 {
229 return CXTPPoint2T<T>(X, Y);
230 }
231
238 CXTPSizeT<T> GetSize() const
239 {
240 return CXTPSizeT<T>(Width, Height);
241 }
242
249 T GetLeft() const
250 {
251 return X;
252 }
253
260 T GetTop() const
261 {
262 return Y;
263 }
264
271 T GetRight() const
272 {
273 return X + Width;
274 }
275
282 T GetBottom() const
283 {
284 return Y + Height;
285 }
286
293 bool IsEmptyArea() const
294 {
295 return (Width <= CXTPEpsilon<T>::Epsilon) || (Height <= CXTPEpsilon<T>::Epsilon);
296 }
297
302 void SetEmpty() const
303 {
304 X = Y = Width = Height = T(0);
305 }
306
317 bool Equals(const CXTPRectT& rect) const
318 {
319 return (*this == rect);
320 }
321
329 bool operator==(const CXTPRectT& rect) const
330 {
331 return (X == rect.X) && (Y == rect.Y) && (Width == rect.Width) && (Height == rect.Height);
332 }
333
341 bool operator!=(const CXTPRectT& rect) const
342 {
343 return !(*this == rect);
344 }
345
356 bool Contains(T x, T y) const
357 {
358 return (x >= X) && (x < X + Width) && (y >= Y) && (y < Y + Height);
359 }
360
370 bool Contains(const CXTPPoint2T<T>& pt) const
371 {
372 return Contains(pt.X, pt.Y);
373 }
374
384 bool Contains(const CXTPRectT& rect) const
385 {
386 return (X <= rect.X) && (rect.GetRight() <= GetRight()) && (Y <= rect.Y)
387 && (rect.GetBottom() <= GetBottom());
388 }
389
396 void Inflate(T dx, T dy)
397 {
398 X -= dx;
399 Y -= dy;
400 Width += dx * T(2);
401 Height += dy * T(2);
402 }
403
410 void Inflate(const CXTPPoint2T<T>& point)
411 {
412 Inflate(point.X, point.Y);
413 }
414
424 void DeflateRect(T l, T t, T r, T b)
425 {
426 X += l;
427 Y += t;
428 Width -= l + r;
429 Height -= t + b;
430 }
431
440 bool Intersect(const CXTPRectT& rect)
441 {
442 return Intersect(*this, *this, rect);
443 }
444
455 static bool AFX_CDECL Intersect(CXTPRectT& c, const CXTPRectT& a, const CXTPRectT& b)
456 {
457 T right = min(a.GetRight(), b.GetRight());
458 T bottom = min(a.GetBottom(), b.GetBottom());
459 T left = max(a.GetLeft(), b.GetLeft());
460 T top = max(a.GetTop(), b.GetTop());
461
462 c.X = left;
463 c.Y = top;
464 c.Width = right - left;
465 c.Height = bottom - top;
466 return !c.IsEmptyArea();
467 }
468
476 bool IntersectsWith(const CXTPRectT& rect) const
477 {
478 return (GetLeft() < rect.GetRight()) && (GetTop() < rect.GetBottom())
479 && (GetRight() > rect.GetLeft()) && (GetBottom() > rect.GetTop());
480 }
481
495 static bool AFX_CDECL Union(CXTPRectT& c, const CXTPRectT& a, const CXTPRectT& b)
496 {
497 T right = max(a.GetRight(), b.GetRight());
498 T bottom = max(a.GetBottom(), b.GetBottom());
499 T left = min(a.GetLeft(), b.GetLeft());
500 T top = min(a.GetTop(), b.GetTop());
501
502 c.X = left;
503 c.Y = top;
504 c.Width = right - left;
505 c.Height = bottom - top;
506 return !c.IsEmptyArea();
507 }
508
514 void Offset(const CXTPPoint2T<T>& point)
515 {
516 Offset(point.X, point.Y);
517 }
518
525 void Offset(T dx, T dy)
526 {
527 X += dx;
528 Y += dy;
529 }
530
537 CXTPPoint2T<T> GetCenter()
538 {
539 return CXTPPoint2T<T>(X + Width / T(2), Y + Height / T(2));
540 }
541
546 void Round()
547 {
548 T r = T(CXTPMathUtils::Round(double(X + Width)));
549 T d = T(CXTPMathUtils::Round(double(Y + Height)));
550
551 X = T(CXTPMathUtils::Round(double(X)));
552 Y = T(CXTPMathUtils::Round(double(Y)));
553 Width = r - X;
554 Height = d - Y;
555 }
556
557public:
558 T X;
559 T Y;
560 T Width;
561 T Height;
562};
563
567typedef CXTPRectT<int> CXTPRectI;
568
572typedef CXTPRectT<float> CXTPRectF;
573
577typedef CXTPRectT<double> CXTPRectD;
578
579# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
581#endif // !defined(__XTPRECT_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPRectD
CXTPRectT< double > CXTPRectD
CXTPRectT shortcut for double rectangle object.
Definition XTPRect.h:577
CXTPRectI
CXTPRectT< int > CXTPRectI
CXTPRectT shortcut for integer rectangle object.
Definition XTPRect.h:567
CXTPRectF
CXTPRectT< float > CXTPRectF
CXTPRectT shortcut for float rectangle object.
Definition XTPRect.h:572
CXTPMathUtils::Round
static int AFX_CDECL Round(double dValue)
Rounds a real value taking into account its sign and returns result as integer.
CXTPPoint2T
This class represents a two-dimensional point.
Definition XTPPoint2.h:58
CXTPPoint2T::Y
T Y
The Y coordinate.
Definition XTPPoint2.h:223
CXTPPoint2T::X
T X
The X coordinate.
Definition XTPPoint2.h:222
CXTPRectT
This class abstracts a rectangular entity and its operations.
Definition XTPRect.h:51
CXTPRectT::Round
void Round()
Rounds rectangle components.
Definition XTPRect.h:546
CXTPRectT::IntersectsWith
bool IntersectsWith(const CXTPRectT &rect) const
Call this function to check whether this object intersect with a given rectangle.
Definition XTPRect.h:476
CXTPRectT::Offset
void Offset(T dx, T dy)
Call this function to move the rectangle by an offset.
Definition XTPRect.h:525
CXTPRectT::Contains
bool Contains(const CXTPRectT &rect) const
Call this function to check whether a rectangle is inside the rectangle or not.
Definition XTPRect.h:384
CXTPRectT::operator==
bool operator==(const CXTPRectT &rect) const
Compares to another rectangle.
Definition XTPRect.h:329
CXTPRectT::Union
static bool AFX_CDECL Union(CXTPRectT &c, const CXTPRectT &a, const CXTPRectT &b)
Call this static function to calculates the union of two source rectangles and places the coordinates...
Definition XTPRect.h:495
CXTPRectT::CXTPRectT
CXTPRectT(const CXTPPoint2T< T > &ptTopLeft, const CXTPPoint2T< T > &ptBottomRight)
Overloaded constructor, creates a CXTPRectT object from top-left and bottom-right point objects.
Definition XTPRect.h:131
CXTPRectT::Offset
void Offset(const CXTPPoint2T< T > &point)
Call this function to move the rectangle by an offset.
Definition XTPRect.h:514
CXTPRectT::GetLocation
CXTPPoint2T< T > GetLocation() const
Call this function to get the coordinate location of the rectangle.
Definition XTPRect.h:227
CXTPRectT::CXTPRectT
CXTPRectT(const CRect &rc)
Overloaded constructor, creates a CXTPRectT object from CRect type object and initializes the values.
Definition XTPRect.h:85
CXTPRectT::Width
T Width
The width of the rectangle.
Definition XTPRect.h:560
CXTPRectT::Height
T Height
The height of the rectangle.
Definition XTPRect.h:561
CXTPRectT::CXTPRectT
CXTPRectT(const CXTPPoint2T< T > &location, const CXTPSizeT< T > &size)
Overloaded constructor, creates a CXTPRectT object from point and a size objects.
Definition XTPRect.h:116
CXTPRectT::SetRect
void SetRect(T x, T y, T width, T height)
Sets new rectangle data.
Definition XTPRect.h:162
CXTPRectT::operator!=
bool operator!=(const CXTPRectT &rect) const
Compares to another rectangle.
Definition XTPRect.h:341
CXTPRectT::SetRect
void SetRect(const CXTPPoint2T< T > &location, const CXTPSizeT< T > &size)
Sets new rectangle data from from point and a size objects.
Definition XTPRect.h:176
CXTPRectT::SetEmpty
void SetEmpty() const
Call this function to empty rectangle.
Definition XTPRect.h:302
CXTPRectT::Inflate
void Inflate(T dx, T dy)
Call this function to inflate the rectangle by an arbitrary value.
Definition XTPRect.h:396
CXTPRectT::GetRight
T GetRight() const
Call this function to get the ending x coordinate of the rectangle.
Definition XTPRect.h:271
CXTPRectT::CXTPRectT
CXTPRectT(T x, T y, T width, T height)
Overloaded constructor, creates a CXTPRectT object.
Definition XTPRect.h:101
CXTPRectT::Inflate
void Inflate(const CXTPPoint2T< T > &point)
Call this function to inflate the rectangle by an arbitrary value denoted by a CXTPPoint2T object.
Definition XTPRect.h:410
CXTPRectT::Contains
bool Contains(const CXTPPoint2T< T > &pt) const
Call this function to check whether a point is inside the rectangle or not.
Definition XTPRect.h:370
CXTPRectT::GetCenter
CXTPPoint2T< T > GetCenter()
Call this function to get the center point of the rectangle.
Definition XTPRect.h:537
CXTPRectT::GetSize
CXTPSizeT< T > GetSize() const
Call this function to get the size of the rectangle.
Definition XTPRect.h:238
CXTPRectT::Intersect
bool Intersect(const CXTPRectT &rect)
Call check whether the current rectangle object shares some common area with another rectangle object...
Definition XTPRect.h:440
CXTPRectT::SetRect
void SetRect(const CXTPPoint2T< T > &ptTopLeft, const CXTPPoint2T< T > &ptBottomRight)
Sets new rectangle data from top-left and bottom-right point objects.
Definition XTPRect.h:190
CXTPRectT::IsEmptyArea
bool IsEmptyArea() const
Call this function to check whether the rectangular area is epty.
Definition XTPRect.h:293
CXTPRectT::CXTPRectT
CXTPRectT(const CXTPRectT &other)
Copies rectangle from another rectangle.
Definition XTPRect.h:71
CXTPRectT::SetRect
void SetRect(const CRect &rc)
Sets new rectangle data from from CRect type object and initializes the values.
Definition XTPRect.h:146
CXTPRectT::Contains
bool Contains(T x, T y) const
Call this function to check whether a point is inside the rectangle or not.
Definition XTPRect.h:356
CXTPRectT::Equals
bool Equals(const CXTPRectT &rect) const
Call this function to check whether the current rectangle is equal to another.
Definition XTPRect.h:317
CXTPRectT::Y
T Y
The y coordinate(top).
Definition XTPRect.h:559
CXTPRectT::Intersect
static bool AFX_CDECL Intersect(CXTPRectT &c, const CXTPRectT &a, const CXTPRectT &b)
Call check whether two rectangle objects share common area and save the shared rectangle.
Definition XTPRect.h:455
CXTPRectT::GetLeft
T GetLeft() const
Call this function to get the starting x coordinate of the rectangle.
Definition XTPRect.h:249
CXTPRectT::CXTPRectT
CXTPRectT()
Default constructor, creates a CXTPRectT object and initializes the values to zero.
Definition XTPRect.h:58
CXTPRectT::X
T X
The x coordinate(left).
Definition XTPRect.h:558
CXTPRectT::DeflateRect
void DeflateRect(T l, T t, T r, T b)
Call this function to deflate the rectangle by an arbitrary value denoted by top-left and bottom-righ...
Definition XTPRect.h:424
CXTPRectT::Normalize
void Normalize()
Normalizes rectangle, i.e.
Definition XTPRect.h:205
CXTPRectT::GetBottom
T GetBottom() const
Call this function to get the ending y coordinate of the rectangle.
Definition XTPRect.h:282
CXTPRectT::GetTop
T GetTop() const
Call this function to get the starting y coordinate of the rectangle.
Definition XTPRect.h:260
CXTPSizeT
This class incapsulates size data.
Definition XTPSize.h:40
CXTPSizeT::Width
T Width
The Width component.
Definition XTPSize.h:143
CXTPSizeT::Height
T Height
The Height component.
Definition XTPSize.h:144


Toolkit Pro: XTPChart3dPyramidDiagramView.h Source File

  • Source
  • Chart
  • Styles
  • Pyramid
  • 3D
XTPChart3dPyramidDiagramView.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHART3DPYRAMIDDIAGRAMVIEW_H__)
24# define __XTPCHART3DPYRAMIDDIAGRAMVIEW_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartDiagram;
34class CXTPChartElementView;
35
47class _XTP_EXT_CLASS CXTPChart3dPyramidDiagramView : public CXTPChart3dDiagramView
48{
49 DECLARE_DYNAMIC(CXTPChart3dPyramidDiagramView);
50
51public:
59 CXTPChart3dPyramidDiagramView(CXTPChartDiagram* pDiagram, CXTPChartElementView* pParent);
60};
62# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
63#endif //#if !defined(__XTPCHART3DPYRAMIDDIAGRAMVIEW_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChart3dDiagramView
This class represents the view of a chart diagram, which is a kind of CXTPChartElementView.
Definition XTPChartDiagramView.h:180
CXTPChart3dPyramidDiagramView
This class abstracts the view of a pyramid diagram.
Definition XTPChart3dPyramidDiagramView.h:48
CXTPChart3dPyramidDiagramView::CXTPChart3dPyramidDiagramView
CXTPChart3dPyramidDiagramView(CXTPChartDiagram *pDiagram, CXTPChartElementView *pParent)
Constructs a CXTPChart3dPyramidDiagramView object.
CXTPChartDiagram
This class represents a chart diagram, which is a kind of CXTPChartElement.
Definition XTPChartDiagram.h:48
CXTPChartElementView
This class represents the view of a chart element.
Definition XTPChartElementView.h:47


Toolkit Pro: XTPTaskPanelListViewTheme.h Source File

  • Source
  • TaskPanel
  • Themes
XTPTaskPanelListViewTheme.h
Go to the documentation of this file.
1
23#ifndef XTPTaskPanelListViewTheme_h__
24# define XTPTaskPanelListViewTheme_h__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
39class _XTP_EXT_CLASS CXTPTaskPanelListViewTheme : public CXTPTaskPanelToolboxTheme
40{
41public:
46 CXTPTaskPanelListViewTheme();
47
52 void RefreshMetrics();
53};
55# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
56#endif // XTPTaskPanelListViewTheme_h__
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPTaskPanelListViewTheme
CXTPTaskPanelListViewTheme class represents a List View style theme.
Definition XTPTaskPanelListViewTheme.h:40
CXTPTaskPanelListViewTheme::CXTPTaskPanelListViewTheme
CXTPTaskPanelListViewTheme()
Constructs a CXTPTaskPanelListViewTheme object.
CXTPTaskPanelListViewTheme::RefreshMetrics
void RefreshMetrics()
Refreshes the visual metrics of the task panel.
CXTPTaskPanelToolboxTheme
CXTPTaskPanelToolboxTheme represents a Toolbox style theme.
Definition XTPTaskPanelToolboxTheme.h:40


Toolkit Pro: Member List

CXTPDockingPaneColorSetNativeWindows11 Member List

This is the complete list of members for CXTPDockingPaneColorSetNativeWindows11, including all inherited members.

GetButtonColorSet(CXTPDockingPaneCaptionButton *pButton) | CXTPDockingPaneColorSet | virtual
m_clrBackground | CXTPDockingPaneColorSet |
m_clrBorder | CXTPDockingPaneColorSet |
m_clrCaption | CXTPDockingPaneColorSet |
m_clrGripper | CXTPDockingPaneColorSet |
m_clrSplitter | CXTPDockingPaneColorSet |
m_clrText | CXTPDockingPaneColorSet |
m_csCaptionButtonHot | CXTPDockingPaneColorSet | protected
m_csCaptionButtonNormal | CXTPDockingPaneColorSet | protected
m_csCaptionButtonPressed | CXTPDockingPaneColorSet | protected
RefreshMetrics(CString strSection) | CXTPDockingPaneColorSetNativeWindows11 | virtual
~CXTPDockingPaneColorSet() | CXTPDockingPaneColorSet | virtual


Toolkit Pro: XTPCommandBarsVisualStudio2019Theme.h Source File

  • Source
  • CommandBars
  • Themes
XTPCommandBarsVisualStudio2019Theme.h
Go to the documentation of this file.
1
23#if !defined(__XTPCOMMANDBARSVISUALSTUDIO2019THEME_H__)
24# define __XTPCOMMANDBARSVISUALSTUDIO2019THEME_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
40class _XTP_EXT_CLASS CXTPCommandBarsVisualStudio2019Theme : public CXTPCommandBarsOffice2013Theme
41{
43 DECLARE_DYNAMIC(CXTPCommandBarsVisualStudio2019Theme)
45public:
50 CXTPCommandBarsVisualStudio2019Theme();
51
57 virtual ~CXTPCommandBarsVisualStudio2019Theme();
58
66 virtual void SetStateColor(COLORREF clrState = COLORREF_NULL);
67
75 virtual COLORREF GetStateColor() const;
76
77protected:
86 virtual void DrawSplitButtonFrame(CDC* pDC, CXTPControl* pButton, CRect rc);
87
101 virtual void DrawRectangle(CDC* pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled,
102 BOOL bChecked, BOOL bPopuped, XTPBarType barType,
103 XTPBarPosition barPosition);
104
119 virtual void DrawRectangle(CDC* pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled,
120 BOOL bChecked, BOOL bPopuped, XTPBarType barType,
121 XTPBarPosition barPosition, int nID);
122
131 virtual BOOL DrawRectangle(CDC* pDC, CXTPControl* pButton);
132
139 virtual COLORREF GetControlTextColor(CXTPControl* pButton);
140
152 virtual void DrawGalleryItemBack(CDC* pDC, CRect rcItem, BOOL bEnabled, BOOL bSelected,
153 BOOL bPressed, BOOL bChecked, XTPBarType barType);
154
164 virtual void DrawCheckRect(CDC* pDC, CRect rc, COLORREF clrFore, COLORREF clrBack);
165
175 virtual CSize DrawCommandBarGripper(CDC* pDC, CXTPCommandBar* pBar, BOOL bDraw = TRUE);
176
186 virtual CSize DrawControlComboBox(CDC* pDC, CXTPControlComboBox* pComboBox, BOOL bDraw);
187};
188
206_XTP_EXT_CLASS BOOL AFX_CDECL XTPSetVS2019StateColor(CXTPCommandBars* pCommandBars,
207 COLORREF clrState = COLORREF_NULL);
208
210# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
211#endif // !defined(__XTPCOMMANDBARSVISUALSTUDIO2019THEME_H__)
XTPBarType
XTPBarType
Type of the command bar.
Definition XTPCommandBarsDefines.h:77
XTPBarPosition
XTPBarPosition
Position of the command bar.
Definition XTPCommandBarsDefines.h:52
XTPSetVS2019StateColor
_XTP_EXT_CLASS BOOL AFX_CDECL XTPSetVS2019StateColor(CXTPCommandBars *pCommandBars, COLORREF clrState=COLORREF_NULL)
Call XTPSetVS2019StateColor to set the border and status bar colors for this theme to indicate state ...
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCommandBar
CXTPCommandBar is a CWnd derived class.
Definition XTPCommandBar.h:66
CXTPCommandBars
CXTPCommandBars is a standalone class.
Definition XTPCommandBars.h:165
CXTPCommandBarsOffice2013Theme
The CXTPCommandBarsOffice2013Theme class is used to enable an Office 2013 style theme for Command Bar...
Definition XTPCommandBarsOffice2013Theme.h:63
CXTPCommandBarsVisualStudio2019Theme
The CXTPCommandBarsVisualStudio2019Theme class is used to enable a Visual Studio 2019 style theme for...
Definition XTPCommandBarsVisualStudio2019Theme.h:41
CXTPCommandBarsVisualStudio2019Theme::CXTPCommandBarsVisualStudio2019Theme
CXTPCommandBarsVisualStudio2019Theme()
Constructs a CXTPCommandBarsVisualStudio2019Theme object.
CXTPCommandBarsVisualStudio2019Theme::DrawCheckRect
virtual void DrawCheckRect(CDC *pDC, CRect rc, COLORREF clrFore, COLORREF clrBack)
Helper class called by DrawRectangle to render a checkmark background and border.
CXTPCommandBarsVisualStudio2019Theme::DrawCommandBarGripper
virtual CSize DrawCommandBarGripper(CDC *pDC, CXTPCommandBar *pBar, BOOL bDraw=TRUE)
This method is called to draw the command bar's gripper.
CXTPCommandBarsVisualStudio2019Theme::DrawControlComboBox
virtual CSize DrawControlComboBox(CDC *pDC, CXTPControlComboBox *pComboBox, BOOL bDraw)
This method is called to draw the control.
CXTPCommandBarsVisualStudio2019Theme::DrawSplitButtonFrame
virtual void DrawSplitButtonFrame(CDC *pDC, CXTPControl *pButton, CRect rc)
This method is called to draw the frame for the SplitButton control.
CXTPCommandBarsVisualStudio2019Theme::DrawGalleryItemBack
virtual void DrawGalleryItemBack(CDC *pDC, CRect rcItem, BOOL bEnabled, BOOL bSelected, BOOL bPressed, BOOL bChecked, XTPBarType barType)
This method is called to draw the background for a gallery menu item.
CXTPCommandBarsVisualStudio2019Theme::SetStateColor
virtual void SetStateColor(COLORREF clrState=COLORREF_NULL)
Call this member function to set the application state color for the frame border and status bar.
CXTPCommandBarsVisualStudio2019Theme::DrawRectangle
virtual BOOL DrawRectangle(CDC *pDC, CXTPControl *pButton)
This method is called to fill the control's face.
CXTPCommandBarsVisualStudio2019Theme::GetControlTextColor
virtual COLORREF GetControlTextColor(CXTPControl *pButton)
This method returns the control text color to draw.
CXTPCommandBarsVisualStudio2019Theme::~CXTPCommandBarsVisualStudio2019Theme
virtual ~CXTPCommandBarsVisualStudio2019Theme()
Destroys a CXTPCommandBarsVisualStudio2019Theme object, handles cleanup and deallocation.
CXTPCommandBarsVisualStudio2019Theme::GetStateColor
virtual COLORREF GetStateColor() const
Call this member function to get the application state color for the frame border and status bar.
CXTPCommandBarsVisualStudio2019Theme::DrawRectangle
virtual void DrawRectangle(CDC *pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition)
This method is called to fill the control's face.
CXTPCommandBarsVisualStudio2019Theme::DrawRectangle
virtual void DrawRectangle(CDC *pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition, int nID)
This method is called to fill the control's face.
CXTPControlComboBox
CXTPControlComboBox is a CXTPControl derived class.
Definition XTPControlComboBox.h:381
CXTPControl
CXTPControl is a CXTPCmdTarget derived class.
Definition XTPControl.h:841


Toolkit Pro: XTPMarkupRenderTransform.h Source File

  • Source
  • Markup
  • Transform
XTPMarkupRenderTransform.h
Go to the documentation of this file.
1
23#if !defined(__XTPMARKUPRENDERTRANSFORM_H__)
24# define __XTPMARKUPRENDERTRANSFORM_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPMarkupRotateTransform;
34class CXTPMarkupTransform;
35class CXTPMarkupObject;
36class CXTPMarkupDependencyProperty;
37class CXTPMarkupBuilder;
38
39class _XTP_EXT_CLASS CXTPMarkupRenderTransform : public CXTPMarkupObject
40{
42 DECLARE_MARKUPCLASS(CXTPMarkupRenderTransform);
44public:
45 CXTPMarkupRenderTransform();
46 ~CXTPMarkupRenderTransform();
47
48 CXTPMarkupTransform* GetTransformObject() const;
49 CXTPMarkupObject* GetTargetObject() const;
50
51protected:
52 virtual void SetContentObject(CXTPMarkupBuilder* pBuilder, CXTPMarkupObject* pContent);
53 virtual void OnSetAsProperty(CXTPMarkupDependencyProperty* pProperty,
54 CXTPMarkupObject* pTargetObject);
55
56private:
57 CXTPMarkupDependencyProperty* m_pContentProperty;
58 CXTPMarkupObject* m_pTargetObject;
59
60public:
61 static CXTPMarkupDependencyProperty* m_pPropertyRotateTransform;
62 static CXTPMarkupDependencyProperty* m_pPropertyScaleTransform;
63 static CXTPMarkupDependencyProperty* m_pPropertyTranslateTransform;
64 static CXTPMarkupDependencyProperty* m_pPropertySkewTransform;
65 static CXTPMarkupDependencyProperty* m_pPropertyMatrixTransform;
66
67protected:
68 double m_originX;
69 double m_originY;
70
71public:
72 void SetOrigin(double x, double y);
73 double GetOriginX();
74 double GetOriginY();
75};
76
77AFX_INLINE CXTPMarkupObject* CXTPMarkupRenderTransform::GetTargetObject() const
78{
79 return m_pTargetObject;
80}
81
82AFX_INLINE void CXTPMarkupRenderTransform::SetOrigin(double x, double y)
83{
84 m_originX = x;
85 m_originY = y;
86}
87
88AFX_INLINE double CXTPMarkupRenderTransform::GetOriginX()
89{
90 return m_originX;
91}
92
93AFX_INLINE double CXTPMarkupRenderTransform::GetOriginY()
94{
95 return m_originY;
96}
97
98# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
100#endif // !defined(__XTPMARKUPRENDERTRANSFORM_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPMarkupRotateTransform
Default RotateTransform implementation.
Definition XTPMarkupRotateTransform.h:41
CXTPMarkupTransform
Base class for all markup transformation objects.
Definition XTPMarkupTransform.h:43


Toolkit Pro: Member List

XTP_EDIT_NMHDR_SETSCROLLPOS Member List

This is the complete list of members for XTP_EDIT_NMHDR_SETSCROLLPOS, including all inherited members.

dwUpdate | XTP_EDIT_NMHDR_SETSCROLLPOS
nmhdr | XTP_EDIT_NMHDR_SETSCROLLPOS


Toolkit Pro: XTPMarkupRoutedEvent.h Source File

  • Source
  • Markup
XTPMarkupRoutedEvent.h
Go to the documentation of this file.
1
23#if !defined(__XTPMARKUPROUTEDEVENT_H__)
24# define __XTPMARKUPROUTEDEVENT_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPMarkupType;
34
35class _XTP_EXT_CLASS CXTPMarkupRoutedEvent : public CXTPMarkupDependencyProperty
36{
37public:
38 enum RoutingStrategy
39 {
40 routingDirect = 0,
41 routingBubble = 1
42 };
43
44protected:
45 CXTPMarkupRoutedEvent();
46
47public:
48 virtual BOOL IsEvent() const;
49
50public:
51 static CXTPMarkupRoutedEvent* AFX_CDECL RegisterRoutedEvent(LPCWSTR lpszName,
52 RoutingStrategy routingStrategy,
53 CXTPMarkupType* pOwnerType);
54
56public:
57 DECLARE_DISPATCH_MAP()
58# ifdef _XTP_ACTIVEX
59 DECLARE_INTERFACE_MAP()
60 DECLARE_OLETYPELIB_EX(CXTPMarkupRoutedEvent);
61# endif
62
63 afx_msg BSTR OleGetName();
64
66};
67
68AFX_INLINE BOOL CXTPMarkupRoutedEvent::IsEvent() const
69{
70 return TRUE;
71}
72
73# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
75#endif // !defined(__XTPMARKUPROUTEDEVENT_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h


Toolkit Pro: Member List

CXTPTaskPanelToolboxTheme Member List

This is the complete list of members for CXTPTaskPanelToolboxTheme, including all inherited members.

BlendColor(COLORREF clrFrom, COLORREF clrTo, int nAlpha) | CXTPTaskPanelPaintManager | protected
CreateGripperBitmaps() | CXTPTaskPanelPaintManager | protected
CreateGripperIcon(HICON &hIcon, UINT nIDResource, COLORREF clrGripperBack) | CXTPTaskPanelPaintManager | protected
CXTPTaskPanelPaintManager() | CXTPTaskPanelPaintManager |
CXTPTaskPanelPaintManagerPlain() | CXTPTaskPanelPaintManagerPlain |
CXTPTaskPanelToolboxTheme() | CXTPTaskPanelToolboxTheme |
DrawCaptionGripper(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelPaintManager | protectedvirtual
DrawCaptionGripperBitmap(CDC *pDC, CXTPTaskPanelGroup *pGroup, BOOL bExpanded, BOOL bHot, CRect rc) | CXTPTaskPanelPaintManager | protected
DrawCaptionGripperSigns(CDC *pDC, CPoint pt, COLORREF clr, BOOL bExpanded) | CXTPTaskPanelPaintManager | protected
DrawDragArrow(CDC *pDC, CXTPTaskPanelItem *pItem, CRect rc, BOOL bAfter=FALSE) | CXTPTaskPanelPaintManager | protectedvirtual
DrawFocusRect(CDC *pDC, CRect rc) | CXTPTaskPanelPaintManager | protectedvirtual
DrawGroupCaption(CDC *pDC, CXTPTaskPanelGroup *pGroup, BOOL bDraw) | CXTPTaskPanelToolboxTheme | virtual
DrawGroupCaptionBackground(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelToolboxTheme | protectedvirtual
DrawGroupClient(CDC *pDC, CXTPTaskPanelGroup *pGroup) | CXTPTaskPanelPaintManager | virtual
DrawGroupClientFace(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelPaintManagerPlain | virtual
DrawGroupClientItems(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelPaintManager | protectedvirtual
DrawGroupItem(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw) | CXTPTaskPanelPaintManager | virtual
DrawGroupItemFrame(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc) | CXTPTaskPanelPaintManager | virtual
DrawGroupItemImage(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw) | CXTPTaskPanelPaintManager | protected
DrawGroupItemImageWithText(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw) | CXTPTaskPanelPaintManager | protected
DrawGroupItemImageWithTextBelow(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw) | CXTPTaskPanelPaintManager | protected
DrawItemCaption(CDC *pDC, CXTPTaskPanelItem *pItem, CRect rcText, UINT nFormat) | CXTPTaskPanelPaintManager | protectedvirtual
DrawItemImage(CDC *pDC, CXTPTaskPanelItem *pItem, CPoint ptIcon, CXTPImageManagerIcon *pImage, CSize szIcon) | CXTPTaskPanelPaintManager | protectedvirtual
DrawScrollButton(CDC *pDC, CXTPTaskPanelScrollButton *pScrollButton) | CXTPTaskPanelPaintManager | virtual
FillGroupClientFace(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelPaintManagerPlain | virtual
FillTaskPanel(CDC *pDC, CXTPTaskPanel *pTaskPanel) | CXTPTaskPanelPaintManagerPlain | virtual
FreeBitmaps() | CXTPTaskPanelPaintManager | protected
GetCaptionGripperWidth(CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelPaintManager | protectedvirtual
GetControlMargins(const CXTPTaskPanel *pPanel) | CXTPTaskPanelPaintManager | virtual
GetGroupColors(BOOL bSpecial) | CXTPTaskPanelPaintManager |
GetGroupColors(CXTPTaskPanelGroup *pGroup) | CXTPTaskPanelPaintManager | virtual
GetGroupInnerMargins(const CXTPTaskPanelGroup *pGroup) | CXTPTaskPanelPaintManager | virtual
GetGroupOuterMargins(const CXTPTaskPanelGroup *pGroup) | CXTPTaskPanelPaintManager | virtual
GetGroupSpacing(const CXTPTaskPanel *pPanel) | CXTPTaskPanelPaintManager | virtual
GetHighlightOffset(CXTPTaskPanelGroupItem *pItem) | CXTPTaskPanelPaintManager | protectedvirtual
GetItemFont(CXTPTaskPanelItem *pItem) | CXTPTaskPanelPaintManager | virtual
GetItemIconPadding(const CXTPTaskPanelItem *pItem) | CXTPTaskPanelPaintManager | virtual
GetItemInnerMargins(const CXTPTaskPanelGroupItem *pItem) | CXTPTaskPanelPaintManager | virtual
GetItemOuterMargins(const CXTPTaskPanelGroupItem *pItem) | CXTPTaskPanelPaintManager | virtual
m_bBoldCaption | CXTPTaskPanelPaintManager |
m_bCaptionScrollButton | CXTPTaskPanelPaintManager |
m_bEmbossedDisabledText | CXTPTaskPanelPaintManager |
m_bEmulateEplorerTheme | CXTPTaskPanelPaintManager |
m_bInvertDragRect | CXTPTaskPanelPaintManager |
m_bLeftRoundedCorner | CXTPTaskPanelPaintManager | protected
m_bmpGrippers | CXTPTaskPanelPaintManager | protected
m_bOfficeBorder | CXTPTaskPanelPaintManager | protected
m_bOfficeCaption | CXTPTaskPanelPaintManagerPlain | protected
m_bOfficeHighlight | CXTPTaskPanelPaintManager |
m_bRightRoundedCorner | CXTPTaskPanelPaintManager | protected
m_bRoundedFrame | CXTPTaskPanelPaintManagerPlain | protected
m_bUseBitmapGrippers | CXTPTaskPanelPaintManager | protected
m_bUseStandardCaptionFont | CXTPTaskPanelPaintManager | protected
m_bUseStandardItemsFont | CXTPTaskPanelPaintManager | protected
m_clrBackground | CXTPTaskPanelPaintManager | protected
m_clrHighlightBorder | CXTPTaskPanelPaintManager | protected
m_clrHighlightHot | CXTPTaskPanelPaintManager | protected
m_clrHighlightPressed | CXTPTaskPanelPaintManager | protected
m_clrHighlightSelected | CXTPTaskPanelPaintManager | protected
m_eGripper | CXTPTaskPanelPaintManager |
m_groupNormal | CXTPTaskPanelPaintManager | protected
m_groupSpecial | CXTPTaskPanelPaintManager | protected
m_hGripperNormal | CXTPTaskPanelPaintManager | protected
m_hGripperSpecial | CXTPTaskPanelPaintManager | protected
m_nCaptionHeight | CXTPTaskPanelPaintManager | protected
m_nCaptionTextFormat | CXTPTaskPanelPaintManager | protected
m_nGroupSpacing | CXTPTaskPanelPaintManager |
m_nItemTextFormat | CXTPTaskPanelPaintManager | protected
m_rcControlMargins | CXTPTaskPanelPaintManager |
m_rcGroupIconPadding | CXTPTaskPanelPaintManager |
m_rcGroupInnerMargins | CXTPTaskPanelPaintManager |
m_rcGroupOuterMargins | CXTPTaskPanelPaintManager |
m_rcImageLayoutIconPadding | CXTPTaskPanelPaintManager |
m_rcItemIconPadding | CXTPTaskPanelPaintManager |
m_rcItemInnerMargins | CXTPTaskPanelPaintManager |
m_rcItemOuterMargins | CXTPTaskPanelPaintManager |
m_xtpFontCaption | CXTPTaskPanelPaintManager | protected
m_xtpFontIcon | CXTPTaskPanelPaintManager | protected
m_xtpFontIconBold | CXTPTaskPanelPaintManager | protected
m_xtpFontIconHot | CXTPTaskPanelPaintManager | protected
m_xtpFontIconHotBold | CXTPTaskPanelPaintManager | protected
Rectangle(CDC *pDC, CRect rc, COLORREF clrPen, COLORREF clrBrush) | CXTPTaskPanelPaintManager | protected
rectDefault | CXTPTaskPanelPaintManager | static
RefreshMetrics() | CXTPTaskPanelToolboxTheme | virtual
SetCaptionFontIndirect(LOGFONT *pLogFont, BOOL bUseStandardCaptionFont=FALSE) | CXTPTaskPanelPaintManager |
SetItemsFontIndirect(LOGFONT *pLogFont, BOOL bUseStandardItemsFont=FALSE) | CXTPTaskPanelPaintManager |
SetTextFormat(int nTextFormat, BOOL bCaption=FALSE) | CXTPTaskPanelPaintManager |
~CXTPTaskPanelPaintManager() | CXTPTaskPanelPaintManager | virtual


Toolkit Pro: Member List

CXTPGridHyperlink Member List

This is the complete list of members for CXTPGridHyperlink, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPGridHyperlink(int nHyperTextBegin=0, int nHyperTextLen=0) | CXTPGridHyperlink |
DoPropExchange(CXTPPropExchange *pPX) | CXTPGridHyperlink | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
m_nHyperTextBegin | CXTPGridHyperlink |
m_nHyperTextLen | CXTPGridHyperlink |
m_rcHyperSpot | CXTPGridHyperlink |
operator delete(void *p) | CXTPHeapObjectT< CXTPCmdTarget, CXTPGridDataAllocator > | inline
operator new(size_t nSize) | CXTPHeapObjectT< CXTPCmdTarget, CXTPGridDataAllocator > | inline
~CXTPGridHyperlink() | CXTPGridHyperlink | virtual


Toolkit Pro: XTPTabThemeVisualStudio2022.h Source File

  • Source
  • TabManager
  • Themes
XTPTabThemeVisualStudio2022.h
Go to the documentation of this file.
1
23#if !defined(__XTPTABTHEMEVISUALSTUDIO2022_H__)
24# define __XTPTABTHEMEVISUALSTUDIO2022_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
37class _XTP_EXT_CLASS CXTPTabThemeVisualStudio2022 : public CXTPTabThemeVisualStudio2019
38{
39public:
44 CXTPTabThemeVisualStudio2022();
45
54 virtual void RefreshMetrics();
55
64 virtual XTPTabColorStyle GetDefaultColorSet()
65 {
66 return xtpTabColorVisualStudio2022;
67 }
68};
69
70# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
72#endif // __XTPTABTHEMEVISUALSTUDIO2022_H__
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPTabColorStyle
XTPTabColorStyle
XTPTabColorStyle is an enumeration used to set the color style of tabs.
Definition XTPTabManagerDefines.h:139
xtpTabColorVisualStudio2022
@ xtpTabColorVisualStudio2022
Tabs will use the Visual Studio 2022 color style for the currently set Appearance.
Definition XTPTabManagerDefines.h:174
CXTPTabThemeVisualStudio2019
CXTPTabThemeVisualStudio2019 implements a Visual Studio 2019 tab appearance.
Definition XTPTabThemeVisualStudio2019.h:38
CXTPTabThemeVisualStudio2022
CXTPTabThemeVisualStudio2022 implements a Visual Studio 2022 tab appearance.
Definition XTPTabThemeVisualStudio2022.h:38
CXTPTabThemeVisualStudio2022::GetDefaultColorSet
virtual XTPTabColorStyle GetDefaultColorSet()
Gets the default value of the color set for this theme.
Definition XTPTabThemeVisualStudio2022.h:64
CXTPTabThemeVisualStudio2022::CXTPTabThemeVisualStudio2022
CXTPTabThemeVisualStudio2022()
Constructs a CXTPTabThemeVisualStudio2022 object.
CXTPTabThemeVisualStudio2022::RefreshMetrics
virtual void RefreshMetrics()
Refreshes the appearance metrics.


Toolkit Pro: XTPControlSlider.h Source File

  • Source
  • CommandBars
XTPControlSlider.h
Go to the documentation of this file.
1
23#if !defined(__XTPCONTOLSLIDER_H__)
24# define __XTPCONTOLSLIDER_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPControlSlider;
34
39class _XTP_EXT_CLASS CXTPControlSliderCtrl : public CSliderCtrl
40{
41protected:
43 DECLARE_MESSAGE_MAP()
44
45 //{{AFX_MSG(CXTPControlSliderCtrl)
46 afx_msg BOOL OnEraseBkgnd(CDC* pDC);
47 afx_msg HBRUSH CtlColor(CDC* pDC, UINT nCtlColor);
48 afx_msg void OnLButtonDown(UINT nFlags, CPoint point);
49 afx_msg void OnRButtonDown(UINT nFlags, CPoint point);
50 afx_msg void OnMouseMove(UINT nFlags, CPoint point);
51 afx_msg void HScroll(UINT nSBCode, UINT nPos);
52 afx_msg void VScroll(UINT nSBCode, UINT nPos);
53 //}}AFX_MSG
54 BOOL OnWndMsg(UINT message, WPARAM wParam, LPARAM lParam, LRESULT* pResult);
55 LRESULT OnWindowFromPoint(WPARAM, LPARAM);
58protected:
59 CXTPControlSlider* m_pControl;
61private:
62 friend class CXTPControlSlider;
63};
64
70class _XTP_EXT_CLASS CXTPControlSlider : public CXTPControl
71{
73 DECLARE_XTP_CONTROL(CXTPControlSlider)
75public:
80 CXTPControlSlider();
81
86 virtual ~CXTPControlSlider();
87
88public:
96 void SetPos(int nPos);
97
106 int GetPos();
107
116 void SetRange(int nMin, int nMax);
117
118public:
123 virtual void OnEnabledChanged();
124
125public:
132 CSliderCtrl* GetSliderCtrl() const;
133
142 DWORD GetSliderStyle() const;
143
151 void SetSliderStyle(DWORD dwStyle);
152
153protected:
160 virtual void OnScroll(UINT nSBCode, UINT nPos);
161
162protected:
164 BOOL HasFocus() const;
165 CSize GetSize(CDC* pDC);
166 void Draw(CDC* pDC);
167 void SetRect(CRect rcControl);
168 void SetParent(CXTPCommandBar* pParent);
169 void SetHideFlags(DWORD dwFlags);
170 void OnCalcDynamicSize(DWORD dwMode);
171 void OnClick(BOOL bKeyboard = FALSE, CPoint pt = CPoint(0, 0));
172 virtual void OnThemeChanged();
173 virtual int GetCustomizeMinWidth() const;
174 virtual BOOL IsCustomizeResizeAllow() const;
175 void Copy(CXTPControl* pControl, BOOL bRecursive = FALSE);
176 void DoPropExchange(CXTPPropExchange* pPX);
177
180protected:
181 CXTPControlSliderCtrl* m_pSliderCtrl;
182 int m_nMin;
183 int m_nMax;
184 int m_nPos;
185 DWORD m_dwSliderStyle;
186 CRect m_rcPadding;
188 friend class CXTPControlSliderCtrl;
189
190# ifdef _XTP_COMMANDBARS_ACTIVEX
193 DECLARE_DISPATCH_MAP()
194 DECLARE_INTERFACE_MAP()
195
196 DECLARE_OLETYPELIB_EX(CXTPControlSlider);
197 void OleRangeChanged();
199# endif
200};
202AFX_INLINE BOOL CXTPControlSlider::IsCustomizeResizeAllow() const
203{
204 return TRUE;
205}
206AFX_INLINE int CXTPControlSlider::GetCustomizeMinWidth() const
207{
208 return 20;
209}
211AFX_INLINE CSliderCtrl* CXTPControlSlider::GetSliderCtrl() const
212{
213 return m_pSliderCtrl;
214}
215
217# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
218#endif // !defined(__XTPCONTOLSLIDER_H__)
DECLARE_XTP_CONTROL
#define DECLARE_XTP_CONTROL(class_name)
This macro generates the C++ header code necessary for a CXTPControl-derived class that can be serial...
Definition XTPCommandBarsDefines.h:1169
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCommandBar
CXTPCommandBar is a CWnd derived class.
Definition XTPCommandBar.h:66
CXTPControl
CXTPControl is a CXTPCmdTarget derived class.
Definition XTPControl.h:841
CXTPControl::IsCustomizeResizeAllow
virtual BOOL IsCustomizeResizeAllow() const
This member checks if the user can resize the control.
CXTPControl::GetCustomizeMinWidth
virtual int GetCustomizeMinWidth() const
Retrieves the available minimum width of control.
Definition XTPControl.h:2702
CXTPControlSliderCtrl
Inplace slider control of CXTPControlSlider.
Definition XTPControlSlider.h:40
CXTPControlSliderCtrl::m_pControl
CXTPControlSlider * m_pControl
Parent CXTPControlSlider control.
Definition XTPControlSlider.h:59
CXTPControlSlider
CXTPControlSlider is a CXTPControl derived class.
Definition XTPControlSlider.h:71
CXTPControlSlider::m_dwSliderStyle
DWORD m_dwSliderStyle
Slider style.
Definition XTPControlSlider.h:185
CXTPControlSlider::SetPos
void SetPos(int nPos)
Call this member to set the current position of the slider.
CXTPControlSlider::OnScroll
virtual void OnScroll(UINT nSBCode, UINT nPos)
This method is called when the position of the scrollbar is changed.
CXTPControlSlider::m_nMin
int m_nMin
Lower range.
Definition XTPControlSlider.h:182
CXTPControlSlider::m_pSliderCtrl
CXTPControlSliderCtrl * m_pSliderCtrl
Pointer to slider control.
Definition XTPControlSlider.h:181
CXTPControlSlider::SetSliderStyle
void SetSliderStyle(DWORD dwStyle)
Call this member to set the style of the slider control.
CXTPControlSlider::~CXTPControlSlider
virtual ~CXTPControlSlider()
Destroys a CXTPControlSlider object, handles cleanup and deallocation.
CXTPControlSlider::m_nPos
int m_nPos
Current position of slider.
Definition XTPControlSlider.h:184
CXTPControlSlider::GetSliderCtrl
CSliderCtrl * GetSliderCtrl() const
Call this member to get a pointer to the in-place slider control.
Definition XTPControlSlider.h:211
CXTPControlSlider::CXTPControlSlider
CXTPControlSlider()
Constructs a CXTPControlSlider object.
CXTPControlSlider::m_nMax
int m_nMax
Upper range.
Definition XTPControlSlider.h:183
CXTPControlSlider::SetRange
void SetRange(int nMin, int nMax)
Sets the upper and lower limits of the slider control's range.
CXTPControlSlider::GetPos
int GetPos()
Call this member to get the current position of the slider.
CXTPControlSlider::GetSliderStyle
DWORD GetSliderStyle() const
Call this member to get the style of the slider control.
CXTPControlSlider::m_rcPadding
CRect m_rcPadding
Padding around slider.
Definition XTPControlSlider.h:186
CXTPControlSlider::OnEnabledChanged
virtual void OnEnabledChanged()
This method is called when a control's enabled state is changed.
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72


Toolkit Pro: Member List

CXTPCalendarViewEventSubjectEditor Member List

This is the complete list of members for CXTPCalendarViewEventSubjectEditor, including all inherited members.

CXTPCalendarViewEventSubjectEditor(CXTPCalendarControl *pOwner) | CXTPCalendarViewEventSubjectEditor |
m_pOwner | CXTPCalendarViewEventSubjectEditor | protected
~CXTPCalendarViewEventSubjectEditor() | CXTPCalendarViewEventSubjectEditor | virtual


Toolkit Pro: Member List

CXTPSkinObjectFrame Member List

This is the complete list of members for CXTPSkinObjectFrame, including all inherited members.

CXTPSkinObject() | CXTPSkinObject | protected
CXTPSkinObjectFrame() | CXTPSkinObjectFrame |
GetAccessCriticalSection() const | CXTPSynchronized | inline
GetBorders() const | CXTPSkinObjectFrame |
GetCaptionButtons() | CXTPSkinObjectFrame |
GetClassName() const | CXTPSkinObject |
GetClientBrush(CDC *pDC) | CXTPSkinObjectFrame | virtual
GetColor(int nIndex) const | CXTPSkinObject |
GetMetrics() const | CXTPSkinObject |
GetSkinClass() const | CXTPSkinObject |
GetSkinManager() const | CXTPSkinObject |
IsActive() const | CXTPSkinObjectFrame |
m_arrButtons | CXTPSkinObjectFrame | protected
m_bActive | CXTPSkinObjectFrame | protected
m_bActiveX | CXTPSkinObject | protected
m_bLockFrameDraw | CXTPSkinObjectFrame |
m_bMDIClient | CXTPSkinObjectFrame | protected
m_bRegionChanged | CXTPSkinObjectFrame | protected
m_bWindowsForms | CXTPSkinObject | protected
m_dwDialogTexture | CXTPSkinObjectFrame |
m_dwExStyle | CXTPSkinObjectFrame | protected
m_dwStyle | CXTPSkinObjectFrame | protected
m_pButtonHot | CXTPSkinObjectFrame | protected
m_pButtonPressed | CXTPSkinObjectFrame | protected
m_pManager | CXTPSkinObject | protected
m_pOldWndProc | CXTPSkinObject | protected
m_pSBTrack | CXTPSkinObjectFrame | protected
m_rcBorders | CXTPSkinObjectFrame | protected
m_spi | CXTPSkinObjectFrame | protected
m_strClassName | CXTPSkinObject | protected
m_szFrameRegion | CXTPSkinObjectFrame | protected
OnHookAttached(LPCREATESTRUCT lpcs, BOOL bAuto) | CXTPSkinObjectFrame | protectedvirtual
OnHookDetached(BOOL bAuto) | CXTPSkinObjectFrame | protectedvirtual
OnSkinChanged(BOOL bPrevState, BOOL bNewState) | CXTPSkinObjectFrame | protectedvirtual
RedrawScrollBar(int nBar) | CXTPSkinObjectFrame |
RefreshMetrics() | CXTPSkinObjectFrame | protectedvirtual
~CXTPSkinObject() | CXTPSkinObject | protected
~CXTPSkinObjectFrame() | CXTPSkinObjectFrame | virtual


Toolkit Pro: Member List

CXTPChartAxisCustomLabels Member List

This is the complete list of members for CXTPChartAxisCustomLabels, including all inherited members.

Add(CXTPChartAxisCustomLabel *pCustomLabel) | CXTPChartAxisCustomLabels |
CXTPChartAxisCustomLabels(CXTPChartAxis *pAxis) | CXTPChartAxisCustomLabels |
CXTPChartElement() | CXTPChartElement |
CXTPChartElementCollection() | CXTPChartElementCollection |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
DoPropExchange(CXTPPropExchange *pPX) | CXTPChartAxisCustomLabels | virtual
GetAppearance() const | CXTPChartElement |
GetAt(int nIndex) const | CXTPChartAxisCustomLabels |
GetContent() const | CXTPChartElement |
GetCount() const | CXTPChartElementCollection | virtual
GetOwner() const | CXTPChartElement |
IndexOf(CXTPChartElement *pElement) const | CXTPChartElementCollection |
InsertAt(int nIndex, CXTPChartElement *pElement) | CXTPChartElementCollection |
Is3D() const | CXTPChartObject |
m_arrElements | CXTPChartElementCollection | protected
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartElement | virtual
Release() | CXTPChartElementCollection | virtual
Remove(CXTPChartElement *pElement) | CXTPChartElementCollection | virtual
RemoveAll() | CXTPChartElementCollection | virtual
RemoveAt(int nIndex) | CXTPChartElementCollection | virtual
~CXTPChartAxisCustomLabels() | CXTPChartAxisCustomLabels | virtual
~CXTPChartElement() | CXTPChartElement | virtual
~CXTPChartElementCollection() | CXTPChartElementCollection |


Toolkit Pro: Member List

CXTPColorPicker Member List

This is the complete list of members for CXTPColorPicker, including all inherited members.

CXTPButton() | CXTPButton |
CXTPColorPicker() | CXTPColorPicker |
DoDropDown() | CXTPButton | protected
DrawImage(CDC *pDC, CRect rc) | CXTPButton | virtual
EnableMarkup(BOOL bEnableMarkup=TRUE) | CXTPButton |
GetBorderGap() const | CXTPButton |
GetBorderStyle() const | CXTPButton |
GetButtonBackColor() | CXTPButton | virtual
GetButtonRect() | CXTPButton | virtual
GetButtonStyle() const | CXTPButton |
GetButtonText() | CXTPButton | virtual
GetButtonTextColor() | CXTPButton | virtual
GetChecked() | CXTPButton | virtual
GetColor() const | CXTPColorPicker | virtual
GetContrastColor() const | CXTPColorPicker | protectedvirtual
GetDefaultColor() const | CXTPColorPicker | virtual
GetFlatStyle() const | CXTPButton |
GetGlyphSize(BOOL bCheckBox) | CXTPButton |
GetIcon() const | CXTPButton |
GetImageAlignment() const | CXTPButton | virtual
GetImageGap() const | CXTPButton |
GetImageSize() | CXTPButton | virtual
GetMarkupContext() const | CXTPButton |
GetMarkupUIElement() | CXTPButton |
GetPushButtonStyle() const | CXTPButton |
GetShowFocus() const | CXTPButton |
GetStandardColors() | CXTPColorPicker |
GetTextAlignment() const | CXTPButton | virtual
GetTextImageRelation() const | CXTPButton |
GetTheme() | CXTPButton |
GetThemeColors() | CXTPColorPicker |
GetTooltip() const | CXTPButton |
GetToolTipContext() const | CXTPButton |
GetUseVisualStyle() const | CXTPButton |
InternalTextChanged() | CXTPButton | virtual
IsDpiImageScalingEnabled() const | CXTPButton | virtual
IsDropDownStyle() const | CXTPButton |
IsHighlighted() | CXTPButton | virtual
IsPushButton() const | CXTPButton |
IsPushed() | CXTPColorPicker | virtual
IsTextInColor() const | CXTPColorPicker | virtual
IsTextShown() const | CXTPColorPicker | virtual
m_arStandardColors | CXTPColorPicker | protected
m_arThemeColors | CXTPColorPicker | protected
m_bCaptions | CXTPColorPicker | protected
m_bChecked | CXTPButton |
m_bColorText | CXTPColorPicker | protected
m_bEnableMarkup | CXTPButton |
m_bFlatStyle | CXTPButton |
m_bHot | CXTPButton |
m_bImageDPIScaling | CXTPButton | protected
m_bPopupActive | CXTPColorPicker | protected
m_bPushed | CXTPButton |
m_bShowFocus | CXTPButton |
m_bShowText | CXTPColorPicker | protected
m_bUseVisualStyle | CXTPButton |
m_clrDefault | CXTPColorPicker | protected
m_clrSelected | CXTPColorPicker | protected
m_dwPopup | CXTPColorPicker | protected
m_hWndBuddy | CXTPButton |
m_nBorderGap | CXTPButton |
m_nBorderStyle | CXTPButton |
m_nCols | CXTPColorPicker | protected
m_nExtendedColors | CXTPColorPicker | protected
m_nImageAlignment | CXTPButton |
m_nImageGap | CXTPButton |
m_nPushButtonStyle | CXTPButton |
m_nTextImageRelation | CXTPButton |
m_pExtendedColors | CXTPColorPicker | protected
m_pIcon | CXTPButton |
m_pMarkupContext | CXTPButton | protected
m_pTheme | CXTPButton |
m_pToolTipContext | CXTPButton |
m_pUIElement | CXTPButton | protected
m_strTitleCustom | CXTPColorPicker | protected
m_strTitleStandard | CXTPColorPicker | protected
m_strTitleTheme | CXTPColorPicker | protected
m_strTooltip | CXTPButton |
m_szVectorIcon | CXTPButton |
ModifyCPStyle(DWORD dwRemove, DWORD dwAdd) | CXTPColorPicker | virtual
OnDraw(CDC *pDC) | CXTPButton | protectedvirtual
OnDropDown() | CXTPButton | protectedvirtual
RedrawButton(BOOL bUpdateWindow=FALSE) | CXTPButton |
RefreshMetrics() | CXTPButton | protectedvirtual
SetBitmap(CSize size, UINT nID, BOOL bRedraw=TRUE) | CXTPButton | virtual
SetBorderGap(int nBorderGap) | CXTPButton |
SetBorderStyle(XTPGroupBoxBorderStyle style) | CXTPButton |
SetBuddy(CWnd *pWndBuddy, BOOL bMoveButton=TRUE) | CXTPButton |
SetChecked(BOOL bChecked) | CXTPButton |
SetColor(COLORREF clr) | CXTPColorPicker | virtual
SetColors(XTP_PICK_BUTTON *pColors, int nCount, int nCols=8, LPCTSTR lpszTitle=NULL) | CXTPColorPicker |
SetDefaultColor(COLORREF clrDefault) | CXTPColorPicker | virtual
SetDpiImageScaling(BOOL bEnable) | CXTPButton | virtual
SetFlatStyle(BOOL bFlatStyle=TRUE) | CXTPButton |
SetIcon(CSize size, HICON hIcon, HICON hIconHot=NULL, BOOL bRedraw=TRUE) | CXTPButton | virtual
SetIcon(CSize size, UINT nID, UINT nHotID=0, BOOL bRedraw=TRUE) | CXTPButton | virtual
SetIcon(CSize size, LPCTSTR lpszID, LPCTSTR lpszHotID=NULL, BOOL bRedraw=TRUE) | CXTPButton | virtual
SetIcon(CSize size, CXTPImageManagerIcon *pIcon, BOOL bRedraw=TRUE) | CXTPButton |
SetIcon(CSize size, const CXTPImageManagerIconHandle &hIconHandle, const CXTPImageManagerIconHandle &hIconHotHandle, BOOL bRedraw=TRUE) | CXTPButton | virtual
SetImageAlignment(DWORD dwAlignment) | CXTPButton |
SetImageGap(int nImageGap) | CXTPButton |
SetPushButtonStyle(XTPPushButtonStyle nPushButtonStyle) | CXTPButton |
SetShowFocus(BOOL bShowFocus) | CXTPButton |
SetStandardColors(XTP_PICK_BUTTON *pColors=NULL, int nCount=10, int nCols=10, LPCTSTR lpszTitle=NULL) | CXTPColorPicker |
SetTextAlignment(DWORD dwAlignment) | CXTPButton |
SetTextImageRelation(XTPButtonTextImageRelation relation) | CXTPButton |
SetTheme(XTPControlTheme eTheme) | CXTPButton | virtual
SetTheme(CXTPButtonTheme *pPaintManager) | CXTPButton | virtual
SetThemeColors(XTP_PICK_BUTTON *pColors=NULL, int nCount=10, LPCTSTR lpszTitle=NULL, UINT *pStringIDs=NULL, int ppShadeMatrix[6][10]=NULL) | CXTPColorPicker |
SetThemeColors(XTP_PICK_BUTTON *pColors, int nCount, LPCTSTR lpszTitle, LPCTSTR *ppszStrings, int ppShadeMatrix[6][10]) | CXTPColorPicker |
SetTooltip(LPCTSTR lpszTooltip) | CXTPButton |
SetUseVisualStyle(BOOL bUseVisualStyle=TRUE) | CXTPButton |
ShowCaptions(BOOL bShow) | CXTPColorPicker |
ShowPopupWindow() | CXTPColorPicker | virtual
ShowText(BOOL bShowText) | CXTPColorPicker | virtual
ShowTextInColor(BOOL bColorText) | CXTPColorPicker | virtual
~CXTPButton() | CXTPButton | virtual
~CXTPColorPicker() | CXTPColorPicker | virtual


Toolkit Pro: XTPComboBoxThemeVisualStudio2019.h Source File

  • Source
  • Controls
  • Combo
  • Themes
XTPComboBoxThemeVisualStudio2019.h
Go to the documentation of this file.
1
23#if !defined(__XTPCOMBOBOXTHEMEVISUALSTUDIO2019_H__)
24# define __XTPCOMBOBOXTHEMEVISUALSTUDIO2019_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPComboBoxThemeVisualStudio2019 : public CXTPComboBoxThemeOffice2013
39{
40public:
45 CXTPComboBoxThemeVisualStudio2019();
46
51 virtual ~CXTPComboBoxThemeVisualStudio2019();
52
59 virtual void RefreshMetrics(CXTPComboBox* pComboBox);
60
69 virtual void DrawButton(CDC* pDC, CXTPComboBox* pComboBox, CRect rcBtn);
70};
71
72# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
74#endif // __XTPCOMBOBOXTHEMEVISUALSTUDIO2019_H__
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPComboBox
The CXTPComboBox class provides the functionality of a themed Windows combobox.
Definition XTPComboBox.h:42
CXTPComboBoxThemeOffice2013
Used as the paint manager for a combobox control to render an Office 2013 appearance.
Definition XTPComboBoxThemeOffice2013.h:39
CXTPComboBoxThemeVisualStudio2019
Used as the paint manager for a combobox control to render a Visual Studio 2019 appearance.
Definition XTPComboBoxThemeVisualStudio2019.h:39
CXTPComboBoxThemeVisualStudio2019::~CXTPComboBoxThemeVisualStudio2019
virtual ~CXTPComboBoxThemeVisualStudio2019()
Destructor handles cleanup and deallocation.
CXTPComboBoxThemeVisualStudio2019::RefreshMetrics
virtual void RefreshMetrics(CXTPComboBox *pComboBox)
This member function is called by the theme manager to refresh the visual styles used by each compone...
CXTPComboBoxThemeVisualStudio2019::CXTPComboBoxThemeVisualStudio2019
CXTPComboBoxThemeVisualStudio2019()
Default constructor.
CXTPComboBoxThemeVisualStudio2019::DrawButton
virtual void DrawButton(CDC *pDC, CXTPComboBox *pComboBox, CRect rcBtn)
Called by the paint manager to draw the button portion of the combobox control.


Toolkit Pro: XTPListBoxThemeVisualStudio2017.h Source File

  • Source
  • Controls
  • ListBox
  • Themes
XTPListBoxThemeVisualStudio2017.h
Go to the documentation of this file.
1
23#if !defined(__XTPLISTBOXTHEMEVISUALSTUDIO2017_H__)
24# define __XTPLISTBOXTHEMEVISUALSTUDIO2017_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPListBoxThemeVisualStudio2017 : public CXTPListBoxThemeOffice2013
39{
40public:
45 CXTPListBoxThemeVisualStudio2017();
46};
47
48# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
50#endif // !defined(__XTPLISTBOXTHEMEVISUALSTUDIO2017_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPListBoxThemeOffice2013
CXTPListBoxThemeOffice2013 is used by CXTPListBox to draw an Office 2013 style list box.
Definition XTPListBoxThemeOffice2013.h:39
CXTPListBoxThemeVisualStudio2017
CXTPListBoxThemeVisualStudio2017 is used by CXTPListBox to draw a Visual Studio 2017 style list box.
Definition XTPListBoxThemeVisualStudio2017.h:39
CXTPListBoxThemeVisualStudio2017::CXTPListBoxThemeVisualStudio2017
CXTPListBoxThemeVisualStudio2017()
Default constructor.


Toolkit Pro: Member List

CXTPComboBoxThemeNativeWindows11 Member List

This is the complete list of members for CXTPComboBoxThemeNativeWindows11, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPComboBoxTheme() | CXTPComboBoxTheme |
CXTPComboBoxThemeNativeWindows11() | CXTPComboBoxThemeNativeWindows11 |
CXTPComboBoxThemeOffice2003() | CXTPComboBoxThemeOffice2003 |
CXTPComboBoxThemeOffice2013() | CXTPComboBoxThemeOffice2013 |
CXTPComboBoxThemeVisualStudio() | CXTPComboBoxThemeVisualStudio |
CXTPControlTheme() | CXTPControlTheme |
DrawBackground(CDC *pDC, CXTPComboBox *pComboBox) | CXTPComboBoxThemeOffice2013 | virtual
DrawButton(CDC *pDC, CXTPComboBox *pComboBox, CRect rcBtn) | CXTPComboBoxThemeNativeWindows11 | virtual
DrawButtonTriangle(CDC *pDC, CXTPComboBox *pComboBox, CRect rcBtn) | CXTPComboBoxThemeOffice2013 | virtual
DrawComboBox(CDC *pDC, CXTPComboBox *pComboBox) | CXTPComboBoxTheme | virtual
DrawFrame(HDC hdc, LPRECT lprc, int nSize, HBRUSH hBrush) | CXTPComboBoxTheme | virtual
FillSolidRect(HDC hdc, int x, int y, int cx, int cy, HBRUSH hBrush) | CXTPComboBoxTheme | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetBackColor() const | CXTPComboBoxTheme |
GetBackgroundBrush() const | CXTPComboBoxTheme |
GetTextColor() const | CXTPComboBoxTheme |
GetThemeStyle() const | CXTPControlTheme |
m_clrBackDisabled | CXTPComboBoxTheme |
m_clrBackground | CXTPComboBoxTheme |
m_clrBackHighlight | CXTPComboBoxTheme |
m_clrBorderDisabled | CXTPComboBoxTheme |
m_clrBorderHot | CXTPComboBoxTheme |
m_clrBorderNormal | CXTPComboBoxTheme |
m_clrButtonArrowDisabled | CXTPComboBoxThemeOffice2013 | protected
m_clrButtonArrowHot | CXTPComboBoxTheme |
m_clrButtonArrowNormal | CXTPComboBoxTheme |
m_clrButtonArrowPressed | CXTPComboBoxTheme |
m_clrButtonDisabled | CXTPComboBoxThemeOffice2013 | protected
m_clrButtonHot | CXTPComboBoxTheme |
m_clrButtonNormal | CXTPComboBoxTheme |
m_clrButtonPressed | CXTPComboBoxTheme |
m_clrText | CXTPComboBoxTheme |
m_clrTextDisabled | CXTPComboBoxTheme |
m_clrTextHighlight | CXTPComboBoxTheme |
m_grcButton | CXTPComboBoxTheme |
m_grcButtonHilite | CXTPComboBoxTheme |
m_grcButtonPushed | CXTPComboBoxTheme |
m_nTheme | CXTPControlTheme | protected
m_nThumbWidth | CXTPComboBoxTheme | protected
m_themeComboBox | CXTPComboBoxTheme | protected
m_xtpBrushBackground | CXTPComboBoxTheme | protected
RefreshMetrics(CXTPComboBox *pComboBox) | CXTPComboBoxThemeNativeWindows11 | virtual
ResetBackColor() | CXTPComboBoxTheme |
ResetTextColor() | CXTPComboBoxTheme |
SetBackColor(COLORREF clrBackground) | CXTPComboBoxTheme |
SetTextColor(COLORREF clrText) | CXTPComboBoxTheme |
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static
UpdateBackgroundBrush() | CXTPComboBoxTheme | protected
~CXTPComboBoxTheme() | CXTPComboBoxTheme | virtual
~CXTPComboBoxThemeNativeWindows11() | CXTPComboBoxThemeNativeWindows11 | virtual
~CXTPComboBoxThemeOffice2003() | CXTPComboBoxThemeOffice2003 | virtual
~CXTPComboBoxThemeOffice2013() | CXTPComboBoxThemeOffice2013 | virtual
~CXTPComboBoxThemeVisualStudio() | CXTPComboBoxThemeVisualStudio | virtual


Toolkit Pro: Member List

CXTPMarkupRowDefinitionCollection Member List

This is the complete list of members for CXTPMarkupRowDefinitionCollection, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPMarkupDefinitionCollection() | CXTPMarkupDefinitionCollection |
CXTPMarkupRowDefinitionCollection() | CXTPMarkupRowDefinitionCollection |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetItem(int nIndex) const | CXTPMarkupDefinitionCollection |


Toolkit Pro: Member List

CXTPPropertyGridItemOption Member List

This is the complete list of members for CXTPPropertyGridItemOption, including all inherited members.

AddChildItem(CXTPPropertyGridItem *pItem) | CXTPPropertyGridItem |
AddComboButton() | CXTPPropertyGridItem |
AddExpandButton() | CXTPPropertyGridItem |
AddSliderControl() | CXTPPropertyGridItem |
AddSpinButton() | CXTPPropertyGridItem |
BindToOption(int *pBindOption) | CXTPPropertyGridItemOption |
BindToString(CString *pBindString) | CXTPPropertyGridItem |
Collapse() | CXTPPropertyGridItem |
CXTPCmdTarget() | CXTPCmdTarget |
CXTPPropertyGridItem(LPCTSTR lpszCaption, LPCTSTR strValue=NULL, CString *pBindString=NULL) | CXTPPropertyGridItem |
CXTPPropertyGridItem(UINT nID, LPCTSTR strValue=NULL, CString *pBindString=NULL) | CXTPPropertyGridItem |
CXTPPropertyGridItemOption(LPCTSTR strCaption, int nValue=0, int *pBindOption=NULL) | CXTPPropertyGridItemOption |
CXTPPropertyGridItemOption(UINT nID, int nValue=0, int *pBindOption=NULL) | CXTPPropertyGridItemOption |
EnsureVisible() | CXTPPropertyGridItem |
Expand() | CXTPPropertyGridItem |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCaption() const | CXTPPropertyGridItem |
GetCaptionMetrics() const | CXTPPropertyGridItem |
GetChilds() const | CXTPPropertyGridItem |
GetConstraintEdit() const | CXTPPropertyGridItem |
GetConstraints() const | CXTPPropertyGridItem |
GetDefaultValue() const | CXTPPropertyGridItem |
GetDescription() const | CXTPPropertyGridItem |
GetDropDownItemCount() const | CXTPPropertyGridItem |
GetEditStyle() const | CXTPPropertyGridItem | virtual
GetFlags() const | CXTPPropertyGridItem |
GetGrid() const | CXTPPropertyGridItem |
GetHeight() const | CXTPPropertyGridItem |
GetID() const | CXTPPropertyGridItem |
GetIndent() const | CXTPPropertyGridItem |
GetIndex() const | CXTPPropertyGridItem |
GetInplaceButtons() const | CXTPPropertyGridItem |
GetInplaceControls() const | CXTPPropertyGridItem |
GetInPlacedEditValue() | CXTPPropertyGridItem | inlineprotectedvirtual
GetInplaceEdit() | CXTPPropertyGridItem | virtual
GetInplaceList() | CXTPPropertyGridItem | protectedvirtual
GetItemData() const | CXTPPropertyGridItem |
GetItemRect() const | CXTPPropertyGridItem |
GetMarkupCaption() const | CXTPPropertyGridItem |
GetMarkupDescription() const | CXTPPropertyGridItem |
GetMarkupTemplate() const | CXTPPropertyGridItem | virtual
GetMarkupValue() const | CXTPPropertyGridItem |
GetMaskedText() const | CXTPPropertyGridItem |
GetMetrics(BOOL bValueMetrics, BOOL bCreate=TRUE) const | CXTPPropertyGridItem |
GetMultiLinesCount() const | CXTPPropertyGridItem |
GetOption() const | CXTPPropertyGridItemOption |
GetParentItem() const | CXTPPropertyGridItem |
GetReadOnly() const | CXTPPropertyGridItem | virtual
GetTooltip() const | CXTPPropertyGridItem |
GetValue() const | CXTPPropertyGridItem |
GetValueMetrics() const | CXTPPropertyGridItem |
GetValueRect() | CXTPPropertyGridItem | virtual
GetViewValue() | CXTPPropertyGridItem | virtual
HasChilds() const | CXTPPropertyGridItem |
HasParent(CXTPPropertyGridItem *pParent) | CXTPPropertyGridItem |
HasVisibleChilds() const | CXTPPropertyGridItem |
InsertChildItem(int nIndex, CXTPPropertyGridItem *pItem) | CXTPPropertyGridItem |
IsAllowEdit() const | CXTPPropertyGridItem | virtual
IsCategory() const | CXTPPropertyGridItem |
IsCheckBoxStyle() const | CXTPPropertyGridItemOption |
IsExpandable() const | CXTPPropertyGridItem |
IsExpanded() const | CXTPPropertyGridItem |
IsHidden() const | CXTPPropertyGridItem |
IsInplaceButtonVisible(CXTPPropertyGridInplaceButton *pButton) const | CXTPPropertyGridItem | virtual
IsMultiLine() const | CXTPPropertyGridItem |
IsSelected() const | CXTPPropertyGridItem |
IsValueChanged() const | CXTPPropertyGridItem | virtual
IsVisible() const | CXTPPropertyGridItem |
m_bAutoComplete | CXTPPropertyGridItem | protected
m_bCategory | CXTPPropertyGridItem | protected
m_bCheckBoxStyle | CXTPPropertyGridItemOption | protected
m_bConstraintEdit | CXTPPropertyGridItem | protected
m_bExpandable | CXTPPropertyGridItem | protected
m_bExpanded | CXTPPropertyGridItem | protected
m_bHidden | CXTPPropertyGridItem | protected
m_bPassword | CXTPPropertyGridItem | protected
m_bReadOnly | CXTPPropertyGridItem | protected
m_bUseMask | CXTPPropertyGridItem | protected
m_bVisible | CXTPPropertyGridItem | protected
m_chPrompt | CXTPPropertyGridItem | protected
m_dwData | CXTPPropertyGridItem | protected
m_dwEditStyle | CXTPPropertyGridItem | protected
m_nDropDownItemCount | CXTPPropertyGridItem | protected
m_nFlags | CXTPPropertyGridItem | protected
m_nHeight | CXTPPropertyGridItem | protected
m_nID | CXTPPropertyGridItem | protected
m_nIndent | CXTPPropertyGridItem | protected
m_nIndex | CXTPPropertyGridItem | protected
m_nLinesCount | CXTPPropertyGridItem | protected
m_nValue | CXTPPropertyGridItemOption | protected
m_pBindOption | CXTPPropertyGridItemOption | protected
m_pBindString | CXTPPropertyGridItem | protected
m_pCaptionMetrics | CXTPPropertyGridItem | mutableprotected
m_pChilds | CXTPPropertyGridItem | protected
m_pConstraints | CXTPPropertyGridItem | protected
m_pGrid | CXTPPropertyGridItem | protected
m_pInplaceButtons | CXTPPropertyGridItem | protected
m_pInplaceControls | CXTPPropertyGridItem | protected
m_pMarkupCaption | CXTPPropertyGridItem | protected
m_pMarkupDescription | CXTPPropertyGridItem | protected
m_pMarkupValue | CXTPPropertyGridItem | protected
m_pParent | CXTPPropertyGridItem | protected
m_pValueMetrics | CXTPPropertyGridItem | mutableprotected
m_strCaption | CXTPPropertyGridItem | protected
m_strDefaultValue | CXTPPropertyGridItem | protected
m_strDescription | CXTPPropertyGridItem | protected
m_strFormat | CXTPPropertyGridItem | protected
m_strLiteral | CXTPPropertyGridItem | protected
m_strMarkupTemplate | CXTPPropertyGridItem | protected
m_strMask | CXTPPropertyGridItem | protected
m_strTooltip | CXTPPropertyGridItem | protected
m_strValue | CXTPPropertyGridItem | protected
MeasureItem(LPMEASUREITEMSTRUCT lpMeasureItemStruct) | CXTPPropertyGridItemOption | protectedvirtual
Move(CXTPPropertyGridItem *pParent, int nIndex=-1) | CXTPPropertyGridItem |
NotifyValueChanged() | CXTPPropertyGridItem | protected
OnAddChildItem() | CXTPPropertyGridItem | protectedvirtual
OnAfterEdit(CString &strValue) | CXTPPropertyGridItem | virtual
OnBeforeInsert() | CXTPPropertyGridItemOption | protectedvirtual
OnCancelEdit() | CXTPPropertyGridItem | virtual
OnCaptionChanged() | CXTPPropertyGridItem | protectedvirtual
OnChar(UINT nChar) | CXTPPropertyGridItem | protectedvirtual
OnConstraintsChanged() | CXTPPropertyGridItem | protectedvirtual
OnDeselect() | CXTPPropertyGridItemOption | protectedvirtual
OnDrawItemConstraint(CDC *pDC, CXTPPropertyGridItemConstraint *pConstraint, CRect rc, BOOL bSelected) | CXTPPropertyGridItem | virtual
OnDrawItemValue(CDC &dc, CRect rcValue) | CXTPPropertyGridItemOption | protectedvirtual
OnIndexChanged() | CXTPPropertyGridItem | protectedvirtual
OnInpaceControlFocus(BOOL bForward) | CXTPPropertyGridItemOption | protectedvirtual
OnInplaceButtonDown(CXTPPropertyGridInplaceButton *pButton) | CXTPPropertyGridItem | protectedvirtual
OnKeyDown(UINT nChar) | CXTPPropertyGridItemOption | protectedvirtual
OnLButtonDblClk(UINT nFlags, CPoint point) | CXTPPropertyGridItemOption | protectedvirtual
OnLButtonDown(UINT nFlags, CPoint point) | CXTPPropertyGridItemOption | protectedvirtual
OnLButtonUp(UINT nFlags, CPoint point) | CXTPPropertyGridItem | protectedvirtual
OnMarkupChanged() | CXTPPropertyGridItem | virtual
OnMergeItemConstraint(CDC *pDC, CXTPPropertyGridItemConstraint *pConstraint) | CXTPPropertyGridItem | virtual
OnRButtonDown(UINT nFlags, CPoint point) | CXTPPropertyGridItem | protectedvirtual
OnRequestEdit() | CXTPPropertyGridItem | virtual
OnSelect() | CXTPPropertyGridItem | protectedvirtual
OnValidateEdit() | CXTPPropertyGridItem | virtual
OnValueChanged(CString strValue) | CXTPPropertyGridItem | virtual
PtInValueRect(CPoint point) | CXTPPropertyGridItem | protected
RedrawItem() | CXTPPropertyGridItem |
Remove() | CXTPPropertyGridItem |
ResetValue() | CXTPPropertyGridItem | virtual
Select() | CXTPPropertyGridItem |
SelectNextConstraint() | CXTPPropertyGridItem | protected
SetAutoComplete(BOOL bAutoComplete=TRUE) | CXTPPropertyGridItem |
SetCaption(LPCTSTR lpszCaption) | CXTPPropertyGridItem |
SetCheckBoxStyle(BOOL bCheckBoxStyle=TRUE) | CXTPPropertyGridItemOption |
SetConstraintEdit(BOOL bConstraintEdit=TRUE) | CXTPPropertyGridItem |
SetDefaultValue(LPCTSTR lpszDefaultValue) | CXTPPropertyGridItem |
SetDescription(LPCTSTR lpszDescription) | CXTPPropertyGridItem |
SetDropDownItemCount(int nDropDownItemCount) | CXTPPropertyGridItem |
SetEditStyle(DWORD dwEditStyle) | CXTPPropertyGridItem |
SetEditText(const CString &str) | CXTPPropertyGridItem | protectedvirtual
SetExpandable(BOOL bExpandable) | CXTPPropertyGridItem |
SetFlags(UINT nFlags) | CXTPPropertyGridItem |
SetFocusToInplaceControl() | CXTPPropertyGridItem | virtual
SetHeight(int nHeight) | CXTPPropertyGridItem |
SetHidden(BOOL bHidden) | CXTPPropertyGridItem |
SetID(UINT nID) | CXTPPropertyGridItem |
SetItemData(DWORD_PTR dwData) | CXTPPropertyGridItem |
SetMarkupTemplate(LPCTSTR lpstrMarkupTemplate) | CXTPPropertyGridItem |
SetMask(LPCTSTR strMask, LPCTSTR strLiteral, TCHAR chPrompt=_T('_')) | CXTPPropertyGridItem |
SetMaskedText(LPCTSTR lpszMaskedText) | CXTPPropertyGridItem |
SetMultiLinesCount(int nLinesCount) | CXTPPropertyGridItem |
SetOption(int nValue) | CXTPPropertyGridItemOption |
SetPasswordMask(TCHAR chMask=_T(' *')) | CXTPPropertyGridItem |
SetPrompt(LPCTSTR lpszPrompt) | CXTPPropertyGridItem |
SetReadOnly(BOOL bReadOnly=TRUE) | CXTPPropertyGridItem | virtual
SetTooltip(LPCTSTR lpstrTooltip) | CXTPPropertyGridItem |
SetValue(CString strValue) | CXTPPropertyGridItemOption | protectedvirtual
SetVisible(BOOL bVisible) | CXTPPropertyGridItem | protectedvirtual
ToggleConstraint(int nIndex) | CXTPPropertyGridItemOption | protected
~CXTPPropertyGridItem() | CXTPPropertyGridItem | virtual
~CXTPPropertyGridItemOption() | CXTPPropertyGridItemOption | virtual


Toolkit Pro: Member List

XTP_RESIZERECT Member List

This is the complete list of members for XTP_RESIZERECT, including all inherited members.

bottom | XTP_RESIZERECT
left | XTP_RESIZERECT
right | XTP_RESIZERECT
top | XTP_RESIZERECT


Toolkit Pro: XTPDatePickerOffice2013Theme.h Source File

  • Source
  • Calendar
  • DatePicker
  • Themes
XTPDatePickerOffice2013Theme.h
Go to the documentation of this file.
1
22#if !defined(_XTPDATEPICKEROFFICE2013THEME_H__)
23# define _XTPDATEPICKEROFFICE2013THEME_H__
24
25# if _MSC_VER > 1000
26# pragma once
27# endif // _MSC_VER > 1000
28
29# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
30
51class _XTP_EXT_CLASS CXTPDatePickerThemeOffice2013 : public CXTPDatePickerPaintManager
52{
53public:
62 CXTPDatePickerThemeOffice2013();
63
70 virtual ~CXTPDatePickerThemeOffice2013();
71
80 virtual void RefreshMetrics();
81
90 virtual void DrawBackground(CDC* pDC, CRect rcClient);
91
103 virtual void DrawWeekNumbers(CDC* pDC, CXTPDatePickerItemMonth* pMonth);
104
116 virtual void DrawDaysOfWeek(CDC* pDC, CXTPDatePickerItemMonth* pMonth);
117
128 virtual void DrawBorder(CDC* pDC, const CXTPDatePickerControl* pControl, CRect& rcClient,
129 BOOL bDraw);
130
144 virtual BOOL DrawDay(CDC* pDC, CXTPDatePickerItemDay* pDay);
145
175 virtual void DrawButton(CDC* pDC, const CRect& rcButton, const CString& strButton, BOOL bIsDown,
176 BOOL bIsHighLight);
177
186 virtual COLORREF GetHighlightTodayBackColor();
187
196 virtual COLORREF GetHighlightTodayTextColor();
197
206 virtual COLORREF GetHighlightTodayBorderColor();
207
208protected:
209 COLORREF m_clrButtonBorder;
210 COLORREF m_clrButtonPressed;
211 COLORREF m_clrButtonPressedText;
212 COLORREF m_clrButtonPressedBorder;
213 COLORREF m_clrButtonHighlight;
214 COLORREF m_clrButtonHighlightText;
215 COLORREF m_clrButtonHighlightBorder;
216 COLORREF m_clrHighlightTodayText;
217 COLORREF m_clrHighlightTodayBorder;
218
219 CXTPPaintManagerColorGradient m_clrBackground;
222};
223
224AFX_INLINE COLORREF CXTPDatePickerThemeOffice2013::GetHighlightTodayBackColor()
225{
226 return m_clrHighlightToday;
227}
228AFX_INLINE COLORREF CXTPDatePickerThemeOffice2013::GetHighlightTodayTextColor()
229{
230 return m_clrHighlightTodayText;
231}
232AFX_INLINE COLORREF CXTPDatePickerThemeOffice2013::GetHighlightTodayBorderColor()
233{
234 return m_clrHighlightTodayBorder;
235}
236
237# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
238#endif // !defined(_XTPDATEPICKEROFFICE2013THEME_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPDatePickerControl
Class CXTPDatePickerControl encapsulates the functionality of a date and time picker control.
Definition XTPDatePickerControl.h:331
CXTPDatePickerItemDay
Class CXTPDatePickerItemDay represents one displayed day item in the calendar.
Definition XTPDatePickerItemDay.h:47
CXTPDatePickerItemMonth
Class CXTPDatePickerItemMonth represents one month inside the date picker month grid.
Definition XTPDatePickerItemMonth.h:54
CXTPDatePickerPaintManager
Class CXTPDatePickerPaintManager handles most of the drawing activities for the DatePicker control.
Definition XTPDatePickerPaintManager.h:55
CXTPDatePickerPaintManager::m_clrHighlightToday
CXTPPaintManagerColor m_clrHighlightToday
This member variable is a COLORREF object that is used as the color for highlighting the "Today" item...
Definition XTPDatePickerPaintManager.h:643
CXTPDatePickerThemeOffice2013
Class CXTPDatePickerThemeOffice2013 is derived from CXTPDatePickerPaintManager for rendering an Offic...
Definition XTPDatePickerOffice2013Theme.h:52
CXTPDatePickerThemeOffice2013::DrawWeekNumbers
virtual void DrawWeekNumbers(CDC *pDC, CXTPDatePickerItemMonth *pMonth)
Call this member function to draw the week numbers in the month area.
CXTPDatePickerThemeOffice2013::DrawDaysOfWeek
virtual void DrawDaysOfWeek(CDC *pDC, CXTPDatePickerItemMonth *pMonth)
Call this member function to draw the days of the week in the month header.
CXTPDatePickerThemeOffice2013::DrawBorder
virtual void DrawBorder(CDC *pDC, const CXTPDatePickerControl *pControl, CRect &rcClient, BOOL bDraw)
This member function draws a border around the control.
CXTPDatePickerThemeOffice2013::GetHighlightTodayTextColor
virtual COLORREF GetHighlightTodayTextColor()
Call this member function to retrieve the foreground (text) color for the highlight today item.
Definition XTPDatePickerOffice2013Theme.h:228
CXTPDatePickerThemeOffice2013::CXTPDatePickerThemeOffice2013
CXTPDatePickerThemeOffice2013()
Default paint manager constructor.
CXTPDatePickerThemeOffice2013::~CXTPDatePickerThemeOffice2013
virtual ~CXTPDatePickerThemeOffice2013()
Default paint manager destructor.
CXTPDatePickerThemeOffice2013::DrawBackground
virtual void DrawBackground(CDC *pDC, CRect rcClient)
This member function is called to fill the control's background.
CXTPDatePickerThemeOffice2013::GetHighlightTodayBackColor
virtual COLORREF GetHighlightTodayBackColor()
Call this member function to retrieve the background color for the highlight today item.
Definition XTPDatePickerOffice2013Theme.h:224
CXTPDatePickerThemeOffice2013::DrawDay
virtual BOOL DrawDay(CDC *pDC, CXTPDatePickerItemDay *pDay)
Call this member function to draw a single month day in the month area.
CXTPDatePickerThemeOffice2013::RefreshMetrics
virtual void RefreshMetrics()
This member function performs initialization for the Paint Manager.
CXTPDatePickerThemeOffice2013::m_clrBackground
CXTPPaintManagerColorGradient m_clrBackground
This member variable represents two COLORREF objects that is used as the dark and light background gr...
Definition XTPDatePickerOffice2013Theme.h:219
CXTPDatePickerThemeOffice2013::DrawButton
virtual void DrawButton(CDC *pDC, const CRect &rcButton, const CString &strButton, BOOL bIsDown, BOOL bIsHighLight)
This member function is used to draw the control's buttons.
CXTPDatePickerThemeOffice2013::GetHighlightTodayBorderColor
virtual COLORREF GetHighlightTodayBorderColor()
Call this member function to retrieve the Border color for the highlight today item.
Definition XTPDatePickerOffice2013Theme.h:232
CXTPPaintManagerColorGradient
The CXTPPaintManagerColorGradient class is used to manage COLORREF values for determining light and d...
Definition XTPColorManager.h:301


Toolkit Pro: XTPGridThemeVisualStudio2012.h Source File

  • Source
  • GridControl
  • Themes
XTPGridThemeVisualStudio2012.h
Go to the documentation of this file.
1
23#if !defined(__XTPGRIDTHEMEVISUALSTUDIO2012_H__)
24# define __XTPGRIDTHEMEVISUALSTUDIO2012_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPGridThemeVisualStudio2012Light : public CXTPGridThemeOffice2013
39{
40public:
45 CXTPGridThemeVisualStudio2012Light();
46
51 virtual void LoadGlyphs();
52
58 virtual void RefreshMetrics();
59};
60
66class _XTP_EXT_CLASS CXTPGridThemeVisualStudio2012Dark : public CXTPGridThemeOffice2013
67{
68public:
73 CXTPGridThemeVisualStudio2012Dark();
74
79 virtual void LoadGlyphs();
80
86 virtual void RefreshMetrics();
87};
88
94class _XTP_EXT_CLASS CXTPGridThemeVisualStudio2012Blue : public CXTPGridThemeOffice2013
95{
96public:
101 CXTPGridThemeVisualStudio2012Blue();
102
107 virtual void LoadGlyphs();
108
114 virtual void RefreshMetrics();
115};
117# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
118#endif //#if !defined(__XTPGRIDTHEMEVISUALSTUDIO2012_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPGridThemeOffice2013
CXTPGridThemeOffice2013 is a CXTPGridPaintManager derived class that represents an Office 2013 style ...
Definition XTPGridThemeOffice2013.h:39
CXTPGridThemeVisualStudio2012Blue
CXTPGridThemeVisualStudio2012Blue is a CXTPGridThemeOffice2013 derived class that represents a Visual...
Definition XTPGridThemeVisualStudio2012.h:95
CXTPGridThemeVisualStudio2012Blue::CXTPGridThemeVisualStudio2012Blue
CXTPGridThemeVisualStudio2012Blue()
Default paint manager constructor, handles properties initialization.
CXTPGridThemeVisualStudio2012Blue::LoadGlyphs
virtual void LoadGlyphs()
Loads the default images used by the Grid control.
CXTPGridThemeVisualStudio2012Blue::RefreshMetrics
virtual void RefreshMetrics()
This method is called to refresh the visual metrics of the Grid control.
CXTPGridThemeVisualStudio2012Dark
CXTPGridThemeVisualStudio2012Dark is a CXTPGridThemeOffice2013 derived class that represents a Visual...
Definition XTPGridThemeVisualStudio2012.h:67
CXTPGridThemeVisualStudio2012Dark::CXTPGridThemeVisualStudio2012Dark
CXTPGridThemeVisualStudio2012Dark()
Default paint manager constructor, handles properties initialization.
CXTPGridThemeVisualStudio2012Dark::LoadGlyphs
virtual void LoadGlyphs()
Loads the default images used by the Grid control.
CXTPGridThemeVisualStudio2012Dark::RefreshMetrics
virtual void RefreshMetrics()
This method is called to refresh the visual metrics of the Grid control.
CXTPGridThemeVisualStudio2012Light
CXTPGridThemeVisualStudio2012Light is a CXTPGridThemeOffice2013 derived class that represents a Visua...
Definition XTPGridThemeVisualStudio2012.h:39
CXTPGridThemeVisualStudio2012Light::LoadGlyphs
virtual void LoadGlyphs()
Loads the default images used by the Grid control.
CXTPGridThemeVisualStudio2012Light::CXTPGridThemeVisualStudio2012Light
CXTPGridThemeVisualStudio2012Light()
Default paint manager constructor, handles properties initialization.
CXTPGridThemeVisualStudio2012Light::RefreshMetrics
virtual void RefreshMetrics()
This method is called to refresh the visual metrics of the Grid control.


Toolkit Pro: Member List

CXTPTrackThemeOfficeXP Member List

This is the complete list of members for CXTPTrackThemeOfficeXP, including all inherited members.

CalcColumnHeight(CDC *pDC, CXTPGridColumn *pColumn, int nTotalWidth=0) | CXTPGridPaintManager | protectedvirtual
CalculateRowHeight(CDC *pDC, const CString &strText, int nMaxWidth, BOOL bWordBreak=TRUE) | CXTPGridPaintManager | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPGridPaintManager() | CXTPGridPaintManager |
CXTPTrackPaintManager() | CXTPTrackPaintManager |
CXTPTrackThemeOfficeXP() | CXTPTrackThemeOfficeXP |
DrawBitmap(CDC *pDC, CXTPGridControl *pControl, CRect rcColumn, int iImage) | CXTPGridPaintManager | virtual
DrawCollapsedBitmap(CDC *pDC, const CXTPGridRow *pRow, CRect &rcBitmap) | CXTPGridPaintManager | virtual
DrawColumn(CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn, BOOL bDrawExternal=FALSE, int nShadowWidth=0) | CXTPGridPaintManager | virtual
DrawColumnBackground(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, BOOL &bColumnPressed, BOOL &bDraggingFromHeader, CXTPGridHeader *pHeader=NULL) | CXTPTrackThemeOfficeXP | virtual
DrawColumnFooter(CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn) | CXTPGridPaintManager | virtual
DrawColumnFooterDivider(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn) | CXTPGridPaintManager | virtual
DrawColumnIcon(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, CRect rcIcon, int iIcon) | CXTPGridPaintManager | virtual
DrawColumnText(CDC *pDC, CRect rcText, CString strCaption, int nHeaderAlignment, BOOL bIsHeader, BOOL bColumnPressed) | CXTPGridPaintManager | virtual
DrawConnector(CDC *pDC, CPoint ptFrom, CPoint ptTo) | CXTPGridPaintManager |
DrawFocusedRow(CDC *pDC, CRect rcRow) | CXTPGridPaintManager | virtual
DrawFreezeColsDivider(CDC *pDC, const CRect &rc, CXTPGridControl *pControl, CXTPGridRow *pRow=NULL) | CXTPGridPaintManager | virtual
DrawGlyph(CDC *pDC, CRect rcColumn, int iImage) | CXTPGridPaintManager | virtual
DrawGrid(CDC *pDC, XTPGridOrientation orientation, CRect rcGrid) | CXTPGridPaintManager | virtual
DrawGridPattern(CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush) | CXTPGridPaintManager | protectedvirtual
DrawGridPattern(CDC *pDC, CXTPBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush) | CXTPGridPaintManager | protectedvirtual
DrawGridPattern(CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr) | CXTPGridPaintManager | protectedvirtual
DrawGroupRow(CDC *pDC, CXTPGridGroupRow *pRow, CRect rcRow, XTP_GRIDRECORDITEM_METRICS *pMetrics) | CXTPGridPaintManager | virtual
DrawHorizontalLine(CDC *pDC, int xPos, int yPos, int cx, COLORREF clr) | CXTPGridPaintManager |
DrawInplaceButton(CDC *pDC, CXTPGridInplaceButton *pButton) | CXTPGridPaintManager | virtual
DrawInplaceButtonFrame(CDC *pDC, CXTPGridInplaceButton *pButton) | CXTPGridPaintManager | protectedvirtual
DrawInplaceButtonIcon(CDC *pDC, CXTPGridInplaceButton *pButton) | CXTPGridPaintManager | protectedvirtual
DrawInplaceComboButton(CDC *pDC, CRect *pRc) | CXTPGridPaintManager | virtual
DrawInplaceExpandButton(CDC *pDC, CRect *pRc) | CXTPGridPaintManager | virtual
DrawInplaceSpinButton(CDC *pDC, CRect *pRc) | CXTPGridPaintManager | virtual
DrawItemBitmap(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CRect &rcItem, int nImage) | CXTPGridPaintManager | virtual
DrawItemCaption(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics) | CXTPGridPaintManager | virtual
DrawItemControl(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CXTPGridRecordItemControl *pControl, CRect &rcItem) | CXTPGridPaintManager | virtual
DrawLink(int *pnCurrDrawPos, XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CXTPGridHyperlink *pHyperlink, CString strText, CRect rcLink, int nFlag, BOOL bTrim=FALSE) | CXTPGridPaintManager | protectedvirtual
DrawMarkers(CDC *pDC) | CXTPTrackPaintManager | virtual
DrawMultiLineText(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, BOOL bWordBreak=TRUE) | CXTPGridPaintManager | protectedvirtual
DrawNoGroupByText(CDC *pDC, CRect rcItem) | CXTPGridPaintManager | virtual
DrawRowNumber(CDC *pDC, CRect rcNumber, CXTPGridRow *pRow) | CXTPGridPaintManager | virtual
DrawSectionDivider(CDC *pDC, const CRect &rc, XTPGridSectionDividerPosition dividerPosition, XTPGridSectionDividerStyle dividerStyle, CXTPPaintManagerColor dividerColor) | CXTPGridPaintManager |
DrawShellIcon(CDC *pDC, CRect rcColumn, int iImage) | CXTPGridPaintManager | virtual
DrawSingleLineText(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nStartPos, int nEndPos, int nActualWidth) | CXTPGridPaintManager | protectedvirtual
DrawString(int *pnCurrDrawPos, CDC *pDC, const CString &strDraw, CRect rcDraw, UINT nFormat) | CXTPGridPaintManager | protectedvirtual
DrawTextLine(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nFlag, int &nCharCounter, int &nHyperlinkCounter) | CXTPGridPaintManager | protectedvirtual
DrawTimeLine(CDC *pDC) | CXTPTrackPaintManager | virtual
DrawTrackHeader(CDC *pDC) | CXTPTrackPaintManager | virtual
DrawTreeStructure(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CRect rcItem, CSize sizeGlyph) | CXTPGridPaintManager | virtual
DrawTriangle(CDC *pDC, CRect rcTriangle, BOOL bToDown, BOOL bDraggingFromHeader, int nShadowWidth, BOOL bColumnPressed) | CXTPGridPaintManager | virtual
DrawVerticalLine(CDC *pDC, int xPos, int yPos, int cy, COLORREF clr) | CXTPGridPaintManager |
DrawVerticalTimeLineMarker(CDC *pDC, int xPos, CXTPGridControl *pControl, COLORREF color=RGB(0, 255, 0)) | CXTPGridPaintManager | virtual
EnablePreviewMode(BOOL bIsPreviewMode) | CXTPGridPaintManager |
FillFooter(CDC *pDC, CRect rcFooter) | CXTPGridPaintManager | virtual
FillGroupByControl(CDC *pDC, CRect &rcGroupBy) | CXTPGridPaintManager | virtual
FillGroupRowMetrics(CXTPGridGroupRow *pRow, XTP_GRIDRECORDITEM_METRICS *pMetrics, BOOL bPrinting) | CXTPGridPaintManager | virtual
FillHeaderControl(CDC *pDC, CRect rcHeader) | CXTPGridPaintManager | virtual
FillIndent(CDC *pDC, CRect rcRow) | CXTPGridPaintManager | virtual
FillItemShade(CDC *pDC, CRect rcItem) | CXTPGridPaintManager | virtual
FillRow(CDC *pDC, CXTPGridRow *pRow, CRect rcRow) | CXTPGridPaintManager | virtual
FindRowAdjacentToMerged(const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, BOOL bUpward) | CXTPGridPaintManager |
FindRowAdjacentToMergedEx(const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, int &nAdjRowIndex, BOOL bUpward) | CXTPGridPaintManager |
FormatTime(int nPosition) | CXTPTrackPaintManager | virtual
FormatTimeLineTick(int nPosition, COLORREF &clrTick, int &nTickLength) | CXTPTrackPaintManager | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetColumnOffice2007CustomThemeBaseColor() const | CXTPGridPaintManager |
GetColumnStyle() const | CXTPGridPaintManager |
GetControlBackColor(CXTPGridControl *pControl) | CXTPGridPaintManager | virtual
GetFooterHeight(CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0) | CXTPGridPaintManager | virtual
GetFreezeColsDividerStyle() const | CXTPGridPaintManager |
GetGlyphs() const | CXTPGridPaintManager |
GetHeaderHeight() | CXTPGridPaintManager | virtual
GetHeaderHeight(CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0) | CXTPGridPaintManager | virtual
GetItemHeight(XTP_GRIDRECORDITEM_DRAWARGS &drawArgs, int nWidth) | CXTPGridPaintManager |
GetMaxPreviewLines() | CXTPGridPaintManager |
GetPreviewItemHeight(CDC *pDC, CXTPGridRow *pRow, int nWidth, int nHeight) | CXTPGridPaintManager | virtual
GetPreviewLinesCount(CDC *pDC, CRect &rcText, const CString &strText) | CXTPGridPaintManager |
GetRowHeight(CDC *pDC, CXTPGridRow *pRow) | CXTPGridPaintManager | virtual
GetRowHeight(CDC *pDC, CXTPGridRow *pRow, int nTotalWidth) | CXTPGridPaintManager | virtual
GetRowHeightEx(CDC *pDC, CXTPGridRow *pRow, int nTotalWidth, const BOOL firstLevel=TRUE) | CXTPGridPaintManager |
GetSectionDividerHeight(XTPGridFixedRowsDividerStyle dividerStyle) | CXTPGridPaintManager |
GetTextFont() | CXTPGridPaintManager |
IsColumHotTrackingEnabled() const | CXTPGridPaintManager | virtual
IsColumnPlusMinusSign() const | CXTPGridPaintManager |
IsColumnWidthWYSIWYG() const | CXTPGridPaintManager |
IsDrawGridForEmptySpace() const | CXTPGridPaintManager |
IsFixedInplaceButtonHeight() const | CXTPGridPaintManager |
IsFixedRowHeight() const | CXTPGridPaintManager |
IsGridVisible(BOOL bVertical) const | CXTPGridPaintManager |
IsGridVisible(XTPGridOrientation orientation) const | CXTPGridPaintManager |
IsLastColumnWidthWYSIWYG() const | CXTPGridPaintManager |
IsPreviewMode() const | CXTPGridPaintManager |
IsPrintGroupRowIcon() const | CXTPGridPaintManager |
IsShowWYSIWYGMarkers() const | CXTPGridPaintManager |
IsUseDropMarker() const | CXTPGridPaintManager |
LoadGlyphs() | CXTPGridPaintManager | virtual
m_arStartCol | CXTPGridPaintManager |
m_bAllowMergeCells | CXTPGridPaintManager |
m_bBaseTreeIndent | CXTPGridPaintManager |
m_bCleanTooltip | CXTPGridPaintManager |
m_bColumnPlusMinusSign | CXTPGridPaintManager | protected
m_bColumnWidthWYSIWYG | CXTPGridPaintManager | protected
m_bCompactText | CXTPGridPaintManager |
m_bDrawGridForEmptySpace | CXTPGridPaintManager | protected
m_bFixedInplaceButtonHeight | CXTPGridPaintManager | protected
m_bFixedRowHeight | CXTPGridPaintManager | protected
m_bForceDynamicMarkupForCell | CXTPGridPaintManager |
m_bForceShowDropMarker | CXTPGridPaintManager |
m_bForceShowTooltip | CXTPGridPaintManager |
m_bGrayIfDisable | CXTPGridPaintManager |
m_bGroupRowTextBold | CXTPGridPaintManager |
m_bHideSelection | CXTPGridPaintManager |
m_bHotTracking | CXTPGridPaintManager |
m_bInvertColumnOnClick | CXTPGridPaintManager |
m_bIsPreviewMode | CXTPGridPaintManager | protected
m_bLastColumnWidthWYSIWYG | CXTPGridPaintManager | protected
m_bMakeUpper | CXTPGridPaintManager |
m_bMoveScrollbarOnFixedColumnsIndent | CXTPGridPaintManager |
m_bPrintGroupRowIcon | CXTPGridPaintManager | protected
m_bPrintPageRectangle | CXTPGridPaintManager |
m_bPrintSortTriangle | CXTPGridPaintManager |
m_bPrintVirtualPageNumber | CXTPGridPaintManager |
m_bPrintWatermark | CXTPGridPaintManager |
m_bRecOrRowNum | CXTPGridPaintManager |
m_bRevertAlignment | CXTPGridPaintManager |
m_bShadeGroupHeadings | CXTPGridPaintManager |
m_bShadeSortColumn | CXTPGridPaintManager |
m_bShowLockIcon | CXTPGridPaintManager |
m_bShowNonActiveInPlaceButton | CXTPGridPaintManager |
m_bShowWYSIWYGMarkers | CXTPGridPaintManager | protected
m_bSortTriangleOffsetFromRight | CXTPGridPaintManager |
m_bThemedInplaceButtons | CXTPGridPaintManager |
m_bUseAlternativeBackground | CXTPGridPaintManager |
m_bUseDropMarker | CXTPGridPaintManager |
m_bUseEditTextAlignment | CXTPGridPaintManager |
m_bUseGroupRowSelectionState | CXTPGridPaintManager |
m_bUseShellIcon | CXTPGridPaintManager |
m_clrAlternativeBackground | CXTPGridPaintManager |
m_clrBoldText | CXTPGridPaintManager |
m_clrBoldTextHighlight | CXTPGridPaintManager |
m_clrBtnFace | CXTPGridPaintManager |
m_clrBtnFacePressed | CXTPGridPaintManager |
m_clrBtnText | CXTPGridPaintManager |
m_clrCaptionText | CXTPGridPaintManager |
m_clrCaptionTextPressed | CXTPGridPaintManager |
m_clrColumnOffice2007CustomTheme | CXTPGridPaintManager |
m_clrConnector | CXTPGridPaintManager |
m_clrControlBack | CXTPGridPaintManager |
m_clrControlDark | CXTPGridPaintManager |
m_clrControlLightLight | CXTPGridPaintManager |
m_clrDisableBitmapDarkest | CXTPGridPaintManager |
m_clrDisableBitmapLightest | CXTPGridPaintManager |
m_clrFormulaSubSum | CXTPGridPaintManager |
m_clrFormulaSum | CXTPGridPaintManager |
m_clrFreezeColsDivider | CXTPGridPaintManager |
m_clrGradientColumnSeparator | CXTPGridPaintManager |
m_clrGradientColumnShadow | CXTPGridPaintManager |
m_clrGroupBoxBack | CXTPGridPaintManager |
m_clrGroupRowText | CXTPGridPaintManager |
m_clrGroupShadeBack | CXTPGridPaintManager |
m_clrGroupShadeBorder | CXTPGridPaintManager |
m_clrGroupShadeText | CXTPGridPaintManager |
m_clrHeaderControl | CXTPGridPaintManager |
m_clrHighlight | CXTPGridPaintManager |
m_clrHighlightText | CXTPGridPaintManager |
m_clrHotDivider | CXTPGridPaintManager |
m_clrIndentControl | CXTPGridPaintManager |
m_clrItemShade | CXTPGridPaintManager |
m_clrMarker | CXTPTrackPaintManager |
m_clrMarkerBack | CXTPTrackPaintManager |
m_clrMarkerBorder | CXTPTrackPaintManager |
m_clrPreviewText | CXTPGridPaintManager |
m_clrScrollBarBorderDark | CXTPTrackPaintManager |
m_clrScrollBarBorderLight | CXTPTrackPaintManager |
m_clrScrollBarDark | CXTPTrackPaintManager |
m_clrScrollBarLight | CXTPTrackPaintManager |
m_clrSelectedArea | CXTPTrackPaintManager |
m_clrSelectedRow | CXTPGridPaintManager |
m_clrSelectedRowText | CXTPGridPaintManager |
m_clrTimeHeaderBorder | CXTPTrackPaintManager |
m_clrTimeHeaderDark | CXTPTrackPaintManager |
m_clrTimeHeaderDarkDark | CXTPTrackPaintManager |
m_clrTimeHeaderDivider | CXTPTrackPaintManager |
m_clrTimeLinePosition | CXTPTrackPaintManager |
m_clrTimeLineTick | CXTPTrackPaintManager |
m_clrTimeSliderBackground | CXTPTrackPaintManager |
m_clrTrackHeader | CXTPTrackPaintManager |
m_clrTrackMarkerBorder | CXTPTrackPaintManager |
m_clrTrackMarkerText | CXTPTrackPaintManager |
m_clrTrackMarkerTextBack | CXTPTrackPaintManager |
m_clrTrackMarkerTextBorder | CXTPTrackPaintManager |
m_clrTrackTimeArea | CXTPTrackPaintManager |
m_clrWindowText | CXTPGridPaintManager |
m_clrWorkArea | CXTPTrackPaintManager |
m_clrWorkAreaScrollBarBorder | CXTPTrackPaintManager |
m_clrWorkAreaScrollBarDark | CXTPTrackPaintManager |
m_clrWorkAreaScrollBarLight | CXTPTrackPaintManager |
m_columnStyle | CXTPGridPaintManager | protected
m_crlNoGroupByText | CXTPGridPaintManager |
m_grcGradientColumn | CXTPGridPaintManager |
m_grcGradientColumnHot | CXTPGridPaintManager |
m_grcGradientColumnPushed | CXTPGridPaintManager |
m_iRecOrRowStart | CXTPGridPaintManager |
m_nBaseParentRecordIndent | CXTPGridPaintManager |
m_nFixedColumnsIndent | CXTPGridPaintManager |
m_nFooterHeight | CXTPGridPaintManager | protected
m_nFreezeColsDividerStyle | CXTPGridPaintManager | protected
m_nGridLineStylePreviousH | CXTPGridPaintManager | protected
m_nGridLineStylePreviousV | CXTPGridPaintManager | protected
m_nGroupGridLineHeight | CXTPGridPaintManager | protected
m_nGroupGridLineStyle | CXTPGridPaintManager | protected
m_nHeaderHeight | CXTPGridPaintManager | protected
m_nMaxPreviewLines | CXTPGridPaintManager | protected
m_nResizingWidth | CXTPGridPaintManager | protected
m_nRowHeight | CXTPGridPaintManager | protected
m_nRowHeightDefault | CXTPGridPaintManager |
m_nTextIndentForGroupRowsWithNoIcon | CXTPGridPaintManager |
m_nTreeColumnLineLength | CXTPGridPaintManager |
m_nTreeIndent | CXTPGridPaintManager |
m_nTreeStructureStyle | CXTPGridPaintManager |
m_nTreeTextIndent | CXTPGridPaintManager |
m_nTreeTextIndentGroupRow | CXTPGridPaintManager |
m_nTreeTextIndentRowChildren | CXTPGridPaintManager |
m_nTreeTextIndentRowParent | CXTPGridPaintManager |
m_pControl | CXTPGridPaintManager | protected
m_pGlyphs | CXTPGridPaintManager | protected
m_pHyperlinkHoverStyle | CXTPGridPaintManager |
m_pHyperlinkStyle | CXTPGridPaintManager |
m_pMarkupUIElement_NoGroupBy | CXTPGridPaintManager | protected
m_PrintPageWidth | CXTPGridPaintManager |
m_rcPreviewIndent | CXTPGridPaintManager |
m_RecordNumberWidth | CXTPGridPaintManager |
m_strCollapse | CXTPGridPaintManager |
m_strDecreasing | CXTPGridPaintManager |
m_strExpand | CXTPGridPaintManager |
m_strIncreasing | CXTPGridPaintManager |
m_strMarkupUIElement_NoGroupBy | CXTPGridPaintManager | protected
m_strNoFieldsAvailable | CXTPGridPaintManager |
m_strNoGroupBy | CXTPGridPaintManager |
m_strNoItems | CXTPGridPaintManager |
m_strSortBy | CXTPGridPaintManager |
m_szGlyph | CXTPGridPaintManager | protected
m_themeButton | CXTPGridPaintManager | protected
m_themeCombo | CXTPGridPaintManager | protected
m_themeHeader | CXTPGridPaintManager | protected
m_themeSpin | CXTPGridPaintManager | protected
m_treeStructureStyle | CXTPGridPaintManager |
m_xtpBrushGroupGridLineStyle | CXTPGridPaintManager | protected
m_xtpBrushHorizontalGrid | CXTPGridPaintManager | protected
m_xtpBrushTreeStructure | CXTPGridPaintManager | protected
m_xtpBrushVeriticalGrid | CXTPGridPaintManager | protected
m_xtpFontBoldText | CXTPGridPaintManager |
m_xtpFontCaption | CXTPGridPaintManager |
m_xtpFontPreview | CXTPGridPaintManager |
m_xtpFontText | CXTPGridPaintManager |
OnDrawAction(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs) | CXTPGridPaintManager | virtual
RecalcTotalHightOfMergedRows(CXTPGridColumns *pColumns, CDC *pDC, CXTPGridRow *pRow, int nRowHeight, int nTotalWidth) | CXTPGridPaintManager |
RefreshMetrics() | CXTPTrackPaintManager | virtual
SetCaptionFont(LOGFONT &lf) | CXTPGridPaintManager |
SetColumnOffice2007CustomThemeBaseColor(COLORREF clrBaseColor) | CXTPGridPaintManager |
SetColumnPlusMinusSign(BOOL bDraw) | CXTPGridPaintManager |
SetColumnWidthWYSIWYG(BOOL bColumnWidthWYSIWYG) | CXTPGridPaintManager |
SetDrawGridForEmptySpace(BOOL bDrawGrid) | CXTPGridPaintManager |
SetFixedRowHeight(BOOL bFixedRowHeight) | CXTPGridPaintManager |
SetFreezeColsDividerStyle(int nStyle) | CXTPGridPaintManager |
SetGridControl(CXTPGridControl *pControl) | CXTPGridPaintManager | virtual
SetHeaderHeight(int nHeight) | CXTPGridPaintManager | virtual
SetInplaceButtonHeight(BOOL bFixedInplaceButtonHeight) | CXTPGridPaintManager |
SetLastColumnWidthWYSIWYG(BOOL bColumnWidthWYSIWYG) | CXTPGridPaintManager |
SetMaxPreviewLines(int nMaxLines) | CXTPGridPaintManager |
SetPreviewIndent(int nLeft, int nTop, int nRight, int nBottom) | CXTPGridPaintManager |
SetPrintGroupRowIcon(BOOL bDraw) | CXTPGridPaintManager |
SetTextFont(LOGFONT &lf) | CXTPGridPaintManager |
ShowWYSIWYGMarkers(BOOL bSet) | CXTPGridPaintManager |
~CXTPGridPaintManager() | CXTPGridPaintManager | virtual
~CXTPTrackPaintManager() | CXTPTrackPaintManager |


Toolkit Pro: XTPChartPyramidSeriesStyleBase.h Source File

  • Source
  • Chart
  • Styles
  • Pyramid
  • Base
XTPChartPyramidSeriesStyleBase.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTPYRAMIDSERIESSTYLEBASE_H__)
24# define __XTPCHARTPYRAMIDSERIESSTYLEBASE_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartSeriesView;
34class CXTPChartBorder;
35class CXTPChartFillStyle;
36class CXTPChartDiagram;
37class CXTPChartDiagramView;
38class CXTPChartSeries;
39
44class _XTP_EXT_CLASS CXTPChartPyramidSeriesStyleBase : public CXTPChartSeriesStyle
45{
46 DECLARE_DYNAMIC(CXTPChartPyramidSeriesStyleBase);
47
48public:
53 CXTPChartPyramidSeriesStyleBase();
54
59 virtual ~CXTPChartPyramidSeriesStyleBase();
60
68 int GetPointDistance() const;
69
76 void SetPointDistance(int nPointDistance);
77
90 double GetHeightToWidthRatio() const;
91
103 void SetHeightToWidthRatio(double dRatio);
104
113 CXTPChartFillStyle* GetFillStyle() const;
114
122 CXTPChartBorder* GetBorder() const;
123
135 void DoPropExchange(CXTPPropExchange* pPX);
136
137protected:
146 virtual CXTPChartDiagram* CreateDiagram() = 0;
147
158 virtual CXTPChartSeriesView* CreateView(CXTPChartSeries* pSeries,
159 CXTPChartDiagramView* pDiagramView) = 0;
160
172 virtual BOOL IsStyleDiagram(CXTPChartDiagram* pDiagram) const = 0;
173
174# ifdef _XTP_ACTIVEX
175public:
177 DECLARE_DISPATCH_MAP()
178 DECLARE_INTERFACE_MAP()
180# endif
181
182protected:
183 double m_dHeightToWidthRatio;
184 int m_nPointDistance;
185 CXTPChartBorder* m_pBorder;
186 CXTPChartFillStyle* m_pFillStyle;
187};
188
189AFX_INLINE int CXTPChartPyramidSeriesStyleBase::GetPointDistance() const
190{
191 return m_nPointDistance;
192}
193
194AFX_INLINE void CXTPChartPyramidSeriesStyleBase::SetPointDistance(int nPointDistance)
195{
196 m_nPointDistance = nPointDistance;
197 OnChartChanged();
198}
199
200AFX_INLINE CXTPChartFillStyle* CXTPChartPyramidSeriesStyleBase::GetFillStyle() const
201{
202 return m_pFillStyle;
203}
204
205AFX_INLINE CXTPChartBorder* CXTPChartPyramidSeriesStyleBase::GetBorder() const
206{
207 return m_pBorder;
208}
209
210AFX_INLINE void CXTPChartPyramidSeriesStyleBase::SetHeightToWidthRatio(double dRatio)
211{
212 m_dHeightToWidthRatio = dRatio;
213 OnChartChanged();
214}
215
216AFX_INLINE double CXTPChartPyramidSeriesStyleBase::GetHeightToWidthRatio() const
217{
218 return m_dHeightToWidthRatio;
219}
221# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
222#endif //#if !defined(__XTPCHARTPYRAMIDSERIESSTYLEBASE_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartBorder
This class abstracts the border of a chart, it is a kind of chart element.
Definition XTPChartBorder.h:42
CXTPChartDiagram
This class represents a chart diagram, which is a kind of CXTPChartElement.
Definition XTPChartDiagram.h:48
CXTPChartDiagramView
This class represents the view of a chart diagram, which is a kind of CXTPChartElementView.
Definition XTPChartDiagramView.h:49
CXTPChartElement::OnChartChanged
virtual void OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic propertie...
CXTPChartFillStyle
This class abstracts a fill style used to fill the background of various chart elements.
Definition XTPChartFillStyle.h:43
CXTPChartPyramidSeriesStyleBase
This class abstracts the basic style of a pyramid series.
Definition XTPChartPyramidSeriesStyleBase.h:45
CXTPChartPyramidSeriesStyleBase::DoPropExchange
void DoPropExchange(CXTPPropExchange *pPX)
Call this member function to Store/Load an event using the specified data object.
CXTPChartPyramidSeriesStyleBase::CXTPChartPyramidSeriesStyleBase
CXTPChartPyramidSeriesStyleBase()
Constructs a CXTPChartPyramidSeriesStyleBase object.
CXTPChartPyramidSeriesStyleBase::GetFillStyle
CXTPChartFillStyle * GetFillStyle() const
Call this function to get the background fill style.
Definition XTPChartPyramidSeriesStyleBase.h:200
CXTPChartPyramidSeriesStyleBase::SetPointDistance
void SetPointDistance(int nPointDistance)
Sets the distance bettween stacked pyramid point (a gap).
Definition XTPChartPyramidSeriesStyleBase.h:194
CXTPChartPyramidSeriesStyleBase::IsStyleDiagram
virtual BOOL IsStyleDiagram(CXTPChartDiagram *pDiagram) const =0
Call this function to check whether a chart diagram object passed is a kind of CXTPChart2dPyramidDiag...
CXTPChartPyramidSeriesStyleBase::GetPointDistance
int GetPointDistance() const
Gets the distance bettween stacked pyramid point (a gap).
Definition XTPChartPyramidSeriesStyleBase.h:189
CXTPChartPyramidSeriesStyleBase::CreateView
virtual CXTPChartSeriesView * CreateView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)=0
Call this function to create the view of the pyramid series.
CXTPChartPyramidSeriesStyleBase::CreateDiagram
virtual CXTPChartDiagram * CreateDiagram()=0
Call this function to create the pyramid diagram object.
CXTPChartPyramidSeriesStyleBase::GetHeightToWidthRatio
double GetHeightToWidthRatio() const
Gets the the ratio value that determines whether a pyramid looks more stretched towards its cone or i...
Definition XTPChartPyramidSeriesStyleBase.h:216
CXTPChartPyramidSeriesStyleBase::SetHeightToWidthRatio
void SetHeightToWidthRatio(double dRatio)
Sets the the ratio value that determines whether a pyramid looks more stretched towards its cone or i...
Definition XTPChartPyramidSeriesStyleBase.h:210
CXTPChartPyramidSeriesStyleBase::GetBorder
CXTPChartBorder * GetBorder() const
Obtains the border object pointer.
Definition XTPChartPyramidSeriesStyleBase.h:205
CXTPChartPyramidSeriesStyleBase::~CXTPChartPyramidSeriesStyleBase
virtual ~CXTPChartPyramidSeriesStyleBase()
Destroys a CXTPChartPyramidSeriesStyleBase object, handles cleanup.
CXTPChartSeries
This class represents a series in the chart, which is a kind of CXTPChartElement.
Definition XTPChartSeries.h:50
CXTPChartSeriesStyle
CXTPChartSeriesStyle is a CXTPChartElement derived class.
Definition XTPChartSeriesStyle.h:49
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72


Toolkit Pro: Member List

CXTPChartLineStyle Member List

This is the complete list of members for CXTPChartLineStyle, including all inherited members.

CreateDeviceCommand(const CXTPChartPointF &point1, const CXTPChartPointF &point2, const CXTPChartColor &color) | CXTPChartLineStyle | virtual
CreateDeviceCommand(const CXTPChartPoints &points, const CXTPChartColor &color) | CXTPChartLineStyle | virtual
CreateSplineDeviceCommand(const CXTPChartPoints &points, const CXTPChartColor &color) | CXTPChartLineStyle | virtual
CXTPChartLineStyle(CXTPChartElement *pOwner) | CXTPChartLineStyle |
CXTPCmdTarget() | CXTPCmdTarget |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetDashStyle() const | CXTPChartLineStyle |
GetThickness() const | CXTPChartLineStyle |
m_nDashStyle | CXTPChartLineStyle | protected
m_nThickness | CXTPChartLineStyle | protected
m_pOwner | CXTPChartLineStyle | protected
Release() | CXTPChartLineStyle |
SetDashStyle(XTPChartDashStyle nDashStyle) | CXTPChartLineStyle |
SetThickness(int nThickness) | CXTPChartLineStyle |


Toolkit Pro: XTPRibbonThemeOffice2007System.h Source File

  • Source
  • Ribbon
  • Themes
XTPRibbonThemeOffice2007System.h
Go to the documentation of this file.
1
23#if !defined(__XTPRIBBONTHEMEOFFICE2007SYSTEM_H__)
24# define __XTPRIBBONTHEMEOFFICE2007SYSTEM_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPRibbonThemeOffice2007System : public CXTPRibbonMarkupTheme
39{
40public:
46 CXTPRibbonThemeOffice2007System(CXTPPaintManager* pPaintManager);
47
52 virtual ~CXTPRibbonThemeOffice2007System();
53
54public:
64 virtual void RefreshMetrics();
65
72 virtual void DrawRibbonQuickAccessControls(CDC* pDC, CXTPRibbonBar* pRibbonBar);
73
74public:
82 virtual int GetRibbonCaptionHeight(const CXTPRibbonBar* pRibbonBar) const;
83
92 virtual void DrawRibbonQuickAccessButton(CDC* pDC, CXTPControlPopup* pControl);
93
99 virtual void LoadParts(BOOL bReload = FALSE);
100
101protected:
103 _XTP_DEPRECATED_IN_FAVOR(LoadParts)
104 BOOL LoadResource();
106};
107
108# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
110#endif // !defined(__XTPRIBBONTHEMEOFFICE2007SYSTEM_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPControlPopup
CXTPControlPopup is a CXTPControl derived class.
Definition XTPControlPopup.h:42
CXTPPaintManager
Paint manager of the command bars.
Definition XTPPaintManager.h:199
CXTPRibbonBar
CXTPRibbonBar is a CXTPMenuBar derived class.
Definition XTPRibbonBar.h:69
CXTPRibbonMarkupTheme
CXTPRibbonMarkupTheme class.
Definition XTPRibbonMarkupTheme.h:147
CXTPRibbonThemeOffice2007System
CXTPRibbonThemeOffice2007System is a CXTPRibbonMarkupTheme derived class used to represent an Office ...
Definition XTPRibbonThemeOffice2007System.h:39
CXTPRibbonThemeOffice2007System::~CXTPRibbonThemeOffice2007System
virtual ~CXTPRibbonThemeOffice2007System()
Destroys a CXTPRibbonThemeOffice2007System object, handles cleanup and deallocation.
CXTPRibbonThemeOffice2007System::DrawRibbonQuickAccessButton
virtual void DrawRibbonQuickAccessButton(CDC *pDC, CXTPControlPopup *pControl)
This method is called to draw the Quick Access customize button.
CXTPRibbonThemeOffice2007System::LoadParts
virtual void LoadParts(BOOL bReload=FALSE)
Loads markup parts.
CXTPRibbonThemeOffice2007System::DrawRibbonQuickAccessControls
virtual void DrawRibbonQuickAccessControls(CDC *pDC, CXTPRibbonBar *pRibbonBar)
This method is called to draw ribbon Quick Access controls.
CXTPRibbonThemeOffice2007System::RefreshMetrics
virtual void RefreshMetrics()
This method is called to refresh the visual metrics of the manager.
CXTPRibbonThemeOffice2007System::CXTPRibbonThemeOffice2007System
CXTPRibbonThemeOffice2007System(CXTPPaintManager *pPaintManager)
Constructs a CXTPRibbonThemeOffice2007System object.
CXTPRibbonThemeOffice2007System::GetRibbonCaptionHeight
virtual int GetRibbonCaptionHeight(const CXTPRibbonBar *pRibbonBar) const
Calculates the ribbon caption height.


Toolkit Pro: Member List

CXTPCalendarRecurrencePattern Member List

This is the complete list of members for CXTPCalendarRecurrencePattern, including all inherited members.

ClonePattern() | CXTPCalendarRecurrencePattern | virtual
CXTPCalendarRecurrencePattern(CXTPCalendarData *pDataProvider) | CXTPCalendarRecurrencePattern | protected
CXTPCmdTarget() | CXTPCmdTarget |
DoPropExchange(CXTPPropExchange *pPX) | CXTPCalendarRecurrencePattern | virtual
FindException(COleDateTime dtStartOrig, COleDateTime dtEndOrig) const | CXTPCalendarRecurrencePattern | virtual
FindExceptionIndex(COleDateTime dtStartOrig, COleDateTime dtEndOrig) const | CXTPCalendarRecurrencePattern | virtual
FindExceptions(CXTPCalendarEvents *pEvents, COleDateTime dtStart, COleDateTime dtEnd) const | CXTPCalendarRecurrencePattern | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCustomProperties() const | CXTPCalendarRecurrencePattern |
GetDuration() const | CXTPCalendarRecurrencePattern | virtual
GetDurationMinutes() const | CXTPCalendarRecurrencePattern | virtual
GetEndAfterOccurrences() const | CXTPCalendarRecurrencePattern | virtual
GetEndOccurrenceTime(COleDateTime dtOccurrenceStartDate) const | CXTPCalendarRecurrencePattern | virtual
GetExceptions() | CXTPCalendarRecurrencePattern | virtual
GetMasterEvent() const | CXTPCalendarRecurrencePattern | virtual
GetMasterEventID() const | CXTPCalendarRecurrencePattern | virtual
GetOccReminders() | CXTPCalendarRecurrencePattern |
GetOccurrences(CXTPCalendarEvents *pEventsArray, COleDateTime dtStart, COleDateTime dtEnd, CXTPCalendarEvent *pMasterEvent) | CXTPCalendarRecurrencePattern | virtual
GetOccurrencesDates(CXTPCalendarDatesArray &rArDates, COleDateTime dtStart, COleDateTime dtEnd) const | CXTPCalendarRecurrencePattern | virtual
GetPatternEnd() const | CXTPCalendarRecurrencePattern | virtual
GetPatternEndDate() const | CXTPCalendarRecurrencePattern | virtual
GetPatternID() const | CXTPCalendarRecurrencePattern | virtual
GetPatternStartDate() const | CXTPCalendarRecurrencePattern | virtual
GetRecurrenceOptions() const | CXTPCalendarRecurrencePattern | virtual
GetRecurrenceType() const | CXTPCalendarRecurrencePattern | virtual
GetStartOccurrenceTime(COleDateTime dtOccurrenceStartDate) const | CXTPCalendarRecurrencePattern | virtual
GetStartTime() const | CXTPCalendarRecurrencePattern | virtual
GetUseEndMethod() const | CXTPCalendarRecurrencePattern | virtual
IsNoEndDate() const | CXTPCalendarRecurrencePattern | virtual
RemoveAllExceptions() | CXTPCalendarRecurrencePattern | virtual
RemoveException(CXTPCalendarEvent *pException, CXTPCalendarEvent *pMasterEventToUpdate=NULL) | CXTPCalendarRecurrencePattern | virtual
SetDurationMinutes(int nMinutes) | CXTPCalendarRecurrencePattern | virtual
SetEndAfterOccurrences(int nOccurrences) | CXTPCalendarRecurrencePattern | virtual
SetException(CXTPCalendarEvent *pException, CXTPCalendarEvent *pMasterEventToUpdate=NULL) | CXTPCalendarRecurrencePattern | virtual
SetMasterEventID(DWORD dwEventID) | CXTPCalendarRecurrencePattern | virtual
SetNoEndDate() | CXTPCalendarRecurrencePattern | virtual
SetOccReminder(CXTPCalendarEvent *pOccEvent, int nbIsReminder=xtpCalendarRmdPrm_DontChange, DATE dtNextReminderTime_Snoozed=xtpCalendarRmdPrm_DontChange) | CXTPCalendarRecurrencePattern |
SetPatternEnd(const XTP_CALENDAR_PATTERN_END &patternEnd) | CXTPCalendarRecurrencePattern | virtual
SetPatternEndDate(COleDateTime dtEnd) | CXTPCalendarRecurrencePattern | virtual
SetPatternID(DWORD dwID) | CXTPCalendarRecurrencePattern | protected
SetPatternStartDate(COleDateTime dtStart) | CXTPCalendarRecurrencePattern | virtual
SetRecurrenceOptions(const XTP_CALENDAR_RECURRENCE_OPTIONS &Options) | CXTPCalendarRecurrencePattern | virtual
SetStartTime(COleDateTime dtStart) | CXTPCalendarRecurrencePattern | virtual
Update(CXTPCalendarRecurrencePattern *pNewData) | CXTPCalendarRecurrencePattern | virtual
~CXTPCalendarRecurrencePattern() | CXTPCalendarRecurrencePattern | virtual


Toolkit Pro: XTPMarkupUIElement.h Source File

  • Source
  • Markup
XTPMarkupUIElement.h
Go to the documentation of this file.
1
23#if !defined(__XTPMARKUPUIELEMENT_H__)
24# define __XTPMARKUPUIELEMENT_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPMarkupContext;
34class CXTPMarkupRenderTransform;
35class CXTPMarkupTransformationMatrix;
36class CXTPMarkupPoint;
37
42class _XTP_EXT_CLASS CXTPMarkupUIElement : public CXTPMarkupVisual
43{
45 DECLARE_MARKUPCLASS(CXTPMarkupUIElement);
47protected:
52 CXTPMarkupUIElement();
53
58 virtual ~CXTPMarkupUIElement();
59
60public:
70 void Arrange(CRect rcFinalRect);
71
85 void Measure(CXTPMarkupDrawingContext* pDC, CSize szAvailableSize);
86
87public:
100 CSize GetDesiredSize() const;
101
108 CRect GetFinalRect() const;
109
117 XTPMarkupVisibility GetVisibility() const;
118
126 void SetVisibility(XTPMarkupVisibility visibility);
127
136 BOOL IsFocusable() const;
137
145 virtual BOOL IsVisible() const;
146
155 BOOL IsEnabled() const;
156
157public:
167 virtual void InvalidateArrange();
168
176 virtual void InvalidateVisual();
177
185 virtual void InvalidateMeasure();
186
187protected:
195 CXTPMarkupRenderTransform* GetRenderTransform() const;
196
197 CXTPMarkupPoint* GetRenderTransformOrigin() const;
198
205 virtual void ArrangeCore(CRect rcFinalRect);
206
218 virtual CSize MeasureCore(CXTPMarkupDrawingContext* pDC, CSize szAvailableSize);
219
228 virtual BOOL GetLayoutClip(CRect& rc) const;
229
235 virtual void InvalidateMeasureOverride(CXTPMarkupDrawingContext* pDC);
236
245 virtual TransformationMatrices ApplyRenderTransform(CXTPMarkupDrawingContext* pContext);
246
254 virtual void RestoreRenderTransform(CXTPMarkupDrawingContext* pContext,
255 TransformationMatrices& matrices);
256
263 virtual double GetOpacity() const;
264
266public:
267 DECLARE_DISPATCH_MAP()
268# ifdef _XTP_ACTIVEX
269 DECLARE_INTERFACE_MAP()
270 DECLARE_OLETYPELIB_EX(CXTPMarkupUIElement);
271# endif
272
273 afx_msg BOOL OleGetClipToBounds();
274 afx_msg void OleSetClipToBounds(BOOL bValue);
275 afx_msg long OleGetVisibility();
276 afx_msg void OleSetVisibility(long nValue);
277 afx_msg BOOL OleGetFocusable();
278 afx_msg void OleSetFocusable(BOOL bValue);
279 afx_msg BOOL OleGetIsEnabled();
280 afx_msg void OleSetIsEnabled(BOOL bValue);
281 afx_msg double OleGetOpacity();
282 afx_msg void OleSetOpacity(double dValue);
283 afx_msg LPDISPATCH OleGetRenderTransform();
284
287protected:
288 CSize m_szDesiredSize;
290 CRect m_rcFinalRect;
291 BOOL m_bMeasureDirty;
292 BOOL m_bNeverMeasured;
293 CSize m_szPreviousAvailableSize;
294 BOOL m_bArrangeDirty;
295 BOOL m_bNeverArranged;
296 BOOL m_bArrangeInProgress;
297 BOOL m_bMeasureInProgress;
299public:
300 static CXTPMarkupDependencyProperty* m_pClipToBoundsProperty;
308 static CXTPMarkupDependencyProperty* m_pVisibilityProperty;
311 static CXTPMarkupDependencyProperty* m_pFocusableProperty;
313 static CXTPMarkupDependencyProperty* m_pIsEnabledProperty;
316 static CXTPMarkupDependencyProperty* m_pRenderTransformProperty;
320 static CXTPMarkupDependencyProperty* m_pRenderTransformOriginProperty;
328 static CXTPMarkupDependencyProperty* m_pOpacityProperty;
333 friend class CXTPMarkupThemePart;
334
335private:
336 static double NormalizeOpacityValue(double dValue);
337};
338
339AFX_INLINE CSize CXTPMarkupUIElement::GetDesiredSize() const
340{
341 return m_szDesiredSize;
342}
343
344AFX_INLINE CRect CXTPMarkupUIElement::GetFinalRect() const
345{
346 return m_rcFinalRect;
347}
348
349# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
351#endif // !defined(__XTPMARKUPUIELEMENT_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPMarkupContext
CXTPMarkupContext is a standalone class used to provide common settings for Markup objects.
Definition XTPMarkupContext.h:128
CXTPMarkupThemePart
The CXTPMarkupThemePart class is used to create a theme part object used for rendering.
Definition XTPMarkupTheme.h:42
CXTPMarkupTransformationMatrix
An abstract class for device context transformation matrix.
Definition XTPMarkupTransformationMatrix.h:40
CXTPMarkupUIElement
Base class for XML Markup core level implementations.
Definition XTPMarkupUIElement.h:43
CXTPMarkupUIElement::m_pIsEnabledProperty
static CXTPMarkupDependencyProperty * m_pIsEnabledProperty
A value indicating whether thiselement is enabled in the user interface (UI).
Definition XTPMarkupUIElement.h:313
CXTPMarkupUIElement::m_pVisibilityProperty
static CXTPMarkupDependencyProperty * m_pVisibilityProperty
A value indicating whether this element is visible in the user interface (UI).
Definition XTPMarkupUIElement.h:308
CXTPMarkupUIElement::IsVisible
virtual BOOL IsVisible() const
Gets a value indicating whether this element is visible in the user interface (UI).
CXTPMarkupUIElement::MeasureCore
virtual CSize MeasureCore(CXTPMarkupDrawingContext *pDC, CSize szAvailableSize)
When overridden in a derived class, provides measurement logic for sizing this element properly with ...
CXTPMarkupUIElement::m_bArrangeInProgress
BOOL m_bArrangeInProgress
TRUE if Arrange is currently executed.
Definition XTPMarkupUIElement.h:296
CXTPMarkupUIElement::m_szDesiredSize
CSize m_szDesiredSize
Gets the size that this element computed during the measure pass of the layout process.
Definition XTPMarkupUIElement.h:288
CXTPMarkupUIElement::m_rcFinalRect
CRect m_rcFinalRect
Final position of the visual element.
Definition XTPMarkupUIElement.h:290
CXTPMarkupUIElement::~CXTPMarkupUIElement
virtual ~CXTPMarkupUIElement()
Destroys a CXTPMarkupUIElement object, handles cleanup and deallocation.
CXTPMarkupUIElement::GetLayoutClip
virtual BOOL GetLayoutClip(CRect &rc) const
Retrieves an alternative clipping geometry that represents the region that would be clipped if child ...
CXTPMarkupUIElement::m_pRenderTransformProperty
static CXTPMarkupDependencyProperty * m_pRenderTransformProperty
Gets or sets transform information that affects the rendering position of this element.
Definition XTPMarkupUIElement.h:316
CXTPMarkupUIElement::InvalidateMeasure
virtual void InvalidateMeasure()
Invalidates the measurement state (layout) for the element.
CXTPMarkupUIElement::m_bNeverMeasured
BOOL m_bNeverMeasured
TRUE if object has never ran Measure to update its size.
Definition XTPMarkupUIElement.h:292
CXTPMarkupUIElement::GetDesiredSize
CSize GetDesiredSize() const
Gets the size that this element computed during the measure pass of the layout process.
Definition XTPMarkupUIElement.h:339
CXTPMarkupUIElement::InvalidateArrange
virtual void InvalidateArrange()
Invalidates the arrange state (layout) for the element.
CXTPMarkupUIElement::InvalidateVisual
virtual void InvalidateVisual()
Invalidates the rendering of the element, and forces a new complete layout pass.
CXTPMarkupUIElement::m_pFocusableProperty
static CXTPMarkupDependencyProperty * m_pFocusableProperty
A value that indicates whether the element can receive focus.
Definition XTPMarkupUIElement.h:311
CXTPMarkupUIElement::m_szPreviousAvailableSize
CSize m_szPreviousAvailableSize
Previous available size of measure call.
Definition XTPMarkupUIElement.h:293
CXTPMarkupUIElement::RestoreRenderTransform
virtual void RestoreRenderTransform(CXTPMarkupDrawingContext *pContext, TransformationMatrices &matrices)
Restores a previously applied render transformation.
CXTPMarkupUIElement::m_bArrangeDirty
BOOL m_bArrangeDirty
TRUE if object position can be invalid.
Definition XTPMarkupUIElement.h:294
CXTPMarkupUIElement::m_pClipToBoundsProperty
static CXTPMarkupDependencyProperty * m_pClipToBoundsProperty
Gets or sets a value indicating whether to clip the content of this element (or content coming from t...
Definition XTPMarkupUIElement.h:300
CXTPMarkupUIElement::GetVisibility
XTPMarkupVisibility GetVisibility() const
Gets the user interface (UI) visibility of this element.
CXTPMarkupUIElement::Measure
void Measure(CXTPMarkupDrawingContext *pDC, CSize szAvailableSize)
Updates the DesiredSize of a CXTPMarkupUIElement.
CXTPMarkupUIElement::ArrangeCore
virtual void ArrangeCore(CRect rcFinalRect)
Defines the template for the core-level arrange layout definition.
CXTPMarkupUIElement::GetOpacity
virtual double GetOpacity() const
Gets either the default or explicitly set opacity factor value.
CXTPMarkupUIElement::GetRenderTransform
CXTPMarkupRenderTransform * GetRenderTransform() const
Obtains a pointer to the RenderTransform object.
CXTPMarkupUIElement::SetVisibility
void SetVisibility(XTPMarkupVisibility visibility)
Sets the user interface (UI) visibility of this element.
CXTPMarkupUIElement::InvalidateMeasureOverride
virtual void InvalidateMeasureOverride(CXTPMarkupDrawingContext *pDC)
Override this method to provide a custom reaction to an InvalidateMeasure call.
CXTPMarkupUIElement::IsFocusable
BOOL IsFocusable() const
Gets or sets a value indicating whether this element can receive focus.
CXTPMarkupUIElement::m_bMeasureInProgress
BOOL m_bMeasureInProgress
TRUE if Measure is currently executed.
Definition XTPMarkupUIElement.h:297
CXTPMarkupUIElement::m_pRenderTransformOriginProperty
static CXTPMarkupDependencyProperty * m_pRenderTransformOriginProperty
Gets or sets the center point of any possible render transform declared by RenderTransform,...
Definition XTPMarkupUIElement.h:320
CXTPMarkupUIElement::CXTPMarkupUIElement
CXTPMarkupUIElement()
Initializes a new instance of the CXTPMarkupUIElement class.
CXTPMarkupUIElement::Arrange
void Arrange(CRect rcFinalRect)
Positions child elements and determines a size for a CXTPMarkupUIElement.
CXTPMarkupUIElement::ApplyRenderTransform
virtual TransformationMatrices ApplyRenderTransform(CXTPMarkupDrawingContext *pContext)
Applies render transformation if necessary.
CXTPMarkupUIElement::m_bMeasureDirty
BOOL m_bMeasureDirty
TRUE if object hasn't recalculated its size.
Definition XTPMarkupUIElement.h:291
CXTPMarkupUIElement::GetFinalRect
CRect GetFinalRect() const
Gets the final render size of this element.
Definition XTPMarkupUIElement.h:344
CXTPMarkupUIElement::IsEnabled
BOOL IsEnabled() const
Gets or sets a value indicating whether this element is enabled in the user interface (UI).
CXTPMarkupUIElement::m_pOpacityProperty
static CXTPMarkupDependencyProperty * m_pOpacityProperty
Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user inter...
Definition XTPMarkupUIElement.h:328
CXTPMarkupUIElement::m_bNeverArranged
BOOL m_bNeverArranged
TRUE if Arrange was never called for this object.
Definition XTPMarkupUIElement.h:295
CXTPMarkupVisual
Provides rendering support for XML Markup, which includes hit testing, coordinate transformation,...
Definition XTPMarkupInputElement.h:223
CXTPMarkupVisual::TransformationMatrices
A structure that optionally describes the previous and the new transformation matrices.
Definition XTPMarkupInputElement.h:361


Toolkit Pro: Member List

CXTPDockingPaneOffice2013Theme Member List

This is the complete list of members for CXTPDockingPaneOffice2013Theme, including all inherited members.

AdjustCaptionRect(const CXTPDockingPaneTabbedContainer *pPane, CRect &rc) | CXTPDockingPaneVisualStudio2012Theme | virtual
CXTPDockingPaneDefaultTheme::AdjustCaptionRect(const CXTPDockingPaneSidePanel *pPane, CRect &rc) | CXTPDockingPanePaintManager | virtual
AdjustClientRect(CXTPDockingPaneTabbedContainer *pPane, CRect &rc, BOOL bApply) | CXTPDockingPaneVisualStudio2012Theme | virtual
CXTPDockingPaneDefaultTheme::AdjustClientRect(CXTPDockingPaneSidePanel *pPane, CRect &rect) | CXTPDockingPanePaintManager | virtual
ClipAndAddEllipsisIfNeeded(CDC *pDC, CString &strTitle, int nCaptionWidth) const | CXTPDockingPanePaintManager | protected
CXTPCmdTarget() | CXTPCmdTarget |
CXTPDockingPaneDefaultTheme() | CXTPDockingPaneDefaultTheme |
CXTPDockingPaneOffice2013Theme() | CXTPDockingPaneOffice2013Theme |
CXTPDockingPanePaintManager() | CXTPDockingPanePaintManager | protected
CXTPDockingPaneVisualStudio2012Theme() | CXTPDockingPaneVisualStudio2012Theme |
DeletePaneColorSets() | CXTPDockingPaneVisualStudio2012Theme | protected
DrawAutoHidePanel(CDC *pDC, CRect rc, XTPDockingPaneDirection direction) | CXTPDockingPaneOffice2013Theme | virtual
DrawCaption(CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc) | CXTPDockingPaneOffice2013Theme | virtual
DrawCaptionButton(CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton) | CXTPDockingPaneOffice2013Theme | virtual
DrawCaptionButtonEntry(CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton, CSize szOffset) | CXTPDockingPanePaintManager | protectedvirtual
DrawCaptionButtonEntry(CDC *pDC, CXTPDockingPaneCaptionButton *pButton, CPoint pt, COLORREF clrButton) | CXTPDockingPanePaintManager | protectedvirtual
DrawCaptionButtons(CDC *pDC, CXTPDockingPaneCaptionButtons *pButtons, CRect &rcCaption, COLORREF clr, int nButtonSize, int nButtonGap, BOOL bVertical=FALSE) | CXTPDockingPanePaintManager | virtual
DrawCaptionPart(CDC *pDC, CXTPDockingPaneBase *pPane, CRect rcCaption, const CString &strTitle, BOOL bActive, BOOL bVertical) | CXTPDockingPaneDefaultTheme | protectedvirtual
DrawCaptionText(CDC *pDC, const CString &strTitle, CRect rc, BOOL bVertical, BOOL bCalcWidth=FALSE) | CXTPDockingPanePaintManager |
DrawDottedLine(CDC *pDC, int x, int y, int nSize, COLORREF clr, BOOL bVertical) | CXTPDockingPaneVisualStudio2012Theme | protected
DrawFloatingFrame(CDC *pDC, CXTPDockingPaneMiniWnd *pPane, CRect rc) | CXTPDockingPaneOffice2013Theme | virtual
DrawGripper(CDC *pDC, CRect rcGripper, COLORREF clr, BOOL bVertical) | CXTPDockingPaneVisualStudio2012Theme | protected
DrawPane(CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc) | CXTPDockingPaneOffice2013Theme | virtual
DrawSidePanel(CDC *pDC, CXTPDockingPaneSidePanel *pPane, CRect rc) | CXTPDockingPaneOffice2013Theme | virtual
DrawSplitter(CDC *pDC, CXTPDockingPaneSplitterWnd *pSplitter) | CXTPDockingPaneOffice2013Theme | virtual
DrawTitleBar(CDC *pDC, CXTPDockingPaneBase *pPane, CRect rc, BOOL bVertical) | CXTPDockingPaneOffice2013Theme | protectedvirtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCaptionButtonStyle() const | CXTPDockingPanePaintManager |
GetCaptionGripperRect(const CXTPDockingPaneTabbedContainer *pPane) | CXTPDockingPanePaintManager | virtual
GetCaptionHeight() const | CXTPDockingPanePaintManager |
GetCaptionRect(const CXTPDockingPaneTabbedContainer *pPane, CRect &rc) | CXTPDockingPanePaintManager | virtual
GetColorSet(BOOL bActive) | CXTPDockingPaneVisualStudio2012Theme | protectedvirtual
GetCurrentSystemTheme() const | CXTPDockingPanePaintManager |
GetCustomTitleBrush(BOOL bActive, BOOL bVertical) const | CXTPDockingPanePaintManager |
GetPaneCaptionRect(const CXTPDockingPaneSidePanel *pPane) | CXTPDockingPaneVisualStudio2012Theme | virtual
GetPanelPaintManager() const | CXTPDockingPanePaintManager |
GetSplitterStyle() const | CXTPDockingPanePaintManager |
GetTabPaintManager() const | CXTPDockingPanePaintManager |
GetTabsHeight() const | CXTPDockingPanePaintManager |
GetXtremeColor(UINT nIndex) | CXTPDockingPanePaintManager |
Line(CDC *pDC, int x0, int y0, int x1, int y1, int nPen) | CXTPDockingPanePaintManager |
Line(CDC *pDC, int x0, int y0, int x1, int y1) | CXTPDockingPanePaintManager |
m_arrColor | CXTPDockingPanePaintManager | protected
m_bDestroyCustomTitleBrushes | CXTPDockingPanePaintManager | protected
m_bDrawCaptionIcon | CXTPDockingPanePaintManager |
m_bDrawSingleTab | CXTPDockingPanePaintManager |
m_bHighlightActiveCaption | CXTPDockingPanePaintManager |
m_bLunaTheme | CXTPDockingPanePaintManager | protected
m_bShowCaption | CXTPDockingPanePaintManager |
m_bUseBoldCaptionFont | CXTPDockingPanePaintManager |
m_bUseOfficeFont | CXTPDockingPanePaintManager | protected
m_bUseStandardFont | CXTPDockingPanePaintManager | protected
m_clrActiveCaption | CXTPDockingPanePaintManager |
m_clrActiveCaptionText | CXTPDockingPanePaintManager |
m_clrBackground | CXTPDockingPanePaintManager |
m_clrDisabledCaptionText | CXTPDockingPanePaintManager |
m_clrNormalCaption | CXTPDockingPanePaintManager |
m_clrNormalCaptionText | CXTPDockingPanePaintManager |
m_clrSplitter | CXTPDockingPanePaintManager |
m_clrSplitterGradient | CXTPDockingPanePaintManager |
m_clrSplitterGripper | CXTPDockingPanePaintManager |
m_dwSplitterStyle | CXTPDockingPanePaintManager | protected
m_hbrActiveTitleHorz | CXTPDockingPanePaintManager | protected
m_hbrActiveTitleVert | CXTPDockingPanePaintManager | protected
m_hbrInactiveTitleHorz | CXTPDockingPanePaintManager | protected
m_hbrInactiveTitleVert | CXTPDockingPanePaintManager | protected
m_nCaptionButtonStyle | CXTPDockingPanePaintManager | protected
m_nCaptionFontGap | CXTPDockingPanePaintManager | protected
m_nFontSize | CXTPDockingPaneVisualStudio2012Theme | protected
m_nSplitterIndent | CXTPDockingPanePaintManager |
m_nSplitterSize | CXTPDockingPanePaintManager |
m_nTabsHeight | CXTPDockingPanePaintManager | protected
m_nTitleHeight | CXTPDockingPanePaintManager | protected
m_pcsActive | CXTPDockingPaneVisualStudio2012Theme | protected
m_pcsInactive | CXTPDockingPaneVisualStudio2012Theme | protected
m_pPanelPaintManager | CXTPDockingPanePaintManager | protected
m_pTabPaintManager | CXTPDockingPanePaintManager | protected
m_rcCaptionMargin | CXTPDockingPanePaintManager | protected
m_strFontFace | CXTPDockingPaneVisualStudio2012Theme | protected
m_strOfficeFont | CXTPDockingPanePaintManager | protected
m_systemTheme | CXTPDockingPanePaintManager | protected
m_themeButton | CXTPDockingPanePaintManager | protected
m_themeCurrent | CXTPDockingPanePaintManager | protected
m_themeExplorer | CXTPDockingPanePaintManager | protected
m_themeRebar | CXTPDockingPanePaintManager | protected
m_themeToolbar | CXTPDockingPanePaintManager | protected
m_themeWindow | CXTPDockingPanePaintManager | protected
m_xtpFontTitle | CXTPDockingPanePaintManager | protected
m_xtpFontTitleVertical | CXTPDockingPanePaintManager | protected
Pixel(CDC *pDC, int xPos, int yPos, int nPen) | CXTPDockingPanePaintManager |
Rectangle(CDC *pDC, CRect rc, int nPenEntry, int nPenBorder) | CXTPDockingPanePaintManager |
RefreshMetrics() | CXTPDockingPaneOffice2013Theme | virtual
SetCaptionButtonStyle(XTPDockingPaneCaptionButtonStyle nStyle) | CXTPDockingPanePaintManager |
SetCaptionFontIndirect(LOGFONT *pLogFont, BOOL bUseStandardFont=FALSE) | CXTPDockingPanePaintManager |
SetColors(int cElements, CONST INT *lpaElements, CONST COLORREF *lpaRgbValues) | CXTPDockingPanePaintManager |
SetCustomTitleBrushes(HBRUSH hbrActiveTitleHorz, HBRUSH hbrInactiveTitleHorz=NULL, HBRUSH hbrActiveTitleVert=NULL, HBRUSH hbrInactiveTitleVert=NULL, BOOL bDestroyOnCleanup=FALSE) | CXTPDockingPanePaintManager |
SetLunaTheme(XTPCurrentSystemTheme systemTheme) | CXTPDockingPanePaintManager |
SetPaneColorSets(CXTPDockingPaneColorSet *pcsActive, CXTPDockingPaneColorSet *pcsInactive) | CXTPDockingPaneVisualStudio2012Theme | protected
SetPanelPaintManager(CXTPTabPaintManager *pManager) | CXTPDockingPanePaintManager |
SetSplitterStyle(DWORD dwStyle) | CXTPDockingPanePaintManager |
SetTabPaintManager(CXTPTabPaintManager *pManager) | CXTPDockingPanePaintManager |
UseOfficeFont(BOOL bUseOfficeFont) | CXTPDockingPanePaintManager |
~CXTPDockingPaneOffice2013Theme() | CXTPDockingPaneOffice2013Theme | virtual
~CXTPDockingPanePaintManager() | CXTPDockingPanePaintManager | protectedvirtual
~CXTPDockingPaneVisualStudio2012Theme() | CXTPDockingPaneVisualStudio2012Theme | virtual


Toolkit Pro: XTPGridHeader.h Source File

  • Source
  • GridControl
XTPGridHeader.h
Go to the documentation of this file.
1
23#if !defined(__XTPGRIDHEADER_H__)
24# define __XTPGRIDHEADER_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPPropExchange;
34
35class CXTPGridColumn;
36class CXTPGridColumns;
37class CXTPGridControl;
38class CXTPGridSubListControl;
39class CXTPGridFilterEditControl;
40class CXTPGridHeaderDropWnd;
41class CXTPGridHeaderDragWnd;
42class CXTPGridPaintManager;
43
48struct XTP_NM_GRIDSCROLL : public NMHDR
49{
50 int nSection;
51 int nPosition;
52};
53
58struct XTP_NM_GRIDGIVEFEEDBACK : public NMHDR
59{
60 DROPEFFECT dropEffect;
61 BOOL bDragStarted;
62};
63
72struct XTP_NM_GRIDCOLUMNRESIZE
73{
74 NMHDR hdr;
75 CXTPGridColumn* pColumn;
76 int nPrevWidth;
77 int nNewWidth;
78};
79
87struct XTP_NM_GRIDROWRESIZE
88{
89 NMHDR hdr;
90 CXTPGridRow* pRow;
91 int nPrevHeight;
92 int nNewHeight;
93};
94
103struct XTP_NM_GRIDCOLUMNORDERCHANGED
104{
105 NMHDR hdr;
106 CXTPGridColumn* pColumn;
107 int nReason;
108};
109
116enum XTPGridColumnOrderChangedReason
117{
118 xtpGridColumnChangeOther = 0x0000,
119 xtpGridColumnOrderChanged = 0x0001,
120 xtpGridColumnGroupOrderChanged = 0x0002,
121 xtpGridColumnOrderChangedMask = 0x000F,
122 xtpGridColumnAdded = 0x0010,
123 xtpGridColumnRemoved = 0x0020,
124 xtpGridColumnPropExchange = 0x0040,
126 xtpGridColumnCaptionChanged = 0x0080,
127 xtpGridColumnWidthChanged = 0x0100,
128 xtpGridColumnShown = 0x0200,
129 xtpGridColumnHidden = 0x0400,
130 xtpGridColumnMoved = 0x0800,
131 xtpGridColumnAddedToGroupby = 0x1000,
132 xtpGridColumnRemovedFromGroupby = 0x2000,
133 xtpGridColumnAddedToFieldChooser = 0x4000,
134 xtpGridColumnRemovedFromFieldChooser = 0x8000,
136 xtpGridColumnChangeMask = 0xFFF0,
137};
142enum XTPGridColumnDirection
143{
144 xtpGridColumnDirectionLeft = -1,
145 xtpGridColumnDirectionRight = +1
146};
147
170class _XTP_EXT_CLASS CXTPGridHeader
171 : public CXTPCmdTarget
172 , public CXTPAccessible
173{
174 DECLARE_INTERFACE_MAP()
175 friend class CXTPGridSubListControl;
176 friend class CXTPGridControl;
177 friend class CXTPGridColumn;
178 friend class CXTPGridHeaderDragWnd;
179
180public:
196 CXTPGridHeader(CXTPGridControl* pControl, CXTPGridColumns* pColumns);
197
202 virtual ~CXTPGridHeader();
203
204protected:
217 virtual void Draw(CDC* pDC, CRect rcHeader, int nLeftOffset);
218
230 virtual void DrawGroupByControl(CDC* pDC, CRect& rcGroupBy);
231
244 virtual void DrawFooter(CDC* pDC, CRect& rcFooter, int nLeftOffset);
245
257 virtual void OnLButtonDown(CPoint ptClick);
258
264 virtual void OnLButtonDblClk(CPoint ptDblClick);
265
279 virtual void OnLButtonUp(UINT nFlags, CPoint ptClick);
280
295 virtual void OnContextMenu(CPoint ptClick);
296
305 CXTPGridPaintManager* GetPaintManager() const;
306
320 virtual void OnMouseMove(UINT nFlags, CPoint point);
321
327 virtual void DoPropExchange(CXTPPropExchange* pPX);
328
329public:
341 BOOL IsDragHeader() const;
342
354 void AllowColumnRemove(BOOL bAllow);
355
367 BOOL IsAllowColumnRemove() const;
368
380 void AllowColumnReorder(BOOL bAllow);
381
393 BOOL IsAllowColumnReorder() const;
394
406 void AllowColumnResize(BOOL bAllow);
407
419 BOOL IsAllowColumnResize() const;
420
429 void ShowItemsInGroups(BOOL bShowInGroups);
430
440 BOOL IsShowItemsInGroups() const;
441
452 void AllowColumnSort(BOOL bAllow);
453
465 BOOL IsAllowColumnSort() const;
466
477 virtual CXTPGridColumn* GetNextVisibleColumn(int nIndex, int nDirection);
478
489 virtual CXTPGridColumn* HitTest(CPoint ptPoint) const;
490
500 virtual int FindHeaderColumn(CPoint ptPoint) const;
501
511 virtual int FindGroupByColumn(CPoint ptPoint, BOOL bExactSearch = FALSE) const;
512
522 virtual int HitTestHeaderColumnIndex(CPoint ptPoint) const;
523
532 CXTPGridColumn* MouseOverColumnResizeArea(CPoint ptPoint);
533
558 int GetFullColScrollInfo(CXTPGridColumn*& rpPrev, CXTPGridColumn*& rpCurr,
559 CXTPGridColumn*& rpNext, int& rnScrollPos, int& rnScrollMax) const;
560
575 void AdjustColumnsWidth(int nTotalWidth, int nFirstIndex = 0);
576
577protected:
590 void StartDragging(CXTPGridColumn* pColumn, BOOL bHeader = FALSE);
591
601 void ResizeColumn(CXTPGridColumn* pColumn, int nWidth);
602
613 void CancelMouseMode();
614
627 int GetMaxAvailWidth(CXTPGridColumn* pColumn);
628
642 int SetHotDivider(int nIndex, BOOL bHeader = TRUE);
643
644public:
657 CXTPGridColumn* GetDraggingColumn() const;
658
671 CXTPGridColumn* GetResizingColumn() const;
672
694 BOOL SetSubListCtrl(CXTPGridSubListControl* pSubList);
695
704 CXTPGridSubListControl* GetSubListCtrl() const;
705
727 BOOL SetFilterEditCtrl(CXTPGridFilterEditControl* pFilterEdit);
728
737 CXTPGridFilterEditControl* GetFilterEditCtrl() const;
738
748 int GetGroupByHeight() const;
749
756 void BestFit(CXTPGridColumn* pColumn);
757
767 BOOL IsLastVisibleColumn(CXTPGridColumn* pColumn) const;
768
778 BOOL IsLastResizebleColumn(CXTPGridColumn* pColumn) const;
779
788 int GetIndentLevel() const;
789
802 virtual void OnColumnsChanged(int nReason, CXTPGridColumn* pColumn);
803
810 CXTPGridControl* GetControl() const;
811
830 void SetAutoColumnSizing(BOOL bAutoColumnSizing);
831
838 BOOL IsAutoColumnSizing() const;
839
846 BOOL ForceLayoutAdjustment() const;
847
856 int GetWidth() const;
857
864 void SetLastColumnExpand(BOOL bLastColumnExpand, BOOL bLastColumnExpandKeep);
865
872 int GetMaxColumnWidth() const;
873
882 void SetMaxColumnWidth(int nMaxColumnWidth);
883
890 HCURSOR GetResizeCursor() const;
891
898 HCURSOR GetResizeVCursor() const;
899
906 HCURSOR GetDontDropCursor() const;
907
908protected:
921 virtual INT_PTR OnToolHitTest(CPoint point, TOOLINFO* pTI) const;
922
923 // private:
924
926 void TrackColumn(CXTPGridColumn* pColumn, CPoint pt);
927 void DestroyDropWnd();
928 void SetHotTrackingColumn(CXTPGridColumn* pColumn);
929 CXTPGridColumn* GetHotTrackingColumn() const;
932protected:
935 // System accessibility support.
936
937 virtual HRESULT GetAccessibleParent(IDispatch** ppdispParent);
938 virtual HRESULT GetAccessibleChildCount(long* pcountChildren);
939 virtual HRESULT GetAccessibleChild(VARIANT varChild, IDispatch** ppdispChild);
940 virtual HRESULT GetAccessibleName(VARIANT varChild, BSTR* pszName);
941 virtual HRESULT GetAccessibleRole(VARIANT varChild, VARIANT* pvarRole);
942 virtual HRESULT AccessibleLocation(long* pxLeft, long* pyTop, long* pcxWidth, long* pcyHeight,
943 VARIANT varChild);
944 virtual HRESULT AccessibleHitTest(long xLeft, long yTop, VARIANT* pvarChild);
945 virtual HRESULT GetAccessibleState(VARIANT varChild, VARIANT* pvarState);
946 virtual CCmdTarget* GetAccessible();
949protected:
950 CXTPGridColumns* m_pColumns;
951 CXTPGridControl* m_pControl;
953 int m_nDropIndex;
954 int m_nVisIndex;
955 // Release 13.1
956 CXTPGridHeaderDropWnd* m_pDropWnd; // Column drop window.
957 CXTPGridHeaderDragWnd* m_pDragWnd;
959 CXTPGridColumn* m_pDragColumn;
960 CXTPGridColumn* m_pResizeColumn;
961 CXTPGridColumn* m_pHotTrackingColumn;
962 BOOL m_bDragHeader;
964 BOOL m_bDragGroupBox;
966 CXTPGridSubListControl* m_pSubList;
967 CXTPGridFilterEditControl* m_pFilterEdit;
969 CRect m_rcGroupBy;
970 CRect m_rcHeader;
971 CPoint m_ptMouse;
974 HCURSOR m_hResizeCursor;
975 HCURSOR m_hResizeVCursor;
976 HCURSOR m_hDontDropCursor;
978 BOOL m_bAllowColumnRemove;
979 BOOL m_bAllowColumnResize;
980 BOOL m_bAllowColumnReorder;
981 BOOL m_bAllowColumnSort;
983 BOOL m_bAutoColumnSizing;
984 int m_nResizeCaptureRange;
986 int m_nIndentLevel;
987 BOOL m_bShowItemsInGroups;
989 int m_nHeaderWidth;
990 int m_nForceLayoutAdjustment;
993 BOOL m_bLastColumnExpand;
994 BOOL m_bLastColumnExpandKeep;
996 int m_nMaxColumnWidth;
1002 enum GridDraggingMode
1003 {
1004 dragNothing = 0,
1005 dragOutTarget = 1,
1006 dragInHeader = 2,
1007 dragInGroupBox = 4,
1008 dragInTarget = 6,
1009 dragFieldChooser = 8
1010 } m_dragMode;
1012public:
1013 static int s_nMinAutoScrollStep;
1015 static BOOL s_bShowItemsInGroupsPXDefault;
1017 static BOOL s_bSendContextMenuForWholeHeaderArea;
1022 BOOL m_bHideColumnAfterGroupBoxDrop;
1024};
1025
1026AFX_INLINE CXTPGridFilterEditControl* CXTPGridHeader::GetFilterEditCtrl() const
1027{
1028 return m_pFilterEdit;
1029}
1030AFX_INLINE BOOL CXTPGridHeader::IsDragHeader() const
1031{
1032 return m_bDragHeader;
1033}
1034AFX_INLINE int CXTPGridHeader::GetIndentLevel() const
1035{
1036 return m_nIndentLevel;
1037}
1038AFX_INLINE void CXTPGridHeader::AllowColumnRemove(BOOL bAllow)
1039{
1040 m_bAllowColumnRemove = bAllow;
1041}
1042AFX_INLINE void CXTPGridHeader::AllowColumnResize(BOOL bAllow)
1043{
1044 m_bAllowColumnResize = bAllow;
1045}
1046AFX_INLINE void CXTPGridHeader::AllowColumnReorder(BOOL bAllow)
1047{
1048 m_bAllowColumnReorder = bAllow;
1049}
1050AFX_INLINE BOOL CXTPGridHeader::IsAllowColumnRemove() const
1051{
1052 return m_bAllowColumnRemove;
1053}
1054AFX_INLINE BOOL CXTPGridHeader::IsAllowColumnReorder() const
1055{
1056 return m_bAllowColumnReorder;
1057}
1058AFX_INLINE BOOL CXTPGridHeader::IsAllowColumnResize() const
1059{
1060 return m_bAllowColumnResize;
1061}
1062AFX_INLINE void CXTPGridHeader::AllowColumnSort(BOOL bAllow)
1063{
1064 m_bAllowColumnSort = bAllow;
1065}
1066AFX_INLINE BOOL CXTPGridHeader::IsAllowColumnSort() const
1067{
1068 return m_bAllowColumnSort;
1069}
1070AFX_INLINE BOOL CXTPGridHeader::IsShowItemsInGroups() const
1071{
1072 return m_bShowItemsInGroups;
1073}
1074AFX_INLINE CXTPGridControl* CXTPGridHeader::GetControl() const
1075{
1076 return m_pControl;
1077}
1078AFX_INLINE CXTPGridSubListControl* CXTPGridHeader::GetSubListCtrl() const
1079{
1080 return m_pSubList;
1081}
1082AFX_INLINE int CXTPGridHeader::GetWidth() const
1083{
1084 return m_nHeaderWidth;
1085}
1086AFX_INLINE BOOL CXTPGridHeader::IsAutoColumnSizing() const
1087{
1088 return m_bAutoColumnSizing;
1089}
1090AFX_INLINE int CXTPGridHeader::ForceLayoutAdjustment() const
1091{
1092 return m_nForceLayoutAdjustment;
1093}
1094AFX_INLINE void CXTPGridHeader::SetMaxColumnWidth(int nMaxColumnWidth)
1095{
1096 m_nMaxColumnWidth = nMaxColumnWidth;
1097}
1098AFX_INLINE int CXTPGridHeader::GetMaxColumnWidth() const
1099{
1100 return m_nMaxColumnWidth;
1101}
1102
1103AFX_INLINE HCURSOR CXTPGridHeader::GetResizeCursor() const
1104{
1105 return m_hResizeCursor;
1106}
1107
1108AFX_INLINE HCURSOR CXTPGridHeader::GetResizeVCursor() const
1109{
1110 return m_hResizeVCursor;
1111}
1112
1113AFX_INLINE HCURSOR CXTPGridHeader::GetDontDropCursor() const
1114{
1115 return m_hDontDropCursor;
1116}
1118# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
1119#endif //#if !defined(__XTPGRIDHEADER_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPGridColumnDirection
XTPGridColumnDirection
Defines a grid column direction.
Definition XTPGridHeader.h:143
xtpGridColumnDirectionLeft
@ xtpGridColumnDirectionLeft
Specifies a left grid column direction.
Definition XTPGridHeader.h:144
xtpGridColumnDirectionRight
@ xtpGridColumnDirectionRight
Specifies a right grid column direction.
Definition XTPGridHeader.h:145
XTPGridColumnOrderChangedReason
XTPGridColumnOrderChangedReason
Enumeration of OnColumnsChanged event reasons.
Definition XTPGridHeader.h:117
xtpGridColumnHidden
@ xtpGridColumnHidden
A column visibility property is changed to "hidden".
Definition XTPGridHeader.h:129
xtpGridColumnChangeMask
@ xtpGridColumnChangeMask
A mask for column change flags.
Definition XTPGridHeader.h:136
xtpGridColumnWidthChanged
@ xtpGridColumnWidthChanged
The column width is changed.
Definition XTPGridHeader.h:127
xtpGridColumnChangeOther
@ xtpGridColumnChangeOther
Neither column order nor group order is changed.
Definition XTPGridHeader.h:118
xtpGridColumnAdded
@ xtpGridColumnAdded
A column is added to the column list.
Definition XTPGridHeader.h:122
xtpGridColumnRemovedFromFieldChooser
@ xtpGridColumnRemovedFromFieldChooser
A column is removed from the field chooser.
Definition XTPGridHeader.h:134
xtpGridColumnMoved
@ xtpGridColumnMoved
A column is moved.
Definition XTPGridHeader.h:130
xtpGridColumnAddedToFieldChooser
@ xtpGridColumnAddedToFieldChooser
A column is added to the field chooser.
Definition XTPGridHeader.h:133
xtpGridColumnShown
@ xtpGridColumnShown
A column visibility property is changed to "visible".
Definition XTPGridHeader.h:128
xtpGridColumnOrderChangedMask
@ xtpGridColumnOrderChangedMask
A mask for order change flags.
Definition XTPGridHeader.h:121
xtpGridColumnRemoved
@ xtpGridColumnRemoved
A column is removed from the column list.
Definition XTPGridHeader.h:123
xtpGridColumnCaptionChanged
@ xtpGridColumnCaptionChanged
The column caption is changed.
Definition XTPGridHeader.h:126
xtpGridColumnRemovedFromGroupby
@ xtpGridColumnRemovedFromGroupby
A column is removed from the Group By box.
Definition XTPGridHeader.h:132
xtpGridColumnAddedToGroupby
@ xtpGridColumnAddedToGroupby
A column is added to the Group By box.
Definition XTPGridHeader.h:131
xtpGridColumnOrderChanged
@ xtpGridColumnOrderChanged
Column order changed.
Definition XTPGridHeader.h:119
xtpGridColumnPropExchange
@ xtpGridColumnPropExchange
The column properties changed during properties exchange procedure.
Definition XTPGridHeader.h:124
xtpGridColumnGroupOrderChanged
@ xtpGridColumnGroupOrderChanged
Group order changed.
Definition XTPGridHeader.h:120
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPGridColumn
Represents a grid column item with its properties and operations.
Definition XTPGridColumn.h:107
CXTPGridColumns
This class is a collection of grid column objects.
Definition XTPGridColumns.h:54
CXTPGridControl
The CXTPGridControl class provides an implementation of the Grid control.
Definition XTPGridControl.h:479
CXTPGridFilterEditControl
The CXTPGridFilterEditControl class provides the functionality of the filter string edit control asso...
Definition XTPGridFilterEditControl.h:57
CXTPGridHeaderDragWnd
CXTPGridHeaderDragWnd is a CWnd derived class.
Definition XTPGridDragDrop.h:43
CXTPGridHeaderDropWnd
CXTPGridHeaderDropWnd is a CWnd derived class.
Definition XTPGridDragDrop.h:112
CXTPGridHeader
A grid header is a part of the grid window positioned above columns of text or numbers.
Definition XTPGridHeader.h:173
CXTPGridHeader::m_pFilterEdit
CXTPGridFilterEditControl * m_pFilterEdit
Filter edit control.
Definition XTPGridHeader.h:967
CXTPGridHeader::m_nForceLayoutAdjustment
int m_nForceLayoutAdjustment
Internal flag to Force Layout Adjustment (and also show scrollbar) if positive.
Definition XTPGridHeader.h:990
CXTPGridHeader::GetPaintManager
CXTPGridPaintManager * GetPaintManager() const
Gets the paint manager object used to draw the Grid control window.
CXTPGridHeader::OnColumnsChanged
virtual void OnColumnsChanged(int nReason, CXTPGridColumn *pColumn)
Updates header settings after any changes occur.
CXTPGridHeader::GetDontDropCursor
HCURSOR GetDontDropCursor() const
Gets the handler of the user's Don't Drop cursor.
Definition XTPGridHeader.h:1113
CXTPGridHeader::DoPropExchange
virtual void DoPropExchange(CXTPPropExchange *pPX)
Reads/writes configuration to/from the provided archive stream.
CXTPGridHeader::m_bAllowColumnRemove
BOOL m_bAllowColumnRemove
FALSE if columns removing is not allowed.
Definition XTPGridHeader.h:978
CXTPGridHeader::m_pHotTrackingColumn
CXTPGridColumn * m_pHotTrackingColumn
Hot column.
Definition XTPGridHeader.h:961
CXTPGridHeader::IsAllowColumnRemove
BOOL IsAllowColumnRemove() const
Determines if column removing is allowed.
Definition XTPGridHeader.h:1050
CXTPGridHeader::HitTest
virtual CXTPGridColumn * HitTest(CPoint ptPoint) const
Determines which column, if any, is at a specified point.
CXTPGridHeader::AdjustColumnsWidth
void AdjustColumnsWidth(int nTotalWidth, int nFirstIndex=0)
Adjusts the width of columns.
CXTPGridHeader::m_pDragWnd
CXTPGridHeaderDragWnd * m_pDragWnd
Column drag window.
Definition XTPGridHeader.h:957
CXTPGridHeader::m_bShowItemsInGroups
BOOL m_bShowItemsInGroups
TRUE when showing items in groups, FALSE when grouping is not used.
Definition XTPGridHeader.h:987
CXTPGridHeader::m_bAllowColumnResize
BOOL m_bAllowColumnResize
FALSE if columns resizing is not allowed.
Definition XTPGridHeader.h:979
CXTPGridHeader::s_bShowItemsInGroupsPXDefault
static BOOL s_bShowItemsInGroupsPXDefault
Store default value of m_bShowItemsInGroups member for serialization (PropExchange).
Definition XTPGridHeader.h:1015
CXTPGridHeader::m_nVisIndex
int m_nVisIndex
Item visual index of the column to drag from.
Definition XTPGridHeader.h:954
CXTPGridHeader::s_bSendContextMenuForWholeHeaderArea
static BOOL s_bSendContextMenuForWholeHeaderArea
If TRUE, then the Grid control sends ContextMenu event for clicks on whole header area (not only for ...
Definition XTPGridHeader.h:1017
CXTPGridHeader::m_hDontDropCursor
HCURSOR m_hDontDropCursor
Handler of the user's Don't Drop cursor.
Definition XTPGridHeader.h:976
CXTPGridHeader::GetWidth
int GetWidth() const
Gets the total width of the header (i.e.
Definition XTPGridHeader.h:1082
CXTPGridHeader::IsShowItemsInGroups
BOOL IsShowItemsInGroups() const
Determines if show items in groups mode is enabled/disabled.
Definition XTPGridHeader.h:1070
CXTPGridHeader::m_bLastColumnExpandKeep
BOOL m_bLastColumnExpandKeep
Not used currently.
Definition XTPGridHeader.h:994
CXTPGridHeader::m_bDragGroupBox
BOOL m_bDragGroupBox
Determines whether control is in group box dragging mode.
Definition XTPGridHeader.h:964
CXTPGridHeader::m_nDropIndex
int m_nDropIndex
Item index of the column to drop to.
Definition XTPGridHeader.h:953
CXTPGridHeader::SetLastColumnExpand
void SetLastColumnExpand(BOOL bLastColumnExpand, BOOL bLastColumnExpandKeep)
Sets the expanded state of the last column.
CXTPGridHeader::m_pColumns
CXTPGridColumns * m_pColumns
Pointer to the associated columns list.
Definition XTPGridHeader.h:950
CXTPGridHeader::AllowColumnResize
void AllowColumnResize(BOOL bAllow)
Specifies if column resizing is allowed.
Definition XTPGridHeader.h:1042
CXTPGridHeader::GetIndentLevel
int GetIndentLevel() const
Gets the indent, in pixels, for a single level of tree depth for the Grid control in tree mode.
Definition XTPGridHeader.h:1034
CXTPGridHeader::FindHeaderColumn
virtual int FindHeaderColumn(CPoint ptPoint) const
Calculates the header index of where to insert a column nearest to a specified point.
CXTPGridHeader::m_pDragColumn
CXTPGridColumn * m_pDragColumn
Dragging column.
Definition XTPGridHeader.h:959
CXTPGridHeader::GridDraggingMode
GridDraggingMode
Specifies grid dragging mode.
Definition XTPGridHeader.h:1003
CXTPGridHeader::DrawFooter
virtual void DrawFooter(CDC *pDC, CRect &rcFooter, int nLeftOffset)
Draws columns footer on a provided device context.
CXTPGridHeader::m_nIndentLevel
int m_nIndentLevel
Width indent at the left of the column.
Definition XTPGridHeader.h:986
CXTPGridHeader::AllowColumnRemove
void AllowColumnRemove(BOOL bAllow)
Specifies if column removing is allowed.
Definition XTPGridHeader.h:1038
CXTPGridHeader::GetMaxAvailWidth
int GetMaxAvailWidth(CXTPGridColumn *pColumn)
Gets the maximum available width of a specified column, in pixels.
CXTPGridHeader::SetAutoColumnSizing
void SetAutoColumnSizing(BOOL bAutoColumnSizing)
Specifies if AutoColumnSizing should be used.
CXTPGridHeader::GetResizingColumn
CXTPGridColumn * GetResizingColumn() const
Gets the resizing column if the control is in resizing mode.
CXTPGridHeader::GetFilterEditCtrl
CXTPGridFilterEditControl * GetFilterEditCtrl() const
Gets the associated filter edit control.
Definition XTPGridHeader.h:1026
CXTPGridHeader::ResizeColumn
void ResizeColumn(CXTPGridColumn *pColumn, int nWidth)
Resizes a specified column to a specified width and adjusts the width of other columns in corresponde...
CXTPGridHeader::m_bLastColumnExpand
BOOL m_bLastColumnExpand
Tells whether the last column is expanded or not.
Definition XTPGridHeader.h:993
CXTPGridHeader::OnToolHitTest
virtual INT_PTR OnToolHitTest(CPoint point, TOOLINFO *pTI) const
The framework calls this member function to determine whether a point is in the bounding rectangle of...
CXTPGridHeader::Draw
virtual void Draw(CDC *pDC, CRect rcHeader, int nLeftOffset)
Draws columns header on a provided device context.
CXTPGridHeader::ShowItemsInGroups
void ShowItemsInGroups(BOOL bShowInGroups)
Enables/disables show items in groups mode.
CXTPGridHeader::IsDragHeader
BOOL IsDragHeader() const
Determines if the header is being dragged.
Definition XTPGridHeader.h:1030
CXTPGridHeader::AllowColumnSort
void AllowColumnSort(BOOL bAllow)
Specifies if column sorting mode is allowed.
Definition XTPGridHeader.h:1062
CXTPGridHeader::FindGroupByColumn
virtual int FindGroupByColumn(CPoint ptPoint, BOOL bExactSearch=FALSE) const
Calculates index of where to insert a column nearest to the provided point.
CXTPGridHeader::m_hResizeCursor
HCURSOR m_hResizeCursor
Handler of the user's horizontal resizing cursor.
Definition XTPGridHeader.h:974
CXTPGridHeader::m_bHideColumnAfterGroupBoxDrop
BOOL m_bHideColumnAfterGroupBoxDrop
Tell whether to hide the column after group box drop.
Definition XTPGridHeader.h:1022
CXTPGridHeader::m_nResizeCaptureRange
int m_nResizeCaptureRange
Distance around column divider where column re-sizer is shown.
Definition XTPGridHeader.h:984
CXTPGridHeader::SetMaxColumnWidth
void SetMaxColumnWidth(int nMaxColumnWidth)
Sets the maximum column width for all columns.
Definition XTPGridHeader.h:1094
CXTPGridHeader::IsAllowColumnResize
BOOL IsAllowColumnResize() const
Determines if column resizing is allowed.
Definition XTPGridHeader.h:1058
CXTPGridHeader::IsLastResizebleColumn
BOOL IsLastResizebleColumn(CXTPGridColumn *pColumn) const
Determines if a specified column in the last resizable column in the grid header.
CXTPGridHeader::m_rcGroupBy
CRect m_rcGroupBy
Group By area coordinates.
Definition XTPGridHeader.h:969
CXTPGridHeader::IsAllowColumnReorder
BOOL IsAllowColumnReorder() const
Determines if column reordering is allowed.
Definition XTPGridHeader.h:1054
CXTPGridHeader::SetFilterEditCtrl
BOOL SetFilterEditCtrl(CXTPGridFilterEditControl *pFilterEdit)
Sets the associated filter edit control.
CXTPGridHeader::IsLastVisibleColumn
BOOL IsLastVisibleColumn(CXTPGridColumn *pColumn) const
Determines if a specified column is the last visible column in the grid header.
CXTPGridHeader::HitTestHeaderColumnIndex
virtual int HitTestHeaderColumnIndex(CPoint ptPoint) const
private:
CXTPGridHeader::m_pControl
CXTPGridControl * m_pControl
Pointer to the parent Grid control.
Definition XTPGridHeader.h:951
CXTPGridHeader::GetMaxColumnWidth
int GetMaxColumnWidth() const
Gets the maximum column width for all columns.
Definition XTPGridHeader.h:1098
CXTPGridHeader::DrawGroupByControl
virtual void DrawGroupByControl(CDC *pDC, CRect &rcGroupBy)
Draws Group By area on a provided device context.
CXTPGridHeader::BestFit
void BestFit(CXTPGridColumn *pColumn)
Adjusts the width of a specified column to the width of the widest column item.
CXTPGridHeader::s_nMinAutoScrollStep
static int s_nMinAutoScrollStep
Minimal horizontal auto-scrolling step, in pixels.
Definition XTPGridHeader.h:1013
CXTPGridHeader::m_ptMouse
CPoint m_ptMouse
Stores mouse coordinates for processing when required (resizing, etc.).
Definition XTPGridHeader.h:971
CXTPGridHeader::MouseOverColumnResizeArea
CXTPGridColumn * MouseOverColumnResizeArea(CPoint ptPoint)
Determines if a specified point is over the column resize area.
CXTPGridHeader::m_bAutoColumnSizing
BOOL m_bAutoColumnSizing
TRUE if AutoColumnSizing should be used.
Definition XTPGridHeader.h:983
CXTPGridHeader::IsAutoColumnSizing
BOOL IsAutoColumnSizing() const
Determines if AutoColumnSizing is used.
Definition XTPGridHeader.h:1086
CXTPGridHeader::GetDraggingColumn
CXTPGridColumn * GetDraggingColumn() const
Gets the dragging column if the control is in dragging mode.
CXTPGridHeader::OnLButtonDown
virtual void OnLButtonDown(CPoint ptClick)
Processes mouse left button down clicks.
CXTPGridHeader::GetNextVisibleColumn
virtual CXTPGridColumn * GetNextVisibleColumn(int nIndex, int nDirection)
Gets the next visible column in the array of columns.
CXTPGridHeader::m_nMaxColumnWidth
int m_nMaxColumnWidth
Custom maximum column width.
Definition XTPGridHeader.h:996
CXTPGridHeader::GetResizeVCursor
HCURSOR GetResizeVCursor() const
Gets the handler of the user's vertical resizing cursor.
Definition XTPGridHeader.h:1108
CXTPGridHeader::m_bAllowColumnSort
BOOL m_bAllowColumnSort
FALSE if columns sorting is not allowed.
Definition XTPGridHeader.h:981
CXTPGridHeader::m_nHeaderWidth
int m_nHeaderWidth
The combined width of all the visible column headers.
Definition XTPGridHeader.h:989
CXTPGridHeader::OnMouseMove
virtual void OnMouseMove(UINT nFlags, CPoint point)
Processes mouse movements.
CXTPGridHeader::OnContextMenu
virtual void OnContextMenu(CPoint ptClick)
Processes context menu.
CXTPGridHeader::AllowColumnReorder
void AllowColumnReorder(BOOL bAllow)
Specifies if column reordering is allowed.
Definition XTPGridHeader.h:1046
CXTPGridHeader::m_pResizeColumn
CXTPGridColumn * m_pResizeColumn
Resizing column.
Definition XTPGridHeader.h:960
CXTPGridHeader::GetSubListCtrl
CXTPGridSubListControl * GetSubListCtrl() const
Gets the associated field chooser list control.
Definition XTPGridHeader.h:1078
CXTPGridHeader::m_hResizeVCursor
HCURSOR m_hResizeVCursor
Handler of the user's vertical resizing cursor.
Definition XTPGridHeader.h:975
CXTPGridHeader::SetSubListCtrl
BOOL SetSubListCtrl(CXTPGridSubListControl *pSubList)
Sets the associated field chooser list control.
CXTPGridHeader::SetHotDivider
int SetHotDivider(int nIndex, BOOL bHeader=TRUE)
Sets a hot divider between columns.
CXTPGridHeader::OnLButtonUp
virtual void OnLButtonUp(UINT nFlags, CPoint ptClick)
Processes mouse left button up clicks.
CXTPGridHeader::CXTPGridHeader
CXTPGridHeader(CXTPGridControl *pControl, CXTPGridColumns *pColumns)
Constructs a CXTPGridHeader object.
CXTPGridHeader::OnLButtonDblClk
virtual void OnLButtonDblClk(CPoint ptDblClick)
Processes mouse left button double clicks.
CXTPGridHeader::~CXTPGridHeader
virtual ~CXTPGridHeader()
Destroys CXTPGridHeader object, handles cleanup and deallocation.
CXTPGridHeader::GetResizeCursor
HCURSOR GetResizeCursor() const
Gets the handler of the user's horizontal resizing cursor.
Definition XTPGridHeader.h:1103
CXTPGridHeader::m_bDragHeader
BOOL m_bDragHeader
Determines whether control is in header dragging mode or group by dragging mode.
Definition XTPGridHeader.h:962
CXTPGridHeader::m_pSubList
CXTPGridSubListControl * m_pSubList
Field chooser list control.
Definition XTPGridHeader.h:966
CXTPGridHeader::ForceLayoutAdjustment
BOOL ForceLayoutAdjustment() const
Call this member to determine m_bForceLayoutAdjustment flag.
Definition XTPGridHeader.h:1090
CXTPGridHeader::CancelMouseMode
void CancelMouseMode()
Resets the mouse mode to xtpMouseNothing and performs all necessary cleanup operations.
CXTPGridHeader::GetGroupByHeight
int GetGroupByHeight() const
Gets the height of the Group By area, in pixels.
CXTPGridHeader::GetControl
CXTPGridControl * GetControl() const
Gets the parent Grid control.
Definition XTPGridHeader.h:1074
CXTPGridHeader::GetFullColScrollInfo
int GetFullColScrollInfo(CXTPGridColumn *&rpPrev, CXTPGridColumn *&rpCurr, CXTPGridColumn *&rpNext, int &rnScrollPos, int &rnScrollMax) const
Gets the current scroll information for full columns scroll mode and the helper information to scroll...
CXTPGridHeader::m_bAllowColumnReorder
BOOL m_bAllowColumnReorder
FALSE if columns reordering is not allowed.
Definition XTPGridHeader.h:980
CXTPGridHeader::IsAllowColumnSort
BOOL IsAllowColumnSort() const
Determines if column sorting mode is allowed.
Definition XTPGridHeader.h:1066
CXTPGridHeader::StartDragging
void StartDragging(CXTPGridColumn *pColumn, BOOL bHeader=FALSE)
Starts column header dragging mode.
CXTPGridHeader::m_rcHeader
CRect m_rcHeader
Header coordinates.
Definition XTPGridHeader.h:970
CXTPGridPaintManager
Utility class that handles most drawing activities.
Definition XTPGridPaintManager.h:76
CXTPGridRow
CXTPGridRow class represents a row of the Grid control window.
Definition XTPGridRow.h:71
CXTPGridSubListControl
Field chooser list box control.
Definition XTPGridSubListControl.h:60
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72
XTP_NM_GRIDCOLUMNORDERCHANGED
This structure is sent to the main window in a WM_NOTIFY message after columns order or group order i...
Definition XTPGridHeader.h:104
XTP_NM_GRIDCOLUMNORDERCHANGED::pColumn
CXTPGridColumn * pColumn
Affected column.
Definition XTPGridHeader.h:106
XTP_NM_GRIDCOLUMNORDERCHANGED::hdr
NMHDR hdr
Standard structure, containing information about a notification message.
Definition XTPGridHeader.h:105
XTP_NM_GRIDCOLUMNORDERCHANGED::nReason
int nReason
Change reason.
Definition XTPGridHeader.h:107
XTP_NM_GRIDCOLUMNRESIZE
This structure is sent to the main window in a WM_NOTIFY message after a column is resized.
Definition XTPGridHeader.h:73
XTP_NM_GRIDCOLUMNRESIZE::pColumn
CXTPGridColumn * pColumn
Resized column.
Definition XTPGridHeader.h:75
XTP_NM_GRIDCOLUMNRESIZE::nPrevWidth
int nPrevWidth
Previous width.
Definition XTPGridHeader.h:76
XTP_NM_GRIDCOLUMNRESIZE::hdr
NMHDR hdr
Standard structure, containing information about a notification message.
Definition XTPGridHeader.h:74
XTP_NM_GRIDCOLUMNRESIZE::nNewWidth
int nNewWidth
New width.
Definition XTPGridHeader.h:77
XTP_NM_GRIDGIVEFEEDBACK
NM_GRIDGIVEFEEDBACK notification data.
Definition XTPGridHeader.h:59
XTP_NM_GRIDROWRESIZE
This structure is sent to the main window in a WM_NOTIFY message after a row is resized.
Definition XTPGridHeader.h:88
XTP_NM_GRIDROWRESIZE::pRow
CXTPGridRow * pRow
Resized row.
Definition XTPGridHeader.h:90
XTP_NM_GRIDROWRESIZE::hdr
NMHDR hdr
Standard structure, containing information about a notification message.
Definition XTPGridHeader.h:89
XTP_NM_GRIDROWRESIZE::nNewHeight
int nNewHeight
New height.
Definition XTPGridHeader.h:92
XTP_NM_GRIDROWRESIZE::nPrevHeight
int nPrevHeight
Previous height.
Definition XTPGridHeader.h:91
XTP_NM_GRIDSCROLL
NM_GRIDSCROLL notification data.
Definition XTPGridHeader.h:49
XTP_NM_GRIDSCROLL::nPosition
int nPosition
New scroll position.
Definition XTPGridHeader.h:51
XTP_NM_GRIDSCROLL::nSection
int nSection
Index of the section.
Definition XTPGridHeader.h:50


Toolkit Pro: Member List

CXTPFlowGraphUndoDeleteNodeCommand Member List

This is the complete list of members for CXTPFlowGraphUndoDeleteNodeCommand, including all inherited members.

CXTPFlowGraphUndoCommand(int nID) | CXTPFlowGraphUndoCommand | protected
CXTPFlowGraphUndoDeleteNodeCommand(CXTPFlowGraphNode *pNode) | CXTPFlowGraphUndoDeleteNodeCommand |
GetID() const | CXTPFlowGraphUndoCommand |
m_nID | CXTPFlowGraphUndoCommand | protected
m_pNode | CXTPFlowGraphUndoDeleteNodeCommand | protected
m_pPage | CXTPFlowGraphUndoDeleteNodeCommand | protected
Undo() | CXTPFlowGraphUndoDeleteNodeCommand | protectedvirtual
~CXTPFlowGraphUndoCommand() | CXTPFlowGraphUndoCommand | protectedvirtual
~CXTPFlowGraphUndoDeleteNodeCommand() | CXTPFlowGraphUndoDeleteNodeCommand | virtual


Toolkit Pro: XTPPopupThemeOffice2013.h Source File

  • Source
  • Controls
  • Popup
  • Themes
XTPPopupThemeOffice2013.h
Go to the documentation of this file.
1
23#if !defined(__XTPPOPUPTHEMEOFFICE2013_H__)
24# define __XTPPOPUPTHEMEOFFICE2013_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPPopupThemeOffice2013 : public CXTPPopupThemeOffice2003
39{
40public:
45 CXTPPopupThemeOffice2013();
46
51 virtual ~CXTPPopupThemeOffice2013();
52
53public:
58 void RefreshMetrics();
59};
60
61# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
63#endif // __XTPPOPUPTHEMEOFFICE2013_H__
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPPopupThemeOffice2003
CXTPPopupThemeOffice2003 is a class used to perform Office 2003 drawing tasks.
Definition XTPPopupThemeOffice2003.h:39
CXTPPopupThemeOffice2013
CXTPPopupThemeOffice2013 is a class used to perform Office 2013 drawing tasks.
Definition XTPPopupThemeOffice2013.h:39
CXTPPopupThemeOffice2013::RefreshMetrics
void RefreshMetrics()
Call this member function to refresh draw metrics.
CXTPPopupThemeOffice2013::CXTPPopupThemeOffice2013
CXTPPopupThemeOffice2013()
Constructs a CXTPPopupThemeOffice2013 object.
CXTPPopupThemeOffice2013::~CXTPPopupThemeOffice2013
virtual ~CXTPPopupThemeOffice2013()
Destroys a CXTPPopupThemeOffice2013 object.


Toolkit Pro: XTPSyntaxEditStruct.h Source File

  • Source
  • SyntaxEdit
XTPSyntaxEditStruct.h
Go to the documentation of this file.
1
23#if !defined(__XTPSYNTAXEDITSTRUCT_H__)
24# define __XTPSYNTAXEDITSTRUCT_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
34namespace XTPSyntaxEditLexAnalyser
36{
37class CXTPSyntaxEditLexTextBlock;
38}
39
40class CXTPSyntaxEditCtrl;
41
46# define XTP_EDIT_XLC(nL, nC) ((((DWORD)nL) << 12) | (((DWORD)nC) & 0x00000FFF))
47
53struct _XTP_EXT_CLASS XTP_EDIT_LINECOL
54{
55 int nLine;
56 int nCol;
58 static const XTP_EDIT_LINECOL MAXPOS;
59 static const XTP_EDIT_LINECOL MINPOS;
60 static const XTP_EDIT_LINECOL Pos1;
70 static const XTP_EDIT_LINECOL AFX_CDECL MakeLineCol(int nParamLine, int nParamCol);
71
79 static const XTP_EDIT_LINECOL AFX_CDECL min2(const XTP_EDIT_LINECOL& pos1,
80 const XTP_EDIT_LINECOL& pos2);
81
89 static const XTP_EDIT_LINECOL AFX_CDECL max2(const XTP_EDIT_LINECOL& pos1,
90 const XTP_EDIT_LINECOL& pos2);
91
98 DWORD GetXLC() const;
99
106 BOOL IsValidData() const;
107
114 void Clear();
115
126 BOOL operator<(const XTP_EDIT_LINECOL& pos2) const;
127
138 BOOL operator<=(const XTP_EDIT_LINECOL& pos2) const;
139
150 BOOL operator>(const XTP_EDIT_LINECOL& pos2) const;
151
162 BOOL operator>=(const XTP_EDIT_LINECOL& pos2) const;
163
174 BOOL operator==(const XTP_EDIT_LINECOL& pos2) const;
175
186 BOOL operator!=(const XTP_EDIT_LINECOL& pos2) const
187 {
188 return !operator==(pos2);
189 }
190};
191
196struct _XTP_EXT_CLASS XTP_EDIT_COLORVALUES
197{
198 CXTPPaintManagerColor crText;
199 CXTPPaintManagerColor crBack;
200 CXTPPaintManagerColor crReadOnlyBack;
201 CXTPPaintManagerColor crHiliteText;
202 CXTPPaintManagerColor crHiliteBack;
203 CXTPPaintManagerColor crInactiveHiliteText;
204 CXTPPaintManagerColor crInactiveHiliteBack;
205 CXTPPaintManagerColor crLineNumberText;
206 CXTPPaintManagerColor crLineNumberBack;
207 CXTPPaintManagerColor crBreakpointText;
208 CXTPPaintManagerColor crBreakpointBack;
220 COLORREF GetBackColorEx(CXTPSyntaxEditCtrl* pEditCtrl);
221};
222
227struct _XTP_EXT_CLASS XTP_EDIT_ROWSBLOCK
228{
229 XTP_EDIT_LINECOL lcStart;
230 XTP_EDIT_LINECOL lcEnd;
232 CString strCollapsedText;
233};
234
235typedef CArray<XTP_EDIT_ROWSBLOCK, const XTP_EDIT_ROWSBLOCK&> CXTPSyntaxEditRowsBlockArray;
236
243struct _XTP_EXT_CLASS XTP_EDIT_COLLAPSEDBLOCK
244{
245 XTP_EDIT_ROWSBLOCK collBlock;
246 CRect rcCollMark;
247};
248
249const UINT XTP_EDIT_ROWNODE_NOTHING = 0x00;
250const UINT XTP_EDIT_ROWNODE_COLLAPSED = 0x01;
251const UINT XTP_EDIT_ROWNODE_EXPANDED = 0x02;
252const UINT XTP_EDIT_ROWNODE_ENDMARK = 0x04;
253const UINT XTP_EDIT_ROWNODE_NODEUP = 0x10;
254const UINT XTP_EDIT_ROWNODE_NODEDOWN = 0x20;
262# define XTP_EDIT_FONTOPTIONS_UNSPEC_OPTION (BYTE) - 1
263
272struct _XTP_EXT_CLASS XTP_EDIT_FONTOPTIONS : public LOGFONT
273{
278 XTP_EDIT_FONTOPTIONS();
279};
280
285struct _XTP_EXT_CLASS XTP_EDIT_TEXTBLOCK
286{
291 XTP_EDIT_TEXTBLOCK();
292
293 int nPos;
294 int nNextBlockPos;
295 XTP_EDIT_COLORVALUES clrBlock;
296 XTP_EDIT_FONTOPTIONS lf;
297};
298
304struct XTP_EDIT_ROWCOLRECT
305{
306 int nRow1;
307 int nCol1;
308 int nRow2;
309 int nCol2;
310};
311
313// Notification structures
315
321struct XTP_EDIT_SENMBOOKMARK
322{
323 NMHDR nmhdr;
324 HDC hDC;
325 RECT rcBookmark;
326 int nRow;
327};
328
335struct XTP_EDIT_NMHDR_ROWCOLCHANGED
336{
337 NMHDR nmhdr;
338 int nRow;
339 int nCol;
340};
341
348struct XTP_EDIT_NMHDR_DOCMODIFIED
349{
350 NMHDR nmhdr;
351 BOOL bModified;
352};
353
358struct XTP_EDIT_NMHDR_EDITCHANGED
359{
360 NMHDR nmhdr;
361 int nRowFrom;
362 int nRowTo;
363 int nAction;
364};
365
370struct XTP_EDIT_NMHDR_MARGINCLICKED
371{
372 NMHDR nmhdr;
373 int nRow;
374 int nDispRow;
375};
376
381struct XTP_EDIT_NMHDR_SETSCROLLPOS
382{
383 NMHDR nmhdr;
384 DWORD dwUpdate;
386};
387
392struct XTP_EDIT_NMHDR_ENABLESCROLLBAR
393{
394 NMHDR nmhdr;
395 DWORD dwScrollBar;
397 DWORD dwState;
398};
399
404struct XTP_EDIT_NMHDR_PARSEEVENT
405{
406 NMHDR nmhdr;
407 DWORD code;
408 WPARAM wParam;
409 LPARAM lParam;
410};
411
412# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
414#endif // !defined(__XTPSYNTAXEDITSTRUCT_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTP_EDIT_ROWNODE_NODEDOWN
const UINT XTP_EDIT_ROWNODE_NODEDOWN
Define that row has down-line node mark.
Definition XTPSyntaxEditStruct.h:254
XTP_EDIT_ROWNODE_EXPANDED
const UINT XTP_EDIT_ROWNODE_EXPANDED
Define that row has expanded node mark.
Definition XTPSyntaxEditStruct.h:251
XTP_EDIT_ROWNODE_COLLAPSED
const UINT XTP_EDIT_ROWNODE_COLLAPSED
Define that row has collapsed node mark.
Definition XTPSyntaxEditStruct.h:250
XTP_EDIT_ROWNODE_ENDMARK
const UINT XTP_EDIT_ROWNODE_ENDMARK
Define that row has end node mark.
Definition XTPSyntaxEditStruct.h:252
XTP_EDIT_ROWNODE_NODEUP
const UINT XTP_EDIT_ROWNODE_NODEUP
Define that row has up-line node mark.
Definition XTPSyntaxEditStruct.h:253
XTP_EDIT_ROWNODE_NOTHING
const UINT XTP_EDIT_ROWNODE_NOTHING
Define that row has no node mark.
Definition XTPSyntaxEditStruct.h:249
CXTPPaintManagerColor
The CXTPPaintManagerColor class is used to manage COLORREF values for determining default and applica...
Definition XTPColorManager.h:117
CXTPSyntaxEditCtrl
This class is the main CWnd-based editor class.
Definition XTPSyntaxEditCtrl.h:114
CXTPSyntaxEditLexTextBlock
The CXTPSyntaxEditLexTextBlock class represents a block of text which corresponds to a lex class in a...
Definition XTPSyntaxEditLexParser.h:266
XTP_EDIT_COLLAPSEDBLOCK
Stores collapsed block parameters.
Definition XTPSyntaxEditStruct.h:244
XTP_EDIT_COLLAPSEDBLOCK::rcCollMark
CRect rcCollMark
Rectangle area to display collapsed block.
Definition XTPSyntaxEditStruct.h:246
XTP_EDIT_COLLAPSEDBLOCK::collBlock
XTP_EDIT_ROWSBLOCK collBlock
Collapsed block parameters.
Definition XTPSyntaxEditStruct.h:245
XTP_EDIT_COLORVALUES
Stores the colors for different phrases.
Definition XTPSyntaxEditStruct.h:197
XTP_EDIT_COLORVALUES::crReadOnlyBack
CXTPPaintManagerColor crReadOnlyBack
Back color for read only mode.
Definition XTPSyntaxEditStruct.h:200
XTP_EDIT_COLORVALUES::crBreakpointText
CXTPPaintManagerColor crBreakpointText
Breakpoint Text color.
Definition XTPSyntaxEditStruct.h:207
XTP_EDIT_COLORVALUES::crLineNumberBack
CXTPPaintManagerColor crLineNumberBack
Line numbers text and line color.
Definition XTPSyntaxEditStruct.h:206
XTP_EDIT_COLORVALUES::crBreakpointBack
CXTPPaintManagerColor crBreakpointBack
Breakpoint Back color.
Definition XTPSyntaxEditStruct.h:208
XTP_EDIT_COLORVALUES::crText
CXTPPaintManagerColor crText
Text color.
Definition XTPSyntaxEditStruct.h:198
XTP_EDIT_COLORVALUES::crHiliteBack
CXTPPaintManagerColor crHiliteBack
Text color of selection back.
Definition XTPSyntaxEditStruct.h:202
XTP_EDIT_COLORVALUES::crInactiveHiliteText
CXTPPaintManagerColor crInactiveHiliteText
Inactive text color of selection.
Definition XTPSyntaxEditStruct.h:203
XTP_EDIT_COLORVALUES::crBack
CXTPPaintManagerColor crBack
Back color.
Definition XTPSyntaxEditStruct.h:199
XTP_EDIT_COLORVALUES::crLineNumberText
CXTPPaintManagerColor crLineNumberText
Line numbers text and line color.
Definition XTPSyntaxEditStruct.h:205
XTP_EDIT_COLORVALUES::GetBackColorEx
COLORREF GetBackColorEx(CXTPSyntaxEditCtrl *pEditCtrl)
Gets the corresponding background color for either the edit or read-only mode of a specified CXTPSynt...
XTP_EDIT_COLORVALUES::crInactiveHiliteBack
CXTPPaintManagerColor crInactiveHiliteBack
Inactive text color of selection back.
Definition XTPSyntaxEditStruct.h:204
XTP_EDIT_COLORVALUES::crHiliteText
CXTPPaintManagerColor crHiliteText
Text color of selection.
Definition XTPSyntaxEditStruct.h:201
XTP_EDIT_FONTOPTIONS
The XTP_EDIT_FONTOPTIONS structure is a self-initializing LOGFONT structure that initializes all valu...
Definition XTPSyntaxEditStruct.h:273
XTP_EDIT_FONTOPTIONS::XTP_EDIT_FONTOPTIONS
XTP_EDIT_FONTOPTIONS()
Default constructor.
XTP_EDIT_LINECOL
The XTP_EDIT_LINECOL structure represents the coordinates of text items on the displaying context in ...
Definition XTPSyntaxEditStruct.h:54
XTP_EDIT_LINECOL::operator>=
BOOL operator>=(const XTP_EDIT_LINECOL &pos2) const
Greater or equal operator.
XTP_EDIT_LINECOL::nLine
int nLine
Line identifier.
Definition XTPSyntaxEditStruct.h:55
XTP_EDIT_LINECOL::IsValidData
BOOL IsValidData() const
Determines if the data is valid.
XTP_EDIT_LINECOL::operator<=
BOOL operator<=(const XTP_EDIT_LINECOL &pos2) const
Less than or equal operator.
XTP_EDIT_LINECOL::nCol
int nCol
Column identifier.
Definition XTPSyntaxEditStruct.h:56
XTP_EDIT_LINECOL::MakeLineCol
static const XTP_EDIT_LINECOL AFX_CDECL MakeLineCol(int nParamLine, int nParamCol)
Constructs an XTP_EDIT_LINECOL object from a pair of coordinates (line and column).
XTP_EDIT_LINECOL::MAXPOS
static const XTP_EDIT_LINECOL MAXPOS
Maximum position value.
Definition XTPSyntaxEditStruct.h:58
XTP_EDIT_LINECOL::GetXLC
DWORD GetXLC() const
Gets the coordinates in packed form.
XTP_EDIT_LINECOL::operator>
BOOL operator>(const XTP_EDIT_LINECOL &pos2) const
Greater than operator.
XTP_EDIT_LINECOL::operator!=
BOOL operator!=(const XTP_EDIT_LINECOL &pos2) const
Not Equal operator.
Definition XTPSyntaxEditStruct.h:186
XTP_EDIT_LINECOL::Clear
void Clear()
Clears data members.
XTP_EDIT_LINECOL::max2
static const XTP_EDIT_LINECOL AFX_CDECL max2(const XTP_EDIT_LINECOL &pos1, const XTP_EDIT_LINECOL &pos2)
Gets a minimum/maximum of two XTP_EDIT_LINECOL values.
XTP_EDIT_LINECOL::Pos1
static const XTP_EDIT_LINECOL Pos1
{1,0} position value.
Definition XTPSyntaxEditStruct.h:60
XTP_EDIT_LINECOL::min2
static const XTP_EDIT_LINECOL AFX_CDECL min2(const XTP_EDIT_LINECOL &pos1, const XTP_EDIT_LINECOL &pos2)
Gets a minimum/maximum of two XTP_EDIT_LINECOL values.
XTP_EDIT_LINECOL::operator==
BOOL operator==(const XTP_EDIT_LINECOL &pos2) const
Equal operator.
XTP_EDIT_LINECOL::operator<
BOOL operator<(const XTP_EDIT_LINECOL &pos2) const
Less than operator.
XTP_EDIT_LINECOL::MINPOS
static const XTP_EDIT_LINECOL MINPOS
Minimum position value.
Definition XTPSyntaxEditStruct.h:59
XTP_EDIT_NMHDR_DOCMODIFIED
Document notification structure.
Definition XTPSyntaxEditStruct.h:349
XTP_EDIT_NMHDR_DOCMODIFIED::bModified
BOOL bModified
TRUE if the document was modified.
Definition XTPSyntaxEditStruct.h:351
XTP_EDIT_NMHDR_DOCMODIFIED::nmhdr
NMHDR nmhdr
First param should be NMHDR.
Definition XTPSyntaxEditStruct.h:350
XTP_EDIT_NMHDR_EDITCHANGED
Structure to notify "Edit changed" event.
Definition XTPSyntaxEditStruct.h:359
XTP_EDIT_NMHDR_EDITCHANGED::nRowTo
int nRowTo
The end row for the action.
Definition XTPSyntaxEditStruct.h:362
XTP_EDIT_NMHDR_EDITCHANGED::nAction
int nAction
The actual action.
Definition XTPSyntaxEditStruct.h:363
XTP_EDIT_NMHDR_EDITCHANGED::nmhdr
NMHDR nmhdr
First param should be NMHDR.
Definition XTPSyntaxEditStruct.h:360
XTP_EDIT_NMHDR_EDITCHANGED::nRowFrom
int nRowFrom
The start row for the action.
Definition XTPSyntaxEditStruct.h:361
XTP_EDIT_NMHDR_ENABLESCROLLBAR
Structure to notify XTP_EDIT_NM_ENABLESCROLLBAR event.
Definition XTPSyntaxEditStruct.h:393
XTP_EDIT_NMHDR_ENABLESCROLLBAR::dwScrollBar
DWORD dwScrollBar
Define the scroll bar(s) to change state as WS_HSCROLL and WS_VSCROLL flags.
Definition XTPSyntaxEditStruct.h:395
XTP_EDIT_NMHDR_ENABLESCROLLBAR::nmhdr
NMHDR nmhdr
First param should be NMHDR.
Definition XTPSyntaxEditStruct.h:394
XTP_EDIT_NMHDR_ENABLESCROLLBAR::dwState
DWORD dwState
Define the scroll bar(s) state as WS_HSCROLL and WS_VSCROLL flags.
Definition XTPSyntaxEditStruct.h:397
XTP_EDIT_NMHDR_MARGINCLICKED
Structure to notify XTP_EDIT_NM_MARGINCLICKED event.
Definition XTPSyntaxEditStruct.h:371
XTP_EDIT_NMHDR_MARGINCLICKED::nRow
int nRow
Document row number.
Definition XTPSyntaxEditStruct.h:373
XTP_EDIT_NMHDR_MARGINCLICKED::nDispRow
int nDispRow
Visible row number (start from 1).
Definition XTPSyntaxEditStruct.h:374
XTP_EDIT_NMHDR_MARGINCLICKED::nmhdr
NMHDR nmhdr
First param should be NMHDR.
Definition XTPSyntaxEditStruct.h:372
XTP_EDIT_NMHDR_PARSEEVENT
Structure to notify XTP_EDIT_NM_PARSEEVENT event.
Definition XTPSyntaxEditStruct.h:405
XTP_EDIT_NMHDR_PARSEEVENT::wParam
WPARAM wParam
First event parameter.
Definition XTPSyntaxEditStruct.h:408
XTP_EDIT_NMHDR_PARSEEVENT::lParam
LPARAM lParam
Second event parameter.
Definition XTPSyntaxEditStruct.h:409
XTP_EDIT_NMHDR_PARSEEVENT::code
DWORD code
Parser event.
Definition XTPSyntaxEditStruct.h:407
XTP_EDIT_NMHDR_PARSEEVENT::nmhdr
NMHDR nmhdr
First param should be NMHDR.
Definition XTPSyntaxEditStruct.h:406
XTP_EDIT_NMHDR_ROWCOLCHANGED
Row column notification structure.
Definition XTPSyntaxEditStruct.h:336
XTP_EDIT_NMHDR_ROWCOLCHANGED::nRow
int nRow
Current document row.
Definition XTPSyntaxEditStruct.h:338
XTP_EDIT_NMHDR_ROWCOLCHANGED::nCol
int nCol
Current document column.
Definition XTPSyntaxEditStruct.h:339
XTP_EDIT_NMHDR_ROWCOLCHANGED::nmhdr
NMHDR nmhdr
First param should be NMHDR.
Definition XTPSyntaxEditStruct.h:337
XTP_EDIT_NMHDR_SETSCROLLPOS
Structure to notify XTP_EDIT_NM_UPDATESCROLLPOS event.
Definition XTPSyntaxEditStruct.h:382
XTP_EDIT_NMHDR_SETSCROLLPOS::dwUpdate
DWORD dwUpdate
Scroll position update flags can be any combination of XTP_EDIT_UPDATE_HORZ, XTP_EDIT_UPDATE_VERT or ...
Definition XTPSyntaxEditStruct.h:384
XTP_EDIT_NMHDR_SETSCROLLPOS::nmhdr
NMHDR nmhdr
First param should be NMHDR.
Definition XTPSyntaxEditStruct.h:383
XTP_EDIT_ROWCOLRECT
The XTP_EDIT_ROWCOLRECT structure is used to define a row and column selection rectangle.
Definition XTPSyntaxEditStruct.h:305
XTP_EDIT_ROWCOLRECT::nRow1
int nRow1
First row index for a text block.
Definition XTPSyntaxEditStruct.h:306
XTP_EDIT_ROWCOLRECT::nRow2
int nRow2
Last row index for a text block.
Definition XTPSyntaxEditStruct.h:308
XTP_EDIT_ROWCOLRECT::nCol1
int nCol1
First column index for a text block.
Definition XTPSyntaxEditStruct.h:307
XTP_EDIT_ROWCOLRECT::nCol2
int nCol2
Last column index for a text block.
Definition XTPSyntaxEditStruct.h:309
XTP_EDIT_ROWSBLOCK
XTP_EDIT_ROWSBLOCK structure.
Definition XTPSyntaxEditStruct.h:228
XTP_EDIT_ROWSBLOCK::lcStart
XTP_EDIT_LINECOL lcStart
Start position.
Definition XTPSyntaxEditStruct.h:229
XTP_EDIT_ROWSBLOCK::lcEnd
XTP_EDIT_LINECOL lcEnd
End Position.
Definition XTPSyntaxEditStruct.h:230
XTP_EDIT_ROWSBLOCK::strCollapsedText
CString strCollapsedText
Collapsed text.
Definition XTPSyntaxEditStruct.h:232
XTP_EDIT_SENMBOOKMARK
Bookmark notification structure.
Definition XTPSyntaxEditStruct.h:322
XTP_EDIT_SENMBOOKMARK::nRow
int nRow
The row number.
Definition XTPSyntaxEditStruct.h:326
XTP_EDIT_SENMBOOKMARK::hDC
HDC hDC
HDC for drawing.
Definition XTPSyntaxEditStruct.h:324
XTP_EDIT_SENMBOOKMARK::rcBookmark
RECT rcBookmark
RECT for bookmark.
Definition XTPSyntaxEditStruct.h:325
XTP_EDIT_SENMBOOKMARK::nmhdr
NMHDR nmhdr
First param should be NMHDR.
Definition XTPSyntaxEditStruct.h:323
XTP_EDIT_TEXTBLOCK
Summary The XTP_EDIT_TEXTBLOCK structure stores the text blocks after parsing.
Definition XTPSyntaxEditStruct.h:286
XTP_EDIT_TEXTBLOCK::lf
XTP_EDIT_FONTOPTIONS lf
Font options for this block.
Definition XTPSyntaxEditStruct.h:296
XTP_EDIT_TEXTBLOCK::XTP_EDIT_TEXTBLOCK
XTP_EDIT_TEXTBLOCK()
Default constructor.
XTP_EDIT_TEXTBLOCK::nNextBlockPos
int nNextBlockPos
Position for the next block.
Definition XTPSyntaxEditStruct.h:294
XTP_EDIT_TEXTBLOCK::clrBlock
XTP_EDIT_COLORVALUES clrBlock
Color for this block.
Definition XTPSyntaxEditStruct.h:295
XTP_EDIT_TEXTBLOCK::nPos
int nPos
Position.
Definition XTPSyntaxEditStruct.h:293


Toolkit Pro: Member List

CXTPCommandBarsOfficeXPTheme Member List

This is the complete list of members for CXTPCommandBarsOfficeXPTheme, including all inherited members.

AdjustExcludeRect(CRect &rc, CXTPControl *pControl, BOOL bVertical) | CXTPCommandBarsOfficeXPTheme | virtual
Animate(CDC *pDestDC, CDC *pSrcDC, CRect rc, XTPAnimationType animationType) | CXTPPaintManager | virtual
AnimateExpanding(CXTPCommandBar *pCommandBar, CDC *pDestDC, CDC *pSrcDC, BOOL bExpandDown) | CXTPPaintManager | virtual
BaseTheme() | CXTPCommandBarsOfficeXPTheme | inlineprotectedvirtual
CreateTheme(XTPPaintTheme paintTheme) | CXTPPaintManager | static
CXTPCmdTarget() | CXTPCmdTarget |
CXTPCommandBarsOfficeXPTheme() | CXTPCommandBarsOfficeXPTheme |
CXTPObservable() | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | protected
CXTPPaintManager() | CXTPPaintManager | protected
Draw3dRect(CDC *pDC, LPCRECT rc, int nTopLeft, int nBottomRight) | CXTPPaintManager |
Draw3dRect(CDC *pDC, LPCRECT rc, int frameThickness, COLORREF clrPen, COLORREF clrBrush) | CXTPPaintManager |
CXTPPaintManager::DrawCheckMark(CDC *pDC, CRect rcCheck, COLORREF clr=0) | CXTPPaintManager | inline
DrawComboExpandMark(CDC *pDC, CRect rc, COLORREF clr) | CXTPPaintManager | virtual
DrawCommandBarGripper(CDC *pDC, CXTPCommandBar *pBar, BOOL bDraw=TRUE) | CXTPCommandBarsOfficeXPTheme | virtual
DrawCommandBarGroupSeparator(CDC *pDC, CXTPCommandBar *pBar, CXTPControl *pLeftControl, CXTPControl *pRightControl, BOOL bDraw=TRUE) | CXTPPaintManager | virtual
DrawCommandBarSeparator(CDC *pDC, CXTPCommandBar *pBar, CXTPControl *pControl, BOOL bDraw=TRUE) | CXTPCommandBarsOfficeXPTheme | virtual
DrawControl(CDC *pDC, CXTPControl *pButton, BOOL bDraw=TRUE) | CXTPPaintManager |
DrawControlCheckBoxMark(CDC *pDC, CRect rc, BOOL bDraw, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled) | CXTPCommandBarsOfficeXPTheme | protectedvirtual
DrawControlCheckBoxMark(CDC *pDC, CXTPControl *pButton, CRect rc, BOOL bDraw) | CXTPCommandBarsOfficeXPTheme | protectedvirtual
DrawControlComboBox(CDC *pDC, CXTPControlComboBox *pComboBox, BOOL bDraw) | CXTPCommandBarsOfficeXPTheme | protectedvirtual
DrawControlEdit(CDC *pDC, CXTPControlEdit *pEdit, BOOL bDraw) | CXTPCommandBarsOfficeXPTheme | protectedvirtual
DrawControlEntry(CDC *pDC, CXTPControl *pButton) | CXTPPaintManager | virtual
DrawControlMDIButton(CDC *pDC, CXTPControlButton *pButton) | CXTPPaintManager | virtual
DrawControlPopupParent(CDC *pDC, CXTPControl *pButton, BOOL bDraw) | CXTPCommandBarsOfficeXPTheme | protectedvirtual
DrawControlRadioButtonMark(CDC *pDC, CRect rc, BOOL bDraw, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled) | CXTPCommandBarsOfficeXPTheme | protectedvirtual
DrawControlText(CDC *pDC, CXTPControl *pControl, CRect rcText, BOOL bDraw, BOOL bVert, BOOL bCentered, BOOL bTriangled) | CXTPPaintManager |
DrawControlToolBarParent(CDC *pDC, CXTPControl *pButton, BOOL bDraw) | CXTPPaintManager | virtual
DrawDialogBarGripper(CDC *pDC, CXTPDialogBar *pBar, BOOL bDraw) | CXTPCommandBarsOfficeXPTheme | virtual
DrawDropDownGlyph(CDC *pDC, CXTPControl *pControl, CPoint pt, BOOL bSelected, BOOL bPopuped, BOOL bEnabled, BOOL bVert) | CXTPPaintManager | virtual
DrawExpandGlyph(CDC *pDC, CXTPControl *pButton, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clr) | CXTPPaintManager | virtual
DrawExpandGlyph(CDC *pDC, CXTPControl *pButton, COLORREF clr, BOOL bVertical) | CXTPPaintManager | virtual
DrawGalleryItemBack(CDC *pDC, CRect rcItem, BOOL bEnabled, BOOL bSelected, BOOL bPressed, BOOL bChecked, XTPBarType barType) | CXTPPaintManager | virtual
DrawHiddenGlyph(CDC *pDC, CXTPControl *pButton, COLORREF clr, BOOL bVertical) | CXTPPaintManager | virtual
DrawImage(CDC *pDC, CPoint pt, CSize sz, CXTPImageManagerIcon *pImage, BOOL bSelected, BOOL bPressed, BOOL bEnabled=TRUE, BOOL bChecked=FALSE, BOOL bPopuped=FALSE, BOOL bToolBarImage=TRUE) | CXTPCommandBarsOfficeXPTheme | protectedvirtual
DrawListBoxControl(CDC *pDC, CXTPControl *pButton, CRect rc, BOOL bSelected, BOOL bDraw, CXTPCommandBars *pCommandBars=0) | CXTPCommandBarsOfficeXPTheme | virtual
DrawPopupBarCheckMark(CDC *pDC, CRect rcCheck, BOOL bEnabled, COLORREF clr) | CXTPPaintManager | virtual
DrawPopupBarGripper(CDC *pDC, int xPos, int yPos, int cx, int cy, BOOL bExpanded=FALSE) | CXTPCommandBarsOfficeXPTheme | protectedvirtual
DrawPopupBarRadioMark(CDC *pDC, CRect rcCheck, BOOL bEnabled, COLORREF clr) | CXTPPaintManager | virtual
DrawPopupResizeGripper(CDC *pDC, CRect rcGripper, int nFlags) | CXTPCommandBarsOfficeXPTheme | virtual
DrawRectangle(CDC *pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition) | CXTPCommandBarsOfficeXPTheme | protectedvirtual
DrawRectangle(CDC *pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition, int nID) | CXTPCommandBarsOfficeXPTheme | protectedvirtual
DrawRectangle(CDC *pDC, CXTPControl *pButton) | CXTPCommandBarsOfficeXPTheme | protectedvirtual
DrawSpecialControl(CDC *pDC, XTPSpecialControl controlType, CXTPControl *pButton, CXTPCommandBar *pBar, BOOL bDraw, LPVOID lpParam) | CXTPPaintManager | virtual
DrawSplitButtonFrame(CDC *pDC, CXTPControl *pButton, CRect rc) | CXTPCommandBarsOfficeXPTheme | protectedvirtual
DrawTearOffGripper(CDC *pDC, CRect rcGripper, BOOL bSelected, BOOL bDraw) | CXTPCommandBarsOfficeXPTheme | virtual
FillCommandBarEntry(CDC *pDC, CXTPCommandBar *pBar) | CXTPCommandBarsOfficeXPTheme | virtual
FillDockBar(CDC *pDC, CXTPDockBar *pBar) | CXTPPaintManager | virtual
FillIntersectRect(CDC *pDC, CXTPPopupBar *pPopupBar, COLORREF clr) | CXTPCommandBarsOfficeXPTheme | protected
FillWorkspace(CDC *pDC, CRect rc, CRect rcExclude) | CXTPPaintManager | virtual
FontExists(LPCTSTR lpszFaceName) | CXTPPaintManager | static
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCommandBarBorders(CXTPCommandBar *pBar) | CXTPPaintManager | virtual
GetCommandBarFont(CXTPCommandBar *pCommandBar) | CXTPPaintManager | virtual
GetControlBackColor(CXTPControl *pButton) | CXTPPaintManager | virtual
GetControlEditBackColor(CXTPControl *pControl) | CXTPPaintManager | virtual
GetControlFont(CXTPControl *pControl) | CXTPPaintManager | virtual
GetControlHeight() const | CXTPPaintManager |
GetControlTextColor(CXTPControl *pButton) | CXTPPaintManager | virtual
GetControlTextOrientation(CXTPControl *pControl) | CXTPPaintManager | virtual
GetCurrentSystemTheme() | CXTPPaintManager |
GetCurrentTheme() | CXTPPaintManager | inline
GetDefaultCommandBarSize(CXTPCommandBar *pBar) | CXTPPaintManager | virtual
GetFramePaintManager() | CXTPPaintManager | virtual
GetGalleryPaintManager() const | CXTPPaintManager | virtual
GetGlobalPaintManager() | CXTPPaintManager | static
GetIconFont() | CXTPPaintManager |
GetIconsInfo() | CXTPPaintManager |
GetInstanceAddRef() | CXTPPaintManager | static
GetMessageBarPaintManager() | CXTPPaintManager | virtual
GetPopupBarGripperWidth(CXTPCommandBar *pBar) | CXTPPaintManager | virtual
GetProgressPaintManager() const | CXTPPaintManager | virtual
GetRectangleTextColor(BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition) | CXTPCommandBarsOfficeXPTheme | virtual
GetRegularBoldFont() | CXTPPaintManager |
GetRegularFont() | CXTPPaintManager |
GetRibbonPaintManager() | CXTPPaintManager | virtual
GetScrollBarPaintManager() const | CXTPPaintManager | virtual
GetShadowManager() const | CXTPPaintManager |
GetShadowOptions() const | CXTPPaintManager |
GetSliderPaintManager() const | CXTPPaintManager | virtual
GetSmCaptionFont() | CXTPPaintManager |
GetSplitButtonCommandRect(CXTPControl *pButton) | CXTPPaintManager | virtual
GetStatusBarPaintManager() | CXTPPaintManager | virtual
GetXtremeColor(UINT nIndex) | CXTPPaintManager |
GradientFill(CDC *pDC, LPRECT lpRect, COLORREF crFrom, COLORREF crTo, BOOL bHorz, LPCRECT lpRectClip=NULL) | CXTPPaintManager |
HorizontalLine(CDC *pDC, int x0, int y0, int x1, COLORREF clrPen) | CXTPPaintManager |
IsUseSystemAccentColorEnabled() const | CXTPPaintManager |
Line(CDC *pDC, CPoint p0, CPoint p1) | CXTPPaintManager |
Line(CDC *pDC, int x0, int y0, int x1, int y1, const int nPen) | CXTPPaintManager |
Line(CDC *pDC, int x0, int y0, int x1, int y1, COLORREF clrPen) | CXTPPaintManager |
m_arrColor | CXTPPaintManager | protected
m_bAutoResizeIcons | CXTPPaintManager |
m_bClearTypeTextQuality | CXTPPaintManager |
m_bEmbossedDisabledText | CXTPPaintManager | protected
m_bEnableAnimation | CXTPPaintManager |
m_bFlatMenuBar | CXTPPaintManager |
m_bFlatToolBar | CXTPPaintManager |
m_bOffice2007Padding | CXTPPaintManager |
m_bOffsetPopupLabelText | CXTPPaintManager |
m_bSelectImageInPopupBar | CXTPPaintManager |
m_bShowKeyboardCues | CXTPPaintManager | protected
m_bShowShadow | CXTPPaintManager |
m_bThemedCheckBox | CXTPPaintManager |
m_bThemedStatusBar | CXTPPaintManager |
m_bThickCheckMark | CXTPPaintManager |
m_bUseOfficeFont | CXTPPaintManager |
m_bUseStandardFont | CXTPPaintManager | protected
m_bWrapCaptionBelowText | CXTPPaintManager |
m_clrDisabledIcon | CXTPPaintManager |
m_clrFloatingGripper | CXTPPaintManager |
m_clrFloatingGripperText | CXTPPaintManager |
m_clrMessageBarText | CXTPPaintManager |
m_fontIcon | CXTPPaintManager |
m_fontIconBold | CXTPPaintManager |
m_fontSmCaption | CXTPPaintManager |
m_fontToolTip | CXTPPaintManager |
m_iconsInfo | CXTPPaintManager | protected
m_nAnimationSteps | CXTPPaintManager | protected
m_nAnimationTime | CXTPPaintManager | protected
m_nEditHeight | CXTPPaintManager | protected
m_nFontHeight | CXTPPaintManager | protected
m_nPopupBarTextPadding | CXTPPaintManager |
m_nSplitButtonDropDownHeight | CXTPPaintManager |
m_nSplitButtonDropDownWidth | CXTPPaintManager |
m_nSplitButtonPopupWidth | CXTPPaintManager |
m_nStatusBarMinHeight | CXTPPaintManager |
m_nTextHeight | CXTPPaintManager |
m_pfnSetLayeredWindowAttributes | CXTPPaintManager |
m_pFramePaintManager | CXTPPaintManager |
m_pGalleryPaintManager | CXTPPaintManager |
m_pProgressPaintManager | CXTPPaintManager |
m_pRibbonPaintManager | CXTPPaintManager |
m_pScrollBarPaintManager | CXTPPaintManager |
m_pShadowManager | CXTPPaintManager | protected
m_pSliderPaintManager | CXTPPaintManager |
m_pStatusBarPaintManager | CXTPPaintManager |
m_rcMessageBarMargin | CXTPPaintManager |
m_rcStatusBarBorder | CXTPPaintManager |
m_strOfficeFont | CXTPPaintManager |
m_systemTheme | CXTPPaintManager | protected
m_themeButton | CXTPPaintManager | protected
m_themeCurrent | CXTPPaintManager | protected
m_themeStatusBar | CXTPPaintManager | protected
m_xtpFontRegular | CXTPPaintManager | protected
m_xtpFontRegularBold | CXTPPaintManager | protected
m_xtpFontVert | CXTPPaintManager | protected
m_xtpFontVertBold | CXTPPaintManager | protected
Notify(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *)) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
Notify(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1), A1 arg1) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
Notify(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
Notify(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamic(void(T::*method)(O *)) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1), A1 arg1) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *)) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1), A1 arg1) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyReversed(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *)) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyReversed(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1), A1 arg1) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyReversed(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyReversed(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
Pixel(CDC *pDC, int xPos, int yPos, int nPen) | CXTPPaintManager |
Rectangle(CDC *pDC, LPCRECT rc, int nPen, const int nBrush) | CXTPPaintManager |
Rectangle(CDC *pDC, LPCRECT rc, COLORREF clrPen, COLORREF clrBrush) | CXTPPaintManager |
RefreshMetrics() | CXTPPaintManager | virtual
ReleaseInstance() | CXTPPaintManager | static
RequiresResourceImages() | CXTPPaintManager | virtual
RoundRect(CDC *pDC, LPCRECT rc, COLORREF clrPen, COLORREF clrBrush) | CXTPPaintManager |
SetAnimationDelay(int nAnimationSteps, int nAnimationTime) | CXTPPaintManager |
SetColors(int cElements, CONST INT *lpaElements, CONST COLORREF *lpaRgbValues) | CXTPPaintManager |
SetCommandBarRegion(CXTPCommandBar *pCommandBar) | CXTPPaintManager | virtual
SetCommandBarsFontIndirect(LOGFONT *pLogFont, BOOL bUseStandardFont=FALSE) | CXTPPaintManager |
SetCustomTheme(CXTPPaintManager *pTheme) | CXTPPaintManager | static
SetGlobalPaintManager(CXTPPaintManager *pPaintManager) | CXTPPaintManager | static
SetImageHandle(HMODULE hResource, LPCTSTR lpszIniFileName) | CXTPPaintManager | virtual
SetLunaTheme(XTPCurrentSystemTheme systemTheme) | CXTPPaintManager |
SetTheme(XTPPaintTheme paintTheme) | CXTPPaintManager | static
StripMnemonics(CString &strClear) | CXTPPaintManager | static
Subscribe(IXTPPaintManagerEvents *pObserver, CXTPSubscriptionList< CXTPPaintManager, IXTPPaintManagerEvents > *pSubcriptionList=NULL) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > |
Triangle(CDC *pDC, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clr) | CXTPPaintManager | static
Unsubscribe(IXTPPaintManagerEvents *pObserver) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > |
UpdateColors() | CXTPPaintManager | virtual
UpdateFonts() | CXTPPaintManager | virtual
UpdateRTLCaption(CString &strCaption) | CXTPPaintManager | virtual
UseOfficeFont(bool bUseOfficeFont) | CXTPPaintManager |
VerticalLine(CDC *pDC, int x0, int y0, int y1, COLORREF clrPen) | CXTPPaintManager |
~CXTPObservable() | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | protected
~CXTPPaintManager() | CXTPPaintManager | protectedvirtual


Toolkit Pro: Member List

CXTPTabThemeNativeWindows10 Member List

This is the complete list of members for CXTPTabThemeNativeWindows10, including all inherited members.

AdjustClientRect(CXTPTabManager *pTabManager, CRect &rcClient) | CXTPTabPaintManagerTheme | virtual
CXTPTabPaintManagerTheme() | CXTPTabPaintManagerTheme |
CXTPTabThemeFlat() | CXTPTabThemeFlat | inline
CXTPTabThemeNativeWindows10() | CXTPTabThemeNativeWindows10 |
CXTPTabThemeOffice2013() | CXTPTabThemeOffice2013 |
DrawSingleButton(CDC *pDC, CXTPTabManagerItem *pItem) | CXTPTabThemeVisualStudio2012 | virtual
DrawTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl) | CXTPTabPaintManagerTheme | virtual
DrawText(CDC *pDC, CXTPTabManager *pManager, const CString &str, LPRECT lpRect, UINT nFormat) | CXTPTabPaintManagerTheme | virtual
DrawWorkspacePart(CDC *pDC, LPRECT lpRect, XTPTabWorkspacePart workspacePart) | CXTPTabThemeVisualStudio2012 | virtual
FillButton(CDC *pDC, CXTPTabManagerItem *pItem, LPPOINT pts, int nCount, XTPTabPosition tabPosition, BOOL bAbsolute=FALSE) | CXTPTabPaintManagerTheme |
FillTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl) | CXTPTabThemeFlat | virtual
GetButtonDrawRect(const CXTPTabManagerItem *pItem) | CXTPTabPaintManagerTheme | virtual
GetButtonHeight(const CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetButtonLength(CDC *pDC, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerTheme | virtual
GetClientMargin() | CXTPTabPaintManagerTheme | virtual
GetClientRect(CRect rcControl, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetColorSet() const | CXTPTabPaintManagerTheme |
GetDefaultColorSet() | CXTPTabThemeNativeWindows10 | inlinevirtual
GetHeaderClipBox(CDC *pDC, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetHeaderHeight(CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme |
GetHeaderMargin() | CXTPTabPaintManagerTheme | virtual
GetHeaderRect(CRect rcControl, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetSupportedColorSets() | CXTPTabPaintManagerTheme | inlinevirtual
m_bButtonsReverseZOrder | CXTPTabPaintManagerTheme | protected
m_nButtonHeight | CXTPTabPaintManagerTheme | protected
m_nRowMargin | CXTPTabPaintManagerTheme |
m_pPaintManager | CXTPTabPaintManagerTheme | protected
m_rcHeaderMargin | CXTPTabPaintManagerTheme |
RefreshMetrics() | CXTPTabThemeNativeWindows10 | virtual
RepositionTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcClient) | CXTPTabPaintManagerTheme | virtual
~CXTPTabPaintManagerTheme() | CXTPTabPaintManagerTheme | virtual


Toolkit Pro: Member List

CXTPShortcutManagerAccelTable Member List

This is the complete list of members for CXTPShortcutManagerAccelTable, including all inherited members.

Add(const XTP_SHORTCUTMANAGER_ACCEL &accel) | CXTPShortcutManagerAccelTable |
CopyAccels() const | CXTPShortcutManagerAccelTable |
CopyAccelTable(HACCEL hAccelTable) | CXTPShortcutManagerAccelTable |
CopyAccelTable(CXTPShortcutManagerAccelTable *pAccelTable) | CXTPShortcutManagerAccelTable |
CopyAccelTable(LPACCEL lpAccel, int nSize) | CXTPShortcutManagerAccelTable |
CXTPShortcutManagerAccelTable(CXTPShortcutManager *pManager) | CXTPShortcutManagerAccelTable |
GetAt(int nIndex) const | CXTPShortcutManagerAccelTable |
GetCount() const | CXTPShortcutManagerAccelTable |
m_arrAccels | CXTPShortcutManagerAccelTable | protected
m_pManager | CXTPShortcutManagerAccelTable | protected
RemoveAll() | CXTPShortcutManagerAccelTable |
RemoveAt(int nIndex) | CXTPShortcutManagerAccelTable |
~CXTPShortcutManagerAccelTable() | CXTPShortcutManagerAccelTable |


Toolkit Pro: Member List

CXTPThemeDLL Member List

This is the complete list of members for CXTPThemeDLL, including all inherited members.

Init(HINSTANCE hAppInstance=NULL, LPCTSTR lpszDllPath=NULL) | CXTPThemeDLL |
Reset() | CXTPThemeDLL |
SetHandle(CString strINI) | CXTPThemeDLL |
XTPThemeDLL() | CXTPThemeDLL | friend
~CXTPThemeDLL() | CXTPThemeDLL | virtual


Toolkit Pro: XTPRibbonBackstageViewThemeResource.h Source File

  • Source
  • Ribbon
  • Backstage
XTPRibbonBackstageViewThemeResource.h
Go to the documentation of this file.
1
23#if !defined(__XTPRIBBONBACKSTAGEVIEWTHEME_H__)
24# define __XTPRIBBONBACKSTAGEVIEWTHEME_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPRibbonBackstageView;
34
35class _XTP_EXT_CLASS CXTPRibbonBackstageViewThemeResource : public CXTPRibbonBackstagePaintManager
36{
37public:
38 virtual void DrawBackground(CDC* pDC, CXTPRibbonBackstageView* pView);
39 virtual void DrawControl(CDC* pDC, CXTPRibbonBackstageView* pView, CXTPControl* pControl);
40};
41
42# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
44#endif // !defined(__XTPRIBBONBACKSTAGEVIEWTHEME_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPControl
CXTPControl is a CXTPCmdTarget derived class.
Definition XTPControl.h:841
CXTPRibbonBackstageView
CXTPRibbonBackstageView is a CDialog derived class used for a Backstage parent frame.
Definition XTPRibbonBackstageView.h:87


Toolkit Pro: XTPChartPieSeriesPointView.h Source File

  • Source
  • Chart
  • Styles
  • Pie
XTPChartPieSeriesPointView.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTPIESERIESPOINTVIEW_H__)
24# define __XTPCHARTPIESERIESPOINTVIEW_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Chart/Styles/Pie/Base/XTPChartPieSeriesPointViewBase.h"
32# include "Chart/Styles/Pie/2D/XTPChart2dPieSeriesPointView.h"
33
34// CXTPChart2dPieSeriesPointView alias is necessary for naming consistency.
35typedef CXTPChartPieSeriesPointView CXTPChart2dPieSeriesPointView;
37#endif //#if !defined(__XTPCHARTPIESERIESPOINTVIEW_H__)
XTPChart2dPieSeriesPointView.h
XTPChartPieSeriesPointViewBase.h
CXTPChartPieSeriesPointView
This class abstracts the view of a pie series point.
Definition XTPChart2dPieSeriesPointView.h:45


Toolkit Pro: Member List

CXTPSyntaxEditLexOnScreenParseCnt Member List

This is the complete list of members for CXTPSyntaxEditLexOnScreenParseCnt, including all inherited members.

CXTPSyntaxEditLexOnScreenParseCnt() | CXTPSyntaxEditLexOnScreenParseCnt |
m_nRowEnd | CXTPSyntaxEditLexOnScreenParseCnt |
m_nRowStart | CXTPSyntaxEditLexOnScreenParseCnt |
m_ptrTBLast | CXTPSyntaxEditLexOnScreenParseCnt |
~CXTPSyntaxEditLexOnScreenParseCnt() | CXTPSyntaxEditLexOnScreenParseCnt | virtual


Toolkit Pro: Member List

CXTPRibbonSystemPopupBar Member List

This is the complete list of members for CXTPRibbonSystemPopupBar, including all inherited members.

AdjustExcludeRect(CRect &rc, BOOL bVertical) | CXTPPopupBar | protectedvirtual
Animate() | CXTPPopupBar | protectedvirtual
CalcDynamicLayout(int nLength, DWORD dwMode) | CXTPRibbonSystemPopupBar | virtual
CalculatePopupRect(CPoint ptPopup, CSize sz) | CXTPPopupBar | virtual
Copy(CXTPCommandBar *pCommandBar, BOOL bRecursive=FALSE) | CXTPPopupBar | protectedvirtual
Create() | CXTPPopupBar | virtual
CreateKeyboardTips() | CXTPCommandBar | virtual
CreatePopupBar(CXTPCommandBars *pCommandBars) | CXTPPopupBar | static
CXTPCommandBar() | CXTPCommandBar | protected
CXTPHookManagerHookAble() | CXTPHookManagerHookAble |
CXTPPopupBar() | CXTPPopupBar | protected
CXTPRibbonSystemPopupBar() | CXTPRibbonSystemPopupBar |
DelayLayout() | CXTPCommandBar |
DelayRedraw() | CXTPPopupBar | inlineprotectedvirtual
DestroyWindow() | CXTPPopupBar |
DisableShadow() | CXTPPopupBar |
DoPropExchange(CXTPPropExchange *pPX) | CXTPPopupBar | protectedvirtual
DrawCommandBar(CDC *pDC, CRect rcClipBox) | CXTPPopupBar | protectedvirtual
EnableAnimation(BOOL bEnable=TRUE) | CXTPCommandBar |
EnableCustomization(BOOL bEnable=TRUE) | CXTPCommandBar |
EnableDoubleBuffer(BOOL bEnable=TRUE) | CXTPCommandBar |
EnsureVisible(CXTPControl *pControl) | CXTPCommandBar | virtual
ExpandBar() | CXTPPopupBar |
FillCommandBarEntry(CDC *pDC) | CXTPRibbonSystemPopupBar | virtual
FindAccel(TCHAR chAccel) const | CXTPCommandBar |
FindAccelEx(UINT chAccel, BOOL &bSelectOnly) const | CXTPCommandBar |
GenerateCommandBarList(DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam) | CXTPCommandBar | protectedvirtual
GetActiveDocTemplate() const | CXTPCommandBar | protected
GetBarID() const | CXTPCommandBar |
GetBorders() | CXTPRibbonSystemPopupBar | virtual
GetButtonSize() const | CXTPCommandBar | virtual
GetCommandBarData() const | CXTPCommandBar |
GetCommandBars() const | CXTPCommandBar |
GetControl(int nIndex) const | CXTPCommandBar |
GetControlCount() const | CXTPCommandBar |
GetControlPopup() const | CXTPPopupBar |
GetControls() const | CXTPCommandBar |
GetDefaultButtonStyle() const | CXTPCommandBar |
GetDefaultItem(UINT gmdiFlags, BOOL fByPos=FALSE) | CXTPPopupBar |
GetFlags() const | CXTPCommandBar |
GetFrameSite() const | CXTPCommandBar |
GetIconSize() const | CXTPCommandBar | virtual
GetImageManager() const | CXTPCommandBar |
GetLargeIconSize(BOOL bAutoSize) const | CXTPCommandBar |
GetOwnerSite() const | CXTPCommandBar |
GetPaintManager() const | CXTPCommandBar |
GetParentCommandBar() const | CXTPPopupBar | protectedvirtual
GetPosition() const | CXTPCommandBar |
GetRootParent() const | CXTPCommandBar |
GetSelected() const | CXTPCommandBar |
GetShowGripper() const | CXTPCommandBar |
GetSite() const | CXTPCommandBar |
GetTextOrientation() const | CXTPCommandBar |
GetTitle() const | CXTPCommandBar |
GetTrackFocus() const | CXTPCommandBar |
GetType() const | CXTPCommandBar |
GetWidth() const | CXTPCommandBar |
HideKeyboardTips() | CXTPCommandBar |
InvalidateParents() | CXTPCommandBar |
IsAnimationEnabled() const | CXTPCommandBar |
IsContextMenu() const | CXTPPopupBar |
IsCustomizable() const | CXTPCommandBar | virtual
IsCustomizeDialogPresent() const | CXTPCommandBar |
IsCustomizeMode() const | CXTPCommandBar |
IsDialogBar() const | CXTPCommandBar | virtual
IsDoubleGripper() const | CXTPPopupBar |
IsHelpMode() const | CXTPCommandBar | protected
IsKeyboardCuesVisible() const | CXTPCommandBar | virtual
IsKeyboardTipsVisible() const | CXTPCommandBar |
IsLayoutRTL() const | CXTPCommandBar |
IsMenuTitleBar() const | CXTPCommandBar | virtual
IsPopupBar() const | CXTPPopupBar | virtual
IsResizable() const | CXTPPopupBar | virtual
IsRibbonBar() const | CXTPCommandBar | virtual
IsTearOffPopup(CString &strCaption, UINT &nID, int &nWidth) | CXTPPopupBar |
IsTextBelowIcons() const | CXTPCommandBar |
IsTrackingMode() const | CXTPCommandBar |
IsVisible() const | CXTPPopupBar | virtual
LoadMenu(CMenu *pMenu, BOOL bRemoveControls=TRUE) | CXTPCommandBar | virtual
LoadToolBar(UINT nIDResource, BOOL bLoadIcons=TRUE) | CXTPCommandBar | virtual
LockMouseMove(CXTPControl *pControl) | CXTPCommandBar |
LockRedraw() | CXTPCommandBar |
m_bAnimatePopup | CXTPCommandBar | protected
m_barPosition | CXTPCommandBar | protected
m_barType | CXTPCommandBar | protected
m_bAutoDestroy | CXTPHookManagerHookAble |
m_bCloseable | CXTPCommandBar | protected
m_bCollapsed | CXTPPopupBar | protected
m_bComboBar | CXTPCommandBar |
m_bContextMenu | CXTPPopupBar | protected
m_bCustomizable | CXTPCommandBar | protected
m_bCustomizeDialogPresent | CXTPCommandBar | protected
m_bDoubleGripper | CXTPPopupBar | protected
m_bDynamicLayout | CXTPPopupBar | protected
m_bExecOnRButton | CXTPCommandBar | protected
m_bExpanded | CXTPPopupBar | protected
m_bExpanding | CXTPPopupBar | protected
m_bGrabFocus | CXTPCommandBar | protected
m_bIgnoreUpdateHandler | CXTPCommandBar | protected
m_bKeyboardSelect | CXTPCommandBar | protected
m_bMultiLine | CXTPCommandBar | protected
m_bRecursePopup | CXTPCommandBar | protected
m_bResizable | CXTPPopupBar | protected
m_bShowShadow | CXTPPopupBar | protected
m_bTearOffPopup | CXTPPopupBar | protected
m_bTearOffSelected | CXTPPopupBar | protected
m_bTearOffTracking | CXTPPopupBar | protected
m_bTextBelow | CXTPCommandBar | protected
m_bTracking | CXTPCommandBar | protected
m_bTrackOnHover | CXTPCommandBar |
m_buttonStyle | CXTPCommandBar | protected
m_bVerticalMarker | CXTPCommandBar | protected
m_dMaxWidthDivisor | CXTPPopupBar | static
m_dwData | CXTPCommandBar | protected
m_dwFlags | CXTPCommandBar | protected
m_dwStyle | CXTPCommandBar | protected
m_hwndFocus | CXTPCommandBar | protected
m_nBarID | CXTPCommandBar | protected
m_nIdleFlags | CXTPCommandBar | protected
m_nLockRedraw | CXTPCommandBar | protected
m_nMaxHeight | CXTPPopupBar | protected
m_nMRUWidth | CXTPCommandBar | protected
m_nPopuped | CXTPCommandBar | protected
m_nSelected | CXTPCommandBar | protected
m_nStateFlags | CXTPCommandBar |
m_nTearOffID | CXTPPopupBar | protected
m_nTearOffTimer | CXTPPopupBar | protected
m_nTearOffWidth | CXTPPopupBar | protected
m_nTextOrientation | CXTPCommandBar | protected
m_pAnimation | CXTPCommandBar | protected
m_pCommandBars | CXTPCommandBar | protected
m_pControlPopup | CXTPPopupBar | protected
m_pControls | CXTPCommandBar | protected
m_pImageManager | CXTPCommandBar | protected
m_popupFlags | CXTPPopupBar | protected
m_pOwner | CXTPCommandBar | protected
m_pPaintManager | CXTPCommandBar | protected
m_pReturnCmd | CXTPCommandBar | protected
m_pSite | CXTPCommandBar | protected
m_pTearOffBar | CXTPPopupBar | protected
m_pToolTipContext | CXTPCommandBar | protected
m_ptPopup | CXTPPopupBar | protected
m_rcBorders | CXTPPopupBar | protected
m_rcExclude | CXTPPopupBar | protected
m_rcMarker | CXTPCommandBar | protected
m_rcResizeGripper | CXTPPopupBar | protected
m_rcTearOffGripper | CXTPPopupBar | protected
m_strTearOffCaption | CXTPPopupBar | protected
m_strTitle | CXTPCommandBar | protected
m_szButtons | CXTPCommandBar | protected
m_szButtonSpacing | CXTPCommandBar | protected
m_szIcons | CXTPCommandBar | protected
m_szTearOffBar | CXTPPopupBar | protected
OnControlsChanged() | CXTPPopupBar | protectedvirtual
OnControlSelected(BOOL bSelected, CXTPControl *pControl) | CXTPCommandBar | virtual
OnCustomizeDragEnter(CXTPControl *pDataObject, CPoint point) | CXTPCommandBar | virtual
OnCustomizeDragLeave() | CXTPCommandBar | virtual
OnCustomizeDragOver(CXTPControl *pDataObject, CPoint point) | CXTPCommandBar | virtual
OnCustomizeDrop(CXTPControl *pDataObject, DROPEFFECT &dropEffect, CPoint ptDrop, CPoint ptDrag) | CXTPCommandBar | virtual
OnHookAttached(HWND hWnd) | CXTPHookManagerHookAble | virtual
OnHookDetached() | CXTPHookManagerHookAble | virtual
OnHookKeyDown(UINT nChar, LPARAM lParam) | CXTPPopupBar | protectedvirtual
OnHookMessage(HWND hWnd, UINT nMessage, WPARAM &wParam, LPARAM &lParam, LRESULT &lResult) | CXTPCommandBar | virtual
OnKeyboardTip(CXTPCommandBarKeyboardTip *pTip) | CXTPCommandBar | virtual
OnKeyboardTipChar(UINT chAccel) | CXTPCommandBar |
OnMouseHitTest(CPoint pt) | CXTPCommandBar | protectedvirtual
OnPostHookMessage(HWND hWnd, UINT nMessage, WPARAM &wParam, LPARAM &lParam, LRESULT &lResult) | CXTPHookManagerHookAble | virtual
OnRecalcLayout() | CXTPPopupBar | protectedvirtual
OnRemoved() | CXTPCommandBar | protectedvirtual
OnTrackEnter() | CXTPCommandBar | virtual
OnTrackLost() | CXTPCommandBar | virtual
Popup(int xPos, int yPos, LPCRECT rcExclude) | CXTPPopupBar |
Popup(CXTPControlPopup *pControlPopup, BOOL bSelectFirst=FALSE) | CXTPPopupBar | virtual
ProcessSpecialKey(XTPSpecialKey key) | CXTPCommandBar | protectedvirtual
PumpMessage() | CXTPPopupBar |
Redraw(LPCRECT lpRect=0, BOOL bAnimate=TRUE) | CXTPCommandBar | virtual
RestoreCommandBarList(CXTPCommandBarList *pCommandBarList) | CXTPCommandBar | protectedvirtual
s_nExpandDelay | CXTPCommandBar | static
s_nExpandHoverDelay | CXTPCommandBar | static
s_nHoverDelay | CXTPCommandBar | static
SetBarID(UINT nID) | CXTPCommandBar |
SetBorders(CRect rcBorders) | CXTPPopupBar |
SetButtons(UINT *pButtons, int nCount) | CXTPCommandBar |
SetButtonSize(CSize size) | CXTPCommandBar |
SetCommandBarData(DWORD_PTR dwData) | CXTPCommandBar |
SetCommandBars(CXTPCommandBars *pCommandBars) | CXTPCommandBar |
SetControls(CXTPControls *pControls) | CXTPCommandBar |
SetDefaultButtonStyle(XTPButtonStyle buttonStyle) | CXTPCommandBar |
SetDefaultItem(UINT uItem, BOOL fByPos=FALSE) | CXTPPopupBar |
SetDoubleGripper(BOOL bDoubleGripper=TRUE) | CXTPPopupBar |
SetFlags(DWORD dwFlagsAdd, DWORD dwFlagsRemove=0) | CXTPCommandBar |
SetGrabFocus(BOOL bGrabFocus) | CXTPCommandBar |
SetIconSize(CSize size) | CXTPCommandBar |
SetImageManager(CXTPImageManager *pImageManager) | CXTPCommandBar |
SetPaintManager(CXTPPaintManager *pPaintManager) | CXTPCommandBar |
SetPopuped(int nPopuped, BOOL bKeyboard=FALSE) | CXTPCommandBar |
SetPopupFlags(DWORD dwPopupFlags) | CXTPPopupBar |
SetPopupToolBar(BOOL bToolBarType) | CXTPPopupBar |
SetPosition(XTPBarPosition barPosition) | CXTPCommandBar | virtual
SetSelected(int nSelected, BOOL bKeyboard=FALSE) | CXTPPopupBar | protectedvirtual
SetShowGripper(BOOL bShow) | CXTPCommandBar |
SetStatusText(const CString &strDescription) | CXTPCommandBar |
SetTearOffPopup(LPCTSTR lpszCaption, UINT nID, int nWidth=400) | CXTPPopupBar |
SetTextOrientation(XTPBarTextOrientation nTextOrientation) | CXTPCommandBar |
SetTitle(LPCTSTR lpszTitle) | CXTPCommandBar |
SetTrackFocus(HWND hwnd) | CXTPCommandBar |
SetTrackingMode(int bMode, BOOL bSelectFirst=TRUE, BOOL bKeyboard=FALSE) | CXTPPopupBar | virtual
SetVisible(BOOL bVisible) | CXTPCommandBar | virtual
SetWidth(int nWidth) | CXTPCommandBar |
ShowTextBelowIcons(BOOL bTextBelow=TRUE) | CXTPCommandBar |
UnlockMouseMove() | CXTPCommandBar |
UnlockRedraw() | CXTPCommandBar |
UpdateExpandingState() | CXTPPopupBar | protected
UpdateFlags() | CXTPPopupBar | protectedvirtual
UpdateLocation(CSize sz) | CXTPPopupBar | protected
UpdateShortcuts() | CXTPCommandBar | protectedvirtual
~CXTPCommandBar() | CXTPCommandBar | protectedvirtual
~CXTPHookManagerHookAble() | CXTPHookManagerHookAble | virtual
~CXTPPopupBar() | CXTPPopupBar | protectedvirtual


Toolkit Pro: XTPChartPyramidDiagramView.h Source File

  • Source
  • Chart
  • Styles
  • Pyramid
XTPChartPyramidDiagramView.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTPYRAMIDDIAGRAMVIEW_H__)
24# define __XTPCHARTPYRAMIDDIAGRAMVIEW_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Chart/Styles/Pyramid/2D/XTPChart2dPyramidDiagramView.h"
32
34typedef CXTPChartPyramidDiagramView CXTPChart2dPyramidDiagramView;
36#endif //#if !defined(__XTPCHARTPYRAMIDDIAGRAMVIEW_H__)
XTPChart2dPyramidDiagramView.h
CXTPChart2dPyramidDiagramView
CXTPChartPyramidDiagramView CXTPChart2dPyramidDiagramView
CXTPChart2dPyramidDiagramView alias is necessary for naming consistency.
Definition XTPChartPyramidDiagramView.h:34
CXTPChartPyramidDiagramView
This class abstracts the view of a pyramid diagram.
Definition XTPChart2dPyramidDiagramView.h:48


Toolkit Pro: XTPTaskPanelDefines.h Source File

  • Source
  • TaskPanel
XTPTaskPanelDefines.h
Go to the documentation of this file.
1
23#if !defined(__XTPTASKPANELDEFINES_H__)
24# define __XTPTASKPANELDEFINES_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPTaskPanelGroup;
34class CXTPTaskPanelItem;
35
41struct XTP_TPNGROUPEXPANDING
42{
43 CXTPTaskPanelGroup* pGroup;
44 BOOL bExpanding;
45};
46
52struct XTP_TPNENDLABELEDIT
53{
54 CXTPTaskPanelItem* pItem;
55 CString strNewString;
56};
57
73enum XTPTaskPanelItemType
74{
75 xtpTaskItemTypeGroup,
76 xtpTaskItemTypeLink,
77 xtpTaskItemTypeText,
78 xtpTaskItemTypeControl
79};
80
95enum XTPTaskPanelItemAllowDrag
96{
97 xtpTaskItemAllowDragNone = 0x00,
98 xtpTaskItemAllowDragDefault = 0x01,
99 xtpTaskItemAllowDragCopyWithinGroup = 0x02,
100 xtpTaskItemAllowDragCopyWithinControl = 0x04,
101 xtpTaskItemAllowDragCopyOutsideControl = 0x08,
102 xtpTaskItemAllowDragCopy = 0x04 + 0x08,
103 xtpTaskItemAllowDragMoveWithinGroup = 0x20,
104 xtpTaskItemAllowDragMoveWithinControl = 0x40,
105 xtpTaskItemAllowDragMoveOutsideControl = 0x80,
106 xtpTaskItemAllowDragMove = 0x40 + 0x80,
107 xtpTaskItemAllowDragWithinGroup = 0x02 + 0x20,
108 xtpTaskItemAllowDragWithinControl = 0x04 + 0x40,
109 xtpTaskItemAllowDrag = 0x04 + 0x08 + 0x40 + 0x80
110};
111
126enum XTPTaskPanelItemLayout
127{
128 xtpTaskItemLayoutDefault,
129 xtpTaskItemLayoutImages,
130 xtpTaskItemLayoutImagesWithText,
131 xtpTaskItemLayoutImagesWithTextBelow
133};
134
149enum XTPTaskPanelHotTrackStyle
150{
151 xtpTaskPanelHighlightDefault,
152 xtpTaskPanelHighlightText,
153 xtpTaskPanelHighlightImage,
154 xtpTaskPanelHighlightItem,
155 xtpTaskPanelHighlightNone
156};
157
169enum XTPTaskPanelBehaviour
170{
171 xtpTaskPanelBehaviourExplorer,
172 xtpTaskPanelBehaviourList,
173 xtpTaskPanelBehaviourToolbox
174};
175
192enum XTPTaskPanelPaintTheme
193{
194 xtpTaskPanelThemeOffice2000,
195 xtpTaskPanelThemeOffice2003,
196 xtpTaskPanelThemeNativeWinXP,
197 xtpTaskPanelThemeOffice2000Plain,
198 xtpTaskPanelThemeOfficeXPPlain,
199 xtpTaskPanelThemeOffice2003Plain,
200 xtpTaskPanelThemeNativeWinXPPlain,
201 xtpTaskPanelThemeVisualStudio2003,
202 xtpTaskPanelThemeVisualStudio2005,
203 xtpTaskPanelThemeListView,
204 xtpTaskPanelThemeListViewOfficeXP,
205 xtpTaskPanelThemeListViewOffice2003,
206 xtpTaskPanelThemeShortcutBarOffice2003,
207 xtpTaskPanelThemeResource,
208 xtpTaskPanelThemeVisualStudio2010,
209 xtpTaskPanelThemeVisualStudio2012Light,
210 xtpTaskPanelThemeVisualStudio2012Dark,
211 xtpTaskPanelThemeOffice2013,
212 xtpTaskPanelThemeOffice2016 = xtpTaskPanelThemeOffice2013,
214 xtpTaskPanelThemeVisualStudio2015,
215 xtpTaskPanelThemeVisualStudio2017,
216 xtpTaskPanelThemeVisualStudio2019,
217 xtpTaskPanelThemeVisualStudio2022,
218 xtpTaskPanelThemeCustom,
219 xtpTaskPanelThemeNativeWindows10,
220 xtpTaskPanelThemeNativeWindows11,
221};
222
224# define xtpTaskPanelThemeToolbox xtpTaskPanelThemeVisualStudio2003
225# define xtpTaskPanelThemeToolboxWhidbey xtpTaskPanelThemeVisualStudio2005
226# define xtpTaskPanelThemeShortcutBarOffice2007 xtpTaskPanelThemeResource
240enum XTPTaskPanelAnimation
241{
242 xtpTaskPanelAnimationYes,
243 xtpTaskPanelAnimationNo,
244 xtpTaskPanelAnimationSystem
245};
246
316const UINT XTPWM_TASKPANEL_NOTIFY = (WM_USER + 9195 + 1);
317
318const UINT XTP_TPN_CLICK = 1;
319const UINT XTP_TPN_RCLICK = 2;
320const UINT XTP_TPN_STARTDRAG = 3;
321const UINT XTP_TPN_ENDLABELEDIT = 4;
322const UINT XTP_TPN_ITEMDROP = 5;
323const UINT XTP_TPN_GROUPEXPANDING = 6;
324const UINT XTP_TPN_GROUPEXPANDED = 7;
325const UINT XTP_TPN_DBLCLICK = 8;
326const UINT XTP_TPN_FOCUSEDITEMCHANGED = 9;
327const UINT XTP_TPN_ITEMREMOVED = 10;
328const UINT XTP_TPN_HOTITEMCHANGED = 11;
329const UINT XTP_TPN_GROUPMOVE = 12;
330const int XTP_ACTION_CANCEL = -1;
332# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
334#endif // !defined(__XTPTASKPANELDEFINES_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTP_TPN_FOCUSEDITEMCHANGED
const UINT XTP_TPN_FOCUSEDITEMCHANGED
Definition XTPTaskPanelDefines.h:326
XTP_TPN_ITEMDROP
const UINT XTP_TPN_ITEMDROP
Definition XTPTaskPanelDefines.h:322
XTP_TPN_GROUPEXPANDING
const UINT XTP_TPN_GROUPEXPANDING
Definition XTPTaskPanelDefines.h:323
XTP_TPN_HOTITEMCHANGED
const UINT XTP_TPN_HOTITEMCHANGED
Definition XTPTaskPanelDefines.h:328
XTPTaskPanelHotTrackStyle
XTPTaskPanelHotTrackStyle
XTPTaskPanelHotTrackStyle is an enumeration used by CXTPTaskPanel to set the hot tracking style used ...
Definition XTPTaskPanelDefines.h:150
xtpTaskPanelHighlightItem
@ xtpTaskPanelHighlightItem
The entire item is highlighted on mouse over.
Definition XTPTaskPanelDefines.h:154
xtpTaskPanelHighlightImage
@ xtpTaskPanelHighlightImage
Only images are highlighted on mouse over.
Definition XTPTaskPanelDefines.h:153
xtpTaskPanelHighlightNone
@ xtpTaskPanelHighlightNone
No hot tracking is used, nothing will happen on mouse over.
Definition XTPTaskPanelDefines.h:155
xtpTaskPanelHighlightText
@ xtpTaskPanelHighlightText
Only text is highlighted on mouse over.
Definition XTPTaskPanelDefines.h:152
xtpTaskPanelHighlightDefault
@ xtpTaskPanelHighlightDefault
Uses the default hot tracking style.
Definition XTPTaskPanelDefines.h:151
XTPTaskPanelPaintTheme
XTPTaskPanelPaintTheme
XTPTaskPanelPaintTheme is an enumeration used by CXTPTaskPanel to set the theme of the control.
Definition XTPTaskPanelDefines.h:193
xtpTaskPanelThemeOffice2000Plain
@ xtpTaskPanelThemeOffice2000Plain
Office 2000 classic theme.
Definition XTPTaskPanelDefines.h:197
xtpTaskPanelThemeVisualStudio2012Light
@ xtpTaskPanelThemeVisualStudio2012Light
VS 2012 Light style Toolbox theme.
Definition XTPTaskPanelDefines.h:209
xtpTaskPanelThemeNativeWindows10
@ xtpTaskPanelThemeNativeWindows10
Win 10 theme.
Definition XTPTaskPanelDefines.h:219
xtpTaskPanelThemeVisualStudio2012Dark
@ xtpTaskPanelThemeVisualStudio2012Dark
VS 2012 Dark style Toolbox theme.
Definition XTPTaskPanelDefines.h:210
xtpTaskPanelThemeVisualStudio2015
@ xtpTaskPanelThemeVisualStudio2015
VS 2015 style Toolbox theme.
Definition XTPTaskPanelDefines.h:214
xtpTaskPanelThemeVisualStudio2010
@ xtpTaskPanelThemeVisualStudio2010
VS 2010 style Toolbox theme.
Definition XTPTaskPanelDefines.h:208
xtpTaskPanelThemeListViewOfficeXP
@ xtpTaskPanelThemeListViewOfficeXP
Office XP List View theme.
Definition XTPTaskPanelDefines.h:204
xtpTaskPanelThemeVisualStudio2017
@ xtpTaskPanelThemeVisualStudio2017
VS 2017 style Toolbox theme.
Definition XTPTaskPanelDefines.h:215
xtpTaskPanelThemeListView
@ xtpTaskPanelThemeListView
Standard List View theme.
Definition XTPTaskPanelDefines.h:203
xtpTaskPanelThemeVisualStudio2019
@ xtpTaskPanelThemeVisualStudio2019
VS 2019 style Toolbox theme.
Definition XTPTaskPanelDefines.h:216
xtpTaskPanelThemeShortcutBarOffice2003
@ xtpTaskPanelThemeShortcutBarOffice2003
Shortcut Bar Office 2003 theme.
Definition XTPTaskPanelDefines.h:206
xtpTaskPanelThemeNativeWindows11
@ xtpTaskPanelThemeNativeWindows11
Win 11 theme.
Definition XTPTaskPanelDefines.h:220
xtpTaskPanelThemeOffice2003Plain
@ xtpTaskPanelThemeOffice2003Plain
Office 2003 classic theme.
Definition XTPTaskPanelDefines.h:199
xtpTaskPanelThemeCustom
@ xtpTaskPanelThemeCustom
User defined Custom theme is used.
Definition XTPTaskPanelDefines.h:218
xtpTaskPanelThemeVisualStudio2022
@ xtpTaskPanelThemeVisualStudio2022
VS 2022 style Toolbox theme.
Definition XTPTaskPanelDefines.h:217
xtpTaskPanelThemeResource
@ xtpTaskPanelThemeResource
Shortcut Bar Office 2007/2010 theme.
Definition XTPTaskPanelDefines.h:207
xtpTaskPanelThemeOffice2003
@ xtpTaskPanelThemeOffice2003
Office 2003 theme.
Definition XTPTaskPanelDefines.h:195
xtpTaskPanelThemeOfficeXPPlain
@ xtpTaskPanelThemeOfficeXPPlain
Office XP classic theme.
Definition XTPTaskPanelDefines.h:198
xtpTaskPanelThemeVisualStudio2005
@ xtpTaskPanelThemeVisualStudio2005
VS 2005 style Toolbox theme.
Definition XTPTaskPanelDefines.h:202
xtpTaskPanelThemeOffice2016
@ xtpTaskPanelThemeOffice2016
Office 2016 style Toolbox theme.
Definition XTPTaskPanelDefines.h:212
xtpTaskPanelThemeOffice2000
@ xtpTaskPanelThemeOffice2000
Office 2000 theme.
Definition XTPTaskPanelDefines.h:194
xtpTaskPanelThemeNativeWinXPPlain
@ xtpTaskPanelThemeNativeWinXPPlain
Win XP classic theme.
Definition XTPTaskPanelDefines.h:200
xtpTaskPanelThemeNativeWinXP
@ xtpTaskPanelThemeNativeWinXP
Win XP theme.
Definition XTPTaskPanelDefines.h:196
xtpTaskPanelThemeOffice2013
@ xtpTaskPanelThemeOffice2013
Office 2013 style Toolbox theme.
Definition XTPTaskPanelDefines.h:211
xtpTaskPanelThemeVisualStudio2003
@ xtpTaskPanelThemeVisualStudio2003
VS 2003 style Toolbox theme.
Definition XTPTaskPanelDefines.h:201
xtpTaskPanelThemeListViewOffice2003
@ xtpTaskPanelThemeListViewOffice2003
Office 2003 List View theme.
Definition XTPTaskPanelDefines.h:205
XTP_TPN_STARTDRAG
const UINT XTP_TPN_STARTDRAG
Definition XTPTaskPanelDefines.h:320
XTP_TPN_RCLICK
const UINT XTP_TPN_RCLICK
Definition XTPTaskPanelDefines.h:319
XTPTaskPanelAnimation
XTPTaskPanelAnimation
XTPTaskPanelAnimation is an enumeration used by CXTPTaskPanel to set the animation of the control.
Definition XTPTaskPanelDefines.h:241
xtpTaskPanelAnimationNo
@ xtpTaskPanelAnimationNo
Disable animation.
Definition XTPTaskPanelDefines.h:243
xtpTaskPanelAnimationYes
@ xtpTaskPanelAnimationYes
Enable animation.
Definition XTPTaskPanelDefines.h:242
xtpTaskPanelAnimationSystem
@ xtpTaskPanelAnimationSystem
Use system settings to determine animation.
Definition XTPTaskPanelDefines.h:244
XTPTaskPanelItemAllowDrag
XTPTaskPanelItemAllowDrag
XTPTaskPanelItemAllowDrag is an enumeration used by CXTPTaskPanel to specify the drag options.
Definition XTPTaskPanelDefines.h:96
xtpTaskItemAllowDragMoveOutsideControl
@ xtpTaskItemAllowDragMoveOutsideControl
Allow move outside task panel only.
Definition XTPTaskPanelDefines.h:105
xtpTaskItemAllowDragNone
@ xtpTaskItemAllowDragNone
Disable drag.
Definition XTPTaskPanelDefines.h:97
xtpTaskItemAllowDragMoveWithinGroup
@ xtpTaskItemAllowDragMoveWithinGroup
Allow move within group only.
Definition XTPTaskPanelDefines.h:103
xtpTaskItemAllowDragMoveWithinControl
@ xtpTaskItemAllowDragMoveWithinControl
Allow move within task panel only.
Definition XTPTaskPanelDefines.h:104
xtpTaskItemAllowDrag
@ xtpTaskItemAllowDrag
Allow all drag operations.
Definition XTPTaskPanelDefines.h:109
xtpTaskItemAllowDragWithinGroup
@ xtpTaskItemAllowDragWithinGroup
Allow drag within group only.
Definition XTPTaskPanelDefines.h:107
xtpTaskItemAllowDragCopyWithinGroup
@ xtpTaskItemAllowDragCopyWithinGroup
Allow copy within group only.
Definition XTPTaskPanelDefines.h:99
xtpTaskItemAllowDragCopy
@ xtpTaskItemAllowDragCopy
Allow copy operation.
Definition XTPTaskPanelDefines.h:102
xtpTaskItemAllowDragCopyOutsideControl
@ xtpTaskItemAllowDragCopyOutsideControl
Allow copy outside task panel only.
Definition XTPTaskPanelDefines.h:101
xtpTaskItemAllowDragMove
@ xtpTaskItemAllowDragMove
Allow move operation.
Definition XTPTaskPanelDefines.h:106
xtpTaskItemAllowDragWithinControl
@ xtpTaskItemAllowDragWithinControl
Allow drag within task panel only.
Definition XTPTaskPanelDefines.h:108
xtpTaskItemAllowDragCopyWithinControl
@ xtpTaskItemAllowDragCopyWithinControl
Allow copy within task panel only.
Definition XTPTaskPanelDefines.h:100
xtpTaskItemAllowDragDefault
@ xtpTaskItemAllowDragDefault
Default drag options (xtpTaskItemAllowDragAll).
Definition XTPTaskPanelDefines.h:98
XTP_ACTION_CANCEL
const int XTP_ACTION_CANCEL
Definition XTPTaskPanelDefines.h:330
XTP_TPN_ENDLABELEDIT
const UINT XTP_TPN_ENDLABELEDIT
Definition XTPTaskPanelDefines.h:321
XTP_TPN_ITEMREMOVED
const UINT XTP_TPN_ITEMREMOVED
Definition XTPTaskPanelDefines.h:327
XTPWM_TASKPANEL_NOTIFY
const UINT XTPWM_TASKPANEL_NOTIFY
The XTPWM_TASKPANEL_NOTIFY message is sent to the CXTPTaskPanel owner window whenever an action occur...
Definition XTPTaskPanelDefines.h:316
XTP_TPN_GROUPEXPANDED
const UINT XTP_TPN_GROUPEXPANDED
Definition XTPTaskPanelDefines.h:324
XTPTaskPanelItemLayout
XTPTaskPanelItemLayout
XTPTaskPanelItemLayout is an enumeration used by CXTPTaskpanel and CXTPTaskPanelGroup to set how the ...
Definition XTPTaskPanelDefines.h:127
xtpTaskItemLayoutDefault
@ xtpTaskItemLayoutDefault
Default Layout.
Definition XTPTaskPanelDefines.h:128
xtpTaskItemLayoutImages
@ xtpTaskItemLayoutImages
Only images are shown.
Definition XTPTaskPanelDefines.h:129
xtpTaskItemLayoutImagesWithText
@ xtpTaskItemLayoutImagesWithText
Both images and text are shown.
Definition XTPTaskPanelDefines.h:130
xtpTaskItemLayoutImagesWithTextBelow
@ xtpTaskItemLayoutImagesWithTextBelow
Both images and text are shown, text is shown below images.
Definition XTPTaskPanelDefines.h:131
XTP_TPN_CLICK
const UINT XTP_TPN_CLICK
Definition XTPTaskPanelDefines.h:318
XTP_TPN_GROUPMOVE
const UINT XTP_TPN_GROUPMOVE
Definition XTPTaskPanelDefines.h:329
XTP_TPN_DBLCLICK
const UINT XTP_TPN_DBLCLICK
Definition XTPTaskPanelDefines.h:325
XTPTaskPanelBehaviour
XTPTaskPanelBehaviour
XTPTaskPanelBehaviour is an enumeration used by CXTPTaskPanel and CXTPTaskPanelGroup to set the behav...
Definition XTPTaskPanelDefines.h:170
xtpTaskPanelBehaviourList
@ xtpTaskPanelBehaviourList
Task Panel will behave like Windows List Box.
Definition XTPTaskPanelDefines.h:172
xtpTaskPanelBehaviourExplorer
@ xtpTaskPanelBehaviourExplorer
Task Panel will behave like Windows Explorer.
Definition XTPTaskPanelDefines.h:171
xtpTaskPanelBehaviourToolbox
@ xtpTaskPanelBehaviourToolbox
Task Panel will behave like VS.
Definition XTPTaskPanelDefines.h:173
XTPTaskPanelItemType
XTPTaskPanelItemType
XTPTaskPanelItemType is an enumeration used by CXTPTaskPanelItem to specify the type of the item.
Definition XTPTaskPanelDefines.h:74
xtpTaskItemTypeControl
@ xtpTaskItemTypeControl
Item is a control.
Definition XTPTaskPanelDefines.h:78
xtpTaskItemTypeText
@ xtpTaskItemTypeText
Item is a text.
Definition XTPTaskPanelDefines.h:77
xtpTaskItemTypeLink
@ xtpTaskItemTypeLink
Item is a link.
Definition XTPTaskPanelDefines.h:76
xtpTaskItemTypeGroup
@ xtpTaskItemTypeGroup
Item is a group.
Definition XTPTaskPanelDefines.h:75
CXTPTaskPanelGroup
CXTPTaskPanelGroup is used in a Task Panel control to represent a group.
Definition XTPTaskPanelGroup.h:45
CXTPTaskPanelItem
CXTPTaskPanelItem is used in a Task Panel control to represent a single item.
Definition XTPTaskPanelItem.h:49
XTP_TPNENDLABELEDIT
This structure is passed as a parameter when an XTP_TPN_ENDLABELEDIT event occurs.
Definition XTPTaskPanelDefines.h:53
XTP_TPNENDLABELEDIT::pItem
CXTPTaskPanelItem * pItem
Item whose caption is about to be changed.
Definition XTPTaskPanelDefines.h:54
XTP_TPNENDLABELEDIT::strNewString
CString strNewString
New caption of the item.
Definition XTPTaskPanelDefines.h:55
XTP_TPNGROUPEXPANDING
This structure is passed as a parameter when an XTP_TPN_GROUPEXPANDING event occurs.
Definition XTPTaskPanelDefines.h:42
XTP_TPNGROUPEXPANDING::pGroup
CXTPTaskPanelGroup * pGroup
Group that is about to be expanded.
Definition XTPTaskPanelDefines.h:43
XTP_TPNGROUPEXPANDING::bExpanding
BOOL bExpanding
TRUE if the group must be expanded.
Definition XTPTaskPanelDefines.h:44


Toolkit Pro: XTPShortcutBarNativeWindows11Theme.h Source File

  • Source
  • ShortcutBar
  • Themes
XTPShortcutBarNativeWindows11Theme.h
Go to the documentation of this file.
1
23#if !defined(__XTPSHORTCUTBARNATIVEWINDOWS11THEME_H__)
24# define __XTPSHORTCUTBARNATIVEWINDOWS11THEME_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPShortcutBarNativeWindows11Theme : public CXTPShortcutBarOffice2013Theme
39{
40public:
45 CXTPShortcutBarNativeWindows11Theme();
46
52 virtual ~CXTPShortcutBarNativeWindows11Theme();
53
61 virtual void RefreshMetrics();
62
84 virtual int DrawPaneItemCaption(CDC* pDC, CXTPShortcutBarPaneItem* pItem, BOOL bDraw);
85
86 virtual void DrawPaneCaptionMinimizeButton(CDC* pDC, CXTPShortcutBarPane* pPane);
87
94 virtual void FillShortcutItemEntry(CDC* pDC, CXTPShortcutBarItem* pItem);
95
102 virtual void FillNavigationItemEntry(CDC* pDC, CXTPShortcutBarItem* pItem);
103
104 void DrawHiliteBorder(CDC* pDC, CRect rc);
105
106protected:
107 BOOL m_bHiliteBorders;
108 CXTPPaintManagerColor m_clrBorderHilite;
109 CXTPPaintManagerColor m_clrBackHiliteSelected;
110};
111
112# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
114#endif // !defined(__XTPSHORTCUTBARNATIVEWINDOWS11THEME_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPPaintManagerColor
The CXTPPaintManagerColor class is used to manage COLORREF values for determining default and applica...
Definition XTPColorManager.h:117
CXTPShortcutBarItem
CXTPShortcutBarItem is a base class that represents an item for a shortcut bar control.
Definition XTPShortcutBar.h:181
CXTPShortcutBarNativeWindows11Theme
CXTPShortcutBarNativeWindows11Theme is a CXTPShortcutBarOffice2013Theme derived class that represents...
Definition XTPShortcutBarNativeWindows11Theme.h:39
CXTPShortcutBarNativeWindows11Theme::DrawPaneItemCaption
virtual int DrawPaneItemCaption(CDC *pDC, CXTPShortcutBarPaneItem *pItem, BOOL bDraw)
Draws the caption for a specified shortcut bar pane item.
CXTPShortcutBarNativeWindows11Theme::m_bHiliteBorders
BOOL m_bHiliteBorders
TRUE to draw borders around highlighted items.
Definition XTPShortcutBarNativeWindows11Theme.h:107
CXTPShortcutBarNativeWindows11Theme::CXTPShortcutBarNativeWindows11Theme
CXTPShortcutBarNativeWindows11Theme()
Constructs a CXTPShortcutBarNativeWindows11Theme object.
CXTPShortcutBarNativeWindows11Theme::m_clrBackHiliteSelected
CXTPPaintManagerColor m_clrBackHiliteSelected
Selected highlighted background color.
Definition XTPShortcutBarNativeWindows11Theme.h:109
CXTPShortcutBarNativeWindows11Theme::FillShortcutItemEntry
virtual void FillShortcutItemEntry(CDC *pDC, CXTPShortcutBarItem *pItem)
Fills a specified item for the shortcut bar control.
CXTPShortcutBarNativeWindows11Theme::m_clrBorderHilite
CXTPPaintManagerColor m_clrBorderHilite
Highlighted border color.
Definition XTPShortcutBarNativeWindows11Theme.h:108
CXTPShortcutBarNativeWindows11Theme::~CXTPShortcutBarNativeWindows11Theme
virtual ~CXTPShortcutBarNativeWindows11Theme()
Destroys a CXTPShortcutBarNativeWindows11Theme object, handles cleanup and deallocation.
CXTPShortcutBarNativeWindows11Theme::RefreshMetrics
virtual void RefreshMetrics()
Refreshes the visual metrics of the shortcut bar paint manager.
CXTPShortcutBarNativeWindows11Theme::FillNavigationItemEntry
virtual void FillNavigationItemEntry(CDC *pDC, CXTPShortcutBarItem *pItem)
Fills a specified navigation item for the minimized shortcut bar control.
CXTPShortcutBarOffice2013Theme
CXTPShortcutBarOffice2013Theme is a CXTPShortcutBarResourceTheme derived class that represents an Off...
Definition XTPShortcutBarOffice2013Theme.h:39
CXTPShortcutBarPane
CXTPShortcutBarPane is a CWnd derived class used as a client area for a shortcut bar control.
Definition XTPShortcutBarPane.h:158
CXTPShortcutBarPaneItem
CXTPShortcutBarPaneItem is a base class that represents an item for a shortcut bar pane.
Definition XTPShortcutBarPane.h:42


Toolkit Pro: Member List

CXTPDockingPaneTabTheme2017 Member List

This is the complete list of members for CXTPDockingPaneTabTheme2017, including all inherited members.

AdjustClientRect(CXTPTabManager *pTabManager, CRect &rcClient) | CXTPTabPaintManagerTheme | virtual
CXTPDockingPaneTabTheme2012() | CXTPDockingPaneTabTheme2012 |
CXTPDockingPaneTabTheme2017() | CXTPDockingPaneTabTheme2017 |
CXTPTabPaintManagerTheme() | CXTPTabPaintManagerTheme |
CXTPTabThemeFlat() | CXTPTabThemeFlat | inline
DrawSingleButton(CDC *pDC, CXTPTabManagerItem *pItem) | CXTPDockingPaneTabTheme2017 | virtual
DrawTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl) | CXTPTabPaintManagerTheme | virtual
DrawText(CDC *pDC, CXTPTabManager *pManager, const CString &str, LPRECT lpRect, UINT nFormat) | CXTPDockingPaneTabTheme2012 | virtual
DrawWorkspacePart(CDC *pDC, LPRECT lpRect, XTPTabWorkspacePart workspacePart) | CXTPTabPaintManagerTheme | virtual
FillButton(CDC *pDC, CXTPTabManagerItem *pItem, LPPOINT pts, int nCount, XTPTabPosition tabPosition, BOOL bAbsolute=FALSE) | CXTPTabPaintManagerTheme |
FillTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl) | CXTPTabThemeFlat | virtual
GetButtonDrawRect(const CXTPTabManagerItem *pItem) | CXTPTabPaintManagerTheme | virtual
GetButtonHeight(const CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetButtonLength(CDC *pDC, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerTheme | virtual
GetClientMargin() | CXTPTabPaintManagerTheme | virtual
GetClientRect(CRect rcControl, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetColorSet() const | CXTPTabPaintManagerTheme |
GetDefaultColorSet() | CXTPTabThemeFlat | inlinevirtual
GetHeaderClipBox(CDC *pDC, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetHeaderHeight(CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme |
GetHeaderMargin() | CXTPTabPaintManagerTheme | virtual
GetHeaderRect(CRect rcControl, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetSupportedColorSets() | CXTPTabPaintManagerTheme | inlinevirtual
m_bButtonsReverseZOrder | CXTPTabPaintManagerTheme | protected
m_nButtonHeight | CXTPTabPaintManagerTheme | protected
m_nRowMargin | CXTPTabPaintManagerTheme |
m_pPaintManager | CXTPTabPaintManagerTheme | protected
m_rcHeaderMargin | CXTPTabPaintManagerTheme |
RefreshMetrics() | CXTPDockingPaneTabTheme2012 | virtual
RepositionTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcClient) | CXTPTabPaintManagerTheme | virtual
~CXTPTabPaintManagerTheme() | CXTPTabPaintManagerTheme | virtual


Toolkit Pro: XTPFrameThemeVisualStudio2015.h Source File

  • Source
  • CommandBars
  • Frame
XTPFrameThemeVisualStudio2015.h
Go to the documentation of this file.
1
23#if !defined(__XTPFRAMETHEMEVISUALSTUDIO2015_H__)
24# define __XTPFRAMETHEMEVISUALSTUDIO2015_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPPaintManager;
34class CXTPCommandBarsFrameHook;
35class CXTPRibbonBar;
36
37class _XTP_EXT_CLASS CXTPFrameThemeVisualStudio2015
38 : public CXTPFrameThemeOffice2013
39 , private IXTPApplicationEvents
40{
41public:
42 CXTPFrameThemeVisualStudio2015(CXTPPaintManager* pPaintManager);
43
44 virtual ~CXTPFrameThemeVisualStudio2015();
45
46public:
51 virtual void RefreshMetrics();
52
64 virtual void DrawFrameCaptionButton(CDC* pDC, CRect rc, int nId, BOOL bSelected, BOOL bPressed,
65 BOOL bActive);
66
79 virtual void DrawFrameCaptionButton(CDC* pDC, CRect rc, int nId, BOOL bSelected, BOOL bPressed,
80 BOOL bActive, CXTPRibbonBar* pRibbonBar);
81
90 virtual void SetStateColor(COLORREF clrState);
91
100 virtual COLORREF GetStateColor() const;
101
102 virtual CRect CalcFrameBorder(const CXTPCommandBarsFrameHook* pFrameHook) const;
103
104 virtual CXTPFrameShadow* CreateShadow(CWnd* pFrame);
105
106 virtual void OnShadowedFrameActiveStateChanged(BOOL bActive, CWnd* pFrame,
107 CXTPFrameShadow* pShadow);
108
109private:
110 virtual void OnAmbientPropertyChanged(CXTPApplication* pApplication,
111 XTPApplicationAmbientProperty nProperty);
112 void UpdateStateColor();
113
114 BOOL m_bAutomaticStateColor;
115
116protected:
117 COLORREF m_clrShadowColorActive;
118 COLORREF m_clrShadowColorInactive;
119};
121# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
122#endif // !defined(__XTPFRAMETHEMEVISUALSTUDIO2015_H__)
XTPApplicationAmbientProperty
XTPApplicationAmbientProperty
Global ambient property identifiers.
Definition XTPApplication.h:46
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPApplication
Defines a global XTP application object interface.
Definition XTPApplication.h:151
CXTPCommandBarsFrameHook
CXTPCommandBarsFrameHook is a CXTPHookManagerHookAble derived class.
Definition XTPFrameHook.h:56
CXTPFramePaintManager::OnShadowedFrameActiveStateChanged
virtual void OnShadowedFrameActiveStateChanged(BOOL bActive, CWnd *pFrame, CXTPFrameShadow *pShadow)
An implementation can override this method in order to change frame appearance when a window gets act...
CXTPFrameShadow
The class represents frame shadow object.
Definition XTPFrameShadow.h:47
CXTPPaintManager
Paint manager of the command bars.
Definition XTPPaintManager.h:199
CXTPRibbonBar
CXTPRibbonBar is a CXTPMenuBar derived class.
Definition XTPRibbonBar.h:69
IXTPApplicationEvents
Defines a callback interface for XTP application event sink.
Definition XTPApplication.h:82
IXTPApplicationEvents::OnAmbientPropertyChanged
virtual void OnAmbientPropertyChanged(CXTPApplication *pApplication, XTPApplicationAmbientProperty nProperty)
Called by framework when an ambient property is changed.
Definition XTPApplication.h:130


Toolkit Pro: Member List

CXTPCommandBars Member List

This is the complete list of members for CXTPCommandBars, including all inherited members.

Add(LPCTSTR lpszName, XTPBarPosition nBarPosition, CRuntimeClass *pToolbarClass=NULL) | CXTPCommandBars |
Add(CXTPToolBar *pToolBar, LPCTSTR strName, XTPBarPosition nBarPosition) | CXTPCommandBars |
AddCustomBar(LPCTSTR lpcstrCaption, UINT nID, BOOL bTearOffBar=FALSE) | CXTPCommandBars | virtual
CanDock(CPoint pt, CXTPDockBar *pMainDock=NULL) const | CXTPCommandBars |
ClosePopups() const | CXTPCommandBars |
ContextMenu(CXTPToolBar *pToolBar, CPoint point) | CXTPCommandBars | virtual
CreateAction(int nId) | CXTPCommandBars |
CreateCommandBars() | CXTPCommandBars | static
CreateKeyboardTips(CXTPCommandBar *pCommandBar) | CXTPCommandBars | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPCommandBars() | CXTPCommandBars | protected
DockCommandBar(CXTPToolBar *pBar, LPRECT lpRect, CXTPDockBar *pDockBar) | CXTPCommandBars |
DockCommandBar(CXTPToolBar *pBar, XTPBarPosition barPosition) | CXTPCommandBars |
DoPropExchange(CXTPPropExchange *pPX, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam=NULL) | CXTPCommandBars |
EnableActions(BOOL bEnableActions=TRUE) | CXTPCommandBars |
EnableCustomization(BOOL bCustomizeAvail) | CXTPCommandBars |
EnableDefaultResetCustomizedToolbarChoice(BOOL bEnable, BOOL bDefaultYes) | CXTPCommandBars |
EnableDocking() | CXTPCommandBars |
EnableFrameTheme(BOOL bEnable=TRUE) | CXTPCommandBars |
EnableToolbarComposition(BOOL bEnable=TRUE) | CXTPCommandBars |
FindAction(int nId) const | CXTPCommandBars |
FindControl(XTPControlType type, UINT nId, BOOL bVisible, BOOL bRecursive) const | CXTPCommandBars |
FindIndex(CXTPToolBar *pToolBar) const | CXTPCommandBars |
FloatCommandBar(CXTPToolBar *pBar) | CXTPCommandBars | protected
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetActions() const | CXTPCommandBars |
GetActiveDocTemplate() | CXTPCommandBars | virtual
GetAddOrRemovePopup(CXTPToolBar *pToolBar, CXTPCommandBar *pExpandBar) | CXTPCommandBars | virtual
GetAt(int nIndex) const | CXTPCommandBars |
GetCommandBarsOptions() const | CXTPCommandBars |
GetContextMenus() const | CXTPCommandBars |
GetCount() const | CXTPCommandBars |
GetDockBar(XTPBarPosition barPosition) const | CXTPCommandBars |
GetDockState(CXTPDockState &state) | CXTPCommandBars | protected
GetDragControl() const | CXTPCommandBars |
GetDropSource() const | CXTPCommandBars |
GetFontHeight() const | CXTPCommandBars |
GetFrameHook() const | CXTPCommandBars |
GetFrameReBar() const | CXTPCommandBars |
GetHelpTrackingId() const | CXTPCommandBars |
GetHiddenControls(CXTPToolBar *pToolBar, CXTPCommandBar *pExpandBar) | CXTPCommandBars | virtual
GetImageManager() const | CXTPCommandBars |
GetKeyboardManager() const | CXTPCommandBars |
GetMenuBar() const | CXTPCommandBars | virtual
GetMenuTitleBar() const | CXTPCommandBars |
GetMouseManager() const | CXTPCommandBars |
GetPaintManager() const | CXTPCommandBars |
GetShortcutManager() const | CXTPCommandBars |
GetSite() const | CXTPCommandBars |
GetStatusBar() const | CXTPCommandBars |
GetToolBar(UINT nID) const | CXTPCommandBars |
GetToolbarsPopup() | CXTPCommandBars | virtual
GetToolTipContext() const | CXTPCommandBars |
HideCommand(UINT nCommand) | CXTPCommandBars |
HideCommands(const UINT *pCommands, int nCount) | CXTPCommandBars |
HideKeyboardTips() | CXTPCommandBars |
InvalidateCommandBars() | CXTPCommandBars |
IsActionsEnabled() const | CXTPCommandBars |
IsAllCaps() const | CXTPCommandBars |
IsCommandHidden(UINT nCommand) | CXTPCommandBars | virtual
IsControlHidden(CXTPControl *pControl) | CXTPCommandBars | virtual
IsCustomizeAvail() const | CXTPCommandBars |
IsCustomizeMode() const | CXTPCommandBars |
IsDwmEnabled() const | CXTPCommandBars |
IsEnableFrameTheme() | CXTPCommandBars |
IsLayoutRTL() const | CXTPCommandBars |
IsQuickCustomizeMode() const | CXTPCommandBars |
LoadBarState(LPCTSTR lpszProfileName, BOOL bSilent=FALSE) | CXTPCommandBars |
LoadDesignerBars(CArchive &ar, UINT nSchemaVersion=_XTP_SCHEMA_CURRENT) | CXTPCommandBars |
LoadDesignerBars(CXTPPropExchange *pPX) | CXTPCommandBars |
LoadOptions(LPCTSTR lpszProfileName) | CXTPCommandBars |
m_arrBars | CXTPCommandBars | protected
m_bCustomizeAvail | CXTPCommandBars | protected
m_bCustomizeMode | CXTPCommandBars | protected
m_bDefaultResetCustomizedToolbarChoice | CXTPCommandBars | protected
m_bDefaultResetCustomizedToolbarChoiceEnabled | CXTPCommandBars | protected
m_bDesignerMode | CXTPCommandBars |
m_bEnableActions | CXTPCommandBars | protected
m_bIgnoreShiftMenuKey | CXTPCommandBars |
m_bInternalFrameHook | CXTPCommandBars | protected
m_bKeyboardCuesVisible | CXTPCommandBars | protected
m_bQuickCustomizeMode | CXTPCommandBars | protected
m_nDefaultMenuID | CXTPCommandBars | protected
m_nIDHelpTracking | CXTPCommandBars | protected
m_pActions | CXTPCommandBars | protected
m_pContextMenus | CXTPCommandBars | protected
m_pDesignerControls | CXTPCommandBars |
m_pDockBarClass | CXTPCommandBars | protectedstatic
m_pDocks | CXTPCommandBars | protected
m_pDragSelected | CXTPCommandBars | protected
m_pDropSource | CXTPCommandBars | protected
m_pFrame | CXTPCommandBars | protected
m_pFrameHook | CXTPCommandBars | protected
m_pImageManager | CXTPCommandBars | protected
m_pKeyboardManager | CXTPCommandBars | mutableprotected
m_pMenuBarClass | CXTPCommandBars | protectedstatic
m_pMenuTitleBarClass | CXTPCommandBars | protectedstatic
m_pMouseManager | CXTPCommandBars | mutableprotected
m_pOptions | CXTPCommandBars | protected
m_pPaintManager | CXTPCommandBars | protected
m_pPopupBarClass | CXTPCommandBars | protectedstatic
m_pPopupToolBarClass | CXTPCommandBars | protectedstatic
m_pShortcutManager | CXTPCommandBars | protected
m_pToolBarClass | CXTPCommandBars | protectedstatic
m_pToolTipContext | CXTPCommandBars | protected
m_strControlsFileName | CXTPCommandBars | protected
OnFrameAccel(UINT chAccel) | CXTPCommandBars |
OnFrameWndMsg(UINT message, WPARAM wParam, LPARAM lParam, LRESULT *pResult) | CXTPCommandBars |
OnSetPreviewMode(BOOL bPreview) | CXTPCommandBars |
OnToolBarAdded(CXTPToolBar *pToolBar) | CXTPCommandBars | protectedvirtual
OnToolBarRemoved(CXTPToolBar *pToolBar) | CXTPCommandBars | protectedvirtual
OnTrackingModeChanged(CXTPCommandBar *pCommandBar, int bMode) | CXTPCommandBars | virtual
PreTranslateFrameMessage(MSG *pMsg) | CXTPCommandBars |
RecalcFrameLayout(BOOL bDelay=FALSE) | CXTPCommandBars | virtual
RedrawCommandBars() | CXTPCommandBars |
Remove(CXTPToolBar *pToolBar) | CXTPCommandBars |
RemoveAll() | CXTPCommandBars |
ResetUsageData() | CXTPCommandBars |
SaveBarState(LPCTSTR lpszProfileName, BOOL bOnlyCustomized=TRUE) | CXTPCommandBars |
SaveOptions(LPCTSTR lpszProfileName) | CXTPCommandBars |
SerializeBarState(CArchive &ar, BOOL bSerializeControls=FALSE, BOOL bOnlyCustomized=TRUE, BOOL bSilent=FALSE) | CXTPCommandBars |
SetAllCaps(BOOL bAllCaps) | CXTPCommandBars |
SetCommandUsed(UINT nCommand) | CXTPCommandBars |
SetCustomizationDataFileName(LPCTSTR lpszFile) | CXTPCommandBars |
SetCustomizeMode(BOOL bMode) | CXTPCommandBars |
SetDockBarClass(CRuntimeClass *pDockBarClass) | CXTPCommandBars | static
SetDockState(CXTPDockState &state) | CXTPCommandBars | protected
SetDragControl(CCmdTarget *pControl) | CXTPCommandBars |
SetFontHeight(int nFontHeight) | CXTPCommandBars |
SetFrameHook(CXTPCommandBarsFrameHook *pFrameHook) | CXTPCommandBars |
SetImageManager(CXTPImageManager *pImageManager) | CXTPCommandBars |
SetLayoutRTL(BOOL bRightToLeft) | CXTPCommandBars |
SetMenu(LPCTSTR lpszName, UINT nID) | CXTPCommandBars |
SetMenuBarClass(CRuntimeClass *pMenuBarClass) | CXTPCommandBars | static
SetMenuTitleBar(LPCTSTR strName, UINT nID, INT nIconID=-1) | CXTPCommandBars |
SetMenuTitleBarClass(CRuntimeClass *pMenuTitleBarClass) | CXTPCommandBars | static
SetPaintManager(CXTPPaintManager *pPaintManager) | CXTPCommandBars |
SetPopupBarClass(CRuntimeClass *pPopupBarClass) | CXTPCommandBars | static
SetPopupToolBarClass(CRuntimeClass *pPopupToolBarClass) | CXTPCommandBars | static
SetQuickCustomizeMode(BOOL bMode) | CXTPCommandBars |
SetShortcutManager(CXTPShortcutManager *pShortcutManager) | CXTPCommandBars |
SetSite(CWnd *pFrame) | CXTPCommandBars |
SetTheme(XTPPaintTheme paintTheme) | CXTPCommandBars |
SetToolBarClass(CRuntimeClass *pToolBarClass) | CXTPCommandBars | static
SetToolBarFocus(CXTPToolBar *pCommandBar, BOOL bNext=FALSE) | CXTPCommandBars |
ShowKeyboardCues(BOOL bShow) | CXTPCommandBars |
ShowKeyboardTips(CXTPCommandBar *pCommandBar, int nLevel=1) | CXTPCommandBars |
ToggleVisible(int nIndex) | CXTPCommandBars |
TrackPopupMenu(CMenu *pMenu, UINT nFlags, int xPos, int yPos, CWnd *pWnd, LPCRECT rcExclude=NULL, CWnd *pWndOwner=NULL, CXTPCommandBars *pCommandBars=NULL) | CXTPCommandBars | static
TrackPopupMenu(CXTPPopupBar *pPopupBar, UINT nFlags, int xPos, int yPos, CWnd *pWnd, LPCRECT rcExclude=NULL, CWnd *pWndOwner=NULL) | CXTPCommandBars | static
TrackPopupMenu(UINT nBarID, UINT nFlags, int xPos, int yPos, LPCRECT rcExclude=NULL) | CXTPCommandBars |
TrackPopupMenuEx(CMenu *pMenu, UINT nFlags, int xPos, int yPos, CWnd *pWndOwner=NULL, LPTPMPARAMS lptpm=NULL) | CXTPCommandBars |
UpdateCommandBars() const | CXTPCommandBars |
~CXTPCommandBars() | CXTPCommandBars | protectedvirtual


Toolkit Pro: Member List

XTP_EVENT_DRAG_OPERATION_PARAMS Member List

This is the complete list of members for XTP_EVENT_DRAG_OPERATION_PARAMS, including all inherited members.

eOperation | XTP_EVENT_EDIT_OPERATION_PARAMS
nRefCounter | XTP_EVENT_EDIT_OPERATION_PARAMS
pDraggingEvent | XTP_EVENT_DRAG_OPERATION_PARAMS
pDraggingEventNew | XTP_EVENT_DRAG_OPERATION_PARAMS
pDraggingEventOriginal | XTP_EVENT_DRAG_OPERATION_PARAMS
pEventViews | XTP_EVENT_EDIT_OPERATION_PARAMS


Toolkit Pro: XTPChart3dPieSeriesView.h Source File

  • Source
  • Chart
  • Styles
  • Pie
  • 3D
XTPChart3dPieSeriesView.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHART3DPIESERIESVIEW_H__)
24# define __XTPCHART3DPIESERIESVIEW_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
44class _XTP_EXT_CLASS CXTPChart3dPieSeriesView : public CXTPChartPieSeriesViewBase
45{
46public:
54 CXTPChart3dPieSeriesView(CXTPChartSeries* pSeries, CXTPChartDiagramView* pDiagramView);
55
56public:
64 virtual void CalculatePointLayout(CXTPChartDeviceContext* pDC, CRect rcBounds);
65
66protected:
78 virtual CXTPChartSeriesPointView* CreateSeriesPointView(CXTPChartDeviceContext* pDC,
79 CXTPChartSeriesPoint* pPoint,
80 CXTPChartElementView* pParentView);
81
94 virtual CXTPChartDeviceCommand* CreateDeviceCommand(CXTPChartDeviceContext* pDC);
95
106 virtual CXTPChartDeviceCommand* CreateLegendDeviceCommand(CXTPChartDeviceContext* pDC,
107 CRect rcBounds);
108};
110# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
111#endif //#if !defined(__XTPCHART3DPIESERIESVIEW_H__)
pPoint
const CPoint * pPoint
return 0 or xtpCalendarHitTestDayExpandButton
Definition XTPCalendarThemeOffice2007.h:150
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChart3dPieSeriesView
This class abstracts the view of a pie series.
Definition XTPChart3dPieSeriesView.h:45
CXTPChart3dPieSeriesView::CalculatePointLayout
virtual void CalculatePointLayout(CXTPChartDeviceContext *pDC, CRect rcBounds)
Call this function to calculate the pie series point layout.
CXTPChart3dPieSeriesView::CreateDeviceCommand
virtual CXTPChartDeviceCommand * CreateDeviceCommand(CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
CXTPChart3dPieSeriesView::CreateLegendDeviceCommand
virtual CXTPChartDeviceCommand * CreateLegendDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcBounds)
Creates legend drawing device command.
CXTPChart3dPieSeriesView::CreateSeriesPointView
virtual CXTPChartSeriesPointView * CreateSeriesPointView(CXTPChartDeviceContext *pDC, CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Use this function to create the pie series point view object.
CXTPChart3dPieSeriesView::CXTPChart3dPieSeriesView
CXTPChart3dPieSeriesView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Constructs a CXTPChart3dPieSeriesView object.
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartDiagramView
This class represents the view of a chart diagram, which is a kind of CXTPChartElementView.
Definition XTPChartDiagramView.h:49
CXTPChartElementView
This class represents the view of a chart element.
Definition XTPChartElementView.h:47
CXTPChartPieSeriesViewBase
This class abstracts the view of a pie series.
Definition XTPChartPieSeriesViewBase.h:45
CXTPChartSeries
This class represents a series in the chart, which is a kind of CXTPChartElement.
Definition XTPChartSeries.h:50
CXTPChartSeriesPoint
CXTPChartSeriesPoint is a kind of CXTPChartElement.
Definition XTPChartSeriesPoint.h:43
CXTPChartSeriesPointView
Represents chart series point view.
Definition XTPChartSeriesPointView.h:48


Toolkit Pro: Member List

CXTPScrollBarThemeUltraFlat Member List

This is the complete list of members for CXTPScrollBarThemeUltraFlat, including all inherited members.

CalcHScroll(CXTPScrollBase *pScroll, XTPScrollMetricsH *pHScroll) | CXTPScrollBarPaintManager | protectedstatic
CalcVScroll(CXTPScrollBase *pScroll, XTPScrollMetricsV *pVScroll) | CXTPScrollBarPaintManager | protectedstatic
CXTPScrollBarPaintManager() | CXTPScrollBarPaintManager |
CXTPScrollBarThemeWindowsUx() | CXTPScrollBarThemeWindowsUx |
DrawArrowGlyph(CDC *pDC, CRect rcArrow, XTPArrowGlyph glyph, BOOL bEnabled, COLORREF clrText=COLORREF_NULL) | CXTPScrollBarPaintManager | protected
DrawArrows(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics) | CXTPScrollBarThemeFlat | protectedvirtual
DrawArrows(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics) | CXTPScrollBarThemeFlat | protectedvirtual
DrawBackground(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics) | CXTPScrollBarPaintManager | protectedvirtual
DrawBackground(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics) | CXTPScrollBarPaintManager | protectedvirtual
DrawButtons(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics) | CXTPScrollBarThemeFlat | protectedvirtual
DrawButtons(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics) | CXTPScrollBarThemeFlat | protectedvirtual
DrawGripper(CDC *pDC, CXTPScrollBase *pScroll) | CXTPScrollBarThemeFlat | protectedvirtual
DrawScrollBar(CDC *pDC, CXTPScrollBase *pScrollBar) | CXTPScrollBarPaintManager | virtual
DrawThumbButton(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics) | CXTPScrollBarThemeFlat | protectedvirtual
DrawThumbButton(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics) | CXTPScrollBarThemeFlat | protectedvirtual
DrawTracker(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics) | CXTPScrollBarThemeFlat | protectedvirtual
DrawTracker(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics) | CXTPScrollBarThemeFlat | protectedvirtual
m_crBack | CXTPScrollBarPaintManager |
m_crBackHilite | CXTPScrollBarPaintManager |
m_crBackPushed | CXTPScrollBarPaintManager |
m_crBorder | CXTPScrollBarPaintManager |
m_crBorderHilite | CXTPScrollBarPaintManager |
m_cThumb | CXTPScrollBarPaintManager |
m_cxHScroll | CXTPScrollBarPaintManager |
m_cxVScroll | CXTPScrollBarPaintManager |
m_cyHScroll | CXTPScrollBarPaintManager |
m_cyVScroll | CXTPScrollBarPaintManager |
RefreshMetrics() | CXTPScrollBarThemeUltraFlat | protectedvirtual
~CXTPScrollBarThemeWindowsUx() | CXTPScrollBarThemeWindowsUx | virtual


Toolkit Pro: XTPCalendarCaptionBarOffice2003Theme.h Source File

  • Source
  • Calendar
  • CaptionBar
  • Themes
XTPCalendarCaptionBarOffice2003Theme.h
Go to the documentation of this file.
1
22#if !defined(__XTPCALENDARCAPTIONBAROFFICE2003THEME_H__)
23# define __XTPCALENDARCAPTIONBAROFFICE2003THEME_H__
24
25# if _MSC_VER > 1000
26# pragma once
27# endif // _MSC_VER > 1000
28
29# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
30
36class _XTP_EXT_CLASS CXTPCalendarCaptionBarOffice2003Theme
37 : public CXTPCalendarCaptionBarOfficeXPTheme
38{
39public:
48 CXTPCalendarCaptionBarOffice2003Theme(CXTPCalendarCaptionBarTheme* pTheme = NULL);
49
56 virtual ~CXTPCalendarCaptionBarOffice2003Theme();
57
58 virtual void PartDraw(CXTPSwitchViewButtonPart* pBarPart, CDC* pDC);
59 virtual void PartDraw(CXTPScrollDateButtonPart* pBarPart, CDC* pDC);
60 virtual void PartDraw(CXTPRadioButtonPart* pBarPart, CDC* pDC);
61 virtual void PartDraw(CXTPCheckboxButtonPart* pBarPart, CDC* pDC);
62 virtual void PartDraw(CXTPExpandButtonPart* pBarPart, CDC* pDC);
63};
64
65# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
66#endif // !defined(__XTPCALENDARCAPTIONBAROFFICE2003THEME_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCalendarCaptionBarOffice2003Theme
CXTPCalendarCaptionBarOffice2003Theme is a CXTPCalendarCaptionBarOfficeXPTheme derived class that rep...
Definition XTPCalendarCaptionBarOffice2003Theme.h:38
CXTPCalendarCaptionBarOffice2003Theme::~CXTPCalendarCaptionBarOffice2003Theme
virtual ~CXTPCalendarCaptionBarOffice2003Theme()
Default paint manager destructor.
CXTPCalendarCaptionBarOffice2003Theme::CXTPCalendarCaptionBarOffice2003Theme
CXTPCalendarCaptionBarOffice2003Theme(CXTPCalendarCaptionBarTheme *pTheme=NULL)
Default paint manager constructor.
CXTPCalendarCaptionBarOfficeXPTheme
CXTPCalendarCaptionBarOfficeXPTheme is a CXTPCalendarCaptionBarOffice2000Theme derived class that rep...
Definition XTPCalendarCaptionBarOfficeXPTheme.h:38
CXTPCalendarCaptionBarTheme
This class CalendarCaptionBar control drawing, user interaction logic and interaction logic with atta...
Definition XTPCalendarCaptionBarTheme.h:48
CXTPCheckboxButtonPart
This class implements Checkbox button part of the SwitchViewBar.
Definition XTPCalendarCaptionBarThemePart.h:367
CXTPExpandButtonPart
This class implements Expand button part of the ScrollDateBar.
Definition XTPCalendarCaptionBarThemePart.h:429
CXTPRadioButtonPart
This class implements Radio button part of the SwitchViewBar.
Definition XTPCalendarCaptionBarThemePart.h:350
CXTPScrollDateButtonPart
This class implements Scroll Date button part of the ScrollDateBar.
Definition XTPCalendarCaptionBarThemePart.h:383
CXTPSwitchViewButtonPart
This class implements SwitchView button part of the SwitchViewBar.
Definition XTPCalendarCaptionBarThemePart.h:333


Toolkit Pro: XTPMarkupSetter.h Source File

  • Source
  • Markup
XTPMarkupSetter.h
Go to the documentation of this file.
1
23#if !defined(__XTPMARKUPSETTER_H__)
24# define __XTPMARKUPSETTER_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPMarkupObject;
34class CXTPMarkupDependencyProperty;
35
36class _XTP_EXT_CLASS CXTPMarkupSetter : public CXTPMarkupObject
37{
38 DECLARE_MARKUPCLASS(CXTPMarkupSetter);
39
40public:
41 CXTPMarkupSetter();
42 CXTPMarkupSetter(CXTPMarkupDependencyProperty* pProperty, CXTPMarkupObject* pValue);
43
44public:
45 CXTPMarkupDependencyProperty* GetSetterProperty() const;
46 CXTPMarkupObject* GetSetterValue() const;
47
48public:
49 static CXTPMarkupDependencyProperty* m_pPropertyProperty;
50 static CXTPMarkupDependencyProperty* m_pValueProperty;
51};
52
53# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
55#endif // !defined(__XTPMARKUPSETTER_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h


Toolkit Pro: Member List

CXTPTaskPanel Member List

This is the complete list of members for CXTPTaskPanel, including all inherited members.

AddGroup(UINT nID, int nImage=-1) | CXTPTaskPanel |
AllowDrag(long nAllowDrag=xtpTaskItemAllowDragDefault) | CXTPTaskPanel |
AllowDrop(BOOL bAllowDrop) | CXTPTaskPanel |
AnimateGroups(BOOL bCheckDirty=TRUE) | CXTPTaskPanel |
CheckScrollButtonMouseOver(CPoint point) | CXTPTaskPanel | protected
Create(DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID) | CXTPTaskPanel |
CreateScrollBarCtrl(DWORD dwStyle, UINT nID) | CXTPScrollBarContainer< CWnd > | inline
CXTPScrollBarContainer() | CXTPScrollBarContainer< CWnd > | inlineprotected
CXTPTaskPanel() | CXTPTaskPanel |
DrawFocusRect(BOOL bAccept) | CXTPTaskPanel |
EnableAnimation(BOOL bEnable=TRUE) | CXTPTaskPanel |
EnableMarkup(BOOL bEnable=TRUE) | CXTPTaskPanel |
EnableScrollBar(int nSBFlags, UINT nArrowFlags=ESB_ENABLE_BOTH) | CXTPScrollBarContainer< CWnd > | inline
EnsureVisible(CXTPTaskPanelItem *pItem) | CXTPTaskPanel |
ExpandGroup(CXTPTaskPanelGroup *pGroup, BOOL bExpanded) | CXTPTaskPanel | virtual
FindGroup(UINT nID) const | CXTPTaskPanel |
FindItem(UINT nID) const | CXTPTaskPanel |
GetActiveGroup() const | CXTPTaskPanel |
GetAnimation() const | CXTPTaskPanel |
GetAt(int nIndex) const | CXTPTaskPanel |
GetBehaviour() const | CXTPTaskPanel |
GetClientHeight() const | CXTPTaskPanel |
GetClipboardFormat() | CXTPTaskPanel | static
GetColumnWidth() const | CXTPTaskPanel |
GetCurrentTheme() const | CXTPTaskPanel |
GetFocusedItem() const | CXTPTaskPanel |
GetGroupCount() const | CXTPTaskPanel |
GetGroupIconSize() const | CXTPTaskPanel |
GetGroups() const | CXTPTaskPanel |
GetHotItem() const | CXTPTaskPanel |
GetHotTrackStyle() const | CXTPTaskPanel |
GetImageManager() const | CXTPTaskPanel |
GetItemIconSize() const | CXTPTaskPanel |
GetItemLayout() const | CXTPTaskPanel |
GetMargins() const | CXTPTaskPanel |
GetMarkupContext() const | CXTPTaskPanel |
GetMinimumGroupClientHeight() const | CXTPTaskPanel |
GetNextItem(CXTPTaskPanelItem *pItem, int nDirection, BOOL bTab, BOOL bSkipRowItems=TRUE) const | CXTPTaskPanel |
GetNextVisibleGroup(int nIndex, int nDirection=+1) const | CXTPTaskPanel | protected
GetPaintManager() const | CXTPTaskPanel |
GetScrollBarCtrl(int nBar) const | CXTPScrollBarContainer< CWnd > | inlinevirtual
GetScrollButton(BOOL bScrollUp) const | CXTPTaskPanel |
GetScrollOffset() const | CXTPTaskPanel |
GetToolTipContext() const | CXTPTaskPanel |
HitTestGroup(CPoint pt, BOOL *pbCaption=NULL) const | CXTPTaskPanel |
HitTestItem(CPoint pt, BOOL bClientAvail=FALSE) const | CXTPTaskPanel |
HitTestScrollButton(CPoint point) const | CXTPTaskPanel |
IsDirty() const | CXTPTaskPanel |
IsDrawFocusRect() const | CXTPTaskPanel |
IsExpandable() const | CXTPTaskPanel |
IsExplorerBehaviour() const | CXTPTaskPanel | protected
IsGroupExpanded(const CXTPTaskPanelGroup *pGroup) const | CXTPTaskPanel |
IsMultiColumn() const | CXTPTaskPanel |
IsSingleSelection() const | CXTPTaskPanel |
m_bAcceptFocus | CXTPTaskPanel | protected
m_bAllowDrop | CXTPTaskPanel | protected
m_bAnimation | CXTPTaskPanel | protected
m_bDrawFocusRect | CXTPTaskPanel | protected
m_bExpandable | CXTPTaskPanel | protected
m_bGrabbingFocus | CXTPTaskPanel | protected
m_bInUpdateScrollBar | CXTPTaskPanel | protected
m_bMultiColumn | CXTPTaskPanel | protected
m_bPreSubclassWindow | CXTPTaskPanel | protected
m_bScrollVisible | CXTPTaskPanel | protected
m_bSelectItemOnFocus | CXTPTaskPanel | protected
m_bSingleSelection | CXTPTaskPanel | protected
m_bTabItems | CXTPTaskPanel | protected
m_bTimerGroupHover | CXTPTaskPanel | protected
m_cfItem | CXTPTaskPanel | protectedstatic
m_eAnimation | CXTPTaskPanel | protected
m_hHandCursor | CXTPTaskPanel | protected
m_hotTrackStyle | CXTPTaskPanel | protected
m_itemLayout | CXTPTaskPanel | protected
m_nAllowDrag | CXTPTaskPanel | protected
m_nAnimateTimer | CXTPTaskPanel | protected
m_nAnimationStep | CXTPTaskPanel | protected
m_nClientHeight | CXTPTaskPanel | protected
m_nColumnWidth | CXTPTaskPanel | protected
m_nGroupMinClientHeight | CXTPTaskPanel | protected
m_nGroupSpacing | CXTPTaskPanel | protected
m_nLockRedraw | CXTPTaskPanel | protected
m_nOldClientHeight | CXTPTaskPanel | protected
m_nOLEDropMode | CXTPTaskPanel | protected
m_pActiveGroup | CXTPTaskPanel | protected
m_paintTheme | CXTPTaskPanel | protected
m_panelBehaviour | CXTPTaskPanel | protected
m_pAnimation | CXTPTaskPanel | protected
m_pDropTarget | CXTPTaskPanel | protected
m_pGroups | CXTPTaskPanel | protected
m_pImageManager | CXTPTaskPanel | protected
m_pItemDragging | CXTPTaskPanel | protected
m_pItemDragOver | CXTPTaskPanel | protected
m_pItemFocused | CXTPTaskPanel | protected
m_pItemHot | CXTPTaskPanel | protected
m_pItemPressed | CXTPTaskPanel | protected
m_pMarkupContext | CXTPTaskPanel | protected
m_pPaintManager | CXTPTaskPanel | protected
m_pScrollButton | CXTPTaskPanel | protected
m_pToolTipContext | CXTPTaskPanel | protected
m_ptPressed | CXTPTaskPanel | protected
m_rcMargins | CXTPTaskPanel | protected
m_szGroupIcon | CXTPTaskPanel | protected
m_szItemIcon | CXTPTaskPanel | protected
NavigateItems(BOOL bTabItems) | CXTPTaskPanel |
NotifyOwner(WPARAM wParam, LPARAM lParam) | CXTPTaskPanel | virtual
OnClick(CXTPTaskPanelGroupItem *pItem) | CXTPTaskPanel | virtual
OnClickScrollButton(CXTPTaskPanelScrollButton *pScrollButton) | CXTPTaskPanel | protected
OnClientHeightChanged() | CXTPTaskPanel | protectedvirtual
OnDragOver(COleDataObject *pDataObject, DWORD dwKeyState, CPoint point) | CXTPTaskPanel | protectedvirtual
OnDraw(CDC *pDC, CRect rcClipBox) | CXTPTaskPanel | virtual
OnDrop(COleDataObject *pDataObject, DROPEFFECT dropEffect, CPoint point) | CXTPTaskPanel | protectedvirtual
OnEndLabelEdit(CXTPTaskPanelItem *pItem, LPCTSTR str) | CXTPTaskPanel | protectedvirtual
OnItemRemoved(CXTPTaskPanelItem *pItem) | CXTPTaskPanel | protectedvirtual
OnScrollChanged(int nCurPos) | CXTPTaskPanel |
OnStartGroupDrag(CXTPTaskPanelItem *pItem) | CXTPTaskPanel | protectedvirtual
OnStartItemDrag(CXTPTaskPanelGroupItem *pItem) | CXTPTaskPanel | protectedvirtual
OptimizeChildrenClipping() | CXTPScrollBarContainer< CWnd > | inline
Redraw(LPCRECT lpRect=NULL, BOOL bAnimate=FALSE) | CXTPTaskPanel |
RefreshScrollBarMetrics() | CXTPScrollBarContainer< CWnd > | inline
RegisterWindowClass(HINSTANCE hInstance=NULL) | CXTPTaskPanel |
RenameItem(CXTPTaskPanelItem *pItem) | CXTPTaskPanel |
Reposition(BOOL bRecalcOnly=TRUE) | CXTPTaskPanel |
RepositionScrollButtons() | CXTPTaskPanel | protected
SetAnimation(XTPTaskPanelAnimation panelAnimation) | CXTPTaskPanel |
SetBehaviour(XTPTaskPanelBehaviour panelBehaviour) | CXTPTaskPanel |
SetColumnWidth(int nColumnWidth) | CXTPTaskPanel |
SetCustomTheme(CXTPTaskPanelPaintManager *pPaintManager) | CXTPTaskPanel |
SetExpandable(BOOL bExpandable) | CXTPTaskPanel |
SetFocusedItem(CXTPTaskPanelItem *pItem, BOOL bDrawFocusRect=FALSE, BOOL bSetFocus=TRUE) | CXTPTaskPanel | virtual
SetGroupIconSize(CSize szIcon) | CXTPTaskPanel |
SetGroupImageList(CImageList *pImageList, CSize szGroupIcon=CSize(32, 32)) | CXTPTaskPanel |
SetHotItem(CXTPTaskPanelItem *pItem) | CXTPTaskPanel |
SetHotTrackStyle(XTPTaskPanelHotTrackStyle hotTrackStyle) | CXTPTaskPanel |
SetIconSize(CSize szIcon) | CXTPTaskPanel |
SetImageList(CImageList *pImageList, CSize szItemIcon=CSize(16, 16)) | CXTPTaskPanel |
SetImageManager(CXTPImageManager *pImageManager) | CXTPTaskPanel |
SetItemLayout(XTPTaskPanelItemLayout itemLayout) | CXTPTaskPanel |
SetLayoutRTL(BOOL bRightToLeft) | CXTPTaskPanel |
SetLockRedraw(BOOL bLockRedraw) | CXTPTaskPanel |
SetMargins(long nLeft, long nTop, long nRight, long nBottom, long nMiddle) | CXTPTaskPanel |
SetMinimumGroupClientHeight(int nMinClientHeight) | CXTPTaskPanel |
SetMultiColumn(BOOL bMultiColumn) | CXTPTaskPanel |
SetScrollBarClass(CRuntimeClass *pClass=NULL) | CXTPScrollBarContainer< CWnd > | inline
SetScrollBarTheme(XTPScrollBarTheme theme) | CXTPScrollBarContainer< CWnd > | inline
SetSelectItemOnFocus(BOOL bSelect) | CXTPTaskPanel |
SetSingleSelection(BOOL bSingleSelection=TRUE) | CXTPTaskPanel |
SetTheme(XTPTaskPanelPaintTheme paintTheme) | CXTPTaskPanel |
ShowScrollBar(UINT nBar, BOOL bShow=TRUE) | CXTPScrollBarContainer< CWnd > | inline
UpdateScrollBar() | CXTPTaskPanel | protectedvirtual
UpdateScrollButtons() | CXTPTaskPanel | protected
~CXTPTaskPanel() | CXTPTaskPanel | virtual


Toolkit Pro: XTPScrollBarThemeOffice2000.h Source File

  • Source
  • Common
  • ScrollBar
  • Themes
XTPScrollBarThemeOffice2000.h
Go to the documentation of this file.
1
23#if !defined(__XTPSCROLLBARTHEMEOFFICE2000_H__)
24# define __XTPSCROLLBARTHEMEOFFICE2000_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPScrollBarThemeOffice2000 : public CXTPScrollBarThemeWindowsUx
39{
40protected:
48 virtual void DrawButtons(CDC* pDC, CXTPScrollBase* pScroll, XTPScrollMetricsV* pMetrics);
49
57 virtual void DrawArrows(CDC* pDC, CXTPScrollBase* pScroll, XTPScrollMetricsV* pMetrics);
58
66 virtual void DrawButtons(CDC* pDC, CXTPScrollBase* pScroll, XTPScrollMetricsH* pMetrics);
67
75 virtual void DrawArrows(CDC* pDC, CXTPScrollBase* pScroll, XTPScrollMetricsH* pMetrics);
76};
77
78# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
80#endif /*__XTPSCROLLBARTHEMEOFFICE2000_H__*/
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPScrollBarThemeOffice2000
Scrollbar paint manager used to draw Office 200 like scrollbars.
Definition XTPScrollBarThemeOffice2000.h:39
CXTPScrollBarThemeOffice2000::DrawButtons
virtual void DrawButtons(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar buttons only.
CXTPScrollBarThemeOffice2000::DrawArrows
virtual void DrawArrows(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar button arrows only.
CXTPScrollBarThemeOffice2000::DrawButtons
virtual void DrawButtons(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws vertical scrollbar buttons only.
CXTPScrollBarThemeOffice2000::DrawArrows
virtual void DrawArrows(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws vertical scrollbar button arrows only.
CXTPScrollBarThemeWindowsUx
Scrollbar paint manager used to draw scrollbars that use current Windows theme.
Definition XTPScrollBarThemeWindowsUx.h:39
CXTPScrollBase
CXTPScrollBase is the base class for all scrollable objects.
Definition XTPScrollBase.h:222


Toolkit Pro: XTPChartDiagram2DSeriesView.h Source File

  • Source
  • Chart
  • Diagram
  • Diagram2D
XTPChartDiagram2DSeriesView.h
Go to the documentation of this file.
1// XTPChartDiagram2DSeriesView.h
24#if !defined(__XTPCHARTDIAGRAM2DSERIESVIEW_H__)
25# define __XTPCHARTDIAGRAM2DSERIESVIEW_H__
28# if _MSC_VER >= 1000
29# pragma once
30# endif // _MSC_VER >= 1000
31
32# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
33
34class CXTPChartAxis;
35class CXTPChartDiagram2DPane;
36class CXTPChartDiagram2DPaneView;
37class CXTPChartDiagram2DAppearance;
38class CXTPChartAxisView;
39class CXTPChartDiagram2DAxisView;
40
41class _XTP_EXT_CLASS CXTPChartDiagram2DSeriesView : public CXTPChartSeriesView
42{
43protected:
44 CXTPChartDiagram2DSeriesView(CXTPChartSeries* pSeries, CXTPChartDiagramView* pDiagramView,
45 BOOL bSortPoints = FALSE);
46
47public:
48 CXTPChartDiagram2DAxisView* GetAxisViewX() const;
49 CXTPChartDiagram2DAxisView* GetAxisViewY() const;
50
51 CXTPChartPointF GetScreenPoint(double x, double y) const;
52
53 virtual void AfterUpdateRange(CXTPChartDeviceContext* pDC);
54 virtual void BeforeUpdateRange(CXTPChartDeviceContext* pDC);
55
56protected:
57 static int AFX_CDECL ComparePoints(const CXTPChartSeriesPointView** ppPoint1,
58 const CXTPChartSeriesPointView** ppPoint2);
59
60protected:
61 CXTPChartDiagram2DAxisView* m_pAxisViewX;
62 CXTPChartDiagram2DAxisView* m_pAxisViewY;
63
64 BOOL m_bSortPoints;
65
66 friend class CXTPChartDiagram2DView;
67 friend class CXTPChartDiagram2DPaneView;
68};
69
70AFX_INLINE CXTPChartDiagram2DAxisView* CXTPChartDiagram2DSeriesView::GetAxisViewX() const
71{
72 return m_pAxisViewX;
73}
74
75AFX_INLINE CXTPChartDiagram2DAxisView* CXTPChartDiagram2DSeriesView::GetAxisViewY() const
76{
77 return m_pAxisViewY;
78}
80# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
81#endif //#if !defined(__XTPCHARTDIAGRAM2DSERIESVIEW_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartAxis
This abstract base class represents a chart axis as a kind of chart element.
Definition XTPChartAxis.h:86
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartDiagram2DAppearance
This class represents the appearance of diagram in 2D.
Definition XTPChartAppearance.h:292
CXTPChartDiagram2DAxisView
This class abstracts the view of a chart axis and its child items in a bounding rectangle context.
Definition XTPChartAxisView.h:128
CXTPChartDiagram2DView
This class represents the view of a chart 2D diagram, which is a kind of CXTPChartDiagramView.
Definition XTPChartDiagram2DView.h:45
CXTPChartDiagramView
This class represents the view of a chart diagram, which is a kind of CXTPChartElementView.
Definition XTPChartDiagramView.h:49
CXTPChartSeries
This class represents a series in the chart, which is a kind of CXTPChartElement.
Definition XTPChartSeries.h:50
CXTPChartSeriesPointView
Represents chart series point view.
Definition XTPChartSeriesPointView.h:48
CXTPPoint2T< float >


Toolkit Pro: Member List

CXTPChartBubbleSeriesView Member List

This is the complete list of members for CXTPChartBubbleSeriesView, including all inherited members.

AddChildView(CXTPChartElementView *pChildView) | CXTPChartElementView |
CreateDeviceCommand(CXTPChartDeviceContext *pDC) | CXTPChartBubbleSeriesView | protectedvirtual
CreateLegendDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcBounds) | CXTPChartPointSeriesView | virtual
CreatePointsView(CXTPChartDeviceContext *pDC) | CXTPChartBubbleSeriesView | protected
CreateSeriesPointView(CXTPChartDeviceContext *pDC, CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView) | CXTPChartBubbleSeriesView | protected
CXTPChartBubbleSeriesView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView) | CXTPChartBubbleSeriesView |
CXTPChartElementView(CXTPChartElementView *pParentView) | CXTPChartElementView |
CXTPChartElementView(CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartElementView |
CXTPChartElementView(CXTPChartContainer *pContainer) | CXTPChartElementView |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartPointSeriesView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView) | CXTPChartPointSeriesView |
GetAt(int nIndex) const | CXTPChartElementView |
GetBounds() const | CXTPChartElementView |
GetBounds(BOOL bIncludingChildren) const | CXTPChartElementView |
GetChildren() | CXTPChartElementView |
GetCount() const | CXTPChartElementView |
GetParentView() const | CXTPChartElementView |
Is3D() const | CXTPChartObject |
m_arrChildren | CXTPChartElementView | protected
m_pContainer | CXTPChartElementView | protected
m_pParentView | CXTPChartElementView | protected
m_rcBounds | CXTPChartElementView | protected
~CXTPChartElementView() | CXTPChartElementView | protectedvirtual
~CXTPChartLegendItemView() | CXTPChartLegendItemView | inlinevirtual


Toolkit Pro: XTPDockingPaneTabColorSet2019.h Source File

  • Source
  • DockingPane
  • TabColorSets
XTPDockingPaneTabColorSet2019.h
Go to the documentation of this file.
1
23#if !defined(__XTPDOCKINGPANETABCOLORSET2019_H__)
24# define __XTPDOCKINGPANETABCOLORSET2019_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPDockingPaneTabColorSet2019 : public CXTPDockingPaneTabColorSet2012
39{
40public:
45 CXTPDockingPaneTabColorSet2019();
46
61 virtual void FillHeader(CDC* pDC, CRect rc, CXTPTabManager* pTabManager);
62};
63
64# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
66#endif // !defined(__XTPDOCKINGPANETABCOLORSET2019_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPDockingPaneTabColorSet2012
Helper class used to initialize default colors for a theme from an .INI resource and handle drawing r...
Definition XTPDockingPaneTabColorSet2012.h:39
CXTPDockingPaneTabColorSet2019
Helper class used to initialize default colors for a theme from an .INI resource and handle drawing r...
Definition XTPDockingPaneTabColorSet2019.h:39
CXTPDockingPaneTabColorSet2019::FillHeader
virtual void FillHeader(CDC *pDC, CRect rc, CXTPTabManager *pTabManager)
This member is called to fill the header of the TabClient of the tab manager.
CXTPDockingPaneTabColorSet2019::CXTPDockingPaneTabColorSet2019
CXTPDockingPaneTabColorSet2019()
Default class constructor.
CXTPTabManager
CXTPTabManager is the base class for docking pane tabs, tab control tabs, and MDI client tabs.
Definition XTPTabManager.h:87


Toolkit Pro: Member List

CXTPMarqueeCtrlThemeVisualStudio2017 Member List

This is the complete list of members for CXTPMarqueeCtrlThemeVisualStudio2017, including all inherited members.

CXTPMarqueeCtrlPaintManager() | CXTPMarqueeCtrlPaintManager |
CXTPMarqueeCtrlThemeOffice2000() | CXTPMarqueeCtrlThemeOffice2000 |
CXTPMarqueeCtrlThemeOffice2013() | CXTPMarqueeCtrlThemeOffice2013 |
CXTPMarqueeCtrlThemeVisualStudio2017() | CXTPMarqueeCtrlThemeVisualStudio2017 |
DeflateRect(CDC *pDC, CRect &rcClient) | CXTPMarqueeCtrlPaintManager | protectedvirtual
DrawBackground(CXTPMarqueeCtrl *pWndCtrl, CDC *pDC, CRect &rcClient) | CXTPMarqueeCtrlPaintManager | virtual
DrawChunk(CXTPMarqueeCtrl *pWndCtrl, CDC *pDC, CXTPCompatibleDC &dcChunk, int i, int &x, int &y, int cx, int cy) | CXTPMarqueeCtrlPaintManager | protectedvirtual
DrawMarquee(CXTPMarqueeCtrl *pWndCtrl, CDC *pDC, CRect &rcClient) | CXTPMarqueeCtrlPaintManager | virtual
GetBackColor() | CXTPMarqueeCtrlPaintManager |
GetBarColor() | CXTPMarqueeCtrlPaintManager |
GetBorderColor() | CXTPMarqueeCtrlPaintManager |
m_bUseWinTheme | CXTPMarqueeCtrlPaintManager | protected
m_clr3DHilite | CXTPMarqueeCtrlPaintManager | protected
m_clr3DShadow | CXTPMarqueeCtrlPaintManager | protected
m_clrBack | CXTPMarqueeCtrlPaintManager | protected
m_clrBar | CXTPMarqueeCtrlPaintManager | protected
m_nTheme | CXTPMarqueeCtrlPaintManager | protected
m_winTheme | CXTPMarqueeCtrlPaintManager | protected
RefreshMetrics() | CXTPMarqueeCtrlThemeOffice2013 | virtual
SetBackColor(COLORREF clrNew) | CXTPMarqueeCtrlPaintManager |
SetBarColor(COLORREF clrNew) | CXTPMarqueeCtrlPaintManager |
SetBorderColor(COLORREF clrNew) | CXTPMarqueeCtrlPaintManager |
UseWinThemes(BOOL bUseWinThemes=TRUE) | CXTPMarqueeCtrlPaintManager |
UsingWinThemes(BOOL bCheckReady=FALSE) | CXTPMarqueeCtrlPaintManager |
~CXTPMarqueeCtrlPaintManager() | CXTPMarqueeCtrlPaintManager | virtual


Toolkit Pro: XTPChart2dPyramidDiagramView.h Source File

  • Source
  • Chart
  • Styles
  • Pyramid
  • 2D
XTPChart2dPyramidDiagramView.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHART2DPYRAMIDDIAGRAMVIEW_H__)
24# define __XTPCHART2DPYRAMIDDIAGRAMVIEW_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartDiagram;
34class CXTPChartElementView;
35
47class _XTP_EXT_CLASS CXTPChartPyramidDiagramView : public CXTPChartDiagramView
48{
49 DECLARE_DYNAMIC(CXTPChartPyramidDiagramView);
50
51public:
59 CXTPChartPyramidDiagramView(CXTPChartDiagram* pDiagram, CXTPChartElementView* pParent);
60};
62# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
63#endif //#if !defined(__XTPCHART2DPYRAMIDDIAGRAMVIEW_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartDiagram
This class represents a chart diagram, which is a kind of CXTPChartElement.
Definition XTPChartDiagram.h:48
CXTPChartDiagramView
This class represents the view of a chart diagram, which is a kind of CXTPChartElementView.
Definition XTPChartDiagramView.h:49
CXTPChartElementView
This class represents the view of a chart element.
Definition XTPChartElementView.h:47
CXTPChartPyramidDiagramView
This class abstracts the view of a pyramid diagram.
Definition XTPChart2dPyramidDiagramView.h:48
CXTPChartPyramidDiagramView::CXTPChartPyramidDiagramView
CXTPChartPyramidDiagramView(CXTPChartDiagram *pDiagram, CXTPChartElementView *pParent)
Constructs a CXTPChartPyramidDiagramView object.


Toolkit Pro: XTPDockingPanePanelColorSetNativeWindows11.h Source File

  • Source
  • DockingPane
  • TabColorSets
XTPDockingPanePanelColorSetNativeWindows11.h
Go to the documentation of this file.
1
23#if !defined(__XTPDOCKINGPANEPANELCOLORSETNATIVEWINDOWS11_H__)
24# define __XTPDOCKINGPANEPANELCOLORSETNATIVEWINDOWS11_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPDockingPanePanelColorSetNativeWindows11
39 : public CXTPDockingPanePanelColorSet2012
40{
41public:
46 CXTPDockingPanePanelColorSetNativeWindows11();
47
53 virtual void RefreshMetrics();
54};
55
56# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
58#endif // !defined(__XTPDOCKINGPANEPANELCOLORSETNATIVEWINDOWS11_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPDockingPanePanelColorSet2012
Helper class used to initialize default colors for a theme from an .INI resource and handle drawing r...
Definition XTPDockingPanePanelColorSet2012.h:39
CXTPDockingPanePanelColorSetNativeWindows11
Helper class used to initialize default colors for a theme from an .INI resource and handle drawing r...
Definition XTPDockingPanePanelColorSetNativeWindows11.h:40
CXTPDockingPanePanelColorSetNativeWindows11::CXTPDockingPanePanelColorSetNativeWindows11
CXTPDockingPanePanelColorSetNativeWindows11()
Default class constructor.
CXTPDockingPanePanelColorSetNativeWindows11::RefreshMetrics
virtual void RefreshMetrics()
This member function is used to initialize default colors for a theme from an .INI resource.


Toolkit Pro: XTPDockingPaneMiniWnd.h Source File

  • Source
  • DockingPane
XTPDockingPaneMiniWnd.h
Go to the documentation of this file.
1
23#if !defined(__XTPDOCKINGPANEMINIWND_H__)
24# define __XTPDOCKINGPANEMINIWND_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
39class _XTP_EXT_CLASS CXTPDockingPaneMiniWnd
40 : public CMiniFrameWnd
41 , public CXTPDockingPaneBase
42{
43protected:
49 CXTPDockingPaneMiniWnd(CXTPDockingPaneLayout* pLayout);
50
55 ~CXTPDockingPaneMiniWnd();
56
57public:
64 BOOL IsActive() const;
65
72 virtual BOOL IsCaptionVertical() const;
73
78 void Expand();
79
86 CXTPDockingPaneSplitterContainer* GetTopPane() const;
87
93 BOOL IsCollapsed() const;
94
100 void Collapse(BOOL bDelay = FALSE);
101
109 CString GetTitle() const;
110
111protected:
121 virtual void Copy(CXTPDockingPaneBase* pClone, CXTPPaneToPaneMap* pMap, DWORD dwIgnoredOptions);
122
129 virtual void Init(CXTPDockingPaneBase* pPane, CRect rc);
130
131protected:
137 virtual void RemovePane(CXTPDockingPaneBase* pPane);
138
144 virtual void OnChildContainerChanged(CXTPDockingPaneBase* pContainer);
145
153 virtual BOOL DoPropExchange(CXTPPropExchange* pPX);
154
162 virtual BOOL Create(CRect rc);
163
170 virtual void OnCaptionButtonClick(CXTPDockingPaneCaptionButton* pButton);
171
179 virtual BOOL OnCaptionButtonDown(CXTPDockingPaneCaptionButton* pButton);
180
187 CXTPDockingPane* GetSelectedPane() const;
188
196 virtual BOOL IsCaptionButtonVisible(CXTPDockingPaneCaptionButton* pButton);
197
204 BOOL IsThemed() const;
205
210 void OnThemedChanged();
211
216 void RedrawPane();
217
225 virtual HWND GetPaneHwnd() const;
226
232 void GetMinMaxInfo(LPMINMAXINFO pMinMaxInfo) const;
233
234protected:
240 void DoSlideStep(BOOL bActivate = FALSE);
241
246 void OnPinButtonClick();
247
253 virtual void InvalidatePane(BOOL bSelectionChanged);
254
255protected:
262 virtual void UpdateWindowOpacity();
263
268 void OnFocusChanged();
269
280 virtual void FindPane(XTPDockingPaneType type, CXTPDockingPaneBaseList* pList) const;
281
289 BOOL OnAction(XTPDockingPaneAction action);
290
295 void CreateContainer();
296
298 DECLARE_MESSAGE_MAP()
299
300 //{{AFX_VIRTUAL(CXTPDockingPaneMiniWnd)
301public:
302 virtual void RecalcLayout(BOOL bNotify = TRUE);
303
304protected:
305 virtual void PostNcDestroy();
306 BOOL OnWndMsg(UINT message, WPARAM wParam, LPARAM lParam, LRESULT* pResult);
307 INT_PTR OnToolHitTest(CPoint point, TOOLINFO* pTI) const;
308 void DeletePane();
309 void OnFinalRelease();
310 //}}AFX_VIRTUAL
311
312 //{{AFX_MSG(CXTPDockingPaneMiniWnd)
313 afx_msg void OnClose();
314 afx_msg void OnNcLButtonDown(UINT nHitTest, CPoint point);
315 afx_msg void OnNcLButtonDblClk(UINT nHitTest, CPoint point);
316 afx_msg void OnDestroy();
317 afx_msg LRESULT OnNcHitTest(CPoint point);
318 afx_msg void OnNcPaint();
319 afx_msg void OnNcCalcSize(BOOL bCalcValidRects, NCCALCSIZE_PARAMS FAR* lpncsp);
320 afx_msg void OnNcMouseMove(UINT nHitTest, CPoint point);
321 afx_msg void OnTimer(UINT_PTR nIDEvent);
322 afx_msg void OnIdleUpdateCmdUI();
323 afx_msg void OnGetMinMaxInfo(MINMAXINFO* lpMMI);
324 afx_msg void OnSetFocus(CWnd* pOldWnd);
325 afx_msg void OnNcRButtonUp(UINT nHitTest, CPoint point);
326 afx_msg void OnContextMenu(CWnd* pWnd, CPoint pos);
327 afx_msg BOOL OnNcActivate(BOOL bActive);
328 afx_msg void OnSizing(UINT nSide, LPRECT lpRect);
329 //}}AFX_MSG
332# ifdef _XTP_ACTIVEX
334private:
335 DECLARE_DISPATCH_MAP()
336 DECLARE_INTERFACE_MAP()
337 XTP_DECLARE_CMDTARGETPROVIDER_INTERFACE()
338 DECLARE_OLETYPELIB_EX(CXTPDockingPaneMiniWnd);
339 DECLARE_ENUM_VARIANT(CXTPDockingPaneMiniWnd);
340
341 LPDISPATCH OleGetDispatch(BOOL /*bAddRef*/);
342 afx_msg LPDISPATCH OleGetItem(int nIndex);
343 afx_msg int OleGetItemCount();
344 afx_msg LPDISPATCH OleGetContainer();
345 afx_msg int OleGetType();
346 afx_msg LPDISPATCH OleGetPane(int nIndex);
347 afx_msg HWND OleGetHwnd();
348 afx_msg BOOL OleIsEmpty();
349 afx_msg int OleGetPosition();
351# endif
352
353private:
354 BOOL Create(LPCTSTR lpszClassName, LPCTSTR lpszWindowName, DWORD dwStyle, const RECT& rect,
355 CWnd* pParentWnd, UINT nID, CCreateContext* pContext = NULL);
356 BOOL Create(LPCTSTR lpszClassName, LPCTSTR lpszWindowName, DWORD dwStyle = WS_OVERLAPPEDWINDOW,
357 const RECT& rect = rectDefault, CWnd* pParentWnd = NULL,
358 LPCTSTR lpszMenuName = NULL, DWORD dwExStyle = 0, CCreateContext* pContext = NULL);
359 BOOL Create(LPCTSTR lpClassName, LPCTSTR lpWindowName, DWORD dwStyle, const RECT& rect,
360 CWnd* pParentWnd = NULL, UINT nID = 0);
361 void UpdatePosition();
362
363public:
364 static BOOL m_bShowPinButton;
366protected:
367 CXTPDockingPaneSplitterContainer* m_pTopContainer;
368 BOOL m_bCloseEnabled;
370 int m_nExpandedHeight;
372 int m_nStepsCount;
373 int m_nSlideStep;
374 int m_nDeactivationCount;
376 BOOL m_bCollapsed;
377 BOOL m_bExpanded;
378 BOOL m_bSlideOut;
380 BOOL m_bDelayInvalidate;
382 DECLARE_DYNAMIC(CXTPDockingPaneMiniWnd)
383
384 friend class CXTPDockingPaneManager;
385 friend class CXTPDockingPaneLayout;
386};
387
388AFX_INLINE CString CXTPDockingPaneMiniWnd::GetTitle() const
389{
390 CString strTitle;
391 GetWindowText(strTitle);
392 return strTitle;
393}
394
395AFX_INLINE CXTPDockingPaneSplitterContainer* CXTPDockingPaneMiniWnd::GetTopPane() const
396{
397 return m_pTopContainer;
398}
399
400AFX_INLINE BOOL CXTPDockingPaneMiniWnd::IsActive() const
401{
402 return m_bActive;
403}
404
405AFX_INLINE BOOL CXTPDockingPaneMiniWnd::IsCaptionVertical() const
406{
407 return FALSE;
408}
409
410AFX_INLINE BOOL CXTPDockingPaneMiniWnd::Create(LPCTSTR lpszClassName, LPCTSTR lpszWindowName,
411 DWORD dwStyle, const RECT& rect, CWnd* pParentWnd,
412 UINT nID, CCreateContext* pContext)
413{
414 return CWnd::Create(lpszClassName, lpszWindowName, dwStyle, rect, pParentWnd, nID, pContext);
415}
416
417AFX_INLINE BOOL CXTPDockingPaneMiniWnd::Create(LPCTSTR lpszClassName, LPCTSTR lpszWindowName,
418 DWORD dwStyle, const RECT& rect, CWnd* pParentWnd,
419 LPCTSTR lpszMenuName, DWORD dwExStyle,
420 CCreateContext* pContext)
421{
422 return CFrameWnd::Create(lpszClassName, lpszWindowName, dwStyle, rect, pParentWnd, lpszMenuName,
423 dwExStyle, pContext);
424}
425
426AFX_INLINE BOOL CXTPDockingPaneMiniWnd::Create(LPCTSTR lpClassName, LPCTSTR lpWindowName,
427 DWORD dwStyle, const RECT& rect, CWnd* pParentWnd,
428 UINT nID)
429{
430 return CMiniFrameWnd::Create(lpClassName, lpWindowName, dwStyle, rect, pParentWnd, nID);
431}
432
433AFX_INLINE BOOL CXTPDockingPaneMiniWnd::IsCollapsed() const
434{
435 return m_bCollapsed;
436}
437
438AFX_INLINE HWND CXTPDockingPaneMiniWnd::GetPaneHwnd() const
439{
440 return CWnd::GetSafeHwnd();
441}
443# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
444#endif // #if !defined(__XTPDOCKINGPANEMINIWND_H__)
XTPDisableNoisyWarnings.h
XTPDockingPaneType
XTPDockingPaneType
Docking pane type.
Definition XTPDockingPaneDefines.h:77
CXTPPaneToPaneMap
CMap< CXTPDockingPaneBase *, CXTPDockingPaneBase *, CXTPDockingPaneBase *, CXTPDockingPaneBase * > CXTPPaneToPaneMap
This map is used for mapping CXTPDockingPaneBase objects.
Definition XTPDockingPaneDefines.h:514
CXTPDockingPaneBaseList
CList< CXTPDockingPaneBase *, CXTPDockingPaneBase * > CXTPDockingPaneBaseList
This list is used for maintaining a CXTPDockingPaneBase collection.
Definition XTPDockingPaneDefines.h:482
XTPDockingPaneAction
XTPDockingPaneAction
Actions a docking pane is currently performing.
Definition XTPDockingPaneDefines.h:268
XTPEnableNoisyWarnings.h
XTP_DECLARE_CMDTARGETPROVIDER_INTERFACE
#define XTP_DECLARE_CMDTARGETPROVIDER_INTERFACE()
When deriving from CXTPCmdTarget is not possible this macro can be used in addition to standard DECLA...
Definition XTPFramework.h:89
CXTPDockingPaneBase
CXTPDockingPaneBase is a standalone class.
Definition XTPDockingPaneBase.h:69
CXTPDockingPaneBase::GetTitle
virtual CString GetTitle() const
Call this member to get the text in the caption for the tabbed container (group of panes).
Definition XTPDockingPaneBase.h:468
CXTPDockingPaneBase::GetPaneHwnd
virtual HWND GetPaneHwnd() const
Retrieves the window handle for a window.
Definition XTPDockingPaneBase.h:508
CXTPDockingPaneBase::IsActive
virtual BOOL IsActive() const
Determines if the frame is active.
Definition XTPDockingPaneBase.h:458
CXTPDockingPaneBase::IsCaptionVertical
virtual BOOL IsCaptionVertical() const
Determines if the caption is drawn vertically.
Definition XTPDockingPaneBase.h:463
CXTPDockingPaneCaptionButton
CXTPDockingPaneCaptionButton is a standalone internal class.
Definition XTPDockingPaneCaptionButton.h:38
CXTPDockingPane
CXTPDockingPane is a CXTPDockingPaneBase derived class.
Definition XTPDockingPane.h:44
CXTPDockingPaneLayout
CXTPDockingPaneLayout is a standalone class.
Definition XTPDockingPaneLayout.h:54
CXTPDockingPaneManager
CXTPDockingPaneManager is a CWnd derived class.
Definition XTPDockingPaneManager.h:58
CXTPDockingPaneMiniWnd
CXTPDockingPaneMiniWnd is a multiple inheritance class derived from CMiniFrameWnd and CXTPDockingPane...
Definition XTPDockingPaneMiniWnd.h:42
CXTPDockingPaneMiniWnd::GetTitle
CString GetTitle() const
Call this member to get the text in the caption for the tabbed container (group of panes).
Definition XTPDockingPaneMiniWnd.h:388
CXTPDockingPaneMiniWnd::RemovePane
virtual void RemovePane(CXTPDockingPaneBase *pPane)
Call this member to remove a pane from the collection.
CXTPDockingPaneMiniWnd::OnAction
BOOL OnAction(XTPDockingPaneAction action)
This method is called if some action occurs.
CXTPDockingPaneMiniWnd::OnChildContainerChanged
virtual void OnChildContainerChanged(CXTPDockingPaneBase *pContainer)
This member is called when a child pane collection is changed.
CXTPDockingPaneMiniWnd::m_nExpandedHeight
int m_nExpandedHeight
Expanded height of the frame.
Definition XTPDockingPaneMiniWnd.h:370
CXTPDockingPaneMiniWnd::OnFocusChanged
void OnFocusChanged()
This method is called when focus is changed inside the application.
CXTPDockingPaneMiniWnd::OnPinButtonClick
void OnPinButtonClick()
This member is called when the "pin" caption button is clicked.
CXTPDockingPaneMiniWnd::DoPropExchange
virtual BOOL DoPropExchange(CXTPPropExchange *pPX)
Call this member function to save/restore the settings of the pane.
CXTPDockingPaneMiniWnd::IsThemed
BOOL IsThemed() const
Call this member to determine if themed floating panes are used.
CXTPDockingPaneMiniWnd::Collapse
void Collapse(BOOL bDelay=FALSE)
This method is called to collapse the frame.
CXTPDockingPaneMiniWnd::GetMinMaxInfo
void GetMinMaxInfo(LPMINMAXINFO pMinMaxInfo) const
Call this member to get the min/max information for the pane window.
CXTPDockingPaneMiniWnd::InvalidatePane
virtual void InvalidatePane(BOOL bSelectionChanged)
This member is called when a pane must be redrawn.
CXTPDockingPaneMiniWnd::m_bExpanded
BOOL m_bExpanded
Pane is expanded.
Definition XTPDockingPaneMiniWnd.h:377
CXTPDockingPaneMiniWnd::FindPane
virtual void FindPane(XTPDockingPaneType type, CXTPDockingPaneBaseList *pList) const
Call this member to retrieve a collection of the panes with a specified type.
CXTPDockingPaneMiniWnd::CreateContainer
void CreateContainer()
Creates a docking container.
CXTPDockingPaneMiniWnd::m_bCloseEnabled
BOOL m_bCloseEnabled
Close button of frame is enabled.
Definition XTPDockingPaneMiniWnd.h:368
CXTPDockingPaneMiniWnd::m_bDelayInvalidate
BOOL m_bDelayInvalidate
TRUE to redraw the frame after a small delay.
Definition XTPDockingPaneMiniWnd.h:380
CXTPDockingPaneMiniWnd::GetTopPane
CXTPDockingPaneSplitterContainer * GetTopPane() const
Retrieves the top-level container of a floating frame.
Definition XTPDockingPaneMiniWnd.h:395
CXTPDockingPaneMiniWnd::CXTPDockingPaneMiniWnd
CXTPDockingPaneMiniWnd(CXTPDockingPaneLayout *pLayout)
Constructs a CXTPDockingPaneMiniWnd object.
CXTPDockingPaneMiniWnd::Expand
void Expand()
Call this method to expand a collapsed frame.
CXTPDockingPaneMiniWnd::m_nSlideStep
int m_nSlideStep
Current step of the animation process.
Definition XTPDockingPaneMiniWnd.h:373
CXTPDockingPaneMiniWnd::Create
virtual BOOL Create(CRect rc)
Creates a frame window.
CXTPDockingPaneMiniWnd::m_bShowPinButton
static BOOL m_bShowPinButton
TRUE to show pin button of the frame.
Definition XTPDockingPaneMiniWnd.h:364
CXTPDockingPaneMiniWnd::IsCollapsed
BOOL IsCollapsed() const
Determines if the frame is collapsed.
Definition XTPDockingPaneMiniWnd.h:433
CXTPDockingPaneMiniWnd::GetPaneHwnd
virtual HWND GetPaneHwnd() const
Retrieves the window handle for a window.
Definition XTPDockingPaneMiniWnd.h:438
CXTPDockingPaneMiniWnd::IsActive
BOOL IsActive() const
Determines if the frame is active.
Definition XTPDockingPaneMiniWnd.h:400
CXTPDockingPaneMiniWnd::OnThemedChanged
void OnThemedChanged()
This member is called when the theme is changed.
CXTPDockingPaneMiniWnd::m_nDeactivationCount
int m_nDeactivationCount
Deactivation counter.
Definition XTPDockingPaneMiniWnd.h:374
CXTPDockingPaneMiniWnd::IsCaptionVertical
virtual BOOL IsCaptionVertical() const
Determines if the caption is drawn vertically.
Definition XTPDockingPaneMiniWnd.h:405
CXTPDockingPaneMiniWnd::UpdateWindowOpacity
virtual void UpdateWindowOpacity()
This member is called to update the opacity of a floating frame.
CXTPDockingPaneMiniWnd::m_nStepsCount
int m_nStepsCount
Total steps of animation process.
Definition XTPDockingPaneMiniWnd.h:372
CXTPDockingPaneMiniWnd::m_bSlideOut
BOOL m_bSlideOut
Pane is currently expanding.
Definition XTPDockingPaneMiniWnd.h:378
CXTPDockingPaneMiniWnd::~CXTPDockingPaneMiniWnd
~CXTPDockingPaneMiniWnd()
Destroys a CXTPDockingPaneMiniWnd object, handles cleanup and deallocation.
CXTPDockingPaneMiniWnd::OnCaptionButtonClick
virtual void OnCaptionButtonClick(CXTPDockingPaneCaptionButton *pButton)
This member is called by the framework when a caption button is clicked.
CXTPDockingPaneMiniWnd::Init
virtual void Init(CXTPDockingPaneBase *pPane, CRect rc)
Initializes the frame window.
CXTPDockingPaneMiniWnd::m_bCollapsed
BOOL m_bCollapsed
Pane is collapsed.
Definition XTPDockingPaneMiniWnd.h:376
CXTPDockingPaneMiniWnd::Copy
virtual void Copy(CXTPDockingPaneBase *pClone, CXTPPaneToPaneMap *pMap, DWORD dwIgnoredOptions)
Copies self data from another pane.
CXTPDockingPaneMiniWnd::GetSelectedPane
CXTPDockingPane * GetSelectedPane() const
Call this member to determine the currently selected pane.
CXTPDockingPaneMiniWnd::IsCaptionButtonVisible
virtual BOOL IsCaptionButtonVisible(CXTPDockingPaneCaptionButton *pButton)
Call this member to determine if a caption button is visible.
CXTPDockingPaneMiniWnd::m_pTopContainer
CXTPDockingPaneSplitterContainer * m_pTopContainer
Top-level container.
Definition XTPDockingPaneMiniWnd.h:367
CXTPDockingPaneMiniWnd::DoSlideStep
void DoSlideStep(BOOL bActivate=FALSE)
This method is called to animate a collapsed frame.
CXTPDockingPaneMiniWnd::RedrawPane
void RedrawPane()
Call this member to redraw the pane.
CXTPDockingPaneMiniWnd::OnCaptionButtonDown
virtual BOOL OnCaptionButtonDown(CXTPDockingPaneCaptionButton *pButton)
This member is called by the framework when the mouse button is pressed on a caption button.
CXTPDockingPaneSplitterContainer
CXTPDockingPaneSplitterContainer is a CXTPDockingPaneBase derived class.
Definition XTPDockingPaneSplitterContainer.h:168
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72


Toolkit Pro: XTPDockingPaneTabTheme2012.h Source File

  • Source
  • DockingPane
  • TabThemes
XTPDockingPaneTabTheme2012.h
Go to the documentation of this file.
1
23#if !defined(__XTPDOCKINGPANETABTHEME2012_H__)
24# define __XTPDOCKINGPANETABTHEME2012_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPDockingPaneTabTheme2012 : public CXTPTabThemeFlat
39{
40public:
45 CXTPDockingPaneTabTheme2012();
46
52 virtual void RefreshMetrics();
53
63 virtual void DrawText(CDC* pDC, CXTPTabManager* pManager, const CString& str, LPRECT lpRect,
64 UINT nFormat);
65
82 virtual void DrawSingleButton(CDC* pDC, CXTPTabManagerItem* pItem);
83};
84
85# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
87#endif // !defined(__XTPDOCKINGPANETABTHEME2012_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPDockingPaneTabTheme2012
Helper class used to initialize default colors for a theme from an .INI resource and handle drawing r...
Definition XTPDockingPaneTabTheme2012.h:39
CXTPDockingPaneTabTheme2012::CXTPDockingPaneTabTheme2012
CXTPDockingPaneTabTheme2012()
Default class constructor.
CXTPDockingPaneTabTheme2012::DrawText
virtual void DrawText(CDC *pDC, CXTPTabManager *pManager, const CString &str, LPRECT lpRect, UINT nFormat)
This method is called to draw text for the specified item.
CXTPDockingPaneTabTheme2012::DrawSingleButton
virtual void DrawSingleButton(CDC *pDC, CXTPTabManagerItem *pItem)
This method is called to draw a single tab button in the tab client header area.
CXTPDockingPaneTabTheme2012::RefreshMetrics
virtual void RefreshMetrics()
This member function is used to initialize default colors for a theme from an .INI resource.
CXTPTabManager
CXTPTabManager is the base class for docking pane tabs, tab control tabs, and MDI client tabs.
Definition XTPTabManager.h:87
CXTPTabManagerItem
CXTPTabManagerItem is the base class for the tabs that appear in the command bars tab workspace,...
Definition XTPTabManagerItem.h:44
CXTPTabThemeFlat
CXTPTabThemeFlat implements a "Flat" tab appearance.
Definition XTPTabThemeFlat.h:49


Toolkit Pro: XTPPopupThemeResource.h Source File

  • Source
  • Controls
  • Popup
  • Themes
XTPPopupThemeResource.h
Go to the documentation of this file.
1
23#if !defined(__XTPPOPUPTHEMERESOURCE_H__)
24# define __XTPPOPUPTHEMERESOURCE_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPPopupThemeResource : public CXTPPopupThemeOffice2003
39{
40public:
45 CXTPPopupThemeResource();
46
47public:
52 void RefreshMetrics();
53};
54
55# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
57#endif // __XTPPOPUPTHEMERESOURCE_H__
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPPopupThemeOffice2003
CXTPPopupThemeOffice2003 is a class used to perform Office 2003 drawing tasks.
Definition XTPPopupThemeOffice2003.h:39
CXTPPopupThemeResource
CXTPPopupThemeResource is a class used to perform resource drawing tasks.
Definition XTPPopupThemeResource.h:39
CXTPPopupThemeResource::CXTPPopupThemeResource
CXTPPopupThemeResource()
Constructs a CXTPPopupThemeOffice2003 object.
CXTPPopupThemeResource::RefreshMetrics
void RefreshMetrics()
Call this member function to refresh draw metrics.


Toolkit Pro: XTPShortcutBarAnimation.h Source File

  • Source
  • ShortcutBar
XTPShortcutBarAnimation.h
Go to the documentation of this file.
1
23#if !defined(__XTPSHORTCUTBARANIMATION_H__)
24# define __XTPSHORTCUTBARANIMATION_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
34class CXTPShortcutBar;
35
36# define XTP_TID_ANIMATION 0xACD43
37
38class _XTP_EXT_CLASS CXTPShortcutBarAnimation
39{
40protected:
41 struct CAnimateInfo
42 {
43 CAnimateInfo();
44 ~CAnimateInfo();
45
46 HBITMAP hbmSrc;
47 BYTE* pSrcBits;
48
49 HBITMAP hbmSrcBack;
50 BYTE* pSrcBackBits;
51
52 RECT rcPaint;
53 int m_nAnimation;
54 CArray<RECT, RECT&> arrExclude;
55 };
56
57public:
58 CXTPShortcutBarAnimation(CXTPShortcutBar* pShortcutBar);
59 ~CXTPShortcutBarAnimation();
60
61public:
62 void OnPaint(CPaintDC& paintDC);
63 void RedrawRect(LPCRECT lpRect, BOOL bAnimate);
64 void OnAnimate();
65 void OnDestroy();
66
67protected:
68 void RemoveAnimations();
69 void AnimateRect(CClientDC& dc, CAnimateInfo* pai);
70 void RemoveIntersections(LPCRECT rcPaint, BOOL bAddExclude);
71
72 void AlphaBlendU(PBYTE pDest, PBYTE pSrcBack, int cx, int cy, PBYTE pSrc, BYTE byAlpha);
73 void AddAnimation(CClientDC& dc, CAnimateInfo* pai);
74
75 BOOL IsAnimationEnabled() const;
76
77public:
78 CXTPShortcutBar* m_pParent;
79 CBitmap m_bmpCache;
80 BOOL m_bInvalidate;
81 UINT_PTR m_nTimer;
82
83 BOOL m_bAnimation;
84 BOOL m_bDoubleBuffer;
85
86protected:
87 CArray<CAnimateInfo*, CAnimateInfo*> m_arrAnimation;
88};
89
92# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
94#endif // !defined(__XTPSHORTCUTBARANIMATION_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPShortcutBar
CXTPShortcutBar is a CWnd derived class used to implement an Outlook 2003 shortcut bar control style.
Definition XTPShortcutBar.h:456


Toolkit Pro: Member List

CXTPCommandBarsFrameHook Member List

This is the complete list of members for CXTPCommandBarsFrameHook, including all inherited members.

CalcFrameBorder() const | CXTPCommandBarsFrameHook |
CXTPCommandBarsFrameHook() | CXTPCommandBarsFrameHook |
CXTPHookManagerHookAble() | CXTPHookManagerHookAble |
DelayRecalcFrameLayout() | CXTPCommandBarsFrameHook |
DisableDwm() | CXTPCommandBarsFrameHook |
DisableFrameTheme() | CXTPCommandBarsFrameHook |
DisableShadow() | CXTPCommandBarsFrameHook |
DrawRibbonFramePart(CDC *pDC) | CXTPCommandBarsFrameHook |
EnableFrameTheme(CXTPCommandBars *pCommandBars) | CXTPCommandBarsFrameHook |
EnableFrameTheme(CWnd *pSite, CXTPPaintManager *pPaintManager) | CXTPCommandBarsFrameHook |
EnableFrameTheme(CWnd *pSite, CXTPCommandBars *pCommandBars) | CXTPCommandBarsFrameHook |
EnableShadow() | CXTPCommandBarsFrameHook |
GetCaptionButtons() const | CXTPCommandBarsFrameHook |
GetCaptionHeight() const | CXTPCommandBarsFrameHook |
GetFramePaintManager() const | CXTPCommandBarsFrameHook |
GetPaintManager() const | CXTPCommandBarsFrameHook |
GetShadow() const | CXTPCommandBarsFrameHook |
GetSite() const | CXTPCommandBarsFrameHook |
GetSiteExStyle() const | CXTPCommandBarsFrameHook |
GetSiteStyle() const | CXTPCommandBarsFrameHook |
IsCaptionVisible() const | CXTPCommandBarsFrameHook |
IsDwmEnabled() const | CXTPCommandBarsFrameHook |
IsFrameActive() const | CXTPCommandBarsFrameHook |
IsFrameHasStatusBar(int *pnStatusHeight=NULL) const | CXTPCommandBarsFrameHook |
IsMDIMaximized() const | CXTPCommandBarsFrameHook |
m_bActive | CXTPCommandBarsFrameHook | protected
m_bAutoDestroy | CXTPHookManagerHookAble |
m_bBeingDestructed | CXTPCommandBarsFrameHook | protected
m_bButtonPressed | CXTPCommandBarsFrameHook | protected
m_bDelayReclalcLayout | CXTPCommandBarsFrameHook | protected
m_bDwmEnabled | CXTPCommandBarsFrameHook | protected
m_bInUpdateFrame | CXTPCommandBarsFrameHook | protected
m_bLockNCPaint | CXTPCommandBarsFrameHook |
m_bThemeFrameEnabled | CXTPCommandBarsFrameHook | protected
m_bUseGlobalPaintManager | CXTPCommandBarsFrameHook | protected
m_hwndSite | CXTPCommandBarsFrameHook | protected
m_nMsgQueryFrameHook | CXTPCommandBarsFrameHook | static
m_pCaptionButtons | CXTPCommandBarsFrameHook | protected
m_pCommandBars | CXTPCommandBarsFrameHook | protected
m_pMenuTitleBar | CXTPCommandBarsFrameHook | protected
m_pPaintManager | CXTPCommandBarsFrameHook | protected
m_pRibbonBar | CXTPCommandBarsFrameHook | protected
m_pSelected | CXTPCommandBarsFrameHook | protected
m_pShadow | CXTPCommandBarsFrameHook | mutableprotected
m_szFrameRegion | CXTPCommandBarsFrameHook | protected
OnHookAttached(HWND hWnd) | CXTPHookManagerHookAble | virtual
OnHookDetached() | CXTPHookManagerHookAble | virtual
OnHookMessage(HWND hWnd, UINT nMessage, WPARAM &wParam, LPARAM &lParam, LRESULT &lResult) | CXTPCommandBarsFrameHook | protectedvirtual
OnPostHookMessage(HWND hWnd, UINT nMessage, WPARAM &wParam, LPARAM &lParam, LRESULT &lResult) | CXTPHookManagerHookAble | virtual
OnUpdateMDIChildrenTheme() | CXTPCommandBarsFrameHook | protectedvirtual
RecalcFrameLayout() | CXTPCommandBarsFrameHook |
RedrawFrame() | CXTPCommandBarsFrameHook |
RedrawMenuTitleBar() | CXTPCommandBarsFrameHook |
RedrawRibbonBar() | CXTPCommandBarsFrameHook |
UpdateDwmClientArea() | CXTPCommandBarsFrameHook |
~CXTPCommandBarsFrameHook() | CXTPCommandBarsFrameHook |
~CXTPHookManagerHookAble() | CXTPHookManagerHookAble | virtual


Toolkit Pro: Member List

CXTPCustomizeCommandsListBox Member List

This is the complete list of members for CXTPCustomizeCommandsListBox, including all inherited members.

CXTPCustomizeCommandsListBox() | CXTPCustomizeCommandsListBox | inline
m_bDragable | CXTPCustomizeCommandsListBox |
m_pCommandBars | CXTPCustomizeCommandsListBox |


Toolkit Pro: Member List

CXTPSyntaxEditToolTipCtrl Member List

This is the complete list of members for CXTPSyntaxEditToolTipCtrl, including all inherited members.

Activate(const CString &strText) | CXTPSyntaxEditToolTipCtrl |
Create(CXTPSyntaxEditCtrl *pParentWnd) | CXTPSyntaxEditToolTipCtrl | virtual
CXTPSyntaxEditToolTipCtrl() | CXTPSyntaxEditToolTipCtrl |
GetDelay() const | CXTPSyntaxEditToolTipCtrl |
Hide() | CXTPSyntaxEditToolTipCtrl |
m_nDelayTime | CXTPSyntaxEditToolTipCtrl | protected
m_pParentWnd | CXTPSyntaxEditToolTipCtrl | protected
m_rcHover | CXTPSyntaxEditToolTipCtrl | protected
m_strToolTipText | CXTPSyntaxEditToolTipCtrl | protected
SetDelay(int nDelay) | CXTPSyntaxEditToolTipCtrl |
SetHoverRect(CRect rc) | CXTPSyntaxEditToolTipCtrl |
~CXTPSyntaxEditToolTipCtrl() | CXTPSyntaxEditToolTipCtrl | virtual


Toolkit Pro: Member List

CXTPEditThemeVisualStudio2019 Member List

This is the complete list of members for CXTPEditThemeVisualStudio2019, including all inherited members.

AdjustBuddyRect(CWnd *pBuddy, CRect &rcUpDown, int nAlignment) | CXTPEditThemeOfficeXP | virtual
CtlColor(CDC *pDC, UINT nCtlColor, CXTPEdit *pEdit) | CXTPEditThemeDefault | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPControlTheme() | CXTPControlTheme |
CXTPEditTheme() | CXTPEditTheme |
CXTPEditThemeDefault() | CXTPEditThemeDefault |
CXTPEditThemeOffice2000() | CXTPEditThemeOffice2000 |
CXTPEditThemeOffice2013() | CXTPEditThemeOffice2013 |
CXTPEditThemeOfficeXP() | CXTPEditThemeOfficeXP |
CXTPEditThemeVisualStudio2019() | CXTPEditThemeVisualStudio2019 |
DrawBuddyBorders(CWnd *pBuddy, CDC *pDC, CRect rc, int nAlignment, CXTPEdit *pEdit) | CXTPEditThemeOfficeXP | virtual
CXTPEditThemeOffice2000::DrawBuddyBorders(CDC *pDC, CRect rc, int nAlignment, CXTPEdit *pEdit) | CXTPEditThemeOffice2000 | virtual
DrawFrame(CDC *pDC, CRect rc, int nSize, CBrush *pBrush) | CXTPEditTheme | virtual
DrawNcBorders(CDC *pDC, CRect rcWnd, CXTPEdit *pEdit) | CXTPEditThemeOfficeXP | virtual
DrawNcBordersDefault(CDC *pDC, CRect rcWnd, CXTPEdit *pEdit) | CXTPEditThemeDefault | protectedvirtual
DrawNcScrollBack(CDC *pDC, CRect rcWnd, CXTPEdit *pEdit) | CXTPEditThemeDefault | virtual
FillRect(CDC *pDC, int x, int y, int cx, int cy, CBrush *pBrush) | CXTPEditTheme | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetClientBrush(CDC *pDC, CXTPEdit *pEdit) | CXTPEditTheme | virtual
GetThemeID() const | CXTPEditTheme |
GetThemeStyle() const | CXTPControlTheme |
IsFlatStyle() const | CXTPEditTheme |
m_bFlatStyle | CXTPEditTheme | protected
m_bUseWinTheme | CXTPEditTheme | protected
m_clrBack | CXTPEditTheme |
m_clrBackNonClient | CXTPEditTheme |
m_clrBorder | CXTPEditTheme |
m_clrBorderDisabled | CXTPEditThemeOfficeXP | protected
m_clrBorderHilite | CXTPEditThemeOfficeXP | protected
m_clrText | CXTPEditTheme |
m_clrTextReadOnly | CXTPEditTheme |
m_nTheme | CXTPEditTheme | protected
m_winTheme | CXTPEditTheme | protected
m_xtpBrushBack | CXTPEditTheme |
RedrawFocusedFrame() const | CXTPEditThemeOfficeXP | virtual
RefreshMetrics(CXTPEdit *pEdit) | CXTPEditThemeOffice2013 | virtual
SetFlatStyle(BOOL bFlatStyle) | CXTPEditTheme |
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static
UseWinTheme(BOOL bUseWinTheme) | CXTPEditTheme |
~CXTPEditTheme() | CXTPEditTheme | virtual
~CXTPEditThemeDefault() | CXTPEditThemeDefault | virtual
~CXTPEditThemeOffice2000() | CXTPEditThemeOffice2000 | virtual
~CXTPEditThemeOffice2013() | CXTPEditThemeOffice2013 | virtual
~CXTPEditThemeOfficeXP() | CXTPEditThemeOfficeXP | virtual
~CXTPEditThemeVisualStudio2019() | CXTPEditThemeVisualStudio2019 | virtual


Toolkit Pro: Member List

CXTPGridThemeVisualStudio2012Dark Member List

This is the complete list of members for CXTPGridThemeVisualStudio2012Dark, including all inherited members.

CalcColumnHeight(CDC *pDC, CXTPGridColumn *pColumn, int nTotalWidth=0) | CXTPGridPaintManager | protectedvirtual
CalculateRowHeight(CDC *pDC, const CString &strText, int nMaxWidth, BOOL bWordBreak=TRUE) | CXTPGridPaintManager | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPGridPaintManager() | CXTPGridPaintManager |
CXTPGridThemeOffice2013() | CXTPGridThemeOffice2013 |
CXTPGridThemeVisualStudio2012Dark() | CXTPGridThemeVisualStudio2012Dark |
DrawBitmap(CDC *pDC, CXTPGridControl *pControl, CRect rcColumn, int iImage) | CXTPGridPaintManager | virtual
DrawCollapsedBitmap(CDC *pDC, const CXTPGridRow *pRow, CRect &rcBitmap) | CXTPGridThemeOffice2013 | virtual
DrawColumn(CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn, BOOL bDrawExternal=FALSE, int nShadowWidth=0) | CXTPGridPaintManager | virtual
DrawColumnBackground(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, BOOL &bColumnPressed, BOOL &bDraggingFromHeader, CXTPGridHeader *pHeader=NULL) | CXTPGridThemeOffice2013 | virtual
DrawColumnFooter(CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn) | CXTPGridPaintManager | virtual
DrawColumnFooterDivider(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn) | CXTPGridPaintManager | virtual
DrawColumnIcon(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, CRect rcIcon, int iIcon) | CXTPGridPaintManager | virtual
DrawColumnText(CDC *pDC, CRect rcText, CString strCaption, int nHeaderAlignment, BOOL bIsHeader, BOOL bColumnPressed) | CXTPGridThemeOffice2013 | virtual
DrawConnector(CDC *pDC, CPoint ptFrom, CPoint ptTo) | CXTPGridPaintManager |
DrawFocusedRow(CDC *pDC, CRect rcRow) | CXTPGridThemeOffice2013 | virtual
DrawFreezeColsDivider(CDC *pDC, const CRect &rc, CXTPGridControl *pControl, CXTPGridRow *pRow=NULL) | CXTPGridPaintManager | virtual
DrawGlyph(CDC *pDC, CRect rcColumn, int iImage) | CXTPGridPaintManager | virtual
DrawGrid(CDC *pDC, XTPGridOrientation orientation, CRect rcGrid) | CXTPGridPaintManager | virtual
DrawGridPattern(CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush) | CXTPGridPaintManager | protectedvirtual
DrawGridPattern(CDC *pDC, CXTPBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush) | CXTPGridPaintManager | protectedvirtual
DrawGridPattern(CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr) | CXTPGridPaintManager | protectedvirtual
DrawGroupRow(CDC *pDC, CXTPGridGroupRow *pRow, CRect rcRow, XTP_GRIDRECORDITEM_METRICS *pMetrics) | CXTPGridThemeOffice2013 | virtual
DrawHorizontalLine(CDC *pDC, int xPos, int yPos, int cx, COLORREF clr) | CXTPGridPaintManager |
DrawInplaceButton(CDC *pDC, CXTPGridInplaceButton *pButton) | CXTPGridPaintManager | virtual
DrawInplaceButtonFrame(CDC *pDC, CXTPGridInplaceButton *pButton) | CXTPGridPaintManager | protectedvirtual
DrawInplaceButtonIcon(CDC *pDC, CXTPGridInplaceButton *pButton) | CXTPGridPaintManager | protectedvirtual
DrawInplaceComboButton(CDC *pDC, CRect *pRc) | CXTPGridPaintManager | virtual
DrawInplaceExpandButton(CDC *pDC, CRect *pRc) | CXTPGridPaintManager | virtual
DrawInplaceSpinButton(CDC *pDC, CRect *pRc) | CXTPGridPaintManager | virtual
DrawItemBitmap(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CRect &rcItem, int nImage) | CXTPGridPaintManager | virtual
DrawItemCaption(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics) | CXTPGridPaintManager | virtual
DrawItemControl(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CXTPGridRecordItemControl *pControl, CRect &rcItem) | CXTPGridPaintManager | virtual
DrawLink(int *pnCurrDrawPos, XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CXTPGridHyperlink *pHyperlink, CString strText, CRect rcLink, int nFlag, BOOL bTrim=FALSE) | CXTPGridPaintManager | protectedvirtual
DrawMultiLineText(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, BOOL bWordBreak=TRUE) | CXTPGridPaintManager | protectedvirtual
DrawNoGroupByText(CDC *pDC, CRect rcItem) | CXTPGridPaintManager | virtual
DrawRowNumber(CDC *pDC, CRect rcNumber, CXTPGridRow *pRow) | CXTPGridPaintManager | virtual
DrawSectionDivider(CDC *pDC, const CRect &rc, XTPGridSectionDividerPosition dividerPosition, XTPGridSectionDividerStyle dividerStyle, CXTPPaintManagerColor dividerColor) | CXTPGridPaintManager |
DrawShellIcon(CDC *pDC, CRect rcColumn, int iImage) | CXTPGridPaintManager | virtual
DrawSingleLineText(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nStartPos, int nEndPos, int nActualWidth) | CXTPGridPaintManager | protectedvirtual
DrawString(int *pnCurrDrawPos, CDC *pDC, const CString &strDraw, CRect rcDraw, UINT nFormat) | CXTPGridPaintManager | protectedvirtual
DrawTextLine(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nFlag, int &nCharCounter, int &nHyperlinkCounter) | CXTPGridPaintManager | protectedvirtual
DrawTreeStructure(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CRect rcItem, CSize sizeGlyph) | CXTPGridPaintManager | virtual
DrawTriangle(CDC *pDC, CRect rcTriangle, BOOL bToDown, BOOL bDraggingFromHeader, int nShadowWidth, BOOL bColumnPressed) | CXTPGridThemeOffice2013 | virtual
DrawVerticalLine(CDC *pDC, int xPos, int yPos, int cy, COLORREF clr) | CXTPGridPaintManager |
DrawVerticalTimeLineMarker(CDC *pDC, int xPos, CXTPGridControl *pControl, COLORREF color=RGB(0, 255, 0)) | CXTPGridPaintManager | virtual
EnablePreviewMode(BOOL bIsPreviewMode) | CXTPGridPaintManager |
FillFooter(CDC *pDC, CRect rcFooter) | CXTPGridPaintManager | virtual
FillGroupByControl(CDC *pDC, CRect &rcGroupBy) | CXTPGridPaintManager | virtual
FillGroupRowMetrics(CXTPGridGroupRow *pRow, XTP_GRIDRECORDITEM_METRICS *pMetrics, BOOL bPrinting) | CXTPGridThemeOffice2013 | virtual
FillHeaderControl(CDC *pDC, CRect rcHeader) | CXTPGridPaintManager | virtual
FillIndent(CDC *pDC, CRect rcRow) | CXTPGridPaintManager | virtual
FillItemShade(CDC *pDC, CRect rcItem) | CXTPGridPaintManager | virtual
FillRow(CDC *pDC, CXTPGridRow *pRow, CRect rcRow) | CXTPGridPaintManager | virtual
FindRowAdjacentToMerged(const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, BOOL bUpward) | CXTPGridPaintManager |
FindRowAdjacentToMergedEx(const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, int &nAdjRowIndex, BOOL bUpward) | CXTPGridPaintManager |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetColumnOffice2007CustomThemeBaseColor() const | CXTPGridPaintManager |
GetColumnStyle() const | CXTPGridPaintManager |
GetControlBackColor(CXTPGridControl *pControl) | CXTPGridPaintManager | virtual
GetFooterHeight(CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0) | CXTPGridPaintManager | virtual
GetFreezeColsDividerStyle() const | CXTPGridPaintManager |
GetGlyphs() const | CXTPGridPaintManager |
GetHeaderHeight() | CXTPGridPaintManager | virtual
GetHeaderHeight(CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0) | CXTPGridPaintManager | virtual
GetItemHeight(XTP_GRIDRECORDITEM_DRAWARGS &drawArgs, int nWidth) | CXTPGridPaintManager |
GetMaxPreviewLines() | CXTPGridPaintManager |
GetPreviewItemHeight(CDC *pDC, CXTPGridRow *pRow, int nWidth, int nHeight) | CXTPGridPaintManager | virtual
GetPreviewLinesCount(CDC *pDC, CRect &rcText, const CString &strText) | CXTPGridPaintManager |
GetRowHeight(CDC *pDC, CXTPGridRow *pRow) | CXTPGridThemeOffice2013 | virtual
GetRowHeight(CDC *pDC, CXTPGridRow *pRow, int nTotalWidth) | CXTPGridThemeOffice2013 | virtual
GetRowHeightEx(CDC *pDC, CXTPGridRow *pRow, int nTotalWidth, const BOOL firstLevel=TRUE) | CXTPGridPaintManager |
GetSectionDividerHeight(XTPGridFixedRowsDividerStyle dividerStyle) | CXTPGridPaintManager |
GetTextFont() | CXTPGridPaintManager |
IsColumHotTrackingEnabled() const | CXTPGridPaintManager | virtual
IsColumnPlusMinusSign() const | CXTPGridPaintManager |
IsColumnWidthWYSIWYG() const | CXTPGridPaintManager |
IsDrawGridForEmptySpace() const | CXTPGridPaintManager |
IsFixedInplaceButtonHeight() const | CXTPGridPaintManager |
IsFixedRowHeight() const | CXTPGridPaintManager |
IsGridVisible(BOOL bVertical) const | CXTPGridPaintManager |
IsGridVisible(XTPGridOrientation orientation) const | CXTPGridPaintManager |
IsLastColumnWidthWYSIWYG() const | CXTPGridPaintManager |
IsPreviewMode() const | CXTPGridPaintManager |
IsPrintGroupRowIcon() const | CXTPGridPaintManager |
IsShowWYSIWYGMarkers() const | CXTPGridPaintManager |
IsUseDropMarker() const | CXTPGridPaintManager |
LoadGlyphs() | CXTPGridThemeVisualStudio2012Dark | virtual
m_arStartCol | CXTPGridPaintManager |
m_bAllowMergeCells | CXTPGridPaintManager |
m_bBaseTreeIndent | CXTPGridPaintManager |
m_bCleanTooltip | CXTPGridPaintManager |
m_bColumnPlusMinusSign | CXTPGridPaintManager | protected
m_bColumnWidthWYSIWYG | CXTPGridPaintManager | protected
m_bCompactText | CXTPGridPaintManager |
m_bDrawGridForEmptySpace | CXTPGridPaintManager | protected
m_bFixedInplaceButtonHeight | CXTPGridPaintManager | protected
m_bFixedRowHeight | CXTPGridPaintManager | protected
m_bForceDynamicMarkupForCell | CXTPGridPaintManager |
m_bForceShowDropMarker | CXTPGridPaintManager |
m_bForceShowTooltip | CXTPGridPaintManager |
m_bGrayIfDisable | CXTPGridPaintManager |
m_bGroupRowTextBold | CXTPGridPaintManager |
m_bHideSelection | CXTPGridPaintManager |
m_bHotTracking | CXTPGridPaintManager |
m_bInvertColumnOnClick | CXTPGridPaintManager |
m_bIsPreviewMode | CXTPGridPaintManager | protected
m_bLastColumnWidthWYSIWYG | CXTPGridPaintManager | protected
m_bMakeUpper | CXTPGridPaintManager |
m_bMoveScrollbarOnFixedColumnsIndent | CXTPGridPaintManager |
m_bPrintGroupRowIcon | CXTPGridPaintManager | protected
m_bPrintPageRectangle | CXTPGridPaintManager |
m_bPrintSortTriangle | CXTPGridPaintManager |
m_bPrintVirtualPageNumber | CXTPGridPaintManager |
m_bPrintWatermark | CXTPGridPaintManager |
m_bRecOrRowNum | CXTPGridPaintManager |
m_bRevertAlignment | CXTPGridPaintManager |
m_bShadeGroupHeadings | CXTPGridPaintManager |
m_bShadeSortColumn | CXTPGridPaintManager |
m_bShowLockIcon | CXTPGridPaintManager |
m_bShowNonActiveInPlaceButton | CXTPGridPaintManager |
m_bShowWYSIWYGMarkers | CXTPGridPaintManager | protected
m_bSortTriangleOffsetFromRight | CXTPGridPaintManager |
m_bThemedInplaceButtons | CXTPGridPaintManager |
m_bUseAlternativeBackground | CXTPGridPaintManager |
m_bUseDropMarker | CXTPGridPaintManager |
m_bUseEditTextAlignment | CXTPGridPaintManager |
m_bUseGroupRowSelectionState | CXTPGridPaintManager |
m_bUseShellIcon | CXTPGridPaintManager |
m_clrAlternativeBackground | CXTPGridPaintManager |
m_clrBoldText | CXTPGridPaintManager |
m_clrBoldTextHighlight | CXTPGridPaintManager |
m_clrBtnFace | CXTPGridPaintManager |
m_clrBtnFacePressed | CXTPGridPaintManager |
m_clrBtnText | CXTPGridPaintManager |
m_clrCaptionText | CXTPGridPaintManager |
m_clrCaptionTextPressed | CXTPGridPaintManager |
m_clrColumnOffice2007CustomTheme | CXTPGridPaintManager |
m_clrConnector | CXTPGridPaintManager |
m_clrControlBack | CXTPGridPaintManager |
m_clrControlDark | CXTPGridPaintManager |
m_clrControlLightLight | CXTPGridPaintManager |
m_clrDisableBitmapDarkest | CXTPGridPaintManager |
m_clrDisableBitmapLightest | CXTPGridPaintManager |
m_clrFormulaSubSum | CXTPGridPaintManager |
m_clrFormulaSum | CXTPGridPaintManager |
m_clrFreezeColsDivider | CXTPGridPaintManager |
m_clrGlyph | CXTPGridThemeOffice2013 |
m_clrGlyphBorder | CXTPGridThemeOffice2013 |
m_clrGlyphContract | CXTPGridThemeOffice2013 |
m_clrGlyphExpand | CXTPGridThemeOffice2013 |
m_clrGlyphHighlight | CXTPGridThemeOffice2013 |
m_clrGradientColumnSeparator | CXTPGridPaintManager |
m_clrGradientColumnShadow | CXTPGridPaintManager |
m_clrGroupBoxBack | CXTPGridPaintManager |
m_clrGroupRowText | CXTPGridPaintManager |
m_clrGroupShadeBack | CXTPGridPaintManager |
m_clrGroupShadeBorder | CXTPGridPaintManager |
m_clrGroupShadeText | CXTPGridPaintManager |
m_clrHeaderControl | CXTPGridPaintManager |
m_clrHighlight | CXTPGridPaintManager |
m_clrHighlightText | CXTPGridPaintManager |
m_clrHotDivider | CXTPGridPaintManager |
m_clrIndentControl | CXTPGridPaintManager |
m_clrItemShade | CXTPGridPaintManager |
m_clrPreviewText | CXTPGridPaintManager |
m_clrSelectedRow | CXTPGridPaintManager |
m_clrSelectedRowText | CXTPGridPaintManager |
m_clrWindowText | CXTPGridPaintManager |
m_columnStyle | CXTPGridPaintManager | protected
m_crlNoGroupByText | CXTPGridPaintManager |
m_grcGradientColumn | CXTPGridPaintManager |
m_grcGradientColumnHot | CXTPGridPaintManager |
m_grcGradientColumnPushed | CXTPGridPaintManager |
m_iRecOrRowStart | CXTPGridPaintManager |
m_nBaseParentRecordIndent | CXTPGridPaintManager |
m_nFixedColumnsIndent | CXTPGridPaintManager |
m_nFooterHeight | CXTPGridPaintManager | protected
m_nFreezeColsDividerStyle | CXTPGridPaintManager | protected
m_nGridLineStylePreviousH | CXTPGridPaintManager | protected
m_nGridLineStylePreviousV | CXTPGridPaintManager | protected
m_nGroupGridLineHeight | CXTPGridPaintManager | protected
m_nGroupGridLineStyle | CXTPGridPaintManager | protected
m_nHeaderHeight | CXTPGridPaintManager | protected
m_nMaxPreviewLines | CXTPGridPaintManager | protected
m_nResizingWidth | CXTPGridPaintManager | protected
m_nRowHeight | CXTPGridPaintManager | protected
m_nRowHeightDefault | CXTPGridPaintManager |
m_nTextIndentForGroupRowsWithNoIcon | CXTPGridPaintManager |
m_nTreeColumnLineLength | CXTPGridPaintManager |
m_nTreeIndent | CXTPGridPaintManager |
m_nTreeStructureStyle | CXTPGridPaintManager |
m_nTreeTextIndent | CXTPGridPaintManager |
m_nTreeTextIndentGroupRow | CXTPGridPaintManager |
m_nTreeTextIndentRowChildren | CXTPGridPaintManager |
m_nTreeTextIndentRowParent | CXTPGridPaintManager |
m_pControl | CXTPGridPaintManager | protected
m_pGlyphs | CXTPGridPaintManager | protected
m_pHyperlinkHoverStyle | CXTPGridPaintManager |
m_pHyperlinkStyle | CXTPGridPaintManager |
m_pMarkupUIElement_NoGroupBy | CXTPGridPaintManager | protected
m_PrintPageWidth | CXTPGridPaintManager |
m_rcPreviewIndent | CXTPGridPaintManager |
m_RecordNumberWidth | CXTPGridPaintManager |
m_strCollapse | CXTPGridPaintManager |
m_strDecreasing | CXTPGridPaintManager |
m_strExpand | CXTPGridPaintManager |
m_strIncreasing | CXTPGridPaintManager |
m_strMarkupUIElement_NoGroupBy | CXTPGridPaintManager | protected
m_strNoFieldsAvailable | CXTPGridPaintManager |
m_strNoGroupBy | CXTPGridPaintManager |
m_strNoItems | CXTPGridPaintManager |
m_strSortBy | CXTPGridPaintManager |
m_szGlyph | CXTPGridPaintManager | protected
m_themeButton | CXTPGridPaintManager | protected
m_themeCombo | CXTPGridPaintManager | protected
m_themeHeader | CXTPGridPaintManager | protected
m_themeSpin | CXTPGridPaintManager | protected
m_treeStructureStyle | CXTPGridPaintManager |
m_xtpBrushGroupGridLineStyle | CXTPGridPaintManager | protected
m_xtpBrushHorizontalGrid | CXTPGridPaintManager | protected
m_xtpBrushTreeStructure | CXTPGridPaintManager | protected
m_xtpBrushVeriticalGrid | CXTPGridPaintManager | protected
m_xtpFontBoldText | CXTPGridPaintManager |
m_xtpFontCaption | CXTPGridPaintManager |
m_xtpFontPreview | CXTPGridPaintManager |
m_xtpFontText | CXTPGridPaintManager |
OnDrawAction(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs) | CXTPGridPaintManager | virtual
RecalcTotalHightOfMergedRows(CXTPGridColumns *pColumns, CDC *pDC, CXTPGridRow *pRow, int nRowHeight, int nTotalWidth) | CXTPGridPaintManager |
RefreshMetrics() | CXTPGridThemeVisualStudio2012Dark | virtual
SetCaptionFont(LOGFONT &lf) | CXTPGridPaintManager |
SetColumnOffice2007CustomThemeBaseColor(COLORREF clrBaseColor) | CXTPGridPaintManager |
SetColumnPlusMinusSign(BOOL bDraw) | CXTPGridPaintManager |
SetColumnStyle(XTPGridColumnStyle columnStyle) | CXTPGridPaintManager |
SetColumnWidthWYSIWYG(BOOL bColumnWidthWYSIWYG) | CXTPGridPaintManager |
SetDrawGridForEmptySpace(BOOL bDrawGrid) | CXTPGridPaintManager |
SetFixedRowHeight(BOOL bFixedRowHeight) | CXTPGridPaintManager |
SetFreezeColsDividerStyle(int nStyle) | CXTPGridPaintManager |
SetGridControl(CXTPGridControl *pControl) | CXTPGridPaintManager | virtual
SetHeaderHeight(int nHeight) | CXTPGridPaintManager | virtual
SetInplaceButtonHeight(BOOL bFixedInplaceButtonHeight) | CXTPGridPaintManager |
SetLastColumnWidthWYSIWYG(BOOL bColumnWidthWYSIWYG) | CXTPGridPaintManager |
SetMaxPreviewLines(int nMaxLines) | CXTPGridPaintManager |
SetPreviewIndent(int nLeft, int nTop, int nRight, int nBottom) | CXTPGridPaintManager |
SetPrintGroupRowIcon(BOOL bDraw) | CXTPGridPaintManager |
SetTextFont(LOGFONT &lf) | CXTPGridPaintManager |
ShowWYSIWYGMarkers(BOOL bSet) | CXTPGridPaintManager |
~CXTPGridPaintManager() | CXTPGridPaintManager | virtual


Toolkit Pro: Member List

CXTPControlTheme Member List

This is the complete list of members for CXTPControlTheme, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPControlTheme() | CXTPControlTheme |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetThemeStyle() const | CXTPControlTheme |
m_nTheme | CXTPControlTheme | protected
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static


Toolkit Pro: XTPDockContext.h Source File

  • Source
  • CommandBars
XTPDockContext.h
Go to the documentation of this file.
1
23#if !defined(__XTPDOCKCONTEXT_H__)
24# define __XTPDOCKCONTEXT_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPToolBar;
34
40class _XTP_EXT_CLASS CXTPDockContext
41{
42public:
48 CXTPDockContext(CXTPToolBar* pBar);
49
54 virtual ~CXTPDockContext();
55
56public:
62 virtual void StartDrag(CPoint pt);
63
70 virtual void StartResize(int nHitTest, CPoint pt);
71
78 virtual BOOL ToggleDocking();
79
80protected:
85 virtual void Track();
86
92 void Stretch(CPoint pt);
93
99 void Move(CPoint pt);
100
106 void Resize(CPoint pt);
107
108private:
109 static void AFX_CDECL AdjustRectangle(CRect& rect, CPoint pt);
110 void EnsureVisible(CRect& rectDragFrame);
111
112protected:
113 CXTPToolBar* m_pBar;
114 int m_nHitTest;
115 CPoint m_ptLast;
117 XTPBarPosition m_uMRUDockPosition;
119 CRect m_rectMRUDockPos;
120 CPoint m_ptMRUFloatPos;
122 CRect m_rectDragDock;
123 CRect m_rectDragFrame;
125private:
126 friend class CXTPToolBar;
127 friend class CXTPDockBar;
128};
130# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
131#endif //#if !defined(__XTPDOCKCONTEXT_H__)
XTPBarPosition
XTPBarPosition
Position of the command bar.
Definition XTPCommandBarsDefines.h:52
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPDockBar
CXTPDockBar is a CWnd derived class.
Definition XTPDockBar.h:42
CXTPDockContext
CXTPDockContext is a standalone class.
Definition XTPDockContext.h:41
CXTPDockContext::m_rectMRUDockPos
CRect m_rectMRUDockPos
Last docking rectangle.
Definition XTPDockContext.h:119
CXTPDockContext::m_nHitTest
int m_nHitTest
Hit Test code.
Definition XTPDockContext.h:114
CXTPDockContext::Stretch
void Stretch(CPoint pt)
This method is called to stretch the child toolbar.
CXTPDockContext::Resize
void Resize(CPoint pt)
This method is called to move the child toolbar to resize the child dialog bar.
CXTPDockContext::Move
void Move(CPoint pt)
This method is called to move the child toolbar to the specified position.
CXTPDockContext::m_ptMRUFloatPos
CPoint m_ptMRUFloatPos
Last floating rectangle.
Definition XTPDockContext.h:120
CXTPDockContext::CXTPDockContext
CXTPDockContext(CXTPToolBar *pBar)
Constructs a CXTPDockContext object.
CXTPDockContext::m_uMRUDockPosition
XTPBarPosition m_uMRUDockPosition
Last docking position.
Definition XTPDockContext.h:117
CXTPDockContext::m_pBar
CXTPToolBar * m_pBar
Child toolbar.
Definition XTPDockContext.h:113
CXTPDockContext::StartResize
virtual void StartResize(int nHitTest, CPoint pt)
This method is called when the user starts to resize the toolbar.
CXTPDockContext::Track
virtual void Track()
This method is called to start the tracking loop.
CXTPDockContext::StartDrag
virtual void StartDrag(CPoint pt)
This method is called when the user starts to move the toolbar.
CXTPDockContext::m_ptLast
CPoint m_ptLast
Last mouse position.
Definition XTPDockContext.h:115
CXTPDockContext::m_rectDragFrame
CRect m_rectDragFrame
Current floating rectangle.
Definition XTPDockContext.h:123
CXTPDockContext::ToggleDocking
virtual BOOL ToggleDocking()
This method is called to switch the docking position of the toolbar.
CXTPDockContext::~CXTPDockContext
virtual ~CXTPDockContext()
Destroys a CXTPDockContext object, handles cleanup and deallocation.
CXTPDockContext::m_rectDragDock
CRect m_rectDragDock
Current docking rectangle.
Definition XTPDockContext.h:122
CXTPToolBar
CXTPToolBar is a CXTPCommandBar derived class.
Definition XTPToolBar.h:42


Toolkit Pro: Member List

CXTPEditThemeVisualStudio2015 Member List

This is the complete list of members for CXTPEditThemeVisualStudio2015, including all inherited members.

AdjustBuddyRect(CWnd *pBuddy, CRect &rcUpDown, int nAlignment) | CXTPEditThemeOfficeXP | virtual
CtlColor(CDC *pDC, UINT nCtlColor, CXTPEdit *pEdit) | CXTPEditThemeDefault | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPControlTheme() | CXTPControlTheme |
CXTPEditTheme() | CXTPEditTheme |
CXTPEditThemeDefault() | CXTPEditThemeDefault |
CXTPEditThemeOffice2000() | CXTPEditThemeOffice2000 |
CXTPEditThemeOffice2013() | CXTPEditThemeOffice2013 |
CXTPEditThemeOfficeXP() | CXTPEditThemeOfficeXP |
CXTPEditThemeVisualStudio2015() | CXTPEditThemeVisualStudio2015 |
DrawBuddyBorders(CWnd *pBuddy, CDC *pDC, CRect rc, int nAlignment, CXTPEdit *pEdit) | CXTPEditThemeOfficeXP | virtual
CXTPEditThemeOffice2000::DrawBuddyBorders(CDC *pDC, CRect rc, int nAlignment, CXTPEdit *pEdit) | CXTPEditThemeOffice2000 | virtual
DrawFrame(CDC *pDC, CRect rc, int nSize, CBrush *pBrush) | CXTPEditTheme | virtual
DrawNcBorders(CDC *pDC, CRect rcWnd, CXTPEdit *pEdit) | CXTPEditThemeOfficeXP | virtual
DrawNcBordersDefault(CDC *pDC, CRect rcWnd, CXTPEdit *pEdit) | CXTPEditThemeDefault | protectedvirtual
DrawNcScrollBack(CDC *pDC, CRect rcWnd, CXTPEdit *pEdit) | CXTPEditThemeDefault | virtual
FillRect(CDC *pDC, int x, int y, int cx, int cy, CBrush *pBrush) | CXTPEditTheme | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetClientBrush(CDC *pDC, CXTPEdit *pEdit) | CXTPEditTheme | virtual
GetThemeID() const | CXTPEditTheme |
GetThemeStyle() const | CXTPControlTheme |
IsFlatStyle() const | CXTPEditTheme |
m_bFlatStyle | CXTPEditTheme | protected
m_bUseWinTheme | CXTPEditTheme | protected
m_clrBack | CXTPEditTheme |
m_clrBackNonClient | CXTPEditTheme |
m_clrBorder | CXTPEditTheme |
m_clrBorderDisabled | CXTPEditThemeOfficeXP | protected
m_clrBorderHilite | CXTPEditThemeOfficeXP | protected
m_clrText | CXTPEditTheme |
m_clrTextReadOnly | CXTPEditTheme |
m_nTheme | CXTPEditTheme | protected
m_winTheme | CXTPEditTheme | protected
m_xtpBrushBack | CXTPEditTheme |
RedrawFocusedFrame() const | CXTPEditThemeOfficeXP | virtual
RefreshMetrics(CXTPEdit *pEdit) | CXTPEditThemeOffice2013 | virtual
SetFlatStyle(BOOL bFlatStyle) | CXTPEditTheme |
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static
UseWinTheme(BOOL bUseWinTheme) | CXTPEditTheme |
~CXTPEditTheme() | CXTPEditTheme | virtual
~CXTPEditThemeDefault() | CXTPEditThemeDefault | virtual
~CXTPEditThemeOffice2000() | CXTPEditThemeOffice2000 | virtual
~CXTPEditThemeOffice2013() | CXTPEditThemeOffice2013 | virtual
~CXTPEditThemeOfficeXP() | CXTPEditThemeOfficeXP | virtual
~CXTPEditThemeVisualStudio2015() | CXTPEditThemeVisualStudio2015 | virtual


Toolkit Pro: XTPCalendarOptions.h Source File

  • Source
  • Calendar
XTPCalendarOptions.h
Go to the documentation of this file.
1
22#if !defined(_XTPCALENDAROPTIONS_H__)
23# define _XTPCALENDAROPTIONS_H__
24
25# if _MSC_VER > 1000
26# pragma once
27# endif // _MSC_VER > 1000
28
29# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
30
31class CXTPCalendarData;
32class CXTPPropExchange;
33class CXTPCalendarFlagsSet_imp;
34class CXTPCalendarTimeZone;
35
36 XTP_DEFINE_SMART_PTR_INTERNAL(CXTPCalendarTimeZone)
37
38
42enum XTPCalendarAdditionalOptions
43{
44 xtpCalendarOptMonthViewShowStartTimeAlways = 0x00000001, // define option to always show event
45 // start time in the month view.
46 xtpCalendarOptMonthViewShowEndTimeAlways = 0x00000002, // define option to always show event end
47 // time in the month view.
48 xtpCalendarOptWeekViewShowStartTimeAlways = 0x00000004, // define option to always show event
49 // start time in the week view.
50 xtpCalendarOptWeekViewShowEndTimeAlways = 0x00000008, // define option to always show event end
51 // time in the week view.
52 xtpCalendarOptDayViewNoWordBreak = 0x00000010, // define option to draw event text without word
53 // break in the day view.
54 xtpCalendarOptWorkWeekViewShowStartTimeAlways =
55 0x00000020, // define option to always show event start time in the work week view.
56 xtpCalendarOptWorkWeekViewShowEndTimeAlways = 0x00000040, // define option to always show event
57 // end time in the work week view.
58 xtpCalendarOptDayViewShowStartTimeAlways = 0x00000080, // define option to always show event
59 // start time in the day view.
60 xtpCalendarOptDayViewShowEndTimeAlways = 0x00000100 // define option to always show event end
61 // time in the day view.
62};
63
76class _XTP_EXT_CLASS CXTPCalendarOptions : public CXTPCmdTarget
77{
79 DECLARE_DYNAMIC(CXTPCalendarOptions)
82public:
87 CXTPCalendarOptions();
88
96 virtual ~CXTPCalendarOptions();
97
98public:
112 void DoPropExchange(CXTPPropExchange* pPX);
113
126 CXTPCalendarTimeZonePtr GetCurrentTimeZoneInfo();
127
132 void OnOptionsChanged();
133
135 // data provider related
136
151 void SetDataProvider(CXTPCalendarData* pDataProvider);
152
153public:
154 //## Calendar work week
155 int nWorkWeekMask;
158 int nFirstDayOfTheWeek;
160 COleDateTime dtWorkDayStartTime;
161 COleDateTime dtWorkDayEndTime;
163 COleDateTime dtScaleMinTime;
164 COleDateTime dtScaleMaxTime;
166 BOOL bEnableInPlaceEditEventSubject_ByF2;
168 BOOL bEnableInPlaceEditEventSubject_ByMouseClick;
171 BOOL bEnableInPlaceEditEventSubject_ByTab;
173 BOOL bEnableInPlaceEditEventSubject_AfterEventResize;
177 BOOL bEnableInPlaceCreateEvent;
179 BOOL bUseOutlookFontGlyphs;
182 //## Day View
183 BOOL bDayView_AutoResetBusyFlag;
187 int nDayView_ScaleInterval;
189 CString strDayView_ScaleLabel;
190 CString strDayView_AdditionalScaleLabel;
191 BOOL bDayView_ScaleLeftVisible;
192 BOOL bDayView_ScaleRightVisible;
193 BOOL bDayView_AdditionalScaleLeftVisible;
195 BOOL bDayView_AdditionalScaleRightVisible;
198 BOOL bDayView_DrawNowLineOverAppoinment;
199 TIME_ZONE_INFORMATION tziDayView_AdditionalScaleTimeZone;
202 int nDayView_CurrentTimeMarkVisible;
206 BOOL bDayView_TimeScaleShowMinutes;
208 BOOL bShowAllDayExpandButton;
210 //## Month View
211 BOOL bMonthView_CompressWeekendDays;
213 BOOL bMonthView_ShowEndDate;
215 BOOL bMonthView_ShowTimeAsClocks;
217 BOOL bMonthView_HideTimes;
220 //## Week View
221 BOOL bWeekView_ShowEndDate;
223 BOOL bWeekView_ShowTimeAsClocks;
226 //## TimeLine View
227 BOOL bTimeLineCompact;
229 BOOL bTimeLineFocused;
231 //## Common
232 DWORD dwAdditionalOptions;
233 BOOL bHatchAllDayViewEventsBkgnd;
235 BOOL bShowCategoryIcons;
238 //## "Add new appointment" tooltip
239 BOOL bEnableAddNewTooltip;
241 CString strTooltipAddNewText;
244 //## Office2007 Theme only
245 BOOL bEnablePrevNextEventButtons;
247protected:
248 CXTPCalendarData* m_pDataProvider;
250# ifdef _XTP_ACTIVEX
251
252 DECLARE_DISPATCH_MAP()
253 DECLARE_INTERFACE_MAP()
254
255 DECLARE_OLETYPELIB_EX(CXTPCalendarOptions);
256 DATE OleGetWorkDayStartTime();
257 DATE OleGetWorkDayEndTime();
258 void OleSetWorkDayStartTime(DATE);
259 void OleSetWorkDayEndTime(DATE);
260
261 BSTR OleGetDayViewScaleLabel();
262 void OleSetDayViewScaleLabel(LPCTSTR pcszLabel);
263
264 BSTR OleGetDayViewAdditionalScaleLabel();
265 void OleSetDayViewAdditionalScaleLabel(LPCTSTR pcszLabel);
266
267 BSTR OleGetTooltipAddNewText();
268 void OleSetTooltipAddNewText(LPCTSTR pcszLabel);
269
270 LPDISPATCH OleGetCurrentTimeZone();
271
272 LPDISPATCH OleGetAdditionalScaleTimeZone();
273 void OleSetAdditionalScaleTimeZone(LPDISPATCH pDispTZInfo);
274
275 LPDISPATCH OleEnumAllTimeZones();
276
277 LPDISPATCH OleGetAdditionalOptionsFlags();
278
279# endif
280};
281
282# ifdef _XTP_ACTIVEX
283
284class _XTP_EXT_CLASS CXTPCalendarFlagsSet_imp : public CXTPCmdTarget
285{
286public:
287 CXTPCalendarFlagsSet_imp();
288 virtual ~CXTPCalendarFlagsSet_imp();
289
290 void SetDataRef(DWORD* pdwFlags, CCmdTarget* pDataRef);
291
292protected:
293 DWORD* m_pdwFlags;
294 CCmdTarget* m_pDataRef;
295
296 DECLARE_DISPATCH_MAP()
297 DECLARE_INTERFACE_MAP()
298
299 DECLARE_OLETYPELIB_EX(CXTPCalendarFlagsSet_imp);
300
301public:
302 virtual long OleGetFlags();
303 virtual void OleSetFlags(long nFlags);
304
305 virtual BOOL OleIsFlagSet(long nFlag);
306 virtual void OleSetFlag(long nFlag);
307 virtual void OleResetFlag(long nFlag);
308};
309
310# endif
311
312# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
313#endif // !defined(_XTPCALENDAROPTIONS_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTP_DEFINE_SMART_PTR_INTERNAL
#define XTP_DEFINE_SMART_PTR_INTERNAL(ClassName)
Define smart pointer for the specified class as ClassNamePtr.
Definition XTPSmartPtrInternalT.h:47
CXTPCalendarData
This class defines an abstract representation of the Calendar control data with all necessary methods...
Definition XTPCalendarData.h:97
CXTPCalendarOptions
Structure contains all calendar options.
Definition XTPCalendarOptions.h:77
CXTPCalendarOptions::dtScaleMinTime
COleDateTime dtScaleMinTime
The scale minimum time.
Definition XTPCalendarOptions.h:163
CXTPCalendarOptions::nWorkWeekMask
int nWorkWeekMask
This structure member represents week working days using XTPCalendarWeekDay enumeration.
Definition XTPCalendarOptions.h:155
CXTPCalendarOptions::bDayView_ScaleRightVisible
BOOL bDayView_ScaleRightVisible
TRUE to show time scale on the right
Definition XTPCalendarOptions.h:192
CXTPCalendarOptions::tziDayView_AdditionalScaleTimeZone
TIME_ZONE_INFORMATION tziDayView_AdditionalScaleTimeZone
Stores time zone information for the secondary time scale.
Definition XTPCalendarOptions.h:199
CXTPCalendarOptions::DoPropExchange
void DoPropExchange(CXTPPropExchange *pPX)
This method reads data from or writes data to storage.
CXTPCalendarOptions::bDayView_AdditionalScaleLeftVisible
BOOL bDayView_AdditionalScaleLeftVisible
TRUE when additional time scale on the left is visible in day view.
Definition XTPCalendarOptions.h:193
CXTPCalendarOptions::dtWorkDayEndTime
COleDateTime dtWorkDayEndTime
This member contains work day end time.
Definition XTPCalendarOptions.h:161
CXTPCalendarOptions::bUseOutlookFontGlyphs
BOOL bUseOutlookFontGlyphs
Set TRUE to use 'MS Outlook' font to display Glyps, otherwise bitmaps are used.
Definition XTPCalendarOptions.h:179
CXTPCalendarOptions::nDayView_CurrentTimeMarkVisible
int nDayView_CurrentTimeMarkVisible
A set of flags which define when Current Time Mark on the timescale is visible.
Definition XTPCalendarOptions.h:202
CXTPCalendarOptions::bEnableInPlaceEditEventSubject_AfterEventResize
BOOL bEnableInPlaceEditEventSubject_AfterEventResize
Set TRUE to enable in-place edit event subject after event resize, FALSE otherwise.
Definition XTPCalendarOptions.h:173
CXTPCalendarOptions::OnOptionsChanged
void OnOptionsChanged()
This member function is called when option was changed.
CXTPCalendarOptions::bMonthView_ShowTimeAsClocks
BOOL bMonthView_ShowTimeAsClocks
TRUE when showing event time as graphical clocks in month view, FALSE otherwise.
Definition XTPCalendarOptions.h:215
CXTPCalendarOptions::dtScaleMaxTime
COleDateTime dtScaleMaxTime
The scale maximum time.
Definition XTPCalendarOptions.h:164
CXTPCalendarOptions::bEnableInPlaceCreateEvent
BOOL bEnableInPlaceCreateEvent
Set TRUE to enable in-place event creation, FALSE otherwise.
Definition XTPCalendarOptions.h:177
CXTPCalendarOptions::bDayView_DrawNowLineOverAppoinment
BOOL bDayView_DrawNowLineOverAppoinment
TRUE to show time line over appointments.
Definition XTPCalendarOptions.h:198
CXTPCalendarOptions::nDayView_ScaleInterval
int nDayView_ScaleInterval
DayView scale interval in minutes.
Definition XTPCalendarOptions.h:187
CXTPCalendarOptions::nFirstDayOfTheWeek
int nFirstDayOfTheWeek
This member shows the first day of the week using XTPCalendarWeekDay enum.
Definition XTPCalendarOptions.h:158
CXTPCalendarOptions::SetDataProvider
void SetDataProvider(CXTPCalendarData *pDataProvider)
This member function sets the custom data provider for the control.
CXTPCalendarOptions::strTooltipAddNewText
CString strTooltipAddNewText
Text for "add new appointment" tooltip.
Definition XTPCalendarOptions.h:241
CXTPCalendarOptions::bEnablePrevNextEventButtons
BOOL bEnablePrevNextEventButtons
TRUE when "Prev/Next Appointment" buttons are enabled, FALSE otherwise.
Definition XTPCalendarOptions.h:245
CXTPCalendarOptions::bShowCategoryIcons
BOOL bShowCategoryIcons
flag to show-hide additional categories icons in event view for day-multicolumn week views
Definition XTPCalendarOptions.h:235
CXTPCalendarOptions::~CXTPCalendarOptions
virtual ~CXTPCalendarOptions()
Default Destructor.
CXTPCalendarOptions::bTimeLineFocused
BOOL bTimeLineFocused
TRUE when showing focused view of timeline.
Definition XTPCalendarOptions.h:229
CXTPCalendarOptions::bDayView_AutoResetBusyFlag
BOOL bDayView_AutoResetBusyFlag
If TRUE - 'Busy' event status will be automatically set to 'Free' when moving event from hours area t...
Definition XTPCalendarOptions.h:183
CXTPCalendarOptions::bEnableAddNewTooltip
BOOL bEnableAddNewTooltip
TRUE when "add new appointment" tooltips appears, FALSE otherwise.
Definition XTPCalendarOptions.h:239
CXTPCalendarOptions::bShowAllDayExpandButton
BOOL bShowAllDayExpandButton
TRUE to show all day header expand buttons when needed.
Definition XTPCalendarOptions.h:208
CXTPCalendarOptions::strDayView_AdditionalScaleLabel
CString strDayView_AdditionalScaleLabel
Stores secondary time scale label (day view)
Definition XTPCalendarOptions.h:190
CXTPCalendarOptions::dwAdditionalOptions
DWORD dwAdditionalOptions
Additional calendar options.
Definition XTPCalendarOptions.h:232
CXTPCalendarOptions::bEnableInPlaceEditEventSubject_ByF2
BOOL bEnableInPlaceEditEventSubject_ByF2
Set TRUE to enable in-place edit event subject by F2, FALSE otherwise.
Definition XTPCalendarOptions.h:166
CXTPCalendarOptions::bMonthView_CompressWeekendDays
BOOL bMonthView_CompressWeekendDays
TRUE when compressing weekend days in month view, FALSE otherwise.
Definition XTPCalendarOptions.h:211
CXTPCalendarOptions::CXTPCalendarOptions
CXTPCalendarOptions()
Default object constructor.
CXTPCalendarOptions::GetCurrentTimeZoneInfo
CXTPCalendarTimeZonePtr GetCurrentTimeZoneInfo()
Get full information about the current time zone.
CXTPCalendarOptions::bWeekView_ShowTimeAsClocks
BOOL bWeekView_ShowTimeAsClocks
TRUE when showing event time as graphical clocks in week view, FALSE otherwise.
Definition XTPCalendarOptions.h:223
CXTPCalendarOptions::dtWorkDayStartTime
COleDateTime dtWorkDayStartTime
This member contains work day start time.
Definition XTPCalendarOptions.h:160
CXTPCalendarOptions::bEnableInPlaceEditEventSubject_ByMouseClick
BOOL bEnableInPlaceEditEventSubject_ByMouseClick
Set TRUE to enable in-place edit event subject by Mouse Click, FALSE otherwise.
Definition XTPCalendarOptions.h:168
CXTPCalendarOptions::m_pDataProvider
CXTPCalendarData * m_pDataProvider
A stored pointer to the owner data provider.
Definition XTPCalendarOptions.h:248
CXTPCalendarOptions::strDayView_ScaleLabel
CString strDayView_ScaleLabel
Stores main time scale label (day view)
Definition XTPCalendarOptions.h:189
CXTPCalendarOptions::bMonthView_HideTimes
BOOL bMonthView_HideTimes
TRUE to suppress drawing time in month view event, FALSE otherwise.
Definition XTPCalendarOptions.h:217
CXTPCalendarOptions::bDayView_AdditionalScaleRightVisible
BOOL bDayView_AdditionalScaleRightVisible
TRUE when additional time scale on the right is visible in day view.
Definition XTPCalendarOptions.h:195
CXTPCalendarOptions::bHatchAllDayViewEventsBkgnd
BOOL bHatchAllDayViewEventsBkgnd
flag to enable-disable all day events cell background color fill or hatch
Definition XTPCalendarOptions.h:233
CXTPCalendarOptions::bDayView_TimeScaleShowMinutes
BOOL bDayView_TimeScaleShowMinutes
If TRUE - minutes will be shown on time scale.
Definition XTPCalendarOptions.h:206
CXTPCalendarOptions::bWeekView_ShowEndDate
BOOL bWeekView_ShowEndDate
TRUE when showing event end date in week view, FALSE otherwise.
Definition XTPCalendarOptions.h:221
CXTPCalendarOptions::bDayView_ScaleLeftVisible
BOOL bDayView_ScaleLeftVisible
TRUE to show time scale on the left
Definition XTPCalendarOptions.h:191
CXTPCalendarOptions::bMonthView_ShowEndDate
BOOL bMonthView_ShowEndDate
TRUE when showing event end date in month view, FALSE otherwise.
Definition XTPCalendarOptions.h:213
CXTPCalendarOptions::bTimeLineCompact
BOOL bTimeLineCompact
TRUE when showing event compatized or not (like Entry List in Outlook)
Definition XTPCalendarOptions.h:227
CXTPCalendarOptions::bEnableInPlaceEditEventSubject_ByTab
BOOL bEnableInPlaceEditEventSubject_ByTab
Set TRUE to enable in-place edit event subject by TAB, FALSE otherwise.
Definition XTPCalendarOptions.h:171
CXTPCalendarTimeZone
This class extends the TIME_ZONE_INFORMATION structure.
Definition XTPCalendarTimeZoneHelper.h:56
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72


Toolkit Pro: XTPTabControl.h Source File

  • Source
  • TabManager
XTPTabControl.h
Go to the documentation of this file.
1
23#if !defined(__XTPTABCONTROL_H__)
24# define __XTPTABCONTROL_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPTabPaintManager;
34class CXTPImageManager;
35class CXTPToolTipContext;
36
44class _XTP_EXT_CLASS CXTPTabControl
45 : public CWnd
46 , public CXTPTabManager
47{
48private:
49 class CTabControlDropTarget;
50
51public:
56 CXTPTabControl();
57
62 virtual ~CXTPTabControl();
63
64public:
79 CXTPTabManagerItem* InsertItem(int nItem, LPCTSTR lpszItem, HWND hwndChild = NULL,
80 int nImage = -1, CXTPTabManagerItem* pAddItem = NULL);
81
95 BOOL Create(DWORD dwStyle, const RECT& rect, CWnd* pParentWnd, UINT nID);
96
97public:
110 virtual CXTPTabPaintManager* GetPaintManager() const;
111
121 virtual void SetPaintManager(CXTPTabPaintManager* pPaintManager);
122
129 virtual void Reposition();
130
140 virtual void RedrawControl(LPCRECT lpRect, BOOL bAnimate);
141
147 virtual void SetSelectedItem(CXTPTabManagerItem* pItem);
148
157 void OnItemClick(CXTPTabManagerItem* pItem);
158
176 virtual BOOL DrawIcon(CDC* pDC, CPoint pt, CXTPTabManagerItem* pItem, BOOL bDraw,
177 CSize& szIcon) const;
178
187 void SetImageList(CImageList* pImageList);
188
198 CXTPImageManager* GetImageManager() const;
199
205 void SetImageManager(CXTPImageManager* pImageManager);
206
213 CXTPToolTipContext* GetToolTipContext() const;
214
227 void EnableToolTips(XTPTabToolTipBehaviour behaviour = xtpTabToolTipAlways);
228
241 void AdjustRect(BOOL bLarger, LPRECT lpRect) const;
242
243public:
254 void SetLockRedraw(BOOL bLockRedraw);
255
263 virtual void SetFocusedItem(CXTPTabManagerItem* pItem);
264
265protected:
279 void OnNavigateButtonClick(CXTPTabManagerNavigateButton* pButton);
280
281 using CXTPTabManager::OnNavigateButtonClick;
282
290 virtual BOOL HeaderHasFocus() const;
291
292protected:
294 DECLARE_MESSAGE_MAP()
295
296 //{{AFX_VIRTUAL(CXTPTabControl)
297 virtual void PreSubclassWindow();
298 BOOL DrawParentBackground(CDC* pDC, CRect rc);
299 virtual INT_PTR OnToolHitTest(CPoint point, TOOLINFO* pTI) const;
300 BOOL OnWndMsg(UINT message, WPARAM wParam, LPARAM lParam, LRESULT* pResult);
301 //}}AFX_VIRTUAL
302
303 //{{AFX_MSG(CXTPTabControl)
304 afx_msg BOOL OnEraseBkgnd(CDC* pDC);
305 afx_msg void OnPaint();
306 afx_msg void OnSize(UINT nType, int cx, int cy);
307 afx_msg void OnLButtonDown(UINT nFlags, CPoint point);
308 afx_msg void OnSysColorChange();
309 afx_msg void OnMouseMove(UINT nFlags, CPoint point);
310 afx_msg void OnMouseLeave();
311 afx_msg void OnKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags);
312 afx_msg void OnSetFocus(CWnd* pOldWnd);
313 afx_msg UINT OnGetDlgCode();
314 afx_msg void OnKillFocus(CWnd* pNewWnd);
315 afx_msg LRESULT OnPrintClient(WPARAM wParam, LPARAM lParam);
316 afx_msg void OnDestroy();
317 //}}AFX_MSG
320protected:
322 BOOL Create(LPCTSTR lpszClassName, LPCTSTR lpszWindowName, DWORD dwStyle, const RECT& rect,
323 CWnd* pParentWnd, UINT nID, CCreateContext* pContext = NULL);
326private:
327 HWND m_hwndClient;
328
329 CXTPTabPaintManager* m_pPaintManager;
330 CXTPImageManager* m_pImageManager;
331 CTabControlDropTarget* m_pDropTarget;
332 CXTPToolTipContext* m_pToolTipContext;
333 int m_nLockRedraw;
334
335 friend class CTabControlDropTarget;
336};
337
339
340AFX_INLINE CXTPTabPaintManager* CXTPTabControl::GetPaintManager() const
341{
342 return m_pPaintManager;
343}
344
345AFX_INLINE CXTPImageManager* CXTPTabControl::GetImageManager() const
346{
347 return m_pImageManager;
348}
349
350AFX_INLINE BOOL CXTPTabControl::Create(LPCTSTR lpszClassName, LPCTSTR lpszWindowName, DWORD dwStyle,
351 const RECT& rect, CWnd* pParentWnd, UINT nID,
352 CCreateContext* pContext)
353{
354 return CWnd::Create(lpszClassName, lpszWindowName, dwStyle, rect, pParentWnd, nID, pContext);
355}
356
357AFX_INLINE CXTPToolTipContext* CXTPTabControl::GetToolTipContext() const
358{
359 return m_pToolTipContext;
360}
361
362# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
364#endif // !defined(__XTPTABCONTROL_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPTabToolTipBehaviour
XTPTabToolTipBehaviour
XTPTabToolTipBehaviour is an enumeration used to set the tooltip behaviour for tabs.
Definition XTPTabManagerDefines.h:240
xtpTabToolTipAlways
@ xtpTabToolTipAlways
Always show tooltips for tabs.
Definition XTPTabManagerDefines.h:242
CXTPImageManager
CXTPImageManager is a standalone class.
Definition XTPImageManager.h:1898
CXTPTabControl
CXTPTabControl is used to draw an enhanced tab control with Office 2003, Visual Studio,...
Definition XTPTabControl.h:47
CXTPTabControl::Create
BOOL Create(DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID)
Creates the tab control.
Definition XTPTabControl.h:350
CXTPTabControl::DrawIcon
virtual BOOL DrawIcon(CDC *pDC, CPoint pt, CXTPTabManagerItem *pItem, BOOL bDraw, CSize &szIcon) const
This method is called when the icon of a tab must be redrawn (e.g.
CXTPTabControl::EnableToolTips
void EnableToolTips(XTPTabToolTipBehaviour behaviour=xtpTabToolTipAlways)
Sets the behaviour for tooltips.
CXTPTabControl::SetImageList
void SetImageList(CImageList *pImageList)
Sets the icons of the tabs.
CXTPTabControl::InsertItem
CXTPTabManagerItem * InsertItem(int nItem, LPCTSTR lpszItem, HWND hwndChild=NULL, int nImage=-1, CXTPTabManagerItem *pAddItem=NULL)
Inserts a tab at a specified index.
CXTPTabControl::OnItemClick
void OnItemClick(CXTPTabManagerItem *pItem)
This method is called when a tab button is clicked to select the tab item that was clicked.
CXTPTabControl::SetLockRedraw
void SetLockRedraw(BOOL bLockRedraw)
Locks/unlocks redrawing controls.
CXTPTabControl::SetPaintManager
virtual void SetPaintManager(CXTPTabPaintManager *pPaintManager)
Sets the tab paint manager.
CXTPTabControl::~CXTPTabControl
virtual ~CXTPTabControl()
Destroys a CXTPTabControl object, handles cleanup and deallocation.
CXTPTabControl::Reposition
virtual void Reposition()
Recalculates the layout of the tab manager and then repositions itself.
CXTPTabControl::RedrawControl
virtual void RedrawControl(LPCRECT lpRect, BOOL bAnimate)
This method is called when the visual properties of the tabs are changed (e.g.
CXTPTabControl::AdjustRect
void AdjustRect(BOOL bLarger, LPRECT lpRect) const
This method will either calculate the window rectangle of a tab control when provided with a display ...
CXTPTabControl::OnNavigateButtonClick
void OnNavigateButtonClick(CXTPTabManagerNavigateButton *pButton)
This method is called when a tab navigation button is clicked.
CXTPTabControl::GetToolTipContext
CXTPToolTipContext * GetToolTipContext() const
Gets the tooltip context.
Definition XTPTabControl.h:357
CXTPTabControl::SetFocusedItem
virtual void SetFocusedItem(CXTPTabManagerItem *pItem)
Sets the focused item.
CXTPTabControl::GetImageManager
CXTPImageManager * GetImageManager() const
Gets the image manager containing the icons of the tabs.
Definition XTPTabControl.h:345
CXTPTabControl::CXTPTabControl
CXTPTabControl()
Constructs a CXTPTabControl object.
CXTPTabControl::SetSelectedItem
virtual void SetSelectedItem(CXTPTabManagerItem *pItem)
Selects a specified tab.
CXTPTabControl::HeaderHasFocus
virtual BOOL HeaderHasFocus() const
The implementation should return TRUE if the header has focus or FALSE otherwise.
CXTPTabControl::SetImageManager
void SetImageManager(CXTPImageManager *pImageManager)
Sets the image manager to contain the icons of the tabs.
CXTPTabManager
CXTPTabManager is the base class for docking pane tabs, tab control tabs, and MDI client tabs.
Definition XTPTabManager.h:87
CXTPTabManager::GetPaintManager
virtual CXTPTabPaintManager * GetPaintManager() const =0
Gets the tab paint manager.
CXTPTabManager::OnNavigateButtonClick
virtual void OnNavigateButtonClick(CXTPTabManagerNavigateButton *pButton)
This method is called when a tab navigation button is clicked.
Definition XTPTabManager.h:1449
CXTPTabManagerItem
CXTPTabManagerItem is the base class for the tabs that appear in the command bars tab workspace,...
Definition XTPTabManagerItem.h:44
CXTPTabManagerNavigateButton
CXTPTabManagerNavigateButton is a class used to represent a tab navigation button.
Definition XTPTabManagerNavigateButton.h:74
CXTPTabPaintManager
CXTPTabPaintManager is used to store the color and appearance information of the tabs in the tab mana...
Definition XTPTabPaintManager.h:48
CXTPToolTipContext
CXTPToolTipContext is a CXTPCmdTarget derived class.
Definition XTPToolTipContext.h:291


Toolkit Pro: Member List

CXTPChartPanelCollection Member List

This is the complete list of members for CXTPChartPanelCollection, including all inherited members.

Add(CXTPChartPanel *pPanel) | CXTPChartPanelCollection |
CXTPChartElement() | CXTPChartElement |
CXTPChartElementCollection() | CXTPChartElementCollection |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartPanelCollection(CXTPChartContent *pOwner) | CXTPChartPanelCollection |
DoPropExchange(CXTPPropExchange *pPX) | CXTPChartPanelCollection | virtual
GetAppearance() const | CXTPChartElement |
GetAt(int nIndex) const | CXTPChartPanelCollection |
GetContent() const | CXTPChartElement |
GetCount() const | CXTPChartElementCollection | virtual
GetOwner() const | CXTPChartElement |
IndexOf(CXTPChartElement *pElement) const | CXTPChartElementCollection |
InsertAt(int nIndex, CXTPChartElement *pElement) | CXTPChartElementCollection |
Is3D() const | CXTPChartObject |
m_arrElements | CXTPChartElementCollection | protected
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartElement | virtual
Release() | CXTPChartElementCollection | virtual
Remove(CXTPChartElement *pElement) | CXTPChartElementCollection | virtual
RemoveAll() | CXTPChartElementCollection | virtual
RemoveAt(int nIndex) | CXTPChartElementCollection | virtual
~CXTPChartElement() | CXTPChartElement | virtual
~CXTPChartElementCollection() | CXTPChartElementCollection |
~CXTPChartPanelCollection() | CXTPChartPanelCollection | virtual


Toolkit Pro: XTPCalendarADO.h Source File

  • Source
  • Calendar
XTPCalendarADO.h
Go to the documentation of this file.
1
23#if !defined(_XTPCALENDARADO_H__)
24# define _XTPCALENDARADO_H__
25
26# if _MSC_VER > 1000
27# pragma once
28# endif // _MSC_VER > 1000
29
30# pragma pack(push, 8)
31
32# if (_MSC_VER <= 1100)
33# pragma warning(disable : 4510 4513 4610 4310 4244)
34# endif
35
36# include "Common/Base/Diagnostic/XTPDisableAdvancedWarnings.h"
37# include <comdef.h>
38
39namespace XTPADOX
40{
41//
42// Forward references and typedefs
43//
44
45struct __declspec(uuid("00000600-0000-0010-8000-00aa006d2ea4"))
46 /* LIBID */ __ADOX;
47struct __declspec(uuid("00000512-0000-0010-8000-00aa006d2ea4"))
48 /* dual interface */ _Collection;
49struct __declspec(uuid("00000513-0000-0010-8000-00aa006d2ea4"))
50 /* dual interface */ _DynaCollection;
51struct __declspec(uuid("00000603-0000-0010-8000-00aa006d2ea4"))
52 /* dual interface */ _Catalog;
53struct __declspec(uuid("00000611-0000-0010-8000-00aa006d2ea4"))
54 /* dual interface */ Tables;
55struct /* coclass */ Table;
56struct __declspec(uuid("00000610-0000-0010-8000-00aa006d2ea4"))
57 /* dual interface */ _Table;
58struct __declspec(uuid("0000061d-0000-0010-8000-00aa006d2ea4"))
59 /* dual interface */ Columns;
60struct /* coclass */ Column;
61struct __declspec(uuid("0000061c-0000-0010-8000-00aa006d2ea4"))
62 /* dual interface */ _Column;
63enum ColumnAttributesEnum;
64enum SortOrderEnum;
65enum DataTypeEnum;
66struct __declspec(uuid("00000504-0000-0010-8000-00aa006d2ea4"))
67 /* dual interface */ Properties;
68struct __declspec(uuid("00000503-0000-0010-8000-00aa006d2ea4"))
69 /* dual interface */ Property;
70struct __declspec(uuid("00000620-0000-0010-8000-00aa006d2ea4"))
71 /* dual interface */ Indexes;
72struct /* coclass */ Index;
73struct __declspec(uuid("0000061f-0000-0010-8000-00aa006d2ea4"))
74 /* dual interface */ _Index;
75enum AllowNullsEnum;
76struct __declspec(uuid("00000623-0000-0010-8000-00aa006d2ea4"))
77 /* dual interface */ Keys;
78struct /* coclass */ Key;
79struct __declspec(uuid("00000622-0000-0010-8000-00aa006d2ea4"))
80 /* dual interface */ _Key;
81enum RuleEnum;
82enum KeyTypeEnum;
83struct __declspec(uuid("00000626-0000-0010-8000-00aa006d2ea4"))
84 /* dual interface */ Procedures;
85struct __declspec(uuid("00000625-0000-0010-8000-00aa006d2ea4"))
86 /* dual interface */ Procedure;
87struct __declspec(uuid("00000614-0000-0010-8000-00aa006d2ea4"))
88 /* dual interface */ Views;
89struct __declspec(uuid("00000613-0000-0010-8000-00aa006d2ea4"))
90 /* dual interface */ View;
91struct __declspec(uuid("00000617-0000-0010-8000-00aa006d2ea4"))
92 /* dual interface */ Groups;
93struct /* coclass */ Group;
94struct __declspec(uuid("00000628-0000-0010-8000-00aa006d2ea4"))
95 /* dual interface */ _Group;
96struct __declspec(uuid("00000616-0000-0010-8000-00aa006d2ea4"))
97 /* dual interface */ _Group25;
98enum ObjectTypeEnum;
99enum RightsEnum;
100enum ActionEnum;
101enum InheritTypeEnum;
102struct __declspec(uuid("0000061a-0000-0010-8000-00aa006d2ea4"))
103 /* dual interface */ Users;
104struct /* coclass */ User;
105struct __declspec(uuid("00000627-0000-0010-8000-00aa006d2ea4"))
106 /* dual interface */ _User;
107struct __declspec(uuid("00000619-0000-0010-8000-00aa006d2ea4"))
108 /* dual interface */ _User25;
109struct /* coclass */ Catalog;
110
111//
112// Smart pointer typedef declarations
113//
114
115_COM_SMARTPTR_TYPEDEF(_Collection, __uuidof(_Collection));
116_COM_SMARTPTR_TYPEDEF(_DynaCollection, __uuidof(_DynaCollection));
117_COM_SMARTPTR_TYPEDEF(Tables, __uuidof(Tables));
118_COM_SMARTPTR_TYPEDEF(Columns, __uuidof(Columns));
119_COM_SMARTPTR_TYPEDEF(Property, __uuidof(Property));
120_COM_SMARTPTR_TYPEDEF(Properties, __uuidof(Properties));
121_COM_SMARTPTR_TYPEDEF(Indexes, __uuidof(Indexes));
122_COM_SMARTPTR_TYPEDEF(_Index, __uuidof(_Index));
123_COM_SMARTPTR_TYPEDEF(Keys, __uuidof(Keys));
124_COM_SMARTPTR_TYPEDEF(_Key, __uuidof(_Key));
125_COM_SMARTPTR_TYPEDEF(Procedure, __uuidof(Procedure));
126_COM_SMARTPTR_TYPEDEF(Procedures, __uuidof(Procedures));
127_COM_SMARTPTR_TYPEDEF(View, __uuidof(View));
128_COM_SMARTPTR_TYPEDEF(Views, __uuidof(Views));
129_COM_SMARTPTR_TYPEDEF(Groups, __uuidof(Groups));
130_COM_SMARTPTR_TYPEDEF(Users, __uuidof(Users));
131_COM_SMARTPTR_TYPEDEF(_Catalog, __uuidof(_Catalog));
132_COM_SMARTPTR_TYPEDEF(_Table, __uuidof(_Table));
133_COM_SMARTPTR_TYPEDEF(_Column, __uuidof(_Column));
134_COM_SMARTPTR_TYPEDEF(_Group25, __uuidof(_Group25));
135_COM_SMARTPTR_TYPEDEF(_Group, __uuidof(_Group));
136_COM_SMARTPTR_TYPEDEF(_User25, __uuidof(_User25));
137_COM_SMARTPTR_TYPEDEF(_User, __uuidof(_User));
138
139//
140// Type library items
141//
142
143struct __declspec(uuid("00000512-0000-0010-8000-00aa006d2ea4")) _Collection : IDispatch
144{
145 //
146 // Property data
147 //
148
149 __declspec(property(get = GetCount)) long Count;
150
151 //
152 // Wrapper methods for error-handling
153 //
154
155 long GetCount();
156 IUnknownPtr _NewEnum();
157 HRESULT Refresh();
158
159 //
160 // Raw methods provided by interface
161 //
162
163 virtual HRESULT __stdcall get_Count(
164 /*[out,retval]*/ long* c) = 0;
165 virtual HRESULT __stdcall raw__NewEnum(
166 /*[out,retval]*/ IUnknown** ppvObject) = 0;
167 virtual HRESULT __stdcall raw_Refresh() = 0;
168};
169
170struct __declspec(uuid("00000513-0000-0010-8000-00aa006d2ea4")) _DynaCollection : _Collection
171{
172 //
173 // Wrapper methods for error-handling
174 //
175
176 HRESULT Append(IDispatch* Object);
177 HRESULT Delete(const _variant_t& Item);
178
179 //
180 // Raw methods provided by interface
181 //
182
183 virtual HRESULT __stdcall raw_Append(
184 /*[in]*/ IDispatch* Object) = 0;
185 virtual HRESULT __stdcall raw_Delete(
186 /*[in]*/ VARIANT Item) = 0;
187};
188
189struct __declspec(uuid("00000609-0000-0010-8000-00aa006d2ea4")) Table;
190// [ default ] interface _Table
191
192struct __declspec(uuid("00000611-0000-0010-8000-00aa006d2ea4")) Tables : _Collection
193{
194 //
195 // Property data
196 //
197
198 __declspec(property(get = GetItem)) _TablePtr Item[];
199
200 //
201 // Wrapper methods for error-handling
202 //
203
204 _TablePtr GetItem(const _variant_t& Item);
205 HRESULT Append(const _variant_t& Item);
206 HRESULT Delete(const _variant_t& Item);
207
208 //
209 // Raw methods provided by interface
210 //
211
212 virtual HRESULT __stdcall get_Item(
213 /*[in]*/ VARIANT Item,
214 /*[out,retval]*/ struct _Table** ppvObject) = 0;
215 virtual HRESULT __stdcall raw_Append(
216 /*[in]*/ VARIANT Item) = 0;
217 virtual HRESULT __stdcall raw_Delete(
218 /*[in]*/ VARIANT Item) = 0;
219};
220
221struct __declspec(uuid("0000061b-0000-0010-8000-00aa006d2ea4")) Column;
222// [ default ] interface _Column
223
224enum ColumnAttributesEnum
225{
226 adColFixed = 1,
227 adColNullable = 2
228};
229
230enum SortOrderEnum
231{
232 adSortAscending = 1,
233 adSortDescending = 2
234};
235
236enum DataTypeEnum
237{
238 adEmpty = 0,
239 adTinyInt = 16,
240 adSmallInt = 2,
241 adInteger = 3,
242 adBigInt = 20,
243 adUnsignedTinyInt = 17,
244 adUnsignedSmallInt = 18,
245 adUnsignedInt = 19,
246 adUnsignedBigInt = 21,
247 adSingle = 4,
248 adDouble = 5,
249 adCurrency = 6,
250 adDecimal = 14,
251 adNumeric = 131,
252 adBoolean = 11,
253 adError = 10,
254 adUserDefined = 132,
255 adVariant = 12,
256 adIDispatch = 9,
257 adIUnknown = 13,
258 adGUID = 72,
259 adDate = 7,
260 adDBDate = 133,
261 adDBTime = 134,
262 adDBTimeStamp = 135,
263 adBSTR = 8,
264 adChar = 129,
265 adVarChar = 200,
266 adLongVarChar = 201,
267 adWChar = 130,
268 adVarWChar = 202,
269 adLongVarWChar = 203,
270 adBinary = 128,
271 adVarBinary = 204,
272 adLongVarBinary = 205,
273 adChapter = 136,
274 adFileTime = 64,
275 adPropVariant = 138,
276 adVarNumeric = 139
277};
278
279struct __declspec(uuid("0000061d-0000-0010-8000-00aa006d2ea4")) Columns : _Collection
280{
281 //
282 // Property data
283 //
284
285 __declspec(property(get = GetItem)) _ColumnPtr Item[];
286
287 //
288 // Wrapper methods for error-handling
289 //
290
291 _ColumnPtr GetItem(const _variant_t& Item);
292 HRESULT Append(const _variant_t& Item, enum DataTypeEnum Type, long DefinedSize);
293 HRESULT Delete(const _variant_t& Item);
294
295 //
296 // Raw methods provided by interface
297 //
298
299 virtual HRESULT __stdcall get_Item(
300 /*[in]*/ VARIANT Item,
301 /*[out,retval]*/ struct _Column** ppvObject) = 0;
302 virtual HRESULT __stdcall raw_Append(
303 /*[in]*/ VARIANT Item,
304 /*[in]*/ enum DataTypeEnum Type,
305 /*[in]*/ long DefinedSize) = 0;
306 virtual HRESULT __stdcall raw_Delete(
307 /*[in]*/ VARIANT Item) = 0;
308};
309
310struct __declspec(uuid("00000503-0000-0010-8000-00aa006d2ea4")) Property : IDispatch
311{
312 //
313 // Property data
314 //
315
316 __declspec(property(get = GetValue, put = PutValue)) _variant_t Value;
317 __declspec(property(get = GetName)) _bstr_t Name;
318 __declspec(property(get = GetType)) enum DataTypeEnum Type;
319 __declspec(property(get = GetAttributes, put = PutAttributes)) long Attributes;
320
321 //
322 // Wrapper methods for error-handling
323 //
324
325 _variant_t GetValue();
326 void PutValue(const _variant_t& pVal);
327 _bstr_t GetName();
328 enum DataTypeEnum GetType();
329 long GetAttributes();
330 void PutAttributes(long plAttributes);
331
332 //
333 // Raw methods provided by interface
334 //
335
336 virtual HRESULT __stdcall get_Value(
337 /*[out,retval]*/ VARIANT* pVal) = 0;
338 virtual HRESULT __stdcall put_Value(
339 /*[in]*/ VARIANT pVal) = 0;
340 virtual HRESULT __stdcall get_Name(
341 /*[out,retval]*/ BSTR* pbstr) = 0;
342 virtual HRESULT __stdcall get_Type(
343 /*[out,retval]*/ enum DataTypeEnum* ptype) = 0;
344 virtual HRESULT __stdcall get_Attributes(
345 /*[out,retval]*/ long* plAttributes) = 0;
346 virtual HRESULT __stdcall put_Attributes(
347 /*[in]*/ long plAttributes) = 0;
348};
349
350struct __declspec(uuid("00000504-0000-0010-8000-00aa006d2ea4")) Properties : _Collection
351{
352 //
353 // Property data
354 //
355
356 __declspec(property(get = GetItem)) PropertyPtr Item[];
357
358 //
359 // Wrapper methods for error-handling
360 //
361
362 PropertyPtr GetItem(const _variant_t& Item);
363
364 //
365 // Raw methods provided by interface
366 //
367
368 virtual HRESULT __stdcall get_Item(
369 /*[in]*/ VARIANT Item,
370 /*[out,retval]*/ struct Property** ppvObject) = 0;
371};
372
373struct __declspec(uuid("0000061e-0000-0010-8000-00aa006d2ea4")) Index;
374// [ default ] interface _Index
375
376struct __declspec(uuid("00000620-0000-0010-8000-00aa006d2ea4")) Indexes : _Collection
377{
378 //
379 // Property data
380 //
381
382 __declspec(property(get = GetItem)) _IndexPtr Item[];
383
384 //
385 // Wrapper methods for error-handling
386 //
387
388 _IndexPtr GetItem(const _variant_t& Item);
389 HRESULT Append(const _variant_t& Item, const _variant_t& Columns = vtMissing);
390 HRESULT Delete(const _variant_t& Item);
391
392 //
393 // Raw methods provided by interface
394 //
395
396 virtual HRESULT __stdcall get_Item(
397 /*[in]*/ VARIANT Item,
398 /*[out,retval]*/ struct _Index** ppvObject) = 0;
399 virtual HRESULT __stdcall raw_Append(
400 /*[in]*/ VARIANT Item,
401 /*[in]*/ VARIANT Columns = vtMissing) = 0;
402 virtual HRESULT __stdcall raw_Delete(
403 /*[in]*/ VARIANT Item) = 0;
404};
405
406enum AllowNullsEnum
407{
408 adIndexNullsAllow = 0,
409 adIndexNullsDisallow = 1,
410 adIndexNullsIgnore = 2,
411 adIndexNullsIgnoreAny = 4
412};
413
414struct __declspec(uuid("0000061f-0000-0010-8000-00aa006d2ea4")) _Index : IDispatch
415{
416 //
417 // Property data
418 //
419
420 __declspec(property(get = GetName, put = PutName)) _bstr_t Name;
421 __declspec(property(get = GetClustered, put = PutClustered)) VARIANT_BOOL Clustered;
422 __declspec(property(get = GetIndexNulls, put = PutIndexNulls)) enum AllowNullsEnum IndexNulls;
423 __declspec(property(get = GetPrimaryKey, put = PutPrimaryKey)) VARIANT_BOOL PrimaryKey;
424 __declspec(property(get = GetUnique, put = PutUnique)) VARIANT_BOOL Unique;
425 __declspec(property(get = GetColumns)) ColumnsPtr Columns;
426 __declspec(property(get = GetProperties)) PropertiesPtr Properties;
427
428 //
429 // Wrapper methods for error-handling
430 //
431
432 _bstr_t GetName();
433 void PutName(_bstr_t pVal);
434 VARIANT_BOOL GetClustered();
435 void PutClustered(VARIANT_BOOL pVal);
436 enum AllowNullsEnum GetIndexNulls();
437 void PutIndexNulls(enum AllowNullsEnum pVal);
438 VARIANT_BOOL GetPrimaryKey();
439 void PutPrimaryKey(VARIANT_BOOL pVal);
440 VARIANT_BOOL GetUnique();
441 void PutUnique(VARIANT_BOOL pVal);
442 ColumnsPtr GetColumns();
443 PropertiesPtr GetProperties();
444
445 //
446 // Raw methods provided by interface
447 //
448
449 virtual HRESULT __stdcall get_Name(
450 /*[out,retval]*/ BSTR* pVal) = 0;
451 virtual HRESULT __stdcall put_Name(
452 /*[in]*/ BSTR pVal) = 0;
453 virtual HRESULT __stdcall get_Clustered(
454 /*[out,retval]*/ VARIANT_BOOL* pVal) = 0;
455 virtual HRESULT __stdcall put_Clustered(
456 /*[in]*/ VARIANT_BOOL pVal) = 0;
457 virtual HRESULT __stdcall get_IndexNulls(
458 /*[out,retval]*/ enum AllowNullsEnum* pVal) = 0;
459 virtual HRESULT __stdcall put_IndexNulls(
460 /*[in]*/ enum AllowNullsEnum pVal) = 0;
461 virtual HRESULT __stdcall get_PrimaryKey(
462 /*[out,retval]*/ VARIANT_BOOL* pVal) = 0;
463 virtual HRESULT __stdcall put_PrimaryKey(
464 /*[in]*/ VARIANT_BOOL pVal) = 0;
465 virtual HRESULT __stdcall get_Unique(
466 /*[out,retval]*/ VARIANT_BOOL* pVal) = 0;
467 virtual HRESULT __stdcall put_Unique(
468 /*[in]*/ VARIANT_BOOL pVal) = 0;
469 virtual HRESULT __stdcall get_Columns(
470 /*[out,retval]*/ struct Columns** ppvObject) = 0;
471 virtual HRESULT __stdcall get_Properties(
472 /*[out,retval]*/ struct Properties** ppvObject) = 0;
473};
474
475struct __declspec(uuid("00000621-0000-0010-8000-00aa006d2ea4")) Key;
476// [ default ] interface _Key
477
478enum RuleEnum
479{
480 adRINone = 0,
481 adRICascade = 1,
482 adRISetNull = 2,
483 adRISetDefault = 3
484};
485
486enum KeyTypeEnum
487{
488 adKeyPrimary = 1,
489 adKeyForeign = 2,
490 adKeyUnique = 3
491};
492
493struct __declspec(uuid("00000623-0000-0010-8000-00aa006d2ea4")) Keys : _Collection
494{
495 //
496 // Property data
497 //
498
499 __declspec(property(get = GetItem)) _KeyPtr Item[];
500
501 //
502 // Wrapper methods for error-handling
503 //
504
505 _KeyPtr GetItem(const _variant_t& Item);
506 HRESULT Append(const _variant_t& Item, enum KeyTypeEnum Type, const _variant_t& Column,
507 _bstr_t RelatedTable, _bstr_t RelatedColumn);
508 HRESULT Delete(const _variant_t& Item);
509
510 //
511 // Raw methods provided by interface
512 //
513
514 virtual HRESULT __stdcall get_Item(
515 /*[in]*/ VARIANT Item,
516 /*[out,retval]*/ struct _Key** ppvObject) = 0;
517 virtual HRESULT __stdcall raw_Append(
518 /*[in]*/ VARIANT Item,
519 /*[in]*/ enum KeyTypeEnum Type,
520 /*[in]*/ VARIANT Column,
521 /*[in]*/ BSTR RelatedTable,
522 /*[in]*/ BSTR RelatedColumn) = 0;
523 virtual HRESULT __stdcall raw_Delete(
524 /*[in]*/ VARIANT Item) = 0;
525};
526
527struct __declspec(uuid("00000622-0000-0010-8000-00aa006d2ea4")) _Key : IDispatch
528{
529 //
530 // Property data
531 //
532
533 __declspec(property(get = GetName, put = PutName)) _bstr_t Name;
534 __declspec(property(get = GetDeleteRule, put = PutDeleteRule)) enum RuleEnum DeleteRule;
535 __declspec(property(get = GetType, put = PutType)) enum KeyTypeEnum Type;
536 __declspec(property(get = GetRelatedTable, put = PutRelatedTable)) _bstr_t RelatedTable;
537 __declspec(property(get = GetUpdateRule, put = PutUpdateRule)) enum RuleEnum UpdateRule;
538 __declspec(property(get = GetColumns)) ColumnsPtr Columns;
539
540 //
541 // Wrapper methods for error-handling
542 //
543
544 _bstr_t GetName();
545 void PutName(_bstr_t pVal);
546 enum RuleEnum GetDeleteRule();
547 void PutDeleteRule(enum RuleEnum pVal);
548 enum KeyTypeEnum GetType();
549 void PutType(enum KeyTypeEnum pVal);
550 _bstr_t GetRelatedTable();
551 void PutRelatedTable(_bstr_t pVal);
552 enum RuleEnum GetUpdateRule();
553 void PutUpdateRule(enum RuleEnum pVal);
554 ColumnsPtr GetColumns();
555
556 //
557 // Raw methods provided by interface
558 //
559
560 virtual HRESULT __stdcall get_Name(
561 /*[out,retval]*/ BSTR* pVal) = 0;
562 virtual HRESULT __stdcall put_Name(
563 /*[in]*/ BSTR pVal) = 0;
564 virtual HRESULT __stdcall get_DeleteRule(
565 /*[out,retval]*/ enum RuleEnum* pVal) = 0;
566 virtual HRESULT __stdcall put_DeleteRule(
567 /*[in]*/ enum RuleEnum pVal) = 0;
568 virtual HRESULT __stdcall get_Type(
569 /*[out,retval]*/ enum KeyTypeEnum* pVal) = 0;
570 virtual HRESULT __stdcall put_Type(
571 /*[in]*/ enum KeyTypeEnum pVal) = 0;
572 virtual HRESULT __stdcall get_RelatedTable(
573 /*[out,retval]*/ BSTR* pVal) = 0;
574 virtual HRESULT __stdcall put_RelatedTable(
575 /*[in]*/ BSTR pVal) = 0;
576 virtual HRESULT __stdcall get_UpdateRule(
577 /*[out,retval]*/ enum RuleEnum* pVal) = 0;
578 virtual HRESULT __stdcall put_UpdateRule(
579 /*[in]*/ enum RuleEnum pVal) = 0;
580 virtual HRESULT __stdcall get_Columns(
581 /*[out,retval]*/ struct Columns** ppvObject) = 0;
582};
583
584struct __declspec(uuid("00000625-0000-0010-8000-00aa006d2ea4")) Procedure : IDispatch
585{
586 //
587 // Property data
588 //
589
590 __declspec(property(get = GetName)) _bstr_t Name;
591 __declspec(property(get = GetDateCreated)) _variant_t DateCreated;
592 __declspec(property(get = GetDateModified)) _variant_t DateModified;
593
594 //
595 // Wrapper methods for error-handling
596 //
597
598 _variant_t GetCommand();
599 void PutCommand(const _variant_t& pVar);
600 void PutRefCommand(IDispatch* pVar);
601 _bstr_t GetName();
602 _variant_t GetDateCreated();
603 _variant_t GetDateModified();
604
605 //
606 // Raw methods provided by interface
607 //
608
609 virtual HRESULT __stdcall get_Command(
610 /*[out,retval]*/ VARIANT* pVar) = 0;
611 virtual HRESULT __stdcall put_Command(
612 /*[in]*/ VARIANT pVar) = 0;
613 virtual HRESULT __stdcall putref_Command(
614 /*[in]*/ IDispatch* pVar) = 0;
615 virtual HRESULT __stdcall get_Name(
616 /*[out,retval]*/ BSTR* pVal) = 0;
617 virtual HRESULT __stdcall get_DateCreated(
618 /*[out,retval]*/ VARIANT* pVal) = 0;
619 virtual HRESULT __stdcall get_DateModified(
620 /*[out,retval]*/ VARIANT* pVal) = 0;
621};
622
623struct __declspec(uuid("00000626-0000-0010-8000-00aa006d2ea4")) Procedures : _Collection
624{
625 //
626 // Property data
627 //
628
629 __declspec(property(get = GetItem)) ProcedurePtr Item[];
630
631 //
632 // Wrapper methods for error-handling
633 //
634
635 ProcedurePtr GetItem(const _variant_t& Item);
636 HRESULT Append(_bstr_t Name, IDispatch* Command);
637 HRESULT Delete(const _variant_t& Item);
638
639 //
640 // Raw methods provided by interface
641 //
642
643 virtual HRESULT __stdcall get_Item(
644 /*[in]*/ VARIANT Item,
645 /*[out,retval]*/ struct Procedure** ppvObject) = 0;
646 virtual HRESULT __stdcall raw_Append(
647 /*[in]*/ BSTR Name,
648 /*[in]*/ IDispatch* Command) = 0;
649 virtual HRESULT __stdcall raw_Delete(
650 /*[in]*/ VARIANT Item) = 0;
651};
652
653struct __declspec(uuid("00000613-0000-0010-8000-00aa006d2ea4")) View : IDispatch
654{
655 //
656 // Property data
657 //
658
659 __declspec(property(get = GetName)) _bstr_t Name;
660 __declspec(property(get = GetDateCreated)) _variant_t DateCreated;
661 __declspec(property(get = GetDateModified)) _variant_t DateModified;
662
663 //
664 // Wrapper methods for error-handling
665 //
666
667 _variant_t GetCommand();
668 void PutCommand(const _variant_t& pVal);
669 void PutRefCommand(IDispatch* pVal);
670 _bstr_t GetName();
671 _variant_t GetDateCreated();
672 _variant_t GetDateModified();
673
674 //
675 // Raw methods provided by interface
676 //
677
678 virtual HRESULT __stdcall get_Command(
679 /*[out,retval]*/ VARIANT* pVal) = 0;
680 virtual HRESULT __stdcall put_Command(
681 /*[in]*/ VARIANT pVal) = 0;
682 virtual HRESULT __stdcall putref_Command(
683 /*[in]*/ IDispatch* pVal) = 0;
684 virtual HRESULT __stdcall get_Name(
685 /*[out,retval]*/ BSTR* pVal) = 0;
686 virtual HRESULT __stdcall get_DateCreated(
687 /*[out,retval]*/ VARIANT* pVal) = 0;
688 virtual HRESULT __stdcall get_DateModified(
689 /*[out,retval]*/ VARIANT* pVal) = 0;
690};
691
692struct __declspec(uuid("00000614-0000-0010-8000-00aa006d2ea4")) Views : _Collection
693{
694 //
695 // Property data
696 //
697
698 __declspec(property(get = GetItem)) ViewPtr Item[];
699
700 //
701 // Wrapper methods for error-handling
702 //
703
704 ViewPtr GetItem(const _variant_t& Item);
705 HRESULT Append(_bstr_t Name, IDispatch* Command);
706 HRESULT Delete(const _variant_t& Item);
707
708 //
709 // Raw methods provided by interface
710 //
711
712 virtual HRESULT __stdcall get_Item(
713 /*[in]*/ VARIANT Item,
714 /*[out,retval]*/ struct View** ppvObject) = 0;
715 virtual HRESULT __stdcall raw_Append(
716 /*[in]*/ BSTR Name,
717 /*[in]*/ IDispatch* Command) = 0;
718 virtual HRESULT __stdcall raw_Delete(
719 /*[in]*/ VARIANT Item) = 0;
720};
721
722struct __declspec(uuid("00000615-0000-0010-8000-00aa006d2ea4")) Group;
723// [ default ] interface _Group
724
725struct __declspec(uuid("00000617-0000-0010-8000-00aa006d2ea4")) Groups : _Collection
726{
727 //
728 // Property data
729 //
730
731 __declspec(property(get = GetItem)) _GroupPtr Item[];
732
733 //
734 // Wrapper methods for error-handling
735 //
736
737 _GroupPtr GetItem(const _variant_t& Item);
738 HRESULT Append(const _variant_t& Item);
739 HRESULT Delete(const _variant_t& Item);
740
741 //
742 // Raw methods provided by interface
743 //
744
745 virtual HRESULT __stdcall get_Item(
746 /*[in]*/ VARIANT Item,
747 /*[out,retval]*/ struct _Group** ppvObject) = 0;
748 virtual HRESULT __stdcall raw_Append(
749 /*[in]*/ VARIANT Item) = 0;
750 virtual HRESULT __stdcall raw_Delete(
751 /*[in]*/ VARIANT Item) = 0;
752};
753
754enum ObjectTypeEnum
755{
756 adPermObjProviderSpecific = -1,
757 adPermObjTable = 1,
758 adPermObjColumn = 2,
759 adPermObjDatabase = 3,
760 adPermObjProcedure = 4,
761 adPermObjView = 5
762};
763
764enum RightsEnum
765{
766 adRightNone = 0,
767 adRightDrop = 256,
768 adRightExclusive = 512,
769 adRightReadDesign = 1024,
770 adRightWriteDesign = 2048,
771 adRightWithGrant = 4096,
772 adRightReference = 8192,
773 adRightCreate = 16384,
774 adRightInsert = 32768,
775 adRightDelete = 65536,
776 adRightReadPermissions = 131072,
777 adRightWritePermissions = 262144,
778 adRightWriteOwner = 524288,
779 adRightMaximumAllowed = 33554432,
780 adRightFull = 268435456,
781 adRightExecute = 536870912,
782 adRightUpdate = 1073741824,
783 adRightRead = 0x80000000
784};
785
786enum ActionEnum
787{
788 adAccessGrant = 1,
789 adAccessSet = 2,
790 adAccessDeny = 3,
791 adAccessRevoke = 4
792};
793
794enum InheritTypeEnum
795{
796 adInheritNone = 0,
797 adInheritObjects = 1,
798 adInheritContainers = 2,
799 adInheritBoth = 3,
800 adInheritNoPropogate = 4
801};
802
803struct __declspec(uuid("00000618-0000-0010-8000-00aa006d2ea4")) User;
804// [ default ] interface _User
805
806struct __declspec(uuid("0000061a-0000-0010-8000-00aa006d2ea4")) Users : _Collection
807{
808 //
809 // Property data
810 //
811
812 __declspec(property(get = GetItem)) _UserPtr Item[];
813
814 //
815 // Wrapper methods for error-handling
816 //
817
818 _UserPtr GetItem(const _variant_t& Item);
819 HRESULT Append(const _variant_t& Item, _bstr_t Password);
820 HRESULT Delete(const _variant_t& Item);
821
822 //
823 // Raw methods provided by interface
824 //
825
826 virtual HRESULT __stdcall get_Item(
827 /*[in]*/ VARIANT Item,
828 /*[out,retval]*/ struct _User** ppvObject) = 0;
829 virtual HRESULT __stdcall raw_Append(
830 /*[in]*/ VARIANT Item,
831 /*[in]*/ BSTR Password) = 0;
832 virtual HRESULT __stdcall raw_Delete(
833 /*[in]*/ VARIANT Item) = 0;
834};
835
836struct __declspec(uuid("00000603-0000-0010-8000-00aa006d2ea4")) _Catalog : IDispatch
837{
838 //
839 // Property data
840 //
841
842 __declspec(property(get = GetTables)) TablesPtr Tables;
843 __declspec(property(get = GetProcedures)) ProceduresPtr Procedures;
844 __declspec(property(get = GetViews)) ViewsPtr Views;
845 __declspec(property(get = GetGroups)) GroupsPtr Groups;
846 __declspec(property(get = GetUsers)) UsersPtr Users;
847
848 //
849 // Wrapper methods for error-handling
850 //
851
852 TablesPtr GetTables();
853 _variant_t GetActiveConnection();
854 void PutActiveConnection(const _variant_t& pVal);
855 void PutRefActiveConnection(IDispatch* pVal);
856 ProceduresPtr GetProcedures();
857 ViewsPtr GetViews();
858 GroupsPtr GetGroups();
859 UsersPtr GetUsers();
860 _variant_t Create(_bstr_t ConnectString);
861 _bstr_t GetObjectOwner(_bstr_t ObjectName, enum ObjectTypeEnum ObjectType,
862 const _variant_t& ObjectTypeId = vtMissing);
863 HRESULT SetObjectOwner(_bstr_t ObjectName, enum ObjectTypeEnum ObjectType, _bstr_t UserName,
864 const _variant_t& ObjectTypeId = vtMissing);
865
866 //
867 // Raw methods provided by interface
868 //
869
870 virtual HRESULT __stdcall get_Tables(
871 /*[out,retval]*/ struct Tables** ppvObject) = 0;
872 virtual HRESULT __stdcall get_ActiveConnection(
873 /*[out,retval]*/ VARIANT* pVal) = 0;
874 virtual HRESULT __stdcall put_ActiveConnection(
875 /*[in]*/ VARIANT pVal) = 0;
876 virtual HRESULT __stdcall putref_ActiveConnection(
877 /*[in]*/ IDispatch* pVal) = 0;
878 virtual HRESULT __stdcall get_Procedures(
879 /*[out,retval]*/ struct Procedures** ppvObject) = 0;
880 virtual HRESULT __stdcall get_Views(
881 /*[out,retval]*/ struct Views** ppvObject) = 0;
882 virtual HRESULT __stdcall get_Groups(
883 /*[out,retval]*/ struct Groups** ppvObject) = 0;
884 virtual HRESULT __stdcall get_Users(
885 /*[out,retval]*/ struct Users** ppvObject) = 0;
886 virtual HRESULT __stdcall raw_Create(
887 /*[in]*/ BSTR ConnectString,
888 /*[out,retval]*/ VARIANT* Connection) = 0;
889 virtual HRESULT __stdcall raw_GetObjectOwner(
890 /*[in]*/ BSTR ObjectName,
891 /*[in]*/ enum ObjectTypeEnum ObjectType,
892 /*[in]*/ VARIANT ObjectTypeId,
893 /*[out,retval]*/ BSTR* OwnerName) = 0;
894 virtual HRESULT __stdcall raw_SetObjectOwner(
895 /*[in]*/ BSTR ObjectName,
896 /*[in]*/ enum ObjectTypeEnum ObjectType,
897 /*[in]*/ BSTR UserName,
898 /*[in]*/ VARIANT ObjectTypeId = vtMissing) = 0;
899};
900
901struct __declspec(uuid("00000610-0000-0010-8000-00aa006d2ea4")) _Table : IDispatch
902{
903 //
904 // Property data
905 //
906
907 __declspec(property(get = GetColumns)) ColumnsPtr Columns;
908 __declspec(property(get = GetName, put = PutName)) _bstr_t Name;
909 __declspec(property(get = GetType)) _bstr_t Type;
910 __declspec(property(get = GetIndexes)) IndexesPtr Indexes;
911 __declspec(property(get = GetKeys)) KeysPtr Keys;
912 __declspec(property(get = GetProperties)) PropertiesPtr Properties;
913 __declspec(property(get = GetDateCreated)) _variant_t DateCreated;
914 __declspec(property(get = GetDateModified)) _variant_t DateModified;
915 __declspec(property(get = GetParentCatalog,
916 put = PutRefParentCatalog)) _CatalogPtr ParentCatalog;
917
918 //
919 // Wrapper methods for error-handling
920 //
921
922 ColumnsPtr GetColumns();
923 _bstr_t GetName();
924 void PutName(_bstr_t pVal);
925 _bstr_t GetType();
926 IndexesPtr GetIndexes();
927 KeysPtr GetKeys();
928 PropertiesPtr GetProperties();
929 _variant_t GetDateCreated();
930 _variant_t GetDateModified();
931 _CatalogPtr GetParentCatalog();
932 void PutParentCatalog(struct _Catalog* ppvObject);
933 void PutRefParentCatalog(struct _Catalog* ppvObject);
934
935 //
936 // Raw methods provided by interface
937 //
938
939 virtual HRESULT __stdcall get_Columns(
940 /*[out,retval]*/ struct Columns** ppvObject) = 0;
941 virtual HRESULT __stdcall get_Name(
942 /*[out,retval]*/ BSTR* pVal) = 0;
943 virtual HRESULT __stdcall put_Name(
944 /*[in]*/ BSTR pVal) = 0;
945 virtual HRESULT __stdcall get_Type(
946 /*[out,retval]*/ BSTR* pVal) = 0;
947 virtual HRESULT __stdcall get_Indexes(
948 /*[out,retval]*/ struct Indexes** ppvObject) = 0;
949 virtual HRESULT __stdcall get_Keys(
950 /*[out,retval]*/ struct Keys** ppvObject) = 0;
951 virtual HRESULT __stdcall get_Properties(
952 /*[out,retval]*/ struct Properties** ppvObject) = 0;
953 virtual HRESULT __stdcall get_DateCreated(
954 /*[out,retval]*/ VARIANT* pVal) = 0;
955 virtual HRESULT __stdcall get_DateModified(
956 /*[out,retval]*/ VARIANT* pVal) = 0;
957 virtual HRESULT __stdcall get_ParentCatalog(
958 /*[out,retval]*/ struct _Catalog** ppvObject) = 0;
959 virtual HRESULT __stdcall put_ParentCatalog(
960 /*[in]*/ struct _Catalog* ppvObject) = 0;
961 virtual HRESULT __stdcall putref_ParentCatalog(
962 /*[in]*/ struct _Catalog* ppvObject) = 0;
963};
964
965struct __declspec(uuid("0000061c-0000-0010-8000-00aa006d2ea4")) _Column : IDispatch
966{
967 //
968 // Property data
969 //
970
971 __declspec(property(get = GetName, put = PutName)) _bstr_t Name;
972 __declspec(property(get = GetAttributes,
973 put = PutAttributes)) enum ColumnAttributesEnum Attributes;
974 __declspec(property(get = GetDefinedSize, put = PutDefinedSize)) long DefinedSize;
975 __declspec(property(get = GetNumericScale, put = PutNumericScale)) unsigned char NumericScale;
976 __declspec(property(get = GetPrecision, put = PutPrecision)) long Precision;
977 __declspec(property(get = GetRelatedColumn, put = PutRelatedColumn)) _bstr_t RelatedColumn;
978 __declspec(property(get = GetSortOrder, put = PutSortOrder)) enum SortOrderEnum SortOrder;
979 __declspec(property(get = GetType, put = PutType)) enum DataTypeEnum Type;
980 __declspec(property(get = GetProperties)) PropertiesPtr Properties;
981 __declspec(property(get = GetParentCatalog,
982 put = PutRefParentCatalog)) _CatalogPtr ParentCatalog;
983
984 //
985 // Wrapper methods for error-handling
986 //
987
988 _bstr_t GetName();
989 void PutName(_bstr_t pVal);
990 enum ColumnAttributesEnum GetAttributes();
991 void PutAttributes(enum ColumnAttributesEnum pVal);
992 long GetDefinedSize();
993 void PutDefinedSize(long pVal);
994 unsigned char GetNumericScale();
995 void PutNumericScale(unsigned char pVal);
996 long GetPrecision();
997 void PutPrecision(long pVal);
998 _bstr_t GetRelatedColumn();
999 void PutRelatedColumn(_bstr_t pVal);
1000 enum SortOrderEnum GetSortOrder();
1001 void PutSortOrder(enum SortOrderEnum pVal);
1002 enum DataTypeEnum GetType();
1003 void PutType(enum DataTypeEnum pVal);
1004 PropertiesPtr GetProperties();
1005 _CatalogPtr GetParentCatalog();
1006 void PutParentCatalog(struct _Catalog* ppvObject);
1007 void PutRefParentCatalog(struct _Catalog* ppvObject);
1008
1009 //
1010 // Raw methods provided by interface
1011 //
1012
1013 virtual HRESULT __stdcall get_Name(
1014 /*[out,retval]*/ BSTR* pVal) = 0;
1015 virtual HRESULT __stdcall put_Name(
1016 /*[in]*/ BSTR pVal) = 0;
1017 virtual HRESULT __stdcall get_Attributes(
1018 /*[out,retval]*/ enum ColumnAttributesEnum* pVal) = 0;
1019 virtual HRESULT __stdcall put_Attributes(
1020 /*[in]*/ enum ColumnAttributesEnum pVal) = 0;
1021 virtual HRESULT __stdcall get_DefinedSize(
1022 /*[out,retval]*/ long* pVal) = 0;
1023 virtual HRESULT __stdcall put_DefinedSize(
1024 /*[in]*/ long pVal) = 0;
1025 virtual HRESULT __stdcall get_NumericScale(
1026 /*[out,retval]*/ unsigned char* pVal) = 0;
1027 virtual HRESULT __stdcall put_NumericScale(
1028 /*[in]*/ unsigned char pVal) = 0;
1029 virtual HRESULT __stdcall get_Precision(
1030 /*[out,retval]*/ long* pVal) = 0;
1031 virtual HRESULT __stdcall put_Precision(
1032 /*[in]*/ long pVal) = 0;
1033 virtual HRESULT __stdcall get_RelatedColumn(
1034 /*[out,retval]*/ BSTR* pVal) = 0;
1035 virtual HRESULT __stdcall put_RelatedColumn(
1036 /*[in]*/ BSTR pVal) = 0;
1037 virtual HRESULT __stdcall get_SortOrder(
1038 /*[out,retval]*/ enum SortOrderEnum* pVal) = 0;
1039 virtual HRESULT __stdcall put_SortOrder(
1040 /*[in]*/ enum SortOrderEnum pVal) = 0;
1041 virtual HRESULT __stdcall get_Type(
1042 /*[out,retval]*/ enum DataTypeEnum* pVal) = 0;
1043 virtual HRESULT __stdcall put_Type(
1044 /*[in]*/ enum DataTypeEnum pVal) = 0;
1045 virtual HRESULT __stdcall get_Properties(
1046 /*[out,retval]*/ struct Properties** ppvObject) = 0;
1047 virtual HRESULT __stdcall get_ParentCatalog(
1048 /*[out,retval]*/ struct _Catalog** ppvObject) = 0;
1049 virtual HRESULT __stdcall put_ParentCatalog(
1050 /*[in]*/ struct _Catalog* ppvObject) = 0;
1051 virtual HRESULT __stdcall putref_ParentCatalog(
1052 /*[in]*/ struct _Catalog* ppvObject) = 0;
1053};
1054
1055struct __declspec(uuid("00000616-0000-0010-8000-00aa006d2ea4")) _Group25 : IDispatch
1056{
1057 //
1058 // Property data
1059 //
1060
1061 __declspec(property(get = GetName, put = PutName)) _bstr_t Name;
1062 __declspec(property(get = GetUsers)) UsersPtr Users;
1063
1064 //
1065 // Wrapper methods for error-handling
1066 //
1067
1068 _bstr_t GetName();
1069 void PutName(_bstr_t pVal);
1070 enum RightsEnum GetPermissions(const _variant_t& Name, enum ObjectTypeEnum ObjectType,
1071 const _variant_t& ObjectTypeId = vtMissing);
1072 HRESULT SetPermissions(const _variant_t& Name, enum ObjectTypeEnum ObjectType,
1073 enum ActionEnum Action, enum RightsEnum Rights,
1074 enum InheritTypeEnum Inherit,
1075 const _variant_t& ObjectTypeId = vtMissing);
1076 UsersPtr GetUsers();
1077
1078 //
1079 // Raw methods provided by interface
1080 //
1081
1082 virtual HRESULT __stdcall get_Name(
1083 /*[out,retval]*/ BSTR* pVal) = 0;
1084 virtual HRESULT __stdcall put_Name(
1085 /*[in]*/ BSTR pVal) = 0;
1086 virtual HRESULT __stdcall raw_GetPermissions(
1087 /*[in]*/ VARIANT Name,
1088 /*[in]*/ enum ObjectTypeEnum ObjectType,
1089 /*[in]*/ VARIANT ObjectTypeId,
1090 /*[out,retval]*/ enum RightsEnum* Rights) = 0;
1091 virtual HRESULT __stdcall raw_SetPermissions(
1092 /*[in]*/ VARIANT Name,
1093 /*[in]*/ enum ObjectTypeEnum ObjectType,
1094 /*[in]*/ enum ActionEnum Action,
1095 /*[in]*/ enum RightsEnum Rights,
1096 /*[in]*/ enum InheritTypeEnum Inherit,
1097 /*[in]*/ VARIANT ObjectTypeId = vtMissing) = 0;
1098 virtual HRESULT __stdcall get_Users(
1099 /*[out,retval]*/ struct Users** ppvObject) = 0;
1100};
1101
1102struct __declspec(uuid("00000628-0000-0010-8000-00aa006d2ea4")) _Group : _Group25
1103{
1104 //
1105 // Property data
1106 //
1107
1108 __declspec(property(get = GetProperties)) PropertiesPtr Properties;
1109 __declspec(property(get = GetParentCatalog,
1110 put = PutRefParentCatalog)) _CatalogPtr ParentCatalog;
1111
1112 //
1113 // Wrapper methods for error-handling
1114 //
1115
1116 PropertiesPtr GetProperties();
1117 _CatalogPtr GetParentCatalog();
1118 void PutParentCatalog(struct _Catalog* ppvObject);
1119 void PutRefParentCatalog(struct _Catalog* ppvObject);
1120
1121 //
1122 // Raw methods provided by interface
1123 //
1124
1125 virtual HRESULT __stdcall get_Properties(
1126 /*[out,retval]*/ struct Properties** ppvObject) = 0;
1127 virtual HRESULT __stdcall get_ParentCatalog(
1128 /*[out,retval]*/ struct _Catalog** ppvObject) = 0;
1129 virtual HRESULT __stdcall put_ParentCatalog(
1130 /*[in]*/ struct _Catalog* ppvObject) = 0;
1131 virtual HRESULT __stdcall putref_ParentCatalog(
1132 /*[in]*/ struct _Catalog* ppvObject) = 0;
1133};
1134
1135struct __declspec(uuid("00000619-0000-0010-8000-00aa006d2ea4")) _User25 : IDispatch
1136{
1137 //
1138 // Property data
1139 //
1140
1141 __declspec(property(get = GetName, put = PutName)) _bstr_t Name;
1142 __declspec(property(get = GetGroups)) GroupsPtr Groups;
1143
1144 //
1145 // Wrapper methods for error-handling
1146 //
1147
1148 _bstr_t GetName();
1149 void PutName(_bstr_t pVal);
1150 enum RightsEnum GetPermissions(const _variant_t& Name, enum ObjectTypeEnum ObjectType,
1151 const _variant_t& ObjectTypeId = vtMissing);
1152 HRESULT SetPermissions(const _variant_t& Name, enum ObjectTypeEnum ObjectType,
1153 enum ActionEnum Action, enum RightsEnum Rights,
1154 enum InheritTypeEnum Inherit,
1155 const _variant_t& ObjectTypeId = vtMissing);
1156 HRESULT ChangePassword(_bstr_t OldPassword, _bstr_t NewPassword);
1157 GroupsPtr GetGroups();
1158
1159 //
1160 // Raw methods provided by interface
1161 //
1162
1163 virtual HRESULT __stdcall get_Name(
1164 /*[out,retval]*/ BSTR* pVal) = 0;
1165 virtual HRESULT __stdcall put_Name(
1166 /*[in]*/ BSTR pVal) = 0;
1167 virtual HRESULT __stdcall raw_GetPermissions(
1168 /*[in]*/ VARIANT Name,
1169 /*[in]*/ enum ObjectTypeEnum ObjectType,
1170 /*[in]*/ VARIANT ObjectTypeId,
1171 /*[out,retval]*/ enum RightsEnum* Rights) = 0;
1172 virtual HRESULT __stdcall raw_SetPermissions(
1173 /*[in]*/ VARIANT Name,
1174 /*[in]*/ enum ObjectTypeEnum ObjectType,
1175 /*[in]*/ enum ActionEnum Action,
1176 /*[in]*/ enum RightsEnum Rights,
1177 /*[in]*/ enum InheritTypeEnum Inherit,
1178 /*[in]*/ VARIANT ObjectTypeId = vtMissing) = 0;
1179 virtual HRESULT __stdcall raw_ChangePassword(
1180 /*[in]*/ BSTR OldPassword,
1181 /*[in]*/ BSTR NewPassword) = 0;
1182 virtual HRESULT __stdcall get_Groups(
1183 /*[out,retval]*/ struct Groups** ppvObject) = 0;
1184};
1185
1186struct __declspec(uuid("00000627-0000-0010-8000-00aa006d2ea4")) _User : _User25
1187{
1188 //
1189 // Property data
1190 //
1191
1192 __declspec(property(get = GetProperties)) PropertiesPtr Properties;
1193 __declspec(property(get = GetParentCatalog,
1194 put = PutRefParentCatalog)) _CatalogPtr ParentCatalog;
1195
1196 //
1197 // Wrapper methods for error-handling
1198 //
1199
1200 PropertiesPtr GetProperties();
1201 _CatalogPtr GetParentCatalog();
1202 void PutParentCatalog(struct _Catalog* ppvObject);
1203 void PutRefParentCatalog(struct _Catalog* ppvObject);
1204
1205 //
1206 // Raw methods provided by interface
1207 //
1208
1209 virtual HRESULT __stdcall get_Properties(
1210 /*[out,retval]*/ struct Properties** ppvObject) = 0;
1211 virtual HRESULT __stdcall get_ParentCatalog(
1212 /*[out,retval]*/ struct _Catalog** ppvObject) = 0;
1213 virtual HRESULT __stdcall put_ParentCatalog(
1214 /*[in]*/ struct _Catalog* ppvObject) = 0;
1215 virtual HRESULT __stdcall putref_ParentCatalog(
1216 /*[in]*/ struct _Catalog* ppvObject) = 0;
1217};
1218
1219struct __declspec(uuid("00000602-0000-0010-8000-00aa006d2ea4")) Catalog;
1220// [ default ] interface _Catalog
1221
1222//
1223// Wrapper method implementations
1224//
1225
1226//#include "Debug\msadox.tli"
1227
1228} // namespace XTPADOX
1229
1230namespace XTPADODB
1231{
1232//
1233// Forward references and typedefs
1234//
1235
1236struct __declspec(uuid("b691e011-1797-432e-907a-4d8c69339129"))
1237 /* LIBID */ __ADODB;
1238enum CursorTypeEnum;
1239enum CursorOptionEnum;
1240enum LockTypeEnum;
1241enum ExecuteOptionEnum;
1242enum ConnectOptionEnum;
1243enum ObjectStateEnum;
1244enum CursorLocationEnum;
1245enum DataTypeEnum;
1246enum FieldAttributeEnum;
1247enum EditModeEnum;
1248enum RecordStatusEnum;
1249enum GetRowsOptionEnum;
1250enum PositionEnum;
1251enum BookmarkEnum;
1252enum MarshalOptionsEnum;
1253enum AffectEnum;
1254enum ResyncEnum;
1255enum CompareEnum;
1256enum FilterGroupEnum;
1257enum SearchDirectionEnum;
1258enum PersistFormatEnum;
1259enum StringFormatEnum;
1260enum ConnectPromptEnum;
1261enum ConnectModeEnum;
1262enum RecordCreateOptionsEnum;
1263enum RecordOpenOptionsEnum;
1264enum IsolationLevelEnum;
1265enum XactAttributeEnum;
1266enum PropertyAttributesEnum;
1267enum ErrorValueEnum;
1268enum ParameterAttributesEnum;
1269enum ParameterDirectionEnum;
1270enum CommandTypeEnum;
1271enum EventStatusEnum;
1272enum EventReasonEnum;
1273enum SchemaEnum;
1274enum FieldStatusEnum;
1275enum SeekEnum;
1276enum ADCPROP_UPDATECRITERIA_ENUM;
1277enum ADCPROP_ASYNCTHREADPRIORITY_ENUM;
1278enum ADCPROP_AUTORECALC_ENUM;
1279enum ADCPROP_UPDATERESYNC_ENUM;
1280enum MoveRecordOptionsEnum;
1281enum CopyRecordOptionsEnum;
1282enum StreamTypeEnum;
1283enum LineSeparatorEnum;
1284enum StreamOpenOptionsEnum;
1285enum StreamWriteEnum;
1286enum SaveOptionsEnum;
1287enum FieldEnum;
1288enum StreamReadEnum;
1289enum RecordTypeEnum;
1290struct __declspec(uuid("00000512-0000-0010-8000-00aa006d2ea4"))
1291 /* dual interface */ _Collection;
1292struct __declspec(uuid("00000513-0000-0010-8000-00aa006d2ea4"))
1293 /* dual interface */ _DynaCollection;
1294struct __declspec(uuid("00000534-0000-0010-8000-00aa006d2ea4"))
1295 /* dual interface */ _ADO;
1296struct __declspec(uuid("00000504-0000-0010-8000-00aa006d2ea4"))
1297 /* dual interface */ Properties;
1298struct __declspec(uuid("00000503-0000-0010-8000-00aa006d2ea4"))
1299 /* dual interface */ Property;
1300struct __declspec(uuid("00000500-0000-0010-8000-00aa006d2ea4"))
1301 /* dual interface */ Error;
1302struct __declspec(uuid("00000501-0000-0010-8000-00aa006d2ea4"))
1303 /* dual interface */ Errors;
1304struct __declspec(uuid("00001508-0000-0010-8000-00aa006d2ea4"))
1305 /* dual interface */ Command15;
1306struct __declspec(uuid("00001550-0000-0010-8000-00aa006d2ea4"))
1307 /* dual interface */ _Connection;
1308struct __declspec(uuid("00001515-0000-0010-8000-00aa006d2ea4"))
1309 /* dual interface */ Connection15;
1310struct __declspec(uuid("00001556-0000-0010-8000-00aa006d2ea4"))
1311 /* dual interface */ _Recordset;
1312struct __declspec(uuid("00001555-0000-0010-8000-00aa006d2ea4"))
1313 /* dual interface */ Recordset21;
1314struct __declspec(uuid("0000154f-0000-0010-8000-00aa006d2ea4"))
1315 /* dual interface */ Recordset20;
1316struct __declspec(uuid("0000150e-0000-0010-8000-00aa006d2ea4"))
1317 /* dual interface */ Recordset15;
1318struct __declspec(uuid("00001564-0000-0010-8000-00aa006d2ea4"))
1319 /* dual interface */ Fields;
1320struct __declspec(uuid("0000154d-0000-0010-8000-00aa006d2ea4"))
1321 /* dual interface */ Fields20;
1322struct __declspec(uuid("00001506-0000-0010-8000-00aa006d2ea4"))
1323 /* dual interface */ Fields15;
1324struct __declspec(uuid("00001569-0000-0010-8000-00aa006d2ea4"))
1325 /* dual interface */ Field;
1326struct __declspec(uuid("0000154c-0000-0010-8000-00aa006d2ea4"))
1327 /* dual interface */ Field20;
1328struct __declspec(uuid("0000150c-0000-0010-8000-00aa006d2ea4"))
1329 /* dual interface */ _Parameter;
1330struct __declspec(uuid("0000150d-0000-0010-8000-00aa006d2ea4"))
1331 /* dual interface */ Parameters;
1332struct __declspec(uuid("0000154e-0000-0010-8000-00aa006d2ea4"))
1333 /* dual interface */ Command25;
1334struct __declspec(uuid("986761e8-7269-4890-aa65-ad7c03697a6d"))
1335 /* dual interface */ _Command;
1336struct __declspec(uuid("00001402-0000-0010-8000-00aa006d2ea4"))
1337 /* interface */ ConnectionEventsVt;
1338struct __declspec(uuid("00001403-0000-0010-8000-00aa006d2ea4"))
1339 /* interface */ RecordsetEventsVt;
1340struct __declspec(uuid("00001400-0000-0010-8000-00aa006d2ea4"))
1341 /* dispinterface */ ConnectionEvents;
1342struct __declspec(uuid("00001266-0000-0010-8000-00aa006d2ea4"))
1343 /* dispinterface */ RecordsetEvents;
1344struct __declspec(uuid("00000516-0000-0010-8000-00aa006d2ea4"))
1345 /* interface */ ADOConnectionConstruction15;
1346struct __declspec(uuid("00000551-0000-0010-8000-00aa006d2ea4"))
1347 /* interface */ ADOConnectionConstruction;
1348struct /* coclass */ Connection;
1349struct __declspec(uuid("00001562-0000-0010-8000-00aa006d2ea4"))
1350 /* dual interface */ _Record;
1351struct /* coclass */ Record;
1352struct __declspec(uuid("00001565-0000-0010-8000-00aa006d2ea4"))
1353 /* dual interface */ _Stream;
1354struct /* coclass */ Stream;
1355struct __declspec(uuid("00000567-0000-0010-8000-00aa006d2ea4"))
1356 /* interface */ ADORecordConstruction;
1357struct __declspec(uuid("00000568-0000-0010-8000-00aa006d2ea4"))
1358 /* interface */ ADOStreamConstruction;
1359struct __declspec(uuid("00000517-0000-0010-8000-00aa006d2ea4"))
1360 /* interface */ ADOCommandConstruction;
1361struct /* coclass */ Command;
1362struct /* coclass */ Recordset;
1363struct __declspec(uuid("00000283-0000-0010-8000-00aa006d2ea4"))
1364 /* interface */ ADORecordsetConstruction;
1365struct __declspec(uuid("00001505-0000-0010-8000-00aa006d2ea4"))
1366 /* dual interface */ Field15;
1367struct /* coclass */ Parameter;
1368struct __declspec(uuid("00000402-0000-0010-8000-00aa006d2ea4"))
1369 /* interface */ ConnectionEventsVt_Deprecated;
1370struct __declspec(uuid("00000550-0000-0010-8000-00aa006d2ea4"))
1371 /* dual interface */ _Connection_Deprecated;
1372struct __declspec(uuid("00000515-0000-0010-8000-00aa006d2ea4"))
1373 /* dual interface */ Connection15_Deprecated;
1374struct __declspec(uuid("00000556-0000-0010-8000-00aa006d2ea4"))
1375 /* dual interface */ _Recordset_Deprecated;
1376struct __declspec(uuid("00000555-0000-0010-8000-00aa006d2ea4"))
1377 /* dual interface */ Recordset21_Deprecated;
1378struct __declspec(uuid("0000054f-0000-0010-8000-00aa006d2ea4"))
1379 /* dual interface */ Recordset20_Deprecated;
1380struct __declspec(uuid("0000050e-0000-0010-8000-00aa006d2ea4"))
1381 /* dual interface */ Recordset15_Deprecated;
1382struct __declspec(uuid("00000564-0000-0010-8000-00aa006d2ea4"))
1383 /* dual interface */ Fields_Deprecated;
1384struct __declspec(uuid("0000054d-0000-0010-8000-00aa006d2ea4"))
1385 /* dual interface */ Fields20_Deprecated;
1386struct __declspec(uuid("00000506-0000-0010-8000-00aa006d2ea4"))
1387 /* dual interface */ Fields15_Deprecated;
1388struct __declspec(uuid("00000569-0000-0010-8000-00aa006d2ea4"))
1389 /* dual interface */ Field_Deprecated;
1390struct __declspec(uuid("0000054c-0000-0010-8000-00aa006d2ea4"))
1391 /* dual interface */ Field20_Deprecated;
1392struct __declspec(uuid("b08400bd-f9d1-4d02-b856-71d5dba123e9"))
1393 /* dual interface */ _Command_Deprecated;
1394struct __declspec(uuid("0000054e-0000-0010-8000-00aa006d2ea4"))
1395 /* dual interface */ Command25_Deprecated;
1396struct __declspec(uuid("00000508-0000-0010-8000-00aa006d2ea4"))
1397 /* dual interface */ Command15_Deprecated;
1398struct __declspec(uuid("0000050c-0000-0010-8000-00aa006d2ea4"))
1399 /* dual interface */ _Parameter_Deprecated;
1400struct __declspec(uuid("0000050d-0000-0010-8000-00aa006d2ea4"))
1401 /* dual interface */ Parameters_Deprecated;
1402struct __declspec(uuid("00000403-0000-0010-8000-00aa006d2ea4"))
1403 /* interface */ RecordsetEventsVt_Deprecated;
1404struct __declspec(uuid("00000400-0000-0010-8000-00aa006d2ea4"))
1405 /* dispinterface */ ConnectionEvents_Deprecated;
1406struct __declspec(uuid("00000266-0000-0010-8000-00aa006d2ea4"))
1407 /* dispinterface */ RecordsetEvents_Deprecated;
1408struct __declspec(uuid("00000562-0000-0010-8000-00aa006d2ea4"))
1409 /* dual interface */ _Record_Deprecated;
1410struct __declspec(uuid("00000565-0000-0010-8000-00aa006d2ea4"))
1411 /* dual interface */ _Stream_Deprecated;
1412struct __declspec(uuid("00000505-0000-0010-8000-00aa006d2ea4"))
1413 /* dual interface */ Field15_Deprecated;
1414typedef __int64 PositionEnum_Param;
1415typedef enum SearchDirectionEnum SearchDirection;
1416typedef __int64 ADO_LONGPTR;
1417
1418//
1419// Smart pointer typedef declarations
1420//
1421
1422_COM_SMARTPTR_TYPEDEF(_Collection, __uuidof(_Collection));
1423_COM_SMARTPTR_TYPEDEF(_DynaCollection, __uuidof(_DynaCollection));
1424_COM_SMARTPTR_TYPEDEF(Property, __uuidof(Property));
1425_COM_SMARTPTR_TYPEDEF(Properties, __uuidof(Properties));
1426_COM_SMARTPTR_TYPEDEF(_ADO, __uuidof(_ADO));
1427_COM_SMARTPTR_TYPEDEF(Error, __uuidof(Error));
1428_COM_SMARTPTR_TYPEDEF(Errors, __uuidof(Errors));
1429_COM_SMARTPTR_TYPEDEF(Field20, __uuidof(Field20));
1430_COM_SMARTPTR_TYPEDEF(Field, __uuidof(Field));
1431_COM_SMARTPTR_TYPEDEF(Fields15, __uuidof(Fields15));
1432_COM_SMARTPTR_TYPEDEF(Fields20, __uuidof(Fields20));
1433_COM_SMARTPTR_TYPEDEF(Fields, __uuidof(Fields));
1434_COM_SMARTPTR_TYPEDEF(_Parameter, __uuidof(_Parameter));
1435_COM_SMARTPTR_TYPEDEF(Parameters, __uuidof(Parameters));
1436_COM_SMARTPTR_TYPEDEF(ConnectionEvents, __uuidof(ConnectionEvents));
1437_COM_SMARTPTR_TYPEDEF(RecordsetEvents, __uuidof(RecordsetEvents));
1438_COM_SMARTPTR_TYPEDEF(ADOConnectionConstruction15, __uuidof(ADOConnectionConstruction15));
1439_COM_SMARTPTR_TYPEDEF(ADOConnectionConstruction, __uuidof(ADOConnectionConstruction));
1440_COM_SMARTPTR_TYPEDEF(_Stream, __uuidof(_Stream));
1441_COM_SMARTPTR_TYPEDEF(ADORecordConstruction, __uuidof(ADORecordConstruction));
1442_COM_SMARTPTR_TYPEDEF(ADOStreamConstruction, __uuidof(ADOStreamConstruction));
1443_COM_SMARTPTR_TYPEDEF(ADOCommandConstruction, __uuidof(ADOCommandConstruction));
1444_COM_SMARTPTR_TYPEDEF(ADORecordsetConstruction, __uuidof(ADORecordsetConstruction));
1445_COM_SMARTPTR_TYPEDEF(Field15, __uuidof(Field15));
1446_COM_SMARTPTR_TYPEDEF(Field20_Deprecated, __uuidof(Field20_Deprecated));
1447_COM_SMARTPTR_TYPEDEF(Field_Deprecated, __uuidof(Field_Deprecated));
1448_COM_SMARTPTR_TYPEDEF(Fields15_Deprecated, __uuidof(Fields15_Deprecated));
1449_COM_SMARTPTR_TYPEDEF(Fields20_Deprecated, __uuidof(Fields20_Deprecated));
1450_COM_SMARTPTR_TYPEDEF(Fields_Deprecated, __uuidof(Fields_Deprecated));
1451_COM_SMARTPTR_TYPEDEF(_Parameter_Deprecated, __uuidof(_Parameter_Deprecated));
1452_COM_SMARTPTR_TYPEDEF(Parameters_Deprecated, __uuidof(Parameters_Deprecated));
1453_COM_SMARTPTR_TYPEDEF(ConnectionEvents_Deprecated, __uuidof(ConnectionEvents_Deprecated));
1454_COM_SMARTPTR_TYPEDEF(RecordsetEvents_Deprecated, __uuidof(RecordsetEvents_Deprecated));
1455_COM_SMARTPTR_TYPEDEF(_Stream_Deprecated, __uuidof(_Stream_Deprecated));
1456_COM_SMARTPTR_TYPEDEF(Field15_Deprecated, __uuidof(Field15_Deprecated));
1457_COM_SMARTPTR_TYPEDEF(Command15, __uuidof(Command15));
1458_COM_SMARTPTR_TYPEDEF(Command25, __uuidof(Command25));
1459_COM_SMARTPTR_TYPEDEF(_Command, __uuidof(_Command));
1460_COM_SMARTPTR_TYPEDEF(Connection15, __uuidof(Connection15));
1461_COM_SMARTPTR_TYPEDEF(_Connection, __uuidof(_Connection));
1462_COM_SMARTPTR_TYPEDEF(Recordset15, __uuidof(Recordset15));
1463_COM_SMARTPTR_TYPEDEF(Recordset20, __uuidof(Recordset20));
1464_COM_SMARTPTR_TYPEDEF(Recordset21, __uuidof(Recordset21));
1465_COM_SMARTPTR_TYPEDEF(_Recordset, __uuidof(_Recordset));
1466_COM_SMARTPTR_TYPEDEF(ConnectionEventsVt, __uuidof(ConnectionEventsVt));
1467_COM_SMARTPTR_TYPEDEF(RecordsetEventsVt, __uuidof(RecordsetEventsVt));
1468_COM_SMARTPTR_TYPEDEF(_Record, __uuidof(_Record));
1469_COM_SMARTPTR_TYPEDEF(ConnectionEventsVt_Deprecated, __uuidof(ConnectionEventsVt_Deprecated));
1470_COM_SMARTPTR_TYPEDEF(Connection15_Deprecated, __uuidof(Connection15_Deprecated));
1471_COM_SMARTPTR_TYPEDEF(_Connection_Deprecated, __uuidof(_Connection_Deprecated));
1472_COM_SMARTPTR_TYPEDEF(Recordset15_Deprecated, __uuidof(Recordset15_Deprecated));
1473_COM_SMARTPTR_TYPEDEF(Recordset20_Deprecated, __uuidof(Recordset20_Deprecated));
1474_COM_SMARTPTR_TYPEDEF(Recordset21_Deprecated, __uuidof(Recordset21_Deprecated));
1475_COM_SMARTPTR_TYPEDEF(_Recordset_Deprecated, __uuidof(_Recordset_Deprecated));
1476_COM_SMARTPTR_TYPEDEF(Command15_Deprecated, __uuidof(Command15_Deprecated));
1477_COM_SMARTPTR_TYPEDEF(Command25_Deprecated, __uuidof(Command25_Deprecated));
1478_COM_SMARTPTR_TYPEDEF(_Command_Deprecated, __uuidof(_Command_Deprecated));
1479_COM_SMARTPTR_TYPEDEF(RecordsetEventsVt_Deprecated, __uuidof(RecordsetEventsVt_Deprecated));
1480_COM_SMARTPTR_TYPEDEF(_Record_Deprecated, __uuidof(_Record_Deprecated));
1481
1482//
1483// Type library items
1484//
1485
1486enum __declspec(uuid("0000051b-0000-0010-8000-00aa006d2ea4")) CursorTypeEnum
1487{
1488 adOpenUnspecified = -1,
1489 adOpenForwardOnly = 0,
1490 adOpenKeyset = 1,
1491 adOpenDynamic = 2,
1492 adOpenStatic = 3
1493};
1494
1495enum __declspec(uuid("0000051c-0000-0010-8000-00aa006d2ea4")) CursorOptionEnum
1496{
1497 adHoldRecords = 256,
1498 adMovePrevious = 512,
1499 adAddNew = 16778240,
1500 adDelete = 16779264,
1501 adUpdate = 16809984,
1502 adBookmark = 8192,
1503 adApproxPosition = 16384,
1504 adUpdateBatch = 65536,
1505 adResync = 131072,
1506 adNotify = 262144,
1507 adFind = 524288,
1508 adSeek = 4194304,
1509 adIndex = 8388608
1510};
1511
1512enum __declspec(uuid("0000051d-0000-0010-8000-00aa006d2ea4")) LockTypeEnum
1513{
1514 adLockUnspecified = -1,
1515 adLockReadOnly = 1,
1516 adLockPessimistic = 2,
1517 adLockOptimistic = 3,
1518 adLockBatchOptimistic = 4
1519};
1520
1521enum __declspec(uuid("0000051e-0000-0010-8000-00aa006d2ea4")) ExecuteOptionEnum
1522{
1523 adOptionUnspecified = -1,
1524 adAsyncExecute = 16,
1525 adAsyncFetch = 32,
1526 adAsyncFetchNonBlocking = 64,
1527 adExecuteNoRecords = 128,
1528 adExecuteStream = 1024,
1529 adExecuteRecord = 2048
1530};
1531
1532enum __declspec(uuid("00000541-0000-0010-8000-00aa006d2ea4")) ConnectOptionEnum
1533{
1534 adConnectUnspecified = -1,
1535 adAsyncConnect = 16
1536};
1537
1538enum __declspec(uuid("00000532-0000-0010-8000-00aa006d2ea4")) ObjectStateEnum
1539{
1540 adStateClosed = 0,
1541 adStateOpen = 1,
1542 adStateConnecting = 2,
1543 adStateExecuting = 4,
1544 adStateFetching = 8
1545};
1546
1547enum __declspec(uuid("0000052f-0000-0010-8000-00aa006d2ea4")) CursorLocationEnum
1548{
1549 adUseNone = 1,
1550 adUseServer = 2,
1551 adUseClient = 3,
1552 adUseClientBatch = 3
1553};
1554
1555enum __declspec(uuid("0000051f-0000-0010-8000-00aa006d2ea4")) DataTypeEnum
1556{
1557 adEmpty = 0,
1558 adTinyInt = 16,
1559 adSmallInt = 2,
1560 adInteger = 3,
1561 adBigInt = 20,
1562 adUnsignedTinyInt = 17,
1563 adUnsignedSmallInt = 18,
1564 adUnsignedInt = 19,
1565 adUnsignedBigInt = 21,
1566 adSingle = 4,
1567 adDouble = 5,
1568 adCurrency = 6,
1569 adDecimal = 14,
1570 adNumeric = 131,
1571 adBoolean = 11,
1572 adError = 10,
1573 adUserDefined = 132,
1574 adVariant = 12,
1575 adIDispatch = 9,
1576 adIUnknown = 13,
1577 adGUID = 72,
1578 adDate = 7,
1579 adDBDate = 133,
1580 adDBTime = 134,
1581 adDBTimeStamp = 135,
1582 adBSTR = 8,
1583 adChar = 129,
1584 adVarChar = 200,
1585 adLongVarChar = 201,
1586 adWChar = 130,
1587 adVarWChar = 202,
1588 adLongVarWChar = 203,
1589 adBinary = 128,
1590 adVarBinary = 204,
1591 adLongVarBinary = 205,
1592 adChapter = 136,
1593 adFileTime = 64,
1594 adPropVariant = 138,
1595 adVarNumeric = 139,
1596 adArray = 8192
1597};
1598
1599enum __declspec(uuid("00000525-0000-0010-8000-00aa006d2ea4")) FieldAttributeEnum
1600{
1601 adFldUnspecified = -1,
1602 adFldMayDefer = 2,
1603 adFldUpdatable = 4,
1604 adFldUnknownUpdatable = 8,
1605 adFldFixed = 16,
1606 adFldIsNullable = 32,
1607 adFldMayBeNull = 64,
1608 adFldLong = 128,
1609 adFldRowID = 256,
1610 adFldRowVersion = 512,
1611 adFldCacheDeferred = 4096,
1612 adFldIsChapter = 8192,
1613 adFldNegativeScale = 16384,
1614 adFldKeyColumn = 32768,
1615 adFldIsRowURL = 65536,
1616 adFldIsDefaultStream = 131072,
1617 adFldIsCollection = 262144
1618};
1619
1620enum __declspec(uuid("00000526-0000-0010-8000-00aa006d2ea4")) EditModeEnum
1621{
1622 adEditNone = 0,
1623 adEditInProgress = 1,
1624 adEditAdd = 2,
1625 adEditDelete = 4
1626};
1627
1628enum __declspec(uuid("00000527-0000-0010-8000-00aa006d2ea4")) RecordStatusEnum
1629{
1630 adRecOK = 0,
1631 adRecNew = 1,
1632 adRecModified = 2,
1633 adRecDeleted = 4,
1634 adRecUnmodified = 8,
1635 adRecInvalid = 16,
1636 adRecMultipleChanges = 64,
1637 adRecPendingChanges = 128,
1638 adRecCanceled = 256,
1639 adRecCantRelease = 1024,
1640 adRecConcurrencyViolation = 2048,
1641 adRecIntegrityViolation = 4096,
1642 adRecMaxChangesExceeded = 8192,
1643 adRecObjectOpen = 16384,
1644 adRecOutOfMemory = 32768,
1645 adRecPermissionDenied = 65536,
1646 adRecSchemaViolation = 131072,
1647 adRecDBDeleted = 262144
1648};
1649
1650enum __declspec(uuid("00000542-0000-0010-8000-00aa006d2ea4")) GetRowsOptionEnum
1651{
1652 adGetRowsRest = -1
1653};
1654
1655enum __declspec(uuid("00000528-0000-0010-8000-00aa006d2ea4")) PositionEnum
1656{
1657 adPosUnknown = -1,
1658 adPosBOF = -2,
1659 adPosEOF = -3
1660};
1661
1662enum BookmarkEnum
1663{
1664 adBookmarkCurrent = 0,
1665 adBookmarkFirst = 1,
1666 adBookmarkLast = 2
1667};
1668
1669enum __declspec(uuid("00000540-0000-0010-8000-00aa006d2ea4")) MarshalOptionsEnum
1670{
1671 adMarshalAll = 0,
1672 adMarshalModifiedOnly = 1
1673};
1674
1675enum __declspec(uuid("00000543-0000-0010-8000-00aa006d2ea4")) AffectEnum
1676{
1677 adAffectCurrent = 1,
1678 adAffectGroup = 2,
1679 adAffectAll = 3,
1680 adAffectAllChapters = 4
1681};
1682
1683enum __declspec(uuid("00000544-0000-0010-8000-00aa006d2ea4")) ResyncEnum
1684{
1685 adResyncUnderlyingValues = 1,
1686 adResyncAllValues = 2
1687};
1688
1689enum __declspec(uuid("00000545-0000-0010-8000-00aa006d2ea4")) CompareEnum
1690{
1691 adCompareLessThan = 0,
1692 adCompareEqual = 1,
1693 adCompareGreaterThan = 2,
1694 adCompareNotEqual = 3,
1695 adCompareNotComparable = 4
1696};
1697
1698enum __declspec(uuid("00000546-0000-0010-8000-00aa006d2ea4")) FilterGroupEnum
1699{
1700 adFilterNone = 0,
1701 adFilterPendingRecords = 1,
1702 adFilterAffectedRecords = 2,
1703 adFilterFetchedRecords = 3,
1704 adFilterPredicate = 4,
1705 adFilterConflictingRecords = 5
1706};
1707
1708enum __declspec(uuid("00000547-0000-0010-8000-00aa006d2ea4")) SearchDirectionEnum
1709{
1710 adSearchForward = 1,
1711 adSearchBackward = -1
1712};
1713
1714enum __declspec(uuid("00000548-0000-0010-8000-00aa006d2ea4")) PersistFormatEnum
1715{
1716 adPersistADTG = 0,
1717 adPersistXML = 1
1718};
1719
1720enum __declspec(uuid("00000549-0000-0010-8000-00aa006d2ea4")) StringFormatEnum
1721{
1722 adClipString = 2
1723};
1724
1725enum __declspec(uuid("00000520-0000-0010-8000-00aa006d2ea4")) ConnectPromptEnum
1726{
1727 adPromptAlways = 1,
1728 adPromptComplete = 2,
1729 adPromptCompleteRequired = 3,
1730 adPromptNever = 4
1731};
1732
1733enum __declspec(uuid("00000521-0000-0010-8000-00aa006d2ea4")) ConnectModeEnum
1734{
1735 adModeUnknown = 0,
1736 adModeRead = 1,
1737 adModeWrite = 2,
1738 adModeReadWrite = 3,
1739 adModeShareDenyRead = 4,
1740 adModeShareDenyWrite = 8,
1741 adModeShareExclusive = 12,
1742 adModeShareDenyNone = 16,
1743 adModeRecursive = 4194304
1744};
1745
1746enum __declspec(uuid("00000570-0000-0010-8000-00aa006d2ea4")) RecordCreateOptionsEnum
1747{
1748 adCreateCollection = 8192,
1749 adCreateStructDoc = 0x80000000,
1750 adCreateNonCollection = 0,
1751 adOpenIfExists = 33554432,
1752 adCreateOverwrite = 67108864,
1753 adFailIfNotExists = -1
1754};
1755
1756enum __declspec(uuid("00000571-0000-0010-8000-00aa006d2ea4")) RecordOpenOptionsEnum
1757{
1758 adOpenRecordUnspecified = -1,
1759 adOpenSource = 8388608,
1760 adOpenOutput = 8388608,
1761 adOpenAsync = 4096,
1762 adDelayFetchStream = 16384,
1763 adDelayFetchFields = 32768,
1764 adOpenExecuteCommand = 65536
1765};
1766
1767enum __declspec(uuid("00000523-0000-0010-8000-00aa006d2ea4")) IsolationLevelEnum
1768{
1769 adXactUnspecified = -1,
1770 adXactChaos = 16,
1771 adXactReadUncommitted = 256,
1772 adXactBrowse = 256,
1773 adXactCursorStability = 4096,
1774 adXactReadCommitted = 4096,
1775 adXactRepeatableRead = 65536,
1776 adXactSerializable = 1048576,
1777 adXactIsolated = 1048576
1778};
1779
1780enum __declspec(uuid("00000524-0000-0010-8000-00aa006d2ea4")) XactAttributeEnum
1781{
1782 adXactCommitRetaining = 131072,
1783 adXactAbortRetaining = 262144,
1784 adXactAsyncPhaseOne = 524288,
1785 adXactSyncPhaseOne = 1048576
1786};
1787
1788enum __declspec(uuid("00000529-0000-0010-8000-00aa006d2ea4")) PropertyAttributesEnum
1789{
1790 adPropNotSupported = 0,
1791 adPropRequired = 1,
1792 adPropOptional = 2,
1793 adPropRead = 512,
1794 adPropWrite = 1024
1795};
1796
1797enum __declspec(uuid("0000052a-0000-0010-8000-00aa006d2ea4")) ErrorValueEnum
1798{
1799 adErrProviderFailed = 3000,
1800 adErrInvalidArgument = 3001,
1801 adErrOpeningFile = 3002,
1802 adErrReadFile = 3003,
1803 adErrWriteFile = 3004,
1804 adErrNoCurrentRecord = 3021,
1805 adErrIllegalOperation = 3219,
1806 adErrCantChangeProvider = 3220,
1807 adErrInTransaction = 3246,
1808 adErrFeatureNotAvailable = 3251,
1809 adErrItemNotFound = 3265,
1810 adErrObjectInCollection = 3367,
1811 adErrObjectNotSet = 3420,
1812 adErrDataConversion = 3421,
1813 adErrObjectClosed = 3704,
1814 adErrObjectOpen = 3705,
1815 adErrProviderNotFound = 3706,
1816 adErrBoundToCommand = 3707,
1817 adErrInvalidParamInfo = 3708,
1818 adErrInvalidConnection = 3709,
1819 adErrNotReentrant = 3710,
1820 adErrStillExecuting = 3711,
1821 adErrOperationCancelled = 3712,
1822 adErrStillConnecting = 3713,
1823 adErrInvalidTransaction = 3714,
1824 adErrNotExecuting = 3715,
1825 adErrUnsafeOperation = 3716,
1826 adwrnSecurityDialog = 3717,
1827 adwrnSecurityDialogHeader = 3718,
1828 adErrIntegrityViolation = 3719,
1829 adErrPermissionDenied = 3720,
1830 adErrDataOverflow = 3721,
1831 adErrSchemaViolation = 3722,
1832 adErrSignMismatch = 3723,
1833 adErrCantConvertvalue = 3724,
1834 adErrCantCreate = 3725,
1835 adErrColumnNotOnThisRow = 3726,
1836 adErrURLDoesNotExist = 3727,
1837 adErrTreePermissionDenied = 3728,
1838 adErrInvalidURL = 3729,
1839 adErrResourceLocked = 3730,
1840 adErrResourceExists = 3731,
1841 adErrCannotComplete = 3732,
1842 adErrVolumeNotFound = 3733,
1843 adErrOutOfSpace = 3734,
1844 adErrResourceOutOfScope = 3735,
1845 adErrUnavailable = 3736,
1846 adErrURLNamedRowDoesNotExist = 3737,
1847 adErrDelResOutOfScope = 3738,
1848 adErrPropInvalidColumn = 3739,
1849 adErrPropInvalidOption = 3740,
1850 adErrPropInvalidValue = 3741,
1851 adErrPropConflicting = 3742,
1852 adErrPropNotAllSettable = 3743,
1853 adErrPropNotSet = 3744,
1854 adErrPropNotSettable = 3745,
1855 adErrPropNotSupported = 3746,
1856 adErrCatalogNotSet = 3747,
1857 adErrCantChangeConnection = 3748,
1858 adErrFieldsUpdateFailed = 3749,
1859 adErrDenyNotSupported = 3750,
1860 adErrDenyTypeNotSupported = 3751,
1861 adErrProviderNotSpecified = 3753,
1862 adErrConnectionStringTooLong = 3754
1863};
1864
1865enum __declspec(uuid("0000052b-0000-0010-8000-00aa006d2ea4")) ParameterAttributesEnum
1866{
1867 adParamSigned = 16,
1868 adParamNullable = 64,
1869 adParamLong = 128
1870};
1871
1872enum __declspec(uuid("0000052c-0000-0010-8000-00aa006d2ea4")) ParameterDirectionEnum
1873{
1874 adParamUnknown = 0,
1875 adParamInput = 1,
1876 adParamOutput = 2,
1877 adParamInputOutput = 3,
1878 adParamReturnValue = 4
1879};
1880
1881enum __declspec(uuid("0000052e-0000-0010-8000-00aa006d2ea4")) CommandTypeEnum
1882{
1883 adCmdUnspecified = -1,
1884 adCmdUnknown = 8,
1885 adCmdText = 1,
1886 adCmdTable = 2,
1887 adCmdStoredProc = 4,
1888 adCmdFile = 256,
1889 adCmdTableDirect = 512
1890};
1891
1892enum __declspec(uuid("00000530-0000-0010-8000-00aa006d2ea4")) EventStatusEnum
1893{
1894 adStatusOK = 1,
1895 adStatusErrorsOccurred = 2,
1896 adStatusCantDeny = 3,
1897 adStatusCancel = 4,
1898 adStatusUnwantedEvent = 5
1899};
1900
1901enum __declspec(uuid("00000531-0000-0010-8000-00aa006d2ea4")) EventReasonEnum
1902{
1903 adRsnAddNew = 1,
1904 adRsnDelete = 2,
1905 adRsnUpdate = 3,
1906 adRsnUndoUpdate = 4,
1907 adRsnUndoAddNew = 5,
1908 adRsnUndoDelete = 6,
1909 adRsnRequery = 7,
1910 adRsnResynch = 8,
1911 adRsnClose = 9,
1912 adRsnMove = 10,
1913 adRsnFirstChange = 11,
1914 adRsnMoveFirst = 12,
1915 adRsnMoveNext = 13,
1916 adRsnMovePrevious = 14,
1917 adRsnMoveLast = 15
1918};
1919
1920enum __declspec(uuid("00000533-0000-0010-8000-00aa006d2ea4")) SchemaEnum
1921{
1922 adSchemaProviderSpecific = -1,
1923 adSchemaAsserts = 0,
1924 adSchemaCatalogs = 1,
1925 adSchemaCharacterSets = 2,
1926 adSchemaCollations = 3,
1927 adSchemaColumns = 4,
1928 adSchemaCheckConstraints = 5,
1929 adSchemaConstraintColumnUsage = 6,
1930 adSchemaConstraintTableUsage = 7,
1931 adSchemaKeyColumnUsage = 8,
1932 adSchemaReferentialContraints = 9,
1933 adSchemaReferentialConstraints = 9,
1934 adSchemaTableConstraints = 10,
1935 adSchemaColumnsDomainUsage = 11,
1936 adSchemaIndexes = 12,
1937 adSchemaColumnPrivileges = 13,
1938 adSchemaTablePrivileges = 14,
1939 adSchemaUsagePrivileges = 15,
1940 adSchemaProcedures = 16,
1941 adSchemaSchemata = 17,
1942 adSchemaSQLLanguages = 18,
1943 adSchemaStatistics = 19,
1944 adSchemaTables = 20,
1945 adSchemaTranslations = 21,
1946 adSchemaProviderTypes = 22,
1947 adSchemaViews = 23,
1948 adSchemaViewColumnUsage = 24,
1949 adSchemaViewTableUsage = 25,
1950 adSchemaProcedureParameters = 26,
1951 adSchemaForeignKeys = 27,
1952 adSchemaPrimaryKeys = 28,
1953 adSchemaProcedureColumns = 29,
1954 adSchemaDBInfoKeywords = 30,
1955 adSchemaDBInfoLiterals = 31,
1956 adSchemaCubes = 32,
1957 adSchemaDimensions = 33,
1958 adSchemaHierarchies = 34,
1959 adSchemaLevels = 35,
1960 adSchemaMeasures = 36,
1961 adSchemaProperties = 37,
1962 adSchemaMembers = 38,
1963 adSchemaTrustees = 39,
1964 adSchemaFunctions = 40,
1965 adSchemaActions = 41,
1966 adSchemaCommands = 42,
1967 adSchemaSets = 43
1968};
1969
1970enum __declspec(uuid("0000057e-0000-0010-8000-00aa006d2ea4")) FieldStatusEnum
1971{
1972 adFieldOK = 0,
1973 adFieldCantConvertValue = 2,
1974 adFieldIsNull = 3,
1975 adFieldTruncated = 4,
1976 adFieldSignMismatch = 5,
1977 adFieldDataOverflow = 6,
1978 adFieldCantCreate = 7,
1979 adFieldUnavailable = 8,
1980 adFieldPermissionDenied = 9,
1981 adFieldIntegrityViolation = 10,
1982 adFieldSchemaViolation = 11,
1983 adFieldBadStatus = 12,
1984 adFieldDefault = 13,
1985 adFieldIgnore = 15,
1986 adFieldDoesNotExist = 16,
1987 adFieldInvalidURL = 17,
1988 adFieldResourceLocked = 18,
1989 adFieldResourceExists = 19,
1990 adFieldCannotComplete = 20,
1991 adFieldVolumeNotFound = 21,
1992 adFieldOutOfSpace = 22,
1993 adFieldCannotDeleteSource = 23,
1994 adFieldReadOnly = 24,
1995 adFieldResourceOutOfScope = 25,
1996 adFieldAlreadyExists = 26,
1997 adFieldPendingInsert = 65536,
1998 adFieldPendingDelete = 131072,
1999 adFieldPendingChange = 262144,
2000 adFieldPendingUnknown = 524288,
2001 adFieldPendingUnknownDelete = 1048576
2002};
2003
2004enum __declspec(uuid("00000552-0000-0010-8000-00aa006d2ea4")) SeekEnum
2005{
2006 adSeekFirstEQ = 1,
2007 adSeekLastEQ = 2,
2008 adSeekAfterEQ = 4,
2009 adSeekAfter = 8,
2010 adSeekBeforeEQ = 16,
2011 adSeekBefore = 32
2012};
2013
2014enum __declspec(uuid("0000054a-0000-0010-8000-00aa006d2ea4")) ADCPROP_UPDATECRITERIA_ENUM
2015{
2016 adCriteriaKey = 0,
2017 adCriteriaAllCols = 1,
2018 adCriteriaUpdCols = 2,
2019 adCriteriaTimeStamp = 3
2020};
2021
2022enum __declspec(uuid("0000054b-0000-0010-8000-00aa006d2ea4")) ADCPROP_ASYNCTHREADPRIORITY_ENUM
2023{
2024 adPriorityLowest = 1,
2025 adPriorityBelowNormal = 2,
2026 adPriorityNormal = 3,
2027 adPriorityAboveNormal = 4,
2028 adPriorityHighest = 5
2029};
2030
2031enum __declspec(uuid("00000554-0000-0010-8000-00aa006d2ea4")) ADCPROP_AUTORECALC_ENUM
2032{
2033 adRecalcUpFront = 0,
2034 adRecalcAlways = 1
2035};
2036
2037enum __declspec(uuid("00000553-0000-0010-8000-00aa006d2ea4")) ADCPROP_UPDATERESYNC_ENUM
2038{
2039 adResyncNone = 0,
2040 adResyncAutoIncrement = 1,
2041 adResyncConflicts = 2,
2042 adResyncUpdates = 4,
2043 adResyncInserts = 8,
2044 adResyncAll = 15
2045};
2046
2047enum __declspec(uuid("00000573-0000-0010-8000-00aa006d2ea4")) MoveRecordOptionsEnum
2048{
2049 adMoveUnspecified = -1,
2050 adMoveOverWrite = 1,
2051 adMoveDontUpdateLinks = 2,
2052 adMoveAllowEmulation = 4
2053};
2054
2055enum __declspec(uuid("00000574-0000-0010-8000-00aa006d2ea4")) CopyRecordOptionsEnum
2056{
2057 adCopyUnspecified = -1,
2058 adCopyOverWrite = 1,
2059 adCopyAllowEmulation = 4,
2060 adCopyNonRecursive = 2
2061};
2062
2063enum __declspec(uuid("00000576-0000-0010-8000-00aa006d2ea4")) StreamTypeEnum
2064{
2065 adTypeBinary = 1,
2066 adTypeText = 2
2067};
2068
2069enum __declspec(uuid("00000577-0000-0010-8000-00aa006d2ea4")) LineSeparatorEnum
2070{
2071 adLF = 10,
2072 adCR = 13,
2073 adCRLF = -1
2074};
2075
2076enum __declspec(uuid("0000057a-0000-0010-8000-00aa006d2ea4")) StreamOpenOptionsEnum
2077{
2078 adOpenStreamUnspecified = -1,
2079 adOpenStreamAsync = 1,
2080 adOpenStreamFromRecord = 4
2081};
2082
2083enum __declspec(uuid("0000057b-0000-0010-8000-00aa006d2ea4")) StreamWriteEnum
2084{
2085 adWriteChar = 0,
2086 adWriteLine = 1,
2087 stWriteChar = 0,
2088 stWriteLine = 1
2089};
2090
2091enum __declspec(uuid("0000057c-0000-0010-8000-00aa006d2ea4")) SaveOptionsEnum
2092{
2093 adSaveCreateNotExist = 1,
2094 adSaveCreateOverWrite = 2
2095};
2096
2097enum FieldEnum
2098{
2099 adDefaultStream = -1,
2100 adRecordURL = -2
2101};
2102
2103enum StreamReadEnum
2104{
2105 adReadAll = -1,
2106 adReadLine = -2
2107};
2108
2109enum __declspec(uuid("0000057d-0000-0010-8000-00aa006d2ea4")) RecordTypeEnum
2110{
2111 adSimpleRecord = 0,
2112 adCollectionRecord = 1,
2113 adStructDoc = 2
2114};
2115
2116struct __declspec(uuid("00000512-0000-0010-8000-00aa006d2ea4")) _Collection : IDispatch
2117{
2118 //
2119 // Property data
2120 //
2121
2122 __declspec(property(get = GetCount)) long Count;
2123
2124 //
2125 // Wrapper methods for error-handling
2126 //
2127
2128 long GetCount();
2129 IUnknownPtr _NewEnum();
2130 HRESULT Refresh();
2131
2132 //
2133 // Raw methods provided by interface
2134 //
2135
2136 virtual HRESULT __stdcall get_Count(
2137 /*[out,retval]*/ long* c) = 0;
2138 virtual HRESULT __stdcall raw__NewEnum(
2139 /*[out,retval]*/ IUnknown** ppvObject) = 0;
2140 virtual HRESULT __stdcall raw_Refresh() = 0;
2141};
2142
2143struct __declspec(uuid("00000513-0000-0010-8000-00aa006d2ea4")) _DynaCollection : _Collection
2144{
2145 //
2146 // Wrapper methods for error-handling
2147 //
2148
2149 HRESULT Append(IDispatch* Object);
2150 HRESULT Delete(const _variant_t& Index);
2151
2152 //
2153 // Raw methods provided by interface
2154 //
2155
2156 virtual HRESULT __stdcall raw_Append(
2157 /*[in]*/ IDispatch* Object) = 0;
2158 virtual HRESULT __stdcall raw_Delete(
2159 /*[in]*/ VARIANT Index) = 0;
2160};
2161
2162struct __declspec(uuid("00000503-0000-0010-8000-00aa006d2ea4")) Property : IDispatch
2163{
2164 //
2165 // Property data
2166 //
2167
2168 __declspec(property(get = GetValue, put = PutValue)) _variant_t Value;
2169 __declspec(property(get = GetName)) _bstr_t Name;
2170 __declspec(property(get = GetType)) enum DataTypeEnum Type;
2171 __declspec(property(get = GetAttributes, put = PutAttributes)) long Attributes;
2172
2173 //
2174 // Wrapper methods for error-handling
2175 //
2176
2177 _variant_t GetValue();
2178 void PutValue(const _variant_t& pval);
2179 _bstr_t GetName();
2180 enum DataTypeEnum GetType();
2181 long GetAttributes();
2182 void PutAttributes(long plAttributes);
2183
2184 //
2185 // Raw methods provided by interface
2186 //
2187
2188 virtual HRESULT __stdcall get_Value(
2189 /*[out,retval]*/ VARIANT* pval) = 0;
2190 virtual HRESULT __stdcall put_Value(
2191 /*[in]*/ VARIANT pval) = 0;
2192 virtual HRESULT __stdcall get_Name(
2193 /*[out,retval]*/ BSTR* pbstr) = 0;
2194 virtual HRESULT __stdcall get_Type(
2195 /*[out,retval]*/ enum DataTypeEnum* ptype) = 0;
2196 virtual HRESULT __stdcall get_Attributes(
2197 /*[out,retval]*/ long* plAttributes) = 0;
2198 virtual HRESULT __stdcall put_Attributes(
2199 /*[in]*/ long plAttributes) = 0;
2200};
2201
2202struct __declspec(uuid("00000504-0000-0010-8000-00aa006d2ea4")) Properties : _Collection
2203{
2204 //
2205 // Property data
2206 //
2207
2208 __declspec(property(get = GetItem)) PropertyPtr Item[];
2209
2210 //
2211 // Wrapper methods for error-handling
2212 //
2213
2214 PropertyPtr GetItem(const _variant_t& Index);
2215
2216 //
2217 // Raw methods provided by interface
2218 //
2219
2220 virtual HRESULT __stdcall get_Item(
2221 /*[in]*/ VARIANT Index,
2222 /*[out,retval]*/ struct Property** ppvObject) = 0;
2223};
2224
2225struct __declspec(uuid("00000534-0000-0010-8000-00aa006d2ea4")) _ADO : IDispatch
2226{
2227 //
2228 // Property data
2229 //
2230
2231 __declspec(property(get = GetProperties)) PropertiesPtr Properties;
2232
2233 //
2234 // Wrapper methods for error-handling
2235 //
2236
2237 PropertiesPtr GetProperties();
2238
2239 //
2240 // Raw methods provided by interface
2241 //
2242
2243 virtual HRESULT __stdcall get_Properties(
2244 /*[out,retval]*/ struct Properties** ppvObject) = 0;
2245};
2246
2247struct __declspec(uuid("00000500-0000-0010-8000-00aa006d2ea4")) Error : IDispatch
2248{
2249 //
2250 // Property data
2251 //
2252
2253 __declspec(property(get = GetDescription)) _bstr_t Description;
2254 __declspec(property(get = GetNumber)) long Number;
2255 __declspec(property(get = GetSource)) _bstr_t Source;
2256 __declspec(property(get = GetHelpFile)) _bstr_t HelpFile;
2257 __declspec(property(get = GetHelpContext)) long HelpContext;
2258 __declspec(property(get = GetSQLState)) _bstr_t SQLState;
2259 __declspec(property(get = GetNativeError)) long NativeError;
2260
2261 //
2262 // Wrapper methods for error-handling
2263 //
2264
2265 long GetNumber();
2266 _bstr_t GetSource();
2267 _bstr_t GetDescription();
2268 _bstr_t GetHelpFile();
2269 long GetHelpContext();
2270 _bstr_t GetSQLState();
2271 long GetNativeError();
2272
2273 //
2274 // Raw methods provided by interface
2275 //
2276
2277 virtual HRESULT __stdcall get_Number(
2278 /*[out,retval]*/ long* pl) = 0;
2279 virtual HRESULT __stdcall get_Source(
2280 /*[out,retval]*/ BSTR* pbstr) = 0;
2281 virtual HRESULT __stdcall get_Description(
2282 /*[out,retval]*/ BSTR* pbstr) = 0;
2283 virtual HRESULT __stdcall get_HelpFile(
2284 /*[out,retval]*/ BSTR* pbstr) = 0;
2285 virtual HRESULT __stdcall get_HelpContext(
2286 /*[out,retval]*/ long* pl) = 0;
2287 virtual HRESULT __stdcall get_SQLState(
2288 /*[out,retval]*/ BSTR* pbstr) = 0;
2289 virtual HRESULT __stdcall get_NativeError(
2290 /*[out,retval]*/ long* pl) = 0;
2291};
2292
2293struct __declspec(uuid("00000501-0000-0010-8000-00aa006d2ea4")) Errors : _Collection
2294{
2295 //
2296 // Property data
2297 //
2298
2299 __declspec(property(get = GetItem)) ErrorPtr Item[];
2300
2301 //
2302 // Wrapper methods for error-handling
2303 //
2304
2305 ErrorPtr GetItem(const _variant_t& Index);
2306 HRESULT Clear();
2307
2308 //
2309 // Raw methods provided by interface
2310 //
2311
2312 virtual HRESULT __stdcall get_Item(
2313 /*[in]*/ VARIANT Index,
2314 /*[out,retval]*/ struct Error** ppvObject) = 0;
2315 virtual HRESULT __stdcall raw_Clear() = 0;
2316};
2317
2318struct __declspec(uuid("0000154c-0000-0010-8000-00aa006d2ea4")) Field20 : _ADO
2319{
2320 //
2321 // Property data
2322 //
2323
2324 __declspec(property(get = GetValue, put = PutValue)) _variant_t Value;
2325 __declspec(property(get = GetName)) _bstr_t Name;
2326 __declspec(property(get = GetType, put = PutType)) enum DataTypeEnum Type;
2327 __declspec(property(get = GetDefinedSize, put = PutDefinedSize)) long DefinedSize;
2328 __declspec(property(get = GetOriginalValue)) _variant_t OriginalValue;
2329 __declspec(property(get = GetUnderlyingValue)) _variant_t UnderlyingValue;
2330 __declspec(property(get = GetActualSize)) long ActualSize;
2331 __declspec(property(get = GetPrecision, put = PutPrecision)) unsigned char Precision;
2332 __declspec(property(get = GetNumericScale, put = PutNumericScale)) unsigned char NumericScale;
2333 __declspec(property(get = GetAttributes, put = PutAttributes)) long Attributes;
2334 __declspec(property(get = GetDataFormat, put = PutRefDataFormat)) IUnknownPtr DataFormat;
2335
2336 //
2337 // Wrapper methods for error-handling
2338 //
2339
2340 long GetActualSize();
2341 long GetAttributes();
2342 long GetDefinedSize();
2343 _bstr_t GetName();
2344 enum DataTypeEnum GetType();
2345 _variant_t GetValue();
2346 void PutValue(const _variant_t& pvar);
2347 unsigned char GetPrecision();
2348 unsigned char GetNumericScale();
2349 HRESULT AppendChunk(const _variant_t& Data);
2350 _variant_t GetChunk(long Length);
2351 _variant_t GetOriginalValue();
2352 _variant_t GetUnderlyingValue();
2353 IUnknownPtr GetDataFormat();
2354 void PutRefDataFormat(IUnknown* ppiDF);
2355 void PutPrecision(unsigned char pbPrecision);
2356 void PutNumericScale(unsigned char pbNumericScale);
2357 void PutType(enum DataTypeEnum pDataType);
2358 void PutDefinedSize(long pl);
2359 void PutAttributes(long pl);
2360
2361 //
2362 // Raw methods provided by interface
2363 //
2364
2365 virtual HRESULT __stdcall get_ActualSize(
2366 /*[out,retval]*/ long* pl) = 0;
2367 virtual HRESULT __stdcall get_Attributes(
2368 /*[out,retval]*/ long* pl) = 0;
2369 virtual HRESULT __stdcall get_DefinedSize(
2370 /*[out,retval]*/ long* pl) = 0;
2371 virtual HRESULT __stdcall get_Name(
2372 /*[out,retval]*/ BSTR* pbstr) = 0;
2373 virtual HRESULT __stdcall get_Type(
2374 /*[out,retval]*/ enum DataTypeEnum* pDataType) = 0;
2375 virtual HRESULT __stdcall get_Value(
2376 /*[out,retval]*/ VARIANT* pvar) = 0;
2377 virtual HRESULT __stdcall put_Value(
2378 /*[in]*/ VARIANT pvar) = 0;
2379 virtual HRESULT __stdcall get_Precision(
2380 /*[out,retval]*/ unsigned char* pbPrecision) = 0;
2381 virtual HRESULT __stdcall get_NumericScale(
2382 /*[out,retval]*/ unsigned char* pbNumericScale) = 0;
2383 virtual HRESULT __stdcall raw_AppendChunk(
2384 /*[in]*/ VARIANT Data) = 0;
2385 virtual HRESULT __stdcall raw_GetChunk(
2386 /*[in]*/ long Length,
2387 /*[out,retval]*/ VARIANT* pvar) = 0;
2388 virtual HRESULT __stdcall get_OriginalValue(
2389 /*[out,retval]*/ VARIANT* pvar) = 0;
2390 virtual HRESULT __stdcall get_UnderlyingValue(
2391 /*[out,retval]*/ VARIANT* pvar) = 0;
2392 virtual HRESULT __stdcall get_DataFormat(
2393 /*[out,retval]*/ IUnknown** ppiDF) = 0;
2394 virtual HRESULT __stdcall putref_DataFormat(
2395 /*[in]*/ IUnknown* ppiDF) = 0;
2396 virtual HRESULT __stdcall put_Precision(
2397 /*[in]*/ unsigned char pbPrecision) = 0;
2398 virtual HRESULT __stdcall put_NumericScale(
2399 /*[in]*/ unsigned char pbNumericScale) = 0;
2400 virtual HRESULT __stdcall put_Type(
2401 /*[in]*/ enum DataTypeEnum pDataType) = 0;
2402 virtual HRESULT __stdcall put_DefinedSize(
2403 /*[in]*/ long pl) = 0;
2404 virtual HRESULT __stdcall put_Attributes(
2405 /*[in]*/ long pl) = 0;
2406};
2407
2408struct __declspec(uuid("00001569-0000-0010-8000-00aa006d2ea4")) Field : Field20
2409{
2410 //
2411 // Property data
2412 //
2413
2414 __declspec(property(get = GetStatus)) long Status;
2415
2416 //
2417 // Wrapper methods for error-handling
2418 //
2419
2420 long GetStatus();
2421
2422 //
2423 // Raw methods provided by interface
2424 //
2425
2426 virtual HRESULT __stdcall get_Status(
2427 /*[out,retval]*/ long* pFStatus) = 0;
2428};
2429
2430struct __declspec(uuid("00001506-0000-0010-8000-00aa006d2ea4")) Fields15 : _Collection
2431{
2432 //
2433 // Property data
2434 //
2435
2436 __declspec(property(get = GetItem)) FieldPtr Item[];
2437
2438 //
2439 // Wrapper methods for error-handling
2440 //
2441
2442 FieldPtr GetItem(const _variant_t& Index);
2443
2444 //
2445 // Raw methods provided by interface
2446 //
2447
2448 virtual HRESULT __stdcall get_Item(
2449 /*[in]*/ VARIANT Index,
2450 /*[out,retval]*/ struct Field** ppvObject) = 0;
2451};
2452
2453struct __declspec(uuid("0000154d-0000-0010-8000-00aa006d2ea4")) Fields20 : Fields15
2454{
2455 //
2456 // Wrapper methods for error-handling
2457 //
2458
2459 HRESULT _Append(_bstr_t Name, enum DataTypeEnum Type, long DefinedSize,
2460 enum FieldAttributeEnum Attrib);
2461 HRESULT Delete(const _variant_t& Index);
2462
2463 //
2464 // Raw methods provided by interface
2465 //
2466
2467 virtual HRESULT __stdcall raw__Append(
2468 /*[in]*/ BSTR Name,
2469 /*[in]*/ enum DataTypeEnum Type,
2470 /*[in]*/ long DefinedSize,
2471 /*[in]*/ enum FieldAttributeEnum Attrib) = 0;
2472 virtual HRESULT __stdcall raw_Delete(
2473 /*[in]*/ VARIANT Index) = 0;
2474};
2475
2476struct __declspec(uuid("00001564-0000-0010-8000-00aa006d2ea4")) Fields : Fields20
2477{
2478 //
2479 // Wrapper methods for error-handling
2480 //
2481
2482 HRESULT Append(_bstr_t Name, enum DataTypeEnum Type, long DefinedSize,
2483 enum FieldAttributeEnum Attrib, const _variant_t& FieldValue = vtMissing);
2484 HRESULT Update();
2485 HRESULT Resync(enum ResyncEnum ResyncValues);
2486 HRESULT CancelUpdate();
2487
2488 //
2489 // Raw methods provided by interface
2490 //
2491
2492 virtual HRESULT __stdcall raw_Append(
2493 /*[in]*/ BSTR Name,
2494 /*[in]*/ enum DataTypeEnum Type,
2495 /*[in]*/ long DefinedSize,
2496 /*[in]*/ enum FieldAttributeEnum Attrib,
2497 /*[in]*/ VARIANT FieldValue = vtMissing) = 0;
2498 virtual HRESULT __stdcall raw_Update() = 0;
2499 virtual HRESULT __stdcall raw_Resync(
2500 /*[in]*/ enum ResyncEnum ResyncValues) = 0;
2501 virtual HRESULT __stdcall raw_CancelUpdate() = 0;
2502};
2503
2504struct __declspec(uuid("0000150c-0000-0010-8000-00aa006d2ea4")) _Parameter : _ADO
2505{
2506 //
2507 // Property data
2508 //
2509
2510 __declspec(property(get = GetValue, put = PutValue)) _variant_t Value;
2511 __declspec(property(get = GetName, put = PutName)) _bstr_t Name;
2512 __declspec(property(get = GetType, put = PutType)) enum DataTypeEnum Type;
2513 __declspec(property(get = GetDirection,
2514 put = PutDirection)) enum ParameterDirectionEnum Direction;
2515 __declspec(property(get = GetPrecision, put = PutPrecision)) unsigned char Precision;
2516 __declspec(property(get = GetNumericScale, put = PutNumericScale)) unsigned char NumericScale;
2517 __declspec(property(get = GetSize, put = PutSize)) long Size;
2518 __declspec(property(get = GetAttributes, put = PutAttributes)) long Attributes;
2519
2520 //
2521 // Wrapper methods for error-handling
2522 //
2523
2524 _bstr_t GetName();
2525 void PutName(_bstr_t pbstr);
2526 _variant_t GetValue();
2527 void PutValue(const _variant_t& pvar);
2528 enum DataTypeEnum GetType();
2529 void PutType(enum DataTypeEnum psDataType);
2530 void PutDirection(enum ParameterDirectionEnum plParmDirection);
2531 enum ParameterDirectionEnum GetDirection();
2532 void PutPrecision(unsigned char pbPrecision);
2533 unsigned char GetPrecision();
2534 void PutNumericScale(unsigned char pbScale);
2535 unsigned char GetNumericScale();
2536 void PutSize(long pl);
2537 long GetSize();
2538 HRESULT AppendChunk(const _variant_t& Val);
2539 long GetAttributes();
2540 void PutAttributes(long plParmAttribs);
2541
2542 //
2543 // Raw methods provided by interface
2544 //
2545
2546 virtual HRESULT __stdcall get_Name(
2547 /*[out,retval]*/ BSTR* pbstr) = 0;
2548 virtual HRESULT __stdcall put_Name(
2549 /*[in]*/ BSTR pbstr) = 0;
2550 virtual HRESULT __stdcall get_Value(
2551 /*[out,retval]*/ VARIANT* pvar) = 0;
2552 virtual HRESULT __stdcall put_Value(
2553 /*[in]*/ VARIANT pvar) = 0;
2554 virtual HRESULT __stdcall get_Type(
2555 /*[out,retval]*/ enum DataTypeEnum* psDataType) = 0;
2556 virtual HRESULT __stdcall put_Type(
2557 /*[in]*/ enum DataTypeEnum psDataType) = 0;
2558 virtual HRESULT __stdcall put_Direction(
2559 /*[in]*/ enum ParameterDirectionEnum plParmDirection) = 0;
2560 virtual HRESULT __stdcall get_Direction(
2561 /*[out,retval]*/ enum ParameterDirectionEnum* plParmDirection) = 0;
2562 virtual HRESULT __stdcall put_Precision(
2563 /*[in]*/ unsigned char pbPrecision) = 0;
2564 virtual HRESULT __stdcall get_Precision(
2565 /*[out,retval]*/ unsigned char* pbPrecision) = 0;
2566 virtual HRESULT __stdcall put_NumericScale(
2567 /*[in]*/ unsigned char pbScale) = 0;
2568 virtual HRESULT __stdcall get_NumericScale(
2569 /*[out,retval]*/ unsigned char* pbScale) = 0;
2570 virtual HRESULT __stdcall put_Size(
2571 /*[in]*/ long pl) = 0;
2572 virtual HRESULT __stdcall get_Size(
2573 /*[out,retval]*/ long* pl) = 0;
2574 virtual HRESULT __stdcall raw_AppendChunk(
2575 /*[in]*/ VARIANT Val) = 0;
2576 virtual HRESULT __stdcall get_Attributes(
2577 /*[out,retval]*/ long* plParmAttribs) = 0;
2578 virtual HRESULT __stdcall put_Attributes(
2579 /*[in]*/ long plParmAttribs) = 0;
2580};
2581
2582struct __declspec(uuid("0000150d-0000-0010-8000-00aa006d2ea4")) Parameters : _DynaCollection
2583{
2584 //
2585 // Property data
2586 //
2587
2588 __declspec(property(get = GetItem)) _ParameterPtr Item[];
2589
2590 //
2591 // Wrapper methods for error-handling
2592 //
2593
2594 _ParameterPtr GetItem(const _variant_t& Index);
2595
2596 //
2597 // Raw methods provided by interface
2598 //
2599
2600 virtual HRESULT __stdcall get_Item(
2601 /*[in]*/ VARIANT Index,
2602 /*[out,retval]*/ struct _Parameter** ppvObject) = 0;
2603};
2604
2605struct __declspec(uuid("00001400-0000-0010-8000-00aa006d2ea4")) ConnectionEvents : IDispatch
2606{
2607 //
2608 // Wrapper methods for error-handling
2609 //
2610
2611 // Methods:
2612 HRESULT InfoMessage(struct Error* pError, enum EventStatusEnum* adStatus,
2613 struct _Connection* pConnection);
2614 HRESULT BeginTransComplete(long TransactionLevel, struct Error* pError,
2615 enum EventStatusEnum* adStatus, struct _Connection* pConnection);
2616 HRESULT CommitTransComplete(struct Error* pError, enum EventStatusEnum* adStatus,
2617 struct _Connection* pConnection);
2618 HRESULT RollbackTransComplete(struct Error* pError, enum EventStatusEnum* adStatus,
2619 struct _Connection* pConnection);
2620 HRESULT WillExecute(BSTR* Source, enum CursorTypeEnum* CursorType, enum LockTypeEnum* LockType,
2621 long* Options, enum EventStatusEnum* adStatus, struct _Command* pCommand,
2622 struct _Recordset* pRecordset, struct _Connection* pConnection);
2623 HRESULT ExecuteComplete(long RecordsAffected, struct Error* pError,
2624 enum EventStatusEnum* adStatus, struct _Command* pCommand,
2625 struct _Recordset* pRecordset, struct _Connection* pConnection);
2626 HRESULT WillConnect(BSTR* ConnectionString, BSTR* UserID, BSTR* Password, long* Options,
2627 enum EventStatusEnum* adStatus, struct _Connection* pConnection);
2628 HRESULT ConnectComplete(struct Error* pError, enum EventStatusEnum* adStatus,
2629 struct _Connection* pConnection);
2630 HRESULT Disconnect(enum EventStatusEnum* adStatus, struct _Connection* pConnection);
2631};
2632
2633struct __declspec(uuid("00001266-0000-0010-8000-00aa006d2ea4")) RecordsetEvents : IDispatch
2634{
2635 //
2636 // Wrapper methods for error-handling
2637 //
2638
2639 // Methods:
2640 HRESULT WillChangeField(long cFields, const _variant_t& Fields, enum EventStatusEnum* adStatus,
2641 struct _Recordset* pRecordset);
2642 HRESULT FieldChangeComplete(long cFields, const _variant_t& Fields, struct Error* pError,
2643 enum EventStatusEnum* adStatus, struct _Recordset* pRecordset);
2644 HRESULT WillChangeRecord(enum EventReasonEnum adReason, long cRecords,
2645 enum EventStatusEnum* adStatus, struct _Recordset* pRecordset);
2646 HRESULT RecordChangeComplete(enum EventReasonEnum adReason, long cRecords, struct Error* pError,
2647 enum EventStatusEnum* adStatus, struct _Recordset* pRecordset);
2648 HRESULT WillChangeRecordset(enum EventReasonEnum adReason, enum EventStatusEnum* adStatus,
2649 struct _Recordset* pRecordset);
2650 HRESULT RecordsetChangeComplete(enum EventReasonEnum adReason, struct Error* pError,
2651 enum EventStatusEnum* adStatus, struct _Recordset* pRecordset);
2652 HRESULT WillMove(enum EventReasonEnum adReason, enum EventStatusEnum* adStatus,
2653 struct _Recordset* pRecordset);
2654 HRESULT MoveComplete(enum EventReasonEnum adReason, struct Error* pError,
2655 enum EventStatusEnum* adStatus, struct _Recordset* pRecordset);
2656 HRESULT EndOfRecordset(VARIANT_BOOL* fMoreData, enum EventStatusEnum* adStatus,
2657 struct _Recordset* pRecordset);
2658 HRESULT FetchProgress(long Progress, long MaxProgress, enum EventStatusEnum* adStatus,
2659 struct _Recordset* pRecordset);
2660 HRESULT FetchComplete(struct Error* pError, enum EventStatusEnum* adStatus,
2661 struct _Recordset* pRecordset);
2662};
2663
2664struct __declspec(uuid("00000516-0000-0010-8000-00aa006d2ea4")) ADOConnectionConstruction15
2665 : IUnknown
2666{
2667 //
2668 // Property data
2669 //
2670
2671 __declspec(property(get = GetDSO)) IUnknownPtr DSO;
2672 __declspec(property(get = GetSession)) IUnknownPtr Session;
2673
2674 //
2675 // Wrapper methods for error-handling
2676 //
2677
2678 IUnknownPtr GetDSO();
2679 IUnknownPtr GetSession();
2680 HRESULT WrapDSOandSession(IUnknown* pDSO, IUnknown* pSession);
2681
2682 //
2683 // Raw methods provided by interface
2684 //
2685
2686 virtual HRESULT __stdcall get_DSO(
2687 /*[out,retval]*/ IUnknown** ppDSO) = 0;
2688 virtual HRESULT __stdcall get_Session(
2689 /*[out,retval]*/ IUnknown** ppSession) = 0;
2690 virtual HRESULT __stdcall raw_WrapDSOandSession(
2691 /*[in]*/ IUnknown* pDSO,
2692 /*[in]*/ IUnknown* pSession) = 0;
2693};
2694
2695struct __declspec(uuid("00000551-0000-0010-8000-00aa006d2ea4")) ADOConnectionConstruction
2696 : ADOConnectionConstruction15
2697{
2698};
2699
2700struct __declspec(uuid("00000514-0000-0010-8000-00aa006d2ea4")) Connection;
2701// [ default ] interface _Connection
2702// [ default, source ] dispinterface ConnectionEvents
2703
2704struct __declspec(uuid("00000560-0000-0010-8000-00aa006d2ea4")) Record;
2705// [ default ] interface _Record
2706
2707struct __declspec(uuid("00001565-0000-0010-8000-00aa006d2ea4")) _Stream : IDispatch
2708{
2709 //
2710 // Property data
2711 //
2712
2713 __declspec(property(get = GetSize)) long Size;
2714 __declspec(property(get = GetEOS)) VARIANT_BOOL EOS;
2715 __declspec(property(get = GetPosition, put = PutPosition)) long Position;
2716 __declspec(property(get = GetType, put = PutType)) enum StreamTypeEnum Type;
2717 __declspec(property(get = GetLineSeparator,
2718 put = PutLineSeparator)) enum LineSeparatorEnum LineSeparator;
2719 __declspec(property(get = GetState)) enum ObjectStateEnum State;
2720 __declspec(property(get = GetMode, put = PutMode)) enum ConnectModeEnum Mode;
2721 __declspec(property(get = GetCharset, put = PutCharset)) _bstr_t Charset;
2722
2723 //
2724 // Wrapper methods for error-handling
2725 //
2726
2727 long GetSize();
2728 VARIANT_BOOL GetEOS();
2729 long GetPosition();
2730 void PutPosition(long pPos);
2731 enum StreamTypeEnum GetType();
2732 void PutType(enum StreamTypeEnum ptype);
2733 enum LineSeparatorEnum GetLineSeparator();
2734 void PutLineSeparator(enum LineSeparatorEnum pLS);
2735 enum ObjectStateEnum GetState();
2736 enum ConnectModeEnum GetMode();
2737 void PutMode(enum ConnectModeEnum pMode);
2738 _bstr_t GetCharset();
2739 void PutCharset(_bstr_t pbstrCharset);
2740 _variant_t Read(long NumBytes);
2741 HRESULT Open(const _variant_t& Source, enum ConnectModeEnum Mode,
2742 enum StreamOpenOptionsEnum Options, _bstr_t UserName, _bstr_t Password);
2743 HRESULT Close();
2744 HRESULT SkipLine();
2745 HRESULT Write(const _variant_t& Buffer);
2746 HRESULT SetEOS();
2747 HRESULT CopyTo(struct _Stream* DestStream, long CharNumber);
2748 HRESULT Flush();
2749 HRESULT SaveToFile(_bstr_t FileName, enum SaveOptionsEnum Options);
2750 HRESULT LoadFromFile(_bstr_t FileName);
2751 _bstr_t ReadText(long NumChars);
2752 HRESULT WriteText(_bstr_t Data, enum StreamWriteEnum Options);
2753 HRESULT Cancel();
2754
2755 //
2756 // Raw methods provided by interface
2757 //
2758
2759 virtual HRESULT __stdcall get_Size(
2760 /*[out,retval]*/ long* pSize) = 0;
2761 virtual HRESULT __stdcall get_EOS(
2762 /*[out,retval]*/ VARIANT_BOOL* pEOS) = 0;
2763 virtual HRESULT __stdcall get_Position(
2764 /*[out,retval]*/ long* pPos) = 0;
2765 virtual HRESULT __stdcall put_Position(
2766 /*[in]*/ long pPos) = 0;
2767 virtual HRESULT __stdcall get_Type(
2768 /*[out,retval]*/ enum StreamTypeEnum* ptype) = 0;
2769 virtual HRESULT __stdcall put_Type(
2770 /*[in]*/ enum StreamTypeEnum ptype) = 0;
2771 virtual HRESULT __stdcall get_LineSeparator(
2772 /*[out,retval]*/ enum LineSeparatorEnum* pLS) = 0;
2773 virtual HRESULT __stdcall put_LineSeparator(
2774 /*[in]*/ enum LineSeparatorEnum pLS) = 0;
2775 virtual HRESULT __stdcall get_State(
2776 /*[out,retval]*/ enum ObjectStateEnum* pState) = 0;
2777 virtual HRESULT __stdcall get_Mode(
2778 /*[out,retval]*/ enum ConnectModeEnum* pMode) = 0;
2779 virtual HRESULT __stdcall put_Mode(
2780 /*[in]*/ enum ConnectModeEnum pMode) = 0;
2781 virtual HRESULT __stdcall get_Charset(
2782 /*[out,retval]*/ BSTR* pbstrCharset) = 0;
2783 virtual HRESULT __stdcall put_Charset(
2784 /*[in]*/ BSTR pbstrCharset) = 0;
2785 virtual HRESULT __stdcall raw_Read(
2786 /*[in]*/ long NumBytes,
2787 /*[out,retval]*/ VARIANT* pval) = 0;
2788 virtual HRESULT __stdcall raw_Open(
2789 /*[in]*/ VARIANT Source,
2790 /*[in]*/ enum ConnectModeEnum Mode,
2791 /*[in]*/ enum StreamOpenOptionsEnum Options,
2792 /*[in]*/ BSTR UserName,
2793 /*[in]*/ BSTR Password) = 0;
2794 virtual HRESULT __stdcall raw_Close() = 0;
2795 virtual HRESULT __stdcall raw_SkipLine() = 0;
2796 virtual HRESULT __stdcall raw_Write(
2797 /*[in]*/ VARIANT Buffer) = 0;
2798 virtual HRESULT __stdcall raw_SetEOS() = 0;
2799 virtual HRESULT __stdcall raw_CopyTo(
2800 /*[in]*/ struct _Stream* DestStream,
2801 /*[in]*/ long CharNumber) = 0;
2802 virtual HRESULT __stdcall raw_Flush() = 0;
2803 virtual HRESULT __stdcall raw_SaveToFile(
2804 /*[in]*/ BSTR FileName,
2805 /*[in]*/ enum SaveOptionsEnum Options) = 0;
2806 virtual HRESULT __stdcall raw_LoadFromFile(
2807 /*[in]*/ BSTR FileName) = 0;
2808 virtual HRESULT __stdcall raw_ReadText(
2809 /*[in]*/ long NumChars,
2810 /*[out,retval]*/ BSTR* pbstr) = 0;
2811 virtual HRESULT __stdcall raw_WriteText(
2812 /*[in]*/ BSTR Data,
2813 /*[in]*/ enum StreamWriteEnum Options) = 0;
2814 virtual HRESULT __stdcall raw_Cancel() = 0;
2815};
2816
2817struct __declspec(uuid("00000566-0000-0010-8000-00aa006d2ea4")) Stream;
2818// [ default ] interface _Stream
2819
2820struct __declspec(uuid("00000567-0000-0010-8000-00aa006d2ea4")) ADORecordConstruction : IDispatch
2821{
2822 //
2823 // Property data
2824 //
2825
2826 __declspec(property(get = GetRow, put = PutRow)) IUnknownPtr Row;
2827 __declspec(property(put = PutParentRow)) IUnknownPtr ParentRow;
2828
2829 //
2830 // Wrapper methods for error-handling
2831 //
2832
2833 IUnknownPtr GetRow();
2834 void PutRow(IUnknown* ppRow);
2835 void PutParentRow(IUnknown* _arg1);
2836
2837 //
2838 // Raw methods provided by interface
2839 //
2840
2841 virtual HRESULT __stdcall get_Row(
2842 /*[out,retval]*/ IUnknown** ppRow) = 0;
2843 virtual HRESULT __stdcall put_Row(
2844 /*[in]*/ IUnknown* ppRow) = 0;
2845 virtual HRESULT __stdcall put_ParentRow(
2846 /*[in]*/ IUnknown* _arg1) = 0;
2847};
2848
2849struct __declspec(uuid("00000568-0000-0010-8000-00aa006d2ea4")) ADOStreamConstruction : IDispatch
2850{
2851 //
2852 // Property data
2853 //
2854
2855 __declspec(property(get = GetStream, put = PutStream)) IUnknownPtr Stream;
2856
2857 //
2858 // Wrapper methods for error-handling
2859 //
2860
2861 IUnknownPtr GetStream();
2862 void PutStream(IUnknown* ppStm);
2863
2864 //
2865 // Raw methods provided by interface
2866 //
2867
2868 virtual HRESULT __stdcall get_Stream(
2869 /*[out,retval]*/ IUnknown** ppStm) = 0;
2870 virtual HRESULT __stdcall put_Stream(
2871 /*[in]*/ IUnknown* ppStm) = 0;
2872};
2873
2874struct __declspec(uuid("00000517-0000-0010-8000-00aa006d2ea4")) ADOCommandConstruction : IUnknown
2875{
2876 //
2877 // Property data
2878 //
2879
2880 __declspec(property(get = GetOLEDBCommand, put = PutOLEDBCommand)) IUnknownPtr OLEDBCommand;
2881
2882 //
2883 // Wrapper methods for error-handling
2884 //
2885
2886 IUnknownPtr GetOLEDBCommand();
2887 void PutOLEDBCommand(IUnknown* ppOLEDBCommand);
2888
2889 //
2890 // Raw methods provided by interface
2891 //
2892
2893 virtual HRESULT __stdcall get_OLEDBCommand(
2894 /*[out,retval]*/ IUnknown** ppOLEDBCommand) = 0;
2895 virtual HRESULT __stdcall put_OLEDBCommand(
2896 /*[in]*/ IUnknown* ppOLEDBCommand) = 0;
2897};
2898
2899struct __declspec(uuid("00000507-0000-0010-8000-00aa006d2ea4")) Command;
2900// [ default ] interface _Command
2901
2902struct __declspec(uuid("00000535-0000-0010-8000-00aa006d2ea4")) Recordset;
2903// [ default ] interface _Recordset
2904// [ default, source ] dispinterface RecordsetEvents
2905
2906struct __declspec(uuid("00000283-0000-0010-8000-00aa006d2ea4")) ADORecordsetConstruction : IDispatch
2907{
2908 //
2909 // Property data
2910 //
2911
2912 __declspec(property(get = GetRowset, put = PutRowset)) IUnknownPtr Rowset;
2913 __declspec(property(get = GetChapter, put = PutChapter)) ADO_LONGPTR Chapter;
2914 __declspec(property(get = GetRowPosition, put = PutRowPosition)) IUnknownPtr RowPosition;
2915
2916 //
2917 // Wrapper methods for error-handling
2918 //
2919
2920 IUnknownPtr GetRowset();
2921 void PutRowset(IUnknown* ppRowset);
2922 ADO_LONGPTR GetChapter();
2923 void PutChapter(ADO_LONGPTR plChapter);
2924 IUnknownPtr GetRowPosition();
2925 void PutRowPosition(IUnknown* ppRowPos);
2926
2927 //
2928 // Raw methods provided by interface
2929 //
2930
2931 virtual HRESULT __stdcall get_Rowset(
2932 /*[out,retval]*/ IUnknown** ppRowset) = 0;
2933 virtual HRESULT __stdcall put_Rowset(
2934 /*[in]*/ IUnknown* ppRowset) = 0;
2935 virtual HRESULT __stdcall get_Chapter(
2936 /*[out,retval]*/ ADO_LONGPTR* plChapter) = 0;
2937 virtual HRESULT __stdcall put_Chapter(
2938 /*[in]*/ ADO_LONGPTR plChapter) = 0;
2939 virtual HRESULT __stdcall get_RowPosition(
2940 /*[out,retval]*/ IUnknown** ppRowPos) = 0;
2941 virtual HRESULT __stdcall put_RowPosition(
2942 /*[in]*/ IUnknown* ppRowPos) = 0;
2943};
2944
2945struct __declspec(uuid("00001505-0000-0010-8000-00aa006d2ea4")) Field15 : _ADO
2946{
2947 //
2948 // Property data
2949 //
2950
2951 __declspec(property(get = GetValue, put = PutValue)) _variant_t Value;
2952 __declspec(property(get = GetName)) _bstr_t Name;
2953 __declspec(property(get = GetType)) enum DataTypeEnum Type;
2954 __declspec(property(get = GetDefinedSize)) long DefinedSize;
2955 __declspec(property(get = GetOriginalValue)) _variant_t OriginalValue;
2956 __declspec(property(get = GetUnderlyingValue)) _variant_t UnderlyingValue;
2957 __declspec(property(get = GetActualSize)) long ActualSize;
2958 __declspec(property(get = GetPrecision)) unsigned char Precision;
2959 __declspec(property(get = GetNumericScale)) unsigned char NumericScale;
2960 __declspec(property(get = GetAttributes)) long Attributes;
2961
2962 //
2963 // Wrapper methods for error-handling
2964 //
2965
2966 long GetActualSize();
2967 long GetAttributes();
2968 long GetDefinedSize();
2969 _bstr_t GetName();
2970 enum DataTypeEnum GetType();
2971 _variant_t GetValue();
2972 void PutValue(const _variant_t& pvar);
2973 unsigned char GetPrecision();
2974 unsigned char GetNumericScale();
2975 HRESULT AppendChunk(const _variant_t& Data);
2976 _variant_t GetChunk(long Length);
2977 _variant_t GetOriginalValue();
2978 _variant_t GetUnderlyingValue();
2979
2980 //
2981 // Raw methods provided by interface
2982 //
2983
2984 virtual HRESULT __stdcall get_ActualSize(
2985 /*[out,retval]*/ long* pl) = 0;
2986 virtual HRESULT __stdcall get_Attributes(
2987 /*[out,retval]*/ long* pl) = 0;
2988 virtual HRESULT __stdcall get_DefinedSize(
2989 /*[out,retval]*/ long* pl) = 0;
2990 virtual HRESULT __stdcall get_Name(
2991 /*[out,retval]*/ BSTR* pbstr) = 0;
2992 virtual HRESULT __stdcall get_Type(
2993 /*[out,retval]*/ enum DataTypeEnum* pDataType) = 0;
2994 virtual HRESULT __stdcall get_Value(
2995 /*[out,retval]*/ VARIANT* pvar) = 0;
2996 virtual HRESULT __stdcall put_Value(
2997 /*[in]*/ VARIANT pvar) = 0;
2998 virtual HRESULT __stdcall get_Precision(
2999 /*[out,retval]*/ unsigned char* pbPrecision) = 0;
3000 virtual HRESULT __stdcall get_NumericScale(
3001 /*[out,retval]*/ unsigned char* pbNumericScale) = 0;
3002 virtual HRESULT __stdcall raw_AppendChunk(
3003 /*[in]*/ VARIANT Data) = 0;
3004 virtual HRESULT __stdcall raw_GetChunk(
3005 /*[in]*/ long Length,
3006 /*[out,retval]*/ VARIANT* pvar) = 0;
3007 virtual HRESULT __stdcall get_OriginalValue(
3008 /*[out,retval]*/ VARIANT* pvar) = 0;
3009 virtual HRESULT __stdcall get_UnderlyingValue(
3010 /*[out,retval]*/ VARIANT* pvar) = 0;
3011};
3012
3013struct __declspec(uuid("0000050b-0000-0010-8000-00aa006d2ea4")) Parameter;
3014// [ default ] interface _Parameter
3015
3016struct __declspec(uuid("0000054c-0000-0010-8000-00aa006d2ea4")) Field20_Deprecated : _ADO
3017{
3018 //
3019 // Property data
3020 //
3021
3022 __declspec(property(get = GetValue, put = PutValue)) _variant_t Value;
3023 __declspec(property(get = GetName)) _bstr_t Name;
3024 __declspec(property(get = GetType, put = PutType)) enum DataTypeEnum Type;
3025 __declspec(property(get = GetDefinedSize, put = PutDefinedSize)) ADO_LONGPTR DefinedSize;
3026 __declspec(property(get = GetOriginalValue)) _variant_t OriginalValue;
3027 __declspec(property(get = GetUnderlyingValue)) _variant_t UnderlyingValue;
3028 __declspec(property(get = GetActualSize)) ADO_LONGPTR ActualSize;
3029 __declspec(property(get = GetPrecision, put = PutPrecision)) unsigned char Precision;
3030 __declspec(property(get = GetNumericScale, put = PutNumericScale)) unsigned char NumericScale;
3031 __declspec(property(get = GetAttributes, put = PutAttributes)) long Attributes;
3032 __declspec(property(get = GetDataFormat, put = PutRefDataFormat)) IUnknownPtr DataFormat;
3033
3034 //
3035 // Wrapper methods for error-handling
3036 //
3037
3038 ADO_LONGPTR GetActualSize();
3039 long GetAttributes();
3040 ADO_LONGPTR GetDefinedSize();
3041 _bstr_t GetName();
3042 enum DataTypeEnum GetType();
3043 _variant_t GetValue();
3044 void PutValue(const _variant_t& pvar);
3045 unsigned char GetPrecision();
3046 unsigned char GetNumericScale();
3047 HRESULT AppendChunk(const _variant_t& Data);
3048 _variant_t GetChunk(long Length);
3049 _variant_t GetOriginalValue();
3050 _variant_t GetUnderlyingValue();
3051 IUnknownPtr GetDataFormat();
3052 void PutRefDataFormat(IUnknown* ppiDF);
3053 void PutPrecision(unsigned char pbPrecision);
3054 void PutNumericScale(unsigned char pbNumericScale);
3055 void PutType(enum DataTypeEnum pDataType);
3056 void PutDefinedSize(ADO_LONGPTR pl);
3057 void PutAttributes(long pl);
3058
3059 //
3060 // Raw methods provided by interface
3061 //
3062
3063 virtual HRESULT __stdcall get_ActualSize(
3064 /*[out,retval]*/ ADO_LONGPTR* pl) = 0;
3065 virtual HRESULT __stdcall get_Attributes(
3066 /*[out,retval]*/ long* pl) = 0;
3067 virtual HRESULT __stdcall get_DefinedSize(
3068 /*[out,retval]*/ ADO_LONGPTR* pl) = 0;
3069 virtual HRESULT __stdcall get_Name(
3070 /*[out,retval]*/ BSTR* pbstr) = 0;
3071 virtual HRESULT __stdcall get_Type(
3072 /*[out,retval]*/ enum DataTypeEnum* pDataType) = 0;
3073 virtual HRESULT __stdcall get_Value(
3074 /*[out,retval]*/ VARIANT* pvar) = 0;
3075 virtual HRESULT __stdcall put_Value(
3076 /*[in]*/ VARIANT pvar) = 0;
3077 virtual HRESULT __stdcall get_Precision(
3078 /*[out,retval]*/ unsigned char* pbPrecision) = 0;
3079 virtual HRESULT __stdcall get_NumericScale(
3080 /*[out,retval]*/ unsigned char* pbNumericScale) = 0;
3081 virtual HRESULT __stdcall raw_AppendChunk(
3082 /*[in]*/ VARIANT Data) = 0;
3083 virtual HRESULT __stdcall raw_GetChunk(
3084 /*[in]*/ long Length,
3085 /*[out,retval]*/ VARIANT* pvar) = 0;
3086 virtual HRESULT __stdcall get_OriginalValue(
3087 /*[out,retval]*/ VARIANT* pvar) = 0;
3088 virtual HRESULT __stdcall get_UnderlyingValue(
3089 /*[out,retval]*/ VARIANT* pvar) = 0;
3090 virtual HRESULT __stdcall get_DataFormat(
3091 /*[out,retval]*/ IUnknown** ppiDF) = 0;
3092 virtual HRESULT __stdcall putref_DataFormat(
3093 /*[in]*/ IUnknown* ppiDF) = 0;
3094 virtual HRESULT __stdcall put_Precision(
3095 /*[in]*/ unsigned char pbPrecision) = 0;
3096 virtual HRESULT __stdcall put_NumericScale(
3097 /*[in]*/ unsigned char pbNumericScale) = 0;
3098 virtual HRESULT __stdcall put_Type(
3099 /*[in]*/ enum DataTypeEnum pDataType) = 0;
3100 virtual HRESULT __stdcall put_DefinedSize(
3101 /*[in]*/ ADO_LONGPTR pl) = 0;
3102 virtual HRESULT __stdcall put_Attributes(
3103 /*[in]*/ long pl) = 0;
3104};
3105
3106struct __declspec(uuid("00000569-0000-0010-8000-00aa006d2ea4")) Field_Deprecated
3107 : Field20_Deprecated
3108{
3109 //
3110 // Property data
3111 //
3112
3113 __declspec(property(get = GetStatus)) long Status;
3114
3115 //
3116 // Wrapper methods for error-handling
3117 //
3118
3119 long GetStatus();
3120
3121 //
3122 // Raw methods provided by interface
3123 //
3124
3125 virtual HRESULT __stdcall get_Status(
3126 /*[out,retval]*/ long* pFStatus) = 0;
3127};
3128
3129struct __declspec(uuid("00000506-0000-0010-8000-00aa006d2ea4")) Fields15_Deprecated : _Collection
3130{
3131 //
3132 // Property data
3133 //
3134
3135 __declspec(property(get = GetItem)) Field_DeprecatedPtr Item[];
3136
3137 //
3138 // Wrapper methods for error-handling
3139 //
3140
3141 Field_DeprecatedPtr GetItem(const _variant_t& Index);
3142
3143 //
3144 // Raw methods provided by interface
3145 //
3146
3147 virtual HRESULT __stdcall get_Item(
3148 /*[in]*/ VARIANT Index,
3149 /*[out,retval]*/ struct Field_Deprecated** ppvObject) = 0;
3150};
3151
3152struct __declspec(uuid("0000054d-0000-0010-8000-00aa006d2ea4")) Fields20_Deprecated
3153 : Fields15_Deprecated
3154{
3155 //
3156 // Wrapper methods for error-handling
3157 //
3158
3159 HRESULT _Append(_bstr_t Name, enum DataTypeEnum Type, ADO_LONGPTR DefinedSize,
3160 enum FieldAttributeEnum Attrib);
3161 HRESULT Delete(const _variant_t& Index);
3162
3163 //
3164 // Raw methods provided by interface
3165 //
3166
3167 virtual HRESULT __stdcall raw__Append(
3168 /*[in]*/ BSTR Name,
3169 /*[in]*/ enum DataTypeEnum Type,
3170 /*[in]*/ ADO_LONGPTR DefinedSize,
3171 /*[in]*/ enum FieldAttributeEnum Attrib) = 0;
3172 virtual HRESULT __stdcall raw_Delete(
3173 /*[in]*/ VARIANT Index) = 0;
3174};
3175
3176struct __declspec(uuid("00000564-0000-0010-8000-00aa006d2ea4")) Fields_Deprecated
3177 : Fields20_Deprecated
3178{
3179 //
3180 // Wrapper methods for error-handling
3181 //
3182
3183 HRESULT Append(_bstr_t Name, enum DataTypeEnum Type, ADO_LONGPTR DefinedSize,
3184 enum FieldAttributeEnum Attrib, const _variant_t& FieldValue = vtMissing);
3185 HRESULT Update();
3186 HRESULT Resync(enum ResyncEnum ResyncValues);
3187 HRESULT CancelUpdate();
3188
3189 //
3190 // Raw methods provided by interface
3191 //
3192
3193 virtual HRESULT __stdcall raw_Append(
3194 /*[in]*/ BSTR Name,
3195 /*[in]*/ enum DataTypeEnum Type,
3196 /*[in]*/ ADO_LONGPTR DefinedSize,
3197 /*[in]*/ enum FieldAttributeEnum Attrib,
3198 /*[in]*/ VARIANT FieldValue = vtMissing) = 0;
3199 virtual HRESULT __stdcall raw_Update() = 0;
3200 virtual HRESULT __stdcall raw_Resync(
3201 /*[in]*/ enum ResyncEnum ResyncValues) = 0;
3202 virtual HRESULT __stdcall raw_CancelUpdate() = 0;
3203};
3204
3205struct __declspec(uuid("0000050c-0000-0010-8000-00aa006d2ea4")) _Parameter_Deprecated : _ADO
3206{
3207 //
3208 // Property data
3209 //
3210
3211 __declspec(property(get = GetValue, put = PutValue)) _variant_t Value;
3212 __declspec(property(get = GetName, put = PutName)) _bstr_t Name;
3213 __declspec(property(get = GetType, put = PutType)) enum DataTypeEnum Type;
3214 __declspec(property(get = GetDirection,
3215 put = PutDirection)) enum ParameterDirectionEnum Direction;
3216 __declspec(property(get = GetPrecision, put = PutPrecision)) unsigned char Precision;
3217 __declspec(property(get = GetNumericScale, put = PutNumericScale)) unsigned char NumericScale;
3218 __declspec(property(get = GetSize, put = PutSize)) ADO_LONGPTR Size;
3219 __declspec(property(get = GetAttributes, put = PutAttributes)) long Attributes;
3220
3221 //
3222 // Wrapper methods for error-handling
3223 //
3224
3225 _bstr_t GetName();
3226 void PutName(_bstr_t pbstr);
3227 _variant_t GetValue();
3228 void PutValue(const _variant_t& pvar);
3229 enum DataTypeEnum GetType();
3230 void PutType(enum DataTypeEnum psDataType);
3231 void PutDirection(enum ParameterDirectionEnum plParmDirection);
3232 enum ParameterDirectionEnum GetDirection();
3233 void PutPrecision(unsigned char pbPrecision);
3234 unsigned char GetPrecision();
3235 void PutNumericScale(unsigned char pbScale);
3236 unsigned char GetNumericScale();
3237 void PutSize(ADO_LONGPTR pl);
3238 ADO_LONGPTR GetSize();
3239 HRESULT AppendChunk(const _variant_t& Val);
3240 long GetAttributes();
3241 void PutAttributes(long plParmAttribs);
3242
3243 //
3244 // Raw methods provided by interface
3245 //
3246
3247 virtual HRESULT __stdcall get_Name(
3248 /*[out,retval]*/ BSTR* pbstr) = 0;
3249 virtual HRESULT __stdcall put_Name(
3250 /*[in]*/ BSTR pbstr) = 0;
3251 virtual HRESULT __stdcall get_Value(
3252 /*[out,retval]*/ VARIANT* pvar) = 0;
3253 virtual HRESULT __stdcall put_Value(
3254 /*[in]*/ VARIANT pvar) = 0;
3255 virtual HRESULT __stdcall get_Type(
3256 /*[out,retval]*/ enum DataTypeEnum* psDataType) = 0;
3257 virtual HRESULT __stdcall put_Type(
3258 /*[in]*/ enum DataTypeEnum psDataType) = 0;
3259 virtual HRESULT __stdcall put_Direction(
3260 /*[in]*/ enum ParameterDirectionEnum plParmDirection) = 0;
3261 virtual HRESULT __stdcall get_Direction(
3262 /*[out,retval]*/ enum ParameterDirectionEnum* plParmDirection) = 0;
3263 virtual HRESULT __stdcall put_Precision(
3264 /*[in]*/ unsigned char pbPrecision) = 0;
3265 virtual HRESULT __stdcall get_Precision(
3266 /*[out,retval]*/ unsigned char* pbPrecision) = 0;
3267 virtual HRESULT __stdcall put_NumericScale(
3268 /*[in]*/ unsigned char pbScale) = 0;
3269 virtual HRESULT __stdcall get_NumericScale(
3270 /*[out,retval]*/ unsigned char* pbScale) = 0;
3271 virtual HRESULT __stdcall put_Size(
3272 /*[in]*/ ADO_LONGPTR pl) = 0;
3273 virtual HRESULT __stdcall get_Size(
3274 /*[out,retval]*/ ADO_LONGPTR* pl) = 0;
3275 virtual HRESULT __stdcall raw_AppendChunk(
3276 /*[in]*/ VARIANT Val) = 0;
3277 virtual HRESULT __stdcall get_Attributes(
3278 /*[out,retval]*/ long* plParmAttribs) = 0;
3279 virtual HRESULT __stdcall put_Attributes(
3280 /*[in]*/ long plParmAttribs) = 0;
3281};
3282
3283struct __declspec(uuid("0000050d-0000-0010-8000-00aa006d2ea4")) Parameters_Deprecated
3284 : _DynaCollection
3285{
3286 //
3287 // Property data
3288 //
3289
3290 __declspec(property(get = GetItem)) _Parameter_DeprecatedPtr Item[];
3291
3292 //
3293 // Wrapper methods for error-handling
3294 //
3295
3296 _Parameter_DeprecatedPtr GetItem(const _variant_t& Index);
3297
3298 //
3299 // Raw methods provided by interface
3300 //
3301
3302 virtual HRESULT __stdcall get_Item(
3303 /*[in]*/ VARIANT Index,
3304 /*[out,retval]*/ struct _Parameter_Deprecated** ppvObject) = 0;
3305};
3306
3307struct __declspec(uuid("00000400-0000-0010-8000-00aa006d2ea4")) ConnectionEvents_Deprecated
3308 : IDispatch
3309{
3310 //
3311 // Wrapper methods for error-handling
3312 //
3313
3314 // Methods:
3315 HRESULT InfoMessage(struct Error* pError, enum EventStatusEnum* adStatus,
3316 struct _Connection_Deprecated* pConnection);
3317 HRESULT BeginTransComplete(long TransactionLevel, struct Error* pError,
3318 enum EventStatusEnum* adStatus,
3319 struct _Connection_Deprecated* pConnection);
3320 HRESULT CommitTransComplete(struct Error* pError, enum EventStatusEnum* adStatus,
3321 struct _Connection_Deprecated* pConnection);
3322 HRESULT RollbackTransComplete(struct Error* pError, enum EventStatusEnum* adStatus,
3323 struct _Connection_Deprecated* pConnection);
3324 HRESULT WillExecute(BSTR* Source, enum CursorTypeEnum* CursorType, enum LockTypeEnum* LockType,
3325 long* Options, enum EventStatusEnum* adStatus,
3326 struct _Command_Deprecated* pCommand,
3327 struct _Recordset_Deprecated* pRecordset,
3328 struct _Connection_Deprecated* pConnection);
3329 HRESULT ExecuteComplete(long RecordsAffected, struct Error* pError,
3330 enum EventStatusEnum* adStatus, struct _Command_Deprecated* pCommand,
3331 struct _Recordset_Deprecated* pRecordset,
3332 struct _Connection_Deprecated* pConnection);
3333 HRESULT WillConnect(BSTR* ConnectionString, BSTR* UserID, BSTR* Password, long* Options,
3334 enum EventStatusEnum* adStatus, struct _Connection_Deprecated* pConnection);
3335 HRESULT ConnectComplete(struct Error* pError, enum EventStatusEnum* adStatus,
3336 struct _Connection_Deprecated* pConnection);
3337 HRESULT Disconnect(enum EventStatusEnum* adStatus, struct _Connection_Deprecated* pConnection);
3338};
3339
3340struct __declspec(uuid("00000266-0000-0010-8000-00aa006d2ea4")) RecordsetEvents_Deprecated
3341 : IDispatch
3342{
3343 //
3344 // Wrapper methods for error-handling
3345 //
3346
3347 // Methods:
3348 HRESULT WillChangeField(long cFields, const _variant_t& Fields, enum EventStatusEnum* adStatus,
3349 struct _Recordset_Deprecated* pRecordset);
3350 HRESULT FieldChangeComplete(long cFields, const _variant_t& Fields, struct Error* pError,
3351 enum EventStatusEnum* adStatus,
3352 struct _Recordset_Deprecated* pRecordset);
3353 HRESULT WillChangeRecord(enum EventReasonEnum adReason, long cRecords,
3354 enum EventStatusEnum* adStatus,
3355 struct _Recordset_Deprecated* pRecordset);
3356 HRESULT RecordChangeComplete(enum EventReasonEnum adReason, long cRecords, struct Error* pError,
3357 enum EventStatusEnum* adStatus,
3358 struct _Recordset_Deprecated* pRecordset);
3359 HRESULT WillChangeRecordset(enum EventReasonEnum adReason, enum EventStatusEnum* adStatus,
3360 struct _Recordset_Deprecated* pRecordset);
3361 HRESULT RecordsetChangeComplete(enum EventReasonEnum adReason, struct Error* pError,
3362 enum EventStatusEnum* adStatus,
3363 struct _Recordset_Deprecated* pRecordset);
3364 HRESULT WillMove(enum EventReasonEnum adReason, enum EventStatusEnum* adStatus,
3365 struct _Recordset_Deprecated* pRecordset);
3366 HRESULT MoveComplete(enum EventReasonEnum adReason, struct Error* pError,
3367 enum EventStatusEnum* adStatus, struct _Recordset_Deprecated* pRecordset);
3368 HRESULT EndOfRecordset(VARIANT_BOOL* fMoreData, enum EventStatusEnum* adStatus,
3369 struct _Recordset_Deprecated* pRecordset);
3370 HRESULT FetchProgress(long Progress, long MaxProgress, enum EventStatusEnum* adStatus,
3371 struct _Recordset_Deprecated* pRecordset);
3372 HRESULT FetchComplete(struct Error* pError, enum EventStatusEnum* adStatus,
3373 struct _Recordset_Deprecated* pRecordset);
3374};
3375
3376struct __declspec(uuid("00000565-0000-0010-8000-00aa006d2ea4")) _Stream_Deprecated : IDispatch
3377{
3378 //
3379 // Property data
3380 //
3381
3382 __declspec(property(get = GetSize)) ADO_LONGPTR Size;
3383 __declspec(property(get = GetEOS)) VARIANT_BOOL EOS;
3384 __declspec(property(get = GetPosition, put = PutPosition)) ADO_LONGPTR Position;
3385 __declspec(property(get = GetType, put = PutType)) enum StreamTypeEnum Type;
3386 __declspec(property(get = GetLineSeparator,
3387 put = PutLineSeparator)) enum LineSeparatorEnum LineSeparator;
3388 __declspec(property(get = GetState)) enum ObjectStateEnum State;
3389 __declspec(property(get = GetMode, put = PutMode)) enum ConnectModeEnum Mode;
3390 __declspec(property(get = GetCharset, put = PutCharset)) _bstr_t Charset;
3391
3392 //
3393 // Wrapper methods for error-handling
3394 //
3395
3396 ADO_LONGPTR GetSize();
3397 VARIANT_BOOL GetEOS();
3398 ADO_LONGPTR GetPosition();
3399 void PutPosition(ADO_LONGPTR pPos);
3400 enum StreamTypeEnum GetType();
3401 void PutType(enum StreamTypeEnum ptype);
3402 enum LineSeparatorEnum GetLineSeparator();
3403 void PutLineSeparator(enum LineSeparatorEnum pLS);
3404 enum ObjectStateEnum GetState();
3405 enum ConnectModeEnum GetMode();
3406 void PutMode(enum ConnectModeEnum pMode);
3407 _bstr_t GetCharset();
3408 void PutCharset(_bstr_t pbstrCharset);
3409 _variant_t Read(long NumBytes);
3410 HRESULT Open(const _variant_t& Source, enum ConnectModeEnum Mode,
3411 enum StreamOpenOptionsEnum Options, _bstr_t UserName, _bstr_t Password);
3412 HRESULT Close();
3413 HRESULT SkipLine();
3414 HRESULT Write(const _variant_t& Buffer);
3415 HRESULT SetEOS();
3416 HRESULT CopyTo(struct _Stream_Deprecated* DestStream, ADO_LONGPTR CharNumber);
3417 HRESULT Flush();
3418 HRESULT SaveToFile(_bstr_t FileName, enum SaveOptionsEnum Options);
3419 HRESULT LoadFromFile(_bstr_t FileName);
3420 _bstr_t ReadText(long NumChars);
3421 HRESULT WriteText(_bstr_t Data, enum StreamWriteEnum Options);
3422 HRESULT Cancel();
3423
3424 //
3425 // Raw methods provided by interface
3426 //
3427
3428 virtual HRESULT __stdcall get_Size(
3429 /*[out,retval]*/ ADO_LONGPTR* pSize) = 0;
3430 virtual HRESULT __stdcall get_EOS(
3431 /*[out,retval]*/ VARIANT_BOOL* pEOS) = 0;
3432 virtual HRESULT __stdcall get_Position(
3433 /*[out,retval]*/ ADO_LONGPTR* pPos) = 0;
3434 virtual HRESULT __stdcall put_Position(
3435 /*[in]*/ ADO_LONGPTR pPos) = 0;
3436 virtual HRESULT __stdcall get_Type(
3437 /*[out,retval]*/ enum StreamTypeEnum* ptype) = 0;
3438 virtual HRESULT __stdcall put_Type(
3439 /*[in]*/ enum StreamTypeEnum ptype) = 0;
3440 virtual HRESULT __stdcall get_LineSeparator(
3441 /*[out,retval]*/ enum LineSeparatorEnum* pLS) = 0;
3442 virtual HRESULT __stdcall put_LineSeparator(
3443 /*[in]*/ enum LineSeparatorEnum pLS) = 0;
3444 virtual HRESULT __stdcall get_State(
3445 /*[out,retval]*/ enum ObjectStateEnum* pState) = 0;
3446 virtual HRESULT __stdcall get_Mode(
3447 /*[out,retval]*/ enum ConnectModeEnum* pMode) = 0;
3448 virtual HRESULT __stdcall put_Mode(
3449 /*[in]*/ enum ConnectModeEnum pMode) = 0;
3450 virtual HRESULT __stdcall get_Charset(
3451 /*[out,retval]*/ BSTR* pbstrCharset) = 0;
3452 virtual HRESULT __stdcall put_Charset(
3453 /*[in]*/ BSTR pbstrCharset) = 0;
3454 virtual HRESULT __stdcall raw_Read(
3455 /*[in]*/ long NumBytes,
3456 /*[out,retval]*/ VARIANT* pval) = 0;
3457 virtual HRESULT __stdcall raw_Open(
3458 /*[in]*/ VARIANT Source,
3459 /*[in]*/ enum ConnectModeEnum Mode,
3460 /*[in]*/ enum StreamOpenOptionsEnum Options,
3461 /*[in]*/ BSTR UserName,
3462 /*[in]*/ BSTR Password) = 0;
3463 virtual HRESULT __stdcall raw_Close() = 0;
3464 virtual HRESULT __stdcall raw_SkipLine() = 0;
3465 virtual HRESULT __stdcall raw_Write(
3466 /*[in]*/ VARIANT Buffer) = 0;
3467 virtual HRESULT __stdcall raw_SetEOS() = 0;
3468 virtual HRESULT __stdcall raw_CopyTo(
3469 /*[in]*/ struct _Stream_Deprecated* DestStream,
3470 /*[in]*/ ADO_LONGPTR CharNumber) = 0;
3471 virtual HRESULT __stdcall raw_Flush() = 0;
3472 virtual HRESULT __stdcall raw_SaveToFile(
3473 /*[in]*/ BSTR FileName,
3474 /*[in]*/ enum SaveOptionsEnum Options) = 0;
3475 virtual HRESULT __stdcall raw_LoadFromFile(
3476 /*[in]*/ BSTR FileName) = 0;
3477 virtual HRESULT __stdcall raw_ReadText(
3478 /*[in]*/ long NumChars,
3479 /*[out,retval]*/ BSTR* pbstr) = 0;
3480 virtual HRESULT __stdcall raw_WriteText(
3481 /*[in]*/ BSTR Data,
3482 /*[in]*/ enum StreamWriteEnum Options) = 0;
3483 virtual HRESULT __stdcall raw_Cancel() = 0;
3484};
3485
3486struct __declspec(uuid("00000505-0000-0010-8000-00aa006d2ea4")) Field15_Deprecated : _ADO
3487{
3488 //
3489 // Property data
3490 //
3491
3492 __declspec(property(get = GetValue, put = PutValue)) _variant_t Value;
3493 __declspec(property(get = GetName)) _bstr_t Name;
3494 __declspec(property(get = GetType)) enum DataTypeEnum Type;
3495 __declspec(property(get = GetDefinedSize)) ADO_LONGPTR DefinedSize;
3496 __declspec(property(get = GetOriginalValue)) _variant_t OriginalValue;
3497 __declspec(property(get = GetUnderlyingValue)) _variant_t UnderlyingValue;
3498 __declspec(property(get = GetActualSize)) ADO_LONGPTR ActualSize;
3499 __declspec(property(get = GetPrecision)) unsigned char Precision;
3500 __declspec(property(get = GetNumericScale)) unsigned char NumericScale;
3501 __declspec(property(get = GetAttributes)) long Attributes;
3502
3503 //
3504 // Wrapper methods for error-handling
3505 //
3506
3507 ADO_LONGPTR GetActualSize();
3508 long GetAttributes();
3509 ADO_LONGPTR GetDefinedSize();
3510 _bstr_t GetName();
3511 enum DataTypeEnum GetType();
3512 _variant_t GetValue();
3513 void PutValue(const _variant_t& pvar);
3514 unsigned char GetPrecision();
3515 unsigned char GetNumericScale();
3516 HRESULT AppendChunk(const _variant_t& Data);
3517 _variant_t GetChunk(long Length);
3518 _variant_t GetOriginalValue();
3519 _variant_t GetUnderlyingValue();
3520
3521 //
3522 // Raw methods provided by interface
3523 //
3524
3525 virtual HRESULT __stdcall get_ActualSize(
3526 /*[out,retval]*/ ADO_LONGPTR* pl) = 0;
3527 virtual HRESULT __stdcall get_Attributes(
3528 /*[out,retval]*/ long* pl) = 0;
3529 virtual HRESULT __stdcall get_DefinedSize(
3530 /*[out,retval]*/ ADO_LONGPTR* pl) = 0;
3531 virtual HRESULT __stdcall get_Name(
3532 /*[out,retval]*/ BSTR* pbstr) = 0;
3533 virtual HRESULT __stdcall get_Type(
3534 /*[out,retval]*/ enum DataTypeEnum* pDataType) = 0;
3535 virtual HRESULT __stdcall get_Value(
3536 /*[out,retval]*/ VARIANT* pvar) = 0;
3537 virtual HRESULT __stdcall put_Value(
3538 /*[in]*/ VARIANT pvar) = 0;
3539 virtual HRESULT __stdcall get_Precision(
3540 /*[out,retval]*/ unsigned char* pbPrecision) = 0;
3541 virtual HRESULT __stdcall get_NumericScale(
3542 /*[out,retval]*/ unsigned char* pbNumericScale) = 0;
3543 virtual HRESULT __stdcall raw_AppendChunk(
3544 /*[in]*/ VARIANT Data) = 0;
3545 virtual HRESULT __stdcall raw_GetChunk(
3546 /*[in]*/ long Length,
3547 /*[out,retval]*/ VARIANT* pvar) = 0;
3548 virtual HRESULT __stdcall get_OriginalValue(
3549 /*[out,retval]*/ VARIANT* pvar) = 0;
3550 virtual HRESULT __stdcall get_UnderlyingValue(
3551 /*[out,retval]*/ VARIANT* pvar) = 0;
3552};
3553
3554struct __declspec(uuid("00001508-0000-0010-8000-00aa006d2ea4")) Command15 : _ADO
3555{
3556 //
3557 // Property data
3558 //
3559
3560 __declspec(property(get = GetParameters)) ParametersPtr Parameters;
3561 __declspec(property(get = GetActiveConnection,
3562 put = PutRefActiveConnection)) _ConnectionPtr ActiveConnection;
3563 __declspec(property(get = GetCommandText, put = PutCommandText)) _bstr_t CommandText;
3564 __declspec(property(get = GetCommandTimeout, put = PutCommandTimeout)) long CommandTimeout;
3565 __declspec(property(get = GetPrepared, put = PutPrepared)) VARIANT_BOOL Prepared;
3566 __declspec(property(get = GetCommandType,
3567 put = PutCommandType)) enum CommandTypeEnum CommandType;
3568 __declspec(property(get = GetName, put = PutName)) _bstr_t Name;
3569
3570 //
3571 // Wrapper methods for error-handling
3572 //
3573
3574 _ConnectionPtr GetActiveConnection();
3575 void PutRefActiveConnection(struct _Connection* ppvObject);
3576 void PutActiveConnection(const _variant_t& ppvObject);
3577 _bstr_t GetCommandText();
3578 void PutCommandText(_bstr_t pbstr);
3579 long GetCommandTimeout();
3580 void PutCommandTimeout(long pl);
3581 VARIANT_BOOL GetPrepared();
3582 void PutPrepared(VARIANT_BOOL pfPrepared);
3583 _RecordsetPtr Execute(VARIANT* RecordsAffected, VARIANT* Parameters, long Options);
3584 _ParameterPtr CreateParameter(_bstr_t Name, enum DataTypeEnum Type,
3585 enum ParameterDirectionEnum Direction, long Size,
3586 const _variant_t& Value = vtMissing);
3587 ParametersPtr GetParameters();
3588 void PutCommandType(enum CommandTypeEnum plCmdType);
3589 enum CommandTypeEnum GetCommandType();
3590 _bstr_t GetName();
3591 void PutName(_bstr_t pbstrName);
3592
3593 //
3594 // Raw methods provided by interface
3595 //
3596
3597 virtual HRESULT __stdcall get_ActiveConnection(
3598 /*[out,retval]*/ struct _Connection** ppvObject) = 0;
3599 virtual HRESULT __stdcall putref_ActiveConnection(
3600 /*[in]*/ struct _Connection* ppvObject) = 0;
3601 virtual HRESULT __stdcall put_ActiveConnection(
3602 /*[in]*/ VARIANT ppvObject) = 0;
3603 virtual HRESULT __stdcall get_CommandText(
3604 /*[out,retval]*/ BSTR* pbstr) = 0;
3605 virtual HRESULT __stdcall put_CommandText(
3606 /*[in]*/ BSTR pbstr) = 0;
3607 virtual HRESULT __stdcall get_CommandTimeout(
3608 /*[out,retval]*/ long* pl) = 0;
3609 virtual HRESULT __stdcall put_CommandTimeout(
3610 /*[in]*/ long pl) = 0;
3611 virtual HRESULT __stdcall get_Prepared(
3612 /*[out,retval]*/ VARIANT_BOOL* pfPrepared) = 0;
3613 virtual HRESULT __stdcall put_Prepared(
3614 /*[in]*/ VARIANT_BOOL pfPrepared) = 0;
3615 virtual HRESULT __stdcall raw_Execute(
3616 /*[out]*/ VARIANT* RecordsAffected,
3617 /*[in]*/ VARIANT* Parameters,
3618 /*[in]*/ long Options,
3619 /*[out,retval]*/ struct _Recordset** ppiRs) = 0;
3620 virtual HRESULT __stdcall raw_CreateParameter(
3621 /*[in]*/ BSTR Name,
3622 /*[in]*/ enum DataTypeEnum Type,
3623 /*[in]*/ enum ParameterDirectionEnum Direction,
3624 /*[in]*/ long Size,
3625 /*[in]*/ VARIANT Value,
3626 /*[out,retval]*/ struct _Parameter** ppiprm) = 0;
3627 virtual HRESULT __stdcall get_Parameters(
3628 /*[out,retval]*/ struct Parameters** ppvObject) = 0;
3629 virtual HRESULT __stdcall put_CommandType(
3630 /*[in]*/ enum CommandTypeEnum plCmdType) = 0;
3631 virtual HRESULT __stdcall get_CommandType(
3632 /*[out,retval]*/ enum CommandTypeEnum* plCmdType) = 0;
3633 virtual HRESULT __stdcall get_Name(
3634 /*[out,retval]*/ BSTR* pbstrName) = 0;
3635 virtual HRESULT __stdcall put_Name(
3636 /*[in]*/ BSTR pbstrName) = 0;
3637};
3638
3639struct __declspec(uuid("0000154e-0000-0010-8000-00aa006d2ea4")) Command25 : Command15
3640{
3641 //
3642 // Property data
3643 //
3644
3645 __declspec(property(get = GetState)) long State;
3646
3647 //
3648 // Wrapper methods for error-handling
3649 //
3650
3651 long GetState();
3652 HRESULT Cancel();
3653
3654 //
3655 // Raw methods provided by interface
3656 //
3657
3658 virtual HRESULT __stdcall get_State(
3659 /*[out,retval]*/ long* plObjState) = 0;
3660 virtual HRESULT __stdcall raw_Cancel() = 0;
3661};
3662
3663struct __declspec(uuid("986761e8-7269-4890-aa65-ad7c03697a6d")) _Command : Command25
3664{
3665 //
3666 // Property data
3667 //
3668
3669 __declspec(property(get = GetDialect, put = PutDialect)) _bstr_t Dialect;
3670 __declspec(property(get = GetNamedParameters,
3671 put = PutNamedParameters)) VARIANT_BOOL NamedParameters;
3672
3673 //
3674 // Wrapper methods for error-handling
3675 //
3676
3677 void PutRefCommandStream(IUnknown* pvStream);
3678 _variant_t GetCommandStream();
3679 void PutDialect(_bstr_t pbstrDialect);
3680 _bstr_t GetDialect();
3681 void PutNamedParameters(VARIANT_BOOL pfNamedParameters);
3682 VARIANT_BOOL GetNamedParameters();
3683
3684 //
3685 // Raw methods provided by interface
3686 //
3687
3688 virtual HRESULT __stdcall putref_CommandStream(
3689 /*[in]*/ IUnknown* pvStream) = 0;
3690 virtual HRESULT __stdcall get_CommandStream(
3691 /*[out,retval]*/ VARIANT* pvStream) = 0;
3692 virtual HRESULT __stdcall put_Dialect(
3693 /*[in]*/ BSTR pbstrDialect) = 0;
3694 virtual HRESULT __stdcall get_Dialect(
3695 /*[out,retval]*/ BSTR* pbstrDialect) = 0;
3696 virtual HRESULT __stdcall put_NamedParameters(
3697 /*[in]*/ VARIANT_BOOL pfNamedParameters) = 0;
3698 virtual HRESULT __stdcall get_NamedParameters(
3699 /*[out,retval]*/ VARIANT_BOOL* pfNamedParameters) = 0;
3700};
3701
3702struct __declspec(uuid("00001515-0000-0010-8000-00aa006d2ea4")) Connection15 : _ADO
3703{
3704 //
3705 // Property data
3706 //
3707
3708 __declspec(property(get = GetConnectionString,
3709 put = PutConnectionString)) _bstr_t ConnectionString;
3710 __declspec(property(get = GetCommandTimeout, put = PutCommandTimeout)) long CommandTimeout;
3711 __declspec(property(get = GetConnectionTimeout,
3712 put = PutConnectionTimeout)) long ConnectionTimeout;
3713 __declspec(property(get = GetVersion)) _bstr_t Version;
3714 __declspec(property(get = GetErrors)) ErrorsPtr Errors;
3715 __declspec(property(get = GetDefaultDatabase,
3716 put = PutDefaultDatabase)) _bstr_t DefaultDatabase;
3717 __declspec(property(get = GetIsolationLevel,
3718 put = PutIsolationLevel)) enum IsolationLevelEnum IsolationLevel;
3719 __declspec(property(get = GetAttributes, put = PutAttributes)) long Attributes;
3720 __declspec(property(get = GetCursorLocation,
3721 put = PutCursorLocation)) enum CursorLocationEnum CursorLocation;
3722 __declspec(property(get = GetMode, put = PutMode)) enum ConnectModeEnum Mode;
3723 __declspec(property(get = GetProvider, put = PutProvider)) _bstr_t Provider;
3724 __declspec(property(get = GetState)) long State;
3725
3726 //
3727 // Wrapper methods for error-handling
3728 //
3729
3730 _bstr_t GetConnectionString();
3731 void PutConnectionString(_bstr_t pbstr);
3732 long GetCommandTimeout();
3733 void PutCommandTimeout(long plTimeout);
3734 long GetConnectionTimeout();
3735 void PutConnectionTimeout(long plTimeout);
3736 _bstr_t GetVersion();
3737 HRESULT Close();
3738 _RecordsetPtr Execute(_bstr_t CommandText, VARIANT* RecordsAffected, long Options);
3739 long BeginTrans();
3740 HRESULT CommitTrans();
3741 HRESULT RollbackTrans();
3742 HRESULT Open(_bstr_t ConnectionString, _bstr_t UserID, _bstr_t Password, long Options);
3743 ErrorsPtr GetErrors();
3744 _bstr_t GetDefaultDatabase();
3745 void PutDefaultDatabase(_bstr_t pbstr);
3746 enum IsolationLevelEnum GetIsolationLevel();
3747 void PutIsolationLevel(enum IsolationLevelEnum Level);
3748 long GetAttributes();
3749 void PutAttributes(long plAttr);
3750 enum CursorLocationEnum GetCursorLocation();
3751 void PutCursorLocation(enum CursorLocationEnum plCursorLoc);
3752 enum ConnectModeEnum GetMode();
3753 void PutMode(enum ConnectModeEnum plMode);
3754 _bstr_t GetProvider();
3755 void PutProvider(_bstr_t pbstr);
3756 long GetState();
3757 _RecordsetPtr OpenSchema(enum SchemaEnum Schema, const _variant_t& Restrictions = vtMissing,
3758 const _variant_t& SchemaID = vtMissing);
3759
3760 //
3761 // Raw methods provided by interface
3762 //
3763
3764 virtual HRESULT __stdcall get_ConnectionString(
3765 /*[out,retval]*/ BSTR* pbstr) = 0;
3766 virtual HRESULT __stdcall put_ConnectionString(
3767 /*[in]*/ BSTR pbstr) = 0;
3768 virtual HRESULT __stdcall get_CommandTimeout(
3769 /*[out,retval]*/ long* plTimeout) = 0;
3770 virtual HRESULT __stdcall put_CommandTimeout(
3771 /*[in]*/ long plTimeout) = 0;
3772 virtual HRESULT __stdcall get_ConnectionTimeout(
3773 /*[out,retval]*/ long* plTimeout) = 0;
3774 virtual HRESULT __stdcall put_ConnectionTimeout(
3775 /*[in]*/ long plTimeout) = 0;
3776 virtual HRESULT __stdcall get_Version(
3777 /*[out,retval]*/ BSTR* pbstr) = 0;
3778 virtual HRESULT __stdcall raw_Close() = 0;
3779 virtual HRESULT __stdcall raw_Execute(
3780 /*[in]*/ BSTR CommandText,
3781 /*[out]*/ VARIANT* RecordsAffected,
3782 /*[in]*/ long Options,
3783 /*[out,retval]*/ struct _Recordset** ppiRset) = 0;
3784 virtual HRESULT __stdcall raw_BeginTrans(
3785 /*[out,retval]*/ long* TransactionLevel) = 0;
3786 virtual HRESULT __stdcall raw_CommitTrans() = 0;
3787 virtual HRESULT __stdcall raw_RollbackTrans() = 0;
3788 virtual HRESULT __stdcall raw_Open(
3789 /*[in]*/ BSTR ConnectionString,
3790 /*[in]*/ BSTR UserID,
3791 /*[in]*/ BSTR Password,
3792 /*[in]*/ long Options) = 0;
3793 virtual HRESULT __stdcall get_Errors(
3794 /*[out,retval]*/ struct Errors** ppvObject) = 0;
3795 virtual HRESULT __stdcall get_DefaultDatabase(
3796 /*[out,retval]*/ BSTR* pbstr) = 0;
3797 virtual HRESULT __stdcall put_DefaultDatabase(
3798 /*[in]*/ BSTR pbstr) = 0;
3799 virtual HRESULT __stdcall get_IsolationLevel(
3800 /*[out,retval]*/ enum IsolationLevelEnum* Level) = 0;
3801 virtual HRESULT __stdcall put_IsolationLevel(
3802 /*[in]*/ enum IsolationLevelEnum Level) = 0;
3803 virtual HRESULT __stdcall get_Attributes(
3804 /*[out,retval]*/ long* plAttr) = 0;
3805 virtual HRESULT __stdcall put_Attributes(
3806 /*[in]*/ long plAttr) = 0;
3807 virtual HRESULT __stdcall get_CursorLocation(
3808 /*[out,retval]*/ enum CursorLocationEnum* plCursorLoc) = 0;
3809 virtual HRESULT __stdcall put_CursorLocation(
3810 /*[in]*/ enum CursorLocationEnum plCursorLoc) = 0;
3811 virtual HRESULT __stdcall get_Mode(
3812 /*[out,retval]*/ enum ConnectModeEnum* plMode) = 0;
3813 virtual HRESULT __stdcall put_Mode(
3814 /*[in]*/ enum ConnectModeEnum plMode) = 0;
3815 virtual HRESULT __stdcall get_Provider(
3816 /*[out,retval]*/ BSTR* pbstr) = 0;
3817 virtual HRESULT __stdcall put_Provider(
3818 /*[in]*/ BSTR pbstr) = 0;
3819 virtual HRESULT __stdcall get_State(
3820 /*[out,retval]*/ long* plObjState) = 0;
3821 virtual HRESULT __stdcall raw_OpenSchema(
3822 /*[in]*/ enum SchemaEnum Schema,
3823 /*[in]*/ VARIANT Restrictions,
3824 /*[in]*/ VARIANT SchemaID,
3825 /*[out,retval]*/ struct _Recordset** pprset) = 0;
3826};
3827
3828struct __declspec(uuid("00001550-0000-0010-8000-00aa006d2ea4")) _Connection : Connection15
3829{
3830 //
3831 // Wrapper methods for error-handling
3832 //
3833
3834 HRESULT Cancel();
3835
3836 //
3837 // Raw methods provided by interface
3838 //
3839
3840 virtual HRESULT __stdcall raw_Cancel() = 0;
3841};
3842
3843struct __declspec(uuid("0000150e-0000-0010-8000-00aa006d2ea4")) Recordset15 : _ADO
3844{
3845 //
3846 // Property data
3847 //
3848
3849 __declspec(property(get = GetFields)) FieldsPtr Fields;
3850 __declspec(property(get = GetPageSize, put = PutPageSize)) long PageSize;
3851 __declspec(property(get = GetPageCount)) long PageCount;
3852 __declspec(property(get = GetCursorLocation,
3853 put = PutCursorLocation)) enum CursorLocationEnum CursorLocation;
3854 __declspec(property(get = GetState)) long State;
3855 __declspec(property(get = GetMarshalOptions,
3856 put = PutMarshalOptions)) enum MarshalOptionsEnum MarshalOptions;
3857 __declspec(property(get = GetCollect, put = PutCollect)) _variant_t Collect[];
3858 __declspec(property(get = GetEditMode)) enum EditModeEnum EditMode;
3859 __declspec(property(get = GetStatus)) long Status;
3860 __declspec(property(get = GetFilter, put = PutFilter)) _variant_t Filter;
3861 __declspec(property(get = GetSort, put = PutSort)) _bstr_t Sort;
3862 __declspec(property(get = GetAbsolutePosition,
3863 put = PutAbsolutePosition)) enum PositionEnum AbsolutePosition;
3864 __declspec(property(get = GetbBOF)) VARIANT_BOOL bBOF;
3865 __declspec(property(get = GetBookmark, put = PutBookmark)) _variant_t Bookmark;
3866 __declspec(property(get = GetCacheSize, put = PutCacheSize)) long CacheSize;
3867 __declspec(property(get = GetCursorType, put = PutCursorType)) enum CursorTypeEnum CursorType;
3868 __declspec(property(get = GetbEOF)) VARIANT_BOOL bEOF;
3869 __declspec(property(get = GetAbsolutePage,
3870 put = PutAbsolutePage)) enum PositionEnum AbsolutePage;
3871 __declspec(property(get = GetLockType, put = PutLockType)) enum LockTypeEnum LockType;
3872 __declspec(property(get = GetMaxRecords, put = PutMaxRecords)) long MaxRecords;
3873 __declspec(property(get = GetRecordCount)) long RecordCount;
3874
3875 //
3876 // Wrapper methods for error-handling
3877 //
3878
3879 enum PositionEnum GetAbsolutePosition();
3880 void PutAbsolutePosition(enum PositionEnum pl);
3881 void PutRefActiveConnection(IDispatch* pvar);
3882 void PutActiveConnection(const _variant_t& pvar);
3883 _variant_t GetActiveConnection();
3884 VARIANT_BOOL GetbBOF();
3885 _variant_t GetBookmark();
3886 void PutBookmark(const _variant_t& pvBookmark);
3887 long GetCacheSize();
3888 void PutCacheSize(long pl);
3889 enum CursorTypeEnum GetCursorType();
3890 void PutCursorType(enum CursorTypeEnum plCursorType);
3891 VARIANT_BOOL GetbEOF();
3892 FieldsPtr GetFields();
3893 enum LockTypeEnum GetLockType();
3894 void PutLockType(enum LockTypeEnum plLockType);
3895 long GetMaxRecords();
3896 void PutMaxRecords(long plMaxRecords);
3897 long GetRecordCount();
3898 void PutRefSource(IDispatch* pvSource);
3899 void PutSource(_bstr_t pvSource);
3900 _variant_t GetSource();
3901 HRESULT AddNew(const _variant_t& FieldList = vtMissing, const _variant_t& Values = vtMissing);
3902 HRESULT CancelUpdate();
3903 HRESULT Close();
3904 HRESULT Delete(enum AffectEnum AffectRecords);
3905 _variant_t GetRows(long Rows, const _variant_t& Start = vtMissing,
3906 const _variant_t& Fields = vtMissing);
3907 HRESULT Move(long NumRecords, const _variant_t& Start = vtMissing);
3908 HRESULT MoveNext();
3909 HRESULT MovePrevious();
3910 HRESULT MoveFirst();
3911 HRESULT MoveLast();
3912 HRESULT Open(const _variant_t& Source, const _variant_t& ActiveConnection,
3913 enum CursorTypeEnum CursorType, enum LockTypeEnum LockType, long Options);
3914 HRESULT Requery(long Options);
3915 HRESULT _xResync(enum AffectEnum AffectRecords);
3916 HRESULT Update(const _variant_t& Fields = vtMissing, const _variant_t& Values = vtMissing);
3917 enum PositionEnum GetAbsolutePage();
3918 void PutAbsolutePage(enum PositionEnum pl);
3919 enum EditModeEnum GetEditMode();
3920 _variant_t GetFilter();
3921 void PutFilter(const _variant_t& Criteria);
3922 long GetPageCount();
3923 long GetPageSize();
3924 void PutPageSize(long pl);
3925 _bstr_t GetSort();
3926 void PutSort(_bstr_t Criteria);
3927 long GetStatus();
3928 long GetState();
3929 _RecordsetPtr _xClone();
3930 HRESULT UpdateBatch(enum AffectEnum AffectRecords);
3931 HRESULT CancelBatch(enum AffectEnum AffectRecords);
3932 enum CursorLocationEnum GetCursorLocation();
3933 void PutCursorLocation(enum CursorLocationEnum plCursorLoc);
3934 _RecordsetPtr NextRecordset(VARIANT* RecordsAffected);
3935 VARIANT_BOOL Supports(enum CursorOptionEnum CursorOptions);
3936 _variant_t GetCollect(const _variant_t& Index);
3937 void PutCollect(const _variant_t& Index, const _variant_t& pvar);
3938 enum MarshalOptionsEnum GetMarshalOptions();
3939 void PutMarshalOptions(enum MarshalOptionsEnum peMarshal);
3940 HRESULT Find(_bstr_t Criteria, long SkipRecords, enum SearchDirectionEnum SearchDirection,
3941 const _variant_t& Start = vtMissing);
3942
3943 //
3944 // Raw methods provided by interface
3945 //
3946
3947 virtual HRESULT __stdcall get_AbsolutePosition(
3948 /*[out,retval]*/ enum PositionEnum* pl) = 0;
3949 virtual HRESULT __stdcall put_AbsolutePosition(
3950 /*[in]*/ enum PositionEnum pl) = 0;
3951 virtual HRESULT __stdcall putref_ActiveConnection(
3952 /*[in]*/ IDispatch* pvar) = 0;
3953 virtual HRESULT __stdcall put_ActiveConnection(
3954 /*[in]*/ VARIANT pvar) = 0;
3955 virtual HRESULT __stdcall get_ActiveConnection(
3956 /*[out,retval]*/ VARIANT* pvar) = 0;
3957 virtual HRESULT __stdcall get_bBOF(
3958 /*[out,retval]*/ VARIANT_BOOL* pb) = 0;
3959 virtual HRESULT __stdcall get_Bookmark(
3960 /*[out,retval]*/ VARIANT* pvBookmark) = 0;
3961 virtual HRESULT __stdcall put_Bookmark(
3962 /*[in]*/ VARIANT pvBookmark) = 0;
3963 virtual HRESULT __stdcall get_CacheSize(
3964 /*[out,retval]*/ long* pl) = 0;
3965 virtual HRESULT __stdcall put_CacheSize(
3966 /*[in]*/ long pl) = 0;
3967 virtual HRESULT __stdcall get_CursorType(
3968 /*[out,retval]*/ enum CursorTypeEnum* plCursorType) = 0;
3969 virtual HRESULT __stdcall put_CursorType(
3970 /*[in]*/ enum CursorTypeEnum plCursorType) = 0;
3971 virtual HRESULT __stdcall get_bEOF(
3972 /*[out,retval]*/ VARIANT_BOOL* pb) = 0;
3973 virtual HRESULT __stdcall get_Fields(
3974 /*[out,retval]*/ struct Fields** ppvObject) = 0;
3975 virtual HRESULT __stdcall get_LockType(
3976 /*[out,retval]*/ enum LockTypeEnum* plLockType) = 0;
3977 virtual HRESULT __stdcall put_LockType(
3978 /*[in]*/ enum LockTypeEnum plLockType) = 0;
3979 virtual HRESULT __stdcall get_MaxRecords(
3980 /*[out,retval]*/ long* plMaxRecords) = 0;
3981 virtual HRESULT __stdcall put_MaxRecords(
3982 /*[in]*/ long plMaxRecords) = 0;
3983 virtual HRESULT __stdcall get_RecordCount(
3984 /*[out,retval]*/ long* pl) = 0;
3985 virtual HRESULT __stdcall putref_Source(
3986 /*[in]*/ IDispatch* pvSource) = 0;
3987 virtual HRESULT __stdcall put_Source(
3988 /*[in]*/ BSTR pvSource) = 0;
3989 virtual HRESULT __stdcall get_Source(
3990 /*[out,retval]*/ VARIANT* pvSource) = 0;
3991 virtual HRESULT __stdcall raw_AddNew(
3992 /*[in]*/ VARIANT FieldList = vtMissing,
3993 /*[in]*/ VARIANT Values = vtMissing) = 0;
3994 virtual HRESULT __stdcall raw_CancelUpdate() = 0;
3995 virtual HRESULT __stdcall raw_Close() = 0;
3996 virtual HRESULT __stdcall raw_Delete(
3997 /*[in]*/ enum AffectEnum AffectRecords) = 0;
3998 virtual HRESULT __stdcall raw_GetRows(
3999 /*[in]*/ long Rows,
4000 /*[in]*/ VARIANT Start,
4001 /*[in]*/ VARIANT Fields,
4002 /*[out,retval]*/ VARIANT* pvar) = 0;
4003 virtual HRESULT __stdcall raw_Move(
4004 /*[in]*/ long NumRecords,
4005 /*[in]*/ VARIANT Start = vtMissing) = 0;
4006 virtual HRESULT __stdcall raw_MoveNext() = 0;
4007 virtual HRESULT __stdcall raw_MovePrevious() = 0;
4008 virtual HRESULT __stdcall raw_MoveFirst() = 0;
4009 virtual HRESULT __stdcall raw_MoveLast() = 0;
4010 virtual HRESULT __stdcall raw_Open(
4011 /*[in]*/ VARIANT Source,
4012 /*[in]*/ VARIANT ActiveConnection,
4013 /*[in]*/ enum CursorTypeEnum CursorType,
4014 /*[in]*/ enum LockTypeEnum LockType,
4015 /*[in]*/ long Options) = 0;
4016 virtual HRESULT __stdcall raw_Requery(
4017 /*[in]*/ long Options) = 0;
4018 virtual HRESULT __stdcall raw__xResync(
4019 /*[in]*/ enum AffectEnum AffectRecords) = 0;
4020 virtual HRESULT __stdcall raw_Update(
4021 /*[in]*/ VARIANT Fields = vtMissing,
4022 /*[in]*/ VARIANT Values = vtMissing) = 0;
4023 virtual HRESULT __stdcall get_AbsolutePage(
4024 /*[out,retval]*/ enum PositionEnum* pl) = 0;
4025 virtual HRESULT __stdcall put_AbsolutePage(
4026 /*[in]*/ enum PositionEnum pl) = 0;
4027 virtual HRESULT __stdcall get_EditMode(
4028 /*[out,retval]*/ enum EditModeEnum* pl) = 0;
4029 virtual HRESULT __stdcall get_Filter(
4030 /*[out,retval]*/ VARIANT* Criteria) = 0;
4031 virtual HRESULT __stdcall put_Filter(
4032 /*[in]*/ VARIANT Criteria) = 0;
4033 virtual HRESULT __stdcall get_PageCount(
4034 /*[out,retval]*/ long* pl) = 0;
4035 virtual HRESULT __stdcall get_PageSize(
4036 /*[out,retval]*/ long* pl) = 0;
4037 virtual HRESULT __stdcall put_PageSize(
4038 /*[in]*/ long pl) = 0;
4039 virtual HRESULT __stdcall get_Sort(
4040 /*[out,retval]*/ BSTR* Criteria) = 0;
4041 virtual HRESULT __stdcall put_Sort(
4042 /*[in]*/ BSTR Criteria) = 0;
4043 virtual HRESULT __stdcall get_Status(
4044 /*[out,retval]*/ long* pl) = 0;
4045 virtual HRESULT __stdcall get_State(
4046 /*[out,retval]*/ long* plObjState) = 0;
4047 virtual HRESULT __stdcall raw__xClone(
4048 /*[out,retval]*/ struct _Recordset** ppvObject) = 0;
4049 virtual HRESULT __stdcall raw_UpdateBatch(
4050 /*[in]*/ enum AffectEnum AffectRecords) = 0;
4051 virtual HRESULT __stdcall raw_CancelBatch(
4052 /*[in]*/ enum AffectEnum AffectRecords) = 0;
4053 virtual HRESULT __stdcall get_CursorLocation(
4054 /*[out,retval]*/ enum CursorLocationEnum* plCursorLoc) = 0;
4055 virtual HRESULT __stdcall put_CursorLocation(
4056 /*[in]*/ enum CursorLocationEnum plCursorLoc) = 0;
4057 virtual HRESULT __stdcall raw_NextRecordset(
4058 /*[out]*/ VARIANT* RecordsAffected,
4059 /*[out,retval]*/ struct _Recordset** ppiRs) = 0;
4060 virtual HRESULT __stdcall raw_Supports(
4061 /*[in]*/ enum CursorOptionEnum CursorOptions,
4062 /*[out,retval]*/ VARIANT_BOOL* pb) = 0;
4063 virtual HRESULT __stdcall get_Collect(
4064 /*[in]*/ VARIANT Index,
4065 /*[out,retval]*/ VARIANT* pvar) = 0;
4066 virtual HRESULT __stdcall put_Collect(
4067 /*[in]*/ VARIANT Index,
4068 /*[in]*/ VARIANT pvar) = 0;
4069 virtual HRESULT __stdcall get_MarshalOptions(
4070 /*[out,retval]*/ enum MarshalOptionsEnum* peMarshal) = 0;
4071 virtual HRESULT __stdcall put_MarshalOptions(
4072 /*[in]*/ enum MarshalOptionsEnum peMarshal) = 0;
4073 virtual HRESULT __stdcall raw_Find(
4074 /*[in]*/ BSTR Criteria,
4075 /*[in]*/ long SkipRecords,
4076 /*[in]*/ enum SearchDirectionEnum SearchDirection,
4077 /*[in]*/ VARIANT Start = vtMissing) = 0;
4078};
4079
4080struct __declspec(uuid("0000154f-0000-0010-8000-00aa006d2ea4")) Recordset20 : Recordset15
4081{
4082 //
4083 // Property data
4084 //
4085
4086 __declspec(property(get = GetDataSource, put = PutRefDataSource)) IUnknownPtr DataSource;
4087 __declspec(property(get = GetActiveCommand)) IDispatchPtr ActiveCommand;
4088 __declspec(property(get = GetStayInSync, put = PutStayInSync)) VARIANT_BOOL StayInSync;
4089 __declspec(property(get = GetDataMember, put = PutDataMember)) _bstr_t DataMember;
4090
4091 //
4092 // Wrapper methods for error-handling
4093 //
4094
4095 HRESULT Cancel();
4096 IUnknownPtr GetDataSource();
4097 void PutRefDataSource(IUnknown* ppunkDataSource);
4098 HRESULT _xSave(_bstr_t FileName, enum PersistFormatEnum PersistFormat);
4099 IDispatchPtr GetActiveCommand();
4100 void PutStayInSync(VARIANT_BOOL pbStayInSync);
4101 VARIANT_BOOL GetStayInSync();
4102 _bstr_t GetString(enum StringFormatEnum StringFormat, long NumRows, _bstr_t ColumnDelimeter,
4103 _bstr_t RowDelimeter, _bstr_t NullExpr);
4104 _bstr_t GetDataMember();
4105 void PutDataMember(_bstr_t pbstrDataMember);
4106 enum CompareEnum CompareBookmarks(const _variant_t& Bookmark1, const _variant_t& Bookmark2);
4107 _RecordsetPtr Clone(enum LockTypeEnum LockType);
4108 HRESULT Resync(enum AffectEnum AffectRecords, enum ResyncEnum ResyncValues);
4109
4110 //
4111 // Raw methods provided by interface
4112 //
4113
4114 virtual HRESULT __stdcall raw_Cancel() = 0;
4115 virtual HRESULT __stdcall get_DataSource(
4116 /*[out,retval]*/ IUnknown** ppunkDataSource) = 0;
4117 virtual HRESULT __stdcall putref_DataSource(
4118 /*[in]*/ IUnknown* ppunkDataSource) = 0;
4119 virtual HRESULT __stdcall raw__xSave(
4120 /*[in]*/ BSTR FileName,
4121 /*[in]*/ enum PersistFormatEnum PersistFormat) = 0;
4122 virtual HRESULT __stdcall get_ActiveCommand(
4123 /*[out,retval]*/ IDispatch** ppCmd) = 0;
4124 virtual HRESULT __stdcall put_StayInSync(
4125 /*[in]*/ VARIANT_BOOL pbStayInSync) = 0;
4126 virtual HRESULT __stdcall get_StayInSync(
4127 /*[out,retval]*/ VARIANT_BOOL* pbStayInSync) = 0;
4128 virtual HRESULT __stdcall raw_GetString(
4129 /*[in]*/ enum StringFormatEnum StringFormat,
4130 /*[in]*/ long NumRows,
4131 /*[in]*/ BSTR ColumnDelimeter,
4132 /*[in]*/ BSTR RowDelimeter,
4133 /*[in]*/ BSTR NullExpr,
4134 /*[out,retval]*/ BSTR* pRetString) = 0;
4135 virtual HRESULT __stdcall get_DataMember(
4136 /*[out,retval]*/ BSTR* pbstrDataMember) = 0;
4137 virtual HRESULT __stdcall put_DataMember(
4138 /*[in]*/ BSTR pbstrDataMember) = 0;
4139 virtual HRESULT __stdcall raw_CompareBookmarks(
4140 /*[in]*/ VARIANT Bookmark1,
4141 /*[in]*/ VARIANT Bookmark2,
4142 /*[out,retval]*/ enum CompareEnum* pCompare) = 0;
4143 virtual HRESULT __stdcall raw_Clone(
4144 /*[in]*/ enum LockTypeEnum LockType,
4145 /*[out,retval]*/ struct _Recordset** ppvObject) = 0;
4146 virtual HRESULT __stdcall raw_Resync(
4147 /*[in]*/ enum AffectEnum AffectRecords,
4148 /*[in]*/ enum ResyncEnum ResyncValues) = 0;
4149};
4150
4151struct __declspec(uuid("00001555-0000-0010-8000-00aa006d2ea4")) Recordset21 : Recordset20
4152{
4153 //
4154 // Property data
4155 //
4156
4157 __declspec(property(get = GetIndex, put = PutIndex)) _bstr_t Index;
4158
4159 //
4160 // Wrapper methods for error-handling
4161 //
4162
4163 HRESULT Seek(const _variant_t& KeyValues, enum SeekEnum SeekOption);
4164 void PutIndex(_bstr_t pbstrIndex);
4165 _bstr_t GetIndex();
4166
4167 //
4168 // Raw methods provided by interface
4169 //
4170
4171 virtual HRESULT __stdcall raw_Seek(
4172 /*[in]*/ VARIANT KeyValues,
4173 /*[in]*/ enum SeekEnum SeekOption) = 0;
4174 virtual HRESULT __stdcall put_Index(
4175 /*[in]*/ BSTR pbstrIndex) = 0;
4176 virtual HRESULT __stdcall get_Index(
4177 /*[out,retval]*/ BSTR* pbstrIndex) = 0;
4178};
4179
4180struct __declspec(uuid("00001556-0000-0010-8000-00aa006d2ea4")) _Recordset : Recordset21
4181{
4182 //
4183 // Wrapper methods for error-handling
4184 //
4185
4186 HRESULT Save(const _variant_t& Destination, enum PersistFormatEnum PersistFormat);
4187
4188 //
4189 // Raw methods provided by interface
4190 //
4191
4192 virtual HRESULT __stdcall raw_Save(
4193 /*[in]*/ VARIANT Destination,
4194 /*[in]*/ enum PersistFormatEnum PersistFormat) = 0;
4195};
4196
4197struct __declspec(uuid("00001402-0000-0010-8000-00aa006d2ea4")) ConnectionEventsVt : IUnknown
4198{
4199 //
4200 // Wrapper methods for error-handling
4201 //
4202
4203 HRESULT InfoMessage(struct Error* pError, enum EventStatusEnum* adStatus,
4204 struct _Connection* pConnection);
4205 HRESULT BeginTransComplete(long TransactionLevel, struct Error* pError,
4206 enum EventStatusEnum* adStatus, struct _Connection* pConnection);
4207 HRESULT CommitTransComplete(struct Error* pError, enum EventStatusEnum* adStatus,
4208 struct _Connection* pConnection);
4209 HRESULT RollbackTransComplete(struct Error* pError, enum EventStatusEnum* adStatus,
4210 struct _Connection* pConnection);
4211 HRESULT WillExecute(BSTR* Source, enum CursorTypeEnum* CursorType, enum LockTypeEnum* LockType,
4212 long* Options, enum EventStatusEnum* adStatus, struct _Command* pCommand,
4213 struct _Recordset* pRecordset, struct _Connection* pConnection);
4214 HRESULT ExecuteComplete(long RecordsAffected, struct Error* pError,
4215 enum EventStatusEnum* adStatus, struct _Command* pCommand,
4216 struct _Recordset* pRecordset, struct _Connection* pConnection);
4217 HRESULT WillConnect(BSTR* ConnectionString, BSTR* UserID, BSTR* Password, long* Options,
4218 enum EventStatusEnum* adStatus, struct _Connection* pConnection);
4219 HRESULT ConnectComplete(struct Error* pError, enum EventStatusEnum* adStatus,
4220 struct _Connection* pConnection);
4221 HRESULT Disconnect(enum EventStatusEnum* adStatus, struct _Connection* pConnection);
4222
4223 //
4224 // Raw methods provided by interface
4225 //
4226
4227 virtual HRESULT __stdcall raw_InfoMessage(
4228 /*[in]*/ struct Error* pError,
4229 /*[in,out]*/ enum EventStatusEnum* adStatus,
4230 /*[in]*/ struct _Connection* pConnection) = 0;
4231 virtual HRESULT __stdcall raw_BeginTransComplete(
4232 /*[in]*/ long TransactionLevel,
4233 /*[in]*/ struct Error* pError,
4234 /*[in,out]*/ enum EventStatusEnum* adStatus,
4235 /*[in]*/ struct _Connection* pConnection) = 0;
4236 virtual HRESULT __stdcall raw_CommitTransComplete(
4237 /*[in]*/ struct Error* pError,
4238 /*[in,out]*/ enum EventStatusEnum* adStatus,
4239 /*[in]*/ struct _Connection* pConnection) = 0;
4240 virtual HRESULT __stdcall raw_RollbackTransComplete(
4241 /*[in]*/ struct Error* pError,
4242 /*[in,out]*/ enum EventStatusEnum* adStatus,
4243 /*[in]*/ struct _Connection* pConnection) = 0;
4244 virtual HRESULT __stdcall raw_WillExecute(
4245 /*[in,out]*/ BSTR* Source,
4246 /*[in,out]*/ enum CursorTypeEnum* CursorType,
4247 /*[in,out]*/ enum LockTypeEnum* LockType,
4248 /*[in,out]*/ long* Options,
4249 /*[in,out]*/ enum EventStatusEnum* adStatus,
4250 /*[in]*/ struct _Command* pCommand,
4251 /*[in]*/ struct _Recordset* pRecordset,
4252 /*[in]*/ struct _Connection* pConnection) = 0;
4253 virtual HRESULT __stdcall raw_ExecuteComplete(
4254 /*[in]*/ long RecordsAffected,
4255 /*[in]*/ struct Error* pError,
4256 /*[in,out]*/ enum EventStatusEnum* adStatus,
4257 /*[in]*/ struct _Command* pCommand,
4258 /*[in]*/ struct _Recordset* pRecordset,
4259 /*[in]*/ struct _Connection* pConnection) = 0;
4260 virtual HRESULT __stdcall raw_WillConnect(
4261 /*[in,out]*/ BSTR* ConnectionString,
4262 /*[in,out]*/ BSTR* UserID,
4263 /*[in,out]*/ BSTR* Password,
4264 /*[in,out]*/ long* Options,
4265 /*[in,out]*/ enum EventStatusEnum* adStatus,
4266 /*[in]*/ struct _Connection* pConnection) = 0;
4267 virtual HRESULT __stdcall raw_ConnectComplete(
4268 /*[in]*/ struct Error* pError,
4269 /*[in,out]*/ enum EventStatusEnum* adStatus,
4270 /*[in]*/ struct _Connection* pConnection) = 0;
4271 virtual HRESULT __stdcall raw_Disconnect(
4272 /*[in,out]*/ enum EventStatusEnum* adStatus,
4273 /*[in]*/ struct _Connection* pConnection) = 0;
4274};
4275
4276struct __declspec(uuid("00001403-0000-0010-8000-00aa006d2ea4")) RecordsetEventsVt : IUnknown
4277{
4278 //
4279 // Wrapper methods for error-handling
4280 //
4281
4282 HRESULT WillChangeField(long cFields, const _variant_t& Fields, enum EventStatusEnum* adStatus,
4283 struct _Recordset* pRecordset);
4284 HRESULT FieldChangeComplete(long cFields, const _variant_t& Fields, struct Error* pError,
4285 enum EventStatusEnum* adStatus, struct _Recordset* pRecordset);
4286 HRESULT WillChangeRecord(enum EventReasonEnum adReason, long cRecords,
4287 enum EventStatusEnum* adStatus, struct _Recordset* pRecordset);
4288 HRESULT RecordChangeComplete(enum EventReasonEnum adReason, long cRecords, struct Error* pError,
4289 enum EventStatusEnum* adStatus, struct _Recordset* pRecordset);
4290 HRESULT WillChangeRecordset(enum EventReasonEnum adReason, enum EventStatusEnum* adStatus,
4291 struct _Recordset* pRecordset);
4292 HRESULT RecordsetChangeComplete(enum EventReasonEnum adReason, struct Error* pError,
4293 enum EventStatusEnum* adStatus, struct _Recordset* pRecordset);
4294 HRESULT WillMove(enum EventReasonEnum adReason, enum EventStatusEnum* adStatus,
4295 struct _Recordset* pRecordset);
4296 HRESULT MoveComplete(enum EventReasonEnum adReason, struct Error* pError,
4297 enum EventStatusEnum* adStatus, struct _Recordset* pRecordset);
4298 HRESULT EndOfRecordset(VARIANT_BOOL* fMoreData, enum EventStatusEnum* adStatus,
4299 struct _Recordset* pRecordset);
4300 HRESULT FetchProgress(long Progress, long MaxProgress, enum EventStatusEnum* adStatus,
4301 struct _Recordset* pRecordset);
4302 HRESULT FetchComplete(struct Error* pError, enum EventStatusEnum* adStatus,
4303 struct _Recordset* pRecordset);
4304
4305 //
4306 // Raw methods provided by interface
4307 //
4308
4309 virtual HRESULT __stdcall raw_WillChangeField(
4310 /*[in]*/ long cFields,
4311 /*[in]*/ VARIANT Fields,
4312 /*[in,out]*/ enum EventStatusEnum* adStatus,
4313 /*[in]*/ struct _Recordset* pRecordset) = 0;
4314 virtual HRESULT __stdcall raw_FieldChangeComplete(
4315 /*[in]*/ long cFields,
4316 /*[in]*/ VARIANT Fields,
4317 /*[in]*/ struct Error* pError,
4318 /*[in,out]*/ enum EventStatusEnum* adStatus,
4319 /*[in]*/ struct _Recordset* pRecordset) = 0;
4320 virtual HRESULT __stdcall raw_WillChangeRecord(
4321 /*[in]*/ enum EventReasonEnum adReason,
4322 /*[in]*/ long cRecords,
4323 /*[in,out]*/ enum EventStatusEnum* adStatus,
4324 /*[in]*/ struct _Recordset* pRecordset) = 0;
4325 virtual HRESULT __stdcall raw_RecordChangeComplete(
4326 /*[in]*/ enum EventReasonEnum adReason,
4327 /*[in]*/ long cRecords,
4328 /*[in]*/ struct Error* pError,
4329 /*[in,out]*/ enum EventStatusEnum* adStatus,
4330 /*[in]*/ struct _Recordset* pRecordset) = 0;
4331 virtual HRESULT __stdcall raw_WillChangeRecordset(
4332 /*[in]*/ enum EventReasonEnum adReason,
4333 /*[in,out]*/ enum EventStatusEnum* adStatus,
4334 /*[in]*/ struct _Recordset* pRecordset) = 0;
4335 virtual HRESULT __stdcall raw_RecordsetChangeComplete(
4336 /*[in]*/ enum EventReasonEnum adReason,
4337 /*[in]*/ struct Error* pError,
4338 /*[in,out]*/ enum EventStatusEnum* adStatus,
4339 /*[in]*/ struct _Recordset* pRecordset) = 0;
4340 virtual HRESULT __stdcall raw_WillMove(
4341 /*[in]*/ enum EventReasonEnum adReason,
4342 /*[in,out]*/ enum EventStatusEnum* adStatus,
4343 /*[in]*/ struct _Recordset* pRecordset) = 0;
4344 virtual HRESULT __stdcall raw_MoveComplete(
4345 /*[in]*/ enum EventReasonEnum adReason,
4346 /*[in]*/ struct Error* pError,
4347 /*[in,out]*/ enum EventStatusEnum* adStatus,
4348 /*[in]*/ struct _Recordset* pRecordset) = 0;
4349 virtual HRESULT __stdcall raw_EndOfRecordset(
4350 /*[in,out]*/ VARIANT_BOOL* fMoreData,
4351 /*[in,out]*/ enum EventStatusEnum* adStatus,
4352 /*[in]*/ struct _Recordset* pRecordset) = 0;
4353 virtual HRESULT __stdcall raw_FetchProgress(
4354 /*[in]*/ long Progress,
4355 /*[in]*/ long MaxProgress,
4356 /*[in,out]*/ enum EventStatusEnum* adStatus,
4357 /*[in]*/ struct _Recordset* pRecordset) = 0;
4358 virtual HRESULT __stdcall raw_FetchComplete(
4359 /*[in]*/ struct Error* pError,
4360 /*[in,out]*/ enum EventStatusEnum* adStatus,
4361 /*[in]*/ struct _Recordset* pRecordset) = 0;
4362};
4363
4364struct __declspec(uuid("00001562-0000-0010-8000-00aa006d2ea4")) _Record : _ADO
4365{
4366 //
4367 // Property data
4368 //
4369
4370 __declspec(property(get = GetFields)) FieldsPtr Fields;
4371 __declspec(property(get = GetState)) enum ObjectStateEnum State;
4372 __declspec(property(get = GetMode, put = PutMode)) enum ConnectModeEnum Mode;
4373 __declspec(property(get = GetParentURL)) _bstr_t ParentURL;
4374 __declspec(property(get = GetRecordType)) enum RecordTypeEnum RecordType;
4375
4376 //
4377 // Wrapper methods for error-handling
4378 //
4379
4380 _variant_t GetActiveConnection();
4381 void PutActiveConnection(_bstr_t pvar);
4382 void PutRefActiveConnection(struct _Connection* pvar);
4383 enum ObjectStateEnum GetState();
4384 _variant_t GetSource();
4385 void PutSource(_bstr_t pvar);
4386 void PutRefSource(IDispatch* pvar);
4387 enum ConnectModeEnum GetMode();
4388 void PutMode(enum ConnectModeEnum pMode);
4389 _bstr_t GetParentURL();
4390 _bstr_t MoveRecord(_bstr_t Source, _bstr_t Destination, _bstr_t UserName, _bstr_t Password,
4391 enum MoveRecordOptionsEnum Options, VARIANT_BOOL Async);
4392 _bstr_t CopyRecord(_bstr_t Source, _bstr_t Destination, _bstr_t UserName, _bstr_t Password,
4393 enum CopyRecordOptionsEnum Options, VARIANT_BOOL Async);
4394 HRESULT DeleteRecord(_bstr_t Source, VARIANT_BOOL Async);
4395 HRESULT Open(const _variant_t& Source, const _variant_t& ActiveConnection,
4396 enum ConnectModeEnum Mode, enum RecordCreateOptionsEnum CreateOptions,
4397 enum RecordOpenOptionsEnum Options, _bstr_t UserName, _bstr_t Password);
4398 HRESULT Close();
4399 FieldsPtr GetFields();
4400 enum RecordTypeEnum GetRecordType();
4401 _RecordsetPtr GetChildren();
4402 HRESULT Cancel();
4403
4404 //
4405 // Raw methods provided by interface
4406 //
4407
4408 virtual HRESULT __stdcall get_ActiveConnection(
4409 /*[out,retval]*/ VARIANT* pvar) = 0;
4410 virtual HRESULT __stdcall put_ActiveConnection(
4411 /*[in]*/ BSTR pvar) = 0;
4412 virtual HRESULT __stdcall putref_ActiveConnection(
4413 /*[in]*/ struct _Connection* pvar) = 0;
4414 virtual HRESULT __stdcall get_State(
4415 /*[out,retval]*/ enum ObjectStateEnum* pState) = 0;
4416 virtual HRESULT __stdcall get_Source(
4417 /*[out,retval]*/ VARIANT* pvar) = 0;
4418 virtual HRESULT __stdcall put_Source(
4419 /*[in]*/ BSTR pvar) = 0;
4420 virtual HRESULT __stdcall putref_Source(
4421 /*[in]*/ IDispatch* pvar) = 0;
4422 virtual HRESULT __stdcall get_Mode(
4423 /*[out,retval]*/ enum ConnectModeEnum* pMode) = 0;
4424 virtual HRESULT __stdcall put_Mode(
4425 /*[in]*/ enum ConnectModeEnum pMode) = 0;
4426 virtual HRESULT __stdcall get_ParentURL(
4427 /*[out,retval]*/ BSTR* pbstrParentURL) = 0;
4428 virtual HRESULT __stdcall raw_MoveRecord(
4429 /*[in]*/ BSTR Source,
4430 /*[in]*/ BSTR Destination,
4431 /*[in]*/ BSTR UserName,
4432 /*[in]*/ BSTR Password,
4433 /*[in]*/ enum MoveRecordOptionsEnum Options,
4434 /*[in]*/ VARIANT_BOOL Async,
4435 /*[out,retval]*/ BSTR* pbstrNewURL) = 0;
4436 virtual HRESULT __stdcall raw_CopyRecord(
4437 /*[in]*/ BSTR Source,
4438 /*[in]*/ BSTR Destination,
4439 /*[in]*/ BSTR UserName,
4440 /*[in]*/ BSTR Password,
4441 /*[in]*/ enum CopyRecordOptionsEnum Options,
4442 /*[in]*/ VARIANT_BOOL Async,
4443 /*[out,retval]*/ BSTR* pbstrNewURL) = 0;
4444 virtual HRESULT __stdcall raw_DeleteRecord(
4445 /*[in]*/ BSTR Source,
4446 /*[in]*/ VARIANT_BOOL Async) = 0;
4447 virtual HRESULT __stdcall raw_Open(
4448 /*[in]*/ VARIANT Source,
4449 /*[in]*/ VARIANT ActiveConnection,
4450 /*[in]*/ enum ConnectModeEnum Mode,
4451 /*[in]*/ enum RecordCreateOptionsEnum CreateOptions,
4452 /*[in]*/ enum RecordOpenOptionsEnum Options,
4453 /*[in]*/ BSTR UserName,
4454 /*[in]*/ BSTR Password) = 0;
4455 virtual HRESULT __stdcall raw_Close() = 0;
4456 virtual HRESULT __stdcall get_Fields(
4457 /*[out,retval]*/ struct Fields** ppFlds) = 0;
4458 virtual HRESULT __stdcall get_RecordType(
4459 /*[out,retval]*/ enum RecordTypeEnum* ptype) = 0;
4460 virtual HRESULT __stdcall raw_GetChildren(
4461 /*[out,retval]*/ struct _Recordset** pprset) = 0;
4462 virtual HRESULT __stdcall raw_Cancel() = 0;
4463};
4464
4465struct __declspec(uuid("00000402-0000-0010-8000-00aa006d2ea4")) ConnectionEventsVt_Deprecated
4466 : IUnknown
4467{
4468 //
4469 // Wrapper methods for error-handling
4470 //
4471
4472 HRESULT InfoMessage(struct Error* pError, enum EventStatusEnum* adStatus,
4473 struct _Connection_Deprecated* pConnection);
4474 HRESULT BeginTransComplete(long TransactionLevel, struct Error* pError,
4475 enum EventStatusEnum* adStatus,
4476 struct _Connection_Deprecated* pConnection);
4477 HRESULT CommitTransComplete(struct Error* pError, enum EventStatusEnum* adStatus,
4478 struct _Connection_Deprecated* pConnection);
4479 HRESULT RollbackTransComplete(struct Error* pError, enum EventStatusEnum* adStatus,
4480 struct _Connection_Deprecated* pConnection);
4481 HRESULT WillExecute(BSTR* Source, enum CursorTypeEnum* CursorType, enum LockTypeEnum* LockType,
4482 long* Options, enum EventStatusEnum* adStatus,
4483 struct _Command_Deprecated* pCommand,
4484 struct _Recordset_Deprecated* pRecordset,
4485 struct _Connection_Deprecated* pConnection);
4486 HRESULT ExecuteComplete(long RecordsAffected, struct Error* pError,
4487 enum EventStatusEnum* adStatus, struct _Command_Deprecated* pCommand,
4488 struct _Recordset_Deprecated* pRecordset,
4489 struct _Connection_Deprecated* pConnection);
4490 HRESULT WillConnect(BSTR* ConnectionString, BSTR* UserID, BSTR* Password, long* Options,
4491 enum EventStatusEnum* adStatus, struct _Connection_Deprecated* pConnection);
4492 HRESULT ConnectComplete(struct Error* pError, enum EventStatusEnum* adStatus,
4493 struct _Connection_Deprecated* pConnection);
4494 HRESULT Disconnect(enum EventStatusEnum* adStatus, struct _Connection_Deprecated* pConnection);
4495
4496 //
4497 // Raw methods provided by interface
4498 //
4499
4500 virtual HRESULT __stdcall raw_InfoMessage(
4501 /*[in]*/ struct Error* pError,
4502 /*[in,out]*/ enum EventStatusEnum* adStatus,
4503 /*[in]*/ struct _Connection_Deprecated* pConnection) = 0;
4504 virtual HRESULT __stdcall raw_BeginTransComplete(
4505 /*[in]*/ long TransactionLevel,
4506 /*[in]*/ struct Error* pError,
4507 /*[in,out]*/ enum EventStatusEnum* adStatus,
4508 /*[in]*/ struct _Connection_Deprecated* pConnection) = 0;
4509 virtual HRESULT __stdcall raw_CommitTransComplete(
4510 /*[in]*/ struct Error* pError,
4511 /*[in,out]*/ enum EventStatusEnum* adStatus,
4512 /*[in]*/ struct _Connection_Deprecated* pConnection) = 0;
4513 virtual HRESULT __stdcall raw_RollbackTransComplete(
4514 /*[in]*/ struct Error* pError,
4515 /*[in,out]*/ enum EventStatusEnum* adStatus,
4516 /*[in]*/ struct _Connection_Deprecated* pConnection) = 0;
4517 virtual HRESULT __stdcall raw_WillExecute(
4518 /*[in,out]*/ BSTR* Source,
4519 /*[in,out]*/ enum CursorTypeEnum* CursorType,
4520 /*[in,out]*/ enum LockTypeEnum* LockType,
4521 /*[in,out]*/ long* Options,
4522 /*[in,out]*/ enum EventStatusEnum* adStatus,
4523 /*[in]*/ struct _Command_Deprecated* pCommand,
4524 /*[in]*/ struct _Recordset_Deprecated* pRecordset,
4525 /*[in]*/ struct _Connection_Deprecated* pConnection) = 0;
4526 virtual HRESULT __stdcall raw_ExecuteComplete(
4527 /*[in]*/ long RecordsAffected,
4528 /*[in]*/ struct Error* pError,
4529 /*[in,out]*/ enum EventStatusEnum* adStatus,
4530 /*[in]*/ struct _Command_Deprecated* pCommand,
4531 /*[in]*/ struct _Recordset_Deprecated* pRecordset,
4532 /*[in]*/ struct _Connection_Deprecated* pConnection) = 0;
4533 virtual HRESULT __stdcall raw_WillConnect(
4534 /*[in,out]*/ BSTR* ConnectionString,
4535 /*[in,out]*/ BSTR* UserID,
4536 /*[in,out]*/ BSTR* Password,
4537 /*[in,out]*/ long* Options,
4538 /*[in,out]*/ enum EventStatusEnum* adStatus,
4539 /*[in]*/ struct _Connection_Deprecated* pConnection) = 0;
4540 virtual HRESULT __stdcall raw_ConnectComplete(
4541 /*[in]*/ struct Error* pError,
4542 /*[in,out]*/ enum EventStatusEnum* adStatus,
4543 /*[in]*/ struct _Connection_Deprecated* pConnection) = 0;
4544 virtual HRESULT __stdcall raw_Disconnect(
4545 /*[in,out]*/ enum EventStatusEnum* adStatus,
4546 /*[in]*/ struct _Connection_Deprecated* pConnection) = 0;
4547};
4548
4549struct __declspec(uuid("00000515-0000-0010-8000-00aa006d2ea4")) Connection15_Deprecated : _ADO
4550{
4551 //
4552 // Property data
4553 //
4554
4555 __declspec(property(get = GetConnectionString,
4556 put = PutConnectionString)) _bstr_t ConnectionString;
4557 __declspec(property(get = GetCommandTimeout, put = PutCommandTimeout)) long CommandTimeout;
4558 __declspec(property(get = GetConnectionTimeout,
4559 put = PutConnectionTimeout)) long ConnectionTimeout;
4560 __declspec(property(get = GetVersion)) _bstr_t Version;
4561 __declspec(property(get = GetErrors)) ErrorsPtr Errors;
4562 __declspec(property(get = GetDefaultDatabase,
4563 put = PutDefaultDatabase)) _bstr_t DefaultDatabase;
4564 __declspec(property(get = GetIsolationLevel,
4565 put = PutIsolationLevel)) enum IsolationLevelEnum IsolationLevel;
4566 __declspec(property(get = GetAttributes, put = PutAttributes)) long Attributes;
4567 __declspec(property(get = GetCursorLocation,
4568 put = PutCursorLocation)) enum CursorLocationEnum CursorLocation;
4569 __declspec(property(get = GetMode, put = PutMode)) enum ConnectModeEnum Mode;
4570 __declspec(property(get = GetProvider, put = PutProvider)) _bstr_t Provider;
4571 __declspec(property(get = GetState)) long State;
4572
4573 //
4574 // Wrapper methods for error-handling
4575 //
4576
4577 _bstr_t GetConnectionString();
4578 void PutConnectionString(_bstr_t pbstr);
4579 long GetCommandTimeout();
4580 void PutCommandTimeout(long plTimeout);
4581 long GetConnectionTimeout();
4582 void PutConnectionTimeout(long plTimeout);
4583 _bstr_t GetVersion();
4584 HRESULT Close();
4585 _Recordset_DeprecatedPtr Execute(_bstr_t CommandText, VARIANT* RecordsAffected, long Options);
4586 long BeginTrans();
4587 HRESULT CommitTrans();
4588 HRESULT RollbackTrans();
4589 HRESULT Open(_bstr_t ConnectionString, _bstr_t UserID, _bstr_t Password, long Options);
4590 ErrorsPtr GetErrors();
4591 _bstr_t GetDefaultDatabase();
4592 void PutDefaultDatabase(_bstr_t pbstr);
4593 enum IsolationLevelEnum GetIsolationLevel();
4594 void PutIsolationLevel(enum IsolationLevelEnum Level);
4595 long GetAttributes();
4596 void PutAttributes(long plAttr);
4597 enum CursorLocationEnum GetCursorLocation();
4598 void PutCursorLocation(enum CursorLocationEnum plCursorLoc);
4599 enum ConnectModeEnum GetMode();
4600 void PutMode(enum ConnectModeEnum plMode);
4601 _bstr_t GetProvider();
4602 void PutProvider(_bstr_t pbstr);
4603 long GetState();
4604 _Recordset_DeprecatedPtr OpenSchema(enum SchemaEnum Schema,
4605 const _variant_t& Restrictions = vtMissing,
4606 const _variant_t& SchemaID = vtMissing);
4607
4608 //
4609 // Raw methods provided by interface
4610 //
4611
4612 virtual HRESULT __stdcall get_ConnectionString(
4613 /*[out,retval]*/ BSTR* pbstr) = 0;
4614 virtual HRESULT __stdcall put_ConnectionString(
4615 /*[in]*/ BSTR pbstr) = 0;
4616 virtual HRESULT __stdcall get_CommandTimeout(
4617 /*[out,retval]*/ long* plTimeout) = 0;
4618 virtual HRESULT __stdcall put_CommandTimeout(
4619 /*[in]*/ long plTimeout) = 0;
4620 virtual HRESULT __stdcall get_ConnectionTimeout(
4621 /*[out,retval]*/ long* plTimeout) = 0;
4622 virtual HRESULT __stdcall put_ConnectionTimeout(
4623 /*[in]*/ long plTimeout) = 0;
4624 virtual HRESULT __stdcall get_Version(
4625 /*[out,retval]*/ BSTR* pbstr) = 0;
4626 virtual HRESULT __stdcall raw_Close() = 0;
4627 virtual HRESULT __stdcall raw_Execute(
4628 /*[in]*/ BSTR CommandText,
4629 /*[out]*/ VARIANT* RecordsAffected,
4630 /*[in]*/ long Options,
4631 /*[out,retval]*/ struct _Recordset_Deprecated** ppiRset) = 0;
4632 virtual HRESULT __stdcall raw_BeginTrans(
4633 /*[out,retval]*/ long* TransactionLevel) = 0;
4634 virtual HRESULT __stdcall raw_CommitTrans() = 0;
4635 virtual HRESULT __stdcall raw_RollbackTrans() = 0;
4636 virtual HRESULT __stdcall raw_Open(
4637 /*[in]*/ BSTR ConnectionString,
4638 /*[in]*/ BSTR UserID,
4639 /*[in]*/ BSTR Password,
4640 /*[in]*/ long Options) = 0;
4641 virtual HRESULT __stdcall get_Errors(
4642 /*[out,retval]*/ struct Errors** ppvObject) = 0;
4643 virtual HRESULT __stdcall get_DefaultDatabase(
4644 /*[out,retval]*/ BSTR* pbstr) = 0;
4645 virtual HRESULT __stdcall put_DefaultDatabase(
4646 /*[in]*/ BSTR pbstr) = 0;
4647 virtual HRESULT __stdcall get_IsolationLevel(
4648 /*[out,retval]*/ enum IsolationLevelEnum* Level) = 0;
4649 virtual HRESULT __stdcall put_IsolationLevel(
4650 /*[in]*/ enum IsolationLevelEnum Level) = 0;
4651 virtual HRESULT __stdcall get_Attributes(
4652 /*[out,retval]*/ long* plAttr) = 0;
4653 virtual HRESULT __stdcall put_Attributes(
4654 /*[in]*/ long plAttr) = 0;
4655 virtual HRESULT __stdcall get_CursorLocation(
4656 /*[out,retval]*/ enum CursorLocationEnum* plCursorLoc) = 0;
4657 virtual HRESULT __stdcall put_CursorLocation(
4658 /*[in]*/ enum CursorLocationEnum plCursorLoc) = 0;
4659 virtual HRESULT __stdcall get_Mode(
4660 /*[out,retval]*/ enum ConnectModeEnum* plMode) = 0;
4661 virtual HRESULT __stdcall put_Mode(
4662 /*[in]*/ enum ConnectModeEnum plMode) = 0;
4663 virtual HRESULT __stdcall get_Provider(
4664 /*[out,retval]*/ BSTR* pbstr) = 0;
4665 virtual HRESULT __stdcall put_Provider(
4666 /*[in]*/ BSTR pbstr) = 0;
4667 virtual HRESULT __stdcall get_State(
4668 /*[out,retval]*/ long* plObjState) = 0;
4669 virtual HRESULT __stdcall raw_OpenSchema(
4670 /*[in]*/ enum SchemaEnum Schema,
4671 /*[in]*/ VARIANT Restrictions,
4672 /*[in]*/ VARIANT SchemaID,
4673 /*[out,retval]*/ struct _Recordset_Deprecated** pprset) = 0;
4674};
4675
4676struct __declspec(uuid("00000550-0000-0010-8000-00aa006d2ea4")) _Connection_Deprecated
4677 : Connection15_Deprecated
4678{
4679 //
4680 // Wrapper methods for error-handling
4681 //
4682
4683 HRESULT Cancel();
4684
4685 //
4686 // Raw methods provided by interface
4687 //
4688
4689 virtual HRESULT __stdcall raw_Cancel() = 0;
4690};
4691
4692struct __declspec(uuid("0000050e-0000-0010-8000-00aa006d2ea4")) Recordset15_Deprecated : _ADO
4693{
4694 //
4695 // Property data
4696 //
4697
4698 __declspec(property(get = GetFields)) Fields_DeprecatedPtr Fields;
4699 __declspec(property(get = GetPageSize, put = PutPageSize)) long PageSize;
4700 __declspec(property(get = GetPageCount)) ADO_LONGPTR PageCount;
4701 __declspec(property(get = GetCursorLocation,
4702 put = PutCursorLocation)) enum CursorLocationEnum CursorLocation;
4703 __declspec(property(get = GetState)) long State;
4704 __declspec(property(get = GetMarshalOptions,
4705 put = PutMarshalOptions)) enum MarshalOptionsEnum MarshalOptions;
4706 __declspec(property(get = GetCollect, put = PutCollect)) _variant_t Collect[];
4707 __declspec(property(get = GetEditMode)) enum EditModeEnum EditMode;
4708 __declspec(property(get = GetStatus)) long Status;
4709 __declspec(property(get = GetFilter, put = PutFilter)) _variant_t Filter;
4710 __declspec(property(get = GetSort, put = PutSort)) _bstr_t Sort;
4711 __declspec(property(get = GetAbsolutePosition,
4712 put = PutAbsolutePosition)) PositionEnum_Param AbsolutePosition;
4713 __declspec(property(get = GetbBOF)) VARIANT_BOOL bBOF;
4714 __declspec(property(get = GetBookmark, put = PutBookmark)) _variant_t Bookmark;
4715 __declspec(property(get = GetCacheSize, put = PutCacheSize)) long CacheSize;
4716 __declspec(property(get = GetCursorType, put = PutCursorType)) enum CursorTypeEnum CursorType;
4717 __declspec(property(get = GetbEOF)) VARIANT_BOOL bEOF;
4718 __declspec(property(get = GetAbsolutePage,
4719 put = PutAbsolutePage)) PositionEnum_Param AbsolutePage;
4720 __declspec(property(get = GetLockType, put = PutLockType)) enum LockTypeEnum LockType;
4721 __declspec(property(get = GetMaxRecords, put = PutMaxRecords)) ADO_LONGPTR MaxRecords;
4722 __declspec(property(get = GetRecordCount)) ADO_LONGPTR RecordCount;
4723
4724 //
4725 // Wrapper methods for error-handling
4726 //
4727
4728 PositionEnum_Param GetAbsolutePosition();
4729 void PutAbsolutePosition(PositionEnum_Param pl);
4730 void PutRefActiveConnection(IDispatch* pvar);
4731 void PutActiveConnection(const _variant_t& pvar);
4732 _variant_t GetActiveConnection();
4733 VARIANT_BOOL GetbBOF();
4734 _variant_t GetBookmark();
4735 void PutBookmark(const _variant_t& pvBookmark);
4736 long GetCacheSize();
4737 void PutCacheSize(long pl);
4738 enum CursorTypeEnum GetCursorType();
4739 void PutCursorType(enum CursorTypeEnum plCursorType);
4740 VARIANT_BOOL GetbEOF();
4741 Fields_DeprecatedPtr GetFields();
4742 enum LockTypeEnum GetLockType();
4743 void PutLockType(enum LockTypeEnum plLockType);
4744 ADO_LONGPTR GetMaxRecords();
4745 void PutMaxRecords(ADO_LONGPTR plMaxRecords);
4746 ADO_LONGPTR GetRecordCount();
4747 void PutRefSource(IDispatch* pvSource);
4748 void PutSource(_bstr_t pvSource);
4749 _variant_t GetSource();
4750 HRESULT AddNew(const _variant_t& FieldList = vtMissing, const _variant_t& Values = vtMissing);
4751 HRESULT CancelUpdate();
4752 HRESULT Close();
4753 HRESULT Delete(enum AffectEnum AffectRecords);
4754 _variant_t GetRows(long Rows, const _variant_t& Start = vtMissing,
4755 const _variant_t& Fields = vtMissing);
4756 HRESULT Move(ADO_LONGPTR NumRecords, const _variant_t& Start = vtMissing);
4757 HRESULT MoveNext();
4758 HRESULT MovePrevious();
4759 HRESULT MoveFirst();
4760 HRESULT MoveLast();
4761 HRESULT Open(const _variant_t& Source, const _variant_t& ActiveConnection,
4762 enum CursorTypeEnum CursorType, enum LockTypeEnum LockType, long Options);
4763 HRESULT Requery(long Options);
4764 HRESULT _xResync(enum AffectEnum AffectRecords);
4765 HRESULT Update(const _variant_t& Fields = vtMissing, const _variant_t& Values = vtMissing);
4766 PositionEnum_Param GetAbsolutePage();
4767 void PutAbsolutePage(PositionEnum_Param pl);
4768 enum EditModeEnum GetEditMode();
4769 _variant_t GetFilter();
4770 void PutFilter(const _variant_t& Criteria);
4771 ADO_LONGPTR GetPageCount();
4772 long GetPageSize();
4773 void PutPageSize(long pl);
4774 _bstr_t GetSort();
4775 void PutSort(_bstr_t Criteria);
4776 long GetStatus();
4777 long GetState();
4778 _Recordset_DeprecatedPtr _xClone();
4779 HRESULT UpdateBatch(enum AffectEnum AffectRecords);
4780 HRESULT CancelBatch(enum AffectEnum AffectRecords);
4781 enum CursorLocationEnum GetCursorLocation();
4782 void PutCursorLocation(enum CursorLocationEnum plCursorLoc);
4783 _Recordset_DeprecatedPtr NextRecordset(VARIANT* RecordsAffected);
4784 VARIANT_BOOL Supports(enum CursorOptionEnum CursorOptions);
4785 _variant_t GetCollect(const _variant_t& Index);
4786 void PutCollect(const _variant_t& Index, const _variant_t& pvar);
4787 enum MarshalOptionsEnum GetMarshalOptions();
4788 void PutMarshalOptions(enum MarshalOptionsEnum peMarshal);
4789 HRESULT Find(_bstr_t Criteria, ADO_LONGPTR SkipRecords,
4790 enum SearchDirectionEnum SearchDirection, const _variant_t& Start = vtMissing);
4791
4792 //
4793 // Raw methods provided by interface
4794 //
4795
4796 virtual HRESULT __stdcall get_AbsolutePosition(
4797 /*[out,retval]*/ PositionEnum_Param* pl) = 0;
4798 virtual HRESULT __stdcall put_AbsolutePosition(
4799 /*[in]*/ PositionEnum_Param pl) = 0;
4800 virtual HRESULT __stdcall putref_ActiveConnection(
4801 /*[in]*/ IDispatch* pvar) = 0;
4802 virtual HRESULT __stdcall put_ActiveConnection(
4803 /*[in]*/ VARIANT pvar) = 0;
4804 virtual HRESULT __stdcall get_ActiveConnection(
4805 /*[out,retval]*/ VARIANT* pvar) = 0;
4806 virtual HRESULT __stdcall get_bBOF(
4807 /*[out,retval]*/ VARIANT_BOOL* pb) = 0;
4808 virtual HRESULT __stdcall get_Bookmark(
4809 /*[out,retval]*/ VARIANT* pvBookmark) = 0;
4810 virtual HRESULT __stdcall put_Bookmark(
4811 /*[in]*/ VARIANT pvBookmark) = 0;
4812 virtual HRESULT __stdcall get_CacheSize(
4813 /*[out,retval]*/ long* pl) = 0;
4814 virtual HRESULT __stdcall put_CacheSize(
4815 /*[in]*/ long pl) = 0;
4816 virtual HRESULT __stdcall get_CursorType(
4817 /*[out,retval]*/ enum CursorTypeEnum* plCursorType) = 0;
4818 virtual HRESULT __stdcall put_CursorType(
4819 /*[in]*/ enum CursorTypeEnum plCursorType) = 0;
4820 virtual HRESULT __stdcall get_bEOF(
4821 /*[out,retval]*/ VARIANT_BOOL* pb) = 0;
4822 virtual HRESULT __stdcall get_Fields(
4823 /*[out,retval]*/ struct Fields_Deprecated** ppvObject) = 0;
4824 virtual HRESULT __stdcall get_LockType(
4825 /*[out,retval]*/ enum LockTypeEnum* plLockType) = 0;
4826 virtual HRESULT __stdcall put_LockType(
4827 /*[in]*/ enum LockTypeEnum plLockType) = 0;
4828 virtual HRESULT __stdcall get_MaxRecords(
4829 /*[out,retval]*/ ADO_LONGPTR* plMaxRecords) = 0;
4830 virtual HRESULT __stdcall put_MaxRecords(
4831 /*[in]*/ ADO_LONGPTR plMaxRecords) = 0;
4832 virtual HRESULT __stdcall get_RecordCount(
4833 /*[out,retval]*/ ADO_LONGPTR* pl) = 0;
4834 virtual HRESULT __stdcall putref_Source(
4835 /*[in]*/ IDispatch* pvSource) = 0;
4836 virtual HRESULT __stdcall put_Source(
4837 /*[in]*/ BSTR pvSource) = 0;
4838 virtual HRESULT __stdcall get_Source(
4839 /*[out,retval]*/ VARIANT* pvSource) = 0;
4840 virtual HRESULT __stdcall raw_AddNew(
4841 /*[in]*/ VARIANT FieldList = vtMissing,
4842 /*[in]*/ VARIANT Values = vtMissing) = 0;
4843 virtual HRESULT __stdcall raw_CancelUpdate() = 0;
4844 virtual HRESULT __stdcall raw_Close() = 0;
4845 virtual HRESULT __stdcall raw_Delete(
4846 /*[in]*/ enum AffectEnum AffectRecords) = 0;
4847 virtual HRESULT __stdcall raw_GetRows(
4848 /*[in]*/ long Rows,
4849 /*[in]*/ VARIANT Start,
4850 /*[in]*/ VARIANT Fields,
4851 /*[out,retval]*/ VARIANT* pvar) = 0;
4852 virtual HRESULT __stdcall raw_Move(
4853 /*[in]*/ ADO_LONGPTR NumRecords,
4854 /*[in]*/ VARIANT Start = vtMissing) = 0;
4855 virtual HRESULT __stdcall raw_MoveNext() = 0;
4856 virtual HRESULT __stdcall raw_MovePrevious() = 0;
4857 virtual HRESULT __stdcall raw_MoveFirst() = 0;
4858 virtual HRESULT __stdcall raw_MoveLast() = 0;
4859 virtual HRESULT __stdcall raw_Open(
4860 /*[in]*/ VARIANT Source,
4861 /*[in]*/ VARIANT ActiveConnection,
4862 /*[in]*/ enum CursorTypeEnum CursorType,
4863 /*[in]*/ enum LockTypeEnum LockType,
4864 /*[in]*/ long Options) = 0;
4865 virtual HRESULT __stdcall raw_Requery(
4866 /*[in]*/ long Options) = 0;
4867 virtual HRESULT __stdcall raw__xResync(
4868 /*[in]*/ enum AffectEnum AffectRecords) = 0;
4869 virtual HRESULT __stdcall raw_Update(
4870 /*[in]*/ VARIANT Fields = vtMissing,
4871 /*[in]*/ VARIANT Values = vtMissing) = 0;
4872 virtual HRESULT __stdcall get_AbsolutePage(
4873 /*[out,retval]*/ PositionEnum_Param* pl) = 0;
4874 virtual HRESULT __stdcall put_AbsolutePage(
4875 /*[in]*/ PositionEnum_Param pl) = 0;
4876 virtual HRESULT __stdcall get_EditMode(
4877 /*[out,retval]*/ enum EditModeEnum* pl) = 0;
4878 virtual HRESULT __stdcall get_Filter(
4879 /*[out,retval]*/ VARIANT* Criteria) = 0;
4880 virtual HRESULT __stdcall put_Filter(
4881 /*[in]*/ VARIANT Criteria) = 0;
4882 virtual HRESULT __stdcall get_PageCount(
4883 /*[out,retval]*/ ADO_LONGPTR* pl) = 0;
4884 virtual HRESULT __stdcall get_PageSize(
4885 /*[out,retval]*/ long* pl) = 0;
4886 virtual HRESULT __stdcall put_PageSize(
4887 /*[in]*/ long pl) = 0;
4888 virtual HRESULT __stdcall get_Sort(
4889 /*[out,retval]*/ BSTR* Criteria) = 0;
4890 virtual HRESULT __stdcall put_Sort(
4891 /*[in]*/ BSTR Criteria) = 0;
4892 virtual HRESULT __stdcall get_Status(
4893 /*[out,retval]*/ long* pl) = 0;
4894 virtual HRESULT __stdcall get_State(
4895 /*[out,retval]*/ long* plObjState) = 0;
4896 virtual HRESULT __stdcall raw__xClone(
4897 /*[out,retval]*/ struct _Recordset_Deprecated** ppvObject) = 0;
4898 virtual HRESULT __stdcall raw_UpdateBatch(
4899 /*[in]*/ enum AffectEnum AffectRecords) = 0;
4900 virtual HRESULT __stdcall raw_CancelBatch(
4901 /*[in]*/ enum AffectEnum AffectRecords) = 0;
4902 virtual HRESULT __stdcall get_CursorLocation(
4903 /*[out,retval]*/ enum CursorLocationEnum* plCursorLoc) = 0;
4904 virtual HRESULT __stdcall put_CursorLocation(
4905 /*[in]*/ enum CursorLocationEnum plCursorLoc) = 0;
4906 virtual HRESULT __stdcall raw_NextRecordset(
4907 /*[out]*/ VARIANT* RecordsAffected,
4908 /*[out,retval]*/ struct _Recordset_Deprecated** ppiRs) = 0;
4909 virtual HRESULT __stdcall raw_Supports(
4910 /*[in]*/ enum CursorOptionEnum CursorOptions,
4911 /*[out,retval]*/ VARIANT_BOOL* pb) = 0;
4912 virtual HRESULT __stdcall get_Collect(
4913 /*[in]*/ VARIANT Index,
4914 /*[out,retval]*/ VARIANT* pvar) = 0;
4915 virtual HRESULT __stdcall put_Collect(
4916 /*[in]*/ VARIANT Index,
4917 /*[in]*/ VARIANT pvar) = 0;
4918 virtual HRESULT __stdcall get_MarshalOptions(
4919 /*[out,retval]*/ enum MarshalOptionsEnum* peMarshal) = 0;
4920 virtual HRESULT __stdcall put_MarshalOptions(
4921 /*[in]*/ enum MarshalOptionsEnum peMarshal) = 0;
4922 virtual HRESULT __stdcall raw_Find(
4923 /*[in]*/ BSTR Criteria,
4924 /*[in]*/ ADO_LONGPTR SkipRecords,
4925 /*[in]*/ enum SearchDirectionEnum SearchDirection,
4926 /*[in]*/ VARIANT Start = vtMissing) = 0;
4927};
4928
4929struct __declspec(uuid("0000054f-0000-0010-8000-00aa006d2ea4")) Recordset20_Deprecated
4930 : Recordset15_Deprecated
4931{
4932 //
4933 // Property data
4934 //
4935
4936 __declspec(property(get = GetDataSource, put = PutRefDataSource)) IUnknownPtr DataSource;
4937 __declspec(property(get = GetActiveCommand)) IDispatchPtr ActiveCommand;
4938 __declspec(property(get = GetStayInSync, put = PutStayInSync)) VARIANT_BOOL StayInSync;
4939 __declspec(property(get = GetDataMember, put = PutDataMember)) _bstr_t DataMember;
4940
4941 //
4942 // Wrapper methods for error-handling
4943 //
4944
4945 HRESULT Cancel();
4946 IUnknownPtr GetDataSource();
4947 void PutRefDataSource(IUnknown* ppunkDataSource);
4948 HRESULT _xSave(_bstr_t FileName, enum PersistFormatEnum PersistFormat);
4949 IDispatchPtr GetActiveCommand();
4950 void PutStayInSync(VARIANT_BOOL pbStayInSync);
4951 VARIANT_BOOL GetStayInSync();
4952 _bstr_t GetString(enum StringFormatEnum StringFormat, long NumRows, _bstr_t ColumnDelimeter,
4953 _bstr_t RowDelimeter, _bstr_t NullExpr);
4954 _bstr_t GetDataMember();
4955 void PutDataMember(_bstr_t pbstrDataMember);
4956 enum CompareEnum CompareBookmarks(const _variant_t& Bookmark1, const _variant_t& Bookmark2);
4957 _Recordset_DeprecatedPtr Clone(enum LockTypeEnum LockType);
4958 HRESULT Resync(enum AffectEnum AffectRecords, enum ResyncEnum ResyncValues);
4959
4960 //
4961 // Raw methods provided by interface
4962 //
4963
4964 virtual HRESULT __stdcall raw_Cancel() = 0;
4965 virtual HRESULT __stdcall get_DataSource(
4966 /*[out,retval]*/ IUnknown** ppunkDataSource) = 0;
4967 virtual HRESULT __stdcall putref_DataSource(
4968 /*[in]*/ IUnknown* ppunkDataSource) = 0;
4969 virtual HRESULT __stdcall raw__xSave(
4970 /*[in]*/ BSTR FileName,
4971 /*[in]*/ enum PersistFormatEnum PersistFormat) = 0;
4972 virtual HRESULT __stdcall get_ActiveCommand(
4973 /*[out,retval]*/ IDispatch** ppCmd) = 0;
4974 virtual HRESULT __stdcall put_StayInSync(
4975 /*[in]*/ VARIANT_BOOL pbStayInSync) = 0;
4976 virtual HRESULT __stdcall get_StayInSync(
4977 /*[out,retval]*/ VARIANT_BOOL* pbStayInSync) = 0;
4978 virtual HRESULT __stdcall raw_GetString(
4979 /*[in]*/ enum StringFormatEnum StringFormat,
4980 /*[in]*/ long NumRows,
4981 /*[in]*/ BSTR ColumnDelimeter,
4982 /*[in]*/ BSTR RowDelimeter,
4983 /*[in]*/ BSTR NullExpr,
4984 /*[out,retval]*/ BSTR* pRetString) = 0;
4985 virtual HRESULT __stdcall get_DataMember(
4986 /*[out,retval]*/ BSTR* pbstrDataMember) = 0;
4987 virtual HRESULT __stdcall put_DataMember(
4988 /*[in]*/ BSTR pbstrDataMember) = 0;
4989 virtual HRESULT __stdcall raw_CompareBookmarks(
4990 /*[in]*/ VARIANT Bookmark1,
4991 /*[in]*/ VARIANT Bookmark2,
4992 /*[out,retval]*/ enum CompareEnum* pCompare) = 0;
4993 virtual HRESULT __stdcall raw_Clone(
4994 /*[in]*/ enum LockTypeEnum LockType,
4995 /*[out,retval]*/ struct _Recordset_Deprecated** ppvObject) = 0;
4996 virtual HRESULT __stdcall raw_Resync(
4997 /*[in]*/ enum AffectEnum AffectRecords,
4998 /*[in]*/ enum ResyncEnum ResyncValues) = 0;
4999};
5000
5001struct __declspec(uuid("00000555-0000-0010-8000-00aa006d2ea4")) Recordset21_Deprecated
5002 : Recordset20_Deprecated
5003{
5004 //
5005 // Property data
5006 //
5007
5008 __declspec(property(get = GetIndex, put = PutIndex)) _bstr_t Index;
5009
5010 //
5011 // Wrapper methods for error-handling
5012 //
5013
5014 HRESULT Seek(const _variant_t& KeyValues, enum SeekEnum SeekOption);
5015 void PutIndex(_bstr_t pbstrIndex);
5016 _bstr_t GetIndex();
5017
5018 //
5019 // Raw methods provided by interface
5020 //
5021
5022 virtual HRESULT __stdcall raw_Seek(
5023 /*[in]*/ VARIANT KeyValues,
5024 /*[in]*/ enum SeekEnum SeekOption) = 0;
5025 virtual HRESULT __stdcall put_Index(
5026 /*[in]*/ BSTR pbstrIndex) = 0;
5027 virtual HRESULT __stdcall get_Index(
5028 /*[out,retval]*/ BSTR* pbstrIndex) = 0;
5029};
5030
5031struct __declspec(uuid("00000556-0000-0010-8000-00aa006d2ea4")) _Recordset_Deprecated
5032 : Recordset21_Deprecated
5033{
5034 //
5035 // Wrapper methods for error-handling
5036 //
5037
5038 HRESULT Save(const _variant_t& Destination, enum PersistFormatEnum PersistFormat);
5039
5040 //
5041 // Raw methods provided by interface
5042 //
5043
5044 virtual HRESULT __stdcall raw_Save(
5045 /*[in]*/ VARIANT Destination,
5046 /*[in]*/ enum PersistFormatEnum PersistFormat) = 0;
5047};
5048
5049struct __declspec(uuid("00000508-0000-0010-8000-00aa006d2ea4")) Command15_Deprecated : _ADO
5050{
5051 //
5052 // Property data
5053 //
5054
5055 __declspec(property(get = GetParameters)) Parameters_DeprecatedPtr Parameters;
5056 __declspec(property(get = GetActiveConnection,
5057 put = PutRefActiveConnection)) _Connection_DeprecatedPtr ActiveConnection;
5058 __declspec(property(get = GetCommandText, put = PutCommandText)) _bstr_t CommandText;
5059 __declspec(property(get = GetCommandTimeout, put = PutCommandTimeout)) long CommandTimeout;
5060 __declspec(property(get = GetPrepared, put = PutPrepared)) VARIANT_BOOL Prepared;
5061 __declspec(property(get = GetCommandType,
5062 put = PutCommandType)) enum CommandTypeEnum CommandType;
5063 __declspec(property(get = GetName, put = PutName)) _bstr_t Name;
5064
5065 //
5066 // Wrapper methods for error-handling
5067 //
5068
5069 _Connection_DeprecatedPtr GetActiveConnection();
5070 void PutRefActiveConnection(struct _Connection_Deprecated* ppvObject);
5071 void PutActiveConnection(const _variant_t& ppvObject);
5072 _bstr_t GetCommandText();
5073 void PutCommandText(_bstr_t pbstr);
5074 long GetCommandTimeout();
5075 void PutCommandTimeout(long pl);
5076 VARIANT_BOOL GetPrepared();
5077 void PutPrepared(VARIANT_BOOL pfPrepared);
5078 _Recordset_DeprecatedPtr Execute(VARIANT* RecordsAffected, VARIANT* Parameters, long Options);
5079 _Parameter_DeprecatedPtr CreateParameter(_bstr_t Name, enum DataTypeEnum Type,
5080 enum ParameterDirectionEnum Direction,
5081 ADO_LONGPTR Size, const _variant_t& Value = vtMissing);
5082 Parameters_DeprecatedPtr GetParameters();
5083 void PutCommandType(enum CommandTypeEnum plCmdType);
5084 enum CommandTypeEnum GetCommandType();
5085 _bstr_t GetName();
5086 void PutName(_bstr_t pbstrName);
5087
5088 //
5089 // Raw methods provided by interface
5090 //
5091
5092 virtual HRESULT __stdcall get_ActiveConnection(
5093 /*[out,retval]*/ struct _Connection_Deprecated** ppvObject) = 0;
5094 virtual HRESULT __stdcall putref_ActiveConnection(
5095 /*[in]*/ struct _Connection_Deprecated* ppvObject) = 0;
5096 virtual HRESULT __stdcall put_ActiveConnection(
5097 /*[in]*/ VARIANT ppvObject) = 0;
5098 virtual HRESULT __stdcall get_CommandText(
5099 /*[out,retval]*/ BSTR* pbstr) = 0;
5100 virtual HRESULT __stdcall put_CommandText(
5101 /*[in]*/ BSTR pbstr) = 0;
5102 virtual HRESULT __stdcall get_CommandTimeout(
5103 /*[out,retval]*/ long* pl) = 0;
5104 virtual HRESULT __stdcall put_CommandTimeout(
5105 /*[in]*/ long pl) = 0;
5106 virtual HRESULT __stdcall get_Prepared(
5107 /*[out,retval]*/ VARIANT_BOOL* pfPrepared) = 0;
5108 virtual HRESULT __stdcall put_Prepared(
5109 /*[in]*/ VARIANT_BOOL pfPrepared) = 0;
5110 virtual HRESULT __stdcall raw_Execute(
5111 /*[out]*/ VARIANT* RecordsAffected,
5112 /*[in]*/ VARIANT* Parameters,
5113 /*[in]*/ long Options,
5114 /*[out,retval]*/ struct _Recordset_Deprecated** ppiRs) = 0;
5115 virtual HRESULT __stdcall raw_CreateParameter(
5116 /*[in]*/ BSTR Name,
5117 /*[in]*/ enum DataTypeEnum Type,
5118 /*[in]*/ enum ParameterDirectionEnum Direction,
5119 /*[in]*/ ADO_LONGPTR Size,
5120 /*[in]*/ VARIANT Value,
5121 /*[out,retval]*/ struct _Parameter_Deprecated** ppiprm) = 0;
5122 virtual HRESULT __stdcall get_Parameters(
5123 /*[out,retval]*/ struct Parameters_Deprecated** ppvObject) = 0;
5124 virtual HRESULT __stdcall put_CommandType(
5125 /*[in]*/ enum CommandTypeEnum plCmdType) = 0;
5126 virtual HRESULT __stdcall get_CommandType(
5127 /*[out,retval]*/ enum CommandTypeEnum* plCmdType) = 0;
5128 virtual HRESULT __stdcall get_Name(
5129 /*[out,retval]*/ BSTR* pbstrName) = 0;
5130 virtual HRESULT __stdcall put_Name(
5131 /*[in]*/ BSTR pbstrName) = 0;
5132};
5133
5134struct __declspec(uuid("0000054e-0000-0010-8000-00aa006d2ea4")) Command25_Deprecated
5135 : Command15_Deprecated
5136{
5137 //
5138 // Property data
5139 //
5140
5141 __declspec(property(get = GetState)) long State;
5142
5143 //
5144 // Wrapper methods for error-handling
5145 //
5146
5147 long GetState();
5148 HRESULT Cancel();
5149
5150 //
5151 // Raw methods provided by interface
5152 //
5153
5154 virtual HRESULT __stdcall get_State(
5155 /*[out,retval]*/ long* plObjState) = 0;
5156 virtual HRESULT __stdcall raw_Cancel() = 0;
5157};
5158
5159struct __declspec(uuid("b08400bd-f9d1-4d02-b856-71d5dba123e9")) _Command_Deprecated
5160 : Command25_Deprecated
5161{
5162 //
5163 // Property data
5164 //
5165
5166 __declspec(property(get = GetDialect, put = PutDialect)) _bstr_t Dialect;
5167 __declspec(property(get = GetNamedParameters,
5168 put = PutNamedParameters)) VARIANT_BOOL NamedParameters;
5169
5170 //
5171 // Wrapper methods for error-handling
5172 //
5173
5174 void PutRefCommandStream(IUnknown* pvStream);
5175 _variant_t GetCommandStream();
5176 void PutDialect(_bstr_t pbstrDialect);
5177 _bstr_t GetDialect();
5178 void PutNamedParameters(VARIANT_BOOL pfNamedParameters);
5179 VARIANT_BOOL GetNamedParameters();
5180
5181 //
5182 // Raw methods provided by interface
5183 //
5184
5185 virtual HRESULT __stdcall putref_CommandStream(
5186 /*[in]*/ IUnknown* pvStream) = 0;
5187 virtual HRESULT __stdcall get_CommandStream(
5188 /*[out,retval]*/ VARIANT* pvStream) = 0;
5189 virtual HRESULT __stdcall put_Dialect(
5190 /*[in]*/ BSTR pbstrDialect) = 0;
5191 virtual HRESULT __stdcall get_Dialect(
5192 /*[out,retval]*/ BSTR* pbstrDialect) = 0;
5193 virtual HRESULT __stdcall put_NamedParameters(
5194 /*[in]*/ VARIANT_BOOL pfNamedParameters) = 0;
5195 virtual HRESULT __stdcall get_NamedParameters(
5196 /*[out,retval]*/ VARIANT_BOOL* pfNamedParameters) = 0;
5197};
5198
5199struct __declspec(uuid("00000403-0000-0010-8000-00aa006d2ea4")) RecordsetEventsVt_Deprecated
5200 : IUnknown
5201{
5202 //
5203 // Wrapper methods for error-handling
5204 //
5205
5206 HRESULT WillChangeField(long cFields, const _variant_t& Fields, enum EventStatusEnum* adStatus,
5207 struct _Recordset_Deprecated* pRecordset);
5208 HRESULT FieldChangeComplete(long cFields, const _variant_t& Fields, struct Error* pError,
5209 enum EventStatusEnum* adStatus,
5210 struct _Recordset_Deprecated* pRecordset);
5211 HRESULT WillChangeRecord(enum EventReasonEnum adReason, long cRecords,
5212 enum EventStatusEnum* adStatus,
5213 struct _Recordset_Deprecated* pRecordset);
5214 HRESULT RecordChangeComplete(enum EventReasonEnum adReason, long cRecords, struct Error* pError,
5215 enum EventStatusEnum* adStatus,
5216 struct _Recordset_Deprecated* pRecordset);
5217 HRESULT WillChangeRecordset(enum EventReasonEnum adReason, enum EventStatusEnum* adStatus,
5218 struct _Recordset_Deprecated* pRecordset);
5219 HRESULT RecordsetChangeComplete(enum EventReasonEnum adReason, struct Error* pError,
5220 enum EventStatusEnum* adStatus,
5221 struct _Recordset_Deprecated* pRecordset);
5222 HRESULT WillMove(enum EventReasonEnum adReason, enum EventStatusEnum* adStatus,
5223 struct _Recordset_Deprecated* pRecordset);
5224 HRESULT MoveComplete(enum EventReasonEnum adReason, struct Error* pError,
5225 enum EventStatusEnum* adStatus, struct _Recordset_Deprecated* pRecordset);
5226 HRESULT EndOfRecordset(VARIANT_BOOL* fMoreData, enum EventStatusEnum* adStatus,
5227 struct _Recordset_Deprecated* pRecordset);
5228 HRESULT FetchProgress(long Progress, long MaxProgress, enum EventStatusEnum* adStatus,
5229 struct _Recordset_Deprecated* pRecordset);
5230 HRESULT FetchComplete(struct Error* pError, enum EventStatusEnum* adStatus,
5231 struct _Recordset_Deprecated* pRecordset);
5232
5233 //
5234 // Raw methods provided by interface
5235 //
5236
5237 virtual HRESULT __stdcall raw_WillChangeField(
5238 /*[in]*/ long cFields,
5239 /*[in]*/ VARIANT Fields,
5240 /*[in,out]*/ enum EventStatusEnum* adStatus,
5241 /*[in]*/ struct _Recordset_Deprecated* pRecordset) = 0;
5242 virtual HRESULT __stdcall raw_FieldChangeComplete(
5243 /*[in]*/ long cFields,
5244 /*[in]*/ VARIANT Fields,
5245 /*[in]*/ struct Error* pError,
5246 /*[in,out]*/ enum EventStatusEnum* adStatus,
5247 /*[in]*/ struct _Recordset_Deprecated* pRecordset) = 0;
5248 virtual HRESULT __stdcall raw_WillChangeRecord(
5249 /*[in]*/ enum EventReasonEnum adReason,
5250 /*[in]*/ long cRecords,
5251 /*[in,out]*/ enum EventStatusEnum* adStatus,
5252 /*[in]*/ struct _Recordset_Deprecated* pRecordset) = 0;
5253 virtual HRESULT __stdcall raw_RecordChangeComplete(
5254 /*[in]*/ enum EventReasonEnum adReason,
5255 /*[in]*/ long cRecords,
5256 /*[in]*/ struct Error* pError,
5257 /*[in,out]*/ enum EventStatusEnum* adStatus,
5258 /*[in]*/ struct _Recordset_Deprecated* pRecordset) = 0;
5259 virtual HRESULT __stdcall raw_WillChangeRecordset(
5260 /*[in]*/ enum EventReasonEnum adReason,
5261 /*[in,out]*/ enum EventStatusEnum* adStatus,
5262 /*[in]*/ struct _Recordset_Deprecated* pRecordset) = 0;
5263 virtual HRESULT __stdcall raw_RecordsetChangeComplete(
5264 /*[in]*/ enum EventReasonEnum adReason,
5265 /*[in]*/ struct Error* pError,
5266 /*[in,out]*/ enum EventStatusEnum* adStatus,
5267 /*[in]*/ struct _Recordset_Deprecated* pRecordset) = 0;
5268 virtual HRESULT __stdcall raw_WillMove(
5269 /*[in]*/ enum EventReasonEnum adReason,
5270 /*[in,out]*/ enum EventStatusEnum* adStatus,
5271 /*[in]*/ struct _Recordset_Deprecated* pRecordset) = 0;
5272 virtual HRESULT __stdcall raw_MoveComplete(
5273 /*[in]*/ enum EventReasonEnum adReason,
5274 /*[in]*/ struct Error* pError,
5275 /*[in,out]*/ enum EventStatusEnum* adStatus,
5276 /*[in]*/ struct _Recordset_Deprecated* pRecordset) = 0;
5277 virtual HRESULT __stdcall raw_EndOfRecordset(
5278 /*[in,out]*/ VARIANT_BOOL* fMoreData,
5279 /*[in,out]*/ enum EventStatusEnum* adStatus,
5280 /*[in]*/ struct _Recordset_Deprecated* pRecordset) = 0;
5281 virtual HRESULT __stdcall raw_FetchProgress(
5282 /*[in]*/ long Progress,
5283 /*[in]*/ long MaxProgress,
5284 /*[in,out]*/ enum EventStatusEnum* adStatus,
5285 /*[in]*/ struct _Recordset_Deprecated* pRecordset) = 0;
5286 virtual HRESULT __stdcall raw_FetchComplete(
5287 /*[in]*/ struct Error* pError,
5288 /*[in,out]*/ enum EventStatusEnum* adStatus,
5289 /*[in]*/ struct _Recordset_Deprecated* pRecordset) = 0;
5290};
5291
5292struct __declspec(uuid("00000562-0000-0010-8000-00aa006d2ea4")) _Record_Deprecated : _ADO
5293{
5294 //
5295 // Property data
5296 //
5297
5298 __declspec(property(get = GetFields)) Fields_DeprecatedPtr Fields;
5299 __declspec(property(get = GetState)) enum ObjectStateEnum State;
5300 __declspec(property(get = GetMode, put = PutMode)) enum ConnectModeEnum Mode;
5301 __declspec(property(get = GetParentURL)) _bstr_t ParentURL;
5302 __declspec(property(get = GetRecordType)) enum RecordTypeEnum RecordType;
5303
5304 //
5305 // Wrapper methods for error-handling
5306 //
5307
5308 _variant_t GetActiveConnection();
5309 void PutActiveConnection(_bstr_t pvar);
5310 void PutRefActiveConnection(struct _Connection_Deprecated* pvar);
5311 enum ObjectStateEnum GetState();
5312 _variant_t GetSource();
5313 void PutSource(_bstr_t pvar);
5314 void PutRefSource(IDispatch* pvar);
5315 enum ConnectModeEnum GetMode();
5316 void PutMode(enum ConnectModeEnum pMode);
5317 _bstr_t GetParentURL();
5318 _bstr_t MoveRecord(_bstr_t Source, _bstr_t Destination, _bstr_t UserName, _bstr_t Password,
5319 enum MoveRecordOptionsEnum Options, VARIANT_BOOL Async);
5320 _bstr_t CopyRecord(_bstr_t Source, _bstr_t Destination, _bstr_t UserName, _bstr_t Password,
5321 enum CopyRecordOptionsEnum Options, VARIANT_BOOL Async);
5322 HRESULT DeleteRecord(_bstr_t Source, VARIANT_BOOL Async);
5323 HRESULT Open(const _variant_t& Source, const _variant_t& ActiveConnection,
5324 enum ConnectModeEnum Mode, enum RecordCreateOptionsEnum CreateOptions,
5325 enum RecordOpenOptionsEnum Options, _bstr_t UserName, _bstr_t Password);
5326 HRESULT Close();
5327 Fields_DeprecatedPtr GetFields();
5328 enum RecordTypeEnum GetRecordType();
5329 _Recordset_DeprecatedPtr GetChildren();
5330 HRESULT Cancel();
5331
5332 //
5333 // Raw methods provided by interface
5334 //
5335
5336 virtual HRESULT __stdcall get_ActiveConnection(
5337 /*[out,retval]*/ VARIANT* pvar) = 0;
5338 virtual HRESULT __stdcall put_ActiveConnection(
5339 /*[in]*/ BSTR pvar) = 0;
5340 virtual HRESULT __stdcall putref_ActiveConnection(
5341 /*[in]*/ struct _Connection_Deprecated* pvar) = 0;
5342 virtual HRESULT __stdcall get_State(
5343 /*[out,retval]*/ enum ObjectStateEnum* pState) = 0;
5344 virtual HRESULT __stdcall get_Source(
5345 /*[out,retval]*/ VARIANT* pvar) = 0;
5346 virtual HRESULT __stdcall put_Source(
5347 /*[in]*/ BSTR pvar) = 0;
5348 virtual HRESULT __stdcall putref_Source(
5349 /*[in]*/ IDispatch* pvar) = 0;
5350 virtual HRESULT __stdcall get_Mode(
5351 /*[out,retval]*/ enum ConnectModeEnum* pMode) = 0;
5352 virtual HRESULT __stdcall put_Mode(
5353 /*[in]*/ enum ConnectModeEnum pMode) = 0;
5354 virtual HRESULT __stdcall get_ParentURL(
5355 /*[out,retval]*/ BSTR* pbstrParentURL) = 0;
5356 virtual HRESULT __stdcall raw_MoveRecord(
5357 /*[in]*/ BSTR Source,
5358 /*[in]*/ BSTR Destination,
5359 /*[in]*/ BSTR UserName,
5360 /*[in]*/ BSTR Password,
5361 /*[in]*/ enum MoveRecordOptionsEnum Options,
5362 /*[in]*/ VARIANT_BOOL Async,
5363 /*[out,retval]*/ BSTR* pbstrNewURL) = 0;
5364 virtual HRESULT __stdcall raw_CopyRecord(
5365 /*[in]*/ BSTR Source,
5366 /*[in]*/ BSTR Destination,
5367 /*[in]*/ BSTR UserName,
5368 /*[in]*/ BSTR Password,
5369 /*[in]*/ enum CopyRecordOptionsEnum Options,
5370 /*[in]*/ VARIANT_BOOL Async,
5371 /*[out,retval]*/ BSTR* pbstrNewURL) = 0;
5372 virtual HRESULT __stdcall raw_DeleteRecord(
5373 /*[in]*/ BSTR Source,
5374 /*[in]*/ VARIANT_BOOL Async) = 0;
5375 virtual HRESULT __stdcall raw_Open(
5376 /*[in]*/ VARIANT Source,
5377 /*[in]*/ VARIANT ActiveConnection,
5378 /*[in]*/ enum ConnectModeEnum Mode,
5379 /*[in]*/ enum RecordCreateOptionsEnum CreateOptions,
5380 /*[in]*/ enum RecordOpenOptionsEnum Options,
5381 /*[in]*/ BSTR UserName,
5382 /*[in]*/ BSTR Password) = 0;
5383 virtual HRESULT __stdcall raw_Close() = 0;
5384 virtual HRESULT __stdcall get_Fields(
5385 /*[out,retval]*/ struct Fields_Deprecated** ppFlds) = 0;
5386 virtual HRESULT __stdcall get_RecordType(
5387 /*[out,retval]*/ enum RecordTypeEnum* ptype) = 0;
5388 virtual HRESULT __stdcall raw_GetChildren(
5389 /*[out,retval]*/ struct _Recordset_Deprecated** pprset) = 0;
5390 virtual HRESULT __stdcall raw_Cancel() = 0;
5391};
5392
5393//
5394// Wrapper method implementations
5395//
5396
5397//#include "Debug\msado15.tli"
5398
5399} // namespace XTPADODB
5400# include "Common/Base/Diagnostic/XTPEnableAdvancedWarnings.h"
5401
5402# include "Calendar/XTPCalendarADO.inl"
5403
5404# pragma pack(pop)
5405
5406#endif // !defined(_XTPCALENDARADO_H__)
XTPDisableAdvancedWarnings.h
XTPEnableAdvancedWarnings.h


Toolkit Pro: XTPChartOpenGLCameraDeviceCommand.h Source File

  • Source
  • Chart
  • Drawing
  • OpenGL
XTPChartOpenGLCameraDeviceCommand.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTOPENGLCAMERADEVICECOMMAND_H__)
24# define __XTPCHARTOPENGLCAMERADEVICECOMMAND_H__
25
26# if _MSC_VER >= 1000
27# pragma once
28# endif // _MSC_VER >= 1000
29
30# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
31
32class CXTPChartDeviceContext;
33
34class _XTP_EXT_CLASS CXTPChartOpenGLCameraDeviceCommand : public CXTPChart3dDeviceCommand
35{
36public:
41 CXTPChartOpenGLCameraDeviceCommand(const CXTPPoint3f& ptPosition, const CXTPPoint3f& ptFocal,
42 const CXTPPoint3f& ptUpVector);
43
44protected:
53 virtual void ExecuteOverride(CXTPChartDeviceContext* pDC);
54
55private:
56 const CXTPPoint3f m_ptPosition;
57 const CXTPPoint3f m_ptFocal;
58 const CXTPPoint3f m_ptUpVector;
59};
60
61# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
62#endif //#if !defined(__XTPCHARTOPENGLCAMERADEVICECOMMAND_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChart3dDeviceCommand
Defines a common implementation interface for chart 3D drawing commands.
Definition XTPChartDeviceCommand.h:368
CXTPChartDeviceCommand::ExecuteOverride
virtual void ExecuteOverride(CXTPChartDeviceContext *pDC)
Override this function to write the drawing code for specific objects.
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPPoint3T< float >


Toolkit Pro: Member List

CXTPDockingPanePanelColorSet2022 Member List

This is the complete list of members for CXTPDockingPanePanelColorSet2022, including all inherited members.

CXTPDockingPanePanelColorSet2012() | CXTPDockingPanePanelColorSet2012 |
CXTPDockingPanePanelColorSet2022() | CXTPDockingPanePanelColorSet2022 |
CXTPTabPaintManagerColorSet() | CXTPTabPaintManagerColorSet |
FillClient(CDC *pDC, CRect rc, CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
FillHeader(CDC *pDC, CRect rc, CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
FillNavigateButton(CDC *pDC, CXTPTabManagerNavigateButton *pButton, CRect &rc) | CXTPDockingPanePanelColorSet2012 | virtual
FillPropertyButton(CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerColorSet | virtual
FillStateButton(CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerColorSet | virtual
GetClientColor(CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
GetItemColor(CXTPTabManagerItem *pItem) | CXTPDockingPanePanelColorSet2012 | virtual
GradientFill(CDC *pDC, CRect rc, COLORREF clrLight, COLORREF clrDark, XTPTabPosition position) | CXTPTabPaintManagerColorSet |
IsAppThemed() const | CXTPTabPaintManagerColorSet | virtual
m_clrActiveFilesBack | CXTPTabPaintManagerColorSet |
m_clrActiveFilesBackHighlighted | CXTPTabPaintManagerColorSet |
m_clrActiveFilesBackPressed | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyph | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyphHighlighted | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyphPressed | CXTPTabPaintManagerColorSet |
m_clrAutoHideFace | CXTPTabPaintManagerColorSet |
m_clrBorderHighlight | CXTPTabPaintManagerColorSet |
m_clrButtonBorder | CXTPTabPaintManagerColorSet |
m_clrButtonBorderHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonBorderHot | CXTPTabPaintManagerColorSet |
m_clrButtonBorderKeyTips | CXTPTabPaintManagerColorSet |
m_clrButtonBorderTabContext1 | CXTPTabPaintManagerColorSet |
m_clrButtonBorderTabContext2 | CXTPTabPaintManagerColorSet |
m_clrButtonHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonHighlightedClose | CXTPTabPaintManagerColorSet |
m_clrButtonNormal | CXTPTabPaintManagerColorSet |
m_clrButtonPressed | CXTPTabPaintManagerColorSet |
m_clrButtonSelected | CXTPTabPaintManagerColorSet |
m_clrButtonSelectedHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonSelectedPressed | CXTPTabPaintManagerColorSet |
m_clrControlFace | CXTPTabPaintManagerColorSet |
m_clrFrameBorder | CXTPTabPaintManagerColorSet |
m_clrHeaderFace | CXTPTabPaintManagerColorSet |
m_clrPaneFace | CXTPTabPaintManagerColorSet |
m_clrTabClientBack | CXTPTabPaintManagerColorSet |
m_clrTabClientBorder | CXTPTabPaintManagerColorSet |
m_clrTextDisabled | CXTPTabPaintManagerColorSet |
m_clrTextHighlight | CXTPTabPaintManagerColorSet |
m_clrTextHighlightClose | CXTPTabPaintManagerColorSet |
m_clrTextNormal | CXTPTabPaintManagerColorSet |
m_clrTextPressed | CXTPTabPaintManagerColorSet |
m_clrTextSelected | CXTPTabPaintManagerColorSet |
m_clrTextSelectedHighlighted | CXTPTabPaintManagerColorSet |
m_clrTextSelectedPressed | CXTPTabPaintManagerColorSet |
m_csExcelNormal | CXTPTabPaintManagerColorSet |
m_csExcelSelected | CXTPTabPaintManagerColorSet |
m_csPropertyPage | CXTPTabPaintManagerColorSet |
m_csPropertyPage2003 | CXTPTabPaintManagerColorSet |
m_csStateButton | CXTPTabPaintManagerColorSet |
m_pPaintManager | CXTPTabPaintManagerColorSet | protected
RefreshMetrics() | CXTPDockingPanePanelColorSet2022 | virtual
SelectClipRgn(CDC *pDC, CRect rcClient, CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
SetTextColor(CDC *pDC, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerColorSet | virtual
~CXTPTabPaintManagerColorSet() | CXTPTabPaintManagerColorSet | virtual


Toolkit Pro: Member List

CXTPSyntaxEditFileChangesMonitor Member List

This is the complete list of members for CXTPSyntaxEditFileChangesMonitor, including all inherited members.

AddMonitorFile(CString &strFilename, DWORD dwOwnerFlags) | CXTPSyntaxEditFileChangesMonitor |
CXTPSyntaxEditFileChangesMonitor() | CXTPSyntaxEditFileChangesMonitor |
RefreshFiles() | CXTPSyntaxEditFileChangesMonitor |
SetConfigurationManager(CXTPSyntaxEditConfigurationManager *pConfigMgr) | CXTPSyntaxEditFileChangesMonitor |
SetDefaultFolder(const CString &strPath) | CXTPSyntaxEditFileChangesMonitor |
StartMonitoring() | CXTPSyntaxEditFileChangesMonitor |
StopMonitoring() | CXTPSyntaxEditFileChangesMonitor |
~CXTPSyntaxEditFileChangesMonitor() | CXTPSyntaxEditFileChangesMonitor | virtual


Toolkit Pro: Member List

CXTPWinThread Member List

This is the complete list of members for CXTPWinThread, including all inherited members.

CXTPWinThread(int xtpComInit=xtpComInitAppDefault) | CXTPWinThread |
~CXTPWinThread() | CXTPWinThread | virtual


Toolkit Pro: Member List

CXTPDatePickerThemeOffice2013 Member List

This is the complete list of members for CXTPDatePickerThemeOffice2013, including all inherited members.

CalcDayOfWeekRect(CDC *pDC) | CXTPDatePickerPaintManager | virtual
CalcDayRect(CDC *pDC) | CXTPDatePickerPaintManager | virtual
CalcMonthHeaderRect(CDC *pDC) | CXTPDatePickerPaintManager | virtual
CalcMonthRect(CDC *pDC) | CXTPDatePickerPaintManager | virtual
CalcWeekNumbersRect(CDC *pDC) | CXTPDatePickerPaintManager | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPDatePickerPaintManager() | CXTPDatePickerPaintManager |
CXTPDatePickerThemeOffice2013() | CXTPDatePickerThemeOffice2013 |
DrawBackground(CDC *pDC, CRect rcClient) | CXTPDatePickerThemeOffice2013 | virtual
DrawBorder(CDC *pDC, const CXTPDatePickerControl *pControl, CRect &rcClient, BOOL bDraw) | CXTPDatePickerThemeOffice2013 | virtual
DrawButton(CDC *pDC, const CRect &rcButton, const CString &strButton, BOOL bIsDown, BOOL bIsHighLight) | CXTPDatePickerThemeOffice2013 | virtual
DrawDay(CDC *pDC, CXTPDatePickerItemDay *pDay) | CXTPDatePickerThemeOffice2013 | virtual
DrawDaysOfWeek(CDC *pDC, CXTPDatePickerItemMonth *pMonth) | CXTPDatePickerThemeOffice2013 | virtual
DrawMonthHeader(CDC *pDC, CXTPDatePickerItemMonth *pMonth) | CXTPDatePickerPaintManager | virtual
DrawScrollTriangle(CDC *pDC, CRect rcSpot, BOOL bLeftDirection, COLORREF clrColor=0, BOOL bYears=FALSE) | CXTPDatePickerPaintManager | virtual
DrawWeekNumbers(CDC *pDC, CXTPDatePickerItemMonth *pMonth) | CXTPDatePickerThemeOffice2013 | virtual
EnableTheme(BOOL bEnableTheme) | CXTPDatePickerPaintManager | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetButtonFont() | CXTPDatePickerPaintManager |
GetControlBackColor() | CXTPDatePickerPaintManager | virtual
GetCursorBack() | CXTPDatePickerPaintManager | virtual
GetDayBackColor() | CXTPDatePickerPaintManager | virtual
GetDaysOfWeekBackColor() | CXTPDatePickerPaintManager | virtual
GetDaysOfWeekTextColor() | CXTPDatePickerPaintManager | virtual
GetDaysOfWeekTextFont() | CXTPDatePickerPaintManager |
GetDayTextColor() | CXTPDatePickerPaintManager | virtual
GetDayTextFont() | CXTPDatePickerPaintManager | virtual
GetDayTextFontBold() | CXTPDatePickerPaintManager | virtual
GetHeaderTextFont() | CXTPDatePickerPaintManager |
GetHighlightTodayBackColor() | CXTPDatePickerThemeOffice2013 | virtual
GetHighlightTodayBorderColor() | CXTPDatePickerThemeOffice2013 | virtual
GetHighlightTodayColor() | CXTPDatePickerPaintManager | virtual
GetHighlightTodayTextColor() | CXTPDatePickerThemeOffice2013 | virtual
GetListControlBackColor() | CXTPDatePickerPaintManager | virtual
GetListControlTextColor() | CXTPDatePickerPaintManager | virtual
GetListControlTextFont() | CXTPDatePickerPaintManager |
GetMonthHeaderBackColor() | CXTPDatePickerPaintManager | virtual
GetMonthHeaderTextColor() | CXTPDatePickerPaintManager | virtual
GetNonMonthDayBackColor() | CXTPDatePickerPaintManager | virtual
GetNonMonthDayTextColor() | CXTPDatePickerPaintManager | virtual
GetNonMonthDayTextFont() | CXTPDatePickerPaintManager |
GetPaintTheme() const | CXTPDatePickerPaintManager | protected
GetSelectedDayBackColor() | CXTPDatePickerPaintManager | virtual
GetSelectedDayTextColor() | CXTPDatePickerPaintManager | virtual
GetWeekNumbersBackColor() | CXTPDatePickerPaintManager | virtual
GetWeekNumbersTextColor() | CXTPDatePickerPaintManager | virtual
GetWeekNumbersTextFont() | CXTPDatePickerPaintManager |
m_bEnableTheme | CXTPDatePickerPaintManager | protected
m_clr3DFace | CXTPDatePickerPaintManager | protected
m_clr3DLight | CXTPDatePickerPaintManager | protected
m_clr3DShadow | CXTPDatePickerPaintManager | protected
m_clr3DText | CXTPDatePickerPaintManager | protected
m_clrBackground | CXTPDatePickerThemeOffice2013 | protected
m_clrButtonFace | CXTPDatePickerPaintManager |
m_clrButtonText | CXTPDatePickerPaintManager |
m_clrControlBack | CXTPDatePickerPaintManager |
m_clrDayBack | CXTPDatePickerPaintManager |
m_clrDaysOfWeekBack | CXTPDatePickerPaintManager |
m_clrDaysOfWeekText | CXTPDatePickerPaintManager |
m_clrDayText | CXTPDatePickerPaintManager |
m_clrHighlightToday | CXTPDatePickerPaintManager |
m_clrListControlBack | CXTPDatePickerPaintManager |
m_clrListControlText | CXTPDatePickerPaintManager |
m_clrMonthBorder | CXTPDatePickerPaintManager |
m_clrMonthHeaderBack | CXTPDatePickerPaintManager |
m_clrMonthHeaderButton | CXTPDatePickerPaintManager |
m_clrMonthHeaderText | CXTPDatePickerPaintManager |
m_clrNonMonthDayBack | CXTPDatePickerPaintManager |
m_clrNonMonthDayText | CXTPDatePickerPaintManager |
m_clrSelectedDayBack | CXTPDatePickerPaintManager |
m_clrSelectedDayText | CXTPDatePickerPaintManager |
m_clrStaticBorder | CXTPDatePickerPaintManager | protected
m_clrWeekNumbersBack | CXTPDatePickerPaintManager |
m_clrWeekNumbersText | CXTPDatePickerPaintManager |
m_hCursorBack | CXTPDatePickerPaintManager | protected
m_nPaintTheme | CXTPDatePickerPaintManager | protected
m_szDayMargin | CXTPDatePickerPaintManager |
m_themeButton | CXTPDatePickerPaintManager | protected
m_xtpFontButton | CXTPDatePickerPaintManager | protected
m_xtpFontDay | CXTPDatePickerPaintManager | protected
m_xtpFontDayBold | CXTPDatePickerPaintManager | protected
m_xtpFontDaysOfWeek | CXTPDatePickerPaintManager | protected
m_xtpFontHeader | CXTPDatePickerPaintManager | protected
m_xtpFontListControl | CXTPDatePickerPaintManager | protected
m_xtpFontNonMonthDay | CXTPDatePickerPaintManager | protected
m_xtpFontWeekNumbers | CXTPDatePickerPaintManager | protected
RefreshMetrics() | CXTPDatePickerThemeOffice2013 | virtual
SetButtonFont(CFont *fontButton) | CXTPDatePickerPaintManager |
SetButtonFontIndirect(LOGFONT *lFont) | CXTPDatePickerPaintManager |
SetFontIndirect(LOGFONT *lFont) | CXTPDatePickerPaintManager |
Triangle(CDC *pDC, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clrColor=0) | CXTPDatePickerPaintManager | protectedvirtual
~CXTPDatePickerPaintManager() | CXTPDatePickerPaintManager | virtual
~CXTPDatePickerThemeOffice2013() | CXTPDatePickerThemeOffice2013 | virtual


Toolkit Pro: XTPScrollBarThemeOffice2013.h Source File

  • Source
  • Common
  • ScrollBar
  • Themes
XTPScrollBarThemeOffice2013.h
Go to the documentation of this file.
1
23#if !defined(__XTPSCROLLBARTHEMEOFFICE2013_H__)
24# define __XTPSCROLLBARTHEMEOFFICE2013_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38struct XTP_SCROLLBARINICOLORS
39{
40 COLORREF clrBack;
41 COLORREF clrScrollBack;
42 COLORREF clrScrollArrow;
43 COLORREF clrScrollBorder;
44 COLORREF clrThumbBack;
45 COLORREF clrThumbBorder;
46};
47
53struct XTP_SCROLLBARDRAWCOLORS : public XTP_SCROLLBARINICOLORS
54{
55 COLORREF clrScrollDownBack;
56 COLORREF clrScrollDownArrow;
57 COLORREF clrScrollDownBorder;
58};
59
66class _XTP_EXT_CLASS CXTPScrollBarThemeOffice2013 : public CXTPScrollBarPaintManager
67{
68public:
73 CXTPScrollBarThemeOffice2013();
74
79 virtual ~CXTPScrollBarThemeOffice2013();
80
98 virtual void GetScrollBarColors(XTP_SCROLLBARDRAWCOLORS& sbc, int nHitSelected, int nHitPressed,
99 BOOL bEnabled);
100
101protected:
108 virtual void DrawScrollBar(CDC* pDC, CXTPScrollBase* pGallery);
109
114 virtual void RefreshMetrics();
115
123 virtual void DrawBackground(CDC* pDC, CXTPScrollBase* pScroll, XTPScrollMetricsV* pMetrics);
124
132 virtual void DrawButtons(CDC* pDC, CXTPScrollBase* pScroll, XTPScrollMetricsV* pMetrics);
133
141 virtual void DrawArrows(CDC* pDC, CXTPScrollBase* pScroll, XTPScrollMetricsV* pMetrics);
142
150 virtual void DrawThumbButton(CDC* pDC, CXTPScrollBase* pScroll, XTPScrollMetricsV* pMetrics);
151
159 virtual void DrawBackground(CDC* pDC, CXTPScrollBase* pScroll, XTPScrollMetricsH* pMetrics);
160
168 virtual void DrawButtons(CDC* pDC, CXTPScrollBase* pScroll, XTPScrollMetricsH* pMetrics);
169
177 virtual void DrawArrows(CDC* pDC, CXTPScrollBase* pScroll, XTPScrollMetricsH* pMetrics);
178
186 virtual void DrawThumbButton(CDC* pDC, CXTPScrollBase* pScroll, XTPScrollMetricsH* pMetrics);
187
194 virtual void DrawGripper(CDC* pDC, CXTPScrollBase* pScroll);
195
196 XTP_SCROLLBARINICOLORS m_clrNormal;
197 XTP_SCROLLBARINICOLORS m_clrPressed;
198 XTP_SCROLLBARINICOLORS m_clrSelected;
199 XTP_SCROLLBARINICOLORS m_clrDisabled;
200 XTP_SCROLLBARDRAWCOLORS m_clrCurrent;
201};
202
203# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
205#endif // !defined(__XTPSCROLLBARTHEMEOFFICE2013_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPScrollBarPaintManager
CXTPScrollBarPaintManager is standalone class used to draw CXTPCommandBarScrollBarCtrl object.
Definition XTPScrollBarPaintManager.h:40
CXTPScrollBarThemeOffice2013
The CXTPScrollBarThemeOffice2013 class is used to enable a Gallery Office 2013 style theme for Comman...
Definition XTPScrollBarThemeOffice2013.h:67
CXTPScrollBarThemeOffice2013::~CXTPScrollBarThemeOffice2013
virtual ~CXTPScrollBarThemeOffice2013()
Destructor, handles any cleanup / deallocation necessary.
CXTPScrollBarThemeOffice2013::m_clrNormal
XTP_SCROLLBARINICOLORS m_clrNormal
Holds scrollbar default state colors.
Definition XTPScrollBarThemeOffice2013.h:196
CXTPScrollBarThemeOffice2013::DrawBackground
virtual void DrawBackground(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws verical scrollbar background only.
CXTPScrollBarThemeOffice2013::CXTPScrollBarThemeOffice2013
CXTPScrollBarThemeOffice2013()
Constructs a CXTPScrollBarThemeOffice2013 object.
CXTPScrollBarThemeOffice2013::DrawScrollBar
virtual void DrawScrollBar(CDC *pDC, CXTPScrollBase *pGallery)
This method is called to draw all scrollbar parts.
CXTPScrollBarThemeOffice2013::DrawButtons
virtual void DrawButtons(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar buttons only.
CXTPScrollBarThemeOffice2013::m_clrSelected
XTP_SCROLLBARINICOLORS m_clrSelected
Holds scrollbar selected state colors.
Definition XTPScrollBarThemeOffice2013.h:198
CXTPScrollBarThemeOffice2013::m_clrCurrent
XTP_SCROLLBARDRAWCOLORS m_clrCurrent
Holds currently selected scrollbar colors.
Definition XTPScrollBarThemeOffice2013.h:200
CXTPScrollBarThemeOffice2013::DrawArrows
virtual void DrawArrows(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar button arrows only.
CXTPScrollBarThemeOffice2013::DrawGripper
virtual void DrawGripper(CDC *pDC, CXTPScrollBase *pScroll)
Draws scrollbar gripper only.
CXTPScrollBarThemeOffice2013::DrawButtons
virtual void DrawButtons(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws vertical scrollbar buttons only.
CXTPScrollBarThemeOffice2013::m_clrDisabled
XTP_SCROLLBARINICOLORS m_clrDisabled
Holds scrollbar disabled state colors.
Definition XTPScrollBarThemeOffice2013.h:199
CXTPScrollBarThemeOffice2013::DrawBackground
virtual void DrawBackground(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar background only.
CXTPScrollBarThemeOffice2013::DrawArrows
virtual void DrawArrows(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws vertical scrollbar button arrows only.
CXTPScrollBarThemeOffice2013::GetScrollBarColors
virtual void GetScrollBarColors(XTP_SCROLLBARDRAWCOLORS &sbc, int nHitSelected, int nHitPressed, BOOL bEnabled)
Used by the paint manager to retreive state colors used when drawing the scrollbar.
CXTPScrollBarThemeOffice2013::DrawThumbButton
virtual void DrawThumbButton(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar thumb button only.
CXTPScrollBarThemeOffice2013::m_clrPressed
XTP_SCROLLBARINICOLORS m_clrPressed
Holds scrollbar pressed state colors.
Definition XTPScrollBarThemeOffice2013.h:197
CXTPScrollBarThemeOffice2013::RefreshMetrics
virtual void RefreshMetrics()
Recalculates scrollbar metrics.
CXTPScrollBarThemeOffice2013::DrawThumbButton
virtual void DrawThumbButton(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws vertical scrollbar thumb button only.
CXTPScrollBase
CXTPScrollBase is the base class for all scrollable objects.
Definition XTPScrollBase.h:222
XTP_SCROLLBARDRAWCOLORS
Used by paint manager to retrieve the current state color settings when drawing scrollbars.
Definition XTPScrollBarThemeOffice2013.h:54
XTP_SCROLLBARDRAWCOLORS::clrScrollDownArrow
COLORREF clrScrollDownArrow
Scrollbar down / right button arrow color.
Definition XTPScrollBarThemeOffice2013.h:56
XTP_SCROLLBARDRAWCOLORS::clrScrollDownBorder
COLORREF clrScrollDownBorder
Scrollbar down / right button border color.
Definition XTPScrollBarThemeOffice2013.h:57
XTP_SCROLLBARDRAWCOLORS::clrScrollDownBack
COLORREF clrScrollDownBack
Scrollbar down / right button background color.
Definition XTPScrollBarThemeOffice2013.h:55
XTP_SCROLLBARINICOLORS
Used by paint manager to retrieve color settings from the loaded resource INI file.
Definition XTPScrollBarThemeOffice2013.h:39
XTP_SCROLLBARINICOLORS::clrThumbBorder
COLORREF clrThumbBorder
Scrollbar thumb border color.
Definition XTPScrollBarThemeOffice2013.h:45
XTP_SCROLLBARINICOLORS::clrThumbBack
COLORREF clrThumbBack
Scrollbar thumb background color.
Definition XTPScrollBarThemeOffice2013.h:44
XTP_SCROLLBARINICOLORS::clrBack
COLORREF clrBack
Scrollbar background color.
Definition XTPScrollBarThemeOffice2013.h:40
XTP_SCROLLBARINICOLORS::clrScrollBack
COLORREF clrScrollBack
Scrollbar button background color.
Definition XTPScrollBarThemeOffice2013.h:41
XTP_SCROLLBARINICOLORS::clrScrollArrow
COLORREF clrScrollArrow
Scrollbar button arrow color.
Definition XTPScrollBarThemeOffice2013.h:42
XTP_SCROLLBARINICOLORS::clrScrollBorder
COLORREF clrScrollBorder
Scrollbar button border color.
Definition XTPScrollBarThemeOffice2013.h:43


Toolkit Pro: XTPChartRadarAxis.h Source File

  • Source
  • Chart
  • Diagram
  • Axis
XTPChartRadarAxis.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTRADARAXIS_H__)
24# define __XTPCHARTRADARAXIS_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartRadarDiagram;
34
43class _XTP_EXT_CLASS CXTPChartRadarAxisX : public CXTPChartAxis
44{
46 DECLARE_DYNAMIC(CXTPChartRadarAxisX)
48public:
55 CXTPChartRadarAxisX(CXTPChartRadarDiagram* pDiagram);
56
57public:
65 virtual BOOL IsVertical() const;
66
74 virtual BOOL IsValuesAxis() const;
75
86 virtual double CalcSideMarginsValue(double nMinValue, double nMaxValue) const;
87
101 BOOL IsDirectionClockwise() const;
102
117 void SetDirectionClockwise(BOOL bDirectionClockwise);
118
119protected:
129 virtual CXTPChartAxisView* CreateView(CXTPChartDeviceContext* pDC,
130 CXTPChartElementView* pParentView);
131
132 BOOL m_bDirectionClockwise;
133};
134
143class _XTP_EXT_CLASS CXTPChartRadarAxisY : public CXTPChartAxis
144{
145public:
152 CXTPChartRadarAxisY(CXTPChartRadarDiagram* pDiagram);
153
154public:
162 virtual BOOL IsVertical() const;
163
171 virtual BOOL IsValuesAxis() const;
172
183 virtual double CalcSideMarginsValue(double nMinValue, double nMaxValue) const;
184
185protected:
195 virtual CXTPChartAxisView* CreateView(CXTPChartDeviceContext* pDC,
196 CXTPChartElementView* pParentView);
197};
199# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
200#endif //#if !defined(__XTPCHARTRADARAXIS_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartAxis
This abstract base class represents a chart axis as a kind of chart element.
Definition XTPChartAxis.h:86
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartElementView
This class represents the view of a chart element.
Definition XTPChartElementView.h:47
CXTPChartRadarAxisX
CXTPChartRadarAxisX is a derived class from the CXTPChartAxis class and represents the X axis of a ch...
Definition XTPChartRadarAxis.h:44
CXTPChartRadarAxisX::CalcSideMarginsValue
virtual double CalcSideMarginsValue(double nMinValue, double nMaxValue) const
This method overrides the base class member and returns the side margin value of the chart's X axis.
CXTPChartRadarAxisX::CXTPChartRadarAxisX
CXTPChartRadarAxisX(CXTPChartRadarDiagram *pDiagram)
Constructs a CXTPChartAxisX object.
CXTPChartRadarAxisX::SetDirectionClockwise
void SetDirectionClockwise(BOOL bDirectionClockwise)
This function sets the direction of the axis.
CXTPChartRadarAxisX::CreateView
virtual CXTPChartAxisView * CreateView(CXTPChartDeviceContext *pDC, CXTPChartElementView *pParentView)
This function creates the view (CXTPChartAxisView) of the axis.
CXTPChartRadarAxisX::m_bDirectionClockwise
BOOL m_bDirectionClockwise
The direction of the axis.
Definition XTPChartRadarAxis.h:132
CXTPChartRadarAxisX::IsDirectionClockwise
BOOL IsDirectionClockwise() const
This function returns the direction of the axis.
CXTPChartRadarAxisX::IsValuesAxis
virtual BOOL IsValuesAxis() const
This method overrides the base class member and determines if the X axis is value type.
CXTPChartRadarAxisX::IsVertical
virtual BOOL IsVertical() const
This method overrides the base class member and determines if the X axis is vertical.
CXTPChartRadarAxisY
CXTPChartRadarAxisY is a derived class from the CXTPChartAxis class and represents the Y axis of a ch...
Definition XTPChartRadarAxis.h:144
CXTPChartRadarAxisY::CalcSideMarginsValue
virtual double CalcSideMarginsValue(double nMinValue, double nMaxValue) const
This method overrides the base class member and returns the side margin value of the chart's Y axis.
CXTPChartRadarAxisY::CreateView
virtual CXTPChartAxisView * CreateView(CXTPChartDeviceContext *pDC, CXTPChartElementView *pParentView)
This function creates the view (CXTPChartAxisView) of the axis.
CXTPChartRadarAxisY::IsValuesAxis
virtual BOOL IsValuesAxis() const
This method overrides the base class member and determines if the Y axis is value type.
CXTPChartRadarAxisY::CXTPChartRadarAxisY
CXTPChartRadarAxisY(CXTPChartRadarDiagram *pDiagram)
Constructs a CXTPChartAxisY object.
CXTPChartRadarAxisY::IsVertical
virtual BOOL IsVertical() const
This method overrides the base class member and determines if the Y axis is vertical.
CXTPChartRadarDiagram
This class represents a chart 2D diagram, which is a kind of CXTPChartDiagram.
Definition XTPChartRadarDiagram.h:53


Toolkit Pro: XTPMDIWndTab.h Source File

  • Source
  • Controls
  • Tab
XTPMDIWndTab.h
Go to the documentation of this file.
1
23#if !defined(__XTPMDIWNDTAB_H__)
24# define __XTPMDIWNDTAB_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
36class CXTPMDIWndTab;
37
44class _XTP_EXT_CLASS CXTPMDIClientWnd : public CWnd
45{
46public:
52 CXTPMDIClientWnd(CXTPMDIWndTab* pMDIWndTab);
53
58 virtual ~CXTPMDIClientWnd();
59
60public:
67 void SetBorderGap(int iSize);
68
69protected:
71 DECLARE_MESSAGE_MAP()
72
73 //{{AFX_VIRTUAL(CXTPMDIClientWnd)
74 virtual void CalcWindowRect(LPRECT lpClientRect, UINT nAdjustType = adjustBorder);
75 //}}AFX_VIRTUAL
76
77 //{{AFX_MSG(CXTPMDIClientWnd)
78 afx_msg LRESULT OnMDICreate(WPARAM wParam, LPARAM lParam);
79 afx_msg LRESULT OnMDIDestroy(WPARAM wParam, LPARAM lParam);
80 afx_msg LRESULT OnMDIActivate(WPARAM wParam, LPARAM lParam);
81 //}}AFX_MSG
84protected:
85 int m_iBorderGap;
86 CXTPMDIWndTab* m_pMDIWndTab;
87};
88
90
91AFX_INLINE void CXTPMDIClientWnd::SetBorderGap(int iBorderGap)
92{
93 m_iBorderGap = iBorderGap;
94}
95
96DECLARE_TABCTRL_BASE(CXTPMDIWndTabBase, CTabCtrl, CXTPTabBase)
114class _XTP_EXT_CLASS CXTPMDIWndTab : public CXTPMDIWndTabBase
115{
117 DECLARE_DYNAMIC(CXTPMDIWndTab)
126 struct MDICHILD
127 {
128 int iItem;
129 HWND hWnd;
130 CString strItem;
131 };
132
143 typedef CList<MDICHILD*, MDICHILD*> CMDIChildList;
144
155 typedef CMap<HWND, HWND, HICON, HICON&> CIconWndMap;
156
167 typedef CMap<HWND, HWND, CString, CString&> CStringMap;
168
169public:
174 CXTPMDIWndTab();
175
180 virtual ~CXTPMDIWndTab();
181
182public:
192 bool SetTabIcon(int iIndex, HICON& hIcon);
193
203 bool SetTabIcon(HWND hChildWnd, HICON& hIcon);
204
214 bool SetTabLabel(int iIndex, CString& strLabel);
215
225 bool SetTabLabel(HWND hChildWnd, CString& strLabel);
226
236 virtual BOOL Install(CMDIFrameWnd* pMDIFrameWnd, DWORD dwStyle = TCS_BOTTOM | TCS_HOTTRACK,
237 BOOL bNoIcons = TRUE);
238
245 virtual BOOL UnInstall();
246
256 int TabFromPoint(CPoint point) const;
257
267 CMDIChildWnd* GetFrameWnd(int iIndex = -1) const;
268
277 CMDIChildWnd* GetFrameWnd(CPoint point) const;
278
287 void SetMenuID(UINT popupMenuID, int nPos = 0, UINT nDefCmd = (UINT)-1);
288
295 void SetBorderGap(int iSize);
296
305 CString GetChildWndText(HWND hWnd) const;
306
307protected:
315 virtual BOOL Init();
316
322 virtual void InitializeFont();
323
331 virtual void InsertTabWnd(CMDIChildWnd* pChildFrame, BOOL bRecalcLayout = TRUE);
332
340 BOOL RefreshActiveSel();
341
347 void RefreshTabLabels();
348
354 void RefreshIndexes();
355
362 virtual void OnMDICreate(HWND hWnd);
363
370 virtual void OnMDIDestroy(HWND hWnd);
371
379 virtual void OnMDIActivate(HWND hWnd);
380
386 virtual void RecalcLayout(BOOL bDelayRecalc);
387
388protected:
390 DECLARE_MESSAGE_MAP()
391
392 //{{AFX_MSG(CXTPMDIWndTab)
393 afx_msg void OnNcCalcSize(BOOL bCalcValidRects, NCCALCSIZE_PARAMS FAR* lpncsp);
394 afx_msg void OnNcPaint();
395 afx_msg void OnSelchange(NMHDR* pNMHDR, LRESULT* pResult);
396 afx_msg void OnDestroy();
397 afx_msg void OnRButtonDown(UINT nFlags, CPoint point);
398 afx_msg void OnIdleUpdateCmdUI();
399 afx_msg void OnTabClose();
400 //}}AFX_MSG
403protected:
404 int m_iBorderGap;
405 int m_iHitTest;
406 int m_nPos;
407 UINT m_nDefCmd;
408 UINT m_popupMenuID;
409 HWND m_hActiveChild;
410 BOOL m_bNoIcons;
411 DWORD m_dwInitSignature;
413 CImageList m_imageList;
414 CMDIFrameWnd* m_pMDIFrameWnd;
415 CMDIChildList m_arMDIChildern;
416 CXTPMDIClientWnd* m_pMDIClientWnd;
418 CIconWndMap m_mapTabIcons;
419 CStringMap m_mapTabLabels;
421 friend class CXTPMDIClientWnd;
422};
423
425
426AFX_INLINE void CXTPMDIWndTab::SetMenuID(UINT popupMenuID, int nPos, UINT nDefCmd)
427{
428 m_popupMenuID = popupMenuID;
429 m_nPos = nPos;
430 m_nDefCmd = nDefCmd;
431}
432AFX_INLINE void CXTPMDIWndTab::SetBorderGap(int iBorderGap)
433{
434 m_iBorderGap = iBorderGap;
435 m_pMDIClientWnd->SetBorderGap(iBorderGap + ::GetSystemMetrics(SM_CXSIZEFRAME));
436}
438# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
440#endif // !defined(__XTPMDIWNDTAB_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPMDIClientWnd
CXTPMDIClientWnd is a CWnd derived helper class for the CXTPMDIWndTab tab control.
Definition XTPMDIWndTab.h:45
CXTPMDIClientWnd::CXTPMDIClientWnd
CXTPMDIClientWnd(CXTPMDIWndTab *pMDIWndTab)
Constructs a CXTPMDIClientWnd object.
CXTPMDIClientWnd::SetBorderGap
void SetBorderGap(int iSize)
This member function will set the size of the gap between the client area and the tab control.
CXTPMDIClientWnd::~CXTPMDIClientWnd
virtual ~CXTPMDIClientWnd()
Destroys a CXTPMDIClientWnd object, handles cleanup and deallocation.
CXTPMDIWndTab
The CXTPMDIWndTab class is used for creating a tabbed MDI document interface.
Definition XTPMDIWndTab.h:115
CXTPMDIWndTab::RefreshActiveSel
BOOL RefreshActiveSel()
This member function is called by the tab control to ensure that the current selection matches the ac...
CXTPMDIWndTab::SetTabIcon
bool SetTabIcon(int iIndex, HICON &hIcon)
Call this member function to set the icon for the tab item specified by 'iIndex'.
CXTPMDIWndTab::CXTPMDIWndTab
CXTPMDIWndTab()
Constructs a CXTPMDIWndTab object.
CXTPMDIWndTab::UnInstall
virtual BOOL UnInstall()
This member function will uninstall the MDI tab views from your application.
CXTPMDIWndTab::InsertTabWnd
virtual void InsertTabWnd(CMDIChildWnd *pChildFrame, BOOL bRecalcLayout=TRUE)
This member function is called to insert a child frame into the MDI tab control.
CXTPMDIWndTab::GetChildWndText
CString GetChildWndText(HWND hWnd) const
This member function will get the text for the specified MDI child window.
CXTPMDIWndTab::GetFrameWnd
CMDIChildWnd * GetFrameWnd(int iIndex=-1) const
This member function will retrieve a pointer to the child frame associated with the tab item.
CXTPMDIWndTab::SetBorderGap
void SetBorderGap(int iSize)
This member function will set the size of the gap between the client area and the tab control.
CXTPMDIWndTab::RefreshTabLabels
void RefreshTabLabels()
This member function is called by the tab control to ensure that the tab labels match their correspon...
CXTPMDIWndTab::RefreshIndexes
void RefreshIndexes()
This member function is called by the tab control to ensure that the stored indexes match their corre...
CXTPMDIWndTab::RecalcLayout
virtual void RecalcLayout(BOOL bDelayRecalc)
Called to refresh the tab labels and frame window layout.
CXTPMDIWndTab::SetTabIcon
bool SetTabIcon(HWND hChildWnd, HICON &hIcon)
Call this member function to set the icon for the tab item specified by 'iIndex'.
CXTPMDIWndTab::Install
virtual BOOL Install(CMDIFrameWnd *pMDIFrameWnd, DWORD dwStyle=TCS_BOTTOM|TCS_HOTTRACK, BOOL bNoIcons=TRUE)
This member function will install the MDI tab views with your application.
CXTPMDIWndTab::Init
virtual BOOL Init()
This member function is called by the CXTPMDIWndTab class to perform initialization when the window i...
CXTPMDIWndTab::SetTabLabel
bool SetTabLabel(HWND hChildWnd, CString &strLabel)
Call this member function to set the label for the tab item specified by 'iIndex'.
CXTPMDIWndTab::TabFromPoint
int TabFromPoint(CPoint point) const
Call this member function to retrieve the tab index from the current cursor position.
CXTPMDIWndTab::OnMDIDestroy
virtual void OnMDIDestroy(HWND hWnd)
Called when a WM_MDIDESTROY message is sent to a multiple-document interface (MDI) client window to c...
CXTPMDIWndTab::SetTabLabel
bool SetTabLabel(int iIndex, CString &strLabel)
Call this member function to set the label for the tab item specified by 'iIndex'.
CXTPMDIWndTab::InitializeFont
virtual void InitializeFont()
This member function is called to initialize the font for the tab control associated with this view.
CXTPMDIWndTab::OnMDIActivate
virtual void OnMDIActivate(HWND hWnd)
Called when a WM_MDIACTIVATE message is sent to a multiple-document interface (MDI) client window to ...
CXTPMDIWndTab::OnMDICreate
virtual void OnMDICreate(HWND hWnd)
Called when a WM_MDICREATE message is sent to a multiple-document interface (MDI) client window to cr...
CXTPMDIWndTab::SetMenuID
void SetMenuID(UINT popupMenuID, int nPos=0, UINT nDefCmd=(UINT) -1)
This member function is used to set the resource ID for the pop-up menu used by the tab control.
CXTPMDIWndTab::~CXTPMDIWndTab
virtual ~CXTPMDIWndTab()
Destroys a CXTPMDIWndTab object, handles cleanup and deallocation.
CXTPMDIWndTab::GetFrameWnd
CMDIChildWnd * GetFrameWnd(CPoint point) const
This member function will retrieve a pointer to the child frame associated with the tab item.
CXTPTabBase
CXTPTabBase is a standalone base class.
Definition XTPTabBase.h:61


Toolkit Pro: Member List

CXTPChartRadarDiagram Member List

This is the complete list of members for CXTPChartRadarDiagram, including all inherited members.

CalculateSeriesLayout(CXTPChartDeviceContext *pDC, CXTPChartDiagramView *pView) | CXTPChartDiagram | virtual
CreateView(CXTPChartDeviceContext *pDC, CXTPChartElementView *pParent) | CXTPChartRadarDiagram | virtual
CXTPChartDiagram() | CXTPChartDiagram | protected
CXTPChartElement() | CXTPChartElement |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartPanel() | CXTPChartPanel |
CXTPChartRadarDiagram() | CXTPChartRadarDiagram |
DoPropExchange(CXTPPropExchange *pPX) | CXTPChartRadarDiagram | virtual
GetAppearance() const | CXTPChartRadarDiagram |
GetAxisX() const | CXTPChartRadarDiagram |
GetAxisY() const | CXTPChartRadarDiagram |
GetContent() const | CXTPChartElement |
GetOwner() const | CXTPChartElement |
GetSeries() const | CXTPChartDiagram |
GetTitles() const | CXTPChartPanel |
Is3D() const | CXTPChartObject |
m_arrSeries | CXTPChartDiagram | protected
m_pAxisX | CXTPChartRadarDiagram | protected
m_pAxisY | CXTPChartRadarDiagram | protected
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartElement | virtual
OnSeriesAdded(CXTPChartSeries *pSeries) | CXTPChartDiagram | protectedvirtual
OnSeriesRemoved(CXTPChartSeries *pSeries) | CXTPChartDiagram | protected
Release() | CXTPChartDiagram | protectedvirtual
UpdateLayout(CXTPChartDeviceContext *pDC, CXTPChartDiagramView *pView, CRect rcBounds) | CXTPChartRadarDiagram | protected
~CXTPChartElement() | CXTPChartElement | virtual
~CXTPChartPanel() | CXTPChartPanel | virtual
~CXTPChartRadarDiagram() | CXTPChartRadarDiagram | virtual


Toolkit Pro: Member List

CXTPPropertyGridVisualStudio2012Theme Member List

This is the complete list of members for CXTPPropertyGridVisualStudio2012Theme, including all inherited members.

AdjustItemCaptionRect(CXTPPropertyGridItem *pItem, CRect &rcCaption) | CXTPPropertyGridPaintManager | virtual
AdjustItemValueRect(CXTPPropertyGridItem *pItem, CRect &rcValue) | CXTPPropertyGridPaintManager | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPPropertyGridPaintManager(CXTPPropertyGrid *pGrid) | CXTPPropertyGridPaintManager |
CXTPPropertyGridVisualStudio2012Theme(CXTPPropertyGrid *pGrid, BOOL bLight) | CXTPPropertyGridVisualStudio2012Theme |
DrawCategoryCaptionBackground(CDC *pDC, CXTPPropertyGridItem *pItem, CRect rc) | CXTPPropertyGridPaintManager | virtual
DrawCheckBox(CDC *pDC, CXTPPropertyGridItemBool *pButton) | CXTPPropertyGridPaintManager | virtual
DrawCheckMark(CDC *pDC, CRect rc, BOOL bEnabled, BOOL bChecked) | CXTPPropertyGridPaintManager | virtual
DrawExpandButton(CDC &dc, CXTPPropertyGridItem *pItem, CRect rcCaption) | CXTPPropertyGridVisualStudio2012Theme | virtual
DrawInplaceButtons(CDC *pDC, PDRAWITEMSTRUCT lpDrawItemStruct, CXTPPropertyGridItem *pItem, CRect rcValue) | CXTPPropertyGridPaintManager | virtual
DrawInplaceListItem(CDC *pDC, CXTPPropertyGridItemConstraint *pConstraint, CRect rc, BOOL bSelected) | CXTPPropertyGridPaintManager | virtual
DrawItem(PDRAWITEMSTRUCT lpDrawItemStruct) | CXTPPropertyGridPaintManager | virtual
DrawItemCaption(CDC *pDC, CXTPPropertyGridItem *pItem, CRect rcCaption) | CXTPPropertyGridPaintManager | virtual
DrawItemValue(CDC *pDC, CXTPPropertyGridItem *pItem, CRect rcValue) | CXTPPropertyGridPaintManager | virtual
DrawPropertyGridBorder(CDC *pDC, RECT &rcBorder, XTPPropertyGridWindow nWindow) | CXTPPropertyGridPaintManager | virtual
DrawRadioMark(CDC *pDC, CRect rc, BOOL bEnabled, BOOL bChecked) | CXTPPropertyGridPaintManager | virtual
FillInplaceButton(CDC *pDC, CXTPPropertyGridInplaceButton *pButton) | CXTPPropertyGridPaintManager | virtual
FillPropertyGrid(CDC *pDC) | CXTPPropertyGridPaintManager | virtual
FillPropertyGridView(CDC *pDC) | CXTPPropertyGridPaintManager | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetItemBackColor(CXTPPropertyGridItem *pItem, BOOL bValuePart) | CXTPPropertyGridPaintManager | virtual
GetItemFont(CXTPPropertyGridItem *pItem, BOOL bValuePart) | CXTPPropertyGridPaintManager | virtual
GetItemMetrics() const | CXTPPropertyGridPaintManager |
GetItemsBorderHeight() const | CXTPPropertyGridPaintManager | virtual
GetItemTextColor(CXTPPropertyGridItem *pItem, BOOL bValuePart) | CXTPPropertyGridPaintManager | virtual
GetScrollBarTheme() const | CXTPPropertyGridVisualStudio2012Theme | virtual
GetSplitterRect(CRect rc, BOOL bIsHelp) | CXTPPropertyGridPaintManager |
HitTestVerbs(CDC *pDC, CRect rcVerbs, CPoint pt) | CXTPPropertyGridPaintManager |
m_bThinSplitter | CXTPPropertyGridPaintManager | protected
m_bTransparent | CXTPPropertyGridPaintManager |
m_buttonsStyle | CXTPPropertyGridPaintManager |
m_clrCategorySeparator | CXTPPropertyGridPaintManager |
m_clrFace | CXTPPropertyGridPaintManager |
m_clrHighlight | CXTPPropertyGridPaintManager |
m_clrHighlightText | CXTPPropertyGridPaintManager |
m_clrNonHighlightBack | CXTPPropertyGridPaintManager |
m_clrNonHighlightText | CXTPPropertyGridPaintManager |
m_clrShadow | CXTPPropertyGridPaintManager |
m_clrSplitter | CXTPPropertyGridPaintManager |
m_nHelpHeight | CXTPPropertyGridPaintManager | protected
m_nItemsBorderHeight | CXTPPropertyGridPaintManager | protected
m_nSplitterHeight | CXTPPropertyGridPaintManager | protected
m_nVerbsHeight | CXTPPropertyGridPaintManager | protected
m_pGrid | CXTPPropertyGridPaintManager | protected
m_pMetrics | CXTPPropertyGridPaintManager | protected
m_themeButton | CXTPPropertyGridPaintManager |
m_themeCombo | CXTPPropertyGridPaintManager |
m_themeTree | CXTPPropertyGridPaintManager |
MeasureItem(LPMEASUREITEMSTRUCT lpMeasureItemStruct) | CXTPPropertyGridPaintManager | virtual
OnNcCalcSize(RECT &rc) | CXTPPropertyGridPaintManager | virtual
RefreshMetrics() | CXTPPropertyGridVisualStudio2012Theme | virtual
SetItemsBorderHeight(int nHeight) | CXTPPropertyGridPaintManager | virtual
SetThinSplitter(BOOL bThinSplitter) | CXTPPropertyGridPaintManager | virtual
~CXTPPropertyGridPaintManager() | CXTPPropertyGridPaintManager | virtual


Toolkit Pro: Member List

CXTPMouseManager Member List

This is the complete list of members for CXTPMouseManager, including all inherited members.

AddTrustedWindow(HWND hWnd) | CXTPMouseManager |
CXTPMouseManager() | CXTPMouseManager |
HitTest(POINT point) const | CXTPMouseManager |
IgnoreLButtonUp() | CXTPMouseManager |
IsForceExpanded() const | CXTPMouseManager |
IsMouseLocked() const | CXTPMouseManager |
IsTopParentActive(HWND hWnd) | CXTPMouseManager | static
IsTrackedLock(const CXTPCommandBar *pItem=NULL) | CXTPMouseManager |
LockMouseMove() | CXTPMouseManager |
RefreshCursor() | CXTPMouseManager | static
RemoveSelected(CXTPCommandBar *pSelected) | CXTPMouseManager |
RemoveTrack(CXTPCommandBar *pTrack) | CXTPMouseManager |
RemoveTrustedWindow(HWND hWnd) | CXTPMouseManager |
SendTrackLost() | CXTPMouseManager |
SetForceExpanded(BOOL bForceExpanded) | CXTPMouseManager |
SetSelected(CXTPCommandBar *pSelected) | CXTPMouseManager |
SetTrack(CXTPCommandBar *pTrack, BOOL bCaptureMouse=TRUE) | CXTPMouseManager |
TrackMouseLeave(HWND hwnd) | CXTPMouseManager |
UnlockMouseMove() | CXTPMouseManager |
~CXTPMouseManager() | CXTPMouseManager |


Toolkit Pro: XTPSkinManagerApiHookBase.h Source File

  • Source
  • SkinFramework
  • ApiHook
XTPSkinManagerApiHookBase.h
Go to the documentation of this file.
1
23#if !defined(__XTPSKINMANAGERAPIHOOKBASE_H__)
24# define __XTPSKINMANAGERAPIHOOKBASE_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPWinThemeWrapper;
34
37# define XTP_LDR_IS_DATAFILE(handle) (((ULONG_PTR)(handle)) & (ULONG_PTR)1)
38# define XTP_LDR_IS_IMAGEMAPPING(handle) (((ULONG_PTR)(handle)) & (ULONG_PTR)2)
39# define XTP_LDR_IS_RESOURCE(handle) \
40 (XTP_LDR_IS_IMAGEMAPPING(handle) || XTP_LDR_IS_DATAFILE(handle))
41
43// CXTPSkinManagerApiHookBase
44
45class _XTP_EXT_CLASS CXTPSkinManagerApiHookBase
46 : public CObject
47 , public CXTPSynchronized
48{
49 DECLARE_DYNAMIC(CXTPSkinManagerApiHookBase);
50
51public:
52 virtual ~CXTPSkinManagerApiHookBase();
53
54 virtual void InitializeHookManagement() = 0;
55 virtual void FinalizeHookManagement() = 0;
56 virtual void ExcludeModule(LPCTSTR lpszModule, BOOL bWin9x) = 0;
57 virtual LPVOID GetOriginalFunctionAddress(int nFunction) const = 0;
58 virtual BOOL AdjustWindowRectExOrig(LPRECT lpRect, DWORD dwStyle, BOOL bMenu,
59 DWORD dwExStyle) = 0;
60 virtual LRESULT CallWindowProcOrig(WNDPROC lpPrevWndFunc, HWND hWnd, UINT Msg, WPARAM wParam,
61 LPARAM lParam) = 0;
62 virtual LPVOID GetOpenThemeDataOriginalPtr() const = 0;
63 virtual LPVOID GetCloseThemeDataOriginalPtr() const = 0;
64 virtual void ConnectWrapper(CXTPWinThemeWrapper* pThemeWrapper) = 0;
65
66 static BOOL AFX_CDECL IsSystemWindowModule(WNDPROC lpWndProc);
67
68 BOOL IsLegacyImplementation() const;
69
70 static PVOID GetAfxWndProc();
71
72protected:
73 explicit CXTPSkinManagerApiHookBase(BOOL bLegacy);
74
75 static BOOL AFX_CDECL IsHookedByAppHelpDll(LPVOID lpProc);
76
77 BOOL CallHookDefWindowProc(HWND hWnd, LPVOID pfnOrig, XTPSkinDefaultProc defProc, LPVOID lpPrev,
78 UINT nMessage, WPARAM& wParam, LPARAM& lParam, LRESULT& lResult);
79
80private:
81 BOOL m_bLegacy;
82
83 static PVOID sm_pfnAfxWndProc;
84};
85
86AFX_INLINE BOOL CXTPSkinManagerApiHookBase::IsLegacyImplementation() const
87{
88 return m_bLegacy;
89}
90
91AFX_INLINE PVOID CXTPSkinManagerApiHookBase::GetAfxWndProc()
92{
93 return sm_pfnAfxWndProc;
94}
95
98# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
100#endif // !defined(__XTPSKINMANAGERAPIHOOKBASE_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPSynchronized
A base class for a synchronized object.
Definition XTPSynchro.h:602
CXTPWinThemeWrapper
The CXTPWinThemeWrapper class wraps the UxTheme.dll visual theme API.
Definition XTPWinThemeWrapper.h:188


Toolkit Pro: XTPCalendarViewEvent.h Source File

  • Source
  • Calendar
XTPCalendarViewEvent.h
Go to the documentation of this file.
1
22#if !defined(_XTP_CALENDARViewEvent_H__)
23# define _XTP_CALENDARViewEvent_H__
24
25# if _MSC_VER > 1000
26# pragma once
27# endif // _MSC_VER > 1000
28
29# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
30
31class CXTPCalendarEvent;
32class CXTPCalendarControl;
33class CXTPCalendarViewGroup;
34struct XTP_CALENDAR_HITTESTINFO;
35class CXTPCalendarViewEventSubjectEditor;
36class CXTPMarkupUIElement;
37
42enum XTPCalendarEventCaptionFormat
43{
44 xtpCalendarCaptionFormatUnknown = 0,
45 xtpCalendarCaptionFormatSubject = 1,
46 xtpCalendarCaptionFormatStartSubject = 2,
47 xtpCalendarCaptionFormatStartEndSubject = 3
48};
49
54enum XTPCalendarMultiDayEventFlags
55{
56 xtpCalendarMultiDayUnknown = 0,
58 xtpCalendarMultiDayNoMultiDay = 0x01,
60 xtpCalendarMultiDayFirst = 0x02,
62 xtpCalendarMultiDayMiddle = 0x04,
64 xtpCalendarMultiDayLast = 0x08,
67 xtpCalendarMultiDayFMLmask = xtpCalendarMultiDayFirst | xtpCalendarMultiDayMiddle
68 | xtpCalendarMultiDayLast,
70 xtpCalendarMultiDayMaster = 0x10,
72 xtpCalendarMultiDaySlave = 0x20,
73 xtpCalendarMultiDayMSmask = xtpCalendarMultiDayMaster
74 | xtpCalendarMultiDaySlave
75};
76
105class _XTP_EXT_CLASS CXTPCalendarViewEvent : public CXTPCalendarWMHandler
106{
107 friend class CXTPCalendarView;
108 friend class CXTPCalendarViewDay;
109 friend class CXTPCalendarViewGroup;
110
111 DECLARE_DYNAMIC(CXTPCalendarViewEvent)
112 typedef CXTPCalendarWMHandler TBase;
113
114public:
124 CXTPCalendarViewEvent(CXTPCalendarEvent* pEvent, CXTPCalendarViewGroup* pViewGroup);
125
130 virtual ~CXTPCalendarViewEvent();
131
145 virtual BOOL HitTest(CPoint pt, XTP_CALENDAR_HITTESTINFO* pHitTest) const;
146
154 virtual CXTPCalendarViewGroup* GetViewGroup_() const = 0;
155
163 virtual CXTPCalendarEvent* GetEvent() const;
164
172 virtual CXTPCalendarControl* GetCalendarControl() const;
173
174 CXTPCalendarView* GetView() const;
175
187 virtual BOOL IsVisible() const = 0;
188
198 virtual BOOL IsSelected() const;
199
210 virtual void SetSelected(BOOL bSet = TRUE);
211
219 virtual BOOL IsMultidayEvent() const;
220
233 virtual CXTPCalendarViewEvent* StartEditSubject();
234
241 virtual CString GetEditingSubjectFromEditor() const;
242
250 virtual CString EndEditSubject();
251
256 virtual void ShowToolTip();
257
262 virtual void HideToolTip();
263
271 virtual BOOL IsEditingSubject() const;
272
280 virtual CRect GetSubjectEditorRect() const;
281
289 virtual CWnd* GetSubjectEditor() const;
290
298 virtual BOOL IsShowingToolTip();
299
310 virtual CString FormatEventTime(COleDateTime dtTime) const;
311
319 virtual CRect GetFirstClockRect() const;
320
328 virtual CRect GetLastClockRect() const;
329
337 virtual CRect GetTextRect() const;
338
347 virtual CRect GetStartTimeRect() const;
348
356 virtual CRect GetEndTimeRect() const;
357
365 virtual CRect GetViewEventRect() const;
366
374 virtual CRect GetViewEventRectMax() const;
375
383 virtual CRect GetReminderGlyphRect() const;
384
392 virtual CRect GetRecurrenceGlyphRect() const;
393
401 virtual CRect GetMeetingGlyphRect() const;
402
410 virtual CRect GetPrivateGlyphRect() const;
422 virtual BOOL IsMultyDayTextAlign() const;
423
432 virtual int GetMultiDayEventFlags() const;
433
461 virtual void SetMultiDayEvent_MasterSlave(BOOL bMaster, CXTPCalendarViewEvent* pMasterView);
462
477 virtual void AddMultiDayEvent_Slave(CXTPCalendarViewEvent* pSlaveView, int nMasterEventPlace);
478
487 virtual void SetTextOutOfBorders(BOOL bOutOfBorders);
488
496 virtual BOOL IsTextOutOfBorders() const;
497
505 virtual int GetEventPlaceNumber() const;
506
514 virtual int GetEventTimelinePlaceNumber() const;
515
527 CRect GetEventRect() const;
528
543 virtual void AdjustLayout(CDC* pDC, const CRect& rcEventMax, int nEventPlaceNumber);
544
556 virtual void AdjustLayout2(CDC* pDC, const CRect& rcEventMax, int nEventPlaceNumber) = 0;
557
567 virtual void OnPostAdjustLayout();
568
584 virtual void Draw(CDC* pDC) = 0;
585
595 virtual void AdjustSubjectEditor();
596
606 virtual CString GetItemTextSubject() const;
607
617 virtual CString GetItemTextLocation() const;
618
628 virtual CString GetItemTextBody() const;
629
639 virtual CString GetItemTextStartTime() const;
640
650 virtual CString GetItemTextEndTime() const;
651
666 virtual CString GetItemText(DWORD dwItemFlag, LPCTSTR pcszDefaultText = NULL) const;
667
683 virtual CString GetMarkupText() const;
684
691 virtual CXTPMarkupUIElement* GetMarkupUIElement();
692
707 virtual BOOL HitTestEx(CPoint pt, XTP_CALENDAR_HITTESTINFO* pHitTest) const = 0;
708
709public:
724 virtual int CalcIconsRect(CRect rc);
725
726protected:
742 virtual void AdjustMultidayEvent(CRect rcEventMax, int nEventPlaceNumber);
743
751 virtual CString GetToolText();
752
753private:
766 BOOL MarkupHandleMouseEvent(UINT nMessage, UINT nFlags, const CPoint& point);
767
768public:
784 virtual BOOL OnLButtonDown(UINT nFlags, CPoint point);
785
801 virtual BOOL OnLButtonUp(UINT nFlags, CPoint point);
802
818 virtual BOOL OnLButtonDblClk(UINT nFlags, CPoint point);
819
833 virtual void OnMouseMove(UINT nFlags, CPoint point);
834
846 virtual BOOL OnWndMsg(UINT message, WPARAM wParam, LPARAM lParam, LRESULT* pResult);
847
857 virtual UINT SetTimer(UINT uTimeOut_ms);
858
868 virtual void KillTimer(UINT uTimerID);
869
879 virtual BOOL OnTimer(UINT_PTR uTimerID);
880
888 virtual UINT GetShowToolTipTimeOut() const;
889
897 virtual DWORD GetSubjectEditorStyles() const; // like multi-line
898
906 virtual CFont* GetSubjectEditorFont() const;
907
914 virtual void ChangeEventPlace(int nNewPlace);
915
916 virtual void _ChangeEventPlace(int nNewPlace, int nYbasePrev, int nYbaseNew);
917
927 static void AFX_CDECL _MoveRectY(int nYbasePrev, int nYbaseNew, CRect& rRC);
928
933 virtual void OnBeforeDestroy();
934
935public:
936 CRect m_rcEvent;
937 CRect m_rcEventMax;
939 CRect m_rcText;
940 CSize m_szText;
942 CRect m_rcFirstClock;
944 CRect m_rcLastClock;
946 CRect m_rcStartTime;
947 CRect m_rcEndTime;
949 int m_nMultiDayEventFlags;
951 CRect m_rcReminderGlyph;
952 CRect m_rcRecurrenceGlyph;
953 CRect m_rcMeetingGlyph;
954 CRect m_rcPrivateGlyph;
956 CRect m_rcSubjectEditor;
957 CRect m_rcToolTip;
959 CXTPMarkupUIElement* m_pUIElement;
960 CString m_strUIElementText;
963protected:
964 CXTPCalendarEvent* m_ptrEvent;
965 BOOL m_bSelected;
966 CXTPCalendarViewEvent* m_pMasterView;
967 int m_nEventPlaceNumber;
968 int m_nEventTimelinePlaceNumber;
970 UINT m_nTimerID_ShowToolTip;
972 CXTPCalendarViewEventSubjectEditor* m_pSubjectEditor;
974 BOOL m_bMultyDayTextAlign;
976 BOOL m_bTextOutOfBorders;
977private:
978 BOOL m_bShowingToolTip;
980# ifdef _XTP_ACTIVEX
981
982 DECLARE_DISPATCH_MAP()
983 DECLARE_INTERFACE_MAP()
984
985 DECLARE_OLETYPELIB_EX(CXTPCalendarViewEvent);
986
987 LPDISPATCH OleGetEvent();
988 BOOL OleGetSelected();
989 void OleSetSelected(BOOL bSelected);
990 LPDISPATCH OleGetViewDay();
991 LPDISPATCH OleGetViewGroup();
992
993# endif
994};
995
1002class _XTP_EXT_CLASS CXTPCalendarViewEvents
1003 : public CXTPCalendarPtrCollectionT<CXTPCalendarViewEvent>
1004{
1005public:
1006 typedef CXTPCalendarPtrCollectionT<CXTPCalendarViewEvent> TBase;
1007
1012 CXTPCalendarViewEvents();
1013
1018 virtual ~CXTPCalendarViewEvents();
1019
1031 virtual int Find(const CXTPCalendarEvent* pEvent) const;
1032
1033 using CXTPCalendarPtrCollectionT<CXTPCalendarViewEvent>::Find;
1034
1042 virtual void Remove(CXTPCalendarEvent* pEvent);
1043
1044 using CXTPCalendarPtrCollectionT<CXTPCalendarViewEvent>::Remove;
1045
1046# ifdef _XTP_ACTIVEX
1047
1048 DECLARE_DISPATCH_MAP()
1049 DECLARE_INTERFACE_MAP()
1050
1051 DECLARE_OLETYPELIB_EX(CXTPCalendarViewEvents);
1052 DECLARE_ENUM_VARIANT(CXTPCalendarViewEvents)
1053
1054# endif
1055};
1056
1075template<class _TViewGroup>
1076class CXTPCalendarViewEventT : public CXTPCalendarViewEvent
1077{
1078public:
1088 CXTPCalendarViewEventT(CXTPCalendarEvent* pEvent, _TViewGroup* pViewGroup)
1089 : CXTPCalendarViewEvent(pEvent, (CXTPCalendarViewGroup*)pViewGroup)
1090 {
1091 m_pViewGroup = pViewGroup;
1092 }
1093
1098 virtual ~CXTPCalendarViewEventT(){};
1099
1113 virtual CXTPCalendarViewGroup* GetViewGroup_() const
1114 {
1115 _ASSERTE(this);
1116 return this ? (CXTPCalendarViewGroup*)m_pViewGroup : NULL;
1117 }
1118
1133 _TViewGroup* GetViewGroup() const
1134 {
1135 _ASSERTE(this);
1136 return this ? m_pViewGroup : NULL;
1137 }
1138
1139private:
1140 _TViewGroup* m_pViewGroup;
1141};
1142
1144
1156class _XTP_EXT_CLASS CXTPCalendarViewEventSubjectEditor : public CEdit
1157{
1158public:
1167 CXTPCalendarViewEventSubjectEditor(CXTPCalendarControl* pOwner);
1168
1173 virtual ~CXTPCalendarViewEventSubjectEditor();
1174
1175protected:
1176 CXTPCalendarControl* m_pOwner;
1178 DECLARE_MESSAGE_MAP()
1179
1180 afx_msg virtual UINT OnGetDlgCode();
1181 virtual BOOL OnWndMsg(UINT message, WPARAM wParam, LPARAM lParam, LRESULT* pResult);
1182};
1183
1195class _XTP_EXT_CLASS CXTPCalendarViewEventSubjectEditorColored
1196 : public CXTPCalendarViewEventSubjectEditor
1197{
1198public:
1209 CXTPCalendarViewEventSubjectEditorColored(CXTPCalendarControl* pOwner,
1210 CXTPCalendarViewEvent* pViewEvent,
1211 COLORREF clrBackground);
1212
1217 virtual ~CXTPCalendarViewEventSubjectEditorColored();
1218
1219protected:
1220 CXTPCalendarViewEvent* m_pViewEvent;
1221 CXTPPaintManagerColorGradient m_grclrBk;
1224 DECLARE_MESSAGE_MAP()
1225
1226 afx_msg virtual BOOL OnEraseBkgnd(CDC* pDC);
1227 afx_msg virtual HBRUSH CtlColor(CDC* pDC, UINT nCtlColor);
1228 afx_msg virtual void OnChange();
1229};
1230
1232AFX_INLINE void CXTPCalendarViewEvent::SetTextOutOfBorders(BOOL bOutOfBorders)
1233{
1234 m_bTextOutOfBorders = bOutOfBorders;
1235}
1236AFX_INLINE BOOL CXTPCalendarViewEvent::IsTextOutOfBorders() const
1237{
1238 return m_bTextOutOfBorders;
1239}
1240
1241AFX_INLINE CXTPCalendarEvent* CXTPCalendarViewEvent::GetEvent() const
1242{
1243 return m_ptrEvent;
1244}
1245AFX_INLINE int CXTPCalendarViewEvent::GetMultiDayEventFlags() const
1246{
1247 return m_nMultiDayEventFlags;
1248}
1249AFX_INLINE int CXTPCalendarViewEvent::GetEventPlaceNumber() const
1250{
1251 return m_nEventPlaceNumber;
1252}
1253AFX_INLINE int CXTPCalendarViewEvent::GetEventTimelinePlaceNumber() const
1254{
1255 return m_nEventTimelinePlaceNumber;
1256}
1257AFX_INLINE BOOL CXTPCalendarViewEvent::IsEditingSubject() const
1258{
1259 return m_pSubjectEditor != NULL;
1260}
1261AFX_INLINE CRect CXTPCalendarViewEvent::GetSubjectEditorRect() const
1262{
1263 return m_rcSubjectEditor;
1264}
1265AFX_INLINE CWnd* CXTPCalendarViewEvent::GetSubjectEditor() const
1266{
1267 return m_pSubjectEditor;
1268}
1269AFX_INLINE UINT CXTPCalendarViewEvent::GetShowToolTipTimeOut() const
1270{
1271 return XTP_CALENDAR_SHOW_TOOLTIP_TIMEOUT_MS;
1272}
1273AFX_INLINE DWORD CXTPCalendarViewEvent::GetSubjectEditorStyles() const
1274{
1275 return ES_NOHIDESEL | ES_MULTILINE;
1276}
1277AFX_INLINE CFont* CXTPCalendarViewEvent::GetSubjectEditorFont() const
1278{
1279 return NULL;
1280}
1281AFX_INLINE CRect CXTPCalendarViewEvent::GetFirstClockRect() const
1282{
1283 return m_rcFirstClock;
1284}
1285AFX_INLINE CRect CXTPCalendarViewEvent::GetLastClockRect() const
1286{
1287 return m_rcLastClock;
1288}
1289AFX_INLINE CRect CXTPCalendarViewEvent::GetTextRect() const
1290{
1291 return m_rcText;
1292}
1293AFX_INLINE CRect CXTPCalendarViewEvent::GetStartTimeRect() const
1294{
1295 return m_rcStartTime;
1296}
1297AFX_INLINE CRect CXTPCalendarViewEvent::GetEndTimeRect() const
1298{
1299 return m_rcEndTime;
1300}
1301AFX_INLINE CRect CXTPCalendarViewEvent::GetViewEventRect() const
1302{
1303 return m_rcEvent;
1304}
1305AFX_INLINE CRect CXTPCalendarViewEvent::GetViewEventRectMax() const
1306{
1307 return m_rcEventMax;
1308}
1309AFX_INLINE CRect CXTPCalendarViewEvent::GetReminderGlyphRect() const
1310{
1311 return m_rcReminderGlyph;
1312}
1313AFX_INLINE CRect CXTPCalendarViewEvent::GetRecurrenceGlyphRect() const
1314{
1315 return m_rcRecurrenceGlyph;
1316}
1317AFX_INLINE CRect CXTPCalendarViewEvent::GetMeetingGlyphRect() const
1318{
1319 return m_rcMeetingGlyph;
1320}
1321AFX_INLINE CRect CXTPCalendarViewEvent::GetPrivateGlyphRect() const
1322{
1323 return m_rcPrivateGlyph;
1324}
1325AFX_INLINE BOOL CXTPCalendarViewEvent::IsMultyDayTextAlign() const
1326{
1327 return m_bMultyDayTextAlign;
1328}
1329AFX_INLINE CRect CXTPCalendarViewEvent::GetEventRect() const
1330{
1331 return m_rcEvent;
1332}
1333
1335
1336# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
1337#endif // !defined(_XTP_CALENDARViewEvent_H__)
XTP_CALENDAR_SHOW_TOOLTIP_TIMEOUT_MS
#define XTP_CALENDAR_SHOW_TOOLTIP_TIMEOUT_MS
Timeout before appearing event tool tip window.
Definition XTPCalendarDefines.h:147
XTPCalendarMultiDayEventFlags
XTPCalendarMultiDayEventFlags
Enumerates defined flags for multi day event states.
Definition XTPCalendarViewEvent.h:55
xtpCalendarMultiDayNoMultiDay
@ xtpCalendarMultiDayNoMultiDay
Not a multi day event.
Definition XTPCalendarViewEvent.h:58
xtpCalendarMultiDaySlave
@ xtpCalendarMultiDaySlave
Rest of the event views (besides Master).
Definition XTPCalendarViewEvent.h:72
xtpCalendarMultiDayMSmask
@ xtpCalendarMultiDayMSmask
Combines flag.
Definition XTPCalendarViewEvent.h:73
xtpCalendarMultiDayMaster
@ xtpCalendarMultiDayMaster
First portion of a multi day event.
Definition XTPCalendarViewEvent.h:70
xtpCalendarMultiDayFMLmask
@ xtpCalendarMultiDayFMLmask
Combined flag.
Definition XTPCalendarViewEvent.h:67
xtpCalendarMultiDayLast
@ xtpCalendarMultiDayLast
Last portion of a multi day event.
Definition XTPCalendarViewEvent.h:64
xtpCalendarMultiDayMiddle
@ xtpCalendarMultiDayMiddle
Middle portion of a multi day event.
Definition XTPCalendarViewEvent.h:62
xtpCalendarMultiDayFirst
@ xtpCalendarMultiDayFirst
First portion of a multi day event.
Definition XTPCalendarViewEvent.h:60
xtpCalendarMultiDayUnknown
@ xtpCalendarMultiDayUnknown
Undefined multi day event.
Definition XTPCalendarViewEvent.h:56
XTPCalendarEventCaptionFormat
XTPCalendarEventCaptionFormat
Enumerates allowable formats for event caption.
Definition XTPCalendarViewEvent.h:43
xtpCalendarCaptionFormatSubject
@ xtpCalendarCaptionFormatSubject
Caption displays subject.
Definition XTPCalendarViewEvent.h:45
xtpCalendarCaptionFormatStartSubject
@ xtpCalendarCaptionFormatStartSubject
Besides subject displays start time.
Definition XTPCalendarViewEvent.h:46
xtpCalendarCaptionFormatStartEndSubject
@ xtpCalendarCaptionFormatStartEndSubject
Besides subject displays start and end time.
Definition XTPCalendarViewEvent.h:47
xtpCalendarCaptionFormatUnknown
@ xtpCalendarCaptionFormatUnknown
Undefined format.
Definition XTPCalendarViewEvent.h:44
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCalendarControl
Class CXTPCalendarControl implements the calendar's view interface.
Definition XTPCalendarControl.h:126
CXTPCalendarEvent
This class represents the data of a single Event used in the Calendar control.
Definition XTPCalendarEvent.h:77
CXTPCalendarPtrCollectionT
This class represents a simple array collection of objects.
Definition XTPCalendarPtrCollectionT.h:48
CXTPCalendarViewDay
This class represents the day view portion of the CalendarView.
Definition XTPCalendarViewDay.h:555
CXTPCalendarViewEvent
This class represents an event view portion of the CalendarViewGroup.
Definition XTPCalendarViewEvent.h:106
CXTPCalendarViewEvent::OnLButtonDown
virtual BOOL OnLButtonDown(UINT nFlags, CPoint point)
This member function is used to process left mouse button down events.
CXTPCalendarViewEvent::m_nMultiDayEventFlags
int m_nMultiDayEventFlags
Multi-day event flags packed into integer by bitwise operations.
Definition XTPCalendarViewEvent.h:949
CXTPCalendarViewEvent::AdjustMultidayEvent
virtual void AdjustMultidayEvent(CRect rcEventMax, int nEventPlaceNumber)
This member function is used to adjust a multi-day view's layout depending on the provided rectangle ...
CXTPCalendarViewEvent::GetCalendarControl
virtual CXTPCalendarControl * GetCalendarControl() const
Call this member function to obtain a pointer to the calendar control object.
CXTPCalendarViewEvent::GetViewEventRectMax
virtual CRect GetViewEventRectMax() const
This member function is used to obtain the rectangle coordinates for the event's maximum rectangle di...
Definition XTPCalendarViewEvent.h:1305
CXTPCalendarViewEvent::_MoveRectY
static void AFX_CDECL _MoveRectY(int nYbasePrev, int nYbaseNew, CRect &rRC)
This member function is used to move the rectangle vertically.
CXTPCalendarViewEvent::m_rcFirstClock
CRect m_rcFirstClock
Rectangle to draw clock in the beginning of the first day of multi-day event.
Definition XTPCalendarViewEvent.h:942
CXTPCalendarViewEvent::GetEventPlaceNumber
virtual int GetEventPlaceNumber() const
This member function is used to obtain the place number of the event view.
Definition XTPCalendarViewEvent.h:1249
CXTPCalendarViewEvent::m_rcEventMax
CRect m_rcEventMax
Event view rectangle margins.
Definition XTPCalendarViewEvent.h:937
CXTPCalendarViewEvent::GetTextRect
virtual CRect GetTextRect() const
This member function is used to obtain the rectangle coordinates used for displaying the event's subj...
Definition XTPCalendarViewEvent.h:1289
CXTPCalendarViewEvent::GetItemTextStartTime
virtual CString GetItemTextStartTime() const
Call this function to get the item start time.
CXTPCalendarViewEvent::SetSelected
virtual void SetSelected(BOOL bSet=TRUE)
This member function is used to set the day view as select or unselected.
CXTPCalendarViewEvent::HideToolTip
virtual void HideToolTip()
This member function is used to hide the ToolTip rectangle.
CXTPCalendarViewEvent::m_rcEvent
CRect m_rcEvent
Event view rectangle.
Definition XTPCalendarViewEvent.h:936
CXTPCalendarViewEvent::m_rcText
CRect m_rcText
Rectangle to display event text in event view.
Definition XTPCalendarViewEvent.h:939
CXTPCalendarViewEvent::GetToolText
virtual CString GetToolText()
This member function is used to obtain tooltip text for the event view.
CXTPCalendarViewEvent::GetItemTextBody
virtual CString GetItemTextBody() const
Call this function to get the item body.
CXTPCalendarViewEvent::GetSubjectEditor
virtual CWnd * GetSubjectEditor() const
This member function is used to obtain the event's subject editor window.
Definition XTPCalendarViewEvent.h:1265
CXTPCalendarViewEvent::CalcIconsRect
virtual int CalcIconsRect(CRect rc)
This member function is used to adjust the icons rectangle used to draw the event view icons.
CXTPCalendarViewEvent::ShowToolTip
virtual void ShowToolTip()
This member function is used to show a ToolTip rectangle.
CXTPCalendarViewEvent::GetItemTextLocation
virtual CString GetItemTextLocation() const
Call this function to get the item location.
CXTPCalendarViewEvent::m_rcStartTime
CRect m_rcStartTime
Rectangle to display start time day event view.
Definition XTPCalendarViewEvent.h:946
CXTPCalendarViewEvent::FormatEventTime
virtual CString FormatEventTime(COleDateTime dtTime) const
This member function is used to format the event's time as a string with a predefined format.
CXTPCalendarViewEvent::OnPostAdjustLayout
virtual void OnPostAdjustLayout()
This member function is used to perform additional adjustments in some kinds of views.
CXTPCalendarViewEvent::m_rcPrivateGlyph
CRect m_rcPrivateGlyph
Rectangle to draw private glyph event view.
Definition XTPCalendarViewEvent.h:954
CXTPCalendarViewEvent::m_bSelected
BOOL m_bSelected
Event view selected flag.
Definition XTPCalendarViewEvent.h:965
CXTPCalendarViewEvent::m_bMultyDayTextAlign
BOOL m_bMultyDayTextAlign
Flag indicates special text alignment for a multi-day event.
Definition XTPCalendarViewEvent.h:974
CXTPCalendarViewEvent::m_pSubjectEditor
CXTPCalendarViewEventSubjectEditor * m_pSubjectEditor
Pointer to the subject editor.
Definition XTPCalendarViewEvent.h:972
CXTPCalendarViewEvent::HitTest
virtual BOOL HitTest(CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const
This member function is used to determine which view item, if any, is at the specified position index...
CXTPCalendarViewEvent::OnLButtonUp
virtual BOOL OnLButtonUp(UINT nFlags, CPoint point)
This member function is used to process left mouse button up events.
CXTPCalendarViewEvent::IsSelected
virtual BOOL IsSelected() const
Call this member function to determine if the given event view is selected.
CXTPCalendarViewEvent::m_pMasterView
CXTPCalendarViewEvent * m_pMasterView
Pointer to Master event view object.
Definition XTPCalendarViewEvent.h:966
CXTPCalendarViewEvent::AddMultiDayEvent_Slave
virtual void AddMultiDayEvent_Slave(CXTPCalendarViewEvent *pSlaveView, int nMasterEventPlace)
This member function is used to add a Slave event view to the Master event view.
CXTPCalendarViewEvent::KillTimer
virtual void KillTimer(UINT uTimerID)
This member function is used to destroy a timer event.
CXTPCalendarViewEvent::GetMeetingGlyphRect
virtual CRect GetMeetingGlyphRect() const
This member function obtains the rectangle coordinates for displaying the meeting icon.
Definition XTPCalendarViewEvent.h:1317
CXTPCalendarViewEvent::AdjustLayout2
virtual void AdjustLayout2(CDC *pDC, const CRect &rcEventMax, int nEventPlaceNumber)=0
This member function is used to adjust the view's layout when theme is set depending on the provided ...
CXTPCalendarViewEvent::m_rcMeetingGlyph
CRect m_rcMeetingGlyph
Rectangle to draw meeting glyph event view.
Definition XTPCalendarViewEvent.h:953
CXTPCalendarViewEvent::GetEditingSubjectFromEditor
virtual CString GetEditingSubjectFromEditor() const
Call this member function to obtain an edited subject.
CXTPCalendarViewEvent::m_strUIElementText
CString m_strUIElementText
Store last markup text for which m_pUIElement object was updated.
Definition XTPCalendarViewEvent.h:960
CXTPCalendarViewEvent::GetViewGroup_
virtual CXTPCalendarViewGroup * GetViewGroup_() const =0
Call this member function to obtain a pointer to the containing CXTPCalendarViewDay object.
CXTPCalendarViewEvent::AdjustSubjectEditor
virtual void AdjustSubjectEditor()
This member function is used to perform adjustments of the subject editor area.
CXTPCalendarViewEvent::OnWndMsg
virtual BOOL OnWndMsg(UINT message, WPARAM wParam, LPARAM lParam, LRESULT *pResult)
This method is called by framework after default message processing.
CXTPCalendarViewEvent::GetEventTimelinePlaceNumber
virtual int GetEventTimelinePlaceNumber() const
This member function is used to obtain the place number of the event in Timeline view.
Definition XTPCalendarViewEvent.h:1253
CXTPCalendarViewEvent::GetMarkupText
virtual CString GetMarkupText() const
This member function is used to obtain markup template text.
CXTPCalendarViewEvent::StartEditSubject
virtual CXTPCalendarViewEvent * StartEditSubject()
This member function is used to create and to show the subject editor.
CXTPCalendarViewEvent::IsTextOutOfBorders
virtual BOOL IsTextOutOfBorders() const
This member function is used to determine if the text size exceeds the event view bounds.
Definition XTPCalendarViewEvent.h:1236
CXTPCalendarViewEvent::~CXTPCalendarViewEvent
virtual ~CXTPCalendarViewEvent()
Default class destructor.
CXTPCalendarViewEvent::GetEvent
virtual CXTPCalendarEvent * GetEvent() const
Call this member function to obtain the corresponding read only event object without increasing the o...
Definition XTPCalendarViewEvent.h:1241
CXTPCalendarViewEvent::m_rcEndTime
CRect m_rcEndTime
Rectangle to display end time event view.
Definition XTPCalendarViewEvent.h:947
CXTPCalendarViewEvent::GetEventRect
CRect GetEventRect() const
This member function is used to obtain the event view's bounding rectangle.
Definition XTPCalendarViewEvent.h:1329
CXTPCalendarViewEvent::m_ptrEvent
CXTPCalendarEvent * m_ptrEvent
Pointer to the displayed event object.
Definition XTPCalendarViewEvent.h:964
CXTPCalendarViewEvent::GetStartTimeRect
virtual CRect GetStartTimeRect() const
This member function is used to obtain the rectangle coordinates used for displaying a clock to show ...
Definition XTPCalendarViewEvent.h:1293
CXTPCalendarViewEvent::IsVisible
virtual BOOL IsVisible() const =0
Call this member function to determine if this event view is visible on the screen.
CXTPCalendarViewEvent::m_rcReminderGlyph
CRect m_rcReminderGlyph
Rectangle to draw reminder glyph event view.
Definition XTPCalendarViewEvent.h:951
CXTPCalendarViewEvent::AdjustLayout
virtual void AdjustLayout(CDC *pDC, const CRect &rcEventMax, int nEventPlaceNumber)
This member function is used to adjust the view's layout depending on the provided rectangle and call...
CXTPCalendarViewEvent::GetLastClockRect
virtual CRect GetLastClockRect() const
This member function is used to obtain the rectangle coordinates used for drawing a clock in the end ...
Definition XTPCalendarViewEvent.h:1285
CXTPCalendarViewEvent::GetViewEventRect
virtual CRect GetViewEventRect() const
This member function is used to obtain the rectangle coordinates for the event's rectangle.
Definition XTPCalendarViewEvent.h:1301
CXTPCalendarViewEvent::GetPrivateGlyphRect
virtual CRect GetPrivateGlyphRect() const
This member function is used to obtain the rectangle coordinates used for displaying the private icon...
Definition XTPCalendarViewEvent.h:1321
CXTPCalendarViewEvent::SetMultiDayEvent_MasterSlave
virtual void SetMultiDayEvent_MasterSlave(BOOL bMaster, CXTPCalendarViewEvent *pMasterView)
This member function is used to set the multi-day event Master/Slave state.
CXTPCalendarViewEvent::m_pUIElement
CXTPMarkupUIElement * m_pUIElement
Store pointer to CXTPMarkupUIElement object.
Definition XTPCalendarViewEvent.h:959
CXTPCalendarViewEvent::GetRecurrenceGlyphRect
virtual CRect GetRecurrenceGlyphRect() const
This member function is used to obtain the rectangle coordinates used for displaying the recurrence i...
Definition XTPCalendarViewEvent.h:1313
CXTPCalendarViewEvent::GetMultiDayEventFlags
virtual int GetMultiDayEventFlags() const
This member function is used to obtain the multi-day event state flags.
Definition XTPCalendarViewEvent.h:1245
CXTPCalendarViewEvent::m_rcRecurrenceGlyph
CRect m_rcRecurrenceGlyph
Rectangle to draw recurrence glyph event view.
Definition XTPCalendarViewEvent.h:952
CXTPCalendarViewEvent::GetItemTextEndTime
virtual CString GetItemTextEndTime() const
Call this function to get the item end time.
CXTPCalendarViewEvent::GetItemText
virtual CString GetItemText(DWORD dwItemFlag, LPCTSTR pcszDefaultText=NULL) const
Call this function to get the item text.
CXTPCalendarViewEvent::CXTPCalendarViewEvent
CXTPCalendarViewEvent(CXTPCalendarEvent *pEvent, CXTPCalendarViewGroup *pViewGroup)
Default object constructor.
CXTPCalendarViewEvent::SetTimer
virtual UINT SetTimer(UINT uTimeOut_ms)
This member function is used to create a timer event.
CXTPCalendarViewEvent::IsEditingSubject
virtual BOOL IsEditingSubject() const
Call this member function to determine if the event's subject is currently being edited.
Definition XTPCalendarViewEvent.h:1257
CXTPCalendarViewEvent::GetSubjectEditorStyles
virtual DWORD GetSubjectEditorStyles() const
This member function is used to obtain the styles of the editor window.
Definition XTPCalendarViewEvent.h:1273
CXTPCalendarViewEvent::m_rcLastClock
CRect m_rcLastClock
Rectangle to draw clock at the end of the last day of multi-day event.
Definition XTPCalendarViewEvent.h:944
CXTPCalendarViewEvent::OnMouseMove
virtual void OnMouseMove(UINT nFlags, CPoint point)
This member function is used to process mouse movement events.
CXTPCalendarViewEvent::GetSubjectEditorRect
virtual CRect GetSubjectEditorRect() const
This member function is used to obtain the subject editor rectangle coordinates.
Definition XTPCalendarViewEvent.h:1261
CXTPCalendarViewEvent::m_nEventTimelinePlaceNumber
int m_nEventTimelinePlaceNumber
Event view place number in Timeline view.
Definition XTPCalendarViewEvent.h:968
CXTPCalendarViewEvent::Draw
virtual void Draw(CDC *pDC)=0
This member function is used to draw the view content using the specified device context.
CXTPCalendarViewEvent::m_rcToolTip
CRect m_rcToolTip
Tool tip rectangle.
Definition XTPCalendarViewEvent.h:957
CXTPCalendarViewEvent::OnBeforeDestroy
virtual void OnBeforeDestroy()
Called by the framework before the destroy() function is called.
CXTPCalendarViewEvent::GetEndTimeRect
virtual CRect GetEndTimeRect() const
This member function is used to obtain the rectangle coordinates for displaying a clock to show the e...
Definition XTPCalendarViewEvent.h:1297
CXTPCalendarViewEvent::GetShowToolTipTimeOut
virtual UINT GetShowToolTipTimeOut() const
This member function is used to obtain the timeout value for displaying a tooltip.
Definition XTPCalendarViewEvent.h:1269
CXTPCalendarViewEvent::m_szText
CSize m_szText
Sizes of displayed text.
Definition XTPCalendarViewEvent.h:940
CXTPCalendarViewEvent::OnTimer
virtual BOOL OnTimer(UINT_PTR uTimerID)
The framework calls this member function after each interval specified in the SetTimer member functio...
CXTPCalendarViewEvent::EndEditSubject
virtual CString EndEditSubject()
This member function is used to end the editing project, delete the subject editor,...
CXTPCalendarViewEvent::m_nEventPlaceNumber
int m_nEventPlaceNumber
Event view place number (sequential identifier).
Definition XTPCalendarViewEvent.h:967
CXTPCalendarViewEvent::HitTestEx
virtual BOOL HitTestEx(CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const =0
This member function is used to determine which view item, if any, is at a specified position index,...
CXTPCalendarViewEvent::m_nTimerID_ShowToolTip
UINT m_nTimerID_ShowToolTip
Identifier of timer event to show tooltip with delay.
Definition XTPCalendarViewEvent.h:970
CXTPCalendarViewEvent::GetFirstClockRect
virtual CRect GetFirstClockRect() const
This member function is used to obtain the rectangle coordinates used for drawing a clock in the begi...
Definition XTPCalendarViewEvent.h:1281
CXTPCalendarViewEvent::GetSubjectEditorFont
virtual CFont * GetSubjectEditorFont() const
This member function is used to obtain a pointer to the editor window font.
Definition XTPCalendarViewEvent.h:1277
CXTPCalendarViewEvent::IsMultyDayTextAlign
virtual BOOL IsMultyDayTextAlign() const
This member function is used to obtain the flag to determine if multi-day text align mode is on.
Definition XTPCalendarViewEvent.h:1325
CXTPCalendarViewEvent::GetReminderGlyphRect
virtual CRect GetReminderGlyphRect() const
This member function is used to obtain the rectangle coordinates for displaying the remainder icon.
Definition XTPCalendarViewEvent.h:1309
CXTPCalendarViewEvent::m_bTextOutOfBorders
BOOL m_bTextOutOfBorders
Flag indicates text out of event borders.
Definition XTPCalendarViewEvent.h:976
CXTPCalendarViewEvent::OnLButtonDblClk
virtual BOOL OnLButtonDblClk(UINT nFlags, CPoint point)
This member function is used to process left mouse button double click events.
CXTPCalendarViewEvent::ChangeEventPlace
virtual void ChangeEventPlace(int nNewPlace)
This function is used to change the event place number.
CXTPCalendarViewEvent::GetItemTextSubject
virtual CString GetItemTextSubject() const
Call this function to get the item subject.
CXTPCalendarViewEvent::GetMarkupUIElement
virtual CXTPMarkupUIElement * GetMarkupUIElement()
This member function is used to get a stored CXTPMarkupUIElement object.
CXTPCalendarViewEvent::IsMultidayEvent
virtual BOOL IsMultidayEvent() const
Call this member function to determine if the given event view is a multi-day event.
CXTPCalendarViewEvent::IsShowingToolTip
virtual BOOL IsShowingToolTip()
Call this member function to determine if the event's tooltip is visible.
CXTPCalendarViewEvent::m_rcSubjectEditor
CRect m_rcSubjectEditor
Subject editor rectangle.
Definition XTPCalendarViewEvent.h:956
CXTPCalendarViewEventSubjectEditorColored
This class is used to edit event subject in Office 2007 Theme.
Definition XTPCalendarViewEvent.h:1197
CXTPCalendarViewEventSubjectEditorColored::m_grclrBk
CXTPPaintManagerColorGradient m_grclrBk
Subject Editor background color (or gradient colors).
Definition XTPCalendarViewEvent.h:1221
CXTPCalendarViewEventSubjectEditorColored::m_pViewEvent
CXTPCalendarViewEvent * m_pViewEvent
Stored pointer to the editing event object.
Definition XTPCalendarViewEvent.h:1220
CXTPCalendarViewEventSubjectEditorColored::~CXTPCalendarViewEventSubjectEditorColored
virtual ~CXTPCalendarViewEventSubjectEditorColored()
Default class destructor.
CXTPCalendarViewEventSubjectEditorColored::CXTPCalendarViewEventSubjectEditorColored
CXTPCalendarViewEventSubjectEditorColored(CXTPCalendarControl *pOwner, CXTPCalendarViewEvent *pViewEvent, COLORREF clrBackground)
Default object constructor.
CXTPCalendarViewEventSubjectEditor
This class is used to edit an event subject.
Definition XTPCalendarViewEvent.h:1157
CXTPCalendarViewEventSubjectEditor::m_pOwner
CXTPCalendarControl * m_pOwner
Stored pointer to the owner calendar control object.
Definition XTPCalendarViewEvent.h:1176
CXTPCalendarViewEventSubjectEditor::~CXTPCalendarViewEventSubjectEditor
virtual ~CXTPCalendarViewEventSubjectEditor()
Default class destructor.
CXTPCalendarViewEventSubjectEditor::CXTPCalendarViewEventSubjectEditor
CXTPCalendarViewEventSubjectEditor(CXTPCalendarControl *pOwner)
Default object constructor.
CXTPCalendarViewEventT
This class is used to build the ViewEvent layer of the DayView and ViewEvent hierarchies.
Definition XTPCalendarViewEvent.h:1077
CXTPCalendarViewEventT::GetViewGroup_
virtual CXTPCalendarViewGroup * GetViewGroup_() const
This member function is used to obtain a base CXTPCalendarViewGroup* pointer to a corresponding DayVi...
Definition XTPCalendarViewEvent.h:1113
CXTPCalendarViewEventT::CXTPCalendarViewEventT
CXTPCalendarViewEventT(CXTPCalendarEvent *pEvent, _TViewGroup *pViewGroup)
Default object constructor.
Definition XTPCalendarViewEvent.h:1088
CXTPCalendarViewEventT::GetViewGroup
_TViewGroup * GetViewGroup() const
This member function is used to obtain a pointer to a DayView object.
Definition XTPCalendarViewEvent.h:1133
CXTPCalendarViewEventT::~CXTPCalendarViewEventT
virtual ~CXTPCalendarViewEventT()
Default class destructor.
Definition XTPCalendarViewEvent.h:1098
CXTPCalendarViewEvents
This class is used as a collection of Event View objects.
Definition XTPCalendarViewEvent.h:1004
CXTPCalendarViewEvents::Remove
virtual void Remove(CXTPCalendarEvent *pEvent)
This member function finds all event views for an event object and removes them from the array.
CXTPCalendarViewEvents::CXTPCalendarViewEvents
CXTPCalendarViewEvents()
Default class constructor.
CXTPCalendarViewEvents::Find
virtual int Find(const CXTPCalendarEvent *pEvent) const
This member function finds the first event view index in the collection using event object.
CXTPCalendarViewEvents::~CXTPCalendarViewEvents
virtual ~CXTPCalendarViewEvents()
Default class destructor.
CXTPCalendarViewGroup
Regular schema:
Definition XTPCalendarViewDay.h:54
CXTPCalendarView
This class represents the view portion of the Calendar control.
Definition XTPCalendarView.h:360
CXTPCalendarWMHandler
This class helps to handle Windows messages (WM_*) processing portion of the Calendar control views.
Definition XTPCalendarView.h:100
CXTPMarkupUIElement
Base class for XML Markup core level implementations.
Definition XTPMarkupUIElement.h:43
CXTPPaintManagerColorGradient
The CXTPPaintManagerColorGradient class is used to manage COLORREF values for determining light and d...
Definition XTPColorManager.h:301
XTP_CALENDAR_HITTESTINFO
Basic set of parameters transferred from calendar items to mouse handlers.
Definition XTPCalendarDefines.h:856


Toolkit Pro: Member List

CXTPChartStackedAreaSeriesStyle Member List

This is the complete list of members for CXTPChartStackedAreaSeriesStyle, including all inherited members.

ApplyTo(CXTPChartDeviceCommand *pCommand) | CXTPChartSeriesStyle | virtual
CorrectAxisSideMargins(CXTPChartAxis *pAxis, double nMinValue, double nMaxValue, double &nCorrection) | CXTPChartSeriesStyle | virtual
CreateDiagram() | CXTPChartDiagram2DSeriesStyle | virtual
CreateView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView) | CXTPChartStackedAreaSeriesStyle | protectedvirtual
CXTPChartAreaSeriesStyle() | CXTPChartAreaSeriesStyle |
CXTPChartDiagram2DSeriesStyle() | CXTPChartDiagram2DSeriesStyle |
CXTPChartElement() | CXTPChartElement |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartPointSeriesStyle() | CXTPChartPointSeriesStyle |
CXTPChartSeriesStyle() | CXTPChartSeriesStyle |
CXTPChartStackedAreaSeriesStyle() | CXTPChartStackedAreaSeriesStyle |
DoPropExchange(CXTPPropExchange *pPX) | CXTPChartAreaSeriesStyle | virtual
Enable3dEdgeSmoothing(BOOL bEnable=TRUE) | CXTPChartSeriesStyle | virtual
Get3dRotation() const | CXTPChartSeriesStyle | virtual
GetAppearance() const | CXTPChartElement |
GetColor() const | CXTPChartSeriesStyle | virtual
GetContent() const | CXTPChartElement |
GetErrorBar() const | CXTPChartSeriesStyle | virtual
GetFillAcrossXAxis() const | CXTPChartAreaSeriesStyle |
GetFillStyle() const | CXTPChartAreaSeriesStyle |
GetLabel() const | CXTPChartSeriesStyle | virtual
GetMarker() const | CXTPChartPointSeriesStyle |
GetOwner() const | CXTPChartElement |
GetSeriesPointValueIndex() const | CXTPChartSeriesStyle | virtual
GetStyleAppearance() const | CXTPChartSeriesStyle | virtual
GetTransparency() const | CXTPChartAreaSeriesStyle | virtual
Is3D() const | CXTPChartObject |
Is3dEdgeSmoothingEnabled() const | CXTPChartSeriesStyle | virtual
IsColorEach() const | CXTPChartSeriesStyle | virtual
IsStyleDiagram(CXTPChartDiagram *pDiagram) const | CXTPChartDiagram2DSeriesStyle | virtual
m_bColorEach | CXTPChartSeriesStyle | protected
m_bSmooth3dEdges | CXTPChartSeriesStyle | protected
m_clrColor | CXTPChartSeriesStyle | protected
m_nAxisIndexX | CXTPChartDiagram2DSeriesStyle | protected
m_nAxisIndexY | CXTPChartDiagram2DSeriesStyle | protected
m_nFillAcrossXAxis | CXTPChartAreaSeriesStyle | protected
m_nTransparency | CXTPChartAreaSeriesStyle | protected
m_pBorder | CXTPChartAreaSeriesStyle | protected
m_pErrorBar | CXTPChartSeriesStyle | protected
m_pFillStyle | CXTPChartAreaSeriesStyle | protected
m_pLabel | CXTPChartSeriesStyle | protected
m_Rotation3d | CXTPChartSeriesStyle | protected
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartElement | virtual
Release() | CXTPChartElement | virtual
Set3dRotation(const CXTPChart3dRotation &rotation) | CXTPChartSeriesStyle | virtual
Set3dRotation(double dYaw, double dPitch, double dRoll) | CXTPChartSeriesStyle | virtual
SetColor(CXTPChartColor clr) | CXTPChartSeriesStyle | virtual
SetColorEach(BOOL bColorEach) | CXTPChartSeriesStyle | virtual
SetErrorBar(CXTPChartErrorBar *pErrorBar) | CXTPChartSeriesStyle | virtual
SetFillAcrossXAxis(BOOL nFillAcrossXAxis) | CXTPChartAreaSeriesStyle |
SetLabel(CXTPChartSeriesLabel *pLabel) | CXTPChartSeriesStyle | virtual
SetTransparency(int nTransparency) | CXTPChartAreaSeriesStyle | virtual
~CXTPChartAreaSeriesStyle() | CXTPChartAreaSeriesStyle | virtual
~CXTPChartDiagram2DSeriesStyle() | CXTPChartDiagram2DSeriesStyle | virtual
~CXTPChartElement() | CXTPChartElement | virtual
~CXTPChartPointSeriesStyle() | CXTPChartPointSeriesStyle | virtual
~CXTPChartSeriesStyle() | CXTPChartSeriesStyle | virtual
~CXTPChartStackedAreaSeriesStyle() | CXTPChartStackedAreaSeriesStyle | virtual


Toolkit Pro: Member List

CXTPGridRecordItemVariant Member List

This is the complete list of members for CXTPGridRecordItemVariant, including all inherited members.

AddHyperlink(CXTPGridHyperlink *pHyperlink) | CXTPGridRecordItem | virtual
Compare(CXTPGridColumn *pCol, CXTPGridRecordItem *pItem) | CXTPGridRecordItemVariant | virtual
CompareGroupCaption(CXTPGridColumn *pColumn, CXTPGridGroupRow *pGroupRow) | CXTPGridRecordItemVariant | virtual
CompareGroupCaption(CXTPGridColumn *pColumn, CXTPGridRecordItem *pItem) | CXTPGridRecordItemVariant | virtual
CreateBorder() | CXTPGridRecordItem |
CXTPCmdTarget() | CXTPCmdTarget |
CXTPGridRecordItem() | CXTPGridRecordItem |
CXTPGridRecordItemVariant(const VARIANT &lpValue=COleVariant((long) 0)) | CXTPGridRecordItemVariant |
DestroyBorder() | CXTPGridRecordItem |
DoPropExchange(CXTPPropExchange *pPX) | CXTPGridRecordItemVariant | virtual
Draw(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs) | CXTPGridRecordItem | virtual
DrawCheckBox(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CRect &rcItem) | CXTPGridRecordItem | protectedvirtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAlignment() const | CXTPGridRecordItem |
GetBackgroundColor() | CXTPGridRecordItem | virtual
GetBorder() const | CXTPGridRecordItem |
GetCanEditCheckboxItem() const | CXTPGridRecordItem |
GetCaption(CXTPGridColumn *pColumn) | CXTPGridRecordItemVariant | virtual
GetCaption() | CXTPGridRecordItemVariant | virtual
GetCaptionRect(XTP_GRIDRECORDITEM_ARGS *pDrawArgs, CRect &rcItem) | CXTPGridRecordItem | virtual
GetCheckedState() const | CXTPGridRecordItem |
GetColumnCaptionPrefix(CXTPGridColumn *pColumn) const | CXTPGridRecordItem |
GetEditOptions(CXTPGridColumn *pColumn) | CXTPGridRecordItem |
GetFont() | CXTPGridRecordItem | virtual
GetFormatString() const | CXTPGridRecordItem | virtual
GetFormula() const | CXTPGridRecordItem | virtual
GetGroupCaption(CXTPGridColumn *pColumn) | CXTPGridRecordItem | virtual
GetGroupCaptionID(CXTPGridColumn *pColumn) | CXTPGridRecordItem | virtual
GetGroupCaptionValue(CXTPGridColumn *pColumn) | CXTPGridRecordItemVariant | virtual
GetGroupPriority() const | CXTPGridRecordItem | virtual
GetHasCheckbox() const | CXTPGridRecordItem | virtual
GetHyperlinkAt(int nHyperlink) const | CXTPGridRecordItem | virtual
GetHyperlinks() | CXTPGridRecordItem | protected
GetHyperlinksCount() const | CXTPGridRecordItem | virtual
GetIconIndex() const | CXTPGridRecordItem | virtual
GetIndex() const | CXTPGridRecordItem |
GetItemControls() | CXTPGridRecordItem |
GetItemData() const | CXTPGridRecordItem | virtual
GetItemMetrics(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pItemMetrics) | CXTPGridRecordItem | virtual
GetMarkupUIElement() const | CXTPGridRecordItem |
GetRecord() const | CXTPGridRecordItem |
GetSelectedConstraintData(XTP_GRIDRECORDITEM_ARGS *pItemArgs) | CXTPGridRecordItemVariant | virtual
GetSortPriority() const | CXTPGridRecordItem | virtual
GetTextColor() | CXTPGridRecordItem | virtual
GetTooltip() const | CXTPGridRecordItem | virtual
GetValue() | CXTPGridRecordItemVariant |
HasCheckbox(BOOL bHasCheckbox, BOOL bTristate=FALSE) | CXTPGridRecordItem | virtual
HitTest(CPoint ptPoint) | CXTPGridRecordItem |
HitTestHyperlink(CPoint ptClick) | CXTPGridRecordItem | virtual
IsBold() const | CXTPGridRecordItem | virtual
IsChecked() const | CXTPGridRecordItem | virtual
IsChildOfMerge() const | CXTPGridRecordItem |
IsEditable() const | CXTPGridRecordItem | virtual
IsFocusable() const | CXTPGridRecordItem | virtual
IsPreviewItem() const | CXTPGridRecordItem | virtual
m_Alignment | CXTPGridRecordItem | protected
m_bBoldText | CXTPGridRecordItem | protected
m_bCanEditCheckboxItem | CXTPGridRecordItem | protected
m_bEditable | CXTPGridRecordItem | protected
m_bFocusable | CXTPGridRecordItem | protected
m_bHasCheckbox | CXTPGridRecordItem | protected
m_bItemControlUnderMouse | CXTPGridRecordItem | protected
m_bTristateCheckbox | CXTPGridRecordItem | protected
m_checkState | CXTPGridRecordItem | protected
m_clrBackground | CXTPGridRecordItem | protected
m_clrText | CXTPGridRecordItem | protected
m_dwData | CXTPGridRecordItem | protected
m_nGroupPriority | CXTPGridRecordItem | protected
m_nIconIndex | CXTPGridRecordItem | protected
m_nSortLocale | CXTPGridRecordItemVariant | static
m_nSortPriority | CXTPGridRecordItem | protected
m_oleValue | CXTPGridRecordItemVariant |
m_pBorder | CXTPGridRecordItem | protected
m_pControl | CXTPGridRecordItem | protected
m_pEditOptions | CXTPGridRecordItem | protected
m_pFocusedItemControl | CXTPGridRecordItem | protected
m_pFontCaption | CXTPGridRecordItem | protected
m_pHyperlinks | CXTPGridRecordItem | protected
m_pItemControlHookWnd | CXTPGridRecordItem | protected
m_pItemControls | CXTPGridRecordItem | protected
m_pMarkupUIElement | CXTPGridRecordItem | protected
m_pRecord | CXTPGridRecordItem | protected
m_rcGlyph | CXTPGridRecordItem | protected
m_strCaption | CXTPGridRecordItem | protected
m_strFormatString | CXTPGridRecordItem | protected
m_strFormula | CXTPGridRecordItem | protected
m_strGroupCaption | CXTPGridRecordItem | protected
m_strTooltip | CXTPGridRecordItem | protected
OnBeginEdit(XTP_GRIDRECORDITEM_ARGS *pItemArgs) | CXTPGridRecordItem | protectedvirtual
OnCancelEdit(CXTPGridControl *pControl, BOOL bApply) | CXTPGridRecordItem | virtual
OnChar(XTP_GRIDRECORDITEM_ARGS *pItemArgs, UINT nChar) | CXTPGridRecordItem | protectedvirtual
OnClick(XTP_GRIDRECORDITEM_CLICKARGS *pClickArgs) | CXTPGridRecordItem | virtual
OnConstraintChanged(XTP_GRIDRECORDITEM_ARGS *pItemArgs, CXTPGridRecordItemConstraint *pConstraint) | CXTPGridRecordItemVariant | virtual
OnDblClick(XTP_GRIDRECORDITEM_CLICKARGS *pClickArgs) | CXTPGridRecordItem | virtual
OnDrawCaption(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics) | CXTPGridRecordItem | virtual
OnDrawControls(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CRect &rcItem) | CXTPGridRecordItem | virtual
OnEditCanceled(XTP_GRIDRECORDITEM_ARGS *pItemArgs) | CXTPGridRecordItem | virtual
OnEditChanged(XTP_GRIDRECORDITEM_ARGS *pItemArgs, LPCTSTR szText) | CXTPGridRecordItemVariant | virtual
OnEditChanging(XTP_GRIDRECORDITEM_ARGS *pItemArgs, CString &rstrNewText) | CXTPGridRecordItemVariant | protectedvirtual
OnInplaceButtonDown(CXTPGridInplaceButton *pButton) | CXTPGridRecordItem | virtual
OnLButtonDown(XTP_GRIDRECORDITEM_CLICKARGS *pClickArgs) | CXTPGridRecordItem | virtual
OnLButtonUp(XTP_GRIDRECORDITEM_CLICKARGS *pClickArgs) | CXTPGridRecordItem | virtual
OnMouseMove(UINT nFlags, CPoint point, CXTPGridControl *pControl=NULL) | CXTPGridRecordItem | virtual
OnRequestEdit(XTP_GRIDRECORDITEM_ARGS *pItemArgs) | CXTPGridRecordItem | protectedvirtual
OnToolHitTest(CPoint point, TOOLINFO *pTI) | CXTPGridRecordItem | virtual
OnValidateEdit(XTP_GRIDRECORDITEM_ARGS *pItemArgs) | CXTPGridRecordItem | virtual
OnValueChanging(XTP_GRIDRECORDITEM_ARGS *pItemArgs, LPVARIANT lpNewValue) | CXTPGridRecordItemVariant | protectedvirtual
operator delete(void *p) | CXTPHeapObjectT< CXTPCmdTarget, CXTPGridDataAllocator > | inline
operator new(size_t nSize) | CXTPHeapObjectT< CXTPCmdTarget, CXTPGridDataAllocator > | inline
RemoveHyperlinkAt(int nHyperlink) | CXTPGridRecordItem | virtual
ResetMarkupUIElement() | CXTPGridRecordItem | virtual
SetAlignment(int nAlignment) | CXTPGridRecordItem |
SetBackgroundColor(COLORREF clrBackground) | CXTPGridRecordItem | virtual
SetBold(BOOL bBold=TRUE) | CXTPGridRecordItem | virtual
SetCanEditCheckboxItem(BOOL bSet) | CXTPGridRecordItem |
SetCaption(LPCTSTR strCaption) | CXTPGridRecordItem | virtual
SetChecked(BOOL bChecked) | CXTPGridRecordItem | virtual
SetCheckedState(int iState) | CXTPGridRecordItem |
SetEditable(BOOL bEditable=TRUE) | CXTPGridRecordItem | virtual
SetFocusable(BOOL bFocusable) | CXTPGridRecordItem | virtual
SetFont(CFont *pFont) | CXTPGridRecordItem | virtual
SetFormatString(LPCTSTR strFormat) | CXTPGridRecordItem | virtual
SetFormula(LPCTSTR sFormula) | CXTPGridRecordItem | virtual
SetGridControl(CXTPGridControl *pControl) | CXTPGridRecordItem |
SetGroupCaption(LPCTSTR strCaption) | CXTPGridRecordItem | virtual
SetGroupPriority(int nGroupPriority) | CXTPGridRecordItem | virtual
SetIconIndex(int nIconIndex) | CXTPGridRecordItem | virtual
SetItemData(DWORD_PTR dwData) | CXTPGridRecordItem | virtual
SetRecord(CXTPGridRecord *pGridRecord) | CXTPGridRecordItem |
SetSortPriority(int nSortPriority) | CXTPGridRecordItem | virtual
SetTextColor(COLORREF clrText) | CXTPGridRecordItem | virtual
SetTooltip(LPCTSTR lpszTooltip) | CXTPGridRecordItem | virtual
SetValue(const COleVariant &var) | CXTPGridRecordItemVariant |
SetValue(const VARIANT &var) | CXTPGridRecordItemVariant |
SetValue(const VARIANT *var) | CXTPGridRecordItemVariant |
UpdateValue() | CXTPGridRecordItem |
~CXTPGridRecordItem() | CXTPGridRecordItem | virtual


Toolkit Pro: XTPMarkupObject.h Source File

  • Source
  • Markup
XTPMarkupObject.h
Go to the documentation of this file.
1
23#if !defined(__XTPMARKUPOBJECT_H__)
24# define __XTPMARKUPOBJECT_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableAdvancedWarnings.h"
32# include <DispEx.h>
33# include "Common/Base/Diagnostic/XTPEnableAdvancedWarnings.h"
34
35# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
36
37class CXTPMarkupDrawingContext;
38class CXTPMarkupDependencyProperty;
39class CXTPMarkupObject;
40class CXTPMarkupBuilder;
41class CXTPMarkupPropertyFromNameMap;
42class CXTPMarkupPropertyChangedEventArgs;
43class CXTPMarkupContext;
44class CXTPMarkupProperties;
45class CXTPMarkupType;
46class CXTPMarkupStyle;
47class CXTPMarkupBuilder;
48class CXTPMarkupExtension;
49class CXTPComInitializer;
51class CXTPMarkupObjectAttachedPropertyDispCollection;
52class CXTPMarkupObjectAttachedPropertyElementSO;
55namespace XTPXML
56{
57struct IXMLDOMElement;
58}
59
60enum XTPMarkupTextAlignment
61{
62 xtpMarkupTextAlignmentLeft,
63 xtpMarkupTextAlignmentRight,
64 xtpMarkupTextAlignmentCenter,
65 xtpMarkupTextAlignmentJustify
66};
67
68enum XTPMarkupHorizontalAlignment
69{
70 xtpMarkupHorizontalAlignmentLeft,
71 xtpMarkupHorizontalAlignmentCenter,
72 xtpMarkupHorizontalAlignmentRight,
73 xtpMarkupHorizontalAlignmentStretch
74};
75
76enum XTPMarkupVerticalAlignment
77{
78 xtpMarkupVerticalAlignmentTop,
79 xtpMarkupVerticalAlignmentCenter,
80 xtpMarkupVerticalAlignmentBottom,
81 xtpMarkupVerticalAlignmentStretch
82};
83
84enum XTPMarkupOrientation
85{
86 xtpMarkupOrientationHorizontal,
87 xtpMarkupOrientationVertical
88};
89
90enum XTPMarkupBaselineAlignment
91{
92 xtpMarkupBaselineTop,
93 xtpMarkupBaselineCenter,
94 xtpMarkupBaselineBottom,
95 xtpMarkupBaseline,
96 xtpMarkupBaselineTextTop,
97 xtpMarkupBaselineTextBottom,
98 xtpMarkupBaselineSubscript,
99 xtpMarkupBaselineSuperscript
100};
101
102enum XTPMarkupVisibility
103{
104 xtpMarkupVisibilityVisible = 0,
105 xtpMarkupVisibilityHidden = 1,
106 xtpMarkupVisibilityCollapsed = 2
107};
108
109enum XTPMarkupLineCap
110{
111 xtpMarkupLineCapFlat,
112 xtpMarkupLineCapSquare,
113 xtpMarkupLineCapRound,
114 xtpMarkupLineCapTriangle
115};
116
117enum XTPMarkupLineJoin
118{
119 xtpMarkupLineJoinMiter,
120 xtpMarkupLineJoinBevel,
121 xtpMarkupLineJoinRound
122};
123
124typedef CXTPMarkupObject* (*PFNCONVERTFROM)(
125 CXTPMarkupBuilder* pBuilder, CXTPMarkupObject* pObject,
126 CXTPMarkupDependencyProperty* pAssociatedProperty /*= NULL*/);
127typedef void (*PFNPROPERTYCHANGED)(CXTPMarkupObject* d, CXTPMarkupPropertyChangedEventArgs* e);
128
129class _XTP_EXT_CLASS CXTPMarkupPropertyMetadata
130{
131public:
132 enum MetadataFlags
133 {
134 flagInherited = 1,
135 flagAffectsArrange = 2,
136 flagAffectsMeasure = 4,
137 flagAffectsParentArrange = 8,
138 flagAffectsParentMeasure = 16,
139 flagAffectsRender = 32,
140 flagDpiSensible = 64,
141 flagHorzDpiSensible = flagDpiSensible,
142 flagVertDpiSensible = 128,
143 };
144
145public:
146 CXTPMarkupPropertyMetadata(CXTPMarkupObject* pDefaultValue, DWORD dwFlags = 0);
147 CXTPMarkupPropertyMetadata(CXTPMarkupObject* pDefaultValue, PFNCONVERTFROM pConverter,
148 DWORD dwFlags = 0);
149 CXTPMarkupPropertyMetadata(CXTPMarkupObject* pDefaultValue, PFNPROPERTYCHANGED pPropertyChanged,
150 DWORD dwFlags = 0);
151 CXTPMarkupPropertyMetadata(CXTPMarkupObject* pDefaultValue, PFNCONVERTFROM pConverter,
152 PFNPROPERTYCHANGED pPropertyChanged, DWORD dwFlags = 0);
153 virtual ~CXTPMarkupPropertyMetadata();
154
155public:
156 CXTPMarkupObject* m_pDefaultValue;
157 PFNCONVERTFROM m_pConverter;
158 PFNPROPERTYCHANGED m_pPropertyChanged;
159 DWORD m_dwFlags;
160
161 friend class CXTPMarkupObject;
162};
163
164# define MARKUP_RELEASE(x) \
165 if (x) \
166 { \
167 (x)->Release(); \
168 (x) = 0; \
169 }
170# define MARKUP_ADDREF(x) \
171 if (x) \
172 { \
173 (x)->AddRef(); \
174 }
175
177# define MARKUP_TYPE_(class_name) class_name::Get##class_name##Type()
180# define MARKUP_TYPE(class_name) XTP_ASSERT_CHECK_NOT_NULL(MARKUP_TYPE_(class_name))
181
182# define DECLARE_MARKUPCLASS(class_name) \
183 DECLARE_DYNAMIC(class_name) \
184 private: \
185 static CXTPThreadLocal<CXTPMarkupType>* m_p##class_name##TlsPtr; \
186 static BOOL m_b##class_name##RegistrationAttempted; \
187 static BOOL m_b##class_name##Unregistered; \
188 \
189 public: \
190 static CXTPMarkupType* AFX_CDECL GetMarkupBaseType(); \
191 static CXTPMarkupObject* AFX_CDECL CreateMarkupObject(CXTPMarkupContext* pContext); \
192 static void AFX_CDECL RegisterMarkupClass(); \
193 static void AFX_CDECL RegisterMarkupClass_(); \
194 static void AFX_CDECL UnregisterMarkupClass(); \
195 virtual CXTPMarkupType* GetType() const; \
196 static void AFX_CDECL RegisterType(); \
197 static CXTPMarkupType* Get##class_name##Type(); \
198 static CXTPMarkupType* AFX_CDECL Create##class_name##Instance(); \
199 static void AFX_CDECL Destroy##class_name##Instance(CXTPMarkupType* pType);
200
201# define IMPLEMENT_MARKUPCLASS_CUSTOM_BASE(class_tag, class_name, base_class_name, \
202 get_base_type) \
203 IMPLEMENT_DYNAMIC(class_name, base_class_name); \
204 CXTPThreadLocal<CXTPMarkupType>* class_name::m_p##class_name##TlsPtr = NULL; \
205 BOOL class_name::m_b##class_name##RegistrationAttempted = FALSE; \
206 BOOL class_name::m_b##class_name##Unregistered = FALSE; \
207 CXTPMarkupObject* AFX_CDECL class_name::CreateMarkupObject(CXTPMarkupContext* pContext) \
208 { \
209 class_name* obj = new class_name; \
210 if (obj) \
211 obj->m_pMarkupContext = pContext; \
212 return obj; \
213 } \
214 void AFX_CDECL class_name::RegisterMarkupClass_() \
215 { \
216 CXTPMarkupType::RegisterTypeEntry(class_tag, class_name::Get##class_name##Type); \
217 RegisterMarkupClass(); \
218 } \
219 CXTPMarkupType* AFX_CDECL class_name::GetMarkupBaseType() \
220 { \
221 return get_base_type; \
222 } \
223 CXTPMarkupType* AFX_CDECL class_name::Create##class_name##Instance() \
224 { \
225 CXTPMarkupType* pType = new CXTPMarkupType(class_tag, L#class_name, \
226 &class_name::CreateMarkupObject, \
227 &class_name::GetMarkupBaseType, \
228 &class_name::RegisterMarkupClass_, \
229 &class_name::UnregisterMarkupClass); \
230 return pType; \
231 } \
232 void AFX_CDECL class_name::Destroy##class_name##Instance(CXTPMarkupType* pType) \
233 { \
234 _ASSERTE(NULL != pType); \
235 pType->ExternalRelease(); \
236 } \
237 CXTPMarkupType* class_name::Get##class_name##Type() \
238 { \
239 if (m_b##class_name##Unregistered) \
240 return NULL; \
241 if (!m_b##class_name##RegistrationAttempted) \
242 RegisterType(); \
243 if (NULL == m_p##class_name##TlsPtr) \
244 m_p##class_name##TlsPtr = new CXTPThreadLocal<CXTPMarkupType>( \
245 class_name::Create##class_name##Instance, \
246 class_name::Destroy##class_name##Instance); \
247 return &**m_p##class_name##TlsPtr; \
248 } \
249 CXTPMarkupType* class_name::GetType() const \
250 { \
251 return MARKUP_TYPE(class_name); \
252 } \
253 void AFX_CDECL class_name::RegisterType() \
254 { \
255 _ASSERTE(!m_b##class_name##Unregistered); \
256 if (m_b##class_name##RegistrationAttempted) \
257 return; \
258 m_b##class_name##RegistrationAttempted = TRUE; \
259 MARKUP_TYPE(class_name)->Register(); \
260 } \
261 void AFX_CDECL class_name::UnregisterMarkupClass() \
262 { \
263 _ASSERTE(!m_b##class_name##Unregistered); \
264 _ASSERTE(m_b##class_name##RegistrationAttempted); \
265 m_b##class_name##Unregistered = TRUE; \
266 if (NULL == m_p##class_name##TlsPtr) \
267 return; \
268 delete m_p##class_name##TlsPtr; \
269 m_p##class_name##TlsPtr = NULL; \
270 }
271
272# define IMPLEMENT_MARKUPCLASS(class_tag, class_name, base_class_name) \
273 IMPLEMENT_MARKUPCLASS_CUSTOM_BASE(class_tag, class_name, base_class_name, \
274 MARKUP_TYPE_(base_class_name))
275
276# ifdef _DEBUG
277# define MARKUP_STATICCAST(class_name, object) \
278 (static_cast<class_name*>( \
279 CXTPMarkupType::StaticDownCast(MARKUP_TYPE(class_name), object)))
280# else
281# define MARKUP_STATICCAST(class_name, object) (static_cast<class_name*>(object))
282# endif
283
284# undef MARKUP_DYNAMICCAST
285# define MARKUP_DYNAMICCAST(class_name, object) \
286 (static_cast<class_name*>(CXTPMarkupType::DynamicDownCast(MARKUP_TYPE(class_name), object)))
287
288class _XTP_EXT_CLASS CXTPMarkupObject : public CXTPCmdTarget
289{
290 DECLARE_MARKUPCLASS(CXTPMarkupObject);
291
292 friend class CXTPMarkupObjectAttachedPropertyElementSO;
293
294public:
296 enum Flags
297 {
298 flagNoCom = 1
299 };
302 CXTPMarkupObject(int nReserved = 0);
303
304protected:
305 virtual ~CXTPMarkupObject();
306
307public:
308 CXTPMarkupContext* GetMarkupContext() const;
309
310 XTPXML::IXMLDOMElement* GetSourceMarkupElement() const;
311 void SetSourceMarkupElement(XTPXML::IXMLDOMElement* pElement);
312
313 LPCWSTR GetKey() const;
314 void SetKey(LPCWSTR lpszKey);
315
316 LPCWSTR GetName() const;
317 void SetName(LPCWSTR lpszName);
318
319 void SetValue(CXTPMarkupDependencyProperty* pProperty, CXTPMarkupObject* pValue);
320 CXTPMarkupObject* GetValue(CXTPMarkupDependencyProperty* pProperty) const;
321
322 CXTPMarkupObject* GetValueSource(CXTPMarkupDependencyProperty* pProperty) const;
323
324 virtual CXTPMarkupObject* GetValueCore(CXTPMarkupDependencyProperty* pProperty) const;
325
326 CXTPMarkupDependencyProperty* GetAssociatedProperty() const;
327 void SetAssociatedProperty(CXTPMarkupDependencyProperty* pAssociatedProperty);
328
329 void SetLogicalParent(CXTPMarkupObject* pObject);
330 CXTPMarkupObject* GetLogicalParent() const;
331
332 void AddExtension(CXTPMarkupExtension* pExtension);
333 CXTPMarkupExtension* GetNextExtension(const CXTPMarkupType* pClass = NULL);
334 const CXTPMarkupExtension* GetNextExtension(const CXTPMarkupType* pClass = NULL) const;
335 void ResetExtensionEnumerator();
336
337 BOOL IsKindOf(const CXTPMarkupType* pClass) const;
338
339public:
340 DWORD AddRef();
341 DWORD Release();
342
343public:
344 virtual UINT GetHashKey() const;
345 virtual BOOL IsEqual(const CXTPMarkupObject* pObject) const;
346
347 BOOL operator==(const CXTPMarkupObject* pObject) const;
348
349public:
350 void SetTagName(LPCWSTR lpszTagName);
351 LPCWSTR GetTagName() const;
352
353 CXTPMarkupObject* FindKey(LPCWSTR lpszKey);
354 CXTPMarkupObject* FindName(LPCWSTR lpszName);
355
356 virtual int GetLogicalChildrenCount() const;
357 virtual CXTPMarkupObject* GetLogicalChild(int nIndex) const;
358
359public:
360 virtual void SetContentObject(CXTPMarkupBuilder* pBuilder, CXTPMarkupObject* pContent);
361 virtual void SetPropertyObject(CXTPMarkupBuilder* pBuilder,
362 CXTPMarkupDependencyProperty* pProperty,
363 CXTPMarkupObject* pValue);
364 virtual CXTPMarkupObject* ConvertFrom(CXTPMarkupBuilder* pBuilder,
365 CXTPMarkupObject* pObject) const;
366 virtual BOOL HasContentObject() const;
367 virtual BOOL AllowWhiteSpaceContent() const;
368
369protected:
370 virtual void OnPropertyChanged(CXTPMarkupDependencyProperty* pProperty,
371 CXTPMarkupObject* pOldValue, CXTPMarkupObject* pNewValue);
372 virtual void OnSetAsProperty(CXTPMarkupDependencyProperty* pProperty,
373 CXTPMarkupObject* pTargetObject);
374 virtual void OnLoaded(CXTPMarkupBuilder* pBuilder);
375
376 void RecursePropertyChanged(CXTPMarkupDependencyProperty* pProperty,
377 CXTPMarkupObject* pOldValue, CXTPMarkupObject* pNewValue);
378
379 void OnSetValue(CXTPMarkupDependencyProperty* pProperty, CXTPMarkupObject* pOldValue,
380 CXTPMarkupObject* pValue);
381
382protected:
383 virtual void OnFinalRelease();
384
386public:
387 DECLARE_DISPATCH_MAP()
388 DECLARE_INTERFACE_MAP()
389# ifdef _XTP_ACTIVEX
390 DECLARE_OLETYPELIB_EX(CXTPMarkupObject);
391# endif
392
393# pragma warning(push)
394// C4616: #pragma warning : warning number '...' out of range, must be between '4001' and '4999'
395// C4619: #pragma warning : there is no warning number 'number'
396// C5204: '...': class has virtual functions, but its trivial destructor is not virtual; instances
397// of objects derived from this class may not be destructed correctly
398# pragma warning(disable : 4616 4619 5204)
399 BEGIN_INTERFACE_PART(DispatchEx, IDispatchEx)
400 XTP_DECLARE_IDISPATCH()
401
402 // IDispatchEx
403 virtual HRESULT STDMETHODCALLTYPE GetDispID(
404 /* [in] */ BSTR bstrName,
405 /* [in] */ DWORD grfdex,
406 /* [out] */ DISPID* pid);
407
408 virtual /* [local] */ HRESULT STDMETHODCALLTYPE InvokeEx(
409 /* [annotation][in] */
410 DISPID id,
411 /* [annotation][in] */
412 LCID lcid,
413 /* [annotation][in] */
414 WORD wFlags,
415 /* [annotation][in] */
416 DISPPARAMS* pdp,
417 /* [annotation][out] */
418 VARIANT* pvarRes,
419 /* [annotation][out] */
420 EXCEPINFO* pei,
421 /* [annotation][unique][in] */
422 IServiceProvider* pspCaller);
423
424 virtual HRESULT STDMETHODCALLTYPE DeleteMemberByName(
425 /* [in] */ BSTR bstrName,
426 /* [in] */ DWORD grfdex);
427
428 virtual HRESULT STDMETHODCALLTYPE DeleteMemberByDispID(
429 /* [in] */ DISPID id);
430
431 virtual HRESULT STDMETHODCALLTYPE GetMemberProperties(
432 /* [in] */ DISPID id,
433 /* [in] */ DWORD grfdexFetch,
434 /* [out] */ DWORD* pgrfdex);
435
436 virtual HRESULT STDMETHODCALLTYPE GetMemberName(
437 /* [in] */ DISPID id,
438 /* [out] */ BSTR* pbstrName);
439
440 virtual HRESULT STDMETHODCALLTYPE GetNextDispID(
441 /* [in] */ DWORD grfdex,
442 /* [in] */ DISPID id,
443 /* [out] */ DISPID* pid);
444
445 virtual HRESULT STDMETHODCALLTYPE GetNameSpaceParent(
446 /* [out] */ IUnknown** ppunk);
447 END_INTERFACE_PART(DispatchEx)
448# pragma warning(pop)
449
450public:
451 static CXTPMarkupObject* FromDispatch(LPDISPATCH pDisp, BOOL bAddRef = TRUE);
452 static CXTPMarkupObject* FromDispatchAs(CXTPMarkupType* pType, LPDISPATCH pDisp,
453 BOOL bAddRef = TRUE);
454
455 void SetBeingLoaded(BOOL bBeingLoaded = TRUE);
456 BOOL IsBeingLoaded() const;
457
460protected:
461 CXTPMarkupObject* m_pLogicalParent;
462
463 CXTPMarkupProperties* m_pProperties;
464 CXTPMarkupDependencyProperty* m_pAssociatedProperty;
465
466 CList<CXTPMarkupExtension*, CXTPMarkupExtension*> m_Extensions;
467 POSITION m_posExtension;
468
469 CXTPMarkupContext* m_pMarkupContext;
470
471 XTPXML::IXMLDOMElement* m_pMarkupElement;
472 LPWSTR m_lpszMarkupTag;
473
474private:
475 BOOL m_bBeingLoaded;
476 CXTPMarkupObjectAttachedPropertyDispCollection* m_pDispColl;
477
478protected:
479 friend class CXTPMarkupBuilder;
480 friend class CXTPMarkupStyle;
481 static CXTPMarkupDependencyProperty* m_pNameProperty;
482 static CXTPMarkupDependencyProperty* m_pKeyProperty;
483
484 friend class CXTPMarkupProperties;
485};
486
487AFX_INLINE CXTPMarkupDependencyProperty* CXTPMarkupObject::GetAssociatedProperty() const
488{
489 return m_pAssociatedProperty;
490}
491
492AFX_INLINE void
493 CXTPMarkupObject::SetAssociatedProperty(CXTPMarkupDependencyProperty* pAssociatedProperty)
494{
495 m_pAssociatedProperty = pAssociatedProperty;
496}
498AFX_INLINE void CXTPMarkupObject::SetBeingLoaded(BOOL bBeingLoaded /*= TRUE*/)
499{
500 m_bBeingLoaded = bBeingLoaded;
501}
502
503AFX_INLINE BOOL CXTPMarkupObject::IsBeingLoaded() const
504{
505 return m_bBeingLoaded;
506}
508typedef CXTPMarkupObject* CXTPMarkupObjectPtr;
509
510class _XTP_EXT_CLASS CXTPMarkupDependencyProperty : public CXTPMarkupObject
511{
512 DECLARE_MARKUPCLASS(CXTPMarkupDependencyProperty);
513
514protected:
515 CXTPMarkupDependencyProperty();
516
517public:
518 virtual ~CXTPMarkupDependencyProperty();
519
520public:
521 static CXTPMarkupDependencyProperty* AFX_CDECL
522 Register(LPCWSTR lpszName, CXTPMarkupType* pPropetyType, CXTPMarkupType* pOwnerType,
523 CXTPMarkupPropertyMetadata* pMetadata = NULL);
524 static CXTPMarkupDependencyProperty* AFX_CDECL
525 RegisterAttached(LPCWSTR lpszName, CXTPMarkupType* pPropetyType, CXTPMarkupType* pOwnerType,
526 CXTPMarkupPropertyMetadata* pMetadata = NULL);
527 CXTPMarkupDependencyProperty* AddOwner(CXTPMarkupType* pOwnerType);
528
529public:
530 LPCWSTR GetName() const;
531 CXTPMarkupType* GetPropetyType() const;
532 CXTPMarkupType* GetOwnerType() const;
533 CXTPMarkupPropertyMetadata* GetMetadata() const;
534 BOOL IsAttached() const;
535 virtual BOOL IsEvent() const;
536
537 DWORD GetFlags() const;
538
539public:
540 static CXTPMarkupDependencyProperty* AFX_CDECL FindProperty(CXTPMarkupType* pRuntimeClass,
541 LPCWSTR lpszAttribute);
542
543protected:
544 static CXTPMarkupPropertyFromNameMap* AFX_CDECL GetPropertyMap();
545 static CXTPMarkupDependencyProperty* AFX_CDECL RegisterCommon(CXTPMarkupDependencyProperty* dp,
546 LPCWSTR lpszName,
547 CXTPMarkupType* pPropetyType,
548 CXTPMarkupType* pOwnerType,
549 BOOL bAttached);
550
551private:
552 LPCWSTR m_lpszName;
553 CXTPMarkupType* m_pPropetyType;
554 CXTPMarkupType* m_pOwnerType;
555 CXTPMarkupPropertyMetadata* m_pMetadata;
556 BOOL m_bAttached;
557 int m_nIndex;
558
559 static int s_nCount;
560
561 friend class CXTPMarkupBuilder;
562 friend class CXTPMarkupRoutedEvent;
563 friend class CXTPMarkupProperties;
564};
565
566class _XTP_EXT_CLASS CXTPMarkupPropertyChangedEventArgs
567{
568public:
569 CXTPMarkupPropertyChangedEventArgs(CXTPMarkupDependencyProperty* pProperty,
570 CXTPMarkupObject* pOldValue, CXTPMarkupObject* pNewValue);
571
572public:
573 CXTPMarkupDependencyProperty* m_pProperty;
574 CXTPMarkupObject* m_pOldValue;
575 CXTPMarkupObject* m_pNewValue;
576};
577
578class _XTP_EXT_CLASS CXTPMarkupInt : public CXTPMarkupObject
579{
580 DECLARE_MARKUPCLASS(CXTPMarkupInt);
581 DECLARE_DISPATCH_MAP();
582
583public:
584 CXTPMarkupInt(int nValue = 0);
585
586 operator int() const
587 {
588 return m_nValue;
589 }
590
591 int GetValue() const
592 {
593 return m_nValue;
594 }
595
596public:
597 CXTPMarkupObject* ConvertFrom(CXTPMarkupBuilder* pBuilder, CXTPMarkupObject* pObject) const;
598
599public:
600 virtual BOOL IsEqual(const CXTPMarkupObject* pObject) const;
601
602protected:
603 int m_nValue;
604};
605
606class _XTP_EXT_CLASS CXTPMarkupDouble : public CXTPMarkupObject
607{
608 DECLARE_MARKUPCLASS(CXTPMarkupDouble);
609
610public:
611 CXTPMarkupDouble(double dValue = 0);
612
613 operator double() const
614 {
615 return m_dValue;
616 }
617
618public:
619 CXTPMarkupObject* ConvertFrom(CXTPMarkupBuilder* pBuilder, CXTPMarkupObject* pObject) const;
620
621public:
622 virtual BOOL IsEqual(const CXTPMarkupObject* pObject) const;
623
624protected:
625 double m_dValue;
626};
627
628class _XTP_EXT_CLASS CXTPMarkupEnum : public CXTPMarkupObject
629{
630 DECLARE_MARKUPCLASS(CXTPMarkupEnum);
631
632 struct EnumMapTag
633 {
634 };
635
636public:
637 CXTPMarkupEnum(int nValue = 0);
638
639 operator int() const
640 {
641 return m_nValue;
642 }
643
644 int GetValue() const
645 {
646 return m_nValue;
647 }
648
649public:
650 static CXTPMarkupEnum* AFX_CDECL CreateValue(int nValue);
651
652public:
653 CXTPMarkupObject* ConvertFrom(CXTPMarkupBuilder* pBuilder, CXTPMarkupObject* pObject) const;
654
655public:
656 virtual BOOL IsEqual(const CXTPMarkupObject* pObject) const;
657
658protected:
659 int m_nValue;
660};
661
662class _XTP_EXT_CLASS CXTPMarkupBool : public CXTPMarkupObject
663{
664 DECLARE_MARKUPCLASS(CXTPMarkupBool);
665
666public:
667 CXTPMarkupBool(BOOL bValue = FALSE);
668
669 operator BOOL() const
670 {
671 return m_bValue;
672 }
673
674public:
675 static CXTPMarkupBool* AFX_CDECL CreateTrueValue();
676 static CXTPMarkupBool* AFX_CDECL CreateFalseValue();
677 static CXTPMarkupBool* AFX_CDECL CreateValue(BOOL bValue);
678
679public:
680 CXTPMarkupObject* ConvertFrom(CXTPMarkupBuilder* pBuilder, CXTPMarkupObject* pObject) const;
681
682public:
683 virtual UINT GetHashKey() const;
684 virtual BOOL IsEqual(const CXTPMarkupObject* pObject) const;
685
686protected:
687 BOOL m_bValue;
688};
689
690class _XTP_EXT_CLASS CXTPMarkupColor : public CXTPMarkupObject
691{
692 DECLARE_MARKUPCLASS(CXTPMarkupColor);
693
694public:
695 CXTPMarkupColor(COLORREF nValue = 0);
696 CXTPMarkupColor(BYTE bAlpha, COLORREF nValue);
697
698 operator COLORREF() const;
699
700 COLORREF GetCOLORREF() const;
701 DWORD GetARGB() const;
702 BYTE GetAlpha() const;
703
704 CXTPMarkupObject* ConvertFrom(CXTPMarkupBuilder* pBuilder, CXTPMarkupObject* pObject) const;
705
706public:
707 static BOOL AFX_CDECL ConvertFromString(LPCWSTR lpszValue, COLORREF& clr);
708
709public:
710 virtual BOOL IsEqual(const CXTPMarkupObject* pObject) const;
711
712protected:
713 void SetContentObject(CXTPMarkupBuilder* pBuilder, CXTPMarkupObject* /*pContent*/);
714
715protected:
716 COLORREF m_nValue;
717};
718
719AFX_INLINE CXTPMarkupColor::operator COLORREF() const
720{
721 return m_nValue;
722}
723
724AFX_INLINE COLORREF CXTPMarkupColor::GetCOLORREF() const
725{
726 return m_nValue & 0xFFFFFF;
727}
728
729AFX_INLINE DWORD CXTPMarkupColor::GetARGB() const
730{
731 return (m_nValue & 0xFF000000)
732 | RGB(GetBValue(m_nValue), GetGValue(m_nValue), GetRValue(m_nValue));
733}
734
735AFX_INLINE BYTE CXTPMarkupColor::GetAlpha() const
736{
737 return static_cast<BYTE>(m_nValue >> 24);
738}
739
740class _XTP_EXT_CLASS CXTPMarkupColorKey : public CXTPMarkupObject
741{
742 DECLARE_MARKUPCLASS(CXTPMarkupColorKey);
743
744public:
745 CXTPMarkupColorKey(int nIndex = 0);
746
747public:
748 int m_nIndex;
749};
750
751class _XTP_EXT_CLASS CXTPMarkupType : public CXTPMarkupObject
752{
753 DECLARE_MARKUPCLASS(CXTPMarkupType);
754
755protected:
756 class CClassList;
757 static CClassList* AFX_CDECL GetClassList();
758
759public:
760 typedef CXTPMarkupObject*(AFX_CDECL* PFNCREATEOBJECT)(CXTPMarkupContext*);
761 typedef CXTPMarkupType*(AFX_CDECL* PFNGETBASETYPE)();
762 typedef void(AFX_CDECL* PFNREGISTERMARKUPCLASS)();
763
764 CXTPMarkupObject* CreateObject(CXTPMarkupContext* pContext) const;
765
766 static void AFX_CDECL RegisterAll();
767 static void AFX_CDECL UnregisterAll();
768
770 static void* AFX_CDECL RegisterTypeEntry(LPCWSTR lpTag, PFNGETBASETYPE pfnGetType);
771 static void AFX_CDECL ResolveTypeEntry(void* pTypeEntry);
774public:
775 CXTPMarkupType();
776 CXTPMarkupType(LPCWSTR lpszTag, LPCWSTR lpszClassName, PFNCREATEOBJECT pfnCreateObject,
777 PFNGETBASETYPE pfnGetBaseType,
778 PFNREGISTERMARKUPCLASS pfnRegisterMarkupClass = NULL,
779 PFNREGISTERMARKUPCLASS pfnUnregisterMarkupClass = NULL);
780
781 virtual ~CXTPMarkupType();
782
783public:
784 BOOL IsDerivedFrom(const CXTPMarkupType* pType) const;
785 BOOL IsEqualTo(const CXTPMarkupType* pBaseClass) const;
786 UINT GetHashKey() const;
787
788 static CXTPMarkupObject* AFX_CDECL DynamicDownCast(CXTPMarkupType* pType,
789 CXTPMarkupObject* pObject);
790 static CXTPMarkupObject* AFX_CDECL StaticDownCast(CXTPMarkupType* pType,
791 CXTPMarkupObject* pObject);
792
793 static CXTPMarkupType* AFX_CDECL LookupTag(LPCWSTR lpszTag);
794
795 void Register();
796 void Unregister();
797
798 CXTPMarkupStyle* GetTypeStyle() const;
799 void SetTypeStyle(CXTPMarkupStyle* pStyle);
800
801 CXTPMarkupType* GetBaseType() const;
802
803protected:
804 CXTPMarkupObject* ConvertFrom(CXTPMarkupBuilder* pBuilder, CXTPMarkupObject* pObject) const;
805
806public:
807 LPCWSTR m_lpszTag;
808 LPCWSTR m_lpszClassName;
810 _XTP_DEPRECATED
811 CXTPMarkupType* m_pNextType;
813protected:
814 BOOL m_bRegister;
815 PFNCREATEOBJECT m_pfnCreateObject;
816 PFNGETBASETYPE m_pfnGetBaseType;
817 PFNREGISTERMARKUPCLASS m_pfnRegisterMarkupClass;
818 PFNREGISTERMARKUPCLASS m_pfnUnregisterMarkupClass;
819 CXTPMarkupStyle* m_pTypeStyle;
820};
821
822class _XTP_EXT_CLASS CXTPMarkupCollection : public CXTPMarkupObject
823{
824 DECLARE_MARKUPCLASS(CXTPMarkupCollection);
825
826public:
827 CXTPMarkupCollection();
828 virtual ~CXTPMarkupCollection();
829
830public:
831 int GetCount() const;
832 void Add(CXTPMarkupObject* pElement);
833 void Insert(int nIndex, CXTPMarkupObject* pElement);
834 void RemoveAll();
835 void Remove(int nIndex);
836 int IndexOf(CXTPMarkupObject* pElement) const;
837
838public:
839 void SetContentObject(CXTPMarkupBuilder* pBuilder, CXTPMarkupObject* pContent);
840 BOOL HasContentObject() const;
841
842 CXTPMarkupType* GetElementType() const;
843
844 virtual int GetLogicalChildrenCount() const;
845 virtual CXTPMarkupObject* GetLogicalChild(int nIndex) const;
846
847protected:
848 virtual void OnItemAdded(CXTPMarkupObject* pItem, int nIndex);
849 virtual void OnChanged();
850
851protected:
852 CArray<CXTPMarkupObject*, CXTPMarkupObject*> m_arrItems;
853 CXTPMarkupType* m_pElementType;
854 BOOL m_bLogicalParent;
855};
856
857class _XTP_EXT_CLASS CXTPMarkupProperties : public CXTPMarkupObject
858{
859public:
860 CXTPMarkupProperties(CXTPMarkupObject* pOwner);
861 virtual ~CXTPMarkupProperties();
862
863public:
864 BOOL IsPropertyValid(CXTPMarkupDependencyProperty* pProperty) const;
865
866 CXTPMarkupObject* Lookup(CXTPMarkupDependencyProperty* pProperty) const;
867
868 void Copy(CXTPMarkupProperties* pOwner);
869
870 void Set(CXTPMarkupDependencyProperty* pProperty, CXTPMarkupObject* pValue);
871
872 void Remove(CXTPMarkupDependencyProperty* pProperty);
873
874protected:
875 CXTPMarkupObject** m_pTable;
876 int m_nTableSize;
877 CXTPMarkupObject* m_pOwner;
878};
879
880class _XTP_EXT_CLASS CXTPMarkupAutoPtr
881{
882public:
883 CXTPMarkupAutoPtr(CXTPMarkupObject* pObject = NULL);
884 virtual ~CXTPMarkupAutoPtr();
885
886public:
887 void Assign(CXTPMarkupObject* pObject);
888 CXTPMarkupObject* AddRef();
889 CXTPMarkupObject* operator->();
890 const CXTPMarkupObject* operator->() const;
891
892public:
893 CXTPMarkupObject* m_pObject;
894};
895
896class _XTP_EXT_CLASS CXTPMarkupDoubleCollection : public CXTPMarkupObject
897{
899 DECLARE_MARKUPCLASS(CXTPMarkupDoubleCollection)
901public:
902 typedef CArray<float, float&> CDoubleArray;
903
904public:
905 CXTPMarkupDoubleCollection();
906 CXTPMarkupDoubleCollection(CDoubleArray& arr);
907
908public:
909 int GetCount() const;
910 const float* GetData() const;
911 float GetAt(int nIndex) const;
912 void RemoveAll();
913 void Remove(int nIndex);
914 void Add(float fValue);
915
916protected:
917 CXTPMarkupObject* ConvertFrom(CXTPMarkupBuilder* pBuilder, CXTPMarkupObject* pObject) const;
918 static BOOL AFX_CDECL ConvertFromString(LPCWSTR lpszValue, CDoubleArray& arr);
919 static BOOL AFX_CDECL GetNextValue(LPCWSTR& lpszValue, float& nValue);
920
921protected:
922 CDoubleArray m_arr;
923
925public:
926 DECLARE_DISPATCH_MAP()
927# ifdef _XTP_ACTIVEX
928 DECLARE_INTERFACE_MAP()
929 DECLARE_OLETYPELIB_EX(CXTPMarkupDoubleCollection);
930# endif
931
932 afx_msg long OleGetItemCount();
933 afx_msg void OleAdd(double dValue);
934 afx_msg double OleGetItem(long nIndex);
936};
937
938AFX_INLINE CXTPMarkupStyle* CXTPMarkupType::GetTypeStyle() const
939{
940 return m_pTypeStyle;
941}
942AFX_INLINE int CXTPMarkupCollection::GetCount() const
943{
944 return (int)m_arrItems.GetSize();
945}
946AFX_INLINE CXTPMarkupType* CXTPMarkupCollection::GetElementType() const
947{
948 return m_pElementType;
949}
950AFX_INLINE LPCWSTR CXTPMarkupDependencyProperty::GetName() const
951{
952 return m_lpszName;
953}
954AFX_INLINE CXTPMarkupType* CXTPMarkupDependencyProperty::GetPropetyType() const
955{
956 return m_pPropetyType;
957}
958AFX_INLINE CXTPMarkupType* CXTPMarkupDependencyProperty::GetOwnerType() const
959{
960 return m_pOwnerType;
961}
962AFX_INLINE CXTPMarkupPropertyMetadata* CXTPMarkupDependencyProperty::GetMetadata() const
963{
964 return m_pMetadata;
965}
966AFX_INLINE BOOL CXTPMarkupDependencyProperty::IsAttached() const
967{
968 return m_bAttached;
969}
970AFX_INLINE BOOL CXTPMarkupDependencyProperty::IsEvent() const
971{
972 return FALSE;
973}
974AFX_INLINE DWORD CXTPMarkupDependencyProperty::GetFlags() const
975{
976 return m_pMetadata ? m_pMetadata->m_dwFlags : 0;
977}
978AFX_INLINE CXTPMarkupContext* CXTPMarkupObject::GetMarkupContext() const
979{
980 return m_pMarkupContext;
981}
982AFX_INLINE UINT CXTPMarkupObject::GetHashKey() const
983{
984 return (UINT)(UINT_PTR)this;
985}
986AFX_INLINE BOOL CXTPMarkupObject::IsEqual(const CXTPMarkupObject* pObject) const
987{
988 return pObject == this;
989}
990AFX_INLINE BOOL CXTPMarkupObject::operator==(const CXTPMarkupObject* pObject) const
991{
992 return IsEqual(pObject);
993}
994AFX_INLINE bool AFXAPI operator==(const CXTPMarkupObject& s1, const CXTPMarkupObject& s2)
995{
996 return s1.IsEqual(&s2) ? true : false;
997}
998template<>
999AFX_INLINE UINT AFXAPI HashKey(CXTPMarkupObject* key)
1000{
1001 _ASSERTE(NULL != key);
1002
1003 return key->GetHashKey();
1004}
1005template<>
1006AFX_INLINE BOOL AFXAPI CompareElements(const CXTPMarkupObjectPtr* pElement1,
1007 const CXTPMarkupObjectPtr* pElement2)
1008{
1009 _ASSERTE(NULL != pElement1);
1010 _ASSERTE(NULL != *pElement1);
1011 _ASSERTE(NULL != pElement2);
1012
1013 return (*pElement1)->IsEqual(*pElement2);
1014}
1015
1016AFX_INLINE BOOL IsEqual(CXTPMarkupObject* pNewValue, CXTPMarkupObject* pOldValue)
1017{
1018 if (pNewValue == NULL && pOldValue == NULL)
1019 return TRUE;
1020
1021 if (pNewValue != NULL && pOldValue != NULL)
1022 return pNewValue->IsEqual(pOldValue);
1023
1024 return FALSE;
1025}
1026
1027# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
1029#endif // !defined(__XTPMARKUPOBJECT_H__)
XTPDisableAdvancedWarnings.h
XTPDisableNoisyWarnings.h
XTPEnableAdvancedWarnings.h
XTPEnableNoisyWarnings.h
XTP_DECLARE_IDISPATCH
#define XTP_DECLARE_IDISPATCH()
Provides standard IDispatch implementation for a class derived from CCmdTarget.
Definition XTPMacros.h:875
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPComInitializer
Initializes COM and increments and holds COM initialization reference counter for the thread where co...
Definition XTPSystemHelpers.h:2021
CXTPMarkupContext
CXTPMarkupContext is a standalone class used to provide common settings for Markup objects.
Definition XTPMarkupContext.h:128
CXTPMarkupExtension
Base class for all markup extension objects.
Definition XTPMarkupExtension.h:38


Toolkit Pro: Member List

CXTPChartPieSeriesStyle Member List

This is the complete list of members for CXTPChartPieSeriesStyle, including all inherited members.

ApplyTo(CXTPChartDeviceCommand *pCommand) | CXTPChartSeriesStyle | virtual
CorrectAxisSideMargins(CXTPChartAxis *pAxis, double nMinValue, double nMaxValue, double &nCorrection) | CXTPChartSeriesStyle | virtual
CreateDiagram() | CXTPChartPieSeriesStyle | protectedvirtual
CreateView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView) | CXTPChartPieSeriesStyle | protectedvirtual
CXTPChartElement() | CXTPChartElement |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartPieSeriesStyle() | CXTPChartPieSeriesStyle |
CXTPChartPieSeriesStyleBase() | CXTPChartPieSeriesStyleBase | protected
CXTPChartSeriesStyle() | CXTPChartSeriesStyle |
DoPropExchange(CXTPPropExchange *pPX) | CXTPChartPieSeriesStyleBase | virtual
Enable3dEdgeSmoothing(BOOL bEnable=TRUE) | CXTPChartSeriesStyle | virtual
Get3dRotation() const | CXTPChartSeriesStyle | virtual
GetAppearance() const | CXTPChartElement |
GetBorder() const | CXTPChartPieSeriesStyleBase |
GetBorderActualColor() const | CXTPChartPieSeriesStyleBase |
GetColor() const | CXTPChartSeriesStyle | virtual
GetContent() const | CXTPChartElement |
GetDepth() const | CXTPChartPieSeriesStyleBase | virtual
GetErrorBar() const | CXTPChartSeriesStyle | virtual
GetExplodedDistancePercent() const | CXTPChartPieSeriesStyleBase |
GetHolePercent() const | CXTPChartPieSeriesStyleBase |
GetLabel() const | CXTPChartSeriesStyle | virtual
GetOwner() const | CXTPChartElement |
GetRotation() const | CXTPChartPieSeriesStyleBase |
GetSeriesPointValueIndex() const | CXTPChartSeriesStyle | virtual
GetStyleAppearance() const | CXTPChartSeriesStyle | virtual
GetTransparency() const | CXTPChartSeriesStyle | virtual
Is3D() const | CXTPChartObject |
Is3dEdgeSmoothingEnabled() const | CXTPChartSeriesStyle | virtual
IsColorEach() const | CXTPChartSeriesStyle | virtual
IsStyleDiagram(CXTPChartDiagram *pDiagram) const | CXTPChartPieSeriesStyleBase | protectedvirtual
m_bColorEach | CXTPChartSeriesStyle | protected
m_bSmooth3dEdges | CXTPChartSeriesStyle | protected
m_clrColor | CXTPChartSeriesStyle | protected
m_nExplodedDistancePercent | CXTPChartPieSeriesStyleBase | protected
m_nHolePercent | CXTPChartPieSeriesStyleBase | protected
m_nRotation | CXTPChartPieSeriesStyleBase | protected
m_nTransparency | CXTPChartSeriesStyle | protected
m_pBorder | CXTPChartPieSeriesStyleBase | protected
m_pErrorBar | CXTPChartSeriesStyle | protected
m_pLabel | CXTPChartSeriesStyle | protected
m_Rotation3d | CXTPChartSeriesStyle | protected
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartElement | virtual
Release() | CXTPChartElement | virtual
Set3dRotation(const CXTPChart3dRotation &rotation) | CXTPChartSeriesStyle | virtual
Set3dRotation(double dYaw, double dPitch, double dRoll) | CXTPChartSeriesStyle | virtual
SetColor(CXTPChartColor clr) | CXTPChartSeriesStyle | virtual
SetColorEach(BOOL bColorEach) | CXTPChartSeriesStyle | virtual
SetErrorBar(CXTPChartErrorBar *pErrorBar) | CXTPChartSeriesStyle | virtual
SetExplodedDistancePercent(int nExplodedDistancePercent) | CXTPChartPieSeriesStyleBase |
SetHolePercent(int nHolePercent) | CXTPChartPieSeriesStyleBase |
SetLabel(CXTPChartSeriesLabel *pLabel) | CXTPChartSeriesStyle | virtual
SetRotation(int nRotation) | CXTPChartPieSeriesStyleBase |
SetTransparency(int nTransparency) | CXTPChartSeriesStyle | virtual
~CXTPChartElement() | CXTPChartElement | virtual
~CXTPChartPieSeriesStyleBase() | CXTPChartPieSeriesStyleBase | protectedvirtual
~CXTPChartSeriesStyle() | CXTPChartSeriesStyle | virtual


Toolkit Pro: Member List

CXTPMarkupContentControl Member List

This is the complete list of members for CXTPMarkupContentControl, including all inherited members.

ApplyRenderTransform(CXTPMarkupDrawingContext *pContext) | CXTPMarkupUIElement | protectedvirtual
Arrange(CRect rcFinalRect) | CXTPMarkupUIElement |
ArrangeCore(CRect rcFinalRect) | CXTPMarkupUIElement | protectedvirtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPMarkupContentControl() | CXTPMarkupContentControl | protected
CXTPMarkupFrameworkElement() | CXTPMarkupFrameworkElement | protected
CXTPMarkupUIElement() | CXTPMarkupUIElement | protected
CXTPMarkupVisual() | CXTPMarkupVisual |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAbsoluteVisualOffset() const | CXTPMarkupVisual | protected
GetActualSize() const | CXTPMarkupFrameworkElement |
GetBackground() const | CXTPMarkupControl |
GetBoundRect() const | CXTPMarkupVisual |
GetClipToBounds() const | CXTPMarkupFrameworkElement |
GetContent() const | CXTPMarkupContentControl |
GetDesiredSize() const | CXTPMarkupUIElement |
GetFinalRect() const | CXTPMarkupUIElement |
GetForeground() const | CXTPMarkupControl |
GetHeight() const | CXTPMarkupFrameworkElement |
GetHorizontalAlignment() const | CXTPMarkupFrameworkElement |
GetLayoutClip(CRect &rc) const | CXTPMarkupUIElement | protectedvirtual
GetLogicalChild(int nIndex) const | CXTPMarkupVisual | virtual
GetLogicalChildrenCount() const | CXTPMarkupVisual | virtual
GetMargin() const | CXTPMarkupFrameworkElement |
GetMaxHeight() const | CXTPMarkupFrameworkElement |
GetMaxWidth() const | CXTPMarkupFrameworkElement |
GetMinHeight() const | CXTPMarkupFrameworkElement |
GetMinWidth() const | CXTPMarkupFrameworkElement |
GetOpacity() const | CXTPMarkupUIElement | protectedvirtual
GetPadding() const | CXTPMarkupControl |
GetRenderSize() const | CXTPMarkupVisual |
GetRenderTransform() const | CXTPMarkupUIElement | protected
GetStyle() const | CXTPMarkupFrameworkElement |
GetTag() const | CXTPMarkupFrameworkElement |
GetUpdateRect() const | CXTPMarkupVisual |
GetVerticalAlignment() const | CXTPMarkupFrameworkElement |
GetVisibility() const | CXTPMarkupUIElement |
GetVisualChild(int nIndex) const | CXTPMarkupVisual | virtual
GetVisualChildrenCount() const | CXTPMarkupVisual | virtual
GetVisualOffset() const | CXTPMarkupVisual |
GetVisualParent() const | CXTPMarkupVisual |
GetWidth() const | CXTPMarkupFrameworkElement |
InputHitTest(CPoint point) const | CXTPMarkupVisual |
InputHitTestOverride(CPoint point) const | CXTPMarkupVisual | protectedvirtual
InvalidateArrange() | CXTPMarkupUIElement | virtual
InvalidateMeasure() | CXTPMarkupUIElement | virtual
InvalidateMeasureOverride(CXTPMarkupDrawingContext *pDC) | CXTPMarkupUIElement | protectedvirtual
InvalidateVisual() | CXTPMarkupUIElement | virtual
IsEnabled() const | CXTPMarkupUIElement |
IsFocusable() const | CXTPMarkupUIElement |
IsVisible() const | CXTPMarkupUIElement | virtual
m_bArrangeDirty | CXTPMarkupUIElement | protected
m_bArrangeInProgress | CXTPMarkupUIElement | protected
m_bMeasureDirty | CXTPMarkupUIElement | protected
m_bMeasureInProgress | CXTPMarkupUIElement | protected
m_bNeverArranged | CXTPMarkupUIElement | protected
m_bNeverMeasured | CXTPMarkupUIElement | protected
m_pClipToBoundsProperty | CXTPMarkupUIElement | static
m_pFocusableProperty | CXTPMarkupUIElement | static
m_pIsEnabledProperty | CXTPMarkupUIElement | static
m_pOpacityProperty | CXTPMarkupUIElement | static
m_pRenderTransformOriginProperty | CXTPMarkupUIElement | static
m_pRenderTransformProperty | CXTPMarkupUIElement | static
m_ptVisualOffset | CXTPMarkupVisual | protected
m_pVisibilityProperty | CXTPMarkupUIElement | static
m_rcBoundRect | CXTPMarkupVisual | protected
m_rcFinalRect | CXTPMarkupUIElement | protected
m_rcPrevUpdateRect | CXTPMarkupVisual | protected
m_rcUpdateRect | CXTPMarkupVisual | protected
m_szDesiredSize | CXTPMarkupUIElement | protected
m_szPreviousAvailableSize | CXTPMarkupUIElement | protected
m_szRenderSize | CXTPMarkupVisual | protected
Measure(CXTPMarkupDrawingContext *pDC, CSize szAvailableSize) | CXTPMarkupUIElement |
MeasureCore(CXTPMarkupDrawingContext *pDC, CSize szAvailableSize) | CXTPMarkupUIElement | protectedvirtual
OnRender(CXTPMarkupDrawingContext *drawingContext) | CXTPMarkupVisual | protectedvirtual
OnRenderFocusVisual(CXTPMarkupDrawingContext *drawingContext) | CXTPMarkupVisual | protectedvirtual
PtInRectTransform(const RECT &rect, const POINT &point) const | CXTPMarkupVisual | protected
Render(CXTPMarkupDrawingContext *drawingContext) | CXTPMarkupVisual |
RenderClipped(CXTPMarkupDrawingContext *drawingContext) | CXTPMarkupVisual | protectedvirtual
RestoreRenderTransform(CXTPMarkupDrawingContext *pContext, TransformationMatrices &matrices) | CXTPMarkupUIElement | protectedvirtual
SetBackground(CXTPMarkupBrush *pBrush) | CXTPMarkupControl |
SetClipToBounds(BOOL bClipToBounds) | CXTPMarkupFrameworkElement |
SetContent(CXTPMarkupUIElement *pContent) | CXTPMarkupContentControl |
SetForeground(CXTPMarkupBrush *pBrush) | CXTPMarkupControl |
SetHeight(int nHeight) | CXTPMarkupFrameworkElement |
SetHorizontalAlignment(XTPMarkupHorizontalAlignment alignment) | CXTPMarkupFrameworkElement |
SetMargin(int nLeft, int nTop, int nRight, int nBottom) | CXTPMarkupFrameworkElement |
SetMargin(int nMargin) | CXTPMarkupFrameworkElement |
SetMaxHeight(int nHeight) | CXTPMarkupFrameworkElement |
SetMaxWidth(int nWidth) | CXTPMarkupFrameworkElement |
SetMinHeight(int nHeight) | CXTPMarkupFrameworkElement |
SetMinWidth(int nWidth) | CXTPMarkupFrameworkElement |
SetPadding(int nLeft, int nTop, int nRight, int nBottom) | CXTPMarkupControl |
SetPadding(int nPadding) | CXTPMarkupControl |
SetTag(CXTPMarkupObject *pTag) | CXTPMarkupFrameworkElement |
SetVerticalAlignment(XTPMarkupVerticalAlignment alignment) | CXTPMarkupFrameworkElement |
SetVisibility(XTPMarkupVisibility visibility) | CXTPMarkupUIElement |
SetWidth(int nWidth) | CXTPMarkupFrameworkElement |
~CXTPMarkupContentControl() | CXTPMarkupContentControl | protectedvirtual
~CXTPMarkupFrameworkElement() | CXTPMarkupFrameworkElement | protectedvirtual
~CXTPMarkupUIElement() | CXTPMarkupUIElement | protectedvirtual
~CXTPMarkupVisual() | CXTPMarkupVisual | virtual


Toolkit Pro: XTPPoint2.h Source File

  • Source
  • Common
  • Base
  • Types
XTPPoint2.h
Go to the documentation of this file.
1
23#if !defined(__XTPPOINT2_H__)
24# define __XTPPOINT2_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33template<class T>
34class CXTPPoint2T;
35
39typedef CXTPPoint2T<int> CXTPPoint2i;
40
44typedef CXTPPoint2T<float> CXTPPoint2f;
45
49typedef CXTPPoint2T<double> CXTPPoint2d;
50
56template<class T>
57class CXTPPoint2T
58{
59public:
64 CXTPPoint2T()
65 : X(T(0))
66 , Y(T(0))
67 {
68 }
69
75 CXTPPoint2T(const CXTPPoint2T& point)
76 : X(point.X)
77 , Y(point.Y)
78 {
79 }
80
87 CXTPPoint2T(int x, int y)
88 : X(T(x))
89 , Y(T(y))
90 {
91 }
92
99 CXTPPoint2T(float x, float y)
100 : X(T(x))
101 , Y(T(y))
102 {
103 }
104
111 CXTPPoint2T(double x, double y)
112 : X(T(x))
113 , Y(T(y))
114 {
115 }
116
123 void SetPoint(T x, T y)
124 {
125 X = x;
126 Y = y;
127 }
128
136 void Offset(T dx, T dy)
137 {
138 X += dx;
139 Y += dy;
140 }
141
148 CXTPPoint2T<int> Round() const
149 {
150 return CXTPPoint2T<int>(CXTPMathUtils::Round(double(X)), CXTPMathUtils::Round(double(Y)));
151 }
152
160 bool operator==(const CXTPPoint2T& point) const
161 {
162 return (&point == this) || (X == point.X && Y == point.Y);
163 }
164
172 bool operator!=(const CXTPPoint2T& point) const
173 {
174 return !(*this == point);
175 }
176
183 bool IsZero() const
184 {
185 return (T(0) == X && T(0) == Y);
186 }
187
194 operator CXTPPoint2i() const
195 {
196 return CXTPPoint2i(int(X), int(Y));
197 }
198
205 operator CXTPPoint2f() const
206 {
207 return CXTPPoint2f(float(X), float(Y));
208 }
209
216 operator CXTPPoint2d() const
217 {
218 return CXTPPoint2d(double(X), double(Y));
219 }
220
221public:
222 T X;
223 T Y;
224};
225
226# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
227
229#endif // !defined(__XTPPOINT2_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPPoint2i
CXTPPoint2T< int > CXTPPoint2i
CXTPPoint2T shortcut for integer point object.
Definition XTPPoint2.h:39
CXTPPoint2f
CXTPPoint2T< float > CXTPPoint2f
CXTPPoint2T shortcut for float point object.
Definition XTPPoint2.h:44
CXTPPoint2d
CXTPPoint2T< double > CXTPPoint2d
CXTPPoint2T shortcut for double point object.
Definition XTPPoint2.h:49
CXTPMathUtils::Round
static int AFX_CDECL Round(double dValue)
Rounds a real value taking into account its sign and returns result as integer.
CXTPPoint2T
This class represents a two-dimensional point.
Definition XTPPoint2.h:58
CXTPPoint2T::Offset
void Offset(T dx, T dy)
Offsets the point to another location.
Definition XTPPoint2.h:136
CXTPPoint2T::CXTPPoint2T
CXTPPoint2T(const CXTPPoint2T &point)
Constructs a CXTPPoint2T object from another CXTPPoint2T object.
Definition XTPPoint2.h:75
CXTPPoint2T::operator==
bool operator==(const CXTPPoint2T &point) const
Compares two points.
Definition XTPPoint2.h:160
CXTPPoint2T::IsZero
bool IsZero() const
Determines if the point object is zero, i.e.
Definition XTPPoint2.h:183
CXTPPoint2T::CXTPPoint2T
CXTPPoint2T(int x, int y)
Constructs a CXTPPoint2T object.
Definition XTPPoint2.h:87
CXTPPoint2T::SetPoint
void SetPoint(T x, T y)
Sets point component values.
Definition XTPPoint2.h:123
CXTPPoint2T::CXTPPoint2T
CXTPPoint2T(float x, float y)
Constructs a CXTPPoint2T object.
Definition XTPPoint2.h:99
CXTPPoint2T::operator!=
bool operator!=(const CXTPPoint2T &point) const
Compares two points.
Definition XTPPoint2.h:172
CXTPPoint2T::Round
CXTPPoint2T< int > Round() const
Rounds point to integer values.
Definition XTPPoint2.h:148
CXTPPoint2T::CXTPPoint2T
CXTPPoint2T()
Constructs an empty CXTPPoint2T object with all components equal to 0.
Definition XTPPoint2.h:64
CXTPPoint2T::Y
T Y
The Y coordinate.
Definition XTPPoint2.h:223
CXTPPoint2T::CXTPPoint2T
CXTPPoint2T(double x, double y)
Constructs a CXTPPoint2T object.
Definition XTPPoint2.h:111
CXTPPoint2T::X
T X
The X coordinate.
Definition XTPPoint2.h:222


Toolkit Pro: XTPDockingPaneColorSet2012.h Source File

  • Source
  • DockingPane
  • ColorSets
XTPDockingPaneColorSet2012.h
Go to the documentation of this file.
1
23#if !defined(__XTPDOCKINGPANECOLORSET2012_H__)
24# define __XTPDOCKINGPANECOLORSET2012_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPDockingPaneColorSet2012 : public CXTPDockingPaneColorSet
39{
40public:
47 virtual void RefreshMetrics(CString strSection);
48};
49
50# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
52#endif // !defined(__XTPDOCKINGPANECOLORSET2012_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPDockingPaneColorSet2012
Helper class used to initialize default colors for a theme from an .INI resource.
Definition XTPDockingPaneColorSet2012.h:39
CXTPDockingPaneColorSet2012::RefreshMetrics
virtual void RefreshMetrics(CString strSection)
This member function is used to initialize default colors for a theme from an .INI resource.
CXTPDockingPaneColorSet
Helper class used to initialize default colors for a theme from an .INI resource.
Definition XTPDockingPaneColorSet.h:39


Toolkit Pro: Member List

CXTPChartAxisStrip Member List

This is the complete list of members for CXTPChartAxisStrip, including all inherited members.

CreateLegendDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcBounds) | CXTPChartAxisStrip | protectedvirtual
CXTPChartAxisStrip() | CXTPChartAxisStrip |
CXTPChartElement() | CXTPChartElement |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
DoPropExchange(CXTPPropExchange *pPX) | CXTPChartAxisStrip | virtual
GetActualColor() const | CXTPChartAxisStrip |
GetAppearance() const | CXTPChartElement |
GetAxisMaxValue() const | CXTPChartAxisStrip |
GetAxisMinValue() const | CXTPChartAxisStrip |
GetAxisMinValueInternal() const | CXTPChartAxisStrip |
GetColor() const | CXTPChartAxisStrip |
GetContent() const | CXTPChartElement |
GetFillStyle() const | CXTPChartAxisStrip |
GetLegendName() const | CXTPChartAxisStrip | virtual
GetName() const | CXTPChartAxisStrip |
GetOwner() const | CXTPChartElement |
Is3D() const | CXTPChartObject |
IsLegendVisible() const | CXTPChartAxisStrip |
IsVisible() const | CXTPChartAxisStrip |
m_bLegendVisible | CXTPChartAxisStrip | protected
m_bVisible | CXTPChartAxisStrip | protected
m_clrColor | CXTPChartAxisStrip | protected
m_clrColor2 | CXTPChartAxisStrip | protected
m_dAxisMaxValue | CXTPChartAxisStrip | protected
m_dAxisMinValue | CXTPChartAxisStrip | protected
m_pFillStyle | CXTPChartAxisStrip | protected
m_strAxisMaxValue | CXTPChartAxisStrip | protected
m_strAxisMinValue | CXTPChartAxisStrip | protected
m_strLegendName | CXTPChartAxisStrip | protected
m_strName | CXTPChartAxisStrip | protected
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartElement | virtual
Release() | CXTPChartElement | virtual
SetAxisMaxValue(LPCTSTR lpszValue) | CXTPChartAxisStrip |
SetAxisMinValue(LPCTSTR lpszValue) | CXTPChartAxisStrip |
SetAxisMinValue(double dValue) | CXTPChartAxisStrip |
SetColor(const CXTPChartColor &color) | CXTPChartAxisStrip |
SetColor2(const CXTPChartColor &color) | CXTPChartAxisStrip |
SetLegendName(const CXTPChartString &lpszName) | CXTPChartAxisStrip |
SetLegendVisible(BOOL bVisible) | CXTPChartAxisStrip |
SetName(const CXTPChartString &lpszName) | CXTPChartAxisStrip |
SetVisible(BOOL bVisible) | CXTPChartAxisStrip |
~CXTPChartAxisStrip() | CXTPChartAxisStrip | virtual
~CXTPChartElement() | CXTPChartElement | virtual
~CXTPChartLegendItemView() | CXTPChartLegendItemView | inlinevirtual


Toolkit Pro: Member List

CXTPScrollBarThemeWindowsClassic Member List

This is the complete list of members for CXTPScrollBarThemeWindowsClassic, including all inherited members.

CalcHScroll(CXTPScrollBase *pScroll, XTPScrollMetricsH *pHScroll) | CXTPScrollBarPaintManager | protectedstatic
CalcVScroll(CXTPScrollBase *pScroll, XTPScrollMetricsV *pVScroll) | CXTPScrollBarPaintManager | protectedstatic
CXTPScrollBarPaintManager() | CXTPScrollBarPaintManager |
DrawArrowGlyph(CDC *pDC, CRect rcArrow, XTPArrowGlyph glyph, BOOL bEnabled, COLORREF clrText=COLORREF_NULL) | CXTPScrollBarPaintManager | protected
DrawArrows(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics) | CXTPScrollBarPaintManager | protectedvirtual
DrawArrows(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics) | CXTPScrollBarPaintManager | protectedvirtual
DrawBackground(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics) | CXTPScrollBarPaintManager | protectedvirtual
DrawBackground(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics) | CXTPScrollBarPaintManager | protectedvirtual
DrawButtons(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics) | CXTPScrollBarThemeWindowsClassic | protectedvirtual
DrawButtons(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics) | CXTPScrollBarThemeWindowsClassic | protectedvirtual
DrawGripper(CDC *pDC, CXTPScrollBase *pScroll) | CXTPScrollBarThemeWindowsClassic | protectedvirtual
DrawScrollBar(CDC *pDC, CXTPScrollBase *pScrollBar) | CXTPScrollBarPaintManager | virtual
DrawThumbButton(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics) | CXTPScrollBarPaintManager | protectedvirtual
DrawThumbButton(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics) | CXTPScrollBarPaintManager | protectedvirtual
DrawTracker(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics) | CXTPScrollBarThemeWindowsClassic | protectedvirtual
DrawTracker(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics) | CXTPScrollBarThemeWindowsClassic | protectedvirtual
m_crBack | CXTPScrollBarPaintManager |
m_crBackHilite | CXTPScrollBarPaintManager |
m_crBackPushed | CXTPScrollBarPaintManager |
m_crBorder | CXTPScrollBarPaintManager |
m_crBorderHilite | CXTPScrollBarPaintManager |
m_cThumb | CXTPScrollBarPaintManager |
m_cxHScroll | CXTPScrollBarPaintManager |
m_cxVScroll | CXTPScrollBarPaintManager |
m_cyHScroll | CXTPScrollBarPaintManager |
m_cyVScroll | CXTPScrollBarPaintManager |
RefreshMetrics() | CXTPScrollBarPaintManager | virtual


Toolkit Pro: Member List

CXTPTreeNativeWindows11Theme Member List

This is the complete list of members for CXTPTreeNativeWindows11Theme, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPControlTheme() | CXTPControlTheme |
CXTPTreeNativeWindows11Theme() | CXTPTreeNativeWindows11Theme |
CXTPTreeOffice2013Theme() | CXTPTreeOffice2013Theme |
CXTPTreeTheme() | CXTPTreeTheme |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetItemBackColor(UINT uState, bool bTreeHasFocus, DWORD dwStyle, COLORREF crTextDef, CTreeCtrl *pTreeBase) const | CXTPTreeTheme | virtual
GetItemTextColor(UINT uState, bool bTreeHasFocus, DWORD dwStyle, COLORREF crBackDef, CTreeCtrl *pTreeBase) const | CXTPTreeTheme | virtual
GetThemeStyle() const | CXTPControlTheme |
GetTreeBackColor() const | CXTPTreeTheme | virtual
GetTreeTextColor() const | CXTPTreeTheme | virtual
IsDrawFocusRect() const | CXTPTreeTheme | inline
IsThemeDark() const | CXTPTreeTheme | inlinevirtual
m_bDarkTheme | CXTPTreeTheme | protected
m_bDrawFocusRect | CXTPTreeTheme | protected
m_crBack | CXTPTreeTheme | protected
m_crBackDisabled | CXTPTreeTheme | protected
m_crBackSelected | CXTPTreeTheme | protected
m_crBackSelectedDisabled | CXTPTreeTheme | protected
m_crBackSelectedInactive | CXTPTreeTheme | protected
m_crText | CXTPTreeTheme | protected
m_crTextDisabled | CXTPTreeTheme | protected
m_crTextSelected | CXTPTreeTheme | protected
m_crTextSelectedDisabled | CXTPTreeTheme | protected
m_crTextSelectedInactive | CXTPTreeTheme | protected
m_nTheme | CXTPControlTheme | protected
RefreshMetrics(CXTPTreeBase *pTreeBase) | CXTPTreeOffice2013Theme | virtual
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static
~CXTPTreeTheme() | CXTPTreeTheme | virtual


Toolkit Pro: Member List

XTP_SCROLLBARINICOLORS Member List

This is the complete list of members for XTP_SCROLLBARINICOLORS, including all inherited members.

clrBack | XTP_SCROLLBARINICOLORS
clrScrollArrow | XTP_SCROLLBARINICOLORS
clrScrollBack | XTP_SCROLLBARINICOLORS
clrScrollBorder | XTP_SCROLLBARINICOLORS
clrThumbBack | XTP_SCROLLBARINICOLORS
clrThumbBorder | XTP_SCROLLBARINICOLORS


Toolkit Pro: XTPProgressThemeVisualStudio2022.h Source File

  • Source
  • CommandBars
  • Progress
XTPProgressThemeVisualStudio2022.h
Go to the documentation of this file.
1
23#if !defined(__XTPPROGRESSTHEMEVISUALSTUDIO2022_H__)
24# define __XTPPROGRESSTHEMEVISUALSTUDIO2022_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPProgressBase;
34class CXTPPaintManager;
35
40class _XTP_EXT_CLASS CXTPProgressThemeVisualStudio2022 : public CXTPProgressThemeOffice2013
41{
42public:
48 CXTPProgressThemeVisualStudio2022(CXTPPaintManager* pPaintManager);
49
55 virtual ~CXTPProgressThemeVisualStudio2022();
56};
57
59# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
60#endif // !defined(__XTPPROGRESSTHEMEVISUALSTUDIO2022_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPPaintManager
Paint manager of the command bars.
Definition XTPPaintManager.h:199
CXTPProgressBase
CXTPControlProgressBase is base class for all progress objects.
Definition XTPProgressBase.h:40
CXTPProgressThemeOffice2013
CXTPProgressThemeOffice2013 object.
Definition XTPProgressThemeOffice2013.h:41
CXTPProgressThemeVisualStudio2022
CXTPProgressThemeVisualStudio2022 object.
Definition XTPProgressThemeVisualStudio2022.h:41
CXTPProgressThemeVisualStudio2022::CXTPProgressThemeVisualStudio2022
CXTPProgressThemeVisualStudio2022(CXTPPaintManager *pPaintManager)
Constructs a CXTPProgressThemeVisualStudio2022 object.
CXTPProgressThemeVisualStudio2022::~CXTPProgressThemeVisualStudio2022
virtual ~CXTPProgressThemeVisualStudio2022()
Destroys a CXTPProgressThemeVisualStudio2022 object, handles cleanup and deallocation.


Toolkit Pro: Member List

CXTPMarkupSystemColorKeyStaticExtension Member List

This is the complete list of members for CXTPMarkupSystemColorKeyStaticExtension, including all inherited members.

CXTPMarkupStaticExtension(LPCWSTR lpzName, BOOL bProperty) | CXTPMarkupStaticExtension | protected
CXTPMarkupStaticExtension(LPCWSTR lpzName) | CXTPMarkupStaticExtension |
CXTPMarkupStaticExtensionProperty(LPCWSTR lpzName, CXTPMarkupObject *pObject=NULL) | CXTPMarkupStaticExtensionProperty |
CXTPMarkupSystemColorKeyStaticExtension(LPCWSTR lpzName, int nColorIndex) | CXTPMarkupSystemColorKeyStaticExtension |
Extend(CXTPMarkupStaticExtension *pExtension, BOOL bReplace=FALSE) | CXTPMarkupStaticExtension |
FindExtension(LPCWSTR lpzName) const | CXTPMarkupStaticExtension |
GetName() const | CXTPMarkupStaticExtension |
GetValue() | CXTPMarkupStaticExtensionProperty |
IsProperty() const | CXTPMarkupStaticExtension |
OnPrepareValue() | CXTPMarkupStaticExtension | inlineprotectedvirtual
Parse(LPCWSTR lpzValue, LPCWSTR &lpzSubValue) | CXTPMarkupStaticExtension | static
ProvideValue() | CXTPMarkupStaticExtensionProperty | virtual
ProvideValue(LPCWSTR lpzValue) | CXTPMarkupStaticExtensionProperty | virtual
SetValue(CXTPMarkupObject *pObject) | CXTPMarkupStaticExtensionProperty |
~CXTPMarkupStaticExtension() | CXTPMarkupStaticExtension | virtual
~CXTPMarkupStaticExtensionProperty() | CXTPMarkupStaticExtensionProperty |


Toolkit Pro: XTPPropertyGridItemSize.h Source File

  • Source
  • PropertyGrid
XTPPropertyGridItemSize.h
Go to the documentation of this file.
1
23#if !defined(__XTPPROPERTYGRIDITEMSIZE_H__)
24# define __XTPPROPERTYGRIDITEMSIZE_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPPropertyGridItemSize : public CXTPPropertyGridItem
39{
40public:
76 CXTPPropertyGridItemSize(LPCTSTR strCaption, CSize size = 0, CSize* pBindSize = NULL);
77
113 CXTPPropertyGridItemSize(UINT nID, CSize size = 0, CSize* pBindSize = NULL);
118 virtual ~CXTPPropertyGridItemSize();
119
120public:
126 virtual void SetSize(CSize size);
127
134 virtual CSize GetSize() const;
135
159 virtual void BindToSize(CSize* pBindSize);
160
161protected:
175 virtual void OnBeforeInsert();
176
177private:
178 void SetWidth(LPCTSTR strWidth);
179 void SetHeight(LPCTSTR strHeight);
180
181 CString SizeToString(CSize size);
182 CSize StringToSize(LPCTSTR str);
183
184 virtual void OnAddChildItem();
185 virtual void SetValue(CString strValue);
186
187 void UpdateChilds();
188
189private:
190 class CXTPPropertyGridItemSizeWidth;
191 class CXTPPropertyGridItemSizeHeight;
192
193 CSize m_szValue;
194 CXTPPropertyGridItemSizeWidth* m_pItemWidth;
195 CXTPPropertyGridItemSizeHeight* m_pItemHeight;
196
197 CSize* m_pBindSize;
198
199private:
200 DECLARE_DYNAMIC(CXTPPropertyGridItemSize)
201
202 friend class CXTPPropertyGridItemSizeWidth;
203 friend class CXTPPropertyGridItemSizeHeight;
204};
205
211class _XTP_EXT_CLASS CXTPPropertyGridItemPoint : public CXTPPropertyGridItem
212{
213public:
249 CXTPPropertyGridItemPoint(LPCTSTR strCaption, CPoint pt = 0, CPoint* pBindPoint = NULL);
250
286 CXTPPropertyGridItemPoint(UINT nID, CPoint pt = 0, CPoint* pBindPoint = NULL);
287
292 virtual ~CXTPPropertyGridItemPoint();
293
294public:
300 virtual void SetPoint(CPoint pt);
301
308 virtual CPoint GetPoint() const;
309
333 virtual void BindToPoint(CPoint* pBindPoint);
334
335protected:
349 virtual void OnBeforeInsert();
350
351private:
352 void SetX(LPCTSTR sx);
353 void SetY(LPCTSTR sy);
354
355 CString PointToString(CPoint pt);
356 CPoint StringToPoint(LPCTSTR str);
357
358 virtual void OnAddChildItem();
359 virtual void SetValue(CString strValue);
360
361 void UpdateChilds();
362
363private:
364 class CItemX;
365 class CItemY;
366
367 CPoint m_ptValue;
368 CItemX* m_pItemX;
369 CItemY* m_pItemY;
370
371 CPoint* m_pBindPoint;
372
373private:
374 DECLARE_DYNAMIC(CXTPPropertyGridItemPoint)
375
376 friend class CItemX;
377 friend class CItemY;
378};
379
381
382AFX_INLINE CSize CXTPPropertyGridItemSize::GetSize() const
383{
384 return m_szValue;
385}
386AFX_INLINE CPoint CXTPPropertyGridItemPoint::GetPoint() const
387{
388 return m_ptValue;
389}
391# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
392#endif // #if !defined(__XTPPROPERTYGRIDITEMSIZE_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPPropertyGridItem
CXTPPropertyGridItem is the base class representing an item of the Property Grid control.
Definition XTPPropertyGridItem.h:523
CXTPPropertyGridItem::SetValue
virtual void SetValue(CString strValue)
Sets the value of the item.
CXTPPropertyGridItem::SetHeight
void SetHeight(int nHeight)
Sets the variable height of the item.
CXTPPropertyGridItem::OnAddChildItem
virtual void OnAddChildItem()
This method is called when an item is added to the parent.
CXTPPropertyGridItemPoint
CXTPPropertyGridItemPoint is a CXTPPropertyGridItem derived class.
Definition XTPPropertyGridItemSize.h:212
CXTPPropertyGridItemPoint::SetPoint
virtual void SetPoint(CPoint pt)
Sets the point value for the item.
CXTPPropertyGridItemPoint::OnBeforeInsert
virtual void OnBeforeInsert()
This method is called before the item becomes visible in the property grid.
CXTPPropertyGridItemPoint::GetPoint
virtual CPoint GetPoint() const
Gets the point value of the item.
Definition XTPPropertyGridItemSize.h:386
CXTPPropertyGridItemPoint::BindToPoint
virtual void BindToPoint(CPoint *pBindPoint)
Binds the item to a specified CPoint object.
CXTPPropertyGridItemPoint::CXTPPropertyGridItemPoint
CXTPPropertyGridItemPoint(LPCTSTR strCaption, CPoint pt=0, CPoint *pBindPoint=NULL)
Constructs a CXTPPropertyGridItemPoint object.
CXTPPropertyGridItemPoint::CXTPPropertyGridItemPoint
CXTPPropertyGridItemPoint(UINT nID, CPoint pt=0, CPoint *pBindPoint=NULL)
Constructs a CXTPPropertyGridItemPoint object.
CXTPPropertyGridItemPoint::~CXTPPropertyGridItemPoint
virtual ~CXTPPropertyGridItemPoint()
Destroys a CXTPPropertyGridItemPoint object.
CXTPPropertyGridItemSize
CXTPPropertyGridItemSize is a CXTPPropertyGridItem derived class.
Definition XTPPropertyGridItemSize.h:39
CXTPPropertyGridItemSize::OnBeforeInsert
virtual void OnBeforeInsert()
This method is called before the item becomes visible in the property grid.
CXTPPropertyGridItemSize::CXTPPropertyGridItemSize
CXTPPropertyGridItemSize(UINT nID, CSize size=0, CSize *pBindSize=NULL)
Constructs a CXTPPropertyGridItemSize object.
CXTPPropertyGridItemSize::CXTPPropertyGridItemSize
CXTPPropertyGridItemSize(LPCTSTR strCaption, CSize size=0, CSize *pBindSize=NULL)
Constructs a CXTPPropertyGridItemSize object.
CXTPPropertyGridItemSize::SetSize
virtual void SetSize(CSize size)
Sets the size value for the item.
CXTPPropertyGridItemSize::GetSize
virtual CSize GetSize() const
Gets the size value of the item.
Definition XTPPropertyGridItemSize.h:382
CXTPPropertyGridItemSize::BindToSize
virtual void BindToSize(CSize *pBindSize)
Binds the item to a specified CSize object.
CXTPPropertyGridItemSize::~CXTPPropertyGridItemSize
virtual ~CXTPPropertyGridItemSize()
Destroys a CXTPPropertyGridItemSize object.


Toolkit Pro: Member List

CXTPDockingPaneTabColorSet2017 Member List

This is the complete list of members for CXTPDockingPaneTabColorSet2017, including all inherited members.

CXTPDockingPaneTabColorSet2012() | CXTPDockingPaneTabColorSet2012 |
CXTPDockingPaneTabColorSet2017() | CXTPDockingPaneTabColorSet2017 |
CXTPTabPaintManagerColorSet() | CXTPTabPaintManagerColorSet |
FillClient(CDC *pDC, CRect rc, CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
FillHeader(CDC *pDC, CRect rc, CXTPTabManager *pTabManager) | CXTPDockingPaneTabColorSet2017 | virtual
FillNavigateButton(CDC *pDC, CXTPTabManagerNavigateButton *pButton, CRect &rc) | CXTPDockingPaneTabColorSet2012 | virtual
FillPropertyButton(CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerColorSet | virtual
FillStateButton(CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerColorSet | virtual
GetClientColor(CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
GetItemColor(CXTPTabManagerItem *pItem) | CXTPDockingPaneTabColorSet2012 | virtual
GradientFill(CDC *pDC, CRect rc, COLORREF clrLight, COLORREF clrDark, XTPTabPosition position) | CXTPTabPaintManagerColorSet |
IsAppThemed() const | CXTPTabPaintManagerColorSet | virtual
m_clrActiveFilesBack | CXTPTabPaintManagerColorSet |
m_clrActiveFilesBackHighlighted | CXTPTabPaintManagerColorSet |
m_clrActiveFilesBackPressed | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyph | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyphHighlighted | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyphPressed | CXTPTabPaintManagerColorSet |
m_clrAutoHideFace | CXTPTabPaintManagerColorSet |
m_clrBorderHighlight | CXTPTabPaintManagerColorSet |
m_clrButtonBorder | CXTPTabPaintManagerColorSet |
m_clrButtonBorderHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonBorderHot | CXTPTabPaintManagerColorSet |
m_clrButtonBorderKeyTips | CXTPTabPaintManagerColorSet |
m_clrButtonBorderTabContext1 | CXTPTabPaintManagerColorSet |
m_clrButtonBorderTabContext2 | CXTPTabPaintManagerColorSet |
m_clrButtonHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonHighlightedClose | CXTPTabPaintManagerColorSet |
m_clrButtonNormal | CXTPTabPaintManagerColorSet |
m_clrButtonPressed | CXTPTabPaintManagerColorSet |
m_clrButtonSelected | CXTPTabPaintManagerColorSet |
m_clrButtonSelectedHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonSelectedPressed | CXTPTabPaintManagerColorSet |
m_clrControlFace | CXTPTabPaintManagerColorSet |
m_clrFrameBorder | CXTPTabPaintManagerColorSet |
m_clrHeaderFace | CXTPTabPaintManagerColorSet |
m_clrPaneFace | CXTPTabPaintManagerColorSet |
m_clrTabClientBack | CXTPTabPaintManagerColorSet |
m_clrTabClientBorder | CXTPTabPaintManagerColorSet |
m_clrTextDisabled | CXTPTabPaintManagerColorSet |
m_clrTextHighlight | CXTPTabPaintManagerColorSet |
m_clrTextHighlightClose | CXTPTabPaintManagerColorSet |
m_clrTextNormal | CXTPTabPaintManagerColorSet |
m_clrTextPressed | CXTPTabPaintManagerColorSet |
m_clrTextSelected | CXTPTabPaintManagerColorSet |
m_clrTextSelectedHighlighted | CXTPTabPaintManagerColorSet |
m_clrTextSelectedPressed | CXTPTabPaintManagerColorSet |
m_csExcelNormal | CXTPTabPaintManagerColorSet |
m_csExcelSelected | CXTPTabPaintManagerColorSet |
m_csPropertyPage | CXTPTabPaintManagerColorSet |
m_csPropertyPage2003 | CXTPTabPaintManagerColorSet |
m_csStateButton | CXTPTabPaintManagerColorSet |
m_pPaintManager | CXTPTabPaintManagerColorSet | protected
RefreshMetrics() | CXTPDockingPaneTabColorSet2012 | virtual
SelectClipRgn(CDC *pDC, CRect rcClient, CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
SetTextColor(CDC *pDC, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerColorSet | virtual
~CXTPTabPaintManagerColorSet() | CXTPTabPaintManagerColorSet | virtual


Toolkit Pro: Member List

CXTPTaskPanelVisualStudio2015Theme Member List

This is the complete list of members for CXTPTaskPanelVisualStudio2015Theme, including all inherited members.

BlendColor(COLORREF clrFrom, COLORREF clrTo, int nAlpha) | CXTPTaskPanelPaintManager | protected
CreateGripperBitmaps() | CXTPTaskPanelPaintManager | protected
CreateGripperIcon(HICON &hIcon, UINT nIDResource, COLORREF clrGripperBack) | CXTPTaskPanelPaintManager | protected
CXTPTaskPanelPaintManager() | CXTPTaskPanelPaintManager |
CXTPTaskPanelPaintManagerPlain() | CXTPTaskPanelPaintManagerPlain |
CXTPTaskPanelToolboxTheme() | CXTPTaskPanelToolboxTheme |
CXTPTaskPanelVisualStudio2005Theme() | CXTPTaskPanelVisualStudio2005Theme |
CXTPTaskPanelVisualStudio2012Theme(BOOL bLight=TRUE) | CXTPTaskPanelVisualStudio2012Theme |
CXTPTaskPanelVisualStudio2015Theme() | CXTPTaskPanelVisualStudio2015Theme |
DrawCaptionGripper(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelPaintManager | protectedvirtual
DrawCaptionGripperBitmap(CDC *pDC, CXTPTaskPanelGroup *pGroup, BOOL bExpanded, BOOL bHot, CRect rc) | CXTPTaskPanelPaintManager | protected
DrawCaptionGripperSigns(CDC *pDC, CPoint pt, COLORREF clr, BOOL bExpanded) | CXTPTaskPanelPaintManager | protected
DrawDragArrow(CDC *pDC, CXTPTaskPanelItem *pItem, CRect rc, BOOL bAfter=FALSE) | CXTPTaskPanelPaintManager | protectedvirtual
DrawFocusRect(CDC *pDC, CRect rc) | CXTPTaskPanelPaintManager | protectedvirtual
DrawGroupCaption(CDC *pDC, CXTPTaskPanelGroup *pGroup, BOOL bDraw) | CXTPTaskPanelToolboxTheme | virtual
DrawGroupCaptionBackground(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelVisualStudio2012Theme | virtual
DrawGroupClient(CDC *pDC, CXTPTaskPanelGroup *pGroup) | CXTPTaskPanelPaintManager | virtual
DrawGroupClientFace(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelVisualStudio2012Theme | virtual
DrawGroupClientItems(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelPaintManager | protectedvirtual
DrawGroupItem(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw) | CXTPTaskPanelPaintManager | virtual
DrawGroupItemFrame(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc) | CXTPTaskPanelVisualStudio2012Theme | virtual
DrawGroupItemImage(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw) | CXTPTaskPanelPaintManager | protected
DrawGroupItemImageWithText(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw) | CXTPTaskPanelPaintManager | protected
DrawGroupItemImageWithTextBelow(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw) | CXTPTaskPanelPaintManager | protected
DrawItemCaption(CDC *pDC, CXTPTaskPanelItem *pItem, CRect rcText, UINT nFormat) | CXTPTaskPanelVisualStudio2012Theme | virtual
DrawItemImage(CDC *pDC, CXTPTaskPanelItem *pItem, CPoint ptIcon, CXTPImageManagerIcon *pImage, CSize szIcon) | CXTPTaskPanelPaintManager | protectedvirtual
DrawScrollButton(CDC *pDC, CXTPTaskPanelScrollButton *pScrollButton) | CXTPTaskPanelPaintManager | virtual
FillGroupClientFace(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelVisualStudio2012Theme | virtual
FillTaskPanel(CDC *pDC, CXTPTaskPanel *pTaskPanel) | CXTPTaskPanelVisualStudio2012Theme | virtual
FreeBitmaps() | CXTPTaskPanelPaintManager | protected
GetCaptionGripperWidth(CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelPaintManager | protectedvirtual
GetControlMargins(const CXTPTaskPanel *pPanel) | CXTPTaskPanelPaintManager | virtual
GetGroupColors(BOOL bSpecial) | CXTPTaskPanelPaintManager |
GetGroupColors(CXTPTaskPanelGroup *pGroup) | CXTPTaskPanelPaintManager | virtual
GetGroupInnerMargins(const CXTPTaskPanelGroup *pGroup) | CXTPTaskPanelPaintManager | virtual
GetGroupOuterMargins(const CXTPTaskPanelGroup *pGroup) | CXTPTaskPanelPaintManager | virtual
GetGroupSpacing(const CXTPTaskPanel *pPanel) | CXTPTaskPanelPaintManager | virtual
GetHighlightOffset(CXTPTaskPanelGroupItem *pItem) | CXTPTaskPanelPaintManager | protectedvirtual
GetItemFont(CXTPTaskPanelItem *pItem) | CXTPTaskPanelPaintManager | virtual
GetItemIconPadding(const CXTPTaskPanelItem *pItem) | CXTPTaskPanelPaintManager | virtual
GetItemInnerMargins(const CXTPTaskPanelGroupItem *pItem) | CXTPTaskPanelPaintManager | virtual
GetItemOuterMargins(const CXTPTaskPanelGroupItem *pItem) | CXTPTaskPanelPaintManager | virtual
m_bBoldCaption | CXTPTaskPanelPaintManager |
m_bCaptionScrollButton | CXTPTaskPanelPaintManager |
m_bEmbossedDisabledText | CXTPTaskPanelPaintManager |
m_bEmulateEplorerTheme | CXTPTaskPanelPaintManager |
m_bInvertDragRect | CXTPTaskPanelPaintManager |
m_bLeftRoundedCorner | CXTPTaskPanelPaintManager | protected
m_bmpGrippers | CXTPTaskPanelPaintManager | protected
m_bOfficeBorder | CXTPTaskPanelPaintManager | protected
m_bOfficeCaption | CXTPTaskPanelPaintManagerPlain | protected
m_bOfficeHighlight | CXTPTaskPanelPaintManager |
m_bRightRoundedCorner | CXTPTaskPanelPaintManager | protected
m_bRoundedFrame | CXTPTaskPanelPaintManagerPlain | protected
m_bUseBitmapGrippers | CXTPTaskPanelPaintManager | protected
m_bUseStandardCaptionFont | CXTPTaskPanelPaintManager | protected
m_bUseStandardItemsFont | CXTPTaskPanelPaintManager | protected
m_clrBackground | CXTPTaskPanelPaintManager | protected
m_clrHighlightBorder | CXTPTaskPanelPaintManager | protected
m_clrHighlightHot | CXTPTaskPanelPaintManager | protected
m_clrHighlightPressed | CXTPTaskPanelPaintManager | protected
m_clrHighlightSelected | CXTPTaskPanelPaintManager | protected
m_clrSelectedText | CXTPTaskPanelVisualStudio2012Theme | protected
m_clrSelectedTextWithoutFocus | CXTPTaskPanelVisualStudio2012Theme | protected
m_clrSelectedWithoutFocus | CXTPTaskPanelVisualStudio2012Theme | protected
m_clrText | CXTPTaskPanelVisualStudio2012Theme | protected
m_eGripper | CXTPTaskPanelPaintManager |
m_groupNormal | CXTPTaskPanelPaintManager | protected
m_groupSpecial | CXTPTaskPanelPaintManager | protected
m_hGripperNormal | CXTPTaskPanelPaintManager | protected
m_hGripperSpecial | CXTPTaskPanelPaintManager | protected
m_nCaptionHeight | CXTPTaskPanelPaintManager | protected
m_nCaptionTextFormat | CXTPTaskPanelPaintManager | protected
m_nGroupSpacing | CXTPTaskPanelPaintManager |
m_nItemTextFormat | CXTPTaskPanelPaintManager | protected
m_rcControlMargins | CXTPTaskPanelPaintManager |
m_rcGroupIconPadding | CXTPTaskPanelPaintManager |
m_rcGroupInnerMargins | CXTPTaskPanelPaintManager |
m_rcGroupOuterMargins | CXTPTaskPanelPaintManager |
m_rcImageLayoutIconPadding | CXTPTaskPanelPaintManager |
m_rcItemIconPadding | CXTPTaskPanelPaintManager |
m_rcItemInnerMargins | CXTPTaskPanelPaintManager |
m_rcItemOuterMargins | CXTPTaskPanelPaintManager |
m_xtpFontCaption | CXTPTaskPanelPaintManager | protected
m_xtpFontIcon | CXTPTaskPanelPaintManager | protected
m_xtpFontIconBold | CXTPTaskPanelPaintManager | protected
m_xtpFontIconHot | CXTPTaskPanelPaintManager | protected
m_xtpFontIconHotBold | CXTPTaskPanelPaintManager | protected
Rectangle(CDC *pDC, CRect rc, COLORREF clrPen, COLORREF clrBrush) | CXTPTaskPanelPaintManager | protected
rectDefault | CXTPTaskPanelPaintManager | static
RefreshMetrics() | CXTPTaskPanelVisualStudio2015Theme | virtual
SetCaptionFontIndirect(LOGFONT *pLogFont, BOOL bUseStandardCaptionFont=FALSE) | CXTPTaskPanelPaintManager |
SetItemsFontIndirect(LOGFONT *pLogFont, BOOL bUseStandardItemsFont=FALSE) | CXTPTaskPanelPaintManager |
SetTextFormat(int nTextFormat, BOOL bCaption=FALSE) | CXTPTaskPanelPaintManager |
~CXTPTaskPanelPaintManager() | CXTPTaskPanelPaintManager | virtual
~CXTPTaskPanelVisualStudio2012Theme() | CXTPTaskPanelVisualStudio2012Theme | virtual
~CXTPTaskPanelVisualStudio2015Theme() | CXTPTaskPanelVisualStudio2015Theme | virtual


Toolkit Pro: XTPTaskPanelPaintManager.h Source File

  • Source
  • TaskPanel
XTPTaskPanelPaintManager.h
Go to the documentation of this file.
1
23#if !defined(__XTPTASKPANELPAINTMANAGER_H__)
24# define __XTPTASKPANELPAINTMANAGER_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPTaskPanel;
34class CXTPTaskPanelGroupItem;
35class CXTPTaskPanelScrollButton;
36class CXTPWinThemeWrapper;
37
38# define XTP_TASKPANEL_HIGHLIGHT_OFFICE2003 2
39
53struct XTP_TASKPANEL_GROUPCOLORS
54{
55 CXTPPaintManagerColorGradient clrHead;
57 CXTPPaintManagerColorGradient clrClient;
59 CXTPPaintManagerColor clrClientBorder;
61 double dHeadGradientFactor;
64 CXTPPaintManagerColor clrHeadTextNormal;
65 CXTPPaintManagerColor clrHeadTextHot;
67 CXTPPaintManagerColor clrClientText;
69 CXTPPaintManagerColor clrClientLink;
71 CXTPPaintManagerColor clrClientLinkHot;
74 CXTPPaintManagerColor clrClientLinkSelected;
77};
78
99enum XTPTaskPanelGripper
100{
101 xtpTaskPanelGripperNone,
102 xtpTaskPanelGripperBitmap,
104 xtpTaskPanelGripperPlain,
106 xtpTaskPanelGripperTriangle
107};
108
114class _XTP_EXT_CLASS CXTPTaskPanelPaintManager
115{
116public:
117 static const CRect rectDefault;
126public:
131 CXTPTaskPanelPaintManager();
132
137 virtual ~CXTPTaskPanelPaintManager();
138
145 virtual void FillTaskPanel(CDC* pDC, CXTPTaskPanel* pTaskPanel);
146
153 virtual void DrawGroupClient(CDC* pDC, CXTPTaskPanelGroup* pGroup);
154
165 virtual int DrawGroupCaption(CDC* pDC, CXTPTaskPanelGroup* pGroup, BOOL bDraw);
166
178 virtual CRect DrawGroupItem(CDC* pDC, CXTPTaskPanelGroupItem* pItem, CRect rc, BOOL bDraw);
179
184 virtual void RefreshMetrics();
185
200 XTP_TASKPANEL_GROUPCOLORS* GetGroupColors(BOOL bSpecial);
201
215 virtual XTP_TASKPANEL_GROUPCOLORS* GetGroupColors(CXTPTaskPanelGroup* pGroup);
216
225 virtual void DrawGroupItemFrame(CDC* pDC, CXTPTaskPanelGroupItem* pItem, CRect rc);
226
237 virtual CRect GetItemOuterMargins(const CXTPTaskPanelGroupItem* pItem);
238
249 virtual CRect GetItemInnerMargins(const CXTPTaskPanelGroupItem* pItem);
250
261 virtual CRect GetGroupOuterMargins(const CXTPTaskPanelGroup* pGroup);
262
273 virtual CRect GetItemIconPadding(const CXTPTaskPanelItem* pItem);
274
285 virtual CRect GetGroupInnerMargins(const CXTPTaskPanelGroup* pGroup);
286
299 virtual CRect GetControlMargins(const CXTPTaskPanel* pPanel);
300
310 virtual int GetGroupSpacing(const CXTPTaskPanel* pPanel);
311
324 virtual void DrawScrollButton(CDC* pDC, CXTPTaskPanelScrollButton* pScrollButton);
325
337 void SetTextFormat(int nTextFormat, BOOL bCaption = FALSE);
338
339public:
347 void SetItemsFontIndirect(LOGFONT* pLogFont, BOOL bUseStandardItemsFont = FALSE);
348
356 void SetCaptionFontIndirect(LOGFONT* pLogFont, BOOL bUseStandardCaptionFont = FALSE);
357
365 virtual CFont* GetItemFont(CXTPTaskPanelItem* pItem);
366
376 virtual void FillGroupClientFace(CDC* pDC, CXTPTaskPanelGroup* pGroup, CRect rc);
377
378protected:
398 CRect DrawGroupItemImageWithText(CDC* pDC, CXTPTaskPanelGroupItem* pItem, CRect rc, BOOL bDraw);
399
419 CRect DrawGroupItemImageWithTextBelow(CDC* pDC, CXTPTaskPanelGroupItem* pItem, CRect rc,
420 BOOL bDraw);
421
441 CRect DrawGroupItemImage(CDC* pDC, CXTPTaskPanelGroupItem* pItem, CRect rc, BOOL bDraw);
442
443protected:
451 virtual void DrawGroupClientFace(CDC* pDC, CXTPTaskPanelGroup* pGroup, CRect rc);
452
460 virtual void DrawGroupClientItems(CDC* pDC, CXTPTaskPanelGroup* pGroup, CRect rc);
461
476 virtual CRect DrawCaptionGripper(CDC* pDC, CXTPTaskPanelGroup* pGroup, CRect rc);
477
491 virtual int GetCaptionGripperWidth(CXTPTaskPanelGroup* pGroup, CRect rc);
492
599 virtual void DrawItemCaption(CDC* pDC, CXTPTaskPanelItem* pItem, CRect rcText, UINT nFormat);
600
610 virtual void DrawItemImage(CDC* pDC, CXTPTaskPanelItem* pItem, CPoint ptIcon,
611 CXTPImageManagerIcon* pImage, CSize szIcon);
612
613 // Helper functions
614protected:
627 COLORREF BlendColor(COLORREF clrFrom, COLORREF clrTo, int nAlpha);
628
644 CRect DrawCaptionGripperBitmap(CDC* pDC, CXTPTaskPanelGroup* pGroup, BOOL bExpanded, BOOL bHot,
645 CRect rc);
646
657 void DrawCaptionGripperSigns(CDC* pDC, CPoint pt, COLORREF clr, BOOL bExpanded);
658
672 void CreateGripperBitmaps();
673
686 void CreateGripperIcon(HICON& hIcon, UINT nIDResource, COLORREF clrGripperBack);
687
692 void FreeBitmaps();
693
703 void Rectangle(CDC* pDC, CRect rc, COLORREF clrPen, COLORREF clrBrush);
704
714 virtual CPoint GetHighlightOffset(CXTPTaskPanelGroupItem* pItem);
715
732 virtual void DrawDragArrow(CDC* pDC, CXTPTaskPanelItem* pItem, CRect rc, BOOL bAfter = FALSE);
733
740 virtual void DrawFocusRect(CDC* pDC, CRect rc);
741
742private:
743 void PremultplyAlpha(HBITMAP& bmp);
744 void ConvertToHSL(COLORREF clr, double& h, double& s, double& l);
745 double ConvertHueToRGB(double temp1, double temp2, double temp3);
746 COLORREF ConvertFromHSL(double h, double s, double l);
747 void Triangle(CDC* pDC, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clr);
748 void DrawScrollArrow(CDC* pDC, CPoint pt0, CPoint pt1, CPoint pt2, BOOL bEnabled);
749 CRect MergeRect(CRect rcSpecified, CRect rcDefault);
750
751public:
752 BOOL m_bEmulateEplorerTheme;
754 XTPTaskPanelGripper m_eGripper;
756 BOOL m_bBoldCaption;
759 CRect m_rcGroupOuterMargins;
760 CRect m_rcGroupInnerMargins;
761 CRect m_rcItemOuterMargins;
762 CRect m_rcItemInnerMargins;
763 CRect m_rcControlMargins;
764 int m_nGroupSpacing;
765 CRect m_rcImageLayoutIconPadding;
767 CRect m_rcItemIconPadding;
768 CRect m_rcGroupIconPadding;
770 BOOL m_bOfficeHighlight;
773 BOOL m_bInvertDragRect;
775 BOOL m_bCaptionScrollButton;
777 BOOL m_bEmbossedDisabledText;
779protected:
780 BOOL m_bUseBitmapGrippers;
781 HICON m_hGripperNormal;
782 HICON m_hGripperSpecial;
784 HBITMAP m_bmpGrippers[8];
786 CXTPFont m_xtpFontCaption;
787 CXTPFont m_xtpFontIcon;
788 CXTPFont m_xtpFontIconBold;
789 CXTPFont m_xtpFontIconHot;
790 CXTPFont m_xtpFontIconHotBold;
792 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CFont, m_fntCaption, m_xtpFontCaption,
793 GetCaptionFontHandle);
794 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CFont, m_fntIcon, m_xtpFontIcon, GetIconFontHandle);
795 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CFont, m_fntIconBold, m_xtpFontIconBold,
796 GetIconBoldFontHandle);
797 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CFont, m_fntIconHot, m_xtpFontIconHot,
798 GetIconHotFontHandle);
799 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CFont, m_fntIconHotBold, m_xtpFontIconHotBold,
800 GetIconHotBoldFontHandle);
801
802 CXTPPaintManagerColorGradient m_clrBackground;
804 XTP_TASKPANEL_GROUPCOLORS m_groupNormal;
805 XTP_TASKPANEL_GROUPCOLORS m_groupSpecial;
807 CXTPPaintManagerColor m_clrHighlightHot;
810 CXTPPaintManagerColor m_clrHighlightSelected;
812 CXTPPaintManagerColor m_clrHighlightPressed;
814 CXTPPaintManagerColorGradient m_clrHighlightBorder;
819 BOOL m_bOfficeBorder;
820 BOOL m_bLeftRoundedCorner;
821 BOOL m_bRightRoundedCorner;
823 int m_nCaptionHeight;
824 BOOL m_bUseStandardCaptionFont;
825 BOOL m_bUseStandardItemsFont;
827 int m_nItemTextFormat;
831 int m_nCaptionTextFormat;
835 friend class CXTPTaskPanelColorSet;
836};
837
838AFX_INLINE XTP_TASKPANEL_GROUPCOLORS* CXTPTaskPanelPaintManager::GetGroupColors(BOOL bSpecial)
839{
840 return bSpecial ? &m_groupSpecial : &m_groupNormal;
841}
842
843AFX_INLINE void CXTPTaskPanelPaintManager::SetTextFormat(int nTextFormat, BOOL bCaption /*= FALSE*/)
844{
845 if (bCaption)
846 m_nCaptionTextFormat = nTextFormat;
847 else
848 m_nItemTextFormat = nTextFormat;
849}
850
851# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
853#endif // !defined(__XTPTASKPANELPAINTMANAGER_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPTaskPanelGripper
XTPTaskPanelGripper
Enumeration used to indicate which type of gripper is drawn on task panel group headers.
Definition XTPTaskPanelPaintManager.h:100
xtpTaskPanelGripperBitmap
@ xtpTaskPanelGripperBitmap
Display a bitmap in task panel group headers (i.e.
Definition XTPTaskPanelPaintManager.h:102
xtpTaskPanelGripperPlain
@ xtpTaskPanelGripperPlain
Display the default "classic" gripper in task panel group headers.
Definition XTPTaskPanelPaintManager.h:104
xtpTaskPanelGripperNone
@ xtpTaskPanelGripperNone
Do not draw a gripper in task panel group headers.
Definition XTPTaskPanelPaintManager.h:101
xtpTaskPanelGripperTriangle
@ xtpTaskPanelGripperTriangle
Display a triangle gripper in task panel group headers.
Definition XTPTaskPanelPaintManager.h:106
CXTPFont
Provides a convenient object oriented interface for HFONT GDI object and uses GDI handle caching.
Definition XTPGdiObjects.h:414
CXTPImageManagerIcon
Icons holder class.
Definition XTPImageManager.h:622
CXTPPaintManagerColorGradient
The CXTPPaintManagerColorGradient class is used to manage COLORREF values for determining light and d...
Definition XTPColorManager.h:301
CXTPPaintManagerColor
The CXTPPaintManagerColor class is used to manage COLORREF values for determining default and applica...
Definition XTPColorManager.h:117
CXTPTaskPanelGroup
CXTPTaskPanelGroup is used in a Task Panel control to represent a group.
Definition XTPTaskPanelGroup.h:45
CXTPTaskPanelGroupItem
CXTPTaskPanelGroupItem is used in a TaskPanel control to represent a single item of a group.
Definition XTPTaskPanelGroupItem.h:39
CXTPTaskPanel
CXTPTaskPanel is used to implement an Explorer and Office-like Task Panel control.
Definition XTPTaskPanel.h:107
CXTPTaskPanelItem
CXTPTaskPanelItem is used in a Task Panel control to represent a single item.
Definition XTPTaskPanelItem.h:49
CXTPTaskPanelPaintManager
CXTPTaskPanelPaintManager is a standalone class used by CXTPTaskPanel as a paint manager.
Definition XTPTaskPanelPaintManager.h:115
CXTPTaskPanelPaintManager::m_xtpFontIconBold
CXTPFont m_xtpFontIconBold
Bold items font.
Definition XTPTaskPanelPaintManager.h:788
CXTPTaskPanelPaintManager::m_bEmbossedDisabledText
BOOL m_bEmbossedDisabledText
TRUE to draw disabled text embossed.
Definition XTPTaskPanelPaintManager.h:777
CXTPTaskPanelPaintManager::m_nItemTextFormat
int m_nItemTextFormat
Format flags of item text.
Definition XTPTaskPanelPaintManager.h:827
CXTPTaskPanelPaintManager::GetItemFont
virtual CFont * GetItemFont(CXTPTaskPanelItem *pItem)
Retrieves the text font of a specified item.
CXTPTaskPanelPaintManager::DrawGroupItemFrame
virtual void DrawGroupItemFrame(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc)
Draws a rectangle around a group item when it is selected, pressed or highlighted.
CXTPTaskPanelPaintManager::DrawGroupClientItems
virtual void DrawGroupClientItems(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Draws the items of a specified group.
CXTPTaskPanelPaintManager::CXTPTaskPanelPaintManager
CXTPTaskPanelPaintManager()
Constructs a CXTPTaskPanelPaintManager object.
CXTPTaskPanelPaintManager::GetGroupSpacing
virtual int GetGroupSpacing(const CXTPTaskPanel *pPanel)
Gets the spacing used between groups within a specified Task Panel control.
CXTPTaskPanelPaintManager::m_groupNormal
XTP_TASKPANEL_GROUPCOLORS m_groupNormal
Normal colors set.
Definition XTPTaskPanelPaintManager.h:804
CXTPTaskPanelPaintManager::GetGroupColors
virtual XTP_TASKPANEL_GROUPCOLORS * GetGroupColors(CXTPTaskPanelGroup *pGroup)
Retrieves a specified group color set.
CXTPTaskPanelPaintManager::m_hGripperNormal
HICON m_hGripperNormal
Icon of normal group header gripper.
Definition XTPTaskPanelPaintManager.h:781
CXTPTaskPanelPaintManager::rectDefault
static const CRect rectDefault
System selected default margins.
Definition XTPTaskPanelPaintManager.h:117
CXTPTaskPanelPaintManager::Rectangle
void Rectangle(CDC *pDC, CRect rc, COLORREF clrPen, COLORREF clrBrush)
This method is only used when drawing hot, pressed, and selected group items and scroll buttons when ...
CXTPTaskPanelPaintManager::m_bUseStandardCaptionFont
BOOL m_bUseStandardCaptionFont
TRUE to use system font for group caption text.
Definition XTPTaskPanelPaintManager.h:824
CXTPTaskPanelPaintManager::DrawScrollButton
virtual void DrawScrollButton(CDC *pDC, CXTPTaskPanelScrollButton *pScrollButton)
Draws a group scroll button.
CXTPTaskPanelPaintManager::m_clrHighlightSelected
CXTPPaintManagerColor m_clrHighlightSelected
Color of items when they are selected.
Definition XTPTaskPanelPaintManager.h:810
CXTPTaskPanelPaintManager::m_xtpFontIcon
CXTPFont m_xtpFontIcon
Normal items font.
Definition XTPTaskPanelPaintManager.h:787
CXTPTaskPanelPaintManager::m_clrHighlightPressed
CXTPPaintManagerColor m_clrHighlightPressed
Color of items when they are pressed.
Definition XTPTaskPanelPaintManager.h:812
CXTPTaskPanelPaintManager::m_rcItemOuterMargins
CRect m_rcItemOuterMargins
Outer margins of the group items.
Definition XTPTaskPanelPaintManager.h:761
CXTPTaskPanelPaintManager::DrawGroupItemImage
CRect DrawGroupItemImage(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw)
Draws the icon of a specified group item.
CXTPTaskPanelPaintManager::FillTaskPanel
virtual void FillTaskPanel(CDC *pDC, CXTPTaskPanel *pTaskPanel)
Fills the background of a specified task panel.
CXTPTaskPanelPaintManager::DrawGroupItem
virtual CRect DrawGroupItem(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw)
Draws a specified group item.
CXTPTaskPanelPaintManager::m_rcItemIconPadding
CRect m_rcItemIconPadding
Padding around images for items.
Definition XTPTaskPanelPaintManager.h:767
CXTPTaskPanelPaintManager::DrawCaptionGripperSigns
void DrawCaptionGripperSigns(CDC *pDC, CPoint pt, COLORREF clr, BOOL bExpanded)
Draws the ">>" and "<<" signs of the caption gripper when the theme of the Task Panel is set to Offic...
CXTPTaskPanelPaintManager::m_bOfficeHighlight
BOOL m_bOfficeHighlight
TRUE to highlight group items and scroll buttons using the Office XP style (XPCOLOR_HIGHLIGHT,...
Definition XTPTaskPanelPaintManager.h:770
CXTPTaskPanelPaintManager::m_nGroupSpacing
int m_nGroupSpacing
Amount of space placed between groups in the task panel.
Definition XTPTaskPanelPaintManager.h:764
CXTPTaskPanelPaintManager::GetItemIconPadding
virtual CRect GetItemIconPadding(const CXTPTaskPanelItem *pItem)
Retrieves the icon padding of a specified item.
CXTPTaskPanelPaintManager::m_bInvertDragRect
BOOL m_bInvertDragRect
Only used when the theme is set to xtpTaskPanelThemeVisualStudio2003.
Definition XTPTaskPanelPaintManager.h:773
CXTPTaskPanelPaintManager::m_rcGroupIconPadding
CRect m_rcGroupIconPadding
Padding around images for groups.
Definition XTPTaskPanelPaintManager.h:768
CXTPTaskPanelPaintManager::DrawGroupClient
virtual void DrawGroupClient(CDC *pDC, CXTPTaskPanelGroup *pGroup)
Draws a specified group.
CXTPTaskPanelPaintManager::DrawCaptionGripper
virtual CRect DrawCaptionGripper(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Draws the caption gripper of a specified group.
CXTPTaskPanelPaintManager::FillGroupClientFace
virtual void FillGroupClientFace(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Fills the client face of a specified group.
CXTPTaskPanelPaintManager::DrawGroupCaption
virtual int DrawGroupCaption(CDC *pDC, CXTPTaskPanelGroup *pGroup, BOOL bDraw)
Draws the caption of a specified group.
CXTPTaskPanelPaintManager::m_rcItemInnerMargins
CRect m_rcItemInnerMargins
Inner margins of the group items.
Definition XTPTaskPanelPaintManager.h:762
CXTPTaskPanelPaintManager::GetItemOuterMargins
virtual CRect GetItemOuterMargins(const CXTPTaskPanelGroupItem *pItem)
Retrieves the outer margins of a specified group item.
CXTPTaskPanelPaintManager::m_eGripper
XTPTaskPanelGripper m_eGripper
Gripper of the manager.
Definition XTPTaskPanelPaintManager.h:754
CXTPTaskPanelPaintManager::DrawGroupItemImageWithTextBelow
CRect DrawGroupItemImageWithTextBelow(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw)
Draws the icon of a specified group item.
CXTPTaskPanelPaintManager::m_nCaptionHeight
int m_nCaptionHeight
Caption height, in pixels.
Definition XTPTaskPanelPaintManager.h:823
CXTPTaskPanelPaintManager::m_xtpFontIconHotBold
CXTPFont m_xtpFontIconHotBold
Bold items font.
Definition XTPTaskPanelPaintManager.h:790
CXTPTaskPanelPaintManager::m_nCaptionTextFormat
int m_nCaptionTextFormat
Format flags of caption text.
Definition XTPTaskPanelPaintManager.h:831
CXTPTaskPanelPaintManager::DrawFocusRect
virtual void DrawFocusRect(CDC *pDC, CRect rc)
Draws a rectangle around the focused item.
CXTPTaskPanelPaintManager::m_xtpFontCaption
CXTPFont m_xtpFontCaption
Caption font.
Definition XTPTaskPanelPaintManager.h:786
CXTPTaskPanelPaintManager::m_bCaptionScrollButton
BOOL m_bCaptionScrollButton
TRUE if the group caption scroll button is visible, FALSE if the group caption scroll button is hidde...
Definition XTPTaskPanelPaintManager.h:775
CXTPTaskPanelPaintManager::DrawItemCaption
virtual void DrawItemCaption(CDC *pDC, CXTPTaskPanelItem *pItem, CRect rcText, UINT nFormat)
Draws the text caption of a specified item.
CXTPTaskPanelPaintManager::BlendColor
COLORREF BlendColor(COLORREF clrFrom, COLORREF clrTo, int nAlpha)
Blends one color to another color by a specified amount.
CXTPTaskPanelPaintManager::GetGroupColors
XTP_TASKPANEL_GROUPCOLORS * GetGroupColors(BOOL bSpecial)
Retrieves a specified group color set.
Definition XTPTaskPanelPaintManager.h:838
CXTPTaskPanelPaintManager::~CXTPTaskPanelPaintManager
virtual ~CXTPTaskPanelPaintManager()
Destroys a CXTPTaskPanelPaintManager object, handles cleanup and deallocation.
CXTPTaskPanelPaintManager::DrawGroupClientFace
virtual void DrawGroupClientFace(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Draws the client face of a specified group.
CXTPTaskPanelPaintManager::GetControlMargins
virtual CRect GetControlMargins(const CXTPTaskPanel *pPanel)
Gets the default margins used for all groups within a specified Task Panel control.
CXTPTaskPanelPaintManager::m_bRightRoundedCorner
BOOL m_bRightRoundedCorner
TRUE to round right corner of the group caption.
Definition XTPTaskPanelPaintManager.h:821
CXTPTaskPanelPaintManager::m_xtpFontIconHot
CXTPFont m_xtpFontIconHot
"Hot" items font.
Definition XTPTaskPanelPaintManager.h:789
CXTPTaskPanelPaintManager::m_bBoldCaption
BOOL m_bBoldCaption
TRUE to display caption text in bold font, FALSE to display caption text in normal type.
Definition XTPTaskPanelPaintManager.h:756
CXTPTaskPanelPaintManager::FreeBitmaps
void FreeBitmaps()
Frees the memory used by the group caption bitmaps.
CXTPTaskPanelPaintManager::m_rcGroupOuterMargins
CRect m_rcGroupOuterMargins
Outer margins of the group.
Definition XTPTaskPanelPaintManager.h:759
CXTPTaskPanelPaintManager::GetCaptionGripperWidth
virtual int GetCaptionGripperWidth(CXTPTaskPanelGroup *pGroup, CRect rc)
Retrieves the width of the caption gripper of a specified group.
CXTPTaskPanelPaintManager::SetTextFormat
void SetTextFormat(int nTextFormat, BOOL bCaption=FALSE)
Sets the text format for captions/items.
Definition XTPTaskPanelPaintManager.h:843
CXTPTaskPanelPaintManager::m_rcGroupInnerMargins
CRect m_rcGroupInnerMargins
Inner margins of the group.
Definition XTPTaskPanelPaintManager.h:760
CXTPTaskPanelPaintManager::DrawCaptionGripperBitmap
CRect DrawCaptionGripperBitmap(CDC *pDC, CXTPTaskPanelGroup *pGroup, BOOL bExpanded, BOOL bHot, CRect rc)
Draws the caption gripper bitmap.
CXTPTaskPanelPaintManager::DrawDragArrow
virtual void DrawDragArrow(CDC *pDC, CXTPTaskPanelItem *pItem, CRect rc, BOOL bAfter=FALSE)
Draws the "drag arrow" of a specified item.
CXTPTaskPanelPaintManager::m_bEmulateEplorerTheme
BOOL m_bEmulateEplorerTheme
TRUE to use Explorer theme under WinXP and Office 2000 under older OS.
Definition XTPTaskPanelPaintManager.h:752
CXTPTaskPanelPaintManager::DrawGroupItemImageWithText
CRect DrawGroupItemImageWithText(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw)
Draws the icon of a specified group item.
CXTPTaskPanelPaintManager::m_rcControlMargins
CRect m_rcControlMargins
Default margins for all groups.
Definition XTPTaskPanelPaintManager.h:763
CXTPTaskPanelPaintManager::GetHighlightOffset
virtual CPoint GetHighlightOffset(CXTPTaskPanelGroupItem *pItem)
Retrieves the highlight offset of the text of a specified group item.
CXTPTaskPanelPaintManager::CreateGripperIcon
void CreateGripperIcon(HICON &hIcon, UINT nIDResource, COLORREF clrGripperBack)
Creates the gripper bitmap icons when the theme of the Task Panel is set to either Windows XP or Clas...
CXTPTaskPanelPaintManager::SetItemsFontIndirect
void SetItemsFontIndirect(LOGFONT *pLogFont, BOOL bUseStandardItemsFont=FALSE)
Sets the text font for items.
CXTPTaskPanelPaintManager::GetGroupInnerMargins
virtual CRect GetGroupInnerMargins(const CXTPTaskPanelGroup *pGroup)
Retrieves the inner margins of a specified group.
CXTPTaskPanelPaintManager::CreateGripperBitmaps
void CreateGripperBitmaps()
Loads the gripper bitmap when the theme of the Task Panel is set to either Windows XP or Classic Wind...
CXTPTaskPanelPaintManager::m_clrHighlightBorder
CXTPPaintManagerColorGradient m_clrHighlightBorder
Border color of items when they are "hot." This is the border color of the item on mouse over if hot ...
Definition XTPTaskPanelPaintManager.h:814
CXTPTaskPanelPaintManager::m_groupSpecial
XTP_TASKPANEL_GROUPCOLORS m_groupSpecial
Special colors set.
Definition XTPTaskPanelPaintManager.h:805
CXTPTaskPanelPaintManager::RefreshMetrics
virtual void RefreshMetrics()
Refreshes the visual metrics of the paint manager.
CXTPTaskPanelPaintManager::GetGroupOuterMargins
virtual CRect GetGroupOuterMargins(const CXTPTaskPanelGroup *pGroup)
Retrieves the outer margins of a specified group.
CXTPTaskPanelPaintManager::m_bOfficeBorder
BOOL m_bOfficeBorder
TRUE to use Office borders.
Definition XTPTaskPanelPaintManager.h:819
CXTPTaskPanelPaintManager::m_bLeftRoundedCorner
BOOL m_bLeftRoundedCorner
TRUE to round left corner of the group caption.
Definition XTPTaskPanelPaintManager.h:820
CXTPTaskPanelPaintManager::m_bUseStandardItemsFont
BOOL m_bUseStandardItemsFont
TRUE to use system font for item caption text.
Definition XTPTaskPanelPaintManager.h:825
CXTPTaskPanelPaintManager::SetCaptionFontIndirect
void SetCaptionFontIndirect(LOGFONT *pLogFont, BOOL bUseStandardCaptionFont=FALSE)
Sets the text font for captions.
CXTPTaskPanelPaintManager::m_clrBackground
CXTPPaintManagerColorGradient m_clrBackground
Background color of the Task Panel.
Definition XTPTaskPanelPaintManager.h:802
CXTPTaskPanelPaintManager::GetItemInnerMargins
virtual CRect GetItemInnerMargins(const CXTPTaskPanelGroupItem *pItem)
Retrieves the inner margins of a specified group item.
CXTPTaskPanelPaintManager::m_bUseBitmapGrippers
BOOL m_bUseBitmapGrippers
TRUE to use alpha grippers.
Definition XTPTaskPanelPaintManager.h:780
CXTPTaskPanelPaintManager::DrawItemImage
virtual void DrawItemImage(CDC *pDC, CXTPTaskPanelItem *pItem, CPoint ptIcon, CXTPImageManagerIcon *pImage, CSize szIcon)
Draws the icon of a specified item.
CXTPTaskPanelPaintManager::m_clrHighlightHot
CXTPPaintManagerColor m_clrHighlightHot
Color of items when they are "hot." This is the color of the item on mouseover if hot tracking is ena...
Definition XTPTaskPanelPaintManager.h:807
CXTPTaskPanelPaintManager::m_hGripperSpecial
HICON m_hGripperSpecial
Icon of special group header gripper.
Definition XTPTaskPanelPaintManager.h:782
CXTPTaskPanelPaintManager::m_rcImageLayoutIconPadding
CRect m_rcImageLayoutIconPadding
Padding around images for xtpTaskItemLayoutImages layout.
Definition XTPTaskPanelPaintManager.h:765
CXTPTaskPanelScrollButton
CXTPTaskPanelScrollButton is a standalone class that represents a task panel scroll button.
Definition XTPTaskPanel.h:64
CXTPWinThemeWrapper
The CXTPWinThemeWrapper class wraps the UxTheme.dll visual theme API.
Definition XTPWinThemeWrapper.h:188
XTP_TASKPANEL_GROUPCOLORS
Structure used to store task panel group colorization information for various parts of the group.
Definition XTPTaskPanelPaintManager.h:54
XTP_TASKPANEL_GROUPCOLORS::dHeadGradientFactor
double dHeadGradientFactor
Value used to calculate the gradient of the group header.
Definition XTPTaskPanelPaintManager.h:61
XTP_TASKPANEL_GROUPCOLORS::clrClientLinkSelected
CXTPPaintManagerColor clrClientLinkSelected
Color of links within the client or "body" of the group.
Definition XTPTaskPanelPaintManager.h:74
XTP_TASKPANEL_GROUPCOLORS::clrClientLinkHot
CXTPPaintManagerColor clrClientLinkHot
Color of "hot" links within the client or "body" of the group.
Definition XTPTaskPanelPaintManager.h:71
XTP_TASKPANEL_GROUPCOLORS::clrClientBorder
CXTPPaintManagerColor clrClientBorder
Color of the client group border.
Definition XTPTaskPanelPaintManager.h:59
XTP_TASKPANEL_GROUPCOLORS::clrClientText
CXTPPaintManagerColor clrClientText
Color of text within the client or "body" of the group.
Definition XTPTaskPanelPaintManager.h:67
XTP_TASKPANEL_GROUPCOLORS::clrHead
CXTPPaintManagerColorGradient clrHead
Color gradient used for the background color of group headers.
Definition XTPTaskPanelPaintManager.h:55
XTP_TASKPANEL_GROUPCOLORS::clrClient
CXTPPaintManagerColorGradient clrClient
Background color of the client area of the group.
Definition XTPTaskPanelPaintManager.h:57
XTP_TASKPANEL_GROUPCOLORS::clrClientLink
CXTPPaintManagerColor clrClientLink
Color of links within the client or "body" of the group.
Definition XTPTaskPanelPaintManager.h:69
XTP_TASKPANEL_GROUPCOLORS::clrHeadTextNormal
CXTPPaintManagerColor clrHeadTextNormal
Color of normal text in the group header.
Definition XTPTaskPanelPaintManager.h:64
XTP_TASKPANEL_GROUPCOLORS::clrHeadTextHot
CXTPPaintManagerColor clrHeadTextHot
Color of "hot" text in the group header.
Definition XTPTaskPanelPaintManager.h:65


Toolkit Pro: XTPDockingPaneThemeOffice2013.h Source File

  • Source
  • DockingPane
  • Themes
XTPDockingPaneThemeOffice2013.h
Go to the documentation of this file.
1
23#if !defined(__XTPDOCKINGPANETHEMEOFFICE2013_H__)
24# define __XTPDOCKINGPANETHEMEOFFICE2013_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPDockingPaneOffice2013Theme : public CXTPDockingPaneVisualStudio2012Theme
39{
40public:
45 CXTPDockingPaneOffice2013Theme();
46
52 virtual ~CXTPDockingPaneOffice2013Theme();
53
59 virtual void RefreshMetrics();
60
67 virtual void DrawSplitter(CDC* pDC, CXTPDockingPaneSplitterWnd* pSplitter);
68
76 virtual void DrawCaption(CDC* pDC, CXTPDockingPaneTabbedContainer* pPane, CRect rc);
77
85 virtual void DrawFloatingFrame(CDC* pDC, CXTPDockingPaneMiniWnd* pPane, CRect rc);
86
94 virtual void DrawPane(CDC* pDC, CXTPDockingPaneTabbedContainer* pPane, CRect rc);
95
103 virtual void DrawSidePanel(CDC* pDC, CXTPDockingPaneSidePanel* pPane, CRect rc);
104
112 virtual void DrawCaptionButton(CDC* pDC, CXTPDockingPaneCaptionButton* pButton,
113 COLORREF clrButton);
114
124 virtual void DrawAutoHidePanel(CDC* pDC, CRect rc, XTPDockingPaneDirection direction);
125
126protected:
136 virtual void DrawTitleBar(CDC* pDC, CXTPDockingPaneBase* pPane, CRect rc, BOOL bVertical);
137};
138
139# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
141#endif // !defined(__XTPDOCKINGPANETHEMEOFFICE2013_H__)
XTPDisableNoisyWarnings.h
XTPDockingPaneDirection
XTPDockingPaneDirection
Docking direction enumeration.
Definition XTPDockingPaneDefines.h:51
XTPEnableNoisyWarnings.h
CXTPDockingPaneBase
CXTPDockingPaneBase is a standalone class.
Definition XTPDockingPaneBase.h:69
CXTPDockingPaneCaptionButton
CXTPDockingPaneCaptionButton is a standalone internal class.
Definition XTPDockingPaneCaptionButton.h:38
CXTPDockingPaneMiniWnd
CXTPDockingPaneMiniWnd is a multiple inheritance class derived from CMiniFrameWnd and CXTPDockingPane...
Definition XTPDockingPaneMiniWnd.h:42
CXTPDockingPaneOffice2013Theme
CXTPDockingPaneOffice2013Theme is used to define drawing routines specific to an Office 2013 docking ...
Definition XTPDockingPaneThemeOffice2013.h:39
CXTPDockingPaneOffice2013Theme::CXTPDockingPaneOffice2013Theme
CXTPDockingPaneOffice2013Theme()
Constructs a CXTPDockingPaneOffice2013Theme object.
CXTPDockingPaneOffice2013Theme::DrawCaptionButton
virtual void DrawCaptionButton(CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton)
Override this member function to draw a button for a tabbed caption.
CXTPDockingPaneOffice2013Theme::DrawPane
virtual void DrawPane(CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc)
Override this member function to draw a tabbed container.
CXTPDockingPaneOffice2013Theme::DrawFloatingFrame
virtual void DrawFloatingFrame(CDC *pDC, CXTPDockingPaneMiniWnd *pPane, CRect rc)
Call this method to draw the frame of a floating window.
CXTPDockingPaneOffice2013Theme::DrawTitleBar
virtual void DrawTitleBar(CDC *pDC, CXTPDockingPaneBase *pPane, CRect rc, BOOL bVertical)
This member function is called to draw a title bar for the docking pane.
CXTPDockingPaneOffice2013Theme::DrawSplitter
virtual void DrawSplitter(CDC *pDC, CXTPDockingPaneSplitterWnd *pSplitter)
Override this method to draw a splitter.
CXTPDockingPaneOffice2013Theme::DrawCaption
virtual void DrawCaption(CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc)
Override this member function to draw a caption.
CXTPDockingPaneOffice2013Theme::~CXTPDockingPaneOffice2013Theme
virtual ~CXTPDockingPaneOffice2013Theme()
Destroys a CXTPDockingPaneOffice2013Theme object, handles cleanup and deallocation.
CXTPDockingPaneOffice2013Theme::DrawAutoHidePanel
virtual void DrawAutoHidePanel(CDC *pDC, CRect rc, XTPDockingPaneDirection direction)
This method is called by the framework to draw the docking pane auto-hide panel background and splitt...
CXTPDockingPaneOffice2013Theme::DrawSidePanel
virtual void DrawSidePanel(CDC *pDC, CXTPDockingPaneSidePanel *pPane, CRect rc)
Override this member function to draw the side panel.
CXTPDockingPaneOffice2013Theme::RefreshMetrics
virtual void RefreshMetrics()
This member function is used to initialize default colors for a theme from an .INI resource.
CXTPDockingPaneSidePanel
CXTPDockingPaneSidePanel is a multiple inheritance class derived from CWnd and CXTPDockingPaneBase.
Definition XTPDockingPaneSidePanel.h:45
CXTPDockingPaneSplitterWnd
CXTPDockingPaneSplitterWnd is a CWnd derived class.
Definition XTPDockingPaneSplitterContainer.h:42
CXTPDockingPaneTabbedContainer
CXTPDockingPaneTabbedContainer is a multiple inheritance class derived from CWnd and CXTPDockingPaneB...
Definition XTPDockingPaneTabbedContainer.h:47
CXTPDockingPaneVisualStudio2012Theme
CXTPDockingPaneVisualStudio2012Theme is used to define drawing routines specific to a Visual Studio 2...
Definition XTPDockingPaneThemeVisualStudio2012.h:41


Toolkit Pro: XTPComboBoxThemeOffice2000.h Source File

  • Source
  • Controls
  • Combo
  • Themes
XTPComboBoxThemeOffice2000.h
Go to the documentation of this file.
1
23#ifndef XTPComboBoxThemeOffice2000_h__
24# define XTPComboBoxThemeOffice2000_h__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPComboBoxThemeOffice2000 : public CXTPComboBoxTheme
39{
40public:
45 CXTPComboBoxThemeOffice2000();
46
51 virtual ~CXTPComboBoxThemeOffice2000();
52
53 virtual void DrawBackground(CDC* pDC, CXTPComboBox* pComboBox);
54
63 virtual void DrawButton(CDC* pDC, CXTPComboBox* pComboBox, CRect rcBtn);
64
71 virtual void RefreshMetrics(CXTPComboBox* pComboBox);
72};
73
74# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
76#endif // XTPComboBoxThemeOffice2000_h__
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPComboBox
The CXTPComboBox class provides the functionality of a themed Windows combobox.
Definition XTPComboBox.h:42
CXTPComboBoxTheme
CXTPComboBoxTheme is a class used to perform ComboBox Theme drawing tasks.
Definition XTPComboBoxTheme.h:42
CXTPComboBoxThemeOffice2000
Used as the paint manager for a combobox control to render an Office 2000 appearance.
Definition XTPComboBoxThemeOffice2000.h:39
CXTPComboBoxThemeOffice2000::CXTPComboBoxThemeOffice2000
CXTPComboBoxThemeOffice2000()
Default constructor.
CXTPComboBoxThemeOffice2000::RefreshMetrics
virtual void RefreshMetrics(CXTPComboBox *pComboBox)
This member function is called by the theme manager to refresh the visual styles used by each compone...
CXTPComboBoxThemeOffice2000::~CXTPComboBoxThemeOffice2000
virtual ~CXTPComboBoxThemeOffice2000()
Destructor handles cleanup and deallocation.
CXTPComboBoxThemeOffice2000::DrawButton
virtual void DrawButton(CDC *pDC, CXTPComboBox *pComboBox, CRect rcBtn)
Called by the paint manager to draw the button portion of the combobox control.
CXTPComboBoxThemeOffice2000::DrawBackground
virtual void DrawBackground(CDC *pDC, CXTPComboBox *pComboBox)
This member function is called to draw the combobox background.


Toolkit Pro: Member List

CXTPChartDiagramView Member List

This is the complete list of members for CXTPChartDiagramView, including all inherited members.

AddChildView(CXTPChartElementView *pChildView) | CXTPChartElementView |
CalculateView(CXTPChartDeviceContext *pDC, CRect rcBounds) | CXTPChartDiagramView | virtual
CreateDeviceCommand(CXTPChartDeviceContext *pDC) | CXTPChartDiagramView | protectedvirtual
CreateView(CXTPChartDeviceContext *pDC) | CXTPChartDiagramView | virtual
CXTPChartDiagramView(CXTPChartDiagram *pDiagram, CXTPChartElementView *pParentView) | CXTPChartDiagramView |
CXTPChartElementView(CXTPChartElementView *pParentView) | CXTPChartElementView |
CXTPChartElementView(CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartElementView |
CXTPChartElementView(CXTPChartContainer *pContainer) | CXTPChartElementView |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
GetAt(int nIndex) const | CXTPChartElementView |
GetBounds() const | CXTPChartDiagramView |
CXTPChartElementView::GetBounds(BOOL bIncludingChildren) const | CXTPChartElementView |
GetChildren() | CXTPChartElementView |
GetCount() const | CXTPChartElementView |
GetDiagram() const | CXTPChartDiagramView |
GetLabelsView() const | CXTPChartDiagramView |
GetParentView() const | CXTPChartElementView |
GetSeriesView() const | CXTPChartDiagramView |
Is3D() const | CXTPChartObject |
m_arrChildren | CXTPChartElementView | protected
m_pContainer | CXTPChartElementView | protected
m_pDiagram | CXTPChartDiagramView | protected
m_pLabelsView | CXTPChartDiagramView | protected
m_pParentView | CXTPChartElementView | protected
m_pSeriesView | CXTPChartDiagramView | protected
m_pTitlesView | CXTPChartDiagramView | protected
m_rcBounds | CXTPChartDiagramView | protected
OnMouseWheel(UINT nFlags, short zDelta, CPoint pt) | CXTPChartDiagramView | virtual
UpdateRange(CXTPChartDeviceContext *pDC) | CXTPChartDiagramView | virtual
~CXTPChartElementView() | CXTPChartElementView | protectedvirtual


Toolkit Pro: Member List

CXTPTrackBlock Member List

This is the complete list of members for CXTPTrackBlock, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPTrackBlock() | CXTPTrackBlock |
DoPropExchange(CXTPPropExchange *pPX) | CXTPTrackBlock |
Draw(CDC *pDC, CRect rc, BOOL bSelected) | CXTPTrackBlock | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCaption() const | CXTPTrackBlock |
GetDescriptionText() const | CXTPTrackBlock |
GetHeightPercent() const | CXTPTrackBlock |
GetIndex() const | CXTPTrackBlock |
GetItem() const | CXTPTrackBlock |
GetLength() const | CXTPTrackBlock |
GetMaxLength() const | CXTPTrackBlock |
GetMinLength() const | CXTPTrackBlock |
GetPosition() const | CXTPTrackBlock |
GetRect() const | CXTPTrackBlock |
GetTooltip() const | CXTPTrackBlock | virtual
GetVerticalAlignment() const | CXTPTrackBlock |
IsKey() const | CXTPTrackBlock | virtual
IsLocked() const | CXTPTrackBlock |
IsResizable() const | CXTPTrackBlock | virtual
IsSelected() const | CXTPTrackBlock |
m_bDragging | CXTPTrackBlock | protected
m_bLocked | CXTPTrackBlock |
m_clrBlock | CXTPTrackBlock |
m_dHeightPercent | CXTPTrackBlock |
m_nIndex | CXTPTrackBlock | protected
m_nLastDragTime | CXTPTrackBlock | protected
m_nLength | CXTPTrackBlock |
m_nMaxLength | CXTPTrackBlock | protected
m_nMinLength | CXTPTrackBlock | protected
m_nMRUPosition | CXTPTrackBlock | protected
m_nPosition | CXTPTrackBlock |
m_nVerticalAlignment | CXTPTrackBlock |
m_pItem | CXTPTrackBlock |
m_rcBlock | CXTPTrackBlock |
m_strCaption | CXTPTrackBlock |
m_strDescription | CXTPTrackBlock | protected
m_strToolTip | CXTPTrackBlock | protected
Remove() | CXTPTrackBlock |
Select(BOOL bSelect=TRUE) | CXTPTrackBlock |
SetCaption(LPCTSTR lpszCaption) | CXTPTrackBlock |
SetColor(COLORREF clr) | CXTPTrackBlock |
SetDescriptionText(LPCTSTR lpszDescriptionText) | CXTPTrackBlock |
SetHeightPercent(double dHeightPercent) | CXTPTrackBlock |
SetLength(int nLength) | CXTPTrackBlock |
SetLocked(BOOL bLocked=TRUE) | CXTPTrackBlock |
SetMaxLength(int nMaxLength) | CXTPTrackBlock |
SetMinLength(int nMinLength) | CXTPTrackBlock |
SetPosition(int nPosition) | CXTPTrackBlock |
SetTooltip(LPCTSTR lpszTooltip) | CXTPTrackBlock |
SetVerticalAlignment(int nAlignment) | CXTPTrackBlock |


Toolkit Pro: Member List

CXTPSortClass Member List

This is the complete list of members for CXTPSortClass, including all inherited members.

Compare(LPARAM lParam1, LPARAM lParam2, LPARAM lParamSort) | CXTPSortClass | static
CXTPSortClass(CListCtrl *pListCtrl, const int nCol, PFNLVCOMPARE pfnCompare=NULL) | CXTPSortClass |
m_pfnCompare | CXTPSortClass | protected
m_pListCtrl | CXTPSortClass | protected
RemoveNonNumeric(CString &strSource) | CXTPSortClass | static
Sort(bool bAsc, int iType) | CXTPSortClass | virtual
SortDateTime(LPCTSTR lpszItem1, LPCTSTR lpszItem2, const short sOrder) | CXTPSortClass | static
SortDecimal(LPCTSTR lpszItem1, LPCTSTR lpszItem2, const short sOrder) | CXTPSortClass | static
SortInt(LPCTSTR lpszItem1, LPCTSTR lpszItem2, const short sOrder) | CXTPSortClass | static
SortString(LPCTSTR lpszItem1, LPCTSTR lpszItem2, const short sOrder) | CXTPSortClass | static
~CXTPSortClass() | CXTPSortClass | virtual


Toolkit Pro: XTPCalendarCustomDataProvider.h Source File

  • Source
  • Calendar
XTPCalendarCustomDataProvider.h
Go to the documentation of this file.
1
22#if !defined(_XTP_CALENDAR_CUSTOM_DATA_PROVIDER_H__)
23# define _XTP_CALENDAR_CUSTOM_DATA_PROVIDER_H__
24
25# if _MSC_VER > 1000
26# pragma once
27# endif // _MSC_VER > 1000
28
29# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
30
46class _XTP_EXT_CLASS CXTPCalendarCustomDataProvider : public CXTPCalendarData
47{
49 DECLARE_DYNAMIC(CXTPCalendarCustomDataProvider)
51public:
63 CXTPCalendarCustomDataProvider();
64
72 virtual ~CXTPCalendarCustomDataProvider();
73
78 virtual void Close();
79
80protected:
101 virtual CXTPCalendarEventsPtr DoRetrieveDayEvents(COleDateTime dtDay);
102
116 virtual void DoRemoveAllEvents();
117
136 virtual CXTPCalendarEventPtr DoRead_Event(DWORD dwEventID);
137
156 virtual CXTPCalendarRecurrencePatternPtr DoRead_RPattern(DWORD dwPatternID);
157
179 virtual BOOL DoCreate_Event(CXTPCalendarEvent* pEvent, DWORD& rdwNewEventID);
180
201 virtual BOOL DoUpdate_Event(CXTPCalendarEvent* pEvent);
202
223 virtual BOOL DoDelete_Event(CXTPCalendarEvent* pEvent);
224
246 virtual BOOL DoCreate_RPattern(CXTPCalendarRecurrencePattern* pPattern, DWORD& rdwNewPatternID);
247
267 virtual BOOL DoUpdate_RPattern(CXTPCalendarRecurrencePattern* pPattern);
268
289 virtual BOOL DoDelete_RPattern(CXTPCalendarRecurrencePattern* pPattern);
290
310 virtual CXTPCalendarEventsPtr DoGetAllEvents_raw();
311
333 virtual CXTPCalendarEventsPtr DoGetUpcomingEvents(COleDateTime dtFrom,
334 COleDateTimeSpan spPeriod);
335};
336
338
339# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
340#endif // !defined(_XTP_CALENDAR_CUSTOM_DATA_PROVIDER_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCalendarCustomDataProvider
Custom implementation of XTPCalendarData based on notifications.
Definition XTPCalendarCustomDataProvider.h:47
CXTPCalendarCustomDataProvider::DoRead_Event
virtual CXTPCalendarEventPtr DoRead_Event(DWORD dwEventID)
Read event from the data source.
CXTPCalendarCustomDataProvider::DoRead_RPattern
virtual CXTPCalendarRecurrencePatternPtr DoRead_RPattern(DWORD dwPatternID)
Read recurrence pattern from the data source.
CXTPCalendarCustomDataProvider::DoCreate_RPattern
virtual BOOL DoCreate_RPattern(CXTPCalendarRecurrencePattern *pPattern, DWORD &rdwNewPatternID)
Creates a new recurrence pattern in the data source.
CXTPCalendarCustomDataProvider::DoDelete_Event
virtual BOOL DoDelete_Event(CXTPCalendarEvent *pEvent)
Deletes an event from the data source.
CXTPCalendarCustomDataProvider::DoUpdate_RPattern
virtual BOOL DoUpdate_RPattern(CXTPCalendarRecurrencePattern *pPattern)
Updates a recurrence pattern in the database.
CXTPCalendarCustomDataProvider::DoCreate_Event
virtual BOOL DoCreate_Event(CXTPCalendarEvent *pEvent, DWORD &rdwNewEventID)
Creates a new event in the data source.
CXTPCalendarCustomDataProvider::~CXTPCalendarCustomDataProvider
virtual ~CXTPCalendarCustomDataProvider()
Default Destructor.
CXTPCalendarCustomDataProvider::DoGetUpcomingEvents
virtual CXTPCalendarEventsPtr DoGetUpcomingEvents(COleDateTime dtFrom, COleDateTimeSpan spPeriod)
This method implements getting a collection of events expiring in the period from dtFrom during next ...
CXTPCalendarCustomDataProvider::DoDelete_RPattern
virtual BOOL DoDelete_RPattern(CXTPCalendarRecurrencePattern *pPattern)
Deletes a recurrence pattern from the database.
CXTPCalendarCustomDataProvider::DoUpdate_Event
virtual BOOL DoUpdate_Event(CXTPCalendarEvent *pEvent)
Updates event properties in the data source.
CXTPCalendarCustomDataProvider::Close
virtual void Close()
Call this member function to close the connection to a data source.
CXTPCalendarCustomDataProvider::DoRemoveAllEvents
virtual void DoRemoveAllEvents()
Removes all events from the data source.
CXTPCalendarCustomDataProvider::DoRetrieveDayEvents
virtual CXTPCalendarEventsPtr DoRetrieveDayEvents(COleDateTime dtDay)
Retrieves day events for a specified day from the data source.
CXTPCalendarCustomDataProvider::CXTPCalendarCustomDataProvider
CXTPCalendarCustomDataProvider()
Default constructor.
CXTPCalendarCustomDataProvider::DoGetAllEvents_raw
virtual CXTPCalendarEventsPtr DoGetAllEvents_raw()
This method implements Getting all events without generating recurrence occurrences.
CXTPCalendarData
This class defines an abstract representation of the Calendar control data with all necessary methods...
Definition XTPCalendarData.h:97
CXTPCalendarEvent
This class represents the data of a single Event used in the Calendar control.
Definition XTPCalendarEvent.h:77
CXTPCalendarRecurrencePattern
This class represents a recurrence pattern and stores data to build a schedule for recurrence events.
Definition XTPCalendarRecurrencePattern.h:398


Toolkit Pro: Member List

CXTPCaptionButtonTheme Member List

This is the complete list of members for CXTPCaptionButtonTheme, including all inherited members.

CXTPButtonTheme() | CXTPButtonTheme |
CXTPCaptionButtonTheme() | CXTPCaptionButtonTheme |
CXTPCmdTarget() | CXTPCmdTarget |
CXTPControlTheme() | CXTPControlTheme |
DrawButton(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
DrawButtonBackground(CDC *pDC, CXTPButton *pButton) | CXTPCaptionButtonTheme | protectedvirtual
DrawButtonText(CDC *pDC, CXTPButton *pButton) | CXTPCaptionButtonTheme | protectedvirtual
DrawButtonVisualStyleBackground(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
DrawCheckBoxMark(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
DrawFocusRect(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
DrawGroupBox(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
DrawPushButtonDropDown(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
DrawPushButtonIcon(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
DrawPushButtonText(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
DrawRadioButtonMark(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetTextColor(CXTPButton *pButton) | CXTPCaptionButtonTheme | protectedvirtual
GetThemeStyle() const | CXTPControlTheme |
m_crBack | CXTPButtonTheme |
m_crBorder3DHilite | CXTPButtonTheme |
m_crBorder3DShadow | CXTPButtonTheme |
m_crBorderHilite | CXTPButtonTheme |
m_crBorderShadow | CXTPButtonTheme |
m_crText | CXTPButtonTheme |
m_crTextCheck | CXTPButtonTheme |
m_crTextDisabled | CXTPButtonTheme |
m_nTheme | CXTPControlTheme | protected
RefreshMetrics(CXTPButton *pButton) | CXTPButtonTheme | virtual
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static
~CXTPButtonTheme() | CXTPButtonTheme | virtual


Toolkit Pro: Member List

CXTPChartEllipse Member List

This is the complete list of members for CXTPChartEllipse, including all inherited members.

ApplyCenterPoint(const CXTPPoint3d &point) const | CXTPChartEllipse
CalcEllipseAngleFromCircleAngle(double angle) const | CXTPChartEllipse
CalcEllipsePoint(double angle) const | CXTPChartEllipse
CalcEllipseRadius(double angle) const | CXTPChartEllipse
CalcEllipseSectorArea(double startAngle, double finishAngle) const | CXTPChartEllipse
CalcEllipseSectorFinishAngle(double areaSector, double startAngle) const | CXTPChartEllipse
CXTPChartEllipse() | CXTPChartEllipse
CXTPChartEllipse(const CXTPPoint3d &ptCenter, double dMajorSemiaxis, double dMinorSemiaxis) | CXTPChartEllipse
GetArea() const | CXTPChartEllipse
GetCenter() const | CXTPChartEllipse
m_dArea | CXTPChartEllipse
m_dMajorSemiaxis | CXTPChartEllipse
m_dMinorSemiaxis | CXTPChartEllipse
m_ptCenter | CXTPChartEllipse
Polar2Cartesian(double angle, double radius) const | CXTPChartEllipse


Toolkit Pro: Member List

CXTPDockingPaneTabColorSetOfficePanel Member List

This is the complete list of members for CXTPDockingPaneTabColorSetOfficePanel, including all inherited members.

CXTPDockingPaneTabColorSetOfficePanel() | CXTPDockingPaneTabColorSetOfficePanel |
CXTPDockingPaneTabColorSetVisualStudio2003(BOOL bHighlightSelected) | CXTPDockingPaneTabColorSetVisualStudio2003 |
CXTPTabPaintManagerColorSet() | CXTPTabPaintManagerColorSet |
FillClient(CDC *pDC, CRect rc, CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
FillFramePartRect(CDC *pDC, CRect rc, CWnd *pWnd, CWnd *pSite) | CXTPDockingPaneTabColorSetVisualStudio2003 |
FillHeader(CDC *pDC, CRect rc, CXTPTabManager *pTabManager) | CXTPDockingPaneTabColorSetVisualStudio2003 | virtual
FillNavigateButton(CDC *pDC, CXTPTabManagerNavigateButton *pButton, CRect &rc) | CXTPTabColorSetOffice2003 | virtual
FillPropertyButton(CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem) | CXTPDockingPaneTabColorSetVisualStudio2003 | virtual
FillStateButton(CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerColorSet | virtual
GetClientColor(CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
GetItemColor(CXTPTabManagerItem *pItem) | CXTPTabPaintManagerColorSet | virtual
GradientFill(CDC *pDC, CRect rc, COLORREF clrLight, COLORREF clrDark, XTPTabPosition position) | CXTPTabPaintManagerColorSet |
IsAppThemed() const | CXTPTabPaintManagerColorSet | virtual
m_bLunaTheme | CXTPTabColorSetOffice2003 | protected
m_clrActiveFilesBack | CXTPTabPaintManagerColorSet |
m_clrActiveFilesBackHighlighted | CXTPTabPaintManagerColorSet |
m_clrActiveFilesBackPressed | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyph | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyphHighlighted | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyphPressed | CXTPTabPaintManagerColorSet |
m_clrAutoHideFace | CXTPTabPaintManagerColorSet |
m_clrBorderHighlight | CXTPTabPaintManagerColorSet |
m_clrButtonBorder | CXTPTabPaintManagerColorSet |
m_clrButtonBorderHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonBorderHot | CXTPTabPaintManagerColorSet |
m_clrButtonBorderKeyTips | CXTPTabPaintManagerColorSet |
m_clrButtonBorderTabContext1 | CXTPTabPaintManagerColorSet |
m_clrButtonBorderTabContext2 | CXTPTabPaintManagerColorSet |
m_clrButtonHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonHighlightedClose | CXTPTabPaintManagerColorSet |
m_clrButtonNormal | CXTPTabPaintManagerColorSet |
m_clrButtonPressed | CXTPTabPaintManagerColorSet |
m_clrButtonSelected | CXTPTabPaintManagerColorSet |
m_clrButtonSelectedHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonSelectedPressed | CXTPTabPaintManagerColorSet |
m_clrControlFace | CXTPTabPaintManagerColorSet |
m_clrFrameBorder | CXTPTabPaintManagerColorSet |
m_clrHeaderFace | CXTPTabPaintManagerColorSet |
m_clrNavigateButtonBorder | CXTPTabColorSetOffice2003 | protected
m_clrPaneFace | CXTPTabPaintManagerColorSet |
m_clrTabClientBack | CXTPTabPaintManagerColorSet |
m_clrTabClientBorder | CXTPTabPaintManagerColorSet |
m_clrTextDisabled | CXTPTabPaintManagerColorSet |
m_clrTextHighlight | CXTPTabPaintManagerColorSet |
m_clrTextHighlightClose | CXTPTabPaintManagerColorSet |
m_clrTextNormal | CXTPTabPaintManagerColorSet |
m_clrTextPressed | CXTPTabPaintManagerColorSet |
m_clrTextSelected | CXTPTabPaintManagerColorSet |
m_clrTextSelectedHighlighted | CXTPTabPaintManagerColorSet |
m_clrTextSelectedPressed | CXTPTabPaintManagerColorSet |
m_csExcelNormal | CXTPTabPaintManagerColorSet |
m_csExcelSelected | CXTPTabPaintManagerColorSet |
m_csPropertyPage | CXTPTabPaintManagerColorSet |
m_csPropertyPage2003 | CXTPTabPaintManagerColorSet |
m_csStateButton | CXTPTabPaintManagerColorSet |
m_pPaintManager | CXTPTabPaintManagerColorSet | protected
Rectangle(CDC *pDC, CRect rc, int nPen, int nBrush) | CXTPTabColorSetOffice2003 |
RefreshMetrics() | CXTPDockingPaneTabColorSetOfficePanel | virtual
SelectClipRgn(CDC *pDC, CRect rcClient, CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
SetTextColor(CDC *pDC, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerColorSet | virtual
~CXTPTabPaintManagerColorSet() | CXTPTabPaintManagerColorSet | virtual


Toolkit Pro: XTPSize.h Source File

  • Source
  • Common
  • Base
  • Types
XTPSize.h
Go to the documentation of this file.
1
23#if !defined(__XTPSIZE_H__)
24# define __XTPSIZE_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38template<class T>
39class CXTPSizeT
40{
41public:
46 CXTPSizeT()
47 : Width(T(0))
48 , Height(T(0))
49 {
50 }
51
58 CXTPSizeT(T width, T height)
59 : Width(width)
60 , Height(height)
61 {
62 }
63
70 CXTPSizeT(const CXTPSizeT& other)
71 : Width(other.Width)
72 , Height(other.Height)
73 {
74 }
75
83 CXTPSizeT operator+(const CXTPSizeT& other) const
84 {
85 return CXTPSizeT(Width + other.Width, Height + other.Height);
86 }
87
95 CXTPSizeT operator-(const CXTPSizeT& other) const
96 {
97 return CXTPSizeT(Width - other.Width, Height - other.Height);
98 }
99
107 bool operator==(const CXTPSizeT& other) const
108 {
109 return (&other == this) || (Width == other.Width && Height == other.Height);
110 }
111
119 bool operator!=(const CXTPSizeT& other) const
120 {
121 return !(*this == other);
122 }
123
131 bool IsEmpty() const
132 {
133 return (T(0) == Width && T(0) == Height);
134 }
135
136 template<class U>
137 operator CXTPSizeT<U>() const
138 {
139 return CXTPSizeT<U>(U(Width), U(Height));
140 }
141
142public:
143 T Width;
144 T Height;
145};
146
150typedef CXTPSizeT<int> CXTPSizeI;
151
155typedef CXTPSizeT<float> CXTPSizeF;
156
160typedef CXTPSizeT<double> CXTPSizeD;
161
162# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
164#endif // !defined(__XTPSIZE_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPSizeI
CXTPSizeT< int > CXTPSizeI
CXTPSizeT shortcut for integer size object.
Definition XTPSize.h:150
CXTPSizeD
CXTPSizeT< double > CXTPSizeD
CXTPSizeT shortcut for double size object.
Definition XTPSize.h:160
CXTPSizeF
CXTPSizeT< float > CXTPSizeF
CXTPSizeT shortcut for float size object.
Definition XTPSize.h:155
CXTPSizeT
This class incapsulates size data.
Definition XTPSize.h:40
CXTPSizeT::operator-
CXTPSizeT operator-(const CXTPSizeT &other) const
Performs subtraction of two size objects.
Definition XTPSize.h:95
CXTPSizeT::Width
T Width
The Width component.
Definition XTPSize.h:143
CXTPSizeT::operator==
bool operator==(const CXTPSizeT &other) const
Compares two sizes.
Definition XTPSize.h:107
CXTPSizeT::Height
T Height
The Height component.
Definition XTPSize.h:144
CXTPSizeT::CXTPSizeT
CXTPSizeT(T width, T height)
Constructs a CXTPSizeT object.
Definition XTPSize.h:58
CXTPSizeT::CXTPSizeT
CXTPSizeT()
Constructs an empty CXTPSizeT object with all components equal to 0.
Definition XTPSize.h:46
CXTPSizeT::IsEmpty
bool IsEmpty() const
Determines if the size object is empty.
Definition XTPSize.h:131
CXTPSizeT::CXTPSizeT
CXTPSizeT(const CXTPSizeT &other)
Constructs a CXTPSizeT object from another CXTPSizeT object.
Definition XTPSize.h:70
CXTPSizeT::operator!=
bool operator!=(const CXTPSizeT &other) const
Compares two sizes.
Definition XTPSize.h:119
CXTPSizeT::operator+
CXTPSizeT operator+(const CXTPSizeT &other) const
Performs addition of two size objects.
Definition XTPSize.h:83


Toolkit Pro: XTPRibbonBackstageSeparatorThemeVisualStudio2019.h Source File

  • Source
  • Ribbon
  • Backstage
XTPRibbonBackstageSeparatorThemeVisualStudio2019.h
Go to the documentation of this file.
1
23#if !defined(__XTPRIBBONBACKSTAGESEPARATORTHEMEVISUALSTUDIO2019_H__)
24# define __XTPRIBBONBACKSTAGESEPARATORTHEMEVISUALSTUDIO2019_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPRibbonBackstageSeparator;
34
35class _XTP_EXT_CLASS CXTPRibbonBackstageSeparatorThemeVisualStudio2019
36 : public CXTPRibbonBackstageSeparatorThemeOffice2013
37{
38public:
39 CXTPRibbonBackstageSeparatorThemeVisualStudio2019();
40};
41
42# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
44#endif // !defined(__XTPRIBBONBACKSTAGESEPARATORTHEMEVISUALSTUDIO2019_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h


Toolkit Pro: XTPGaugeMeterType.h Source File

  • Source
  • Gauge
  • Types
XTPGaugeMeterType.h
Go to the documentation of this file.
1
22#if !defined(__XTPGAUGEMETERTYPE_H__)
23# define __XTPGAUGEMETERTYPE_H__
24
25# if _MSC_VER > 1000
26# pragma once
27# endif // _MSC_VER > 1000
28
29# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
30
44class _XTP_EXT_CLASS CXTPGaugeMeterType : public CXTPGaugeBaseType
45{
46 DECLARE_DYNCREATE(CXTPGaugeMeterType);
47
48private:
49 CXTPGaugeMeterType();
50
51public:
56 ~CXTPGaugeMeterType();
57
64 virtual LPCWSTR GetTypeName() const;
65
77 double GetMin() const;
78
92 double GetMin(UINT nDimension) const;
93
107 BOOL SetMin(double dValue);
108
124 BOOL SetMin(UINT nDimension, double dValue);
125
140 BOOL UnsetMin(UINT nDimension);
141
153 double GetMax() const;
154
169 double GetMax(UINT nDimension) const;
170
185 BOOL SetMax(double dValue);
186
203 BOOL SetMax(UINT nDimension, double dValue);
204
220 BOOL UnsetMax(UINT nDimension);
221
233 double GetCurrent() const;
234
248 double GetCurrent(UINT nDimension) const;
249
265 BOOL SetCurrent(double dValue);
266
284 BOOL SetCurrent(UINT nDimension, double dValue);
285
300 BOOL UnsetCurrent(UINT nDimension);
301
308 UINT GetDimensionCount() const;
309
310protected:
312 virtual void OnInit();
315private:
316 struct DimensionData
317 {
318 DimensionData();
319
320 double dMin;
321 double dMax;
322 double dCurrent;
323 };
324
325 DimensionData* GetDimData(UINT nDim);
326 const DimensionData* GetDimData(UINT nDim) const;
327 static CString FormatJPath(UINT nDim, LPCTSTR pRelJPath);
328
329private:
330 static const double m_dNan;
331 CMap<UINT, UINT, DimensionData, DimensionData&> m_DimData;
332 UINT m_nDimCount;
333};
334
335AFX_INLINE double CXTPGaugeMeterType::GetMin() const
336{
337 return GetMin(UINT_MAX);
338}
339
340AFX_INLINE BOOL CXTPGaugeMeterType::SetMin(double dValue)
341{
342 return SetMin(UINT_MAX, dValue);
343}
344
345AFX_INLINE BOOL CXTPGaugeMeterType::UnsetMin(UINT nDimension)
346{
347 return SetMin(nDimension, m_dNan);
348}
349
350AFX_INLINE double CXTPGaugeMeterType::GetMax() const
351{
352 return GetMax(UINT_MAX);
353}
354
355AFX_INLINE BOOL CXTPGaugeMeterType::SetMax(double dValue)
356{
357 return SetMax(UINT_MAX, dValue);
358}
359
360AFX_INLINE BOOL CXTPGaugeMeterType::UnsetMax(UINT nDimension)
361{
362 return SetMax(nDimension, m_dNan);
363}
364
365AFX_INLINE double CXTPGaugeMeterType::GetCurrent() const
366{
367 return GetCurrent(UINT_MAX);
368}
369
370AFX_INLINE BOOL CXTPGaugeMeterType::SetCurrent(double dValue)
371{
372 return SetCurrent(UINT_MAX, dValue);
373}
374
375AFX_INLINE BOOL CXTPGaugeMeterType::UnsetCurrent(UINT nDimension)
376{
377 return SetCurrent(nDimension, m_dNan);
378}
379
380AFX_INLINE const CXTPGaugeMeterType::DimensionData* CXTPGaugeMeterType::GetDimData(UINT nDim) const
381{
382 return const_cast< CXTPGaugeMeterType*>(this)->GetDimData(nDim);
383}
384
385# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
386
387#endif // !defined(__XTPGAUGEMETERTYPE_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPGaugeBaseType
A base class for all gauge types.
Definition XTPGaugeBaseType.h:44
CXTPGaugeMeterType
Implements a Meter gauge type.
Definition XTPGaugeMeterType.h:45
CXTPGaugeMeterType::SetMax
BOOL SetMax(double dValue)
Sets the maximum acceptable value in the value range.
Definition XTPGaugeMeterType.h:355
CXTPGaugeMeterType::~CXTPGaugeMeterType
~CXTPGaugeMeterType()
Handles meter gauge type destruction.
CXTPGaugeMeterType::SetMax
BOOL SetMax(UINT nDimension, double dValue)
Sets the maximum acceptable value in the value range.
CXTPGaugeMeterType::SetCurrent
BOOL SetCurrent(UINT nDimension, double dValue)
Sets/clears the currently reflected value.
CXTPGaugeMeterType::GetDimensionCount
UINT GetDimensionCount() const
Obtains the number of available dimensions.
CXTPGaugeMeterType::GetMax
double GetMax(UINT nDimension) const
Gets the maximum acceptable value in the value range.
CXTPGaugeMeterType::SetMin
BOOL SetMin(UINT nDimension, double dValue)
Sets the minimum acceptable value in the value range.
CXTPGaugeMeterType::UnsetMax
BOOL UnsetMax(UINT nDimension)
Clears the maximum acceptable value in the value range.
Definition XTPGaugeMeterType.h:360
CXTPGaugeMeterType::UnsetMin
BOOL UnsetMin(UINT nDimension)
Clears the minimum acceptable value in the value range.
Definition XTPGaugeMeterType.h:345
CXTPGaugeMeterType::GetCurrent
double GetCurrent(UINT nDimension) const
Gets the currently reflected value.
CXTPGaugeMeterType::SetMin
BOOL SetMin(double dValue)
Sets the minimum acceptable value in the value range.
Definition XTPGaugeMeterType.h:340
CXTPGaugeMeterType::SetCurrent
BOOL SetCurrent(double dValue)
Sets/clears the currently reflected value.
Definition XTPGaugeMeterType.h:370
CXTPGaugeMeterType::GetTypeName
virtual LPCWSTR GetTypeName() const
Obtains implementation specified type name.
CXTPGaugeMeterType::UnsetCurrent
BOOL UnsetCurrent(UINT nDimension)
Clears the currently reflected value.
Definition XTPGaugeMeterType.h:375
CXTPGaugeMeterType::GetMin
double GetMin() const
Gets the minimum acceptable value in the value range.
Definition XTPGaugeMeterType.h:335
CXTPGaugeMeterType::GetMax
double GetMax() const
Gets the maximum acceptable value in the value range.
Definition XTPGaugeMeterType.h:350
CXTPGaugeMeterType::GetCurrent
double GetCurrent() const
Gets the currently reflected value.
Definition XTPGaugeMeterType.h:365
CXTPGaugeMeterType::GetMin
double GetMin(UINT nDimension) const
Gets the minimum acceptable value in the value range.


Toolkit Pro: Member List

CXTPDockingPaneSplitterWnd Member List

This is the complete list of members for CXTPDockingPaneSplitterWnd, including all inherited members.

Create(CXTPDockingPaneSplitterContainer *pContainer, CXTPDockingPaneBase *pFirst, CXTPDockingPaneBase *pSecond) | CXTPDockingPaneSplitterWnd |
Create(CXTPDockingPaneManager *pManager, BOOL bHoriz) | CXTPDockingPaneSplitterWnd |
CXTPDockingPaneSplitterWnd() | CXTPDockingPaneSplitterWnd | protected
GetContainer() const | CXTPDockingPaneSplitterWnd |
GetDockingPaneManager() const | CXTPDockingPaneSplitterWnd |
GetPaneBase(BOOL bFirst=TRUE) | CXTPDockingPaneSplitterWnd |
GetPaneDirection() const | CXTPDockingPaneSplitterWnd | inline
IsHorizontal() const | CXTPDockingPaneSplitterWnd |
~CXTPDockingPaneSplitterWnd() | CXTPDockingPaneSplitterWnd | protected


Toolkit Pro: Member List

CXTPFlowGraphEditItem Member List

This is the complete list of members for CXTPFlowGraphEditItem, including all inherited members.

Create(CXTPFlowGraphElement *pElement) | CXTPFlowGraphEditItem |
CXTPFlowGraphEditItem() | CXTPFlowGraphEditItem |
m_bEscapeKey | CXTPFlowGraphEditItem | protected
m_pElement | CXTPFlowGraphEditItem | protected
m_xtpFont | CXTPFlowGraphEditItem | protected


Toolkit Pro: Member List

CXTPDropSource Member List

This is the complete list of members for CXTPDropSource, including all inherited members.

CXTPDropSource() | CXTPDropSource |
GiveFeedback(DWORD dwEffect) | CXTPDropSource |
m_uiRefCount | CXTPDropSource | protected
QueryContinueDrag(BOOL bEsc, DWORD dwKeyState) | CXTPDropSource |
QueryInterface(REFIID riid, LPVOID *ppReturn) | CXTPDropSource |
~CXTPDropSource() | CXTPDropSource | virtual


Toolkit Pro: Member List

CXTPCalendarVisualStudio2017Theme Member List

This is the complete list of members for CXTPCalendarVisualStudio2017Theme, including all inherited members.

_GetAtGrow_BusyStatusBrushValue(int eBusyStatus, BOOL bGrow) | CXTPCalendarPaintManager | protected
_Init() | CXTPCalendarPaintManager | virtual
AddViewPart(CXTPCalendarViewPart *pPart) | CXTPCalendarPaintManager | protected
AdjustTimeFont(CDC *pDC, CRect rcCell) | CXTPCalendarPaintManager |
BEGIN_VIEW_PART(ControlPart, XTPCalendarViewPart) virtual void RefreshMetrics() | CXTPCalendarPaintManager |
CalcEventSize(CDC *c, CXTPCalendarTimeLineViewEvent *pViewEvent) | CXTPCalendarPaintManager | virtual
CalcWidth(CDC *pDC, const CString &strHour, const CString &strMin, int nHourHeight, int &nWidth) | CXTPCalendarPaintManager |
CXTPCalendarOffice2000Theme() | CXTPCalendarOffice2000Theme |
CXTPCalendarOffice2013Theme() | CXTPCalendarOffice2013Theme |
CXTPCalendarPaintManager() | CXTPCalendarPaintManager |
CXTPCalendarVisualStudio2017Theme() | CXTPCalendarVisualStudio2017Theme |
CXTPCmdTarget() | CXTPCmdTarget |
DrawBigHourCell(CDC *pDC, CRect rc, CString strHour, CString strMin, int nRowPerHour, BOOL bFillBackground=TRUE, BOOL bCurrentTime=FALSE) | CXTPCalendarPaintManager | virtual
DrawBitmap(CImageList *pImageList, CDC *pDC, CRect rcView, int iIcon, UINT uFlags=0) | CXTPCalendarPaintManager | virtual
DrawBitmap(UINT nIDResource, CDC *pDC, CRect rcBitmap) | CXTPCalendarPaintManager | virtual
DrawBorder(CDC *pDC, CRect rcView, CXTPCalendarWeekViewEvent *pWeekViewEvent) | CXTPCalendarPaintManager | virtual
DrawBusyStatus(CDC *pDC, CRect &rcRect, int eBusyStatus) | CXTPCalendarPaintManager | virtual
DrawBusyStatus(CDC *pDC, CRgn &rgnBusy, int eBusyStatus) | CXTPCalendarPaintManager | virtual
DrawClock(CDC *pDC, COleDateTime dtClockTime, CRect rcView, COLORREF clrBackground, XTPCalendarClockAlignFlags cafAlign) | CXTPCalendarPaintManager | virtual
DrawDayHeader(CDC *pDC, CRect rcDay, int nHeaderHeight, CString strHeader, BOOL bIsCurrent=FALSE, BOOL bIsSelected=FALSE) | CXTPCalendarPaintManager | virtual
DrawEvent(CDC *pDC, const CRect &rcEvents, CXTPCalendarTimeLineViewEvent *pViewEvent) | CXTPCalendarPaintManager | virtual
DrawExpandSigns(CDC *pDC, CXTPCalendarDayView *pView, const CRect &rcTSHours) | CXTPCalendarPaintManager | virtual
DrawGroup(CDC *pDC, const CRect &rcRect, CXTPCalendarTimeLineViewGroup *pGroup) | CXTPCalendarPaintManager | virtual
DrawHeader(CDC *pDC, CRect &rcHeader, BOOL bIsSelected, BOOL bIsCurrent, const CXTPPaintManagerColorGradient &grclr, COLORREF clrUnderLineHdr) | CXTPCalendarOffice2013Theme | virtual
CXTPCalendarOffice2000Theme::DrawHeader(CDC *pDC, CRect &rcHeader, BOOL bIsSelected, BOOL bIsCurrent) | CXTPCalendarPaintManager | virtual
DrawHorizontalLine(CDC *pDC, int xPos, int yPos, int cx) | CXTPCalendarPaintManager | virtual
DrawHourCell(CDC *pDC, CRect rc, CString strText, BOOL bFillBackground=TRUE, BOOL bCurrentTime=FALSE) | CXTPCalendarPaintManager | virtual
DrawIconChar(CDC *pDC, CRect rc, TCHAR ch) | CXTPCalendarPaintManager | virtual
DrawIcons(CDC *pDC, CXTPCalendarViewEvent *pViewEvent) | CXTPCalendarPaintManager | virtual
DrawLine(CDC *pDC, int xPos, int yPos, int cx, int cy) | CXTPCalendarPaintManager | virtual
DrawNowLine(CDC *pDC, CXTPCalendarDayView *pView, CRect rc, int y, BOOL bDrawBk=FALSE) | CXTPCalendarPaintManager | virtual
DrawNowLine(CDC *pDC, CXTPCalendarDayView *pView, CXTPCalendarDayViewTimeScale *pScale, CRect rc, int y, BOOL bDrawBk=FALSE) | CXTPCalendarPaintManager | virtual
DrawShadow(CDC *pDC, const CRect &rcRect) | CXTPCalendarPaintManager | virtual
DrawSubj(CDC *pDC, CXTPCalendarWeekViewEvent *pWeekViewEvent) | CXTPCalendarPaintManager | virtual
DrawTimes(CDC *pDC, CXTPCalendarWeekViewEvent *pWeekViewEvent) | CXTPCalendarPaintManager | virtual
DrawVerticalLine(CDC *pDC, int xPos, int yPos, int cy) | CXTPCalendarPaintManager | virtual
EnableTheme(BOOL bEnableTheme) | CXTPCalendarPaintManager |
END_VIEW_PART(ControlPart) BEGIN_VIEW_PART(DayViewTimeScaleHeaderPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewTimeScaleHeaderPart) BEGIN_VIEW_PART(DayViewTimeScaleCellPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewTimeScaleCellPart) BEGIN_VIEW_PART(DayViewCellPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewCellPart) BEGIN_VIEW_PART(DayViewWorkCellPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewWorkCellPart) BEGIN_VIEW_PART(DayViewNonworkCellPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewNonworkCellPart) BEGIN_VIEW_PART(DayMonthViewHeaderPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayMonthViewHeaderPart) BEGIN_VIEW_PART(DayViewHeaderPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewHeaderPart) BEGIN_VIEW_PART(DayViewGroupHeaderPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewGroupHeaderPart) BEGIN_VIEW_PART(DayViewAllDayEventsPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewAllDayEventsPart) BEGIN_VIEW_PART(DayViewAllDayEventScrollIconsPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewAllDayEventScrollIconsPart) BEGIN_VIEW_PART(DayViewEventPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewEventPart) BEGIN_VIEW_PART(MonthViewGridPart | CXTPCalendarPaintManager |
END_VIEW_PART(MonthViewGridPart) BEGIN_VIEW_PART(MonthViewHeaderPart | CXTPCalendarPaintManager |
END_VIEW_PART(MonthViewHeaderPart) BEGIN_VIEW_PART(MonthViewEventPart | CXTPCalendarPaintManager |
END_VIEW_PART(MonthViewEventPart) BEGIN_VIEW_PART(WeekViewPart | CXTPCalendarPaintManager |
END_VIEW_PART(WeekViewPart) BEGIN_VIEW_PART(WeekViewEventPart | CXTPCalendarPaintManager |
END_VIEW_PART(WeekViewEventPart) BEGIN_VIEW_PART(TimeLineViewTimeScalePart_Day | CXTPCalendarPaintManager |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAskItemTextFlags() const | CXTPCalendarPaintManager |
GetBusyStatusBrush(int nBusyStatus) | CXTPCalendarPaintManager |
GetClockSize() | CXTPCalendarPaintManager | virtual
GetCurrentSystemTheme() | CXTPCalendarPaintManager |
GetEventBackColor(CXTPCalendarEvent *pEvent) | CXTPCalendarOffice2013Theme | virtual
CXTPCalendarOffice2000Theme::GetEventBackColor(CXTPCalendarEvent *pEvent, COLORREF crDefault) | CXTPCalendarPaintManager | virtual
GetEventEdgeColor(CXTPCalendarEvent *pEvent) | CXTPCalendarOffice2013Theme | virtual
GetExpandSignSize() | CXTPCalendarPaintManager | virtual
GetPaintTheme() const | CXTPCalendarPaintManager | virtual
GetParams(CXTPCalendarDayViewGroup *pViewGroup, XTP_CALENDAR_DAYVIEWCELL_PARAMS *rCellParams) | CXTPCalendarPaintManager | virtual
idxExpandSignDown enum value | CXTPCalendarPaintManager | protected
idxExpandSignUp enum value | CXTPCalendarPaintManager | protected
idxMeeting enum value | CXTPCalendarPaintManager | protected
idxPrivate enum value | CXTPCalendarPaintManager | protected
idxRecurrenceException enum value | CXTPCalendarPaintManager | protected
idxRecurrenceOccurrence enum value | CXTPCalendarPaintManager | protected
idxReminder enum value | CXTPCalendarPaintManager | protected
InitBusyStatusDefaultColors() | CXTPCalendarPaintManager | protectedvirtual
IsThemeEnabled() | CXTPCalendarPaintManager |
m_arBusyStatusBrushes | CXTPCalendarPaintManager | protected
m_arStartCol | CXTPCalendarPaintManager |
m_arStartRow | CXTPCalendarPaintManager |
m_bEnableTheme | CXTPCalendarPaintManager | protected
m_bmpElsewherePattern | CXTPCalendarPaintManager | protected
m_bmpTentativePattern | CXTPCalendarPaintManager | protected
m_bShowMinutes | CXTPCalendarPaintManager |
m_clr3DShadow | CXTPCalendarPaintManager |
m_clrBackground | CXTPCalendarPaintManager |
m_clrBackground2 | CXTPCalendarPaintManager |
m_clrBackgroundSlave | CXTPCalendarPaintManager |
m_clrBorders | CXTPCalendarPaintManager |
m_clrButtonFace | CXTPCalendarPaintManager |
m_clrButtonFaceText | CXTPCalendarPaintManager |
m_clrClassicUnderline | CXTPCalendarPaintManager |
m_clrEventBar | CXTPCalendarPaintManager |
m_clrEventBarLine | CXTPCalendarPaintManager |
m_clrEventBorderLine | CXTPCalendarPaintManager |
m_clrHeaderBottomLine | CXTPCalendarPaintManager |
m_clrHighlight | CXTPCalendarPaintManager |
m_clrHour | CXTPCalendarPaintManager |
m_clrSelectedBackground | CXTPCalendarPaintManager |
m_clrSelectedText | CXTPCalendarPaintManager |
m_clrShadow | CXTPCalendarPaintManager |
m_clrText | CXTPCalendarPaintManager |
m_clrTextHighLightColor | CXTPCalendarPaintManager |
m_clrTextNormalColor | CXTPCalendarPaintManager |
m_clrTimeScaleBackground | CXTPCalendarPaintManager |
m_clrTimeScaleHightlite | CXTPCalendarPaintManager |
m_clrTimeScaleText | CXTPCalendarPaintManager |
m_clrUnderLineHdr | CXTPCalendarPaintManager | protected
m_clrWeekendBackground | CXTPCalendarPaintManager |
m_clrWindow | CXTPCalendarPaintManager |
m_clrWindowText | CXTPCalendarPaintManager |
m_CurrSystemTheme | CXTPCalendarPaintManager | protected
m_dwAskItemTextFlags | CXTPCalendarPaintManager | protected
m_fntTimeText | CXTPCalendarPaintManager |
m_grclrClassicSelDay | CXTPCalendarPaintManager |
m_grclrToday | CXTPCalendarPaintManager |
m_lstViewParts | CXTPCalendarPaintManager | protected
m_nHourWidth | CXTPCalendarPaintManager |
m_nMinWidth | CXTPCalendarPaintManager |
m_nPaintTheme | CXTPCalendarPaintManager | protected
m_pControl | CXTPCalendarPaintManager | protected
m_pExpandSigns | CXTPCalendarPaintManager | protected
m_pGlyphs | CXTPCalendarPaintManager | protected
m_pGlyphsFont | CXTPCalendarPaintManager | protected
m_PrintPageWidth | CXTPCalendarPaintManager |
m_szClockRect | CXTPCalendarPaintManager | protected
m_xtpBrushElsewhere | CXTPCalendarPaintManager | protected
m_xtpBrushTentative | CXTPCalendarPaintManager | protected
OnDraw(CDC *pDC, CXTPCalendarDayView *pView, CRect rc, CString strText) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarDayViewGroup *pViewGroup, CRect rc, const XTP_CALENDAR_DAYVIEWCELL_PARAMS &cellParams) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarDayViewDay *pViewDay, CRect rc, CString strText) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarDayViewGroup *pViewGroup, CRect rc, CString strText) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarDayViewGroup *pViewGroup, CRect rc, BOOL bSelected) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarDayViewGroup *pViewGroup, BOOL bDrawUp, BOOL bDrawDown, const CRect &rcIconUp, const CRect &rcIconDown, BOOL bHighlightUp, BOOL bHighlightDown) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarDayViewEvent *pViewEvent) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarMonthView *pMonthView, CRect rc, int nCollIndex, CString strText) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarWeekView *pWeekView) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarWeekViewEvent *pWeekViewEvent) | CXTPCalendarPaintManager | virtual
OnDrawDayDate(CDC *pDC, CRect rc, BOOL bToday, BOOL bSelected, BOOL bFirstMonthDay, CString strText) | CXTPCalendarPaintManager | virtual
OnDrawEvent(CDC *pDC, CXTPCalendarMonthViewEvent *pViewEvent) | CXTPCalendarPaintManager | virtual
OnDrawGrid(CDC *pDC, CXTPCalendarMonthView *pMonthView) | CXTPCalendarPaintManager | virtual
RefreshMetrics() | CXTPCalendarOffice2013Theme | virtual
SetAskItemTextFlags(DWORD dwFlags) | CXTPCalendarPaintManager |
SetBusyStatusBrush(int nBusyStatus, CBrush *pBrush, BOOL bAutodeleteBrush) | CXTPCalendarPaintManager |
SetControl(CXTPCalendarControl *pControl) | CXTPCalendarPaintManager | virtual
SetPaintTheme(XTPCalendarTheme ePaintTheme) | CXTPCalendarPaintManager | virtual
UpdateEventCategoriesDefaultColors() | CXTPCalendarOffice2013Theme | virtual
UpdateEventLabelsDefaultColors() | CXTPCalendarOffice2013Theme | virtual
UpdateGlyphs() | CXTPCalendarOffice2013Theme | virtual
XTPEnumEventGlyphs enum name | CXTPCalendarPaintManager | protected
XTPEnumExpandSigns enum name | CXTPCalendarPaintManager | protected
~CTimeLineViewPart() | CXTPCalendarPaintManager | virtual
~CXTPCalendarOffice2000Theme() | CXTPCalendarOffice2000Theme | virtual
~CXTPCalendarOffice2013Theme() | CXTPCalendarOffice2013Theme | virtual
~CXTPCalendarPaintManager() | CXTPCalendarPaintManager | virtual
~CXTPCalendarVisualStudio2017Theme() | CXTPCalendarVisualStudio2017Theme | virtual


Toolkit Pro: XTPCommandBar.h Source File

  • Source
  • CommandBars
XTPCommandBar.h
Go to the documentation of this file.
1
23#if !defined(__XTPCOMMANDBAR_H__)
24# define __XTPCOMMANDBAR_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPDockBar;
34class CXTPControls;
35class CXTPControl;
36class CXTPControlPopup;
37class CXTPCommandBars;
38class CXTPCommandBar;
39class CXTPCommandBarAnimation;
40class CXTPPaintManager;
41class CXTPImageManager;
42class CXTPPropExchange;
43struct XTP_COMMANDBARS_PROPEXCHANGE_PARAM;
44class CXTPToolTipContext;
45class CXTPCommandBarAnimation;
46class CXTPCommandBarKeyboardTip;
47class CXTPCommandBarList;
48
50# define XTP_TID_HOVER 112223
51# define XTP_TID_EXPANDED_POPUP 112224
52# define XTP_BOOL_DEFAULT 2
53# define XTP_TID_SHOWKEYBOARDTIPS 0xCCCA
61class _XTP_EXT_CLASS CXTPCommandBar
62 : public CWnd
63 , public CXTPHookManagerHookAble
64 , public CXTPAccessible
65 , IXTPPaintManagerEvents
66{
67protected:
72 CXTPCommandBar();
73
78 virtual ~CXTPCommandBar();
79
80public:
87 int IsTrackingMode() const;
88
95 CXTPControls* GetControls() const;
96
104 void SetControls(CXTPControls* pControls);
105
117 XTPBarType GetType() const;
118
125 void SetTextOrientation(XTPBarTextOrientation nTextOrientation);
126
132 XTPBarTextOrientation GetTextOrientation() const;
133
142 XTPBarPosition GetPosition() const;
143
148 void DelayLayout();
149
154 virtual void DelayRedraw();
155
167 virtual BOOL SetTrackingMode(int bMode, BOOL bSelectFirst = TRUE, BOOL bKeyboard = FALSE);
168
177 virtual BOOL LoadMenu(CMenu* pMenu, BOOL bRemoveControls = TRUE);
178
188 CXTPControl* GetControl(int nIndex) const;
189
196 int GetControlCount() const;
197
206 virtual BOOL SetSelected(int nSelected, BOOL bKeyboard = FALSE);
207
215 CXTPControl* GetSelected() const;
216
225 BOOL SetPopuped(int nPopuped, BOOL bKeyboard = FALSE);
226
232 void SetTitle(LPCTSTR lpszTitle);
233
240 CString GetTitle() const;
241
248 CXTPCommandBars* GetCommandBars() const;
249
255 void SetCommandBars(CXTPCommandBars* pCommandBars);
256
263 CWnd* GetSite() const;
264
265 void SetOwner(CWnd* pWnd);
266
273 CFrameWnd* GetFrameSite() const;
274
307 void SetFlags(DWORD dwFlagsAdd, DWORD dwFlagsRemove = 0);
308
319 BOOL SetButtons(UINT* pButtons, int nCount);
320
331 virtual BOOL LoadToolBar(UINT nIDResource, BOOL bLoadIcons = TRUE);
332
339 void SetIconSize(CSize size);
340
349 virtual CSize GetIconSize() const;
350
360 CSize GetLargeIconSize(BOOL bAutoSize) const;
361
372 void SetButtonSize(CSize size);
373
380 virtual CSize GetButtonSize() const;
381
387 void ShowTextBelowIcons(BOOL bTextBelow = TRUE);
388
395 BOOL IsTextBelowIcons() const;
396
405 virtual BOOL Popup(CXTPControlPopup* pControlPopup, BOOL bSelectFirst = FALSE);
406
413 HWND GetTrackFocus() const;
414
420 void SetTrackFocus(HWND hwnd);
421
427 virtual void SetVisible(BOOL bVisible);
428
435 virtual BOOL IsVisible() const;
436
444 virtual BOOL SetPosition(XTPBarPosition barPosition);
445
454 int FindAccel(TCHAR chAccel) const;
455
465 int FindAccelEx(UINT chAccel, BOOL& bSelectOnly) const;
466
473 BOOL IsCustomizeMode() const;
474
484 virtual DROPEFFECT OnCustomizeDragEnter(CXTPControl* pDataObject, CPoint point);
485
490 virtual void OnCustomizeDragLeave();
491
500 virtual DROPEFFECT OnCustomizeDragOver(CXTPControl* pDataObject, CPoint point);
501
510 virtual void OnCustomizeDrop(CXTPControl* pDataObject, DROPEFFECT& dropEffect, CPoint ptDrop,
511 CPoint ptDrag);
512
519 virtual BOOL IsCustomizable() const;
520
527 BOOL IsCustomizeDialogPresent() const;
528
534 void EnableCustomization(BOOL bEnable = TRUE);
535
540 virtual void OnRecalcLayout();
541
546 virtual void OnTrackLost();
547
552 virtual void OnTrackEnter();
553
560 CWnd* GetOwnerSite() const;
561
566 void InvalidateParents();
567
575 DWORD GetFlags() const;
576
583 UINT GetBarID() const;
584
590 void SetBarID(UINT nID);
591
598 virtual void OnControlSelected(BOOL bSelected, CXTPControl* pControl);
599
607 BOOL SetStatusText(const CString& strDescription);
608
616 void SetCommandBarData(DWORD_PTR dwData);
617
627 DWORD_PTR GetCommandBarData() const;
628
635 virtual CXTPCommandBar* GetParentCommandBar() const;
636
643 CXTPCommandBar* GetRootParent() const;
644
651 CXTPPaintManager* GetPaintManager() const;
652
659 CXTPImageManager* GetImageManager() const;
660
666 void SetWidth(int nWidth);
667
674 int GetWidth() const;
675
681 void SetPaintManager(CXTPPaintManager* pPaintManager);
682
688 void SetImageManager(CXTPImageManager* pImageManager);
689
697 BOOL IsLayoutRTL() const;
698
708 virtual BOOL IsDialogBar() const;
709
719 virtual BOOL IsRibbonBar() const;
720
730 virtual BOOL IsMenuTitleBar() const;
731
741 virtual BOOL IsPopupBar() const;
742
748 virtual void DoPropExchange(CXTPPropExchange* pPX);
749
756 virtual BOOL IsKeyboardCuesVisible() const;
757
764 void SetGrabFocus(BOOL bGrabFocus);
765
772 virtual void Redraw(LPCRECT lpRect = 0, BOOL bAnimate = TRUE);
773
780 virtual void DrawCommandBar(CDC* pDC, CRect rcClipBox);
781
787 void EnableAnimation(BOOL bEnable = TRUE);
788
796 void EnableDoubleBuffer(BOOL bEnable = TRUE);
797
806 BOOL IsAnimationEnabled() const;
807
820 virtual int OnHookMessage(HWND hWnd, UINT nMessage, WPARAM& wParam, LPARAM& lParam,
821 LRESULT& lResult);
822
828 virtual void EnsureVisible(CXTPControl* pControl);
829
838 XTPButtonStyle GetDefaultButtonStyle() const;
839
847 void SetDefaultButtonStyle(XTPButtonStyle buttonStyle);
848
855 void LockRedraw();
856
863 void UnlockRedraw();
864
872 void SetShowGripper(BOOL bShow);
873
882 BOOL GetShowGripper() const;
883
890 virtual CRect GetBorders();
891
899 virtual void FillCommandBarEntry(CDC* pDC);
900
909 virtual BOOL IsResizable() const;
910
911public:
920 BOOL IsKeyboardTipsVisible() const;
921
928 virtual void CreateKeyboardTips();
929
937 void OnKeyboardTipChar(UINT chAccel);
938
946 virtual void OnKeyboardTip(CXTPCommandBarKeyboardTip* pTip);
947
954 void HideKeyboardTips();
955
961 void LockMouseMove(CXTPControl* pControl);
962
967 void UnlockMouseMove();
968
969protected:
978 virtual BOOL OnHookKeyDown(UINT nChar, LPARAM lParam);
979
990 virtual CSize CalcDynamicLayout(int nLength, DWORD dwMode);
991
1018 virtual BOOL ProcessSpecialKey(XTPSpecialKey key);
1019
1024 virtual void OnControlsChanged();
1025
1032 virtual void Copy(CXTPCommandBar* pCommandBar, BOOL bRecursive = FALSE);
1033
1041 virtual int OnMouseHitTest(CPoint pt);
1042
1047 virtual void UpdateShortcuts();
1048
1049public:
1050 BOOL IsDwmEnabled() const;
1051
1052protected:
1063 UINT GetActiveDocTemplate() const;
1064
1065protected:
1073 virtual void GenerateCommandBarList(DWORD& nID, CXTPCommandBarList* pCommandBarList,
1074 XTP_COMMANDBARS_PROPEXCHANGE_PARAM* pParam);
1075
1082 virtual void RestoreCommandBarList(CXTPCommandBarList* pCommandBarList);
1083
1089 BOOL IsHelpMode() const;
1090
1095 virtual void OnRemoved();
1096
1097 virtual BOOL IsControlEnabled(const CXTPControl* pControl) const;
1098
1099protected:
1101 virtual void OnPaintManagerDestroyed(CXTPPaintManager* pPaintManager);
1102 virtual void CustomizeFindDropIndex(CXTPControl* pDataObject, const CPoint& point,
1103 CRect& rcMarker, int& nDropIndex, BOOL& bDropAfter);
1104 void CustomizeDrawMarker(CDC* pDC);
1105 void UpdateDocTemplateControls();
1106 BOOL IsMouseLocked() const;
1107 CSize GetAutoIconSize(BOOL bLarge) const;
1110protected:
1112 // System accessibility support.
1113 virtual HRESULT GetAccessibleParent(IDispatch** ppdispParent);
1114 virtual HRESULT GetAccessibleChildCount(long* pcountChildren);
1115 virtual HRESULT GetAccessibleChild(VARIANT varChild, IDispatch** ppdispChild);
1116 virtual HRESULT GetAccessibleName(VARIANT varChild, BSTR* pszName);
1117 virtual HRESULT GetAccessibleRole(VARIANT varChild, VARIANT* pvarRole);
1118 virtual HRESULT AccessibleLocation(long* pxLeft, long* pyTop, long* pcxWidth, long* pcyHeight,
1119 VARIANT varChild);
1120 virtual HRESULT AccessibleHitTest(long xLeft, long yTop, VARIANT* pvarChild);
1121 virtual HRESULT GetAccessibleState(VARIANT varChild, VARIANT* pvarState);
1122 virtual CCmdTarget* GetAccessible();
1125protected:
1128 //{{AFX_VIRTUAL(CXTPCommandBar)
1129public:
1130 virtual void OnFinalRelease();
1131 virtual INT_PTR OnToolHitTest(CPoint point, TOOLINFO* pTI) const;
1132 BOOL OnWndMsg(UINT message, WPARAM wParam, LPARAM lParam, LRESULT* pResult);
1133 virtual LRESULT OnIdleUpdateCmdUI(WPARAM wParam, LPARAM);
1134 void FilterToolTipMessage(UINT message, WPARAM wParam, LPARAM lParam);
1135 virtual BOOL PreviewAccel(UINT chAccel);
1136 //}}AFX_VIRTUAL
1137
1138 //{{AFX_MSG(CXTPCommandBar)
1139 afx_msg void OnUpdateCmdUI();
1140 afx_msg void OnMouseMove(UINT nFlags, CPoint point);
1141 afx_msg void OnInitialUpdate();
1142 afx_msg void OnLButtonDown(UINT nFlags, CPoint point);
1143 afx_msg void OnRButtonUp(UINT nFlags, CPoint point);
1144 virtual void OnPopupRButtonUp(CXTPCommandBar* pCommandBar, CPoint point);
1145 afx_msg BOOL OnEraseBkgnd(CDC* pDC);
1146 afx_msg void OnMouseLeave();
1147 afx_msg void OnPaint();
1148 afx_msg LRESULT OnPrintClient(WPARAM wParam, LPARAM);
1149 afx_msg void OnTimer(UINT_PTR nIDEvent);
1150 afx_msg void OnLButtonUp(UINT nFlags, CPoint point);
1151 afx_msg void OnNcMouseMove(UINT nHitTest, CPoint point);
1152 afx_msg int OnCreate(LPCREATESTRUCT lpCreateStruct);
1153 afx_msg void OnDestroy();
1154 afx_msg void OnRButtonDown(UINT nFlags, CPoint point);
1155 afx_msg void OnLButtonDblClk(UINT nFlags, CPoint point);
1156 afx_msg LRESULT OnHelpHitTest(WPARAM, LPARAM lParam);
1157 afx_msg LRESULT OnNcHitTest(CPoint point);
1158 afx_msg void OnNcLButtonDown(UINT nHitTest, CPoint point);
1159 afx_msg LRESULT OnGetObject(WPARAM wParam, LPARAM lParam);
1160 //}}AFX_MSG
1163public:
1164 int m_nStateFlags;
1165 static int s_nHoverDelay;
1166 static int s_nExpandDelay;
1167 static int s_nExpandHoverDelay;
1168 BOOL m_bComboBar;
1169 BOOL m_bTrackOnHover;
1171protected:
1172 BOOL m_bGrabFocus;
1173 int m_nMRUWidth;
1174 int m_nSelected;
1175 int m_nPopuped;
1176 HWND m_hwndFocus;
1177 UINT m_nBarID;
1178 BOOL m_bTracking;
1179 CWnd* m_pSite;
1180 DWORD m_nIdleFlags;
1181 DWORD m_dwFlags;
1182 DWORD m_dwStyle;
1183 CString m_strTitle;
1184 XTPBarType m_barType;
1185 CXTPControls* m_pControls;
1186 XTPBarPosition m_barPosition;
1187 CXTPCommandBars* m_pCommandBars;
1188 CWnd* m_pOwner;
1189 CSize m_szIcons;
1190 CSize m_szButtons;
1191 BOOL m_bTextBelow;
1192 BOOL m_bExecOnRButton;
1193 BOOL m_bIgnoreUpdateHandler;
1194 BOOL m_bRecursePopup;
1196 int m_nLockRecurse; // TRUE if another pop-up bar is opened recursively.
1197 BOOL m_bKeyboardSelect;
1198 BOOL m_bCloseable;
1199 BOOL m_bCustomizable;
1200 CRect m_rcMarker;
1201 BOOL m_bVerticalMarker;
1202 DWORD_PTR m_dwData;
1203 UINT* m_pReturnCmd;
1204 BOOL m_bCustomizeDialogPresent;
1205 BOOL m_bAnimatePopup;
1206 BOOL m_nLockRedraw;
1207 CXTPPaintManager* m_pPaintManager;
1208 CXTPImageManager* m_pImageManager;
1209 BOOL m_bMultiLine;
1210 XTPButtonStyle m_buttonStyle;
1211 XTPBarTextOrientation m_nTextOrientation;
1212 CXTPControl* m_pMouseMoveLockControl;
1213
1214 CXTPToolTipContext* m_pToolTipContext;
1215 CXTPCommandBarAnimation* m_pAnimation;
1216 CSize m_szButtonSpacing;
1217private:
1218 int m_nClickedControl;
1219
1221 DECLARE_MESSAGE_MAP()
1222 DECLARE_XTP_COMMANDBAR(CXTPCommandBar)
1223
1224 class CCommandBarCmdUI;
1225
1226 DECLARE_INTERFACE_MAP()
1227 XTP_DECLARE_CMDTARGETPROVIDER_INTERFACE()
1228
1229# ifdef _XTP_COMMANDBARS_ACTIVEX
1230
1231 DECLARE_DISPATCH_MAP()
1232
1233 DECLARE_OLETYPELIB_EX(CXTPCommandBar);
1234
1235 afx_msg LPDISPATCH OleControls();
1236 afx_msg long OleGetType();
1237 afx_msg LPDISPATCH OleGetCommandBars();
1238 afx_msg long OleGetPosition();
1239 afx_msg void OleSetPosition(long);
1240 afx_msg long OleShowPopup(const VARIANT& Flags, const VARIANT& x, const VARIANT& y);
1241 afx_msg void OleSetIconSize(long cx, long cy);
1242 afx_msg int OleGetIconWidth();
1243 afx_msg int OleGetIconHeight();
1244 afx_msg void OleEnableDocking(long dwFlags);
1245 afx_msg void OleSetTearOffPopup(LPCTSTR strCaption, long nID, long nWidth);
1246 afx_msg LPDISPATCH OleFindControl(const VARIANT& varType, const VARIANT& nId,
1247 const VARIANT& bVisible, const VARIANT& bRecursive);
1248 afx_msg LPDISPATCH OleParent();
1249 afx_msg BOOL OleBuiltIn();
1250 afx_msg void OleModifyStyle(long dwRemove, long dwAdd);
1251 afx_msg void OleGetWindowRect(long* pLeft, long* pTop, long* pRight, long* pBottom);
1252 afx_msg void OleSetPopupToolBar(BOOL bToolBarType);
1253 afx_msg LPDISPATCH OleGetControlPopup();
1254 afx_msg BOOL OleGetCustomizable();
1255 afx_msg void OleSetCustomizable(BOOL);
1256 afx_msg void OleRedrawBar();
1257 afx_msg void OleRecalcLayout();
1258 afx_msg void OleSetSelectedControl(LPDISPATCH);
1259 afx_msg LPDISPATCH OleGetSelectedControl();
1260 afx_msg HWND OleGetHandle();
1261 afx_msg BOOL OleGetVisible();
1262 afx_msg void OleSetVisible(BOOL bVisible);
1263
1264public:
1265 void OlePixelToUnits(CRect& rc);
1266 void OleUnitsToPixel(CPoint& pt);
1267 BOOL m_bAutoMenuLoad;
1268
1269 void OleFireTrackingModeChanged(int bMode);
1270
1271 enum
1272 {
1273 dispidTitle = 1L,
1274 dispidControls = 2L,
1275 dispidType = 3L,
1276 dispidVisible = 4L,
1277 dispidPosition = 5L,
1278 dispidShowPopup = 6L,
1279 dispidSetIconSize = 7L,
1280 dispidEnableDocking = 8L,
1281 dispidSetTearOffPopup = 9L,
1282 dispidBarID = 10L,
1283 dispidFindControl = 11L,
1284 dispidParent = 12L,
1285 dispidBuiltIn = 13L,
1286 dispidDelete = 14L,
1287 dispidModifyStyle = 16L,
1288 dispidGetWindowRect = 17L,
1289 dispidSetFlags = 18L
1290 };
1291
1292public:
1293 static CXTPCommandBar* AFX_CDECL FromDispatch(LPDISPATCH pDisp);
1294
1295# endif /*_XTP_COMMANDBARS_ACTIVEX*/
1296
1297 friend class CXTPCommandBars;
1298 friend class CXTPDockBar;
1299 friend class CCommandBarCmdUI;
1300 friend class CXTPControl;
1301 friend class CXTPControls;
1302 friend class CXTPControlPopup;
1303 friend class CXTPToolBar;
1304 friend class CXTPMouseManager;
1305 friend class CXTPPopupBar;
1306 friend class CXTPCustomizeSheet;
1307 friend class CXTPPaintManager;
1308 friend class CXTPMiniToolBar;
1309
1311};
1312
1314
1315AFX_INLINE int CXTPCommandBar::IsTrackingMode() const
1316{
1317 return m_bTracking;
1318}
1319AFX_INLINE CXTPControls* CXTPCommandBar::GetControls() const
1320{
1321 return m_pControls;
1322}
1323AFX_INLINE XTPBarType CXTPCommandBar::GetType() const
1324{
1325 return m_barType;
1326}
1327AFX_INLINE XTPBarPosition CXTPCommandBar::GetPosition() const
1328{
1329 return m_barPosition;
1330}
1331AFX_INLINE void CXTPCommandBar::DelayLayout()
1332{
1333 m_nIdleFlags |= xtpIdleLayout;
1334}
1335
1336# ifndef _XTP_COMMANDBARS_ACTIVEX
1337AFX_INLINE void CXTPCommandBar::DelayRedraw()
1338{
1339 m_nIdleFlags |= xtpIdleRedraw;
1340}
1341# endif
1342
1343# ifdef _XTP_COMMANDBARS_ACTIVEX
1345AFX_INLINE void CXTPCommandBar::DelayRedraw()
1346{
1347 Redraw();
1348}
1350# endif
1351
1352AFX_INLINE void CXTPCommandBar::SetTitle(LPCTSTR lpszTitle)
1353{
1354 m_strTitle = lpszTitle;
1355 Redraw();
1356}
1357AFX_INLINE CString CXTPCommandBar::GetTitle() const
1358{
1359 return m_strTitle;
1360}
1361AFX_INLINE void CXTPCommandBar::SetCommandBars(CXTPCommandBars* pCommandBars)
1362{
1363 m_pCommandBars = pCommandBars;
1364}
1365AFX_INLINE HWND CXTPCommandBar::GetTrackFocus() const
1366{
1367 return m_hwndFocus;
1368}
1369AFX_INLINE void CXTPCommandBar::SetTrackFocus(HWND hwnd)
1370{
1371 m_hwndFocus = hwnd;
1372}
1373AFX_INLINE void CXTPCommandBar::SetVisible(BOOL /*bVisible*/)
1374{
1375}
1376AFX_INLINE BOOL CXTPCommandBar::IsVisible() const
1377{
1378 return FALSE;
1379}
1380AFX_INLINE BOOL CXTPCommandBar::SetPosition(XTPBarPosition /*barPosition*/)
1381{
1382 return FALSE;
1383}
1384AFX_INLINE CSize CXTPCommandBar::CalcDynamicLayout(int, DWORD /*nMode*/)
1385{
1386 return CSize(0, 0);
1387}
1388AFX_INLINE CXTPCommandBar* CXTPCommandBar::GetParentCommandBar() const
1389{
1390 return NULL;
1391}
1392AFX_INLINE void CXTPCommandBar::OnRecalcLayout()
1393{
1394}
1395AFX_INLINE BOOL CXTPCommandBar::IsCustomizable() const
1396{
1397 return m_bCustomizable;
1398}
1399AFX_INLINE BOOL CXTPCommandBar::IsCustomizeDialogPresent() const
1400{
1401 return m_bCustomizeDialogPresent;
1402}
1403AFX_INLINE BOOL CXTPCommandBar::IsDialogBar() const
1404{
1405 return FALSE;
1406}
1407AFX_INLINE void CXTPCommandBar::EnableCustomization(BOOL bEnable)
1408{
1409 if (!IsDialogBar())
1410 m_bCustomizable = bEnable;
1411}
1412
1413AFX_INLINE void CXTPCommandBar::SetIconSize(CSize size)
1414{
1415 m_szIcons = size;
1416}
1417AFX_INLINE void CXTPCommandBar::SetButtonSize(CSize size)
1418{
1419 m_szButtons = size;
1420}
1421
1422AFX_INLINE DWORD CXTPCommandBar::GetFlags() const
1423{
1424 return m_dwFlags;
1425}
1426
1427AFX_INLINE UINT CXTPCommandBar::GetBarID() const
1428{
1429 return m_nBarID;
1430}
1431AFX_INLINE void CXTPCommandBar::SetCommandBarData(DWORD_PTR dwData)
1432{
1433 m_dwData = dwData;
1434}
1435AFX_INLINE DWORD_PTR CXTPCommandBar::GetCommandBarData() const
1436{
1437 return m_dwData;
1438}
1439AFX_INLINE void CXTPCommandBar::LockRedraw()
1440{
1441 m_nLockRedraw++;
1442}
1443AFX_INLINE void CXTPCommandBar::UnlockRedraw()
1444{
1445 m_nLockRedraw--;
1446 if (m_nLockRedraw == 0 && (m_nIdleFlags & xtpIdleRedraw))
1447 Redraw();
1448}
1449AFX_INLINE void CXTPCommandBar::SetGrabFocus(BOOL bGrabFocus)
1450{
1451 m_bGrabFocus = bGrabFocus;
1452}
1454AFX_INLINE BOOL CXTPCommandBar::PreviewAccel(UINT)
1455{
1456 return FALSE;
1457}
1459AFX_INLINE BOOL CXTPCommandBar::IsRibbonBar() const
1460{
1461 return FALSE;
1462}
1463AFX_INLINE BOOL CXTPCommandBar::IsMenuTitleBar() const
1464{
1465 return FALSE;
1466}
1467AFX_INLINE BOOL CXTPCommandBar::IsPopupBar() const
1468{
1469 return FALSE;
1470}
1471AFX_INLINE void CXTPCommandBar::SetBarID(UINT nID)
1472{
1473 m_nBarID = nID;
1474}
1475AFX_INLINE XTPButtonStyle CXTPCommandBar::GetDefaultButtonStyle() const
1476{
1477 return m_buttonStyle;
1478}
1479
1480AFX_INLINE void CXTPCommandBar::SetDefaultButtonStyle(XTPButtonStyle buttonStyle)
1481{
1482 m_buttonStyle = buttonStyle;
1483}
1484AFX_INLINE BOOL CXTPCommandBar::IsResizable() const
1485{
1486 return FALSE;
1487}
1489AFX_INLINE void CXTPCommandBar::OnPopupRButtonUp(CXTPCommandBar* /*pCommandBar*/, CPoint /*point*/)
1490{
1491}
1493AFX_INLINE CXTPControl* CXTPCommandBar::GetSelected() const
1494{
1495 return GetControl(m_nSelected);
1496}
1497AFX_INLINE void CXTPCommandBar::SetTextOrientation(XTPBarTextOrientation nTextOrientation)
1498{
1499 m_nTextOrientation = nTextOrientation;
1500 DelayLayout();
1501}
1502AFX_INLINE XTPBarTextOrientation CXTPCommandBar::GetTextOrientation() const
1503{
1504 return m_nTextOrientation;
1505}
1506AFX_INLINE void CXTPCommandBar::SetOwner(CWnd* pWnd)
1507{
1508 m_pOwner = pWnd;
1509}
1510AFX_INLINE BOOL CXTPCommandBar::IsControlEnabled(const CXTPControl* /*pControl*/) const
1511{
1512 return (BOOL)-1;
1513}
1515# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
1516#endif //#if !defined(__XTPCOMMANDBAR_H__)
XTPBarType
XTPBarType
Type of the command bar.
Definition XTPCommandBarsDefines.h:77
xtpIdleRedraw
@ xtpIdleRedraw
Delay redraw of command bar.
Definition XTPCommandBarsDefines.h:433
xtpIdleLayout
@ xtpIdleLayout
Delay recalculate layout of command bar.
Definition XTPCommandBarsDefines.h:432
XTPButtonStyle
XTPButtonStyle
Button's styles.
Definition XTPCommandBarsDefines.h:197
XTPSpecialKey
XTPSpecialKey
Special keys enumerator.
Definition XTPCommandBarsDefines.h:407
XTPBarTextOrientation
XTPBarTextOrientation
Command bar text orientation flags.
Definition XTPCommandBarsDefines.h:91
XTPBarPosition
XTPBarPosition
Position of the command bar.
Definition XTPCommandBarsDefines.h:52
DECLARE_XTP_COMMANDBAR
#define DECLARE_XTP_COMMANDBAR(class_name)
This macro generates the C++ header code necessary for a CXTPCommandBar-derived class that can be ser...
Definition XTPCommandBarsDefines.h:1234
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTP_DECLARE_CMDTARGETPROVIDER_INTERFACE
#define XTP_DECLARE_CMDTARGETPROVIDER_INTERFACE()
When deriving from CXTPCmdTarget is not possible this macro can be used in addition to standard DECLA...
Definition XTPFramework.h:89
CXTPCommandBar
CXTPCommandBar is a CWnd derived class.
Definition XTPCommandBar.h:66
CXTPCommandBar::m_nSelected
int m_nSelected
Selected control index.
Definition XTPCommandBar.h:1174
CXTPCommandBar::s_nExpandDelay
static int s_nExpandDelay
Expand delay time.
Definition XTPCommandBar.h:1166
CXTPCommandBar::SetCommandBars
void SetCommandBars(CXTPCommandBars *pCommandBars)
Call this member to set the command bar's object.
Definition XTPCommandBar.h:1361
CXTPCommandBar::SetTextOrientation
void SetTextOrientation(XTPBarTextOrientation nTextOrientation)
Call this member to change text orientation.
Definition XTPCommandBar.h:1497
CXTPCommandBar::GetTitle
CString GetTitle() const
Call this member to get a title for this command bar.
Definition XTPCommandBar.h:1357
CXTPCommandBar::CXTPCommandBar
CXTPCommandBar()
Constructs a CXTPCommandBar object.
CXTPCommandBar::m_hwndFocus
HWND m_hwndFocus
The handle of the window that currently has focus.
Definition XTPCommandBar.h:1176
CXTPCommandBar::DoPropExchange
virtual void DoPropExchange(CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
CXTPCommandBar::m_nStateFlags
int m_nStateFlags
State of the command bars.
Definition XTPCommandBar.h:1164
CXTPCommandBar::GenerateCommandBarList
virtual void GenerateCommandBarList(DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam)
This method is called to assign self identifiers for the serialization process.
CXTPCommandBar::IsMenuTitleBar
virtual BOOL IsMenuTitleBar() const
Call this member function to determine if the command bar is a CXTPMenuTitleBar.
Definition XTPCommandBar.h:1463
CXTPCommandBar::DrawCommandBar
virtual void DrawCommandBar(CDC *pDC, CRect rcClipBox)
This method is called to draw the command bar in the given context.
CXTPCommandBar::HideKeyboardTips
void HideKeyboardTips()
Call this method to hide keyboard tips.
CXTPCommandBar::SetPopuped
BOOL SetPopuped(int nPopuped, BOOL bKeyboard=FALSE)
Call this member to pop-up the specified control.
CXTPCommandBar::m_pOwner
CWnd * m_pOwner
Owner window.
Definition XTPCommandBar.h:1188
CXTPCommandBar::OnHookMessage
virtual int OnHookMessage(HWND hWnd, UINT nMessage, WPARAM &wParam, LPARAM &lParam, LRESULT &lResult)
This member function is called by WindowProc, or is called during message reflection.
CXTPCommandBar::s_nExpandHoverDelay
static int s_nExpandHoverDelay
Expand hover delay.
Definition XTPCommandBar.h:1167
CXTPCommandBar::SetGrabFocus
void SetGrabFocus(BOOL bGrabFocus)
This method is called internally to prevent the command bar from grabbing edit focus.
Definition XTPCommandBar.h:1449
CXTPCommandBar::m_szButtonSpacing
CSize m_szButtonSpacing
Spacing used between toolbar buttons.
Definition XTPCommandBar.h:1216
CXTPCommandBar::UnlockRedraw
void UnlockRedraw()
Call this method to unfreeze redrawing.
Definition XTPCommandBar.h:1443
CXTPCommandBar::SetBarID
void SetBarID(UINT nID)
Call this method to set the identifier of the command bar.
Definition XTPCommandBar.h:1471
CXTPCommandBar::m_pAnimation
CXTPCommandBarAnimation * m_pAnimation
Animation context.
Definition XTPCommandBar.h:1215
CXTPCommandBar::OnCustomizeDragOver
virtual DROPEFFECT OnCustomizeDragOver(CXTPControl *pDataObject, CPoint point)
This member is called when control is over the command bar.
CXTPCommandBar::m_nIdleFlags
DWORD m_nIdleFlags
Idle flags.
Definition XTPCommandBar.h:1180
CXTPCommandBar::OnTrackLost
virtual void OnTrackLost()
Call this method to remove the tracking state of the command bar.
CXTPCommandBar::OnRemoved
virtual void OnRemoved()
This method is called when a toolbar is removed from the command bars collection.
CXTPCommandBar::m_bExecOnRButton
BOOL m_bExecOnRButton
TRUE if the control button is executed on a right-click.
Definition XTPCommandBar.h:1192
CXTPCommandBar::SetButtons
BOOL SetButtons(UINT *pButtons, int nCount)
Call this member to set the controls from the button array.
CXTPCommandBar::SetFlags
void SetFlags(DWORD dwFlagsAdd, DWORD dwFlagsRemove=0)
Call this member to set the command bar's flags.
CXTPCommandBar::CreateKeyboardTips
virtual void CreateKeyboardTips()
This method is called to create a keyboard tips collection for the command bar.
CXTPCommandBar::EnsureVisible
virtual void EnsureVisible(CXTPControl *pControl)
Call this method to ensure that a specified control is visible on the toolbar.
CXTPCommandBar::GetButtonSize
virtual CSize GetButtonSize() const
Call this function to get the size of the command bar button.
CXTPCommandBar::SetButtonSize
void SetButtonSize(CSize size)
Sets the size of the buttons in the command bar.
Definition XTPCommandBar.h:1417
CXTPCommandBar::GetTextOrientation
XTPBarTextOrientation GetTextOrientation() const
Call this member to get the text orientation.
Definition XTPCommandBar.h:1502
CXTPCommandBar::GetWidth
int GetWidth() const
Call this member to get the width of the floated or pop-up toolbar.
CXTPCommandBar::IsCustomizeMode
BOOL IsCustomizeMode() const
Call this method to check if the command bars are in customize mode.
CXTPCommandBar::GetFrameSite
CFrameWnd * GetFrameSite() const
Call this member to get the command bar's site as CFrameWnd.
CXTPCommandBar::GetPaintManager
CXTPPaintManager * GetPaintManager() const
Call this method to retrieve the paint manager.
CXTPCommandBar::SetVisible
virtual void SetVisible(BOOL bVisible)
Call this method to set the visibility state of the control.
Definition XTPCommandBar.h:1373
CXTPCommandBar::s_nHoverDelay
static int s_nHoverDelay
Hover delay time.
Definition XTPCommandBar.h:1165
CXTPCommandBar::m_bMultiLine
BOOL m_bMultiLine
True if multi line commandbar.
Definition XTPCommandBar.h:1209
CXTPCommandBar::m_bCloseable
BOOL m_bCloseable
TRUE if the CommandBar can be closed and-or Hidden.
Definition XTPCommandBar.h:1198
CXTPCommandBar::m_pSite
CWnd * m_pSite
Command bar's site.
Definition XTPCommandBar.h:1179
CXTPCommandBar::ShowTextBelowIcons
void ShowTextBelowIcons(BOOL bTextBelow=TRUE)
Call this member to show the caption below control's icon.
CXTPCommandBar::OnKeyboardTipChar
void OnKeyboardTipChar(UINT chAccel)
This method is called when the user presses a key while keyboard tips are visible.
CXTPCommandBar::m_dwFlags
DWORD m_dwFlags
Command bar's flags.
Definition XTPCommandBar.h:1181
CXTPCommandBar::SetSelected
virtual BOOL SetSelected(int nSelected, BOOL bKeyboard=FALSE)
Call this member to select the specified control.
CXTPCommandBar::LockMouseMove
void LockMouseMove(CXTPControl *pControl)
Locks the mouse cursor for a specified control.
CXTPCommandBar::m_barType
XTPBarType m_barType
Type of the command bar.
Definition XTPCommandBar.h:1184
CXTPCommandBar::m_nPopuped
int m_nPopuped
Pop-up'ed control index.
Definition XTPCommandBar.h:1175
CXTPCommandBar::DelayRedraw
virtual void DelayRedraw()
Call this member to redraw the command bar.
Definition XTPCommandBar.h:1337
CXTPCommandBar::IsLayoutRTL
BOOL IsLayoutRTL() const
Call this member function to determine if the command bar layout is Right-to-Left (RTL).
CXTPCommandBar::GetActiveDocTemplate
UINT GetActiveDocTemplate() const
Retrieves the active MDI document template.
CXTPCommandBar::m_bTextBelow
BOOL m_bTextBelow
TRUE if text is shown below the CommandBar buttons.
Definition XTPCommandBar.h:1191
CXTPCommandBar::GetControl
CXTPControl * GetControl(int nIndex) const
Call this member to return the control at the specified index.
CXTPCommandBar::SetTitle
void SetTitle(LPCTSTR lpszTitle)
Call this member to set a title for this command bar.
Definition XTPCommandBar.h:1352
CXTPCommandBar::GetTrackFocus
HWND GetTrackFocus() const
Call this method to retrieve the current focused control.
Definition XTPCommandBar.h:1365
CXTPCommandBar::GetControlCount
int GetControlCount() const
Call this member to get the count of the controls.
CXTPCommandBar::OnKeyboardTip
virtual void OnKeyboardTip(CXTPCommandBarKeyboardTip *pTip)
This method is called when a keyboard tip is found for the command bar.
CXTPCommandBar::IsResizable
virtual BOOL IsResizable() const
Specifies whether the pop-up gallery can be resized by the user.
Definition XTPCommandBar.h:1484
CXTPCommandBar::m_pPaintManager
CXTPPaintManager * m_pPaintManager
Selected paint manager for command bar.
Definition XTPCommandBar.h:1207
CXTPCommandBar::m_nBarID
UINT m_nBarID
Command bar's identifier.
Definition XTPCommandBar.h:1177
CXTPCommandBar::FindAccel
int FindAccel(TCHAR chAccel) const
Call this method to get the index of the control with the specified accelerator character.
CXTPCommandBar::SetTrackingMode
virtual BOOL SetTrackingMode(int bMode, BOOL bSelectFirst=TRUE, BOOL bKeyboard=FALSE)
Call this member to change the tracking state.
CXTPCommandBar::SetTrackFocus
void SetTrackFocus(HWND hwnd)
Call this method to set focus to the window.
Definition XTPCommandBar.h:1369
CXTPCommandBar::UpdateShortcuts
virtual void UpdateShortcuts()
Updates the control's shortcuts.
CXTPCommandBar::m_nTextOrientation
XTPBarTextOrientation m_nTextOrientation
Commandbar text orientation.
Definition XTPCommandBar.h:1211
CXTPCommandBar::SetPosition
virtual BOOL SetPosition(XTPBarPosition barPosition)
Call this member function to set the position of the command bar.
Definition XTPCommandBar.h:1380
CXTPCommandBar::OnCustomizeDrop
virtual void OnCustomizeDrop(CXTPControl *pDataObject, DROPEFFECT &dropEffect, CPoint ptDrop, CPoint ptDrag)
This method is called when a control is dropped to the command bar.
CXTPCommandBar::m_szIcons
CSize m_szIcons
Size of the command bar's icons.
Definition XTPCommandBar.h:1189
CXTPCommandBar::GetParentCommandBar
virtual CXTPCommandBar * GetParentCommandBar() const
This method retrieves the parent command bar.
Definition XTPCommandBar.h:1388
CXTPCommandBar::GetOwnerSite
CWnd * GetOwnerSite() const
Call this method to retrieve the owner window of the command bar.
CXTPCommandBar::LoadToolBar
virtual BOOL LoadToolBar(UINT nIDResource, BOOL bLoadIcons=TRUE)
Call this member function to load the toolbar specified by nIDResource.
CXTPCommandBar::GetCommandBarData
DWORD_PTR GetCommandBarData() const
This method retrieves the application-supplied, 32-bit value associated with the command bar.
Definition XTPCommandBar.h:1435
CXTPCommandBar::GetControls
CXTPControls * GetControls() const
Call this member to get the controls collection.
Definition XTPCommandBar.h:1319
CXTPCommandBar::OnControlsChanged
virtual void OnControlsChanged()
This method is called when the controls array is changed.
CXTPCommandBar::IsVisible
virtual BOOL IsVisible() const
Returns a Boolean value indicating if the command bar is visible.
Definition XTPCommandBar.h:1376
CXTPCommandBar::GetLargeIconSize
CSize GetLargeIconSize(BOOL bAutoSize) const
Call this method to get the large icon size of the toolbar.
CXTPCommandBar::LockRedraw
void LockRedraw()
Call this method to freeze redrawing until UnlockRedraw is called.
Definition XTPCommandBar.h:1439
CXTPCommandBar::SetShowGripper
void SetShowGripper(BOOL bShow)
Call this method to set the visibility of the command bar's gripper.
CXTPCommandBar::GetDefaultButtonStyle
XTPButtonStyle GetDefaultButtonStyle() const
Call this method to retrieve the default button style of the command bar.
Definition XTPCommandBar.h:1475
CXTPCommandBar::m_strTitle
CString m_strTitle
Command bar's caption.
Definition XTPCommandBar.h:1183
CXTPCommandBar::m_pImageManager
CXTPImageManager * m_pImageManager
Selected image manager for command bar.
Definition XTPCommandBar.h:1208
CXTPCommandBar::OnHookKeyDown
virtual BOOL OnHookKeyDown(UINT nChar, LPARAM lParam)
The framework calls this member function when a non-system key is pressed.
CXTPCommandBar::UnlockMouseMove
void UnlockMouseMove()
Unlocks the mouse cursor.
CXTPCommandBar::m_bRecursePopup
BOOL m_bRecursePopup
TRUE if pop-up bar was opened recursively.
Definition XTPCommandBar.h:1194
CXTPCommandBar::m_nLockRedraw
BOOL m_nLockRedraw
TRUE if all drawing routines skipped.
Definition XTPCommandBar.h:1206
CXTPCommandBar::m_pToolTipContext
CXTPToolTipContext * m_pToolTipContext
Tool tip Context.
Definition XTPCommandBar.h:1214
CXTPCommandBar::m_bIgnoreUpdateHandler
BOOL m_bIgnoreUpdateHandler
TRUE to skip update handler for all child controls.
Definition XTPCommandBar.h:1193
CXTPCommandBar::ProcessSpecialKey
virtual BOOL ProcessSpecialKey(XTPSpecialKey key)
This method is called to process special keys.
CXTPCommandBar::IsAnimationEnabled
BOOL IsAnimationEnabled() const
Determines if animation is enabled for the specified command bar.
CXTPCommandBar::CalcDynamicLayout
virtual CSize CalcDynamicLayout(int nLength, DWORD dwMode)
This method is called to get the size of the command bar.
Definition XTPCommandBar.h:1384
CXTPCommandBar::OnControlSelected
virtual void OnControlSelected(BOOL bSelected, CXTPControl *pControl)
This method is called when a child control becomes selected.
CXTPCommandBar::Popup
virtual BOOL Popup(CXTPControlPopup *pControlPopup, BOOL bSelectFirst=FALSE)
This method is called to pop-up the command bar.
CXTPCommandBar::OnRecalcLayout
virtual void OnRecalcLayout()
This method is called to recalculate the command bar layout.
Definition XTPCommandBar.h:1392
CXTPCommandBar::m_dwStyle
DWORD m_dwStyle
Command bar's styles.
Definition XTPCommandBar.h:1182
CXTPCommandBar::IsDialogBar
virtual BOOL IsDialogBar() const
Call this member function to determine if the command bar is a CXTPDialogBar.
Definition XTPCommandBar.h:1403
CXTPCommandBar::InvalidateParents
void InvalidateParents()
Call this method to redraw all parent command bars.
CXTPCommandBar::Redraw
virtual void Redraw(LPCRECT lpRect=0, BOOL bAnimate=TRUE)
The framework calls this member function to redraw the command bar.
CXTPCommandBar::IsCustomizable
virtual BOOL IsCustomizable() const
Call this method to check if the command bar is customizable.
Definition XTPCommandBar.h:1395
CXTPCommandBar::EnableDoubleBuffer
void EnableDoubleBuffer(BOOL bEnable=TRUE)
Call this method to enable double buffer for toolbar drawing.
CXTPCommandBar::GetPosition
XTPBarPosition GetPosition() const
Call this member to get the position of the command bar.
Definition XTPCommandBar.h:1327
CXTPCommandBar::GetSelected
CXTPControl * GetSelected() const
Call this member to get the currently selected control.
Definition XTPCommandBar.h:1493
CXTPCommandBar::IsPopupBar
virtual BOOL IsPopupBar() const
Call this member function to determine if the command bar is a CXTPPopupBar.
Definition XTPCommandBar.h:1467
CXTPCommandBar::~CXTPCommandBar
virtual ~CXTPCommandBar()
Destroys a CXTPCommandBar object, handles cleanup and deallocation.
CXTPCommandBar::m_pReturnCmd
UINT * m_pReturnCmd
Return command holder.
Definition XTPCommandBar.h:1203
CXTPCommandBar::m_pControls
CXTPControls * m_pControls
A pointer to controls collection.
Definition XTPCommandBar.h:1185
CXTPCommandBar::SetIconSize
void SetIconSize(CSize size)
Call this function to set the size of the actual bitmapped images to be added to a toolbar.
Definition XTPCommandBar.h:1413
CXTPCommandBar::LoadMenu
virtual BOOL LoadMenu(CMenu *pMenu, BOOL bRemoveControls=TRUE)
Call this member to convert menu items to command bar controls.
CXTPCommandBar::m_bCustomizeDialogPresent
BOOL m_bCustomizeDialogPresent
TRUE if the command bar is present in Customize dialog.
Definition XTPCommandBar.h:1204
CXTPCommandBar::m_bComboBar
BOOL m_bComboBar
TRUE if it is combobox list.
Definition XTPCommandBar.h:1168
CXTPCommandBar::RestoreCommandBarList
virtual void RestoreCommandBarList(CXTPCommandBarList *pCommandBarList)
This method is called in the serialization process to restore pop-ups from a list of command bars.
CXTPCommandBar::GetShowGripper
BOOL GetShowGripper() const
Call this method to check if the command bar's gripper is visible.
CXTPCommandBar::SetPaintManager
void SetPaintManager(CXTPPaintManager *pPaintManager)
Call this member to set the specified paint manager.
CXTPCommandBar::m_barPosition
XTPBarPosition m_barPosition
Position of the command bar.
Definition XTPCommandBar.h:1186
CXTPCommandBar::OnCustomizeDragLeave
virtual void OnCustomizeDragLeave()
This method is called when a control leaves the command bar.
CXTPCommandBar::m_rcMarker
CRect m_rcMarker
Marker position.
Definition XTPCommandBar.h:1200
CXTPCommandBar::m_bAnimatePopup
BOOL m_bAnimatePopup
TRUE to animate pop-up bar.
Definition XTPCommandBar.h:1205
CXTPCommandBar::IsKeyboardCuesVisible
virtual BOOL IsKeyboardCuesVisible() const
Determines if underlines are visible in the command bar control.
CXTPCommandBar::IsTrackingMode
int IsTrackingMode() const
Call this member to get the tracking state.
Definition XTPCommandBar.h:1315
CXTPCommandBar::GetImageManager
CXTPImageManager * GetImageManager() const
Call this method to retrieve the image manager.
CXTPCommandBar::GetIconSize
virtual CSize GetIconSize() const
Call this member function to get the size of the toolbar icon.
CXTPCommandBar::SetCommandBarData
void SetCommandBarData(DWORD_PTR dwData)
This method sets the 32-bit value associated with the command bar.
Definition XTPCommandBar.h:1431
CXTPCommandBar::m_pCommandBars
CXTPCommandBars * m_pCommandBars
parent command bars class.
Definition XTPCommandBar.h:1187
CXTPCommandBar::IsRibbonBar
virtual BOOL IsRibbonBar() const
Call this member function to determine if the command bar is a CXTPRibbonBar.
Definition XTPCommandBar.h:1459
CXTPCommandBar::m_nMRUWidth
int m_nMRUWidth
Recent width.
Definition XTPCommandBar.h:1173
CXTPCommandBar::IsCustomizeDialogPresent
BOOL IsCustomizeDialogPresent() const
Call this method to check if the command bar is present in Customize dialog.
Definition XTPCommandBar.h:1399
CXTPCommandBar::GetSite
CWnd * GetSite() const
Call this member to get the command bar's site.
CXTPCommandBar::m_bTrackOnHover
BOOL m_bTrackOnHover
TRUE to select item if mouse stay over control.
Definition XTPCommandBar.h:1169
CXTPCommandBar::FindAccelEx
int FindAccelEx(UINT chAccel, BOOL &bSelectOnly) const
Call this method to get the index of the control with the specified accelerator character.
CXTPCommandBar::m_dwData
DWORD_PTR m_dwData
The 32-bit value associated with the command bar.
Definition XTPCommandBar.h:1202
CXTPCommandBar::m_bKeyboardSelect
BOOL m_bKeyboardSelect
TRUE if last item was selected by keyboard.
Definition XTPCommandBar.h:1197
CXTPCommandBar::GetFlags
DWORD GetFlags() const
Call this method to retrieve the current behavior modification flags of the command bar.
Definition XTPCommandBar.h:1422
CXTPCommandBar::m_buttonStyle
XTPButtonStyle m_buttonStyle
Default button Style.
Definition XTPCommandBar.h:1210
CXTPCommandBar::IsHelpMode
BOOL IsHelpMode() const
Determines if the parent frame is in help mode.
CXTPCommandBar::GetType
XTPBarType GetType() const
Call this member to get the type of the command bar.
Definition XTPCommandBar.h:1323
CXTPCommandBar::EnableCustomization
void EnableCustomization(BOOL bEnable=TRUE)
Call this method to enable/disable customization of the command bar.
Definition XTPCommandBar.h:1407
CXTPCommandBar::SetStatusText
BOOL SetStatusText(const CString &strDescription)
This method is called to set the description context.
CXTPCommandBar::Copy
virtual void Copy(CXTPCommandBar *pCommandBar, BOOL bRecursive=FALSE)
This method makes a copy of the command bar.
CXTPCommandBar::m_bGrabFocus
BOOL m_bGrabFocus
TRUE to grab current focus.
Definition XTPCommandBar.h:1172
CXTPCommandBar::SetDefaultButtonStyle
void SetDefaultButtonStyle(XTPButtonStyle buttonStyle)
Call this method to set the default button style of the command bar.
Definition XTPCommandBar.h:1480
CXTPCommandBar::OnTrackEnter
virtual void OnTrackEnter()
Call this method to track the command bar.
CXTPCommandBar::GetBarID
UINT GetBarID() const
Call this method to retrieve the identifier of the command bar.
Definition XTPCommandBar.h:1427
CXTPCommandBar::SetWidth
void SetWidth(int nWidth)
Call this member to set the width of the floated or pop-up toolbar.
CXTPCommandBar::OnMouseHitTest
virtual int OnMouseHitTest(CPoint pt)
This method is called to determine mouse hit code.
CXTPCommandBar::GetRootParent
CXTPCommandBar * GetRootParent() const
Call this method to retrieve the top-level parent command bar.
CXTPCommandBar::m_bCustomizable
BOOL m_bCustomizable
TRUE if command bar is customizable.
Definition XTPCommandBar.h:1199
CXTPCommandBar::m_szButtons
CSize m_szButtons
Size of the command bar's buttons.
Definition XTPCommandBar.h:1190
CXTPCommandBar::OnCustomizeDragEnter
virtual DROPEFFECT OnCustomizeDragEnter(CXTPControl *pDataObject, CPoint point)
This member is called when a control is entered into the command bar.
CXTPCommandBar::DelayLayout
void DelayLayout()
Call this member to recalculate the layout.
Definition XTPCommandBar.h:1331
CXTPCommandBar::GetCommandBars
CXTPCommandBars * GetCommandBars() const
Call this member to get the command bar's object.
CXTPCommandBar::IsTextBelowIcons
BOOL IsTextBelowIcons() const
Checks whether the caption is below the control's icon.
CXTPCommandBar::IsKeyboardTipsVisible
BOOL IsKeyboardTipsVisible() const
Call this method to check if keyboard tips are visible for the command bar.
CXTPCommandBar::FillCommandBarEntry
virtual void FillCommandBarEntry(CDC *pDC)
This method is called to draw the background of the command bar.
CXTPCommandBar::GetBorders
virtual CRect GetBorders()
This method is called to get the border margins of the command bar.
CXTPCommandBar::SetImageManager
void SetImageManager(CXTPImageManager *pImageManager)
Call this member to set the specified image manager.
CXTPCommandBar::m_bVerticalMarker
BOOL m_bVerticalMarker
TRUE to draw marker vertically.
Definition XTPCommandBar.h:1201
CXTPCommandBar::m_bTracking
BOOL m_bTracking
TRUE if the command bar is in tracking mode.
Definition XTPCommandBar.h:1178
CXTPCommandBar::SetControls
void SetControls(CXTPControls *pControls)
Call this member to set the controls collection of the command bar.
CXTPCommandBar::EnableAnimation
void EnableAnimation(BOOL bEnable=TRUE)
Call this method to enable animation for the command bar.
CXTPCommandBarKeyboardTip
CXTPCommandBarKeyboardTip is a CWnd derived class which represents a keyboard tip single window.
Definition XTPCommandBarKeyboardTip.h:41
CXTPCommandBarList
CXTPCommandBarList is a CList derived class.
Definition XTPCommandBarList.h:42
CXTPCommandBars
CXTPCommandBars is a standalone class.
Definition XTPCommandBars.h:165
CXTPControl
CXTPControl is a CXTPCmdTarget derived class.
Definition XTPControl.h:841
CXTPControlPopup
CXTPControlPopup is a CXTPControl derived class.
Definition XTPControlPopup.h:42
CXTPControls
CXTPControls is a CXTPCmdTarget derived class.
Definition XTPControls.h:47
CXTPCustomizeSheet
CXTPCustomizeSheet is a CPropertySheet derived class.
Definition XTPCustomizeSheet.h:47
CXTPDockBar
CXTPDockBar is a CWnd derived class.
Definition XTPDockBar.h:42
CXTPHookManagerHookAble
HookAble interface.
Definition XTPHookManager.h:42
CXTPImageManager
CXTPImageManager is a standalone class.
Definition XTPImageManager.h:1898
CXTPMiniToolBar
Represents a MiniToolbar object.
Definition XTPMiniToolBar.h:50
CXTPMouseManager
CXTPMouseManager is standalone class.
Definition XTPMouseManager.h:41
CXTPPaintManager
Paint manager of the command bars.
Definition XTPPaintManager.h:199
CXTPPopupBar
CXTPPopupBar is a CXTPCommandBar derived class.
Definition XTPPopupBar.h:42
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72
CXTPToolBar
CXTPToolBar is a CXTPCommandBar derived class.
Definition XTPToolBar.h:42
CXTPToolTipContext
CXTPToolTipContext is a CXTPCmdTarget derived class.
Definition XTPToolTipContext.h:291
XTP_COMMANDBARS_PROPEXCHANGE_PARAM
XTP_COMMANDBARS_PROPEXCHANGE_PARAM is a structure used to store the CommandBar's save settings.
Definition XTPCommandBars.h:88


Toolkit Pro: Member List

CXTPInternalCollectionT< _TObject > Member List

This is the complete list of members for CXTPInternalCollectionT< _TObject >, including all inherited members.

AddPtr(_TObject *pObj, BOOL bCallAddRef=FALSE) | CXTPInternalCollectionT< _TObject > | inlinevirtual
CXTPInternalCollectionT() | CXTPInternalCollectionT< _TObject > | inline
GetAt(int nIndex, BOOL bWithAddRef=TRUE) | CXTPInternalCollectionT< _TObject > | inlinevirtual
TObject typedef | CXTPInternalCollectionT< _TObject > |
TObjectPtr typedef | CXTPInternalCollectionT< _TObject > |
~CXTPInternalCollectionT() | CXTPInternalCollectionT< _TObject > | inlinevirtual


Toolkit Pro: XTPPropExchangeEnumerator.h Source File

  • Source
  • Common
  • PropExchange
XTPPropExchangeEnumerator.h
Go to the documentation of this file.
1
23#if !defined(__XTPPROPEXCHANGEENUMERATOR_H__)
24# define __XTPPROPEXCHANGEENUMERATOR_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPPropExchange;
34
55class _XTP_EXT_CLASS CXTPPropExchangeEnumerator
56{
57public:
64 CXTPPropExchangeEnumerator(CXTPPropExchange* pContainer, LPCTSTR lpszSection);
65
71 virtual ~CXTPPropExchangeEnumerator();
72
73public:
82 virtual POSITION GetPosition(DWORD dwCount = 0, BOOL bCompactMode = TRUE);
83
91 virtual CXTPPropExchange* GetNext(POSITION& pos);
92
93 CXTPPropExchange* GetContainer() const;
94 virtual int GetCount() const;
95
96protected:
97 CXTPPropExchange* m_pContainer;
98 CString m_strSectionName;
99 DWORD m_nCount;
100};
102AFX_INLINE CXTPPropExchange* CXTPPropExchangeEnumerator::GetContainer() const
103{
104 return m_pContainer;
105}
107# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
109#endif // !defined(__XTPPROPEXCHANGEENUMERATOR_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPPropExchangeEnumerator
CXTPPropExchangeEnumerator is standalone class.
Definition XTPPropExchangeEnumerator.h:56
CXTPPropExchangeEnumerator::m_strSectionName
CString m_strSectionName
Enumerator section name.
Definition XTPPropExchangeEnumerator.h:98
CXTPPropExchangeEnumerator::~CXTPPropExchangeEnumerator
virtual ~CXTPPropExchangeEnumerator()
Destroys a CXTPPropExchangeEnumerator object, handles cleanup and deallocation.
CXTPPropExchangeEnumerator::m_nCount
DWORD m_nCount
Count of items to load.
Definition XTPPropExchangeEnumerator.h:99
CXTPPropExchangeEnumerator::CXTPPropExchangeEnumerator
CXTPPropExchangeEnumerator(CXTPPropExchange *pContainer, LPCTSTR lpszSection)
Constructs a CXTPPropExchangeEnumerator object.
CXTPPropExchangeEnumerator::GetNext
virtual CXTPPropExchange * GetNext(POSITION &pos)
Call this method to get next enumerable section to load.
CXTPPropExchangeEnumerator::m_pContainer
CXTPPropExchange * m_pContainer
Parent section of enumerator.
Definition XTPPropExchangeEnumerator.h:97
CXTPPropExchangeEnumerator::GetPosition
virtual POSITION GetPosition(DWORD dwCount=0, BOOL bCompactMode=TRUE)
Call this method to init enumerable section.
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72


Toolkit Pro: XTPPageScroller.h Source File

  • Source
  • Controls
  • Scroll
XTPPageScroller.h
Go to the documentation of this file.
1
23#if !defined(__XTPPAGERSCROLLER_H__)
24# define __XTPPAGERSCROLLER_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
47class _XTP_EXT_CLASS CXTPPageScroller : public CWnd
48{
50 DECLARE_DYNAMIC(CXTPPageScroller)
52public:
57 CXTPPageScroller();
58
63 virtual ~CXTPPageScroller();
64
65public:
95 virtual BOOL Create(DWORD dwStyle, const RECT& rect, CWnd* pParentWnd, UINT nID);
96
97 using CWnd::Create;
98
108 void SetChild(HWND hwndChild);
109
116 void RecalcSize();
117
127 void ForwardMouse(BOOL bForward);
128
138 COLORREF SetBkColor(COLORREF clr);
139
147 COLORREF GetBkColor();
148
161 int SetBorder(int iBorder);
162
170 int GetBorder();
171
177 void SetPos(int iPos);
178
186 int GetPos();
187
196 int SetButtonSize(int iSize);
197
205 int GetButtonSize();
206
217 DWORD GetButtonState(int iButton);
218
227 void GetDropTarget(IDropTarget** ppdt);
228
229protected:
231 DECLARE_MESSAGE_MAP()
232
233 //{{AFX_VIRTUAL(CXTPPageScroller)
234 //}}AFX_VIRTUAL
235
236 //{{AFX_MSG(CXTPPageScroller)
237 //}}AFX_MSG
239};
240
242
243AFX_INLINE void CXTPPageScroller::SetChild(HWND hwndChild)
244{
245 _ASSERTE(::IsWindow(m_hWnd));
246 Pager_SetChild(m_hWnd, hwndChild);
247}
248AFX_INLINE void CXTPPageScroller::RecalcSize()
249{
250 _ASSERTE(::IsWindow(m_hWnd));
251 Pager_RecalcSize(m_hWnd);
252}
253AFX_INLINE void CXTPPageScroller::ForwardMouse(BOOL bForward)
254{
255 _ASSERTE(::IsWindow(m_hWnd));
256 Pager_ForwardMouse(m_hWnd, bForward);
257}
258AFX_INLINE COLORREF CXTPPageScroller::SetBkColor(COLORREF clr)
259{
260 _ASSERTE(::IsWindow(m_hWnd));
261 return Pager_SetBkColor(m_hWnd, clr);
262}
263AFX_INLINE COLORREF CXTPPageScroller::GetBkColor()
264{
265 _ASSERTE(::IsWindow(m_hWnd));
266 return Pager_GetBkColor(m_hWnd);
267}
268AFX_INLINE int CXTPPageScroller::SetBorder(int iBorder)
269{
270 _ASSERTE(::IsWindow(m_hWnd));
271 return Pager_SetBorder(m_hWnd, iBorder);
272}
273AFX_INLINE int CXTPPageScroller::GetBorder()
274{
275 _ASSERTE(::IsWindow(m_hWnd));
276 return Pager_GetBorder(m_hWnd);
277}
278AFX_INLINE void CXTPPageScroller::SetPos(int iPos)
279{
280 _ASSERTE(::IsWindow(m_hWnd));
281 Pager_SetPos(m_hWnd, iPos);
282}
283AFX_INLINE int CXTPPageScroller::GetPos()
284{
285 _ASSERTE(::IsWindow(m_hWnd));
286 return Pager_GetPos(m_hWnd);
287}
288AFX_INLINE int CXTPPageScroller::SetButtonSize(int iSize)
289{
290 _ASSERTE(::IsWindow(m_hWnd));
291 return Pager_SetButtonSize(m_hWnd, iSize);
292}
293AFX_INLINE int CXTPPageScroller::GetButtonSize()
294{
295 _ASSERTE(::IsWindow(m_hWnd));
296 return Pager_GetButtonSize(m_hWnd);
297}
298AFX_INLINE DWORD CXTPPageScroller::GetButtonState(int iButton)
299{
300 _ASSERTE(::IsWindow(m_hWnd));
301 return Pager_GetButtonState(m_hWnd, iButton);
302}
303AFX_INLINE void CXTPPageScroller::GetDropTarget(IDropTarget** ppdt)
304{
305 _ASSERTE(::IsWindow(m_hWnd));
306 Pager_GetDropTarget(m_hWnd, ppdt);
307}
309# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
311#endif // #if !defined(__XTPPAGERSCROLLER_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPPageScroller
CXTPPageScroller is a CWnd derived class.
Definition XTPPageScroller.h:48
CXTPPageScroller::GetBorder
int GetBorder()
This member function retrieves the current border size for the pager control.
CXTPPageScroller::GetButtonSize
int GetButtonSize()
This member function retrieves the current button size for the pager control.
CXTPPageScroller::SetPos
void SetPos(int iPos)
This member function sets the scroll position for the pager control.
CXTPPageScroller::SetBkColor
COLORREF SetBkColor(COLORREF clr)
This member function sets the current background color for the pager control.
CXTPPageScroller::ForwardMouse
void ForwardMouse(BOOL bForward)
This member function enables/disables mouse forwarding for the pager control.
CXTPPageScroller::RecalcSize
void RecalcSize()
This member function forces the pager control to recalculate the size of the contained window.
CXTPPageScroller::SetChild
void SetChild(HWND hwndChild)
This member function sets the contained window for the pager control.
CXTPPageScroller::GetBkColor
COLORREF GetBkColor()
This member function retrieves the current background color for the pager control.
CXTPPageScroller::SetButtonSize
int SetButtonSize(int iSize)
This member function sets the current button size for the pager control.
CXTPPageScroller::GetDropTarget
void GetDropTarget(IDropTarget **ppdt)
This member function retrieves a pager control's IDropTarget interface pointer.
CXTPPageScroller::GetButtonState
DWORD GetButtonState(int iButton)
This member function retrieves the state of the specified button in a pager control.
CXTPPageScroller::~CXTPPageScroller
virtual ~CXTPPageScroller()
Destroys a CXTPPageScroller object, handles cleanup and deallocation.
CXTPPageScroller::Create
virtual BOOL Create(DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID)
This member function creates a pager child window and attaches it to this CWnd object.
CXTPPageScroller::CXTPPageScroller
CXTPPageScroller()
Constructs a CXTPPageScroller object.
CXTPPageScroller::SetBorder
int SetBorder(int iBorder)
This member function sets the current border size for the pager control.
CXTPPageScroller::GetPos
int GetPos()
This member function retrieves the current scroll position of the pager control.


Toolkit Pro: XTPCustomHeap.h Source File

  • Source
  • Common
XTPCustomHeap.h
Go to the documentation of this file.
1
23#if !defined(_XTPCUSTOMHEAP_H__)
24# define _XTPCUSTOMHEAP_H__
25
26# if _MSC_VER > 1000
27# pragma once
28# endif // _MSC_VER > 1000
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
34# define XTP_EXPORT_PARAMS_NO
35
36typedef enum _XTP_HEAP_INFORMATION_CLASS
37{
38 xtpHeapCompatibilityInformation
39} XTP_HEAP_INFORMATION_CLASS;
65_XTP_EXT_CLASS BOOL AFX_CDECL XTPHeapSetCompatibilityInformation(HANDLE hHeapHandle,
66 PVOID pHeapInformation,
67 ULONG_PTR nHeapInformationLength);
68
88_XTP_EXT_CLASS BOOL AFX_CDECL XTPHeapSetLowFragmentation(HANDLE hHeapHandle);
89
109template<class _TData>
110class CXTPHeapAllocatorT : public _TData
111{
112public:
114 typedef _TData TData;
115 using _TData::ms_bLFHEnabled;
116 using _TData::ms_bUseCustomHeap;
117 using _TData::ms_dwRefs;
118 using _TData::ms_hCustomHeap;
121 // Allocator Interface
122
132 static void* AFX_CDECL Alloc_mem(size_t nBytes)
133 {
134 InterlockedIncrement(&ms_dwRefs); // ms_dwRefs++;
135
136 if (ms_bUseCustomHeap)
137 {
138 CreateHeapIfNeed();
139
140 return ::HeapAlloc(ms_hCustomHeap, 0, nBytes);
141 }
142 else
143 {
144# ifdef _DEBUG
145 return DEBUG_NEW char[nBytes];
146# else
147 return new char[nBytes];
148# endif
149 }
150 };
151
160 static void AFX_CDECL Free_mem(void* p)
161 {
162 LONG nRefs = 0;
163 if (ms_dwRefs)
164 nRefs = InterlockedDecrement(&ms_dwRefs); // ms_dwRefs--;
165
166 if (ms_bUseCustomHeap)
167 {
168 VERIFY(::HeapFree(ms_hCustomHeap, 0, p));
169
170 if (nRefs == 0)
171 ClearHeap();
172 }
173 else
174 {
175 delete p;
176 }
177 };
178
179 // Implementation
180
182 CXTPHeapAllocatorT(){};
183
184 virtual ~CXTPHeapAllocatorT()
185 {
186 // When other static objects use this allocator,
187 // they may be destroyed later (and free memory later)
188 // Each static object, which use this allocator,
189 // should check ms_dwRefs and destroy heap if no more refs.
190 if (ms_dwRefs == 0)
191 ClearHeap();
192 };
193
194 static void AFX_CDECL CreateHeapIfNeed()
195 {
196 if (!ms_hCustomHeap)
197 {
198 ms_hCustomHeap = ::HeapCreate(0, 0, 0);
199 _ASSERTE(ms_hCustomHeap);
200 ms_bLFHEnabled = XTPHeapSetLowFragmentation(ms_hCustomHeap);
201 }
202 }
203
204 static void AFX_CDECL ClearHeap()
205 {
206 _ASSERTE(ms_dwRefs == 0);
207 if (ms_hCustomHeap)
208 VERIFY(::HeapDestroy(ms_hCustomHeap));
209 ms_hCustomHeap = NULL;
210 }
212};
213
215# define XTP_DECLARE_HEAP_ALLOCATOR_(allocatorClass, EXPORT_PARAMS) \
216 struct EXPORT_PARAMS allocatorClass##Data \
217 { \
218 static HANDLE ms_hCustomHeap; \
219 static LONG ms_dwRefs; \
220 static BOOL ms_bLFHEnabled; \
221 static BOOL ms_bUseCustomHeap; \
222 }; \
223 class EXPORT_PARAMS allocatorClass : public CXTPHeapAllocatorT<allocatorClass##Data> \
224 { \
225 };
251# define XTP_DECLARE_HEAP_ALLOCATOR(allocatorClass) \
252 XTP_DECLARE_HEAP_ALLOCATOR_(allocatorClass, XTP_EXPORT_PARAMS_NO)
253
279# define XTP_IMPLEMENT_HEAP_ALLOCATOR(allocatorClass, bUseCustomHeap) \
280 HANDLE allocatorClass##Data::ms_hCustomHeap = NULL; \
281 LONG allocatorClass##Data::ms_dwRefs = 0; \
282 BOOL allocatorClass##Data::ms_bLFHEnabled = FALSE; \
283 BOOL allocatorClass##Data::ms_bUseCustomHeap = bUseCustomHeap; \
284 allocatorClass g_obj##allocatorClass;
285
333template<class _TObject, class _TAllocator>
334class CXTPHeapObjectT : public _TObject
335{
336public:
338 typedef _TObject TObject;
339 typedef _TAllocator TAllocator;
351 void* PASCAL operator new(size_t nSize)
352 {
353 if (TAllocator::ms_bUseCustomHeap)
354 return TAllocator::Alloc_mem(nSize);
355 else
356 {
357 InterlockedIncrement(&TAllocator::ms_dwRefs); // TAllocator::ms_dwRefs++;
358 return ::operator new(nSize);
359 }
360 }
361
370 void PASCAL operator delete(void* p)
371 {
372 if (TAllocator::ms_bUseCustomHeap)
373 TAllocator::Free_mem(p);
374 else
375 {
376 InterlockedDecrement(&TAllocator::ms_dwRefs); // TAllocator::ms_dwRefs--;
377 ::operator delete(p);
378 }
379 }
380
383 // void* PASCAL operator new(size_t, void* p) {return p;} // default is fine as is
384
385# if _MSC_VER >= 1200
386 void PASCAL operator delete(void* p, void* pPlace)
387 {
388 if (TAllocator::ms_bUseCustomHeap)
389 operator delete(p);
390 else
391 {
392 InterlockedDecrement(&TAllocator::ms_dwRefs); // TAllocator::ms_dwRefs--;
393 ::operator delete(p, pPlace);
394 }
395 }
396# endif
397
398# if defined(_DEBUG) && !defined(_AFX_NO_DEBUG_CRT)
399 // for file name/line number tracking using DEBUG_NEW
400 void* PASCAL operator new(size_t nSize, LPCSTR lpszFileName, int nLine)
401 {
402 if (TAllocator::ms_bUseCustomHeap)
403 return operator new(nSize);
404 else
405 {
406 InterlockedIncrement(&TAllocator::ms_dwRefs); // TAllocator::ms_dwRefs++;
407 return ::operator new(nSize, lpszFileName, nLine);
408 }
409 }
410
411# if _MSC_VER >= 1200
412 void PASCAL operator delete(void* p, LPCSTR lpszFileName, int nLine)
413 {
414 if (TAllocator::ms_bUseCustomHeap)
415 operator delete(p);
416 else
417 {
418 InterlockedDecrement(&TAllocator::ms_dwRefs); // TAllocator::ms_dwRefs--;
419 ::operator delete(p, lpszFileName, nLine);
420 }
421 }
422# endif
423# endif
425};
426
436class _XTP_EXT_CLASS CXTPHeapString
437{
438public:
445 CXTPHeapString();
446
454 CXTPHeapString(LPCTSTR pcszString);
455
462 virtual ~CXTPHeapString();
463
470 virtual BOOL IsEmpty() const;
471
479 LPCTSTR operator=(LPCTSTR pcszString);
480
488 BOOL operator==(LPCTSTR pcszString) const;
489
497 BOOL operator!=(LPCTSTR pcszString) const;
498
505 operator LPCTSTR() const;
506
513 operator CString() const;
514
521 virtual BSTR AllocSysString() const;
522
528 virtual void SetString(LPCTSTR pcszString);
529
530protected:
536 virtual void _AllocStringData(int nNewStrLen);
537
543 virtual void _FreeStringData();
544
545 int m_nStrLen;
546 LPTSTR m_pcszString;
547};
548
560template<class _TAllocator>
561class CXTPHeapStringT : public CXTPHeapString
562{
563public:
565 typedef _TAllocator TAllocator;
575 CXTPHeapStringT(LPCTSTR pcszString = _T(""))
576 {
577 SetString(pcszString);
578 }
579
586 virtual ~CXTPHeapStringT()
587 {
588 _FreeStringData();
589 }
590
598 LPCTSTR operator=(LPCTSTR pcszString)
599 {
600 SetString(pcszString);
601 return m_pcszString ? m_pcszString : _T("");
602 }
603
611 BOOL operator==(LPCTSTR pcszString) const
612 {
613 return 0 == _tcscmp((LPCTSTR) * this, pcszString);
614 }
615
623 BOOL operator!=(LPCTSTR pcszString) const
624 {
625 return 0 != _tcscmp((LPCTSTR) * this, pcszString);
626 }
627
634 operator LPCTSTR() const
635 {
636 return m_pcszString ? m_pcszString : _T("");
637 }
638
645 operator CString() const
646 {
647 return CString(m_pcszString ? m_pcszString : _T(""));
648 }
649
650protected:
656 virtual void _AllocStringData(int nNewStrLen)
657 {
658 _ASSERTE(m_pcszString == NULL);
659
660 m_nStrLen = nNewStrLen;
661 m_pcszString = (LPTSTR)TAllocator::Alloc_mem((nNewStrLen + 1) * sizeof(TCHAR));
662 }
663
669 virtual void _FreeStringData()
670 {
671 if (m_pcszString)
672 TAllocator::Free_mem(m_pcszString);
673
674 m_pcszString = NULL;
675 m_nStrLen = 0;
676 }
677};
678
680struct XTP_BATCHALLOC_OBJ_HEADER;
681
682struct XTP_BATCHALLOC_BLOCK_HEADER
683{
684 LONG m_dwRefs;
685
686# ifdef _DEBUG
687 DWORD m_dwObjCount;
688 DWORD m_dwObjSize; // for debug
689# endif
690 XTP_BATCHALLOC_OBJ_HEADER* pFreeList;
691
692 XTP_BATCHALLOC_BLOCK_HEADER* pPrev;
693 XTP_BATCHALLOC_BLOCK_HEADER* pNext;
694};
695
696struct XTP_BATCHALLOC_OBJ_HEADER
697{
698 XTP_BATCHALLOC_BLOCK_HEADER* pBlockHeader;
699
700 XTP_BATCHALLOC_OBJ_HEADER* pNextFree;
701
702 void* GetData()
703 {
704 BYTE* pData = (BYTE*)this;
705 pData += sizeof(XTP_BATCHALLOC_OBJ_HEADER);
706 return pData;
707 }
708
709 static XTP_BATCHALLOC_OBJ_HEADER* AFX_CDECL GetHeader(void* pData)
710 {
711 BYTE* pBlockData = (BYTE*)pData;
712 pBlockData -= sizeof(XTP_BATCHALLOC_OBJ_HEADER);
713 return (XTP_BATCHALLOC_OBJ_HEADER*)pBlockData;
714 }
715};
716
717template<class _TAllocator, class _TBatchAllocData>
718class CXTPBatchAllocManagerT : public _TBatchAllocData
719{
720 using _TBatchAllocData::m_bDestroyEmptyBlocksOnFree;
721 using _TBatchAllocData::m_bDestroyLastEmptyBlockOnFree;
722 using _TBatchAllocData::m_dwAllocatedObjects;
723 using _TBatchAllocData::m_nBlockSize;
724 using _TBatchAllocData::m_pBusyBlocks;
725 using _TBatchAllocData::m_pFreeBlocks;
726
727public:
728 typedef _TBatchAllocData TBatchAllocData;
729 typedef _TAllocator TAllocator;
730
731 virtual ~CXTPBatchAllocManagerT()
732 {
733 // all data must be deallocated before
734 _ASSERTE(m_pBusyBlocks == NULL);
735
736 FreeExtraData();
737
738 _ASSERTE(m_pFreeBlocks == NULL);
739
740 // This static object destructor may be called later than allocator destructor.
741 if (TAllocator::ms_dwRefs == 0)
742 TAllocator::ClearHeap();
743 }
744
745 AFX_INLINE static int AFX_CDECL _Round4(int nSize)
746 {
747 int nDiv = nSize / 4;
748 int nMod = nSize % 4;
749 int nSizeQ4 = (nDiv + (nMod ? 1 : 0)) * 4;
750 return nSizeQ4;
751 }
752
753 static void* AFX_CDECL AllocData(size_t nSize)
754 {
755 if (!m_pFreeBlocks)
756 {
757 int nObjSize = _Round4(XTPToIntChecked(nSize)
758 + XTPToIntChecked(sizeof(XTP_BATCHALLOC_OBJ_HEADER)));
759 int nBlockDataSize = XTPToIntChecked(sizeof(XTP_BATCHALLOC_BLOCK_HEADER)
760 + m_nBlockSize * nObjSize);
761
762 BYTE* pBlockData = (BYTE*)_TAllocator::Alloc_mem(XTPToSizeTChecked(nBlockDataSize));
763
764 if (!pBlockData)
765 return NULL;
766
767 XTP_BATCHALLOC_BLOCK_HEADER* pBlockHdr = (XTP_BATCHALLOC_BLOCK_HEADER*)pBlockData;
768 ZeroMemory(pBlockHdr, sizeof(XTP_BATCHALLOC_BLOCK_HEADER));
769 pBlockHdr->m_dwRefs = 0;
770# ifdef _DEBUG
771 pBlockHdr->m_dwObjCount = XTPToDWORDChecked(m_nBlockSize);
772 pBlockHdr->m_dwObjSize = (DWORD)nSize;
773# endif
774 //---------
775 m_pFreeBlocks = pBlockHdr;
776
777 XTP_BATCHALLOC_OBJ_HEADER* pObjHdr = NULL;
778 pBlockData = pBlockData + sizeof(XTP_BATCHALLOC_BLOCK_HEADER);
779 pBlockHdr->pFreeList = (XTP_BATCHALLOC_OBJ_HEADER*)pBlockData;
780
781 for (int i = 0; i < m_nBlockSize; i++)
782 {
783 pObjHdr = (XTP_BATCHALLOC_OBJ_HEADER*)pBlockData;
784 // ZeroMemory(pObjHdr, sizeof(XTP_BATCHALLOC_OBJ_HEADER));
785
786 pBlockData += nObjSize;
787
788 pObjHdr->pBlockHeader = pBlockHdr;
789 pObjHdr->pNextFree = (XTP_BATCHALLOC_OBJ_HEADER*)pBlockData;
790 }
791 if (pObjHdr)
792 pObjHdr->pNextFree = NULL;
793 }
794
795 _ASSERTE(m_pFreeBlocks && m_pFreeBlocks->pFreeList);
796 if (!m_pFreeBlocks || !m_pFreeBlocks->pFreeList)
797 return NULL;
798
799 _ASSERTE(m_pFreeBlocks->m_dwObjSize == (DWORD)nSize);
800
801 void* pData = m_pFreeBlocks->pFreeList->GetData();
802
803 m_pFreeBlocks->m_dwRefs++;
804 m_dwAllocatedObjects++;
805
806 XTP_BATCHALLOC_OBJ_HEADER* pNextFree = m_pFreeBlocks->pFreeList->pNextFree;
807 m_pFreeBlocks->pFreeList->pNextFree = NULL;
808 m_pFreeBlocks->pFreeList = pNextFree;
809
810 // no more free objects, move to busy blocks
811 if (!pNextFree)
812 {
813 XTP_BATCHALLOC_BLOCK_HEADER* pNewBusyBlock = m_pFreeBlocks;
814 m_pFreeBlocks = m_pFreeBlocks->pPrev ? m_pFreeBlocks->pPrev : m_pFreeBlocks->pNext;
815 if (m_pFreeBlocks)
816 m_pFreeBlocks->pPrev = pNewBusyBlock->pPrev;
817
818 pNewBusyBlock->pNext = m_pBusyBlocks;
819 pNewBusyBlock->pPrev = m_pBusyBlocks ? m_pBusyBlocks->pPrev : NULL;
820 if (m_pBusyBlocks)
821 m_pBusyBlocks->pPrev = pNewBusyBlock;
822 m_pBusyBlocks = pNewBusyBlock;
823 }
824
825 return pData;
826 }
827
828 static void AFX_CDECL FreeData(void* pObj)
829 {
830 if (!pObj)
831 return;
832
833 XTP_BATCHALLOC_OBJ_HEADER* pObjHdr = XTP_BATCHALLOC_OBJ_HEADER::GetHeader(pObj);
834 pObjHdr->pNextFree = pObjHdr->pBlockHeader->pFreeList;
835 pObjHdr->pBlockHeader->pFreeList = pObjHdr;
836
837 pObjHdr->pBlockHeader->m_dwRefs--;
838 m_dwAllocatedObjects--;
839
840 // was busy block, move to free list
841 if (pObjHdr->pNextFree == NULL)
842 {
843 XTP_BATCHALLOC_BLOCK_HEADER* pNewFreeBlock = pObjHdr->pBlockHeader;
844 if (pNewFreeBlock->pPrev)
845 pNewFreeBlock->pPrev->pNext = pNewFreeBlock->pNext;
846
847 if (pNewFreeBlock->pNext)
848 pNewFreeBlock->pNext->pPrev = pNewFreeBlock->pPrev;
849
850 if (m_pBusyBlocks == pNewFreeBlock)
851 m_pBusyBlocks = pNewFreeBlock->pPrev ? pNewFreeBlock->pPrev : pNewFreeBlock->pNext;
852
853 pNewFreeBlock->pNext = m_pFreeBlocks;
854 pNewFreeBlock->pPrev = m_pFreeBlocks ? m_pFreeBlocks->pPrev : NULL;
855 if (m_pFreeBlocks)
856 m_pFreeBlocks->pPrev = pNewFreeBlock;
857 m_pFreeBlocks = pNewFreeBlock;
858 }
859
860 // block is totally free, destroy block
861 if (pObjHdr->pBlockHeader->m_dwRefs == 0 && m_bDestroyEmptyBlocksOnFree)
862 {
863 XTP_BATCHALLOC_BLOCK_HEADER* pEmptyBlock = pObjHdr->pBlockHeader;
864
865 XTP_BATCHALLOC_BLOCK_HEADER* pIsNextFree = pEmptyBlock->pPrev ? pEmptyBlock->pPrev
866 : pEmptyBlock->pNext;
867 BOOL bLast = (m_pFreeBlocks == pEmptyBlock) && pIsNextFree;
868
869 // do not destroy last free block
870 if (!bLast || m_bDestroyLastEmptyBlockOnFree)
871 {
872 if (pEmptyBlock->pPrev)
873 pEmptyBlock->pPrev->pNext = pEmptyBlock->pNext;
874 if (pEmptyBlock->pNext)
875 pEmptyBlock->pNext->pPrev = pEmptyBlock->pPrev;
876
877 if (m_pFreeBlocks == pEmptyBlock)
878 m_pFreeBlocks = pEmptyBlock->pPrev ? pEmptyBlock->pPrev : pEmptyBlock->pNext;
879
880 _TAllocator::Free_mem(pEmptyBlock);
881 }
882 }
883
884 // if (m_dwAllocatedObjects == 0)
885 // FreeExtraData();
886 }
887
888public:
889 static void AFX_CDECL FreeExtraData()
890 {
891 XTP_BATCHALLOC_BLOCK_HEADER* pBlock = m_pFreeBlocks;
892 while (pBlock && pBlock->pPrev)
893 {
894 pBlock = pBlock->pPrev;
895 }
896
897 while (pBlock)
898 {
899 // block is totally free, destroy block
900 if (pBlock->m_dwRefs == 0)
901 {
902 XTP_BATCHALLOC_BLOCK_HEADER* pEmptyBlock = pBlock;
903
904 if (pEmptyBlock->pPrev)
905 pEmptyBlock->pPrev->pNext = pEmptyBlock->pNext;
906
907 if (pEmptyBlock->pNext)
908 pEmptyBlock->pNext->pPrev = pEmptyBlock->pPrev;
909
910 if (m_pFreeBlocks == pEmptyBlock)
911 m_pFreeBlocks = pEmptyBlock->pPrev ? pEmptyBlock->pPrev : pEmptyBlock->pNext;
912
913 pBlock = pBlock->pNext;
914
915 TAllocator::Free_mem(pEmptyBlock);
916 }
917 else
918 {
919 pBlock = pBlock->pNext;
920 }
921 }
922 }
923};
995template<class _TObject, class _TBatchAllocData, class _TAllocator = _TObject::TAllocator>
996class CXTPBatchAllocObjT : public _TObject
997{
998public:
1000 typedef _TObject TObject;
1001 typedef _TBatchAllocData TBatchAllocData;
1002 typedef _TAllocator TAllocator;
1003
1004 typedef CXTPBatchAllocManagerT<_TAllocator, _TBatchAllocData> TBlockMan;
1007public:
1016 static void AFX_CDECL FreeExtraData()
1017 {
1018 TBlockMan::FreeExtraData();
1019 }
1020
1030 void* PASCAL operator new(size_t nSize)
1031 {
1032 if (TBlockMan::m_bBatchAllocationEnabled)
1033 return TBlockMan::AllocData(nSize);
1034 else
1035 return _TObject::operator new(nSize);
1036 }
1037
1046 void PASCAL operator delete(void* p)
1047 {
1048 if (TBlockMan::m_bBatchAllocationEnabled)
1049 TBlockMan::FreeData(p);
1050 else
1051 _TObject::operator delete(p);
1052 }
1053
1055 // void* PASCAL operator new(size_t, void* p) {return p; /**< } // default is fine as is */
1056
1057# if _MSC_VER >= 1200
1058 void PASCAL operator delete(void* p, void* pPlace)
1059 {
1060 if (TBlockMan::m_bBatchAllocationEnabled)
1061 TBlockMan::FreeData(p);
1062 else
1063 _TObject::operator delete(p, pPlace);
1064 }
1065# endif
1066
1067# if defined(_DEBUG) && !defined(_AFX_NO_DEBUG_CRT)
1068 // for file name/line number tracking using DEBUG_NEW
1069 void* PASCAL operator new(size_t nSize, LPCSTR lpszFileName, int nLine)
1070 {
1071 if (TBlockMan::m_bBatchAllocationEnabled)
1072 return operator new(nSize);
1073 else
1074 return _TObject::operator new(nSize, lpszFileName, nLine);
1075 }
1076
1077# if _MSC_VER >= 1200
1078 void PASCAL operator delete(void* p, LPCSTR lpszFileName, int nLine)
1079 {
1080 if (TBlockMan::m_bBatchAllocationEnabled)
1081 operator delete(p);
1082 else
1083 _TObject::operator delete(p, lpszFileName, nLine);
1084 }
1085# endif
1086# endif
1088};
1089
1091# define XTP_DECLARE_BATCH_ALLOC_OBJ_DATA_(dataClass, EXPORT_PARAMS) \
1092 struct EXPORT_PARAMS dataClass \
1093 { \
1094 static BOOL m_bBatchAllocationEnabled; \
1095 static LONG m_dwAllocatedObjects; \
1096 static BOOL m_bDestroyEmptyBlocksOnFree; \
1097 static BOOL m_bDestroyLastEmptyBlockOnFree; \
1098 static int m_nBlockSize; \
1099 \
1100 static BOOL AFX_CDECL IsDataEmpty() \
1101 { \
1102 return !m_pFreeBlocks && !m_pBusyBlocks; \
1103 }; \
1104 \
1105 protected: \
1106 static XTP_BATCHALLOC_BLOCK_HEADER* m_pFreeBlocks; \
1107 static XTP_BATCHALLOC_BLOCK_HEADER* m_pBusyBlocks; \
1108 };
1135# define XTP_DECLARE_BATCH_ALLOC_OBJ_DATA(dataClass) \
1136 XTP_DECLARE_BATCH_ALLOC_OBJ_DATA_(dataClass, XTP_EXPORT_PARAMS_NO)
1137
1165# define XTP_IMPLEMENT_BATCH_ALLOC_OBJ_DATA(dataClass, objClass, batchAllocEnabled) \
1166 BOOL dataClass::m_bBatchAllocationEnabled = batchAllocEnabled; \
1167 LONG dataClass::m_dwAllocatedObjects = 0; \
1168 int dataClass::m_nBlockSize = 1024; \
1169 BOOL dataClass::m_bDestroyEmptyBlocksOnFree = FALSE; \
1170 BOOL dataClass::m_bDestroyLastEmptyBlockOnFree = FALSE; \
1171 XTP_BATCHALLOC_BLOCK_HEADER* dataClass::m_pFreeBlocks = NULL; \
1172 XTP_BATCHALLOC_BLOCK_HEADER* dataClass::m_pBusyBlocks = NULL; \
1173 objClass::TBlockMan gs_##objClass##_BlocksManager;
1174
1175# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
1177#endif // !defined(_XTPCUSTOMHEAP_H__)
XTPHeapSetLowFragmentation
_XTP_EXT_CLASS BOOL AFX_CDECL XTPHeapSetLowFragmentation(HANDLE hHeapHandle)
Call this member to enable "Low-fragmentation Heap" (LFH) feature for a given heap.
XTPHeapSetCompatibilityInformation
_XTP_EXT_CLASS BOOL AFX_CDECL XTPHeapSetCompatibilityInformation(HANDLE hHeapHandle, PVOID pHeapInformation, ULONG_PTR nHeapInformationLength)
This function enables features for a specified heap.
XTPEnableNoisyWarnings.h
CXTPBatchAllocObjT
This template class used as a helper class to override new/delete operators and use batch allocation ...
Definition XTPCustomHeap.h:997
CXTPBatchAllocObjT::FreeExtraData
static void AFX_CDECL FreeExtraData()
This member function check all blocks and deallocate which are completely free.
Definition XTPCustomHeap.h:1016
CXTPHeapAllocatorT
This template class used as a base class for allocators which can use a custom (separate) heap.
Definition XTPCustomHeap.h:111
CXTPHeapAllocatorT::Free_mem
static void AFX_CDECL Free_mem(void *p)
Free memory block previously allocated by Alloc_mem.
Definition XTPCustomHeap.h:160
CXTPHeapAllocatorT::Alloc_mem
static void *AFX_CDECL Alloc_mem(size_t nBytes)
Allocate memory block of nBytes size.
Definition XTPCustomHeap.h:132
CXTPHeapObjectT
This template class used as a helper class to override new/delete operators and use custom heap alloc...
Definition XTPCustomHeap.h:335
CXTPHeapString
This class used to store strings.
Definition XTPCustomHeap.h:437
CXTPHeapString::_FreeStringData
virtual void _FreeStringData()
This method is used to free string data buffer previously allocated in _AllocStringData.
CXTPHeapString::m_nStrLen
int m_nStrLen
Stored string length (without null character).
Definition XTPCustomHeap.h:545
CXTPHeapString::~CXTPHeapString
virtual ~CXTPHeapString()
Default object destructor.
CXTPHeapString::CXTPHeapString
CXTPHeapString(LPCTSTR pcszString)
Object constructor.
CXTPHeapString::operator=
LPCTSTR operator=(LPCTSTR pcszString)
Assign new string value.
CXTPHeapString::operator!=
BOOL operator!=(LPCTSTR pcszString) const
Determine are strings different.
CXTPHeapString::CXTPHeapString
CXTPHeapString()
Default object constructor.
CXTPHeapString::AllocSysString
virtual BSTR AllocSysString() const
Allocates a BSTR from stored string data.
CXTPHeapString::SetString
virtual void SetString(LPCTSTR pcszString)
Use this method to set new string value.
CXTPHeapString::_AllocStringData
virtual void _AllocStringData(int nNewStrLen)
This method is used to allocate string data buffer.
CXTPHeapString::IsEmpty
virtual BOOL IsEmpty() const
Use this function to determine is string empty.
CXTPHeapString::m_pcszString
LPTSTR m_pcszString
Pointer to a stored string (or NULL).
Definition XTPCustomHeap.h:546
CXTPHeapString::operator==
BOOL operator==(LPCTSTR pcszString) const
Determine are strings equal.
CXTPHeapStringT
This template used to store strings using different allocators.
Definition XTPCustomHeap.h:562
CXTPHeapStringT::_FreeStringData
virtual void _FreeStringData()
This method is used to free string data buffer previously allocated in _AllocStringData.
Definition XTPCustomHeap.h:669
CXTPHeapStringT::operator=
LPCTSTR operator=(LPCTSTR pcszString)
Assign new string value.
Definition XTPCustomHeap.h:598
CXTPHeapStringT::operator!=
BOOL operator!=(LPCTSTR pcszString) const
Determine are strings different.
Definition XTPCustomHeap.h:623
CXTPHeapStringT::_AllocStringData
virtual void _AllocStringData(int nNewStrLen)
This method is used to allocate string data buffer.
Definition XTPCustomHeap.h:656
CXTPHeapStringT::CXTPHeapStringT
CXTPHeapStringT(LPCTSTR pcszString=_T(""))
Default object constructor.
Definition XTPCustomHeap.h:575
CXTPHeapStringT::~CXTPHeapStringT
virtual ~CXTPHeapStringT()
Default object destructor.
Definition XTPCustomHeap.h:586
CXTPHeapStringT::operator==
BOOL operator==(LPCTSTR pcszString) const
Determine are strings equal.
Definition XTPCustomHeap.h:611


Toolkit Pro: Member List

CXTPTaskPanelOffice2003Theme Member List

This is the complete list of members for CXTPTaskPanelOffice2003Theme, including all inherited members.

BlendColor(COLORREF clrFrom, COLORREF clrTo, int nAlpha) | CXTPTaskPanelPaintManager | protected
CreateGripperBitmaps() | CXTPTaskPanelPaintManager | protected
CreateGripperIcon(HICON &hIcon, UINT nIDResource, COLORREF clrGripperBack) | CXTPTaskPanelPaintManager | protected
CXTPTaskPanelOffice2003Theme() | CXTPTaskPanelOffice2003Theme |
CXTPTaskPanelPaintManager() | CXTPTaskPanelPaintManager |
DrawCaptionGripper(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelPaintManager | protectedvirtual
DrawCaptionGripperBitmap(CDC *pDC, CXTPTaskPanelGroup *pGroup, BOOL bExpanded, BOOL bHot, CRect rc) | CXTPTaskPanelPaintManager | protected
DrawCaptionGripperSigns(CDC *pDC, CPoint pt, COLORREF clr, BOOL bExpanded) | CXTPTaskPanelPaintManager | protected
DrawDragArrow(CDC *pDC, CXTPTaskPanelItem *pItem, CRect rc, BOOL bAfter=FALSE) | CXTPTaskPanelPaintManager | protectedvirtual
DrawFocusRect(CDC *pDC, CRect rc) | CXTPTaskPanelPaintManager | protectedvirtual
DrawGroupCaption(CDC *pDC, CXTPTaskPanelGroup *pGroup, BOOL bDraw) | CXTPTaskPanelPaintManager | virtual
DrawGroupClient(CDC *pDC, CXTPTaskPanelGroup *pGroup) | CXTPTaskPanelPaintManager | virtual
DrawGroupClientFace(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelPaintManager | protectedvirtual
DrawGroupClientItems(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelPaintManager | protectedvirtual
DrawGroupItem(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw) | CXTPTaskPanelPaintManager | virtual
DrawGroupItemFrame(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc) | CXTPTaskPanelPaintManager | virtual
DrawGroupItemImage(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw) | CXTPTaskPanelPaintManager | protected
DrawGroupItemImageWithText(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw) | CXTPTaskPanelPaintManager | protected
DrawGroupItemImageWithTextBelow(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw) | CXTPTaskPanelPaintManager | protected
DrawItemCaption(CDC *pDC, CXTPTaskPanelItem *pItem, CRect rcText, UINT nFormat) | CXTPTaskPanelPaintManager | protectedvirtual
DrawItemImage(CDC *pDC, CXTPTaskPanelItem *pItem, CPoint ptIcon, CXTPImageManagerIcon *pImage, CSize szIcon) | CXTPTaskPanelPaintManager | protectedvirtual
DrawScrollButton(CDC *pDC, CXTPTaskPanelScrollButton *pScrollButton) | CXTPTaskPanelPaintManager | virtual
FillGroupClientFace(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelPaintManager | virtual
FillTaskPanel(CDC *pDC, CXTPTaskPanel *pTaskPanel) | CXTPTaskPanelPaintManager | virtual
FreeBitmaps() | CXTPTaskPanelPaintManager | protected
GetCaptionGripperWidth(CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelPaintManager | protectedvirtual
GetControlMargins(const CXTPTaskPanel *pPanel) | CXTPTaskPanelPaintManager | virtual
GetGroupColors(BOOL bSpecial) | CXTPTaskPanelPaintManager |
GetGroupColors(CXTPTaskPanelGroup *pGroup) | CXTPTaskPanelPaintManager | virtual
GetGroupInnerMargins(const CXTPTaskPanelGroup *pGroup) | CXTPTaskPanelPaintManager | virtual
GetGroupOuterMargins(const CXTPTaskPanelGroup *pGroup) | CXTPTaskPanelPaintManager | virtual
GetGroupSpacing(const CXTPTaskPanel *pPanel) | CXTPTaskPanelPaintManager | virtual
GetHighlightOffset(CXTPTaskPanelGroupItem *pItem) | CXTPTaskPanelPaintManager | protectedvirtual
GetItemFont(CXTPTaskPanelItem *pItem) | CXTPTaskPanelPaintManager | virtual
GetItemIconPadding(const CXTPTaskPanelItem *pItem) | CXTPTaskPanelPaintManager | virtual
GetItemInnerMargins(const CXTPTaskPanelGroupItem *pItem) | CXTPTaskPanelPaintManager | virtual
GetItemOuterMargins(const CXTPTaskPanelGroupItem *pItem) | CXTPTaskPanelPaintManager | virtual
m_bBoldCaption | CXTPTaskPanelPaintManager |
m_bCaptionScrollButton | CXTPTaskPanelPaintManager |
m_bEmbossedDisabledText | CXTPTaskPanelPaintManager |
m_bEmulateEplorerTheme | CXTPTaskPanelPaintManager |
m_bInvertDragRect | CXTPTaskPanelPaintManager |
m_bLeftRoundedCorner | CXTPTaskPanelPaintManager | protected
m_bmpGrippers | CXTPTaskPanelPaintManager | protected
m_bOfficeBorder | CXTPTaskPanelPaintManager | protected
m_bOfficeHighlight | CXTPTaskPanelPaintManager |
m_bRightRoundedCorner | CXTPTaskPanelPaintManager | protected
m_bUseBitmapGrippers | CXTPTaskPanelPaintManager | protected
m_bUseStandardCaptionFont | CXTPTaskPanelPaintManager | protected
m_bUseStandardItemsFont | CXTPTaskPanelPaintManager | protected
m_clrBackground | CXTPTaskPanelPaintManager | protected
m_clrHighlightBorder | CXTPTaskPanelPaintManager | protected
m_clrHighlightHot | CXTPTaskPanelPaintManager | protected
m_clrHighlightPressed | CXTPTaskPanelPaintManager | protected
m_clrHighlightSelected | CXTPTaskPanelPaintManager | protected
m_eGripper | CXTPTaskPanelPaintManager |
m_groupNormal | CXTPTaskPanelPaintManager | protected
m_groupSpecial | CXTPTaskPanelPaintManager | protected
m_hGripperNormal | CXTPTaskPanelPaintManager | protected
m_hGripperSpecial | CXTPTaskPanelPaintManager | protected
m_nCaptionHeight | CXTPTaskPanelPaintManager | protected
m_nCaptionTextFormat | CXTPTaskPanelPaintManager | protected
m_nGroupSpacing | CXTPTaskPanelPaintManager |
m_nItemTextFormat | CXTPTaskPanelPaintManager | protected
m_rcControlMargins | CXTPTaskPanelPaintManager |
m_rcGroupIconPadding | CXTPTaskPanelPaintManager |
m_rcGroupInnerMargins | CXTPTaskPanelPaintManager |
m_rcGroupOuterMargins | CXTPTaskPanelPaintManager |
m_rcImageLayoutIconPadding | CXTPTaskPanelPaintManager |
m_rcItemIconPadding | CXTPTaskPanelPaintManager |
m_rcItemInnerMargins | CXTPTaskPanelPaintManager |
m_rcItemOuterMargins | CXTPTaskPanelPaintManager |
m_xtpFontCaption | CXTPTaskPanelPaintManager | protected
m_xtpFontIcon | CXTPTaskPanelPaintManager | protected
m_xtpFontIconBold | CXTPTaskPanelPaintManager | protected
m_xtpFontIconHot | CXTPTaskPanelPaintManager | protected
m_xtpFontIconHotBold | CXTPTaskPanelPaintManager | protected
Rectangle(CDC *pDC, CRect rc, COLORREF clrPen, COLORREF clrBrush) | CXTPTaskPanelPaintManager | protected
rectDefault | CXTPTaskPanelPaintManager | static
RefreshMetrics() | CXTPTaskPanelOffice2003Theme | virtual
SetCaptionFontIndirect(LOGFONT *pLogFont, BOOL bUseStandardCaptionFont=FALSE) | CXTPTaskPanelPaintManager |
SetItemsFontIndirect(LOGFONT *pLogFont, BOOL bUseStandardItemsFont=FALSE) | CXTPTaskPanelPaintManager |
SetTextFormat(int nTextFormat, BOOL bCaption=FALSE) | CXTPTaskPanelPaintManager |
~CXTPTaskPanelPaintManager() | CXTPTaskPanelPaintManager | virtual


Toolkit Pro: XTPMarkupShape.h Source File

  • Source
  • Markup
  • Shapes
XTPMarkupShape.h
Go to the documentation of this file.
1
23#if !defined(__XTPMARKUPSHAPE_H__)
24# define __XTPMARKUPSHAPE_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPMarkupBrush;
34class CXTPMarkupStrokeStyle;
35class CXTPMarkupDoubleCollection;
36class CXTPMarkupBuilder;
37class CXTPMarkupObject;
38class CXTPMarkupDependencyProperty;
39
40enum XTPMarkupStretch
41{
42 xtpMarkupStretchNone,
43 xtpMarkupStretchFill,
44 xtpMarkupStretchUniform,
45 xtpMarkupStretchUniformToFill
46};
47
48class _XTP_EXT_CLASS CXTPMarkupShape : public CXTPMarkupFrameworkElement
49{
51 DECLARE_MARKUPCLASS(CXTPMarkupShape)
53protected:
54 CXTPMarkupShape();
55 virtual ~CXTPMarkupShape();
56
57public:
58 void SetFill(CXTPMarkupBrush* pBrush);
59 CXTPMarkupBrush* GetFill() const;
60
61 void SetStroke(CXTPMarkupBrush* pBrush);
62 CXTPMarkupBrush* GetStroke() const;
63
64 void SetStrokeThickness(int nThickness);
65 int GetStrokeThickness() const;
66
67 XTPMarkupStretch GetStretch() const;
68
69 CXTPMarkupDoubleCollection* GetStrokeDashArray() const;
70 void SetStrokeDashArray(CXTPMarkupDoubleCollection* pStrokeDashArray);
71
72 void GetStrokeStyle(CXTPMarkupStrokeStyle* pStrokeStyle) const;
73
74 XTPMarkupLineCap GetStrokeStartLineCap() const;
75 void SetStrokeStartLineCap(XTPMarkupLineCap nLineCap);
76
77 XTPMarkupLineCap GetStrokeEndLineCap() const;
78 void SetStrokeEndLineCap(XTPMarkupLineCap nLineCap);
79
80 XTPMarkupLineJoin GetStrokeLineJoin() const;
81 void SetStrokeLineJoin(XTPMarkupLineJoin nLineJoin);
82
83 XTPMarkupSmoothingMode GetSmoothingMode() const;
84 void SetSmoothingMode(XTPMarkupSmoothingMode smoothingMode);
85
86public:
87 static CXTPMarkupObject* AFX_CDECL
88 ConvertLineCap(CXTPMarkupBuilder* pBuilder, CXTPMarkupObject* pObject,
89 CXTPMarkupDependencyProperty* pAssociatedProperty = NULL);
90 static CXTPMarkupObject* AFX_CDECL
91 ConvertLineJoin(CXTPMarkupBuilder* pBuilder, CXTPMarkupObject* pObject,
92 CXTPMarkupDependencyProperty* pAssociatedProperty = NULL);
93 static CXTPMarkupObject* AFX_CDECL
94 ConvertSmoothing(CXTPMarkupBuilder* pBuilder, CXTPMarkupObject* pObject,
95 CXTPMarkupDependencyProperty* pAssociatedProperty = NULL);
97public:
98 DECLARE_DISPATCH_MAP()
99# ifdef _XTP_ACTIVEX
100 DECLARE_INTERFACE_MAP()
101 DECLARE_OLETYPELIB_EX(CXTPMarkupShape);
102# endif
103
104 afx_msg LPDISPATCH OleGetFill();
105 afx_msg void OleSetFill(LPDISPATCH lpBackground);
106 afx_msg LPDISPATCH OleGetStroke();
107 afx_msg void OleSetStroke(LPDISPATCH lpBackground);
108 afx_msg int OleGetStrokeThickness();
109 afx_msg void OleSetStrokeThickness(int lpThickness);
110 afx_msg int OleGetStrokeStartLineCap();
111 afx_msg void OleSetStrokeStartLineCap(int nValue);
112 afx_msg int OleGetStrokeEndLineCap();
113 afx_msg void OleSetStrokeEndLineCap(int nValue);
114 afx_msg int OleGetStrokeLineJoin();
115 afx_msg void OleSetStrokeLineJoin(int nValue);
116 afx_msg LPDISPATCH OleGetStrokeDashArray();
117 afx_msg void OleSetStrokeDashArray(LPDISPATCH lpValue);
118
121public:
122 static CXTPMarkupDependencyProperty* m_pStrokeProperty;
123 static CXTPMarkupDependencyProperty* m_pFillProperty;
124 static CXTPMarkupDependencyProperty* m_pStrokeThicknessProperty;
125 static CXTPMarkupDependencyProperty* m_pStretchProperty;
126
127 static CXTPMarkupDependencyProperty* m_pStrokeDashArrayProperty;
128 static CXTPMarkupDependencyProperty* m_pStrokeStartLineCapProperty;
129 static CXTPMarkupDependencyProperty* m_pStrokeEndLineCapProperty;
130 static CXTPMarkupDependencyProperty* m_pStrokeLineJoinProperty;
131 static CXTPMarkupDependencyProperty* m_pSmoothingMode;
132
133 static CXTPMarkupDependencyProperty* m_pPropertyStrokeMiterLimit;
134};
135
136# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
138#endif // !defined(__XTPMARKUPSHAPE_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPMarkupSmoothingMode
XTPMarkupSmoothingMode
Defines markup smoothing mode.
Definition XTPMarkupContext.h:69
CXTPMarkupFrameworkElement
This class represents the provided framework-level implementation built on CXTPMarkupUIElement.
Definition XTPMarkupFrameworkElement.h:44


Toolkit Pro: XTPMarkupRender.h Source File

  • Source
  • Common
XTPMarkupRender.h
Go to the documentation of this file.
1
23#if !defined(__XTPMARKUPRENDER_H__)
24# define __XTPMARKUPRENDER_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPMarkupContext;
34class CXTPMarkupUIElement;
35
48const UINT XTP_WM_MARKUPREDRAW = (WM_USER + 9820);
49
74_XTP_EXT_CLASS CXTPMarkupContext* AFX_CDECL XTPMarkupCreateContext(HWND hWnd = NULL,
75 BOOL bDpiAware = FALSE);
76
102_XTP_EXT_CLASS CXTPMarkupContext* AFX_CDECL XTPMarkupCreateContext(HWND hWnd, RECT rcUpdate,
103 BOOL bDpiAware);
104
112_XTP_EXT_CLASS void AFX_CDECL XTPMarkupAssignHandle(CXTPMarkupContext* pContext, HWND hWnd);
113
122_XTP_EXT_CLASS void AFX_CDECL XTPMarkupAssignHandle(CXTPMarkupContext* pContext, HWND hWnd,
123 CRect rcUpdate);
124
139_XTP_EXT_CLASS void AFX_CDECL XTPMarkupReleaseContext(CXTPMarkupContext*& pContext);
140
157_XTP_EXT_CLASS void AFX_CDECL XTPMarkupReleaseContext(CXTPMarkupContext*& pContext, BOOL bShutdown);
158
172_XTP_EXT_CLASS CXTPMarkupUIElement* AFX_CDECL XTPMarkupParseText(CXTPMarkupContext* pContext,
173 LPCSTR lpszMarkup);
174
188_XTP_EXT_CLASS CXTPMarkupUIElement* AFX_CDECL XTPMarkupParseText(CXTPMarkupContext* pContext,
189 LPCWSTR lpszMarkup);
190
205_XTP_EXT_CLASS CXTPMarkupUIElement* AFX_CDECL XTPMarkupParseText(CXTPMarkupContext* pContext,
206 LPCSTR lpszMarkup,
207 INT_PTR nLength);
208
223_XTP_EXT_CLASS CXTPMarkupUIElement* AFX_CDECL XTPMarkupParseText(CXTPMarkupContext* pContext,
224 LPCWSTR lpszMarkup,
225 INT_PTR nLength);
226
240_XTP_EXT_CLASS CXTPMarkupUIElement* AFX_CDECL XTPMarkupParseText(CXTPMarkupContext* pContext,
241 IStream* pStream);
242
255_XTP_EXT_CLASS void AFX_CDECL XTPMarkupReleaseElement(CXTPMarkupUIElement*& pElement);
256
271_XTP_EXT_CLASS CSize AFX_CDECL XTPMarkupMeasureElement(CXTPMarkupUIElement* pElement,
272 int cxAvail = INT_MAX,
273 int cyAvail = INT_MAX);
274
289_XTP_EXT_CLASS void AFX_CDECL XTPMarkupRenderElement(CXTPMarkupUIElement* pElement, HDC hDC,
290 LPCRECT rc);
291
317_XTP_EXT_CLASS void AFX_CDECL XTPMarkupSetDefaultFont(CXTPMarkupContext* pContext, HFONT hFont,
318 COLORREF clrText);
319
334_XTP_EXT_CLASS BOOL AFX_CDECL XTPMarkupRelayMessage(CXTPMarkupUIElement* pElement, UINT message,
335 WPARAM wParam, LPARAM lParam, LRESULT* pResult);
336
351_XTP_EXT_CLASS BOOL AFX_CDECL XTPMarkupRelayMessage(CXTPMarkupContext* pContext, UINT message,
352 WPARAM wParam, LPARAM lParam, LRESULT* pResult);
353
363_XTP_EXT_CLASS CXTPMarkupContext* AFX_CDECL XTPMarkupElementContext(CXTPMarkupUIElement* pElement);
364
365_XTP_EXT_CLASS void AFX_CDECL XTPMarkupDrawText(CXTPMarkupContext* pContext, HDC hDC,
366 LPCTSTR lpszText, LPRECT lpRect, UINT nFormat);
367
368# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
370#endif // !defined(__XTPMARKUPRENDER_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTP_WM_MARKUPREDRAW
const UINT XTP_WM_MARKUPREDRAW
Notifies Markup context window about Markup redraw event.
Definition XTPMarkupRender.h:48
XTPMarkupElementContext
_XTP_EXT_CLASS CXTPMarkupContext *AFX_CDECL XTPMarkupElementContext(CXTPMarkupUIElement *pElement)
XTPMarkupElementContext is part of Markup API that returns Markup contrext of Markup element.
XTPMarkupRenderElement
_XTP_EXT_CLASS void AFX_CDECL XTPMarkupRenderElement(CXTPMarkupUIElement *pElement, HDC hDC, LPCRECT rc)
XTPMarkupRenderElement is part of Markup API that draws Markup element to device context.
XTPMarkupSetDefaultFont
_XTP_EXT_CLASS void AFX_CDECL XTPMarkupSetDefaultFont(CXTPMarkupContext *pContext, HFONT hFont, COLORREF clrText)
XTPMarkupSetDefaultFont is part of Markup API.
XTPMarkupReleaseElement
_XTP_EXT_CLASS void AFX_CDECL XTPMarkupReleaseElement(CXTPMarkupUIElement *&pElement)
XTPMarkupReleaseElement is part of Markup API that destroys CXTPMarkupUIElement object.
XTPMarkupAssignHandle
_XTP_EXT_CLASS void AFX_CDECL XTPMarkupAssignHandle(CXTPMarkupContext *pContext, HWND hWnd)
Assigns handle to using the items specified by pContext and hWnd.
XTPMarkupParseText
_XTP_EXT_CLASS CXTPMarkupUIElement *AFX_CDECL XTPMarkupParseText(CXTPMarkupContext *pContext, LPCSTR lpszMarkup)
XTPMarkupParseText is part of Markup API that creates new Markup elements using Markup string.
XTPMarkupCreateContext
_XTP_EXT_CLASS CXTPMarkupContext *AFX_CDECL XTPMarkupCreateContext(HWND hWnd=NULL, BOOL bDpiAware=FALSE)
XTPMarkupCreateContext is part of Markup API that creates new CXTPMarkupContext object.
XTPMarkupRelayMessage
_XTP_EXT_CLASS BOOL AFX_CDECL XTPMarkupRelayMessage(CXTPMarkupUIElement *pElement, UINT message, WPARAM wParam, LPARAM lParam, LRESULT *pResult)
XTPMarkupRelayMessage is part of Markup API.
XTPMarkupReleaseContext
_XTP_EXT_CLASS void AFX_CDECL XTPMarkupReleaseContext(CXTPMarkupContext *&pContext)
XTPMarkupReleaseContext is part of Markup API that destroys CXTPMarkupContext object.
XTPMarkupMeasureElement
_XTP_EXT_CLASS CSize AFX_CDECL XTPMarkupMeasureElement(CXTPMarkupUIElement *pElement, int cxAvail=INT_MAX, int cyAvail=INT_MAX)
XTPMarkupMeasureElement is part of Markup API that calculates dimensions of Markup element.
CXTPMarkupContext
CXTPMarkupContext is a standalone class used to provide common settings for Markup objects.
Definition XTPMarkupContext.h:128
CXTPMarkupUIElement
Base class for XML Markup core level implementations.
Definition XTPMarkupUIElement.h:43


Toolkit Pro: XTPMathUtils.h Source File

  • Source
  • Common
  • Math
XTPMathUtils.h
Go to the documentation of this file.
1
23#if !defined(__XTPMATHUTILS_H__)
24# define __XTPMATHUTILS_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
36# define XTP_NAN CXTPMathUtils::GetNaN()
37
41# define XTP_ISNAN(v) CXTPMathUtils::IsNan(v)
42
48class _XTP_EXT_CLASS CXTPMathUtils
49{
50public:
61 static double AFX_CDECL NormalizeRadian(double angleRadian);
62
73 static double AFX_CDECL NormalizeDegree(double angle);
74
84 static int AFX_CDECL Sign(double value);
85
98 static int AFX_CDECL Compare(double value1, double value2);
99
113 static int AFX_CDECL Compare(double value1, double value2, double epsilon);
114
124 static double AFX_CDECL Radian2Degree(double angleRadian);
125
135 static double AFX_CDECL Degree2Radian(double angleDegree);
136
145 static int AFX_CDECL Round(double dValue);
146
155 static double AFX_CDECL GetNaN();
156
166 static BOOL AFX_CDECL IsNan(double x);
167
192 static void AFX_CDECL ComputeTriangleNormal(double x1, double y1, double z1, double x2,
193 double y2, double z2, double x3, double y3,
194 double z4, double& nx, double& ny, double& nz,
195 bool normalize = true, bool ccw = false);
196
207 static double AFX_CDECL GetSegmentLength(double x1, double y1, double x2, double y2);
208
221 static double AFX_CDECL GetSegmentLength(double x1, double y1, double z1, double x2, double y2,
222 double z2);
223
238 static BOOL AFX_CDECL HitTestLineSegment(double x1, double y1, double x2, double y2,
239 double xPoint, double yPoint, int nLineThickness);
240
259 static BOOL AFX_CDECL GetLinesIntersection(double x11, double y11, double x12, double y12,
260 double x21, double y21, double x22, double y22,
261 double& xi, double& yi);
262
279 static void AFX_CDECL ComputeVectorCrossProduct(double x1, double y1, double z1, double x2,
280 double y2, double z2, double& rx, double& ry,
281 double& rz);
282
297 static double AFX_CDECL ComputeVectorDotProduct(double x1, double y1, double z1, double x2,
298 double y2, double z2);
299
311 static double AFX_CDECL ComputeVectorLength(double x, double y, double z);
312
313public:
314 static const double m_dPI;
315 static const double m_dEPS;
316};
317
318# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
320#endif //#if !defined(__XTPMATHUTILS_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPMathUtils
This class provide some mathematical utility functions.
Definition XTPMathUtils.h:49
CXTPMathUtils::ComputeTriangleNormal
static void AFX_CDECL ComputeTriangleNormal(double x1, double y1, double z1, double x2, double y2, double z2, double x3, double y3, double z4, double &nx, double &ny, double &nz, bool normalize=true, bool ccw=false)
Computes a normal for a triangle specified.
CXTPMathUtils::Compare
static int AFX_CDECL Compare(double value1, double value2, double epsilon)
Call this function to compare two double values.It also checks whether they are equal or almost equal...
CXTPMathUtils::IsNan
static BOOL AFX_CDECL IsNan(double x)
Checks if the value provided is Not-a-Number (NaN) value.
CXTPMathUtils::ComputeVectorDotProduct
static double AFX_CDECL ComputeVectorDotProduct(double x1, double y1, double z1, double x2, double y2, double z2)
Computes vector cross product.
CXTPMathUtils::Degree2Radian
static double AFX_CDECL Degree2Radian(double angleDegree)
Call this function to convert degree angle to radian.
CXTPMathUtils::ComputeVectorCrossProduct
static void AFX_CDECL ComputeVectorCrossProduct(double x1, double y1, double z1, double x2, double y2, double z2, double &rx, double &ry, double &rz)
Computes vector cross product.
CXTPMathUtils::GetSegmentLength
static double AFX_CDECL GetSegmentLength(double x1, double y1, double z1, double x2, double y2, double z2)
Computes 3D line segment length.
CXTPMathUtils::Round
static int AFX_CDECL Round(double dValue)
Rounds a real value taking into account its sign and returns result as integer.
CXTPMathUtils::ComputeVectorLength
static double AFX_CDECL ComputeVectorLength(double x, double y, double z)
Computes vector length.
CXTPMathUtils::GetNaN
static double AFX_CDECL GetNaN()
Obtains Not-a-Number (NaN) value for double type.
CXTPMathUtils::m_dPI
static const double m_dPI
Pi value.
Definition XTPMathUtils.h:314
CXTPMathUtils::Compare
static int AFX_CDECL Compare(double value1, double value2)
Call this function to compare two double values.It also checks whether they are equal or almost equal...
CXTPMathUtils::Radian2Degree
static double AFX_CDECL Radian2Degree(double angleRadian)
Call this function to convert radian angle to degree.
CXTPMathUtils::NormalizeRadian
static double AFX_CDECL NormalizeRadian(double angleRadian)
Call this function to normalize angle in radian i.e.
CXTPMathUtils::GetSegmentLength
static double AFX_CDECL GetSegmentLength(double x1, double y1, double x2, double y2)
Computes 2D line segment length.
CXTPMathUtils::NormalizeDegree
static double AFX_CDECL NormalizeDegree(double angle)
Call this function to normalize angle in degree i.e.
CXTPMathUtils::Sign
static int AFX_CDECL Sign(double value)
Call this function to check the sign of a double value.
CXTPMathUtils::m_dEPS
static const double m_dEPS
The smallest possible double value, or epsilon.
Definition XTPMathUtils.h:315
CXTPMathUtils::HitTestLineSegment
static BOOL AFX_CDECL HitTestLineSegment(double x1, double y1, double x2, double y2, double xPoint, double yPoint, int nLineThickness)
Tests if the point specified hits a line segment determined by two points.
CXTPMathUtils::GetLinesIntersection
static BOOL AFX_CDECL GetLinesIntersection(double x11, double y11, double x12, double y12, double x21, double y21, double x22, double y22, double &xi, double &yi)
Computes a point where two lines detemined by four points intersect.


Toolkit Pro: Member List

CXTPDockingPaneVisualStudio2010Theme Member List

This is the complete list of members for CXTPDockingPaneVisualStudio2010Theme, including all inherited members.

AdjustCaptionRect(const CXTPDockingPaneSidePanel *pPane, CRect &rc) | CXTPDockingPanePaintManager | virtual
AdjustCaptionRect(const CXTPDockingPaneTabbedContainer *pPane, CRect &rc) | CXTPDockingPanePaintManager | virtual
AdjustClientRect(CXTPDockingPaneSidePanel *pPane, CRect &rect) | CXTPDockingPanePaintManager | virtual
AdjustClientRect(CXTPDockingPaneTabbedContainer *pPane, CRect &rect, BOOL bApply) | CXTPDockingPanePaintManager | virtual
ClipAndAddEllipsisIfNeeded(CDC *pDC, CString &strTitle, int nCaptionWidth) const | CXTPDockingPanePaintManager | protected
CXTPCmdTarget() | CXTPCmdTarget |
CXTPDockingPaneDefaultTheme() | CXTPDockingPaneDefaultTheme |
CXTPDockingPaneGripperedTheme() | CXTPDockingPaneGripperedTheme |
CXTPDockingPanePaintManager() | CXTPDockingPanePaintManager | protected
CXTPDockingPaneVisualStudio2003Theme() | CXTPDockingPaneVisualStudio2003Theme |
CXTPDockingPaneVisualStudio2005Beta1Theme() | CXTPDockingPaneVisualStudio2005Beta1Theme |
CXTPDockingPaneVisualStudio2005Beta2Theme() | CXTPDockingPaneVisualStudio2005Beta2Theme |
CXTPDockingPaneVisualStudio2005Theme() | CXTPDockingPaneVisualStudio2005Theme |
CXTPDockingPaneVisualStudio2008Theme() | CXTPDockingPaneVisualStudio2008Theme |
CXTPDockingPaneVisualStudio2010Theme() | CXTPDockingPaneVisualStudio2010Theme |
DrawAutoHidePanel(CDC *pDC, CRect rc, XTPDockingPaneDirection direction) | CXTPDockingPanePaintManager | virtual
DrawCaption(CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc) | CXTPDockingPaneGripperedTheme | virtual
DrawCaptionButton(CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton) | CXTPDockingPanePaintManager | virtual
DrawCaptionButtonEntry(CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton, CSize szOffset) | CXTPDockingPanePaintManager | protectedvirtual
DrawCaptionButtonEntry(CDC *pDC, CXTPDockingPaneCaptionButton *pButton, CPoint pt, COLORREF clrButton) | CXTPDockingPanePaintManager | protectedvirtual
DrawCaptionButtons(CDC *pDC, CXTPDockingPaneCaptionButtons *pButtons, CRect &rcCaption, COLORREF clr, int nButtonSize, int nButtonGap, BOOL bVertical=FALSE) | CXTPDockingPanePaintManager | virtual
DrawCaptionPart(CDC *pDC, CXTPDockingPaneBase *pPane, CRect rcCaption, const CString &strTitle, BOOL bActive, BOOL bVertical) | CXTPDockingPaneVisualStudio2003Theme | protectedvirtual
DrawCaptionText(CDC *pDC, const CString &strTitle, CRect rc, BOOL bVertical, BOOL bCalcWidth=FALSE) | CXTPDockingPanePaintManager |
DrawFloatingFrame(CDC *pDC, CXTPDockingPaneMiniWnd *pPane, CRect rc) | CXTPDockingPaneVisualStudio2010Theme | protectedvirtual
DrawPane(CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc) | CXTPDockingPanePaintManager | virtual
DrawSidePanel(CDC *pDC, CXTPDockingPaneSidePanel *pPane, CRect rc) | CXTPDockingPaneDefaultTheme | virtual
DrawSplitter(CDC *pDC, CXTPDockingPaneSplitterWnd *pSplitter) | CXTPDockingPanePaintManager | virtual
FillCaptionPart(CDC *pDC, CXTPDockingPaneBase *pPane, CRect rcCaption, BOOL bActive, BOOL bVertical) | CXTPDockingPaneVisualStudio2010Theme | protectedvirtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCaptionButtonStyle() const | CXTPDockingPanePaintManager |
GetCaptionGripperRect(const CXTPDockingPaneTabbedContainer *pPane) | CXTPDockingPanePaintManager | virtual
GetCaptionHeight() const | CXTPDockingPanePaintManager |
GetCaptionRect(const CXTPDockingPaneTabbedContainer *pPane, CRect &rc) | CXTPDockingPanePaintManager | virtual
GetCurrentSystemTheme() const | CXTPDockingPanePaintManager |
GetCustomTitleBrush(BOOL bActive, BOOL bVertical) const | CXTPDockingPanePaintManager |
GetPaneCaptionRect(const CXTPDockingPaneSidePanel *pPane) | CXTPDockingPanePaintManager | virtual
GetPanelPaintManager() const | CXTPDockingPanePaintManager |
GetSplitterStyle() const | CXTPDockingPanePaintManager |
GetTabPaintManager() const | CXTPDockingPanePaintManager |
GetTabsHeight() const | CXTPDockingPanePaintManager |
GetXtremeColor(UINT nIndex) | CXTPDockingPanePaintManager |
Line(CDC *pDC, int x0, int y0, int x1, int y1, int nPen) | CXTPDockingPanePaintManager |
Line(CDC *pDC, int x0, int y0, int x1, int y1) | CXTPDockingPanePaintManager |
m_arrColor | CXTPDockingPanePaintManager | protected
m_bDestroyCustomTitleBrushes | CXTPDockingPanePaintManager | protected
m_bDrawCaptionIcon | CXTPDockingPanePaintManager |
m_bDrawSingleTab | CXTPDockingPanePaintManager |
m_bGradientCaption | CXTPDockingPaneVisualStudio2003Theme | protected
m_bHighlightActiveCaption | CXTPDockingPanePaintManager |
m_bLunaTheme | CXTPDockingPanePaintManager | protected
m_bShowCaption | CXTPDockingPanePaintManager |
m_bUseBoldCaptionFont | CXTPDockingPanePaintManager |
m_bUseOfficeFont | CXTPDockingPanePaintManager | protected
m_bUseStandardFont | CXTPDockingPanePaintManager | protected
m_clrActiveCaption | CXTPDockingPanePaintManager |
m_clrActiveCaptionText | CXTPDockingPanePaintManager |
m_clrBackground | CXTPDockingPanePaintManager |
m_clrCaptionBorder | CXTPDockingPaneVisualStudio2005Beta2Theme | protected
m_clrDisabledCaptionText | CXTPDockingPanePaintManager |
m_clrNormalCaption | CXTPDockingPanePaintManager |
m_clrNormalCaptionText | CXTPDockingPanePaintManager |
m_clrSplitter | CXTPDockingPanePaintManager |
m_clrSplitterGradient | CXTPDockingPanePaintManager |
m_clrSplitterGripper | CXTPDockingPanePaintManager |
m_dwSplitterStyle | CXTPDockingPanePaintManager | protected
m_hbrActiveTitleHorz | CXTPDockingPanePaintManager | protected
m_hbrActiveTitleVert | CXTPDockingPanePaintManager | protected
m_hbrInactiveTitleHorz | CXTPDockingPanePaintManager | protected
m_hbrInactiveTitleVert | CXTPDockingPanePaintManager | protected
m_nCaptionButtonStyle | CXTPDockingPanePaintManager | protected
m_nCaptionFontGap | CXTPDockingPanePaintManager | protected
m_nSplitterIndent | CXTPDockingPanePaintManager |
m_nSplitterSize | CXTPDockingPanePaintManager |
m_nTabsHeight | CXTPDockingPanePaintManager | protected
m_nTitleHeight | CXTPDockingPanePaintManager | protected
m_pPanelPaintManager | CXTPDockingPanePaintManager | protected
m_pTabPaintManager | CXTPDockingPanePaintManager | protected
m_rcCaptionMargin | CXTPDockingPanePaintManager | protected
m_strOfficeFont | CXTPDockingPanePaintManager | protected
m_systemTheme | CXTPDockingPanePaintManager | protected
m_themeButton | CXTPDockingPanePaintManager | protected
m_themeCurrent | CXTPDockingPanePaintManager | protected
m_themeExplorer | CXTPDockingPanePaintManager | protected
m_themeRebar | CXTPDockingPanePaintManager | protected
m_themeToolbar | CXTPDockingPanePaintManager | protected
m_themeWindow | CXTPDockingPanePaintManager | protected
m_xtpFontTitle | CXTPDockingPanePaintManager | protected
m_xtpFontTitleVertical | CXTPDockingPanePaintManager | protected
Pixel(CDC *pDC, int xPos, int yPos, int nPen) | CXTPDockingPanePaintManager |
Rectangle(CDC *pDC, CRect rc, int nPenEntry, int nPenBorder) | CXTPDockingPanePaintManager |
RefreshMetrics() | CXTPDockingPaneVisualStudio2010Theme | virtual
SetCaptionButtonStyle(XTPDockingPaneCaptionButtonStyle nStyle) | CXTPDockingPanePaintManager |
SetCaptionFontIndirect(LOGFONT *pLogFont, BOOL bUseStandardFont=FALSE) | CXTPDockingPanePaintManager |
SetColors(int cElements, CONST INT *lpaElements, CONST COLORREF *lpaRgbValues) | CXTPDockingPanePaintManager |
SetCustomTitleBrushes(HBRUSH hbrActiveTitleHorz, HBRUSH hbrInactiveTitleHorz=NULL, HBRUSH hbrActiveTitleVert=NULL, HBRUSH hbrInactiveTitleVert=NULL, BOOL bDestroyOnCleanup=FALSE) | CXTPDockingPanePaintManager |
SetLunaTheme(XTPCurrentSystemTheme systemTheme) | CXTPDockingPanePaintManager |
SetPanelPaintManager(CXTPTabPaintManager *pManager) | CXTPDockingPanePaintManager |
SetSplitterStyle(DWORD dwStyle) | CXTPDockingPanePaintManager |
SetTabPaintManager(CXTPTabPaintManager *pManager) | CXTPDockingPanePaintManager |
UseOfficeFont(BOOL bUseOfficeFont) | CXTPDockingPanePaintManager |
~CXTPDockingPanePaintManager() | CXTPDockingPanePaintManager | protectedvirtual


Toolkit Pro: Member List

XTP_COMMANDBARS_PROPEXCHANGE_PARAM Member List

This is the complete list of members for XTP_COMMANDBARS_PROPEXCHANGE_PARAM, including all inherited members.

bLoadSilent | XTP_COMMANDBARS_PROPEXCHANGE_PARAM
bSaveOnlyCustomized | XTP_COMMANDBARS_PROPEXCHANGE_PARAM
bSaveOriginalControls | XTP_COMMANDBARS_PROPEXCHANGE_PARAM
bSerializeActions | XTP_COMMANDBARS_PROPEXCHANGE_PARAM
bSerializeControls | XTP_COMMANDBARS_PROPEXCHANGE_PARAM
bSerializeDesignerControls | XTP_COMMANDBARS_PROPEXCHANGE_PARAM
bSerializeImages | XTP_COMMANDBARS_PROPEXCHANGE_PARAM
bSerializeLayout | XTP_COMMANDBARS_PROPEXCHANGE_PARAM
bSerializeOptions | XTP_COMMANDBARS_PROPEXCHANGE_PARAM
pCommandBars | XTP_COMMANDBARS_PROPEXCHANGE_PARAM


Toolkit Pro: XTPChartFunnelSeriesStyle.h Source File

  • Source
  • Chart
  • Styles
  • Funnel
XTPChartFunnelSeriesStyle.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTFUNNELSERIESSTYLE_H__)
24# define __XTPCHARTFUNNELSERIESSTYLE_H__
26# if _MSC_VER >= 1000
27# pragma once
28# endif // _MSC_VER >= 1000
29
30# include "Chart/Styles/Funnel/Base/XTPChartFunnelSeriesStyleBase.h"
31# include "Chart/Styles/Funnel/2D/XTPChart2dFunnelSeriesStyle.h"
32
33// CXTPChart2dFunnelSeriesStyle alias is necessary for naming consistency.
34typedef CXTPChartFunnelSeriesStyle CXTPChart2dFunnelSeriesStyle;
36#endif //#if !defined(__XTPCHARTFUNNELSERIESSTYLE_H__)
XTPChart2dFunnelSeriesStyle.h
XTPChartFunnelSeriesStyleBase.h
CXTPChartFunnelSeriesStyle
This class abstracts the basic style of a funnel series.
Definition XTPChart2dFunnelSeriesStyle.h:49


Toolkit Pro: Member List

CXTPFlowGraphUndoSetNodeCaptionCommand Member List

This is the complete list of members for CXTPFlowGraphUndoSetNodeCaptionCommand, including all inherited members.

CXTPFlowGraphUndoCommand(int nID) | CXTPFlowGraphUndoCommand | protected
CXTPFlowGraphUndoSetNodeCaptionCommand(CXTPFlowGraphElement *pNode, CString strOldCaption) | CXTPFlowGraphUndoSetNodeCaptionCommand |
GetID() const | CXTPFlowGraphUndoCommand |
m_nID | CXTPFlowGraphUndoCommand | protected
m_pNode | CXTPFlowGraphUndoSetNodeCaptionCommand | protected
m_strOldCaption | CXTPFlowGraphUndoSetNodeCaptionCommand | protected
Undo() | CXTPFlowGraphUndoSetNodeCaptionCommand | protectedvirtual
~CXTPFlowGraphUndoCommand() | CXTPFlowGraphUndoCommand | protectedvirtual
~CXTPFlowGraphUndoSetNodeCaptionCommand() | CXTPFlowGraphUndoSetNodeCaptionCommand | virtual


Toolkit Pro: Member List

CXTPTrackThemeOffice2013 Member List

This is the complete list of members for CXTPTrackThemeOffice2013, including all inherited members.

CalcColumnHeight(CDC *pDC, CXTPGridColumn *pColumn, int nTotalWidth=0) | CXTPGridPaintManager | protectedvirtual
CalculateRowHeight(CDC *pDC, const CString &strText, int nMaxWidth, BOOL bWordBreak=TRUE) | CXTPGridPaintManager | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPGridPaintManager() | CXTPGridPaintManager |
CXTPTrackPaintManager() | CXTPTrackPaintManager |
CXTPTrackThemeOffice2013() | CXTPTrackThemeOffice2013 |
DrawBitmap(CDC *pDC, CXTPGridControl *pControl, CRect rcColumn, int iImage) | CXTPGridPaintManager | virtual
DrawCollapsedBitmap(CDC *pDC, const CXTPGridRow *pRow, CRect &rcBitmap) | CXTPGridPaintManager | virtual
DrawColumn(CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn, BOOL bDrawExternal=FALSE, int nShadowWidth=0) | CXTPGridPaintManager | virtual
DrawColumnBackground(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, BOOL &bColumnPressed, BOOL &bDraggingFromHeader, CXTPGridHeader *pHeader=NULL) | CXTPTrackThemeOffice2013 | virtual
DrawColumnFooter(CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn) | CXTPGridPaintManager | virtual
DrawColumnFooterDivider(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn) | CXTPGridPaintManager | virtual
DrawColumnIcon(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, CRect rcIcon, int iIcon) | CXTPGridPaintManager | virtual
DrawColumnText(CDC *pDC, CRect rcText, CString strCaption, int nHeaderAlignment, BOOL bIsHeader, BOOL bColumnPressed) | CXTPTrackThemeOffice2013 | virtual
DrawConnector(CDC *pDC, CPoint ptFrom, CPoint ptTo) | CXTPGridPaintManager |
DrawFocusedRow(CDC *pDC, CRect rcRow) | CXTPTrackThemeOffice2013 | virtual
DrawFreezeColsDivider(CDC *pDC, const CRect &rc, CXTPGridControl *pControl, CXTPGridRow *pRow=NULL) | CXTPGridPaintManager | virtual
DrawGlyph(CDC *pDC, CRect rcColumn, int iImage) | CXTPGridPaintManager | virtual
DrawGrid(CDC *pDC, XTPGridOrientation orientation, CRect rcGrid) | CXTPGridPaintManager | virtual
DrawGridPattern(CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush) | CXTPGridPaintManager | protectedvirtual
DrawGridPattern(CDC *pDC, CXTPBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush) | CXTPGridPaintManager | protectedvirtual
DrawGridPattern(CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr) | CXTPGridPaintManager | protectedvirtual
DrawGroupRow(CDC *pDC, CXTPGridGroupRow *pRow, CRect rcRow, XTP_GRIDRECORDITEM_METRICS *pMetrics) | CXTPTrackThemeOffice2013 | virtual
DrawHorizontalLine(CDC *pDC, int xPos, int yPos, int cx, COLORREF clr) | CXTPGridPaintManager |
DrawInplaceButton(CDC *pDC, CXTPGridInplaceButton *pButton) | CXTPGridPaintManager | virtual
DrawInplaceButtonFrame(CDC *pDC, CXTPGridInplaceButton *pButton) | CXTPGridPaintManager | protectedvirtual
DrawInplaceButtonIcon(CDC *pDC, CXTPGridInplaceButton *pButton) | CXTPGridPaintManager | protectedvirtual
DrawInplaceComboButton(CDC *pDC, CRect *pRc) | CXTPGridPaintManager | virtual
DrawInplaceExpandButton(CDC *pDC, CRect *pRc) | CXTPGridPaintManager | virtual
DrawInplaceSpinButton(CDC *pDC, CRect *pRc) | CXTPGridPaintManager | virtual
DrawItemBitmap(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CRect &rcItem, int nImage) | CXTPGridPaintManager | virtual
DrawItemCaption(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics) | CXTPGridPaintManager | virtual
DrawItemControl(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CXTPGridRecordItemControl *pControl, CRect &rcItem) | CXTPGridPaintManager | virtual
DrawLink(int *pnCurrDrawPos, XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CXTPGridHyperlink *pHyperlink, CString strText, CRect rcLink, int nFlag, BOOL bTrim=FALSE) | CXTPGridPaintManager | protectedvirtual
DrawMarkers(CDC *pDC) | CXTPTrackPaintManager | virtual
DrawMultiLineText(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, BOOL bWordBreak=TRUE) | CXTPGridPaintManager | protectedvirtual
DrawNoGroupByText(CDC *pDC, CRect rcItem) | CXTPGridPaintManager | virtual
DrawRowNumber(CDC *pDC, CRect rcNumber, CXTPGridRow *pRow) | CXTPGridPaintManager | virtual
DrawSectionDivider(CDC *pDC, const CRect &rc, XTPGridSectionDividerPosition dividerPosition, XTPGridSectionDividerStyle dividerStyle, CXTPPaintManagerColor dividerColor) | CXTPGridPaintManager |
DrawShellIcon(CDC *pDC, CRect rcColumn, int iImage) | CXTPGridPaintManager | virtual
DrawSingleLineText(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nStartPos, int nEndPos, int nActualWidth) | CXTPGridPaintManager | protectedvirtual
DrawString(int *pnCurrDrawPos, CDC *pDC, const CString &strDraw, CRect rcDraw, UINT nFormat) | CXTPGridPaintManager | protectedvirtual
DrawTextLine(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nFlag, int &nCharCounter, int &nHyperlinkCounter) | CXTPGridPaintManager | protectedvirtual
DrawTimeLine(CDC *pDC) | CXTPTrackPaintManager | virtual
DrawTrackHeader(CDC *pDC) | CXTPTrackPaintManager | virtual
DrawTreeStructure(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CRect rcItem, CSize sizeGlyph) | CXTPGridPaintManager | virtual
DrawTriangle(CDC *pDC, CRect rcTriangle, BOOL bToDown, BOOL bDraggingFromHeader, int nShadowWidth, BOOL bColumnPressed) | CXTPTrackThemeOffice2013 | virtual
DrawVerticalLine(CDC *pDC, int xPos, int yPos, int cy, COLORREF clr) | CXTPGridPaintManager |
DrawVerticalTimeLineMarker(CDC *pDC, int xPos, CXTPGridControl *pControl, COLORREF color=RGB(0, 255, 0)) | CXTPGridPaintManager | virtual
EnablePreviewMode(BOOL bIsPreviewMode) | CXTPGridPaintManager |
FillFooter(CDC *pDC, CRect rcFooter) | CXTPGridPaintManager | virtual
FillGroupByControl(CDC *pDC, CRect &rcGroupBy) | CXTPGridPaintManager | virtual
FillGroupRowMetrics(CXTPGridGroupRow *pRow, XTP_GRIDRECORDITEM_METRICS *pMetrics, BOOL bPrinting) | CXTPTrackThemeOffice2013 | virtual
FillHeaderControl(CDC *pDC, CRect rcHeader) | CXTPGridPaintManager | virtual
FillIndent(CDC *pDC, CRect rcRow) | CXTPGridPaintManager | virtual
FillItemShade(CDC *pDC, CRect rcItem) | CXTPGridPaintManager | virtual
FillRow(CDC *pDC, CXTPGridRow *pRow, CRect rcRow) | CXTPGridPaintManager | virtual
FindRowAdjacentToMerged(const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, BOOL bUpward) | CXTPGridPaintManager |
FindRowAdjacentToMergedEx(const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, int &nAdjRowIndex, BOOL bUpward) | CXTPGridPaintManager |
FormatTime(int nPosition) | CXTPTrackPaintManager | virtual
FormatTimeLineTick(int nPosition, COLORREF &clrTick, int &nTickLength) | CXTPTrackPaintManager | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetColumnOffice2007CustomThemeBaseColor() const | CXTPGridPaintManager |
GetColumnStyle() const | CXTPGridPaintManager |
GetControlBackColor(CXTPGridControl *pControl) | CXTPGridPaintManager | virtual
GetFooterHeight(CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0) | CXTPGridPaintManager | virtual
GetFreezeColsDividerStyle() const | CXTPGridPaintManager |
GetGlyphs() const | CXTPGridPaintManager |
GetHeaderHeight() | CXTPGridPaintManager | virtual
GetHeaderHeight(CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0) | CXTPGridPaintManager | virtual
GetItemHeight(XTP_GRIDRECORDITEM_DRAWARGS &drawArgs, int nWidth) | CXTPGridPaintManager |
GetMaxPreviewLines() | CXTPGridPaintManager |
GetPreviewItemHeight(CDC *pDC, CXTPGridRow *pRow, int nWidth, int nHeight) | CXTPGridPaintManager | virtual
GetPreviewLinesCount(CDC *pDC, CRect &rcText, const CString &strText) | CXTPGridPaintManager |
GetRowHeight(CDC *pDC, CXTPGridRow *pRow) | CXTPTrackThemeOffice2013 | virtual
CXTPTrackPaintManager::GetRowHeight(CDC *pDC, CXTPGridRow *pRow, int nTotalWidth) | CXTPGridPaintManager | virtual
GetRowHeightEx(CDC *pDC, CXTPGridRow *pRow, int nTotalWidth, const BOOL firstLevel=TRUE) | CXTPGridPaintManager |
GetSectionDividerHeight(XTPGridFixedRowsDividerStyle dividerStyle) | CXTPGridPaintManager |
GetTextFont() | CXTPGridPaintManager |
IsColumHotTrackingEnabled() const | CXTPGridPaintManager | virtual
IsColumnPlusMinusSign() const | CXTPGridPaintManager |
IsColumnWidthWYSIWYG() const | CXTPGridPaintManager |
IsDrawGridForEmptySpace() const | CXTPGridPaintManager |
IsFixedInplaceButtonHeight() const | CXTPGridPaintManager |
IsFixedRowHeight() const | CXTPGridPaintManager |
IsGridVisible(BOOL bVertical) const | CXTPGridPaintManager |
IsGridVisible(XTPGridOrientation orientation) const | CXTPGridPaintManager |
IsLastColumnWidthWYSIWYG() const | CXTPGridPaintManager |
IsPreviewMode() const | CXTPGridPaintManager |
IsPrintGroupRowIcon() const | CXTPGridPaintManager |
IsShowWYSIWYGMarkers() const | CXTPGridPaintManager |
IsUseDropMarker() const | CXTPGridPaintManager |
LoadGlyphs() | CXTPTrackThemeOffice2013 | virtual
m_arStartCol | CXTPGridPaintManager |
m_bAllowMergeCells | CXTPGridPaintManager |
m_bBaseTreeIndent | CXTPGridPaintManager |
m_bCleanTooltip | CXTPGridPaintManager |
m_bColumnPlusMinusSign | CXTPGridPaintManager | protected
m_bColumnWidthWYSIWYG | CXTPGridPaintManager | protected
m_bCompactText | CXTPGridPaintManager |
m_bDrawGridForEmptySpace | CXTPGridPaintManager | protected
m_bFixedInplaceButtonHeight | CXTPGridPaintManager | protected
m_bFixedRowHeight | CXTPGridPaintManager | protected
m_bForceDynamicMarkupForCell | CXTPGridPaintManager |
m_bForceShowDropMarker | CXTPGridPaintManager |
m_bForceShowTooltip | CXTPGridPaintManager |
m_bGrayIfDisable | CXTPGridPaintManager |
m_bGroupRowTextBold | CXTPGridPaintManager |
m_bHideSelection | CXTPGridPaintManager |
m_bHotTracking | CXTPGridPaintManager |
m_bInvertColumnOnClick | CXTPGridPaintManager |
m_bIsPreviewMode | CXTPGridPaintManager | protected
m_bLastColumnWidthWYSIWYG | CXTPGridPaintManager | protected
m_bMakeUpper | CXTPGridPaintManager |
m_bMoveScrollbarOnFixedColumnsIndent | CXTPGridPaintManager |
m_bPrintGroupRowIcon | CXTPGridPaintManager | protected
m_bPrintPageRectangle | CXTPGridPaintManager |
m_bPrintSortTriangle | CXTPGridPaintManager |
m_bPrintVirtualPageNumber | CXTPGridPaintManager |
m_bPrintWatermark | CXTPGridPaintManager |
m_bRecOrRowNum | CXTPGridPaintManager |
m_bRevertAlignment | CXTPGridPaintManager |
m_bShadeGroupHeadings | CXTPGridPaintManager |
m_bShadeSortColumn | CXTPGridPaintManager |
m_bShowLockIcon | CXTPGridPaintManager |
m_bShowNonActiveInPlaceButton | CXTPGridPaintManager |
m_bShowWYSIWYGMarkers | CXTPGridPaintManager | protected
m_bSortTriangleOffsetFromRight | CXTPGridPaintManager |
m_bThemedInplaceButtons | CXTPGridPaintManager |
m_bUseAlternativeBackground | CXTPGridPaintManager |
m_bUseDropMarker | CXTPGridPaintManager |
m_bUseEditTextAlignment | CXTPGridPaintManager |
m_bUseGroupRowSelectionState | CXTPGridPaintManager |
m_bUseShellIcon | CXTPGridPaintManager |
m_clrAlternativeBackground | CXTPGridPaintManager |
m_clrBoldText | CXTPGridPaintManager |
m_clrBoldTextHighlight | CXTPGridPaintManager |
m_clrBtnFace | CXTPGridPaintManager |
m_clrBtnFacePressed | CXTPGridPaintManager |
m_clrBtnText | CXTPGridPaintManager |
m_clrCaptionText | CXTPGridPaintManager |
m_clrCaptionTextPressed | CXTPGridPaintManager |
m_clrColumnOffice2007CustomTheme | CXTPGridPaintManager |
m_clrConnector | CXTPGridPaintManager |
m_clrControlBack | CXTPGridPaintManager |
m_clrControlDark | CXTPGridPaintManager |
m_clrControlLightLight | CXTPGridPaintManager |
m_clrDisableBitmapDarkest | CXTPGridPaintManager |
m_clrDisableBitmapLightest | CXTPGridPaintManager |
m_clrFormulaSubSum | CXTPGridPaintManager |
m_clrFormulaSum | CXTPGridPaintManager |
m_clrFreezeColsDivider | CXTPGridPaintManager |
m_clrGlyph | CXTPTrackThemeOffice2013 |
m_clrGlyphHighlight | CXTPTrackThemeOffice2013 |
m_clrGradientColumnSeparator | CXTPGridPaintManager |
m_clrGradientColumnShadow | CXTPGridPaintManager |
m_clrGroupBoxBack | CXTPGridPaintManager |
m_clrGroupRowText | CXTPGridPaintManager |
m_clrGroupShadeBack | CXTPGridPaintManager |
m_clrGroupShadeBorder | CXTPGridPaintManager |
m_clrGroupShadeText | CXTPGridPaintManager |
m_clrHeaderControl | CXTPGridPaintManager |
m_clrHighlight | CXTPGridPaintManager |
m_clrHighlightText | CXTPGridPaintManager |
m_clrHotDivider | CXTPGridPaintManager |
m_clrIndentControl | CXTPGridPaintManager |
m_clrItemShade | CXTPGridPaintManager |
m_clrMarker | CXTPTrackPaintManager |
m_clrMarkerBack | CXTPTrackPaintManager |
m_clrMarkerBorder | CXTPTrackPaintManager |
m_clrPreviewText | CXTPGridPaintManager |
m_clrScrollBarBorderDark | CXTPTrackPaintManager |
m_clrScrollBarBorderLight | CXTPTrackPaintManager |
m_clrScrollBarDark | CXTPTrackPaintManager |
m_clrScrollBarLight | CXTPTrackPaintManager |
m_clrSelectedArea | CXTPTrackPaintManager |
m_clrSelectedBorder | CXTPTrackThemeOffice2013 |
m_clrSelectedRow | CXTPGridPaintManager |
m_clrSelectedRowText | CXTPGridPaintManager |
m_clrTimeHeaderBorder | CXTPTrackPaintManager |
m_clrTimeHeaderDark | CXTPTrackPaintManager |
m_clrTimeHeaderDarkDark | CXTPTrackPaintManager |
m_clrTimeHeaderDivider | CXTPTrackPaintManager |
m_clrTimeLinePosition | CXTPTrackPaintManager |
m_clrTimeLineTick | CXTPTrackPaintManager |
m_clrTimeSliderBackground | CXTPTrackPaintManager |
m_clrTrackHeader | CXTPTrackPaintManager |
m_clrTrackMarkerBorder | CXTPTrackPaintManager |
m_clrTrackMarkerText | CXTPTrackPaintManager |
m_clrTrackMarkerTextBack | CXTPTrackPaintManager |
m_clrTrackMarkerTextBorder | CXTPTrackPaintManager |
m_clrTrackTimeArea | CXTPTrackPaintManager |
m_clrWindowText | CXTPGridPaintManager |
m_clrWorkArea | CXTPTrackPaintManager |
m_clrWorkAreaScrollBarBorder | CXTPTrackPaintManager |
m_clrWorkAreaScrollBarDark | CXTPTrackPaintManager |
m_clrWorkAreaScrollBarLight | CXTPTrackPaintManager |
m_columnStyle | CXTPGridPaintManager | protected
m_crlNoGroupByText | CXTPGridPaintManager |
m_grcGradientColumn | CXTPGridPaintManager |
m_grcGradientColumnHot | CXTPGridPaintManager |
m_grcGradientColumnPushed | CXTPGridPaintManager |
m_iRecOrRowStart | CXTPGridPaintManager |
m_nBaseParentRecordIndent | CXTPGridPaintManager |
m_nFixedColumnsIndent | CXTPGridPaintManager |
m_nFooterHeight | CXTPGridPaintManager | protected
m_nFreezeColsDividerStyle | CXTPGridPaintManager | protected
m_nGridLineStylePreviousH | CXTPGridPaintManager | protected
m_nGridLineStylePreviousV | CXTPGridPaintManager | protected
m_nGroupGridLineHeight | CXTPGridPaintManager | protected
m_nGroupGridLineStyle | CXTPGridPaintManager | protected
m_nHeaderHeight | CXTPGridPaintManager | protected
m_nMaxPreviewLines | CXTPGridPaintManager | protected
m_nResizingWidth | CXTPGridPaintManager | protected
m_nRowHeight | CXTPGridPaintManager | protected
m_nRowHeightDefault | CXTPGridPaintManager |
m_nTextIndentForGroupRowsWithNoIcon | CXTPGridPaintManager |
m_nTreeColumnLineLength | CXTPGridPaintManager |
m_nTreeIndent | CXTPGridPaintManager |
m_nTreeStructureStyle | CXTPGridPaintManager |
m_nTreeTextIndent | CXTPGridPaintManager |
m_nTreeTextIndentGroupRow | CXTPGridPaintManager |
m_nTreeTextIndentRowChildren | CXTPGridPaintManager |
m_nTreeTextIndentRowParent | CXTPGridPaintManager |
m_pControl | CXTPGridPaintManager | protected
m_pGlyphs | CXTPGridPaintManager | protected
m_pHyperlinkHoverStyle | CXTPGridPaintManager |
m_pHyperlinkStyle | CXTPGridPaintManager |
m_pMarkupUIElement_NoGroupBy | CXTPGridPaintManager | protected
m_PrintPageWidth | CXTPGridPaintManager |
m_rcPreviewIndent | CXTPGridPaintManager |
m_RecordNumberWidth | CXTPGridPaintManager |
m_strCollapse | CXTPGridPaintManager |
m_strDecreasing | CXTPGridPaintManager |
m_strExpand | CXTPGridPaintManager |
m_strIncreasing | CXTPGridPaintManager |
m_strMarkupUIElement_NoGroupBy | CXTPGridPaintManager | protected
m_strNoFieldsAvailable | CXTPGridPaintManager |
m_strNoGroupBy | CXTPGridPaintManager |
m_strNoItems | CXTPGridPaintManager |
m_strSortBy | CXTPGridPaintManager |
m_szGlyph | CXTPGridPaintManager | protected
m_themeButton | CXTPGridPaintManager | protected
m_themeCombo | CXTPGridPaintManager | protected
m_themeHeader | CXTPGridPaintManager | protected
m_themeSpin | CXTPGridPaintManager | protected
m_treeStructureStyle | CXTPGridPaintManager |
m_xtpBrushGroupGridLineStyle | CXTPGridPaintManager | protected
m_xtpBrushHorizontalGrid | CXTPGridPaintManager | protected
m_xtpBrushTreeStructure | CXTPGridPaintManager | protected
m_xtpBrushVeriticalGrid | CXTPGridPaintManager | protected
m_xtpFontBoldText | CXTPGridPaintManager |
m_xtpFontCaption | CXTPGridPaintManager |
m_xtpFontPreview | CXTPGridPaintManager |
m_xtpFontText | CXTPGridPaintManager |
OnDrawAction(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs) | CXTPGridPaintManager | virtual
RecalcTotalHightOfMergedRows(CXTPGridColumns *pColumns, CDC *pDC, CXTPGridRow *pRow, int nRowHeight, int nTotalWidth) | CXTPGridPaintManager |
RefreshMetrics() | CXTPTrackThemeOffice2013 | virtual
SetCaptionFont(LOGFONT &lf) | CXTPGridPaintManager |
SetColumnOffice2007CustomThemeBaseColor(COLORREF clrBaseColor) | CXTPGridPaintManager |
SetColumnPlusMinusSign(BOOL bDraw) | CXTPGridPaintManager |
SetColumnWidthWYSIWYG(BOOL bColumnWidthWYSIWYG) | CXTPGridPaintManager |
SetDrawGridForEmptySpace(BOOL bDrawGrid) | CXTPGridPaintManager |
SetFixedRowHeight(BOOL bFixedRowHeight) | CXTPGridPaintManager |
SetFreezeColsDividerStyle(int nStyle) | CXTPGridPaintManager |
SetGridControl(CXTPGridControl *pControl) | CXTPGridPaintManager | virtual
SetHeaderHeight(int nHeight) | CXTPGridPaintManager | virtual
SetInplaceButtonHeight(BOOL bFixedInplaceButtonHeight) | CXTPGridPaintManager |
SetLastColumnWidthWYSIWYG(BOOL bColumnWidthWYSIWYG) | CXTPGridPaintManager |
SetMaxPreviewLines(int nMaxLines) | CXTPGridPaintManager |
SetPreviewIndent(int nLeft, int nTop, int nRight, int nBottom) | CXTPGridPaintManager |
SetPrintGroupRowIcon(BOOL bDraw) | CXTPGridPaintManager |
SetTextFont(LOGFONT &lf) | CXTPGridPaintManager |
ShowWYSIWYGMarkers(BOOL bSet) | CXTPGridPaintManager |
~CXTPGridPaintManager() | CXTPGridPaintManager | virtual
~CXTPTrackPaintManager() | CXTPTrackPaintManager |


Toolkit Pro: Member List

  • XTP_CALENDAR_RECURRENCE_OPTIONS
  • PATTERN_MONTHNTH
XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_MONTHNTH Member List

This is the complete list of members for XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_MONTHNTH, including all inherited members.

nIntervalMonths | XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_MONTHNTH
nWhichDay | XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_MONTHNTH
nWhichDayMask | XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_MONTHNTH


Toolkit Pro: Member List

CXTPListBoxThemeResource Member List

This is the complete list of members for CXTPListBoxThemeResource, including all inherited members.

DrawItem(CDC *pDC, CXTPListBox *pListBox, LPDRAWITEMSTRUCT lpDIS) | CXTPListBoxThemeResource | virtual
DrawItemText(CDC *pDC, CRect rcText, CXTPListBox *pListBox, LPDRAWITEMSTRUCT lpDIS) | CXTPListBoxTheme | virtual
DrawNcBorders(CDC *pDC, CRect rc) | CXTPListBoxTheme | virtual
GetBackColor() | CXTPListBoxTheme | virtual
RefreshMetrics() | CXTPListBoxThemeResource | virtual
~CXTPListBoxTheme() | CXTPListBoxTheme | inlinevirtual


Toolkit Pro: Member List

CXTPTabView Member List

This is the complete list of members for CXTPTabView, including all inherited members.

CXTPTabView() | CXTPTabView |
GetTabCtrl() const | CXTPTabView | virtual
GetToolTips() | CXTPTabView | virtual
Init() | CXTPTabView | protectedvirtual
SetTabImageList(CImageList *pImageList) | CXTPTabView | virtual
SetToolTips(CToolTipCtrl *pWndTip) | CXTPTabView | virtual
UpdateDocTitle() | CXTPTabView |
~CXTPTabView() | CXTPTabView | virtual


Toolkit Pro: XTPRibbonBackstageLabel.h Source File

  • Source
  • Ribbon
  • Backstage
XTPRibbonBackstageLabel.h
Go to the documentation of this file.
1
23#if !defined(__XTPRIBBONBACKSTAGELABEL_H__)
24# define __XTPRIBBONBACKSTAGELABEL_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class _XTP_EXT_CLASS CXTPRibbonBackstageLabel : public CStatic
34{
35public:
36 CXTPRibbonBackstageLabel();
37 virtual ~CXTPRibbonBackstageLabel();
38
39public:
40 void SetTextColor(COLORREF clrText);
41 virtual void SetTheme(XTPControlTheme nTheme);
42 virtual void RefreshMetrics();
43
44 //{{AFX_VIRTUAL(CXTPRibbonBackstageLabel)
45 //}}AFX_VIRTUAL
46
47protected:
48 DECLARE_MESSAGE_MAP()
49 //{{AFX_MSG(CXTPRibbonBackstageLabel)
50 afx_msg void OnPaint();
51 //}}AFX_MSG
52
53protected:
54 COLORREF m_clrText;
55 COLORREF m_clrBack;
56};
57
58AFX_INLINE void CXTPRibbonBackstageLabel::SetTextColor(COLORREF clrText)
59{
60 m_clrText = clrText;
61}
62
63# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
65#endif // !defined(__XTPRIBBONBACKSTAGELABEL_H__)
XTPControlTheme
XTPControlTheme
Enumeration used to determine the active theme style.
Definition XTPControlTheme.h:43
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h


Toolkit Pro: Member List

CXTPButtonThemeVisualStudio2017 Member List

This is the complete list of members for CXTPButtonThemeVisualStudio2017, including all inherited members.

CXTPButtonTheme() | CXTPButtonTheme |
CXTPButtonThemeUltraFlat() | CXTPButtonThemeUltraFlat |
CXTPButtonThemeVisualStudio2017() | CXTPButtonThemeVisualStudio2017 |
CXTPCmdTarget() | CXTPCmdTarget |
CXTPControlTheme() | CXTPControlTheme |
DrawButton(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
DrawButtonBackground(CDC *pDC, CXTPButton *pButton) | CXTPButtonThemeOffice2013 | virtual
DrawButtonText(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme |
DrawButtonVisualStyleBackground(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
DrawCheckBoxMark(CDC *pDC, CXTPButton *pButton) | CXTPButtonThemeOffice2013 | virtual
DrawFocusRect(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
DrawGroupBox(CDC *pDC, CXTPButton *pButton) | CXTPButtonThemeOffice2013 | virtual
DrawPushButtonDropDown(CDC *pDC, CXTPButton *pButton) | CXTPButtonThemeOffice2013 | virtual
DrawPushButtonIcon(CDC *pDC, CXTPButton *pButton) | CXTPButtonThemeOffice2013 | virtual
DrawPushButtonText(CDC *pDC, CXTPButton *pButton) | CXTPButtonThemeOffice2013 | virtual
DrawRadioButtonMark(CDC *pDC, CXTPButton *pButton) | CXTPButtonThemeOffice2013 | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetTextColor(CXTPButton *pButton) | CXTPButtonThemeOffice2013 | virtual
GetThemeStyle() const | CXTPControlTheme |
m_crBack | CXTPButtonTheme |
m_crBackChecked | CXTPButtonThemeUltraFlat |
m_crBackDisabled | CXTPButtonThemeOffice2013 | protected
m_crBackHilite | CXTPButtonThemeUltraFlat |
m_crBackPushed | CXTPButtonThemeUltraFlat |
m_crBorder | CXTPButtonThemeOffice2013 | protected
m_crBorder3DHilite | CXTPButtonTheme |
m_crBorder3DShadow | CXTPButtonTheme |
m_crBorderDefault | CXTPButtonThemeOffice2013 | protected
m_crBorderDisabled | CXTPButtonThemeOffice2013 | protected
m_crBorderHilite | CXTPButtonTheme |
m_crBorderPushed | CXTPButtonThemeUltraFlat |
m_crBorderShadow | CXTPButtonTheme |
m_crCheckMark | CXTPButtonThemeUltraFlat |
m_crMark | CXTPButtonThemeOffice2013 | protected
m_crMarkDisabled | CXTPButtonThemeOffice2013 | protected
m_crMarkHilite | CXTPButtonThemeOffice2013 | protected
m_crMarkPushed | CXTPButtonThemeOffice2013 | protected
m_crText | CXTPButtonTheme |
m_crTextCheck | CXTPButtonTheme |
m_crTextDisabled | CXTPButtonTheme |
m_crTextHilite | CXTPButtonThemeUltraFlat |
m_crTextPushed | CXTPButtonThemeUltraFlat |
m_nTheme | CXTPControlTheme | protected
RefreshMetrics(CXTPButton *pButton) | CXTPButtonThemeVisualStudio2017 | virtual
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static
~CXTPButtonTheme() | CXTPButtonTheme | virtual


Toolkit Pro: XTPDockingPaneTabTheme2015.h Source File

  • Source
  • DockingPane
  • TabThemes
XTPDockingPaneTabTheme2015.h
Go to the documentation of this file.
1
23#if !defined(__XTPDOCKINGPANETABTHEME2015_H__)
24# define __XTPDOCKINGPANETABTHEME2015_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPDockingPaneTabTheme2015 : public CXTPDockingPaneTabTheme2012
39{
40public:
45 CXTPDockingPaneTabTheme2015();
46
63 virtual void DrawSingleButton(CDC* pDC, CXTPTabManagerItem* pItem);
64};
65
66# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
68#endif // !defined(__XTPDOCKINGPANETABTHEME2015_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPDockingPaneTabTheme2012
Helper class used to initialize default colors for a theme from an .INI resource and handle drawing r...
Definition XTPDockingPaneTabTheme2012.h:39
CXTPDockingPaneTabTheme2015
Helper class used to initialize default colors for a theme from an .INI resource and handle drawing r...
Definition XTPDockingPaneTabTheme2015.h:39
CXTPDockingPaneTabTheme2015::CXTPDockingPaneTabTheme2015
CXTPDockingPaneTabTheme2015()
Default class constructor.
CXTPDockingPaneTabTheme2015::DrawSingleButton
virtual void DrawSingleButton(CDC *pDC, CXTPTabManagerItem *pItem)
This method is called to draw a single tab button in the tab client header area.
CXTPTabManagerItem
CXTPTabManagerItem is the base class for the tabs that appear in the command bars tab workspace,...
Definition XTPTabManagerItem.h:44


Toolkit Pro: Member List

  • CXTPGridControl
  • CUpdateContext
CXTPGridControl::CUpdateContext Member List

This is the complete list of members for CXTPGridControl::CUpdateContext, including all inherited members.

CUpdateContext(CXTPGridControl *pControl) | CXTPGridControl::CUpdateContext | inline
m_pControl | CXTPGridControl::CUpdateContext | protected
~CUpdateContext() | CXTPGridControl::CUpdateContext | inline


Toolkit Pro: XTPTrayIcon.h Source File

  • Source
  • Controls
  • Shell
XTPTrayIcon.h
Go to the documentation of this file.
1
23#if !defined(__XTPTRAYICON_H__)
24# define __XTPTRAYICON_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
34# ifndef NIIF_NONE
35# define NIIF_NONE 0x00000000
36# define NIIF_INFO 0x00000001
37# define NIIF_WARNING 0x00000002
38# define NIIF_ERROR 0x00000003
39# define NIIF_ICON_MASK 0x0000000F
40# endif
41
42# ifndef NIS_HIDDEN
43# define NIS_HIDDEN 0x00000001
44# endif
45
46# ifndef NIF_STATE
47# define NIF_STATE 0x00000008
48# define NIF_INFO 0x00000010
49# endif
50
51# ifndef NIN_BALLOONSHOW
52# define NIN_BALLOONSHOW (WM_USER + 2)
53# define NIN_BALLOONHIDE (WM_USER + 3)
54# define NIN_BALLOONTIMEOUT (WM_USER + 4)
55# define NIN_BALLOONUSERCLICK (WM_USER + 5)
56# endif
57
58# ifndef NIN_SELECT
59# define NIN_SELECT (WM_USER + 0)
60# define NINF_KEY 0x1
61# define NIN_KEYSELECT (NIN_SELECT | NINF_KEY)
62# endif
63
64# ifndef NIM_SETFOCUS
65# define NIM_SETFOCUS 0x00000003
66# endif
74class _XTP_EXT_CLASS CXTPTrayIcon : public CWnd
75{
76private:
82 struct TRAYICONDATA
83 {
84 HICON hIcon;
85 CString strToolTip;
87 };
88
94 struct NOTIFYICONDATAEX
95 {
96 DWORD cbSize;
97 HWND hWnd;
100 UINT uID;
104 UINT uFlags;
106 UINT uCallbackMessage;
107 HICON hIcon;
108 TCHAR szTip[128];
110 DWORD dwState;
111 DWORD dwStateMask;
113 TCHAR szInfo[256];
115 union {
116 UINT uTimeout;
117 UINT uVersion;
119 } DUMMYUNIONNAME;
120 TCHAR szInfoTitle[64];
122 DWORD dwInfoFlags;
123 GUID guidItem;
124 HICON hBalloonIcon;
127 };
128
133 typedef CList<TRAYICONDATA, TRAYICONDATA&> CTrayIconList;
134
135public:
140 CXTPTrayIcon();
141
146 virtual ~CXTPTrayIcon();
147
148public:
157 BOOL IsShellVersion5() const;
158
159public:
175 virtual bool Create(LPCTSTR lpszCaption, CWnd* pParentWnd, UINT nIconID, UINT uMenuID = 0,
176 UINT uDefMenuItemID = 0, bool bDefMenuItemByPos = false);
178 virtual bool Create(LPCTSTR lpszCaption, DWORD dwStyle, CWnd* pParentWnd,
179 UINT nIconID); // DEPRECATED
212 bool ShowBalloonTip(LPCTSTR lpszInfo = NULL, LPCTSTR lpszInfoTitle = NULL,
213 DWORD dwInfoFlags = NIIF_NONE, UINT uTimeout = 10,
214 HICON hBaloonIcon = NULL);
215
220 virtual void StopAnimation();
221
227 virtual void StartAnimation(UINT uElapse = 500);
228
241 virtual void SetAnimationIcons(const UINT* lpIDArray, const CString* lpStrTipArray,
242 int nIDCount);
243
258 virtual bool SetAnimationIcons(const UINT* lpIDArray, int nIDCount,
259 const CString* lpStrTipArray = NULL);
260
269 bool SetTooltipText(UINT nTipText);
270
279 bool SetTooltipText(LPCTSTR lpszTipText);
280
288 CString GetTooltipText() const;
289
295 void SetDefaultValues();
296
305 bool SetCallbackMessage(UINT uNewCallbackMessage);
306
314 UINT GetCallbackMessage();
315
326 bool SetDefaultMenuItem(UINT uItem, bool bByPos);
327
337 void GetDefaultMenuItem(UINT& uItem, bool& bByPos);
338
347 bool SetNotificationWnd(CWnd* pWndNotify);
348
356 CWnd* GetNotificationWnd();
357
366 bool SetIcon(HICON hIcon);
367
376 bool SetIcon(LPCTSTR lpszIconName);
377
386 bool SetIcon(UINT nIDResource);
387
395 HICON GetIcon() const;
396
403 bool AddIcon();
404
411 bool RemoveIcon();
412
420 bool HideIcon();
421
429 bool ShowIcon();
430
439 BOOL ShowIcon(BOOL bShow);
440
448 void MinimizeToTray(CWnd* pWnd);
449
457 void MaximizeFromTray(CWnd* pWnd);
458
540 BOOL ShellNotify(DWORD dwMessage);
541
552 virtual void InstallIconPending();
553
564 virtual bool CreateMinimizeWnd(CWnd* pWndApp);
565
573 virtual void RemoveAnimationIcons();
574
584 virtual void SetTooltip(LPCTSTR strToolTip);
585
595 virtual void SetTrayIcon(UINT nIcon, DWORD dwMessage = NIM_ADD);
596
605 virtual void KillTimer();
606
617 virtual void SetTimer(UINT nIDEvent, UINT uElapse);
618
619protected:
621 DECLARE_MESSAGE_MAP()
622
623 //{{AFX_VIRTUAL(CXTPTrayIcon)
624 virtual LRESULT WindowProc(UINT message, WPARAM wParam, LPARAM lParam);
625 virtual LRESULT OnTrayNotification(WPARAM wParam, LPARAM lParam);
626 //}}AFX_VIRTUAL
627
628 //{{AFX_MSG(CXTPTrayIcon)
629 afx_msg void OnTimer(UINT_PTR nIDEvent);
630 afx_msg void OnSettingChange(UINT uFlags, LPCTSTR lpszSection);
631 afx_msg LRESULT OnTaskbarCreated(WPARAM wParam, LPARAM lParam);
632 //}}AFX_MSG
635private:
636 BOOL Create(LPCTSTR lpszClassName, LPCTSTR lpszWindowName, DWORD dwStyle, const RECT& rect,
637 CWnd* pParentWnd, UINT nID, CCreateContext* pContext = NULL);
638 bool CanAnimate() const;
639 static BOOL CALLBACK FindTrayWnd(HWND hWnd, LPARAM lParam);
640 bool GetTrayWindowRect(CRect& rect);
641 bool SetShellTooltip(LPCTSTR lpszTipText);
642
643protected:
644 UINT m_uFlags;
645 UINT m_nIconID;
646 UINT m_nIDEvent;
647 UINT m_nCounter;
648 UINT m_uDefMenuItemID;
649 bool m_bDefMenuItemByPos;
650 bool m_bHidden;
651 bool m_bRemoved;
652 bool m_bShowPending;
653 HWND m_hWndNotify;
654 CWnd m_wndMinimize;
655 size_t m_iMaxTipSize;
656 CString m_strToolTip;
657 CXTPIconHandle m_hIcon;
658 CTrayIconList m_arTrayIcons;
660 NOTIFYICONDATAEX m_niData;
661};
662
663const TCHAR XTPTRAYICON_CLASSNAME[] = _T("XTPTrayIcon");
664
666
667AFX_INLINE bool CXTPTrayIcon::Create(LPCTSTR lpszCaption, DWORD /*dwStyle*/, CWnd* pParentWnd,
668 UINT nIconID)
669{
670 return Create(lpszCaption, pParentWnd, nIconID);
671}
672AFX_INLINE void CXTPTrayIcon::SetTooltip(LPCTSTR strToolTip)
673{
674 SetTooltipText(strToolTip);
675}
676AFX_INLINE void CXTPTrayIcon::SetTrayIcon(UINT nIcon, DWORD /*dwMessage*/)
677{
678 SetIcon(nIcon);
679}
680AFX_INLINE void CXTPTrayIcon::SetAnimationIcons(const UINT* lpIDArray, const CString* lpStrTipArray,
681 int nIDCount)
682{
683 SetAnimationIcons(lpIDArray, nIDCount, lpStrTipArray);
684}
685AFX_INLINE void CXTPTrayIcon::KillTimer()
686{
687 StopAnimation();
688}
689AFX_INLINE void CXTPTrayIcon::SetTimer(UINT nIDEvent, UINT uElapse)
690{
691 m_nIDEvent = nIDEvent;
692 StartAnimation(uElapse);
693}
694AFX_INLINE BOOL CXTPTrayIcon::Create(LPCTSTR lpszClassName, LPCTSTR lpszWindowName, DWORD dwStyle,
695 const RECT& rect, CWnd* pParentWnd, UINT nID,
696 CCreateContext* pContext)
697{
698 return CWnd::Create(lpszClassName, lpszWindowName, dwStyle, rect, pParentWnd, nID, pContext);
699}
701# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
703#endif // #if !defined(__XTPTRAYICON_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPIconHandle
CXTPIconHandle is a standalone helper class.
Definition XTPUtil.h:39
CXTPTrayIcon
CXTPTrayIcon is a CWnd derived class of the NOTIFYICONDATA structure.
Definition XTPTrayIcon.h:75
CXTPTrayIcon::GetDefaultMenuItem
void GetDefaultMenuItem(UINT &uItem, bool &bByPos)
Call this member function to retrieve the item ID and position flag for the tray icon.
CXTPTrayIcon::MinimizeToTray
void MinimizeToTray(CWnd *pWnd)
Call this member function to minimize the specified window to the system tray.
CXTPTrayIcon::SetTooltipText
bool SetTooltipText(UINT nTipText)
Call this member function to set the tooltip text for the tray icon.
CXTPTrayIcon::SetTrayIcon
virtual void SetTrayIcon(UINT nIcon, DWORD dwMessage=NIM_ADD)
Sets the icon for the CXTPTrayIcon object.
CXTPTrayIcon::StartAnimation
virtual void StartAnimation(UINT uElapse=500)
This member function will start the tray icon animation timer.
CXTPTrayIcon::SetIcon
bool SetIcon(LPCTSTR lpszIconName)
Call this member function to set the icon that is displayed in the system tray.
CXTPTrayIcon::KillTimer
virtual void KillTimer()
Stops the animation timer.
CXTPTrayIcon::SetIcon
bool SetIcon(UINT nIDResource)
Call this member function to set the icon that is displayed in the system tray.
CXTPTrayIcon::GetIcon
HICON GetIcon() const
Call this member function to retrieve a handle to the icon displayed in the system tray.
CXTPTrayIcon::GetTooltipText
CString GetTooltipText() const
Call this member function to retrieve the tooltip text that is displayed by the tray icon.
CXTPTrayIcon::GetNotificationWnd
CWnd * GetNotificationWnd()
Call this member function to retrieve a pointer to the window that receives notification messages fro...
CXTPTrayIcon::SetTimer
virtual void SetTimer(UINT nIDEvent, UINT uElapse)
Sets the animation timer.
CXTPTrayIcon::SetAnimationIcons
virtual bool SetAnimationIcons(const UINT *lpIDArray, int nIDCount, const CString *lpStrTipArray=NULL)
This member function will set the icons used for animated system tray icons.
CXTPTrayIcon::Create
virtual bool Create(LPCTSTR lpszCaption, CWnd *pParentWnd, UINT nIconID, UINT uMenuID=0, UINT uDefMenuItemID=0, bool bDefMenuItemByPos=false)
This member function will create the system tray icon.
CXTPTrayIcon::RemoveIcon
bool RemoveIcon()
Call this member function to remove the icon from the system tray.
CXTPTrayIcon::RemoveAnimationIcons
virtual void RemoveAnimationIcons()
Clears the animated icon array.
CXTPTrayIcon::SetTooltip
virtual void SetTooltip(LPCTSTR strToolTip)
Sets the tooltip for the CXTPTrayIcon object.
CXTPTrayIcon::SetIcon
bool SetIcon(HICON hIcon)
Call this member function to set the icon that is displayed in the system tray.
CXTPTrayIcon::ShellNotify
BOOL ShellNotify(DWORD dwMessage)
Sends a message to the taskbar's status area.
CXTPTrayIcon::StopAnimation
virtual void StopAnimation()
This member function will stop the tray icon animation timer.
CXTPTrayIcon::SetDefaultMenuItem
bool SetDefaultMenuItem(UINT uItem, bool bByPos)
This member function will set the default menu item for the tray icon's pop-up menu if the tray icon ...
CXTPTrayIcon::SetNotificationWnd
bool SetNotificationWnd(CWnd *pWndNotify)
Call this member function to set the window that is to receive notification messages from the tray ic...
CXTPTrayIcon::GetCallbackMessage
UINT GetCallbackMessage()
This member function will retrieve the notification message ID used by the tray icon.
CXTPTrayIcon::MaximizeFromTray
void MaximizeFromTray(CWnd *pWnd)
Call this member function to maximize the specified window from the system tray.
CXTPTrayIcon::~CXTPTrayIcon
virtual ~CXTPTrayIcon()
Destroys a CXTPTrayIcon object, handles cleanup and deallocation.
CXTPTrayIcon::SetTooltipText
bool SetTooltipText(LPCTSTR lpszTipText)
Call this member function to set the tooltip text for the tray icon.
CXTPTrayIcon::HideIcon
bool HideIcon()
Call this member function to hide the system tray icon in Windows 2000 or greater.
CXTPTrayIcon::ShowIcon
bool ShowIcon()
Call this member function to show the system tray icon in Windows 2000 or greater.
CXTPTrayIcon::SetDefaultValues
void SetDefaultValues()
This member function is called to reset the tray icon control settings to their default value.
CXTPTrayIcon::ShowIcon
BOOL ShowIcon(BOOL bShow)
Call this member function to show the system tray icon in Windows 2000 or greater.
CXTPTrayIcon::SetCallbackMessage
bool SetCallbackMessage(UINT uNewCallbackMessage)
This member function will set the callback message to be used by the tray icon.
CXTPTrayIcon::CXTPTrayIcon
CXTPTrayIcon()
Constructs a CXTPTrayIcon object.
CXTPTrayIcon::SetAnimationIcons
virtual void SetAnimationIcons(const UINT *lpIDArray, const CString *lpStrTipArray, int nIDCount)
This member function will set the icons used for animated system tray icons.
CXTPTrayIcon::AddIcon
bool AddIcon()
Call this member function to add the icon to the system tray.
CXTPTrayIcon::InstallIconPending
virtual void InstallIconPending()
Adds an icon to the system tray.
CXTPTrayIcon::CreateMinimizeWnd
virtual bool CreateMinimizeWnd(CWnd *pWndApp)
Creates the tray icon's min/max window.
CXTPTrayIcon::ShowBalloonTip
bool ShowBalloonTip(LPCTSTR lpszInfo=NULL, LPCTSTR lpszInfoTitle=NULL, DWORD dwInfoFlags=NIIF_NONE, UINT uTimeout=10, HICON hBaloonIcon=NULL)
Call this member function to display a balloon tooltip for the system tray icon.
CXTPTrayIcon::IsShellVersion5
BOOL IsShellVersion5() const
Determines if shell32.dll has Major version 5 or above.


Toolkit Pro: Member List

CXTPChartRadarPointSeriesStyle Member List

This is the complete list of members for CXTPChartRadarPointSeriesStyle, including all inherited members.

ApplyTo(CXTPChartDeviceCommand *pCommand) | CXTPChartSeriesStyle | virtual
CorrectAxisSideMargins(CXTPChartAxis *pAxis, double nMinValue, double nMaxValue, double &nCorrection) | CXTPChartSeriesStyle | virtual
CreateDiagram() | CXTPChartRadarDiagramSeriesStyle | virtual
CreateView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView) | CXTPChartRadarPointSeriesStyle | protectedvirtual
CXTPChartElement() | CXTPChartElement |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartRadarDiagramSeriesStyle() | CXTPChartRadarDiagramSeriesStyle |
CXTPChartRadarPointSeriesStyle() | CXTPChartRadarPointSeriesStyle |
CXTPChartSeriesStyle() | CXTPChartSeriesStyle |
DoPropExchange(CXTPPropExchange *pPX) | CXTPChartRadarPointSeriesStyle | virtual
Enable3dEdgeSmoothing(BOOL bEnable=TRUE) | CXTPChartSeriesStyle | virtual
Get3dRotation() const | CXTPChartSeriesStyle | virtual
GetAppearance() const | CXTPChartElement |
GetColor() const | CXTPChartSeriesStyle | virtual
GetContent() const | CXTPChartElement |
GetErrorBar() const | CXTPChartSeriesStyle | virtual
GetLabel() const | CXTPChartSeriesStyle | virtual
GetMarker() const | CXTPChartRadarPointSeriesStyle |
GetOwner() const | CXTPChartElement |
GetSeriesPointValueIndex() const | CXTPChartSeriesStyle | virtual
GetStyleAppearance() const | CXTPChartSeriesStyle | virtual
GetTransparency() const | CXTPChartSeriesStyle | virtual
Is3D() const | CXTPChartObject |
Is3dEdgeSmoothingEnabled() const | CXTPChartSeriesStyle | virtual
IsColorEach() const | CXTPChartSeriesStyle | virtual
IsStyleDiagram(CXTPChartDiagram *pDiagram) const | CXTPChartRadarDiagramSeriesStyle | virtual
m_bColorEach | CXTPChartSeriesStyle | protected
m_bSmooth3dEdges | CXTPChartSeriesStyle | protected
m_clrColor | CXTPChartSeriesStyle | protected
m_nTransparency | CXTPChartSeriesStyle | protected
m_pErrorBar | CXTPChartSeriesStyle | protected
m_pLabel | CXTPChartSeriesStyle | protected
m_Rotation3d | CXTPChartSeriesStyle | protected
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartElement | virtual
Release() | CXTPChartElement | virtual
Set3dRotation(const CXTPChart3dRotation &rotation) | CXTPChartSeriesStyle | virtual
Set3dRotation(double dYaw, double dPitch, double dRoll) | CXTPChartSeriesStyle | virtual
SetColor(CXTPChartColor clr) | CXTPChartSeriesStyle | virtual
SetColorEach(BOOL bColorEach) | CXTPChartSeriesStyle | virtual
SetErrorBar(CXTPChartErrorBar *pErrorBar) | CXTPChartSeriesStyle | virtual
SetLabel(CXTPChartSeriesLabel *pLabel) | CXTPChartSeriesStyle | virtual
SetTransparency(int nTransparency) | CXTPChartSeriesStyle | virtual
~CXTPChartElement() | CXTPChartElement | virtual
~CXTPChartRadarDiagramSeriesStyle() | CXTPChartRadarDiagramSeriesStyle | virtual
~CXTPChartRadarPointSeriesStyle() | CXTPChartRadarPointSeriesStyle | virtual
~CXTPChartSeriesStyle() | CXTPChartSeriesStyle | virtual


Toolkit Pro: Member List

CXTPScrollBarThemeOffice2013 Member List

This is the complete list of members for CXTPScrollBarThemeOffice2013, including all inherited members.

CalcHScroll(CXTPScrollBase *pScroll, XTPScrollMetricsH *pHScroll) | CXTPScrollBarPaintManager | protectedstatic
CalcVScroll(CXTPScrollBase *pScroll, XTPScrollMetricsV *pVScroll) | CXTPScrollBarPaintManager | protectedstatic
CXTPScrollBarPaintManager() | CXTPScrollBarPaintManager |
CXTPScrollBarThemeOffice2013() | CXTPScrollBarThemeOffice2013 |
DrawArrowGlyph(CDC *pDC, CRect rcArrow, XTPArrowGlyph glyph, BOOL bEnabled, COLORREF clrText=COLORREF_NULL) | CXTPScrollBarPaintManager | protected
DrawArrows(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics) | CXTPScrollBarThemeOffice2013 | protectedvirtual
DrawArrows(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics) | CXTPScrollBarThemeOffice2013 | protectedvirtual
DrawBackground(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics) | CXTPScrollBarThemeOffice2013 | protectedvirtual
DrawBackground(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics) | CXTPScrollBarThemeOffice2013 | protectedvirtual
DrawButtons(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics) | CXTPScrollBarThemeOffice2013 | protectedvirtual
DrawButtons(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics) | CXTPScrollBarThemeOffice2013 | protectedvirtual
DrawGripper(CDC *pDC, CXTPScrollBase *pScroll) | CXTPScrollBarThemeOffice2013 | protectedvirtual
DrawScrollBar(CDC *pDC, CXTPScrollBase *pGallery) | CXTPScrollBarThemeOffice2013 | protectedvirtual
DrawThumbButton(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics) | CXTPScrollBarThemeOffice2013 | protectedvirtual
DrawThumbButton(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics) | CXTPScrollBarThemeOffice2013 | protectedvirtual
DrawTracker(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics) | CXTPScrollBarPaintManager | protectedvirtual
DrawTracker(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics) | CXTPScrollBarPaintManager | protectedvirtual
GetScrollBarColors(XTP_SCROLLBARDRAWCOLORS &sbc, int nHitSelected, int nHitPressed, BOOL bEnabled) | CXTPScrollBarThemeOffice2013 | virtual
m_clrCurrent | CXTPScrollBarThemeOffice2013 | protected
m_clrDisabled | CXTPScrollBarThemeOffice2013 | protected
m_clrNormal | CXTPScrollBarThemeOffice2013 | protected
m_clrPressed | CXTPScrollBarThemeOffice2013 | protected
m_clrSelected | CXTPScrollBarThemeOffice2013 | protected
m_crBack | CXTPScrollBarPaintManager |
m_crBackHilite | CXTPScrollBarPaintManager |
m_crBackPushed | CXTPScrollBarPaintManager |
m_crBorder | CXTPScrollBarPaintManager |
m_crBorderHilite | CXTPScrollBarPaintManager |
m_cThumb | CXTPScrollBarPaintManager |
m_cxHScroll | CXTPScrollBarPaintManager |
m_cxVScroll | CXTPScrollBarPaintManager |
m_cyHScroll | CXTPScrollBarPaintManager |
m_cyVScroll | CXTPScrollBarPaintManager |
RefreshMetrics() | CXTPScrollBarThemeOffice2013 | protectedvirtual
~CXTPScrollBarThemeOffice2013() | CXTPScrollBarThemeOffice2013 | virtual


Toolkit Pro: Member List

CXTPCalendarOffice2000Theme Member List

This is the complete list of members for CXTPCalendarOffice2000Theme, including all inherited members.

_GetAtGrow_BusyStatusBrushValue(int eBusyStatus, BOOL bGrow) | CXTPCalendarPaintManager | protected
_Init() | CXTPCalendarPaintManager | virtual
AddViewPart(CXTPCalendarViewPart *pPart) | CXTPCalendarPaintManager | protected
AdjustTimeFont(CDC *pDC, CRect rcCell) | CXTPCalendarPaintManager |
BEGIN_VIEW_PART(ControlPart, XTPCalendarViewPart) virtual void RefreshMetrics() | CXTPCalendarPaintManager |
CalcEventSize(CDC *c, CXTPCalendarTimeLineViewEvent *pViewEvent) | CXTPCalendarPaintManager | virtual
CalcWidth(CDC *pDC, const CString &strHour, const CString &strMin, int nHourHeight, int &nWidth) | CXTPCalendarPaintManager |
CXTPCalendarOffice2000Theme() | CXTPCalendarOffice2000Theme |
CXTPCalendarPaintManager() | CXTPCalendarPaintManager |
CXTPCmdTarget() | CXTPCmdTarget |
DrawBigHourCell(CDC *pDC, CRect rc, CString strHour, CString strMin, int nRowPerHour, BOOL bFillBackground=TRUE, BOOL bCurrentTime=FALSE) | CXTPCalendarPaintManager | virtual
DrawBitmap(CImageList *pImageList, CDC *pDC, CRect rcView, int iIcon, UINT uFlags=0) | CXTPCalendarPaintManager | virtual
DrawBitmap(UINT nIDResource, CDC *pDC, CRect rcBitmap) | CXTPCalendarPaintManager | virtual
DrawBorder(CDC *pDC, CRect rcView, CXTPCalendarWeekViewEvent *pWeekViewEvent) | CXTPCalendarPaintManager | virtual
DrawBusyStatus(CDC *pDC, CRect &rcRect, int eBusyStatus) | CXTPCalendarPaintManager | virtual
DrawBusyStatus(CDC *pDC, CRgn &rgnBusy, int eBusyStatus) | CXTPCalendarPaintManager | virtual
DrawClock(CDC *pDC, COleDateTime dtClockTime, CRect rcView, COLORREF clrBackground, XTPCalendarClockAlignFlags cafAlign) | CXTPCalendarPaintManager | virtual
DrawDayHeader(CDC *pDC, CRect rcDay, int nHeaderHeight, CString strHeader, BOOL bIsCurrent=FALSE, BOOL bIsSelected=FALSE) | CXTPCalendarPaintManager | virtual
DrawEvent(CDC *pDC, const CRect &rcEvents, CXTPCalendarTimeLineViewEvent *pViewEvent) | CXTPCalendarPaintManager | virtual
DrawExpandSigns(CDC *pDC, CXTPCalendarDayView *pView, const CRect &rcTSHours) | CXTPCalendarPaintManager | virtual
DrawGroup(CDC *pDC, const CRect &rcRect, CXTPCalendarTimeLineViewGroup *pGroup) | CXTPCalendarPaintManager | virtual
DrawHeader(CDC *pDC, CRect &rcHeader, BOOL bIsSelected, BOOL bIsCurrent) | CXTPCalendarPaintManager | virtual
DrawHeader(CDC *pDC, CRect &rcHeader, BOOL bIsSelected, BOOL bIsCurrent, const CXTPPaintManagerColorGradient &grclr, COLORREF clrUnderLineHdr) | CXTPCalendarPaintManager | virtual
DrawHorizontalLine(CDC *pDC, int xPos, int yPos, int cx) | CXTPCalendarPaintManager | virtual
DrawHourCell(CDC *pDC, CRect rc, CString strText, BOOL bFillBackground=TRUE, BOOL bCurrentTime=FALSE) | CXTPCalendarPaintManager | virtual
DrawIconChar(CDC *pDC, CRect rc, TCHAR ch) | CXTPCalendarPaintManager | virtual
DrawIcons(CDC *pDC, CXTPCalendarViewEvent *pViewEvent) | CXTPCalendarPaintManager | virtual
DrawLine(CDC *pDC, int xPos, int yPos, int cx, int cy) | CXTPCalendarPaintManager | virtual
DrawNowLine(CDC *pDC, CXTPCalendarDayView *pView, CRect rc, int y, BOOL bDrawBk=FALSE) | CXTPCalendarPaintManager | virtual
DrawNowLine(CDC *pDC, CXTPCalendarDayView *pView, CXTPCalendarDayViewTimeScale *pScale, CRect rc, int y, BOOL bDrawBk=FALSE) | CXTPCalendarPaintManager | virtual
DrawShadow(CDC *pDC, const CRect &rcRect) | CXTPCalendarPaintManager | virtual
DrawSubj(CDC *pDC, CXTPCalendarWeekViewEvent *pWeekViewEvent) | CXTPCalendarPaintManager | virtual
DrawTimes(CDC *pDC, CXTPCalendarWeekViewEvent *pWeekViewEvent) | CXTPCalendarPaintManager | virtual
DrawVerticalLine(CDC *pDC, int xPos, int yPos, int cy) | CXTPCalendarPaintManager | virtual
EnableTheme(BOOL bEnableTheme) | CXTPCalendarPaintManager |
END_VIEW_PART(ControlPart) BEGIN_VIEW_PART(DayViewTimeScaleHeaderPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewTimeScaleHeaderPart) BEGIN_VIEW_PART(DayViewTimeScaleCellPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewTimeScaleCellPart) BEGIN_VIEW_PART(DayViewCellPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewCellPart) BEGIN_VIEW_PART(DayViewWorkCellPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewWorkCellPart) BEGIN_VIEW_PART(DayViewNonworkCellPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewNonworkCellPart) BEGIN_VIEW_PART(DayMonthViewHeaderPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayMonthViewHeaderPart) BEGIN_VIEW_PART(DayViewHeaderPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewHeaderPart) BEGIN_VIEW_PART(DayViewGroupHeaderPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewGroupHeaderPart) BEGIN_VIEW_PART(DayViewAllDayEventsPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewAllDayEventsPart) BEGIN_VIEW_PART(DayViewAllDayEventScrollIconsPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewAllDayEventScrollIconsPart) BEGIN_VIEW_PART(DayViewEventPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewEventPart) BEGIN_VIEW_PART(MonthViewGridPart | CXTPCalendarPaintManager |
END_VIEW_PART(MonthViewGridPart) BEGIN_VIEW_PART(MonthViewHeaderPart | CXTPCalendarPaintManager |
END_VIEW_PART(MonthViewHeaderPart) BEGIN_VIEW_PART(MonthViewEventPart | CXTPCalendarPaintManager |
END_VIEW_PART(MonthViewEventPart) BEGIN_VIEW_PART(WeekViewPart | CXTPCalendarPaintManager |
END_VIEW_PART(WeekViewPart) BEGIN_VIEW_PART(WeekViewEventPart | CXTPCalendarPaintManager |
END_VIEW_PART(WeekViewEventPart) BEGIN_VIEW_PART(TimeLineViewTimeScalePart_Day | CXTPCalendarPaintManager |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAskItemTextFlags() const | CXTPCalendarPaintManager |
GetBusyStatusBrush(int nBusyStatus) | CXTPCalendarPaintManager |
GetClockSize() | CXTPCalendarPaintManager | virtual
GetCurrentSystemTheme() | CXTPCalendarPaintManager |
GetEventBackColor(CXTPCalendarEvent *pEvent, COLORREF crDefault) | CXTPCalendarPaintManager | virtual
GetExpandSignSize() | CXTPCalendarPaintManager | virtual
GetPaintTheme() const | CXTPCalendarPaintManager | virtual
GetParams(CXTPCalendarDayViewGroup *pViewGroup, XTP_CALENDAR_DAYVIEWCELL_PARAMS *rCellParams) | CXTPCalendarPaintManager | virtual
idxExpandSignDown enum value | CXTPCalendarPaintManager | protected
idxExpandSignUp enum value | CXTPCalendarPaintManager | protected
idxMeeting enum value | CXTPCalendarPaintManager | protected
idxPrivate enum value | CXTPCalendarPaintManager | protected
idxRecurrenceException enum value | CXTPCalendarPaintManager | protected
idxRecurrenceOccurrence enum value | CXTPCalendarPaintManager | protected
idxReminder enum value | CXTPCalendarPaintManager | protected
InitBusyStatusDefaultColors() | CXTPCalendarPaintManager | protectedvirtual
IsThemeEnabled() | CXTPCalendarPaintManager |
m_arBusyStatusBrushes | CXTPCalendarPaintManager | protected
m_arStartCol | CXTPCalendarPaintManager |
m_arStartRow | CXTPCalendarPaintManager |
m_bEnableTheme | CXTPCalendarPaintManager | protected
m_bmpElsewherePattern | CXTPCalendarPaintManager | protected
m_bmpTentativePattern | CXTPCalendarPaintManager | protected
m_bShowMinutes | CXTPCalendarPaintManager |
m_clr3DShadow | CXTPCalendarPaintManager |
m_clrBackground | CXTPCalendarPaintManager |
m_clrBackground2 | CXTPCalendarPaintManager |
m_clrBackgroundSlave | CXTPCalendarPaintManager |
m_clrBorders | CXTPCalendarPaintManager |
m_clrButtonFace | CXTPCalendarPaintManager |
m_clrButtonFaceText | CXTPCalendarPaintManager |
m_clrClassicUnderline | CXTPCalendarPaintManager |
m_clrEventBar | CXTPCalendarPaintManager |
m_clrEventBarLine | CXTPCalendarPaintManager |
m_clrEventBorderLine | CXTPCalendarPaintManager |
m_clrHeaderBottomLine | CXTPCalendarPaintManager |
m_clrHighlight | CXTPCalendarPaintManager |
m_clrHour | CXTPCalendarPaintManager |
m_clrMultiDayEventFrameColor | CXTPCalendarPaintManager |
m_clrSelectedBackground | CXTPCalendarPaintManager |
m_clrSelectedText | CXTPCalendarPaintManager |
m_clrShadow | CXTPCalendarPaintManager |
m_clrText | CXTPCalendarPaintManager |
m_clrTextHighLightColor | CXTPCalendarPaintManager |
m_clrTextNormalColor | CXTPCalendarPaintManager |
m_clrTimeScaleBackground | CXTPCalendarPaintManager |
m_clrTimeScaleHightlite | CXTPCalendarPaintManager |
m_clrTimeScaleText | CXTPCalendarPaintManager |
m_clrUnderLineHdr | CXTPCalendarPaintManager | protected
m_clrWeekendBackground | CXTPCalendarPaintManager |
m_clrWindow | CXTPCalendarPaintManager |
m_clrWindowText | CXTPCalendarPaintManager |
m_CurrSystemTheme | CXTPCalendarPaintManager | protected
m_dwAskItemTextFlags | CXTPCalendarPaintManager | protected
m_fntTimeText | CXTPCalendarPaintManager |
m_grclrClassicSelDay | CXTPCalendarPaintManager |
m_grclrToday | CXTPCalendarPaintManager |
m_lstViewParts | CXTPCalendarPaintManager | protected
m_nHourWidth | CXTPCalendarPaintManager |
m_nMinWidth | CXTPCalendarPaintManager |
m_nPaintTheme | CXTPCalendarPaintManager | protected
m_pControl | CXTPCalendarPaintManager | protected
m_pExpandSigns | CXTPCalendarPaintManager | protected
m_pGlyphs | CXTPCalendarPaintManager | protected
m_pGlyphsFont | CXTPCalendarPaintManager | protected
m_PrintPageWidth | CXTPCalendarPaintManager |
m_szClockRect | CXTPCalendarPaintManager | protected
m_xtpBrushElsewhere | CXTPCalendarPaintManager | protected
m_xtpBrushTentative | CXTPCalendarPaintManager | protected
OnDraw(CDC *pDC, CXTPCalendarDayView *pView, CRect rc, CString strText) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarDayViewGroup *pViewGroup, CRect rc, const XTP_CALENDAR_DAYVIEWCELL_PARAMS &cellParams) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarDayViewDay *pViewDay, CRect rc, CString strText) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarDayViewGroup *pViewGroup, CRect rc, CString strText) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarDayViewGroup *pViewGroup, CRect rc, BOOL bSelected) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarDayViewGroup *pViewGroup, BOOL bDrawUp, BOOL bDrawDown, const CRect &rcIconUp, const CRect &rcIconDown, BOOL bHighlightUp, BOOL bHighlightDown) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarDayViewEvent *pViewEvent) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarMonthView *pMonthView, CRect rc, int nCollIndex, CString strText) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarWeekView *pWeekView) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarWeekViewEvent *pWeekViewEvent) | CXTPCalendarPaintManager | virtual
OnDrawDayDate(CDC *pDC, CRect rc, BOOL bToday, BOOL bSelected, BOOL bFirstMonthDay, CString strText) | CXTPCalendarPaintManager | virtual
OnDrawEvent(CDC *pDC, CXTPCalendarMonthViewEvent *pViewEvent) | CXTPCalendarPaintManager | virtual
OnDrawGrid(CDC *pDC, CXTPCalendarMonthView *pMonthView) | CXTPCalendarPaintManager | virtual
RefreshMetrics() | CXTPCalendarPaintManager | virtual
RefreshMetrics() | CXTPCalendarPaintManager | virtual
RefreshMetrics() | CXTPCalendarPaintManager | virtual
RefreshMetrics() | CXTPCalendarPaintManager | virtual
RefreshMetrics() | CXTPCalendarPaintManager | virtual
RefreshMetrics() | CXTPCalendarPaintManager | inlinevirtual
RefreshMetrics() | CXTPCalendarPaintManager | virtual
RefreshMetrics() | CXTPCalendarPaintManager | virtual
RefreshMetrics() | CXTPCalendarPaintManager | virtual
RefreshMetrics() | CXTPCalendarPaintManager | virtual
RefreshMetrics() | CXTPCalendarPaintManager | virtual
RefreshMetrics() | CXTPCalendarPaintManager | inlinevirtual
RefreshMetrics() | CXTPCalendarPaintManager | virtual
RefreshMetrics() | CXTPCalendarPaintManager | virtual
SetAskItemTextFlags(DWORD dwFlags) | CXTPCalendarPaintManager |
SetBusyStatusBrush(int nBusyStatus, CBrush *pBrush, BOOL bAutodeleteBrush) | CXTPCalendarPaintManager |
SetControl(CXTPCalendarControl *pControl) | CXTPCalendarPaintManager | virtual
SetPaintTheme(XTPCalendarTheme ePaintTheme) | CXTPCalendarPaintManager | virtual
UpdateEventCategoriesDefaultColors() | CXTPCalendarPaintManager | virtual
UpdateEventLabelsDefaultColors() | CXTPCalendarPaintManager | virtual
UpdateGlyphs() | CXTPCalendarPaintManager | virtual
XTPEnumEventGlyphs enum name | CXTPCalendarPaintManager | protected
XTPEnumExpandSigns enum name | CXTPCalendarPaintManager | protected
~CTimeLineViewPart() | CXTPCalendarPaintManager | virtual
~CXTPCalendarOffice2000Theme() | CXTPCalendarOffice2000Theme | virtual
~CXTPCalendarPaintManager() | CXTPCalendarPaintManager | virtual


Toolkit Pro: Member List

CXTPSyntaxEditDoc Member List

This is the complete list of members for CXTPSyntaxEditDoc, including all inherited members.

CheckFileModified(LPCTSTR lpszPathName) | CXTPSyntaxEditDoc |
CXTPSyntaxEditDoc() | CXTPSyntaxEditDoc | protected
GetAutoReload() const | CXTPSyntaxEditDoc |
GetDataManager() const | CXTPSyntaxEditDoc |
GetFirstView() | CXTPSyntaxEditDoc |
IsReadonly() | CXTPSyntaxEditDoc |
m_bAutoReload | CXTPSyntaxEditDoc | protected
m_bDocCreated | CXTPSyntaxEditDoc | protected
m_bNewFile | CXTPSyntaxEditDoc | protected
m_bOpened | CXTPSyntaxEditDoc | protected
m_bReloading | CXTPSyntaxEditDoc | protected
m_iHScrollPos | CXTPSyntaxEditDoc | protected
m_iTopRow | CXTPSyntaxEditDoc | protected
m_ptrDataMan | CXTPSyntaxEditDoc | protected
ReOpen() | CXTPSyntaxEditDoc |
SetAutoReload(BOOL bAutoReload, BOOL bUpdateReg=FALSE) | CXTPSyntaxEditDoc |
SetConfigFile(LPCTSTR szPath) | CXTPSyntaxEditDoc |
SetDataManager(CXTPSyntaxEditBufferManager *pBuffer) | CXTPSyntaxEditDoc |
~CXTPSyntaxEditDoc() | CXTPSyntaxEditDoc | protectedvirtual


Toolkit Pro: Member List

CXTPSyntaxEditOptions Member List

This is the complete list of members for CXTPSyntaxEditOptions, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
m_bAutoIndent | CXTPSyntaxEditOptions | protected
m_bDrawNodes | CXTPSyntaxEditOptions | protected
m_bEnableEditAccelerators | CXTPSyntaxEditOptions | protected
m_bEnableWhiteSpace | CXTPSyntaxEditOptions | protected
m_bHideCaret | CXTPSyntaxEditOptions | protected
m_bLineNumbers | CXTPSyntaxEditOptions | protected
m_bReadOnly | CXTPSyntaxEditOptions | protected
m_bSelMargin | CXTPSyntaxEditOptions | protected
m_bSyntaxColor | CXTPSyntaxEditOptions | protected
m_bTabWithSpace | CXTPSyntaxEditOptions | protected
m_bViewOnly | CXTPSyntaxEditOptions | protected
m_bVirtualSpace | CXTPSyntaxEditOptions | protected
m_bWideCaret | CXTPSyntaxEditOptions | protected
m_mapRowBkColor | CXTPSyntaxEditOptions | protected
m_mapRowForeColor | CXTPSyntaxEditOptions | protected


Toolkit Pro: Member List

XTP_GRIDDATAMANAGER_COM_ERROR Member List

This is the complete list of members for XTP_GRIDDATAMANAGER_COM_ERROR, including all inherited members.

hResult | XTP_GRIDDATAMANAGER_COM_ERROR |
operator=(const XTP_GRIDDATAMANAGER_COM_ERROR &errorSrc) | XTP_GRIDDATAMANAGER_COM_ERROR | inline
strMessage | XTP_GRIDDATAMANAGER_COM_ERROR |
strSource | XTP_GRIDDATAMANAGER_COM_ERROR |
XTP_GRIDDATAMANAGER_COM_ERROR() | XTP_GRIDDATAMANAGER_COM_ERROR | inline


Toolkit Pro: Member List

CXTPChartPieSeriesStyleBase Member List

This is the complete list of members for CXTPChartPieSeriesStyleBase, including all inherited members.

ApplyTo(CXTPChartDeviceCommand *pCommand) | CXTPChartSeriesStyle | virtual
CorrectAxisSideMargins(CXTPChartAxis *pAxis, double nMinValue, double nMaxValue, double &nCorrection) | CXTPChartSeriesStyle | virtual
CreateDiagram()=0 | CXTPChartPieSeriesStyleBase | protectedpure virtual
CreateView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)=0 | CXTPChartPieSeriesStyleBase | protectedpure virtual
CXTPChartElement() | CXTPChartElement |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartPieSeriesStyleBase() | CXTPChartPieSeriesStyleBase | protected
CXTPChartSeriesStyle() | CXTPChartSeriesStyle |
DoPropExchange(CXTPPropExchange *pPX) | CXTPChartPieSeriesStyleBase | virtual
Enable3dEdgeSmoothing(BOOL bEnable=TRUE) | CXTPChartSeriesStyle | virtual
Get3dRotation() const | CXTPChartSeriesStyle | virtual
GetAppearance() const | CXTPChartElement |
GetBorder() const | CXTPChartPieSeriesStyleBase |
GetBorderActualColor() const | CXTPChartPieSeriesStyleBase |
GetColor() const | CXTPChartSeriesStyle | virtual
GetContent() const | CXTPChartElement |
GetDepth() const | CXTPChartPieSeriesStyleBase | virtual
GetErrorBar() const | CXTPChartSeriesStyle | virtual
GetExplodedDistancePercent() const | CXTPChartPieSeriesStyleBase |
GetHolePercent() const | CXTPChartPieSeriesStyleBase |
GetLabel() const | CXTPChartSeriesStyle | virtual
GetOwner() const | CXTPChartElement |
GetRotation() const | CXTPChartPieSeriesStyleBase |
GetSeriesPointValueIndex() const | CXTPChartSeriesStyle | virtual
GetStyleAppearance() const | CXTPChartSeriesStyle | virtual
GetTransparency() const | CXTPChartSeriesStyle | virtual
Is3D() const | CXTPChartObject |
Is3dEdgeSmoothingEnabled() const | CXTPChartSeriesStyle | virtual
IsColorEach() const | CXTPChartSeriesStyle | virtual
IsStyleDiagram(CXTPChartDiagram *pDiagram) const | CXTPChartPieSeriesStyleBase | protectedvirtual
m_bColorEach | CXTPChartSeriesStyle | protected
m_bSmooth3dEdges | CXTPChartSeriesStyle | protected
m_clrColor | CXTPChartSeriesStyle | protected
m_nExplodedDistancePercent | CXTPChartPieSeriesStyleBase | protected
m_nHolePercent | CXTPChartPieSeriesStyleBase | protected
m_nRotation | CXTPChartPieSeriesStyleBase | protected
m_nTransparency | CXTPChartSeriesStyle | protected
m_pBorder | CXTPChartPieSeriesStyleBase | protected
m_pErrorBar | CXTPChartSeriesStyle | protected
m_pLabel | CXTPChartSeriesStyle | protected
m_Rotation3d | CXTPChartSeriesStyle | protected
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartElement | virtual
Release() | CXTPChartElement | virtual
Set3dRotation(const CXTPChart3dRotation &rotation) | CXTPChartSeriesStyle | virtual
Set3dRotation(double dYaw, double dPitch, double dRoll) | CXTPChartSeriesStyle | virtual
SetColor(CXTPChartColor clr) | CXTPChartSeriesStyle | virtual
SetColorEach(BOOL bColorEach) | CXTPChartSeriesStyle | virtual
SetErrorBar(CXTPChartErrorBar *pErrorBar) | CXTPChartSeriesStyle | virtual
SetExplodedDistancePercent(int nExplodedDistancePercent) | CXTPChartPieSeriesStyleBase |
SetHolePercent(int nHolePercent) | CXTPChartPieSeriesStyleBase |
SetLabel(CXTPChartSeriesLabel *pLabel) | CXTPChartSeriesStyle | virtual
SetRotation(int nRotation) | CXTPChartPieSeriesStyleBase |
SetTransparency(int nTransparency) | CXTPChartSeriesStyle | virtual
~CXTPChartElement() | CXTPChartElement | virtual
~CXTPChartPieSeriesStyleBase() | CXTPChartPieSeriesStyleBase | protectedvirtual
~CXTPChartSeriesStyle() | CXTPChartSeriesStyle | virtual


Toolkit Pro: Member List

CXTPTreeVisualStudio2022Theme Member List

This is the complete list of members for CXTPTreeVisualStudio2022Theme, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPControlTheme() | CXTPControlTheme |
CXTPTreeOffice2013Theme() | CXTPTreeOffice2013Theme |
CXTPTreeTheme() | CXTPTreeTheme |
CXTPTreeVisualStudio2022Theme() | CXTPTreeVisualStudio2022Theme |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetItemBackColor(UINT uState, bool bTreeHasFocus, DWORD dwStyle, COLORREF crTextDef, CTreeCtrl *pTreeBase) const | CXTPTreeTheme | virtual
GetItemTextColor(UINT uState, bool bTreeHasFocus, DWORD dwStyle, COLORREF crBackDef, CTreeCtrl *pTreeBase) const | CXTPTreeTheme | virtual
GetThemeStyle() const | CXTPControlTheme |
GetTreeBackColor() const | CXTPTreeTheme | virtual
GetTreeTextColor() const | CXTPTreeTheme | virtual
IsDrawFocusRect() const | CXTPTreeTheme | inline
IsThemeDark() const | CXTPTreeTheme | inlinevirtual
m_bDarkTheme | CXTPTreeTheme | protected
m_bDrawFocusRect | CXTPTreeTheme | protected
m_crBack | CXTPTreeTheme | protected
m_crBackDisabled | CXTPTreeTheme | protected
m_crBackSelected | CXTPTreeTheme | protected
m_crBackSelectedDisabled | CXTPTreeTheme | protected
m_crBackSelectedInactive | CXTPTreeTheme | protected
m_crText | CXTPTreeTheme | protected
m_crTextDisabled | CXTPTreeTheme | protected
m_crTextSelected | CXTPTreeTheme | protected
m_crTextSelectedDisabled | CXTPTreeTheme | protected
m_crTextSelectedInactive | CXTPTreeTheme | protected
m_nTheme | CXTPControlTheme | protected
RefreshMetrics(CXTPTreeBase *pTreeBase) | CXTPTreeOffice2013Theme | virtual
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static
~CXTPTreeTheme() | CXTPTreeTheme | virtual


Toolkit Pro: Member List

CXTPColorSelectorCtrlThemeResource Member List

This is the complete list of members for CXTPColorSelectorCtrlThemeResource, including all inherited members.

CalcSize(CXTPColorSelectorCtrl *pOwner) | CXTPColorSelectorCtrlTheme | virtual
CreateAutoButton(CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked) | CXTPColorSelectorCtrlTheme | virtual
CreateColorButtons(CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked) | CXTPColorSelectorCtrlTheme | virtual
CreateExtendedButtons(CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked) | CXTPColorSelectorCtrlTheme | virtual
CreateMoreButton(CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked) | CXTPColorSelectorCtrlTheme | virtual
CreateRecentColorButtons(CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked) | CXTPColorSelectorCtrlTheme | virtual
CreateThemeButtons(CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked) | CXTPColorSelectorCtrlTheme | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPColorSelectorCtrlTheme() | CXTPColorSelectorCtrlTheme |
CXTPColorSelectorCtrlThemeOfficeXP() | CXTPColorSelectorCtrlThemeOfficeXP |
CXTPColorSelectorCtrlThemeResource() | CXTPColorSelectorCtrlThemeResource |
CXTPControlTheme() | CXTPControlTheme |
DrawColorCell(CDC *pDC, CXTPColorSelectorCtrl *pOwner, CXTPColorSelectorCtrl::COLOR_CELL *pColorCell, BOOL bHighlight, BOOL bPressed) | CXTPColorSelectorCtrlTheme | virtual
DrawColorSelector(CDC *pDC, CXTPColorSelectorCtrl *pOwner) | CXTPColorSelectorCtrlTheme | virtual
FillBackground(CDC *pDC, CXTPColorSelectorCtrl *pOwner, const CRect &rect) | CXTPColorSelectorCtrlTheme | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetButtonSize() const | CXTPColorSelectorCtrlTheme | virtual
GetThemeStyle() const | CXTPControlTheme |
m_bThinBorder | CXTPColorSelectorCtrlTheme |
m_crBack | CXTPColorSelectorCtrlTheme |
m_crBackChecked | CXTPColorSelectorCtrlTheme |
m_crBackHilight | CXTPColorSelectorCtrlTheme |
m_crBackPressed | CXTPColorSelectorCtrlTheme |
m_crBorder | CXTPColorSelectorCtrlTheme |
m_crBorderHilight | CXTPColorSelectorCtrlTheme |
m_crBorderPressed | CXTPColorSelectorCtrlTheme |
m_crPopupBorder | CXTPColorSelectorCtrlTheme |
m_crText | CXTPColorSelectorCtrlTheme |
m_crTextPressed | CXTPColorSelectorCtrlTheme |
m_nAutoButton | CXTPColorSelectorCtrlTheme |
m_nCaption | CXTPColorSelectorCtrlTheme |
m_nMargin | CXTPColorSelectorCtrlTheme |
m_nTheme | CXTPControlTheme | protected
m_rcRecentText | CXTPColorSelectorCtrlTheme |
m_rcStandardText | CXTPColorSelectorCtrlTheme |
m_rcThemeText | CXTPColorSelectorCtrlTheme |
m_sizeButton | CXTPColorSelectorCtrlTheme |
RefreshMetrics(CXTPColorSelectorCtrl *pOwner) | CXTPColorSelectorCtrlThemeResource | virtual
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static


Toolkit Pro: XTPChart2dPyramidDiagram.h Source File

  • Source
  • Chart
  • Styles
  • Pyramid
  • 2D
XTPChart2dPyramidDiagram.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHART2DPYRAMIDDIAGRAM_H__)
24# define __XTPCHART2DPYRAMIDDIAGRAM_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartDeviceContext;
34class CXTPChartElementView;
35class CXTPChartDiagramView;
36
42class _XTP_EXT_CLASS CXTPChartPyramidDiagram : public CXTPChart2dPyramidDiagramBase
43{
44 DECLARE_SERIAL(CXTPChartPyramidDiagram);
45
46public:
51 CXTPChartPyramidDiagram();
52
53public:
64 virtual CXTPChartDiagramView* CreateView(CXTPChartDeviceContext* pDC,
65 CXTPChartElementView* pParent);
66
67# ifdef _XTP_ACTIVEX
68public:
70 DECLARE_DISPATCH_MAP()
71 DECLARE_INTERFACE_MAP()
72 DECLARE_OLETYPELIB_EX(CXTPChartPyramidDiagram);
73 DECLARE_OLECREATE_EX(CXTPChartPyramidDiagram)
75# endif
76};
78# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
79#endif //#if !defined(__XTPCHART2DPYRAMIDDIAGRAM_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartDiagramView
This class represents the view of a chart diagram, which is a kind of CXTPChartElementView.
Definition XTPChartDiagramView.h:49
CXTPChartElementView
This class represents the view of a chart element.
Definition XTPChartElementView.h:47
CXTPChartPyramidDiagramBase
This class abstracts the pyramid diagram.
Definition XTPChartPyramidDiagramBase.h:55
CXTPChartPyramidDiagram
This class abstracts the pyramid diagram.
Definition XTPChart2dPyramidDiagram.h:43
CXTPChartPyramidDiagram::CXTPChartPyramidDiagram
CXTPChartPyramidDiagram()
Constructs a CXTPChartPyramidDiagram object.
CXTPChartPyramidDiagram::CreateView
virtual CXTPChartDiagramView * CreateView(CXTPChartDeviceContext *pDC, CXTPChartElementView *pParent)
Call this function to create the view of the pyramid diagram.


Toolkit Pro: XTPChartPalette.h Source File

  • Source
  • Chart
  • Appearance
XTPChartPalette.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTPALETTE_H__)
24# define __XTPCHARTPALETTE_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPChartPaletteEntry
39{
40public:
41 CXTPChartColor Color;
42 CXTPChartColor Color2;
43};
44
50typedef CArray<CXTPChartPaletteEntry, CXTPChartPaletteEntry&> CXTPChartPaletteEntries;
51
56class _XTP_EXT_CLASS CXTPChartPalette : public CXTPChartElement
57{
58public:
65 CXTPChartPalette(CXTPChartElement* pOwner);
66
71 virtual ~CXTPChartPalette();
72
73public:
82 CXTPChartColor GetColor(int nIndex) const;
83
92 CXTPChartColor GetColor2(int nIndex) const;
93
100 int GetCount() const;
101
108 CXTPChartPaletteEntries& GetEntries();
109
110public:
122 void DoPropExchange(CXTPPropExchange* pPX);
123
124# ifdef _XTP_ACTIVEX
125public:
127 DECLARE_DISPATCH_MAP()
128 DECLARE_INTERFACE_MAP()
129 DECLARE_OLETYPELIB_EX(CXTPChartPalette);
130
131 afx_msg OLE_COLOR OleGetColor(int nIndex);
132 afx_msg OLE_COLOR OleGetColor2(int nIndex);
133 afx_msg void OleSetColor(int nIndex, OLE_COLOR clr);
134 afx_msg void OleSetColor2(int nIndex, OLE_COLOR clr);
135 afx_msg void OleDeleteAll();
136 afx_msg void OleAddEntry(OLE_COLOR clr, OLE_COLOR clr2);
137 afx_msg int OleGetCount();
139# endif
140
141protected:
142 CXTPChartPaletteEntries m_arrEntries;
143};
144
145AFX_INLINE int CXTPChartPalette::GetCount() const
146{
147 return (int)m_arrEntries.GetSize();
148}
149AFX_INLINE CXTPChartPaletteEntries& CXTPChartPalette::GetEntries()
150{
151 return m_arrEntries;
152}
154# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
155#endif //#if !defined(__XTPCHARTPALETTE_H__)
CXTPChartPaletteEntries
CArray< CXTPChartPaletteEntry, CXTPChartPaletteEntry & > CXTPChartPaletteEntries
This type represents a collection of CXTPChartPaletteEntry objects, the container here used is CArray...
Definition XTPChartPalette.h:50
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartColor
This class abstracts a color entity.
Definition XTPChartTypes.h:51
CXTPChartElement
This class abstracts a chart element, this class acts as a base class for all chart elements.
Definition XTPChartElement.h:131
CXTPChartPaletteEntry
This class represents a palette entry, which abstracts two 32 bit color values of type ARGB.
Definition XTPChartPalette.h:39
CXTPChartPalette
This class abstracts a color palette.
Definition XTPChartPalette.h:57
CXTPChartPalette::GetCount
int GetCount() const
Call this function to get number of entris in the palette.
Definition XTPChartPalette.h:145
CXTPChartPalette::~CXTPChartPalette
virtual ~CXTPChartPalette()
Destroys a CXTPChartPalette object, handles cleanup.
CXTPChartPalette::DoPropExchange
void DoPropExchange(CXTPPropExchange *pPX)
Call this member function to Store/Load the properties of palette object using the specified data obj...
CXTPChartPalette::GetColor
CXTPChartColor GetColor(int nIndex) const
Call this function to get the first color at a particular index in the palette.
CXTPChartPalette::GetColor2
CXTPChartColor GetColor2(int nIndex) const
Call this function to get the second color at a particular index in the palette.
CXTPChartPalette::m_arrEntries
CXTPChartPaletteEntries m_arrEntries
The palette entry collection object.
Definition XTPChartPalette.h:142
CXTPChartPalette::GetEntries
CXTPChartPaletteEntries & GetEntries()
Call this function to get the palette entries.
Definition XTPChartPalette.h:149
CXTPChartPalette::CXTPChartPalette
CXTPChartPalette(CXTPChartElement *pOwner)
Constructs a CXTPChartPalette object.
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72


Toolkit Pro: Member List

CXTPCaptionPopupWnd Member List

This is the complete list of members for CXTPCaptionPopupWnd, including all inherited members.

Create(const CRect &rect, CWnd *pParentWnd, CWnd *pChildWnd) | CXTPCaptionPopupWnd | virtual
CXTPCaptionPopupWnd() | CXTPCaptionPopupWnd |
m_Caption | CXTPCaptionPopupWnd | protected
m_CaptionButton | CXTPCaptionPopupWnd | protected
m_hIconOff | CXTPCaptionPopupWnd | protected
m_hIconOn | CXTPCaptionPopupWnd | protected
m_pChildParent | CXTPCaptionPopupWnd | protected
m_pChildWnd | CXTPCaptionPopupWnd | protected
m_pParentWnd | CXTPCaptionPopupWnd | protected
RecalcLayout() | CXTPCaptionPopupWnd | virtual
RegisterWindowClass() | CXTPCaptionPopupWnd | protected
ResetParent() | CXTPCaptionPopupWnd | virtual
SendCancelMessage() | CXTPCaptionPopupWnd | virtual
SetTheme(XTPControlTheme nTheme) | CXTPCaptionPopupWnd |
~CXTPCaptionPopupWnd() | CXTPCaptionPopupWnd | virtual


Toolkit Pro: Member List

CXTPShortcutListBoxTheme Member List

This is the complete list of members for CXTPShortcutListBoxTheme, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPControlTheme() | CXTPControlTheme |
CXTPShortcutListBoxTheme() | CXTPShortcutListBoxTheme |
DrawImage(CDC *pDC, CRect &rcIcon, CXTPImageManagerIcon *pImage, BOOL bEnabled, BOOL bSelected, BOOL bPressed) | CXTPShortcutListBoxTheme | protectedvirtual
DrawItem(CXTPShortcutListBox *pMenuListBox, LPDRAWITEMSTRUCT lpDIS) | CXTPShortcutListBoxTheme | virtual
DrawText(CDC *pDC, CRect &rcText, CXTPShortcutListBox::CONTENT_ITEM *pCI) | CXTPShortcutListBoxTheme | protectedvirtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetBackColor() | CXTPShortcutListBoxTheme |
GetTextColor() | CXTPShortcutListBoxTheme |
GetThemeStyle() const | CXTPControlTheme |
m_crgBack | CXTPShortcutListBoxTheme |
m_crgItemBackHot | CXTPShortcutListBoxTheme |
m_crgItemBackPressed | CXTPShortcutListBoxTheme |
m_crgItemBorder | CXTPShortcutListBoxTheme |
m_crItemText | CXTPShortcutListBoxTheme |
m_crItemTextDisabled | CXTPShortcutListBoxTheme |
m_cxIcon | CXTPShortcutListBoxTheme |
m_cyEdge | CXTPShortcutListBoxTheme |
m_cyIcon | CXTPShortcutListBoxTheme |
m_nTheme | CXTPControlTheme | protected
RefreshMetrics(CXTPShortcutListBox *pList) | CXTPShortcutListBoxTheme | virtual
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static
~CXTPShortcutListBoxTheme() | CXTPShortcutListBoxTheme | virtual


Toolkit Pro: Member List

CXTPShortcutManagerAccel Member List

This is the complete list of members for CXTPShortcutManagerAccel, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPShortcutManagerAccel() | CXTPShortcutManagerAccel |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static


Toolkit Pro: XTPDockState.h Source File

  • Source
  • CommandBars
XTPDockState.h
Go to the documentation of this file.
1
23#if !defined(__XTPDOCKSTATE_H__)
24# define __XTPDOCKSTATE_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPDockState
39{
40 friend class CXTPCommandBars;
41
42private:
47 typedef CXTPToolBar::CToolBarInfo TOOLBARINFO;
48
49public:
55 void ScalePoint(CPoint& pt);
56
62 void ScaleRectPos(CRect& rect);
63
69 DWORD GetVersion() const;
70
71public:
76 CXTPDockState();
77
82 ~CXTPDockState();
83
84public:
92 void SaveState(LPCTSTR lpszProfileName);
93
101 void LoadState(LPCTSTR lpszProfileName);
102
110 void DoPropExchange(CXTPPropExchange* pPX);
111
112private:
113 void SaveDockBarState(LPCTSTR lpszProfileName);
114 CSize GetScreenSize();
115 void SetScreenSize(CSize& size);
116 void Clear();
117
118private:
119 DWORD m_dwVersion;
120 CArray<TOOLBARINFO*, TOOLBARINFO*> m_arrBarInfo;
121 BOOL m_bScaling;
122 CSize m_sizeDevice;
123 CSize m_sizeLogical;
124};
125
126AFX_INLINE DWORD CXTPDockState::GetVersion() const
127{
128 return m_dwVersion;
129}
131# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
132#endif //#if !defined(__XTPDOCKSTATE_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCommandBars
CXTPCommandBars is a standalone class.
Definition XTPCommandBars.h:165
CXTPDockState
CXTPDockState is a standalone class.
Definition XTPDockState.h:39
CXTPDockState::DoPropExchange
void DoPropExchange(CXTPPropExchange *pPX)
Either reads this object from or writes this object to an archive.
CXTPDockState::LoadState
void LoadState(LPCTSTR lpszProfileName)
Retrieves state information from the registry or .INI file.
CXTPDockState::GetVersion
DWORD GetVersion() const
Call this function to retrieve the version number of the stored bar state.
Definition XTPDockState.h:126
CXTPDockState::ScalePoint
void ScalePoint(CPoint &pt)
Maps the point from the stored coordinates to the device.
CXTPDockState::SaveState
void SaveState(LPCTSTR lpszProfileName)
Saves state information to the registry or .INI file.
CXTPDockState::~CXTPDockState
~CXTPDockState()
Destroys a CXTPDockState object, handles cleanup and deallocation.
CXTPDockState::CXTPDockState
CXTPDockState()
Constructs a CXTPDockState object.
CXTPDockState::ScaleRectPos
void ScaleRectPos(CRect &rect)
Maps the point from the stored coordinates to the device.
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72


Toolkit Pro: Member List

CXTPRibbonCustomizePage Member List

This is the complete list of members for CXTPRibbonCustomizePage, including all inherited members.

AddCategories(UINT nIDResource, BOOL bListSubItems=FALSE) | CXTPRibbonCustomizePage |
AddCategories(CXTPControls *pControls) | CXTPRibbonCustomizePage |
AddCategory(LPCTSTR strCategory, CMenu *pMenu, BOOL bListSubItems=FALSE) | CXTPRibbonCustomizePage |
AdjustResizeRect(CSize &rcWindow) | CXTPResize | protectedvirtual
AutoLoadPlacement(LPCTSTR pszSection) | CXTPResize |
CResizeItemArray typedef | CXTPResize | protected
CXTPPropertyPage() | CXTPPropertyPage |
CXTPPropertyPage(UINT nIDTemplate, UINT nIDCaption=0) | CXTPPropertyPage |
CXTPPropertyPage(LPCTSTR lpszTemplateName, UINT nIDCaption=0) | CXTPPropertyPage |
CXTPResize(CWnd *pWnd, const UINT nFlags=0) | CXTPResize |
CXTPRibbonCustomizePage(CXTPCustomizeSheet *pSheet) | CXTPRibbonCustomizePage |
CXTPRibbonCustomizePage(CXTPCommandBars *pCommandBars) | CXTPRibbonCustomizePage |
Defer(HDWP &hdwp, CXTPResizeItem *pItem, int dx, int dy) | CXTPResize | protectedvirtual
GetCaption() const | CXTPPropertyPage |
GetControls(LPCTSTR strCategory) | CXTPRibbonCustomizePage |
GetMinMaxInfo(MINMAXINFO *pMMI) | CXTPResize | protected
GetRibbonBar() | CXTPRibbonCustomizePage |
HasFlag(XTPResize eFlag) | CXTPResize | protected
Init() | CXTPResize | protectedvirtual
InsertCategory(LPCTSTR strCategory, int nIndex=-1) | CXTPRibbonCustomizePage |
LoadPlacement(LPCTSTR pszSection) | CXTPResize |
m_arrCategories | CXTPRibbonCustomizePage | protected
m_arrItems | CXTPResize | protected
m_bModified | CXTPPropertyPage | protected
m_cmbCategories | CXTPRibbonCustomizePage |
m_cmbTabGroup | CXTPRibbonCustomizePage |
m_dwData | CXTPPropertyPage |
m_nFlagsXX | CXTPResize | protected
m_pCommandBars | CXTPRibbonCustomizePage | protected
m_pSheet | CXTPRibbonCustomizePage | protected
m_pWnd | CXTPResize | protected
m_scSizeIcon | CXTPResize | protected
m_strSection | CXTPResize | protected
m_szInitWindow | CXTPResize | protected
m_szMax | CXTPResize | protected
m_szMin | CXTPResize | protected
m_szWindow | CXTPResize | protected
m_treeCommands | CXTPRibbonCustomizePage |
m_treeRibbon | CXTPRibbonCustomizePage |
Offset(CPoint ptOffset) | CXTPResize | protected
RefreshRibbonList() | CXTPRibbonCustomizePage | protected
RemoveAllControls() | CXTPResize | protected
RemoveResize(UINT nID) | CXTPResize | protected
Reset() | CXTPResize | protected
SavePlacement(LPCTSTR pszSection) | CXTPResize |
SetCaption(LPCTSTR lpszCaption) | CXTPPropertyPage |
SetFlag(XTPResize eFlag) | CXTPResize | protected
SetMaxSize(CSize &sz) | CXTPResize |
SetMinSize(CSize &sz) | CXTPResize |
SetResize(UINT nID, XTP_RESIZE left, XTP_RESIZE top, XTP_RESIZE right, XTP_RESIZE bottom) | CXTPResize |
SetResize(UINT nID, const XTP_RESIZERECT &rrcSizing) | CXTPResize |
SetResize(UINT nID, HWND hWnd, const XTP_RESIZERECT &rrcSizing) | CXTPResize |
SetResize(UINT nID, HWND hWnd, const XTP_RESIZEPOINT &rpTopLeft, const XTP_RESIZEPOINT &rpBottomRight) | CXTPResize |
SetResize(UINT nID, const XTP_RESIZEPOINT &rpTopLeft, const XTP_RESIZEPOINT &rpBottomRight) | CXTPResize |
SetResize(CWnd *pWnd, const CXTPResizeRect &rrcSizing, CRect rcWindow) | CXTPResize | protected
Size() | CXTPResize | protectedvirtual
UpdateControlRect(CWnd *pWnd) | CXTPResize | protected
UpdatePage(void) | CXTPPropertyPage | virtual
~CXTPPropertyPage() | CXTPPropertyPage |
~CXTPResize() | CXTPResize | virtual
~CXTPRibbonCustomizePage() | CXTPRibbonCustomizePage | virtual


Toolkit Pro: Member List

CXTPCaptionButtonThemeOfficeXP Member List

This is the complete list of members for CXTPCaptionButtonThemeOfficeXP, including all inherited members.

CXTPButtonTheme() | CXTPButtonTheme |
CXTPButtonThemeOfficeXP() | CXTPButtonThemeOfficeXP |
CXTPButtonThemeUltraFlat() | CXTPButtonThemeUltraFlat |
CXTPCaptionButtonThemeOfficeXP() | CXTPCaptionButtonThemeOfficeXP |
CXTPCmdTarget() | CXTPCmdTarget |
CXTPControlTheme() | CXTPControlTheme |
DrawButton(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
DrawButtonBackground(CDC *pDC, CXTPButton *pButton) | CXTPCaptionButtonThemeOfficeXP | protectedvirtual
DrawButtonText(CDC *pDC, CXTPButton *pButton) | CXTPCaptionButtonThemeOfficeXP | protectedvirtual
DrawButtonVisualStyleBackground(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
DrawCheckBoxMark(CDC *pDC, CXTPButton *pButton) | CXTPButtonThemeUltraFlat | virtual
DrawFocusRect(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
DrawGroupBox(CDC *pDC, CXTPButton *pButton) | CXTPButtonThemeUltraFlat | virtual
DrawPushButtonDropDown(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
DrawPushButtonIcon(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
DrawPushButtonText(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
DrawRadioButtonMark(CDC *pDC, CXTPButton *pButton) | CXTPButtonThemeUltraFlat | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetTextColor(CXTPButton *pButton) | CXTPCaptionButtonThemeOfficeXP | protectedvirtual
GetThemeStyle() const | CXTPControlTheme |
m_crBack | CXTPButtonTheme |
m_crBackChecked | CXTPButtonThemeUltraFlat |
m_crBackHilite | CXTPButtonThemeUltraFlat |
m_crBackPushed | CXTPButtonThemeUltraFlat |
m_crBorder3DHilite | CXTPButtonTheme |
m_crBorder3DShadow | CXTPButtonTheme |
m_crBorderHilite | CXTPButtonTheme |
m_crBorderPushed | CXTPButtonThemeUltraFlat |
m_crBorderShadow | CXTPButtonTheme |
m_crCheckMark | CXTPButtonThemeUltraFlat |
m_crText | CXTPButtonTheme |
m_crTextCheck | CXTPButtonTheme |
m_crTextDisabled | CXTPButtonTheme |
m_crTextHilite | CXTPButtonThemeUltraFlat |
m_crTextPushed | CXTPButtonThemeUltraFlat |
m_nTheme | CXTPControlTheme | protected
RefreshMetrics(CXTPButton *pButton) | CXTPButtonThemeOfficeXP | virtual
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static
~CXTPButtonTheme() | CXTPButtonTheme | virtual


Toolkit Pro: XTPScrollBar.h Source File

  • Source
  • Controls
  • Scroll
XTPScrollBar.h
Go to the documentation of this file.
1
23#if !defined(__XTPSCROLLBAR_H__)
24# define __XTPSCROLLBAR_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
43class _XTP_EXT_CLASS CXTPScrollBar : public CXTPScrollBarCtrl
44{
46 DECLARE_DYNAMIC(CXTPScrollBar)
48public:
53 CXTPScrollBar();
54
59 virtual ~CXTPScrollBar();
60
61public:
78 void SetTheme(XTPControlTheme nTheme);
79
99 BOOL GetUseVisualStyle() const;
100
120 void SetUseVisualStyle(BOOL bUseVisualStyle = TRUE);
121
122public:
124 void SetCommandBars(void*);
125
126 DECLARE_MESSAGE_MAP()
127 afx_msg LRESULT OnSetTheme(WPARAM wParam, LPARAM lParam);
130protected:
131 XTPControlTheme m_nTheme;
132 BOOL m_bUseVisualStyle;
133};
135AFX_INLINE BOOL CXTPScrollBar::GetUseVisualStyle() const
136{
137 return m_bUseVisualStyle;
138}
140# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
142#endif // !defined(__XTPSCROLLBAR_H__)
XTPControlTheme
XTPControlTheme
Enumeration used to determine the active theme style.
Definition XTPControlTheme.h:43
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPScrollBarCtrl
Scrollbar control.
Definition XTPScrollBarCtrl.h:48
CXTPScrollBar
Scrollbar control.
Definition XTPScrollBar.h:44
CXTPScrollBar::SetUseVisualStyle
void SetUseVisualStyle(BOOL bUseVisualStyle=TRUE)
Enables Windows XP visual styles for the control.
CXTPScrollBar::~CXTPScrollBar
virtual ~CXTPScrollBar()
Destroys a CXTPScrollBar object, handles cleanup and deallocation.
CXTPScrollBar::SetTheme
void SetTheme(XTPControlTheme nTheme)
Call this member to switch the visual theme of the control.
CXTPScrollBar::CXTPScrollBar
CXTPScrollBar()
Constructs a CXTPScrollBar object.
CXTPScrollBar::GetUseVisualStyle
BOOL GetUseVisualStyle() const
Determines if the control is drawn using visual styles/SkinFramework, if supported.


Toolkit Pro: XTPStatusBar.h Source File

  • Source
  • CommandBars
  • StatusBar
XTPStatusBar.h
Go to the documentation of this file.
1
23#if !defined(__XTPSTATUSBAR_H__)
24# define __XTPSTATUSBAR_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPCommandBars;
34class CXTPPaintManager;
35class CXTPStatusBar;
36class CXTPStatusBarPane;
37class CXTPStatusBarPaintManager;
38class CXTPImageManagerIcon;
39class CXTPImageManager;
40class CXTPToolTipContext;
41class CXTPPopupBar;
42class CXTPPropExchange;
43
44class CXTPMarkupUIElement;
45class CXTPMarkupContext;
46
51class _XTP_EXT_CLASS CXTPStatusBar : public CControlBar
52{
54 DECLARE_DYNAMIC(CXTPStatusBar)
57private:
58 class CStatusCmdUI;
59 class CControlCustomization;
60
61public:
66 CXTPStatusBar();
67
72 virtual ~CXTPStatusBar();
73
74public:
87 BOOL Create(CWnd* pParentWnd,
88 DWORD dwStyle = WS_CHILD | WS_VISIBLE | CBRS_BOTTOM | WS_CLIPCHILDREN
89 | WS_CLIPSIBLINGS,
90 UINT nID = AFX_IDW_STATUS_BAR);
91
92public:
103 BOOL SetIndicators(const UINT* lpIDArray, int nIDCount);
104
105 CXTPCommandBars* GetCommandBars() const;
106
112 void SetCommandBars(CXTPCommandBars* pCommandBars);
113
120 CXTPPaintManager* GetPaintManager() const;
121
128 CXTPStatusBarPaintManager* GetStatusBarPaintManager() const;
129
130public:
131 BOOL IsAllCaps() const;
132
133 void SetAllCaps(BOOL bAllCaps);
134
140 void PositionControls();
141
151 BOOL AddControl(CWnd* pWnd, UINT nID, BOOL bAutoDelete = TRUE);
152
159 void SetPaneWidth(int nIndex, int cxText);
160
169 CXTPStatusBarPane* AddIndicator(UINT nID, int nIndex = -1);
170
180 CXTPStatusBarPane* AddIndicator(CXTPStatusBarPane* pPane, UINT nID, int nIndex = -1);
181
189 BOOL RemoveIndicator(UINT nID);
190
198 int GetPaneCount() const;
199
206 int GetVisiblePaneCount() const;
207
215 CXTPStatusBarPane* GetPane(int nIndex) const;
216
224 CXTPStatusBarPane* FindPane(UINT nID) const;
225
230 void RemoveAll();
231
239 BOOL RemoveAt(int nIndex);
240
247 CXTPImageManager* GetImageManager() const;
248
258 CXTPStatusBarPane* HitTest(CPoint pt, CRect* lpRect = NULL) const;
259
260public:
266 void EnableCustomization(BOOL bEnable = TRUE);
267
275 void LoadState(LPCTSTR lpszProfileName);
276
284 void SaveState(LPCTSTR lpszProfileName);
285
291 virtual void DoPropExchange(CXTPPropExchange* pPX);
292
293public:
299 void SetDrawDisabledText(BOOL bDraw);
300
307 BOOL GetDrawDisabledText() const;
308
315 CXTPToolTipContext* GetToolTipContext() const;
316
317public:
325 virtual void DrawPaneEntry(CDC* pDC, int nIndex, CRect rcItem);
326
327public:
340 BOOL CreateEx(CWnd* pParentWnd, DWORD dwCtrlStyle = 0,
341 DWORD dwStyle = WS_CHILD | WS_VISIBLE | CBRS_BOTTOM,
342 UINT nID = AFX_IDW_STATUS_BAR);
343
353 int CommandToIndex(UINT nIDFind) const;
354
364 UINT GetItemID(int nIndex) const;
365
377 void GetItemRect(int nIndex, LPRECT lpRect) const;
378
389 CString GetPaneText(int nIndex) const;
390
401 void GetPaneText(int nIndex, CString& rString) const;
402
413 BOOL SetPaneText(int nIndex, LPCTSTR lpszNewText);
414
426 void GetPaneInfo(int nIndex, UINT& nID, UINT& nStyle, int& cxWidth) const;
427
438 void SetPaneInfo(int nIndex, UINT nID, UINT nStyle, int cxWidth);
439
450 UINT GetPaneStyle(int nIndex) const;
451
461 void SetPaneStyle(int nIndex, UINT nStyle);
462
469 CStatusBarCtrl& GetStatusBarCtrl() const;
470
477 void SetFont(CFont* pFont, BOOL bRedraw = TRUE);
478
485 CFont* GetFont();
486
498 void SetRibbonDividerIndex(int nIndex);
499
506 int GetRibbonDividerIndex() const;
507
514 void EnableMarkup(BOOL bEnableMarkup = TRUE);
515
522 CXTPMarkupContext* GetMarkupContext() const;
523
528 virtual void RecalcLayout();
529
531 // Obsolete
532 void UpdateAllPanes(BOOL bUpdateRects, BOOL bUpdateText);
533
534# if _MSC_VER > 1100
535 void SetBorders(LPCRECT lpRect);
536 void SetBorders(int cxLeft = 0, int cyTop = 0, int cxRight = 0, int cyBottom = 0);
537# endif
540protected:
547 virtual void DrawStretch(CDC* pDC, CRect& rcClient);
548
549protected:
551 virtual CSize CalcFixedLayout(BOOL bStretch, BOOL bHorz);
552 BOOL PreCreateWindow(CREATESTRUCT& cs);
553 void CalcInsideRect(CRect& rect, BOOL bHorz) const;
554 virtual void OnBarStyleChange(DWORD dwOldStyle, DWORD dwNewStyle);
555
556# ifdef _DEBUG
557 virtual void AssertValid() const;
558 virtual void Dump(CDumpContext& dc) const;
559 void EnableDocking(DWORD dwDockStyle);
560# endif
561
562public:
563 virtual void OnPaneClick(CXTPStatusBarPane* pPane);
564 virtual void OnSwitchPaneClick(CXTPStatusBarPane* pPane, long Id);
565
566 virtual CXTPPopupBar* GetStatusBarPopup();
567
570protected:
572 DECLARE_MESSAGE_MAP()
573
574 virtual void OnUpdateCmdUI(CFrameWnd* pTarget, BOOL bDisableIfNoHndler);
575 INT_PTR OnToolHitTest(CPoint point, TOOLINFO* pTI) const;
576 virtual BOOL OnWndMsg(UINT message, WPARAM wParam, LPARAM lParam, LRESULT* pResult);
577
578 //{{AFX_MSG(CXTPStatusBar)
579public:
580 afx_msg void OnPaint();
581 afx_msg void OnDraw(CDC* pDC);
582 afx_msg LRESULT OnPrintClient(WPARAM wParam, LPARAM /*lParam*/);
583 afx_msg BOOL OnEraseBkgnd(CDC* pDC);
584 afx_msg void OnSize(UINT nType, int cx, int cy);
585 afx_msg int OnCreate(LPCREATESTRUCT lpcs);
586 afx_msg LRESULT OnIdleUpdateCmdUI(WPARAM wParam, LPARAM lParam);
587
588protected:
589 afx_msg LRESULT OnNcHitTest(CPoint);
590 afx_msg void OnNcCalcSize(BOOL, NCCALCSIZE_PARAMS*);
591 afx_msg void OnNcPaint();
592 afx_msg void OnWindowPosChanging(LPWINDOWPOS);
593 afx_msg LRESULT OnSetText(WPARAM wParam, LPARAM lParam);
594 afx_msg LRESULT OnGetText(WPARAM wParam, LPARAM lParam);
595 afx_msg LRESULT OnGetTextLength(WPARAM wParam, LPARAM lParam);
596 afx_msg LRESULT OnSetMinHeight(WPARAM wParam, LPARAM lParam);
597 afx_msg void OnWindowPosChanged(WINDOWPOS* lpwndpos);
598 afx_msg void OnMouseMove(UINT nFlags, CPoint point);
599 afx_msg void HandleMouseMove(CPoint point);
600 afx_msg void OnMouseLeave();
601 afx_msg void OnLButtonDown(UINT nFlags, CPoint pt);
602 afx_msg void OnLButtonDblClk(UINT nFlags, CPoint point);
603 afx_msg void OnRButtonUp(UINT nFlags, CPoint point);
604 afx_msg void OnSysCommand(UINT nID, LPARAM lParam);
605 afx_msg void OnUpdateKeyIndicator(CCmdUI* pCmdUI);
606 //}}AFX_MSG
609private:
610 BOOL IsWin4();
611
612private:
614 DISABLE_WNDCREATE()
615 DISABLE_WNDCREATEEX()
617# ifdef _XTP_COMMANDBARS_ACTIVEX
620 DECLARE_ENUM_VARIANT(CXTPStatusBar);
621 long OleGetItemCount();
622 LPDISPATCH OleGetItem(int nItem);
623
624public:
625 CString m_strIdleText;
626
627 // Implementation
628protected:
629 void OnFinalRelease();
630
631 DECLARE_DISPATCH_MAP()
632 DECLARE_INTERFACE_MAP()
633 XTP_DECLARE_CMDTARGETPROVIDER_INTERFACE()
634
635 DECLARE_OLETYPELIB_EX(CXTPStatusBar);
636 DECLARE_CONNECTION_EX(CXTPStatusBar)
637
638 LPFONTDISP OleGetFont();
639 void OleSetFont(LPFONTDISP pFontDisp);
640 afx_msg LPDISPATCH OleHitTest(OLE_XPOS_PIXELS x, OLE_YPOS_PIXELS y);
641 afx_msg long OleGetMinHeight();
642 afx_msg void OleSetMinHeight(int nMinHeight);
643 afx_msg BOOL OleGetVisible();
644 afx_msg void OleSetVisible(BOOL bNewValue);
645 afx_msg void OleOnIdleTextChanged();
646 afx_msg LPDISPATCH OleAddPane(long nID);
647 afx_msg LPDISPATCH OleAddSwitchPane(long nID);
648 afx_msg LPDISPATCH OleAddProgressPane(long nID);
649 afx_msg LPDISPATCH OleAddSliderPane(long nID);
650 afx_msg LPDISPATCH OleGetToolTipContext();
651 afx_msg LPDISPATCH OleFindPane(long nID);
652 afx_msg LPDISPATCH OleInsertPane(int nIndex, int nID);
653 afx_msg void OleSetPaneText(long nIndex, LPCTSTR strText);
654 afx_msg void OleSetPaneWidth(long nIndex, long nWidth);
655 afx_msg void OleSetPaneStyle(long nIndex, long nStyle);
656
657 afx_msg void OleSetShowSizeGripper(BOOL bGripper);
658 afx_msg BOOL OleGetShowSizeGripper();
659
660 afx_msg void OleSetEnableMarkup(BOOL bEnableMarkup);
661 afx_msg BOOL OleGetEnableMarkup();
662 afx_msg OLE_HANDLE OleGetHwnd();
663
664 afx_msg void OleSetAllCaps(BOOL bAllCaps);
665 afx_msg BOOL OleIsAllCaps();
666
667public:
668 void FireMouseDown(short nButton, short nShiftState, OLE_XPOS_PIXELS x, OLE_YPOS_PIXELS y)
669 {
670 FireEvent(DISPID_MOUSEDOWN, EVENT_PARAM(VTS_I2 VTS_I2 VTS_XPOS_PIXELS VTS_YPOS_PIXELS),
671 nButton, nShiftState, x, y);
672 }
673 void FireMouseUp(short nButton, short nShiftState, OLE_XPOS_PIXELS x, OLE_YPOS_PIXELS y)
674 {
675 FireEvent(DISPID_MOUSEUP, EVENT_PARAM(VTS_I2 VTS_I2 VTS_XPOS_PIXELS VTS_YPOS_PIXELS),
676 nButton, nShiftState, x, y);
677 }
678 void FirePaneDblClick(LPDISPATCH lpDispatch)
679 {
680 FireEvent(1, EVENT_PARAM(VTS_DISPATCH), lpDispatch);
681 }
682 void FirePaneClick(LPDISPATCH lpDispatch)
683 {
684 FireEvent(2, EVENT_PARAM(VTS_DISPATCH), lpDispatch);
685 }
686 void FireSwitchPaneClick(LPDISPATCH lpDispatch, long Id)
687 {
688 FireEvent(3, EVENT_PARAM(VTS_DISPATCH VTS_I4), lpDispatch, Id);
689 }
690 void FireSliderPaneClick(LPDISPATCH lpDispatch, long Command, long Pos)
691 {
692 FireEvent(4, EVENT_PARAM(VTS_DISPATCH VTS_I4 VTS_I4), lpDispatch, Command, Pos);
693 }
694
696# endif
697
698protected:
699 CArray<CXTPStatusBarPane*, CXTPStatusBarPane*> m_arrPanes;
700 int m_nMinHeight;
702 CXTPFont m_xtpFontStatus;
703 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CFont, m_fontStatus, m_xtpFontStatus,
704 GetStatusFontHandle);
705
706 BOOL m_bShowSizeGripper;
707 BOOL m_bDrawDisabledText;
708 BOOL m_bAllCaps;
709
710 CXTPStatusBarPane* m_pHighlightedPane;
711 int m_nRibbonDividerIndex;
712 CXTPMarkupContext* m_pMarkupContext;
714 int m_cxPaneSpacing;
715 int m_bCustomizable;
716private:
717 CXTPCommandBars* m_pCommandBars;
718 CXTPToolTipContext* m_pToolTipContext;
720 friend class CXTPStatusBarPane;
721};
722
723AFX_INLINE BOOL CXTPStatusBar::IsAllCaps() const
724{
725 return m_bAllCaps;
726}
727
728AFX_INLINE void CXTPStatusBar::SetAllCaps(BOOL bAllCaps)
729{
730 m_bAllCaps = bAllCaps;
731}
732
733AFX_INLINE void CXTPStatusBar::SetRibbonDividerIndex(int nIndex)
734{
735 m_nRibbonDividerIndex = nIndex;
736}
737
738AFX_INLINE int CXTPStatusBar::GetRibbonDividerIndex() const
739{
740 return m_nRibbonDividerIndex;
741}
742
743AFX_INLINE CXTPCommandBars* CXTPStatusBar::GetCommandBars() const
744{
745 return m_pCommandBars;
746}
747
748AFX_INLINE void CXTPStatusBar::SetCommandBars(CXTPCommandBars* pCommandBars)
749{
750 m_pCommandBars = pCommandBars;
751}
752
753AFX_INLINE int CXTPStatusBar::GetPaneCount() const
754{
755 return (int)m_arrPanes.GetSize();
756}
757AFX_INLINE CStatusBarCtrl& CXTPStatusBar::GetStatusBarCtrl() const
758{
759 return *(CStatusBarCtrl*)this;
760}
761
762# if _MSC_VER > 1100
763AFX_INLINE void CXTPStatusBar::SetBorders(int cxLeft, int cyTop, int cxRight, int cyBottom)
764{
765 _ASSERTE(cyTop >= 2);
766 CControlBar::SetBorders(cxLeft, cyTop, cxRight, cyBottom);
767}
768AFX_INLINE void CXTPStatusBar::SetBorders(LPCRECT lpRect)
769{
770 SetBorders(lpRect->left, lpRect->top, lpRect->right, lpRect->bottom);
771}
772# endif
773
774# ifdef _DEBUG
775// status bars do not support docking
776AFX_INLINE void CXTPStatusBar::EnableDocking(DWORD)
777{
778 _ASSERTE(FALSE);
779}
780# endif
781
782AFX_INLINE void CXTPStatusBar::SetDrawDisabledText(BOOL bDraw)
783{
784 m_bDrawDisabledText = bDraw;
785}
786AFX_INLINE BOOL CXTPStatusBar::GetDrawDisabledText() const
787{
788 return m_bDrawDisabledText;
789}
790AFX_INLINE CXTPToolTipContext* CXTPStatusBar::GetToolTipContext() const
791{
792 return m_pToolTipContext;
793}
794AFX_INLINE CXTPMarkupContext* CXTPStatusBar::GetMarkupContext() const
795{
796 return m_pMarkupContext;
797}
799# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
800#endif //#if !defined(__XTPSTATUSBAR_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTP_DECLARE_CMDTARGETPROVIDER_INTERFACE
#define XTP_DECLARE_CMDTARGETPROVIDER_INTERFACE()
When deriving from CXTPCmdTarget is not possible this macro can be used in addition to standard DECLA...
Definition XTPFramework.h:89
CXTPCommandBars
CXTPCommandBars is a standalone class.
Definition XTPCommandBars.h:165
CXTPFont
Provides a convenient object oriented interface for HFONT GDI object and uses GDI handle caching.
Definition XTPGdiObjects.h:414
CXTPImageManager
CXTPImageManager is a standalone class.
Definition XTPImageManager.h:1898
CXTPImageManagerIcon
Icons holder class.
Definition XTPImageManager.h:622
CXTPMarkupContext
CXTPMarkupContext is a standalone class used to provide common settings for Markup objects.
Definition XTPMarkupContext.h:128
CXTPMarkupUIElement
Base class for XML Markup core level implementations.
Definition XTPMarkupUIElement.h:43
CXTPPaintManager
Paint manager of the command bars.
Definition XTPPaintManager.h:199
CXTPPopupBar
CXTPPopupBar is a CXTPCommandBar derived class.
Definition XTPPopupBar.h:42
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72
CXTPStatusBar
CXTPStatusBar is a CControlBar derived class.
Definition XTPStatusBar.h:52
CXTPStatusBar::SetCommandBars
void SetCommandBars(CXTPCommandBars *pCommandBars)
Call this member to set the command bar's object.
Definition XTPStatusBar.h:748
CXTPStatusBar::m_nRibbonDividerIndex
int m_nRibbonDividerIndex
Position of dark part for Ribbon Theme.
Definition XTPStatusBar.h:711
CXTPStatusBar::DoPropExchange
virtual void DoPropExchange(CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
CXTPStatusBar::PositionControls
void PositionControls()
This member function is called by the status bar to reposition pane item controls.
CXTPStatusBar::~CXTPStatusBar
virtual ~CXTPStatusBar()
Destroys a CXTPStatusBar object, handles cleanup and deallocation.
CXTPStatusBar::DrawStretch
virtual void DrawStretch(CDC *pDC, CRect &rcClient)
Draws the stretch gripper of the status bar.
CXTPStatusBar::GetPaneText
CString GetPaneText(int nIndex) const
Call this member function to retrieve the text that appears in a status bar pane.
CXTPStatusBar::AddIndicator
CXTPStatusBarPane * AddIndicator(CXTPStatusBarPane *pPane, UINT nID, int nIndex=-1)
Call this member function to add an indicator pane to the status bar.
CXTPStatusBar::GetPaintManager
CXTPPaintManager * GetPaintManager() const
Retrieves the paint manager.
CXTPStatusBar::SetPaneWidth
void SetPaneWidth(int nIndex, int cxText)
Call this member function to set the width for an indicator pane.
CXTPStatusBar::LoadState
void LoadState(LPCTSTR lpszProfileName)
Retrieves state information from the registry or .INI file.
CXTPStatusBar::RecalcLayout
virtual void RecalcLayout()
Call this method to reposition all panes.
CXTPStatusBar::m_bCustomizable
int m_bCustomizable
TRUE to allow customize status bar.
Definition XTPStatusBar.h:715
CXTPStatusBar::GetItemID
UINT GetItemID(int nIndex) const
Returns the ID of the indicator specified by nIndex.
CXTPStatusBar::SaveState
void SaveState(LPCTSTR lpszProfileName)
Saves state information to the registry or .INI file.
CXTPStatusBar::SetDrawDisabledText
void SetDrawDisabledText(BOOL bDraw)
Call this member function to set the paint manager to draw disabled text.
Definition XTPStatusBar.h:782
CXTPStatusBar::GetStatusBarCtrl
CStatusBarCtrl & GetStatusBarCtrl() const
This member function allows direct access to the underlying common control.
Definition XTPStatusBar.h:757
CXTPStatusBar::EnableMarkup
void EnableMarkup(BOOL bEnableMarkup=TRUE)
Allows the use of a XAML snippet to be used for the text of panes in the status Bar.
CXTPStatusBar::m_xtpFontStatus
CXTPFont m_xtpFontStatus
Font of status bar.
Definition XTPStatusBar.h:702
CXTPStatusBar::CreateEx
BOOL CreateEx(CWnd *pParentWnd, DWORD dwCtrlStyle=0, DWORD dwStyle=WS_CHILD|WS_VISIBLE|CBRS_BOTTOM, UINT nID=AFX_IDW_STATUS_BAR)
Call this function to create a status bar.
CXTPStatusBar::m_bDrawDisabledText
BOOL m_bDrawDisabledText
TRUE to draw disabled text.
Definition XTPStatusBar.h:707
CXTPStatusBar::RemoveAt
BOOL RemoveAt(int nIndex)
Call this member function to remove an indicator pane from the status bar.
CXTPStatusBar::FindPane
CXTPStatusBarPane * FindPane(UINT nID) const
Call this member function to find the pane for the given identifier.
CXTPStatusBar::m_arrPanes
CArray< CXTPStatusBarPane *, CXTPStatusBarPane * > m_arrPanes
Array of panes.
Definition XTPStatusBar.h:699
CXTPStatusBar::GetItemRect
void GetItemRect(int nIndex, LPRECT lpRect) const
Copies the coordinates of the indicator specified by nIndex into the structure pointed to by lpRect.
CXTPStatusBar::m_cxPaneSpacing
int m_cxPaneSpacing
Gap between panes.
Definition XTPStatusBar.h:714
CXTPStatusBar::DrawPaneEntry
virtual void DrawPaneEntry(CDC *pDC, int nIndex, CRect rcItem)
This method is called to draw a single pane of the status bar.
CXTPStatusBar::SetPaneInfo
void SetPaneInfo(int nIndex, UINT nID, UINT nStyle, int cxWidth)
Sets the specified indicator pane to a new ID, style, and width.
CXTPStatusBar::GetPane
CXTPStatusBarPane * GetPane(int nIndex) const
Call this member function to get the pane information for the given index.
CXTPStatusBar::m_nMinHeight
int m_nMinHeight
Minimum client height.
Definition XTPStatusBar.h:700
CXTPStatusBar::GetVisiblePaneCount
int GetVisiblePaneCount() const
Calculates the total number of visible panes.
CXTPStatusBar::GetMarkupContext
CXTPMarkupContext * GetMarkupContext() const
Retrieves a pointer to the markup context.
Definition XTPStatusBar.h:794
CXTPStatusBar::CommandToIndex
int CommandToIndex(UINT nIDFind) const
Gets the indicator index for a given ID.
CXTPStatusBar::GetRibbonDividerIndex
int GetRibbonDividerIndex() const
Gets the position of the ribbon divider index.
Definition XTPStatusBar.h:738
CXTPStatusBar::m_pMarkupContext
CXTPMarkupContext * m_pMarkupContext
Markup Context.
Definition XTPStatusBar.h:712
CXTPStatusBar::m_bShowSizeGripper
BOOL m_bShowSizeGripper
TRUE to show size gripper.
Definition XTPStatusBar.h:706
CXTPStatusBar::GetDrawDisabledText
BOOL GetDrawDisabledText() const
Call this member function to check if the paint manager will draw disabled text.
Definition XTPStatusBar.h:786
CXTPStatusBar::RemoveAll
void RemoveAll()
Call this member function to remove all indicators.
CXTPStatusBar::GetPaneText
void GetPaneText(int nIndex, CString &rString) const
Call this member function to retrieve the text that appears in a status bar pane.
CXTPStatusBar::SetPaneStyle
void SetPaneStyle(int nIndex, UINT nStyle)
Call this member function to set the style of a status bar's pane.
CXTPStatusBar::SetPaneText
BOOL SetPaneText(int nIndex, LPCTSTR lpszNewText)
Sets the pane text to the string pointed to by lpszNewText.
CXTPStatusBar::HitTest
CXTPStatusBarPane * HitTest(CPoint pt, CRect *lpRect=NULL) const
Determines which pane, if any, is at a specified screen position.
CXTPStatusBar::GetPaneInfo
void GetPaneInfo(int nIndex, UINT &nID, UINT &nStyle, int &cxWidth) const
Sets nID, nStyle, and cxWidth to the ID, style, and width of the indicator pane at the location speci...
CXTPStatusBar::AddIndicator
CXTPStatusBarPane * AddIndicator(UINT nID, int nIndex=-1)
Call this member function to add an indicator pane to the status bar.
CXTPStatusBar::SetRibbonDividerIndex
void SetRibbonDividerIndex(int nIndex)
Sets the position of the ribbon divider index.
Definition XTPStatusBar.h:733
CXTPStatusBar::GetImageManager
CXTPImageManager * GetImageManager() const
Call this member to retrieve the image manager of the image manager.
CXTPStatusBar::GetPaneStyle
UINT GetPaneStyle(int nIndex) const
Call this member function to retrieve the style of a status bar's pane.
CXTPStatusBar::GetFont
CFont * GetFont()
Call this method to get the font for the status bar.
CXTPStatusBar::m_pHighlightedPane
CXTPStatusBarPane * m_pHighlightedPane
Pane currently highlighted.
Definition XTPStatusBar.h:710
CXTPStatusBar::GetStatusBarPaintManager
CXTPStatusBarPaintManager * GetStatusBarPaintManager() const
Retrieves the status bar paint manager.
CXTPStatusBar::GetToolTipContext
CXTPToolTipContext * GetToolTipContext() const
Call this method to get a pointer to the tooltip context.
Definition XTPStatusBar.h:790
CXTPStatusBar::SetIndicators
BOOL SetIndicators(const UINT *lpIDArray, int nIDCount)
Sets each indicator's ID to the value specified by the corresponding element of the array lpIDArray,...
CXTPStatusBar::AddControl
BOOL AddControl(CWnd *pWnd, UINT nID, BOOL bAutoDelete=TRUE)
Call this member function to add a control to an indicator pane.
CXTPStatusBar::SetFont
void SetFont(CFont *pFont, BOOL bRedraw=TRUE)
Call this method to set the font for the status bar.
CXTPStatusBar::EnableCustomization
void EnableCustomization(BOOL bEnable=TRUE)
Call this method to enable/disable customization of the status bar.
CXTPStatusBar::Create
BOOL Create(CWnd *pParentWnd, DWORD dwStyle=WS_CHILD|WS_VISIBLE|CBRS_BOTTOM|WS_CLIPCHILDREN|WS_CLIPSIBLINGS, UINT nID=AFX_IDW_STATUS_BAR)
Creates a status bar (a child window) and associates it with the CStatusBar object.
CXTPStatusBar::GetPaneCount
int GetPaneCount() const
Call this member function to return the number of panes that are created for the status bar.
Definition XTPStatusBar.h:753
CXTPStatusBar::CXTPStatusBar
CXTPStatusBar()
Constructs a CXTPStatusBar object.
CXTPStatusBar::RemoveIndicator
BOOL RemoveIndicator(UINT nID)
Call this member function to remove an indicator pane from the status bar.
CXTPStatusBarPane
CXTPStatusBarPane is a CXTPCmdTarget derived class.
Definition XTPStatusBarPane.h:39
CXTPToolTipContext
CXTPToolTipContext is a CXTPCmdTarget derived class.
Definition XTPToolTipContext.h:291


Toolkit Pro: Member List

CXTPChartRangeAreaSeriesLabelView Member List

This is the complete list of members for CXTPChartRangeAreaSeriesLabelView, including all inherited members.

AddChildView(CXTPChartElementView *pChildView) | CXTPChartElementView |
CreateDeviceCommand(CXTPChartDeviceContext *pDC) | CXTPChartRangeAreaSeriesLabelView | protectedvirtual
CXTPChartPointSeriesLabelView::CreateDeviceCommand(CXTPChartDeviceContext *pDC, CXTPChartPointF ptCenterPoint) | CXTPChartDiagram2DSeriesLabelView | virtual
CXTPChartPointSeriesLabelView::CreateDeviceCommand(CXTPChartDeviceContext *pDC, CXTPChartPointF ptCenterPoint, const CXTPChartString &text) | CXTPChartDiagram2DSeriesLabelView | virtual
CXTPChartPointSeriesLabelView::CreateDeviceCommand(CXTPChartDeviceContext *pDC, const CXTPChartPointF &ptAnchorPoint, double dAnchorAngle, const CXTPChartString &text) | CXTPChartDiagram2DSeriesLabelView | virtual
CXTPChartDiagram2DSeriesLabelView(CXTPChartSeriesLabel *pLabel, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView) | CXTPChartDiagram2DSeriesLabelView |
CXTPChartElementView(CXTPChartElementView *pParentView) | CXTPChartElementView |
CXTPChartElementView(CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartElementView |
CXTPChartElementView(CXTPChartContainer *pContainer) | CXTPChartElementView |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartPointSeriesLabelView(CXTPChartSeriesLabel *pLabel, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView) | CXTPChartPointSeriesLabelView |
CXTPChartRangeAreaSeriesLabelView(CXTPChartSeriesLabel *pLabel, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView) | CXTPChartRangeAreaSeriesLabelView |
GetAnchorPoint() const | CXTPChartRangeAreaSeriesLabelView | virtual
GetAt(int nIndex) const | CXTPChartElementView |
GetBounds() const | CXTPChartElementView |
GetBounds(BOOL bIncludingChildren) const | CXTPChartElementView |
GetChildren() | CXTPChartElementView |
GetCount() const | CXTPChartElementView |
GetParentView() const | CXTPChartElementView |
Is3D() const | CXTPChartObject |
m_arrChildren | CXTPChartElementView | protected
m_pContainer | CXTPChartElementView | protected
m_pParentView | CXTPChartElementView | protected
m_rcBounds | CXTPChartElementView | protected
~CXTPChartElementView() | CXTPChartElementView | protectedvirtual


Toolkit Pro: XTPChart3dPie.h Source File

  • Source
  • Chart
  • Types
  • 3D
XTPChart3dPie.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHART3DPIE_H__)
24# define __XTPCHART3DPIE_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartDeviceCommand;
34class CXTPChartEllipse;
35
40class _XTP_EXT_CLASS CXTPChart3dPie : public CXTPChartPieBase
41{
42 DECLARE_DYNAMIC(CXTPChart3dPie);
43
44public:
57 CXTPChart3dPie(double dStartAngle, double dFinishAngle, const CXTPChartEllipse& ellipse,
58 int nDepthPercent, int nHolePercent, BOOL bStartGap = FALSE,
59 BOOL bEndGap = FALSE);
60
61public:
75 virtual CXTPChartDeviceCommand* CreatePieDeviceCommand(const CXTPChartColor& color,
76 const CXTPChartColor& color2,
77 const CXTPChartPointF& basePoint);
78
92 virtual CXTPChartDeviceCommand* CreateBoundedPieDeviceCommand(const CXTPChartColor& color,
93 int nThickness,
94 const CXTPChartPointF& basePoint);
95
96private:
97 BOOL m_bStartGap;
98 BOOL m_bEndGap;
99};
101# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
102#endif //#if !defined(__XTPCHART3DPIE_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChart3dPie
This class abstracts a pie chart.
Definition XTPChart3dPie.h:41
CXTPChart3dPie::CreatePieDeviceCommand
virtual CXTPChartDeviceCommand * CreatePieDeviceCommand(const CXTPChartColor &color, const CXTPChartColor &color2, const CXTPChartPointF &basePoint)
This function creates a CXTPChartDeviceCommand object.
CXTPChart3dPie::CXTPChart3dPie
CXTPChart3dPie(double dStartAngle, double dFinishAngle, const CXTPChartEllipse &ellipse, int nDepthPercent, int nHolePercent, BOOL bStartGap=FALSE, BOOL bEndGap=FALSE)
Constructs a CXTPChart3dPie object.
CXTPChart3dPie::CreateBoundedPieDeviceCommand
virtual CXTPChartDeviceCommand * CreateBoundedPieDeviceCommand(const CXTPChartColor &color, int nThickness, const CXTPChartPointF &basePoint)
This function creates a CXTPChartDeviceCommand object.
CXTPChartColor
This class abstracts a color entity.
Definition XTPChartTypes.h:51
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPChartEllipse
This class abstracts an ellipse.
Definition XTPChartPie.h:42
CXTPChartPieBase
This class abstracts a pie chart.
Definition XTPChartPie.h:176
CXTPPoint2T< float >


Toolkit Pro: XTPRibbonBackstageViewThemeNativeWindows10.h Source File

  • Source
  • Ribbon
  • Backstage
XTPRibbonBackstageViewThemeNativeWindows10.h
Go to the documentation of this file.
1
23#if !defined(__XTPRIBBONBACKSTAGEVIEWTHEMENATIVEWINDOWS10_H__)
24# define __XTPRIBBONBACKSTAGEVIEWTHEMENATIVEWINDOWS10_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class _XTP_EXT_CLASS CXTPRibbonBackstageViewThemeNativeWindows10
34 : public CXTPRibbonBackstageViewThemeOffice2013
35{
36public:
37 CXTPRibbonBackstageViewThemeNativeWindows10();
38 ~CXTPRibbonBackstageViewThemeNativeWindows10();
39
45 void SetButtonBackNormalColor(COLORREF clr);
46
52 void SetButtonBackSelectedColor(COLORREF clr);
53
59 void SetButtonBackHighlightedColor(COLORREF clr);
60
66 void SetButtonTextNormalColor(COLORREF clr);
67
73 void SetButtonTextSelectedColor(COLORREF clr);
74
80 void SetButtonTextHighlightedColor(COLORREF clr);
81};
82
83# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
85#endif // !defined(__XTPRIBBONBACKSTAGEVIEWTHEMENATIVEWINDOWS10_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h


Toolkit Pro: Member List

CXTPGridPageSetupDialog Member List

This is the complete list of members for CXTPGridPageSetupDialog, including all inherited members.

CXTPGridPageSetupDialog(CXTPGridViewPrintOptions *pOptions, DWORD dwFlags=PSD_MARGINS|PSD_INWININIINTLMEASURE, CWnd *pParentWnd=NULL) | CXTPGridPageSetupDialog |
m_pOptions | CXTPGridPageSetupDialog | protected
OnInitDialog() | CXTPGridPageSetupDialog | protectedvirtual
OnOK() | CXTPGridPageSetupDialog | protectedvirtual
~CXTPGridPageSetupDialog() | CXTPGridPageSetupDialog | virtual


Toolkit Pro: XTPRibbonBackstageSeparatorPaintManager.h Source File

  • Source
  • Ribbon
  • Backstage
XTPRibbonBackstageSeparatorPaintManager.h
Go to the documentation of this file.
1
23#if !defined(__XTPRIBBONBACKSTAGESEPARATORPAINTMANAGER_H__)
24# define __XTPRIBBONBACKSTAGESEPARATORPAINTMANAGER_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPRibbonBackstageSeparator;
34
35class _XTP_EXT_CLASS CXTPRibbonBackstageSeparatorPaintManager
36{
37public:
38 CXTPRibbonBackstageSeparatorPaintManager();
39 virtual ~CXTPRibbonBackstageSeparatorPaintManager();
40
41 virtual void DrawSeparator(CDC* pDC, CXTPRibbonBackstageSeparator* pSeparator);
42
43 COLORREF GetColorSeparator() const;
44 COLORREF GetColorBack() const;
45
46protected:
47 COLORREF m_clrSeparator;
48 COLORREF m_clrBack;
49};
50
51AFX_INLINE COLORREF CXTPRibbonBackstageSeparatorPaintManager::GetColorSeparator() const
52{
53 return m_clrSeparator;
54}
55
56AFX_INLINE COLORREF CXTPRibbonBackstageSeparatorPaintManager::GetColorBack() const
57{
58 return m_clrBack;
59}
60
61# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
63#endif // !defined(__XTPRIBBONBACKSTAGESEPARATORPAINTMANAGER_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h


Toolkit Pro: XTPTrackBlock.h Source File

  • Source
  • GridControl
  • TrackControl
XTPTrackBlock.h
Go to the documentation of this file.
1
23#if !defined(__XTPTRACKBLOCK_H__)
24# define __XTPTRACKBLOCK_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPTrackControlItem;
34
41class _XTP_EXT_CLASS CXTPTrackBlock : public CXTPCmdTarget
42{
43 DECLARE_SERIAL(CXTPTrackBlock);
44
45public:
50 CXTPTrackBlock();
51
52public:
65 virtual int Draw(CDC* pDC, CRect rc, BOOL bSelected);
66
76 virtual BOOL IsKey() const;
77
87 virtual BOOL IsResizable() const;
88
94 void SetPosition(int nPosition);
95
102 int GetPosition() const;
103
109 void SetLength(int nLength);
110
117 int GetLength() const;
118
124 void SetColor(COLORREF clr);
125
132 CRect GetRect() const;
133
141 BOOL IsLocked() const;
142
150 void SetLocked(BOOL bLocked = TRUE);
151
161 void SetHeightPercent(double dHeightPercent);
162
169 double GetHeightPercent() const;
170
171 void SetHeightFixed(int nHeightPercent);
172 int GetHeightFixed() const;
173
183 void SetVerticalAlignment(int nAlignment);
184
195 int GetVerticalAlignment() const;
196
206 CXTPTrackControlItem* GetItem() const;
207
214 int GetIndex() const;
215
222 void Select(BOOL bSelect = TRUE);
223
230 BOOL IsSelected() const;
231
238 CString GetCaption() const;
239
245 void SetCaption(LPCTSTR lpszCaption);
246
253 virtual CString GetTooltip() const;
254
260 void SetTooltip(LPCTSTR lpszTooltip);
261
267 void SetDescriptionText(LPCTSTR lpszDescriptionText);
268
275 CString GetDescriptionText() const;
276
282 void SetMinLength(int nMinLength);
283
290 int GetMinLength() const;
291
297 void SetMaxLength(int nMaxLength);
298
305 int GetMaxLength() const;
306
307public:
317 void DoPropExchange(CXTPPropExchange* pPX);
318
319public:
324 void Remove();
325
326public:
327 CRect m_rcBlock;
328 CXTPTrackControlItem* m_pItem;
329 int m_nPosition;
330 int m_nLength;
331 BOOL m_bLocked;
332 COLORREF m_clrBlock;
333 CString m_strCaption;
334 double m_dHeightPercent;
335 int m_nHeightFixed;
336 int m_nVerticalAlignment;
338protected:
339 int m_nMRUPosition;
340 CString m_strToolTip;
341 CString m_strDescription;
342 int m_nIndex;
343 int m_nLastDragTime;
344 int m_nMinLength;
345 int m_nMaxLength;
346 BOOL m_bDragging;
348# ifdef _XTP_ACTIVEX
350 DECLARE_DISPATCH_MAP()
351 DECLARE_INTERFACE_MAP()
352 DECLARE_OLETYPELIB_EX(CXTPTrackBlock);
353
354 int OleGetPosition();
355 void OleSetPosition(int nPosition);
356 int OleGetLength();
357 void OleSetLength(int nLength);
358 BOOL OleGetLocked();
359 void OleSetLocked(BOOL bLocked);
360 COLORREF OleGetColor();
361 void OleSetColor(OLE_COLOR clr);
362 BSTR OleGetTooltip();
363 void OleSetTooltip(LPCTSTR lpszTooltip);
364 BSTR OleGetDescriptionText();
365 void OleSetDescriptionText(LPCTSTR lpszDescription);
366 double OleGetHeightPercent();
367 void OleSetHeightPercent(double dHeightPercent);
368 int OleGetHeightFixed();
369 int OleGetVerticalAlignment();
370 void OleSetHeightFixed(int dHeightFixed);
371 void OleSetVerticalAlignment(int nVerticalAlignment);
372 int OleGetMinLength();
373 void OleSetMinLength(int nMinLength);
374 int OleGetMaxLength();
375 void OleSetMaxLength(int nMaxLength);
376 LPDISPATCH OleGetItem();
377 int OleGetIndex();
378 BOOL OleGetIsKey();
379 BSTR OleGetCaption();
380 void OleSetCaption(LPCTSTR lpszCaption);
382# endif
383private:
384 friend class CXTPTrackControlItem;
385 friend class CXTPTrackControl;
386};
387
394class _XTP_EXT_CLASS CXTPTrackKey : public CXTPTrackBlock
395{
396 DECLARE_SERIAL(CXTPTrackKey);
397
398public:
403 CXTPTrackKey();
404
405public:
418 virtual int Draw(CDC* pDC, CRect rc, BOOL bSelected);
419
429 virtual BOOL IsKey() const;
430};
431
437class _XTP_EXT_CLASS CXTPTrackMarker : public CXTPCmdTarget
438{
439 DECLARE_SERIAL(CXTPTrackMarker);
440
441public:
446 CXTPTrackMarker();
447
448public:
454 void SetPosition(int nPosition);
455
462 int GetPosition() const;
463
469 void SetCaption(LPCTSTR lpszCaption);
470
477 CString GetCaption() const;
478
485 CRect GetRect() const;
486
491 void Remove();
492
500 CXTPTrackControl* GetControl() const;
501
502public:
512 void DoPropExchange(CXTPPropExchange* pPX);
513
514protected:
515 CString m_strCaption;
516 int m_nPosition;
517 CRect m_rcMarker;
518 CXTPTrackControl* m_pControl;
520# ifdef _XTP_ACTIVEX
522 DECLARE_DISPATCH_MAP()
523 DECLARE_INTERFACE_MAP()
524 DECLARE_OLETYPELIB_EX(CXTPTrackMarker);
526# endif
527
528private:
529 friend class CXTPTrackPaintManager;
530 friend class CXTPTrackMarkers;
531};
532
538class _XTP_EXT_CLASS CXTPTrackMarkers : public CXTPCmdTarget
539{
540protected:
546 CXTPTrackMarkers(CXTPTrackControl* pControl);
547
552 ~CXTPTrackMarkers();
553
554public:
563 CXTPTrackMarker* Add(int nPosition, LPCTSTR lpszCaption);
564
572 CXTPTrackMarker* Add(CXTPTrackMarker* pMarker);
573
582 CXTPTrackMarker* GetAt(int nIndex) const;
583
589 void RemoveAt(int nIndex);
590
596 void Remove(CXTPTrackMarker* pMarker);
597
602 void RemoveAll();
603
611 int IndexOf(CXTPTrackMarker* pMarker);
612
619 int GetCount() const;
620
630 int HitTest(CPoint pt) const;
631
632public:
642 void DoPropExchange(CXTPPropExchange* pPX);
643
644protected:
645 CXTPTrackControl* m_pControl;
646 CArray<CXTPTrackMarker*, CXTPTrackMarker*> m_arrMarkers;
648# ifdef _XTP_ACTIVEX
650 DECLARE_DISPATCH_MAP()
651 DECLARE_INTERFACE_MAP()
652 DECLARE_OLETYPELIB_EX(CXTPTrackMarkers);
653 DECLARE_ENUM_VARIANT(CXTPTrackMarkers)
654
655 LPDISPATCH OleAdd(int Position, LPCTSTR lpszCaption);
656 LPDISPATCH OleGetItem(long nIndex);
657 int OleGetItemCount();
659# endif
660
661private:
662 friend class CXTPTrackControl;
663};
664
670class _XTP_EXT_CLASS CXTPTrackSelectedBlocks : public CXTPCmdTarget
671{
672public:
677 CXTPTrackSelectedBlocks();
678
685 int GetCount() const;
686
692 void Add(CXTPTrackBlock* pBlock);
693
701 BOOL IsSelected(const CXTPTrackBlock* pBlock) const;
702
710 CXTPTrackBlock* GetAt(int nIndex) const;
711
716 void RemoveAll();
717
723 void RemoveAt(int nIndex);
724
730 void Remove(CXTPTrackBlock* pBlock);
731
732protected:
733# ifdef _XTP_ACTIVEX
735 DECLARE_DISPATCH_MAP()
736 DECLARE_INTERFACE_MAP()
737 DECLARE_OLETYPELIB_EX(CXTPTrackSelectedBlocks);
738 DECLARE_ENUM_VARIANT(CXTPTrackSelectedBlocks)
739
740 LPDISPATCH OleGetItem(long nIndex);
741 int OleGetItemCount();
743# endif
744protected:
745 CArray<CXTPTrackBlock*, CXTPTrackBlock*> m_arrBlocks;
746};
747
748AFX_INLINE BOOL CXTPTrackBlock::IsKey() const
749{
750 return FALSE;
751}
752AFX_INLINE void CXTPTrackBlock::SetColor(COLORREF clr)
753{
754 m_clrBlock = clr;
755}
756AFX_INLINE CRect CXTPTrackBlock::GetRect() const
757{
758 return m_rcBlock;
759}
760AFX_INLINE int CXTPTrackBlock::GetPosition() const
761{
762 return m_nPosition;
763}
764AFX_INLINE int CXTPTrackBlock::GetLength() const
765{
766 return m_nLength;
767}
768AFX_INLINE CString CXTPTrackBlock::GetTooltip() const
769{
770 return m_strToolTip;
771}
772AFX_INLINE void CXTPTrackBlock::SetTooltip(LPCTSTR lpszTooltip)
773{
774 m_strToolTip = lpszTooltip;
775}
776AFX_INLINE CString CXTPTrackBlock::GetCaption() const
777{
778 return m_strCaption;
779}
780AFX_INLINE void CXTPTrackBlock::SetCaption(LPCTSTR lpszCaption)
781{
782 m_strCaption = lpszCaption;
783}
784AFX_INLINE void CXTPTrackBlock::SetDescriptionText(LPCTSTR lpszDescriptionText)
785{
786 m_strDescription = lpszDescriptionText;
787}
788AFX_INLINE CString CXTPTrackBlock::GetDescriptionText() const
789{
790 return m_strDescription;
791}
792AFX_INLINE void CXTPTrackBlock::SetLocked(BOOL bLocked)
793{
794 m_bLocked = bLocked;
795}
796AFX_INLINE void CXTPTrackBlock::SetHeightPercent(double dHeightPercent)
797{
798 m_dHeightPercent = dHeightPercent;
799}
800AFX_INLINE double CXTPTrackBlock::GetHeightPercent() const
801{
802 return m_dHeightPercent;
803}
804AFX_INLINE void CXTPTrackBlock::SetHeightFixed(int nHeightFixed)
805{
806 m_nHeightFixed = nHeightFixed;
807}
808AFX_INLINE int CXTPTrackBlock::GetHeightFixed() const
809{
810 return m_nHeightFixed;
811}
812AFX_INLINE void CXTPTrackBlock::SetVerticalAlignment(int nAlignment)
813{
814 m_nVerticalAlignment = nAlignment;
815}
816AFX_INLINE int CXTPTrackBlock::GetVerticalAlignment() const
817{
818 return m_nVerticalAlignment;
819}
820AFX_INLINE CXTPTrackControlItem* CXTPTrackBlock::GetItem() const
821{
822 return m_pItem;
823}
824AFX_INLINE int CXTPTrackBlock::GetIndex() const
825{
826 return m_nIndex;
827}
828AFX_INLINE BOOL CXTPTrackBlock::IsResizable() const
829{
830 return !IsKey();
831}
832AFX_INLINE void CXTPTrackBlock::SetMinLength(int nMinLength)
833{
834 m_nMinLength = nMinLength;
835}
836AFX_INLINE int CXTPTrackBlock::GetMinLength() const
837{
838 return m_nMinLength;
839}
840AFX_INLINE void CXTPTrackBlock::SetMaxLength(int nMaxLength)
841{
842 m_nMaxLength = nMaxLength;
843}
844AFX_INLINE int CXTPTrackBlock::GetMaxLength() const
845{
846 return m_nMaxLength;
847}
848AFX_INLINE BOOL CXTPTrackKey::IsKey() const
849{
850 return TRUE;
851}
852AFX_INLINE int CXTPTrackMarker::GetPosition() const
853{
854 return m_nPosition;
855}
856AFX_INLINE void CXTPTrackMarker::SetCaption(LPCTSTR lpszCaption)
857{
858 m_strCaption = lpszCaption;
859}
860AFX_INLINE CString CXTPTrackMarker::GetCaption() const
861{
862 return m_strCaption;
863}
864AFX_INLINE CRect CXTPTrackMarker::GetRect() const
865{
866 return m_rcMarker;
867}
868AFX_INLINE CXTPTrackControl* CXTPTrackMarker::GetControl() const
869{
870 return m_pControl;
871}
872
873typedef CArray<CXTPTrackBlock*, CXTPTrackBlock*> CXTPTrackBlockArray;
875# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
876#endif //#if !defined(__XTPTRACKBLOCK_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72
CXTPTrackBlock
This class represents a track control block.
Definition XTPTrackBlock.h:42
CXTPTrackBlock::GetPosition
int GetPosition() const
Gets the position of the block on the track.
Definition XTPTrackBlock.h:760
CXTPTrackBlock::SetHeightPercent
void SetHeightPercent(double dHeightPercent)
Sets the height percentage for the block compared to its track.
Definition XTPTrackBlock.h:796
CXTPTrackBlock::Remove
void Remove()
Removes the block.
CXTPTrackBlock::DoPropExchange
void DoPropExchange(CXTPPropExchange *pPX)
Call this member function to store/load the properties related to the block.
CXTPTrackBlock::SetLength
void SetLength(int nLength)
Sets the length for the block on the track.
CXTPTrackBlock::IsLocked
BOOL IsLocked() const
Gets the locked state of the block (i.e.
CXTPTrackBlock::SetPosition
void SetPosition(int nPosition)
Sets the position for the block on the track.
CXTPTrackBlock::GetItem
CXTPTrackControlItem * GetItem() const
Gets the track control to which the block is associated with.
Definition XTPTrackBlock.h:820
CXTPTrackBlock::IsSelected
BOOL IsSelected() const
Gets the selected state of the block.
CXTPTrackBlock::m_strToolTip
CString m_strToolTip
Tooltip text.
Definition XTPTrackBlock.h:340
CXTPTrackBlock::m_pItem
CXTPTrackControlItem * m_pItem
Pointer to the parent track of the block.
Definition XTPTrackBlock.h:328
CXTPTrackBlock::SetTooltip
void SetTooltip(LPCTSTR lpszTooltip)
Sets the tooltip text for the block.
Definition XTPTrackBlock.h:772
CXTPTrackBlock::GetIndex
int GetIndex() const
Gets the index of the block in its track.
Definition XTPTrackBlock.h:824
CXTPTrackBlock::m_nMaxLength
int m_nMaxLength
Maximum resize length.
Definition XTPTrackBlock.h:345
CXTPTrackBlock::m_dHeightPercent
double m_dHeightPercent
Height percentage of the block compared to its track.
Definition XTPTrackBlock.h:334
CXTPTrackBlock::GetVerticalAlignment
int GetVerticalAlignment() const
Gets the vertical alignment of the block in its track.
Definition XTPTrackBlock.h:816
CXTPTrackBlock::m_nLength
int m_nLength
Length of the block.
Definition XTPTrackBlock.h:330
CXTPTrackBlock::IsKey
virtual BOOL IsKey() const
Determines if the item is a key.
Definition XTPTrackBlock.h:748
CXTPTrackBlock::GetHeightPercent
double GetHeightPercent() const
Gets the height percentage of the block compared to its track.
Definition XTPTrackBlock.h:800
CXTPTrackBlock::m_rcBlock
CRect m_rcBlock
Drawing bounding rectangle of block.
Definition XTPTrackBlock.h:327
CXTPTrackBlock::IsResizable
virtual BOOL IsResizable() const
Determines if the block is resizable.
Definition XTPTrackBlock.h:828
CXTPTrackBlock::SetLocked
void SetLocked(BOOL bLocked=TRUE)
Sets the locked state for the block (i.e.
Definition XTPTrackBlock.h:792
CXTPTrackBlock::m_strDescription
CString m_strDescription
Description text.
Definition XTPTrackBlock.h:341
CXTPTrackBlock::m_nIndex
int m_nIndex
Index of the block in its parent track.
Definition XTPTrackBlock.h:342
CXTPTrackBlock::m_bLocked
BOOL m_bLocked
TRUE if the block is not movable/resizable.
Definition XTPTrackBlock.h:331
CXTPTrackBlock::SetCaption
void SetCaption(LPCTSTR lpszCaption)
Sets the caption for the block.
Definition XTPTrackBlock.h:780
CXTPTrackBlock::m_nMRUPosition
int m_nMRUPosition
Last position that was set by the user.
Definition XTPTrackBlock.h:339
CXTPTrackBlock::SetVerticalAlignment
void SetVerticalAlignment(int nAlignment)
Sets the vertical alignment for the block in its track.
Definition XTPTrackBlock.h:812
CXTPTrackBlock::m_nLastDragTime
int m_nLastDragTime
Last drag moment of user (used as priority for flexible draging).
Definition XTPTrackBlock.h:343
CXTPTrackBlock::GetLength
int GetLength() const
Gets the length of the block on the track.
Definition XTPTrackBlock.h:764
CXTPTrackBlock::Draw
virtual int Draw(CDC *pDC, CRect rc, BOOL bSelected)
Draws the block.
CXTPTrackBlock::GetCaption
CString GetCaption() const
Gets the caption of the block.
Definition XTPTrackBlock.h:776
CXTPTrackBlock::m_nMinLength
int m_nMinLength
Minimum resize length.
Definition XTPTrackBlock.h:344
CXTPTrackBlock::SetDescriptionText
void SetDescriptionText(LPCTSTR lpszDescriptionText)
Sets the description text for the block.
Definition XTPTrackBlock.h:784
CXTPTrackBlock::m_bDragging
BOOL m_bDragging
Block is currently dragging.
Definition XTPTrackBlock.h:346
CXTPTrackBlock::CXTPTrackBlock
CXTPTrackBlock()
Constructs a CXTPTrackBlock object.
CXTPTrackBlock::SetMaxLength
void SetMaxLength(int nMaxLength)
Sets the maximum length for the block.
Definition XTPTrackBlock.h:840
CXTPTrackBlock::m_clrBlock
COLORREF m_clrBlock
Color of the block.
Definition XTPTrackBlock.h:332
CXTPTrackBlock::Select
void Select(BOOL bSelect=TRUE)
Sets the selected state for the block.
CXTPTrackBlock::GetDescriptionText
CString GetDescriptionText() const
Gets the description text of the block.
Definition XTPTrackBlock.h:788
CXTPTrackBlock::GetTooltip
virtual CString GetTooltip() const
Gets the tooltip text of the block.
Definition XTPTrackBlock.h:768
CXTPTrackBlock::GetMinLength
int GetMinLength() const
Gets the minimum length of the block.
Definition XTPTrackBlock.h:836
CXTPTrackBlock::SetColor
void SetColor(COLORREF clr)
Sets the color for the block.
Definition XTPTrackBlock.h:752
CXTPTrackBlock::m_nVerticalAlignment
int m_nVerticalAlignment
Vertical alignment of blocks with m_dHeightPercent < 1.
Definition XTPTrackBlock.h:336
CXTPTrackBlock::GetRect
CRect GetRect() const
Gets the bounding rectangle of the block.
Definition XTPTrackBlock.h:756
CXTPTrackBlock::GetMaxLength
int GetMaxLength() const
Gets the maximum length of the block.
Definition XTPTrackBlock.h:844
CXTPTrackBlock::m_nPosition
int m_nPosition
Position that resolve overlaps with items on same track.
Definition XTPTrackBlock.h:329
CXTPTrackBlock::m_strCaption
CString m_strCaption
Caption text.
Definition XTPTrackBlock.h:333
CXTPTrackBlock::SetMinLength
void SetMinLength(int nMinLength)
Sets the minimum length for the block.
Definition XTPTrackBlock.h:832
CXTPTrackControl
This class represents a track control.
Definition XTPTrackControl.h:113
CXTPTrackControlItem
This class represents a container cell for a set of blocks and keys and inherits basic functionality ...
Definition XTPTrackControlItem.h:45
CXTPTrackKey
This class represents a track control key.
Definition XTPTrackBlock.h:395
CXTPTrackKey::IsKey
virtual BOOL IsKey() const
Determines if the item is a key.
Definition XTPTrackBlock.h:848
CXTPTrackKey::CXTPTrackKey
CXTPTrackKey()
Constructs a CXTPTrackKey object.
CXTPTrackKey::Draw
virtual int Draw(CDC *pDC, CRect rc, BOOL bSelected)
Draws the key.
CXTPTrackMarker
This class represents a track control marker.
Definition XTPTrackBlock.h:438
CXTPTrackMarker::GetPosition
int GetPosition() const
Gets the position of the marker.
Definition XTPTrackBlock.h:852
CXTPTrackMarker::Remove
void Remove()
Removes the marker.
CXTPTrackMarker::DoPropExchange
void DoPropExchange(CXTPPropExchange *pPX)
Call this member function to store/load the properties related to the marker.
CXTPTrackMarker::SetPosition
void SetPosition(int nPosition)
Sets the position of the marker.
CXTPTrackMarker::m_pControl
CXTPTrackControl * m_pControl
Parent control.
Definition XTPTrackBlock.h:518
CXTPTrackMarker::CXTPTrackMarker
CXTPTrackMarker()
Constructs a CXTPTrackMarker object.
CXTPTrackMarker::SetCaption
void SetCaption(LPCTSTR lpszCaption)
Sets the caption for the marker.
Definition XTPTrackBlock.h:856
CXTPTrackMarker::GetControl
CXTPTrackControl * GetControl() const
Gets the track control to which the marker is associated with.
Definition XTPTrackBlock.h:868
CXTPTrackMarker::GetCaption
CString GetCaption() const
Gets the caption of the marker.
Definition XTPTrackBlock.h:860
CXTPTrackMarker::m_rcMarker
CRect m_rcMarker
Drawing position of the marker.
Definition XTPTrackBlock.h:517
CXTPTrackMarker::GetRect
CRect GetRect() const
Gets the bounding rectangle of the marker.
Definition XTPTrackBlock.h:864
CXTPTrackMarker::m_nPosition
int m_nPosition
Position of the marker.
Definition XTPTrackBlock.h:516
CXTPTrackMarker::m_strCaption
CString m_strCaption
Caption of the marker.
Definition XTPTrackBlock.h:515
CXTPTrackMarkers
This class abstracts the track control markers.
Definition XTPTrackBlock.h:539
CXTPTrackMarkers::DoPropExchange
void DoPropExchange(CXTPPropExchange *pPX)
Call this member function to store/load the properties related to the marker collection.
CXTPTrackMarkers::GetCount
int GetCount() const
Gets the number of markers in the marker collection.
CXTPTrackMarkers::m_pControl
CXTPTrackControl * m_pControl
Parent control.
Definition XTPTrackBlock.h:645
CXTPTrackMarkers::IndexOf
int IndexOf(CXTPTrackMarker *pMarker)
Retrieves the index of a marker in the marker collection.
CXTPTrackMarkers::Remove
void Remove(CXTPTrackMarker *pMarker)
Removes a specified marker from the marker collection.
CXTPTrackMarkers::HitTest
int HitTest(CPoint pt) const
Call this member function to determine the index of the marker, if any, at a specified point.
CXTPTrackMarkers::~CXTPTrackMarkers
~CXTPTrackMarkers()
Destroys the CXTPTrackMarkers object, handles cleanup and deallocation.
CXTPTrackMarkers::CXTPTrackMarkers
CXTPTrackMarkers(CXTPTrackControl *pControl)
Constructs a CXTPTrackMarkers object.
CXTPTrackMarkers::Add
CXTPTrackMarker * Add(CXTPTrackMarker *pMarker)
Adds a marker to the marker collection.
CXTPTrackMarkers::RemoveAll
void RemoveAll()
Removes all markers from the marker collection.
CXTPTrackMarkers::Add
CXTPTrackMarker * Add(int nPosition, LPCTSTR lpszCaption)
Creates and adds a marker to the marker collection.
CXTPTrackMarkers::RemoveAt
void RemoveAt(int nIndex)
Removes the marker at a specified index from the marker collection.
CXTPTrackMarkers::m_arrMarkers
CArray< CXTPTrackMarker *, CXTPTrackMarker * > m_arrMarkers
Array of markers.
Definition XTPTrackBlock.h:646
CXTPTrackMarkers::GetAt
CXTPTrackMarker * GetAt(int nIndex) const
Retrieves the marker at a specified index in the marker collection.
CXTPTrackPaintManager
This class represents a track control paint manager.
Definition XTPTrackPaintManager.h:41
CXTPTrackSelectedBlocks
This class abstracts the selected blocks of the track control.
Definition XTPTrackBlock.h:671
CXTPTrackSelectedBlocks::IsSelected
BOOL IsSelected(const CXTPTrackBlock *pBlock) const
Determines if a block is selected.
CXTPTrackSelectedBlocks::GetCount
int GetCount() const
Gets the number of blocks in selected blocks.
CXTPTrackSelectedBlocks::GetAt
CXTPTrackBlock * GetAt(int nIndex) const
Retrieves the block at a specified index in selected blocks.
CXTPTrackSelectedBlocks::RemoveAll
void RemoveAll()
Removes all blocks from selected blocks.
CXTPTrackSelectedBlocks::CXTPTrackSelectedBlocks
CXTPTrackSelectedBlocks()
Constructs the CXTPTrackSelectedBlocks object.
CXTPTrackSelectedBlocks::Add
void Add(CXTPTrackBlock *pBlock)
Adds a block to selected blocks.
CXTPTrackSelectedBlocks::RemoveAt
void RemoveAt(int nIndex)
Removes the block at a specified index from selected blocks.
CXTPTrackSelectedBlocks::Remove
void Remove(CXTPTrackBlock *pBlock)
Removes a specified block from selected blocks.


Toolkit Pro: Member List

XTP_NM_GRIDCOLUMNRESIZE Member List

This is the complete list of members for XTP_NM_GRIDCOLUMNRESIZE, including all inherited members.

hdr | XTP_NM_GRIDCOLUMNRESIZE
nNewWidth | XTP_NM_GRIDCOLUMNRESIZE
nPrevWidth | XTP_NM_GRIDCOLUMNRESIZE
pColumn | XTP_NM_GRIDCOLUMNRESIZE


Toolkit Pro: XTPMarkupTools.h Source File

  • Source
  • Markup
XTPMarkupTools.h
Go to the documentation of this file.
1
23#if !defined(__XTPMARKUPTOOLS_H__)
24# define __XTPMARKUPTOOLS_H__
25
26# if _MSC_VER > 1000
27# pragma once
28# endif // _MSC_VER > 1000
29
30# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
31
32# ifndef _XTP_ACTIVEX
33
34# ifndef DECLARE_ENUM_VARIANT
35# define DECLARE_ENUM_VARIANT(theClass) \
36 afx_msg LPUNKNOWN OleNewEnum(); \
37 friend class CEnumVariantArray<theClass>;
38# endif
40# ifndef IMPLEMENT_ENUM_VARIANT
41# define IMPLEMENT_ENUM_VARIANT(theClass) \
42 LPUNKNOWN theClass::OleNewEnum() \
43 { \
44 CEnumVariantArray<theClass>* pEnumVariant = new CEnumVariantArray<theClass>( \
45 this); \
46 return (LPUNKNOWN)pEnumVariant; \
47 }
48# endif /* !IMPLEMENT_ENUM_VARIANT */
49
50AFX_INLINE LPDISPATCH XTPGetDispatch(CCmdTarget* pCmdTarget, BOOL bAddRef = TRUE)
51{
52 if (NULL == pCmdTarget)
53 return NULL;
54
55 return pCmdTarget->GetIDispatch(bAddRef);
56}
57
58# pragma warning(push)
59// C4616: #pragma warning : warning number '...' out of range, must be between '4001' and '4999'
60// C4619: #pragma warning : there is no warning number 'number'
61// C5204: '...': class has virtual functions, but its trivial destructor is not virtual; instances
62// of objects derived from this class may not be destructed correctly
63# pragma warning(disable : 4616 4619 5204)
64
65template<class T>
66class CEnumVariantArray : public IEnumVARIANT
67{
68public:
69 CEnumVariantArray(T* pEnumable)
70 {
71 m_nCurrent = 0;
72 m_pEnumable = pEnumable;
73 m_dwRef = 1;
74 }
75
76 STDMETHOD_(ULONG, AddRef)();
77 STDMETHOD_(ULONG, Release)();
78 STDMETHOD(QueryInterface)(REFIID iid, LPVOID* ppvObj);
79
80 HRESULT STDMETHODCALLTYPE Next(ULONG celt, VARIANT* rgVar, ULONG* pCeltFetched);
81
82 HRESULT STDMETHODCALLTYPE Skip(ULONG celt);
83
84 HRESULT STDMETHODCALLTYPE Reset();
85
86 HRESULT STDMETHODCALLTYPE Clone(IEnumVARIANT** ppEnum);
87
88 int m_nCurrent;
89 T* m_pEnumable;
90 long m_dwRef;
91};
92
93# pragma warning(pop)
94
95template<class T>
96inline ULONG FAR EXPORT CEnumVariantArray<T>::AddRef()
97{
98 return XTPToULongChecked(InterlockedIncrement(&m_dwRef));
99}
100
101template<class T>
102inline ULONG FAR EXPORT CEnumVariantArray<T>::Release()
103{
104 if (m_dwRef == 0)
105 return 0;
106
107 LONG lResult = InterlockedDecrement(&m_dwRef);
108 if (lResult == 0)
109 {
110 delete this;
111 }
112 return XTPToULongChecked(lResult);
113}
114template<class T>
115inline HRESULT FAR EXPORT CEnumVariantArray<T>::QueryInterface(REFIID iid, void FAR* FAR* ppvObj)
116{
117 if (iid == IID_IUnknown || iid == IID_IEnumVARIANT)
118 {
119 *ppvObj = this;
120 AddRef();
121 return S_OK;
122 }
123
124 *ppvObj = NULL;
125 return E_NOINTERFACE;
126}
127
128template<class T>
129inline HRESULT STDMETHODCALLTYPE CEnumVariantArray<T>::Next(ULONG celt, VARIANT* rgVar,
130 ULONG* pceltFetched)
131{
132 AFX_MANAGE_STATE(m_pEnumable->m_pModuleState)
133
134 ULONG nFetched = 0;
135 while (nFetched < celt && m_nCurrent < m_pEnumable->OleGetItemCount())
136 {
137 rgVar[nFetched].vt = VT_DISPATCH;
138 rgVar[nFetched].pdispVal = m_pEnumable->OleGetItem(m_nCurrent);
139 nFetched++;
140 m_nCurrent++;
141 }
142
143 if (pceltFetched)
144 *pceltFetched = nFetched;
145 return nFetched == celt ? S_OK : S_FALSE;
146}
147
148template<class T>
149inline HRESULT STDMETHODCALLTYPE CEnumVariantArray<T>::Skip(ULONG celt)
150{
151 if (m_nCurrent + (int)celt < m_pEnumable->OleGetItemCount())
152 {
153 m_nCurrent += celt;
154 return S_OK;
155 }
156 m_nCurrent = m_pEnumable->OleGetItemCount() - 1;
157 return S_FALSE;
158}
159
160template<class T>
161inline HRESULT STDMETHODCALLTYPE CEnumVariantArray<T>::Reset()
162{
163 m_nCurrent = 0;
164 return S_OK;
165}
166
167template<class T>
168inline HRESULT STDMETHODCALLTYPE CEnumVariantArray<T>::Clone(IEnumVARIANT** ppEnum)
169{
170 CEnumVariantArray<T>* pEnumVariant = new CEnumVariantArray<T>(m_pEnumable);
171 pEnumVariant->m_nCurrent = m_nCurrent;
172
173 *ppEnum = pEnumVariant;
174 return S_OK;
175}
176
177# endif
178# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
179#endif // #if !defined(__XTPMARKUPTOOLS_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h


Toolkit Pro: Member List

CXTPControlToolbars Member List

This is the complete list of members for CXTPControlToolbars, including all inherited members.

AssignDocTemplate(UINT nIDResource) | CXTPControl |
ClickToolBarButton(CRect rcActiveRect=CRect(0, 0, 0, 0)) | CXTPControl | protected
Compare(CXTPControl *pOther) | CXTPControl | virtual
Copy(CXTPControl *pControl, BOOL bRecursive=FALSE) | CXTPControlButton | protectedvirtual
CreateToolbarMenu(CXTPCommandBar *pPopupBar, int nInsert, int nID, BOOL bAddCustomize, BOOL bBeginGroup=FALSE) | CXTPControlToolbars | static
CustomizeStartDrag(CPoint point) | CXTPControl | protectedvirtual
CustomizeStartResize(CPoint point) | CXTPControl | protectedvirtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPControl() | CXTPControl | protected
CXTPControlButton() | CXTPControlButton |
CXTPControlToolbars() | CXTPControlToolbars |
DelayLayoutParent() | CXTPControl |
DelayRedrawParent() | CXTPControl |
DoCustomDragOver(CXTPCommandBar *pCommandBar, CPoint point, DROPEFFECT &dropEffect) | CXTPControlToolbars | protectedvirtual
DoPropExchange(CXTPPropExchange *pPX) | CXTPControlButton | virtual
Draw(CDC *pDC) | CXTPControl | virtual
ExcludeDocTemplate(UINT nIDResource) | CXTPControl |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
FromUI(CCmdUI *pCmdUI) | CXTPControl | static
GenerateCommandBarList(DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam) | CXTPControl | protectedvirtual
GetAction() const | CXTPControl |
GetBeginGroup() const | CXTPControl |
GetButtonSize() const | CXTPControl | virtual
GetCaption() const | CXTPControl | virtual
GetCategory() const | CXTPControl |
GetChecked() const | CXTPControl |
GetCloseSubMenuOnClick() const | CXTPControl |
GetCommandBar() const | CXTPControl | virtual
GetControls() const | CXTPControl |
GetCustomizeMinHeight() const | CXTPControl | protectedvirtual
GetCustomizeMinWidth() const | CXTPControl | protectedvirtual
GetCustomShortcutText() const | CXTPControl |
GetDescription() const | CXTPControl | virtual
GetEnabled() const | CXTPControl |
GetExecuteOnPressInterval() const | CXTPControl |
GetExpanded() const | CXTPControl |
GetFlags() const | CXTPControl |
GetHeight() const | CXTPControl |
GetHelpId() const | CXTPControl |
GetHideFlags() const | CXTPControl |
GetIconId() const | CXTPControl |
GetIconSize() const | CXTPControl | virtual
GetID() const | CXTPControl |
GetImage(int nWidth=16) const | CXTPControl | virtual
GetImageManager() const | CXTPControl |
GetIndex() const | CXTPControl |
GetKeyboardTip() const | CXTPControl |
GetPaintManager() const | CXTPControl |
GetParameter() const | CXTPControl |
GetParent() const | CXTPControl |
GetPopuped() const | CXTPControl | virtual
GetPressed() const | CXTPControl | virtual
GetRect() const | CXTPControl |
GetRibbonGroup() const | CXTPControl |
GetRowRect() const | CXTPControl |
GetSelected() const | CXTPControl | virtual
GetShortcutText() const | CXTPControl |
GetSize(CDC *pDC) | CXTPControl | virtual
GetStyle() const | CXTPControl |
GetStyleEx() const | CXTPControlButton |
GetTag() const | CXTPControl |
GetTooltip() const | CXTPControl | virtual
GetType() const | CXTPControl |
GetWidth() const | CXTPControl |
GetWrap() const | CXTPControl |
HasDwmCompositedRect() const | CXTPControl |
IsCaptionVisible() const | CXTPControl | virtual
IsCursorOver() const | CXTPControl |
IsCustomizeMode() const | CXTPControl | protected
IsCustomizeMovable() const | CXTPControl | virtual
IsCustomizeResizeAllow() const | CXTPControl | protectedvirtual
IsFocusable() const | CXTPControl | protectedvirtual
IsFocused() const | CXTPControl | virtual
IsItemDefault() const | CXTPControl |
IsLayoutChanged() | CXTPControl | protected
IsLayoutRTL() const | CXTPControl | protected
IsOnQuickAccess() const | CXTPControl |
IsTemporary() const | CXTPControl |
IsTransparent() const | CXTPControl | inlinevirtual
IsVisible(DWORD dwSkipFlags=0) const | CXTPControl | virtual
m_bBeginGroup | CXTPControl | protected
m_bChecked | CXTPControl | protected
m_bCloseSubMenuOnClick | CXTPControl | protected
m_bDefaultItem | CXTPControl | protected
m_bEnabled | CXTPControl | protected
m_bExpanded | CXTPControl | protected
m_bLayoutRTL | CXTPControl | protected
m_bOnQuickAccess | CXTPControl | protected
m_bPressed | CXTPControl | protected
m_bSelected | CXTPControl | protected
m_bTemporary | CXTPControl | protected
m_buttonCustomStyle | CXTPControl | protected
m_buttonRibbonStyle | CXTPControl | protected
m_buttonStyle | CXTPControl | protected
m_buttonStyleEx | CXTPControlButton | protected
m_bWrap | CXTPControl | protected
m_controlType | CXTPControl | protected
m_dwFlags | CXTPControl | protected
m_dwHideFlags | CXTPControl | protected
m_mapDocTemplatesAssigned | CXTPControl | protected
m_mapDocTemplatesExcluded | CXTPControl | protected
m_nCustomIconId | CXTPControl | protected
m_nExecuteOnPressInterval | CXTPControl | protected
m_nHeight | CXTPControl | protected
m_nHelpId | CXTPControl | protected
m_nIconId | CXTPControl | protected
m_nId | CXTPControl | protected
m_nIndex | CXTPControl | protected
m_nTag | CXTPControl | protected
m_nWidth | CXTPControl | protected
m_pAction | CXTPControl | protected
m_pControls | CXTPControl | protected
m_pParent | CXTPControl | protected
m_pRibbonGroup | CXTPControl | protected
m_rcControl | CXTPControl | protected
m_rcRow | CXTPControl | protected
m_strCaption | CXTPControl | protected
m_strCategory | CXTPControl | protected
m_strCustomCaption | CXTPControl | protected
m_strDescriptionText | CXTPControl | protected
m_strKeyboardTip | CXTPControl | protected
m_strParameter | CXTPControl | protected
m_strShortcutText | CXTPControl | protected
m_strShortcutTextAuto | CXTPControl | protected
m_strTooltipText | CXTPControl | protected
m_szIcon | CXTPControl | protected
NotifySite(UINT code) | CXTPControl |
NotifySite(UINT code, NMXTPCONTROL *pNM) | CXTPControl |
NotifySite(CWnd *pSite, UINT code, NMXTPCONTROL *pNM) | CXTPControl |
OnActionChanged(int nProperty) | CXTPControl | protectedvirtual
OnActionChanging(int nProperty) | CXTPControl | protectedvirtual
OnCalcDynamicSize(DWORD dwMode) | CXTPControlToolbars | protectedvirtual
OnCaptionChanged() | CXTPControl | protectedvirtual
OnClick(BOOL bKeyboard=FALSE, CPoint pt=CPoint(0, 0)) | CXTPControlButton | protectedvirtual
OnCustomizeDragOver(CXTPControl *pDataObject, CPoint point, DROPEFFECT &dropEffect) | CXTPControl | protectedvirtual
OnCustomizeMouseMove(CPoint point) | CXTPControl | protected
OnEnabledChanged() | CXTPControl | virtual
OnExecute() | CXTPControl | virtual
OnHookKeyDown(UINT nChar, LPARAM lParam) | CXTPControl | protectedvirtual
OnHookMouseWheel(UINT nFlags, short zDelta, CPoint point) | CXTPControl | protectedvirtual
OnIdleUpdate() | CXTPControl | protectedvirtual
OnLButtonDblClk(CPoint point) | CXTPControl | protectedvirtual
OnLButtonDown(CPoint point) | CXTPControl | protectedvirtual
OnLButtonUp(CPoint point) | CXTPControlButton | protectedvirtual
OnMouseHover() | CXTPControl | protectedvirtual
OnMouseMove(CPoint point) | CXTPControl | protectedvirtual
OnRButtonDown(CPoint point) | CXTPControl | protectedvirtual
OnRButtonUp(CPoint point) | CXTPControl | protectedvirtual
OnRemoved() | CXTPControl | protectedvirtual
OnSetPopup(BOOL bPopup) | CXTPControl | protectedvirtual
OnSetSelected(int bSelected) | CXTPControl | protectedvirtual
OnThemeChanged() | CXTPControl | virtual
OnToolHitTest(CPoint point, TOOLINFO *pTI) const | CXTPControl | protectedvirtual
OnUnderlineActivate() | CXTPControl | virtual
RedrawParent(BOOL bAnimate=TRUE) | CXTPControl |
Reset() | CXTPControl |
RestoreCommandBarList(CXTPCommandBarList *pCommandBarList) | CXTPControl | protectedvirtual
ScreenToClient(CPoint *point) | CXTPControl | protected
SetAction(CXTPControlAction *pAction) | CXTPControl | virtual
SetBeginGroup(BOOL bBeginGroup) | CXTPControl | virtual
SetCaption(LPCTSTR lpszCaption) | CXTPControl |
SetCaption(UINT nIDCaption) | CXTPControl |
SetCategory(LPCTSTR lpszCategory) | CXTPControl |
SetChecked(BOOL bChecked) | CXTPControl | virtual
SetCloseSubMenuOnClick(BOOL bCloseOnClick) | CXTPControl |
SetCustomIcon(HICON hIcon) | CXTPControl |
SetCustomShortcutText(LPCTSTR lpszCustomShortcutText) | CXTPControl |
SetDescription(LPCTSTR lpszDescription) | CXTPControl |
SetEnabled(BOOL bEnabled) | CXTPControl | virtual
SetExecuteOnPressInterval(int nExecuteOnPressInterval) | CXTPControl |
SetExpanded(BOOL bExpanded) | CXTPControl | protected
SetFlags(DWORD dwFlags) | CXTPControl |
SetFocused(BOOL bFocused) | CXTPControl | virtual
SetHeight(int nHeight) | CXTPControl | virtual
SetHelpId(int nId) | CXTPControl |
SetHideFlag(XTPControlHideFlags dwFlag, BOOL bSet) | CXTPControl |
SetHideFlags(DWORD dwFlags) | CXTPControl | virtual
SetHideWrap(BOOL bHide) | CXTPControl |
SetIconId(int nId) | CXTPControl |
SetIconSize(CSize szIcon) | CXTPControl |
SetID(int nId) | CXTPControl |
SetIndex(int nIndex) | CXTPControl | inlineprotected
SetItemDefault(BOOL bDefault) | CXTPControl |
SetKeyboardTip(LPCTSTR lpszKeyboardTip) | CXTPControl |
SetOnQuickAccess(BOOL bOnQuicAccess=FALSE) | CXTPControl |
SetParameter(LPCTSTR lpszParameter) | CXTPControl |
SetParent(CXTPCommandBar *pParent) | CXTPControl | inlineprotectedvirtual
SetPressed(BOOL bPressed) | CXTPControl |
SetPrompt(LPCTSTR lpszPrompt) | CXTPControl |
SetRect(CRect rcControl) | CXTPControl | virtual
SetRowRect(CRect rcRow) | CXTPControl |
SetShortcutText(LPCTSTR lpszShortcutText) | CXTPControl |
SetStyle(XTPButtonStyle buttonStyle) | CXTPControl |
SetStyleEx(XTPButtonStyle buttonStyle) | CXTPControlButton |
SetTag(DWORD_PTR dwTag) | CXTPControl |
SetTooltip(LPCTSTR lpszTooltip) | CXTPControl |
SetVisible(BOOL bVisible) | CXTPControl |
SetWidth(int nWidth) | CXTPControl | virtual
SetWrap(BOOL bWrap) | CXTPControl |
~CXTPControl() | CXTPControl | protectedvirtual
~CXTPControlButton() | CXTPControlButton | virtual


Toolkit Pro: Member List

CXTPCalendarViewDayT< _TView, _TViewGroup, XTP_CALENDAR_HITTESTINFO, _TPThis > Member List

This is the complete list of members for CXTPCalendarViewDayT< _TView, _TViewGroup, XTP_CALENDAR_HITTESTINFO, _TPThis >, including all inherited members.

AdjustLayout(CDC *pDC, const CRect &rcDay) | CXTPCalendarViewDayT< _TView, _TViewGroup, XTP_CALENDAR_HITTESTINFO, _TPThis > | inlinevirtual
ContainsInvisibleEvents() const | CXTPCalendarViewDay | virtual
ContainsInvisibleEventsUpdate() | CXTPCalendarViewDay | virtual
CreateGroup() | CXTPCalendarViewDayT< _TView, _TViewGroup, XTP_CALENDAR_HITTESTINFO, _TPThis > | inlinevirtual
CXTPCalendarViewDay(const CXTPCalendarView *pView) | CXTPCalendarViewDay |
CXTPCalendarViewDayT(const _TView *pView) | CXTPCalendarViewDayT< _TView, _TViewGroup, XTP_CALENDAR_HITTESTINFO, _TPThis > | inline
CXTPCalendarWMHandler() | CXTPCalendarWMHandler |
CXTPCmdTarget() | CXTPCmdTarget |
Draw(CDC *pDC) | CXTPCalendarViewDay | inlinevirtual
FillHitTestEx(XTP_CALENDAR_HITTESTINFO *pHitTest) const =0 | CXTPCalendarViewDayT< _TView, _TViewGroup, XTP_CALENDAR_HITTESTINFO, _TPThis > | pure virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCalendarControl() const | CXTPCalendarViewDay | virtual
GetChildHandlerAt(int nIndex) const | CXTPCalendarViewDay | inlinevirtual
GetChildHandlersCount() const | CXTPCalendarViewDay | inlinevirtual
GetDayDate() const | CXTPCalendarViewDay | virtual
GetDayIndex() const | CXTPCalendarViewDay | virtual
GetDayRect() const | CXTPCalendarViewDay | virtual
GetExpandSignRect() const | CXTPCalendarViewDay | virtual
GetPThis()=0 | CXTPCalendarViewDayT< _TView, _TViewGroup, XTP_CALENDAR_HITTESTINFO, _TPThis > | protectedpure virtual
GetResources() const | CXTPCalendarViewDay | virtual
GetView() const | CXTPCalendarViewDayT< _TView, _TViewGroup, XTP_CALENDAR_HITTESTINFO, _TPThis > | inline
GetView_() const | CXTPCalendarViewDay | virtual
GetViewEvent_(int nIndex) const | CXTPCalendarViewDay | virtual
GetViewEventsCount() const | CXTPCalendarViewDay | virtual
GetViewGroup(int nIndex) const | CXTPCalendarViewDayT< _TView, _TViewGroup, XTP_CALENDAR_HITTESTINFO, _TPThis > | inlinevirtual
GetViewGroup_(int nIndex) const | CXTPCalendarViewDay |
GetViewGroupsCount() const | CXTPCalendarViewDay |
HitTest(CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const | CXTPCalendarViewDay | virtual
HitTestEx(CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const | CXTPCalendarViewDay | virtual
IsExpanded() const | CXTPCalendarViewDay | virtual
IsSelected() const | CXTPCalendarViewDay | virtual
KillTimer(UINT uTimerID) | CXTPCalendarViewDay | virtual
m_arViewGroups | CXTPCalendarViewDay | protected
m_dtDate | CXTPCalendarViewDay | protected
m_Layout | CXTPCalendarViewDay | protected
m_pResources | CXTPCalendarViewDay | protected
m_pView | CXTPCalendarViewDay | protected
OnBeforeDestroy() | CXTPCalendarWMHandler | virtual
OnChar(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnKeyUp(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnLButtonDblClk(UINT nFlags, CPoint point) | CXTPCalendarWMHandler | virtual
OnLButtonDown(UINT nFlags, CPoint point) | CXTPCalendarWMHandler | virtual
OnLButtonUp(UINT nFlags, CPoint point) | CXTPCalendarWMHandler | virtual
OnMouseMove(UINT nFlags, CPoint point) | CXTPCalendarWMHandler | virtual
OnPostAdjustLayout() | CXTPCalendarWMHandler | virtual
OnPrePopulateDay() | CXTPCalendarViewDay | protectedvirtual
OnSysKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnTimer(UINT_PTR uTimerID) | CXTPCalendarWMHandler | virtual
OnWndMsg(UINT message, WPARAM wParam, LPARAM lParam, LRESULT *pResult) | CXTPCalendarWMHandler | virtual
Populate(COleDateTime dtDayDate) | CXTPCalendarViewDay | virtual
SetDayDate(COleDateTime dtDayDate) | CXTPCalendarViewDay | virtual
SetDayRect(CRect rcDay) | CXTPCalendarViewDay | virtual
SetResources(CXTPCalendarResources *pResources) | CXTPCalendarViewDay | virtual
SetSelected() | CXTPCalendarViewDay | virtual
SetTimer(UINT uTimeOut_ms) | CXTPCalendarViewDay | virtual
TView typedef | CXTPCalendarViewDayT< _TView, _TViewGroup, XTP_CALENDAR_HITTESTINFO, _TPThis > |
UserAction_OnExpandDay(XTPCalendarExpandDayButton eButton) | CXTPCalendarViewDay | virtual
~CXTPCalendarViewDay() | CXTPCalendarViewDay | virtual
~CXTPCalendarViewDayT() | CXTPCalendarViewDayT< _TView, _TViewGroup, XTP_CALENDAR_HITTESTINFO, _TPThis > | inlinevirtual


Toolkit Pro: Member List

CXTPEditThemeNativeWindows11 Member List

This is the complete list of members for CXTPEditThemeNativeWindows11, including all inherited members.

AdjustBuddyRect(CWnd *pBuddy, CRect &rcUpDown, int nAlignment) | CXTPEditThemeOfficeXP | virtual
CtlColor(CDC *pDC, UINT nCtlColor, CXTPEdit *pEdit) | CXTPEditThemeDefault | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPControlTheme() | CXTPControlTheme |
CXTPEditTheme() | CXTPEditTheme |
CXTPEditThemeDefault() | CXTPEditThemeDefault |
CXTPEditThemeNativeWindows11() | CXTPEditThemeNativeWindows11 |
CXTPEditThemeOffice2000() | CXTPEditThemeOffice2000 |
CXTPEditThemeOffice2013() | CXTPEditThemeOffice2013 |
CXTPEditThemeOfficeXP() | CXTPEditThemeOfficeXP |
DrawBuddyBorders(CWnd *pBuddy, CDC *pDC, CRect rc, int nAlignment, CXTPEdit *pEdit) | CXTPEditThemeOfficeXP | virtual
CXTPEditThemeOffice2000::DrawBuddyBorders(CDC *pDC, CRect rc, int nAlignment, CXTPEdit *pEdit) | CXTPEditThemeOffice2000 | virtual
DrawFrame(CDC *pDC, CRect rc, int nSize, CBrush *pBrush) | CXTPEditTheme | virtual
DrawNcBorders(CDC *pDC, CRect rcWnd, CXTPEdit *pEdit) | CXTPEditThemeOfficeXP | virtual
DrawNcBordersDefault(CDC *pDC, CRect rcWnd, CXTPEdit *pEdit) | CXTPEditThemeDefault | protectedvirtual
DrawNcScrollBack(CDC *pDC, CRect rcWnd, CXTPEdit *pEdit) | CXTPEditThemeDefault | virtual
FillRect(CDC *pDC, int x, int y, int cx, int cy, CBrush *pBrush) | CXTPEditTheme | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetClientBrush(CDC *pDC, CXTPEdit *pEdit) | CXTPEditTheme | virtual
GetThemeID() const | CXTPEditTheme |
GetThemeStyle() const | CXTPControlTheme |
IsFlatStyle() const | CXTPEditTheme |
m_bFlatStyle | CXTPEditTheme | protected
m_bUseWinTheme | CXTPEditTheme | protected
m_clrBack | CXTPEditTheme |
m_clrBackNonClient | CXTPEditTheme |
m_clrBorder | CXTPEditTheme |
m_clrBorderDisabled | CXTPEditThemeOfficeXP | protected
m_clrBorderHilite | CXTPEditThemeOfficeXP | protected
m_clrText | CXTPEditTheme |
m_clrTextReadOnly | CXTPEditTheme |
m_nTheme | CXTPEditTheme | protected
m_winTheme | CXTPEditTheme | protected
m_xtpBrushBack | CXTPEditTheme |
RedrawFocusedFrame() const | CXTPEditThemeOfficeXP | virtual
RefreshMetrics(CXTPEdit *pEdit) | CXTPEditThemeOffice2013 | virtual
SetFlatStyle(BOOL bFlatStyle) | CXTPEditTheme |
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static
UseWinTheme(BOOL bUseWinTheme) | CXTPEditTheme |
~CXTPEditTheme() | CXTPEditTheme | virtual
~CXTPEditThemeDefault() | CXTPEditThemeDefault | virtual
~CXTPEditThemeNativeWindows11() | CXTPEditThemeNativeWindows11 | virtual
~CXTPEditThemeOffice2000() | CXTPEditThemeOffice2000 | virtual
~CXTPEditThemeOffice2013() | CXTPEditThemeOffice2013 | virtual
~CXTPEditThemeOfficeXP() | CXTPEditThemeOfficeXP | virtual


Toolkit Pro: XTPSyntaxEditToolTipCtrl.h Source File

  • Source
  • SyntaxEdit
XTPSyntaxEditToolTipCtrl.h
Go to the documentation of this file.
1
23#if !defined(__XTPSYNTAXEDITTOOLTIPCTRL_H__)
24# define __XTPSYNTAXEDITTOOLTIPCTRL_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPSyntaxEditCtrl;
34// Internal class
35
51class _XTP_EXT_CLASS CXTPSyntaxEditToolTipCtrl : public CWnd
52{
53 // Construction
54public:
72 CXTPSyntaxEditToolTipCtrl();
73
78 virtual ~CXTPSyntaxEditToolTipCtrl();
79
89 virtual BOOL Create(CXTPSyntaxEditCtrl* pParentWnd);
90
91 using CWnd::Create;
92
100 void SetDelay(int nDelay);
101
110 int GetDelay() const;
111
116 void Hide();
117
124 void Activate(const CString& strText);
125
135 void SetHoverRect(CRect rc);
136
137 //{{AFX_VIRTUAL(CXTPSyntaxEditToolTipCtrl)
138 //}}AFX_VIRTUAL
139
140protected:
141 int m_nDelayTime;
142 CXTPSyntaxEditCtrl* m_pParentWnd;
143 CRect m_rcHover;
144 CString m_strToolTipText;
146 //{{AFX_MSG(CXTPSyntaxEditToolTipCtrl)
147
148 afx_msg LRESULT OnNcHitTest(CPoint point);
149 afx_msg void OnPaint();
150 afx_msg void OnTimer(UINT_PTR nIDEvent);
151
152 //}}AFX_MSG
154 DECLARE_MESSAGE_MAP()
156private:
157 void ReCalcToolTipRect();
158 BOOL RegisterWindowClass(HINSTANCE hInstance = NULL);
159};
160
162
163AFX_INLINE void CXTPSyntaxEditToolTipCtrl::SetDelay(int nDelay)
164{
165 m_nDelayTime = nDelay;
166}
167AFX_INLINE int CXTPSyntaxEditToolTipCtrl::GetDelay() const
168{
169 return m_nDelayTime;
170}
171AFX_INLINE void CXTPSyntaxEditToolTipCtrl::SetHoverRect(CRect rc)
172{
173 m_rcHover = rc;
174}
175
177
178//{{AFX_INSERT_LOCATION}}
179// Microsoft Visual C++ will insert additional declarations immediately before the previous line.
180
181# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
183#endif // !defined(__XTPSYNTAXEDITTOOLTIPCTRL_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPSyntaxEditCtrl
This class is the main CWnd-based editor class.
Definition XTPSyntaxEditCtrl.h:114
CXTPSyntaxEditToolTipCtrl
The CXTPSyntaxEditToolTipCtrl class encapsulates the functionality of a "tip control,...
Definition XTPSyntaxEditToolTipCtrl.h:52
CXTPSyntaxEditToolTipCtrl::m_strToolTipText
CString m_strToolTipText
Tooltip text.
Definition XTPSyntaxEditToolTipCtrl.h:144
CXTPSyntaxEditToolTipCtrl::m_pParentWnd
CXTPSyntaxEditCtrl * m_pParentWnd
Pointer to the parent report window.
Definition XTPSyntaxEditToolTipCtrl.h:142
CXTPSyntaxEditToolTipCtrl::Hide
void Hide()
Hides the tooltip window.
CXTPSyntaxEditToolTipCtrl::m_nDelayTime
int m_nDelayTime
Delay, in milliseconds, before showing the tooltip.
Definition XTPSyntaxEditToolTipCtrl.h:141
CXTPSyntaxEditToolTipCtrl::GetDelay
int GetDelay() const
Gets the display delay, in milliseconds, of the tooltip.
Definition XTPSyntaxEditToolTipCtrl.h:167
CXTPSyntaxEditToolTipCtrl::CXTPSyntaxEditToolTipCtrl
CXTPSyntaxEditToolTipCtrl()
Constructs a CXTPSyntaxEditToolTipCtrl object.
CXTPSyntaxEditToolTipCtrl::SetHoverRect
void SetHoverRect(CRect rc)
Sets the coordinates of the tooltip hover rectangle.
Definition XTPSyntaxEditToolTipCtrl.h:171
CXTPSyntaxEditToolTipCtrl::Create
virtual BOOL Create(CXTPSyntaxEditCtrl *pParentWnd)
Creates a smart edit tip window.
CXTPSyntaxEditToolTipCtrl::~CXTPSyntaxEditToolTipCtrl
virtual ~CXTPSyntaxEditToolTipCtrl()
Destroys a CXTPSyntaxEditToolTipCtrl object, handles cleanup and de-allocation.
CXTPSyntaxEditToolTipCtrl::m_rcHover
CRect m_rcHover
Hover window coordinates.
Definition XTPSyntaxEditToolTipCtrl.h:143
CXTPSyntaxEditToolTipCtrl::Activate
void Activate(const CString &strText)
Activates the tooltip window.


Toolkit Pro: XTPStatusBarPaneProgress.h Source File

  • Source
  • CommandBars
  • StatusBar
  • Panes
XTPStatusBarPaneProgress.h
Go to the documentation of this file.
1
23#if !defined(__XTPSTATUSBARPANEPROGRESS_H__)
24# define __XTPSTATUSBARPANEPROGRESS_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
39class _XTP_EXT_CLASS CXTPStatusBarProgressPane
40 : public CXTPStatusBarPane
41 , public CXTPProgressBase
42{
44 DECLARE_DYNAMIC(CXTPStatusBarProgressPane)
46public:
51 CXTPStatusBarProgressPane();
52
57 ~CXTPStatusBarProgressPane();
58
59protected:
64 virtual void RedrawProgress();
65
71 virtual CXTPProgressPaintManager* GetProgressPaintManager() const;
72
78 virtual CRect GetProgressRect();
79
86 virtual void OnDraw(CDC* pDC, CRect rcItem);
87
88public:
89# ifdef _XTP_COMMANDBARS_ACTIVEX
91 DECLARE_DISPATCH_MAP()
92 DECLARE_INTERFACE_MAP()
93 DECLARE_OLETYPELIB_EX(CXTPStatusBarProgressPane);
94
95 int OleGetPos();
96 void OleSetPos(int nPos);
97 void OleRedrawProgress();
99# endif
100};
101
103# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
104#endif // !defined(__XTPSTATUSBARPANEPROGRESS_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPProgressBase
CXTPControlProgressBase is base class for all progress objects.
Definition XTPProgressBase.h:40
CXTPProgressPaintManager
CXTPProgressPaintManager object.
Definition XTPProgressPaintManager.h:41
CXTPStatusBarPane
CXTPStatusBarPane is a CXTPCmdTarget derived class.
Definition XTPStatusBarPane.h:39
CXTPStatusBarProgressPane
CXTPStatusBarProgressPane is a CXTPStatusBarPane derived class.
Definition XTPStatusBarPaneProgress.h:42
CXTPStatusBarProgressPane::GetProgressRect
virtual CRect GetProgressRect()
This method is called to get the bounding rectangle of the progressbar.
CXTPStatusBarProgressPane::GetProgressPaintManager
virtual CXTPProgressPaintManager * GetProgressPaintManager() const
This method is called to retrieve a pointer to CXTPProgressPaintManager.
CXTPStatusBarProgressPane::CXTPStatusBarProgressPane
CXTPStatusBarProgressPane()
Constructs a CXTPStatusBarProgressPane object.
CXTPStatusBarProgressPane::RedrawProgress
virtual void RedrawProgress()
This method is called to redraw the progress bar.
CXTPStatusBarProgressPane::OnDraw
virtual void OnDraw(CDC *pDC, CRect rcItem)
This method is called to draw a pane item.
CXTPStatusBarProgressPane::~CXTPStatusBarProgressPane
~CXTPStatusBarProgressPane()
Destroys a CXTPStatusBarProgressPane object, handles cleanup and deallocation.


Toolkit Pro: Member List

XTP_EDIT_TEXTBLOCK Member List

This is the complete list of members for XTP_EDIT_TEXTBLOCK, including all inherited members.

clrBlock | XTP_EDIT_TEXTBLOCK
lf | XTP_EDIT_TEXTBLOCK
nNextBlockPos | XTP_EDIT_TEXTBLOCK
nPos | XTP_EDIT_TEXTBLOCK
XTP_EDIT_TEXTBLOCK() | XTP_EDIT_TEXTBLOCK


Toolkit Pro: Member List

CXTPColorSetStateRibbon Member List

This is the complete list of members for CXTPColorSetStateRibbon, including all inherited members.

clrBack | CXTPColorSetStateButton |
clrBackChecked | CXTPColorSetStateButton |
clrBackCheckedHighlight | CXTPColorSetStateButton |
clrBackDisabled | CXTPColorSetStateButton |
clrBackHighlight | CXTPColorSetStateButton |
clrBackPushed | CXTPColorSetStateButton |
clrBorder | CXTPColorSetStateButton |
clrBorderChecked | CXTPColorSetStateButton |
clrBorderCheckedHighlight | CXTPColorSetStateButton |
clrBorderDisabled | CXTPColorSetStateButton |
clrBorderHighlight | CXTPColorSetStateButton |
clrBorderPushed | CXTPColorSetStateButton |
clrTabBackInactive | CXTPColorSetStateRibbon |
clrTabTextInactive | CXTPColorSetStateRibbon |
clrText | CXTPColorSetStateButton |
clrTextChecked | CXTPColorSetStateButton |
clrTextCheckedHighlight | CXTPColorSetStateButton |
clrTextDisabled | CXTPColorSetStateButton |
clrTextHighlight | CXTPColorSetStateButton |
clrTextPushed | CXTPColorSetStateButton |
CXTPCmdTarget() | CXTPCmdTarget |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
RefreshColors() | CXTPColorSetStateRibbon | virtual


Toolkit Pro: Member List

CXTPSplitterWndThemeVisualStudio2010 Member List

This is the complete list of members for CXTPSplitterWndThemeVisualStudio2010, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPControlTheme() | CXTPControlTheme |
CXTPSplitterWndTheme() | CXTPSplitterWndTheme |
CXTPSplitterWndThemeOffice2003() | CXTPSplitterWndThemeOffice2003 |
CXTPSplitterWndThemeOfficeXP() | CXTPSplitterWndThemeOfficeXP |
CXTPSplitterWndThemeVisualStudio2010() | CXTPSplitterWndThemeVisualStudio2010 |
DrawSplitter(CDC *pDC, CXTPSplitterWnd *pSplitter, int nType, const CRect &rectArg) | CXTPSplitterWndThemeVisualStudio2010 | virtual
EnableTabColors(BOOL bEnable=TRUE) | CXTPSplitterWndTheme |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetThemeStyle() const | CXTPControlTheme |
GetTrackBrush() | CXTPSplitterWndThemeOfficeXP | virtual
m_bTabColors | CXTPSplitterWndTheme |
m_crBack | CXTPSplitterWndTheme |
m_crBoxBack | CXTPSplitterWndTheme |
m_crInnerBorder | CXTPSplitterWndTheme |
m_crInnerBoxBorder | CXTPSplitterWndTheme |
m_crOuterBorder | CXTPSplitterWndTheme |
m_crOuterBoxBorder | CXTPSplitterWndTheme |
m_nTheme | CXTPControlTheme | protected
RefreshMetrics() | CXTPSplitterWndThemeVisualStudio2010 | virtual
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static


Toolkit Pro: Member List

IXTPScrollable Member List

This is the complete list of members for IXTPScrollable, including all inherited members.

CreateBar() const =0 | IXTPScrollable | pure virtual
CreateControl() const =0 | IXTPScrollable | pure virtual
DisableScrollbars()=0 | IXTPScrollable | pure virtual
DisableScrollbars(CWnd &wnd)=0 | IXTPScrollable | pure virtual
FilterExStyle(DWORD dwExStyle) const =0 | IXTPScrollable | pure virtual
FilterStyle(DWORD dwStyle) const =0 | IXTPScrollable | pure virtual
GetWnd()=0 | IXTPScrollable | pure virtual
HasHScroll(DWORD dwStyle, DWORD dwExStyle) const =0 | IXTPScrollable | pure virtual
HasLeftScrollbar(DWORD dwStyle, DWORD dwExStyle) const =0 | IXTPScrollable | pure virtual
HasVScroll(DWORD dwStyle, DWORD dwExStyle) const =0 | IXTPScrollable | pure virtual
RequiresMouseWheelOverriding() const =0 | IXTPScrollable | pure virtual
~IXTPScrollable() | IXTPScrollable | inlinevirtual


Toolkit Pro: XTPGridRecordItemControls.h Source File

  • Source
  • GridControl
XTPGridRecordItemControls.h
Go to the documentation of this file.
1
23#if !defined(__XTPGRIDRECORDITEMCONTROLS_H__)
24# define __XTPGRIDRECORDITEMCONTROLS_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33struct XTP_NM_GRIDRECORDITEM;
34struct XTP_GRIDRECORDITEM_CLICKARGS;
35class CXTPGridRecordItemControl;
36
41enum XTPGridItemControlType
42{
43 xtpItemControlTypeUndefined = 0,
45 xtpItemControlTypeButton = 1,
46};
47
52enum XTPGridItemControlAlignment
53{
54 xtpItemControlUnknown = 0,
55 xtpItemControlLeft = 0x001,
56 xtpItemControlRight = 0x002,
57};
58
69struct XTP_NM_GRIDITEMCONTROL : public XTP_NM_GRIDRECORDITEM
70{
71 CXTPGridRecordItemControl* pItemControl;
72};
73
84class _XTP_EXT_CLASS CXTPGridRecordItemControl : public CXTPCmdTarget
85{
87 DECLARE_SERIAL(CXTPGridRecordItemControl)
89public:
95 CXTPGridRecordItemControl(LPCTSTR szCaption = _T(""));
96
101 virtual ~CXTPGridRecordItemControl();
102
109 virtual void DoPropExchange(CXTPPropExchange* pPX);
110
119 CString GetCaption() const;
120
128 void SetCaption(LPCTSTR szCaption);
129
138 int GetType() const;
139
146 int GetIndex() const;
147
156 CFont* GetFont();
157
165 void SetFont(CFont* pFont);
166
175 COLORREF GetCaptionColor() const;
176
184 void SetCaptionColor(COLORREF clrCaption);
185
194 CSize GetSize() const;
195
206 void SetSize(CSize sizeControl);
207
216 int GetWidth() const;
217
228 void SetWidth(int nWidth);
229
238 int GetHeight() const;
239
250 void SetHeight(int nHeight);
251
259 CRect GetRect() const;
260
269 UINT GetFlags() const;
270
278 void SetFlags(UINT unFlags);
279
288 int GetAlignment() const;
289
297 void SetAlignment(int nAlignment);
298
308 BOOL GetEnable() const;
309
321 void SetEnable(BOOL bEnable);
322
331 int GetState() const;
332
340 void SetState(int nNewState);
341
347 void SetThemed(BOOL bThemed);
348
355 BOOL GetThemed() const;
356
371 void SetIconIndex(int nState, int nIconIndex);
372
382 int GetIconIndex(int nState) const;
383
384protected:
393 void SetRect(CRect rcControl);
394
395public:
406 virtual void OnLButtonDown(XTP_GRIDRECORDITEM_CLICKARGS* pClickArgs)
407 {
408 UNREFERENCED_PARAMETER(pClickArgs);
409 }
410
421 virtual void OnLButtonUp(XTP_GRIDRECORDITEM_CLICKARGS* pClickArgs)
422 {
423 UNREFERENCED_PARAMETER(pClickArgs);
424 }
425
435 virtual void OnMouseEnter(UINT nFlags, CPoint point)
436 {
437 UNREFERENCED_PARAMETER(nFlags);
438 UNREFERENCED_PARAMETER(point);
439 }
440
450 virtual void OnMouseLeave(UINT nFlags, CPoint point)
451 {
452 UNREFERENCED_PARAMETER(nFlags);
453 UNREFERENCED_PARAMETER(point);
454 }
455
464 virtual void OnMouseMove(UINT nFlags, CPoint point)
465 {
466 UNREFERENCED_PARAMETER(nFlags);
467 UNREFERENCED_PARAMETER(point);
468 }
469
470protected:
471 int m_nType;
472 int m_nIndex;
473 CString m_strCaption;
475 CXTPFont m_xtpFontCaption;
476 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CFont, m_fntCaption, m_xtpFontCaption,
477 GetCaptionFontHandle);
478
479 COLORREF m_clrCaption;
480 CSize m_sizeControl;
482 CRect m_rcControl;
483 UINT m_unFlags;
484 XTPGridItemControlAlignment m_Alignment;
486 BOOL m_bEnabled;
487 int m_nState;
488 BOOL m_bThemed;
489 CMap<int, int, int, int> m_mapIcon;
491# ifdef _XTP_ACTIVEX
493 DECLARE_DISPATCH_MAP()
494 DECLARE_INTERFACE_MAP()
495
496 DECLARE_OLETYPELIB_EX(CXTPGridRecordItemControl);
497
498 afx_msg BSTR OleGetCaption();
499 afx_msg void OleSetCaption(LPCTSTR pcszCaption);
500
501 LPFONTDISP OleGetFont();
502 void OleSetFont(LPFONTDISP pFontDisp);
503
504 afx_msg void OleSetSize(long cx, long cy);
505 afx_msg void OleGetRect(long* pnLeft, long* pnTop, long* pnRight, long* pnBottom);
507# endif
508
509 friend class CXTPGridRecordItemControls;
510 friend class CXTPGridRecordItemButton;
511 friend class CXTPGridPaintManager;
512};
513
523class _XTP_EXT_CLASS CXTPGridRecordItemButton : public CXTPGridRecordItemControl
524{
526 DECLARE_SERIAL(CXTPGridRecordItemButton)
529public:
535 CXTPGridRecordItemButton(LPCTSTR szCaption = _T(""));
536
543 virtual void DoPropExchange(CXTPPropExchange* pPX);
544
555 virtual void OnLButtonDown(XTP_GRIDRECORDITEM_CLICKARGS* pClickArgs);
556
567 virtual void OnLButtonUp(XTP_GRIDRECORDITEM_CLICKARGS* pClickArgs);
568
578 virtual void OnMouseEnter(UINT nFlags, CPoint point);
579
589 virtual void OnMouseLeave(UINT nFlags, CPoint point);
590
599 virtual void OnMouseMove(UINT nFlags, CPoint point);
600
601protected:
602 int m_nSavedState;
604# ifdef _XTP_ACTIVEX
606 DECLARE_DISPATCH_MAP()
607 DECLARE_INTERFACE_MAP()
608
609 DECLARE_OLETYPELIB_EX(CXTPGridRecordItemButton);
611# endif
612};
613
618typedef CXTPArrayT<CXTPGridRecordItemControl*, CXTPGridRecordItemControl*, LPDISPATCH>
619 CXTPGridRecordItemControls_base;
620
629class _XTP_EXT_CLASS CXTPGridRecordItemControls : public CXTPGridRecordItemControls_base
630
631// class _XTP_EXT_CLASS CXTPGridRecordItemControls : public
632// CXTPHeapObjectT<CXTPGridRecordItemControls_base, CXTPGridDataAllocator>
633
634{
636 DECLARE_DYNAMIC(CXTPGridRecordItemControls)
637 typedef CXTPGridRecordItemControls_base TBase;
639public:
644 CXTPGridRecordItemControls();
650 CXTPGridRecordItemControls(CXTPGridRecordItem* pRecordItem);
651
657 ~CXTPGridRecordItemControls();
658
665 virtual void DoPropExchange(CXTPPropExchange* pPX);
666
667public:
676 CXTPGridRecordItemControl* AddControl(int nType, int nIndex = -1);
677
686 CXTPGridRecordItemControl* AddControl(CXTPGridRecordItemControl* pControl, int nIndex = -1);
687
698 virtual void RemoveAll();
699
705 virtual void RemoveAt(int nIndex);
706
713 virtual void RemoveAt(int nIndex, int nCount);
714
721 virtual void CopyFrom(CXTPGridRecordItemControls* pSrc);
722
723protected:
730 virtual void RefreshIndexes(int nIndexStart = 0);
731
732public:
733 CXTPGridRecordItem* m_pRecordItem;
735# ifdef _XTP_ACTIVEX
737 DECLARE_DISPATCH_MAP()
738 DECLARE_INTERFACE_MAP()
739
740 DECLARE_OLETYPELIB_EX(CXTPGridRecordItemControls);
741 DECLARE_ENUM_VARIANT(CXTPGridRecordItemControls)
742
743 afx_msg int OleGetCount();
744 afx_msg LPDISPATCH OleAddButton(int nIndex);
745 afx_msg void OleRemoveAt(int nIndex);
746 // afx_msg LPDISPATCH OleGetButton(int nIndex);
747 virtual LPDISPATCH OleGetItem(long nIndex);
749# endif
750};
751
762class _XTP_EXT_CLASS CXTPGridRecordItemControlHookWnd : public CWnd
763{
764public:
771 CXTPGridRecordItemControlHookWnd(XTP_GRIDRECORDITEM_CLICKARGS* pClickArgs);
777 ~CXTPGridRecordItemControlHookWnd();
778
779protected:
781 DECLARE_MESSAGE_MAP()
782
783 afx_msg void OnLButtonDown(UINT nFlags, CPoint point);
784 afx_msg void OnLButtonUp(UINT nFlags, CPoint point);
785 afx_msg void OnMouseMove(UINT nFlags, CPoint point);
788 XTP_GRIDRECORDITEM_CLICKARGS m_ClickArgs;
789};
790
792AFX_INLINE void CXTPGridRecordItemControl::SetCaption(LPCTSTR szCaption)
793{
794 m_strCaption = szCaption;
795}
796AFX_INLINE CString CXTPGridRecordItemControl::GetCaption() const
797{
798 return m_strCaption;
799}
800AFX_INLINE int CXTPGridRecordItemControl::GetType() const
801{
802 return m_nType;
803}
804AFX_INLINE int CXTPGridRecordItemControl::GetIndex() const
805{
806 return m_nIndex;
807}
808AFX_INLINE COLORREF CXTPGridRecordItemControl::GetCaptionColor() const
809{
810 return m_clrCaption;
811}
812AFX_INLINE void CXTPGridRecordItemControl::SetCaptionColor(COLORREF clrCaption)
813{
814 m_clrCaption = clrCaption;
815}
816AFX_INLINE CSize CXTPGridRecordItemControl::GetSize() const
817{
818 return m_sizeControl;
819}
820AFX_INLINE void CXTPGridRecordItemControl::SetSize(CSize sizeControl)
821{
822 m_sizeControl = sizeControl;
823}
824AFX_INLINE int CXTPGridRecordItemControl::GetWidth() const
825{
826 return m_sizeControl.cx;
827}
828AFX_INLINE void CXTPGridRecordItemControl::SetWidth(int nWidth)
829{
830 m_sizeControl.cx = nWidth;
831}
832AFX_INLINE int CXTPGridRecordItemControl::GetHeight() const
833{
834 return m_sizeControl.cy;
835}
836AFX_INLINE void CXTPGridRecordItemControl::SetHeight(int nHeight)
837{
838 m_sizeControl.cy = nHeight;
839}
840AFX_INLINE CRect CXTPGridRecordItemControl::GetRect() const
841{
842 return m_rcControl;
843}
844AFX_INLINE void CXTPGridRecordItemControl::SetFlags(UINT unFlags)
845{
846 m_unFlags = unFlags;
847}
848AFX_INLINE UINT CXTPGridRecordItemControl::GetFlags() const
849{
850 return m_unFlags;
851}
852AFX_INLINE int CXTPGridRecordItemControl::GetAlignment() const
853{
854 return m_Alignment;
855}
856AFX_INLINE void CXTPGridRecordItemControl::SetAlignment(int nAlignment)
857{
858 m_Alignment = (XTPGridItemControlAlignment)nAlignment;
859}
860AFX_INLINE BOOL CXTPGridRecordItemControl::GetEnable() const
861{
862 return m_bEnabled;
863}
864AFX_INLINE void CXTPGridRecordItemControl::SetEnable(BOOL bEnable)
865{
866 m_bEnabled = bEnable;
867}
868AFX_INLINE int CXTPGridRecordItemControl::GetState() const
869{
870 return m_nState;
871}
872AFX_INLINE void CXTPGridRecordItemControl::SetState(int nNewState)
873{
874 m_nState = nNewState;
875}
876AFX_INLINE void CXTPGridRecordItemControl::SetThemed(BOOL bThemed)
877{
878 m_bThemed = bThemed;
879}
880AFX_INLINE BOOL CXTPGridRecordItemControl::GetThemed() const
881{
882 return m_bThemed;
883}
884AFX_INLINE void CXTPGridRecordItemControl::SetIconIndex(int nState, int nIconIndex)
885{
886 m_mapIcon.SetAt(nState, nIconIndex);
887}
888AFX_INLINE void CXTPGridRecordItemControl::SetRect(CRect rcControl)
889{
890 m_rcControl = rcControl;
891}
893# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
894#endif //#if !defined(__XTPGRIDRECORDITEMCONTROLS_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPGridRecordItemControls_base
CXTPArrayT< CXTPGridRecordItemControl *, CXTPGridRecordItemControl *, LPDISPATCH > CXTPGridRecordItemControls_base
This typedef is used to declare a base class for CXTPGridRecordItemControls.
Definition XTPGridRecordItemControls.h:619
XTPGridItemControlAlignment
XTPGridItemControlAlignment
This enum defines alignment styles for the item control.
Definition XTPGridRecordItemControls.h:53
xtpItemControlUnknown
@ xtpItemControlUnknown
Unknown (empty) value.
Definition XTPGridRecordItemControls.h:54
xtpItemControlLeft
@ xtpItemControlLeft
Aligns control to the left.
Definition XTPGridRecordItemControls.h:55
xtpItemControlRight
@ xtpItemControlRight
Aligns control to the right.
Definition XTPGridRecordItemControls.h:56
XTPGridItemControlType
XTPGridItemControlType
This enum defines types for the item control.
Definition XTPGridRecordItemControls.h:42
xtpItemControlTypeUndefined
@ xtpItemControlTypeUndefined
Undefined type.
Definition XTPGridRecordItemControls.h:43
xtpItemControlTypeButton
@ xtpItemControlTypeButton
Button.
Definition XTPGridRecordItemControls.h:45
CXTPArrayT
This class represents a simple array of typed elements.
Definition XTPSmartPtrInternalT.h:490
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPFont
Provides a convenient object oriented interface for HFONT GDI object and uses GDI handle caching.
Definition XTPGdiObjects.h:414
CXTPGridPaintManager
Utility class that handles most drawing activities.
Definition XTPGridPaintManager.h:76
CXTPGridRecordItemButton
This class represents an item button and inherits basic functionality from the CXTPGridRecordItemCont...
Definition XTPGridRecordItemControls.h:524
CXTPGridRecordItemButton::DoPropExchange
virtual void DoPropExchange(CXTPPropExchange *pPX)
Call this member function to store/load a grid item button using the specified data object.
CXTPGridRecordItemButton::OnLButtonUp
virtual void OnLButtonUp(XTP_GRIDRECORDITEM_CLICKARGS *pClickArgs)
Processes mouse left button up clicks.
CXTPGridRecordItemButton::OnLButtonDown
virtual void OnLButtonDown(XTP_GRIDRECORDITEM_CLICKARGS *pClickArgs)
Processes mouse left button down clicks.
CXTPGridRecordItemButton::OnMouseEnter
virtual void OnMouseEnter(UINT nFlags, CPoint point)
Notifies the item control that the mouse cursor has entered the item button's area.
CXTPGridRecordItemButton::CXTPGridRecordItemButton
CXTPGridRecordItemButton(LPCTSTR szCaption=_T(""))
Creates an item button.
CXTPGridRecordItemButton::OnMouseLeave
virtual void OnMouseLeave(UINT nFlags, CPoint point)
Notifies the item control that the mouse cursor has left the item button's area.
CXTPGridRecordItemButton::m_nSavedState
int m_nSavedState
Button state when the mouse cursor leaves the button area.
Definition XTPGridRecordItemControls.h:602
CXTPGridRecordItemButton::OnMouseMove
virtual void OnMouseMove(UINT nFlags, CPoint point)
Processes the move mouse event.
CXTPGridRecordItemControlHookWnd
This class represents an item control hook window.
Definition XTPGridRecordItemControls.h:763
CXTPGridRecordItemControlHookWnd::~CXTPGridRecordItemControlHookWnd
~CXTPGridRecordItemControlHookWnd()
Destroys a CXTPGridRecordItemControlHookWnd object, handles cleanup and deallocation.
CXTPGridRecordItemControlHookWnd::CXTPGridRecordItemControlHookWnd
CXTPGridRecordItemControlHookWnd(XTP_GRIDRECORDITEM_CLICKARGS *pClickArgs)
Constructs a CXTPGridRecordItemControlHookWnd window.
CXTPGridRecordItemControl
This class represents a generic item control and handles control's behaviour, common for all derived ...
Definition XTPGridRecordItemControls.h:85
CXTPGridRecordItemControl::SetWidth
void SetWidth(int nWidth)
Sets the item control width.
Definition XTPGridRecordItemControls.h:828
CXTPGridRecordItemControl::DoPropExchange
virtual void DoPropExchange(CXTPPropExchange *pPX)
Call this member function to store/load a grid item control using the specified data object.
CXTPGridRecordItemControl::GetCaptionColor
COLORREF GetCaptionColor() const
Gets the color of the item control caption.
Definition XTPGridRecordItemControls.h:808
CXTPGridRecordItemControl::SetEnable
void SetEnable(BOOL bEnable)
Enables/disables the item control.
Definition XTPGridRecordItemControls.h:864
CXTPGridRecordItemControl::OnLButtonUp
virtual void OnLButtonUp(XTP_GRIDRECORDITEM_CLICKARGS *pClickArgs)
Processes mouse left button up clicks.
Definition XTPGridRecordItemControls.h:421
CXTPGridRecordItemControl::m_mapIcon
CMap< int, int, int, int > m_mapIcon
Control icon map.
Definition XTPGridRecordItemControls.h:489
CXTPGridRecordItemControl::GetIndex
int GetIndex() const
Gets the item control index.
Definition XTPGridRecordItemControls.h:804
CXTPGridRecordItemControl::m_clrCaption
COLORREF m_clrCaption
Control caption color.
Definition XTPGridRecordItemControls.h:479
CXTPGridRecordItemControl::GetWidth
int GetWidth() const
Gets the item control width.
Definition XTPGridRecordItemControls.h:824
CXTPGridRecordItemControl::OnLButtonDown
virtual void OnLButtonDown(XTP_GRIDRECORDITEM_CLICKARGS *pClickArgs)
Processes mouse left button down clicks.
Definition XTPGridRecordItemControls.h:406
CXTPGridRecordItemControl::SetIconIndex
void SetIconIndex(int nState, int nIconIndex)
Sets the icon index for a specified control state.
Definition XTPGridRecordItemControls.h:884
CXTPGridRecordItemControl::m_sizeControl
CSize m_sizeControl
Control size.
Definition XTPGridRecordItemControls.h:480
CXTPGridRecordItemControl::m_nType
int m_nType
Control type.
Definition XTPGridRecordItemControls.h:471
CXTPGridRecordItemControl::GetType
int GetType() const
Gets the item control type.
Definition XTPGridRecordItemControls.h:800
CXTPGridRecordItemControl::SetFont
void SetFont(CFont *pFont)
Sets the font for the item control caption.
CXTPGridRecordItemControl::GetState
int GetState() const
Gets the item control state.
Definition XTPGridRecordItemControls.h:868
CXTPGridRecordItemControl::SetFlags
void SetFlags(UINT unFlags)
Sets the item control flags.
Definition XTPGridRecordItemControls.h:844
CXTPGridRecordItemControl::SetCaptionColor
void SetCaptionColor(COLORREF clrCaption)
Sets the color of the item control caption.
Definition XTPGridRecordItemControls.h:812
CXTPGridRecordItemControl::GetSize
CSize GetSize() const
Gets the item control size.
Definition XTPGridRecordItemControls.h:816
CXTPGridRecordItemControl::m_nState
int m_nState
Control state.
Definition XTPGridRecordItemControls.h:487
CXTPGridRecordItemControl::m_unFlags
UINT m_unFlags
Control flags.
Definition XTPGridRecordItemControls.h:483
CXTPGridRecordItemControl::m_nIndex
int m_nIndex
Control index.
Definition XTPGridRecordItemControls.h:472
CXTPGridRecordItemControl::SetHeight
void SetHeight(int nHeight)
Sets the item control height.
Definition XTPGridRecordItemControls.h:836
CXTPGridRecordItemControl::OnMouseEnter
virtual void OnMouseEnter(UINT nFlags, CPoint point)
Notifies the item control that the mouse cursor has entered the item control's area.
Definition XTPGridRecordItemControls.h:435
CXTPGridRecordItemControl::GetIconIndex
int GetIconIndex(int nState) const
Retrieves the icon index of a specified item control state.
CXTPGridRecordItemControl::m_Alignment
XTPGridItemControlAlignment m_Alignment
Control alignment.
Definition XTPGridRecordItemControls.h:484
CXTPGridRecordItemControl::SetSize
void SetSize(CSize sizeControl)
Sets the item control size.
Definition XTPGridRecordItemControls.h:820
CXTPGridRecordItemControl::m_bThemed
BOOL m_bThemed
TRUE if control is themed, FALSE otherwise.
Definition XTPGridRecordItemControls.h:488
CXTPGridRecordItemControl::GetAlignment
int GetAlignment() const
Gets the item control alignment.
Definition XTPGridRecordItemControls.h:852
CXTPGridRecordItemControl::SetRect
void SetRect(CRect rcControl)
Sets the item control rectangle (i.e.
Definition XTPGridRecordItemControls.h:888
CXTPGridRecordItemControl::m_xtpFontCaption
CXTPFont m_xtpFontCaption
Control caption font.
Definition XTPGridRecordItemControls.h:475
CXTPGridRecordItemControl::GetFlags
UINT GetFlags() const
Gets the item control flags.
Definition XTPGridRecordItemControls.h:848
CXTPGridRecordItemControl::GetCaption
CString GetCaption() const
Gets the item control caption.
Definition XTPGridRecordItemControls.h:796
CXTPGridRecordItemControl::GetHeight
int GetHeight() const
Gets the item control height.
Definition XTPGridRecordItemControls.h:832
CXTPGridRecordItemControl::SetThemed
void SetThemed(BOOL bThemed)
Specifies the themed state of the item control.
Definition XTPGridRecordItemControls.h:876
CXTPGridRecordItemControl::GetFont
CFont * GetFont()
Gets the font of the item control caption.
CXTPGridRecordItemControl::OnMouseLeave
virtual void OnMouseLeave(UINT nFlags, CPoint point)
Notifies the item control that the mouse cursor has left the item control's area.
Definition XTPGridRecordItemControls.h:450
CXTPGridRecordItemControl::GetThemed
BOOL GetThemed() const
Determines the themed state of the item control.
Definition XTPGridRecordItemControls.h:880
CXTPGridRecordItemControl::SetState
void SetState(int nNewState)
Sets the item control state.
Definition XTPGridRecordItemControls.h:872
CXTPGridRecordItemControl::OnMouseMove
virtual void OnMouseMove(UINT nFlags, CPoint point)
Processes the move mouse event.
Definition XTPGridRecordItemControls.h:464
CXTPGridRecordItemControl::CXTPGridRecordItemControl
CXTPGridRecordItemControl(LPCTSTR szCaption=_T(""))
Creates a CXTPGridRecordItemControl object.
CXTPGridRecordItemControl::GetEnable
BOOL GetEnable() const
Determines if the item control is enabled/disabled.
Definition XTPGridRecordItemControls.h:860
CXTPGridRecordItemControl::GetRect
CRect GetRect() const
Gets the item control rectangle (i.e.
Definition XTPGridRecordItemControls.h:840
CXTPGridRecordItemControl::m_rcControl
CRect m_rcControl
Control rectangle.
Definition XTPGridRecordItemControls.h:482
CXTPGridRecordItemControl::SetAlignment
void SetAlignment(int nAlignment)
Sets the item control alignment.
Definition XTPGridRecordItemControls.h:856
CXTPGridRecordItemControl::~CXTPGridRecordItemControl
virtual ~CXTPGridRecordItemControl()
Destroys a CXTPGridRecordItemControl, handles cleanup and deallocation.
CXTPGridRecordItemControl::m_bEnabled
BOOL m_bEnabled
Control enable flag.
Definition XTPGridRecordItemControls.h:486
CXTPGridRecordItemControl::m_strCaption
CString m_strCaption
Control caption.
Definition XTPGridRecordItemControls.h:473
CXTPGridRecordItemControls
This class represents the inplace controls of a single item.
Definition XTPGridRecordItemControls.h:634
CXTPGridRecordItemControls::m_pRecordItem
CXTPGridRecordItem * m_pRecordItem
Pointer to parent record item.
Definition XTPGridRecordItemControls.h:733
CXTPGridRecordItemControls::AddControl
CXTPGridRecordItemControl * AddControl(int nType, int nIndex=-1)
Adds a new control to the controls list.
CXTPGridRecordItemControls::DoPropExchange
virtual void DoPropExchange(CXTPPropExchange *pPX)
Call this member function to store/load a grid item controls list using the specified data object.
CXTPGridRecordItemControls::~CXTPGridRecordItemControls
~CXTPGridRecordItemControls()
Destroys a CXTPGridRecordItemControls object, handles cleanup and deallocation.
CXTPGridRecordItemControls::CopyFrom
virtual void CopyFrom(CXTPGridRecordItemControls *pSrc)
Copies all controls from a specified CXTPGridRecordItemControls object to this CXTPGridRecordItemCont...
CXTPGridRecordItemControls::RefreshIndexes
virtual void RefreshIndexes(int nIndexStart=0)
Recalculates the indices of all record item controls in the list that appear at or after a specified ...
CXTPGridRecordItemControls::AddControl
CXTPGridRecordItemControl * AddControl(CXTPGridRecordItemControl *pControl, int nIndex=-1)
Adds a new control to the controls list.
CXTPGridRecordItemControls::CXTPGridRecordItemControls
CXTPGridRecordItemControls()
Constructs a CXTPGridRecordItemControls object.
CXTPGridRecordItemControls::CXTPGridRecordItemControls
CXTPGridRecordItemControls(CXTPGridRecordItem *pRecordItem)
Constructs a CXTPGridRecordItemControls object.
CXTPGridRecordItemControls::RemoveAt
virtual void RemoveAt(int nIndex, int nCount)
Removes a control from the list by its index.
CXTPGridRecordItemControls::RemoveAll
virtual void RemoveAll()
Removes all controls from the list.
CXTPGridRecordItemControls::RemoveAt
virtual void RemoveAt(int nIndex)
Removes a control from the list by its index.
CXTPGridRecordItem
Class for working with single list cell.
Definition XTPGridRecordItem.h:600
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72
XTP_GRIDRECORDITEM_CLICKARGS
A set of parameters transferred to mouse click item handlers.
Definition XTPGridRecordItem.h:149
XTP_NM_GRIDITEMCONTROL
This structure is sent to the Main window in a WM_NOTIFY message from the item control and provides a...
Definition XTPGridRecordItemControls.h:70
XTP_NM_GRIDITEMCONTROL::pItemControl
CXTPGridRecordItemControl * pItemControl
Pointer to the item control.
Definition XTPGridRecordItemControls.h:71
XTP_NM_GRIDRECORDITEM
This structure is sent to the Main window in a WM_NOTIFY message from Item and provides all parameter...
Definition XTPGridRecordItem.h:179


Toolkit Pro: Member List

CXTPPopupThemeOffice2013 Member List

This is the complete list of members for CXTPPopupThemeOffice2013, including all inherited members.

CXTPPopupPaintManager() | CXTPPopupPaintManager |
CXTPPopupThemeOffice2000() | CXTPPopupThemeOffice2000 |
CXTPPopupThemeOffice2003() | CXTPPopupThemeOffice2003 |
CXTPPopupThemeOffice2013() | CXTPPopupThemeOffice2013 |
CXTPPopupThemeOfficeXP() | CXTPPopupThemeOfficeXP |
DrawBackground(CDC *pDC, CXTPPopupControl *pControl, CRect rcClient) | CXTPPopupThemeOffice2003 | virtual
DrawButton(CDC *pDC, CXTPPopupItem *pItem) | CXTPPopupPaintManager | virtual
DrawItem(CDC *pDC, CXTPPopupItem *pItem) | CXTPPopupPaintManager |
DrawItemIcon(CDC *pDC, CXTPPopupItem *pItem) | CXTPPopupPaintManager | virtual
m_clrBackground | CXTPPopupPaintManager |
m_clrButtonPressed | CXTPPopupPaintManager |
m_clrButtonPressedBorder | CXTPPopupPaintManager |
m_clrButtonSelected | CXTPPopupPaintManager |
m_clrButtonSelectedBorder | CXTPPopupPaintManager |
m_clrFrame | CXTPPopupPaintManager |
m_clrGripper | CXTPPopupThemeOffice2003 |
m_clrText | CXTPPopupPaintManager |
m_xtpFontText | CXTPPopupPaintManager |
RefreshMetrics() | CXTPPopupThemeOffice2013 | virtual
SetFont(HFONT hFont) | CXTPPopupPaintManager |
~CXTPPopupPaintManager() | CXTPPopupPaintManager | virtual
~CXTPPopupThemeOffice2000() | CXTPPopupThemeOffice2000 | virtual
~CXTPPopupThemeOffice2003() | CXTPPopupThemeOffice2003 | virtual
~CXTPPopupThemeOffice2013() | CXTPPopupThemeOffice2013 | virtual
~CXTPPopupThemeOfficeXP() | CXTPPopupThemeOfficeXP | virtual


Toolkit Pro: XTPTrackThemeOfficeXP.h Source File

  • Source
  • GridControl
  • TrackControl
  • Themes
XTPTrackThemeOfficeXP.h
Go to the documentation of this file.
1
23#if !defined(__XTPTRACKTHEMEOfficeXP_H__)
24# define __XTPTRACKTHEMEOfficeXP_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPTrackThemeOfficeXP : public CXTPTrackPaintManager
39{
40public:
45 CXTPTrackThemeOfficeXP();
46
58 virtual void DrawColumnBackground(CDC* pDC, CXTPGridColumn* pColumn, CRect rcColumn,
59 BOOL& bColumnPressed, BOOL& bDraggingFromHeader,
60 CXTPGridHeader* pHeader = NULL);
61};
63# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
64#endif //#if !defined(__XTPTRACKTHEMEOfficeXP_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPGridColumn
Represents a grid column item with its properties and operations.
Definition XTPGridColumn.h:107
CXTPGridHeader
A grid header is a part of the grid window positioned above columns of text or numbers.
Definition XTPGridHeader.h:173
CXTPTrackPaintManager
This class represents a track control paint manager.
Definition XTPTrackPaintManager.h:41
CXTPTrackThemeOfficeXP
CXTPTrackThemeOfficeXP is a CXTPTrackPaintManager derived class that represents an Office XP style th...
Definition XTPTrackThemeOfficeXP.h:39
CXTPTrackThemeOfficeXP::DrawColumnBackground
virtual void DrawColumnBackground(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, BOOL &bColumnPressed, BOOL &bDraggingFromHeader, CXTPGridHeader *pHeader=NULL)
This method is called to draw the background of a column using the current column style.
CXTPTrackThemeOfficeXP::CXTPTrackThemeOfficeXP
CXTPTrackThemeOfficeXP()
Default paint manager constructor, handles properties initialization.


Toolkit Pro: Member List

CXTPHeaderCtrlTheme Member List

This is the complete list of members for CXTPHeaderCtrlTheme, including all inherited members.

CleanUp(CXTPHeaderCtrl *pHeaderCtrl) | CXTPHeaderCtrlTheme | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPControlTheme() | CXTPControlTheme |
CXTPHeaderCtrlTheme() | CXTPHeaderCtrlTheme |
DrawHeader(CDC *pDC, CXTPHeaderCtrl *pHeaderCtrl) | CXTPHeaderCtrlTheme | virtual
DrawSortArrow(CDC *pDC, LPPOINT ptsArrow, BOOL bAscending) | CXTPHeaderCtrlTheme | protectedvirtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetDrawStyle() const | CXTPHeaderCtrlTheme | virtual
GetThemeStyle() const | CXTPControlTheme |
GetThemeWrapper() | CXTPHeaderCtrlTheme |
HasSortArrow() | CXTPHeaderCtrlTheme |
Layout(LPHDLAYOUT lpHDL, CXTPHeaderCtrl *pHeaderCtrl) | CXTPHeaderCtrlTheme | virtual
m_bUseWinThemes | CXTPHeaderCtrlTheme | protected
m_cr3DDkShadow | CXTPHeaderCtrlTheme | protected
m_cr3DFace | CXTPHeaderCtrlTheme | protected
m_cr3DHighLight | CXTPHeaderCtrlTheme | protected
m_cr3DShadow | CXTPHeaderCtrlTheme | protected
m_crText | CXTPHeaderCtrlTheme | protected
m_dwDrawStyle | CXTPHeaderCtrlTheme | protected
m_iArrowPadding | CXTPHeaderCtrlTheme | protected
m_nTheme | CXTPControlTheme | protected
m_sizeArrow | CXTPHeaderCtrlTheme | protected
m_sizePadding | CXTPHeaderCtrlTheme | protected
m_themeHeader | CXTPHeaderCtrlTheme | protected
OnDrawBackground(LPDRAWITEMSTRUCT lpDIS) | CXTPHeaderCtrlTheme | protectedvirtual
OnDrawBackgroundWinThemed(LPDRAWITEMSTRUCT lpDIS) | CXTPHeaderCtrlTheme | protectedvirtual
OnDrawItemBackground(LPDRAWITEMSTRUCT lpDIS) | CXTPHeaderCtrlTheme | protectedvirtual
OnDrawItemBackgroundWinThemed(LPDRAWITEMSTRUCT lpDIS) | CXTPHeaderCtrlTheme | protectedvirtual
OnDrawItemBitmap(LPDRAWITEMSTRUCT lpDIS, CRect &rcText, CXTPHeaderCtrl *pHeaderCtrl) | CXTPHeaderCtrlTheme | protectedvirtual
OnDrawItemSortArrow(LPDRAWITEMSTRUCT lpDIS, BOOL bAscending) | CXTPHeaderCtrlTheme | protectedvirtual
OnDrawItemText(LPDRAWITEMSTRUCT lpDIS, CXTPHeaderCtrl *pHeaderCtrl) | CXTPHeaderCtrlTheme | protectedvirtual
RefreshMetrics(CXTPHeaderCtrl *pHeader) | CXTPHeaderCtrlTheme | virtual
SetBitmap(int iCol, UINT uBitmapID, BOOL bRemove, COLORREF crMask, CXTPHeaderCtrl *pHeaderCtrl) | CXTPHeaderCtrlTheme | virtual
SetDrawStyle(DWORD dwDrawStyle, CXTPHeaderCtrl *pHeaderCtrl) | CXTPHeaderCtrlTheme | virtual
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static
UseWinXPThemes(CXTPHeaderCtrl *pHeaderCtrl) | CXTPHeaderCtrlTheme | virtual
~CXTPHeaderCtrlTheme() | CXTPHeaderCtrlTheme | virtual


Toolkit Pro: Member List

CXTPGridPaintManager Member List

This is the complete list of members for CXTPGridPaintManager, including all inherited members.

CalcColumnHeight(CDC *pDC, CXTPGridColumn *pColumn, int nTotalWidth=0) | CXTPGridPaintManager | protectedvirtual
CalculateRowHeight(CDC *pDC, const CString &strText, int nMaxWidth, BOOL bWordBreak=TRUE) | CXTPGridPaintManager | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPGridPaintManager() | CXTPGridPaintManager |
DrawBitmap(CDC *pDC, CXTPGridControl *pControl, CRect rcColumn, int iImage) | CXTPGridPaintManager | virtual
DrawCollapsedBitmap(CDC *pDC, const CXTPGridRow *pRow, CRect &rcBitmap) | CXTPGridPaintManager | virtual
DrawColumn(CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn, BOOL bDrawExternal=FALSE, int nShadowWidth=0) | CXTPGridPaintManager | virtual
DrawColumnBackground(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, BOOL &bColumnPressed, BOOL &bDraggingFromHeader, CXTPGridHeader *pHeader=NULL) | CXTPGridPaintManager | protectedvirtual
DrawColumnFooter(CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn) | CXTPGridPaintManager | virtual
DrawColumnFooterDivider(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn) | CXTPGridPaintManager | virtual
DrawColumnIcon(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, CRect rcIcon, int iIcon) | CXTPGridPaintManager | virtual
DrawColumnText(CDC *pDC, CRect rcText, CString strCaption, int nHeaderAlignment, BOOL bIsHeader, BOOL bColumnPressed) | CXTPGridPaintManager | virtual
DrawConnector(CDC *pDC, CPoint ptFrom, CPoint ptTo) | CXTPGridPaintManager |
DrawFocusedRow(CDC *pDC, CRect rcRow) | CXTPGridPaintManager | virtual
DrawFreezeColsDivider(CDC *pDC, const CRect &rc, CXTPGridControl *pControl, CXTPGridRow *pRow=NULL) | CXTPGridPaintManager | virtual
DrawGlyph(CDC *pDC, CRect rcColumn, int iImage) | CXTPGridPaintManager | virtual
DrawGrid(CDC *pDC, XTPGridOrientation orientation, CRect rcGrid) | CXTPGridPaintManager | virtual
DrawGridPattern(CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush) | CXTPGridPaintManager | protectedvirtual
DrawGridPattern(CDC *pDC, CXTPBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush) | CXTPGridPaintManager | protectedvirtual
DrawGridPattern(CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr) | CXTPGridPaintManager | protectedvirtual
DrawGroupRow(CDC *pDC, CXTPGridGroupRow *pRow, CRect rcRow, XTP_GRIDRECORDITEM_METRICS *pMetrics) | CXTPGridPaintManager | virtual
DrawHorizontalLine(CDC *pDC, int xPos, int yPos, int cx, COLORREF clr) | CXTPGridPaintManager |
DrawInplaceButton(CDC *pDC, CXTPGridInplaceButton *pButton) | CXTPGridPaintManager | virtual
DrawInplaceButtonFrame(CDC *pDC, CXTPGridInplaceButton *pButton) | CXTPGridPaintManager | protectedvirtual
DrawInplaceButtonIcon(CDC *pDC, CXTPGridInplaceButton *pButton) | CXTPGridPaintManager | protectedvirtual
DrawInplaceComboButton(CDC *pDC, CRect *pRc) | CXTPGridPaintManager | virtual
DrawInplaceExpandButton(CDC *pDC, CRect *pRc) | CXTPGridPaintManager | virtual
DrawInplaceSpinButton(CDC *pDC, CRect *pRc) | CXTPGridPaintManager | virtual
DrawItemBitmap(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CRect &rcItem, int nImage) | CXTPGridPaintManager | virtual
DrawItemCaption(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics) | CXTPGridPaintManager | virtual
DrawItemControl(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CXTPGridRecordItemControl *pControl, CRect &rcItem) | CXTPGridPaintManager | virtual
DrawLink(int *pnCurrDrawPos, XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CXTPGridHyperlink *pHyperlink, CString strText, CRect rcLink, int nFlag, BOOL bTrim=FALSE) | CXTPGridPaintManager | protectedvirtual
DrawMultiLineText(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, BOOL bWordBreak=TRUE) | CXTPGridPaintManager | protectedvirtual
DrawNoGroupByText(CDC *pDC, CRect rcItem) | CXTPGridPaintManager | virtual
DrawRowNumber(CDC *pDC, CRect rcNumber, CXTPGridRow *pRow) | CXTPGridPaintManager | virtual
DrawSectionDivider(CDC *pDC, const CRect &rc, XTPGridSectionDividerPosition dividerPosition, XTPGridSectionDividerStyle dividerStyle, CXTPPaintManagerColor dividerColor) | CXTPGridPaintManager |
DrawShellIcon(CDC *pDC, CRect rcColumn, int iImage) | CXTPGridPaintManager | virtual
DrawSingleLineText(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nStartPos, int nEndPos, int nActualWidth) | CXTPGridPaintManager | protectedvirtual
DrawString(int *pnCurrDrawPos, CDC *pDC, const CString &strDraw, CRect rcDraw, UINT nFormat) | CXTPGridPaintManager | protectedvirtual
DrawTextLine(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nFlag, int &nCharCounter, int &nHyperlinkCounter) | CXTPGridPaintManager | protectedvirtual
DrawTreeStructure(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CRect rcItem, CSize sizeGlyph) | CXTPGridPaintManager | virtual
DrawTriangle(CDC *pDC, CRect rcTriangle, BOOL bToDown, BOOL bDraggingFromHeader, int nShadowWidth, BOOL bColumnPressed) | CXTPGridPaintManager | virtual
DrawVerticalLine(CDC *pDC, int xPos, int yPos, int cy, COLORREF clr) | CXTPGridPaintManager |
DrawVerticalTimeLineMarker(CDC *pDC, int xPos, CXTPGridControl *pControl, COLORREF color=RGB(0, 255, 0)) | CXTPGridPaintManager | virtual
EnablePreviewMode(BOOL bIsPreviewMode) | CXTPGridPaintManager |
FillFooter(CDC *pDC, CRect rcFooter) | CXTPGridPaintManager | virtual
FillGroupByControl(CDC *pDC, CRect &rcGroupBy) | CXTPGridPaintManager | virtual
FillGroupRowMetrics(CXTPGridGroupRow *pRow, XTP_GRIDRECORDITEM_METRICS *pMetrics, BOOL bPrinting) | CXTPGridPaintManager | virtual
FillHeaderControl(CDC *pDC, CRect rcHeader) | CXTPGridPaintManager | virtual
FillIndent(CDC *pDC, CRect rcRow) | CXTPGridPaintManager | virtual
FillItemShade(CDC *pDC, CRect rcItem) | CXTPGridPaintManager | virtual
FillRow(CDC *pDC, CXTPGridRow *pRow, CRect rcRow) | CXTPGridPaintManager | virtual
FindRowAdjacentToMerged(const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, BOOL bUpward) | CXTPGridPaintManager |
FindRowAdjacentToMergedEx(const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, int &nAdjRowIndex, BOOL bUpward) | CXTPGridPaintManager |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetColumnOffice2007CustomThemeBaseColor() const | CXTPGridPaintManager |
GetColumnStyle() const | CXTPGridPaintManager |
GetControlBackColor(CXTPGridControl *pControl) | CXTPGridPaintManager | virtual
GetFooterHeight(CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0) | CXTPGridPaintManager | virtual
GetFreezeColsDividerStyle() const | CXTPGridPaintManager |
GetGlyphs() const | CXTPGridPaintManager |
GetHeaderHeight() | CXTPGridPaintManager | virtual
GetHeaderHeight(CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0) | CXTPGridPaintManager | virtual
GetItemHeight(XTP_GRIDRECORDITEM_DRAWARGS &drawArgs, int nWidth) | CXTPGridPaintManager |
GetMaxPreviewLines() | CXTPGridPaintManager |
GetPreviewItemHeight(CDC *pDC, CXTPGridRow *pRow, int nWidth, int nHeight) | CXTPGridPaintManager | virtual
GetPreviewLinesCount(CDC *pDC, CRect &rcText, const CString &strText) | CXTPGridPaintManager |
GetRowHeight(CDC *pDC, CXTPGridRow *pRow) | CXTPGridPaintManager | virtual
GetRowHeight(CDC *pDC, CXTPGridRow *pRow, int nTotalWidth) | CXTPGridPaintManager | virtual
GetRowHeightEx(CDC *pDC, CXTPGridRow *pRow, int nTotalWidth, const BOOL firstLevel=TRUE) | CXTPGridPaintManager |
GetSectionDividerHeight(XTPGridFixedRowsDividerStyle dividerStyle) | CXTPGridPaintManager |
GetTextFont() | CXTPGridPaintManager |
IsColumHotTrackingEnabled() const | CXTPGridPaintManager | virtual
IsColumnPlusMinusSign() const | CXTPGridPaintManager |
IsColumnWidthWYSIWYG() const | CXTPGridPaintManager |
IsDrawGridForEmptySpace() const | CXTPGridPaintManager |
IsFixedInplaceButtonHeight() const | CXTPGridPaintManager |
IsFixedRowHeight() const | CXTPGridPaintManager |
IsGridVisible(BOOL bVertical) const | CXTPGridPaintManager |
IsGridVisible(XTPGridOrientation orientation) const | CXTPGridPaintManager |
IsLastColumnWidthWYSIWYG() const | CXTPGridPaintManager |
IsPreviewMode() const | CXTPGridPaintManager |
IsPrintGroupRowIcon() const | CXTPGridPaintManager |
IsShowWYSIWYGMarkers() const | CXTPGridPaintManager |
IsUseDropMarker() const | CXTPGridPaintManager |
LoadGlyphs() | CXTPGridPaintManager | virtual
m_arStartCol | CXTPGridPaintManager |
m_bAllowMergeCells | CXTPGridPaintManager |
m_bBaseTreeIndent | CXTPGridPaintManager |
m_bCleanTooltip | CXTPGridPaintManager |
m_bColumnPlusMinusSign | CXTPGridPaintManager | protected
m_bColumnWidthWYSIWYG | CXTPGridPaintManager | protected
m_bCompactText | CXTPGridPaintManager |
m_bDrawGridForEmptySpace | CXTPGridPaintManager | protected
m_bFixedInplaceButtonHeight | CXTPGridPaintManager | protected
m_bFixedRowHeight | CXTPGridPaintManager | protected
m_bForceDynamicMarkupForCell | CXTPGridPaintManager |
m_bForceShowDropMarker | CXTPGridPaintManager |
m_bForceShowTooltip | CXTPGridPaintManager |
m_bGrayIfDisable | CXTPGridPaintManager |
m_bGroupRowTextBold | CXTPGridPaintManager |
m_bHideSelection | CXTPGridPaintManager |
m_bHotTracking | CXTPGridPaintManager |
m_bInvertColumnOnClick | CXTPGridPaintManager |
m_bIsPreviewMode | CXTPGridPaintManager | protected
m_bLastColumnWidthWYSIWYG | CXTPGridPaintManager | protected
m_bMakeUpper | CXTPGridPaintManager |
m_bMoveScrollbarOnFixedColumnsIndent | CXTPGridPaintManager |
m_bPrintGroupRowIcon | CXTPGridPaintManager | protected
m_bPrintPageRectangle | CXTPGridPaintManager |
m_bPrintSortTriangle | CXTPGridPaintManager |
m_bPrintVirtualPageNumber | CXTPGridPaintManager |
m_bPrintWatermark | CXTPGridPaintManager |
m_bRecOrRowNum | CXTPGridPaintManager |
m_bRevertAlignment | CXTPGridPaintManager |
m_bShadeGroupHeadings | CXTPGridPaintManager |
m_bShadeSortColumn | CXTPGridPaintManager |
m_bShowLockIcon | CXTPGridPaintManager |
m_bShowNonActiveInPlaceButton | CXTPGridPaintManager |
m_bShowWYSIWYGMarkers | CXTPGridPaintManager | protected
m_bSortTriangleOffsetFromRight | CXTPGridPaintManager |
m_bThemedInplaceButtons | CXTPGridPaintManager |
m_bUseAlternativeBackground | CXTPGridPaintManager |
m_bUseDropMarker | CXTPGridPaintManager |
m_bUseEditTextAlignment | CXTPGridPaintManager |
m_bUseGroupRowSelectionState | CXTPGridPaintManager |
m_bUseShellIcon | CXTPGridPaintManager |
m_clrAlternativeBackground | CXTPGridPaintManager |
m_clrBoldText | CXTPGridPaintManager |
m_clrBoldTextHighlight | CXTPGridPaintManager |
m_clrBtnFace | CXTPGridPaintManager |
m_clrBtnFacePressed | CXTPGridPaintManager |
m_clrBtnText | CXTPGridPaintManager |
m_clrCaptionText | CXTPGridPaintManager |
m_clrCaptionTextPressed | CXTPGridPaintManager |
m_clrColumnOffice2007CustomTheme | CXTPGridPaintManager |
m_clrConnector | CXTPGridPaintManager |
m_clrControlBack | CXTPGridPaintManager |
m_clrControlDark | CXTPGridPaintManager |
m_clrControlLightLight | CXTPGridPaintManager |
m_clrDisableBitmapDarkest | CXTPGridPaintManager |
m_clrDisableBitmapLightest | CXTPGridPaintManager |
m_clrFormulaSubSum | CXTPGridPaintManager |
m_clrFormulaSum | CXTPGridPaintManager |
m_clrFreezeColsDivider | CXTPGridPaintManager |
m_clrGradientColumnSeparator | CXTPGridPaintManager |
m_clrGradientColumnShadow | CXTPGridPaintManager |
m_clrGroupBoxBack | CXTPGridPaintManager |
m_clrGroupRowText | CXTPGridPaintManager |
m_clrGroupShadeBack | CXTPGridPaintManager |
m_clrGroupShadeBorder | CXTPGridPaintManager |
m_clrGroupShadeText | CXTPGridPaintManager |
m_clrHeaderControl | CXTPGridPaintManager |
m_clrHighlight | CXTPGridPaintManager |
m_clrHighlightText | CXTPGridPaintManager |
m_clrHotDivider | CXTPGridPaintManager |
m_clrIndentControl | CXTPGridPaintManager |
m_clrItemShade | CXTPGridPaintManager |
m_clrPreviewText | CXTPGridPaintManager |
m_clrSelectedRow | CXTPGridPaintManager |
m_clrSelectedRowText | CXTPGridPaintManager |
m_clrWindowText | CXTPGridPaintManager |
m_columnStyle | CXTPGridPaintManager | protected
m_crlNoGroupByText | CXTPGridPaintManager |
m_grcGradientColumn | CXTPGridPaintManager |
m_grcGradientColumnHot | CXTPGridPaintManager |
m_grcGradientColumnPushed | CXTPGridPaintManager |
m_iRecOrRowStart | CXTPGridPaintManager |
m_nBaseParentRecordIndent | CXTPGridPaintManager |
m_nFixedColumnsIndent | CXTPGridPaintManager |
m_nFooterHeight | CXTPGridPaintManager | protected
m_nFreezeColsDividerStyle | CXTPGridPaintManager | protected
m_nGridLineStylePreviousH | CXTPGridPaintManager | protected
m_nGridLineStylePreviousV | CXTPGridPaintManager | protected
m_nGroupGridLineHeight | CXTPGridPaintManager | protected
m_nGroupGridLineStyle | CXTPGridPaintManager | protected
m_nHeaderHeight | CXTPGridPaintManager | protected
m_nMaxPreviewLines | CXTPGridPaintManager | protected
m_nResizingWidth | CXTPGridPaintManager | protected
m_nRowHeight | CXTPGridPaintManager | protected
m_nRowHeightDefault | CXTPGridPaintManager |
m_nTextIndentForGroupRowsWithNoIcon | CXTPGridPaintManager |
m_nTreeColumnLineLength | CXTPGridPaintManager |
m_nTreeIndent | CXTPGridPaintManager |
m_nTreeStructureStyle | CXTPGridPaintManager |
m_nTreeTextIndent | CXTPGridPaintManager |
m_nTreeTextIndentGroupRow | CXTPGridPaintManager |
m_nTreeTextIndentRowChildren | CXTPGridPaintManager |
m_nTreeTextIndentRowParent | CXTPGridPaintManager |
m_pControl | CXTPGridPaintManager | protected
m_pGlyphs | CXTPGridPaintManager | protected
m_pHyperlinkHoverStyle | CXTPGridPaintManager |
m_pHyperlinkStyle | CXTPGridPaintManager |
m_pMarkupUIElement_NoGroupBy | CXTPGridPaintManager | protected
m_PrintPageWidth | CXTPGridPaintManager |
m_rcPreviewIndent | CXTPGridPaintManager |
m_RecordNumberWidth | CXTPGridPaintManager |
m_strCollapse | CXTPGridPaintManager |
m_strDecreasing | CXTPGridPaintManager |
m_strExpand | CXTPGridPaintManager |
m_strIncreasing | CXTPGridPaintManager |
m_strMarkupUIElement_NoGroupBy | CXTPGridPaintManager | protected
m_strNoFieldsAvailable | CXTPGridPaintManager |
m_strNoGroupBy | CXTPGridPaintManager |
m_strNoItems | CXTPGridPaintManager |
m_strSortBy | CXTPGridPaintManager |
m_szGlyph | CXTPGridPaintManager | protected
m_themeButton | CXTPGridPaintManager | protected
m_themeCombo | CXTPGridPaintManager | protected
m_themeHeader | CXTPGridPaintManager | protected
m_themeSpin | CXTPGridPaintManager | protected
m_treeStructureStyle | CXTPGridPaintManager |
m_xtpBrushGroupGridLineStyle | CXTPGridPaintManager | protected
m_xtpBrushHorizontalGrid | CXTPGridPaintManager | protected
m_xtpBrushTreeStructure | CXTPGridPaintManager | protected
m_xtpBrushVeriticalGrid | CXTPGridPaintManager | protected
m_xtpFontBoldText | CXTPGridPaintManager |
m_xtpFontCaption | CXTPGridPaintManager |
m_xtpFontPreview | CXTPGridPaintManager |
m_xtpFontText | CXTPGridPaintManager |
OnDrawAction(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs) | CXTPGridPaintManager | virtual
RecalcTotalHightOfMergedRows(CXTPGridColumns *pColumns, CDC *pDC, CXTPGridRow *pRow, int nRowHeight, int nTotalWidth) | CXTPGridPaintManager |
RefreshMetrics() | CXTPGridPaintManager | virtual
SetCaptionFont(LOGFONT &lf) | CXTPGridPaintManager |
SetColumnOffice2007CustomThemeBaseColor(COLORREF clrBaseColor) | CXTPGridPaintManager |
SetColumnPlusMinusSign(BOOL bDraw) | CXTPGridPaintManager |
SetColumnStyle(XTPGridColumnStyle columnStyle) | CXTPGridPaintManager |
SetColumnWidthWYSIWYG(BOOL bColumnWidthWYSIWYG) | CXTPGridPaintManager |
SetDrawGridForEmptySpace(BOOL bDrawGrid) | CXTPGridPaintManager |
SetFixedRowHeight(BOOL bFixedRowHeight) | CXTPGridPaintManager |
SetFreezeColsDividerStyle(int nStyle) | CXTPGridPaintManager |
SetGridControl(CXTPGridControl *pControl) | CXTPGridPaintManager | virtual
SetHeaderHeight(int nHeight) | CXTPGridPaintManager | virtual
SetInplaceButtonHeight(BOOL bFixedInplaceButtonHeight) | CXTPGridPaintManager |
SetLastColumnWidthWYSIWYG(BOOL bColumnWidthWYSIWYG) | CXTPGridPaintManager |
SetMaxPreviewLines(int nMaxLines) | CXTPGridPaintManager |
SetPreviewIndent(int nLeft, int nTop, int nRight, int nBottom) | CXTPGridPaintManager |
SetPrintGroupRowIcon(BOOL bDraw) | CXTPGridPaintManager |
SetTextFont(LOGFONT &lf) | CXTPGridPaintManager |
ShowWYSIWYGMarkers(BOOL bSet) | CXTPGridPaintManager |
~CXTPGridPaintManager() | CXTPGridPaintManager | virtual


Toolkit Pro: XTPScrollBarThemeUltraFlat.h Source File

  • Source
  • Common
  • ScrollBar
  • Themes
XTPScrollBarThemeUltraFlat.h
Go to the documentation of this file.
1
23#if !defined(__XTPSCROLLBARTHEMEULTRAFLAT_H__)
24# define __XTPSCROLLBARTHEMEULTRAFLAT_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPScrollBarThemeUltraFlat : public CXTPScrollBarThemeFlat
39{
40protected:
45 virtual void RefreshMetrics();
46};
47
48# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
50#endif /*__XTPSCROLLBARTHEMEULTRAFLAT_H__*/
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPScrollBarThemeFlat
Scrollbar paint manager used to draw flat scrollbars.
Definition XTPScrollBarThemeFlat.h:39
CXTPScrollBarThemeUltraFlat
Scrollbar paint manager used to draw ultra flat scrollbars.
Definition XTPScrollBarThemeUltraFlat.h:39
CXTPScrollBarThemeUltraFlat::RefreshMetrics
virtual void RefreshMetrics()
Recalculates scrollbar metrics.


Toolkit Pro: Member List

CXTPHeapAllocatorT< _TData > Member List

This is the complete list of members for CXTPHeapAllocatorT< _TData >, including all inherited members.

Alloc_mem(size_t nBytes) | CXTPHeapAllocatorT< _TData > | inlinestatic
Free_mem(void *p) | CXTPHeapAllocatorT< _TData > | inlinestatic


Toolkit Pro: Member List

CXTPTrackSelectedBlocks Member List

This is the complete list of members for CXTPTrackSelectedBlocks, including all inherited members.

Add(CXTPTrackBlock *pBlock) | CXTPTrackSelectedBlocks |
CXTPCmdTarget() | CXTPCmdTarget |
CXTPTrackSelectedBlocks() | CXTPTrackSelectedBlocks |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAt(int nIndex) const | CXTPTrackSelectedBlocks |
GetCount() const | CXTPTrackSelectedBlocks |
IsSelected(const CXTPTrackBlock *pBlock) const | CXTPTrackSelectedBlocks |
Remove(CXTPTrackBlock *pBlock) | CXTPTrackSelectedBlocks |
RemoveAll() | CXTPTrackSelectedBlocks |
RemoveAt(int nIndex) | CXTPTrackSelectedBlocks |


Toolkit Pro: XTPDockingPaneThemeVisualStudio2022.h Source File

  • Source
  • DockingPane
  • Themes
XTPDockingPaneThemeVisualStudio2022.h
Go to the documentation of this file.
1
23#if !defined(__XTPDOCKINGPANETHEMEVISUALSTUDIO2022_H__)
24# define __XTPDOCKINGPANETHEMEVISUALSTUDIO2022_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPDockingPaneVisualStudio2022Theme
39 : public CXTPDockingPaneVisualStudio2012Theme
40{
41public:
46 CXTPDockingPaneVisualStudio2022Theme();
47
53 virtual ~CXTPDockingPaneVisualStudio2022Theme();
54
60 virtual void RefreshMetrics();
61
68 virtual void DrawSplitter(CDC* pDC, CXTPDockingPaneSplitterWnd* pSplitter);
69
79 virtual void DrawAutoHidePanel(CDC* pDC, CRect rc, XTPDockingPaneDirection direction);
80
81protected:
91 virtual void DrawTitleBar(CDC* pDC, CXTPDockingPaneBase* pPane, CRect rc, BOOL bVertical);
92
93 COLORREF m_clrCaptionBorder;
94};
95
96# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
98#endif // !defined(__XTPDOCKINGPANETHEMEVISUALSTUDIO2022_H__)
XTPDisableNoisyWarnings.h
XTPDockingPaneDirection
XTPDockingPaneDirection
Docking direction enumeration.
Definition XTPDockingPaneDefines.h:51
XTPEnableNoisyWarnings.h
CXTPDockingPaneBase
CXTPDockingPaneBase is a standalone class.
Definition XTPDockingPaneBase.h:69
CXTPDockingPaneSplitterWnd
CXTPDockingPaneSplitterWnd is a CWnd derived class.
Definition XTPDockingPaneSplitterContainer.h:42
CXTPDockingPaneVisualStudio2012Theme
CXTPDockingPaneVisualStudio2012Theme is used to define drawing routines specific to a Visual Studio 2...
Definition XTPDockingPaneThemeVisualStudio2012.h:41
CXTPDockingPaneVisualStudio2022Theme
CXTPDockingPaneVisualStudio2022Theme is used to define drawing routines specific to a Visual Studio 2...
Definition XTPDockingPaneThemeVisualStudio2022.h:40
CXTPDockingPaneVisualStudio2022Theme::DrawTitleBar
virtual void DrawTitleBar(CDC *pDC, CXTPDockingPaneBase *pPane, CRect rc, BOOL bVertical)
This member function is called to draw a title bar for the docking pane.
CXTPDockingPaneVisualStudio2022Theme::DrawSplitter
virtual void DrawSplitter(CDC *pDC, CXTPDockingPaneSplitterWnd *pSplitter)
Override this method to draw a splitter.
CXTPDockingPaneVisualStudio2022Theme::DrawAutoHidePanel
virtual void DrawAutoHidePanel(CDC *pDC, CRect rc, XTPDockingPaneDirection direction)
This method is called by the framework to draw the docking pane auto-hide panel background and splitt...
CXTPDockingPaneVisualStudio2022Theme::~CXTPDockingPaneVisualStudio2022Theme
virtual ~CXTPDockingPaneVisualStudio2022Theme()
Destroys a CXTPDockingPaneVisualStudio2022Theme object, handles cleanup and deallocation.
CXTPDockingPaneVisualStudio2022Theme::RefreshMetrics
virtual void RefreshMetrics()
This member function is used to initialize default colors for a theme from an .INI resource.
CXTPDockingPaneVisualStudio2022Theme::m_clrCaptionBorder
COLORREF m_clrCaptionBorder
Caption border color.
Definition XTPDockingPaneThemeVisualStudio2022.h:93
CXTPDockingPaneVisualStudio2022Theme::CXTPDockingPaneVisualStudio2022Theme
CXTPDockingPaneVisualStudio2022Theme()
Constructs a CXTPDockingPaneVisualStudio2022Theme object.


Toolkit Pro: Member List

CXTPGridRecordItemCheckbox Member List

This is the complete list of members for CXTPGridRecordItemCheckbox, including all inherited members.

AddHyperlink(CXTPGridHyperlink *pHyperlink) | CXTPGridRecordItem | virtual
Compare(CXTPGridColumn *pColumn, CXTPGridRecordItem *pItem) | CXTPGridRecordItem | virtual
CompareGroupCaption(CXTPGridColumn *pColumn, CXTPGridRecordItem *pItem) | CXTPGridRecordItem | virtual
CompareGroupCaption(CXTPGridColumn *pColumn, CXTPGridGroupRow *pGroupRow) | CXTPGridRecordItem | virtual
CreateBorder() | CXTPGridRecordItem |
CXTPCmdTarget() | CXTPCmdTarget |
CXTPGridRecordItem() | CXTPGridRecordItem |
CXTPGridRecordItemCheckbox(XTPGridCheckState state=xtpGridCheckStateChecked, BOOL bTristateCheckbox=FALSE) | CXTPGridRecordItemCheckbox |
DestroyBorder() | CXTPGridRecordItem |
DoPropExchange(CXTPPropExchange *pPX) | CXTPGridRecordItem | virtual
Draw(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs) | CXTPGridRecordItem | virtual
DrawCheckBox(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CRect &rcItem) | CXTPGridRecordItem | protectedvirtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAlignment() const | CXTPGridRecordItem |
GetBackgroundColor() | CXTPGridRecordItem | virtual
GetBorder() const | CXTPGridRecordItem |
GetCanEditCheckboxItem() const | CXTPGridRecordItem |
GetCaption() | CXTPGridRecordItem | virtual
GetCaption(CXTPGridColumn *pColumn) | CXTPGridRecordItem | virtual
GetCaptionRect(XTP_GRIDRECORDITEM_ARGS *pDrawArgs, CRect &rcItem) | CXTPGridRecordItem | virtual
GetCheckedState() const | CXTPGridRecordItem |
GetColumnCaptionPrefix(CXTPGridColumn *pColumn) const | CXTPGridRecordItem |
GetEditOptions(CXTPGridColumn *pColumn) | CXTPGridRecordItem |
GetFont() | CXTPGridRecordItem | virtual
GetFormatString() const | CXTPGridRecordItem | virtual
GetFormula() const | CXTPGridRecordItem | virtual
GetGroupCaption(CXTPGridColumn *pColumn) | CXTPGridRecordItem | virtual
GetGroupCaptionID(CXTPGridColumn *pColumn) | CXTPGridRecordItem | virtual
GetGroupCaptionValue(CXTPGridColumn *pColumn) | CXTPGridRecordItem | virtual
GetGroupPriority() const | CXTPGridRecordItem | virtual
GetHasCheckbox() const | CXTPGridRecordItem | virtual
GetHyperlinkAt(int nHyperlink) const | CXTPGridRecordItem | virtual
GetHyperlinks() | CXTPGridRecordItem | protected
GetHyperlinksCount() const | CXTPGridRecordItem | virtual
GetIconIndex() const | CXTPGridRecordItem | virtual
GetIndex() const | CXTPGridRecordItem |
GetItemControls() | CXTPGridRecordItem |
GetItemData() const | CXTPGridRecordItem | virtual
GetItemMetrics(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pItemMetrics) | CXTPGridRecordItem | virtual
GetMarkupUIElement() const | CXTPGridRecordItem |
GetRecord() const | CXTPGridRecordItem |
GetSelectedConstraintData(XTP_GRIDRECORDITEM_ARGS *pItemArgs) | CXTPGridRecordItem | virtual
GetSortPriority() const | CXTPGridRecordItem | virtual
GetTextColor() | CXTPGridRecordItem | virtual
GetTooltip() const | CXTPGridRecordItem | virtual
HasCheckbox(BOOL bHasCheckbox, BOOL bTristate=FALSE) | CXTPGridRecordItem | virtual
HitTest(CPoint ptPoint) | CXTPGridRecordItem |
HitTestHyperlink(CPoint ptClick) | CXTPGridRecordItem | virtual
IsBold() const | CXTPGridRecordItem | virtual
IsChecked() const | CXTPGridRecordItem | virtual
IsChildOfMerge() const | CXTPGridRecordItem |
IsEditable() const | CXTPGridRecordItem | virtual
IsFocusable() const | CXTPGridRecordItem | virtual
IsPreviewItem() const | CXTPGridRecordItem | virtual
m_Alignment | CXTPGridRecordItem | protected
m_bBoldText | CXTPGridRecordItem | protected
m_bCanEditCheckboxItem | CXTPGridRecordItem | protected
m_bEditable | CXTPGridRecordItem | protected
m_bFocusable | CXTPGridRecordItem | protected
m_bHasCheckbox | CXTPGridRecordItem | protected
m_bItemControlUnderMouse | CXTPGridRecordItem | protected
m_bTristateCheckbox | CXTPGridRecordItem | protected
m_checkState | CXTPGridRecordItem | protected
m_clrBackground | CXTPGridRecordItem | protected
m_clrText | CXTPGridRecordItem | protected
m_dwData | CXTPGridRecordItem | protected
m_nGroupPriority | CXTPGridRecordItem | protected
m_nIconIndex | CXTPGridRecordItem | protected
m_nSortPriority | CXTPGridRecordItem | protected
m_pBorder | CXTPGridRecordItem | protected
m_pControl | CXTPGridRecordItem | protected
m_pEditOptions | CXTPGridRecordItem | protected
m_pFocusedItemControl | CXTPGridRecordItem | protected
m_pFontCaption | CXTPGridRecordItem | protected
m_pHyperlinks | CXTPGridRecordItem | protected
m_pItemControlHookWnd | CXTPGridRecordItem | protected
m_pItemControls | CXTPGridRecordItem | protected
m_pMarkupUIElement | CXTPGridRecordItem | protected
m_pRecord | CXTPGridRecordItem | protected
m_rcGlyph | CXTPGridRecordItem | protected
m_strCaption | CXTPGridRecordItem | protected
m_strFormatString | CXTPGridRecordItem | protected
m_strFormula | CXTPGridRecordItem | protected
m_strGroupCaption | CXTPGridRecordItem | protected
m_strTooltip | CXTPGridRecordItem | protected
OnBeginEdit(XTP_GRIDRECORDITEM_ARGS *pItemArgs) | CXTPGridRecordItem | protectedvirtual
OnCancelEdit(CXTPGridControl *pControl, BOOL bApply) | CXTPGridRecordItem | virtual
OnChar(XTP_GRIDRECORDITEM_ARGS *pItemArgs, UINT nChar) | CXTPGridRecordItem | protectedvirtual
OnClick(XTP_GRIDRECORDITEM_CLICKARGS *pClickArgs) | CXTPGridRecordItem | virtual
OnConstraintChanged(XTP_GRIDRECORDITEM_ARGS *pItemArgs, CXTPGridRecordItemConstraint *pConstraint) | CXTPGridRecordItem | virtual
OnDblClick(XTP_GRIDRECORDITEM_CLICKARGS *pClickArgs) | CXTPGridRecordItem | virtual
OnDrawCaption(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics) | CXTPGridRecordItem | virtual
OnDrawControls(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CRect &rcItem) | CXTPGridRecordItem | virtual
OnEditCanceled(XTP_GRIDRECORDITEM_ARGS *pItemArgs) | CXTPGridRecordItem | virtual
OnEditChanged(XTP_GRIDRECORDITEM_ARGS *pItemArgs, LPCTSTR szText) | CXTPGridRecordItem | virtual
OnEditChanging(XTP_GRIDRECORDITEM_ARGS *pItemArgs, CString &rstrNewText) | CXTPGridRecordItem | virtual
OnInplaceButtonDown(CXTPGridInplaceButton *pButton) | CXTPGridRecordItem | virtual
OnLButtonDown(XTP_GRIDRECORDITEM_CLICKARGS *pClickArgs) | CXTPGridRecordItem | virtual
OnLButtonUp(XTP_GRIDRECORDITEM_CLICKARGS *pClickArgs) | CXTPGridRecordItem | virtual
OnMouseMove(UINT nFlags, CPoint point, CXTPGridControl *pControl=NULL) | CXTPGridRecordItem | virtual
OnRequestEdit(XTP_GRIDRECORDITEM_ARGS *pItemArgs) | CXTPGridRecordItem | protectedvirtual
OnToolHitTest(CPoint point, TOOLINFO *pTI) | CXTPGridRecordItem | virtual
OnValidateEdit(XTP_GRIDRECORDITEM_ARGS *pItemArgs) | CXTPGridRecordItem | virtual
operator delete(void *p) | CXTPHeapObjectT< CXTPCmdTarget, CXTPGridDataAllocator > | inline
operator new(size_t nSize) | CXTPHeapObjectT< CXTPCmdTarget, CXTPGridDataAllocator > | inline
RemoveHyperlinkAt(int nHyperlink) | CXTPGridRecordItem | virtual
ResetMarkupUIElement() | CXTPGridRecordItem | virtual
SetAlignment(int nAlignment) | CXTPGridRecordItem |
SetBackgroundColor(COLORREF clrBackground) | CXTPGridRecordItem | virtual
SetBold(BOOL bBold=TRUE) | CXTPGridRecordItem | virtual
SetCanEditCheckboxItem(BOOL bSet) | CXTPGridRecordItem |
SetCaption(LPCTSTR strCaption) | CXTPGridRecordItem | virtual
SetChecked(BOOL bChecked) | CXTPGridRecordItem | virtual
SetCheckedState(int iState) | CXTPGridRecordItem |
SetEditable(BOOL bEditable=TRUE) | CXTPGridRecordItem | virtual
SetFocusable(BOOL bFocusable) | CXTPGridRecordItem | virtual
SetFont(CFont *pFont) | CXTPGridRecordItem | virtual
SetFormatString(LPCTSTR strFormat) | CXTPGridRecordItem | virtual
SetFormula(LPCTSTR sFormula) | CXTPGridRecordItem | virtual
SetGridControl(CXTPGridControl *pControl) | CXTPGridRecordItem |
SetGroupCaption(LPCTSTR strCaption) | CXTPGridRecordItem | virtual
SetGroupPriority(int nGroupPriority) | CXTPGridRecordItem | virtual
SetIconIndex(int nIconIndex) | CXTPGridRecordItem | virtual
SetItemData(DWORD_PTR dwData) | CXTPGridRecordItem | virtual
SetRecord(CXTPGridRecord *pGridRecord) | CXTPGridRecordItem |
SetSortPriority(int nSortPriority) | CXTPGridRecordItem | virtual
SetTextColor(COLORREF clrText) | CXTPGridRecordItem | virtual
SetTooltip(LPCTSTR lpszTooltip) | CXTPGridRecordItem | virtual
UpdateValue() | CXTPGridRecordItem |
~CXTPGridRecordItem() | CXTPGridRecordItem | virtual


Toolkit Pro: Member List

CXTPPropertyGridItemFlags Member List

This is the complete list of members for CXTPPropertyGridItemFlags, including all inherited members.

AddChildItem(CXTPPropertyGridItem *pItem) | CXTPPropertyGridItem |
AddComboButton() | CXTPPropertyGridItem |
AddExpandButton() | CXTPPropertyGridItem |
AddSliderControl() | CXTPPropertyGridItem |
AddSpinButton() | CXTPPropertyGridItem |
BindToFlags(int *pBindFlags) | CXTPPropertyGridItemFlags | virtual
BindToString(CString *pBindString) | CXTPPropertyGridItem |
Collapse() | CXTPPropertyGridItem |
CXTPCmdTarget() | CXTPCmdTarget |
CXTPPropertyGridItem(LPCTSTR lpszCaption, LPCTSTR strValue=NULL, CString *pBindString=NULL) | CXTPPropertyGridItem |
CXTPPropertyGridItem(UINT nID, LPCTSTR strValue=NULL, CString *pBindString=NULL) | CXTPPropertyGridItem |
CXTPPropertyGridItemFlags(LPCTSTR strCaption, int nValue=0, int *pBindFlags=NULL) | CXTPPropertyGridItemFlags |
CXTPPropertyGridItemFlags(UINT nID, int nValue=0, int *pBindFlags=NULL) | CXTPPropertyGridItemFlags |
EnsureVisible() | CXTPPropertyGridItem |
Expand() | CXTPPropertyGridItem |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCaption() const | CXTPPropertyGridItem |
GetCaptionMetrics() const | CXTPPropertyGridItem |
GetChilds() const | CXTPPropertyGridItem |
GetConstraintEdit() const | CXTPPropertyGridItem |
GetConstraints() const | CXTPPropertyGridItem |
GetDefaultValue() const | CXTPPropertyGridItem |
GetDescription() const | CXTPPropertyGridItem |
GetDropDownItemCount() const | CXTPPropertyGridItem |
GetEditStyle() const | CXTPPropertyGridItem | virtual
GetFlags() const | CXTPPropertyGridItemFlags | virtual
GetFlagsString() | CXTPPropertyGridItemFlags | protectedvirtual
GetGrid() const | CXTPPropertyGridItem |
GetHeight() const | CXTPPropertyGridItem |
GetID() const | CXTPPropertyGridItem |
GetIndent() const | CXTPPropertyGridItem |
GetIndex() const | CXTPPropertyGridItem |
GetInplaceButtons() const | CXTPPropertyGridItem |
GetInplaceControls() const | CXTPPropertyGridItem |
GetInPlacedEditValue() | CXTPPropertyGridItem | inlineprotectedvirtual
GetInplaceEdit() | CXTPPropertyGridItem | virtual
GetInplaceList() | CXTPPropertyGridItem | protectedvirtual
GetItemData() const | CXTPPropertyGridItem |
GetItemRect() const | CXTPPropertyGridItem |
GetMarkupCaption() const | CXTPPropertyGridItem |
GetMarkupDescription() const | CXTPPropertyGridItem |
GetMarkupTemplate() const | CXTPPropertyGridItem | virtual
GetMarkupValue() const | CXTPPropertyGridItem |
GetMaskedText() const | CXTPPropertyGridItem |
GetMetrics(BOOL bValueMetrics, BOOL bCreate=TRUE) const | CXTPPropertyGridItem |
GetMultiLinesCount() const | CXTPPropertyGridItem |
GetParentItem() const | CXTPPropertyGridItem |
GetReadOnly() const | CXTPPropertyGridItem | virtual
GetTooltip() const | CXTPPropertyGridItem |
GetValue() const | CXTPPropertyGridItem |
GetValueMetrics() const | CXTPPropertyGridItem |
GetValueRect() | CXTPPropertyGridItem | virtual
GetViewValue() | CXTPPropertyGridItem | virtual
HasChilds() const | CXTPPropertyGridItem |
HasParent(CXTPPropertyGridItem *pParent) | CXTPPropertyGridItem |
HasVisibleChilds() const | CXTPPropertyGridItem |
InsertChildItem(int nIndex, CXTPPropertyGridItem *pItem) | CXTPPropertyGridItem |
IsAllowEdit() const | CXTPPropertyGridItem | virtual
IsCategory() const | CXTPPropertyGridItem |
IsExpandable() const | CXTPPropertyGridItem |
IsExpanded() const | CXTPPropertyGridItem |
IsHidden() const | CXTPPropertyGridItem |
IsInplaceButtonVisible(CXTPPropertyGridInplaceButton *pButton) const | CXTPPropertyGridItem | virtual
IsMultiLine() const | CXTPPropertyGridItem |
IsSelected() const | CXTPPropertyGridItem |
IsValueChanged() const | CXTPPropertyGridItem | virtual
IsVisible() const | CXTPPropertyGridItem |
m_bAutoComplete | CXTPPropertyGridItem | protected
m_bCategory | CXTPPropertyGridItem | protected
m_bConstraintEdit | CXTPPropertyGridItem | protected
m_bExpandable | CXTPPropertyGridItem | protected
m_bExpanded | CXTPPropertyGridItem | protected
m_bHidden | CXTPPropertyGridItem | protected
m_bPassword | CXTPPropertyGridItem | protected
m_bReadOnly | CXTPPropertyGridItem | protected
m_bUseMask | CXTPPropertyGridItem | protected
m_bVisible | CXTPPropertyGridItem | protected
m_chPrompt | CXTPPropertyGridItem | protected
m_dwData | CXTPPropertyGridItem | protected
m_dwEditStyle | CXTPPropertyGridItem | protected
m_nDropDownItemCount | CXTPPropertyGridItem | protected
m_nFlags | CXTPPropertyGridItem | protected
m_nHeight | CXTPPropertyGridItem | protected
m_nID | CXTPPropertyGridItem | protected
m_nIndent | CXTPPropertyGridItem | protected
m_nIndex | CXTPPropertyGridItem | protected
m_nLinesCount | CXTPPropertyGridItem | protected
m_nValue | CXTPPropertyGridItemFlags | protected
m_pBindString | CXTPPropertyGridItem | protected
m_pCaptionMetrics | CXTPPropertyGridItem | mutableprotected
m_pChilds | CXTPPropertyGridItem | protected
m_pConstraints | CXTPPropertyGridItem | protected
m_pGrid | CXTPPropertyGridItem | protected
m_pInplaceButtons | CXTPPropertyGridItem | protected
m_pInplaceControls | CXTPPropertyGridItem | protected
m_pMarkupCaption | CXTPPropertyGridItem | protected
m_pMarkupDescription | CXTPPropertyGridItem | protected
m_pMarkupValue | CXTPPropertyGridItem | protected
m_pParent | CXTPPropertyGridItem | protected
m_pValueMetrics | CXTPPropertyGridItem | mutableprotected
m_strCaption | CXTPPropertyGridItem | protected
m_strDefaultValue | CXTPPropertyGridItem | protected
m_strDescription | CXTPPropertyGridItem | protected
m_strFormat | CXTPPropertyGridItem | protected
m_strLiteral | CXTPPropertyGridItem | protected
m_strMarkupTemplate | CXTPPropertyGridItem | protected
m_strMask | CXTPPropertyGridItem | protected
m_strTooltip | CXTPPropertyGridItem | protected
m_strValue | CXTPPropertyGridItem | protected
MeasureItem(LPMEASUREITEMSTRUCT lpMeasureItemStruct) | CXTPPropertyGridItem | virtual
Move(CXTPPropertyGridItem *pParent, int nIndex=-1) | CXTPPropertyGridItem |
NotifyValueChanged() | CXTPPropertyGridItem | protected
OnAddChildItem() | CXTPPropertyGridItem | protectedvirtual
OnAfterEdit(CString &strValue) | CXTPPropertyGridItem | virtual
OnBeforeInsert() | CXTPPropertyGridItemFlags | protectedvirtual
OnCancelEdit() | CXTPPropertyGridItem | virtual
OnCaptionChanged() | CXTPPropertyGridItem | protectedvirtual
OnChar(UINT nChar) | CXTPPropertyGridItem | protectedvirtual
OnConstraintsChanged() | CXTPPropertyGridItemFlags | protectedvirtual
OnDeselect() | CXTPPropertyGridItem | protectedvirtual
OnDrawItemConstraint(CDC *pDC, CXTPPropertyGridItemConstraint *pConstraint, CRect rc, BOOL bSelected) | CXTPPropertyGridItem | virtual
OnDrawItemValue(CDC &dc, CRect rcValue) | CXTPPropertyGridItem | virtual
OnIndexChanged() | CXTPPropertyGridItem | protectedvirtual
OnInpaceControlFocus(BOOL bForward) | CXTPPropertyGridItem | protectedvirtual
OnInplaceButtonDown(CXTPPropertyGridInplaceButton *pButton) | CXTPPropertyGridItem | protectedvirtual
OnKeyDown(UINT nChar) | CXTPPropertyGridItem | protectedvirtual
OnLButtonDblClk(UINT nFlags, CPoint point) | CXTPPropertyGridItem | protectedvirtual
OnLButtonDown(UINT nFlags, CPoint point) | CXTPPropertyGridItem | protectedvirtual
OnLButtonUp(UINT nFlags, CPoint point) | CXTPPropertyGridItem | protectedvirtual
OnMarkupChanged() | CXTPPropertyGridItem | virtual
OnMergeItemConstraint(CDC *pDC, CXTPPropertyGridItemConstraint *pConstraint) | CXTPPropertyGridItem | virtual
OnRButtonDown(UINT nFlags, CPoint point) | CXTPPropertyGridItem | protectedvirtual
OnRequestEdit() | CXTPPropertyGridItem | virtual
OnSelect() | CXTPPropertyGridItem | protectedvirtual
OnValidateEdit() | CXTPPropertyGridItem | virtual
OnValueChanged(CString strValue) | CXTPPropertyGridItem | virtual
PtInValueRect(CPoint point) | CXTPPropertyGridItem | protected
RedrawItem() | CXTPPropertyGridItem |
Remove() | CXTPPropertyGridItem |
ResetValue() | CXTPPropertyGridItem | virtual
Select() | CXTPPropertyGridItem |
SelectNextConstraint() | CXTPPropertyGridItem | protected
SetAutoComplete(BOOL bAutoComplete=TRUE) | CXTPPropertyGridItem |
SetCaption(LPCTSTR lpszCaption) | CXTPPropertyGridItem |
SetConstraintEdit(BOOL bConstraintEdit=TRUE) | CXTPPropertyGridItem |
SetDefaultValue(LPCTSTR lpszDefaultValue) | CXTPPropertyGridItem |
SetDescription(LPCTSTR lpszDescription) | CXTPPropertyGridItem |
SetDropDownItemCount(int nDropDownItemCount) | CXTPPropertyGridItem |
SetEditStyle(DWORD dwEditStyle) | CXTPPropertyGridItem |
SetEditText(const CString &str) | CXTPPropertyGridItem | protectedvirtual
SetExpandable(BOOL bExpandable) | CXTPPropertyGridItem |
SetFlags(int nValue) | CXTPPropertyGridItemFlags | virtual
CXTPPropertyGridItem::SetFlags(UINT nFlags) | CXTPPropertyGridItem |
SetFocusToInplaceControl() | CXTPPropertyGridItem | virtual
SetHeight(int nHeight) | CXTPPropertyGridItem |
SetHidden(BOOL bHidden) | CXTPPropertyGridItem |
SetID(UINT nID) | CXTPPropertyGridItem |
SetItemData(DWORD_PTR dwData) | CXTPPropertyGridItem |
SetMarkupTemplate(LPCTSTR lpstrMarkupTemplate) | CXTPPropertyGridItem |
SetMask(LPCTSTR strMask, LPCTSTR strLiteral, TCHAR chPrompt=_T('_')) | CXTPPropertyGridItem |
SetMaskedText(LPCTSTR lpszMaskedText) | CXTPPropertyGridItem |
SetMultiLinesCount(int nLinesCount) | CXTPPropertyGridItem |
SetPasswordMask(TCHAR chMask=_T(' *')) | CXTPPropertyGridItem |
SetPrompt(LPCTSTR lpszPrompt) | CXTPPropertyGridItem |
SetReadOnly(BOOL bReadOnly) | CXTPPropertyGridItemFlags | protectedvirtual
SetTooltip(LPCTSTR lpstrTooltip) | CXTPPropertyGridItem |
SetValue(CString strValue) | CXTPPropertyGridItemFlags | protectedvirtual
SetVisible(BOOL bVisible) | CXTPPropertyGridItem | protectedvirtual
UpdateChilds() | CXTPPropertyGridItemFlags | protectedvirtual
~CXTPPropertyGridItem() | CXTPPropertyGridItem | virtual
~CXTPPropertyGridItemFlags() | CXTPPropertyGridItemFlags | virtual


Toolkit Pro: Member List

CXTPTabThemeVisualStudio2019 Member List

This is the complete list of members for CXTPTabThemeVisualStudio2019, including all inherited members.

AdjustClientRect(CXTPTabManager *pTabManager, CRect &rcClient) | CXTPTabPaintManagerTheme | virtual
CXTPTabPaintManagerTheme() | CXTPTabPaintManagerTheme |
CXTPTabThemeFlat() | CXTPTabThemeFlat | inline
CXTPTabThemeVisualStudio2015() | CXTPTabThemeVisualStudio2015 |
CXTPTabThemeVisualStudio2017() | CXTPTabThemeVisualStudio2017 |
CXTPTabThemeVisualStudio2019() | CXTPTabThemeVisualStudio2019 |
DrawSingleButton(CDC *pDC, CXTPTabManagerItem *pItem) | CXTPTabThemeVisualStudio2012 | virtual
DrawTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl) | CXTPTabPaintManagerTheme | virtual
DrawText(CDC *pDC, CXTPTabManager *pManager, const CString &str, LPRECT lpRect, UINT nFormat) | CXTPTabPaintManagerTheme | virtual
DrawWorkspacePart(CDC *pDC, LPRECT lpRect, XTPTabWorkspacePart workspacePart) | CXTPTabThemeVisualStudio2012 | virtual
FillButton(CDC *pDC, CXTPTabManagerItem *pItem, LPPOINT pts, int nCount, XTPTabPosition tabPosition, BOOL bAbsolute=FALSE) | CXTPTabPaintManagerTheme |
FillTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl) | CXTPTabThemeFlat | virtual
GetButtonDrawRect(const CXTPTabManagerItem *pItem) | CXTPTabPaintManagerTheme | virtual
GetButtonHeight(const CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetButtonLength(CDC *pDC, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerTheme | virtual
GetClientMargin() | CXTPTabPaintManagerTheme | virtual
GetClientRect(CRect rcControl, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetColorSet() const | CXTPTabPaintManagerTheme |
GetDefaultColorSet() | CXTPTabThemeVisualStudio2019 | inlinevirtual
GetHeaderClipBox(CDC *pDC, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetHeaderHeight(CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme |
GetHeaderMargin() | CXTPTabPaintManagerTheme | virtual
GetHeaderRect(CRect rcControl, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetSupportedColorSets() | CXTPTabPaintManagerTheme | inlinevirtual
m_bButtonsReverseZOrder | CXTPTabPaintManagerTheme | protected
m_nButtonHeight | CXTPTabPaintManagerTheme | protected
m_nRowMargin | CXTPTabPaintManagerTheme |
m_pPaintManager | CXTPTabPaintManagerTheme | protected
m_rcHeaderMargin | CXTPTabPaintManagerTheme |
RefreshMetrics() | CXTPTabThemeVisualStudio2019 | virtual
RepositionTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcClient) | CXTPTabPaintManagerTheme | virtual
~CXTPTabPaintManagerTheme() | CXTPTabPaintManagerTheme | virtual


Toolkit Pro: Member List

CXTPChartTitleAppearance Member List

This is the complete list of members for CXTPChartTitleAppearance, including all inherited members.

ApplyToDeviceContext(CXTPChartDeviceContext *pDC) | CXTPChartElementAppearance | virtual
CXTPChartElement() | CXTPChartElement |
CXTPChartElementAppearance(CXTPChartElement *pOwner) | CXTPChartElementAppearance |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartTitleAppearance(CXTPChartElement *pOwner) | CXTPChartTitleAppearance |
DoPropExchange(CXTPPropExchange *pPX) | CXTPChartTitleAppearance | virtual
GetAppearance() const | CXTPChartElement |
GetContent() const | CXTPChartElement |
GetOwner() const | CXTPChartElement |
Is3D() const | CXTPChartObject |
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartElement | virtual
Release() | CXTPChartElement | virtual
~CXTPChartElement() | CXTPChartElement | virtual
~CXTPChartElementAppearance() | CXTPChartElementAppearance | virtual


Toolkit Pro: XTPScrollable.h Source File

  • Source
  • Common
  • ScrollBar
XTPScrollable.h
Go to the documentation of this file.
1
23#if !defined(__XTPSCROLLABLE_H__)
24# define __XTPSCROLLABLE_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
35struct IXTPScrollable;
36
37class _XTP_EXT_CLASS CXTPScrollHost
38{
39public:
40 explicit CXTPScrollHost();
41 ~CXTPScrollHost();
42
43protected:
44 BOOL InitializeScrollHost(IXTPScrollable* pScrollable, DWORD dwInitialStyle,
45 DWORD dwInitialExStyle);
46 void UninitializeScrollHost();
47 void SetScrollBarTheme(XTPScrollBarTheme nTheme);
48 void EnableDefaultBorderDrawing(BOOL bEnable);
49 BOOL IsScrollHostInitialized() const;
50 BOOL OnHostWndMsg(UINT message, WPARAM wParam, LPARAM lParam, LRESULT* pResult);
51 BOOL OnHostDefWindowProc(UINT message, WPARAM wParam, LPARAM lParam, LRESULT* pResult);
52 LRESULT SendControlMessage(UINT message, WPARAM wParam, LPARAM lParam);
53 CWnd* GetEmbeddedControl();
54
55private:
56 CScrollBar* CreateBar(DWORD style, CWnd* pParent);
57 void Layout();
58 void SynchronizeScrollBar(int nBar, PBOOL pbRequiresLayout = NULL, BOOL bInInit = FALSE);
59 static LRESULT CALLBACK CtrlWndProc(HWND hwnd, UINT uMsg, WPARAM wParam, LPARAM lParam);
60 LRESULT OnCtrlWndProc(HWND hwnd, UINT uMsg, WPARAM wParam, LPARAM lParam);
61 BOOL OnStyleChanging(WPARAM wParam, LPARAM lParam, LRESULT* pResult);
62 BOOL OnNotify(WPARAM wParam, LPARAM lParam, LRESULT* pResult);
63 BOOL OnScroll(UINT message, WPARAM wParam, LPARAM lParam, LRESULT* pResult);
64 void FilterStyles();
65# ifdef _XTP_INCLUDE_CONTROLS
66 BOOL OnSetTheme(WPARAM wParam, LPARAM lParam, LRESULT* pResult);
67# endif
68 BOOL OnCtrlMouseWheel(WPARAM wParam, LPARAM lParam, LRESULT* pResult);
69 BOOL OnCtrlMouseHWheel(WPARAM wParam, LPARAM lParam, LRESULT* pResult);
70
71private:
72 IXTPScrollable* m_pScrollable;
73 CScrollBar* m_bars[2];
74 SCROLLINFO m_scrollInfo[2];
75 BOOL m_bLeftBar;
76 BOOL m_bInitialized;
77 CWnd* m_pControl;
78 WNDPROC m_pfnCtrlProc;
79 CWnd m_oldControl;
80 CWnd* m_pGapCtrl;
81 BOOL m_bEnableDefaultBorder;
82 int m_nAccumulatedWheelDelta;
83 int m_nAccumulatedHWheelDelta;
84 BOOL m_bInLayout;
85 DWORD m_dwCurrentCtlStyle;
86 DWORD m_dwCurrentCtlExStyle;
87
88 static CFont m_Font;
89 static CXTPGlobalAtom m_propAtom;
90};
91
92AFX_INLINE BOOL CXTPScrollHost::IsScrollHostInitialized() const
93{
94 return m_bInitialized;
95}
96
97AFX_INLINE CWnd* CXTPScrollHost::GetEmbeddedControl()
98{
99 return m_pControl;
100}
101
112struct IXTPScrollable
113{
118 virtual ~IXTPScrollable()
119 {
120 }
121
128 virtual CWnd& GetWnd() = 0;
129
140 virtual BOOL HasVScroll(DWORD dwStyle, DWORD dwExStyle) const = 0;
141
152 virtual BOOL HasHScroll(DWORD dwStyle, DWORD dwExStyle) const = 0;
153
166 virtual BOOL HasLeftScrollbar(DWORD dwStyle, DWORD dwExStyle) const = 0;
167
173 virtual void DisableScrollbars() = 0;
174
181 virtual void DisableScrollbars(CWnd& wnd) = 0;
182
190 virtual CScrollBar* CreateBar() const = 0;
191
199 virtual CWnd* CreateControl() const = 0;
200
210 virtual DWORD FilterStyle(DWORD dwStyle) const = 0;
211
221 virtual DWORD FilterExStyle(DWORD dwExStyle) const = 0;
222
233 virtual BOOL RequiresMouseWheelOverriding() const = 0;
234};
235
244template<class Base>
245class CXTPScrollable
246 : public Base
247 , public CXTPScrollHost
248 , public IXTPScrollable
249{
250public:
255 CXTPScrollable();
256
257# if (1310 < _MSC_VER)
258 using Base::Create;
259 using Base::CreateEx;
260# endif
261
285 virtual BOOL Create(LPCTSTR lpszClassName, LPCTSTR lpszWindowName, DWORD dwStyle,
286 const RECT& rect, CWnd* pParentWnd, UINT nID,
287 CCreateContext* pContext = NULL);
288
314 virtual BOOL CreateEx(DWORD dwExStyle, LPCTSTR lpszClassName, LPCTSTR lpszWindowName,
315 DWORD dwStyle, int x, int y, int nWidth, int nHeight, HWND hWndParent,
316 HMENU nIDorHMenu, LPVOID lpParam = NULL);
317
339 virtual BOOL CreateEx(DWORD dwExStyle, LPCTSTR lpszClassName, LPCTSTR lpszWindowName,
340 DWORD dwStyle, const RECT& rect, CWnd* pParentWnd, UINT nID,
341 LPVOID lpParam = NULL);
342
352 BOOL InitScrollBars();
353
359 void SetScrollBarTheme(XTPScrollBarTheme nTheme);
360
367 void EnableDefaultBorderDrawing(BOOL bEnable = TRUE);
368
369private:
370 virtual CWnd& GetWnd();
371 virtual BOOL HasVScroll(DWORD dwStyle, DWORD dwExStyle) const;
372 virtual BOOL HasHScroll(DWORD dwStyle, DWORD dwExStyle) const;
373 virtual BOOL HasLeftScrollbar(DWORD dwStyle, DWORD dwExStyle) const;
374 virtual void DisableScrollbars();
375 virtual void DisableScrollbars(CWnd& wnd);
376 virtual CScrollBar* CreateBar() const;
377 virtual CWnd* CreateControl() const;
378 virtual DWORD FilterStyle(DWORD dwStyle) const;
379 virtual DWORD FilterExStyle(DWORD dwStyle) const;
380 virtual BOOL RequiresMouseWheelOverriding() const;
381
383protected:
384 virtual void PreSubclassWindow();
385 virtual BOOL OnWndMsg(UINT message, WPARAM wParam, LPARAM lParam, LRESULT* pResult);
386 virtual LRESULT DefWindowProc(UINT message, WPARAM wParam, LPARAM lParam);
389private:
390 DWORD m_dwInitialStyle;
391 DWORD m_dwInitialExStyle;
392};
394template<class Base>
395AFX_INLINE CXTPScrollable<Base>::CXTPScrollable()
396 : m_dwInitialStyle(0)
397 , m_dwInitialExStyle(0)
398{
399}
400
401template<class Base>
402AFX_INLINE BOOL CXTPScrollable<Base>::Create(LPCTSTR lpszClassName, LPCTSTR lpszWindowName,
403 DWORD dwStyle, const RECT& rect, CWnd* pParentWnd,
404 UINT nID, CCreateContext* pContext /*= NULL*/)
405{
406 if (0 == m_dwInitialStyle)
407 m_dwInitialStyle = dwStyle | WS_CHILD;
408
409 // The window being created will be destroyed right away so it should be OK to bypass
410 // Base::Create call and call CWnd::Create directly.
411 if (!CWnd::Create(lpszClassName, lpszWindowName, dwStyle & ~WS_VISIBLE, rect, pParentWnd, nID,
412 pContext))
413 return FALSE;
414
415 if (!IsScrollHostInitialized())
416 {
417 VERIFY(CXTPScrollHost::InitializeScrollHost(this, m_dwInitialStyle, 0));
418 m_dwInitialStyle = 0;
419 }
420
421 return TRUE;
422}
423
424template<class Base>
425AFX_INLINE BOOL CXTPScrollable<Base>::CreateEx(DWORD dwExStyle, LPCTSTR lpszClassName,
426 LPCTSTR lpszWindowName, DWORD dwStyle, int x, int y,
427 int nWidth, int nHeight, HWND hWndParent,
428 HMENU nIDorHMenu, LPVOID lpParam /*= NULL*/)
429{
430 if (0 == m_dwInitialStyle)
431 m_dwInitialStyle = dwStyle | WS_CHILD;
432 if (0 == m_dwInitialExStyle)
433 m_dwInitialExStyle = dwExStyle;
434
435 // The window being created will be destroyed right away so it should be OK to bypass
436 // Base::CreateEx call and call CWnd::CreateEx directly.
437 if (!CWnd::CreateEx(dwExStyle, lpszClassName, lpszWindowName, dwStyle & ~WS_VISIBLE, x, y,
438 nWidth, nHeight, hWndParent, nIDorHMenu, lpParam))
439 return FALSE;
440
441 if (!IsScrollHostInitialized())
442 {
443 VERIFY(CXTPScrollHost::InitializeScrollHost(this, m_dwInitialStyle, m_dwInitialExStyle));
444 m_dwInitialStyle = 0;
445 m_dwInitialExStyle = 0;
446 }
447
448 return TRUE;
449}
450
451template<class Base>
452AFX_INLINE BOOL CXTPScrollable<Base>::CreateEx(DWORD dwExStyle, LPCTSTR lpszClassName,
453 LPCTSTR lpszWindowName, DWORD dwStyle,
454 const RECT& rect, CWnd* pParentWnd, UINT nID,
455 LPVOID lpParam /*= NULL*/)
456{
457 if (0 == m_dwInitialStyle)
458 m_dwInitialStyle = dwStyle | WS_CHILD;
459 if (0 == m_dwInitialExStyle)
460 m_dwInitialExStyle = dwExStyle;
461
462 // The window being created will be destroyed right away so it should be OK to bypass
463 // Base::CreateEx call and call CWnd::CreateEx directly.
464 if (!CWnd::CreateEx(dwExStyle, lpszClassName, lpszWindowName, dwStyle & ~WS_VISIBLE, rect,
465 pParentWnd, nID, lpParam))
466 return FALSE;
467
468 if (!IsScrollHostInitialized())
469 {
470 VERIFY(CXTPScrollHost::InitializeScrollHost(this, m_dwInitialStyle, m_dwInitialExStyle));
471 m_dwInitialStyle = 0;
472 m_dwInitialExStyle = 0;
473 }
474
475 return TRUE;
476}
477
478template<class Base>
479AFX_INLINE BOOL CXTPScrollable<Base>::InitScrollBars()
480{
481 if (IsScrollHostInitialized())
482 return TRUE;
483
484 _ASSERTE(::IsWindow(*this));
485 return CXTPScrollHost::InitializeScrollHost(this, CObject::GetStyle(), CObject::GetExStyle());
486}
487
488template<class Base>
489AFX_INLINE void CXTPScrollable<Base>::SetScrollBarTheme(XTPScrollBarTheme nTheme)
490{
491 CXTPScrollHost::SetScrollBarTheme(nTheme);
492}
493
494template<class Base>
495AFX_INLINE void CXTPScrollable<Base>::EnableDefaultBorderDrawing(BOOL bEnable /*= TRUE*/)
496{
497 CXTPScrollHost::EnableDefaultBorderDrawing(bEnable);
498}
499
500template<class Base>
501AFX_INLINE CWnd& CXTPScrollable<Base>::GetWnd()
502{
503 return *this;
504}
505
506template<class Base>
507AFX_INLINE BOOL CXTPScrollable<Base>::HasVScroll(DWORD dwStyle, DWORD dwExStyle) const
508{
509 UNREFERENCED_PARAMETER(dwExStyle);
510 return 0 != (dwStyle & WS_VSCROLL);
511}
512
513template<class Base>
514AFX_INLINE BOOL CXTPScrollable<Base>::HasHScroll(DWORD dwStyle, DWORD dwExStyle) const
515{
516 UNREFERENCED_PARAMETER(dwExStyle);
517 return 0 != (dwStyle & WS_HSCROLL);
518}
519
520template<class Base>
521AFX_INLINE BOOL CXTPScrollable<Base>::HasLeftScrollbar(DWORD dwStyle, DWORD dwExStyle) const
522{
523 UNREFERENCED_PARAMETER(dwStyle);
524 return 0 != (dwExStyle & WS_EX_LEFTSCROLLBAR);
525}
526
527template<class Base>
528AFX_INLINE void CXTPScrollable<Base>::DisableScrollbars()
529{
530 DisableScrollbars(*this);
531}
532
533template<class Base>
534AFX_INLINE void CXTPScrollable<Base>::DisableScrollbars(CWnd& wnd)
535{
536 wnd.ModifyStyle(WS_VSCROLL | WS_HSCROLL, 0);
537 wnd.ModifyStyleEx(WS_EX_LEFTSCROLLBAR, 0);
538}
539
540template<class Base>
541AFX_INLINE CScrollBar* CXTPScrollable<Base>::CreateBar() const
542{
543 return new CXTPScrollBarCtrl();
544}
545
546template<class Base>
547AFX_INLINE CWnd* CXTPScrollable<Base>::CreateControl() const
548{
549 return new Base();
550}
551
552template<class Base>
553AFX_INLINE DWORD CXTPScrollable<Base>::FilterStyle(DWORD dwStyle) const
554{
555 return dwStyle;
556}
557
558template<class Base>
559AFX_INLINE DWORD CXTPScrollable<Base>::FilterExStyle(DWORD dwExStyle) const
560{
561 return dwExStyle;
562}
563
564template<class Base>
565AFX_INLINE BOOL CXTPScrollable<Base>::RequiresMouseWheelOverriding() const
566{
567 return FALSE;
568}
569
570template<class Base>
571AFX_INLINE void CXTPScrollable<Base>::PreSubclassWindow()
572{
573 Base::PreSubclassWindow();
574
575 if (!IsScrollHostInitialized())
576 {
577 // If window has coordinates it is assumed the window is fully
578 // created and the calls is not made from HCBT_CREATEWND.
579 CRect rc;
580 ::GetWindowRect(CXTPScrollable<Base>::m_hWnd, &rc);
581 if (0 != rc.top || 0 != rc.left || 0 != rc.bottom || 0 != rc.right)
582 VERIFY(CXTPScrollHost::InitializeScrollHost(this, CXTPScrollable<Base>::GetStyle(),
583 CXTPScrollable<Base>::GetExStyle()));
584 }
585}
586
587template<class Base>
588AFX_INLINE LRESULT CXTPScrollable<Base>::DefWindowProc(UINT message, WPARAM wParam, LPARAM lParam)
589{
590 if (!IsScrollHostInitialized())
591 return Base::DefWindowProc(message, wParam, lParam);
592
593 LRESULT lResult = 0;
594 if (CXTPScrollHost::OnHostDefWindowProc(message, wParam, lParam, &lResult))
595 return lResult;
596
597 return ::DefWindowProc(CXTPScrollable<Base>::m_hWnd, message, wParam, lParam);
598}
599
600template<class Base>
601AFX_INLINE BOOL CXTPScrollable<Base>::OnWndMsg(UINT message, WPARAM wParam, LPARAM lParam,
602 LRESULT* pResult)
603{
604 if (!IsScrollHostInitialized())
605 return Base::OnWndMsg(message, wParam, lParam, pResult);
606
607 if (CXTPScrollHost::OnHostWndMsg(message, wParam, lParam, pResult))
608 return TRUE;
609
610 // Base implementation must not be called as the control is already stolen.
611 return CWnd::OnWndMsg(message, wParam, lParam, pResult);
612}
614# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
616#endif // !defined(__XTPSCROLLABLE_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPScrollBarTheme
XTPScrollBarTheme
Scrollbar theme identifier enum.
Definition XTPScrollBase.h:87
CXTPGlobalAtom
A helper class for handling a global atom primitive.
Definition XTPSystemHelpers.h:3160
CXTPScrollBarCtrl
Scrollbar control.
Definition XTPScrollBarCtrl.h:48
CXTPScrollable
The adaptor class for a scrollable control for which standard scroll bars have to be overriden.
Definition XTPScrollable.h:249
CXTPScrollable::SetScrollBarTheme
void SetScrollBarTheme(XTPScrollBarTheme nTheme)
Sets custom scroll bars theme.
CXTPScrollable::CreateEx
virtual BOOL CreateEx(DWORD dwExStyle, LPCTSTR lpszClassName, LPCTSTR lpszWindowName, DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID, LPVOID lpParam=NULL)
Creates a scrollable control window.
CXTPScrollable::CXTPScrollable
CXTPScrollable()
Initializes a scrollable object instance.
CXTPScrollable::CreateEx
virtual BOOL CreateEx(DWORD dwExStyle, LPCTSTR lpszClassName, LPCTSTR lpszWindowName, DWORD dwStyle, int x, int y, int nWidth, int nHeight, HWND hWndParent, HMENU nIDorHMenu, LPVOID lpParam=NULL)
Creates a scrollable control window.
CXTPScrollable::EnableDefaultBorderDrawing
void EnableDefaultBorderDrawing(BOOL bEnable=TRUE)
Enables or disables default border drawing for a host control.
CXTPScrollable::InitScrollBars
BOOL InitScrollBars()
Performs one time custom scroll bars intitialization.
CXTPScrollable::Create
virtual BOOL Create(LPCTSTR lpszClassName, LPCTSTR lpszWindowName, DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID, CCreateContext *pContext=NULL)
Creates a scrollable control window.
IXTPScrollable
This interface is to be implemented only by special scrollable controls that require overriding of sc...
Definition XTPScrollable.h:113
IXTPScrollable::CreateBar
virtual CScrollBar * CreateBar() const =0
Creates a new scroll bar object.
IXTPScrollable::GetWnd
virtual CWnd & GetWnd()=0
Obtains scrollable control window reference.
IXTPScrollable::CreateControl
virtual CWnd * CreateControl() const =0
Creates a close instance of the control itself.
IXTPScrollable::RequiresMouseWheelOverriding
virtual BOOL RequiresMouseWheelOverriding() const =0
Determines if mouse wheel handling logic must be overridden by scroll host when a hosted control is n...
IXTPScrollable::FilterExStyle
virtual DWORD FilterExStyle(DWORD dwExStyle) const =0
Filters supplied extended window style if needed.
IXTPScrollable::DisableScrollbars
virtual void DisableScrollbars()=0
Disables/removes standard scroll bars so that custom scroll bars created via this interface could be ...
IXTPScrollable::~IXTPScrollable
virtual ~IXTPScrollable()
Handles object destruction.
Definition XTPScrollable.h:118
IXTPScrollable::HasHScroll
virtual BOOL HasHScroll(DWORD dwStyle, DWORD dwExStyle) const =0
Returns TRUE if the control has horizontal scroll bar for the combination of styles specified.
IXTPScrollable::HasVScroll
virtual BOOL HasVScroll(DWORD dwStyle, DWORD dwExStyle) const =0
Returns TRUE if the control has vertical scroll bar for the combination of styles specified.
IXTPScrollable::FilterStyle
virtual DWORD FilterStyle(DWORD dwStyle) const =0
Filters supplied window style if needed.
IXTPScrollable::DisableScrollbars
virtual void DisableScrollbars(CWnd &wnd)=0
Disables/removes standard scroll bars so that custom scroll bars created via this interface could be ...
IXTPScrollable::HasLeftScrollbar
virtual BOOL HasLeftScrollbar(DWORD dwStyle, DWORD dwExStyle) const =0
Returns TRUE if the control has vertical scroll bar on the left side for the combination of styles sp...


Toolkit Pro: XTPSkinManagerApiHook.h Source File

  • Source
  • SkinFramework
XTPSkinManagerApiHook.h
Go to the documentation of this file.
1
23#if !defined(__XTPSKINMANAGERAPIHOOK_H__)
24# define __XTPSKINMANAGERAPIHOOK_H__
25
26# if _MSC_VER > 1000
27# pragma once
28# endif // _MSC_VER > 1000
29
30# include "SkinFramework/ApiHook/XTPSkinManagerApiHookConfig.h"
31
32# if !defined(_XTP_ACTIVEX) && defined(XTP_SKINFRAMEWORK_USE_DETOURS_API_HOOK) \
33 && defined(XTP_SKINFRAMEWORK_USE_LEGACY_API_HOOK)
34# error Only one implementation of SkinManager API Hook is allowed.
35# endif
36
37# include "SkinFramework/ApiHook/XTPSkinManagerApiHookBase.h"
38
39# ifdef XTP_SKINFRAMEWORK_USE_DETOURS_API_HOOK
40# include "SkinFramework/ApiHook/XTPSkinManagerDetoursApiHook.h"
41# endif
42# ifdef XTP_SKINFRAMEWORK_USE_LEGACY_API_HOOK
43# include "SkinFramework/ApiHook/XTPSkinManagerLegacyApiHook.h"
44# endif
45
46#endif // !defined(__XTPSKINMANAGERAPIHOOK_H__)
47
XTPSkinManagerApiHookBase.h
XTPSkinManagerApiHookConfig.h
XTPSkinManagerDetoursApiHook.h
XTPSkinManagerLegacyApiHook.h


Toolkit Pro: XTPTypeId.h Source File

  • Source
  • Common
XTPTypeId.h
Go to the documentation of this file.
1
23#if !defined(_XTPTYPEID_H_)
24# define _XTPTYPEID_H_
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPTypeId
34{
35public:
36 explicit CXTPTypeId(DWORD_PTR id);
37 CXTPTypeId(const CXTPTypeId& rhs);
38
39 BOOL operator==(const CXTPTypeId& rhs) const;
40 BOOL operator!=(const CXTPTypeId& rhs) const;
41
42private:
43 DWORD_PTR m_id;
44};
45
46AFX_INLINE CXTPTypeId::CXTPTypeId(DWORD_PTR id)
47 : m_id(id)
48{
49}
50
51AFX_INLINE CXTPTypeId::CXTPTypeId(const CXTPTypeId& rhs)
52 : m_id(rhs.m_id)
53{
54}
55
56AFX_INLINE BOOL CXTPTypeId::operator==(const CXTPTypeId& rhs) const
57{
58 return m_id == rhs.m_id;
59}
60
61AFX_INLINE BOOL CXTPTypeId::operator!=(const CXTPTypeId& rhs) const
62{
63 return m_id != rhs.m_id;
64}
65
66template<class This, class Parent>
67class CXTPTypeIdProvider;
68
69class _XTP_EXT_CLASS CXTPTypeIdProviderBase
70{
71# if _MSC_VER > 1200
72protected:
73 template<class T, class U>
74 friend class CXTPTypeIdProvider;
75# else
76public:
77# endif
78
79 struct DerivedList
80 {
81 DerivedList(CXTPTypeId derivedTypeId, CXTPTypeIdProviderBase* pTypeProvider,
82 void* pInstance, DerivedList* pFLink);
83
84 CXTPTypeId derivedTypeId;
85 CXTPTypeIdProviderBase* pTypeProvider;
86 void* pInstance;
87 DerivedList* pFLink;
88 };
89
90 explicit CXTPTypeIdProviderBase(CXTPTypeId typeId);
91 virtual ~CXTPTypeIdProviderBase();
92
93 virtual CXTPTypeId GetTypeId() const;
94 void AddDerived(CXTPTypeId typeId, CXTPTypeIdProviderBase* pTypeProvider, void* pInstance);
95
96 template<class T>
97 AFX_INLINE T* TryCast() const;
98
99 void* TryCastTo(CXTPTypeId typeId) const;
100
101 const CXTPTypeId m_typeId;
102 DerivedList* m_pDerivedList;
103};
104
105template<class This, class Parent = This>
106class CXTPTypeIdProvider
107 :
108# if _MSC_VER > 1200
109 private CXTPTypeIdProviderBase
110{
111 template<class T, class U>
112 friend class CXTPTypeIdProvider;
113
114protected:
115# else
116 public CXTPTypeIdProviderBase
117{
118public:
119# endif
120
121 typedef CXTPTypeIdProvider<This, Parent> XTPTypeIdProvider;
122
123 CXTPTypeIdProvider();
124
125public:
126 using CXTPTypeIdProviderBase::GetTypeId;
127 using CXTPTypeIdProviderBase::TryCastTo;
128};
129
130template<class T>
131class CXTPTypeIdOf
132{
133public:
134 static CXTPTypeId AFX_CDECL Id();
135};
136
137template<class T>
138AFX_INLINE T* CXTPTypeIdProviderBase::TryCast() const
139{
140 return reinterpret_cast<T*>(TryCastTo(CXTPTypeIdOf<T>::Id()));
141}
142
143template<class This, class Parent>
144AFX_INLINE CXTPTypeIdProvider<This, Parent>::CXTPTypeIdProvider()
145 : CXTPTypeIdProviderBase(CXTPTypeIdOf<This>::Id())
146{
147 typename Parent::XTPTypeIdProvider* pParent = static_cast<typename Parent::XTPTypeIdProvider*>(
148 static_cast<This*>(this));
149 pParent->AddDerived(GetTypeId(), this, static_cast<This*>(this));
150}
151
152template<class T>
153AFX_INLINE CXTPTypeId AFX_CDECL CXTPTypeIdOf<T>::Id()
154{
155 static const CXTPTypeId id(reinterpret_cast<DWORD_PTR>(&CXTPTypeIdOf<T>::Id));
156 return id;
157}
158
159# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
161#endif // !defined(_XTPTYPEID_H_)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h


Toolkit Pro: Member List

CXTPEditThemeOffice2013 Member List

This is the complete list of members for CXTPEditThemeOffice2013, including all inherited members.

AdjustBuddyRect(CWnd *pBuddy, CRect &rcUpDown, int nAlignment) | CXTPEditThemeOfficeXP | virtual
CtlColor(CDC *pDC, UINT nCtlColor, CXTPEdit *pEdit) | CXTPEditThemeDefault | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPControlTheme() | CXTPControlTheme |
CXTPEditTheme() | CXTPEditTheme |
CXTPEditThemeDefault() | CXTPEditThemeDefault |
CXTPEditThemeOffice2000() | CXTPEditThemeOffice2000 |
CXTPEditThemeOffice2013() | CXTPEditThemeOffice2013 |
CXTPEditThemeOfficeXP() | CXTPEditThemeOfficeXP |
DrawBuddyBorders(CWnd *pBuddy, CDC *pDC, CRect rc, int nAlignment, CXTPEdit *pEdit) | CXTPEditThemeOfficeXP | virtual
CXTPEditThemeOffice2000::DrawBuddyBorders(CDC *pDC, CRect rc, int nAlignment, CXTPEdit *pEdit) | CXTPEditThemeOffice2000 | virtual
DrawFrame(CDC *pDC, CRect rc, int nSize, CBrush *pBrush) | CXTPEditTheme | virtual
DrawNcBorders(CDC *pDC, CRect rcWnd, CXTPEdit *pEdit) | CXTPEditThemeOfficeXP | virtual
DrawNcBordersDefault(CDC *pDC, CRect rcWnd, CXTPEdit *pEdit) | CXTPEditThemeDefault | protectedvirtual
DrawNcScrollBack(CDC *pDC, CRect rcWnd, CXTPEdit *pEdit) | CXTPEditThemeDefault | virtual
FillRect(CDC *pDC, int x, int y, int cx, int cy, CBrush *pBrush) | CXTPEditTheme | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetClientBrush(CDC *pDC, CXTPEdit *pEdit) | CXTPEditTheme | virtual
GetThemeID() const | CXTPEditTheme |
GetThemeStyle() const | CXTPControlTheme |
IsFlatStyle() const | CXTPEditTheme |
m_bFlatStyle | CXTPEditTheme | protected
m_bUseWinTheme | CXTPEditTheme | protected
m_clrBack | CXTPEditTheme |
m_clrBackNonClient | CXTPEditTheme |
m_clrBorder | CXTPEditTheme |
m_clrBorderDisabled | CXTPEditThemeOfficeXP | protected
m_clrBorderHilite | CXTPEditThemeOfficeXP | protected
m_clrText | CXTPEditTheme |
m_clrTextReadOnly | CXTPEditTheme |
m_nTheme | CXTPEditTheme | protected
m_winTheme | CXTPEditTheme | protected
m_xtpBrushBack | CXTPEditTheme |
RedrawFocusedFrame() const | CXTPEditThemeOfficeXP | virtual
RefreshMetrics(CXTPEdit *pEdit) | CXTPEditThemeOffice2013 | virtual
SetFlatStyle(BOOL bFlatStyle) | CXTPEditTheme |
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static
UseWinTheme(BOOL bUseWinTheme) | CXTPEditTheme |
~CXTPEditTheme() | CXTPEditTheme | virtual
~CXTPEditThemeDefault() | CXTPEditThemeDefault | virtual
~CXTPEditThemeOffice2000() | CXTPEditThemeOffice2000 | virtual
~CXTPEditThemeOffice2013() | CXTPEditThemeOffice2013 | virtual
~CXTPEditThemeOfficeXP() | CXTPEditThemeOfficeXP | virtual


Toolkit Pro: Member List

CXTPColorHex Member List

This is the complete list of members for CXTPColorHex, including all inherited members.

ColorFromPoint(CPoint point) | CXTPColorHex |
CreateCellArray() | CXTPColorHex | protected
CRgnCellList typedef | CXTPColorHex | protected
CXTPColorHex() | CXTPColorHex |
GetColorCell(int iIndex) | CXTPColorHex |
GetColorCell(COLORREF color) | CXTPColorHex |
GetSelectedColor() const | CXTPColorHex |
Init() | CXTPColorHex | protectedvirtual
IsValidColor(COLORREF color) const | CXTPColorHex | protectedvirtual
m_bmpPicker | CXTPColorHex | protected
m_bPreSubclassInit | CXTPColorHex | protected
m_clrColor | CXTPColorHex | protected
m_pCell | CXTPColorHex | protected
m_rgnList | CXTPColorHex | protected
SetSelectedColor(int iIndex, BOOL bNotify=TRUE) | CXTPColorHex |
SetSelectedColor(COLORREF color, BOOL bNotify=TRUE) | CXTPColorHex |
UpdateSelection(CPoint point, BOOL bNotify=TRUE) | CXTPColorHex | protected
UpdateSelection(CRgnCell *pCell, BOOL bNotify=TRUE) | CXTPColorHex | protected
~CXTPColorHex() | CXTPColorHex | virtual


Toolkit Pro: Member List

CXTPDockingPaneVisualStudio2005Theme Member List

This is the complete list of members for CXTPDockingPaneVisualStudio2005Theme, including all inherited members.

AdjustCaptionRect(const CXTPDockingPaneSidePanel *pPane, CRect &rc) | CXTPDockingPanePaintManager | virtual
AdjustCaptionRect(const CXTPDockingPaneTabbedContainer *pPane, CRect &rc) | CXTPDockingPanePaintManager | virtual
AdjustClientRect(CXTPDockingPaneSidePanel *pPane, CRect &rect) | CXTPDockingPanePaintManager | virtual
AdjustClientRect(CXTPDockingPaneTabbedContainer *pPane, CRect &rect, BOOL bApply) | CXTPDockingPanePaintManager | virtual
ClipAndAddEllipsisIfNeeded(CDC *pDC, CString &strTitle, int nCaptionWidth) const | CXTPDockingPanePaintManager | protected
CXTPCmdTarget() | CXTPCmdTarget |
CXTPDockingPaneDefaultTheme() | CXTPDockingPaneDefaultTheme |
CXTPDockingPaneGripperedTheme() | CXTPDockingPaneGripperedTheme |
CXTPDockingPanePaintManager() | CXTPDockingPanePaintManager | protected
CXTPDockingPaneVisualStudio2003Theme() | CXTPDockingPaneVisualStudio2003Theme |
CXTPDockingPaneVisualStudio2005Beta1Theme() | CXTPDockingPaneVisualStudio2005Beta1Theme |
CXTPDockingPaneVisualStudio2005Beta2Theme() | CXTPDockingPaneVisualStudio2005Beta2Theme |
CXTPDockingPaneVisualStudio2005Theme() | CXTPDockingPaneVisualStudio2005Theme |
DrawAutoHidePanel(CDC *pDC, CRect rc, XTPDockingPaneDirection direction) | CXTPDockingPanePaintManager | virtual
DrawCaption(CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc) | CXTPDockingPaneGripperedTheme | virtual
DrawCaptionButton(CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton) | CXTPDockingPanePaintManager | virtual
DrawCaptionButtonEntry(CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton, CSize szOffset) | CXTPDockingPanePaintManager | protectedvirtual
DrawCaptionButtonEntry(CDC *pDC, CXTPDockingPaneCaptionButton *pButton, CPoint pt, COLORREF clrButton) | CXTPDockingPanePaintManager | protectedvirtual
DrawCaptionButtons(CDC *pDC, CXTPDockingPaneCaptionButtons *pButtons, CRect &rcCaption, COLORREF clr, int nButtonSize, int nButtonGap, BOOL bVertical=FALSE) | CXTPDockingPanePaintManager | virtual
DrawCaptionPart(CDC *pDC, CXTPDockingPaneBase *pPane, CRect rcCaption, const CString &strTitle, BOOL bActive, BOOL bVertical) | CXTPDockingPaneVisualStudio2003Theme | protectedvirtual
DrawCaptionText(CDC *pDC, const CString &strTitle, CRect rc, BOOL bVertical, BOOL bCalcWidth=FALSE) | CXTPDockingPanePaintManager |
DrawFloatingFrame(CDC *pDC, CXTPDockingPaneMiniWnd *pPane, CRect rc) | CXTPDockingPaneGripperedTheme | virtual
DrawPane(CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc) | CXTPDockingPanePaintManager | virtual
DrawSidePanel(CDC *pDC, CXTPDockingPaneSidePanel *pPane, CRect rc) | CXTPDockingPaneDefaultTheme | virtual
DrawSplitter(CDC *pDC, CXTPDockingPaneSplitterWnd *pSplitter) | CXTPDockingPanePaintManager | virtual
FillCaptionPart(CDC *pDC, CXTPDockingPaneBase *pPane, CRect rcCaption, BOOL bActive, BOOL bVertical) | CXTPDockingPaneVisualStudio2005Beta2Theme | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCaptionButtonStyle() const | CXTPDockingPanePaintManager |
GetCaptionGripperRect(const CXTPDockingPaneTabbedContainer *pPane) | CXTPDockingPanePaintManager | virtual
GetCaptionHeight() const | CXTPDockingPanePaintManager |
GetCaptionRect(const CXTPDockingPaneTabbedContainer *pPane, CRect &rc) | CXTPDockingPanePaintManager | virtual
GetCurrentSystemTheme() const | CXTPDockingPanePaintManager |
GetCustomTitleBrush(BOOL bActive, BOOL bVertical) const | CXTPDockingPanePaintManager |
GetPaneCaptionRect(const CXTPDockingPaneSidePanel *pPane) | CXTPDockingPanePaintManager | virtual
GetPanelPaintManager() const | CXTPDockingPanePaintManager |
GetSplitterStyle() const | CXTPDockingPanePaintManager |
GetTabPaintManager() const | CXTPDockingPanePaintManager |
GetTabsHeight() const | CXTPDockingPanePaintManager |
GetXtremeColor(UINT nIndex) | CXTPDockingPanePaintManager |
Line(CDC *pDC, int x0, int y0, int x1, int y1, int nPen) | CXTPDockingPanePaintManager |
Line(CDC *pDC, int x0, int y0, int x1, int y1) | CXTPDockingPanePaintManager |
m_arrColor | CXTPDockingPanePaintManager | protected
m_bDestroyCustomTitleBrushes | CXTPDockingPanePaintManager | protected
m_bDrawCaptionIcon | CXTPDockingPanePaintManager |
m_bDrawSingleTab | CXTPDockingPanePaintManager |
m_bGradientCaption | CXTPDockingPaneVisualStudio2003Theme | protected
m_bHighlightActiveCaption | CXTPDockingPanePaintManager |
m_bLunaTheme | CXTPDockingPanePaintManager | protected
m_bShowCaption | CXTPDockingPanePaintManager |
m_bUseBoldCaptionFont | CXTPDockingPanePaintManager |
m_bUseOfficeFont | CXTPDockingPanePaintManager | protected
m_bUseStandardFont | CXTPDockingPanePaintManager | protected
m_clrActiveCaption | CXTPDockingPanePaintManager |
m_clrActiveCaptionText | CXTPDockingPanePaintManager |
m_clrBackground | CXTPDockingPanePaintManager |
m_clrCaptionBorder | CXTPDockingPaneVisualStudio2005Beta2Theme | protected
m_clrDisabledCaptionText | CXTPDockingPanePaintManager |
m_clrNormalCaption | CXTPDockingPanePaintManager |
m_clrNormalCaptionText | CXTPDockingPanePaintManager |
m_clrSplitter | CXTPDockingPanePaintManager |
m_clrSplitterGradient | CXTPDockingPanePaintManager |
m_clrSplitterGripper | CXTPDockingPanePaintManager |
m_dwSplitterStyle | CXTPDockingPanePaintManager | protected
m_hbrActiveTitleHorz | CXTPDockingPanePaintManager | protected
m_hbrActiveTitleVert | CXTPDockingPanePaintManager | protected
m_hbrInactiveTitleHorz | CXTPDockingPanePaintManager | protected
m_hbrInactiveTitleVert | CXTPDockingPanePaintManager | protected
m_nCaptionButtonStyle | CXTPDockingPanePaintManager | protected
m_nCaptionFontGap | CXTPDockingPanePaintManager | protected
m_nSplitterIndent | CXTPDockingPanePaintManager |
m_nSplitterSize | CXTPDockingPanePaintManager |
m_nTabsHeight | CXTPDockingPanePaintManager | protected
m_nTitleHeight | CXTPDockingPanePaintManager | protected
m_pPanelPaintManager | CXTPDockingPanePaintManager | protected
m_pTabPaintManager | CXTPDockingPanePaintManager | protected
m_rcCaptionMargin | CXTPDockingPanePaintManager | protected
m_strOfficeFont | CXTPDockingPanePaintManager | protected
m_systemTheme | CXTPDockingPanePaintManager | protected
m_themeButton | CXTPDockingPanePaintManager | protected
m_themeCurrent | CXTPDockingPanePaintManager | protected
m_themeExplorer | CXTPDockingPanePaintManager | protected
m_themeRebar | CXTPDockingPanePaintManager | protected
m_themeToolbar | CXTPDockingPanePaintManager | protected
m_themeWindow | CXTPDockingPanePaintManager | protected
m_xtpFontTitle | CXTPDockingPanePaintManager | protected
m_xtpFontTitleVertical | CXTPDockingPanePaintManager | protected
Pixel(CDC *pDC, int xPos, int yPos, int nPen) | CXTPDockingPanePaintManager |
Rectangle(CDC *pDC, CRect rc, int nPenEntry, int nPenBorder) | CXTPDockingPanePaintManager |
RefreshMetrics() | CXTPDockingPaneVisualStudio2005Beta2Theme | virtual
SetCaptionButtonStyle(XTPDockingPaneCaptionButtonStyle nStyle) | CXTPDockingPanePaintManager |
SetCaptionFontIndirect(LOGFONT *pLogFont, BOOL bUseStandardFont=FALSE) | CXTPDockingPanePaintManager |
SetColors(int cElements, CONST INT *lpaElements, CONST COLORREF *lpaRgbValues) | CXTPDockingPanePaintManager |
SetCustomTitleBrushes(HBRUSH hbrActiveTitleHorz, HBRUSH hbrInactiveTitleHorz=NULL, HBRUSH hbrActiveTitleVert=NULL, HBRUSH hbrInactiveTitleVert=NULL, BOOL bDestroyOnCleanup=FALSE) | CXTPDockingPanePaintManager |
SetLunaTheme(XTPCurrentSystemTheme systemTheme) | CXTPDockingPanePaintManager |
SetPanelPaintManager(CXTPTabPaintManager *pManager) | CXTPDockingPanePaintManager |
SetSplitterStyle(DWORD dwStyle) | CXTPDockingPanePaintManager |
SetTabPaintManager(CXTPTabPaintManager *pManager) | CXTPDockingPanePaintManager |
UseOfficeFont(BOOL bUseOfficeFont) | CXTPDockingPanePaintManager |
~CXTPDockingPanePaintManager() | CXTPDockingPanePaintManager | protectedvirtual


Toolkit Pro: Member List

CXTPCalendarDayViewTimeScale Member List

This is the complete list of members for CXTPCalendarDayViewTimeScale, including all inherited members.

AdjustLayout(CDC *pDC) | CXTPCalendarDayViewTimeScale | virtual
CalcWidth(CDC *pDC) | CXTPCalendarDayViewTimeScale |
CXTPCalendarDayViewTimeScale(CXTPCalendarDayView *pDayView, BOOL bVisible=TRUE, BOOL bDrawNowLine=TRUE) | CXTPCalendarDayViewTimeScale |
CXTPCmdTarget() | CXTPCmdTarget |
Draw(CDC *pDC) | CXTPCalendarDayViewTimeScale |
Format(COleDateTime dtTime, BOOL bTopCell, CString *pHour=NULL, CString *pMin=NULL) | CXTPCalendarDayViewTimeScale | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCaption() const | CXTPCalendarDayViewTimeScale |
GetDayView() const | CXTPCalendarDayViewTimeScale |
GetScaleInterval() const | CXTPCalendarDayViewTimeScale |
GetTimeshift() const | CXTPCalendarDayViewTimeScale |
GetVisible() const | CXTPCalendarDayViewTimeScale |
GetWidth() const | CXTPCalendarDayViewTimeScale |
HitTestDateTime(XTP_CALENDAR_HITTESTINFO *pHitTest) const | CXTPCalendarDayViewTimeScale |
IsDrawNowLine() const | CXTPCalendarDayViewTimeScale | virtual
m_bDrawNowLine | CXTPCalendarDayViewTimeScale |
m_bVisible | CXTPCalendarDayViewTimeScale | protected
m_Layout | CXTPCalendarDayViewTimeScale | protected
m_nTimeshift_min | CXTPCalendarDayViewTimeScale | protected
m_pDayView | CXTPCalendarDayViewTimeScale | protected
m_strCaption | CXTPCalendarDayViewTimeScale | protected
MoveTo(int nXPos) | CXTPCalendarDayViewTimeScale |
ResetCustomTimeFormat() | CXTPCalendarDayViewTimeScale |
SetCaption(LPCTSTR strCaption) | CXTPCalendarDayViewTimeScale |
SetCustomTimeFormat(BOOL bAmPm, BOOL bLeadingZero=TRUE, const CString &separator=_T(":"), const CString &am=_T("am"), const CString &pm=_T("pm")) | CXTPCalendarDayViewTimeScale |
SetTimeshift(int nMinutes) | CXTPCalendarDayViewTimeScale |
SetVisible(BOOL bVisible) | CXTPCalendarDayViewTimeScale |
~CXTPCalendarDayViewTimeScale() | CXTPCalendarDayViewTimeScale | virtual


Toolkit Pro: Member List

CXTPChartStackedSplineAreaSeriesStyle Member List

This is the complete list of members for CXTPChartStackedSplineAreaSeriesStyle, including all inherited members.

ApplyTo(CXTPChartDeviceCommand *pCommand) | CXTPChartSeriesStyle | virtual
CorrectAxisSideMargins(CXTPChartAxis *pAxis, double nMinValue, double nMaxValue, double &nCorrection) | CXTPChartSeriesStyle | virtual
CreateDiagram() | CXTPChartDiagram2DSeriesStyle | virtual
CreateView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView) | CXTPChartStackedSplineAreaSeriesStyle | protectedvirtual
CXTPChartAreaSeriesStyle() | CXTPChartAreaSeriesStyle |
CXTPChartDiagram2DSeriesStyle() | CXTPChartDiagram2DSeriesStyle |
CXTPChartElement() | CXTPChartElement |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartPointSeriesStyle() | CXTPChartPointSeriesStyle |
CXTPChartSeriesStyle() | CXTPChartSeriesStyle |
CXTPChartStackedAreaSeriesStyle() | CXTPChartStackedAreaSeriesStyle |
CXTPChartStackedSplineAreaSeriesStyle() | CXTPChartStackedSplineAreaSeriesStyle |
DoPropExchange(CXTPPropExchange *pPX) | CXTPChartAreaSeriesStyle | virtual
Enable3dEdgeSmoothing(BOOL bEnable=TRUE) | CXTPChartSeriesStyle | virtual
Get3dRotation() const | CXTPChartSeriesStyle | virtual
GetAppearance() const | CXTPChartElement |
GetColor() const | CXTPChartSeriesStyle | virtual
GetContent() const | CXTPChartElement |
GetErrorBar() const | CXTPChartSeriesStyle | virtual
GetFillAcrossXAxis() const | CXTPChartAreaSeriesStyle |
GetFillStyle() const | CXTPChartAreaSeriesStyle |
GetLabel() const | CXTPChartSeriesStyle | virtual
GetMarker() const | CXTPChartPointSeriesStyle |
GetOwner() const | CXTPChartElement |
GetSeriesPointValueIndex() const | CXTPChartSeriesStyle | virtual
GetStyleAppearance() const | CXTPChartSeriesStyle | virtual
GetTransparency() const | CXTPChartAreaSeriesStyle | virtual
Is3D() const | CXTPChartObject |
Is3dEdgeSmoothingEnabled() const | CXTPChartSeriesStyle | virtual
IsColorEach() const | CXTPChartSeriesStyle | virtual
IsStyleDiagram(CXTPChartDiagram *pDiagram) const | CXTPChartDiagram2DSeriesStyle | virtual
m_bColorEach | CXTPChartSeriesStyle | protected
m_bSmooth3dEdges | CXTPChartSeriesStyle | protected
m_clrColor | CXTPChartSeriesStyle | protected
m_nAxisIndexX | CXTPChartDiagram2DSeriesStyle | protected
m_nAxisIndexY | CXTPChartDiagram2DSeriesStyle | protected
m_nFillAcrossXAxis | CXTPChartAreaSeriesStyle | protected
m_nTransparency | CXTPChartAreaSeriesStyle | protected
m_pBorder | CXTPChartAreaSeriesStyle | protected
m_pErrorBar | CXTPChartSeriesStyle | protected
m_pFillStyle | CXTPChartAreaSeriesStyle | protected
m_pLabel | CXTPChartSeriesStyle | protected
m_Rotation3d | CXTPChartSeriesStyle | protected
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartElement | virtual
Release() | CXTPChartElement | virtual
Set3dRotation(const CXTPChart3dRotation &rotation) | CXTPChartSeriesStyle | virtual
Set3dRotation(double dYaw, double dPitch, double dRoll) | CXTPChartSeriesStyle | virtual
SetColor(CXTPChartColor clr) | CXTPChartSeriesStyle | virtual
SetColorEach(BOOL bColorEach) | CXTPChartSeriesStyle | virtual
SetErrorBar(CXTPChartErrorBar *pErrorBar) | CXTPChartSeriesStyle | virtual
SetFillAcrossXAxis(BOOL nFillAcrossXAxis) | CXTPChartAreaSeriesStyle |
SetLabel(CXTPChartSeriesLabel *pLabel) | CXTPChartSeriesStyle | virtual
SetTransparency(int nTransparency) | CXTPChartAreaSeriesStyle | virtual
~CXTPChartAreaSeriesStyle() | CXTPChartAreaSeriesStyle | virtual
~CXTPChartDiagram2DSeriesStyle() | CXTPChartDiagram2DSeriesStyle | virtual
~CXTPChartElement() | CXTPChartElement | virtual
~CXTPChartPointSeriesStyle() | CXTPChartPointSeriesStyle | virtual
~CXTPChartSeriesStyle() | CXTPChartSeriesStyle | virtual
~CXTPChartStackedAreaSeriesStyle() | CXTPChartStackedAreaSeriesStyle | virtual
~CXTPChartStackedSplineAreaSeriesStyle() | CXTPChartStackedSplineAreaSeriesStyle | virtual


Toolkit Pro: Member List

CXTPChart3dPieSeriesLabelDeviceCommand Member List

This is the complete list of members for CXTPChart3dPieSeriesLabelDeviceCommand, including all inherited members.

AddChildCommand(CXTPChartDeviceCommand *pCommand) | CXTPChartDeviceCommand |
AfterExecute(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
ApplySeriesStyle(CXTPChartSeriesStyle *pStyle) | CXTPChartDeviceCommand | virtual
BeforeExecute(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
BindView(CXTPChartElementView *pView) | CXTPChartDeviceCommand |
Commit() | CXTPChartDeviceCommand |
ComputeConnectorBend(CXTPChart3dDeviceContext *pDC, CRect rcBoundaries) | CXTPChart3dPieSeriesLabelDeviceCommand |
ComputeConnectorVector(CXTPChart3dDeviceContext *pDC) | CXTPChart3dPieSeriesLabelDeviceCommand |
ComputeLabel(CXTPChart3dDeviceContext *pDC) | CXTPChart3dPieSeriesLabelDeviceCommand |
CXTPChart3dDeviceCommand(XTPChart3dAntialiasingPolicy nAntialiasingPolicy) | CXTPChart3dDeviceCommand | protected
CXTPChart3dPieSeriesLabelDeviceCommand(CXTPChart3dPieSeriesLabelView *pSeriesLabelView) | CXTPChart3dPieSeriesLabelDeviceCommand |
CXTPChartDeviceCommand() | CXTPChartDeviceCommand |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPObservable() | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | protected
Execute(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
ExecuteOverride(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
GetBoundView() const | CXTPChartDeviceCommand |
GetChildCommand(int nIndex) const | CXTPChartDeviceCommand |
GetChildCommandCount() const | CXTPChartDeviceCommand |
GetConnectorEndpointVerticalOffset() const | CXTPChart3dPieSeriesLabelDeviceCommand |
GetConnectorLengthFactor() const | CXTPChart3dPieSeriesLabelDeviceCommand |
GetCurrentDC() const | CXTPChartDeviceCommand |
GetLabelRect() const | CXTPChart3dPieSeriesLabelDeviceCommand |
GetPassNumber() const | CXTPChartDeviceCommand |
GetSeriesLabelView() const | CXTPChart3dPieSeriesLabelDeviceCommand |
HitTest(CPoint point, CXTPChartElement *pParent) const | CXTPChartDeviceCommand | virtual
Is3D() const | CXTPChartObject |
IsBent() const | CXTPChart3dPieSeriesLabelDeviceCommand |
IsCommitted() const | CXTPChartDeviceCommand |
IsEnabled() const | CXTPChart3dDeviceCommand | virtual
IsFailed() const | CXTPChart3dPieSeriesLabelDeviceCommand |
m_arrChildren | CXTPChartDeviceCommand | protected
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Prepare(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
PrepareOverride(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
SetColumnAnchorVerticalPosition(CXTPChart3dDeviceContext *pDC, int y) | CXTPChart3dPieSeriesLabelDeviceCommand |
SetConnectorEndpointVerticalOffset(double yOffset) | CXTPChart3dPieSeriesLabelDeviceCommand |
SetConnectorLengthFactor(double dFactor) | CXTPChart3dPieSeriesLabelDeviceCommand |
SetEnabled(BOOL bEnabled=TRUE) | CXTPChartDeviceCommand |
SetFailed() | CXTPChart3dPieSeriesLabelDeviceCommand |
SetLabelRect(CRect rcLabel) | CXTPChart3dPieSeriesLabelDeviceCommand |
Subscribe(CXTPChartDeviceCommandEvents *pObserver, CXTPSubscriptionList< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > *pSubcriptionList=NULL) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > |
Unsubscribe(CXTPChartDeviceCommandEvents *pObserver) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > |
~CXTPChartDeviceCommand() | CXTPChartDeviceCommand | virtual
~CXTPObservable() | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | protected


Toolkit Pro: Member List

CXTPChartSolidSplinePolygonDeviceCommand Member List

This is the complete list of members for CXTPChartSolidSplinePolygonDeviceCommand, including all inherited members.

AddChildCommand(CXTPChartDeviceCommand *pCommand) | CXTPChartDeviceCommand |
AfterExecute(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
ApplySeriesStyle(CXTPChartSeriesStyle *pStyle) | CXTPChartDeviceCommand | virtual
BeforeExecute(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
BindView(CXTPChartElementView *pView) | CXTPChartDeviceCommand |
Commit() | CXTPChartDeviceCommand |
CXTPChartDeviceCommand() | CXTPChartDeviceCommand |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartSolidSplinePolygonDeviceCommand(const CXTPChartColor &color, BOOL bTwoSides=FALSE) | CXTPChartSolidSplinePolygonDeviceCommand |
CXTPObservable() | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | protected
Execute(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
ExecuteOverride(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
GetBoundView() const | CXTPChartDeviceCommand |
GetChildCommand(int nIndex) const | CXTPChartDeviceCommand |
GetChildCommandCount() const | CXTPChartDeviceCommand |
GetCurrentDC() const | CXTPChartDeviceCommand |
GetPassNumber() const | CXTPChartDeviceCommand |
HitTest(CPoint point, CXTPChartElement *pParent) const | CXTPChartDeviceCommand | virtual
Is3D() const | CXTPChartObject |
IsCommitted() const | CXTPChartDeviceCommand |
IsEnabled() const | CXTPChartDeviceCommand | virtual
m_arrChildren | CXTPChartDeviceCommand | protected
m_bTwoSides | CXTPChartSolidSplinePolygonDeviceCommand | protected
m_color | CXTPChartSolidSplinePolygonDeviceCommand | protected
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Prepare(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
PrepareOverride(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
SetEnabled(BOOL bEnabled=TRUE) | CXTPChartDeviceCommand |
Subscribe(CXTPChartDeviceCommandEvents *pObserver, CXTPSubscriptionList< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > *pSubcriptionList=NULL) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > |
Unsubscribe(CXTPChartDeviceCommandEvents *pObserver) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > |
~CXTPChartDeviceCommand() | CXTPChartDeviceCommand | virtual
~CXTPObservable() | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | protected


Toolkit Pro: XTPChartRadarAxisXView.h Source File

  • Source
  • Chart
  • Diagram
  • Axis
XTPChartRadarAxisXView.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTRADARAXISXVIEW_H__)
24# define __XTPCHARTRADARAXISXVIEW_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartRadarAxisXView;
34class CXTPChartAxisRange;
35class CXTPChartAxis;
36class CXTPChartSeriesView;
37
42class _XTP_EXT_CLASS CXTPChartRadarAxisXViewTick
43{
44public:
45 double m_dValue;
46 CXTPChartString m_strLabel;
47 CSize m_szBounds;
48 CXTPChartSizeF m_szLabel;
49 CXTPChartPointF m_ptLocation;
50};
56class _XTP_EXT_CLASS CXTPChartRadarAxisXView : public CXTPChartRadarAxisView
57{
58public:
66 CXTPChartRadarAxisXView(CXTPChartAxis* pAxis, CXTPChartElementView* pParentView);
67
72 ~CXTPChartRadarAxisXView();
73
74public:
86 virtual CXTPChartDeviceCommand* CreateDeviceCommand(CXTPChartDeviceContext* pDC);
87
99 virtual CXTPChartDeviceCommand* CreateGridLinesDeviceCommand(CXTPChartDeviceContext* pDC);
100
112 virtual CXTPChartDeviceCommand* CreateInterlacedDeviceCommand(CXTPChartDeviceContext* pDC);
113
125 virtual CXTPChartDeviceCommand* CreateTickMarksDeviceCommand(CXTPChartDeviceContext* pDC);
126
138 virtual CXTPChartDeviceCommand* CreateLabelsDeviceCommand(CXTPChartDeviceContext* pDC);
139
152 virtual CXTPChartDeviceCommand* CreateConstantLinesDeviceCommand(CXTPChartDeviceContext* pDC,
153 BOOL bBehind);
154
166 virtual CXTPChartDeviceCommand* CreateStripsDeviceCommand(CXTPChartDeviceContext* pDC);
167
178 void CreateView(CXTPChartDeviceContext* pDC);
179
188 void CalcSize(CXTPChartDeviceContext* pDC, CRect rcDiagram);
196 void SetBounds(CXTPChartDeviceContext* pDC, CRect rcBounds);
197
198 double ValueToAngle(double nValue) const;
199
207 int GetSize() const;
208
209protected:
216 void CreateTickMarks(CXTPChartDeviceContext* pDC);
217
218public:
219 CArray<CXTPChartRadarAxisXViewTick, CXTPChartRadarAxisXViewTick&> m_arrTicks;
223 CArray<double, double&> m_arrMinorTicks;
224
225protected:
226 CRect m_rcBounds;
227 int m_nSize;
229 double m_dMinValue;
230 double m_dMaxValue;
231
232 CXTPPoint2i m_ptCenter;
233 int m_nRadius;
234};
235
236AFX_INLINE int CXTPChartRadarAxisXView::GetSize() const
237{
238 return m_nSize;
239}
241# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
242#endif //#if !defined(__XTPCHARTRADARAXISXVIEW_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartAxis
This abstract base class represents a chart axis as a kind of chart element.
Definition XTPChartAxis.h:86
CXTPChartAxisRange
This class represents the value range of the axis.
Definition XTPChartAxisRange.h:44
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartElementView
This class represents the view of a chart element.
Definition XTPChartElementView.h:47
CXTPChartRadarAxisView
This class abstracts the view of a chart axis and its child items in a bounding rectangle context.
Definition XTPChartRadarAxisView.h:41
CXTPChartRadarAxisXView
This class abstracts the view of a chart axis and its child items in a bounding rectangle context.
Definition XTPChartRadarAxisXView.h:57
CXTPChartRadarAxisXView::~CXTPChartRadarAxisXView
~CXTPChartRadarAxisXView()
Destroys a CXTPChartRadarAxisXView object, handles cleanup and deallocation.
CXTPChartRadarAxisXView::SetBounds
void SetBounds(CXTPChartDeviceContext *pDC, CRect rcBounds)
This function sets the bounds for the axis.
CXTPChartRadarAxisXView::CreateStripsDeviceCommand
virtual CXTPChartDeviceCommand * CreateStripsDeviceCommand(CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
CXTPChartRadarAxisXView::m_nSize
int m_nSize
The axis size;.
Definition XTPChartRadarAxisXView.h:227
CXTPChartRadarAxisXView::CalcSize
void CalcSize(CXTPChartDeviceContext *pDC, CRect rcDiagram)
This function calculates the size of an axis, including its constituent elements (e....
CXTPChartRadarAxisXView::CXTPChartRadarAxisXView
CXTPChartRadarAxisXView(CXTPChartAxis *pAxis, CXTPChartElementView *pParentView)
Constructs a CXTPChartRadarAxisXView object.
CXTPChartRadarAxisXView::CreateDeviceCommand
virtual CXTPChartDeviceCommand * CreateDeviceCommand(CXTPChartDeviceContext *pDC)
Override this function to create a CXTPChartDeviceCommand object.
CXTPChartRadarAxisXView::CreateConstantLinesDeviceCommand
virtual CXTPChartDeviceCommand * CreateConstantLinesDeviceCommand(CXTPChartDeviceContext *pDC, BOOL bBehind)
This function creates a CXTPChartDeviceCommand object.
CXTPChartRadarAxisXView::GetSize
int GetSize() const
This function returns the size of the axis.
Definition XTPChartRadarAxisXView.h:236
CXTPChartRadarAxisXView::m_arrTicks
CArray< CXTPChartRadarAxisXViewTick, CXTPChartRadarAxisXViewTick & > m_arrTicks
The collection of tick marks.
Definition XTPChartRadarAxisXView.h:219
CXTPChartRadarAxisXView::CreateLabelsDeviceCommand
virtual CXTPChartDeviceCommand * CreateLabelsDeviceCommand(CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
CXTPChartRadarAxisXView::CreateView
void CreateView(CXTPChartDeviceContext *pDC)
Call this function to create a chart axis view.
CXTPChartRadarAxisXView::m_rcBounds
CRect m_rcBounds
The diagram boundary.
Definition XTPChartRadarAxisXView.h:226
CXTPChartRadarAxisXView::CreateGridLinesDeviceCommand
virtual CXTPChartDeviceCommand * CreateGridLinesDeviceCommand(CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
CXTPChartRadarAxisXView::CreateTickMarksDeviceCommand
virtual CXTPChartDeviceCommand * CreateTickMarksDeviceCommand(CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
CXTPChartRadarAxisXView::CreateTickMarks
void CreateTickMarks(CXTPChartDeviceContext *pDC)
This function creates the axis tick marks.
CXTPChartRadarAxisXView::CreateInterlacedDeviceCommand
virtual CXTPChartDeviceCommand * CreateInterlacedDeviceCommand(CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
CXTPChartRadarAxisXViewTick
This class represents a tick mark in the axis.
Definition XTPChartRadarAxisXView.h:43
CXTPChartRadarAxisXViewTick::m_strLabel
CXTPChartString m_strLabel
The tick mark label.
Definition XTPChartRadarAxisXView.h:46
CXTPChartRadarAxisXViewTick::m_szLabel
CXTPChartSizeF m_szLabel
The size of the label.
Definition XTPChartRadarAxisXView.h:48
CXTPChartRadarAxisXViewTick::m_szBounds
CSize m_szBounds
The boundary.
Definition XTPChartRadarAxisXView.h:47
CXTPChartRadarAxisXViewTick::m_dValue
double m_dValue
The value of the tick mark.
Definition XTPChartRadarAxisXView.h:45
CXTPPoint2T< float >
CXTPSizeT
This class incapsulates size data.
Definition XTPSize.h:40


Toolkit Pro: Member List

CXTPExpandButtonPart Member List

This is the complete list of members for CXTPExpandButtonPart, including all inherited members.

AdjustLayout(CDC *pDC, const CRect &rcRect) | CXTPExpandButtonPart | virtual
CXTPCalendarCaptionBarThemePart(CXTPCalendarCaptionBarTheme *pTheme, int nPartID) | CXTPCalendarCaptionBarThemePart |
CXTPCalendarWMHandler() | CXTPCalendarWMHandler |
CXTPCmdTarget() | CXTPCmdTarget |
Draw(CDC *pDC) | CXTPExpandButtonPart | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCheck() const | CXTPCalendarCaptionBarThemePart | virtual
GetChildHandlerAt(int nIndex) const | CXTPCalendarWMHandler | virtual
GetChildHandlersCount() const | CXTPCalendarWMHandler | virtual
GetPaintManager() const | CXTPCalendarCaptionBarThemePart |
GetPaintTheme() const | CXTPCalendarCaptionBarThemePart | virtual
GetPartID() const | CXTPCalendarCaptionBarThemePart | virtual
GetRect() const | CXTPCalendarCaptionBarThemePart | virtual
GetState() const | CXTPCalendarCaptionBarThemePart |
GetText() const | CXTPCalendarCaptionBarThemePart | virtual
GetTextColor() | CXTPCalendarCaptionBarThemePart | virtual
GetTheme() const | CXTPCalendarCaptionBarThemePart | virtual
HitTest(const CPoint &pt) const | CXTPCalendarCaptionBarThemePart | virtual
IsVisible() const | CXTPCalendarCaptionBarThemePart | virtual
m_bVisible | CXTPCalendarCaptionBarThemePart | protected
m_clrTextColor | CXTPCalendarCaptionBarThemePart |
m_nPartID | CXTPCalendarCaptionBarThemePart | protected
m_nState | CXTPCalendarCaptionBarThemePart |
m_pTheme | CXTPCalendarCaptionBarThemePart | protected
m_rcRect | CXTPCalendarCaptionBarThemePart |
m_strText | CXTPCalendarCaptionBarThemePart |
OnBeforeDestroy() | CXTPCalendarWMHandler | virtual
OnChar(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnKeyUp(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnLButtonDblClk(UINT nFlags, CPoint point) | CXTPCalendarWMHandler | virtual
OnLButtonDown(UINT nFlags, CPoint point) | CXTPCalendarCaptionBarThemePart | virtual
OnLButtonUp(UINT nFlags, CPoint point) | CXTPCalendarCaptionBarThemePart | virtual
OnMouseMove(UINT nFlags, CPoint point) | CXTPCalendarCaptionBarThemePart | virtual
OnPostAdjustLayout() | CXTPCalendarWMHandler | virtual
OnSysKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnTimer(UINT_PTR uTimerID) | CXTPCalendarWMHandler | virtual
OnWndMsg(UINT message, WPARAM wParam, LPARAM lParam, LRESULT *pResult) | CXTPCalendarWMHandler | virtual
Redraw(BOOL bUpdateNow=FALSE) | CXTPCalendarCaptionBarThemePart | virtual
RefreshMetrics() | CXTPCalendarCaptionBarThemePart | inlinevirtual
SetCheck(int nCheck) | CXTPCalendarCaptionBarThemePart | virtual
SetState(int nState) | CXTPCalendarCaptionBarThemePart | virtual
SetText(LPCTSTR pcszText) | CXTPCalendarCaptionBarThemePart | virtual
SetVisible(BOOL bVisible) | CXTPCalendarCaptionBarThemePart | virtual
~CXTPCalendarCaptionBarThemePart() | CXTPCalendarCaptionBarThemePart | virtual


Toolkit Pro: XTPChart3dPieSeriesStyle.h Source File

  • Source
  • Chart
  • Styles
  • Pie
  • 3D
XTPChart3dPieSeriesStyle.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHART3DPIESERIESSTYLE_H__)
24# define __XTPCHART3DPIESERIESSTYLE_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartDiagramView;
34class CXTPChartSeries;
35
47class _XTP_EXT_CLASS CXTPChart3dPieSeriesStyle : public CXTPChartPieSeriesStyleBase
48{
50 DECLARE_SERIAL(CXTPChart3dPieSeriesStyle)
52public:
57 CXTPChart3dPieSeriesStyle();
58
67 virtual CXTPChartDiagram* CreateDiagram();
68
79 virtual CXTPChartSeriesView* CreateView(CXTPChartSeries* pSeries,
80 CXTPChartDiagramView* pDiagramView);
81
92 virtual CXTPChart3dRotation Get3dRotation() const;
93
104 virtual int GetDepth() const;
105
115 void SetDepth(int dDepth);
116
127 BOOL IsTorus() const;
128
139 void SetTorus(BOOL bTorus);
140
152 virtual void DoPropExchange(CXTPPropExchange* pPX);
153
154# ifdef _XTP_ACTIVEX
155public:
157 DECLARE_DISPATCH_MAP()
158 DECLARE_INTERFACE_MAP()
159 DECLARE_OLETYPELIB_EX(CXTPChart3dPieSeriesStyle);
160 DECLARE_OLECREATE_EX(CXTPChart3dPieSeriesStyle);
162# endif
163
164private:
165 int OleGetDepth();
166 void OleSetDepth(int dDepth);
167 BOOL OleGetIsTorus();
168 void OleSetTorus(BOOL bTorus);
169
170private:
171 int m_nDepth;
172 BOOL m_bTorus;
173};
174
175AFX_INLINE int CXTPChart3dPieSeriesStyle::GetDepth() const
176{
177 return m_nDepth;
178}
179
180AFX_INLINE void CXTPChart3dPieSeriesStyle::SetDepth(int nDepth)
181{
182 m_nDepth = nDepth;
183 OnChartChanged();
184}
185
186AFX_INLINE BOOL CXTPChart3dPieSeriesStyle::IsTorus() const
187{
188 return m_bTorus;
189}
190
191AFX_INLINE void CXTPChart3dPieSeriesStyle::SetTorus(BOOL bTorus)
192{
193 m_bTorus = bTorus;
194 OnChartChanged();
195}
197# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
198#endif //#if !defined(__XTPCHART3DPIESERIESSTYLE_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChart3dPieSeriesStyle
This class abstracts the pie series style.
Definition XTPChart3dPieSeriesStyle.h:48
CXTPChart3dPieSeriesStyle::DoPropExchange
virtual void DoPropExchange(CXTPPropExchange *pPX)
Call this member function to Store/Load an event using the specified data object.
CXTPChart3dPieSeriesStyle::Get3dRotation
virtual CXTPChart3dRotation Get3dRotation() const
Obtains rotation parameters for 3D chart.
CXTPChart3dPieSeriesStyle::SetTorus
void SetTorus(BOOL bTorus)
Sets torus appearance of the chart.
Definition XTPChart3dPieSeriesStyle.h:191
CXTPChart3dPieSeriesStyle::IsTorus
BOOL IsTorus() const
Checks if the chart has to be drawn as a torus instead of a pie.
Definition XTPChart3dPieSeriesStyle.h:186
CXTPChart3dPieSeriesStyle::CreateView
virtual CXTPChartSeriesView * CreateView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Call this function to create the view of the pie series.
CXTPChart3dPieSeriesStyle::CreateDiagram
virtual CXTPChartDiagram * CreateDiagram()
Call this function to create the pie diagram object.
CXTPChart3dPieSeriesStyle::CXTPChart3dPieSeriesStyle
CXTPChart3dPieSeriesStyle()
Constructs a CXTPChart3dPieSeriesStyle object.
CXTPChart3dPieSeriesStyle::SetDepth
void SetDepth(int dDepth)
Sets depth value.
Definition XTPChart3dPieSeriesStyle.h:180
CXTPChart3dPieSeriesStyle::GetDepth
virtual int GetDepth() const
Obtains depth value.
Definition XTPChart3dPieSeriesStyle.h:175
CXTPChart3dRotation
Represents a 3D rotation primitive for chart objects using Euler angles Yaw, Pitch and Roll in degree...
Definition XTPChartTypes.h:639
CXTPChartDiagram
This class represents a chart diagram, which is a kind of CXTPChartElement.
Definition XTPChartDiagram.h:48
CXTPChartDiagramView
This class represents the view of a chart diagram, which is a kind of CXTPChartElementView.
Definition XTPChartDiagramView.h:49
CXTPChartElement::OnChartChanged
virtual void OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic propertie...
CXTPChartPieSeriesStyleBase
This class abstracts the basic style of a pie serie.This class is a kind of CXTPChartSeriesStyle.
Definition XTPChartPieSeriesStyleBase.h:48
CXTPChartPieSeriesStyleBase::GetDepth
virtual int GetDepth() const
Call this function to get the depth of 3D pie chart.
CXTPChartSeries
This class represents a series in the chart, which is a kind of CXTPChartElement.
Definition XTPChartSeries.h:50
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72


Toolkit Pro: XTPDockingPanePanelColorSet2017.h Source File

  • Source
  • DockingPane
  • TabColorSets
XTPDockingPanePanelColorSet2017.h
Go to the documentation of this file.
1
23#if !defined(__XTPDOCKINGPANEPANELCOLORSET2017_H__)
24# define __XTPDOCKINGPANEPANELCOLORSET2017_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPDockingPanePanelColorSet2017 : public CXTPDockingPanePanelColorSet2012
39{
40public:
45 CXTPDockingPanePanelColorSet2017();
46
52 virtual void RefreshMetrics();
53};
54
55# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
57#endif // !defined(__XTPDOCKINGPANEPANELCOLORSET2017_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPDockingPanePanelColorSet2012
Helper class used to initialize default colors for a theme from an .INI resource and handle drawing r...
Definition XTPDockingPanePanelColorSet2012.h:39
CXTPDockingPanePanelColorSet2017
Helper class used to initialize default colors for a theme from an .INI resource and handle drawing r...
Definition XTPDockingPanePanelColorSet2017.h:39
CXTPDockingPanePanelColorSet2017::RefreshMetrics
virtual void RefreshMetrics()
This member function is used to initialize default colors for a theme from an .INI resource.
CXTPDockingPanePanelColorSet2017::CXTPDockingPanePanelColorSet2017
CXTPDockingPanePanelColorSet2017()
Default class constructor.


Toolkit Pro: XTPMessageBarThemeOffice2010.h Source File

  • Source
  • CommandBars
  • MessageBar
XTPMessageBarThemeOffice2010.h
Go to the documentation of this file.
1
23#if !defined(__XTPMESSAGEBARTHEMEOFFICE2010_H__)
24# define __XTPMESSAGEBARTHEMEOFFICE2010_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPPaintManager;
34class CXTPMessageBar;
35class CXTPMessageBarButton;
36
42class _XTP_EXT_CLASS CXTPMessageBarThemeOffice2010 : public CXTPMessageBarPaintManager
43{
44public:
50 CXTPMessageBarThemeOffice2010(CXTPPaintManager* pPaintManager);
51
56 virtual void RefreshMetrics();
57
64 virtual void FillMessageBar(CDC* pDC, CXTPMessageBar* pBar);
65
72 virtual void DrawMessageBarButton(CDC* pDC, CXTPMessageBarButton* pButton);
73
83 virtual CRect GetCloseButtonRect(int x, int y, int cy);
84
85protected:
86 CXTPPaintManagerColor m_clrTextHilite;
88private:
89 friend class CXTPPaintManager;
90};
91
93# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
94#endif // !defined(__XTPMESSAGEBARTHEMEOFFICE2010_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPMessageBarButton
CXTPMessageBarButton is a standalone class.
Definition XTPMessageBar.h:48
CXTPMessageBar
CXTPMessageBar is a CControlBar derived class.
Definition XTPMessageBar.h:88
CXTPMessageBarPaintManager
The CXTPMessageBarPaintManager class is used by the message bar to perform standard paint routines.
Definition XTPMessageBarPaintManager.h:39
CXTPMessageBarThemeOffice2010
The CXTPMessageBarThemeOffice2010 class is used by the message bar to draw an Office 2010 style messa...
Definition XTPMessageBarThemeOffice2010.h:43
CXTPMessageBarThemeOffice2010::DrawMessageBarButton
virtual void DrawMessageBarButton(CDC *pDC, CXTPMessageBarButton *pButton)
Call this member to draw a button in the message bar.
CXTPMessageBarThemeOffice2010::GetCloseButtonRect
virtual CRect GetCloseButtonRect(int x, int y, int cy)
Call this member to retrieve the close button coordinates.
CXTPMessageBarThemeOffice2010::FillMessageBar
virtual void FillMessageBar(CDC *pDC, CXTPMessageBar *pBar)
Draws the message bar.
CXTPMessageBarThemeOffice2010::RefreshMetrics
virtual void RefreshMetrics()
Call to update class colors and settings.
CXTPMessageBarThemeOffice2010::m_clrTextHilite
CXTPPaintManagerColor m_clrTextHilite
Message bar text hilite color.
Definition XTPMessageBarThemeOffice2010.h:86
CXTPMessageBarThemeOffice2010::CXTPMessageBarThemeOffice2010
CXTPMessageBarThemeOffice2010(CXTPPaintManager *pPaintManager)
Message bar constructor.
CXTPPaintManagerColor
The CXTPPaintManagerColor class is used to manage COLORREF values for determining default and applica...
Definition XTPColorManager.h:117
CXTPPaintManager
Paint manager of the command bars.
Definition XTPPaintManager.h:199


Toolkit Pro: Member List

CXTPChartDiagram2DSeriesStyle Member List

This is the complete list of members for CXTPChartDiagram2DSeriesStyle, including all inherited members.

ApplyTo(CXTPChartDeviceCommand *pCommand) | CXTPChartSeriesStyle | virtual
CorrectAxisSideMargins(CXTPChartAxis *pAxis, double nMinValue, double nMaxValue, double &nCorrection) | CXTPChartSeriesStyle | virtual
CreateDiagram() | CXTPChartDiagram2DSeriesStyle | virtual
CreateView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)=0 | CXTPChartSeriesStyle | pure virtual
CXTPChartDiagram2DSeriesStyle() | CXTPChartDiagram2DSeriesStyle |
CXTPChartElement() | CXTPChartElement |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartSeriesStyle() | CXTPChartSeriesStyle |
DoPropExchange(CXTPPropExchange *pPX) | CXTPChartDiagram2DSeriesStyle | virtual
Enable3dEdgeSmoothing(BOOL bEnable=TRUE) | CXTPChartSeriesStyle | virtual
Get3dRotation() const | CXTPChartSeriesStyle | virtual
GetAppearance() const | CXTPChartElement |
GetColor() const | CXTPChartSeriesStyle | virtual
GetContent() const | CXTPChartElement |
GetErrorBar() const | CXTPChartSeriesStyle | virtual
GetLabel() const | CXTPChartSeriesStyle | virtual
GetOwner() const | CXTPChartElement |
GetSeriesPointValueIndex() const | CXTPChartSeriesStyle | virtual
GetStyleAppearance() const | CXTPChartSeriesStyle | virtual
GetTransparency() const | CXTPChartSeriesStyle | virtual
Is3D() const | CXTPChartObject |
Is3dEdgeSmoothingEnabled() const | CXTPChartSeriesStyle | virtual
IsColorEach() const | CXTPChartSeriesStyle | virtual
IsStyleDiagram(CXTPChartDiagram *pDiagram) const | CXTPChartDiagram2DSeriesStyle | virtual
m_bColorEach | CXTPChartSeriesStyle | protected
m_bSmooth3dEdges | CXTPChartSeriesStyle | protected
m_clrColor | CXTPChartSeriesStyle | protected
m_nAxisIndexX | CXTPChartDiagram2DSeriesStyle | protected
m_nAxisIndexY | CXTPChartDiagram2DSeriesStyle | protected
m_nTransparency | CXTPChartSeriesStyle | protected
m_pErrorBar | CXTPChartSeriesStyle | protected
m_pLabel | CXTPChartSeriesStyle | protected
m_Rotation3d | CXTPChartSeriesStyle | protected
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartElement | virtual
Release() | CXTPChartElement | virtual
Set3dRotation(const CXTPChart3dRotation &rotation) | CXTPChartSeriesStyle | virtual
Set3dRotation(double dYaw, double dPitch, double dRoll) | CXTPChartSeriesStyle | virtual
SetColor(CXTPChartColor clr) | CXTPChartSeriesStyle | virtual
SetColorEach(BOOL bColorEach) | CXTPChartSeriesStyle | virtual
SetErrorBar(CXTPChartErrorBar *pErrorBar) | CXTPChartSeriesStyle | virtual
SetLabel(CXTPChartSeriesLabel *pLabel) | CXTPChartSeriesStyle | virtual
SetTransparency(int nTransparency) | CXTPChartSeriesStyle | virtual
~CXTPChartDiagram2DSeriesStyle() | CXTPChartDiagram2DSeriesStyle | virtual
~CXTPChartElement() | CXTPChartElement | virtual
~CXTPChartSeriesStyle() | CXTPChartSeriesStyle | virtual


Toolkit Pro: Member List

CXTPComboBoxThemeVisualStudio2015 Member List

This is the complete list of members for CXTPComboBoxThemeVisualStudio2015, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPComboBoxTheme() | CXTPComboBoxTheme |
CXTPComboBoxThemeOffice2003() | CXTPComboBoxThemeOffice2003 |
CXTPComboBoxThemeOffice2013() | CXTPComboBoxThemeOffice2013 |
CXTPComboBoxThemeVisualStudio() | CXTPComboBoxThemeVisualStudio |
CXTPComboBoxThemeVisualStudio2015() | CXTPComboBoxThemeVisualStudio2015 |
CXTPControlTheme() | CXTPControlTheme |
DrawBackground(CDC *pDC, CXTPComboBox *pComboBox) | CXTPComboBoxThemeOffice2013 | virtual
DrawButton(CDC *pDC, CXTPComboBox *pComboBox, CRect rcBtn) | CXTPComboBoxThemeVisualStudio2015 | virtual
DrawButtonTriangle(CDC *pDC, CXTPComboBox *pComboBox, CRect rcBtn) | CXTPComboBoxThemeOffice2013 | virtual
DrawComboBox(CDC *pDC, CXTPComboBox *pComboBox) | CXTPComboBoxTheme | virtual
DrawFrame(HDC hdc, LPRECT lprc, int nSize, HBRUSH hBrush) | CXTPComboBoxTheme | virtual
FillSolidRect(HDC hdc, int x, int y, int cx, int cy, HBRUSH hBrush) | CXTPComboBoxTheme | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetBackColor() const | CXTPComboBoxTheme |
GetBackgroundBrush() const | CXTPComboBoxTheme |
GetTextColor() const | CXTPComboBoxTheme |
GetThemeStyle() const | CXTPControlTheme |
m_clrBackDisabled | CXTPComboBoxTheme |
m_clrBackground | CXTPComboBoxTheme |
m_clrBackHighlight | CXTPComboBoxTheme |
m_clrBorderDisabled | CXTPComboBoxTheme |
m_clrBorderHot | CXTPComboBoxTheme |
m_clrBorderNormal | CXTPComboBoxTheme |
m_clrButtonArrowDisabled | CXTPComboBoxThemeOffice2013 | protected
m_clrButtonArrowHot | CXTPComboBoxTheme |
m_clrButtonArrowNormal | CXTPComboBoxTheme |
m_clrButtonArrowPressed | CXTPComboBoxTheme |
m_clrButtonDisabled | CXTPComboBoxThemeOffice2013 | protected
m_clrButtonHot | CXTPComboBoxTheme |
m_clrButtonNormal | CXTPComboBoxTheme |
m_clrButtonPressed | CXTPComboBoxTheme |
m_clrText | CXTPComboBoxTheme |
m_clrTextDisabled | CXTPComboBoxTheme |
m_clrTextHighlight | CXTPComboBoxTheme |
m_grcButton | CXTPComboBoxTheme |
m_grcButtonHilite | CXTPComboBoxTheme |
m_grcButtonPushed | CXTPComboBoxTheme |
m_nTheme | CXTPControlTheme | protected
m_nThumbWidth | CXTPComboBoxTheme | protected
m_themeComboBox | CXTPComboBoxTheme | protected
m_xtpBrushBackground | CXTPComboBoxTheme | protected
RefreshMetrics(CXTPComboBox *pComboBox) | CXTPComboBoxThemeVisualStudio2015 | virtual
ResetBackColor() | CXTPComboBoxTheme |
ResetTextColor() | CXTPComboBoxTheme |
SetBackColor(COLORREF clrBackground) | CXTPComboBoxTheme |
SetTextColor(COLORREF clrText) | CXTPComboBoxTheme |
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static
UpdateBackgroundBrush() | CXTPComboBoxTheme | protected
~CXTPComboBoxTheme() | CXTPComboBoxTheme | virtual
~CXTPComboBoxThemeOffice2003() | CXTPComboBoxThemeOffice2003 | virtual
~CXTPComboBoxThemeOffice2013() | CXTPComboBoxThemeOffice2013 | virtual
~CXTPComboBoxThemeVisualStudio() | CXTPComboBoxThemeVisualStudio | virtual
~CXTPComboBoxThemeVisualStudio2015() | CXTPComboBoxThemeVisualStudio2015 | virtual


Toolkit Pro: XTPStatusBarThemeVisualStudio2017.h Source File

  • Source
  • CommandBars
  • StatusBar
XTPStatusBarThemeVisualStudio2017.h
Go to the documentation of this file.
1
23#if !defined(__XTPXTPSTATUSBARTHEMEVISUALSTUDIO2017_H__)
24# define __XTPXTPSTATUSBARTHEMEVISUALSTUDIO2017_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPStatusBarThemeVisualStudio2017
39 : public CXTPStatusBarThemeOffice2013
40 , private IXTPApplicationEvents
41{
42public:
48 CXTPStatusBarThemeVisualStudio2017(CXTPPaintManager* pPaintManager);
49
54 ~CXTPStatusBarThemeVisualStudio2017();
55
62 virtual void DrawStatusBarGripper(CDC* pDC, CRect rcClient);
63
69 virtual void RefreshMetrics();
70
78 virtual void SetStateColor(COLORREF clrState);
79
86 virtual COLORREF GetStateColor() const;
87
88private:
89 virtual void OnAmbientPropertyChanged(CXTPApplication* pApplication,
90 XTPApplicationAmbientProperty nProperty);
91 void UpdateStateColor();
92
93 BOOL m_bAutomaticStateColor;
94};
95
97# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
98#endif // !defined(__XTPXTPSTATUSBARTHEMEVISUALSTUDIO2017_H__)
XTPApplicationAmbientProperty
XTPApplicationAmbientProperty
Global ambient property identifiers.
Definition XTPApplication.h:46
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPApplication
Defines a global XTP application object interface.
Definition XTPApplication.h:151
CXTPPaintManager
Paint manager of the command bars.
Definition XTPPaintManager.h:199
CXTPStatusBarThemeOffice2013
The CXTPStatusBarThemeVisualStudio2015 class is used to enable the Office 2013 style theme for the st...
Definition XTPStatusBarThemeOffice2013.h:39
CXTPStatusBarThemeVisualStudio2017
The CXTPStatusBarThemeVisualStudio2017 class is used to enable the Visual Studio 2017 style theme for...
Definition XTPStatusBarThemeVisualStudio2017.h:41
CXTPStatusBarThemeVisualStudio2017::DrawStatusBarGripper
virtual void DrawStatusBarGripper(CDC *pDC, CRect rcClient)
This method is called to draw the status bar's gripper.
CXTPStatusBarThemeVisualStudio2017::CXTPStatusBarThemeVisualStudio2017
CXTPStatusBarThemeVisualStudio2017(CXTPPaintManager *pPaintManager)
Constructs a CXTPStatusBarThemeVisualStudio2017 object.
CXTPStatusBarThemeVisualStudio2017::SetStateColor
virtual void SetStateColor(COLORREF clrState)
Call this member function to set the application state color for the status bar.
CXTPStatusBarThemeVisualStudio2017::RefreshMetrics
virtual void RefreshMetrics()
This method is called to refresh colors and other theme specific metrics for the paint manager.
CXTPStatusBarThemeVisualStudio2017::~CXTPStatusBarThemeVisualStudio2017
~CXTPStatusBarThemeVisualStudio2017()
Handles object destruction.
CXTPStatusBarThemeVisualStudio2017::GetStateColor
virtual COLORREF GetStateColor() const
Call this member function to get the application state color for the status bar.
IXTPApplicationEvents
Defines a callback interface for XTP application event sink.
Definition XTPApplication.h:82
IXTPApplicationEvents::OnAmbientPropertyChanged
virtual void OnAmbientPropertyChanged(CXTPApplication *pApplication, XTPApplicationAmbientProperty nProperty)
Called by framework when an ambient property is changed.
Definition XTPApplication.h:130


Toolkit Pro: Member List

XTP_DAYITEM_METRICS Member List

This is the complete list of members for XTP_DAYITEM_METRICS, including all inherited members.

clrBackground | XTP_DAYITEM_METRICS |
clrForeground | XTP_DAYITEM_METRICS |
CXTPCmdTarget() | CXTPCmdTarget |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetFont() | XTP_DAYITEM_METRICS |
SetFont(CFont *pFont) | XTP_DAYITEM_METRICS |


Toolkit Pro: Member List

CXTPCmdTarget Member List

This is the complete list of members for CXTPCmdTarget, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static


Toolkit Pro: XTPSvgImage.h Source File

  • Source
  • GraphicLibrary
XTPSvgImage.h
Go to the documentation of this file.
1
23#if !defined(__XTPSVGIMAGE_H__)
24# define __XTPSVGIMAGE_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
34struct NSVGimage;
35struct NSVGrasterizer;
42class _XTP_EXT_CLASS CXTPSvgImage
43{
44public:
49 CXTPSvgImage();
50
55 ~CXTPSvgImage();
56
57public:
61 enum Units
62 {
63 unitPX,
64 unitPT,
65 unitPC,
66 unitMM,
67 unitCM,
68 unitIN,
69 unitPercent,
70 unitEM,
71 unitEX
72 };
73
83 BOOL Load(const void* pData, SIZE_T cbSize, Units nUnits = unitPX);
84
94 BOOL Load(IStream* pStream, Units nUnits = unitPX);
95
105 BOOL Load(CFile* pFile, Units nUnits = unitPX);
106
115 BOOL Load(LPCTSTR lpFilePath, Units nUnits = unitPX);
116
126 BOOL Load(HMODULE hModule, HRSRC hRes, Units nUnits = unitPX);
127
134 BOOL IsLoaded() const;
135
142 BOOL IsAlpha() const;
143
153 const CBitmap* GetBitmap() const;
154
165 CSize GetSize() const;
166
176 void SetSize(CSize size);
177
189 void Draw(HDC hDC, CPoint pt, BOOL bPreserveAlpha = TRUE);
190
204 void Draw(CDC* pDC, CPoint pt, BOOL bPreserveAlpha = TRUE);
205
219 void Draw(HDC hDC, CRect rc, BOOL bPreserveAlpha = TRUE);
220
234 void Draw(CDC* pDC, CRect rc, BOOL bPreserveAlpha = TRUE);
235
253 SIZE_T DirectDraw(PVOID pBits, SIZE_T cbSize, CRect rc);
254
255private:
256 BOOL LoadXml(const char* pData, Units nUnits = unitPX);
257 BOOL Rasterize();
258 void Unrasterize();
259 void Reset();
260 CBitmap* AccessBitmap();
261
262private:
263 BOOL m_bLoaded;
264 BOOL m_bAlpha;
265 BOOL m_bRasterized;
266 NSVGimage* m_pSvg;
267 NSVGrasterizer* m_pRast;
268 CSize m_size;
269 CBitmap m_bmp;
270 PVOID m_pBits;
271};
273AFX_INLINE BOOL CXTPSvgImage::IsLoaded() const
274{
275 return m_bLoaded;
276}
277
278AFX_INLINE CSize CXTPSvgImage::GetSize() const
279{
280 return m_size;
281}
282
283AFX_INLINE void CXTPSvgImage::Draw(CDC* pDC, CPoint pt, BOOL bPreserveAlpha /*= TRUE*/)
284{
285 ASSERT_VALID(pDC);
286 Draw(pDC->m_hDC, pt, bPreserveAlpha);
287}
288
289AFX_INLINE void CXTPSvgImage::Draw(CDC* pDC, CRect rc, BOOL bPreserveAlpha /*= TRUE*/)
290{
291 ASSERT_VALID(pDC);
292 Draw(pDC->m_hDC, rc, bPreserveAlpha);
293}
295# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
297#endif // #if !defined(__XTPSVGIMAGE_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPSvgImage
Implements basic SVG image format support.
Definition XTPSvgImage.h:43
CXTPSvgImage::GetSize
CSize GetSize() const
Gets rasterized SVG image size.
CXTPSvgImage::SetSize
void SetSize(CSize size)
Sets rasterized SVG image size.
CXTPSvgImage::~CXTPSvgImage
~CXTPSvgImage()
Handles object desctruction.
CXTPSvgImage::GetBitmap
const CBitmap * GetBitmap() const
Obtains bitmap object that contains a rasterized SVG image.
CXTPSvgImage::Load
BOOL Load(const void *pData, SIZE_T cbSize, Units nUnits=unitPX)
Loads SVG data from the specified memory location.
CXTPSvgImage::IsLoaded
BOOL IsLoaded() const
Determines if SVG data has been successfuly loaded.
CXTPSvgImage::Draw
void Draw(HDC hDC, CPoint pt, BOOL bPreserveAlpha=TRUE)
Draws a loaded SVG image to the target device context.
CXTPSvgImage::IsAlpha
BOOL IsAlpha() const
Determines if the loaded .SVG file has alpha layer.
CXTPSvgImage::Draw
void Draw(CDC *pDC, CPoint pt, BOOL bPreserveAlpha=TRUE)
Draws a loaded SVG image to the target device context.
CXTPSvgImage::Load
BOOL Load(HMODULE hModule, HRSRC hRes, Units nUnits=unitPX)
Loads SVG data from the specified resource.
CXTPSvgImage::Load
BOOL Load(IStream *pStream, Units nUnits=unitPX)
Loads SVG data from the specified stream.
CXTPSvgImage::Draw
void Draw(HDC hDC, CRect rc, BOOL bPreserveAlpha=TRUE)
Draws a loaded SVG image to the target device context.
CXTPSvgImage::Load
BOOL Load(CFile *pFile, Units nUnits=unitPX)
Loads SVG data from the specified file.
CXTPSvgImage::Units
Units
Defines image units.
Definition XTPSvgImage.h:62
CXTPSvgImage::unitPC
@ unitPC
Picas units.
Definition XTPSvgImage.h:65
CXTPSvgImage::unitEM
@ unitEM
Relative to the font size of the current element.
Definition XTPSvgImage.h:70
CXTPSvgImage::unitPX
@ unitPX
Pixel units.
Definition XTPSvgImage.h:63
CXTPSvgImage::unitCM
@ unitCM
Centimeter units.
Definition XTPSvgImage.h:67
CXTPSvgImage::unitIN
@ unitIN
Inch units.
Definition XTPSvgImage.h:68
CXTPSvgImage::unitMM
@ unitMM
Millimeter units.
Definition XTPSvgImage.h:66
CXTPSvgImage::unitPercent
@ unitPercent
Persent units.
Definition XTPSvgImage.h:69
CXTPSvgImage::unitPT
@ unitPT
Point units.
Definition XTPSvgImage.h:64
CXTPSvgImage::Draw
void Draw(CDC *pDC, CRect rc, BOOL bPreserveAlpha=TRUE)
Draws a loaded SVG image to the target device context.
CXTPSvgImage::CXTPSvgImage
CXTPSvgImage()
Constructs an uninitialized SVG image.
CXTPSvgImage::DirectDraw
SIZE_T DirectDraw(PVOID pBits, SIZE_T cbSize, CRect rc)
Draws rasterized image bits directly into the specified memoby buffer.
CXTPSvgImage::Load
BOOL Load(LPCTSTR lpFilePath, Units nUnits=unitPX)
Loads SVG data from the specified file.


Toolkit Pro: Member List

CXTPTempColorMask Member List

This is the complete list of members for CXTPTempColorMask, including all inherited members.

CXTPTempColorMask(COLORREF crNewMask) | CXTPTempColorMask
~CXTPTempColorMask() | CXTPTempColorMask


Toolkit Pro: Member List

CXTPChartGanttSeriesStyle Member List

This is the complete list of members for CXTPChartGanttSeriesStyle, including all inherited members.

ApplyTo(CXTPChartDeviceCommand *pCommand) | CXTPChartSeriesStyle | virtual
CorrectAxisSideMargins(CXTPChartAxis *pAxis, double nMinValue, double nMaxValue, double &nCorrection) | CXTPChartBarSeriesStyle | protectedvirtual
CreateDiagram() | CXTPChartDiagram2DSeriesStyle | virtual
CreateView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView) | CXTPChartGanttSeriesStyle | protectedvirtual
CXTPChartBarSeriesStyle() | CXTPChartBarSeriesStyle |
CXTPChartDiagram2DSeriesStyle() | CXTPChartDiagram2DSeriesStyle |
CXTPChartElement() | CXTPChartElement |
CXTPChartGanttSeriesStyle() | CXTPChartGanttSeriesStyle |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartRangeBarSeriesStyle() | CXTPChartRangeBarSeriesStyle |
CXTPChartSeriesStyle() | CXTPChartSeriesStyle |
DoPropExchange(CXTPPropExchange *pPX) | CXTPChartGanttSeriesStyle | virtual
Enable3dEdgeSmoothing(BOOL bEnable=TRUE) | CXTPChartSeriesStyle | virtual
Get3dRotation() const | CXTPChartSeriesStyle | virtual
GetAppearance() const | CXTPChartElement |
GetBarWidth() const | CXTPChartBarSeriesStyle |
GetColor() const | CXTPChartSeriesStyle | virtual
GetContent() const | CXTPChartElement |
GetErrorBar() const | CXTPChartSeriesStyle | virtual
GetLabel() const | CXTPChartSeriesStyle | virtual
GetOwner() const | CXTPChartElement |
GetSeriesPointValueIndex() const | CXTPChartSeriesStyle | virtual
GetStyleAppearance() const | CXTPChartSeriesStyle | virtual
GetTransparency() const | CXTPChartSeriesStyle | virtual
Is3D() const | CXTPChartObject |
Is3dEdgeSmoothingEnabled() const | CXTPChartSeriesStyle | virtual
IsColorEach() const | CXTPChartSeriesStyle | virtual
IsStyleDiagram(CXTPChartDiagram *pDiagram) const | CXTPChartDiagram2DSeriesStyle | virtual
m_bColorEach | CXTPChartSeriesStyle | protected
m_bSmooth3dEdges | CXTPChartSeriesStyle | protected
m_clrColor | CXTPChartSeriesStyle | protected
m_nAxisIndexX | CXTPChartDiagram2DSeriesStyle | protected
m_nAxisIndexY | CXTPChartDiagram2DSeriesStyle | protected
m_nTransparency | CXTPChartSeriesStyle | protected
m_pErrorBar | CXTPChartSeriesStyle | protected
m_pLabel | CXTPChartSeriesStyle | protected
m_Rotation3d | CXTPChartSeriesStyle | protected
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartElement | virtual
Release() | CXTPChartElement | virtual
Set3dRotation(const CXTPChart3dRotation &rotation) | CXTPChartSeriesStyle | virtual
Set3dRotation(double dYaw, double dPitch, double dRoll) | CXTPChartSeriesStyle | virtual
SetBarWidth(double dWidth) | CXTPChartBarSeriesStyle |
SetColor(CXTPChartColor clr) | CXTPChartSeriesStyle | virtual
SetColorEach(BOOL bColorEach) | CXTPChartSeriesStyle | virtual
SetErrorBar(CXTPChartErrorBar *pErrorBar) | CXTPChartSeriesStyle | virtual
SetLabel(CXTPChartSeriesLabel *pLabel) | CXTPChartSeriesStyle | virtual
SetTransparency(int nTransparency) | CXTPChartSeriesStyle | virtual
~CXTPChartBarSeriesStyle() | CXTPChartBarSeriesStyle | virtual
~CXTPChartDiagram2DSeriesStyle() | CXTPChartDiagram2DSeriesStyle | virtual
~CXTPChartElement() | CXTPChartElement | virtual
~CXTPChartGanttSeriesStyle() | CXTPChartGanttSeriesStyle | virtual
~CXTPChartRangeBarSeriesStyle() | CXTPChartRangeBarSeriesStyle | virtual
~CXTPChartSeriesStyle() | CXTPChartSeriesStyle | virtual


Toolkit Pro: Member List

CXTPGridHeader Member List

This is the complete list of members for CXTPGridHeader, including all inherited members.

AdjustColumnsWidth(int nTotalWidth, int nFirstIndex=0) | CXTPGridHeader |
AllowColumnRemove(BOOL bAllow) | CXTPGridHeader |
AllowColumnReorder(BOOL bAllow) | CXTPGridHeader |
AllowColumnResize(BOOL bAllow) | CXTPGridHeader |
AllowColumnSort(BOOL bAllow) | CXTPGridHeader |
BestFit(CXTPGridColumn *pColumn) | CXTPGridHeader |
CancelMouseMode() | CXTPGridHeader | protected
CXTPCmdTarget() | CXTPCmdTarget |
CXTPGridHeader(CXTPGridControl *pControl, CXTPGridColumns *pColumns) | CXTPGridHeader |
DoPropExchange(CXTPPropExchange *pPX) | CXTPGridHeader | protectedvirtual
dragFieldChooser enum value | CXTPGridHeader | protected
dragInGroupBox enum value | CXTPGridHeader | protected
dragInHeader enum value | CXTPGridHeader | protected
dragInTarget enum value | CXTPGridHeader | protected
dragNothing enum value | CXTPGridHeader | protected
dragOutTarget enum value | CXTPGridHeader | protected
Draw(CDC *pDC, CRect rcHeader, int nLeftOffset) | CXTPGridHeader | protectedvirtual
DrawFooter(CDC *pDC, CRect &rcFooter, int nLeftOffset) | CXTPGridHeader | protectedvirtual
DrawGroupByControl(CDC *pDC, CRect &rcGroupBy) | CXTPGridHeader | protectedvirtual
FindGroupByColumn(CPoint ptPoint, BOOL bExactSearch=FALSE) const | CXTPGridHeader | virtual
FindHeaderColumn(CPoint ptPoint) const | CXTPGridHeader | virtual
ForceLayoutAdjustment() const | CXTPGridHeader |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetControl() const | CXTPGridHeader |
GetDontDropCursor() const | CXTPGridHeader |
GetDraggingColumn() const | CXTPGridHeader |
GetFilterEditCtrl() const | CXTPGridHeader |
GetFullColScrollInfo(CXTPGridColumn *&rpPrev, CXTPGridColumn *&rpCurr, CXTPGridColumn *&rpNext, int &rnScrollPos, int &rnScrollMax) const | CXTPGridHeader |
GetGroupByHeight() const | CXTPGridHeader |
GetIndentLevel() const | CXTPGridHeader |
GetMaxAvailWidth(CXTPGridColumn *pColumn) | CXTPGridHeader | protected
GetMaxColumnWidth() const | CXTPGridHeader |
GetNextVisibleColumn(int nIndex, int nDirection) | CXTPGridHeader | virtual
GetPaintManager() const | CXTPGridHeader | protected
GetResizeCursor() const | CXTPGridHeader |
GetResizeVCursor() const | CXTPGridHeader |
GetResizingColumn() const | CXTPGridHeader |
GetSubListCtrl() const | CXTPGridHeader |
GetWidth() const | CXTPGridHeader |
GridDraggingMode enum name | CXTPGridHeader | protected
HitTest(CPoint ptPoint) const | CXTPGridHeader | virtual
HitTestHeaderColumnIndex(CPoint ptPoint) const | CXTPGridHeader | virtual
IsAllowColumnRemove() const | CXTPGridHeader |
IsAllowColumnReorder() const | CXTPGridHeader |
IsAllowColumnResize() const | CXTPGridHeader |
IsAllowColumnSort() const | CXTPGridHeader |
IsAutoColumnSizing() const | CXTPGridHeader |
IsDragHeader() const | CXTPGridHeader |
IsLastResizebleColumn(CXTPGridColumn *pColumn) const | CXTPGridHeader |
IsLastVisibleColumn(CXTPGridColumn *pColumn) const | CXTPGridHeader |
IsShowItemsInGroups() const | CXTPGridHeader |
m_bAllowColumnRemove | CXTPGridHeader | protected
m_bAllowColumnReorder | CXTPGridHeader | protected
m_bAllowColumnResize | CXTPGridHeader | protected
m_bAllowColumnSort | CXTPGridHeader | protected
m_bAutoColumnSizing | CXTPGridHeader | protected
m_bDragGroupBox | CXTPGridHeader | protected
m_bDragHeader | CXTPGridHeader | protected
m_bHideColumnAfterGroupBoxDrop | CXTPGridHeader |
m_bLastColumnExpand | CXTPGridHeader | protected
m_bLastColumnExpandKeep | CXTPGridHeader | protected
m_bShowItemsInGroups | CXTPGridHeader | protected
m_dragMode | CXTPGridHeader | protected
m_hDontDropCursor | CXTPGridHeader | protected
m_hResizeCursor | CXTPGridHeader | protected
m_hResizeVCursor | CXTPGridHeader | protected
m_nDropIndex | CXTPGridHeader | protected
m_nForceLayoutAdjustment | CXTPGridHeader | protected
m_nHeaderWidth | CXTPGridHeader | protected
m_nIndentLevel | CXTPGridHeader | protected
m_nMaxColumnWidth | CXTPGridHeader | protected
m_nResizeCaptureRange | CXTPGridHeader | protected
m_nVisIndex | CXTPGridHeader | protected
m_pColumns | CXTPGridHeader | protected
m_pControl | CXTPGridHeader | protected
m_pDragColumn | CXTPGridHeader | protected
m_pDragWnd | CXTPGridHeader | protected
m_pFilterEdit | CXTPGridHeader | protected
m_pHotTrackingColumn | CXTPGridHeader | protected
m_pResizeColumn | CXTPGridHeader | protected
m_pSubList | CXTPGridHeader | protected
m_ptMouse | CXTPGridHeader | protected
m_rcGroupBy | CXTPGridHeader | protected
m_rcHeader | CXTPGridHeader | protected
MouseOverColumnResizeArea(CPoint ptPoint) | CXTPGridHeader |
OnColumnsChanged(int nReason, CXTPGridColumn *pColumn) | CXTPGridHeader | virtual
OnContextMenu(CPoint ptClick) | CXTPGridHeader | protectedvirtual
OnLButtonDblClk(CPoint ptDblClick) | CXTPGridHeader | protectedvirtual
OnLButtonDown(CPoint ptClick) | CXTPGridHeader | protectedvirtual
OnLButtonUp(UINT nFlags, CPoint ptClick) | CXTPGridHeader | protectedvirtual
OnMouseMove(UINT nFlags, CPoint point) | CXTPGridHeader | protectedvirtual
OnToolHitTest(CPoint point, TOOLINFO *pTI) const | CXTPGridHeader | protectedvirtual
ResizeColumn(CXTPGridColumn *pColumn, int nWidth) | CXTPGridHeader | protected
s_bSendContextMenuForWholeHeaderArea | CXTPGridHeader | static
s_bShowItemsInGroupsPXDefault | CXTPGridHeader | static
s_nMinAutoScrollStep | CXTPGridHeader | static
SetAutoColumnSizing(BOOL bAutoColumnSizing) | CXTPGridHeader |
SetFilterEditCtrl(CXTPGridFilterEditControl *pFilterEdit) | CXTPGridHeader |
SetHotDivider(int nIndex, BOOL bHeader=TRUE) | CXTPGridHeader | protected
SetLastColumnExpand(BOOL bLastColumnExpand, BOOL bLastColumnExpandKeep) | CXTPGridHeader |
SetMaxColumnWidth(int nMaxColumnWidth) | CXTPGridHeader |
SetSubListCtrl(CXTPGridSubListControl *pSubList) | CXTPGridHeader |
ShowItemsInGroups(BOOL bShowInGroups) | CXTPGridHeader |
StartDragging(CXTPGridColumn *pColumn, BOOL bHeader=FALSE) | CXTPGridHeader | protected
~CXTPGridHeader() | CXTPGridHeader | virtual


Toolkit Pro: Member List

CXTPRibbonThemeVisualStudio2019 Member List

This is the complete list of members for CXTPRibbonThemeVisualStudio2019, including all inherited members.

CreateTabPaintManager() | CXTPRibbonPaintManager | protectedvirtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPRibbonMarkupTheme(CXTPPaintManager *pPaintManager) | CXTPRibbonMarkupTheme |
CXTPRibbonOffice2013Theme(CXTPPaintManager *pPaintManager) | CXTPRibbonOffice2013Theme |
CXTPRibbonPaintManager(CXTPPaintManager *pPaintManager) | CXTPRibbonPaintManager |
CXTPRibbonThemeVisualStudio2019(CXTPPaintManager *pPaintManager) | CXTPRibbonThemeVisualStudio2019 |
DrawBackImage(CDC *pDC, CXTPRibbonBar *pRibbonBar) | CXTPRibbonOffice2013Theme | protectedvirtual
DrawControlGroupOption(CDC *pDC, CXTPControl *pControlGroupOption, BOOL bDraw) | CXTPRibbonMarkupTheme | virtual
DrawControlGroupPopup(CDC *pDC, CXTPControlPopup *pControlGroupPopup, BOOL bDraw) | CXTPRibbonMarkupTheme | virtual
DrawDwmCaptionText(CDC *pDC, CRect rcCaptionText, CString strText, CWnd *pSite, BOOL bActive) | CXTPRibbonPaintManager | protected
DrawGroup(CDC *pDC, CXTPRibbonGroup *pGroup) | CXTPRibbonMarkupTheme | virtual
DrawQuickAccessControl(CDC *pDC, CXTPRibbonBar *pRibbon, CXTPControl *pControl) | CXTPRibbonOffice2013Theme | virtual
DrawRibbonApplicationIcon(CDC *pDC, CXTPRibbonBar *pRibbonBar, CRect rc, HICON hIcon) | CXTPRibbonPaintManager | protected
DrawRibbonFrameCaption(CDC *pDC, CXTPRibbonBar *pRibbonBar, BOOL bActive) | CXTPRibbonOffice2013Theme | virtual
DrawRibbonFrameCaptionBar(CDC *pDC, CXTPRibbonBar *pRibbonBar, BOOL bActive) | CXTPRibbonOffice2013Theme | virtual
DrawRibbonFrameContextHeaders(CDC *pDC, CXTPRibbonBar *pRibbonBar, CXTPRibbonTabContextHeaders *pContextHeaders) | CXTPRibbonOffice2013Theme | virtual
DrawRibbonFramePart(CDC *pDC, CXTPRibbonBar *pRibbonBar) | CXTPRibbonPaintManager | virtual
DrawRibbonFrameSystemButton(CDC *pDC, CXTPRibbonControlSystemButton *pControl, CRect rc) | CXTPRibbonOffice2013Theme | virtual
DrawRibbonGroupControlEntry(CDC *pDC, CXTPControl *pButton) | CXTPRibbonMarkupTheme | virtual
DrawRibbonGroupPopupToolBar(CDC *pDC, CXTPRibbonGroup *pRibbonGroup) | CXTPRibbonMarkupTheme | virtual
DrawRibbonQuickAccessButton(CDC *pDC, CXTPControlPopup *pControl) | CXTPRibbonMarkupTheme | virtual
DrawRibbonQuickAccessControls(CDC *pDC, CXTPRibbonBar *pRibbonBar) | CXTPRibbonMarkupTheme | virtual
DrawRibbonQuickAccessMoreButton(CDC *pDC, CXTPControlPopup *pControl) | CXTPRibbonMarkupTheme | virtual
DrawRibbonScrollButton(CDC *pDC, CXTPControl *pControl, BOOL bScrollLeft) | CXTPRibbonMarkupTheme | virtual
DrawRibbonTab(CDC *pDC, CXTPRibbonTab *pItem) | CXTPRibbonOffice2013Theme | virtual
DrawSystemPopupBarButton(CDC *pDC, CXTPControl *pButton) | CXTPRibbonMarkupTheme | virtual
FillGroupPopupToolBar(CDC *pDC, CXTPRibbonGroup *pGroup, CXTPCommandBar *pCommandBar) | CXTPRibbonMarkupTheme | virtual
FillGroupRect(CDC *pDC, CXTPRibbonTab *pActiveTab, CRect rcGroups) | CXTPRibbonMarkupTheme | virtual
FillMorePopupToolBarEntry(CDC *pDC, CXTPCommandBar *pBar) | CXTPRibbonMarkupTheme | virtual
FillRibbonBar(CDC *pDC, CXTPRibbonBar *pRibbonBar) | CXTPRibbonOffice2013Theme | virtual
FillRibbonTabControl(CDC *pDC, CXTPRibbonBar *pRibbonBar, CRect rcControl) | CXTPRibbonMarkupTheme | virtual
FillSystemPopupBarEntry(CDC *pDC, CXTPPopupBar *pBar) | CXTPRibbonMarkupTheme | virtual
FillTabPopupToolBar(CDC *pDC, CXTPPopupToolBar *pPopupToolBar) | CXTPRibbonPaintManager | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetBackImageName() | CXTPRibbonOffice2013Theme | protectedvirtual
GetControlGroupOptionSize() const | CXTPRibbonMarkupTheme | virtual
GetEditHeight() const | CXTPRibbonPaintManager |
GetFontHeight() const | CXTPRibbonPaintManager |
GetFramePaintManager() const | CXTPRibbonPaintManager |
GetGroupCaptionHeight() const | CXTPRibbonPaintManager |
GetImages() const | CXTPRibbonPaintManager |
GetRibbonCaptionHeight(const CXTPRibbonBar *pRibbonBar) const | CXTPRibbonOffice2013Theme | virtual
GetTabPaintManager() const | CXTPRibbonPaintManager |
LoadImage(LPCTSTR lpszFileName) | CXTPRibbonPaintManager |
LoadParts(BOOL bReload=FALSE) | CXTPRibbonOffice2013Theme | protectedvirtual
CXTPRibbonMarkupTheme::LoadParts(HZIP hZip, CXTPMarkupContext *pMarkupContext=NULL) | CXTPRibbonMarkupTheme |
m_bFlatFrame | CXTPRibbonPaintManager |
m_bHotTrackingGroups | CXTPRibbonPaintManager |
m_clrBackstageSysButtonBack2013Highlighted | CXTPRibbonMarkupTheme | protected
m_clrBackstageSysButtonBack2013Normal | CXTPRibbonMarkupTheme | protected
m_clrFileButtonText | CXTPRibbonPaintManager | protected
m_clrHeader | CXTPRibbonOffice2013Theme | protected
m_clrMinimizedFrameEdgeHighLight | CXTPRibbonPaintManager | protected
m_clrMinimizedFrameEdgeShadow | CXTPRibbonPaintManager | protected
m_clrRecentFileListEdgeHighLight | CXTPRibbonPaintManager |
m_clrRecentFileListEdgeShadow | CXTPRibbonPaintManager |
m_clrRibbonBorder | CXTPRibbonPaintManager | protected
m_clrRibbonFace | CXTPRibbonPaintManager | protected
m_clrRibbonGroupCaptionText | CXTPRibbonPaintManager | protected
m_clrRibbonInactiveFace | CXTPRibbonPaintManager | protected
m_clrRibbonInactiveFaceState | CXTPRibbonOffice2013Theme | protected
m_clrRibbonTabDelimeter | CXTPRibbonOffice2013Theme | protected
m_clrTabBackackstageLeft | CXTPRibbonOffice2013Theme | protected
m_clrTabBackackstageRight | CXTPRibbonOffice2013Theme | protected
m_clrTabBackInactiveState | CXTPRibbonOffice2013Theme | protected
m_fontGroupCaption | CXTPRibbonPaintManager |
m_nGroupCaptionHeight | CXTPRibbonPaintManager |
m_nGroupSpacing | CXTPRibbonPaintManager |
m_nTabsHeight | CXTPRibbonPaintManager |
m_pMarkupContext | CXTPRibbonMarkupTheme | protected
m_pPaintManager | CXTPRibbonPaintManager | protected
m_pTabPaintManager | CXTPRibbonPaintManager | protected
m_rcFileButtonMargin | CXTPRibbonPaintManager | protected
m_strHighlightedPrefix | CXTPRibbonMarkupTheme | protected
m_strNormalPrefix | CXTPRibbonMarkupTheme | protected
RefreshMetrics() | CXTPRibbonOffice2013Theme | virtual
RenderMarkup(CDC *pDC, CRect rc, LPCTSTR lpszText) | CXTPRibbonMarkupTheme |
RenderMarkup(CDC *pDC, CRect rc, XTPRibbonThemePart part) | CXTPRibbonMarkupTheme |
SetBackImage(int nImage) | CXTPRibbonOffice2013Theme | virtual
SetFontHeight(int nFontHeight) | CXTPRibbonPaintManager |
~CXTPRibbonMarkupTheme() | CXTPRibbonMarkupTheme | virtual
~CXTPRibbonOffice2013Theme() | CXTPRibbonOffice2013Theme | virtual
~CXTPRibbonPaintManager() | CXTPRibbonPaintManager | virtual
~CXTPRibbonThemeVisualStudio2019() | CXTPRibbonThemeVisualStudio2019 | virtual


Toolkit Pro: Member List

CXTPSkinImage Member List

This is the complete list of members for CXTPSkinImage, including all inherited members.

CreateSolidRectArray(int nBitmaps, BOOL bHorizontalImage, const CRect &rcSizingMargins) | CXTPSkinImage |
CXTPSkinImage() | CXTPSkinImage |
DrawImage(CDC *pDC, const CRect &rcDest, const CRect &rcSrc, const CRect &rcSizingMargins, int nSizingType, BOOL bBorderOnly) | CXTPSkinImage |
DrawImage(CDC *pDC, const CRect &rcDest, const CRect &rcSrc, const CRect &rcSizingMargins, COLORREF clrTransparent, int nSizingType, BOOL bBorderOnly) | CXTPSkinImage |
GetAccessCriticalSection() const | CXTPSynchronized | inline
GetExtent() const | CXTPSkinImage |
GetHeight() const | CXTPSkinImage |
GetSource(int nState=0, int nCount=1) const | CXTPSkinImage |
GetWidth() const | CXTPSkinImage |
IsAlphaImage() const | CXTPSkinImage |
LoadFile(LPCTSTR lpszFileName) | CXTPSkinImage |
LoadFile(HMODULE hModule, LPCTSTR lpszBitmapFileName) | CXTPSkinImage |
m_arrSolidRects | CXTPSkinImage | protected
m_bAlpha | CXTPSkinImage | protected
m_bFiltered | CXTPSkinImage | protected
m_bInvert | CXTPSkinImage | protected
m_bMirrorImage | CXTPSkinImage |
m_bOptimized | CXTPSkinImage | protected
m_hBitmap | CXTPSkinImage | protected
m_szBitmap | CXTPSkinImage | protected
SetBitmap(HBITMAP hBitmap, BOOL bAlpha=FALSE) | CXTPSkinImage |
~CXTPSkinImage() | CXTPSkinImage | virtual


Toolkit Pro: Member List

CXTPTreeNativeWindows10Theme Member List

This is the complete list of members for CXTPTreeNativeWindows10Theme, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPControlTheme() | CXTPControlTheme |
CXTPTreeNativeWindows10Theme() | CXTPTreeNativeWindows10Theme |
CXTPTreeOffice2013Theme() | CXTPTreeOffice2013Theme |
CXTPTreeTheme() | CXTPTreeTheme |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetItemBackColor(UINT uState, bool bTreeHasFocus, DWORD dwStyle, COLORREF crTextDef, CTreeCtrl *pTreeBase) const | CXTPTreeTheme | virtual
GetItemTextColor(UINT uState, bool bTreeHasFocus, DWORD dwStyle, COLORREF crBackDef, CTreeCtrl *pTreeBase) const | CXTPTreeTheme | virtual
GetThemeStyle() const | CXTPControlTheme |
GetTreeBackColor() const | CXTPTreeTheme | virtual
GetTreeTextColor() const | CXTPTreeTheme | virtual
IsDrawFocusRect() const | CXTPTreeTheme | inline
IsThemeDark() const | CXTPTreeTheme | inlinevirtual
m_bDarkTheme | CXTPTreeTheme | protected
m_bDrawFocusRect | CXTPTreeTheme | protected
m_crBack | CXTPTreeTheme | protected
m_crBackDisabled | CXTPTreeTheme | protected
m_crBackSelected | CXTPTreeTheme | protected
m_crBackSelectedDisabled | CXTPTreeTheme | protected
m_crBackSelectedInactive | CXTPTreeTheme | protected
m_crText | CXTPTreeTheme | protected
m_crTextDisabled | CXTPTreeTheme | protected
m_crTextSelected | CXTPTreeTheme | protected
m_crTextSelectedDisabled | CXTPTreeTheme | protected
m_crTextSelectedInactive | CXTPTreeTheme | protected
m_nTheme | CXTPControlTheme | protected
RefreshMetrics(CXTPTreeBase *pTreeBase) | CXTPTreeOffice2013Theme | virtual
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static
~CXTPTreeTheme() | CXTPTreeTheme | virtual


Toolkit Pro: Member List

CXTPColorSelectorCtrlThemeNativeWindows10 Member List

This is the complete list of members for CXTPColorSelectorCtrlThemeNativeWindows10, including all inherited members.

CalcSize(CXTPColorSelectorCtrl *pOwner) | CXTPColorSelectorCtrlThemeOffice2013 | virtual
CreateAutoButton(CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked) | CXTPColorSelectorCtrlThemeOffice2013 | virtual
CreateColorButtons(CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked) | CXTPColorSelectorCtrlTheme | virtual
CreateExtendedButtons(CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked) | CXTPColorSelectorCtrlThemeOffice2013 | virtual
CreateMoreButton(CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked) | CXTPColorSelectorCtrlThemeOffice2013 | virtual
CreateRecentColorButtons(CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked) | CXTPColorSelectorCtrlThemeOffice2013 | virtual
CreateThemeButtons(CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked) | CXTPColorSelectorCtrlThemeOffice2013 | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPColorSelectorCtrlTheme() | CXTPColorSelectorCtrlTheme |
CXTPColorSelectorCtrlThemeNativeWindows10() | CXTPColorSelectorCtrlThemeNativeWindows10 |
CXTPColorSelectorCtrlThemeOffice2013() | CXTPColorSelectorCtrlThemeOffice2013 |
CXTPColorSelectorCtrlThemeVisualStudio2015() | CXTPColorSelectorCtrlThemeVisualStudio2015 |
CXTPControlTheme() | CXTPControlTheme |
DrawBorder(CDC *pDC, CRect rcItem, CRect rcBorder, COLORREF crBorder) | CXTPColorSelectorCtrlThemeOffice2013 | virtual
DrawColor(CDC *pDC, CXTPColorSelectorCtrl *pOwner, CXTPColorSelectorCtrl::COLOR_CELL *pColorCell, CRect rcItem, BOOL bChecked, BOOL bHighlight, BOOL bPressed) | CXTPColorSelectorCtrlThemeOffice2013 | virtual
DrawColorCell(CDC *pDC, CXTPColorSelectorCtrl *pOwner, CXTPColorSelectorCtrl::COLOR_CELL *pColorCell, BOOL bHighlight, BOOL bPressed) | CXTPColorSelectorCtrlThemeVisualStudio2015 | virtual
DrawColorSelector(CDC *pDC, CXTPColorSelectorCtrl *pOwner) | CXTPColorSelectorCtrlThemeOffice2013 | virtual
FillBackground(CDC *pDC, CXTPColorSelectorCtrl *pOwner, const CRect &rect) | CXTPColorSelectorCtrlTheme | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetButtonSize() const | CXTPColorSelectorCtrlTheme | virtual
GetThemeStyle() const | CXTPControlTheme |
m_bThinBorder | CXTPColorSelectorCtrlTheme |
m_crBack | CXTPColorSelectorCtrlTheme |
m_crBackChecked | CXTPColorSelectorCtrlTheme |
m_crBackHilight | CXTPColorSelectorCtrlTheme |
m_crBackPressed | CXTPColorSelectorCtrlTheme |
m_crBorder | CXTPColorSelectorCtrlTheme |
m_crBorderHilight | CXTPColorSelectorCtrlTheme |
m_crBorderInside | CXTPColorSelectorCtrlThemeOffice2013 | protected
m_crBorderPressed | CXTPColorSelectorCtrlTheme |
m_crPopupBorder | CXTPColorSelectorCtrlTheme |
m_crText | CXTPColorSelectorCtrlTheme |
m_crTextPressed | CXTPColorSelectorCtrlTheme |
m_crTitleBack | CXTPColorSelectorCtrlThemeOffice2013 | protected
m_crTitleText | CXTPColorSelectorCtrlThemeOffice2013 | protected
m_nAutoButton | CXTPColorSelectorCtrlTheme |
m_nCaption | CXTPColorSelectorCtrlTheme |
m_nMargin | CXTPColorSelectorCtrlTheme |
m_nTheme | CXTPControlTheme | protected
m_rcRecentText | CXTPColorSelectorCtrlTheme |
m_rcStandardText | CXTPColorSelectorCtrlTheme |
m_rcThemeText | CXTPColorSelectorCtrlTheme |
m_sizeButton | CXTPColorSelectorCtrlTheme |
RefreshMetrics(CXTPColorSelectorCtrl *pOwner) | CXTPColorSelectorCtrlThemeVisualStudio2015 | virtual
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static


Toolkit Pro: Member List

CXTPTabThemeVisualStudio2012 Member List

This is the complete list of members for CXTPTabThemeVisualStudio2012, including all inherited members.

AdjustClientRect(CXTPTabManager *pTabManager, CRect &rcClient) | CXTPTabPaintManagerTheme | virtual
CXTPTabPaintManagerTheme() | CXTPTabPaintManagerTheme |
CXTPTabThemeFlat() | CXTPTabThemeFlat | inline
DrawSingleButton(CDC *pDC, CXTPTabManagerItem *pItem) | CXTPTabThemeVisualStudio2012 | virtual
DrawTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl) | CXTPTabPaintManagerTheme | virtual
DrawText(CDC *pDC, CXTPTabManager *pManager, const CString &str, LPRECT lpRect, UINT nFormat) | CXTPTabPaintManagerTheme | virtual
DrawWorkspacePart(CDC *pDC, LPRECT lpRect, XTPTabWorkspacePart workspacePart) | CXTPTabThemeVisualStudio2012 | virtual
FillButton(CDC *pDC, CXTPTabManagerItem *pItem, LPPOINT pts, int nCount, XTPTabPosition tabPosition, BOOL bAbsolute=FALSE) | CXTPTabPaintManagerTheme |
FillTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl) | CXTPTabThemeFlat | virtual
GetButtonDrawRect(const CXTPTabManagerItem *pItem) | CXTPTabPaintManagerTheme | virtual
GetButtonHeight(const CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetButtonLength(CDC *pDC, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerTheme | virtual
GetClientMargin() | CXTPTabPaintManagerTheme | virtual
GetClientRect(CRect rcControl, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetColorSet() const | CXTPTabPaintManagerTheme |
GetDefaultColorSet() | CXTPTabThemeVisualStudio2012 | inlinevirtual
GetHeaderClipBox(CDC *pDC, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetHeaderHeight(CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme |
GetHeaderMargin() | CXTPTabPaintManagerTheme | virtual
GetHeaderRect(CRect rcControl, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetSupportedColorSets() | CXTPTabPaintManagerTheme | inlinevirtual
m_bButtonsReverseZOrder | CXTPTabPaintManagerTheme | protected
m_nButtonHeight | CXTPTabPaintManagerTheme | protected
m_nRowMargin | CXTPTabPaintManagerTheme |
m_pPaintManager | CXTPTabPaintManagerTheme | protected
m_rcHeaderMargin | CXTPTabPaintManagerTheme |
RefreshMetrics() | CXTPTabThemeVisualStudio2012 | virtual
RepositionTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcClient) | CXTPTabPaintManagerTheme | virtual
~CXTPTabPaintManagerTheme() | CXTPTabPaintManagerTheme | virtual


Toolkit Pro: Member List

CXTPCalendarEventColorNewDlg Member List

This is the complete list of members for CXTPCalendarEventColorNewDlg, including all inherited members.

CXTPCalendarEventColorNewDlg(BOOL bCategories, CWnd *pParent=NULL) | CXTPCalendarEventColorNewDlg |
EnableOkButton() | CXTPCalendarEventColorNewDlg | protectedvirtual
m_bCategories | CXTPCalendarEventColorNewDlg | protected


Toolkit Pro: Member List

CXTPGridRows Member List

This is the complete list of members for CXTPGridRows, including all inherited members.

Add(CXTPGridRow *pRow) | CXTPGridRows | virtual
Clear(BOOL bResetRow=TRUE) | CXTPGridRows | virtual
ClearMergeHeight() | CXTPGridRows |
CompareRows(const CXTPGridRow **pRow1, const CXTPGridRow **pRow2) | CXTPGridRows | static
CompareRows2(const CXTPGridRow **pRow1, const CXTPGridRow **pRow2) | CXTPGridRows | static
Contains(const CXTPGridRow *pRow) const | CXTPGridRows | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPGridRows() | CXTPGridRows |
Find(CXTPGridRecord *pRecord) | CXTPGridRows | virtual
Find(CXTPGridRecord *pRecord, BOOL bRecursive) | CXTPGridRows | virtual
FindInsertionPos(CXTPGridRow *pRow, BOOL &bInsertAfter) | CXTPGridRows | virtual
FindInTree(CXTPGridRecord *pRecord) | CXTPGridRows | virtual
FindRecordItemByRows(int nStartIndex, int nEndIndex, int nStartColumn, int nEndColumn, int nRecordIndex, int nItem, LPCTSTR pcszText, int nFlags) | CXTPGridRows | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAt(int nIndex) const | CXTPGridRows | virtual
GetCount() const | CXTPGridRows |
GetFocusedRow() | CXTPGridRows | virtual
GetFocusedRowIndex() const | CXTPGridRows | virtual
GetNext(CXTPGridRow *pRow, BOOL bSkipGroupFocus) | CXTPGridRows | virtual
GetPrev(CXTPGridRow *pRow, BOOL bSkipGroupFocus) | CXTPGridRows | virtual
GetScreenRows() | CXTPGridRows | virtual
HasFocus() const | CXTPGridRows | virtual
InsertAt(int nIndex, CXTPGridRow *pRow) | CXTPGridRows | virtual
m_nFocusedRow | CXTPGridRows | protected
m_nVirtualRowsCount | CXTPGridRows | protected
m_pScreenRows | CXTPGridRows | protected
m_pVirtualRow | CXTPGridRows | protected
operator delete(void *p) | CXTPHeapObjectT< CXTPCmdTarget, CXTPGridDataAllocator > | inline
operator new(size_t nSize) | CXTPHeapObjectT< CXTPCmdTarget, CXTPGridDataAllocator > | inline
RefreshChildIndices(BOOL bRunInChildren=TRUE) | CXTPGridRows | virtual
RemoveAt(int nIndex) | CXTPGridRows | virtual
RemoveAt(int nStartIndex, int nCount) | CXTPGridRows | virtual
RemoveRow(CXTPGridRow *pRow) | CXTPGridRows | virtual
SetFocusedRowIndex(int nRow) | CXTPGridRows | virtual
SetVirtualMode(CXTPGridRow *pRow, int nCount) | CXTPGridRows | virtual
Sort() | CXTPGridRows | virtual
SortEx(XTPGridRowsCompareFunc pCompareFunc) | CXTPGridRows | virtual
~CXTPGridRows() | CXTPGridRows | virtual


Toolkit Pro: Member List

CXTPMarqueeCtrlPaintManager Member List

This is the complete list of members for CXTPMarqueeCtrlPaintManager, including all inherited members.

CXTPMarqueeCtrlPaintManager() | CXTPMarqueeCtrlPaintManager |
DeflateRect(CDC *pDC, CRect &rcClient) | CXTPMarqueeCtrlPaintManager | protectedvirtual
DrawBackground(CXTPMarqueeCtrl *pWndCtrl, CDC *pDC, CRect &rcClient) | CXTPMarqueeCtrlPaintManager | virtual
DrawChunk(CXTPMarqueeCtrl *pWndCtrl, CDC *pDC, CXTPCompatibleDC &dcChunk, int i, int &x, int &y, int cx, int cy) | CXTPMarqueeCtrlPaintManager | protectedvirtual
DrawMarquee(CXTPMarqueeCtrl *pWndCtrl, CDC *pDC, CRect &rcClient) | CXTPMarqueeCtrlPaintManager | virtual
GetBackColor() | CXTPMarqueeCtrlPaintManager |
GetBarColor() | CXTPMarqueeCtrlPaintManager |
GetBorderColor() | CXTPMarqueeCtrlPaintManager |
m_bUseWinTheme | CXTPMarqueeCtrlPaintManager | protected
m_clr3DHilite | CXTPMarqueeCtrlPaintManager | protected
m_clr3DShadow | CXTPMarqueeCtrlPaintManager | protected
m_clrBack | CXTPMarqueeCtrlPaintManager | protected
m_clrBar | CXTPMarqueeCtrlPaintManager | protected
m_nTheme | CXTPMarqueeCtrlPaintManager | protected
m_winTheme | CXTPMarqueeCtrlPaintManager | protected
RefreshMetrics() | CXTPMarqueeCtrlPaintManager | virtual
SetBackColor(COLORREF clrNew) | CXTPMarqueeCtrlPaintManager |
SetBarColor(COLORREF clrNew) | CXTPMarqueeCtrlPaintManager |
SetBorderColor(COLORREF clrNew) | CXTPMarqueeCtrlPaintManager |
UseWinThemes(BOOL bUseWinThemes=TRUE) | CXTPMarqueeCtrlPaintManager |
UsingWinThemes(BOOL bCheckReady=FALSE) | CXTPMarqueeCtrlPaintManager |
~CXTPMarqueeCtrlPaintManager() | CXTPMarqueeCtrlPaintManager | virtual


Toolkit Pro: XTPCalendarThemeOffice2007.h Source File

  • Source
  • Calendar
XTPCalendarThemeOffice2007.h
Go to the documentation of this file.
1
22#if !defined(_XTP_CALENDAR_THEME_OFFICE_2007_H__)
23# define _XTP_CALENDAR_THEME_OFFICE_2007_H__
24
25# if _MSC_VER > 1000
26# pragma once
27# endif // _MSC_VER > 1000
28
29# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
30
31# if (_MSC_VER > 1100)
32# pragma warning(push)
33# endif
34
35# pragma warning(disable : 4250)
36//#pragma warning(disable: 4097)
37
38# pragma warning(disable : 4100) // TODO: remove when themes will be finished
39
40class CXTPResourceImages;
41class CXTPImageManager;
42class CXTPCalendarResources;
43class CXTPNotifySink;
44class CXTPCalendarEventCategories;
45class CXTPCalendarEventCategoryIDs;
46
48// Initial version. Will be expanded in the feature.
49
50class _XTP_EXT_CLASS CXTPCalendarThemeOffice2007 : public CXTPCalendarTheme
51{
52 DECLARE_DYNCREATE(CXTPCalendarThemeOffice2007)
53
54 typedef CXTPCalendarTheme TBase;
55
56public:
57 DECLARE_THEMEPART(CTOHeader, CXTPCalendarTheme::CTOHeader)
58
59 DECLARE_THEMEPART_MEMBER(0, CTOFormula_MulDivC, HeightFormula)
60 //===========================================
61 virtual void RefreshMetrics(BOOL bRefreshChildren = TRUE);
62
63 virtual void Draw(CCmdTarget* pObject, CDC* pDC)
64 {
65 _ASSERTE(FALSE);
66 };
67
68protected:
69};
71friend class CTOHeader;
73//=======================================================================
74DECLARE_THEMEPART(CTOEvent, CXTPCalendarTheme::CTOEvent)
75struct CEventFontsColorsSet
76{
77 virtual ~CEventFontsColorsSet()
78 {
79 }
80
81 CXTPPaintManagerColor clrBorder;
82 CXTPPaintManagerColorGradient grclrBackground;
83
84 CThemeFontColorSetValue fcsetSubject;
85 CThemeFontColorSetValue fcsetLocation;
86 CThemeFontColorSetValue fcsetBody;
87
88 CThemeFontColorSetValue fcsetStartEnd;
90 virtual void CopySettings(const CEventFontsColorsSet& rSrc);
91
92 virtual void doPX(CXTPPropExchange* pPX, LPCTSTR pcszPropName, CXTPCalendarTheme* pTheme);
93 virtual void Serialize(CArchive& ar);
94};
95
96CEventFontsColorsSet m_fcsetNormal;
97CEventFontsColorsSet m_fcsetSelected;
98
99 CXTPPaintManagerColor m_clrGripperBorder;
100 CXTPPaintManagerColor m_clrGripperBackground;
101
102virtual void RefreshMetrics(BOOL bRefreshChildren = TRUE);
103virtual void RefreshFromParent(CTOEvent* pParentSrc);
104
105virtual void DoPropExchange(CXTPPropExchange* pPX);
106virtual void Serialize(CArchive& ar);
107
108virtual int CalcMinEventHeight(CDC* pDC);
109
110virtual void GetEventColors(CDC* pDC, CXTPCalendarViewEvent* pViewEvent, COLORREF& rClrBorder,
111 COLORREF& rClrBorderNotSel, CXTPPaintManagerColorGradient& rGrclrBk,
112 BOOL bSelected = -1, int* pnColorsSrc_1Cat2Lbl = NULL);
113
114virtual void GetShowAsStatusColors(CDC* pDC, CXTPCalendarViewEvent* pViewEvent, COLORREF& clrBorder,
115 COLORREF& clrBorderNotSel,
116 CXTPPaintManagerColorGradient& grclrBk);
117virtual BOOL DrawShowAsStatus(CDC* pDC, CXTPCalendarViewEvent* pViewEvent,
118 CXTPCalendarThemeOffice2007* pThemeX, const CRect& rcEvent,
119 LONG& lShowAsBlockWidth);
120
121virtual void FillEventBackgroundEx(CDC* pDC, CXTPCalendarViewEvent* pViewEvent,
122 const CRect& rcRect);
123
124virtual void MultidayDrawTime(int nMDEFlags, CXTPCalendarViewEvent* pViewEvent, CDC* pDC,
125 const CRect& rcEvent, BOOL fStartTimeAsClock, BOOL fEndTimeAsClock,
126 CRect& rcText);
127virtual void MultidayDrawTimeBlocks(CDC* pDC, const CRect& rcEventRect,
128 CXTPCalendarViewEvent* pViewEvent, BOOL MultiDayFirstPart,
129 BOOL MultiDayLastPart, BOOL fStartTimeAsClock,
130 BOOL fEndTimeAsClock);
131virtual void GetMultidayTimeFontAndColor(CFont*& pFont, COLORREF& clrColor, BOOL bSelected);
132
133protected:
134virtual BOOL Draw_ArrowL(CXTPCalendarViewEvent* pViewEvent, CDC* pDC, CRect& rrcRect,
135 LONG lArrowOffset = 0);
136virtual BOOL Draw_ArrowR(CXTPCalendarViewEvent* pViewEvent, CDC* pDC, CRect& rrcRect);
137
138virtual CSize Draw_Icons(CXTPCalendarViewEvent* pViewEvent, CDC* pDC, const CRect& rcIconsMax,
139 BOOL bCalculate = FALSE);
140
141virtual void InitBusyStatusDefaultColors();
142}
143;
145friend class CTOEvent;
147DECLARE_THEMEPART(CTODay, CXTPCalendarTheme::CTODay)
148virtual int HitTestExpandDayButton(
149 const CXTPCalendarViewDay* pViewDay,
150 const CPoint* pPoint = NULL);
151}
152;
153
155// ******** Day View *********
156
157//=======================================================================
158DECLARE_THEMEPART2(CTODayViewEvent, CTOEvent, CXTPCalendarTheme::CTODayViewEvent)
159
160DECLARE_THEMEPART_MEMBER(0, CTOEventIconsToDraw, EventIconsToDraw)
161DECLARE_THEMEPART_MEMBER(1, CTOFormula_MulDivC, HeightFormula)
162
163virtual void RefreshMetrics(BOOL bRefreshChildren = TRUE);
164
165protected:
166BOOL NeedDrawCategoryIcons(CXTPCalendarEvent* pEvent);
167void DrawCategoryIcons(CDC* pDC, CXTPCalendarEvent* pEvent, const CRect& rcCategoryIcons);
168bool GetCategoryIconColors(CXTPCalendarEventCategories* pCategories,
169 CXTPCalendarEventCategoryIDs* pCategoryIDs, int nCategoryIdx,
170 COLORREF& clrCatColor, COLORREF& clrIconBorder);
171int CalcCategoryAreaWidth(int nCategoriesCount);
172}
173;
174
175DECLARE_THEMEPART2(CTODayViewEvent_MultiDay, CTODayViewEvent,
176 CXTPCalendarTheme::CTODayViewEvent_MultiDay)
177
178 CXTPCalendarThemeStringValue m_strDateFormatFrom;
179 CXTPCalendarThemeStringValue m_strDateFormatTo;
180 CXTPCalendarThemeBOOLValue m_bShowFromToArrowTextAlways;
181
182virtual void AdjustLayout(CCmdTarget* pObject, CDC* pDC, const CRect& rcRect,
183 int nEventPlaceNumber);
184virtual void RefreshMetrics(BOOL bRefreshChildren = TRUE);
185
186virtual void DoPropExchange(CXTPPropExchange* pPX);
187virtual void Serialize(CArchive& ar);
188
189virtual void Draw(CCmdTarget* pObject, CDC* pDC);
190
191virtual void CalcEventYs(CRect& rcRect, int nEventPlaceNumber);
192
193protected:
194virtual BOOL Draw_ArrowLtext(CXTPCalendarViewEvent* pViewEvent, CDC* pDC,
195 CThemeFontColorSetValue* pfcsetText, CRect& rrcRect, int nLeft_x);
196virtual BOOL Draw_ArrowRtext(CXTPCalendarViewEvent* pViewEvent, CDC* pDC,
197 CThemeFontColorSetValue* pfcsetText, CRect& rrcRect, int nRight_x);
198
199virtual CString Format_FromToDate(CXTPCalendarViewEvent* pViewEvent, int nStart1End2);
200
201void DrawCategoryIcons(CDC* pDC, CXTPCalendarViewEvent* pViewEvent, CRect rcCategoryIcons,
202 const CRect& rcEventMax);
203CRect AdjustCategoryIconsRectWidth(const CRect& rcCategoryIconsBase, const CRect& rcEvent,
204 int nCategoriesCount);
205}
206;
208friend class CTODayViewEvent_MultiDay;
210DECLARE_THEMEPART2(CTODayViewEvent_SingleDay, CTODayViewEvent,
211 CXTPCalendarTheme::CTODayViewEvent_SingleDay)
212virtual void RefreshMetrics(BOOL bRefreshChildren = TRUE);
213virtual void AdjustLayout(CCmdTarget* pObject, CDC* pDC, const CRect& rcRect,
214 int nEventPlaceNumber);
215virtual void Draw(CCmdTarget* pObject, CDC* pDC);
216virtual void DrawShadow(CDC* pDC, CXTPCalendarDayViewEvent* pViewEvent);
217
218private:
219void DrawCategoryIcons(CDC* pDC, CXTPCalendarViewEvent* pViewEvent, const CRect& rcText,
220 const CRect& rcTopRow);
221CRect CalcCategoryIconsRect(int nCategoriesCount, const CRect& rcText, const CRect& rcTopRow);
222}
223;
225friend class CTODayViewEvent_SingleDay;
227//=======================================================================
228DECLARE_THEMEPART(CTODayViewTimeScale, CXTPCalendarTheme::CTODayViewTimeScale)
229virtual void RefreshMetrics(BOOL bRefreshChildren = TRUE);
230
231virtual int CalcMinRowHeight(CDC* pDC, CXTPCalendarDayViewTimeScale* pTimeScale);
232
233DECLARE_THEMEPART_MEMBER(0, CTOFormula_MulDivC, HeightFormula)
234}
235;
236
237//=======================================================================
238DECLARE_THEMEPART2(CTODayViewDayGroupHeader, CTOHeader, CXTPCalendarTheme::CTODayViewDayGroupHeader)
239virtual void RefreshMetrics(BOOL bRefreshChildren = TRUE);
240virtual void Draw(CCmdTarget* pObject, CDC* pDC);
241}
242;
243
244DECLARE_THEMEPART(CTODayViewDayGroupAllDayEvents, CXTPCalendarTheme::CTODayViewDayGroupAllDayEvents)
245
246virtual void RefreshMetrics(BOOL bRefreshChildren = TRUE);
247
248virtual void Draw(CCmdTarget* pObject, CDC* pDC);
249
250virtual void SetDynColors(CXTPCalendarDayViewGroup* pViewGroup);
251
252protected:
253COLORREF m_clrDynHatch;
254int m_nDynBusyStatus;
255}
256;
257
258DECLARE_THEMEPART(CTODayViewDayGroupCell, CXTPCalendarTheme::CTODayViewDayGroupCell)
259
260COLORREF m_clrDynHatchBrush;
261
262virtual void RefreshMetrics(BOOL bRefreshChildren = TRUE);
263virtual int CalcHeight(CDC* pDC, int nCellWidth)
264{
265 return 23;
266}
267
268virtual void Draw(CDC* pDC, const CRect& rcRect,
269 const XTP_CALENDAR_THEME_DAYVIEWCELL_PARAMS& cellParams,
270 CXTPPropsStateContext* pStateCnt = NULL);
271using TBase::Draw;
272}
273;
274
275//=======================================================================
276DECLARE_THEMEPART(CTODayViewDayGroup, CXTPCalendarTheme::CTODayViewDayGroup)
277
278virtual void RefreshMetrics(BOOL bRefreshChildren = TRUE);
279virtual void Draw(CCmdTarget* pObject, CDC* pDC);
280
281virtual BOOL IsSelected(CXTPCalendarViewGroup* pViewGroup);
283DECLARE_THEMEPART_MEMBER(0, CTODayViewDayGroupHeader, Header)
284DECLARE_THEMEPART_MEMBER(1, CTODayViewDayGroupAllDayEvents, AllDayEvents)
285DECLARE_THEMEPART_MEMBER(2, CTODayViewDayGroupCell, Cell)
286DECLARE_THEMEPART_MEMBER(3, CTODayViewEvent_MultiDay, MultiDayEvent)
287DECLARE_THEMEPART_MEMBER(4, CTODayViewEvent_SingleDay, SingleDayEvent)
289public:
290virtual void OnMouseMove(CCmdTarget* pObject, UINT nFlags, CPoint point);
291virtual BOOL OnLButtonDown(CCmdTarget* pObject, UINT nFlags, CPoint point);
292
293virtual CRect GetScrollButtonRect(const XTP_DAY_VIEW_GROUP_LAYOUT& groupLayout, int nButton);
294
295protected:
296virtual void AdjustDayEvents(CXTPCalendarDayViewGroup* pDayViewGroup, CDC* pDC);
297int HitTestAllDayEventsScrollIcons(const CXTPCalendarDayViewGroup* pDVGroup, const CPoint& point);
298}
299;
300
301DECLARE_THEMEPART2(CTODayViewDayHeader, CTOHeader, CXTPCalendarTheme::CTODayViewDayHeader)
302
303 CXTPCalendarThemeBOOLValue m_UseOffice2003HeaderFormat;
304
305CTODayViewDayHeader()
306{
307 m_nWeekDayFormat = 0;
308}
309
310virtual void RefreshMetrics(BOOL bRefreshChildren = TRUE);
311virtual void AdjustLayout(CCmdTarget* pObject, CDC* pDC, const CRect& rcRect);
312virtual void Draw(CCmdTarget* pObject, CDC* pDC);
313
314virtual void DoPropExchange(CXTPPropExchange* pPX);
315virtual void Serialize(CArchive& ar);
316
317private:
318int m_nWeekDayFormat;
319}
320;
321
322//=======================================================================
323DECLARE_THEMEPART(CTODayViewDay, CXTPCalendarTheme::CTODayViewDay)
324
325 CXTPPaintManagerColor m_clrBorder;
326 CXTPPaintManagerColor m_clrTodayBorder;
327
328DECLARE_THEMEPART_MEMBER(0, CTODayViewDayHeader, Header)
329DECLARE_THEMEPART_MEMBER(1, CTODayViewDayGroup, Group)
330
331virtual void RefreshMetrics(BOOL bRefreshChildren = TRUE);
332
333virtual void DoPropExchange(CXTPPropExchange* pPX);
334virtual void Serialize(CArchive& ar);
335
336virtual void Draw(CCmdTarget* pObject, CDC* pDC);
337
338virtual void Draw_DayBorder(CXTPCalendarDayViewDay* pDayViewDay, CDC* pDC);
339virtual CRect ExcludeDayBorder(CXTPCalendarDayViewDay* pDayViewDay, const CRect& rcDay);
340
341public:
342virtual void OnMouseMove(CCmdTarget* pObject, UINT nFlags, CPoint point);
343}
344;
345
346DECLARE_THEMEPART(CTODayViewHeader, CTOHeader)
347virtual void RefreshMetrics(BOOL bRefreshChildren = TRUE);
348}
349;
350
351//=======================================================================
352DECLARE_THEMEPART(CTODayView, CXTPCalendarTheme::CTODayView)
353
354virtual void RefreshMetrics(BOOL bRefreshChildren = TRUE);
355
356virtual void AdjustLayout(CDC* pDC, const CRect& rcRect);
357virtual void Draw(CDC* pDC);
358using TBase::Draw;
359
360DECLARE_THEMEPART_MEMBER_(0, CTODayViewHeader, Header, CXTPCalendarTheme::CTOHeader)
361DECLARE_THEMEPART_MEMBER(1, CTODayViewEvent, Event)
362DECLARE_THEMEPART_MEMBER(2, CTODayViewTimeScale, TimeScale)
363DECLARE_THEMEPART_MEMBER(3, CTODayViewDay, Day)
364
365// theme specific control options
366virtual BOOL IsUseCellAlignedDraggingInTimeArea() const
367{
368 return TRUE;
369};
370
371protected:
372}
373;
374
376// ******** Month View *********
377
378// ======= MonthViewEvent ======
379DECLARE_THEMEPART2(CTOMonthViewEvent, CTOEvent, CXTPCalendarTheme::CTOMonthViewEvent)
380DECLARE_THEMEPART_MEMBER(0, CTOEventIconsToDraw, EventIconsToDraw)
381DECLARE_THEMEPART_MEMBER(1, CTOFormula_MulDivC, HeightFormula)
382
383virtual void RefreshMetrics(BOOL bRefreshChildren = TRUE);
384virtual void AdjustLayout(CCmdTarget* pObject, CDC* pDC, const CRect& rcRect,
385 int nEventPlaceNumber);
386}
387;
389friend class CTOMonthViewEvent;
391// ---- MonthViewEvent_SingleDay ----
392DECLARE_THEMEPART2(CTOMonthViewEvent_SingleDay, CTOMonthViewEvent,
393 CXTPCalendarTheme::CTOMonthViewEvent_SingleDay)
394
395virtual void RefreshMetrics(BOOL bRefreshChildren = TRUE);
396virtual void Draw(CCmdTarget* pObject, CDC* pDC);
397
398virtual void GetShowAsStatusColors(CDC* pDC, CXTPCalendarViewEvent* pViewEvent, COLORREF& clrBorder,
399 COLORREF& clrBorderNotSel,
400 CXTPPaintManagerColorGradient& grclrBk);
401
402protected:
403virtual void Draw_Background(CDC* pDC, const CRect& rcEventRect,
404 CXTPCalendarMonthViewEvent* pViewEvent);
405virtual CSize Draw_Time(CDC* pDC, const CRect& rcEventRect, CXTPCalendarMonthViewEvent* pViewEvent);
406virtual void Draw_Caption(CDC* pDC, const CRect& rcTextRect,
407 CXTPCalendarMonthViewEvent* pViewEvent);
408
409protected:
410}
411;
413friend class CTOMonthViewEvent_SingleDay;
415// ---- MonthViewEvent_MultiDay ----
416DECLARE_THEMEPART2(CTOMonthViewEvent_MultiDay, CTOMonthViewEvent,
417 CXTPCalendarTheme::CTOMonthViewEvent_MultiDay)
418
419virtual void RefreshMetrics(BOOL bRefreshChildren = TRUE);
420virtual void Draw(CCmdTarget* pObject, CDC* pDC);
421}
422;
424friend class CTOMonthViewEvent_MultiDay;
426// ===== MonthViewDayHeader ====
427DECLARE_THEMEPART2(CTOMonthViewDayHeader, CTOHeader, CXTPCalendarTheme::CTOMonthViewDayHeader)
428virtual void RefreshMetrics(BOOL bRefreshChildren = TRUE);
429virtual void Draw(CCmdTarget* pObject, CDC* pDC);
430}
431;
433friend class CTOMonthViewDayHeader;
435// ======= MonthViewDay =======
436DECLARE_THEMEPART2(CTOMonthViewDay, CTODay, CXTPCalendarTheme::CTOMonthViewDay)
437
438 CXTPPaintManagerColor m_clrBorder;
439 CXTPPaintManagerColor m_clrTodayBorder;
440
441 CXTPPaintManagerColor m_clrBackgroundLight;
442 CXTPPaintManagerColor m_clrBackgroundDark;
443 CXTPPaintManagerColor m_clrBackgroundSelected;
444
445virtual void RefreshMetrics(BOOL bRefreshChildren = TRUE);
446virtual void Draw(CCmdTarget* pObject, CDC* pDC);
447
448virtual void DoPropExchange(CXTPPropExchange* pPX);
449virtual void Serialize(CArchive& ar);
450
451DECLARE_THEMEPART_MEMBER(0, CTOMonthViewDayHeader, Header);
452DECLARE_THEMEPART_MEMBER(1, CTOMonthViewEvent_MultiDay, MultiDayEvent);
453DECLARE_THEMEPART_MEMBER(2, CTOMonthViewEvent_SingleDay, SingleDayEvent);
454
455public:
456virtual void OnMouseMove(CCmdTarget* pObject, UINT nFlags, CPoint point);
457virtual BOOL OnLButtonDown(CCmdTarget* pObject, UINT nFlags, CPoint point);
458
459void SetDynColors(CXTPCalendarMonthViewDay* pMViewDay);
460
461protected:
462COLORREF m_clrDynHatch;
463int m_nDynBusyStatus;
464BOOL m_fHatchBackground;
465}
466;
468friend class CTOMonthViewDay;
470// ======= MonthViewWeekDayHeader =======
471DECLARE_THEMEPART2(CTOMonthViewWeekDayHeader, CTOHeader,
472 CXTPCalendarTheme::CTOMonthViewWeekDayHeader)
473
474virtual void RefreshMetrics(BOOL bRefreshChildren = TRUE);
475virtual void AdjustLayout(CCmdTarget* pObject, CDC* pDC, const CRect& rcRect);
476virtual void Draw(CCmdTarget* pObject, CDC* pDC);
477
478protected:
479virtual void Draw_Borders2(CDC* pDC, const CRect& rcRect, BOOL bDrawRightBorder);
480
481protected:
482BOOL m_bWeekDayNamesLong;
483BOOL m_bWeekDayNameSaSuLong;
484
485CStringArray m_arWeekDayNamesLong;
486CStringArray m_arWeekDayNamesShort;
488public:
489CTOMonthViewWeekDayHeader()
490{
491 m_bWeekDayNamesLong = FALSE;
492 m_bWeekDayNameSaSuLong = FALSE;
493}
494}
495;
497friend class CTOMonthViewWeekDayHeader;
499// ======= MonthViewWeekHeader =======
500DECLARE_THEMEPART(CTOMonthViewWeekHeader, CTOHeader)
501 CXTPPaintManagerColor m_clrFreeSpaceBk;
502// CTOHeader::m_TextCenter.fcsetNormal is used to draw header caption;
503
504virtual void RefreshMetrics(BOOL bRefreshChildren = TRUE);
505virtual void AdjustLayout(CCmdTarget* pObject, CDC* pDC, const CRect& rcRect);
506virtual void Draw(CCmdTarget* pObject, CDC* pDC);
507
508virtual void DoPropExchange(CXTPPropExchange* pPX);
509virtual void Serialize(CArchive& ar);
510
511virtual BOOL OnLButtonDown(CCmdTarget* pObject, UINT nFlags, CPoint point);
512
513virtual int CalcWidth(CDC* pDC);
514
515CTOMonthViewWeekHeader()
516{
517 m_rcHeader.SetRect(0, 0, 0, 0);
518 m_bDateFormatShort = TRUE;
519}
520
521protected:
522CRect m_rcHeader;
523BOOL m_bDateFormatShort;
524
525void GetWeekHeaderRect(CXTPCalendarThemeOffice2007* pThemeX, CXTPCalendarMonthViewDay* pViewDay,
526 CRect& rcWHeader);
527
528void SwitchCalendarActiveViewToWeekView(CXTPCalendarControl* pCalendar);
529
530virtual void FormatWeekCaption(COleDateTime dtWDay1, CString& rstrShort, CString& rstrLong,
531 int nShort1Long2 = 0);
532
533virtual CString _FormatWCaption(LPCTSTR pcszDay1, LPCTSTR pcszMonth1, LPCTSTR pcszDay7,
534 LPCTSTR pcszMonth7, LPCTSTR pcszDayMonthSeparator,
535 int nDateOrdering);
536
537virtual void Draw_TextCenter(CDC* pDC, const CRect& rcRect, int nState, LPCTSTR pcszCenterText,
538 int* pnWidth = NULL);
539}
540;
542friend class CTOMonthViewWeekHeader;
544// ******* MonthView theme part object *******
545DECLARE_THEMEPART(CTOMonthView, CXTPCalendarTheme::CTOMonthView)
546
547// TODO:
548// BOOL m_bShowWeekNumbers;
549//
550// virtual void DoPropExchange(CXTPPropExchange* pPX);
551// virtual void Serialize(CArchive& ar);
552
553virtual void RefreshMetrics(BOOL bRefreshChildren = TRUE);
554virtual void AdjustLayout(CDC* pDC, const CRect& rcRect, BOOL bCallPostAdjustLayout);
555virtual void Draw(CDC* pDC);
556virtual BOOL OnLButtonDown(CCmdTarget* pObject, UINT nFlags, CPoint point);
557
558using TBase::Draw;
559
560DECLARE_THEMEPART_MEMBER(0, CTOHeader, Header);
561DECLARE_THEMEPART_MEMBER(1, CTOMonthViewEvent, Event);
562DECLARE_THEMEPART_MEMBER(2, CTOMonthViewWeekDayHeader, WeekDayHeader);
563DECLARE_THEMEPART_MEMBER_(3, CTOMonthViewWeekHeader, WeekHeader, CTOHeader);
564DECLARE_THEMEPART_MEMBER(4, CTOMonthViewDay, Day);
565}
566;
568friend class CTOMonthView;
571// ******** WeekView *********
572
573// ======= WeekViewEvent =======
574DECLARE_THEMEPART2(CTOWeekViewEvent, CTOEvent, CXTPCalendarTheme::CTOWeekViewEvent)
575DECLARE_THEMEPART_MEMBER(0, CTOEventIconsToDraw, EventIconsToDraw)
576DECLARE_THEMEPART_MEMBER(1, CTOFormula_MulDivC, HeightFormula)
577
578virtual void RefreshMetrics(BOOL bRefreshChildren = TRUE);
579virtual void AdjustLayout(CCmdTarget* pObject, CDC* pDC, const CRect& rcRect,
580 int nEventPlaceNumber);
581}
582;
584friend class CTOWeekViewEvent;
586// ==== WeekViewEvent_SingleDay ====
587DECLARE_THEMEPART2(CTOWeekViewEvent_SingleDay, CTOWeekViewEvent,
588 CXTPCalendarTheme::CTOWeekViewEvent_SingleDay)
589virtual void RefreshMetrics(BOOL bRefreshChildren = TRUE);
590virtual void Draw(CCmdTarget* pObject, CDC* pDC);
591
592protected:
593virtual void Draw_Background(CDC* pDC, const CRect& rcEventRect,
594 CXTPCalendarWeekViewEvent* pViewEvent);
595virtual CSize Draw_Time(CDC* pDC, const CRect& rcEventRect, CXTPCalendarWeekViewEvent* pViewEvent);
596virtual void Draw_Caption(CDC* pDC, const CRect& rcTextRect, CXTPCalendarWeekViewEvent* pViewEvent);
597}
598;
600friend class CTOWeekViewEvent_SingleDay;
602// ==== WeekViewEvent_MultiDay ====
603DECLARE_THEMEPART2(CTOWeekViewEvent_MultiDay, CTOWeekViewEvent,
604 CXTPCalendarTheme::CTOWeekViewEvent_MultiDay)
605virtual void RefreshMetrics(BOOL bRefreshChildren = TRUE);
606virtual void Draw(CCmdTarget* pObject, CDC* pDC);
607virtual void GetMultidayTimeFontAndColor(CFont*& pFont, COLORREF& clrColor, BOOL bSelected);
608}
609;
611friend class CTOWeekViewEvent_MultiDay;
613// ==== WeekViewDayHeader ====
614DECLARE_THEMEPART2(CTOWeekViewDayHeader, CTOHeader, CXTPCalendarTheme::CTOWeekViewDayHeader)
615 CXTPCalendarThemeStringValue m_strHeaderFormat;
616 CXTPCalendarThemeBOOLValue m_UseOffice2003HeaderFormat;
617
618virtual void AdjustLayout(CCmdTarget* pObject, CDC* pDC, const CRect& rcRect);
619virtual void RefreshMetrics(BOOL bRefreshChildren = TRUE);
620virtual void Draw(CCmdTarget* pObject, CDC* pDC);
621
622virtual void DoPropExchange(CXTPPropExchange* pPX);
623virtual void Serialize(CArchive& ar);
624}
625;
627friend class CTOWeekViewDayHeader;
629// ======= WeekViewDay =======
630DECLARE_THEMEPART2(CTOWeekViewDay, CTODay, CXTPCalendarTheme::CTOWeekViewDay)
631
632 CXTPPaintManagerColor m_clrBorder;
633 CXTPPaintManagerColor m_clrTodayBorder;
634
635 CXTPPaintManagerColor m_clrBackgroundLight;
636 CXTPPaintManagerColor m_clrBackgroundDark;
637 CXTPPaintManagerColor m_clrBackgroundSelected;
638
639virtual void RefreshMetrics(BOOL bRefreshChildren = TRUE);
640virtual void Draw(CCmdTarget* pObject, CDC* pDC);
641
642virtual void DoPropExchange(CXTPPropExchange* pPX);
643virtual void Serialize(CArchive& ar);
644
645virtual void OnMouseMove(CCmdTarget* pObject, UINT nFlags, CPoint point);
646virtual BOOL OnLButtonDown(CCmdTarget* pObject, UINT nFlags, CPoint point);
647
648DECLARE_THEMEPART_MEMBER(0, CTOWeekViewDayHeader, Header);
649DECLARE_THEMEPART_MEMBER(1, CTOWeekViewEvent_MultiDay, MultiDayEvent);
650DECLARE_THEMEPART_MEMBER(2, CTOWeekViewEvent_SingleDay, SingleDayEvent);
651
652virtual void SetDynColors(CXTPCalendarWeekViewDay* pWViewDay);
653
654protected:
655COLORREF m_clrDynHatch;
656int m_nDynBusyStatus;
657}
658;
660friend class CTOWeekViewDay;
662// ==== WeekView theme part object ====
663DECLARE_THEMEPART(CTOWeekView, CXTPCalendarTheme::CTOWeekView)
664virtual void RefreshMetrics(BOOL bRefreshChildren = TRUE);
665virtual void AdjustLayout(CDC* pDC, const CRect& rcRect, BOOL bCallPostAdjustLayout);
666virtual void Draw(CCmdTarget* pObject, CDC* pDC);
667using TBase::Draw;
668
669DECLARE_THEMEPART_MEMBER(0, CTOWeekViewEvent, Event);
670DECLARE_THEMEPART_MEMBER(1, CTOWeekViewDay, Day);
671}
672;
673
674DECLARE_THEMEPART(CTOCellDynBackground, CXTPCalendarThemePart)
675virtual int GetCellDynBackground(CXTPCalendarViewGroup* pVioewGroup, COleDateTime dtCellTime,
676 int nCellIndex, XTP_BUSY_STATUS_CONTEXT& rContext);
677virtual CXTPCalendarViewEvent* GetCellBackgroundEvent(CXTPCalendarViewGroup* pVioewGroup,
678 COleDateTime dtCellTime, int nCellIndex);
679BOOL DrawMonthViewHatchBackground();
680 CXTPCalendarEvent* GetBkTentativeEvent();
681
682protected:
683virtual int CmpEventBusyStatus(CXTPCalendarEvent* pEvent1, CXTPCalendarEvent* pEvent2);
684virtual int _GetEventBusyStatusRank(CXTPCalendarEvent* pEvent);
685
686protected:
687void CheckIsBackgroundHatchNeeded();
688
689protected:
690BOOL m_fDrawMonthViewBackgroundHatch;
691 CXTPCalendarViewEvent* m_pBkViewEvent;
692 CXTPCalendarEvent* m_pBkTentativeEvent;
693}
694;
695
696//=======================================================================
697DECLARE_THEMEPART_MEMBER(0, CTOColorsSet, ColorsSet)
698
699virtual BOOL IsBaseColorOrig();
700virtual COLORREF GetColor(int eCLR, COLORREF clrBase = (COLORREF)-1);
701virtual COLORREF GetColor2(LPCTSTR pcszColorName, COLORREF clrDefault);
702
703virtual CXTPResourceImage* GetBitmap(LPCTSTR pcszStdBmpName);
704
705DECLARE_THEMEPART_MEMBER(1, CTOHeader, Header)
706DECLARE_THEMEPART_MEMBER(2, CTOEvent, Event)
707
708DECLARE_THEMEPART_MEMBER(3, CTODayView, DayView)
709DECLARE_THEMEPART_MEMBER(4, CTOMonthView, MonthView)
710DECLARE_THEMEPART_MEMBER(5, CTOWeekView, WeekView)
711
712// office 2007 theme specific parts
713DECLARE_THEMEPART_MEMBER_(6, CTOCellDynBackground, CellDynBackground, CTOCellDynBackground)
714
715DECLARE_THEMEPART_MEMBER_(7, CTOPrevNextEventButtons, PrevNextEventButtons, CXTPCalendarThemePart)
716
717//=======================================================================
718CXTPCalendarThemeOffice2007();
719virtual ~CXTPCalendarThemeOffice2007();
720
721// If enough space on the rect - draw 3 strings one under other
722// as multi-line text.
723// If rect height allow draw only 1 line - string 1 an 2 are drawn
724// as single line with a separator.
725// Separate font settings are used to draw each text.
726
727virtual CSize DrawText_Auto2SL3ML(CDC* pDC, LPCTSTR pcszText1, LPCTSTR pcszText2, LPCTSTR pcszText3,
728 CThemeFontColorSet* pFontColor1, CThemeFontColorSet* pFontColor2,
729 CThemeFontColorSet* pFontColor3, CRect& rcRect,
730 LPCTSTR pcszText1Separator, UINT uWordBreakMode = DT_WORDBREAK);
731
732// Common colors id's: {0 - 99}
733// DayViev colors id's: {100 - 499}
734// MonthViev colors id's: {500 - 999}
735// WeekViev colors id's: {1000 - 1499}
736//
737// For darken colors: id + 5000
738
739enum XTPEnumThemeColorsSet
740{
741 xtpCLR_DarkenOffset = 5000,
742
743 xtpCLR_SelectedBk = 1 + xtpCLR_DarkenOffset,
744
745 xtpCLR_HeaderBorder = 2,
746 xtpCLR_DayBorder = 3,
747
748 xtpCLR_MultiDayEventBorder = 10,
749 xtpCLR_MultiDayEventSelectedBorder = 11 + xtpCLR_DarkenOffset,
750 xtpCLR_MultiDayEventBkGRfrom = 12,
751 xtpCLR_MultiDayEventBkGRto = 13,
752
753 xtpCLR_MultiDayEventFromToDates = 20,
754
755 // xtpCLR_DayView_ = 100,
756 xtpCLR_DayViewCellWorkBk = 101,
757 xtpCLR_DayViewCellNonWorkBk = 102,
758
759 xtpCLR_DayViewCellWorkBorderBottomInHour = 103,
760 xtpCLR_DayViewCellWorkBorderBottomHour = 104,
761 xtpCLR_DayViewCellNonWorkBorderBottomInHour = 105,
762 xtpCLR_DayViewCellNonWorkBorderBottomHour = 106,
763
764 xtpCLR_DayViewAllDayEventsBk = 110,
765 xtpCLR_DayViewAllDayEventsBorderBottom = 111,
766
767 xtpCLR_DayViewSingleDayEventBorder = 120,
768 xtpCLR_DayViewSingleDayEventSelectedBorder = 121 + xtpCLR_DarkenOffset,
769 xtpCLR_DayViewSingleDayEventBkGRfrom = 122,
770 xtpCLR_DayViewSingleDayEventBkGRto = 123,
771
772 // xtpCLR_MonthView_ = 500,
773 xtpCLR_MonthViewDayBkLight = 501,
774 xtpCLR_MonthViewDayBkDark = 502,
775 xtpCLR_MonthViewDayBkSelected = 503,
776
777 xtpCLR_MonthViewEventTime = 510 + xtpCLR_DarkenOffset,
778
779 xtpCLR_MonthViewSingleDayEventBorder = 520,
780 xtpCLR_MonthViewSingleDayEventSelectedBorder = 521 + xtpCLR_DarkenOffset,
781 xtpCLR_MonthViewSingleDayEventBkGRfrom = 522,
782 xtpCLR_MonthViewSingleDayEventBkGRto = 523,
783
784 // xtpCLR_WeekView_ = 1000,
785 xtpCLR_WeekViewDayBkLight = 1001,
786 xtpCLR_WeekViewDayBkDark = 1002,
787 xtpCLR_WeekViewDayBkSelected = 1003,
788
789 xtpCLR_WeekViewEventTime = 1010 + xtpCLR_DarkenOffset,
790
791 xtpCLR_WeekViewSingleDayEventBorder = 1020,
792 xtpCLR_WeekViewSingleDayEventSelectedBorder = 1021 + xtpCLR_DarkenOffset,
793 xtpCLR_WeekViewSingleDayEventBkGRfrom = 1022,
794 xtpCLR_WeekViewSingleDayEventBkGRto = 1023,
795
796};
797
798public:
799virtual CXTPCalendarViewEventSubjectEditor* StartEditSubject(CXTPCalendarViewEvent* pViewEvent);
800
801static int AFX_CDECL DrawClock(CDC* pDC, COleDateTime dtClockTime, CRect rcView,
802 COLORREF clrBackground, XTPCalendarClockAlignFlags cafAlign);
810virtual CTOEvent* GetThemePartForEvent(CXTPCalendarViewEvent* pViewEvent);
811
812virtual void GetItemTextIfNeed(int nItem, CString* pstrText, CXTPCalendarViewDay* pViewDay);
813
814static const int cnGripperSize;
815static const int cnShadowWidth;
816BOOL m_bFlatStyle;
817
818static COLORREF AFX_CDECL PowerColor(COLORREF clrB, double dFactor, double dPower);
819
820void DrawEventRect(CDC* pDC, const CRect& rcRect, COLORREF clrBorder, BOOL bBoldBorder,
821 CXTPPaintManagerColorGradient& grclrBk);
822
823protected:
824virtual void SetCalendarControl(CXTPCalendarControl* pCalendar);
825virtual void RefreshMetrics(BOOL bRefreshChildren);
826virtual void RefreshMetrics();
827
828virtual void _DrawEventLTHighlight(CDC* pDC, CPoint ptLT, int nRTx,
829 const CXTPPaintManagerColorGradient& grclrBk, int nLTCorner = 0,
830 int nLBy = INT_MAX, BOOL bRCorner = TRUE);
831
832protected:
833CXTPNotifySink* m_pSink;
834virtual void OnEvent_ResourceImagesChanged(XTP_NOTIFY_CODE Event, WPARAM wParam, LPARAM lParam);
835
836protected:
837# ifdef _XTP_ACTIVEX
838
839DECLARE_DISPATCH_MAP()
840DECLARE_INTERFACE_MAP()
841
842DECLARE_OLETYPELIB_EX(CXTPCalendarThemeOffice2007)
843DECLARE_OLECREATE_EX(CXTPCalendarThemeOffice2007)
844
845LPDISPATCH OleGet_Header();
846LPDISPATCH OleGet_Event();
847
848LPDISPATCH OleGet_DayView();
849LPDISPATCH OleGet_MonthView();
850LPDISPATCH OleGet_WeekView();
851
852LPDISPATCH OleGet_PrevNextEventButtons();
853
854 CXTPSmartPtrInternalT<CXTPCalendarThemeAxPart> m_ptrAxHeader;
855 CXTPSmartPtrInternalT<CXTPCalendarThemeAxPart> m_ptrAxEvent;
856
857 CXTPSmartPtrInternalT<CXTPCalendarThemeAxPart> m_ptrAxDayView;
858 CXTPSmartPtrInternalT<CXTPCalendarThemeAxPart> m_ptrAxMonthView;
859 CXTPSmartPtrInternalT<CXTPCalendarThemeAxPart> m_ptrAxWeekView;
860
861 CXTPSmartPtrInternalT<CXTPCalendarThemeAxPart> m_ptrAxPrevNextEventButtons;
862# endif
863}
864;
865
867
868# if (_MSC_VER > 1100)
869# pragma warning(pop)
870# endif
871
872# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
873#endif // !defined(_XTP_CALENDAR_THEME_OFFICE_2007_H__)
XTPCalendarClockAlignFlags
XTPCalendarClockAlignFlags
Definition XTPCalendarDefines.h:306
GetThemePartForEvent
virtual CTOEvent * GetThemePartForEvent(CXTPCalendarViewEvent *pViewEvent)
Thin method determine event view type (day, week, month) and return corresponding drawing part.
m_arWeekDayNamesLong
CStringArray m_arWeekDayNamesLong
0 - Sunday, 1 - Monday, ...; 7 - Sat/Sun
Definition XTPCalendarThemeOffice2007.h:485
pPoint
const CPoint * pPoint
return 0 or xtpCalendarHitTestDayExpandButton
Definition XTPCalendarThemeOffice2007.h:150
m_arWeekDayNamesShort
CStringArray m_arWeekDayNamesShort
0 - Sunday, 1 - Monday, ...; 7 - Sat/Sun
Definition XTPCalendarThemeOffice2007.h:486
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCalendarControl
Class CXTPCalendarControl implements the calendar's view interface.
Definition XTPCalendarControl.h:126
CXTPCalendarDayViewDay
This class represents a day view portion of the Calendar Day View.
Definition XTPCalendarDayViewDay.h:726
CXTPCalendarDayViewEvent
This class represents an event view portion of the CalendarDayViewDay.
Definition XTPCalendarDayViewEvent.h:56
CXTPCalendarDayViewGroup
This class represents a single resource view portion of the Calendar Day View.
Definition XTPCalendarDayViewDay.h:53
CXTPCalendarDayViewTimeScale
This class implements a specific view portion of the Calendar Day view - called Time scale.
Definition XTPCalendarDayViewTimeScale.h:75
CXTPCalendarEventCategories
This class is used as a collection of CXTPCalendarEventCategory objects.
Definition XTPCalendarEventLabel.h:440
CXTPCalendarEventCategoryIDs
This class represents the collection of event categories IDs.
Definition XTPCalendarEventLabel.h:692
CXTPCalendarEvent
This class represents the data of a single Event used in the Calendar control.
Definition XTPCalendarEvent.h:77
CXTPCalendarMonthViewDay
This class represents a day view portion of the CalendarMonthView.
Definition XTPCalendarMonthViewDay.h:151
CXTPCalendarMonthViewEvent
This class represents an event view portion of the CalendarMonthViewDay.
Definition XTPCalendarMonthViewEvent.h:56
CXTPCalendarResources
This class represents a simple array collection of CXTPCalendarResource objects.
Definition XTPCalendarResource.h:555
CXTPCalendarThemeBOOLValue
Helper class provides functionality to manage customized BOOL value objects.
Definition XTPCalendarViewPart.h:1123
CXTPCalendarThemeStringValue
Helper class provides functionality to manage customized string value objects.
Definition XTPCalendarViewPart.h:983
CXTPCalendarViewDay
This class represents the day view portion of the CalendarView.
Definition XTPCalendarViewDay.h:555
CXTPCalendarViewEvent
This class represents an event view portion of the CalendarViewGroup.
Definition XTPCalendarViewEvent.h:106
CXTPCalendarViewEventSubjectEditor
This class is used to edit an event subject.
Definition XTPCalendarViewEvent.h:1157
CXTPCalendarViewGroup
Regular schema:
Definition XTPCalendarViewDay.h:54
CXTPCalendarWeekViewDay
This class represents a day view portion of the CalendarWeekView.
Definition XTPCalendarWeekViewDay.h:131
CXTPCalendarWeekViewEvent
This class represents an event view portion of the CalendarWeekViewDay.
Definition XTPCalendarWeekViewEvent.h:58
CXTPImageManager
CXTPImageManager is a standalone class.
Definition XTPImageManager.h:1898
CXTPPaintManagerColorGradient
The CXTPPaintManagerColorGradient class is used to manage COLORREF values for determining light and d...
Definition XTPColorManager.h:301
CXTPPaintManagerColor
The CXTPPaintManagerColor class is used to manage COLORREF values for determining default and applica...
Definition XTPColorManager.h:117
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72
CXTPResourceImage
Represent a resource image and provides basic images functions.
Definition XTPResourceImage.h:48
CXTPResourceImages
Implements resource image collection and its operations.
Definition XTPResourceImage.h:257
CXTPSmartPtrInternalT
Definition XTPSmartPtrInternalT.h:72
XTP_CALENDAR_THEME_DAYVIEWCELL_PARAMS
Set of parameters transferred from calendar items for an XTP_NC_CALENDAR_BEFORE_DRAW_THEMEOBJECT noti...
Definition XTPCalendarNotifications.h:672


Toolkit Pro: Member List

CXTPGridInplaceControl Member List

This is the complete list of members for CXTPGridInplaceControl, including all inherited members.

CXTPGridInplaceControl() | CXTPGridInplaceControl |
pColumn | XTP_GRIDRECORDITEM_ARGS |
pControl | XTP_GRIDRECORDITEM_ARGS |
pItem | XTP_GRIDRECORDITEM_ARGS |
pRow | XTP_GRIDRECORDITEM_ARGS |
rcItem | XTP_GRIDRECORDITEM_ARGS |
SetItemArgs(XTP_GRIDRECORDITEM_ARGS *pItemArgs) | CXTPGridInplaceControl | protectedvirtual
~CXTPGridInplaceControl() | CXTPGridInplaceControl | virtual


Toolkit Pro: XTPGridThemeDefault.h Source File

  • Source
  • GridControl
  • Themes
XTPGridThemeDefault.h
Go to the documentation of this file.
1
23#if !defined(__XTPGRIDTHEMEDEFAULT_H__)
24# define __XTPGRIDTHEMEDEFAULT_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPGridThemeDefault : public CXTPGridPaintManager
39{
40public:
45 CXTPGridThemeDefault();
46
58 virtual void DrawColumnBackground(CDC* pDC, CXTPGridColumn* pColumn, CRect rcColumn,
59 BOOL& bColumnPressed, BOOL& bDraggingFromHeader,
60 CXTPGridHeader* pHeader = NULL);
61};
63# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
64#endif //#if !defined(__XTPGRIDTHEMEDEFAULT_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPGridColumn
Represents a grid column item with its properties and operations.
Definition XTPGridColumn.h:107
CXTPGridHeader
A grid header is a part of the grid window positioned above columns of text or numbers.
Definition XTPGridHeader.h:173
CXTPGridPaintManager
Utility class that handles most drawing activities.
Definition XTPGridPaintManager.h:76
CXTPGridThemeDefault
CXTPGridThemeDefault is a CXTPGridPaintManager derived class that represents an Office 97 style theme...
Definition XTPGridThemeDefault.h:39
CXTPGridThemeDefault::DrawColumnBackground
virtual void DrawColumnBackground(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, BOOL &bColumnPressed, BOOL &bDraggingFromHeader, CXTPGridHeader *pHeader=NULL)
This method is called to draw the background of a column using the current column style.
CXTPGridThemeDefault::CXTPGridThemeDefault
CXTPGridThemeDefault()
Default paint manager constructor, handles properties initialization.


Toolkit Pro: Member List

CXTPPaintManagerFont Member List

This is the complete list of members for CXTPPaintManagerFont, including all inherited members.

CXTPPaintManagerFont() | CXTPPaintManagerFont | inline
EnableCustomFont(BOOL bEnable=TRUE) | CXTPPaintManagerFont |
m_bStandardFont | CXTPPaintManagerFont | protected
SetCustomFont(const LOGFONT *lpLogFont) | CXTPPaintManagerFont |
SetStandardFont(const LOGFONT *lpLogFont) | CXTPPaintManagerFont |


Toolkit Pro: Member List

CXTPPoint2T< T > Member List

This is the complete list of members for CXTPPoint2T< T >, including all inherited members.

CXTPPoint2T() | CXTPPoint2T< T > | inline
CXTPPoint2T(const CXTPPoint2T &point) | CXTPPoint2T< T > | inline
CXTPPoint2T(int x, int y) | CXTPPoint2T< T > | inline
CXTPPoint2T(float x, float y) | CXTPPoint2T< T > | inline
CXTPPoint2T(double x, double y) | CXTPPoint2T< T > | inline
IsZero() const | CXTPPoint2T< T > | inline
Offset(T dx, T dy) | CXTPPoint2T< T > | inline
operator CXTPPoint2d() const | CXTPPoint2T< T > | inline
operator CXTPPoint2f() const | CXTPPoint2T< T > | inline
operator CXTPPoint2i() const | CXTPPoint2T< T > | inline
operator!=(const CXTPPoint2T &point) const | CXTPPoint2T< T > | inline
operator==(const CXTPPoint2T &point) const | CXTPPoint2T< T > | inline
Round() const | CXTPPoint2T< T > | inline
SetPoint(T x, T y) | CXTPPoint2T< T > | inline
X | CXTPPoint2T< T > |
Y | CXTPPoint2T< T > |


Toolkit Pro: XTPControlGalleryNativeWindows10Theme.h Source File

  • Source
  • CommandBars
  • Gallery
XTPControlGalleryNativeWindows10Theme.h
Go to the documentation of this file.
1
23#if !defined(__XTPCONTROLGALLERYNATIVEWINDOWS10THEME_H__)
24# define __XTPCONTROLGALLERYNATIVEWINDOWS10THEME_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
40class _XTP_EXT_CLASS CXTPControlGalleryNativeWindows10Theme
41 : public CXTPControlGalleryOffice2013Theme
42{
43public:
49 CXTPControlGalleryNativeWindows10Theme(CXTPPaintManager* pPaintManager);
50};
51
53# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
54#endif // !defined(__XTPCONTROLGALLERYNATIVEWINDOWS10THEME_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPControlGalleryNativeWindows10Theme
The CXTPControlGalleryResourceTheme class is used to enable a Gallery Native Windows 10 style theme f...
Definition XTPControlGalleryNativeWindows10Theme.h:42
CXTPControlGalleryNativeWindows10Theme::CXTPControlGalleryNativeWindows10Theme
CXTPControlGalleryNativeWindows10Theme(CXTPPaintManager *pPaintManager)
Constructs a CXTPControlGalleryNativeWindows10Theme object.
CXTPControlGalleryOffice2013Theme
The CXTPControlGalleryResourceTheme class is used to enable a Gallery Office 2013 style theme for Com...
Definition XTPControlGalleryOffice2013Theme.h:41
CXTPPaintManager
Paint manager of the command bars.
Definition XTPPaintManager.h:199


Toolkit Pro: XTPRibbonBackstageSeparatorThemeVisualStudio2017.h Source File

  • Source
  • Ribbon
  • Backstage
XTPRibbonBackstageSeparatorThemeVisualStudio2017.h
Go to the documentation of this file.
1
23#if !defined(__XTPRIBBONBACKSTAGESEPARATORTHEMEVISUALSTUDIO2017_H__)
24# define __XTPRIBBONBACKSTAGESEPARATORTHEMEVISUALSTUDIO2017_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPRibbonBackstageSeparator;
34
35class _XTP_EXT_CLASS CXTPRibbonBackstageSeparatorThemeVisualStudio2017
36 : public CXTPRibbonBackstageSeparatorThemeOffice2013
37{
38public:
39 CXTPRibbonBackstageSeparatorThemeVisualStudio2017();
40};
41
42# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
44#endif // !defined(__XTPRIBBONBACKSTAGESEPARATORTHEMEVISUALSTUDIO2017_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h


Toolkit Pro: Member List

CXTPCaptionButton Member List

This is the complete list of members for CXTPCaptionButton, including all inherited members.

CXTPButton() | CXTPButton |
CXTPCaptionButton() | CXTPCaptionButton |
DoDropDown() | CXTPButton | protected
DrawImage(CDC *pDC, CRect rc) | CXTPButton | virtual
EnableMarkup(BOOL bEnableMarkup=TRUE) | CXTPButton |
GetBorderGap() const | CXTPButton |
GetBorderStyle() const | CXTPButton |
GetButtonBackColor() | CXTPButton | virtual
GetButtonRect() | CXTPButton | virtual
GetButtonStyle() const | CXTPButton |
GetButtonText() | CXTPButton | virtual
GetButtonTextColor() | CXTPButton | virtual
GetCaption() | CXTPCaptionButton | inline
GetChecked() | CXTPButton | virtual
GetFlatStyle() const | CXTPButton |
GetGlyphSize(BOOL bCheckBox) | CXTPButton |
GetIcon() const | CXTPButton |
GetImageAlignment() const | CXTPButton | virtual
GetImageGap() const | CXTPButton |
GetImageSize() | CXTPButton | virtual
GetMarkupContext() const | CXTPButton |
GetMarkupUIElement() | CXTPButton |
GetPushButtonStyle() const | CXTPButton |
GetShowFocus() const | CXTPButton |
GetTextAlignment() const | CXTPButton | virtual
GetTextImageRelation() const | CXTPButton |
GetTheme() | CXTPButton |
GetTooltip() const | CXTPButton |
GetToolTipContext() const | CXTPButton |
GetUseVisualStyle() const | CXTPButton |
InternalTextChanged() | CXTPButton | virtual
IsDpiImageScalingEnabled() const | CXTPButton | virtual
IsDropDownStyle() const | CXTPButton |
IsHighlighted() | CXTPButton | virtual
IsPushButton() const | CXTPButton |
IsPushed() | CXTPButton | virtual
m_bChecked | CXTPButton |
m_bEnableMarkup | CXTPButton |
m_bFlatStyle | CXTPButton |
m_bHot | CXTPButton |
m_bImageDPIScaling | CXTPButton | protected
m_bPushed | CXTPButton |
m_bShowFocus | CXTPButton |
m_bUseVisualStyle | CXTPButton |
m_hWndBuddy | CXTPButton |
m_nBorderGap | CXTPButton |
m_nBorderStyle | CXTPButton |
m_nImageAlignment | CXTPButton |
m_nImageGap | CXTPButton |
m_nPushButtonStyle | CXTPButton |
m_nTextImageRelation | CXTPButton |
m_pCaption | CXTPCaptionButton | protected
m_pIcon | CXTPButton |
m_pMarkupContext | CXTPButton | protected
m_pTheme | CXTPButton |
m_pToolTipContext | CXTPButton |
m_pUIElement | CXTPButton | protected
m_strTooltip | CXTPButton |
m_szVectorIcon | CXTPButton |
OnDraw(CDC *pDC) | CXTPButton | protectedvirtual
OnDropDown() | CXTPButton | protectedvirtual
RedrawButton(BOOL bUpdateWindow=FALSE) | CXTPButton |
RefreshMetrics() | CXTPButton | protectedvirtual
SetBitmap(CSize size, UINT nID, BOOL bRedraw=TRUE) | CXTPButton | virtual
SetBorderGap(int nBorderGap) | CXTPButton |
SetBorderStyle(XTPGroupBoxBorderStyle style) | CXTPButton |
SetBuddy(CWnd *pWndBuddy, BOOL bMoveButton=TRUE) | CXTPButton |
SetCaption(CXTPCaption *pCaption) | CXTPCaptionButton | inline
SetChecked(BOOL bChecked) | CXTPButton |
SetDpiImageScaling(BOOL bEnable) | CXTPButton | virtual
SetFlatStyle(BOOL bFlatStyle=TRUE) | CXTPButton |
SetIcon(CSize size, HICON hIcon, HICON hIconHot=NULL, BOOL bRedraw=TRUE) | CXTPButton | virtual
SetIcon(CSize size, UINT nID, UINT nHotID=0, BOOL bRedraw=TRUE) | CXTPButton | virtual
SetIcon(CSize size, LPCTSTR lpszID, LPCTSTR lpszHotID=NULL, BOOL bRedraw=TRUE) | CXTPButton | virtual
SetIcon(CSize size, CXTPImageManagerIcon *pIcon, BOOL bRedraw=TRUE) | CXTPButton |
SetIcon(CSize size, const CXTPImageManagerIconHandle &hIconHandle, const CXTPImageManagerIconHandle &hIconHotHandle, BOOL bRedraw=TRUE) | CXTPButton | virtual
SetImageAlignment(DWORD dwAlignment) | CXTPButton |
SetImageGap(int nImageGap) | CXTPButton |
SetPushButtonStyle(XTPPushButtonStyle nPushButtonStyle) | CXTPButton |
SetShowFocus(BOOL bShowFocus) | CXTPButton |
SetTextAlignment(DWORD dwAlignment) | CXTPButton |
SetTextImageRelation(XTPButtonTextImageRelation relation) | CXTPButton |
SetTheme(XTPControlTheme eTheme) | CXTPCaptionButton | virtual
SetTheme(CXTPButtonTheme *pPaintManager) | CXTPCaptionButton | virtual
SetTooltip(LPCTSTR lpszTooltip) | CXTPButton |
SetUseVisualStyle(BOOL bUseVisualStyle=TRUE) | CXTPButton |
~CXTPButton() | CXTPButton | virtual


Toolkit Pro: XTPCalendarPaintManager.h Source File

  • Source
  • Calendar
XTPCalendarPaintManager.h
Go to the documentation of this file.
1
22#if !defined(_XTPCALENDARPAINTMANAGER_H__)
23# define _XTPCALENDARPAINTMANAGER_H__
24
25# if _MSC_VER > 1000
26# pragma once
27# endif // _MSC_VER > 1000
28
29# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
30
31class CXTPCalendarTimeLineViewTimeScale;
32class CXTPCalendarTimeLineViewGroup;
33class CXTPCalendarTimeLineViewEvent;
34class CXTPCalendarTimeLineView;
35class CXTPResourceImage;
36class CXTPImageManager;
37class CXTPCalendarControl;
38class CXTPCalendarDayView;
39class CXTPCalendarDayViewDay;
40class CXTPCalendarDayViewGroup;
41class CXTPCalendarMonthView;
42class CXTPCalendarWeekView;
43class CXTPCalendarDayViewEvent;
44class CXTPCalendarMonthViewEvent;
45class CXTPCalendarWeekViewEvent;
46class CXTPCalendarViewEvent;
47class CXTPCalendarDayViewTimeScale;
48class CXTPCalendarFlagsSet_imp;
49class CXTPCalendarViewPartBrushValue;
50class CXTPCalendarViewEventSubjectEditor;
51
52struct XTP_CALENDAR_DAYVIEWCELL_PARAMS;
53
79# define BEGIN_VIEW_PART(theClass, parentClass)
80
81# undef BEGIN_VIEW_PART
82# define BEGIN_VIEW_PART(theClass, parentClass) \
83 class C##theClass : public C##parentClass \
84 { \
85 public: \
86 typedef C##parentClass TBase; \
87 C##theClass(CXTPCalendarViewPart* pParentPart = NULL) \
88 : C##parentClass(pParentPart) \
89 { \
90 _Init(); \
91 }
92
101# define END_VIEW_PART(theClass)
102
103# undef END_VIEW_PART
104# define END_VIEW_PART(theClass) \
105 } \
106 ; \
107 friend class C##theClass; \
108 \
109 protected: \
110 C##theClass* m_p##theClass; \
111 \
112 public: \
113 C##theClass* Get##theClass() const \
114 { \
115 return m_p##theClass; \
116 } \
117 void Set##theClass(C##theClass* p##theClass) \
118 { \
119 POSITION pos = m_lstViewParts.Find(m_p##theClass); \
120 _ASSERTE(pos); \
121 m_lstViewParts.RemoveAt(pos); \
122 delete m_p##theClass; \
123 m_p##theClass = p##theClass; \
124 m_lstViewParts.AddTail(p##theClass); \
125 p##theClass->m_pPaintManager = this; \
126 }
127
129// CXTPCalendarPaintManager command target
130
149class _XTP_EXT_CLASS CXTPCalendarPaintManager : public CXTPCmdTarget
150{
151 friend class CXTPCalendarViewPart;
152
153public:
159 BEGIN_VIEW_PART(ControlPart, XTPCalendarViewPart)
165 virtual void RefreshMetrics();
166 END_VIEW_PART(ControlPart)
167
168
177 BEGIN_VIEW_PART(DayViewTimeScaleHeaderPart, XTPCalendarViewPart)
178
179 COLORREF m_clrBorder;
180
186 virtual void RefreshMetrics();
187
198 virtual void OnDraw(CDC* pDC, CXTPCalendarDayView* pView, CRect rc, CString strText);
199
211 virtual void DrawNowLine(CDC* pDC, CXTPCalendarDayView* pView, CRect rc, int y,
212 BOOL bDrawBk = FALSE);
213
226 virtual void DrawNowLine(CDC* pDC, CXTPCalendarDayView* pView,
227 CXTPCalendarDayViewTimeScale* pScale, CRect rc, int y,
228 BOOL bDrawBk = FALSE);
229
238 virtual void DrawExpandSigns(CDC* pDC, CXTPCalendarDayView* pView, const CRect& rcTSHours);
239 END_VIEW_PART(DayViewTimeScaleHeaderPart)
240
241
246 BEGIN_VIEW_PART(DayViewTimeScaleCellPart, DayViewTimeScaleHeaderPart)
247 CXTPCalendarViewPartFontValue m_fntTimeText;
248 int m_nHourWidth;
249 int m_nMinWidth;
250 BOOL m_bShowMinutes;
252 COLORREF m_clrBorder;
253
259 virtual void RefreshMetrics();
260
269 void AdjustTimeFont(CDC* pDC, CRect rcCell);
270
282 void CalcWidth(CDC* pDC, const CString& strHour, const CString& strMin, int nHourHeight,
283 int& nWidth);
284
289 // virtual void DrawBackground(CDC* pDC, CRect rc);
290
303 virtual void DrawHourCell(CDC* pDC, CRect rc, CString strText, BOOL bFillBackground = TRUE,
304 BOOL bCurrentTime = FALSE);
305
320 virtual void DrawBigHourCell(CDC* pDC, CRect rc, CString strHour, CString strMin,
321 int nRowPerHour, BOOL bFillBackground = TRUE,
322 BOOL bCurrentTime = FALSE);
323 END_VIEW_PART(DayViewTimeScaleCellPart)
324
331 BEGIN_VIEW_PART(DayViewCellPart, XTPCalendarViewPart)
332 CXTPPaintManagerColor m_clrBackgroundSlave;
333 CXTPPaintManagerColor m_clrShadow;
334 CXTPPaintManagerColor m_clrHour;
341 virtual void RefreshMetrics();
342
352 virtual void GetParams(CXTPCalendarDayViewGroup* pViewGroup,
353 XTP_CALENDAR_DAYVIEWCELL_PARAMS* rCellParams);
354
366 virtual void OnDraw(CDC* pDC, CXTPCalendarDayViewGroup* pViewGroup, CRect rc,
367 const XTP_CALENDAR_DAYVIEWCELL_PARAMS& cellParams);
368 END_VIEW_PART(DayViewCellPart)
369
375 BEGIN_VIEW_PART(DayViewWorkCellPart, DayViewCellPart)
381 virtual void RefreshMetrics();
382 END_VIEW_PART(DayViewWorkCellPart)
383
389 BEGIN_VIEW_PART(DayViewNonworkCellPart, DayViewCellPart)
395 virtual void RefreshMetrics();
396 END_VIEW_PART(DayViewNonworkCellPart)
397
403 BEGIN_VIEW_PART(DayMonthViewHeaderPart, XTPCalendarViewPart)
404 CXTPPaintManagerColor m_clrTopLeftBorder; // Top and Left borders color.
405
411 virtual void RefreshMetrics()
412 {
413 m_clrTopLeftBorder.SetStandardValue(RGB(255, 255, 255));
414 }
415 END_VIEW_PART(DayMonthViewHeaderPart)
416
417
422 BEGIN_VIEW_PART(DayViewHeaderPart, DayMonthViewHeaderPart)
434 virtual void OnDraw(CDC* pDC, CXTPCalendarDayViewDay* pViewDay, CRect rc, CString strText);
435
436 virtual void RefreshMetrics();
437 END_VIEW_PART(DayViewHeaderPart)
438
444 BEGIN_VIEW_PART(DayViewGroupHeaderPart, DayMonthViewHeaderPart)
456 virtual void OnDraw(CDC* pDC, CXTPCalendarDayViewGroup* pViewGroup, CRect rc, CString strText);
457 END_VIEW_PART(DayViewGroupHeaderPart)
458
464 BEGIN_VIEW_PART(DayViewAllDayEventsPart, XTPCalendarViewPart)
470 virtual void RefreshMetrics();
471
482 virtual void OnDraw(CDC* pDC, CXTPCalendarDayViewGroup* pViewGroup, CRect rc, BOOL bSelected);
483 END_VIEW_PART(DayViewAllDayEventsPart)
484
490 BEGIN_VIEW_PART(DayViewAllDayEventScrollIconsPart, XTPCalendarViewPart)
504 virtual void OnDraw(CDC* pDC, CXTPCalendarDayViewGroup* pViewGroup, BOOL bDrawUp,
505 BOOL bDrawDown, const CRect& rcIconUp, const CRect& rcIconDown,
506 BOOL bHighlightUp, BOOL bHighlightDown);
507 END_VIEW_PART(DayViewAllDayEventScrollIconsPart)
508
514 BEGIN_VIEW_PART(DayViewEventPart, XTPCalendarViewPart)
520 virtual void RefreshMetrics();
529 virtual void OnDraw(CDC* pDC, CXTPCalendarDayViewEvent* pViewEvent);
530 END_VIEW_PART(DayViewEventPart)
531
541 BEGIN_VIEW_PART(MonthViewGridPart, XTPCalendarViewPart)
542 CXTPPaintManagerColor m_clrBackground2;
550 virtual void RefreshMetrics();
551
560 virtual void OnDrawGrid(CDC* pDC, CXTPCalendarMonthView* pMonthView);
561 END_VIEW_PART(MonthViewGridPart)
562
568 BEGIN_VIEW_PART(MonthViewHeaderPart, DayMonthViewHeaderPart)
581 virtual void OnDraw(CDC* pDC, CXTPCalendarMonthView* pMonthView, CRect rc, int nCollIndex,
582 CString strText);
583
584 virtual void RefreshMetrics();
585
586 END_VIEW_PART(MonthViewHeaderPart)
587
593 BEGIN_VIEW_PART(MonthViewEventPart, XTPCalendarViewPart)
594 COLORREF m_clrTextHighLightColor;
595 COLORREF m_clrMultiDayEventFrameColor;
596 COLORREF m_clrClassicUnderline;
598 CXTPPaintManagerColorGradient m_grclrClassicSelDay;
605 virtual void RefreshMetrics();
606
614 virtual void OnDrawEvent(CDC* pDC, CXTPCalendarMonthViewEvent* pViewEvent);
615
628 virtual void OnDrawDayDate(CDC* pDC, CRect rc, BOOL bToday, BOOL bSelected, BOOL bFirstMonthDay,
629 CString strText);
630 END_VIEW_PART(MonthViewEventPart)
631
641 BEGIN_VIEW_PART(WeekViewPart, XTPCalendarViewPart)
642 COLORREF m_clrTextHighLightColor;
643 COLORREF m_clrTextNormalColor;
644 COLORREF m_clrHeaderBottomLine;
651 virtual void RefreshMetrics();
652
660 virtual void OnDraw(CDC* pDC, CXTPCalendarWeekView* pWeekView);
661
674 virtual void DrawDayHeader(CDC* pDC, CRect rcDay, int nHeaderHeight, CString strHeader,
675 BOOL bIsCurrent = FALSE, BOOL bIsSelected = FALSE);
676 END_VIEW_PART(WeekViewPart)
677
683 BEGIN_VIEW_PART(WeekViewEventPart, XTPCalendarViewPart)
684 COLORREF m_clrTextHighLightColor;
685 COLORREF m_clrTextNormalColor;
692 virtual void RefreshMetrics()
693 {
694 m_clrBackground.SetStandardValue(
695 m_pPaintManager->GetWeekViewPart()->GetBackgroundColor()); // RGB(255, 255, 213));
696 m_clrTextColor.SetStandardValue(m_pPaintManager->m_clrButtonFaceText);
697 m_clrTextHighLightColor = RGB(255, 255, 255);
698 m_clrTextNormalColor = m_pPaintManager->m_clrButtonFaceText;
699
700 LOGFONT lfIcon;
701 VERIFY(m_pPaintManager->GetIconLogFont(&lfIcon));
702 m_fntText.SetStandardValue(&lfIcon);
703 }
704
712 virtual void OnDraw(CDC* pDC, CXTPCalendarWeekViewEvent* pWeekViewEvent);
713
722 virtual void DrawBorder(CDC* pDC, CRect rcView, CXTPCalendarWeekViewEvent* pWeekViewEvent);
723
732 virtual int DrawTimes(CDC* pDC, CXTPCalendarWeekViewEvent* pWeekViewEvent);
733
741 virtual void DrawSubj(CDC* pDC, CXTPCalendarWeekViewEvent* pWeekViewEvent);
742 END_VIEW_PART(WeekViewEventPart)
743
744
748 BEGIN_VIEW_PART(TimeLineViewTimeScalePart_Day, XTPCalendarTimeLineViewTimeScalePart)
749 virtual void Draw(CDC* pDC, const CRect& rcRect, CXTPCalendarTimeLineView* pView);
750 END_VIEW_PART(TimeLineViewTimeScalePart_Day)
751
752 BEGIN_VIEW_PART(TimeLineViewTimeScalePart_Week, XTPCalendarTimeLineViewTimeScalePart)
753 virtual void Draw(CDC* pDC, const CRect& rcRect, CXTPCalendarTimeLineView* pView);
754 END_VIEW_PART(TimeLineViewTimeScalePart_Week)
755
756 BEGIN_VIEW_PART(TimeLineViewTimeScalePart_Month, XTPCalendarTimeLineViewTimeScalePart)
757 virtual void Draw(CDC* pDC, const CRect& rcRect, CXTPCalendarTimeLineView* pView);
758 END_VIEW_PART(TimeLineViewTimeScalePart_Month)
759
760 BEGIN_VIEW_PART(TimeLineViewTimeScalePart_WorkWeek, XTPCalendarTimeLineViewTimeScalePart)
761 virtual void Draw(CDC* pDC, const CRect& rcRect, CXTPCalendarTimeLineView* pView);
762 END_VIEW_PART(TimeLineViewTimeScalePart_WorkWeek)
763
764 BEGIN_VIEW_PART(TimeLineViewPart, XTPCalendarTimeLineViewPart)
765
766 CXTPPaintManagerColor m_clrEventBar;
767 CXTPPaintManagerColor m_clrEventBarLine;
768 CXTPPaintManagerColor m_clrEventBorderLine;
770 CXTPPaintManagerColor m_clrTimeScaleBackground;
771 CXTPPaintManagerColor m_clrTimeScaleHightlite;
772 CXTPPaintManagerColor m_clrTimeScaleText;
774 CXTPPaintManagerColor m_clrSelectedBackground;
775 CXTPPaintManagerColor m_clrSelectedText;
777 CXTPPaintManagerColor m_clrBackground;
778 CXTPPaintManagerColor m_clrText;
780 CXTPPaintManagerColor m_clrWeekendBackground;
790 virtual void DrawGroup(CDC* pDC, const CRect& rcRect, CXTPCalendarTimeLineViewGroup* pGroup);
791
801 virtual CSize CalcEventSize(CDC* c, CXTPCalendarTimeLineViewEvent* pViewEvent);
802
811 virtual void DrawEvent(CDC* pDC, const CRect& rcEvents,
812 CXTPCalendarTimeLineViewEvent* pViewEvent);
813
818 virtual void RefreshMetrics();
819
820 CXTPImageManager* m_pImgTLVEvent;
821
826 virtual void _Init();
827
832 virtual ~CTimeLineViewPart();
833
834 END_VIEW_PART(TimeLineViewPart)
835
836 virtual void DrawBorders(CDC* pDC, const CRect& rcRect, const CRect& rcBorders);
837 virtual void DrawExpandSign(CDC* pDC, BOOL bExpandUp, const CRect& rcTSHours);
838 virtual CXTPCalendarViewEventSubjectEditor* StartEditSubject(CXTPCalendarViewEvent* pViewEvent,
839 CRect& rcEditor);
840 virtual void SetEditFont(CXTPCalendarViewEvent* pViewEvent,
841 CXTPCalendarViewEventSubjectEditor* pEditor);
842 virtual void GetDateFormat(CString& strShort, CString& strLong);
843
844protected:
845 virtual void CreateGlyphsFont();
846 virtual void RefreshPartMetrics();
847
848 //-- CALENDAR PART REFRESH METHODS
849 virtual void PartRefresh(CControlPart* pViewPart);
850 virtual void PartRefresh(CDayViewEventPart* pViewPart);
851 virtual void PartRefresh(CDayViewTimeScaleCellPart* pViewPart);
852 virtual void PartRefresh(CDayViewTimeScaleHeaderPart* pViewPart);
853 virtual void PartRefresh(CDayViewCellPart* pViewPart);
854 virtual void PartRefresh(CDayViewAllDayEventsPart* pViewPart);
855 virtual void PartRefresh(CDayViewHeaderPart* pViewPart);
856 virtual void PartRefresh(CWeekViewPart* pViewPart);
857 virtual void PartRefresh(CMonthViewHeaderPart* pViewPart);
858 virtual void PartRefresh(CMonthViewEventPart* pViewPart);
859 virtual void PartRefresh(CDayViewWorkCellPart* pViewPart);
860 virtual void PartRefresh(CDayViewNonworkCellPart* pViewPart);
861 virtual void PartRefresh(CMonthViewGridPart* pViewPart);
862 virtual void PartRefresh(CTimeLineViewPart* pViewPart);
863
864 //-- CALENDAR PART DRAWING METHODS
865 virtual void PartDraw(CDayViewEventPart* pViewPart, CDC* pDC,
866 CXTPCalendarDayViewEvent* pViewEvent);
867 virtual void PartDrawHourCell(CDayViewTimeScaleCellPart* pViewPart, CDC* pDC, CRect rc,
868 CString strText, BOOL bFillBackground, BOOL bCurrentTime);
869 virtual void PartDrawBigHourCell(CDayViewTimeScaleCellPart* pViewPart, CDC* pDC, CRect rc,
870 CString strHour, CString strMin, int nRowPerHour,
871 BOOL bFillBackground, BOOL bCurrentTime);
872 virtual void PartDraw(CDayViewTimeScaleHeaderPart* pViewPart, CDC* pDC,
873 CXTPCalendarDayView* pView, CRect rc, CString strText);
874 virtual void PartDrawNowLine(CDayViewTimeScaleHeaderPart* pViewPart, CDC* pDC,
875 CXTPCalendarDayView* pView, CRect rc, int y, BOOL bDrawBk);
876 virtual void PartDrawNowLine(CDayViewTimeScaleHeaderPart* pViewPart, CDC* pDC,
877 CXTPCalendarDayView* pView, CXTPCalendarDayViewTimeScale* pScale,
878 CRect rc, int y, BOOL bDrawBk);
879 virtual void PartDraw(CDayViewCellPart* pViewPart, CDC* pDC,
880 CXTPCalendarDayViewGroup* pViewGroup, CRect rc,
881 const XTP_CALENDAR_DAYVIEWCELL_PARAMS& cellParams);
882 virtual void PartDraw(CDayViewAllDayEventsPart* pViewPart, CDC* pDC,
883 CXTPCalendarDayViewGroup* pViewGroup, CRect rc, BOOL bSelected);
884 virtual void PartDraw(CDayViewHeaderPart* pViewPart, CDC* pDC, CXTPCalendarDayViewDay* pViewDay,
885 CRect rc, CString strText);
886 virtual void PartDraw(CDayViewAllDayEventScrollIconsPart* pViewPart, CDC* pDC,
887 CXTPCalendarDayViewGroup* pViewGroup, BOOL bDrawUp, BOOL bDrawDown,
888 const CRect& rcIconUp, const CRect& rcIconDown, BOOL bHighlightUp,
889 BOOL bHighlightDown);
890 virtual void PartDraw(CDayViewGroupHeaderPart* pViewPart, CDC* pDC,
891 CXTPCalendarDayViewGroup* pViewGroup, CRect rc, CString strText);
892 virtual void PartDrawDayHeader(CWeekViewPart* pViewPart, CDC* pDC, CRect rcDay,
893 int nHeaderHeight, CString strHeader, BOOL bIsCurrent,
894 BOOL bIsSelected);
895 virtual void PartDraw(CWeekViewPart* pViewPart, CDC* pDC, CXTPCalendarWeekView* pWeekView);
896 virtual void PartDrawBorder(CWeekViewEventPart* pViewPart, CDC* pDC, CRect rcView,
897 CXTPCalendarWeekViewEvent* pWeekViewEvent);
898 virtual int PartDrawTimes(CWeekViewEventPart* pViewPart, CDC* pDC,
899 CXTPCalendarWeekViewEvent* pWeekViewEvent);
900 virtual void PartDrawSubj(CWeekViewEventPart* pViewPart, CDC* pDC,
901 CXTPCalendarWeekViewEvent* pWeekViewEvent);
902 virtual void PartDraw(CWeekViewEventPart* pViewPart, CDC* pDC,
903 CXTPCalendarWeekViewEvent* pWeekViewEvent);
904 virtual void PartDrawGrid(CMonthViewGridPart* pViewPart, CDC* pDC,
905 CXTPCalendarMonthView* pMonthView);
906 virtual void PartDraw(CMonthViewHeaderPart* pViewPart, CDC* pDC,
907 CXTPCalendarMonthView* pMonthView, CRect rc, int nCollIndex,
908 CString strText);
909 virtual void PartDrawDayDate(CMonthViewEventPart* pViewPart, CDC* pDC, CRect rc, BOOL bToday,
910 BOOL bSelected, BOOL bFirstMonthDay, CString strText);
911 virtual void PartDrawEvent(CMonthViewEventPart* pViewPart, CDC* pDC,
912 CXTPCalendarMonthViewEvent* pViewEvent);
913 virtual void PartDraw(CTimeLineViewTimeScalePart_Day* pViewPart, CDC* pDC, const CRect& rcRect,
914 CXTPCalendarTimeLineView* pView);
915 virtual void PartDraw(CTimeLineViewTimeScalePart_Week* pViewPart, CDC* pDC, const CRect& rcRect,
916 CXTPCalendarTimeLineView* pView);
917 virtual void PartDraw(CTimeLineViewTimeScalePart_Month* pViewPart, CDC* pDC,
918 const CRect& rcRect, CXTPCalendarTimeLineView* pView);
919 virtual void PartDraw(CTimeLineViewTimeScalePart_WorkWeek* pViewPart, CDC* pDC,
920 const CRect& rcRect, CXTPCalendarTimeLineView* pView);
921 virtual void PartDrawGroup(CTimeLineViewPart* pViewPart, CDC* pDC, const CRect& rcRect,
922 CXTPCalendarTimeLineViewGroup* pGroup);
923 virtual void PartDrawEvent(CTimeLineViewPart* pViewPart, CDC* pDC, const CRect& rcEvents,
924 CXTPCalendarTimeLineViewEvent* pViewEvent);
925
926 //-- CALENDAR PART GET METHODS
927 virtual COLORREF PartGetBackColor(CXTPCalendarViewPart* pViewPart);
928 virtual COLORREF PartGetTextColor(CXTPCalendarViewPart* pViewPart);
929 virtual CFont& PartGetTextFont(CXTPCalendarViewPart* pViewPart,
930 CXTPCalendarViewPartFontValue& fntText);
931 virtual void PartGetParams(CDayViewCellPart* pViewPart, CXTPCalendarDayViewGroup* pViewGroup,
932 XTP_CALENDAR_DAYVIEWCELL_PARAMS* rCellParams);
933
934 //-- MISC PART METHODS
935 virtual void PartCalcWidth(CDayViewTimeScaleCellPart* pViewPart, CDC* pDC,
936 const CString& strHour, const CString& strMin, int nHourHeight,
937 int& nWidth);
938 virtual void PartAdjustTimeFont(CDayViewTimeScaleCellPart* pViewPart, CDC* pDC, CRect rcCell);
939 virtual CSize PartCalcEventSize(CTimeLineViewPart* pViewPart, CDC* pDC,
940 CXTPCalendarTimeLineViewEvent* pViewEvent);
941
942public:
952 CXTPCalendarPaintManager();
953
961 virtual ~CXTPCalendarPaintManager();
962
963public:
968 virtual void UpdateEventLabelsDefaultColors();
969
974 virtual void UpdateEventCategoriesDefaultColors();
975
982 virtual XTPCalendarTheme GetPaintTheme() const;
983
990 virtual void SetPaintTheme(XTPCalendarTheme ePaintTheme);
991
1000 virtual void RefreshMetrics();
1001
1010 virtual void UpdateGlyphs();
1011
1024 virtual COLORREF GetEventBackColor(CXTPCalendarEvent* pEvent, COLORREF crDefault);
1025
1039 virtual void DrawLine(CDC* pDC, int xPos, int yPos, int cx, int cy);
1040
1053 virtual void DrawHorizontalLine(CDC* pDC, int xPos, int yPos, int cx);
1054
1067 virtual void DrawVerticalLine(CDC* pDC, int xPos, int yPos, int cy);
1068
1090 virtual int DrawClock(CDC* pDC, COleDateTime dtClockTime, CRect rcView, COLORREF clrBackground,
1091 XTPCalendarClockAlignFlags cafAlign);
1092
1111 virtual int DrawBitmap(CImageList* pImageList, CDC* pDC, CRect rcView, int iIcon,
1112 UINT uFlags = 0);
1113
1129 virtual int DrawBitmap(UINT nIDResource, CDC* pDC, CRect rcBitmap);
1130
1147 virtual int DrawIconChar(CDC* pDC, CRect rc, TCHAR ch);
1148
1156 virtual const CSize GetExpandSignSize();
1157
1165 virtual CSize GetClockSize();
1166
1174 virtual void SetControl(CXTPCalendarControl* pControl);
1175
1185 virtual void DrawShadow(CDC* pDC, const CRect& rcRect);
1186
1196 virtual int DrawIcons(CDC* pDC, CXTPCalendarViewEvent* pViewEvent);
1197
1209 virtual void DrawHeader(CDC* pDC, CRect& rcHeader, BOOL bIsSelected, BOOL bIsCurrent);
1210
1226 virtual void DrawHeader(CDC* pDC, CRect& rcHeader, BOOL bIsSelected, BOOL bIsCurrent,
1227 const CXTPPaintManagerColorGradient& grclr, COLORREF clrUnderLineHdr);
1228
1243 virtual void DrawBusyStatus(CDC* pDC, CRect& rcRect, int eBusyStatus);
1244
1260 virtual void DrawBusyStatus(CDC* pDC, CRgn& rgnBusy, int eBusyStatus);
1261
1268 void EnableTheme(BOOL bEnableTheme);
1269
1276 BOOL IsThemeEnabled();
1277
1291 XTPCurrentSystemTheme GetCurrentSystemTheme();
1292
1293public:
1294private:
1295 CSize m_szExpandSign; // Cached size of the expand sign
1296
1297protected:
1307 CXTPCalendarViewPart* AddViewPart(CXTPCalendarViewPart* pPart);
1308
1309public:
1310 CFont* m_pSelFont;
1311 CXTPPaintManagerColor m_clrButtonFace;
1312 CXTPPaintManagerColor m_clrButtonFaceText;
1313 CXTPPaintManagerColor m_clrWindow;
1314 CXTPPaintManagerColor m_clrWindowText;
1315 CXTPPaintManagerColor m_clr3DShadow;
1316 CXTPPaintManagerColor m_clrHighlight;
1317 CXTPPaintManagerColor m_clrBorders[4];
1319 CXTPPaintManagerColor m_clrTLVEventBar;
1320 CXTPPaintManagerColor m_clrTLVEventBarLine;
1321 CXTPPaintManagerColor m_clrTLVEventBorderLine;
1322 CXTPPaintManagerColor m_clrTLVTimeScaleBackground;
1323 CXTPPaintManagerColor m_clrTLVTimeScaleBorder;
1324 CXTPPaintManagerColor m_clrTLVTimeScaleHighlight;
1325 CXTPPaintManagerColor m_clrTLVTimeScaleText;
1326 CXTPPaintManagerColor m_clrTLVText;
1327 CXTPPaintManagerColor m_clrTLVBack;
1328 CXTPPaintManagerColor m_clrTLVSelectedText;
1329 CXTPPaintManagerColor m_clrTLVSelectedBack;
1330 CXTPPaintManagerColor m_clrTLVWeekendBack;
1331 CXTPPaintManagerColorGradient m_grclrToday;
1357 void SetBusyStatusBrush(int nBusyStatus, CBrush* pBrush, BOOL bAutodeleteBrush);
1358
1367 CBrush* GetBusyStatusBrush(int nBusyStatus);
1368
1384 DWORD GetAskItemTextFlags() const;
1385
1402 void SetAskItemTextFlags(DWORD dwFlags);
1403
1404 BOOL GetIconLogFont(LOGFONT* plf);
1405
1406 CUIntArray m_arStartCol;
1407 CUIntArray m_arStartRow;
1408 int m_PrintPageWidth;
1410protected:
1411 CList<CXTPCalendarViewPart*, CXTPCalendarViewPart*> m_lstViewParts;
1418 enum XTPEnumExpandSigns
1419 {
1420 idxExpandSignUp = 0,
1421 idxExpandSignDown = 1
1422 };
1423
1424 CXTPImageManager* m_pExpandSigns;
1430 enum XTPEnumEventGlyphs
1431 {
1432 idxMeeting = 0,
1433 idxPrivate = 1,
1434 idxRecurrenceException = 2,
1435 idxRecurrenceOccurrence = 3,
1436 idxReminder = 4
1437 };
1438
1439 CXTPImageManager* m_pGlyphs;
1442 CFont* m_pGlyphsFont;
1444 CBitmap m_bmpElsewherePattern;
1447 CXTPBrush m_xtpBrushElsewhere;
1448 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CBrush, m_brushElsewhere, m_xtpBrushElsewhere,
1449 GetBrushElsewhereHandle);
1450
1451 CBitmap m_bmpTentativePattern;
1454 CXTPBrush m_xtpBrushTentative;
1455 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CBrush, m_brushTentative, m_xtpBrushTentative,
1456 GetBrushTentativeHandle);
1457
1458 CXTPCalendarTypedPtrAutoDeleteArray<CPtrArray, CXTPCalendarViewPartBrushValue*>
1459 m_arBusyStatusBrushes;
1473 CXTPCalendarViewPartBrushValue* _GetAtGrow_BusyStatusBrushValue(int eBusyStatus, BOOL bGrow);
1474
1479 virtual void InitBusyStatusDefaultColors();
1480
1481 virtual void FormatLabel(CString& strLabel);
1482
1483 CSize m_szClockRect;
1486 CXTPCalendarControl* m_pControl;
1488 BOOL m_bEnableTheme;
1489 COLORREF m_clrUnderLineHdr;
1490 XTPCurrentSystemTheme m_CurrSystemTheme;
1492 XTPCalendarTheme m_nPaintTheme;
1494 DWORD m_dwAskItemTextFlags;
1497protected:
1498# ifdef _XTP_ACTIVEX
1499
1500 friend class CCalendarControlCtrl;
1501 CXTPCalendarFlagsSet_imp* AxGetAskItemTextFlags();
1502 friend class CXTPCalendarMonthViewDay;
1503
1504# endif
1505};
1506
1508
1509AFX_INLINE XTPCalendarTheme CXTPCalendarPaintManager::GetPaintTheme() const
1510{
1511 return m_nPaintTheme;
1512}
1513
1514AFX_INLINE void CXTPCalendarPaintManager::SetPaintTheme(XTPCalendarTheme ePaintTheme)
1515{
1516 m_nPaintTheme = min(xtpCalendarThemeOffice2013, ePaintTheme);
1517 RefreshMetrics();
1518}
1519
1520AFX_INLINE XTPCurrentSystemTheme CXTPCalendarPaintManager::GetCurrentSystemTheme()
1521{
1522 return m_CurrSystemTheme;
1523}
1524
1525AFX_INLINE CSize CXTPCalendarPaintManager::GetClockSize()
1526{
1527 return m_szClockRect;
1528}
1529AFX_INLINE BOOL CXTPCalendarPaintManager::IsThemeEnabled()
1530{
1531 return m_bEnableTheme;
1532}
1533
1534AFX_INLINE void CXTPCalendarPaintManager::EnableTheme(BOOL bEnableTheme)
1535{
1536 m_bEnableTheme = bEnableTheme;
1537 RefreshMetrics();
1538}
1539
1540AFX_INLINE DWORD CXTPCalendarPaintManager::GetAskItemTextFlags() const
1541{
1542 return m_dwAskItemTextFlags;
1543}
1544
1545AFX_INLINE void CXTPCalendarPaintManager::SetAskItemTextFlags(DWORD dwFlags)
1546{
1547 m_dwAskItemTextFlags = dwFlags;
1548}
1549
1551
1552# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
1553#endif // !defined(_XTPCALENDARPAINTMANAGER_H__)
XTPCalendarClockAlignFlags
XTPCalendarClockAlignFlags
Definition XTPCalendarDefines.h:306
XTPCalendarTheme
XTPCalendarTheme
Paint themes used by calendar.
Definition XTPCalendarDefines.h:62
xtpCalendarThemeOffice2013
@ xtpCalendarThemeOffice2013
Office 2013 theme.
Definition XTPCalendarDefines.h:67
BEGIN_VIEW_PART
#define BEGIN_VIEW_PART(theClass, parentClass)
This helper macro is used to declare paint manager drawing parts.
Definition XTPCalendarPaintManager.h:79
END_VIEW_PART
#define END_VIEW_PART(theClass)
This helper macro is used to declare paint manager drawing parts.
Definition XTPCalendarPaintManager.h:101
XTPCurrentSystemTheme
XTPCurrentSystemTheme
Enumeration used to determine the current Windows XP theme in use.
Definition XTPColorManager.h:45
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPBrush
Provides a convenient object oriented interface for HBRUSH GDI object and uses GDI handle caching.
Definition XTPGdiObjects.h:653
CXTPCalendarControl
Class CXTPCalendarControl implements the calendar's view interface.
Definition XTPCalendarControl.h:126
CXTPCalendarDayViewDay
This class represents a day view portion of the Calendar Day View.
Definition XTPCalendarDayViewDay.h:726
CXTPCalendarDayViewEvent
This class represents an event view portion of the CalendarDayViewDay.
Definition XTPCalendarDayViewEvent.h:56
CXTPCalendarDayViewGroup
This class represents a single resource view portion of the Calendar Day View.
Definition XTPCalendarDayViewDay.h:53
CXTPCalendarDayView
This class implements a specific view portion of the Calendar control - called Day view.
Definition XTPCalendarDayView.h:62
CXTPCalendarDayViewTimeScale
This class implements a specific view portion of the Calendar Day view - called Time scale.
Definition XTPCalendarDayViewTimeScale.h:75
CXTPCalendarEvent
This class represents the data of a single Event used in the Calendar control.
Definition XTPCalendarEvent.h:77
CXTPCalendarMonthViewDay
This class represents a day view portion of the CalendarMonthView.
Definition XTPCalendarMonthViewDay.h:151
CXTPCalendarMonthViewEvent
This class represents an event view portion of the CalendarMonthViewDay.
Definition XTPCalendarMonthViewEvent.h:56
CXTPCalendarMonthView
This class implements a specific view portion of the Calendar control - called Month view.
Definition XTPCalendarMonthView.h:74
CXTPCalendarPaintManager
Utility class, handles most of the drawing activities.
Definition XTPCalendarPaintManager.h:150
CXTPCalendarPaintManager::m_pExpandSigns
CXTPImageManager * m_pExpandSigns
Stores standard Expand Signs icons.
Definition XTPCalendarPaintManager.h:1424
CXTPCalendarPaintManager::m_arBusyStatusBrushes
CXTPCalendarTypedPtrAutoDeleteArray< CPtrArray, CXTPCalendarViewPartBrushValue * > m_arBusyStatusBrushes
Stores customizable brush values to draw Event Busy Status in the Day View.
Definition XTPCalendarPaintManager.h:1459
CXTPCalendarPaintManager::InitBusyStatusDefaultColors
virtual void InitBusyStatusDefaultColors()
Set default colors/patterns to fill Busy Status area.
CXTPCalendarPaintManager::m_bmpElsewherePattern
CBitmap m_bmpElsewherePattern
Stores standard bitmap pattern to draw Elsewhere event busy status.
Definition XTPCalendarPaintManager.h:1444
CXTPCalendarPaintManager::OnDraw
virtual void OnDraw(CDC *pDC, CXTPCalendarWeekViewEvent *pWeekViewEvent)
This member function is used to draw the specified event.
CXTPCalendarPaintManager::DrawTimes
virtual int DrawTimes(CDC *pDC, CXTPCalendarWeekViewEvent *pWeekViewEvent)
This member function is used to draw the event's times texts or icons.
CXTPCalendarPaintManager::DrawExpandSigns
virtual void DrawExpandSigns(CDC *pDC, CXTPCalendarDayView *pView, const CRect &rcTSHours)
This member function is used to draw expand signs.
CXTPCalendarPaintManager::m_szClockRect
CSize m_szClockRect
Stores dimensions for a rectangle used to display the time as a clock glyph.
Definition XTPCalendarPaintManager.h:1483
CXTPCalendarPaintManager::m_dwAskItemTextFlags
DWORD m_dwAskItemTextFlags
Store flag set to send XTP_NC_CALENDAR_GETITEMTEXT notification.
Definition XTPCalendarPaintManager.h:1494
CXTPCalendarPaintManager::DrawNowLine
virtual void DrawNowLine(CDC *pDC, CXTPCalendarDayView *pView, CXTPCalendarDayViewTimeScale *pScale, CRect rc, int y, BOOL bDrawBk=FALSE)
This member function is used to draw the 'Now' line.
CXTPCalendarPaintManager::m_pControl
CXTPCalendarControl * m_pControl
Stores a pointer to a CXTPCalendarControl object.
Definition XTPCalendarPaintManager.h:1486
CXTPCalendarPaintManager::OnDraw
virtual void OnDraw(CDC *pDC, CXTPCalendarDayView *pView, CRect rc, CString strText)
This member function is used to draw the time scale header.
CXTPCalendarPaintManager::m_bEnableTheme
BOOL m_bEnableTheme
True to enable Luna theme.
Definition XTPCalendarPaintManager.h:1488
CXTPCalendarPaintManager::BEGIN_VIEW_PART
BEGIN_VIEW_PART(ControlPart, XTPCalendarViewPart) virtual void RefreshMetrics()
Paint manager's ControlPart is used as parent for the other parts of the control.
CXTPCalendarPaintManager::m_CurrSystemTheme
XTPCurrentSystemTheme m_CurrSystemTheme
Current theme flag.
Definition XTPCalendarPaintManager.h:1490
CXTPCalendarPaintManager::m_xtpBrushElsewhere
CXTPBrush m_xtpBrushElsewhere
Stores standard brush to draw Elsewhere event busy status.
Definition XTPCalendarPaintManager.h:1447
CXTPCalendarPaintManager::GetClockSize
virtual CSize GetClockSize()
This member function is used to obtain the horizontal and vertical size of the Clock.
Definition XTPCalendarPaintManager.h:1525
CXTPCalendarPaintManager::m_nPaintTheme
XTPCalendarTheme m_nPaintTheme
Store the Paint Theme;.
Definition XTPCalendarPaintManager.h:1492
CXTPCalendarPaintManager::DrawSubj
virtual void DrawSubj(CDC *pDC, CXTPCalendarWeekViewEvent *pWeekViewEvent)
This member function is used to draw the event subject.
CXTPCalendarPaintManager::m_bmpTentativePattern
CBitmap m_bmpTentativePattern
Stores standard bitmap pattern to draw Tentative event busy status.
Definition XTPCalendarPaintManager.h:1451
CXTPCalendarPaintManager::END_VIEW_PART
END_VIEW_PART(WeekViewEventPart) BEGIN_VIEW_PART(TimeLineViewTimeScalePart_Day
This paint manager part is used to draw time scale for the Time Line view.
CXTPCalendarPaintManager::XTPEnumExpandSigns
XTPEnumExpandSigns
Enumerates types of expand signs drawn on a day view.
Definition XTPCalendarPaintManager.h:1419
CXTPCalendarPaintManager::END_VIEW_PART
END_VIEW_PART(DayMonthViewHeaderPart) BEGIN_VIEW_PART(DayViewHeaderPart
This paint manager part is used to draw days headers for the Day View.
CXTPCalendarPaintManager::END_VIEW_PART
END_VIEW_PART(ControlPart) BEGIN_VIEW_PART(DayViewTimeScaleHeaderPart
This paint manager part is used to draw the time scale header, 'Now' line, and the expand signs for t...
CXTPCalendarPaintManager::END_VIEW_PART
END_VIEW_PART(DayViewTimeScaleHeaderPart) BEGIN_VIEW_PART(DayViewTimeScaleCellPart
This paint manager part is used to draw time scale time cells for the Day View.
CXTPCalendarPaintManager::DrawBorder
virtual void DrawBorder(CDC *pDC, CRect rcView, CXTPCalendarWeekViewEvent *pWeekViewEvent)
This member functions is used to draw the event border.
CXTPCalendarPaintManager::GetPaintTheme
virtual XTPCalendarTheme GetPaintTheme() const
This member function is used to obtain the current paint theme.
Definition XTPCalendarPaintManager.h:1509
CXTPCalendarPaintManager::m_clrUnderLineHdr
COLORREF m_clrUnderLineHdr
Color of header's underline.
Definition XTPCalendarPaintManager.h:1489
CXTPCalendarPaintManager::EnableTheme
void EnableTheme(BOOL bEnableTheme)
This member function is used to enable a new theme.
Definition XTPCalendarPaintManager.h:1534
CXTPCalendarPaintManager::IsThemeEnabled
BOOL IsThemeEnabled()
This member function is used to obtain the status of the theme.
Definition XTPCalendarPaintManager.h:1529
CXTPCalendarPaintManager::DrawNowLine
virtual void DrawNowLine(CDC *pDC, CXTPCalendarDayView *pView, CRect rc, int y, BOOL bDrawBk=FALSE)
This member function is used to draw the 'Now' line.
CXTPCalendarPaintManager::GetCurrentSystemTheme
XTPCurrentSystemTheme GetCurrentSystemTheme()
Call this member function to determine the current Windows XP theme that is in use.
Definition XTPCalendarPaintManager.h:1520
CXTPCalendarPaintManager::XTPEnumEventGlyphs
XTPEnumEventGlyphs
Enumerates types of event glyphs.
Definition XTPCalendarPaintManager.h:1431
CXTPCalendarPaintManager::m_pGlyphs
CXTPImageManager * m_pGlyphs
Stores standard glyphs for displaying events.
Definition XTPCalendarPaintManager.h:1439
CXTPCalendarPaintManager::SetPaintTheme
virtual void SetPaintTheme(XTPCalendarTheme ePaintTheme)
This member function is used to set the current paint theme.
Definition XTPCalendarPaintManager.h:1514
CXTPCalendarPaintManager::RefreshMetrics
virtual void RefreshMetrics()
Performs refreshing of graphical related parameters from system settings.
CXTPCalendarPaintManager::m_pGlyphsFont
CFont * m_pGlyphsFont
Stores standard glyphs font for displaying events.
Definition XTPCalendarPaintManager.h:1442
CXTPCalendarPaintManager::GetAskItemTextFlags
DWORD GetAskItemTextFlags() const
This member function returns a set of flags which define calendar items to send an XTP_NC_CALENDAR_GE...
Definition XTPCalendarPaintManager.h:1540
CXTPCalendarPaintManager::_GetAtGrow_BusyStatusBrushValue
CXTPCalendarViewPartBrushValue * _GetAtGrow_BusyStatusBrushValue(int eBusyStatus, BOOL bGrow)
Returns drawing brush value for a specific busy status.
CXTPCalendarPaintManager::m_xtpBrushTentative
CXTPBrush m_xtpBrushTentative
Stores standard brush to draw Tentative event busy status.
Definition XTPCalendarPaintManager.h:1454
CXTPCalendarPaintManager::SetAskItemTextFlags
void SetAskItemTextFlags(DWORD dwFlags)
This member function is used to set flags which define calendar items to send an XTP_NC_CALENDAR_GETI...
Definition XTPCalendarPaintManager.h:1545
CXTPCalendarTimeLineViewEvent
This class represents an event timeline view portion of the CXTPCalendarViewEvent.
Definition XTPCalendarTimeLineViewGroup.h:51
CXTPCalendarTimeLineViewGroup
This class represents an event timeline view portion of the CalendarViewGroup.
Definition XTPCalendarTimeLineViewGroup.h:242
CXTPCalendarTimeLineView
This class implements a specific view portion of the Calendar control - called Timeline view.
Definition XTPCalendarTimeLineView.h:76
CXTPCalendarTimeLineViewTimeScale
This class implements a specific view portion of the Calendar control called Timeline view scale.
Definition XTPCalendarTimeLineViewTimeScale.h:70
CXTPCalendarTypedPtrAutoDeleteArray
This class represents a simple array collection of objects pointers.
Definition XTPCalendarPtrCollectionT.h:472
CXTPCalendarViewEvent
This class represents an event view portion of the CalendarViewGroup.
Definition XTPCalendarViewEvent.h:106
CXTPCalendarViewEventSubjectEditor
This class is used to edit an event subject.
Definition XTPCalendarViewEvent.h:1157
CXTPCalendarViewPartBrushValue
Helper class provides functionality to manage brush value objects.
Definition XTPCalendarViewPart.h:849
CXTPCalendarViewPartFontValue
Helper class provides functionality to manage font settings for various graphical elements of control...
Definition XTPCalendarViewPart.h:45
CXTPCalendarViewPart
Helper base class to implement parts for calendar paint manager.
Definition XTPCalendarViewPart.h:1228
CXTPCalendarWeekViewEvent
This class represents an event view portion of the CalendarWeekViewDay.
Definition XTPCalendarWeekViewEvent.h:58
CXTPCalendarWeekView
This class implements a specific view portion of the Calendar control - called Week view.
Definition XTPCalendarWeekView.h:54
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPImageManager
CXTPImageManager is a standalone class.
Definition XTPImageManager.h:1898
CXTPPaintManagerColorGradient
The CXTPPaintManagerColorGradient class is used to manage COLORREF values for determining light and d...
Definition XTPColorManager.h:301
CXTPPaintManagerColorGradient::SetStandardValue
void SetStandardValue(const COLORREF clr)
This member function sets the value of the default dark and light colors equal to the specified COLOR...
CXTPPaintManagerColor
The CXTPPaintManagerColor class is used to manage COLORREF values for determining default and applica...
Definition XTPColorManager.h:117
CXTPPaintManagerColor::SetStandardValue
void SetStandardValue(COLORREF clr)
This member function will sets the default color for the CXTPPaintManagerColor class.
CXTPResourceImage
Represent a resource image and provides basic images functions.
Definition XTPResourceImage.h:48
XTP_CALENDAR_DAYVIEWCELL_PARAMS
Set of parameters transferred from calendar items for an XTP_NC_CALENDAR_BEFORE_DRAW_DAYVIEWCELL noti...
Definition XTPCalendarNotifications.h:638


Toolkit Pro: XTPChartStepAreaSeriesStyle.h Source File

  • Source
  • Chart
  • Styles
  • Area
XTPChartStepAreaSeriesStyle.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTStepAreaSERIESSTYLE_H__)
24# define __XTPCHARTStepAreaSERIESSTYLE_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartSeriesView;
34class CXTPChartStepAreaStyle;
35
46class _XTP_EXT_CLASS CXTPChartStepAreaSeriesStyle : public CXTPChartAreaSeriesStyle
47{
49 DECLARE_SERIAL(CXTPChartStepAreaSeriesStyle)
51public:
56 CXTPChartStepAreaSeriesStyle();
57
62 virtual ~CXTPChartStepAreaSeriesStyle();
63
64public:
65 BOOL GetInvertedStep() const;
66 void SetInvertedStep(BOOL bInvertedStep);
67
68protected:
80 virtual CXTPChartSeriesView* CreateView(CXTPChartSeries* pSeries,
81 CXTPChartDiagramView* pDiagramView);
82
83 void DoPropExchange(CXTPPropExchange* pPX);
84# ifdef _XTP_ACTIVEX
85public:
87 DECLARE_DISPATCH_MAP()
88 DECLARE_INTERFACE_MAP()
89 DECLARE_OLETYPELIB_EX(CXTPChartStepAreaSeriesStyle);
90 DECLARE_OLECREATE_EX(CXTPChartStepAreaSeriesStyle)
91 LPDISPATCH OleGetStepAreaStyle();
93# endif
94
95protected:
96 BOOL m_bInvertedStep;
97};
98
104class _XTP_EXT_CLASS CXTPChartStepAreaSeriesView : public CXTPChartAreaSeriesView
105{
106public:
114 CXTPChartStepAreaSeriesView(CXTPChartSeries* pSeries, CXTPChartDiagramView* pDiagramView);
115
116protected:
129 virtual CXTPChartDeviceCommand* CreateDeviceCommand(CXTPChartDeviceContext* pDC);
130};
131
132AFX_INLINE BOOL CXTPChartStepAreaSeriesStyle::GetInvertedStep() const
133{
134 return m_bInvertedStep;
135}
136AFX_INLINE void CXTPChartStepAreaSeriesStyle::SetInvertedStep(BOOL bInvertedStep)
137{
138 m_bInvertedStep = bInvertedStep;
139 OnChartChanged();
140}
142# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
143#endif //#if !defined(__XTPCHARTStepAreaSERIESSTYLE_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartAreaSeriesStyle
CXTPChartAreaSeriesStyle is a CXTPChartPointSeriesStyle derived class which represents the area serie...
Definition XTPChartAreaSeriesStyle.h:48
CXTPChartAreaSeriesView
CXTPChartAreaSeriesView is a kind of CXTPChartSeriesView.
Definition XTPChartAreaSeriesView.h:48
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartDiagramView
This class represents the view of a chart diagram, which is a kind of CXTPChartElementView.
Definition XTPChartDiagramView.h:49
CXTPChartElement::OnChartChanged
virtual void OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic propertie...
CXTPChartSeries
This class represents a series in the chart, which is a kind of CXTPChartElement.
Definition XTPChartSeries.h:50
CXTPChartStepAreaSeriesStyle
This class represents a StepArea series style, which is a kind of CXTPChartAreaSeriesStyle.
Definition XTPChartStepAreaSeriesStyle.h:47
CXTPChartStepAreaSeriesStyle::DoPropExchange
void DoPropExchange(CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
CXTPChartStepAreaSeriesStyle::CreateView
virtual CXTPChartSeriesView * CreateView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Call this function to create a view of the StepArea series.
CXTPChartStepAreaSeriesStyle::CXTPChartStepAreaSeriesStyle
CXTPChartStepAreaSeriesStyle()
Constructs a CXTPChartStepAreaSeriesStyle object.
CXTPChartStepAreaSeriesStyle::~CXTPChartStepAreaSeriesStyle
virtual ~CXTPChartStepAreaSeriesStyle()
Destroys a CXTPChartStepAreaSeriesStyle object, handles cleanup.
CXTPChartStepAreaSeriesView
This class represents the view of a StepArea series, which is a kind of CXTPChartSeriesView.
Definition XTPChartStepAreaSeriesStyle.h:105
CXTPChartStepAreaSeriesView::CXTPChartStepAreaSeriesView
CXTPChartStepAreaSeriesView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Constructs a CXTPChartStepAreaSeriesView object.
CXTPChartStepAreaSeriesView::CreateDeviceCommand
virtual CXTPChartDeviceCommand * CreateDeviceCommand(CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72


Toolkit Pro: Member List

CXTPSearchOptionsView Member List

This is the complete list of members for CXTPSearchOptionsView, including all inherited members.

AdjustScrollSizes(CXTPSearchOptionsCtrl *pSOCtrl, bool bAdd) | CXTPSearchOptionsView | protected
CXTPSearchOptionsView(UINT nIDTemplate) | CXTPSearchOptionsView | protected
CXTPSearchOptionsView(LPCTSTR lpszTemplateName) | CXTPSearchOptionsView | protected
m_arResizeWnd | CXTPSearchOptionsView | protected
m_rcWindow | CXTPSearchOptionsView | protected
m_xtpBrush | CXTPSearchOptionsView | protected
SetResize(int nID, const XTP_RESIZEPOINT &ptTopLeft, const XTP_RESIZEPOINT &ptTopRight) | CXTPSearchOptionsView | protected
~CXTPSearchOptionsView() | CXTPSearchOptionsView | protectedvirtual


Toolkit Pro: XTPTaskPanelToolboxTheme.h Source File

  • Source
  • TaskPanel
  • Themes
XTPTaskPanelToolboxTheme.h
Go to the documentation of this file.
1
23#ifndef XTPTaskPanelToolboxTheme_h__
24# define XTPTaskPanelToolboxTheme_h__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
39class _XTP_EXT_CLASS CXTPTaskPanelToolboxTheme : public CXTPTaskPanelPaintManagerPlain
40{
41public:
46 CXTPTaskPanelToolboxTheme();
47
52 void RefreshMetrics();
53
64 int DrawGroupCaption(CDC* pDC, CXTPTaskPanelGroup* pGroup, BOOL bDraw);
65
66protected:
76 virtual CRect DrawGroupCaptionBackground(CDC* pDC, CXTPTaskPanelGroup* pGroup, CRect rc);
77};
79# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
80#endif // XTPTaskPanelToolboxTheme_h__
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPTaskPanelGroup
CXTPTaskPanelGroup is used in a Task Panel control to represent a group.
Definition XTPTaskPanelGroup.h:45
CXTPTaskPanelPaintManagerPlain
Base class theme that all other themes are derived from.
Definition XTPTaskPanelPaintManagerPlain.h:41
CXTPTaskPanelToolboxTheme
CXTPTaskPanelToolboxTheme represents a Toolbox style theme.
Definition XTPTaskPanelToolboxTheme.h:40
CXTPTaskPanelToolboxTheme::DrawGroupCaptionBackground
virtual CRect DrawGroupCaptionBackground(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Draws the group caption background of a specified group.
CXTPTaskPanelToolboxTheme::CXTPTaskPanelToolboxTheme
CXTPTaskPanelToolboxTheme()
Constructs a CXTPTaskPanelToolboxTheme object.
CXTPTaskPanelToolboxTheme::DrawGroupCaption
int DrawGroupCaption(CDC *pDC, CXTPTaskPanelGroup *pGroup, BOOL bDraw)
Draws the caption of a specified group.
CXTPTaskPanelToolboxTheme::RefreshMetrics
void RefreshMetrics()
Refreshes the visual metrics of the task panel.


Toolkit Pro: XTPFrameThemeVisualStudio2022.h Source File

  • Source
  • CommandBars
  • Frame
XTPFrameThemeVisualStudio2022.h
Go to the documentation of this file.
1
23#if !defined(__XTPFRAMETHEMEVISUALSTUDIO2022_H__)
24# define __XTPFRAMETHEMEVISUALSTUDIO2022_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPPaintManager;
34class CXTPCommandBarsFrameHook;
35class CXTPRibbonBar;
36
37class _XTP_EXT_CLASS CXTPFrameThemeVisualStudio2022
38 : public CXTPFrameThemeOffice2013
39 , private IXTPApplicationEvents
40{
41public:
42 CXTPFrameThemeVisualStudio2022(CXTPPaintManager* pPaintManager);
43
44 virtual ~CXTPFrameThemeVisualStudio2022();
45
46public:
51 virtual void RefreshMetrics();
52
64 virtual void DrawFrameCaptionButton(CDC* pDC, CRect rc, int nId, BOOL bSelected, BOOL bPressed,
65 BOOL bActive);
66
79 virtual void DrawFrameCaptionButton(CDC* pDC, CRect rc, int nId, BOOL bSelected, BOOL bPressed,
80 BOOL bActive, CXTPRibbonBar* pRibbonBar);
81
90 virtual void SetStateColor(COLORREF clrState);
91
100 virtual COLORREF GetStateColor() const;
101
102 virtual CRect CalcFrameBorder(const CXTPCommandBarsFrameHook* pFrameHook) const;
103
104 virtual CXTPFrameShadow* CreateShadow(CWnd* pFrame);
105
106 virtual void OnShadowedFrameActiveStateChanged(BOOL bActive, CWnd* pFrame,
107 CXTPFrameShadow* pShadow);
108
109private:
110 virtual void OnAmbientPropertyChanged(CXTPApplication* pApplication,
111 XTPApplicationAmbientProperty nProperty);
112 void UpdateStateColor();
113
114 BOOL m_bAutomaticStateColor;
115
116protected:
117 COLORREF m_clrShadowColorActive;
118 COLORREF m_clrShadowColorInactive;
119};
120
122# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
123#endif // !defined(__XTPFRAMETHEMEVISUALSTUDIO2022_H__)
XTPApplicationAmbientProperty
XTPApplicationAmbientProperty
Global ambient property identifiers.
Definition XTPApplication.h:46
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPApplication
Defines a global XTP application object interface.
Definition XTPApplication.h:151
CXTPCommandBarsFrameHook
CXTPCommandBarsFrameHook is a CXTPHookManagerHookAble derived class.
Definition XTPFrameHook.h:56
CXTPFramePaintManager::OnShadowedFrameActiveStateChanged
virtual void OnShadowedFrameActiveStateChanged(BOOL bActive, CWnd *pFrame, CXTPFrameShadow *pShadow)
An implementation can override this method in order to change frame appearance when a window gets act...
CXTPFrameShadow
The class represents frame shadow object.
Definition XTPFrameShadow.h:47
CXTPPaintManager
Paint manager of the command bars.
Definition XTPPaintManager.h:199
CXTPRibbonBar
CXTPRibbonBar is a CXTPMenuBar derived class.
Definition XTPRibbonBar.h:69
IXTPApplicationEvents
Defines a callback interface for XTP application event sink.
Definition XTPApplication.h:82
IXTPApplicationEvents::OnAmbientPropertyChanged
virtual void OnAmbientPropertyChanged(CXTPApplication *pApplication, XTPApplicationAmbientProperty nProperty)
Called by framework when an ambient property is changed.
Definition XTPApplication.h:130


Toolkit Pro: XTPResourceManager.h Source File

  • Source
  • Common
XTPResourceManager.h
Go to the documentation of this file.
1
23#if !defined(__XTPRESOURCEMANAGER_H__)
24# define __XTPRESOURCEMANAGER_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
37struct XTP_RESOURCEMANAGER_LANGINFO
38{
39 WORD wLanguage;
40 UINT nCodePage;
41 LPCTSTR lpszEncoding;
42 LPCTSTR lpszCaption;
43 LPCTSTR lpszLang;
44 LPCTSTR lpszSubLang;
45 BYTE nFontCharSet;
46};
47
49# define XTP_CW2CA(lp) ((LPCSTR)CXTPResourceManager::CXTPW2A((LPCWSTR)(lp)))
50# define XTP_CA2CW(lp) ((LPCWSTR)CXTPResourceManager::CXTPA2W((LPCSTR)(lp)))
51# define XTP_CW2CAN(lp, n) ((LPCSTR)CXTPResourceManager::CXTPW2A((LPCWSTR)(lp), n))
52# define XTP_CA2CWN(lp, n) ((LPCWSTR)CXTPResourceManager::CXTPA2W((LPCSTR)(lp), n))
53
54# ifdef _UNICODE
55# define XTP_CT2CW(lp) ((LPCWSTR)(LPCTSTR)(lp))
56# define XTP_CW2CT(lp) ((LPCTSTR)(LPCWSTR)(lp))
57# define XTP_CT2CA(lp) XTP_CW2CA(lp)
58# define XTP_CA2CT(lp) XTP_CA2CW(lp)
59# define XTP_CT2CAN(lp, n) XTP_CW2CAN(lp, n)
60# define XTP_CA2CTN(lp, n) XTP_CA2CWN(lp, n)
61# else
62# define XTP_CT2CW(lp) XTP_CA2CW(lp)
63# define XTP_CW2CT(lp) XTP_CW2CA(lp)
64# define XTP_CT2CWN(lp, n) XTP_CA2CWN(lp, n)
65# define XTP_CW2CTN(lp, n) XTP_CW2CAN(lp, n)
66# define XTP_CT2CA(lp) ((LPCSTR)(LPCTSTR)(lp))
67# define XTP_CA2CT(lp) ((LPCSTR)(LPCTSTR)(lp))
68# endif
75class _XTP_EXT_CLASS CXTPResourceManager : public CNoTrackObject
76{
77public:
85 class _XTP_EXT_CLASS CManageState
86 {
87 public:
92 CManageState();
93
98 ~CManageState();
99
100 public:
105 void Undo();
106
111 void Redo();
112
113 protected:
114 bool m_bSet;
115 HMODULE m_hModOldResource;
116 };
117
118public:
123 CXTPResourceManager();
124
130 ~CXTPResourceManager();
131
132public:
142 void SetResourceFile(const CString& strResourceFile);
143
149 void SetResourceHandle(HMODULE hModRes);
150
157 HMODULE GetResourceHandle() const;
158
175 HRSRC FindResource(HMODULE& hModule, LPCTSTR lpName, LPCTSTR lpType);
176
177public:
186 virtual BOOL LoadString(CString* pString, UINT nIDResource);
187
197 virtual CString LoadString(UINT nIDResource, BOOL* pbError = NULL);
198
207 virtual BOOL LoadMenu(CMenu* lpMenu, UINT nIDResource);
208
217 virtual BOOL LoadToolBar(CToolBar* pToolBar, UINT nIDResource);
218
227 virtual BOOL LoadBitmap(CBitmap* pBitmap, UINT nIDResource);
228
237 virtual BOOL LoadBitmap(CBitmap* pBitmap, LPCTSTR lpszResource);
238
246 virtual HCURSOR LoadCursor(UINT nIDResource);
247
255 virtual LPCDLGTEMPLATE LoadDialogTemplate(UINT nIDResource);
256
269 virtual HGLOBAL LoadDialogTemplate2(LPCTSTR pszTemplate);
270
280 virtual BOOL LoadHTML(CString* pText, UINT nIDResource);
281
291 virtual BOOL LoadHTML(CString* pText, LPCTSTR pszResource);
292
303 virtual HICON LoadIcon(LPCTSTR lpszID, CSize iconSize);
304
315 virtual HICON LoadIcon(int nID, CSize iconSize);
316
326 virtual BOOL LoadXAML(CString& xaml, UINT nIDResource);
327
337 virtual BOOL LoadSVG(CString& svg, UINT nIDResource);
338
352 virtual HICON CreateIconFromResource(HMODULE hModule, LPCTSTR lpszID, CSize iconSize);
353
354public:
363 int ShowMessageBox(UINT nIDPrompt, UINT nType = MB_OK);
364
373 int ShowMessageBox(LPCTSTR lpszText, UINT nType = MB_OK);
374
382 virtual void Close();
383
384public:
392 BOOL SetResourceManager(CXTPResourceManager* pResourceManager);
393
402 virtual WORD GetResourcesLangID();
403
410 LCID GetActiveLCID();
411
420 static WORD AFX_CDECL GetResourceLanguage(HMODULE hResModule);
421
431 static BOOL AFX_CDECL IsIntResource(LPCTSTR lpName, BOOL bTryParse = FALSE);
432
441 static WORD AFX_CDECL MakeIntResource(LPCTSTR lpName);
442
443public:
444 void SetResourceLanguage(WORD wLanguage);
445
446 int LoadLocaleString(HINSTANCE hInstance, UINT nID, CString& rString) const;
447 int GetMenuLocaleString(CMenu* pMenu, UINT nIDItem, CString& rString, UINT nFlags) const;
448
449 static XTP_RESOURCEMANAGER_LANGINFO* AFX_CDECL GetLanguageInfo(UINT nLangId);
450
451 XTP_RESOURCEMANAGER_LANGINFO* GetLanguageInfo() const;
452
453 static void AFX_CDECL AssertValid(BOOL bValid);
454
455public:
462 void SetResourceFontCharset(BOOL bResourceCharset = TRUE);
463
470 BYTE GetFontCharset() const;
471
477 void SetFontCharset(BYTE nFontCharset);
478
479public:
480 class _XTP_EXT_CLASS CXTPW2A
481 {
482 public:
483 CXTPW2A(LPCWSTR lpwstr, int nLen = -1, UINT nCodePage = 0);
484 ~CXTPW2A();
485 operator LPCSTR() const;
486 int GetLength() const;
487
488 protected:
489 LPSTR m_lpsrt;
490 int m_nLen;
491 };
492
493 class _XTP_EXT_CLASS CXTPA2W
494 {
495 public:
496 CXTPA2W(LPCSTR lpstr, int nLen = -1, UINT nCodePage = 0);
497 ~CXTPA2W();
498 operator LPCWSTR() const;
499 int GetLength() const;
500
501 protected:
502 LPWSTR m_lpwsrt;
503 int m_nLen;
504 };
505
506protected:
511 virtual void UpdateResourcesLangID();
512
519 BOOL OnLoadingFailed();
520
522 _XTP_DEPRECATED_IN_FAVOR(OnLoadingFailed)
523 BOOL LoadFailed()
524 {
525 return OnLoadingFailed();
526 }
529public:
530 static CProcessLocal<CXTPResourceManager> m_managerInstance;
532protected:
533 BOOL m_bValid;
534 HMODULE m_hResourceFile;
536 XTP_RESOURCEMANAGER_LANGINFO* m_pLanguageInfo;
538 static HMODULE m_hModXTResource;
540 BOOL m_bResourceCharset;
541 BYTE m_nSystemCharset;
542
544 static BOOL CALLBACK EnumResTypeProc(HMODULE hModule, LPTSTR lpszType, LONG_PTR lParam);
545 static BOOL CALLBACK EnumResNameProc(HMODULE hModule, LPCTSTR lpszType, LPTSTR lpszName,
546 LONG_PTR lParam);
547 static BOOL CALLBACK EnumResLangProc(HMODULE hModule, LPCTSTR lpszType, LPCTSTR lpszName,
548 WORD wIDLanguage, LONG_PTR lParam);
550};
551
561AFX_INLINE HMODULE XTPGetInstanceHandle()
562{
563 return (afxCurrentInstanceHandle == NULL) ? ::GetModuleHandle(NULL) : afxCurrentInstanceHandle;
564}
565
566# ifndef _XTP_EXCLUDE_XML
567
568class CXTPPropExchangeXMLNode;
569class CXTPPropExchange;
570
575class _XTP_EXT_CLASS CXTPResourceManagerXML : public CXTPResourceManager
576{
577private:
578 struct MENUITEMTEMPLATEINFO;
579 struct MENUTEMPLATEINFO;
580 struct DLGTEMPLATEINFO;
581 struct DLGITEMTEMPLATEINFO;
582 struct DLGTEMPLATEEX;
583 struct DLGITEMTEMPLATEEX;
584
585public:
591 CXTPResourceManagerXML(LPCTSTR lpszFileName);
592
598 CXTPResourceManagerXML(CXTPPropExchangeXMLNode* pResourceRoot);
599
604 ~CXTPResourceManagerXML();
605
606public:
607 using CXTPResourceManager::LoadString;
608
618 virtual BOOL LoadString(CString* pString, UINT nIDResource);
619
629 virtual BOOL LoadMenu(CMenu* lpMenu, UINT nIDResource);
630
638 virtual LPCDLGTEMPLATE LoadDialogTemplate(UINT nIDResource);
639
647 virtual void Close();
648
649protected:
654 virtual void UpdateResourcesLangID();
655
656private:
657 BOOL CreateMenu(CMenu& menu, CXTPPropExchange* pPX);
658 void AddMenuItems(CXTPPropExchange* pPX, MENUTEMPLATEINFO* pItems);
659 LPDLGTEMPLATE CreateDialogTemplate(CXTPPropExchange* pPX);
660 LPDLGTEMPLATE CreateDialogTemplate(DLGTEMPLATEINFO& dlgTemplate);
661
662private:
663 CXTPPropExchangeXMLNode* m_pResourceRoot;
664 CMap<UINT, UINT, DLGTEMPLATE*, DLGTEMPLATE*> m_mapDialogs;
665};
666
667# endif
668
683_XTP_EXT_CLASS CXTPResourceManager* AFX_CDECL XTPResourceManager();
685AFX_INLINE WORD CXTPResourceManager::GetResourcesLangID()
686{
687 return m_pLanguageInfo->wLanguage;
688}
689AFX_INLINE LCID CXTPResourceManager::GetActiveLCID()
690{
691 return MAKELCID(GetResourcesLangID(), SORT_DEFAULT);
692}
693AFX_INLINE XTP_RESOURCEMANAGER_LANGINFO* CXTPResourceManager::GetLanguageInfo() const
694{
695 return m_pLanguageInfo;
696}
697
698AFX_INLINE CString CXTPResourceManager::LoadString(UINT nIDResource, BOOL* pbError)
699{
700 CString str;
701 BOOL bRes = LoadString(&str, nIDResource);
702 _ASSERTE(bRes);
703 if (pbError)
704 *pbError = !bRes;
705 return str;
706}
707AFX_INLINE void CXTPResourceManager::SetResourceFontCharset(BOOL bResourceCharset)
708{
709 m_bResourceCharset = bResourceCharset;
710}
711AFX_INLINE void CXTPResourceManager::SetFontCharset(BYTE nFontCharset)
712{
713 m_bResourceCharset = FALSE;
714 m_nSystemCharset = nFontCharset;
715}
726_XTP_EXT_CLASS LPCTSTR AFX_CDECL XTPGetDefaultResourceTypeFromPath(LPCTSTR lpszPath);
727
739_XTP_EXT_CLASS CString AFX_CDECL XTPFindResourceType(HMODULE hModule, LPCTSTR lpszName);
740
741# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
743#endif // !defined(__XTPRESOURCEMANAGER_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPFindResourceType
_XTP_EXT_CLASS CString AFX_CDECL XTPFindResourceType(HMODULE hModule, LPCTSTR lpszName)
Tries to find a resource type name in a provided module by looking up through all resource directorie...
XTPGetInstanceHandle
AFX_INLINE HMODULE XTPGetInstanceHandle()
Call this member to safely return an instance handle of the current application.
Definition XTPResourceManager.h:561
XTPGetDefaultResourceTypeFromPath
_XTP_EXT_CLASS LPCTSTR AFX_CDECL XTPGetDefaultResourceTypeFromPath(LPCTSTR lpszPath)
Obtains a default resource type name depending on the file extension specified by the full path to th...
XTPResourceManager
_XTP_EXT_CLASS CXTPResourceManager *AFX_CDECL XTPResourceManager()
Call this function to access CXTPResourceManager members.
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72
CXTPPropExchangeXMLNode
CXTPPropExchangeXMLNode is CXTPPropExchange derived class.
Definition XTPPropExchangeXMLNode.h:52
CXTPResourceManager::CManageState
CManageState is used internally by the toolkit to switch module states.
Definition XTPResourceManager.h:86
CXTPResourceManager::CManageState::m_hModOldResource
HMODULE m_hModOldResource
Handle to previous resource.
Definition XTPResourceManager.h:115
CXTPResourceManager::CManageState::Undo
void Undo()
Call this member function to UNDO managed state.
CXTPResourceManager::CManageState::m_bSet
bool m_bSet
true to set
Definition XTPResourceManager.h:114
CXTPResourceManager::CManageState::~CManageState
~CManageState()
Destroys a CManageState object, handles cleanup and deallocation.
CXTPResourceManager::CManageState::CManageState
CManageState()
Constructs a CManageState object.
CXTPResourceManager::CManageState::Redo
void Redo()
Call this member function to REDO managed state.
CXTPResourceManager
Standalone class used to managed toolkit resources.
Definition XTPResourceManager.h:76
CXTPResourceManager::SetResourceManager
BOOL SetResourceManager(CXTPResourceManager *pResourceManager)
Call this method to set application defined Resource manager.
CXTPResourceManager::LoadMenu
virtual BOOL LoadMenu(CMenu *lpMenu, UINT nIDResource)
Reads a Windows menu resource, identified by nID, into an existing CMenu object.
CXTPResourceManager::UpdateResourcesLangID
virtual void UpdateResourcesLangID()
This method checks the resource identifier of loaded resources.
CXTPResourceManager::CreateIconFromResource
virtual HICON CreateIconFromResource(HMODULE hModule, LPCTSTR lpszID, CSize iconSize)
The CreateIconFromResource function creates a new icon from the specified modules icon resource.
CXTPResourceManager::LoadCursor
virtual HCURSOR LoadCursor(UINT nIDResource)
Reads a Windows cursor resource, identified by nID, into an existing cursor object.
CXTPResourceManager::GetFontCharset
BYTE GetFontCharset() const
Call this member to get the default charset for a LOGFONT structure.
CXTPResourceManager::GetResourceHandle
HMODULE GetResourceHandle() const
Call this member function to return the library resource handle.
CXTPResourceManager::GetResourcesLangID
virtual WORD GetResourcesLangID()
Get current resource language ID.
CXTPResourceManager::LoadDialogTemplate2
virtual HGLOBAL LoadDialogTemplate2(LPCTSTR pszTemplate)
Reads a Windows dialog template identified by pszResource into the memory.
CXTPResourceManager::SetResourceHandle
void SetResourceHandle(HMODULE hModRes)
Call this member to set the resource handle for the calling module.
CXTPResourceManager::OnLoadingFailed
BOOL OnLoadingFailed()
This method is called to notify the developer that resource load failed.
CXTPResourceManager::m_hResourceFile
HMODULE m_hResourceFile
Resource file handle.
Definition XTPResourceManager.h:534
CXTPResourceManager::LoadHTML
virtual BOOL LoadHTML(CString *pText, UINT nIDResource)
Reads a Windows HTML resource, identified by nIDResource, into an existing CString object.
CXTPResourceManager::LoadHTML
virtual BOOL LoadHTML(CString *pText, LPCTSTR pszResource)
Reads a Windows HTML resource, identified by pszResource, into an existing CString object.
CXTPResourceManager::MakeIntResource
static WORD AFX_CDECL MakeIntResource(LPCTSTR lpName)
Makes a resource identifier from a provided INT-resource name.
CXTPResourceManager::LoadBitmap
virtual BOOL LoadBitmap(CBitmap *pBitmap, LPCTSTR lpszResource)
Reads a Windows bitmap resource, identified by nID, into an existing CBitmap object.
CXTPResourceManager::ShowMessageBox
int ShowMessageBox(LPCTSTR lpszText, UINT nType=MB_OK)
Displays a message box on the screen.
CXTPResourceManager::LoadDialogTemplate
virtual LPCDLGTEMPLATE LoadDialogTemplate(UINT nIDResource)
Reads a Windows dialog resource, identified by pszResource.
CXTPResourceManager::GetResourceLanguage
static WORD AFX_CDECL GetResourceLanguage(HMODULE hResModule)
Call this static method to determine what language has resources.
CXTPResourceManager::m_managerInstance
static CProcessLocal< CXTPResourceManager > m_managerInstance
Manager instance.
Definition XTPResourceManager.h:530
CXTPResourceManager::LoadIcon
virtual HICON LoadIcon(int nID, CSize iconSize)
The LoadIcon function loads an icon by locating its resource handle.
CXTPResourceManager::m_hModXTResource
static HMODULE m_hModXTResource
Handle to toolkit resource.
Definition XTPResourceManager.h:538
CXTPResourceManager::m_bValid
BOOL m_bValid
TRUE if Resource manager is valid.
Definition XTPResourceManager.h:533
CXTPResourceManager::LoadIcon
virtual HICON LoadIcon(LPCTSTR lpszID, CSize iconSize)
The LoadIcon function loads an icon by locating its resource handle.
CXTPResourceManager::SetResourceFile
void SetResourceFile(const CString &strResourceFile)
Call this member to set resource file to be used (dll or xml)
CXTPResourceManager::LoadXAML
virtual BOOL LoadXAML(CString &xaml, UINT nIDResource)
Reads a Windows RT_XAML resource, identified by pszResource, into an existing CString object.
CXTPResourceManager::FindResource
HRSRC FindResource(HMODULE &hModule, LPCTSTR lpName, LPCTSTR lpType)
The FindResource function tries to locate the resource in the library resources first.
CXTPResourceManager::CXTPResourceManager
CXTPResourceManager()
Constructs a CXTPResourceManager object.
CXTPResourceManager::SetFontCharset
void SetFontCharset(BYTE nFontCharset)
Call this member to set the default font charset.
CXTPResourceManager::LoadToolBar
virtual BOOL LoadToolBar(CToolBar *pToolBar, UINT nIDResource)
Call this member function to load the toolbar specified by CToolBar and nIDResource.
CXTPResourceManager::LoadString
virtual BOOL LoadString(CString *pString, UINT nIDResource)
Reads a Windows string resource, identified by nID, into an existing CString object.
CXTPResourceManager::Close
virtual void Close()
This method free used resource.
CXTPResourceManager::LoadString
virtual CString LoadString(UINT nIDResource, BOOL *pbError=NULL)
Reads a Windows string resource, identified by nID.
CXTPResourceManager::LoadBitmap
virtual BOOL LoadBitmap(CBitmap *pBitmap, UINT nIDResource)
Reads a Windows bitmap resource, identified by nID, into an existing CBitmap object.
CXTPResourceManager::ShowMessageBox
int ShowMessageBox(UINT nIDPrompt, UINT nType=MB_OK)
Displays a message box on the screen.
CXTPResourceManager::GetActiveLCID
LCID GetActiveLCID()
Get current LCID.
CXTPResourceManager::IsIntResource
static BOOL AFX_CDECL IsIntResource(LPCTSTR lpName, BOOL bTryParse=FALSE)
Checks if the resource name is an INT-resource.
CXTPResourceManager::SetResourceFontCharset
void SetResourceFontCharset(BOOL bResourceCharset=TRUE)
Call this member to use the default font charset defined in resource files.
CXTPResourceManager::~CXTPResourceManager
~CXTPResourceManager()
Destroys a CXTPResourceManagerXML object, handles cleanup and de- allocation.
CXTPResourceManager::m_pLanguageInfo
XTP_RESOURCEMANAGER_LANGINFO * m_pLanguageInfo
Resource language.
Definition XTPResourceManager.h:536
CXTPResourceManager::LoadSVG
virtual BOOL LoadSVG(CString &svg, UINT nIDResource)
Reads a Windows RT_SVG resource, identified by pszResource, into an existing CString object.
CXTPResourceManagerXML
Class used to managed toolkit resources from an XML file.
Definition XTPResourceManager.h:576
CXTPResourceManagerXML::LoadMenu
virtual BOOL LoadMenu(CMenu *lpMenu, UINT nIDResource)
Reads a Windows menu resource, specified by nID, into an existing CMenu object.
CXTPResourceManagerXML::UpdateResourcesLangID
virtual void UpdateResourcesLangID()
This method checks the resource identifier of loaded resources.
CXTPResourceManagerXML::~CXTPResourceManagerXML
~CXTPResourceManagerXML()
Destroys a CXTPResourceManagerXML object, handles cleanup and deallocation.
CXTPResourceManagerXML::CXTPResourceManagerXML
CXTPResourceManagerXML(CXTPPropExchangeXMLNode *pResourceRoot)
Constructs a CXTPResourceManagerXML object.
CXTPResourceManagerXML::LoadDialogTemplate
virtual LPCDLGTEMPLATE LoadDialogTemplate(UINT nIDResource)
Reads a Windows dialog resource, specified by pszResource.
CXTPResourceManagerXML::CXTPResourceManagerXML
CXTPResourceManagerXML(LPCTSTR lpszFileName)
Constructs a CXTPResourceManagerXML object.
CXTPResourceManagerXML::LoadString
virtual BOOL LoadString(CString *pString, UINT nIDResource)
Reads a Windows string resource, specified by nID, into an existing CString object.
CXTPResourceManagerXML::Close
virtual void Close()
This method frees used resources.
XTP_RESOURCEMANAGER_LANGINFO
Standalone structure used to manage Language Info.
Definition XTPResourceManager.h:38
XTP_RESOURCEMANAGER_LANGINFO::nFontCharSet
BYTE nFontCharSet
FontCharSet.
Definition XTPResourceManager.h:45
XTP_RESOURCEMANAGER_LANGINFO::lpszLang
LPCTSTR lpszLang
Lang.
Definition XTPResourceManager.h:43
XTP_RESOURCEMANAGER_LANGINFO::wLanguage
WORD wLanguage
Language.
Definition XTPResourceManager.h:39
XTP_RESOURCEMANAGER_LANGINFO::lpszCaption
LPCTSTR lpszCaption
Caption.
Definition XTPResourceManager.h:42
XTP_RESOURCEMANAGER_LANGINFO::nCodePage
UINT nCodePage
CodePage.
Definition XTPResourceManager.h:40
XTP_RESOURCEMANAGER_LANGINFO::lpszEncoding
LPCTSTR lpszEncoding
Encoding.
Definition XTPResourceManager.h:41
XTP_RESOURCEMANAGER_LANGINFO::lpszSubLang
LPCTSTR lpszSubLang
SubLang.
Definition XTPResourceManager.h:44


Toolkit Pro: Member List

CXTPDockingPaneTabThemeNativeWindows10 Member List

This is the complete list of members for CXTPDockingPaneTabThemeNativeWindows10, including all inherited members.

AdjustClientRect(CXTPTabManager *pTabManager, CRect &rcClient) | CXTPTabPaintManagerTheme | virtual
CXTPDockingPaneTabTheme2012() | CXTPDockingPaneTabTheme2012 |
CXTPDockingPaneTabThemeNativeWindows10() | CXTPDockingPaneTabThemeNativeWindows10 |
CXTPTabPaintManagerTheme() | CXTPTabPaintManagerTheme |
CXTPTabThemeFlat() | CXTPTabThemeFlat | inline
DrawSingleButton(CDC *pDC, CXTPTabManagerItem *pItem) | CXTPDockingPaneTabThemeNativeWindows10 | virtual
DrawTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl) | CXTPTabPaintManagerTheme | virtual
DrawText(CDC *pDC, CXTPTabManager *pManager, const CString &str, LPRECT lpRect, UINT nFormat) | CXTPDockingPaneTabTheme2012 | virtual
DrawWorkspacePart(CDC *pDC, LPRECT lpRect, XTPTabWorkspacePart workspacePart) | CXTPTabPaintManagerTheme | virtual
FillButton(CDC *pDC, CXTPTabManagerItem *pItem, LPPOINT pts, int nCount, XTPTabPosition tabPosition, BOOL bAbsolute=FALSE) | CXTPTabPaintManagerTheme |
FillTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl) | CXTPTabThemeFlat | virtual
GetButtonDrawRect(const CXTPTabManagerItem *pItem) | CXTPTabPaintManagerTheme | virtual
GetButtonHeight(const CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetButtonLength(CDC *pDC, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerTheme | virtual
GetClientMargin() | CXTPTabPaintManagerTheme | virtual
GetClientRect(CRect rcControl, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetColorSet() const | CXTPTabPaintManagerTheme |
GetDefaultColorSet() | CXTPTabThemeFlat | inlinevirtual
GetHeaderClipBox(CDC *pDC, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetHeaderHeight(CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme |
GetHeaderMargin() | CXTPTabPaintManagerTheme | virtual
GetHeaderRect(CRect rcControl, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetSupportedColorSets() | CXTPTabPaintManagerTheme | inlinevirtual
m_bButtonsReverseZOrder | CXTPTabPaintManagerTheme | protected
m_nButtonHeight | CXTPTabPaintManagerTheme | protected
m_nRowMargin | CXTPTabPaintManagerTheme |
m_pPaintManager | CXTPTabPaintManagerTheme | protected
m_rcHeaderMargin | CXTPTabPaintManagerTheme |
RefreshMetrics() | CXTPDockingPaneTabTheme2012 | virtual
RepositionTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcClient) | CXTPTabPaintManagerTheme | virtual
~CXTPTabPaintManagerTheme() | CXTPTabPaintManagerTheme | virtual


Toolkit Pro: XTPChartObjectFactory.h Source File

  • Source
  • Chart
XTPChartObjectFactory.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTOBJECTFACTORY_H__)
24# define __XTPCHARTOBJECTFACTORY_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartDrawingObjectFactory;
34
36// CXTPChartObjectFactory
37
38class _XTP_EXT_CLASS CXTPChartObjectFactory : public CXTPSingleton<CXTPChartObjectFactory>
39{
40 friend class CXTPSingleton<CXTPChartObjectFactory>;
41
42 CXTPChartObjectFactory();
43
44public:
45 CXTPChartDrawingObjectFactory* Get2dDrawingObjectFactory();
46 CXTPChartDrawingObjectFactory* Get3dDrawingObjectFactory();
47};
48
49_XTP_EXT_CLASS CXTPChartObjectFactory* AFX_CDECL XTPChartObjectFactory();
51# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
52#endif //#if !defined(__XTPCHARTOBJECTFACTORY_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartDrawingObjectFactory
Provides a set of factory methods for creating drawing device commands and a base class interface for...
Definition XTPChartDrawingObjectFactory.h:55
CXTPSingleton
Implements Singleton design pattern.
Definition XTPSingleton.h:215


Toolkit Pro: XTPShortcutBarVisualStudio2019Theme.h Source File

  • Source
  • ShortcutBar
  • Themes
XTPShortcutBarVisualStudio2019Theme.h
Go to the documentation of this file.
1
23#if !defined(__XTPSHORTCUTBARVISUALSTUDIO2019THEME_H__)
24# define __XTPSHORTCUTBARVISUALSTUDIO2019THEME_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPShortcutBarVisualStudio2019Theme : public CXTPShortcutBarOffice2013Theme
39{
40public:
45 CXTPShortcutBarVisualStudio2019Theme();
46
52 virtual ~CXTPShortcutBarVisualStudio2019Theme();
53
61 virtual void RefreshMetrics();
62
84 virtual int DrawPaneItemCaption(CDC* pDC, CXTPShortcutBarPaneItem* pItem, BOOL bDraw);
85
86 virtual void DrawPaneCaptionMinimizeButton(CDC* pDC, CXTPShortcutBarPane* pPane);
87
94 virtual void FillShortcutItemEntry(CDC* pDC, CXTPShortcutBarItem* pItem);
95
102 virtual void FillNavigationItemEntry(CDC* pDC, CXTPShortcutBarItem* pItem);
103
104 void DrawHiliteBorder(CDC* pDC, CRect rc);
105
106protected:
107 BOOL m_bHiliteBorders;
108 CXTPPaintManagerColor m_clrBorderHilite;
109 CXTPPaintManagerColor m_clrBackHiliteSelected;
110};
111
112# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
114#endif // !defined(__XTPSHORTCUTBARVISUALSTUDIO2019THEME_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPPaintManagerColor
The CXTPPaintManagerColor class is used to manage COLORREF values for determining default and applica...
Definition XTPColorManager.h:117
CXTPShortcutBarItem
CXTPShortcutBarItem is a base class that represents an item for a shortcut bar control.
Definition XTPShortcutBar.h:181
CXTPShortcutBarOffice2013Theme
CXTPShortcutBarOffice2013Theme is a CXTPShortcutBarResourceTheme derived class that represents an Off...
Definition XTPShortcutBarOffice2013Theme.h:39
CXTPShortcutBarPane
CXTPShortcutBarPane is a CWnd derived class used as a client area for a shortcut bar control.
Definition XTPShortcutBarPane.h:158
CXTPShortcutBarPaneItem
CXTPShortcutBarPaneItem is a base class that represents an item for a shortcut bar pane.
Definition XTPShortcutBarPane.h:42
CXTPShortcutBarVisualStudio2019Theme
CXTPShortcutBarVisualStudio2019Theme is a CXTPShortcutBarOffice2013Theme derived class that represent...
Definition XTPShortcutBarVisualStudio2019Theme.h:39
CXTPShortcutBarVisualStudio2019Theme::DrawPaneItemCaption
virtual int DrawPaneItemCaption(CDC *pDC, CXTPShortcutBarPaneItem *pItem, BOOL bDraw)
Draws the caption for a specified shortcut bar pane item.
CXTPShortcutBarVisualStudio2019Theme::m_bHiliteBorders
BOOL m_bHiliteBorders
TRUE to draw borders around highlighted items.
Definition XTPShortcutBarVisualStudio2019Theme.h:107
CXTPShortcutBarVisualStudio2019Theme::m_clrBackHiliteSelected
CXTPPaintManagerColor m_clrBackHiliteSelected
Selected highlighted background color.
Definition XTPShortcutBarVisualStudio2019Theme.h:109
CXTPShortcutBarVisualStudio2019Theme::CXTPShortcutBarVisualStudio2019Theme
CXTPShortcutBarVisualStudio2019Theme()
Constructs a CXTPShortcutBarVisualStudio2019Theme object.
CXTPShortcutBarVisualStudio2019Theme::FillShortcutItemEntry
virtual void FillShortcutItemEntry(CDC *pDC, CXTPShortcutBarItem *pItem)
Fills a specified item for the shortcut bar control.
CXTPShortcutBarVisualStudio2019Theme::m_clrBorderHilite
CXTPPaintManagerColor m_clrBorderHilite
Highlighted border color.
Definition XTPShortcutBarVisualStudio2019Theme.h:108
CXTPShortcutBarVisualStudio2019Theme::RefreshMetrics
virtual void RefreshMetrics()
Refreshes the visual metrics of the shortcut bar paint manager.
CXTPShortcutBarVisualStudio2019Theme::~CXTPShortcutBarVisualStudio2019Theme
virtual ~CXTPShortcutBarVisualStudio2019Theme()
Destroys a CXTPShortcutBarVisualStudio2019Theme object, handles cleanup and deallocation.
CXTPShortcutBarVisualStudio2019Theme::FillNavigationItemEntry
virtual void FillNavigationItemEntry(CDC *pDC, CXTPShortcutBarItem *pItem)
Fills a specified navigation item for the minimized shortcut bar control.


Toolkit Pro: XTPSliderThemeVisualStudio2019.h Source File

  • Source
  • CommandBars
  • Slider
XTPSliderThemeVisualStudio2019.h
Go to the documentation of this file.
1
23#if !defined(__XTPSLIDERTHEMEVISUALSTUDIO2019_H__)
24# define __XTPSLIDERTHEMEVISUALSTUDIO2019_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class _XTP_EXT_CLASS CXTPSliderThemeVisualStudio2019 : public CXTPSliderThemeOffice2013
34{
35public:
36 CXTPSliderThemeVisualStudio2019(CXTPPaintManager* pPaintManager);
37};
38
40# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
41#endif // !defined(__XTPSLIDERTHEMEVISUALSTUDIO2019_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPPaintManager
Paint manager of the command bars.
Definition XTPPaintManager.h:199


Toolkit Pro: XTPSliderThemeNativeWindows10.h Source File

  • Source
  • CommandBars
  • Slider
XTPSliderThemeNativeWindows10.h
Go to the documentation of this file.
1
23#if !defined(__XTPSLIDERTHEMENATIVEWINDOWS10_H__)
24# define __XTPSLIDERTHEMENATIVEWINDOWS10_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class _XTP_EXT_CLASS CXTPSliderThemeNativeWindows10 : public CXTPSliderThemeOffice2013
34{
35public:
36 CXTPSliderThemeNativeWindows10(CXTPPaintManager* pPaintManager);
37};
38
40# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
41#endif // !defined(__XTPSLIDERTHEMENATIVEWINDOWS10_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPPaintManager
Paint manager of the command bars.
Definition XTPPaintManager.h:199


Toolkit Pro: Member List

CXTPChartElementAppearance Member List

This is the complete list of members for CXTPChartElementAppearance, including all inherited members.

ApplyToDeviceContext(CXTPChartDeviceContext *pDC) | CXTPChartElementAppearance | virtual
CXTPChartElement() | CXTPChartElement |
CXTPChartElementAppearance(CXTPChartElement *pOwner) | CXTPChartElementAppearance |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
DoPropExchange(CXTPPropExchange *pPX) | CXTPChartElement | virtual
GetAppearance() const | CXTPChartElement |
GetContent() const | CXTPChartElement |
GetOwner() const | CXTPChartElement |
Is3D() const | CXTPChartObject |
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartElement | virtual
Release() | CXTPChartElement | virtual
~CXTPChartElement() | CXTPChartElement | virtual
~CXTPChartElementAppearance() | CXTPChartElementAppearance | virtual


Toolkit Pro: Member List

CXTPChartFunnelSeriesStyle Member List

This is the complete list of members for CXTPChartFunnelSeriesStyle, including all inherited members.

ApplyTo(CXTPChartDeviceCommand *pCommand) | CXTPChartSeriesStyle | virtual
CorrectAxisSideMargins(CXTPChartAxis *pAxis, double nMinValue, double nMaxValue, double &nCorrection) | CXTPChartSeriesStyle | virtual
CreateDiagram() | CXTPChartFunnelSeriesStyle | protectedvirtual
CreateView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView) | CXTPChartFunnelSeriesStyle | protectedvirtual
CXTPChartElement() | CXTPChartElement |
CXTPChartFunnelSeriesStyle() | CXTPChartFunnelSeriesStyle |
CXTPChartFunnelSeriesStyleBase() | CXTPChartFunnelSeriesStyleBase |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartSeriesStyle() | CXTPChartSeriesStyle |
DoPropExchange(CXTPPropExchange *pPX) | CXTPChartFunnelSeriesStyleBase | virtual
Enable3dEdgeSmoothing(BOOL bEnable=TRUE) | CXTPChartSeriesStyle | virtual
Get3dRotation() const | CXTPChartSeriesStyle | virtual
GetAppearance() const | CXTPChartElement |
GetBorder() const | CXTPChartFunnelSeriesStyleBase |
GetColor() const | CXTPChartSeriesStyle | virtual
GetContent() const | CXTPChartElement |
GetErrorBar() const | CXTPChartSeriesStyle | virtual
GetFillStyle() const | CXTPChartFunnelSeriesStyleBase |
GetHeightToWidthRatio() const | CXTPChartFunnelSeriesStyleBase |
GetLabel() const | CXTPChartSeriesStyle | virtual
GetOwner() const | CXTPChartElement |
GetPointDistance() const | CXTPChartFunnelSeriesStyleBase |
GetSeriesPointValueIndex() const | CXTPChartSeriesStyle | virtual
GetStyleAppearance() const | CXTPChartSeriesStyle | virtual
GetTransparency() const | CXTPChartSeriesStyle | virtual
Is3D() const | CXTPChartObject |
Is3dEdgeSmoothingEnabled() const | CXTPChartSeriesStyle | virtual
IsColorEach() const | CXTPChartSeriesStyle | virtual
IsEqualHeight() const | CXTPChartFunnelSeriesStyleBase |
IsStyleDiagram(CXTPChartDiagram *pDiagram) const | CXTPChartFunnelSeriesStyle | protectedvirtual
m_bColorEach | CXTPChartSeriesStyle | protected
m_bSmooth3dEdges | CXTPChartSeriesStyle | protected
m_clrColor | CXTPChartSeriesStyle | protected
m_nTransparency | CXTPChartSeriesStyle | protected
m_pErrorBar | CXTPChartSeriesStyle | protected
m_pLabel | CXTPChartSeriesStyle | protected
m_Rotation3d | CXTPChartSeriesStyle | protected
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartElement | virtual
Release() | CXTPChartElement | virtual
Set3dRotation(const CXTPChart3dRotation &rotation) | CXTPChartSeriesStyle | virtual
Set3dRotation(double dYaw, double dPitch, double dRoll) | CXTPChartSeriesStyle | virtual
SetColor(CXTPChartColor clr) | CXTPChartSeriesStyle | virtual
SetColorEach(BOOL bColorEach) | CXTPChartSeriesStyle | virtual
SetEqualHeight(BOOL bEqualHeight) | CXTPChartFunnelSeriesStyleBase |
SetErrorBar(CXTPChartErrorBar *pErrorBar) | CXTPChartSeriesStyle | virtual
SetHeightToWidthRatio(double dRatio) | CXTPChartFunnelSeriesStyleBase |
SetLabel(CXTPChartSeriesLabel *pLabel) | CXTPChartSeriesStyle | virtual
SetPointDistance(int nPointDistance) | CXTPChartFunnelSeriesStyleBase |
SetTransparency(int nTransparency) | CXTPChartSeriesStyle | virtual
~CXTPChartElement() | CXTPChartElement | virtual
~CXTPChartFunnelSeriesStyleBase() | CXTPChartFunnelSeriesStyleBase | virtual
~CXTPChartSeriesStyle() | CXTPChartSeriesStyle | virtual


Toolkit Pro: XTPDockingPanePaintManager.h Source File

  • Source
  • DockingPane
XTPDockingPanePaintManager.h
Go to the documentation of this file.
1
23#if !defined(__XTPDOCKINGPANEPAINTMANAGER_H__)
24# define __XTPDOCKINGPANEPAINTMANAGER_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPTabPaintManager;
34class CXTPDockingPane;
35class CXTPDockingPaneBase;
36class CXTPDockingPaneTabbedContainer;
37class CXTPDockingPaneMiniWnd;
38class CXTPDockingPaneSplitterWnd;
39class CXTPDockingPaneCaptionButton;
40class CXTPDockingPaneCaptionButtons;
41class CXTPDockingPaneSidePanel;
42class CXTPWinThemeWrapper;
43
50class _XTP_EXT_CLASS CXTPDockingPaneTabPaintManager : public CXTPTabPaintManager
51{
52public:
65 virtual CXTPTabPaintManagerColorSet* SetColor(XTPTabColorStyle tabColor);
66
81 virtual CXTPTabPaintManagerTheme* SetAppearance(XTPTabAppearanceStyle tabAppearance);
82};
83
90class _XTP_EXT_CLASS CXTPDockingPanePanelPaintManager : public CXTPTabPaintManager
91{
92public:
105 virtual CXTPTabPaintManagerColorSet* SetColor(XTPTabColorStyle tabColor);
106
121 virtual CXTPTabPaintManagerTheme* SetAppearance(XTPTabAppearanceStyle tabAppearance);
122};
123
132enum XTPDockingPanePinState
133{
134 xtpPanePinVisible = 1,
135 xtpPanePinPushed = 2
136};
137
150enum XTPDockingPaneSplitterStyle
151{
152 xtpPaneSplitterFlat = 0,
153 xtpPaneSplitter3D = 1,
154 xtpPaneSplitterSoft3D = 2,
155 xtpPaneSplitterGradient = 4,
156 xtpPaneSplitterGradientVert = 8,
157 xtpPaneSplitterGripperOfficeXP = 0x100,
158 xtpPaneSplitterGripperOffice2003 = 0x200
159};
160
170enum XTPDockingPaneCaptionButtonStyle
171{
172 xtpPaneCaptionButtonDefault,
173 xtpPaneCaptionButtonOffice,
174 xtpPaneCaptionButtonOffice2003,
175 xtpPaneCaptionButtonThemedExplorerBar,
176 xtpPaneCaptionButtonThemedButton,
177 xtpPaneCaptionButtonThemedToolBar,
178 xtpPaneCaptionButtonThemedToolWindow,
179};
180
181_XTP_EXT_CLASS void AFX_CDECL XTPDeflateRectDirection(CRect& rc, int left, int top, int right,
182 int bottom, BOOL bVertical);
183
184_XTP_EXT_CLASS int AFX_CDECL XTPGetRectDirectionHeight(const CRect& rc, BOOL bVertical);
185
186_XTP_EXT_CLASS void AFX_CDECL
187 XTPFillFramePartRect(CDC* pDC, CRect rc, CWnd* pWnd, CWnd* pParentFrame,
188 const CXTPPaintManagerColorGradient& clrHeaderFace, BOOL bHoriz);
189
195class _XTP_EXT_CLASS CXTPDockingPanePaintManager : public CXTPCmdTarget
196{
197protected:
202 CXTPDockingPanePaintManager();
203
209 virtual ~CXTPDockingPanePaintManager();
210
211public:
219 virtual void DrawPane(CDC* pDC, CXTPDockingPaneTabbedContainer* pPane, CRect rc);
220
228 virtual void DrawSidePanel(CDC* pDC, CXTPDockingPaneSidePanel* pPane, CRect rc);
229
237 virtual CRect GetPaneCaptionRect(const CXTPDockingPaneSidePanel* pPane);
238
246 virtual void DrawFloatingFrame(CDC* pDC, CXTPDockingPaneMiniWnd* pPane, CRect rc);
247
254 virtual void DrawSplitter(CDC* pDC, CXTPDockingPaneSplitterWnd* pSplitter);
255
263 virtual void DrawCaption(CDC* pDC, CXTPDockingPaneTabbedContainer* pPane, CRect rc) = 0;
264
276 virtual void DrawCaptionButtons(CDC* pDC, CXTPDockingPaneCaptionButtons* pButtons,
277 CRect& rcCaption, COLORREF clr, int nButtonSize, int nButtonGap,
278 BOOL bVertical = FALSE);
279
287 virtual void DrawCaptionButton(CDC* pDC, CXTPDockingPaneCaptionButton* pButton,
288 COLORREF clrButton);
289
294 virtual void RefreshMetrics();
295
303 virtual void AdjustClientRect(CXTPDockingPaneSidePanel* pPane, CRect& rect);
304
313 virtual void AdjustClientRect(CXTPDockingPaneTabbedContainer* pPane, CRect& rect, BOOL bApply);
314
323 virtual void AdjustCaptionRect(const CXTPDockingPaneSidePanel* pPane, CRect& rc);
324
333 virtual void AdjustCaptionRect(const CXTPDockingPaneTabbedContainer* pPane, CRect& rc);
334
341 virtual void GetCaptionRect(const CXTPDockingPaneTabbedContainer* pPane, CRect& rc);
342
350 virtual CRect GetCaptionGripperRect(const CXTPDockingPaneTabbedContainer* pPane);
351
352public:
363 void Line(CDC* pDC, int x0, int y0, int x1, int y1, int nPen);
373 void Line(CDC* pDC, int x0, int y0, int x1, int y1);
374
386 int DrawCaptionText(CDC* pDC, const CString& strTitle, CRect rc, BOOL bVertical,
387 BOOL bCalcWidth = FALSE);
388
397 void Pixel(CDC* pDC, int xPos, int yPos, int nPen);
398
407 void Rectangle(CDC* pDC, CRect rc, int nPenEntry, int nPenBorder);
408
414 void UseOfficeFont(BOOL bUseOfficeFont);
415
422 void SetCaptionFontIndirect(LOGFONT* pLogFont, BOOL bUseStandardFont = FALSE);
423
434 CXTPTabPaintManager* SetTabPaintManager(CXTPTabPaintManager* pManager);
435
446 CXTPTabPaintManager* SetPanelPaintManager(CXTPTabPaintManager* pManager);
447
457 CXTPTabPaintManager* GetTabPaintManager() const;
458
468 CXTPTabPaintManager* GetPanelPaintManager() const;
469
562 COLORREF GetXtremeColor(UINT nIndex);
563
574 void SetColors(int cElements, CONST INT* lpaElements, CONST COLORREF* lpaRgbValues);
575
584 int GetCaptionHeight() const;
585
594 int GetTabsHeight() const;
595
612 void SetSplitterStyle(DWORD dwStyle);
613
622 DWORD GetSplitterStyle() const;
623
642 void SetCaptionButtonStyle(XTPDockingPaneCaptionButtonStyle nStyle);
643
652 XTPDockingPaneCaptionButtonStyle GetCaptionButtonStyle() const;
653
668 XTPCurrentSystemTheme GetCurrentSystemTheme() const;
669
682 void SetLunaTheme(XTPCurrentSystemTheme systemTheme);
683
693 virtual void DrawAutoHidePanel(CDC* pDC, CRect rc, XTPDockingPaneDirection direction);
694
708 void SetCustomTitleBrushes(HBRUSH hbrActiveTitleHorz, HBRUSH hbrInactiveTitleHorz = NULL,
709 HBRUSH hbrActiveTitleVert = NULL, HBRUSH hbrInactiveTitleVert = NULL,
710 BOOL bDestroyOnCleanup = FALSE);
711
722 HBRUSH GetCustomTitleBrush(BOOL bActive, BOOL bVertical) const;
723
724protected:
733 virtual void DrawCaptionButtonEntry(CDC* pDC, CXTPDockingPaneCaptionButton* pButton,
734 COLORREF clrButton, CSize szOffset);
743 virtual void DrawCaptionButtonEntry(CDC* pDC, CXTPDockingPaneCaptionButton* pButton, CPoint pt,
744 COLORREF clrButton);
745
757 void ClipAndAddEllipsisIfNeeded(CDC* pDC, CString& strTitle, int nCaptionWidth) const;
758
760 void DrawCaptionIcon(CDC* pDC, CXTPDockingPaneBase* pPane, CRect& rcCaption, BOOL bVertical);
761
762public:
763 static CXTPDockingPane* AFX_CDECL GetSelectedPane(CXTPDockingPaneBase* pPane);
764 BOOL IsCaptionEnabled(CXTPDockingPaneBase* pPane);
766public:
767 BOOL m_bUseBoldCaptionFont;
768 BOOL m_bHighlightActiveCaption;
769 int m_nSplitterSize;
770 BOOL m_bShowCaption;
771 BOOL m_bDrawSingleTab;
772 BOOL m_bDrawCaptionIcon;
773 BOOL m_bAutoHidePanelHighlightSelected;
774
775 int m_nSplitterIndent;
777 CXTPPaintManagerColor m_clrBackground;
778 CXTPPaintManagerColor m_clrSplitterGripper;
779 CXTPPaintManagerColor m_clrSplitter;
780 CXTPPaintManagerColorGradient m_clrSplitterGradient;
781 CXTPPaintManagerColorGradient m_clrNormalCaption;
782 CXTPPaintManagerColorGradient m_clrActiveCaption;
783 CXTPPaintManagerColor m_clrNormalCaptionText;
785 CXTPPaintManagerColor m_clrActiveCaptionText;
786 CXTPPaintManagerColor m_clrDisabledCaptionText;
788protected:
789 XTPDockingPaneCaptionButtonStyle m_nCaptionButtonStyle;
790 DWORD m_dwSplitterStyle;
791 int m_nTitleHeight;
792 int m_nCaptionFontGap;
793 int m_nTabsHeight;
795 CXTPFont m_xtpFontTitle;
796 CXTPFont m_xtpFontTitleVertical;
798 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CFont, m_fntTitle, m_xtpFontTitle, GetTitleFontHandle);
799 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CFont, m_fntTitleVertical, m_xtpFontTitleVertical,
800 GetVerticalTitleFontHandle);
801
802 BOOL m_bUseOfficeFont;
803 BOOL m_bUseStandardFont;
804 BOOL m_bDestroyCustomTitleBrushes;
806 HBRUSH m_hbrActiveTitleHorz;
807 HBRUSH m_hbrInactiveTitleHorz;
808 HBRUSH m_hbrActiveTitleVert;
809 HBRUSH m_hbrInactiveTitleVert;
811protected:
812 CXTPTabPaintManager* m_pTabPaintManager;
814 CXTPTabPaintManager* m_pPanelPaintManager;
817 COLORREF m_arrColor[XPCOLOR_LAST + 1];
818 XTPDockingPanePaintTheme m_themeCurrent;
819 CString m_strOfficeFont;
820 CRect m_rcCaptionMargin;
821 XTPCurrentSystemTheme m_systemTheme;
823 CXTPWinThemeWrapper* m_themeToolbar;
824 CXTPWinThemeWrapper* m_themeExplorer;
825 CXTPWinThemeWrapper* m_themeButton;
826 CXTPWinThemeWrapper* m_themeWindow;
827 CXTPWinThemeWrapper* m_themeRebar;
829 BOOL m_bLunaTheme;
831private:
832 friend class CXTPDockingPaneManager;
833
834# ifdef _XTP_ACTIVEX
836 DECLARE_DISPATCH_MAP()
837 DECLARE_INTERFACE_MAP()
838
839 DECLARE_OLETYPELIB_EX(CXTPDockingPanePaintManager);
840
841 LPFONTDISP OleGetFont();
842 void OleSetFont(LPFONTDISP pFontDisp);
843
844 BOOL OleGetUseCustomTitleColors();
845 void OleSetUseCustomTitleColors(BOOL fUse);
846
847 void OleSetCustomTitleColors(OLE_COLOR clrActiveHorz, OLE_COLOR clrInactiveHorz,
848 OLE_COLOR clrActiveVert, OLE_COLOR clrInactiveVert);
849 OLE_COLOR OleGetCustomTitleColor(BOOL fActive, BOOL fVert);
850
851 COLORREF OleGetSplitterColor();
852 void OleSetSplitterColor(OLE_COLOR clr);
853
854 void OleRefreshMetrics();
855
856 BOOL m_bAxUseCustomTitleColors;
857
858 OLE_COLOR m_clrAxTitleActiveHorz;
859 OLE_COLOR m_clrAxTitleInactiveHorz;
860 OLE_COLOR m_clrAxTitleActiveVert;
861 OLE_COLOR m_clrAxTitleInactiveVert;
862
864# endif
865};
866
867AFX_INLINE int CXTPDockingPanePaintManager::GetCaptionHeight() const
868{
869 return m_nTitleHeight;
870}
871AFX_INLINE int CXTPDockingPanePaintManager::GetTabsHeight() const
872{
873 return m_nTabsHeight;
874}
875AFX_INLINE CXTPTabPaintManager* CXTPDockingPanePaintManager::GetTabPaintManager() const
876{
877 return m_pTabPaintManager;
878}
879AFX_INLINE CXTPTabPaintManager* CXTPDockingPanePaintManager::GetPanelPaintManager() const
880{
881 return m_pPanelPaintManager;
882}
883AFX_INLINE void CXTPDockingPanePaintManager::DrawFloatingFrame(CDC* /*pDC*/,
884 CXTPDockingPaneMiniWnd* /*pPane*/,
885 CRect /*rc*/)
886{
887}
888AFX_INLINE void CXTPDockingPanePaintManager::DrawSidePanel(CDC* /*pDC*/,
889 CXTPDockingPaneSidePanel* /*pPane*/,
890 CRect /*rc*/)
891{
892}
893AFX_INLINE void
894 CXTPDockingPanePaintManager::SetCaptionButtonStyle(XTPDockingPaneCaptionButtonStyle nStyle)
895{
896 m_nCaptionButtonStyle = nStyle;
897}
898AFX_INLINE XTPDockingPaneCaptionButtonStyle
899 CXTPDockingPanePaintManager::GetCaptionButtonStyle() const
900{
901 return m_nCaptionButtonStyle;
902}
904# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
905#endif // #if !defined(__XTPDOCKINGPANEPAINTMANAGER_H__)
XPCOLOR_LAST
const int XPCOLOR_LAST
Definition XTPColorManager.h:109
XTPCurrentSystemTheme
XTPCurrentSystemTheme
Enumeration used to determine the current Windows XP theme in use.
Definition XTPColorManager.h:45
XTPDisableNoisyWarnings.h
XTPDockingPaneDirection
XTPDockingPaneDirection
Docking direction enumeration.
Definition XTPDockingPaneDefines.h:51
XTPDockingPanePaintTheme
XTPDockingPanePaintTheme
Visual theme enumeration.
Definition XTPDockingPaneDefines.h:100
XTPDockingPaneCaptionButtonStyle
XTPDockingPaneCaptionButtonStyle
Enumeration of the caption button styles.
Definition XTPDockingPanePaintManager.h:171
xtpPaneCaptionButtonThemedButton
@ xtpPaneCaptionButtonThemedButton
Windows XP Button style.
Definition XTPDockingPanePaintManager.h:176
xtpPaneCaptionButtonOffice
@ xtpPaneCaptionButtonOffice
Office XP caption button style.
Definition XTPDockingPanePaintManager.h:173
xtpPaneCaptionButtonThemedToolWindow
@ xtpPaneCaptionButtonThemedToolWindow
Window XP Tool Window style.
Definition XTPDockingPanePaintManager.h:178
xtpPaneCaptionButtonThemedToolBar
@ xtpPaneCaptionButtonThemedToolBar
Windows XP Toolbar style.
Definition XTPDockingPanePaintManager.h:177
xtpPaneCaptionButtonOffice2003
@ xtpPaneCaptionButtonOffice2003
Office 2003 caption button style.
Definition XTPDockingPanePaintManager.h:174
xtpPaneCaptionButtonThemedExplorerBar
@ xtpPaneCaptionButtonThemedExplorerBar
Explorer button style.
Definition XTPDockingPanePaintManager.h:175
xtpPaneCaptionButtonDefault
@ xtpPaneCaptionButtonDefault
Default caption button style.
Definition XTPDockingPanePaintManager.h:172
XTPDockingPanePinState
XTPDockingPanePinState
Enumeration of the pin button state.
Definition XTPDockingPanePaintManager.h:133
xtpPanePinPushed
@ xtpPanePinPushed
Pin button is pushed.
Definition XTPDockingPanePaintManager.h:135
xtpPanePinVisible
@ xtpPanePinVisible
Pin button is visible.
Definition XTPDockingPanePaintManager.h:134
XTPDockingPaneSplitterStyle
XTPDockingPaneSplitterStyle
Enumeration of the splitter styles.
Definition XTPDockingPanePaintManager.h:151
xtpPaneSplitterGripperOffice2003
@ xtpPaneSplitterGripperOffice2003
Splitter has an Office 2003 gripper.
Definition XTPDockingPanePaintManager.h:158
xtpPaneSplitter3D
@ xtpPaneSplitter3D
3D splitter style.
Definition XTPDockingPanePaintManager.h:153
xtpPaneSplitterFlat
@ xtpPaneSplitterFlat
Flat splitter style.
Definition XTPDockingPanePaintManager.h:152
xtpPaneSplitterGradient
@ xtpPaneSplitterGradient
Gradient splitter style.
Definition XTPDockingPanePaintManager.h:155
xtpPaneSplitterGradientVert
@ xtpPaneSplitterGradientVert
Gradient splitter style.
Definition XTPDockingPanePaintManager.h:156
xtpPaneSplitterSoft3D
@ xtpPaneSplitterSoft3D
Soft splitter style.
Definition XTPDockingPanePaintManager.h:154
xtpPaneSplitterGripperOfficeXP
@ xtpPaneSplitterGripperOfficeXP
Splitter has an Office XP gripper.
Definition XTPDockingPanePaintManager.h:157
XTPEnableNoisyWarnings.h
XTPTabAppearanceStyle
XTPTabAppearanceStyle
XTPTabAppearanceStyle is an enumeration used to set the appearance of tabs.
Definition XTPTabManagerDefines.h:84
XTPTabColorStyle
XTPTabColorStyle
XTPTabColorStyle is an enumeration used to set the color style of tabs.
Definition XTPTabManagerDefines.h:139
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPDockingPaneBase
CXTPDockingPaneBase is a standalone class.
Definition XTPDockingPaneBase.h:69
CXTPDockingPaneCaptionButton
CXTPDockingPaneCaptionButton is a standalone internal class.
Definition XTPDockingPaneCaptionButton.h:38
CXTPDockingPaneCaptionButtons
CXTPDockingPaneCaptionButtons is a CArray derived class used to manipulate Caption Buttons.
Definition XTPDockingPaneBase.h:49
CXTPDockingPane
CXTPDockingPane is a CXTPDockingPaneBase derived class.
Definition XTPDockingPane.h:44
CXTPDockingPaneManager
CXTPDockingPaneManager is a CWnd derived class.
Definition XTPDockingPaneManager.h:58
CXTPDockingPaneMiniWnd
CXTPDockingPaneMiniWnd is a multiple inheritance class derived from CMiniFrameWnd and CXTPDockingPane...
Definition XTPDockingPaneMiniWnd.h:42
CXTPDockingPanePaintManager
CXTPDockingPanePaintManager is a standalone class.
Definition XTPDockingPanePaintManager.h:196
CXTPDockingPanePaintManager::GetCustomTitleBrush
HBRUSH GetCustomTitleBrush(BOOL bActive, BOOL bVertical) const
Obtains the custom title brush.
CXTPDockingPanePaintManager::GetCaptionHeight
int GetCaptionHeight() const
Call this member to get the caption height of the tabbed container.
Definition XTPDockingPanePaintManager.h:867
CXTPDockingPanePaintManager::SetSplitterStyle
void SetSplitterStyle(DWORD dwStyle)
Call this member to set the splitter style.
CXTPDockingPanePaintManager::DrawCaptionText
int DrawCaptionText(CDC *pDC, const CString &strTitle, CRect rc, BOOL bVertical, BOOL bCalcWidth=FALSE)
Draws the text of a pane caption.
CXTPDockingPanePaintManager::m_bDestroyCustomTitleBrushes
BOOL m_bDestroyCustomTitleBrushes
If TRUE, custom title bushes will be destroyed on cleanup.
Definition XTPDockingPanePaintManager.h:804
CXTPDockingPanePaintManager::DrawCaptionButton
virtual void DrawCaptionButton(CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton)
Override this member function to draw a button for a tabbed caption.
CXTPDockingPanePaintManager::DrawPane
virtual void DrawPane(CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc)
Override this member function to draw a tabbed container.
CXTPDockingPanePaintManager::m_nTitleHeight
int m_nTitleHeight
Title's height.
Definition XTPDockingPanePaintManager.h:791
CXTPDockingPanePaintManager::SetCaptionFontIndirect
void SetCaptionFontIndirect(LOGFONT *pLogFont, BOOL bUseStandardFont=FALSE)
Call this method to set the caption's font.
CXTPDockingPanePaintManager::SetCaptionButtonStyle
void SetCaptionButtonStyle(XTPDockingPaneCaptionButtonStyle nStyle)
Call this member to set the caption button style.
Definition XTPDockingPanePaintManager.h:894
CXTPDockingPanePaintManager::SetPanelPaintManager
CXTPTabPaintManager * SetPanelPaintManager(CXTPTabPaintManager *pManager)
Call this method to set the paint manager used to draw tabs of an auto-hide panel.
CXTPDockingPanePaintManager::m_nSplitterSize
int m_nSplitterSize
Splitter size.
Definition XTPDockingPanePaintManager.h:769
CXTPDockingPanePaintManager::GetTabsHeight
int GetTabsHeight() const
Call this member to get tabs height of the tabbed container.
Definition XTPDockingPanePaintManager.h:871
CXTPDockingPanePaintManager::m_bLunaTheme
BOOL m_bLunaTheme
TRUE if luna colors are used.
Definition XTPDockingPanePaintManager.h:829
CXTPDockingPanePaintManager::GetCaptionRect
virtual void GetCaptionRect(const CXTPDockingPaneTabbedContainer *pPane, CRect &rc)
Call this method to get a caption rectangle.
CXTPDockingPanePaintManager::m_clrSplitterGripper
CXTPPaintManagerColor m_clrSplitterGripper
Splitter gripper color.
Definition XTPDockingPanePaintManager.h:778
CXTPDockingPanePaintManager::m_systemTheme
XTPCurrentSystemTheme m_systemTheme
Current system theme.
Definition XTPDockingPanePaintManager.h:821
CXTPDockingPanePaintManager::m_themeToolbar
CXTPWinThemeWrapper * m_themeToolbar
Toolbar theme helper.
Definition XTPDockingPanePaintManager.h:823
CXTPDockingPanePaintManager::m_hbrInactiveTitleVert
HBRUSH m_hbrInactiveTitleVert
Optional user specified inactive vertical title brush.
Definition XTPDockingPanePaintManager.h:809
CXTPDockingPanePaintManager::GetCurrentSystemTheme
XTPCurrentSystemTheme GetCurrentSystemTheme() const
Call this member function to determine the current Windows XP theme in use.
CXTPDockingPanePaintManager::~CXTPDockingPanePaintManager
virtual ~CXTPDockingPanePaintManager()
Destroys a CXTPDockingPanePaintManager object, handles cleanup and deallocation.
CXTPDockingPanePaintManager::AdjustClientRect
virtual void AdjustClientRect(CXTPDockingPaneTabbedContainer *pPane, CRect &rect, BOOL bApply)
Override this member to change the client rectangle of the child docking pane.
CXTPDockingPanePaintManager::m_dwSplitterStyle
DWORD m_dwSplitterStyle
Splitter style.
Definition XTPDockingPanePaintManager.h:790
CXTPDockingPanePaintManager::GetPaneCaptionRect
virtual CRect GetPaneCaptionRect(const CXTPDockingPaneSidePanel *pPane)
Call this method to get the pane's caption rectangle.
CXTPDockingPanePaintManager::m_rcCaptionMargin
CRect m_rcCaptionMargin
Margins of caption.
Definition XTPDockingPanePaintManager.h:820
CXTPDockingPanePaintManager::GetCaptionButtonStyle
XTPDockingPaneCaptionButtonStyle GetCaptionButtonStyle() const
Call this method to get the caption button style.
Definition XTPDockingPanePaintManager.h:899
CXTPDockingPanePaintManager::DrawSidePanel
virtual void DrawSidePanel(CDC *pDC, CXTPDockingPaneSidePanel *pPane, CRect rc)
Override this member function to draw the side panel.
Definition XTPDockingPanePaintManager.h:888
CXTPDockingPanePaintManager::m_clrBackground
CXTPPaintManagerColor m_clrBackground
Background color.
Definition XTPDockingPanePaintManager.h:777
CXTPDockingPanePaintManager::DrawCaption
virtual void DrawCaption(CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc)=0
Override this member function to draw a caption.
CXTPDockingPanePaintManager::m_hbrActiveTitleVert
HBRUSH m_hbrActiveTitleVert
Optional user specified active vertical title brush.
Definition XTPDockingPanePaintManager.h:808
CXTPDockingPanePaintManager::m_xtpFontTitle
CXTPFont m_xtpFontTitle
Title font.
Definition XTPDockingPanePaintManager.h:795
CXTPDockingPanePaintManager::m_bDrawCaptionIcon
BOOL m_bDrawCaptionIcon
TRUE to draw caption icon.
Definition XTPDockingPanePaintManager.h:772
CXTPDockingPanePaintManager::Line
void Line(CDC *pDC, int x0, int y0, int x1, int y1)
Draws a line.
CXTPDockingPanePaintManager::GetSplitterStyle
DWORD GetSplitterStyle() const
Call this method to get the splitter style.
CXTPDockingPanePaintManager::SetColors
void SetColors(int cElements, CONST INT *lpaElements, CONST COLORREF *lpaRgbValues)
Call this member to set the colors for each element in an array to the colors in a specified color ar...
CXTPDockingPanePaintManager::DrawCaptionButtonEntry
virtual void DrawCaptionButtonEntry(CDC *pDC, CXTPDockingPaneCaptionButton *pButton, CPoint pt, COLORREF clrButton)
Draws only the glyph of a button.
CXTPDockingPanePaintManager::m_bShowCaption
BOOL m_bShowCaption
TRUE to draw captions of tabbed containers.
Definition XTPDockingPanePaintManager.h:770
CXTPDockingPanePaintManager::GetXtremeColor
COLORREF GetXtremeColor(UINT nIndex)
Retrieves the current color of the specified XP display element.
CXTPDockingPanePaintManager::m_themeRebar
CXTPWinThemeWrapper * m_themeRebar
Rebar theme helper.
Definition XTPDockingPanePaintManager.h:827
CXTPDockingPanePaintManager::m_pPanelPaintManager
CXTPTabPaintManager * m_pPanelPaintManager
Paint Manager used to draw tabs for an auto-hide panel.
Definition XTPDockingPanePaintManager.h:814
CXTPDockingPanePaintManager::DrawSplitter
virtual void DrawSplitter(CDC *pDC, CXTPDockingPaneSplitterWnd *pSplitter)
Override this method to draw a splitter.
CXTPDockingPanePaintManager::m_clrActiveCaption
CXTPPaintManagerColorGradient m_clrActiveCaption
Color of pane caption when active.
Definition XTPDockingPanePaintManager.h:782
CXTPDockingPanePaintManager::DrawCaptionButtonEntry
virtual void DrawCaptionButtonEntry(CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton, CSize szOffset)
Draws only the glyph of a button.
CXTPDockingPanePaintManager::SetLunaTheme
void SetLunaTheme(XTPCurrentSystemTheme systemTheme)
Call this method to force system theme.
CXTPDockingPanePaintManager::m_strOfficeFont
CString m_strOfficeFont
Office font name.
Definition XTPDockingPanePaintManager.h:819
CXTPDockingPanePaintManager::m_hbrActiveTitleHorz
HBRUSH m_hbrActiveTitleHorz
Optional user specified active horizontal title brush.
Definition XTPDockingPanePaintManager.h:806
CXTPDockingPanePaintManager::Line
void Line(CDC *pDC, int x0, int y0, int x1, int y1, int nPen)
Draws a line.
CXTPDockingPanePaintManager::AdjustCaptionRect
virtual void AdjustCaptionRect(const CXTPDockingPaneTabbedContainer *pPane, CRect &rc)
Override this member to change the caption rectangle of the child docking pane.
CXTPDockingPanePaintManager::m_bUseOfficeFont
BOOL m_bUseOfficeFont
TRUE to use Tahoma font.
Definition XTPDockingPanePaintManager.h:802
CXTPDockingPanePaintManager::GetCaptionGripperRect
virtual CRect GetCaptionGripperRect(const CXTPDockingPaneTabbedContainer *pPane)
Call this method to get a caption gripper for a tabbed container.
CXTPDockingPanePaintManager::m_bDrawSingleTab
BOOL m_bDrawSingleTab
TRUE to draw single tab.
Definition XTPDockingPanePaintManager.h:771
CXTPDockingPanePaintManager::GetTabPaintManager
CXTPTabPaintManager * GetTabPaintManager() const
Retrieves the paint manager used to draw tabs of a tabbed container.
Definition XTPDockingPanePaintManager.h:875
CXTPDockingPanePaintManager::m_pTabPaintManager
CXTPTabPaintManager * m_pTabPaintManager
Paint Manager used to draw tabs for a tabbed container.
Definition XTPDockingPanePaintManager.h:812
CXTPDockingPanePaintManager::GetPanelPaintManager
CXTPTabPaintManager * GetPanelPaintManager() const
Retrieves the paint manager used to draw tabs of an auto-hide panel.
Definition XTPDockingPanePaintManager.h:879
CXTPDockingPanePaintManager::CXTPDockingPanePaintManager
CXTPDockingPanePaintManager()
Constructs a CXTPDockingPanePaintManager object.
CXTPDockingPanePaintManager::m_bUseBoldCaptionFont
BOOL m_bUseBoldCaptionFont
TRUE to use bold font for caption.
Definition XTPDockingPanePaintManager.h:767
CXTPDockingPanePaintManager::m_themeExplorer
CXTPWinThemeWrapper * m_themeExplorer
WinXP Explorer theme helper.
Definition XTPDockingPanePaintManager.h:824
CXTPDockingPanePaintManager::DrawCaptionButtons
virtual void DrawCaptionButtons(CDC *pDC, CXTPDockingPaneCaptionButtons *pButtons, CRect &rcCaption, COLORREF clr, int nButtonSize, int nButtonGap, BOOL bVertical=FALSE)
Override this member function to draw buttons for a tabbed caption.
CXTPDockingPanePaintManager::m_bHighlightActiveCaption
BOOL m_bHighlightActiveCaption
TRUE to highlight active caption.
Definition XTPDockingPanePaintManager.h:768
CXTPDockingPanePaintManager::m_nTabsHeight
int m_nTabsHeight
Tab bar's height.
Definition XTPDockingPanePaintManager.h:793
CXTPDockingPanePaintManager::m_nCaptionButtonStyle
XTPDockingPaneCaptionButtonStyle m_nCaptionButtonStyle
Caption button style.
Definition XTPDockingPanePaintManager.h:789
CXTPDockingPanePaintManager::m_themeButton
CXTPWinThemeWrapper * m_themeButton
WinXP Button theme helper.
Definition XTPDockingPanePaintManager.h:825
CXTPDockingPanePaintManager::DrawFloatingFrame
virtual void DrawFloatingFrame(CDC *pDC, CXTPDockingPaneMiniWnd *pPane, CRect rc)
Call this method to draw the frame of a floating window.
Definition XTPDockingPanePaintManager.h:883
CXTPDockingPanePaintManager::m_hbrInactiveTitleHorz
HBRUSH m_hbrInactiveTitleHorz
Optional user specified inactive horizontal title brush.
Definition XTPDockingPanePaintManager.h:807
CXTPDockingPanePaintManager::m_bUseStandardFont
BOOL m_bUseStandardFont
TRUE to use system icon font.
Definition XTPDockingPanePaintManager.h:803
CXTPDockingPanePaintManager::DrawAutoHidePanel
virtual void DrawAutoHidePanel(CDC *pDC, CRect rc, XTPDockingPaneDirection direction)
This mmethod is called by the framework to draw the docking pane auto-hide panel background and split...
CXTPDockingPanePaintManager::m_themeCurrent
XTPDockingPanePaintTheme m_themeCurrent
Current theme.
Definition XTPDockingPanePaintManager.h:818
CXTPDockingPanePaintManager::Rectangle
void Rectangle(CDC *pDC, CRect rc, int nPenEntry, int nPenBorder)
Draws a rectangle.
CXTPDockingPanePaintManager::m_clrDisabledCaptionText
CXTPPaintManagerColor m_clrDisabledCaptionText
Disabled caption text.
Definition XTPDockingPanePaintManager.h:786
CXTPDockingPanePaintManager::m_clrSplitterGradient
CXTPPaintManagerColorGradient m_clrSplitterGradient
Splitter gradient color.
Definition XTPDockingPanePaintManager.h:780
CXTPDockingPanePaintManager::m_clrNormalCaption
CXTPPaintManagerColorGradient m_clrNormalCaption
Color of pane caption when inactive.
Definition XTPDockingPanePaintManager.h:781
CXTPDockingPanePaintManager::ClipAndAddEllipsisIfNeeded
void ClipAndAddEllipsisIfNeeded(CDC *pDC, CString &strTitle, int nCaptionWidth) const
Clip string and add ellipsis if its width less than nCaptionWidth.
CXTPDockingPanePaintManager::m_clrActiveCaptionText
CXTPPaintManagerColor m_clrActiveCaptionText
Active caption text.
Definition XTPDockingPanePaintManager.h:785
CXTPDockingPanePaintManager::SetCustomTitleBrushes
void SetCustomTitleBrushes(HBRUSH hbrActiveTitleHorz, HBRUSH hbrInactiveTitleHorz=NULL, HBRUSH hbrActiveTitleVert=NULL, HBRUSH hbrInactiveTitleVert=NULL, BOOL bDestroyOnCleanup=FALSE)
Sets custom title brushes.
CXTPDockingPanePaintManager::m_clrNormalCaptionText
CXTPPaintManagerColor m_clrNormalCaptionText
Color of pane caption text when the caption is inactive.
Definition XTPDockingPanePaintManager.h:783
CXTPDockingPanePaintManager::AdjustClientRect
virtual void AdjustClientRect(CXTPDockingPaneSidePanel *pPane, CRect &rect)
Override this member to change the client rectangle of the child docking pane.
CXTPDockingPanePaintManager::SetTabPaintManager
CXTPTabPaintManager * SetTabPaintManager(CXTPTabPaintManager *pManager)
Call this method to set the paint manager used to draw tabs of a tabbed container.
CXTPDockingPanePaintManager::UseOfficeFont
void UseOfficeFont(BOOL bUseOfficeFont)
Call this member to use Office (Tahoma) font.
CXTPDockingPanePaintManager::m_themeWindow
CXTPWinThemeWrapper * m_themeWindow
WinXP Window Theme helper.
Definition XTPDockingPanePaintManager.h:826
CXTPDockingPanePaintManager::RefreshMetrics
virtual void RefreshMetrics()
This method is called to refresh the visual metrics of the manager.
CXTPDockingPanePaintManager::m_nCaptionFontGap
int m_nCaptionFontGap
Additional gap of font.
Definition XTPDockingPanePaintManager.h:792
CXTPDockingPanePaintManager::m_xtpFontTitleVertical
CXTPFont m_xtpFontTitleVertical
Title vertical font.
Definition XTPDockingPanePaintManager.h:796
CXTPDockingPanePaintManager::Pixel
void Pixel(CDC *pDC, int xPos, int yPos, int nPen)
Sets the pixel at the point.
CXTPDockingPanePaintManager::m_clrSplitter
CXTPPaintManagerColor m_clrSplitter
Splitter color.
Definition XTPDockingPanePaintManager.h:779
CXTPDockingPanePaintManager::m_nSplitterIndent
int m_nSplitterIndent
Size of splitter indent.
Definition XTPDockingPanePaintManager.h:775
CXTPDockingPanePaintManager::AdjustCaptionRect
virtual void AdjustCaptionRect(const CXTPDockingPaneSidePanel *pPane, CRect &rc)
Override this member to change the caption rectangle of the child docking pane.
CXTPDockingPanePanelPaintManager
CXTPDockingPanePanelPaintManager is a CXTPTabPaintManager derived class that is used to store the col...
Definition XTPDockingPanePaintManager.h:91
CXTPDockingPanePanelPaintManager::SetAppearance
virtual CXTPTabPaintManagerTheme * SetAppearance(XTPTabAppearanceStyle tabAppearance)
Call this member to apply one of the "built-in" appearances to the tabs.
CXTPDockingPanePanelPaintManager::SetColor
virtual CXTPTabPaintManagerColorSet * SetColor(XTPTabColorStyle tabColor)
Call this member to apply one of the "built-in" color sets to the tabs.
CXTPDockingPaneSidePanel
CXTPDockingPaneSidePanel is a multiple inheritance class derived from CWnd and CXTPDockingPaneBase.
Definition XTPDockingPaneSidePanel.h:45
CXTPDockingPaneSplitterWnd
CXTPDockingPaneSplitterWnd is a CWnd derived class.
Definition XTPDockingPaneSplitterContainer.h:42
CXTPDockingPaneTabPaintManager
CXTPDockingPaneTabPaintManager is a CXTPTabPaintManager derived class that is used to store the color...
Definition XTPDockingPanePaintManager.h:51
CXTPDockingPaneTabPaintManager::SetAppearance
virtual CXTPTabPaintManagerTheme * SetAppearance(XTPTabAppearanceStyle tabAppearance)
Call this member to apply one of the "built-in" appearances to the tabs.
CXTPDockingPaneTabPaintManager::SetColor
virtual CXTPTabPaintManagerColorSet * SetColor(XTPTabColorStyle tabColor)
Call this member to apply one of the "built-in" color sets to the tabs.
CXTPDockingPaneTabbedContainer
CXTPDockingPaneTabbedContainer is a multiple inheritance class derived from CWnd and CXTPDockingPaneB...
Definition XTPDockingPaneTabbedContainer.h:47
CXTPFont
Provides a convenient object oriented interface for HFONT GDI object and uses GDI handle caching.
Definition XTPGdiObjects.h:414
CXTPPaintManagerColorGradient
The CXTPPaintManagerColorGradient class is used to manage COLORREF values for determining light and d...
Definition XTPColorManager.h:301
CXTPPaintManagerColor
The CXTPPaintManagerColor class is used to manage COLORREF values for determining default and applica...
Definition XTPColorManager.h:117
CXTPTabPaintManagerColorSet
CXTPTabPaintManagerColorSet represents the colors for all of the components of the tab manager (e....
Definition XTPTabPaintManagerColorSet.h:50
CXTPTabPaintManager
CXTPTabPaintManager is used to store the color and appearance information of the tabs in the tab mana...
Definition XTPTabPaintManager.h:48
CXTPTabPaintManagerTheme
CXTPTabPaintManagerTheme is a class that represents the appearance of all components of the tab manag...
Definition XTPTabPaintManagerTheme.h:56
CXTPWinThemeWrapper
The CXTPWinThemeWrapper class wraps the UxTheme.dll visual theme API.
Definition XTPWinThemeWrapper.h:188


Toolkit Pro: Member List

CXTPChartStackedBarSeriesStyle Member List

This is the complete list of members for CXTPChartStackedBarSeriesStyle, including all inherited members.

ApplyTo(CXTPChartDeviceCommand *pCommand) | CXTPChartSeriesStyle | virtual
CorrectAxisSideMargins(CXTPChartAxis *pAxis, double nMinValue, double nMaxValue, double &nCorrection) | CXTPChartStackedBarSeriesStyle | protectedvirtual
CreateDiagram() | CXTPChartDiagram2DSeriesStyle | virtual
CreateView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView) | CXTPChartStackedBarSeriesStyle | protectedvirtual
CXTPChartBarSeriesStyle() | CXTPChartBarSeriesStyle |
CXTPChartDiagram2DSeriesStyle() | CXTPChartDiagram2DSeriesStyle |
CXTPChartElement() | CXTPChartElement |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartSeriesStyle() | CXTPChartSeriesStyle |
CXTPChartStackedBarSeriesStyle() | CXTPChartStackedBarSeriesStyle |
DoPropExchange(CXTPPropExchange *pPX) | CXTPChartStackedBarSeriesStyle | virtual
Enable3dEdgeSmoothing(BOOL bEnable=TRUE) | CXTPChartSeriesStyle | virtual
Get3dRotation() const | CXTPChartSeriesStyle | virtual
GetAppearance() const | CXTPChartElement |
GetBarWidth() const | CXTPChartBarSeriesStyle |
GetColor() const | CXTPChartSeriesStyle | virtual
GetContent() const | CXTPChartElement |
GetErrorBar() const | CXTPChartSeriesStyle | virtual
GetLabel() const | CXTPChartSeriesStyle | virtual
GetOwner() const | CXTPChartElement |
GetSeriesPointValueIndex() const | CXTPChartSeriesStyle | virtual
GetStyleAppearance() const | CXTPChartSeriesStyle | virtual
GetTransparency() const | CXTPChartSeriesStyle | virtual
Is3D() const | CXTPChartObject |
Is3dEdgeSmoothingEnabled() const | CXTPChartSeriesStyle | virtual
IsColorEach() const | CXTPChartSeriesStyle | virtual
IsStyleDiagram(CXTPChartDiagram *pDiagram) const | CXTPChartDiagram2DSeriesStyle | virtual
m_bColorEach | CXTPChartSeriesStyle | protected
m_bSmooth3dEdges | CXTPChartSeriesStyle | protected
m_clrColor | CXTPChartSeriesStyle | protected
m_nAxisIndexX | CXTPChartDiagram2DSeriesStyle | protected
m_nAxisIndexY | CXTPChartDiagram2DSeriesStyle | protected
m_nTransparency | CXTPChartSeriesStyle | protected
m_pErrorBar | CXTPChartSeriesStyle | protected
m_pLabel | CXTPChartSeriesStyle | protected
m_Rotation3d | CXTPChartSeriesStyle | protected
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartElement | virtual
Release() | CXTPChartElement | virtual
Set3dRotation(const CXTPChart3dRotation &rotation) | CXTPChartSeriesStyle | virtual
Set3dRotation(double dYaw, double dPitch, double dRoll) | CXTPChartSeriesStyle | virtual
SetBarWidth(double dWidth) | CXTPChartBarSeriesStyle |
SetColor(CXTPChartColor clr) | CXTPChartSeriesStyle | virtual
SetColorEach(BOOL bColorEach) | CXTPChartSeriesStyle | virtual
SetErrorBar(CXTPChartErrorBar *pErrorBar) | CXTPChartSeriesStyle | virtual
SetLabel(CXTPChartSeriesLabel *pLabel) | CXTPChartSeriesStyle | virtual
SetTransparency(int nTransparency) | CXTPChartSeriesStyle | virtual
~CXTPChartBarSeriesStyle() | CXTPChartBarSeriesStyle | virtual
~CXTPChartDiagram2DSeriesStyle() | CXTPChartDiagram2DSeriesStyle | virtual
~CXTPChartElement() | CXTPChartElement | virtual
~CXTPChartSeriesStyle() | CXTPChartSeriesStyle | virtual
~CXTPChartStackedBarSeriesStyle() | CXTPChartStackedBarSeriesStyle | virtual


Toolkit Pro: Member List

CXTPChartTextAntialiasingDeviceCommand Member List

This is the complete list of members for CXTPChartTextAntialiasingDeviceCommand, including all inherited members.

AddChildCommand(CXTPChartDeviceCommand *pCommand) | CXTPChartDeviceCommand |
AfterExecute(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
ApplySeriesStyle(CXTPChartSeriesStyle *pStyle) | CXTPChartDeviceCommand | virtual
BeforeExecute(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
BindView(CXTPChartElementView *pView) | CXTPChartDeviceCommand |
Commit() | CXTPChartDeviceCommand |
CXTPChartDeviceCommand() | CXTPChartDeviceCommand |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartTextAntialiasingDeviceCommand(BOOL bAntialias=TRUE) | CXTPChartTextAntialiasingDeviceCommand |
CXTPObservable() | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | protected
Execute(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
ExecuteOverride(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
GetBoundView() const | CXTPChartDeviceCommand |
GetChildCommand(int nIndex) const | CXTPChartDeviceCommand |
GetChildCommandCount() const | CXTPChartDeviceCommand |
GetCurrentDC() const | CXTPChartDeviceCommand |
GetPassNumber() const | CXTPChartDeviceCommand |
HitTest(CPoint point, CXTPChartElement *pParent) const | CXTPChartDeviceCommand | virtual
Is3D() const | CXTPChartObject |
IsCommitted() const | CXTPChartDeviceCommand |
IsEnabled() const | CXTPChartDeviceCommand | virtual
m_arrChildren | CXTPChartDeviceCommand | protected
m_bAntiAlias | CXTPChartTextAntialiasingDeviceCommand | protected
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Prepare(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
PrepareOverride(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
SetEnabled(BOOL bEnabled=TRUE) | CXTPChartDeviceCommand |
Subscribe(CXTPChartDeviceCommandEvents *pObserver, CXTPSubscriptionList< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > *pSubcriptionList=NULL) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > |
Unsubscribe(CXTPChartDeviceCommandEvents *pObserver) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > |
~CXTPChartDeviceCommand() | CXTPChartDeviceCommand | virtual
~CXTPObservable() | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | protected


Toolkit Pro: Member List

CXTPChartRotatedTextPainterNearLine Member List

This is the complete list of members for CXTPChartRotatedTextPainterNearLine, including all inherited members.

CalculateBounds() | CXTPChartRotatedTextPainterBase | virtual
CalculateLeftTopPoint() | CXTPChartRotatedTextPainterNearLine | virtual
CalculatePoints(XTPChartTextRotation rotation, CRect rect, float angle, float points[4][2]) | CXTPChartRotatedTextPainterBase |
CalculateRotation() | CXTPChartRotatedTextPainterNearLine | virtual
CreateDeviceCommand(CXTPChartDeviceContext *pDC, const CXTPChartColor &color) | CXTPChartRotatedTextPainterBase | virtual
CXTPChartRotatedTextPainterBase(CXTPChartDeviceContext *pDC, const CXTPChartString &text, CXTPChartTextElement *pTextProvider, CPoint ptBase=CPoint(0, 0)) | CXTPChartRotatedTextPainterBase | protected
CXTPChartRotatedTextPainterNearLine(CXTPChartDeviceContext *pDC, const CXTPChartString &text, CXTPChartTextElement *pTextProvider, CPoint ptBase, XTPChartNearTextPosition position, float fAngle) | CXTPChartRotatedTextPainterNearLine |
CXTPChartTextPainterBase(CXTPChartDeviceContext *pDC, const CXTPChartString &text, CXTPChartTextElement *pTextProvider) | CXTPChartTextPainterBase | protected
GetInitialTextRect() | CXTPChartRotatedTextPainterBase |
GetRoundedBounds() | CXTPChartTextPainterBase |
m_fAngle | CXTPChartRotatedTextPainterBase | protected
m_nHeight | CXTPChartTextPainterBase | protected
m_nNearPosition | CXTPChartRotatedTextPainterNearLine | protected
m_nWidth | CXTPChartTextPainterBase | protected
m_ptBasePoint | CXTPChartRotatedTextPainterBase | protected
m_pTextProvider | CXTPChartTextPainterBase | protected
m_rcBounds | CXTPChartTextPainterBase | protected
m_rcRoundedBounds | CXTPChartTextPainterBase | protected
m_strText | CXTPChartTextPainterBase | protected
m_szTextSize | CXTPChartTextPainterBase | protected
SetBasePoint(CPoint pt) | CXTPChartRotatedTextPainterBase |
~CXTPChartTextPainterBase() | CXTPChartTextPainterBase | virtual


Toolkit Pro: Member List

CXTPTabControl Member List

This is the complete list of members for CXTPTabControl, including all inherited members.

AddItem(int nItem, CXTPTabManagerItem *pItem=NULL) | CXTPTabManager | protected
AdjustRect(BOOL bLarger, LPRECT lpRect) const | CXTPTabControl |
Create(DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID) | CXTPTabControl |
CXTPTabControl() | CXTPTabControl |
CXTPTabManager() | CXTPTabManager |
DeleteAllItems() | CXTPTabManager |
DeleteItem(int nItem) | CXTPTabManager |
DrawIcon(CDC *pDC, CPoint pt, CXTPTabManagerItem *pItem, BOOL bDraw, CSize &szIcon) const | CXTPTabControl | virtual
DrawParentBackground(CDC *pDC, CRect rc) | CXTPTabManager | virtual
EnableMarkup(BOOL bEnable=TRUE) | CXTPTabManager |
EnableTabThemeTexture(HWND hWnd, BOOL bEnable=TRUE) | CXTPTabManager |
EnableToolTips(XTPTabToolTipBehaviour behaviour=xtpTabToolTipAlways) | CXTPTabControl |
EnsureVisible(CXTPTabManagerItem *pItem) | CXTPTabManager |
FindNavigateButton(UINT nID) const | CXTPTabManager |
FindNextFocusable(int nIndex, int nDirection) const | CXTPTabManager |
GetAppearance() const | CXTPTabManager |
GetAppearanceSet() const | CXTPTabManager |
GetClientRect() const | CXTPTabManager |
GetColor() const | CXTPTabManager |
GetColorSet() const | CXTPTabManager |
GetControlRect() const | CXTPTabManager |
GetCurSel() const | CXTPTabManager |
GetHeaderOffset() const | CXTPTabManager |
GetHeaderRect() const | CXTPTabManager |
GetImageManager() const | CXTPTabControl |
GetItem(int nIndex) const | CXTPTabManager |
GetItemCaption(const CXTPTabManagerItem *pItem) const | CXTPTabManager | virtual
GetItemColor(const CXTPTabManagerItem *pItem) const | CXTPTabManager | virtual
GetItemCount() const | CXTPTabManager |
GetItemIcon(const CXTPTabManagerItem *pItem) const | CXTPTabManager | virtual
GetItemMetrics(CSize *szNormal, CSize *szMin=NULL, CSize *szMax=NULL) const | CXTPTabManager | virtual
GetItemsLength() const | CXTPTabManager | virtual
GetItemTooltip(const CXTPTabManagerItem *pItem) const | CXTPTabManager | virtual
GetLayout() const | CXTPTabManager |
GetMarkupContext() const | CXTPTabManager | virtual
GetNavigateButton(int nIndex) const | CXTPTabManager |
GetNavigateButtonCount() const | CXTPTabManager |
GetNavigateButtons() | CXTPTabManager |
GetPaintManager() const | CXTPTabControl | virtual
GetPosition() const | CXTPTabManager | virtual
GetRectLength(CRect rc) const | CXTPTabManager |
GetRowCount() const | CXTPTabManager |
GetSelectedItem() const | CXTPTabManager |
GetToolTipContext() const | CXTPTabControl |
HeaderHasFocus() const | CXTPTabControl | protectedvirtual
HitTest(CPoint point) const | CXTPTabManager |
HitTestNavigateButton(CPoint point, BOOL bHeaderOnly, int *pnIndex=NULL) const | CXTPTabManager |
InsertItem(int nItem, LPCTSTR lpszItem, HWND hwndChild=NULL, int nImage=-1, CXTPTabManagerItem *pAddItem=NULL) | CXTPTabControl |
IsActive() const | CXTPTabManager |
IsAllowReorder() const | CXTPTabManager | virtual
IsDrawStaticFrame() const | CXTPTabManager | virtual
IsHorizontalPosition() const | CXTPTabManager |
IsMouseLocked() const | CXTPTabManager | protectedvirtual
IsNavigateButtonAutomaticVisible(CXTPTabManagerNavigateButton *pButton) | CXTPTabManager | protectedvirtual
IsNavigateButtonVisible(CXTPTabManagerNavigateButton *pButton) | CXTPTabManager | protectedvirtual
m_arrItems | CXTPTabManager | protected
m_arrNavigateButtons | CXTPTabManager | protected
m_bActive | CXTPTabManager | protected
m_bAllowReorder | CXTPTabManager | protected
m_bCloseItemButton | CXTPTabManager | protected
m_nHeaderOffset | CXTPTabManager | protected
m_nScrollDelta | CXTPTabManager | protected
m_pHighlighted | CXTPTabManager | protected
m_pHighlightedNavigateButton | CXTPTabManager | protected
m_pMarkupContext | CXTPTabManager | protected
m_pPressed | CXTPTabManager | protected
m_pRowIndexer | CXTPTabManager | protected
m_pSelected | CXTPTabManager | protected
m_rcControl | CXTPTabManager | protected
m_rcHeaderRect | CXTPTabManager | protected
MoveItem(CXTPTabManagerItem *pItem, int nIndex) | CXTPTabManager |
OnBeforeItemClick(CXTPTabManagerItem *pItem) | CXTPTabManager | protectedvirtual
OnItemClick(CXTPTabManagerItem *pItem) | CXTPTabControl | virtual
OnItemHandleChanged(CXTPTabManagerItem *pItem, HWND hwndOld, HWND hwndNew) | CXTPTabManager | protectedvirtual
OnItemOrderChanged(CXTPTabManagerItem *pItem, int nOldIndex, int nNewIndex) | CXTPTabManager | protectedvirtual
OnItemsChanged() | CXTPTabManager | virtual
OnNavigateButtonClick(CXTPTabManagerNavigateButton *pButton) | CXTPTabControl | protectedvirtual
OnNavigateButtonClick(UINT nID) | CXTPTabControl | protectedvirtual
OnPropertyChanged() | CXTPTabManagerAtom | inlinevirtual
OnScrollHeader(BOOL bRight) | CXTPTabManager | virtual
OnSwitchItem(CXTPTabManagerItem *pItem1, CXTPTabManagerItem *pItem2) | CXTPTabManager | protectedvirtual
PerformClick(HWND hWnd, CPoint pt, BOOL bNoItemClick=FALSE) | CXTPTabManager |
PerformKeyDown(HWND hWnd, UINT nChar) | CXTPTabManager | virtual
PerformMouseMove(HWND hWnd, CPoint pt) | CXTPTabManager |
PerformToolHitTest(HWND hWnd, CPoint point, TOOLINFO *pTI) const | CXTPTabManager | virtual
RedrawControl(LPCRECT lpRect, BOOL bAnimate) | CXTPTabControl | virtual
ReOrder(HWND hWnd, CPoint pt, CXTPTabManagerItem *pItem) | CXTPTabManager | protectedvirtual
Reposition() | CXTPTabControl | virtual
SetActive(BOOL bActive) | CXTPTabManager |
SetAllowReorder(BOOL bAllowReorder) | CXTPTabManager | virtual
SetAppearance(XTPTabAppearanceStyle tabAppearance) | CXTPTabManager |
SetAppearanceSet(CXTPTabPaintManagerTheme *pAppearanceSet) | CXTPTabManager |
SetColor(XTPTabColorStyle tabColor) | CXTPTabManager |
SetColorSet(CXTPTabPaintManagerColorSet *pColorSet) | CXTPTabManager |
SetCurSel(int nIndex) | CXTPTabManager |
SetFocusedItem(CXTPTabManagerItem *pItem) | CXTPTabControl | virtual
SetHeaderOffset(int nOffset) | CXTPTabManager |
SetImageList(CImageList *pImageList) | CXTPTabControl |
SetImageManager(CXTPImageManager *pImageManager) | CXTPTabControl |
SetItemMetrics(CSize szNormal, CSize szMin=CSize(0, 0), CSize szMax=CSize(0, 0)) | CXTPTabManager |
SetLayoutStyle(XTPTabLayoutStyle tabLayout) | CXTPTabManager |
SetLockRedraw(BOOL bLockRedraw) | CXTPTabControl |
SetPaintManager(CXTPTabPaintManager *pPaintManager) | CXTPTabControl | virtual
SetPosition(XTPTabPosition tabPosition) | CXTPTabManager |
SetSelectedItem(CXTPTabManagerItem *pItem) | CXTPTabControl | virtual
ShowCloseItemButton(XTPTabNavigateButtonFlags bCloseItemButton=xtpTabNavigateButtonAlways) | CXTPTabManager |
ShowIcons(BOOL bShowIcons) | CXTPTabManager |
TrackClick(HWND hWnd, CPoint pt, CXTPTabManagerItem *pItem) | CXTPTabManager | protected
~CXTPTabControl() | CXTPTabControl | virtual
~CXTPTabManager() | CXTPTabManager | virtual
~CXTPTabManagerAtom() | CXTPTabManagerAtom | inlineprotectedvirtual


Toolkit Pro: XTPShellTreeBase.h Source File

  • Source
  • Controls
  • Shell
XTPShellTreeBase.h
Go to the documentation of this file.
1
23#if !defined(__XTPSHELLTREEBASE_H__)
24# define __XTPSHELLTREEBASE_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
44enum XTPFindType
45{
46 xtpFindTypeDrive,
47 xtpFindTypeFolder,
48 xtpFindTypeRoot,
49 xtpFindTypeShare
50};
51
57class _XTP_EXT_CLASS CXTPShellTreeBase
58 : public CXTPTreeBase
59 , public CXTPShellPidl
60{
61public:
66 CXTPShellTreeBase();
67
72 virtual ~CXTPShellTreeBase();
73
74protected:
87 virtual BOOL InitTreeViewItems(LPSHELLFOLDER lpsf, LPITEMIDLIST lpifq, HTREEITEM hParent);
88
96 virtual void GetNormalAndSelectedIcons(LPITEMIDLIST lpifq, LPTV_ITEM lptvitem);
97
98public:
105 void EnableContextMenu(BOOL bEnable);
106
112 void SetRootFolder(int nRootFolder = CSIDL_DESKTOP);
113
119 void ShowFiles(BOOL bShowFiles = TRUE);
120
149 void SetEnumFlags(UINT uFlags);
150
158 virtual BOOL InitSystemImageLists();
159
164 virtual void PopulateTreeView();
165
172 virtual void OnFolderExpanding(NM_TREEVIEW* pNMTreeView);
173
181 virtual HTREEITEM GetContextMenu();
182
192 virtual BOOL OnFolderSelected(NM_TREEVIEW* pNMTreeView, CString& strFolderPath);
193
202 virtual BOOL GetSelectedFolderPath(CString& strFolderPath);
203
215 virtual BOOL FindTreeItem(HTREEITEM hItem, XTP_LVITEMDATA* lplvid, BOOL bRecursively = TRUE);
216
223 virtual void AssociateCombo(CWnd* pWnd);
224
231 virtual void InitTreeNode(HTREEITEM hItem, XTP_TVITEMDATA* lptvid);
232
241 virtual HTREEITEM SearchTree(HTREEITEM hItem, LPCITEMIDLIST pABSPidl);
242
251 virtual BOOL TunnelTree(CString strFindPath);
252
264 virtual BOOL GetFolderItemPath(HTREEITEM hItem, CString& strFolderPath);
265
274 virtual void PopulateTree(LPCTSTR lpszPath);
275
286 virtual BOOL InitializeTree(DWORD dwStyle = TVS_HASBUTTONS | TVS_HASLINES | TVS_LINESATROOT);
287
293 virtual void BeginDrag(NM_TREEVIEW* pNMTreeView);
294
303 virtual HTREEITEM InsertDesktopItem(int nFolder = CSIDL_DESKTOP);
304
317 virtual void SelectionChanged(HTREEITEM hItem, CString strFolderPath);
318
319public:
325 void SetExplorerStyle();
326
327protected:
335 void SetAttributes(HTREEITEM hItem, DWORD dwAttributes);
336
384 CString PathFindNextComponent(const CString& pszPath);
385
391 virtual void SortChildren(HTREEITEM hParent);
392
393protected:
396 //{{AFX_MSG(CXTPShellTreeBase)
397 afx_msg void OnItemexpanding(NMHDR* pNMHDR, LRESULT* pResult);
398 afx_msg void OnSelchanged(NMHDR* pNMHDR, LRESULT* pResult);
399 afx_msg void OnDeleteTreeItem(NMHDR* pNMHDR, LRESULT* pResult);
400 afx_msg void OnRclick(NMHDR* pNMHDR, LRESULT* pResult);
401 afx_msg BOOL OnEraseBkgnd(CDC* pDC);
402 afx_msg void OnPaint();
403 //}}AFX_MSG
406protected:
407 UINT m_uFlags;
408 bool m_bTunneling;
409 BOOL m_bContextMenu;
410 CWnd* m_pComboBox;
412 CXTPShellSettings m_shSettings;
413 int m_nRootFolder;
414 BOOL m_bShowFiles;
415 BOOL m_bExplorerStyle;
416};
417
419
420AFX_INLINE void CXTPShellTreeBase::SetEnumFlags(UINT uFlags)
421{
422 m_uFlags = uFlags;
423}
424AFX_INLINE void CXTPShellTreeBase::EnableContextMenu(BOOL bEnable)
425{
426 m_bContextMenu = bEnable;
427}
428AFX_INLINE void CXTPShellTreeBase::SetRootFolder(int nRootFolder /*= CSIDL_DESKTOP*/)
429{
430 m_nRootFolder = nRootFolder;
431}
432AFX_INLINE void CXTPShellTreeBase::ShowFiles(BOOL bShowFiles /*= TRUE*/)
433{
434 m_bShowFiles = bShowFiles;
435}
460# define DECLARE_SHELLTREE_BASE(ClassName, Tree, Base)
462# undef DECLARE_SHELLTREE_BASE
463# define DECLARE_SHELLTREE_BASE(ClassName, Tree, Base) \
464 DECLARE_TREE_BASE(Base##Tree, Tree, Base) \
465 class _XTP_EXT_CLASS ClassName : public Base##Tree \
466 { \
467 protected: \
468 void OnPaint() \
469 { \
470 Base::OnPaint(); \
471 } \
472 void OnBeginDrag(NMHDR* pNMHDR, LRESULT* pResult) \
473 { \
474 NM_TREEVIEW* pNMTreeView = (NM_TREEVIEW*)pNMHDR; \
475 BeginDrag(pNMTreeView); \
476 *pResult = 0; \
477 } \
478 void OnSelchanged(NMHDR* pNMHDR, LRESULT* pResult) \
479 { \
480 Base::OnSelchanged(pNMHDR, pResult); \
481 } \
482 void OnDeleteTreeItem(NMHDR* pNMHDR, LRESULT* pResult) \
483 { \
484 Base::OnDeleteTreeItem(pNMHDR, pResult); \
485 } \
486 void OnRclick(NMHDR* pNMHDR, LRESULT* pResult) \
487 { \
488 Base::OnRclick(pNMHDR, pResult); \
489 } \
490 void OnItemexpanding(NMHDR* pNMHDR, LRESULT* pResult) \
491 { \
492 Base::OnItemexpanding(pNMHDR, pResult); \
493 } \
494 };
495
496# define ON_SHELLTREE_REFLECT \
497 ON_NOTIFY_REFLECT(NM_RCLICK, OnRclick) \
498 ON_NOTIFY_REFLECT(TVN_ITEMEXPANDING, OnItemexpanding) \
499 ON_NOTIFY_REFLECT(TVN_SELCHANGED, OnSelchanged) \
500 ON_NOTIFY_REFLECT(TVN_BEGINDRAG, OnBeginDrag) \
501 ON_NOTIFY_REFLECT(TVN_BEGINRDRAG, OnBeginDrag) \
502 ON_NOTIFY_REFLECT(TVN_DELETEITEM, OnDeleteTreeItem) \
503 ON_TREECTRL_REFLECT
504
509# define DECLATE_SHELLTREE_BASE(ClassName, Tree, Base) \
510 DECLARE_SHELLTREE_BASE(ClassName, Tree, Base)
511
514# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
516#endif // __XTPSHELLTREEBASE_H__
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPFindType
XTPFindType
Enumeration used to determine folder or drive type.
Definition XTPShellTreeBase.h:45
xtpFindTypeRoot
@ xtpFindTypeRoot
The object type is a root folder.
Definition XTPShellTreeBase.h:48
xtpFindTypeFolder
@ xtpFindTypeFolder
The object type is a folder.
Definition XTPShellTreeBase.h:47
xtpFindTypeDrive
@ xtpFindTypeDrive
The object type is a drive.
Definition XTPShellTreeBase.h:46
xtpFindTypeShare
@ xtpFindTypeShare
The object is a UNC share.
Definition XTPShellTreeBase.h:49
CXTPShellPidl
CXTPShellPidl is a standalone base class.
Definition XTPShellPidl.h:69
CXTPShellSettings
CXTPShellSettings is a SHELLFLAGSTATE struct derived class.
Definition XTPShellSettings.h:40
CXTPShellTreeBase
CXTPShellTreeBase is a multiple inheritance class derived from CXTPTreeView and CXTPShellPidl.
Definition XTPShellTreeBase.h:60
CXTPShellTreeBase::InitTreeViewItems
virtual BOOL InitTreeViewItems(LPSHELLFOLDER lpsf, LPITEMIDLIST lpifq, HTREEITEM hParent)
This member function fills a branch of the TreeView control.
CXTPShellTreeBase::m_uFlags
UINT m_uFlags
Flags indicating which items to include in the enumeration.
Definition XTPShellTreeBase.h:407
CXTPShellTreeBase::TunnelTree
virtual BOOL TunnelTree(CString strFindPath)
This member function will "tunnel" the tree to find the specified path.
CXTPShellTreeBase::m_bExplorerStyle
BOOL m_bExplorerStyle
Explorer Style.
Definition XTPShellTreeBase.h:415
CXTPShellTreeBase::m_bTunneling
bool m_bTunneling
true if the tree is currently traversing.
Definition XTPShellTreeBase.h:408
CXTPShellTreeBase::m_bContextMenu
BOOL m_bContextMenu
TRUE to display the shell context menu on right item click.
Definition XTPShellTreeBase.h:409
CXTPShellTreeBase::FindTreeItem
virtual BOOL FindTreeItem(HTREEITEM hItem, XTP_LVITEMDATA *lplvid, BOOL bRecursively=TRUE)
This member function recursively searches the tree control beginning at 'hItem' to find the item spec...
CXTPShellTreeBase::m_bShowFiles
BOOL m_bShowFiles
FALSE to only show directories.
Definition XTPShellTreeBase.h:414
CXTPShellTreeBase::PopulateTreeView
virtual void PopulateTreeView()
This member function adds items to the tree view.
CXTPShellTreeBase::PopulateTree
virtual void PopulateTree(LPCTSTR lpszPath)
This member function populates a tree based upon a path.
CXTPShellTreeBase::OnFolderExpanding
virtual void OnFolderExpanding(NM_TREEVIEW *pNMTreeView)
This member function responds to a TVN_ITEMEXPANDING message in order to fill up sub-directories.
CXTPShellTreeBase::m_shSettings
CXTPShellSettings m_shSettings
Contains SHELLFLAGSTATE info.
Definition XTPShellTreeBase.h:412
CXTPShellTreeBase::SetEnumFlags
void SetEnumFlags(UINT uFlags)
Call this member function to determine the type of items included in the shell enumeration.
CXTPShellTreeBase::OnFolderSelected
virtual BOOL OnFolderSelected(NM_TREEVIEW *pNMTreeView, CString &strFolderPath)
This member function responds to a TVN_SELCHANGED message to retrieve the specified folder path.
CXTPShellTreeBase::CXTPShellTreeBase
CXTPShellTreeBase()
Constructs a CXTPShellTreeBase object.
CXTPShellTreeBase::SelectionChanged
virtual void SelectionChanged(HTREEITEM hItem, CString strFolderPath)
Called after a user makes a new tree selection.
CXTPShellTreeBase::GetContextMenu
virtual HTREEITEM GetContextMenu()
This member function displays the shell context menu for the selected item or folder.
CXTPShellTreeBase::InitTreeNode
virtual void InitTreeNode(HTREEITEM hItem, XTP_TVITEMDATA *lptvid)
This member function is called to initialize a branch of the shell tree.
CXTPShellTreeBase::GetNormalAndSelectedIcons
virtual void GetNormalAndSelectedIcons(LPITEMIDLIST lpifq, LPTV_ITEM lptvitem)
This member function gets the index for the normal and selected icons for the current item.
CXTPShellTreeBase::InsertDesktopItem
virtual HTREEITEM InsertDesktopItem(int nFolder=CSIDL_DESKTOP)
This member function is called to insert the desktop as the root item in the shell tree control.
CXTPShellTreeBase::SortChildren
virtual void SortChildren(HTREEITEM hParent)
Sorts items in the control using the provided callback function.
CXTPShellTreeBase::~CXTPShellTreeBase
virtual ~CXTPShellTreeBase()
Destroys a CXTPShellTreeBase object, handles cleanup and deallocation.
CXTPShellTreeBase::EnableContextMenu
void EnableContextMenu(BOOL bEnable)
Call this member function to enable/disable the display of the shell context menu on right item click...
CXTPShellTreeBase::InitializeTree
virtual BOOL InitializeTree(DWORD dwStyle=TVS_HASBUTTONS|TVS_HASLINES|TVS_LINESATROOT)
Call this member function to initialize the shell tree control prior to calling PopulateTree.
CXTPShellTreeBase::m_pComboBox
CWnd * m_pComboBox
CComboBox that is associated with this control.
Definition XTPShellTreeBase.h:410
CXTPShellTreeBase::PathFindNextComponent
CString PathFindNextComponent(const CString &pszPath)
Parses a path for the next path component.
CXTPShellTreeBase::GetSelectedFolderPath
virtual BOOL GetSelectedFolderPath(CString &strFolderPath)
This member function retrieves the path of the currently selected tree item.
CXTPShellTreeBase::GetFolderItemPath
virtual BOOL GetFolderItemPath(HTREEITEM hItem, CString &strFolderPath)
This member function retrieves the path of a folder item, which does not have to be selected.
CXTPShellTreeBase::SetAttributes
void SetAttributes(HTREEITEM hItem, DWORD dwAttributes)
This member function sets the shell attribute flags for the specified tree item.
CXTPShellTreeBase::SetExplorerStyle
void SetExplorerStyle()
Call this method to enable auto-hidden triangles for Windows Vista and Windows 7.
CXTPShellTreeBase::BeginDrag
virtual void BeginDrag(NM_TREEVIEW *pNMTreeView)
Used by the shell list control to handle a drag event.
CXTPShellTreeBase::SetRootFolder
void SetRootFolder(int nRootFolder=CSIDL_DESKTOP)
Call this member to set the root CSIDL folder.
CXTPShellTreeBase::InitSystemImageLists
virtual BOOL InitSystemImageLists()
This member function obtains a handle to the system image list and attaches it to the tree control.
CXTPShellTreeBase::AssociateCombo
virtual void AssociateCombo(CWnd *pWnd)
This member function is used to associate a CComboBox object with the control.
CXTPShellTreeBase::m_nRootFolder
int m_nRootFolder
Root Folder CSIDL.
Definition XTPShellTreeBase.h:413
CXTPShellTreeBase::ShowFiles
void ShowFiles(BOOL bShowFiles=TRUE)
Call this member to show all files instead of only folders.
CXTPShellTreeBase::SearchTree
virtual HTREEITEM SearchTree(HTREEITEM hItem, LPCITEMIDLIST pABSPidl)
This member function searches the tree for a specified folder.
CXTPTreeBase
CXTPTreeBase is a CTreeView derived class.
Definition XTPTreeBase.h:43
XTP_LVITEMDATA
The XTP_LVITEMDATA structure is used to maintain information for a particular list item in a CXTPShel...
Definition XTPShellPidl.h:42
XTP_TVITEMDATA
The XTP_TVITEMDATA structure is used to maintain information for a particular tree item in a CXTPShel...
Definition XTPShellPidl.h:57


Toolkit Pro: Member List

CXTPChartPieSeriesLabelBase Member List

This is the complete list of members for CXTPChartPieSeriesLabelBase, including all inherited members.

CreateView(CXTPChartDeviceContext *pDC, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView)=0 | CXTPChartPieSeriesLabelBase | protectedpure virtual
CXTPChartElement() | CXTPChartElement |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartPieSeriesLabelBase() | CXTPChartPieSeriesLabelBase |
CXTPChartSeriesLabel() | CXTPChartSeriesLabel |
DoPropExchange(CXTPPropExchange *pPX) | CXTPChartPieSeriesLabelBase | virtual
GetAntialiasing() const | CXTPChartSeriesLabel | virtual
GetAppearance() const | CXTPChartElement |
GetBackColor() const | CXTPChartSeriesLabel |
GetContent() const | CXTPChartElement |
GetFont() const | CXTPChartSeriesLabel | virtual
GetFormat() const | CXTPChartSeriesLabel |
GetLineColor() const | CXTPChartSeriesLabel |
GetLineLength() const | CXTPChartSeriesLabel |
GetOwner() const | CXTPChartElement |
GetPosition() const | CXTPChartPieSeriesLabelBase |
GetShowLines() const | CXTPChartSeriesLabel |
GetStyle() const | CXTPChartPieSeriesLabelBase |
GetTextColor() const | CXTPChartSeriesLabel |
GetTransparency() const | CXTPChartSeriesLabel |
Is3D() const | CXTPChartObject |
IsInside() const | CXTPChartPieSeriesLabelBase |
IsVisible() const | CXTPChartSeriesLabel |
m_bAntialiasing | CXTPChartSeriesLabel | protected
m_bShowLines | CXTPChartSeriesLabel | protected
m_bVisible | CXTPChartSeriesLabel | protected
m_clrBackColor | CXTPChartSeriesLabel | protected
m_clrLineColor | CXTPChartSeriesLabel | protected
m_clrTextColor | CXTPChartSeriesLabel | protected
m_nLineLength | CXTPChartSeriesLabel | protected
m_nPosition | CXTPChartPieSeriesLabelBase | protected
m_nTransparency | CXTPChartSeriesLabel | protected
m_pBorder | CXTPChartSeriesLabel | protected
m_pFont | CXTPChartSeriesLabel | protected
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartElement | virtual
Release() | CXTPChartElement | virtual
SetAntialiasing(BOOL bAntialiasing) | CXTPChartSeriesLabel |
SetBackColor(const CXTPChartColor &clrBackColor) | CXTPChartSeriesLabel |
SetFont(CXTPChartFont *pFont) | CXTPChartSeriesLabel |
SetFormat(LPCTSTR lpszFormat) | CXTPChartSeriesLabel |
SetLineColor(const CXTPChartColor &clrBackColor) | CXTPChartSeriesLabel |
SetLineLength(int nLineLength) | CXTPChartSeriesLabel |
SetPosition(XTPChartPieLabelPosition nPosition) | CXTPChartPieSeriesLabelBase |
SetShowLines(BOOL bShowLines) | CXTPChartSeriesLabel |
SetTextColor(const CXTPChartColor &clrTextColor) | CXTPChartSeriesLabel |
SetTransparency(int nTransparency) | CXTPChartSeriesLabel |
SetVisible(BOOL bVisible) | CXTPChartSeriesLabel |
~CXTPChartElement() | CXTPChartElement | virtual
~CXTPChartPieSeriesLabelBase() | CXTPChartPieSeriesLabelBase | virtual
~CXTPChartSeriesLabel() | CXTPChartSeriesLabel | virtual


Toolkit Pro: XTPCommandBarsVisualStudio2012Theme.h Source File

  • Source
  • CommandBars
  • Themes
XTPCommandBarsVisualStudio2012Theme.h
Go to the documentation of this file.
1
23#if !defined(__XTPCOMMANDBARSVISUALSTUDIO2012THEME_H__)
24# define __XTPCOMMANDBARSVISUALSTUDIO2012THEME_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPCommandBarsColorSet;
34
42class _XTP_EXT_CLASS CXTPCommandBarsVisualStudio2012Theme : public CXTPCommandBarsModernUITheme
43{
45 DECLARE_DYNAMIC(CXTPCommandBarsVisualStudio2012Theme)
47public:
53 explicit CXTPCommandBarsVisualStudio2012Theme(
54 XTPPaintTheme paintTheme = xtpThemeVisualStudio2012Light);
55
61 virtual ~CXTPCommandBarsVisualStudio2012Theme();
62
63public:
68 virtual void RefreshMetrics();
69
70public:
80 virtual CSize DrawCommandBarGripper(CDC* pDC, CXTPCommandBar* pBar, BOOL bDraw = TRUE);
81
89 virtual COLORREF GetControlEditBackColor(CXTPControl* pControl);
90
91 virtual CSize DrawControlComboBox(CDC* pDC, CXTPControlComboBox* pControlCombo, BOOL bDraw);
92
99 virtual void FillDockBar(CDC* pDC, CXTPDockBar* pBar);
100
107 virtual void FillCommandBarEntry(CDC* pDC, CXTPCommandBar* pBar);
108
122 virtual void DrawRectangle(CDC* pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled,
123 BOOL bChecked, BOOL bPopuped, XTPBarType barType,
124 XTPBarPosition barPosition);
125
140 virtual void DrawRectangle(CDC* pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled,
141 BOOL bChecked, BOOL bPopuped, XTPBarType barType,
142 XTPBarPosition barPosition, int nID);
143
152 virtual BOOL DrawRectangle(CDC* pDC, CXTPControl* pButton);
153
166 virtual void DrawPopupBarGripper(CDC* pDC, int xPos, int yPos, int cx, int cy, BOOL bExpanded);
167
178 virtual void DrawExpandGlyph(CDC* pDC, CXTPControl* pButton, CPoint pt0, CPoint pt1, CPoint pt2,
179 COLORREF clr);
180
189 virtual void DrawExpandGlyph(CDC* pDC, CXTPControl* pButton, COLORREF clr, BOOL bVertical);
190
199 virtual void DrawHiddenGlyph(CDC* pDC, CXTPControl* pButton, COLORREF clr, BOOL bVertical);
200
212 virtual void DrawDropDownGlyph(CDC* pDC, CXTPControl* pControl, CPoint pt, BOOL bSelected,
213 BOOL bPopuped, BOOL bEnabled, BOOL bVert);
214
225 virtual CSize DrawCommandBarSeparator(CDC* pDC, CXTPCommandBar* pBar, CXTPControl* pControl,
226 BOOL bDraw = TRUE);
227
228 virtual void DrawCheckMark(CDC* pDC, CRect rcCheck, BOOL bIsRadio, BOOL bEnabled,
229 BOOL bSelected);
230
231 virtual COLORREF GetGlyphColor(CXTPControl* pControl);
232
241 virtual void DrawSplitButtonFrame(CDC* pDC, CXTPControl* pButton, CRect rc);
242
249 virtual XTPPaintTheme BaseTheme()
250 {
251 return xtpThemeVisualStudio2012;
252 }
253
254protected:
268 virtual CSize DrawControlCheckBoxMark(CDC* pDC, CRect rc, BOOL bDraw, BOOL bSelected,
269 BOOL bPressed, BOOL bChecked, BOOL bEnabled);
270
271 using CXTPCommandBarsModernUITheme::DrawControlCheckBoxMark;
272
273 virtual void DrawDashedLine(CDC* pDC, int x, int y1, int y2, COLORREF clr);
274 virtual BOOL RequiresResourceImages();
275 virtual void DrawControlPopupGlyph(CDC* pDC, CXTPControl* pButton);
276
277 static void AFX_CDECL FillRect(CDC* pDC, CRect rc, BOOL bCheckMark, COLORREF clrFore,
278 COLORREF clrBack);
279
280 CXTPCommandBarsColorSet* m_pColorSet;
281};
282
283AFX_INLINE BOOL CXTPCommandBarsVisualStudio2012Theme::RequiresResourceImages()
284{
285 return TRUE;
286}
287
289# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
290#endif // !defined(__XTPCOMMANDBARSVISUALSTUDIO2012THEME_H__)
XTPBarType
XTPBarType
Type of the command bar.
Definition XTPCommandBarsDefines.h:77
XTPBarPosition
XTPBarPosition
Position of the command bar.
Definition XTPCommandBarsDefines.h:52
XTPPaintTheme
XTPPaintTheme
Paint themes used by command bars.
Definition XTPCommandBarsDefines.h:233
xtpThemeVisualStudio2012
@ xtpThemeVisualStudio2012
Visual Studio 2012 theme, uses INI file.
Definition XTPCommandBarsDefines.h:249
xtpThemeVisualStudio2012Light
@ xtpThemeVisualStudio2012Light
Visual Studio 2012 light theme.
Definition XTPCommandBarsDefines.h:250
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCommandBar
CXTPCommandBar is a CWnd derived class.
Definition XTPCommandBar.h:66
CXTPCommandBarsModernUITheme
The CXTPCommandBarsModernUITheme class is the base class for the Modern UI themes for Command Bars.
Definition XTPCommandBarsModernUITheme.h:41
CXTPCommandBarsOfficeXPTheme::DrawControlCheckBoxMark
virtual CSize DrawControlCheckBoxMark(CDC *pDC, CRect rc, BOOL bDraw, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled)
This method is called to draw a check box mark area.
CXTPCommandBarsVisualStudio2012Theme
The CXTPCommandBarsVisualStudio2012Theme class is used to enable a Visual Studio 2012 theme for Comma...
Definition XTPCommandBarsVisualStudio2012Theme.h:43
CXTPCommandBarsVisualStudio2012Theme::DrawPopupBarGripper
virtual void DrawPopupBarGripper(CDC *pDC, int xPos, int yPos, int cx, int cy, BOOL bExpanded)
This method is called to draw a pop-up bar's right gripper.
CXTPCommandBarsVisualStudio2012Theme::RequiresResourceImages
virtual BOOL RequiresResourceImages()
Used by the paint manager to determine if the theme requires a resource DLL to load image and color i...
Definition XTPCommandBarsVisualStudio2012Theme.h:283
CXTPCommandBarsVisualStudio2012Theme::DrawCommandBarGripper
virtual CSize DrawCommandBarGripper(CDC *pDC, CXTPCommandBar *pBar, BOOL bDraw=TRUE)
This method is called to draw the command bar's gripper.
CXTPCommandBarsVisualStudio2012Theme::DrawExpandGlyph
virtual void DrawExpandGlyph(CDC *pDC, CXTPControl *pButton, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clr)
Draw expand or hidden glyphs for a button.
CXTPCommandBarsVisualStudio2012Theme::~CXTPCommandBarsVisualStudio2012Theme
virtual ~CXTPCommandBarsVisualStudio2012Theme()
Destroys a CXTPCommandBarsVisualStudio2012Theme object, handles cleanup and deallocation.
CXTPCommandBarsVisualStudio2012Theme::DrawSplitButtonFrame
virtual void DrawSplitButtonFrame(CDC *pDC, CXTPControl *pButton, CRect rc)
This method is called to draw the frame for the SplitButton control.
CXTPCommandBarsVisualStudio2012Theme::GetControlEditBackColor
virtual COLORREF GetControlEditBackColor(CXTPControl *pControl)
This method returns the edit control back color to draw.
CXTPCommandBarsVisualStudio2012Theme::DrawExpandGlyph
virtual void DrawExpandGlyph(CDC *pDC, CXTPControl *pButton, COLORREF clr, BOOL bVertical)
Draw expand or hidden glyphs for a button.
CXTPCommandBarsVisualStudio2012Theme::DrawRectangle
virtual BOOL DrawRectangle(CDC *pDC, CXTPControl *pButton)
This method is called to fill the control's face.
CXTPCommandBarsVisualStudio2012Theme::CXTPCommandBarsVisualStudio2012Theme
CXTPCommandBarsVisualStudio2012Theme(XTPPaintTheme paintTheme=xtpThemeVisualStudio2012Light)
Constructs a CXTPCommandBarsVisualStudio2012Theme object.
CXTPCommandBarsVisualStudio2012Theme::DrawHiddenGlyph
virtual void DrawHiddenGlyph(CDC *pDC, CXTPControl *pButton, COLORREF clr, BOOL bVertical)
Draw expand or hidden glyphs for a button.
CXTPCommandBarsVisualStudio2012Theme::FillCommandBarEntry
virtual void FillCommandBarEntry(CDC *pDC, CXTPCommandBar *pBar)
This method is called to fill the command bar's face.
CXTPCommandBarsVisualStudio2012Theme::DrawControlComboBox
virtual CSize DrawControlComboBox(CDC *pDC, CXTPControlComboBox *pControlCombo, BOOL bDraw)
This method is called to draw the control.
CXTPCommandBarsVisualStudio2012Theme::DrawControlCheckBoxMark
virtual CSize DrawControlCheckBoxMark(CDC *pDC, CRect rc, BOOL bDraw, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled)
This method is called to draw a check box mark area.
CXTPCommandBarsVisualStudio2012Theme::DrawDropDownGlyph
virtual void DrawDropDownGlyph(CDC *pDC, CXTPControl *pControl, CPoint pt, BOOL bSelected, BOOL bPopuped, BOOL bEnabled, BOOL bVert)
This member function is called to draw a split button expand symbol.
CXTPCommandBarsVisualStudio2012Theme::BaseTheme
virtual XTPPaintTheme BaseTheme()
Retrieves the base theme of the manager.
Definition XTPCommandBarsVisualStudio2012Theme.h:249
CXTPCommandBarsVisualStudio2012Theme::RefreshMetrics
virtual void RefreshMetrics()
This method is called to refresh the visual metrics of the manager.
CXTPCommandBarsVisualStudio2012Theme::DrawRectangle
virtual void DrawRectangle(CDC *pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition)
This method is called to fill the control's face.
CXTPCommandBarsVisualStudio2012Theme::DrawRectangle
virtual void DrawRectangle(CDC *pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition, int nID)
This method is called to fill the control's face.
CXTPCommandBarsVisualStudio2012Theme::DrawCommandBarSeparator
virtual CSize DrawCommandBarSeparator(CDC *pDC, CXTPCommandBar *pBar, CXTPControl *pControl, BOOL bDraw=TRUE)
This method is called to draw a command bar's separator.
CXTPCommandBarsVisualStudio2012Theme::FillDockBar
virtual void FillDockBar(CDC *pDC, CXTPDockBar *pBar)
This method is called to fill a dock bar.
CXTPControlComboBox
CXTPControlComboBox is a CXTPControl derived class.
Definition XTPControlComboBox.h:381
CXTPControl
CXTPControl is a CXTPCmdTarget derived class.
Definition XTPControl.h:841
CXTPDockBar
CXTPDockBar is a CWnd derived class.
Definition XTPDockBar.h:42
CXTPPaintManager::RequiresResourceImages
virtual BOOL RequiresResourceImages()
Used by the paint manager to determine if the theme requires a resource DLL to load image and color i...
Definition XTPPaintManager.h:1842


Toolkit Pro: XTPMessageBarThemeNativeWindows10.h Source File

  • Source
  • CommandBars
  • MessageBar
XTPMessageBarThemeNativeWindows10.h
Go to the documentation of this file.
1
23#if !defined(__XTPMESSAGEBARTHEMENATIVEWINDOWS10_H__)
24# define __XTPMESSAGEBARTHEMENATIVEWINDOWS10_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPPaintManager;
34class CXTPMessageBar;
35class CXTPMessageBarButton;
36
42class _XTP_EXT_CLASS CXTPMessageBarThemeNativeWindows10 : public CXTPMessageBarThemeOffice2013
43{
44public:
50 CXTPMessageBarThemeNativeWindows10(CXTPPaintManager* pPaintManager);
51};
52
54# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
55#endif // !defined(__XTPMESSAGEBARTHEMENATIVEWINDOWS10_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPMessageBarButton
CXTPMessageBarButton is a standalone class.
Definition XTPMessageBar.h:48
CXTPMessageBar
CXTPMessageBar is a CControlBar derived class.
Definition XTPMessageBar.h:88
CXTPMessageBarThemeNativeWindows10
The CXTPMessageBarThemeNativeWindows10 class is used by the message bar to draw a Native Windows 10 s...
Definition XTPMessageBarThemeNativeWindows10.h:43
CXTPMessageBarThemeNativeWindows10::CXTPMessageBarThemeNativeWindows10
CXTPMessageBarThemeNativeWindows10(CXTPPaintManager *pPaintManager)
Message bar constructor.
CXTPMessageBarThemeOffice2013
The CXTPMessageBarThemeOffice2013 class is used by the message bar to draw an Office 2013 style messa...
Definition XTPMessageBarThemeOffice2013.h:43
CXTPPaintManager
Paint manager of the command bars.
Definition XTPPaintManager.h:199


Toolkit Pro: Member List

CXTPChartFinanceStyleAppearance Member List

This is the complete list of members for CXTPChartFinanceStyleAppearance, including all inherited members.

ApplyToDeviceContext(CXTPChartDeviceContext *pDC) | CXTPChartElementAppearance | virtual
CXTPChartElement() | CXTPChartElement |
CXTPChartElementAppearance(CXTPChartElement *pOwner) | CXTPChartElementAppearance |
CXTPChartFinanceStyleAppearance(CXTPChartElement *pOwner) | CXTPChartFinanceStyleAppearance |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
DoPropExchange(CXTPPropExchange *pPX) | CXTPChartFinanceStyleAppearance | virtual
DownColor | CXTPChartFinanceStyleAppearance |
GetAppearance() const | CXTPChartElement |
GetContent() const | CXTPChartElement |
GetOwner() const | CXTPChartElement |
Is3D() const | CXTPChartObject |
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartElement | virtual
Release() | CXTPChartElement | virtual
UpColor | CXTPChartFinanceStyleAppearance |
~CXTPChartElement() | CXTPChartElement | virtual
~CXTPChartElementAppearance() | CXTPChartElementAppearance | virtual
~CXTPChartFinanceStyleAppearance() | CXTPChartFinanceStyleAppearance | virtual


Toolkit Pro: XTPRibbonBackstageButtonThemeOffice2013.h Source File

  • Source
  • Ribbon
  • Backstage
XTPRibbonBackstageButtonThemeOffice2013.h
Go to the documentation of this file.
1
23#if !defined(__XTPRIBBONBACKSTAGEBUTTONTHEMEOFFICE2013T_H__)
24# define __XTPRIBBONBACKSTAGEBUTTONTHEMEOFFICE2013T_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class _XTP_EXT_CLASS CXTPRibbonBackstageButtonThemeOffice2013 : public CXTPButtonThemeOffice2013
34{
35public:
36 CXTPRibbonBackstageButtonThemeOffice2013();
37
38public:
39 void DrawButtonBackground(CDC* pDC, CXTPButton* pButton);
40 virtual void DrawButton(CDC* pDC, CXTPButton* pButton);
41
42protected:
43 friend class CBackstageButtonCtrl;
44};
45
46# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
48#endif // !defined(__XTPRIBBONBACKSTAGEBUTTONTHEMEOFFICE2013T_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPButton
Push Button control.
Definition XTPButton.h:109
CXTPButtonTheme::DrawButton
virtual void DrawButton(CDC *pDC, CXTPButton *pButton)
This member function is called to the button.
CXTPButtonThemeOffice2013
CXTPButtonThemeOffice2013 is a class used to perform Office 2013 theme drawing tasks.
Definition XTPButtonThemeOffice2013.h:39
CXTPButtonThemeOffice2013::DrawButtonBackground
virtual void DrawButtonBackground(CDC *pDC, CXTPButton *pButton)
This member function is called to draw the background for the button.


Toolkit Pro: Member List

CXTPColorPageStandard Member List

This is the complete list of members for CXTPColorPageStandard, including all inherited members.

CXTPColorPageStandard(CXTPColorDialog *pParentSheet=NULL) | CXTPColorPageStandard |
m_colorHex | CXTPColorPageStandard | protected
m_pParentSheet | CXTPColorPageStandard | protected
SetColor(COLORREF clr) | CXTPColorPageStandard |
~CXTPColorPageStandard() | CXTPColorPageStandard | virtual


Toolkit Pro: Member List

  • CXTPCalendarView
  • SEventTimeFormatInfo
CXTPCalendarView::SEventTimeFormatInfo Member List

This is the complete list of members for CXTPCalendarView::SEventTimeFormatInfo, including all inherited members.

b24_HFormat | CXTPCalendarView::SEventTimeFormatInfo |
SEventTimeFormatInfo() | CXTPCalendarView::SEventTimeFormatInfo | inline
strAM | CXTPCalendarView::SEventTimeFormatInfo |
strFormat | CXTPCalendarView::SEventTimeFormatInfo |
strPM | CXTPCalendarView::SEventTimeFormatInfo |


Toolkit Pro: XTPListBoxThemeVisualStudio2015.h Source File

  • Source
  • Controls
  • ListBox
  • Themes
XTPListBoxThemeVisualStudio2015.h
Go to the documentation of this file.
1
23#if !defined(__XTPLISTBOXTHEMEVISUALSTUDIO2015_H__)
24# define __XTPLISTBOXTHEMEVISUALSTUDIO2015_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPListBoxThemeVisualStudio2015 : public CXTPListBoxThemeOffice2013
39{
40public:
45 CXTPListBoxThemeVisualStudio2015();
46};
47
48# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
50#endif // !defined(__XTPLISTBOXTHEMEVISUALSTUDIO2015_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPListBoxThemeOffice2013
CXTPListBoxThemeOffice2013 is used by CXTPListBox to draw an Office 2013 style list box.
Definition XTPListBoxThemeOffice2013.h:39
CXTPListBoxThemeVisualStudio2015
CXTPListBoxThemeVisualStudio2015 is used by CXTPListBox to draw a Visual Studio 2015 style list box.
Definition XTPListBoxThemeVisualStudio2015.h:39
CXTPListBoxThemeVisualStudio2015::CXTPListBoxThemeVisualStudio2015
CXTPListBoxThemeVisualStudio2015()
Default constructor.


Toolkit Pro: Member List

CXTPSyntaxEditLexClass Member List

This is the complete list of members for CXTPSyntaxEditLexClass, including all inherited members.

Close() | CXTPSyntaxEditLexClass | virtual
CloseClasses(CXTPSyntaxEditLexClassPtrArray *pArClasses) | CXTPSyntaxEditLexClass | static
CXTPCmdTarget() | CXTPCmdTarget |
CXTPSyntaxEditLexClass() | CXTPSyntaxEditLexClass |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetActiveTags() | CXTPSyntaxEditLexClass | protectedvirtual
GetAttribute(LPCTSTR strName, BOOL bDyn) const | CXTPSyntaxEditLexClass | virtual
GetAttribute_BOOL(LPCTSTR strName, BOOL bDyn, BOOL bDefault=FALSE) const | CXTPSyntaxEditLexClass | virtual
GetAttribute_int(LPCTSTR strName, BOOL bDyn, int nDefault=0) const | CXTPSyntaxEditLexClass | virtual
GetChildren() | CXTPSyntaxEditLexClass | protectedvirtual
GetChildrenDyn() | CXTPSyntaxEditLexClass | protectedvirtual
GetChildrenSelfRef() | CXTPSyntaxEditLexClass | protectedvirtual
GetClassName() const | CXTPSyntaxEditLexClass | virtual
GetTextAttributes(XTP_EDIT_TEXTBLOCK &rTB) | CXTPSyntaxEditLexClass | virtual
IsCaseSensitive() | CXTPSyntaxEditLexClass | virtual
IsCollapsable() | CXTPSyntaxEditLexClass | virtual
m_nActiv_EndTags_Offset | CXTPSyntaxEditLexClass |
PropV(LPCTSTR pcszPropName) | CXTPSyntaxEditLexClass | virtual
RunParse(CTextIter *pTxtIter, CXTPSyntaxEditLexTextSchema *pTxtSch, CXTPSyntaxEditLexTextBlockPtr &rPtrTxtBlock, CXTPSyntaxEditLexOnScreenParseCnt *pOnScreenRunCnt=NULL) | CXTPSyntaxEditLexClass | protectedvirtual
SetAttribute(CString strName, const CXTPSyntaxEditLexVariant &rVal) | CXTPSyntaxEditLexClass | protectedvirtual
TBase typedef | CXTPSyntaxEditLexClass |
~CXTPSyntaxEditLexClass() | CXTPSyntaxEditLexClass | virtual


Toolkit Pro: Member List

  • CXTPShellPidl
  • CShellSpecialFolder
CXTPShellPidl::CShellSpecialFolder Member List

This is the complete list of members for CXTPShellPidl::CShellSpecialFolder, including all inherited members.

CShellSpecialFolder(int nFolder=CSIDL_DESKTOP) | CXTPShellPidl::CShellSpecialFolder |
m_lpFolder | CXTPShellPidl::CShellSpecialFolder | protected
operator LPSHELLFOLDER() | CXTPShellPidl::CShellSpecialFolder | inline
~CShellSpecialFolder() | CXTPShellPidl::CShellSpecialFolder | inlinevirtual


Toolkit Pro: Member List

CXTPTabManagerNavigateButton Member List

This is the complete list of members for CXTPTabManagerNavigateButton, including all inherited members.

AdjustWidth(int &nWidth) | CXTPTabManagerNavigateButton | virtual
CXTPTabManagerNavigateButton(CXTPTabManager *pManager, UINT nID, XTPTabNavigateButtonFlags dwFlags) | CXTPTabManagerNavigateButton |
Draw(CDC *pDC) | CXTPTabManagerNavigateButton |
DrawEntry(CDC *pDC, CRect rc, COLORREF clr, BOOL bEnabled)=0 | CXTPTabManagerNavigateButton | pure virtual
GetFlags() const | CXTPTabManagerNavigateButton |
GetID() const | CXTPTabManagerNavigateButton |
GetItem() const | CXTPTabManagerNavigateButton |
GetRect() const | CXTPTabManagerNavigateButton |
GetSize() const | CXTPTabManagerNavigateButton | virtual
GetTooltip() const | CXTPTabManagerNavigateButton |
IsEnabled() const | CXTPTabManagerNavigateButton |
IsHighlighted() const | CXTPTabManagerNavigateButton |
IsOwnerActive() const | CXTPTabManagerNavigateButton |
IsOwnerHighlighted() const | CXTPTabManagerNavigateButton |
IsOwnerNull() const | CXTPTabManagerNavigateButton |
IsOwnerSelected() const | CXTPTabManagerNavigateButton |
IsPressed() const | CXTPTabManagerNavigateButton |
IsVisible() const | CXTPTabManagerNavigateButton |
m_bEnabled | CXTPTabManagerNavigateButton | protected
m_bPressed | CXTPTabManagerNavigateButton | protected
m_dwFlags | CXTPTabManagerNavigateButton | protected
m_nID | CXTPTabManagerNavigateButton | protected
m_pItem | CXTPTabManagerNavigateButton | protected
m_pManager | CXTPTabManagerNavigateButton | protected
m_rcButton | CXTPTabManagerNavigateButton | protected
m_strToolTip | CXTPTabManagerNavigateButton | protected
OnExecute(BOOL bTick) | CXTPTabManagerNavigateButton | virtual
PerformClick(HWND hWnd, CPoint pt) | CXTPTabManagerNavigateButton | virtual
Reposition(CRect &rcNavigateButtons) | CXTPTabManagerNavigateButton | virtual
SetFlags(XTPTabNavigateButtonFlags dwFlags) | CXTPTabManagerNavigateButton |
SetRect(CRect rcButton) | CXTPTabManagerNavigateButton |
SetTooltip(LPCTSTR lpszTooltip) | CXTPTabManagerNavigateButton |
~CXTPTabManagerNavigateButton() | CXTPTabManagerNavigateButton | protectedvirtual


Toolkit Pro: XTPEditThemeDefault.h Source File

  • Source
  • Controls
  • Edit
  • Themes
XTPEditThemeDefault.h
Go to the documentation of this file.
1
23#if !defined(__XTPEDITTHEMEDEFAULT_H__)
24# define __XTPEDITTHEMEDEFAULT_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
37class _XTP_EXT_CLASS CXTPEditThemeDefault : public CXTPEditTheme
38{
39public:
44 CXTPEditThemeDefault();
45
50 virtual ~CXTPEditThemeDefault();
51
58 virtual void RefreshMetrics(CXTPEdit* pEdit);
59
68 virtual void DrawNcBorders(CDC* pDC, CRect rcWnd, CXTPEdit* pEdit);
69
78 virtual void DrawNcScrollBack(CDC* pDC, CRect rcWnd, CXTPEdit* pEdit);
79
91 virtual CBrush* CtlColor(CDC* pDC, UINT nCtlColor, CXTPEdit* pEdit);
92
104 virtual BOOL AdjustBuddyRect(CWnd* pBuddy, CRect& rcUpDown, int nAlignment);
105
117 virtual void DrawBuddyBorders(CWnd* pBuddy, CDC* pDC, CRect rc, int nAlignment,
118 CXTPEdit* pEdit);
119
120protected:
133 virtual BOOL DrawBuddyBorders(CDC* pDC, CRect rc, int nAlignment, CXTPEdit* pEdit);
134
145 virtual BOOL DrawNcBordersDefault(CDC* pDC, CRect rcWnd, CXTPEdit* pEdit);
146};
147
148# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
150#endif // __XTPEDITTHEMEDEFAULT_H__
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPEdit
CXTPEdit is a CEdit derived class.
Definition XTPEdit.h:129
CXTPEditThemeDefault
CXTPEditThemeDefault is a class used to perform theme drawing tasks.
Definition XTPEditThemeDefault.h:38
CXTPEditThemeDefault::DrawNcBordersDefault
virtual BOOL DrawNcBordersDefault(CDC *pDC, CRect rcWnd, CXTPEdit *pEdit)
Called by the paint-manager to perform Windows default border drawing for the non-client area of the ...
CXTPEditThemeDefault::AdjustBuddyRect
virtual BOOL AdjustBuddyRect(CWnd *pBuddy, CRect &rcUpDown, int nAlignment)
Called by the framework to adjust the size of the area to draw the buddy control borders on.
CXTPEditThemeDefault::~CXTPEditThemeDefault
virtual ~CXTPEditThemeDefault()
Destructor, handles cleanup and deallocation.
CXTPEditThemeDefault::DrawNcScrollBack
virtual void DrawNcScrollBack(CDC *pDC, CRect rcWnd, CXTPEdit *pEdit)
Called by the framework to draw the non-client background for the combobox scrollbar area.
CXTPEditThemeDefault::DrawBuddyBorders
virtual void DrawBuddyBorders(CWnd *pBuddy, CDC *pDC, CRect rc, int nAlignment, CXTPEdit *pEdit)
Called by the framework to draw the borders for the associated buddy window.
CXTPEditThemeDefault::CtlColor
virtual CBrush * CtlColor(CDC *pDC, UINT nCtlColor, CXTPEdit *pEdit)
Called by the framework to handle setting the text and background colors for the edit control.
CXTPEditThemeDefault::CXTPEditThemeDefault
CXTPEditThemeDefault()
Constructs a CXTPEditThemeDefault object.
CXTPEditThemeDefault::DrawNcBorders
virtual void DrawNcBorders(CDC *pDC, CRect rcWnd, CXTPEdit *pEdit)
This member function is called by the theme manager to draw non-client borders for the edit control.
CXTPEditThemeDefault::DrawBuddyBorders
virtual BOOL DrawBuddyBorders(CDC *pDC, CRect rc, int nAlignment, CXTPEdit *pEdit)
Called by the paint-manager to draw the borders for the associated buddy window.
CXTPEditThemeDefault::RefreshMetrics
virtual void RefreshMetrics(CXTPEdit *pEdit)
This member function is called by the theme manager to refresh the visual styles used by each compone...
CXTPEditTheme
CXTPEditTheme is the base class for all edit themes used to perform drawing tasks.
Definition XTPEditTheme.h:42


Toolkit Pro: XTPCalendarCaptionBarResourceTheme.h Source File

  • Source
  • Calendar
  • CaptionBar
  • Themes
XTPCalendarCaptionBarResourceTheme.h
Go to the documentation of this file.
1
22#if !defined(__XTPCALENDARCAPTIONBARRESOURCETHEME_H__)
23# define __XTPCALENDARCAPTIONBARRESOURCETHEME_H__
24
25# if _MSC_VER > 1000
26# pragma once
27# endif // _MSC_VER > 1000
28
29# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
30
36class _XTP_EXT_CLASS CXTPCalendarCaptionBarResourceTheme
37 : public CXTPCalendarCaptionBarOffice2013Theme
38{
39public:
48 CXTPCalendarCaptionBarResourceTheme(CXTPCalendarCaptionBarTheme* pTheme = NULL);
49
56 virtual ~CXTPCalendarCaptionBarResourceTheme();
57
63 virtual void RefreshMetrics();
64
74 virtual COLORREF GetColor2(LPCTSTR pcszColorName, COLORREF clrDefault);
75
76 virtual void PartAdjustLayout(CXTPExpandButtonPart* pBarPart, CDC* /*pDC*/,
77 const CRect& rcRect);
78 virtual void PartDraw(CXTPSwitchViewButtonPart* pBarPart, CDC* pDC);
79 virtual void PartDraw(CXTPScrollDateButtonPart* pBarPart, CDC* pDC);
80 virtual void PartDraw(CXTPDateLabelPart* pBarPart, CDC* pDC);
81 virtual void PartDraw(CXTPExpandButtonPart* pBarPart, CDC* pDC);
82
83protected:
84 virtual CXTPResourceImage* GetResourceImage(LPCTSTR lpszImageFile);
85};
86
87# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
88#endif // !defined(__XTPCALENDARCAPTIONBARRESOURCETHEME_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCalendarCaptionBarOffice2013Theme
CXTPCalendarCaptionBarOffice2013Theme is a CXTPCalendarCaptionBarOffice2003Theme derived class that r...
Definition XTPCalendarCaptionBarOffice2013Theme.h:38
CXTPCalendarCaptionBarResourceTheme
CXTPCalendarCaptionBarResourceTheme is a CXTPCalendarCaptionBarOffice2013Theme derived class that rep...
Definition XTPCalendarCaptionBarResourceTheme.h:38
CXTPCalendarCaptionBarResourceTheme::GetColor2
virtual COLORREF GetColor2(LPCTSTR pcszColorName, COLORREF clrDefault)
This member function is used to read color by name from resources.
CXTPCalendarCaptionBarResourceTheme::~CXTPCalendarCaptionBarResourceTheme
virtual ~CXTPCalendarCaptionBarResourceTheme()
Default paint manager destructor.
CXTPCalendarCaptionBarResourceTheme::CXTPCalendarCaptionBarResourceTheme
CXTPCalendarCaptionBarResourceTheme(CXTPCalendarCaptionBarTheme *pTheme=NULL)
Default paint manager constructor.
CXTPCalendarCaptionBarResourceTheme::RefreshMetrics
virtual void RefreshMetrics()
Performs refreshing of graphical related parameters from system settings.
CXTPCalendarCaptionBarTheme
This class CalendarCaptionBar control drawing, user interaction logic and interaction logic with atta...
Definition XTPCalendarCaptionBarTheme.h:48
CXTPDateLabelPart
This class implements Date Label part of the ScrollDateBar.
Definition XTPCalendarCaptionBarThemePart.h:407
CXTPExpandButtonPart
This class implements Expand button part of the ScrollDateBar.
Definition XTPCalendarCaptionBarThemePart.h:429
CXTPResourceImage
Represent a resource image and provides basic images functions.
Definition XTPResourceImage.h:48
CXTPScrollDateButtonPart
This class implements Scroll Date button part of the ScrollDateBar.
Definition XTPCalendarCaptionBarThemePart.h:383
CXTPSwitchViewButtonPart
This class implements SwitchView button part of the SwitchViewBar.
Definition XTPCalendarCaptionBarThemePart.h:333


Toolkit Pro: XTPDockingPaneTabThemeNativeWindows10.h Source File

  • Source
  • DockingPane
  • TabThemes
XTPDockingPaneTabThemeNativeWindows10.h
Go to the documentation of this file.
1
23#if !defined(__XTPDOCKINGPANETABTHEMENATIVEWINDOWS10_H__)
24# define __XTPDOCKINGPANETABTHEMENATIVEWINDOWS10_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPDockingPaneTabThemeNativeWindows10 : public CXTPDockingPaneTabTheme2012
39{
40public:
45 CXTPDockingPaneTabThemeNativeWindows10();
46
63 virtual void DrawSingleButton(CDC* pDC, CXTPTabManagerItem* pItem);
64};
65
66# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
68#endif // !defined(__XTPDOCKINGPANETABTHEMENATIVEWINDOWS10_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPDockingPaneTabTheme2012
Helper class used to initialize default colors for a theme from an .INI resource and handle drawing r...
Definition XTPDockingPaneTabTheme2012.h:39
CXTPDockingPaneTabThemeNativeWindows10
Helper class used to initialize default colors for a theme from an .INI resource and handle drawing r...
Definition XTPDockingPaneTabThemeNativeWindows10.h:39
CXTPDockingPaneTabThemeNativeWindows10::CXTPDockingPaneTabThemeNativeWindows10
CXTPDockingPaneTabThemeNativeWindows10()
Default class constructor.
CXTPDockingPaneTabThemeNativeWindows10::DrawSingleButton
virtual void DrawSingleButton(CDC *pDC, CXTPTabManagerItem *pItem)
This method is called to draw a single tab button in the tab client header area.
CXTPTabManagerItem
CXTPTabManagerItem is the base class for the tabs that appear in the command bars tab workspace,...
Definition XTPTabManagerItem.h:44


Toolkit Pro: Member List

CXTPProgressCtrlThemeOffice2013 Member List

This is the complete list of members for CXTPProgressCtrlThemeOffice2013, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPProgressCtrlPaintManager() | CXTPProgressCtrlPaintManager |
CXTPProgressCtrlThemeOffice2000() | CXTPProgressCtrlThemeOffice2000 |
CXTPProgressCtrlThemeOffice2013() | CXTPProgressCtrlThemeOffice2013 |
DeflateRect(XTPPROGRESSDRAWSTRUCT &ds) | CXTPProgressCtrlPaintManager | protectedvirtual
Draw(XTPPROGRESSDRAWSTRUCT &ds) | CXTPProgressCtrlThemeOffice2013 | virtual
DrawNcBorders(CDC *pDC, CRect rc) | CXTPProgressCtrlThemeOffice2013 | virtual
DrawText(XTPPROGRESSDRAWSTRUCT &ds) | CXTPProgressCtrlPaintManager | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetBackColor() | CXTPProgressCtrlPaintManager |
GetBarColor() | CXTPProgressCtrlPaintManager |
GetBorderColor() | CXTPProgressCtrlPaintManager |
GetTextColor() | CXTPProgressCtrlPaintManager |
m_bUseWinTheme | CXTPProgressCtrlPaintManager | protected
m_clrBack | CXTPProgressCtrlPaintManager | protected
m_clrBar | CXTPProgressCtrlPaintManager | protected
m_clrBarText | CXTPProgressCtrlPaintManager | protected
m_clrBorder | CXTPProgressCtrlPaintManager | protected
m_clrText | CXTPProgressCtrlPaintManager | protected
m_nTheme | CXTPProgressCtrlPaintManager | protected
m_winTheme | CXTPProgressCtrlPaintManager | protected
RefreshMetrics() | CXTPProgressCtrlThemeOffice2013 | virtual
SetBackColor(COLORREF clrNew) | CXTPProgressCtrlPaintManager |
SetBarColor(COLORREF clrNew) | CXTPProgressCtrlPaintManager |
SetBorderColor(COLORREF clrNew) | CXTPProgressCtrlPaintManager |
SetTextColor(COLORREF clrNew) | CXTPProgressCtrlPaintManager |
UseWinThemes(BOOL bUseWinThemes=TRUE) | CXTPProgressCtrlPaintManager |
UsingWinThemes(BOOL bCheckReady=FALSE) | CXTPProgressCtrlPaintManager |
~CXTPProgressCtrlPaintManager() | CXTPProgressCtrlPaintManager | virtual


Toolkit Pro: XTPTaskPanelOffice2003Theme.h Source File

  • Source
  • TaskPanel
  • Themes
XTPTaskPanelOffice2003Theme.h
Go to the documentation of this file.
1
23#ifndef XTPTaskPanelOffice2003Theme_h__
24# define XTPTaskPanelOffice2003Theme_h__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
39class _XTP_EXT_CLASS CXTPTaskPanelOffice2003Theme : public CXTPTaskPanelPaintManager
40{
41public:
46 CXTPTaskPanelOffice2003Theme();
47
52 void RefreshMetrics();
53};
55# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
56#endif // XTPTaskPanelOffice2003Theme_h__
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPTaskPanelOffice2003Theme
CXTPTaskPanelOffice2003Theme represents an Office 2003 style theme.
Definition XTPTaskPanelOffice2003Theme.h:40
CXTPTaskPanelOffice2003Theme::CXTPTaskPanelOffice2003Theme
CXTPTaskPanelOffice2003Theme()
Constructs a CXTPTaskPanelOffice2003Theme object.
CXTPTaskPanelOffice2003Theme::RefreshMetrics
void RefreshMetrics()
Refreshes the visual metrics of the task panel.
CXTPTaskPanelPaintManager
CXTPTaskPanelPaintManager is a standalone class used by CXTPTaskPanel as a paint manager.
Definition XTPTaskPanelPaintManager.h:115


Toolkit Pro: Member List

CXTPChartTextDeviceCommand Member List

This is the complete list of members for CXTPChartTextDeviceCommand, including all inherited members.

AddChildCommand(CXTPChartDeviceCommand *pCommand) | CXTPChartDeviceCommand |
AfterExecute(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
ApplySeriesStyle(CXTPChartSeriesStyle *pStyle) | CXTPChartDeviceCommand | virtual
BeforeExecute(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
BindView(CXTPChartElementView *pView) | CXTPChartDeviceCommand |
Commit() | CXTPChartDeviceCommand |
CXTPChartDeviceCommand() | CXTPChartDeviceCommand |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartTextDeviceCommand(const CXTPChartString &strText, CXTPChartFont *pFont, const CXTPChartColor &color) | CXTPChartTextDeviceCommand | protected
CXTPObservable() | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | protected
Execute(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
ExecuteInternal(CXTPChartDeviceContext *pDC) | CXTPChartTextDeviceCommand | protectedvirtual
ExecuteOverride(CXTPChartDeviceContext *pDC) | CXTPChartTextDeviceCommand | protectedvirtual
GetBoundView() const | CXTPChartDeviceCommand |
GetChildCommand(int nIndex) const | CXTPChartDeviceCommand |
GetChildCommandCount() const | CXTPChartDeviceCommand |
GetCurrentDC() const | CXTPChartDeviceCommand |
GetPassNumber() const | CXTPChartDeviceCommand |
HitTest(CPoint point, CXTPChartElement *pParent) const | CXTPChartDeviceCommand | virtual
Is3D() const | CXTPChartObject |
IsCommitted() const | CXTPChartDeviceCommand |
IsEnabled() const | CXTPChartDeviceCommand | virtual
m_arrChildren | CXTPChartDeviceCommand | protected
m_color | CXTPChartTextDeviceCommand | protected
m_pFont | CXTPChartTextDeviceCommand | protected
m_strText | CXTPChartTextDeviceCommand | protected
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Prepare(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
PrepareOverride(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
SetEnabled(BOOL bEnabled=TRUE) | CXTPChartDeviceCommand |
Subscribe(CXTPChartDeviceCommandEvents *pObserver, CXTPSubscriptionList< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > *pSubcriptionList=NULL) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > |
Unsubscribe(CXTPChartDeviceCommandEvents *pObserver) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > |
~CXTPChartDeviceCommand() | CXTPChartDeviceCommand | virtual
~CXTPObservable() | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | protected


Toolkit Pro: Member List

CXTPFlowGraphUndoAddNodeCommand Member List

This is the complete list of members for CXTPFlowGraphUndoAddNodeCommand, including all inherited members.

CXTPFlowGraphUndoAddNodeCommand(CXTPFlowGraphNode *pNode) | CXTPFlowGraphUndoAddNodeCommand |
CXTPFlowGraphUndoCommand(int nID) | CXTPFlowGraphUndoCommand | protected
GetID() const | CXTPFlowGraphUndoCommand |
m_nID | CXTPFlowGraphUndoCommand | protected
m_pNode | CXTPFlowGraphUndoAddNodeCommand | protected
Undo() | CXTPFlowGraphUndoAddNodeCommand | protectedvirtual
~CXTPFlowGraphUndoAddNodeCommand() | CXTPFlowGraphUndoAddNodeCommand | virtual
~CXTPFlowGraphUndoCommand() | CXTPFlowGraphUndoCommand | protectedvirtual


Toolkit Pro: Member List

CXTPChartSeriesPointView Member List

This is the complete list of members for CXTPChartSeriesPointView, including all inherited members.

AddChildView(CXTPChartElementView *pChildView) | CXTPChartElementView |
CreateDeviceCommand(CXTPChartDeviceContext *pDC) | CXTPChartElementView | virtual
CreateLegendDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcBounds) | CXTPChartSeriesPointView | virtual
CXTPChartElementView(CXTPChartElementView *pParentView) | CXTPChartElementView |
CXTPChartElementView(CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartElementView |
CXTPChartElementView(CXTPChartContainer *pContainer) | CXTPChartElementView |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartSeriesPointView(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView) | CXTPChartSeriesPointView |
CXTPChartSeriesPointView(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartSeriesPointView |
GetAt(int nIndex) const | CXTPChartElementView |
GetBounds() const | CXTPChartElementView |
GetBounds(BOOL bIncludingChildren) const | CXTPChartElementView |
GetChildren() | CXTPChartElementView |
GetColor() const | CXTPChartSeriesPointView |
GetColor2() const | CXTPChartSeriesPointView |
GetCount() const | CXTPChartElementView |
GetInternalValue() const | CXTPChartSeriesPointView |
GetLegendName() const | CXTPChartSeriesPointView | virtual
GetParentView() const | CXTPChartElementView |
GetPoint() const | CXTPChartSeriesPointView |
GetSeriesView() const | CXTPChartSeriesPointView |
Is3D() const | CXTPChartObject |
m_arrChildren | CXTPChartElementView | protected
m_dInternalValue | CXTPChartSeriesPointView |
m_pContainer | CXTPChartElementView | protected
m_pParentView | CXTPChartElementView | protected
m_pPoint | CXTPChartSeriesPointView | protected
m_rcBounds | CXTPChartElementView | protected
UpdateMinMaxRange(double &nMinValue, double &nMaxValue) const | CXTPChartSeriesPointView | virtual
~CXTPChartElementView() | CXTPChartElementView | protectedvirtual
~CXTPChartLegendItemView() | CXTPChartLegendItemView | inlinevirtual


Toolkit Pro: XTPGridThemeVisualStudio2015.h Source File

  • Source
  • GridControl
  • Themes
XTPGridThemeVisualStudio2015.h
Go to the documentation of this file.
1
23#if !defined(__XTPGRIDTHEMEVISUALSTUDIO2015_H__)
24# define __XTPGRIDTHEMEVISUALSTUDIO2015_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPGridThemeVisualStudio2015 : public CXTPGridThemeOffice2013
39{
40public:
45 CXTPGridThemeVisualStudio2015();
46
52 virtual void RefreshMetrics();
53};
55# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
56#endif //#if !defined(__XTPGRIDTHEMEVISUALSTUDIO2015_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPGridThemeOffice2013
CXTPGridThemeOffice2013 is a CXTPGridPaintManager derived class that represents an Office 2013 style ...
Definition XTPGridThemeOffice2013.h:39
CXTPGridThemeVisualStudio2015
CXTPGridThemeVisualStudio2015 is a CXTPGridThemeOffice2013 derived class that represents a Visual Stu...
Definition XTPGridThemeVisualStudio2015.h:39
CXTPGridThemeVisualStudio2015::CXTPGridThemeVisualStudio2015
CXTPGridThemeVisualStudio2015()
Default paint manager constructor, handles properties initialization.
CXTPGridThemeVisualStudio2015::RefreshMetrics
virtual void RefreshMetrics()
This method is called to refresh the visual metrics of the Grid control.


Toolkit Pro: Member List

XTP_CALENDAR_MONTHVIEW_DAYPOS Member List

This is the complete list of members for XTP_CALENDAR_MONTHVIEW_DAYPOS, including all inherited members.

GetPOS() const | XTP_CALENDAR_MONTHVIEW_DAYPOS
IsValid() const | XTP_CALENDAR_MONTHVIEW_DAYPOS
nWeekDayIndex | XTP_CALENDAR_MONTHVIEW_DAYPOS
nWeekIndex | XTP_CALENDAR_MONTHVIEW_DAYPOS
operator int() const | XTP_CALENDAR_MONTHVIEW_DAYPOS
operator++() | XTP_CALENDAR_MONTHVIEW_DAYPOS
operator++(int) | XTP_CALENDAR_MONTHVIEW_DAYPOS
operator=(int nPOS) | XTP_CALENDAR_MONTHVIEW_DAYPOS
SetPOS(int nWidx, int nWDidx) | XTP_CALENDAR_MONTHVIEW_DAYPOS
SetPOS(int nPOS) | XTP_CALENDAR_MONTHVIEW_DAYPOS


Toolkit Pro: Member List

CXTPDatePickerThemeOfficeXP Member List

This is the complete list of members for CXTPDatePickerThemeOfficeXP, including all inherited members.

CalcDayOfWeekRect(CDC *pDC) | CXTPDatePickerPaintManager | virtual
CalcDayRect(CDC *pDC) | CXTPDatePickerPaintManager | virtual
CalcMonthHeaderRect(CDC *pDC) | CXTPDatePickerPaintManager | virtual
CalcMonthRect(CDC *pDC) | CXTPDatePickerPaintManager | virtual
CalcWeekNumbersRect(CDC *pDC) | CXTPDatePickerPaintManager | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPDatePickerPaintManager() | CXTPDatePickerPaintManager |
CXTPDatePickerThemeOfficeXP() | CXTPDatePickerThemeOfficeXP |
DrawBackground(CDC *pDC, CRect rcClient) | CXTPDatePickerPaintManager | virtual
DrawBorder(CDC *pDC, const CXTPDatePickerControl *pControl, CRect &rcClient, BOOL bDraw) | CXTPDatePickerPaintManager | virtual
DrawButton(CDC *pDC, const CRect &rcButton, const CString &strButton, BOOL bIsDown, BOOL bIsHighLight) | CXTPDatePickerPaintManager | virtual
DrawDay(CDC *pDC, CXTPDatePickerItemDay *pDay) | CXTPDatePickerPaintManager | virtual
DrawDaysOfWeek(CDC *pDC, CXTPDatePickerItemMonth *pMonth) | CXTPDatePickerPaintManager | virtual
DrawMonthHeader(CDC *pDC, CXTPDatePickerItemMonth *pMonth) | CXTPDatePickerPaintManager | virtual
DrawScrollTriangle(CDC *pDC, CRect rcSpot, BOOL bLeftDirection, COLORREF clrColor=0, BOOL bYears=FALSE) | CXTPDatePickerPaintManager | virtual
DrawWeekNumbers(CDC *pDC, CXTPDatePickerItemMonth *pMonth) | CXTPDatePickerPaintManager | virtual
EnableTheme(BOOL bEnableTheme) | CXTPDatePickerPaintManager | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetButtonFont() | CXTPDatePickerPaintManager |
GetControlBackColor() | CXTPDatePickerPaintManager | virtual
GetCursorBack() | CXTPDatePickerPaintManager | virtual
GetDayBackColor() | CXTPDatePickerPaintManager | virtual
GetDaysOfWeekBackColor() | CXTPDatePickerPaintManager | virtual
GetDaysOfWeekTextColor() | CXTPDatePickerPaintManager | virtual
GetDaysOfWeekTextFont() | CXTPDatePickerPaintManager |
GetDayTextColor() | CXTPDatePickerPaintManager | virtual
GetDayTextFont() | CXTPDatePickerPaintManager | virtual
GetDayTextFontBold() | CXTPDatePickerPaintManager | virtual
GetHeaderTextFont() | CXTPDatePickerPaintManager |
GetHighlightTodayColor() | CXTPDatePickerPaintManager | virtual
GetListControlBackColor() | CXTPDatePickerPaintManager | virtual
GetListControlTextColor() | CXTPDatePickerPaintManager | virtual
GetListControlTextFont() | CXTPDatePickerPaintManager |
GetMonthHeaderBackColor() | CXTPDatePickerPaintManager | virtual
GetMonthHeaderTextColor() | CXTPDatePickerPaintManager | virtual
GetNonMonthDayBackColor() | CXTPDatePickerPaintManager | virtual
GetNonMonthDayTextColor() | CXTPDatePickerPaintManager | virtual
GetNonMonthDayTextFont() | CXTPDatePickerPaintManager |
GetPaintTheme() const | CXTPDatePickerPaintManager | protected
GetSelectedDayBackColor() | CXTPDatePickerPaintManager | virtual
GetSelectedDayTextColor() | CXTPDatePickerPaintManager | virtual
GetWeekNumbersBackColor() | CXTPDatePickerPaintManager | virtual
GetWeekNumbersTextColor() | CXTPDatePickerPaintManager | virtual
GetWeekNumbersTextFont() | CXTPDatePickerPaintManager |
m_bEnableTheme | CXTPDatePickerPaintManager | protected
m_clr3DFace | CXTPDatePickerPaintManager | protected
m_clr3DLight | CXTPDatePickerPaintManager | protected
m_clr3DShadow | CXTPDatePickerPaintManager | protected
m_clr3DText | CXTPDatePickerPaintManager | protected
m_clrButtonFace | CXTPDatePickerPaintManager |
m_clrButtonText | CXTPDatePickerPaintManager |
m_clrControlBack | CXTPDatePickerPaintManager |
m_clrDayBack | CXTPDatePickerPaintManager |
m_clrDaysOfWeekBack | CXTPDatePickerPaintManager |
m_clrDaysOfWeekText | CXTPDatePickerPaintManager |
m_clrDayText | CXTPDatePickerPaintManager |
m_clrHighlightToday | CXTPDatePickerPaintManager |
m_clrListControlBack | CXTPDatePickerPaintManager |
m_clrListControlText | CXTPDatePickerPaintManager |
m_clrMonthBorder | CXTPDatePickerPaintManager |
m_clrMonthHeaderBack | CXTPDatePickerPaintManager |
m_clrMonthHeaderButton | CXTPDatePickerPaintManager |
m_clrMonthHeaderText | CXTPDatePickerPaintManager |
m_clrNonMonthDayBack | CXTPDatePickerPaintManager |
m_clrNonMonthDayText | CXTPDatePickerPaintManager |
m_clrSelectedDayBack | CXTPDatePickerPaintManager |
m_clrSelectedDayText | CXTPDatePickerPaintManager |
m_clrStaticBorder | CXTPDatePickerPaintManager | protected
m_clrWeekNumbersBack | CXTPDatePickerPaintManager |
m_clrWeekNumbersText | CXTPDatePickerPaintManager |
m_hCursorBack | CXTPDatePickerPaintManager | protected
m_nPaintTheme | CXTPDatePickerPaintManager | protected
m_szDayMargin | CXTPDatePickerPaintManager |
m_themeButton | CXTPDatePickerPaintManager | protected
m_xtpFontButton | CXTPDatePickerPaintManager | protected
m_xtpFontDay | CXTPDatePickerPaintManager | protected
m_xtpFontDayBold | CXTPDatePickerPaintManager | protected
m_xtpFontDaysOfWeek | CXTPDatePickerPaintManager | protected
m_xtpFontHeader | CXTPDatePickerPaintManager | protected
m_xtpFontListControl | CXTPDatePickerPaintManager | protected
m_xtpFontNonMonthDay | CXTPDatePickerPaintManager | protected
m_xtpFontWeekNumbers | CXTPDatePickerPaintManager | protected
RefreshMetrics() | CXTPDatePickerPaintManager | virtual
SetButtonFont(CFont *fontButton) | CXTPDatePickerPaintManager |
SetButtonFontIndirect(LOGFONT *lFont) | CXTPDatePickerPaintManager |
SetFontIndirect(LOGFONT *lFont) | CXTPDatePickerPaintManager |
Triangle(CDC *pDC, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clrColor=0) | CXTPDatePickerPaintManager | protectedvirtual
~CXTPDatePickerPaintManager() | CXTPDatePickerPaintManager | virtual
~CXTPDatePickerThemeOfficeXP() | CXTPDatePickerThemeOfficeXP | virtual


Toolkit Pro: XTPPropertyGridInplaceEdit.h Source File

  • Source
  • PropertyGrid
XTPPropertyGridInplaceEdit.h
Go to the documentation of this file.
1
23#if !defined(__XTPPROPERTYGRIDINPLACEEDIT_H__)
24# define __XTPPROPERTYGRIDINPLACEEDIT_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33// class forwards.
34
35class CXTPPropertyGridView;
36class CXTPPropertyGridItem;
37
43class _XTP_EXT_CLASS CXTPPropertyGridInplaceEdit : public CXTPMaskEditT<CEdit>
44{
46 DECLARE_DYNAMIC(CXTPPropertyGridInplaceEdit)
48public:
53 CXTPPropertyGridInplaceEdit();
54
60 virtual ~CXTPPropertyGridInplaceEdit();
61
67 virtual void SetValue(LPCTSTR strValue);
68
73 virtual void HideWindow();
74
81 virtual void Create(CXTPPropertyGridItem* pItem, CRect rect);
82
87 virtual void DestroyItem();
88
95 CXTPPropertyGridItem* GetItem();
96
109 virtual BOOL SelectConstraint(int nDirection, BOOL bCycle);
110
111protected:
112 CString m_strValue;
114 CXTPBrush m_xtpBrushBack;
115 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CBrush, m_brBack, m_xtpBrushBack, GetBackBrushHandle);
116
117 COLORREF m_clrBack;
118 CXTPPropertyGridView* m_pGrid;
119 CXTPPropertyGridItem* m_pItem;
120 BOOL m_bDelayCreate;
121 BOOL m_bCreated;
122 BOOL m_bEditMode;
123 BOOL m_bCancel;
124 BOOL m_bCheckAutoComplete;
125 BOOL m_bIgnoreEditChanged;
127protected:
129 //{{AFX_VIRTUAL(CXTPPropertyGridInplaceEdit)
130 virtual BOOL PreTranslateMessage(MSG* pMsg);
131 //}}AFX_VIRTUAL
132
133 //{{AFX_MSG(CXTPPropertyGridInplaceEdit)
134 afx_msg HBRUSH CtlColor(CDC* pDC, UINT nCtlColor);
135 afx_msg void OnEnKillfocus();
136 afx_msg void OnEnSetfocus();
137 afx_msg void OnEnChange();
138 afx_msg void OnLButtonDblClk(UINT nFlags, CPoint point);
139 afx_msg void OnKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags);
140 afx_msg void OnSysKeyUp(UINT nChar, UINT nRepCnt, UINT nFlags);
141 afx_msg void OnKeyUp(UINT nChar, UINT nRepCnt, UINT nFlags);
142 afx_msg UINT OnGetDlgCode();
143 afx_msg void OnChar(UINT nChar, UINT nRepCnt, UINT nFlags);
144 afx_msg void OnSysKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags);
145 afx_msg void OnStyleChanged(int nStyleType, LPSTYLESTRUCT lpStyleStruct);
146 afx_msg BOOL OnMouseWheel(UINT nFlags, short zDelta, CPoint pt);
147 afx_msg void OnDestroy();
148 //}}AFX_MSG
151private:
152 BOOL Create(LPCTSTR lpszClassName, LPCTSTR lpszWindowName, DWORD dwStyle, const RECT& rect,
153 CWnd* pParentWnd, UINT nID, CCreateContext* pContext = NULL);
154 BOOL Create(DWORD dwStyle, const RECT& rect, CWnd* pParentWnd, UINT nID);
155
156 DECLARE_MESSAGE_MAP()
157 friend class CXTPPropertyGridItem;
158 friend class CXTPPropertyGrid;
159};
160
166class _XTP_EXT_CLASS CXTPPropertyGridInplaceControl : public CWnd
167{
169 DECLARE_DYNAMIC(CXTPPropertyGridInplaceControl)
171public:
177 CXTPPropertyGridInplaceControl(CXTPPropertyGridItem* pItem);
178
179public:
187 virtual void OnCreateWindow(CRect& rcValue) = 0;
188
195 virtual void OnDestroyWindow();
196
204 virtual void OnAdjustValueRect(CRect& rcValue) = 0;
205
210 virtual void OnValueChanged();
211
221 virtual BOOL OnEditMouseWheel(CEdit* pEdit, short zDelta);
222
223protected:
225 DECLARE_MESSAGE_MAP()
226 virtual void OnFinalRelease();
227
228 //{{AFX_MSG(CXTPPropertyGridInplaceControl)
229 afx_msg void OnKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags);
230 afx_msg UINT OnGetDlgCode();
231 afx_msg void OnChar(UINT nChar, UINT nRepCnt, UINT nFlags);
232 //}}AFX_MSG
235protected:
236 CXTPPropertyGridItem* m_pItem;
237 int m_nWidth;
238};
239
247class _XTP_EXT_CLASS CXTPPropertyGridInplaceSlider : public CXTPPropertyGridInplaceControl
248{
250 DECLARE_DYNAMIC(CXTPPropertyGridInplaceSlider)
252public:
258 CXTPPropertyGridInplaceSlider(CXTPPropertyGridItem* pItem);
259
260public:
268 virtual void OnCreateWindow(CRect& rcValue);
269
277 virtual void OnAdjustValueRect(CRect& rcValue);
278
283 virtual void OnValueChanged();
284
291 CSliderCtrl* GetSliderCtrl() const;
292
300 void SetMin(int nMin);
301
309 void SetMax(int nMax);
310
317 int GetMin() const;
318
325 int GetMax() const;
326
336 virtual BOOL OnEditMouseWheel(CEdit* pEdit, short zDelta);
337
338protected:
345 virtual void OnScroll(UINT nSBCode, UINT nPos);
346
347protected:
349 DECLARE_MESSAGE_MAP()
350
351 int CalcualteEditWidth();
352
353 //{{AFX_MSG(CXTPPropertyGridInplaceSlider)
354 afx_msg HBRUSH CtlColor(CDC* pDC, UINT nCtlColor);
355 afx_msg void HScroll(UINT nSBCode, UINT nPos);
356 afx_msg BOOL OnMouseWheel(UINT nFlags, short zDelta, CPoint pt);
357 afx_msg UINT OnGetDlgCode();
358 //}}AFX_MSG
361# ifdef _XTP_ACTIVEX
363 DECLARE_DISPATCH_MAP()
364 DECLARE_INTERFACE_MAP()
365 XTP_DECLARE_CMDTARGETPROVIDER_INTERFACE()
366
367 DECLARE_OLETYPELIB_EX(CXTPPropertyGridInplaceSlider);
369# endif
370
371protected:
372 int m_nMin;
373 int m_nMax;
374 int m_nValue;
376private:
377 COLORREF m_clrBack;
378 CXTPBrush m_xtpBrushBack;
379};
380
381AFX_INLINE CSliderCtrl* CXTPPropertyGridInplaceSlider::GetSliderCtrl() const
382{
383 return (CSliderCtrl*)this;
384}
385AFX_INLINE void CXTPPropertyGridInplaceSlider::SetMin(int nMin)
386{
387 m_nMin = nMin;
388}
389AFX_INLINE void CXTPPropertyGridInplaceSlider::SetMax(int nMax)
390{
391 m_nMax = nMax;
392}
393AFX_INLINE int CXTPPropertyGridInplaceSlider::GetMin() const
394{
395 return m_nMin;
396}
397AFX_INLINE int CXTPPropertyGridInplaceSlider::GetMax() const
398{
399 return m_nMax;
400}
401
409class _XTP_EXT_CLASS CXTPPropertyGridInplaceSpinButton : public CXTPPropertyGridInplaceControl
410{
412 DECLARE_DYNAMIC(CXTPPropertyGridInplaceSpinButton)
414public:
420 CXTPPropertyGridInplaceSpinButton(CXTPPropertyGridItem* pItem);
421
422public:
430 virtual void OnCreateWindow(CRect& rcValue);
431
439 virtual void OnAdjustValueRect(CRect& rcValue);
440
445 virtual void OnValueChanged();
446
453 CSpinButtonCtrl* GetSpinButtonCtrl() const;
454
462 void SetMin(int nMin);
463
471 void SetMax(int nMax);
472
479 int GetMin() const;
480
487 int GetMax() const;
488
498 virtual BOOL OnEditMouseWheel(CEdit* pEdit, short zDelta);
499
500protected:
502 DECLARE_MESSAGE_MAP()
503
504 //{{AFX_MSG(CXTPPropertyGridInplaceSpinButton)
505 afx_msg void OnDeltapos(NMHDR* pNMHDR, LRESULT* pResult);
506 afx_msg UINT OnGetDlgCode();
507 //}}AFX_MSG
510# ifdef _XTP_ACTIVEX
512 DECLARE_DISPATCH_MAP()
513 DECLARE_INTERFACE_MAP()
514 XTP_DECLARE_CMDTARGETPROVIDER_INTERFACE()
515
516 DECLARE_OLETYPELIB_EX(CXTPPropertyGridInplaceSpinButton);
518# endif
519
520protected:
521 int m_nMin;
522 int m_nMax;
523};
524
525AFX_INLINE CSpinButtonCtrl* CXTPPropertyGridInplaceSpinButton::GetSpinButtonCtrl() const
526{
527 return (CSpinButtonCtrl*)this;
528}
529AFX_INLINE void CXTPPropertyGridInplaceSpinButton::SetMin(int nMin)
530{
531 m_nMin = nMin;
532}
533AFX_INLINE void CXTPPropertyGridInplaceSpinButton::SetMax(int nMax)
534{
535 m_nMax = nMax;
536}
537AFX_INLINE int CXTPPropertyGridInplaceSpinButton::GetMin() const
538{
539 return m_nMin;
540}
541AFX_INLINE int CXTPPropertyGridInplaceSpinButton::GetMax() const
542{
543 return m_nMax;
544}
545
551class _XTP_EXT_CLASS CXTPPropertyGridInplaceControls
552{
553public:
558 CXTPPropertyGridInplaceControls();
559
565 ~CXTPPropertyGridInplaceControls();
566
567public:
574 void RemoveAll();
575
584 int GetCount() const;
585
593 void Add(CXTPPropertyGridInplaceControl* pWindow);
594
604 CXTPPropertyGridInplaceControl* GetAt(int nIndex);
605
606protected:
607 CArray<CXTPPropertyGridInplaceControl*, CXTPPropertyGridInplaceControl*>
608 m_arrControls;
609};
610
611AFX_INLINE CXTPPropertyGridItem* CXTPPropertyGridInplaceEdit::GetItem()
612{
613 return m_pItem;
614}
615AFX_INLINE BOOL CXTPPropertyGridInplaceEdit::Create(LPCTSTR lpszClassName, LPCTSTR lpszWindowName,
616 DWORD dwStyle, const RECT& rect,
617 CWnd* pParentWnd, UINT nID,
618 CCreateContext* pContext)
619{
620 return CWnd::Create(lpszClassName, lpszWindowName, dwStyle, rect, pParentWnd, nID, pContext);
621}
622AFX_INLINE BOOL CXTPPropertyGridInplaceEdit::Create(DWORD dwStyle, const RECT& rect,
623 CWnd* pParentWnd, UINT nID)
624{
625 return CEdit::Create(dwStyle, rect, pParentWnd, nID);
626}
627AFX_INLINE BOOL CXTPPropertyGridInplaceControl::OnEditMouseWheel(CEdit* /*pEdit*/, short /*zDelta*/)
628{
629 return FALSE;
630}
632# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
633#endif // #if !defined(__XTPPROPERTYGRIDINPLACEEDIT_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTP_DECLARE_CMDTARGETPROVIDER_INTERFACE
#define XTP_DECLARE_CMDTARGETPROVIDER_INTERFACE()
When deriving from CXTPCmdTarget is not possible this macro can be used in addition to standard DECLA...
Definition XTPFramework.h:89
CXTPBrush
Provides a convenient object oriented interface for HBRUSH GDI object and uses GDI handle caching.
Definition XTPGdiObjects.h:653
CXTPMaskEditT
CXTPMaskEditT is a template class.
Definition XTPMaskEditT.h:45
CXTPMaskEditT::PreTranslateMessage
virtual BOOL PreTranslateMessage(MSG *pMsg)
Used by class CWinApp to translate window messages before they are dispatched to theTranslateMessage ...
Definition XTPMaskEditT.h:671
CXTPPropertyGrid
CXTPPropertyGrid is a CWnd derived class.
Definition XTPPropertyGrid.h:402
CXTPPropertyGridInplaceControl
CXTPPropertyGridInplaceControl is a CWnd derived class that represents the base class for all items w...
Definition XTPPropertyGridInplaceEdit.h:167
CXTPPropertyGridInplaceControl::OnAdjustValueRect
virtual void OnAdjustValueRect(CRect &rcValue)=0
This method is called when an item adjusts the rectangle of its value part.
CXTPPropertyGridInplaceControl::OnCreateWindow
virtual void OnCreateWindow(CRect &rcValue)=0
This method is called when an item creates its in-place control.
CXTPPropertyGridInplaceControl::CXTPPropertyGridInplaceControl
CXTPPropertyGridInplaceControl(CXTPPropertyGridItem *pItem)
Constructs a CXTPPropertyGridInplaceControl object.
CXTPPropertyGridInplaceControl::OnEditMouseWheel
virtual BOOL OnEditMouseWheel(CEdit *pEdit, short zDelta)
This method is called when the user rolls the mouse wheel while in an edit control.
Definition XTPPropertyGridInplaceEdit.h:627
CXTPPropertyGridInplaceControl::OnDestroyWindow
virtual void OnDestroyWindow()
This method is called when an item destroys its in-place control.
CXTPPropertyGridInplaceControl::OnValueChanged
virtual void OnValueChanged()
This method is called when the value of the parent item is changed.
CXTPPropertyGridInplaceControls
CXTPPropertyGridInplaceControls is a standalone class that represents a collection of CXTPPropertyGri...
Definition XTPPropertyGridInplaceEdit.h:552
CXTPPropertyGridInplaceControls::Add
void Add(CXTPPropertyGridInplaceControl *pWindow)
Adds an in-place control to the collection.
CXTPPropertyGridInplaceControls::GetCount
int GetCount() const
Gets the number of controls in the collection.
CXTPPropertyGridInplaceControls::~CXTPPropertyGridInplaceControls
~CXTPPropertyGridInplaceControls()
Destroys a CXTPPropertyGridInplaceControls object, handles cleanup and deallocation.
CXTPPropertyGridInplaceControls::GetAt
CXTPPropertyGridInplaceControl * GetAt(int nIndex)
Retrieves the in-place control at a specified index in the collection.
CXTPPropertyGridInplaceControls::RemoveAll
void RemoveAll()
Removes all in-place controls from the collection.
CXTPPropertyGridInplaceControls::m_arrControls
CArray< CXTPPropertyGridInplaceControl *, CXTPPropertyGridInplaceControl * > m_arrControls
Array of controls.
Definition XTPPropertyGridInplaceEdit.h:608
CXTPPropertyGridInplaceControls::CXTPPropertyGridInplaceControls
CXTPPropertyGridInplaceControls()
Constructs a CXTPPropertyGridInplaceControls object.
CXTPPropertyGridInplaceEdit
CXTPPropertyGridInplaceEdit is a CEdit derived class.
Definition XTPPropertyGridInplaceEdit.h:44
CXTPPropertyGridInplaceEdit::Create
virtual void Create(CXTPPropertyGridItem *pItem, CRect rect)
Creates the in-place edit control.
CXTPPropertyGridInplaceEdit::DestroyItem
virtual void DestroyItem()
This method is called when the parent item is destroyed.
CXTPPropertyGridInplaceEdit::m_bDelayCreate
BOOL m_bDelayCreate
TRUE to create Edit after activate.
Definition XTPPropertyGridInplaceEdit.h:120
CXTPPropertyGridInplaceEdit::HideWindow
virtual void HideWindow()
Hides the in-place edit control.
CXTPPropertyGridInplaceEdit::~CXTPPropertyGridInplaceEdit
virtual ~CXTPPropertyGridInplaceEdit()
Destroys a CXTPPropertyGridInplaceEdit object, handles cleanup and deallocation.
CXTPPropertyGridInplaceEdit::CXTPPropertyGridInplaceEdit
CXTPPropertyGridInplaceEdit()
Constructs a CXTPPropertyGridInplaceEdit object.
CXTPPropertyGridInplaceEdit::m_pGrid
CXTPPropertyGridView * m_pGrid
Parent grid view.
Definition XTPPropertyGridInplaceEdit.h:118
CXTPPropertyGridInplaceEdit::SelectConstraint
virtual BOOL SelectConstraint(int nDirection, BOOL bCycle)
Selects the next constraint value in the specified direction within the edit control.
CXTPPropertyGridInplaceEdit::m_xtpBrushBack
CXTPBrush m_xtpBrushBack
Background brush.
Definition XTPPropertyGridInplaceEdit.h:114
CXTPPropertyGridInplaceEdit::SetValue
virtual void SetValue(LPCTSTR strValue)
Sets the value for the edit text.
CXTPPropertyGridInplaceEdit::m_bEditMode
BOOL m_bEditMode
TRUE after edit first receive focus.
Definition XTPPropertyGridInplaceEdit.h:122
CXTPPropertyGridInplaceEdit::m_strValue
CString m_strValue
Previous item value.
Definition XTPPropertyGridInplaceEdit.h:112
CXTPPropertyGridInplaceEdit::m_clrBack
COLORREF m_clrBack
Background color.
Definition XTPPropertyGridInplaceEdit.h:117
CXTPPropertyGridInplaceEdit::m_bCreated
BOOL m_bCreated
TRUE if the Create method was executed.
Definition XTPPropertyGridInplaceEdit.h:121
CXTPPropertyGridInplaceEdit::GetItem
CXTPPropertyGridItem * GetItem()
Gets the current item.
Definition XTPPropertyGridInplaceEdit.h:611
CXTPPropertyGridInplaceEdit::m_bCancel
BOOL m_bCancel
User cancel edit with Escape.
Definition XTPPropertyGridInplaceEdit.h:123
CXTPPropertyGridInplaceEdit::m_bCheckAutoComplete
BOOL m_bCheckAutoComplete
Check auto-complete.
Definition XTPPropertyGridInplaceEdit.h:124
CXTPPropertyGridInplaceEdit::m_pItem
CXTPPropertyGridItem * m_pItem
Current item.
Definition XTPPropertyGridInplaceEdit.h:119
CXTPPropertyGridInplaceEdit::m_bIgnoreEditChanged
BOOL m_bIgnoreEditChanged
TRUE to ignore edit changed notification.
Definition XTPPropertyGridInplaceEdit.h:125
CXTPPropertyGridInplaceSlider
CXTPPropertyGridInplaceSlider is a CXTPPropertyGridInplaceControl derived class.
Definition XTPPropertyGridInplaceEdit.h:248
CXTPPropertyGridInplaceSlider::GetMax
int GetMax() const
Gets the upper range of the slider control.
Definition XTPPropertyGridInplaceEdit.h:397
CXTPPropertyGridInplaceSlider::OnCreateWindow
virtual void OnCreateWindow(CRect &rcValue)
This method is called when an item creates its in-place control.
CXTPPropertyGridInplaceSlider::OnScroll
virtual void OnScroll(UINT nSBCode, UINT nPos)
This method is called when the slider is moved by the user.
CXTPPropertyGridInplaceSlider::m_nValue
int m_nValue
Value of the slider.
Definition XTPPropertyGridInplaceEdit.h:374
CXTPPropertyGridInplaceSlider::SetMin
void SetMin(int nMin)
Sets the lower range for the slider control.
Definition XTPPropertyGridInplaceEdit.h:385
CXTPPropertyGridInplaceSlider::m_nMin
int m_nMin
Lower range.
Definition XTPPropertyGridInplaceEdit.h:372
CXTPPropertyGridInplaceSlider::GetMin
int GetMin() const
Gets the lower range of the slider control.
Definition XTPPropertyGridInplaceEdit.h:393
CXTPPropertyGridInplaceSlider::SetMax
void SetMax(int nMax)
Sets the upper range for the slider control.
Definition XTPPropertyGridInplaceEdit.h:389
CXTPPropertyGridInplaceSlider::CXTPPropertyGridInplaceSlider
CXTPPropertyGridInplaceSlider(CXTPPropertyGridItem *pItem)
Constructs a CXTPPropertyGridInplaceSlider object.
CXTPPropertyGridInplaceSlider::GetSliderCtrl
CSliderCtrl * GetSliderCtrl() const
Gets the slider control.
Definition XTPPropertyGridInplaceEdit.h:381
CXTPPropertyGridInplaceSlider::OnAdjustValueRect
virtual void OnAdjustValueRect(CRect &rcValue)
This method is called when an item adjusts the rectangle of its value part.
CXTPPropertyGridInplaceSlider::OnEditMouseWheel
virtual BOOL OnEditMouseWheel(CEdit *pEdit, short zDelta)
This method is called when the user rolls the mouse wheel while in an edit control.
CXTPPropertyGridInplaceSlider::m_nMax
int m_nMax
Upper range.
Definition XTPPropertyGridInplaceEdit.h:373
CXTPPropertyGridInplaceSlider::OnValueChanged
virtual void OnValueChanged()
This method is called when the value of the parent item is changed.
CXTPPropertyGridInplaceSpinButton
CXTPPropertyGridInplaceSpinButton is a CXTPPropertyGridInplaceControl derived class.
Definition XTPPropertyGridInplaceEdit.h:410
CXTPPropertyGridInplaceSpinButton::GetMax
int GetMax() const
Gets the upper range of the spin button control.
Definition XTPPropertyGridInplaceEdit.h:541
CXTPPropertyGridInplaceSpinButton::OnCreateWindow
virtual void OnCreateWindow(CRect &rcValue)
This method is called when an item creates its in-place control.
CXTPPropertyGridInplaceSpinButton::SetMin
void SetMin(int nMin)
Sets the lower range for the spin button control.
Definition XTPPropertyGridInplaceEdit.h:529
CXTPPropertyGridInplaceSpinButton::m_nMin
int m_nMin
Lower range.
Definition XTPPropertyGridInplaceEdit.h:521
CXTPPropertyGridInplaceSpinButton::GetMin
int GetMin() const
Gets the lower range of the spin button control.
Definition XTPPropertyGridInplaceEdit.h:537
CXTPPropertyGridInplaceSpinButton::SetMax
void SetMax(int nMax)
Sets the upper range for the spin button control.
Definition XTPPropertyGridInplaceEdit.h:533
CXTPPropertyGridInplaceSpinButton::CXTPPropertyGridInplaceSpinButton
CXTPPropertyGridInplaceSpinButton(CXTPPropertyGridItem *pItem)
Constructs a CXTPPropertyGridInplaceSpinButton object.
CXTPPropertyGridInplaceSpinButton::OnAdjustValueRect
virtual void OnAdjustValueRect(CRect &rcValue)
This method is called when an item adjusts the rectangle of its value part.
CXTPPropertyGridInplaceSpinButton::OnEditMouseWheel
virtual BOOL OnEditMouseWheel(CEdit *pEdit, short zDelta)
This method is called when the user rolls the mouse wheel while in an edit control.
CXTPPropertyGridInplaceSpinButton::m_nMax
int m_nMax
Upper range.
Definition XTPPropertyGridInplaceEdit.h:522
CXTPPropertyGridInplaceSpinButton::GetSpinButtonCtrl
CSpinButtonCtrl * GetSpinButtonCtrl() const
Gets the spin button control.
Definition XTPPropertyGridInplaceEdit.h:525
CXTPPropertyGridInplaceSpinButton::OnValueChanged
virtual void OnValueChanged()
This method is called when the value of the parent item is changed.
CXTPPropertyGridItem
CXTPPropertyGridItem is the base class representing an item of the Property Grid control.
Definition XTPPropertyGridItem.h:523
CXTPPropertyGridView
CXTPPropertyGridView is a CListBox derived class.
Definition XTPPropertyGridView.h:49


Toolkit Pro: Member List

CXTPScrollBarContainer< Parent > Member List

This is the complete list of members for CXTPScrollBarContainer< Parent >, including all inherited members.

CreateScrollBarCtrl(DWORD dwStyle, UINT nID) | CXTPScrollBarContainer< Parent > | inline
CXTPScrollBarContainer() | CXTPScrollBarContainer< Parent > | inlineprotected
EnableScrollBar(int nSBFlags, UINT nArrowFlags=ESB_ENABLE_BOTH) | CXTPScrollBarContainer< Parent > | inline
GetScrollBarCtrl(int nBar) const | CXTPScrollBarContainer< Parent > | inlinevirtual
OptimizeChildrenClipping() | CXTPScrollBarContainer< Parent > | inline
RefreshScrollBarMetrics() | CXTPScrollBarContainer< Parent > | inline
SetScrollBarClass(CRuntimeClass *pClass=NULL) | CXTPScrollBarContainer< Parent > | inline
SetScrollBarTheme(XTPScrollBarTheme theme) | CXTPScrollBarContainer< Parent > | inline
ShowScrollBar(UINT nBar, BOOL bShow=TRUE) | CXTPScrollBarContainer< Parent > | inline


Toolkit Pro: Member List

CXTPWindowRect Member List

This is the complete list of members for CXTPWindowRect, including all inherited members.

CXTPWindowRect(HWND hWnd) | CXTPWindowRect
CXTPWindowRect(const CWnd *pWnd) | CXTPWindowRect


Toolkit Pro: Member List

XTP_IMAGERESOURCE_INFO Member List

This is the complete list of members for XTP_IMAGERESOURCE_INFO, including all inherited members.

bAlpha | XTP_IMAGERESOURCE_INFO
pResource | XTP_IMAGERESOURCE_INFO
rc | XTP_IMAGERESOURCE_INFO


Toolkit Pro: XTPCommandBarsVisualStudio2005Theme.h Source File

  • Source
  • CommandBars
  • Themes
XTPCommandBarsVisualStudio2005Theme.h
Go to the documentation of this file.
1
23#if !defined(__XTPCOMMANDBARSVISUALSTUDIO2005THEME_H__)
24# define __XTPCOMMANDBARSVISUALSTUDIO2005THEME_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
40class _XTP_EXT_CLASS CXTPVisualStudio2005Theme : public CXTPCommandBarsOffice2003Theme
41{
43 DECLARE_DYNAMIC(CXTPVisualStudio2005Theme)
45public:
50 CXTPVisualStudio2005Theme();
51
56 virtual ~CXTPVisualStudio2005Theme();
57
62 void RefreshMetrics();
63
64public:
71 virtual XTPPaintTheme BaseTheme()
72 {
73 return xtpThemeVisualStudio2005;
74 }
75};
76
78typedef CXTPVisualStudio2005Theme CXTPWhidbeyTheme;
82# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
83#endif // !defined(__XTPCOMMANDBARSVISUALSTUDIO2005THEME_H__)
XTPPaintTheme
XTPPaintTheme
Paint themes used by command bars.
Definition XTPCommandBarsDefines.h:233
xtpThemeVisualStudio2005
@ xtpThemeVisualStudio2005
Visual Studio 2005 theme.
Definition XTPCommandBarsDefines.h:239
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCommandBarsOffice2003Theme
The CXTPCommandBarsOffice2003Theme class is used to enable an Office 2003 style theme for Command Bar...
Definition XTPCommandBarsOffice2003Theme.h:41
CXTPVisualStudio2005Theme
The CXTPVisualStudio2005Theme class is used to enable a Visual Studio 2005 style theme for Command Ba...
Definition XTPCommandBarsVisualStudio2005Theme.h:41
CXTPVisualStudio2005Theme::CXTPVisualStudio2005Theme
CXTPVisualStudio2005Theme()
Constructs a CXTPVisualStudio2005Theme object.
CXTPVisualStudio2005Theme::~CXTPVisualStudio2005Theme
virtual ~CXTPVisualStudio2005Theme()
Destroys a CXTPVisualStudio2005Theme object, handles cleanup and deallocation.
CXTPVisualStudio2005Theme::BaseTheme
virtual XTPPaintTheme BaseTheme()
Retrieves the base theme of the manager.
Definition XTPCommandBarsVisualStudio2005Theme.h:71
CXTPVisualStudio2005Theme::RefreshMetrics
void RefreshMetrics()
This method is called to refresh the visual metrics of the manager.


Toolkit Pro: XTPGdiPlus.h Source File

  • Source
  • Markup
  • DeviceContext
Markup/DeviceContext/XTPGdiPlus.h
Go to the documentation of this file.
1
24#if !defined(__XTPGDIPLUS_H__)
25# define __XTPGDIPLUS_H__
26
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33# define DECLARE_GDIPLUS_METHOD_(return, rettype, calltype, proc, proc_param, call_param) \
34 public: \
35 rettype(calltype* proc) proc_param;
36
37# define DECLARE_GDIPLUS_METHOD(calltype, proc, proc_param, call_param) \
38 DECLARE_GDIPLUS_METHOD_(return, GpStatus, calltype, proc, proc_param, call_param)
39# define DECLARE_GDIPLUS_METHOD_VOID(calltype, proc, proc_param, call_param) \
40 DECLARE_GDIPLUS_METHOD_(;, void, calltype, proc, proc_param, call_param)
41
42_XTP_DEPRECATED
43class CXTPGdiPlus
44{
45public:
46 CXTPGdiPlus();
47
48public:
53 void Register(BOOL bReserved);
54
55 DECLARE_GDIPLUS_METHOD(WINAPI, GdiplusStartup,
56 (ULONG_PTR * token, const GdiplusStartupInput* input,
57 GdiplusStartupOutput* output),
58 (token, input, output))
59 DECLARE_GDIPLUS_METHOD_VOID(WINAPI, GdiplusShutdown, (ULONG_PTR token), (token))
60
61 DECLARE_GDIPLUS_METHOD(WINGDIPAPI, GdipSetPixelOffsetMode,
62 (GpGraphics * graphics, PixelOffsetMode pixelOffsetMode),
63 (graphics, pixelOffsetMode))
64 DECLARE_GDIPLUS_METHOD(WINGDIPAPI, GdipSetPageUnit, (GpGraphics * graphics, GpUnit unit),
65 (graphics, unit))
66 DECLARE_GDIPLUS_METHOD(WINGDIPAPI, GdipSetSmoothingMode,
67 (GpGraphics * graphics, SmoothingMode smoothingMode),
68 (graphics, smoothingMode))
69 DECLARE_GDIPLUS_METHOD(WINGDIPAPI, GdipSetLinePresetBlend,
70 (GpLineGradient * brush, GDIPCONST ARGB* blend,
71 GDIPCONST REAL* positions, INT count),
72 (brush, blend, positions, count))
73 DECLARE_GDIPLUS_METHOD(WINGDIPAPI, GdipSetInterpolationMode,
74 (GpGraphics * graphics, InterpolationMode interpolationMode),
75 (graphics, interpolationMode))
76
77 DECLARE_GDIPLUS_METHOD(WINGDIPAPI, GdipCreateFromHDC2,
78 (HDC hdc, HANDLE hDevice, GpGraphics** graphics),
79 (hdc, hDevice, graphics))
80 DECLARE_GDIPLUS_METHOD(WINGDIPAPI, GdipCreateFromHDC, (HDC hdc, GpGraphics** graphics),
81 (hdc, graphics))
82 DECLARE_GDIPLUS_METHOD(WINGDIPAPI, GdipCreatePath2,
83 (GDIPCONST GpPointF * points, GDIPCONST BYTE* data, INT dataCount,
84 GpFillMode fillMode, GpPath** path),
85 (points, data, dataCount, fillMode, path))
86 DECLARE_GDIPLUS_METHOD(WINGDIPAPI, GdipCreateSolidFill, (ARGB color, GpSolidFill** brush),
87 (color, brush))
88
89 DECLARE_GDIPLUS_METHOD(WINGDIPAPI, GdipCreateLineBrush,
90 (GDIPCONST GpPointF * point1, GDIPCONST GpPointF* point2, ARGB color1,
91 ARGB color2, GpWrapMode wrapMode, GpLineGradient** lineGradient),
92 (point1, point2, color1, color2, wrapMode, lineGradient))
93 DECLARE_GDIPLUS_METHOD(WINGDIPAPI, GdipCreatePen1,
94 (ARGB color, REAL width, GpUnit unit, GpPen** pen),
95 (color, width, unit, pen))
96 DECLARE_GDIPLUS_METHOD(WINGDIPAPI, GdipCreatePen2,
97 (GpBrush * brush, REAL width, GpUnit unit, GpPen** pen),
98 (brush, width, unit, pen))
99
100 DECLARE_GDIPLUS_METHOD(WINGDIPAPI, GdipDeleteGraphics, (GpGraphics * graphics), (graphics))
101 DECLARE_GDIPLUS_METHOD(WINGDIPAPI, GdipDeleteBrush, (GpBrush * brush), (brush))
102 DECLARE_GDIPLUS_METHOD(WINGDIPAPI, GdipDeletePen, (GpPen * pen), (pen))
103 DECLARE_GDIPLUS_METHOD(WINGDIPAPI, GdipDeletePath, (GpPath * path), (path))
104
105 DECLARE_GDIPLUS_METHOD(WINGDIPAPI, GdipDrawEllipse,
106 (GpGraphics * graphics, GpPen* pen, REAL x, REAL y, REAL width,
107 REAL height),
108 (graphics, pen, x, y, width, height))
109 DECLARE_GDIPLUS_METHOD(WINGDIPAPI, GdipDrawLines,
110 (GpGraphics * graphics, GpPen* pen, GDIPCONST GpPointF* points,
111 INT count),
112 (graphics, pen, points, count))
113 DECLARE_GDIPLUS_METHOD(WINGDIPAPI, GdipDrawLinesI,
114 (GpGraphics * graphics, GpPen* pen, GDIPCONST GpPoint* points,
115 INT count),
116 (graphics, pen, points, count))
117 DECLARE_GDIPLUS_METHOD(WINGDIPAPI, GdipDrawPolygon,
118 (GpGraphics * graphics, GpPen* pen, GDIPCONST GpPointF* points,
119 INT count),
120 (graphics, pen, points, count))
121 DECLARE_GDIPLUS_METHOD(WINGDIPAPI, GdipDrawPolygonI,
122 (GpGraphics * graphics, GpPen* pen, GDIPCONST GpPoint* points,
123 INT count),
124 (graphics, pen, points, count))
125 DECLARE_GDIPLUS_METHOD(WINGDIPAPI, GdipDrawPath,
126 (GpGraphics * graphics, GpPen* pen, GpPath* path), (graphics, pen, path))
127 DECLARE_GDIPLUS_METHOD(WINGDIPAPI, GdipDrawLineI,
128 (GpGraphics * graphics, GpPen* pen, INT x1, INT y1, INT x2, INT y2),
129 (graphics, pen, x1, y1, x2, y2))
130
131 DECLARE_GDIPLUS_METHOD(WINGDIPAPI, GdipFillEllipse,
132 (GpGraphics * graphics, GpBrush* brush, REAL x, REAL y, REAL width,
133 REAL height),
134 (graphics, brush, x, y, width, height))
135 DECLARE_GDIPLUS_METHOD(WINGDIPAPI, GdipFillPolygon,
136 (GpGraphics * graphics, GpBrush* brush, GDIPCONST GpPointF* points,
137 INT count, GpFillMode fillMode),
138 (graphics, brush, points, count, fillMode))
139 DECLARE_GDIPLUS_METHOD(WINGDIPAPI, GdipFillPolygonI,
140 (GpGraphics * graphics, GpBrush* brush, GDIPCONST GpPoint* points,
141 INT count, GpFillMode fillMode),
142 (graphics, brush, points, count, fillMode))
143 DECLARE_GDIPLUS_METHOD(WINGDIPAPI, GdipFillRectangleI,
144 (GpGraphics * graphics, GpBrush* brush, INT x, INT y, INT width,
145 INT height),
146 (graphics, brush, x, y, width, height))
147 DECLARE_GDIPLUS_METHOD(WINGDIPAPI, GdipFillPath,
148 (GpGraphics * graphics, GpBrush* brush, GpPath* path),
149 (graphics, brush, path))
150 DECLARE_GDIPLUS_METHOD(WINGDIPAPI, GdipGetClipBoundsI, (GpGraphics * graphics, GpRect* rect),
151 (graphics, rect))
152
153 DECLARE_GDIPLUS_METHOD(WINGDIPAPI, GdipCreateFontFromLogfontA,
154 (HDC hdc, const LOGFONTA* logfont, GpFont** font), (hdc, logfont, font))
155 DECLARE_GDIPLUS_METHOD(WINGDIPAPI, GdipCreateFontFromLogfontW,
156 (HDC hdc, const LOGFONTW* logfont, GpFont** font), (hdc, logfont, font))
157 DECLARE_GDIPLUS_METHOD(WINGDIPAPI, GdipGetFontStyle, (GpFont * font, INT* style), (font, style))
158 DECLARE_GDIPLUS_METHOD(WINGDIPAPI, GdipGetFontSize, (GpFont * font, REAL* size), (font, size))
159 DECLARE_GDIPLUS_METHOD(WINGDIPAPI, GdipDeleteFont, (GpFont * font), (font))
160
161 DECLARE_GDIPLUS_METHOD(WINGDIPAPI, GdipGetFamily, (GpFont * font, GpFontFamily** family),
162 (font, family))
163 DECLARE_GDIPLUS_METHOD(WINGDIPAPI, GdipGetEmHeight,
164 (GDIPCONST GpFontFamily * family, INT style, UINT16* EmHeight),
165 (family, style, EmHeight))
166 DECLARE_GDIPLUS_METHOD(WINGDIPAPI, GdipGetCellAscent,
167 (GDIPCONST GpFontFamily * family, INT style, UINT16* CellAscent),
168 (family, style, CellAscent))
169 DECLARE_GDIPLUS_METHOD(WINGDIPAPI, GdipGetCellDescent,
170 (GDIPCONST GpFontFamily * family, INT style, UINT16* CellDescent),
171 (family, style, CellDescent))
172 DECLARE_GDIPLUS_METHOD(WINGDIPAPI, GdipDeleteFontFamily, (GpFontFamily * family), (family))
173
174 DECLARE_GDIPLUS_METHOD(WINGDIPAPI, GdipMeasureString,
175 (GpGraphics * graphics, GDIPCONST WCHAR* string, INT length,
176 GDIPCONST GpFont* font, GDIPCONST RectF* layoutRect,
177 GDIPCONST GpStringFormat* stringFormat, RectF* boundingBox,
178 INT* codepointsFitted, INT* linesFilled),
179 (graphics, string, length, font, layoutRect, stringFormat, boundingBox,
180 codepointsFitted, linesFilled))
181
182 DECLARE_GDIPLUS_METHOD(WINGDIPAPI, GdipTranslateWorldTransform,
183 (GpGraphics * graphics, REAL dx, REAL dy, GpMatrixOrder order),
184 (graphics, dx, dy, order))
185 DECLARE_GDIPLUS_METHOD(WINGDIPAPI, GdipGetWorldTransform,
186 (GpGraphics * graphics, GpMatrix* matrix), (graphics, matrix))
187 DECLARE_GDIPLUS_METHOD(WINGDIPAPI, GdipSetWorldTransform,
188 (GpGraphics * graphics, GpMatrix* matrix), (graphics, matrix))
189
190 DECLARE_GDIPLUS_METHOD(WINGDIPAPI, GdipDeleteStringFormat, (GpStringFormat * format), (format))
191 DECLARE_GDIPLUS_METHOD(WINGDIPAPI, GdipCreateStringFormat,
192 (INT formatAttributes, LANGID language, GpStringFormat** format),
193 (formatAttributes, language, format))
194
195 DECLARE_GDIPLUS_METHOD(WINGDIPAPI, GdipGetDC, (GpGraphics * graphics, HDC* hdc),
196 (graphics, hdc))
197 DECLARE_GDIPLUS_METHOD(WINGDIPAPI, GdipReleaseDC, (GpGraphics * graphics, HDC hdc),
198 (graphics, hdc))
199
200 DECLARE_GDIPLUS_METHOD(WINGDIPAPI, GdipDrawString,
201 (GpGraphics * graphics, GDIPCONST WCHAR* string, INT length,
202 GDIPCONST GpFont* font, GDIPCONST RectF* layoutRect,
203 GDIPCONST GpStringFormat* stringFormat, GDIPCONST GpBrush* brush),
204 (graphics, string, length, font, layoutRect, stringFormat, brush))
205 DECLARE_GDIPLUS_METHOD(WINGDIPAPI, GdipSetTextRenderingHint,
206 (GpGraphics * graphics, TextRenderingHint mode), (graphics, mode))
207
208 DECLARE_GDIPLUS_METHOD(WINGDIPAPI, GdipStringFormatGetGenericTypographic,
209 (GpStringFormat * *format), (format))
210 DECLARE_GDIPLUS_METHOD(WINGDIPAPI, GdipCloneStringFormat,
211 (GDIPCONST GpStringFormat * format, GpStringFormat** newFormat),
212 (format, newFormat))
213 DECLARE_GDIPLUS_METHOD(WINGDIPAPI, GdipSetStringFormatFlags,
214 (GpStringFormat * format, INT flags), (format, flags))
215 DECLARE_GDIPLUS_METHOD(WINGDIPAPI, GdipGetStringFormatFlags,
216 (GDIPCONST GpStringFormat * format, INT* flags), (format, flags))
217
218 DECLARE_GDIPLUS_METHOD(WINGDIPAPI, GdipSetPenDashArray,
219 (GpPen * pen, GDIPCONST REAL* dash, INT count), (pen, dash, count))
220 DECLARE_GDIPLUS_METHOD(WINGDIPAPI, GdipSetPenLineJoin, (GpPen * pen, GpLineJoin lineJoin),
221 (pen, lineJoin))
222 DECLARE_GDIPLUS_METHOD(WINGDIPAPI, GdipSetPenStartCap, (GpPen * pen, GpLineCap startCap),
223 (pen, startCap))
224 DECLARE_GDIPLUS_METHOD(WINGDIPAPI, GdipSetPenEndCap, (GpPen * pen, GpLineCap endCap),
225 (pen, endCap))
226
227 DECLARE_GDIPLUS_METHOD(WINGDIPAPI, GdipCreateRegion, (GpRegion * *region), (region))
228 DECLARE_GDIPLUS_METHOD(WINGDIPAPI, GdipGetClip, (GpGraphics * graphics, GpRegion* region),
229 (graphics, region))
230 DECLARE_GDIPLUS_METHOD(WINGDIPAPI, GdipSetClipRegion,
231 (GpGraphics * graphics, GpRegion* region, CombineMode combineMode),
232 (graphics, region, combineMode))
233 DECLARE_GDIPLUS_METHOD(WINGDIPAPI, GdipDeleteRegion, (GpRegion * region), (region))
234 DECLARE_GDIPLUS_METHOD(WINGDIPAPI, GdipSetClipRectI,
235 (GpGraphics * graphics, INT x, INT y, INT width, INT height,
236 CombineMode combineMode),
237 (graphics, x, y, width, height, combineMode))
238
239 DECLARE_GDIPLUS_METHOD(WINGDIPAPI, GdipCreateImageAttributes, (GpImageAttributes * *imageattr),
240 (imageattr))
241 DECLARE_GDIPLUS_METHOD(WINGDIPAPI, GdipDisposeImageAttributes, (GpImageAttributes * imageattr),
242 (imageattr))
243 DECLARE_GDIPLUS_METHOD(WINGDIPAPI, GdipSetImageAttributesColorKeys,
244 (GpImageAttributes * imageattr, ColorAdjustType type, BOOL enableFlag,
245 ARGB colorLow, ARGB colorHigh),
246 (imageattr, type, enableFlag, colorLow, colorHigh))
247
248 DECLARE_GDIPLUS_METHOD(WINGDIPAPI, GdipDrawImage,
249 (GpGraphics * graphics, GpImage* image, REAL x, REAL y),
250 (graphics, image, x, y))
251 DECLARE_GDIPLUS_METHOD(WINGDIPAPI, GdipDrawImageRect,
252 (GpGraphics * graphics, GpImage* image, REAL x, REAL y, REAL width,
253 REAL height),
254 (graphics, image, x, y, width, height))
255 DECLARE_GDIPLUS_METHOD(WINGDIPAPI, GdipDrawImageRectRect,
256 (GpGraphics * graphics, GpImage* image, REAL dstx, REAL dsty,
257 REAL dstwidth, REAL dstheight, REAL srcx, REAL srcy, REAL srcwidth,
258 REAL srcheight, GpUnit srcUnit,
259 GDIPCONST GpImageAttributes* imageAttributes, DrawImageAbort callback,
260 VOID* callbackData),
261 (graphics, image, dstx, dsty, dstwidth, dstheight, srcx, srcy, srcwidth,
262 srcheight, srcUnit, imageAttributes, callback, callbackData))
263 DECLARE_GDIPLUS_METHOD(WINGDIPAPI, GdipCreateBitmapFromHBITMAP,
264 (HBITMAP hbm, HPALETTE hpal, GpBitmap** bitmap), (hbm, hpal, bitmap))
265 DECLARE_GDIPLUS_METHOD(WINGDIPAPI, GdipCreateBitmapFromScan0,
266 (INT width, INT height, INT stride, PixelFormat format, BYTE* scan0,
267 GpBitmap** bitmap),
268 (width, height, stride, format, scan0, bitmap))
269 DECLARE_GDIPLUS_METHOD(WINGDIPAPI, GdipLoadImageFromStream, (IStream * stream, GpImage** image),
270 (stream, image))
271 DECLARE_GDIPLUS_METHOD(WINGDIPAPI, GdipGetImageWidth, (GpImage * image, UINT* width),
272 (image, width))
273 DECLARE_GDIPLUS_METHOD(WINGDIPAPI, GdipGetImageHeight, (GpImage * image, UINT* height),
274 (image, height))
275 DECLARE_GDIPLUS_METHOD(WINGDIPAPI, GdipImageRotateFlip,
276 (GpImage * image, RotateFlipType rfType), (image, rfType))
277 DECLARE_GDIPLUS_METHOD(WINGDIPAPI, GdipGetImageGraphicsContext,
278 (GpImage * image, GpGraphics** graphics), (image, graphics))
279 DECLARE_GDIPLUS_METHOD(WINGDIPAPI, GdipImageGetFrameDimensionsCount,
280 (GpImage * image, UINT* count), (image, count))
281 DECLARE_GDIPLUS_METHOD(WINGDIPAPI, GdipImageGetFrameDimensionsList,
282 (GpImage * image, GUID* dimensionIDs, UINT count),
283 (image, dimensionIDs, count))
284 DECLARE_GDIPLUS_METHOD(WINGDIPAPI, GdipImageGetFrameCount,
285 (GpImage * image, GDIPCONST GUID* dimensionID, UINT* count),
286 (image, dimensionID, count))
287 DECLARE_GDIPLUS_METHOD(WINGDIPAPI, GdipGetPropertyItemSize,
288 (GpImage * image, PROPID propId, UINT* size), (image, propId, size))
289 DECLARE_GDIPLUS_METHOD(WINGDIPAPI, GdipGetPropertyItem,
290 (GpImage * image, PROPID propId, UINT propSize, PropertyItem* buffer),
291 (image, propId, propSize, buffer))
292 DECLARE_GDIPLUS_METHOD(WINGDIPAPI, GdipImageSelectActiveFrame,
293 (GpImage * image, GDIPCONST GUID* dimensionID, UINT frameIndex),
294 (image, dimensionID, frameIndex))
295 DECLARE_GDIPLUS_METHOD(WINGDIPAPI, GdipDisposeImage, (GpImage * image), (image))
296 DECLARE_GDIPLUS_METHOD(WINGDIPAPI, GdipBitmapLockBits,
297 (GpBitmap * bitmap, GDIPCONST GpRect* rect, UINT flags,
298 PixelFormat format, BitmapData* lockedBitmapData),
299 (bitmap, rect, flags, format, lockedBitmapData))
300 DECLARE_GDIPLUS_METHOD(WINGDIPAPI, GdipBitmapUnlockBits,
301 (GpBitmap * bitmap, BitmapData* lockedBitmapData),
302 (bitmap, lockedBitmapData))
303 DECLARE_GDIPLUS_METHOD(WINGDIPAPI, GdipGetImageFlags, (GpImage * image, UINT* flags),
304 (image, flags));
305
306 DECLARE_GDIPLUS_METHOD(WINGDIPAPI, GdipCreateMatrix, (GpMatrix * *matrix), (matrix))
307 DECLARE_GDIPLUS_METHOD(WINGDIPAPI, GdipCloneMatrix, (GpMatrix * matrix, GpMatrix** cloneMatrix),
308 (matrix, cloneMatrix))
309 DECLARE_GDIPLUS_METHOD(WINGDIPAPI, GdipDeleteMatrix, (GpMatrix * matrix), (matrix))
310
311 DECLARE_GDIPLUS_METHOD(WINGDIPAPI, GdipInvertMatrix, (GpMatrix * matrix), (matrix))
312 DECLARE_GDIPLUS_METHOD(WINGDIPAPI, GdipTransformMatrixPointsI,
313 (GpMatrix * matrix, GpPoint* pts, INT count), (matrix, pts, count))
314 DECLARE_GDIPLUS_METHOD(WINGDIPAPI, GdipTransformMatrixPoints,
315 (GpMatrix * matrix, GpPointF* pts, INT count), (matrix, pts, count))
316 DECLARE_GDIPLUS_METHOD(WINGDIPAPI, GdipTranslateMatrix,
317 (GpMatrix * matrix, REAL offsetX, REAL offsetY, GpMatrixOrder order),
318 (matrix, offsetX, offsetY, order))
319 DECLARE_GDIPLUS_METHOD(WINGDIPAPI, GdipRotateMatrix,
320 (GpMatrix * matrix, REAL angle, GpMatrixOrder order),
321 (matrix, angle, order))
322 DECLARE_GDIPLUS_METHOD(WINGDIPAPI, GdipScaleMatrix,
323 (GpMatrix * matrix, REAL scaleX, REAL scaleY, GpMatrixOrder order),
324 (matrix, scaleX, scaleY, order))
325 DECLARE_GDIPLUS_METHOD(WINGDIPAPI, GdipShearMatrix,
326 (GpMatrix * matrix, REAL shearX, REAL shearY, GpMatrixOrder order),
327 (matrix, shearX, shearY, order))
328 DECLARE_GDIPLUS_METHOD(WINGDIPAPI, GdipSetImageAttributesColorMatrix,
329 (GpImageAttributes * imageattr, ColorAdjustType type, BOOL enableFlag,
330 GDIPCONST ColorMatrix* colorMatrix, GDIPCONST ColorMatrix* grayMatrix,
331 ColorMatrixFlags flags),
332 (imageattr, type, enableFlag, colorMatrix, grayMatrix, flags));
333
334public:
335 _XTP_DEPRECATED HMODULE m_hModule;
336 _XTP_DEPRECATED ULONG_PTR m_nGdiplusToken;
337 _XTP_DEPRECATED int m_nCount;
338};
339
340AFX_INLINE void CXTPGdiPlus::Register(BOOL bReserved)
341{
342 UNREFERENCED_PARAMETER(bReserved);
343}
344
345# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
346#endif // !defined(__XTPGDIPLUS_H__)
347
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h


Toolkit Pro: XTPChartFastLineSeriesStyle.h Source File

  • Source
  • Chart
  • Styles
  • Line
XTPChartFastLineSeriesStyle.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTFASTLINESERIESSTYLE_H__)
24# define __XTPCHARTFASTLINESERIESSTYLE_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartSeriesView;
34class CXTPChartLineStyle;
35
46class _XTP_EXT_CLASS CXTPChartFastLineSeriesStyle : public CXTPChartDiagram2DSeriesStyle
47{
49 DECLARE_SERIAL(CXTPChartFastLineSeriesStyle)
51public:
56 CXTPChartFastLineSeriesStyle();
57
62 virtual ~CXTPChartFastLineSeriesStyle();
63
64public:
72 CXTPChartLineStyle* GetLineStyle() const;
73
81 BOOL GetAntialiasing() const;
82
89 void SetAntialiasing(BOOL bEnable = TRUE);
90
91protected:
102 virtual CXTPChartSeriesView* CreateView(CXTPChartSeries* pSeries,
103 CXTPChartDiagramView* pDiagramView);
104
111 void DoPropExchange(CXTPPropExchange* pPX);
112
113# ifdef _XTP_ACTIVEX
114public:
116 DECLARE_DISPATCH_MAP()
117 DECLARE_INTERFACE_MAP()
118 DECLARE_OLETYPELIB_EX(CXTPChartFastLineSeriesStyle);
119 DECLARE_OLECREATE_EX(CXTPChartFastLineSeriesStyle)
120 LPDISPATCH OleGetLineStyle();
122# endif
123
124protected:
125 CXTPChartLineStyle* m_pLineStyle;
126 BOOL m_bAntialiasing;
127};
128
129AFX_INLINE BOOL CXTPChartFastLineSeriesStyle::GetAntialiasing() const
130{
131 return m_bAntialiasing;
132}
133
134AFX_INLINE void CXTPChartFastLineSeriesStyle::SetAntialiasing(BOOL bAntialiasing)
135{
136 m_bAntialiasing = bAntialiasing;
137 OnChartChanged();
138}
139
145class _XTP_EXT_CLASS CXTPChartFastLineSeriesView : public CXTPChartDiagram2DSeriesView
146{
147public:
155 CXTPChartFastLineSeriesView(CXTPChartSeries* pSeries, CXTPChartDiagramView* pDiagramView);
156
157protected:
169 CXTPChartSeriesPointView* CreateSeriesPointView(CXTPChartDeviceContext* pDC,
170 CXTPChartSeriesPoint* pPoint,
171 CXTPChartElementView* pParentView);
172
185 virtual CXTPChartDeviceCommand* CreateDeviceCommand(CXTPChartDeviceContext* pDC);
186
197 virtual CXTPChartDeviceCommand* CreateLegendDeviceCommand(CXTPChartDeviceContext* pDC,
198 CRect rcBounds);
199
206 void CreatePointsView(CXTPChartDeviceContext* pDC);
207};
208
209AFX_INLINE CXTPChartLineStyle* CXTPChartFastLineSeriesStyle::GetLineStyle() const
210{
211 return m_pLineStyle;
212}
214# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
215#endif //#if !defined(__XTPCHARTFASTLINESERIESSTYLE_H__)
pPoint
const CPoint * pPoint
return 0 or xtpCalendarHitTestDayExpandButton
Definition XTPCalendarThemeOffice2007.h:150
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartDiagram2DSeriesStyle
This class represents a line series style, which is a kind of CXTPChartSeriesStyle.
Definition XTPChartDiagram2DSeriesStyle.h:47
CXTPChartDiagramView
This class represents the view of a chart diagram, which is a kind of CXTPChartElementView.
Definition XTPChartDiagramView.h:49
CXTPChartElement::OnChartChanged
virtual void OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic propertie...
CXTPChartElementView
This class represents the view of a chart element.
Definition XTPChartElementView.h:47
CXTPChartFastLineSeriesStyle
This class represents a line series style, which is a kind of CXTPChartPointSeriesStyle.
Definition XTPChartFastLineSeriesStyle.h:47
CXTPChartFastLineSeriesStyle::DoPropExchange
void DoPropExchange(CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
CXTPChartFastLineSeriesStyle::SetAntialiasing
void SetAntialiasing(BOOL bEnable=TRUE)
Enables/disables antialiasing if supported.
Definition XTPChartFastLineSeriesStyle.h:134
CXTPChartFastLineSeriesStyle::m_pLineStyle
CXTPChartLineStyle * m_pLineStyle
The line style.
Definition XTPChartFastLineSeriesStyle.h:125
CXTPChartFastLineSeriesStyle::~CXTPChartFastLineSeriesStyle
virtual ~CXTPChartFastLineSeriesStyle()
Destroys a CXTPChartFastLineSeriesStyle object, handles cleanup.
CXTPChartFastLineSeriesStyle::CreateView
virtual CXTPChartSeriesView * CreateView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Call this function to create a view of the line series.
CXTPChartFastLineSeriesStyle::CXTPChartFastLineSeriesStyle
CXTPChartFastLineSeriesStyle()
Constructs a CXTPChartFastLineSeriesStyle object.
CXTPChartFastLineSeriesStyle::GetLineStyle
CXTPChartLineStyle * GetLineStyle() const
Call this function to get the line style of the line series.
Definition XTPChartFastLineSeriesStyle.h:209
CXTPChartFastLineSeriesStyle::GetAntialiasing
BOOL GetAntialiasing() const
Enables/disables antialiasing if supported.
Definition XTPChartFastLineSeriesStyle.h:129
CXTPChartFastLineSeriesView
This class represents the view of a line series, which is a kind of CXTPChartSeriesView.
Definition XTPChartFastLineSeriesStyle.h:146
CXTPChartFastLineSeriesView::CreateDeviceCommand
virtual CXTPChartDeviceCommand * CreateDeviceCommand(CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
CXTPChartFastLineSeriesView::CreateLegendDeviceCommand
virtual CXTPChartDeviceCommand * CreateLegendDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcBounds)
This function creates a label view drawing command object.
CXTPChartFastLineSeriesView::CreatePointsView
void CreatePointsView(CXTPChartDeviceContext *pDC)
Creates the view object.
CXTPChartFastLineSeriesView::CreateSeriesPointView
CXTPChartSeriesPointView * CreateSeriesPointView(CXTPChartDeviceContext *pDC, CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Call this function to create a view of the line series point.
CXTPChartFastLineSeriesView::CXTPChartFastLineSeriesView
CXTPChartFastLineSeriesView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Constructs a CXTPChartLineSeriesView object.
CXTPChartLineStyle
This class represents a chart line style, which is a kind of CXTPCmdTarget.
Definition XTPChartLineStyle.h:43
CXTPChartSeries
This class represents a series in the chart, which is a kind of CXTPChartElement.
Definition XTPChartSeries.h:50
CXTPChartSeriesPoint
CXTPChartSeriesPoint is a kind of CXTPChartElement.
Definition XTPChartSeriesPoint.h:43
CXTPChartSeriesPointView
Represents chart series point view.
Definition XTPChartSeriesPointView.h:48
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72


Toolkit Pro: XTPMarkupMouseButtonEventArgs.h Source File

  • Source
  • Markup
XTPMarkupMouseButtonEventArgs.h
Go to the documentation of this file.
1
23#if !defined(__XTPMMARKUPMOUSEBUTTONEVENTARGS_H__)
24# define __XTPMMARKUPMOUSEBUTTONEVENTARGS_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPMarkupRoutedEvent;
34
35class _XTP_EXT_CLASS CXTPMarkupMouseButtonEventArgs : public CXTPMarkupMouseEventArgs
36{
37public:
38 CXTPMarkupMouseButtonEventArgs(CXTPMarkupRoutedEvent* pEvent);
39};
40
41# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
43#endif // !defined(__XTPMMARKUPMOUSEBUTTONEVENTARGS_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h


Toolkit Pro: Member List

CXTPGridRecordItem Member List

This is the complete list of members for CXTPGridRecordItem, including all inherited members.

AddHyperlink(CXTPGridHyperlink *pHyperlink) | CXTPGridRecordItem | virtual
Compare(CXTPGridColumn *pColumn, CXTPGridRecordItem *pItem) | CXTPGridRecordItem | virtual
CompareGroupCaption(CXTPGridColumn *pColumn, CXTPGridRecordItem *pItem) | CXTPGridRecordItem | virtual
CompareGroupCaption(CXTPGridColumn *pColumn, CXTPGridGroupRow *pGroupRow) | CXTPGridRecordItem | virtual
CreateBorder() | CXTPGridRecordItem |
CXTPCmdTarget() | CXTPCmdTarget |
CXTPGridRecordItem() | CXTPGridRecordItem |
DestroyBorder() | CXTPGridRecordItem |
DoPropExchange(CXTPPropExchange *pPX) | CXTPGridRecordItem | virtual
Draw(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs) | CXTPGridRecordItem | virtual
DrawCheckBox(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CRect &rcItem) | CXTPGridRecordItem | protectedvirtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAlignment() const | CXTPGridRecordItem |
GetBackgroundColor() | CXTPGridRecordItem | virtual
GetBorder() const | CXTPGridRecordItem |
GetCanEditCheckboxItem() const | CXTPGridRecordItem |
GetCaption() | CXTPGridRecordItem | virtual
GetCaption(CXTPGridColumn *pColumn) | CXTPGridRecordItem | virtual
GetCaptionRect(XTP_GRIDRECORDITEM_ARGS *pDrawArgs, CRect &rcItem) | CXTPGridRecordItem | virtual
GetCheckedState() const | CXTPGridRecordItem |
GetColumnCaptionPrefix(CXTPGridColumn *pColumn) const | CXTPGridRecordItem |
GetEditOptions(CXTPGridColumn *pColumn) | CXTPGridRecordItem |
GetFont() | CXTPGridRecordItem | virtual
GetFormatString() const | CXTPGridRecordItem | virtual
GetFormula() const | CXTPGridRecordItem | virtual
GetGroupCaption(CXTPGridColumn *pColumn) | CXTPGridRecordItem | virtual
GetGroupCaptionID(CXTPGridColumn *pColumn) | CXTPGridRecordItem | virtual
GetGroupCaptionValue(CXTPGridColumn *pColumn) | CXTPGridRecordItem | virtual
GetGroupPriority() const | CXTPGridRecordItem | virtual
GetHasCheckbox() const | CXTPGridRecordItem | virtual
GetHyperlinkAt(int nHyperlink) const | CXTPGridRecordItem | virtual
GetHyperlinks() | CXTPGridRecordItem | protected
GetHyperlinksCount() const | CXTPGridRecordItem | virtual
GetIconIndex() const | CXTPGridRecordItem | virtual
GetIndex() const | CXTPGridRecordItem |
GetItemControls() | CXTPGridRecordItem |
GetItemData() const | CXTPGridRecordItem | virtual
GetItemMetrics(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pItemMetrics) | CXTPGridRecordItem | virtual
GetMarkupUIElement() const | CXTPGridRecordItem |
GetRecord() const | CXTPGridRecordItem |
GetSelectedConstraintData(XTP_GRIDRECORDITEM_ARGS *pItemArgs) | CXTPGridRecordItem | virtual
GetSortPriority() const | CXTPGridRecordItem | virtual
GetTextColor() | CXTPGridRecordItem | virtual
GetTooltip() const | CXTPGridRecordItem | virtual
HasCheckbox(BOOL bHasCheckbox, BOOL bTristate=FALSE) | CXTPGridRecordItem | virtual
HitTest(CPoint ptPoint) | CXTPGridRecordItem |
HitTestHyperlink(CPoint ptClick) | CXTPGridRecordItem | virtual
IsBold() const | CXTPGridRecordItem | virtual
IsChecked() const | CXTPGridRecordItem | virtual
IsChildOfMerge() const | CXTPGridRecordItem |
IsEditable() const | CXTPGridRecordItem | virtual
IsFocusable() const | CXTPGridRecordItem | virtual
IsPreviewItem() const | CXTPGridRecordItem | virtual
m_Alignment | CXTPGridRecordItem | protected
m_bBoldText | CXTPGridRecordItem | protected
m_bCanEditCheckboxItem | CXTPGridRecordItem | protected
m_bEditable | CXTPGridRecordItem | protected
m_bFocusable | CXTPGridRecordItem | protected
m_bHasCheckbox | CXTPGridRecordItem | protected
m_bItemControlUnderMouse | CXTPGridRecordItem | protected
m_bTristateCheckbox | CXTPGridRecordItem | protected
m_checkState | CXTPGridRecordItem | protected
m_clrBackground | CXTPGridRecordItem | protected
m_clrText | CXTPGridRecordItem | protected
m_dwData | CXTPGridRecordItem | protected
m_nGroupPriority | CXTPGridRecordItem | protected
m_nIconIndex | CXTPGridRecordItem | protected
m_nSortPriority | CXTPGridRecordItem | protected
m_pBorder | CXTPGridRecordItem | protected
m_pControl | CXTPGridRecordItem | protected
m_pEditOptions | CXTPGridRecordItem | protected
m_pFocusedItemControl | CXTPGridRecordItem | protected
m_pFontCaption | CXTPGridRecordItem | protected
m_pHyperlinks | CXTPGridRecordItem | protected
m_pItemControlHookWnd | CXTPGridRecordItem | protected
m_pItemControls | CXTPGridRecordItem | protected
m_pMarkupUIElement | CXTPGridRecordItem | protected
m_pRecord | CXTPGridRecordItem | protected
m_rcGlyph | CXTPGridRecordItem | protected
m_strCaption | CXTPGridRecordItem | protected
m_strFormatString | CXTPGridRecordItem | protected
m_strFormula | CXTPGridRecordItem | protected
m_strGroupCaption | CXTPGridRecordItem | protected
m_strTooltip | CXTPGridRecordItem | protected
OnBeginEdit(XTP_GRIDRECORDITEM_ARGS *pItemArgs) | CXTPGridRecordItem | protectedvirtual
OnCancelEdit(CXTPGridControl *pControl, BOOL bApply) | CXTPGridRecordItem | virtual
OnChar(XTP_GRIDRECORDITEM_ARGS *pItemArgs, UINT nChar) | CXTPGridRecordItem | protectedvirtual
OnClick(XTP_GRIDRECORDITEM_CLICKARGS *pClickArgs) | CXTPGridRecordItem | virtual
OnConstraintChanged(XTP_GRIDRECORDITEM_ARGS *pItemArgs, CXTPGridRecordItemConstraint *pConstraint) | CXTPGridRecordItem | virtual
OnDblClick(XTP_GRIDRECORDITEM_CLICKARGS *pClickArgs) | CXTPGridRecordItem | virtual
OnDrawCaption(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics) | CXTPGridRecordItem | virtual
OnDrawControls(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CRect &rcItem) | CXTPGridRecordItem | virtual
OnEditCanceled(XTP_GRIDRECORDITEM_ARGS *pItemArgs) | CXTPGridRecordItem | virtual
OnEditChanged(XTP_GRIDRECORDITEM_ARGS *pItemArgs, LPCTSTR szText) | CXTPGridRecordItem | virtual
OnEditChanging(XTP_GRIDRECORDITEM_ARGS *pItemArgs, CString &rstrNewText) | CXTPGridRecordItem | virtual
OnInplaceButtonDown(CXTPGridInplaceButton *pButton) | CXTPGridRecordItem | virtual
OnLButtonDown(XTP_GRIDRECORDITEM_CLICKARGS *pClickArgs) | CXTPGridRecordItem | virtual
OnLButtonUp(XTP_GRIDRECORDITEM_CLICKARGS *pClickArgs) | CXTPGridRecordItem | virtual
OnMouseMove(UINT nFlags, CPoint point, CXTPGridControl *pControl=NULL) | CXTPGridRecordItem | virtual
OnRequestEdit(XTP_GRIDRECORDITEM_ARGS *pItemArgs) | CXTPGridRecordItem | protectedvirtual
OnToolHitTest(CPoint point, TOOLINFO *pTI) | CXTPGridRecordItem | virtual
OnValidateEdit(XTP_GRIDRECORDITEM_ARGS *pItemArgs) | CXTPGridRecordItem | virtual
operator delete(void *p) | CXTPHeapObjectT< CXTPCmdTarget, CXTPGridDataAllocator > | inline
operator new(size_t nSize) | CXTPHeapObjectT< CXTPCmdTarget, CXTPGridDataAllocator > | inline
RemoveHyperlinkAt(int nHyperlink) | CXTPGridRecordItem | virtual
ResetMarkupUIElement() | CXTPGridRecordItem | virtual
SetAlignment(int nAlignment) | CXTPGridRecordItem |
SetBackgroundColor(COLORREF clrBackground) | CXTPGridRecordItem | virtual
SetBold(BOOL bBold=TRUE) | CXTPGridRecordItem | virtual
SetCanEditCheckboxItem(BOOL bSet) | CXTPGridRecordItem |
SetCaption(LPCTSTR strCaption) | CXTPGridRecordItem | virtual
SetChecked(BOOL bChecked) | CXTPGridRecordItem | virtual
SetCheckedState(int iState) | CXTPGridRecordItem |
SetEditable(BOOL bEditable=TRUE) | CXTPGridRecordItem | virtual
SetFocusable(BOOL bFocusable) | CXTPGridRecordItem | virtual
SetFont(CFont *pFont) | CXTPGridRecordItem | virtual
SetFormatString(LPCTSTR strFormat) | CXTPGridRecordItem | virtual
SetFormula(LPCTSTR sFormula) | CXTPGridRecordItem | virtual
SetGridControl(CXTPGridControl *pControl) | CXTPGridRecordItem |
SetGroupCaption(LPCTSTR strCaption) | CXTPGridRecordItem | virtual
SetGroupPriority(int nGroupPriority) | CXTPGridRecordItem | virtual
SetIconIndex(int nIconIndex) | CXTPGridRecordItem | virtual
SetItemData(DWORD_PTR dwData) | CXTPGridRecordItem | virtual
SetRecord(CXTPGridRecord *pGridRecord) | CXTPGridRecordItem |
SetSortPriority(int nSortPriority) | CXTPGridRecordItem | virtual
SetTextColor(COLORREF clrText) | CXTPGridRecordItem | virtual
SetTooltip(LPCTSTR lpszTooltip) | CXTPGridRecordItem | virtual
UpdateValue() | CXTPGridRecordItem |
~CXTPGridRecordItem() | CXTPGridRecordItem | virtual


Toolkit Pro: XTPImageManager.h Source File

  • Source
  • Common
XTPImageManager.h
Go to the documentation of this file.
1
23#if !defined(__XTPIMAGEMANAGER_H__)
24# define __XTPIMAGEMANAGER_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
34namespace Gdiplus
35{
36class GpBitmap;
37}
38
54enum XTPImageState
55{
56 xtpImageNormal,
57 xtpImageDisabled,
58 xtpImageHot,
59 xtpImageChecked,
60 xtpImagePressed
61};
62
67enum XTPIconSizeMatching
68{
69 xtpIconSizeExact,
70 xtpIconSizeAtLeast,
71 xtpIconSizeAtMost,
72};
73
74class CXTPImageManager;
75class CXTPImageManagerIconSet;
76class CXTPImageManagerImageList;
77class CXTPImageManagerIconHandle;
78class CXTPImageManagerResource;
79class CXTPPropExchange;
80class CXTPMarkupContext;
81class CXTPMarkupUIElement;
82class CXTPSvgImage;
83
89class _XTP_EXT_CLASS CXTPImageManagerVectorImageHandle
90{
91public:
96 CXTPImageManagerVectorImageHandle();
97
102 virtual ~CXTPImageManagerVectorImageHandle();
103
109 CXTPImageManagerVectorImageHandle(const CXTPImageManagerVectorImageHandle& rhs);
110
118 CXTPImageManagerVectorImageHandle& operator=(const CXTPImageManagerVectorImageHandle& rhs);
119
126 operator BOOL() const;
127
134 BOOL IsMarkupImage() const;
135
142 BOOL IsSvgImage() const;
143
151 void Draw(CDC* pDC, CPoint pt, CSize szIcon);
152
162 BOOL IsDirectDrawSupported() const;
163
182 SIZE_T DirectDraw(PVOID pBits, SIZE_T cbSize, CPoint pt, CSize szIcon);
183
192 HGLOBAL GetSerializationData() const;
193
200 CXTPMarkupContext* GetMarkupContext();
201
208 IStream* GetDataStream() const;
209
224 static CXTPImageManagerVectorImageHandle CreateMarkupHandle(CXTPMarkupContext* pContext,
225 BOOL bSharedContext,
226 HGLOBAL SerializationData);
227
241 static CXTPImageManagerVectorImageHandle CreateMarkupHandle(CXTPMarkupContext* pContext,
242 BOOL bSharedContext,
243 IStream* pStream);
258 static CXTPImageManagerVectorImageHandle CreateMarkupHandle(CXTPMarkupContext* pContext,
259 BOOL bSharedContext,
260 LPCSTR lpszCode,
261 INT_PTR nLength = -1);
276 static CXTPImageManagerVectorImageHandle CreateMarkupHandle(CXTPMarkupContext* pContext,
277 BOOL bSharedContext,
278 LPCWSTR lpszCode,
279 INT_PTR nLength = -1);
280
290 static CXTPImageManagerVectorImageHandle CreateSvgHandle(HGLOBAL SerializationData);
291
300 static CXTPImageManagerVectorImageHandle CreateSvgHandle(IStream* pStream);
301
311 static CXTPImageManagerVectorImageHandle CreateSvgHandle(LPCSTR lpszCode, INT_PTR nLength = -1);
312
314 CXTPSvgImage* GetSvgImage();
317private:
318 CXTPImageManagerVectorImageHandle(CXTPMarkupContext* pContext, BOOL bSharedContext,
319 CXTPMarkupUIElement* pMarkupElement,
320 HGLOBAL SerializationData);
321 CXTPImageManagerVectorImageHandle(CXTPMarkupContext* pContext, BOOL bSharedContext,
322 CXTPMarkupUIElement* pMarkupElement,
323 IStream* pSerializationData);
324 CXTPImageManagerVectorImageHandle(CXTPSvgImage* pSvgImage, HGLOBAL SerializationData);
325 CXTPImageManagerVectorImageHandle(CXTPSvgImage* pSvgImage, IStream* pSerializationData);
326
327 void Reset();
328
329private:
330 struct IMAGE_RESOURCE
331 {
332 ULONG cRefs;
333 enum
334 {
335 MarkupType,
336 SvgType
337 } nType;
338 HGLOBAL SerializationData;
339 IStream* pSerializationDataStream;
340 union {
341 struct
342 {
343 CXTPMarkupContext* pContext;
344 BOOL bSharedContext;
345 CXTPMarkupUIElement* pMarkupElement;
346 } markup;
347 CXTPSvgImage* pSvgImage;
348 // more can be added
349 } u;
350 };
351
352 mutable IMAGE_RESOURCE* m_pResource;
353
354 friend class CXTPImageManagerIcon;
355};
356
357AFX_INLINE CXTPMarkupContext* CXTPImageManagerVectorImageHandle::GetMarkupContext()
358{
359 return XTP_SAFE_GET1(m_pResource, u.markup.pContext, NULL);
360}
361
362AFX_INLINE IStream* CXTPImageManagerVectorImageHandle::GetDataStream() const
363{
364 return XTP_SAFE_GET1(m_pResource, pSerializationDataStream, NULL);
365}
366
371struct XTP_IMAGERESOURCE_INFO
372{
373 BOOL bAlpha;
375 CRect rc;
376 CXTPImageManagerResource* pResource;
377};
378
383class _XTP_EXT_CLASS CXTPImageManagerIconHandle
384{
385public:
390 CXTPImageManagerIconHandle();
399 CXTPImageManagerIconHandle(HICON hIcon, BOOL bUseResources = TRUE, BOOL bSharedHandle = TRUE);
407 CXTPImageManagerIconHandle(HBITMAP hBitmap, BOOL bSharedHandle = TRUE);
413 CXTPImageManagerIconHandle(const CXTPImageManagerIconHandle& hHandle);
414
419 ~CXTPImageManagerIconHandle();
420
428 operator HICON() const;
429
435 void CopyHandle(HBITMAP hBitmap);
441 void CopyHandle(const CXTPImageManagerIconHandle& handle);
442
449 BOOL IsAlpha() const;
450
457 BOOL IsEmpty() const;
458
465 HBITMAP GetBitmap() const;
466
473 HICON GetIcon() const;
474
481 CSize GetExtent() const;
482
491 void Draw(CDC* pDC, CPoint pt, CSize szIcon, BOOL bDrawComposited = FALSE);
492
500 HICON GetDpiScaled(int nDpi = 0) const;
501
506 void Clear();
507
519 BOOL CreateIconFromResource(LPCTSTR lpszResourceName, CSize szIcon, BOOL bGroupResource = TRUE,
520 XTPIconSizeMatching nSizeMatching = xtpIconSizeExact);
533 BOOL CreateIconFromResource(HINSTANCE hInst, LPCTSTR lpszResourceName, CSize szIcon,
534 BOOL bGroupResource,
535 XTPIconSizeMatching nSizeMatching = xtpIconSizeExact);
536
544 void Attach(HICON hIcon, BOOL bSharedHandle);
545
553 void Attach(HBITMAP hBitmap, BOOL bSharedHandle);
562 _XTP_DEPRECATED_IN_FAVOR2(CXTPImageManagerIconHandle, Attach)
563 const CXTPImageManagerIconHandle& operator=(const HICON hIcon);
564
571 _XTP_DEPRECATED_IN_FAVOR2(CXTPImageManagerIconHandle, Attach)
572 const CXTPImageManagerIconHandle& operator=(const HBITMAP hBitmap);
580 LPBYTE PreMultiply();
581
587 void Detach();
588
589protected:
594 void Init();
595
596private:
597 const CXTPImageManagerIconHandle& operator=(const CXTPImageManagerIconHandle&);
598 CSize _GetExtent() const;
599
600protected:
601 HICON m_hIcon;
602 HBITMAP m_hBitmap;
604 LPBYTE m_pBits;
605 BOOL m_bClearHandles;
606 CXTPImageManager* m_pImageManager;
607 XTP_IMAGERESOURCE_INFO* m_pRInfo;
609 CSize m_szIcon;
610 BOOL m_bUseResources;
612private:
613 friend class CXTPImageManagerIcon;
614 friend class CXTPImageManagerResource;
615};
616
621class _XTP_EXT_CLASS CXTPImageManagerIcon : public CXTPCmdTarget
622{
624 DECLARE_DYNAMIC(CXTPImageManagerIcon)
626private:
627 struct ICONDIRENTRY;
628 struct ICONDIRHEADER;
629 struct ICONIMAGE;
630 struct GRPICONDIRENTRY;
631 struct GRPICONDIR;
632
633public:
642 CXTPImageManagerIcon(UINT nID, int nWidth, int nHeight,
643 CXTPImageManagerIconSet* pIconSet = NULL);
652 CXTPImageManagerIcon(UINT nID, int nWidth, int nHeight, CXTPImageManagerImageList* pImageList);
661 CXTPImageManagerIcon(UINT nID, CXTPImageManagerIconSet* pIconSet = NULL,
662 CSize szRecommendedExtent = CSize(0));
663
668 ~CXTPImageManagerIcon();
669
676 UINT GetID() const;
677
684 BOOL IsAlpha() const;
685
692 BOOL IsScaled() const;
693
702 CXTPImageManagerImageList* GetImageList();
703
712 const CXTPImageManagerImageList* GetImageList() const;
713
722 CXTPImageManagerIconHandle& GetIcon();
732 CXTPImageManagerIconHandle& GetIcon(XTPImageState imageState);
733
740 CXTPImageManagerIconHandle& GetFadedIcon();
741
748 CXTPImageManagerIconHandle& GetShadowIcon();
749
756 CXTPImageManagerIconHandle& GetCheckedIcon();
757
764 CXTPImageManagerIconHandle& GetPressedIcon();
765
772 CXTPImageManagerIconHandle& GetHotIcon();
773
782 CXTPImageManagerIconHandle& GetDisabledIcon(BOOL bCreateIfNotExists = TRUE);
783
791 BOOL HasIcon(XTPImageState imageState) const;
792
799 BOOL HasNormalIcon() const;
800
807 BOOL HasDisabledIcon() const;
808
815 BOOL HasCheckedIcon() const;
816
823 BOOL HasPressedIcon() const;
824
831 BOOL HasHotIcon() const;
832
839 void CreateDisabledIcon(COLORREF clrDisabledLight = (COLORREF)-1,
840 COLORREF clrDisabledDark = (COLORREF)-1);
841
849 BOOL SetIcon(const CXTPImageManagerIconHandle& hIcon);
850
859 BOOL SetIcon(const CXTPImageManagerIconHandle& hIcon, XTPImageState imageState);
860
872 BOOL SetIcon(UINT nIDResourceIcon, int nWidth, int nHeight,
873 XTPIconSizeMatching nSizeMatching = xtpIconSizeExact);
874
880 void SetDisabledIcon(const CXTPImageManagerIconHandle& hIcon);
881
887 void SetHotIcon(const CXTPImageManagerIconHandle& hIcon);
888
894 void SetCheckedIcon(const CXTPImageManagerIconHandle& hIcon);
895
901 void SetNormalIcon(const CXTPImageManagerIconHandle& hIcon);
902
908 void SetPressedIcon(const CXTPImageManagerIconHandle& hIcon);
909
918 CSize GetExtent() const;
919
929 static CSize AFX_CDECL GetExtent(HICON hIcon);
930
943 CSize GetRecommendedExtent() const;
944
952 static BOOL AFX_CDECL IsAlphaBitmapFile(LPCTSTR pszFileName);
953
961 static BOOL AFX_CDECL IsPngBitmapFile(LPCTSTR pszFileName);
962
971 static HBITMAP AFX_CDECL LoadAlphaIcon(LPCTSTR pszFileName, int nWidth);
972
983 static HBITMAP AFX_CDECL LoadAlphaBitmap(UINT nIDResource);
984
998 static HBITMAP AFX_CDECL LoadAlphaBitmap(HMODULE hModule, LPCTSTR lpszResource);
999
1008 static HBITMAP AFX_CDECL LoadBitmapFromFile(LPCTSTR lpszFileName, BOOL* lbAlphaBitmap = NULL);
1009
1019 static HBITMAP AFX_CDECL LoadBitmapFromResource(LPCTSTR lpszResource, BOOL* lbAlphaBitmap);
1020
1032 static HBITMAP AFX_CDECL LoadBitmapFromResource(HMODULE hModule, LPCTSTR lpszResource,
1033 BOOL* lbAlphaBitmap);
1034
1043 static BOOL AFX_CDECL IsAlphaBitmapResource(HMODULE hModule, LPCTSTR lpBitmapName);
1044
1053 static BOOL AFX_CDECL IsPngBitmapResource(HMODULE hModule, LPCTSTR lpBitmapName);
1054
1067 static void AFX_CDECL DrawAlphaBitmap(CDC* pDC, HBITMAP hBitmap, CPoint ptDest, CSize szDest,
1068 CPoint ptSrc = 0, CSize szSrc = 0);
1069
1081 static HBITMAP AFX_CDECL PreMultiplyAlphaBitmap(HBITMAP hBitmap, BOOL* pbAlpha = NULL,
1082 LPBYTE* lpBits = NULL);
1083
1091 static HBITMAP AFX_CDECL InvertAlphaBitmap(HBITMAP hBitmap);
1092
1105 static BOOL AFX_CDECL GetBitmapBits(CDC& dcSrc, HBITMAP hBitmap, PBITMAPINFO& pbmi,
1106 LPVOID& pBits, UINT& nSize);
1107
1116 static HBITMAP AFX_CDECL CopyAlphaBitmap(HBITMAP hBitmap, LPBYTE* lpBits = NULL);
1117
1125 static BOOL AFX_CDECL IsAlphaIconHandle(HICON hIcon);
1126
1133 int GetHeight() const;
1134
1141 int GetWidth() const;
1142
1148 void Serialize(CArchive& ar);
1149
1155 void Copy(CXTPImageManagerIcon* pIcon);
1156
1164 void SerializeIcon(CXTPImageManagerIconHandle& hIcon, CArchive& ar, long nSchema);
1165
1173 void SerializeIcon(CXTPImageManagerVectorImageHandle& hIcon, CArchive& ar, long nSchema);
1174
1181 void Draw(CDC* pDC, CPoint pt);
1182
1190 void Draw(CDC* pDC, CPoint pt, CSize szIcon);
1191
1199 void Draw(CDC* pDC, CPoint pt, XTPImageState imageState);
1200
1209 void Draw(CDC* pDC, CPoint pt, XTPImageState imageState, CSize szIcon);
1210
1222 void Draw(CDC* pDC, CPoint pt, CXTPImageManagerIconHandle& hIcon, CSize szIcon = 0,
1223 COLORREF clrBK = CLR_NONE, COLORREF clrFG = CLR_NONE, UINT uiFlags = 0);
1224
1233 void Draw(CDC* pDC, CPoint pt, CXTPImageManagerVectorImageHandle hIcon, CSize szIcon = 0);
1234
1245 BOOL IsDirectDrawSupported(XTPImageState imageState = xtpImageNormal) const;
1246
1266 SIZE_T DirectDraw(PVOID pBits, SIZE_T cbSize, CPoint pt, CSize szIcon);
1267
1288 SIZE_T DirectDraw(PVOID pBits, SIZE_T cbSize, CPoint pt, XTPImageState imageState,
1289 CSize szIcon);
1290
1311 SIZE_T DirectDraw(PVOID pBits, SIZE_T cbSize, CPoint pt,
1312 CXTPImageManagerVectorImageHandle hIcon, CSize szIcon = 0);
1313
1323 void DrawMono(CDC* pDC, CPoint pt, CXTPImageManagerIconHandle& hIcon, CSize szIcon,
1324 COLORREF clrBrush);
1325
1330 void Refresh();
1331
1340 CXTPMarkupContext* CreateMarkupContext();
1341
1348 CXTPMarkupContext* GetMarkupContext();
1349
1357 BOOL SetVectorIcon(CXTPImageManagerVectorImageHandle hIcon);
1358
1367 BOOL SetVectorIcon(CXTPImageManagerVectorImageHandle hIcon, XTPImageState imageState);
1368
1376 BOOL SetVectorDisabledIcon(CXTPImageManagerVectorImageHandle hIcon);
1377
1385 BOOL SetVectorHotIcon(CXTPImageManagerVectorImageHandle hIcon);
1386
1394 BOOL SetVectorCheckedIcon(CXTPImageManagerVectorImageHandle hIcon);
1395
1403 BOOL SetVectorPressedIcon(CXTPImageManagerVectorImageHandle hIcon);
1404
1411 CXTPImageManagerVectorImageHandle GetVectorIcon() const;
1412
1420 CXTPImageManagerVectorImageHandle GetVectorIcon(XTPImageState imageState) const;
1421
1428 CXTPImageManagerVectorImageHandle GetVectorCheckedIcon() const;
1429
1436 CXTPImageManagerVectorImageHandle GetVectorPressedIcon() const;
1437
1444 CXTPImageManagerVectorImageHandle GetVectorHotIcon() const;
1445
1452 CXTPImageManagerVectorImageHandle GetVectorDisabledIcon() const;
1453
1460 BOOL IsRasterIcon() const;
1461
1468 BOOL IsVectorIcon() const;
1469
1477 BOOL IsUndefinedIcon() const;
1478
1487 static HICON AFX_CDECL ScaleToFit(HICON hIcon, CSize szExtent, int nWidth);
1488
1498 static void AFX_CDECL DrawIconComposited(CDC* pDC, CPoint pt, CSize szIcon, HICON hIcon);
1499
1501 CXTPSvgImage* GetSvgImage();
1504private:
1505 void CreateFadedIcon();
1506 void CreateShadowIcon();
1507
1508 void Clear(BOOL bIcon = FALSE);
1509 COLORREF LightenColor(COLORREF clr, double factor);
1510
1511 BOOL GetDIBBitmap(HBITMAP hBitmap, PBYTE& pBits, UINT& nBitsSize, PBITMAPINFO& pBitmapInfo,
1512 UINT& nBitmapInfoSize);
1513 HBITMAP ReadDIBBitmap(CArchive& ar, LPBYTE* pBits1);
1514 void WriteDIBBitmap(CArchive& ar, HBITMAP hBitmap);
1515
1516 CXTPImageManager* GetImageManager() const;
1517
1518private:
1519 CXTPImageManagerIcon(const CXTPImageManagerIcon&)
1520 : m_nID(0)
1521 , m_nType(RasterIcon)
1522 , m_pMarkupContext(NULL)
1523 {
1524 }
1525
1526 const CXTPImageManagerIcon& operator=(const CXTPImageManagerIcon&)
1527 {
1528 return *this;
1529 }
1530
1531public:
1532 BOOL m_bDrawComposited;
1534private:
1535 const UINT m_nID;
1536 enum IconType
1537 {
1538 UndefinedIcon,
1539 RasterIcon,
1540 VectorIcon
1541 } m_nType;
1542
1543 int m_nWidth;
1544 int m_nHeight;
1545 CSize m_szRecommendedExtent;
1546 CXTPImageManagerIconHandle m_hIcon;
1547 CXTPImageManagerIconHandle m_hFaded;
1548 CXTPImageManagerIconHandle m_hShadow;
1549 CXTPImageManagerIconHandle m_hHot;
1550 CXTPImageManagerIconHandle m_hChecked;
1551 CXTPImageManagerIconHandle m_hPressed;
1552 CXTPImageManagerIconHandle m_hDisabled;
1553 CXTPImageManagerIconHandle m_hDisabledAuto;
1554 CXTPImageManagerIconSet* m_pIconSet;
1555 CXTPImageManagerImageList* m_pImageList;
1556
1557 CXTPMarkupContext* m_pMarkupContext;
1558
1559 CXTPImageManagerVectorImageHandle m_VectorImageNormal;
1560 CXTPImageManagerVectorImageHandle m_VectorImageHot;
1561 CXTPImageManagerVectorImageHandle m_VectorImageChecked;
1562 CXTPImageManagerVectorImageHandle m_VectorImagePressed;
1563 CXTPImageManagerVectorImageHandle m_VectorImageDisabled;
1564
1565private:
1566 friend class CXTPImageManager;
1567 friend class CXTPImageManagerIconSet;
1568 friend class CXTPImageManagerIconHandle;
1569
1570# ifdef _XTP_ACTIVEX
1572public:
1573 DECLARE_DISPATCH_MAP()
1574 DECLARE_INTERFACE_MAP()
1575
1576 DECLARE_OLETYPELIB_EX(CXTPImageManagerIcon);
1577 afx_msg long OleGetHandle();
1578 afx_msg void OleDraw(long hDC, int x, int y, int cx, int cy, int nState);
1579 afx_msg LPDISPATCH OleCreatePicture(int nState);
1580 afx_msg LPDISPATCH OleScale(long nWidth);
1582# endif
1583};
1584
1589class _XTP_EXT_CLASS CXTPImageManagerIconSet : public CXTPCmdTarget
1590{
1591public:
1592 typedef CMap<UINT, UINT, CXTPImageManagerIcon*, CXTPImageManagerIcon*> CIconSetMap;
1596public:
1603 CXTPImageManagerIconSet(UINT nID, CXTPImageManager* pImageManager);
1604
1609 ~CXTPImageManagerIconSet();
1610
1619 CXTPImageManagerIcon* GetIcon(UINT nWidth, BOOL bScaled = TRUE);
1620
1627 CIconSetMap* GetIcons();
1628
1635 UINT GetID() const;
1636
1641 void RemoveAll();
1642
1647 void RefreshAll();
1648
1657 BOOL SetVectorIcon(IStream* pStream, UINT nWidth);
1658
1667 BOOL SetVectorDisabledIcon(IStream* pStream, UINT nWidth);
1668
1677 BOOL SetVectorHotIcon(IStream* pStream, UINT nWidth);
1678
1687 BOOL SetVectorCheckedIcon(IStream* pStream, UINT nWidth);
1688
1697 BOOL SetVectorPressedIcon(IStream* pStream, UINT nWidth);
1698
1707 BOOL SetVectorIcon(CXTPImageManagerVectorImageHandle hIcon, UINT nWidth);
1708
1717 BOOL SetVectorDisabledIcon(CXTPImageManagerVectorImageHandle hIcon, UINT nWidth);
1718
1727 BOOL SetVectorHotIcon(CXTPImageManagerVectorImageHandle hIcon, UINT nWidth);
1728
1737 BOOL SetVectorCheckedIcon(CXTPImageManagerVectorImageHandle hIcon, UINT nWidth);
1738
1747 BOOL SetVectorPressedIcon(CXTPImageManagerVectorImageHandle hIcon, UINT nWidth);
1748
1749private:
1750 CXTPImageManagerIcon* CreateIcon(UINT nWidth);
1751 CXTPImageManagerIcon* CreateVectorIcon(UINT nWidth);
1752 CXTPImageManagerVectorImageHandle CreateAutoVectorIconHandle(CXTPImageManagerIcon* pIcon,
1753 IStream* pStream);
1754
1755 void SetIcon(const CXTPImageManagerIconHandle& hIcon, UINT nWidth);
1756 void SetDisabledIcon(const CXTPImageManagerIconHandle& hIcon, UINT nWidth);
1757 void SetHotIcon(const CXTPImageManagerIconHandle& hIcon, UINT nWidth);
1758 void SetCheckedIcon(const CXTPImageManagerIconHandle& hIcon, UINT nWidth);
1759 void SetPressedIcon(const CXTPImageManagerIconHandle& hIcon, UINT nWidth);
1760
1761# ifdef _XTP_ACTIVEX
1763public:
1764 DECLARE_DISPATCH_MAP()
1765 DECLARE_INTERFACE_MAP()
1766 DECLARE_OLETYPELIB_EX(CXTPImageManagerIconSet);
1767 DECLARE_ENUM_VARIANTLIST(CXTPImageManagerIconSet)
1768
1769 afx_msg long OleGetCount();
1770 afx_msg long OleGetID();
1771 LPDISPATCH OleGetImage(long Width);
1772
1774# endif
1775
1776private:
1777 CXTPImageManagerIconSet(const CXTPImageManagerIconSet&)
1778 : m_nID(0)
1779 {
1780 }
1781
1782 const CXTPImageManagerIconSet& operator=(const CXTPImageManagerIconSet&)
1783 {
1784 return *this;
1785 }
1786
1787private:
1788 CIconSetMap m_mapIcons;
1789 const UINT m_nID;
1790 CXTPImageManager* m_pImageManager;
1791
1792private:
1793 friend class CXTPImageManager;
1794 friend class CXTPImageManagerIcon;
1795};
1796
1801class _XTP_EXT_CLASS CXTPImageManagerImageList
1802{
1803public:
1808 CXTPImageManagerImageList();
1809
1814 ~CXTPImageManagerImageList();
1815
1816public:
1825 BOOL Lookup(UINT nCommand);
1826
1835 CXTPImageManagerIcon* GetIcon(UINT nCommand);
1836
1848 void Draw(CDC* pDC, CPoint pt, CXTPImageManagerIcon* pIcon, CSize szIcon,
1849 COLORREF clrBK = CLR_NONE, COLORREF clrFG = CLR_NONE, UINT uiFlags = 0);
1850
1855 void RemoveAll();
1856
1863 CSize GetIconSize() const;
1864
1872 HICON GetIconHandle(UINT nCommand) const;
1873
1881 HBITMAP GetBitmapHandle(UINT nCommand) const;
1882
1883private:
1884 HIMAGELIST m_hImageList;
1885 BOOL m_bDestroyImageList;
1886 UINT m_nBaseCommand;
1887 CXTPImageManager* m_pImageManager;
1888 CMap<UINT, UINT, CXTPImageManagerIcon*, CXTPImageManagerIcon*> m_mapIcons;
1889
1890 friend class CXTPImageManager;
1891};
1892
1897class _XTP_EXT_CLASS CXTPImageManager : public CXTPCmdTarget
1898{
1899 friend class CXTPSingleton<CXTPImageManager>;
1900
1901 DECLARE_DYNAMIC(CXTPImageManager);
1902
1903public:
1908 CXTPImageManager();
1909
1914 ~CXTPImageManager();
1915
1916public:
1949 BOOL SetIcons(UINT nIDResourceToolBar, XTPImageState imageState = xtpImageNormal);
1950
1984 BOOL SetIcons(UINT nIDResourceToolBar, UINT nIDResourceBitmap,
1985 XTPImageState imageState = xtpImageNormal);
1986
2023 BOOL SetIcons(CBitmap& bmpIcons, UINT* pCommands, int nCount, CSize szIcon,
2024 XTPImageState imageState = xtpImageNormal, BOOL bAlpha = FALSE);
2025
2059 BOOL SetIcons(UINT nIDResourceToolBar, CBitmap& bmpIcons,
2060 XTPImageState imageState = xtpImageNormal);
2061
2097 BOOL SetIcons(UINT nIDResourceBitmap, UINT* pCommands, int nCount, CSize szIcon,
2098 XTPImageState imageState = xtpImageNormal);
2099
2135 BOOL SetIcons(LPCTSTR lpszResourceBitmap, UINT* pCommands, int nCount, CSize szIcon,
2136 XTPImageState imageState = xtpImageNormal);
2137
2173 BOOL SetIcons(CImageList& imlIcons, UINT* pCommands, int nCount, CSize szIcon,
2174 XTPImageState imageState = xtpImageNormal);
2175
2209 BOOL SetIcons(UINT nIDResourceToolBar, CImageList& imlIcons,
2210 XTPImageState imageState = xtpImageNormal);
2211
2222 BOOL SetIconFromIcoFile(LPCTSTR lpszFileName, UINT nIDCommand, CSize szIcon,
2223 XTPImageState imageState);
2224
2237 BOOL SetImageList(HIMAGELIST hImageList, int nBaseCommand, BOOL bDestroyImageList = FALSE);
2238
2256 BOOL SetImageList(UINT nIDResourceBitmap, int cx, int nBaseCommand = 0,
2257 COLORREF clrMask = (COLORREF)-1);
2258
2265 void AddIcons(CXTPImageManager* pImageManager);
2266
2273 void AddIcons(CXTPImageManagerIconSet* pIconSet);
2274
2287 BOOL SetIcon(const CXTPImageManagerIconHandle& hIcon, UINT nIDCommand, CSize szIcon = 0,
2288 XTPImageState imageState = xtpImageNormal);
2289
2302 BOOL SetIcon(UINT nIDResourceIcon, UINT nIDCommand, CSize szIcon = 0,
2303 XTPImageState imageState = xtpImageNormal);
2304
2317 BOOL SetIcon(LPCTSTR lpszResourceIcon, UINT nIDCommand, CSize szIcon = 0,
2318 XTPImageState imageState = xtpImageNormal);
2319
2331 BOOL SetVectorIcon(LPCTSTR lpResourceType, UINT nIDResource, UINT nIDCommand, UINT nWidth,
2332 XTPImageState imageState = xtpImageNormal);
2333
2345 BOOL SetVectorIcon(LPCTSTR lpResourceType, LPCTSTR lpResource, UINT nIDCommand, UINT nWidth,
2346 XTPImageState imageState = xtpImageNormal);
2347
2360 BOOL SetVectorIcon(HMODULE hModule, LPCTSTR lpResourceType, UINT nIDResource, UINT nIDCommand,
2361 UINT nWidth, XTPImageState imageState = xtpImageNormal);
2362
2375 BOOL SetVectorIcon(HMODULE hModule, LPCTSTR lpResourceType, LPCTSTR lpResource, UINT nIDCommand,
2376 UINT nWidth, XTPImageState imageState = xtpImageNormal);
2377
2388 BOOL SetVectorIcon(CXTPImageManagerVectorImageHandle hImage, UINT nIDCommand, UINT nWidth,
2389 XTPImageState imageState = xtpImageNormal);
2390
2405 BOOL SetVectorIcon(LPCTSTR lpResourceType, UINT nIDResourceNormal, UINT nIDResourceDisabled,
2406 UINT nIDResourceHot, UINT nIDResourceChecked, UINT nIDResourcePressed,
2407 UINT nIDCommand, UINT nWidth);
2408
2423 BOOL SetVectorIcon(LPCTSTR lpResourceType, LPCTSTR lpIDResourceNormal,
2424 LPCTSTR lpIDResourceDisabled, LPCTSTR lpIDResourceHot,
2425 LPCTSTR lpIDResourceChecked, LPCTSTR lpIDResourcePressed, UINT nIDCommand,
2426 UINT nWidth);
2427
2443 BOOL SetVectorIcon(HMODULE hModule, LPCTSTR lpResourceType, UINT nIDResourceNormal,
2444 UINT nIDResourceDisabled, UINT nIDResourceHot, UINT nIDResourceChecked,
2445 UINT nIDResourcePressed, UINT nIDCommand, UINT nWidth);
2446
2462 BOOL SetVectorIcon(HMODULE hModule, LPCTSTR lpResourceType, LPCTSTR lpIDResourceNormal,
2463 LPCTSTR lpIDResourceDisabled, LPCTSTR lpIDResourceHot,
2464 LPCTSTR lpIDResourceChecked, LPCTSTR lpIDResourcePressed, UINT nIDCommand,
2465 UINT nWidth);
2466
2480 BOOL SetVectorIcon(CXTPImageManagerVectorImageHandle hImageNormal,
2481 CXTPImageManagerVectorImageHandle hImageDisabled,
2482 CXTPImageManagerVectorImageHandle hImageHot,
2483 CXTPImageManagerVectorImageHandle hImageChecked,
2484 CXTPImageManagerVectorImageHandle hImagePressed, UINT nIDCommand,
2485 UINT nWidth);
2486
2497 BOOL SetVectorIcon(IStream* pStream, UINT nIDCommand, UINT nWidth, XTPImageState imageState);
2498
2506 COLORREF SetMaskColor(COLORREF clrMask);
2507
2514 COLORREF GetMaskColor() const;
2515
2523 void DrawReverted(BOOL bDrawReverted);
2524
2529 void RemoveAll();
2530
2536 void RemoveIcon(UINT nIDCommand);
2537
2542 void RefreshAll();
2543
2551 UINT AddCustomIcon(const CXTPImageManagerIconHandle& hIcon);
2552
2561 CXTPImageManagerIcon* GetImage(UINT nCommand, int nWidth = 16) const;
2562
2573 BOOL IsPrimaryImageExists(UINT nCommand, int nWidth) const;
2574
2582 CXTPImageManagerIconSet* GetIconSet(UINT nCommand) const;
2583
2591 CXTPImageManagerImageList* GetImageList(UINT nCommand) const;
2592
2599 CMap<UINT, UINT, CXTPImageManagerIconSet*, CXTPImageManagerIconSet*>* GetImages();
2600
2608 BOOL Lookup(UINT nCommand) const;
2609
2617 BOOL IsDrawReverted() const;
2618
2627 BOOL IsDrawReverted(CDC* pDC) const;
2628
2637 CXTPImageManagerResource* GetResource(CSize szIcon);
2638
2644 void Serialize(CArchive& ar);
2645
2652 void Serialize(UINT nCommand, CArchive& ar);
2653
2659 void DoPropExchange(CXTPPropExchange* pPX);
2660
2667 void DoPropExchange(UINT nCommand, CXTPPropExchange* pPX);
2668
2676 static BOOL AFX_CDECL IsAlphaBitmapResource(UINT nIDResourceBitmap);
2677
2685 static BOOL AFX_CDECL IsPngBitmapResource(UINT nIDResourceBitmap);
2686
2695 BOOL IsAlphaIconsSupported() const;
2696
2705 static BOOL AFX_CDECL IsAlphaIconsImageListSupported();
2706
2715 static COLORREF AFX_CDECL GetBitmapMaskColor(CBitmap& bmp, CPoint pt = 0);
2716
2725 static COLORREF AFX_CDECL GetBitmapMaskColor(UINT nIDBitmap, CPoint pt = 0);
2726
2736 static HBITMAP AFX_CDECL ResampleAlphaLayer(HBITMAP bmpAlpha, COLORREF clrMask);
2737
2747 static HBITMAP AFX_CDECL ResampleAlphaLayer(UINT nIDBitmap, COLORREF clrMask);
2748
2764 BOOL TransparentBlt(HDC hdcDest, const CRect& rcDest, HDC hdcSrc, const CRect& rcSrc,
2765 UINT crTransparent) const;
2766
2780 BOOL AlphaBlend(HDC hdcDest, const CRect& rcDest, HDC hdcSrc, const CRect& rcSrc) const;
2781
2796 BOOL AlphaBlend2(HDC hdcDest, const CRect& rcDest, HDC hdcSrc, const CRect& rcSrc,
2797 BYTE Transparency) const;
2798
2811 BOOL DisableBitmap(HDC hDC, const CRect& rcRect, COLORREF clrDisabledLight = (COLORREF)-1,
2812 COLORREF clrDisabledDark = (COLORREF)-1);
2813
2825 BOOL BlackWhiteBitmap(HDC hDC, const CRect& rcRect, int nBlackAndWhiteContrast = 0);
2826
2837 static HBITMAP AFX_CDECL Create32BPPDIBSection(HDC hDC, int iWidth, int iHeight,
2838 LPBYTE* lpBits = NULL);
2839
2851 BOOL SetIconFromResource(HINSTANCE hInst, LPCTSTR lpszResourceName, UINT nIDCommand,
2852 CSize szIcon, XTPImageState imageState);
2853
2872 static BOOL AFX_CDECL McTransparentBlt(HDC hdcDest, int nXOriginDest, int nYOriginDest,
2873 int nWidthDest, int nHeightDest, HDC hdcSrc,
2874 int nXOriginSrc, int nYOriginSrc, int nWidthSrc,
2875 int nHeightSrc, UINT crTransparent);
2876
2886 static void AFX_CDECL PreMultiplyAlphaBitmapBits(LPVOID lpBits, SIZE_T nSize,
2887 PBOOL pbAlpha = NULL);
2888
2898 static void AFX_CDECL PreMultiplyAlphaBitmapBits(LPVOID lpBits, CSize size,
2899 PBOOL pbAlpha = NULL);
2900
2901private:
2902 BOOL LoadToolbar(UINT nIDResourceToolBar, UINT*& pItems, int& nCount, CSize& szIcon) const;
2903
2904 UINT PasteCustomImage(COleDataObject& data);
2905 void CopyImage(UINT nCommand);
2906 BOOL SplitBitmap(HBITMAP hbmSource, int nCount, HBITMAP* pDest) const;
2907 BOOL IsWindow2000() const;
2908 BOOL BitmapsCompatible(LPBITMAP lpbm1, LPBITMAP lpbm2) const;
2909
2910 BOOL BlendImages(HBITMAP hbmSrc1, BOOL bRTL1, HBITMAP hbmSrc2, BOOL bRTL2,
2911 HBITMAP hbmDst) const;
2912 BOOL DoAlphaBlend(HDC hdcDest, int nXOriginDest, int nYOriginDest, int nWidthDest,
2913 int nHeightDest, HDC hdcSrc, int nXOriginSrc, int nYOriginSrc, int nWidthSrc,
2914 int nHeightSrc) const;
2915 BOOL DoDisableBitmap(HBITMAP hBmp, COLORREF clrDisabledLight = (COLORREF)-1,
2916 COLORREF clrDisabledDark = (COLORREF)-1, int nBlackAndWhiteContrast = -1);
2917
2918 BOOL ResourceToStream(HMODULE hModule, LPCTSTR lpResource, LPCTSTR lpResourceType,
2919 IStream** ppStream);
2920 BOOL FileToStream(LPCTSTR path, IStream** ppStream);
2921
2922public:
2923 static double m_dDisabledBrightnessFactor;
2924 static double m_dDisabledAlphaFactor;
2925 static BOOL m_bAutoResample;
2927 static CLIPFORMAT m_nImageClipFormat;
2928 static CLIPFORMAT m_nAlphaClipFormat;
2929 BOOL m_bUseResources;
2931private:
2932 COLORREF m_clrMask;
2933 CMap<UINT, UINT, CXTPImageManagerIconSet*, CXTPImageManagerIconSet*> m_mapImages;
2934 CArray<CXTPImageManagerImageList*, CXTPImageManagerImageList*> m_arrImageList;
2935 CMap<DWORD, DWORD, CXTPImageManagerResource*, CXTPImageManagerResource*> m_mapResources;
2936
2937 UINT m_nCustomID;
2938 BOOL m_bDrawReverted;
2939
2940private:
2941 friend _XTP_EXT_CLASS CXTPImageManager* AFX_CDECL XTPImageManager();
2942 friend class CXTPCustomizeSheet;
2943 friend class CXTPImageManagerIcon;
2944 friend class CXTPImageManagerIconHandle;
2945
2947public:
2948 static CXTPImageManager* AFX_CDECL FromDispatch(LPDISPATCH pDisp);
2949
2950# ifdef _XTP_ACTIVEX
2951 /* x64 #ifdef below is a fix for OLE_HANDLE. While HBITMAP/HICON are still 32-bit on 64-bit
2952 Windows, OLE_HANDLE (long) can still be used. But OLE_HANDLE cannot be used as HMODULE which
2953 is always 64-bit
2954 */
2955
2956# ifndef _WIN64
2957# define MODULE_HANDLE OLE_HANDLE
2958# define MODULE_HANDLE_TYPE VTS_I4
2959# define GDI_HANDLE long
2960# define GDI_HANDLE_TYPE VTS_I4
2961# else
2962# define MODULE_HANDLE LONG64
2963# define MODULE_HANDLE_TYPE VTS_I8
2964# define GDI_HANDLE LONG64
2965# define GDI_HANDLE_TYPE VTS_I8
2966# endif
2967
2968 DECLARE_DISPATCH_MAP()
2969 DECLARE_INTERFACE_MAP()
2970
2971 DECLARE_OLETYPELIB_EX(CXTPImageManager);
2972 DECLARE_ENUM_VARIANTLIST(CXTPImageManager)
2973
2974 afx_msg long OleGetCount();
2975 afx_msg void OleAddIcon(GDI_HANDLE Handle, long Command, long imageState);
2976 afx_msg void OleLoadIcon(LPCTSTR Path, long Command, long imageState);
2977 afx_msg void OleLoadBitmap(LPCTSTR Path, const VARIANT& Commands, long imageState);
2978 afx_msg void OleAddBitmap(GDI_HANDLE Handle, const VARIANT& Commands, long imageState,
2979 BOOL bAlphaBitmap);
2980 afx_msg void OleAddIcons(LPDISPATCH lpImageManagerIcons);
2981 afx_msg LPDISPATCH OleGetImage(long Command, long Width);
2982 afx_msg void OleLoadBitmapFromResource(MODULE_HANDLE Module, long Resource,
2983 const VARIANT& Commands, long imageState);
2984 afx_msg void OleLoadIconFromResource(MODULE_HANDLE Module, long Resource, long Command,
2985 long imageState);
2986 afx_msg void OleDoPropExchange(LPDISPATCH lpPropExchage);
2987
2988 afx_msg BOOL OleLoadVectorIcon(LPCTSTR Path, long nIDCommand, long nWidth,
2989 XTPImageState imageState);
2990 afx_msg BOOL OleLoadVectorIconCode(LPCTSTR Code, long nIDCommand, long nWidth,
2991 XTPImageState imageState);
2992 afx_msg BOOL OleLoadVectorIconFromResource(MODULE_HANDLE Module, LPCTSTR ResourceType,
2993 long Resource, long nIDCommand, long nWidth,
2994 XTPImageState imageState);
2995
2996# endif
2998};
2999
3024class _XTP_EXT_CLASS CXTPTempColorMask
3025{
3026public:
3035 CXTPTempColorMask(COLORREF crNewMask);
3036 CXTPTempColorMask(CXTPImageManager* pImageManager, COLORREF crNewMask);
3037
3043 ~CXTPTempColorMask();
3044
3045private:
3046 COLORREF m_crMask;
3047 CXTPImageManager* m_pImageManager;
3048};
3049
3058_XTP_EXT_CLASS CXTPImageManager* AFX_CDECL XTPImageManager();
3059
3061
3062AFX_INLINE CXTPImageManagerIconHandle::operator HICON() const
3063{
3064 return m_hIcon;
3065}
3066
3067AFX_INLINE CXTPImageManagerImageList* CXTPImageManagerIcon::GetImageList()
3068{
3069 return m_pImageList;
3070}
3071
3072AFX_INLINE const CXTPImageManagerImageList* CXTPImageManagerIcon::GetImageList() const
3073{
3074 return m_pImageList;
3075}
3076
3077AFX_INLINE UINT CXTPImageManagerIconSet::GetID() const
3078{
3079 return m_nID;
3080}
3081
3082AFX_INLINE CSize CXTPImageManagerIcon::GetRecommendedExtent() const
3083{
3084 return m_szRecommendedExtent;
3085}
3086
3087AFX_INLINE BOOL CXTPImageManagerIcon::IsScaled() const
3088{
3089 return FALSE;
3090}
3091
3092AFX_INLINE CXTPImageManagerVectorImageHandle CXTPImageManagerIcon::GetVectorCheckedIcon() const
3093{
3094 return GetVectorIcon(xtpImageChecked);
3095}
3096
3097AFX_INLINE CXTPImageManagerVectorImageHandle CXTPImageManagerIcon::GetVectorPressedIcon() const
3098{
3099 return GetVectorIcon(xtpImagePressed);
3100}
3101
3102AFX_INLINE CXTPImageManagerVectorImageHandle CXTPImageManagerIcon::GetVectorHotIcon() const
3103{
3104 return GetVectorIcon(xtpImageHot);
3105}
3106
3107AFX_INLINE CXTPImageManagerVectorImageHandle CXTPImageManagerIcon::GetVectorDisabledIcon() const
3108{
3109 return GetVectorIcon(xtpImageDisabled);
3110}
3111
3112AFX_INLINE BOOL CXTPImageManagerIcon::SetVectorDisabledIcon(CXTPImageManagerVectorImageHandle hIcon)
3113{
3114 return SetVectorIcon(hIcon, xtpImageDisabled);
3115}
3116
3117AFX_INLINE BOOL CXTPImageManagerIcon::SetVectorHotIcon(CXTPImageManagerVectorImageHandle hIcon)
3118{
3119 return SetVectorIcon(hIcon, xtpImageHot);
3120}
3121
3122AFX_INLINE BOOL CXTPImageManagerIcon::SetVectorCheckedIcon(CXTPImageManagerVectorImageHandle hIcon)
3123{
3124 return SetVectorIcon(hIcon, xtpImageChecked);
3125}
3126
3127AFX_INLINE BOOL CXTPImageManagerIcon::SetVectorPressedIcon(CXTPImageManagerVectorImageHandle hIcon)
3128{
3129 return SetVectorIcon(hIcon, xtpImagePressed);
3130}
3131
3132AFX_INLINE BOOL CXTPImageManagerIcon::IsRasterIcon() const
3133{
3134 return RasterIcon == m_nType;
3135}
3136
3137AFX_INLINE BOOL CXTPImageManagerIcon::IsVectorIcon() const
3138{
3139 return VectorIcon == m_nType;
3140}
3141
3142AFX_INLINE BOOL CXTPImageManagerIcon::IsUndefinedIcon() const
3143{
3144 return UndefinedIcon == m_nType;
3145}
3146
3147AFX_INLINE CXTPImageManagerIconSet::CIconSetMap* CXTPImageManagerIconSet::GetIcons()
3148{
3149 return &m_mapIcons;
3150}
3151
3152AFX_INLINE CMap<UINT, UINT, CXTPImageManagerIconSet*, CXTPImageManagerIconSet*>*
3153 CXTPImageManager::GetImages()
3154{
3155 return &m_mapImages;
3156}
3157
3158AFX_INLINE void CXTPImageManager::DrawReverted(BOOL bDrawReverted)
3159{
3160 m_bDrawReverted = bDrawReverted;
3161}
3162
3163AFX_INLINE BOOL CXTPImageManager::IsDrawReverted() const
3164{
3165 return m_bDrawReverted;
3166}
3167
3168AFX_INLINE CXTPTempColorMask::CXTPTempColorMask(COLORREF crNewMask)
3169{
3170 m_pImageManager = XTPImageManager();
3171 m_crMask = m_pImageManager->SetMaskColor(crNewMask);
3172}
3173
3174AFX_INLINE CXTPTempColorMask::CXTPTempColorMask(CXTPImageManager* pImageManager, COLORREF crNewMask)
3175{
3176 m_pImageManager = pImageManager;
3177 m_crMask = m_pImageManager->SetMaskColor(crNewMask);
3178}
3179
3180AFX_INLINE CXTPTempColorMask::~CXTPTempColorMask()
3181{
3182 m_pImageManager->SetMaskColor(m_crMask);
3183}
3193_XTP_EXT_CLASS BOOL AFX_CDECL XTPScaleBitmap(CBitmap* src, CBitmap* dst);
3194
3196_XTP_DEPRECATED_IN_FAVOR(XTPScaleBitmap)
3197AFX_INLINE BOOL ScaleBitmap(CBitmap* src, CBitmap* dst)
3198{
3199 return XTPScaleBitmap(src, dst);
3200}
3203# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
3205#endif //#if !defined(__XTPIMAGEMANAGER_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPIconSizeMatching
XTPIconSizeMatching
Icon size matching enumerators.
Definition XTPImageManager.h:68
xtpIconSizeExact
@ xtpIconSizeExact
Requires an icon to have size the same as requested.
Definition XTPImageManager.h:69
xtpIconSizeAtMost
@ xtpIconSizeAtMost
Requires an icon to have size no more than requested.
Definition XTPImageManager.h:71
xtpIconSizeAtLeast
@ xtpIconSizeAtLeast
Requires an icon to have size the same or larger than requested.
Definition XTPImageManager.h:70
XTPScaleBitmap
_XTP_EXT_CLASS BOOL AFX_CDECL XTPScaleBitmap(CBitmap *src, CBitmap *dst)
Scales bitmap image to the current DPI level.
XTPImageState
XTPImageState
Image state enumerators.
Definition XTPImageManager.h:55
xtpImageChecked
@ xtpImageChecked
Checked (selected) image.
Definition XTPImageManager.h:59
xtpImageNormal
@ xtpImageNormal
Normal image.
Definition XTPImageManager.h:56
xtpImageDisabled
@ xtpImageDisabled
Disabled image.
Definition XTPImageManager.h:57
xtpImageHot
@ xtpImageHot
Hot image.
Definition XTPImageManager.h:58
xtpImagePressed
@ xtpImagePressed
Pressed image.
Definition XTPImageManager.h:60
XTPImageManager
_XTP_EXT_CLASS CXTPImageManager *AFX_CDECL XTPImageManager()
XTPImageManager returns a pointer to the common CXTPImageManager class.
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPCustomizeSheet
CXTPCustomizeSheet is a CPropertySheet derived class.
Definition XTPCustomizeSheet.h:47
CXTPImageManager
CXTPImageManager is a standalone class.
Definition XTPImageManager.h:1898
CXTPImageManager::McTransparentBlt
static BOOL AFX_CDECL McTransparentBlt(HDC hdcDest, int nXOriginDest, int nYOriginDest, int nWidthDest, int nHeightDest, HDC hdcSrc, int nXOriginSrc, int nYOriginSrc, int nWidthSrc, int nHeightSrc, UINT crTransparent)
Fall back for systems without MSIMG32.DLL.
CXTPImageManager::SetVectorIcon
BOOL SetVectorIcon(HMODULE hModule, LPCTSTR lpResourceType, UINT nIDResourceNormal, UINT nIDResourceDisabled, UINT nIDResourceHot, UINT nIDResourceChecked, UINT nIDResourcePressed, UINT nIDCommand, UINT nWidth)
Sets a vector icon for the specific image state and command identifier.
CXTPImageManager::IsAlphaIconsImageListSupported
static BOOL AFX_CDECL IsAlphaIconsImageListSupported()
Determines if the OS supports alpha image list.
CXTPImageManager::DoPropExchange
void DoPropExchange(CXTPPropExchange *pPX)
Either reads icons from or writes icons to an archive.
CXTPImageManager::GetResource
CXTPImageManagerResource * GetResource(CSize szIcon)
Retrieves resources of a specified size.
CXTPImageManager::IsDrawReverted
BOOL IsDrawReverted() const
Checks if the icons are drawn mirrored/reverted.
CXTPImageManager::SetIcons
BOOL SetIcons(UINT nIDResourceBitmap, UINT *pCommands, int nCount, CSize szIcon, XTPImageState imageState=xtpImageNormal)
Adds the icons.
CXTPImageManager::DrawReverted
void DrawReverted(BOOL bDrawReverted)
Mirrors images around the y-axis, useful in RTL (Right-To-Left) Languages.
CXTPImageManager::m_dDisabledBrightnessFactor
static double m_dDisabledBrightnessFactor
Brightness factor of disabled icons.
Definition XTPImageManager.h:2923
CXTPImageManager::BlackWhiteBitmap
BOOL BlackWhiteBitmap(HDC hDC, const CRect &rcRect, int nBlackAndWhiteContrast=0)
This function makes a rectangle in a specified device context gray scale.
CXTPImageManager::IsPngBitmapResource
static BOOL AFX_CDECL IsPngBitmapResource(UINT nIDResourceBitmap)
Determines if a resource contains a .PNG image.
CXTPImageManager::m_bAutoResample
static BOOL m_bAutoResample
TRUE to automatically re-sample alpha bitmaps if msimg32 is not found.
Definition XTPImageManager.h:2925
CXTPImageManager::SetIconFromResource
BOOL SetIconFromResource(HINSTANCE hInst, LPCTSTR lpszResourceName, UINT nIDCommand, CSize szIcon, XTPImageState imageState)
This method adds all icons of a specified size from resources.
CXTPImageManager::RefreshAll
void RefreshAll()
Redraws all icons.
CXTPImageManager::SetVectorIcon
BOOL SetVectorIcon(LPCTSTR lpResourceType, UINT nIDResourceNormal, UINT nIDResourceDisabled, UINT nIDResourceHot, UINT nIDResourceChecked, UINT nIDResourcePressed, UINT nIDCommand, UINT nWidth)
Sets a vector icon for the specific image state and command identifier.
CXTPImageManager::SetImageList
BOOL SetImageList(UINT nIDResourceBitmap, int cx, int nBaseCommand=0, COLORREF clrMask=(COLORREF) -1)
Call this method to create a system HIMAGELIST from a bitmap and add it to the image manager.
CXTPImageManager::SetIcon
BOOL SetIcon(UINT nIDResourceIcon, UINT nIDCommand, CSize szIcon=0, XTPImageState imageState=xtpImageNormal)
Adds the icon.
CXTPImageManager::PreMultiplyAlphaBitmapBits
static void AFX_CDECL PreMultiplyAlphaBitmapBits(LPVOID lpBits, CSize size, PBOOL pbAlpha=NULL)
Pre-multiplies alpha bitmap bits to be used in AlphaBlend.
CXTPImageManager::m_nImageClipFormat
static CLIPFORMAT m_nImageClipFormat
Clipboard format of icons.
Definition XTPImageManager.h:2927
CXTPImageManager::PreMultiplyAlphaBitmapBits
static void AFX_CDECL PreMultiplyAlphaBitmapBits(LPVOID lpBits, SIZE_T nSize, PBOOL pbAlpha=NULL)
Pre-multiplies alpha bitmap bits to be used in AlphaBlend.
CXTPImageManager::SetVectorIcon
BOOL SetVectorIcon(LPCTSTR lpResourceType, LPCTSTR lpResource, UINT nIDCommand, UINT nWidth, XTPImageState imageState=xtpImageNormal)
Sets a vector icon for the specific image state and command identifier.
CXTPImageManager::AddIcons
void AddIcons(CXTPImageManager *pImageManager)
Adds the icons from another image manager.
CXTPImageManager::SetVectorIcon
BOOL SetVectorIcon(HMODULE hModule, LPCTSTR lpResourceType, UINT nIDResource, UINT nIDCommand, UINT nWidth, XTPImageState imageState=xtpImageNormal)
Sets a vector icon for the specific image state and command identifier.
CXTPImageManager::SetIcons
BOOL SetIcons(LPCTSTR lpszResourceBitmap, UINT *pCommands, int nCount, CSize szIcon, XTPImageState imageState=xtpImageNormal)
Adds the icons.
CXTPImageManager::IsAlphaIconsSupported
BOOL IsAlphaIconsSupported() const
Determines if the OS supports alpha icons.
CXTPImageManager::ResampleAlphaLayer
static HBITMAP AFX_CDECL ResampleAlphaLayer(HBITMAP bmpAlpha, COLORREF clrMask)
This method creates a 24bit bitmap from a 32bit alpha bitmap to draw it in old OSs.
CXTPImageManager::DisableBitmap
BOOL DisableBitmap(HDC hDC, const CRect &rcRect, COLORREF clrDisabledLight=(COLORREF) -1, COLORREF clrDisabledDark=(COLORREF) -1)
This function makes a rectangle in a specified device context disabled.
CXTPImageManager::AddCustomIcon
UINT AddCustomIcon(const CXTPImageManagerIconHandle &hIcon)
This method is used by CommandBars to add custom icons.
CXTPImageManager::m_nAlphaClipFormat
static CLIPFORMAT m_nAlphaClipFormat
Clipboard format of icons.
Definition XTPImageManager.h:2928
CXTPImageManager::m_dDisabledAlphaFactor
static double m_dDisabledAlphaFactor
Alpha factor of disabled icons.
Definition XTPImageManager.h:2924
CXTPImageManager::SetImageList
BOOL SetImageList(HIMAGELIST hImageList, int nBaseCommand, BOOL bDestroyImageList=FALSE)
Call this method to attach images from an HIMAGELIST control to the image manager.
CXTPImageManager::ResampleAlphaLayer
static HBITMAP AFX_CDECL ResampleAlphaLayer(UINT nIDBitmap, COLORREF clrMask)
This method creates a 24bit bitmap from a 32bit alpha bitmap to draw it in old OSs.
CXTPImageManager::SetVectorIcon
BOOL SetVectorIcon(HMODULE hModule, LPCTSTR lpResourceType, LPCTSTR lpResource, UINT nIDCommand, UINT nWidth, XTPImageState imageState=xtpImageNormal)
Sets a vector icon for the specific image state and command identifier.
CXTPImageManager::SetVectorIcon
BOOL SetVectorIcon(LPCTSTR lpResourceType, UINT nIDResource, UINT nIDCommand, UINT nWidth, XTPImageState imageState=xtpImageNormal)
Sets a vector icon for the specific image state and command identifier.
CXTPImageManager::SetIconFromIcoFile
BOOL SetIconFromIcoFile(LPCTSTR lpszFileName, UINT nIDCommand, CSize szIcon, XTPImageState imageState)
This method loads an icon from an .ico file.
CXTPImageManager::SetVectorIcon
BOOL SetVectorIcon(CXTPImageManagerVectorImageHandle hImage, UINT nIDCommand, UINT nWidth, XTPImageState imageState=xtpImageNormal)
Sets a vector icon for the specific image state and command identifier.
CXTPImageManager::SetIcon
BOOL SetIcon(LPCTSTR lpszResourceIcon, UINT nIDCommand, CSize szIcon=0, XTPImageState imageState=xtpImageNormal)
Sets the icon.
CXTPImageManager::SetVectorIcon
BOOL SetVectorIcon(CXTPImageManagerVectorImageHandle hImageNormal, CXTPImageManagerVectorImageHandle hImageDisabled, CXTPImageManagerVectorImageHandle hImageHot, CXTPImageManagerVectorImageHandle hImageChecked, CXTPImageManagerVectorImageHandle hImagePressed, UINT nIDCommand, UINT nWidth)
Sets a vector icon for the specific image state and command identifier.
CXTPImageManager::AlphaBlend
BOOL AlphaBlend(HDC hdcDest, const CRect &rcDest, HDC hdcSrc, const CRect &rcSrc) const
The AlphaBlend function displays bitmaps that have transparent or semi-transparent pixels.
CXTPImageManager::Lookup
BOOL Lookup(UINT nCommand) const
Checks if an icon set exists with a specified ID.
CXTPImageManager::IsDrawReverted
BOOL IsDrawReverted(CDC *pDC) const
Checks if the icons are drawn mirrored/reverted.
CXTPImageManager::SetIcons
BOOL SetIcons(UINT nIDResourceToolBar, XTPImageState imageState=xtpImageNormal)
Adds the icons.
CXTPImageManager::CXTPImageManager
CXTPImageManager()
Constructs a CXTPImageManager object.
CXTPImageManager::RemoveAll
void RemoveAll()
Removes all icons.
CXTPImageManager::Create32BPPDIBSection
static HBITMAP AFX_CDECL Create32BPPDIBSection(HDC hDC, int iWidth, int iHeight, LPBYTE *lpBits=NULL)
This helper method creates a 32bit bitmap.
CXTPImageManager::SetIcons
BOOL SetIcons(CImageList &imlIcons, UINT *pCommands, int nCount, CSize szIcon, XTPImageState imageState=xtpImageNormal)
Adds the icons.
CXTPImageManager::IsAlphaBitmapResource
static BOOL AFX_CDECL IsAlphaBitmapResource(UINT nIDResourceBitmap)
Checks if a bitmap with a specified resource has alpha channel.
CXTPImageManager::m_bUseResources
BOOL m_bUseResources
TRUE to create a single bitmap for all icons.
Definition XTPImageManager.h:2929
CXTPImageManager::GetMaskColor
COLORREF GetMaskColor() const
Retrieves mask color.
CXTPImageManager::IsPrimaryImageExists
BOOL IsPrimaryImageExists(UINT nCommand, int nWidth) const
Call this method to determine if a non-scaled image exists in the image manager.
CXTPImageManager::~CXTPImageManager
~CXTPImageManager()
Destroys a CXTPImageManager object, handles cleanup and deallocation.
CXTPImageManager::Serialize
void Serialize(UINT nCommand, CArchive &ar)
Either reads icons from or writes icons to an archive.
CXTPImageManager::Serialize
void Serialize(CArchive &ar)
Either reads icons from or writes icons to an archive.
CXTPImageManager::SetIcons
BOOL SetIcons(UINT nIDResourceToolBar, CBitmap &bmpIcons, XTPImageState imageState=xtpImageNormal)
Adds the icons.
CXTPImageManager::GetIconSet
CXTPImageManagerIconSet * GetIconSet(UINT nCommand) const
Call this member to get the icon set with the specified ID.
CXTPImageManager::GetImageList
CXTPImageManagerImageList * GetImageList(UINT nCommand) const
Call this member to get the icon set with the specified ID from an image list.
CXTPImageManager::GetBitmapMaskColor
static COLORREF AFX_CDECL GetBitmapMaskColor(UINT nIDBitmap, CPoint pt=0)
Retrieves the color of the top-left pixel.
CXTPImageManager::SetIcons
BOOL SetIcons(UINT nIDResourceToolBar, UINT nIDResourceBitmap, XTPImageState imageState=xtpImageNormal)
Adds the icons.
CXTPImageManager::SetVectorIcon
BOOL SetVectorIcon(LPCTSTR lpResourceType, LPCTSTR lpIDResourceNormal, LPCTSTR lpIDResourceDisabled, LPCTSTR lpIDResourceHot, LPCTSTR lpIDResourceChecked, LPCTSTR lpIDResourcePressed, UINT nIDCommand, UINT nWidth)
Sets a vector icon for the specific image state and command identifier.
CXTPImageManager::XTPImageManager
friend _XTP_EXT_CLASS CXTPImageManager *AFX_CDECL XTPImageManager()
XTPImageManager returns a pointer to the common CXTPImageManager class.
CXTPImageManager::GetBitmapMaskColor
static COLORREF AFX_CDECL GetBitmapMaskColor(CBitmap &bmp, CPoint pt=0)
Retrieves the color of the top-left pixel.
CXTPImageManager::SetIcons
BOOL SetIcons(CBitmap &bmpIcons, UINT *pCommands, int nCount, CSize szIcon, XTPImageState imageState=xtpImageNormal, BOOL bAlpha=FALSE)
Adds the icons.
CXTPImageManager::SetIcon
BOOL SetIcon(const CXTPImageManagerIconHandle &hIcon, UINT nIDCommand, CSize szIcon=0, XTPImageState imageState=xtpImageNormal)
Adds the icon.
CXTPImageManager::GetImage
CXTPImageManagerIcon * GetImage(UINT nCommand, int nWidth=16) const
Call this member to get the icon with the specified ID and width.
CXTPImageManager::TransparentBlt
BOOL TransparentBlt(HDC hdcDest, const CRect &rcDest, HDC hdcSrc, const CRect &rcSrc, UINT crTransparent) const
The TransparentBlt function performs a bit-block transfer of the color data corresponding to a rectan...
CXTPImageManager::RemoveIcon
void RemoveIcon(UINT nIDCommand)
Removes the specified icon.
CXTPImageManager::AddIcons
void AddIcons(CXTPImageManagerIconSet *pIconSet)
Adds the icons from another image manager.
CXTPImageManager::SetVectorIcon
BOOL SetVectorIcon(HMODULE hModule, LPCTSTR lpResourceType, LPCTSTR lpIDResourceNormal, LPCTSTR lpIDResourceDisabled, LPCTSTR lpIDResourceHot, LPCTSTR lpIDResourceChecked, LPCTSTR lpIDResourcePressed, UINT nIDCommand, UINT nWidth)
Sets a vector icon for the specific image state and command identifier.
CXTPImageManager::DoPropExchange
void DoPropExchange(UINT nCommand, CXTPPropExchange *pPX)
Either reads icons from or writes icons to an archive.
CXTPImageManager::AlphaBlend2
BOOL AlphaBlend2(HDC hdcDest, const CRect &rcDest, HDC hdcSrc, const CRect &rcSrc, BYTE Transparency) const
The AlphaBlend function displays bitmaps that have transparent or semi-transparent pixels.
CXTPImageManager::GetImages
CMap< UINT, UINT, CXTPImageManagerIconSet *, CXTPImageManagerIconSet * > * GetImages()
Retrieves a collection of images.
CXTPImageManager::SetMaskColor
COLORREF SetMaskColor(COLORREF clrMask)
Call this method to set the mask color of the bitmaps that will be added.
CXTPImageManager::SetVectorIcon
BOOL SetVectorIcon(IStream *pStream, UINT nIDCommand, UINT nWidth, XTPImageState imageState)
Sets a vector icon for the specific image state and command identifier.
CXTPImageManager::SetIcons
BOOL SetIcons(UINT nIDResourceToolBar, CImageList &imlIcons, XTPImageState imageState=xtpImageNormal)
Adds the icons.
CXTPImageManagerIconHandle
CXTPImageManagerIconHandle is a HICON wrapper class.
Definition XTPImageManager.h:384
CXTPImageManagerIconHandle::CXTPImageManagerIconHandle
CXTPImageManagerIconHandle()
Constructs a CXTPImageManagerIconHandle object.
CXTPImageManagerIconHandle::GetDpiScaled
HICON GetDpiScaled(int nDpi=0) const
Obtains a new icon handle with the icon image scaled to the specified DPI.
CXTPImageManagerIconHandle::GetBitmap
HBITMAP GetBitmap() const
Retrieves bitmap handle.
CXTPImageManagerIconHandle::Init
void Init()
Initializes icons.
CXTPImageManagerIconHandle::CopyHandle
void CopyHandle(const CXTPImageManagerIconHandle &handle)
Copies data from an HBITMAP or CXTPImageManagerIconHandle object.
CXTPImageManagerIconHandle::m_bClearHandles
BOOL m_bClearHandles
TRUE if object must destroy handlers.
Definition XTPImageManager.h:605
CXTPImageManagerIconHandle::GetIcon
HICON GetIcon() const
Retrieves the icon handle.
CXTPImageManagerIconHandle::CopyHandle
void CopyHandle(HBITMAP hBitmap)
Copies data from an HBITMAP or CXTPImageManagerIconHandle object.
CXTPImageManagerIconHandle::IsAlpha
BOOL IsAlpha() const
Checks if the image has alpha channel.
CXTPImageManagerIconHandle::m_pImageManager
CXTPImageManager * m_pImageManager
Pointer to parent Image Manager.
Definition XTPImageManager.h:606
CXTPImageManagerIconHandle::m_hBitmap
HBITMAP m_hBitmap
The underlying Alpha bitmap handler for this CXTPImageManagerIconHandle object.
Definition XTPImageManager.h:602
CXTPImageManagerIconHandle::m_szIcon
CSize m_szIcon
Size of the icon.
Definition XTPImageManager.h:609
CXTPImageManagerIconHandle::CreateIconFromResource
BOOL CreateIconFromResource(LPCTSTR lpszResourceName, CSize szIcon, BOOL bGroupResource=TRUE, XTPIconSizeMatching nSizeMatching=xtpIconSizeExact)
Creates an icon from resource bits describing the icon.
CXTPImageManagerIconHandle::Attach
void Attach(HICON hIcon, BOOL bSharedHandle)
Attaches an object to an existing icon handle.
CXTPImageManagerIconHandle::m_bUseResources
BOOL m_bUseResources
TRUE to use common resources.
Definition XTPImageManager.h:610
CXTPImageManagerIconHandle::GetExtent
CSize GetExtent() const
Retrieves the size of the icon.
CXTPImageManagerIconHandle::m_hIcon
HICON m_hIcon
The underlying HICON handler for this CXTPImageManagerIconHandle object.
Definition XTPImageManager.h:601
CXTPImageManagerIconHandle::Clear
void Clear()
Release bitmap and icon handlers.
CXTPImageManagerIconHandle::CXTPImageManagerIconHandle
CXTPImageManagerIconHandle(HBITMAP hBitmap, BOOL bSharedHandle=TRUE)
Constructs a CXTPImageManagerIconHandle object.
CXTPImageManagerIconHandle::CXTPImageManagerIconHandle
CXTPImageManagerIconHandle(HICON hIcon, BOOL bUseResources=TRUE, BOOL bSharedHandle=TRUE)
Constructs a CXTPImageManagerIconHandle object.
CXTPImageManagerIconHandle::Detach
void Detach()
Detaches the handle from the associated icon handle without releasing the resource.
CXTPImageManagerIconHandle::Attach
void Attach(HBITMAP hBitmap, BOOL bSharedHandle)
Attaches an object to an existing bitmap handle.
CXTPImageManagerIconHandle::~CXTPImageManagerIconHandle
~CXTPImageManagerIconHandle()
Destroys a CXTPImageManagerIconHandle object, handles cleanup and deallocation.
CXTPImageManagerIconHandle::PreMultiply
LPBYTE PreMultiply()
Creates an alpha bitmap with a valid alpha layer.
CXTPImageManagerIconHandle::CXTPImageManagerIconHandle
CXTPImageManagerIconHandle(const CXTPImageManagerIconHandle &hHandle)
Constructs a CXTPImageManagerIconHandle object.
CXTPImageManagerIconHandle::CreateIconFromResource
BOOL CreateIconFromResource(HINSTANCE hInst, LPCTSTR lpszResourceName, CSize szIcon, BOOL bGroupResource, XTPIconSizeMatching nSizeMatching=xtpIconSizeExact)
Creates an icon from resource bits describing the icon.
CXTPImageManagerIconHandle::m_pBits
LPBYTE m_pBits
Alpha bitmap bits.
Definition XTPImageManager.h:604
CXTPImageManagerIconHandle::IsEmpty
BOOL IsEmpty() const
Checks if the class has no icon.
CXTPImageManagerIconHandle::m_pRInfo
XTP_IMAGERESOURCE_INFO * m_pRInfo
Pointer to resource info if the icon is part of common resources.
Definition XTPImageManager.h:607
CXTPImageManagerIconHandle::Draw
void Draw(CDC *pDC, CPoint pt, CSize szIcon, BOOL bDrawComposited=FALSE)
Call this method to draw icons.
CXTPImageManagerIcon
Icons holder class.
Definition XTPImageManager.h:622
CXTPImageManagerIcon::GetID
UINT GetID() const
Retrieves the image identifier.
CXTPImageManagerIcon::DrawMono
void DrawMono(CDC *pDC, CPoint pt, CXTPImageManagerIconHandle &hIcon, CSize szIcon, COLORREF clrBrush)
Draws the image using the brush specified by the clrBrush parameter.
CXTPImageManagerIcon::CXTPImageManagerIcon
CXTPImageManagerIcon(UINT nID, int nWidth, int nHeight, CXTPImageManagerIconSet *pIconSet=NULL)
Constructs a CXTPImageManagerIcon object.
CXTPImageManagerIcon::SetIcon
BOOL SetIcon(UINT nIDResourceIcon, int nWidth, int nHeight, XTPIconSizeMatching nSizeMatching=xtpIconSizeExact)
Sets the icon.
CXTPImageManagerIcon::HasPressedIcon
BOOL HasPressedIcon() const
Determines if a state specific icon exists.
CXTPImageManagerIcon::IsAlphaBitmapFile
static BOOL AFX_CDECL IsAlphaBitmapFile(LPCTSTR pszFileName)
This method tests if the file is an alpha bitmap.
CXTPImageManagerIcon::SetPressedIcon
void SetPressedIcon(const CXTPImageManagerIconHandle &hIcon)
Sets the pressed icon.
CXTPImageManagerIcon::LoadAlphaIcon
static HBITMAP AFX_CDECL LoadAlphaIcon(LPCTSTR pszFileName, int nWidth)
This method loads an alpha bitmap from an icon file.
CXTPImageManagerIcon::GetVectorIcon
CXTPImageManagerVectorImageHandle GetVectorIcon() const
Obtains the vector icon handle for a specified state.
CXTPImageManagerIcon::ScaleToFit
static HICON AFX_CDECL ScaleToFit(HICON hIcon, CSize szExtent, int nWidth)
Use this method to scale an icon.
CXTPImageManagerIcon::CXTPImageManagerIcon
CXTPImageManagerIcon(UINT nID, int nWidth, int nHeight, CXTPImageManagerImageList *pImageList)
Constructs a CXTPImageManagerIcon object.
CXTPImageManagerIcon::PreMultiplyAlphaBitmap
static HBITMAP AFX_CDECL PreMultiplyAlphaBitmap(HBITMAP hBitmap, BOOL *pbAlpha=NULL, LPBYTE *lpBits=NULL)
Creates valid alpha bits to use in AlphaBlend.
CXTPImageManagerIcon::IsDirectDrawSupported
BOOL IsDirectDrawSupported(XTPImageState imageState=xtpImageNormal) const
Determines if the encapsulated vector image supports drawing its bits directly into a memory buffer.
CXTPImageManagerIcon::DirectDraw
SIZE_T DirectDraw(PVOID pBits, SIZE_T cbSize, CPoint pt, CSize szIcon)
Draw vector image bits directly into the specified memoby buffer.
CXTPImageManagerIcon::GetWidth
int GetWidth() const
Retrieves the icon width.
CXTPImageManagerIcon::GetPressedIcon
CXTPImageManagerIconHandle & GetPressedIcon()
Retrieves the pressed icon.
CXTPImageManagerIcon::SetVectorIcon
BOOL SetVectorIcon(CXTPImageManagerVectorImageHandle hIcon)
Sets the icon for a specified state.
CXTPImageManagerIcon::InvertAlphaBitmap
static HBITMAP AFX_CDECL InvertAlphaBitmap(HBITMAP hBitmap)
This method is called to create a mirror copy of a bitmap.
CXTPImageManagerIcon::GetHeight
int GetHeight() const
Retrieves the icon height.
CXTPImageManagerIcon::Draw
void Draw(CDC *pDC, CPoint pt)
Draws the image at a specified location.
CXTPImageManagerIcon::GetFadedIcon
CXTPImageManagerIconHandle & GetFadedIcon()
Retrieves the faded icon.
CXTPImageManagerIcon::GetVectorHotIcon
CXTPImageManagerVectorImageHandle GetVectorHotIcon() const
Obtains the vector icon handle for a specified state.
CXTPImageManagerIcon::SetVectorCheckedIcon
BOOL SetVectorCheckedIcon(CXTPImageManagerVectorImageHandle hIcon)
Sets the icon for a specified state.
CXTPImageManagerIcon::CopyAlphaBitmap
static HBITMAP AFX_CDECL CopyAlphaBitmap(HBITMAP hBitmap, LPBYTE *lpBits=NULL)
Copies an alpha bitmap.
CXTPImageManagerIcon::SetVectorDisabledIcon
BOOL SetVectorDisabledIcon(CXTPImageManagerVectorImageHandle hIcon)
Sets the icon for a specified state.
CXTPImageManagerIcon::IsPngBitmapFile
static BOOL AFX_CDECL IsPngBitmapFile(LPCTSTR pszFileName)
This method tests if the file is a .png image.
CXTPImageManagerIcon::SetVectorHotIcon
BOOL SetVectorHotIcon(CXTPImageManagerVectorImageHandle hIcon)
Sets the icon for a specified state.
CXTPImageManagerIcon::LoadBitmapFromFile
static HBITMAP AFX_CDECL LoadBitmapFromFile(LPCTSTR lpszFileName, BOOL *lbAlphaBitmap=NULL)
This method loads a bitmap or .png from a file on disk.
CXTPImageManagerIcon::LoadBitmapFromResource
static HBITMAP AFX_CDECL LoadBitmapFromResource(LPCTSTR lpszResource, BOOL *lbAlphaBitmap)
This method loads an alpha bitmap or .png from a resource file.
CXTPImageManagerIcon::SetDisabledIcon
void SetDisabledIcon(const CXTPImageManagerIconHandle &hIcon)
Sets the disabled icon.
CXTPImageManagerIcon::GetVectorDisabledIcon
CXTPImageManagerVectorImageHandle GetVectorDisabledIcon() const
Obtains the vector icon handle for a specified state.
CXTPImageManagerIcon::GetIcon
CXTPImageManagerIconHandle & GetIcon()
Retrieves the icon handle.
CXTPImageManagerIcon::GetShadowIcon
CXTPImageManagerIconHandle & GetShadowIcon()
Retrieves the shadow for the icon.
CXTPImageManagerIcon::GetVectorCheckedIcon
CXTPImageManagerVectorImageHandle GetVectorCheckedIcon() const
Obtains the vector icon handle for a specified state.
CXTPImageManagerIcon::GetIcon
CXTPImageManagerIconHandle & GetIcon(XTPImageState imageState)
Retrieves the icon handle.
CXTPImageManagerIcon::CXTPImageManagerIcon
CXTPImageManagerIcon(UINT nID, CXTPImageManagerIconSet *pIconSet=NULL, CSize szRecommendedExtent=CSize(0))
Constructs a CXTPImageManagerIcon object.
CXTPImageManagerIcon::IsAlpha
BOOL IsAlpha() const
Checks if the image has alpha channel.
CXTPImageManagerIcon::GetImageList
const CXTPImageManagerImageList * GetImageList() const
Obtains a pointer to an associated image list if the icon object is an icon in an image list.
CXTPImageManagerIcon::DrawIconComposited
static void AFX_CDECL DrawIconComposited(CDC *pDC, CPoint pt, CSize szIcon, HICON hIcon)
Call this method to draw a non-alpha icon in a composited Vista Glass rectangle.
CXTPImageManagerIcon::IsScaled
BOOL IsScaled() const
Checks if icons were scaled from another CXTPImageManagerIcon object.
CXTPImageManagerIcon::GetImageList
CXTPImageManagerImageList * GetImageList()
Obtains a pointer to an associated image list if the icon object is an icon in an image list.
CXTPImageManagerIcon::SetCheckedIcon
void SetCheckedIcon(const CXTPImageManagerIconHandle &hIcon)
Sets the checked icon.
CXTPImageManagerIcon::HasDisabledIcon
BOOL HasDisabledIcon() const
Determines if a state specific icon exists.
CXTPImageManagerIcon::GetMarkupContext
CXTPMarkupContext * GetMarkupContext()
Retrieves the markup context for the icon.
CXTPImageManagerIcon::LoadAlphaBitmap
static HBITMAP AFX_CDECL LoadAlphaBitmap(UINT nIDResource)
This method loads an alpha bitmap from a resource file.
CXTPImageManagerIcon::DirectDraw
SIZE_T DirectDraw(PVOID pBits, SIZE_T cbSize, CPoint pt, XTPImageState imageState, CSize szIcon)
Draw vector image bits directly into the specified memoby buffer.
CXTPImageManagerIcon::CreateMarkupContext
CXTPMarkupContext * CreateMarkupContext()
Creates a markup context if it is necessary for the icon and has not already been created.
CXTPImageManagerIcon::DirectDraw
SIZE_T DirectDraw(PVOID pBits, SIZE_T cbSize, CPoint pt, CXTPImageManagerVectorImageHandle hIcon, CSize szIcon=0)
Draw vector image bits directly into the specified memoby buffer.
CXTPImageManagerIcon::SetVectorPressedIcon
BOOL SetVectorPressedIcon(CXTPImageManagerVectorImageHandle hIcon)
Sets the icon for a specified state.
CXTPImageManagerIcon::Draw
void Draw(CDC *pDC, CPoint pt, XTPImageState imageState)
Draws the image at a specified location.
CXTPImageManagerIcon::SetVectorIcon
BOOL SetVectorIcon(CXTPImageManagerVectorImageHandle hIcon, XTPImageState imageState)
Sets the icon for a specified state.
CXTPImageManagerIcon::SetNormalIcon
void SetNormalIcon(const CXTPImageManagerIconHandle &hIcon)
Sets the icon.
CXTPImageManagerIcon::IsAlphaIconHandle
static BOOL AFX_CDECL IsAlphaIconHandle(HICON hIcon)
Determines whether the provided icon is translucent or not.
CXTPImageManagerIcon::HasHotIcon
BOOL HasHotIcon() const
Determines if a state specific icon exists.
CXTPImageManagerIcon::IsUndefinedIcon
BOOL IsUndefinedIcon() const
Checks if the current icon has an underfined type, i.e.
CXTPImageManagerIcon::DrawAlphaBitmap
static void AFX_CDECL DrawAlphaBitmap(CDC *pDC, HBITMAP hBitmap, CPoint ptDest, CSize szDest, CPoint ptSrc=0, CSize szSrc=0)
The DrawAlphaBitmap function displays bitmaps that have transparent or semitransparent pixels.
CXTPImageManagerIcon::GetExtent
CSize GetExtent() const
Retrieves the size of the icon.
CXTPImageManagerIcon::Serialize
void Serialize(CArchive &ar)
Either reads this object from or writes this object to an archive.
CXTPImageManagerIcon::GetDisabledIcon
CXTPImageManagerIconHandle & GetDisabledIcon(BOOL bCreateIfNotExists=TRUE)
Retrieves the disabled icon.
CXTPImageManagerIcon::HasCheckedIcon
BOOL HasCheckedIcon() const
Determines if a state specific icon exists.
CXTPImageManagerIcon::IsVectorIcon
BOOL IsVectorIcon() const
Checks if the current icon is a vector icon.
CXTPImageManagerIcon::SerializeIcon
void SerializeIcon(CXTPImageManagerIconHandle &hIcon, CArchive &ar, long nSchema)
Either reads this object from or writes this object to an archive.
CXTPImageManagerIcon::LoadAlphaBitmap
static HBITMAP AFX_CDECL LoadAlphaBitmap(HMODULE hModule, LPCTSTR lpszResource)
This method loads an alpha bitmap from a resource file.
CXTPImageManagerIcon::Copy
void Copy(CXTPImageManagerIcon *pIcon)
Makes the current icon a copy of a provided icon.
CXTPImageManagerIcon::Draw
void Draw(CDC *pDC, CPoint pt, CXTPImageManagerVectorImageHandle hIcon, CSize szIcon=0)
Draws the image at a specified location.
CXTPImageManagerIcon::IsAlphaBitmapResource
static BOOL AFX_CDECL IsAlphaBitmapResource(HMODULE hModule, LPCTSTR lpBitmapName)
Checks if a bitmap with a specified resource has alpha channel.
CXTPImageManagerIcon::SetIcon
BOOL SetIcon(const CXTPImageManagerIconHandle &hIcon, XTPImageState imageState)
Sets the icon.
CXTPImageManagerIcon::GetExtent
static CSize AFX_CDECL GetExtent(HICON hIcon)
Retrieves the size of the icon.
CXTPImageManagerIcon::Refresh
void Refresh()
Redraws Fade and Shadow icons.
CXTPImageManagerIcon::Draw
void Draw(CDC *pDC, CPoint pt, CXTPImageManagerIconHandle &hIcon, CSize szIcon=0, COLORREF clrBK=CLR_NONE, COLORREF clrFG=CLR_NONE, UINT uiFlags=0)
Draws the image at a specified location.
CXTPImageManagerIcon::GetBitmapBits
static BOOL AFX_CDECL GetBitmapBits(CDC &dcSrc, HBITMAP hBitmap, PBITMAPINFO &pbmi, LPVOID &pBits, UINT &nSize)
This helper method retrieves information about an alpha bitmap and its alpha bits.
CXTPImageManagerIcon::GetCheckedIcon
CXTPImageManagerIconHandle & GetCheckedIcon()
Retrieves the checked icon.
CXTPImageManagerIcon::~CXTPImageManagerIcon
~CXTPImageManagerIcon()
Destroys a CXTPImageManagerIcon object, handles cleanup and deallocation.
CXTPImageManagerIcon::m_bDrawComposited
BOOL m_bDrawComposited
Draw on Vista composited rects.
Definition XTPImageManager.h:1532
CXTPImageManagerIcon::HasNormalIcon
BOOL HasNormalIcon() const
Determines if a state specific icon exists.
CXTPImageManagerIcon::LoadBitmapFromResource
static HBITMAP AFX_CDECL LoadBitmapFromResource(HMODULE hModule, LPCTSTR lpszResource, BOOL *lbAlphaBitmap)
This method loads an alpha bitmap or .png from a resource file.
CXTPImageManagerIcon::SetHotIcon
void SetHotIcon(const CXTPImageManagerIconHandle &hIcon)
Sets the hot icon.
CXTPImageManagerIcon::IsPngBitmapResource
static BOOL AFX_CDECL IsPngBitmapResource(HMODULE hModule, LPCTSTR lpBitmapName)
Checks if a bitmap with a specified resource is a .png resource.
CXTPImageManagerIcon::HasIcon
BOOL HasIcon(XTPImageState imageState) const
Determines if a state specific icon exists.
CXTPImageManagerIcon::SetIcon
BOOL SetIcon(const CXTPImageManagerIconHandle &hIcon)
Sets the icon.
CXTPImageManagerIcon::GetVectorIcon
CXTPImageManagerVectorImageHandle GetVectorIcon(XTPImageState imageState) const
Obtains the vector icon handle for a specified state.
CXTPImageManagerIcon::Draw
void Draw(CDC *pDC, CPoint pt, CSize szIcon)
Draws the image at a specified location.
CXTPImageManagerIcon::IsRasterIcon
BOOL IsRasterIcon() const
Checks if the current icon is a raster icon.
CXTPImageManagerIcon::GetHotIcon
CXTPImageManagerIconHandle & GetHotIcon()
Retrieves hot icon.
CXTPImageManagerIcon::SerializeIcon
void SerializeIcon(CXTPImageManagerVectorImageHandle &hIcon, CArchive &ar, long nSchema)
Either reads this object from or writes this object to an archive.
CXTPImageManagerIcon::GetRecommendedExtent
CSize GetRecommendedExtent() const
Retrieves the recommended size of the icon.
CXTPImageManagerIcon::CreateDisabledIcon
void CreateDisabledIcon(COLORREF clrDisabledLight=(COLORREF) -1, COLORREF clrDisabledDark=(COLORREF) -1)
Creates a disabled icon.
CXTPImageManagerIcon::Draw
void Draw(CDC *pDC, CPoint pt, XTPImageState imageState, CSize szIcon)
Draws the image at a specified location.
CXTPImageManagerIcon::GetVectorPressedIcon
CXTPImageManagerVectorImageHandle GetVectorPressedIcon() const
Obtains the vector icon handle for a specified state.
CXTPImageManagerIconSet
CXTPImageManagerIconSet represents the collection of icons for a specified identifier.
Definition XTPImageManager.h:1590
CXTPImageManagerIconSet::GetID
UINT GetID() const
Retrieves the identifier of the collection set.
CXTPImageManagerIconSet::SetVectorPressedIcon
BOOL SetVectorPressedIcon(IStream *pStream, UINT nWidth)
Sets state dependent icon from various icon sources.
CXTPImageManagerIconSet::RefreshAll
void RefreshAll()
Redraws all icons.
CXTPImageManagerIconSet::SetVectorCheckedIcon
BOOL SetVectorCheckedIcon(IStream *pStream, UINT nWidth)
Sets state dependent icon from various icon sources.
CXTPImageManagerIconSet::SetVectorDisabledIcon
BOOL SetVectorDisabledIcon(CXTPImageManagerVectorImageHandle hIcon, UINT nWidth)
Sets state dependent icon from various icon sources.
CXTPImageManagerIconSet::SetVectorPressedIcon
BOOL SetVectorPressedIcon(CXTPImageManagerVectorImageHandle hIcon, UINT nWidth)
Sets state dependent icon from various icon sources.
CXTPImageManagerIconSet::GetIcon
CXTPImageManagerIcon * GetIcon(UINT nWidth, BOOL bScaled=TRUE)
Call this member to get the icon with the specified width.
CXTPImageManagerIconSet::SetVectorIcon
BOOL SetVectorIcon(IStream *pStream, UINT nWidth)
Sets state dependent icon from various icon sources.
CXTPImageManagerIconSet::~CXTPImageManagerIconSet
~CXTPImageManagerIconSet()
Destroys a CXTPImageManagerIconSet object, handles cleanup and deallocation.
CXTPImageManagerIconSet::SetVectorHotIcon
BOOL SetVectorHotIcon(CXTPImageManagerVectorImageHandle hIcon, UINT nWidth)
Sets state dependent icon from various icon sources.
CXTPImageManagerIconSet::SetVectorIcon
BOOL SetVectorIcon(CXTPImageManagerVectorImageHandle hIcon, UINT nWidth)
Sets state dependent icon from various icon sources.
CXTPImageManagerIconSet::RemoveAll
void RemoveAll()
Removes all icons.
CXTPImageManagerIconSet::SetVectorHotIcon
BOOL SetVectorHotIcon(IStream *pStream, UINT nWidth)
Sets state dependent icon from various icon sources.
CXTPImageManagerIconSet::CIconSetMap
CMap< UINT, UINT, CXTPImageManagerIcon *, CXTPImageManagerIcon * > CIconSetMap
Icons collection.
Definition XTPImageManager.h:1592
CXTPImageManagerIconSet::SetVectorCheckedIcon
BOOL SetVectorCheckedIcon(CXTPImageManagerVectorImageHandle hIcon, UINT nWidth)
Sets state dependent icon from various icon sources.
CXTPImageManagerIconSet::GetIcons
CIconSetMap * GetIcons()
Retrieves the collection of icons.
CXTPImageManagerIconSet::SetVectorDisabledIcon
BOOL SetVectorDisabledIcon(IStream *pStream, UINT nWidth)
Sets state dependent icon from various icon sources.
CXTPImageManagerIconSet::CXTPImageManagerIconSet
CXTPImageManagerIconSet(UINT nID, CXTPImageManager *pImageManager)
Constructs a CXTPImageManagerIconSet object.
CXTPImageManagerImageList
This class is used to connect ImageManager with specified HIMAGELIST.
Definition XTPImageManager.h:1802
CXTPImageManagerImageList::GetIconHandle
HICON GetIconHandle(UINT nCommand) const
Retrieves the icon handle for an image specified by a command ID.
CXTPImageManagerImageList::Lookup
BOOL Lookup(UINT nCommand)
Call this method to determine if ImageList handles a command with a specified command ID.
CXTPImageManagerImageList::GetIcon
CXTPImageManagerIcon * GetIcon(UINT nCommand)
Draws the icon for a command with a specified command ID.
CXTPImageManagerImageList::RemoveAll
void RemoveAll()
Cleans all temporary icons.
CXTPImageManagerImageList::~CXTPImageManagerImageList
~CXTPImageManagerImageList()
Destroys a CXTPImageManagerImageList object, handles cleanup and deallocation.
CXTPImageManagerImageList::GetIconSize
CSize GetIconSize() const
Retrieves the size of images inside HIMAGELIST.
CXTPImageManagerImageList::Draw
void Draw(CDC *pDC, CPoint pt, CXTPImageManagerIcon *pIcon, CSize szIcon, COLORREF clrBK=CLR_NONE, COLORREF clrFG=CLR_NONE, UINT uiFlags=0)
Call this method to draw a specified icon.
CXTPImageManagerImageList::CXTPImageManagerImageList
CXTPImageManagerImageList()
Constructs a CXTPImageManagerImageList class.
CXTPImageManagerImageList::GetBitmapHandle
HBITMAP GetBitmapHandle(UINT nCommand) const
Retrieves the bitmap handle for an image specified by a command ID.
CXTPImageManagerResource
Definition XTPImageManagerResource.h:38
CXTPImageManagerVectorImageHandle
Represents a generic interface for a vector image of any possible format to be used with CXTPImageMan...
Definition XTPImageManager.h:90
CXTPImageManagerVectorImageHandle::CXTPImageManagerVectorImageHandle
CXTPImageManagerVectorImageHandle()
Construct an empty vector image handle object.
CXTPImageManagerVectorImageHandle::CXTPImageManagerVectorImageHandle
CXTPImageManagerVectorImageHandle(const CXTPImageManagerVectorImageHandle &rhs)
Construct a copy of the vector image handle object.
CXTPImageManagerVectorImageHandle::CreateMarkupHandle
static CXTPImageManagerVectorImageHandle CreateMarkupHandle(CXTPMarkupContext *pContext, BOOL bSharedContext, LPCWSTR lpszCode, INT_PTR nLength=-1)
Creates a Markup image handle.
CXTPImageManagerVectorImageHandle::~CXTPImageManagerVectorImageHandle
virtual ~CXTPImageManagerVectorImageHandle()
Handles object destruction, releases vector image resources.
CXTPImageManagerVectorImageHandle::DirectDraw
SIZE_T DirectDraw(PVOID pBits, SIZE_T cbSize, CPoint pt, CSize szIcon)
Draws vector image bits directly into the specified memoby buffer.
CXTPImageManagerVectorImageHandle::CreateMarkupHandle
static CXTPImageManagerVectorImageHandle CreateMarkupHandle(CXTPMarkupContext *pContext, BOOL bSharedContext, LPCSTR lpszCode, INT_PTR nLength=-1)
Creates a Markup image handle.
CXTPImageManagerVectorImageHandle::CreateMarkupHandle
static CXTPImageManagerVectorImageHandle CreateMarkupHandle(CXTPMarkupContext *pContext, BOOL bSharedContext, HGLOBAL SerializationData)
Creates a Markup image handle.
CXTPImageManagerVectorImageHandle::CreateSvgHandle
static CXTPImageManagerVectorImageHandle CreateSvgHandle(LPCSTR lpszCode, INT_PTR nLength=-1)
Creates an SVG image handle.
CXTPImageManagerVectorImageHandle::CreateMarkupHandle
static CXTPImageManagerVectorImageHandle CreateMarkupHandle(CXTPMarkupContext *pContext, BOOL bSharedContext, IStream *pStream)
Creates a Markup image handle.
CXTPImageManagerVectorImageHandle::CreateSvgHandle
static CXTPImageManagerVectorImageHandle CreateSvgHandle(HGLOBAL SerializationData)
Creates an SVG image handle.
CXTPImageManagerVectorImageHandle::GetDataStream
IStream * GetDataStream() const
Retrieves the data stream for the icon.
Definition XTPImageManager.h:362
CXTPImageManagerVectorImageHandle::IsMarkupImage
BOOL IsMarkupImage() const
Determines if the handle is associated with Markup image.
CXTPImageManagerVectorImageHandle::IsDirectDrawSupported
BOOL IsDirectDrawSupported() const
Determines if the encapsulated vector image supports drawing its bits directly into a memory buffer.
CXTPImageManagerVectorImageHandle::operator=
CXTPImageManagerVectorImageHandle & operator=(const CXTPImageManagerVectorImageHandle &rhs)
Make the current vector image handle identical to the provided image handle.
CXTPImageManagerVectorImageHandle::CreateSvgHandle
static CXTPImageManagerVectorImageHandle CreateSvgHandle(IStream *pStream)
Creates an SVG image handle.
CXTPImageManagerVectorImageHandle::Draw
void Draw(CDC *pDC, CPoint pt, CSize szIcon)
Draws the image associated with the handle.
CXTPImageManagerVectorImageHandle::GetMarkupContext
CXTPMarkupContext * GetMarkupContext()
Retrieves the markup context for the icon.
Definition XTPImageManager.h:357
CXTPImageManagerVectorImageHandle::IsSvgImage
BOOL IsSvgImage() const
Determines if the handle is associated with SVG image.
CXTPImageManagerVectorImageHandle::GetSerializationData
HGLOBAL GetSerializationData() const
Obtains a handle to image specific serialization data that can be used storing and re-storing an imag...
CXTPMarkupContext
CXTPMarkupContext is a standalone class used to provide common settings for Markup objects.
Definition XTPMarkupContext.h:128
CXTPMarkupUIElement
Base class for XML Markup core level implementations.
Definition XTPMarkupUIElement.h:43
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72
CXTPSingleton
Implements Singleton design pattern.
Definition XTPSingleton.h:215
CXTPSvgImage
Implements basic SVG image format support.
Definition XTPSvgImage.h:43
CXTPTempColorMask
The CXTPTempColorMask class can be used to temporarily set the color mask used by XTPImageManager whe...
Definition XTPImageManager.h:3025
CXTPTempColorMask::CXTPTempColorMask
CXTPTempColorMask(COLORREF crNewMask)
Constructs a CXTPTempColorMask object, initializes the application defined mask color,...
CXTPTempColorMask::~CXTPTempColorMask
~CXTPTempColorMask()
Destructor for CXTPTempColorMask.
XTP_IMAGERESOURCE_INFO
This structure is used to define the position and style of the icon in resources.
Definition XTPImageManager.h:372
XTP_IMAGERESOURCE_INFO::bAlpha
BOOL bAlpha
TRUE if the icon has alpha layer, otherwise m_hbmpMask used to draw its mask.
Definition XTPImageManager.h:373
XTP_IMAGERESOURCE_INFO::pResource
CXTPImageManagerResource * pResource
Pointer to owner resources.
Definition XTPImageManager.h:376
XTP_IMAGERESOURCE_INFO::rc
CRect rc
Position of the icon inside resources' m_hbmpImage bitmap.
Definition XTPImageManager.h:375


Toolkit Pro: Member List

CXTPDockingPaneColorSetNativeWindows10 Member List

This is the complete list of members for CXTPDockingPaneColorSetNativeWindows10, including all inherited members.

GetButtonColorSet(CXTPDockingPaneCaptionButton *pButton) | CXTPDockingPaneColorSet | virtual
m_clrBackground | CXTPDockingPaneColorSet |
m_clrBorder | CXTPDockingPaneColorSet |
m_clrCaption | CXTPDockingPaneColorSet |
m_clrGripper | CXTPDockingPaneColorSet |
m_clrSplitter | CXTPDockingPaneColorSet |
m_clrText | CXTPDockingPaneColorSet |
m_csCaptionButtonHot | CXTPDockingPaneColorSet | protected
m_csCaptionButtonNormal | CXTPDockingPaneColorSet | protected
m_csCaptionButtonPressed | CXTPDockingPaneColorSet | protected
RefreshMetrics(CString strSection) | CXTPDockingPaneColorSetNativeWindows10 | virtual
~CXTPDockingPaneColorSet() | CXTPDockingPaneColorSet | virtual


Toolkit Pro: XTPCalendarDayViewDay.h Source File

  • Source
  • Calendar
XTPCalendarDayViewDay.h
Go to the documentation of this file.
1
22#if !defined(_XTPCALENDARDAYVIEWDAY_H__)
23# define _XTPCALENDARDAYVIEWDAY_H__
24
25# if _MSC_VER > 1000
26# pragma once
27# endif // _MSC_VER > 1000
28
29# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
30
31class CXTPCalendarDayView;
32class CXTPCalendarViewPart;
33class CXTPCalendarDayViewDay;
34class CXTPCalendarDayViewEvent;
35
36struct XTP_CALENDAR_HITTESTINFO;
37
50class _XTP_EXT_CLASS CXTPCalendarDayViewGroup
51 : public CXTPCalendarViewGroupT<CXTPCalendarDayViewDay, CXTPCalendarDayViewEvent,
52 CXTPCalendarDayViewGroup>
53{
54 friend class CXTPCalendarDayViewEvent;
55 friend class CXTPCalendarTheme;
57 DECLARE_DYNAMIC(CXTPCalendarDayViewGroup)
60public:
65 typedef CXTPCalendarViewGroupT<CXTPCalendarDayViewDay, CXTPCalendarDayViewEvent,
66 CXTPCalendarDayViewGroup>
67 TBase;
68
69 typedef CXTPCalendarPtrCollectionT<CXTPCalendarDayViewEvent> TViewEventsCollection;
70
80 CXTPCalendarDayViewGroup(CXTPCalendarDayViewDay* pViewDay);
81
89 virtual ~CXTPCalendarDayViewGroup();
90
105 virtual void AdjustLayout(CDC* pDC, const CRect& rcGroup);
106
121 virtual void AdjustLayout2(CDC* pDC, const CRect& rcGroup);
122
135 virtual void Draw(CDC* pDC);
136
137 virtual void DrawEvents(CDC* pDC);
138
139 void DrawAllDayAreaScrollIcons(CDC* pDC);
140
157 virtual BOOL HitTestEx(CPoint pt, XTP_CALENDAR_HITTESTINFO* pHitTest) const;
158
169 virtual int GetBusyStatus(COleDateTime dtTime) const;
170
179 virtual CRect GetAllDayEventsRect() const;
180
187 virtual void AdjustDayEvents(CDC* pDC);
188
195 int GetRowHeight() const;
196
204 int GetVisibleRowCount() const;
205
213 int GetTopRow() const;
214
222 int GetRowCount() const;
223
234 COleDateTime GetCellDateTime(int nCell) const;
235
252 int GetDateTimeCell(const COleDateTime& dtTime, BOOL bForEndTime) const;
253
263 CRect GetCellRect(int nCell) const;
264
280 virtual CRect GetTooltipRect(const CPoint& ptHit,
281 const XTP_CALENDAR_HITTESTINFO& hitInfo) const;
282
293 BOOL IsWorkDateTime(const COleDateTime& dtDateTime) const;
294
302 BOOL IsGroupHeaderVisible() const;
303
311 void SetExpandUp();
312
320 void SetExpandDown();
321
331 BOOL IsExpandUp() const;
332
342 BOOL IsExpandDown() const;
343
356 CRect GetAllDayEventsScrollButtonRect(XTP_DAY_VIEW_GROUP_LAYOUT::XTPEnumHotItem nButton) const;
357
365 BOOL NeedScrollAllDayEvents() const;
366
374 BOOL IsShowAllDayEventsUpScrollButton() const;
375
383 BOOL IsShowAllDayEventsDownScrollButton() const;
384
391 void SetShowAllDayEventsUpScrollButton(BOOL bShow);
392
399 void SetShowAllDayEventsDownScrollButton(BOOL bShow);
400
408 int GetFirstVisibleAllDayEvent() const;
409
417 int GetLastVisibleAllDayEvent() const;
418
426 BOOL IsUpAllDayEventsScrollButtonVisible() const;
427
435 BOOL IsDownAllDayEventsScrollButtonVisible() const;
436
444 void FindMinMaxGroupDayEvents(CXTPCalendarDayViewEvent*& rpMin,
445 CXTPCalendarDayViewEvent*& rpMax) const;
446
462 BOOL UserAction_OnScrollDay(XTPCalendarScrollDayButton eButton);
463
480 BOOL UserAction_OnScrollAllDayEvents(XTP_DAY_VIEW_GROUP_LAYOUT::XTPEnumHotItem eHotBtn);
481
491 BOOL ScrollIcon_ScrollAllDayEventsUp();
492
502 BOOL ScrollIcon_ScrollAllDayEventsDown();
503
509 int GetEventsCountInAllDayArea() const;
510
511 BOOL m_bHide;
512 COLORREF m_GroupColor;
513
514protected:
531 virtual BOOL OnLButtonDown(UINT nFlags, CPoint point);
532
549 virtual BOOL OnLButtonDblClk(UINT nFlags, CPoint point);
550
564 BOOL OnAllDaysAreaClick(UINT nFlags, CPoint point);
565
580 virtual void OnMouseMove(UINT nFlags, CPoint point);
581
599 virtual CXTPCalendarViewPart* GetCellViewPart(const COleDateTime& dtDateTime) const;
600
617 virtual void GetCellEvents(int nCell, TViewEventsCollection* pViewEvents,
618 COleDateTime& rdtMinEventTime, COleDateTime& rdtMaxEventTime);
619
638 virtual BOOL HitTestDateTime(XTP_CALENDAR_HITTESTINFO* pHitTest) const;
639
653 virtual void FillHitTestEx(XTP_CALENDAR_HITTESTINFO* pHitTest) const;
654
655public:
656 const XTP_DAY_VIEW_GROUP_LAYOUT& GetLayout() const;
657
677 virtual BOOL HitTestAllDayEventsScrollIcons(CPoint pt,
678 XTP_CALENDAR_HITTESTINFO* pHitTest) const;
679
680protected:
681 XTP_DAY_VIEW_GROUP_LAYOUT& GetLayout();
682
683protected:
684 XTP_DAY_VIEW_GROUP_LAYOUT m_LayoutX;
686 BOOL m_bExpandUP;
687 BOOL m_bExpandDOWN;
689 BOOL m_bIsShowAllDayEventsUpScrollButton;
690 BOOL m_bIsShowAllDayEventsDownScrollButton;
691
692private:
693 TViewEventsCollection m_arRegionViewEvents;
694
695 void _AddInRegion_IfNeed(CXTPCalendarDayViewEvent* pViewEvent);
696 void _OnRegionEnded(CDC* pDC, int nRegionMaxSize);
697
698 virtual CXTPCalendarDayViewGroup* GetPThis();
699};
700
701AFX_INLINE CXTPCalendarDayViewGroup* CXTPCalendarDayViewGroup::GetPThis()
702{
703 return this;
704}
705
723class _XTP_EXT_CLASS CXTPCalendarDayViewDay
724 : public CXTPCalendarViewDayT<CXTPCalendarDayView, CXTPCalendarDayViewGroup,
725 XTP_CALENDAR_HITTESTINFO, CXTPCalendarDayViewDay>
726{
727 friend class CXTPCalendarDayView;
728 friend class CXTPCalendarDayViewGroup;
729 friend class CXTPCalendarDayViewEvent;
731 DECLARE_DYNAMIC(CXTPCalendarDayViewDay)
734public:
739 typedef CXTPCalendarViewDayT<CXTPCalendarDayView, CXTPCalendarDayViewGroup,
740 XTP_CALENDAR_HITTESTINFO, CXTPCalendarDayViewDay>
741 TBase;
742
755 CXTPCalendarDayViewDay(CXTPCalendarDayView* pDayView, COleDateTime dtDate);
756
764 virtual ~CXTPCalendarDayViewDay();
765
778 virtual void Draw(CDC* pDC);
779
792 virtual void DrawEvents(CDC* pDC);
793
806 virtual void DrawTopmostLayer(CDC* pDC);
807
822 virtual void AdjustLayout(CDC* pDC, const CRect& rcDay);
823
838 virtual void AdjustLayout2(CDC* pDC, const CRect& rcDay);
839
847 virtual void Populate(COleDateTime dtDayDate);
848
855 virtual CString GetCaption() const;
856
870 virtual void FillHitTestEx(XTP_CALENDAR_HITTESTINFO* pInfo) const;
871
872protected:
887 virtual void OnMouseMove(UINT nFlags, CPoint point);
888
889private:
890 virtual CXTPCalendarDayViewDay* GetPThis();
891};
892
894AFX_INLINE CRect CXTPCalendarDayViewGroup::GetAllDayEventsRect() const
895{
896 return m_LayoutX.m_rcAllDayEvents;
897}
898AFX_INLINE BOOL CXTPCalendarDayViewGroup::IsGroupHeaderVisible() const
899{
900 return m_LayoutX.m_bShowHeader;
901}
902AFX_INLINE XTP_DAY_VIEW_GROUP_LAYOUT& CXTPCalendarDayViewGroup::GetLayout()
903{
904 return m_LayoutX;
905}
906AFX_INLINE const XTP_DAY_VIEW_GROUP_LAYOUT& CXTPCalendarDayViewGroup::GetLayout() const
907{
908 return m_LayoutX;
909}
910AFX_INLINE CXTPCalendarDayViewDay* CXTPCalendarDayViewDay::GetPThis()
911{
912 return this;
913}
914AFX_INLINE void CXTPCalendarDayViewGroup::SetExpandUp()
915{
916 m_bExpandUP = TRUE;
917}
918AFX_INLINE void CXTPCalendarDayViewGroup::SetExpandDown()
919{
920 m_bExpandDOWN = TRUE;
921}
922AFX_INLINE BOOL CXTPCalendarDayViewGroup::IsExpandUp() const
923{
924 return m_bExpandUP;
925}
926AFX_INLINE BOOL CXTPCalendarDayViewGroup::IsExpandDown() const
927{
928 return m_bExpandDOWN;
929}
930
931# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
932#endif // !defined(AFX_XTPCALENDARDAYVIEWDAY_H__7E299FBF_C671_4648_8919_8ACAFDF38A99__INCLUDED_)
XTPCalendarScrollDayButton
XTPCalendarScrollDayButton
This enum defines parameters for xtpCalendarUserAction_OnScrollDay user action.
Definition XTPCalendarDefines.h:1329
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCalendarDayViewDay
This class represents a day view portion of the Calendar Day View.
Definition XTPCalendarDayViewDay.h:726
CXTPCalendarDayViewDay::DrawTopmostLayer
virtual void DrawTopmostLayer(CDC *pDC)
This member function is used to draw the view content utilizing the specified device context.
CXTPCalendarDayViewDay::FillHitTestEx
virtual void FillHitTestEx(XTP_CALENDAR_HITTESTINFO *pInfo) const
This member function is used to fill an XTP_CALENDAR_HITTESTINFO structure.
CXTPCalendarDayViewDay::DrawEvents
virtual void DrawEvents(CDC *pDC)
This member function is used to draw the view content utilizing the specified device context.
CXTPCalendarDayViewDay::GetCaption
virtual CString GetCaption() const
This member function is used to obtain a single day's view caption.
CXTPCalendarDayViewDay::Draw
virtual void Draw(CDC *pDC)
This member function is used to draw the view content utilizing the specified device context.
CXTPCalendarDayViewDay::CXTPCalendarDayViewDay
CXTPCalendarDayViewDay(CXTPCalendarDayView *pDayView, COleDateTime dtDate)
Default object constructor.
CXTPCalendarDayViewDay::Populate
virtual void Populate(COleDateTime dtDayDate)
This member function is used to populate the view with data for all items contained in the view.
CXTPCalendarDayViewDay::~CXTPCalendarDayViewDay
virtual ~CXTPCalendarDayViewDay()
Default class destructor.
CXTPCalendarDayViewDay::OnMouseMove
virtual void OnMouseMove(UINT nFlags, CPoint point)
This member function is used to processes mouse movement events.
CXTPCalendarDayViewDay::AdjustLayout
virtual void AdjustLayout(CDC *pDC, const CRect &rcDay)
This member function is used to adjust the view's layout depending on the provided bounding rectangle...
CXTPCalendarDayViewDay::AdjustLayout2
virtual void AdjustLayout2(CDC *pDC, const CRect &rcDay)
This member function is used to adjust the view's layout depending on the provided bounding rectangle...
CXTPCalendarDayViewDay::TBase
CXTPCalendarViewDayT< CXTPCalendarDayView, CXTPCalendarDayViewGroup, XTP_CALENDAR_HITTESTINFO, CXTPCalendarDayViewDay > TBase
Base class type definition.
Definition XTPCalendarDayViewDay.h:741
CXTPCalendarDayViewEvent
This class represents an event view portion of the CalendarDayViewDay.
Definition XTPCalendarDayViewEvent.h:56
CXTPCalendarDayViewGroup
This class represents a single resource view portion of the Calendar Day View.
Definition XTPCalendarDayViewDay.h:53
CXTPCalendarDayViewGroup::GetTooltipRect
virtual CRect GetTooltipRect(const CPoint &ptHit, const XTP_CALENDAR_HITTESTINFO &hitInfo) const
Call this member function to obtain the bounding rectangle of the tooltip space (currently this is on...
CXTPCalendarDayViewGroup::OnLButtonDown
virtual BOOL OnLButtonDown(UINT nFlags, CPoint point)
This member function is used to process left mouse button events.
CXTPCalendarDayViewGroup::~CXTPCalendarDayViewGroup
virtual ~CXTPCalendarDayViewGroup()
Default class destructor.
CXTPCalendarDayViewGroup::NeedScrollAllDayEvents
BOOL NeedScrollAllDayEvents() const
Call this member function to determine if all day events scroll icons will be shown in day view.
CXTPCalendarDayViewGroup::CXTPCalendarDayViewGroup
CXTPCalendarDayViewGroup(CXTPCalendarDayViewDay *pViewDay)
Default object constructor.
CXTPCalendarDayViewGroup::m_LayoutX
XTP_DAY_VIEW_GROUP_LAYOUT m_LayoutX
Store group view layout.
Definition XTPCalendarDayViewDay.h:684
CXTPCalendarDayViewGroup::GetEventsCountInAllDayArea
int GetEventsCountInAllDayArea() const
This member function returns events count in the all day area of the group.
CXTPCalendarDayViewGroup::IsExpandUp
BOOL IsExpandUp() const
Call this member function to determine if the ExpandUp sign is visible.
Definition XTPCalendarDayViewDay.h:922
CXTPCalendarDayViewGroup::AdjustDayEvents
virtual void AdjustDayEvents(CDC *pDC)
Adjusts layout of day events items.
CXTPCalendarDayViewGroup::GetRowHeight
int GetRowHeight() const
This member function is used to obtain the height of a single cell.
CXTPCalendarDayViewGroup::FillHitTestEx
virtual void FillHitTestEx(XTP_CALENDAR_HITTESTINFO *pHitTest) const
This member function is used to fill an XTP_CALENDAR_HITTESTINFO structure.
CXTPCalendarDayViewGroup::SetShowAllDayEventsUpScrollButton
void SetShowAllDayEventsUpScrollButton(BOOL bShow)
Call this member function to set the visibility for the up scroll button in the all day events area.
CXTPCalendarDayViewGroup::AdjustLayout2
virtual void AdjustLayout2(CDC *pDC, const CRect &rcGroup)
This member function is used to adjust the view's layout depending on the provided bounding rectangle...
CXTPCalendarDayViewGroup::IsGroupHeaderVisible
BOOL IsGroupHeaderVisible() const
This member function is used to determine if the group header is visible or not.
Definition XTPCalendarDayViewDay.h:898
CXTPCalendarDayViewGroup::IsShowAllDayEventsUpScrollButton
BOOL IsShowAllDayEventsUpScrollButton() const
Call this member function to determine if the up scroll button for the alldayevents area will be show...
CXTPCalendarDayViewGroup::UserAction_OnScrollDay
BOOL UserAction_OnScrollDay(XTPCalendarScrollDayButton eButton)
This member function is used to process the user action xtpCalendarUserAction_OnScrollDay.
CXTPCalendarDayViewGroup::GetAllDayEventsScrollButtonRect
CRect GetAllDayEventsScrollButtonRect(XTP_DAY_VIEW_GROUP_LAYOUT::XTPEnumHotItem nButton) const
Calculates the rectangle to fill with a scroll button icon for day view when there are too many allda...
CXTPCalendarDayViewGroup::GetVisibleRowCount
int GetVisibleRowCount() const
This member function is used to obtain the number of rows visible in the view.
CXTPCalendarDayViewGroup::m_bExpandDOWN
BOOL m_bExpandDOWN
Store is ExpandDOWN sign visible.
Definition XTPCalendarDayViewDay.h:687
CXTPCalendarDayViewGroup::ScrollIcon_ScrollAllDayEventsDown
BOOL ScrollIcon_ScrollAllDayEventsDown()
This member function processes click on down scroll icon in the all day events area.
CXTPCalendarDayViewGroup::GetCellViewPart
virtual CXTPCalendarViewPart * GetCellViewPart(const COleDateTime &dtDateTime) const
This member function is used to obtain the view part of the specified cell.
CXTPCalendarDayViewGroup::AdjustLayout
virtual void AdjustLayout(CDC *pDC, const CRect &rcGroup)
This member function is used to adjust the view's layout depending on the provided bounding rectangle...
CXTPCalendarDayViewGroup::TBase
CXTPCalendarViewGroupT< CXTPCalendarDayViewDay, CXTPCalendarDayViewEvent, CXTPCalendarDayViewGroup > TBase
Base class type definition.
Definition XTPCalendarDayViewDay.h:67
CXTPCalendarDayViewGroup::GetAllDayEventsRect
virtual CRect GetAllDayEventsRect() const
This member function is used to obtain the drawing area of all day events.
Definition XTPCalendarDayViewDay.h:894
CXTPCalendarDayViewGroup::IsExpandDown
BOOL IsExpandDown() const
Call this member function to determine if the ExpandDown sign is visible.
Definition XTPCalendarDayViewDay.h:926
CXTPCalendarDayViewGroup::GetRowCount
int GetRowCount() const
This member function is used to obtain the total number of rows in the view.
CXTPCalendarDayViewGroup::Draw
virtual void Draw(CDC *pDC)
This member function is used to draw the view content utilizing the specified device context.
CXTPCalendarDayViewGroup::FindMinMaxGroupDayEvents
void FindMinMaxGroupDayEvents(CXTPCalendarDayViewEvent *&rpMin, CXTPCalendarDayViewEvent *&rpMax) const
Call this member function to find the top and bottom events in a group.
CXTPCalendarDayViewGroup::GetDateTimeCell
int GetDateTimeCell(const COleDateTime &dtTime, BOOL bForEndTime) const
This member function is used to calculate the cell number for the specified time value.
CXTPCalendarDayViewGroup::GetTopRow
int GetTopRow() const
This member function is used to obtain the number of the top visible row in the view.
CXTPCalendarDayViewGroup::GetCellEvents
virtual void GetCellEvents(int nCell, TViewEventsCollection *pViewEvents, COleDateTime &rdtMinEventTime, COleDateTime &rdtMaxEventTime)
This member function is used to obtain the events collection which belongs to the specified cell.
CXTPCalendarDayViewGroup::UserAction_OnScrollAllDayEvents
BOOL UserAction_OnScrollAllDayEvents(XTP_DAY_VIEW_GROUP_LAYOUT::XTPEnumHotItem eHotBtn)
This member function is used to process the user actions xtpCalendarUserAction_OnScrollAllDayEvensUp ...
CXTPCalendarDayViewGroup::SetExpandDown
void SetExpandDown()
Call this member function to set the ExpandDown sign visible.
Definition XTPCalendarDayViewDay.h:918
CXTPCalendarDayViewGroup::GetCellDateTime
COleDateTime GetCellDateTime(int nCell) const
This member function is used to obtain the beginning time value for the specified cell.
CXTPCalendarDayViewGroup::HitTestAllDayEventsScrollIcons
virtual BOOL HitTestAllDayEventsScrollIcons(CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const
This member function is used to fill an XTP_CALENDAR_HITTESTINFO structure.
CXTPCalendarDayViewGroup::SetExpandUp
void SetExpandUp()
Call this member function to set the ExpandUp sign visible.
Definition XTPCalendarDayViewDay.h:914
CXTPCalendarDayViewGroup::m_bExpandUP
BOOL m_bExpandUP
Store is ExpandUP sign visible.
Definition XTPCalendarDayViewDay.h:686
CXTPCalendarDayViewGroup::IsDownAllDayEventsScrollButtonVisible
BOOL IsDownAllDayEventsScrollButtonVisible() const
Call this member function to determine if the down scroll icon in the all day events area is visible-...
CXTPCalendarDayViewGroup::IsShowAllDayEventsDownScrollButton
BOOL IsShowAllDayEventsDownScrollButton() const
Call this member function to determine if the down scroll button for the alldayevents area will be sh...
CXTPCalendarDayViewGroup::HitTestDateTime
virtual BOOL HitTestDateTime(XTP_CALENDAR_HITTESTINFO *pHitTest) const
This member function is used to fill an XTP_CALENDAR_HITTESTINFO structure.
CXTPCalendarDayViewGroup::GetLastVisibleAllDayEvent
int GetLastVisibleAllDayEvent() const
Call this member function to determine the index of the last visible all day event in group view.
CXTPCalendarDayViewGroup::IsWorkDateTime
BOOL IsWorkDateTime(const COleDateTime &dtDateTime) const
This member function is used to check if the specified date time is work or non-work.
CXTPCalendarDayViewGroup::OnMouseMove
virtual void OnMouseMove(UINT nFlags, CPoint point)
This member function is used to process mouse movement events.
CXTPCalendarDayViewGroup::GetFirstVisibleAllDayEvent
int GetFirstVisibleAllDayEvent() const
Call this member function to determine the index of the first visible all day event in group view.
CXTPCalendarDayViewGroup::IsUpAllDayEventsScrollButtonVisible
BOOL IsUpAllDayEventsScrollButtonVisible() const
Call this member function to determine if the up scroll icon in the all day events area is visible-hi...
CXTPCalendarDayViewGroup::SetShowAllDayEventsDownScrollButton
void SetShowAllDayEventsDownScrollButton(BOOL bShow)
Call this member function to set the visibility for the down scroll button in the all day events area...
CXTPCalendarDayViewGroup::GetBusyStatus
virtual int GetBusyStatus(COleDateTime dtTime) const
This member function is used to obtain the busy status for the specified time.
CXTPCalendarDayViewGroup::OnLButtonDblClk
virtual BOOL OnLButtonDblClk(UINT nFlags, CPoint point)
This member function is used to process left mouse button events.
CXTPCalendarDayViewGroup::ScrollIcon_ScrollAllDayEventsUp
BOOL ScrollIcon_ScrollAllDayEventsUp()
This member function processes click on up scroll icon in the all day events area.
CXTPCalendarDayViewGroup::HitTestEx
virtual BOOL HitTestEx(CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const
This member function is used to fill the XTP_CALENDAR_HITTESTINFO structure.
CXTPCalendarDayViewGroup::OnAllDaysAreaClick
BOOL OnAllDaysAreaClick(UINT nFlags, CPoint point)
This member function is used by OnLButtonDblClk() and OnLButtonDown() to filter scroll icons presses ...
CXTPCalendarDayViewGroup::GetCellRect
CRect GetCellRect(int nCell) const
This member function is used to obtain the rect for the specified cell.
CXTPCalendarDayView
This class implements a specific view portion of the Calendar control - called Day view.
Definition XTPCalendarDayView.h:62
CXTPCalendarPtrCollectionT
This class represents a simple array collection of objects.
Definition XTPCalendarPtrCollectionT.h:48
CXTPCalendarViewDayT
This class template customizes, overrides and implements some functionality for the CXTPCalendarViewD...
Definition XTPCalendarViewDay.h:1077
CXTPCalendarViewGroupT
This class template customizes, overrides and implements some functionality for the CXTPCalendarViewG...
Definition XTPCalendarViewDay.h:1257
CXTPCalendarViewGroupT::GetPThis
virtual _TPThis * GetPThis()=0
Call this member function to obtain the typed pointer to the last derived class in the class hierarch...
CXTPCalendarViewPart
Helper base class to implement parts for calendar paint manager.
Definition XTPCalendarViewPart.h:1228
XTP_CALENDAR_HITTESTINFO
Basic set of parameters transferred from calendar items to mouse handlers.
Definition XTPCalendarDefines.h:856


Toolkit Pro: Member List

CXTPComboBoxThemeDefault Member List

This is the complete list of members for CXTPComboBoxThemeDefault, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPComboBoxTheme() | CXTPComboBoxTheme |
CXTPComboBoxThemeDefault() | CXTPComboBoxThemeDefault |
CXTPControlTheme() | CXTPControlTheme |
DrawBackground(CDC *pDC, CXTPComboBox *pComboBox) | CXTPComboBoxTheme | virtual
DrawButton(CDC *pDC, CXTPComboBox *pComboBox, CRect rcBtn) | CXTPComboBoxTheme | virtual
DrawButtonTriangle(CDC *pDC, CXTPComboBox *pComboBox, CRect rcBtn) | CXTPComboBoxTheme | virtual
DrawComboBox(CDC *pDC, CXTPComboBox *pComboBox) | CXTPComboBoxThemeDefault | virtual
DrawFrame(HDC hdc, LPRECT lprc, int nSize, HBRUSH hBrush) | CXTPComboBoxTheme | virtual
FillSolidRect(HDC hdc, int x, int y, int cx, int cy, HBRUSH hBrush) | CXTPComboBoxTheme | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetBackColor() const | CXTPComboBoxTheme |
GetBackgroundBrush() const | CXTPComboBoxTheme |
GetTextColor() const | CXTPComboBoxTheme |
GetThemeStyle() const | CXTPControlTheme |
m_clrBackDisabled | CXTPComboBoxTheme |
m_clrBackground | CXTPComboBoxTheme |
m_clrBackHighlight | CXTPComboBoxTheme |
m_clrBorderDisabled | CXTPComboBoxTheme |
m_clrBorderHot | CXTPComboBoxTheme |
m_clrBorderNormal | CXTPComboBoxTheme |
m_clrButtonArrowHot | CXTPComboBoxTheme |
m_clrButtonArrowNormal | CXTPComboBoxTheme |
m_clrButtonArrowPressed | CXTPComboBoxTheme |
m_clrButtonHot | CXTPComboBoxTheme |
m_clrButtonNormal | CXTPComboBoxTheme |
m_clrButtonPressed | CXTPComboBoxTheme |
m_clrText | CXTPComboBoxTheme |
m_clrTextDisabled | CXTPComboBoxTheme |
m_clrTextHighlight | CXTPComboBoxTheme |
m_grcButton | CXTPComboBoxTheme |
m_grcButtonHilite | CXTPComboBoxTheme |
m_grcButtonPushed | CXTPComboBoxTheme |
m_nTheme | CXTPControlTheme | protected
m_nThumbWidth | CXTPComboBoxTheme | protected
m_themeComboBox | CXTPComboBoxTheme | protected
m_xtpBrushBackground | CXTPComboBoxTheme | protected
RefreshMetrics(CXTPComboBox *pComboBox) | CXTPComboBoxThemeDefault | virtual
ResetBackColor() | CXTPComboBoxTheme |
ResetTextColor() | CXTPComboBoxTheme |
SetBackColor(COLORREF clrBackground) | CXTPComboBoxTheme |
SetTextColor(COLORREF clrText) | CXTPComboBoxTheme |
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static
UpdateBackgroundBrush() | CXTPComboBoxTheme | protected
~CXTPComboBoxTheme() | CXTPComboBoxTheme | virtual
~CXTPComboBoxThemeDefault() | CXTPComboBoxThemeDefault | virtual


Toolkit Pro: XTPCalendarCaptionBarVisualStudio2022Theme.h Source File

  • Source
  • Calendar
  • CaptionBar
  • Themes
XTPCalendarCaptionBarVisualStudio2022Theme.h
Go to the documentation of this file.
1
22#if !defined(__XTPCALENDARCAPTIONBARVISUALSTUDIO2022THEME_H__)
23# define __XTPCALENDARCAPTIONBARVISUALSTUDIO2022THEME_H__
24
25# if _MSC_VER > 1000
26# pragma once
27# endif // _MSC_VER > 1000
28
29# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
30
36class _XTP_EXT_CLASS CXTPCalendarCaptionBarVisualStudio2022Theme
37 : public CXTPCalendarCaptionBarOffice2013Theme
38{
39public:
48 CXTPCalendarCaptionBarVisualStudio2022Theme(CXTPCalendarCaptionBarTheme* pTheme = NULL);
49
56 virtual ~CXTPCalendarCaptionBarVisualStudio2022Theme();
57};
58
59# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
60#endif // !defined(__XTPCALENDARCAPTIONBARVISUALSTUDIO2022THEME_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCalendarCaptionBarOffice2013Theme
CXTPCalendarCaptionBarOffice2013Theme is a CXTPCalendarCaptionBarOffice2003Theme derived class that r...
Definition XTPCalendarCaptionBarOffice2013Theme.h:38
CXTPCalendarCaptionBarTheme
This class CalendarCaptionBar control drawing, user interaction logic and interaction logic with atta...
Definition XTPCalendarCaptionBarTheme.h:48
CXTPCalendarCaptionBarVisualStudio2022Theme
CXTPCalendarCaptionBarVisualStudio2022Theme is a CXTPCalendarCaptionBarOffice2013Theme derived class ...
Definition XTPCalendarCaptionBarVisualStudio2022Theme.h:38
CXTPCalendarCaptionBarVisualStudio2022Theme::~CXTPCalendarCaptionBarVisualStudio2022Theme
virtual ~CXTPCalendarCaptionBarVisualStudio2022Theme()
Default paint manager destructor.
CXTPCalendarCaptionBarVisualStudio2022Theme::CXTPCalendarCaptionBarVisualStudio2022Theme
CXTPCalendarCaptionBarVisualStudio2022Theme(CXTPCalendarCaptionBarTheme *pTheme=NULL)
Default paint manager constructor.


Toolkit Pro: Member List

CXTPComboBoxThemeVisualStudio2010 Member List

This is the complete list of members for CXTPComboBoxThemeVisualStudio2010, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPComboBoxTheme() | CXTPComboBoxTheme |
CXTPComboBoxThemeOffice2003() | CXTPComboBoxThemeOffice2003 |
CXTPComboBoxThemeVisualStudio() | CXTPComboBoxThemeVisualStudio |
CXTPComboBoxThemeVisualStudio2010() | CXTPComboBoxThemeVisualStudio2010 |
CXTPControlTheme() | CXTPControlTheme |
DrawBackground(CDC *pDC, CXTPComboBox *pComboBox) | CXTPComboBoxThemeOffice2003 | virtual
DrawButton(CDC *pDC, CXTPComboBox *pComboBox, CRect rcBtn) | CXTPComboBoxThemeOffice2003 | virtual
DrawButtonTriangle(CDC *pDC, CXTPComboBox *pComboBox, CRect rcBtn) | CXTPComboBoxTheme | virtual
DrawComboBox(CDC *pDC, CXTPComboBox *pComboBox) | CXTPComboBoxTheme | virtual
DrawFrame(HDC hdc, LPRECT lprc, int nSize, HBRUSH hBrush) | CXTPComboBoxTheme | virtual
FillSolidRect(HDC hdc, int x, int y, int cx, int cy, HBRUSH hBrush) | CXTPComboBoxTheme | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetBackColor() const | CXTPComboBoxTheme |
GetBackgroundBrush() const | CXTPComboBoxTheme |
GetTextColor() const | CXTPComboBoxTheme |
GetThemeStyle() const | CXTPControlTheme |
m_clrBackDisabled | CXTPComboBoxTheme |
m_clrBackground | CXTPComboBoxTheme |
m_clrBackHighlight | CXTPComboBoxTheme |
m_clrBorderDisabled | CXTPComboBoxTheme |
m_clrBorderHot | CXTPComboBoxTheme |
m_clrBorderNormal | CXTPComboBoxTheme |
m_clrButtonArrowHot | CXTPComboBoxTheme |
m_clrButtonArrowNormal | CXTPComboBoxTheme |
m_clrButtonArrowPressed | CXTPComboBoxTheme |
m_clrButtonHot | CXTPComboBoxTheme |
m_clrButtonNormal | CXTPComboBoxTheme |
m_clrButtonPressed | CXTPComboBoxTheme |
m_clrText | CXTPComboBoxTheme |
m_clrTextDisabled | CXTPComboBoxTheme |
m_clrTextHighlight | CXTPComboBoxTheme |
m_grcButton | CXTPComboBoxTheme |
m_grcButtonHilite | CXTPComboBoxTheme |
m_grcButtonPushed | CXTPComboBoxTheme |
m_nTheme | CXTPControlTheme | protected
m_nThumbWidth | CXTPComboBoxTheme | protected
m_themeComboBox | CXTPComboBoxTheme | protected
m_xtpBrushBackground | CXTPComboBoxTheme | protected
RefreshMetrics(CXTPComboBox *pComboBox) | CXTPComboBoxThemeVisualStudio2010 | virtual
ResetBackColor() | CXTPComboBoxTheme |
ResetTextColor() | CXTPComboBoxTheme |
SetBackColor(COLORREF clrBackground) | CXTPComboBoxTheme |
SetTextColor(COLORREF clrText) | CXTPComboBoxTheme |
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static
UpdateBackgroundBrush() | CXTPComboBoxTheme | protected
~CXTPComboBoxTheme() | CXTPComboBoxTheme | virtual
~CXTPComboBoxThemeOffice2003() | CXTPComboBoxThemeOffice2003 | virtual
~CXTPComboBoxThemeVisualStudio() | CXTPComboBoxThemeVisualStudio | virtual
~CXTPComboBoxThemeVisualStudio2010() | CXTPComboBoxThemeVisualStudio2010 | virtual


Toolkit Pro: Member List

CXTPMarkupCheckBox Member List

This is the complete list of members for CXTPMarkupCheckBox, including all inherited members.

ApplyRenderTransform(CXTPMarkupDrawingContext *pContext) | CXTPMarkupUIElement | protectedvirtual
Arrange(CRect rcFinalRect) | CXTPMarkupUIElement |
ArrangeCore(CRect rcFinalRect) | CXTPMarkupUIElement | protectedvirtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPMarkupButtonBase() | CXTPMarkupButtonBase | protected
CXTPMarkupCheckBox() | CXTPMarkupCheckBox | protected
CXTPMarkupContentControl() | CXTPMarkupContentControl | protected
CXTPMarkupFrameworkElement() | CXTPMarkupFrameworkElement | protected
CXTPMarkupUIElement() | CXTPMarkupUIElement | protected
CXTPMarkupVisual() | CXTPMarkupVisual |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAbsoluteVisualOffset() const | CXTPMarkupVisual | protected
GetActualSize() const | CXTPMarkupFrameworkElement |
GetBackground() const | CXTPMarkupControl |
GetBoundRect() const | CXTPMarkupVisual |
GetChecked() const | CXTPMarkupToggleButton |
GetClipToBounds() const | CXTPMarkupFrameworkElement |
GetContent() const | CXTPMarkupContentControl |
GetDesiredSize() const | CXTPMarkupUIElement |
GetFinalRect() const | CXTPMarkupUIElement |
GetForeground() const | CXTPMarkupControl |
GetHeight() const | CXTPMarkupFrameworkElement |
GetHorizontalAlignment() const | CXTPMarkupFrameworkElement |
GetLayoutClip(CRect &rc) const | CXTPMarkupUIElement | protectedvirtual
GetLogicalChild(int nIndex) const | CXTPMarkupVisual | virtual
GetLogicalChildrenCount() const | CXTPMarkupVisual | virtual
GetMargin() const | CXTPMarkupFrameworkElement |
GetMaxHeight() const | CXTPMarkupFrameworkElement |
GetMaxWidth() const | CXTPMarkupFrameworkElement |
GetMinHeight() const | CXTPMarkupFrameworkElement |
GetMinWidth() const | CXTPMarkupFrameworkElement |
GetOpacity() const | CXTPMarkupUIElement | protectedvirtual
GetPadding() const | CXTPMarkupControl |
GetRenderSize() const | CXTPMarkupVisual |
GetRenderTransform() const | CXTPMarkupUIElement | protected
GetStyle() const | CXTPMarkupFrameworkElement |
GetTag() const | CXTPMarkupFrameworkElement |
GetUpdateRect() const | CXTPMarkupVisual |
GetVerticalAlignment() const | CXTPMarkupFrameworkElement |
GetVisibility() const | CXTPMarkupUIElement |
GetVisualChild(int nIndex) const | CXTPMarkupVisual | virtual
GetVisualChildrenCount() const | CXTPMarkupVisual | virtual
GetVisualOffset() const | CXTPMarkupVisual |
GetVisualParent() const | CXTPMarkupVisual |
GetWidth() const | CXTPMarkupFrameworkElement |
InputHitTest(CPoint point) const | CXTPMarkupVisual |
InputHitTestOverride(CPoint point) const | CXTPMarkupVisual | protectedvirtual
InvalidateArrange() | CXTPMarkupUIElement | virtual
InvalidateMeasure() | CXTPMarkupUIElement | virtual
InvalidateMeasureOverride(CXTPMarkupDrawingContext *pDC) | CXTPMarkupUIElement | protectedvirtual
InvalidateVisual() | CXTPMarkupUIElement | virtual
IsEnabled() const | CXTPMarkupUIElement |
IsFocusable() const | CXTPMarkupUIElement |
IsPressed() const | CXTPMarkupButtonBase |
IsThreeState() const | CXTPMarkupToggleButton |
IsVisible() const | CXTPMarkupUIElement | virtual
m_bArrangeDirty | CXTPMarkupUIElement | protected
m_bArrangeInProgress | CXTPMarkupUIElement | protected
m_bMeasureDirty | CXTPMarkupUIElement | protected
m_bMeasureInProgress | CXTPMarkupUIElement | protected
m_bNeverArranged | CXTPMarkupUIElement | protected
m_bNeverMeasured | CXTPMarkupUIElement | protected
m_pClipToBoundsProperty | CXTPMarkupUIElement | static
m_pFocusableProperty | CXTPMarkupUIElement | static
m_pIsEnabledProperty | CXTPMarkupUIElement | static
m_pOpacityProperty | CXTPMarkupUIElement | static
m_pRenderTransformOriginProperty | CXTPMarkupUIElement | static
m_pRenderTransformProperty | CXTPMarkupUIElement | static
m_ptVisualOffset | CXTPMarkupVisual | protected
m_pVisibilityProperty | CXTPMarkupUIElement | static
m_rcBoundRect | CXTPMarkupVisual | protected
m_rcFinalRect | CXTPMarkupUIElement | protected
m_rcPrevUpdateRect | CXTPMarkupVisual | protected
m_rcUpdateRect | CXTPMarkupVisual | protected
m_szDesiredSize | CXTPMarkupUIElement | protected
m_szPreviousAvailableSize | CXTPMarkupUIElement | protected
m_szRenderSize | CXTPMarkupVisual | protected
Measure(CXTPMarkupDrawingContext *pDC, CSize szAvailableSize) | CXTPMarkupUIElement |
MeasureCore(CXTPMarkupDrawingContext *pDC, CSize szAvailableSize) | CXTPMarkupUIElement | protectedvirtual
OnChecked(CXTPMarkupRoutedEventArgs *e) | CXTPMarkupToggleButton | protectedvirtual
OnClick() | CXTPMarkupToggleButton | protectedvirtual
OnIndeterminate(CXTPMarkupRoutedEventArgs *e) | CXTPMarkupToggleButton | protectedvirtual
OnRender(CXTPMarkupDrawingContext *drawingContext) | CXTPMarkupVisual | protectedvirtual
OnRenderFocusVisual(CXTPMarkupDrawingContext *drawingContext) | CXTPMarkupVisual | protectedvirtual
OnToggle() | CXTPMarkupToggleButton | protectedvirtual
OnUnchecked(CXTPMarkupRoutedEventArgs *e) | CXTPMarkupToggleButton | protectedvirtual
PtInRectTransform(const RECT &rect, const POINT &point) const | CXTPMarkupVisual | protected
Render(CXTPMarkupDrawingContext *drawingContext) | CXTPMarkupVisual |
RenderClipped(CXTPMarkupDrawingContext *drawingContext) | CXTPMarkupVisual | protectedvirtual
RestoreRenderTransform(CXTPMarkupDrawingContext *pContext, TransformationMatrices &matrices) | CXTPMarkupUIElement | protectedvirtual
SetBackground(CXTPMarkupBrush *pBrush) | CXTPMarkupControl |
SetChecked(BOOL bChecked) | CXTPMarkupToggleButton |
SetClipToBounds(BOOL bClipToBounds) | CXTPMarkupFrameworkElement |
SetContent(CXTPMarkupUIElement *pContent) | CXTPMarkupContentControl |
SetForeground(CXTPMarkupBrush *pBrush) | CXTPMarkupControl |
SetHeight(int nHeight) | CXTPMarkupFrameworkElement |
SetHorizontalAlignment(XTPMarkupHorizontalAlignment alignment) | CXTPMarkupFrameworkElement |
SetMargin(int nLeft, int nTop, int nRight, int nBottom) | CXTPMarkupFrameworkElement |
SetMargin(int nMargin) | CXTPMarkupFrameworkElement |
SetMaxHeight(int nHeight) | CXTPMarkupFrameworkElement |
SetMaxWidth(int nWidth) | CXTPMarkupFrameworkElement |
SetMinHeight(int nHeight) | CXTPMarkupFrameworkElement |
SetMinWidth(int nWidth) | CXTPMarkupFrameworkElement |
SetPadding(int nLeft, int nTop, int nRight, int nBottom) | CXTPMarkupControl |
SetPadding(int nPadding) | CXTPMarkupControl |
SetTag(CXTPMarkupObject *pTag) | CXTPMarkupFrameworkElement |
SetThreeState(BOOL bThreeState) | CXTPMarkupToggleButton |
SetVerticalAlignment(XTPMarkupVerticalAlignment alignment) | CXTPMarkupFrameworkElement |
SetVisibility(XTPMarkupVisibility visibility) | CXTPMarkupUIElement |
SetWidth(int nWidth) | CXTPMarkupFrameworkElement |
~CXTPMarkupButtonBase() | CXTPMarkupButtonBase | protected
~CXTPMarkupCheckBox() | CXTPMarkupCheckBox | protected
~CXTPMarkupContentControl() | CXTPMarkupContentControl | protectedvirtual
~CXTPMarkupFrameworkElement() | CXTPMarkupFrameworkElement | protectedvirtual
~CXTPMarkupUIElement() | CXTPMarkupUIElement | protectedvirtual
~CXTPMarkupVisual() | CXTPMarkupVisual | virtual


Toolkit Pro: XTPChartPyramidSeriesStyle.h Source File

  • Source
  • Chart
  • Styles
  • Pyramid
XTPChartPyramidSeriesStyle.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTPYRAMIDSERIESSTYLE_H__)
24# define __XTPCHARTPYRAMIDSERIESSTYLE_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Chart/Styles/Pyramid/Base/XTPChartPyramidSeriesStyleBase.h"
32# include "Chart/Styles/Pyramid/2D/XTPChart2dPyramidSeriesStyle.h"
33
35typedef CXTPChartPyramidSeriesStyle CXTPChart2dPyramidSeriesStyle;
37#endif //#if !defined(__XTPCHARTPYRAMIDSERIESSTYLE_H__)
XTPChart2dPyramidSeriesStyle.h
CXTPChart2dPyramidSeriesStyle
CXTPChartPyramidSeriesStyle CXTPChart2dPyramidSeriesStyle
CXTPChart2dPyramidSeriesStyle alias is necessary for naming consistency.
Definition XTPChartPyramidSeriesStyle.h:35
XTPChartPyramidSeriesStyleBase.h
CXTPChartPyramidSeriesStyle
This class abstracts the basic style of a pyramid series.
Definition XTPChart2dPyramidSeriesStyle.h:49


Toolkit Pro: XTPTabThemeVisualStudio2010.h Source File

  • Source
  • TabManager
  • Themes
XTPTabThemeVisualStudio2010.h
Go to the documentation of this file.
1
23#if !defined(__XTPTABTHEMEVISUALSTUDIO2010_H__)
24# define __XTPTABTHEMEVISUALSTUDIO2010_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
37class _XTP_EXT_CLASS CXTPTabThemeVisualStudio2010 : public CAppearanceSetPropertyPageFlat
38{
39public:
46 CXTPTabThemeVisualStudio2010()
47 {
48 m_bDrawNormalTab = FALSE;
49 }
50
68 virtual void DrawSingleButton(CDC* pDC, CXTPTabManagerItem* pItem);
69
78 virtual XTPTabColorStyle GetDefaultColorSet()
79 {
80 return xtpTabColorVisualStudio2010;
81 }
82
83public:
84};
85
86# define CAppearanceSetVisualStudio2010 CXTPTabThemeVisualStudio2010 // Old name.
87
88# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
90#endif // !defined(__XTPTABTHEMEVISUALSTUDIO2010_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPTabColorStyle
XTPTabColorStyle
XTPTabColorStyle is an enumeration used to set the color style of tabs.
Definition XTPTabManagerDefines.h:139
xtpTabColorVisualStudio2010
@ xtpTabColorVisualStudio2010
Tabs will use the Visual Studio 2010 color style for the currently set Appearance.
Definition XTPTabManagerDefines.h:156
CAppearanceSetPropertyPageFlat
CAppearanceSetPropertyPageFlat implements an Office 2000 Flat tab appearance.
Definition XTPTabThemePropertyPageFlat.h:49
CXTPTabManagerItem
CXTPTabManagerItem is the base class for the tabs that appear in the command bars tab workspace,...
Definition XTPTabManagerItem.h:44
CXTPTabThemeVisualStudio2010
CXTPTabThemeVisualStudio2010 implements a Visual Studio 2010 tab appearance.
Definition XTPTabThemeVisualStudio2010.h:38
CXTPTabThemeVisualStudio2010::GetDefaultColorSet
virtual XTPTabColorStyle GetDefaultColorSet()
Gets the default value of the color set for this theme.
Definition XTPTabThemeVisualStudio2010.h:78
CXTPTabThemeVisualStudio2010::DrawSingleButton
virtual void DrawSingleButton(CDC *pDC, CXTPTabManagerItem *pItem)
Draws a single tab button in the tab client header area.
CXTPTabThemeVisualStudio2010::CXTPTabThemeVisualStudio2010
CXTPTabThemeVisualStudio2010()
Constructs a CXTPTabThemeVisualStudio2010 object.
Definition XTPTabThemeVisualStudio2010.h:46


Toolkit Pro: Member List

CXTPChartFunnelDiagramView Member List

This is the complete list of members for CXTPChartFunnelDiagramView, including all inherited members.

AddChildView(CXTPChartElementView *pChildView) | CXTPChartElementView |
CalculateView(CXTPChartDeviceContext *pDC, CRect rcBounds) | CXTPChartDiagramView | virtual
CreateDeviceCommand(CXTPChartDeviceContext *pDC) | CXTPChartDiagramView | protectedvirtual
CreateView(CXTPChartDeviceContext *pDC) | CXTPChartDiagramView | virtual
CXTPChartDiagramView(CXTPChartDiagram *pDiagram, CXTPChartElementView *pParentView) | CXTPChartDiagramView |
CXTPChartElementView(CXTPChartElementView *pParentView) | CXTPChartElementView |
CXTPChartElementView(CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartElementView |
CXTPChartElementView(CXTPChartContainer *pContainer) | CXTPChartElementView |
CXTPChartFunnelDiagramView(CXTPChartDiagram *pDiagram, CXTPChartElementView *pParent) | CXTPChartFunnelDiagramView |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
GetAt(int nIndex) const | CXTPChartElementView |
GetBounds() const | CXTPChartDiagramView |
CXTPChartElementView::GetBounds(BOOL bIncludingChildren) const | CXTPChartElementView |
GetChildren() | CXTPChartElementView |
GetCount() const | CXTPChartElementView |
GetDiagram() const | CXTPChartDiagramView |
GetLabelsView() const | CXTPChartDiagramView |
GetParentView() const | CXTPChartElementView |
GetSeriesView() const | CXTPChartDiagramView |
Is3D() const | CXTPChartObject |
m_arrChildren | CXTPChartElementView | protected
m_pContainer | CXTPChartElementView | protected
m_pDiagram | CXTPChartDiagramView | protected
m_pLabelsView | CXTPChartDiagramView | protected
m_pParentView | CXTPChartElementView | protected
m_pSeriesView | CXTPChartDiagramView | protected
m_pTitlesView | CXTPChartDiagramView | protected
m_rcBounds | CXTPChartDiagramView | protected
OnMouseWheel(UINT nFlags, short zDelta, CPoint pt) | CXTPChartDiagramView | virtual
UpdateRange(CXTPChartDeviceContext *pDC) | CXTPChartDiagramView | virtual
~CXTPChartElementView() | CXTPChartElementView | protectedvirtual


Toolkit Pro: Member List

CXTPTabBaseTheme Member List

This is the complete list of members for CXTPTabBaseTheme, including all inherited members.

AdjustBorders(CXTPTabBase *pTabCtrl, CXTPTcbItem *pMember) | CXTPTabBaseTheme | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPControlTheme() | CXTPControlTheme |
CXTPTabBaseTheme() | CXTPTabBaseTheme |
DrawBorder(CDC *pDC, const CRect &r) | CXTPTabBaseTheme | protectedvirtual
DrawBorders(CDC *pDC, const CRect &rcClient) | CXTPTabBaseTheme | protectedvirtual
DrawButton(CDC *pDC, CXTPTabCtrlButton *pButton, COLORREF clrButton) | CXTPTabBaseTheme | virtual
DrawTab(CDC *pDC, CXTPTabBase *pTabCtrlBase, int iItem) | CXTPTabBaseTheme | protectedvirtual
DrawTabCtrl(CDC *pDC, CXTPTabBase *pTabCtrl) | CXTPTabBaseTheme | virtual
DrawTabIcon(CDC *pDC, CTabCtrl *pTabCtrl, CRect &rcItem, int iItem) | CXTPTabBaseTheme | protectedvirtual
DrawTabText(CDC *pDC, CTabCtrl *pTabCtrl, CRect &rcItem, int iItem, BOOL bSelected, BOOL bBoldFont) | CXTPTabBaseTheme | protectedvirtual
FillButtons(CDC *pDC, CXTPTabCtrlButtons *pButtons) | CXTPTabBaseTheme | virtual
FillHeader(CDC *pDC, CXTPTabBase *pTabCtrlBase, CRect rcHeader) | CXTPTabBaseTheme | protectedvirtual
FillTabFace(CDC *pDC, CTabCtrl *pTabCtrl, CRect rcItem, BOOL bSelected) | CXTPTabBaseTheme | protectedvirtual
FillTabFaceNativeWinXP(CDC *pDC, CTabCtrl *pTabCtrl, CRect rcItem, BOOL bSelected) | CXTPTabBaseTheme | protectedvirtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetBackColor() const | CXTPTabBaseTheme | virtual
GetHeaderRect(CXTPTabBase *pTabCtrlBase) | CXTPTabBaseTheme | protectedvirtual
GetTabStyle(CTabCtrl *pTabCtrl) const | CXTPTabBaseTheme | inlineprotected
GetThemeStyle() const | CXTPControlTheme |
HorizontalLine(CDC *pDC, int xPos, int yPos, int nLength, COLORREF clr) | CXTPTabBaseTheme | protected
IsBottom(DWORD dwStyle) const | CXTPTabBaseTheme | inlineprotected
IsHorz(DWORD dwStyle) const | CXTPTabBaseTheme | inlineprotected
IsLeft(DWORD dwStyle) const | CXTPTabBaseTheme | inlineprotected
IsRight(DWORD dwStyle) const | CXTPTabBaseTheme | inlineprotected
IsTop(DWORD dwStyle) const | CXTPTabBaseTheme | inlineprotected
IsVert(DWORD dwStyle) const | CXTPTabBaseTheme | inlineprotected
m_bSystemDrawing | CXTPTabBaseTheme |
m_bUseWinThemes | CXTPTabBaseTheme |
m_clrNormalText | CXTPTabBaseTheme | protected
m_iEdge | CXTPTabBaseTheme | protected
m_nTheme | CXTPControlTheme | protected
m_themeTab | CXTPTabBaseTheme | protected
Pixel(CDC *pDC, int xPos, int yPos, COLORREF clr) | CXTPTabBaseTheme | protected
RefreshMetrics(CTabCtrl *pTab) | CXTPTabBaseTheme | virtual
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static
ShowButtons(CXTPTabBase *pTabCtrlBase) | CXTPTabBaseTheme | protectedvirtual
SwapColors(COLORREF &clrLight, COLORREF &clrDark) | CXTPTabBaseTheme | protected
VerticalLine(CDC *pDC, int xPos, int yPos, int nLength, COLORREF clr) | CXTPTabBaseTheme | protected
~CXTPTabBaseTheme() | CXTPTabBaseTheme | virtual


Toolkit Pro: XTPCalendarCaptionBarThemePart.h Source File

  • Source
  • Calendar
  • CaptionBar
XTPCalendarCaptionBarThemePart.h
Go to the documentation of this file.
1
22#if !defined(__XTPCALENDARCAPTIONBARTHEMEPART_H__)
23# define __XTPCALENDARCAPTIONBARTHEMEPART_H__
24
25# if _MSC_VER >= 1000
26# pragma once
27# endif // _MSC_VER >= 1000
28
29# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
30
31class CXTPCalendarCaptionBarPaintManager;
32
37enum EStates
38{
39 xtpBtnStateNormal = 0,
40 xtpBtnStateMouseOver = 0x001,
41 xtpBtnStatePressed = 0x002,
42 xtpBtnStateChecked = 0x004,
43 xtpBtnStateFocused = 0x008,
44};
45
53class _XTP_EXT_CLASS CXTPCalendarCaptionBarThemePart : public CXTPCalendarWMHandler
54{
55 friend class CXTPCalendarCaptionBarTheme;
57 DECLARE_DYNAMIC(CXTPCalendarCaptionBarThemePart)
60public:
70 CXTPCalendarCaptionBarThemePart(CXTPCalendarCaptionBarTheme* pTheme, int nPartID);
71
78 virtual ~CXTPCalendarCaptionBarThemePart();
79
89 virtual void AdjustLayout(CDC* pDC, const CRect& rcRect);
90
98 virtual void Draw(CDC* pDC);
99
105 virtual void RefreshMetrics(){};
106
118 virtual void Redraw(BOOL bUpdateNow = FALSE);
119
129 virtual BOOL HitTest(const CPoint& pt) const;
130
138 virtual CXTPCalendarCaptionBarTheme* GetTheme() const;
139
146 virtual XTPCalendarTheme GetPaintTheme() const;
147
154 virtual int GetPartID() const;
155
162 virtual CRect GetRect() const;
163
172 virtual CString GetText() const;
173
182 virtual void SetText(LPCTSTR pcszText);
183
192 virtual BOOL IsVisible() const;
193
202 virtual void SetVisible(BOOL bVisible);
203
212 virtual int GetCheck() const;
213
222 virtual void SetCheck(int nCheck);
223
233 int GetState() const;
234
244 virtual void SetState(int nState);
245
256 virtual COLORREF GetTextColor();
257
264 CXTPCalendarCaptionBarPaintManager* GetPaintManager() const;
265
266public:
279 virtual void OnMouseMove(UINT nFlags, CPoint point);
280
295 virtual BOOL OnLButtonDown(UINT nFlags, CPoint point);
296
311 virtual BOOL OnLButtonUp(UINT nFlags, CPoint point);
312
313public:
314 CXTPPaintManagerColor m_clrTextColor;
315 CRect m_rcRect;
316 int m_nState;
317 CString m_strText;
319protected:
320 CXTPCalendarCaptionBarTheme* m_pTheme;
321 int m_nPartID;
323 BOOL m_bVisible;
324};
325
332class _XTP_EXT_CLASS CXTPSwitchViewButtonPart : public CXTPCalendarCaptionBarThemePart
333{
334public:
335 CXTPSwitchViewButtonPart(CXTPCalendarCaptionBarTheme* pTheme, int nPartID)
336 : CXTPCalendarCaptionBarThemePart(pTheme, nPartID){};
337
338 virtual void RefreshMetrics();
339 virtual void AdjustLayout(CDC* pDC, const CRect& rcRect);
340 virtual void Draw(CDC* pDC);
341};
342
349class _XTP_EXT_CLASS CXTPRadioButtonPart : public CXTPCalendarCaptionBarThemePart
350{
351public:
352 CXTPRadioButtonPart(CXTPCalendarCaptionBarTheme* pTheme, int nPartID)
353 : CXTPCalendarCaptionBarThemePart(pTheme, nPartID){};
354
355 virtual void AdjustLayout(CDC* pDC, const CRect& rcRect);
356 virtual void RefreshMetrics();
357 virtual void Draw(CDC* pDC);
358};
359
366class _XTP_EXT_CLASS CXTPCheckboxButtonPart : public CXTPCalendarCaptionBarThemePart
367{
368public:
369 CXTPCheckboxButtonPart(CXTPCalendarCaptionBarTheme* pTheme, int nPartID)
370 : CXTPCalendarCaptionBarThemePart(pTheme, nPartID){};
371
372 virtual void AdjustLayout(CDC* pDC, const CRect& rcRect);
373 virtual void RefreshMetrics();
374 virtual void Draw(CDC* pDC);
375};
382class _XTP_EXT_CLASS CXTPScrollDateButtonPart : public CXTPCalendarCaptionBarThemePart
383{
384public:
385 CXTPScrollDateButtonPart(CXTPCalendarCaptionBarTheme* pTheme, int nPartID)
386 : CXTPCalendarCaptionBarThemePart(pTheme, nPartID){};
387
388 virtual void Draw(CDC* pDC);
389 virtual void AdjustLayout(CDC* pDC, const CRect& rcRect);
390
391 virtual BOOL OnLButtonDown(UINT nFlags, CPoint point);
392 virtual void OnKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags);
393 virtual void OnKeyUp(UINT nChar, UINT nRepCnt, UINT nFlags);
394 virtual LPCTSTR _GetImageName();
395
396protected:
397 virtual void DrawScrollTriangle(CDC* pDC, CRect rcRect, BOOL bLeftDirection, COLORREF clrColor);
398};
399
406class _XTP_EXT_CLASS CXTPDateLabelPart : public CXTPCalendarCaptionBarThemePart
407{
408public:
409 CXTPDateLabelPart(CXTPCalendarCaptionBarTheme* pTheme, int nPartID)
410 : CXTPCalendarCaptionBarThemePart(pTheme, nPartID){};
411
412 virtual void RefreshMetrics();
413 virtual void Draw(CDC* pDC);
414
415 virtual CString _FormatDate(COleDateTime dtDay1, COleDateTime dtDay2, BOOL bShowMonthDay);
416 void UserAction_FormatCaptionBarLabel(CString& strCaption, COleDateTime dtDay1);
417
418public:
419 CXTPCalendarThemeFontValue m_fntTextFont;
420};
421
428class _XTP_EXT_CLASS CXTPExpandButtonPart : public CXTPCalendarCaptionBarThemePart
429{
430public:
431 CXTPExpandButtonPart(CXTPCalendarCaptionBarTheme* pTheme, int nPartID)
432 : CXTPCalendarCaptionBarThemePart(pTheme, nPartID){};
433
434 virtual void Draw(CDC* pDC);
435 virtual void AdjustLayout(CDC* pDC, const CRect& rcRect);
436
437protected:
438 // virtual LPCTSTR _GetImageName();
439
440 // virtual void _DrawTriangle(CDC* pDC, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clrColor);
441 virtual void DrawExpandTriangle(CDC* pDC, CRect rcRect, BOOL bDownDirection, COLORREF clrColor);
442};
443
445
446AFX_INLINE CXTPCalendarCaptionBarTheme* CXTPCalendarCaptionBarThemePart::GetTheme() const
447{
448 return m_pTheme;
449}
450AFX_INLINE CRect CXTPCalendarCaptionBarThemePart::GetRect() const
451{
452 return m_rcRect;
453}
454AFX_INLINE CString CXTPCalendarCaptionBarThemePart::GetText() const
455{
456 return m_strText;
457}
458AFX_INLINE void CXTPCalendarCaptionBarThemePart::SetText(LPCTSTR pcszText)
459{
460 m_strText = pcszText;
461}
462AFX_INLINE int CXTPCalendarCaptionBarThemePart::GetPartID() const
463{
464 return m_nPartID;
465}
466AFX_INLINE BOOL CXTPCalendarCaptionBarThemePart::IsVisible() const
467{
468 return m_bVisible;
469}
470AFX_INLINE void CXTPCalendarCaptionBarThemePart::SetVisible(BOOL bVisible)
471{
472 m_bVisible = bVisible;
473}
474AFX_INLINE int CXTPCalendarCaptionBarThemePart::GetCheck() const
475{
476 return !!(m_nState & xtpBtnStateChecked);
477}
478AFX_INLINE void CXTPCalendarCaptionBarThemePart::SetCheck(int nCheck)
479{
480 if (nCheck)
481 m_nState = m_nState | xtpBtnStateChecked;
482 else
483 m_nState = m_nState & (~xtpBtnStateChecked);
484}
485AFX_INLINE int CXTPCalendarCaptionBarThemePart::GetState() const
486{
487 return m_nState;
488}
489AFX_INLINE void CXTPCalendarCaptionBarThemePart::SetState(int nState)
490{
491 m_nState = nState;
492}
493
494# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
495#endif // !defined(__XTPCALENDARCAPTIONBARTHEMEPART_H__)
EStates
EStates
Defines the part object states flags.
Definition XTPCalendarCaptionBarThemePart.h:38
xtpBtnStateNormal
@ xtpBtnStateNormal
defines a normal state.
Definition XTPCalendarCaptionBarThemePart.h:39
xtpBtnStateChecked
@ xtpBtnStateChecked
defines a checked state.
Definition XTPCalendarCaptionBarThemePart.h:42
xtpBtnStatePressed
@ xtpBtnStatePressed
defines a pressed state.
Definition XTPCalendarCaptionBarThemePart.h:41
xtpBtnStateMouseOver
@ xtpBtnStateMouseOver
defines a mouse over state.
Definition XTPCalendarCaptionBarThemePart.h:40
xtpBtnStateFocused
@ xtpBtnStateFocused
defines a ficused state.
Definition XTPCalendarCaptionBarThemePart.h:43
XTPCalendarTheme
XTPCalendarTheme
Paint themes used by calendar.
Definition XTPCalendarDefines.h:62
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCalendarCaptionBarPaintManager
Utility class, handles most of the drawing activities.
Definition XTPCalendarCaptionBarPaintManager.h:49
CXTPCalendarCaptionBarTheme
This class CalendarCaptionBar control drawing, user interaction logic and interaction logic with atta...
Definition XTPCalendarCaptionBarTheme.h:48
CXTPCalendarCaptionBarThemePart
This class used as a base class for graphical Parts of CalendarCaptionBar paint theme.
Definition XTPCalendarCaptionBarThemePart.h:54
CXTPCalendarCaptionBarThemePart::OnLButtonDown
virtual BOOL OnLButtonDown(UINT nFlags, CPoint point)
This member function is used to process left mouse button down events.
CXTPCalendarCaptionBarThemePart::GetText
virtual CString GetText() const
This member function is used to obtain an object text.
Definition XTPCalendarCaptionBarThemePart.h:454
CXTPCalendarCaptionBarThemePart::m_strText
CString m_strText
Store a Part text.
Definition XTPCalendarCaptionBarThemePart.h:317
CXTPCalendarCaptionBarThemePart::GetPartID
virtual int GetPartID() const
This member function is used to obtain an object identifier.
Definition XTPCalendarCaptionBarThemePart.h:462
CXTPCalendarCaptionBarThemePart::GetTheme
virtual CXTPCalendarCaptionBarTheme * GetTheme() const
This member function is used to obtain pointer to parent CXTPCalendarCaptionBarTheme object.
Definition XTPCalendarCaptionBarThemePart.h:446
CXTPCalendarCaptionBarThemePart::m_nPartID
int m_nPartID
Store a Part ID.
Definition XTPCalendarCaptionBarThemePart.h:321
CXTPCalendarCaptionBarThemePart::m_rcRect
CRect m_rcRect
Store a Part rectangle.
Definition XTPCalendarCaptionBarThemePart.h:315
CXTPCalendarCaptionBarThemePart::SetVisible
virtual void SetVisible(BOOL bVisible)
This member function is used to set visible object's state.
Definition XTPCalendarCaptionBarThemePart.h:470
CXTPCalendarCaptionBarThemePart::SetText
virtual void SetText(LPCTSTR pcszText)
This member function is used to set object text.
Definition XTPCalendarCaptionBarThemePart.h:458
CXTPCalendarCaptionBarThemePart::GetState
int GetState() const
This member function is used to get object state (flags from CXTPCalendarCaptionBarThemePart::EStates...
Definition XTPCalendarCaptionBarThemePart.h:485
CXTPCalendarCaptionBarThemePart::m_nState
int m_nState
Store a Part state.
Definition XTPCalendarCaptionBarThemePart.h:316
CXTPCalendarCaptionBarThemePart::OnLButtonUp
virtual BOOL OnLButtonUp(UINT nFlags, CPoint point)
This member function is used to process left mouse button up events.
CXTPCalendarCaptionBarThemePart::IsVisible
virtual BOOL IsVisible() const
This member function is used to get is part object visible.
Definition XTPCalendarCaptionBarThemePart.h:466
CXTPCalendarCaptionBarThemePart::Draw
virtual void Draw(CDC *pDC)
This member function is used to draw the part content utilizing the specified device context.
CXTPCalendarCaptionBarThemePart::SetState
virtual void SetState(int nState)
This member function is used to set object state as set of flags from CXTPCalendarCaptionBarThemePart...
Definition XTPCalendarCaptionBarThemePart.h:489
CXTPCalendarCaptionBarThemePart::GetTextColor
virtual COLORREF GetTextColor()
This member function is used to get object text color.
CXTPCalendarCaptionBarThemePart::m_clrTextColor
CXTPPaintManagerColor m_clrTextColor
Store the object's text color.
Definition XTPCalendarCaptionBarThemePart.h:314
CXTPCalendarCaptionBarThemePart::Redraw
virtual void Redraw(BOOL bUpdateNow=FALSE)
This member function initiates the CalendarCaptionBar control's redrawing.
CXTPCalendarCaptionBarThemePart::m_pTheme
CXTPCalendarCaptionBarTheme * m_pTheme
Store pointer to a parent theme object.
Definition XTPCalendarCaptionBarThemePart.h:320
CXTPCalendarCaptionBarThemePart::m_bVisible
BOOL m_bVisible
Store a Part visible state.
Definition XTPCalendarCaptionBarThemePart.h:323
CXTPCalendarCaptionBarThemePart::SetCheck
virtual void SetCheck(int nCheck)
This member function is used to set checked state.
Definition XTPCalendarCaptionBarThemePart.h:478
CXTPCalendarCaptionBarThemePart::~CXTPCalendarCaptionBarThemePart
virtual ~CXTPCalendarCaptionBarThemePart()
Default object destructor.
CXTPCalendarCaptionBarThemePart::CXTPCalendarCaptionBarThemePart
CXTPCalendarCaptionBarThemePart(CXTPCalendarCaptionBarTheme *pTheme, int nPartID)
Default object constructor.
CXTPCalendarCaptionBarThemePart::AdjustLayout
virtual void AdjustLayout(CDC *pDC, const CRect &rcRect)
This member function is used to adjust the object's layout depending on the provided bounding rectang...
CXTPCalendarCaptionBarThemePart::HitTest
virtual BOOL HitTest(const CPoint &pt) const
This member function is used to determine is the specified point over visible object rectangle.
CXTPCalendarCaptionBarThemePart::OnMouseMove
virtual void OnMouseMove(UINT nFlags, CPoint point)
This member function is used to processes mouse movement events.
CXTPCalendarCaptionBarThemePart::GetPaintTheme
virtual XTPCalendarTheme GetPaintTheme() const
This member function is used to obtain current paint theme.
CXTPCalendarCaptionBarThemePart::GetCheck
virtual int GetCheck() const
This member function is used to get checked state.
Definition XTPCalendarCaptionBarThemePart.h:474
CXTPCalendarCaptionBarThemePart::GetPaintManager
CXTPCalendarCaptionBarPaintManager * GetPaintManager() const
Gets the paint manager.
CXTPCalendarCaptionBarThemePart::RefreshMetrics
virtual void RefreshMetrics()
Performs refreshing of graphical related parameters from system settings.
Definition XTPCalendarCaptionBarThemePart.h:105
CXTPCalendarCaptionBarThemePart::GetRect
virtual CRect GetRect() const
This member function is used to obtain an object rectangle.
Definition XTPCalendarCaptionBarThemePart.h:450
CXTPCalendarThemeFontValue
Helper class provides functionality to manage font value objects.
Definition XTPCalendarViewPart.h:868
CXTPCalendarWMHandler
This class helps to handle Windows messages (WM_*) processing portion of the Calendar control views.
Definition XTPCalendarView.h:100
CXTPCheckboxButtonPart
This class implements Checkbox button part of the SwitchViewBar.
Definition XTPCalendarCaptionBarThemePart.h:367
CXTPCheckboxButtonPart::Draw
virtual void Draw(CDC *pDC)
This member function is used to draw the part content utilizing the specified device context.
CXTPCheckboxButtonPart::AdjustLayout
virtual void AdjustLayout(CDC *pDC, const CRect &rcRect)
This member function is used to adjust the object's layout depending on the provided bounding rectang...
CXTPCheckboxButtonPart::RefreshMetrics
virtual void RefreshMetrics()
Performs refreshing of graphical related parameters from system settings.
CXTPDateLabelPart
This class implements Date Label part of the ScrollDateBar.
Definition XTPCalendarCaptionBarThemePart.h:407
CXTPDateLabelPart::Draw
virtual void Draw(CDC *pDC)
This member function is used to draw the part content utilizing the specified device context.
CXTPDateLabelPart::m_fntTextFont
CXTPCalendarThemeFontValue m_fntTextFont
Store the text font.
Definition XTPCalendarCaptionBarThemePart.h:419
CXTPDateLabelPart::RefreshMetrics
virtual void RefreshMetrics()
Performs refreshing of graphical related parameters from system settings.
CXTPExpandButtonPart
This class implements Expand button part of the ScrollDateBar.
Definition XTPCalendarCaptionBarThemePart.h:429
CXTPExpandButtonPart::Draw
virtual void Draw(CDC *pDC)
This member function is used to draw the part content utilizing the specified device context.
CXTPExpandButtonPart::AdjustLayout
virtual void AdjustLayout(CDC *pDC, const CRect &rcRect)
This member function is used to adjust the object's layout depending on the provided bounding rectang...
CXTPPaintManagerColor
The CXTPPaintManagerColor class is used to manage COLORREF values for determining default and applica...
Definition XTPColorManager.h:117
CXTPRadioButtonPart
This class implements Radio button part of the SwitchViewBar.
Definition XTPCalendarCaptionBarThemePart.h:350
CXTPRadioButtonPart::Draw
virtual void Draw(CDC *pDC)
This member function is used to draw the part content utilizing the specified device context.
CXTPRadioButtonPart::AdjustLayout
virtual void AdjustLayout(CDC *pDC, const CRect &rcRect)
This member function is used to adjust the object's layout depending on the provided bounding rectang...
CXTPRadioButtonPart::RefreshMetrics
virtual void RefreshMetrics()
Performs refreshing of graphical related parameters from system settings.
CXTPScrollDateButtonPart
This class implements Scroll Date button part of the ScrollDateBar.
Definition XTPCalendarCaptionBarThemePart.h:383
CXTPScrollDateButtonPart::OnLButtonDown
virtual BOOL OnLButtonDown(UINT nFlags, CPoint point)
This member function is used to process left mouse button down events.
CXTPScrollDateButtonPart::OnKeyDown
virtual void OnKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process key-down keyboard events.
CXTPScrollDateButtonPart::OnKeyUp
virtual void OnKeyUp(UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process key-up keyboard events.
CXTPScrollDateButtonPart::Draw
virtual void Draw(CDC *pDC)
This member function is used to draw the part content utilizing the specified device context.
CXTPScrollDateButtonPart::AdjustLayout
virtual void AdjustLayout(CDC *pDC, const CRect &rcRect)
This member function is used to adjust the object's layout depending on the provided bounding rectang...
CXTPSwitchViewButtonPart
This class implements SwitchView button part of the SwitchViewBar.
Definition XTPCalendarCaptionBarThemePart.h:333
CXTPSwitchViewButtonPart::Draw
virtual void Draw(CDC *pDC)
This member function is used to draw the part content utilizing the specified device context.
CXTPSwitchViewButtonPart::AdjustLayout
virtual void AdjustLayout(CDC *pDC, const CRect &rcRect)
This member function is used to adjust the object's layout depending on the provided bounding rectang...
CXTPSwitchViewButtonPart::RefreshMetrics
virtual void RefreshMetrics()
Performs refreshing of graphical related parameters from system settings.


Toolkit Pro: XTPMarkupDockPanel.h Source File

  • Source
  • Markup
  • Controls
XTPMarkupDockPanel.h
Go to the documentation of this file.
1
23#if !defined(__XTPMARKUPDOCKPANEL_H__)
24# define __XTPMARKUPDOCKPANEL_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPMarkupUIElement;
34class CXTPMarkupDrawingContext;
35class CXTPMarkupObject;
36class CXTPMarkupPropertyChangedEventArgs;
37class CXTPMarkupBuilder;
38class CXTPMarkupDependencyProperty;
43enum XTPMarkupDock
44{
45 xtpMarkupDockLeft,
46 xtpMarkupDockTop,
47 xtpMarkupDockRight,
48 xtpMarkupDockBottom
49};
50
56class _XTP_EXT_CLASS CXTPMarkupDockPanel : public CXTPMarkupPanel
57{
59 DECLARE_MARKUPCLASS(CXTPMarkupDockPanel)
61protected:
66 CXTPMarkupDockPanel();
67
72 virtual ~CXTPMarkupDockPanel();
73
74public:
84 static void AFX_CDECL SetDock(CXTPMarkupUIElement* pElement, XTPMarkupDock dock);
85
95 static XTPMarkupDock AFX_CDECL GetDock(CXTPMarkupUIElement* pElement);
96
97public:
104 void SetLastChildFill(BOOL bLastChildFill);
105
113 BOOL GetLastChildFill() const;
114
115protected:
117 // Implementation
118 virtual CSize MeasureOverride(CXTPMarkupDrawingContext* pDC, CSize szAvailableSize);
119 virtual CSize ArrangeOverride(CSize szFinalSize);
120
121private:
122 static void AFX_CDECL OnDockChanged(CXTPMarkupObject* d, CXTPMarkupPropertyChangedEventArgs* e);
123 static CXTPMarkupObject* AFX_CDECL
124 ConvertDock(CXTPMarkupBuilder* pBuilder, CXTPMarkupObject* pObject,
125 CXTPMarkupDependencyProperty* pAssociatedProperty = NULL);
126
127public:
128 static CXTPMarkupDependencyProperty* m_pLastChildFillProperty;
129 static CXTPMarkupDependencyProperty* m_pDockProperty;
133public:
134 DECLARE_DISPATCH_MAP()
135# ifdef _XTP_ACTIVEX
136 DECLARE_INTERFACE_MAP()
137 DECLARE_OLETYPELIB_EX(CXTPMarkupDockPanel);
138# endif
139
140 afx_msg BOOL OleGetLastChildFill();
141 afx_msg void OleSetLastChildFill(BOOL nValue);
142 afx_msg int OleGetDock(LPDISPATCH lpElementDisp);
143 afx_msg void OleSetDock(LPDISPATCH lpElementDisp, int nValue);
145};
146
147# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
149#endif // !defined(__XTPMARKUPDOCKPANEL_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPMarkupDock
XTPMarkupDock
Defines markup docking direction.
Definition XTPMarkupDockPanel.h:44
xtpMarkupDockLeft
@ xtpMarkupDockLeft
Specifies docking to the left.
Definition XTPMarkupDockPanel.h:45
xtpMarkupDockRight
@ xtpMarkupDockRight
Specifies docking to the right.
Definition XTPMarkupDockPanel.h:47
xtpMarkupDockBottom
@ xtpMarkupDockBottom
Specifies docking to the bottom.
Definition XTPMarkupDockPanel.h:48
xtpMarkupDockTop
@ xtpMarkupDockTop
Specifies docking to the top.
Definition XTPMarkupDockPanel.h:46
CXTPMarkupDockPanel
CXTPMarkupDockPanel is a CXTPMarkupPanel derived class.
Definition XTPMarkupDockPanel.h:57
CXTPMarkupDockPanel::CXTPMarkupDockPanel
CXTPMarkupDockPanel()
Constructs a CXTPMarkupDockPanel object.
CXTPMarkupDockPanel::~CXTPMarkupDockPanel
virtual ~CXTPMarkupDockPanel()
Destroys a CXTPMarkupDockPanel object, handles cleanup and deallocation.
CXTPMarkupDockPanel::SetLastChildFill
void SetLastChildFill(BOOL bLastChildFill)
Specifies if the last child element inside the whole client area of DockPanel should be filled.
CXTPMarkupDockPanel::GetDock
static XTPMarkupDock AFX_CDECL GetDock(CXTPMarkupUIElement *pElement)
Retrieves the dock position of a child element.
CXTPMarkupDockPanel::GetLastChildFill
BOOL GetLastChildFill() const
Determines if the last child element inside the whole client area of DockPanel is filled.
CXTPMarkupDockPanel::SetDock
static void AFX_CDECL SetDock(CXTPMarkupUIElement *pElement, XTPMarkupDock dock)
Sets the dock position for a child element.
CXTPMarkupPanel
CXTPMarkupPanel is a CXTPMarkupFrameworkElement derived class.
Definition XTPMarkupPanel.h:48
CXTPMarkupUIElement
Base class for XML Markup core level implementations.
Definition XTPMarkupUIElement.h:43


Toolkit Pro: XTPRibbonBackstageViewThemeVisualStudio2017.h Source File

  • Source
  • Ribbon
  • Backstage
XTPRibbonBackstageViewThemeVisualStudio2017.h
Go to the documentation of this file.
1
23#if !defined(__XTPRIBBONBACKSTAGEVIEWTHEMEVISUALSTUDIO2017_H__)
24# define __XTPRIBBONBACKSTAGEVIEWTHEMEVISUALSTUDIO2017_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class _XTP_EXT_CLASS CXTPRibbonBackstageViewThemeVisualStudio2017
34 : public CXTPRibbonBackstageViewThemeOffice2013
35{
36public:
37 CXTPRibbonBackstageViewThemeVisualStudio2017();
38 ~CXTPRibbonBackstageViewThemeVisualStudio2017();
39};
40
41# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
43#endif // !defined(__XTPRIBBONBACKSTAGEVIEWTHEMEVISUALSTUDIO2017_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h


Toolkit Pro: XTPCalendarCaptionBarOffice2013Theme.h Source File

  • Source
  • Calendar
  • CaptionBar
  • Themes
XTPCalendarCaptionBarOffice2013Theme.h
Go to the documentation of this file.
1
22#if !defined(__XTPCALENDARCAPTIONBAROFFICE2013THEME_H__)
23# define __XTPCALENDARCAPTIONBAROFFICE2013THEME_H__
24
25# if _MSC_VER > 1000
26# pragma once
27# endif // _MSC_VER > 1000
28
29# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
30
36class _XTP_EXT_CLASS CXTPCalendarCaptionBarOffice2013Theme
37 : public CXTPCalendarCaptionBarOffice2003Theme
38{
39public:
48 CXTPCalendarCaptionBarOffice2013Theme(CXTPCalendarCaptionBarTheme* pTheme = NULL);
49
56 virtual ~CXTPCalendarCaptionBarOffice2013Theme();
57
63 virtual void RefreshMetrics();
64
65 virtual void PartRefresh(CXTPSwitchViewButtonPart* pBarPart);
66 virtual void PartRefresh(CXTPRadioButtonPart* pBarPart);
67 virtual void PartRefresh(CXTPCheckboxButtonPart* pBarPart);
68
69 virtual void PartDraw(CXTPSwitchViewButtonPart* pBarPart, CDC* pDC);
70 virtual void PartDraw(CXTPScrollDateButtonPart* pBarPart, CDC* pDC);
71 virtual void PartDraw(CXTPDateLabelPart* pBarPart, CDC* pDC);
72
73 virtual void DrawBack(CDC* pDC, CRect rcRect, int nState);
74
75protected:
76 CXTPPaintManagerColor m_clrButtonHighlight;
77 CXTPPaintManagerColor m_clrButtonHighlightText;
78 CXTPPaintManagerColor m_clrButtonHighlightBorder;
79 CXTPPaintManagerColor m_clrButtonPressed;
80 CXTPPaintManagerColor m_clrButtonPressedText;
81 CXTPPaintManagerColor m_clrButtonPressedBorder;
82 CXTPPaintManagerColor m_clrButtonChecked;
83 CXTPPaintManagerColor m_clrButtonCheckedText;
84 CXTPPaintManagerColor m_clrButtonCheckedBorder;
85};
86
87# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
88#endif // !defined(__XTPCALENDARCAPTIONBAROFFICE2013THEME_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCalendarCaptionBarOffice2003Theme
CXTPCalendarCaptionBarOffice2003Theme is a CXTPCalendarCaptionBarOfficeXPTheme derived class that rep...
Definition XTPCalendarCaptionBarOffice2003Theme.h:38
CXTPCalendarCaptionBarOffice2013Theme
CXTPCalendarCaptionBarOffice2013Theme is a CXTPCalendarCaptionBarOffice2003Theme derived class that r...
Definition XTPCalendarCaptionBarOffice2013Theme.h:38
CXTPCalendarCaptionBarOffice2013Theme::CXTPCalendarCaptionBarOffice2013Theme
CXTPCalendarCaptionBarOffice2013Theme(CXTPCalendarCaptionBarTheme *pTheme=NULL)
Default paint manager constructor.
CXTPCalendarCaptionBarOffice2013Theme::~CXTPCalendarCaptionBarOffice2013Theme
virtual ~CXTPCalendarCaptionBarOffice2013Theme()
Default paint manager destructor.
CXTPCalendarCaptionBarOffice2013Theme::RefreshMetrics
virtual void RefreshMetrics()
Performs refreshing of graphical related parameters from system settings.
CXTPCalendarCaptionBarTheme
This class CalendarCaptionBar control drawing, user interaction logic and interaction logic with atta...
Definition XTPCalendarCaptionBarTheme.h:48
CXTPCheckboxButtonPart
This class implements Checkbox button part of the SwitchViewBar.
Definition XTPCalendarCaptionBarThemePart.h:367
CXTPDateLabelPart
This class implements Date Label part of the ScrollDateBar.
Definition XTPCalendarCaptionBarThemePart.h:407
CXTPPaintManagerColor
The CXTPPaintManagerColor class is used to manage COLORREF values for determining default and applica...
Definition XTPColorManager.h:117
CXTPRadioButtonPart
This class implements Radio button part of the SwitchViewBar.
Definition XTPCalendarCaptionBarThemePart.h:350
CXTPScrollDateButtonPart
This class implements Scroll Date button part of the ScrollDateBar.
Definition XTPCalendarCaptionBarThemePart.h:383
CXTPSwitchViewButtonPart
This class implements SwitchView button part of the SwitchViewBar.
Definition XTPCalendarCaptionBarThemePart.h:333


Toolkit Pro: XTPCalendarEvent.h Source File

  • Source
  • Calendar
XTPCalendarEvent.h
Go to the documentation of this file.
1
22#if !defined(_XTPCALENDAREVENT_H__)
23# define _XTPCALENDAREVENT_H__
24
25# if _MSC_VER > 1000
26# pragma once
27# endif // _MSC_VER > 1000
28
29# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
30
31class CXTPCalendarEvent;
32class CXTPCalendarRecurrencePattern;
33
34class CXTPCalendarEventLabel;
35class CXTPCalendarEventLabels;
36class CXTPCalendarEventCategoryIDs;
37
38class CXTPPropExchange;
39class CXTPCalendarCustomProperties;
40
41class CXTPCalendarIconIDs;
42typedef CXTPCalendarIconIDs CXTPCalendarCustomIconIDs;
44 XTP_DEFINE_SMART_PTR_INTERNAL(CXTPCalendarRecurrencePattern)
45 XTP_DEFINE_SMART_PTR_INTERNAL(CXTPCalendarEvent)
76class _XTP_EXT_CLASS CXTPCalendarEvent : public CXTPCmdTarget
77{
78 friend class CXTPCalendarData;
79 friend class CXTPCalendarRecurrencePattern;
80 friend class CXTPCalendarView;
82 DECLARE_DYNAMIC(CXTPCalendarEvent)
84public:
93 CXTPCalendarEvent(CXTPCalendarData* pDataProvider);
94
95public:
105 virtual ~CXTPCalendarEvent();
106
116 virtual DWORD GetEventID() const;
117
124 virtual void SetEventID(DWORD dwEventID);
125
140 virtual UINT GetScheduleID() const;
141
148 virtual void SetScheduleID(UINT uScheduleID);
149
155 virtual CString GetScheduleSet() const;
156
163 virtual void SetScheduleSet(CString ScheduleSet);
164
171 virtual CString GetSubject() const;
172
179 virtual void SetSubject(LPCTSTR pcszSubject);
180
189 virtual CString GetLocation() const;
190
199 virtual void SetLocation(LPCTSTR pcszLocation);
200
211 virtual CXTPCalendarEventLabel* GetLabel() const;
212
222 virtual int GetLabelID() const;
223
232 virtual void SetLabelID(int nLabelID);
233
243 virtual BOOL IsAllDayEvent() const;
244
257 virtual void SetAllDayEvent(BOOL bSet = TRUE);
258
265 BOOL IsEventVisible() const;
266
274 void SetEventVisible(BOOL bSet);
275
284 virtual COleDateTime GetStartTime() const;
285
297 virtual void SetStartTime(COleDateTime dtStart);
298
307 virtual COleDateTime GetEndTime() const;
308
318 virtual void SetEndTime(COleDateTime dtEnd);
319
328 virtual int GetDurationMinutes() const;
329
339 virtual COleDateTimeSpan GetDuration() const;
340
352 virtual void SetDuration(COleDateTimeSpan spDuration, BOOL bKeepStart = TRUE);
353
362 virtual void MoveEvent(COleDateTime dtNewStartTime);
363
374 virtual int GetEventPeriodDays() const;
375
385 virtual BOOL IsReminder() const;
386
401 virtual void SetReminder(BOOL bReminder);
402
410 virtual BOOL IsSound() const;
411
422 virtual int GetReminderMinutesBeforeStart() const;
423
434 virtual void SetReminderMinutesBeforeStart(int nMinutes);
435
446 virtual CString GetReminderSoundFile() const;
447
458 virtual void SetReminderSoundFile(LPCTSTR pcszFile);
459
469 virtual CString GetBody() const;
470
479 virtual void SetBody(LPCTSTR pcszDesc);
480
490 virtual int GetBusyStatus() const;
491
502 virtual void SetBusyStatus(int Status);
503
513 virtual int GetImportance() const;
514
525 virtual void SetImportance(int nImportance);
526
535 virtual COleDateTime GetCreationTime() const;
536
545 virtual void SetCreationTime(COleDateTime dtTime);
546
557 virtual COleDateTime GetLastModificationTime() const;
558
568 virtual void SetLastModificationTime(COleDateTime dtTime);
569
579 virtual XTPCalendarEventRecurrenceState GetRecurrenceState() const;
580
590 virtual BOOL MakeEventAsRecurrence();
591
604 virtual BOOL UpdateRecurrence(CXTPCalendarRecurrencePattern* pRPattern);
605
614 virtual BOOL RemoveRecurrence();
615
622 virtual DWORD GetRecurrencePatternID() const;
623
634 virtual CXTPCalendarRecurrencePatternPtr GetRecurrencePattern() const;
635
645 virtual BOOL MakeAsRException(DWORD dwPatternID = XTP_CALENDAR_UNKNOWN_RECURRENCE_PATTERN_ID);
646
656 virtual BOOL IsRExceptionDeleted() const;
657
669 virtual void SetRExceptionDeleted(BOOL bDeleted = TRUE);
670
682 virtual BOOL Update(CXTPCalendarEvent* pNewData);
683
692 virtual CXTPCalendarEventPtr CloneEvent();
693
705 virtual BOOL CloneEventTo(CXTPCalendarEvent* pEventDest);
706
726 virtual CXTPCalendarEventPtr
727 CloneForOccurrence(COleDateTime dtStart, COleDateTime dtEnd,
728 DWORD dwNewEventID = XTP_CALENDAR_UNKNOWN_EVENT_ID);
729
739 BOOL IsEqualIDs(const CXTPCalendarEvent* pEvent) const;
740
752 BOOL IsEqualStartEnd(const CXTPCalendarEvent* pEvent) const;
753
763 virtual void SetMeeting(BOOL bMeeting = TRUE);
764
772 virtual BOOL IsMeeting() const;
773
784 virtual void SetPrivate(BOOL bPrivate = TRUE);
785
794 virtual BOOL IsPrivate() const;
795
803 CXTPCalendarCustomIconIDs* GetCustomIcons() const;
804
815 CXTPCalendarEventCategoryIDs* GetCategories() const;
816
827 int GetCategoriesCount() const;
828
840 virtual void DoPropExchange(CXTPPropExchange* pPX);
841
850 CXTPCalendarCustomProperties* GetCustomProperties() const;
851
862 virtual COleDateTime GetRException_StartTimeOrig() const;
863
874 virtual void SetRException_StartTimeOrig(COleDateTime dtStartOrig);
875
886 virtual COleDateTime GetRException_EndTimeOrig() const;
887
899 virtual void SetRException_EndTimeOrig(COleDateTime dtEndOrig);
900
901 // void SetPermanentlyROccurrence_Reminder(
902 // int nbIsReminder = xtpCalendarRmdPrm_DontChange,
903 // int nMinutesBeforeStart = xtpCalendarRmdPrm_DontChange );
904 // //, int nMinutesBeforeStart2_Snoozed = xtpCalendarRmdPrm_DontChange);
905
914 virtual void SetRecurrencePatternID(DWORD dwRecurrencePatternID);
915
922 CXTPCalendarData* GetDataProvider() const;
923
932 CXTPCalendarRecurrencePattern* GetRPatternRef() const;
933
934protected:
940 virtual void Clear(); // Clear current event properties
941
949 virtual BOOL CalcStartEndDatesFromPattern();
950
959 virtual BOOL UpdateStartEndDatesFromPatternExceptions();
960
971 virtual BOOL SetRecurrenceState_Master(CXTPCalendarRecurrencePattern* pPattern);
972
982 virtual BOOL SetRecurrenceState_ExceptionOccurrence(
983 XTPCalendarEventRecurrenceState nState,
984 DWORD dwNewPatternID = XTP_CALENDAR_UNKNOWN_RECURRENCE_PATTERN_ID);
985
992 virtual BOOL SetRecurrenceState_NotRecurring();
993
1003 virtual void ClearIntermediateData();
1004
1005protected:
1006 CXTPCalendarData* m_pDataProvider;
1008 BOOL m_bMeeting;
1009 BOOL m_bPrivate;
1011 DWORD m_dwEventID;
1012 int m_nLabelID;
1013 CString m_strSubject;
1014 CString m_strLocation;
1016 UINT m_uScheduleID;
1017 BOOL m_bEventVisible;
1018 BOOL m_bAllDayEvent;
1019 COleDateTime m_dtStartTime;
1020 COleDateTime m_dtEndTime;
1022 BOOL m_bReminder;
1023 int m_nReminderMinutesBeforeStart;
1024 CString m_strReminderSoundFile;
1026 CString m_strBody;
1028 int m_nBusyStatus;
1029 int m_nImportance;
1030 XTPCalendarEventRecurrenceState m_nRecurrenceState;
1032 COleDateTime m_dtCreationTime;
1033 COleDateTime m_dtLastModificationTime;
1035 CXTPCalendarRecurrencePatternPtr m_ptrRPattern;
1037 DWORD m_dwRecurrencePatternID;
1039 BOOL m_bRExceptionDeleted;
1041 COleDateTime m_dtRException_StartTimeOrig;
1043 COleDateTime m_dtRException_EndTimeOrig;
1045 DWORD m_dwRecurrencePatternID_ToUse;
1047 CXTPCalendarCustomProperties* m_pCustomProperties;
1049 CXTPCalendarCustomIconIDs* m_pCustomIconsIDs;
1052 CXTPCalendarEventCategoryIDs* m_pEventCategoryIDs;
1055 CString m_sMultipleSchedules;
1057protected:
1058# ifdef _XTP_ACTIVEX
1059
1060 DECLARE_DISPATCH_MAP()
1061 DECLARE_INTERFACE_MAP()
1062
1063 DECLARE_OLETYPELIB_EX(CXTPCalendarEvent);
1064
1065 afx_msg DATE OleGetStartTime();
1066 afx_msg void OleSetStartTime(DATE dt);
1067 afx_msg DATE OleGetEndTime();
1068 afx_msg void OleSetEndTime(DATE dt);
1069 afx_msg LPDISPATCH OleGetStartTimeV();
1070 afx_msg LPDISPATCH OleGetEndTimeV();
1071
1072 afx_msg long OleGetEventID();
1073
1074 afx_msg DATE OleGetCreationTime();
1075 afx_msg void OleSetCreationTime(DATE dt);
1076
1077 afx_msg DATE OleGetLastModificationTime();
1078 afx_msg void OleSetLastModificationTime(DATE dt);
1079
1080 afx_msg int OleGetRecurrence();
1081 afx_msg LPDISPATCH OleGetRecurrencePattern();
1082 afx_msg LPDISPATCH OleCreateRecurrence();
1083 afx_msg LPDISPATCH OleCreateRecurrenceEx(long nPatternID);
1084
1085 afx_msg void OleUpdateRecurrence(LPDISPATCH Pattern);
1086 afx_msg void OleRemoveRecurrence();
1087
1088 afx_msg void OleMakeAsRException();
1089 afx_msg void OleMakeAsRExceptionEx(long nPatternID);
1090 afx_msg void OleSetRExceptionDeleted(BOOL bDeleted);
1091
1092 afx_msg LPDISPATCH OleCloneEvent();
1093 afx_msg void OleUpdate(LPDISPATCH SourceEvent);
1094
1095 afx_msg LPDISPATCH OleGetCustomProperties();
1096 afx_msg LPDISPATCH OleGetCustomIcons();
1097 afx_msg LPDISPATCH OleGetDataProvider();
1098 afx_msg LPDISPATCH OleGetCategories();
1099
1100# endif
1101};
1102
1103AFX_INLINE DWORD CXTPCalendarEvent::GetEventID() const
1104{
1105 return m_dwEventID;
1106}
1107AFX_INLINE CString CXTPCalendarEvent::GetSubject() const
1108{
1109 return m_strSubject;
1110}
1111AFX_INLINE void CXTPCalendarEvent::SetSubject(LPCTSTR pcszSubject)
1112{
1113 m_strSubject = pcszSubject;
1114}
1115AFX_INLINE UINT CXTPCalendarEvent::GetScheduleID() const
1116{
1117 return m_uScheduleID;
1118}
1119AFX_INLINE void CXTPCalendarEvent::SetScheduleID(UINT uScheduleID)
1120{
1121 m_uScheduleID = uScheduleID;
1122}
1123AFX_INLINE CString CXTPCalendarEvent::GetLocation() const
1124{
1125 return m_strLocation;
1126}
1127AFX_INLINE void CXTPCalendarEvent::SetLocation(LPCTSTR pcszLocation)
1128{
1129 m_strLocation = pcszLocation;
1130}
1131AFX_INLINE int CXTPCalendarEvent::GetLabelID() const
1132{
1133 return m_nLabelID;
1134}
1135AFX_INLINE void CXTPCalendarEvent::SetLabelID(int nLabelID)
1136{
1137 m_nLabelID = nLabelID;
1138}
1139AFX_INLINE BOOL CXTPCalendarEvent::IsEventVisible() const
1140{
1141 return m_bEventVisible;
1142}
1143AFX_INLINE void CXTPCalendarEvent::SetEventVisible(BOOL bSet)
1144{
1145 m_bEventVisible = bSet;
1146}
1147AFX_INLINE BOOL CXTPCalendarEvent::IsAllDayEvent() const
1148{
1149 return m_bAllDayEvent;
1150}
1151AFX_INLINE void CXTPCalendarEvent::SetAllDayEvent(BOOL bSet)
1152{
1153 _ASSERTE(m_nRecurrenceState != xtpCalendarRecurrenceOccurrence);
1154 m_bAllDayEvent = bSet;
1155}
1156AFX_INLINE COleDateTime CXTPCalendarEvent::GetStartTime() const
1157{
1158 return m_dtStartTime;
1159}
1160AFX_INLINE COleDateTime CXTPCalendarEvent::GetEndTime() const
1161{
1162 return m_dtEndTime;
1163}
1164AFX_INLINE BOOL CXTPCalendarEvent::IsReminder() const
1165{
1166 return m_bReminder;
1167}
1168AFX_INLINE void CXTPCalendarEvent::SetReminder(BOOL bReminder)
1169{
1170 m_bReminder = bReminder;
1171}
1172AFX_INLINE BOOL CXTPCalendarEvent::IsSound() const
1173{
1174 return !m_strReminderSoundFile.IsEmpty();
1175}
1176AFX_INLINE int CXTPCalendarEvent::GetReminderMinutesBeforeStart() const
1177{
1178 return m_nReminderMinutesBeforeStart;
1179}
1180AFX_INLINE void CXTPCalendarEvent::SetReminderMinutesBeforeStart(int nMinutes)
1181{
1182 m_nReminderMinutesBeforeStart = nMinutes;
1183}
1184AFX_INLINE CString CXTPCalendarEvent::GetReminderSoundFile() const
1185{
1186 return m_strReminderSoundFile;
1187}
1188AFX_INLINE void CXTPCalendarEvent::SetReminderSoundFile(LPCTSTR pcszFile)
1189{
1190 m_strReminderSoundFile = pcszFile;
1191}
1192AFX_INLINE CString CXTPCalendarEvent::GetBody() const
1193{
1194 return m_strBody;
1195}
1196AFX_INLINE void CXTPCalendarEvent::SetBody(LPCTSTR pcszDesc)
1197{
1198 m_strBody = pcszDesc;
1199}
1200AFX_INLINE int CXTPCalendarEvent::GetBusyStatus() const
1201{
1202 return m_nBusyStatus;
1203}
1204AFX_INLINE void CXTPCalendarEvent::SetBusyStatus(int nStatus)
1205{
1206 m_nBusyStatus = nStatus;
1207}
1208AFX_INLINE int CXTPCalendarEvent::GetImportance() const
1209{
1210 return m_nImportance;
1211}
1212AFX_INLINE void CXTPCalendarEvent::SetImportance(int nImportance)
1213{
1214 m_nImportance = nImportance;
1215}
1216AFX_INLINE XTPCalendarEventRecurrenceState CXTPCalendarEvent::GetRecurrenceState() const
1217{
1218 return m_nRecurrenceState;
1219}
1220AFX_INLINE COleDateTime CXTPCalendarEvent::GetCreationTime() const
1221{
1222 return m_dtCreationTime;
1223}
1224AFX_INLINE void CXTPCalendarEvent::SetCreationTime(COleDateTime dtTime)
1225{
1226 m_dtCreationTime = dtTime;
1227}
1228AFX_INLINE COleDateTime CXTPCalendarEvent::GetLastModificationTime() const
1229{
1230 return m_dtLastModificationTime;
1231}
1232AFX_INLINE void CXTPCalendarEvent::SetLastModificationTime(COleDateTime dtTime)
1233{
1234 m_dtLastModificationTime = dtTime;
1235}
1236AFX_INLINE DWORD CXTPCalendarEvent::GetRecurrencePatternID() const
1237{
1238 return m_dwRecurrencePatternID;
1239}
1240AFX_INLINE BOOL CXTPCalendarEvent::IsRExceptionDeleted() const
1241{
1242 return m_bRExceptionDeleted;
1243}
1244AFX_INLINE void CXTPCalendarEvent::SetRExceptionDeleted(BOOL bDeleted)
1245{
1246 m_bRExceptionDeleted = bDeleted;
1247}
1248AFX_INLINE COleDateTime CXTPCalendarEvent::GetRException_StartTimeOrig() const
1249{
1250 return m_dtRException_StartTimeOrig;
1251}
1252AFX_INLINE void CXTPCalendarEvent::SetRException_StartTimeOrig(COleDateTime dtStartOrig)
1253{
1254 m_dtRException_StartTimeOrig = dtStartOrig;
1255}
1256AFX_INLINE COleDateTime CXTPCalendarEvent::GetRException_EndTimeOrig() const
1257{
1258 return m_dtRException_EndTimeOrig;
1259}
1260AFX_INLINE void CXTPCalendarEvent::SetRException_EndTimeOrig(COleDateTime dtEndOrig)
1261{
1262 m_dtRException_EndTimeOrig = dtEndOrig;
1263}
1264AFX_INLINE BOOL CXTPCalendarEvent::MakeAsRException(DWORD dwPatternID)
1265{
1266 _ASSERTE(m_nRecurrenceState == xtpCalendarRecurrenceNotRecurring
1267 || m_nRecurrenceState == xtpCalendarRecurrenceOccurrence
1268 || m_nRecurrenceState == xtpCalendarRecurrenceException);
1269 return SetRecurrenceState_ExceptionOccurrence(xtpCalendarRecurrenceException, dwPatternID);
1270}
1271AFX_INLINE void CXTPCalendarEvent::SetMeeting(BOOL bMeeting)
1272{
1273 m_bMeeting = bMeeting;
1274}
1275AFX_INLINE BOOL CXTPCalendarEvent::IsMeeting() const
1276{
1277 return m_bMeeting;
1278}
1279AFX_INLINE void CXTPCalendarEvent::SetPrivate(BOOL bPrivate)
1280{
1281 m_bPrivate = bPrivate;
1282}
1283AFX_INLINE BOOL CXTPCalendarEvent::IsPrivate() const
1284{
1285 return m_bPrivate;
1286}
1287AFX_INLINE CXTPCalendarCustomProperties* CXTPCalendarEvent::GetCustomProperties() const
1288{
1289 return m_pCustomProperties;
1290}
1291AFX_INLINE CXTPCalendarData* CXTPCalendarEvent::GetDataProvider() const
1292{
1293 return m_pDataProvider;
1294}
1295AFX_INLINE CXTPCalendarCustomIconIDs* CXTPCalendarEvent::GetCustomIcons() const
1296{
1297 return m_pCustomIconsIDs;
1298}
1299AFX_INLINE CXTPCalendarEventCategoryIDs* CXTPCalendarEvent::GetCategories() const
1300{
1301 return m_pEventCategoryIDs;
1302}
1303AFX_INLINE CString CXTPCalendarEvent::GetScheduleSet() const
1304{
1305 return m_sMultipleSchedules;
1306}
1307AFX_INLINE void CXTPCalendarEvent::SetScheduleSet(CString ScheduleSet)
1308{
1309 m_sMultipleSchedules = ScheduleSet;
1310}
1311
1312# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
1313#endif // !defined(_XTPCALENDAREVENT_H__)
XTP_CALENDAR_UNKNOWN_RECURRENCE_PATTERN_ID
#define XTP_CALENDAR_UNKNOWN_RECURRENCE_PATTERN_ID
Define an unknown recurrence pattern ID.
Definition XTPCalendarDefines.h:113
XTPCalendarEventRecurrenceState
XTPCalendarEventRecurrenceState
Enumerates recurrence states.
Definition XTPCalendarDefines.h:223
xtpCalendarRecurrenceOccurrence
@ xtpCalendarRecurrenceOccurrence
Event is Occurrence.
Definition XTPCalendarDefines.h:226
xtpCalendarRecurrenceNotRecurring
@ xtpCalendarRecurrenceNotRecurring
Event is not recurring.
Definition XTPCalendarDefines.h:224
xtpCalendarRecurrenceException
@ xtpCalendarRecurrenceException
Event is Exception (changed occurrence).
Definition XTPCalendarDefines.h:227
XTP_CALENDAR_UNKNOWN_EVENT_ID
#define XTP_CALENDAR_UNKNOWN_EVENT_ID
Define unknown event ID.
Definition XTPCalendarDefines.h:107
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTP_DEFINE_SMART_PTR_INTERNAL
#define XTP_DEFINE_SMART_PTR_INTERNAL(ClassName)
Define smart pointer for the specified class as ClassNamePtr.
Definition XTPSmartPtrInternalT.h:47
CXTPCalendarCustomProperties
This class is used to store properties collection.
Definition XTPCalendarCustomProperties.h:44
CXTPCalendarData
This class defines an abstract representation of the Calendar control data with all necessary methods...
Definition XTPCalendarData.h:97
CXTPCalendarEventCategoryIDs
This class represents the collection of event categories IDs.
Definition XTPCalendarEventLabel.h:692
CXTPCalendarEvent
This class represents the data of a single Event used in the Calendar control.
Definition XTPCalendarEvent.h:77
CXTPCalendarEvent::CXTPCalendarEvent
CXTPCalendarEvent(CXTPCalendarData *pDataProvider)
Default object constructor.
CXTPCalendarEvent::SetEndTime
virtual void SetEndTime(COleDateTime dtEnd)
This member function is used to set the new end date and time for the event.
CXTPCalendarEvent::GetRecurrencePattern
virtual CXTPCalendarRecurrencePatternPtr GetRecurrencePattern() const
Call this member function to get the event's recurrence pattern object.
CXTPCalendarEvent::DoPropExchange
virtual void DoPropExchange(CXTPPropExchange *pPX)
Call this member function to Store/Load an event using the specified data object.
CXTPCalendarEvent::m_pCustomIconsIDs
CXTPCalendarCustomIconIDs * m_pCustomIconsIDs
An array to store custom icons id's assigned to event.
Definition XTPCalendarEvent.h:1049
CXTPCalendarEvent::SetRecurrencePatternID
virtual void SetRecurrencePatternID(DWORD dwRecurrencePatternID)
This member function is used to set the new ID value for the event recurrence pattern.
CXTPCalendarEvent::GetEventID
virtual DWORD GetEventID() const
This member function is used to obtain a unique event ID.
Definition XTPCalendarEvent.h:1103
CXTPCalendarEvent::MakeAsRException
virtual BOOL MakeAsRException(DWORD dwPatternID=XTP_CALENDAR_UNKNOWN_RECURRENCE_PATTERN_ID)
Call this member function to set the event's recurrence pattern as an exception occurrence.
Definition XTPCalendarEvent.h:1264
CXTPCalendarEvent::GetImportance
virtual int GetImportance() const
Call this member function to get an importance level for an event.
Definition XTPCalendarEvent.h:1208
CXTPCalendarEvent::SetScheduleSet
virtual void SetScheduleSet(CString ScheduleSet)
This member function is used to set a new multiple schedules set for the event.
Definition XTPCalendarEvent.h:1307
CXTPCalendarEvent::GetRecurrenceState
virtual XTPCalendarEventRecurrenceState GetRecurrenceState() const
Call this member function to get a recurrence state for the event.
Definition XTPCalendarEvent.h:1216
CXTPCalendarEvent::m_bReminder
BOOL m_bReminder
This flag value indicates is the Reminder enabled or not.
Definition XTPCalendarEvent.h:1022
CXTPCalendarEvent::SetReminder
virtual void SetReminder(BOOL bReminder)
Call this member function to setup a reminder for this event.
Definition XTPCalendarEvent.h:1168
CXTPCalendarEvent::UpdateStartEndDatesFromPatternExceptions
virtual BOOL UpdateStartEndDatesFromPatternExceptions()
This member function is used to change the date-time values of the start and end dates of the master ...
CXTPCalendarEvent::GetEventPeriodDays
virtual int GetEventPeriodDays() const
Call this member function to get an event duration as a number of days.
CXTPCalendarEvent::m_dtRException_EndTimeOrig
COleDateTime m_dtRException_EndTimeOrig
Original end time of Recurrence exception event.
Definition XTPCalendarEvent.h:1043
CXTPCalendarEvent::m_nLabelID
int m_nLabelID
Label ID.
Definition XTPCalendarEvent.h:1012
CXTPCalendarEvent::GetScheduleID
virtual UINT GetScheduleID() const
This member function is used to obtain a schedule ID of the event.
Definition XTPCalendarEvent.h:1115
CXTPCalendarEvent::SetImportance
virtual void SetImportance(int nImportance)
This member function is used to set the importance level for the event.
Definition XTPCalendarEvent.h:1212
CXTPCalendarEvent::GetDurationMinutes
virtual int GetDurationMinutes() const
Call this member function to get an event duration in minutes.
CXTPCalendarEvent::Clear
virtual void Clear()
This member function is used to set all event properties to the empty or default state.
CXTPCalendarEvent::GetLocation
virtual CString GetLocation() const
Call this member function to obtain the event location text.
Definition XTPCalendarEvent.h:1123
CXTPCalendarEvent::GetSubject
virtual CString GetSubject() const
This member function is used to obtain the event subject.
Definition XTPCalendarEvent.h:1107
CXTPCalendarEvent::SetLocation
virtual void SetLocation(LPCTSTR pcszLocation)
This member function is used to set the location text for the event.
Definition XTPCalendarEvent.h:1127
CXTPCalendarEvent::m_bRExceptionDeleted
BOOL m_bRExceptionDeleted
Is Recurrence Exception deleted.
Definition XTPCalendarEvent.h:1039
CXTPCalendarEvent::GetBusyStatus
virtual int GetBusyStatus() const
Call this member function to get a busy status value for the event.
Definition XTPCalendarEvent.h:1200
CXTPCalendarEvent::m_dtRException_StartTimeOrig
COleDateTime m_dtRException_StartTimeOrig
Original start time of Recurrence exception event.
Definition XTPCalendarEvent.h:1041
CXTPCalendarEvent::SetBusyStatus
virtual void SetBusyStatus(int Status)
This member function is used to set the busy status value for the event.
Definition XTPCalendarEvent.h:1204
CXTPCalendarEvent::m_nImportance
int m_nImportance
Event Importance value.
Definition XTPCalendarEvent.h:1029
CXTPCalendarEvent::CloneEvent
virtual CXTPCalendarEventPtr CloneEvent()
Call this member function to obtain a pointer to the read-write interface of the event.
CXTPCalendarEvent::m_bPrivate
BOOL m_bPrivate
Boolean flag that is used to indicate if an event is a private meeting.
Definition XTPCalendarEvent.h:1009
CXTPCalendarEvent::m_strReminderSoundFile
CString m_strReminderSoundFile
Reminder sound file path.
Definition XTPCalendarEvent.h:1024
CXTPCalendarEvent::~CXTPCalendarEvent
virtual ~CXTPCalendarEvent()
Default class destructor.
CXTPCalendarEvent::m_bAllDayEvent
BOOL m_bAllDayEvent
Is this an all day event value.
Definition XTPCalendarEvent.h:1018
CXTPCalendarEvent::GetReminderMinutesBeforeStart
virtual int GetReminderMinutesBeforeStart() const
Call this member function to determine the number of minutes before the start of an event.
Definition XTPCalendarEvent.h:1176
CXTPCalendarEvent::GetCategories
CXTPCalendarEventCategoryIDs * GetCategories() const
This member function is used to obtain a collection of Event category IDs associated with an event ob...
Definition XTPCalendarEvent.h:1299
CXTPCalendarEvent::SetPrivate
virtual void SetPrivate(BOOL bPrivate=TRUE)
This member function is used to set the state for the private flag.
Definition XTPCalendarEvent.h:1279
CXTPCalendarEvent::GetRecurrencePatternID
virtual DWORD GetRecurrencePatternID() const
Call this member function to get the recurrence pattern ID.
Definition XTPCalendarEvent.h:1236
CXTPCalendarEvent::SetRExceptionDeleted
virtual void SetRExceptionDeleted(BOOL bDeleted=TRUE)
Call this member function to mark an exception occurrence as deleted/undeleted.
Definition XTPCalendarEvent.h:1244
CXTPCalendarEvent::IsAllDayEvent
virtual BOOL IsAllDayEvent() const
Call this member function to determine if an event is an "All Day" event.
Definition XTPCalendarEvent.h:1147
CXTPCalendarEvent::GetRPatternRef
CXTPCalendarRecurrencePattern * GetRPatternRef() const
This member function is used to obtain a pointer to the internally stored Recurrence Pattern object.
CXTPCalendarEvent::GetCustomProperties
CXTPCalendarCustomProperties * GetCustomProperties() const
Get custom (named, user-defined) properties collection.
Definition XTPCalendarEvent.h:1287
CXTPCalendarEvent::GetLabelID
virtual int GetLabelID() const
Call this member function to get the event label ID.
Definition XTPCalendarEvent.h:1131
CXTPCalendarEvent::MakeEventAsRecurrence
virtual BOOL MakeEventAsRecurrence()
Call this member function to change the recurrence state for the event.
CXTPCalendarEvent::SetLabelID
virtual void SetLabelID(int nLabelID)
This member function is used to set the new label ID for the event.
Definition XTPCalendarEvent.h:1135
CXTPCalendarEvent::SetBody
virtual void SetBody(LPCTSTR pcszDesc)
This member function is used to set the body text for the event.
Definition XTPCalendarEvent.h:1196
CXTPCalendarEvent::m_nRecurrenceState
XTPCalendarEventRecurrenceState m_nRecurrenceState
Event Recurrence State.
Definition XTPCalendarEvent.h:1030
CXTPCalendarEvent::IsPrivate
virtual BOOL IsPrivate() const
This member function is used to obtain the value of the private state flag.
Definition XTPCalendarEvent.h:1283
CXTPCalendarEvent::m_dtLastModificationTime
COleDateTime m_dtLastModificationTime
Last Modification event time value.
Definition XTPCalendarEvent.h:1033
CXTPCalendarEvent::SetStartTime
virtual void SetStartTime(COleDateTime dtStart)
This member function is used to set the new start date and time for the event.
CXTPCalendarEvent::GetStartTime
virtual COleDateTime GetStartTime() const
Call this member function to get the event's start DateTime.
Definition XTPCalendarEvent.h:1156
CXTPCalendarEvent::SetAllDayEvent
virtual void SetAllDayEvent(BOOL bSet=TRUE)
This member function is used to set the "All Day" flag for an event.
Definition XTPCalendarEvent.h:1151
CXTPCalendarEvent::GetCategoriesCount
int GetCategoriesCount() const
This member function is used to obtain the count of Event category IDs associated with an event objec...
CXTPCalendarEvent::SetScheduleID
virtual void SetScheduleID(UINT uScheduleID)
This member function is used to set a new schedule ID for the event.
Definition XTPCalendarEvent.h:1119
CXTPCalendarEvent::GetScheduleSet
virtual CString GetScheduleSet() const
This member function is used to obtain a multiple schedules set for the event.
Definition XTPCalendarEvent.h:1303
CXTPCalendarEvent::GetDuration
virtual COleDateTimeSpan GetDuration() const
Call this member function to get an event duration as an COleDateTimeSpan object.
CXTPCalendarEvent::UpdateRecurrence
virtual BOOL UpdateRecurrence(CXTPCalendarRecurrencePattern *pRPattern)
This member function is used to set the recurrence pattern for the event.
CXTPCalendarEvent::SetMeeting
virtual void SetMeeting(BOOL bMeeting=TRUE)
This member function is used to set the state for the meeting flag.
Definition XTPCalendarEvent.h:1271
CXTPCalendarEvent::m_nBusyStatus
int m_nBusyStatus
Event Busy Status value.
Definition XTPCalendarEvent.h:1028
CXTPCalendarEvent::SetRException_EndTimeOrig
virtual void SetRException_EndTimeOrig(COleDateTime dtEndOrig)
This member function is used to set the original end time of an exception event.
Definition XTPCalendarEvent.h:1260
CXTPCalendarEvent::m_sMultipleSchedules
CString m_sMultipleSchedules
ScheduleSet string in form "|#1|...|#N|".
Definition XTPCalendarEvent.h:1055
CXTPCalendarEvent::m_bEventVisible
BOOL m_bEventVisible
flag to display event on screen
Definition XTPCalendarEvent.h:1017
CXTPCalendarEvent::SetLastModificationTime
virtual void SetLastModificationTime(COleDateTime dtTime)
This member function is used to set the modification time for the event.
Definition XTPCalendarEvent.h:1232
CXTPCalendarEvent::GetRException_StartTimeOrig
virtual COleDateTime GetRException_StartTimeOrig() const
This member function is used to obtain the original start time of an exception event.
Definition XTPCalendarEvent.h:1248
CXTPCalendarEvent::SetReminderSoundFile
virtual void SetReminderSoundFile(LPCTSTR pcszFile)
This member function is used to set the sound file for the event reminder.
Definition XTPCalendarEvent.h:1188
CXTPCalendarEvent::m_dwRecurrencePatternID_ToUse
DWORD m_dwRecurrencePatternID_ToUse
Previously used pattern ID.
Definition XTPCalendarEvent.h:1045
CXTPCalendarEvent::CloneForOccurrence
virtual CXTPCalendarEventPtr CloneForOccurrence(COleDateTime dtStart, COleDateTime dtEnd, DWORD dwNewEventID=XTP_CALENDAR_UNKNOWN_EVENT_ID)
This member function is used to build an occurrence event by duplicating the master event.
CXTPCalendarEvent::ClearIntermediateData
virtual void ClearIntermediateData()
Clear intermediate data members which where set when operations with recurrence properties where made...
CXTPCalendarEvent::m_dwEventID
DWORD m_dwEventID
ID of this event object.
Definition XTPCalendarEvent.h:1011
CXTPCalendarEvent::m_pCustomProperties
CXTPCalendarCustomProperties * m_pCustomProperties
Custom properties collection object.
Definition XTPCalendarEvent.h:1047
CXTPCalendarEvent::m_dtStartTime
COleDateTime m_dtStartTime
Start event time value.
Definition XTPCalendarEvent.h:1019
CXTPCalendarEvent::SetCreationTime
virtual void SetCreationTime(COleDateTime dtTime)
This member function is used to set the creation time for an event.
Definition XTPCalendarEvent.h:1224
CXTPCalendarEvent::MoveEvent
virtual void MoveEvent(COleDateTime dtNewStartTime)
This member function is used to move the start date event to the provided DateTime.
CXTPCalendarEvent::GetDataProvider
CXTPCalendarData * GetDataProvider() const
Returns event data provider.
Definition XTPCalendarEvent.h:1291
CXTPCalendarEvent::m_strBody
CString m_strBody
Body value.
Definition XTPCalendarEvent.h:1026
CXTPCalendarEvent::SetEventID
virtual void SetEventID(DWORD dwEventID)
This member function is used to set a new ID value for an event.
CXTPCalendarEvent::SetRException_StartTimeOrig
virtual void SetRException_StartTimeOrig(COleDateTime dtStartOrig)
This member function is used to set the original start time of an exception event.
Definition XTPCalendarEvent.h:1252
CXTPCalendarEvent::m_strSubject
CString m_strSubject
Subject value.
Definition XTPCalendarEvent.h:1013
CXTPCalendarEvent::GetBody
virtual CString GetBody() const
Call this member function to obtain the body text for the event.
Definition XTPCalendarEvent.h:1192
CXTPCalendarEvent::GetEndTime
virtual COleDateTime GetEndTime() const
Call this member function to get the event's end DateTime.
Definition XTPCalendarEvent.h:1160
CXTPCalendarEvent::CalcStartEndDatesFromPattern
virtual BOOL CalcStartEndDatesFromPattern()
This member function is used to calculate the date-time values of the start and end dates for occurre...
CXTPCalendarEvent::m_uScheduleID
UINT m_uScheduleID
ID of the corresponding Schedule.
Definition XTPCalendarEvent.h:1016
CXTPCalendarEvent::SetReminderMinutesBeforeStart
virtual void SetReminderMinutesBeforeStart(int nMinutes)
This member function is used to set the number of minutes before the start of an event.
Definition XTPCalendarEvent.h:1180
CXTPCalendarEvent::IsEqualStartEnd
BOOL IsEqualStartEnd(const CXTPCalendarEvent *pEvent) const
Call this member function to compare start dates of different events.
CXTPCalendarEvent::m_pDataProvider
CXTPCalendarData * m_pDataProvider
Pointer to the owner data provider.
Definition XTPCalendarEvent.h:1006
CXTPCalendarEvent::m_strLocation
CString m_strLocation
Location value.
Definition XTPCalendarEvent.h:1014
CXTPCalendarEvent::GetCustomIcons
CXTPCalendarCustomIconIDs * GetCustomIcons() const
This member function is used to obtain collection of custom icons IDs associated with event object.
Definition XTPCalendarEvent.h:1295
CXTPCalendarEvent::SetSubject
virtual void SetSubject(LPCTSTR pcszSubject)
This member function is used to set the subject text for the event.
Definition XTPCalendarEvent.h:1111
CXTPCalendarEvent::GetRException_EndTimeOrig
virtual COleDateTime GetRException_EndTimeOrig() const
This member function is used to obtain the original end time of an exception event.
Definition XTPCalendarEvent.h:1256
CXTPCalendarEvent::GetLastModificationTime
virtual COleDateTime GetLastModificationTime() const
Call this member function to get the last modification time for an event.
Definition XTPCalendarEvent.h:1228
CXTPCalendarEvent::SetDuration
virtual void SetDuration(COleDateTimeSpan spDuration, BOOL bKeepStart=TRUE)
This member function is used to set the new duration for the event.
CXTPCalendarEvent::m_ptrRPattern
CXTPCalendarRecurrencePatternPtr m_ptrRPattern
Recurrence Pattern object for a master event only.
Definition XTPCalendarEvent.h:1035
CXTPCalendarEvent::RemoveRecurrence
virtual BOOL RemoveRecurrence()
This member function removes the recurrence pattern for the event.
CXTPCalendarEvent::CloneEventTo
virtual BOOL CloneEventTo(CXTPCalendarEvent *pEventDest)
Clones current event properties into a provided object instance.
CXTPCalendarEvent::Update
virtual BOOL Update(CXTPCalendarEvent *pNewData)
Call this member function to update the event's data.
CXTPCalendarEvent::IsEventVisible
BOOL IsEventVisible() const
Call this member function to determine if an event is Visible.
Definition XTPCalendarEvent.h:1139
CXTPCalendarEvent::m_bMeeting
BOOL m_bMeeting
Boolean flag that is used to indicate if an event is a meeting.
Definition XTPCalendarEvent.h:1008
CXTPCalendarEvent::IsReminder
virtual BOOL IsReminder() const
Call this member function to determine if a reminder is set for event.
Definition XTPCalendarEvent.h:1164
CXTPCalendarEvent::SetRecurrenceState_ExceptionOccurrence
virtual BOOL SetRecurrenceState_ExceptionOccurrence(XTPCalendarEventRecurrenceState nState, DWORD dwNewPatternID=XTP_CALENDAR_UNKNOWN_RECURRENCE_PATTERN_ID)
This member function is used to set the exception recurrence.
CXTPCalendarEvent::m_nReminderMinutesBeforeStart
int m_nReminderMinutesBeforeStart
Reminder time value.
Definition XTPCalendarEvent.h:1023
CXTPCalendarEvent::m_dtEndTime
COleDateTime m_dtEndTime
End event time value.
Definition XTPCalendarEvent.h:1020
CXTPCalendarEvent::m_dwRecurrencePatternID
DWORD m_dwRecurrencePatternID
Recurrence Pattern ID.
Definition XTPCalendarEvent.h:1037
CXTPCalendarEvent::m_dtCreationTime
COleDateTime m_dtCreationTime
Creation event time value.
Definition XTPCalendarEvent.h:1032
CXTPCalendarEvent::GetLabel
virtual CXTPCalendarEventLabel * GetLabel() const
Call this member function to obtain the event label.
CXTPCalendarEvent::IsMeeting
virtual BOOL IsMeeting() const
This member function is used to obtain the value of the Meeting state flag.
Definition XTPCalendarEvent.h:1275
CXTPCalendarEvent::IsSound
virtual BOOL IsSound() const
Call this member function to determine if a sound file is configured for the event reminder.
Definition XTPCalendarEvent.h:1172
CXTPCalendarEvent::GetCreationTime
virtual COleDateTime GetCreationTime() const
Call this member function to get the creation time for an event.
Definition XTPCalendarEvent.h:1220
CXTPCalendarEvent::IsRExceptionDeleted
virtual BOOL IsRExceptionDeleted() const
Call this member function to determine if an exception occurrence is marked as deleted.
Definition XTPCalendarEvent.h:1240
CXTPCalendarEvent::m_pEventCategoryIDs
CXTPCalendarEventCategoryIDs * m_pEventCategoryIDs
An array to store categories id's assigned to event.
Definition XTPCalendarEvent.h:1052
CXTPCalendarEvent::GetReminderSoundFile
virtual CString GetReminderSoundFile() const
Call this member function to determine a full path to the sound file assigned to the event reminder.
Definition XTPCalendarEvent.h:1184
CXTPCalendarEvent::IsEqualIDs
BOOL IsEqualIDs(const CXTPCalendarEvent *pEvent) const
Call this member function to compare IDs of different events.
CXTPCalendarEvent::SetRecurrenceState_NotRecurring
virtual BOOL SetRecurrenceState_NotRecurring()
This function is used to reset the recurrence state for an event.
CXTPCalendarEvent::SetEventVisible
void SetEventVisible(BOOL bSet)
This member function is used to set the EventVisible flag for an event.
Definition XTPCalendarEvent.h:1143
CXTPCalendarEvent::SetRecurrenceState_Master
virtual BOOL SetRecurrenceState_Master(CXTPCalendarRecurrencePattern *pPattern)
This member function is used to assign a new RecurrencePattern to an event and set the Master flag.
CXTPCalendarEventLabel
This class defines Calendar Event label properties.
Definition XTPCalendarEventLabel.h:43
CXTPCalendarEventLabels
This class is used as a collection of CXTPCalendarEventLabel objects.
Definition XTPCalendarEventLabel.h:120
CXTPCalendarIconIDs
This class represents the collection of custom icons IDs.
Definition XTPCalendarEventLabel.h:636
CXTPCalendarRecurrencePattern
This class represents a recurrence pattern and stores data to build a schedule for recurrence events.
Definition XTPCalendarRecurrencePattern.h:398
CXTPCalendarView
This class represents the view portion of the Calendar control.
Definition XTPCalendarView.h:360
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72


Toolkit Pro: XTPRecentFileList.h Source File

  • Source
  • CommandBars
XTPRecentFileList.h
Go to the documentation of this file.
1
23#if !defined(__XTPRECENTFILELIST_H__)
24# define __XTPRECENTFILELIST_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPRecentFileList;
34
35class _XTP_EXT_CLASS CXTPRecentFileListItem : public CXTPCmdTarget
36{
37 DECLARE_DYNAMIC(CXTPRecentFileListItem);
38
39public:
40 CXTPRecentFileListItem(CXTPRecentFileList* pList);
41
42public:
43 BOOL IsPinned() const;
44 void SetPinned(BOOL bPinned);
45
46 int GetIconId() const;
47 void SetIconId(int nIconId);
48
49 void SetCaption(LPCTSTR lpszCaption);
50 CString GetCaption() const;
51
52 void SetTag(LPCTSTR lpszTag);
53 CString GetTag() const;
54
55 CString GetPathName() const;
56
57 CXTPRecentFileList* GetList() const;
58
59# ifdef _XTP_COMMANDBARS_ACTIVEX
61 DECLARE_DISPATCH_MAP()
62 DECLARE_INTERFACE_MAP()
63 DECLARE_OLETYPELIB_EX(CXTPRecentFileListItem);
64 BSTR OleGetPathName();
66# endif
67
68protected:
69 BOOL m_bPinned;
70 int m_nIconId;
71
72 CString m_strPathName;
73 CString m_strCaption;
74 CString m_strTag;
75 CXTPRecentFileList* m_pList;
76
77 friend class CXTPRecentFileList;
78};
79
85class _XTP_EXT_CLASS CXTPRecentFileList
86 : public CXTPCmdTarget
87 , public CRecentFileList
88{
90 DECLARE_DYNAMIC(CXTPRecentFileList)
92public:
102 CXTPRecentFileList(UINT nStart, LPCTSTR lpszSection, LPCTSTR lpszEntryFormat, int nSize,
103 int nMaxDispLen = AFX_ABBREV_FILENAME_LEN);
104
109 ~CXTPRecentFileList();
110
111public:
117 virtual void Remove(int nIndex);
118
126 virtual void Add(LPCTSTR lpszPathName);
127
128 using CRecentFileList::Add;
129
134 virtual void ReadList();
135
140 virtual void WriteList();
141
142 CXTPRecentFileListItem* GetItem(int nIndex) const;
143 int GetCount() const;
144
145protected:
146 virtual void OnNewItem(CXTPRecentFileListItem* pItem);
147 CXTPRecentFileListItem* AddItem(LPCTSTR lpszPathName);
148
149# ifdef _XTP_COMMANDBARS_ACTIVEX
151 DECLARE_DISPATCH_MAP()
152 DECLARE_INTERFACE_MAP()
153 DECLARE_OLETYPELIB_EX(CXTPRecentFileList);
154
155 LPDISPATCH OleAdd(LPCTSTR lpszFileName);
156 long OleGetItemCount();
157 void OleSetMaxSize(int nMaxSize);
158 long OleGetMaxSize();
159 LPDISPATCH OleGetItem(int nIndex);
160 LPDISPATCH OleItem(int nIndex);
161 void OleRemove(int nIndex);
162 DECLARE_ENUM_VARIANT(CXTPRecentFileList)
164# endif
165
166public:
167 BOOL m_bPinable;
169protected:
170 CXTPRecentFileListItem** m_pItems;
171};
172
173AFX_INLINE BOOL CXTPRecentFileListItem::IsPinned() const
174{
175 return m_bPinned;
176}
177AFX_INLINE void CXTPRecentFileListItem::SetPinned(BOOL bPinned)
178{
179 m_bPinned = bPinned;
180}
181AFX_INLINE int CXTPRecentFileListItem::GetIconId() const
182{
183 return m_nIconId;
184}
185AFX_INLINE void CXTPRecentFileListItem::SetIconId(int nIconId)
186{
187 m_nIconId = nIconId;
188}
189AFX_INLINE void CXTPRecentFileListItem::SetCaption(LPCTSTR lpszCaption)
190{
191 m_strCaption = lpszCaption;
192}
193AFX_INLINE CString CXTPRecentFileListItem::GetCaption() const
194{
195 return m_strCaption;
196}
197AFX_INLINE void CXTPRecentFileListItem::SetTag(LPCTSTR lpszTag)
198{
199 m_strTag = lpszTag;
200}
201AFX_INLINE CString CXTPRecentFileListItem::GetTag() const
202{
203 return m_strTag;
204}
205AFX_INLINE CString CXTPRecentFileListItem::GetPathName() const
206{
207 return m_strPathName;
208}
209AFX_INLINE CXTPRecentFileList* CXTPRecentFileListItem::GetList() const
210{
211 return m_pList;
212}
213
215# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
216#endif // !defined(__XTPRECENTFILELIST_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPRecentFileList
CXTPRecentFileList is a CRecentFileList derived class.
Definition XTPRecentFileList.h:88
CXTPRecentFileList::m_bPinable
BOOL m_bPinable
True if the MRU is a pinnable MRU (for ribbon).
Definition XTPRecentFileList.h:167
CXTPRecentFileList::Remove
virtual void Remove(int nIndex)
Removes an item from the MRU.
CXTPRecentFileList::ReadList
virtual void ReadList()
Reads from registry or ini file.
CXTPRecentFileList::CXTPRecentFileList
CXTPRecentFileList(UINT nStart, LPCTSTR lpszSection, LPCTSTR lpszEntryFormat, int nSize, int nMaxDispLen=AFX_ABBREV_FILENAME_LEN)
Constructs a CXTPPinableRecentFileList object.
CXTPRecentFileList::WriteList
virtual void WriteList()
Writes to registry or ini file.
CXTPRecentFileList::Add
virtual void Add(LPCTSTR lpszPathName)
Adds an item to the MRU.
CXTPRecentFileList::~CXTPRecentFileList
~CXTPRecentFileList()
Destroys a CXTPPinableRecentFileList object, handles cleanup and deallocation.


Toolkit Pro: XTPDatePickerVisualStudio2015Theme.h Source File

  • Source
  • Calendar
  • DatePicker
  • Themes
XTPDatePickerVisualStudio2015Theme.h
Go to the documentation of this file.
1
22#if !defined(_XTPDATEPICKERVISUALSTUDIO2015THEME_H__)
23# define _XTPDATEPICKERVISUALSTUDIO2015THEME_H__
24
25# if _MSC_VER > 1000
26# pragma once
27# endif // _MSC_VER > 1000
28
29# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
30
51class _XTP_EXT_CLASS CXTPDatePickerThemeVisualStudio2015 : public CXTPDatePickerThemeOffice2013
52{
53public:
62 CXTPDatePickerThemeVisualStudio2015();
63
70 virtual ~CXTPDatePickerThemeVisualStudio2015();
71};
72
73# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
74#endif // !defined(_XTPDATEPICKERVISUALSTUDIO2015THEME_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPDatePickerThemeOffice2013
Class CXTPDatePickerThemeOffice2013 is derived from CXTPDatePickerPaintManager for rendering an Offic...
Definition XTPDatePickerOffice2013Theme.h:52
CXTPDatePickerThemeVisualStudio2015
Class CXTPDatePickerThemeVisualStudio2015 is derived from CXTPDatePickerThemeOffice2013 for rendering...
Definition XTPDatePickerVisualStudio2015Theme.h:52
CXTPDatePickerThemeVisualStudio2015::CXTPDatePickerThemeVisualStudio2015
CXTPDatePickerThemeVisualStudio2015()
Default paint manager constructor.
CXTPDatePickerThemeVisualStudio2015::~CXTPDatePickerThemeVisualStudio2015
virtual ~CXTPDatePickerThemeVisualStudio2015()
Default paint manager destructor.


Toolkit Pro: XTPFontComboBox.h Source File

  • Source
  • Controls
  • Combo
XTPFontComboBox.h
Go to the documentation of this file.
1
23#if !defined(__XTPFONTCOMBOBOX_H__)
24# define __XTPFONTCOMBOBOX_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
43typedef CList<CXTPLogFont, CXTPLogFont&> CXTPFontList;
44
61class _XTP_EXT_CLASS CXTPFontEnum
62{
63 friend class CXTPSingleton<CXTPFontEnum>;
64
65protected:
71 CXTPFontEnum();
72
73public:
78 virtual ~CXTPFontEnum();
79
80public:
94 static CXTPFontEnum& AFX_CDECL Get();
95
105 bool DoesFontExist(CString& strFaceName);
106
117 CXTPLogFont* GetLogFont(const CString& strFaceName);
118
127 int GetMaxWidth();
128
136 int GetMaxWidth(LPCTSTR lpString);
137
144 CXTPFontList& GetFontList();
145
157 void Init(CDC* pDC = NULL, BYTE nCharSet = DEFAULT_CHARSET);
158
159protected:
187 static BOOL CALLBACK EnumFontFamExProc(ENUMLOGFONTEX* pelf, NEWTEXTMETRICEX* lpntm,
188 DWORD dwFontType, LPARAM lParam);
189
206 bool AddFont(const LOGFONT* pLF, DWORD dwType);
207
208protected:
209 CXTPFontList m_listFonts;
210 CDC* m_pDC;
211};
212
214
215AFX_INLINE CXTPFontList& CXTPFontEnum::GetFontList()
216{
217 return m_listFonts;
218}
231enum XTPFontStyle
232{
233 xtpFontUnknown = 0x00,
234 xtpFontGUI = 0x01,
235 xtpFontSample = 0x02,
236 xtpFontBoth = 0x03,
238};
239
240class CXTPFontListBox;
241class CXTPFontComboBox;
242
248class _XTP_EXT_CLASS CXTPFontCtrlBase
249{
250public:
255 CXTPFontCtrlBase();
256
261 virtual ~CXTPFontCtrlBase();
262
270 static int AFX_CDECL GetFontItemHeight();
271
280 static BOOL AFX_CDECL CreateUIFont(CFont& font);
281
294 virtual BOOL GetSelFont(CXTPLogFont& lf);
295
309 virtual BOOL GetSelFont(CString& strFaceName);
310
322 virtual BOOL SetSelFont(CXTPLogFont& lf);
323
336 virtual BOOL SetSelFont(const CString& strFaceName);
337
338protected:
346 virtual void OnDrawItem(LPDRAWITEMSTRUCT lpDIS);
347
354 virtual void OnMeasureItem(LPMEASUREITEMSTRUCT lpMIS);
355
372 virtual int OnCompareItem(LPCOMPAREITEMSTRUCT lpCIS);
373
380 virtual void OnInit(CXTPFontListBox* pListBox);
381
388 virtual void OnInit(CXTPFontComboBox* pComboBox);
389
390protected:
391 DWORD m_dwStyle;
392 CString m_csSymbol;
393 CXTPFontListBox* m_pListBox;
394 CXTPFontComboBox* m_pComboBox;
396 enum
397 {
398 FontTypeWidth = 16
399 };
400};
401
411class _XTP_EXT_CLASS CXTPFontListBox
412 : public CXTPListBox
413 , public CXTPFontCtrlBase
414{
415public:
420 CXTPFontListBox();
421
426 virtual ~CXTPFontListBox();
427
440 void SetListStyle(DWORD dwStyle);
441
449 virtual void Initialize(bool bAutoFont = true);
450
451protected:
453 DECLARE_MESSAGE_MAP()
454
455 //{{AFX_VIRTUAL(CXTPFontListBox)
456 virtual void DrawItem(LPDRAWITEMSTRUCT lpDrawItemStruct);
457 virtual void MeasureItem(LPMEASUREITEMSTRUCT lpMeasureItemStruct);
458 virtual int CompareItem(LPCOMPAREITEMSTRUCT lpCompareItemStruct);
459 //}}AFX_VIRTUAL
460
461 //{{AFX_MSG(CXTPFontListBox)
462 //}}AFX_MSG
464};
465
467
468AFX_INLINE void CXTPFontListBox::SetListStyle(DWORD dwStyle)
469{
470 m_dwStyle = dwStyle;
471}
479class _XTP_EXT_CLASS CXTPFontComboBox
480 : public CXTPComboBox
481 , public CXTPFontCtrlBase
482{
484 DECLARE_DYNAMIC(CXTPFontComboBox)
486public:
491 CXTPFontComboBox();
492
497 virtual ~CXTPFontComboBox();
498
499public:
519 void SetListStyle(DWORD dwStyle);
520
533 virtual void InitControl(LPCTSTR lpszFaceName = NULL, UINT nWidth = 0, BOOL bEnable = TRUE);
534
535protected:
542 virtual void NotifyOwner(UINT nCode);
543
545 DECLARE_MESSAGE_MAP()
546
547 //{{AFX_VIRTUAL(CXTPFontComboBox)
548 virtual void DrawItem(LPDRAWITEMSTRUCT);
549 virtual void MeasureItem(LPMEASUREITEMSTRUCT);
550 virtual int CompareItem(LPCOMPAREITEMSTRUCT lpCompareItemStruct);
551 virtual BOOL PreTranslateMessage(MSG* pMsg);
552 //}}AFX_VIRTUAL
553
554 //{{AFX_MSG(CXTPFontComboBox)
555 afx_msg BOOL OnDropDown();
556 afx_msg BOOL OnCloseUp();
557 //}}AFX_MSG
561public:
562# ifdef _DEBUG
563 virtual void AssertValid() const;
564# endif
567private:
568 CString m_csSelected;
569 BOOL m_bIsOpen;
570};
571
573
574AFX_INLINE void CXTPFontComboBox::SetListStyle(DWORD dwStyle)
575{
576 m_dwStyle = dwStyle;
577}
579# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
581#endif // #if !defined(__XTPFONTCOMBOBOX_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPFontList
CList< CXTPLogFont, CXTPLogFont & > CXTPFontList
List used for enumerating CXTPLogFont structures.
Definition XTPFontComboBox.h:43
XTPFontStyle
XTPFontStyle
Enumeration used to determine font display.
Definition XTPFontComboBox.h:232
xtpFontUnknown
@ xtpFontUnknown
Display type not defined.
Definition XTPFontComboBox.h:233
xtpFontSample
@ xtpFontSample
Display font name with its own font style.
Definition XTPFontComboBox.h:235
xtpFontGUI
@ xtpFontGUI
Display font name with GUI font style.
Definition XTPFontComboBox.h:234
xtpFontBoth
@ xtpFontBoth
Display font name with GUI font style, then a sample display to the right.
Definition XTPFontComboBox.h:236
CXTPComboBox
The CXTPComboBox class provides the functionality of a themed Windows combobox.
Definition XTPComboBox.h:42
CXTPFontComboBox
CXTPFontComboBox is a CXTPComboBox derived class.
Definition XTPFontComboBox.h:482
CXTPFontComboBox::InitControl
virtual void InitControl(LPCTSTR lpszFaceName=NULL, UINT nWidth=0, BOOL bEnable=TRUE)
Initializes the CXTPFontComboBox control.
CXTPFontComboBox::~CXTPFontComboBox
virtual ~CXTPFontComboBox()
Destroys a CXTPFontComboBox object, handles cleanup and deallocation.
CXTPFontComboBox::SetListStyle
void SetListStyle(DWORD dwStyle)
Sets the font style for the CXTPFontComboBox control.
CXTPFontComboBox::CXTPFontComboBox
CXTPFontComboBox()
Constructs a CXTPFontComboBox object.
CXTPFontComboBox::NotifyOwner
virtual void NotifyOwner(UINT nCode)
Called by the font combobox to send CBN notifications to the owner window to support keyboard navigat...
CXTPFontCtrlBase
CXTPFontCtrlBase is a base class used by CXTPFontListBox and CXTPFontComboBox controls to perform com...
Definition XTPFontComboBox.h:249
CXTPFontCtrlBase::GetFontItemHeight
static int AFX_CDECL GetFontItemHeight()
Call this member function to retrieve the default height for combo or list items.
CXTPFontCtrlBase::OnInit
virtual void OnInit(CXTPFontComboBox *pComboBox)
Call this member function to set the combobox pointer for the base class.
CXTPFontCtrlBase::m_pComboBox
CXTPFontComboBox * m_pComboBox
Pointer to the owner combobox.
Definition XTPFontComboBox.h:394
CXTPFontCtrlBase::SetSelFont
virtual BOOL SetSelFont(const CString &strFaceName)
Call this member function to select the font for the list box.
CXTPFontCtrlBase::OnInit
virtual void OnInit(CXTPFontListBox *pListBox)
Call this member function to set the listbox pointer for the base class.
CXTPFontCtrlBase::m_csSymbol
CString m_csSymbol
String displayed for the symbol characters.
Definition XTPFontComboBox.h:392
CXTPFontCtrlBase::m_pListBox
CXTPFontListBox * m_pListBox
Pointer to the owner list box.
Definition XTPFontComboBox.h:393
CXTPFontCtrlBase::~CXTPFontCtrlBase
virtual ~CXTPFontCtrlBase()
Handles object destruction.
CXTPFontCtrlBase::OnMeasureItem
virtual void OnMeasureItem(LPMEASUREITEMSTRUCT lpMIS)
This method is called by the framework when a combo or list box with an owner-drawn style is created.
CXTPFontCtrlBase::m_dwStyle
DWORD m_dwStyle
Display style indicating how to render the font list.
Definition XTPFontComboBox.h:391
CXTPFontCtrlBase::CXTPFontCtrlBase
CXTPFontCtrlBase()
Standard constructor.
CXTPFontCtrlBase::SetSelFont
virtual BOOL SetSelFont(CXTPLogFont &lf)
Call this member function to select the font for the list box.
CXTPFontCtrlBase::OnCompareItem
virtual int OnCompareItem(LPCOMPAREITEMSTRUCT lpCIS)
Called by the framework to determine the relative position of a new item in the list-box portion of a...
CXTPFontCtrlBase::OnDrawItem
virtual void OnDrawItem(LPDRAWITEMSTRUCT lpDIS)
This method is called by the framework when a visual aspect of an owner-drawn combo or list box chang...
CXTPFontCtrlBase::GetSelFont
virtual BOOL GetSelFont(CString &strFaceName)
Call this member function to get the font for the currently selected item.
CXTPFontCtrlBase::GetSelFont
virtual BOOL GetSelFont(CXTPLogFont &lf)
Call this member function to get the font for the currently selected item.
CXTPFontCtrlBase::CreateUIFont
static BOOL AFX_CDECL CreateUIFont(CFont &font)
Call this member function to create a default font for a combo or list box.
CXTPFontEnum
CXTPFontEnum is a standalone singleton font enumeration class.
Definition XTPFontComboBox.h:62
CXTPFontEnum::AddFont
bool AddFont(const LOGFONT *pLF, DWORD dwType)
This member function is called by the font enumeration callback to add a font to the font list.
CXTPFontEnum::CXTPFontEnum
CXTPFontEnum()
Constructs a CXTPFontEnum object.
CXTPFontEnum::GetMaxWidth
int GetMaxWidth()
This member function is used by the callback function to retrieve the current width for the longest f...
CXTPFontEnum::GetMaxWidth
int GetMaxWidth(LPCTSTR lpString)
Retrieves the widest size of a string provided using available fonts.
CXTPFontEnum::GetLogFont
CXTPLogFont * GetLogFont(const CString &strFaceName)
This member function is used to get a pointer to the font specified by 'strFaceName'.
CXTPFontEnum::Get
static CXTPFontEnum &AFX_CDECL Get()
This static member function will return a reference to the one and only CXTPFontEnum object.
CXTPFontEnum::Init
void Init(CDC *pDC=NULL, BYTE nCharSet=DEFAULT_CHARSET)
This member function is called by the CXTPFontEnum class to initialize the font list.
CXTPFontEnum::EnumFontFamExProc
static BOOL CALLBACK EnumFontFamExProc(ENUMLOGFONTEX *pelf, NEWTEXTMETRICEX *lpntm, DWORD dwFontType, LPARAM lParam)
The EnumFontFamExProc function is an application defined-callback function used with the EnumFontFami...
CXTPFontEnum::m_listFonts
CXTPFontList m_listFonts
List of fonts found during enumeration.
Definition XTPFontComboBox.h:209
CXTPFontEnum::~CXTPFontEnum
virtual ~CXTPFontEnum()
Destroys a CXTPFontEnum object, handles cleanup and deallocation.
CXTPFontEnum::DoesFontExist
bool DoesFontExist(CString &strFaceName)
This member function is used to determine the existence of the font specified by 'strFaceName'.
CXTPFontEnum::GetFontList
CXTPFontList & GetFontList()
This member function is used to get a reference to the font list.
CXTPFontListBox
CXTPFontListBox is a CXTPListBox derived class.
Definition XTPFontComboBox.h:414
CXTPFontListBox::SetListStyle
void SetListStyle(DWORD dwStyle)
Call this member function to set the font display style for the font list box.
CXTPFontListBox::CXTPFontListBox
CXTPFontListBox()
Constructs a CXTPFontListBox object.
CXTPFontListBox::Initialize
virtual void Initialize(bool bAutoFont=true)
Call this member function to initialize the font list box and populate it with a list of available fo...
CXTPFontListBox::~CXTPFontListBox
virtual ~CXTPFontListBox()
Destroys a CXTPFontListBox object, handles cleanup and deallocation.
CXTPListBox
CXTPListBox is a CListBox derived class.
Definition XTPListBox.h:127
CXTPLogFont
CXTPLogFont is a self initializing LOGFONT derived class.
Definition XTPGlobal.h:69
CXTPSingleton
Implements Singleton design pattern.
Definition XTPSingleton.h:215


Toolkit Pro: Member List

CXTPGridSections Member List

This is the complete list of members for CXTPGridSections, including all inherited members.

AdjustLayout(CDC *pDC, CRect rcSections) | CXTPGridSections | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPGridSections(CXTPGridControl *pControl) | CXTPGridSections |
Draw(CDC *pDC) | CXTPGridSections | virtual
EnsureVisible(CDC *pDC, CXTPGridRow *pRow) | CXTPGridSections | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetFocusedRow() const | CXTPGridSections |
GetRect() const | CXTPGridSections |
HitTest(CPoint pt) const | CXTPGridSections |
m_pControl | CXTPGridSections | protected
m_rcSections | CXTPGridSections | protected
RefreshIndexes(BOOL bAdjustLayout) | CXTPGridSections | virtual
ReSortRows() | CXTPGridSections | virtual
SetMarkupContext(CXTPMarkupContext *pMarkupContext) | CXTPGridSections |
~CXTPGridSections() | CXTPGridSections |


Toolkit Pro: XTPChartOpenGLShadeModelDeviceCommand.h Source File

  • Source
  • Chart
  • Drawing
  • OpenGL
XTPChartOpenGLShadeModelDeviceCommand.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTOPENGLPOLYGONDEVICECOMMAND_H__)
24# define __XTPCHARTOPENGLPOLYGONDEVICECOMMAND_H__
25
26# if _MSC_VER >= 1000
27# pragma once
28# endif // _MSC_VER >= 1000
29
30# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
31
32class _XTP_EXT_CLASS CXTPChartOpenGLShadeModelDeviceCommand
33 : public CXTPChartPolygonAntialiasingDeviceCommand
34{
35public:
43 CXTPChartOpenGLShadeModelDeviceCommand(BOOL bAntiAlias = TRUE);
44
49 ~CXTPChartOpenGLShadeModelDeviceCommand();
50
51protected:
59 virtual void BeforeExecute(CXTPChartDeviceContext* pDC);
60
68 virtual void AfterExecute(CXTPChartDeviceContext* pDC);
69
70private:
71 GLint m_nOldShadeModel;
72};
73
74# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
75#endif //#if !defined(__XTPCHARTOPENGLPOLYGONDEVICECOMMAND_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartPolygonAntialiasingDeviceCommand
Base class implementation for 2D chart antialiased polygon device command.
Definition XTPChartPolygonDeviceCommand.h:103
CXTPChartPolygonAntialiasingDeviceCommand::AfterExecute
virtual void AfterExecute(CXTPChartDeviceContext *pDC)=0
This method gets called after a command is executed which allows for the customization of command beh...
CXTPChartPolygonAntialiasingDeviceCommand::BeforeExecute
virtual void BeforeExecute(CXTPChartDeviceContext *pDC)=0
This method gets called before a command is executed which allows for the customization of command be...


Toolkit Pro: Member List

CXTPDialogBase< TBase > Member List

This is the complete list of members for CXTPDialogBase< TBase >, including all inherited members.

CXTPDialogBase() | CXTPDialogBase< TBase > | inline
CXTPDialogBase(UINT nIDTemplate, CWnd *pParentWnd=NULL) | CXTPDialogBase< TBase > | inline
CXTPDialogBase(LPCTSTR lpszTemplateName, CWnd *pParentWnd=NULL) | CXTPDialogBase< TBase > | inline


Toolkit Pro: XTPChartTitleView.h Source File

  • Source
  • Chart
XTPChartTitleView.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTTITLEVIEW_H__)
24# define __XTPCHARTTITLEVIEW_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartTitle;
34class CXTPChartElementView;
35class CXTPChartDeviceCommand;
36class CXTPChartDeviceContext;
37class CXTPChartTitle;
38
40// CXTPChartTitleView
41
42class _XTP_EXT_CLASS CXTPChartTitleView : public CXTPChartElementView
43{
44public:
45 CXTPChartTitleView(CXTPChartTitle* pTitle, CXTPChartString& strText,
46 CXTPChartElementView* pParentView);
47
48 ~CXTPChartTitleView();
49
50public:
51 virtual CXTPChartDeviceCommand* CreateDeviceCommand(CXTPChartDeviceContext* pDC);
52
53 void CalculateView(CXTPChartDeviceContext* pDC, CRect& rcBounds, CRect rcChart);
54
55 CXTPChartString m_strText;
56 CXTPChartTitle* m_pTitle;
57 CPoint m_ptOrigin;
58};
60# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
61#endif //#if !defined(__XTPCHARTTITLEVIEW_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartElementView
This class represents the view of a chart element.
Definition XTPChartElementView.h:47
CXTPChartElementView::CreateDeviceCommand
virtual CXTPChartDeviceCommand * CreateDeviceCommand(CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
CXTPChartTitle
This class represents a chart title.
Definition XTPChartTitle.h:56


Toolkit Pro: XTPOpenGLListPool.h Source File

  • Source
  • GraphicLibrary
  • OpenGL
XTPOpenGLListPool.h
Go to the documentation of this file.
1
23#if !defined(__XTPOPENGLLISTPOOL_H__)
24#define __XTPOPENGLLISTPOOL_H__
27#if _MSC_VER > 1000
28#pragma once
29#endif // _MSC_VER > 1000
30
31#include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPOpenGLListPool : public CXTPSingleton<CXTPOpenGLListPool>
39{
40 friend class CXTPSingleton<CXTPOpenGLListPool>;
41
42 CXTPOpenGLListPool();
43 ~CXTPOpenGLListPool();
44
45public:
46
58 GLuint AllocateList(GLenum mode);
59
67 void CommitList();
68
77 void ReclaimList(GLuint id);
78
79private:
80 GLuint m_nMax;
81 CList<GLuint, const GLuint&> m_allocated;
82 CList<GLuint, const GLuint&> m_reclaimed;
83 BOOL m_bCommitExpected;
84};
85
92_XTP_EXT_CLASS CXTPOpenGLListPool* AFX_CDECL XTPOpenGLListPool();
93
94
95#include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
97#endif // #if !defined(__XTPOPENGLLISTPOOL_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPOpenGLListPool
_XTP_EXT_CLASS CXTPOpenGLListPool *AFX_CDECL XTPOpenGLListPool()
Provides access to the global instance of an OpenGL list pool object.
CXTPOpenGLListPool
Provides a convenient API around an OpenGL list for reliable list management.
Definition XTPOpenGLListPool.h:39
CXTPOpenGLListPool::ReclaimList
void ReclaimList(GLuint id)
Reclaims a previously allocated and committed OpenGL list and releases all associated resources.
CXTPOpenGLListPool::AllocateList
GLuint AllocateList(GLenum mode)
Allocates an OpenGL list.
CXTPOpenGLListPool::CommitList
void CommitList()
Commits a list that has been allocated during a previous call to AllocateList.
CXTPSingleton
Implements Singleton design pattern.
Definition XTPSingleton.h:215


Toolkit Pro: XTPChartTypes.h Source File

  • Source
  • Chart
  • Types
XTPChartTypes.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTTYPES_H__)
24# define __XTPCHARTTYPES_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPPropExchange;
34
35typedef CXTPPoint2f CXTPChartPointF, CXTPChartPoint2dF;
36typedef CXTPPoint3f CXTPChartPoint3dF;
37typedef CXTPSizeF CXTPChartSizeF;
38typedef CXTPRectF CXTPChartRectF;
39
40typedef CArray<CXTPChartPoint2dF, const CXTPChartPoint2dF&> CXTPChartPoints, CXTPChartPoints2d;
41typedef CArray<CXTPChartPoint3dF, const CXTPChartPoint3dF&> CXTPChartPoints3d;
42typedef CArray<float, float> CXTPChartLineDashArray;
43typedef CString CXTPChartString;
44
50class _XTP_EXT_CLASS CXTPChartColor
51{
52public:
53 typedef DWORD ARGB;
54
55public:
61 CXTPChartColor()
62 {
63 Argb = CXTPChartColor::Empty;
64 }
65
79 CXTPChartColor(BYTE r, BYTE g, BYTE b)
80 {
81 Argb = MakeARGB(255, r, g, b);
82 }
83
97 CXTPChartColor(BYTE a, BYTE r, BYTE g, BYTE b)
98 {
99 Argb = MakeARGB(a, r, g, b);
100 }
101
109 CXTPChartColor(ARGB argb)
110 {
111 Argb = argb;
112 }
113
121 BYTE GetAlpha() const
122 {
123 return (BYTE)(Argb >> AlphaShift);
124 }
125
133 BYTE GetA() const
134 {
135 return GetAlpha();
136 }
137
145 BYTE GetRed() const
146 {
147 return (BYTE)(Argb >> RedShift);
148 }
149
157 BYTE GetR() const
158 {
159 return GetRed();
160 }
161
169 BYTE GetGreen() const
170 {
171 return (BYTE)(Argb >> GreenShift);
172 }
173
181 BYTE GetG() const
182 {
183 return GetGreen();
184 }
185
193 BYTE GetBlue() const
194 {
195 return (BYTE)(Argb >> BlueShift);
196 }
197
205 BYTE GetB() const
206 {
207 return GetBlue();
208 }
209
216 float ClampA() const
217 {
218 return static_cast<float>(GetA()) / 255;
219 }
220
227 float ClampR() const
228 {
229 return static_cast<float>(GetR()) / 255;
230 }
231
238 float ClampG() const
239 {
240 return static_cast<float>(GetG()) / 255;
241 }
242
249 float ClampB() const
250 {
251 return static_cast<float>(GetB()) / 255;
252 }
253
260 ARGB GetValue() const
261 {
262 return Argb;
263 }
264
272 VOID SetValue(ARGB argb)
273 {
274 Argb = argb;
275 }
276
287 VOID SetFromCOLORREF(COLORREF rgb)
288 {
289 Argb = MakeARGB(255, GetRValue(rgb), GetGValue(rgb), GetBValue(rgb));
290 }
291
302 void SetFromString(LPCTSTR lpsz);
303
310 COLORREF ToCOLORREF() const
311 {
312 return RGB(GetRed(), GetGreen(), GetBlue());
313 }
314
321 BOOL IsEmpty() const
322 {
323 return Argb == Empty;
324 }
325
332 CXTPChartColor GetDarkColor() const;
333
334public:
335 // Common color constants
336
337 const static ARGB AliceBlue;
338 const static ARGB AntiqueWhite;
339 const static ARGB Aqua;
340 const static ARGB Aquamarine;
341 const static ARGB Azure;
342 const static ARGB Beige;
343 const static ARGB Bisque;
344 const static ARGB Black;
345 const static ARGB BlanchedAlmond;
346 const static ARGB Blue;
347 const static ARGB BlueViolet;
348 const static ARGB Brown;
349 const static ARGB BurlyWood;
350 const static ARGB CadetBlue;
351 const static ARGB Chartreuse;
352 const static ARGB Chocolate;
353 const static ARGB Coral;
354 const static ARGB CornflowerBlue;
355 const static ARGB Cornsilk;
356 const static ARGB Crimson;
357 const static ARGB Cyan;
358 const static ARGB DarkBlue;
359 const static ARGB DarkCyan;
360 const static ARGB DarkGoldenrod;
361 const static ARGB DarkGray;
362 const static ARGB DarkGreen;
363 const static ARGB DarkKhaki;
364 const static ARGB DarkMagenta;
365 const static ARGB DarkOliveGreen;
366 const static ARGB DarkOrange;
367 const static ARGB DarkOrchid;
368 const static ARGB DarkRed;
369 const static ARGB DarkSalmon;
370 const static ARGB DarkSeaGreen;
371 const static ARGB DarkSlateBlue;
372 const static ARGB DarkSlateGray;
373 const static ARGB DarkTurquoise;
374 const static ARGB DarkViolet;
375 const static ARGB DeepPink;
376 const static ARGB DeepSkyBlue;
377 const static ARGB DimGray;
378 const static ARGB DodgerBlue;
379 const static ARGB Firebrick;
380 const static ARGB FloralWhite;
381 const static ARGB ForestGreen;
382 const static ARGB Fuchsia;
383 const static ARGB Gainsboro;
384 const static ARGB GhostWhite;
385 const static ARGB Gold;
386 const static ARGB Goldenrod;
387 const static ARGB Gray;
388 const static ARGB Green;
389 const static ARGB GreenYellow;
390 const static ARGB Honeydew;
391 const static ARGB HotPink;
392 const static ARGB IndianRed;
393 const static ARGB Indigo;
394 const static ARGB Ivory;
395 const static ARGB Khaki;
396 const static ARGB Lavender;
397 const static ARGB LavenderBlush;
398 const static ARGB LawnGreen;
399 const static ARGB LemonChiffon;
400 const static ARGB LightBlue;
401 const static ARGB LightCoral;
402 const static ARGB LightCyan;
403 const static ARGB LightGoldenrodYellow;
404 const static ARGB LightGray;
405 const static ARGB LightGreen;
406 const static ARGB LightPink;
407 const static ARGB LightSalmon;
408 const static ARGB LightSeaGreen;
409 const static ARGB LightSkyBlue;
410 const static ARGB LightSlateGray;
411 const static ARGB LightSteelBlue;
412 const static ARGB LightYellow;
413 const static ARGB Lime;
414 const static ARGB LimeGreen;
415 const static ARGB Linen;
416 const static ARGB Magenta;
417 const static ARGB Maroon;
418 const static ARGB MediumAquamarine;
419 const static ARGB MediumBlue;
420 const static ARGB MediumOrchid;
421 const static ARGB MediumPurple;
422 const static ARGB MediumSeaGreen;
423 const static ARGB MediumSlateBlue;
424 const static ARGB MediumSpringGreen;
425 const static ARGB MediumTurquoise;
426 const static ARGB MediumVioletRed;
427 const static ARGB MidnightBlue;
428 const static ARGB MintCream;
429 const static ARGB MistyRose;
430 const static ARGB Moccas;
431 const static ARGB NavajoWhite;
432 const static ARGB Navy;
433 const static ARGB OldLace;
434 const static ARGB Olive;
435 const static ARGB OliveDrab;
436 const static ARGB Orange;
437 const static ARGB OrangeRed;
438 const static ARGB Orchid;
439 const static ARGB PaleGoldenrod;
440 const static ARGB PaleGreen;
441 const static ARGB PaleTurquoise;
442 const static ARGB PaleVioletRed;
443 const static ARGB PapayaWhip;
444 const static ARGB PeachPuff;
445 const static ARGB Peru;
446 const static ARGB Pink;
447 const static ARGB Plum;
448 const static ARGB PowderBlue;
449 const static ARGB Purple;
450 const static ARGB Red;
451 const static ARGB RosyBrown;
452 const static ARGB RoyalBlue;
453 const static ARGB SaddleBrown;
454 const static ARGB Salmon;
455 const static ARGB SandyBrown;
456 const static ARGB SeaGreen;
457 const static ARGB SeaShell;
458 const static ARGB Sienna;
459 const static ARGB Silver;
460 const static ARGB SkyBlue;
461 const static ARGB SlateBlue;
462 const static ARGB SlateGray;
463 const static ARGB Snow;
464 const static ARGB SpringGreen;
465 const static ARGB SteelBlue;
466 const static ARGB Tan;
467 const static ARGB Teal;
468 const static ARGB Thistle;
469 const static ARGB Tomato;
470 const static ARGB Transparent;
471 const static ARGB Turquoise;
472 const static ARGB Violet;
473 const static ARGB Wheat;
474 const static ARGB White;
475 const static ARGB WhiteSmoke;
476 const static ARGB Yellow;
477 const static ARGB YellowGreen;
478 const static ARGB Empty;
479
484 enum
485 {
486 AlphaShift = 24,
487 RedShift = 16,
488 GreenShift = 8,
489 BlueShift = 0
490 };
491
496 enum
497 {
498 AlphaMask = 0xff000000,
499 RedMask = 0x00ff0000,
500 GreenMask = 0x0000ff00,
501 BlueMask = 0x000000ff
502 };
503
504 // Assemble A, R, G, B values into a 32-bit integer
517 static ARGB AFX_CDECL MakeARGB(BYTE a, BYTE r, BYTE g, BYTE b)
518 {
519 return (((ARGB)(b) << BlueShift) | ((ARGB)(g) << GreenShift) | ((ARGB)(r) << RedShift)
520 | ((ARGB)(a) << AlphaShift));
521 }
522
523protected:
524 ARGB Argb;
526# ifdef _XTP_ACTIVEX
528public:
529 OLE_COLOR ToOleColor();
530 static CXTPChartColor AFX_CDECL FromOleColor(OLE_COLOR);
532# endif
533};
534
539class _XTP_EXT_CLASS CXTPChartFont : public CXTPCmdTarget
540{
541public:
547 CXTPChartFont();
548
555 CXTPChartFont(LOGFONT* pLogFont);
556
561 virtual ~CXTPChartFont();
562
563public:
570 void SetLogFont(LOGFONT* lf);
571
572public:
583 static CXTPChartFont* AFX_CDECL GetTahoma18();
584
595 static CXTPChartFont* AFX_CDECL GetTahoma12();
596
607 static CXTPChartFont* AFX_CDECL GetTahoma8();
608
613 void Release();
614
615# ifdef _XTP_ACTIVEX
616public:
618 DECLARE_DISPATCH_MAP()
619 DECLARE_INTERFACE_MAP()
620 DECLARE_OLETYPELIB_EX(CXTPChartFont);
621 afx_msg void OleSetFont(LPFONTDISP pFontDisp);
622 afx_msg LPFONTDISP OleGetFont();
624# endif
625
626public:
627 LOGFONT m_lf;
628};
629
635class _XTP_EXT_CLASS CXTPChart3dRotation
636# ifdef _XTP_ACTIVEX
637 : public CXTPCmdTarget
638# endif
639{
640# ifdef _XTP_ACTIVEX
641 DECLARE_SERIAL(CXTPChart3dRotation)
642# endif
643
644public:
649 CXTPChart3dRotation();
650
657 CXTPChart3dRotation(const CXTPChart3dRotation& rhs);
658
667 CXTPChart3dRotation(double dYaw, double dPitch, double dRoll);
668
675 BOOL IsRotated() const;
676
684 void SetFromString(LPCTSTR pString);
685
692 CXTPChart3dRotation& operator=(const CXTPChart3dRotation& rhs);
693
694 double m_dYaw;
695 double m_dPitch;
696 double m_dRoll;
698# ifdef _XTP_ACTIVEX
699public:
701 DECLARE_DISPATCH_MAP()
702 DECLARE_INTERFACE_MAP()
703 DECLARE_OLETYPELIB_EX(CXTPChart3dRotation);
704 DECLARE_OLECREATE_EX(CXTPChart3dRotation);
706# endif
707};
708
709AFX_INLINE BOOL CXTPChart3dRotation::IsRotated() const
710{
711 return 0 != m_dYaw || 0 != m_dPitch || 0 != m_dRoll;
712}
713
714AFX_INLINE CXTPChart3dRotation& CXTPChart3dRotation::operator=(const CXTPChart3dRotation& rhs)
715{
716 m_dYaw = rhs.m_dYaw;
717 m_dPitch = rhs.m_dPitch;
718 m_dRoll = rhs.m_dRoll;
719 return *this;
720}
721
727class _XTP_EXT_CLASS CXTPChart3dBox
728{
729public:
731 typedef CList<CXTPPoint3d, const CXTPPoint3d&> PointList;
732
737 CXTPChart3dBox();
738
745 CXTPChart3dBox(const CXTPChart3dBox& rhs);
746
747public:
756 CXTPChart3dBox& operator=(const CXTPChart3dBox& rhs);
757
765 BOOL IsValid() const;
766
779 void Include(const CXTPPoint3d& pt, BOOL bCenterCandidate = FALSE);
780
795 void Include(double x, double y, double z, BOOL bCenterCandidate = FALSE);
796
807 void Include(const CXTPChart3dBox& box);
808
816 const CXTPPoint3d& GetMinPoint() const;
817
825 const CXTPPoint3d& GetMaxPoint() const;
826
843 CXTPPoint3d GetCenter(BOOL bAmongstCenterCandidates = FALSE) const;
844
853 void GetCorners(CXTPPoint3d (&pt)[8]) const;
854
864 const PointList& GetCenterCandidates() const;
865
866private:
867 CXTPPoint3d m_ptMin, m_ptMax;
868 PointList m_CenterCandidates;
869};
870
871AFX_INLINE void CXTPChart3dBox::Include(double x, double y, double z,
872 BOOL bCenterCandidate /*= FALSE*/)
873{
874 Include(CXTPPoint3d(x, y, z), bCenterCandidate);
875}
876AFX_INLINE const CXTPPoint3d& CXTPChart3dBox::GetMinPoint() const
877{
878 return m_ptMin;
879}
880AFX_INLINE const CXTPPoint3d& CXTPChart3dBox::GetMaxPoint() const
881{
882 return m_ptMax;
883}
884AFX_INLINE const CXTPChart3dBox::PointList& CXTPChart3dBox::GetCenterCandidates() const
885{
886 return m_CenterCandidates;
887}
888
889_XTP_EXT_CLASS BOOL AFX_CDECL PX_Color(CXTPPropExchange* pPX, LPCTSTR pszPropName,
890 CXTPChartColor& clrValue,
891 CXTPChartColor clrDefault = CXTPChartColor::Empty);
892_XTP_EXT_CLASS BOOL AFX_CDECL PX_Font(CXTPPropExchange* pPX, LPCTSTR pszPropName,
893 CXTPChartFont* pFont);
894_XTP_EXT_CLASS BOOL AFX_CDECL PX_Rotation(CXTPPropExchange* pPX, LPCTSTR pszPropName,
895 CXTPChart3dRotation& rotation,
896 CXTPChart3dRotation def = CXTPChart3dRotation());
897
898# ifdef _XTP_ACTIVEX
899extern double AFX_CDECL VariantToDoubleEx(const VARIANT* pVariant);
900extern BOOL AFX_CDECL IsStringVariant(const VARIANT* pVariant);
901extern double AFX_CDECL VariantToDouble(const VARIANT* pVariant);
902# endif
904# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
905#endif //#if !defined(__XTPCHARTTYPES_H__)
PX_Font
_XTP_EXT_CLASS BOOL AFX_CDECL PX_Font(CXTPPropExchange *pPX, LPCTSTR pcszPropName, LOGFONT &rLogFont)
Call this function within your class's DoPropExchange member function to serialize or initialize a LO...
PX_Color
_XTP_EXT_CLASS BOOL AFX_CDECL PX_Color(CXTPPropExchange *pPX, LPCTSTR pcszPropName, COLORREF &refColor)
Call this function within your class's DoPropExchange member function to serialize or initialize a cu...
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPPoint3d
CXTPPoint3T< double > CXTPPoint3d
CXTPPoint3T shortcut for double point object.
Definition XTPPoint3.h:49
CXTPChart3dBox
Represents a 3D box build around included points and provides useful and fast operations.
Definition XTPChartTypes.h:728
CXTPChart3dBox::Include
void Include(const CXTPPoint3d &pt, BOOL bCenterCandidate=FALSE)
Includes a point into the box.
CXTPChart3dBox::operator=
CXTPChart3dBox & operator=(const CXTPChart3dBox &rhs)
Performs box assignment in an efficient way.
CXTPChart3dBox::GetCenterCandidates
const PointList & GetCenterCandidates() const
Provides access to the list of center candidate points.
Definition XTPChartTypes.h:884
CXTPChart3dBox::GetMinPoint
const CXTPPoint3d & GetMinPoint() const
Obtains a minimal point in the box, i.e.
Definition XTPChartTypes.h:876
CXTPChart3dBox::PointList
CList< CXTPPoint3d, const CXTPPoint3d & > PointList
Point list collection type.
Definition XTPChartTypes.h:731
CXTPChart3dBox::CXTPChart3dBox
CXTPChart3dBox(const CXTPChart3dBox &rhs)
Constructs a copy of a provided 3D box.
CXTPChart3dBox::IsValid
BOOL IsValid() const
Determines if a box is valid, e.i.
CXTPChart3dBox::GetCorners
void GetCorners(CXTPPoint3d(&pt)[8]) const
Obtains box corners coordinates.
CXTPChart3dBox::GetCenter
CXTPPoint3d GetCenter(BOOL bAmongstCenterCandidates=FALSE) const
Computes a center of the box.
CXTPChart3dBox::Include
void Include(const CXTPChart3dBox &box)
Includes a box into the box.
CXTPChart3dBox::CXTPChart3dBox
CXTPChart3dBox()
Constructs an empty 3D box.
CXTPChart3dBox::GetMaxPoint
const CXTPPoint3d & GetMaxPoint() const
Obtains a maximal point in the box, i.e.
Definition XTPChartTypes.h:880
CXTPChart3dRotation
Represents a 3D rotation primitive for chart objects using Euler angles Yaw, Pitch and Roll in degree...
Definition XTPChartTypes.h:639
CXTPChart3dRotation::IsRotated
BOOL IsRotated() const
Checks if any rotation is applied.
Definition XTPChartTypes.h:709
CXTPChart3dRotation::m_dYaw
double m_dYaw
Yaw angle value in degrees.
Definition XTPChartTypes.h:694
CXTPChart3dRotation::operator=
CXTPChart3dRotation & operator=(const CXTPChart3dRotation &rhs)
Overloads default assignment operator.
Definition XTPChartTypes.h:714
CXTPChart3dRotation::CXTPChart3dRotation
CXTPChart3dRotation()
Constructs a rotation object with no rotation by default.
CXTPChart3dRotation::CXTPChart3dRotation
CXTPChart3dRotation(double dYaw, double dPitch, double dRoll)
Constructs a rotation object with the provided rotation parameters.
CXTPChart3dRotation::SetFromString
void SetFromString(LPCTSTR pString)
Reads rotation angle value from a string provided.
CXTPChart3dRotation::m_dPitch
double m_dPitch
Pitch angle value in degrees.
Definition XTPChartTypes.h:695
CXTPChart3dRotation::CXTPChart3dRotation
CXTPChart3dRotation(const CXTPChart3dRotation &rhs)
Constructs a rotation object with no rotation by default.
CXTPChart3dRotation::m_dRoll
double m_dRoll
Roll angle value in degrees.
Definition XTPChartTypes.h:696
CXTPChartColor
This class abstracts a color entity.
Definition XTPChartTypes.h:51
CXTPChartColor::GetRed
BYTE GetRed() const
Call this function to get the RED channel value of the color.
Definition XTPChartTypes.h:145
CXTPChartColor::ClampA
float ClampA() const
Clamps alpha color component to range 0..1.
Definition XTPChartTypes.h:216
CXTPChartColor::SetFromString
void SetFromString(LPCTSTR lpsz)
Call this function to set the color value from a string value.
CXTPChartColor::CXTPChartColor
CXTPChartColor(BYTE a, BYTE r, BYTE g, BYTE b)
Overloaded constructor, creates a color object from the specified Red, Green, Blue values.
Definition XTPChartTypes.h:97
CXTPChartColor::ClampG
float ClampG() const
Clamps green color component to range 0..1.
Definition XTPChartTypes.h:238
CXTPChartColor::CXTPChartColor
CXTPChartColor(BYTE r, BYTE g, BYTE b)
Overloaded constructor, creates an opaque color object from the specified Red, Green,...
Definition XTPChartTypes.h:79
CXTPChartColor::GetG
BYTE GetG() const
Call this function to get the GREEN channel value of the color.
Definition XTPChartTypes.h:181
CXTPChartColor::MakeARGB
static ARGB AFX_CDECL MakeARGB(BYTE a, BYTE r, BYTE g, BYTE b)
Call this static function to assemble A, R, G, B values into a 32-bit integer ARGB value.
Definition XTPChartTypes.h:517
CXTPChartColor::CXTPChartColor
CXTPChartColor()
Default constructor, creates a CXTPChartColor object and initializes the values.
Definition XTPChartTypes.h:61
CXTPChartColor::ClampR
float ClampR() const
Clamps red color component to range 0..1.
Definition XTPChartTypes.h:227
CXTPChartColor::GetBlue
BYTE GetBlue() const
Call this function to get the BLUE channel value of the color.
Definition XTPChartTypes.h:193
CXTPChartColor::GetB
BYTE GetB() const
Call this function to get the BLUE channel value of the color.
Definition XTPChartTypes.h:205
CXTPChartColor::ClampB
float ClampB() const
Clamps blue color component to range 0..1.
Definition XTPChartTypes.h:249
CXTPChartColor::CXTPChartColor
CXTPChartColor(ARGB argb)
Overloaded constructor, creates a color object from the specified premultiplied ARGB values.
Definition XTPChartTypes.h:109
CXTPChartColor::SetFromCOLORREF
VOID SetFromCOLORREF(COLORREF rgb)
Call this function to set the opaque color value from a COLORREF value.
Definition XTPChartTypes.h:287
CXTPChartColor::Argb
ARGB Argb
The 32 bit color value.
Definition XTPChartTypes.h:524
CXTPChartColor::ToCOLORREF
COLORREF ToCOLORREF() const
Call this function to convert the object to a COLORREF value.
Definition XTPChartTypes.h:310
CXTPChartColor::SetValue
VOID SetValue(ARGB argb)
Call this function to set the ARGB value of the color object.
Definition XTPChartTypes.h:272
CXTPChartColor::GetAlpha
BYTE GetAlpha() const
Call this function to get the alpha channel value of the color.
Definition XTPChartTypes.h:121
CXTPChartColor::IsEmpty
BOOL IsEmpty() const
Call this function to check whether the color object is empty.
Definition XTPChartTypes.h:321
CXTPChartColor::GetGreen
BYTE GetGreen() const
Call this function to get the GREEN channel value of the color.
Definition XTPChartTypes.h:169
CXTPChartColor::GetR
BYTE GetR() const
Call this function to get the RED channel value of the color.
Definition XTPChartTypes.h:157
CXTPChartColor::GetValue
ARGB GetValue() const
Call this function to get the ARGB value of the color object.
Definition XTPChartTypes.h:260
CXTPChartColor::GetDarkColor
CXTPChartColor GetDarkColor() const
Obtains a "darker" color for the current color.
CXTPChartColor::GetA
BYTE GetA() const
Call this function to get the alpha channel value of the color.
Definition XTPChartTypes.h:133
CXTPChartFont
This class abstracts a font entity.
Definition XTPChartTypes.h:540
CXTPChartFont::GetTahoma12
static CXTPChartFont *AFX_CDECL GetTahoma12()
Call this static function to get Tahoma font with size 12.
CXTPChartFont::~CXTPChartFont
virtual ~CXTPChartFont()
Destructor, does the cleaning.
CXTPChartFont::CXTPChartFont
CXTPChartFont()
Default constructor, creates a CXTPChartFont object and initializes the values.
CXTPChartFont::Release
void Release()
Call this function to do the cleanup.
CXTPChartFont::CXTPChartFont
CXTPChartFont(LOGFONT *pLogFont)
Overloaded constructor, creates a font object from the LOGFONT structure.
CXTPChartFont::GetTahoma8
static CXTPChartFont *AFX_CDECL GetTahoma8()
Call this static function to get Tahoma font with size 8.
CXTPChartFont::m_lf
LOGFONT m_lf
The LOGFONT variable.
Definition XTPChartTypes.h:627
CXTPChartFont::SetLogFont
void SetLogFont(LOGFONT *lf)
Call this function to set the LOGFONT for this object.
CXTPChartFont::GetTahoma18
static CXTPChartFont *AFX_CDECL GetTahoma18()
Call this static function to get Tahoma font with size 18.
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPPoint2T< float >
CXTPPoint3T< float >
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72
CXTPRectT< float >
CXTPSizeT
This class incapsulates size data.
Definition XTPSize.h:40


Toolkit Pro: XTPDockingPanePanelColorSet2012.h Source File

  • Source
  • DockingPane
  • TabColorSets
XTPDockingPanePanelColorSet2012.h
Go to the documentation of this file.
1
23#if !defined(__XTPDOCKINGPANEPANELCOLORSET2012_H__)
24# define __XTPDOCKINGPANEPANELCOLORSET2012_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPDockingPanePanelColorSet2012 : public CXTPTabPaintManagerColorSet
39{
40public:
45 CXTPDockingPanePanelColorSet2012();
46
52 virtual void RefreshMetrics();
53
62 virtual COLORREF GetItemColor(CXTPTabManagerItem* pItem);
63
80 virtual void FillNavigateButton(CDC* pDC, CXTPTabManagerNavigateButton* pButton, CRect& rc);
81};
82
83# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
85#endif // !defined(__XTPDOCKINGPANEPANELCOLORSET2012_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPDockingPanePanelColorSet2012
Helper class used to initialize default colors for a theme from an .INI resource and handle drawing r...
Definition XTPDockingPanePanelColorSet2012.h:39
CXTPDockingPanePanelColorSet2012::CXTPDockingPanePanelColorSet2012
CXTPDockingPanePanelColorSet2012()
Default class constructor.
CXTPDockingPanePanelColorSet2012::GetItemColor
virtual COLORREF GetItemColor(CXTPTabManagerItem *pItem)
Call this member function to retrieve the color for the tab specified by pItem.
CXTPDockingPanePanelColorSet2012::FillNavigateButton
virtual void FillNavigateButton(CDC *pDC, CXTPTabManagerNavigateButton *pButton, CRect &rc)
This member is called to fill the tab navigation buttons.
CXTPDockingPanePanelColorSet2012::RefreshMetrics
virtual void RefreshMetrics()
This member function is used to initialize default colors for a theme from an .INI resource.
CXTPTabManagerItem
CXTPTabManagerItem is the base class for the tabs that appear in the command bars tab workspace,...
Definition XTPTabManagerItem.h:44
CXTPTabManagerNavigateButton
CXTPTabManagerNavigateButton is a class used to represent a tab navigation button.
Definition XTPTabManagerNavigateButton.h:74
CXTPTabPaintManagerColorSet
CXTPTabPaintManagerColorSet represents the colors for all of the components of the tab manager (e....
Definition XTPTabPaintManagerColorSet.h:50


Toolkit Pro: XTPAnimationDC.h Source File

  • Source
  • Controls
  • Util
XTPAnimationDC.h
Go to the documentation of this file.
1
23#if !defined(__XTPANIMATIONDC_H__)
24# define __XTPANIMATIONDC_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
45enum XTPAnimationDCType
46{
47 xtpAniDefault,
48 xtpAniRandom,
49 xtpAniUnfold,
50 xtpAniSlide,
51 xtpAniFade,
52 xtpAniNone
53};
54
71class _XTP_EXT_CLASS CXTPAnimationDC : public CDC
72{
73public:
90 typedef void(AFX_CDECL* LPFNANIMATION)(CRect rc, CDC* pDestDC, CDC* pSrcDC, int nType,
91 int nSteps, int nAnimationTime);
92
93public:
102 CXTPAnimationDC(HDC hDestDC, const CRect& rcPaint);
103
116 CXTPAnimationDC(HDC hDestDC, const CRect& rcPaint, const CXTPPaintManagerColorGradient& clrBack,
117 const BOOL bHorz = FALSE);
118
123 virtual ~CXTPAnimationDC();
124
162 void Animate(int nType = xtpAniDefault, int nSteps = 10, int nAnimationTime = 1000);
163
186 static void AFX_CDECL DefaultAnimation(CRect rc, CDC* pDestDC, CDC* pSrcDC, int nType,
187 int nSteps, int nAnimationTime);
188
225 static void AFX_CDECL SetCustomAnimation(LPFNANIMATION pCustom);
226
227private:
233 static LPFNANIMATION m_pCustomAnimation;
234
239 static void AFX_CDECL AlphaBlendU(PBYTE, PBYTE, int, int, PBYTE, BYTE);
240
241protected:
242 HDC m_hDestDC;
243 CBitmap m_bitmap;
244 CRect m_rect;
245 HGDIOBJ m_hOldBitmap;
246};
247
248# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
250#endif // !defined(__XTPANIMATIONDC_H__)
XTPAnimationDCType
XTPAnimationDCType
Enumeration used to determine animation style.
Definition XTPAnimationDC.h:46
xtpAniRandom
@ xtpAniRandom
Animates a window with a random animation type.
Definition XTPAnimationDC.h:48
xtpAniNone
@ xtpAniNone
No animation.
Definition XTPAnimationDC.h:52
xtpAniSlide
@ xtpAniSlide
Animates a window to slide in from the left.
Definition XTPAnimationDC.h:50
xtpAniFade
@ xtpAniFade
Animates a window with a fade-in effect.
Definition XTPAnimationDC.h:51
xtpAniDefault
@ xtpAniDefault
Uses Windows default animation settings.
Definition XTPAnimationDC.h:47
xtpAniUnfold
@ xtpAniUnfold
Animates a window to unfold top to bottom.
Definition XTPAnimationDC.h:49
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPAnimationDC
CXTPAnimationDC is a CXTPBufferDC derived class.
Definition XTPAnimationDC.h:72
CXTPAnimationDC::m_hOldBitmap
HGDIOBJ m_hOldBitmap
Handle to the previously selected bitmap.
Definition XTPAnimationDC.h:245
CXTPAnimationDC::Animate
void Animate(int nType=xtpAniDefault, int nSteps=10, int nAnimationTime=1000)
This member function performs the animation.
CXTPAnimationDC::~CXTPAnimationDC
virtual ~CXTPAnimationDC()
Destroys a CXTPAnimationDC object, handles cleanup and deallocation.
CXTPAnimationDC::CXTPAnimationDC
CXTPAnimationDC(HDC hDestDC, const CRect &rcPaint)
Constructs a CXTPBufferDC object used to create a memory device context used to draw an off-screen bi...
CXTPAnimationDC::SetCustomAnimation
static void AFX_CDECL SetCustomAnimation(LPFNANIMATION pCustom)
Call this member function to setup new Animation effects.
CXTPAnimationDC::m_rect
CRect m_rect
Size of the area to paint.
Definition XTPAnimationDC.h:244
CXTPAnimationDC::m_bitmap
CBitmap m_bitmap
Bitmap in memory device context.
Definition XTPAnimationDC.h:243
CXTPAnimationDC::m_hDestDC
HDC m_hDestDC
Handle to the destination device context.
Definition XTPAnimationDC.h:242
CXTPAnimationDC::DefaultAnimation
static void AFX_CDECL DefaultAnimation(CRect rc, CDC *pDestDC, CDC *pSrcDC, int nType, int nSteps, int nAnimationTime)
This member implements default animation effects Fade, Slide and Unfold.
CXTPAnimationDC::CXTPAnimationDC
CXTPAnimationDC(HDC hDestDC, const CRect &rcPaint, const CXTPPaintManagerColorGradient &clrBack, const BOOL bHorz=FALSE)
Constructs a CXTPBufferDC object used to create a memory device context used to draw an off-screen bi...
CXTPPaintManagerColorGradient
The CXTPPaintManagerColorGradient class is used to manage COLORREF values for determining light and d...
Definition XTPColorManager.h:301


Toolkit Pro: Member List

CXTPControl Member List

This is the complete list of members for CXTPControl, including all inherited members.

AssignDocTemplate(UINT nIDResource) | CXTPControl |
ClickToolBarButton(CRect rcActiveRect=CRect(0, 0, 0, 0)) | CXTPControl | protected
Compare(CXTPControl *pOther) | CXTPControl | virtual
Copy(CXTPControl *pControl, BOOL bRecursive=FALSE) | CXTPControl | virtual
CustomizeStartDrag(CPoint point) | CXTPControl | protectedvirtual
CustomizeStartResize(CPoint point) | CXTPControl | protectedvirtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPControl() | CXTPControl | protected
DelayLayoutParent() | CXTPControl |
DelayRedrawParent() | CXTPControl |
DoCustomDragOver(CXTPCommandBar *pCommandBar, CPoint point, DROPEFFECT &dropEffect) | CXTPControl | protectedvirtual
DoPropExchange(CXTPPropExchange *pPX) | CXTPControl | virtual
Draw(CDC *pDC) | CXTPControl | virtual
ExcludeDocTemplate(UINT nIDResource) | CXTPControl |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
FromUI(CCmdUI *pCmdUI) | CXTPControl | static
GenerateCommandBarList(DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam) | CXTPControl | protectedvirtual
GetAction() const | CXTPControl |
GetBeginGroup() const | CXTPControl |
GetButtonSize() const | CXTPControl | virtual
GetCaption() const | CXTPControl | virtual
GetCategory() const | CXTPControl |
GetChecked() const | CXTPControl |
GetCloseSubMenuOnClick() const | CXTPControl |
GetCommandBar() const | CXTPControl | virtual
GetControls() const | CXTPControl |
GetCustomizeMinHeight() const | CXTPControl | protectedvirtual
GetCustomizeMinWidth() const | CXTPControl | protectedvirtual
GetCustomShortcutText() const | CXTPControl |
GetDescription() const | CXTPControl | virtual
GetEnabled() const | CXTPControl |
GetExecuteOnPressInterval() const | CXTPControl |
GetExpanded() const | CXTPControl |
GetFlags() const | CXTPControl |
GetHeight() const | CXTPControl |
GetHelpId() const | CXTPControl |
GetHideFlags() const | CXTPControl |
GetIconId() const | CXTPControl |
GetIconSize() const | CXTPControl | virtual
GetID() const | CXTPControl |
GetImage(int nWidth=16) const | CXTPControl | virtual
GetImageManager() const | CXTPControl |
GetIndex() const | CXTPControl |
GetKeyboardTip() const | CXTPControl |
GetPaintManager() const | CXTPControl |
GetParameter() const | CXTPControl |
GetParent() const | CXTPControl |
GetPopuped() const | CXTPControl | virtual
GetPressed() const | CXTPControl | virtual
GetRect() const | CXTPControl |
GetRibbonGroup() const | CXTPControl |
GetRowRect() const | CXTPControl |
GetSelected() const | CXTPControl | virtual
GetShortcutText() const | CXTPControl |
GetSize(CDC *pDC) | CXTPControl | virtual
GetStyle() const | CXTPControl |
GetTag() const | CXTPControl |
GetTooltip() const | CXTPControl | virtual
GetType() const | CXTPControl |
GetWidth() const | CXTPControl |
GetWrap() const | CXTPControl |
HasDwmCompositedRect() const | CXTPControl |
IsCaptionVisible() const | CXTPControl | virtual
IsCursorOver() const | CXTPControl |
IsCustomizeMode() const | CXTPControl | protected
IsCustomizeMovable() const | CXTPControl | virtual
IsCustomizeResizeAllow() const | CXTPControl | protectedvirtual
IsFocusable() const | CXTPControl | protectedvirtual
IsFocused() const | CXTPControl | virtual
IsItemDefault() const | CXTPControl |
IsLayoutChanged() | CXTPControl | protected
IsLayoutRTL() const | CXTPControl | protected
IsOnQuickAccess() const | CXTPControl |
IsTemporary() const | CXTPControl |
IsTransparent() const | CXTPControl | inlinevirtual
IsVisible(DWORD dwSkipFlags=0) const | CXTPControl | virtual
m_bBeginGroup | CXTPControl | protected
m_bChecked | CXTPControl | protected
m_bCloseSubMenuOnClick | CXTPControl | protected
m_bDefaultItem | CXTPControl | protected
m_bEnabled | CXTPControl | protected
m_bExpanded | CXTPControl | protected
m_bLayoutRTL | CXTPControl | protected
m_bOnQuickAccess | CXTPControl | protected
m_bPressed | CXTPControl | protected
m_bSelected | CXTPControl | protected
m_bTemporary | CXTPControl | protected
m_buttonCustomStyle | CXTPControl | protected
m_buttonRibbonStyle | CXTPControl | protected
m_buttonStyle | CXTPControl | protected
m_bWrap | CXTPControl | protected
m_controlType | CXTPControl | protected
m_dwFlags | CXTPControl | protected
m_dwHideFlags | CXTPControl | protected
m_mapDocTemplatesAssigned | CXTPControl | protected
m_mapDocTemplatesExcluded | CXTPControl | protected
m_nCustomIconId | CXTPControl | protected
m_nExecuteOnPressInterval | CXTPControl | protected
m_nHeight | CXTPControl | protected
m_nHelpId | CXTPControl | protected
m_nIconId | CXTPControl | protected
m_nId | CXTPControl | protected
m_nIndex | CXTPControl | protected
m_nTag | CXTPControl | protected
m_nWidth | CXTPControl | protected
m_pAction | CXTPControl | protected
m_pControls | CXTPControl | protected
m_pParent | CXTPControl | protected
m_pRibbonGroup | CXTPControl | protected
m_rcControl | CXTPControl | protected
m_rcRow | CXTPControl | protected
m_strCaption | CXTPControl | protected
m_strCategory | CXTPControl | protected
m_strCustomCaption | CXTPControl | protected
m_strDescriptionText | CXTPControl | protected
m_strKeyboardTip | CXTPControl | protected
m_strParameter | CXTPControl | protected
m_strShortcutText | CXTPControl | protected
m_strShortcutTextAuto | CXTPControl | protected
m_strTooltipText | CXTPControl | protected
m_szIcon | CXTPControl | protected
NotifySite(UINT code) | CXTPControl |
NotifySite(UINT code, NMXTPCONTROL *pNM) | CXTPControl |
NotifySite(CWnd *pSite, UINT code, NMXTPCONTROL *pNM) | CXTPControl |
OnActionChanged(int nProperty) | CXTPControl | protectedvirtual
OnActionChanging(int nProperty) | CXTPControl | protectedvirtual
OnCalcDynamicSize(DWORD dwMode) | CXTPControl | virtual
OnCaptionChanged() | CXTPControl | protectedvirtual
OnClick(BOOL bKeyboard=FALSE, CPoint pt=CPoint(0, 0)) | CXTPControl | virtual
OnCustomizeDragOver(CXTPControl *pDataObject, CPoint point, DROPEFFECT &dropEffect) | CXTPControl | protectedvirtual
OnCustomizeMouseMove(CPoint point) | CXTPControl | protected
OnEnabledChanged() | CXTPControl | virtual
OnExecute() | CXTPControl | virtual
OnHookKeyDown(UINT nChar, LPARAM lParam) | CXTPControl | protectedvirtual
OnHookMouseWheel(UINT nFlags, short zDelta, CPoint point) | CXTPControl | protectedvirtual
OnIdleUpdate() | CXTPControl | protectedvirtual
OnLButtonDblClk(CPoint point) | CXTPControl | protectedvirtual
OnLButtonDown(CPoint point) | CXTPControl | protectedvirtual
OnLButtonUp(CPoint point) | CXTPControl | protectedvirtual
OnMouseHover() | CXTPControl | protectedvirtual
OnMouseMove(CPoint point) | CXTPControl | protectedvirtual
OnRButtonDown(CPoint point) | CXTPControl | protectedvirtual
OnRButtonUp(CPoint point) | CXTPControl | protectedvirtual
OnRemoved() | CXTPControl | protectedvirtual
OnSetPopup(BOOL bPopup) | CXTPControl | protectedvirtual
OnSetSelected(int bSelected) | CXTPControl | protectedvirtual
OnThemeChanged() | CXTPControl | virtual
OnToolHitTest(CPoint point, TOOLINFO *pTI) const | CXTPControl | protectedvirtual
OnUnderlineActivate() | CXTPControl | virtual
RedrawParent(BOOL bAnimate=TRUE) | CXTPControl |
Reset() | CXTPControl |
RestoreCommandBarList(CXTPCommandBarList *pCommandBarList) | CXTPControl | protectedvirtual
ScreenToClient(CPoint *point) | CXTPControl | protected
SetAction(CXTPControlAction *pAction) | CXTPControl | virtual
SetBeginGroup(BOOL bBeginGroup) | CXTPControl | virtual
SetCaption(LPCTSTR lpszCaption) | CXTPControl |
SetCaption(UINT nIDCaption) | CXTPControl |
SetCategory(LPCTSTR lpszCategory) | CXTPControl |
SetChecked(BOOL bChecked) | CXTPControl | virtual
SetCloseSubMenuOnClick(BOOL bCloseOnClick) | CXTPControl |
SetCustomIcon(HICON hIcon) | CXTPControl |
SetCustomShortcutText(LPCTSTR lpszCustomShortcutText) | CXTPControl |
SetDescription(LPCTSTR lpszDescription) | CXTPControl |
SetEnabled(BOOL bEnabled) | CXTPControl | virtual
SetExecuteOnPressInterval(int nExecuteOnPressInterval) | CXTPControl |
SetExpanded(BOOL bExpanded) | CXTPControl | protected
SetFlags(DWORD dwFlags) | CXTPControl |
SetFocused(BOOL bFocused) | CXTPControl | virtual
SetHeight(int nHeight) | CXTPControl | virtual
SetHelpId(int nId) | CXTPControl |
SetHideFlag(XTPControlHideFlags dwFlag, BOOL bSet) | CXTPControl |
SetHideFlags(DWORD dwFlags) | CXTPControl | virtual
SetHideWrap(BOOL bHide) | CXTPControl |
SetIconId(int nId) | CXTPControl |
SetIconSize(CSize szIcon) | CXTPControl |
SetID(int nId) | CXTPControl |
SetIndex(int nIndex) | CXTPControl | inlineprotected
SetItemDefault(BOOL bDefault) | CXTPControl |
SetKeyboardTip(LPCTSTR lpszKeyboardTip) | CXTPControl |
SetOnQuickAccess(BOOL bOnQuicAccess=FALSE) | CXTPControl |
SetParameter(LPCTSTR lpszParameter) | CXTPControl |
SetParent(CXTPCommandBar *pParent) | CXTPControl | inlineprotectedvirtual
SetPressed(BOOL bPressed) | CXTPControl |
SetPrompt(LPCTSTR lpszPrompt) | CXTPControl |
SetRect(CRect rcControl) | CXTPControl | virtual
SetRowRect(CRect rcRow) | CXTPControl |
SetShortcutText(LPCTSTR lpszShortcutText) | CXTPControl |
SetStyle(XTPButtonStyle buttonStyle) | CXTPControl |
SetTag(DWORD_PTR dwTag) | CXTPControl |
SetTooltip(LPCTSTR lpszTooltip) | CXTPControl |
SetVisible(BOOL bVisible) | CXTPControl |
SetWidth(int nWidth) | CXTPControl | virtual
SetWrap(BOOL bWrap) | CXTPControl |
~CXTPControl() | CXTPControl | protectedvirtual


Toolkit Pro: XTPCalendarCaptionBarOfficeXPTheme.h Source File

  • Source
  • Calendar
  • CaptionBar
  • Themes
XTPCalendarCaptionBarOfficeXPTheme.h
Go to the documentation of this file.
1
22#if !defined(__XTPCALENDARCAPTIONBAROFFICEXPTHEME_H__)
23# define __XTPCALENDARCAPTIONBAROFFICEXPTHEME_H__
24
25# if _MSC_VER > 1000
26# pragma once
27# endif // _MSC_VER > 1000
28
29# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
30
36class _XTP_EXT_CLASS CXTPCalendarCaptionBarOfficeXPTheme
37 : public CXTPCalendarCaptionBarOffice2000Theme
38{
39public:
48 CXTPCalendarCaptionBarOfficeXPTheme(CXTPCalendarCaptionBarTheme* pTheme = NULL);
49
56 virtual ~CXTPCalendarCaptionBarOfficeXPTheme();
57
63 virtual void RefreshMetrics();
64
65 virtual void PartDraw(CXTPRadioButtonPart* pBarPart, CDC* pDC);
66 virtual void PartDraw(CXTPCheckboxButtonPart* pBarPart, CDC* pDC);
67};
68
69# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
70#endif // !defined(__XTPCALENDARCAPTIONBAROFFICEXPTHEME_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCalendarCaptionBarOffice2000Theme
CXTPCalendarCaptionBarOffice2000Theme is a CXTPCalendarCaptionBarPaintManager derived class thatrepre...
Definition XTPCalendarCaptionBarOffice2000Theme.h:38
CXTPCalendarCaptionBarOfficeXPTheme
CXTPCalendarCaptionBarOfficeXPTheme is a CXTPCalendarCaptionBarOffice2000Theme derived class that rep...
Definition XTPCalendarCaptionBarOfficeXPTheme.h:38
CXTPCalendarCaptionBarOfficeXPTheme::CXTPCalendarCaptionBarOfficeXPTheme
CXTPCalendarCaptionBarOfficeXPTheme(CXTPCalendarCaptionBarTheme *pTheme=NULL)
Default paint manager constructor.
CXTPCalendarCaptionBarOfficeXPTheme::~CXTPCalendarCaptionBarOfficeXPTheme
virtual ~CXTPCalendarCaptionBarOfficeXPTheme()
Default paint manager destructor.
CXTPCalendarCaptionBarOfficeXPTheme::RefreshMetrics
virtual void RefreshMetrics()
Performs refreshing of graphical related parameters from system settings.
CXTPCalendarCaptionBarTheme
This class CalendarCaptionBar control drawing, user interaction logic and interaction logic with atta...
Definition XTPCalendarCaptionBarTheme.h:48
CXTPCheckboxButtonPart
This class implements Checkbox button part of the SwitchViewBar.
Definition XTPCalendarCaptionBarThemePart.h:367
CXTPRadioButtonPart
This class implements Radio button part of the SwitchViewBar.
Definition XTPCalendarCaptionBarThemePart.h:350


Toolkit Pro: Member List

CXTPChartRadarSplineSeriesView Member List

This is the complete list of members for CXTPChartRadarSplineSeriesView, including all inherited members.

AddChildView(CXTPChartElementView *pChildView) | CXTPChartElementView |
CreateDeviceCommand(CXTPChartDeviceContext *pDC) | CXTPChartRadarSplineSeriesView | protectedvirtual
CreateLegendDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcBounds) | CXTPChartRadarLineSeriesView | protectedvirtual
CreateSeriesPointView(CXTPChartDeviceContext *pDC, CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView) | CXTPChartRadarSplineSeriesView | protected
CXTPChartElementView(CXTPChartElementView *pParentView) | CXTPChartElementView |
CXTPChartElementView(CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartElementView |
CXTPChartElementView(CXTPChartContainer *pContainer) | CXTPChartElementView |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartRadarLineSeriesView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView) | CXTPChartRadarLineSeriesView |
CXTPChartRadarSplineSeriesView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView) | CXTPChartRadarSplineSeriesView |
GetAt(int nIndex) const | CXTPChartElementView |
GetBounds() const | CXTPChartElementView |
GetBounds(BOOL bIncludingChildren) const | CXTPChartElementView |
GetChildren() | CXTPChartElementView |
GetCount() const | CXTPChartElementView |
GetParentView() const | CXTPChartElementView |
Is3D() const | CXTPChartObject |
m_arrChildren | CXTPChartElementView | protected
m_pContainer | CXTPChartElementView | protected
m_pParentView | CXTPChartElementView | protected
m_rcBounds | CXTPChartElementView | protected
~CXTPChartElementView() | CXTPChartElementView | protectedvirtual
~CXTPChartLegendItemView() | CXTPChartLegendItemView | inlinevirtual


Toolkit Pro: XTPChart2dFunnelSeriesPointView.h Source File

  • Source
  • Chart
  • Styles
  • Funnel
  • 2D
XTPChart2dFunnelSeriesPointView.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHART2DFUNNELSERIESPOINTVIEW_H__)
24# define __XTPCHART2DFUNNELSERIESPOINTVIEW_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartSeriesPoint;
34class CXTPChartElementView;
35class CXTPChartDeviceContext;
36
48class _XTP_EXT_CLASS CXTPChartFunnelSeriesPointView : public CXTPChartFunnelSeriesPointViewBase
49{
50 DECLARE_DYNAMIC(CXTPChartFunnelSeriesPointView);
51
52public:
60 CXTPChartFunnelSeriesPointView(CXTPChartSeriesPoint* pPoint, CXTPChartElementView* pParentView);
61
70 CXTPChartFunnelSeriesPointView(CXTPChartSeriesPoint* pPoint, CXTPChartElementView* pParentView,
71 BOOL bAddToParent);
72
73protected:
86 virtual CXTPChartDeviceCommand* CreateDeviceCommand(CXTPChartDeviceContext* pDC);
87};
89# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
90#endif //#if !defined(__XTPCHART2DFUNNELSERIESPOINTVIEW_H__)
pPoint
const CPoint * pPoint
return 0 or xtpCalendarHitTestDayExpandButton
Definition XTPCalendarThemeOffice2007.h:150
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartElementView
This class represents the view of a chart element.
Definition XTPChartElementView.h:47
CXTPChartFunnelSeriesPointViewBase
This class abstracts the view of a funnel series point.
Definition XTPChartFunnelSeriesPointViewBase.h:50
CXTPChartFunnelSeriesPointView
This class abstracts the view of a funnel series point.
Definition XTPChart2dFunnelSeriesPointView.h:49
CXTPChartFunnelSeriesPointView::CXTPChartFunnelSeriesPointView
CXTPChartFunnelSeriesPointView(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView, BOOL bAddToParent)
Constructs a CXTPChartFunnelSeriesPointView object.
CXTPChartFunnelSeriesPointView::CreateDeviceCommand
virtual CXTPChartDeviceCommand * CreateDeviceCommand(CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
CXTPChartFunnelSeriesPointView::CXTPChartFunnelSeriesPointView
CXTPChartFunnelSeriesPointView(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Constructs a CXTPChartFunnelSeriesPointView object.
CXTPChartSeriesPoint
CXTPChartSeriesPoint is a kind of CXTPChartElement.
Definition XTPChartSeriesPoint.h:43


Toolkit Pro: Member List

CXTPResizePropertyPage Member List

This is the complete list of members for CXTPResizePropertyPage, including all inherited members.

AdjustResizeRect(CSize &rcWindow) | CXTPResize | protectedvirtual
AutoLoadPlacement(LPCTSTR pszSection) | CXTPResize |
CResizeItemArray typedef | CXTPResize | protected
CXTPResize(CWnd *pWnd, const UINT nFlags=0) | CXTPResize |
CXTPResizePropertyPage(const UINT nTemplate=0, const UINT nCaption=0, const UINT nFlags=0) | CXTPResizePropertyPage |
Defer(HDWP &hdwp, CXTPResizeItem *pItem, int dx, int dy) | CXTPResize | protectedvirtual
GetMinMaxInfo(MINMAXINFO *pMMI) | CXTPResize | protected
HasFlag(XTPResize eFlag) | CXTPResize | protected
Init() | CXTPResize | protectedvirtual
LoadPlacement(LPCTSTR pszSection) | CXTPResize |
m_arrItems | CXTPResize | protected
m_nDialogID | CXTPResizePropertyPage |
m_nFlagsXX | CXTPResize | protected
m_pWnd | CXTPResize | protected
m_scSizeIcon | CXTPResize | protected
m_strSection | CXTPResize | protected
m_szInitWindow | CXTPResize | protected
m_szMax | CXTPResize | protected
m_szMin | CXTPResize | protected
m_szWindow | CXTPResize | protected
Offset(CPoint ptOffset) | CXTPResize | protected
RemoveAllControls() | CXTPResize | protected
RemoveResize(UINT nID) | CXTPResize | protected
Reset() | CXTPResize | protected
SavePlacement(LPCTSTR pszSection) | CXTPResize |
SetFlag(XTPResize eFlag) | CXTPResize | protected
SetMaxSize(CSize &sz) | CXTPResize |
SetMinSize(CSize &sz) | CXTPResize |
SetResize(UINT nID, XTP_RESIZE left, XTP_RESIZE top, XTP_RESIZE right, XTP_RESIZE bottom) | CXTPResize |
SetResize(UINT nID, const XTP_RESIZERECT &rrcSizing) | CXTPResize |
SetResize(UINT nID, HWND hWnd, const XTP_RESIZERECT &rrcSizing) | CXTPResize |
SetResize(UINT nID, HWND hWnd, const XTP_RESIZEPOINT &rpTopLeft, const XTP_RESIZEPOINT &rpBottomRight) | CXTPResize |
SetResize(UINT nID, const XTP_RESIZEPOINT &rpTopLeft, const XTP_RESIZEPOINT &rpBottomRight) | CXTPResize |
SetResize(CWnd *pWnd, const CXTPResizeRect &rrcSizing, CRect rcWindow) | CXTPResize | protected
Size() | CXTPResize | protectedvirtual
UpdateControlRect(CWnd *pWnd) | CXTPResize | protected
~CXTPResize() | CXTPResize | virtual


Toolkit Pro: Member List

CXTPRibbonMarkupFrameTheme Member List

This is the complete list of members for CXTPRibbonMarkupFrameTheme, including all inherited members.

CalcFrameBorder(const CXTPCommandBarsFrameHook *pFrameHook) const | CXTPFramePaintManager | virtual
CalcFrameCaption(const CXTPCommandBarsFrameHook *pFrameHook) const | CXTPFramePaintManager | virtual
CalcFrameRegion(CXTPCommandBarsFrameHook *pFrameHook, CSize sz) const =0 | CXTPFramePaintManager | pure virtual
CreateShadow(CWnd *pFrame) | CXTPFramePaintManager | virtual
CXTPFramePaintManager(CXTPPaintManager *pPaintManager) | CXTPFramePaintManager |
CXTPRibbonMarkupFrameTheme(CXTPPaintManager *pPaintManager) | CXTPRibbonMarkupFrameTheme |
DrawCaptionBar(CDC *pDC, CRect rcCaptionBar, CWnd *pSite, BOOL bActive) | CXTPFramePaintManager | virtual
DrawCaptionText(CDC *pDC, CRect rcCaptionText, CWnd *pSite, BOOL bActive) | CXTPFramePaintManager | virtual
DrawCaptionText(CDC *pDC, CRect rcCaptionText, CWnd *pSite, BOOL bActive, CXTPRibbonBar *pRibbonBar) | CXTPFramePaintManager | virtual
DrawFrame(CDC *pDC, CXTPCommandBarsFrameHook *pFrameHook) | CXTPRibbonMarkupFrameTheme | virtual
DrawFrameBorder(CDC *pDC, CXTPCommandBarsFrameHook *pFrameHook) | CXTPRibbonMarkupFrameTheme | virtual
DrawFrameCaptionButton(CDC *pDC, CRect rc, int nId, BOOL bSelected, BOOL bPressed, BOOL bActive)=0 | CXTPFramePaintManager | pure virtual
DrawFrameCaptionButton(CDC *pDC, CRect rc, int nId, BOOL bSelected, BOOL bPressed, BOOL bActive, CXTPRibbonBar *pRibbonBar)=0 | CXTPFramePaintManager | pure virtual
GetFrameBorder(int nId, BOOL bActive)=0 | CXTPRibbonMarkupFrameTheme | protectedpure virtual
GetFrameCaptionAccentTextColor(BOOL bActive) const | CXTPFramePaintManager | virtual
GetFrameCaptionActiveColor() const | CXTPFramePaintManager |
GetFrameCaptionHeight() const | CXTPFramePaintManager | virtual
GetFrameLargeIcon(CWnd *pFrame) | CXTPFramePaintManager |
GetFrameSmallIcon(CWnd *pFrame) | CXTPFramePaintManager |
GetImages() const | CXTPFramePaintManager |
IsUseSystemAccentColorEnabled() const | CXTPFramePaintManager |
LoadImage(LPCTSTR lpszFileName) | CXTPFramePaintManager |
LoadParts(HZIP hZip, CXTPMarkupContext *pMarkupContext)=0 | CXTPRibbonMarkupFrameTheme | protectedpure virtual
LoadParts(BOOL bReload=FALSE)=0 | CXTPRibbonMarkupFrameTheme | protectedpure virtual
m_bCaptionCenterAligned | CXTPFramePaintManager |
m_bFlatFrame | CXTPFramePaintManager |
m_bFrameStatusBar | CXTPFramePaintManager |
m_bMarkupPartsLoaded | CXTPRibbonMarkupFrameTheme | protected
m_clrFrameCaptionActive | CXTPFramePaintManager | protected
m_clrFrameCaptionInactive | CXTPFramePaintManager | protected
m_clrFrameCaptionTextActive | CXTPFramePaintManager | protected
m_clrFrameCaptionTextActiveBSMode | CXTPFramePaintManager | protected
m_clrFrameCaptionTextActiveTitle | CXTPFramePaintManager | protected
m_clrFrameCaptionTextActiveTitleBSMode | CXTPFramePaintManager | protected
m_clrFrameCaptionTextInactive | CXTPFramePaintManager | protected
m_clrFrameCaptionTextInactiveBSMode | CXTPFramePaintManager | protected
m_fntFrameCaption | CXTPFramePaintManager |
m_hIcon | CXTPFramePaintManager | protected
m_nFrameCaptionHeight | CXTPFramePaintManager |
m_pPaintManager | CXTPFramePaintManager |
m_rcIconMargin | CXTPFramePaintManager | protected
m_szIcon | CXTPFramePaintManager | protected
OnShadowedFrameActiveStateChanged(BOOL bActive, CWnd *pFrame, CXTPFrameShadow *pShadow) | CXTPFramePaintManager | virtual
RefreshMetrics() | CXTPFramePaintManager | virtual
ReloadMarkupParts(HZIP hZip, CXTPMarkupContext *pMarkupContext) | CXTPRibbonMarkupFrameTheme |
SetIcon(HICON hIcon, CSize szIcon) | CXTPFramePaintManager |
XTPBorderPart enum name | CXTPRibbonMarkupFrameTheme | protected
xtpBorderPartBottom enum value | CXTPRibbonMarkupFrameTheme | protected
xtpBorderPartCount enum value | CXTPRibbonMarkupFrameTheme | protected
xtpBorderPartLeft enum value | CXTPRibbonMarkupFrameTheme | protected
xtpBorderPartLeftCaption enum value | CXTPRibbonMarkupFrameTheme | protected
xtpBorderPartRight enum value | CXTPRibbonMarkupFrameTheme | protected
xtpBorderPartRightCaption enum value | CXTPRibbonMarkupFrameTheme | protected
xtpBorderPartTop enum value | CXTPRibbonMarkupFrameTheme | protected
~CXTPFramePaintManager() | CXTPFramePaintManager | virtual
~CXTPRibbonMarkupFrameTheme() | CXTPRibbonMarkupFrameTheme | virtual


Toolkit Pro: XTPMarkupContentControl.h Source File

  • Source
  • Markup
  • Controls
XTPMarkupContentControl.h
Go to the documentation of this file.
1
23#if !defined(__XTPMARKUPCONTENTCONTROL_H__)
24# define __XTPMARKUPCONTENTCONTROL_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPMarkupDependencyProperty;
34class CXTPMarkupUIElement;
35class CXTPMarkupVisual;
36class CXTPMarkupBuilder;
37class CXTPMarkupObject;
38
44class _XTP_EXT_CLASS CXTPMarkupContentControl : public CXTPMarkupControl
45{
47 DECLARE_MARKUPCLASS(CXTPMarkupContentControl);
49protected:
54 CXTPMarkupContentControl();
55
60 virtual ~CXTPMarkupContentControl();
61
62public:
71 CXTPMarkupUIElement* GetContent() const;
72
80 void SetContent(CXTPMarkupUIElement* pContent);
81
82protected:
84 // Implementation
85 virtual void SetContentObject(CXTPMarkupBuilder* pBuilder, CXTPMarkupObject* pContent);
86 virtual BOOL HasContentObject() const;
87
88public:
89 virtual int GetVisualChildrenCount() const;
90 virtual CXTPMarkupVisual* GetVisualChild(int nIndex) const;
91
92protected:
93 static CXTPMarkupDependencyProperty* m_pContentProperty;
97public:
98 DECLARE_DISPATCH_MAP()
99# ifdef _XTP_ACTIVEX
100 DECLARE_INTERFACE_MAP()
101 DECLARE_OLETYPELIB_EX(CXTPMarkupContentControl);
102# endif
103
104 afx_msg LPDISPATCH OleGetContent();
105 afx_msg void OleSetContent(LPDISPATCH lpContent);
107};
109AFX_INLINE int CXTPMarkupContentControl::GetVisualChildrenCount() const
110{
111 return GetContent() != NULL ? 1 : 0;
112}
113
114AFX_INLINE CXTPMarkupVisual* CXTPMarkupContentControl::GetVisualChild(int nIndex) const
115{
116 return nIndex == 0 ? GetContent() : NULL;
117}
119# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
121#endif // !defined(__XTPMARKUPCONTENTCONTROL_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPMarkupContentControl
CXTPMarkupContentControl is a CXTPMarkupControl derived class.
Definition XTPMarkupContentControl.h:45
CXTPMarkupContentControl::CXTPMarkupContentControl
CXTPMarkupContentControl()
Constructs a CXTPMarkupContentControl object.
CXTPMarkupContentControl::GetContent
CXTPMarkupUIElement * GetContent() const
Gets the child object of the ControlContent element.
CXTPMarkupContentControl::SetContent
void SetContent(CXTPMarkupUIElement *pContent)
Sets the child object for the ControlContent element.
CXTPMarkupContentControl::~CXTPMarkupContentControl
virtual ~CXTPMarkupContentControl()
Destroys a CXTPMarkupContentControl object, handles cleanup and deallocation.
CXTPMarkupControl
CXTPMarkupControl is a CXTPMarkupFrameworkElement derived class.
Definition XTPMarkupControl.h:44
CXTPMarkupUIElement
Base class for XML Markup core level implementations.
Definition XTPMarkupUIElement.h:43
CXTPMarkupVisual
Provides rendering support for XML Markup, which includes hit testing, coordinate transformation,...
Definition XTPMarkupInputElement.h:223
CXTPMarkupVisual::GetVisualChild
virtual CXTPMarkupVisual * GetVisualChild(int nIndex) const
Retrieves the child Visual object located at a specified index within the parent VisualCollection.
CXTPMarkupVisual::GetVisualChildrenCount
virtual int GetVisualChildrenCount() const
Gets the number of child elements for the Visual.


Toolkit Pro: Member List

CXTPGridTip Member List

This is the complete list of members for CXTPGridTip, including all inherited members.

Activate(BOOL bActive, BOOL bMultiline) | CXTPGridTip |
Create(CWnd *pParentWnd) | CXTPGridTip | virtual
CXTPGridTip() | CXTPGridTip |
GetHoverRect() const | CXTPGridTip |
GetTooltipRect() const | CXTPGridTip |
GetTooltipText() const | CXTPGridTip |
IsMultilineForce() const | CXTPGridTip |
m_bMultiline | CXTPGridTip | protected
m_nRowIndex | CXTPGridTip | protected
m_pGridControl | CXTPGridTip | protected
m_pItem | CXTPGridTip | protected
m_pParentWnd | CXTPGridTip | protected
m_rcHover | CXTPGridTip | protected
m_rcTooltip | CXTPGridTip | protected
m_strTooltipText | CXTPGridTip | protected
m_xtpFontToolTip | CXTPGridTip | protected
SetFont(CFont *pFont) | CXTPGridTip |
SetHoverRect(CRect rc) | CXTPGridTip |
SetTooltipRect(CRect rc) | CXTPGridTip |
SetTooltipText(LPCTSTR str) | CXTPGridTip |
~CXTPGridTip() | CXTPGridTip | virtual


Toolkit Pro: Member List

CXTPPropExchange Member List

This is the complete list of members for CXTPPropExchange, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPPropExchange() | CXTPPropExchange |
EmptySection() | CXTPPropExchange | virtual
ExchangeBlobProp(LPCTSTR pszPropName, BYTE *&pData, DWORD &nBytes) | CXTPPropExchange | virtual
ExchangeLocale() | CXTPPropExchange |
ExchangeObjectInstance(CObject *&pObject, CRuntimeClass *pObjectRuntime) | CXTPPropExchange | virtual
ExchangeProp(LPCTSTR pszPropName, VARTYPE vtProp, void *pvProp, const void *pvDefault=NULL)=0 | CXTPPropExchange | pure virtual
ExchangeRuntimeClass(LPCTSTR pszPropName, CRuntimeClass *&pClass, CRuntimeClass *pDefaultClass) | CXTPPropExchange | virtual
ExchangeSchema() | CXTPPropExchange |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetArchive(LPCTSTR pszPropName) | CXTPPropExchange | virtual
GetEnumerator(LPCTSTR lpszSection) | CXTPPropExchange | virtual
GetSchema() const | CXTPPropExchange |
GetSection(LPCTSTR lpszSection)=0 | CXTPPropExchange | pure virtual
InitSection(CXTPPropExchange *pRootSection) | CXTPPropExchange | protected
IsAllowBlobValues() const | CXTPPropExchange | virtual
IsAllowDefaultValues() const | CXTPPropExchange | virtual
IsLoading() const | CXTPPropExchange |
IsRootSection() const | CXTPPropExchange |
IsStoring() const | CXTPPropExchange |
m_bChildSection | CXTPPropExchange | protected
m_bEmptySection | CXTPPropExchange | protected
m_bInitialized | CXTPPropExchange | protected
m_bLoading | CXTPPropExchange | protected
m_bUseDefaultOnLoad | CXTPPropExchange | protected
m_bUseDefaultOnSave | CXTPPropExchange | protected
m_dwData | CXTPPropExchange |
m_lcidDateTime | CXTPPropExchange | static
m_nSchema | CXTPPropExchange | protected
m_pOwner | CXTPPropExchange |
OnBeforeExchange() | CXTPPropExchange | virtual
Read(LPCTSTR pszPropName, void *lpBuf, UINT nCount) | CXTPPropExchange | virtual
ReadCount() | CXTPPropExchange | virtual
ReleaseArchive(LPCTSTR pszPropName, CArchive *pArchive) | CXTPPropExchange | virtual
SetSchema(UINT nSchemaVersion) | CXTPPropExchange |
UseDefaultOnLoad(BOOL bUseDefaultOnLoad=TRUE) | CXTPPropExchange |
UseDefaultOnSave(BOOL bUseDefaultOnSave=TRUE) | CXTPPropExchange |
Write(LPCTSTR pszPropName, const void *lpBuf, UINT nCount) | CXTPPropExchange | virtual
WriteCount(DWORD dwCount) | CXTPPropExchange | virtual
~CXTPPropExchange() | CXTPPropExchange | virtual


Toolkit Pro: XTPStatusBarThemeVisualStudio2010.h Source File

  • Source
  • CommandBars
  • StatusBar
XTPStatusBarThemeVisualStudio2010.h
Go to the documentation of this file.
1
23#if !defined(__XTPSTATUSBARTHEMEVISUALSTUDIO2010_H__)
24# define __XTPSTATUSBARTHEMEVISUALSTUDIO2010_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class _XTP_EXT_CLASS CXTPStatusBarThemeVisualStudio2010 : public CXTPStatusBarPaintManager
34{
35public:
36 CXTPStatusBarThemeVisualStudio2010(CXTPPaintManager* pPaintManager);
37
44 virtual void FillStatusBar(CDC* pDC, CXTPStatusBar* pBar);
45
52 virtual void DrawStatusBarGripper(CDC* pDC, CRect rcClient);
53
54 virtual void RefreshMetrics();
55};
56
58# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
59#endif // !defined(__XTPSTATUSBARTHEMEVISUALSTUDIO2010_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPPaintManager
Paint manager of the command bars.
Definition XTPPaintManager.h:199
CXTPStatusBar
CXTPStatusBar is a CControlBar derived class.
Definition XTPStatusBar.h:52


Toolkit Pro: XTPCommandBarsVisualStudio2015Theme.h Source File

  • Source
  • CommandBars
  • Themes
XTPCommandBarsVisualStudio2015Theme.h
Go to the documentation of this file.
1
23#if !defined(__XTPCOMMANDBARSVISUALSTUDIO2015THEME_H__)
24# define __XTPCOMMANDBARSVISUALSTUDIO2015THEME_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
40class _XTP_EXT_CLASS CXTPCommandBarsVisualStudio2015Theme : public CXTPCommandBarsOffice2013Theme
41{
43 DECLARE_DYNAMIC(CXTPCommandBarsVisualStudio2015Theme)
45public:
50 CXTPCommandBarsVisualStudio2015Theme();
51
57 virtual ~CXTPCommandBarsVisualStudio2015Theme();
58
66 virtual void SetStateColor(COLORREF clrState = COLORREF_NULL);
67
75 virtual COLORREF GetStateColor() const;
76
77protected:
86 virtual void DrawSplitButtonFrame(CDC* pDC, CXTPControl* pButton, CRect rc);
87
101 virtual void DrawRectangle(CDC* pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled,
102 BOOL bChecked, BOOL bPopuped, XTPBarType barType,
103 XTPBarPosition barPosition);
104
119 virtual void DrawRectangle(CDC* pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled,
120 BOOL bChecked, BOOL bPopuped, XTPBarType barType,
121 XTPBarPosition barPosition, int nID);
130 virtual BOOL DrawRectangle(CDC* pDC, CXTPControl* pButton);
131
138 virtual COLORREF GetControlTextColor(CXTPControl* pButton);
139
151 virtual void DrawGalleryItemBack(CDC* pDC, CRect rcItem, BOOL bEnabled, BOOL bSelected,
152 BOOL bPressed, BOOL bChecked, XTPBarType barType);
153
163 virtual void DrawCheckRect(CDC* pDC, CRect rc, COLORREF clrFore, COLORREF clrBack);
164
174 virtual CSize DrawCommandBarGripper(CDC* pDC, CXTPCommandBar* pBar, BOOL bDraw = TRUE);
175
185 virtual CSize DrawControlComboBox(CDC* pDC, CXTPControlComboBox* pComboBox, BOOL bDraw);
186};
187
205_XTP_EXT_CLASS BOOL AFX_CDECL XTPSetVSStateColor(CXTPCommandBars* pCommandBars,
206 COLORREF clrState = COLORREF_NULL);
207
209# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
210#endif // !defined(__XTPCOMMANDBARSVISUALSTUDIO2015THEME_H__)
XTPBarType
XTPBarType
Type of the command bar.
Definition XTPCommandBarsDefines.h:77
XTPBarPosition
XTPBarPosition
Position of the command bar.
Definition XTPCommandBarsDefines.h:52
XTPSetVSStateColor
_XTP_EXT_CLASS BOOL AFX_CDECL XTPSetVSStateColor(CXTPCommandBars *pCommandBars, COLORREF clrState=COLORREF_NULL)
Call XTPSetVSStateColor to set the border and status bar colors for this theme to indicate state chan...
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCommandBar
CXTPCommandBar is a CWnd derived class.
Definition XTPCommandBar.h:66
CXTPCommandBars
CXTPCommandBars is a standalone class.
Definition XTPCommandBars.h:165
CXTPCommandBarsOffice2013Theme
The CXTPCommandBarsOffice2013Theme class is used to enable an Office 2013 style theme for Command Bar...
Definition XTPCommandBarsOffice2013Theme.h:63
CXTPCommandBarsVisualStudio2015Theme
The CXTPCommandBarsVisualStudio2015Theme class is used to enable a Visual Studio 2015 style theme for...
Definition XTPCommandBarsVisualStudio2015Theme.h:41
CXTPCommandBarsVisualStudio2015Theme::DrawCheckRect
virtual void DrawCheckRect(CDC *pDC, CRect rc, COLORREF clrFore, COLORREF clrBack)
Helper class called by DrawRectangle to render a checkmark background and border.
CXTPCommandBarsVisualStudio2015Theme::DrawCommandBarGripper
virtual CSize DrawCommandBarGripper(CDC *pDC, CXTPCommandBar *pBar, BOOL bDraw=TRUE)
This method is called to draw the command bar's gripper.
CXTPCommandBarsVisualStudio2015Theme::DrawControlComboBox
virtual CSize DrawControlComboBox(CDC *pDC, CXTPControlComboBox *pComboBox, BOOL bDraw)
This method is called to draw the control.
CXTPCommandBarsVisualStudio2015Theme::DrawSplitButtonFrame
virtual void DrawSplitButtonFrame(CDC *pDC, CXTPControl *pButton, CRect rc)
This method is called to draw the frame for the SplitButton control.
CXTPCommandBarsVisualStudio2015Theme::DrawGalleryItemBack
virtual void DrawGalleryItemBack(CDC *pDC, CRect rcItem, BOOL bEnabled, BOOL bSelected, BOOL bPressed, BOOL bChecked, XTPBarType barType)
This method is called to draw the background for a gallery menu item.
CXTPCommandBarsVisualStudio2015Theme::~CXTPCommandBarsVisualStudio2015Theme
virtual ~CXTPCommandBarsVisualStudio2015Theme()
Destroys a CXTPCommandBarsVisualStudio2015Theme object, handles cleanup and deallocation.
CXTPCommandBarsVisualStudio2015Theme::SetStateColor
virtual void SetStateColor(COLORREF clrState=COLORREF_NULL)
Call this member function to set the application state color for the frame border and status bar.
CXTPCommandBarsVisualStudio2015Theme::DrawRectangle
virtual BOOL DrawRectangle(CDC *pDC, CXTPControl *pButton)
This method is called to fill the control's face.
CXTPCommandBarsVisualStudio2015Theme::CXTPCommandBarsVisualStudio2015Theme
CXTPCommandBarsVisualStudio2015Theme()
Constructs a CXTPCommandBarsVisualStudio2015Theme object.
CXTPCommandBarsVisualStudio2015Theme::GetControlTextColor
virtual COLORREF GetControlTextColor(CXTPControl *pButton)
This method returns the control text color to draw.
CXTPCommandBarsVisualStudio2015Theme::GetStateColor
virtual COLORREF GetStateColor() const
Call this member function to get the application state color for the frame border and status bar.
CXTPCommandBarsVisualStudio2015Theme::DrawRectangle
virtual void DrawRectangle(CDC *pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition)
This method is called to fill the control's face.
CXTPCommandBarsVisualStudio2015Theme::DrawRectangle
virtual void DrawRectangle(CDC *pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition, int nID)
This method is called to fill the control's face.
CXTPControlComboBox
CXTPControlComboBox is a CXTPControl derived class.
Definition XTPControlComboBox.h:381
CXTPControl
CXTPControl is a CXTPCmdTarget derived class.
Definition XTPControl.h:841


Toolkit Pro: Member List

CXTPPropertyGridInplaceControl Member List

This is the complete list of members for CXTPPropertyGridInplaceControl, including all inherited members.

CXTPPropertyGridInplaceControl(CXTPPropertyGridItem *pItem) | CXTPPropertyGridInplaceControl |
m_nWidth | CXTPPropertyGridInplaceControl | protected
m_pItem | CXTPPropertyGridInplaceControl | protected
OnAdjustValueRect(CRect &rcValue)=0 | CXTPPropertyGridInplaceControl | pure virtual
OnCreateWindow(CRect &rcValue)=0 | CXTPPropertyGridInplaceControl | pure virtual
OnDestroyWindow() | CXTPPropertyGridInplaceControl | virtual
OnEditMouseWheel(CEdit *pEdit, short zDelta) | CXTPPropertyGridInplaceControl | virtual
OnValueChanged() | CXTPPropertyGridInplaceControl | virtual


Toolkit Pro: XTPWindowPos.h Source File

  • Source
  • Controls
  • Util
XTPWindowPos.h
Go to the documentation of this file.
1
23#if !defined(__XTPWINDOWPLACEMENT_H__)
24# define __XTPWINDOWPLACEMENT_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPWindowPos : public WINDOWPLACEMENT
39{
40public:
45 CXTPWindowPos();
46
47public:
62 BOOL LoadWindowPos(LPCTSTR lpszWndPos = NULL, LPCTSTR lpszSection = NULL);
63
80 BOOL LoadWindowPos(CWnd* pWnd, LPCTSTR lpszWndPos = NULL, LPCTSTR lpszSection = NULL);
81
97 BOOL SaveWindowPos(CWnd* pWnd, LPCTSTR lpszWndPos = NULL, LPCTSTR lpszSection = NULL);
98};
99
100# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
102#endif // #if !defined(__XTPWINDOWPLACEMENT_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPWindowPos
CXTPWindowPos is a WINDOWPLACEMENT structure derived class.
Definition XTPWindowPos.h:39
CXTPWindowPos::SaveWindowPos
BOOL SaveWindowPos(CWnd *pWnd, LPCTSTR lpszWndPos=NULL, LPCTSTR lpszSection=NULL)
This member function will save the window specified by 'pWnd' by its current window position.
CXTPWindowPos::CXTPWindowPos
CXTPWindowPos()
Constructs a CXTPWindowPos object.
CXTPWindowPos::LoadWindowPos
BOOL LoadWindowPos(CWnd *pWnd, LPCTSTR lpszWndPos=NULL, LPCTSTR lpszSection=NULL)
This member function will load the window specified by 'pWnd' to its previous window position.
CXTPWindowPos::LoadWindowPos
BOOL LoadWindowPos(LPCTSTR lpszWndPos=NULL, LPCTSTR lpszSection=NULL)
This member function will load the window specified by 'pWnd' to its previous window position.


Toolkit Pro: Member List

CXTPControlFontComboBox Member List

This is the complete list of members for CXTPControlFontComboBox, including all inherited members.

AddString(LPCTSTR lpsz) | CXTPControlComboBox |
AdjustExcludeRect(CRect &rc, BOOL bVertical) | CXTPControlPopup | virtual
AssignDocTemplate(UINT nIDResource) | CXTPControl |
ClickToolBarButton(CRect rcActiveRect=CRect(0, 0, 0, 0)) | CXTPControl | protected
Compare(CXTPControl *pOther) | CXTPControlComboBox | virtual
ContainsPopup(CXTPControlPopup *pControlPopup) | CXTPControlPopup | protected
Copy(CXTPControl *pControl, BOOL bRecursive=FALSE) | CXTPControlComboBox | protectedvirtual
CreateControlPopup(XTPControlType controlType) | CXTPControlPopup | static
CreateEditControl() | CXTPControlComboBox | protectedvirtual
CustomizeStartDrag(CPoint point) | CXTPControl | protectedvirtual
CustomizeStartResize(CPoint point) | CXTPControl | protectedvirtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPControl() | CXTPControl | protected
CXTPControlButton() | CXTPControlButton |
CXTPControlComboBox(CXTPCommandBars *pCommandBars=NULL) | CXTPControlComboBox |
CXTPControlFontComboBox(DWORD dwStyleListBox=1) | CXTPControlFontComboBox |
CXTPControlPopup() | CXTPControlPopup |
DeflateEditRect(CRect &rcControl) | CXTPControlComboBox | protectedvirtual
DelayLayoutParent() | CXTPControl |
DelayRedrawParent() | CXTPControl |
DeleteItem(long nIndex) | CXTPControlComboBox |
DoCustomDragOver(CXTPCommandBar *pCommandBar, CPoint point, DROPEFFECT &dropEffect) | CXTPControlPopup | protectedvirtual
DoPropExchange(CXTPPropExchange *pPX) | CXTPControlComboBox | virtual
Draw(CDC *pDC) | CXTPControl | virtual
DrawEditText(CDC *pDC, CRect rcText) | CXTPControlComboBox | virtual
EnableAutoComplete(BOOL bAutoComplete=TRUE) | CXTPControlComboBox |
EnableShellAutoComplete(DWORD dwFlags=SHACF_FILESYSTEM|SHACF_URLALL) | CXTPControlComboBox |
ExcludeDocTemplate(UINT nIDResource) | CXTPControl |
ExpandCommandBar() | CXTPControlPopup | protected
FindString(int nStartAfter, LPCTSTR lpszItem) const | CXTPControlComboBox |
FindStringExact(int nIndexStart, LPCTSTR lpsz) const | CXTPControlComboBox |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
FromUI(CCmdUI *pCmdUI) | CXTPControl | static
GenerateCommandBarList(DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam) | CXTPControl | protectedvirtual
GetAction() const | CXTPControl |
GetBeginGroup() const | CXTPControl |
GetButtonSize() const | CXTPControl | virtual
GetCaption() const | CXTPControlPopup | virtual
GetCategory() const | CXTPControl |
GetChecked() const | CXTPControl |
GetCloseSubMenuOnClick() const | CXTPControl |
GetComboBoxPopupBar() const | CXTPControlComboBox |
GetCommandBar() const | CXTPControlPopup | virtual
GetControls() const | CXTPControl |
GetCount() const | CXTPControlComboBox |
GetCurSel() const | CXTPControlComboBox |
GetCustomizeMinHeight() const | CXTPControl | protectedvirtual
GetCustomizeMinWidth() const | CXTPControlComboBox | protectedvirtual
GetCustomShortcutText() const | CXTPControl |
GetDefaultCharFormat() | CXTPControlComboBox | virtual
GetDescription() const | CXTPControl | virtual
GetDropDownListStyle() const | CXTPControlComboBox |
GetDropDownWidth() const | CXTPControlComboBox |
GetDroppedState() const | CXTPControlComboBox |
GetEditCtrl() const | CXTPControlComboBox |
GetEditHint() const | CXTPControlComboBox |
GetEditIconId() const | CXTPControlComboBox |
GetEditStyle() const | CXTPControlComboBox |
GetEditText() const | CXTPControlComboBox |
GetEnabled() const | CXTPControl |
GetExecuteOnPressInterval() const | CXTPControl |
GetExpanded() const | CXTPControl |
GetFlags() const | CXTPControl |
GetHeight() const | CXTPControl |
GetHelpId() const | CXTPControl |
GetHideFlags() const | CXTPControl |
GetIconId() const | CXTPControl |
GetIconSize() const | CXTPControl | virtual
GetID() const | CXTPControl |
GetImage(int nWidth=16) const | CXTPControl | virtual
GetImageManager() const | CXTPControl |
GetIndex() const | CXTPControl |
GetItemData(int nIndex) const | CXTPControlComboBox |
GetKeyboardTip() const | CXTPControl |
GetLabelWidth() const | CXTPControlComboBox |
GetLBText(int nIndex, CString &str) const | CXTPControlComboBox |
GetListBoxCtrl() const | CXTPControlComboBox |
GetListBoxText() const | CXTPControlComboBox | virtual
GetListIconId() const | CXTPControlComboBox |
GetPaintManager() const | CXTPControl |
GetParameter() const | CXTPControl |
GetParent() const | CXTPControl |
GetPopuped() const | CXTPControlPopup | virtual
GetPressed() const | CXTPControl | virtual
GetRect() const | CXTPControl |
GetRibbonGroup() const | CXTPControl |
GetRowRect() const | CXTPControl |
GetSelected() const | CXTPControl | virtual
GetShortcutText() const | CXTPControl |
GetSize(CDC *pDC) | CXTPControl | virtual
GetStyle() const | CXTPControl |
GetStyleEx() const | CXTPControlButton |
GetTag() const | CXTPControl |
GetTextLimit() const | CXTPControlComboBox |
GetThumbWidth() const | CXTPControlComboBox |
GetTooltip() const | CXTPControl | virtual
GetType() const | CXTPControl |
GetWidth() const | CXTPControl |
GetWrap() const | CXTPControl |
HasDwmCompositedRect() const | CXTPControl |
HasFocus() const | CXTPControlComboBox |
InsertString(int nIndex, LPCTSTR lpsz) | CXTPControlComboBox |
IsCaptionVisible() const | CXTPControlComboBox | virtual
IsCursorOver() const | CXTPControl |
IsCustomizeMode() const | CXTPControl | protected
IsCustomizeMovable() const | CXTPControl | virtual
IsCustomizeResizeAllow() const | CXTPControlComboBox | protectedvirtual
IsFocusable() const | CXTPControlComboBox | protectedvirtual
IsFocused() const | CXTPControlComboBox | virtual
IsImageVisible() const | CXTPControlComboBox |
IsItemDefault() const | CXTPControl |
IsLayoutChanged() | CXTPControl | protected
IsLayoutRTL() const | CXTPControl | protected
IsOnQuickAccess() const | CXTPControl |
IsTemporary() const | CXTPControl |
IsTransparent() const | CXTPControl | inlinevirtual
IsVisible(DWORD dwSkipFlags=0) const | CXTPControl | virtual
m_bAutoComplete | CXTPControlComboBox | protected
m_bBeginGroup | CXTPControl | protected
m_bChecked | CXTPControl | protected
m_bCloseSubMenuOnClick | CXTPControl | protected
m_bDefaultItem | CXTPControl | protected
m_bDelayDestroy | CXTPControlComboBox | protected
m_bDelayReposition | CXTPControlComboBox | protected
m_bDropDown | CXTPControlComboBox | protected
m_bEditChanged | CXTPControlComboBox | mutableprotected
m_bEnabled | CXTPControl | protected
m_bExpanded | CXTPControl | protected
m_bFocused | CXTPControlComboBox | protected
m_bIgnoreAutoComplete | CXTPControlComboBox | protected
m_bLayoutRTL | CXTPControl | protected
m_bOnQuickAccess | CXTPControl | protected
m_bPopup | CXTPControlPopup | protected
m_bPressed | CXTPControl | protected
m_bSelected | CXTPControl | protected
m_bSelEndOk | CXTPControlComboBox | protected
m_bShowShadow | CXTPControlPopup | protected
m_bTemporary | CXTPControl | protected
m_buttonCustomStyle | CXTPControl | protected
m_buttonRibbonStyle | CXTPControl | protected
m_buttonStyle | CXTPControl | protected
m_buttonStyleEx | CXTPControlButton | protected
m_bWrap | CXTPControl | protected
m_comboStyle | CXTPControlComboBox | protected
m_controlType | CXTPControl | protected
m_dwCommandBarID | CXTPControlPopup | protected
m_dwEditStyle | CXTPControlComboBox | protected
m_dwFlags | CXTPControl | protected
m_dwHideFlags | CXTPControl | protected
m_dwShellAutoCompleteFlags | CXTPControlComboBox | protected
m_mapDocTemplatesAssigned | CXTPControl | protected
m_mapDocTemplatesExcluded | CXTPControl | protected
m_nCustomIconId | CXTPControl | protected
m_nDropDownItemCount | CXTPControlComboBox | protected
m_nEditIconId | CXTPControlComboBox | protected
m_nExecuteOnPressInterval | CXTPControl | protected
m_nHeight | CXTPControl | protected
m_nHelpId | CXTPControl | protected
m_nIconId | CXTPControl | protected
m_nId | CXTPControl | protected
m_nIndex | CXTPControl | protected
m_nLabelWidth | CXTPControlComboBox | protected
m_nLastSel | CXTPControlComboBox | protected
m_nTag | CXTPControl | protected
m_nTextLimit | CXTPControlComboBox | protected
m_nThumbWidth | CXTPControlComboBox | protected
m_nWidth | CXTPControl | protected
m_pAction | CXTPControl | protected
m_pAutoCompleteWnd | CXTPControlComboBox | protected
m_pCommandBar | CXTPControlPopup | protected
m_pControls | CXTPControl | protected
m_pEdit | CXTPControlComboBox | protected
m_pParent | CXTPControl | protected
m_pRibbonGroup | CXTPControl | protected
m_rcControl | CXTPControl | protected
m_rcRow | CXTPControl | protected
m_strCaption | CXTPControl | protected
m_strCategory | CXTPControl | protected
m_strCustomCaption | CXTPControl | protected
m_strDescriptionText | CXTPControl | protected
m_strEditHint | CXTPControlComboBox | protected
m_strEditText | CXTPControlComboBox | mutableprotected
m_strKeyboardTip | CXTPControl | protected
m_strLastText | CXTPControlComboBox | protected
m_strParameter | CXTPControl | protected
m_strShortcutText | CXTPControl | protected
m_strShortcutTextAuto | CXTPControl | protected
m_strTooltipText | CXTPControl | protected
m_szIcon | CXTPControl | protected
ModifyListBoxStyle(DWORD dwRemove, DWORD dwAdd) | CXTPControlComboBox |
NotifySite(UINT code) | CXTPControl |
NotifySite(UINT code, NMXTPCONTROL *pNM) | CXTPControl |
NotifySite(CWnd *pSite, UINT code, NMXTPCONTROL *pNM) | CXTPControl |
OnActionChanged(int nProperty) | CXTPControlComboBox | virtual
OnActionChanging(int nProperty) | CXTPControlComboBox | virtual
OnCalcDynamicSize(DWORD dwMode) | CXTPControlComboBox | protectedvirtual
OnCaptionChanged() | CXTPControl | protectedvirtual
OnClick(BOOL bKeyboard=FALSE, CPoint pt=CPoint(0, 0)) | CXTPControlComboBox | protectedvirtual
OnCustomizeDragOver(CXTPControl *pDataObject, CPoint point, DROPEFFECT &dropEffect) | CXTPControlPopup | protectedvirtual
OnCustomizeMouseMove(CPoint point) | CXTPControl | protected
OnEditChanged() | CXTPControlComboBox | virtual
OnEnabledChanged() | CXTPControlComboBox | virtual
OnExecute() | CXTPControlFontComboBox | protectedvirtual
OnHookKeyDown(UINT nChar, LPARAM lParam) | CXTPControlComboBox | protectedvirtual
OnHookMouseWheel(UINT nFlags, short zDelta, CPoint point) | CXTPControl | protectedvirtual
OnIdleUpdate() | CXTPControl | protectedvirtual
OnKillFocus() | CXTPControlComboBox | protectedvirtual
OnLButtonDblClk(CPoint point) | CXTPControlPopup | protectedvirtual
OnLButtonDown(CPoint point) | CXTPControl | protectedvirtual
OnLButtonUp(CPoint point) | CXTPControlPopup | protectedvirtual
OnMouseHover() | CXTPControlComboBox | protectedvirtual
OnMouseMove(CPoint point) | CXTPControlComboBox | protectedvirtual
OnRButtonDown(CPoint point) | CXTPControl | protectedvirtual
OnRButtonUp(CPoint point) | CXTPControl | protectedvirtual
OnRemoved() | CXTPControlComboBox | protectedvirtual
OnSelChanged() | CXTPControlComboBox | virtual
OnSetFocus(CWnd *pOldWnd) | CXTPControlComboBox | protectedvirtual
OnSetPopup(BOOL bPopup) | CXTPControlComboBox | protectedvirtual
OnSetSelected(int bSelected) | CXTPControlComboBox | protectedvirtual
OnThemeChanged() | CXTPControl | virtual
OnToolHitTest(CPoint point, TOOLINFO *pTI) const | CXTPControl | protectedvirtual
OnUnderlineActivate() | CXTPControlComboBox | protectedvirtual
RedrawParent(BOOL bAnimate=TRUE) | CXTPControl |
Reset() | CXTPControl |
ResetContent() | CXTPControlComboBox |
RestoreCommandBarList(CXTPCommandBarList *pCommandBarList) | CXTPControlPopup | protectedvirtual
ScreenToClient(CPoint *point) | CXTPControl | protected
SetAction(CXTPControlAction *pAction) | CXTPControl | virtual
SetBeginGroup(BOOL bBeginGroup) | CXTPControl | virtual
SetCaption(LPCTSTR lpszCaption) | CXTPControl |
SetCaption(UINT nIDCaption) | CXTPControl |
SetCategory(LPCTSTR lpszCategory) | CXTPControl |
SetCharFormat(CHARFORMAT &cf) | CXTPControlFontComboBox |
SetChecked(BOOL bChecked) | CXTPControl | virtual
SetCloseSubMenuOnClick(BOOL bCloseOnClick) | CXTPControl |
SetCommandBar(CMenu *pMenu) | CXTPControlPopup |
SetCommandBar(CXTPCommandBar *pBar) | CXTPControlPopup |
SetCurSel(int nIndex) | CXTPControlComboBox |
SetCustomIcon(HICON hIcon) | CXTPControl |
SetCustomShortcutText(LPCTSTR lpszCustomShortcutText) | CXTPControl |
SetDescription(LPCTSTR lpszDescription) | CXTPControl |
SetDropDownItemCount(int nDropDownItemCount) | CXTPControlComboBox |
SetDropDownListStyle(BOOL bSet=TRUE) | CXTPControlComboBox |
SetDropDownWidth(int nWidth) | CXTPControlComboBox |
SetEditHint(LPCTSTR lpszEditHint) | CXTPControlComboBox |
SetEditIconId(int nId) | CXTPControlComboBox |
SetEditStyle(DWORD dwStyle) | CXTPControlComboBox |
SetEditText(const CString &lpszText) | CXTPControlComboBox |
SetEnabled(BOOL bEnabled) | CXTPControl | virtual
SetExecuteOnPressInterval(int nExecuteOnPressInterval) | CXTPControl |
SetExpanded(BOOL bExpanded) | CXTPControl | protected
SetFlags(DWORD dwFlags) | CXTPControl |
SetFocused(BOOL bFocused) | CXTPControlComboBox | virtual
SetHeight(int nHeight) | CXTPControl | virtual
SetHelpId(int nId) | CXTPControl |
SetHideFlag(XTPControlHideFlags dwFlag, BOOL bSet) | CXTPControl |
SetHideFlags(DWORD dwFlags) | CXTPControlComboBox | virtual
SetHideWrap(BOOL bHide) | CXTPControl |
SetIconId(int nId) | CXTPControl |
SetIconSize(CSize szIcon) | CXTPControl |
SetID(int nId) | CXTPControl |
SetIndex(int nIndex) | CXTPControl | inlineprotected
SetItemData(int nIndex, DWORD_PTR dwItemData) | CXTPControlComboBox |
SetItemDefault(BOOL bDefault) | CXTPControl |
SetKeyboardTip(LPCTSTR lpszKeyboardTip) | CXTPControl |
SetLabelWidth(int nLabelWidth) | CXTPControlComboBox |
SetListIconId(int nId) | CXTPControlComboBox |
SetOnQuickAccess(BOOL bOnQuicAccess=FALSE) | CXTPControl |
SetParameter(LPCTSTR lpszParameter) | CXTPControl |
SetParent(CXTPCommandBar *pParent) | CXTPControlComboBox | protectedvirtual
SetPressed(BOOL bPressed) | CXTPControl |
SetPrompt(LPCTSTR lpszPrompt) | CXTPControl |
SetRect(CRect rcControl) | CXTPControlComboBox | protectedvirtual
SetRowRect(CRect rcRow) | CXTPControl |
SetShortcutText(LPCTSTR lpszShortcutText) | CXTPControl |
SetStyle(XTPButtonStyle buttonStyle) | CXTPControl |
SetStyleEx(XTPButtonStyle buttonStyle) | CXTPControlButton |
SetTag(DWORD_PTR dwTag) | CXTPControl |
SetTextLimit(int nTextLimit) | CXTPControlComboBox |
SetThumbWidth(int nThumbWidth) | CXTPControlComboBox |
SetTooltip(LPCTSTR lpszTooltip) | CXTPControl |
SetVisible(BOOL bVisible) | CXTPControl |
SetWidth(int nWidth) | CXTPControl | virtual
SetWrap(BOOL bWrap) | CXTPControl |
UpdateShadow() | CXTPControlPopup | protectedvirtual
~CXTPControl() | CXTPControl | protectedvirtual
~CXTPControlButton() | CXTPControlButton | virtual
~CXTPControlComboBox() | CXTPControlComboBox | virtual
~CXTPControlFontComboBox() | CXTPControlFontComboBox | virtual
~CXTPControlPopup() | CXTPControlPopup | virtual


Toolkit Pro: Member List

CXTPChart3dPieSeriesStyle Member List

This is the complete list of members for CXTPChart3dPieSeriesStyle, including all inherited members.

ApplyTo(CXTPChartDeviceCommand *pCommand) | CXTPChartSeriesStyle | virtual
CorrectAxisSideMargins(CXTPChartAxis *pAxis, double nMinValue, double nMaxValue, double &nCorrection) | CXTPChartSeriesStyle | virtual
CreateDiagram() | CXTPChart3dPieSeriesStyle | virtual
CreateView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView) | CXTPChart3dPieSeriesStyle | virtual
CXTPChart3dPieSeriesStyle() | CXTPChart3dPieSeriesStyle |
CXTPChartElement() | CXTPChartElement |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartPieSeriesStyleBase() | CXTPChartPieSeriesStyleBase | protected
CXTPChartSeriesStyle() | CXTPChartSeriesStyle |
DoPropExchange(CXTPPropExchange *pPX) | CXTPChart3dPieSeriesStyle | virtual
Enable3dEdgeSmoothing(BOOL bEnable=TRUE) | CXTPChartSeriesStyle | virtual
Get3dRotation() const | CXTPChart3dPieSeriesStyle | virtual
GetAppearance() const | CXTPChartElement |
GetBorder() const | CXTPChartPieSeriesStyleBase |
GetBorderActualColor() const | CXTPChartPieSeriesStyleBase |
GetColor() const | CXTPChartSeriesStyle | virtual
GetContent() const | CXTPChartElement |
GetDepth() const | CXTPChart3dPieSeriesStyle | virtual
GetErrorBar() const | CXTPChartSeriesStyle | virtual
GetExplodedDistancePercent() const | CXTPChartPieSeriesStyleBase |
GetHolePercent() const | CXTPChartPieSeriesStyleBase |
GetLabel() const | CXTPChartSeriesStyle | virtual
GetOwner() const | CXTPChartElement |
GetRotation() const | CXTPChartPieSeriesStyleBase |
GetSeriesPointValueIndex() const | CXTPChartSeriesStyle | virtual
GetStyleAppearance() const | CXTPChartSeriesStyle | virtual
GetTransparency() const | CXTPChartSeriesStyle | virtual
Is3D() const | CXTPChartObject |
Is3dEdgeSmoothingEnabled() const | CXTPChartSeriesStyle | virtual
IsColorEach() const | CXTPChartSeriesStyle | virtual
IsStyleDiagram(CXTPChartDiagram *pDiagram) const | CXTPChartPieSeriesStyleBase | protectedvirtual
IsTorus() const | CXTPChart3dPieSeriesStyle |
m_bColorEach | CXTPChartSeriesStyle | protected
m_bSmooth3dEdges | CXTPChartSeriesStyle | protected
m_clrColor | CXTPChartSeriesStyle | protected
m_nExplodedDistancePercent | CXTPChartPieSeriesStyleBase | protected
m_nHolePercent | CXTPChartPieSeriesStyleBase | protected
m_nRotation | CXTPChartPieSeriesStyleBase | protected
m_nTransparency | CXTPChartSeriesStyle | protected
m_pBorder | CXTPChartPieSeriesStyleBase | protected
m_pErrorBar | CXTPChartSeriesStyle | protected
m_pLabel | CXTPChartSeriesStyle | protected
m_Rotation3d | CXTPChartSeriesStyle | protected
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartElement | virtual
Release() | CXTPChartElement | virtual
Set3dRotation(const CXTPChart3dRotation &rotation) | CXTPChartSeriesStyle | virtual
Set3dRotation(double dYaw, double dPitch, double dRoll) | CXTPChartSeriesStyle | virtual
SetColor(CXTPChartColor clr) | CXTPChartSeriesStyle | virtual
SetColorEach(BOOL bColorEach) | CXTPChartSeriesStyle | virtual
SetDepth(int dDepth) | CXTPChart3dPieSeriesStyle |
SetErrorBar(CXTPChartErrorBar *pErrorBar) | CXTPChartSeriesStyle | virtual
SetExplodedDistancePercent(int nExplodedDistancePercent) | CXTPChartPieSeriesStyleBase |
SetHolePercent(int nHolePercent) | CXTPChartPieSeriesStyleBase |
SetLabel(CXTPChartSeriesLabel *pLabel) | CXTPChartSeriesStyle | virtual
SetRotation(int nRotation) | CXTPChartPieSeriesStyleBase |
SetTorus(BOOL bTorus) | CXTPChart3dPieSeriesStyle |
SetTransparency(int nTransparency) | CXTPChartSeriesStyle | virtual
~CXTPChartElement() | CXTPChartElement | virtual
~CXTPChartPieSeriesStyleBase() | CXTPChartPieSeriesStyleBase | protectedvirtual
~CXTPChartSeriesStyle() | CXTPChartSeriesStyle | virtual


Toolkit Pro: XTPScrollBarContainer.h Source File

  • Source
  • Common
  • ScrollBar
XTPScrollBarContainer.h
Go to the documentation of this file.
1
23#if !defined(__XTPSCROLLBARCONTAINER_H__)
24# define __XTPSCROLLBARCONTAINER_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPScrollBarCtrl;
34
36class _XTP_EXT_CLASS CXTPScrollBarContainerImpl
37{
38public:
39 CXTPScrollBarContainerImpl();
40 ~CXTPScrollBarContainerImpl();
41
42 void SetContainer(CWnd* pContainer);
43
44 BOOL CreateScrollBarCtrl(DWORD dwStyle, UINT nID);
45 void DestroyScrollBarCtrl(UINT nID);
46
47 void SetScrollBarClass(CRuntimeClass* pClass = NULL);
48 CScrollBar* GetScrollBarCtrl(int nBar);
49 void SetScrollBarTheme(XTPScrollBarTheme theme);
50 void ShowScrollBar(UINT nBar, BOOL bShow);
51 BOOL EnableScrollBar(int nSBFlags, UINT nArrowFlags = ESB_ENABLE_BOTH);
52
53 void RefreshMetrics();
54 void OnWindowProc(UINT message, WPARAM wParam, LPARAM lParam, LRESULT& lResult);
55
56 void OptimizeChildrenClipping();
57
58private:
59 struct STDSCROLLBAR
60 {
61 STDSCROLLBAR();
62 ~STDSCROLLBAR();
63
64 CXTPScrollBarCtrl* operator->() throw();
65 const CXTPScrollBarCtrl* operator->() const throw();
66
67 CXTPScrollBarCtrl* pCtrl;
68 BOOL bVisible;
69 };
70
71 enum StdScrollBarId
72 {
73 SbInvalid = -1,
74 SbHorz = 0,
75 SbVert = 1,
76 SbGripper = 2
77 };
78
79 void OnCreate(LPCREATESTRUCT lpCreateStruct);
80 void OnWindowPosChange(WINDOWPOS* lpWndPos);
81 void OnNcCalcSize(BOOL bCalcValidRects, NCCALCSIZE_PARAMS* lpncsp);
82 void OnStyleChanged(LONG nType, LPSTYLESTRUCT pStyleStruct);
83
84 BOOL HasStdBar(StdScrollBarId nBar) const;
85 CScrollBar* CreateStdScrollBar(StdScrollBarId nBar);
86 void DestroyStdScrollBar(StdScrollBarId nBar);
87 void RepositionStdScrollBars(const RECT* lpRect = NULL);
88 static StdScrollBarId AFX_CDECL SBtoSBId(int nBar);
89 static UINT AFX_CDECL SBIdToSBWs(StdScrollBarId nBar);
90 static int AFX_CDECL SBIdToSB(StdScrollBarId nBar);
91 void ShowScrollBarInternal(StdScrollBarId nBar, BOOL bShow);
92 void SyncStdScrollBarStates();
93 CSize GetContainerBorder();
94
95 BOOL m_bCreated;
96 STDSCROLLBAR m_StdScrollBar[3];
97 CWnd* m_pContainer;
98 XTPScrollBarTheme m_nTheme;
99 CList<CXTPScrollBarCtrl*, CXTPScrollBarCtrl*> m_ScrollBars;
100 BOOL m_bRightFrameAdjusted;
101 BOOL m_bBottomFrameAdjusted;
102 CRuntimeClass* m_pScrollBarClass;
103};
111template<class Parent = CWnd>
112class CXTPScrollBarContainer : public Parent
113{
114protected:
120 CXTPScrollBarContainer()
121 {
122 m_Impl.SetContainer(this);
123 }
124
125public:
126 //{{AFX_VIRTUAL(CXTPScrollBarContainer)
127
128 virtual LRESULT WindowProc(UINT message, WPARAM wParam, LPARAM lParam)
129 {
130 LRESULT lResult = Parent::WindowProc(message, wParam, lParam);
131 m_Impl.OnWindowProc(message, wParam, lParam, lResult);
132 return lResult;
133 }
134
135 //}}AFX_VIRTUAL
136
142 void SetScrollBarTheme(XTPScrollBarTheme theme)
143 {
144 m_Impl.SetScrollBarTheme(theme);
145 RefreshScrollBarMetrics();
146 }
147
156 BOOL CreateScrollBarCtrl(DWORD dwStyle, UINT nID)
157 {
158 return m_Impl.CreateScrollBarCtrl(dwStyle, nID);
159 }
160
168 virtual CScrollBar* GetScrollBarCtrl(int nBar) const
169 {
170 return const_cast<CXTPScrollBarContainerImpl&>(m_Impl).GetScrollBarCtrl(nBar);
171 }
172
179 void ShowScrollBar(UINT nBar, BOOL bShow = TRUE)
180 {
181 m_Impl.ShowScrollBar(nBar, bShow);
182 }
183
192 BOOL EnableScrollBar(int nSBFlags, UINT nArrowFlags = ESB_ENABLE_BOTH)
193 {
194 return m_Impl.EnableScrollBar(nSBFlags, nArrowFlags);
195 }
196
202 void RefreshScrollBarMetrics()
203 {
204 m_Impl.RefreshMetrics();
205 }
206
213 void OptimizeChildrenClipping()
214 {
215 m_Impl.OptimizeChildrenClipping();
216 }
217
224 void SetScrollBarClass(CRuntimeClass* pClass = NULL)
225 {
226 m_Impl.SetScrollBarClass(pClass);
227 }
228
229private:
230 CXTPScrollBarContainerImpl m_Impl;
231};
232
238template<class Parent>
239class CXTPDialogScrollBarContainer : public CXTPScrollBarContainer<Parent>
240{
241protected:
246 CXTPDialogScrollBarContainer()
247 {
248 }
249
258 explicit CXTPDialogScrollBarContainer(LPCTSTR lpszTemplateName, CWnd* pParentWnd = NULL)
259 {
260 new (static_cast<Parent*>(this)) Parent(lpszTemplateName, pParentWnd);
261 }
262
273 explicit CXTPDialogScrollBarContainer(UINT nIDTemplate, CWnd* pParentWnd = NULL)
274 {
275 new (static_cast<Parent*>(this)) Parent(nIDTemplate, pParentWnd);
276 }
277};
278
279# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
281#endif // !defined(__XTPSCROLLBARCONTAINER_H__
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPScrollBarTheme
XTPScrollBarTheme
Scrollbar theme identifier enum.
Definition XTPScrollBase.h:87
CXTPDialogScrollBarContainer
CXTPDialogScrollBarContainer class adds XTP scroll bars to a class derived from CDialog.
Definition XTPScrollBarContainer.h:240
CXTPDialogScrollBarContainer::CXTPDialogScrollBarContainer
CXTPDialogScrollBarContainer(UINT nIDTemplate, CWnd *pParentWnd=NULL)
Constructs a CXTPDialogScrollBarContainer object.
Definition XTPScrollBarContainer.h:273
CXTPDialogScrollBarContainer::CXTPDialogScrollBarContainer
CXTPDialogScrollBarContainer(LPCTSTR lpszTemplateName, CWnd *pParentWnd=NULL)
Constructs a CXTPDialogScrollBarContainer object.
Definition XTPScrollBarContainer.h:258
CXTPDialogScrollBarContainer::CXTPDialogScrollBarContainer
CXTPDialogScrollBarContainer()
Constructs a CXTPDialogScrollBarContainer object.
Definition XTPScrollBarContainer.h:246
CXTPScrollBarContainer
CXTPScrollBarContainer class adds XTP scroll bars to a class derived from CWnd.
Definition XTPScrollBarContainer.h:113
CXTPScrollBarContainer::GetScrollBarCtrl
virtual CScrollBar * GetScrollBarCtrl(int nBar) const
Call this member function to obtain a pointer to the specified sibling scroll bar or splitter window.
Definition XTPScrollBarContainer.h:168
CXTPScrollBarContainer::CXTPScrollBarContainer
CXTPScrollBarContainer()
Constructs a CXTPScrollBarContainer object.
Definition XTPScrollBarContainer.h:120
CXTPScrollBarContainer::SetScrollBarClass
void SetScrollBarClass(CRuntimeClass *pClass=NULL)
Sets a scroll bar class to be used for creating scroll bars.
Definition XTPScrollBarContainer.h:224
CXTPScrollBarContainer::CreateScrollBarCtrl
BOOL CreateScrollBarCtrl(DWORD dwStyle, UINT nID)
Creates a scroll bar control with ID and style specied.
Definition XTPScrollBarContainer.h:156
CXTPScrollBarContainer::RefreshScrollBarMetrics
void RefreshScrollBarMetrics()
Triggers update of color and size information for themed scroll bars.
Definition XTPScrollBarContainer.h:202
CXTPScrollBarContainer::ShowScrollBar
void ShowScrollBar(UINT nBar, BOOL bShow=TRUE)
Shows or hides a scroll bar.
Definition XTPScrollBarContainer.h:179
CXTPScrollBarContainer::EnableScrollBar
BOOL EnableScrollBar(int nSBFlags, UINT nArrowFlags=ESB_ENABLE_BOTH)
Enables or disables one or both arrows of a scroll bar.
Definition XTPScrollBarContainer.h:192
CXTPScrollBarContainer::OptimizeChildrenClipping
void OptimizeChildrenClipping()
Applies WS_CLIPCHILDREN and WS_CLIPSIBLINGS styles the the container owner and all its immediate chil...
Definition XTPScrollBarContainer.h:213
CXTPScrollBarContainer::SetScrollBarTheme
void SetScrollBarTheme(XTPScrollBarTheme theme)
Sets scroll bar theme.
Definition XTPScrollBarContainer.h:142
CXTPScrollBarCtrl
Scrollbar control.
Definition XTPScrollBarCtrl.h:48


Toolkit Pro: Member List

CXTPPropertyGridVisualStudio2005Theme Member List

This is the complete list of members for CXTPPropertyGridVisualStudio2005Theme, including all inherited members.

AdjustItemCaptionRect(CXTPPropertyGridItem *pItem, CRect &rcCaption) | CXTPPropertyGridPaintManager | virtual
AdjustItemValueRect(CXTPPropertyGridItem *pItem, CRect &rcValue) | CXTPPropertyGridPaintManager | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPPropertyGridPaintManager(CXTPPropertyGrid *pGrid) | CXTPPropertyGridPaintManager |
CXTPPropertyGridVisualStudio2005Theme(CXTPPropertyGrid *pGrid) | CXTPPropertyGridVisualStudio2005Theme |
DrawCategoryCaptionBackground(CDC *pDC, CXTPPropertyGridItem *pItem, CRect rc) | CXTPPropertyGridVisualStudio2005Theme | protectedvirtual
DrawCheckBox(CDC *pDC, CXTPPropertyGridItemBool *pButton) | CXTPPropertyGridPaintManager | virtual
DrawCheckMark(CDC *pDC, CRect rc, BOOL bEnabled, BOOL bChecked) | CXTPPropertyGridPaintManager | virtual
DrawExpandButton(CDC &dc, CXTPPropertyGridItem *pItem, CRect rcCaption) | CXTPPropertyGridVisualStudio2005Theme | protectedvirtual
DrawInplaceButtons(CDC *pDC, PDRAWITEMSTRUCT lpDrawItemStruct, CXTPPropertyGridItem *pItem, CRect rcValue) | CXTPPropertyGridPaintManager | virtual
DrawInplaceListItem(CDC *pDC, CXTPPropertyGridItemConstraint *pConstraint, CRect rc, BOOL bSelected) | CXTPPropertyGridPaintManager | virtual
DrawItem(PDRAWITEMSTRUCT lpDrawItemStruct) | CXTPPropertyGridPaintManager | virtual
DrawItemCaption(CDC *pDC, CXTPPropertyGridItem *pItem, CRect rcCaption) | CXTPPropertyGridPaintManager | virtual
DrawItemValue(CDC *pDC, CXTPPropertyGridItem *pItem, CRect rcValue) | CXTPPropertyGridPaintManager | virtual
DrawPropertyGridBorder(CDC *pDC, RECT &rcBorder, XTPPropertyGridWindow nWindow) | CXTPPropertyGridPaintManager | virtual
DrawRadioMark(CDC *pDC, CRect rc, BOOL bEnabled, BOOL bChecked) | CXTPPropertyGridPaintManager | virtual
FillInplaceButton(CDC *pDC, CXTPPropertyGridInplaceButton *pButton) | CXTPPropertyGridPaintManager | virtual
FillPropertyGrid(CDC *pDC) | CXTPPropertyGridPaintManager | virtual
FillPropertyGridView(CDC *pDC) | CXTPPropertyGridPaintManager | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetItemBackColor(CXTPPropertyGridItem *pItem, BOOL bValuePart) | CXTPPropertyGridPaintManager | virtual
GetItemFont(CXTPPropertyGridItem *pItem, BOOL bValuePart) | CXTPPropertyGridPaintManager | virtual
GetItemMetrics() const | CXTPPropertyGridPaintManager |
GetItemsBorderHeight() const | CXTPPropertyGridPaintManager | virtual
GetItemTextColor(CXTPPropertyGridItem *pItem, BOOL bValuePart) | CXTPPropertyGridPaintManager | virtual
GetScrollBarTheme() const | CXTPPropertyGridVisualStudio2005Theme | protectedvirtual
GetSplitterRect(CRect rc, BOOL bIsHelp) | CXTPPropertyGridPaintManager |
HitTestVerbs(CDC *pDC, CRect rcVerbs, CPoint pt) | CXTPPropertyGridPaintManager |
m_bThinSplitter | CXTPPropertyGridPaintManager | protected
m_bTransparent | CXTPPropertyGridPaintManager |
m_buttonsStyle | CXTPPropertyGridPaintManager |
m_clrCategorySeparator | CXTPPropertyGridPaintManager |
m_clrFace | CXTPPropertyGridPaintManager |
m_clrHighlight | CXTPPropertyGridPaintManager |
m_clrHighlightText | CXTPPropertyGridPaintManager |
m_clrNonHighlightBack | CXTPPropertyGridPaintManager |
m_clrNonHighlightText | CXTPPropertyGridPaintManager |
m_clrShadow | CXTPPropertyGridPaintManager |
m_clrSplitter | CXTPPropertyGridPaintManager |
m_nHelpHeight | CXTPPropertyGridPaintManager | protected
m_nItemsBorderHeight | CXTPPropertyGridPaintManager | protected
m_nSplitterHeight | CXTPPropertyGridPaintManager | protected
m_nVerbsHeight | CXTPPropertyGridPaintManager | protected
m_pGrid | CXTPPropertyGridPaintManager | protected
m_pMetrics | CXTPPropertyGridPaintManager | protected
m_themeButton | CXTPPropertyGridPaintManager |
m_themeCombo | CXTPPropertyGridPaintManager |
m_themeTree | CXTPPropertyGridPaintManager |
MeasureItem(LPMEASUREITEMSTRUCT lpMeasureItemStruct) | CXTPPropertyGridPaintManager | virtual
OnNcCalcSize(RECT &rc) | CXTPPropertyGridPaintManager | virtual
RefreshMetrics() | CXTPPropertyGridVisualStudio2005Theme | protectedvirtual
SetItemsBorderHeight(int nHeight) | CXTPPropertyGridPaintManager | virtual
SetThinSplitter(BOOL bThinSplitter) | CXTPPropertyGridPaintManager | virtual
~CXTPPropertyGridPaintManager() | CXTPPropertyGridPaintManager | virtual


Toolkit Pro: Member List

CXTPPropertyGridItemConstraints Member List

This is the complete list of members for CXTPPropertyGridItemConstraints, including all inherited members.

AddConstraint(LPCTSTR str, DWORD_PTR dwData=0, int nImage=-1) | CXTPPropertyGridItemConstraints | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPPropertyGridItemConstraints(CXTPPropertyGridItem *pItem) | CXTPPropertyGridItemConstraints | protected
FindConstraint(LPCTSTR str) const | CXTPPropertyGridItemConstraints |
FindConstraint(DWORD_PTR dwData) const | CXTPPropertyGridItemConstraints |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAt(int nIndex) const | CXTPPropertyGridItemConstraints |
GetConstraintAt(int nIndex) const | CXTPPropertyGridItemConstraints |
GetCount() const | CXTPPropertyGridItemConstraints |
GetCurrent() const | CXTPPropertyGridItemConstraints |
IsEmpty() const | CXTPPropertyGridItemConstraints |
RemoveAll() | CXTPPropertyGridItemConstraints |
RemoveAt(int nIndex) | CXTPPropertyGridItemConstraints |
SetCurrent(int nIndex) | CXTPPropertyGridItemConstraints |
Sort() | CXTPPropertyGridItemConstraints | virtual
~CXTPPropertyGridItemConstraints() | CXTPPropertyGridItemConstraints | protected


Toolkit Pro: Member List

CColorSetWinNative Member List

This is the complete list of members for CColorSetWinNative, including all inherited members.

CXTPTabPaintManagerColorSet() | CXTPTabPaintManagerColorSet |
FillClient(CDC *pDC, CRect rc, CXTPTabManager *pTabManager) | CColorSetWinNative | virtual
FillHeader(CDC *pDC, CRect rc, CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
FillNavigateButton(CDC *pDC, CXTPTabManagerNavigateButton *pButton, CRect &rc) | CColorSetWinNative | virtual
FillPropertyButton(CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem) | CColorSetWinNative | virtual
FillStateButton(CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem) | CColorSetWinNative | virtual
GetClientColor(CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
GetItemColor(CXTPTabManagerItem *pItem) | CXTPTabPaintManagerColorSet | virtual
GradientFill(CDC *pDC, CRect rc, COLORREF clrLight, COLORREF clrDark, XTPTabPosition position) | CXTPTabPaintManagerColorSet |
IsAppThemed() const | CColorSetWinNative | virtual
m_clrActiveFilesBack | CXTPTabPaintManagerColorSet |
m_clrActiveFilesBackHighlighted | CXTPTabPaintManagerColorSet |
m_clrActiveFilesBackPressed | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyph | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyphHighlighted | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyphPressed | CXTPTabPaintManagerColorSet |
m_clrAutoHideFace | CXTPTabPaintManagerColorSet |
m_clrBorderHighlight | CXTPTabPaintManagerColorSet |
m_clrButtonBorder | CXTPTabPaintManagerColorSet |
m_clrButtonBorderHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonBorderHot | CXTPTabPaintManagerColorSet |
m_clrButtonBorderKeyTips | CXTPTabPaintManagerColorSet |
m_clrButtonBorderTabContext1 | CXTPTabPaintManagerColorSet |
m_clrButtonBorderTabContext2 | CXTPTabPaintManagerColorSet |
m_clrButtonHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonHighlightedClose | CXTPTabPaintManagerColorSet |
m_clrButtonNormal | CXTPTabPaintManagerColorSet |
m_clrButtonPressed | CXTPTabPaintManagerColorSet |
m_clrButtonSelected | CXTPTabPaintManagerColorSet |
m_clrButtonSelectedHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonSelectedPressed | CXTPTabPaintManagerColorSet |
m_clrControlFace | CXTPTabPaintManagerColorSet |
m_clrFrameBorder | CXTPTabPaintManagerColorSet |
m_clrHeaderFace | CXTPTabPaintManagerColorSet |
m_clrPaneFace | CXTPTabPaintManagerColorSet |
m_clrTabClientBack | CXTPTabPaintManagerColorSet |
m_clrTabClientBorder | CXTPTabPaintManagerColorSet |
m_clrTextDisabled | CXTPTabPaintManagerColorSet |
m_clrTextHighlight | CXTPTabPaintManagerColorSet |
m_clrTextHighlightClose | CXTPTabPaintManagerColorSet |
m_clrTextNormal | CXTPTabPaintManagerColorSet |
m_clrTextPressed | CXTPTabPaintManagerColorSet |
m_clrTextSelected | CXTPTabPaintManagerColorSet |
m_clrTextSelectedHighlighted | CXTPTabPaintManagerColorSet |
m_clrTextSelectedPressed | CXTPTabPaintManagerColorSet |
m_csExcelNormal | CXTPTabPaintManagerColorSet |
m_csExcelSelected | CXTPTabPaintManagerColorSet |
m_csPropertyPage | CXTPTabPaintManagerColorSet |
m_csPropertyPage2003 | CXTPTabPaintManagerColorSet |
m_csStateButton | CXTPTabPaintManagerColorSet |
m_pPaintManager | CXTPTabPaintManagerColorSet | protected
m_themeTabButton | CColorSetWinNative | protected
m_themeToolbar | CColorSetWinNative | protected
RefreshMetrics() | CColorSetWinNative | virtual
SelectClipRgn(CDC *pDC, CRect rcClient, CXTPTabManager *pTabManager) | CColorSetWinNative | virtual
SetTextColor(CDC *pDC, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerColorSet | virtual
~CXTPTabPaintManagerColorSet() | CXTPTabPaintManagerColorSet | virtual


Toolkit Pro: Member List

CXTPShortcutBarItem Member List

This is the complete list of members for CXTPShortcutBarItem, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPShortcutBarItem(CXTPShortcutBar *pShortcutBar, int nID, CWnd *pWnd) | CXTPShortcutBarItem | protected
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCaption() const | CXTPShortcutBarItem |
GetClientWindow() const | CXTPShortcutBarItem |
GetIconId() const | CXTPShortcutBarItem |
GetID() const | CXTPShortcutBarItem |
GetImage(int nWidth) const | CXTPShortcutBarItem |
GetItemData() const | CXTPShortcutBarItem |
GetItemRect() const | CXTPShortcutBarItem |
GetShortcutBar() const | CXTPShortcutBarItem |
GetTooltip() const | CXTPShortcutBarItem |
IsEnabled() const | CXTPShortcutBarItem |
IsExpanded() const | CXTPShortcutBarItem |
IsHidden() const | CXTPShortcutBarItem |
IsItemExpandButton() const | CXTPShortcutBarItem |
IsSelected() const | CXTPShortcutBarItem |
IsVisible() const | CXTPShortcutBarItem |
m_bEnabled | CXTPShortcutBarItem | protected
m_bExpandButton | CXTPShortcutBarItem | protected
m_bExpanded | CXTPShortcutBarItem | protected
m_bHidden | CXTPShortcutBarItem | protected
m_bNavigateButton | CXTPShortcutBarItem | protected
m_bSelected | CXTPShortcutBarItem | protected
m_bVisible | CXTPShortcutBarItem | protected
m_dwData | CXTPShortcutBarItem | protected
m_hwndChild | CXTPShortcutBarItem | protected
m_nIconId | CXTPShortcutBarItem | protected
m_nID | CXTPShortcutBarItem | protected
m_pShortcutBar | CXTPShortcutBarItem | protected
m_rcItem | CXTPShortcutBarItem | protected
m_strCaption | CXTPShortcutBarItem | protected
m_strTooltip | CXTPShortcutBarItem | protected
SetCaption(LPCTSTR strCaption) | CXTPShortcutBarItem |
SetClientWindow(CWnd *pWnd) | CXTPShortcutBarItem |
SetEnabled(BOOL bEnabled) | CXTPShortcutBarItem |
SetIconId(int nId) | CXTPShortcutBarItem |
SetID(int nID) | CXTPShortcutBarItem |
SetItemData(DWORD_PTR dwData) | CXTPShortcutBarItem |
SetSelected(BOOL bSelected) | CXTPShortcutBarItem |
SetTooltip(LPCTSTR strTooltip) | CXTPShortcutBarItem |
SetVisible(BOOL bVisible) | CXTPShortcutBarItem |


Toolkit Pro: Member List

CXTPChartPieSeriesLabelView Member List

This is the complete list of members for CXTPChartPieSeriesLabelView, including all inherited members.

AddChildView(CXTPChartElementView *pChildView) | CXTPChartElementView |
CalculateLayout(CXTPChartDeviceContext *pDC) | CXTPChartPieSeriesLabelView |
CreateConnectorDeviceCommand(CXTPChartDeviceContext *pDC) | CXTPChartPieSeriesLabelView | virtual
CreateDeviceCommand(CXTPChartDeviceContext *pDC) | CXTPChartPieSeriesLabelView | virtual
CXTPChartElementView(CXTPChartElementView *pParentView) | CXTPChartElementView |
CXTPChartElementView(CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartElementView |
CXTPChartElementView(CXTPChartContainer *pContainer) | CXTPChartElementView |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartPieSeriesLabelView(CXTPChartSeriesLabel *pLabel, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView) | CXTPChartPieSeriesLabelView |
CXTPChartPieSeriesLabelViewBase(CXTPChartSeriesLabel *pLabel, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView) | CXTPChartPieSeriesLabelViewBase | protected
GetAt(int nIndex) const | CXTPChartElementView |
GetBounds() const | CXTPChartElementView |
GetBounds(BOOL bIncludingChildren) const | CXTPChartElementView |
GetChildren() | CXTPChartElementView |
GetCount() const | CXTPChartElementView |
GetParentView() const | CXTPChartElementView |
GetPosition() const | CXTPChartPieSeriesLabelViewBase |
Is3D() const | CXTPChartObject |
m_arrChildren | CXTPChartElementView | protected
m_dLineAngle | CXTPChartPieSeriesLabelView | protected
m_pContainer | CXTPChartElementView | protected
m_pParentView | CXTPChartElementView | protected
m_ptStartPoint | CXTPChartPieSeriesLabelView | protected
m_rcBounds | CXTPChartPieSeriesLabelView | protected
~CXTPChartElementView() | CXTPChartElementView | protectedvirtual


Toolkit Pro: Member List

CXTPMarkupDefinitionBase Member List

This is the complete list of members for CXTPMarkupDefinitionBase, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPMarkupDefinitionBase(BOOL bIsColumnDefinition=FALSE) | CXTPMarkupDefinitionBase | protected
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetUserMaxSize() const | CXTPMarkupDefinitionBase |
GetUserMinSize() const | CXTPMarkupDefinitionBase |
GetUserSize() const | CXTPMarkupDefinitionBase |


Toolkit Pro: Member List

CXTPTabThemeExcel2003 Member List

This is the complete list of members for CXTPTabThemeExcel2003, including all inherited members.

AdjustClientRect(CXTPTabManager *pTabManager, CRect &rcClient) | CXTPTabPaintManagerTheme | virtual
CXTPTabPaintManagerTheme() | CXTPTabPaintManagerTheme |
CXTPTabThemeExcel2003() | CXTPTabThemeExcel2003 | inline
CXTPTabThemeFlat() | CXTPTabThemeFlat | inline
DrawSingleButton(CDC *pDC, CXTPTabManagerItem *pItem) | CXTPTabThemeExcel2003 | virtual
DrawTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl) | CXTPTabPaintManagerTheme | virtual
DrawText(CDC *pDC, CXTPTabManager *pManager, const CString &str, LPRECT lpRect, UINT nFormat) | CXTPTabPaintManagerTheme | virtual
DrawWorkspacePart(CDC *pDC, LPRECT lpRect, XTPTabWorkspacePart workspacePart) | CXTPTabPaintManagerTheme | virtual
FillButton(CDC *pDC, CXTPTabManagerItem *pItem, LPPOINT pts, int nCount, XTPTabPosition tabPosition, BOOL bAbsolute=FALSE) | CXTPTabPaintManagerTheme |
FillTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl) | CXTPTabThemeFlat | virtual
GetButtonDrawRect(const CXTPTabManagerItem *pItem) | CXTPTabThemeExcel2003 | virtual
GetButtonHeight(const CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetButtonLength(CDC *pDC, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerTheme | virtual
GetClientMargin() | CXTPTabPaintManagerTheme | virtual
GetClientRect(CRect rcControl, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetColorSet() const | CXTPTabPaintManagerTheme |
GetDefaultColorSet() | CXTPTabThemeFlat | inlinevirtual
GetHeaderClipBox(CDC *pDC, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetHeaderHeight(CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme |
GetHeaderMargin() | CXTPTabThemeExcel2003 | inlinevirtual
GetHeaderRect(CRect rcControl, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetSupportedColorSets() | CXTPTabPaintManagerTheme | inlinevirtual
m_bButtonsReverseZOrder | CXTPTabPaintManagerTheme | protected
m_nButtonHeight | CXTPTabPaintManagerTheme | protected
m_nRowMargin | CXTPTabPaintManagerTheme |
m_pPaintManager | CXTPTabPaintManagerTheme | protected
m_rcHeaderMargin | CXTPTabPaintManagerTheme |
RefreshMetrics() | CXTPTabPaintManagerTheme | virtual
RepositionTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcClient) | CXTPTabPaintManagerTheme | virtual
~CXTPTabPaintManagerTheme() | CXTPTabPaintManagerTheme | virtual


Toolkit Pro: Member List

CAppearanceSetPropertyPageSelected Member List

This is the complete list of members for CAppearanceSetPropertyPageSelected, including all inherited members.

AdjustClientRect(CXTPTabManager *pTabManager, CRect &rcClient) | CXTPTabPaintManagerTheme | virtual
CXTPTabPaintManagerTheme() | CXTPTabPaintManagerTheme |
CXTPTabThemeOffice2000() | CXTPTabThemeOffice2000 | inline
DrawSingleButton(CDC *pDC, CXTPTabManagerItem *pItem) | CAppearanceSetPropertyPageSelected | virtual
DrawTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl) | CXTPTabPaintManagerTheme | virtual
DrawText(CDC *pDC, CXTPTabManager *pManager, const CString &str, LPRECT lpRect, UINT nFormat) | CXTPTabPaintManagerTheme | virtual
DrawWorkspacePart(CDC *pDC, LPRECT lpRect, XTPTabWorkspacePart workspacePart) | CXTPTabPaintManagerTheme | virtual
FillButton(CDC *pDC, CXTPTabManagerItem *pItem, LPPOINT pts, int nCount, XTPTabPosition tabPosition, BOOL bAbsolute=FALSE) | CXTPTabPaintManagerTheme |
FillTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl) | CXTPTabThemeOffice2000 | virtual
GetButtonDrawRect(const CXTPTabManagerItem *pItem) | CXTPTabThemeOffice2000 | virtual
GetButtonHeight(const CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetButtonLength(CDC *pDC, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerTheme | virtual
GetClientMargin() | CXTPTabThemeOffice2000 | virtual
GetClientRect(CRect rcControl, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetColorSet() const | CXTPTabPaintManagerTheme |
GetDefaultColorSet() | CXTPTabThemeOffice2000 | inlinevirtual
GetHeaderClipBox(CDC *pDC, CXTPTabManager *pTabManager) | CXTPTabThemeOffice2000 | virtual
GetHeaderHeight(CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme |
GetHeaderMargin() | CXTPTabPaintManagerTheme | virtual
GetHeaderRect(CRect rcControl, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetSupportedColorSets() | CXTPTabPaintManagerTheme | inlinevirtual
m_bButtonsReverseZOrder | CXTPTabPaintManagerTheme | protected
m_nButtonHeight | CXTPTabPaintManagerTheme | protected
m_nRowMargin | CXTPTabPaintManagerTheme |
m_pPaintManager | CXTPTabPaintManagerTheme | protected
m_rcHeaderMargin | CXTPTabPaintManagerTheme |
RefreshMetrics() | CXTPTabThemeOffice2000 | virtual
RepositionTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcClient) | CXTPTabPaintManagerTheme | virtual
~CXTPTabPaintManagerTheme() | CXTPTabPaintManagerTheme | virtual


Toolkit Pro: Member List

XTP_EDIT_NMHDR_MARGINCLICKED Member List

This is the complete list of members for XTP_EDIT_NMHDR_MARGINCLICKED, including all inherited members.

nDispRow | XTP_EDIT_NMHDR_MARGINCLICKED
nmhdr | XTP_EDIT_NMHDR_MARGINCLICKED
nRow | XTP_EDIT_NMHDR_MARGINCLICKED


Toolkit Pro: XTPDirWatcher.h Source File

  • Source
  • Controls
  • Shell
XTPDirWatcher.h
Go to the documentation of this file.
1
23#if !defined(__XTPDIRWATCHER_H__)
24# define __XTPDIRWATCHER_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
114class _XTP_EXT_CLASS CXTPDirWatcher : public CXTPWinThread
115{
117 DECLARE_DYNCREATE(CXTPDirWatcher)
119public:
124 CXTPDirWatcher();
125
126protected:
131 virtual ~CXTPDirWatcher();
132
133public:
144 BOOL SetFolderPath(CWnd* pMainWnd, LPCTSTR lpszFolderPath, BOOL bWatchSubtree = FALSE);
145
154 CString GetFolderPath() const;
155
165 BOOL SetFolderData(CWnd* pMainWnd, XTP_TVITEMDATA* lpTVID);
166
176 XTP_TVITEMDATA* GetFolderData();
177
186 BOOL GetFolderData(LPCTSTR lpszFolderPath, XTP_TVITEMDATA& lpTVID);
187
196 BOOL IsPathValid(LPCTSTR lpszFolderPath);
197
202 void StopNotifications();
203
204public:
206 //{{AFX_VIRTUAL(CXTPDirWatcher)
207 virtual BOOL InitInstance();
208 //}}AFX_VIRTUAL
211protected:
217 virtual void RefreshFolder();
218
224 virtual void RefreshTree();
225
232 BOOL MonitorNotifications();
233
240 BOOL WaitPathChangedEvent();
241
242protected:
244 DECLARE_MESSAGE_MAP()
245
246 //{{AFX_MSG(CXTPDirWatcher)
247 //}}AFX_MSG
250protected:
251 HANDLE m_dwMonitorEvents[4];
252 CString m_strFolderPath;
253 XTP_TVITEMDATA m_tvid;
254 BOOL m_bWatchSubtree;
255};
256
258
259AFX_INLINE CString CXTPDirWatcher::GetFolderPath() const
260{
261 return m_strFolderPath;
262}
263AFX_INLINE XTP_TVITEMDATA* CXTPDirWatcher::GetFolderData()
264{
265 return &m_tvid;
266}
268# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
270#endif // !defined(__XTPDIRWATCHER_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPDirWatcher
The CXTPDirWatcher is a thread class that will monitor a specified path for file and directory change...
Definition XTPDirWatcher.h:115
CXTPDirWatcher::IsPathValid
BOOL IsPathValid(LPCTSTR lpszFolderPath)
Call this member function to determine if the specified path is a valid directory name.
CXTPDirWatcher::RefreshFolder
virtual void RefreshFolder()
This member function is called by the thread whenever the monitored directory list needs to be refres...
CXTPDirWatcher::StopNotifications
void StopNotifications()
Finishes Notification loop.
CXTPDirWatcher::RefreshTree
virtual void RefreshTree()
This member function is called by the thread whenever the monitored directory tree needs to be refres...
CXTPDirWatcher::GetFolderData
BOOL GetFolderData(LPCTSTR lpszFolderPath, XTP_TVITEMDATA &lpTVID)
This function constructs an XTP_TVITEMDATA structure from the specified path.
CXTPDirWatcher::~CXTPDirWatcher
virtual ~CXTPDirWatcher()
Destroys a CXTPDirWatcher object, handles cleanup and deallocation.
CXTPDirWatcher::GetFolderPath
CString GetFolderPath() const
Call this member function to retrieve the full path to the currently monitored directory.
CXTPDirWatcher::MonitorNotifications
BOOL MonitorNotifications()
Worker method with main notification loop.
CXTPDirWatcher::CXTPDirWatcher
CXTPDirWatcher()
Constructs a CXTPDirWatcher object.
CXTPDirWatcher::WaitPathChangedEvent
BOOL WaitPathChangedEvent()
Waits for the developer to set a new path to monitor.
CXTPDirWatcher::GetFolderData
XTP_TVITEMDATA * GetFolderData()
This member function is called to return a pointer to the XTP_TVITEMDATA structure for the directory ...
CXTPDirWatcher::SetFolderData
BOOL SetFolderData(CWnd *pMainWnd, XTP_TVITEMDATA *lpTVID)
Call this member function to monitor the directory using a pointer to an XTP_TVITEMDATA pointer.
CXTPDirWatcher::SetFolderPath
BOOL SetFolderPath(CWnd *pMainWnd, LPCTSTR lpszFolderPath, BOOL bWatchSubtree=FALSE)
Call this member function to monitor the directory specified by strPath.
CXTPWinThread
All XTP threads should derive from CXTPWinThread instead of CWinThread in order to ensure compatibili...
Definition XTPWinThread.h:42
XTP_TVITEMDATA
The XTP_TVITEMDATA structure is used to maintain information for a particular tree item in a CXTPShel...
Definition XTPShellPidl.h:57


Toolkit Pro: Member List

CXTPGridThemeOffice2003Luna Member List

This is the complete list of members for CXTPGridThemeOffice2003Luna, including all inherited members.

CalcColumnHeight(CDC *pDC, CXTPGridColumn *pColumn, int nTotalWidth=0) | CXTPGridPaintManager | protectedvirtual
CalculateRowHeight(CDC *pDC, const CString &strText, int nMaxWidth, BOOL bWordBreak=TRUE) | CXTPGridPaintManager | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPGridPaintManager() | CXTPGridPaintManager |
CXTPGridThemeOffice2003Luna() | CXTPGridThemeOffice2003Luna |
DrawBitmap(CDC *pDC, CXTPGridControl *pControl, CRect rcColumn, int iImage) | CXTPGridPaintManager | virtual
DrawCollapsedBitmap(CDC *pDC, const CXTPGridRow *pRow, CRect &rcBitmap) | CXTPGridPaintManager | virtual
DrawColumn(CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn, BOOL bDrawExternal=FALSE, int nShadowWidth=0) | CXTPGridPaintManager | virtual
DrawColumnBackground(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, BOOL &bColumnPressed, BOOL &bDraggingFromHeader, CXTPGridHeader *pHeader=NULL) | CXTPGridThemeOffice2003Luna | virtual
DrawColumnFooter(CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn) | CXTPGridPaintManager | virtual
DrawColumnFooterDivider(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn) | CXTPGridThemeOffice2003Luna | virtual
DrawColumnIcon(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, CRect rcIcon, int iIcon) | CXTPGridPaintManager | virtual
DrawColumnText(CDC *pDC, CRect rcText, CString strCaption, int nHeaderAlignment, BOOL bIsHeader, BOOL bColumnPressed) | CXTPGridPaintManager | virtual
DrawConnector(CDC *pDC, CPoint ptFrom, CPoint ptTo) | CXTPGridPaintManager |
DrawFocusedRow(CDC *pDC, CRect rcRow) | CXTPGridPaintManager | virtual
DrawFreezeColsDivider(CDC *pDC, const CRect &rc, CXTPGridControl *pControl, CXTPGridRow *pRow=NULL) | CXTPGridPaintManager | virtual
DrawGlyph(CDC *pDC, CRect rcColumn, int iImage) | CXTPGridPaintManager | virtual
DrawGrid(CDC *pDC, XTPGridOrientation orientation, CRect rcGrid) | CXTPGridPaintManager | virtual
DrawGridPattern(CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush) | CXTPGridPaintManager | protectedvirtual
DrawGridPattern(CDC *pDC, CXTPBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush) | CXTPGridPaintManager | protectedvirtual
DrawGridPattern(CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr) | CXTPGridPaintManager | protectedvirtual
DrawGroupRow(CDC *pDC, CXTPGridGroupRow *pRow, CRect rcRow, XTP_GRIDRECORDITEM_METRICS *pMetrics) | CXTPGridPaintManager | virtual
DrawHorizontalLine(CDC *pDC, int xPos, int yPos, int cx, COLORREF clr) | CXTPGridPaintManager |
DrawInplaceButton(CDC *pDC, CXTPGridInplaceButton *pButton) | CXTPGridPaintManager | virtual
DrawInplaceButtonFrame(CDC *pDC, CXTPGridInplaceButton *pButton) | CXTPGridPaintManager | protectedvirtual
DrawInplaceButtonIcon(CDC *pDC, CXTPGridInplaceButton *pButton) | CXTPGridPaintManager | protectedvirtual
DrawInplaceComboButton(CDC *pDC, CRect *pRc) | CXTPGridPaintManager | virtual
DrawInplaceExpandButton(CDC *pDC, CRect *pRc) | CXTPGridPaintManager | virtual
DrawInplaceSpinButton(CDC *pDC, CRect *pRc) | CXTPGridPaintManager | virtual
DrawItemBitmap(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CRect &rcItem, int nImage) | CXTPGridPaintManager | virtual
DrawItemCaption(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics) | CXTPGridPaintManager | virtual
DrawItemControl(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CXTPGridRecordItemControl *pControl, CRect &rcItem) | CXTPGridPaintManager | virtual
DrawLink(int *pnCurrDrawPos, XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CXTPGridHyperlink *pHyperlink, CString strText, CRect rcLink, int nFlag, BOOL bTrim=FALSE) | CXTPGridPaintManager | protectedvirtual
DrawMultiLineText(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, BOOL bWordBreak=TRUE) | CXTPGridPaintManager | protectedvirtual
DrawNoGroupByText(CDC *pDC, CRect rcItem) | CXTPGridPaintManager | virtual
DrawRowNumber(CDC *pDC, CRect rcNumber, CXTPGridRow *pRow) | CXTPGridPaintManager | virtual
DrawSectionDivider(CDC *pDC, const CRect &rc, XTPGridSectionDividerPosition dividerPosition, XTPGridSectionDividerStyle dividerStyle, CXTPPaintManagerColor dividerColor) | CXTPGridThemeOffice2003Luna |
DrawShellIcon(CDC *pDC, CRect rcColumn, int iImage) | CXTPGridPaintManager | virtual
DrawSingleLineText(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nStartPos, int nEndPos, int nActualWidth) | CXTPGridPaintManager | protectedvirtual
DrawString(int *pnCurrDrawPos, CDC *pDC, const CString &strDraw, CRect rcDraw, UINT nFormat) | CXTPGridPaintManager | protectedvirtual
DrawTextLine(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nFlag, int &nCharCounter, int &nHyperlinkCounter) | CXTPGridPaintManager | protectedvirtual
DrawTreeStructure(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CRect rcItem, CSize sizeGlyph) | CXTPGridPaintManager | virtual
DrawTriangle(CDC *pDC, CRect rcTriangle, BOOL bToDown, BOOL bDraggingFromHeader, int nShadowWidth, BOOL bColumnPressed) | CXTPGridPaintManager | virtual
DrawVerticalLine(CDC *pDC, int xPos, int yPos, int cy, COLORREF clr) | CXTPGridPaintManager |
DrawVerticalTimeLineMarker(CDC *pDC, int xPos, CXTPGridControl *pControl, COLORREF color=RGB(0, 255, 0)) | CXTPGridPaintManager | virtual
EnablePreviewMode(BOOL bIsPreviewMode) | CXTPGridPaintManager |
FillFooter(CDC *pDC, CRect rcFooter) | CXTPGridThemeOffice2003Luna | virtual
FillGroupByControl(CDC *pDC, CRect &rcGroupBy) | CXTPGridPaintManager | virtual
FillGroupRowMetrics(CXTPGridGroupRow *pRow, XTP_GRIDRECORDITEM_METRICS *pMetrics, BOOL bPrinting) | CXTPGridPaintManager | virtual
FillHeaderControl(CDC *pDC, CRect rcHeader) | CXTPGridPaintManager | virtual
FillIndent(CDC *pDC, CRect rcRow) | CXTPGridPaintManager | virtual
FillItemShade(CDC *pDC, CRect rcItem) | CXTPGridPaintManager | virtual
FillRow(CDC *pDC, CXTPGridRow *pRow, CRect rcRow) | CXTPGridPaintManager | virtual
FindRowAdjacentToMerged(const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, BOOL bUpward) | CXTPGridPaintManager |
FindRowAdjacentToMergedEx(const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, int &nAdjRowIndex, BOOL bUpward) | CXTPGridPaintManager |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetColumnOffice2007CustomThemeBaseColor() const | CXTPGridPaintManager |
GetColumnStyle() const | CXTPGridPaintManager |
GetControlBackColor(CXTPGridControl *pControl) | CXTPGridPaintManager | virtual
GetFooterHeight(CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0) | CXTPGridPaintManager | virtual
GetFreezeColsDividerStyle() const | CXTPGridPaintManager |
GetGlyphs() const | CXTPGridPaintManager |
GetHeaderHeight() | CXTPGridPaintManager | virtual
GetHeaderHeight(CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0) | CXTPGridPaintManager | virtual
GetItemHeight(XTP_GRIDRECORDITEM_DRAWARGS &drawArgs, int nWidth) | CXTPGridPaintManager |
GetMaxPreviewLines() | CXTPGridPaintManager |
GetPreviewItemHeight(CDC *pDC, CXTPGridRow *pRow, int nWidth, int nHeight) | CXTPGridPaintManager | virtual
GetPreviewLinesCount(CDC *pDC, CRect &rcText, const CString &strText) | CXTPGridPaintManager |
GetRowHeight(CDC *pDC, CXTPGridRow *pRow) | CXTPGridPaintManager | virtual
GetRowHeight(CDC *pDC, CXTPGridRow *pRow, int nTotalWidth) | CXTPGridPaintManager | virtual
GetRowHeightEx(CDC *pDC, CXTPGridRow *pRow, int nTotalWidth, const BOOL firstLevel=TRUE) | CXTPGridPaintManager |
GetSectionDividerHeight(XTPGridFixedRowsDividerStyle dividerStyle) | CXTPGridPaintManager |
GetTextFont() | CXTPGridPaintManager |
IsColumHotTrackingEnabled() const | CXTPGridThemeOffice2003Luna | virtual
IsColumnPlusMinusSign() const | CXTPGridPaintManager |
IsColumnWidthWYSIWYG() const | CXTPGridPaintManager |
IsDrawGridForEmptySpace() const | CXTPGridPaintManager |
IsFixedInplaceButtonHeight() const | CXTPGridPaintManager |
IsFixedRowHeight() const | CXTPGridPaintManager |
IsGridVisible(BOOL bVertical) const | CXTPGridPaintManager |
IsGridVisible(XTPGridOrientation orientation) const | CXTPGridPaintManager |
IsLastColumnWidthWYSIWYG() const | CXTPGridPaintManager |
IsPreviewMode() const | CXTPGridPaintManager |
IsPrintGroupRowIcon() const | CXTPGridPaintManager |
IsShowWYSIWYGMarkers() const | CXTPGridPaintManager |
IsUseDropMarker() const | CXTPGridPaintManager |
LoadGlyphs() | CXTPGridPaintManager | virtual
m_arStartCol | CXTPGridPaintManager |
m_bAllowMergeCells | CXTPGridPaintManager |
m_bBaseTreeIndent | CXTPGridPaintManager |
m_bCleanTooltip | CXTPGridPaintManager |
m_bColumnPlusMinusSign | CXTPGridPaintManager | protected
m_bColumnWidthWYSIWYG | CXTPGridPaintManager | protected
m_bCompactText | CXTPGridPaintManager |
m_bDrawGridForEmptySpace | CXTPGridPaintManager | protected
m_bFixedInplaceButtonHeight | CXTPGridPaintManager | protected
m_bFixedRowHeight | CXTPGridPaintManager | protected
m_bForceDynamicMarkupForCell | CXTPGridPaintManager |
m_bForceShowDropMarker | CXTPGridPaintManager |
m_bForceShowTooltip | CXTPGridPaintManager |
m_bGrayIfDisable | CXTPGridPaintManager |
m_bGroupRowTextBold | CXTPGridPaintManager |
m_bHideSelection | CXTPGridPaintManager |
m_bHotTracking | CXTPGridPaintManager |
m_bInvertColumnOnClick | CXTPGridPaintManager |
m_bIsPreviewMode | CXTPGridPaintManager | protected
m_bLastColumnWidthWYSIWYG | CXTPGridPaintManager | protected
m_bMakeUpper | CXTPGridPaintManager |
m_bMoveScrollbarOnFixedColumnsIndent | CXTPGridPaintManager |
m_bPrintGroupRowIcon | CXTPGridPaintManager | protected
m_bPrintPageRectangle | CXTPGridPaintManager |
m_bPrintSortTriangle | CXTPGridPaintManager |
m_bPrintVirtualPageNumber | CXTPGridPaintManager |
m_bPrintWatermark | CXTPGridPaintManager |
m_bRecOrRowNum | CXTPGridPaintManager |
m_bRevertAlignment | CXTPGridPaintManager |
m_bShadeGroupHeadings | CXTPGridPaintManager |
m_bShadeSortColumn | CXTPGridPaintManager |
m_bShowLockIcon | CXTPGridPaintManager |
m_bShowNonActiveInPlaceButton | CXTPGridPaintManager |
m_bShowWYSIWYGMarkers | CXTPGridPaintManager | protected
m_bSortTriangleOffsetFromRight | CXTPGridPaintManager |
m_bThemedInplaceButtons | CXTPGridPaintManager |
m_bUseAlternativeBackground | CXTPGridPaintManager |
m_bUseDropMarker | CXTPGridPaintManager |
m_bUseEditTextAlignment | CXTPGridPaintManager |
m_bUseGroupRowSelectionState | CXTPGridPaintManager |
m_bUseShellIcon | CXTPGridPaintManager |
m_clrAlternativeBackground | CXTPGridPaintManager |
m_clrBoldText | CXTPGridPaintManager |
m_clrBoldTextHighlight | CXTPGridPaintManager |
m_clrBtnFace | CXTPGridPaintManager |
m_clrBtnFacePressed | CXTPGridPaintManager |
m_clrBtnText | CXTPGridPaintManager |
m_clrCaptionText | CXTPGridPaintManager |
m_clrCaptionTextPressed | CXTPGridPaintManager |
m_clrColumnOffice2007CustomTheme | CXTPGridPaintManager |
m_clrConnector | CXTPGridPaintManager |
m_clrControlBack | CXTPGridPaintManager |
m_clrControlDark | CXTPGridPaintManager |
m_clrControlLightLight | CXTPGridPaintManager |
m_clrDisableBitmapDarkest | CXTPGridPaintManager |
m_clrDisableBitmapLightest | CXTPGridPaintManager |
m_clrFormulaSubSum | CXTPGridPaintManager |
m_clrFormulaSum | CXTPGridPaintManager |
m_clrFreezeColsDivider | CXTPGridPaintManager |
m_clrGradientColumnSeparator | CXTPGridPaintManager |
m_clrGradientColumnShadow | CXTPGridPaintManager |
m_clrGroupBoxBack | CXTPGridPaintManager |
m_clrGroupRowText | CXTPGridPaintManager |
m_clrGroupShadeBack | CXTPGridPaintManager |
m_clrGroupShadeBorder | CXTPGridPaintManager |
m_clrGroupShadeText | CXTPGridPaintManager |
m_clrHeaderControl | CXTPGridPaintManager |
m_clrHighlight | CXTPGridPaintManager |
m_clrHighlightText | CXTPGridPaintManager |
m_clrHotDivider | CXTPGridPaintManager |
m_clrIndentControl | CXTPGridPaintManager |
m_clrItemShade | CXTPGridPaintManager |
m_clrPreviewText | CXTPGridPaintManager |
m_clrSelectedRow | CXTPGridPaintManager |
m_clrSelectedRowText | CXTPGridPaintManager |
m_clrWindowText | CXTPGridPaintManager |
m_columnStyle | CXTPGridPaintManager | protected
m_crlNoGroupByText | CXTPGridPaintManager |
m_grcGradientColumn | CXTPGridPaintManager |
m_grcGradientColumnHot | CXTPGridPaintManager |
m_grcGradientColumnPushed | CXTPGridPaintManager |
m_iRecOrRowStart | CXTPGridPaintManager |
m_nBaseParentRecordIndent | CXTPGridPaintManager |
m_nFixedColumnsIndent | CXTPGridPaintManager |
m_nFooterHeight | CXTPGridPaintManager | protected
m_nFreezeColsDividerStyle | CXTPGridPaintManager | protected
m_nGridLineStylePreviousH | CXTPGridPaintManager | protected
m_nGridLineStylePreviousV | CXTPGridPaintManager | protected
m_nGroupGridLineHeight | CXTPGridPaintManager | protected
m_nGroupGridLineStyle | CXTPGridPaintManager | protected
m_nHeaderHeight | CXTPGridPaintManager | protected
m_nMaxPreviewLines | CXTPGridPaintManager | protected
m_nResizingWidth | CXTPGridPaintManager | protected
m_nRowHeight | CXTPGridPaintManager | protected
m_nRowHeightDefault | CXTPGridPaintManager |
m_nTextIndentForGroupRowsWithNoIcon | CXTPGridPaintManager |
m_nTreeColumnLineLength | CXTPGridPaintManager |
m_nTreeIndent | CXTPGridPaintManager |
m_nTreeStructureStyle | CXTPGridPaintManager |
m_nTreeTextIndent | CXTPGridPaintManager |
m_nTreeTextIndentGroupRow | CXTPGridPaintManager |
m_nTreeTextIndentRowChildren | CXTPGridPaintManager |
m_nTreeTextIndentRowParent | CXTPGridPaintManager |
m_pControl | CXTPGridPaintManager | protected
m_pGlyphs | CXTPGridPaintManager | protected
m_pHyperlinkHoverStyle | CXTPGridPaintManager |
m_pHyperlinkStyle | CXTPGridPaintManager |
m_pMarkupUIElement_NoGroupBy | CXTPGridPaintManager | protected
m_PrintPageWidth | CXTPGridPaintManager |
m_rcPreviewIndent | CXTPGridPaintManager |
m_RecordNumberWidth | CXTPGridPaintManager |
m_strCollapse | CXTPGridPaintManager |
m_strDecreasing | CXTPGridPaintManager |
m_strExpand | CXTPGridPaintManager |
m_strIncreasing | CXTPGridPaintManager |
m_strMarkupUIElement_NoGroupBy | CXTPGridPaintManager | protected
m_strNoFieldsAvailable | CXTPGridPaintManager |
m_strNoGroupBy | CXTPGridPaintManager |
m_strNoItems | CXTPGridPaintManager |
m_strSortBy | CXTPGridPaintManager |
m_szGlyph | CXTPGridPaintManager | protected
m_themeButton | CXTPGridPaintManager | protected
m_themeCombo | CXTPGridPaintManager | protected
m_themeHeader | CXTPGridPaintManager | protected
m_themeSpin | CXTPGridPaintManager | protected
m_treeStructureStyle | CXTPGridPaintManager |
m_xtpBrushGroupGridLineStyle | CXTPGridPaintManager | protected
m_xtpBrushHorizontalGrid | CXTPGridPaintManager | protected
m_xtpBrushTreeStructure | CXTPGridPaintManager | protected
m_xtpBrushVeriticalGrid | CXTPGridPaintManager | protected
m_xtpFontBoldText | CXTPGridPaintManager |
m_xtpFontCaption | CXTPGridPaintManager |
m_xtpFontPreview | CXTPGridPaintManager |
m_xtpFontText | CXTPGridPaintManager |
OnDrawAction(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs) | CXTPGridPaintManager | virtual
RecalcTotalHightOfMergedRows(CXTPGridColumns *pColumns, CDC *pDC, CXTPGridRow *pRow, int nRowHeight, int nTotalWidth) | CXTPGridPaintManager |
RefreshMetrics() | CXTPGridThemeOffice2003Luna | virtual
SetCaptionFont(LOGFONT &lf) | CXTPGridPaintManager |
SetColumnOffice2007CustomThemeBaseColor(COLORREF clrBaseColor) | CXTPGridPaintManager |
SetColumnPlusMinusSign(BOOL bDraw) | CXTPGridPaintManager |
SetColumnStyle(XTPGridColumnStyle columnStyle) | CXTPGridPaintManager |
SetColumnWidthWYSIWYG(BOOL bColumnWidthWYSIWYG) | CXTPGridPaintManager |
SetDrawGridForEmptySpace(BOOL bDrawGrid) | CXTPGridPaintManager |
SetFixedRowHeight(BOOL bFixedRowHeight) | CXTPGridPaintManager |
SetFreezeColsDividerStyle(int nStyle) | CXTPGridPaintManager |
SetGridControl(CXTPGridControl *pControl) | CXTPGridPaintManager | virtual
SetHeaderHeight(int nHeight) | CXTPGridPaintManager | virtual
SetInplaceButtonHeight(BOOL bFixedInplaceButtonHeight) | CXTPGridPaintManager |
SetLastColumnWidthWYSIWYG(BOOL bColumnWidthWYSIWYG) | CXTPGridPaintManager |
SetMaxPreviewLines(int nMaxLines) | CXTPGridPaintManager |
SetPreviewIndent(int nLeft, int nTop, int nRight, int nBottom) | CXTPGridPaintManager |
SetPrintGroupRowIcon(BOOL bDraw) | CXTPGridPaintManager |
SetTextFont(LOGFONT &lf) | CXTPGridPaintManager |
ShowWYSIWYGMarkers(BOOL bSet) | CXTPGridPaintManager |
~CXTPGridPaintManager() | CXTPGridPaintManager | virtual


Toolkit Pro: Member List

CXTPTabColorSetVisualStudio2015 Member List

This is the complete list of members for CXTPTabColorSetVisualStudio2015, including all inherited members.

CXTPTabPaintManagerColorSet() | CXTPTabPaintManagerColorSet |
FillClient(CDC *pDC, CRect rc, CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
FillHeader(CDC *pDC, CRect rc, CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
FillNavigateButton(CDC *pDC, CXTPTabManagerNavigateButton *pButton, CRect &rc) | CXTPTabColorSetVisualStudio2015 | virtual
FillPropertyButton(CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem) | CXTPTabColorSetVisualStudio2015 | virtual
FillStateButton(CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerColorSet | virtual
GetClientColor(CXTPTabManager *pTabManager) | CXTPTabColorSetVisualStudio2015 | virtual
GetItemColor(CXTPTabManagerItem *pItem) | CXTPTabColorSetVisualStudio2015 | virtual
GradientFill(CDC *pDC, CRect rc, COLORREF clrLight, COLORREF clrDark, XTPTabPosition position) | CXTPTabPaintManagerColorSet |
IsAppThemed() const | CXTPTabPaintManagerColorSet | virtual
m_clrActiveFilesBack | CXTPTabPaintManagerColorSet |
m_clrActiveFilesBackHighlighted | CXTPTabPaintManagerColorSet |
m_clrActiveFilesBackPressed | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyph | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyphHighlighted | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyphPressed | CXTPTabPaintManagerColorSet |
m_clrAutoHideFace | CXTPTabPaintManagerColorSet |
m_clrBorderHighlight | CXTPTabPaintManagerColorSet |
m_clrButtonBorder | CXTPTabPaintManagerColorSet |
m_clrButtonBorderHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonBorderHot | CXTPTabPaintManagerColorSet |
m_clrButtonBorderKeyTips | CXTPTabPaintManagerColorSet |
m_clrButtonBorderTabContext1 | CXTPTabPaintManagerColorSet |
m_clrButtonBorderTabContext2 | CXTPTabPaintManagerColorSet |
m_clrButtonHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonHighlightedClose | CXTPTabPaintManagerColorSet |
m_clrButtonNormal | CXTPTabPaintManagerColorSet |
m_clrButtonPressed | CXTPTabPaintManagerColorSet |
m_clrButtonSelected | CXTPTabPaintManagerColorSet |
m_clrButtonSelectedHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonSelectedPressed | CXTPTabPaintManagerColorSet |
m_clrControlFace | CXTPTabPaintManagerColorSet |
m_clrFrameBorder | CXTPTabPaintManagerColorSet |
m_clrHeaderFace | CXTPTabPaintManagerColorSet |
m_clrPaneFace | CXTPTabPaintManagerColorSet |
m_clrTabClientBack | CXTPTabPaintManagerColorSet |
m_clrTabClientBorder | CXTPTabPaintManagerColorSet |
m_clrTextDisabled | CXTPTabPaintManagerColorSet |
m_clrTextHighlight | CXTPTabPaintManagerColorSet |
m_clrTextHighlightClose | CXTPTabPaintManagerColorSet |
m_clrTextNormal | CXTPTabPaintManagerColorSet |
m_clrTextPressed | CXTPTabPaintManagerColorSet |
m_clrTextSelected | CXTPTabPaintManagerColorSet |
m_clrTextSelectedHighlighted | CXTPTabPaintManagerColorSet |
m_clrTextSelectedPressed | CXTPTabPaintManagerColorSet |
m_csExcelNormal | CXTPTabPaintManagerColorSet |
m_csExcelSelected | CXTPTabPaintManagerColorSet |
m_csPropertyPage | CXTPTabPaintManagerColorSet |
m_csPropertyPage2003 | CXTPTabPaintManagerColorSet |
m_csStateButton | CXTPTabPaintManagerColorSet |
m_pPaintManager | CXTPTabPaintManagerColorSet | protected
RefreshMetrics() | CXTPTabColorSetVisualStudio2015 | virtual
SelectClipRgn(CDC *pDC, CRect rcClient, CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
SetTextColor(CDC *pDC, CXTPTabManagerItem *pItem) | CXTPTabColorSetVisualStudio2015 | virtual
~CXTPTabPaintManagerColorSet() | CXTPTabPaintManagerColorSet | virtual


Toolkit Pro: XTPCalendarWeekViewDay.h Source File

  • Source
  • Calendar
XTPCalendarWeekViewDay.h
Go to the documentation of this file.
1
22#if !defined(__XTPCALENDARWEEKVIEWDAY_H_)
23# define __XTPCALENDARWEEKVIEWDAY_H_
24
25# if _MSC_VER > 1000
26# pragma once
27# endif // _MSC_VER > 1000
28
29# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
30
31class CXTPCalendarWeekView;
32class CXTPCalendarWeekViewDay;
33class CXTPCalendarWeekViewEvent;
34
47class _XTP_EXT_CLASS CXTPCalendarWeekViewGroup
48 : public CXTPCalendarViewGroupT<CXTPCalendarWeekViewDay, CXTPCalendarWeekViewEvent,
49 CXTPCalendarWeekViewGroup>
50{
51public:
56 typedef CXTPCalendarViewGroupT<CXTPCalendarWeekViewDay, CXTPCalendarWeekViewEvent,
57 CXTPCalendarWeekViewGroup>
58 TBase;
59
67 CXTPCalendarWeekViewGroup(CXTPCalendarWeekViewDay* pViewDay);
68
76 virtual ~CXTPCalendarWeekViewGroup();
77
78protected:
91 virtual void FillHitTestEx(XTP_CALENDAR_HITTESTINFO* pHitTest) const;
92
93private:
103 virtual CXTPCalendarWeekViewGroup* GetPThis();
104};
105
106AFX_INLINE CXTPCalendarWeekViewGroup* CXTPCalendarWeekViewGroup::GetPThis()
107{
108 return this;
109}
110
128class _XTP_EXT_CLASS CXTPCalendarWeekViewDay
129 : public CXTPCalendarViewDayT<CXTPCalendarWeekView, CXTPCalendarWeekViewGroup,
130 XTP_CALENDAR_HITTESTINFO, CXTPCalendarWeekViewDay>
131{
133 friend class CXTPCalendarWeekViewEvent;
134 DECLARE_DYNAMIC(CXTPCalendarWeekViewDay)
136public:
141 typedef CXTPCalendarViewDayT<CXTPCalendarWeekView, CXTPCalendarWeekViewGroup,
142 XTP_CALENDAR_HITTESTINFO, CXTPCalendarWeekViewDay>
143 TBase;
144
154 CXTPCalendarWeekViewDay(CXTPCalendarWeekView* pWeekView);
155
163 virtual ~CXTPCalendarWeekViewDay();
164
177 virtual void FillHitTestEx(XTP_CALENDAR_HITTESTINFO* pInfo) const;
178
195 virtual BOOL HitTestEx(CPoint pt, XTP_CALENDAR_HITTESTINFO* pHitTest) const;
196
210 virtual void AdjustLayout(CDC* pDC, const CRect& rcDay);
211
225 virtual void AdjustLayout2(CDC* pDC, const CRect& rcDay);
226
239 virtual void Draw(CDC* pDC);
240
248 CRect GetDayEventsRect() const;
249
256 virtual CString GetCaption() const;
257
258protected:
275 virtual BOOL OnLButtonDown(UINT nFlags, CPoint point);
276
291 virtual void OnMouseMove(UINT nFlags, CPoint point);
292
299 virtual CXTPCalendarWeekViewDay* GetPThis();
300};
302
303AFX_INLINE CXTPCalendarWeekViewDay* CXTPCalendarWeekViewDay::GetPThis()
304{
305 return this;
306}
307
308# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
309#endif // !defined(__XTPCALENDARWEEKVIEWDAY_H_)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCalendarViewDayT
This class template customizes, overrides and implements some functionality for the CXTPCalendarViewD...
Definition XTPCalendarViewDay.h:1077
CXTPCalendarViewGroupT
This class template customizes, overrides and implements some functionality for the CXTPCalendarViewG...
Definition XTPCalendarViewDay.h:1257
CXTPCalendarViewGroupT::GetPThis
virtual _TPThis * GetPThis()=0
Call this member function to obtain the typed pointer to the last derived class in the class hierarch...
CXTPCalendarWeekViewDay
This class represents a day view portion of the CalendarWeekView.
Definition XTPCalendarWeekViewDay.h:131
CXTPCalendarWeekViewDay::OnLButtonDown
virtual BOOL OnLButtonDown(UINT nFlags, CPoint point)
This member function is used to process left mouse button events.
CXTPCalendarWeekViewDay::FillHitTestEx
virtual void FillHitTestEx(XTP_CALENDAR_HITTESTINFO *pInfo) const
This member function is used to fill an XTP_CALENDAR_HITTESTINFO structure.
CXTPCalendarWeekViewDay::GetCaption
virtual CString GetCaption() const
This member function is used to obtain a single day's view caption.
CXTPCalendarWeekViewDay::GetPThis
virtual CXTPCalendarWeekViewDay * GetPThis()
This member function is used to obtain a pointer to itself.
Definition XTPCalendarWeekViewDay.h:303
CXTPCalendarWeekViewDay::Draw
virtual void Draw(CDC *pDC)
This member function is used to draw the view content using the specified device context.
CXTPCalendarWeekViewDay::GetDayEventsRect
CRect GetDayEventsRect() const
This function is used to obtain a portion of a day rectangle used to draw event views.
CXTPCalendarWeekViewDay::OnMouseMove
virtual void OnMouseMove(UINT nFlags, CPoint point)
This member function is used to process mouse movement events.
CXTPCalendarWeekViewDay::AdjustLayout
virtual void AdjustLayout(CDC *pDC, const CRect &rcDay)
This member function is used to adjust the view's layout depending on the provided rectangle and also...
CXTPCalendarWeekViewDay::AdjustLayout2
virtual void AdjustLayout2(CDC *pDC, const CRect &rcDay)
This member function is used to adjust the view's layout depending on the provided rectangle and also...
CXTPCalendarWeekViewDay::TBase
CXTPCalendarViewDayT< CXTPCalendarWeekView, CXTPCalendarWeekViewGroup, XTP_CALENDAR_HITTESTINFO, CXTPCalendarWeekViewDay > TBase
Base class type definition.
Definition XTPCalendarWeekViewDay.h:143
CXTPCalendarWeekViewDay::~CXTPCalendarWeekViewDay
virtual ~CXTPCalendarWeekViewDay()
Default class destructor.
CXTPCalendarWeekViewDay::CXTPCalendarWeekViewDay
CXTPCalendarWeekViewDay(CXTPCalendarWeekView *pWeekView)
Default object constructor.
CXTPCalendarWeekViewDay::HitTestEx
virtual BOOL HitTestEx(CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const
This member function is used to determine which view item, if any, is at the specified position index...
CXTPCalendarWeekViewEvent
This class represents an event view portion of the CalendarWeekViewDay.
Definition XTPCalendarWeekViewEvent.h:58
CXTPCalendarWeekViewGroup
This class represents a single resource view portion of the Calendar Week View.
Definition XTPCalendarWeekViewDay.h:50
CXTPCalendarWeekViewGroup::FillHitTestEx
virtual void FillHitTestEx(XTP_CALENDAR_HITTESTINFO *pHitTest) const
This member function is used to fill an XTP_CALENDAR_HITTESTINFO structure.
CXTPCalendarWeekViewGroup::TBase
CXTPCalendarViewGroupT< CXTPCalendarWeekViewDay, CXTPCalendarWeekViewEvent, CXTPCalendarWeekViewGroup > TBase
Base class type definition.
Definition XTPCalendarWeekViewDay.h:58
CXTPCalendarWeekViewGroup::CXTPCalendarWeekViewGroup
CXTPCalendarWeekViewGroup(CXTPCalendarWeekViewDay *pViewDay)
Default object constructor.
CXTPCalendarWeekViewGroup::~CXTPCalendarWeekViewGroup
virtual ~CXTPCalendarWeekViewGroup()
Default class destructor.
CXTPCalendarWeekView
This class implements a specific view portion of the Calendar control - called Week view.
Definition XTPCalendarWeekView.h:54
XTP_CALENDAR_HITTESTINFO
Basic set of parameters transferred from calendar items to mouse handlers.
Definition XTPCalendarDefines.h:856


Toolkit Pro: XTPFlowGraphSelectedElements.h Source File

  • Source
  • FlowGraph
XTPFlowGraphSelectedElements.h
Go to the documentation of this file.
1
23#if !defined(__XTPFLOWGRAPHSELECTEDELEMENTS_H__)
24# define __XTPFLOWGRAPHSELECTEDELEMENTS_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPFlowGraphControl;
34class CXTPFlowGraphPage;
35
45class _XTP_EXT_CLASS CXTPFlowGraphSelectedElements : public CXTPCmdTarget
46{
47public:
53 CXTPFlowGraphSelectedElements(CXTPFlowGraphPage* pPage);
59 virtual ~CXTPFlowGraphSelectedElements();
60
61public:
66 void Clear();
67
74 void SetSelection(CXTPFlowGraphElement* pElement);
81 void AddSelection(CXTPFlowGraphElement* pElement);
82
89 void Remove(CXTPFlowGraphElement* pElement);
95 void RemoveAt(int nIndex);
96
103 int GetCount() const;
104
112 CXTPFlowGraphElement* GetAt(int nIndex) const;
113
114protected:
115 CArray<CXTPFlowGraphElement*, CXTPFlowGraphElement*> m_arrSelectedElements;
119 CXTPFlowGraphPage* m_pPage;
121# ifdef _XTP_ACTIVEX
124 DECLARE_DISPATCH_MAP()
125 DECLARE_INTERFACE_MAP()
126
127 DECLARE_OLETYPELIB_EX(CXTPFlowGraphSelectedElements)
128 DECLARE_ENUM_VARIANT(CXTPFlowGraphSelectedElements)
129
130 afx_msg int OleGetItemCount();
131 afx_msg LPDISPATCH OleGetItem(int nIndex);
132 afx_msg void OleAddSelection(LPDISPATCH lpDisp);
133 afx_msg void OleRemove(LPDISPATCH lpDisp);
134
136# endif
137};
138
139AFX_INLINE int CXTPFlowGraphSelectedElements::GetCount() const
140{
141 return (int)m_arrSelectedElements.GetSize();
142}
143AFX_INLINE CXTPFlowGraphElement* CXTPFlowGraphSelectedElements::GetAt(int nIndex) const
144{
145 return nIndex >= 0 && nIndex < m_arrSelectedElements.GetSize() ? m_arrSelectedElements[nIndex]
146 : NULL;
147}
149# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
150#endif //#if !defined(__XTPFLOWGRAPHSELECTEDELEMENTS_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPFlowGraphControl
Flow Graph Control.
Definition XTPFlowGraphControl.h:173
CXTPFlowGraphElement
Base class for all elements in the flow graph.
Definition XTPFlowGraphElement.h:46
CXTPFlowGraphPage
Represents a page in the flow graph.
Definition XTPFlowGraphPage.h:54
CXTPFlowGraphSelectedElements
Collection of selected elements in the flow graph.
Definition XTPFlowGraphSelectedElements.h:46
CXTPFlowGraphSelectedElements::GetCount
int GetCount() const
Retrieves the number of elements in the current selection.
Definition XTPFlowGraphSelectedElements.h:139
CXTPFlowGraphSelectedElements::Remove
void Remove(CXTPFlowGraphElement *pElement)
Removes an element from the current selection.
CXTPFlowGraphSelectedElements::m_pPage
CXTPFlowGraphPage * m_pPage
Pointer to the page that the selected elements are dispalyed on.
Definition XTPFlowGraphSelectedElements.h:119
CXTPFlowGraphSelectedElements::AddSelection
void AddSelection(CXTPFlowGraphElement *pElement)
Adds an element to the current selection.
CXTPFlowGraphSelectedElements::GetAt
CXTPFlowGraphElement * GetAt(int nIndex) const
Definition XTPFlowGraphSelectedElements.h:143
CXTPFlowGraphSelectedElements::Clear
void Clear()
Removes all elements from the current selection.
CXTPFlowGraphSelectedElements::m_arrSelectedElements
CArray< CXTPFlowGraphElement *, CXTPFlowGraphElement * > m_arrSelectedElements
Collection of selected elements.
Definition XTPFlowGraphSelectedElements.h:115
CXTPFlowGraphSelectedElements::~CXTPFlowGraphSelectedElements
virtual ~CXTPFlowGraphSelectedElements()
Destroys a CXTPFlowGraphSelectedElements object, handles cleanup and deallocation.
CXTPFlowGraphSelectedElements::SetSelection
void SetSelection(CXTPFlowGraphElement *pElement)
Sets the current selection to a specified element.
CXTPFlowGraphSelectedElements::RemoveAt
void RemoveAt(int nIndex)
Removes the element at a specified index from the current selection.
CXTPFlowGraphSelectedElements::CXTPFlowGraphSelectedElements
CXTPFlowGraphSelectedElements(CXTPFlowGraphPage *pPage)
Constructs a CXTPFlowGraphSelectedElements object.


Toolkit Pro: XTPChartPieDiagram.h Source File

  • Source
  • Chart
  • Styles
  • Pie
XTPChartPieDiagram.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTPIEDIAGRAM_H__)
24# define __XTPCHARTPIEDIAGRAM_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Chart/Styles/Pie/Base/XTPChartPieDiagramBase.h"
32# include "Chart/Styles/Pie/2D/XTPChart2dPieDiagram.h"
33
34// CXTPChart2dPieDiagram is necessary for naming consistency.
35typedef CXTPChartPieDiagram CXTPChart2dPieDiagram;
37#endif //#if !defined(__XTPCHARTPIEDIAGRAM_H__)
XTPChart2dPieDiagram.h
XTPChartPieDiagramBase.h
CXTPChartPieDiagram
This class abstracts the pie diagram.
Definition XTPChart2dPieDiagram.h:48


Toolkit Pro: Member List

CXTPChartDiagram Member List

This is the complete list of members for CXTPChartDiagram, including all inherited members.

CalculateSeriesLayout(CXTPChartDeviceContext *pDC, CXTPChartDiagramView *pView) | CXTPChartDiagram | virtual
CreateView(CXTPChartDeviceContext *pDC, CXTPChartElementView *pParent) | CXTPChartDiagram | virtual
CXTPChartDiagram() | CXTPChartDiagram | protected
CXTPChartElement() | CXTPChartElement |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartPanel() | CXTPChartPanel |
DoPropExchange(CXTPPropExchange *pPX) | CXTPChartDiagram | virtual
GetAppearance() const | CXTPChartElement |
GetContent() const | CXTPChartElement |
GetOwner() const | CXTPChartElement |
GetSeries() const | CXTPChartDiagram |
GetTitles() const | CXTPChartPanel |
Is3D() const | CXTPChartObject |
m_arrSeries | CXTPChartDiagram | protected
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartElement | virtual
OnSeriesAdded(CXTPChartSeries *pSeries) | CXTPChartDiagram | protectedvirtual
OnSeriesRemoved(CXTPChartSeries *pSeries) | CXTPChartDiagram | protected
Release() | CXTPChartDiagram | protectedvirtual
~CXTPChartElement() | CXTPChartElement | virtual
~CXTPChartPanel() | CXTPChartPanel | virtual


Toolkit Pro: XTPCaptionButtonThemeOffice2003.h Source File

  • Source
  • Controls
  • Static
  • Themes
XTPCaptionButtonThemeOffice2003.h
Go to the documentation of this file.
1
23#if !defined(__XTPCAPTIONBUTTONTHEMEOFFICE2003_H__)
24# define __XTPCAPTIONBUTTONTHEMEOFFICE2003_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
39class _XTP_EXT_CLASS CXTPCaptionButtonThemeOffice2003 : public CXTPButtonThemeOffice2003
40{
41protected:
48 virtual void DrawButtonBackground(CDC* pDC, CXTPButton* pButton);
49
57 virtual COLORREF GetTextColor(CXTPButton* pButton);
58};
59
60# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
62#endif // !defined(__XTPCAPTIONBUTTONTHEMEOFFICE2003_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPButton
Push Button control.
Definition XTPButton.h:109
CXTPButtonThemeOffice2003
CXTPButtonThemeOffice2003 is a class used to perform Office 2003 Theme drawing tasks.
Definition XTPButtonThemeOffice2003.h:39
CXTPCaptionButtonThemeOffice2003
Class CXTPCaptionButtonThemeOffice2003 is a CXTPButtonOffice2003Theme derived class.
Definition XTPCaptionButtonThemeOffice2003.h:40
CXTPCaptionButtonThemeOffice2003::GetTextColor
virtual COLORREF GetTextColor(CXTPButton *pButton)
Call this member function to get the text color of the button caption.
CXTPCaptionButtonThemeOffice2003::DrawButtonBackground
virtual void DrawButtonBackground(CDC *pDC, CXTPButton *pButton)
Call this member function to draw the background of the button caption.


Toolkit Pro: XTPButtonThemeOfficeXP.h Source File

  • Source
  • Controls
  • Button
  • Themes
XTPButtonThemeOfficeXP.h
Go to the documentation of this file.
1
23#if !defined(__XTPBUTTONTHEMEOFFICEXP_H__)
24# define __XTPBUTTONTHEMEOFFICEXP_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPButtonThemeOfficeXP : public CXTPButtonThemeUltraFlat
39{
40public:
45 CXTPButtonThemeOfficeXP();
46
53 void DrawButtonBackground(CDC* pDC, CXTPButton* pButton);
54
61 void RefreshMetrics(CXTPButton* pButton);
62};
63
64# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
66#endif //#if !defined(__XTPBUTTONTHEMEOFFICEXP_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPButton
Push Button control.
Definition XTPButton.h:109
CXTPButtonThemeOfficeXP
CXTPButtonThemeOfficeXP is a class used to perform Office XP Theme drawing tasks.
Definition XTPButtonThemeOfficeXP.h:39
CXTPButtonThemeOfficeXP::RefreshMetrics
void RefreshMetrics(CXTPButton *pButton)
This member function is called by the theme manager to refresh the visual styles used by each compone...
CXTPButtonThemeOfficeXP::DrawButtonBackground
void DrawButtonBackground(CDC *pDC, CXTPButton *pButton)
This member function is called to draw the background for the button.
CXTPButtonThemeOfficeXP::CXTPButtonThemeOfficeXP
CXTPButtonThemeOfficeXP()
Constructs a CXTPButtonThemeOfficeXP object.
CXTPButtonThemeUltraFlat
CXTPButtonThemeUltraFlat is a class used to perform Ultra Flat Theme drawing tasks.
Definition XTPButtonThemeUltraFlat.h:39


Toolkit Pro: XTPControlComboBoxGalleryPopupBar.h Source File

  • Source
  • CommandBars
XTPControlComboBoxGalleryPopupBar.h
Go to the documentation of this file.
1
23#if !defined(__XTPCONTROLCOMBOBOXGALLERYPOPUPBAR_H__)
24# define __XTPCONTROLCOMBOBOXGALLERYPOPUPBAR_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
37class _XTP_EXT_CLASS CXTPControlComboBoxGalleryPopupBar : public CXTPControlComboBoxPopupBar
38{
40 DECLARE_XTP_COMMANDBAR(CXTPControlComboBoxGalleryPopupBar)
42protected:
47 CXTPControlComboBoxGalleryPopupBar();
48
49public:
57 static CXTPControlComboBoxGalleryPopupBar* AFX_CDECL
58 CreateComboBoxGalleryPopupBar(CXTPCommandBars* pCommandBars);
59
60protected:
62 DECLARE_MESSAGE_MAP()
63
64 BOOL SetTrackingMode(int bMode, BOOL bSelectFirst, BOOL bKeyboard);
65 BOOL OnHookKeyDown(UINT nChar, LPARAM lParam);
66
67 CXTPControlGallery* GetGalleryItem() const;
68
69 //{{AFX_VIRUAL(CXTPControlComboBoxList)
70 virtual int GetCurSel() const
71 {
72 return GetGalleryItem()->GetSelectedItem();
73 }
74 virtual int FindString(int nStartAfter, LPCTSTR lpszItem) const
75 {
76 return GetGalleryItem()->FindItem(nStartAfter, lpszItem, FALSE);
77 }
78 virtual int FindStringExact(int nIndexStart, LPCTSTR lpsz) const
79 {
80 return GetGalleryItem()->FindItem(nIndexStart, lpsz, TRUE);
81 }
82 virtual int SetTopIndex(int nIndex)
83 {
84 return GetGalleryItem()->SetTopIndex(nIndex);
85 }
86 virtual void SetCurSel(int nIndex)
87 {
88 GetGalleryItem()->SetSelectedItem(nIndex);
89 }
90 virtual void GetText(int nIndex, CString& rString) const
91 {
92 rString = GetGalleryItem()->GetItemCaption(nIndex);
93 }
94
95 virtual int GetCount() const
96 {
97 return GetGalleryItem()->GetItemCount();
98 }
99
100 //}}AFX_VIRUAL
101
102 //{{AFX_MSG(CXTPControlComboBoxList)
103 void OnLButtonUp(UINT nFlags, CPoint point);
104 //}}AFX_MSG
106};
108# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
109#endif // #if !defined(__XTPCONTROLCOMBOBOXGALLERYPOPUPBAR_H__)
DECLARE_XTP_COMMANDBAR
#define DECLARE_XTP_COMMANDBAR(class_name)
This macro generates the C++ header code necessary for a CXTPCommandBar-derived class that can be ser...
Definition XTPCommandBarsDefines.h:1234
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCommandBars
CXTPCommandBars is a standalone class.
Definition XTPCommandBars.h:165
CXTPControlComboBoxGalleryPopupBar
CXTPControlComboBoxPopupBar object.
Definition XTPControlComboBoxGalleryPopupBar.h:38
CXTPControlComboBoxGalleryPopupBar::CXTPControlComboBoxGalleryPopupBar
CXTPControlComboBoxGalleryPopupBar()
Constructs a CXTPControlComboBoxGalleryPopupBar object.
CXTPControlComboBoxGalleryPopupBar::CreateComboBoxGalleryPopupBar
static CXTPControlComboBoxGalleryPopupBar *AFX_CDECL CreateComboBoxGalleryPopupBar(CXTPCommandBars *pCommandBars)
Creates a pop-up bar object.
CXTPControlComboBoxPopupBar
CXTPControlComboBoxPopupBar is a CXTPPopupBar derived class.
Definition XTPControlComboBox.h:80
CXTPControlGallery
CXTPControlGallery is a CXTPControlPopup derived class.
Definition XTPControlGallery.h:63
CXTPControlGallery::GetSelectedItem
int GetSelectedItem() const
Call this method to get the selected item in the gallery.


Toolkit Pro: XTPShortcutBarNativeWinXPTheme.h Source File

  • Source
  • ShortcutBar
  • Themes
XTPShortcutBarNativeWinXPTheme.h
Go to the documentation of this file.
1
23#if !defined(__XTPSHORTCUTBARNATIVEWINXPTHEME_H__)
24# define __XTPSHORTCUTBARNATIVEWINXPTHEME_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPShortcutBarNativeWinXPTheme : public CXTPShortcutBarOffice2003Theme
39{
40public:
45 CXTPShortcutBarNativeWinXPTheme();
46
52 ~CXTPShortcutBarNativeWinXPTheme();
53
54public:
62 void RefreshMetrics();
63
64public:
71 void FillShortcutBar(CDC* pDC, CXTPShortcutBar* pShortcutBar);
72
79 void FillShortcutItemEntry(CDC* pDC, CXTPShortcutBarItem* pItem);
80
81protected:
82 CXTPWinThemeWrapper* m_themeToolbar;
83 CXTPWinThemeWrapper* m_themeRebar;
84};
85
86# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
88#endif // !defined(__XTPSHORTCUTBARNATIVEWINXPTHEME_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPShortcutBar
CXTPShortcutBar is a CWnd derived class used to implement an Outlook 2003 shortcut bar control style.
Definition XTPShortcutBar.h:456
CXTPShortcutBarItem
CXTPShortcutBarItem is a base class that represents an item for a shortcut bar control.
Definition XTPShortcutBar.h:181
CXTPShortcutBarNativeWinXPTheme
CXTPShortcutBarNativeWinXPTheme is a CXTPShortcutBarOffice2003Theme derived class that represents a N...
Definition XTPShortcutBarNativeWinXPTheme.h:39
CXTPShortcutBarNativeWinXPTheme::CXTPShortcutBarNativeWinXPTheme
CXTPShortcutBarNativeWinXPTheme()
Constructs a CXTPShortcutBarNativeWinXPTheme object.
CXTPShortcutBarNativeWinXPTheme::FillShortcutItemEntry
void FillShortcutItemEntry(CDC *pDC, CXTPShortcutBarItem *pItem)
Fills a specified item for the shortcut bar control.
CXTPShortcutBarNativeWinXPTheme::FillShortcutBar
void FillShortcutBar(CDC *pDC, CXTPShortcutBar *pShortcutBar)
Fills the client area of the shortcut bar control.
CXTPShortcutBarNativeWinXPTheme::~CXTPShortcutBarNativeWinXPTheme
~CXTPShortcutBarNativeWinXPTheme()
Destroys a CXTPShortcutBarNativeWinXPTheme object, handles cleanup and deallocation.
CXTPShortcutBarNativeWinXPTheme::RefreshMetrics
void RefreshMetrics()
Refreshes the visual metrics of the shortcut bar paint manager.
CXTPShortcutBarOffice2003Theme
CXTPShortcutBarOffice2003Theme is a CXTPShortcutBarPaintManager derived class that represents an Offi...
Definition XTPShortcutBarOffice2003Theme.h:39
CXTPWinThemeWrapper
The CXTPWinThemeWrapper class wraps the UxTheme.dll visual theme API.
Definition XTPWinThemeWrapper.h:188


Toolkit Pro: XTPButtonThemeResource.h Source File

  • Source
  • Controls
  • Button
  • Themes
XTPButtonThemeResource.h
Go to the documentation of this file.
1
23#if !defined(__XTPBUTTONTHEMERESOURCE_H__)
24# define __XTPBUTTONTHEMERESOURCE_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPButtonThemeResource : public CXTPButtonThemeUltraFlat
39{
40public:
45 CXTPButtonThemeResource();
46
53 virtual void DrawButtonBackground(CDC* pDC, CXTPButton* pButton);
54
62 virtual void DrawCheckBoxMark(CDC* pDC, CXTPButton* pButton);
63
71 virtual void DrawRadioButtonMark(CDC* pDC, CXTPButton* pButton);
72
79 virtual void RefreshMetrics(CXTPButton* pButton);
80};
81
82# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
84#endif //#if !defined(__XTPBUTTONTHEMERESOURCE_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPButton
Push Button control.
Definition XTPButton.h:109
CXTPButtonThemeResource
CXTPButtonThemeResource is a class used to perform Office 2007 Theme drawing tasks.
Definition XTPButtonThemeResource.h:39
CXTPButtonThemeResource::DrawCheckBoxMark
virtual void DrawCheckBoxMark(CDC *pDC, CXTPButton *pButton)
This member function is called to draw the check box mark for the button control.
CXTPButtonThemeResource::CXTPButtonThemeResource
CXTPButtonThemeResource()
Constructs a CXTPButtonThemeResource object.
CXTPButtonThemeResource::DrawButtonBackground
virtual void DrawButtonBackground(CDC *pDC, CXTPButton *pButton)
This member function is called to draw the background for the button.
CXTPButtonThemeResource::DrawRadioButtonMark
virtual void DrawRadioButtonMark(CDC *pDC, CXTPButton *pButton)
This member function is called to draw the radio mark for the button control.
CXTPButtonThemeResource::RefreshMetrics
virtual void RefreshMetrics(CXTPButton *pButton)
This member function is called by the theme manager to refresh the visual styles used by each compone...
CXTPButtonThemeUltraFlat
CXTPButtonThemeUltraFlat is a class used to perform Ultra Flat Theme drawing tasks.
Definition XTPButtonThemeUltraFlat.h:39


Toolkit Pro: Member List

CXTPChartStepLineSeriesView Member List

This is the complete list of members for CXTPChartStepLineSeriesView, including all inherited members.

AddChildView(CXTPChartElementView *pChildView) | CXTPChartElementView |
CreateDeviceCommand(CXTPChartDeviceContext *pDC) | CXTPChartStepLineSeriesView | protectedvirtual
CreateLegendDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcBounds) | CXTPChartStepLineSeriesView | protectedvirtual
CreateSeriesPointView(CXTPChartDeviceContext *pDC, CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView) | CXTPChartStepLineSeriesView | protected
CXTPChartElementView(CXTPChartElementView *pParentView) | CXTPChartElementView |
CXTPChartElementView(CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartElementView |
CXTPChartElementView(CXTPChartContainer *pContainer) | CXTPChartElementView |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartStepLineSeriesView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView) | CXTPChartStepLineSeriesView |
GetAt(int nIndex) const | CXTPChartElementView |
GetBounds() const | CXTPChartElementView |
GetBounds(BOOL bIncludingChildren) const | CXTPChartElementView |
GetChildren() | CXTPChartElementView |
GetCount() const | CXTPChartElementView |
GetParentView() const | CXTPChartElementView |
Is3D() const | CXTPChartObject |
m_arrChildren | CXTPChartElementView | protected
m_pContainer | CXTPChartElementView | protected
m_pParentView | CXTPChartElementView | protected
m_rcBounds | CXTPChartElementView | protected
~CXTPChartElementView() | CXTPChartElementView | protectedvirtual
~CXTPChartLegendItemView() | CXTPChartLegendItemView | inlinevirtual


Toolkit Pro: Member List

CXTPRectT< T > Member List

This is the complete list of members for CXTPRectT< T >, including all inherited members.

Contains(T x, T y) const | CXTPRectT< T > | inline
Contains(const CXTPPoint2T< T > &pt) const | CXTPRectT< T > | inline
Contains(const CXTPRectT &rect) const | CXTPRectT< T > | inline
CXTPRectT() | CXTPRectT< T > | inline
CXTPRectT(const CXTPRectT &other) | CXTPRectT< T > | inline
CXTPRectT(const CRect &rc) | CXTPRectT< T > | inline
CXTPRectT(T x, T y, T width, T height) | CXTPRectT< T > | inline
CXTPRectT(const CXTPPoint2T< T > &location, const CXTPSizeT< T > &size) | CXTPRectT< T > | inline
CXTPRectT(const CXTPPoint2T< T > &ptTopLeft, const CXTPPoint2T< T > &ptBottomRight) | CXTPRectT< T > | inline
DeflateRect(T l, T t, T r, T b) | CXTPRectT< T > | inline
Equals(const CXTPRectT &rect) const | CXTPRectT< T > | inline
GetBottom() const | CXTPRectT< T > | inline
GetCenter() | CXTPRectT< T > | inline
GetLeft() const | CXTPRectT< T > | inline
GetLocation() const | CXTPRectT< T > | inline
GetRight() const | CXTPRectT< T > | inline
GetSize() const | CXTPRectT< T > | inline
GetTop() const | CXTPRectT< T > | inline
Height | CXTPRectT< T > |
Inflate(T dx, T dy) | CXTPRectT< T > | inline
Inflate(const CXTPPoint2T< T > &point) | CXTPRectT< T > | inline
Intersect(const CXTPRectT &rect) | CXTPRectT< T > | inline
Intersect(CXTPRectT &c, const CXTPRectT &a, const CXTPRectT &b) | CXTPRectT< T > | inlinestatic
IntersectsWith(const CXTPRectT &rect) const | CXTPRectT< T > | inline
IsEmptyArea() const | CXTPRectT< T > | inline
Normalize() | CXTPRectT< T > | inline
Offset(const CXTPPoint2T< T > &point) | CXTPRectT< T > | inline
Offset(T dx, T dy) | CXTPRectT< T > | inline
operator!=(const CXTPRectT &rect) const | CXTPRectT< T > | inline
operator==(const CXTPRectT &rect) const | CXTPRectT< T > | inline
Round() | CXTPRectT< T > | inline
SetEmpty() const | CXTPRectT< T > | inline
SetRect(const CRect &rc) | CXTPRectT< T > | inline
SetRect(T x, T y, T width, T height) | CXTPRectT< T > | inline
SetRect(const CXTPPoint2T< T > &location, const CXTPSizeT< T > &size) | CXTPRectT< T > | inline
SetRect(const CXTPPoint2T< T > &ptTopLeft, const CXTPPoint2T< T > &ptBottomRight) | CXTPRectT< T > | inline
Union(CXTPRectT &c, const CXTPRectT &a, const CXTPRectT &b) | CXTPRectT< T > | inlinestatic
Width | CXTPRectT< T > |
X | CXTPRectT< T > |
Y | CXTPRectT< T > |


Toolkit Pro: XTPChart3dFunnelSeriesLabel.h Source File

  • Source
  • Chart
  • Styles
  • Funnel
  • 3D
XTPChart3dFunnelSeriesLabel.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHART3DFUNNELSERIESLABEL_H__)
24# define __XTPCHART3DFUNNELSERIESLABEL_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartSeriesView;
34class CXTPChartFunnelSeriesPointViewBase;
35class CXTPChartFunnelSeriesStyleBase;
36class CXTPChart3dFunnelSeriesPointView;
37class CXTPChart3dFunnelSeriesStyle;
38
44class _XTP_EXT_CLASS CXTPChart3dFunnelSeriesLabel : public CXTPChartFunnelSeriesLabelBase
45{
46 DECLARE_SERIAL(CXTPChart3dFunnelSeriesLabel);
47
48public:
53 CXTPChart3dFunnelSeriesLabel();
54
55protected:
67 virtual CXTPChartElementView* CreateView(CXTPChartDeviceContext* pDC,
68 CXTPChartSeriesPointView* pPointView,
69 CXTPChartElementView* pParentView);
70};
71
76class _XTP_EXT_CLASS CXTPChart3dFunnelSeriesLabelView : public CXTPChartFunnelSeriesLabelViewBase
77{
78 DECLARE_DYNAMIC(CXTPChart3dFunnelSeriesLabelView);
79
80public:
89 CXTPChart3dFunnelSeriesLabelView(CXTPChartSeriesLabel* pLabel,
90 CXTPChartSeriesPointView* pPointView,
91 CXTPChartElementView* pParentView);
92
97 ~CXTPChart3dFunnelSeriesLabelView();
98
108 virtual CXTPChartDeviceCommand* CreateTranspositionDeviceCommand(CXTPChartDeviceContext* pDC);
109
119 virtual CXTPChartDeviceCommand* CreateDeviceCommand(CXTPChartDeviceContext* pDC);
120
130 virtual CXTPChartDeviceCommand* CreateConnectorDeviceCommand(CXTPChartDeviceContext* pDC);
131
142 const CXTPPoint3d* GetConnectorStartPoint() const;
143
153 void SetConnectorStartPoint(const CXTPPoint3d& point);
154
165 const CXTPPoint3d* GetConnectorBendPoint() const;
166
176 void SetConnectorBendPoint(const CXTPPoint3d& point);
177
188 const CXTPPoint3d* GetConnectorEndPoint() const;
189
199 void SetConnectorEndPoint(const CXTPPoint3d& point);
200
211 const CPoint* GetLabelAnchorPoint() const;
212
222 void SetLabelAnchorPoint(CPoint ptAnchor);
223
234 const CPoint* GetLabelAnchorOrigin() const;
235
245 void SetLabelAnchorOrigin(CPoint ptAnchorOrigin);
246
254 void SetLeftDirected();
255
266 BOOL IsLeftDirected() const;
267
275 void SetRightDirected();
276
287 BOOL IsRightDirected() const;
288
299 BOOL IsConnectorVisible() const;
300
311 void SetConnectorVisible(BOOL bVisible = TRUE);
312
313protected:
314 CXTPPoint3d* m_ptStart;
315 CXTPPoint3d* m_ptBend;
316 CXTPPoint3d* m_ptEnd;
317 CPoint m_ptLabelAnchor;
318 CPoint m_ptLabelAnchorOrigin;
319 CXTPChart3dFunnelSeriesPointView* m_p3dPointView;
320 BOOL m_bLeftDirected;
321 BOOL m_bConnectorVisible;
323 friend class CXTPChart3dFunnelSeriesLabelsView;
324};
325
326AFX_INLINE const CXTPPoint3d* CXTPChart3dFunnelSeriesLabelView::GetConnectorStartPoint() const
327{
328 return m_ptStart;
329}
330
331AFX_INLINE const CXTPPoint3d* CXTPChart3dFunnelSeriesLabelView::GetConnectorBendPoint() const
332{
333 return m_ptBend;
334}
335
336AFX_INLINE const CXTPPoint3d* CXTPChart3dFunnelSeriesLabelView::GetConnectorEndPoint() const
337{
338 return m_ptEnd;
339}
340
341AFX_INLINE void CXTPChart3dFunnelSeriesLabelView::SetLabelAnchorPoint(CPoint ptAnchor)
342{
343 m_ptLabelAnchor = ptAnchor;
344}
345
346AFX_INLINE void CXTPChart3dFunnelSeriesLabelView::SetLabelAnchorOrigin(CPoint ptAnchorOrigin)
347{
348 m_ptLabelAnchorOrigin = ptAnchorOrigin;
349}
350
351AFX_INLINE void CXTPChart3dFunnelSeriesLabelView::SetLeftDirected()
352{
353 m_bLeftDirected = TRUE;
354}
355
356AFX_INLINE BOOL CXTPChart3dFunnelSeriesLabelView::IsLeftDirected() const
357{
358 return m_bLeftDirected;
359}
360
361AFX_INLINE void CXTPChart3dFunnelSeriesLabelView::SetRightDirected()
362{
363 m_bLeftDirected = FALSE;
364}
365
366AFX_INLINE BOOL CXTPChart3dFunnelSeriesLabelView::IsRightDirected() const
367{
368 return !m_bLeftDirected;
369}
370
371AFX_INLINE BOOL CXTPChart3dFunnelSeriesLabelView::IsConnectorVisible() const
372{
373 return m_bConnectorVisible;
374}
375
376AFX_INLINE void CXTPChart3dFunnelSeriesLabelView::SetConnectorVisible(BOOL bVisible /*= TRUE*/)
377{
378 m_bConnectorVisible = bVisible;
379}
380
385class _XTP_EXT_CLASS CXTPChart3dFunnelSeriesLabelsView : public CXTPChartElementView
386{
387 DECLARE_DYNAMIC(CXTPChart3dFunnelSeriesLabelsView);
388
389public:
396 CXTPChart3dFunnelSeriesLabelsView(CXTPChartElementView* pParentView);
397
398public:
409 virtual CXTPChartDeviceCommand* CreateDeviceCommand(CXTPChartDeviceContext* pDC);
410
415 void ResolveOverlapping();
416
417private:
418 CXTPChart3dFunnelSeriesStyle* GetStyle() const;
419};
421# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
422#endif //#if !defined(__XTPCHART3DFUNNELSERIESLABEL_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChart3dFunnelSeriesLabel
CXTPChartFunnelSeriesLabelBase is a kind of CXTPChart3dFunnelSeriesLabel.
Definition XTPChart3dFunnelSeriesLabel.h:45
CXTPChart3dFunnelSeriesLabel::CXTPChart3dFunnelSeriesLabel
CXTPChart3dFunnelSeriesLabel()
Constructs a CXTPChart3dFunnelSeriesLabel object.
CXTPChart3dFunnelSeriesLabel::CreateView
virtual CXTPChartElementView * CreateView(CXTPChartDeviceContext *pDC, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView)
This function creates the view of the funnel series.
CXTPChart3dFunnelSeriesLabelView
Represents a series label view object.
Definition XTPChart3dFunnelSeriesLabel.h:77
CXTPChart3dFunnelSeriesLabelView::SetLeftDirected
void SetLeftDirected()
Makes the label left directed.
Definition XTPChart3dFunnelSeriesLabel.h:351
CXTPChart3dFunnelSeriesLabelView::IsConnectorVisible
BOOL IsConnectorVisible() const
Determines if the connector is visible.
Definition XTPChart3dFunnelSeriesLabel.h:371
CXTPChart3dFunnelSeriesLabelView::SetConnectorBendPoint
void SetConnectorBendPoint(const CXTPPoint3d &point)
Sets the connector bend point.
CXTPChart3dFunnelSeriesLabelView::IsRightDirected
BOOL IsRightDirected() const
Determies if the label is right directed.
Definition XTPChart3dFunnelSeriesLabel.h:366
CXTPChart3dFunnelSeriesLabelView::CXTPChart3dFunnelSeriesLabelView
CXTPChart3dFunnelSeriesLabelView(CXTPChartSeriesLabel *pLabel, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView)
Constructs a view object.
CXTPChart3dFunnelSeriesLabelView::m_ptLabelAnchor
CPoint m_ptLabelAnchor
Label anchor point.
Definition XTPChart3dFunnelSeriesLabel.h:317
CXTPChart3dFunnelSeriesLabelView::m_ptEnd
CXTPPoint3d * m_ptEnd
Connector end point or NULL if not set.
Definition XTPChart3dFunnelSeriesLabel.h:316
CXTPChart3dFunnelSeriesLabelView::SetLabelAnchorOrigin
void SetLabelAnchorOrigin(CPoint ptAnchorOrigin)
Sets the label anchor origin point.
Definition XTPChart3dFunnelSeriesLabel.h:346
CXTPChart3dFunnelSeriesLabelView::SetLabelAnchorPoint
void SetLabelAnchorPoint(CPoint ptAnchor)
Sets the label anchor point.
Definition XTPChart3dFunnelSeriesLabel.h:341
CXTPChart3dFunnelSeriesLabelView::m_ptStart
CXTPPoint3d * m_ptStart
Connector start point or NULL if not set.
Definition XTPChart3dFunnelSeriesLabel.h:314
CXTPChart3dFunnelSeriesLabelView::SetConnectorStartPoint
void SetConnectorStartPoint(const CXTPPoint3d &point)
Sets the connector start point.
CXTPChart3dFunnelSeriesLabelView::CreateConnectorDeviceCommand
virtual CXTPChartDeviceCommand * CreateConnectorDeviceCommand(CXTPChartDeviceContext *pDC)
Creates a label connector drawing device command object.
CXTPChart3dFunnelSeriesLabelView::CreateTranspositionDeviceCommand
virtual CXTPChartDeviceCommand * CreateTranspositionDeviceCommand(CXTPChartDeviceContext *pDC)
Creates a label transposition device command object.
CXTPChart3dFunnelSeriesLabelView::IsLeftDirected
BOOL IsLeftDirected() const
Determies if the label is left directed.
Definition XTPChart3dFunnelSeriesLabel.h:356
CXTPChart3dFunnelSeriesLabelView::GetLabelAnchorOrigin
const CPoint * GetLabelAnchorOrigin() const
Obtains a previously set label anchor origin point.
CXTPChart3dFunnelSeriesLabelView::CreateDeviceCommand
virtual CXTPChartDeviceCommand * CreateDeviceCommand(CXTPChartDeviceContext *pDC)
Creates a label drawing device command object.
CXTPChart3dFunnelSeriesLabelView::SetConnectorEndPoint
void SetConnectorEndPoint(const CXTPPoint3d &point)
Sets the connector end point.
CXTPChart3dFunnelSeriesLabelView::GetLabelAnchorPoint
const CPoint * GetLabelAnchorPoint() const
Obtains a previously set label anchor point.
CXTPChart3dFunnelSeriesLabelView::SetConnectorVisible
void SetConnectorVisible(BOOL bVisible=TRUE)
Sets connector visibility.
Definition XTPChart3dFunnelSeriesLabel.h:376
CXTPChart3dFunnelSeriesLabelView::m_bConnectorVisible
BOOL m_bConnectorVisible
TRUE if connector is visible.
Definition XTPChart3dFunnelSeriesLabel.h:321
CXTPChart3dFunnelSeriesLabelView::GetConnectorEndPoint
const CXTPPoint3d * GetConnectorEndPoint() const
Obtains a previously set connector end point.
Definition XTPChart3dFunnelSeriesLabel.h:336
CXTPChart3dFunnelSeriesLabelView::~CXTPChart3dFunnelSeriesLabelView
~CXTPChart3dFunnelSeriesLabelView()
Handles view object destruction.
CXTPChart3dFunnelSeriesLabelView::SetRightDirected
void SetRightDirected()
Makes the label right directed.
Definition XTPChart3dFunnelSeriesLabel.h:361
CXTPChart3dFunnelSeriesLabelView::m_ptBend
CXTPPoint3d * m_ptBend
Connector bend point or NULL if not set.
Definition XTPChart3dFunnelSeriesLabel.h:315
CXTPChart3dFunnelSeriesLabelView::GetConnectorStartPoint
const CXTPPoint3d * GetConnectorStartPoint() const
Obtains a previously set connector start point.
Definition XTPChart3dFunnelSeriesLabel.h:326
CXTPChart3dFunnelSeriesLabelView::m_p3dPointView
CXTPChart3dFunnelSeriesPointView * m_p3dPointView
Point view.
Definition XTPChart3dFunnelSeriesLabel.h:319
CXTPChart3dFunnelSeriesLabelView::m_bLeftDirected
BOOL m_bLeftDirected
TRUE if label is to be left directed.
Definition XTPChart3dFunnelSeriesLabel.h:320
CXTPChart3dFunnelSeriesLabelView::m_ptLabelAnchorOrigin
CPoint m_ptLabelAnchorOrigin
Label anchor point origin.
Definition XTPChart3dFunnelSeriesLabel.h:318
CXTPChart3dFunnelSeriesLabelView::GetConnectorBendPoint
const CXTPPoint3d * GetConnectorBendPoint() const
Obtains a previously set connector bend point.
Definition XTPChart3dFunnelSeriesLabel.h:331
CXTPChart3dFunnelSeriesLabelsView
Represents a view object for all funnel series labels.
Definition XTPChart3dFunnelSeriesLabel.h:386
CXTPChart3dFunnelSeriesLabelsView::CXTPChart3dFunnelSeriesLabelsView
CXTPChart3dFunnelSeriesLabelsView(CXTPChartElementView *pParentView)
Constructs a view object.
CXTPChart3dFunnelSeriesLabelsView::CreateDeviceCommand
virtual CXTPChartDeviceCommand * CreateDeviceCommand(CXTPChartDeviceContext *pDC)
Creates view drawing device command for the device context specified.
CXTPChart3dFunnelSeriesLabelsView::ResolveOverlapping
void ResolveOverlapping()
Resolves label overlapping in an implementation specific way.
CXTPChart3dFunnelSeriesPointView
This class abstracts the view of a funnel series point.
Definition XTPChart3dFunnelSeriesPointView.h:47
CXTPChart3dFunnelSeriesStyle
This class abstracts the basic style of a funnel series.
Definition XTPChart3dFunnelSeriesStyle.h:49
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartElementView
This class represents the view of a chart element.
Definition XTPChartElementView.h:47
CXTPChartFunnelSeriesLabelBase
CXTPChartFunnelSeriesLabelBase is a kind of CXTPChartSeriesLabel.
Definition XTPChartFunnelSeriesLabelBase.h:54
CXTPChartFunnelSeriesLabelBase::GetStyle
CXTPChartFunnelSeriesStyleBase * GetStyle() const
Call this function to get the basic style of the funnel series.
CXTPChartFunnelSeriesLabelViewBase
This class abstracts the view of a funnel series label.
Definition XTPChartFunnelSeriesLabelBase.h:159
CXTPChartFunnelSeriesPointViewBase
This class abstracts the view of a funnel series point.
Definition XTPChartFunnelSeriesPointViewBase.h:50
CXTPChartFunnelSeriesStyleBase
This class abstracts the basic style of a funnel serie.This class is a kind of CXTPChartSeriesStyle.
Definition XTPChartFunnelSeriesStyleBase.h:49
CXTPChartSeriesLabel
This class abstracts the label of a series.
Definition XTPChartSeriesLabel.h:49
CXTPChartSeriesPointView
Represents chart series point view.
Definition XTPChartSeriesPointView.h:48
CXTPPoint3T< double >


Toolkit Pro: XTPGaugeCtrl.h Source File

  • Source
  • Gauge
XTPGaugeCtrl.h
Go to the documentation of this file.
1
22#if !defined(__XTPGAUGECTRL_H__)
23# define __XTPGAUGECTRL_H__
24
25# if _MSC_VER > 1000
26# pragma once
27# endif // _MSC_VER > 1000
28
29# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
30
31class CXTPGaugeTraits;
32class CXTPGaugeBaseType;
33class CXTPGaugeMeterType;
34class CXTPGaugeStateType;
35
45# define XTP_WM_GAUGEUPDATE CXTPGaugeCtrl::m_XTP_WM_GAUGEUPDATE
46
53# define ON_XTP_WM_GAUGEUPDATE(member) ON_REGISTERED_MESSAGE(XTP_WM_GAUGEUPDATE, member)
54
59struct IXTPGaugeClientSite
60{
62 virtual ~IXTPGaugeClientSite()
63 {
64 }
72 virtual void OnGaugeUpdated(CXTPGaugeBaseType& type) = 0;
73};
74
101class _XTP_EXT_CLASS CXTPGaugeCtrl : public CWnd
102{
103 friend class CXTPGaugeBaseType;
104
105 DECLARE_DYNAMIC(CXTPGaugeCtrl);
106
107public:
112 CXTPGaugeCtrl();
113
118 ~CXTPGaugeCtrl();
119
120public:
129 BOOL RegisterWindowClass(HINSTANCE hInstance = NULL);
130
148 virtual BOOL Create(DWORD dwStyle, const RECT& rect, CWnd* pParentWnd, UINT nID,
149 CCreateContext* pContext = NULL);
150
175 virtual BOOL CreateEx(DWORD dwExStyle, DWORD dwStyle, int x, int y, int nWidth, int nHeight,
176 HWND hWndParent, HMENU nIDorHMenu, LPVOID lpParam = NULL);
177
198 virtual BOOL CreateEx(DWORD dwExStyle, DWORD dwStyle, const RECT& rect, CWnd* pParentWnd,
199 UINT nID, LPVOID lpParam = NULL);
200
201 using CWnd::Create;
202 using CWnd::CreateEx;
203
209 IXTPGaugeClientSite* GetCilentSite() const;
210
216 void SetCilentSite(IXTPGaugeClientSite* pSite);
217
224 BOOL IsLoaded() const;
225
238 CXTPGaugeBaseType* Load(CRuntimeClass* pClass, IStream& source, const CXTPGaugeTraits& traits);
239
246 CXTPGaugeBaseType* GetType();
247
254 const CXTPGaugeBaseType* GetType() const;
255
264 BOOL IsType(CRuntimeClass* pClass) const;
265
275 CXTPGaugeMeterType* LoadMeterType(IStream& source, const CXTPGaugeTraits& traits);
276
284 CXTPGaugeMeterType* GetMeterType();
285
293 const CXTPGaugeMeterType* GetMeterType() const;
294
302 BOOL IsMeterType() const;
303
313 CXTPGaugeStateType* LoadStateType(IStream& source, const CXTPGaugeTraits& traits);
314
322 CXTPGaugeStateType* GetStateType();
323
331 const CXTPGaugeStateType* GetStateType() const;
332
340 BOOL IsStateType() const;
341
346 void Unload();
347
349 BOOL IsTabStopEnabled() const;
350 void EnableTabStop(BOOL bEnable = TRUE);
351 void Draw(CDC* pDC, const CRect& rcPaint);
352
353 static const UINT m_XTP_WM_GAUGEUPDATE;
354 static const UINT m_XTP_WM_GAUGEDELAYREDRAW;
357private:
358 void NotifyUpdate(CXTPGaugeBaseType& type);
359
360protected:
362 virtual BOOL PreCreateWindow(CREATESTRUCT& cs);
363 virtual void PreSubclassWindow();
364 virtual BOOL OnWndMsg(UINT message, WPARAM wParam, LPARAM lParam, LRESULT* pResult);
365
366 DECLARE_MESSAGE_MAP()
367 afx_msg int OnCreate(LPCREATESTRUCT lpCreateStruct);
368 afx_msg void OnDestroy();
369 afx_msg void OnPaint();
370 afx_msg BOOL OnEraseBkgnd(CDC* pDC);
371 afx_msg LRESULT OnDelayRedraw(WPARAM, LPARAM);
372 afx_msg void OnSetFocus(CWnd* pWnd);
373 afx_msg void OnKillFocus(CWnd* pWnd);
376private:
377 void OnInitialSetup();
378 void SetTransparentBackgroundColor(COLORREF color);
379 void SetBackgroundColor(COLORREF color);
380 void ApplyTransparentBackgroundColor();
381
382private:
383 BOOL m_bSubclassed;
384 mutable BOOL m_bTabStopEnabled;
385 BOOL m_bFocused;
386 CXTPMarkupContext* m_pMarkupContext;
387 CXTPGaugeBaseType* m_pType;
388 COLORREF m_crTransparent;
389 COLORREF m_crBackground;
390 IXTPGaugeClientSite* m_pClientSite;
391};
392
393AFX_INLINE IXTPGaugeClientSite* CXTPGaugeCtrl::GetCilentSite() const
394{
395 return m_pClientSite;
396}
397
398AFX_INLINE void CXTPGaugeCtrl::SetCilentSite(IXTPGaugeClientSite* pSite)
399{
400 m_pClientSite = pSite;
401}
402
403AFX_INLINE BOOL CXTPGaugeCtrl::IsLoaded() const
404{
405 return (NULL != m_pType);
406}
407
408AFX_INLINE CXTPGaugeBaseType* CXTPGaugeCtrl::GetType()
409{
410 return m_pType;
411}
412
413AFX_INLINE const CXTPGaugeBaseType* CXTPGaugeCtrl::GetType() const
414{
415 return m_pType;
416}
417
418AFX_INLINE const CXTPGaugeMeterType* CXTPGaugeCtrl::GetMeterType() const
419{
420 return const_cast< CXTPGaugeCtrl*>(this)->GetMeterType();
421}
422
423AFX_INLINE BOOL CXTPGaugeCtrl::IsMeterType() const
424{
425 return (NULL != GetMeterType());
426}
427
428AFX_INLINE const CXTPGaugeStateType* CXTPGaugeCtrl::GetStateType() const
429{
430 return const_cast< CXTPGaugeCtrl*>(this)->GetStateType();
431}
432
433AFX_INLINE BOOL CXTPGaugeCtrl::IsStateType() const
434{
435 return (NULL != GetStateType());
436}
437
438# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
439
440#endif // !defined(__XTPGAUGECTRL_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPGaugeBaseType
A base class for all gauge types.
Definition XTPGaugeBaseType.h:44
CXTPGaugeCtrl
Gauge control hosts a JavaScript and Markup based gauge implementation of a certain type and provides...
Definition XTPGaugeCtrl.h:102
CXTPGaugeCtrl::GetMeterType
CXTPGaugeMeterType * GetMeterType()
A helpers method for obtaining the currently loaded gauge type as CXTPGaugeMeterType.
CXTPGaugeCtrl::GetStateType
CXTPGaugeStateType * GetStateType()
A helpers method for obtaining the currently loaded gauge type as CXTPGaugeStateType.
CXTPGaugeCtrl::IsType
BOOL IsType(CRuntimeClass *pClass) const
Checks if the currently loaded gauge type is of the specified class.
CXTPGaugeCtrl::RegisterWindowClass
BOOL RegisterWindowClass(HINSTANCE hInstance=NULL)
Registers the window class if it has not already been registered.
CXTPGaugeCtrl::CXTPGaugeCtrl
CXTPGaugeCtrl()
Constructs gauge control object.
CXTPGaugeCtrl::IsLoaded
BOOL IsLoaded() const
Determines if any gauge type is currently loaded.
Definition XTPGaugeCtrl.h:403
CXTPGaugeCtrl::Unload
void Unload()
Unloads the currently loaded gauge type.
CXTPGaugeCtrl::IsStateType
BOOL IsStateType() const
Determines if the currently loaded gauge type is CXTPGaugeStateType.
Definition XTPGaugeCtrl.h:433
CXTPGaugeCtrl::Load
CXTPGaugeBaseType * Load(CRuntimeClass *pClass, IStream &source, const CXTPGaugeTraits &traits)
Loads a gauge using the specified gauge type from the data source provided using provided gauge trait...
CXTPGaugeCtrl::CreateEx
virtual BOOL CreateEx(DWORD dwExStyle, DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID, LPVOID lpParam=NULL)
Creates a Gauge control window object.
CXTPGaugeCtrl::IsMeterType
BOOL IsMeterType() const
Determines if the currently loaded gauge type is CXTPGaugeMeterType.
Definition XTPGaugeCtrl.h:423
CXTPGaugeCtrl::Create
virtual BOOL Create(DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID, CCreateContext *pContext=NULL)
Creates a Gauge control window object.
CXTPGaugeCtrl::CreateEx
virtual BOOL CreateEx(DWORD dwExStyle, DWORD dwStyle, int x, int y, int nWidth, int nHeight, HWND hWndParent, HMENU nIDorHMenu, LPVOID lpParam=NULL)
Creates a Gauge control window object.
CXTPGaugeCtrl::~CXTPGaugeCtrl
~CXTPGaugeCtrl()
Handles gauge control object destruction.
CXTPGaugeCtrl::GetType
CXTPGaugeBaseType * GetType()
Obtains a generalized pointer of the currently loaded gauge type object.
Definition XTPGaugeCtrl.h:408
CXTPGaugeCtrl::SetCilentSite
void SetCilentSite(IXTPGaugeClientSite *pSite)
Sets an associated gauge client site interface.
Definition XTPGaugeCtrl.h:398
CXTPGaugeCtrl::LoadMeterType
CXTPGaugeMeterType * LoadMeterType(IStream &source, const CXTPGaugeTraits &traits)
A helper method for loading CXTPGaugeMeterType gauge.
CXTPGaugeCtrl::LoadStateType
CXTPGaugeStateType * LoadStateType(IStream &source, const CXTPGaugeTraits &traits)
A helper method for loading CXTPGaugeStateType gauge.
CXTPGaugeMeterType
Implements a Meter gauge type.
Definition XTPGaugeMeterType.h:45
CXTPGaugeStateType
Implements a State gauge type.
Definition XTPGaugeStateType.h:44
CXTPGaugeTraits
Defines a set of loaded gauge traits.
Definition XTPGaugeTraits.h:38
CXTPMarkupContext
CXTPMarkupContext is a standalone class used to provide common settings for Markup objects.
Definition XTPMarkupContext.h:128
IXTPGaugeClientSite
Provides a client site interface for a gauge control owner.
Definition XTPGaugeCtrl.h:60
IXTPGaugeClientSite::OnGaugeUpdated
virtual void OnGaugeUpdated(CXTPGaugeBaseType &type)=0
Notifies client site about a gauge update event.


Toolkit Pro: XTPMarkupGdiPlusImage.h Source File

  • Source
  • Markup
  • DeviceContext
XTPMarkupGdiPlusImage.h
Go to the documentation of this file.
1
23#if !defined(__XTPMARKUPGDIPLUSIMAGE_H__)
24# define __XTPMARKUPGDIPLUSIMAGE_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33namespace Gdiplus
34{
35class GpImage;
36class PropertyItem;
37} // namespace Gdiplus
38
39class CXTPGdiPlus;
40class CXTPImageManager;
41class CXTPImageManagerIcon;
42struct XTP_URI;
43struct IXTPMarkupDeviceDependentImageSite;
44
49class _XTP_EXT_CLASS CXTPMarkupGdiPlusImage : public CXTPMarkupDeviceDependentImage
50{
52 DECLARE_DYNAMIC(CXTPMarkupGdiPlusImage);
54public:
61 CXTPMarkupGdiPlusImage(CXTPGdiPlus* pReserved, IXTPMarkupDeviceDependentImageSite* pSite);
62
67 virtual ~CXTPMarkupGdiPlusImage();
68
69public:
83 virtual BOOL Load(LPCWSTR lpszSource, int nWidth, int nHeight = 0);
84
91 Gdiplus::GpImage* GetGpImage();
92
99 CXTPImageManagerIcon* GetIcon();
100
101private:
102 typedef CMap<UINT_PTR, UINT_PTR, CXTPMarkupGdiPlusImage*, CXTPMarkupGdiPlusImage*>
103 AnimationTimerData;
104 static AnimationTimerData& AFX_CDECL GetAnimationTimerData();
105 static BOOL AFX_CDECL ParseIconSource(LPCWSTR lpszSource, UINT& nIconId);
106 BOOL LoadIcon(UINT nIconId, int nWidth);
107 BOOL LoadIcon(const XTP_URI& uri, int nWidth);
108 BOOL LoadImage(const XTP_URI& uri);
109 BOOL LoadXamlImage(const XTP_URI& uri, int nWidth, int nHeight);
110 BOOL LoadSvgImage(const XTP_URI& uri, int nWidth, int nHeight);
111 void Cleanup();
112 void LoadAnimationData();
113 void RenderAnimation();
114 void StopAnimation();
115 static void CALLBACK OnAnimationTimer(HWND hWnd, UINT uMsg, UINT_PTR nTimerId, DWORD dwTime);
116
117 Gdiplus::GpImage* m_pImage;
118 UINT m_nFrameCount;
119 UINT m_nCurrentFrame;
120 Gdiplus::PropertyItem* m_pDelayProperty;
121 UINT_PTR m_nTimerId;
122 CXTPImageManager* m_pImageManager;
123 CXTPImageManagerIcon* m_pIcon;
124 CXTPMarkupContext* m_pMarkupContext;
125};
126
127AFX_INLINE Gdiplus::GpImage* CXTPMarkupGdiPlusImage::GetGpImage()
128{
129 return m_pImage;
130}
131
132AFX_INLINE CXTPImageManagerIcon* CXTPMarkupGdiPlusImage::GetIcon()
133{
134 return m_pIcon;
135}
137# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
138#endif /*__XTPMARKUPGDIPLUSIMAGE_H__*/
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPImageManager
CXTPImageManager is a standalone class.
Definition XTPImageManager.h:1898
CXTPImageManagerIcon
Icons holder class.
Definition XTPImageManager.h:622
CXTPMarkupContext
CXTPMarkupContext is a standalone class used to provide common settings for Markup objects.
Definition XTPMarkupContext.h:128
CXTPMarkupDeviceDependentImage
Implements an abstract device dependent image.
Definition XTPMarkupDeviceDependentImage.h:73
CXTPMarkupGdiPlusImage
Implements an abstract GDI+ device dependent image.
Definition XTPMarkupGdiPlusImage.h:50
CXTPMarkupGdiPlusImage::~CXTPMarkupGdiPlusImage
virtual ~CXTPMarkupGdiPlusImage()
Handles device dependent image object deallocation.
CXTPMarkupGdiPlusImage::GetIcon
CXTPImageManagerIcon * GetIcon()
Obtains the icon wrapped image pointer.
Definition XTPMarkupGdiPlusImage.h:132
CXTPMarkupGdiPlusImage::GetGpImage
Gdiplus::GpImage * GetGpImage()
Obtains the GDI+ wrapped image pointer.
Definition XTPMarkupGdiPlusImage.h:127
CXTPMarkupGdiPlusImage::CXTPMarkupGdiPlusImage
CXTPMarkupGdiPlusImage(CXTPGdiPlus *pReserved, IXTPMarkupDeviceDependentImageSite *pSite)
Constructs a device dependent image object.
CXTPMarkupGdiPlusImage::Load
virtual BOOL Load(LPCWSTR lpszSource, int nWidth, int nHeight=0)
Loads an image from a specified resource.
IXTPMarkupDeviceDependentImageSite
Describes an image site interface.
Definition XTPMarkupDeviceDependentImage.h:40
XTP_URI
Parse URI information.
Definition XTPSystemHelpers.h:1348


Toolkit Pro: Member List

CXTPStatusBarThemeNativeWindows10 Member List

This is the complete list of members for CXTPStatusBarThemeNativeWindows10, including all inherited members.

CXTPStatusBarThemeNativeWindows10(CXTPPaintManager *pPaintManager) | CXTPStatusBarThemeNativeWindows10 |
CXTPStatusBarThemeOffice2013(CXTPPaintManager *pPaintManager) | CXTPStatusBarThemeOffice2013 |
DrawStatusBarButtonFace(CDC *pDC, CRect rcItem, CXTPStatusBarPane *pPane) | CXTPStatusBarThemeOffice2013 | virtual
DrawStatusBarGripper(CDC *pDC, CRect rcClient) | CXTPStatusBarThemeNativeWindows10 | virtual
DrawStatusBarPaneBorder(CDC *pDC, CRect rc, CXTPStatusBarPane *pPane, BOOL bGripperPane) | CXTPStatusBarThemeOffice2013 | virtual
DrawStatusBarPaneEntry(CDC *pDC, CRect rcItem, CXTPStatusBarPane *pPane) | CXTPStatusBarThemeOffice2013 | virtual
DrawStatusBarPaneSeparator(CDC *pDC, CRect rc, CXTPStatusBarPane *pPane) | CXTPStatusBarThemeOffice2013 | virtual
DrawStatusBarSwitchPane(CDC *pDC, CRect rcItem, CXTPStatusBarSwitchPane *pPane) | CXTPStatusBarThemeOffice2013 | virtual
FillStatusBar(CDC *pDC, CXTPStatusBar *pBar) | CXTPStatusBarThemeOffice2013 | virtual
GetStateColor() const | CXTPStatusBarThemeNativeWindows10 | virtual
GetTextColor(CXTPStatusBarPane *pPane) | CXTPStatusBarThemeOffice2013 | virtual
m_clrButtonBack | CXTPStatusBarThemeOffice2013 | protected
m_clrButtonBackChecked | CXTPStatusBarThemeOffice2013 | protected
m_clrButtonBackHighlight | CXTPStatusBarThemeOffice2013 | protected
m_clrButtonBackPushed | CXTPStatusBarThemeOffice2013 | protected
m_clrButtonTextChecked | CXTPStatusBarThemeOffice2013 | protected
m_clrButtonTextHighlight | CXTPStatusBarThemeOffice2013 | protected
m_clrButtonTextPushed | CXTPStatusBarThemeOffice2013 | protected
RefreshMetrics() | CXTPStatusBarThemeNativeWindows10 | virtual
SetStateColor(COLORREF clrState) | CXTPStatusBarThemeNativeWindows10 | virtual


Toolkit Pro: Member List

CXTPTaskButtonThemeExpando Member List

This is the complete list of members for CXTPTaskButtonThemeExpando, including all inherited members.

CXTPButtonTheme() | CXTPButtonTheme |
CXTPCmdTarget() | CXTPCmdTarget |
CXTPControlTheme() | CXTPControlTheme |
DrawButton(CDC *pDC, CXTPButton *pButton) | CXTPTaskButtonThemeExpando | virtual
DrawButtonBackground(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
DrawButtonText(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme |
DrawButtonVisualStyleBackground(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
DrawCheckBoxMark(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
DrawFocusRect(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
DrawGroupBox(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
DrawPushButtonDropDown(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
DrawPushButtonIcon(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
DrawPushButtonText(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
DrawRadioButtonMark(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetTextColor(CXTPButton *pButton) | CXTPButtonTheme | virtual
GetThemeStyle() const | CXTPControlTheme |
m_crBack | CXTPButtonTheme |
m_crBorder3DHilite | CXTPButtonTheme |
m_crBorder3DShadow | CXTPButtonTheme |
m_crBorderHilite | CXTPButtonTheme |
m_crBorderShadow | CXTPButtonTheme |
m_crText | CXTPButtonTheme |
m_crTextCheck | CXTPButtonTheme |
m_crTextDisabled | CXTPButtonTheme |
m_nTheme | CXTPControlTheme | protected
RefreshMetrics(CXTPButton *pButton) | CXTPButtonTheme | virtual
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static
~CXTPButtonTheme() | CXTPButtonTheme | virtual


Toolkit Pro: Member List

XTP_EDIT_ROWCOLRECT Member List

This is the complete list of members for XTP_EDIT_ROWCOLRECT, including all inherited members.

nCol1 | XTP_EDIT_ROWCOLRECT
nCol2 | XTP_EDIT_ROWCOLRECT
nRow1 | XTP_EDIT_ROWCOLRECT
nRow2 | XTP_EDIT_ROWCOLRECT


Toolkit Pro: Member List

XTP_WEEK_VIEW_LAYOUT Member List

This is the complete list of members for XTP_WEEK_VIEW_LAYOUT, including all inherited members.

m_nDayHeaderHeight | XTP_WEEK_VIEW_LAYOUT
m_nDayHeight | XTP_WEEK_VIEW_LAYOUT
m_nDayWidth | XTP_WEEK_VIEW_LAYOUT
m_nGridColumns | XTP_WEEK_VIEW_LAYOUT


Toolkit Pro: Member List

CXTPGridThemeVisualStudio2019 Member List

This is the complete list of members for CXTPGridThemeVisualStudio2019, including all inherited members.

CalcColumnHeight(CDC *pDC, CXTPGridColumn *pColumn, int nTotalWidth=0) | CXTPGridPaintManager | protectedvirtual
CalculateRowHeight(CDC *pDC, const CString &strText, int nMaxWidth, BOOL bWordBreak=TRUE) | CXTPGridPaintManager | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPGridPaintManager() | CXTPGridPaintManager |
CXTPGridThemeOffice2013() | CXTPGridThemeOffice2013 |
CXTPGridThemeVisualStudio2019() | CXTPGridThemeVisualStudio2019 |
DrawBitmap(CDC *pDC, CXTPGridControl *pControl, CRect rcColumn, int iImage) | CXTPGridPaintManager | virtual
DrawCollapsedBitmap(CDC *pDC, const CXTPGridRow *pRow, CRect &rcBitmap) | CXTPGridThemeOffice2013 | virtual
DrawColumn(CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn, BOOL bDrawExternal=FALSE, int nShadowWidth=0) | CXTPGridPaintManager | virtual
DrawColumnBackground(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, BOOL &bColumnPressed, BOOL &bDraggingFromHeader, CXTPGridHeader *pHeader=NULL) | CXTPGridThemeOffice2013 | virtual
DrawColumnFooter(CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn) | CXTPGridPaintManager | virtual
DrawColumnFooterDivider(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn) | CXTPGridPaintManager | virtual
DrawColumnIcon(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, CRect rcIcon, int iIcon) | CXTPGridPaintManager | virtual
DrawColumnText(CDC *pDC, CRect rcText, CString strCaption, int nHeaderAlignment, BOOL bIsHeader, BOOL bColumnPressed) | CXTPGridThemeOffice2013 | virtual
DrawConnector(CDC *pDC, CPoint ptFrom, CPoint ptTo) | CXTPGridPaintManager |
DrawFocusedRow(CDC *pDC, CRect rcRow) | CXTPGridThemeOffice2013 | virtual
DrawFreezeColsDivider(CDC *pDC, const CRect &rc, CXTPGridControl *pControl, CXTPGridRow *pRow=NULL) | CXTPGridPaintManager | virtual
DrawGlyph(CDC *pDC, CRect rcColumn, int iImage) | CXTPGridPaintManager | virtual
DrawGrid(CDC *pDC, XTPGridOrientation orientation, CRect rcGrid) | CXTPGridPaintManager | virtual
DrawGridPattern(CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush) | CXTPGridPaintManager | protectedvirtual
DrawGridPattern(CDC *pDC, CXTPBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush) | CXTPGridPaintManager | protectedvirtual
DrawGridPattern(CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr) | CXTPGridPaintManager | protectedvirtual
DrawGroupRow(CDC *pDC, CXTPGridGroupRow *pRow, CRect rcRow, XTP_GRIDRECORDITEM_METRICS *pMetrics) | CXTPGridThemeOffice2013 | virtual
DrawHorizontalLine(CDC *pDC, int xPos, int yPos, int cx, COLORREF clr) | CXTPGridPaintManager |
DrawInplaceButton(CDC *pDC, CXTPGridInplaceButton *pButton) | CXTPGridPaintManager | virtual
DrawInplaceButtonFrame(CDC *pDC, CXTPGridInplaceButton *pButton) | CXTPGridPaintManager | protectedvirtual
DrawInplaceButtonIcon(CDC *pDC, CXTPGridInplaceButton *pButton) | CXTPGridPaintManager | protectedvirtual
DrawInplaceComboButton(CDC *pDC, CRect *pRc) | CXTPGridPaintManager | virtual
DrawInplaceExpandButton(CDC *pDC, CRect *pRc) | CXTPGridPaintManager | virtual
DrawInplaceSpinButton(CDC *pDC, CRect *pRc) | CXTPGridPaintManager | virtual
DrawItemBitmap(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CRect &rcItem, int nImage) | CXTPGridPaintManager | virtual
DrawItemCaption(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics) | CXTPGridPaintManager | virtual
DrawItemControl(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CXTPGridRecordItemControl *pControl, CRect &rcItem) | CXTPGridPaintManager | virtual
DrawLink(int *pnCurrDrawPos, XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CXTPGridHyperlink *pHyperlink, CString strText, CRect rcLink, int nFlag, BOOL bTrim=FALSE) | CXTPGridPaintManager | protectedvirtual
DrawMultiLineText(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, BOOL bWordBreak=TRUE) | CXTPGridPaintManager | protectedvirtual
DrawNoGroupByText(CDC *pDC, CRect rcItem) | CXTPGridPaintManager | virtual
DrawRowNumber(CDC *pDC, CRect rcNumber, CXTPGridRow *pRow) | CXTPGridPaintManager | virtual
DrawSectionDivider(CDC *pDC, const CRect &rc, XTPGridSectionDividerPosition dividerPosition, XTPGridSectionDividerStyle dividerStyle, CXTPPaintManagerColor dividerColor) | CXTPGridPaintManager |
DrawShellIcon(CDC *pDC, CRect rcColumn, int iImage) | CXTPGridPaintManager | virtual
DrawSingleLineText(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nStartPos, int nEndPos, int nActualWidth) | CXTPGridPaintManager | protectedvirtual
DrawString(int *pnCurrDrawPos, CDC *pDC, const CString &strDraw, CRect rcDraw, UINT nFormat) | CXTPGridPaintManager | protectedvirtual
DrawTextLine(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nFlag, int &nCharCounter, int &nHyperlinkCounter) | CXTPGridPaintManager | protectedvirtual
DrawTreeStructure(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CRect rcItem, CSize sizeGlyph) | CXTPGridPaintManager | virtual
DrawTriangle(CDC *pDC, CRect rcTriangle, BOOL bToDown, BOOL bDraggingFromHeader, int nShadowWidth, BOOL bColumnPressed) | CXTPGridThemeOffice2013 | virtual
DrawVerticalLine(CDC *pDC, int xPos, int yPos, int cy, COLORREF clr) | CXTPGridPaintManager |
DrawVerticalTimeLineMarker(CDC *pDC, int xPos, CXTPGridControl *pControl, COLORREF color=RGB(0, 255, 0)) | CXTPGridPaintManager | virtual
EnablePreviewMode(BOOL bIsPreviewMode) | CXTPGridPaintManager |
FillFooter(CDC *pDC, CRect rcFooter) | CXTPGridPaintManager | virtual
FillGroupByControl(CDC *pDC, CRect &rcGroupBy) | CXTPGridPaintManager | virtual
FillGroupRowMetrics(CXTPGridGroupRow *pRow, XTP_GRIDRECORDITEM_METRICS *pMetrics, BOOL bPrinting) | CXTPGridThemeOffice2013 | virtual
FillHeaderControl(CDC *pDC, CRect rcHeader) | CXTPGridPaintManager | virtual
FillIndent(CDC *pDC, CRect rcRow) | CXTPGridPaintManager | virtual
FillItemShade(CDC *pDC, CRect rcItem) | CXTPGridPaintManager | virtual
FillRow(CDC *pDC, CXTPGridRow *pRow, CRect rcRow) | CXTPGridPaintManager | virtual
FindRowAdjacentToMerged(const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, BOOL bUpward) | CXTPGridPaintManager |
FindRowAdjacentToMergedEx(const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, int &nAdjRowIndex, BOOL bUpward) | CXTPGridPaintManager |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetColumnOffice2007CustomThemeBaseColor() const | CXTPGridPaintManager |
GetColumnStyle() const | CXTPGridPaintManager |
GetControlBackColor(CXTPGridControl *pControl) | CXTPGridPaintManager | virtual
GetFooterHeight(CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0) | CXTPGridPaintManager | virtual
GetFreezeColsDividerStyle() const | CXTPGridPaintManager |
GetGlyphs() const | CXTPGridPaintManager |
GetHeaderHeight() | CXTPGridPaintManager | virtual
GetHeaderHeight(CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0) | CXTPGridPaintManager | virtual
GetItemHeight(XTP_GRIDRECORDITEM_DRAWARGS &drawArgs, int nWidth) | CXTPGridPaintManager |
GetMaxPreviewLines() | CXTPGridPaintManager |
GetPreviewItemHeight(CDC *pDC, CXTPGridRow *pRow, int nWidth, int nHeight) | CXTPGridPaintManager | virtual
GetPreviewLinesCount(CDC *pDC, CRect &rcText, const CString &strText) | CXTPGridPaintManager |
GetRowHeight(CDC *pDC, CXTPGridRow *pRow) | CXTPGridThemeOffice2013 | virtual
GetRowHeight(CDC *pDC, CXTPGridRow *pRow, int nTotalWidth) | CXTPGridThemeOffice2013 | virtual
GetRowHeightEx(CDC *pDC, CXTPGridRow *pRow, int nTotalWidth, const BOOL firstLevel=TRUE) | CXTPGridPaintManager |
GetSectionDividerHeight(XTPGridFixedRowsDividerStyle dividerStyle) | CXTPGridPaintManager |
GetTextFont() | CXTPGridPaintManager |
IsColumHotTrackingEnabled() const | CXTPGridPaintManager | virtual
IsColumnPlusMinusSign() const | CXTPGridPaintManager |
IsColumnWidthWYSIWYG() const | CXTPGridPaintManager |
IsDrawGridForEmptySpace() const | CXTPGridPaintManager |
IsFixedInplaceButtonHeight() const | CXTPGridPaintManager |
IsFixedRowHeight() const | CXTPGridPaintManager |
IsGridVisible(BOOL bVertical) const | CXTPGridPaintManager |
IsGridVisible(XTPGridOrientation orientation) const | CXTPGridPaintManager |
IsLastColumnWidthWYSIWYG() const | CXTPGridPaintManager |
IsPreviewMode() const | CXTPGridPaintManager |
IsPrintGroupRowIcon() const | CXTPGridPaintManager |
IsShowWYSIWYGMarkers() const | CXTPGridPaintManager |
IsUseDropMarker() const | CXTPGridPaintManager |
LoadGlyphs() | CXTPGridThemeOffice2013 | virtual
m_arStartCol | CXTPGridPaintManager |
m_bAllowMergeCells | CXTPGridPaintManager |
m_bBaseTreeIndent | CXTPGridPaintManager |
m_bCleanTooltip | CXTPGridPaintManager |
m_bColumnPlusMinusSign | CXTPGridPaintManager | protected
m_bColumnWidthWYSIWYG | CXTPGridPaintManager | protected
m_bCompactText | CXTPGridPaintManager |
m_bDrawGridForEmptySpace | CXTPGridPaintManager | protected
m_bFixedInplaceButtonHeight | CXTPGridPaintManager | protected
m_bFixedRowHeight | CXTPGridPaintManager | protected
m_bForceDynamicMarkupForCell | CXTPGridPaintManager |
m_bForceShowDropMarker | CXTPGridPaintManager |
m_bForceShowTooltip | CXTPGridPaintManager |
m_bGrayIfDisable | CXTPGridPaintManager |
m_bGroupRowTextBold | CXTPGridPaintManager |
m_bHideSelection | CXTPGridPaintManager |
m_bHotTracking | CXTPGridPaintManager |
m_bInvertColumnOnClick | CXTPGridPaintManager |
m_bIsPreviewMode | CXTPGridPaintManager | protected
m_bLastColumnWidthWYSIWYG | CXTPGridPaintManager | protected
m_bMakeUpper | CXTPGridPaintManager |
m_bMoveScrollbarOnFixedColumnsIndent | CXTPGridPaintManager |
m_bPrintGroupRowIcon | CXTPGridPaintManager | protected
m_bPrintPageRectangle | CXTPGridPaintManager |
m_bPrintSortTriangle | CXTPGridPaintManager |
m_bPrintVirtualPageNumber | CXTPGridPaintManager |
m_bPrintWatermark | CXTPGridPaintManager |
m_bRecOrRowNum | CXTPGridPaintManager |
m_bRevertAlignment | CXTPGridPaintManager |
m_bShadeGroupHeadings | CXTPGridPaintManager |
m_bShadeSortColumn | CXTPGridPaintManager |
m_bShowLockIcon | CXTPGridPaintManager |
m_bShowNonActiveInPlaceButton | CXTPGridPaintManager |
m_bShowWYSIWYGMarkers | CXTPGridPaintManager | protected
m_bSortTriangleOffsetFromRight | CXTPGridPaintManager |
m_bThemedInplaceButtons | CXTPGridPaintManager |
m_bUseAlternativeBackground | CXTPGridPaintManager |
m_bUseDropMarker | CXTPGridPaintManager |
m_bUseEditTextAlignment | CXTPGridPaintManager |
m_bUseGroupRowSelectionState | CXTPGridPaintManager |
m_bUseShellIcon | CXTPGridPaintManager |
m_clrAlternativeBackground | CXTPGridPaintManager |
m_clrBoldText | CXTPGridPaintManager |
m_clrBoldTextHighlight | CXTPGridPaintManager |
m_clrBtnFace | CXTPGridPaintManager |
m_clrBtnFacePressed | CXTPGridPaintManager |
m_clrBtnText | CXTPGridPaintManager |
m_clrCaptionText | CXTPGridPaintManager |
m_clrCaptionTextPressed | CXTPGridPaintManager |
m_clrColumnOffice2007CustomTheme | CXTPGridPaintManager |
m_clrConnector | CXTPGridPaintManager |
m_clrControlBack | CXTPGridPaintManager |
m_clrControlDark | CXTPGridPaintManager |
m_clrControlLightLight | CXTPGridPaintManager |
m_clrDisableBitmapDarkest | CXTPGridPaintManager |
m_clrDisableBitmapLightest | CXTPGridPaintManager |
m_clrFormulaSubSum | CXTPGridPaintManager |
m_clrFormulaSum | CXTPGridPaintManager |
m_clrFreezeColsDivider | CXTPGridPaintManager |
m_clrGlyph | CXTPGridThemeOffice2013 |
m_clrGlyphBorder | CXTPGridThemeOffice2013 |
m_clrGlyphContract | CXTPGridThemeOffice2013 |
m_clrGlyphExpand | CXTPGridThemeOffice2013 |
m_clrGlyphHighlight | CXTPGridThemeOffice2013 |
m_clrGradientColumnSeparator | CXTPGridPaintManager |
m_clrGradientColumnShadow | CXTPGridPaintManager |
m_clrGroupBoxBack | CXTPGridPaintManager |
m_clrGroupRowText | CXTPGridPaintManager |
m_clrGroupShadeBack | CXTPGridPaintManager |
m_clrGroupShadeBorder | CXTPGridPaintManager |
m_clrGroupShadeText | CXTPGridPaintManager |
m_clrHeaderControl | CXTPGridPaintManager |
m_clrHighlight | CXTPGridPaintManager |
m_clrHighlightText | CXTPGridPaintManager |
m_clrHotDivider | CXTPGridPaintManager |
m_clrIndentControl | CXTPGridPaintManager |
m_clrItemShade | CXTPGridPaintManager |
m_clrPreviewText | CXTPGridPaintManager |
m_clrSelectedRow | CXTPGridPaintManager |
m_clrSelectedRowText | CXTPGridPaintManager |
m_clrWindowText | CXTPGridPaintManager |
m_columnStyle | CXTPGridPaintManager | protected
m_crlNoGroupByText | CXTPGridPaintManager |
m_grcGradientColumn | CXTPGridPaintManager |
m_grcGradientColumnHot | CXTPGridPaintManager |
m_grcGradientColumnPushed | CXTPGridPaintManager |
m_iRecOrRowStart | CXTPGridPaintManager |
m_nBaseParentRecordIndent | CXTPGridPaintManager |
m_nFixedColumnsIndent | CXTPGridPaintManager |
m_nFooterHeight | CXTPGridPaintManager | protected
m_nFreezeColsDividerStyle | CXTPGridPaintManager | protected
m_nGridLineStylePreviousH | CXTPGridPaintManager | protected
m_nGridLineStylePreviousV | CXTPGridPaintManager | protected
m_nGroupGridLineHeight | CXTPGridPaintManager | protected
m_nGroupGridLineStyle | CXTPGridPaintManager | protected
m_nHeaderHeight | CXTPGridPaintManager | protected
m_nMaxPreviewLines | CXTPGridPaintManager | protected
m_nResizingWidth | CXTPGridPaintManager | protected
m_nRowHeight | CXTPGridPaintManager | protected
m_nRowHeightDefault | CXTPGridPaintManager |
m_nTextIndentForGroupRowsWithNoIcon | CXTPGridPaintManager |
m_nTreeColumnLineLength | CXTPGridPaintManager |
m_nTreeIndent | CXTPGridPaintManager |
m_nTreeStructureStyle | CXTPGridPaintManager |
m_nTreeTextIndent | CXTPGridPaintManager |
m_nTreeTextIndentGroupRow | CXTPGridPaintManager |
m_nTreeTextIndentRowChildren | CXTPGridPaintManager |
m_nTreeTextIndentRowParent | CXTPGridPaintManager |
m_pControl | CXTPGridPaintManager | protected
m_pGlyphs | CXTPGridPaintManager | protected
m_pHyperlinkHoverStyle | CXTPGridPaintManager |
m_pHyperlinkStyle | CXTPGridPaintManager |
m_pMarkupUIElement_NoGroupBy | CXTPGridPaintManager | protected
m_PrintPageWidth | CXTPGridPaintManager |
m_rcPreviewIndent | CXTPGridPaintManager |
m_RecordNumberWidth | CXTPGridPaintManager |
m_strCollapse | CXTPGridPaintManager |
m_strDecreasing | CXTPGridPaintManager |
m_strExpand | CXTPGridPaintManager |
m_strIncreasing | CXTPGridPaintManager |
m_strMarkupUIElement_NoGroupBy | CXTPGridPaintManager | protected
m_strNoFieldsAvailable | CXTPGridPaintManager |
m_strNoGroupBy | CXTPGridPaintManager |
m_strNoItems | CXTPGridPaintManager |
m_strSortBy | CXTPGridPaintManager |
m_szGlyph | CXTPGridPaintManager | protected
m_themeButton | CXTPGridPaintManager | protected
m_themeCombo | CXTPGridPaintManager | protected
m_themeHeader | CXTPGridPaintManager | protected
m_themeSpin | CXTPGridPaintManager | protected
m_treeStructureStyle | CXTPGridPaintManager |
m_xtpBrushGroupGridLineStyle | CXTPGridPaintManager | protected
m_xtpBrushHorizontalGrid | CXTPGridPaintManager | protected
m_xtpBrushTreeStructure | CXTPGridPaintManager | protected
m_xtpBrushVeriticalGrid | CXTPGridPaintManager | protected
m_xtpFontBoldText | CXTPGridPaintManager |
m_xtpFontCaption | CXTPGridPaintManager |
m_xtpFontPreview | CXTPGridPaintManager |
m_xtpFontText | CXTPGridPaintManager |
OnDrawAction(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs) | CXTPGridPaintManager | virtual
RecalcTotalHightOfMergedRows(CXTPGridColumns *pColumns, CDC *pDC, CXTPGridRow *pRow, int nRowHeight, int nTotalWidth) | CXTPGridPaintManager |
RefreshMetrics() | CXTPGridThemeVisualStudio2019 | virtual
SetCaptionFont(LOGFONT &lf) | CXTPGridPaintManager |
SetColumnOffice2007CustomThemeBaseColor(COLORREF clrBaseColor) | CXTPGridPaintManager |
SetColumnPlusMinusSign(BOOL bDraw) | CXTPGridPaintManager |
SetColumnStyle(XTPGridColumnStyle columnStyle) | CXTPGridPaintManager |
SetColumnWidthWYSIWYG(BOOL bColumnWidthWYSIWYG) | CXTPGridPaintManager |
SetDrawGridForEmptySpace(BOOL bDrawGrid) | CXTPGridPaintManager |
SetFixedRowHeight(BOOL bFixedRowHeight) | CXTPGridPaintManager |
SetFreezeColsDividerStyle(int nStyle) | CXTPGridPaintManager |
SetGridControl(CXTPGridControl *pControl) | CXTPGridPaintManager | virtual
SetHeaderHeight(int nHeight) | CXTPGridPaintManager | virtual
SetInplaceButtonHeight(BOOL bFixedInplaceButtonHeight) | CXTPGridPaintManager |
SetLastColumnWidthWYSIWYG(BOOL bColumnWidthWYSIWYG) | CXTPGridPaintManager |
SetMaxPreviewLines(int nMaxLines) | CXTPGridPaintManager |
SetPreviewIndent(int nLeft, int nTop, int nRight, int nBottom) | CXTPGridPaintManager |
SetPrintGroupRowIcon(BOOL bDraw) | CXTPGridPaintManager |
SetTextFont(LOGFONT &lf) | CXTPGridPaintManager |
ShowWYSIWYGMarkers(BOOL bSet) | CXTPGridPaintManager |
~CXTPGridPaintManager() | CXTPGridPaintManager | virtual


Toolkit Pro: XTPGridSections.h Source File

  • Source
  • GridControl
XTPGridSections.h
Go to the documentation of this file.
1
23#if !defined(__XTPGRIDSECTIONS_H__)
24# define __XTPGRIDSECTIONS_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPGridControl;
34class CXTPGridSection;
35class CXTPMarkupContext;
40enum XTPGridSection
41{
42 xtpGridSectionHeader = 0,
43 xtpGridSectionBody = 1,
44 xtpGridSectionFooter = 2,
45 xtpGridSectionCount = 3
46};
47
52class _XTP_EXT_CLASS CXTPGridSections : public CXTPCmdTarget
53{
54public:
60 CXTPGridSections(CXTPGridControl* pControl);
61
66 ~CXTPGridSections();
67
68public:
69 int Add(CXTPGridSection* pSection)
70 {
71 return (int)m_arrSections.Add(pSection);
72 }
73
74 CXTPGridSection* GetAt(int nIndex) const
75 {
76 CXTPGridSection* pSection = NULL;
77
78 if (GetSize() > nIndex) // Valid index
79 {
80 pSection = m_arrSections.GetAt(nIndex);
81 }
82
83 return pSection;
84 }
85
86 int GetSize() const
87 {
88 return int(m_arrSections.GetSize());
89 }
90
91 void RemoveAll()
92 {
93 m_arrSections.RemoveAll();
94 }
95
96public:
111 virtual BOOL EnsureVisible(CDC* pDC, CXTPGridRow* pRow);
112
120 CXTPGridRow* GetFocusedRow() const;
121
128 CRect GetRect() const;
129
138 CXTPGridSection* HitTest(CPoint pt) const;
139
145 virtual void Draw(CDC* pDC);
146
153 virtual void AdjustLayout(CDC* pDC, CRect rcSections);
154
160 void SetMarkupContext(CXTPMarkupContext* pMarkupContext);
161
166 virtual void ReSortRows();
167
173 virtual void RefreshIndexes(BOOL bAdjustLayout);
174
175 virtual void ResetContent();
176
177protected:
178 CXTPGridSection* FindSection(CXTPGridRow* pRow) const;
179
180protected:
181 CArray<CXTPGridSection*, CXTPGridSection*> m_arrSections;
182
183 CRect m_rcSections;
184 CXTPGridControl* m_pControl;
186private:
187# ifdef _XTP_ACTIVEX
188 DECLARE_OLETYPELIB_EX(CXTPGridSections);
189 DECLARE_DISPATCH_MAP()
190 DECLARE_INTERFACE_MAP()
191
192 int OleGetCount() const
193 {
194 return GetSize();
195 }
196
197 LPDISPATCH OleGetSection(int nIndex) const;
198# endif // _XTP_ACTIVEX
199};
201# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
202#endif //#if !defined(__XTPGRIDSECTIONS_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPGridSection
XTPGridSection
Defines a grid section.
Definition XTPGridSections.h:41
xtpGridSectionCount
@ xtpGridSectionCount
Number of default sections.
Definition XTPGridSections.h:45
xtpGridSectionFooter
@ xtpGridSectionFooter
Index of footer section.
Definition XTPGridSections.h:44
xtpGridSectionHeader
@ xtpGridSectionHeader
Index of header section.
Definition XTPGridSections.h:42
xtpGridSectionBody
@ xtpGridSectionBody
Index of body section.
Definition XTPGridSections.h:43
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPGridControl
The CXTPGridControl class provides an implementation of the Grid control.
Definition XTPGridControl.h:479
CXTPGridRow
CXTPGridRow class represents a row of the Grid control window.
Definition XTPGridRow.h:71
CXTPGridSection
Represents a grid section.
Definition XTPGridSection.h:61
CXTPGridSections
Collection of sections.
Definition XTPGridSections.h:53
CXTPGridSections::SetMarkupContext
void SetMarkupContext(CXTPMarkupContext *pMarkupContext)
Sets the markup context.
CXTPGridSections::ReSortRows
virtual void ReSortRows()
Re-sorts the rows for all sections.
CXTPGridSections::GetFocusedRow
CXTPGridRow * GetFocusedRow() const
Gets the currently focused row in the Grid control's view.
CXTPGridSections::GetRect
CRect GetRect() const
Retrieves the current rectangle for the sections.
CXTPGridSections::Draw
virtual void Draw(CDC *pDC)
Draws the sections to the device context.
CXTPGridSections::RefreshIndexes
virtual void RefreshIndexes(BOOL bAdjustLayout)
Recalculates the indices of all rows.
CXTPGridSections::HitTest
CXTPGridSection * HitTest(CPoint pt) const
Determines which section, if any, is at a specified point.
CXTPGridSections::m_pControl
CXTPGridControl * m_pControl
Parent control.
Definition XTPGridSections.h:184
CXTPGridSections::CXTPGridSections
CXTPGridSections(CXTPGridControl *pControl)
Constructs the collection and default sections.
CXTPGridSections::AdjustLayout
virtual void AdjustLayout(CDC *pDC, CRect rcSections)
Adjusts section areas depending on the current control size.
CXTPGridSections::~CXTPGridSections
~CXTPGridSections()
Destructs the collection and sections.
CXTPGridSections::m_rcSections
CRect m_rcSections
Sections rectangle.
Definition XTPGridSections.h:183
CXTPGridSections::EnsureVisible
virtual BOOL EnsureVisible(CDC *pDC, CXTPGridRow *pRow)
Ensures that a Grid control row is at least partially visible.
CXTPMarkupContext
CXTPMarkupContext is a standalone class used to provide common settings for Markup objects.
Definition XTPMarkupContext.h:128


Toolkit Pro: XTPChartPanel.h Source File

  • Source
  • Chart
XTPChartPanel.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTPANEL_H__)
24# define __XTPCHARTPANEL_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartDiagram;
34class CXTPChartPanelCollection;
35class CXTPChartTitleCollection;
36
47class _XTP_EXT_CLASS CXTPChartPanel : public CXTPChartElement
48{
49 DECLARE_DYNAMIC(CXTPChartPanel);
50
51public:
56 CXTPChartPanel();
57
62 virtual ~CXTPChartPanel();
63
64public:
72 CXTPChartTitleCollection* GetTitles() const;
73
74public:
75 void Remove();
76
77 virtual void DoPropExchange(CXTPPropExchange* pPX);
78
79public:
80protected:
81 CXTPChartTitleCollection* m_pTitles;
82
83protected:
84 friend class CXTPChartPanelCollection;
85 friend class CXTPChartContent;
86};
87
98class _XTP_EXT_CLASS CXTPChartPanelCollection : public CXTPChartElementCollection
99{
100public:
106 CXTPChartPanelCollection(CXTPChartContent* pOwner);
107
112 virtual ~CXTPChartPanelCollection();
113
114public:
122 CXTPChartPanel* Add(CXTPChartPanel* pPanel);
123
134 CXTPChartPanel* GetAt(int nIndex) const;
135
136public:
137 void DoPropExchange(CXTPPropExchange* pPX);
138
139protected:
140# ifdef _XTP_ACTIVEX
141public:
143 DECLARE_DISPATCH_MAP()
144 DECLARE_INTERFACE_MAP()
145
146 DECLARE_OLETYPELIB_EX(CXTPChartPanelCollection);
147
148 afx_msg long OleGetItemCount();
149 afx_msg LPDISPATCH OleGetItem(long nIndex);
150 void OleAdd(LPDISPATCH lpDisp);
151 DECLARE_ENUM_VARIANT(CXTPChartPanelCollection)
152
154# endif
155protected:
156 friend class CXTPChartContent;
157};
158
159AFX_INLINE CXTPChartPanel* CXTPChartPanelCollection::GetAt(int nIndex) const
160{
161 return nIndex >= 0 && nIndex < m_arrElements.GetSize()
162 ? (CXTPChartPanel*)m_arrElements.GetAt(nIndex)
163 : NULL;
164}
165AFX_INLINE CXTPChartTitleCollection* CXTPChartPanel::GetTitles() const
166{
167 return m_pTitles;
168}
170# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
171#endif //#if !defined(__XTPCHARTPANEL_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartContent
This class represents chart content, which is a kind of CXTPChartElement.
Definition XTPChartContent.h:66
CXTPChartDiagram
This class represents a chart diagram, which is a kind of CXTPChartElement.
Definition XTPChartDiagram.h:48
CXTPChartElementCollection
This class abstracts a chart collection.
Definition XTPChartElement.h:358
CXTPChartElementCollection::m_arrElements
CArray< CXTPChartElement *, CXTPChartElement * > m_arrElements
Array of CXTPChartElement pointer.
Definition XTPChartElement.h:450
CXTPChartElement
This class abstracts a chart element, this class acts as a base class for all chart elements.
Definition XTPChartElement.h:131
CXTPChartPanelCollection
This class abstracts a chart panel collection.
Definition XTPChartPanel.h:99
CXTPChartPanelCollection::DoPropExchange
void DoPropExchange(CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
CXTPChartPanelCollection::~CXTPChartPanelCollection
virtual ~CXTPChartPanelCollection()
Destroys a CXTPChartPanelCollection object, handles cleanup.
CXTPChartPanelCollection::CXTPChartPanelCollection
CXTPChartPanelCollection(CXTPChartContent *pOwner)
Constructs a CXTPChartPanelCollection object.
CXTPChartPanelCollection::GetAt
CXTPChartPanel * GetAt(int nIndex) const
Call this function to get the panel at a particular index in the collection.
Definition XTPChartPanel.h:159
CXTPChartPanelCollection::Add
CXTPChartPanel * Add(CXTPChartPanel *pPanel)
Call this function to add a panel to the collection.
CXTPChartPanel
This class abstracts a chart panel.
Definition XTPChartPanel.h:48
CXTPChartPanel::DoPropExchange
virtual void DoPropExchange(CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
CXTPChartPanel::CXTPChartPanel
CXTPChartPanel()
Constructs a CXTPChartPanel object.
CXTPChartPanel::GetTitles
CXTPChartTitleCollection * GetTitles() const
Call this function to get the the title collection object.
Definition XTPChartPanel.h:165
CXTPChartPanel::~CXTPChartPanel
virtual ~CXTPChartPanel()
Destroys a CXTPChartMarker object, handles cleanup.
CXTPChartTitleCollection
CXTPChartTitleCollection represents a collection of chart titles.
Definition XTPChartTitle.h:339
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72


Toolkit Pro: Member List

CXTPCommandBarsOffice2013Theme Member List

This is the complete list of members for CXTPCommandBarsOffice2013Theme, including all inherited members.

AdjustExcludeRect(CRect &rc, CXTPControl *pControl, BOOL bVertical) | CXTPCommandBarsOfficeXPTheme | virtual
Animate(CDC *pDestDC, CDC *pSrcDC, CRect rc, XTPAnimationType animationType) | CXTPPaintManager | virtual
AnimateExpanding(CXTPCommandBar *pCommandBar, CDC *pDestDC, CDC *pSrcDC, BOOL bExpandDown) | CXTPPaintManager | virtual
BaseTheme() | CXTPCommandBarsOffice2013Theme | virtual
CreateTheme(XTPPaintTheme paintTheme) | CXTPPaintManager | static
CXTPCmdTarget() | CXTPCmdTarget |
CXTPCommandBarsModernUITheme() | CXTPCommandBarsModernUITheme |
CXTPCommandBarsOffice2013Theme() | CXTPCommandBarsOffice2013Theme |
CXTPCommandBarsOfficeXPTheme() | CXTPCommandBarsOfficeXPTheme |
CXTPObservable() | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | protected
CXTPPaintManager() | CXTPPaintManager | protected
Draw3dRect(CDC *pDC, LPCRECT rc, int nTopLeft, int nBottomRight) | CXTPPaintManager |
Draw3dRect(CDC *pDC, LPCRECT rc, int frameThickness, COLORREF clrPen, COLORREF clrBrush) | CXTPPaintManager |
CXTPPaintManager::DrawCheckMark(CDC *pDC, CRect rcCheck, COLORREF clr=0) | CXTPPaintManager | inline
DrawComboExpandMark(CDC *pDC, CRect rc, COLORREF clr) | CXTPPaintManager | virtual
DrawCommandBarGripper(CDC *pDC, CXTPCommandBar *pBar, BOOL bDraw=TRUE) | CXTPCommandBarsOffice2013Theme | protectedvirtual
DrawCommandBarGroupSeparator(CDC *pDC, CXTPCommandBar *pBar, CXTPControl *pLeftControl, CXTPControl *pRightControl, BOOL bDraw) | CXTPCommandBarsOffice2013Theme | virtual
DrawCommandBarSeparator(CDC *pDC, CXTPCommandBar *pBar, CXTPControl *pControl, BOOL bDraw=TRUE) | CXTPCommandBarsOffice2013Theme | protectedvirtual
DrawControl(CDC *pDC, CXTPControl *pButton, BOOL bDraw=TRUE) | CXTPPaintManager |
DrawControlCheckBoxMark(CDC *pDC, CXTPControl *pButton, CRect rc, BOOL bDraw) | CXTPCommandBarsOffice2013Theme | protectedvirtual
DrawControlCheckBoxMark(CDC *pDC, CRect rc, BOOL bDraw, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled) | CXTPCommandBarsOffice2013Theme | protectedvirtual
DrawControlComboBox(CDC *pDC, CXTPControlComboBox *pComboBox, BOOL bDraw) | CXTPCommandBarsOffice2013Theme | protectedvirtual
DrawControlEdit(CDC *pDC, CXTPControlEdit *pEdit, BOOL bDraw) | CXTPCommandBarsOffice2013Theme | virtual
DrawControlEntry(CDC *pDC, CXTPControl *pButton) | CXTPPaintManager | virtual
DrawControlMDIButton(CDC *pDC, CXTPControlButton *pButton) | CXTPCommandBarsOffice2013Theme | protectedvirtual
DrawControlPopupParent(CDC *pDC, CXTPControl *pButton, BOOL bDraw) | CXTPCommandBarsOfficeXPTheme | protectedvirtual
DrawControlRadioButtonMark(CDC *pDC, CRect rc, BOOL bDraw, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled) | CXTPCommandBarsOffice2013Theme | protectedvirtual
DrawControlText(CDC *pDC, CXTPControl *pControl, CRect rcText, BOOL bDraw, BOOL bVert, BOOL bCentered, BOOL bTriangled) | CXTPPaintManager |
DrawControlToolBarParent(CDC *pDC, CXTPControl *pButton, BOOL bDraw) | CXTPPaintManager | virtual
DrawDialogBarGripper(CDC *pDC, CXTPDialogBar *pBar, BOOL bDraw) | CXTPCommandBarsOfficeXPTheme | virtual
DrawDropDownGlyph(CDC *pDC, CXTPControl *pControl, CPoint pt, BOOL bSelected, BOOL bPopuped, BOOL bEnabled, BOOL bVert) | CXTPCommandBarsOffice2013Theme | protectedvirtual
DrawExpandGlyph(CDC *pDC, CXTPControl *pButton, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clr) | CXTPCommandBarsOffice2013Theme | protectedvirtual
DrawExpandGlyph(CDC *pDC, CXTPControl *pButton, COLORREF clr, BOOL bVertical) | CXTPCommandBarsOffice2013Theme | protectedvirtual
DrawFrameBorder(CDC *pDC, CRect rc, int nBorderThickness, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition) | CXTPCommandBarsOffice2013Theme | protected
DrawGalleryItemBack(CDC *pDC, CRect rcItem, BOOL bEnabled, BOOL bSelected, BOOL bPressed, BOOL bChecked, XTPBarType barType) | CXTPCommandBarsOffice2013Theme | virtual
DrawHiddenGlyph(CDC *pDC, CXTPControl *pButton, COLORREF clr, BOOL bVertical) | CXTPCommandBarsOffice2013Theme | protectedvirtual
DrawImage(CDC *pDC, CPoint pt, CSize sz, CXTPImageManagerIcon *pImage, BOOL bSelected, BOOL bPressed, BOOL bEnabled=TRUE, BOOL bChecked=FALSE, BOOL bPopuped=FALSE, BOOL bToolBarImage=TRUE) | CXTPCommandBarsOfficeXPTheme | protectedvirtual
DrawListBoxControl(CDC *pDC, CXTPControl *pButton, CRect rc, BOOL bSelected, BOOL bDraw, CXTPCommandBars *pCommandBars=0) | CXTPCommandBarsOfficeXPTheme | virtual
DrawPopupBarCheckMark(CDC *pDC, CRect rcCheck, BOOL bEnabled, COLORREF clr) | CXTPPaintManager | virtual
DrawPopupBarGripper(CDC *pDC, int xPos, int yPos, int cx, int cy, BOOL bExpanded=FALSE) | CXTPCommandBarsOffice2013Theme | protectedvirtual
DrawPopupBarRadioMark(CDC *pDC, CRect rcCheck, BOOL bEnabled, COLORREF clr) | CXTPPaintManager | virtual
DrawPopupResizeGripper(CDC *pDC, CRect rcGripper, int nFlags) | CXTPCommandBarsOfficeXPTheme | virtual
DrawRectangle(CDC *pDC, CXTPControl *pButton) | CXTPCommandBarsOffice2013Theme | virtual
DrawRectangle(CDC *pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition) | CXTPCommandBarsOffice2013Theme | protectedvirtual
DrawRectangle(CDC *pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition, int nID) | CXTPCommandBarsOffice2013Theme | protectedvirtual
DrawSpecialControl(CDC *pDC, XTPSpecialControl controlType, CXTPControl *pButton, CXTPCommandBar *pBar, BOOL bDraw, LPVOID lpParam) | CXTPPaintManager | virtual
DrawSplitButtonFrame(CDC *pDC, CXTPControl *pButton, CRect rc) | CXTPCommandBarsOffice2013Theme | protectedvirtual
DrawTearOffGripper(CDC *pDC, CRect rcGripper, BOOL bSelected, BOOL bDraw) | CXTPCommandBarsOfficeXPTheme | virtual
FillCommandBarEntry(CDC *pDC, CXTPCommandBar *pBar) | CXTPCommandBarsOffice2013Theme | virtual
FillDockBar(CDC *pDC, CXTPDockBar *pBar) | CXTPCommandBarsOffice2013Theme | virtual
FillIntersectRect(CDC *pDC, CXTPPopupBar *pPopupBar, COLORREF clr) | CXTPCommandBarsOfficeXPTheme | protected
FillWorkspace(CDC *pDC, CRect rc, CRect rcExclude) | CXTPCommandBarsOffice2013Theme | virtual
FontExists(LPCTSTR lpszFaceName) | CXTPPaintManager | static
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCommandBarBorders(CXTPCommandBar *pBar) | CXTPPaintManager | virtual
GetCommandBarFont(CXTPCommandBar *pCommandBar) | CXTPPaintManager | virtual
GetControlBackColor(CXTPControl *pButton) | CXTPCommandBarsOffice2013Theme | protectedvirtual
GetControlEditBackColor(CXTPControl *pControl) | CXTPCommandBarsOffice2013Theme | virtual
GetControlFont(CXTPControl *pControl) | CXTPPaintManager | virtual
GetControlHeight() const | CXTPPaintManager |
GetControlTextColor(CXTPControl *pButton) | CXTPCommandBarsOffice2013Theme | protectedvirtual
GetControlTextOrientation(CXTPControl *pControl) | CXTPPaintManager | virtual
GetCurrentSystemTheme() | CXTPPaintManager |
GetCurrentTheme() | CXTPPaintManager | inline
GetDefaultCommandBarSize(CXTPCommandBar *pBar) | CXTPPaintManager | virtual
GetFramePaintManager() | CXTPCommandBarsModernUITheme | virtual
GetGalleryPaintManager() const | CXTPPaintManager | virtual
GetGlobalPaintManager() | CXTPPaintManager | static
GetIconFont() | CXTPPaintManager |
GetIconsInfo() | CXTPPaintManager |
GetInstanceAddRef() | CXTPPaintManager | static
GetMarkupContext() | CXTPCommandBarsModernUITheme | virtual
GetMessageBarPaintManager() | CXTPPaintManager | virtual
GetPopupBarGripperWidth(CXTPCommandBar *pBar) | CXTPPaintManager | virtual
GetProgressPaintManager() const | CXTPPaintManager | virtual
GetRectangleTextColor(BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition) | CXTPCommandBarsOffice2013Theme | protectedvirtual
GetRegularBoldFont() | CXTPPaintManager |
GetRegularFont() | CXTPPaintManager |
GetRibbonPaintManager() | CXTPCommandBarsModernUITheme | virtual
GetScrollBarPaintManager() const | CXTPPaintManager | virtual
GetShadowManager() const | CXTPPaintManager |
GetShadowOptions() const | CXTPPaintManager |
GetSliderPaintManager() const | CXTPPaintManager | virtual
GetSmCaptionFont() | CXTPPaintManager |
GetSplitButtonCommandRect(CXTPControl *pButton) | CXTPPaintManager | virtual
GetStatusBarPaintManager() | CXTPPaintManager | virtual
GetXtremeColor(UINT nIndex) | CXTPPaintManager |
GradientFill(CDC *pDC, LPRECT lpRect, COLORREF crFrom, COLORREF crTo, BOOL bHorz, LPCRECT lpRectClip=NULL) | CXTPPaintManager |
HorizontalLine(CDC *pDC, int x0, int y0, int x1, COLORREF clrPen) | CXTPPaintManager |
IsUseSystemAccentColorEnabled() const | CXTPPaintManager |
Line(CDC *pDC, CPoint p0, CPoint p1) | CXTPPaintManager |
Line(CDC *pDC, int x0, int y0, int x1, int y1, const int nPen) | CXTPPaintManager |
Line(CDC *pDC, int x0, int y0, int x1, int y1, COLORREF clrPen) | CXTPPaintManager |
m_arrColor | CXTPPaintManager | protected
m_bAutoResizeIcons | CXTPPaintManager |
m_bClearTypeTextQuality | CXTPPaintManager |
m_bEmbossedDisabledText | CXTPPaintManager | protected
m_bEnableAnimation | CXTPPaintManager |
m_bFlatMenuBar | CXTPPaintManager |
m_bFlatToolBar | CXTPPaintManager |
m_bIntersect | CXTPCommandBarsOffice2013Theme | protected
m_bOffice2007Padding | CXTPPaintManager |
m_bOffsetPopupLabelText | CXTPPaintManager |
m_bSelectImageInPopupBar | CXTPPaintManager |
m_bShowKeyboardCues | CXTPPaintManager | protected
m_bShowShadow | CXTPPaintManager |
m_bThemedCheckBox | CXTPPaintManager |
m_bThemedStatusBar | CXTPPaintManager |
m_bThickCheckMark | CXTPPaintManager |
m_bUseOfficeFont | CXTPPaintManager |
m_bUseStandardFont | CXTPPaintManager | protected
m_bWrapCaptionBelowText | CXTPPaintManager |
m_clr3DShadow | CXTPCommandBarsOffice2013Theme | protected
m_clrBack | CXTPCommandBarsOffice2013Theme | protected
m_clrBtnFace | CXTPCommandBarsOffice2013Theme | protected
m_clrCaptionButtonFill | CXTPCommandBarsOffice2013Theme | protected
m_clrDisabledIcon | CXTPPaintManager |
m_clrFloatingGripper | CXTPPaintManager |
m_clrFloatingGripperText | CXTPPaintManager |
m_clrGlyph | CXTPCommandBarsOffice2013Theme | protected
m_clrGlyphDisabled | CXTPCommandBarsOffice2013Theme | protected
m_clrGlyphHighlight | CXTPCommandBarsOffice2013Theme | protected
m_clrGlyphPushed | CXTPCommandBarsOffice2013Theme | protected
m_clrHighlight | CXTPCommandBarsOffice2013Theme | protected
m_clrMessageBarText | CXTPCommandBarsOffice2013Theme | protected
m_clrWorkspace | CXTPCommandBarsOffice2013Theme | protected
m_csCheckBox | CXTPCommandBarsOffice2013Theme | protected
m_csCheckMark | CXTPCommandBarsOffice2013Theme | protected
m_csComboBox | CXTPCommandBarsOffice2013Theme | protected
m_csMenu | CXTPCommandBarsOffice2013Theme | protected
m_csMenuTitleBar | CXTPCommandBarsOffice2013Theme | protected
m_csRibbon | CXTPCommandBarsOffice2013Theme | protected
m_csToolbar | CXTPCommandBarsOffice2013Theme | protected
m_fontIcon | CXTPPaintManager |
m_fontIconBold | CXTPPaintManager |
m_fontSmCaption | CXTPPaintManager |
m_fontToolTip | CXTPPaintManager |
m_iconsInfo | CXTPPaintManager | protected
m_nAnimationSteps | CXTPPaintManager | protected
m_nAnimationTime | CXTPPaintManager | protected
m_nEditHeight | CXTPPaintManager | protected
m_nFontHeight | CXTPPaintManager | protected
m_nPopupBarTextPadding | CXTPPaintManager |
m_nSplitButtonDropDownHeight | CXTPPaintManager |
m_nSplitButtonDropDownWidth | CXTPPaintManager |
m_nSplitButtonPopupWidth | CXTPPaintManager |
m_nStatusBarMinHeight | CXTPPaintManager |
m_nTextHeight | CXTPPaintManager |
m_pfnSetLayeredWindowAttributes | CXTPPaintManager |
m_pFramePaintManager | CXTPPaintManager |
m_pGalleryPaintManager | CXTPPaintManager |
m_pImages | CXTPCommandBarsModernUITheme | protected
m_pMarkupContext | CXTPCommandBarsModernUITheme | protected
m_pProgressPaintManager | CXTPPaintManager |
m_pRibbonPaintManager | CXTPPaintManager |
m_pScrollBarPaintManager | CXTPPaintManager |
m_pShadowManager | CXTPPaintManager | protected
m_pSliderPaintManager | CXTPPaintManager |
m_pStatusBarPaintManager | CXTPPaintManager |
m_rcMessageBarMargin | CXTPPaintManager |
m_rcStatusBarBorder | CXTPPaintManager |
m_strOfficeFont | CXTPPaintManager |
m_systemTheme | CXTPPaintManager | protected
m_themeButton | CXTPPaintManager | protected
m_themeCurrent | CXTPPaintManager | protected
m_themeStatusBar | CXTPPaintManager | protected
m_xtpFontRegular | CXTPPaintManager | protected
m_xtpFontRegularBold | CXTPPaintManager | protected
m_xtpFontVert | CXTPPaintManager | protected
m_xtpFontVertBold | CXTPPaintManager | protected
Notify(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *)) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
Notify(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1), A1 arg1) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
Notify(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
Notify(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamic(void(T::*method)(O *)) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1), A1 arg1) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *)) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1), A1 arg1) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyReversed(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *)) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyReversed(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1), A1 arg1) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyReversed(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyReversed(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
Pixel(CDC *pDC, int xPos, int yPos, int nPen) | CXTPPaintManager |
Rectangle(CDC *pDC, LPCRECT rc, int nPen, const int nBrush) | CXTPPaintManager |
Rectangle(CDC *pDC, LPCRECT rc, COLORREF clrPen, COLORREF clrBrush) | CXTPPaintManager |
RefreshMetrics() | CXTPCommandBarsOffice2013Theme | protectedvirtual
RefreshStandardColors() | CXTPCommandBarsOffice2013Theme | protectedvirtual
ReleaseInstance() | CXTPPaintManager | static
RequiresResourceImages() | CXTPCommandBarsOffice2013Theme | virtual
RoundRect(CDC *pDC, LPCRECT rc, COLORREF clrPen, COLORREF clrBrush) | CXTPPaintManager |
SetAnimationDelay(int nAnimationSteps, int nAnimationTime) | CXTPPaintManager |
SetColors(int cElements, CONST INT *lpaElements, CONST COLORREF *lpaRgbValues) | CXTPPaintManager |
SetCommandBarRegion(CXTPCommandBar *pCommandBar) | CXTPPaintManager | virtual
SetCommandBarsFontIndirect(LOGFONT *pLogFont, BOOL bUseStandardFont=FALSE) | CXTPPaintManager |
SetCustomTheme(CXTPPaintManager *pTheme) | CXTPPaintManager | static
SetGlobalPaintManager(CXTPPaintManager *pPaintManager) | CXTPPaintManager | static
SetImageHandle(HMODULE hResource, LPCTSTR lpszIniFileName) | CXTPPaintManager | virtual
SetLunaTheme(XTPCurrentSystemTheme systemTheme) | CXTPPaintManager |
SetTheme(XTPPaintTheme paintTheme) | CXTPPaintManager | static
StripMnemonics(CString &strClear) | CXTPPaintManager | static
Subscribe(IXTPPaintManagerEvents *pObserver, CXTPSubscriptionList< CXTPPaintManager, IXTPPaintManagerEvents > *pSubcriptionList=NULL) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > |
Triangle(CDC *pDC, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clr) | CXTPPaintManager | static
Unsubscribe(IXTPPaintManagerEvents *pObserver) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > |
UpdateColors() | CXTPPaintManager | virtual
UpdateFonts() | CXTPPaintManager | virtual
UpdateRTLCaption(CString &strCaption) | CXTPPaintManager | virtual
UseOfficeFont(bool bUseOfficeFont) | CXTPPaintManager |
VerticalLine(CDC *pDC, int x0, int y0, int y1, COLORREF clrPen) | CXTPPaintManager |
~CXTPCommandBarsModernUITheme() | CXTPCommandBarsModernUITheme | virtual
~CXTPCommandBarsOffice2013Theme() | CXTPCommandBarsOffice2013Theme | virtual
~CXTPObservable() | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | protected
~CXTPPaintManager() | CXTPPaintManager | protectedvirtual


Toolkit Pro: XTPSkinManagerColorFilter.h Source File

  • Source
  • SkinFramework
XTPSkinManagerColorFilter.h
Go to the documentation of this file.
1
23#if !defined(__XTPSKINIMAGECOLORFILTER_H__)
24# define __XTPSKINIMAGECOLORFILTER_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
39class _XTP_EXT_CLASS CXTPSkinManagerColorFilter
40{
41public:
46 virtual ~CXTPSkinManagerColorFilter()
47 {
48 }
49
55 virtual void ApplyColorFilter(COLORREF& clr) = 0;
56};
57
60class _XTP_EXT_CLASS CXTPSkinManagerColorFilterColorize : public CXTPSkinManagerColorFilter
61{
62public:
63 CXTPSkinManagerColorFilterColorize(BYTE hue, BYTE sat, float blend);
64
65public:
66 virtual void ApplyColorFilter(COLORREF& clr);
67
68protected:
69 BYTE m_hue;
70 BYTE m_sat;
71 float m_blend;
72};
73
74class _XTP_EXT_CLASS CXTPSkinManagerColorFilterShiftRGB : public CXTPSkinManagerColorFilter
75{
76public:
77 CXTPSkinManagerColorFilterShiftRGB(long r, long g, long b);
78
79public:
80 virtual void ApplyColorFilter(COLORREF& clr);
81
82protected:
83 long m_r;
84 long m_g;
85 long m_b;
86};
89# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
91#endif // !defined(__XTPSKINIMAGECOLORFILTER_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPSkinManagerColorFilter
CXTPSkinManagerColorFilter represents the parent class for all color filters of skin manager.
Definition XTPSkinManagerColorFilter.h:40
CXTPSkinManagerColorFilter::ApplyColorFilter
virtual void ApplyColorFilter(COLORREF &clr)=0
Modifies the color of the skin manager before drawing the skin.
CXTPSkinManagerColorFilter::~CXTPSkinManagerColorFilter
virtual ~CXTPSkinManagerColorFilter()
Handles color filter object destruction.
Definition XTPSkinManagerColorFilter.h:46


Toolkit Pro: XTPOpenGLTriangleRenderList.h Source File

  • Source
  • GraphicLibrary
  • OpenGL
XTPOpenGLTriangleRenderList.h
Go to the documentation of this file.
1
23#if !defined(__XTPOPENGLTRIANGLERENDERLIST_H__)
24# define __XTPOPENGLTRIANGLERENDERLIST_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
35class _XTP_EXT_CLASS CXTPOpenGLTriangleRenderList
36{
37public:
38 CXTPOpenGLTriangleRenderList();
39 ~CXTPOpenGLTriangleRenderList();
40
41 BOOL IsEmpty() const;
42 void SetCurrentMatrices();
43 void SetCurrentColor(float r, float g, float b, float a);
44 void Add(const CXTPPoint3d& a, const CXTPPoint3d& an, const CXTPPoint3d& b,
45 const CXTPPoint3d& bn, const CXTPPoint3d& c, const CXTPPoint3d& cn);
46 void Commit();
47 void RenderAll();
48 void Reset();
49 void SetJitter(const CXTPPoint3d& offset);
50
51private:
52 struct State
53 {
54 UINT nRefs;
55 GLfloat mView[16];
56
57 void Activate(const CXTPPoint3d& jitter);
58 };
59
60 struct Color
61 {
62 UINT nRefs;
63 float r;
64 float g;
65 float b;
66 float a;
67
68 void Activate();
69 };
70
71 struct Triangle
72 {
73 State* pState;
74 Color* pColor;
75 double dDist;
76 struct Vertices
77 {
78 CXTPPoint3d v, n;
79 } a, b, c;
80 };
81
82 static int __cdecl Compare(const void* x, const void* y);
83 void PushRenderState(Triangle& triangle);
84 void PopRenderState();
85 void RenderTriangle(const CXTPPoint3d& a, const CXTPPoint3d& an, const CXTPPoint3d& b,
86 const CXTPPoint3d& bn, const CXTPPoint3d& c, const CXTPPoint3d& cn);
87 void ClearTriangleList();
88
89 CArray<Triangle*, Triangle*> m_list;
90 CList<State, const State&> m_states;
91 CList<Color, const Color&> m_colors;
92 CList<State*, State*> m_RenderStateQueue;
93 CList<Color*, Color*> m_RenderColorQueue;
94 CXTPPoint3d m_jitter;
95 BOOL m_bCommitted;
96};
97
98AFX_INLINE BOOL CXTPOpenGLTriangleRenderList::IsEmpty() const
99{
100 return m_list.GetSize() == 0;
101}
102
103AFX_INLINE void CXTPOpenGLTriangleRenderList::SetJitter(const CXTPPoint3d& offset)
104{
105 m_jitter = offset;
106}
107
110# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
112#endif // #if !defined(__XTPOPENGLTRIANGLERENDERLIST_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPPoint3T< double >


Toolkit Pro: Member List

CXTPChart3dPyramidSeriesLabelDeviceCommand Member List

This is the complete list of members for CXTPChart3dPyramidSeriesLabelDeviceCommand, including all inherited members.

AddChildCommand(CXTPChartDeviceCommand *pCommand) | CXTPChartDeviceCommand |
AfterExecute(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
ApplySeriesStyle(CXTPChartSeriesStyle *pStyle) | CXTPChartDeviceCommand | virtual
BeforeExecute(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
BindView(CXTPChartElementView *pView) | CXTPChartDeviceCommand |
Commit() | CXTPChartDeviceCommand |
ComputeConnectorVector(CXTPChart3dDeviceContext *pDC) | CXTPChart3dPyramidSeriesLabelDeviceCommand |
ComputeLabel(CXTPChart3dDeviceContext *pDC) | CXTPChart3dPyramidSeriesLabelDeviceCommand |
CXTPChart3dDeviceCommand(XTPChart3dAntialiasingPolicy nAntialiasingPolicy) | CXTPChart3dDeviceCommand | protected
CXTPChart3dPyramidSeriesLabelDeviceCommand(CXTPChart3dPyramidSeriesLabelView *pSeriesLabelView) | CXTPChart3dPyramidSeriesLabelDeviceCommand |
CXTPChartDeviceCommand() | CXTPChartDeviceCommand |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPObservable() | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | protected
Execute(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
ExecuteOverride(CXTPChartDeviceContext *pDC) | CXTPChart3dPyramidSeriesLabelDeviceCommand | virtual
GetBoundView() const | CXTPChartDeviceCommand |
GetChildCommand(int nIndex) const | CXTPChartDeviceCommand |
GetChildCommandCount() const | CXTPChartDeviceCommand |
GetConnectorEndpointVerticalOffset() const | CXTPChart3dPyramidSeriesLabelDeviceCommand |
GetConnectorLength() const | CXTPChart3dPyramidSeriesLabelDeviceCommand |
GetCurrentDC() const | CXTPChartDeviceCommand |
GetLabelRect() const | CXTPChart3dPyramidSeriesLabelDeviceCommand |
GetPassNumber() const | CXTPChartDeviceCommand |
GetSeriesLabelView() const | CXTPChart3dPyramidSeriesLabelDeviceCommand |
HitTest(CPoint point, CXTPChartElement *pParent) const | CXTPChartDeviceCommand | virtual
Is3D() const | CXTPChartObject |
IsCommitted() const | CXTPChartDeviceCommand |
IsEnabled() const | CXTPChart3dDeviceCommand | virtual
IsFailed() const | CXTPChart3dPyramidSeriesLabelDeviceCommand |
m_arrChildren | CXTPChartDeviceCommand | protected
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Prepare(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
PrepareOverride(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
SetConnectorEndpointVerticalOffset(double yOffset) | CXTPChart3dPyramidSeriesLabelDeviceCommand |
SetConnectorLength(double dLength) | CXTPChart3dPyramidSeriesLabelDeviceCommand |
SetEnabled(BOOL bEnabled=TRUE) | CXTPChartDeviceCommand |
SetFailed() | CXTPChart3dPyramidSeriesLabelDeviceCommand |
SetLabelRect(CRect rcLabel) | CXTPChart3dPyramidSeriesLabelDeviceCommand |
Subscribe(CXTPChartDeviceCommandEvents *pObserver, CXTPSubscriptionList< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > *pSubcriptionList=NULL) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > |
Unsubscribe(CXTPChartDeviceCommandEvents *pObserver) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > |
~CXTPChartDeviceCommand() | CXTPChartDeviceCommand | virtual
~CXTPObservable() | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | protected


Toolkit Pro: XTPCheckListBox.h Source File

  • Source
  • Controls
  • ListBox
XTPCheckListBox.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHECKLISTBOX_H__)
24# define __XTPCHECKLISTBOX_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPWinThemeWrapper;
34
61class _XTP_EXT_CLASS CXTPCheckListBox : public CXTPListBox
62{
64 DECLARE_DYNAMIC(CXTPCheckListBox)
66protected:
73 class _XTP_EXT_CLASS CCheckListState
74 {
75 public:
81 CCheckListState(BOOL bListBox3D);
82
91 void Draw(CDC* pDC, int nCheck, CPoint pt, CSize sz);
92
97 virtual ~CCheckListState();
98
99 public:
100 CSize m_sizeCheck;
101 CSize m_sizeCheckThemed;
102 protected:
103 int idUnchecked;
104 int idChecked;
105 int idMixed;
106
107 private:
108 BOOL m_bIconsSet;
109 };
110
111private:
112 struct CHECK_DATA;
113
114public:
120 CXTPCheckListBox(BOOL bListBox3D = FALSE);
121
126 virtual ~CXTPCheckListBox();
127
128public:
146 virtual BOOL Create(DWORD dwStyle, const RECT& rect, CWnd* pParentWnd, UINT nID);
147
173 void SetCheckStyle(UINT nStyle);
174
186 UINT GetCheckStyle();
187
196 void SetCheck(int nIndex, int nCheck);
197
206 int GetCheck(int nIndex);
207
214 void Enable(int nIndex, BOOL bEnabled = TRUE);
215
223 BOOL IsEnabled(int nIndex);
224
260 virtual CRect OnGetCheckPosition(CRect rectItem, CRect rectCheckBox);
261
262protected:
268 virtual void Init();
269
276 virtual int GetFontHeight();
277
294 virtual int PreCompareItem(LPCOMPAREITEMSTRUCT lpCompareItemStruct);
295
303 virtual int CalcMinimumItemHeight();
304
316 virtual int CheckFromPoint(CPoint point, BOOL& bInCheck);
317
344 virtual void PreDrawItem(LPDRAWITEMSTRUCT lpDrawItemStruct);
345
377 virtual void PreMeasureItem(LPMEASUREITEMSTRUCT lpMeasureItemStruct);
378
400 virtual void PreDeleteItem(LPDELETEITEMSTRUCT lpDeleteItemStruct);
401
409 virtual void SetSelectionCheck(int nCheck);
410
422 virtual void InvalidateCheck(int nIndex);
423
434 virtual void InvalidateItem(int nIndex);
435
454 bool PreDrawItemThemed(CDC* pDC, DRAWITEMSTRUCT& drawItem, int nCheck, int cyItem);
455
471 void PreDrawItemNonThemed(CDC* pDC, DRAWITEMSTRUCT& drawItem, int nCheck, int cyItem);
472
473protected:
475 DECLARE_MESSAGE_MAP()
476
477 //{{AFX_VIRTUAL(CXTPCheckListBox)
478 virtual void DrawItem(LPDRAWITEMSTRUCT lpDrawItemStruct);
479 virtual void MeasureItem(LPMEASUREITEMSTRUCT lpMeasureItemStruct);
480 virtual BOOL OnChildNotify(UINT, WPARAM, LPARAM, LRESULT*);
481 virtual void PreSubclassWindow();
482 //}}AFX_VIRTUAL
483
484 //{{AFX_MSG(CXTPCheckListBox)
485 afx_msg void OnLButtonDown(UINT nFlags, CPoint point);
486 afx_msg void OnKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags);
487 afx_msg int OnCreate(LPCREATESTRUCT lpCreateStruct);
488 afx_msg void OnLButtonDblClk(UINT nFlags, CPoint point);
489 afx_msg LRESULT OnSetFont(WPARAM wParam, LPARAM lParam);
490 afx_msg LRESULT OnLBAddString(WPARAM wParam, LPARAM lParam);
491 afx_msg LRESULT OnLBFindString(WPARAM wParam, LPARAM lParam);
492 afx_msg LRESULT OnLBFindStringExact(WPARAM wParam, LPARAM lParam);
493 afx_msg LRESULT OnLBGetItemData(WPARAM wParam, LPARAM lParam);
494 afx_msg LRESULT OnLBGetText(WPARAM wParam, LPARAM lParam);
495 afx_msg LRESULT OnLBInsertString(WPARAM wParam, LPARAM lParam);
496 afx_msg LRESULT OnLBSelectString(WPARAM wParam, LPARAM lParam);
497 afx_msg LRESULT OnLBSetItemData(WPARAM wParam, LPARAM lParam);
498 afx_msg LRESULT OnLBSetItemHeight(WPARAM wParam, LPARAM lParam);
499 //}}AFX_MSG
502private:
503 BOOL Create(LPCTSTR lpszClassName, LPCTSTR lpszWindowName, DWORD dwStyle, const RECT& rect,
504 CWnd* pParentWnd, UINT nID, CCreateContext* pContext = NULL);
505
506protected:
507 int m_cyText;
508 UINT m_nStyle;
509 CCheckListState m_checkListState;
510 CXTPWinThemeWrapper* m_themeHelper;
511 BOOL m_bLastItemDrawnThemed;
512};
513
515
516AFX_INLINE UINT CXTPCheckListBox::GetCheckStyle()
517{
518 return m_nStyle;
519}
520AFX_INLINE BOOL CXTPCheckListBox::Create(LPCTSTR lpszClassName, LPCTSTR lpszWindowName,
521 DWORD dwStyle, const RECT& rect, CWnd* pParentWnd,
522 UINT nID, CCreateContext* pContext)
523{
524 return CWnd::Create(lpszClassName, lpszWindowName, dwStyle, rect, pParentWnd, nID, pContext);
525}
527# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
529#endif // #if !defined(__XTPCHECKLISTBOX_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCheckListBox::CCheckListState
CCheckListState is a helper class used by CXTPCheckListBox that contains information about the checkb...
Definition XTPCheckListBox.h:74
CXTPCheckListBox::CCheckListState::Draw
void Draw(CDC *pDC, int nCheck, CPoint pt, CSize sz)
Draws the state icon.
CXTPCheckListBox::CCheckListState::m_sizeCheckThemed
CSize m_sizeCheckThemed
Width and height of the check mark themed image.
Definition XTPCheckListBox.h:101
CXTPCheckListBox::CCheckListState::~CCheckListState
virtual ~CCheckListState()
Destroys a CCheckListState object, handles cleanup and deallocation.
CXTPCheckListBox::CCheckListState::CCheckListState
CCheckListState(BOOL bListBox3D)
Constructs a CCheckListState object.
CXTPCheckListBox::CCheckListState::m_sizeCheck
CSize m_sizeCheck
Width and height of the check mark bitmap.
Definition XTPCheckListBox.h:100
CXTPCheckListBox
The CXTPCheckListBox class is a CXTPListBox derived class.
Definition XTPCheckListBox.h:62
CXTPCheckListBox::PreDrawItemThemed
bool PreDrawItemThemed(CDC *pDC, DRAWITEMSTRUCT &drawItem, int nCheck, int cyItem)
Called to paint the control to an off screen device context for a themed application.
CXTPCheckListBox::SetCheckStyle
void SetCheckStyle(UINT nStyle)
Call this function to set the style of check boxes in the checklist box.
CXTPCheckListBox::PreMeasureItem
virtual void PreMeasureItem(LPMEASUREITEMSTRUCT lpMeasureItemStruct)
This function is called to measure the size of the item in the list box for proper handling of an own...
CXTPCheckListBox::InvalidateItem
virtual void InvalidateItem(int nIndex)
Called by CXTPCheckListBox to redraw an item.
CXTPCheckListBox::OnGetCheckPosition
virtual CRect OnGetCheckPosition(CRect rectItem, CRect rectCheckBox)
The framework calls this function to get the position and size of the check box in an item.
CXTPCheckListBox::PreDrawItemNonThemed
void PreDrawItemNonThemed(CDC *pDC, DRAWITEMSTRUCT &drawItem, int nCheck, int cyItem)
Called to paint the control to an off screen device context for a non-themed application.
CXTPCheckListBox::Init
virtual void Init()
This member function is called by the CXTPListBase class to perform initialization when a window is c...
CXTPCheckListBox::SetSelectionCheck
virtual void SetSelectionCheck(int nCheck)
Call this function to check all items in the list box that are currently highlighted and not disabled...
CXTPCheckListBox::GetCheckStyle
UINT GetCheckStyle()
Retrieves the CXTPCheckListBox style.
CXTPCheckListBox::PreDrawItem
virtual void PreDrawItem(LPDRAWITEMSTRUCT lpDrawItemStruct)
Called to paint the control to an off screen device context for a themed application.
CXTPCheckListBox::CalcMinimumItemHeight
virtual int CalcMinimumItemHeight()
Called by the check list box to determine the minimum height for each item in the check list box.
CXTPCheckListBox::GetFontHeight
virtual int GetFontHeight()
Retrieves the height for the font used by the check list box.
CXTPCheckListBox::GetCheck
int GetCheck(int nIndex)
Call this function to determine the check state of an item.
CXTPCheckListBox::Create
virtual BOOL Create(DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID)
Creates the Windows checklist box and attaches it to the CXTPListBox object.
CXTPCheckListBox::CheckFromPoint
virtual int CheckFromPoint(CPoint point, BOOL &bInCheck)
Call this function to determine if a left mouse click occurred in the check box to the left of a list...
CXTPCheckListBox::InvalidateCheck
virtual void InvalidateCheck(int nIndex)
Called by CXTPCheckListBox to redraw a check box.
CXTPCheckListBox::~CXTPCheckListBox
virtual ~CXTPCheckListBox()
Destroys a CXTPCheckListBox object, handles cleanup and deallocation.
CXTPCheckListBox::CXTPCheckListBox
CXTPCheckListBox(BOOL bListBox3D=FALSE)
Constructs a CXTPCheckListBox object.
CXTPCheckListBox::PreDeleteItem
virtual void PreDeleteItem(LPDELETEITEMSTRUCT lpDeleteItemStruct)
This function is called so that an owner drawn list box control can properly handle the delete item m...
CXTPCheckListBox::PreCompareItem
virtual int PreCompareItem(LPCOMPAREITEMSTRUCT lpCompareItemStruct)
Called by the framework to determine the relative position of a new item in the check list box.
CXTPCheckListBox::IsEnabled
BOOL IsEnabled(int nIndex)
Call this function to determine whether or not an item is enabled.
CXTPCheckListBox::SetCheck
void SetCheck(int nIndex, int nCheck)
Call this function to set the check box of the item specified by nIndex.
CXTPCheckListBox::Enable
void Enable(int nIndex, BOOL bEnabled=TRUE)
Call this function to enable/disable a checklist box item.
CXTPListBox
CXTPListBox is a CListBox derived class.
Definition XTPListBox.h:127
CXTPWinThemeWrapper
The CXTPWinThemeWrapper class wraps the UxTheme.dll visual theme API.
Definition XTPWinThemeWrapper.h:188


Toolkit Pro: XTPCalendarNativeWindows11Theme.h Source File

  • Source
  • Calendar
  • Themes
XTPCalendarNativeWindows11Theme.h
Go to the documentation of this file.
1
22#if !defined(__XTPCALENDARNATIVEWINDOWS11THEME_H__)
23# define __XTPCALENDARNATIVEWINDOWS11THEME_H__
24
25# if _MSC_VER > 1000
26# pragma once
27# endif // _MSC_VER > 1000
28
29# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
30
36class _XTP_EXT_CLASS CXTPCalendarNativeWindows11Theme : public CXTPCalendarOffice2013Theme
37{
38public:
47 CXTPCalendarNativeWindows11Theme();
48
55 virtual ~CXTPCalendarNativeWindows11Theme();
56};
57
58# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
59#endif // !defined(__XTPCALENDARNATIVEWINDOWS11THEME_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCalendarNativeWindows11Theme
CXTPCalendarNativeWindows11Theme is a CXTPCalendarOffice2013Theme derived class that represents the N...
Definition XTPCalendarNativeWindows11Theme.h:37
CXTPCalendarNativeWindows11Theme::~CXTPCalendarNativeWindows11Theme
virtual ~CXTPCalendarNativeWindows11Theme()
Default paint manager destructor.
CXTPCalendarNativeWindows11Theme::CXTPCalendarNativeWindows11Theme
CXTPCalendarNativeWindows11Theme()
Default paint manager constructor.
CXTPCalendarOffice2013Theme
CXTPCalendarOffice2013Theme is a CXTPCalendarOffice2000Theme derived class that represents the Office...
Definition XTPCalendarOffice2013Theme.h:37


Toolkit Pro: Member List

CXTPChartPieSeriesLabelsView Member List

This is the complete list of members for CXTPChartPieSeriesLabelsView, including all inherited members.

AddChildView(CXTPChartElementView *pChildView) | CXTPChartElementView |
CreateDeviceCommand(CXTPChartDeviceContext *pDC) | CXTPChartPieSeriesLabelsView | virtual
CXTPChartElementView(CXTPChartElementView *pParentView) | CXTPChartElementView |
CXTPChartElementView(CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartElementView |
CXTPChartElementView(CXTPChartContainer *pContainer) | CXTPChartElementView |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartPieSeriesLabelsView(CXTPChartElementView *pParentView) | CXTPChartPieSeriesLabelsView |
CXTPChartPieSeriesLabelsViewBase(CXTPChartElementView *pParentView) | CXTPChartPieSeriesLabelsViewBase | protected
GetAt(int nIndex) const | CXTPChartElementView |
GetBounds() const | CXTPChartElementView |
GetBounds(BOOL bIncludingChildren) const | CXTPChartElementView |
GetChildren() | CXTPChartElementView |
GetCount() const | CXTPChartElementView |
GetParentView() const | CXTPChartElementView |
Is3D() const | CXTPChartObject |
m_arrChildren | CXTPChartElementView | protected
m_pContainer | CXTPChartElementView | protected
m_pParentView | CXTPChartElementView | protected
m_rcBounds | CXTPChartElementView | protected
ResolveOverlapping() | CXTPChartPieSeriesLabelsView | virtual
ResolveOverlappingColumn(CArray< CXTPChartPieSeriesLabelView *, CXTPChartPieSeriesLabelView * > &arrColumn) | CXTPChartPieSeriesLabelsView | protected
~CXTPChartElementView() | CXTPChartElementView | protectedvirtual


Toolkit Pro: XTPCalendarVisualStudio2015Theme.h Source File

  • Source
  • Calendar
  • Themes
XTPCalendarVisualStudio2015Theme.h
Go to the documentation of this file.
1
22#if !defined(__XTPCALENDARVISUALSTUDIO2015THEME_H__)
23# define __XTPCALENDARVISUALSTUDIO2015THEME_H__
24
25# if _MSC_VER > 1000
26# pragma once
27# endif // _MSC_VER > 1000
28
29# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
30
36class _XTP_EXT_CLASS CXTPCalendarVisualStudio2015Theme : public CXTPCalendarOffice2013Theme
37{
38public:
47 CXTPCalendarVisualStudio2015Theme();
48
55 virtual ~CXTPCalendarVisualStudio2015Theme();
56};
57
58# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
59#endif // !defined(__XTPCALENDARVISUALSTUDIO2015THEME_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCalendarOffice2013Theme
CXTPCalendarOffice2013Theme is a CXTPCalendarOffice2000Theme derived class that represents the Office...
Definition XTPCalendarOffice2013Theme.h:37
CXTPCalendarVisualStudio2015Theme
CXTPCalendarVisualStudio2015Theme is a CXTPCalendarOffice2013Theme derived class that represents the ...
Definition XTPCalendarVisualStudio2015Theme.h:37
CXTPCalendarVisualStudio2015Theme::~CXTPCalendarVisualStudio2015Theme
virtual ~CXTPCalendarVisualStudio2015Theme()
Default paint manager destructor.
CXTPCalendarVisualStudio2015Theme::CXTPCalendarVisualStudio2015Theme
CXTPCalendarVisualStudio2015Theme()
Default paint manager constructor.


Toolkit Pro: Member List

XTP_CALENDAR_USERACTION_PARAMS Member List

This is the complete list of members for XTP_CALENDAR_USERACTION_PARAMS, including all inherited members.

m_eAction | XTP_CALENDAR_USERACTION_PARAMS
m_ExpandDayButton | XTP_CALENDAR_USERACTION_PARAMS
m_ScrollDayButton | XTP_CALENDAR_USERACTION_PARAMS


Toolkit Pro: Member List

CXTPMarkupXtpScript Member List

This is the complete list of members for CXTPMarkupXtpScript, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPMarkupExtension() | CXTPMarkupExtension | protected
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetLanguage() const | CXTPMarkupXtpScript |
GetRequires() const | CXTPMarkupXtpScript |
GetSource() const | CXTPMarkupXtpScript |
SetContentObject(CXTPMarkupBuilder *pBuilder, CXTPMarkupObject *pContent) | CXTPMarkupXtpScript | virtual


Toolkit Pro: Member List

CXTPCalendarWMHandler Member List

This is the complete list of members for CXTPCalendarWMHandler, including all inherited members.

CXTPCalendarWMHandler() | CXTPCalendarWMHandler |
CXTPCmdTarget() | CXTPCmdTarget |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetChildHandlerAt(int nIndex) const | CXTPCalendarWMHandler | virtual
GetChildHandlersCount() const | CXTPCalendarWMHandler | virtual
OnBeforeDestroy() | CXTPCalendarWMHandler | virtual
OnChar(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnKeyUp(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnLButtonDblClk(UINT nFlags, CPoint point) | CXTPCalendarWMHandler | virtual
OnLButtonDown(UINT nFlags, CPoint point) | CXTPCalendarWMHandler | virtual
OnLButtonUp(UINT nFlags, CPoint point) | CXTPCalendarWMHandler | virtual
OnMouseMove(UINT nFlags, CPoint point) | CXTPCalendarWMHandler | virtual
OnPostAdjustLayout() | CXTPCalendarWMHandler | virtual
OnSysKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnTimer(UINT_PTR uTimerID) | CXTPCalendarWMHandler | virtual
OnWndMsg(UINT message, WPARAM wParam, LPARAM lParam, LRESULT *pResult) | CXTPCalendarWMHandler | virtual


Toolkit Pro: XTPTabThemeVisualStudio2019.h Source File

  • Source
  • TabManager
  • Themes
XTPTabThemeVisualStudio2019.h
Go to the documentation of this file.
1
23#if !defined(__XTPTABTHEMEVISUALSTUDIO2019_H__)
24# define __XTPTABTHEMEVISUALSTUDIO2019_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
37class _XTP_EXT_CLASS CXTPTabThemeVisualStudio2019 : public CXTPTabThemeVisualStudio2017
38{
39public:
44 CXTPTabThemeVisualStudio2019();
45
54 virtual void RefreshMetrics();
55
64 virtual XTPTabColorStyle GetDefaultColorSet()
65 {
66 return xtpTabColorVisualStudio2019;
67 }
68};
69
70# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
72#endif // __XTPTABTHEMEVISUALSTUDIO2019_H__
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPTabColorStyle
XTPTabColorStyle
XTPTabColorStyle is an enumeration used to set the color style of tabs.
Definition XTPTabManagerDefines.h:139
xtpTabColorVisualStudio2019
@ xtpTabColorVisualStudio2019
Tabs will use the Visual Studio 2019 color style for the currently set Appearance.
Definition XTPTabManagerDefines.h:172
CXTPTabThemeVisualStudio2017
CXTPTabThemeVisualStudio2017 implements a Visual Studio 2017 tab appearance.
Definition XTPTabThemeVisualStudio2017.h:38
CXTPTabThemeVisualStudio2019
CXTPTabThemeVisualStudio2019 implements a Visual Studio 2019 tab appearance.
Definition XTPTabThemeVisualStudio2019.h:38
CXTPTabThemeVisualStudio2019::GetDefaultColorSet
virtual XTPTabColorStyle GetDefaultColorSet()
Gets the default value of the color set for this theme.
Definition XTPTabThemeVisualStudio2019.h:64
CXTPTabThemeVisualStudio2019::CXTPTabThemeVisualStudio2019
CXTPTabThemeVisualStudio2019()
Constructs a CXTPTabThemeVisualStudio2019 object.
CXTPTabThemeVisualStudio2019::RefreshMetrics
virtual void RefreshMetrics()
Refreshes the appearance metrics.


Toolkit Pro: XTPCommandBarsResourceTheme.h Source File

  • Source
  • CommandBars
  • Themes
XTPCommandBarsResourceTheme.h
Go to the documentation of this file.
1
23#if !defined(__XTPRESOURCETHEME_H__)
24# define __XTPRESOURCETHEME_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPResourceImage;
34class CXTPResourceImages;
35class CXTPCommandBarsFrameHook;
36class CXTPMarkupContext;
37
45class _XTP_EXT_CLASS CXTPResourceTheme : public CXTPCommandBarsOffice2003Theme
46{
48 DECLARE_DYNAMIC(CXTPResourceTheme)
50public:
55 CXTPResourceTheme();
56
61 virtual ~CXTPResourceTheme();
62
63public:
82 CXTPResourceImage* LoadImage(LPCTSTR lpszFileName);
83
106 void SetImageHandle(HMODULE hResource, LPCTSTR lpszIniFileName);
107
108 virtual BOOL RequiresResourceImages();
109
110protected:
115 virtual void RefreshMetrics();
116
123 virtual XTPPaintTheme BaseTheme()
124 {
125 return xtpThemeResource;
126 }
127
128public:
135 CXTPResourceImages* GetImages() const;
136
144 void SetImages(CXTPResourceImages* pImages);
145
159 virtual COLORREF GetRectangleTextColor(BOOL bSelected, BOOL bPressed, BOOL bEnabled,
160 BOOL bChecked, BOOL bPopuped, XTPBarType barType,
161 XTPBarPosition barPosition);
162
170 virtual void FillWorkspace(CDC* pDC, CRect rc, CRect rcExclude);
171
178 virtual CXTPFramePaintManager* GetFramePaintManager();
179
186 virtual CXTPRibbonPaintManager* GetRibbonPaintManager();
187
188protected:
195 BOOL IsImagesAvailable();
196
197protected:
198 int m_nRibbonCaptionHeight;
200protected:
202 CXTPResourceImages* m_pImages;
203 COLORREF m_clrMenuBarText;
204 COLORREF m_clrStatusBarShadow;
205 CXTPPaintManagerColorGradient m_clrStatusBarTop;
206 CXTPPaintManagerColorGradient m_clrStatusBarBottom;
207 COLORREF m_clrWorkspaceClientTop;
208 COLORREF m_clrWorkspaceClientMiddle;
209 COLORREF m_clrWorkspaceClientBottom;
210 int m_nMessageBarHeight;
211 CSize m_szMessageBarDefaultButtonSize;
212 CXTPPaintManagerColorGradient m_clrMessageBar;
213 COLORREF m_clrMessageBarFrame;
214 COLORREF m_clrMessageBarFace;
217 friend class CXTPStatusBarThemeResource;
218 friend class CXTPMessageBarThemeResource;
219};
220
221AFX_INLINE BOOL CXTPResourceTheme::RequiresResourceImages()
222{
223 return TRUE;
224}
225
226// Obsolete class
227# define CXTPOffice2007Theme CXTPResourceTheme
229# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
230#endif // #if !defined(__XTPRESOURCETHEME_H__)
XTPBarType
XTPBarType
Type of the command bar.
Definition XTPCommandBarsDefines.h:77
XTPBarPosition
XTPBarPosition
Position of the command bar.
Definition XTPCommandBarsDefines.h:52
XTPPaintTheme
XTPPaintTheme
Paint themes used by command bars.
Definition XTPCommandBarsDefines.h:233
xtpThemeResource
@ xtpThemeResource
Office 2007 theme.
Definition XTPCommandBarsDefines.h:240
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCommandBarsFrameHook
CXTPCommandBarsFrameHook is a CXTPHookManagerHookAble derived class.
Definition XTPFrameHook.h:56
CXTPCommandBarsOffice2003Theme
The CXTPCommandBarsOffice2003Theme class is used to enable an Office 2003 style theme for Command Bar...
Definition XTPCommandBarsOffice2003Theme.h:41
CXTPFramePaintManager
Paint manager for the Office 2007 style window frame.
Definition XTPFramePaintManager.h:41
CXTPMarkupContext
CXTPMarkupContext is a standalone class used to provide common settings for Markup objects.
Definition XTPMarkupContext.h:128
CXTPPaintManagerColorGradient
The CXTPPaintManagerColorGradient class is used to manage COLORREF values for determining light and d...
Definition XTPColorManager.h:301
CXTPPaintManager::RequiresResourceImages
virtual BOOL RequiresResourceImages()
Used by the paint manager to determine if the theme requires a resource DLL to load image and color i...
Definition XTPPaintManager.h:1842
CXTPResourceImage
Represent a resource image and provides basic images functions.
Definition XTPResourceImage.h:48
CXTPResourceImages
Implements resource image collection and its operations.
Definition XTPResourceImage.h:257
CXTPResourceTheme
The CXTPResourceTheme class is used to enable a resource style theme for Command Bars.
Definition XTPCommandBarsResourceTheme.h:46
CXTPResourceTheme::IsImagesAvailable
BOOL IsImagesAvailable()
Determines if images are available.
CXTPResourceTheme::RequiresResourceImages
virtual BOOL RequiresResourceImages()
Used by the paint manager to determine if the theme requires a resource DLL to load image and color i...
Definition XTPCommandBarsResourceTheme.h:221
CXTPResourceTheme::m_nRibbonCaptionHeight
int m_nRibbonCaptionHeight
Ribbon caption height.
Definition XTPCommandBarsResourceTheme.h:198
CXTPResourceTheme::FillWorkspace
virtual void FillWorkspace(CDC *pDC, CRect rc, CRect rcExclude)
Draws workspace space.
CXTPResourceTheme::GetRectangleTextColor
virtual COLORREF GetRectangleTextColor(BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition)
This method retrieves a button's text color.
CXTPResourceTheme::~CXTPResourceTheme
virtual ~CXTPResourceTheme()
Destroys a CXTPResourceTheme object, handles cleanup and deallocation.
CXTPResourceTheme::SetImages
void SetImages(CXTPResourceImages *pImages)
Call this method to set images for the theme.
CXTPResourceTheme::GetFramePaintManager
virtual CXTPFramePaintManager * GetFramePaintManager()
Returns the paint manager used to draw frames.
CXTPResourceTheme::CXTPResourceTheme
CXTPResourceTheme()
Constructs a CXTPResourceTheme object.
CXTPResourceTheme::GetRibbonPaintManager
virtual CXTPRibbonPaintManager * GetRibbonPaintManager()
Retrieves the ribbon paint manager.
CXTPResourceTheme::LoadImage
CXTPResourceImage * LoadImage(LPCTSTR lpszFileName)
Loads a bitmap image from the specified path.
CXTPResourceTheme::SetImageHandle
void SetImageHandle(HMODULE hResource, LPCTSTR lpszIniFileName)
Specifies the resource that contains the bitmaps to be loaded for the theme.
CXTPResourceTheme::GetImages
CXTPResourceImages * GetImages() const
This method is called to get the CXTPResourceImages pointer.
CXTPResourceTheme::BaseTheme
virtual XTPPaintTheme BaseTheme()
Retrieves the base theme of the manager.
Definition XTPCommandBarsResourceTheme.h:123
CXTPResourceTheme::RefreshMetrics
virtual void RefreshMetrics()
This method is called to refresh the visual metrics of the manager.
CXTPRibbonPaintManager
Standalone class used by CXTPRibbonBar as a paint manager.
Definition XTPRibbonPaintManager.h:51


Toolkit Pro: XTPGridADO.h Source File

  • Source
  • GridControl
XTPGridADO.h
Go to the documentation of this file.
1
23#if !defined(_XTPGRIDADO_H__)
24# define _XTPGRIDADO_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# pragma pack(push, 8)
32
33# if (_MSC_VER <= 1100)
34# pragma warning(disable : 4510 4513 4610 4310 4244)
35# endif
36
37# include "Common/Base/Diagnostic/XTPDisableAdvancedWarnings.h"
38# include <comdef.h>
39# include "Common/Base/Diagnostic/XTPEnableAdvancedWarnings.h"
40
41# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
42# pragma warning(push)
43// C4616: #pragma warning : warning number '...' out of range, must be between '4001' and '4999'
44// C4619: #pragma warning : there is no warning number 'number'
45// C5204: '...': class has virtual functions, but its trivial destructor is not virtual; instances
46// C4471: '...': a forward declaration of an unscoped enumeration must have an underlying type
47// of objects derived from this class may not be destructed correctly
48# pragma warning(disable : 4616 4619 5204 4471)
49
51namespace XTPGRIDADOX
52{
53//
54// Forward references and typedefs
55//
56
57struct __declspec(uuid("00000600-0000-0010-8000-00aa006d2ea4"))
58 /* LIBID */ __ADOX;
59struct __declspec(uuid("00000512-0000-0010-8000-00aa006d2ea4"))
60 /* dual interface */ _Collection;
61struct __declspec(uuid("00000513-0000-0010-8000-00aa006d2ea4"))
62 /* dual interface */ _DynaCollection;
63struct __declspec(uuid("00000603-0000-0010-8000-00aa006d2ea4"))
64 /* dual interface */ _Catalog;
65struct __declspec(uuid("00000611-0000-0010-8000-00aa006d2ea4"))
66 /* dual interface */ Tables;
67struct /* coclass */ Table;
68struct __declspec(uuid("00000610-0000-0010-8000-00aa006d2ea4"))
69 /* dual interface */ _Table;
70struct __declspec(uuid("0000061d-0000-0010-8000-00aa006d2ea4"))
71 /* dual interface */ Columns;
72struct /* coclass */ Column;
73struct __declspec(uuid("0000061c-0000-0010-8000-00aa006d2ea4"))
74 /* dual interface */ _Column;
75enum ColumnAttributesEnum;
76enum SortOrderEnum;
77enum DataTypeEnum;
78struct __declspec(uuid("00000504-0000-0010-8000-00aa006d2ea4"))
79 /* dual interface */ Properties;
80struct __declspec(uuid("00000503-0000-0010-8000-00aa006d2ea4"))
81 /* dual interface */ Property;
82struct __declspec(uuid("00000620-0000-0010-8000-00aa006d2ea4"))
83 /* dual interface */ Indexes;
84struct /* coclass */ Index;
85struct __declspec(uuid("0000061f-0000-0010-8000-00aa006d2ea4"))
86 /* dual interface */ _Index;
87enum AllowNullsEnum;
88struct __declspec(uuid("00000623-0000-0010-8000-00aa006d2ea4"))
89 /* dual interface */ Keys;
90struct /* coclass */ Key;
91struct __declspec(uuid("00000622-0000-0010-8000-00aa006d2ea4"))
92 /* dual interface */ _Key;
93enum RuleEnum;
94enum KeyTypeEnum;
95struct __declspec(uuid("00000626-0000-0010-8000-00aa006d2ea4"))
96 /* dual interface */ Procedures;
97struct __declspec(uuid("00000625-0000-0010-8000-00aa006d2ea4"))
98 /* dual interface */ Procedure;
99struct __declspec(uuid("00000614-0000-0010-8000-00aa006d2ea4"))
100 /* dual interface */ Views;
101struct __declspec(uuid("00000613-0000-0010-8000-00aa006d2ea4"))
102 /* dual interface */ View;
103struct __declspec(uuid("00000617-0000-0010-8000-00aa006d2ea4"))
104 /* dual interface */ Groups;
105struct /* coclass */ Group;
106struct __declspec(uuid("00000628-0000-0010-8000-00aa006d2ea4"))
107 /* dual interface */ _Group;
108struct __declspec(uuid("00000616-0000-0010-8000-00aa006d2ea4"))
109 /* dual interface */ _Group25;
110enum ObjectTypeEnum;
111enum RightsEnum;
112enum ActionEnum;
113enum InheritTypeEnum;
114struct __declspec(uuid("0000061a-0000-0010-8000-00aa006d2ea4"))
115 /* dual interface */ Users;
116struct /* coclass */ User;
117struct __declspec(uuid("00000627-0000-0010-8000-00aa006d2ea4"))
118 /* dual interface */ _User;
119struct __declspec(uuid("00000619-0000-0010-8000-00aa006d2ea4"))
120 /* dual interface */ _User25;
121struct /* coclass */ Catalog;
122
123//
124// Smart pointer typedef declarations
125//
126
127_COM_SMARTPTR_TYPEDEF(_Collection, __uuidof(_Collection));
128_COM_SMARTPTR_TYPEDEF(_DynaCollection, __uuidof(_DynaCollection));
129_COM_SMARTPTR_TYPEDEF(Tables, __uuidof(Tables));
130_COM_SMARTPTR_TYPEDEF(Columns, __uuidof(Columns));
131_COM_SMARTPTR_TYPEDEF(Property, __uuidof(Property));
132_COM_SMARTPTR_TYPEDEF(Properties, __uuidof(Properties));
133_COM_SMARTPTR_TYPEDEF(Indexes, __uuidof(Indexes));
134_COM_SMARTPTR_TYPEDEF(_Index, __uuidof(_Index));
135_COM_SMARTPTR_TYPEDEF(Keys, __uuidof(Keys));
136_COM_SMARTPTR_TYPEDEF(_Key, __uuidof(_Key));
137_COM_SMARTPTR_TYPEDEF(Procedure, __uuidof(Procedure));
138_COM_SMARTPTR_TYPEDEF(Procedures, __uuidof(Procedures));
139_COM_SMARTPTR_TYPEDEF(View, __uuidof(View));
140_COM_SMARTPTR_TYPEDEF(Views, __uuidof(Views));
141_COM_SMARTPTR_TYPEDEF(Groups, __uuidof(Groups));
142_COM_SMARTPTR_TYPEDEF(Users, __uuidof(Users));
143_COM_SMARTPTR_TYPEDEF(_Catalog, __uuidof(_Catalog));
144_COM_SMARTPTR_TYPEDEF(_Table, __uuidof(_Table));
145_COM_SMARTPTR_TYPEDEF(_Column, __uuidof(_Column));
146_COM_SMARTPTR_TYPEDEF(_Group25, __uuidof(_Group25));
147_COM_SMARTPTR_TYPEDEF(_Group, __uuidof(_Group));
148_COM_SMARTPTR_TYPEDEF(_User25, __uuidof(_User25));
149_COM_SMARTPTR_TYPEDEF(_User, __uuidof(_User));
150
151//
152// Type library items
153//
154
155struct __declspec(uuid("00000512-0000-0010-8000-00aa006d2ea4")) _Collection : IDispatch
156{
157 //
158 // Property data
159 //
160
161 __declspec(property(get = GetCount)) long Count;
162
163 //
164 // Wrapper methods for error-handling
165 //
166
167 long GetCount();
168 IUnknownPtr _NewEnum();
169 HRESULT Refresh();
170
171 //
172 // Raw methods provided by interface
173 //
174
175 virtual HRESULT __stdcall get_Count(
176 /*[out,retval]*/ long* c) = 0;
177 virtual HRESULT __stdcall raw__NewEnum(
178 /*[out,retval]*/ IUnknown** ppvObject) = 0;
179 virtual HRESULT __stdcall raw_Refresh() = 0;
180};
181
182struct __declspec(uuid("00000513-0000-0010-8000-00aa006d2ea4")) _DynaCollection : _Collection
183{
184 //
185 // Wrapper methods for error-handling
186 //
187
188 HRESULT Append(IDispatch* Object);
189 HRESULT Delete(const _variant_t& Item);
190
191 //
192 // Raw methods provided by interface
193 //
194
195 virtual HRESULT __stdcall raw_Append(
196 /*[in]*/ IDispatch* Object) = 0;
197 virtual HRESULT __stdcall raw_Delete(
198 /*[in]*/ VARIANT Item) = 0;
199};
200
201struct __declspec(uuid("00000609-0000-0010-8000-00aa006d2ea4")) Table;
202// [ default ] interface _Table
203
204struct __declspec(uuid("00000611-0000-0010-8000-00aa006d2ea4")) Tables : _Collection
205{
206 //
207 // Property data
208 //
209
210 __declspec(property(get = GetItem)) _TablePtr Item[];
211
212 //
213 // Wrapper methods for error-handling
214 //
215
216 _TablePtr GetItem(const _variant_t& Item);
217 HRESULT Append(const _variant_t& Item);
218 HRESULT Delete(const _variant_t& Item);
219
220 //
221 // Raw methods provided by interface
222 //
223
224 virtual HRESULT __stdcall get_Item(
225 /*[in]*/ VARIANT Item,
226 /*[out,retval]*/ struct _Table** ppvObject) = 0;
227 virtual HRESULT __stdcall raw_Append(
228 /*[in]*/ VARIANT Item) = 0;
229 virtual HRESULT __stdcall raw_Delete(
230 /*[in]*/ VARIANT Item) = 0;
231};
232
233struct __declspec(uuid("0000061b-0000-0010-8000-00aa006d2ea4")) Column;
234// [ default ] interface _Column
235
236enum ColumnAttributesEnum
237{
238 adColFixed = 1,
239 adColNullable = 2
240};
241
242enum SortOrderEnum
243{
244 adSortAscending = 1,
245 adSortDescending = 2
246};
247
248enum DataTypeEnum
249{
250 adEmpty = 0,
251 adTinyInt = 16,
252 adSmallInt = 2,
253 adInteger = 3,
254 adBigInt = 20,
255 adUnsignedTinyInt = 17,
256 adUnsignedSmallInt = 18,
257 adUnsignedInt = 19,
258 adUnsignedBigInt = 21,
259 adSingle = 4,
260 adDouble = 5,
261 adCurrency = 6,
262 adDecimal = 14,
263 adNumeric = 131,
264 adBoolean = 11,
265 adError = 10,
266 adUserDefined = 132,
267 adVariant = 12,
268 adIDispatch = 9,
269 adIUnknown = 13,
270 adGUID = 72,
271 adDate = 7,
272 adDBDate = 133,
273 adDBTime = 134,
274 adDBTimeStamp = 135,
275 adBSTR = 8,
276 adChar = 129,
277 adVarChar = 200,
278 adLongVarChar = 201,
279 adWChar = 130,
280 adVarWChar = 202,
281 adLongVarWChar = 203,
282 adBinary = 128,
283 adVarBinary = 204,
284 adLongVarBinary = 205,
285 adChapter = 136,
286 adFileTime = 64,
287 adPropVariant = 138,
288 adVarNumeric = 139
289};
290
291struct __declspec(uuid("0000061d-0000-0010-8000-00aa006d2ea4")) Columns : _Collection
292{
293 //
294 // Property data
295 //
296
297 __declspec(property(get = GetItem)) _ColumnPtr Item[];
298
299 //
300 // Wrapper methods for error-handling
301 //
302
303 _ColumnPtr GetItem(const _variant_t& Item);
304 HRESULT Append(const _variant_t& Item, enum DataTypeEnum Type, long DefinedSize);
305 HRESULT Delete(const _variant_t& Item);
306
307 //
308 // Raw methods provided by interface
309 //
310
311 virtual HRESULT __stdcall get_Item(
312 /*[in]*/ VARIANT Item,
313 /*[out,retval]*/ struct _Column** ppvObject) = 0;
314 virtual HRESULT __stdcall raw_Append(
315 /*[in]*/ VARIANT Item,
316 /*[in]*/ enum DataTypeEnum Type,
317 /*[in]*/ long DefinedSize) = 0;
318 virtual HRESULT __stdcall raw_Delete(
319 /*[in]*/ VARIANT Item) = 0;
320};
321
322struct __declspec(uuid("00000503-0000-0010-8000-00aa006d2ea4")) Property : IDispatch
323{
324 //
325 // Property data
326 //
327
328 __declspec(property(get = GetValue, put = PutValue)) _variant_t Value;
329 __declspec(property(get = GetName)) _bstr_t Name;
330 __declspec(property(get = GetType)) enum DataTypeEnum Type;
331 __declspec(property(get = GetAttributes, put = PutAttributes)) long Attributes;
332
333 //
334 // Wrapper methods for error-handling
335 //
336
337 _variant_t GetValue();
338 void PutValue(const _variant_t& pVal);
339 _bstr_t GetName();
340 enum DataTypeEnum GetType();
341 long GetAttributes();
342 void PutAttributes(long plAttributes);
343
344 //
345 // Raw methods provided by interface
346 //
347
348 virtual HRESULT __stdcall get_Value(
349 /*[out,retval]*/ VARIANT* pVal) = 0;
350 virtual HRESULT __stdcall put_Value(
351 /*[in]*/ VARIANT pVal) = 0;
352 virtual HRESULT __stdcall get_Name(
353 /*[out,retval]*/ BSTR* pbstr) = 0;
354 virtual HRESULT __stdcall get_Type(
355 /*[out,retval]*/ enum DataTypeEnum* ptype) = 0;
356 virtual HRESULT __stdcall get_Attributes(
357 /*[out,retval]*/ long* plAttributes) = 0;
358 virtual HRESULT __stdcall put_Attributes(
359 /*[in]*/ long plAttributes) = 0;
360};
361
362struct __declspec(uuid("00000504-0000-0010-8000-00aa006d2ea4")) Properties : _Collection
363{
364 //
365 // Property data
366 //
367
368 __declspec(property(get = GetItem)) PropertyPtr Item[];
369
370 //
371 // Wrapper methods for error-handling
372 //
373
374 PropertyPtr GetItem(const _variant_t& Item);
375
376 //
377 // Raw methods provided by interface
378 //
379
380 virtual HRESULT __stdcall get_Item(
381 /*[in]*/ VARIANT Item,
382 /*[out,retval]*/ struct Property** ppvObject) = 0;
383};
384
385struct __declspec(uuid("0000061e-0000-0010-8000-00aa006d2ea4")) Index;
386// [ default ] interface _Index
387
388struct __declspec(uuid("00000620-0000-0010-8000-00aa006d2ea4")) Indexes : _Collection
389{
390 //
391 // Property data
392 //
393
394 __declspec(property(get = GetItem)) _IndexPtr Item[];
395
396 //
397 // Wrapper methods for error-handling
398 //
399
400 _IndexPtr GetItem(const _variant_t& Item);
401 HRESULT Append(const _variant_t& Item, const _variant_t& Columns = vtMissing);
402 HRESULT Delete(const _variant_t& Item);
403
404 //
405 // Raw methods provided by interface
406 //
407
408 virtual HRESULT __stdcall get_Item(
409 /*[in]*/ VARIANT Item,
410 /*[out,retval]*/ struct _Index** ppvObject) = 0;
411 virtual HRESULT __stdcall raw_Append(
412 /*[in]*/ VARIANT Item,
413 /*[in]*/ VARIANT Columns = vtMissing) = 0;
414 virtual HRESULT __stdcall raw_Delete(
415 /*[in]*/ VARIANT Item) = 0;
416};
417
418enum AllowNullsEnum
419{
420 adIndexNullsAllow = 0,
421 adIndexNullsDisallow = 1,
422 adIndexNullsIgnore = 2,
423 adIndexNullsIgnoreAny = 4
424};
425
426struct __declspec(uuid("0000061f-0000-0010-8000-00aa006d2ea4")) _Index : IDispatch
427{
428 //
429 // Property data
430 //
431
432 __declspec(property(get = GetName, put = PutName)) _bstr_t Name;
433 __declspec(property(get = GetClustered, put = PutClustered)) VARIANT_BOOL Clustered;
434 __declspec(property(get = GetIndexNulls, put = PutIndexNulls)) enum AllowNullsEnum IndexNulls;
435 __declspec(property(get = GetPrimaryKey, put = PutPrimaryKey)) VARIANT_BOOL PrimaryKey;
436 __declspec(property(get = GetUnique, put = PutUnique)) VARIANT_BOOL Unique;
437 __declspec(property(get = GetColumns)) ColumnsPtr Columns;
438 __declspec(property(get = GetProperties)) PropertiesPtr Properties;
439
440 //
441 // Wrapper methods for error-handling
442 //
443
444 _bstr_t GetName();
445 void PutName(_bstr_t pVal);
446 VARIANT_BOOL GetClustered();
447 void PutClustered(VARIANT_BOOL pVal);
448 enum AllowNullsEnum GetIndexNulls();
449 void PutIndexNulls(enum AllowNullsEnum pVal);
450 VARIANT_BOOL GetPrimaryKey();
451 void PutPrimaryKey(VARIANT_BOOL pVal);
452 VARIANT_BOOL GetUnique();
453 void PutUnique(VARIANT_BOOL pVal);
454 ColumnsPtr GetColumns();
455 PropertiesPtr GetProperties();
456
457 //
458 // Raw methods provided by interface
459 //
460
461 virtual HRESULT __stdcall get_Name(
462 /*[out,retval]*/ BSTR* pVal) = 0;
463 virtual HRESULT __stdcall put_Name(
464 /*[in]*/ BSTR pVal) = 0;
465 virtual HRESULT __stdcall get_Clustered(
466 /*[out,retval]*/ VARIANT_BOOL* pVal) = 0;
467 virtual HRESULT __stdcall put_Clustered(
468 /*[in]*/ VARIANT_BOOL pVal) = 0;
469 virtual HRESULT __stdcall get_IndexNulls(
470 /*[out,retval]*/ enum AllowNullsEnum* pVal) = 0;
471 virtual HRESULT __stdcall put_IndexNulls(
472 /*[in]*/ enum AllowNullsEnum pVal) = 0;
473 virtual HRESULT __stdcall get_PrimaryKey(
474 /*[out,retval]*/ VARIANT_BOOL* pVal) = 0;
475 virtual HRESULT __stdcall put_PrimaryKey(
476 /*[in]*/ VARIANT_BOOL pVal) = 0;
477 virtual HRESULT __stdcall get_Unique(
478 /*[out,retval]*/ VARIANT_BOOL* pVal) = 0;
479 virtual HRESULT __stdcall put_Unique(
480 /*[in]*/ VARIANT_BOOL pVal) = 0;
481 virtual HRESULT __stdcall get_Columns(
482 /*[out,retval]*/ struct Columns** ppvObject) = 0;
483 virtual HRESULT __stdcall get_Properties(
484 /*[out,retval]*/ struct Properties** ppvObject) = 0;
485};
486
487struct __declspec(uuid("00000621-0000-0010-8000-00aa006d2ea4")) Key;
488// [ default ] interface _Key
489
490enum RuleEnum
491{
492 adRINone = 0,
493 adRICascade = 1,
494 adRISetNull = 2,
495 adRISetDefault = 3
496};
497
498enum KeyTypeEnum
499{
500 adKeyPrimary = 1,
501 adKeyForeign = 2,
502 adKeyUnique = 3
503};
504
505struct __declspec(uuid("00000623-0000-0010-8000-00aa006d2ea4")) Keys : _Collection
506{
507 //
508 // Property data
509 //
510
511 __declspec(property(get = GetItem)) _KeyPtr Item[];
512
513 //
514 // Wrapper methods for error-handling
515 //
516
517 _KeyPtr GetItem(const _variant_t& Item);
518 HRESULT Append(const _variant_t& Item, enum KeyTypeEnum Type, const _variant_t& Column,
519 _bstr_t RelatedTable, _bstr_t RelatedColumn);
520 HRESULT Delete(const _variant_t& Item);
521
522 //
523 // Raw methods provided by interface
524 //
525
526 virtual HRESULT __stdcall get_Item(
527 /*[in]*/ VARIANT Item,
528 /*[out,retval]*/ struct _Key** ppvObject) = 0;
529 virtual HRESULT __stdcall raw_Append(
530 /*[in]*/ VARIANT Item,
531 /*[in]*/ enum KeyTypeEnum Type,
532 /*[in]*/ VARIANT Column,
533 /*[in]*/ BSTR RelatedTable,
534 /*[in]*/ BSTR RelatedColumn) = 0;
535 virtual HRESULT __stdcall raw_Delete(
536 /*[in]*/ VARIANT Item) = 0;
537};
538
539struct __declspec(uuid("00000622-0000-0010-8000-00aa006d2ea4")) _Key : IDispatch
540{
541 //
542 // Property data
543 //
544
545 __declspec(property(get = GetName, put = PutName)) _bstr_t Name;
546 __declspec(property(get = GetDeleteRule, put = PutDeleteRule)) enum RuleEnum DeleteRule;
547 __declspec(property(get = GetType, put = PutType)) enum KeyTypeEnum Type;
548 __declspec(property(get = GetRelatedTable, put = PutRelatedTable)) _bstr_t RelatedTable;
549 __declspec(property(get = GetUpdateRule, put = PutUpdateRule)) enum RuleEnum UpdateRule;
550 __declspec(property(get = GetColumns)) ColumnsPtr Columns;
551
552 //
553 // Wrapper methods for error-handling
554 //
555
556 _bstr_t GetName();
557 void PutName(_bstr_t pVal);
558 enum RuleEnum GetDeleteRule();
559 void PutDeleteRule(enum RuleEnum pVal);
560 enum KeyTypeEnum GetType();
561 void PutType(enum KeyTypeEnum pVal);
562 _bstr_t GetRelatedTable();
563 void PutRelatedTable(_bstr_t pVal);
564 enum RuleEnum GetUpdateRule();
565 void PutUpdateRule(enum RuleEnum pVal);
566 ColumnsPtr GetColumns();
567
568 //
569 // Raw methods provided by interface
570 //
571
572 virtual HRESULT __stdcall get_Name(
573 /*[out,retval]*/ BSTR* pVal) = 0;
574 virtual HRESULT __stdcall put_Name(
575 /*[in]*/ BSTR pVal) = 0;
576 virtual HRESULT __stdcall get_DeleteRule(
577 /*[out,retval]*/ enum RuleEnum* pVal) = 0;
578 virtual HRESULT __stdcall put_DeleteRule(
579 /*[in]*/ enum RuleEnum pVal) = 0;
580 virtual HRESULT __stdcall get_Type(
581 /*[out,retval]*/ enum KeyTypeEnum* pVal) = 0;
582 virtual HRESULT __stdcall put_Type(
583 /*[in]*/ enum KeyTypeEnum pVal) = 0;
584 virtual HRESULT __stdcall get_RelatedTable(
585 /*[out,retval]*/ BSTR* pVal) = 0;
586 virtual HRESULT __stdcall put_RelatedTable(
587 /*[in]*/ BSTR pVal) = 0;
588 virtual HRESULT __stdcall get_UpdateRule(
589 /*[out,retval]*/ enum RuleEnum* pVal) = 0;
590 virtual HRESULT __stdcall put_UpdateRule(
591 /*[in]*/ enum RuleEnum pVal) = 0;
592 virtual HRESULT __stdcall get_Columns(
593 /*[out,retval]*/ struct Columns** ppvObject) = 0;
594};
595
596struct __declspec(uuid("00000625-0000-0010-8000-00aa006d2ea4")) Procedure : IDispatch
597{
598 //
599 // Property data
600 //
601
602 __declspec(property(get = GetName)) _bstr_t Name;
603 __declspec(property(get = GetDateCreated)) _variant_t DateCreated;
604 __declspec(property(get = GetDateModified)) _variant_t DateModified;
605
606 //
607 // Wrapper methods for error-handling
608 //
609
610 _variant_t GetCommand();
611 void PutCommand(const _variant_t& pVar);
612 void PutRefCommand(IDispatch* pVar);
613 _bstr_t GetName();
614 _variant_t GetDateCreated();
615 _variant_t GetDateModified();
616
617 //
618 // Raw methods provided by interface
619 //
620
621 virtual HRESULT __stdcall get_Command(
622 /*[out,retval]*/ VARIANT* pVar) = 0;
623 virtual HRESULT __stdcall put_Command(
624 /*[in]*/ VARIANT pVar) = 0;
625 virtual HRESULT __stdcall putref_Command(
626 /*[in]*/ IDispatch* pVar) = 0;
627 virtual HRESULT __stdcall get_Name(
628 /*[out,retval]*/ BSTR* pVal) = 0;
629 virtual HRESULT __stdcall get_DateCreated(
630 /*[out,retval]*/ VARIANT* pVal) = 0;
631 virtual HRESULT __stdcall get_DateModified(
632 /*[out,retval]*/ VARIANT* pVal) = 0;
633};
634
635struct __declspec(uuid("00000626-0000-0010-8000-00aa006d2ea4")) Procedures : _Collection
636{
637 //
638 // Property data
639 //
640
641 __declspec(property(get = GetItem)) ProcedurePtr Item[];
642
643 //
644 // Wrapper methods for error-handling
645 //
646
647 ProcedurePtr GetItem(const _variant_t& Item);
648 HRESULT Append(_bstr_t Name, IDispatch* Command);
649 HRESULT Delete(const _variant_t& Item);
650
651 //
652 // Raw methods provided by interface
653 //
654
655 virtual HRESULT __stdcall get_Item(
656 /*[in]*/ VARIANT Item,
657 /*[out,retval]*/ struct Procedure** ppvObject) = 0;
658 virtual HRESULT __stdcall raw_Append(
659 /*[in]*/ BSTR Name,
660 /*[in]*/ IDispatch* Command) = 0;
661 virtual HRESULT __stdcall raw_Delete(
662 /*[in]*/ VARIANT Item) = 0;
663};
664
665struct __declspec(uuid("00000613-0000-0010-8000-00aa006d2ea4")) View : IDispatch
666{
667 //
668 // Property data
669 //
670
671 __declspec(property(get = GetName)) _bstr_t Name;
672 __declspec(property(get = GetDateCreated)) _variant_t DateCreated;
673 __declspec(property(get = GetDateModified)) _variant_t DateModified;
674
675 //
676 // Wrapper methods for error-handling
677 //
678
679 _variant_t GetCommand();
680 void PutCommand(const _variant_t& pVal);
681 void PutRefCommand(IDispatch* pVal);
682 _bstr_t GetName();
683 _variant_t GetDateCreated();
684 _variant_t GetDateModified();
685
686 //
687 // Raw methods provided by interface
688 //
689
690 virtual HRESULT __stdcall get_Command(
691 /*[out,retval]*/ VARIANT* pVal) = 0;
692 virtual HRESULT __stdcall put_Command(
693 /*[in]*/ VARIANT pVal) = 0;
694 virtual HRESULT __stdcall putref_Command(
695 /*[in]*/ IDispatch* pVal) = 0;
696 virtual HRESULT __stdcall get_Name(
697 /*[out,retval]*/ BSTR* pVal) = 0;
698 virtual HRESULT __stdcall get_DateCreated(
699 /*[out,retval]*/ VARIANT* pVal) = 0;
700 virtual HRESULT __stdcall get_DateModified(
701 /*[out,retval]*/ VARIANT* pVal) = 0;
702};
703
704struct __declspec(uuid("00000614-0000-0010-8000-00aa006d2ea4")) Views : _Collection
705{
706 //
707 // Property data
708 //
709
710 __declspec(property(get = GetItem)) ViewPtr Item[];
711
712 //
713 // Wrapper methods for error-handling
714 //
715
716 ViewPtr GetItem(const _variant_t& Item);
717 HRESULT Append(_bstr_t Name, IDispatch* Command);
718 HRESULT Delete(const _variant_t& Item);
719
720 //
721 // Raw methods provided by interface
722 //
723
724 virtual HRESULT __stdcall get_Item(
725 /*[in]*/ VARIANT Item,
726 /*[out,retval]*/ struct View** ppvObject) = 0;
727 virtual HRESULT __stdcall raw_Append(
728 /*[in]*/ BSTR Name,
729 /*[in]*/ IDispatch* Command) = 0;
730 virtual HRESULT __stdcall raw_Delete(
731 /*[in]*/ VARIANT Item) = 0;
732};
733
734struct __declspec(uuid("00000615-0000-0010-8000-00aa006d2ea4")) Group;
735// [ default ] interface _Group
736
737struct __declspec(uuid("00000617-0000-0010-8000-00aa006d2ea4")) Groups : _Collection
738{
739 //
740 // Property data
741 //
742
743 __declspec(property(get = GetItem)) _GroupPtr Item[];
744
745 //
746 // Wrapper methods for error-handling
747 //
748
749 _GroupPtr GetItem(const _variant_t& Item);
750 HRESULT Append(const _variant_t& Item);
751 HRESULT Delete(const _variant_t& Item);
752
753 //
754 // Raw methods provided by interface
755 //
756
757 virtual HRESULT __stdcall get_Item(
758 /*[in]*/ VARIANT Item,
759 /*[out,retval]*/ struct _Group** ppvObject) = 0;
760 virtual HRESULT __stdcall raw_Append(
761 /*[in]*/ VARIANT Item) = 0;
762 virtual HRESULT __stdcall raw_Delete(
763 /*[in]*/ VARIANT Item) = 0;
764};
765
766enum ObjectTypeEnum
767{
768 adPermObjProviderSpecific = -1,
769 adPermObjTable = 1,
770 adPermObjColumn = 2,
771 adPermObjDatabase = 3,
772 adPermObjProcedure = 4,
773 adPermObjView = 5
774};
775
776enum RightsEnum
777{
778 adRightNone = 0,
779 adRightDrop = 256,
780 adRightExclusive = 512,
781 adRightReadDesign = 1024,
782 adRightWriteDesign = 2048,
783 adRightWithGrant = 4096,
784 adRightReference = 8192,
785 adRightCreate = 16384,
786 adRightInsert = 32768,
787 adRightDelete = 65536,
788 adRightReadPermissions = 131072,
789 adRightWritePermissions = 262144,
790 adRightWriteOwner = 524288,
791 adRightMaximumAllowed = 33554432,
792 adRightFull = 268435456,
793 adRightExecute = 536870912,
794 adRightUpdate = 1073741824,
795 adRightRead = 0x80000000
796};
797
798enum ActionEnum
799{
800 adAccessGrant = 1,
801 adAccessSet = 2,
802 adAccessDeny = 3,
803 adAccessRevoke = 4
804};
805
806enum InheritTypeEnum
807{
808 adInheritNone = 0,
809 adInheritObjects = 1,
810 adInheritContainers = 2,
811 adInheritBoth = 3,
812 adInheritNoPropogate = 4
813};
814
815struct __declspec(uuid("00000618-0000-0010-8000-00aa006d2ea4")) User;
816// [ default ] interface _User
817
818struct __declspec(uuid("0000061a-0000-0010-8000-00aa006d2ea4")) Users : _Collection
819{
820 //
821 // Property data
822 //
823
824 __declspec(property(get = GetItem)) _UserPtr Item[];
825
826 //
827 // Wrapper methods for error-handling
828 //
829
830 _UserPtr GetItem(const _variant_t& Item);
831 HRESULT Append(const _variant_t& Item, _bstr_t Password);
832 HRESULT Delete(const _variant_t& Item);
833
834 //
835 // Raw methods provided by interface
836 //
837
838 virtual HRESULT __stdcall get_Item(
839 /*[in]*/ VARIANT Item,
840 /*[out,retval]*/ struct _User** ppvObject) = 0;
841 virtual HRESULT __stdcall raw_Append(
842 /*[in]*/ VARIANT Item,
843 /*[in]*/ BSTR Password) = 0;
844 virtual HRESULT __stdcall raw_Delete(
845 /*[in]*/ VARIANT Item) = 0;
846};
847
848struct __declspec(uuid("00000603-0000-0010-8000-00aa006d2ea4")) _Catalog : IDispatch
849{
850 //
851 // Property data
852 //
853
854 __declspec(property(get = GetTables)) TablesPtr Tables;
855 __declspec(property(get = GetProcedures)) ProceduresPtr Procedures;
856 __declspec(property(get = GetViews)) ViewsPtr Views;
857 __declspec(property(get = GetGroups)) GroupsPtr Groups;
858 __declspec(property(get = GetUsers)) UsersPtr Users;
859
860 //
861 // Wrapper methods for error-handling
862 //
863
864 TablesPtr GetTables();
865 _variant_t GetActiveConnection();
866 void PutActiveConnection(const _variant_t& pVal);
867 void PutRefActiveConnection(IDispatch* pVal);
868 ProceduresPtr GetProcedures();
869 ViewsPtr GetViews();
870 GroupsPtr GetGroups();
871 UsersPtr GetUsers();
872 _variant_t Create(_bstr_t ConnectString);
873 _bstr_t GetObjectOwner(_bstr_t ObjectName, enum ObjectTypeEnum ObjectType,
874 const _variant_t& ObjectTypeId = vtMissing);
875 HRESULT SetObjectOwner(_bstr_t ObjectName, enum ObjectTypeEnum ObjectType, _bstr_t UserName,
876 const _variant_t& ObjectTypeId = vtMissing);
877
878 //
879 // Raw methods provided by interface
880 //
881
882 virtual HRESULT __stdcall get_Tables(
883 /*[out,retval]*/ struct Tables** ppvObject) = 0;
884 virtual HRESULT __stdcall get_ActiveConnection(
885 /*[out,retval]*/ VARIANT* pVal) = 0;
886 virtual HRESULT __stdcall put_ActiveConnection(
887 /*[in]*/ VARIANT pVal) = 0;
888 virtual HRESULT __stdcall putref_ActiveConnection(
889 /*[in]*/ IDispatch* pVal) = 0;
890 virtual HRESULT __stdcall get_Procedures(
891 /*[out,retval]*/ struct Procedures** ppvObject) = 0;
892 virtual HRESULT __stdcall get_Views(
893 /*[out,retval]*/ struct Views** ppvObject) = 0;
894 virtual HRESULT __stdcall get_Groups(
895 /*[out,retval]*/ struct Groups** ppvObject) = 0;
896 virtual HRESULT __stdcall get_Users(
897 /*[out,retval]*/ struct Users** ppvObject) = 0;
898 virtual HRESULT __stdcall raw_Create(
899 /*[in]*/ BSTR ConnectString,
900 /*[out,retval]*/ VARIANT* Connection) = 0;
901 virtual HRESULT __stdcall raw_GetObjectOwner(
902 /*[in]*/ BSTR ObjectName,
903 /*[in]*/ enum ObjectTypeEnum ObjectType,
904 /*[in]*/ VARIANT ObjectTypeId,
905 /*[out,retval]*/ BSTR* OwnerName) = 0;
906 virtual HRESULT __stdcall raw_SetObjectOwner(
907 /*[in]*/ BSTR ObjectName,
908 /*[in]*/ enum ObjectTypeEnum ObjectType,
909 /*[in]*/ BSTR UserName,
910 /*[in]*/ VARIANT ObjectTypeId = vtMissing) = 0;
911};
912
913struct __declspec(uuid("00000610-0000-0010-8000-00aa006d2ea4")) _Table : IDispatch
914{
915 //
916 // Property data
917 //
918
919 __declspec(property(get = GetColumns)) ColumnsPtr Columns;
920 __declspec(property(get = GetName, put = PutName)) _bstr_t Name;
921 __declspec(property(get = GetType)) _bstr_t Type;
922 __declspec(property(get = GetIndexes)) IndexesPtr Indexes;
923 __declspec(property(get = GetKeys)) KeysPtr Keys;
924 __declspec(property(get = GetProperties)) PropertiesPtr Properties;
925 __declspec(property(get = GetDateCreated)) _variant_t DateCreated;
926 __declspec(property(get = GetDateModified)) _variant_t DateModified;
927 __declspec(property(get = GetParentCatalog,
928 put = PutRefParentCatalog)) _CatalogPtr ParentCatalog;
929
930 //
931 // Wrapper methods for error-handling
932 //
933
934 ColumnsPtr GetColumns();
935 _bstr_t GetName();
936 void PutName(_bstr_t pVal);
937 _bstr_t GetType();
938 IndexesPtr GetIndexes();
939 KeysPtr GetKeys();
940 PropertiesPtr GetProperties();
941 _variant_t GetDateCreated();
942 _variant_t GetDateModified();
943 _CatalogPtr GetParentCatalog();
944 void PutParentCatalog(struct _Catalog* ppvObject);
945 void PutRefParentCatalog(struct _Catalog* ppvObject);
946
947 //
948 // Raw methods provided by interface
949 //
950
951 virtual HRESULT __stdcall get_Columns(
952 /*[out,retval]*/ struct Columns** ppvObject) = 0;
953 virtual HRESULT __stdcall get_Name(
954 /*[out,retval]*/ BSTR* pVal) = 0;
955 virtual HRESULT __stdcall put_Name(
956 /*[in]*/ BSTR pVal) = 0;
957 virtual HRESULT __stdcall get_Type(
958 /*[out,retval]*/ BSTR* pVal) = 0;
959 virtual HRESULT __stdcall get_Indexes(
960 /*[out,retval]*/ struct Indexes** ppvObject) = 0;
961 virtual HRESULT __stdcall get_Keys(
962 /*[out,retval]*/ struct Keys** ppvObject) = 0;
963 virtual HRESULT __stdcall get_Properties(
964 /*[out,retval]*/ struct Properties** ppvObject) = 0;
965 virtual HRESULT __stdcall get_DateCreated(
966 /*[out,retval]*/ VARIANT* pVal) = 0;
967 virtual HRESULT __stdcall get_DateModified(
968 /*[out,retval]*/ VARIANT* pVal) = 0;
969 virtual HRESULT __stdcall get_ParentCatalog(
970 /*[out,retval]*/ struct _Catalog** ppvObject) = 0;
971 virtual HRESULT __stdcall put_ParentCatalog(
972 /*[in]*/ struct _Catalog* ppvObject) = 0;
973 virtual HRESULT __stdcall putref_ParentCatalog(
974 /*[in]*/ struct _Catalog* ppvObject) = 0;
975};
976
977struct __declspec(uuid("0000061c-0000-0010-8000-00aa006d2ea4")) _Column : IDispatch
978{
979 //
980 // Property data
981 //
982
983 __declspec(property(get = GetName, put = PutName)) _bstr_t Name;
984 __declspec(property(get = GetAttributes,
985 put = PutAttributes)) enum ColumnAttributesEnum Attributes;
986 __declspec(property(get = GetDefinedSize, put = PutDefinedSize)) long DefinedSize;
987 __declspec(property(get = GetNumericScale, put = PutNumericScale)) unsigned char NumericScale;
988 __declspec(property(get = GetPrecision, put = PutPrecision)) long Precision;
989 __declspec(property(get = GetRelatedColumn, put = PutRelatedColumn)) _bstr_t RelatedColumn;
990 __declspec(property(get = GetSortOrder, put = PutSortOrder)) enum SortOrderEnum SortOrder;
991 __declspec(property(get = GetType, put = PutType)) enum DataTypeEnum Type;
992 __declspec(property(get = GetProperties)) PropertiesPtr Properties;
993 __declspec(property(get = GetParentCatalog,
994 put = PutRefParentCatalog)) _CatalogPtr ParentCatalog;
995
996 //
997 // Wrapper methods for error-handling
998 //
999
1000 _bstr_t GetName();
1001 void PutName(_bstr_t pVal);
1002 enum ColumnAttributesEnum GetAttributes();
1003 void PutAttributes(enum ColumnAttributesEnum pVal);
1004 long GetDefinedSize();
1005 void PutDefinedSize(long pVal);
1006 unsigned char GetNumericScale();
1007 void PutNumericScale(unsigned char pVal);
1008 long GetPrecision();
1009 void PutPrecision(long pVal);
1010 _bstr_t GetRelatedColumn();
1011 void PutRelatedColumn(_bstr_t pVal);
1012 enum SortOrderEnum GetSortOrder();
1013 void PutSortOrder(enum SortOrderEnum pVal);
1014 enum DataTypeEnum GetType();
1015 void PutType(enum DataTypeEnum pVal);
1016 PropertiesPtr GetProperties();
1017 _CatalogPtr GetParentCatalog();
1018 void PutParentCatalog(struct _Catalog* ppvObject);
1019 void PutRefParentCatalog(struct _Catalog* ppvObject);
1020
1021 //
1022 // Raw methods provided by interface
1023 //
1024
1025 virtual HRESULT __stdcall get_Name(
1026 /*[out,retval]*/ BSTR* pVal) = 0;
1027 virtual HRESULT __stdcall put_Name(
1028 /*[in]*/ BSTR pVal) = 0;
1029 virtual HRESULT __stdcall get_Attributes(
1030 /*[out,retval]*/ enum ColumnAttributesEnum* pVal) = 0;
1031 virtual HRESULT __stdcall put_Attributes(
1032 /*[in]*/ enum ColumnAttributesEnum pVal) = 0;
1033 virtual HRESULT __stdcall get_DefinedSize(
1034 /*[out,retval]*/ long* pVal) = 0;
1035 virtual HRESULT __stdcall put_DefinedSize(
1036 /*[in]*/ long pVal) = 0;
1037 virtual HRESULT __stdcall get_NumericScale(
1038 /*[out,retval]*/ unsigned char* pVal) = 0;
1039 virtual HRESULT __stdcall put_NumericScale(
1040 /*[in]*/ unsigned char pVal) = 0;
1041 virtual HRESULT __stdcall get_Precision(
1042 /*[out,retval]*/ long* pVal) = 0;
1043 virtual HRESULT __stdcall put_Precision(
1044 /*[in]*/ long pVal) = 0;
1045 virtual HRESULT __stdcall get_RelatedColumn(
1046 /*[out,retval]*/ BSTR* pVal) = 0;
1047 virtual HRESULT __stdcall put_RelatedColumn(
1048 /*[in]*/ BSTR pVal) = 0;
1049 virtual HRESULT __stdcall get_SortOrder(
1050 /*[out,retval]*/ enum SortOrderEnum* pVal) = 0;
1051 virtual HRESULT __stdcall put_SortOrder(
1052 /*[in]*/ enum SortOrderEnum pVal) = 0;
1053 virtual HRESULT __stdcall get_Type(
1054 /*[out,retval]*/ enum DataTypeEnum* pVal) = 0;
1055 virtual HRESULT __stdcall put_Type(
1056 /*[in]*/ enum DataTypeEnum pVal) = 0;
1057 virtual HRESULT __stdcall get_Properties(
1058 /*[out,retval]*/ struct Properties** ppvObject) = 0;
1059 virtual HRESULT __stdcall get_ParentCatalog(
1060 /*[out,retval]*/ struct _Catalog** ppvObject) = 0;
1061 virtual HRESULT __stdcall put_ParentCatalog(
1062 /*[in]*/ struct _Catalog* ppvObject) = 0;
1063 virtual HRESULT __stdcall putref_ParentCatalog(
1064 /*[in]*/ struct _Catalog* ppvObject) = 0;
1065};
1066
1067struct __declspec(uuid("00000616-0000-0010-8000-00aa006d2ea4")) _Group25 : IDispatch
1068{
1069 //
1070 // Property data
1071 //
1072
1073 __declspec(property(get = GetName, put = PutName)) _bstr_t Name;
1074 __declspec(property(get = GetUsers)) UsersPtr Users;
1075
1076 //
1077 // Wrapper methods for error-handling
1078 //
1079
1080 _bstr_t GetName();
1081 void PutName(_bstr_t pVal);
1082 enum RightsEnum GetPermissions(const _variant_t& Name, enum ObjectTypeEnum ObjectType,
1083 const _variant_t& ObjectTypeId = vtMissing);
1084 HRESULT SetPermissions(const _variant_t& Name, enum ObjectTypeEnum ObjectType,
1085 enum ActionEnum Action, enum RightsEnum Rights,
1086 enum InheritTypeEnum Inherit,
1087 const _variant_t& ObjectTypeId = vtMissing);
1088 UsersPtr GetUsers();
1089
1090 //
1091 // Raw methods provided by interface
1092 //
1093
1094 virtual HRESULT __stdcall get_Name(
1095 /*[out,retval]*/ BSTR* pVal) = 0;
1096 virtual HRESULT __stdcall put_Name(
1097 /*[in]*/ BSTR pVal) = 0;
1098 virtual HRESULT __stdcall raw_GetPermissions(
1099 /*[in]*/ VARIANT Name,
1100 /*[in]*/ enum ObjectTypeEnum ObjectType,
1101 /*[in]*/ VARIANT ObjectTypeId,
1102 /*[out,retval]*/ enum RightsEnum* Rights) = 0;
1103 virtual HRESULT __stdcall raw_SetPermissions(
1104 /*[in]*/ VARIANT Name,
1105 /*[in]*/ enum ObjectTypeEnum ObjectType,
1106 /*[in]*/ enum ActionEnum Action,
1107 /*[in]*/ enum RightsEnum Rights,
1108 /*[in]*/ enum InheritTypeEnum Inherit,
1109 /*[in]*/ VARIANT ObjectTypeId = vtMissing) = 0;
1110 virtual HRESULT __stdcall get_Users(
1111 /*[out,retval]*/ struct Users** ppvObject) = 0;
1112};
1113
1114struct __declspec(uuid("00000628-0000-0010-8000-00aa006d2ea4")) _Group : _Group25
1115{
1116 //
1117 // Property data
1118 //
1119
1120 __declspec(property(get = GetProperties)) PropertiesPtr Properties;
1121 __declspec(property(get = GetParentCatalog,
1122 put = PutRefParentCatalog)) _CatalogPtr ParentCatalog;
1123
1124 //
1125 // Wrapper methods for error-handling
1126 //
1127
1128 PropertiesPtr GetProperties();
1129 _CatalogPtr GetParentCatalog();
1130 void PutParentCatalog(struct _Catalog* ppvObject);
1131 void PutRefParentCatalog(struct _Catalog* ppvObject);
1132
1133 //
1134 // Raw methods provided by interface
1135 //
1136
1137 virtual HRESULT __stdcall get_Properties(
1138 /*[out,retval]*/ struct Properties** ppvObject) = 0;
1139 virtual HRESULT __stdcall get_ParentCatalog(
1140 /*[out,retval]*/ struct _Catalog** ppvObject) = 0;
1141 virtual HRESULT __stdcall put_ParentCatalog(
1142 /*[in]*/ struct _Catalog* ppvObject) = 0;
1143 virtual HRESULT __stdcall putref_ParentCatalog(
1144 /*[in]*/ struct _Catalog* ppvObject) = 0;
1145};
1146
1147struct __declspec(uuid("00000619-0000-0010-8000-00aa006d2ea4")) _User25 : IDispatch
1148{
1149 //
1150 // Property data
1151 //
1152
1153 __declspec(property(get = GetName, put = PutName)) _bstr_t Name;
1154 __declspec(property(get = GetGroups)) GroupsPtr Groups;
1155
1156 //
1157 // Wrapper methods for error-handling
1158 //
1159
1160 _bstr_t GetName();
1161 void PutName(_bstr_t pVal);
1162 enum RightsEnum GetPermissions(const _variant_t& Name, enum ObjectTypeEnum ObjectType,
1163 const _variant_t& ObjectTypeId = vtMissing);
1164 HRESULT SetPermissions(const _variant_t& Name, enum ObjectTypeEnum ObjectType,
1165 enum ActionEnum Action, enum RightsEnum Rights,
1166 enum InheritTypeEnum Inherit,
1167 const _variant_t& ObjectTypeId = vtMissing);
1168 HRESULT ChangePassword(_bstr_t OldPassword, _bstr_t NewPassword);
1169 GroupsPtr GetGroups();
1170
1171 //
1172 // Raw methods provided by interface
1173 //
1174
1175 virtual HRESULT __stdcall get_Name(
1176 /*[out,retval]*/ BSTR* pVal) = 0;
1177 virtual HRESULT __stdcall put_Name(
1178 /*[in]*/ BSTR pVal) = 0;
1179 virtual HRESULT __stdcall raw_GetPermissions(
1180 /*[in]*/ VARIANT Name,
1181 /*[in]*/ enum ObjectTypeEnum ObjectType,
1182 /*[in]*/ VARIANT ObjectTypeId,
1183 /*[out,retval]*/ enum RightsEnum* Rights) = 0;
1184 virtual HRESULT __stdcall raw_SetPermissions(
1185 /*[in]*/ VARIANT Name,
1186 /*[in]*/ enum ObjectTypeEnum ObjectType,
1187 /*[in]*/ enum ActionEnum Action,
1188 /*[in]*/ enum RightsEnum Rights,
1189 /*[in]*/ enum InheritTypeEnum Inherit,
1190 /*[in]*/ VARIANT ObjectTypeId = vtMissing) = 0;
1191 virtual HRESULT __stdcall raw_ChangePassword(
1192 /*[in]*/ BSTR OldPassword,
1193 /*[in]*/ BSTR NewPassword) = 0;
1194 virtual HRESULT __stdcall get_Groups(
1195 /*[out,retval]*/ struct Groups** ppvObject) = 0;
1196};
1197
1198struct __declspec(uuid("00000627-0000-0010-8000-00aa006d2ea4")) _User : _User25
1199{
1200 //
1201 // Property data
1202 //
1203
1204 __declspec(property(get = GetProperties)) PropertiesPtr Properties;
1205 __declspec(property(get = GetParentCatalog,
1206 put = PutRefParentCatalog)) _CatalogPtr ParentCatalog;
1207
1208 //
1209 // Wrapper methods for error-handling
1210 //
1211
1212 PropertiesPtr GetProperties();
1213 _CatalogPtr GetParentCatalog();
1214 void PutParentCatalog(struct _Catalog* ppvObject);
1215 void PutRefParentCatalog(struct _Catalog* ppvObject);
1216
1217 //
1218 // Raw methods provided by interface
1219 //
1220
1221 virtual HRESULT __stdcall get_Properties(
1222 /*[out,retval]*/ struct Properties** ppvObject) = 0;
1223 virtual HRESULT __stdcall get_ParentCatalog(
1224 /*[out,retval]*/ struct _Catalog** ppvObject) = 0;
1225 virtual HRESULT __stdcall put_ParentCatalog(
1226 /*[in]*/ struct _Catalog* ppvObject) = 0;
1227 virtual HRESULT __stdcall putref_ParentCatalog(
1228 /*[in]*/ struct _Catalog* ppvObject) = 0;
1229};
1230
1231struct __declspec(uuid("00000602-0000-0010-8000-00aa006d2ea4")) Catalog;
1232// [ default ] interface _Catalog
1233
1234//
1235// Wrapper method implementations
1236//
1237
1238//#include "Debug\msadox.tli"
1239
1240} // namespace XTPGRIDADOX
1241
1242namespace XTPGRIDADODB
1243{
1244//
1245// Forward references and typedefs
1246//
1247
1248struct __declspec(uuid("b691e011-1797-432e-907a-4d8c69339129"))
1249 /* LIBID */ __ADODB;
1250enum CursorTypeEnum;
1251enum CursorOptionEnum;
1252enum LockTypeEnum;
1253enum ExecuteOptionEnum;
1254enum ConnectOptionEnum;
1255enum ObjectStateEnum;
1256enum CursorLocationEnum;
1257enum DataTypeEnum;
1258enum FieldAttributeEnum;
1259enum EditModeEnum;
1260enum RecordStatusEnum;
1261enum GetRowsOptionEnum;
1262enum PositionEnum;
1263enum BookmarkEnum;
1264enum MarshalOptionsEnum;
1265enum AffectEnum;
1266enum ResyncEnum;
1267enum CompareEnum;
1268enum FilterGroupEnum;
1269enum SearchDirectionEnum;
1270enum PersistFormatEnum;
1271enum StringFormatEnum;
1272enum ConnectPromptEnum;
1273enum ConnectModeEnum;
1274enum RecordCreateOptionsEnum;
1275enum RecordOpenOptionsEnum;
1276enum IsolationLevelEnum;
1277enum XactAttributeEnum;
1278enum PropertyAttributesEnum;
1279enum ErrorValueEnum;
1280enum ParameterAttributesEnum;
1281enum ParameterDirectionEnum;
1282enum CommandTypeEnum;
1283enum EventStatusEnum;
1284enum EventReasonEnum;
1285enum SchemaEnum;
1286enum FieldStatusEnum;
1287enum SeekEnum;
1288enum ADCPROP_UPDATECRITERIA_ENUM;
1289enum ADCPROP_ASYNCTHREADPRIORITY_ENUM;
1290enum ADCPROP_AUTORECALC_ENUM;
1291enum ADCPROP_UPDATERESYNC_ENUM;
1292enum MoveRecordOptionsEnum;
1293enum CopyRecordOptionsEnum;
1294enum StreamTypeEnum;
1295enum LineSeparatorEnum;
1296enum StreamOpenOptionsEnum;
1297enum StreamWriteEnum;
1298enum SaveOptionsEnum;
1299enum FieldEnum;
1300enum StreamReadEnum;
1301enum RecordTypeEnum;
1302struct __declspec(uuid("00000512-0000-0010-8000-00aa006d2ea4"))
1303 /* dual interface */ _Collection;
1304struct __declspec(uuid("00000513-0000-0010-8000-00aa006d2ea4"))
1305 /* dual interface */ _DynaCollection;
1306struct __declspec(uuid("00000534-0000-0010-8000-00aa006d2ea4"))
1307 /* dual interface */ _ADO;
1308struct __declspec(uuid("00000504-0000-0010-8000-00aa006d2ea4"))
1309 /* dual interface */ Properties;
1310struct __declspec(uuid("00000503-0000-0010-8000-00aa006d2ea4"))
1311 /* dual interface */ Property;
1312struct __declspec(uuid("00000500-0000-0010-8000-00aa006d2ea4"))
1313 /* dual interface */ Error;
1314struct __declspec(uuid("00000501-0000-0010-8000-00aa006d2ea4"))
1315 /* dual interface */ Errors;
1316struct __declspec(uuid("00001508-0000-0010-8000-00aa006d2ea4"))
1317 /* dual interface */ Command15;
1318struct __declspec(uuid("00001550-0000-0010-8000-00aa006d2ea4"))
1319 /* dual interface */ _Connection;
1320struct __declspec(uuid("00001515-0000-0010-8000-00aa006d2ea4"))
1321 /* dual interface */ Connection15;
1322struct __declspec(uuid("00001556-0000-0010-8000-00aa006d2ea4"))
1323 /* dual interface */ _Recordset;
1324struct __declspec(uuid("00001555-0000-0010-8000-00aa006d2ea4"))
1325 /* dual interface */ Recordset21;
1326struct __declspec(uuid("0000154f-0000-0010-8000-00aa006d2ea4"))
1327 /* dual interface */ Recordset20;
1328struct __declspec(uuid("0000150e-0000-0010-8000-00aa006d2ea4"))
1329 /* dual interface */ Recordset15;
1330struct __declspec(uuid("00001564-0000-0010-8000-00aa006d2ea4"))
1331 /* dual interface */ Fields;
1332struct __declspec(uuid("0000154d-0000-0010-8000-00aa006d2ea4"))
1333 /* dual interface */ Fields20;
1334struct __declspec(uuid("00001506-0000-0010-8000-00aa006d2ea4"))
1335 /* dual interface */ Fields15;
1336struct __declspec(uuid("00001569-0000-0010-8000-00aa006d2ea4"))
1337 /* dual interface */ Field;
1338struct __declspec(uuid("0000154c-0000-0010-8000-00aa006d2ea4"))
1339 /* dual interface */ Field20;
1340struct __declspec(uuid("0000150c-0000-0010-8000-00aa006d2ea4"))
1341 /* dual interface */ _Parameter;
1342struct __declspec(uuid("0000150d-0000-0010-8000-00aa006d2ea4"))
1343 /* dual interface */ Parameters;
1344struct __declspec(uuid("0000154e-0000-0010-8000-00aa006d2ea4"))
1345 /* dual interface */ Command25;
1346struct __declspec(uuid("986761e8-7269-4890-aa65-ad7c03697a6d"))
1347 /* dual interface */ _Command;
1348struct __declspec(uuid("00001402-0000-0010-8000-00aa006d2ea4"))
1349 /* interface */ ConnectionEventsVt;
1350struct __declspec(uuid("00001403-0000-0010-8000-00aa006d2ea4"))
1351 /* interface */ RecordsetEventsVt;
1352struct __declspec(uuid("00001400-0000-0010-8000-00aa006d2ea4"))
1353 /* dispinterface */ ConnectionEvents;
1354struct __declspec(uuid("00001266-0000-0010-8000-00aa006d2ea4"))
1355 /* dispinterface */ RecordsetEvents;
1356struct __declspec(uuid("00000516-0000-0010-8000-00aa006d2ea4"))
1357 /* interface */ ADOConnectionConstruction15;
1358struct __declspec(uuid("00000551-0000-0010-8000-00aa006d2ea4"))
1359 /* interface */ ADOConnectionConstruction;
1360struct /* coclass */ Connection;
1361struct __declspec(uuid("00001562-0000-0010-8000-00aa006d2ea4"))
1362 /* dual interface */ _Record;
1363struct /* coclass */ Record;
1364struct __declspec(uuid("00001565-0000-0010-8000-00aa006d2ea4"))
1365 /* dual interface */ _Stream;
1366struct /* coclass */ Stream;
1367struct __declspec(uuid("00000567-0000-0010-8000-00aa006d2ea4"))
1368 /* interface */ ADORecordConstruction;
1369struct __declspec(uuid("00000568-0000-0010-8000-00aa006d2ea4"))
1370 /* interface */ ADOStreamConstruction;
1371struct __declspec(uuid("00000517-0000-0010-8000-00aa006d2ea4"))
1372 /* interface */ ADOCommandConstruction;
1373struct /* coclass */ Command;
1374struct /* coclass */ Recordset;
1375struct __declspec(uuid("00000283-0000-0010-8000-00aa006d2ea4"))
1376 /* interface */ ADORecordsetConstruction;
1377struct __declspec(uuid("00001505-0000-0010-8000-00aa006d2ea4"))
1378 /* dual interface */ Field15;
1379struct /* coclass */ Parameter;
1380struct __declspec(uuid("00000402-0000-0010-8000-00aa006d2ea4"))
1381 /* interface */ ConnectionEventsVt_Deprecated;
1382struct __declspec(uuid("00000550-0000-0010-8000-00aa006d2ea4"))
1383 /* dual interface */ _Connection_Deprecated;
1384struct __declspec(uuid("00000515-0000-0010-8000-00aa006d2ea4"))
1385 /* dual interface */ Connection15_Deprecated;
1386struct __declspec(uuid("00000556-0000-0010-8000-00aa006d2ea4"))
1387 /* dual interface */ _Recordset_Deprecated;
1388struct __declspec(uuid("00000555-0000-0010-8000-00aa006d2ea4"))
1389 /* dual interface */ Recordset21_Deprecated;
1390struct __declspec(uuid("0000054f-0000-0010-8000-00aa006d2ea4"))
1391 /* dual interface */ Recordset20_Deprecated;
1392struct __declspec(uuid("0000050e-0000-0010-8000-00aa006d2ea4"))
1393 /* dual interface */ Recordset15_Deprecated;
1394struct __declspec(uuid("00000564-0000-0010-8000-00aa006d2ea4"))
1395 /* dual interface */ Fields_Deprecated;
1396struct __declspec(uuid("0000054d-0000-0010-8000-00aa006d2ea4"))
1397 /* dual interface */ Fields20_Deprecated;
1398struct __declspec(uuid("00000506-0000-0010-8000-00aa006d2ea4"))
1399 /* dual interface */ Fields15_Deprecated;
1400struct __declspec(uuid("00000569-0000-0010-8000-00aa006d2ea4"))
1401 /* dual interface */ Field_Deprecated;
1402struct __declspec(uuid("0000054c-0000-0010-8000-00aa006d2ea4"))
1403 /* dual interface */ Field20_Deprecated;
1404struct __declspec(uuid("b08400bd-f9d1-4d02-b856-71d5dba123e9"))
1405 /* dual interface */ _Command_Deprecated;
1406struct __declspec(uuid("0000054e-0000-0010-8000-00aa006d2ea4"))
1407 /* dual interface */ Command25_Deprecated;
1408struct __declspec(uuid("00000508-0000-0010-8000-00aa006d2ea4"))
1409 /* dual interface */ Command15_Deprecated;
1410struct __declspec(uuid("0000050c-0000-0010-8000-00aa006d2ea4"))
1411 /* dual interface */ _Parameter_Deprecated;
1412struct __declspec(uuid("0000050d-0000-0010-8000-00aa006d2ea4"))
1413 /* dual interface */ Parameters_Deprecated;
1414struct __declspec(uuid("00000403-0000-0010-8000-00aa006d2ea4"))
1415 /* interface */ RecordsetEventsVt_Deprecated;
1416struct __declspec(uuid("00000400-0000-0010-8000-00aa006d2ea4"))
1417 /* dispinterface */ ConnectionEvents_Deprecated;
1418struct __declspec(uuid("00000266-0000-0010-8000-00aa006d2ea4"))
1419 /* dispinterface */ RecordsetEvents_Deprecated;
1420struct __declspec(uuid("00000562-0000-0010-8000-00aa006d2ea4"))
1421 /* dual interface */ _Record_Deprecated;
1422struct __declspec(uuid("00000565-0000-0010-8000-00aa006d2ea4"))
1423 /* dual interface */ _Stream_Deprecated;
1424struct __declspec(uuid("00000505-0000-0010-8000-00aa006d2ea4"))
1425 /* dual interface */ Field15_Deprecated;
1426typedef __int64 PositionEnum_Param;
1427typedef enum SearchDirectionEnum SearchDirection;
1428typedef __int64 ADO_LONGPTR;
1429
1430//
1431// Smart pointer typedef declarations
1432//
1433
1434_COM_SMARTPTR_TYPEDEF(_Collection, __uuidof(_Collection));
1435_COM_SMARTPTR_TYPEDEF(_DynaCollection, __uuidof(_DynaCollection));
1436_COM_SMARTPTR_TYPEDEF(Property, __uuidof(Property));
1437_COM_SMARTPTR_TYPEDEF(Properties, __uuidof(Properties));
1438_COM_SMARTPTR_TYPEDEF(_ADO, __uuidof(_ADO));
1439_COM_SMARTPTR_TYPEDEF(Error, __uuidof(Error));
1440_COM_SMARTPTR_TYPEDEF(Errors, __uuidof(Errors));
1441_COM_SMARTPTR_TYPEDEF(Field20, __uuidof(Field20));
1442_COM_SMARTPTR_TYPEDEF(Field, __uuidof(Field));
1443_COM_SMARTPTR_TYPEDEF(Fields15, __uuidof(Fields15));
1444_COM_SMARTPTR_TYPEDEF(Fields20, __uuidof(Fields20));
1445_COM_SMARTPTR_TYPEDEF(Fields, __uuidof(Fields));
1446_COM_SMARTPTR_TYPEDEF(_Parameter, __uuidof(_Parameter));
1447_COM_SMARTPTR_TYPEDEF(Parameters, __uuidof(Parameters));
1448_COM_SMARTPTR_TYPEDEF(ConnectionEvents, __uuidof(ConnectionEvents));
1449_COM_SMARTPTR_TYPEDEF(RecordsetEvents, __uuidof(RecordsetEvents));
1450_COM_SMARTPTR_TYPEDEF(ADOConnectionConstruction15, __uuidof(ADOConnectionConstruction15));
1451_COM_SMARTPTR_TYPEDEF(ADOConnectionConstruction, __uuidof(ADOConnectionConstruction));
1452_COM_SMARTPTR_TYPEDEF(_Stream, __uuidof(_Stream));
1453_COM_SMARTPTR_TYPEDEF(ADORecordConstruction, __uuidof(ADORecordConstruction));
1454_COM_SMARTPTR_TYPEDEF(ADOStreamConstruction, __uuidof(ADOStreamConstruction));
1455_COM_SMARTPTR_TYPEDEF(ADOCommandConstruction, __uuidof(ADOCommandConstruction));
1456_COM_SMARTPTR_TYPEDEF(ADORecordsetConstruction, __uuidof(ADORecordsetConstruction));
1457_COM_SMARTPTR_TYPEDEF(Field15, __uuidof(Field15));
1458_COM_SMARTPTR_TYPEDEF(Field20_Deprecated, __uuidof(Field20_Deprecated));
1459_COM_SMARTPTR_TYPEDEF(Field_Deprecated, __uuidof(Field_Deprecated));
1460_COM_SMARTPTR_TYPEDEF(Fields15_Deprecated, __uuidof(Fields15_Deprecated));
1461_COM_SMARTPTR_TYPEDEF(Fields20_Deprecated, __uuidof(Fields20_Deprecated));
1462_COM_SMARTPTR_TYPEDEF(Fields_Deprecated, __uuidof(Fields_Deprecated));
1463_COM_SMARTPTR_TYPEDEF(_Parameter_Deprecated, __uuidof(_Parameter_Deprecated));
1464_COM_SMARTPTR_TYPEDEF(Parameters_Deprecated, __uuidof(Parameters_Deprecated));
1465_COM_SMARTPTR_TYPEDEF(ConnectionEvents_Deprecated, __uuidof(ConnectionEvents_Deprecated));
1466_COM_SMARTPTR_TYPEDEF(RecordsetEvents_Deprecated, __uuidof(RecordsetEvents_Deprecated));
1467_COM_SMARTPTR_TYPEDEF(_Stream_Deprecated, __uuidof(_Stream_Deprecated));
1468_COM_SMARTPTR_TYPEDEF(Field15_Deprecated, __uuidof(Field15_Deprecated));
1469_COM_SMARTPTR_TYPEDEF(Command15, __uuidof(Command15));
1470_COM_SMARTPTR_TYPEDEF(Command25, __uuidof(Command25));
1471_COM_SMARTPTR_TYPEDEF(_Command, __uuidof(_Command));
1472_COM_SMARTPTR_TYPEDEF(Connection15, __uuidof(Connection15));
1473_COM_SMARTPTR_TYPEDEF(_Connection, __uuidof(_Connection));
1474_COM_SMARTPTR_TYPEDEF(Recordset15, __uuidof(Recordset15));
1475_COM_SMARTPTR_TYPEDEF(Recordset20, __uuidof(Recordset20));
1476_COM_SMARTPTR_TYPEDEF(Recordset21, __uuidof(Recordset21));
1477_COM_SMARTPTR_TYPEDEF(_Recordset, __uuidof(_Recordset));
1478_COM_SMARTPTR_TYPEDEF(ConnectionEventsVt, __uuidof(ConnectionEventsVt));
1479_COM_SMARTPTR_TYPEDEF(RecordsetEventsVt, __uuidof(RecordsetEventsVt));
1480_COM_SMARTPTR_TYPEDEF(_Record, __uuidof(_Record));
1481_COM_SMARTPTR_TYPEDEF(ConnectionEventsVt_Deprecated, __uuidof(ConnectionEventsVt_Deprecated));
1482_COM_SMARTPTR_TYPEDEF(Connection15_Deprecated, __uuidof(Connection15_Deprecated));
1483_COM_SMARTPTR_TYPEDEF(_Connection_Deprecated, __uuidof(_Connection_Deprecated));
1484_COM_SMARTPTR_TYPEDEF(Recordset15_Deprecated, __uuidof(Recordset15_Deprecated));
1485_COM_SMARTPTR_TYPEDEF(Recordset20_Deprecated, __uuidof(Recordset20_Deprecated));
1486_COM_SMARTPTR_TYPEDEF(Recordset21_Deprecated, __uuidof(Recordset21_Deprecated));
1487_COM_SMARTPTR_TYPEDEF(_Recordset_Deprecated, __uuidof(_Recordset_Deprecated));
1488_COM_SMARTPTR_TYPEDEF(Command15_Deprecated, __uuidof(Command15_Deprecated));
1489_COM_SMARTPTR_TYPEDEF(Command25_Deprecated, __uuidof(Command25_Deprecated));
1490_COM_SMARTPTR_TYPEDEF(_Command_Deprecated, __uuidof(_Command_Deprecated));
1491_COM_SMARTPTR_TYPEDEF(RecordsetEventsVt_Deprecated, __uuidof(RecordsetEventsVt_Deprecated));
1492_COM_SMARTPTR_TYPEDEF(_Record_Deprecated, __uuidof(_Record_Deprecated));
1493
1494//
1495// Type library items
1496//
1497
1498enum __declspec(uuid("0000051b-0000-0010-8000-00aa006d2ea4")) CursorTypeEnum
1499{
1500 adOpenUnspecified = -1,
1501 adOpenForwardOnly = 0,
1502 adOpenKeyset = 1,
1503 adOpenDynamic = 2,
1504 adOpenStatic = 3
1505};
1506
1507enum __declspec(uuid("0000051c-0000-0010-8000-00aa006d2ea4")) CursorOptionEnum
1508{
1509 adHoldRecords = 256,
1510 adMovePrevious = 512,
1511 adAddNew = 16778240,
1512 adDelete = 16779264,
1513 adUpdate = 16809984,
1514 adBookmark = 8192,
1515 adApproxPosition = 16384,
1516 adUpdateBatch = 65536,
1517 adResync = 131072,
1518 adNotify = 262144,
1519 adFind = 524288,
1520 adSeek = 4194304,
1521 adIndex = 8388608
1522};
1523
1524enum __declspec(uuid("0000051d-0000-0010-8000-00aa006d2ea4")) LockTypeEnum
1525{
1526 adLockUnspecified = -1,
1527 adLockReadOnly = 1,
1528 adLockPessimistic = 2,
1529 adLockOptimistic = 3,
1530 adLockBatchOptimistic = 4
1531};
1532
1533enum __declspec(uuid("0000051e-0000-0010-8000-00aa006d2ea4")) ExecuteOptionEnum
1534{
1535 adOptionUnspecified = -1,
1536 adAsyncExecute = 16,
1537 adAsyncFetch = 32,
1538 adAsyncFetchNonBlocking = 64,
1539 adExecuteNoRecords = 128,
1540 adExecuteStream = 1024,
1541 adExecuteRecord = 2048
1542};
1543
1544enum __declspec(uuid("00000541-0000-0010-8000-00aa006d2ea4")) ConnectOptionEnum
1545{
1546 adConnectUnspecified = -1,
1547 adAsyncConnect = 16
1548};
1549
1550enum __declspec(uuid("00000532-0000-0010-8000-00aa006d2ea4")) ObjectStateEnum
1551{
1552 adStateClosed = 0,
1553 adStateOpen = 1,
1554 adStateConnecting = 2,
1555 adStateExecuting = 4,
1556 adStateFetching = 8
1557};
1558
1559enum __declspec(uuid("0000052f-0000-0010-8000-00aa006d2ea4")) CursorLocationEnum
1560{
1561 adUseNone = 1,
1562 adUseServer = 2,
1563 adUseClient = 3,
1564 adUseClientBatch = 3
1565};
1566
1567enum __declspec(uuid("0000051f-0000-0010-8000-00aa006d2ea4")) DataTypeEnum
1568{
1569 adEmpty = 0,
1570 adTinyInt = 16,
1571 adSmallInt = 2,
1572 adInteger = 3,
1573 adBigInt = 20,
1574 adUnsignedTinyInt = 17,
1575 adUnsignedSmallInt = 18,
1576 adUnsignedInt = 19,
1577 adUnsignedBigInt = 21,
1578 adSingle = 4,
1579 adDouble = 5,
1580 adCurrency = 6,
1581 adDecimal = 14,
1582 adNumeric = 131,
1583 adBoolean = 11,
1584 adError = 10,
1585 adUserDefined = 132,
1586 adVariant = 12,
1587 adIDispatch = 9,
1588 adIUnknown = 13,
1589 adGUID = 72,
1590 adDate = 7,
1591 adDBDate = 133,
1592 adDBTime = 134,
1593 adDBTimeStamp = 135,
1594 adBSTR = 8,
1595 adChar = 129,
1596 adVarChar = 200,
1597 adLongVarChar = 201,
1598 adWChar = 130,
1599 adVarWChar = 202,
1600 adLongVarWChar = 203,
1601 adBinary = 128,
1602 adVarBinary = 204,
1603 adLongVarBinary = 205,
1604 adChapter = 136,
1605 adFileTime = 64,
1606 adPropVariant = 138,
1607 adVarNumeric = 139,
1608 adArray = 8192
1609};
1610
1611enum __declspec(uuid("00000525-0000-0010-8000-00aa006d2ea4")) FieldAttributeEnum
1612{
1613 adFldUnspecified = -1,
1614 adFldMayDefer = 2,
1615 adFldUpdatable = 4,
1616 adFldUnknownUpdatable = 8,
1617 adFldFixed = 16,
1618 adFldIsNullable = 32,
1619 adFldMayBeNull = 64,
1620 adFldLong = 128,
1621 adFldRowID = 256,
1622 adFldRowVersion = 512,
1623 adFldCacheDeferred = 4096,
1624 adFldIsChapter = 8192,
1625 adFldNegativeScale = 16384,
1626 adFldKeyColumn = 32768,
1627 adFldIsRowURL = 65536,
1628 adFldIsDefaultStream = 131072,
1629 adFldIsCollection = 262144
1630};
1631
1632enum __declspec(uuid("00000526-0000-0010-8000-00aa006d2ea4")) EditModeEnum
1633{
1634 adEditNone = 0,
1635 adEditInProgress = 1,
1636 adEditAdd = 2,
1637 adEditDelete = 4
1638};
1639
1640enum __declspec(uuid("00000527-0000-0010-8000-00aa006d2ea4")) RecordStatusEnum
1641{
1642 adRecOK = 0,
1643 adRecNew = 1,
1644 adRecModified = 2,
1645 adRecDeleted = 4,
1646 adRecUnmodified = 8,
1647 adRecInvalid = 16,
1648 adRecMultipleChanges = 64,
1649 adRecPendingChanges = 128,
1650 adRecCanceled = 256,
1651 adRecCantRelease = 1024,
1652 adRecConcurrencyViolation = 2048,
1653 adRecIntegrityViolation = 4096,
1654 adRecMaxChangesExceeded = 8192,
1655 adRecObjectOpen = 16384,
1656 adRecOutOfMemory = 32768,
1657 adRecPermissionDenied = 65536,
1658 adRecSchemaViolation = 131072,
1659 adRecDBDeleted = 262144
1660};
1661
1662enum __declspec(uuid("00000542-0000-0010-8000-00aa006d2ea4")) GetRowsOptionEnum
1663{
1664 adGetRowsRest = -1
1665};
1666
1667enum __declspec(uuid("00000528-0000-0010-8000-00aa006d2ea4")) PositionEnum
1668{
1669 adPosUnknown = -1,
1670 adPosBOF = -2,
1671 adPosEOF = -3
1672};
1673
1674enum BookmarkEnum
1675{
1676 adBookmarkCurrent = 0,
1677 adBookmarkFirst = 1,
1678 adBookmarkLast = 2
1679};
1680
1681enum __declspec(uuid("00000540-0000-0010-8000-00aa006d2ea4")) MarshalOptionsEnum
1682{
1683 adMarshalAll = 0,
1684 adMarshalModifiedOnly = 1
1685};
1686
1687enum __declspec(uuid("00000543-0000-0010-8000-00aa006d2ea4")) AffectEnum
1688{
1689 adAffectCurrent = 1,
1690 adAffectGroup = 2,
1691 adAffectAll = 3,
1692 adAffectAllChapters = 4
1693};
1694
1695enum __declspec(uuid("00000544-0000-0010-8000-00aa006d2ea4")) ResyncEnum
1696{
1697 adResyncUnderlyingValues = 1,
1698 adResyncAllValues = 2
1699};
1700
1701enum __declspec(uuid("00000545-0000-0010-8000-00aa006d2ea4")) CompareEnum
1702{
1703 adCompareLessThan = 0,
1704 adCompareEqual = 1,
1705 adCompareGreaterThan = 2,
1706 adCompareNotEqual = 3,
1707 adCompareNotComparable = 4
1708};
1709
1710enum __declspec(uuid("00000546-0000-0010-8000-00aa006d2ea4")) FilterGroupEnum
1711{
1712 adFilterNone = 0,
1713 adFilterPendingRecords = 1,
1714 adFilterAffectedRecords = 2,
1715 adFilterFetchedRecords = 3,
1716 adFilterPredicate = 4,
1717 adFilterConflictingRecords = 5
1718};
1719
1720enum __declspec(uuid("00000547-0000-0010-8000-00aa006d2ea4")) SearchDirectionEnum
1721{
1722 adSearchForward = 1,
1723 adSearchBackward = -1
1724};
1725
1726enum __declspec(uuid("00000548-0000-0010-8000-00aa006d2ea4")) PersistFormatEnum
1727{
1728 adPersistADTG = 0,
1729 adPersistXML = 1
1730};
1731
1732enum __declspec(uuid("00000549-0000-0010-8000-00aa006d2ea4")) StringFormatEnum
1733{
1734 adClipString = 2
1735};
1736
1737enum __declspec(uuid("00000520-0000-0010-8000-00aa006d2ea4")) ConnectPromptEnum
1738{
1739 adPromptAlways = 1,
1740 adPromptComplete = 2,
1741 adPromptCompleteRequired = 3,
1742 adPromptNever = 4
1743};
1744
1745enum __declspec(uuid("00000521-0000-0010-8000-00aa006d2ea4")) ConnectModeEnum
1746{
1747 adModeUnknown = 0,
1748 adModeRead = 1,
1749 adModeWrite = 2,
1750 adModeReadWrite = 3,
1751 adModeShareDenyRead = 4,
1752 adModeShareDenyWrite = 8,
1753 adModeShareExclusive = 12,
1754 adModeShareDenyNone = 16,
1755 adModeRecursive = 4194304
1756};
1757
1758enum __declspec(uuid("00000570-0000-0010-8000-00aa006d2ea4")) RecordCreateOptionsEnum
1759{
1760 adCreateCollection = 8192,
1761 adCreateStructDoc = 0x80000000,
1762 adCreateNonCollection = 0,
1763 adOpenIfExists = 33554432,
1764 adCreateOverwrite = 67108864,
1765 adFailIfNotExists = -1
1766};
1767
1768enum __declspec(uuid("00000571-0000-0010-8000-00aa006d2ea4")) RecordOpenOptionsEnum
1769{
1770 adOpenRecordUnspecified = -1,
1771 adOpenSource = 8388608,
1772 adOpenOutput = 8388608,
1773 adOpenAsync = 4096,
1774 adDelayFetchStream = 16384,
1775 adDelayFetchFields = 32768,
1776 adOpenExecuteCommand = 65536
1777};
1778
1779enum __declspec(uuid("00000523-0000-0010-8000-00aa006d2ea4")) IsolationLevelEnum
1780{
1781 adXactUnspecified = -1,
1782 adXactChaos = 16,
1783 adXactReadUncommitted = 256,
1784 adXactBrowse = 256,
1785 adXactCursorStability = 4096,
1786 adXactReadCommitted = 4096,
1787 adXactRepeatableRead = 65536,
1788 adXactSerializable = 1048576,
1789 adXactIsolated = 1048576
1790};
1791
1792enum __declspec(uuid("00000524-0000-0010-8000-00aa006d2ea4")) XactAttributeEnum
1793{
1794 adXactCommitRetaining = 131072,
1795 adXactAbortRetaining = 262144,
1796 adXactAsyncPhaseOne = 524288,
1797 adXactSyncPhaseOne = 1048576
1798};
1799
1800enum __declspec(uuid("00000529-0000-0010-8000-00aa006d2ea4")) PropertyAttributesEnum
1801{
1802 adPropNotSupported = 0,
1803 adPropRequired = 1,
1804 adPropOptional = 2,
1805 adPropRead = 512,
1806 adPropWrite = 1024
1807};
1808
1809enum __declspec(uuid("0000052a-0000-0010-8000-00aa006d2ea4")) ErrorValueEnum
1810{
1811 adErrProviderFailed = 3000,
1812 adErrInvalidArgument = 3001,
1813 adErrOpeningFile = 3002,
1814 adErrReadFile = 3003,
1815 adErrWriteFile = 3004,
1816 adErrNoCurrentRecord = 3021,
1817 adErrIllegalOperation = 3219,
1818 adErrCantChangeProvider = 3220,
1819 adErrInTransaction = 3246,
1820 adErrFeatureNotAvailable = 3251,
1821 adErrItemNotFound = 3265,
1822 adErrObjectInCollection = 3367,
1823 adErrObjectNotSet = 3420,
1824 adErrDataConversion = 3421,
1825 adErrObjectClosed = 3704,
1826 adErrObjectOpen = 3705,
1827 adErrProviderNotFound = 3706,
1828 adErrBoundToCommand = 3707,
1829 adErrInvalidParamInfo = 3708,
1830 adErrInvalidConnection = 3709,
1831 adErrNotReentrant = 3710,
1832 adErrStillExecuting = 3711,
1833 adErrOperationCancelled = 3712,
1834 adErrStillConnecting = 3713,
1835 adErrInvalidTransaction = 3714,
1836 adErrNotExecuting = 3715,
1837 adErrUnsafeOperation = 3716,
1838 adwrnSecurityDialog = 3717,
1839 adwrnSecurityDialogHeader = 3718,
1840 adErrIntegrityViolation = 3719,
1841 adErrPermissionDenied = 3720,
1842 adErrDataOverflow = 3721,
1843 adErrSchemaViolation = 3722,
1844 adErrSignMismatch = 3723,
1845 adErrCantConvertvalue = 3724,
1846 adErrCantCreate = 3725,
1847 adErrColumnNotOnThisRow = 3726,
1848 adErrURLDoesNotExist = 3727,
1849 adErrTreePermissionDenied = 3728,
1850 adErrInvalidURL = 3729,
1851 adErrResourceLocked = 3730,
1852 adErrResourceExists = 3731,
1853 adErrCannotComplete = 3732,
1854 adErrVolumeNotFound = 3733,
1855 adErrOutOfSpace = 3734,
1856 adErrResourceOutOfScope = 3735,
1857 adErrUnavailable = 3736,
1858 adErrURLNamedRowDoesNotExist = 3737,
1859 adErrDelResOutOfScope = 3738,
1860 adErrPropInvalidColumn = 3739,
1861 adErrPropInvalidOption = 3740,
1862 adErrPropInvalidValue = 3741,
1863 adErrPropConflicting = 3742,
1864 adErrPropNotAllSettable = 3743,
1865 adErrPropNotSet = 3744,
1866 adErrPropNotSettable = 3745,
1867 adErrPropNotSupported = 3746,
1868 adErrCatalogNotSet = 3747,
1869 adErrCantChangeConnection = 3748,
1870 adErrFieldsUpdateFailed = 3749,
1871 adErrDenyNotSupported = 3750,
1872 adErrDenyTypeNotSupported = 3751,
1873 adErrProviderNotSpecified = 3753,
1874 adErrConnectionStringTooLong = 3754
1875};
1876
1877enum __declspec(uuid("0000052b-0000-0010-8000-00aa006d2ea4")) ParameterAttributesEnum
1878{
1879 adParamSigned = 16,
1880 adParamNullable = 64,
1881 adParamLong = 128
1882};
1883
1884enum __declspec(uuid("0000052c-0000-0010-8000-00aa006d2ea4")) ParameterDirectionEnum
1885{
1886 adParamUnknown = 0,
1887 adParamInput = 1,
1888 adParamOutput = 2,
1889 adParamInputOutput = 3,
1890 adParamReturnValue = 4
1891};
1892
1893enum __declspec(uuid("0000052e-0000-0010-8000-00aa006d2ea4")) CommandTypeEnum
1894{
1895 adCmdUnspecified = -1,
1896 adCmdUnknown = 8,
1897 adCmdText = 1,
1898 adCmdTable = 2,
1899 adCmdStoredProc = 4,
1900 adCmdFile = 256,
1901 adCmdTableDirect = 512
1902};
1903
1904enum __declspec(uuid("00000530-0000-0010-8000-00aa006d2ea4")) EventStatusEnum
1905{
1906 adStatusOK = 1,
1907 adStatusErrorsOccurred = 2,
1908 adStatusCantDeny = 3,
1909 adStatusCancel = 4,
1910 adStatusUnwantedEvent = 5
1911};
1912
1913enum __declspec(uuid("00000531-0000-0010-8000-00aa006d2ea4")) EventReasonEnum
1914{
1915 adRsnAddNew = 1,
1916 adRsnDelete = 2,
1917 adRsnUpdate = 3,
1918 adRsnUndoUpdate = 4,
1919 adRsnUndoAddNew = 5,
1920 adRsnUndoDelete = 6,
1921 adRsnRequery = 7,
1922 adRsnResynch = 8,
1923 adRsnClose = 9,
1924 adRsnMove = 10,
1925 adRsnFirstChange = 11,
1926 adRsnMoveFirst = 12,
1927 adRsnMoveNext = 13,
1928 adRsnMovePrevious = 14,
1929 adRsnMoveLast = 15
1930};
1931
1932enum __declspec(uuid("00000533-0000-0010-8000-00aa006d2ea4")) SchemaEnum
1933{
1934 adSchemaProviderSpecific = -1,
1935 adSchemaAsserts = 0,
1936 adSchemaCatalogs = 1,
1937 adSchemaCharacterSets = 2,
1938 adSchemaCollations = 3,
1939 adSchemaColumns = 4,
1940 adSchemaCheckConstraints = 5,
1941 adSchemaConstraintColumnUsage = 6,
1942 adSchemaConstraintTableUsage = 7,
1943 adSchemaKeyColumnUsage = 8,
1944 adSchemaReferentialContraints = 9,
1945 adSchemaReferentialConstraints = 9,
1946 adSchemaTableConstraints = 10,
1947 adSchemaColumnsDomainUsage = 11,
1948 adSchemaIndexes = 12,
1949 adSchemaColumnPrivileges = 13,
1950 adSchemaTablePrivileges = 14,
1951 adSchemaUsagePrivileges = 15,
1952 adSchemaProcedures = 16,
1953 adSchemaSchemata = 17,
1954 adSchemaSQLLanguages = 18,
1955 adSchemaStatistics = 19,
1956 adSchemaTables = 20,
1957 adSchemaTranslations = 21,
1958 adSchemaProviderTypes = 22,
1959 adSchemaViews = 23,
1960 adSchemaViewColumnUsage = 24,
1961 adSchemaViewTableUsage = 25,
1962 adSchemaProcedureParameters = 26,
1963 adSchemaForeignKeys = 27,
1964 adSchemaPrimaryKeys = 28,
1965 adSchemaProcedureColumns = 29,
1966 adSchemaDBInfoKeywords = 30,
1967 adSchemaDBInfoLiterals = 31,
1968 adSchemaCubes = 32,
1969 adSchemaDimensions = 33,
1970 adSchemaHierarchies = 34,
1971 adSchemaLevels = 35,
1972 adSchemaMeasures = 36,
1973 adSchemaProperties = 37,
1974 adSchemaMembers = 38,
1975 adSchemaTrustees = 39,
1976 adSchemaFunctions = 40,
1977 adSchemaActions = 41,
1978 adSchemaCommands = 42,
1979 adSchemaSets = 43
1980};
1981
1982enum __declspec(uuid("0000057e-0000-0010-8000-00aa006d2ea4")) FieldStatusEnum
1983{
1984 adFieldOK = 0,
1985 adFieldCantConvertValue = 2,
1986 adFieldIsNull = 3,
1987 adFieldTruncated = 4,
1988 adFieldSignMismatch = 5,
1989 adFieldDataOverflow = 6,
1990 adFieldCantCreate = 7,
1991 adFieldUnavailable = 8,
1992 adFieldPermissionDenied = 9,
1993 adFieldIntegrityViolation = 10,
1994 adFieldSchemaViolation = 11,
1995 adFieldBadStatus = 12,
1996 adFieldDefault = 13,
1997 adFieldIgnore = 15,
1998 adFieldDoesNotExist = 16,
1999 adFieldInvalidURL = 17,
2000 adFieldResourceLocked = 18,
2001 adFieldResourceExists = 19,
2002 adFieldCannotComplete = 20,
2003 adFieldVolumeNotFound = 21,
2004 adFieldOutOfSpace = 22,
2005 adFieldCannotDeleteSource = 23,
2006 adFieldReadOnly = 24,
2007 adFieldResourceOutOfScope = 25,
2008 adFieldAlreadyExists = 26,
2009 adFieldPendingInsert = 65536,
2010 adFieldPendingDelete = 131072,
2011 adFieldPendingChange = 262144,
2012 adFieldPendingUnknown = 524288,
2013 adFieldPendingUnknownDelete = 1048576
2014};
2015
2016enum __declspec(uuid("00000552-0000-0010-8000-00aa006d2ea4")) SeekEnum
2017{
2018 adSeekFirstEQ = 1,
2019 adSeekLastEQ = 2,
2020 adSeekAfterEQ = 4,
2021 adSeekAfter = 8,
2022 adSeekBeforeEQ = 16,
2023 adSeekBefore = 32
2024};
2025
2026enum __declspec(uuid("0000054a-0000-0010-8000-00aa006d2ea4")) ADCPROP_UPDATECRITERIA_ENUM
2027{
2028 adCriteriaKey = 0,
2029 adCriteriaAllCols = 1,
2030 adCriteriaUpdCols = 2,
2031 adCriteriaTimeStamp = 3
2032};
2033
2034enum __declspec(uuid("0000054b-0000-0010-8000-00aa006d2ea4")) ADCPROP_ASYNCTHREADPRIORITY_ENUM
2035{
2036 adPriorityLowest = 1,
2037 adPriorityBelowNormal = 2,
2038 adPriorityNormal = 3,
2039 adPriorityAboveNormal = 4,
2040 adPriorityHighest = 5
2041};
2042
2043enum __declspec(uuid("00000554-0000-0010-8000-00aa006d2ea4")) ADCPROP_AUTORECALC_ENUM
2044{
2045 adRecalcUpFront = 0,
2046 adRecalcAlways = 1
2047};
2048
2049enum __declspec(uuid("00000553-0000-0010-8000-00aa006d2ea4")) ADCPROP_UPDATERESYNC_ENUM
2050{
2051 adResyncNone = 0,
2052 adResyncAutoIncrement = 1,
2053 adResyncConflicts = 2,
2054 adResyncUpdates = 4,
2055 adResyncInserts = 8,
2056 adResyncAll = 15
2057};
2058
2059enum __declspec(uuid("00000573-0000-0010-8000-00aa006d2ea4")) MoveRecordOptionsEnum
2060{
2061 adMoveUnspecified = -1,
2062 adMoveOverWrite = 1,
2063 adMoveDontUpdateLinks = 2,
2064 adMoveAllowEmulation = 4
2065};
2066
2067enum __declspec(uuid("00000574-0000-0010-8000-00aa006d2ea4")) CopyRecordOptionsEnum
2068{
2069 adCopyUnspecified = -1,
2070 adCopyOverWrite = 1,
2071 adCopyAllowEmulation = 4,
2072 adCopyNonRecursive = 2
2073};
2074
2075enum __declspec(uuid("00000576-0000-0010-8000-00aa006d2ea4")) StreamTypeEnum
2076{
2077 adTypeBinary = 1,
2078 adTypeText = 2
2079};
2080
2081enum __declspec(uuid("00000577-0000-0010-8000-00aa006d2ea4")) LineSeparatorEnum
2082{
2083 adLF = 10,
2084 adCR = 13,
2085 adCRLF = -1
2086};
2087
2088enum __declspec(uuid("0000057a-0000-0010-8000-00aa006d2ea4")) StreamOpenOptionsEnum
2089{
2090 adOpenStreamUnspecified = -1,
2091 adOpenStreamAsync = 1,
2092 adOpenStreamFromRecord = 4
2093};
2094
2095enum __declspec(uuid("0000057b-0000-0010-8000-00aa006d2ea4")) StreamWriteEnum
2096{
2097 adWriteChar = 0,
2098 adWriteLine = 1,
2099 stWriteChar = 0,
2100 stWriteLine = 1
2101};
2102
2103enum __declspec(uuid("0000057c-0000-0010-8000-00aa006d2ea4")) SaveOptionsEnum
2104{
2105 adSaveCreateNotExist = 1,
2106 adSaveCreateOverWrite = 2
2107};
2108
2109enum FieldEnum
2110{
2111 adDefaultStream = -1,
2112 adRecordURL = -2
2113};
2114
2115enum StreamReadEnum
2116{
2117 adReadAll = -1,
2118 adReadLine = -2
2119};
2120
2121enum __declspec(uuid("0000057d-0000-0010-8000-00aa006d2ea4")) RecordTypeEnum
2122{
2123 adSimpleRecord = 0,
2124 adCollectionRecord = 1,
2125 adStructDoc = 2
2126};
2127
2128struct __declspec(uuid("00000512-0000-0010-8000-00aa006d2ea4")) _Collection : IDispatch
2129{
2130 //
2131 // Property data
2132 //
2133
2134 __declspec(property(get = GetCount)) long Count;
2135
2136 //
2137 // Wrapper methods for error-handling
2138 //
2139
2140 long GetCount();
2141 IUnknownPtr _NewEnum();
2142 HRESULT Refresh();
2143
2144 //
2145 // Raw methods provided by interface
2146 //
2147
2148 virtual HRESULT __stdcall get_Count(
2149 /*[out,retval]*/ long* c) = 0;
2150 virtual HRESULT __stdcall raw__NewEnum(
2151 /*[out,retval]*/ IUnknown** ppvObject) = 0;
2152 virtual HRESULT __stdcall raw_Refresh() = 0;
2153};
2154
2155struct __declspec(uuid("00000513-0000-0010-8000-00aa006d2ea4")) _DynaCollection : _Collection
2156{
2157 //
2158 // Wrapper methods for error-handling
2159 //
2160
2161 HRESULT Append(IDispatch* Object);
2162 HRESULT Delete(const _variant_t& Index);
2163
2164 //
2165 // Raw methods provided by interface
2166 //
2167
2168 virtual HRESULT __stdcall raw_Append(
2169 /*[in]*/ IDispatch* Object) = 0;
2170 virtual HRESULT __stdcall raw_Delete(
2171 /*[in]*/ VARIANT Index) = 0;
2172};
2173
2174struct __declspec(uuid("00000503-0000-0010-8000-00aa006d2ea4")) Property : IDispatch
2175{
2176 //
2177 // Property data
2178 //
2179
2180 __declspec(property(get = GetValue, put = PutValue)) _variant_t Value;
2181 __declspec(property(get = GetName)) _bstr_t Name;
2182 __declspec(property(get = GetType)) enum DataTypeEnum Type;
2183 __declspec(property(get = GetAttributes, put = PutAttributes)) long Attributes;
2184
2185 //
2186 // Wrapper methods for error-handling
2187 //
2188
2189 _variant_t GetValue();
2190 void PutValue(const _variant_t& pval);
2191 _bstr_t GetName();
2192 enum DataTypeEnum GetType();
2193 long GetAttributes();
2194 void PutAttributes(long plAttributes);
2195
2196 //
2197 // Raw methods provided by interface
2198 //
2199
2200 virtual HRESULT __stdcall get_Value(
2201 /*[out,retval]*/ VARIANT* pval) = 0;
2202 virtual HRESULT __stdcall put_Value(
2203 /*[in]*/ VARIANT pval) = 0;
2204 virtual HRESULT __stdcall get_Name(
2205 /*[out,retval]*/ BSTR* pbstr) = 0;
2206 virtual HRESULT __stdcall get_Type(
2207 /*[out,retval]*/ enum DataTypeEnum* ptype) = 0;
2208 virtual HRESULT __stdcall get_Attributes(
2209 /*[out,retval]*/ long* plAttributes) = 0;
2210 virtual HRESULT __stdcall put_Attributes(
2211 /*[in]*/ long plAttributes) = 0;
2212};
2213
2214struct __declspec(uuid("00000504-0000-0010-8000-00aa006d2ea4")) Properties : _Collection
2215{
2216 //
2217 // Property data
2218 //
2219
2220 __declspec(property(get = GetItem)) PropertyPtr Item[];
2221
2222 //
2223 // Wrapper methods for error-handling
2224 //
2225
2226 PropertyPtr GetItem(const _variant_t& Index);
2227
2228 //
2229 // Raw methods provided by interface
2230 //
2231
2232 virtual HRESULT __stdcall get_Item(
2233 /*[in]*/ VARIANT Index,
2234 /*[out,retval]*/ struct Property** ppvObject) = 0;
2235};
2236
2237struct __declspec(uuid("00000534-0000-0010-8000-00aa006d2ea4")) _ADO : IDispatch
2238{
2239 //
2240 // Property data
2241 //
2242
2243 __declspec(property(get = GetProperties)) PropertiesPtr Properties;
2244
2245 //
2246 // Wrapper methods for error-handling
2247 //
2248
2249 PropertiesPtr GetProperties();
2250
2251 //
2252 // Raw methods provided by interface
2253 //
2254
2255 virtual HRESULT __stdcall get_Properties(
2256 /*[out,retval]*/ struct Properties** ppvObject) = 0;
2257};
2258
2259struct __declspec(uuid("00000500-0000-0010-8000-00aa006d2ea4")) Error : IDispatch
2260{
2261 //
2262 // Property data
2263 //
2264
2265 __declspec(property(get = GetDescription)) _bstr_t Description;
2266 __declspec(property(get = GetNumber)) long Number;
2267 __declspec(property(get = GetSource)) _bstr_t Source;
2268 __declspec(property(get = GetHelpFile)) _bstr_t HelpFile;
2269 __declspec(property(get = GetHelpContext)) long HelpContext;
2270 __declspec(property(get = GetSQLState)) _bstr_t SQLState;
2271 __declspec(property(get = GetNativeError)) long NativeError;
2272
2273 //
2274 // Wrapper methods for error-handling
2275 //
2276
2277 long GetNumber();
2278 _bstr_t GetSource();
2279 _bstr_t GetDescription();
2280 _bstr_t GetHelpFile();
2281 long GetHelpContext();
2282 _bstr_t GetSQLState();
2283 long GetNativeError();
2284
2285 //
2286 // Raw methods provided by interface
2287 //
2288
2289 virtual HRESULT __stdcall get_Number(
2290 /*[out,retval]*/ long* pl) = 0;
2291 virtual HRESULT __stdcall get_Source(
2292 /*[out,retval]*/ BSTR* pbstr) = 0;
2293 virtual HRESULT __stdcall get_Description(
2294 /*[out,retval]*/ BSTR* pbstr) = 0;
2295 virtual HRESULT __stdcall get_HelpFile(
2296 /*[out,retval]*/ BSTR* pbstr) = 0;
2297 virtual HRESULT __stdcall get_HelpContext(
2298 /*[out,retval]*/ long* pl) = 0;
2299 virtual HRESULT __stdcall get_SQLState(
2300 /*[out,retval]*/ BSTR* pbstr) = 0;
2301 virtual HRESULT __stdcall get_NativeError(
2302 /*[out,retval]*/ long* pl) = 0;
2303};
2304
2305struct __declspec(uuid("00000501-0000-0010-8000-00aa006d2ea4")) Errors : _Collection
2306{
2307 //
2308 // Property data
2309 //
2310
2311 __declspec(property(get = GetItem)) ErrorPtr Item[];
2312
2313 //
2314 // Wrapper methods for error-handling
2315 //
2316
2317 ErrorPtr GetItem(const _variant_t& Index);
2318 HRESULT Clear();
2319
2320 //
2321 // Raw methods provided by interface
2322 //
2323
2324 virtual HRESULT __stdcall get_Item(
2325 /*[in]*/ VARIANT Index,
2326 /*[out,retval]*/ struct Error** ppvObject) = 0;
2327 virtual HRESULT __stdcall raw_Clear() = 0;
2328};
2329
2330struct __declspec(uuid("0000154c-0000-0010-8000-00aa006d2ea4")) Field20 : _ADO
2331{
2332 //
2333 // Property data
2334 //
2335
2336 __declspec(property(get = GetValue, put = PutValue)) _variant_t Value;
2337 __declspec(property(get = GetName)) _bstr_t Name;
2338 __declspec(property(get = GetType, put = PutType)) enum DataTypeEnum Type;
2339 __declspec(property(get = GetDefinedSize, put = PutDefinedSize)) long DefinedSize;
2340 __declspec(property(get = GetOriginalValue)) _variant_t OriginalValue;
2341 __declspec(property(get = GetUnderlyingValue)) _variant_t UnderlyingValue;
2342 __declspec(property(get = GetActualSize)) long ActualSize;
2343 __declspec(property(get = GetPrecision, put = PutPrecision)) unsigned char Precision;
2344 __declspec(property(get = GetNumericScale, put = PutNumericScale)) unsigned char NumericScale;
2345 __declspec(property(get = GetAttributes, put = PutAttributes)) long Attributes;
2346 __declspec(property(get = GetDataFormat, put = PutRefDataFormat)) IUnknownPtr DataFormat;
2347
2348 //
2349 // Wrapper methods for error-handling
2350 //
2351
2352 long GetActualSize();
2353 long GetAttributes();
2354 long GetDefinedSize();
2355 _bstr_t GetName();
2356 enum DataTypeEnum GetType();
2357 _variant_t GetValue();
2358 void PutValue(const _variant_t& pvar);
2359 unsigned char GetPrecision();
2360 unsigned char GetNumericScale();
2361 HRESULT AppendChunk(const _variant_t& Data);
2362 _variant_t GetChunk(long Length);
2363 _variant_t GetOriginalValue();
2364 _variant_t GetUnderlyingValue();
2365 IUnknownPtr GetDataFormat();
2366 void PutRefDataFormat(IUnknown* ppiDF);
2367 void PutPrecision(unsigned char pbPrecision);
2368 void PutNumericScale(unsigned char pbNumericScale);
2369 void PutType(enum DataTypeEnum pDataType);
2370 void PutDefinedSize(long pl);
2371 void PutAttributes(long pl);
2372
2373 //
2374 // Raw methods provided by interface
2375 //
2376
2377 virtual HRESULT __stdcall get_ActualSize(
2378 /*[out,retval]*/ long* pl) = 0;
2379 virtual HRESULT __stdcall get_Attributes(
2380 /*[out,retval]*/ long* pl) = 0;
2381 virtual HRESULT __stdcall get_DefinedSize(
2382 /*[out,retval]*/ long* pl) = 0;
2383 virtual HRESULT __stdcall get_Name(
2384 /*[out,retval]*/ BSTR* pbstr) = 0;
2385 virtual HRESULT __stdcall get_Type(
2386 /*[out,retval]*/ enum DataTypeEnum* pDataType) = 0;
2387 virtual HRESULT __stdcall get_Value(
2388 /*[out,retval]*/ VARIANT* pvar) = 0;
2389 virtual HRESULT __stdcall put_Value(
2390 /*[in]*/ VARIANT pvar) = 0;
2391 virtual HRESULT __stdcall get_Precision(
2392 /*[out,retval]*/ unsigned char* pbPrecision) = 0;
2393 virtual HRESULT __stdcall get_NumericScale(
2394 /*[out,retval]*/ unsigned char* pbNumericScale) = 0;
2395 virtual HRESULT __stdcall raw_AppendChunk(
2396 /*[in]*/ VARIANT Data) = 0;
2397 virtual HRESULT __stdcall raw_GetChunk(
2398 /*[in]*/ long Length,
2399 /*[out,retval]*/ VARIANT* pvar) = 0;
2400 virtual HRESULT __stdcall get_OriginalValue(
2401 /*[out,retval]*/ VARIANT* pvar) = 0;
2402 virtual HRESULT __stdcall get_UnderlyingValue(
2403 /*[out,retval]*/ VARIANT* pvar) = 0;
2404 virtual HRESULT __stdcall get_DataFormat(
2405 /*[out,retval]*/ IUnknown** ppiDF) = 0;
2406 virtual HRESULT __stdcall putref_DataFormat(
2407 /*[in]*/ IUnknown* ppiDF) = 0;
2408 virtual HRESULT __stdcall put_Precision(
2409 /*[in]*/ unsigned char pbPrecision) = 0;
2410 virtual HRESULT __stdcall put_NumericScale(
2411 /*[in]*/ unsigned char pbNumericScale) = 0;
2412 virtual HRESULT __stdcall put_Type(
2413 /*[in]*/ enum DataTypeEnum pDataType) = 0;
2414 virtual HRESULT __stdcall put_DefinedSize(
2415 /*[in]*/ long pl) = 0;
2416 virtual HRESULT __stdcall put_Attributes(
2417 /*[in]*/ long pl) = 0;
2418};
2419
2420struct __declspec(uuid("00001569-0000-0010-8000-00aa006d2ea4")) Field : Field20
2421{
2422 //
2423 // Property data
2424 //
2425
2426 __declspec(property(get = GetStatus)) long Status;
2427
2428 //
2429 // Wrapper methods for error-handling
2430 //
2431
2432 long GetStatus();
2433
2434 //
2435 // Raw methods provided by interface
2436 //
2437
2438 virtual HRESULT __stdcall get_Status(
2439 /*[out,retval]*/ long* pFStatus) = 0;
2440};
2441
2442struct __declspec(uuid("00001506-0000-0010-8000-00aa006d2ea4")) Fields15 : _Collection
2443{
2444 //
2445 // Property data
2446 //
2447
2448 __declspec(property(get = GetItem)) FieldPtr Item[];
2449
2450 //
2451 // Wrapper methods for error-handling
2452 //
2453
2454 FieldPtr GetItem(const _variant_t& Index);
2455
2456 //
2457 // Raw methods provided by interface
2458 //
2459
2460 virtual HRESULT __stdcall get_Item(
2461 /*[in]*/ VARIANT Index,
2462 /*[out,retval]*/ struct Field** ppvObject) = 0;
2463};
2464
2465struct __declspec(uuid("0000154d-0000-0010-8000-00aa006d2ea4")) Fields20 : Fields15
2466{
2467 //
2468 // Wrapper methods for error-handling
2469 //
2470
2471 HRESULT _Append(_bstr_t Name, enum DataTypeEnum Type, long DefinedSize,
2472 enum FieldAttributeEnum Attrib);
2473 HRESULT Delete(const _variant_t& Index);
2474
2475 //
2476 // Raw methods provided by interface
2477 //
2478
2479 virtual HRESULT __stdcall raw__Append(
2480 /*[in]*/ BSTR Name,
2481 /*[in]*/ enum DataTypeEnum Type,
2482 /*[in]*/ long DefinedSize,
2483 /*[in]*/ enum FieldAttributeEnum Attrib) = 0;
2484 virtual HRESULT __stdcall raw_Delete(
2485 /*[in]*/ VARIANT Index) = 0;
2486};
2487
2488struct __declspec(uuid("00001564-0000-0010-8000-00aa006d2ea4")) Fields : Fields20
2489{
2490 //
2491 // Wrapper methods for error-handling
2492 //
2493
2494 HRESULT Append(_bstr_t Name, enum DataTypeEnum Type, long DefinedSize,
2495 enum FieldAttributeEnum Attrib, const _variant_t& FieldValue = vtMissing);
2496 HRESULT Update();
2497 HRESULT Resync(enum ResyncEnum ResyncValues);
2498 HRESULT CancelUpdate();
2499
2500 //
2501 // Raw methods provided by interface
2502 //
2503
2504 virtual HRESULT __stdcall raw_Append(
2505 /*[in]*/ BSTR Name,
2506 /*[in]*/ enum DataTypeEnum Type,
2507 /*[in]*/ long DefinedSize,
2508 /*[in]*/ enum FieldAttributeEnum Attrib,
2509 /*[in]*/ VARIANT FieldValue = vtMissing) = 0;
2510 virtual HRESULT __stdcall raw_Update() = 0;
2511 virtual HRESULT __stdcall raw_Resync(
2512 /*[in]*/ enum ResyncEnum ResyncValues) = 0;
2513 virtual HRESULT __stdcall raw_CancelUpdate() = 0;
2514};
2515
2516struct __declspec(uuid("0000150c-0000-0010-8000-00aa006d2ea4")) _Parameter : _ADO
2517{
2518 //
2519 // Property data
2520 //
2521
2522 __declspec(property(get = GetValue, put = PutValue)) _variant_t Value;
2523 __declspec(property(get = GetName, put = PutName)) _bstr_t Name;
2524 __declspec(property(get = GetType, put = PutType)) enum DataTypeEnum Type;
2525 __declspec(property(get = GetDirection,
2526 put = PutDirection)) enum ParameterDirectionEnum Direction;
2527 __declspec(property(get = GetPrecision, put = PutPrecision)) unsigned char Precision;
2528 __declspec(property(get = GetNumericScale, put = PutNumericScale)) unsigned char NumericScale;
2529 __declspec(property(get = GetSize, put = PutSize)) long Size;
2530 __declspec(property(get = GetAttributes, put = PutAttributes)) long Attributes;
2531
2532 //
2533 // Wrapper methods for error-handling
2534 //
2535
2536 _bstr_t GetName();
2537 void PutName(_bstr_t pbstr);
2538 _variant_t GetValue();
2539 void PutValue(const _variant_t& pvar);
2540 enum DataTypeEnum GetType();
2541 void PutType(enum DataTypeEnum psDataType);
2542 void PutDirection(enum ParameterDirectionEnum plParmDirection);
2543 enum ParameterDirectionEnum GetDirection();
2544 void PutPrecision(unsigned char pbPrecision);
2545 unsigned char GetPrecision();
2546 void PutNumericScale(unsigned char pbScale);
2547 unsigned char GetNumericScale();
2548 void PutSize(long pl);
2549 long GetSize();
2550 HRESULT AppendChunk(const _variant_t& Val);
2551 long GetAttributes();
2552 void PutAttributes(long plParmAttribs);
2553
2554 //
2555 // Raw methods provided by interface
2556 //
2557
2558 virtual HRESULT __stdcall get_Name(
2559 /*[out,retval]*/ BSTR* pbstr) = 0;
2560 virtual HRESULT __stdcall put_Name(
2561 /*[in]*/ BSTR pbstr) = 0;
2562 virtual HRESULT __stdcall get_Value(
2563 /*[out,retval]*/ VARIANT* pvar) = 0;
2564 virtual HRESULT __stdcall put_Value(
2565 /*[in]*/ VARIANT pvar) = 0;
2566 virtual HRESULT __stdcall get_Type(
2567 /*[out,retval]*/ enum DataTypeEnum* psDataType) = 0;
2568 virtual HRESULT __stdcall put_Type(
2569 /*[in]*/ enum DataTypeEnum psDataType) = 0;
2570 virtual HRESULT __stdcall put_Direction(
2571 /*[in]*/ enum ParameterDirectionEnum plParmDirection) = 0;
2572 virtual HRESULT __stdcall get_Direction(
2573 /*[out,retval]*/ enum ParameterDirectionEnum* plParmDirection) = 0;
2574 virtual HRESULT __stdcall put_Precision(
2575 /*[in]*/ unsigned char pbPrecision) = 0;
2576 virtual HRESULT __stdcall get_Precision(
2577 /*[out,retval]*/ unsigned char* pbPrecision) = 0;
2578 virtual HRESULT __stdcall put_NumericScale(
2579 /*[in]*/ unsigned char pbScale) = 0;
2580 virtual HRESULT __stdcall get_NumericScale(
2581 /*[out,retval]*/ unsigned char* pbScale) = 0;
2582 virtual HRESULT __stdcall put_Size(
2583 /*[in]*/ long pl) = 0;
2584 virtual HRESULT __stdcall get_Size(
2585 /*[out,retval]*/ long* pl) = 0;
2586 virtual HRESULT __stdcall raw_AppendChunk(
2587 /*[in]*/ VARIANT Val) = 0;
2588 virtual HRESULT __stdcall get_Attributes(
2589 /*[out,retval]*/ long* plParmAttribs) = 0;
2590 virtual HRESULT __stdcall put_Attributes(
2591 /*[in]*/ long plParmAttribs) = 0;
2592};
2593
2594struct __declspec(uuid("0000150d-0000-0010-8000-00aa006d2ea4")) Parameters : _DynaCollection
2595{
2596 //
2597 // Property data
2598 //
2599
2600 __declspec(property(get = GetItem)) _ParameterPtr Item[];
2601
2602 //
2603 // Wrapper methods for error-handling
2604 //
2605
2606 _ParameterPtr GetItem(const _variant_t& Index);
2607
2608 //
2609 // Raw methods provided by interface
2610 //
2611
2612 virtual HRESULT __stdcall get_Item(
2613 /*[in]*/ VARIANT Index,
2614 /*[out,retval]*/ struct _Parameter** ppvObject) = 0;
2615};
2616
2617struct __declspec(uuid("00001400-0000-0010-8000-00aa006d2ea4")) ConnectionEvents : IDispatch
2618{
2619 //
2620 // Wrapper methods for error-handling
2621 //
2622
2623 // Methods:
2624 HRESULT InfoMessage(struct Error* pError, enum EventStatusEnum* adStatus,
2625 struct _Connection* pConnection);
2626 HRESULT BeginTransComplete(long TransactionLevel, struct Error* pError,
2627 enum EventStatusEnum* adStatus, struct _Connection* pConnection);
2628 HRESULT CommitTransComplete(struct Error* pError, enum EventStatusEnum* adStatus,
2629 struct _Connection* pConnection);
2630 HRESULT RollbackTransComplete(struct Error* pError, enum EventStatusEnum* adStatus,
2631 struct _Connection* pConnection);
2632 HRESULT WillExecute(BSTR* Source, enum CursorTypeEnum* CursorType, enum LockTypeEnum* LockType,
2633 long* Options, enum EventStatusEnum* adStatus, struct _Command* pCommand,
2634 struct _Recordset* pRecordset, struct _Connection* pConnection);
2635 HRESULT ExecuteComplete(long RecordsAffected, struct Error* pError,
2636 enum EventStatusEnum* adStatus, struct _Command* pCommand,
2637 struct _Recordset* pRecordset, struct _Connection* pConnection);
2638 HRESULT WillConnect(BSTR* ConnectionString, BSTR* UserID, BSTR* Password, long* Options,
2639 enum EventStatusEnum* adStatus, struct _Connection* pConnection);
2640 HRESULT ConnectComplete(struct Error* pError, enum EventStatusEnum* adStatus,
2641 struct _Connection* pConnection);
2642 HRESULT Disconnect(enum EventStatusEnum* adStatus, struct _Connection* pConnection);
2643};
2644
2645struct __declspec(uuid("00001266-0000-0010-8000-00aa006d2ea4")) RecordsetEvents : IDispatch
2646{
2647 //
2648 // Wrapper methods for error-handling
2649 //
2650
2651 // Methods:
2652 HRESULT WillChangeField(long cFields, const _variant_t& Fields, enum EventStatusEnum* adStatus,
2653 struct _Recordset* pRecordset);
2654 HRESULT FieldChangeComplete(long cFields, const _variant_t& Fields, struct Error* pError,
2655 enum EventStatusEnum* adStatus, struct _Recordset* pRecordset);
2656 HRESULT WillChangeRecord(enum EventReasonEnum adReason, long cRecords,
2657 enum EventStatusEnum* adStatus, struct _Recordset* pRecordset);
2658 HRESULT RecordChangeComplete(enum EventReasonEnum adReason, long cRecords, struct Error* pError,
2659 enum EventStatusEnum* adStatus, struct _Recordset* pRecordset);
2660 HRESULT WillChangeRecordset(enum EventReasonEnum adReason, enum EventStatusEnum* adStatus,
2661 struct _Recordset* pRecordset);
2662 HRESULT RecordsetChangeComplete(enum EventReasonEnum adReason, struct Error* pError,
2663 enum EventStatusEnum* adStatus, struct _Recordset* pRecordset);
2664 HRESULT WillMove(enum EventReasonEnum adReason, enum EventStatusEnum* adStatus,
2665 struct _Recordset* pRecordset);
2666 HRESULT MoveComplete(enum EventReasonEnum adReason, struct Error* pError,
2667 enum EventStatusEnum* adStatus, struct _Recordset* pRecordset);
2668 HRESULT EndOfRecordset(VARIANT_BOOL* fMoreData, enum EventStatusEnum* adStatus,
2669 struct _Recordset* pRecordset);
2670 HRESULT FetchProgress(long Progress, long MaxProgress, enum EventStatusEnum* adStatus,
2671 struct _Recordset* pRecordset);
2672 HRESULT FetchComplete(struct Error* pError, enum EventStatusEnum* adStatus,
2673 struct _Recordset* pRecordset);
2674};
2675
2676struct __declspec(uuid("00000516-0000-0010-8000-00aa006d2ea4")) ADOConnectionConstruction15
2677 : IUnknown
2678{
2679 //
2680 // Property data
2681 //
2682
2683 __declspec(property(get = GetDSO)) IUnknownPtr DSO;
2684 __declspec(property(get = GetSession)) IUnknownPtr Session;
2685
2686 //
2687 // Wrapper methods for error-handling
2688 //
2689
2690 IUnknownPtr GetDSO();
2691 IUnknownPtr GetSession();
2692 HRESULT WrapDSOandSession(IUnknown* pDSO, IUnknown* pSession);
2693
2694 //
2695 // Raw methods provided by interface
2696 //
2697
2698 virtual HRESULT __stdcall get_DSO(
2699 /*[out,retval]*/ IUnknown** ppDSO) = 0;
2700 virtual HRESULT __stdcall get_Session(
2701 /*[out,retval]*/ IUnknown** ppSession) = 0;
2702 virtual HRESULT __stdcall raw_WrapDSOandSession(
2703 /*[in]*/ IUnknown* pDSO,
2704 /*[in]*/ IUnknown* pSession) = 0;
2705};
2706
2707struct __declspec(uuid("00000551-0000-0010-8000-00aa006d2ea4")) ADOConnectionConstruction
2708 : ADOConnectionConstruction15
2709{
2710};
2711
2712struct __declspec(uuid("00000514-0000-0010-8000-00aa006d2ea4")) Connection;
2713// [ default ] interface _Connection
2714// [ default, source ] dispinterface ConnectionEvents
2715
2716struct __declspec(uuid("00000560-0000-0010-8000-00aa006d2ea4")) Record;
2717// [ default ] interface _Record
2718
2719struct __declspec(uuid("00001565-0000-0010-8000-00aa006d2ea4")) _Stream : IDispatch
2720{
2721 //
2722 // Property data
2723 //
2724
2725 __declspec(property(get = GetSize)) long Size;
2726 __declspec(property(get = GetEOS)) VARIANT_BOOL EOS;
2727 __declspec(property(get = GetPosition, put = PutPosition)) long Position;
2728 __declspec(property(get = GetType, put = PutType)) enum StreamTypeEnum Type;
2729 __declspec(property(get = GetLineSeparator,
2730 put = PutLineSeparator)) enum LineSeparatorEnum LineSeparator;
2731 __declspec(property(get = GetState)) enum ObjectStateEnum State;
2732 __declspec(property(get = GetMode, put = PutMode)) enum ConnectModeEnum Mode;
2733 __declspec(property(get = GetCharset, put = PutCharset)) _bstr_t Charset;
2734
2735 //
2736 // Wrapper methods for error-handling
2737 //
2738
2739 long GetSize();
2740 VARIANT_BOOL GetEOS();
2741 long GetPosition();
2742 void PutPosition(long pPos);
2743 enum StreamTypeEnum GetType();
2744 void PutType(enum StreamTypeEnum ptype);
2745 enum LineSeparatorEnum GetLineSeparator();
2746 void PutLineSeparator(enum LineSeparatorEnum pLS);
2747 enum ObjectStateEnum GetState();
2748 enum ConnectModeEnum GetMode();
2749 void PutMode(enum ConnectModeEnum pMode);
2750 _bstr_t GetCharset();
2751 void PutCharset(_bstr_t pbstrCharset);
2752 _variant_t Read(long NumBytes);
2753 HRESULT Open(const _variant_t& Source, enum ConnectModeEnum Mode,
2754 enum StreamOpenOptionsEnum Options, _bstr_t UserName, _bstr_t Password);
2755 HRESULT Close();
2756 HRESULT SkipLine();
2757 HRESULT Write(const _variant_t& Buffer);
2758 HRESULT SetEOS();
2759 HRESULT CopyTo(struct _Stream* DestStream, long CharNumber);
2760 HRESULT Flush();
2761 HRESULT SaveToFile(_bstr_t FileName, enum SaveOptionsEnum Options);
2762 HRESULT LoadFromFile(_bstr_t FileName);
2763 _bstr_t ReadText(long NumChars);
2764 HRESULT WriteText(_bstr_t Data, enum StreamWriteEnum Options);
2765 HRESULT Cancel();
2766
2767 //
2768 // Raw methods provided by interface
2769 //
2770
2771 virtual HRESULT __stdcall get_Size(
2772 /*[out,retval]*/ long* pSize) = 0;
2773 virtual HRESULT __stdcall get_EOS(
2774 /*[out,retval]*/ VARIANT_BOOL* pEOS) = 0;
2775 virtual HRESULT __stdcall get_Position(
2776 /*[out,retval]*/ long* pPos) = 0;
2777 virtual HRESULT __stdcall put_Position(
2778 /*[in]*/ long pPos) = 0;
2779 virtual HRESULT __stdcall get_Type(
2780 /*[out,retval]*/ enum StreamTypeEnum* ptype) = 0;
2781 virtual HRESULT __stdcall put_Type(
2782 /*[in]*/ enum StreamTypeEnum ptype) = 0;
2783 virtual HRESULT __stdcall get_LineSeparator(
2784 /*[out,retval]*/ enum LineSeparatorEnum* pLS) = 0;
2785 virtual HRESULT __stdcall put_LineSeparator(
2786 /*[in]*/ enum LineSeparatorEnum pLS) = 0;
2787 virtual HRESULT __stdcall get_State(
2788 /*[out,retval]*/ enum ObjectStateEnum* pState) = 0;
2789 virtual HRESULT __stdcall get_Mode(
2790 /*[out,retval]*/ enum ConnectModeEnum* pMode) = 0;
2791 virtual HRESULT __stdcall put_Mode(
2792 /*[in]*/ enum ConnectModeEnum pMode) = 0;
2793 virtual HRESULT __stdcall get_Charset(
2794 /*[out,retval]*/ BSTR* pbstrCharset) = 0;
2795 virtual HRESULT __stdcall put_Charset(
2796 /*[in]*/ BSTR pbstrCharset) = 0;
2797 virtual HRESULT __stdcall raw_Read(
2798 /*[in]*/ long NumBytes,
2799 /*[out,retval]*/ VARIANT* pval) = 0;
2800 virtual HRESULT __stdcall raw_Open(
2801 /*[in]*/ VARIANT Source,
2802 /*[in]*/ enum ConnectModeEnum Mode,
2803 /*[in]*/ enum StreamOpenOptionsEnum Options,
2804 /*[in]*/ BSTR UserName,
2805 /*[in]*/ BSTR Password) = 0;
2806 virtual HRESULT __stdcall raw_Close() = 0;
2807 virtual HRESULT __stdcall raw_SkipLine() = 0;
2808 virtual HRESULT __stdcall raw_Write(
2809 /*[in]*/ VARIANT Buffer) = 0;
2810 virtual HRESULT __stdcall raw_SetEOS() = 0;
2811 virtual HRESULT __stdcall raw_CopyTo(
2812 /*[in]*/ struct _Stream* DestStream,
2813 /*[in]*/ long CharNumber) = 0;
2814 virtual HRESULT __stdcall raw_Flush() = 0;
2815 virtual HRESULT __stdcall raw_SaveToFile(
2816 /*[in]*/ BSTR FileName,
2817 /*[in]*/ enum SaveOptionsEnum Options) = 0;
2818 virtual HRESULT __stdcall raw_LoadFromFile(
2819 /*[in]*/ BSTR FileName) = 0;
2820 virtual HRESULT __stdcall raw_ReadText(
2821 /*[in]*/ long NumChars,
2822 /*[out,retval]*/ BSTR* pbstr) = 0;
2823 virtual HRESULT __stdcall raw_WriteText(
2824 /*[in]*/ BSTR Data,
2825 /*[in]*/ enum StreamWriteEnum Options) = 0;
2826 virtual HRESULT __stdcall raw_Cancel() = 0;
2827};
2828
2829struct __declspec(uuid("00000566-0000-0010-8000-00aa006d2ea4")) Stream;
2830// [ default ] interface _Stream
2831
2832struct __declspec(uuid("00000567-0000-0010-8000-00aa006d2ea4")) ADORecordConstruction : IDispatch
2833{
2834 //
2835 // Property data
2836 //
2837
2838 __declspec(property(get = GetRow, put = PutRow)) IUnknownPtr Row;
2839 __declspec(property(put = PutParentRow)) IUnknownPtr ParentRow;
2840
2841 //
2842 // Wrapper methods for error-handling
2843 //
2844
2845 IUnknownPtr GetRow();
2846 void PutRow(IUnknown* ppRow);
2847 void PutParentRow(IUnknown* _arg1);
2848
2849 //
2850 // Raw methods provided by interface
2851 //
2852
2853 virtual HRESULT __stdcall get_Row(
2854 /*[out,retval]*/ IUnknown** ppRow) = 0;
2855 virtual HRESULT __stdcall put_Row(
2856 /*[in]*/ IUnknown* ppRow) = 0;
2857 virtual HRESULT __stdcall put_ParentRow(
2858 /*[in]*/ IUnknown* _arg1) = 0;
2859};
2860
2861struct __declspec(uuid("00000568-0000-0010-8000-00aa006d2ea4")) ADOStreamConstruction : IDispatch
2862{
2863 //
2864 // Property data
2865 //
2866
2867 __declspec(property(get = GetStream, put = PutStream)) IUnknownPtr Stream;
2868
2869 //
2870 // Wrapper methods for error-handling
2871 //
2872
2873 IUnknownPtr GetStream();
2874 void PutStream(IUnknown* ppStm);
2875
2876 //
2877 // Raw methods provided by interface
2878 //
2879
2880 virtual HRESULT __stdcall get_Stream(
2881 /*[out,retval]*/ IUnknown** ppStm) = 0;
2882 virtual HRESULT __stdcall put_Stream(
2883 /*[in]*/ IUnknown* ppStm) = 0;
2884};
2885
2886struct __declspec(uuid("00000517-0000-0010-8000-00aa006d2ea4")) ADOCommandConstruction : IUnknown
2887{
2888 //
2889 // Property data
2890 //
2891
2892 __declspec(property(get = GetOLEDBCommand, put = PutOLEDBCommand)) IUnknownPtr OLEDBCommand;
2893
2894 //
2895 // Wrapper methods for error-handling
2896 //
2897
2898 IUnknownPtr GetOLEDBCommand();
2899 void PutOLEDBCommand(IUnknown* ppOLEDBCommand);
2900
2901 //
2902 // Raw methods provided by interface
2903 //
2904
2905 virtual HRESULT __stdcall get_OLEDBCommand(
2906 /*[out,retval]*/ IUnknown** ppOLEDBCommand) = 0;
2907 virtual HRESULT __stdcall put_OLEDBCommand(
2908 /*[in]*/ IUnknown* ppOLEDBCommand) = 0;
2909};
2910
2911struct __declspec(uuid("00000507-0000-0010-8000-00aa006d2ea4")) Command;
2912// [ default ] interface _Command
2913
2914struct __declspec(uuid("00000535-0000-0010-8000-00aa006d2ea4")) Recordset;
2915// [ default ] interface _Recordset
2916// [ default, source ] dispinterface RecordsetEvents
2917
2918struct __declspec(uuid("00000283-0000-0010-8000-00aa006d2ea4")) ADORecordsetConstruction : IDispatch
2919{
2920 //
2921 // Property data
2922 //
2923
2924 __declspec(property(get = GetRowset, put = PutRowset)) IUnknownPtr Rowset;
2925 __declspec(property(get = GetChapter, put = PutChapter)) ADO_LONGPTR Chapter;
2926 __declspec(property(get = GetRowPosition, put = PutRowPosition)) IUnknownPtr RowPosition;
2927
2928 //
2929 // Wrapper methods for error-handling
2930 //
2931
2932 IUnknownPtr GetRowset();
2933 void PutRowset(IUnknown* ppRowset);
2934 ADO_LONGPTR GetChapter();
2935 void PutChapter(ADO_LONGPTR plChapter);
2936 IUnknownPtr GetRowPosition();
2937 void PutRowPosition(IUnknown* ppRowPos);
2938
2939 //
2940 // Raw methods provided by interface
2941 //
2942
2943 virtual HRESULT __stdcall get_Rowset(
2944 /*[out,retval]*/ IUnknown** ppRowset) = 0;
2945 virtual HRESULT __stdcall put_Rowset(
2946 /*[in]*/ IUnknown* ppRowset) = 0;
2947 virtual HRESULT __stdcall get_Chapter(
2948 /*[out,retval]*/ ADO_LONGPTR* plChapter) = 0;
2949 virtual HRESULT __stdcall put_Chapter(
2950 /*[in]*/ ADO_LONGPTR plChapter) = 0;
2951 virtual HRESULT __stdcall get_RowPosition(
2952 /*[out,retval]*/ IUnknown** ppRowPos) = 0;
2953 virtual HRESULT __stdcall put_RowPosition(
2954 /*[in]*/ IUnknown* ppRowPos) = 0;
2955};
2956
2957struct __declspec(uuid("00001505-0000-0010-8000-00aa006d2ea4")) Field15 : _ADO
2958{
2959 //
2960 // Property data
2961 //
2962
2963 __declspec(property(get = GetValue, put = PutValue)) _variant_t Value;
2964 __declspec(property(get = GetName)) _bstr_t Name;
2965 __declspec(property(get = GetType)) enum DataTypeEnum Type;
2966 __declspec(property(get = GetDefinedSize)) long DefinedSize;
2967 __declspec(property(get = GetOriginalValue)) _variant_t OriginalValue;
2968 __declspec(property(get = GetUnderlyingValue)) _variant_t UnderlyingValue;
2969 __declspec(property(get = GetActualSize)) long ActualSize;
2970 __declspec(property(get = GetPrecision)) unsigned char Precision;
2971 __declspec(property(get = GetNumericScale)) unsigned char NumericScale;
2972 __declspec(property(get = GetAttributes)) long Attributes;
2973
2974 //
2975 // Wrapper methods for error-handling
2976 //
2977
2978 long GetActualSize();
2979 long GetAttributes();
2980 long GetDefinedSize();
2981 _bstr_t GetName();
2982 enum DataTypeEnum GetType();
2983 _variant_t GetValue();
2984 void PutValue(const _variant_t& pvar);
2985 unsigned char GetPrecision();
2986 unsigned char GetNumericScale();
2987 HRESULT AppendChunk(const _variant_t& Data);
2988 _variant_t GetChunk(long Length);
2989 _variant_t GetOriginalValue();
2990 _variant_t GetUnderlyingValue();
2991
2992 //
2993 // Raw methods provided by interface
2994 //
2995
2996 virtual HRESULT __stdcall get_ActualSize(
2997 /*[out,retval]*/ long* pl) = 0;
2998 virtual HRESULT __stdcall get_Attributes(
2999 /*[out,retval]*/ long* pl) = 0;
3000 virtual HRESULT __stdcall get_DefinedSize(
3001 /*[out,retval]*/ long* pl) = 0;
3002 virtual HRESULT __stdcall get_Name(
3003 /*[out,retval]*/ BSTR* pbstr) = 0;
3004 virtual HRESULT __stdcall get_Type(
3005 /*[out,retval]*/ enum DataTypeEnum* pDataType) = 0;
3006 virtual HRESULT __stdcall get_Value(
3007 /*[out,retval]*/ VARIANT* pvar) = 0;
3008 virtual HRESULT __stdcall put_Value(
3009 /*[in]*/ VARIANT pvar) = 0;
3010 virtual HRESULT __stdcall get_Precision(
3011 /*[out,retval]*/ unsigned char* pbPrecision) = 0;
3012 virtual HRESULT __stdcall get_NumericScale(
3013 /*[out,retval]*/ unsigned char* pbNumericScale) = 0;
3014 virtual HRESULT __stdcall raw_AppendChunk(
3015 /*[in]*/ VARIANT Data) = 0;
3016 virtual HRESULT __stdcall raw_GetChunk(
3017 /*[in]*/ long Length,
3018 /*[out,retval]*/ VARIANT* pvar) = 0;
3019 virtual HRESULT __stdcall get_OriginalValue(
3020 /*[out,retval]*/ VARIANT* pvar) = 0;
3021 virtual HRESULT __stdcall get_UnderlyingValue(
3022 /*[out,retval]*/ VARIANT* pvar) = 0;
3023};
3024
3025struct __declspec(uuid("0000050b-0000-0010-8000-00aa006d2ea4")) Parameter;
3026// [ default ] interface _Parameter
3027
3028struct __declspec(uuid("0000054c-0000-0010-8000-00aa006d2ea4")) Field20_Deprecated : _ADO
3029{
3030 //
3031 // Property data
3032 //
3033
3034 __declspec(property(get = GetValue, put = PutValue)) _variant_t Value;
3035 __declspec(property(get = GetName)) _bstr_t Name;
3036 __declspec(property(get = GetType, put = PutType)) enum DataTypeEnum Type;
3037 __declspec(property(get = GetDefinedSize, put = PutDefinedSize)) ADO_LONGPTR DefinedSize;
3038 __declspec(property(get = GetOriginalValue)) _variant_t OriginalValue;
3039 __declspec(property(get = GetUnderlyingValue)) _variant_t UnderlyingValue;
3040 __declspec(property(get = GetActualSize)) ADO_LONGPTR ActualSize;
3041 __declspec(property(get = GetPrecision, put = PutPrecision)) unsigned char Precision;
3042 __declspec(property(get = GetNumericScale, put = PutNumericScale)) unsigned char NumericScale;
3043 __declspec(property(get = GetAttributes, put = PutAttributes)) long Attributes;
3044 __declspec(property(get = GetDataFormat, put = PutRefDataFormat)) IUnknownPtr DataFormat;
3045
3046 //
3047 // Wrapper methods for error-handling
3048 //
3049
3050 ADO_LONGPTR GetActualSize();
3051 long GetAttributes();
3052 ADO_LONGPTR GetDefinedSize();
3053 _bstr_t GetName();
3054 enum DataTypeEnum GetType();
3055 _variant_t GetValue();
3056 void PutValue(const _variant_t& pvar);
3057 unsigned char GetPrecision();
3058 unsigned char GetNumericScale();
3059 HRESULT AppendChunk(const _variant_t& Data);
3060 _variant_t GetChunk(long Length);
3061 _variant_t GetOriginalValue();
3062 _variant_t GetUnderlyingValue();
3063 IUnknownPtr GetDataFormat();
3064 void PutRefDataFormat(IUnknown* ppiDF);
3065 void PutPrecision(unsigned char pbPrecision);
3066 void PutNumericScale(unsigned char pbNumericScale);
3067 void PutType(enum DataTypeEnum pDataType);
3068 void PutDefinedSize(ADO_LONGPTR pl);
3069 void PutAttributes(long pl);
3070
3071 //
3072 // Raw methods provided by interface
3073 //
3074
3075 virtual HRESULT __stdcall get_ActualSize(
3076 /*[out,retval]*/ ADO_LONGPTR* pl) = 0;
3077 virtual HRESULT __stdcall get_Attributes(
3078 /*[out,retval]*/ long* pl) = 0;
3079 virtual HRESULT __stdcall get_DefinedSize(
3080 /*[out,retval]*/ ADO_LONGPTR* pl) = 0;
3081 virtual HRESULT __stdcall get_Name(
3082 /*[out,retval]*/ BSTR* pbstr) = 0;
3083 virtual HRESULT __stdcall get_Type(
3084 /*[out,retval]*/ enum DataTypeEnum* pDataType) = 0;
3085 virtual HRESULT __stdcall get_Value(
3086 /*[out,retval]*/ VARIANT* pvar) = 0;
3087 virtual HRESULT __stdcall put_Value(
3088 /*[in]*/ VARIANT pvar) = 0;
3089 virtual HRESULT __stdcall get_Precision(
3090 /*[out,retval]*/ unsigned char* pbPrecision) = 0;
3091 virtual HRESULT __stdcall get_NumericScale(
3092 /*[out,retval]*/ unsigned char* pbNumericScale) = 0;
3093 virtual HRESULT __stdcall raw_AppendChunk(
3094 /*[in]*/ VARIANT Data) = 0;
3095 virtual HRESULT __stdcall raw_GetChunk(
3096 /*[in]*/ long Length,
3097 /*[out,retval]*/ VARIANT* pvar) = 0;
3098 virtual HRESULT __stdcall get_OriginalValue(
3099 /*[out,retval]*/ VARIANT* pvar) = 0;
3100 virtual HRESULT __stdcall get_UnderlyingValue(
3101 /*[out,retval]*/ VARIANT* pvar) = 0;
3102 virtual HRESULT __stdcall get_DataFormat(
3103 /*[out,retval]*/ IUnknown** ppiDF) = 0;
3104 virtual HRESULT __stdcall putref_DataFormat(
3105 /*[in]*/ IUnknown* ppiDF) = 0;
3106 virtual HRESULT __stdcall put_Precision(
3107 /*[in]*/ unsigned char pbPrecision) = 0;
3108 virtual HRESULT __stdcall put_NumericScale(
3109 /*[in]*/ unsigned char pbNumericScale) = 0;
3110 virtual HRESULT __stdcall put_Type(
3111 /*[in]*/ enum DataTypeEnum pDataType) = 0;
3112 virtual HRESULT __stdcall put_DefinedSize(
3113 /*[in]*/ ADO_LONGPTR pl) = 0;
3114 virtual HRESULT __stdcall put_Attributes(
3115 /*[in]*/ long pl) = 0;
3116};
3117
3118struct __declspec(uuid("00000569-0000-0010-8000-00aa006d2ea4")) Field_Deprecated
3119 : Field20_Deprecated
3120{
3121 //
3122 // Property data
3123 //
3124
3125 __declspec(property(get = GetStatus)) long Status;
3126
3127 //
3128 // Wrapper methods for error-handling
3129 //
3130
3131 long GetStatus();
3132
3133 //
3134 // Raw methods provided by interface
3135 //
3136
3137 virtual HRESULT __stdcall get_Status(
3138 /*[out,retval]*/ long* pFStatus) = 0;
3139};
3140
3141struct __declspec(uuid("00000506-0000-0010-8000-00aa006d2ea4")) Fields15_Deprecated : _Collection
3142{
3143 //
3144 // Property data
3145 //
3146
3147 __declspec(property(get = GetItem)) Field_DeprecatedPtr Item[];
3148
3149 //
3150 // Wrapper methods for error-handling
3151 //
3152
3153 Field_DeprecatedPtr GetItem(const _variant_t& Index);
3154
3155 //
3156 // Raw methods provided by interface
3157 //
3158
3159 virtual HRESULT __stdcall get_Item(
3160 /*[in]*/ VARIANT Index,
3161 /*[out,retval]*/ struct Field_Deprecated** ppvObject) = 0;
3162};
3163
3164struct __declspec(uuid("0000054d-0000-0010-8000-00aa006d2ea4")) Fields20_Deprecated
3165 : Fields15_Deprecated
3166{
3167 //
3168 // Wrapper methods for error-handling
3169 //
3170
3171 HRESULT _Append(_bstr_t Name, enum DataTypeEnum Type, ADO_LONGPTR DefinedSize,
3172 enum FieldAttributeEnum Attrib);
3173 HRESULT Delete(const _variant_t& Index);
3174
3175 //
3176 // Raw methods provided by interface
3177 //
3178
3179 virtual HRESULT __stdcall raw__Append(
3180 /*[in]*/ BSTR Name,
3181 /*[in]*/ enum DataTypeEnum Type,
3182 /*[in]*/ ADO_LONGPTR DefinedSize,
3183 /*[in]*/ enum FieldAttributeEnum Attrib) = 0;
3184 virtual HRESULT __stdcall raw_Delete(
3185 /*[in]*/ VARIANT Index) = 0;
3186};
3187
3188struct __declspec(uuid("00000564-0000-0010-8000-00aa006d2ea4")) Fields_Deprecated
3189 : Fields20_Deprecated
3190{
3191 //
3192 // Wrapper methods for error-handling
3193 //
3194
3195 HRESULT Append(_bstr_t Name, enum DataTypeEnum Type, ADO_LONGPTR DefinedSize,
3196 enum FieldAttributeEnum Attrib, const _variant_t& FieldValue = vtMissing);
3197 HRESULT Update();
3198 HRESULT Resync(enum ResyncEnum ResyncValues);
3199 HRESULT CancelUpdate();
3200
3201 //
3202 // Raw methods provided by interface
3203 //
3204
3205 virtual HRESULT __stdcall raw_Append(
3206 /*[in]*/ BSTR Name,
3207 /*[in]*/ enum DataTypeEnum Type,
3208 /*[in]*/ ADO_LONGPTR DefinedSize,
3209 /*[in]*/ enum FieldAttributeEnum Attrib,
3210 /*[in]*/ VARIANT FieldValue = vtMissing) = 0;
3211 virtual HRESULT __stdcall raw_Update() = 0;
3212 virtual HRESULT __stdcall raw_Resync(
3213 /*[in]*/ enum ResyncEnum ResyncValues) = 0;
3214 virtual HRESULT __stdcall raw_CancelUpdate() = 0;
3215};
3216
3217struct __declspec(uuid("0000050c-0000-0010-8000-00aa006d2ea4")) _Parameter_Deprecated : _ADO
3218{
3219 //
3220 // Property data
3221 //
3222
3223 __declspec(property(get = GetValue, put = PutValue)) _variant_t Value;
3224 __declspec(property(get = GetName, put = PutName)) _bstr_t Name;
3225 __declspec(property(get = GetType, put = PutType)) enum DataTypeEnum Type;
3226 __declspec(property(get = GetDirection,
3227 put = PutDirection)) enum ParameterDirectionEnum Direction;
3228 __declspec(property(get = GetPrecision, put = PutPrecision)) unsigned char Precision;
3229 __declspec(property(get = GetNumericScale, put = PutNumericScale)) unsigned char NumericScale;
3230 __declspec(property(get = GetSize, put = PutSize)) ADO_LONGPTR Size;
3231 __declspec(property(get = GetAttributes, put = PutAttributes)) long Attributes;
3232
3233 //
3234 // Wrapper methods for error-handling
3235 //
3236
3237 _bstr_t GetName();
3238 void PutName(_bstr_t pbstr);
3239 _variant_t GetValue();
3240 void PutValue(const _variant_t& pvar);
3241 enum DataTypeEnum GetType();
3242 void PutType(enum DataTypeEnum psDataType);
3243 void PutDirection(enum ParameterDirectionEnum plParmDirection);
3244 enum ParameterDirectionEnum GetDirection();
3245 void PutPrecision(unsigned char pbPrecision);
3246 unsigned char GetPrecision();
3247 void PutNumericScale(unsigned char pbScale);
3248 unsigned char GetNumericScale();
3249 void PutSize(ADO_LONGPTR pl);
3250 ADO_LONGPTR GetSize();
3251 HRESULT AppendChunk(const _variant_t& Val);
3252 long GetAttributes();
3253 void PutAttributes(long plParmAttribs);
3254
3255 //
3256 // Raw methods provided by interface
3257 //
3258
3259 virtual HRESULT __stdcall get_Name(
3260 /*[out,retval]*/ BSTR* pbstr) = 0;
3261 virtual HRESULT __stdcall put_Name(
3262 /*[in]*/ BSTR pbstr) = 0;
3263 virtual HRESULT __stdcall get_Value(
3264 /*[out,retval]*/ VARIANT* pvar) = 0;
3265 virtual HRESULT __stdcall put_Value(
3266 /*[in]*/ VARIANT pvar) = 0;
3267 virtual HRESULT __stdcall get_Type(
3268 /*[out,retval]*/ enum DataTypeEnum* psDataType) = 0;
3269 virtual HRESULT __stdcall put_Type(
3270 /*[in]*/ enum DataTypeEnum psDataType) = 0;
3271 virtual HRESULT __stdcall put_Direction(
3272 /*[in]*/ enum ParameterDirectionEnum plParmDirection) = 0;
3273 virtual HRESULT __stdcall get_Direction(
3274 /*[out,retval]*/ enum ParameterDirectionEnum* plParmDirection) = 0;
3275 virtual HRESULT __stdcall put_Precision(
3276 /*[in]*/ unsigned char pbPrecision) = 0;
3277 virtual HRESULT __stdcall get_Precision(
3278 /*[out,retval]*/ unsigned char* pbPrecision) = 0;
3279 virtual HRESULT __stdcall put_NumericScale(
3280 /*[in]*/ unsigned char pbScale) = 0;
3281 virtual HRESULT __stdcall get_NumericScale(
3282 /*[out,retval]*/ unsigned char* pbScale) = 0;
3283 virtual HRESULT __stdcall put_Size(
3284 /*[in]*/ ADO_LONGPTR pl) = 0;
3285 virtual HRESULT __stdcall get_Size(
3286 /*[out,retval]*/ ADO_LONGPTR* pl) = 0;
3287 virtual HRESULT __stdcall raw_AppendChunk(
3288 /*[in]*/ VARIANT Val) = 0;
3289 virtual HRESULT __stdcall get_Attributes(
3290 /*[out,retval]*/ long* plParmAttribs) = 0;
3291 virtual HRESULT __stdcall put_Attributes(
3292 /*[in]*/ long plParmAttribs) = 0;
3293};
3294
3295struct __declspec(uuid("0000050d-0000-0010-8000-00aa006d2ea4")) Parameters_Deprecated
3296 : _DynaCollection
3297{
3298 //
3299 // Property data
3300 //
3301
3302 __declspec(property(get = GetItem)) _Parameter_DeprecatedPtr Item[];
3303
3304 //
3305 // Wrapper methods for error-handling
3306 //
3307
3308 _Parameter_DeprecatedPtr GetItem(const _variant_t& Index);
3309
3310 //
3311 // Raw methods provided by interface
3312 //
3313
3314 virtual HRESULT __stdcall get_Item(
3315 /*[in]*/ VARIANT Index,
3316 /*[out,retval]*/ struct _Parameter_Deprecated** ppvObject) = 0;
3317};
3318
3319struct __declspec(uuid("00000400-0000-0010-8000-00aa006d2ea4")) ConnectionEvents_Deprecated
3320 : IDispatch
3321{
3322 //
3323 // Wrapper methods for error-handling
3324 //
3325
3326 // Methods:
3327 HRESULT InfoMessage(struct Error* pError, enum EventStatusEnum* adStatus,
3328 struct _Connection_Deprecated* pConnection);
3329 HRESULT BeginTransComplete(long TransactionLevel, struct Error* pError,
3330 enum EventStatusEnum* adStatus,
3331 struct _Connection_Deprecated* pConnection);
3332 HRESULT CommitTransComplete(struct Error* pError, enum EventStatusEnum* adStatus,
3333 struct _Connection_Deprecated* pConnection);
3334 HRESULT RollbackTransComplete(struct Error* pError, enum EventStatusEnum* adStatus,
3335 struct _Connection_Deprecated* pConnection);
3336 HRESULT WillExecute(BSTR* Source, enum CursorTypeEnum* CursorType, enum LockTypeEnum* LockType,
3337 long* Options, enum EventStatusEnum* adStatus,
3338 struct _Command_Deprecated* pCommand,
3339 struct _Recordset_Deprecated* pRecordset,
3340 struct _Connection_Deprecated* pConnection);
3341 HRESULT ExecuteComplete(long RecordsAffected, struct Error* pError,
3342 enum EventStatusEnum* adStatus, struct _Command_Deprecated* pCommand,
3343 struct _Recordset_Deprecated* pRecordset,
3344 struct _Connection_Deprecated* pConnection);
3345 HRESULT WillConnect(BSTR* ConnectionString, BSTR* UserID, BSTR* Password, long* Options,
3346 enum EventStatusEnum* adStatus, struct _Connection_Deprecated* pConnection);
3347 HRESULT ConnectComplete(struct Error* pError, enum EventStatusEnum* adStatus,
3348 struct _Connection_Deprecated* pConnection);
3349 HRESULT Disconnect(enum EventStatusEnum* adStatus, struct _Connection_Deprecated* pConnection);
3350};
3351
3352struct __declspec(uuid("00000266-0000-0010-8000-00aa006d2ea4")) RecordsetEvents_Deprecated
3353 : IDispatch
3354{
3355 //
3356 // Wrapper methods for error-handling
3357 //
3358
3359 // Methods:
3360 HRESULT WillChangeField(long cFields, const _variant_t& Fields, enum EventStatusEnum* adStatus,
3361 struct _Recordset_Deprecated* pRecordset);
3362 HRESULT FieldChangeComplete(long cFields, const _variant_t& Fields, struct Error* pError,
3363 enum EventStatusEnum* adStatus,
3364 struct _Recordset_Deprecated* pRecordset);
3365 HRESULT WillChangeRecord(enum EventReasonEnum adReason, long cRecords,
3366 enum EventStatusEnum* adStatus,
3367 struct _Recordset_Deprecated* pRecordset);
3368 HRESULT RecordChangeComplete(enum EventReasonEnum adReason, long cRecords, struct Error* pError,
3369 enum EventStatusEnum* adStatus,
3370 struct _Recordset_Deprecated* pRecordset);
3371 HRESULT WillChangeRecordset(enum EventReasonEnum adReason, enum EventStatusEnum* adStatus,
3372 struct _Recordset_Deprecated* pRecordset);
3373 HRESULT RecordsetChangeComplete(enum EventReasonEnum adReason, struct Error* pError,
3374 enum EventStatusEnum* adStatus,
3375 struct _Recordset_Deprecated* pRecordset);
3376 HRESULT WillMove(enum EventReasonEnum adReason, enum EventStatusEnum* adStatus,
3377 struct _Recordset_Deprecated* pRecordset);
3378 HRESULT MoveComplete(enum EventReasonEnum adReason, struct Error* pError,
3379 enum EventStatusEnum* adStatus, struct _Recordset_Deprecated* pRecordset);
3380 HRESULT EndOfRecordset(VARIANT_BOOL* fMoreData, enum EventStatusEnum* adStatus,
3381 struct _Recordset_Deprecated* pRecordset);
3382 HRESULT FetchProgress(long Progress, long MaxProgress, enum EventStatusEnum* adStatus,
3383 struct _Recordset_Deprecated* pRecordset);
3384 HRESULT FetchComplete(struct Error* pError, enum EventStatusEnum* adStatus,
3385 struct _Recordset_Deprecated* pRecordset);
3386};
3387
3388struct __declspec(uuid("00000565-0000-0010-8000-00aa006d2ea4")) _Stream_Deprecated : IDispatch
3389{
3390 //
3391 // Property data
3392 //
3393
3394 __declspec(property(get = GetSize)) ADO_LONGPTR Size;
3395 __declspec(property(get = GetEOS)) VARIANT_BOOL EOS;
3396 __declspec(property(get = GetPosition, put = PutPosition)) ADO_LONGPTR Position;
3397 __declspec(property(get = GetType, put = PutType)) enum StreamTypeEnum Type;
3398 __declspec(property(get = GetLineSeparator,
3399 put = PutLineSeparator)) enum LineSeparatorEnum LineSeparator;
3400 __declspec(property(get = GetState)) enum ObjectStateEnum State;
3401 __declspec(property(get = GetMode, put = PutMode)) enum ConnectModeEnum Mode;
3402 __declspec(property(get = GetCharset, put = PutCharset)) _bstr_t Charset;
3403
3404 //
3405 // Wrapper methods for error-handling
3406 //
3407
3408 ADO_LONGPTR GetSize();
3409 VARIANT_BOOL GetEOS();
3410 ADO_LONGPTR GetPosition();
3411 void PutPosition(ADO_LONGPTR pPos);
3412 enum StreamTypeEnum GetType();
3413 void PutType(enum StreamTypeEnum ptype);
3414 enum LineSeparatorEnum GetLineSeparator();
3415 void PutLineSeparator(enum LineSeparatorEnum pLS);
3416 enum ObjectStateEnum GetState();
3417 enum ConnectModeEnum GetMode();
3418 void PutMode(enum ConnectModeEnum pMode);
3419 _bstr_t GetCharset();
3420 void PutCharset(_bstr_t pbstrCharset);
3421 _variant_t Read(long NumBytes);
3422 HRESULT Open(const _variant_t& Source, enum ConnectModeEnum Mode,
3423 enum StreamOpenOptionsEnum Options, _bstr_t UserName, _bstr_t Password);
3424 HRESULT Close();
3425 HRESULT SkipLine();
3426 HRESULT Write(const _variant_t& Buffer);
3427 HRESULT SetEOS();
3428 HRESULT CopyTo(struct _Stream_Deprecated* DestStream, ADO_LONGPTR CharNumber);
3429 HRESULT Flush();
3430 HRESULT SaveToFile(_bstr_t FileName, enum SaveOptionsEnum Options);
3431 HRESULT LoadFromFile(_bstr_t FileName);
3432 _bstr_t ReadText(long NumChars);
3433 HRESULT WriteText(_bstr_t Data, enum StreamWriteEnum Options);
3434 HRESULT Cancel();
3435
3436 //
3437 // Raw methods provided by interface
3438 //
3439
3440 virtual HRESULT __stdcall get_Size(
3441 /*[out,retval]*/ ADO_LONGPTR* pSize) = 0;
3442 virtual HRESULT __stdcall get_EOS(
3443 /*[out,retval]*/ VARIANT_BOOL* pEOS) = 0;
3444 virtual HRESULT __stdcall get_Position(
3445 /*[out,retval]*/ ADO_LONGPTR* pPos) = 0;
3446 virtual HRESULT __stdcall put_Position(
3447 /*[in]*/ ADO_LONGPTR pPos) = 0;
3448 virtual HRESULT __stdcall get_Type(
3449 /*[out,retval]*/ enum StreamTypeEnum* ptype) = 0;
3450 virtual HRESULT __stdcall put_Type(
3451 /*[in]*/ enum StreamTypeEnum ptype) = 0;
3452 virtual HRESULT __stdcall get_LineSeparator(
3453 /*[out,retval]*/ enum LineSeparatorEnum* pLS) = 0;
3454 virtual HRESULT __stdcall put_LineSeparator(
3455 /*[in]*/ enum LineSeparatorEnum pLS) = 0;
3456 virtual HRESULT __stdcall get_State(
3457 /*[out,retval]*/ enum ObjectStateEnum* pState) = 0;
3458 virtual HRESULT __stdcall get_Mode(
3459 /*[out,retval]*/ enum ConnectModeEnum* pMode) = 0;
3460 virtual HRESULT __stdcall put_Mode(
3461 /*[in]*/ enum ConnectModeEnum pMode) = 0;
3462 virtual HRESULT __stdcall get_Charset(
3463 /*[out,retval]*/ BSTR* pbstrCharset) = 0;
3464 virtual HRESULT __stdcall put_Charset(
3465 /*[in]*/ BSTR pbstrCharset) = 0;
3466 virtual HRESULT __stdcall raw_Read(
3467 /*[in]*/ long NumBytes,
3468 /*[out,retval]*/ VARIANT* pval) = 0;
3469 virtual HRESULT __stdcall raw_Open(
3470 /*[in]*/ VARIANT Source,
3471 /*[in]*/ enum ConnectModeEnum Mode,
3472 /*[in]*/ enum StreamOpenOptionsEnum Options,
3473 /*[in]*/ BSTR UserName,
3474 /*[in]*/ BSTR Password) = 0;
3475 virtual HRESULT __stdcall raw_Close() = 0;
3476 virtual HRESULT __stdcall raw_SkipLine() = 0;
3477 virtual HRESULT __stdcall raw_Write(
3478 /*[in]*/ VARIANT Buffer) = 0;
3479 virtual HRESULT __stdcall raw_SetEOS() = 0;
3480 virtual HRESULT __stdcall raw_CopyTo(
3481 /*[in]*/ struct _Stream_Deprecated* DestStream,
3482 /*[in]*/ ADO_LONGPTR CharNumber) = 0;
3483 virtual HRESULT __stdcall raw_Flush() = 0;
3484 virtual HRESULT __stdcall raw_SaveToFile(
3485 /*[in]*/ BSTR FileName,
3486 /*[in]*/ enum SaveOptionsEnum Options) = 0;
3487 virtual HRESULT __stdcall raw_LoadFromFile(
3488 /*[in]*/ BSTR FileName) = 0;
3489 virtual HRESULT __stdcall raw_ReadText(
3490 /*[in]*/ long NumChars,
3491 /*[out,retval]*/ BSTR* pbstr) = 0;
3492 virtual HRESULT __stdcall raw_WriteText(
3493 /*[in]*/ BSTR Data,
3494 /*[in]*/ enum StreamWriteEnum Options) = 0;
3495 virtual HRESULT __stdcall raw_Cancel() = 0;
3496};
3497
3498struct __declspec(uuid("00000505-0000-0010-8000-00aa006d2ea4")) Field15_Deprecated : _ADO
3499{
3500 //
3501 // Property data
3502 //
3503
3504 __declspec(property(get = GetValue, put = PutValue)) _variant_t Value;
3505 __declspec(property(get = GetName)) _bstr_t Name;
3506 __declspec(property(get = GetType)) enum DataTypeEnum Type;
3507 __declspec(property(get = GetDefinedSize)) ADO_LONGPTR DefinedSize;
3508 __declspec(property(get = GetOriginalValue)) _variant_t OriginalValue;
3509 __declspec(property(get = GetUnderlyingValue)) _variant_t UnderlyingValue;
3510 __declspec(property(get = GetActualSize)) ADO_LONGPTR ActualSize;
3511 __declspec(property(get = GetPrecision)) unsigned char Precision;
3512 __declspec(property(get = GetNumericScale)) unsigned char NumericScale;
3513 __declspec(property(get = GetAttributes)) long Attributes;
3514
3515 //
3516 // Wrapper methods for error-handling
3517 //
3518
3519 ADO_LONGPTR GetActualSize();
3520 long GetAttributes();
3521 ADO_LONGPTR GetDefinedSize();
3522 _bstr_t GetName();
3523 enum DataTypeEnum GetType();
3524 _variant_t GetValue();
3525 void PutValue(const _variant_t& pvar);
3526 unsigned char GetPrecision();
3527 unsigned char GetNumericScale();
3528 HRESULT AppendChunk(const _variant_t& Data);
3529 _variant_t GetChunk(long Length);
3530 _variant_t GetOriginalValue();
3531 _variant_t GetUnderlyingValue();
3532
3533 //
3534 // Raw methods provided by interface
3535 //
3536
3537 virtual HRESULT __stdcall get_ActualSize(
3538 /*[out,retval]*/ ADO_LONGPTR* pl) = 0;
3539 virtual HRESULT __stdcall get_Attributes(
3540 /*[out,retval]*/ long* pl) = 0;
3541 virtual HRESULT __stdcall get_DefinedSize(
3542 /*[out,retval]*/ ADO_LONGPTR* pl) = 0;
3543 virtual HRESULT __stdcall get_Name(
3544 /*[out,retval]*/ BSTR* pbstr) = 0;
3545 virtual HRESULT __stdcall get_Type(
3546 /*[out,retval]*/ enum DataTypeEnum* pDataType) = 0;
3547 virtual HRESULT __stdcall get_Value(
3548 /*[out,retval]*/ VARIANT* pvar) = 0;
3549 virtual HRESULT __stdcall put_Value(
3550 /*[in]*/ VARIANT pvar) = 0;
3551 virtual HRESULT __stdcall get_Precision(
3552 /*[out,retval]*/ unsigned char* pbPrecision) = 0;
3553 virtual HRESULT __stdcall get_NumericScale(
3554 /*[out,retval]*/ unsigned char* pbNumericScale) = 0;
3555 virtual HRESULT __stdcall raw_AppendChunk(
3556 /*[in]*/ VARIANT Data) = 0;
3557 virtual HRESULT __stdcall raw_GetChunk(
3558 /*[in]*/ long Length,
3559 /*[out,retval]*/ VARIANT* pvar) = 0;
3560 virtual HRESULT __stdcall get_OriginalValue(
3561 /*[out,retval]*/ VARIANT* pvar) = 0;
3562 virtual HRESULT __stdcall get_UnderlyingValue(
3563 /*[out,retval]*/ VARIANT* pvar) = 0;
3564};
3565
3566struct __declspec(uuid("00001508-0000-0010-8000-00aa006d2ea4")) Command15 : _ADO
3567{
3568 //
3569 // Property data
3570 //
3571
3572 __declspec(property(get = GetParameters)) ParametersPtr Parameters;
3573 __declspec(property(get = GetActiveConnection,
3574 put = PutRefActiveConnection)) _ConnectionPtr ActiveConnection;
3575 __declspec(property(get = GetCommandText, put = PutCommandText)) _bstr_t CommandText;
3576 __declspec(property(get = GetCommandTimeout, put = PutCommandTimeout)) long CommandTimeout;
3577 __declspec(property(get = GetPrepared, put = PutPrepared)) VARIANT_BOOL Prepared;
3578 __declspec(property(get = GetCommandType,
3579 put = PutCommandType)) enum CommandTypeEnum CommandType;
3580 __declspec(property(get = GetName, put = PutName)) _bstr_t Name;
3581
3582 //
3583 // Wrapper methods for error-handling
3584 //
3585
3586 _ConnectionPtr GetActiveConnection();
3587 void PutRefActiveConnection(struct _Connection* ppvObject);
3588 void PutActiveConnection(const _variant_t& ppvObject);
3589 _bstr_t GetCommandText();
3590 void PutCommandText(_bstr_t pbstr);
3591 long GetCommandTimeout();
3592 void PutCommandTimeout(long pl);
3593 VARIANT_BOOL GetPrepared();
3594 void PutPrepared(VARIANT_BOOL pfPrepared);
3595 _RecordsetPtr Execute(VARIANT* RecordsAffected, VARIANT* Parameters, long Options);
3596 _ParameterPtr CreateParameter(_bstr_t Name, enum DataTypeEnum Type,
3597 enum ParameterDirectionEnum Direction, long Size,
3598 const _variant_t& Value = vtMissing);
3599 ParametersPtr GetParameters();
3600 void PutCommandType(enum CommandTypeEnum plCmdType);
3601 enum CommandTypeEnum GetCommandType();
3602 _bstr_t GetName();
3603 void PutName(_bstr_t pbstrName);
3604
3605 //
3606 // Raw methods provided by interface
3607 //
3608
3609 virtual HRESULT __stdcall get_ActiveConnection(
3610 /*[out,retval]*/ struct _Connection** ppvObject) = 0;
3611 virtual HRESULT __stdcall putref_ActiveConnection(
3612 /*[in]*/ struct _Connection* ppvObject) = 0;
3613 virtual HRESULT __stdcall put_ActiveConnection(
3614 /*[in]*/ VARIANT ppvObject) = 0;
3615 virtual HRESULT __stdcall get_CommandText(
3616 /*[out,retval]*/ BSTR* pbstr) = 0;
3617 virtual HRESULT __stdcall put_CommandText(
3618 /*[in]*/ BSTR pbstr) = 0;
3619 virtual HRESULT __stdcall get_CommandTimeout(
3620 /*[out,retval]*/ long* pl) = 0;
3621 virtual HRESULT __stdcall put_CommandTimeout(
3622 /*[in]*/ long pl) = 0;
3623 virtual HRESULT __stdcall get_Prepared(
3624 /*[out,retval]*/ VARIANT_BOOL* pfPrepared) = 0;
3625 virtual HRESULT __stdcall put_Prepared(
3626 /*[in]*/ VARIANT_BOOL pfPrepared) = 0;
3627 virtual HRESULT __stdcall raw_Execute(
3628 /*[out]*/ VARIANT* RecordsAffected,
3629 /*[in]*/ VARIANT* Parameters,
3630 /*[in]*/ long Options,
3631 /*[out,retval]*/ struct _Recordset** ppiRs) = 0;
3632 virtual HRESULT __stdcall raw_CreateParameter(
3633 /*[in]*/ BSTR Name,
3634 /*[in]*/ enum DataTypeEnum Type,
3635 /*[in]*/ enum ParameterDirectionEnum Direction,
3636 /*[in]*/ long Size,
3637 /*[in]*/ VARIANT Value,
3638 /*[out,retval]*/ struct _Parameter** ppiprm) = 0;
3639 virtual HRESULT __stdcall get_Parameters(
3640 /*[out,retval]*/ struct Parameters** ppvObject) = 0;
3641 virtual HRESULT __stdcall put_CommandType(
3642 /*[in]*/ enum CommandTypeEnum plCmdType) = 0;
3643 virtual HRESULT __stdcall get_CommandType(
3644 /*[out,retval]*/ enum CommandTypeEnum* plCmdType) = 0;
3645 virtual HRESULT __stdcall get_Name(
3646 /*[out,retval]*/ BSTR* pbstrName) = 0;
3647 virtual HRESULT __stdcall put_Name(
3648 /*[in]*/ BSTR pbstrName) = 0;
3649};
3650
3651struct __declspec(uuid("0000154e-0000-0010-8000-00aa006d2ea4")) Command25 : Command15
3652{
3653 //
3654 // Property data
3655 //
3656
3657 __declspec(property(get = GetState)) long State;
3658
3659 //
3660 // Wrapper methods for error-handling
3661 //
3662
3663 long GetState();
3664 HRESULT Cancel();
3665
3666 //
3667 // Raw methods provided by interface
3668 //
3669
3670 virtual HRESULT __stdcall get_State(
3671 /*[out,retval]*/ long* plObjState) = 0;
3672 virtual HRESULT __stdcall raw_Cancel() = 0;
3673};
3674
3675struct __declspec(uuid("986761e8-7269-4890-aa65-ad7c03697a6d")) _Command : Command25
3676{
3677 //
3678 // Property data
3679 //
3680
3681 __declspec(property(get = GetDialect, put = PutDialect)) _bstr_t Dialect;
3682 __declspec(property(get = GetNamedParameters,
3683 put = PutNamedParameters)) VARIANT_BOOL NamedParameters;
3684
3685 //
3686 // Wrapper methods for error-handling
3687 //
3688
3689 void PutRefCommandStream(IUnknown* pvStream);
3690 _variant_t GetCommandStream();
3691 void PutDialect(_bstr_t pbstrDialect);
3692 _bstr_t GetDialect();
3693 void PutNamedParameters(VARIANT_BOOL pfNamedParameters);
3694 VARIANT_BOOL GetNamedParameters();
3695
3696 //
3697 // Raw methods provided by interface
3698 //
3699
3700 virtual HRESULT __stdcall putref_CommandStream(
3701 /*[in]*/ IUnknown* pvStream) = 0;
3702 virtual HRESULT __stdcall get_CommandStream(
3703 /*[out,retval]*/ VARIANT* pvStream) = 0;
3704 virtual HRESULT __stdcall put_Dialect(
3705 /*[in]*/ BSTR pbstrDialect) = 0;
3706 virtual HRESULT __stdcall get_Dialect(
3707 /*[out,retval]*/ BSTR* pbstrDialect) = 0;
3708 virtual HRESULT __stdcall put_NamedParameters(
3709 /*[in]*/ VARIANT_BOOL pfNamedParameters) = 0;
3710 virtual HRESULT __stdcall get_NamedParameters(
3711 /*[out,retval]*/ VARIANT_BOOL* pfNamedParameters) = 0;
3712};
3713
3714struct __declspec(uuid("00001515-0000-0010-8000-00aa006d2ea4")) Connection15 : _ADO
3715{
3716 //
3717 // Property data
3718 //
3719
3720 __declspec(property(get = GetConnectionString,
3721 put = PutConnectionString)) _bstr_t ConnectionString;
3722 __declspec(property(get = GetCommandTimeout, put = PutCommandTimeout)) long CommandTimeout;
3723 __declspec(property(get = GetConnectionTimeout,
3724 put = PutConnectionTimeout)) long ConnectionTimeout;
3725 __declspec(property(get = GetVersion)) _bstr_t Version;
3726 __declspec(property(get = GetErrors)) ErrorsPtr Errors;
3727 __declspec(property(get = GetDefaultDatabase,
3728 put = PutDefaultDatabase)) _bstr_t DefaultDatabase;
3729 __declspec(property(get = GetIsolationLevel,
3730 put = PutIsolationLevel)) enum IsolationLevelEnum IsolationLevel;
3731 __declspec(property(get = GetAttributes, put = PutAttributes)) long Attributes;
3732 __declspec(property(get = GetCursorLocation,
3733 put = PutCursorLocation)) enum CursorLocationEnum CursorLocation;
3734 __declspec(property(get = GetMode, put = PutMode)) enum ConnectModeEnum Mode;
3735 __declspec(property(get = GetProvider, put = PutProvider)) _bstr_t Provider;
3736 __declspec(property(get = GetState)) long State;
3737
3738 //
3739 // Wrapper methods for error-handling
3740 //
3741
3742 _bstr_t GetConnectionString();
3743 void PutConnectionString(_bstr_t pbstr);
3744 long GetCommandTimeout();
3745 void PutCommandTimeout(long plTimeout);
3746 long GetConnectionTimeout();
3747 void PutConnectionTimeout(long plTimeout);
3748 _bstr_t GetVersion();
3749 HRESULT Close();
3750 _RecordsetPtr Execute(_bstr_t CommandText, VARIANT* RecordsAffected, long Options);
3751 long BeginTrans();
3752 HRESULT CommitTrans();
3753 HRESULT RollbackTrans();
3754 HRESULT Open(_bstr_t ConnectionString, _bstr_t UserID, _bstr_t Password, long Options);
3755 ErrorsPtr GetErrors();
3756 _bstr_t GetDefaultDatabase();
3757 void PutDefaultDatabase(_bstr_t pbstr);
3758 enum IsolationLevelEnum GetIsolationLevel();
3759 void PutIsolationLevel(enum IsolationLevelEnum Level);
3760 long GetAttributes();
3761 void PutAttributes(long plAttr);
3762 enum CursorLocationEnum GetCursorLocation();
3763 void PutCursorLocation(enum CursorLocationEnum plCursorLoc);
3764 enum ConnectModeEnum GetMode();
3765 void PutMode(enum ConnectModeEnum plMode);
3766 _bstr_t GetProvider();
3767 void PutProvider(_bstr_t pbstr);
3768 long GetState();
3769 _RecordsetPtr OpenSchema(enum SchemaEnum Schema, const _variant_t& Restrictions = vtMissing,
3770 const _variant_t& SchemaID = vtMissing);
3771
3772 //
3773 // Raw methods provided by interface
3774 //
3775
3776 virtual HRESULT __stdcall get_ConnectionString(
3777 /*[out,retval]*/ BSTR* pbstr) = 0;
3778 virtual HRESULT __stdcall put_ConnectionString(
3779 /*[in]*/ BSTR pbstr) = 0;
3780 virtual HRESULT __stdcall get_CommandTimeout(
3781 /*[out,retval]*/ long* plTimeout) = 0;
3782 virtual HRESULT __stdcall put_CommandTimeout(
3783 /*[in]*/ long plTimeout) = 0;
3784 virtual HRESULT __stdcall get_ConnectionTimeout(
3785 /*[out,retval]*/ long* plTimeout) = 0;
3786 virtual HRESULT __stdcall put_ConnectionTimeout(
3787 /*[in]*/ long plTimeout) = 0;
3788 virtual HRESULT __stdcall get_Version(
3789 /*[out,retval]*/ BSTR* pbstr) = 0;
3790 virtual HRESULT __stdcall raw_Close() = 0;
3791 virtual HRESULT __stdcall raw_Execute(
3792 /*[in]*/ BSTR CommandText,
3793 /*[out]*/ VARIANT* RecordsAffected,
3794 /*[in]*/ long Options,
3795 /*[out,retval]*/ struct _Recordset** ppiRset) = 0;
3796 virtual HRESULT __stdcall raw_BeginTrans(
3797 /*[out,retval]*/ long* TransactionLevel) = 0;
3798 virtual HRESULT __stdcall raw_CommitTrans() = 0;
3799 virtual HRESULT __stdcall raw_RollbackTrans() = 0;
3800 virtual HRESULT __stdcall raw_Open(
3801 /*[in]*/ BSTR ConnectionString,
3802 /*[in]*/ BSTR UserID,
3803 /*[in]*/ BSTR Password,
3804 /*[in]*/ long Options) = 0;
3805 virtual HRESULT __stdcall get_Errors(
3806 /*[out,retval]*/ struct Errors** ppvObject) = 0;
3807 virtual HRESULT __stdcall get_DefaultDatabase(
3808 /*[out,retval]*/ BSTR* pbstr) = 0;
3809 virtual HRESULT __stdcall put_DefaultDatabase(
3810 /*[in]*/ BSTR pbstr) = 0;
3811 virtual HRESULT __stdcall get_IsolationLevel(
3812 /*[out,retval]*/ enum IsolationLevelEnum* Level) = 0;
3813 virtual HRESULT __stdcall put_IsolationLevel(
3814 /*[in]*/ enum IsolationLevelEnum Level) = 0;
3815 virtual HRESULT __stdcall get_Attributes(
3816 /*[out,retval]*/ long* plAttr) = 0;
3817 virtual HRESULT __stdcall put_Attributes(
3818 /*[in]*/ long plAttr) = 0;
3819 virtual HRESULT __stdcall get_CursorLocation(
3820 /*[out,retval]*/ enum CursorLocationEnum* plCursorLoc) = 0;
3821 virtual HRESULT __stdcall put_CursorLocation(
3822 /*[in]*/ enum CursorLocationEnum plCursorLoc) = 0;
3823 virtual HRESULT __stdcall get_Mode(
3824 /*[out,retval]*/ enum ConnectModeEnum* plMode) = 0;
3825 virtual HRESULT __stdcall put_Mode(
3826 /*[in]*/ enum ConnectModeEnum plMode) = 0;
3827 virtual HRESULT __stdcall get_Provider(
3828 /*[out,retval]*/ BSTR* pbstr) = 0;
3829 virtual HRESULT __stdcall put_Provider(
3830 /*[in]*/ BSTR pbstr) = 0;
3831 virtual HRESULT __stdcall get_State(
3832 /*[out,retval]*/ long* plObjState) = 0;
3833 virtual HRESULT __stdcall raw_OpenSchema(
3834 /*[in]*/ enum SchemaEnum Schema,
3835 /*[in]*/ VARIANT Restrictions,
3836 /*[in]*/ VARIANT SchemaID,
3837 /*[out,retval]*/ struct _Recordset** pprset) = 0;
3838};
3839
3840struct __declspec(uuid("00001550-0000-0010-8000-00aa006d2ea4")) _Connection : Connection15
3841{
3842 //
3843 // Wrapper methods for error-handling
3844 //
3845
3846 HRESULT Cancel();
3847
3848 //
3849 // Raw methods provided by interface
3850 //
3851
3852 virtual HRESULT __stdcall raw_Cancel() = 0;
3853};
3854
3855struct __declspec(uuid("0000150e-0000-0010-8000-00aa006d2ea4")) Recordset15 : _ADO
3856{
3857 //
3858 // Property data
3859 //
3860
3861 __declspec(property(get = GetFields)) FieldsPtr Fields;
3862 __declspec(property(get = GetPageSize, put = PutPageSize)) long PageSize;
3863 __declspec(property(get = GetPageCount)) long PageCount;
3864 __declspec(property(get = GetCursorLocation,
3865 put = PutCursorLocation)) enum CursorLocationEnum CursorLocation;
3866 __declspec(property(get = GetState)) long State;
3867 __declspec(property(get = GetMarshalOptions,
3868 put = PutMarshalOptions)) enum MarshalOptionsEnum MarshalOptions;
3869 __declspec(property(get = GetCollect, put = PutCollect)) _variant_t Collect[];
3870 __declspec(property(get = GetEditMode)) enum EditModeEnum EditMode;
3871 __declspec(property(get = GetStatus)) long Status;
3872 __declspec(property(get = GetFilter, put = PutFilter)) _variant_t Filter;
3873 __declspec(property(get = GetSort, put = PutSort)) _bstr_t Sort;
3874 __declspec(property(get = GetAbsolutePosition,
3875 put = PutAbsolutePosition)) enum PositionEnum AbsolutePosition;
3876 __declspec(property(get = GetbBOF)) VARIANT_BOOL bBOF;
3877 __declspec(property(get = GetBookmark, put = PutBookmark)) _variant_t Bookmark;
3878 __declspec(property(get = GetCacheSize, put = PutCacheSize)) long CacheSize;
3879 __declspec(property(get = GetCursorType, put = PutCursorType)) enum CursorTypeEnum CursorType;
3880 __declspec(property(get = GetbEOF)) VARIANT_BOOL bEOF;
3881 __declspec(property(get = GetAbsolutePage,
3882 put = PutAbsolutePage)) enum PositionEnum AbsolutePage;
3883 __declspec(property(get = GetLockType, put = PutLockType)) enum LockTypeEnum LockType;
3884 __declspec(property(get = GetMaxRecords, put = PutMaxRecords)) long MaxRecords;
3885 __declspec(property(get = GetRecordCount)) long RecordCount;
3886
3887 //
3888 // Wrapper methods for error-handling
3889 //
3890
3891 enum PositionEnum GetAbsolutePosition();
3892 void PutAbsolutePosition(enum PositionEnum pl);
3893 void PutRefActiveConnection(IDispatch* pvar);
3894 void PutActiveConnection(const _variant_t& pvar);
3895 _variant_t GetActiveConnection();
3896 VARIANT_BOOL GetbBOF();
3897 _variant_t GetBookmark();
3898 void PutBookmark(const _variant_t& pvBookmark);
3899 long GetCacheSize();
3900 void PutCacheSize(long pl);
3901 enum CursorTypeEnum GetCursorType();
3902 void PutCursorType(enum CursorTypeEnum plCursorType);
3903 VARIANT_BOOL GetbEOF();
3904 FieldsPtr GetFields();
3905 enum LockTypeEnum GetLockType();
3906 void PutLockType(enum LockTypeEnum plLockType);
3907 long GetMaxRecords();
3908 void PutMaxRecords(long plMaxRecords);
3909 long GetRecordCount();
3910 void PutRefSource(IDispatch* pvSource);
3911 void PutSource(_bstr_t pvSource);
3912 _variant_t GetSource();
3913 HRESULT AddNew(const _variant_t& FieldList = vtMissing, const _variant_t& Values = vtMissing);
3914 HRESULT CancelUpdate();
3915 HRESULT Close();
3916 HRESULT Delete(enum AffectEnum AffectRecords);
3917 _variant_t GetRows(long Rows, const _variant_t& Start = vtMissing,
3918 const _variant_t& Fields = vtMissing);
3919 HRESULT Move(long NumRecords, const _variant_t& Start = vtMissing);
3920 HRESULT MoveNext();
3921 HRESULT MovePrevious();
3922 HRESULT MoveFirst();
3923 HRESULT MoveLast();
3924 HRESULT Open(const _variant_t& Source, const _variant_t& ActiveConnection,
3925 enum CursorTypeEnum CursorType, enum LockTypeEnum LockType, long Options);
3926 HRESULT Requery(long Options);
3927 HRESULT _xResync(enum AffectEnum AffectRecords);
3928 HRESULT Update(const _variant_t& Fields = vtMissing, const _variant_t& Values = vtMissing);
3929 enum PositionEnum GetAbsolutePage();
3930 void PutAbsolutePage(enum PositionEnum pl);
3931 enum EditModeEnum GetEditMode();
3932 _variant_t GetFilter();
3933 void PutFilter(const _variant_t& Criteria);
3934 long GetPageCount();
3935 long GetPageSize();
3936 void PutPageSize(long pl);
3937 _bstr_t GetSort();
3938 void PutSort(_bstr_t Criteria);
3939 long GetStatus();
3940 long GetState();
3941 _RecordsetPtr _xClone();
3942 HRESULT UpdateBatch(enum AffectEnum AffectRecords);
3943 HRESULT CancelBatch(enum AffectEnum AffectRecords);
3944 enum CursorLocationEnum GetCursorLocation();
3945 void PutCursorLocation(enum CursorLocationEnum plCursorLoc);
3946 _RecordsetPtr NextRecordset(VARIANT* RecordsAffected);
3947 VARIANT_BOOL Supports(enum CursorOptionEnum CursorOptions);
3948 _variant_t GetCollect(const _variant_t& Index);
3949 void PutCollect(const _variant_t& Index, const _variant_t& pvar);
3950 enum MarshalOptionsEnum GetMarshalOptions();
3951 void PutMarshalOptions(enum MarshalOptionsEnum peMarshal);
3952 HRESULT Find(_bstr_t Criteria, long SkipRecords, enum SearchDirectionEnum SearchDirection,
3953 const _variant_t& Start = vtMissing);
3954
3955 //
3956 // Raw methods provided by interface
3957 //
3958
3959 virtual HRESULT __stdcall get_AbsolutePosition(
3960 /*[out,retval]*/ enum PositionEnum* pl) = 0;
3961 virtual HRESULT __stdcall put_AbsolutePosition(
3962 /*[in]*/ enum PositionEnum pl) = 0;
3963 virtual HRESULT __stdcall putref_ActiveConnection(
3964 /*[in]*/ IDispatch* pvar) = 0;
3965 virtual HRESULT __stdcall put_ActiveConnection(
3966 /*[in]*/ VARIANT pvar) = 0;
3967 virtual HRESULT __stdcall get_ActiveConnection(
3968 /*[out,retval]*/ VARIANT* pvar) = 0;
3969 virtual HRESULT __stdcall get_bBOF(
3970 /*[out,retval]*/ VARIANT_BOOL* pb) = 0;
3971 virtual HRESULT __stdcall get_Bookmark(
3972 /*[out,retval]*/ VARIANT* pvBookmark) = 0;
3973 virtual HRESULT __stdcall put_Bookmark(
3974 /*[in]*/ VARIANT pvBookmark) = 0;
3975 virtual HRESULT __stdcall get_CacheSize(
3976 /*[out,retval]*/ long* pl) = 0;
3977 virtual HRESULT __stdcall put_CacheSize(
3978 /*[in]*/ long pl) = 0;
3979 virtual HRESULT __stdcall get_CursorType(
3980 /*[out,retval]*/ enum CursorTypeEnum* plCursorType) = 0;
3981 virtual HRESULT __stdcall put_CursorType(
3982 /*[in]*/ enum CursorTypeEnum plCursorType) = 0;
3983 virtual HRESULT __stdcall get_bEOF(
3984 /*[out,retval]*/ VARIANT_BOOL* pb) = 0;
3985 virtual HRESULT __stdcall get_Fields(
3986 /*[out,retval]*/ struct Fields** ppvObject) = 0;
3987 virtual HRESULT __stdcall get_LockType(
3988 /*[out,retval]*/ enum LockTypeEnum* plLockType) = 0;
3989 virtual HRESULT __stdcall put_LockType(
3990 /*[in]*/ enum LockTypeEnum plLockType) = 0;
3991 virtual HRESULT __stdcall get_MaxRecords(
3992 /*[out,retval]*/ long* plMaxRecords) = 0;
3993 virtual HRESULT __stdcall put_MaxRecords(
3994 /*[in]*/ long plMaxRecords) = 0;
3995 virtual HRESULT __stdcall get_RecordCount(
3996 /*[out,retval]*/ long* pl) = 0;
3997 virtual HRESULT __stdcall putref_Source(
3998 /*[in]*/ IDispatch* pvSource) = 0;
3999 virtual HRESULT __stdcall put_Source(
4000 /*[in]*/ BSTR pvSource) = 0;
4001 virtual HRESULT __stdcall get_Source(
4002 /*[out,retval]*/ VARIANT* pvSource) = 0;
4003 virtual HRESULT __stdcall raw_AddNew(
4004 /*[in]*/ VARIANT FieldList = vtMissing,
4005 /*[in]*/ VARIANT Values = vtMissing) = 0;
4006 virtual HRESULT __stdcall raw_CancelUpdate() = 0;
4007 virtual HRESULT __stdcall raw_Close() = 0;
4008 virtual HRESULT __stdcall raw_Delete(
4009 /*[in]*/ enum AffectEnum AffectRecords) = 0;
4010 virtual HRESULT __stdcall raw_GetRows(
4011 /*[in]*/ long Rows,
4012 /*[in]*/ VARIANT Start,
4013 /*[in]*/ VARIANT Fields,
4014 /*[out,retval]*/ VARIANT* pvar) = 0;
4015 virtual HRESULT __stdcall raw_Move(
4016 /*[in]*/ long NumRecords,
4017 /*[in]*/ VARIANT Start = vtMissing) = 0;
4018 virtual HRESULT __stdcall raw_MoveNext() = 0;
4019 virtual HRESULT __stdcall raw_MovePrevious() = 0;
4020 virtual HRESULT __stdcall raw_MoveFirst() = 0;
4021 virtual HRESULT __stdcall raw_MoveLast() = 0;
4022 virtual HRESULT __stdcall raw_Open(
4023 /*[in]*/ VARIANT Source,
4024 /*[in]*/ VARIANT ActiveConnection,
4025 /*[in]*/ enum CursorTypeEnum CursorType,
4026 /*[in]*/ enum LockTypeEnum LockType,
4027 /*[in]*/ long Options) = 0;
4028 virtual HRESULT __stdcall raw_Requery(
4029 /*[in]*/ long Options) = 0;
4030 virtual HRESULT __stdcall raw__xResync(
4031 /*[in]*/ enum AffectEnum AffectRecords) = 0;
4032 virtual HRESULT __stdcall raw_Update(
4033 /*[in]*/ VARIANT Fields = vtMissing,
4034 /*[in]*/ VARIANT Values = vtMissing) = 0;
4035 virtual HRESULT __stdcall get_AbsolutePage(
4036 /*[out,retval]*/ enum PositionEnum* pl) = 0;
4037 virtual HRESULT __stdcall put_AbsolutePage(
4038 /*[in]*/ enum PositionEnum pl) = 0;
4039 virtual HRESULT __stdcall get_EditMode(
4040 /*[out,retval]*/ enum EditModeEnum* pl) = 0;
4041 virtual HRESULT __stdcall get_Filter(
4042 /*[out,retval]*/ VARIANT* Criteria) = 0;
4043 virtual HRESULT __stdcall put_Filter(
4044 /*[in]*/ VARIANT Criteria) = 0;
4045 virtual HRESULT __stdcall get_PageCount(
4046 /*[out,retval]*/ long* pl) = 0;
4047 virtual HRESULT __stdcall get_PageSize(
4048 /*[out,retval]*/ long* pl) = 0;
4049 virtual HRESULT __stdcall put_PageSize(
4050 /*[in]*/ long pl) = 0;
4051 virtual HRESULT __stdcall get_Sort(
4052 /*[out,retval]*/ BSTR* Criteria) = 0;
4053 virtual HRESULT __stdcall put_Sort(
4054 /*[in]*/ BSTR Criteria) = 0;
4055 virtual HRESULT __stdcall get_Status(
4056 /*[out,retval]*/ long* pl) = 0;
4057 virtual HRESULT __stdcall get_State(
4058 /*[out,retval]*/ long* plObjState) = 0;
4059 virtual HRESULT __stdcall raw__xClone(
4060 /*[out,retval]*/ struct _Recordset** ppvObject) = 0;
4061 virtual HRESULT __stdcall raw_UpdateBatch(
4062 /*[in]*/ enum AffectEnum AffectRecords) = 0;
4063 virtual HRESULT __stdcall raw_CancelBatch(
4064 /*[in]*/ enum AffectEnum AffectRecords) = 0;
4065 virtual HRESULT __stdcall get_CursorLocation(
4066 /*[out,retval]*/ enum CursorLocationEnum* plCursorLoc) = 0;
4067 virtual HRESULT __stdcall put_CursorLocation(
4068 /*[in]*/ enum CursorLocationEnum plCursorLoc) = 0;
4069 virtual HRESULT __stdcall raw_NextRecordset(
4070 /*[out]*/ VARIANT* RecordsAffected,
4071 /*[out,retval]*/ struct _Recordset** ppiRs) = 0;
4072 virtual HRESULT __stdcall raw_Supports(
4073 /*[in]*/ enum CursorOptionEnum CursorOptions,
4074 /*[out,retval]*/ VARIANT_BOOL* pb) = 0;
4075 virtual HRESULT __stdcall get_Collect(
4076 /*[in]*/ VARIANT Index,
4077 /*[out,retval]*/ VARIANT* pvar) = 0;
4078 virtual HRESULT __stdcall put_Collect(
4079 /*[in]*/ VARIANT Index,
4080 /*[in]*/ VARIANT pvar) = 0;
4081 virtual HRESULT __stdcall get_MarshalOptions(
4082 /*[out,retval]*/ enum MarshalOptionsEnum* peMarshal) = 0;
4083 virtual HRESULT __stdcall put_MarshalOptions(
4084 /*[in]*/ enum MarshalOptionsEnum peMarshal) = 0;
4085 virtual HRESULT __stdcall raw_Find(
4086 /*[in]*/ BSTR Criteria,
4087 /*[in]*/ long SkipRecords,
4088 /*[in]*/ enum SearchDirectionEnum SearchDirection,
4089 /*[in]*/ VARIANT Start = vtMissing) = 0;
4090};
4091
4092struct __declspec(uuid("0000154f-0000-0010-8000-00aa006d2ea4")) Recordset20 : Recordset15
4093{
4094 //
4095 // Property data
4096 //
4097
4098 __declspec(property(get = GetDataSource, put = PutRefDataSource)) IUnknownPtr DataSource;
4099 __declspec(property(get = GetActiveCommand)) IDispatchPtr ActiveCommand;
4100 __declspec(property(get = GetStayInSync, put = PutStayInSync)) VARIANT_BOOL StayInSync;
4101 __declspec(property(get = GetDataMember, put = PutDataMember)) _bstr_t DataMember;
4102
4103 //
4104 // Wrapper methods for error-handling
4105 //
4106
4107 HRESULT Cancel();
4108 IUnknownPtr GetDataSource();
4109 void PutRefDataSource(IUnknown* ppunkDataSource);
4110 HRESULT _xSave(_bstr_t FileName, enum PersistFormatEnum PersistFormat);
4111 IDispatchPtr GetActiveCommand();
4112 void PutStayInSync(VARIANT_BOOL pbStayInSync);
4113 VARIANT_BOOL GetStayInSync();
4114 _bstr_t GetString(enum StringFormatEnum StringFormat, long NumRows, _bstr_t ColumnDelimeter,
4115 _bstr_t RowDelimeter, _bstr_t NullExpr);
4116 _bstr_t GetDataMember();
4117 void PutDataMember(_bstr_t pbstrDataMember);
4118 enum CompareEnum CompareBookmarks(const _variant_t& Bookmark1, const _variant_t& Bookmark2);
4119 _RecordsetPtr Clone(enum LockTypeEnum LockType);
4120 HRESULT Resync(enum AffectEnum AffectRecords, enum ResyncEnum ResyncValues);
4121
4122 //
4123 // Raw methods provided by interface
4124 //
4125
4126 virtual HRESULT __stdcall raw_Cancel() = 0;
4127 virtual HRESULT __stdcall get_DataSource(
4128 /*[out,retval]*/ IUnknown** ppunkDataSource) = 0;
4129 virtual HRESULT __stdcall putref_DataSource(
4130 /*[in]*/ IUnknown* ppunkDataSource) = 0;
4131 virtual HRESULT __stdcall raw__xSave(
4132 /*[in]*/ BSTR FileName,
4133 /*[in]*/ enum PersistFormatEnum PersistFormat) = 0;
4134 virtual HRESULT __stdcall get_ActiveCommand(
4135 /*[out,retval]*/ IDispatch** ppCmd) = 0;
4136 virtual HRESULT __stdcall put_StayInSync(
4137 /*[in]*/ VARIANT_BOOL pbStayInSync) = 0;
4138 virtual HRESULT __stdcall get_StayInSync(
4139 /*[out,retval]*/ VARIANT_BOOL* pbStayInSync) = 0;
4140 virtual HRESULT __stdcall raw_GetString(
4141 /*[in]*/ enum StringFormatEnum StringFormat,
4142 /*[in]*/ long NumRows,
4143 /*[in]*/ BSTR ColumnDelimeter,
4144 /*[in]*/ BSTR RowDelimeter,
4145 /*[in]*/ BSTR NullExpr,
4146 /*[out,retval]*/ BSTR* pRetString) = 0;
4147 virtual HRESULT __stdcall get_DataMember(
4148 /*[out,retval]*/ BSTR* pbstrDataMember) = 0;
4149 virtual HRESULT __stdcall put_DataMember(
4150 /*[in]*/ BSTR pbstrDataMember) = 0;
4151 virtual HRESULT __stdcall raw_CompareBookmarks(
4152 /*[in]*/ VARIANT Bookmark1,
4153 /*[in]*/ VARIANT Bookmark2,
4154 /*[out,retval]*/ enum CompareEnum* pCompare) = 0;
4155 virtual HRESULT __stdcall raw_Clone(
4156 /*[in]*/ enum LockTypeEnum LockType,
4157 /*[out,retval]*/ struct _Recordset** ppvObject) = 0;
4158 virtual HRESULT __stdcall raw_Resync(
4159 /*[in]*/ enum AffectEnum AffectRecords,
4160 /*[in]*/ enum ResyncEnum ResyncValues) = 0;
4161};
4162
4163struct __declspec(uuid("00001555-0000-0010-8000-00aa006d2ea4")) Recordset21 : Recordset20
4164{
4165 //
4166 // Property data
4167 //
4168
4169 __declspec(property(get = GetIndex, put = PutIndex)) _bstr_t Index;
4170
4171 //
4172 // Wrapper methods for error-handling
4173 //
4174
4175 HRESULT Seek(const _variant_t& KeyValues, enum SeekEnum SeekOption);
4176 void PutIndex(_bstr_t pbstrIndex);
4177 _bstr_t GetIndex();
4178
4179 //
4180 // Raw methods provided by interface
4181 //
4182
4183 virtual HRESULT __stdcall raw_Seek(
4184 /*[in]*/ VARIANT KeyValues,
4185 /*[in]*/ enum SeekEnum SeekOption) = 0;
4186 virtual HRESULT __stdcall put_Index(
4187 /*[in]*/ BSTR pbstrIndex) = 0;
4188 virtual HRESULT __stdcall get_Index(
4189 /*[out,retval]*/ BSTR* pbstrIndex) = 0;
4190};
4191
4192struct __declspec(uuid("00001556-0000-0010-8000-00aa006d2ea4")) _Recordset : Recordset21
4193{
4194 //
4195 // Wrapper methods for error-handling
4196 //
4197
4198 HRESULT Save(const _variant_t& Destination, enum PersistFormatEnum PersistFormat);
4199
4200 //
4201 // Raw methods provided by interface
4202 //
4203
4204 virtual HRESULT __stdcall raw_Save(
4205 /*[in]*/ VARIANT Destination,
4206 /*[in]*/ enum PersistFormatEnum PersistFormat) = 0;
4207};
4208
4209struct __declspec(uuid("00001402-0000-0010-8000-00aa006d2ea4")) ConnectionEventsVt : IUnknown
4210{
4211 //
4212 // Wrapper methods for error-handling
4213 //
4214
4215 HRESULT InfoMessage(struct Error* pError, enum EventStatusEnum* adStatus,
4216 struct _Connection* pConnection);
4217 HRESULT BeginTransComplete(long TransactionLevel, struct Error* pError,
4218 enum EventStatusEnum* adStatus, struct _Connection* pConnection);
4219 HRESULT CommitTransComplete(struct Error* pError, enum EventStatusEnum* adStatus,
4220 struct _Connection* pConnection);
4221 HRESULT RollbackTransComplete(struct Error* pError, enum EventStatusEnum* adStatus,
4222 struct _Connection* pConnection);
4223 HRESULT WillExecute(BSTR* Source, enum CursorTypeEnum* CursorType, enum LockTypeEnum* LockType,
4224 long* Options, enum EventStatusEnum* adStatus, struct _Command* pCommand,
4225 struct _Recordset* pRecordset, struct _Connection* pConnection);
4226 HRESULT ExecuteComplete(long RecordsAffected, struct Error* pError,
4227 enum EventStatusEnum* adStatus, struct _Command* pCommand,
4228 struct _Recordset* pRecordset, struct _Connection* pConnection);
4229 HRESULT WillConnect(BSTR* ConnectionString, BSTR* UserID, BSTR* Password, long* Options,
4230 enum EventStatusEnum* adStatus, struct _Connection* pConnection);
4231 HRESULT ConnectComplete(struct Error* pError, enum EventStatusEnum* adStatus,
4232 struct _Connection* pConnection);
4233 HRESULT Disconnect(enum EventStatusEnum* adStatus, struct _Connection* pConnection);
4234
4235 //
4236 // Raw methods provided by interface
4237 //
4238
4239 virtual HRESULT __stdcall raw_InfoMessage(
4240 /*[in]*/ struct Error* pError,
4241 /*[in,out]*/ enum EventStatusEnum* adStatus,
4242 /*[in]*/ struct _Connection* pConnection) = 0;
4243 virtual HRESULT __stdcall raw_BeginTransComplete(
4244 /*[in]*/ long TransactionLevel,
4245 /*[in]*/ struct Error* pError,
4246 /*[in,out]*/ enum EventStatusEnum* adStatus,
4247 /*[in]*/ struct _Connection* pConnection) = 0;
4248 virtual HRESULT __stdcall raw_CommitTransComplete(
4249 /*[in]*/ struct Error* pError,
4250 /*[in,out]*/ enum EventStatusEnum* adStatus,
4251 /*[in]*/ struct _Connection* pConnection) = 0;
4252 virtual HRESULT __stdcall raw_RollbackTransComplete(
4253 /*[in]*/ struct Error* pError,
4254 /*[in,out]*/ enum EventStatusEnum* adStatus,
4255 /*[in]*/ struct _Connection* pConnection) = 0;
4256 virtual HRESULT __stdcall raw_WillExecute(
4257 /*[in,out]*/ BSTR* Source,
4258 /*[in,out]*/ enum CursorTypeEnum* CursorType,
4259 /*[in,out]*/ enum LockTypeEnum* LockType,
4260 /*[in,out]*/ long* Options,
4261 /*[in,out]*/ enum EventStatusEnum* adStatus,
4262 /*[in]*/ struct _Command* pCommand,
4263 /*[in]*/ struct _Recordset* pRecordset,
4264 /*[in]*/ struct _Connection* pConnection) = 0;
4265 virtual HRESULT __stdcall raw_ExecuteComplete(
4266 /*[in]*/ long RecordsAffected,
4267 /*[in]*/ struct Error* pError,
4268 /*[in,out]*/ enum EventStatusEnum* adStatus,
4269 /*[in]*/ struct _Command* pCommand,
4270 /*[in]*/ struct _Recordset* pRecordset,
4271 /*[in]*/ struct _Connection* pConnection) = 0;
4272 virtual HRESULT __stdcall raw_WillConnect(
4273 /*[in,out]*/ BSTR* ConnectionString,
4274 /*[in,out]*/ BSTR* UserID,
4275 /*[in,out]*/ BSTR* Password,
4276 /*[in,out]*/ long* Options,
4277 /*[in,out]*/ enum EventStatusEnum* adStatus,
4278 /*[in]*/ struct _Connection* pConnection) = 0;
4279 virtual HRESULT __stdcall raw_ConnectComplete(
4280 /*[in]*/ struct Error* pError,
4281 /*[in,out]*/ enum EventStatusEnum* adStatus,
4282 /*[in]*/ struct _Connection* pConnection) = 0;
4283 virtual HRESULT __stdcall raw_Disconnect(
4284 /*[in,out]*/ enum EventStatusEnum* adStatus,
4285 /*[in]*/ struct _Connection* pConnection) = 0;
4286};
4287
4288struct __declspec(uuid("00001403-0000-0010-8000-00aa006d2ea4")) RecordsetEventsVt : IUnknown
4289{
4290 //
4291 // Wrapper methods for error-handling
4292 //
4293
4294 HRESULT WillChangeField(long cFields, const _variant_t& Fields, enum EventStatusEnum* adStatus,
4295 struct _Recordset* pRecordset);
4296 HRESULT FieldChangeComplete(long cFields, const _variant_t& Fields, struct Error* pError,
4297 enum EventStatusEnum* adStatus, struct _Recordset* pRecordset);
4298 HRESULT WillChangeRecord(enum EventReasonEnum adReason, long cRecords,
4299 enum EventStatusEnum* adStatus, struct _Recordset* pRecordset);
4300 HRESULT RecordChangeComplete(enum EventReasonEnum adReason, long cRecords, struct Error* pError,
4301 enum EventStatusEnum* adStatus, struct _Recordset* pRecordset);
4302 HRESULT WillChangeRecordset(enum EventReasonEnum adReason, enum EventStatusEnum* adStatus,
4303 struct _Recordset* pRecordset);
4304 HRESULT RecordsetChangeComplete(enum EventReasonEnum adReason, struct Error* pError,
4305 enum EventStatusEnum* adStatus, struct _Recordset* pRecordset);
4306 HRESULT WillMove(enum EventReasonEnum adReason, enum EventStatusEnum* adStatus,
4307 struct _Recordset* pRecordset);
4308 HRESULT MoveComplete(enum EventReasonEnum adReason, struct Error* pError,
4309 enum EventStatusEnum* adStatus, struct _Recordset* pRecordset);
4310 HRESULT EndOfRecordset(VARIANT_BOOL* fMoreData, enum EventStatusEnum* adStatus,
4311 struct _Recordset* pRecordset);
4312 HRESULT FetchProgress(long Progress, long MaxProgress, enum EventStatusEnum* adStatus,
4313 struct _Recordset* pRecordset);
4314 HRESULT FetchComplete(struct Error* pError, enum EventStatusEnum* adStatus,
4315 struct _Recordset* pRecordset);
4316
4317 //
4318 // Raw methods provided by interface
4319 //
4320
4321 virtual HRESULT __stdcall raw_WillChangeField(
4322 /*[in]*/ long cFields,
4323 /*[in]*/ VARIANT Fields,
4324 /*[in,out]*/ enum EventStatusEnum* adStatus,
4325 /*[in]*/ struct _Recordset* pRecordset) = 0;
4326 virtual HRESULT __stdcall raw_FieldChangeComplete(
4327 /*[in]*/ long cFields,
4328 /*[in]*/ VARIANT Fields,
4329 /*[in]*/ struct Error* pError,
4330 /*[in,out]*/ enum EventStatusEnum* adStatus,
4331 /*[in]*/ struct _Recordset* pRecordset) = 0;
4332 virtual HRESULT __stdcall raw_WillChangeRecord(
4333 /*[in]*/ enum EventReasonEnum adReason,
4334 /*[in]*/ long cRecords,
4335 /*[in,out]*/ enum EventStatusEnum* adStatus,
4336 /*[in]*/ struct _Recordset* pRecordset) = 0;
4337 virtual HRESULT __stdcall raw_RecordChangeComplete(
4338 /*[in]*/ enum EventReasonEnum adReason,
4339 /*[in]*/ long cRecords,
4340 /*[in]*/ struct Error* pError,
4341 /*[in,out]*/ enum EventStatusEnum* adStatus,
4342 /*[in]*/ struct _Recordset* pRecordset) = 0;
4343 virtual HRESULT __stdcall raw_WillChangeRecordset(
4344 /*[in]*/ enum EventReasonEnum adReason,
4345 /*[in,out]*/ enum EventStatusEnum* adStatus,
4346 /*[in]*/ struct _Recordset* pRecordset) = 0;
4347 virtual HRESULT __stdcall raw_RecordsetChangeComplete(
4348 /*[in]*/ enum EventReasonEnum adReason,
4349 /*[in]*/ struct Error* pError,
4350 /*[in,out]*/ enum EventStatusEnum* adStatus,
4351 /*[in]*/ struct _Recordset* pRecordset) = 0;
4352 virtual HRESULT __stdcall raw_WillMove(
4353 /*[in]*/ enum EventReasonEnum adReason,
4354 /*[in,out]*/ enum EventStatusEnum* adStatus,
4355 /*[in]*/ struct _Recordset* pRecordset) = 0;
4356 virtual HRESULT __stdcall raw_MoveComplete(
4357 /*[in]*/ enum EventReasonEnum adReason,
4358 /*[in]*/ struct Error* pError,
4359 /*[in,out]*/ enum EventStatusEnum* adStatus,
4360 /*[in]*/ struct _Recordset* pRecordset) = 0;
4361 virtual HRESULT __stdcall raw_EndOfRecordset(
4362 /*[in,out]*/ VARIANT_BOOL* fMoreData,
4363 /*[in,out]*/ enum EventStatusEnum* adStatus,
4364 /*[in]*/ struct _Recordset* pRecordset) = 0;
4365 virtual HRESULT __stdcall raw_FetchProgress(
4366 /*[in]*/ long Progress,
4367 /*[in]*/ long MaxProgress,
4368 /*[in,out]*/ enum EventStatusEnum* adStatus,
4369 /*[in]*/ struct _Recordset* pRecordset) = 0;
4370 virtual HRESULT __stdcall raw_FetchComplete(
4371 /*[in]*/ struct Error* pError,
4372 /*[in,out]*/ enum EventStatusEnum* adStatus,
4373 /*[in]*/ struct _Recordset* pRecordset) = 0;
4374};
4375
4376struct __declspec(uuid("00001562-0000-0010-8000-00aa006d2ea4")) _Record : _ADO
4377{
4378 //
4379 // Property data
4380 //
4381
4382 __declspec(property(get = GetFields)) FieldsPtr Fields;
4383 __declspec(property(get = GetState)) enum ObjectStateEnum State;
4384 __declspec(property(get = GetMode, put = PutMode)) enum ConnectModeEnum Mode;
4385 __declspec(property(get = GetParentURL)) _bstr_t ParentURL;
4386 __declspec(property(get = GetRecordType)) enum RecordTypeEnum RecordType;
4387
4388 //
4389 // Wrapper methods for error-handling
4390 //
4391
4392 _variant_t GetActiveConnection();
4393 void PutActiveConnection(_bstr_t pvar);
4394 void PutRefActiveConnection(struct _Connection* pvar);
4395 enum ObjectStateEnum GetState();
4396 _variant_t GetSource();
4397 void PutSource(_bstr_t pvar);
4398 void PutRefSource(IDispatch* pvar);
4399 enum ConnectModeEnum GetMode();
4400 void PutMode(enum ConnectModeEnum pMode);
4401 _bstr_t GetParentURL();
4402 _bstr_t MoveRecord(_bstr_t Source, _bstr_t Destination, _bstr_t UserName, _bstr_t Password,
4403 enum MoveRecordOptionsEnum Options, VARIANT_BOOL Async);
4404 _bstr_t CopyRecord(_bstr_t Source, _bstr_t Destination, _bstr_t UserName, _bstr_t Password,
4405 enum CopyRecordOptionsEnum Options, VARIANT_BOOL Async);
4406 HRESULT DeleteRecord(_bstr_t Source, VARIANT_BOOL Async);
4407 HRESULT Open(const _variant_t& Source, const _variant_t& ActiveConnection,
4408 enum ConnectModeEnum Mode, enum RecordCreateOptionsEnum CreateOptions,
4409 enum RecordOpenOptionsEnum Options, _bstr_t UserName, _bstr_t Password);
4410 HRESULT Close();
4411 FieldsPtr GetFields();
4412 enum RecordTypeEnum GetRecordType();
4413 _RecordsetPtr GetChildren();
4414 HRESULT Cancel();
4415
4416 //
4417 // Raw methods provided by interface
4418 //
4419
4420 virtual HRESULT __stdcall get_ActiveConnection(
4421 /*[out,retval]*/ VARIANT* pvar) = 0;
4422 virtual HRESULT __stdcall put_ActiveConnection(
4423 /*[in]*/ BSTR pvar) = 0;
4424 virtual HRESULT __stdcall putref_ActiveConnection(
4425 /*[in]*/ struct _Connection* pvar) = 0;
4426 virtual HRESULT __stdcall get_State(
4427 /*[out,retval]*/ enum ObjectStateEnum* pState) = 0;
4428 virtual HRESULT __stdcall get_Source(
4429 /*[out,retval]*/ VARIANT* pvar) = 0;
4430 virtual HRESULT __stdcall put_Source(
4431 /*[in]*/ BSTR pvar) = 0;
4432 virtual HRESULT __stdcall putref_Source(
4433 /*[in]*/ IDispatch* pvar) = 0;
4434 virtual HRESULT __stdcall get_Mode(
4435 /*[out,retval]*/ enum ConnectModeEnum* pMode) = 0;
4436 virtual HRESULT __stdcall put_Mode(
4437 /*[in]*/ enum ConnectModeEnum pMode) = 0;
4438 virtual HRESULT __stdcall get_ParentURL(
4439 /*[out,retval]*/ BSTR* pbstrParentURL) = 0;
4440 virtual HRESULT __stdcall raw_MoveRecord(
4441 /*[in]*/ BSTR Source,
4442 /*[in]*/ BSTR Destination,
4443 /*[in]*/ BSTR UserName,
4444 /*[in]*/ BSTR Password,
4445 /*[in]*/ enum MoveRecordOptionsEnum Options,
4446 /*[in]*/ VARIANT_BOOL Async,
4447 /*[out,retval]*/ BSTR* pbstrNewURL) = 0;
4448 virtual HRESULT __stdcall raw_CopyRecord(
4449 /*[in]*/ BSTR Source,
4450 /*[in]*/ BSTR Destination,
4451 /*[in]*/ BSTR UserName,
4452 /*[in]*/ BSTR Password,
4453 /*[in]*/ enum CopyRecordOptionsEnum Options,
4454 /*[in]*/ VARIANT_BOOL Async,
4455 /*[out,retval]*/ BSTR* pbstrNewURL) = 0;
4456 virtual HRESULT __stdcall raw_DeleteRecord(
4457 /*[in]*/ BSTR Source,
4458 /*[in]*/ VARIANT_BOOL Async) = 0;
4459 virtual HRESULT __stdcall raw_Open(
4460 /*[in]*/ VARIANT Source,
4461 /*[in]*/ VARIANT ActiveConnection,
4462 /*[in]*/ enum ConnectModeEnum Mode,
4463 /*[in]*/ enum RecordCreateOptionsEnum CreateOptions,
4464 /*[in]*/ enum RecordOpenOptionsEnum Options,
4465 /*[in]*/ BSTR UserName,
4466 /*[in]*/ BSTR Password) = 0;
4467 virtual HRESULT __stdcall raw_Close() = 0;
4468 virtual HRESULT __stdcall get_Fields(
4469 /*[out,retval]*/ struct Fields** ppFlds) = 0;
4470 virtual HRESULT __stdcall get_RecordType(
4471 /*[out,retval]*/ enum RecordTypeEnum* ptype) = 0;
4472 virtual HRESULT __stdcall raw_GetChildren(
4473 /*[out,retval]*/ struct _Recordset** pprset) = 0;
4474 virtual HRESULT __stdcall raw_Cancel() = 0;
4475};
4476
4477struct __declspec(uuid("00000402-0000-0010-8000-00aa006d2ea4")) ConnectionEventsVt_Deprecated
4478 : IUnknown
4479{
4480 //
4481 // Wrapper methods for error-handling
4482 //
4483
4484 HRESULT InfoMessage(struct Error* pError, enum EventStatusEnum* adStatus,
4485 struct _Connection_Deprecated* pConnection);
4486 HRESULT BeginTransComplete(long TransactionLevel, struct Error* pError,
4487 enum EventStatusEnum* adStatus,
4488 struct _Connection_Deprecated* pConnection);
4489 HRESULT CommitTransComplete(struct Error* pError, enum EventStatusEnum* adStatus,
4490 struct _Connection_Deprecated* pConnection);
4491 HRESULT RollbackTransComplete(struct Error* pError, enum EventStatusEnum* adStatus,
4492 struct _Connection_Deprecated* pConnection);
4493 HRESULT WillExecute(BSTR* Source, enum CursorTypeEnum* CursorType, enum LockTypeEnum* LockType,
4494 long* Options, enum EventStatusEnum* adStatus,
4495 struct _Command_Deprecated* pCommand,
4496 struct _Recordset_Deprecated* pRecordset,
4497 struct _Connection_Deprecated* pConnection);
4498 HRESULT ExecuteComplete(long RecordsAffected, struct Error* pError,
4499 enum EventStatusEnum* adStatus, struct _Command_Deprecated* pCommand,
4500 struct _Recordset_Deprecated* pRecordset,
4501 struct _Connection_Deprecated* pConnection);
4502 HRESULT WillConnect(BSTR* ConnectionString, BSTR* UserID, BSTR* Password, long* Options,
4503 enum EventStatusEnum* adStatus, struct _Connection_Deprecated* pConnection);
4504 HRESULT ConnectComplete(struct Error* pError, enum EventStatusEnum* adStatus,
4505 struct _Connection_Deprecated* pConnection);
4506 HRESULT Disconnect(enum EventStatusEnum* adStatus, struct _Connection_Deprecated* pConnection);
4507
4508 //
4509 // Raw methods provided by interface
4510 //
4511
4512 virtual HRESULT __stdcall raw_InfoMessage(
4513 /*[in]*/ struct Error* pError,
4514 /*[in,out]*/ enum EventStatusEnum* adStatus,
4515 /*[in]*/ struct _Connection_Deprecated* pConnection) = 0;
4516 virtual HRESULT __stdcall raw_BeginTransComplete(
4517 /*[in]*/ long TransactionLevel,
4518 /*[in]*/ struct Error* pError,
4519 /*[in,out]*/ enum EventStatusEnum* adStatus,
4520 /*[in]*/ struct _Connection_Deprecated* pConnection) = 0;
4521 virtual HRESULT __stdcall raw_CommitTransComplete(
4522 /*[in]*/ struct Error* pError,
4523 /*[in,out]*/ enum EventStatusEnum* adStatus,
4524 /*[in]*/ struct _Connection_Deprecated* pConnection) = 0;
4525 virtual HRESULT __stdcall raw_RollbackTransComplete(
4526 /*[in]*/ struct Error* pError,
4527 /*[in,out]*/ enum EventStatusEnum* adStatus,
4528 /*[in]*/ struct _Connection_Deprecated* pConnection) = 0;
4529 virtual HRESULT __stdcall raw_WillExecute(
4530 /*[in,out]*/ BSTR* Source,
4531 /*[in,out]*/ enum CursorTypeEnum* CursorType,
4532 /*[in,out]*/ enum LockTypeEnum* LockType,
4533 /*[in,out]*/ long* Options,
4534 /*[in,out]*/ enum EventStatusEnum* adStatus,
4535 /*[in]*/ struct _Command_Deprecated* pCommand,
4536 /*[in]*/ struct _Recordset_Deprecated* pRecordset,
4537 /*[in]*/ struct _Connection_Deprecated* pConnection) = 0;
4538 virtual HRESULT __stdcall raw_ExecuteComplete(
4539 /*[in]*/ long RecordsAffected,
4540 /*[in]*/ struct Error* pError,
4541 /*[in,out]*/ enum EventStatusEnum* adStatus,
4542 /*[in]*/ struct _Command_Deprecated* pCommand,
4543 /*[in]*/ struct _Recordset_Deprecated* pRecordset,
4544 /*[in]*/ struct _Connection_Deprecated* pConnection) = 0;
4545 virtual HRESULT __stdcall raw_WillConnect(
4546 /*[in,out]*/ BSTR* ConnectionString,
4547 /*[in,out]*/ BSTR* UserID,
4548 /*[in,out]*/ BSTR* Password,
4549 /*[in,out]*/ long* Options,
4550 /*[in,out]*/ enum EventStatusEnum* adStatus,
4551 /*[in]*/ struct _Connection_Deprecated* pConnection) = 0;
4552 virtual HRESULT __stdcall raw_ConnectComplete(
4553 /*[in]*/ struct Error* pError,
4554 /*[in,out]*/ enum EventStatusEnum* adStatus,
4555 /*[in]*/ struct _Connection_Deprecated* pConnection) = 0;
4556 virtual HRESULT __stdcall raw_Disconnect(
4557 /*[in,out]*/ enum EventStatusEnum* adStatus,
4558 /*[in]*/ struct _Connection_Deprecated* pConnection) = 0;
4559};
4560
4561struct __declspec(uuid("00000515-0000-0010-8000-00aa006d2ea4")) Connection15_Deprecated : _ADO
4562{
4563 //
4564 // Property data
4565 //
4566
4567 __declspec(property(get = GetConnectionString,
4568 put = PutConnectionString)) _bstr_t ConnectionString;
4569 __declspec(property(get = GetCommandTimeout, put = PutCommandTimeout)) long CommandTimeout;
4570 __declspec(property(get = GetConnectionTimeout,
4571 put = PutConnectionTimeout)) long ConnectionTimeout;
4572 __declspec(property(get = GetVersion)) _bstr_t Version;
4573 __declspec(property(get = GetErrors)) ErrorsPtr Errors;
4574 __declspec(property(get = GetDefaultDatabase,
4575 put = PutDefaultDatabase)) _bstr_t DefaultDatabase;
4576 __declspec(property(get = GetIsolationLevel,
4577 put = PutIsolationLevel)) enum IsolationLevelEnum IsolationLevel;
4578 __declspec(property(get = GetAttributes, put = PutAttributes)) long Attributes;
4579 __declspec(property(get = GetCursorLocation,
4580 put = PutCursorLocation)) enum CursorLocationEnum CursorLocation;
4581 __declspec(property(get = GetMode, put = PutMode)) enum ConnectModeEnum Mode;
4582 __declspec(property(get = GetProvider, put = PutProvider)) _bstr_t Provider;
4583 __declspec(property(get = GetState)) long State;
4584
4585 //
4586 // Wrapper methods for error-handling
4587 //
4588
4589 _bstr_t GetConnectionString();
4590 void PutConnectionString(_bstr_t pbstr);
4591 long GetCommandTimeout();
4592 void PutCommandTimeout(long plTimeout);
4593 long GetConnectionTimeout();
4594 void PutConnectionTimeout(long plTimeout);
4595 _bstr_t GetVersion();
4596 HRESULT Close();
4597 _Recordset_DeprecatedPtr Execute(_bstr_t CommandText, VARIANT* RecordsAffected, long Options);
4598 long BeginTrans();
4599 HRESULT CommitTrans();
4600 HRESULT RollbackTrans();
4601 HRESULT Open(_bstr_t ConnectionString, _bstr_t UserID, _bstr_t Password, long Options);
4602 ErrorsPtr GetErrors();
4603 _bstr_t GetDefaultDatabase();
4604 void PutDefaultDatabase(_bstr_t pbstr);
4605 enum IsolationLevelEnum GetIsolationLevel();
4606 void PutIsolationLevel(enum IsolationLevelEnum Level);
4607 long GetAttributes();
4608 void PutAttributes(long plAttr);
4609 enum CursorLocationEnum GetCursorLocation();
4610 void PutCursorLocation(enum CursorLocationEnum plCursorLoc);
4611 enum ConnectModeEnum GetMode();
4612 void PutMode(enum ConnectModeEnum plMode);
4613 _bstr_t GetProvider();
4614 void PutProvider(_bstr_t pbstr);
4615 long GetState();
4616 _Recordset_DeprecatedPtr OpenSchema(enum SchemaEnum Schema,
4617 const _variant_t& Restrictions = vtMissing,
4618 const _variant_t& SchemaID = vtMissing);
4619
4620 //
4621 // Raw methods provided by interface
4622 //
4623
4624 virtual HRESULT __stdcall get_ConnectionString(
4625 /*[out,retval]*/ BSTR* pbstr) = 0;
4626 virtual HRESULT __stdcall put_ConnectionString(
4627 /*[in]*/ BSTR pbstr) = 0;
4628 virtual HRESULT __stdcall get_CommandTimeout(
4629 /*[out,retval]*/ long* plTimeout) = 0;
4630 virtual HRESULT __stdcall put_CommandTimeout(
4631 /*[in]*/ long plTimeout) = 0;
4632 virtual HRESULT __stdcall get_ConnectionTimeout(
4633 /*[out,retval]*/ long* plTimeout) = 0;
4634 virtual HRESULT __stdcall put_ConnectionTimeout(
4635 /*[in]*/ long plTimeout) = 0;
4636 virtual HRESULT __stdcall get_Version(
4637 /*[out,retval]*/ BSTR* pbstr) = 0;
4638 virtual HRESULT __stdcall raw_Close() = 0;
4639 virtual HRESULT __stdcall raw_Execute(
4640 /*[in]*/ BSTR CommandText,
4641 /*[out]*/ VARIANT* RecordsAffected,
4642 /*[in]*/ long Options,
4643 /*[out,retval]*/ struct _Recordset_Deprecated** ppiRset) = 0;
4644 virtual HRESULT __stdcall raw_BeginTrans(
4645 /*[out,retval]*/ long* TransactionLevel) = 0;
4646 virtual HRESULT __stdcall raw_CommitTrans() = 0;
4647 virtual HRESULT __stdcall raw_RollbackTrans() = 0;
4648 virtual HRESULT __stdcall raw_Open(
4649 /*[in]*/ BSTR ConnectionString,
4650 /*[in]*/ BSTR UserID,
4651 /*[in]*/ BSTR Password,
4652 /*[in]*/ long Options) = 0;
4653 virtual HRESULT __stdcall get_Errors(
4654 /*[out,retval]*/ struct Errors** ppvObject) = 0;
4655 virtual HRESULT __stdcall get_DefaultDatabase(
4656 /*[out,retval]*/ BSTR* pbstr) = 0;
4657 virtual HRESULT __stdcall put_DefaultDatabase(
4658 /*[in]*/ BSTR pbstr) = 0;
4659 virtual HRESULT __stdcall get_IsolationLevel(
4660 /*[out,retval]*/ enum IsolationLevelEnum* Level) = 0;
4661 virtual HRESULT __stdcall put_IsolationLevel(
4662 /*[in]*/ enum IsolationLevelEnum Level) = 0;
4663 virtual HRESULT __stdcall get_Attributes(
4664 /*[out,retval]*/ long* plAttr) = 0;
4665 virtual HRESULT __stdcall put_Attributes(
4666 /*[in]*/ long plAttr) = 0;
4667 virtual HRESULT __stdcall get_CursorLocation(
4668 /*[out,retval]*/ enum CursorLocationEnum* plCursorLoc) = 0;
4669 virtual HRESULT __stdcall put_CursorLocation(
4670 /*[in]*/ enum CursorLocationEnum plCursorLoc) = 0;
4671 virtual HRESULT __stdcall get_Mode(
4672 /*[out,retval]*/ enum ConnectModeEnum* plMode) = 0;
4673 virtual HRESULT __stdcall put_Mode(
4674 /*[in]*/ enum ConnectModeEnum plMode) = 0;
4675 virtual HRESULT __stdcall get_Provider(
4676 /*[out,retval]*/ BSTR* pbstr) = 0;
4677 virtual HRESULT __stdcall put_Provider(
4678 /*[in]*/ BSTR pbstr) = 0;
4679 virtual HRESULT __stdcall get_State(
4680 /*[out,retval]*/ long* plObjState) = 0;
4681 virtual HRESULT __stdcall raw_OpenSchema(
4682 /*[in]*/ enum SchemaEnum Schema,
4683 /*[in]*/ VARIANT Restrictions,
4684 /*[in]*/ VARIANT SchemaID,
4685 /*[out,retval]*/ struct _Recordset_Deprecated** pprset) = 0;
4686};
4687
4688struct __declspec(uuid("00000550-0000-0010-8000-00aa006d2ea4")) _Connection_Deprecated
4689 : Connection15_Deprecated
4690{
4691 //
4692 // Wrapper methods for error-handling
4693 //
4694
4695 HRESULT Cancel();
4696
4697 //
4698 // Raw methods provided by interface
4699 //
4700
4701 virtual HRESULT __stdcall raw_Cancel() = 0;
4702};
4703
4704struct __declspec(uuid("0000050e-0000-0010-8000-00aa006d2ea4")) Recordset15_Deprecated : _ADO
4705{
4706 //
4707 // Property data
4708 //
4709
4710 __declspec(property(get = GetFields)) Fields_DeprecatedPtr Fields;
4711 __declspec(property(get = GetPageSize, put = PutPageSize)) long PageSize;
4712 __declspec(property(get = GetPageCount)) ADO_LONGPTR PageCount;
4713 __declspec(property(get = GetCursorLocation,
4714 put = PutCursorLocation)) enum CursorLocationEnum CursorLocation;
4715 __declspec(property(get = GetState)) long State;
4716 __declspec(property(get = GetMarshalOptions,
4717 put = PutMarshalOptions)) enum MarshalOptionsEnum MarshalOptions;
4718 __declspec(property(get = GetCollect, put = PutCollect)) _variant_t Collect[];
4719 __declspec(property(get = GetEditMode)) enum EditModeEnum EditMode;
4720 __declspec(property(get = GetStatus)) long Status;
4721 __declspec(property(get = GetFilter, put = PutFilter)) _variant_t Filter;
4722 __declspec(property(get = GetSort, put = PutSort)) _bstr_t Sort;
4723 __declspec(property(get = GetAbsolutePosition,
4724 put = PutAbsolutePosition)) PositionEnum_Param AbsolutePosition;
4725 __declspec(property(get = GetbBOF)) VARIANT_BOOL bBOF;
4726 __declspec(property(get = GetBookmark, put = PutBookmark)) _variant_t Bookmark;
4727 __declspec(property(get = GetCacheSize, put = PutCacheSize)) long CacheSize;
4728 __declspec(property(get = GetCursorType, put = PutCursorType)) enum CursorTypeEnum CursorType;
4729 __declspec(property(get = GetbEOF)) VARIANT_BOOL bEOF;
4730 __declspec(property(get = GetAbsolutePage,
4731 put = PutAbsolutePage)) PositionEnum_Param AbsolutePage;
4732 __declspec(property(get = GetLockType, put = PutLockType)) enum LockTypeEnum LockType;
4733 __declspec(property(get = GetMaxRecords, put = PutMaxRecords)) ADO_LONGPTR MaxRecords;
4734 __declspec(property(get = GetRecordCount)) ADO_LONGPTR RecordCount;
4735
4736 //
4737 // Wrapper methods for error-handling
4738 //
4739
4740 PositionEnum_Param GetAbsolutePosition();
4741 void PutAbsolutePosition(PositionEnum_Param pl);
4742 void PutRefActiveConnection(IDispatch* pvar);
4743 void PutActiveConnection(const _variant_t& pvar);
4744 _variant_t GetActiveConnection();
4745 VARIANT_BOOL GetbBOF();
4746 _variant_t GetBookmark();
4747 void PutBookmark(const _variant_t& pvBookmark);
4748 long GetCacheSize();
4749 void PutCacheSize(long pl);
4750 enum CursorTypeEnum GetCursorType();
4751 void PutCursorType(enum CursorTypeEnum plCursorType);
4752 VARIANT_BOOL GetbEOF();
4753 Fields_DeprecatedPtr GetFields();
4754 enum LockTypeEnum GetLockType();
4755 void PutLockType(enum LockTypeEnum plLockType);
4756 ADO_LONGPTR GetMaxRecords();
4757 void PutMaxRecords(ADO_LONGPTR plMaxRecords);
4758 ADO_LONGPTR GetRecordCount();
4759 void PutRefSource(IDispatch* pvSource);
4760 void PutSource(_bstr_t pvSource);
4761 _variant_t GetSource();
4762 HRESULT AddNew(const _variant_t& FieldList = vtMissing, const _variant_t& Values = vtMissing);
4763 HRESULT CancelUpdate();
4764 HRESULT Close();
4765 HRESULT Delete(enum AffectEnum AffectRecords);
4766 _variant_t GetRows(long Rows, const _variant_t& Start = vtMissing,
4767 const _variant_t& Fields = vtMissing);
4768 HRESULT Move(ADO_LONGPTR NumRecords, const _variant_t& Start = vtMissing);
4769 HRESULT MoveNext();
4770 HRESULT MovePrevious();
4771 HRESULT MoveFirst();
4772 HRESULT MoveLast();
4773 HRESULT Open(const _variant_t& Source, const _variant_t& ActiveConnection,
4774 enum CursorTypeEnum CursorType, enum LockTypeEnum LockType, long Options);
4775 HRESULT Requery(long Options);
4776 HRESULT _xResync(enum AffectEnum AffectRecords);
4777 HRESULT Update(const _variant_t& Fields = vtMissing, const _variant_t& Values = vtMissing);
4778 PositionEnum_Param GetAbsolutePage();
4779 void PutAbsolutePage(PositionEnum_Param pl);
4780 enum EditModeEnum GetEditMode();
4781 _variant_t GetFilter();
4782 void PutFilter(const _variant_t& Criteria);
4783 ADO_LONGPTR GetPageCount();
4784 long GetPageSize();
4785 void PutPageSize(long pl);
4786 _bstr_t GetSort();
4787 void PutSort(_bstr_t Criteria);
4788 long GetStatus();
4789 long GetState();
4790 _Recordset_DeprecatedPtr _xClone();
4791 HRESULT UpdateBatch(enum AffectEnum AffectRecords);
4792 HRESULT CancelBatch(enum AffectEnum AffectRecords);
4793 enum CursorLocationEnum GetCursorLocation();
4794 void PutCursorLocation(enum CursorLocationEnum plCursorLoc);
4795 _Recordset_DeprecatedPtr NextRecordset(VARIANT* RecordsAffected);
4796 VARIANT_BOOL Supports(enum CursorOptionEnum CursorOptions);
4797 _variant_t GetCollect(const _variant_t& Index);
4798 void PutCollect(const _variant_t& Index, const _variant_t& pvar);
4799 enum MarshalOptionsEnum GetMarshalOptions();
4800 void PutMarshalOptions(enum MarshalOptionsEnum peMarshal);
4801 HRESULT Find(_bstr_t Criteria, ADO_LONGPTR SkipRecords,
4802 enum SearchDirectionEnum SearchDirection, const _variant_t& Start = vtMissing);
4803
4804 //
4805 // Raw methods provided by interface
4806 //
4807
4808 virtual HRESULT __stdcall get_AbsolutePosition(
4809 /*[out,retval]*/ PositionEnum_Param* pl) = 0;
4810 virtual HRESULT __stdcall put_AbsolutePosition(
4811 /*[in]*/ PositionEnum_Param pl) = 0;
4812 virtual HRESULT __stdcall putref_ActiveConnection(
4813 /*[in]*/ IDispatch* pvar) = 0;
4814 virtual HRESULT __stdcall put_ActiveConnection(
4815 /*[in]*/ VARIANT pvar) = 0;
4816 virtual HRESULT __stdcall get_ActiveConnection(
4817 /*[out,retval]*/ VARIANT* pvar) = 0;
4818 virtual HRESULT __stdcall get_bBOF(
4819 /*[out,retval]*/ VARIANT_BOOL* pb) = 0;
4820 virtual HRESULT __stdcall get_Bookmark(
4821 /*[out,retval]*/ VARIANT* pvBookmark) = 0;
4822 virtual HRESULT __stdcall put_Bookmark(
4823 /*[in]*/ VARIANT pvBookmark) = 0;
4824 virtual HRESULT __stdcall get_CacheSize(
4825 /*[out,retval]*/ long* pl) = 0;
4826 virtual HRESULT __stdcall put_CacheSize(
4827 /*[in]*/ long pl) = 0;
4828 virtual HRESULT __stdcall get_CursorType(
4829 /*[out,retval]*/ enum CursorTypeEnum* plCursorType) = 0;
4830 virtual HRESULT __stdcall put_CursorType(
4831 /*[in]*/ enum CursorTypeEnum plCursorType) = 0;
4832 virtual HRESULT __stdcall get_bEOF(
4833 /*[out,retval]*/ VARIANT_BOOL* pb) = 0;
4834 virtual HRESULT __stdcall get_Fields(
4835 /*[out,retval]*/ struct Fields_Deprecated** ppvObject) = 0;
4836 virtual HRESULT __stdcall get_LockType(
4837 /*[out,retval]*/ enum LockTypeEnum* plLockType) = 0;
4838 virtual HRESULT __stdcall put_LockType(
4839 /*[in]*/ enum LockTypeEnum plLockType) = 0;
4840 virtual HRESULT __stdcall get_MaxRecords(
4841 /*[out,retval]*/ ADO_LONGPTR* plMaxRecords) = 0;
4842 virtual HRESULT __stdcall put_MaxRecords(
4843 /*[in]*/ ADO_LONGPTR plMaxRecords) = 0;
4844 virtual HRESULT __stdcall get_RecordCount(
4845 /*[out,retval]*/ ADO_LONGPTR* pl) = 0;
4846 virtual HRESULT __stdcall putref_Source(
4847 /*[in]*/ IDispatch* pvSource) = 0;
4848 virtual HRESULT __stdcall put_Source(
4849 /*[in]*/ BSTR pvSource) = 0;
4850 virtual HRESULT __stdcall get_Source(
4851 /*[out,retval]*/ VARIANT* pvSource) = 0;
4852 virtual HRESULT __stdcall raw_AddNew(
4853 /*[in]*/ VARIANT FieldList = vtMissing,
4854 /*[in]*/ VARIANT Values = vtMissing) = 0;
4855 virtual HRESULT __stdcall raw_CancelUpdate() = 0;
4856 virtual HRESULT __stdcall raw_Close() = 0;
4857 virtual HRESULT __stdcall raw_Delete(
4858 /*[in]*/ enum AffectEnum AffectRecords) = 0;
4859 virtual HRESULT __stdcall raw_GetRows(
4860 /*[in]*/ long Rows,
4861 /*[in]*/ VARIANT Start,
4862 /*[in]*/ VARIANT Fields,
4863 /*[out,retval]*/ VARIANT* pvar) = 0;
4864 virtual HRESULT __stdcall raw_Move(
4865 /*[in]*/ ADO_LONGPTR NumRecords,
4866 /*[in]*/ VARIANT Start = vtMissing) = 0;
4867 virtual HRESULT __stdcall raw_MoveNext() = 0;
4868 virtual HRESULT __stdcall raw_MovePrevious() = 0;
4869 virtual HRESULT __stdcall raw_MoveFirst() = 0;
4870 virtual HRESULT __stdcall raw_MoveLast() = 0;
4871 virtual HRESULT __stdcall raw_Open(
4872 /*[in]*/ VARIANT Source,
4873 /*[in]*/ VARIANT ActiveConnection,
4874 /*[in]*/ enum CursorTypeEnum CursorType,
4875 /*[in]*/ enum LockTypeEnum LockType,
4876 /*[in]*/ long Options) = 0;
4877 virtual HRESULT __stdcall raw_Requery(
4878 /*[in]*/ long Options) = 0;
4879 virtual HRESULT __stdcall raw__xResync(
4880 /*[in]*/ enum AffectEnum AffectRecords) = 0;
4881 virtual HRESULT __stdcall raw_Update(
4882 /*[in]*/ VARIANT Fields = vtMissing,
4883 /*[in]*/ VARIANT Values = vtMissing) = 0;
4884 virtual HRESULT __stdcall get_AbsolutePage(
4885 /*[out,retval]*/ PositionEnum_Param* pl) = 0;
4886 virtual HRESULT __stdcall put_AbsolutePage(
4887 /*[in]*/ PositionEnum_Param pl) = 0;
4888 virtual HRESULT __stdcall get_EditMode(
4889 /*[out,retval]*/ enum EditModeEnum* pl) = 0;
4890 virtual HRESULT __stdcall get_Filter(
4891 /*[out,retval]*/ VARIANT* Criteria) = 0;
4892 virtual HRESULT __stdcall put_Filter(
4893 /*[in]*/ VARIANT Criteria) = 0;
4894 virtual HRESULT __stdcall get_PageCount(
4895 /*[out,retval]*/ ADO_LONGPTR* pl) = 0;
4896 virtual HRESULT __stdcall get_PageSize(
4897 /*[out,retval]*/ long* pl) = 0;
4898 virtual HRESULT __stdcall put_PageSize(
4899 /*[in]*/ long pl) = 0;
4900 virtual HRESULT __stdcall get_Sort(
4901 /*[out,retval]*/ BSTR* Criteria) = 0;
4902 virtual HRESULT __stdcall put_Sort(
4903 /*[in]*/ BSTR Criteria) = 0;
4904 virtual HRESULT __stdcall get_Status(
4905 /*[out,retval]*/ long* pl) = 0;
4906 virtual HRESULT __stdcall get_State(
4907 /*[out,retval]*/ long* plObjState) = 0;
4908 virtual HRESULT __stdcall raw__xClone(
4909 /*[out,retval]*/ struct _Recordset_Deprecated** ppvObject) = 0;
4910 virtual HRESULT __stdcall raw_UpdateBatch(
4911 /*[in]*/ enum AffectEnum AffectRecords) = 0;
4912 virtual HRESULT __stdcall raw_CancelBatch(
4913 /*[in]*/ enum AffectEnum AffectRecords) = 0;
4914 virtual HRESULT __stdcall get_CursorLocation(
4915 /*[out,retval]*/ enum CursorLocationEnum* plCursorLoc) = 0;
4916 virtual HRESULT __stdcall put_CursorLocation(
4917 /*[in]*/ enum CursorLocationEnum plCursorLoc) = 0;
4918 virtual HRESULT __stdcall raw_NextRecordset(
4919 /*[out]*/ VARIANT* RecordsAffected,
4920 /*[out,retval]*/ struct _Recordset_Deprecated** ppiRs) = 0;
4921 virtual HRESULT __stdcall raw_Supports(
4922 /*[in]*/ enum CursorOptionEnum CursorOptions,
4923 /*[out,retval]*/ VARIANT_BOOL* pb) = 0;
4924 virtual HRESULT __stdcall get_Collect(
4925 /*[in]*/ VARIANT Index,
4926 /*[out,retval]*/ VARIANT* pvar) = 0;
4927 virtual HRESULT __stdcall put_Collect(
4928 /*[in]*/ VARIANT Index,
4929 /*[in]*/ VARIANT pvar) = 0;
4930 virtual HRESULT __stdcall get_MarshalOptions(
4931 /*[out,retval]*/ enum MarshalOptionsEnum* peMarshal) = 0;
4932 virtual HRESULT __stdcall put_MarshalOptions(
4933 /*[in]*/ enum MarshalOptionsEnum peMarshal) = 0;
4934 virtual HRESULT __stdcall raw_Find(
4935 /*[in]*/ BSTR Criteria,
4936 /*[in]*/ ADO_LONGPTR SkipRecords,
4937 /*[in]*/ enum SearchDirectionEnum SearchDirection,
4938 /*[in]*/ VARIANT Start = vtMissing) = 0;
4939};
4940
4941struct __declspec(uuid("0000054f-0000-0010-8000-00aa006d2ea4")) Recordset20_Deprecated
4942 : Recordset15_Deprecated
4943{
4944 //
4945 // Property data
4946 //
4947
4948 __declspec(property(get = GetDataSource, put = PutRefDataSource)) IUnknownPtr DataSource;
4949 __declspec(property(get = GetActiveCommand)) IDispatchPtr ActiveCommand;
4950 __declspec(property(get = GetStayInSync, put = PutStayInSync)) VARIANT_BOOL StayInSync;
4951 __declspec(property(get = GetDataMember, put = PutDataMember)) _bstr_t DataMember;
4952
4953 //
4954 // Wrapper methods for error-handling
4955 //
4956
4957 HRESULT Cancel();
4958 IUnknownPtr GetDataSource();
4959 void PutRefDataSource(IUnknown* ppunkDataSource);
4960 HRESULT _xSave(_bstr_t FileName, enum PersistFormatEnum PersistFormat);
4961 IDispatchPtr GetActiveCommand();
4962 void PutStayInSync(VARIANT_BOOL pbStayInSync);
4963 VARIANT_BOOL GetStayInSync();
4964 _bstr_t GetString(enum StringFormatEnum StringFormat, long NumRows, _bstr_t ColumnDelimeter,
4965 _bstr_t RowDelimeter, _bstr_t NullExpr);
4966 _bstr_t GetDataMember();
4967 void PutDataMember(_bstr_t pbstrDataMember);
4968 enum CompareEnum CompareBookmarks(const _variant_t& Bookmark1, const _variant_t& Bookmark2);
4969 _Recordset_DeprecatedPtr Clone(enum LockTypeEnum LockType);
4970 HRESULT Resync(enum AffectEnum AffectRecords, enum ResyncEnum ResyncValues);
4971
4972 //
4973 // Raw methods provided by interface
4974 //
4975
4976 virtual HRESULT __stdcall raw_Cancel() = 0;
4977 virtual HRESULT __stdcall get_DataSource(
4978 /*[out,retval]*/ IUnknown** ppunkDataSource) = 0;
4979 virtual HRESULT __stdcall putref_DataSource(
4980 /*[in]*/ IUnknown* ppunkDataSource) = 0;
4981 virtual HRESULT __stdcall raw__xSave(
4982 /*[in]*/ BSTR FileName,
4983 /*[in]*/ enum PersistFormatEnum PersistFormat) = 0;
4984 virtual HRESULT __stdcall get_ActiveCommand(
4985 /*[out,retval]*/ IDispatch** ppCmd) = 0;
4986 virtual HRESULT __stdcall put_StayInSync(
4987 /*[in]*/ VARIANT_BOOL pbStayInSync) = 0;
4988 virtual HRESULT __stdcall get_StayInSync(
4989 /*[out,retval]*/ VARIANT_BOOL* pbStayInSync) = 0;
4990 virtual HRESULT __stdcall raw_GetString(
4991 /*[in]*/ enum StringFormatEnum StringFormat,
4992 /*[in]*/ long NumRows,
4993 /*[in]*/ BSTR ColumnDelimeter,
4994 /*[in]*/ BSTR RowDelimeter,
4995 /*[in]*/ BSTR NullExpr,
4996 /*[out,retval]*/ BSTR* pRetString) = 0;
4997 virtual HRESULT __stdcall get_DataMember(
4998 /*[out,retval]*/ BSTR* pbstrDataMember) = 0;
4999 virtual HRESULT __stdcall put_DataMember(
5000 /*[in]*/ BSTR pbstrDataMember) = 0;
5001 virtual HRESULT __stdcall raw_CompareBookmarks(
5002 /*[in]*/ VARIANT Bookmark1,
5003 /*[in]*/ VARIANT Bookmark2,
5004 /*[out,retval]*/ enum CompareEnum* pCompare) = 0;
5005 virtual HRESULT __stdcall raw_Clone(
5006 /*[in]*/ enum LockTypeEnum LockType,
5007 /*[out,retval]*/ struct _Recordset_Deprecated** ppvObject) = 0;
5008 virtual HRESULT __stdcall raw_Resync(
5009 /*[in]*/ enum AffectEnum AffectRecords,
5010 /*[in]*/ enum ResyncEnum ResyncValues) = 0;
5011};
5012
5013struct __declspec(uuid("00000555-0000-0010-8000-00aa006d2ea4")) Recordset21_Deprecated
5014 : Recordset20_Deprecated
5015{
5016 //
5017 // Property data
5018 //
5019
5020 __declspec(property(get = GetIndex, put = PutIndex)) _bstr_t Index;
5021
5022 //
5023 // Wrapper methods for error-handling
5024 //
5025
5026 HRESULT Seek(const _variant_t& KeyValues, enum SeekEnum SeekOption);
5027 void PutIndex(_bstr_t pbstrIndex);
5028 _bstr_t GetIndex();
5029
5030 //
5031 // Raw methods provided by interface
5032 //
5033
5034 virtual HRESULT __stdcall raw_Seek(
5035 /*[in]*/ VARIANT KeyValues,
5036 /*[in]*/ enum SeekEnum SeekOption) = 0;
5037 virtual HRESULT __stdcall put_Index(
5038 /*[in]*/ BSTR pbstrIndex) = 0;
5039 virtual HRESULT __stdcall get_Index(
5040 /*[out,retval]*/ BSTR* pbstrIndex) = 0;
5041};
5042
5043struct __declspec(uuid("00000556-0000-0010-8000-00aa006d2ea4")) _Recordset_Deprecated
5044 : Recordset21_Deprecated
5045{
5046 //
5047 // Wrapper methods for error-handling
5048 //
5049
5050 HRESULT Save(const _variant_t& Destination, enum PersistFormatEnum PersistFormat);
5051
5052 //
5053 // Raw methods provided by interface
5054 //
5055
5056 virtual HRESULT __stdcall raw_Save(
5057 /*[in]*/ VARIANT Destination,
5058 /*[in]*/ enum PersistFormatEnum PersistFormat) = 0;
5059};
5060
5061struct __declspec(uuid("00000508-0000-0010-8000-00aa006d2ea4")) Command15_Deprecated : _ADO
5062{
5063 //
5064 // Property data
5065 //
5066
5067 __declspec(property(get = GetParameters)) Parameters_DeprecatedPtr Parameters;
5068 __declspec(property(get = GetActiveConnection,
5069 put = PutRefActiveConnection)) _Connection_DeprecatedPtr ActiveConnection;
5070 __declspec(property(get = GetCommandText, put = PutCommandText)) _bstr_t CommandText;
5071 __declspec(property(get = GetCommandTimeout, put = PutCommandTimeout)) long CommandTimeout;
5072 __declspec(property(get = GetPrepared, put = PutPrepared)) VARIANT_BOOL Prepared;
5073 __declspec(property(get = GetCommandType,
5074 put = PutCommandType)) enum CommandTypeEnum CommandType;
5075 __declspec(property(get = GetName, put = PutName)) _bstr_t Name;
5076
5077 //
5078 // Wrapper methods for error-handling
5079 //
5080
5081 _Connection_DeprecatedPtr GetActiveConnection();
5082 void PutRefActiveConnection(struct _Connection_Deprecated* ppvObject);
5083 void PutActiveConnection(const _variant_t& ppvObject);
5084 _bstr_t GetCommandText();
5085 void PutCommandText(_bstr_t pbstr);
5086 long GetCommandTimeout();
5087 void PutCommandTimeout(long pl);
5088 VARIANT_BOOL GetPrepared();
5089 void PutPrepared(VARIANT_BOOL pfPrepared);
5090 _Recordset_DeprecatedPtr Execute(VARIANT* RecordsAffected, VARIANT* Parameters, long Options);
5091 _Parameter_DeprecatedPtr CreateParameter(_bstr_t Name, enum DataTypeEnum Type,
5092 enum ParameterDirectionEnum Direction,
5093 ADO_LONGPTR Size, const _variant_t& Value = vtMissing);
5094 Parameters_DeprecatedPtr GetParameters();
5095 void PutCommandType(enum CommandTypeEnum plCmdType);
5096 enum CommandTypeEnum GetCommandType();
5097 _bstr_t GetName();
5098 void PutName(_bstr_t pbstrName);
5099
5100 //
5101 // Raw methods provided by interface
5102 //
5103
5104 virtual HRESULT __stdcall get_ActiveConnection(
5105 /*[out,retval]*/ struct _Connection_Deprecated** ppvObject) = 0;
5106 virtual HRESULT __stdcall putref_ActiveConnection(
5107 /*[in]*/ struct _Connection_Deprecated* ppvObject) = 0;
5108 virtual HRESULT __stdcall put_ActiveConnection(
5109 /*[in]*/ VARIANT ppvObject) = 0;
5110 virtual HRESULT __stdcall get_CommandText(
5111 /*[out,retval]*/ BSTR* pbstr) = 0;
5112 virtual HRESULT __stdcall put_CommandText(
5113 /*[in]*/ BSTR pbstr) = 0;
5114 virtual HRESULT __stdcall get_CommandTimeout(
5115 /*[out,retval]*/ long* pl) = 0;
5116 virtual HRESULT __stdcall put_CommandTimeout(
5117 /*[in]*/ long pl) = 0;
5118 virtual HRESULT __stdcall get_Prepared(
5119 /*[out,retval]*/ VARIANT_BOOL* pfPrepared) = 0;
5120 virtual HRESULT __stdcall put_Prepared(
5121 /*[in]*/ VARIANT_BOOL pfPrepared) = 0;
5122 virtual HRESULT __stdcall raw_Execute(
5123 /*[out]*/ VARIANT* RecordsAffected,
5124 /*[in]*/ VARIANT* Parameters,
5125 /*[in]*/ long Options,
5126 /*[out,retval]*/ struct _Recordset_Deprecated** ppiRs) = 0;
5127 virtual HRESULT __stdcall raw_CreateParameter(
5128 /*[in]*/ BSTR Name,
5129 /*[in]*/ enum DataTypeEnum Type,
5130 /*[in]*/ enum ParameterDirectionEnum Direction,
5131 /*[in]*/ ADO_LONGPTR Size,
5132 /*[in]*/ VARIANT Value,
5133 /*[out,retval]*/ struct _Parameter_Deprecated** ppiprm) = 0;
5134 virtual HRESULT __stdcall get_Parameters(
5135 /*[out,retval]*/ struct Parameters_Deprecated** ppvObject) = 0;
5136 virtual HRESULT __stdcall put_CommandType(
5137 /*[in]*/ enum CommandTypeEnum plCmdType) = 0;
5138 virtual HRESULT __stdcall get_CommandType(
5139 /*[out,retval]*/ enum CommandTypeEnum* plCmdType) = 0;
5140 virtual HRESULT __stdcall get_Name(
5141 /*[out,retval]*/ BSTR* pbstrName) = 0;
5142 virtual HRESULT __stdcall put_Name(
5143 /*[in]*/ BSTR pbstrName) = 0;
5144};
5145
5146struct __declspec(uuid("0000054e-0000-0010-8000-00aa006d2ea4")) Command25_Deprecated
5147 : Command15_Deprecated
5148{
5149 //
5150 // Property data
5151 //
5152
5153 __declspec(property(get = GetState)) long State;
5154
5155 //
5156 // Wrapper methods for error-handling
5157 //
5158
5159 long GetState();
5160 HRESULT Cancel();
5161
5162 //
5163 // Raw methods provided by interface
5164 //
5165
5166 virtual HRESULT __stdcall get_State(
5167 /*[out,retval]*/ long* plObjState) = 0;
5168 virtual HRESULT __stdcall raw_Cancel() = 0;
5169};
5170
5171struct __declspec(uuid("b08400bd-f9d1-4d02-b856-71d5dba123e9")) _Command_Deprecated
5172 : Command25_Deprecated
5173{
5174 //
5175 // Property data
5176 //
5177
5178 __declspec(property(get = GetDialect, put = PutDialect)) _bstr_t Dialect;
5179 __declspec(property(get = GetNamedParameters,
5180 put = PutNamedParameters)) VARIANT_BOOL NamedParameters;
5181
5182 //
5183 // Wrapper methods for error-handling
5184 //
5185
5186 void PutRefCommandStream(IUnknown* pvStream);
5187 _variant_t GetCommandStream();
5188 void PutDialect(_bstr_t pbstrDialect);
5189 _bstr_t GetDialect();
5190 void PutNamedParameters(VARIANT_BOOL pfNamedParameters);
5191 VARIANT_BOOL GetNamedParameters();
5192
5193 //
5194 // Raw methods provided by interface
5195 //
5196
5197 virtual HRESULT __stdcall putref_CommandStream(
5198 /*[in]*/ IUnknown* pvStream) = 0;
5199 virtual HRESULT __stdcall get_CommandStream(
5200 /*[out,retval]*/ VARIANT* pvStream) = 0;
5201 virtual HRESULT __stdcall put_Dialect(
5202 /*[in]*/ BSTR pbstrDialect) = 0;
5203 virtual HRESULT __stdcall get_Dialect(
5204 /*[out,retval]*/ BSTR* pbstrDialect) = 0;
5205 virtual HRESULT __stdcall put_NamedParameters(
5206 /*[in]*/ VARIANT_BOOL pfNamedParameters) = 0;
5207 virtual HRESULT __stdcall get_NamedParameters(
5208 /*[out,retval]*/ VARIANT_BOOL* pfNamedParameters) = 0;
5209};
5210
5211struct __declspec(uuid("00000403-0000-0010-8000-00aa006d2ea4")) RecordsetEventsVt_Deprecated
5212 : IUnknown
5213{
5214 //
5215 // Wrapper methods for error-handling
5216 //
5217
5218 HRESULT WillChangeField(long cFields, const _variant_t& Fields, enum EventStatusEnum* adStatus,
5219 struct _Recordset_Deprecated* pRecordset);
5220 HRESULT FieldChangeComplete(long cFields, const _variant_t& Fields, struct Error* pError,
5221 enum EventStatusEnum* adStatus,
5222 struct _Recordset_Deprecated* pRecordset);
5223 HRESULT WillChangeRecord(enum EventReasonEnum adReason, long cRecords,
5224 enum EventStatusEnum* adStatus,
5225 struct _Recordset_Deprecated* pRecordset);
5226 HRESULT RecordChangeComplete(enum EventReasonEnum adReason, long cRecords, struct Error* pError,
5227 enum EventStatusEnum* adStatus,
5228 struct _Recordset_Deprecated* pRecordset);
5229 HRESULT WillChangeRecordset(enum EventReasonEnum adReason, enum EventStatusEnum* adStatus,
5230 struct _Recordset_Deprecated* pRecordset);
5231 HRESULT RecordsetChangeComplete(enum EventReasonEnum adReason, struct Error* pError,
5232 enum EventStatusEnum* adStatus,
5233 struct _Recordset_Deprecated* pRecordset);
5234 HRESULT WillMove(enum EventReasonEnum adReason, enum EventStatusEnum* adStatus,
5235 struct _Recordset_Deprecated* pRecordset);
5236 HRESULT MoveComplete(enum EventReasonEnum adReason, struct Error* pError,
5237 enum EventStatusEnum* adStatus, struct _Recordset_Deprecated* pRecordset);
5238 HRESULT EndOfRecordset(VARIANT_BOOL* fMoreData, enum EventStatusEnum* adStatus,
5239 struct _Recordset_Deprecated* pRecordset);
5240 HRESULT FetchProgress(long Progress, long MaxProgress, enum EventStatusEnum* adStatus,
5241 struct _Recordset_Deprecated* pRecordset);
5242 HRESULT FetchComplete(struct Error* pError, enum EventStatusEnum* adStatus,
5243 struct _Recordset_Deprecated* pRecordset);
5244
5245 //
5246 // Raw methods provided by interface
5247 //
5248
5249 virtual HRESULT __stdcall raw_WillChangeField(
5250 /*[in]*/ long cFields,
5251 /*[in]*/ VARIANT Fields,
5252 /*[in,out]*/ enum EventStatusEnum* adStatus,
5253 /*[in]*/ struct _Recordset_Deprecated* pRecordset) = 0;
5254 virtual HRESULT __stdcall raw_FieldChangeComplete(
5255 /*[in]*/ long cFields,
5256 /*[in]*/ VARIANT Fields,
5257 /*[in]*/ struct Error* pError,
5258 /*[in,out]*/ enum EventStatusEnum* adStatus,
5259 /*[in]*/ struct _Recordset_Deprecated* pRecordset) = 0;
5260 virtual HRESULT __stdcall raw_WillChangeRecord(
5261 /*[in]*/ enum EventReasonEnum adReason,
5262 /*[in]*/ long cRecords,
5263 /*[in,out]*/ enum EventStatusEnum* adStatus,
5264 /*[in]*/ struct _Recordset_Deprecated* pRecordset) = 0;
5265 virtual HRESULT __stdcall raw_RecordChangeComplete(
5266 /*[in]*/ enum EventReasonEnum adReason,
5267 /*[in]*/ long cRecords,
5268 /*[in]*/ struct Error* pError,
5269 /*[in,out]*/ enum EventStatusEnum* adStatus,
5270 /*[in]*/ struct _Recordset_Deprecated* pRecordset) = 0;
5271 virtual HRESULT __stdcall raw_WillChangeRecordset(
5272 /*[in]*/ enum EventReasonEnum adReason,
5273 /*[in,out]*/ enum EventStatusEnum* adStatus,
5274 /*[in]*/ struct _Recordset_Deprecated* pRecordset) = 0;
5275 virtual HRESULT __stdcall raw_RecordsetChangeComplete(
5276 /*[in]*/ enum EventReasonEnum adReason,
5277 /*[in]*/ struct Error* pError,
5278 /*[in,out]*/ enum EventStatusEnum* adStatus,
5279 /*[in]*/ struct _Recordset_Deprecated* pRecordset) = 0;
5280 virtual HRESULT __stdcall raw_WillMove(
5281 /*[in]*/ enum EventReasonEnum adReason,
5282 /*[in,out]*/ enum EventStatusEnum* adStatus,
5283 /*[in]*/ struct _Recordset_Deprecated* pRecordset) = 0;
5284 virtual HRESULT __stdcall raw_MoveComplete(
5285 /*[in]*/ enum EventReasonEnum adReason,
5286 /*[in]*/ struct Error* pError,
5287 /*[in,out]*/ enum EventStatusEnum* adStatus,
5288 /*[in]*/ struct _Recordset_Deprecated* pRecordset) = 0;
5289 virtual HRESULT __stdcall raw_EndOfRecordset(
5290 /*[in,out]*/ VARIANT_BOOL* fMoreData,
5291 /*[in,out]*/ enum EventStatusEnum* adStatus,
5292 /*[in]*/ struct _Recordset_Deprecated* pRecordset) = 0;
5293 virtual HRESULT __stdcall raw_FetchProgress(
5294 /*[in]*/ long Progress,
5295 /*[in]*/ long MaxProgress,
5296 /*[in,out]*/ enum EventStatusEnum* adStatus,
5297 /*[in]*/ struct _Recordset_Deprecated* pRecordset) = 0;
5298 virtual HRESULT __stdcall raw_FetchComplete(
5299 /*[in]*/ struct Error* pError,
5300 /*[in,out]*/ enum EventStatusEnum* adStatus,
5301 /*[in]*/ struct _Recordset_Deprecated* pRecordset) = 0;
5302};
5303
5304struct __declspec(uuid("00000562-0000-0010-8000-00aa006d2ea4")) _Record_Deprecated : _ADO
5305{
5306 //
5307 // Property data
5308 //
5309
5310 __declspec(property(get = GetFields)) Fields_DeprecatedPtr Fields;
5311 __declspec(property(get = GetState)) enum ObjectStateEnum State;
5312 __declspec(property(get = GetMode, put = PutMode)) enum ConnectModeEnum Mode;
5313 __declspec(property(get = GetParentURL)) _bstr_t ParentURL;
5314 __declspec(property(get = GetRecordType)) enum RecordTypeEnum RecordType;
5315
5316 //
5317 // Wrapper methods for error-handling
5318 //
5319
5320 _variant_t GetActiveConnection();
5321 void PutActiveConnection(_bstr_t pvar);
5322 void PutRefActiveConnection(struct _Connection_Deprecated* pvar);
5323 enum ObjectStateEnum GetState();
5324 _variant_t GetSource();
5325 void PutSource(_bstr_t pvar);
5326 void PutRefSource(IDispatch* pvar);
5327 enum ConnectModeEnum GetMode();
5328 void PutMode(enum ConnectModeEnum pMode);
5329 _bstr_t GetParentURL();
5330 _bstr_t MoveRecord(_bstr_t Source, _bstr_t Destination, _bstr_t UserName, _bstr_t Password,
5331 enum MoveRecordOptionsEnum Options, VARIANT_BOOL Async);
5332 _bstr_t CopyRecord(_bstr_t Source, _bstr_t Destination, _bstr_t UserName, _bstr_t Password,
5333 enum CopyRecordOptionsEnum Options, VARIANT_BOOL Async);
5334 HRESULT DeleteRecord(_bstr_t Source, VARIANT_BOOL Async);
5335 HRESULT Open(const _variant_t& Source, const _variant_t& ActiveConnection,
5336 enum ConnectModeEnum Mode, enum RecordCreateOptionsEnum CreateOptions,
5337 enum RecordOpenOptionsEnum Options, _bstr_t UserName, _bstr_t Password);
5338 HRESULT Close();
5339 Fields_DeprecatedPtr GetFields();
5340 enum RecordTypeEnum GetRecordType();
5341 _Recordset_DeprecatedPtr GetChildren();
5342 HRESULT Cancel();
5343
5344 //
5345 // Raw methods provided by interface
5346 //
5347
5348 virtual HRESULT __stdcall get_ActiveConnection(
5349 /*[out,retval]*/ VARIANT* pvar) = 0;
5350 virtual HRESULT __stdcall put_ActiveConnection(
5351 /*[in]*/ BSTR pvar) = 0;
5352 virtual HRESULT __stdcall putref_ActiveConnection(
5353 /*[in]*/ struct _Connection_Deprecated* pvar) = 0;
5354 virtual HRESULT __stdcall get_State(
5355 /*[out,retval]*/ enum ObjectStateEnum* pState) = 0;
5356 virtual HRESULT __stdcall get_Source(
5357 /*[out,retval]*/ VARIANT* pvar) = 0;
5358 virtual HRESULT __stdcall put_Source(
5359 /*[in]*/ BSTR pvar) = 0;
5360 virtual HRESULT __stdcall putref_Source(
5361 /*[in]*/ IDispatch* pvar) = 0;
5362 virtual HRESULT __stdcall get_Mode(
5363 /*[out,retval]*/ enum ConnectModeEnum* pMode) = 0;
5364 virtual HRESULT __stdcall put_Mode(
5365 /*[in]*/ enum ConnectModeEnum pMode) = 0;
5366 virtual HRESULT __stdcall get_ParentURL(
5367 /*[out,retval]*/ BSTR* pbstrParentURL) = 0;
5368 virtual HRESULT __stdcall raw_MoveRecord(
5369 /*[in]*/ BSTR Source,
5370 /*[in]*/ BSTR Destination,
5371 /*[in]*/ BSTR UserName,
5372 /*[in]*/ BSTR Password,
5373 /*[in]*/ enum MoveRecordOptionsEnum Options,
5374 /*[in]*/ VARIANT_BOOL Async,
5375 /*[out,retval]*/ BSTR* pbstrNewURL) = 0;
5376 virtual HRESULT __stdcall raw_CopyRecord(
5377 /*[in]*/ BSTR Source,
5378 /*[in]*/ BSTR Destination,
5379 /*[in]*/ BSTR UserName,
5380 /*[in]*/ BSTR Password,
5381 /*[in]*/ enum CopyRecordOptionsEnum Options,
5382 /*[in]*/ VARIANT_BOOL Async,
5383 /*[out,retval]*/ BSTR* pbstrNewURL) = 0;
5384 virtual HRESULT __stdcall raw_DeleteRecord(
5385 /*[in]*/ BSTR Source,
5386 /*[in]*/ VARIANT_BOOL Async) = 0;
5387 virtual HRESULT __stdcall raw_Open(
5388 /*[in]*/ VARIANT Source,
5389 /*[in]*/ VARIANT ActiveConnection,
5390 /*[in]*/ enum ConnectModeEnum Mode,
5391 /*[in]*/ enum RecordCreateOptionsEnum CreateOptions,
5392 /*[in]*/ enum RecordOpenOptionsEnum Options,
5393 /*[in]*/ BSTR UserName,
5394 /*[in]*/ BSTR Password) = 0;
5395 virtual HRESULT __stdcall raw_Close() = 0;
5396 virtual HRESULT __stdcall get_Fields(
5397 /*[out,retval]*/ struct Fields_Deprecated** ppFlds) = 0;
5398 virtual HRESULT __stdcall get_RecordType(
5399 /*[out,retval]*/ enum RecordTypeEnum* ptype) = 0;
5400 virtual HRESULT __stdcall raw_GetChildren(
5401 /*[out,retval]*/ struct _Recordset_Deprecated** pprset) = 0;
5402 virtual HRESULT __stdcall raw_Cancel() = 0;
5403};
5404
5405//
5406// Wrapper method implementations
5407//
5408
5409//#include "Debug\msado15.tli"
5410
5411} // namespace XTPGRIDADODB
5412
5413# pragma warning(pop)
5414# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
5415
5416# include "GridControl/XTPGridADO.inl"
5419# pragma pack(pop)
5421#endif // !defined(_XTPGRIDADO_H__)
XTPDisableAdvancedWarnings.h
XTPDisableNoisyWarnings.h
XTPEnableAdvancedWarnings.h
XTPEnableNoisyWarnings.h


Toolkit Pro: Member List

CXTPCalendarWeekViewDay Member List

This is the complete list of members for CXTPCalendarWeekViewDay, including all inherited members.

AdjustLayout(CDC *pDC, const CRect &rcDay) | CXTPCalendarWeekViewDay | virtual
AdjustLayout2(CDC *pDC, const CRect &rcDay) | CXTPCalendarWeekViewDay | virtual
ContainsInvisibleEvents() const | CXTPCalendarViewDay | virtual
ContainsInvisibleEventsUpdate() | CXTPCalendarViewDay | virtual
CreateGroup() | CXTPCalendarViewDayT< CXTPCalendarWeekView, CXTPCalendarWeekViewGroup, XTP_CALENDAR_HITTESTINFO, CXTPCalendarWeekViewDay > | inlinevirtual
CXTPCalendarViewDay(const CXTPCalendarView *pView) | CXTPCalendarViewDay |
CXTPCalendarViewDayT(const CXTPCalendarWeekView *pView) | CXTPCalendarViewDayT< CXTPCalendarWeekView, CXTPCalendarWeekViewGroup, XTP_CALENDAR_HITTESTINFO, CXTPCalendarWeekViewDay > | inline
CXTPCalendarWeekViewDay(CXTPCalendarWeekView *pWeekView) | CXTPCalendarWeekViewDay |
CXTPCalendarWMHandler() | CXTPCalendarWMHandler |
CXTPCmdTarget() | CXTPCmdTarget |
Draw(CDC *pDC) | CXTPCalendarWeekViewDay | virtual
FillHitTestEx(XTP_CALENDAR_HITTESTINFO *pInfo) const | CXTPCalendarWeekViewDay | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCalendarControl() const | CXTPCalendarViewDay | virtual
GetCaption() const | CXTPCalendarWeekViewDay | virtual
GetChildHandlerAt(int nIndex) const | CXTPCalendarViewDay | inlinevirtual
GetChildHandlersCount() const | CXTPCalendarViewDay | inlinevirtual
GetDayDate() const | CXTPCalendarViewDay | virtual
GetDayEventsRect() const | CXTPCalendarWeekViewDay |
GetDayIndex() const | CXTPCalendarViewDay | virtual
GetDayRect() const | CXTPCalendarViewDay | virtual
GetExpandSignRect() const | CXTPCalendarViewDay | virtual
GetPThis() | CXTPCalendarWeekViewDay | protectedvirtual
GetResources() const | CXTPCalendarViewDay | virtual
GetView() const | CXTPCalendarViewDayT< CXTPCalendarWeekView, CXTPCalendarWeekViewGroup, XTP_CALENDAR_HITTESTINFO, CXTPCalendarWeekViewDay > | inline
GetView_() const | CXTPCalendarViewDay | virtual
GetViewEvent_(int nIndex) const | CXTPCalendarViewDay | virtual
GetViewEventsCount() const | CXTPCalendarViewDay | virtual
GetViewGroup(int nIndex) const | CXTPCalendarViewDayT< CXTPCalendarWeekView, CXTPCalendarWeekViewGroup, XTP_CALENDAR_HITTESTINFO, CXTPCalendarWeekViewDay > | inlinevirtual
GetViewGroup_(int nIndex) const | CXTPCalendarViewDay |
GetViewGroupsCount() const | CXTPCalendarViewDay |
HitTest(CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const | CXTPCalendarViewDay | virtual
HitTestEx(CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const | CXTPCalendarWeekViewDay | virtual
IsExpanded() const | CXTPCalendarViewDay | virtual
IsSelected() const | CXTPCalendarViewDay | virtual
KillTimer(UINT uTimerID) | CXTPCalendarViewDay | virtual
m_arViewGroups | CXTPCalendarViewDay | protected
m_dtDate | CXTPCalendarViewDay | protected
m_Layout | CXTPCalendarViewDay | protected
m_pResources | CXTPCalendarViewDay | protected
m_pView | CXTPCalendarViewDay | protected
OnBeforeDestroy() | CXTPCalendarWMHandler | virtual
OnChar(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnKeyUp(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnLButtonDblClk(UINT nFlags, CPoint point) | CXTPCalendarWMHandler | virtual
OnLButtonDown(UINT nFlags, CPoint point) | CXTPCalendarWeekViewDay | protectedvirtual
OnLButtonUp(UINT nFlags, CPoint point) | CXTPCalendarWMHandler | virtual
OnMouseMove(UINT nFlags, CPoint point) | CXTPCalendarWeekViewDay | protectedvirtual
OnPostAdjustLayout() | CXTPCalendarWMHandler | virtual
OnPrePopulateDay() | CXTPCalendarViewDay | protectedvirtual
OnSysKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnTimer(UINT_PTR uTimerID) | CXTPCalendarWMHandler | virtual
OnWndMsg(UINT message, WPARAM wParam, LPARAM lParam, LRESULT *pResult) | CXTPCalendarWMHandler | virtual
Populate(COleDateTime dtDayDate) | CXTPCalendarViewDay | virtual
SetDayDate(COleDateTime dtDayDate) | CXTPCalendarViewDay | virtual
SetDayRect(CRect rcDay) | CXTPCalendarViewDay | virtual
SetResources(CXTPCalendarResources *pResources) | CXTPCalendarViewDay | virtual
SetSelected() | CXTPCalendarViewDay | virtual
SetTimer(UINT uTimeOut_ms) | CXTPCalendarViewDay | virtual
TBase typedef | CXTPCalendarWeekViewDay |
TView typedef | CXTPCalendarViewDayT< CXTPCalendarWeekView, CXTPCalendarWeekViewGroup, XTP_CALENDAR_HITTESTINFO, CXTPCalendarWeekViewDay > |
UserAction_OnExpandDay(XTPCalendarExpandDayButton eButton) | CXTPCalendarViewDay | virtual
~CXTPCalendarViewDay() | CXTPCalendarViewDay | virtual
~CXTPCalendarViewDayT() | CXTPCalendarViewDayT< CXTPCalendarWeekView, CXTPCalendarWeekViewGroup, XTP_CALENDAR_HITTESTINFO, CXTPCalendarWeekViewDay > | inlinevirtual
~CXTPCalendarWeekViewDay() | CXTPCalendarWeekViewDay | virtual


Toolkit Pro: XTPChartOpenGLDebugDeviceCommands.h Source File

  • Source
  • Chart
  • Drawing
  • OpenGL
XTPChartOpenGLDebugDeviceCommands.h
Go to the documentation of this file.
1
23#ifdef _DEBUG
24
25# if !defined(__XTPCHARTOPENGLDEBUGDEVICECOMMANDS_H__)
26# define __XTPCHARTOPENGLDEBUGDEVICECOMMANDS_H__
27
28# if _MSC_VER >= 1000
29# pragma once
30# endif // _MSC_VER >= 1000
31
32# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
33
34class _XTP_EXT_CLASS CXTPChartOpenGLDebugAxesDeviceCommand : public CXTPChart3dDeviceCommand
35{
36public:
37 // In absolute coordinates
38 CXTPChartOpenGLDebugAxesDeviceCommand(const CXTPPoint3d& pt, double dSize);
39
40protected:
41 virtual void ExecuteOverride(CXTPChartDeviceContext* pDC);
42
43private:
44 CXTPPoint3d m_pt;
45 double m_dSize;
46};
47
48class _XTP_EXT_CLASS CXTPChartOpenGLDebugBoxDeviceCommand : public CXTPChart3dDeviceCommand
49{
50public:
51 // In absolute coordinates
52 CXTPChartOpenGLDebugBoxDeviceCommand(const CXTPChart3dBox& box, BOOL bSolid = FALSE);
53
54protected:
55 virtual void ExecuteOverride(CXTPChartDeviceContext* pDC);
56
57private:
58 CXTPChart3dBox m_box;
59 BOOL m_bSolid;
60};
61
62# endif //#if !defined(__XTPCHARTOPENGLDEBUGDEVICECOMMANDS_H__)
63
64# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
65#endif /*_DEBUG*/
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChart3dBox
Represents a 3D box build around included points and provides useful and fast operations.
Definition XTPChartTypes.h:728
CXTPChart3dDeviceCommand
Defines a common implementation interface for chart 3D drawing commands.
Definition XTPChartDeviceCommand.h:368
CXTPChartDeviceCommand::ExecuteOverride
virtual void ExecuteOverride(CXTPChartDeviceContext *pDC)
Override this function to write the drawing code for specific objects.
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPPoint3T< double >


Toolkit Pro: Member List

CXTPControlOleItems Member List

This is the complete list of members for CXTPControlOleItems, including all inherited members.

AssignDocTemplate(UINT nIDResource) | CXTPControl |
ClickToolBarButton(CRect rcActiveRect=CRect(0, 0, 0, 0)) | CXTPControl | protected
Compare(CXTPControl *pOther) | CXTPControl | virtual
Copy(CXTPControl *pControl, BOOL bRecursive=FALSE) | CXTPControlButton | protectedvirtual
CustomizeStartDrag(CPoint point) | CXTPControl | protectedvirtual
CustomizeStartResize(CPoint point) | CXTPControl | protectedvirtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPControl() | CXTPControl | protected
CXTPControlButton() | CXTPControlButton |
DelayLayoutParent() | CXTPControl |
DelayRedrawParent() | CXTPControl |
DoCustomDragOver(CXTPCommandBar *pCommandBar, CPoint point, DROPEFFECT &dropEffect) | CXTPControlOleItems | protectedvirtual
DoPropExchange(CXTPPropExchange *pPX) | CXTPControlButton | virtual
Draw(CDC *pDC) | CXTPControl | virtual
ExcludeDocTemplate(UINT nIDResource) | CXTPControl |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
FromUI(CCmdUI *pCmdUI) | CXTPControl | static
GenerateCommandBarList(DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam) | CXTPControl | protectedvirtual
GetAction() const | CXTPControl |
GetBeginGroup() const | CXTPControl |
GetButtonSize() const | CXTPControl | virtual
GetCaption() const | CXTPControl | virtual
GetCategory() const | CXTPControl |
GetChecked() const | CXTPControl |
GetCloseSubMenuOnClick() const | CXTPControl |
GetCommandBar() const | CXTPControl | virtual
GetControls() const | CXTPControl |
GetCustomizeMinHeight() const | CXTPControl | protectedvirtual
GetCustomizeMinWidth() const | CXTPControl | protectedvirtual
GetCustomShortcutText() const | CXTPControl |
GetDescription() const | CXTPControl | virtual
GetEnabled() const | CXTPControl |
GetExecuteOnPressInterval() const | CXTPControl |
GetExpanded() const | CXTPControl |
GetFlags() const | CXTPControl |
GetHeight() const | CXTPControl |
GetHelpId() const | CXTPControl |
GetHideFlags() const | CXTPControl |
GetIconId() const | CXTPControl |
GetIconSize() const | CXTPControl | virtual
GetID() const | CXTPControl |
GetImage(int nWidth=16) const | CXTPControl | virtual
GetImageManager() const | CXTPControl |
GetIndex() const | CXTPControl |
GetKeyboardTip() const | CXTPControl |
GetPaintManager() const | CXTPControl |
GetParameter() const | CXTPControl |
GetParent() const | CXTPControl |
GetPopuped() const | CXTPControl | virtual
GetPressed() const | CXTPControl | virtual
GetRect() const | CXTPControl |
GetRibbonGroup() const | CXTPControl |
GetRowRect() const | CXTPControl |
GetSelected() const | CXTPControl | virtual
GetShortcutText() const | CXTPControl |
GetSize(CDC *pDC) | CXTPControl | virtual
GetStyle() const | CXTPControl |
GetStyleEx() const | CXTPControlButton |
GetTag() const | CXTPControl |
GetTooltip() const | CXTPControl | virtual
GetType() const | CXTPControl |
GetWidth() const | CXTPControl |
GetWrap() const | CXTPControl |
HasDwmCompositedRect() const | CXTPControl |
IsCaptionVisible() const | CXTPControl | virtual
IsCursorOver() const | CXTPControl |
IsCustomizeMode() const | CXTPControl | protected
IsCustomizeMovable() const | CXTPControl | virtual
IsCustomizeResizeAllow() const | CXTPControl | protectedvirtual
IsFocusable() const | CXTPControl | protectedvirtual
IsFocused() const | CXTPControl | virtual
IsItemDefault() const | CXTPControl |
IsLayoutChanged() | CXTPControl | protected
IsLayoutRTL() const | CXTPControl | protected
IsOnQuickAccess() const | CXTPControl |
IsTemporary() const | CXTPControl |
IsTransparent() const | CXTPControl | inlinevirtual
IsVisible(DWORD dwSkipFlags=0) const | CXTPControl | virtual
m_bBeginGroup | CXTPControl | protected
m_bChecked | CXTPControl | protected
m_bCloseSubMenuOnClick | CXTPControl | protected
m_bDefaultItem | CXTPControl | protected
m_bEnabled | CXTPControl | protected
m_bExpanded | CXTPControl | protected
m_bLayoutRTL | CXTPControl | protected
m_bOnQuickAccess | CXTPControl | protected
m_bPressed | CXTPControl | protected
m_bSelected | CXTPControl | protected
m_bTemporary | CXTPControl | protected
m_buttonCustomStyle | CXTPControl | protected
m_buttonRibbonStyle | CXTPControl | protected
m_buttonStyle | CXTPControl | protected
m_buttonStyleEx | CXTPControlButton | protected
m_bWrap | CXTPControl | protected
m_controlType | CXTPControl | protected
m_dwFlags | CXTPControl | protected
m_dwHideFlags | CXTPControl | protected
m_mapDocTemplatesAssigned | CXTPControl | protected
m_mapDocTemplatesExcluded | CXTPControl | protected
m_nCustomIconId | CXTPControl | protected
m_nExecuteOnPressInterval | CXTPControl | protected
m_nHeight | CXTPControl | protected
m_nHelpId | CXTPControl | protected
m_nIconId | CXTPControl | protected
m_nId | CXTPControl | protected
m_nIndex | CXTPControl | protected
m_nTag | CXTPControl | protected
m_nWidth | CXTPControl | protected
m_pAction | CXTPControl | protected
m_pControls | CXTPControl | protected
m_pParent | CXTPControl | protected
m_pRibbonGroup | CXTPControl | protected
m_rcControl | CXTPControl | protected
m_rcRow | CXTPControl | protected
m_strCaption | CXTPControl | protected
m_strCategory | CXTPControl | protected
m_strCustomCaption | CXTPControl | protected
m_strDescriptionText | CXTPControl | protected
m_strKeyboardTip | CXTPControl | protected
m_strParameter | CXTPControl | protected
m_strShortcutText | CXTPControl | protected
m_strShortcutTextAuto | CXTPControl | protected
m_strTooltipText | CXTPControl | protected
m_szIcon | CXTPControl | protected
NotifySite(UINT code) | CXTPControl |
NotifySite(UINT code, NMXTPCONTROL *pNM) | CXTPControl |
NotifySite(CWnd *pSite, UINT code, NMXTPCONTROL *pNM) | CXTPControl |
OnActionChanged(int nProperty) | CXTPControl | protectedvirtual
OnActionChanging(int nProperty) | CXTPControl | protectedvirtual
OnCalcDynamicSize(DWORD dwMode) | CXTPControlOleItems | protectedvirtual
OnCaptionChanged() | CXTPControl | protectedvirtual
OnClick(BOOL bKeyboard=FALSE, CPoint pt=CPoint(0, 0)) | CXTPControlButton | protectedvirtual
OnCustomizeDragOver(CXTPControl *pDataObject, CPoint point, DROPEFFECT &dropEffect) | CXTPControl | protectedvirtual
OnCustomizeMouseMove(CPoint point) | CXTPControl | protected
OnEnabledChanged() | CXTPControl | virtual
OnExecute() | CXTPControl | virtual
OnHookKeyDown(UINT nChar, LPARAM lParam) | CXTPControl | protectedvirtual
OnHookMouseWheel(UINT nFlags, short zDelta, CPoint point) | CXTPControl | protectedvirtual
OnIdleUpdate() | CXTPControl | protectedvirtual
OnLButtonDblClk(CPoint point) | CXTPControl | protectedvirtual
OnLButtonDown(CPoint point) | CXTPControl | protectedvirtual
OnLButtonUp(CPoint point) | CXTPControlButton | protectedvirtual
OnMouseHover() | CXTPControl | protectedvirtual
OnMouseMove(CPoint point) | CXTPControl | protectedvirtual
OnRButtonDown(CPoint point) | CXTPControl | protectedvirtual
OnRButtonUp(CPoint point) | CXTPControl | protectedvirtual
OnRemoved() | CXTPControl | protectedvirtual
OnSetPopup(BOOL bPopup) | CXTPControl | protectedvirtual
OnSetSelected(int bSelected) | CXTPControl | protectedvirtual
OnThemeChanged() | CXTPControl | virtual
OnToolHitTest(CPoint point, TOOLINFO *pTI) const | CXTPControl | protectedvirtual
OnUnderlineActivate() | CXTPControl | virtual
RedrawParent(BOOL bAnimate=TRUE) | CXTPControl |
Reset() | CXTPControl |
RestoreCommandBarList(CXTPCommandBarList *pCommandBarList) | CXTPControl | protectedvirtual
ScreenToClient(CPoint *point) | CXTPControl | protected
SetAction(CXTPControlAction *pAction) | CXTPControl | virtual
SetBeginGroup(BOOL bBeginGroup) | CXTPControl | virtual
SetCaption(LPCTSTR lpszCaption) | CXTPControl |
SetCaption(UINT nIDCaption) | CXTPControl |
SetCategory(LPCTSTR lpszCategory) | CXTPControl |
SetChecked(BOOL bChecked) | CXTPControl | virtual
SetCloseSubMenuOnClick(BOOL bCloseOnClick) | CXTPControl |
SetCustomIcon(HICON hIcon) | CXTPControl |
SetCustomShortcutText(LPCTSTR lpszCustomShortcutText) | CXTPControl |
SetDescription(LPCTSTR lpszDescription) | CXTPControl |
SetEnabled(BOOL bEnabled) | CXTPControl | virtual
SetExecuteOnPressInterval(int nExecuteOnPressInterval) | CXTPControl |
SetExpanded(BOOL bExpanded) | CXTPControl | protected
SetFlags(DWORD dwFlags) | CXTPControl |
SetFocused(BOOL bFocused) | CXTPControl | virtual
SetHeight(int nHeight) | CXTPControl | virtual
SetHelpId(int nId) | CXTPControl |
SetHideFlag(XTPControlHideFlags dwFlag, BOOL bSet) | CXTPControl |
SetHideFlags(DWORD dwFlags) | CXTPControl | virtual
SetHideWrap(BOOL bHide) | CXTPControl |
SetIconId(int nId) | CXTPControl |
SetIconSize(CSize szIcon) | CXTPControl |
SetID(int nId) | CXTPControl |
SetIndex(int nIndex) | CXTPControl | inlineprotected
SetItemDefault(BOOL bDefault) | CXTPControl |
SetKeyboardTip(LPCTSTR lpszKeyboardTip) | CXTPControl |
SetOnQuickAccess(BOOL bOnQuicAccess=FALSE) | CXTPControl |
SetParameter(LPCTSTR lpszParameter) | CXTPControl |
SetParent(CXTPCommandBar *pParent) | CXTPControl | inlineprotectedvirtual
SetPressed(BOOL bPressed) | CXTPControl |
SetPrompt(LPCTSTR lpszPrompt) | CXTPControl |
SetRect(CRect rcControl) | CXTPControl | virtual
SetRowRect(CRect rcRow) | CXTPControl |
SetShortcutText(LPCTSTR lpszShortcutText) | CXTPControl |
SetStyle(XTPButtonStyle buttonStyle) | CXTPControl |
SetStyleEx(XTPButtonStyle buttonStyle) | CXTPControlButton |
SetTag(DWORD_PTR dwTag) | CXTPControl |
SetTooltip(LPCTSTR lpszTooltip) | CXTPControl |
SetVisible(BOOL bVisible) | CXTPControl |
SetWidth(int nWidth) | CXTPControl | virtual
SetWrap(BOOL bWrap) | CXTPControl |
~CXTPControl() | CXTPControl | protectedvirtual
~CXTPControlButton() | CXTPControlButton | virtual


Toolkit Pro: XTPCalendarTimeZoneHelper.h Source File

  • Source
  • Calendar
XTPCalendarTimeZoneHelper.h
Go to the documentation of this file.
1
22#if !defined(_XTPCALENDARTIMEZONEHELPER_H__)
23# define _XTPCALENDARTIMEZONEHELPER_H__
24
25# if _MSC_VER > 1000
26# pragma once
27# endif // _MSC_VER > 1000
28
29# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
31class CXTPCalendarTimeZone;
32 XTP_DEFINE_SMART_PTR_INTERNAL(CXTPCalendarTimeZone)
53class _XTP_EXT_CLASS CXTPCalendarTimeZone
54 : public CXTPCmdTarget
55 , public TIME_ZONE_INFORMATION
56{
58 friend class CXTPCalendarTimeZones;
59 DECLARE_DYNAMIC(CXTPCalendarTimeZone)
62public:
73 CXTPCalendarTimeZone(const TIME_ZONE_INFORMATION* pTZInfo = NULL);
74
84 CXTPCalendarTimeZone(const CXTPCalendarTimeZone* pTZInfoEx);
85
92 virtual ~CXTPCalendarTimeZone();
93
100 CString GetDisplayString() const;
101
111 DWORD GetIndex() const;
112
122 BOOL IsEqual(const TIME_ZONE_INFORMATION* pTZI2) const;
123
134 const CXTPCalendarTimeZone& operator=(const CXTPCalendarTimeZone& rTZInfo);
135
149 static CXTPCalendarTimeZonePtr AFX_CDECL GetTimeZoneInfo(const TIME_ZONE_INFORMATION* pTZIdata);
150
151protected:
152 CString m_strDisplayString;
153 DWORD m_dwIndex;
155# ifdef _XTP_ACTIVEX
156
157 BSTR OleGetStandardName();
158 void OleSetStandardName(LPCTSTR bstrStandardName);
159
160 BSTR OleGetDaylightName();
161 void OleSetDaylightName(LPCTSTR bstrDaylightName);
162
163 LPDISPATCH OleGetStandardDate();
164 void OleSetStandardDate(LPDISPATCH pDispStandardDate);
165
166 LPDISPATCH OleGetDaylightDate();
167 void OleSetDaylightDate(LPDISPATCH pDispDaylightDate);
168
169 BSTR OleGetDisplayString();
170
171 BOOL OleIsEqual(LPDISPATCH pDispTZI2);
172
173protected:
174 DECLARE_DISPATCH_MAP()
175 DECLARE_INTERFACE_MAP()
176
177 DECLARE_OLETYPELIB_EX(CXTPCalendarTimeZone);
178
179# endif
180};
181
203class _XTP_EXT_CLASS CXTPCalendarTimeZones : public CXTPCmdTarget
204{
206 DECLARE_DYNAMIC(CXTPCalendarTimeZones)
208public:
215 CXTPCalendarTimeZones();
216
223 virtual ~CXTPCalendarTimeZones();
224
233 BOOL InitFromRegistry();
234
244 int GetCount() const;
245
258 CXTPCalendarTimeZone* GetAt(long nIndex) const;
259
271 CXTPCalendarTimeZone* Find(const TIME_ZONE_INFORMATION* pTZI2) const;
272
273public:
284 struct REGISTRY_TIMEZONE_INFORMATION
285 {
286 LONG Bias;
287 LONG StandardBias;
289 LONG DaylightBias;
291 SYSTEMTIME StandardDate;
294 SYSTEMTIME DaylightDate;
297 };
298
311 static BOOL AFX_CDECL GetRegStr(HKEY hKey, LPCTSTR pcszValueName, CString& rstrValue);
312
330 static BOOL AFX_CDECL GetRegBSTR(HKEY hKey, LPCWSTR pcszValueNameW, BSTR& rbstrValue);
331
342 static BOOL AFX_CDECL GetRegDWORD(HKEY hKey, LPCTSTR pcszValueName, DWORD& rdwValue);
343
356 static BOOL AFX_CDECL GetRegTZI(HKEY hKey, LPCTSTR pcszValueName,
357 REGISTRY_TIMEZONE_INFORMATION& rRegTZI);
358
359protected:
360 //--------------------------------------------------------------
361 CXTPCalendarPtrCollectionT<CXTPCalendarTimeZone> m_arTZInfo;
365private:
366 int CompareTZI(const CXTPCalendarTimeZone* pTZI1, const CXTPCalendarTimeZone* pTZI2,
367 BOOL bUseIndex) const;
368
369 void ParseDisplayStr(LPCTSTR str, int& rnBias, CString& rstrPlace) const;
370 int GetDigit(TCHAR ch) const;
371
372protected:
373# ifdef _XTP_ACTIVEX
374
375 int OleGetItemCount();
376 LPDISPATCH OleGetItem(long nIndex);
377
378 DECLARE_DISPATCH_MAP()
379 DECLARE_INTERFACE_MAP()
380
381 DECLARE_OLETYPELIB_EX(CXTPCalendarTimeZones);
382
383 DECLARE_ENUM_VARIANT(CXTPCalendarTimeZones);
384
385# endif
386};
387
388//================================================================
389# ifdef _XTP_ACTIVEX
390
391class _XTP_EXT_CLASS CXTPCalendarSystemTime
392 : public CXTPCmdTarget
393 , public SYSTEMTIME
394{
395public:
396 CXTPCalendarSystemTime(const SYSTEMTIME* pTime = NULL);
397 virtual ~CXTPCalendarSystemTime();
398
399protected:
400 DECLARE_DYNAMIC(CXTPCalendarSystemTime)
401
402 DECLARE_DISPATCH_MAP()
403 DECLARE_INTERFACE_MAP()
404
405 DECLARE_OLETYPELIB_EX(CXTPCalendarSystemTime);
406};
407
408# endif
409
411
412# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
413#endif // !defined(_XTPCALENDARTIMEZONEHELPER_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTP_DEFINE_SMART_PTR_INTERNAL
#define XTP_DEFINE_SMART_PTR_INTERNAL(ClassName)
Define smart pointer for the specified class as ClassNamePtr.
Definition XTPSmartPtrInternalT.h:47
CXTPCalendarPtrCollectionT
This class represents a simple array collection of objects.
Definition XTPCalendarPtrCollectionT.h:48
CXTPCalendarTimeZone
This class extends the TIME_ZONE_INFORMATION structure.
Definition XTPCalendarTimeZoneHelper.h:56
CXTPCalendarTimeZone::~CXTPCalendarTimeZone
virtual ~CXTPCalendarTimeZone()
Default object destructor.
CXTPCalendarTimeZone::CXTPCalendarTimeZone
CXTPCalendarTimeZone(const CXTPCalendarTimeZone *pTZInfoEx)
Default object constructor.
CXTPCalendarTimeZone::GetTimeZoneInfo
static CXTPCalendarTimeZonePtr AFX_CDECL GetTimeZoneInfo(const TIME_ZONE_INFORMATION *pTZIdata)
Get full information about the specified time zone.
CXTPCalendarTimeZone::m_strDisplayString
CString m_strDisplayString
A time zone display string stored value.
Definition XTPCalendarTimeZoneHelper.h:152
CXTPCalendarTimeZone::m_dwIndex
DWORD m_dwIndex
A time zone order index stored value.
Definition XTPCalendarTimeZoneHelper.h:153
CXTPCalendarTimeZone::GetIndex
DWORD GetIndex() const
Get a time zone order index value.
CXTPCalendarTimeZone::IsEqual
BOOL IsEqual(const TIME_ZONE_INFORMATION *pTZI2) const
Compare 2 time zones data.
CXTPCalendarTimeZone::CXTPCalendarTimeZone
CXTPCalendarTimeZone(const TIME_ZONE_INFORMATION *pTZInfo=NULL)
Default object constructor.
CXTPCalendarTimeZone::operator=
const CXTPCalendarTimeZone & operator=(const CXTPCalendarTimeZone &rTZInfo)
Copy operator.
CXTPCalendarTimeZone::GetDisplayString
CString GetDisplayString() const
Get a time zone display string value.
CXTPCalendarTimeZones
This class represents a simple array collection of CXTPCalendarTimeZone objects.
Definition XTPCalendarTimeZoneHelper.h:204
CXTPCalendarTimeZones::GetCount
int GetCount() const
This member function is used to obtain the number of elements in this collection.
CXTPCalendarTimeZones::InitFromRegistry
BOOL InitFromRegistry()
Reads all time zones from the registry and adds them to the collection.
CXTPCalendarTimeZones::GetRegStr
static BOOL AFX_CDECL GetRegStr(HKEY hKey, LPCTSTR pcszValueName, CString &rstrValue)
This method is used to read a string value from the registry.
CXTPCalendarTimeZones::GetRegTZI
static BOOL AFX_CDECL GetRegTZI(HKEY hKey, LPCTSTR pcszValueName, REGISTRY_TIMEZONE_INFORMATION &rRegTZI)
This method is used to read a time zone's information stored as a binary value in the registry.
CXTPCalendarTimeZones::Find
CXTPCalendarTimeZone * Find(const TIME_ZONE_INFORMATION *pTZI2) const
This method is used to find time zone information using a specified time zone's data.
CXTPCalendarTimeZones::CXTPCalendarTimeZones
CXTPCalendarTimeZones()
Default object constructor.
CXTPCalendarTimeZones::m_arTZInfo
CXTPCalendarPtrCollectionT< CXTPCalendarTimeZone > m_arTZInfo
Collection to store CXTPCalendarTimeZone object pointers;.
Definition XTPCalendarTimeZoneHelper.h:361
CXTPCalendarTimeZones::GetRegBSTR
static BOOL AFX_CDECL GetRegBSTR(HKEY hKey, LPCWSTR pcszValueNameW, BSTR &rbstrValue)
This method is used to read a UNICODE string value from the registry.
CXTPCalendarTimeZones::GetAt
CXTPCalendarTimeZone * GetAt(long nIndex) const
Call this method to get an element at the specified numeric index.
CXTPCalendarTimeZones::~CXTPCalendarTimeZones
virtual ~CXTPCalendarTimeZones()
Default object destructor.
CXTPCalendarTimeZones::GetRegDWORD
static BOOL AFX_CDECL GetRegDWORD(HKEY hKey, LPCTSTR pcszValueName, DWORD &rdwValue)
This method is used to read a DWORD value from the registry.
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPCalendarTimeZones::REGISTRY_TIMEZONE_INFORMATION
This structure represents a format of binary data stored in the "TZI" registry key.
Definition XTPCalendarTimeZoneHelper.h:285
CXTPCalendarTimeZones::REGISTRY_TIMEZONE_INFORMATION::StandardBias
LONG StandardBias
Bias value to be used during local time translations that occur during standard time.
Definition XTPCalendarTimeZoneHelper.h:287
CXTPCalendarTimeZones::REGISTRY_TIMEZONE_INFORMATION::StandardDate
SYSTEMTIME StandardDate
A SYSTEMTIME structure that contains a date and local time when the transition from daylight saving t...
Definition XTPCalendarTimeZoneHelper.h:291
CXTPCalendarTimeZones::REGISTRY_TIMEZONE_INFORMATION::Bias
LONG Bias
Current bias for local time translation on this computer, in minutes.
Definition XTPCalendarTimeZoneHelper.h:286
CXTPCalendarTimeZones::REGISTRY_TIMEZONE_INFORMATION::DaylightBias
LONG DaylightBias
Bias value to be used during local time translations that occur during daylight saving time.
Definition XTPCalendarTimeZoneHelper.h:289
CXTPCalendarTimeZones::REGISTRY_TIMEZONE_INFORMATION::DaylightDate
SYSTEMTIME DaylightDate
A SYSTEMTIME structure that contains a date and local time when the transition from standard time to ...
Definition XTPCalendarTimeZoneHelper.h:294


Toolkit Pro: XTPMarkupParser.h Source File

  • Source
  • Markup
XTPMarkupParser.h
Go to the documentation of this file.
1
23#if !defined(__XTPMARKUPPARSER_H__)
24# define __XTPMARKUPPARSER_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
35class CXTPComInitializer;
36
37# define XTP_MAX_TOKEN_SIZE 1024
38# define XTP_MAX_NAME_SIZE 128
39
44class _XTP_EXT_CLASS CXTPMarkupParser
45{
46public:
47 CXTPMarkupParser();
48 virtual ~CXTPMarkupParser();
49
50public:
59 BOOL SetBuffer(LPCSTR lpszStart, LPCSTR lpszEnd);
60
69 BOOL SetBuffer(LPCWSTR lpszStart, LPCWSTR lpszEnd);
70
78 BOOL SetDataStream(IStream* pStream);
79
87 XTPXML::IXMLDOMDocumentPtr GetXmlDocument();
88
93 struct ErrorInfo
94 {
95 HRESULT nCode;
96 BOOL bXml;
97 long nLine;
98 long nPosition;
99 _bstr_t strReason;
100 _bstr_t strSource;
101 };
102
109 const ErrorInfo& GetErrorInfo() const;
110
117 CString FormatErrorMessage() const;
118
125 CString FormatMarkupErrorMessage() const;
126
127private:
128 struct MEMORY_BLOB
129 {
130 SIZE_T cbSize;
131 LPCVOID pBlobData;
132 };
133
134 BOOL CreateDataStream(LPCSTR lpString, SIZE_T cch, IStream** ppStream) const;
135 BOOL CreateDataStream(LPCWSTR lpString, SIZE_T cch, IStream** ppStream) const;
136 BOOL CreateDataStream(const MEMORY_BLOB* pBlobs, UINT nBlobs, IStream** ppStream) const;
137
138 void ObtainComErrorInfo(HRESULT hr) const;
139 void ObtainXmlErrorInfo(XTPXML::IXMLDOMDocument* pXmlDocument, HRESULT hr = S_OK);
140 void ResetErrorInfo();
141
142 void ReleaseXml();
143
144 HGLOBAL ReadStreamData(IStream* pStream) const;
145 LPWSTR ReadStreamDataAsUnicode(IStream* pStream, UINT* pchUnicodeText) const;
146
147 // Backward compatibility tools.
148 BOOL FixReferenceToUndeclaredNamespacePrefixX(IStream* pInputStream,
149 IStream** ppOutputStream) const;
150 BOOL FixRequiredWhiteSpaceWasMissing(IStream* pInputStream, IStream** ppOutputStream) const;
151
152private:
153 CXTPComInitializer* m_pComInitializer;
154 XTPXML::IXMLDOMDocumentPtr m_pXmlDocument;
155 mutable ErrorInfo m_errorInfo;
156 BOOL m_bInFixReferenceToUndeclaredNamespacePrefixX;
157 static const BYTE UnicodeBOM[2];
158};
159
160AFX_INLINE const CXTPMarkupParser::ErrorInfo& CXTPMarkupParser::GetErrorInfo() const
161{
162 return m_errorInfo;
163}
164
165AFX_INLINE XTPXML::IXMLDOMDocumentPtr CXTPMarkupParser::GetXmlDocument()
166{
167 return m_pXmlDocument;
168}
169
172# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
174#endif // !defined(__XTPMARKUPPARSER_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPComInitializer
Initializes COM and increments and holds COM initialization reference counter for the thread where co...
Definition XTPSystemHelpers.h:2021


Toolkit Pro: Member List

CXTPChartPieSeriesPointViewBase Member List

This is the complete list of members for CXTPChartPieSeriesPointViewBase, including all inherited members.

AddChildView(CXTPChartElementView *pChildView) | CXTPChartElementView |
CalculateLayout(double &dAngle)=0 | CXTPChartPieSeriesPointViewBase | pure virtual
CreateDeviceCommand(CXTPChartDeviceContext *pDC)=0 | CXTPChartPieSeriesPointViewBase | pure virtual
CreateLegendDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcBounds)=0 | CXTPChartPieSeriesPointViewBase | pure virtual
CXTPChartElementView(CXTPChartElementView *pParentView) | CXTPChartElementView |
CXTPChartElementView(CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartElementView |
CXTPChartElementView(CXTPChartContainer *pContainer) | CXTPChartElementView |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartPieSeriesPointViewBase(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView) | CXTPChartPieSeriesPointViewBase | protected
CXTPChartPieSeriesPointViewBase(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartPieSeriesPointViewBase | protected
CXTPChartSeriesPointView(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView) | CXTPChartSeriesPointView |
CXTPChartSeriesPointView(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartSeriesPointView |
GetAt(int nIndex) const | CXTPChartElementView |
GetBasePoint() const | CXTPChartPieSeriesPointViewBase |
GetBounds() const | CXTPChartElementView |
GetBounds(BOOL bIncludingChildren) const | CXTPChartElementView |
GetChildren() | CXTPChartElementView |
GetColor() const | CXTPChartSeriesPointView |
GetColor2() const | CXTPChartSeriesPointView |
GetCount() const | CXTPChartElementView |
GetInternalValue() const | CXTPChartSeriesPointView |
GetLegendName() const | CXTPChartSeriesPointView | virtual
GetParentView() const | CXTPChartElementView |
GetPie() const | CXTPChartPieSeriesPointViewBase |
GetPoint() const | CXTPChartSeriesPointView |
GetSeriesView() const | CXTPChartSeriesPointView |
Is3D() const | CXTPChartObject |
m_arrChildren | CXTPChartElementView | protected
m_dInternalValue | CXTPChartSeriesPointView |
m_pContainer | CXTPChartElementView | protected
m_pParentView | CXTPChartElementView | protected
m_pPoint | CXTPChartSeriesPointView | protected
m_rcBounds | CXTPChartElementView | protected
UpdateMinMaxRange(double &nMinValue, double &nMaxValue) const | CXTPChartSeriesPointView | virtual
~CXTPChartElementView() | CXTPChartElementView | protectedvirtual
~CXTPChartLegendItemView() | CXTPChartLegendItemView | inlinevirtual
~CXTPChartPieSeriesPointViewBase() | CXTPChartPieSeriesPointViewBase | virtual


Toolkit Pro: Member List

CXTPGridThemeVisualStudio2012Blue Member List

This is the complete list of members for CXTPGridThemeVisualStudio2012Blue, including all inherited members.

CalcColumnHeight(CDC *pDC, CXTPGridColumn *pColumn, int nTotalWidth=0) | CXTPGridPaintManager | protectedvirtual
CalculateRowHeight(CDC *pDC, const CString &strText, int nMaxWidth, BOOL bWordBreak=TRUE) | CXTPGridPaintManager | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPGridPaintManager() | CXTPGridPaintManager |
CXTPGridThemeOffice2013() | CXTPGridThemeOffice2013 |
CXTPGridThemeVisualStudio2012Blue() | CXTPGridThemeVisualStudio2012Blue |
DrawBitmap(CDC *pDC, CXTPGridControl *pControl, CRect rcColumn, int iImage) | CXTPGridPaintManager | virtual
DrawCollapsedBitmap(CDC *pDC, const CXTPGridRow *pRow, CRect &rcBitmap) | CXTPGridThemeOffice2013 | virtual
DrawColumn(CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn, BOOL bDrawExternal=FALSE, int nShadowWidth=0) | CXTPGridPaintManager | virtual
DrawColumnBackground(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, BOOL &bColumnPressed, BOOL &bDraggingFromHeader, CXTPGridHeader *pHeader=NULL) | CXTPGridThemeOffice2013 | virtual
DrawColumnFooter(CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn) | CXTPGridPaintManager | virtual
DrawColumnFooterDivider(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn) | CXTPGridPaintManager | virtual
DrawColumnIcon(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, CRect rcIcon, int iIcon) | CXTPGridPaintManager | virtual
DrawColumnText(CDC *pDC, CRect rcText, CString strCaption, int nHeaderAlignment, BOOL bIsHeader, BOOL bColumnPressed) | CXTPGridThemeOffice2013 | virtual
DrawConnector(CDC *pDC, CPoint ptFrom, CPoint ptTo) | CXTPGridPaintManager |
DrawFocusedRow(CDC *pDC, CRect rcRow) | CXTPGridThemeOffice2013 | virtual
DrawFreezeColsDivider(CDC *pDC, const CRect &rc, CXTPGridControl *pControl, CXTPGridRow *pRow=NULL) | CXTPGridPaintManager | virtual
DrawGlyph(CDC *pDC, CRect rcColumn, int iImage) | CXTPGridPaintManager | virtual
DrawGrid(CDC *pDC, XTPGridOrientation orientation, CRect rcGrid) | CXTPGridPaintManager | virtual
DrawGridPattern(CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush) | CXTPGridPaintManager | protectedvirtual
DrawGridPattern(CDC *pDC, CXTPBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush) | CXTPGridPaintManager | protectedvirtual
DrawGridPattern(CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr) | CXTPGridPaintManager | protectedvirtual
DrawGroupRow(CDC *pDC, CXTPGridGroupRow *pRow, CRect rcRow, XTP_GRIDRECORDITEM_METRICS *pMetrics) | CXTPGridThemeOffice2013 | virtual
DrawHorizontalLine(CDC *pDC, int xPos, int yPos, int cx, COLORREF clr) | CXTPGridPaintManager |
DrawInplaceButton(CDC *pDC, CXTPGridInplaceButton *pButton) | CXTPGridPaintManager | virtual
DrawInplaceButtonFrame(CDC *pDC, CXTPGridInplaceButton *pButton) | CXTPGridPaintManager | protectedvirtual
DrawInplaceButtonIcon(CDC *pDC, CXTPGridInplaceButton *pButton) | CXTPGridPaintManager | protectedvirtual
DrawInplaceComboButton(CDC *pDC, CRect *pRc) | CXTPGridPaintManager | virtual
DrawInplaceExpandButton(CDC *pDC, CRect *pRc) | CXTPGridPaintManager | virtual
DrawInplaceSpinButton(CDC *pDC, CRect *pRc) | CXTPGridPaintManager | virtual
DrawItemBitmap(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CRect &rcItem, int nImage) | CXTPGridPaintManager | virtual
DrawItemCaption(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics) | CXTPGridPaintManager | virtual
DrawItemControl(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CXTPGridRecordItemControl *pControl, CRect &rcItem) | CXTPGridPaintManager | virtual
DrawLink(int *pnCurrDrawPos, XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CXTPGridHyperlink *pHyperlink, CString strText, CRect rcLink, int nFlag, BOOL bTrim=FALSE) | CXTPGridPaintManager | protectedvirtual
DrawMultiLineText(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, BOOL bWordBreak=TRUE) | CXTPGridPaintManager | protectedvirtual
DrawNoGroupByText(CDC *pDC, CRect rcItem) | CXTPGridPaintManager | virtual
DrawRowNumber(CDC *pDC, CRect rcNumber, CXTPGridRow *pRow) | CXTPGridPaintManager | virtual
DrawSectionDivider(CDC *pDC, const CRect &rc, XTPGridSectionDividerPosition dividerPosition, XTPGridSectionDividerStyle dividerStyle, CXTPPaintManagerColor dividerColor) | CXTPGridPaintManager |
DrawShellIcon(CDC *pDC, CRect rcColumn, int iImage) | CXTPGridPaintManager | virtual
DrawSingleLineText(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nStartPos, int nEndPos, int nActualWidth) | CXTPGridPaintManager | protectedvirtual
DrawString(int *pnCurrDrawPos, CDC *pDC, const CString &strDraw, CRect rcDraw, UINT nFormat) | CXTPGridPaintManager | protectedvirtual
DrawTextLine(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nFlag, int &nCharCounter, int &nHyperlinkCounter) | CXTPGridPaintManager | protectedvirtual
DrawTreeStructure(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CRect rcItem, CSize sizeGlyph) | CXTPGridPaintManager | virtual
DrawTriangle(CDC *pDC, CRect rcTriangle, BOOL bToDown, BOOL bDraggingFromHeader, int nShadowWidth, BOOL bColumnPressed) | CXTPGridThemeOffice2013 | virtual
DrawVerticalLine(CDC *pDC, int xPos, int yPos, int cy, COLORREF clr) | CXTPGridPaintManager |
DrawVerticalTimeLineMarker(CDC *pDC, int xPos, CXTPGridControl *pControl, COLORREF color=RGB(0, 255, 0)) | CXTPGridPaintManager | virtual
EnablePreviewMode(BOOL bIsPreviewMode) | CXTPGridPaintManager |
FillFooter(CDC *pDC, CRect rcFooter) | CXTPGridPaintManager | virtual
FillGroupByControl(CDC *pDC, CRect &rcGroupBy) | CXTPGridPaintManager | virtual
FillGroupRowMetrics(CXTPGridGroupRow *pRow, XTP_GRIDRECORDITEM_METRICS *pMetrics, BOOL bPrinting) | CXTPGridThemeOffice2013 | virtual
FillHeaderControl(CDC *pDC, CRect rcHeader) | CXTPGridPaintManager | virtual
FillIndent(CDC *pDC, CRect rcRow) | CXTPGridPaintManager | virtual
FillItemShade(CDC *pDC, CRect rcItem) | CXTPGridPaintManager | virtual
FillRow(CDC *pDC, CXTPGridRow *pRow, CRect rcRow) | CXTPGridPaintManager | virtual
FindRowAdjacentToMerged(const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, BOOL bUpward) | CXTPGridPaintManager |
FindRowAdjacentToMergedEx(const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, int &nAdjRowIndex, BOOL bUpward) | CXTPGridPaintManager |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetColumnOffice2007CustomThemeBaseColor() const | CXTPGridPaintManager |
GetColumnStyle() const | CXTPGridPaintManager |
GetControlBackColor(CXTPGridControl *pControl) | CXTPGridPaintManager | virtual
GetFooterHeight(CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0) | CXTPGridPaintManager | virtual
GetFreezeColsDividerStyle() const | CXTPGridPaintManager |
GetGlyphs() const | CXTPGridPaintManager |
GetHeaderHeight() | CXTPGridPaintManager | virtual
GetHeaderHeight(CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0) | CXTPGridPaintManager | virtual
GetItemHeight(XTP_GRIDRECORDITEM_DRAWARGS &drawArgs, int nWidth) | CXTPGridPaintManager |
GetMaxPreviewLines() | CXTPGridPaintManager |
GetPreviewItemHeight(CDC *pDC, CXTPGridRow *pRow, int nWidth, int nHeight) | CXTPGridPaintManager | virtual
GetPreviewLinesCount(CDC *pDC, CRect &rcText, const CString &strText) | CXTPGridPaintManager |
GetRowHeight(CDC *pDC, CXTPGridRow *pRow) | CXTPGridThemeOffice2013 | virtual
GetRowHeight(CDC *pDC, CXTPGridRow *pRow, int nTotalWidth) | CXTPGridThemeOffice2013 | virtual
GetRowHeightEx(CDC *pDC, CXTPGridRow *pRow, int nTotalWidth, const BOOL firstLevel=TRUE) | CXTPGridPaintManager |
GetSectionDividerHeight(XTPGridFixedRowsDividerStyle dividerStyle) | CXTPGridPaintManager |
GetTextFont() | CXTPGridPaintManager |
IsColumHotTrackingEnabled() const | CXTPGridPaintManager | virtual
IsColumnPlusMinusSign() const | CXTPGridPaintManager |
IsColumnWidthWYSIWYG() const | CXTPGridPaintManager |
IsDrawGridForEmptySpace() const | CXTPGridPaintManager |
IsFixedInplaceButtonHeight() const | CXTPGridPaintManager |
IsFixedRowHeight() const | CXTPGridPaintManager |
IsGridVisible(BOOL bVertical) const | CXTPGridPaintManager |
IsGridVisible(XTPGridOrientation orientation) const | CXTPGridPaintManager |
IsLastColumnWidthWYSIWYG() const | CXTPGridPaintManager |
IsPreviewMode() const | CXTPGridPaintManager |
IsPrintGroupRowIcon() const | CXTPGridPaintManager |
IsShowWYSIWYGMarkers() const | CXTPGridPaintManager |
IsUseDropMarker() const | CXTPGridPaintManager |
LoadGlyphs() | CXTPGridThemeVisualStudio2012Blue | virtual
m_arStartCol | CXTPGridPaintManager |
m_bAllowMergeCells | CXTPGridPaintManager |
m_bBaseTreeIndent | CXTPGridPaintManager |
m_bCleanTooltip | CXTPGridPaintManager |
m_bColumnPlusMinusSign | CXTPGridPaintManager | protected
m_bColumnWidthWYSIWYG | CXTPGridPaintManager | protected
m_bCompactText | CXTPGridPaintManager |
m_bDrawGridForEmptySpace | CXTPGridPaintManager | protected
m_bFixedInplaceButtonHeight | CXTPGridPaintManager | protected
m_bFixedRowHeight | CXTPGridPaintManager | protected
m_bForceDynamicMarkupForCell | CXTPGridPaintManager |
m_bForceShowDropMarker | CXTPGridPaintManager |
m_bForceShowTooltip | CXTPGridPaintManager |
m_bGrayIfDisable | CXTPGridPaintManager |
m_bGroupRowTextBold | CXTPGridPaintManager |
m_bHideSelection | CXTPGridPaintManager |
m_bHotTracking | CXTPGridPaintManager |
m_bInvertColumnOnClick | CXTPGridPaintManager |
m_bIsPreviewMode | CXTPGridPaintManager | protected
m_bLastColumnWidthWYSIWYG | CXTPGridPaintManager | protected
m_bMakeUpper | CXTPGridPaintManager |
m_bMoveScrollbarOnFixedColumnsIndent | CXTPGridPaintManager |
m_bPrintGroupRowIcon | CXTPGridPaintManager | protected
m_bPrintPageRectangle | CXTPGridPaintManager |
m_bPrintSortTriangle | CXTPGridPaintManager |
m_bPrintVirtualPageNumber | CXTPGridPaintManager |
m_bPrintWatermark | CXTPGridPaintManager |
m_bRecOrRowNum | CXTPGridPaintManager |
m_bRevertAlignment | CXTPGridPaintManager |
m_bShadeGroupHeadings | CXTPGridPaintManager |
m_bShadeSortColumn | CXTPGridPaintManager |
m_bShowLockIcon | CXTPGridPaintManager |
m_bShowNonActiveInPlaceButton | CXTPGridPaintManager |
m_bShowWYSIWYGMarkers | CXTPGridPaintManager | protected
m_bSortTriangleOffsetFromRight | CXTPGridPaintManager |
m_bThemedInplaceButtons | CXTPGridPaintManager |
m_bUseAlternativeBackground | CXTPGridPaintManager |
m_bUseDropMarker | CXTPGridPaintManager |
m_bUseEditTextAlignment | CXTPGridPaintManager |
m_bUseGroupRowSelectionState | CXTPGridPaintManager |
m_bUseShellIcon | CXTPGridPaintManager |
m_clrAlternativeBackground | CXTPGridPaintManager |
m_clrBoldText | CXTPGridPaintManager |
m_clrBoldTextHighlight | CXTPGridPaintManager |
m_clrBtnFace | CXTPGridPaintManager |
m_clrBtnFacePressed | CXTPGridPaintManager |
m_clrBtnText | CXTPGridPaintManager |
m_clrCaptionText | CXTPGridPaintManager |
m_clrCaptionTextPressed | CXTPGridPaintManager |
m_clrColumnOffice2007CustomTheme | CXTPGridPaintManager |
m_clrConnector | CXTPGridPaintManager |
m_clrControlBack | CXTPGridPaintManager |
m_clrControlDark | CXTPGridPaintManager |
m_clrControlLightLight | CXTPGridPaintManager |
m_clrDisableBitmapDarkest | CXTPGridPaintManager |
m_clrDisableBitmapLightest | CXTPGridPaintManager |
m_clrFormulaSubSum | CXTPGridPaintManager |
m_clrFormulaSum | CXTPGridPaintManager |
m_clrFreezeColsDivider | CXTPGridPaintManager |
m_clrGlyph | CXTPGridThemeOffice2013 |
m_clrGlyphBorder | CXTPGridThemeOffice2013 |
m_clrGlyphContract | CXTPGridThemeOffice2013 |
m_clrGlyphExpand | CXTPGridThemeOffice2013 |
m_clrGlyphHighlight | CXTPGridThemeOffice2013 |
m_clrGradientColumnSeparator | CXTPGridPaintManager |
m_clrGradientColumnShadow | CXTPGridPaintManager |
m_clrGroupBoxBack | CXTPGridPaintManager |
m_clrGroupRowText | CXTPGridPaintManager |
m_clrGroupShadeBack | CXTPGridPaintManager |
m_clrGroupShadeBorder | CXTPGridPaintManager |
m_clrGroupShadeText | CXTPGridPaintManager |
m_clrHeaderControl | CXTPGridPaintManager |
m_clrHighlight | CXTPGridPaintManager |
m_clrHighlightText | CXTPGridPaintManager |
m_clrHotDivider | CXTPGridPaintManager |
m_clrIndentControl | CXTPGridPaintManager |
m_clrItemShade | CXTPGridPaintManager |
m_clrPreviewText | CXTPGridPaintManager |
m_clrSelectedRow | CXTPGridPaintManager |
m_clrSelectedRowText | CXTPGridPaintManager |
m_clrWindowText | CXTPGridPaintManager |
m_columnStyle | CXTPGridPaintManager | protected
m_crlNoGroupByText | CXTPGridPaintManager |
m_grcGradientColumn | CXTPGridPaintManager |
m_grcGradientColumnHot | CXTPGridPaintManager |
m_grcGradientColumnPushed | CXTPGridPaintManager |
m_iRecOrRowStart | CXTPGridPaintManager |
m_nBaseParentRecordIndent | CXTPGridPaintManager |
m_nFixedColumnsIndent | CXTPGridPaintManager |
m_nFooterHeight | CXTPGridPaintManager | protected
m_nFreezeColsDividerStyle | CXTPGridPaintManager | protected
m_nGridLineStylePreviousH | CXTPGridPaintManager | protected
m_nGridLineStylePreviousV | CXTPGridPaintManager | protected
m_nGroupGridLineHeight | CXTPGridPaintManager | protected
m_nGroupGridLineStyle | CXTPGridPaintManager | protected
m_nHeaderHeight | CXTPGridPaintManager | protected
m_nMaxPreviewLines | CXTPGridPaintManager | protected
m_nResizingWidth | CXTPGridPaintManager | protected
m_nRowHeight | CXTPGridPaintManager | protected
m_nRowHeightDefault | CXTPGridPaintManager |
m_nTextIndentForGroupRowsWithNoIcon | CXTPGridPaintManager |
m_nTreeColumnLineLength | CXTPGridPaintManager |
m_nTreeIndent | CXTPGridPaintManager |
m_nTreeStructureStyle | CXTPGridPaintManager |
m_nTreeTextIndent | CXTPGridPaintManager |
m_nTreeTextIndentGroupRow | CXTPGridPaintManager |
m_nTreeTextIndentRowChildren | CXTPGridPaintManager |
m_nTreeTextIndentRowParent | CXTPGridPaintManager |
m_pControl | CXTPGridPaintManager | protected
m_pGlyphs | CXTPGridPaintManager | protected
m_pHyperlinkHoverStyle | CXTPGridPaintManager |
m_pHyperlinkStyle | CXTPGridPaintManager |
m_pMarkupUIElement_NoGroupBy | CXTPGridPaintManager | protected
m_PrintPageWidth | CXTPGridPaintManager |
m_rcPreviewIndent | CXTPGridPaintManager |
m_RecordNumberWidth | CXTPGridPaintManager |
m_strCollapse | CXTPGridPaintManager |
m_strDecreasing | CXTPGridPaintManager |
m_strExpand | CXTPGridPaintManager |
m_strIncreasing | CXTPGridPaintManager |
m_strMarkupUIElement_NoGroupBy | CXTPGridPaintManager | protected
m_strNoFieldsAvailable | CXTPGridPaintManager |
m_strNoGroupBy | CXTPGridPaintManager |
m_strNoItems | CXTPGridPaintManager |
m_strSortBy | CXTPGridPaintManager |
m_szGlyph | CXTPGridPaintManager | protected
m_themeButton | CXTPGridPaintManager | protected
m_themeCombo | CXTPGridPaintManager | protected
m_themeHeader | CXTPGridPaintManager | protected
m_themeSpin | CXTPGridPaintManager | protected
m_treeStructureStyle | CXTPGridPaintManager |
m_xtpBrushGroupGridLineStyle | CXTPGridPaintManager | protected
m_xtpBrushHorizontalGrid | CXTPGridPaintManager | protected
m_xtpBrushTreeStructure | CXTPGridPaintManager | protected
m_xtpBrushVeriticalGrid | CXTPGridPaintManager | protected
m_xtpFontBoldText | CXTPGridPaintManager |
m_xtpFontCaption | CXTPGridPaintManager |
m_xtpFontPreview | CXTPGridPaintManager |
m_xtpFontText | CXTPGridPaintManager |
OnDrawAction(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs) | CXTPGridPaintManager | virtual
RecalcTotalHightOfMergedRows(CXTPGridColumns *pColumns, CDC *pDC, CXTPGridRow *pRow, int nRowHeight, int nTotalWidth) | CXTPGridPaintManager |
RefreshMetrics() | CXTPGridThemeVisualStudio2012Blue | virtual
SetCaptionFont(LOGFONT &lf) | CXTPGridPaintManager |
SetColumnOffice2007CustomThemeBaseColor(COLORREF clrBaseColor) | CXTPGridPaintManager |
SetColumnPlusMinusSign(BOOL bDraw) | CXTPGridPaintManager |
SetColumnStyle(XTPGridColumnStyle columnStyle) | CXTPGridPaintManager |
SetColumnWidthWYSIWYG(BOOL bColumnWidthWYSIWYG) | CXTPGridPaintManager |
SetDrawGridForEmptySpace(BOOL bDrawGrid) | CXTPGridPaintManager |
SetFixedRowHeight(BOOL bFixedRowHeight) | CXTPGridPaintManager |
SetFreezeColsDividerStyle(int nStyle) | CXTPGridPaintManager |
SetGridControl(CXTPGridControl *pControl) | CXTPGridPaintManager | virtual
SetHeaderHeight(int nHeight) | CXTPGridPaintManager | virtual
SetInplaceButtonHeight(BOOL bFixedInplaceButtonHeight) | CXTPGridPaintManager |
SetLastColumnWidthWYSIWYG(BOOL bColumnWidthWYSIWYG) | CXTPGridPaintManager |
SetMaxPreviewLines(int nMaxLines) | CXTPGridPaintManager |
SetPreviewIndent(int nLeft, int nTop, int nRight, int nBottom) | CXTPGridPaintManager |
SetPrintGroupRowIcon(BOOL bDraw) | CXTPGridPaintManager |
SetTextFont(LOGFONT &lf) | CXTPGridPaintManager |
ShowWYSIWYGMarkers(BOOL bSet) | CXTPGridPaintManager |
~CXTPGridPaintManager() | CXTPGridPaintManager | virtual


Toolkit Pro: Member List

CXTPImageManager Member List

This is the complete list of members for CXTPImageManager, including all inherited members.

AddCustomIcon(const CXTPImageManagerIconHandle &hIcon) | CXTPImageManager |
AddIcons(CXTPImageManager *pImageManager) | CXTPImageManager |
AddIcons(CXTPImageManagerIconSet *pIconSet) | CXTPImageManager |
AlphaBlend(HDC hdcDest, const CRect &rcDest, HDC hdcSrc, const CRect &rcSrc) const | CXTPImageManager |
AlphaBlend2(HDC hdcDest, const CRect &rcDest, HDC hdcSrc, const CRect &rcSrc, BYTE Transparency) const | CXTPImageManager |
BlackWhiteBitmap(HDC hDC, const CRect &rcRect, int nBlackAndWhiteContrast=0) | CXTPImageManager |
Create32BPPDIBSection(HDC hDC, int iWidth, int iHeight, LPBYTE *lpBits=NULL) | CXTPImageManager | static
CXTPCmdTarget() | CXTPCmdTarget |
CXTPImageManager() | CXTPImageManager |
DisableBitmap(HDC hDC, const CRect &rcRect, COLORREF clrDisabledLight=(COLORREF) -1, COLORREF clrDisabledDark=(COLORREF) -1) | CXTPImageManager |
DoPropExchange(CXTPPropExchange *pPX) | CXTPImageManager |
DoPropExchange(UINT nCommand, CXTPPropExchange *pPX) | CXTPImageManager |
DrawReverted(BOOL bDrawReverted) | CXTPImageManager |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetBitmapMaskColor(CBitmap &bmp, CPoint pt=0) | CXTPImageManager | static
GetBitmapMaskColor(UINT nIDBitmap, CPoint pt=0) | CXTPImageManager | static
GetIconSet(UINT nCommand) const | CXTPImageManager |
GetImage(UINT nCommand, int nWidth=16) const | CXTPImageManager |
GetImageList(UINT nCommand) const | CXTPImageManager |
GetImages() | CXTPImageManager |
GetMaskColor() const | CXTPImageManager |
GetResource(CSize szIcon) | CXTPImageManager |
IsAlphaBitmapResource(UINT nIDResourceBitmap) | CXTPImageManager | static
IsAlphaIconsImageListSupported() | CXTPImageManager | static
IsAlphaIconsSupported() const | CXTPImageManager |
IsDrawReverted() const | CXTPImageManager |
IsDrawReverted(CDC *pDC) const | CXTPImageManager |
IsPngBitmapResource(UINT nIDResourceBitmap) | CXTPImageManager | static
IsPrimaryImageExists(UINT nCommand, int nWidth) const | CXTPImageManager |
Lookup(UINT nCommand) const | CXTPImageManager |
m_bAutoResample | CXTPImageManager | static
m_bUseResources | CXTPImageManager |
m_dDisabledAlphaFactor | CXTPImageManager | static
m_dDisabledBrightnessFactor | CXTPImageManager | static
m_nAlphaClipFormat | CXTPImageManager | static
m_nImageClipFormat | CXTPImageManager | static
McTransparentBlt(HDC hdcDest, int nXOriginDest, int nYOriginDest, int nWidthDest, int nHeightDest, HDC hdcSrc, int nXOriginSrc, int nYOriginSrc, int nWidthSrc, int nHeightSrc, UINT crTransparent) | CXTPImageManager | static
PreMultiplyAlphaBitmapBits(LPVOID lpBits, SIZE_T nSize, PBOOL pbAlpha=NULL) | CXTPImageManager | static
PreMultiplyAlphaBitmapBits(LPVOID lpBits, CSize size, PBOOL pbAlpha=NULL) | CXTPImageManager | static
RefreshAll() | CXTPImageManager |
RemoveAll() | CXTPImageManager |
RemoveIcon(UINT nIDCommand) | CXTPImageManager |
ResampleAlphaLayer(HBITMAP bmpAlpha, COLORREF clrMask) | CXTPImageManager | static
ResampleAlphaLayer(UINT nIDBitmap, COLORREF clrMask) | CXTPImageManager | static
Serialize(CArchive &ar) | CXTPImageManager |
Serialize(UINT nCommand, CArchive &ar) | CXTPImageManager |
SetIcon(const CXTPImageManagerIconHandle &hIcon, UINT nIDCommand, CSize szIcon=0, XTPImageState imageState=xtpImageNormal) | CXTPImageManager |
SetIcon(UINT nIDResourceIcon, UINT nIDCommand, CSize szIcon=0, XTPImageState imageState=xtpImageNormal) | CXTPImageManager |
SetIcon(LPCTSTR lpszResourceIcon, UINT nIDCommand, CSize szIcon=0, XTPImageState imageState=xtpImageNormal) | CXTPImageManager |
SetIconFromIcoFile(LPCTSTR lpszFileName, UINT nIDCommand, CSize szIcon, XTPImageState imageState) | CXTPImageManager |
SetIconFromResource(HINSTANCE hInst, LPCTSTR lpszResourceName, UINT nIDCommand, CSize szIcon, XTPImageState imageState) | CXTPImageManager |
SetIcons(UINT nIDResourceToolBar, XTPImageState imageState=xtpImageNormal) | CXTPImageManager |
SetIcons(UINT nIDResourceToolBar, UINT nIDResourceBitmap, XTPImageState imageState=xtpImageNormal) | CXTPImageManager |
SetIcons(CBitmap &bmpIcons, UINT *pCommands, int nCount, CSize szIcon, XTPImageState imageState=xtpImageNormal, BOOL bAlpha=FALSE) | CXTPImageManager |
SetIcons(UINT nIDResourceToolBar, CBitmap &bmpIcons, XTPImageState imageState=xtpImageNormal) | CXTPImageManager |
SetIcons(UINT nIDResourceBitmap, UINT *pCommands, int nCount, CSize szIcon, XTPImageState imageState=xtpImageNormal) | CXTPImageManager |
SetIcons(LPCTSTR lpszResourceBitmap, UINT *pCommands, int nCount, CSize szIcon, XTPImageState imageState=xtpImageNormal) | CXTPImageManager |
SetIcons(CImageList &imlIcons, UINT *pCommands, int nCount, CSize szIcon, XTPImageState imageState=xtpImageNormal) | CXTPImageManager |
SetIcons(UINT nIDResourceToolBar, CImageList &imlIcons, XTPImageState imageState=xtpImageNormal) | CXTPImageManager |
SetImageList(HIMAGELIST hImageList, int nBaseCommand, BOOL bDestroyImageList=FALSE) | CXTPImageManager |
SetImageList(UINT nIDResourceBitmap, int cx, int nBaseCommand=0, COLORREF clrMask=(COLORREF) -1) | CXTPImageManager |
SetMaskColor(COLORREF clrMask) | CXTPImageManager |
SetVectorIcon(LPCTSTR lpResourceType, UINT nIDResource, UINT nIDCommand, UINT nWidth, XTPImageState imageState=xtpImageNormal) | CXTPImageManager |
SetVectorIcon(LPCTSTR lpResourceType, LPCTSTR lpResource, UINT nIDCommand, UINT nWidth, XTPImageState imageState=xtpImageNormal) | CXTPImageManager |
SetVectorIcon(HMODULE hModule, LPCTSTR lpResourceType, UINT nIDResource, UINT nIDCommand, UINT nWidth, XTPImageState imageState=xtpImageNormal) | CXTPImageManager |
SetVectorIcon(HMODULE hModule, LPCTSTR lpResourceType, LPCTSTR lpResource, UINT nIDCommand, UINT nWidth, XTPImageState imageState=xtpImageNormal) | CXTPImageManager |
SetVectorIcon(CXTPImageManagerVectorImageHandle hImage, UINT nIDCommand, UINT nWidth, XTPImageState imageState=xtpImageNormal) | CXTPImageManager |
SetVectorIcon(LPCTSTR lpResourceType, UINT nIDResourceNormal, UINT nIDResourceDisabled, UINT nIDResourceHot, UINT nIDResourceChecked, UINT nIDResourcePressed, UINT nIDCommand, UINT nWidth) | CXTPImageManager |
SetVectorIcon(LPCTSTR lpResourceType, LPCTSTR lpIDResourceNormal, LPCTSTR lpIDResourceDisabled, LPCTSTR lpIDResourceHot, LPCTSTR lpIDResourceChecked, LPCTSTR lpIDResourcePressed, UINT nIDCommand, UINT nWidth) | CXTPImageManager |
SetVectorIcon(HMODULE hModule, LPCTSTR lpResourceType, UINT nIDResourceNormal, UINT nIDResourceDisabled, UINT nIDResourceHot, UINT nIDResourceChecked, UINT nIDResourcePressed, UINT nIDCommand, UINT nWidth) | CXTPImageManager |
SetVectorIcon(HMODULE hModule, LPCTSTR lpResourceType, LPCTSTR lpIDResourceNormal, LPCTSTR lpIDResourceDisabled, LPCTSTR lpIDResourceHot, LPCTSTR lpIDResourceChecked, LPCTSTR lpIDResourcePressed, UINT nIDCommand, UINT nWidth) | CXTPImageManager |
SetVectorIcon(CXTPImageManagerVectorImageHandle hImageNormal, CXTPImageManagerVectorImageHandle hImageDisabled, CXTPImageManagerVectorImageHandle hImageHot, CXTPImageManagerVectorImageHandle hImageChecked, CXTPImageManagerVectorImageHandle hImagePressed, UINT nIDCommand, UINT nWidth) | CXTPImageManager |
SetVectorIcon(IStream *pStream, UINT nIDCommand, UINT nWidth, XTPImageState imageState) | CXTPImageManager |
TransparentBlt(HDC hdcDest, const CRect &rcDest, HDC hdcSrc, const CRect &rcSrc, UINT crTransparent) const | CXTPImageManager |
XTPImageManager() | CXTPImageManager | friend
~CXTPImageManager() | CXTPImageManager |


Toolkit Pro: Member List

CXTPShortcutBarOffice2013Theme Member List

This is the complete list of members for CXTPShortcutBarOffice2013Theme, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPShortcutBarOffice2003Theme() | CXTPShortcutBarOffice2003Theme |
CXTPShortcutBarOffice2013Theme() | CXTPShortcutBarOffice2013Theme |
CXTPShortcutBarPaintManager() | CXTPShortcutBarPaintManager |
CXTPShortcutBarResourceTheme() | CXTPShortcutBarResourceTheme |
DrawExpandButton(CDC *pDC, CRect rc) | CXTPShortcutBarOffice2013Theme | virtual
DrawGripper(CDC *pDC, CXTPShortcutBar *pShortcutBar, BOOL bDraw) | CXTPShortcutBarOffice2013Theme | virtual
DrawImage(CDC *pDC, CPoint pt, CSize sz, CXTPImageManagerIcon *pImage, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled) | CXTPShortcutBarOffice2003Theme | virtual
DrawNavigationItem(CDC *pDC, CXTPShortcutBarItem *pItem) | CXTPShortcutBarPaintManager | virtual
DrawPaneCaption(CDC *pDC, CXTPShortcutBarPane *pPane, BOOL bDraw) | CXTPShortcutBarResourceTheme | virtual
DrawPaneItemCaption(CDC *pDC, CXTPShortcutBarPaneItem *pItem, BOOL bDraw) | CXTPShortcutBarOffice2013Theme | virtual
DrawShortcutBarFrame(CDC *pDC, CXTPShortcutBar *pShortcutBar) | CXTPShortcutBarOffice2003Theme | virtual
DrawShortcutItem(CDC *pDC, CXTPShortcutBarItem *pItem) | CXTPShortcutBarPaintManager | virtual
FillNavigationItemEntry(CDC *pDC, CXTPShortcutBarItem *pItem) | CXTPShortcutBarOffice2013Theme | virtual
FillShortcutBar(CDC *pDC, CXTPShortcutBar *pShortcutBar) | CXTPShortcutBarOffice2013Theme | virtual
FillShortcutItemEntry(CDC *pDC, CXTPShortcutBarItem *pItem) | CXTPShortcutBarOffice2013Theme | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
IsShortcutItemTruncated(CDC *pDC, CXTPShortcutBarItem *pItem) | CXTPShortcutBarPaintManager |
Line(CDC *pDC, int x0, int y0, int x1, int y1, int nPen) | CXTPShortcutBarPaintManager |
m_bBoldItemCaptionFont | CXTPShortcutBarPaintManager |
m_bClearTypeTextQuality | CXTPShortcutBarPaintManager |
m_bNavigationButton | CXTPShortcutBarPaintManager |
m_bShowTopLeftCaptionShadow | CXTPShortcutBarOffice2003Theme |
m_bUseStandardFont | CXTPShortcutBarPaintManager |
m_clrCaptionText | CXTPShortcutBarOffice2003Theme |
m_clrDisabledText | CXTPShortcutBarPaintManager |
m_clrGlyph | CXTPShortcutBarOffice2013Theme | protected
m_clrGlyphExpanded | CXTPShortcutBarOffice2013Theme | protected
m_clrGlyphFill | CXTPShortcutBarOffice2013Theme | protected
m_clrGlyphPushed | CXTPShortcutBarOffice2013Theme | protected
m_clrHotText | CXTPShortcutBarPaintManager |
m_clrItemCaptionShadow | CXTPShortcutBarOffice2003Theme |
m_clrItemCaptionText | CXTPShortcutBarOffice2003Theme |
m_clrItemCaptionTop | CXTPShortcutBarOffice2003Theme |
m_clrNormalText | CXTPShortcutBarPaintManager |
m_clrPushedText | CXTPShortcutBarPaintManager |
m_clrSelectedText | CXTPShortcutBarPaintManager |
m_clrShortcutItemShadow | CXTPShortcutBarPaintManager |
m_grcCaption | CXTPShortcutBarOffice2003Theme |
m_grcHot | CXTPShortcutBarPaintManager |
m_grcItemCaption | CXTPShortcutBarOffice2003Theme |
m_grcItemHotCaption | CXTPShortcutBarOffice2003Theme |
m_grcPushed | CXTPShortcutBarPaintManager |
m_grcSelected | CXTPShortcutBarPaintManager |
m_grcShortcutBarGripper | CXTPShortcutBarPaintManager |
m_grcShortcutItem | CXTPShortcutBarPaintManager |
m_nExpandedIconWidth | CXTPShortcutBarPaintManager |
m_nNormalIconWidth | CXTPShortcutBarPaintManager |
m_nPaneItemHeight | CXTPShortcutBarPaintManager |
m_pExpandIcon | CXTPShortcutBarPaintManager |
m_rcCaptionPadding | CXTPShortcutBarPaintManager |
m_rcItemCaptionPadding | CXTPShortcutBarPaintManager |
m_strOfficeFont | CXTPShortcutBarPaintManager |
m_xtpFontPaneCaption | CXTPShortcutBarPaintManager |
m_xtpFontPaneItemCaption | CXTPShortcutBarPaintManager |
m_xtpFontText | CXTPShortcutBarPaintManager |
m_xtpFontVerticalText | CXTPShortcutBarPaintManager |
Rectangle(CDC *pDC, CRect rc, int nPen, int nBrush) | CXTPShortcutBarPaintManager |
RefreshMetrics() | CXTPShortcutBarOffice2013Theme | virtual
~CXTPShortcutBarOffice2013Theme() | CXTPShortcutBarOffice2013Theme | virtual
~CXTPShortcutBarPaintManager() | CXTPShortcutBarPaintManager | virtual


Toolkit Pro: XTPChartPointSeriesLabelView.h Source File

  • Source
  • Chart
  • Styles
  • Point
XTPChartPointSeriesLabelView.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTPOINTSERIESLABELVIEW_H__)
24# define __XTPCHARTPOINTSERIESLABELVIEW_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartSeriesView;
34
40class _XTP_EXT_CLASS CXTPChartPointSeriesLabelView : public CXTPChartDiagram2DSeriesLabelView
41{
42public:
51 CXTPChartPointSeriesLabelView(CXTPChartSeriesLabel* pLabel,
52 CXTPChartSeriesPointView* pPointView,
53 CXTPChartElementView* pParentView);
54
62 virtual CXTPChartPointF GetAnchorPoint() const;
63 virtual double GetAnchorAngle() const;
64};
66# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
67#endif //#if !defined(__XTPCHARTPOINTSERIESLABELVIEW_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartDiagram2DSeriesLabelView
This class abstracts the view of the label of a point series.
Definition XTPChartDiagram2DSeriesLabel.h:69
CXTPChartElementView
This class represents the view of a chart element.
Definition XTPChartElementView.h:47
CXTPChartPointSeriesLabelView
This class abstracts the view of the label of a point series.
Definition XTPChartPointSeriesLabelView.h:41
CXTPChartPointSeriesLabelView::GetAnchorPoint
virtual CXTPChartPointF GetAnchorPoint() const
This function calculates the anchor point of the label stem.
CXTPChartPointSeriesLabelView::CXTPChartPointSeriesLabelView
CXTPChartPointSeriesLabelView(CXTPChartSeriesLabel *pLabel, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView)
Constructs a CXTPChartPointSeriesLabelView object.
CXTPChartSeriesLabel
This class abstracts the label of a series.
Definition XTPChartSeriesLabel.h:49
CXTPChartSeriesPointView
Represents chart series point view.
Definition XTPChartSeriesPointView.h:48
CXTPPoint2T< float >


Toolkit Pro: Member List

XTP_GRIDRECORDITEM_CLICKARGS Member List

This is the complete list of members for XTP_GRIDRECORDITEM_CLICKARGS, including all inherited members.

pColumn | XTP_GRIDRECORDITEM_ARGS
pControl | XTP_GRIDRECORDITEM_ARGS
pItem | XTP_GRIDRECORDITEM_ARGS
pRow | XTP_GRIDRECORDITEM_ARGS
ptClient | XTP_GRIDRECORDITEM_CLICKARGS
rcItem | XTP_GRIDRECORDITEM_ARGS


Toolkit Pro: Member List

CXTPCalendarCaptionBarNativeWindows11Theme Member List

This is the complete list of members for CXTPCalendarCaptionBarNativeWindows11Theme, including all inherited members.

CXTPCalendarCaptionBarNativeWindows11Theme(CXTPCalendarCaptionBarTheme *pTheme=NULL) | CXTPCalendarCaptionBarNativeWindows11Theme |
CXTPCalendarCaptionBarOffice2000Theme(CXTPCalendarCaptionBarTheme *pTheme=NULL) | CXTPCalendarCaptionBarOffice2000Theme |
CXTPCalendarCaptionBarOffice2003Theme(CXTPCalendarCaptionBarTheme *pTheme=NULL) | CXTPCalendarCaptionBarOffice2003Theme |
CXTPCalendarCaptionBarOffice2013Theme(CXTPCalendarCaptionBarTheme *pTheme=NULL) | CXTPCalendarCaptionBarOffice2013Theme |
CXTPCalendarCaptionBarOfficeXPTheme(CXTPCalendarCaptionBarTheme *pTheme=NULL) | CXTPCalendarCaptionBarOfficeXPTheme |
CXTPCalendarCaptionBarPaintManager(CXTPCalendarCaptionBarTheme *pTheme=NULL) | CXTPCalendarCaptionBarPaintManager |
CXTPCmdTarget() | CXTPCmdTarget |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetPaintTheme() const | CXTPCalendarCaptionBarPaintManager | virtual
m_clrBorders | CXTPCalendarCaptionBarPaintManager | protected
m_clrScrollDateBarBk | CXTPCalendarCaptionBarPaintManager | protected
m_clrScrollTriangleColor | CXTPCalendarCaptionBarPaintManager | protected
m_clrSwitchViewBarBk | CXTPCalendarCaptionBarPaintManager | protected
m_clrTextColor | CXTPCalendarCaptionBarPaintManager | protected
m_fntTextFont | CXTPCalendarCaptionBarPaintManager | protected
m_pTheme | CXTPCalendarCaptionBarPaintManager | protected
RefreshMetrics() | CXTPCalendarCaptionBarOffice2013Theme | virtual
~CXTPCalendarCaptionBarNativeWindows11Theme() | CXTPCalendarCaptionBarNativeWindows11Theme | virtual
~CXTPCalendarCaptionBarOffice2000Theme() | CXTPCalendarCaptionBarOffice2000Theme | virtual
~CXTPCalendarCaptionBarOffice2003Theme() | CXTPCalendarCaptionBarOffice2003Theme | virtual
~CXTPCalendarCaptionBarOffice2013Theme() | CXTPCalendarCaptionBarOffice2013Theme | virtual
~CXTPCalendarCaptionBarOfficeXPTheme() | CXTPCalendarCaptionBarOfficeXPTheme | virtual
~CXTPCalendarCaptionBarPaintManager() | CXTPCalendarCaptionBarPaintManager | virtual


Toolkit Pro: XTPChart2dFunnelSeriesStyle.h Source File

  • Source
  • Chart
  • Styles
  • Funnel
  • 2D
XTPChart2dFunnelSeriesStyle.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHART2DFUNNELSERIESSTYLE_H__)
24# define __XTPCHART2DFUNNELSERIESSTYLE_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartSeriesView;
34class CXTPChartBorder;
35class CXTPChartFillStyle;
36
48class _XTP_EXT_CLASS CXTPChartFunnelSeriesStyle : public CXTPChartFunnelSeriesStyleBase
49{
51 DECLARE_SERIAL(CXTPChartFunnelSeriesStyle)
53public:
58 CXTPChartFunnelSeriesStyle();
59
60protected:
69 CXTPChartDiagram* CreateDiagram();
70
81 CXTPChartSeriesView* CreateView(CXTPChartSeries* pSeries, CXTPChartDiagramView* pDiagramView);
82
93 virtual BOOL IsStyleDiagram(CXTPChartDiagram* pDiagram) const;
94
96# ifdef _XTP_ACTIVEX
97public:
98 DECLARE_DISPATCH_MAP()
99 DECLARE_INTERFACE_MAP()
100 DECLARE_OLETYPELIB_EX(CXTPChartFunnelSeriesStyle);
101 DECLARE_OLECREATE_EX(CXTPChartFunnelSeriesStyle)
102# endif
104};
106# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
107#endif //#if !defined(__XTPCHART2DFUNNELSERIESSTYLE_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartBorder
This class abstracts the border of a chart, it is a kind of chart element.
Definition XTPChartBorder.h:42
CXTPChartDiagram
This class represents a chart diagram, which is a kind of CXTPChartElement.
Definition XTPChartDiagram.h:48
CXTPChartDiagramView
This class represents the view of a chart diagram, which is a kind of CXTPChartElementView.
Definition XTPChartDiagramView.h:49
CXTPChartFillStyle
This class abstracts a fill style used to fill the background of various chart elements.
Definition XTPChartFillStyle.h:43
CXTPChartFunnelSeriesStyleBase
This class abstracts the basic style of a funnel serie.This class is a kind of CXTPChartSeriesStyle.
Definition XTPChartFunnelSeriesStyleBase.h:49
CXTPChartFunnelSeriesStyle
This class abstracts the basic style of a funnel series.
Definition XTPChart2dFunnelSeriesStyle.h:49
CXTPChartFunnelSeriesStyle::CreateView
CXTPChartSeriesView * CreateView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Call this function to create the view of the funnel series.
CXTPChartFunnelSeriesStyle::CXTPChartFunnelSeriesStyle
CXTPChartFunnelSeriesStyle()
Constructs a CXTPChartFunnelSeriesStyleBase object.
CXTPChartFunnelSeriesStyle::IsStyleDiagram
virtual BOOL IsStyleDiagram(CXTPChartDiagram *pDiagram) const
Call this function to check whether the chart diagram object passed is a kind of CXTPChart3dFunnelDia...
CXTPChartFunnelSeriesStyle::CreateDiagram
CXTPChartDiagram * CreateDiagram()
Call this function to create the diagram for this series.
CXTPChartSeries
This class represents a series in the chart, which is a kind of CXTPChartElement.
Definition XTPChartSeries.h:50


Toolkit Pro: Member List

CXTPCalendarEventLabel Member List

This is the complete list of members for CXTPCalendarEventLabel, including all inherited members.

CXTPCalendarEventLabel(int nID=0, COLORREF clrColor=0, LPCTSTR pcszName=_T("")) | CXTPCalendarEventLabel |
CXTPCalendarEventLabel(CXTPCalendarEventLabel *pSrc) | CXTPCalendarEventLabel |
CXTPCmdTarget() | CXTPCmdTarget |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
m_clrColor | CXTPCalendarEventLabel |
m_nLabelID | CXTPCalendarEventLabel |
m_strName | CXTPCalendarEventLabel |
operator=(const CXTPCalendarEventLabel &rSrc) | CXTPCalendarEventLabel |
~CXTPCalendarEventLabel() | CXTPCalendarEventLabel | virtual


Toolkit Pro: XTPSyntaxEditPropertiesDlg.h Source File

  • Source
  • SyntaxEdit
XTPSyntaxEditPropertiesDlg.h
Go to the documentation of this file.
1
23#if !defined(__XTPSYNTAXEDITPROPERTIESDLG_H__)
24# define __XTPSYNTAXEDITPROPERTIESDLG_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPSyntaxEditView;
34
39class _XTP_EXT_CLASS CXTPSyntaxEditPropertiesDlg : public CPropertySheet
40{
42 DECLARE_DYNAMIC(CXTPSyntaxEditPropertiesDlg)
44public:
50 CXTPSyntaxEditPropertiesDlg(CXTPSyntaxEditView* pEditView = NULL);
51
56 virtual ~CXTPSyntaxEditPropertiesDlg();
57
58protected:
59 //{{AFX_MSG(CXTPSyntaxEditPropertiesDlg)
60 //}}AFX_MSG
61 DECLARE_MESSAGE_MAP()
62
63 CXTPSyntaxEditPropertiesPageEdit m_Page1;
64 CXTPSyntaxEditPropertiesPageFont m_Page2;
65 CXTPSyntaxEditPropertiesPageColor m_Page3;
66};
67
69
70//{{AFX_INSERT_LOCATION}}
71// Microsoft Visual C++ will insert additional declarations immediately before the previous line.
72
73# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
75#endif // !defined(__XTPSYNTAXEDITPROPERTIESDLG_H__)
XTPDisableNoisyWarnings.h
CXTPSyntaxEditPropertiesDlg
This class provides a default dialog to edit SyntaxEdit control settings.
Definition XTPSyntaxEditPropertiesDlg.h:40
CXTPSyntaxEditPropertiesDlg::~CXTPSyntaxEditPropertiesDlg
virtual ~CXTPSyntaxEditPropertiesDlg()
Default object destructor.
CXTPSyntaxEditPropertiesDlg::CXTPSyntaxEditPropertiesDlg
CXTPSyntaxEditPropertiesDlg(CXTPSyntaxEditView *pEditView=NULL)
Default object constructor.
CXTPSyntaxEditPropertiesDlg::DECLARE_MESSAGE_MAP
DECLARE_MESSAGE_MAP() CXTPSyntaxEditPropertiesPageEdit m_Page1
Property page for common edit options.
CXTPSyntaxEditPropertiesPageColor
This class implements property page colors options.
Definition XTPSyntaxEditPropertiesPage.h:648
CXTPSyntaxEditPropertiesPageEdit
This class implements a property page for common edit options.
Definition XTPSyntaxEditPropertiesPage.h:317
CXTPSyntaxEditPropertiesPageFont
This class implements property page font options.
Definition XTPSyntaxEditPropertiesPage.h:422
CXTPSyntaxEditView
This class represents a View portion of the Edit Control.
Definition XTPSyntaxEditView.h:89


Toolkit Pro: Member List

CXTPDockingPaneBaseContainer Member List

This is the complete list of members for CXTPDockingPaneBaseContainer, including all inherited members.

Clone(CXTPDockingPaneLayout *pLayout, CXTPPaneToPaneMap *pMap, DWORD dwIgnoredOptions=0) | CXTPDockingPaneBase | protectedvirtual
ContainPane(CXTPDockingPaneBase *pPane) const | CXTPDockingPaneBaseContainer | virtual
Copy(CXTPDockingPaneBase *pClone, CXTPPaneToPaneMap *pMap, DWORD dwIgnoredOptions) | CXTPDockingPaneBase | protectedvirtual
CreateContainer() | CXTPDockingPaneBase | protectedvirtual
CXTPDockingPaneBase(XTPDockingPaneType type, CXTPDockingPaneLayout *pLayout) | CXTPDockingPaneBase | protected
CXTPDockingPaneBaseContainer(XTPDockingPaneType type, CXTPDockingPaneLayout *pLayout) | CXTPDockingPaneBaseContainer | protected
DeletePane()=0 | CXTPDockingPaneBase | protectedpure virtual
DoPropExchange(CXTPPropExchange *pPX) | CXTPDockingPaneBase | protectedvirtual
FindCaptionButton(int nID) const | CXTPDockingPaneBase |
FindPane(XTPDockingPaneType type, CXTPDockingPaneBaseList *pList) const | CXTPDockingPaneBaseContainer | virtual
GetCaptionButtons() const | CXTPDockingPaneBase |
GetContainer() const | CXTPDockingPaneBase |
GetDockingPaneManager() const | CXTPDockingPaneBase |
GetDockingSite() const | CXTPDockingPaneBase | virtual
GetFirstPane() const | CXTPDockingPaneBaseContainer |
GetHeadPosition() const | CXTPDockingPaneBaseContainer |
GetLastPane() const | CXTPDockingPaneBaseContainer |
GetMinMaxInfo(LPMINMAXINFO pMinMaxInfo) const | CXTPDockingPaneBase | virtual
GetNext(POSITION &pos) const | CXTPDockingPaneBaseContainer |
GetPaintManager() const | CXTPDockingPaneBase |
GetPaneHwnd() const | CXTPDockingPaneBase | virtual
GetPanes() | CXTPDockingPaneBaseContainer |
GetPaneWindowRect() const | CXTPDockingPaneBase |
GetTitle() const | CXTPDockingPaneBase | virtual
GetType() const | CXTPDockingPaneBase |
InvalidatePane(BOOL bSelectionChanged) | CXTPDockingPaneBase | virtual
IsActive() const | CXTPDockingPaneBase | virtual
IsCaptionButtonVisible(CXTPDockingPaneCaptionButton *pButton) | CXTPDockingPaneBase | protectedvirtual
IsCaptionVertical() const | CXTPDockingPaneBase | virtual
IsEmpty() const | CXTPDockingPaneBaseContainer | protectedvirtual
IsHidden() const | CXTPDockingPaneBase | virtual
m_lstPanes | CXTPDockingPaneBaseContainer | protected
m_pCaptionButtons | CXTPDockingPaneBase | protected
m_pDockingSite | CXTPDockingPaneBase | protected
m_pLayout | CXTPDockingPaneBase | protected
m_pParentContainer | CXTPDockingPaneBase | protected
m_rcWindow | CXTPDockingPaneBase | protected
m_szDocking | CXTPDockingPaneBase | protected
m_type | CXTPDockingPaneBase | protected
OnAction(XTPDockingPaneAction action) | CXTPDockingPaneBaseContainer |
OnCaptionButtonRectChanged(CXTPDockingPaneCaptionButton *pButton) | CXTPDockingPaneBase | protectedvirtual
OnChildContainerChanged(CXTPDockingPaneBase *pContainer) | CXTPDockingPaneBase | protectedvirtual
OnFocusChanged() | CXTPDockingPaneBase | protectedvirtual
OnParentContainerChanged(CXTPDockingPaneBase *pContainer) | CXTPDockingPaneBase | protectedvirtual
OnSizeParent(CWnd *pParent, CRect rect, LPVOID lParam) | CXTPDockingPaneBase | protectedvirtual
RedrawPane() | CXTPDockingPaneBase | virtual
RemovePane(CXTPDockingPaneBase *pPane) | CXTPDockingPaneBase | protectedvirtual
SetDockingSite(CWnd *pFrame) | CXTPDockingPaneBase | protectedvirtual
SetParentContainer(CXTPDockingPaneBase *pContainer) | CXTPDockingPaneBase | protectedvirtual
~CXTPDockingPaneBase() | CXTPDockingPaneBase | protectedvirtual
~CXTPDockingPaneBaseContainer() | CXTPDockingPaneBaseContainer | protectedvirtual


Toolkit Pro: Member List

CXTPPropertyGridVisualStudio2019Theme Member List

This is the complete list of members for CXTPPropertyGridVisualStudio2019Theme, including all inherited members.

AdjustItemCaptionRect(CXTPPropertyGridItem *pItem, CRect &rcCaption) | CXTPPropertyGridPaintManager | virtual
AdjustItemValueRect(CXTPPropertyGridItem *pItem, CRect &rcValue) | CXTPPropertyGridPaintManager | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPPropertyGridPaintManager(CXTPPropertyGrid *pGrid) | CXTPPropertyGridPaintManager |
CXTPPropertyGridVisualStudio2010Theme(CXTPPropertyGrid *pGrid) | CXTPPropertyGridVisualStudio2010Theme |
CXTPPropertyGridVisualStudio2019Theme(CXTPPropertyGrid *pGrid) | CXTPPropertyGridVisualStudio2019Theme |
DrawCategoryCaptionBackground(CDC *pDC, CXTPPropertyGridItem *pItem, CRect rc) | CXTPPropertyGridPaintManager | virtual
DrawCheckBox(CDC *pDC, CXTPPropertyGridItemBool *pButton) | CXTPPropertyGridPaintManager | virtual
DrawCheckMark(CDC *pDC, CRect rc, BOOL bEnabled, BOOL bChecked) | CXTPPropertyGridPaintManager | virtual
DrawExpandButton(CDC &dc, CXTPPropertyGridItem *pItem, CRect rcCaption) | CXTPPropertyGridVisualStudio2019Theme | virtual
DrawInplaceButtons(CDC *pDC, PDRAWITEMSTRUCT lpDrawItemStruct, CXTPPropertyGridItem *pItem, CRect rcValue) | CXTPPropertyGridPaintManager | virtual
DrawInplaceListItem(CDC *pDC, CXTPPropertyGridItemConstraint *pConstraint, CRect rc, BOOL bSelected) | CXTPPropertyGridPaintManager | virtual
DrawItem(PDRAWITEMSTRUCT lpDrawItemStruct) | CXTPPropertyGridPaintManager | virtual
DrawItemCaption(CDC *pDC, CXTPPropertyGridItem *pItem, CRect rcCaption) | CXTPPropertyGridPaintManager | virtual
DrawItemValue(CDC *pDC, CXTPPropertyGridItem *pItem, CRect rcValue) | CXTPPropertyGridPaintManager | virtual
DrawPropertyGridBorder(CDC *pDC, RECT &rcBorder, XTPPropertyGridWindow nWindow) | CXTPPropertyGridPaintManager | virtual
DrawRadioMark(CDC *pDC, CRect rc, BOOL bEnabled, BOOL bChecked) | CXTPPropertyGridPaintManager | virtual
FillInplaceButton(CDC *pDC, CXTPPropertyGridInplaceButton *pButton) | CXTPPropertyGridPaintManager | virtual
FillPropertyGrid(CDC *pDC) | CXTPPropertyGridPaintManager | virtual
FillPropertyGridView(CDC *pDC) | CXTPPropertyGridPaintManager | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetItemBackColor(CXTPPropertyGridItem *pItem, BOOL bValuePart) | CXTPPropertyGridPaintManager | virtual
GetItemFont(CXTPPropertyGridItem *pItem, BOOL bValuePart) | CXTPPropertyGridPaintManager | virtual
GetItemMetrics() const | CXTPPropertyGridPaintManager |
GetItemsBorderHeight() const | CXTPPropertyGridPaintManager | virtual
GetItemTextColor(CXTPPropertyGridItem *pItem, BOOL bValuePart) | CXTPPropertyGridPaintManager | virtual
GetScrollBarTheme() const | CXTPPropertyGridVisualStudio2019Theme | virtual
GetSplitterRect(CRect rc, BOOL bIsHelp) | CXTPPropertyGridPaintManager |
HitTestVerbs(CDC *pDC, CRect rcVerbs, CPoint pt) | CXTPPropertyGridPaintManager |
m_bThinSplitter | CXTPPropertyGridPaintManager | protected
m_bTransparent | CXTPPropertyGridPaintManager |
m_buttonsStyle | CXTPPropertyGridPaintManager |
m_clrCategorySeparator | CXTPPropertyGridPaintManager |
m_clrFace | CXTPPropertyGridPaintManager |
m_clrHighlight | CXTPPropertyGridPaintManager |
m_clrHighlightText | CXTPPropertyGridPaintManager |
m_clrNonHighlightBack | CXTPPropertyGridPaintManager |
m_clrNonHighlightText | CXTPPropertyGridPaintManager |
m_clrShadow | CXTPPropertyGridPaintManager |
m_clrSplitter | CXTPPropertyGridPaintManager |
m_nHelpHeight | CXTPPropertyGridPaintManager | protected
m_nItemsBorderHeight | CXTPPropertyGridPaintManager | protected
m_nSplitterHeight | CXTPPropertyGridPaintManager | protected
m_nVerbsHeight | CXTPPropertyGridPaintManager | protected
m_pGrid | CXTPPropertyGridPaintManager | protected
m_pMetrics | CXTPPropertyGridPaintManager | protected
m_themeButton | CXTPPropertyGridPaintManager |
m_themeCombo | CXTPPropertyGridPaintManager |
m_themeTree | CXTPPropertyGridPaintManager |
MeasureItem(LPMEASUREITEMSTRUCT lpMeasureItemStruct) | CXTPPropertyGridPaintManager | virtual
OnNcCalcSize(RECT &rc) | CXTPPropertyGridPaintManager | virtual
RefreshMetrics() | CXTPPropertyGridVisualStudio2019Theme | virtual
SetItemsBorderHeight(int nHeight) | CXTPPropertyGridPaintManager | virtual
SetThinSplitter(BOOL bThinSplitter) | CXTPPropertyGridPaintManager | virtual
~CXTPPropertyGridPaintManager() | CXTPPropertyGridPaintManager | virtual
~CXTPPropertyGridVisualStudio2010Theme() | CXTPPropertyGridVisualStudio2010Theme |


Toolkit Pro: Member List

CXTPSyntaxEditViewPrintOptions Member List

This is the complete list of members for CXTPSyntaxEditViewPrintOptions, including all inherited members.

CXTPSyntaxEditViewPrintOptions() CXTPSyntaxEditViewPrintOptions


Toolkit Pro: XTPTextOnPath.h Source File

  • Source
  • FlowGraph
XTPTextOnPath.h
Go to the documentation of this file.
1
23#if !defined(__XTPTEXTONPATH_H__)
24# define __XTPTEXTONPATH_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33// an array that can be copied with a copy constructor (e.g. returned from a function/method)
34
35template<typename TYPE, class ARG_TYPE = const TYPE&>
36class CCArray : public CArray<TYPE, ARG_TYPE>
37{
38public:
39 CCArray(const CCArray& rhs)
40 {
41 CCArray::Copy(rhs);
42 }
43 CCArray()
44 {
45 }
46
47 bool operator=(const CCArray& rhs)
48 {
49 CCArray::Copy(rhs);
50 return true;
51 }
52};
53
58class _XTP_EXT_CLASS CXTPTextOnPath
59{
60 enum TextPathAlign
61 {
62 Left = 0,
63 Center = 1,
64 Right = 2
65 };
66
67 enum TextPathPosition
68 {
69 OverPath = 0,
70 CenterPath = 1,
71 UnderPath = 2
72 };
73
74protected:
75 void GetLinePoints(Gdiplus::PointF p1, Gdiplus::PointF p2, int stepWitdth,
76 CCArray<Gdiplus::PointF>& ret);
77
78 Gdiplus::SizeF MeasureString(const CString& str, Gdiplus::StringFormat* pFormat);
79
80 static CCArray<Gdiplus::PointF> AFX_CDECL CleanPoints(CCArray<Gdiplus::PointF> points);
81 static double AFX_CDECL GetAngle(Gdiplus::PointF point1, Gdiplus::PointF point2);
82
83 void DrawSingleRotatedLetter(const CString& letter, Gdiplus::REAL angle,
84 Gdiplus::PointF pointCenter);
85
86 Gdiplus::REAL StringRegionWidth(int textpos);
87
88 void DrawText(CCArray<Gdiplus::PointF> points, int maxPoints);
89
90 int CalculatePathPoints(Gdiplus::PointF* pPathPoints, int maxCount);
91
92 void DoTests();
93
94public:
95 void Draw();
96
97 CXTPTextOnPath(const CString& text, Gdiplus::Graphics* pGraphics, Gdiplus::GraphicsPath* pPath);
98 ~CXTPTextOnPath();
99
100 void SetFont(LOGFONT* lf);
101
102 void ReversePath();
103
104private:
105 Gdiplus::Font* m_pFont;
106 Gdiplus::Graphics* m_pGraphics;
108 Gdiplus::GraphicsPath* m_pPath;
109 Gdiplus::PathData m_Pathdata;
110
111 CString m_sText;
113 TextPathPosition m_TextPathPathPosition;
114 TextPathAlign m_pathalign;
115
116 Gdiplus::Brush* m_pFillBrush;
117
118 int m_LetterSpacingPercentage;
121
122 CCArray<Gdiplus::PointF> m_TmpPointsReserved;
123
124 Gdiplus::CharacterRange m_characterRanges[2];
125 Gdiplus::Region m_stringRegions[2];
126
127 Gdiplus::SizeF m_TextSize;
129# ifdef _TEXTONPATH_TESTING
130
133 // testing mode
134
135 CCArray<Gdiplus::RectF> _regionList;
136 CCArray<float> _angles;
137 CCArray<Gdiplus::PointF> _pointText;
138 CCArray<Gdiplus::PointF> _pointTextUp;
139
140# endif
141};
143# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
144#endif // __XTPTEXTONPATH_H__
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPTextOnPath
GDI+ drawing of text on path.
Definition XTPTextOnPath.h:59


Toolkit Pro: Member List

CXTPTagCloudTagArray Member List

This is the complete list of members for CXTPTagCloudTagArray, including all inherited members.

Sort(XTPTagCloudSort nSort, BOOL bAsc) CXTPTagCloudTagArray


Toolkit Pro: Member List

CXTPTabColorSetVisualStudio2012Dark Member List

This is the complete list of members for CXTPTabColorSetVisualStudio2012Dark, including all inherited members.

CXTPTabPaintManagerColorSet() | CXTPTabPaintManagerColorSet |
FillClient(CDC *pDC, CRect rc, CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
FillHeader(CDC *pDC, CRect rc, CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
FillNavigateButton(CDC *pDC, CXTPTabManagerNavigateButton *pButton, CRect &rc) | CXTPTabColorSetVisualStudio2012 | virtual
FillPropertyButton(CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerColorSet | virtual
FillStateButton(CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerColorSet | virtual
GetClientColor(CXTPTabManager *pTabManager) | CXTPTabColorSetVisualStudio2012 | virtual
GetItemColor(CXTPTabManagerItem *pItem) | CXTPTabColorSetVisualStudio2012 | virtual
GradientFill(CDC *pDC, CRect rc, COLORREF clrLight, COLORREF clrDark, XTPTabPosition position) | CXTPTabPaintManagerColorSet |
IsAppThemed() const | CXTPTabPaintManagerColorSet | virtual
m_clrActiveFilesBack | CXTPTabPaintManagerColorSet |
m_clrActiveFilesBackHighlighted | CXTPTabPaintManagerColorSet |
m_clrActiveFilesBackPressed | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyph | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyphHighlighted | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyphPressed | CXTPTabPaintManagerColorSet |
m_clrAutoHideFace | CXTPTabPaintManagerColorSet |
m_clrBorderHighlight | CXTPTabPaintManagerColorSet |
m_clrButtonBorder | CXTPTabPaintManagerColorSet |
m_clrButtonBorderHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonBorderHot | CXTPTabPaintManagerColorSet |
m_clrButtonBorderKeyTips | CXTPTabPaintManagerColorSet |
m_clrButtonBorderTabContext1 | CXTPTabPaintManagerColorSet |
m_clrButtonBorderTabContext2 | CXTPTabPaintManagerColorSet |
m_clrButtonHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonHighlightedClose | CXTPTabPaintManagerColorSet |
m_clrButtonNormal | CXTPTabPaintManagerColorSet |
m_clrButtonPressed | CXTPTabPaintManagerColorSet |
m_clrButtonSelected | CXTPTabPaintManagerColorSet |
m_clrButtonSelectedHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonSelectedPressed | CXTPTabPaintManagerColorSet |
m_clrControlFace | CXTPTabPaintManagerColorSet |
m_clrFrameBorder | CXTPTabPaintManagerColorSet |
m_clrHeaderFace | CXTPTabPaintManagerColorSet |
m_clrPaneFace | CXTPTabPaintManagerColorSet |
m_clrTabClientBack | CXTPTabPaintManagerColorSet |
m_clrTabClientBorder | CXTPTabPaintManagerColorSet |
m_clrTextDisabled | CXTPTabPaintManagerColorSet |
m_clrTextHighlight | CXTPTabPaintManagerColorSet |
m_clrTextHighlightClose | CXTPTabPaintManagerColorSet |
m_clrTextNormal | CXTPTabPaintManagerColorSet |
m_clrTextPressed | CXTPTabPaintManagerColorSet |
m_clrTextSelected | CXTPTabPaintManagerColorSet |
m_clrTextSelectedHighlighted | CXTPTabPaintManagerColorSet |
m_clrTextSelectedPressed | CXTPTabPaintManagerColorSet |
m_csExcelNormal | CXTPTabPaintManagerColorSet |
m_csExcelSelected | CXTPTabPaintManagerColorSet |
m_csPropertyPage | CXTPTabPaintManagerColorSet |
m_csPropertyPage2003 | CXTPTabPaintManagerColorSet |
m_csStateButton | CXTPTabPaintManagerColorSet |
m_pPaintManager | CXTPTabPaintManagerColorSet | protected
RefreshMetrics() | CXTPTabColorSetVisualStudio2012Dark | virtual
SelectClipRgn(CDC *pDC, CRect rcClient, CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
SetTextColor(CDC *pDC, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerColorSet | virtual
~CXTPTabPaintManagerColorSet() | CXTPTabPaintManagerColorSet | virtual


Toolkit Pro: Member List

CXTPCalendarWeekViewEvent Member List

This is the complete list of members for CXTPCalendarWeekViewEvent, including all inherited members.

_MoveRectY(int nYbasePrev, int nYbaseNew, CRect &rRC) | CXTPCalendarViewEvent | static
AddMultiDayEvent_Slave(CXTPCalendarViewEvent *pSlaveView, int nMasterEventPlace) | CXTPCalendarViewEvent | virtual
AdjustLayout(CDC *pDC, const CRect &rcEventMax, int nEventPlaceNumber) | CXTPCalendarWeekViewEvent | virtual
AdjustLayout2(CDC *pDC, const CRect &rcEventMax, int nEventPlaceNumber) | CXTPCalendarWeekViewEvent | virtual
AdjustMultidayEvent(CRect rcEventMax, int nEventPlaceNumber) | CXTPCalendarViewEvent | protectedvirtual
AdjustSubjectEditor() | CXTPCalendarViewEvent | virtual
CalcIconsRect(CRect rc) | CXTPCalendarWeekViewEvent | virtual
ChangeEventPlace(int nNewPlace) | CXTPCalendarViewEvent | virtual
CXTPCalendarViewEvent(CXTPCalendarEvent *pEvent, CXTPCalendarViewGroup *pViewGroup) | CXTPCalendarViewEvent |
CXTPCalendarViewEventT(CXTPCalendarEvent *pEvent, CXTPCalendarWeekViewGroup *pViewGroup) | CXTPCalendarViewEventT< CXTPCalendarWeekViewGroup > | inline
CXTPCalendarWeekViewEvent(CXTPCalendarEvent *pEvent, CXTPCalendarWeekViewGroup *pViewGroup) | CXTPCalendarWeekViewEvent |
CXTPCalendarWMHandler() | CXTPCalendarWMHandler |
CXTPCmdTarget() | CXTPCmdTarget |
Draw(CDC *pDC) | CXTPCalendarWeekViewEvent | virtual
EndEditSubject() | CXTPCalendarViewEvent | virtual
FormatEventTime(COleDateTime dtTime) const | CXTPCalendarViewEvent | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCalendarControl() const | CXTPCalendarViewEvent | virtual
GetChildHandlerAt(int nIndex) const | CXTPCalendarWMHandler | virtual
GetChildHandlersCount() const | CXTPCalendarWMHandler | virtual
GetEditingSubjectFromEditor() const | CXTPCalendarViewEvent | virtual
GetEndTimeRect() const | CXTPCalendarViewEvent | virtual
GetEvent() const | CXTPCalendarViewEvent | virtual
GetEventPlaceNumber() const | CXTPCalendarViewEvent | virtual
GetEventRect() const | CXTPCalendarViewEvent |
GetEventTimelinePlaceNumber() const | CXTPCalendarViewEvent | virtual
GetFirstClockRect() const | CXTPCalendarViewEvent | virtual
GetItemText(DWORD dwItemFlag, LPCTSTR pcszDefaultText=NULL) const | CXTPCalendarViewEvent | virtual
GetItemTextBody() const | CXTPCalendarViewEvent | virtual
GetItemTextEndTime() const | CXTPCalendarViewEvent | virtual
GetItemTextLocation() const | CXTPCalendarViewEvent | virtual
GetItemTextStartTime() const | CXTPCalendarViewEvent | virtual
GetItemTextSubject() const | CXTPCalendarViewEvent | virtual
GetLastClockRect() const | CXTPCalendarViewEvent | virtual
GetMarkupText() const | CXTPCalendarViewEvent | virtual
GetMarkupUIElement() | CXTPCalendarViewEvent | virtual
GetMeetingGlyphRect() const | CXTPCalendarViewEvent | virtual
GetMultiDayEventFlags() const | CXTPCalendarViewEvent | virtual
GetPrivateGlyphRect() const | CXTPCalendarViewEvent | virtual
GetRecurrenceGlyphRect() const | CXTPCalendarViewEvent | virtual
GetReminderGlyphRect() const | CXTPCalendarViewEvent | virtual
GetShowToolTipTimeOut() const | CXTPCalendarViewEvent | virtual
GetStartTimeRect() const | CXTPCalendarViewEvent | virtual
GetSubjectEditor() const | CXTPCalendarViewEvent | virtual
GetSubjectEditorFont() const | CXTPCalendarWeekViewEvent | protectedvirtual
GetSubjectEditorRect() const | CXTPCalendarViewEvent | virtual
GetSubjectEditorStyles() const | CXTPCalendarViewEvent | virtual
GetTextRect() const | CXTPCalendarViewEvent | virtual
GetToolText() | CXTPCalendarViewEvent | protectedvirtual
GetViewEventRect() const | CXTPCalendarViewEvent | virtual
GetViewEventRectMax() const | CXTPCalendarViewEvent | virtual
GetViewGroup() const | CXTPCalendarViewEventT< CXTPCalendarWeekViewGroup > | inline
GetViewGroup_() const | CXTPCalendarViewEventT< CXTPCalendarWeekViewGroup > | inlinevirtual
GetViewRect() | CXTPCalendarWeekViewEvent |
HideToolTip() | CXTPCalendarViewEvent | virtual
HitTest(CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const | CXTPCalendarViewEvent | virtual
HitTestEx(CPoint point, XTP_CALENDAR_HITTESTINFO *pInfo) const | CXTPCalendarWeekViewEvent | virtual
IsEditingSubject() const | CXTPCalendarViewEvent | virtual
IsMultidayEvent() const | CXTPCalendarViewEvent | virtual
IsMultyDayTextAlign() const | CXTPCalendarViewEvent | virtual
IsSelected() const | CXTPCalendarViewEvent | virtual
IsShowEndTime() const | CXTPCalendarWeekViewEvent |
IsShowingToolTip() | CXTPCalendarViewEvent | virtual
IsTextOutOfBorders() const | CXTPCalendarViewEvent | virtual
IsTimeAsClock() const | CXTPCalendarWeekViewEvent |
IsVisible() const | CXTPCalendarWeekViewEvent | virtual
KillTimer(UINT uTimerID) | CXTPCalendarViewEvent | virtual
m_bMultyDayTextAlign | CXTPCalendarViewEvent | protected
m_bSelected | CXTPCalendarViewEvent | protected
m_bTextOutOfBorders | CXTPCalendarViewEvent | protected
m_nEventPlaceNumber | CXTPCalendarViewEvent | protected
m_nEventTimelinePlaceNumber | CXTPCalendarViewEvent | protected
m_nMultiDayEventFlags | CXTPCalendarViewEvent |
m_nTimerID_ShowToolTip | CXTPCalendarViewEvent | protected
m_pMasterView | CXTPCalendarViewEvent | protected
m_pSubjectEditor | CXTPCalendarViewEvent | protected
m_ptrEvent | CXTPCalendarViewEvent | protected
m_pUIElement | CXTPCalendarViewEvent |
m_rcEndTime | CXTPCalendarViewEvent |
m_rcEvent | CXTPCalendarViewEvent |
m_rcEventMax | CXTPCalendarViewEvent |
m_rcFirstClock | CXTPCalendarViewEvent |
m_rcLastClock | CXTPCalendarViewEvent |
m_rcMeetingGlyph | CXTPCalendarViewEvent |
m_rcPrivateGlyph | CXTPCalendarViewEvent |
m_rcRecurrenceGlyph | CXTPCalendarViewEvent |
m_rcReminderGlyph | CXTPCalendarViewEvent |
m_rcStartTime | CXTPCalendarViewEvent |
m_rcSubjectEditor | CXTPCalendarViewEvent |
m_rcText | CXTPCalendarViewEvent |
m_rcToolTip | CXTPCalendarViewEvent |
m_strUIElementText | CXTPCalendarViewEvent |
m_szText | CXTPCalendarViewEvent |
OnBeforeDestroy() | CXTPCalendarViewEvent | virtual
OnChar(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnKeyUp(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnLButtonDblClk(UINT nFlags, CPoint point) | CXTPCalendarViewEvent | virtual
OnLButtonDown(UINT nFlags, CPoint point) | CXTPCalendarViewEvent | virtual
OnLButtonUp(UINT nFlags, CPoint point) | CXTPCalendarViewEvent | virtual
OnMouseMove(UINT nFlags, CPoint point) | CXTPCalendarViewEvent | virtual
OnPostAdjustLayout() | CXTPCalendarWeekViewEvent | virtual
OnSysKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnTimer(UINT_PTR uTimerID) | CXTPCalendarViewEvent | virtual
OnWndMsg(UINT message, WPARAM wParam, LPARAM lParam, LRESULT *pResult) | CXTPCalendarViewEvent | virtual
SetMultiDayEvent_MasterSlave(BOOL bMaster, CXTPCalendarViewEvent *pMasterView) | CXTPCalendarViewEvent | virtual
SetSelected(BOOL bSet=TRUE) | CXTPCalendarViewEvent | virtual
SetTextOutOfBorders(BOOL bOutOfBorders) | CXTPCalendarViewEvent | virtual
SetTimer(UINT uTimeOut_ms) | CXTPCalendarViewEvent | virtual
ShowToolTip() | CXTPCalendarViewEvent | virtual
StartEditSubject() | CXTPCalendarViewEvent | virtual
TBase typedef | CXTPCalendarWeekViewEvent |
~CXTPCalendarViewEvent() | CXTPCalendarViewEvent | virtual
~CXTPCalendarViewEventT() | CXTPCalendarViewEventT< CXTPCalendarWeekViewGroup > | inlinevirtual
~CXTPCalendarWeekViewEvent() | CXTPCalendarWeekViewEvent | virtual


Toolkit Pro: Member List

CXTPChart3dFunnelSeriesLabelsView Member List

This is the complete list of members for CXTPChart3dFunnelSeriesLabelsView, including all inherited members.

AddChildView(CXTPChartElementView *pChildView) | CXTPChartElementView |
CreateDeviceCommand(CXTPChartDeviceContext *pDC) | CXTPChart3dFunnelSeriesLabelsView | virtual
CXTPChart3dFunnelSeriesLabelsView(CXTPChartElementView *pParentView) | CXTPChart3dFunnelSeriesLabelsView |
CXTPChartElementView(CXTPChartElementView *pParentView) | CXTPChartElementView |
CXTPChartElementView(CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartElementView |
CXTPChartElementView(CXTPChartContainer *pContainer) | CXTPChartElementView |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
GetAt(int nIndex) const | CXTPChartElementView |
GetBounds() const | CXTPChartElementView |
GetBounds(BOOL bIncludingChildren) const | CXTPChartElementView |
GetChildren() | CXTPChartElementView |
GetCount() const | CXTPChartElementView |
GetParentView() const | CXTPChartElementView |
Is3D() const | CXTPChartObject |
m_arrChildren | CXTPChartElementView | protected
m_pContainer | CXTPChartElementView | protected
m_pParentView | CXTPChartElementView | protected
m_rcBounds | CXTPChartElementView | protected
ResolveOverlapping() | CXTPChart3dFunnelSeriesLabelsView |
~CXTPChartElementView() | CXTPChartElementView | protectedvirtual


Toolkit Pro: Member List

CXTPSkinObjectMonthCal Member List

This is the complete list of members for CXTPSkinObjectMonthCal, including all inherited members.

CXTPSkinObject() | CXTPSkinObject | protected
CXTPSkinObjectFrame() | CXTPSkinObjectFrame |
CXTPSkinObjectMonthCal() | CXTPSkinObjectMonthCal |
GetAccessCriticalSection() const | CXTPSynchronized | inline
GetBorders() const | CXTPSkinObjectFrame |
GetCaptionButtons() | CXTPSkinObjectFrame |
GetClassName() const | CXTPSkinObject |
GetClientBrush(CDC *pDC) | CXTPSkinObjectFrame | virtual
GetColor(int nIndex) const | CXTPSkinObject |
GetMetrics() const | CXTPSkinObject |
GetSkinClass() const | CXTPSkinObject |
GetSkinManager() const | CXTPSkinObject |
IsActive() const | CXTPSkinObjectFrame |
m_arrButtons | CXTPSkinObjectFrame | protected
m_bActive | CXTPSkinObjectFrame | protected
m_bActiveX | CXTPSkinObject | protected
m_bLockFrameDraw | CXTPSkinObjectFrame |
m_bMDIClient | CXTPSkinObjectFrame | protected
m_bRegionChanged | CXTPSkinObjectFrame | protected
m_bWindowsForms | CXTPSkinObject | protected
m_dwDialogTexture | CXTPSkinObjectFrame |
m_dwExStyle | CXTPSkinObjectFrame | protected
m_dwStyle | CXTPSkinObjectFrame | protected
m_pButtonHot | CXTPSkinObjectFrame | protected
m_pButtonPressed | CXTPSkinObjectFrame | protected
m_pManager | CXTPSkinObject | protected
m_pOldWndProc | CXTPSkinObject | protected
m_pSBTrack | CXTPSkinObjectFrame | protected
m_rcBorders | CXTPSkinObjectFrame | protected
m_spi | CXTPSkinObjectFrame | protected
m_strClassName | CXTPSkinObject | protected
m_szFrameRegion | CXTPSkinObjectFrame | protected
OnHookAttached(LPCREATESTRUCT lpcs, BOOL bAuto) | CXTPSkinObjectFrame | protectedvirtual
OnHookDetached(BOOL bAuto) | CXTPSkinObjectFrame | protectedvirtual
OnSkinChanged(BOOL bPrevState, BOOL bNewState) | CXTPSkinObjectFrame | protectedvirtual
RedrawScrollBar(int nBar) | CXTPSkinObjectFrame |
RefreshMetrics() | CXTPSkinObjectMonthCal | virtual
~CXTPSkinObject() | CXTPSkinObject | protected
~CXTPSkinObjectFrame() | CXTPSkinObjectFrame | virtual


Toolkit Pro: XTPChart2dFunnelSeriesLabel.h Source File

  • Source
  • Chart
  • Styles
  • Funnel
  • 2D
XTPChart2dFunnelSeriesLabel.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHART2DFUNNELSERIESLABEL_H__)
24# define __XTPCHART2DFUNNELSERIESLABEL_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartSeriesView;
34class CXTPChartFunnelSeriesPointView;
35class CXTPChartFunnelSeriesStyle;
36
42class _XTP_EXT_CLASS CXTPChartFunnelSeriesLabel : public CXTPChartFunnelSeriesLabelBase
43{
45 DECLARE_SERIAL(CXTPChartFunnelSeriesLabel)
47public:
52 CXTPChartFunnelSeriesLabel();
53
61 CXTPChartFunnelSeriesStyle* GetStyle() const;
62
63protected:
75 virtual CXTPChartElementView* CreateView(CXTPChartDeviceContext* pDC,
76 CXTPChartSeriesPointView* pPointView,
77 CXTPChartElementView* pParentView);
78};
79
84class _XTP_EXT_CLASS CXTPChartFunnelSeriesLabelView : public CXTPChartFunnelSeriesLabelViewBase
85{
86 DECLARE_DYNAMIC(CXTPChartFunnelSeriesLabelView);
87
88public:
97 CXTPChartFunnelSeriesLabelView(CXTPChartSeriesLabel* pLabel,
98 CXTPChartSeriesPointView* pPointView,
99 CXTPChartElementView* pParentView);
100
111 virtual CXTPChartDeviceCommand* CreateDeviceCommand(CXTPChartDeviceContext* pDC);
112};
114# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
115#endif //#if !defined(__XTPCHART2DFUNNELSERIESLABEL_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartElementView
This class represents the view of a chart element.
Definition XTPChartElementView.h:47
CXTPChartFunnelSeriesLabelBase
CXTPChartFunnelSeriesLabelBase is a kind of CXTPChartSeriesLabel.
Definition XTPChartFunnelSeriesLabelBase.h:54
CXTPChartFunnelSeriesLabel
CXTPChartFunnelSeriesLabel is a kind of CXTPChartSeriesLabel.
Definition XTPChart2dFunnelSeriesLabel.h:43
CXTPChartFunnelSeriesLabel::GetStyle
CXTPChartFunnelSeriesStyle * GetStyle() const
Call this function to get the basic style of the funnel series.
CXTPChartFunnelSeriesLabel::CXTPChartFunnelSeriesLabel
CXTPChartFunnelSeriesLabel()
Constructs a CXTPChartFunnelSeriesLabel object.
CXTPChartFunnelSeriesLabel::CreateView
virtual CXTPChartElementView * CreateView(CXTPChartDeviceContext *pDC, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView)
This function creates the view of the funnel series.
CXTPChartFunnelSeriesLabelViewBase
This class abstracts the view of a funnel series label.
Definition XTPChartFunnelSeriesLabelBase.h:159
CXTPChartFunnelSeriesLabelView
Defines 2D series label view.
Definition XTPChart2dFunnelSeriesLabel.h:85
CXTPChartFunnelSeriesLabelView::CreateDeviceCommand
virtual CXTPChartDeviceCommand * CreateDeviceCommand(CXTPChartDeviceContext *pDC)
Creates a view drawing device command for the device context specified.
CXTPChartFunnelSeriesLabelView::CXTPChartFunnelSeriesLabelView
CXTPChartFunnelSeriesLabelView(CXTPChartSeriesLabel *pLabel, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView)
Constructs a CXTPChartFunnelSeriesLabelView object.
CXTPChartFunnelSeriesPointView
This class abstracts the view of a funnel series point.
Definition XTPChart2dFunnelSeriesPointView.h:49
CXTPChartFunnelSeriesStyle
This class abstracts the basic style of a funnel series.
Definition XTPChart2dFunnelSeriesStyle.h:49
CXTPChartSeriesLabel
This class abstracts the label of a series.
Definition XTPChartSeriesLabel.h:49
CXTPChartSeriesPointView
Represents chart series point view.
Definition XTPChartSeriesPointView.h:48


Toolkit Pro: Member List

CXTPCalendarCaptionBarVisualStudio2022Theme Member List

This is the complete list of members for CXTPCalendarCaptionBarVisualStudio2022Theme, including all inherited members.

CXTPCalendarCaptionBarOffice2000Theme(CXTPCalendarCaptionBarTheme *pTheme=NULL) | CXTPCalendarCaptionBarOffice2000Theme |
CXTPCalendarCaptionBarOffice2003Theme(CXTPCalendarCaptionBarTheme *pTheme=NULL) | CXTPCalendarCaptionBarOffice2003Theme |
CXTPCalendarCaptionBarOffice2013Theme(CXTPCalendarCaptionBarTheme *pTheme=NULL) | CXTPCalendarCaptionBarOffice2013Theme |
CXTPCalendarCaptionBarOfficeXPTheme(CXTPCalendarCaptionBarTheme *pTheme=NULL) | CXTPCalendarCaptionBarOfficeXPTheme |
CXTPCalendarCaptionBarPaintManager(CXTPCalendarCaptionBarTheme *pTheme=NULL) | CXTPCalendarCaptionBarPaintManager |
CXTPCalendarCaptionBarVisualStudio2022Theme(CXTPCalendarCaptionBarTheme *pTheme=NULL) | CXTPCalendarCaptionBarVisualStudio2022Theme |
CXTPCmdTarget() | CXTPCmdTarget |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetPaintTheme() const | CXTPCalendarCaptionBarPaintManager | virtual
m_clrBorders | CXTPCalendarCaptionBarPaintManager | protected
m_clrScrollDateBarBk | CXTPCalendarCaptionBarPaintManager | protected
m_clrScrollTriangleColor | CXTPCalendarCaptionBarPaintManager | protected
m_clrSwitchViewBarBk | CXTPCalendarCaptionBarPaintManager | protected
m_clrTextColor | CXTPCalendarCaptionBarPaintManager | protected
m_fntTextFont | CXTPCalendarCaptionBarPaintManager | protected
m_pTheme | CXTPCalendarCaptionBarPaintManager | protected
RefreshMetrics() | CXTPCalendarCaptionBarOffice2013Theme | virtual
~CXTPCalendarCaptionBarOffice2000Theme() | CXTPCalendarCaptionBarOffice2000Theme | virtual
~CXTPCalendarCaptionBarOffice2003Theme() | CXTPCalendarCaptionBarOffice2003Theme | virtual
~CXTPCalendarCaptionBarOffice2013Theme() | CXTPCalendarCaptionBarOffice2013Theme | virtual
~CXTPCalendarCaptionBarOfficeXPTheme() | CXTPCalendarCaptionBarOfficeXPTheme | virtual
~CXTPCalendarCaptionBarPaintManager() | CXTPCalendarCaptionBarPaintManager | virtual
~CXTPCalendarCaptionBarVisualStudio2022Theme() | CXTPCalendarCaptionBarVisualStudio2022Theme | virtual


Toolkit Pro: XTPSkinDrawTools.h Source File

  • Source
  • SkinFramework
XTPSkinDrawTools.h
Go to the documentation of this file.
1
23#if !defined(__XTPSKINDRAWTOOLS_H__)
24# define __XTPSKINDRAWTOOLS_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
35// Private function
36
37_XTP_EXT_CLASS BOOL WINAPI XTPSkinFrameworkDrawEdge(HDC hdc, LPRECT lprc, UINT edge, UINT flags);
38_XTP_EXT_CLASS BOOL WINAPI XTPSkinFrameworkDrawFrameControl(HDC hdc, LPRECT lprc, UINT uType,
39 UINT uState);
40_XTP_EXT_CLASS int AFX_CDECL XTPGetParentDCClipBox(HWND pwnd, HDC hdc, LPRECT lprc);
41_XTP_EXT_CLASS void AFX_CDECL XTPSkinFrameworkGetIconSize(HICON hImage, int* pcx, int* pcy);
42_XTP_EXT_CLASS HBITMAP AFX_CDECL XTPSkinFrameworkLoadBitmap(HMODULE hModule,
43 LPCTSTR lpszResourceName, BOOL& bAlpha);
44_XTP_EXT_CLASS void AFX_CDECL XTPSkinFrameworkDrawFrame(HDC hdc, LPRECT lprc, int nSize,
45 COLORREF clr);
46_XTP_EXT_CLASS void AFX_CDECL XTPSkinFrameworkDrawFrame(HDC hdc, LPRECT lprc, int xSize, int ySize,
47 COLORREF clr);
48_XTP_EXT_CLASS void AFX_CDECL XTPSkinFrameworkDrawFrame(HDC hdc, LPRECT lprc, int nSize,
49 HBRUSH hBrush);
50_XTP_EXT_CLASS int AFX_CDECL XTPSkinFrameworkDrawText(HDC hdc, LPCTSTR lpText, int cch, LPRECT lprc,
51 UINT nFormat,
52 LPLOGFONT pAssociatedFont = NULL);
53
54AFX_INLINE int AFX_CDECL XTPSkinFrameworkDrawText(HDC hdc, const CString& strText, LPRECT lprc,
55 UINT nFormat, LPLOGFONT pAssociatedFont = NULL)
56{
57 return XTPSkinFrameworkDrawText(hdc, strText, strText.GetLength(), lprc, nFormat,
58 pAssociatedFont);
59}
60
63# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
65#endif // !defined(__XTPSKINDRAWTOOLS_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h


Toolkit Pro: Member List

  • CXTPRibbonOffice2013Theme
  • CThemeStaticExtension
CXTPRibbonOffice2013Theme::CThemeStaticExtension Member List

This is the complete list of members for CXTPRibbonOffice2013Theme::CThemeStaticExtension, including all inherited members.

CThemeStaticExtension() | CXTPRibbonOffice2013Theme::CThemeStaticExtension |
CXTPMarkupStaticExtension(LPCWSTR lpzName, BOOL bProperty) | CXTPMarkupStaticExtension | protected
CXTPMarkupStaticExtension(LPCWSTR lpzName) | CXTPMarkupStaticExtension |
Extend(CXTPMarkupStaticExtension *pExtension, BOOL bReplace=FALSE) | CXTPMarkupStaticExtension |
FindExtension(LPCWSTR lpzName) const | CXTPMarkupStaticExtension |
GetName() const | CXTPMarkupStaticExtension |
IsProperty() const | CXTPMarkupStaticExtension |
OnPrepareValue() | CXTPMarkupStaticExtension | inlineprotectedvirtual
Parse(LPCWSTR lpzValue, LPCWSTR &lpzSubValue) | CXTPMarkupStaticExtension | static
ProvideValue(LPCWSTR lpzValue) | CXTPMarkupStaticExtension | virtual
ProvideValue() | CXTPMarkupStaticExtension | virtual
~CXTPMarkupStaticExtension() | CXTPMarkupStaticExtension | virtual


Toolkit Pro: Member List

CXTPTaskPanelGroupItem Member List

This is the complete list of members for CXTPTaskPanelGroupItem, including all inherited members.

AllowDrag(long nAllowDrag=xtpTaskItemAllowDragDefault) | CXTPTaskPanelItem |
AllowDrop(BOOL bAllowDrop) | CXTPTaskPanelItem |
CacheGlobalData() | CXTPTaskPanelItem |
CopyToClipboard() | CXTPTaskPanelItem |
CreateFromOleData(COleDataObject *pDataObject) | CXTPTaskPanelItem | static
CreateFromOleFile(CFile *pDataObject) | CXTPTaskPanelItem | static
CXTPCmdTarget() | CXTPCmdTarget |
CXTPTaskPanelGroupItem() | CXTPTaskPanelGroupItem |
CXTPTaskPanelItem() | CXTPTaskPanelItem | protected
DoPropExchange(CXTPPropExchange *pPX) | CXTPTaskPanelGroupItem | virtual
DrawCaptionText(CDC *pDC, CRect rc, UINT nFormat) | CXTPTaskPanelItem | virtual
EnsureVisible() | CXTPTaskPanelItem |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetBackColor() const | CXTPTaskPanelGroupItem |
GetCaption() const | CXTPTaskPanelItem |
GetCaptionTextSize(CDC *pDC, CRect rc, UINT nFormat) | CXTPTaskPanelItem | virtual
GetControlHandle() const | CXTPTaskPanelGroupItem |
GetDragText() const | CXTPTaskPanelGroupItem | virtual
GetEnabled() const | CXTPTaskPanelItem |
GetHitTestRect() const | CXTPTaskPanelGroupItem | virtual
GetIconIndex() const | CXTPTaskPanelItem |
GetIconPadding() | CXTPTaskPanelItem |
GetID() const | CXTPTaskPanelItem |
GetImage(int nWidth) const | CXTPTaskPanelItem |
GetIndex() const | CXTPTaskPanelItem |
GetInvalidateRect() const | CXTPTaskPanelItem | virtual
GetItemData() const | CXTPTaskPanelItem |
GetItemFont() const | CXTPTaskPanelItem |
GetItemGroup() const | CXTPTaskPanelGroupItem | virtual
GetItemRect() const | CXTPTaskPanelGroupItem |
GetMargins() | CXTPTaskPanelGroupItem |
GetMarkupUIElement() const | CXTPTaskPanelItem |
GetPaintManager() const | CXTPTaskPanelItem |
GetParentItems() const | CXTPTaskPanelItem |
GetSize() const | CXTPTaskPanelGroupItem |
GetTaskPanel() const | CXTPTaskPanelItem |
GetTextColor() const | CXTPTaskPanelGroupItem |
GetTextRect(UINT *pFormat=0) const | CXTPTaskPanelItem |
GetTooltip() const | CXTPTaskPanelItem |
GetType() const | CXTPTaskPanelItem |
IsAcceptFocus() const | CXTPTaskPanelItem | virtual
IsAllowDrag() const | CXTPTaskPanelItem |
IsAllowDrop() const | CXTPTaskPanelItem |
IsAutoHeight() const | CXTPTaskPanelGroupItem |
IsBold() const | CXTPTaskPanelGroupItem |
IsDroppedOff() const | CXTPTaskPanelItem |
IsGroup() const | CXTPTaskPanelItem |
IsItemDragging() const | CXTPTaskPanelItem |
IsItemDragOver() const | CXTPTaskPanelItem |
IsItemFocused() const | CXTPTaskPanelItem |
IsItemHot() const | CXTPTaskPanelItem |
IsItemPressed() const | CXTPTaskPanelItem |
IsItemSelected() const | CXTPTaskPanelGroupItem |
IsVisible() const | CXTPTaskPanelItem |
m_bAllowDrop | CXTPTaskPanelItem | protected
m_bAutoHeight | CXTPTaskPanelGroupItem | protected
m_bBold | CXTPTaskPanelGroupItem | protected
m_bEnabled | CXTPTaskPanelItem | protected
m_bmpPreview | CXTPTaskPanelGroupItem | protected
m_bSelected | CXTPTaskPanelGroupItem | protected
m_bVisible | CXTPTaskPanelItem | protected
m_clrText | CXTPTaskPanelGroupItem | protected
m_dwData | CXTPTaskPanelItem | protected
m_hWnd | CXTPTaskPanelGroupItem | protected
m_nAllowDrag | CXTPTaskPanelItem | protected
m_nIconIndex | CXTPTaskPanelItem | protected
m_nID | CXTPTaskPanelItem | protected
m_nTextFormat | CXTPTaskPanelItem | protected
m_pItems | CXTPTaskPanelItem | protected
m_pMarkupUIElement | CXTPTaskPanelItem | protected
m_pPanel | CXTPTaskPanelItem | protected
m_rcIconPadding | CXTPTaskPanelItem | protected
m_rcItem | CXTPTaskPanelGroupItem | protected
m_rcMargins | CXTPTaskPanelGroupItem | protected
m_rcText | CXTPTaskPanelItem | protected
m_strCaption | CXTPTaskPanelItem | protected
m_strDragText | CXTPTaskPanelGroupItem | protected
m_strTooltip | CXTPTaskPanelItem | protected
m_szItem | CXTPTaskPanelGroupItem | protected
m_szPreview | CXTPTaskPanelGroupItem | protected
m_typeItem | CXTPTaskPanelItem | protected
m_xtpFontItem | CXTPTaskPanelItem | protected
OnAnimate(int nStep) | CXTPTaskPanelGroupItem |
OnDrawItem(CDC *pDC, CRect rc) | CXTPTaskPanelGroupItem | virtual
OnInserted() | CXTPTaskPanelItem | protectedvirtual
OnRemoved() | CXTPTaskPanelItem | protectedvirtual
OnReposition(CRect rc) | CXTPTaskPanelGroupItem | virtual
PasteFromClipboard() | CXTPTaskPanelItem | static
PrepareDrag(COleDataSource &srcItem, BOOL bCacheTextData=TRUE) | CXTPTaskPanelGroupItem |
RedrawPanel(BOOL bAnimate=FALSE) const | CXTPTaskPanelItem |
Remove() | CXTPTaskPanelItem |
RepositionPanel() const | CXTPTaskPanelItem |
SetBold(BOOL bBold=TRUE) | CXTPTaskPanelGroupItem |
SetCaption(LPCTSTR lpszCaption) | CXTPTaskPanelItem |
SetControlHandle(HWND hWnd) | CXTPTaskPanelGroupItem |
SetDragText(LPCTSTR lpszDragText) | CXTPTaskPanelGroupItem |
SetEnabled(BOOL bEnabled) | CXTPTaskPanelItem |
SetIconIndex(int nIndex) | CXTPTaskPanelItem |
SetID(UINT nID) | CXTPTaskPanelItem |
SetID(UINT nID, LPCTSTR lpCaption, LPCTSTR lpTooltip=NULL) | CXTPTaskPanelItem |
SetItemData(DWORD_PTR dwData) | CXTPTaskPanelItem |
SetItemFont(LOGFONT *pLogFont) | CXTPTaskPanelItem |
SetItemRect(LPCRECT lpRect) | CXTPTaskPanelGroupItem |
SetItemSelected(BOOL bSelected) | CXTPTaskPanelGroupItem |
SetSize(CSize szItem, BOOL bAutoHeight=FALSE) | CXTPTaskPanelGroupItem |
SetTextColor(COLORREF clrText) | CXTPTaskPanelGroupItem |
SetTextRect(CDC *pDC, CRect rc, UINT nFormat) | CXTPTaskPanelItem |
SetTooltip(LPCTSTR lpszTooltip) | CXTPTaskPanelItem |
SetType(XTPTaskPanelItemType typeItem) | CXTPTaskPanelItem |
SetVisible(BOOL bVisible) | CXTPTaskPanelItem |
~CXTPTaskPanelGroupItem() | CXTPTaskPanelGroupItem | virtual
~CXTPTaskPanelItem() | CXTPTaskPanelItem | virtual


Toolkit Pro: Member List

CXTPModuleHandle Member List

This is the complete list of members for CXTPModuleHandle, including all inherited members.

CXTPModuleHandle() | CXTPModuleHandle |
CXTPModuleHandle(LPCTSTR lpszModuleName) | CXTPModuleHandle |
FreeLibrary() | CXTPModuleHandle |
GetHandle() const | CXTPModuleHandle |
GetModuleHandle(LPCTSTR lpszModuleName) | CXTPModuleHandle |
GetModuleState() const | CXTPModuleHandle |
GetName() const | CXTPModuleHandle |
GetProcAddress(FARPROC *ppFnPtr, LPCSTR lpProcName, DWORD dwMinVer=NULL) | CXTPModuleHandle |
GetVersion() | CXTPModuleHandle |
Init(LPCTSTR lpszModuleName) | CXTPModuleHandle |
LoadLibrary(LPCTSTR lpszModuleName) | CXTPModuleHandle |
operator HMODULE() const | CXTPModuleHandle |
xtpModLoaded enum value | CXTPModuleHandle |
xtpModMapped enum value | CXTPModuleHandle |
xtpModNone enum value | CXTPModuleHandle |
XTPModuleState enum name | CXTPModuleHandle |
~CXTPModuleHandle() | CXTPModuleHandle | virtual


Toolkit Pro: Member List

CXTPSyntaxEditColorThemesManager Member List

This is the complete list of members for CXTPSyntaxEditColorThemesManager, including all inherited members.

AddThemeInfo(const CString &strThemeName, const CString &strThemeFilename) | CXTPSyntaxEditColorThemesManager |
CXTPSyntaxEditColorThemesManager() | CXTPSyntaxEditColorThemesManager |
GetTheme(const CString &strThemeName) | CXTPSyntaxEditColorThemesManager |
GetThemes() | CXTPSyntaxEditColorThemesManager |
LoadTheme(const CString &strThemeName, const CString &strThemeFilename) | CXTPSyntaxEditColorThemesManager |
LoadThemeFromString(const CString &strThemeName, CStringArray &arPassedString) | CXTPSyntaxEditColorThemesManager |
ReloadFile(const CString &csFileName, int nCfgFlags=0) | CXTPSyntaxEditColorThemesManager |
RemoveAll() | CXTPSyntaxEditColorThemesManager |
~CXTPSyntaxEditColorThemesManager() | CXTPSyntaxEditColorThemesManager | virtual


Toolkit Pro: XTPChartFunnelDiagram.h Source File

  • Source
  • Chart
  • Styles
  • Funnel
XTPChartFunnelDiagram.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTFUNNELDIAGRAM_H__)
24# define __XTPCHARTFUNNELDIAGRAM_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Chart/Styles/Funnel/Base/XTPChartFunnelDiagramBase.h"
32# include "Chart/Styles/Funnel/2D/XTPChart2dFunnelDiagram.h"
33
34// CXTPChart2dFunnelDiagram alias is necessary for naming consistency.
35typedef CXTPChartFunnelDiagram CXTPChart2dFunnelDiagram;
37#endif //#if !defined(__XTPCHARTFUNNELDIAGRAM_H__)
XTPChart2dFunnelDiagram.h
XTPChartFunnelDiagramBase.h
CXTPChartFunnelDiagram
This class abstracts the funnel diagram.
Definition XTPChart2dFunnelDiagram.h:45


Toolkit Pro: XTPResizeDialog.h Source File

  • Source
  • Controls
  • Resize
XTPResizeDialog.h
Go to the documentation of this file.
1
23#if !defined(__XTPRESIZEDIALOG_H__)
24# define __XTPRESIZEDIALOG_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
39class _XTP_EXT_CLASS CXTPResizeDialog
40 : public CDialog
41 , public CXTPResize
42{
44 DECLARE_DYNCREATE(CXTPResizeDialog)
46public:
61 CXTPResizeDialog();
62
85 CXTPResizeDialog(const UINT nID, CWnd* pParent = 0, const UINT nFlags = 0);
86
110 CXTPResizeDialog(LPCTSTR lpszTemplateName, CWnd* pParent = 0, const UINT nFlags = 0);
111
112protected:
114 DECLARE_MESSAGE_MAP()
115
116 //{{AFX_MSG(CXTPResizeDialog)
117 virtual BOOL OnInitDialog();
118 afx_msg void OnSize(UINT nType, int cx, int cy);
119 afx_msg void OnGetMinMaxInfo(MINMAXINFO* lpMMI);
120 afx_msg void OnDestroy();
121 //}}AFX_MSG
124protected:
125 UINT m_nDialogID;
126};
127
128# if (_MSC_VER > 1200)
135class _XTP_EXT_CLASS CXTPResizeDHtmlDialog
136 : public CDHtmlDialog
137 , public CXTPResize
138{
139 DECLARE_DYNCREATE(CXTPResizeDHtmlDialog)
140
141public:
146 CXTPResizeDHtmlDialog();
147
171 CXTPResizeDHtmlDialog(const UINT nID, UINT nHtmlResID = 0, CWnd* pParent = 0,
172 const UINT nFlags = 0);
173
198 CXTPResizeDHtmlDialog(LPCTSTR lpszTemplateName, LPCTSTR szHtmlResID, CWnd* pParent = 0,
199 const UINT nFlags = 0);
200
201protected:
203 DECLARE_MESSAGE_MAP()
204
205 //{{AFX_MSG(CXTPResizeDHtmlDialog)
206 virtual BOOL OnInitDialog();
207 afx_msg void OnSize(UINT nType, int cx, int cy);
208 afx_msg void OnGetMinMaxInfo(MINMAXINFO* lpMMI);
209 afx_msg void OnDestroy();
210 //}}AFX_MSG
213protected:
214 UINT m_nDialogID;
215};
216# endif
217
218# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
220#endif // !defined(__XTPRESIZEDIALOG_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPResizeDialog
CXTPResizeDialog is a multiple inheritance class derived from CDialog and CXTPResize.
Definition XTPResizeDialog.h:42
CXTPResizeDialog::CXTPResizeDialog
CXTPResizeDialog(LPCTSTR lpszTemplateName, CWnd *pParent=0, const UINT nFlags=0)
Constructs a CXTPResizeDialog object.
CXTPResizeDialog::CXTPResizeDialog
CXTPResizeDialog()
Constructs a CXTPResizeDialog object.
CXTPResizeDialog::CXTPResizeDialog
CXTPResizeDialog(const UINT nID, CWnd *pParent=0, const UINT nFlags=0)
Constructs a CXTPResizeDialog object.
CXTPResize
CXTPResize is a base class.
Definition XTPResize.h:145


Toolkit Pro: XTPStatusBarThemeOffice2013.h Source File

  • Source
  • CommandBars
  • StatusBar
XTPStatusBarThemeOffice2013.h
Go to the documentation of this file.
1
23#if !defined(__XTPSTATUSBARTHEMEOFFICE2013_H__)
24# define __XTPSTATUSBARTHEMEOFFICE2013_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPStatusBarThemeOffice2013 : public CXTPStatusBarPaintManager
39{
40public:
46 CXTPStatusBarThemeOffice2013(CXTPPaintManager* pPaintManager);
47
54 virtual void FillStatusBar(CDC* pDC, CXTPStatusBar* pBar);
55
62 virtual void DrawStatusBarGripper(CDC* pDC, CRect rcClient);
63
72 virtual void DrawStatusBarPaneBorder(CDC* pDC, CRect rc, CXTPStatusBarPane* pPane,
73 BOOL bGripperPane);
74
82 virtual void DrawStatusBarPaneSeparator(CDC* pDC, CRect rc, CXTPStatusBarPane* pPane);
83
91 virtual void DrawStatusBarPaneEntry(CDC* pDC, CRect rcItem, CXTPStatusBarPane* pPane);
92
100 virtual void DrawStatusBarButtonFace(CDC* pDC, CRect rcItem, CXTPStatusBarPane* pPane);
101
111 virtual int DrawStatusBarSwitchPane(CDC* pDC, CRect rcItem, CXTPStatusBarSwitchPane* pPane);
112
118 virtual void RefreshMetrics();
119
128 virtual COLORREF GetTextColor(CXTPStatusBarPane* pPane);
129
130protected:
131 CXTPPaintManagerColor m_clrButtonBack;
132 CXTPPaintManagerColor m_clrButtonBackChecked;
134 CXTPPaintManagerColor m_clrButtonBackHighlight;
136 CXTPPaintManagerColor m_clrButtonBackPushed;
137 CXTPPaintManagerColor m_clrButtonTextChecked;
138 CXTPPaintManagerColor m_clrButtonTextHighlight;
139 CXTPPaintManagerColor m_clrButtonTextPushed;
140};
141
143# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
144#endif // !defined(__XTPSTATUSBARTHEMEOFFICE2013_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPPaintManagerColor
The CXTPPaintManagerColor class is used to manage COLORREF values for determining default and applica...
Definition XTPColorManager.h:117
CXTPPaintManager
Paint manager of the command bars.
Definition XTPPaintManager.h:199
CXTPStatusBar
CXTPStatusBar is a CControlBar derived class.
Definition XTPStatusBar.h:52
CXTPStatusBarPane
CXTPStatusBarPane is a CXTPCmdTarget derived class.
Definition XTPStatusBarPane.h:39
CXTPStatusBarSwitchPane
CXTPStatusBarSwitchPane is a CXTPStatusBarPane derived class.
Definition XTPStatusBarPaneSwitch.h:40
CXTPStatusBarThemeOffice2013
The CXTPStatusBarThemeVisualStudio2015 class is used to enable the Office 2013 style theme for the st...
Definition XTPStatusBarThemeOffice2013.h:39
CXTPStatusBarThemeOffice2013::m_clrButtonBack
CXTPPaintManagerColor m_clrButtonBack
Status bar button background color.
Definition XTPStatusBarThemeOffice2013.h:131
CXTPStatusBarThemeOffice2013::DrawStatusBarButtonFace
virtual void DrawStatusBarButtonFace(CDC *pDC, CRect rcItem, CXTPStatusBarPane *pPane)
This method is called to draw a status bar button.
CXTPStatusBarThemeOffice2013::DrawStatusBarGripper
virtual void DrawStatusBarGripper(CDC *pDC, CRect rcClient)
This method is called to draw the status bar's gripper.
CXTPStatusBarThemeOffice2013::m_clrButtonBackChecked
CXTPPaintManagerColor m_clrButtonBackChecked
Status bar button checked background color.
Definition XTPStatusBarThemeOffice2013.h:132
CXTPStatusBarThemeOffice2013::m_clrButtonTextHighlight
CXTPPaintManagerColor m_clrButtonTextHighlight
Status bar button highlight text color.
Definition XTPStatusBarThemeOffice2013.h:138
CXTPStatusBarThemeOffice2013::m_clrButtonBackHighlight
CXTPPaintManagerColor m_clrButtonBackHighlight
Status bar button highlight background color.
Definition XTPStatusBarThemeOffice2013.h:134
CXTPStatusBarThemeOffice2013::CXTPStatusBarThemeOffice2013
CXTPStatusBarThemeOffice2013(CXTPPaintManager *pPaintManager)
Constructs a CXTPStatusBarThemeOffice2013 object.
CXTPStatusBarThemeOffice2013::DrawStatusBarPaneEntry
virtual void DrawStatusBarPaneEntry(CDC *pDC, CRect rcItem, CXTPStatusBarPane *pPane)
This method is called to draw text for a single pane of the status bar.
CXTPStatusBarThemeOffice2013::m_clrButtonTextPushed
CXTPPaintManagerColor m_clrButtonTextPushed
Status bar button pushed text color.
Definition XTPStatusBarThemeOffice2013.h:139
CXTPStatusBarThemeOffice2013::DrawStatusBarPaneSeparator
virtual void DrawStatusBarPaneSeparator(CDC *pDC, CRect rc, CXTPStatusBarPane *pPane)
This method is called to draw a status bar switch pane separator.
CXTPStatusBarThemeOffice2013::FillStatusBar
virtual void FillStatusBar(CDC *pDC, CXTPStatusBar *pBar)
This method is called to fill a status bar.
CXTPStatusBarThemeOffice2013::DrawStatusBarPaneBorder
virtual void DrawStatusBarPaneBorder(CDC *pDC, CRect rc, CXTPStatusBarPane *pPane, BOOL bGripperPane)
This method is called to draw a frame for a single cell of the status bar.
CXTPStatusBarThemeOffice2013::m_clrButtonBackPushed
CXTPPaintManagerColor m_clrButtonBackPushed
Status bar button pushed background color.
Definition XTPStatusBarThemeOffice2013.h:136
CXTPStatusBarThemeOffice2013::m_clrButtonTextChecked
CXTPPaintManagerColor m_clrButtonTextChecked
Status bar button checked text color.
Definition XTPStatusBarThemeOffice2013.h:137
CXTPStatusBarThemeOffice2013::GetTextColor
virtual COLORREF GetTextColor(CXTPStatusBarPane *pPane)
This method is called to retrieve the text color for the pane specified by pPane.
CXTPStatusBarThemeOffice2013::RefreshMetrics
virtual void RefreshMetrics()
This method is called to refresh colors and other theme specific metrics for the paint manager.
CXTPStatusBarThemeOffice2013::DrawStatusBarSwitchPane
virtual int DrawStatusBarSwitchPane(CDC *pDC, CRect rcItem, CXTPStatusBarSwitchPane *pPane)
This method is called to draw a status bar switch pane.


Toolkit Pro: Member List

CXTPDateLabelPart Member List

This is the complete list of members for CXTPDateLabelPart, including all inherited members.

AdjustLayout(CDC *pDC, const CRect &rcRect) | CXTPCalendarCaptionBarThemePart | virtual
CXTPCalendarCaptionBarThemePart(CXTPCalendarCaptionBarTheme *pTheme, int nPartID) | CXTPCalendarCaptionBarThemePart |
CXTPCalendarWMHandler() | CXTPCalendarWMHandler |
CXTPCmdTarget() | CXTPCmdTarget |
Draw(CDC *pDC) | CXTPDateLabelPart | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCheck() const | CXTPCalendarCaptionBarThemePart | virtual
GetChildHandlerAt(int nIndex) const | CXTPCalendarWMHandler | virtual
GetChildHandlersCount() const | CXTPCalendarWMHandler | virtual
GetPaintManager() const | CXTPCalendarCaptionBarThemePart |
GetPaintTheme() const | CXTPCalendarCaptionBarThemePart | virtual
GetPartID() const | CXTPCalendarCaptionBarThemePart | virtual
GetRect() const | CXTPCalendarCaptionBarThemePart | virtual
GetState() const | CXTPCalendarCaptionBarThemePart |
GetText() const | CXTPCalendarCaptionBarThemePart | virtual
GetTextColor() | CXTPCalendarCaptionBarThemePart | virtual
GetTheme() const | CXTPCalendarCaptionBarThemePart | virtual
HitTest(const CPoint &pt) const | CXTPCalendarCaptionBarThemePart | virtual
IsVisible() const | CXTPCalendarCaptionBarThemePart | virtual
m_bVisible | CXTPCalendarCaptionBarThemePart | protected
m_clrTextColor | CXTPCalendarCaptionBarThemePart |
m_fntTextFont | CXTPDateLabelPart |
m_nPartID | CXTPCalendarCaptionBarThemePart | protected
m_nState | CXTPCalendarCaptionBarThemePart |
m_pTheme | CXTPCalendarCaptionBarThemePart | protected
m_rcRect | CXTPCalendarCaptionBarThemePart |
m_strText | CXTPCalendarCaptionBarThemePart |
OnBeforeDestroy() | CXTPCalendarWMHandler | virtual
OnChar(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnKeyUp(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnLButtonDblClk(UINT nFlags, CPoint point) | CXTPCalendarWMHandler | virtual
OnLButtonDown(UINT nFlags, CPoint point) | CXTPCalendarCaptionBarThemePart | virtual
OnLButtonUp(UINT nFlags, CPoint point) | CXTPCalendarCaptionBarThemePart | virtual
OnMouseMove(UINT nFlags, CPoint point) | CXTPCalendarCaptionBarThemePart | virtual
OnPostAdjustLayout() | CXTPCalendarWMHandler | virtual
OnSysKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnTimer(UINT_PTR uTimerID) | CXTPCalendarWMHandler | virtual
OnWndMsg(UINT message, WPARAM wParam, LPARAM lParam, LRESULT *pResult) | CXTPCalendarWMHandler | virtual
Redraw(BOOL bUpdateNow=FALSE) | CXTPCalendarCaptionBarThemePart | virtual
RefreshMetrics() | CXTPDateLabelPart | virtual
SetCheck(int nCheck) | CXTPCalendarCaptionBarThemePart | virtual
SetState(int nState) | CXTPCalendarCaptionBarThemePart | virtual
SetText(LPCTSTR pcszText) | CXTPCalendarCaptionBarThemePart | virtual
SetVisible(BOOL bVisible) | CXTPCalendarCaptionBarThemePart | virtual
~CXTPCalendarCaptionBarThemePart() | CXTPCalendarCaptionBarThemePart | virtual


Toolkit Pro: Member List

CXTPCalendarViewDay Member List

This is the complete list of members for CXTPCalendarViewDay, including all inherited members.

AdjustLayout(CDC *pDC, const CRect &rcDay) | CXTPCalendarViewDay | virtual
ContainsInvisibleEvents() const | CXTPCalendarViewDay | virtual
ContainsInvisibleEventsUpdate() | CXTPCalendarViewDay | virtual
CreateGroup()=0 | CXTPCalendarViewDay | protectedpure virtual
CXTPCalendarViewDay(const CXTPCalendarView *pView) | CXTPCalendarViewDay |
CXTPCalendarWMHandler() | CXTPCalendarWMHandler |
CXTPCmdTarget() | CXTPCmdTarget |
Draw(CDC *pDC) | CXTPCalendarViewDay | inlinevirtual
FillHitTestEx(XTP_CALENDAR_HITTESTINFO *pHitTest) const =0 | CXTPCalendarViewDay | pure virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCalendarControl() const | CXTPCalendarViewDay | virtual
GetChildHandlerAt(int nIndex) const | CXTPCalendarViewDay | inlinevirtual
GetChildHandlersCount() const | CXTPCalendarViewDay | inlinevirtual
GetDayDate() const | CXTPCalendarViewDay | virtual
GetDayIndex() const | CXTPCalendarViewDay | virtual
GetDayRect() const | CXTPCalendarViewDay | virtual
GetExpandSignRect() const | CXTPCalendarViewDay | virtual
GetResources() const | CXTPCalendarViewDay | virtual
GetView_() const | CXTPCalendarViewDay | virtual
GetViewEvent_(int nIndex) const | CXTPCalendarViewDay | virtual
GetViewEventsCount() const | CXTPCalendarViewDay | virtual
GetViewGroup_(int nIndex) const | CXTPCalendarViewDay |
GetViewGroupsCount() const | CXTPCalendarViewDay |
HitTest(CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const | CXTPCalendarViewDay | virtual
HitTestEx(CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const | CXTPCalendarViewDay | virtual
IsExpanded() const | CXTPCalendarViewDay | virtual
IsSelected() const | CXTPCalendarViewDay | virtual
KillTimer(UINT uTimerID) | CXTPCalendarViewDay | virtual
m_arViewGroups | CXTPCalendarViewDay | protected
m_dtDate | CXTPCalendarViewDay | protected
m_Layout | CXTPCalendarViewDay | protected
m_pResources | CXTPCalendarViewDay | protected
m_pView | CXTPCalendarViewDay | protected
OnBeforeDestroy() | CXTPCalendarWMHandler | virtual
OnChar(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnKeyUp(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnLButtonDblClk(UINT nFlags, CPoint point) | CXTPCalendarWMHandler | virtual
OnLButtonDown(UINT nFlags, CPoint point) | CXTPCalendarWMHandler | virtual
OnLButtonUp(UINT nFlags, CPoint point) | CXTPCalendarWMHandler | virtual
OnMouseMove(UINT nFlags, CPoint point) | CXTPCalendarWMHandler | virtual
OnPostAdjustLayout() | CXTPCalendarWMHandler | virtual
OnPrePopulateDay() | CXTPCalendarViewDay | protectedvirtual
OnSysKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnTimer(UINT_PTR uTimerID) | CXTPCalendarWMHandler | virtual
OnWndMsg(UINT message, WPARAM wParam, LPARAM lParam, LRESULT *pResult) | CXTPCalendarWMHandler | virtual
Populate(COleDateTime dtDayDate) | CXTPCalendarViewDay | virtual
SetDayDate(COleDateTime dtDayDate) | CXTPCalendarViewDay | virtual
SetDayRect(CRect rcDay) | CXTPCalendarViewDay | virtual
SetResources(CXTPCalendarResources *pResources) | CXTPCalendarViewDay | virtual
SetSelected() | CXTPCalendarViewDay | virtual
SetTimer(UINT uTimeOut_ms) | CXTPCalendarViewDay | virtual
UserAction_OnExpandDay(XTPCalendarExpandDayButton eButton) | CXTPCalendarViewDay | virtual
~CXTPCalendarViewDay() | CXTPCalendarViewDay | virtual


Toolkit Pro: XTPDatePickerVisualStudio2017Theme.h Source File

  • Source
  • Calendar
  • DatePicker
  • Themes
XTPDatePickerVisualStudio2017Theme.h
Go to the documentation of this file.
1
22#if !defined(_XTPDATEPICKERVISUALSTUDIO2017THEME_H__)
23# define _XTPDATEPICKERVISUALSTUDIO2017THEME_H__
24
25# if _MSC_VER > 1000
26# pragma once
27# endif // _MSC_VER > 1000
28
29# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
30
51class _XTP_EXT_CLASS CXTPDatePickerThemeVisualStudio2017 : public CXTPDatePickerThemeOffice2013
52{
53public:
62 CXTPDatePickerThemeVisualStudio2017();
63
70 virtual ~CXTPDatePickerThemeVisualStudio2017();
71};
72
73# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
74#endif // !defined(_XTPDATEPICKERVISUALSTUDIO2017THEME_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPDatePickerThemeOffice2013
Class CXTPDatePickerThemeOffice2013 is derived from CXTPDatePickerPaintManager for rendering an Offic...
Definition XTPDatePickerOffice2013Theme.h:52
CXTPDatePickerThemeVisualStudio2017
Class CXTPDatePickerThemeVisualStudio2017 is derived from CXTPDatePickerThemeOffice2013 for rendering...
Definition XTPDatePickerVisualStudio2017Theme.h:52
CXTPDatePickerThemeVisualStudio2017::~CXTPDatePickerThemeVisualStudio2017
virtual ~CXTPDatePickerThemeVisualStudio2017()
Default paint manager destructor.
CXTPDatePickerThemeVisualStudio2017::CXTPDatePickerThemeVisualStudio2017
CXTPDatePickerThemeVisualStudio2017()
Default paint manager constructor.


Toolkit Pro: Member List

CXTPChart3dPyramidSeriesPointView Member List

This is the complete list of members for CXTPChart3dPyramidSeriesPointView, including all inherited members.

AddChildView(CXTPChartElementView *pChildView) | CXTPChartElementView |
CalculateLayout(int nIndex, int nCount, double dFrom, double dTo) | CXTPChart3dPyramidSeriesPointView | virtual
CreateDeviceCommand(CXTPChartDeviceContext *pDC) | CXTPChart3dPyramidSeriesPointView | protectedvirtual
CreateLegendDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcBounds) | CXTPChart3dPyramidSeriesPointView | protectedvirtual
CXTPChart3dPyramidSeriesPointView(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView) | CXTPChart3dPyramidSeriesPointView |
CXTPChartElementView(CXTPChartElementView *pParentView) | CXTPChartElementView |
CXTPChartElementView(CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartElementView |
CXTPChartElementView(CXTPChartContainer *pContainer) | CXTPChartElementView |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartPyramidSeriesPointViewBase(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView) | CXTPChartPyramidSeriesPointViewBase |
CXTPChartPyramidSeriesPointViewBase(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartPyramidSeriesPointViewBase |
CXTPChartSeriesPointView(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView) | CXTPChartSeriesPointView |
CXTPChartSeriesPointView(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartSeriesPointView |
GetAt(int nIndex) const | CXTPChartElementView |
GetBorderActualColor() const | CXTPChartPyramidSeriesPointViewBase |
GetBounds() const | CXTPChartElementView |
GetBounds(BOOL bIncludingChildren) const | CXTPChartElementView |
GetCenterShapeConnectorPoint() const | CXTPChart3dPyramidSeriesPointView |
GetChildren() | CXTPChartElementView |
GetColor() const | CXTPChartSeriesPointView |
GetColor2() const | CXTPChartSeriesPointView |
GetCount() const | CXTPChartElementView |
GetInternalValue() const | CXTPChartSeriesPointView |
GetLegendName() const | CXTPChartSeriesPointView | virtual
GetOuterCenterConnectorPoint() const | CXTPChart3dPyramidSeriesPointView |
GetParentView() const | CXTPChartElementView |
GetPoint() const | CXTPChartSeriesPointView |
GetSeriesView() const | CXTPChartSeriesPointView |
Is3D() const | CXTPChartObject |
m_arrChildren | CXTPChartElementView | protected
m_dInternalValue | CXTPChartSeriesPointView |
m_dValue | CXTPChartPyramidSeriesPointViewBase | protected
m_pContainer | CXTPChartElementView | protected
m_pParentView | CXTPChartElementView | protected
m_pPoint | CXTPChartSeriesPointView | protected
m_rcBounds | CXTPChartElementView | protected
OnSetConnectorPoints(CXTPChartDeviceCommand *pCommand, CXTPPoint3d ptShapeCenter, CXTPPoint3d ptOuterCenter) | CXTPChart3dPyramidSeriesPointView | protectedvirtual
OnUpdateBounds(CXTPChartDeviceCommand *pCommand, CRect rcBounds) | CXTPChart3dPyramidSeriesPointView | protectedvirtual
UpdateMinMaxRange(double &nMinValue, double &nMaxValue) const | CXTPChartSeriesPointView | virtual
~CXTPChart3dPyramidSeriesPointView() | CXTPChart3dPyramidSeriesPointView | virtual
~CXTPChartElementView() | CXTPChartElementView | protectedvirtual
~CXTPChartLegendItemView() | CXTPChartLegendItemView | inlinevirtual
~CXTPChartPyramidSeriesPointViewBase() | CXTPChartPyramidSeriesPointViewBase | virtual


Toolkit Pro: XTPPropertyGridItemFlags.h Source File

  • Source
  • PropertyGrid
XTPPropertyGridItemFlags.h
Go to the documentation of this file.
1
23#if !defined(__XTPPROPERTYGRIDITEMFLAGS_H__)
24# define __XTPPROPERTYGRIDITEMFLAGS_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
100class _XTP_EXT_CLASS CXTPPropertyGridItemFlags : public CXTPPropertyGridItem
101{
102public:
141 CXTPPropertyGridItemFlags(LPCTSTR strCaption, int nValue = 0, int* pBindFlags = NULL);
142
181 CXTPPropertyGridItemFlags(UINT nID, int nValue = 0, int* pBindFlags = NULL);
182
187 virtual ~CXTPPropertyGridItemFlags();
188
202 virtual void SetFlags(int nValue);
203
218 virtual int GetFlags() const;
219
243 virtual void BindToFlags(int* pBindFlags);
244
245protected:
253 virtual void SetValue(CString strValue);
254
268 virtual void OnBeforeInsert();
269
277 virtual void OnConstraintsChanged();
278
285 virtual void SetReadOnly(BOOL bReadOnly);
286
293 virtual CString GetFlagsString();
294
299 virtual void UpdateChilds();
300
301 class CXTPPropertyGridItemFlag;
302
303private:
304 void _Init(int nValue);
305 BOOL HasFlag(const CString& strValue, CString strFlag) const;
306
307protected:
308 int m_nValue;
310 int* m_pBindFlags;
312private:
313 DECLARE_DYNAMIC(CXTPPropertyGridItemFlags)
314
315# ifdef _XTP_ACTIVEX
317 afx_msg void OleSetValue(const VARIANT* varValue);
318 afx_msg const VARIANT OleGetValue();
319
320 void BindDispatch();
322# endif
323 friend class CXTPPropertyGridItemFlag;
324};
325
326AFX_INLINE int CXTPPropertyGridItemFlags::GetFlags() const
327{
328 return m_nValue;
329}
330
331# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
333#endif // __XTPPROPERTYGRIDITEMFLAGS_H__
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPPropertyGridItemFlags
CXTPPropertyGridItemFlags is a CXTPPropertyGridItem derived class.
Definition XTPPropertyGridItemFlags.h:101
CXTPPropertyGridItemFlags::OnConstraintsChanged
virtual void OnConstraintsChanged()
This method is called when constraints are added to the item (i.e.
CXTPPropertyGridItemFlags::~CXTPPropertyGridItemFlags
virtual ~CXTPPropertyGridItemFlags()
Destroys a CXTPPropertyGridItemFlags object.
CXTPPropertyGridItemFlags::SetFlags
virtual void SetFlags(int nValue)
Sets the value of the item.
CXTPPropertyGridItemFlags::OnBeforeInsert
virtual void OnBeforeInsert()
This method is called before the item becomes visible in the property grid.
CXTPPropertyGridItemFlags::m_nValue
int m_nValue
Value of the item.
Definition XTPPropertyGridItemFlags.h:308
CXTPPropertyGridItemFlags::SetReadOnly
virtual void SetReadOnly(BOOL bReadOnly)
Specifies if the item state should be set to read-only or to read/write.
CXTPPropertyGridItemFlags::SetValue
virtual void SetValue(CString strValue)
Sets the value of the item.
CXTPPropertyGridItemFlags::UpdateChilds
virtual void UpdateChilds()
Refreshes BOOL child items.
CXTPPropertyGridItemFlags::GetFlags
virtual int GetFlags() const
Gets the value of the item.
Definition XTPPropertyGridItemFlags.h:326
CXTPPropertyGridItemFlags::CXTPPropertyGridItemFlags
CXTPPropertyGridItemFlags(UINT nID, int nValue=0, int *pBindFlags=NULL)
Constructs a CXTPPropertyGridItemFlag object.
CXTPPropertyGridItemFlags::GetFlagsString
virtual CString GetFlagsString()
Gets the string notation of the selected flags.
CXTPPropertyGridItemFlags::CXTPPropertyGridItemFlags
CXTPPropertyGridItemFlags(LPCTSTR strCaption, int nValue=0, int *pBindFlags=NULL)
Constructs a CXTPPropertyGridItemFlag object.
CXTPPropertyGridItemFlags::BindToFlags
virtual void BindToFlags(int *pBindFlags)
Binds the item to a specified integer value.
CXTPPropertyGridItem
CXTPPropertyGridItem is the base class representing an item of the Property Grid control.
Definition XTPPropertyGridItem.h:523
CXTPPropertyGridItem::GetFlags
UINT GetFlags() const
Gets the flags of the item.


Toolkit Pro: XTPTaskPanelPaintManagerPlain.h Source File

  • Source
  • TaskPanel
  • Themes
XTPTaskPanelPaintManagerPlain.h
Go to the documentation of this file.
1
23#ifndef XTPTaskPanelPaintManagerPlain_h__
24# define XTPTaskPanelPaintManagerPlain_h__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
40class _XTP_EXT_CLASS CXTPTaskPanelPaintManagerPlain : public CXTPTaskPanelPaintManager
41{
42public:
47 CXTPTaskPanelPaintManagerPlain();
48
53 void RefreshMetrics();
54
62 void DrawGroupClientFace(CDC* pDC, CXTPTaskPanelGroup* pGroup, CRect rc);
63
73 void FillGroupClientFace(CDC* pDC, CXTPTaskPanelGroup* pGroup, CRect rc);
74
81 void FillTaskPanel(CDC* pDC, CXTPTaskPanel* pTaskPanel);
82
93 int DrawGroupCaption(CDC* pDC, CXTPTaskPanelGroup* pGroup, BOOL bDraw);
94
95protected:
96 BOOL m_bRoundedFrame;
98 BOOL m_bOfficeCaption;
101};
103# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
104#endif // XTPTaskPanelPaintManagerPlain_h__
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPTaskPanelGroup
CXTPTaskPanelGroup is used in a Task Panel control to represent a group.
Definition XTPTaskPanelGroup.h:45
CXTPTaskPanel
CXTPTaskPanel is used to implement an Explorer and Office-like Task Panel control.
Definition XTPTaskPanel.h:107
CXTPTaskPanelPaintManager
CXTPTaskPanelPaintManager is a standalone class used by CXTPTaskPanel as a paint manager.
Definition XTPTaskPanelPaintManager.h:115
CXTPTaskPanelPaintManagerPlain
Base class theme that all other themes are derived from.
Definition XTPTaskPanelPaintManagerPlain.h:41
CXTPTaskPanelPaintManagerPlain::m_bRoundedFrame
BOOL m_bRoundedFrame
TRUE to draw a rounded frame around all of the groups in the task panel.
Definition XTPTaskPanelPaintManagerPlain.h:96
CXTPTaskPanelPaintManagerPlain::FillTaskPanel
void FillTaskPanel(CDC *pDC, CXTPTaskPanel *pTaskPanel)
Fills the background of a specified task panel.
CXTPTaskPanelPaintManagerPlain::CXTPTaskPanelPaintManagerPlain
CXTPTaskPanelPaintManagerPlain()
Constructs a CXTPTaskPanelPaintManagerPlain object.
CXTPTaskPanelPaintManagerPlain::m_bOfficeCaption
BOOL m_bOfficeCaption
FALSE to draw a rounded rectangle around caption.
Definition XTPTaskPanelPaintManagerPlain.h:98
CXTPTaskPanelPaintManagerPlain::DrawGroupCaption
int DrawGroupCaption(CDC *pDC, CXTPTaskPanelGroup *pGroup, BOOL bDraw)
Draws the caption of a specified group.
CXTPTaskPanelPaintManagerPlain::FillGroupClientFace
void FillGroupClientFace(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Fills the client face of a specified group.
CXTPTaskPanelPaintManagerPlain::RefreshMetrics
void RefreshMetrics()
Refreshes the visual metrics of the task panel.
CXTPTaskPanelPaintManagerPlain::DrawGroupClientFace
void DrawGroupClientFace(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Draws the client face of a specified group.


Toolkit Pro: XTPComboBoxThemeVisualStudio2022.h Source File

  • Source
  • Controls
  • Combo
  • Themes
XTPComboBoxThemeVisualStudio2022.h
Go to the documentation of this file.
1
23#if !defined(__XTPCOMBOBOXTHEMEVISUALSTUDIO2022_H__)
24# define __XTPCOMBOBOXTHEMEVISUALSTUDIO2022_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPComboBoxThemeVisualStudio2022 : public CXTPComboBoxThemeOffice2013
39{
40public:
45 CXTPComboBoxThemeVisualStudio2022();
46
51 virtual ~CXTPComboBoxThemeVisualStudio2022();
52
59 virtual void RefreshMetrics(CXTPComboBox* pComboBox);
60
69 virtual void DrawButton(CDC* pDC, CXTPComboBox* pComboBox, CRect rcBtn);
70};
71
72# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
74#endif // __XTPCOMBOBOXTHEMEVISUALSTUDIO2022_H__
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPComboBox
The CXTPComboBox class provides the functionality of a themed Windows combobox.
Definition XTPComboBox.h:42
CXTPComboBoxThemeOffice2013
Used as the paint manager for a combobox control to render an Office 2013 appearance.
Definition XTPComboBoxThemeOffice2013.h:39
CXTPComboBoxThemeVisualStudio2022
Used as the paint manager for a combobox control to render a Visual Studio 2022 appearance.
Definition XTPComboBoxThemeVisualStudio2022.h:39
CXTPComboBoxThemeVisualStudio2022::RefreshMetrics
virtual void RefreshMetrics(CXTPComboBox *pComboBox)
This member function is called by the theme manager to refresh the visual styles used by each compone...
CXTPComboBoxThemeVisualStudio2022::CXTPComboBoxThemeVisualStudio2022
CXTPComboBoxThemeVisualStudio2022()
Default constructor.
CXTPComboBoxThemeVisualStudio2022::DrawButton
virtual void DrawButton(CDC *pDC, CXTPComboBox *pComboBox, CRect rcBtn)
Called by the paint manager to draw the button portion of the combobox control.
CXTPComboBoxThemeVisualStudio2022::~CXTPComboBoxThemeVisualStudio2022
virtual ~CXTPComboBoxThemeVisualStudio2022()
Destructor handles cleanup and deallocation.


Toolkit Pro: XTPDockingPaneThemeOffice2003Outlook.h Source File

  • Source
  • DockingPane
  • Themes
XTPDockingPaneThemeOffice2003Outlook.h
Go to the documentation of this file.
1
23#if !defined(__XTPDOCKINGPANETHEMEOFFICE2003OUTLOOK_H__)
24# define __XTPDOCKINGPANETHEMEOFFICE2003OUTLOOK_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
41class _XTP_EXT_CLASS CXTPDockingPaneOffice2003OutlookTheme : public CXTPDockingPaneOffice2003Theme
42{
43public:
48 CXTPDockingPaneOffice2003OutlookTheme();
49
55 virtual ~CXTPDockingPaneOffice2003OutlookTheme();
56
57public:
62 virtual void RefreshMetrics();
63
71 virtual CRect GetCaptionGripperRect(const CXTPDockingPaneTabbedContainer* pPane);
72};
73
74# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
76#endif // !defined(__XTPDOCKINGPANETHEMEOFFICE2003OUTLOOK_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPDockingPaneOffice2003OutlookTheme
CXTPDockingPaneOffice2003OutlookTheme is a CXTPDockingPaneOffice2003Theme derived class that represen...
Definition XTPDockingPaneThemeOffice2003Outlook.h:42
CXTPDockingPaneOffice2003OutlookTheme::CXTPDockingPaneOffice2003OutlookTheme
CXTPDockingPaneOffice2003OutlookTheme()
Constructs a CXTPDockingPaneOffice2003OutlookTheme object.
CXTPDockingPaneOffice2003OutlookTheme::~CXTPDockingPaneOffice2003OutlookTheme
virtual ~CXTPDockingPaneOffice2003OutlookTheme()
Destroys a CXTPDockingPaneOffice2003OutlookTheme object, handles cleanup and deallocation.
CXTPDockingPaneOffice2003OutlookTheme::GetCaptionGripperRect
virtual CRect GetCaptionGripperRect(const CXTPDockingPaneTabbedContainer *pPane)
Call this method to get the caption gripper for a tabbed container.
CXTPDockingPaneOffice2003OutlookTheme::RefreshMetrics
virtual void RefreshMetrics()
This method is called to refresh the visual metrics of the pane.
CXTPDockingPaneOffice2003Theme
CXTPDockingPaneOffice2003Theme is a CXTPDockingPaneVisualStudio2003Theme derived class that represent...
Definition XTPDockingPaneThemeOffice2003.h:41
CXTPDockingPaneTabbedContainer
CXTPDockingPaneTabbedContainer is a multiple inheritance class derived from CWnd and CXTPDockingPaneB...
Definition XTPDockingPaneTabbedContainer.h:47


Toolkit Pro: Member List

CXTPDockingPaneVisualStudio2012Theme Member List

This is the complete list of members for CXTPDockingPaneVisualStudio2012Theme, including all inherited members.

AdjustCaptionRect(const CXTPDockingPaneTabbedContainer *pPane, CRect &rc) | CXTPDockingPaneVisualStudio2012Theme | virtual
CXTPDockingPaneDefaultTheme::AdjustCaptionRect(const CXTPDockingPaneSidePanel *pPane, CRect &rc) | CXTPDockingPanePaintManager | virtual
AdjustClientRect(CXTPDockingPaneTabbedContainer *pPane, CRect &rc, BOOL bApply) | CXTPDockingPaneVisualStudio2012Theme | virtual
CXTPDockingPaneDefaultTheme::AdjustClientRect(CXTPDockingPaneSidePanel *pPane, CRect &rect) | CXTPDockingPanePaintManager | virtual
ClipAndAddEllipsisIfNeeded(CDC *pDC, CString &strTitle, int nCaptionWidth) const | CXTPDockingPanePaintManager | protected
CXTPCmdTarget() | CXTPCmdTarget |
CXTPDockingPaneDefaultTheme() | CXTPDockingPaneDefaultTheme |
CXTPDockingPanePaintManager() | CXTPDockingPanePaintManager | protected
CXTPDockingPaneVisualStudio2012Theme() | CXTPDockingPaneVisualStudio2012Theme |
DeletePaneColorSets() | CXTPDockingPaneVisualStudio2012Theme | protected
DrawAutoHidePanel(CDC *pDC, CRect rc, XTPDockingPaneDirection direction) | CXTPDockingPaneVisualStudio2012Theme | virtual
DrawCaption(CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc) | CXTPDockingPaneVisualStudio2012Theme | virtual
DrawCaptionButton(CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton) | CXTPDockingPaneVisualStudio2012Theme | virtual
DrawCaptionButtonEntry(CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton, CSize szOffset) | CXTPDockingPanePaintManager | protectedvirtual
DrawCaptionButtonEntry(CDC *pDC, CXTPDockingPaneCaptionButton *pButton, CPoint pt, COLORREF clrButton) | CXTPDockingPanePaintManager | protectedvirtual
DrawCaptionButtons(CDC *pDC, CXTPDockingPaneCaptionButtons *pButtons, CRect &rcCaption, COLORREF clr, int nButtonSize, int nButtonGap, BOOL bVertical=FALSE) | CXTPDockingPanePaintManager | virtual
DrawCaptionPart(CDC *pDC, CXTPDockingPaneBase *pPane, CRect rcCaption, const CString &strTitle, BOOL bActive, BOOL bVertical) | CXTPDockingPaneDefaultTheme | protectedvirtual
DrawCaptionText(CDC *pDC, const CString &strTitle, CRect rc, BOOL bVertical, BOOL bCalcWidth=FALSE) | CXTPDockingPanePaintManager |
DrawDottedLine(CDC *pDC, int x, int y, int nSize, COLORREF clr, BOOL bVertical) | CXTPDockingPaneVisualStudio2012Theme | protected
DrawFloatingFrame(CDC *pDC, CXTPDockingPaneMiniWnd *pPane, CRect rc) | CXTPDockingPaneVisualStudio2012Theme | virtual
DrawGripper(CDC *pDC, CRect rcGripper, COLORREF clr, BOOL bVertical) | CXTPDockingPaneVisualStudio2012Theme | protected
DrawPane(CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc) | CXTPDockingPaneVisualStudio2012Theme | virtual
DrawSidePanel(CDC *pDC, CXTPDockingPaneSidePanel *pPane, CRect rc) | CXTPDockingPaneVisualStudio2012Theme | virtual
DrawSplitter(CDC *pDC, CXTPDockingPaneSplitterWnd *pSplitter) | CXTPDockingPaneVisualStudio2012Theme | virtual
DrawTitleBar(CDC *pDC, CXTPDockingPaneBase *pPane, CRect rc, BOOL bVertical) | CXTPDockingPaneVisualStudio2012Theme | protectedvirtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCaptionButtonStyle() const | CXTPDockingPanePaintManager |
GetCaptionGripperRect(const CXTPDockingPaneTabbedContainer *pPane) | CXTPDockingPanePaintManager | virtual
GetCaptionHeight() const | CXTPDockingPanePaintManager |
GetCaptionRect(const CXTPDockingPaneTabbedContainer *pPane, CRect &rc) | CXTPDockingPanePaintManager | virtual
GetColorSet(BOOL bActive) | CXTPDockingPaneVisualStudio2012Theme | protectedvirtual
GetCurrentSystemTheme() const | CXTPDockingPanePaintManager |
GetCustomTitleBrush(BOOL bActive, BOOL bVertical) const | CXTPDockingPanePaintManager |
GetPaneCaptionRect(const CXTPDockingPaneSidePanel *pPane) | CXTPDockingPaneVisualStudio2012Theme | virtual
GetPanelPaintManager() const | CXTPDockingPanePaintManager |
GetSplitterStyle() const | CXTPDockingPanePaintManager |
GetTabPaintManager() const | CXTPDockingPanePaintManager |
GetTabsHeight() const | CXTPDockingPanePaintManager |
GetXtremeColor(UINT nIndex) | CXTPDockingPanePaintManager |
Line(CDC *pDC, int x0, int y0, int x1, int y1, int nPen) | CXTPDockingPanePaintManager |
Line(CDC *pDC, int x0, int y0, int x1, int y1) | CXTPDockingPanePaintManager |
m_arrColor | CXTPDockingPanePaintManager | protected
m_bDestroyCustomTitleBrushes | CXTPDockingPanePaintManager | protected
m_bDrawCaptionIcon | CXTPDockingPanePaintManager |
m_bDrawSingleTab | CXTPDockingPanePaintManager |
m_bHighlightActiveCaption | CXTPDockingPanePaintManager |
m_bLunaTheme | CXTPDockingPanePaintManager | protected
m_bShowCaption | CXTPDockingPanePaintManager |
m_bUseBoldCaptionFont | CXTPDockingPanePaintManager |
m_bUseOfficeFont | CXTPDockingPanePaintManager | protected
m_bUseStandardFont | CXTPDockingPanePaintManager | protected
m_clrActiveCaption | CXTPDockingPanePaintManager |
m_clrActiveCaptionText | CXTPDockingPanePaintManager |
m_clrBackground | CXTPDockingPanePaintManager |
m_clrDisabledCaptionText | CXTPDockingPanePaintManager |
m_clrNormalCaption | CXTPDockingPanePaintManager |
m_clrNormalCaptionText | CXTPDockingPanePaintManager |
m_clrSplitter | CXTPDockingPanePaintManager |
m_clrSplitterGradient | CXTPDockingPanePaintManager |
m_clrSplitterGripper | CXTPDockingPanePaintManager |
m_dwSplitterStyle | CXTPDockingPanePaintManager | protected
m_hbrActiveTitleHorz | CXTPDockingPanePaintManager | protected
m_hbrActiveTitleVert | CXTPDockingPanePaintManager | protected
m_hbrInactiveTitleHorz | CXTPDockingPanePaintManager | protected
m_hbrInactiveTitleVert | CXTPDockingPanePaintManager | protected
m_nCaptionButtonStyle | CXTPDockingPanePaintManager | protected
m_nCaptionFontGap | CXTPDockingPanePaintManager | protected
m_nFontSize | CXTPDockingPaneVisualStudio2012Theme | protected
m_nSplitterIndent | CXTPDockingPanePaintManager |
m_nSplitterSize | CXTPDockingPanePaintManager |
m_nTabsHeight | CXTPDockingPanePaintManager | protected
m_nTitleHeight | CXTPDockingPanePaintManager | protected
m_pcsActive | CXTPDockingPaneVisualStudio2012Theme | protected
m_pcsInactive | CXTPDockingPaneVisualStudio2012Theme | protected
m_pPanelPaintManager | CXTPDockingPanePaintManager | protected
m_pTabPaintManager | CXTPDockingPanePaintManager | protected
m_rcCaptionMargin | CXTPDockingPanePaintManager | protected
m_strFontFace | CXTPDockingPaneVisualStudio2012Theme | protected
m_strOfficeFont | CXTPDockingPanePaintManager | protected
m_systemTheme | CXTPDockingPanePaintManager | protected
m_themeButton | CXTPDockingPanePaintManager | protected
m_themeCurrent | CXTPDockingPanePaintManager | protected
m_themeExplorer | CXTPDockingPanePaintManager | protected
m_themeRebar | CXTPDockingPanePaintManager | protected
m_themeToolbar | CXTPDockingPanePaintManager | protected
m_themeWindow | CXTPDockingPanePaintManager | protected
m_xtpFontTitle | CXTPDockingPanePaintManager | protected
m_xtpFontTitleVertical | CXTPDockingPanePaintManager | protected
Pixel(CDC *pDC, int xPos, int yPos, int nPen) | CXTPDockingPanePaintManager |
Rectangle(CDC *pDC, CRect rc, int nPenEntry, int nPenBorder) | CXTPDockingPanePaintManager |
RefreshMetrics() | CXTPDockingPaneVisualStudio2012Theme | virtual
SetCaptionButtonStyle(XTPDockingPaneCaptionButtonStyle nStyle) | CXTPDockingPanePaintManager |
SetCaptionFontIndirect(LOGFONT *pLogFont, BOOL bUseStandardFont=FALSE) | CXTPDockingPanePaintManager |
SetColors(int cElements, CONST INT *lpaElements, CONST COLORREF *lpaRgbValues) | CXTPDockingPanePaintManager |
SetCustomTitleBrushes(HBRUSH hbrActiveTitleHorz, HBRUSH hbrInactiveTitleHorz=NULL, HBRUSH hbrActiveTitleVert=NULL, HBRUSH hbrInactiveTitleVert=NULL, BOOL bDestroyOnCleanup=FALSE) | CXTPDockingPanePaintManager |
SetLunaTheme(XTPCurrentSystemTheme systemTheme) | CXTPDockingPanePaintManager |
SetPaneColorSets(CXTPDockingPaneColorSet *pcsActive, CXTPDockingPaneColorSet *pcsInactive) | CXTPDockingPaneVisualStudio2012Theme | protected
SetPanelPaintManager(CXTPTabPaintManager *pManager) | CXTPDockingPanePaintManager |
SetSplitterStyle(DWORD dwStyle) | CXTPDockingPanePaintManager |
SetTabPaintManager(CXTPTabPaintManager *pManager) | CXTPDockingPanePaintManager |
UseOfficeFont(BOOL bUseOfficeFont) | CXTPDockingPanePaintManager |
~CXTPDockingPanePaintManager() | CXTPDockingPanePaintManager | protectedvirtual
~CXTPDockingPaneVisualStudio2012Theme() | CXTPDockingPaneVisualStudio2012Theme | virtual


Toolkit Pro: XTPStatusBarColorSet.h Source File

  • Source
  • CommandBars
  • StatusBar
XTPStatusBarColorSet.h
Go to the documentation of this file.
1
23#if !defined(__XTPSTATUSBARCOLORSET_H__)
24# define __XTPSTATUSBARCOLORSET_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class _XTP_EXT_CLASS CXTPStatusBarColorSet
34{
35public:
36 CXTPPaintManagerColor m_clrStatusBarBackground;
37 CXTPPaintManagerColor m_clrStatusBarText;
38};
39
41# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
42#endif // !defined(__XTPSTATUSBARCOLORSET_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPPaintManagerColor
The CXTPPaintManagerColor class is used to manage COLORREF values for determining default and applica...
Definition XTPColorManager.h:117


Toolkit Pro: XTPCommandBarsOffice2013Theme.h Source File

  • Source
  • CommandBars
  • Themes
XTPCommandBarsOffice2013Theme.h
Go to the documentation of this file.
1
23#if !defined(__XTPCOMMANDBARSOFFICE2013THEME_H__)
24# define __XTPCOMMANDBARSOFFICE2013THEME_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
36enum XTPBackImage
37{
38 XTPNone,
39 XTPCalligraphy,
40 XTPCirclesAndStripes,
41 XTPCircuit,
42 XTPClouds,
43 XTPDoodleCircles,
44 XTPDoodleDiamonds,
45 XTPGeometry,
46 XTPLunchBox,
47 XTPSchoolSupplies,
48 XTPSpring,
49 XTPStars,
50 XTPStraws,
51 XTPTreeRings,
52 XTPUnderWater,
53};
54
62class _XTP_EXT_CLASS CXTPCommandBarsOffice2013Theme : public CXTPCommandBarsModernUITheme
63{
65 DECLARE_DYNAMIC(CXTPCommandBarsOffice2013Theme)
67public:
72 CXTPCommandBarsOffice2013Theme();
73
78 virtual ~CXTPCommandBarsOffice2013Theme();
79
86 virtual XTPPaintTheme BaseTheme();
87
96 virtual BOOL DrawRectangle(CDC* pDC, CXTPControl* pButton);
97
104 virtual void FillCommandBarEntry(CDC* pDC, CXTPCommandBar* pBar);
105
112 virtual void FillDockBar(CDC* pDC, CXTPDockBar* pBar);
113
123 virtual void DrawCommandBarGroupSeparator(CDC* pDC, CXTPCommandBar* pBar,
124 CXTPControl* pLeftControl, CXTPControl* pRightControl,
125 BOOL bDraw);
126
136 virtual CSize DrawControlEdit(CDC* pDC, CXTPControlEdit* pEdit, BOOL bDraw);
137
145 virtual void FillWorkspace(CDC* pDC, CRect rc, CRect rcExclude);
146
154 virtual BOOL RequiresResourceImages();
155
163 virtual COLORREF GetControlEditBackColor(CXTPControl* pControl);
164
176 virtual void DrawGalleryItemBack(CDC* pDC, CRect rcItem, BOOL bEnabled, BOOL bSelected,
177 BOOL bPressed, BOOL bChecked, XTPBarType barType);
178
179 virtual BOOL SetOfficeBackImage(CXTPCommandBars* pCommandBars,
180 XTPBackImage nBackImage = XTPNone);
181
182protected:
187 virtual void RefreshMetrics();
188
195 virtual void RefreshStandardColors();
196
209 virtual COLORREF GetRectangleTextColor(BOOL bSelected, BOOL bPressed, BOOL bEnabled,
210 BOOL bChecked, BOOL bPopuped, XTPBarType barType,
211 XTPBarPosition barPosition);
212
219 virtual COLORREF GetControlTextColor(CXTPControl* pButton);
220
228 virtual COLORREF GetControlBackColor(CXTPControl* pButton);
229
230 //-----------------------------------------------------------------------
231 // Summary:
232 // This method is called to fill the control's face.
233 // Parameters:
234 // pDC - Pointer to a valid device context.
235 // rc - Rectangle to draw.
236 // bSelected - TRUE if the control is selected.
237 // bPressed - TRUE if the control is pushed.
238 // bEnabled - TRUE if the control is enabled.
239 // bChecked - TRUE if the control is checked.
240 // bPopuped - TRUE if the control is pop-up'ed.
241 // barType - Parent's bar type.
242 // barPosition - Parent's bar position.
243 // nID - Bar's control ID.
244 //-----------------------------------------------------------------------
245 virtual void DrawRectangle(CDC* pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled,
246 BOOL bChecked, BOOL bPopuped, XTPBarType barType,
247 XTPBarPosition barPosition);
248
263 virtual void DrawRectangle(CDC* pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled,
264 BOOL bChecked, BOOL bPopuped, XTPBarType barType,
265 XTPBarPosition barPosition, int nID);
266
281 void DrawFrameBorder(CDC* pDC, CRect rc, int nBorderThickness, BOOL bSelected, BOOL bPressed,
282 BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType,
283 XTPBarPosition barPosition);
284
297 virtual void DrawPopupBarGripper(CDC* pDC, int xPos, int yPos, int cx, int cy,
298 BOOL bExpanded = FALSE);
299
309 virtual CSize DrawCommandBarGripper(CDC* pDC, CXTPCommandBar* pBar, BOOL bDraw = TRUE);
310
320 virtual CSize DrawControlComboBox(CDC* pDC, CXTPControlComboBox* pComboBox, BOOL bDraw);
321
322 virtual COLORREF GetGlyphColor(CXTPControl* pControl);
323
324 virtual COLORREF GetSeparatorColor(CXTPControl* pControl, BOOL bDark);
325
326 virtual void DrawControlPopupGlyph(CDC* pDC, CXTPControl* pButton);
327
339 virtual void DrawDropDownGlyph(CDC* pDC, CXTPControl* pControl, CPoint pt, BOOL bSelected,
340 BOOL bPopuped, BOOL bEnabled, BOOL bVert);
341
352 virtual CSize DrawCommandBarSeparator(CDC* pDC, CXTPCommandBar* pBar, CXTPControl* pControl,
353 BOOL bDraw = TRUE);
354
365 virtual void DrawExpandGlyph(CDC* pDC, CXTPControl* pButton, CPoint pt0, CPoint pt1, CPoint pt2,
366 COLORREF clr);
367
376 virtual void DrawHiddenGlyph(CDC* pDC, CXTPControl* pButton, COLORREF clr, BOOL bVertical);
377
386 virtual void DrawExpandGlyph(CDC* pDC, CXTPControl* pButton, COLORREF clr, BOOL bVertical);
387
388 virtual void DrawCheckMark(CDC* pDC, CRect rcCheck, BOOL bIsRadio, BOOL bEnabled,
389 BOOL bSelected);
390
401 virtual CSize DrawControlCheckBoxMark(CDC* pDC, CXTPControl* pButton, CRect rc, BOOL bDraw);
402
416 virtual CSize DrawControlCheckBoxMark(CDC* pDC, CRect rc, BOOL bDraw, BOOL bSelected,
417 BOOL bPressed, BOOL bChecked, BOOL bEnabled);
418
432 virtual CSize DrawControlRadioButtonMark(CDC* pDC, CRect rc, BOOL bDraw, BOOL bSelected,
433 BOOL bPressed, BOOL bChecked, BOOL bEnabled);
434
442 virtual void DrawSplitButtonFrame(CDC* pDC, CXTPControl* pButton, CRect rc);
443
444 CXTPColorSetStateButton* GetButtonColorSet(XTPBarType barType, BOOL bTextColor = FALSE);
445
446 virtual void GetCheckMarkColors(COLORREF& clrMark, COLORREF& clrBack, COLORREF& clrBorder,
447 BOOL bSelected, BOOL bPressed, BOOL bEnabled);
448
455 virtual void DrawControlMDIButton(CDC* pDC, CXTPControlButton* pButton);
456
457 virtual void DrawDashedLine(CDC* pDC, int x, int y, int z, COLORREF clr, BOOL bHorzBar);
458
459 BOOL m_bIntersect;
460 CXTPColorSetStateMenu m_csMenu;
461 CXTPColorSetStateMenuTitleBar m_csMenuTitleBar;
462 CXTPColorSetStateRibbon m_csRibbon;
463 CXTPColorSetStateToolbar m_csToolbar;
464 CXTPColorSetStateCheckMark m_csCheckMark;
465 CXTPColorSetStateComboBox m_csComboBox;
466 CXTPColorSetStateCheckBox m_csCheckBox;
468 CXTPPaintManagerColor m_clrBack;
469 CXTPPaintManagerColor m_clrGlyph;
470 CXTPPaintManagerColor m_clrGlyphHighlight;
471 CXTPPaintManagerColor m_clrGlyphPushed;
472 CXTPPaintManagerColor m_clrGlyphDisabled;
473 CXTPPaintManagerColor m_clrMessageBarText;
474 CXTPPaintManagerColor m_clrBtnFace;
475 CXTPPaintManagerColor m_clr3DShadow;
476 CXTPPaintManagerColor m_clrHighlight;
477 CXTPPaintManagerColor m_clrCaptionButtonFill;
478 CXTPPaintManagerColorGradient m_clrWorkspace;
480 COLORREF m_clrQuickAccess;
481 COLORREF m_clrQuickAccessDisabled;
482 COLORREF m_clrQuickAccessButtonHotBack;
483 COLORREF m_clrQuickAccessButtonPressedBack;
484};
485
486_XTP_EXT_CLASS BOOL AFX_CDECL XTPSetOfficeSetBackImage(CXTPCommandBars* pCommandBars,
487 XTPBackImage nBackImage = XTPNone);
488
490
491AFX_INLINE XTPPaintTheme CXTPCommandBarsOffice2013Theme::BaseTheme()
492{
493 return xtpThemeOffice2013;
494}
495AFX_INLINE BOOL CXTPCommandBarsOffice2013Theme::RequiresResourceImages()
496{
497 return TRUE;
498}
499
501# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
502#endif // !defined(__XTPCOMMANDBARSOFFICE2013THEME_H__)
XTPBarType
XTPBarType
Type of the command bar.
Definition XTPCommandBarsDefines.h:77
XTPBarPosition
XTPBarPosition
Position of the command bar.
Definition XTPCommandBarsDefines.h:52
XTPPaintTheme
XTPPaintTheme
Paint themes used by command bars.
Definition XTPCommandBarsDefines.h:233
xtpThemeOffice2013
@ xtpThemeOffice2013
Office 2013 theme.
Definition XTPCommandBarsDefines.h:247
XTPBackImage
XTPBackImage
Defines a back image.
Definition XTPCommandBarsOffice2013Theme.h:37
XTPDoodleCircles
@ XTPDoodleCircles
Specifies doodle circles back image.
Definition XTPCommandBarsOffice2013Theme.h:43
XTPUnderWater
@ XTPUnderWater
Specifies underwater back image.
Definition XTPCommandBarsOffice2013Theme.h:52
XTPStars
@ XTPStars
Specifies stars back image.
Definition XTPCommandBarsOffice2013Theme.h:49
XTPDoodleDiamonds
@ XTPDoodleDiamonds
Specifies doodle diamonds back image.
Definition XTPCommandBarsOffice2013Theme.h:44
XTPNone
@ XTPNone
Specifies no back image.
Definition XTPCommandBarsOffice2013Theme.h:38
XTPCircuit
@ XTPCircuit
Specifies circuit back image.
Definition XTPCommandBarsOffice2013Theme.h:41
XTPLunchBox
@ XTPLunchBox
Specifies lunch box back image.
Definition XTPCommandBarsOffice2013Theme.h:46
XTPSchoolSupplies
@ XTPSchoolSupplies
Specifies school supplies back image.
Definition XTPCommandBarsOffice2013Theme.h:47
XTPStraws
@ XTPStraws
Specifies straws back image.
Definition XTPCommandBarsOffice2013Theme.h:50
XTPSpring
@ XTPSpring
Specifies sptring back image.
Definition XTPCommandBarsOffice2013Theme.h:48
XTPCirclesAndStripes
@ XTPCirclesAndStripes
Specifies circle and stipes back image.
Definition XTPCommandBarsOffice2013Theme.h:40
XTPClouds
@ XTPClouds
Specifies cluds back image.
Definition XTPCommandBarsOffice2013Theme.h:42
XTPGeometry
@ XTPGeometry
Specifies geometry back image.
Definition XTPCommandBarsOffice2013Theme.h:45
XTPTreeRings
@ XTPTreeRings
Specifies tree rings back image.
Definition XTPCommandBarsOffice2013Theme.h:51
XTPCalligraphy
@ XTPCalligraphy
Specifies caligraphy back image.
Definition XTPCommandBarsOffice2013Theme.h:39
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPColorSetStateButton
Base class used to define various state colors used by command bar buttons text, background and borde...
Definition XTPCommandBarsColorSetOffice2013.h:38
CXTPColorSetStateCheckBox
Helper class used to define various state colors used by check box and radio button controls.
Definition XTPCommandBarsColorSetOffice2013.h:266
CXTPColorSetStateCheckMark
Helper class used to define various state colors used by command bar check marks foreground and backg...
Definition XTPCommandBarsColorSetOffice2013.h:174
CXTPColorSetStateComboBox
Helper class used to define various state colors used by command bar glyphs.
Definition XTPCommandBarsColorSetOffice2013.h:208
CXTPColorSetStateMenu
Color set class used to define various state colors used by command bar menus.
Definition XTPCommandBarsColorSetOffice2013.h:77
CXTPColorSetStateMenuTitleBar
Color set class used to define various state colors used by command bar menu title bars.
Definition XTPCommandBarsColorSetOffice2013.h:101
CXTPColorSetStateRibbon
Color set class used to define various state colors used by command bar ribbon.
Definition XTPCommandBarsColorSetOffice2013.h:123
CXTPColorSetStateToolbar
Color set class used to define various state colors used by command bar toolbars.
Definition XTPCommandBarsColorSetOffice2013.h:144
CXTPCommandBar
CXTPCommandBar is a CWnd derived class.
Definition XTPCommandBar.h:66
CXTPCommandBars
CXTPCommandBars is a standalone class.
Definition XTPCommandBars.h:165
CXTPCommandBarsModernUITheme
The CXTPCommandBarsModernUITheme class is the base class for the Modern UI themes for Command Bars.
Definition XTPCommandBarsModernUITheme.h:41
CXTPCommandBarsOffice2013Theme
The CXTPCommandBarsOffice2013Theme class is used to enable an Office 2013 style theme for Command Bar...
Definition XTPCommandBarsOffice2013Theme.h:63
CXTPCommandBarsOffice2013Theme::m_csCheckMark
CXTPColorSetStateCheckMark m_csCheckMark
State colors used by Menu Check Marks.
Definition XTPCommandBarsOffice2013Theme.h:464
CXTPCommandBarsOffice2013Theme::DrawCommandBarGroupSeparator
virtual void DrawCommandBarGroupSeparator(CDC *pDC, CXTPCommandBar *pBar, CXTPControl *pLeftControl, CXTPControl *pRightControl, BOOL bDraw)
This method is called to draw a command bar's group separator.
CXTPCommandBarsOffice2013Theme::BaseTheme
virtual XTPPaintTheme BaseTheme()
Retrieves the base theme of the manager.
Definition XTPCommandBarsOffice2013Theme.h:491
CXTPCommandBarsOffice2013Theme::RequiresResourceImages
virtual BOOL RequiresResourceImages()
Used by the paint manager to determine if the theme requires a resource DLL to load image and color i...
Definition XTPCommandBarsOffice2013Theme.h:495
CXTPCommandBarsOffice2013Theme::m_clrGlyph
CXTPPaintManagerColor m_clrGlyph
Glyph Normal color.
Definition XTPCommandBarsOffice2013Theme.h:469
CXTPCommandBarsOffice2013Theme::DrawControlRadioButtonMark
virtual CSize DrawControlRadioButtonMark(CDC *pDC, CRect rc, BOOL bDraw, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled)
This method is called to draw a radio button mark area.
CXTPCommandBarsOffice2013Theme::DrawCommandBarGripper
virtual CSize DrawCommandBarGripper(CDC *pDC, CXTPCommandBar *pBar, BOOL bDraw=TRUE)
This method is called to draw the command bar's gripper.
CXTPCommandBarsOffice2013Theme::DrawExpandGlyph
virtual void DrawExpandGlyph(CDC *pDC, CXTPControl *pButton, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clr)
Draw expand or hidden glyphs for a button.
CXTPCommandBarsOffice2013Theme::CXTPCommandBarsOffice2013Theme
CXTPCommandBarsOffice2013Theme()
Constructs a CXTPCommandBarsOffice2013Theme object.
CXTPCommandBarsOffice2013Theme::FillWorkspace
virtual void FillWorkspace(CDC *pDC, CRect rc, CRect rcExclude)
Draws workspace space.
CXTPCommandBarsOffice2013Theme::DrawControlComboBox
virtual CSize DrawControlComboBox(CDC *pDC, CXTPControlComboBox *pComboBox, BOOL bDraw)
This method is called to draw the control.
CXTPCommandBarsOffice2013Theme::m_csCheckBox
CXTPColorSetStateCheckBox m_csCheckBox
State colors used by Check Box and Radio Button controls.
Definition XTPCommandBarsOffice2013Theme.h:466
CXTPCommandBarsOffice2013Theme::DrawSplitButtonFrame
virtual void DrawSplitButtonFrame(CDC *pDC, CXTPControl *pButton, CRect rc)
This method is called to draw the frame for the SplitButton control.
CXTPCommandBarsOffice2013Theme::m_clrGlyphDisabled
CXTPPaintManagerColor m_clrGlyphDisabled
Glyph Disabled color.
Definition XTPCommandBarsOffice2013Theme.h:472
CXTPCommandBarsOffice2013Theme::DrawGalleryItemBack
virtual void DrawGalleryItemBack(CDC *pDC, CRect rcItem, BOOL bEnabled, BOOL bSelected, BOOL bPressed, BOOL bChecked, XTPBarType barType)
This method is called to draw the background for a gallery menu item.
CXTPCommandBarsOffice2013Theme::GetControlEditBackColor
virtual COLORREF GetControlEditBackColor(CXTPControl *pControl)
This method returns the edit control back color to draw.
CXTPCommandBarsOffice2013Theme::DrawExpandGlyph
virtual void DrawExpandGlyph(CDC *pDC, CXTPControl *pButton, COLORREF clr, BOOL bVertical)
Draw expand or hidden glyphs for a button.
CXTPCommandBarsOffice2013Theme::GetRectangleTextColor
virtual COLORREF GetRectangleTextColor(BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition)
This method retrieves a buttons text color.
CXTPCommandBarsOffice2013Theme::m_clrMessageBarText
CXTPPaintManagerColor m_clrMessageBarText
Message bar text color.
Definition XTPCommandBarsOffice2013Theme.h:473
CXTPCommandBarsOffice2013Theme::m_csToolbar
CXTPColorSetStateToolbar m_csToolbar
State colors used by Toolbar buttons.
Definition XTPCommandBarsOffice2013Theme.h:463
CXTPCommandBarsOffice2013Theme::DrawRectangle
virtual BOOL DrawRectangle(CDC *pDC, CXTPControl *pButton)
This method is called to fill the control's face.
CXTPCommandBarsOffice2013Theme::m_clrGlyphHighlight
CXTPPaintManagerColor m_clrGlyphHighlight
Glyph Highlight color.
Definition XTPCommandBarsOffice2013Theme.h:470
CXTPCommandBarsOffice2013Theme::m_csMenuTitleBar
CXTPColorSetStateMenuTitleBar m_csMenuTitleBar
State colors used by MenuTitleBar items.
Definition XTPCommandBarsOffice2013Theme.h:461
CXTPCommandBarsOffice2013Theme::DrawHiddenGlyph
virtual void DrawHiddenGlyph(CDC *pDC, CXTPControl *pButton, COLORREF clr, BOOL bVertical)
Draw expand or hidden glyphs for a button.
CXTPCommandBarsOffice2013Theme::m_clr3DShadow
CXTPPaintManagerColor m_clr3DShadow
Button shadow color.
Definition XTPCommandBarsOffice2013Theme.h:475
CXTPCommandBarsOffice2013Theme::m_csRibbon
CXTPColorSetStateRibbon m_csRibbon
State colors used by Ribbon group buttons.
Definition XTPCommandBarsOffice2013Theme.h:462
CXTPCommandBarsOffice2013Theme::GetControlBackColor
virtual COLORREF GetControlBackColor(CXTPControl *pButton)
Call this method to get the control back color to draw.
CXTPCommandBarsOffice2013Theme::RefreshStandardColors
virtual void RefreshStandardColors()
Called to update the standard colors used by the framework.
CXTPCommandBarsOffice2013Theme::DrawControlEdit
virtual CSize DrawControlEdit(CDC *pDC, CXTPControlEdit *pEdit, BOOL bDraw)
This method is called to draw the control.
CXTPCommandBarsOffice2013Theme::m_clrCaptionButtonFill
CXTPPaintManagerColor m_clrCaptionButtonFill
Text color for frame caption buttons.
Definition XTPCommandBarsOffice2013Theme.h:477
CXTPCommandBarsOffice2013Theme::m_clrBtnFace
CXTPPaintManagerColor m_clrBtnFace
Button background color.
Definition XTPCommandBarsOffice2013Theme.h:474
CXTPCommandBarsOffice2013Theme::DrawPopupBarGripper
virtual void DrawPopupBarGripper(CDC *pDC, int xPos, int yPos, int cx, int cy, BOOL bExpanded=FALSE)
This method is called to draw a pop-up bar's right gripper.
CXTPCommandBarsOffice2013Theme::FillCommandBarEntry
virtual void FillCommandBarEntry(CDC *pDC, CXTPCommandBar *pBar)
This method is called to fill the command bar's face.
CXTPCommandBarsOffice2013Theme::GetControlTextColor
virtual COLORREF GetControlTextColor(CXTPControl *pButton)
This method retrieves a buttons text color.
CXTPCommandBarsOffice2013Theme::m_bIntersect
BOOL m_bIntersect
TRUE to draw pop-up bar intersect rectangle.
Definition XTPCommandBarsOffice2013Theme.h:459
CXTPCommandBarsOffice2013Theme::DrawControlCheckBoxMark
virtual CSize DrawControlCheckBoxMark(CDC *pDC, CRect rc, BOOL bDraw, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled)
This method is called to draw a check box mark area.
CXTPCommandBarsOffice2013Theme::DrawDropDownGlyph
virtual void DrawDropDownGlyph(CDC *pDC, CXTPControl *pControl, CPoint pt, BOOL bSelected, BOOL bPopuped, BOOL bEnabled, BOOL bVert)
This member function is called to draw a split button expand symbol.
CXTPCommandBarsOffice2013Theme::m_csComboBox
CXTPColorSetStateComboBox m_csComboBox
State colors used by ComboBox control.
Definition XTPCommandBarsOffice2013Theme.h:465
CXTPCommandBarsOffice2013Theme::m_clrGlyphPushed
CXTPPaintManagerColor m_clrGlyphPushed
Glyph Pushed color.
Definition XTPCommandBarsOffice2013Theme.h:471
CXTPCommandBarsOffice2013Theme::m_csMenu
CXTPColorSetStateMenu m_csMenu
State colors used by Menu items.
Definition XTPCommandBarsOffice2013Theme.h:460
CXTPCommandBarsOffice2013Theme::m_clrWorkspace
CXTPPaintManagerColorGradient m_clrWorkspace
Workspace area gradient color.
Definition XTPCommandBarsOffice2013Theme.h:478
CXTPCommandBarsOffice2013Theme::~CXTPCommandBarsOffice2013Theme
virtual ~CXTPCommandBarsOffice2013Theme()
Destroys a CXTPCommandBarsOffice2013Theme object, handles cleanup and deallocation.
CXTPCommandBarsOffice2013Theme::m_clrHighlight
CXTPPaintManagerColor m_clrHighlight
Button highlight color.
Definition XTPCommandBarsOffice2013Theme.h:476
CXTPCommandBarsOffice2013Theme::RefreshMetrics
virtual void RefreshMetrics()
This method is called to refresh the visual metrics of the manager.
CXTPCommandBarsOffice2013Theme::DrawFrameBorder
void DrawFrameBorder(CDC *pDC, CRect rc, int nBorderThickness, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition)
This method is called to fill the border of the control's face.
CXTPCommandBarsOffice2013Theme::DrawRectangle
virtual void DrawRectangle(CDC *pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition)
This method is called to fill the control's face.
CXTPCommandBarsOffice2013Theme::DrawRectangle
virtual void DrawRectangle(CDC *pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition, int nID)
This method is called to fill the control's face.
CXTPCommandBarsOffice2013Theme::DrawCommandBarSeparator
virtual CSize DrawCommandBarSeparator(CDC *pDC, CXTPCommandBar *pBar, CXTPControl *pControl, BOOL bDraw=TRUE)
This method is called to draw a command bar's separator.
CXTPCommandBarsOffice2013Theme::DrawControlCheckBoxMark
virtual CSize DrawControlCheckBoxMark(CDC *pDC, CXTPControl *pButton, CRect rc, BOOL bDraw)
This method is called to draw a check box mark area.
CXTPCommandBarsOffice2013Theme::DrawControlMDIButton
virtual void DrawControlMDIButton(CDC *pDC, CXTPControlButton *pButton)
Call this member function to draw Menu MDI buttons.
CXTPCommandBarsOffice2013Theme::FillDockBar
virtual void FillDockBar(CDC *pDC, CXTPDockBar *pBar)
This method is called to fill a dock bar.
CXTPCommandBarsOffice2013Theme::m_clrBack
CXTPPaintManagerColor m_clrBack
CommandBars background color;.
Definition XTPCommandBarsOffice2013Theme.h:468
CXTPCommandBarsOfficeXPTheme::BaseTheme
virtual XTPPaintTheme BaseTheme()
Retrieves the base theme of the manager.
Definition XTPCommandBarsOfficeXPTheme.h:283
CXTPControlButton
CXTPControlButton is a CXTPControl derived class.
Definition XTPControlButton.h:39
CXTPControlComboBox
CXTPControlComboBox is a CXTPControl derived class.
Definition XTPControlComboBox.h:381
CXTPControlEdit
CXTPControlEdit is a CXTPControl derived class.
Definition XTPControlEdit.h:274
CXTPControl
CXTPControl is a CXTPCmdTarget derived class.
Definition XTPControl.h:841
CXTPDockBar
CXTPDockBar is a CWnd derived class.
Definition XTPDockBar.h:42
CXTPPaintManagerColorGradient
The CXTPPaintManagerColorGradient class is used to manage COLORREF values for determining light and d...
Definition XTPColorManager.h:301
CXTPPaintManagerColor
The CXTPPaintManagerColor class is used to manage COLORREF values for determining default and applica...
Definition XTPColorManager.h:117
CXTPPaintManager::RequiresResourceImages
virtual BOOL RequiresResourceImages()
Used by the paint manager to determine if the theme requires a resource DLL to load image and color i...
Definition XTPPaintManager.h:1842


Toolkit Pro: Member List

CXTPMarkupDefinitionCollection Member List

This is the complete list of members for CXTPMarkupDefinitionCollection, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPMarkupDefinitionCollection() | CXTPMarkupDefinitionCollection |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetItem(int nIndex) const | CXTPMarkupDefinitionCollection |


Toolkit Pro: Member List

CXTPControlActions Member List

This is the complete list of members for CXTPControlActions, including all inherited members.

Add(int nId) | CXTPControlActions |
Add(int nId, CXTPControlAction *pAction) | CXTPControlActions |
CreateFromMenu(CMenu *pMenu) | CXTPControlActions |
CXTPCmdTarget() | CXTPCmdTarget |
CXTPControlActions(CXTPCommandBars *pCommandBars) | CXTPControlActions | protected
DoPropExchange(CXTPPropExchange *pPX) | CXTPControlActions |
FindAction(int nId) const | CXTPControlActions |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAt(int nIndex) const | CXTPControlActions |
GetCount() const | CXTPControlActions |
Insert(CXTPControlAction *pAction) | CXTPControlActions | protected
m_arrActions | CXTPControlActions | protected
m_pCommandBars | CXTPControlActions | protected
Remove(int nId) | CXTPControlActions |
RemoveAll() | CXTPControlActions |
SetActionId(CXTPControlAction *pAction, int nId) | CXTPControlActions | protected
~CXTPControlActions() | CXTPControlActions | protected


Toolkit Pro: Member List

CXTPDockingPaneColorSet2017 Member List

This is the complete list of members for CXTPDockingPaneColorSet2017, including all inherited members.

GetButtonColorSet(CXTPDockingPaneCaptionButton *pButton) | CXTPDockingPaneColorSet | virtual
m_clrBackground | CXTPDockingPaneColorSet |
m_clrBorder | CXTPDockingPaneColorSet |
m_clrCaption | CXTPDockingPaneColorSet |
m_clrGripper | CXTPDockingPaneColorSet |
m_clrSplitter | CXTPDockingPaneColorSet |
m_clrText | CXTPDockingPaneColorSet |
m_csCaptionButtonHot | CXTPDockingPaneColorSet | protected
m_csCaptionButtonNormal | CXTPDockingPaneColorSet | protected
m_csCaptionButtonPressed | CXTPDockingPaneColorSet | protected
RefreshMetrics(CString strSection) | CXTPDockingPaneColorSet2017 | virtual
~CXTPDockingPaneColorSet() | CXTPDockingPaneColorSet | virtual


Toolkit Pro: XTPButtonThemeNativeWindows11.h Source File

  • Source
  • Controls
  • Button
  • Themes
XTPButtonThemeNativeWindows11.h
Go to the documentation of this file.
1
23#if !defined(__XTPBUTTONTHEMENATIVEWINDOWS11_H__)
24# define __XTPBUTTONTHEMENATIVEWINDOWS11_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPButtonThemeNativeWindows11 : public CXTPButtonThemeOffice2013
39{
40public:
45 CXTPButtonThemeNativeWindows11();
46
53 virtual void RefreshMetrics(CXTPButton* pButton);
54};
55
56# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
58#endif //#if !defined(__XTPBUTTONTHEMENATIVEWINDOWS11_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPButton
Push Button control.
Definition XTPButton.h:109
CXTPButtonThemeNativeWindows11
CXTPButtonThemeNativeWindows11 is a class used to perform Visual Studio 2015 theme drawing tasks.
Definition XTPButtonThemeNativeWindows11.h:39
CXTPButtonThemeNativeWindows11::CXTPButtonThemeNativeWindows11
CXTPButtonThemeNativeWindows11()
Constructs a CXTPButtonThemeNativeWindows11 object.
CXTPButtonThemeNativeWindows11::RefreshMetrics
virtual void RefreshMetrics(CXTPButton *pButton)
This member function is called by the theme manager to refresh the visual styles used by each compone...
CXTPButtonThemeOffice2013
CXTPButtonThemeOffice2013 is a class used to perform Office 2013 theme drawing tasks.
Definition XTPButtonThemeOffice2013.h:39


Toolkit Pro: XTPScrollBarThemeVisualStudio2012.h Source File

  • Source
  • Common
  • ScrollBar
  • Themes
XTPScrollBarThemeVisualStudio2012.h
Go to the documentation of this file.
1
23#if !defined(__XTPSCROLLBARTHEMEVISUALSTUDIO2012_H__)
24# define __XTPSCROLLBARTHEMEVISUALSTUDIO2012_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPScrollBarThemeVisualStudio2012 : public CXTPScrollBarPaintManager
39{
40protected:
47 virtual void DrawScrollBar(CDC* pDC, CXTPScrollBase* pScrollBar);
48
56 virtual void DrawBackground(CDC* pDC, CXTPScrollBase* pScroll, XTPScrollMetricsV* pMetrics);
57
65 virtual void DrawButtons(CDC* pDC, CXTPScrollBase* pScroll, XTPScrollMetricsV* pMetrics);
66
74 virtual void DrawArrows(CDC* pDC, CXTPScrollBase* pScroll, XTPScrollMetricsV* pMetrics);
75
83 virtual void DrawThumbButton(CDC* pDC, CXTPScrollBase* pScroll, XTPScrollMetricsV* pMetrics);
84
92 virtual void DrawBackground(CDC* pDC, CXTPScrollBase* pScroll, XTPScrollMetricsH* pMetrics);
93
101 virtual void DrawButtons(CDC* pDC, CXTPScrollBase* pScroll, XTPScrollMetricsH* pMetrics);
102
110 virtual void DrawArrows(CDC* pDC, CXTPScrollBase* pScroll, XTPScrollMetricsH* pMetrics);
111
119 virtual void DrawThumbButton(CDC* pDC, CXTPScrollBase* pScroll, XTPScrollMetricsH* pMetrics);
120
127 virtual void DrawGripper(CDC* pDC, CXTPScrollBase* pScroll);
128
129 struct DRAWING_STATE
130 {
131 BOOL nPressedHt;
132 BOOL nHotHt;
133 BOOL bEnabled;
134 int nBtnTrackSize;
135 int nBtnTrackPos;
136 COLORREF clrBackground;
137 COLORREF clrArrowDisabled;
138 COLORREF clrArrowEnabled;
139 COLORREF clrArrowHot;
140 COLORREF clrArrowPressed;
141 COLORREF clrBtnTrackEnabled;
142 COLORREF clrBtnTrackHot;
143 COLORREF clrBtnTrackPressed;
144 };
145
146 DRAWING_STATE m_State;
147};
148
149# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
151#endif /*__XTPSCROLLBARTHEMEVISUALSTUDIO2012_H__*/
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPScrollBarPaintManager
CXTPScrollBarPaintManager is standalone class used to draw CXTPCommandBarScrollBarCtrl object.
Definition XTPScrollBarPaintManager.h:40
CXTPScrollBarThemeVisualStudio2012
Scrollbar paint manager used to draw Visual Studio 2012 like scrollbars.
Definition XTPScrollBarThemeVisualStudio2012.h:39
CXTPScrollBarThemeVisualStudio2012::DrawBackground
virtual void DrawBackground(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws verical scrollbar background only.
CXTPScrollBarThemeVisualStudio2012::DrawButtons
virtual void DrawButtons(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar buttons only.
CXTPScrollBarThemeVisualStudio2012::DrawArrows
virtual void DrawArrows(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar button arrows only.
CXTPScrollBarThemeVisualStudio2012::DrawGripper
virtual void DrawGripper(CDC *pDC, CXTPScrollBase *pScroll)
Draws scrollbar gripper only.
CXTPScrollBarThemeVisualStudio2012::DrawButtons
virtual void DrawButtons(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws vertical scrollbar buttons only.
CXTPScrollBarThemeVisualStudio2012::DrawBackground
virtual void DrawBackground(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar background only.
CXTPScrollBarThemeVisualStudio2012::DrawArrows
virtual void DrawArrows(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws vertical scrollbar button arrows only.
CXTPScrollBarThemeVisualStudio2012::DrawScrollBar
virtual void DrawScrollBar(CDC *pDC, CXTPScrollBase *pScrollBar)
This method is called to draw all scrollbar parts.
CXTPScrollBarThemeVisualStudio2012::DrawThumbButton
virtual void DrawThumbButton(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar thumb button only.
CXTPScrollBarThemeVisualStudio2012::DrawThumbButton
virtual void DrawThumbButton(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws vertical scrollbar thumb button only.
CXTPScrollBase
CXTPScrollBase is the base class for all scrollable objects.
Definition XTPScrollBase.h:222


Toolkit Pro: XTPMarkupKeyboardNavigation.h Source File

  • Source
  • Markup
XTPMarkupKeyboardNavigation.h
Go to the documentation of this file.
1
23#if !defined(__XTPMMARKUPKEYBOARDNAVIGATION_H__)
24# define __XTPMMARKUPKEYBOARDNAVIGATION_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPMarkupInputElement;
34class CXTPMarkupContext;
35
36enum XTPMarkupFocusNavigationDirection
37{
38 xtpMarkupFocusNavigationDirectionNext,
39 xtpMarkupFocusNavigationDirectionPrevious,
40 xtpMarkupFocusNavigationDirectionFirst,
41 xtpMarkupFocusNavigationDirectionLast,
42 xtpMarkupFocusNavigationDirectionLeft,
43 xtpMarkupFocusNavigationDirectionRight,
44 xtpMarkupFocusNavigationDirectionUp,
45 xtpMarkupFocusNavigationDirectionDown
46};
47
48enum XTPMarkupKeyboardNavigationMode
49{
50 xtpMarkupKeyboardNavigationContinue,
51 xtpMarkupKeyboardNavigationOnce,
52 xtpMarkupKeyboardNavigationCycle,
53 xtpMarkupKeyboardNavigationNone,
54 xtpMarkupKeyboardNavigationContained,
55 xtpMarkupKeyboardNavigationLocal
56};
57
58class _XTP_EXT_CLASS CXTPMarkupKeyboardNavigation : public CXTPMarkupObject
59{
61 DECLARE_MARKUPCLASS(CXTPMarkupKeyboardNavigation)
63protected:
64 CXTPMarkupKeyboardNavigation(CXTPMarkupContext* pContext = NULL);
65 virtual ~CXTPMarkupKeyboardNavigation();
66
67public:
68 static XTPMarkupKeyboardNavigationMode AFX_CDECL GetTabNavigation(CXTPMarkupObject* pElement);
69
70public:
71 static CXTPMarkupObject* AFX_CDECL
72 ConvertKeyboardNavigationMode(CXTPMarkupBuilder* pBuilder, CXTPMarkupObject* pObject,
73 CXTPMarkupDependencyProperty* pAssociatedProperty = NULL);
74
75public:
76 void ProcessInput(UINT nChar);
77 void Focus(CXTPMarkupInputElement* pInputElement);
78
79protected:
80 BOOL OnWndMsg(UINT message, WPARAM wParam, LPARAM lParam, LRESULT* pResult);
81
82protected:
83 void Navigate(CXTPMarkupInputElement* pSourceElement, UINT nChar);
84 void Navigate(CXTPMarkupInputElement* pSourceElement,
85 XTPMarkupFocusNavigationDirection direction);
86
87private:
88 CXTPMarkupObject* GetGroupParent(CXTPMarkupObject* e, BOOL bIncludeCurrent = FALSE);
89 CXTPMarkupObject* GetParent(CXTPMarkupObject* e);
90 BOOL IsInNavigationTree(CXTPMarkupObject* pVisual);
91 XTPMarkupKeyboardNavigationMode GetKeyNavigationMode(CXTPMarkupObject* pElement);
92 BOOL IsGroup(CXTPMarkupObject* e);
93 CXTPMarkupObject* GetNextTab(CXTPMarkupObject* e, CXTPMarkupObject* pContainer,
94 BOOL goDownOnly);
95 BOOL IsTabStop(CXTPMarkupObject* e);
96 CXTPMarkupObject* GetTabOnceActiveElement(CXTPMarkupObject* d);
97 CXTPMarkupObject* GetActiveElement(CXTPMarkupObject* d);
98 CXTPMarkupObject* GetNextTabInGroup(CXTPMarkupObject* e, CXTPMarkupObject* container,
99 XTPMarkupKeyboardNavigationMode tabbingType);
100 CXTPMarkupObject* GetFirstTabInGroup(CXTPMarkupObject* container);
101 BOOL IsTabStopOrGroup(CXTPMarkupObject* e);
102 CXTPMarkupObject* GetNextInTree(CXTPMarkupObject* e, CXTPMarkupObject* container);
103 CXTPMarkupObject* GetNextTabWithSameIndex(CXTPMarkupObject* e, CXTPMarkupObject* container);
104 CXTPMarkupObject* GetNextTabWithNextIndex(CXTPMarkupObject* e, CXTPMarkupObject* container,
105 XTPMarkupKeyboardNavigationMode tabbingType);
106 int GetTabIndexHelper(CXTPMarkupObject* d);
107 CXTPMarkupObject* FocusedElement(CXTPMarkupObject* e);
108
109 CXTPMarkupObject* GetTreeFirstChild(CXTPMarkupObject* e);
110 CXTPMarkupObject* GetTreeNextSibling(CXTPMarkupObject* e);
111
112public:
113 static CXTPMarkupDependencyProperty* m_pIsTabStopProperty;
114 static CXTPMarkupDependencyProperty* m_pTabNavigationProperty;
115 static CXTPMarkupDependencyProperty* m_pTabIndexProperty;
116
117protected:
118 CXTPMarkupInputElement* m_pFocused;
119 CXTPMarkupInputElement* m_pLastFocused;
120 CXTPMarkupContext* m_pMarkupContext;
121 CXTPMarkupDependencyProperty* m_pNavigationProperty;
122
123private:
124 friend class CXTPMarkupContext;
125};
126
127# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
129#endif // !defined(__XTPMMARKUPKEYBOARDNAVIGATION_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPMarkupContext
CXTPMarkupContext is a standalone class used to provide common settings for Markup objects.
Definition XTPMarkupContext.h:128


Toolkit Pro: XTPGridRecords.h Source File

  • Source
  • GridControl
XTPGridRecords.h
Go to the documentation of this file.
1
23#if !defined(__XTPGRIDRECORDS_H__)
24# define __XTPGRIDRECORDS_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPGridRecord;
34class CXTPPropExchange;
35class CXTPMarkupContext;
36class CXTPGridRecordItem;
37class CXTPGridRecordItemRange;
38
51enum XTPGridTextSearchParms
52{
53 xtpGridTextSearchExactPhrase = 1,
54 xtpGridTextSearchMatchCase = 2,
55 xtpGridTextSearchBackward = 4,
56 xtpGridTextSearchExactStart = 8,
58};
59
70class _XTP_EXT_CLASS CXTPGridRecords : public CXTPHeapObjectT<CXTPCmdTarget, CXTPGridDataAllocator>
71{
72 DECLARE_DYNAMIC(CXTPGridRecords)
73
74 void _Init();
75 void _swapIndexes(int& A, int& B);
76 void _clampIndexes(int& nOrig, const int& nMin, const int& nMax);
77
78public:
93 CXTPGridRecords(BOOL bArray = FALSE);
94
101 CXTPGridRecords(CXTPGridRecord* pOwnerRecord);
102
107 virtual ~CXTPGridRecords();
108
116 CXTPGridRecord* GetOwnerRecord() const;
117
118public:
133 int GetCount() const;
134
146 CXTPGridRecord* GetAt(int nIndex) const;
147
172 CXTPGridRecord* Add(CXTPGridRecord* pRecord);
173
179 virtual void DoPropExchange(CXTPPropExchange* pPX);
180
193 void RemoveAll();
194
200 void RemoveAt(int nIndex);
201
210 int RemoveRecord(CXTPGridRecord* pRecord);
211
226 void InsertAt(int nIndex, CXTPGridRecord* pRecord);
227
234 void Move(int nIndex, CXTPGridRecords* pRecords);
235
243 void MoveRecord(int nIndex, CXTPGridRecord* pRecord, BOOL bUpdateIndexes = FALSE);
244
245public:
252 CXTPMarkupContext* GetMarkupContext() const;
253
259 void SetMarkupContext(CXTPMarkupContext* pMarkupContext);
260
261public:
270 void SetCaseSensitive(BOOL bCaseSensitive);
271
280 BOOL IsCaseSensitive() const;
281
294 virtual int Compare(const CString& str1, const CString& str2) const;
295
303 virtual void SetSize(INT_PTR nNewSize, INT_PTR nGrowBy = -1);
304
313 virtual void SetAt(INT_PTR nIndex, CXTPGridRecord* pRecord);
314
320 virtual void UpdateIndexes(int nStart = 0);
321
330 virtual CXTPGridRecord* FindRecordByBookmark(VARIANT vtBookmark, BOOL bSearchInChildren);
331
346 virtual CXTPGridRecordItem* FindRecordItem(int nStartRecord, int nEndRecord, int nStartColumn,
347 int nEndColumn, int nRecord, int nItem,
348 LPCTSTR pcszText, int nFlags);
349
350 void MergeItems(const CXTPGridRecordItemRange& range);
351
361 virtual void PrepareToDropping(CXTPGridRecord* pTargetRecord, CXTPGridRecords* pTargetRecords,
362 BOOL bChangeParent);
363
368 virtual void CleanOfRedundant();
369
370protected:
372 void SetVirtualMode(CXTPGridRecord* pVirtualRecord, int nCount);
373 BOOL IsVirtualMode() const;
374 virtual void _DoPropExchange(CXTPPropExchange* pPX);
377protected:
378 CArray<CXTPGridRecord*, CXTPGridRecord*> m_arrRecords;
380 CXTPGridRecord* m_pVirtualRecord; // Virtual record.
381 int m_nVirtualRecordsCount;
382 CXTPGridControl* m_pControl;
384 BOOL m_bArray;
387 BOOL m_bCaseSensitive;
389 CXTPGridRecord* m_pOwnerRecord;
391 CXTPMarkupContext* m_pMarkupContext;
393# ifdef _XTP_ACTIVEX
395 DECLARE_DISPATCH_MAP()
396 DECLARE_INTERFACE_MAP()
397
398 DECLARE_OLETYPELIB_EX(CXTPGridRecords);
399
400 afx_msg int OleGetItemCount();
401 afx_msg LPDISPATCH OleGetItem(long nIndex);
402 afx_msg LPDISPATCH OleAdd();
403
404 afx_msg LPDISPATCH OleInsert(int nIndex);
405 afx_msg void OleInsertAt(int nIndex, LPDISPATCH pdispRecord);
406
407 afx_msg LPDISPATCH OleFindRecordItem(int nStartRecord, int nEndRecord, int nStartColumn,
408 int nEndColumn, int nRecord, int nItem, LPCTSTR pcszText,
409 int nFlags);
410
411 afx_msg void OleMergeItems(int nRecordFrom, int nRecordTo, int nColumnFrom, int nColumnTo);
412
413 afx_msg void OleDoPropExchange(LPDISPATCH lpPropExchage);
414
415 DECLARE_ENUM_VARIANT(CXTPGridRecords)
416
417 enum
418 {
419 dispidCount = 1L,
420 dispidAdd = 2L,
421 dispidFindColumn = 4L,
422 };
423
425# endif
426
427 friend class CXTPGridControl;
428 friend class CXTPGridRecord;
429 friend class CXTPGridSection;
430};
432AFX_INLINE BOOL CXTPGridRecords::IsVirtualMode() const
433{
434 return m_pVirtualRecord != NULL;
435}
437AFX_INLINE void CXTPGridRecords::SetCaseSensitive(BOOL bCaseSensitive)
438{
439 m_bCaseSensitive = bCaseSensitive;
440}
441
442AFX_INLINE BOOL CXTPGridRecords::IsCaseSensitive() const
443{
444 return m_bCaseSensitive;
445}
446
447AFX_INLINE CXTPGridRecord* CXTPGridRecords::GetOwnerRecord() const
448{
449 return m_pOwnerRecord;
450}
451
452AFX_INLINE CXTPMarkupContext* CXTPGridRecords::GetMarkupContext() const
453{
454 return m_pMarkupContext;
455}
456
457AFX_INLINE void CXTPGridRecords::SetMarkupContext(CXTPMarkupContext* pMarkupContext)
458{
459 m_pMarkupContext = pMarkupContext;
460}
462# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
463#endif //#if !defined(__XTPGRIDRECORDS_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPGridTextSearchParms
XTPGridTextSearchParms
Enumeration of text search parameters.
Definition XTPGridRecords.h:52
xtpGridTextSearchExactPhrase
@ xtpGridTextSearchExactPhrase
Search exact phrase.
Definition XTPGridRecords.h:53
xtpGridTextSearchMatchCase
@ xtpGridTextSearchMatchCase
Match case during search.
Definition XTPGridRecords.h:54
xtpGridTextSearchBackward
@ xtpGridTextSearchBackward
Search backward.
Definition XTPGridRecords.h:55
xtpGridTextSearchExactStart
@ xtpGridTextSearchExactStart
Search phrase starting in the beginning of the item caption.
Definition XTPGridRecords.h:56
CXTPGridControl
The CXTPGridControl class provides an implementation of the Grid control.
Definition XTPGridControl.h:479
CXTPGridRecord
CXTPGridRecord represents a collection of CXTPGridRecordItem objects or objects of classes that are c...
Definition XTPGridRecord.h:59
CXTPGridRecordItem
Class for working with single list cell.
Definition XTPGridRecordItem.h:600
CXTPGridRecords
This class represents a grid records collection.
Definition XTPGridRecords.h:71
CXTPGridRecords::DoPropExchange
virtual void DoPropExchange(CXTPPropExchange *pPX)
Call this member function to store/load a grid records collection.
CXTPGridRecords::FindRecordItem
virtual CXTPGridRecordItem * FindRecordItem(int nStartRecord, int nEndRecord, int nStartColumn, int nEndColumn, int nRecord, int nItem, LPCTSTR pcszText, int nFlags)
Retrieves a record item by its text.
CXTPGridRecords::GetAt
CXTPGridRecord * GetAt(int nIndex) const
Gets the record element at a specified numeric index in this collection.
CXTPGridRecords::CXTPGridRecords
CXTPGridRecords(CXTPGridRecord *pOwnerRecord)
Constructs an empty CXTPGridRecord pointer array in case it is used as a member of a CXTPGridRecord o...
CXTPGridRecords::PrepareToDropping
virtual void PrepareToDropping(CXTPGridRecord *pTargetRecord, CXTPGridRecords *pTargetRecords, BOOL bChangeParent)
This method is called before record dropping is processed.
CXTPGridRecords::GetCount
int GetCount() const
Gets the number of record elements in this collection.
CXTPGridRecords::CleanOfRedundant
virtual void CleanOfRedundant()
Removes redundant records.
CXTPGridRecords::InsertAt
void InsertAt(int nIndex, CXTPGridRecord *pRecord)
Inserts a specified record at a specified index in this collection.
CXTPGridRecords::m_arrRecords
CArray< CXTPGridRecord *, CXTPGridRecord * > m_arrRecords
Internal storage array for record items.
Definition XTPGridRecords.h:378
CXTPGridRecords::Add
CXTPGridRecord * Add(CXTPGridRecord *pRecord)
Adds a new record element to the end of this collection.
CXTPGridRecords::m_nVirtualRecordsCount
int m_nVirtualRecordsCount
Virtual records count.
Definition XTPGridRecords.h:381
CXTPGridRecords::RemoveRecord
int RemoveRecord(CXTPGridRecord *pRecord)
Removes a specified record from this collection.
CXTPGridRecords::GetOwnerRecord
CXTPGridRecord * GetOwnerRecord() const
Obtains an associated owner record pointer.
Definition XTPGridRecords.h:447
CXTPGridRecords::Move
void Move(int nIndex, CXTPGridRecords *pRecords)
Moves specified records to a specified index in this collection.
CXTPGridRecords::UpdateIndexes
virtual void UpdateIndexes(int nStart=0)
Updates record element indices.
CXTPGridRecords::m_pControl
CXTPGridControl * m_pControl
Pointer to the parent Grid control.
Definition XTPGridRecords.h:382
CXTPGridRecords::GetMarkupContext
CXTPMarkupContext * GetMarkupContext() const
Gets the markup context.
Definition XTPGridRecords.h:452
CXTPGridRecords::m_pOwnerRecord
CXTPGridRecord * m_pOwnerRecord
Pointer to the owner record object (or NULL).
Definition XTPGridRecords.h:389
CXTPGridRecords::m_pMarkupContext
CXTPMarkupContext * m_pMarkupContext
Markup context;.
Definition XTPGridRecords.h:391
CXTPGridRecords::CXTPGridRecords
CXTPGridRecords(BOOL bArray=FALSE)
Constructs an empty CXTPGridRecord pointer array.
CXTPGridRecords::RemoveAll
void RemoveAll()
Removes all the elements from this collection.
CXTPGridRecords::Compare
virtual int Compare(const CString &str1, const CString &str2) const
Helper function to compare two strings.
CXTPGridRecords::SetCaseSensitive
void SetCaseSensitive(BOOL bCaseSensitive)
Specifies if string comparisons should be case-sensitive.
Definition XTPGridRecords.h:437
CXTPGridRecords::SetAt
virtual void SetAt(INT_PTR nIndex, CXTPGridRecord *pRecord)
Sets a specified record element to a specified index in this collection.
CXTPGridRecords::SetMarkupContext
void SetMarkupContext(CXTPMarkupContext *pMarkupContext)
Sets the markup context.
Definition XTPGridRecords.h:457
CXTPGridRecords::m_bCaseSensitive
BOOL m_bCaseSensitive
Indicates whether string comparisons are case-sensitive.
Definition XTPGridRecords.h:387
CXTPGridRecords::SetSize
virtual void SetSize(INT_PTR nNewSize, INT_PTR nGrowBy=-1)
Changes the size of this collection.
CXTPGridRecords::IsCaseSensitive
BOOL IsCaseSensitive() const
Determines if string comparisons are case-sensitive.
Definition XTPGridRecords.h:442
CXTPGridRecords::RemoveAt
void RemoveAt(int nIndex)
Removes a specified record from this collection by its index.
CXTPGridRecords::~CXTPGridRecords
virtual ~CXTPGridRecords()
Destroys a CXTPGridRecords object, handles cleanup and deallocation.
CXTPGridRecords::MoveRecord
void MoveRecord(int nIndex, CXTPGridRecord *pRecord, BOOL bUpdateIndexes=FALSE)
Moves a specified record to a specified index in this collection.
CXTPGridRecords::FindRecordByBookmark
virtual CXTPGridRecord * FindRecordByBookmark(VARIANT vtBookmark, BOOL bSearchInChildren)
Retrieves a record element by its bookmark.
CXTPGridSection
Represents a grid section.
Definition XTPGridSection.h:61
CXTPHeapObjectT
This template class used as a helper class to override new/delete operators and use custom heap alloc...
Definition XTPCustomHeap.h:335
CXTPMarkupContext
CXTPMarkupContext is a standalone class used to provide common settings for Markup objects.
Definition XTPMarkupContext.h:128
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72


Toolkit Pro: Member List

CXTPDirWatcher Member List

This is the complete list of members for CXTPDirWatcher, including all inherited members.

CXTPDirWatcher() | CXTPDirWatcher |
CXTPWinThread(int xtpComInit=xtpComInitAppDefault) | CXTPWinThread |
GetFolderData() | CXTPDirWatcher |
GetFolderData(LPCTSTR lpszFolderPath, XTP_TVITEMDATA &lpTVID) | CXTPDirWatcher |
GetFolderPath() const | CXTPDirWatcher |
IsPathValid(LPCTSTR lpszFolderPath) | CXTPDirWatcher |
m_bWatchSubtree | CXTPDirWatcher | protected
m_dwMonitorEvents | CXTPDirWatcher | protected
m_strFolderPath | CXTPDirWatcher | protected
m_tvid | CXTPDirWatcher | protected
MonitorNotifications() | CXTPDirWatcher | protected
RefreshFolder() | CXTPDirWatcher | protectedvirtual
RefreshTree() | CXTPDirWatcher | protectedvirtual
SetFolderData(CWnd *pMainWnd, XTP_TVITEMDATA *lpTVID) | CXTPDirWatcher |
SetFolderPath(CWnd *pMainWnd, LPCTSTR lpszFolderPath, BOOL bWatchSubtree=FALSE) | CXTPDirWatcher |
StopNotifications() | CXTPDirWatcher |
WaitPathChangedEvent() | CXTPDirWatcher | protected
~CXTPDirWatcher() | CXTPDirWatcher | protectedvirtual
~CXTPWinThread() | CXTPWinThread | virtual


Toolkit Pro: Member List

CXTPDockingPaneVisualStudio2017Theme Member List

This is the complete list of members for CXTPDockingPaneVisualStudio2017Theme, including all inherited members.

AdjustCaptionRect(const CXTPDockingPaneTabbedContainer *pPane, CRect &rc) | CXTPDockingPaneVisualStudio2012Theme | virtual
CXTPDockingPaneDefaultTheme::AdjustCaptionRect(const CXTPDockingPaneSidePanel *pPane, CRect &rc) | CXTPDockingPanePaintManager | virtual
AdjustClientRect(CXTPDockingPaneTabbedContainer *pPane, CRect &rc, BOOL bApply) | CXTPDockingPaneVisualStudio2012Theme | virtual
CXTPDockingPaneDefaultTheme::AdjustClientRect(CXTPDockingPaneSidePanel *pPane, CRect &rect) | CXTPDockingPanePaintManager | virtual
ClipAndAddEllipsisIfNeeded(CDC *pDC, CString &strTitle, int nCaptionWidth) const | CXTPDockingPanePaintManager | protected
CXTPCmdTarget() | CXTPCmdTarget |
CXTPDockingPaneDefaultTheme() | CXTPDockingPaneDefaultTheme |
CXTPDockingPanePaintManager() | CXTPDockingPanePaintManager | protected
CXTPDockingPaneVisualStudio2012Theme() | CXTPDockingPaneVisualStudio2012Theme |
CXTPDockingPaneVisualStudio2017Theme() | CXTPDockingPaneVisualStudio2017Theme |
DeletePaneColorSets() | CXTPDockingPaneVisualStudio2012Theme | protected
DrawAutoHidePanel(CDC *pDC, CRect rc, XTPDockingPaneDirection direction) | CXTPDockingPaneVisualStudio2017Theme | virtual
DrawCaption(CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc) | CXTPDockingPaneVisualStudio2012Theme | virtual
DrawCaptionButton(CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton) | CXTPDockingPaneVisualStudio2012Theme | virtual
DrawCaptionButtonEntry(CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton, CSize szOffset) | CXTPDockingPanePaintManager | protectedvirtual
DrawCaptionButtonEntry(CDC *pDC, CXTPDockingPaneCaptionButton *pButton, CPoint pt, COLORREF clrButton) | CXTPDockingPanePaintManager | protectedvirtual
DrawCaptionButtons(CDC *pDC, CXTPDockingPaneCaptionButtons *pButtons, CRect &rcCaption, COLORREF clr, int nButtonSize, int nButtonGap, BOOL bVertical=FALSE) | CXTPDockingPanePaintManager | virtual
DrawCaptionPart(CDC *pDC, CXTPDockingPaneBase *pPane, CRect rcCaption, const CString &strTitle, BOOL bActive, BOOL bVertical) | CXTPDockingPaneDefaultTheme | protectedvirtual
DrawCaptionText(CDC *pDC, const CString &strTitle, CRect rc, BOOL bVertical, BOOL bCalcWidth=FALSE) | CXTPDockingPanePaintManager |
DrawDottedLine(CDC *pDC, int x, int y, int nSize, COLORREF clr, BOOL bVertical) | CXTPDockingPaneVisualStudio2012Theme | protected
DrawFloatingFrame(CDC *pDC, CXTPDockingPaneMiniWnd *pPane, CRect rc) | CXTPDockingPaneVisualStudio2012Theme | virtual
DrawGripper(CDC *pDC, CRect rcGripper, COLORREF clr, BOOL bVertical) | CXTPDockingPaneVisualStudio2012Theme | protected
DrawPane(CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc) | CXTPDockingPaneVisualStudio2012Theme | virtual
DrawSidePanel(CDC *pDC, CXTPDockingPaneSidePanel *pPane, CRect rc) | CXTPDockingPaneVisualStudio2012Theme | virtual
DrawSplitter(CDC *pDC, CXTPDockingPaneSplitterWnd *pSplitter) | CXTPDockingPaneVisualStudio2017Theme | virtual
DrawTitleBar(CDC *pDC, CXTPDockingPaneBase *pPane, CRect rc, BOOL bVertical) | CXTPDockingPaneVisualStudio2017Theme | protectedvirtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCaptionButtonStyle() const | CXTPDockingPanePaintManager |
GetCaptionGripperRect(const CXTPDockingPaneTabbedContainer *pPane) | CXTPDockingPanePaintManager | virtual
GetCaptionHeight() const | CXTPDockingPanePaintManager |
GetCaptionRect(const CXTPDockingPaneTabbedContainer *pPane, CRect &rc) | CXTPDockingPanePaintManager | virtual
GetColorSet(BOOL bActive) | CXTPDockingPaneVisualStudio2012Theme | protectedvirtual
GetCurrentSystemTheme() const | CXTPDockingPanePaintManager |
GetCustomTitleBrush(BOOL bActive, BOOL bVertical) const | CXTPDockingPanePaintManager |
GetPaneCaptionRect(const CXTPDockingPaneSidePanel *pPane) | CXTPDockingPaneVisualStudio2012Theme | virtual
GetPanelPaintManager() const | CXTPDockingPanePaintManager |
GetSplitterStyle() const | CXTPDockingPanePaintManager |
GetTabPaintManager() const | CXTPDockingPanePaintManager |
GetTabsHeight() const | CXTPDockingPanePaintManager |
GetXtremeColor(UINT nIndex) | CXTPDockingPanePaintManager |
Line(CDC *pDC, int x0, int y0, int x1, int y1, int nPen) | CXTPDockingPanePaintManager |
Line(CDC *pDC, int x0, int y0, int x1, int y1) | CXTPDockingPanePaintManager |
m_arrColor | CXTPDockingPanePaintManager | protected
m_bDestroyCustomTitleBrushes | CXTPDockingPanePaintManager | protected
m_bDrawCaptionIcon | CXTPDockingPanePaintManager |
m_bDrawSingleTab | CXTPDockingPanePaintManager |
m_bHighlightActiveCaption | CXTPDockingPanePaintManager |
m_bLunaTheme | CXTPDockingPanePaintManager | protected
m_bShowCaption | CXTPDockingPanePaintManager |
m_bUseBoldCaptionFont | CXTPDockingPanePaintManager |
m_bUseOfficeFont | CXTPDockingPanePaintManager | protected
m_bUseStandardFont | CXTPDockingPanePaintManager | protected
m_clrActiveCaption | CXTPDockingPanePaintManager |
m_clrActiveCaptionText | CXTPDockingPanePaintManager |
m_clrBackground | CXTPDockingPanePaintManager |
m_clrCaptionBorder | CXTPDockingPaneVisualStudio2017Theme | protected
m_clrDisabledCaptionText | CXTPDockingPanePaintManager |
m_clrNormalCaption | CXTPDockingPanePaintManager |
m_clrNormalCaptionText | CXTPDockingPanePaintManager |
m_clrSplitter | CXTPDockingPanePaintManager |
m_clrSplitterGradient | CXTPDockingPanePaintManager |
m_clrSplitterGripper | CXTPDockingPanePaintManager |
m_dwSplitterStyle | CXTPDockingPanePaintManager | protected
m_hbrActiveTitleHorz | CXTPDockingPanePaintManager | protected
m_hbrActiveTitleVert | CXTPDockingPanePaintManager | protected
m_hbrInactiveTitleHorz | CXTPDockingPanePaintManager | protected
m_hbrInactiveTitleVert | CXTPDockingPanePaintManager | protected
m_nCaptionButtonStyle | CXTPDockingPanePaintManager | protected
m_nCaptionFontGap | CXTPDockingPanePaintManager | protected
m_nFontSize | CXTPDockingPaneVisualStudio2012Theme | protected
m_nSplitterIndent | CXTPDockingPanePaintManager |
m_nSplitterSize | CXTPDockingPanePaintManager |
m_nTabsHeight | CXTPDockingPanePaintManager | protected
m_nTitleHeight | CXTPDockingPanePaintManager | protected
m_pcsActive | CXTPDockingPaneVisualStudio2012Theme | protected
m_pcsInactive | CXTPDockingPaneVisualStudio2012Theme | protected
m_pPanelPaintManager | CXTPDockingPanePaintManager | protected
m_pTabPaintManager | CXTPDockingPanePaintManager | protected
m_rcCaptionMargin | CXTPDockingPanePaintManager | protected
m_strFontFace | CXTPDockingPaneVisualStudio2012Theme | protected
m_strOfficeFont | CXTPDockingPanePaintManager | protected
m_systemTheme | CXTPDockingPanePaintManager | protected
m_themeButton | CXTPDockingPanePaintManager | protected
m_themeCurrent | CXTPDockingPanePaintManager | protected
m_themeExplorer | CXTPDockingPanePaintManager | protected
m_themeRebar | CXTPDockingPanePaintManager | protected
m_themeToolbar | CXTPDockingPanePaintManager | protected
m_themeWindow | CXTPDockingPanePaintManager | protected
m_xtpFontTitle | CXTPDockingPanePaintManager | protected
m_xtpFontTitleVertical | CXTPDockingPanePaintManager | protected
Pixel(CDC *pDC, int xPos, int yPos, int nPen) | CXTPDockingPanePaintManager |
Rectangle(CDC *pDC, CRect rc, int nPenEntry, int nPenBorder) | CXTPDockingPanePaintManager |
RefreshMetrics() | CXTPDockingPaneVisualStudio2017Theme | virtual
SetCaptionButtonStyle(XTPDockingPaneCaptionButtonStyle nStyle) | CXTPDockingPanePaintManager |
SetCaptionFontIndirect(LOGFONT *pLogFont, BOOL bUseStandardFont=FALSE) | CXTPDockingPanePaintManager |
SetColors(int cElements, CONST INT *lpaElements, CONST COLORREF *lpaRgbValues) | CXTPDockingPanePaintManager |
SetCustomTitleBrushes(HBRUSH hbrActiveTitleHorz, HBRUSH hbrInactiveTitleHorz=NULL, HBRUSH hbrActiveTitleVert=NULL, HBRUSH hbrInactiveTitleVert=NULL, BOOL bDestroyOnCleanup=FALSE) | CXTPDockingPanePaintManager |
SetLunaTheme(XTPCurrentSystemTheme systemTheme) | CXTPDockingPanePaintManager |
SetPaneColorSets(CXTPDockingPaneColorSet *pcsActive, CXTPDockingPaneColorSet *pcsInactive) | CXTPDockingPaneVisualStudio2012Theme | protected
SetPanelPaintManager(CXTPTabPaintManager *pManager) | CXTPDockingPanePaintManager |
SetSplitterStyle(DWORD dwStyle) | CXTPDockingPanePaintManager |
SetTabPaintManager(CXTPTabPaintManager *pManager) | CXTPDockingPanePaintManager |
UseOfficeFont(BOOL bUseOfficeFont) | CXTPDockingPanePaintManager |
~CXTPDockingPanePaintManager() | CXTPDockingPanePaintManager | protectedvirtual
~CXTPDockingPaneVisualStudio2012Theme() | CXTPDockingPaneVisualStudio2012Theme | virtual
~CXTPDockingPaneVisualStudio2017Theme() | CXTPDockingPaneVisualStudio2017Theme | virtual


Toolkit Pro: XTPTabThemeVisualStudio2012.h Source File

  • Source
  • TabManager
  • Themes
XTPTabThemeVisualStudio2012.h
Go to the documentation of this file.
1
23#if !defined(__XTPTABTHEMEVISUALSTUDIO2012_H__)
24# define __XTPTABTHEMEVISUALSTUDIO2012_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
37class _XTP_EXT_CLASS CXTPTabThemeVisualStudio2012 : public CXTPTabThemeFlat
38{
39public:
40 CXTPTabThemeVisualStudio2012();
41
50 virtual void RefreshMetrics();
51
67 virtual void DrawSingleButton(CDC* pDC, CXTPTabManagerItem* pItem);
68
91 virtual void DrawWorkspacePart(CDC* pDC, LPRECT lpRect, XTPTabWorkspacePart workspacePart);
92
101 virtual XTPTabColorStyle GetDefaultColorSet()
102 {
103 return xtpTabColorVisualStudio2012;
104 }
105};
106
107# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
109#endif // !defined(__XTPTABTHEMEVISUALSTUDIO2012_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPTabColorStyle
XTPTabColorStyle
XTPTabColorStyle is an enumeration used to set the color style of tabs.
Definition XTPTabManagerDefines.h:139
xtpTabColorVisualStudio2012
@ xtpTabColorVisualStudio2012
Tabs will use the Visual Studio 2012 color style for the currently set Appearance.
Definition XTPTabManagerDefines.h:158
XTPTabWorkspacePart
XTPTabWorkspacePart
XTPTabWorkspacePart is an enumeration used to indicate which part of the MDI TabWorkspace must be red...
Definition XTPTabManagerDefines.h:284
CXTPTabManagerItem
CXTPTabManagerItem is the base class for the tabs that appear in the command bars tab workspace,...
Definition XTPTabManagerItem.h:44
CXTPTabThemeFlat
CXTPTabThemeFlat implements a "Flat" tab appearance.
Definition XTPTabThemeFlat.h:49
CXTPTabThemeVisualStudio2012
CXTPTabThemeVisualStudio2012 implements a Visual Studio 2012 tab appearance.
Definition XTPTabThemeVisualStudio2012.h:38
CXTPTabThemeVisualStudio2012::GetDefaultColorSet
virtual XTPTabColorStyle GetDefaultColorSet()
Gets the default value of the color set for this theme.
Definition XTPTabThemeVisualStudio2012.h:101
CXTPTabThemeVisualStudio2012::DrawWorkspacePart
virtual void DrawWorkspacePart(CDC *pDC, LPRECT lpRect, XTPTabWorkspacePart workspacePart)
Draws a specified TabMDIClient TabWorkspace part.
CXTPTabThemeVisualStudio2012::DrawSingleButton
virtual void DrawSingleButton(CDC *pDC, CXTPTabManagerItem *pItem)
Draws a single tab button in the tab client header area.
CXTPTabThemeVisualStudio2012::RefreshMetrics
virtual void RefreshMetrics()
Refreshes the appearance metrics.


Toolkit Pro: XTPRegExp.h Source File

  • Source
  • Common
XTPRegExp.h
Go to the documentation of this file.
1
23#if !defined(__XTPREGEXP_H__)
24# define __XTPREGEXP_H__
25
26# if _MSC_VER >= 1000
27# pragma once
28# endif // _MSC_VER >= 1000
29
30# pragma pack(push, 8)
31
32# if (_MSC_VER > 1100)
33# pragma warning(push)
34# endif
35
36# pragma warning(disable : 4310)
37# pragma warning(disable : 4244)
38# pragma warning(disable : 4786)
39
40# include "Common/Base/Diagnostic/XTPDisableAdvancedWarnings.h"
41# include <comdef.h>
42# include "Common/Base/Diagnostic/XTPEnableAdvancedWarnings.h"
43
44# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
45# pragma warning(push)
46// C4616: #pragma warning : warning number '...' out of range, must be between '4001' and '4999'
47// C4619: #pragma warning : there is no warning number 'number'
48// C5204: '...': class has virtual functions, but its trivial destructor is not virtual; instances
49// of objects derived from this class may not be destructed correctly
50# pragma warning(disable : 4616 4619 5204)
51
52namespace XTPREGEXP
53{
54//
55// Forward references and typedefs
56//
57
58struct __declspec(uuid("3f4daca0-160d-11d2-a8e9-00104b365c9f"))
59 /* dual interface */ IRegExp;
60struct __declspec(uuid("3f4daca1-160d-11d2-a8e9-00104b365c9f"))
61 /* dual interface */ IMatch;
62struct __declspec(uuid("3f4daca2-160d-11d2-a8e9-00104b365c9f"))
63 /* dual interface */ IMatchCollection;
64struct /* coclass */ RegExp;
65
66//
67// Smart pointer typedef declarations
68//
69
70_COM_SMARTPTR_TYPEDEF(IRegExp, __uuidof(IRegExp));
71_COM_SMARTPTR_TYPEDEF(IMatch, __uuidof(IMatch));
72_COM_SMARTPTR_TYPEDEF(IMatchCollection, __uuidof(IMatchCollection));
73
74//
75// Type library items
76//
77
78struct __declspec(uuid("3f4daca0-160d-11d2-a8e9-00104b365c9f")) IRegExp : public IDispatch
79{
80 //
81 // Raw methods provided by interface
82 //
83
84 virtual HRESULT __stdcall get_Pattern(BSTR* pPattern) = 0;
85 virtual HRESULT __stdcall put_Pattern(BSTR pPattern) = 0;
86 virtual HRESULT __stdcall get_IgnoreCase(VARIANT_BOOL* pIgnoreCase) = 0;
87 virtual HRESULT __stdcall put_IgnoreCase(VARIANT_BOOL pIgnoreCase) = 0;
88 virtual HRESULT __stdcall get_Global(VARIANT_BOOL* pGlobal) = 0;
89 virtual HRESULT __stdcall put_Global(VARIANT_BOOL pGlobal) = 0;
90 virtual HRESULT __stdcall Execute(BSTR sourceString, IDispatch** ppMatches) = 0;
91 virtual HRESULT __stdcall Test(BSTR sourceString, VARIANT_BOOL* pMatch) = 0;
92 virtual HRESULT __stdcall Replace(BSTR sourceString, BSTR replaceString, BSTR* pDestString) = 0;
93};
94
95struct __declspec(uuid("3f4daca1-160d-11d2-a8e9-00104b365c9f")) IMatch : public IDispatch
96{
97 //
98 // Raw methods provided by interface
99 //
100
101 virtual HRESULT __stdcall get_Value(BSTR* pValue) = 0;
102 virtual HRESULT __stdcall get_FirstIndex(long* pFirstIndex) = 0;
103 virtual HRESULT __stdcall get_Length(long* pLength) = 0;
104};
105
106struct __declspec(uuid("3f4daca2-160d-11d2-a8e9-00104b365c9f")) IMatchCollection : public IDispatch
107{
108 //
109 // Raw methods provided by interface
110 //
111
112 virtual HRESULT __stdcall get_Item(long index, IDispatch** ppMatch) = 0;
113 virtual HRESULT __stdcall get_Count(long* pCount) = 0;
114 virtual HRESULT __stdcall get__NewEnum(IUnknown** ppEnum) = 0;
115};
116
117struct __declspec(uuid("3f4daca4-160d-11d2-a8e9-00104b365c9f")) RegExp;
118
119} // namespace XTPREGEXP
120
121class _XTP_EXT_CLASS CXTPRegExp
122{
123public:
124 CXTPRegExp()
125 {
126 }
127
128public:
129 void SetPattern(LPCTSTR lpszPattern)
130 {
131 if (!CreateInstance())
132 return;
133 m_regexpPtr->put_Pattern(_bstr_t(XTP_CT2CW(lpszPattern)));
134 }
135
136 void SetMatchCase(BOOL bMatchCase)
137 {
138 if (!CreateInstance())
139 return;
140
141 m_regexpPtr->put_IgnoreCase(bMatchCase ? VARIANT_FALSE : VARIANT_TRUE);
142 }
143
144public:
145 BOOL Test(LPCTSTR lpszSourceString)
146 {
147 if (!CreateInstance())
148 return FALSE;
149
150 VARIANT_BOOL bTest = VARIANT_FALSE;
151 if (FAILED(m_regexpPtr->Test(_bstr_t(XTP_CT2CW(lpszSourceString)), &bTest)))
152 return FALSE;
153
154 return bTest != VARIANT_FALSE;
155 }
156
157 BOOL Replace(LPCTSTR lpszSourceString, LPCTSTR lpszReplaceString, CString& strDestString)
158 {
159 if (!CreateInstance())
160 return FALSE;
161
162 BSTR bstrResult = 0;
163 if (FAILED(m_regexpPtr->Replace(_bstr_t(XTP_CT2CW(lpszSourceString)),
164 _bstr_t(XTP_CT2CW(lpszReplaceString)), &bstrResult)))
165 return FALSE;
166
167 strDestString = bstrResult;
168 SysFreeString(bstrResult);
169
170 return TRUE;
171 }
172
173 long Execute(LPCTSTR lpszSourceString)
174 {
175 m_matchesPtr = NULL;
176
177 if (!CreateInstance())
178 return 0;
179
180 long nCount = 0;
181
182 IDispatch* _result = 0;
183 if (SUCCEEDED(m_regexpPtr->Execute(_bstr_t(XTP_CT2CW(lpszSourceString)), &_result)))
184 {
185 m_matchesPtr = _result;
186
187 if (m_matchesPtr != NULL)
188 {
189 m_matchesPtr->get_Count(&nCount);
190 }
191 }
192 if (_result)
193 _result->Release();
194 if (nCount == 0)
195 m_matchesPtr = NULL;
196
197 return nCount;
198 }
199
200 BOOL GetMatch(long nIndex, long* pnFirstIndex, long* pnLength)
201 {
202 if (m_matchesPtr == NULL)
203 return FALSE;
204
205 if (pnFirstIndex == 0 || pnLength == 0)
206 return FALSE;
207
208 long nCount = 0;
209 m_matchesPtr->get_Count(&nCount);
210 if (nIndex >= nCount)
211 return FALSE;
212
213 IDispatch* _result = 0;
214 if (FAILED(m_matchesPtr->get_Item(nIndex, &_result)))
215 return FALSE;
216
217 XTPREGEXP::IMatchPtr match = _result;
218 if (_result)
219 _result->Release();
220
221 if (match == NULL)
222 return FALSE;
223
224 match->get_FirstIndex(pnFirstIndex);
225 match->get_Length(pnLength);
226 return TRUE;
227 }
228
229protected:
230 BOOL CreateInstance()
231 {
232 if (m_regexpPtr == NULL)
233 {
234 if (!SUCCEEDED(m_regexpPtr.CreateInstance(__uuidof(XTPREGEXP::RegExp))))
235 {
236 TRACE(_T("Warning: CreateInstance failed in CXTPRegExp --\n"));
237 TRACE(_T("\tperhaps AfxOleInit() has not been called"));
238
239 return FALSE;
240 }
241 }
242 return TRUE;
243 }
244
245protected:
246 XTPREGEXP::IRegExpPtr m_regexpPtr;
247 XTPREGEXP::IMatchCollectionPtr m_matchesPtr;
248};
249
250# pragma warning(pop)
251# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
252
253# if (_MSC_VER > 1100)
254# pragma warning(pop)
255# endif
256
257# pragma pack(pop)
258
259#endif //#if !defined(__XTPREGEXP_H__)
XTPDisableAdvancedWarnings.h
XTPDisableNoisyWarnings.h
XTPEnableAdvancedWarnings.h
XTPEnableNoisyWarnings.h


Toolkit Pro: Member List

CXTPSyntaxEditSelection Member List

This is the complete list of members for CXTPSyntaxEditSelection, including all inherited members.

bBlockSelectionMode | CXTPSyntaxEditSelection | protected
bSelectingRunning | CXTPSyntaxEditSelection | protected
bWordSelectionMode | CXTPSyntaxEditSelection | protected
CXTPCmdTarget() | CXTPCmdTarget |
CXTPSyntaxEditSelection() | CXTPSyntaxEditSelection |
CXTPSyntaxEditSelection(const CXTPSyntaxEditSelection &rSrc) | CXTPSyntaxEditSelection |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetEnd_disp() const | CXTPSyntaxEditSelection |
GetEnd_str() const | CXTPSyntaxEditSelection |
GetNormalEnd_disp() const | CXTPSyntaxEditSelection |
GetNormalEnd_str() const | CXTPSyntaxEditSelection |
GetNormalStart_disp() const | CXTPSyntaxEditSelection |
GetNormalStart_str() const | CXTPSyntaxEditSelection |
GetStart_disp() const | CXTPSyntaxEditSelection |
GetStart_str() const | CXTPSyntaxEditSelection |
IsbBlockSelectionMode() const | CXTPSyntaxEditSelection |
IsInSel_disp(int nTextRow, int nDispCol) const | CXTPSyntaxEditSelection |
IsInSel_str(int nTextRow, int nStrPos) const | CXTPSyntaxEditSelection |
IsIntersectSel_disp(int nTextRow, int nDispCol1, int nDispCol2) const | CXTPSyntaxEditSelection |
IsIntersectSel_str(int nTextRow, int nStrPos1, int nStrPos2) const | CXTPSyntaxEditSelection |
IsSelExist() const | CXTPSyntaxEditSelection |
IsSelNormal() const | CXTPSyntaxEditSelection |
IsWordSelectionMode() const | CXTPSyntaxEditSelection |
nSelStartTextRowFromLeftBar | CXTPSyntaxEditSelection | protected
operator!=(const CXTPSyntaxEditSelection &rSrc) const | CXTPSyntaxEditSelection |
operator=(const CXTPSyntaxEditSelection &rSrc) | CXTPSyntaxEditSelection |
operator==(const CXTPSyntaxEditSelection &rSrc) const | CXTPSyntaxEditSelection |
Reset_disp(int nTextRow, int nDispCol) | CXTPSyntaxEditSelection |
Reset_str(int nTextRow, int nStrPos) | CXTPSyntaxEditSelection |
SetEnd_disp(int nTextRow, int nDispCol) | CXTPSyntaxEditSelection |
SetEnd_str(int nTextRow, int nStrPos) | CXTPSyntaxEditSelection |
SetStart_disp(int nTextRow, int nDispCol) | CXTPSyntaxEditSelection |
SetStart_str(int nTextRow, int nStrPos) | CXTPSyntaxEditSelection |
~CXTPSyntaxEditSelection() | CXTPSyntaxEditSelection | virtual


Toolkit Pro: Member List

CXTPGridThemeVisualStudio2015 Member List

This is the complete list of members for CXTPGridThemeVisualStudio2015, including all inherited members.

CalcColumnHeight(CDC *pDC, CXTPGridColumn *pColumn, int nTotalWidth=0) | CXTPGridPaintManager | protectedvirtual
CalculateRowHeight(CDC *pDC, const CString &strText, int nMaxWidth, BOOL bWordBreak=TRUE) | CXTPGridPaintManager | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPGridPaintManager() | CXTPGridPaintManager |
CXTPGridThemeOffice2013() | CXTPGridThemeOffice2013 |
CXTPGridThemeVisualStudio2015() | CXTPGridThemeVisualStudio2015 |
DrawBitmap(CDC *pDC, CXTPGridControl *pControl, CRect rcColumn, int iImage) | CXTPGridPaintManager | virtual
DrawCollapsedBitmap(CDC *pDC, const CXTPGridRow *pRow, CRect &rcBitmap) | CXTPGridThemeOffice2013 | virtual
DrawColumn(CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn, BOOL bDrawExternal=FALSE, int nShadowWidth=0) | CXTPGridPaintManager | virtual
DrawColumnBackground(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, BOOL &bColumnPressed, BOOL &bDraggingFromHeader, CXTPGridHeader *pHeader=NULL) | CXTPGridThemeOffice2013 | virtual
DrawColumnFooter(CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn) | CXTPGridPaintManager | virtual
DrawColumnFooterDivider(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn) | CXTPGridPaintManager | virtual
DrawColumnIcon(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, CRect rcIcon, int iIcon) | CXTPGridPaintManager | virtual
DrawColumnText(CDC *pDC, CRect rcText, CString strCaption, int nHeaderAlignment, BOOL bIsHeader, BOOL bColumnPressed) | CXTPGridThemeOffice2013 | virtual
DrawConnector(CDC *pDC, CPoint ptFrom, CPoint ptTo) | CXTPGridPaintManager |
DrawFocusedRow(CDC *pDC, CRect rcRow) | CXTPGridThemeOffice2013 | virtual
DrawFreezeColsDivider(CDC *pDC, const CRect &rc, CXTPGridControl *pControl, CXTPGridRow *pRow=NULL) | CXTPGridPaintManager | virtual
DrawGlyph(CDC *pDC, CRect rcColumn, int iImage) | CXTPGridPaintManager | virtual
DrawGrid(CDC *pDC, XTPGridOrientation orientation, CRect rcGrid) | CXTPGridPaintManager | virtual
DrawGridPattern(CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush) | CXTPGridPaintManager | protectedvirtual
DrawGridPattern(CDC *pDC, CXTPBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush) | CXTPGridPaintManager | protectedvirtual
DrawGridPattern(CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr) | CXTPGridPaintManager | protectedvirtual
DrawGroupRow(CDC *pDC, CXTPGridGroupRow *pRow, CRect rcRow, XTP_GRIDRECORDITEM_METRICS *pMetrics) | CXTPGridThemeOffice2013 | virtual
DrawHorizontalLine(CDC *pDC, int xPos, int yPos, int cx, COLORREF clr) | CXTPGridPaintManager |
DrawInplaceButton(CDC *pDC, CXTPGridInplaceButton *pButton) | CXTPGridPaintManager | virtual
DrawInplaceButtonFrame(CDC *pDC, CXTPGridInplaceButton *pButton) | CXTPGridPaintManager | protectedvirtual
DrawInplaceButtonIcon(CDC *pDC, CXTPGridInplaceButton *pButton) | CXTPGridPaintManager | protectedvirtual
DrawInplaceComboButton(CDC *pDC, CRect *pRc) | CXTPGridPaintManager | virtual
DrawInplaceExpandButton(CDC *pDC, CRect *pRc) | CXTPGridPaintManager | virtual
DrawInplaceSpinButton(CDC *pDC, CRect *pRc) | CXTPGridPaintManager | virtual
DrawItemBitmap(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CRect &rcItem, int nImage) | CXTPGridPaintManager | virtual
DrawItemCaption(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics) | CXTPGridPaintManager | virtual
DrawItemControl(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CXTPGridRecordItemControl *pControl, CRect &rcItem) | CXTPGridPaintManager | virtual
DrawLink(int *pnCurrDrawPos, XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CXTPGridHyperlink *pHyperlink, CString strText, CRect rcLink, int nFlag, BOOL bTrim=FALSE) | CXTPGridPaintManager | protectedvirtual
DrawMultiLineText(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, BOOL bWordBreak=TRUE) | CXTPGridPaintManager | protectedvirtual
DrawNoGroupByText(CDC *pDC, CRect rcItem) | CXTPGridPaintManager | virtual
DrawRowNumber(CDC *pDC, CRect rcNumber, CXTPGridRow *pRow) | CXTPGridPaintManager | virtual
DrawSectionDivider(CDC *pDC, const CRect &rc, XTPGridSectionDividerPosition dividerPosition, XTPGridSectionDividerStyle dividerStyle, CXTPPaintManagerColor dividerColor) | CXTPGridPaintManager |
DrawShellIcon(CDC *pDC, CRect rcColumn, int iImage) | CXTPGridPaintManager | virtual
DrawSingleLineText(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nStartPos, int nEndPos, int nActualWidth) | CXTPGridPaintManager | protectedvirtual
DrawString(int *pnCurrDrawPos, CDC *pDC, const CString &strDraw, CRect rcDraw, UINT nFormat) | CXTPGridPaintManager | protectedvirtual
DrawTextLine(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nFlag, int &nCharCounter, int &nHyperlinkCounter) | CXTPGridPaintManager | protectedvirtual
DrawTreeStructure(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CRect rcItem, CSize sizeGlyph) | CXTPGridPaintManager | virtual
DrawTriangle(CDC *pDC, CRect rcTriangle, BOOL bToDown, BOOL bDraggingFromHeader, int nShadowWidth, BOOL bColumnPressed) | CXTPGridThemeOffice2013 | virtual
DrawVerticalLine(CDC *pDC, int xPos, int yPos, int cy, COLORREF clr) | CXTPGridPaintManager |
DrawVerticalTimeLineMarker(CDC *pDC, int xPos, CXTPGridControl *pControl, COLORREF color=RGB(0, 255, 0)) | CXTPGridPaintManager | virtual
EnablePreviewMode(BOOL bIsPreviewMode) | CXTPGridPaintManager |
FillFooter(CDC *pDC, CRect rcFooter) | CXTPGridPaintManager | virtual
FillGroupByControl(CDC *pDC, CRect &rcGroupBy) | CXTPGridPaintManager | virtual
FillGroupRowMetrics(CXTPGridGroupRow *pRow, XTP_GRIDRECORDITEM_METRICS *pMetrics, BOOL bPrinting) | CXTPGridThemeOffice2013 | virtual
FillHeaderControl(CDC *pDC, CRect rcHeader) | CXTPGridPaintManager | virtual
FillIndent(CDC *pDC, CRect rcRow) | CXTPGridPaintManager | virtual
FillItemShade(CDC *pDC, CRect rcItem) | CXTPGridPaintManager | virtual
FillRow(CDC *pDC, CXTPGridRow *pRow, CRect rcRow) | CXTPGridPaintManager | virtual
FindRowAdjacentToMerged(const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, BOOL bUpward) | CXTPGridPaintManager |
FindRowAdjacentToMergedEx(const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, int &nAdjRowIndex, BOOL bUpward) | CXTPGridPaintManager |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetColumnOffice2007CustomThemeBaseColor() const | CXTPGridPaintManager |
GetColumnStyle() const | CXTPGridPaintManager |
GetControlBackColor(CXTPGridControl *pControl) | CXTPGridPaintManager | virtual
GetFooterHeight(CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0) | CXTPGridPaintManager | virtual
GetFreezeColsDividerStyle() const | CXTPGridPaintManager |
GetGlyphs() const | CXTPGridPaintManager |
GetHeaderHeight() | CXTPGridPaintManager | virtual
GetHeaderHeight(CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0) | CXTPGridPaintManager | virtual
GetItemHeight(XTP_GRIDRECORDITEM_DRAWARGS &drawArgs, int nWidth) | CXTPGridPaintManager |
GetMaxPreviewLines() | CXTPGridPaintManager |
GetPreviewItemHeight(CDC *pDC, CXTPGridRow *pRow, int nWidth, int nHeight) | CXTPGridPaintManager | virtual
GetPreviewLinesCount(CDC *pDC, CRect &rcText, const CString &strText) | CXTPGridPaintManager |
GetRowHeight(CDC *pDC, CXTPGridRow *pRow) | CXTPGridThemeOffice2013 | virtual
GetRowHeight(CDC *pDC, CXTPGridRow *pRow, int nTotalWidth) | CXTPGridThemeOffice2013 | virtual
GetRowHeightEx(CDC *pDC, CXTPGridRow *pRow, int nTotalWidth, const BOOL firstLevel=TRUE) | CXTPGridPaintManager |
GetSectionDividerHeight(XTPGridFixedRowsDividerStyle dividerStyle) | CXTPGridPaintManager |
GetTextFont() | CXTPGridPaintManager |
IsColumHotTrackingEnabled() const | CXTPGridPaintManager | virtual
IsColumnPlusMinusSign() const | CXTPGridPaintManager |
IsColumnWidthWYSIWYG() const | CXTPGridPaintManager |
IsDrawGridForEmptySpace() const | CXTPGridPaintManager |
IsFixedInplaceButtonHeight() const | CXTPGridPaintManager |
IsFixedRowHeight() const | CXTPGridPaintManager |
IsGridVisible(BOOL bVertical) const | CXTPGridPaintManager |
IsGridVisible(XTPGridOrientation orientation) const | CXTPGridPaintManager |
IsLastColumnWidthWYSIWYG() const | CXTPGridPaintManager |
IsPreviewMode() const | CXTPGridPaintManager |
IsPrintGroupRowIcon() const | CXTPGridPaintManager |
IsShowWYSIWYGMarkers() const | CXTPGridPaintManager |
IsUseDropMarker() const | CXTPGridPaintManager |
LoadGlyphs() | CXTPGridThemeOffice2013 | virtual
m_arStartCol | CXTPGridPaintManager |
m_bAllowMergeCells | CXTPGridPaintManager |
m_bBaseTreeIndent | CXTPGridPaintManager |
m_bCleanTooltip | CXTPGridPaintManager |
m_bColumnPlusMinusSign | CXTPGridPaintManager | protected
m_bColumnWidthWYSIWYG | CXTPGridPaintManager | protected
m_bCompactText | CXTPGridPaintManager |
m_bDrawGridForEmptySpace | CXTPGridPaintManager | protected
m_bFixedInplaceButtonHeight | CXTPGridPaintManager | protected
m_bFixedRowHeight | CXTPGridPaintManager | protected
m_bForceDynamicMarkupForCell | CXTPGridPaintManager |
m_bForceShowDropMarker | CXTPGridPaintManager |
m_bForceShowTooltip | CXTPGridPaintManager |
m_bGrayIfDisable | CXTPGridPaintManager |
m_bGroupRowTextBold | CXTPGridPaintManager |
m_bHideSelection | CXTPGridPaintManager |
m_bHotTracking | CXTPGridPaintManager |
m_bInvertColumnOnClick | CXTPGridPaintManager |
m_bIsPreviewMode | CXTPGridPaintManager | protected
m_bLastColumnWidthWYSIWYG | CXTPGridPaintManager | protected
m_bMakeUpper | CXTPGridPaintManager |
m_bMoveScrollbarOnFixedColumnsIndent | CXTPGridPaintManager |
m_bPrintGroupRowIcon | CXTPGridPaintManager | protected
m_bPrintPageRectangle | CXTPGridPaintManager |
m_bPrintSortTriangle | CXTPGridPaintManager |
m_bPrintVirtualPageNumber | CXTPGridPaintManager |
m_bPrintWatermark | CXTPGridPaintManager |
m_bRecOrRowNum | CXTPGridPaintManager |
m_bRevertAlignment | CXTPGridPaintManager |
m_bShadeGroupHeadings | CXTPGridPaintManager |
m_bShadeSortColumn | CXTPGridPaintManager |
m_bShowLockIcon | CXTPGridPaintManager |
m_bShowNonActiveInPlaceButton | CXTPGridPaintManager |
m_bShowWYSIWYGMarkers | CXTPGridPaintManager | protected
m_bSortTriangleOffsetFromRight | CXTPGridPaintManager |
m_bThemedInplaceButtons | CXTPGridPaintManager |
m_bUseAlternativeBackground | CXTPGridPaintManager |
m_bUseDropMarker | CXTPGridPaintManager |
m_bUseEditTextAlignment | CXTPGridPaintManager |
m_bUseGroupRowSelectionState | CXTPGridPaintManager |
m_bUseShellIcon | CXTPGridPaintManager |
m_clrAlternativeBackground | CXTPGridPaintManager |
m_clrBoldText | CXTPGridPaintManager |
m_clrBoldTextHighlight | CXTPGridPaintManager |
m_clrBtnFace | CXTPGridPaintManager |
m_clrBtnFacePressed | CXTPGridPaintManager |
m_clrBtnText | CXTPGridPaintManager |
m_clrCaptionText | CXTPGridPaintManager |
m_clrCaptionTextPressed | CXTPGridPaintManager |
m_clrColumnOffice2007CustomTheme | CXTPGridPaintManager |
m_clrConnector | CXTPGridPaintManager |
m_clrControlBack | CXTPGridPaintManager |
m_clrControlDark | CXTPGridPaintManager |
m_clrControlLightLight | CXTPGridPaintManager |
m_clrDisableBitmapDarkest | CXTPGridPaintManager |
m_clrDisableBitmapLightest | CXTPGridPaintManager |
m_clrFormulaSubSum | CXTPGridPaintManager |
m_clrFormulaSum | CXTPGridPaintManager |
m_clrFreezeColsDivider | CXTPGridPaintManager |
m_clrGlyph | CXTPGridThemeOffice2013 |
m_clrGlyphBorder | CXTPGridThemeOffice2013 |
m_clrGlyphContract | CXTPGridThemeOffice2013 |
m_clrGlyphExpand | CXTPGridThemeOffice2013 |
m_clrGlyphHighlight | CXTPGridThemeOffice2013 |
m_clrGradientColumnSeparator | CXTPGridPaintManager |
m_clrGradientColumnShadow | CXTPGridPaintManager |
m_clrGroupBoxBack | CXTPGridPaintManager |
m_clrGroupRowText | CXTPGridPaintManager |
m_clrGroupShadeBack | CXTPGridPaintManager |
m_clrGroupShadeBorder | CXTPGridPaintManager |
m_clrGroupShadeText | CXTPGridPaintManager |
m_clrHeaderControl | CXTPGridPaintManager |
m_clrHighlight | CXTPGridPaintManager |
m_clrHighlightText | CXTPGridPaintManager |
m_clrHotDivider | CXTPGridPaintManager |
m_clrIndentControl | CXTPGridPaintManager |
m_clrItemShade | CXTPGridPaintManager |
m_clrPreviewText | CXTPGridPaintManager |
m_clrSelectedRow | CXTPGridPaintManager |
m_clrSelectedRowText | CXTPGridPaintManager |
m_clrWindowText | CXTPGridPaintManager |
m_columnStyle | CXTPGridPaintManager | protected
m_crlNoGroupByText | CXTPGridPaintManager |
m_grcGradientColumn | CXTPGridPaintManager |
m_grcGradientColumnHot | CXTPGridPaintManager |
m_grcGradientColumnPushed | CXTPGridPaintManager |
m_iRecOrRowStart | CXTPGridPaintManager |
m_nBaseParentRecordIndent | CXTPGridPaintManager |
m_nFixedColumnsIndent | CXTPGridPaintManager |
m_nFooterHeight | CXTPGridPaintManager | protected
m_nFreezeColsDividerStyle | CXTPGridPaintManager | protected
m_nGridLineStylePreviousH | CXTPGridPaintManager | protected
m_nGridLineStylePreviousV | CXTPGridPaintManager | protected
m_nGroupGridLineHeight | CXTPGridPaintManager | protected
m_nGroupGridLineStyle | CXTPGridPaintManager | protected
m_nHeaderHeight | CXTPGridPaintManager | protected
m_nMaxPreviewLines | CXTPGridPaintManager | protected
m_nResizingWidth | CXTPGridPaintManager | protected
m_nRowHeight | CXTPGridPaintManager | protected
m_nRowHeightDefault | CXTPGridPaintManager |
m_nTextIndentForGroupRowsWithNoIcon | CXTPGridPaintManager |
m_nTreeColumnLineLength | CXTPGridPaintManager |
m_nTreeIndent | CXTPGridPaintManager |
m_nTreeStructureStyle | CXTPGridPaintManager |
m_nTreeTextIndent | CXTPGridPaintManager |
m_nTreeTextIndentGroupRow | CXTPGridPaintManager |
m_nTreeTextIndentRowChildren | CXTPGridPaintManager |
m_nTreeTextIndentRowParent | CXTPGridPaintManager |
m_pControl | CXTPGridPaintManager | protected
m_pGlyphs | CXTPGridPaintManager | protected
m_pHyperlinkHoverStyle | CXTPGridPaintManager |
m_pHyperlinkStyle | CXTPGridPaintManager |
m_pMarkupUIElement_NoGroupBy | CXTPGridPaintManager | protected
m_PrintPageWidth | CXTPGridPaintManager |
m_rcPreviewIndent | CXTPGridPaintManager |
m_RecordNumberWidth | CXTPGridPaintManager |
m_strCollapse | CXTPGridPaintManager |
m_strDecreasing | CXTPGridPaintManager |
m_strExpand | CXTPGridPaintManager |
m_strIncreasing | CXTPGridPaintManager |
m_strMarkupUIElement_NoGroupBy | CXTPGridPaintManager | protected
m_strNoFieldsAvailable | CXTPGridPaintManager |
m_strNoGroupBy | CXTPGridPaintManager |
m_strNoItems | CXTPGridPaintManager |
m_strSortBy | CXTPGridPaintManager |
m_szGlyph | CXTPGridPaintManager | protected
m_themeButton | CXTPGridPaintManager | protected
m_themeCombo | CXTPGridPaintManager | protected
m_themeHeader | CXTPGridPaintManager | protected
m_themeSpin | CXTPGridPaintManager | protected
m_treeStructureStyle | CXTPGridPaintManager |
m_xtpBrushGroupGridLineStyle | CXTPGridPaintManager | protected
m_xtpBrushHorizontalGrid | CXTPGridPaintManager | protected
m_xtpBrushTreeStructure | CXTPGridPaintManager | protected
m_xtpBrushVeriticalGrid | CXTPGridPaintManager | protected
m_xtpFontBoldText | CXTPGridPaintManager |
m_xtpFontCaption | CXTPGridPaintManager |
m_xtpFontPreview | CXTPGridPaintManager |
m_xtpFontText | CXTPGridPaintManager |
OnDrawAction(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs) | CXTPGridPaintManager | virtual
RecalcTotalHightOfMergedRows(CXTPGridColumns *pColumns, CDC *pDC, CXTPGridRow *pRow, int nRowHeight, int nTotalWidth) | CXTPGridPaintManager |
RefreshMetrics() | CXTPGridThemeVisualStudio2015 | virtual
SetCaptionFont(LOGFONT &lf) | CXTPGridPaintManager |
SetColumnOffice2007CustomThemeBaseColor(COLORREF clrBaseColor) | CXTPGridPaintManager |
SetColumnPlusMinusSign(BOOL bDraw) | CXTPGridPaintManager |
SetColumnStyle(XTPGridColumnStyle columnStyle) | CXTPGridPaintManager |
SetColumnWidthWYSIWYG(BOOL bColumnWidthWYSIWYG) | CXTPGridPaintManager |
SetDrawGridForEmptySpace(BOOL bDrawGrid) | CXTPGridPaintManager |
SetFixedRowHeight(BOOL bFixedRowHeight) | CXTPGridPaintManager |
SetFreezeColsDividerStyle(int nStyle) | CXTPGridPaintManager |
SetGridControl(CXTPGridControl *pControl) | CXTPGridPaintManager | virtual
SetHeaderHeight(int nHeight) | CXTPGridPaintManager | virtual
SetInplaceButtonHeight(BOOL bFixedInplaceButtonHeight) | CXTPGridPaintManager |
SetLastColumnWidthWYSIWYG(BOOL bColumnWidthWYSIWYG) | CXTPGridPaintManager |
SetMaxPreviewLines(int nMaxLines) | CXTPGridPaintManager |
SetPreviewIndent(int nLeft, int nTop, int nRight, int nBottom) | CXTPGridPaintManager |
SetPrintGroupRowIcon(BOOL bDraw) | CXTPGridPaintManager |
SetTextFont(LOGFONT &lf) | CXTPGridPaintManager |
ShowWYSIWYGMarkers(BOOL bSet) | CXTPGridPaintManager |
~CXTPGridPaintManager() | CXTPGridPaintManager | virtual


Toolkit Pro: XTPFlowGraphConnectionPoints.h Source File

  • Source
  • FlowGraph
XTPFlowGraphConnectionPoints.h
Go to the documentation of this file.
1
23#if !defined(__XTPFLOWGRAPHCONNECTIONPOINTS_H__)
24# define __XTPFLOWGRAPHCONNECTIONPOINTS_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPFlowGraphNode;
34class CXTPFlowGraphConnectionPoint;
35
43class _XTP_EXT_CLASS CXTPFlowGraphConnectionPoints : public CXTPCmdTarget
44{
45protected:
51 CXTPFlowGraphConnectionPoints(CXTPFlowGraphNode* pNode);
57 virtual ~CXTPFlowGraphConnectionPoints();
58
59public:
68 CXTPFlowGraphConnectionPoint* AddConnectionPoint(CXTPFlowGraphConnectionPoint* pConnectionPoint,
69 int nIndex = -1);
70
75 void RemoveAll();
76
84 void Remove(CXTPFlowGraphConnectionPoint* pConnectionPoint, BOOL bRemovePairs = TRUE);
93 void RemoveAt(int nIndex, BOOL bRemovePairs = TRUE, BOOL bSkipUndoTask = FALSE);
94
101 int GetCount() const;
109 CXTPFlowGraphConnectionPoint* GetAt(int nIndex) const;
110
121 CXTPFlowGraphConnectionPoint* FindConnectionPoint(
122 LPCTSTR lpszName, XTPFlowGraphConnectionPointType type = xtpFlowGraphPointNone) const;
130 CXTPFlowGraphConnectionPoint* FindConnectionPoint(int nId) const;
131
142 CXTPFlowGraphConnectionPoint* FindConnectionPointByCaption(
143 LPCTSTR lpszCaption, XTPFlowGraphConnectionPointType type = xtpFlowGraphPointNone) const;
144
145public:
155 void DoPropExchange(CXTPPropExchange* pPX);
156
157protected:
158 CXTPFlowGraphNode* m_pNode;
161 CArray<CXTPFlowGraphConnectionPoint*, CXTPFlowGraphConnectionPoint*>
162 m_arrConnectionPoints;
164 friend class CXTPFlowGraphNode;
165
166# ifdef _XTP_ACTIVEX
169 DECLARE_DISPATCH_MAP()
170 DECLARE_INTERFACE_MAP()
171
172 DECLARE_OLETYPELIB_EX(CXTPFlowGraphConnectionPoints)
173 DECLARE_ENUM_VARIANT(CXTPFlowGraphConnectionPoints)
174
175 afx_msg int OleGetItemCount();
176 afx_msg LPDISPATCH OleGetItem(int nIndex);
177 afx_msg LPDISPATCH OleFindConnectionPoint(int nId);
178 afx_msg LPDISPATCH OleFindConnectionPointByCaption(LPCTSTR lpszCaption, const VARIANT& vtType);
179
180 afx_msg LPDISPATCH OleFindConnectionPointByName(LPCTSTR lpszName, const VARIANT& vtType);
181
183# endif
184};
185
186AFX_INLINE int CXTPFlowGraphConnectionPoints::GetCount() const
187{
188 return (int)m_arrConnectionPoints.GetSize();
189}
190AFX_INLINE CXTPFlowGraphConnectionPoint* CXTPFlowGraphConnectionPoints::GetAt(int nIndex) const
191{
192 return nIndex >= 0 && nIndex < m_arrConnectionPoints.GetSize() ? m_arrConnectionPoints[nIndex]
193 : NULL;
194}
196# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
197#endif //#if !defined(__XTPFLOWGRAPHCONNECTIONPOINTS_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPFlowGraphConnectionPointType
XTPFlowGraphConnectionPointType
Node connection point types (input/output).
Definition XTPFlowGraphNode.h:85
xtpFlowGraphPointNone
@ xtpFlowGraphPointNone
Connection has no connection points.
Definition XTPFlowGraphNode.h:86
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPFlowGraphConnectionPoint
Represents a connection point for a node.
Definition XTPFlowGraphConnectionPoint.h:46
CXTPFlowGraphConnectionPoints
Represents a collection of connection points for a Node.
Definition XTPFlowGraphConnectionPoints.h:44
CXTPFlowGraphConnectionPoints::GetCount
int GetCount() const
Retrieves the total number of connections points for the Node.
Definition XTPFlowGraphConnectionPoints.h:186
CXTPFlowGraphConnectionPoints::GetAt
CXTPFlowGraphConnectionPoint * GetAt(int nIndex) const
Retrieves the connection point at the specified index.
Definition XTPFlowGraphConnectionPoints.h:190
CXTPFlowGraphConnectionPoints::DoPropExchange
void DoPropExchange(CXTPPropExchange *pPX)
Call this member function to store/load a collection of connection points using the specified data ob...
CXTPFlowGraphConnectionPoints::FindConnectionPoint
CXTPFlowGraphConnectionPoint * FindConnectionPoint(LPCTSTR lpszName, XTPFlowGraphConnectionPointType type=xtpFlowGraphPointNone) const
Finds and retrieves the specified connection point by searching for the connection point's name.
CXTPFlowGraphConnectionPoints::m_arrConnectionPoints
CArray< CXTPFlowGraphConnectionPoint *, CXTPFlowGraphConnectionPoint * > m_arrConnectionPoints
Collection of connection points.
Definition XTPFlowGraphConnectionPoints.h:162
CXTPFlowGraphConnectionPoints::FindConnectionPointByCaption
CXTPFlowGraphConnectionPoint * FindConnectionPointByCaption(LPCTSTR lpszCaption, XTPFlowGraphConnectionPointType type=xtpFlowGraphPointNone) const
Finds and retrieves the specified connection point by searching for the connection point's caption.
CXTPFlowGraphConnectionPoints::Remove
void Remove(CXTPFlowGraphConnectionPoint *pConnectionPoint, BOOL bRemovePairs=TRUE)
Removes a specified connection point.
CXTPFlowGraphConnectionPoints::FindConnectionPoint
CXTPFlowGraphConnectionPoint * FindConnectionPoint(int nId) const
Finds and retrieves the specified connection point.
CXTPFlowGraphConnectionPoints::CXTPFlowGraphConnectionPoints
CXTPFlowGraphConnectionPoints(CXTPFlowGraphNode *pNode)
Constructs a CXTPFlowGraphConnectionPoints object.
CXTPFlowGraphConnectionPoints::RemoveAll
void RemoveAll()
Removes all connection points from the Node.
CXTPFlowGraphConnectionPoints::AddConnectionPoint
CXTPFlowGraphConnectionPoint * AddConnectionPoint(CXTPFlowGraphConnectionPoint *pConnectionPoint, int nIndex=-1)
Adds a connection point to the Node.
CXTPFlowGraphConnectionPoints::~CXTPFlowGraphConnectionPoints
virtual ~CXTPFlowGraphConnectionPoints()
Destroys a CXTPFlowGraphConnectionPoints object, handles cleanup and deallocation.
CXTPFlowGraphConnectionPoints::RemoveAt
void RemoveAt(int nIndex, BOOL bRemovePairs=TRUE, BOOL bSkipUndoTask=FALSE)
Removes a specified connection point from the Node's collection of connection points.
CXTPFlowGraphConnectionPoints::m_pNode
CXTPFlowGraphNode * m_pNode
Reference to the node that uses the connection points from this collection.
Definition XTPFlowGraphConnectionPoints.h:158
CXTPFlowGraphNode
Represents a Node object.
Definition XTPFlowGraphNode.h:116
CXTPFlowGraphNode::GetSize
CSize GetSize() const
Gets the size of the Node.
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72


Toolkit Pro: Member List

CXTPChartPieDeviceCommandImpl Member List

This is the complete list of members for CXTPChartPieDeviceCommandImpl, including all inherited members.

m_bDoughnut | CXTPChartPieDeviceCommandImpl |
m_dCorrectedDepth | CXTPChartPieDeviceCommandImpl |
m_dDepth | CXTPChartPieDeviceCommandImpl |
m_dFacetSize | CXTPChartPieDeviceCommandImpl |
m_dHolePercent | CXTPChartPieDeviceCommandImpl |
m_dInnerMajorSemiAxis | CXTPChartPieDeviceCommandImpl |
m_dInnerMinorSemiAxis | CXTPChartPieDeviceCommandImpl |
m_dInnerRadius | CXTPChartPieDeviceCommandImpl |
m_dMajorSemiAxis | CXTPChartPieDeviceCommandImpl |
m_dMinorSemiAxis | CXTPChartPieDeviceCommandImpl |
m_dRadius | CXTPChartPieDeviceCommandImpl |
m_dStartAngle | CXTPChartPieDeviceCommandImpl |
m_dSweepAngle | CXTPChartPieDeviceCommandImpl |
m_ptCenter | CXTPChartPieDeviceCommandImpl |
~CXTPChartPieDeviceCommandImpl() | CXTPChartPieDeviceCommandImpl | protectedvirtual


Toolkit Pro: XTPExcelTabCtrl.h Source File

  • Source
  • Controls
  • Tab
XTPExcelTabCtrl.h
Go to the documentation of this file.
1
23#if !defined(__XTPEXCELTABCTRL_H__)
24# define __XTPEXCELTABCTRL_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPExcelTabCtrlTheme;
34
47enum XTPArrowIcon
48{
49 xtpArrowIconLeft = 0x0200,
50 xtpArrowIconLeftHome = 0x0201,
51 xtpArrowIconRight = 0x0000,
52 xtpArrowIconRightHome = 0x0001
53};
54
61class _XTP_EXT_CLASS CXTPExcelTabCtrlButtonState
62{
63public:
68 CXTPExcelTabCtrlButtonState();
69
70public:
79 void SetInfo(CRect rect, int iCommand, XTPArrowIcon iconType);
80
81public:
82 int m_iCommand;
83 bool m_bPressed;
84 bool m_bEnabled;
85 bool m_bHilight;
86 CRect m_rect;
87 XTPArrowIcon m_IconType;
88};
89
91typedef CArray<CXTPTcbItem*, CXTPTcbItem*> CTabItemArray;
100class _XTP_EXT_CLASS CXTPExcelTabCtrl : public CWnd
101{
103 DECLARE_DYNAMIC(CXTPExcelTabCtrl)
105public:
110 CXTPExcelTabCtrl();
111
116 virtual ~CXTPExcelTabCtrl();
117
118public:
132 BOOL SetTheme(XTPControlTheme eTheme);
133
141 CXTPExcelTabCtrlTheme* GetTheme();
142
150 CTabItemArray& GetTabItemArray()
151 {
152 return m_tcbItems;
153 }
154
162 LPCTSTR GetItemText(int nIndex) const;
163
172 bool SetItemText(int nIndex, LPCTSTR pszText);
173
183 CWnd* GetItemWindow(int nIndex) const;
184
191 virtual void SetTabFonts(CFont* pNormFont, CFont* pBoldFont);
192
203 virtual int InsertItem(int nItem, UINT nTextID, CWnd* pWndControl = NULL);
204
215 virtual int InsertItem(int nItem, LPCTSTR lpszItem, CWnd* pWndControl = NULL);
216
225 virtual BOOL DeleteItem(int nItem);
226
233 virtual BOOL DeleteAllItems();
234
244 virtual BOOL GetItemRect(int nItem, LPRECT lpRect);
245
257 virtual int HitTest(TCHITTESTINFO* pHitTestInfo) const;
258
267 virtual int GetCurSel() const;
268
277 virtual int SetCurSel(int nItem);
278
286 virtual int GetItemCount() const;
287
295 virtual void SetTipText(int nItem, LPCTSTR lpszTabTip);
296
306 virtual CString GetTipText(int nItem);
307
313 virtual void Home();
314
324 void SetGripperPosition(int nPos, bool bPercent);
325
334 int GetGripperPosition() const;
335
348 void SyncScrollBar();
349
355 void SetTabShadowColor(COLORREF crShadow);
356
364 COLORREF GetTabShadowColor() const;
365
371 void SetTabHighlightColor(COLORREF crHighlight);
372
374 _XTP_DEPRECATED_IN_FAVOR(SetTabHighlightColor)
375 void SetTabHilightColor(COLORREF crHighlight)
376 {
377 SetTabHighlightColor(crHighlight);
378 }
388 COLORREF GetTabHighlightColor() const;
389
391 _XTP_DEPRECATED_IN_FAVOR(GetTabHighlightColor)
392 COLORREF GetTabHilightColor() const
393 {
394 return GetTabHighlightColor();
395 }
404 void SetTabBackColor(COLORREF crBack);
405
413 void SetTabBackColor(int nIndex, COLORREF crBack);
414
423 COLORREF GetTabBackColor() const;
424
434 COLORREF GetTabBackColor(int nIndex) const;
435
443 void SetTabTextColor(COLORREF crText);
444
453 void SetTabTextColor(int nIndex, COLORREF crText);
454
463 COLORREF GetTabTextColor() const;
464
474 COLORREF GetTabTextColor(int nIndex) const;
475
483 void SetSelTabBackColor(COLORREF crBack);
484
493 void SetSelTabBackColor(int nIndex, COLORREF crBack);
494
503 COLORREF GetSelTabBackColor() const;
504
514 COLORREF GetSelTabBackColor(int nIndex) const;
515
523 void SetSelTabTextColor(COLORREF crText);
524
533 void SetSelTabTextColor(int nIndex, COLORREF crText);
534
543 COLORREF GetSelTabTextColor() const;
544
554 COLORREF GetSelTabTextColor(int nIndex) const;
555
561 void UpdateDefaultColors();
562
575 virtual CScrollBar* GetScrollBarCtrl(int nBar) const;
576
586 CRect GetTabsRect();
587
598 CFont* GetTabFont(BOOL bBold);
599
614 DWORD GetTabStyle();
615
628 void SetTabStyle(DWORD dwStyle);
629
701 virtual BOOL Create(DWORD dwStyle, const CRect& rect, CWnd* pParentWnd, UINT nID);
702
710 void SetTabHeight(int iTabHeight);
711
719 int GetTabHeight() const;
720
721protected:
731 virtual int ButtonHitTest(CPoint& pt);
732
741 int GetTabWidth(int nItem) const;
742
750 int GetTotalTabWidth() const;
751
759 int GetTotalArrowWidth() const;
760
768 int GetTotalTabAreaWidth() const;
769
774 void InvalidateTabs();
775
781 void EnableButtons();
782
788 void FreeButtonIcons();
789
795 void CreateButtonIcons();
796
804 void DrawGripper(CDC* pDC, CRect rect) const;
805
812 void SetTracking(bool bTracking);
813
818 void ClearAllItems();
819
826 virtual void RecalcLayout();
827
835 virtual BOOL _DeleteItem(int nItem);
836
843 virtual int GetOverlap() const;
844
850 void ResetMouseOver();
851
858 CRect GetTotalButtonRect() const;
859
860protected:
868 virtual BOOL Init();
869
875 virtual void RefreshMetrics();
876
878 DECLARE_MESSAGE_MAP()
879
880 //{{AFX_VIRTUAL(CXTPExcelTabCtrl)
881 virtual BOOL PreTranslateMessage(MSG* pMsg);
882 virtual BOOL OnNotify(WPARAM, LPARAM lParam, LRESULT* pResult);
883 virtual BOOL OnWndMsg(UINT message, WPARAM wParam, LPARAM lParam, LRESULT* pResult);
884 virtual void PreSubclassWindow();
885 virtual BOOL PreCreateWindow(CREATESTRUCT& cs);
886 //}}AFX_VIRTUAL
887
888 //{{AFX_MSG(CXTPExcelTabCtrl)
889 afx_msg int OnCreate(LPCREATESTRUCT lpCreateStruct);
890 afx_msg void OnPaint();
891 void OnDraw(CDC* pDC);
892 afx_msg LRESULT OnPrintClient(WPARAM wParam, LPARAM);
893 afx_msg BOOL OnEraseBkgnd(CDC* pDC);
894 afx_msg void OnLeftArrow();
895 afx_msg void OnRightArrow();
896 afx_msg void OnHomeArrow();
897 afx_msg void OnEndArrow();
898 afx_msg void OnSize(UINT nType, int cx, int cy);
899 afx_msg void OnLButtonDown(UINT nFlags, CPoint point);
900 afx_msg void OnMouseMove(UINT nFlags, CPoint point);
901 afx_msg BOOL OnSetCursor(CWnd* pWnd, UINT nHitTest, UINT message);
902 afx_msg void OnLButtonUp(UINT nFlags, CPoint point);
903 afx_msg void OnLButtonDblClk(UINT nFlags, CPoint point);
904 afx_msg void OnHScroll(UINT nSBCode, UINT nPos, CScrollBar* pScrollBar);
905 afx_msg void OnTimer(UINT_PTR nIDEvent);
906 //}}AFX_MSG
907 afx_msg LRESULT OnSetTheme(WPARAM wParam, LPARAM lParam);
910private:
911 BOOL Create(LPCTSTR lpszClassName, LPCTSTR lpszWindowName, DWORD dwStyle, const RECT& rect,
912 CWnd* pParentWnd, UINT nID, CCreateContext* pContext = NULL);
913
914protected:
915 int m_cx;
916 int m_cy;
917 int m_nCurSel;
918 int m_nClientWidth;
919 int m_nClientHeight;
920 int m_nOffset;
921 int m_xGripperPos;
922 int m_iGripperPosPerCent;
923 int m_xTrackingDelta;
924 int m_iBtnLeft;
925 int m_iBtnRight;
926 int m_iBtnHome;
927 int m_iBtnEnd;
928 int m_iBtnHilight;
929 int m_iTabHeight;
931 bool m_bTracking;
932 bool m_bManagingViews;
933 bool m_bUserColors;
934 bool m_bPainted;
937 DWORD m_dwStyle;
938 CWnd* m_pWndLastFocus;
939 CRect m_rectTabs;
940 CRect m_rectViews;
941 CRect m_rectSB_H;
942 CRect m_rectGripper;
944 CFont* m_pNormFont;
945 CFont* m_pBoldFont;
947 CXTPScrollBar m_wndHScrollBar;
948 CToolTipCtrl m_ToolTip;
949 CXTPExcelTabCtrlButtonState m_buttons[4];
950 CTabItemArray m_tcbItems;
951 CXTPExcelTabCtrlTheme* m_pTheme;
952 BOOL m_bSubclassed;
953};
954
956
957AFX_INLINE BOOL CXTPExcelTabCtrl::Create(LPCTSTR lpszClassName, LPCTSTR lpszWindowName,
958 DWORD dwStyle, const RECT& rect, CWnd* pParentWnd,
959 UINT nID, CCreateContext* pContext)
960{
961 return CWnd::Create(lpszClassName, lpszWindowName, dwStyle, rect, pParentWnd, nID, pContext);
962}
963AFX_INLINE int CXTPExcelTabCtrl::GetCurSel() const
964{
965 _ASSERTE(IsWindow(m_hWnd));
966 return m_nCurSel;
967}
968AFX_INLINE int CXTPExcelTabCtrl::GetItemCount() const
969{
970 _ASSERTE(IsWindow(m_hWnd));
971 int iItemCount = (int)m_tcbItems.GetSize();
972 return iItemCount;
973}
974AFX_INLINE void CXTPExcelTabCtrl::SetTabFonts(CFont* pNormFont, CFont* pBoldFont)
975{
976 if (pNormFont)
977 {
978 m_pNormFont = pNormFont;
979 }
980 if (pBoldFont)
981 {
982 m_pBoldFont = pBoldFont;
983 }
984}
985AFX_INLINE DWORD CXTPExcelTabCtrl::GetTabStyle()
986{
987 return m_dwStyle;
988}
989AFX_INLINE CRect CXTPExcelTabCtrl::GetTabsRect()
990{
991 return m_rectTabs;
992}
993AFX_INLINE CFont* CXTPExcelTabCtrl::GetTabFont(BOOL bBold)
994{
995 return bBold ? m_pBoldFont : m_pNormFont;
996}
997AFX_INLINE CXTPExcelTabCtrlTheme* CXTPExcelTabCtrl::GetTheme()
998{
999 return m_pTheme;
1000}
1002const DWORD FTS_XTP_BOTTOM = 0x0001;
1003const DWORD FTS_XTP_HASARROWS = 0x0002;
1004const DWORD FTS_XTP_HASHOMEEND = 0x0004;
1005const DWORD FTS_XTP_TOOLTIPS = 0x0008;
1006const DWORD FTS_XTP_DEFAULT = 0x000F;
1007const DWORD FTS_XTP_HSCROLL = 0x0010;
1008const DWORD FTS_XTP_SQUARETABS = 0X0020;
1009const DWORD FTS_XTP_MASK = 0x003F;
1011# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
1013#endif // #if !defined(__XTPEXCELTABCTRL_H__)
XTPControlTheme
XTPControlTheme
Enumeration used to determine the active theme style.
Definition XTPControlTheme.h:43
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPArrowIcon
XTPArrowIcon
Enumeration used to determine arrow button display.
Definition XTPExcelTabCtrl.h:48
xtpArrowIconRight
@ xtpArrowIconRight
Right arrow display.
Definition XTPExcelTabCtrl.h:51
xtpArrowIconLeft
@ xtpArrowIconLeft
Left arrow display.
Definition XTPExcelTabCtrl.h:49
xtpArrowIconRightHome
@ xtpArrowIconRightHome
Right home arrow display.
Definition XTPExcelTabCtrl.h:52
xtpArrowIconLeftHome
@ xtpArrowIconLeftHome
Left home arrow display.
Definition XTPExcelTabCtrl.h:50
FTS_XTP_DEFAULT
const DWORD FTS_XTP_DEFAULT
Definition XTPExcelTabCtrl.h:1006
FTS_XTP_BOTTOM
const DWORD FTS_XTP_BOTTOM
Definition XTPExcelTabCtrl.h:1002
FTS_XTP_MASK
const DWORD FTS_XTP_MASK
Definition XTPExcelTabCtrl.h:1009
FTS_XTP_HSCROLL
const DWORD FTS_XTP_HSCROLL
Definition XTPExcelTabCtrl.h:1007
FTS_XTP_HASHOMEEND
const DWORD FTS_XTP_HASHOMEEND
Definition XTPExcelTabCtrl.h:1004
FTS_XTP_SQUARETABS
const DWORD FTS_XTP_SQUARETABS
Definition XTPExcelTabCtrl.h:1008
FTS_XTP_TOOLTIPS
const DWORD FTS_XTP_TOOLTIPS
Definition XTPExcelTabCtrl.h:1005
FTS_XTP_HASARROWS
const DWORD FTS_XTP_HASARROWS
Definition XTPExcelTabCtrl.h:1003
CXTPExcelTabCtrlButtonState
The CXTPExcelTabCtrlButtonState class is used by the CXTPExcelTabCtrl class to manage navigation butt...
Definition XTPExcelTabCtrl.h:62
CXTPExcelTabCtrlButtonState::m_bEnabled
bool m_bEnabled
true if the button is enabled.
Definition XTPExcelTabCtrl.h:84
CXTPExcelTabCtrlButtonState::SetInfo
void SetInfo(CRect rect, int iCommand, XTPArrowIcon iconType)
This member function is called to initialize the information about the tab control navigation button.
CXTPExcelTabCtrlButtonState::m_bHilight
bool m_bHilight
true if the mouse if hovering.
Definition XTPExcelTabCtrl.h:85
CXTPExcelTabCtrlButtonState::m_bPressed
bool m_bPressed
true if the button is pressed.
Definition XTPExcelTabCtrl.h:83
CXTPExcelTabCtrlButtonState::m_iCommand
int m_iCommand
Button command ID.
Definition XTPExcelTabCtrl.h:82
CXTPExcelTabCtrlButtonState::m_rect
CRect m_rect
Size and location of the button.
Definition XTPExcelTabCtrl.h:86
CXTPExcelTabCtrlButtonState::CXTPExcelTabCtrlButtonState
CXTPExcelTabCtrlButtonState()
Constructs a CXTPExcelTabCtrlButtonState object.
CXTPExcelTabCtrlButtonState::m_IconType
XTPArrowIcon m_IconType
Icon style of the button.
Definition XTPExcelTabCtrl.h:87
CXTPExcelTabCtrl
CXTPExcelTabCtrl is a CWnd derived class.
Definition XTPExcelTabCtrl.h:101
CXTPExcelTabCtrl::SetTabTextColor
void SetTabTextColor(COLORREF crText)
This member function is called to set the default text color for all tabs.
CXTPExcelTabCtrl::GetSelTabTextColor
COLORREF GetSelTabTextColor(int nIndex) const
This member function gets an RGB value that represents the text color for selected tabs.
CXTPExcelTabCtrl::FreeButtonIcons
void FreeButtonIcons()
This member function will free the resources allocated for the icons used by the arrow buttons.
CXTPExcelTabCtrl::ClearAllItems
void ClearAllItems()
This member function frees all memory occupied by the tab items.
CXTPExcelTabCtrl::GetItemCount
virtual int GetItemCount() const
Call this function to retrieve the number of tabs in the tab control.
CXTPExcelTabCtrl::GetTotalTabAreaWidth
int GetTotalTabAreaWidth() const
This member function will calculate the total area width of all the tabs in the flat tab control.
CXTPExcelTabCtrl::GetTheme
CXTPExcelTabCtrlTheme * GetTheme()
Call this member function to get a pointer to the currently selected theme.
CXTPExcelTabCtrl::CXTPExcelTabCtrl
CXTPExcelTabCtrl()
Constructs a CXTPExcelTabCtrl object.
CXTPExcelTabCtrl::GetScrollBarCtrl
virtual CScrollBar * GetScrollBarCtrl(int nBar) const
This method obtains a pointer to the specified sibling scrollbar for the flat tab control.
CXTPExcelTabCtrl::GetTabBackColor
COLORREF GetTabBackColor(int nIndex) const
This member function gets an RGB value that represents the background color of the tab.
CXTPExcelTabCtrl::SetTabHeight
void SetTabHeight(int iTabHeight)
Call this member function to set the height for the tab control.
CXTPExcelTabCtrl::SetSelTabBackColor
void SetSelTabBackColor(COLORREF crBack)
This member function is called to set the selected background color for all tabs.
CXTPExcelTabCtrl::ResetMouseOver
void ResetMouseOver()
Call this member function to remove the highlight from all of the buttons.
CXTPExcelTabCtrl::RecalcLayout
virtual void RecalcLayout()
This member function is called when the tab control is resized.
CXTPExcelTabCtrl::InsertItem
virtual int InsertItem(int nItem, UINT nTextID, CWnd *pWndControl=NULL)
This member function will insert a tab into the flat tab control.
CXTPExcelTabCtrl::DeleteItem
virtual BOOL DeleteItem(int nItem)
This member function will delete the tab specified by 'nItem' from the tab control.
CXTPExcelTabCtrl::GetSelTabBackColor
COLORREF GetSelTabBackColor() const
This member function gets an RGB value that represents the background color for selected tabs.
CXTPExcelTabCtrl::DrawGripper
void DrawGripper(CDC *pDC, CRect rect) const
This member function will draw the horizontal sizing gripper at a specified location.
CXTPExcelTabCtrl::DeleteAllItems
virtual BOOL DeleteAllItems()
This member function will remove all tabs from the tab control.
CXTPExcelTabCtrl::SyncScrollBar
void SyncScrollBar()
Synchronizes the scrollbar with the horizontal scroll position.
CXTPExcelTabCtrl::GetItemText
LPCTSTR GetItemText(int nIndex) const
This member function gets the text of a specific tab.
CXTPExcelTabCtrl::HitTest
virtual int HitTest(TCHITTESTINFO *pHitTestInfo) const
Call this function to determine which tab, if any, is at the specified screen position.
CXTPExcelTabCtrl::SetCurSel
virtual int SetCurSel(int nItem)
This member function selects a tab in a flat tab control.
CXTPExcelTabCtrl::SetTracking
void SetTracking(bool bTracking)
The member function is used internally to toggle the state of the sizing-grip tracking mode.
CXTPExcelTabCtrl::SetTipText
virtual void SetTipText(int nItem, LPCTSTR lpszTabTip)
This member function will set the tooltip for the tab specified by 'nItem'.
CXTPExcelTabCtrl::GetTabBackColor
COLORREF GetTabBackColor() const
This member function gets an RGB value that represents the background color of the tab.
CXTPExcelTabCtrl::SetGripperPosition
void SetGripperPosition(int nPos, bool bPercent)
This member function changes the location of the sizing gripper.
CXTPExcelTabCtrl::SetSelTabTextColor
void SetSelTabTextColor(int nIndex, COLORREF crText)
This member function is called to set the selected text color for all tabs.
CXTPExcelTabCtrl::SetTheme
BOOL SetTheme(XTPControlTheme eTheme)
Call this member to switch the visual theme of the control.
CXTPExcelTabCtrl::GetGripperPosition
int GetGripperPosition() const
This member function gets the location of the sizing gripper in pixels relative to the left-hand side...
CXTPExcelTabCtrl::GetTabStyle
DWORD GetTabStyle()
Retrieves the FTS_XTP_ styles that are currently in use for the flat tab control.
CXTPExcelTabCtrl::Init
virtual BOOL Init()
This member function is called by the CXTPExcelTabCtrl class to perform initialization when the windo...
CXTPExcelTabCtrl::GetSelTabTextColor
COLORREF GetSelTabTextColor() const
This member function gets an RGB value that represents the text color for selected tabs.
CXTPExcelTabCtrl::GetTabShadowColor
COLORREF GetTabShadowColor() const
This member function gets an RGB value that represents the shadow color of the tab.
CXTPExcelTabCtrl::GetTabHighlightColor
COLORREF GetTabHighlightColor() const
This member function gets an RGB value that represents the highlight color of the tab.
CXTPExcelTabCtrl::SetTabBackColor
void SetTabBackColor(int nIndex, COLORREF crBack)
This member function is called to set the default background color for the specified tab located at '...
CXTPExcelTabCtrl::GetOverlap
virtual int GetOverlap() const
This internal function calculates the overlap between two tabs.
CXTPExcelTabCtrl::SetItemText
bool SetItemText(int nIndex, LPCTSTR pszText)
This member function will set the text for a particular tab.
CXTPExcelTabCtrl::SetTabHighlightColor
void SetTabHighlightColor(COLORREF crHighlight)
This member function is called to set the highlight color for all tabs.
CXTPExcelTabCtrl::GetTotalButtonRect
CRect GetTotalButtonRect() const
Call this member function to get the dimensions of the rectangle that encompasses all of the buttons.
CXTPExcelTabCtrl::GetTabFont
CFont * GetTabFont(BOOL bBold)
Retrieves the tab font.
CXTPExcelTabCtrl::GetTipText
virtual CString GetTipText(int nItem)
This member function will get the tooltip text associated with the tab specified by 'nItem'.
CXTPExcelTabCtrl::SetTabShadowColor
void SetTabShadowColor(COLORREF crShadow)
This member function is called to set the shadow color for all tabs.
CXTPExcelTabCtrl::GetTotalTabWidth
int GetTotalTabWidth() const
This member function will calculate the total width of all the tabs in the flat tab control.
CXTPExcelTabCtrl::GetSelTabBackColor
COLORREF GetSelTabBackColor(int nIndex) const
This member function gets an RGB value that represents the background color for selected tabs.
CXTPExcelTabCtrl::GetTabTextColor
COLORREF GetTabTextColor() const
This member function gets an RGB value that represents the text color of the tab.
CXTPExcelTabCtrl::SetTabTextColor
void SetTabTextColor(int nIndex, COLORREF crText)
This member function is called to set the default text color for all tabs.
CXTPExcelTabCtrl::SetTabBackColor
void SetTabBackColor(COLORREF crBack)
This member function is called to set the default background color for all tabs.
CXTPExcelTabCtrl::GetItemRect
virtual BOOL GetItemRect(int nItem, LPRECT lpRect)
This member function will retrieve the size of the tab specified by 'nItem'.
CXTPExcelTabCtrl::GetTotalArrowWidth
int GetTotalArrowWidth() const
This member function will calculate the total width of all the arrow buttons that are visible in the ...
CXTPExcelTabCtrl::GetCurSel
virtual int GetCurSel() const
Call this function to retrieve the currently selected tab in a flat tab control.
CXTPExcelTabCtrl::EnableButtons
void EnableButtons()
This member function will enable/disable the arrow buttons depending on the current tab display state...
CXTPExcelTabCtrl::_DeleteItem
virtual BOOL _DeleteItem(int nItem)
This internal function deletes an item from the tab item list.
CXTPExcelTabCtrl::CreateButtonIcons
void CreateButtonIcons()
This member function will create the icon resources that are used by the arrow buttons.
CXTPExcelTabCtrl::InsertItem
virtual int InsertItem(int nItem, LPCTSTR lpszItem, CWnd *pWndControl=NULL)
This member function will insert a tab into the flat tab control.
CXTPExcelTabCtrl::GetTabWidth
int GetTabWidth(int nItem) const
This member function will get the width in pixels of the tab specified by 'nItem'.
CXTPExcelTabCtrl::GetTabItemArray
CTabItemArray & GetTabItemArray()
Call this member function to retrieve a reference to the tab item array.
Definition XTPExcelTabCtrl.h:150
CXTPExcelTabCtrl::SetSelTabBackColor
void SetSelTabBackColor(int nIndex, COLORREF crBack)
This member function is called to set the selected background color for all tabs.
CXTPExcelTabCtrl::SetTabFonts
virtual void SetTabFonts(CFont *pNormFont, CFont *pBoldFont)
This member function will set the fonts to be used by the tab control.
CXTPExcelTabCtrl::GetItemWindow
CWnd * GetItemWindow(int nIndex) const
This member function gets a CWnd pointer to the window that is associated with a specific tab.
CXTPExcelTabCtrl::SetSelTabTextColor
void SetSelTabTextColor(COLORREF crText)
This member function is called to set the selected text color for all tabs.
CXTPExcelTabCtrl::RefreshMetrics
virtual void RefreshMetrics()
Call this member function to refresh theme colors and redraw the control.
CXTPExcelTabCtrl::GetTabsRect
CRect GetTabsRect()
Retrieves the area occupied by the tabs.
CXTPExcelTabCtrl::GetTabHeight
int GetTabHeight() const
Call this member function to retrieve the current height in pixels for the tab control.
CXTPExcelTabCtrl::SetTabStyle
void SetTabStyle(DWORD dwStyle)
Sets the FTS_XTP_ styles for a flat tab control.
CXTPExcelTabCtrl::InvalidateTabs
void InvalidateTabs()
This member function will force all of the tabs to be repainted.
CXTPExcelTabCtrl::~CXTPExcelTabCtrl
virtual ~CXTPExcelTabCtrl()
Destroys a CXTPExcelTabCtrl object, handles cleanup and deallocation.
CXTPExcelTabCtrl::Create
virtual BOOL Create(DWORD dwStyle, const CRect &rect, CWnd *pParentWnd, UINT nID)
Creates a flat tab control and attaches it to an instance of a CXTPExcelTabCtrl object.
CXTPExcelTabCtrl::GetTabTextColor
COLORREF GetTabTextColor(int nIndex) const
This member function gets an RGB value that represents the text color of the tab.
CXTPExcelTabCtrl::Home
virtual void Home()
This member function will cause the tab control to reposition the tabs to the home position.
CXTPExcelTabCtrl::ButtonHitTest
virtual int ButtonHitTest(CPoint &pt)
Call this function to determine which button, if any, is at the specified screen position.
CXTPExcelTabCtrl::UpdateDefaultColors
void UpdateDefaultColors()
Call this member function to reset the tab control to use default system colors.
CXTPExcelTabCtrlTheme
CXTPExcelTabCtrlTheme is used to draw the CXTPExcelTabCtrl object.
Definition XTPExcelTabCtrlTheme.h:43
CXTPScrollBar
Scrollbar control.
Definition XTPScrollBar.h:44


Toolkit Pro: Member List

CXTPFont Member List

This is the complete list of members for CXTPFont, including all inherited members.

__declspec(property(get=GetSafeHandle)) HGDIOBJ m_hObject | CXTPGdiObject |
CreateFont(int nHeight, int nWidth, int nEscapement, int nOrientation, int nWeight, BYTE bItalic, BYTE bUnderline, BYTE cStrikeOut, BYTE nCharSet, BYTE nOutPrecision, BYTE nClipPrecision, BYTE nQuality, BYTE nPitchAndFamily, LPCTSTR lpszFacename) | CXTPFont |
CreateFontIndirect(const LOGFONT *lpLogFont) | CXTPFont |
CreatePointFont(int nPointSize, LPCTSTR lpszFaceName, CDC *pDC=NULL) | CXTPFont |
CreatePointFontIndirect(const LOGFONT *lpLogFont, CDC *pDC=NULL) | CXTPFont |
CreateStockObject(int nIndex) | CXTPGdiObject |
CXTPFont() | CXTPFont |
CXTPGdiObject() | CXTPGdiObject | protected
DeleteObject() | CXTPGdiObject |
GetLogFont(LOGFONT *pLogFont) | CXTPFont |
GetNativeGdiObject() | CXTPFont |
GetNativeGdiObject() const | CXTPFont |
GetObject(int nCount, LPVOID lpObject) const | CXTPGdiObject |
GetObjectType() const | CXTPGdiObject |
GetSafeHandle() const | CXTPGdiObject |
IsHandleOwnershipGuaranteed() const | CXTPGdiObject |
operator CFont &() | CXTPFont |
operator CGdiObject &() | CXTPGdiObject |
operator const CFont &() const | CXTPFont |
operator const CGdiObject &() const | CXTPGdiObject |
operator HFONT() const | CXTPFont |
operator HGDIOBJ() const | CXTPGdiObject |
operator!=(const CXTPGdiObject &obj) const | CXTPGdiObject |
operator==(const CXTPGdiObject &obj) const | CXTPGdiObject |
SetHandleOwnershipNotGuaranteed() | CXTPGdiObject |
~CXTPFont() | CXTPFont |
~CXTPGdiObject()=0 | CXTPGdiObject | pure virtual


Toolkit Pro: XTPControlEdit.h Source File

  • Source
  • CommandBars
XTPControlEdit.h
Go to the documentation of this file.
1
23#if !defined(__XTPCONTOLEDIT_H__)
24# define __XTPCONTOLEDIT_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPControlEdit;
34class CXTPControlComboBoxAutoCompleteWnd;
35
36const UINT XTP_FN_SPINUP = 0x1008;
37const UINT XTP_FN_SPINDOWN = 0x1009;
38const UINT XTP_FN_BUDDYBUTTONCLICK = 0x100A;
40struct NMXTPUPDOWN : public NMXTPCONTROL
41{
42 int iDelta;
43};
44
47# ifndef SHACF_DEFAULT
48# define SHACF_FILESYSTEM \
49 0x00000001
51# define SHACF_URLALL \
52 (SHACF_URLHISTORY \
53 | SHACF_URLMRU)
55# define SHACF_URLHISTORY 0x00000002
56# define SHACF_URLMRU 0x00000004
57# define SHACF_FILESYS_ONLY \
58 0x00000010
60# define SHACF_USETAB \
61 0x00000008
63# endif
64
71class _XTP_EXT_CLASS CXTPCommandBarEditCtrl : public CEdit
72{
73private:
74 class _XTP_EXT_CLASS CRichEditContext
75 {
76 public:
77 CRichEditContext();
78 ~CRichEditContext();
79
80 public:
81 HINSTANCE m_hInstance;
82 CString m_strClassName;
83 BOOL m_bRichEdit2;
84 };
86 DECLARE_DYNCREATE(CXTPCommandBarEditCtrl)
88public:
93 CXTPCommandBarEditCtrl();
94
109 virtual BOOL OnCmdMsg(UINT nID, int nCode, void* pExtra, AFX_CMDHANDLERINFO* pHandlerInfo);
110
127 virtual BOOL OnCommand(WPARAM wParam, LPARAM lParam);
128
137 virtual BOOL ShowContextMenu(CXTPControl* pControl, CPoint point);
138
147 virtual BOOL CreateEdit(DWORD dwStyle, CWnd* pParentWnd);
148
158 BOOL IsDialogCode(UINT nChar, LPARAM lParam);
159
165 void GetWindowTextEx(CString& rString);
166
172 void SetWindowTextEx(LPCTSTR lpszString);
173
180 BOOL IsImeMode() const;
181
182protected:
188 CRichEditContext& GetRichEditContext();
189
190protected:
198 BOOL IsCommandEnabled(UINT nID);
199
201 DECLARE_MESSAGE_MAP()
202
203 //{{AFX_MSG(CXTPCommandBarEditCtrl)
204 afx_msg void OnImeStartComposition();
205 afx_msg void OnImeEndComposition();
206 afx_msg void OnKillFocus(CWnd* pNewWnd);
207 afx_msg void OnPaint();
208 //}}AFX_MSG
211protected:
212 BOOL m_bImeMode;
213 BOOL m_bComposited;
214 BOOL m_bIgonoreEditChanged;
215};
216
221class _XTP_EXT_CLASS CXTPControlEditCtrl : public CXTPCommandBarEditCtrl
222{
223public:
224 CXTPControlEditCtrl();
225
232 CXTPControlEdit* GetControlEdit() const;
233
234protected:
239 void UpdateCharFormat();
240
241protected:
243 DECLARE_MESSAGE_MAP()
244
245 //{{AFX_MSG(CXTPControlEditCtrl)
246 afx_msg void OnSetFocus(CWnd* pOldWnd);
247 afx_msg void OnKillFocus(CWnd* pNewWnd);
248 afx_msg void OnMouseMove(UINT nFlags, CPoint point);
249 afx_msg void OnDestroy();
250 afx_msg void OnLButtonDown(UINT nFlags, CPoint point);
251 afx_msg void OnRButtonDown(UINT nFlags, CPoint point);
252 afx_msg void OnContextMenu(CWnd* pWnd, CPoint point);
253 afx_msg void OnKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags);
254 BOOL OnWndMsg(UINT message, WPARAM wParam, LPARAM lParam, LRESULT* pResult);
255 afx_msg LRESULT OnWindowFromPoint(WPARAM, LPARAM);
256 afx_msg void OnEditChanged();
257 afx_msg LRESULT OnEnableDisable(WPARAM, LPARAM);
258 //}}AFX_MSG
261protected:
262 CXTPControlEdit* m_pControl;
264private:
265 friend class CXTPControlEdit;
266};
267
273class _XTP_EXT_CLASS CXTPControlEdit : public CXTPControl
274{
275public:
280 CXTPControlEdit();
281
286 virtual ~CXTPControlEdit();
287
288public:
296 virtual CXTPControlEditCtrl* CreateEditControl();
297
298public:
305 CEdit* GetEditCtrl() const;
306
313 CString GetEditText() const;
314
320 void SetEditText(const CString& strText);
321
333 void SetEditHint(LPCTSTR lpszEditHint);
334
344 CString GetEditHint() const;
345
362 void EnableShellAutoComplete(DWORD dwFlags = SHACF_FILESYSTEM | SHACF_URLALL);
363
369 void ShowLabel(BOOL bShow);
370
377 virtual BOOL IsCaptionVisible() const;
378
385 BOOL IsImageVisible() const;
386
393 BOOL IsLabeled() const;
394
402 void ShowSpinButtons(BOOL bShow = TRUE);
403
412 BOOL IsSpinButtonsVisible() const;
413
421 void ShowBuddyButton(int nButtonId);
422
431 BOOL IsBuddyButtonVisible() const;
432
438 void DoPropExchange(CXTPPropExchange* pPX);
439
444 virtual void OnEnabledChanged();
445
454 DWORD GetEditStyle() const;
455
463 void SetEditStyle(DWORD dwStyle);
464
474 void SetReadOnly(BOOL bReadOnly = TRUE);
475
484 BOOL GetReadOnly() const;
485
493 virtual BOOL Compare(CXTPControl* pOther);
494
503 int GetLabelWidth() const;
504
512 void SetLabelWidth(int nLabelWidth);
513
519 BOOL HasFocus() const;
520
526 virtual void SetFocused(BOOL bFocused);
527
534 virtual BOOL IsFocused() const;
535
542 CRect GetSpinButtonsRect() const;
543
544 CRect GetBuddyButtonRect() const;
545 int GetBuddyButtonId() const;
546
554 virtual void SetHideFlags(DWORD dwFlags);
555
563 virtual void OnActionChanged(int nProperty);
564
572 virtual void OnActionChanging(int nProperty);
573
580 virtual void DrawEditText(CDC* pDC, CRect rcText);
581
590 void SetTextLimit(int nTextLimit);
591
601 int GetTextLimit() const;
602
608 void SetEditIconId(int nId);
609
616 int GetEditIconId() const;
617
625 BOOL SetNumericOnly(BOOL bNumericOnly = TRUE);
626
633 BOOL IsNumericOnly() const;
634
635protected:
643 virtual BOOL IsFocusable() const;
644
649 virtual void OnMouseHover();
650
656 virtual void OnMouseMove(CPoint point);
657
663 virtual void OnSetFocus(CWnd* pOldWnd);
664
669 virtual void OnKillFocus();
670
676 virtual void DeflateEditRect(CRect& rcControl);
677
685 BOOL OnSetSelected(int bSelected);
686
692 void SetRect(CRect rcControl);
693
698 virtual void OnEditChanged();
699
705 virtual CHARFORMAT2 GetDefaultCharFormat();
706
713 void OnClick(BOOL bKeyboard = FALSE, CPoint pt = CPoint(0, 0));
714
719 virtual void OnUnderlineActivate();
720
727 void Copy(CXTPControl* pControl, BOOL bRecursive = FALSE);
728
737 BOOL OnHookKeyDown(UINT nChar, LPARAM lParam);
738
789 virtual void OnCalcDynamicSize(DWORD dwMode);
790
796 void SetParent(CXTPCommandBar* pParent);
797
804 virtual BOOL IsCustomizeResizeAllow() const;
805
814 virtual int GetCustomizeMinWidth() const;
815
821 virtual void OnRemoved();
822
823protected:
825 void _SetEditText(const CString& strText);
826 CString _GetEditText() const;
827 void TrackSpinButton(CPoint pt);
828 void TrackBuddyButton(CPoint pt);
829 virtual void NotifySpinChanged(int increment, int direction);
830 void OnThemeChanged();
831 void ShowHideEditControl();
834protected:
835 CXTPControlEditCtrl* m_pEdit;
836 BOOL m_bLabel;
837 BOOL m_bReadOnly;
838 int m_nLabelWidth;
839 BOOL m_bDelayReposition;
840 BOOL m_bDelayDestroy;
841 CString m_strEditHint;
842 BOOL m_bFocused;
843 CString m_strLastText;
844 mutable CString m_strEditText;
845 mutable BOOL m_bEditChanged;
846 CXTPControlComboBoxAutoCompleteWnd* m_pAutoCompleteWnd;
847 DWORD m_dwShellAutoCompleteFlags;
848 DWORD m_dwEditStyle;
849 BOOL m_bShowSpinButtons;
850 int m_nEditIconId;
851 int m_nTextLimit;
853 int m_nBuddyButtonId;
854 BOOL m_bNumericOnly;
856public:
857# ifdef _XTP_COMMANDBARS_ACTIVEX
860 DECLARE_DISPATCH_MAP()
861 DECLARE_INTERFACE_MAP()
862
863 DECLARE_OLETYPELIB_EX(CXTPControlEdit);
864
865 afx_msg BSTR OleGetText();
866 afx_msg void OleSetText(LPCTSTR str);
867
868 afx_msg int OleGetBuddyButtonId();
869 afx_msg void OleSetBuddyButtonId(int nValue);
870
871 afx_msg HWND OleGetEditHandle();
872 afx_msg BSTR OleGetEditHint();
873 afx_msg DWORD OleGetShellAutoComplete();
874 afx_msg void OleSetShellAutoComplete(DWORD dwShellAutoCompleteFlags);
875
876 afx_msg void OleSetEditIconId(int nId);
877 afx_msg int OleGetEditIconId();
878
879 afx_msg VOID OleSetNumericOnly(BOOL Value);
880 afx_msg BOOL OleGetNumericOnly();
881
882 enum
883 {
884 dispidShowLabel = 50L,
885 dispidWidth = 54L,
886 dispidText = 59L,
887 };
888
890# endif
891 DECLARE_XTP_CONTROL(CXTPControlEdit)
892 friend class CXTPControlEditCtrl;
893};
894
896
897AFX_INLINE CEdit* CXTPControlEdit::GetEditCtrl() const
898{
899 return m_pEdit;
900}
901AFX_INLINE void CXTPControlEdit::SetEditIconId(int nId)
902{
903 if (m_nEditIconId != nId)
904 {
905 m_nEditIconId = nId;
906 RedrawParent();
907 m_bDelayReposition = TRUE;
908 }
909}
910AFX_INLINE int CXTPControlEdit::GetEditIconId() const
911{
912 return m_nEditIconId;
913}
914AFX_INLINE BOOL CXTPControlEdit::IsNumericOnly() const
915{
916 return m_bNumericOnly;
917}
918AFX_INLINE void CXTPControlEdit::ShowLabel(BOOL bShow)
919{
920 SetStyle(bShow ? xtpButtonCaption : xtpButtonAutomatic);
921}
922AFX_INLINE BOOL CXTPControlEdit::IsLabeled() const
923{
924 return IsCaptionVisible();
925}
926AFX_INLINE BOOL CXTPControlEdit::IsCustomizeResizeAllow() const
927{
928 return TRUE;
929}
930AFX_INLINE int CXTPControlEdit::GetCustomizeMinWidth() const
931{
932 return m_nLabelWidth + 10;
933}
934AFX_INLINE CXTPControlEdit* CXTPControlEditCtrl::GetControlEdit() const
935{
936 return m_pControl;
937}
938AFX_INLINE int CXTPControlEdit::GetLabelWidth() const
939{
940 return m_nLabelWidth;
941}
942AFX_INLINE void CXTPControlEdit::SetLabelWidth(int nLabelWidth)
943{
944 if (m_nLabelWidth != nLabelWidth)
945 {
946 m_nLabelWidth = nLabelWidth;
947 m_bDelayReposition = TRUE;
948 }
949}
951AFX_INLINE void CXTPControlEdit::OnThemeChanged()
952{
953 m_bDelayReposition = TRUE;
954}
956AFX_INLINE void CXTPControlEdit::ShowSpinButtons(BOOL bShow)
957{
958 if (m_bShowSpinButtons != bShow)
959 {
960 m_bShowSpinButtons = bShow;
961 m_bDelayReposition = TRUE;
962 DelayLayoutParent();
963 }
964}
965AFX_INLINE BOOL CXTPControlEdit::IsSpinButtonsVisible() const
966{
967 return m_bShowSpinButtons;
968}
969
970AFX_INLINE void CXTPControlEdit::ShowBuddyButton(int nBuddyButtonId)
971{
972 if (m_nBuddyButtonId != nBuddyButtonId)
973 {
974 m_nBuddyButtonId = nBuddyButtonId;
975 m_bDelayReposition = TRUE;
976 DelayLayoutParent();
977 }
978}
979AFX_INLINE BOOL CXTPControlEdit::IsBuddyButtonVisible() const
980{
981 return m_nBuddyButtonId > 0;
982}
983AFX_INLINE BOOL CXTPControlEdit::GetBuddyButtonId() const
984{
985 return m_nBuddyButtonId;
986}
988# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
989#endif //#if !defined(__XTPCONTOLEDIT_H__)
xtpButtonAutomatic
@ xtpButtonAutomatic
Automatic style.
Definition XTPCommandBarsDefines.h:199
xtpButtonCaption
@ xtpButtonCaption
Button draw only caption.
Definition XTPCommandBarsDefines.h:200
DECLARE_XTP_CONTROL
#define DECLARE_XTP_CONTROL(class_name)
This macro generates the C++ header code necessary for a CXTPControl-derived class that can be serial...
Definition XTPCommandBarsDefines.h:1169
XTP_FN_SPINUP
const UINT XTP_FN_SPINUP
Button is spinning up.
Definition XTPControlEdit.h:36
XTP_FN_SPINDOWN
const UINT XTP_FN_SPINDOWN
Button is spinning down.
Definition XTPControlEdit.h:37
XTP_FN_BUDDYBUTTONCLICK
const UINT XTP_FN_BUDDYBUTTONCLICK
Buddy button down.
Definition XTPControlEdit.h:38
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCommandBarEditCtrl
CXTPCommandBarEditCtrl is a CEdit derived class.
Definition XTPControlEdit.h:72
CXTPCommandBarEditCtrl::OnCmdMsg
virtual BOOL OnCmdMsg(UINT nID, int nCode, void *pExtra, AFX_CMDHANDLERINFO *pHandlerInfo)
Called by the framework to route and dispatch command messages and to handle the update of command us...
CXTPCommandBarEditCtrl::ShowContextMenu
virtual BOOL ShowContextMenu(CXTPControl *pControl, CPoint point)
This member function displays a pop-up context menu.
CXTPCommandBarEditCtrl::IsCommandEnabled
BOOL IsCommandEnabled(UINT nID)
Determines if edit command is enabled.
CXTPCommandBarEditCtrl::GetRichEditContext
CRichEditContext & GetRichEditContext()
Call this method to get rich edit version information.
CXTPCommandBarEditCtrl::OnCommand
virtual BOOL OnCommand(WPARAM wParam, LPARAM lParam)
The framework calls this member function when the user selects an item from a menu,...
CXTPCommandBarEditCtrl::CXTPCommandBarEditCtrl
CXTPCommandBarEditCtrl()
Constructs a CXTPCommandBarEditCtrl object.
CXTPCommandBarEditCtrl::SetWindowTextEx
void SetWindowTextEx(LPCTSTR lpszString)
Sets the window text of edit.
CXTPCommandBarEditCtrl::IsImeMode
BOOL IsImeMode() const
Determines if the Input Method Editor(IME) is being used.
CXTPCommandBarEditCtrl::IsDialogCode
BOOL IsDialogCode(UINT nChar, LPARAM lParam)
This method determines whether the specified character is intended for an edit.
CXTPCommandBarEditCtrl::CreateEdit
virtual BOOL CreateEdit(DWORD dwStyle, CWnd *pParentWnd)
This member function displays a pop-up context menu.
CXTPCommandBarEditCtrl::GetWindowTextEx
void GetWindowTextEx(CString &rString)
Returns window text of edit.
CXTPCommandBar
CXTPCommandBar is a CWnd derived class.
Definition XTPCommandBar.h:66
CXTPControlEditCtrl
Inplace Edit control of CXTPControlEdit.
Definition XTPControlEdit.h:222
CXTPControlEditCtrl::GetControlEdit
CXTPControlEdit * GetControlEdit() const
Retrieves the parent CXTPControlEdit object.
Definition XTPControlEdit.h:934
CXTPControlEditCtrl::UpdateCharFormat
void UpdateCharFormat()
This method is called to refresh the char format of edit control.
CXTPControlEdit
CXTPControlEdit is a CXTPControl derived class.
Definition XTPControlEdit.h:274
CXTPControlEdit::OnEditChanged
virtual void OnEditChanged()
This method is called when edit control's text is changed.
CXTPControlEdit::SetEditText
void SetEditText(const CString &strText)
Call this member to set the edit control text.
CXTPControlEdit::GetLabelWidth
int GetLabelWidth() const
Call this method to get the width of the label.
Definition XTPControlEdit.h:938
CXTPControlEdit::Copy
void Copy(CXTPControl *pControl, BOOL bRecursive=FALSE)
This method is called to copy the control.
CXTPControlEdit::SetRect
void SetRect(CRect rcControl)
Call this member to set the bounding rectangle of the control.
CXTPControlEdit::m_nEditIconId
int m_nEditIconId
Edit Icon identifier.
Definition XTPControlEdit.h:850
CXTPControlEdit::SetParent
void SetParent(CXTPCommandBar *pParent)
This method is called to assign a parent command bar object.
CXTPControlEdit::SetNumericOnly
BOOL SetNumericOnly(BOOL bNumericOnly=TRUE)
Call this member to allow only digits to be entered into the edit control.
CXTPControlEdit::OnActionChanged
virtual void OnActionChanged(int nProperty)
This method is called when an action property is changed.
CXTPControlEdit::DoPropExchange
void DoPropExchange(CXTPPropExchange *pPX)
Either reads this object from or writes this object to an archive.
CXTPControlEdit::OnSetFocus
virtual void OnSetFocus(CWnd *pOldWnd)
This method is called when the edit control gets focus.
CXTPControlEdit::IsCustomizeResizeAllow
virtual BOOL IsCustomizeResizeAllow() const
This member checks if the user can resize the control.
Definition XTPControlEdit.h:926
CXTPControlEdit::IsImageVisible
BOOL IsImageVisible() const
Determines if the icon is visible for edit control.
CXTPControlEdit::IsLabeled
BOOL IsLabeled() const
Call this member to determine if the control has a visible label.
Definition XTPControlEdit.h:922
CXTPControlEdit::m_dwEditStyle
DWORD m_dwEditStyle
Edit style.
Definition XTPControlEdit.h:848
CXTPControlEdit::SetEditStyle
void SetEditStyle(DWORD dwStyle)
Call this member to set the style of an edit control.
CXTPControlEdit::OnRemoved
virtual void OnRemoved()
This method is called when a control is removed from the parent controls collection.
CXTPControlEdit::m_pAutoCompleteWnd
CXTPControlComboBoxAutoCompleteWnd * m_pAutoCompleteWnd
Auto complete window hook.
Definition XTPControlEdit.h:846
CXTPControlEdit::m_bDelayReposition
BOOL m_bDelayReposition
Need to reposition control.
Definition XTPControlEdit.h:839
CXTPControlEdit::OnHookKeyDown
BOOL OnHookKeyDown(UINT nChar, LPARAM lParam)
This method is called when a non-system key is pressed.
CXTPControlEdit::m_bNumericOnly
BOOL m_bNumericOnly
Allows only digits to be entered into the edit control.
Definition XTPControlEdit.h:854
CXTPControlEdit::IsBuddyButtonVisible
BOOL IsBuddyButtonVisible() const
Call this method to check if the buddy button is visible.
Definition XTPControlEdit.h:979
CXTPControlEdit::m_bFocused
BOOL m_bFocused
TRUE if edit has focus.
Definition XTPControlEdit.h:842
CXTPControlEdit::m_nLabelWidth
int m_nLabelWidth
Width of the label.
Definition XTPControlEdit.h:838
CXTPControlEdit::IsSpinButtonsVisible
BOOL IsSpinButtonsVisible() const
Determines if edit control has spin buttons.
Definition XTPControlEdit.h:965
CXTPControlEdit::SetReadOnly
void SetReadOnly(BOOL bReadOnly=TRUE)
Calls this function to set the read-only state of an edit control.
CXTPControlEdit::OnCalcDynamicSize
virtual void OnCalcDynamicSize(DWORD dwMode)
This method is called before recalculating the parent command bar size to calculate the dimensions of...
CXTPControlEdit::m_bLabel
BOOL m_bLabel
TRUE if label is visible.
Definition XTPControlEdit.h:836
CXTPControlEdit::IsNumericOnly
BOOL IsNumericOnly() const
Call this member to check if only digits can be entered into the edit control.
Definition XTPControlEdit.h:914
CXTPControlEdit::GetEditText
CString GetEditText() const
Call this member to get the edit control text.
CXTPControlEdit::GetEditHint
CString GetEditHint() const
Call this member to get the grayed-out text displayed in the edit control which provides a helpful de...
CXTPControlEdit::DeflateEditRect
virtual void DeflateEditRect(CRect &rcControl)
This method is called to get the real rect of the edit control of CEdit.
CXTPControlEdit::CreateEditControl
virtual CXTPControlEditCtrl * CreateEditControl()
This method creates an edit control.
CXTPControlEdit::OnMouseHover
virtual void OnMouseHover()
Called after the mouse hovers over the control.
CXTPControlEdit::m_bDelayDestroy
BOOL m_bDelayDestroy
Need to reposition control.
Definition XTPControlEdit.h:840
CXTPControlEdit::SetEditIconId
void SetEditIconId(int nId)
Call this member to set the edit icon's identifier.
Definition XTPControlEdit.h:901
CXTPControlEdit::m_pEdit
CXTPControlEditCtrl * m_pEdit
Inplace edit control.
Definition XTPControlEdit.h:835
CXTPControlEdit::OnUnderlineActivate
virtual void OnUnderlineActivate()
This method is called when the user activates a control using its underline.
CXTPControlEdit::GetReadOnly
BOOL GetReadOnly() const
Call this function to check if an edit control is read-only.
CXTPControlEdit::GetEditCtrl
CEdit * GetEditCtrl() const
Call this member to get the edit control.
Definition XTPControlEdit.h:897
CXTPControlEdit::OnActionChanging
virtual void OnActionChanging(int nProperty)
This method is called when an action property is about to be changed.
CXTPControlEdit::SetHideFlags
virtual void SetHideFlags(DWORD dwFlags)
This method is called to hide the control.
CXTPControlEdit::OnSetSelected
BOOL OnSetSelected(int bSelected)
This method is called when the control becomes selected.
CXTPControlEdit::GetDefaultCharFormat
virtual CHARFORMAT2 GetDefaultCharFormat()
This method is called to get the default char format of rich edit text.
CXTPControlEdit::SetLabelWidth
void SetLabelWidth(int nLabelWidth)
Call this method to set the width of the label.
Definition XTPControlEdit.h:942
CXTPControlEdit::OnClick
void OnClick(BOOL bKeyboard=FALSE, CPoint pt=CPoint(0, 0))
This method is called when the user clicks the control.
CXTPControlEdit::GetCustomizeMinWidth
virtual int GetCustomizeMinWidth() const
This member returns the minimum width that the edit control can be sized to by the user while in cust...
Definition XTPControlEdit.h:930
CXTPControlEdit::m_bReadOnly
BOOL m_bReadOnly
TRUE if edit is read-only.
Definition XTPControlEdit.h:837
CXTPControlEdit::EnableShellAutoComplete
void EnableShellAutoComplete(DWORD dwFlags=SHACF_FILESYSTEM|SHACF_URLALL)
This member function enables or disables shell auto completion.
CXTPControlEdit::GetEditStyle
DWORD GetEditStyle() const
Call this member to get the style of an edit control.
CXTPControlEdit::IsFocusable
virtual BOOL IsFocusable() const
This method is called to check if a control can accept focus.
CXTPControlEdit::GetSpinButtonsRect
CRect GetSpinButtonsRect() const
Returns spin buttons' bounding rectangle.
CXTPControlEdit::SetEditHint
void SetEditHint(LPCTSTR lpszEditHint)
Call this member to set the grayed-out text displayed in the edit control which provides a helpful de...
CXTPControlEdit::m_strLastText
CString m_strLastText
Last entered text.
Definition XTPControlEdit.h:843
CXTPControlEdit::OnMouseMove
virtual void OnMouseMove(CPoint point)
This member is called when the mouse cursor moves.
CXTPControlEdit::m_dwShellAutoCompleteFlags
DWORD m_dwShellAutoCompleteFlags
Shell auto complete flags.
Definition XTPControlEdit.h:847
CXTPControlEdit::m_bEditChanged
BOOL m_bEditChanged
TRUE if Edit Text was changed.
Definition XTPControlEdit.h:845
CXTPControlEdit::ShowBuddyButton
void ShowBuddyButton(int nButtonId)
Call this method to show the command (buddy) button for edit control.
Definition XTPControlEdit.h:970
CXTPControlEdit::GetEditIconId
int GetEditIconId() const
Call this member to get the edit icon's identifier.
Definition XTPControlEdit.h:910
CXTPControlEdit::CXTPControlEdit
CXTPControlEdit()
Constructs a CXTPControlEdit object.
CXTPControlEdit::DrawEditText
virtual void DrawEditText(CDC *pDC, CRect rcText)
This method draws the text of a control.
CXTPControlEdit::ShowSpinButtons
void ShowSpinButtons(BOOL bShow=TRUE)
Call this method to show spin buttons for edit control.
Definition XTPControlEdit.h:956
CXTPControlEdit::SetTextLimit
void SetTextLimit(int nTextLimit)
This method sets the maximum text length that the user may enter into an edit control.
CXTPControlEdit::SetFocused
virtual void SetFocused(BOOL bFocused)
Call this member to set the focused state of the control.
CXTPControlEdit::Compare
virtual BOOL Compare(CXTPControl *pOther)
Call this member to compare controls.
CXTPControlEdit::m_nTextLimit
int m_nTextLimit
The maximum number of characters that can be entered into an edit control.
Definition XTPControlEdit.h:851
CXTPControlEdit::~CXTPControlEdit
virtual ~CXTPControlEdit()
Destroys a CXTPControlEdit object, handles cleanup and deallocation.
CXTPControlEdit::IsFocused
virtual BOOL IsFocused() const
Call this member to get the focused state of the control.
CXTPControlEdit::IsCaptionVisible
virtual BOOL IsCaptionVisible() const
Call this member to determine if the caption of the control is visible.
CXTPControlEdit::GetTextLimit
int GetTextLimit() const
This method gets the maximum text length that the user may enter into an edit control.
CXTPControlEdit::OnEnabledChanged
virtual void OnEnabledChanged()
This method is called when control's enabled state is changed.
CXTPControlEdit::m_bShowSpinButtons
BOOL m_bShowSpinButtons
TRUE to show spin buttons.
Definition XTPControlEdit.h:849
CXTPControlEdit::m_strEditText
CString m_strEditText
Edit text.
Definition XTPControlEdit.h:844
CXTPControlEdit::m_strEditHint
CString m_strEditHint
Edit hint of the controls.
Definition XTPControlEdit.h:841
CXTPControlEdit::OnKillFocus
virtual void OnKillFocus()
This method is called when the edit control loses focus.
CXTPControlEdit::HasFocus
BOOL HasFocus() const
Call this method to determine if edit control has focus.
CXTPControlEdit::ShowLabel
void ShowLabel(BOOL bShow)
Call this member to show the label of the control.
Definition XTPControlEdit.h:918
CXTPControl
CXTPControl is a CXTPCmdTarget derived class.
Definition XTPControl.h:841
CXTPControl::OnThemeChanged
virtual void OnThemeChanged()
This method is called when the paint manager theme is changed.
Definition XTPControl.h:2782
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72
NMXTPCONTROL
This structure is passed as a parameter in CBN_XTP_EXECUTE message.
Definition XTPCommandBarsDefines.h:769


Toolkit Pro: Member List

CXTPChartPolylineDeviceCommand Member List

This is the complete list of members for CXTPChartPolylineDeviceCommand, including all inherited members.

AddChildCommand(CXTPChartDeviceCommand *pCommand) | CXTPChartDeviceCommand |
AfterExecute(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
ApplySeriesStyle(CXTPChartSeriesStyle *pStyle) | CXTPChartDeviceCommand | virtual
BeforeExecute(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
BindView(CXTPChartElementView *pView) | CXTPChartDeviceCommand |
Commit() | CXTPChartDeviceCommand |
CXTPChartDeviceCommand() | CXTPChartDeviceCommand |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartPolylineDeviceCommand(const CXTPChartPoints &p, int thickness) | CXTPChartPolylineDeviceCommand | protected
CXTPObservable() | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | protected
Execute(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
ExecuteOverride(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
GetBoundView() const | CXTPChartDeviceCommand |
GetChildCommand(int nIndex) const | CXTPChartDeviceCommand |
GetChildCommandCount() const | CXTPChartDeviceCommand |
GetCurrentDC() const | CXTPChartDeviceCommand |
GetPassNumber() const | CXTPChartDeviceCommand |
HitTest(CPoint point, CXTPChartElement *pParent) const | CXTPChartDeviceCommand | virtual
Is3D() const | CXTPChartObject |
IsCommitted() const | CXTPChartDeviceCommand |
IsEnabled() const | CXTPChartDeviceCommand | virtual
m_arrChildren | CXTPChartDeviceCommand | protected
m_nThickness | CXTPChartPolylineDeviceCommand | protected
m_p | CXTPChartPolylineDeviceCommand | protected
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Prepare(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
PrepareOverride(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
SetEnabled(BOOL bEnabled=TRUE) | CXTPChartDeviceCommand |
Subscribe(CXTPChartDeviceCommandEvents *pObserver, CXTPSubscriptionList< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > *pSubcriptionList=NULL) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > |
Unsubscribe(CXTPChartDeviceCommandEvents *pObserver) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > |
~CXTPChartDeviceCommand() | CXTPChartDeviceCommand | virtual
~CXTPObservable() | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | protected


Toolkit Pro: Member List

CXTPCalendarEventCategoryIDs Member List

This is the complete list of members for CXTPCalendarEventCategoryIDs, including all inherited members.

Add(UINT newElement) | CXTPArrayT< UINT, UINT > | virtual
AddIfNeed(UINT newElement) | CXTPArrayT< UINT, UINT > | virtual
Append(const CXTPArrayT &src) | CXTPArrayT< UINT, UINT > | virtual
Copy(const CXTPArrayT &src) | CXTPArrayT< UINT, UINT > | virtual
CXTPArrayT() | CXTPArrayT< UINT, UINT > |
CXTPCalendarEventCategoryIDs() | CXTPCalendarEventCategoryIDs |
CXTPCmdTarget() | CXTPCmdTarget |
DoPropExchange(CXTPPropExchange *pPX) | CXTPCalendarEventCategoryIDs | virtual
DoPropExchange(CXTPPropExchange *pPX, LPCTSTR pcszSection, LPCTSTR pcszElement) | CXTPCalendarEventCategoryIDs | virtual
ElementAt(int nIndex) | CXTPArrayT< UINT, UINT > | virtual
Find(UINT uID) const | CXTPCalendarUIntArray |
FindElement(UINT nElement) const | CXTPArrayT< UINT, UINT > | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAt(int nIndex) const | CXTPArrayT< UINT, UINT > | virtual
GetData() const | CXTPArrayT< UINT, UINT > | virtual
GetData() | CXTPArrayT< UINT, UINT > | virtual
GetSize() const | CXTPArrayT< UINT, UINT > | virtual
InsertAt(int nIndex, UINT newElement, int nCount=1) | CXTPArrayT< UINT, UINT > | virtual
InsertAt(int nStartIndex, CXTPArrayT *pNewArray) | CXTPArrayT< UINT, UINT > | virtual
LoadFromString(LPCTSTR pcszData) | CXTPCalendarUIntArray | virtual
m_arElements | CXTPArrayT< UINT, UINT > | protected
operator[](int nIndex) const | CXTPArrayT< UINT, UINT > |
operator[](int nIndex) | CXTPArrayT< UINT, UINT > |
RemoveAll() | CXTPArrayT< UINT, UINT > | virtual
RemoveAt(int nIndex, int nCount=1) | CXTPArrayT< UINT, UINT > | virtual
RemoveElement(UINT nElement) | CXTPArrayT< UINT, UINT > | virtual
RemoveID(UINT uID) | CXTPCalendarUIntArray | virtual
SaveToString() const | CXTPCalendarUIntArray | virtual
SetAt(int nIndex, UINT newElement) | CXTPArrayT< UINT, UINT > | virtual
SetAtGrow(int nIndex, UINT newElement) | CXTPArrayT< UINT, UINT > | virtual
SetSize(int nNewSize, int nGrowBy=-1) | CXTPArrayT< UINT, UINT > | virtual
~CXTPArrayT() | CXTPArrayT< UINT, UINT > | virtual
~CXTPCalendarEventCategoryIDs() | CXTPCalendarEventCategoryIDs | virtual


Toolkit Pro: Member List

CXTPResourceManager Member List

This is the complete list of members for CXTPResourceManager, including all inherited members.

Close() | CXTPResourceManager | virtual
CreateIconFromResource(HMODULE hModule, LPCTSTR lpszID, CSize iconSize) | CXTPResourceManager | virtual
CXTPResourceManager() | CXTPResourceManager |
FindResource(HMODULE &hModule, LPCTSTR lpName, LPCTSTR lpType) | CXTPResourceManager |
GetActiveLCID() | CXTPResourceManager |
GetFontCharset() const | CXTPResourceManager |
GetResourceHandle() const | CXTPResourceManager |
GetResourceLanguage(HMODULE hResModule) | CXTPResourceManager | static
GetResourcesLangID() | CXTPResourceManager | virtual
IsIntResource(LPCTSTR lpName, BOOL bTryParse=FALSE) | CXTPResourceManager | static
LoadBitmap(CBitmap *pBitmap, UINT nIDResource) | CXTPResourceManager | virtual
LoadBitmap(CBitmap *pBitmap, LPCTSTR lpszResource) | CXTPResourceManager | virtual
LoadCursor(UINT nIDResource) | CXTPResourceManager | virtual
LoadDialogTemplate(UINT nIDResource) | CXTPResourceManager | virtual
LoadDialogTemplate2(LPCTSTR pszTemplate) | CXTPResourceManager | virtual
LoadHTML(CString *pText, UINT nIDResource) | CXTPResourceManager | virtual
LoadHTML(CString *pText, LPCTSTR pszResource) | CXTPResourceManager | virtual
LoadIcon(LPCTSTR lpszID, CSize iconSize) | CXTPResourceManager | virtual
LoadIcon(int nID, CSize iconSize) | CXTPResourceManager | virtual
LoadMenu(CMenu *lpMenu, UINT nIDResource) | CXTPResourceManager | virtual
LoadString(CString *pString, UINT nIDResource) | CXTPResourceManager | virtual
LoadString(UINT nIDResource, BOOL *pbError=NULL) | CXTPResourceManager | virtual
LoadSVG(CString &svg, UINT nIDResource) | CXTPResourceManager | virtual
LoadToolBar(CToolBar *pToolBar, UINT nIDResource) | CXTPResourceManager | virtual
LoadXAML(CString &xaml, UINT nIDResource) | CXTPResourceManager | virtual
m_bValid | CXTPResourceManager | protected
m_hModXTResource | CXTPResourceManager | protectedstatic
m_hResourceFile | CXTPResourceManager | protected
m_managerInstance | CXTPResourceManager | static
m_pLanguageInfo | CXTPResourceManager | protected
MakeIntResource(LPCTSTR lpName) | CXTPResourceManager | static
OnLoadingFailed() | CXTPResourceManager | protected
SetFontCharset(BYTE nFontCharset) | CXTPResourceManager |
SetResourceFile(const CString &strResourceFile) | CXTPResourceManager |
SetResourceFontCharset(BOOL bResourceCharset=TRUE) | CXTPResourceManager |
SetResourceHandle(HMODULE hModRes) | CXTPResourceManager |
SetResourceManager(CXTPResourceManager *pResourceManager) | CXTPResourceManager |
ShowMessageBox(UINT nIDPrompt, UINT nType=MB_OK) | CXTPResourceManager |
ShowMessageBox(LPCTSTR lpszText, UINT nType=MB_OK) | CXTPResourceManager |
UpdateResourcesLangID() | CXTPResourceManager | protectedvirtual
~CXTPResourceManager() | CXTPResourceManager |


Toolkit Pro: XTPMarkupItalic.h Source File

  • Source
  • Markup
  • Text
XTPMarkupItalic.h
Go to the documentation of this file.
1
23#if !defined(__XTPMARKUPITALIC_H__)
24# define __XTPMARKUPITALIC_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class _XTP_EXT_CLASS CXTPMarkupItalic : public CXTPMarkupSpan
34{
36 DECLARE_MARKUPCLASS(CXTPMarkupItalic)
38protected:
39 CXTPMarkupItalic();
40
42public:
43 DECLARE_DISPATCH_MAP()
44# ifdef _XTP_ACTIVEX
45 DECLARE_INTERFACE_MAP()
46 DECLARE_OLETYPELIB_EX(CXTPMarkupItalic);
47# endif
48
50};
51
52# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
54#endif // !defined(__XTPMARKUPITALIC_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h


Toolkit Pro: XTPGifPreview.h Source File

  • Source
  • Controls
  • Preview
  • Providers
  • GIF
XTPGifPreview.h
Go to the documentation of this file.
1
25#if !defined(__XTPGIFPREVIEW_H__)
26# define __XTPGIFPREVIEW_H__
27
28# if _MSC_VER >= 1000
29# pragma once
30# endif // _MSC_VER >= 1000
31
32# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
33
34namespace Gdiplus
35{
36class Image;
37class PropertyItem;
38} // namespace Gdiplus
39
40class _XTP_EXT_CLASS CXTPGifPreview : public IXTPPreview
41{
42public:
43 explicit CXTPGifPreview(HWND parent);
44 ~CXTPGifPreview();
45
46private:
47 virtual BOOL IsReady() const;
48 virtual BOOL IsAvailable() const;
49 virtual BOOL HasOwnNavigator() const;
50 virtual UINT GetNumberOfPages() const;
51 virtual SIZE GetPreferredPageSize() const;
52 virtual void GoToPage(UINT page);
53 virtual void Draw(HDC dc, SIZE clientSize, RECT updateRect);
54 virtual BOOL OnHostWndMsg(LPMSG msg, LRESULT* result);
55 virtual BOOL SupportsCompositedParent() const;
56 virtual void Activate();
57
58 BOOL InitImage(LPCTSTR pFilePath);
59 BOOL InitImage(IStream* pStream, LPCTSTR pImpliedFileName);
60
61private:
62 friend class CXTPGifPreviewProvider;
63 Gdiplus::Image* m_pPicture;
64 BOOL m_bLoadFinished;
65 BOOL m_bLoadSuccess;
66 ULONG_PTR m_gdiPlusToken;
67 CWnd* m_pHostWindow;
68 UINT_PTR m_nTimerId;
69 BOOL m_bIsPlaying;
70 UINT m_FrameCount;
71 UINT m_iCurrentFrame;
72 GUID* m_pDimensionIDs;
73 Gdiplus::PropertyItem* m_pDelayProperty;
74};
75
76# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
77#endif // #if !defined(__XTPGIFPREVIEW_H__)
78
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPGifPreviewProvider
Provides a preview handler for static and animated GIF files.
Definition XTPGifPreviewProvider.h:41
IXTPPreview
The base interface for a preview handler implementation.
Definition XTPPreviewAbstract.h:40
IXTPPreview::GetNumberOfPages
virtual UINT GetNumberOfPages() const =0
Retrieves the number of pages available for the common page navigator.
IXTPPreview::Draw
virtual void Draw(HDC dc, SIZE clientSize, RECT updateRect)=0
This method is called every time the preview has to draw itself into the available client area.
IXTPPreview::GoToPage
virtual void GoToPage(UINT page)=0
If pages are supported by the preview, then it should cause navigation to the specified page number.
IXTPPreview::OnHostWndMsg
virtual BOOL OnHostWndMsg(LPMSG msg, LRESULT *result)=0
Handles a window message sent to the host preview control.
IXTPPreview::GetPreferredPageSize
virtual SIZE GetPreferredPageSize() const =0
Obtains the preferred page size in pixels if that is required by the preview.
IXTPPreview::SupportsCompositedParent
virtual BOOL SupportsCompositedParent() const =0
Determines if the preview implementation is compatible with composited top level windows (i....
IXTPPreview::IsAvailable
virtual BOOL IsAvailable() const =0
Determines if the preview is available (i.e.
IXTPPreview::IsReady
virtual BOOL IsReady() const =0
Returns TRUE if the handler has attempted and finished loading the preview regardless of the actual l...
IXTPPreview::HasOwnNavigator
virtual BOOL HasOwnNavigator() const =0
Determines if the handler implements its own page navigator.
IXTPPreview::Activate
virtual void Activate()=0
Activate preview.


Toolkit Pro: Member List

CXTPMarqueeCtrlThemeOffice2013 Member List

This is the complete list of members for CXTPMarqueeCtrlThemeOffice2013, including all inherited members.

CXTPMarqueeCtrlPaintManager() | CXTPMarqueeCtrlPaintManager |
CXTPMarqueeCtrlThemeOffice2000() | CXTPMarqueeCtrlThemeOffice2000 |
CXTPMarqueeCtrlThemeOffice2013() | CXTPMarqueeCtrlThemeOffice2013 |
DeflateRect(CDC *pDC, CRect &rcClient) | CXTPMarqueeCtrlPaintManager | protectedvirtual
DrawBackground(CXTPMarqueeCtrl *pWndCtrl, CDC *pDC, CRect &rcClient) | CXTPMarqueeCtrlPaintManager | virtual
DrawChunk(CXTPMarqueeCtrl *pWndCtrl, CDC *pDC, CXTPCompatibleDC &dcChunk, int i, int &x, int &y, int cx, int cy) | CXTPMarqueeCtrlPaintManager | protectedvirtual
DrawMarquee(CXTPMarqueeCtrl *pWndCtrl, CDC *pDC, CRect &rcClient) | CXTPMarqueeCtrlPaintManager | virtual
GetBackColor() | CXTPMarqueeCtrlPaintManager |
GetBarColor() | CXTPMarqueeCtrlPaintManager |
GetBorderColor() | CXTPMarqueeCtrlPaintManager |
m_bUseWinTheme | CXTPMarqueeCtrlPaintManager | protected
m_clr3DHilite | CXTPMarqueeCtrlPaintManager | protected
m_clr3DShadow | CXTPMarqueeCtrlPaintManager | protected
m_clrBack | CXTPMarqueeCtrlPaintManager | protected
m_clrBar | CXTPMarqueeCtrlPaintManager | protected
m_nTheme | CXTPMarqueeCtrlPaintManager | protected
m_winTheme | CXTPMarqueeCtrlPaintManager | protected
RefreshMetrics() | CXTPMarqueeCtrlThemeOffice2013 | virtual
SetBackColor(COLORREF clrNew) | CXTPMarqueeCtrlPaintManager |
SetBarColor(COLORREF clrNew) | CXTPMarqueeCtrlPaintManager |
SetBorderColor(COLORREF clrNew) | CXTPMarqueeCtrlPaintManager |
UseWinThemes(BOOL bUseWinThemes=TRUE) | CXTPMarqueeCtrlPaintManager |
UsingWinThemes(BOOL bCheckReady=FALSE) | CXTPMarqueeCtrlPaintManager |
~CXTPMarqueeCtrlPaintManager() | CXTPMarqueeCtrlPaintManager | virtual


Toolkit Pro: Member List

CXTPPropertyGridDelphiTheme Member List

This is the complete list of members for CXTPPropertyGridDelphiTheme, including all inherited members.

AdjustItemCaptionRect(CXTPPropertyGridItem *pItem, CRect &rcCaption) | CXTPPropertyGridPaintManager | virtual
AdjustItemValueRect(CXTPPropertyGridItem *pItem, CRect &rcValue) | CXTPPropertyGridPaintManager | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPPropertyGridDelphiTheme(CXTPPropertyGrid *pGrid) | CXTPPropertyGridDelphiTheme |
CXTPPropertyGridPaintManager(CXTPPropertyGrid *pGrid) | CXTPPropertyGridPaintManager |
DrawCategoryCaptionBackground(CDC *pDC, CXTPPropertyGridItem *pItem, CRect rc) | CXTPPropertyGridPaintManager | virtual
DrawCheckBox(CDC *pDC, CXTPPropertyGridItemBool *pButton) | CXTPPropertyGridPaintManager | virtual
DrawCheckMark(CDC *pDC, CRect rc, BOOL bEnabled, BOOL bChecked) | CXTPPropertyGridPaintManager | virtual
DrawExpandButton(CDC &dc, CXTPPropertyGridItem *pItem, CRect rcCaption) | CXTPPropertyGridPaintManager | virtual
DrawInplaceButtons(CDC *pDC, PDRAWITEMSTRUCT lpDrawItemStruct, CXTPPropertyGridItem *pItem, CRect rcValue) | CXTPPropertyGridPaintManager | virtual
DrawInplaceListItem(CDC *pDC, CXTPPropertyGridItemConstraint *pConstraint, CRect rc, BOOL bSelected) | CXTPPropertyGridPaintManager | virtual
DrawItem(PDRAWITEMSTRUCT lpDrawItemStruct) | CXTPPropertyGridDelphiTheme | virtual
DrawItemCaption(CDC *pDC, CXTPPropertyGridItem *pItem, CRect rcCaption) | CXTPPropertyGridPaintManager | virtual
DrawItemValue(CDC *pDC, CXTPPropertyGridItem *pItem, CRect rcValue) | CXTPPropertyGridPaintManager | virtual
DrawPropertyGridBorder(CDC *pDC, RECT &rcBorder, XTPPropertyGridWindow nWindow) | CXTPPropertyGridPaintManager | virtual
DrawRadioMark(CDC *pDC, CRect rc, BOOL bEnabled, BOOL bChecked) | CXTPPropertyGridPaintManager | virtual
FillInplaceButton(CDC *pDC, CXTPPropertyGridInplaceButton *pButton) | CXTPPropertyGridPaintManager | virtual
FillPropertyGrid(CDC *pDC) | CXTPPropertyGridPaintManager | virtual
FillPropertyGridView(CDC *pDC) | CXTPPropertyGridPaintManager | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetItemBackColor(CXTPPropertyGridItem *pItem, BOOL bValuePart) | CXTPPropertyGridPaintManager | virtual
GetItemFont(CXTPPropertyGridItem *pItem, BOOL bValuePart) | CXTPPropertyGridPaintManager | virtual
GetItemMetrics() const | CXTPPropertyGridPaintManager |
GetItemsBorderHeight() const | CXTPPropertyGridPaintManager | virtual
GetItemTextColor(CXTPPropertyGridItem *pItem, BOOL bValuePart) | CXTPPropertyGridPaintManager | virtual
GetScrollBarTheme() const | CXTPPropertyGridDelphiTheme | virtual
GetSplitterRect(CRect rc, BOOL bIsHelp) | CXTPPropertyGridPaintManager |
HitTestVerbs(CDC *pDC, CRect rcVerbs, CPoint pt) | CXTPPropertyGridPaintManager |
m_bThinSplitter | CXTPPropertyGridPaintManager | protected
m_bTransparent | CXTPPropertyGridPaintManager |
m_buttonsStyle | CXTPPropertyGridPaintManager |
m_clrCategorySeparator | CXTPPropertyGridPaintManager |
m_clrFace | CXTPPropertyGridPaintManager |
m_clrHighlight | CXTPPropertyGridPaintManager |
m_clrHighlightText | CXTPPropertyGridPaintManager |
m_clrNonHighlightBack | CXTPPropertyGridPaintManager |
m_clrNonHighlightText | CXTPPropertyGridPaintManager |
m_clrShadow | CXTPPropertyGridPaintManager |
m_clrSplitter | CXTPPropertyGridPaintManager |
m_nHelpHeight | CXTPPropertyGridPaintManager | protected
m_nItemsBorderHeight | CXTPPropertyGridPaintManager | protected
m_nSplitterHeight | CXTPPropertyGridPaintManager | protected
m_nVerbsHeight | CXTPPropertyGridPaintManager | protected
m_pGrid | CXTPPropertyGridPaintManager | protected
m_pMetrics | CXTPPropertyGridPaintManager | protected
m_themeButton | CXTPPropertyGridPaintManager |
m_themeCombo | CXTPPropertyGridPaintManager |
m_themeTree | CXTPPropertyGridPaintManager |
MeasureItem(LPMEASUREITEMSTRUCT lpMeasureItemStruct) | CXTPPropertyGridPaintManager | virtual
OnNcCalcSize(RECT &rc) | CXTPPropertyGridPaintManager | virtual
RefreshMetrics() | CXTPPropertyGridDelphiTheme | virtual
SetItemsBorderHeight(int nHeight) | CXTPPropertyGridPaintManager | virtual
SetThinSplitter(BOOL bThinSplitter) | CXTPPropertyGridPaintManager | virtual
~CXTPPropertyGridPaintManager() | CXTPPropertyGridPaintManager | virtual


Toolkit Pro: Member List

CXTPEditThemeOffice2003 Member List

This is the complete list of members for CXTPEditThemeOffice2003, including all inherited members.

AdjustBuddyRect(CWnd *pBuddy, CRect &rcUpDown, int nAlignment) | CXTPEditThemeOfficeXP | virtual
CtlColor(CDC *pDC, UINT nCtlColor, CXTPEdit *pEdit) | CXTPEditThemeDefault | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPControlTheme() | CXTPControlTheme |
CXTPEditTheme() | CXTPEditTheme |
CXTPEditThemeDefault() | CXTPEditThemeDefault |
CXTPEditThemeOffice2000() | CXTPEditThemeOffice2000 |
CXTPEditThemeOffice2003() | CXTPEditThemeOffice2003 |
CXTPEditThemeOfficeXP() | CXTPEditThemeOfficeXP |
DrawBuddyBorders(CWnd *pBuddy, CDC *pDC, CRect rc, int nAlignment, CXTPEdit *pEdit) | CXTPEditThemeOfficeXP | virtual
CXTPEditThemeOffice2000::DrawBuddyBorders(CDC *pDC, CRect rc, int nAlignment, CXTPEdit *pEdit) | CXTPEditThemeOffice2000 | virtual
DrawFrame(CDC *pDC, CRect rc, int nSize, CBrush *pBrush) | CXTPEditTheme | virtual
DrawNcBorders(CDC *pDC, CRect rcWnd, CXTPEdit *pEdit) | CXTPEditThemeOfficeXP | virtual
DrawNcBordersDefault(CDC *pDC, CRect rcWnd, CXTPEdit *pEdit) | CXTPEditThemeDefault | protectedvirtual
DrawNcScrollBack(CDC *pDC, CRect rcWnd, CXTPEdit *pEdit) | CXTPEditThemeDefault | virtual
FillRect(CDC *pDC, int x, int y, int cx, int cy, CBrush *pBrush) | CXTPEditTheme | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetClientBrush(CDC *pDC, CXTPEdit *pEdit) | CXTPEditTheme | virtual
GetThemeID() const | CXTPEditTheme |
GetThemeStyle() const | CXTPControlTheme |
IsFlatStyle() const | CXTPEditTheme |
m_bFlatStyle | CXTPEditTheme | protected
m_bUseWinTheme | CXTPEditTheme | protected
m_clrBack | CXTPEditTheme |
m_clrBackNonClient | CXTPEditTheme |
m_clrBorder | CXTPEditTheme |
m_clrBorderDisabled | CXTPEditThemeOfficeXP | protected
m_clrBorderHilite | CXTPEditThemeOfficeXP | protected
m_clrText | CXTPEditTheme |
m_clrTextReadOnly | CXTPEditTheme |
m_nTheme | CXTPEditTheme | protected
m_winTheme | CXTPEditTheme | protected
m_xtpBrushBack | CXTPEditTheme |
RedrawFocusedFrame() const | CXTPEditThemeOfficeXP | virtual
RefreshMetrics(CXTPEdit *pEdit) | CXTPEditThemeOffice2003 | virtual
SetFlatStyle(BOOL bFlatStyle) | CXTPEditTheme |
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static
UseWinTheme(BOOL bUseWinTheme) | CXTPEditTheme |
~CXTPEditTheme() | CXTPEditTheme | virtual
~CXTPEditThemeDefault() | CXTPEditThemeDefault | virtual
~CXTPEditThemeOffice2000() | CXTPEditThemeOffice2000 | virtual
~CXTPEditThemeOffice2003() | CXTPEditThemeOffice2003 | virtual
~CXTPEditThemeOfficeXP() | CXTPEditThemeOfficeXP | virtual


Toolkit Pro: Member List

CXTPSkinManagerMetrics Member List

This is the complete list of members for CXTPSkinManagerMetrics, including all inherited members.

CreateTabControlBrush(CBitmap *pBitmap) | CXTPSkinManagerMetrics |
CXTPSkinManagerMetrics(CXTPSkinManagerSchema *pSchema) | CXTPSkinManagerMetrics |
DestroyMetrics() | CXTPSkinManagerMetrics |
GetAccessCriticalSection() const | CXTPSynchronized | inline
GetBrush(int nIndex) const | CXTPSkinManagerMetrics |
GetColor(int nIndex) const | CXTPSkinManagerMetrics |
IsMetricObject(HGDIOBJ hObject) const | CXTPSkinManagerMetrics |
m_bRefreshMetrics | CXTPSkinManagerMetrics |
m_brTheme | CXTPSkinManagerMetrics |
m_clrEdgeDkShadow | CXTPSkinManagerMetrics |
m_clrEdgeHighLight | CXTPSkinManagerMetrics |
m_clrEdgeLight | CXTPSkinManagerMetrics |
m_clrEdgeShadow | CXTPSkinManagerMetrics |
m_clrTheme | CXTPSkinManagerMetrics |
m_cxBorder | CXTPSkinManagerMetrics |
m_cxEdge | CXTPSkinManagerMetrics |
m_cxHScroll | CXTPSkinManagerMetrics |
m_cxOsVScroll | CXTPSkinManagerMetrics |
m_cxVScroll | CXTPSkinManagerMetrics |
m_cyBorder | CXTPSkinManagerMetrics |
m_cyCaption | CXTPSkinManagerMetrics |
m_cyEdge | CXTPSkinManagerMetrics |
m_cyHScroll | CXTPSkinManagerMetrics |
m_cyOsCaption | CXTPSkinManagerMetrics |
m_cyOsSmallCaption | CXTPSkinManagerMetrics |
m_cySmallCaption | CXTPSkinManagerMetrics |
m_cyVScroll | CXTPSkinManagerMetrics |
m_nBorderSize | CXTPSkinManagerMetrics |
m_pSchema | CXTPSkinManagerMetrics |
m_xtpBrushDialog | CXTPSkinManagerMetrics |
m_xtpBrushTabControl | CXTPSkinManagerMetrics |
m_xtpBrushWindow | CXTPSkinManagerMetrics |
m_xtpFontCaption | CXTPSkinManagerMetrics |
m_xtpFontMenu | CXTPSkinManagerMetrics |
m_xtpFontSmCaption | CXTPSkinManagerMetrics |
RefreshMetrics() | CXTPSkinManagerMetrics | virtual
~CXTPSkinManagerMetrics() | CXTPSkinManagerMetrics | virtual


Toolkit Pro: XTPChartAxisTickMarks.h Source File

  • Source
  • Chart
  • Diagram
  • Axis
XTPChartAxisTickMarks.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTAXISTICKMARKS_H__)
24# define __XTPCHARTAXISTICKMARKS_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartAxis;
34
39class _XTP_EXT_CLASS CXTPChartAxisTickMarks : public CXTPChartElement
40{
41public:
49 CXTPChartAxisTickMarks(CXTPChartAxis* pAxis);
50
55 virtual ~CXTPChartAxisTickMarks();
56
57public:
65 CXTPChartAxis* GetAxis() const;
66
67public:
75 void SetVisible(BOOL bVisible);
76
83 BOOL IsVisible() const;
84
92 void SetMinorVisible(BOOL bVisible);
93
100 BOOL IsMinorVisible() const;
101
108 void SetThickness(int nThickness);
109
116 int GetThickness() const;
117
124 void SetMinorThickness(int nThickness);
125
132 int GetMinorThickness() const;
133
140 void SetLength(int nLength);
141
148 int GetLength() const;
149
156 void SetMinorLength(int nLength);
157
164 int GetMinorLength() const;
165
173 void SetCrossAxis(BOOL bCrossAxis);
174
181 BOOL IsCrossAxis() const;
182
183public:
184 void DoPropExchange(CXTPPropExchange* pPX);
185
186# ifdef _XTP_ACTIVEX
187public:
189 DECLARE_DISPATCH_MAP()
190 DECLARE_INTERFACE_MAP()
191 DECLARE_OLETYPELIB_EX(CXTPChartAxisTickMarks);
193# endif
194
195protected:
196 BOOL m_bVisible;
197 BOOL m_bMinorVisible;
198 int m_nThickness;
199 int m_nMinorThickness;
200 int m_nLength;
201 int m_nMinorLength;
202 BOOL m_bCrossAxis;
203};
204
205AFX_INLINE CXTPChartAxis* CXTPChartAxisTickMarks::GetAxis() const
206{
207 return (CXTPChartAxis*)m_pOwner;
208}
209AFX_INLINE BOOL CXTPChartAxisTickMarks::IsVisible() const
210{
211 return m_bVisible;
212}
213AFX_INLINE BOOL CXTPChartAxisTickMarks::IsMinorVisible() const
214{
215 return m_bMinorVisible;
216}
217AFX_INLINE int CXTPChartAxisTickMarks::GetThickness() const
218{
219 return m_nThickness;
220}
221AFX_INLINE int CXTPChartAxisTickMarks::GetMinorThickness() const
222{
223 return m_nMinorThickness;
224}
225AFX_INLINE int CXTPChartAxisTickMarks::GetLength() const
226{
227 return m_nLength;
228}
229AFX_INLINE int CXTPChartAxisTickMarks::GetMinorLength() const
230{
231 return m_nMinorLength;
232}
233AFX_INLINE BOOL CXTPChartAxisTickMarks::IsCrossAxis() const
234{
235 return m_bCrossAxis;
236}
237AFX_INLINE void CXTPChartAxisTickMarks::SetVisible(BOOL bVisible)
238{
239 m_bVisible = bVisible;
240 OnChartChanged();
241}
242AFX_INLINE void CXTPChartAxisTickMarks::SetMinorVisible(BOOL bVisible)
243{
244 m_bMinorVisible = bVisible;
245 OnChartChanged();
246}
247AFX_INLINE void CXTPChartAxisTickMarks::SetThickness(int nThickness)
248{
249 m_nThickness = nThickness;
250 OnChartChanged();
251}
252AFX_INLINE void CXTPChartAxisTickMarks::SetMinorThickness(int nThickness)
253{
254 m_nMinorThickness = nThickness;
255 OnChartChanged();
256}
257AFX_INLINE void CXTPChartAxisTickMarks::SetLength(int nLength)
258{
259 m_nLength = nLength;
260 OnChartChanged();
261}
262AFX_INLINE void CXTPChartAxisTickMarks::SetMinorLength(int nLength)
263{
264 m_nMinorLength = nLength;
265 OnChartChanged();
266}
267AFX_INLINE void CXTPChartAxisTickMarks::SetCrossAxis(BOOL bCrossAxis)
268{
269 m_bCrossAxis = bCrossAxis;
270 OnChartChanged();
271}
273# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
274#endif //#if !defined(__XTPCHARTAXISTICKMARKS_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartAxis
This abstract base class represents a chart axis as a kind of chart element.
Definition XTPChartAxis.h:86
CXTPChartAxisTickMarks
This class represents the tick marks in an axis.
Definition XTPChartAxisTickMarks.h:40
CXTPChartAxisTickMarks::GetAxis
CXTPChartAxis * GetAxis() const
This function returns a pointer to the CXTPChartAxis object associated with the axis tick mark object...
Definition XTPChartAxisTickMarks.h:205
CXTPChartAxisTickMarks::DoPropExchange
void DoPropExchange(CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
CXTPChartAxisTickMarks::SetCrossAxis
void SetCrossAxis(BOOL bCrossAxis)
Call this function to set the tick marks to cross the axis.
Definition XTPChartAxisTickMarks.h:267
CXTPChartAxisTickMarks::SetVisible
void SetVisible(BOOL bVisible)
Call this function to set the visibility for the axis tick marks.
Definition XTPChartAxisTickMarks.h:237
CXTPChartAxisTickMarks::GetMinorThickness
int GetMinorThickness() const
Call this function to get the thickness of the minor tick marks.
Definition XTPChartAxisTickMarks.h:221
CXTPChartAxisTickMarks::m_nLength
int m_nLength
The length of the tick marks.
Definition XTPChartAxisTickMarks.h:200
CXTPChartAxisTickMarks::m_nMinorThickness
int m_nMinorThickness
The thickness of the minor tick marks.
Definition XTPChartAxisTickMarks.h:199
CXTPChartAxisTickMarks::SetMinorVisible
void SetMinorVisible(BOOL bVisible)
Call this function to set the visibility for the axis minor tick marks.
Definition XTPChartAxisTickMarks.h:242
CXTPChartAxisTickMarks::CXTPChartAxisTickMarks
CXTPChartAxisTickMarks(CXTPChartAxis *pAxis)
Constructs a CXTPChartAxisTickMarks object.
CXTPChartAxisTickMarks::m_bMinorVisible
BOOL m_bMinorVisible
TRUE if the minor tick marks are visible, FALSE if not.
Definition XTPChartAxisTickMarks.h:197
CXTPChartAxisTickMarks::m_nThickness
int m_nThickness
The thickness of the tick marks.
Definition XTPChartAxisTickMarks.h:198
CXTPChartAxisTickMarks::IsVisible
BOOL IsVisible() const
Call this function to check the visibility of the axis tick marks.
Definition XTPChartAxisTickMarks.h:209
CXTPChartAxisTickMarks::GetThickness
int GetThickness() const
Call this function to get the thickness of the tick marks.
Definition XTPChartAxisTickMarks.h:217
CXTPChartAxisTickMarks::SetMinorLength
void SetMinorLength(int nLength)
Call this function to set the length of the minor tick marks.
Definition XTPChartAxisTickMarks.h:262
CXTPChartAxisTickMarks::SetThickness
void SetThickness(int nThickness)
Call this function to set the thickness of the tick marks.
Definition XTPChartAxisTickMarks.h:247
CXTPChartAxisTickMarks::GetLength
int GetLength() const
Call this function to get the length of the tick marks.
Definition XTPChartAxisTickMarks.h:225
CXTPChartAxisTickMarks::m_bCrossAxis
BOOL m_bCrossAxis
TRUE if the tick marks are crossing the axis, FALSE if not.
Definition XTPChartAxisTickMarks.h:202
CXTPChartAxisTickMarks::IsMinorVisible
BOOL IsMinorVisible() const
Call this function to check the visibility of the axis minor tick marks.
Definition XTPChartAxisTickMarks.h:213
CXTPChartAxisTickMarks::SetMinorThickness
void SetMinorThickness(int nThickness)
Call this function to set the thickness of the minor tick marks.
Definition XTPChartAxisTickMarks.h:252
CXTPChartAxisTickMarks::IsCrossAxis
BOOL IsCrossAxis() const
Call this function to check if the tick marks cross the axis.
Definition XTPChartAxisTickMarks.h:233
CXTPChartAxisTickMarks::m_bVisible
BOOL m_bVisible
TRUE if the tick marks are visible, FALSE if not.
Definition XTPChartAxisTickMarks.h:196
CXTPChartAxisTickMarks::~CXTPChartAxisTickMarks
virtual ~CXTPChartAxisTickMarks()
Destroys a CXTPChartAxisTickMarks object, handles cleanup.
CXTPChartAxisTickMarks::GetMinorLength
int GetMinorLength() const
Call this function to get the length of the minor tick marks.
Definition XTPChartAxisTickMarks.h:229
CXTPChartAxisTickMarks::SetLength
void SetLength(int nLength)
Call this function to set the length of the tick marks.
Definition XTPChartAxisTickMarks.h:257
CXTPChartAxisTickMarks::m_nMinorLength
int m_nMinorLength
The length of the minor tick marks.
Definition XTPChartAxisTickMarks.h:201
CXTPChartElement
This class abstracts a chart element, this class acts as a base class for all chart elements.
Definition XTPChartElement.h:131
CXTPChartElement::OnChartChanged
virtual void OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic propertie...
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72


Toolkit Pro: XTPGridView.h Source File

  • Source
  • GridControl
XTPGridView.h
Go to the documentation of this file.
1
23#if !defined(__XTPGRIDVIEW_H__)
24# define __XTPGRIDVIEW_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPGridViewPrintOptions;
34class CXTPGridControl;
35class CXTPGridPaintManager;
36
63const UINT XTP_ID_GRID_CONTROL = 100;
64
72class _XTP_EXT_CLASS CXTPGridView : public CView
73{
75 DECLARE_DYNCREATE(CXTPGridView)
77protected:
82 CXTPGridView();
83
84 BOOL m_bSwitchMode;
85 BOOL m_bShowRowNumber;
86public:
109 void SetTheme(XTPGridPaintTheme paintTheme, BOOL bEnableMetrics = FALSE);
110
117 virtual CXTPGridControl& GetGridCtrl() const;
118
120 _XTP_DEPRECATED_IN_FAVOR(GetGridCtrl)
121 virtual CXTPGridControl& GetReportCtrl() const;
129 void SetGridCtrl(CXTPGridControl* pGrid);
130
132 _XTP_DEPRECATED_IN_FAVOR(SetGridCtrl)
133 void SetReportCtrl(CXTPGridControl* pGrid);
142 CXTPGridPaintManager* GetPaintManager() const;
143
151 CXTPGridViewPrintOptions* GetPrintOptions() const;
152
153protected:
158 virtual ~CXTPGridView();
159
160protected:
177 virtual int PrintPage(CDC* pDC, CPrintInfo* pInfo, CRect rcPage, int nRowFrom, int nColumnFrom,
178 int nColumnTo);
179
195 virtual int PrintGrid(CDC* pDC, CPrintInfo* pInfo, CRect rcPage, int nRowFrom, int nColumnFrom,
196 int nColumnTo);
197
204 virtual void PrintHeader(CDC* pDC, CRect rcHeader);
205
212 virtual void PrintFooter(CDC* pDC, CRect rcFooter);
213
230 virtual int PrintPageHeader(CDC* pDC, CPrintInfo* pInfo, CRect rcPage, BOOL bOnlyCalculate,
231 int nPageNumber, int nNumberOfPages, int nHorizontalPageNumber,
232 int nNumberOfHorizontalPages);
233
250 virtual int PrintPageFooter(CDC* pDC, CPrintInfo* pInfo, CRect rcPage, BOOL bOnlyCalculate,
251 int nPageNumber, int nNumberOfPages, int nHorizontalPageNumber,
252 int nNumberOfHorizontalPages);
253
263 void SetScrollBarCtrl(CScrollBar* pScrollBar, BOOL bHor = FALSE);
264
270 void SetSliderCtrl(CSliderCtrl* pSlider);
271
282 int PrintFixedRowsDivider(CDC* pDC, const CRect& rc, BOOL bHeaderRows);
283
292 int SetupStartCol(CDC* pDC, CPrintInfo* pInfo);
293
302 CScrollBar* GetScrollBarCtrl(int nBar) const;
303
304public:
309 void UpdateScrollBars();
310
311protected:
314# ifdef _DEBUG
315 virtual void AssertValid() const;
316 virtual void Dump(CDumpContext& dc) const;
317# endif
318
319protected:
320 DECLARE_MESSAGE_MAP()
321
322 //{{AFX_VIRTUAL(CXTPGridView)
323 virtual BOOL PaginateTo(CDC* pDC, CPrintInfo* pInfo);
324 virtual BOOL PreCreateWindow(CREATESTRUCT& cs);
325 virtual void OnPrepareDC(CDC* pDC, CPrintInfo* pInfo);
326 virtual void OnDraw(CDC* pDC);
327 virtual BOOL OnPreparePrinting(CPrintInfo* pInfo);
328 virtual void OnBeginPrinting(CDC* pDC, CPrintInfo* pInfo);
329 virtual void OnEndPrinting(CDC* pDC, CPrintInfo* pInfo);
330 virtual void OnPrint(CDC* pDC, CPrintInfo* pInfo);
331 //}}AFX_VIRTUAL
332
333 //{{AFX_MSG(CXTPGridView)
334 afx_msg BOOL OnEraseBkgnd(CDC* pDC);
335 afx_msg void OnSize(UINT nType, int cx, int cy);
336 afx_msg int OnCreate(LPCREATESTRUCT lpCreateStruct);
337 afx_msg void OnSetFocus(CWnd* pOldWnd);
338 afx_msg void OnPaint();
339 afx_msg void OnVScroll(UINT nSBCode, UINT nPos, CScrollBar* pScrollBar);
340 afx_msg void OnHScroll(UINT nSBCode, UINT nPos, CScrollBar* pScrollBar);
341 afx_msg void OnShowWindow(BOOL bShow, UINT nStatus);
342 afx_msg void OnEditCut();
343 afx_msg void OnEditCopy();
344 afx_msg void OnEditPaste();
345 afx_msg void OnUpdateEditPaste(CCmdUI* pCmdUI);
346 afx_msg void OnUpdateEditCopy(CCmdUI* pCmdUI);
347 afx_msg void OnUpdateEditCut(CCmdUI* pCmdUI);
348 afx_msg void OnFilePageSetup();
349 //}}AFX_MSG
352protected:
353 CBitmap m_bmpGrayDC;
355 CXTPGridControl m_wndGrid;
356 CXTPGridControl* m_pGrid;
357 BOOL m_bPrintSelection;
360 CXTPGridViewPrintOptions* m_pPrintOptions;
362 CXTPScrollBarCtrl m_wndVScrollBar;
363 CXTPScrollBarCtrl m_wndHScrollBar;
364
365 CScrollBar* m_pScrollBarVer;
366 CScrollBar* m_pScrollBarHor;
369 CSliderCtrl* m_pSlider;
370
371 friend class CGridControlCtrl;
372
373 int m_nColumnStart;
374 int m_nColumnEnd;
375 UINT m_nStartIndex;
378 CUIntArray m_aPageStart;
379 BOOL m_bPaginated;
380
383public:
384 BOOL m_bAllowCut;
385 BOOL m_bAllowPaste;
386 BOOL m_bPrintDirect;
387 BOOL m_bResizeControlWithView;
389};
390
391AFX_INLINE CXTPGridViewPrintOptions* CXTPGridView::GetPrintOptions() const
392{
393 return m_pPrintOptions;
394}
396AFX_INLINE void CXTPGridView::SetReportCtrl(CXTPGridControl* pGrid)
397{
398 SetGridCtrl(pGrid);
399}
400
401AFX_INLINE CXTPGridControl& CXTPGridView::GetReportCtrl() const
402{
403 return GetGridCtrl();
404}
405
406# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
407
408#endif // !defined(__XTPGRIDVIEW_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPGridPaintTheme
XTPGridPaintTheme
Visual theme enumeration.
Definition XTPGridDefines.h:299
XTP_ID_GRID_CONTROL
const UINT XTP_ID_GRID_CONTROL
Identifier for a Grid control child window of CXTPGridView.
Definition XTPGridView.h:63
CXTPGridControl
The CXTPGridControl class provides an implementation of the Grid control.
Definition XTPGridControl.h:479
CXTPGridPaintManager
Utility class that handles most drawing activities.
Definition XTPGridPaintManager.h:76
CXTPGridView
The CXTPGridView class provides an implementation of the Grid control as a view class.
Definition XTPGridView.h:73
CXTPGridView::GetPaintManager
CXTPGridPaintManager * GetPaintManager() const
Gets the paint manager of the Grid control.
CXTPGridView::SetSliderCtrl
void SetSliderCtrl(CSliderCtrl *pSlider)
Sets the external slider control.
CXTPGridView::PrintPage
virtual int PrintPage(CDC *pDC, CPrintInfo *pInfo, CRect rcPage, int nRowFrom, int nColumnFrom, int nColumnTo)
Prints a single page of the Grid control.
CXTPGridView::SetTheme
void SetTheme(XTPGridPaintTheme paintTheme, BOOL bEnableMetrics=FALSE)
Sets the Grid control theme.
CXTPGridView::PrintHeader
virtual void PrintHeader(CDC *pDC, CRect rcHeader)
Prints the header of each page.
CXTPGridView::PrintFixedRowsDivider
int PrintFixedRowsDivider(CDC *pDC, const CRect &rc, BOOL bHeaderRows)
Prints either the header or footer divider.
CXTPGridView::PrintPageHeader
virtual int PrintPageHeader(CDC *pDC, CPrintInfo *pInfo, CRect rcPage, BOOL bOnlyCalculate, int nPageNumber, int nNumberOfPages, int nHorizontalPageNumber, int nNumberOfHorizontalPages)
Prints the page header of the Grid control.
CXTPGridView::PrintFooter
virtual void PrintFooter(CDC *pDC, CRect rcFooter)
Prints the footer of each page.
CXTPGridView::~CXTPGridView
virtual ~CXTPGridView()
Destroys a CXTPGridView object, handles cleanup and deallocation.
CXTPGridView::GetScrollBarCtrl
CScrollBar * GetScrollBarCtrl(int nBar) const
Retrieves a specified scrollbar control.
CXTPGridView::GetGridCtrl
virtual CXTPGridControl & GetGridCtrl() const
Gets the Grid control.
CXTPGridView::SetScrollBarCtrl
void SetScrollBarCtrl(CScrollBar *pScrollBar, BOOL bHor=FALSE)
Sets the external scrollbar control.
CXTPGridView::CXTPGridView
CXTPGridView()
Protected constructor used by dynamic creation.
CXTPGridView::m_bShowRowNumber
BOOL m_bShowRowNumber
TRUE to show the row number, FALSE otherwise.
Definition XTPGridView.h:85
CXTPGridView::PrintPageFooter
virtual int PrintPageFooter(CDC *pDC, CPrintInfo *pInfo, CRect rcPage, BOOL bOnlyCalculate, int nPageNumber, int nNumberOfPages, int nHorizontalPageNumber, int nNumberOfHorizontalPages)
Prints the page footer of the Grid control.
CXTPGridView::SetGridCtrl
void SetGridCtrl(CXTPGridControl *pGrid)
Sets the Grid control.
CXTPGridView::m_bSwitchMode
BOOL m_bSwitchMode
Tells whether to switch between modes (icon and grid).
Definition XTPGridView.h:84
CXTPGridView::SetupStartCol
int SetupStartCol(CDC *pDC, CPrintInfo *pInfo)
Prepares an array of columns for printing.
CXTPGridView::PrintGrid
virtual int PrintGrid(CDC *pDC, CPrintInfo *pInfo, CRect rcPage, int nRowFrom, int nColumnFrom, int nColumnTo)
Prints the Grid control (columns, header, and rows) on the page.
CXTPGridView::UpdateScrollBars
void UpdateScrollBars()
Updates the visibility and positions of scrollbars.
CXTPGridViewPrintOptions
This class is used to store printing options.
Definition XTPGridPageSetupDialog.h:40
CXTPScrollBarCtrl
Scrollbar control.
Definition XTPScrollBarCtrl.h:48


Toolkit Pro: Member List

CXTPGridViewPrintOptions Member List

This is the complete list of members for CXTPGridViewPrintOptions, including all inherited members.

CXTPGridViewPrintOptions() | CXTPGridViewPrintOptions |
GetActiveLCID() | CXTPGridViewPrintOptions | virtual
m_bRepeatFooterRows | CXTPGridViewPrintOptions |
m_bRepeatHeaderRows | CXTPGridViewPrintOptions |
Set(const CXTPGridViewPrintOptions *pSrc) | CXTPGridViewPrintOptions | virtual


Toolkit Pro: Member List

CXTPCommandBarsSiteBase< TBase > Member List

This is the complete list of members for CXTPCommandBarsSiteBase< TBase >, including all inherited members.

CXTPCommandBarsSiteBase() | CXTPCommandBarsSiteBase< TBase > | inline
DockRightOf(CXTPToolBar *pBarToDock, CXTPToolBar *pBarOnLeft) | CXTPCommandBarsSiteBase< TBase > | inline
GetCommandBars() const | CXTPCommandBarsSiteBase< TBase > | inline
InitCommandBars(CRuntimeClass *pCommandBarsClass=RUNTIME_CLASS(CXTPCommandBars)) | CXTPCommandBarsSiteBase< TBase > | inlinevirtual
LoadCommandBars(LPCTSTR lpszProfileName, BOOL bSilent=FALSE) | CXTPCommandBarsSiteBase< TBase > | inlinevirtual
SaveCommandBars(LPCTSTR lpszProfileName) | CXTPCommandBarsSiteBase< TBase > | inlinevirtual
~CXTPCommandBarsSiteBase() | CXTPCommandBarsSiteBase< TBase > | inline


Toolkit Pro: Member List

  • CXTPTabPaintManagerColorSet
  • COLORSET_TAB_PROPERTYPAGE
CXTPTabPaintManagerColorSet::COLORSET_TAB_PROPERTYPAGE Member List

This is the complete list of members for CXTPTabPaintManagerColorSet::COLORSET_TAB_PROPERTYPAGE, including all inherited members.

clrDarkShadow | CXTPTabPaintManagerColorSet::COLORSET_TAB_PROPERTYPAGE
clrHighlight | CXTPTabPaintManagerColorSet::COLORSET_TAB_PROPERTYPAGE
clrShadow | CXTPTabPaintManagerColorSet::COLORSET_TAB_PROPERTYPAGE


Toolkit Pro: XTPSkinObjectComboBox.h Source File

  • Source
  • SkinFramework
XTPSkinObjectComboBox.h
Go to the documentation of this file.
1
23#if !defined(__XTPSKINOBJECTCOMBOXBOX__)
24# define __XTPSKINOBJECTCOMBOXBOX__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPSkinObjectComboBox : public CXTPSkinObjectFrame
39{
41 DECLARE_DYNCREATE(CXTPSkinObjectComboBox)
43public:
48 CXTPSkinObjectComboBox();
49
54 virtual ~CXTPSkinObjectComboBox();
55
61 virtual void OnDraw(CDC* pDC);
62
63public:
64 static HWND AFX_CDECL GetComboListBox(HWND hWnd);
65
66protected:
69 DECLARE_MESSAGE_MAP()
70 //{{AFX_VIRTUAL(CXTPSkinObjectButton)
71 virtual int GetClientBrushMessage();
72 //}}AFX_VIRTUAL
73
74 //{{AFX_MSG(CXTPSkinObjectButton)
75 afx_msg void OnPaint();
76 afx_msg BOOL OnEraseBkgnd(CDC* pDC);
77 afx_msg void OnMouseMove(UINT nFlags, CPoint point);
78 afx_msg int OnCreate(LPCREATESTRUCT lpCreateStruct);
79 afx_msg void OnSetFocus(CWnd* pOldWnd);
80 afx_msg void OnKillFocus(CWnd* pNewWnd);
81 afx_msg void OnCaptureChanged(CWnd* pWnd);
82 afx_msg void OnMouseLeave();
83 afx_msg void OnStyleChanged();
84 afx_msg LRESULT OnPrintClient(WPARAM wParam, LPARAM lParam);
85 //}}AFX_MSG
86
87protected:
88 BOOL m_bHot;
89 BOOL m_bPushed;
90 BOOL m_bPaint;
92};
93
99class _XTP_EXT_CLASS CXTPSkinObjectDateTime : public CXTPSkinObjectComboBox
100{
102 DECLARE_DYNCREATE(CXTPSkinObjectDateTime)
104public:
109 CXTPSkinObjectDateTime();
110
118 CRect GetButtonRect();
119
124 void RefreshMetrics();
125
126protected:
133 void OnSkinChanged(BOOL bPrevState, BOOL bNewState);
134
136 DECLARE_MESSAGE_MAP()
137 virtual int GetClientBrushMessage();
138
139 int OnCreate(LPCREATESTRUCT lpCreateStruct);
140 void OnDraw(CDC* pDC);
141 void OnLButtonDown(UINT nFlags, CPoint point);
142 void DrawFrame(CDC* pDC);
143 BOOL IsVistaStyle() const;
145};
146
152class _XTP_EXT_CLASS CXTPSkinObjectMonthCal : public CXTPSkinObjectFrame
153{
155 DECLARE_DYNCREATE(CXTPSkinObjectMonthCal)
157public:
162 CXTPSkinObjectMonthCal();
163
168 void RefreshMetrics();
169};
170
171# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
173#endif // !defined(__XTPSKINOBJECTCOMBOXBOX__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPSkinObjectComboBox
CXTPSkinObjectComboBox is a CXTPSkinObjectFrame derived class.
Definition XTPSkinObjectComboBox.h:39
CXTPSkinObjectComboBox::OnDraw
virtual void OnDraw(CDC *pDC)
Performs all drawing logic.
CXTPSkinObjectComboBox::~CXTPSkinObjectComboBox
virtual ~CXTPSkinObjectComboBox()
Destroys a CXTPSkinObjectComboBox object, handles cleanup and deallocation.
CXTPSkinObjectComboBox::CXTPSkinObjectComboBox
CXTPSkinObjectComboBox()
Constructs a CXTPSkinObjectComboBox object.
CXTPSkinObjectDateTime
CXTPSkinObjectDateTime is a CXTPSkinObjectComboBox derived class.
Definition XTPSkinObjectComboBox.h:100
CXTPSkinObjectDateTime::GetButtonRect
CRect GetButtonRect()
Gets the size and location of the caption button.
CXTPSkinObjectDateTime::CXTPSkinObjectDateTime
CXTPSkinObjectDateTime()
Constructs a CXTPSkinObjectDateTime object.
CXTPSkinObjectDateTime::RefreshMetrics
void RefreshMetrics()
This method is called when visual metrics are changed.
CXTPSkinObjectDateTime::OnSkinChanged
void OnSkinChanged(BOOL bPrevState, BOOL bNewState)
This method is called when the skin is changed.
CXTPSkinObjectFrame
CXTPSkinObjectFrame is a CXTPSkinObject derived class.
Definition XTPSkinObjectFrame.h:75
CXTPSkinObjectMonthCal
CXTPSkinObjectMonthCal is a CXTPSkinObjectFrame derived class.
Definition XTPSkinObjectComboBox.h:153
CXTPSkinObjectMonthCal::CXTPSkinObjectMonthCal
CXTPSkinObjectMonthCal()
Constructs a CXTPSkinObjectMonthCal object.
CXTPSkinObjectMonthCal::RefreshMetrics
void RefreshMetrics()
This method is called when visual metrics are changed.


Toolkit Pro: XTPRibbonThemeNativeWindows10.h Source File

  • Source
  • Ribbon
  • Themes
XTPRibbonThemeNativeWindows10.h
Go to the documentation of this file.
1
23#if !defined(__XTPRIBBONNATIVEWINDOWS10THEME_H__)
24# define __XTPRIBBONNATIVEWINDOWS10THEME_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPRibbonThemeNativeWindows10
39 : public CXTPRibbonOffice2013Theme
40 , private IXTPPaintManagerCustomAccentColorProvider
41{
42public:
48 CXTPRibbonThemeNativeWindows10(CXTPPaintManager* pPaintManager);
49
54 virtual ~CXTPRibbonThemeNativeWindows10();
55
65 virtual void RefreshMetrics();
66
80 void FillGroupRect(CDC* pDC, CXTPRibbonTab* pActiveTab, CRect rcGroups);
81
88 virtual void DrawRibbonTab(CDC* pDC, CXTPRibbonTab* pItem);
89
97 virtual void DrawRibbonFrameContextHeaders(CDC* pDC, CXTPRibbonBar* pRibbonBar,
98 CXTPRibbonTabContextHeaders* pContextHeaders);
99
100private:
101 // IXTPPaintManagerCustomAccentColorProvider overrides
102
103 virtual COLORREF GetCustomAccentColor(XTPPaintManagerAccentColor nColor);
104};
105
106# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
108#endif // !defined(__XTPRIBBONNATIVEWINDOWS10THEME_H__)
XTPPaintManagerAccentColor
XTPPaintManagerAccentColor
Defines a set of accent related colors.
Definition XTPColorManager.h:900
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPPaintManager
Paint manager of the command bars.
Definition XTPPaintManager.h:199
CXTPRibbonBar
CXTPRibbonBar is a CXTPMenuBar derived class.
Definition XTPRibbonBar.h:69
CXTPRibbonOffice2013Theme
CXTPRibbonOffice2013Theme is a CXTPRibbonMarkupTheme derived class used to represent an Office 2013 r...
Definition XTPRibbonThemeOffice2013.h:50
CXTPRibbonTab
Represents a tab in the Ribbon Bar.
Definition XTPRibbonTab.h:116
CXTPRibbonThemeNativeWindows10
CXTPRibbonThemeNativeWindows10 is a CXTPRibbonOffice2013Theme derived class used to represent a Nativ...
Definition XTPRibbonThemeNativeWindows10.h:41
CXTPRibbonThemeNativeWindows10::FillGroupRect
void FillGroupRect(CDC *pDC, CXTPRibbonTab *pActiveTab, CRect rcGroups)
This method is called to fill the background of a CXTPRibbonGroup.
CXTPRibbonThemeNativeWindows10::CXTPRibbonThemeNativeWindows10
CXTPRibbonThemeNativeWindows10(CXTPPaintManager *pPaintManager)
Constructs a CXTPRibbonThemeNativeWindows10 object.
CXTPRibbonThemeNativeWindows10::~CXTPRibbonThemeNativeWindows10
virtual ~CXTPRibbonThemeNativeWindows10()
Destroys a CXTPRibbonThemeNativeWindows10 object, handles cleanup and deallocation.
CXTPRibbonThemeNativeWindows10::DrawRibbonTab
virtual void DrawRibbonTab(CDC *pDC, CXTPRibbonTab *pItem)
This method is called to draw a single tab of the ribbon bar.
CXTPRibbonThemeNativeWindows10::RefreshMetrics
virtual void RefreshMetrics()
This method is called to refresh the visual metrics of the manager.
CXTPRibbonThemeNativeWindows10::DrawRibbonFrameContextHeaders
virtual void DrawRibbonFrameContextHeaders(CDC *pDC, CXTPRibbonBar *pRibbonBar, CXTPRibbonTabContextHeaders *pContextHeaders)
This method is called to draw ribbon context headers.


Toolkit Pro: Member List

CXTPDatePickerThemeNativeWindows11 Member List

This is the complete list of members for CXTPDatePickerThemeNativeWindows11, including all inherited members.

CalcDayOfWeekRect(CDC *pDC) | CXTPDatePickerPaintManager | virtual
CalcDayRect(CDC *pDC) | CXTPDatePickerPaintManager | virtual
CalcMonthHeaderRect(CDC *pDC) | CXTPDatePickerPaintManager | virtual
CalcMonthRect(CDC *pDC) | CXTPDatePickerPaintManager | virtual
CalcWeekNumbersRect(CDC *pDC) | CXTPDatePickerPaintManager | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPDatePickerPaintManager() | CXTPDatePickerPaintManager |
CXTPDatePickerThemeNativeWindows11() | CXTPDatePickerThemeNativeWindows11 |
CXTPDatePickerThemeOffice2013() | CXTPDatePickerThemeOffice2013 |
DrawBackground(CDC *pDC, CRect rcClient) | CXTPDatePickerThemeOffice2013 | virtual
DrawBorder(CDC *pDC, const CXTPDatePickerControl *pControl, CRect &rcClient, BOOL bDraw) | CXTPDatePickerThemeOffice2013 | virtual
DrawButton(CDC *pDC, const CRect &rcButton, const CString &strButton, BOOL bIsDown, BOOL bIsHighLight) | CXTPDatePickerThemeOffice2013 | virtual
DrawDay(CDC *pDC, CXTPDatePickerItemDay *pDay) | CXTPDatePickerThemeOffice2013 | virtual
DrawDaysOfWeek(CDC *pDC, CXTPDatePickerItemMonth *pMonth) | CXTPDatePickerThemeOffice2013 | virtual
DrawMonthHeader(CDC *pDC, CXTPDatePickerItemMonth *pMonth) | CXTPDatePickerPaintManager | virtual
DrawScrollTriangle(CDC *pDC, CRect rcSpot, BOOL bLeftDirection, COLORREF clrColor=0, BOOL bYears=FALSE) | CXTPDatePickerPaintManager | virtual
DrawWeekNumbers(CDC *pDC, CXTPDatePickerItemMonth *pMonth) | CXTPDatePickerThemeOffice2013 | virtual
EnableTheme(BOOL bEnableTheme) | CXTPDatePickerPaintManager | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetButtonFont() | CXTPDatePickerPaintManager |
GetControlBackColor() | CXTPDatePickerPaintManager | virtual
GetCursorBack() | CXTPDatePickerPaintManager | virtual
GetDayBackColor() | CXTPDatePickerPaintManager | virtual
GetDaysOfWeekBackColor() | CXTPDatePickerPaintManager | virtual
GetDaysOfWeekTextColor() | CXTPDatePickerPaintManager | virtual
GetDaysOfWeekTextFont() | CXTPDatePickerPaintManager |
GetDayTextColor() | CXTPDatePickerPaintManager | virtual
GetDayTextFont() | CXTPDatePickerPaintManager | virtual
GetDayTextFontBold() | CXTPDatePickerPaintManager | virtual
GetHeaderTextFont() | CXTPDatePickerPaintManager |
GetHighlightTodayBackColor() | CXTPDatePickerThemeOffice2013 | virtual
GetHighlightTodayBorderColor() | CXTPDatePickerThemeOffice2013 | virtual
GetHighlightTodayColor() | CXTPDatePickerPaintManager | virtual
GetHighlightTodayTextColor() | CXTPDatePickerThemeOffice2013 | virtual
GetListControlBackColor() | CXTPDatePickerPaintManager | virtual
GetListControlTextColor() | CXTPDatePickerPaintManager | virtual
GetListControlTextFont() | CXTPDatePickerPaintManager |
GetMonthHeaderBackColor() | CXTPDatePickerPaintManager | virtual
GetMonthHeaderTextColor() | CXTPDatePickerPaintManager | virtual
GetNonMonthDayBackColor() | CXTPDatePickerPaintManager | virtual
GetNonMonthDayTextColor() | CXTPDatePickerPaintManager | virtual
GetNonMonthDayTextFont() | CXTPDatePickerPaintManager |
GetPaintTheme() const | CXTPDatePickerPaintManager | protected
GetSelectedDayBackColor() | CXTPDatePickerPaintManager | virtual
GetSelectedDayTextColor() | CXTPDatePickerPaintManager | virtual
GetWeekNumbersBackColor() | CXTPDatePickerPaintManager | virtual
GetWeekNumbersTextColor() | CXTPDatePickerPaintManager | virtual
GetWeekNumbersTextFont() | CXTPDatePickerPaintManager |
m_bEnableTheme | CXTPDatePickerPaintManager | protected
m_clr3DFace | CXTPDatePickerPaintManager | protected
m_clr3DLight | CXTPDatePickerPaintManager | protected
m_clr3DShadow | CXTPDatePickerPaintManager | protected
m_clr3DText | CXTPDatePickerPaintManager | protected
m_clrBackground | CXTPDatePickerThemeOffice2013 | protected
m_clrButtonFace | CXTPDatePickerPaintManager |
m_clrButtonText | CXTPDatePickerPaintManager |
m_clrControlBack | CXTPDatePickerPaintManager |
m_clrDayBack | CXTPDatePickerPaintManager |
m_clrDaysOfWeekBack | CXTPDatePickerPaintManager |
m_clrDaysOfWeekText | CXTPDatePickerPaintManager |
m_clrDayText | CXTPDatePickerPaintManager |
m_clrHighlightToday | CXTPDatePickerPaintManager |
m_clrListControlBack | CXTPDatePickerPaintManager |
m_clrListControlText | CXTPDatePickerPaintManager |
m_clrMonthBorder | CXTPDatePickerPaintManager |
m_clrMonthHeaderBack | CXTPDatePickerPaintManager |
m_clrMonthHeaderButton | CXTPDatePickerPaintManager |
m_clrMonthHeaderText | CXTPDatePickerPaintManager |
m_clrNonMonthDayBack | CXTPDatePickerPaintManager |
m_clrNonMonthDayText | CXTPDatePickerPaintManager |
m_clrSelectedDayBack | CXTPDatePickerPaintManager |
m_clrSelectedDayText | CXTPDatePickerPaintManager |
m_clrStaticBorder | CXTPDatePickerPaintManager | protected
m_clrWeekNumbersBack | CXTPDatePickerPaintManager |
m_clrWeekNumbersText | CXTPDatePickerPaintManager |
m_hCursorBack | CXTPDatePickerPaintManager | protected
m_nPaintTheme | CXTPDatePickerPaintManager | protected
m_szDayMargin | CXTPDatePickerPaintManager |
m_themeButton | CXTPDatePickerPaintManager | protected
m_xtpFontButton | CXTPDatePickerPaintManager | protected
m_xtpFontDay | CXTPDatePickerPaintManager | protected
m_xtpFontDayBold | CXTPDatePickerPaintManager | protected
m_xtpFontDaysOfWeek | CXTPDatePickerPaintManager | protected
m_xtpFontHeader | CXTPDatePickerPaintManager | protected
m_xtpFontListControl | CXTPDatePickerPaintManager | protected
m_xtpFontNonMonthDay | CXTPDatePickerPaintManager | protected
m_xtpFontWeekNumbers | CXTPDatePickerPaintManager | protected
RefreshMetrics() | CXTPDatePickerThemeOffice2013 | virtual
SetButtonFont(CFont *fontButton) | CXTPDatePickerPaintManager |
SetButtonFontIndirect(LOGFONT *lFont) | CXTPDatePickerPaintManager |
SetFontIndirect(LOGFONT *lFont) | CXTPDatePickerPaintManager |
Triangle(CDC *pDC, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clrColor=0) | CXTPDatePickerPaintManager | protectedvirtual
~CXTPDatePickerPaintManager() | CXTPDatePickerPaintManager | virtual
~CXTPDatePickerThemeNativeWindows11() | CXTPDatePickerThemeNativeWindows11 | virtual
~CXTPDatePickerThemeOffice2013() | CXTPDatePickerThemeOffice2013 | virtual


Toolkit Pro: Member List

CXTPRibbonBackstageView Member List

This is the complete list of members for CXTPRibbonBackstageView, including all inherited members.

CalcDynamicLayout(int nLength, DWORD dwMode) | CXTPCommandBar | protectedvirtual
CheckKeyboardTips() | CXTPRibbonBackstageView | protected
CheckTabsKeyboardTips() | CXTPRibbonBackstageView | protected
Copy(CXTPCommandBar *pCommandBar, BOOL bRecursive=FALSE) | CXTPCommandBar | protectedvirtual
CreateKeyboardTips() | CXTPCommandBar | virtual
CXTPCommandBar() | CXTPCommandBar | protected
CXTPHookManagerHookAble() | CXTPHookManagerHookAble |
DelayLayout() | CXTPCommandBar |
DelayRedraw() | CXTPCommandBar | virtual
DoPropExchange(CXTPPropExchange *pPX) | CXTPCommandBar | virtual
DrawCommandBar(CDC *pDC, CRect rcClipBox) | CXTPCommandBar | virtual
EnableAnimation(BOOL bEnable=TRUE) | CXTPCommandBar |
EnableCustomization(BOOL bEnable=TRUE) | CXTPCommandBar |
EnableDoubleBuffer(BOOL bEnable=TRUE) | CXTPCommandBar |
EnsureVisible(CXTPControl *pControl) | CXTPCommandBar | virtual
FillCommandBarEntry(CDC *pDC) | CXTPCommandBar | virtual
FindAccel(TCHAR chAccel) const | CXTPCommandBar |
FindAccelEx(UINT chAccel, BOOL &bSelectOnly) const | CXTPCommandBar |
GenerateCommandBarList(DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam) | CXTPCommandBar | protectedvirtual
GetActiveControlPane() const | CXTPRibbonBackstageView |
GetActiveDocTemplate() const | CXTPCommandBar | protected
GetActiveTab() const | CXTPRibbonBackstageView |
GetBackstageStyle() const | CXTPRibbonBackstageView |
GetBarID() const | CXTPCommandBar |
GetBorders() | CXTPCommandBar | virtual
GetButtonSize() const | CXTPCommandBar | virtual
GetCommandBarData() const | CXTPCommandBar |
GetCommandBars() const | CXTPCommandBar |
GetControl(int nIndex) const | CXTPCommandBar |
GetControlCount() const | CXTPCommandBar |
GetControls() const | CXTPCommandBar |
GetDefaultButtonStyle() const | CXTPCommandBar |
GetFlags() const | CXTPCommandBar |
GetFocusedControl() const | CXTPRibbonBackstageView |
GetFrameSite() const | CXTPCommandBar |
GetHighlightedControl() const | CXTPRibbonBackstageView |
GetIconSize() const | CXTPCommandBar | virtual
GetImageManager() const | CXTPRibbonBackstageView |
GetKeyboardTipsBackColor() | CXTPRibbonBackstageView |
GetKeyboardTipsFont() | CXTPRibbonBackstageView |
GetLargeIconSize(BOOL bAutoSize) const | CXTPCommandBar |
GetMenuWidth() const | CXTPRibbonBackstageView |
GetOwnerSite() const | CXTPCommandBar |
GetPaintManager() const | CXTPCommandBar |
GetParentCommandBar() const | CXTPCommandBar | virtual
GetPosition() const | CXTPCommandBar |
GetRootParent() const | CXTPCommandBar |
GetScrollBarCtrl(int nBar) | CXTPRibbonBackstageView | virtual
GetScrollBarCtrl(int nBar) const | CXTPRibbonBackstageView | virtual
GetSelected() const | CXTPCommandBar |
GetShowGripper() const | CXTPCommandBar |
GetSite() const | CXTPCommandBar |
GetTextOrientation() const | CXTPCommandBar |
GetTitle() const | CXTPCommandBar |
GetTrackFocus() const | CXTPCommandBar |
GetType() const | CXTPCommandBar |
GetWidth() const | CXTPCommandBar |
HideKeyboardTips() | CXTPCommandBar |
HitTest(CPoint point) const | CXTPRibbonBackstageView |
IndexOf(CXTPControl *pControl) const | CXTPRibbonBackstageView |
InvalidateParents() | CXTPCommandBar |
IsActiveTab(CXTPControl *pControl) const | CXTPRibbonBackstageView |
IsAnimationEnabled() const | CXTPCommandBar |
IsCommand(CXTPControl *pControl) const | CXTPRibbonBackstageView |
IsCustomizable() const | CXTPCommandBar | virtual
IsCustomizeDialogPresent() const | CXTPCommandBar |
IsCustomizeMode() const | CXTPCommandBar |
IsDialogBar() const | CXTPCommandBar | virtual
IsDpiIconsScalingEnabled() const | CXTPRibbonBackstageView |
IsFocusedControl(CXTPControl *pControl) const | CXTPRibbonBackstageView |
IsHelpMode() const | CXTPCommandBar | protected
IsHighlightedControl(CXTPControl *pControl) const | CXTPRibbonBackstageView |
IsKeyboardCuesVisible() const | CXTPCommandBar | virtual
IsKeyboardTipsVisible() const | CXTPCommandBar |
IsLayoutRTL() const | CXTPCommandBar |
IsMenuSeparator(CXTPControl *pControl) const | CXTPRibbonBackstageView |
IsMenuTitleBar() const | CXTPCommandBar | virtual
IsPopupBar() const | CXTPCommandBar | virtual
IsResizable() const | CXTPCommandBar | virtual
IsRibbonBar() const | CXTPCommandBar | virtual
IsTextBelowIcons() const | CXTPCommandBar |
IsTrackingMode() const | CXTPCommandBar |
IsVisible() const | CXTPCommandBar | virtual
LoadMenu(CMenu *pMenu, BOOL bRemoveControls=TRUE) | CXTPCommandBar | virtual
LoadToolBar(UINT nIDResource, BOOL bLoadIcons=TRUE) | CXTPCommandBar | virtual
LockMouseMove(CXTPControl *pControl) | CXTPCommandBar |
LockRedraw() | CXTPCommandBar |
m_bAnimatePopup | CXTPCommandBar | protected
m_barPosition | CXTPCommandBar | protected
m_barType | CXTPCommandBar | protected
m_bAutoDestroy | CXTPHookManagerHookAble |
m_bCloseable | CXTPCommandBar | protected
m_bComboBar | CXTPCommandBar |
m_bCustomizable | CXTPCommandBar | protected
m_bCustomizeDialogPresent | CXTPCommandBar | protected
m_bExecOnRButton | CXTPCommandBar | protected
m_bGrabFocus | CXTPCommandBar | protected
m_bIgnoreUpdateHandler | CXTPCommandBar | protected
m_bKeyboardSelect | CXTPCommandBar | protected
m_bMultiLine | CXTPCommandBar | protected
m_bRecursePopup | CXTPCommandBar | protected
m_bTextBelow | CXTPCommandBar | protected
m_bTracking | CXTPCommandBar | protected
m_bTrackOnHover | CXTPCommandBar |
m_buttonStyle | CXTPCommandBar | protected
m_bVerticalMarker | CXTPCommandBar | protected
m_chSecondLevelCurrentChar | CXTPRibbonBackstageView | protected
m_dwData | CXTPCommandBar | protected
m_dwFlags | CXTPCommandBar | protected
m_dwStyle | CXTPCommandBar | protected
m_hwndFocus | CXTPCommandBar | protected
m_nBarID | CXTPCommandBar | protected
m_nIdleFlags | CXTPCommandBar | protected
m_nKeyboardTipsLevel | CXTPRibbonBackstageView | protected
m_nLockRedraw | CXTPCommandBar | protected
m_nMRUWidth | CXTPCommandBar | protected
m_nPopuped | CXTPCommandBar | protected
m_nSelected | CXTPCommandBar | protected
m_nStateFlags | CXTPCommandBar |
m_nTextOrientation | CXTPCommandBar | protected
m_pAnimation | CXTPCommandBar | protected
m_pCommandBars | CXTPCommandBar | protected
m_pControls | CXTPCommandBar | protected
m_pImageManager | CXTPCommandBar | protected
m_pOwner | CXTPCommandBar | protected
m_pReturnCmd | CXTPCommandBar | protected
m_pSite | CXTPCommandBar | protected
m_pToolTipContext | CXTPCommandBar | protected
m_rcMarker | CXTPCommandBar | protected
m_strTitle | CXTPCommandBar | protected
m_szButtons | CXTPCommandBar | protected
m_szButtonSpacing | CXTPCommandBar | protected
m_szIcons | CXTPCommandBar | protected
OnControlsChanged() | CXTPCommandBar | protectedvirtual
OnControlSelected(BOOL bSelected, CXTPControl *pControl) | CXTPCommandBar | virtual
OnCustomizeDragEnter(CXTPControl *pDataObject, CPoint point) | CXTPCommandBar | virtual
OnCustomizeDragLeave() | CXTPCommandBar | virtual
OnCustomizeDragOver(CXTPControl *pDataObject, CPoint point) | CXTPCommandBar | virtual
OnCustomizeDrop(CXTPControl *pDataObject, DROPEFFECT &dropEffect, CPoint ptDrop, CPoint ptDrag) | CXTPCommandBar | virtual
OnExecute(CXTPControl *pControl) | CXTPRibbonBackstageView |
OnHookAttached(HWND hWnd) | CXTPHookManagerHookAble | virtual
OnHookDetached() | CXTPHookManagerHookAble | virtual
OnHookKeyDown(UINT nChar, LPARAM lParam) | CXTPCommandBar | protectedvirtual
OnHookMessage(HWND hWnd, UINT nMessage, WPARAM &wParam, LPARAM &lParam, LRESULT &lResult) | CXTPRibbonBackstageView | protectedvirtual
OnKeyboardTip(CXTPCommandBarKeyboardTip *pTip) | CXTPCommandBar | virtual
OnKeyboardTipChar(UINT chAccel) | CXTPCommandBar |
OnMouseHitTest(CPoint pt) | CXTPCommandBar | protectedvirtual
OnPostHookMessage(HWND hWnd, UINT nMessage, WPARAM &wParam, LPARAM &lParam, LRESULT &lResult) | CXTPHookManagerHookAble | virtual
OnRecalcLayout() | CXTPCommandBar | virtual
OnRemoved() | CXTPCommandBar | protectedvirtual
OnTrackEnter() | CXTPCommandBar | virtual
OnTrackLost() | CXTPCommandBar | virtual
Popup(CXTPControlPopup *pControlPopup, BOOL bSelectFirst=FALSE) | CXTPRibbonBackstageView | protectedvirtual
ProcessKeyboardInput(UINT keyMessage, BOOL altPressed, UINT key, int repeat) | CXTPRibbonBackstageView |
ProcessSpecialKey(XTPSpecialKey key) | CXTPCommandBar | protectedvirtual
Redraw(LPCRECT lpRect=0, BOOL bAnimate=TRUE) | CXTPCommandBar | virtual
RestoreCommandBarList(CXTPCommandBarList *pCommandBarList) | CXTPCommandBar | protectedvirtual
s_nExpandDelay | CXTPCommandBar | static
s_nExpandHoverDelay | CXTPCommandBar | static
s_nHoverDelay | CXTPCommandBar | static
SetActiveTab(CXTPRibbonBackstageTab *pTab) | CXTPRibbonBackstageView |
SetBackstageStyle(XTPRibbonBackstageStyle style=xtpRibbonBackstageOffice2016Style) | CXTPRibbonBackstageView |
SetBarID(UINT nID) | CXTPCommandBar |
SetButtons(UINT *pButtons, int nCount) | CXTPCommandBar |
SetButtonSize(CSize size) | CXTPCommandBar |
SetCommandBarData(DWORD_PTR dwData) | CXTPCommandBar |
SetCommandBars(CXTPCommandBars *pCommandBars) | CXTPCommandBar |
SetControls(CXTPControls *pControls) | CXTPCommandBar |
SetDefaultButtonStyle(XTPButtonStyle buttonStyle) | CXTPCommandBar |
SetFlags(DWORD dwFlagsAdd, DWORD dwFlagsRemove=0) | CXTPCommandBar |
SetFocusedControl(CXTPControl *pFocusedControl) | CXTPRibbonBackstageView |
SetGrabFocus(BOOL bGrabFocus) | CXTPCommandBar |
SetIconSize(CSize size) | CXTPCommandBar |
SetImageManager(CXTPImageManager *pImageManager) | CXTPCommandBar |
SetPaintManager(CXTPPaintManager *pPaintManager) | CXTPCommandBar |
SetPopuped(int nPopuped, BOOL bKeyboard=FALSE) | CXTPCommandBar |
SetPosition(XTPBarPosition barPosition) | CXTPCommandBar | virtual
SetScrollPos(int nScrollPos) | CXTPRibbonBackstageView | protected
SetSelected(int nSelected, BOOL bKeyboard=FALSE) | CXTPCommandBar | virtual
SetShowGripper(BOOL bShow) | CXTPCommandBar |
SetStatusText(const CString &strDescription) | CXTPCommandBar |
SetTextOrientation(XTPBarTextOrientation nTextOrientation) | CXTPCommandBar |
SetTheme(XTPPaintTheme theme) | CXTPRibbonBackstageView |
SetTitle(LPCTSTR lpszTitle) | CXTPCommandBar |
SetTrackFocus(HWND hwnd) | CXTPCommandBar |
SetTrackingMode(int bMode, BOOL bSelectFirst=TRUE, BOOL bKeyboard=FALSE) | CXTPRibbonBackstageView | protectedvirtual
SetVisible(BOOL bVisible) | CXTPCommandBar | virtual
SetWidth(int nWidth) | CXTPCommandBar |
ShowTextBelowIcons(BOOL bTextBelow=TRUE) | CXTPCommandBar |
TranslateKeyboardTip(UINT key, int &nControlIndex) | CXTPRibbonBackstageView | protected
UnlockMouseMove() | CXTPCommandBar |
UnlockRedraw() | CXTPCommandBar |
UpdateScrollInfo() | CXTPRibbonBackstageView | protected
UpdateShortcuts() | CXTPCommandBar | protectedvirtual
~CXTPCommandBar() | CXTPCommandBar | protectedvirtual
~CXTPHookManagerHookAble() | CXTPHookManagerHookAble | virtual


Toolkit Pro: XTPRibbonBackstagePaintManager.h Source File

  • Source
  • Ribbon
  • Backstage
XTPRibbonBackstagePaintManager.h
Go to the documentation of this file.
1
23#if !defined(__XTPRIBBONBACKSTAGEPAINTMANAGER_H__)
24# define __XTPRIBBONBACKSTAGEPAINTMANAGER_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPRibbonBackstageView;
34class CXTPControl;
35class CXTPPaintManager;
36
37class _XTP_EXT_CLASS CXTPRibbonBackstagePaintManager
38{
39 // Construction / Destruction
40public:
41 CXTPRibbonBackstagePaintManager();
42
43 virtual ~CXTPRibbonBackstagePaintManager();
44
45 // Drawing interface
46public:
47 virtual void DrawBackground(CDC* pDC, CXTPRibbonBackstageView* pView);
48
49 virtual void DrawControl(CDC* pDC, CXTPRibbonBackstageView* pView, CXTPControl* pControl);
50 virtual void DrawKeyboardTip(CDC* pDC, CXTPPaintManager* pPaintManager, CXTPControl* pControl);
51
52 virtual int GetMenuItemCommandHeight() const;
53 virtual int GetMenuItemPageHeight() const;
54
55 virtual int GetMenuItemCommandGapX() const;
56 virtual int GetMenuItemCommandGapY() const;
57 virtual int GetMenuItemPageGapY() const;
58
59 virtual int GetMenuItemTextGap() const;
60 virtual int GetMenuImageMargin() const;
61 virtual int GetMenuSeparatorHeight() const;
62
63public:
64 int m_nCommandGap;
65 int m_nCommandGapY;
66 int m_nMenuItemCommandHeight;
67 int m_nMenuItemPageHeight;
68 int m_nMenuItemPageGapY;
69 int m_nTextGap;
70 int m_nImageMargin;
71 int m_nMenuSeparatorHeight;
72};
73
74# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
76#endif // !defined(__XTPRIBBONBACKSTAGEPAINTMANAGER_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPControl
CXTPControl is a CXTPCmdTarget derived class.
Definition XTPControl.h:841
CXTPPaintManager
Paint manager of the command bars.
Definition XTPPaintManager.h:199
CXTPRibbonBackstageView
CXTPRibbonBackstageView is a CDialog derived class used for a Backstage parent frame.
Definition XTPRibbonBackstageView.h:87


Toolkit Pro: Member List

CXTPCalendarEventCategory Member List

This is the complete list of members for CXTPCalendarEventCategory, including all inherited members.

CXTPCalendarEventCategory(UINT nID=0, LPCTSTR pcszName=_T(""), COLORREF clrBorder=0, COLORREF clrBkBase=0) | CXTPCalendarEventCategory |
CXTPCalendarEventCategory(CXTPCalendarEventCategory *pCategory) | CXTPCalendarEventCategory |
CXTPCmdTarget() | CXTPCmdTarget |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetBackgroundColor() | CXTPCalendarEventCategory | virtual
GetBkBaseColor() const | CXTPCalendarEventCategory | virtual
GetBkColorAllDayEvents() const | CXTPCalendarEventCategory | virtual
GetBkColorNonWorkCell() const | CXTPCalendarEventCategory | virtual
GetBkColorWorkCell() const | CXTPCalendarEventCategory | virtual
GetBorderColor() const | CXTPCalendarEventCategory | virtual
GetColorCellBorder() const | CXTPCalendarEventCategory | virtual
GetID() const | CXTPCalendarEventCategory |
GetName() const | CXTPCalendarEventCategory |
m_clrBkBase | CXTPCalendarEventCategory | protected
m_clrBorder | CXTPCalendarEventCategory | protected
m_grclrBackground | CXTPCalendarEventCategory | protected
m_nID | CXTPCalendarEventCategory | protected
m_strName | CXTPCalendarEventCategory | protected
SetBkBaseColor(COLORREF clrColor) | CXTPCalendarEventCategory | virtual
SetBorderColor(COLORREF clrColor) | CXTPCalendarEventCategory | virtual
SetID(UINT nID) | CXTPCalendarEventCategory |
SetName(LPCTSTR pcszName) | CXTPCalendarEventCategory |
~CXTPCalendarEventCategory() | CXTPCalendarEventCategory | virtual


Toolkit Pro: Member List

CXTPItemEdit Member List

This is the complete list of members for CXTPItemEdit, including all inherited members.

AdjustBuddyRect(CWnd *pBuddy, CRect &rcUpDown, int nAlignment) | CXTPEdit |
CanOverType() const | CXTPMaskEditT< CEdit > | inline
CanPaste() | CXTPEdit | virtual
CanUseMask() const | CXTPMaskEditT< CEdit > | inline
CheckChar(TCHAR &nChar, int nPos) | CXTPMaskEditT< CEdit > | inlinevirtual
ChooseDirectory() | CXTPBrowseEdit | virtual
ChooseFile() | CXTPBrowseEdit | virtual
ConvertUnicodeAlpha(TCHAR nChar, BOOL bUpperCase) const | CXTPMaskEditT< CEdit > | inline
CopyToClipboard(const CString &strText) | CXTPMaskEditT< CEdit > | inline
Create(CWnd *pParent, const CRect &rect, CString &strWindowText, DWORD dwBStyle=BES_XTP_CHOOSEDIR, bool bAutoDelete=true) | CXTPItemEdit |
CXTPBrowseEdit() | CXTPBrowseEdit |
CXTPEdit() | CXTPEdit |
CXTPItemEdit() | CXTPItemEdit |
CXTPMaskEditT() | CXTPMaskEditT< CEdit > | inline
DeleteCharAt(int iPos) | CXTPMaskEditT< CEdit > | inline
DrawBuddyBorders(CWnd *pBuddy, CDC *pDC, CRect rc, int nAlignment) | CXTPEdit |
EndLabelEdit() | CXTPItemEdit | virtual
GetBrowseButton() | CXTPBrowseEdit |
GetClientBrush(CDC *pDC) | CXTPEdit | protected
GetFlatStyle() const | CXTPEdit |
GetMaskedText(int nStartPos=0, int nEndPos=-1) const | CXTPMaskEditT< CEdit > | inline
GetPromptChar() const | CXTPMaskEditT< CEdit > | inline
GetPromptString(int nLength) const | CXTPMaskEditT< CEdit > | inline
GetTheme() | CXTPEdit |
GetThemeID() | CXTPEdit |
GetUseVisualStyle() const | CXTPEdit |
HasSelection() const | CXTPEdit |
Initialize(CWnd *pParentWnd, DWORD dwBStyle, UINT nMenu=0, int nSubMenuIndx=0) | CXTPBrowseEdit | virtual
Initialize(CWnd *pParentWnd) | CXTPBrowseEdit | virtual
InsertCharAt(int iPos, TCHAR nChar) | CXTPMaskEditT< CEdit > | inline
IsBrowsing() | CXTPBrowseEdit |
IsFlatStyle() const | CXTPEdit |
IsFocused() const | CXTPEdit |
IsHighlighted() const | CXTPEdit |
IsModified() const | CXTPMaskEditT< CEdit > | inline
IsPatternValid() | CXTPEdit |
m_bAutoDelete | CXTPItemEdit |
m_bBrowsing | CXTPBrowseEdit | protected
m_bClosePosted | CXTPItemEdit | protected
m_bEscapeKey | CXTPItemEdit |
m_bFocused | CXTPEdit | protected
m_bHighlighted | CXTPEdit | protected
m_bModified | CXTPItemEdit |
m_bOpenFileDialog | CXTPBrowseEdit | protected
m_bOverType | CXTPMaskEditT< CEdit > | protected
m_bPreSubclassInit | CXTPEdit | protected
m_bRedo | CXTPMaskEditT< CEdit > | protected
m_bShowBorder | CXTPEdit | protected
m_btnBrowse | CXTPBrowseEdit | protected
m_bUpdateUndo | CXTPMaskEditT< CEdit > | protected
m_bUseMask | CXTPMaskEditT< CEdit > | protected
m_chPrompt | CXTPMaskEditT< CEdit > | protected
m_dwBStyle | CXTPBrowseEdit | protected
m_dwFlags | CXTPBrowseEdit | protected
m_nDefaultGap | CXTPBrowseEdit | static
m_nEndChar | CXTPMaskEditT< CEdit > | protected
m_nGap | CXTPBrowseEdit | protected
m_nMenu | CXTPBrowseEdit | protected
m_nStartChar | CXTPMaskEditT< CEdit > | protected
m_nSubMenuIndx | CXTPBrowseEdit | protected
m_pFileDialog | CXTPBrowseEdit | protected
m_pRegExp | CXTPEdit | protected
m_pTheme | CXTPEdit | protected
m_strDefault | CXTPMaskEditT< CEdit > | protected
m_strDefExt | CXTPBrowseEdit | protected
m_strFileName | CXTPBrowseEdit | protected
m_strFilter | CXTPBrowseEdit | protected
m_strInitialDir | CXTPBrowseEdit | protected
m_strLiteral | CXTPMaskEditT< CEdit > | protected
m_strMask | CXTPMaskEditT< CEdit > | protected
m_strRedoBuffer | CXTPMaskEditT< CEdit > | protected
m_strTitle | CXTPBrowseEdit | protected
m_strUndoBuffer | CXTPMaskEditT< CEdit > | protected
m_strWindowText | CXTPItemEdit |
MaskClear() | CXTPMaskEditT< CEdit > | inline
MaskCopy() | CXTPMaskEditT< CEdit > | inline
MaskCut() | CXTPMaskEditT< CEdit > | inline
MaskDeleteSel() | CXTPMaskEditT< CEdit > | inline
MaskPaste() | CXTPMaskEditT< CEdit > | inline
MaskReplaceSel(LPCTSTR lpszNewText) | CXTPMaskEditT< CEdit > | inline
MaskSelectAll() | CXTPMaskEditT< CEdit > | inline
MaskUndo() | CXTPMaskEditT< CEdit > | inline
OnBrowse() | CXTPBrowseEdit | virtual
OnCommand(WPARAM wParam, LPARAM lParam) | CXTPMaskEditT< CEdit > | inlineprotectedvirtual
PopupMenu() | CXTPBrowseEdit | virtual
PosInRange(int iPos) const | CXTPMaskEditT< CEdit > | inline
PositionBrowseButton() | CXTPBrowseEdit | virtual
PreTranslateMessage(MSG *pMsg) | CXTPMaskEditT< CEdit > | inlinevirtual
ProcessMask(TCHAR &nChar, int nEndPos) | CXTPMaskEditT< CEdit > | inlinevirtual
RedrawEdit() | CXTPEdit | protected
RedrawFocusedFrame() | CXTPEdit | protected
RefreshMetrics() | CXTPEdit | virtual
SetDlgDefExt(LPCTSTR lpszDefExt=NULL) | CXTPBrowseEdit |
SetDlgFileName(LPCTSTR lpszFileName=NULL) | CXTPBrowseEdit |
SetDlgFilter(LPCTSTR lpszFilter=NULL) | CXTPBrowseEdit |
SetDlgInitialDir(LPCTSTR lpszInitialDir) | CXTPBrowseEdit |
SetDlgOpenFile(BOOL bOpenFileDialog=TRUE) | CXTPBrowseEdit | virtual
SetDlgStyle(DWORD dwFlags=OFN_HIDEREADONLY|OFN_OVERWRITEPROMPT) | CXTPBrowseEdit | virtual
SetDlgTitle(LPCTSTR lpszTitle=NULL) | CXTPBrowseEdit |
SetEditMask(LPCTSTR lpszMask, LPCTSTR lpszLiteral, LPCTSTR lpszDefault=NULL) | CXTPEdit | virtual
SetFileDialog(CFileDialog *pFileDialog) | CXTPBrowseEdit | virtual
SetFlatStyle(BOOL bFlatStyle=TRUE) | CXTPEdit |
SetGap(int nGap) | CXTPBrowseEdit |
SetMaskedText(LPCTSTR lpszMaskedText, int iPos=0, BOOL bUpdateWindow=TRUE) | CXTPMaskEditT< CEdit > | inline
SetOverType(BOOL bOverType) | CXTPMaskEditT< CEdit > | inline
SetPattern(LPCTSTR lpszPattern) | CXTPEdit |
SetPromptChar(TCHAR ch, BOOL bAutoReplace=TRUE) | CXTPMaskEditT< CEdit > | inline
SetTheme(XTPControlTheme nTheme) | CXTPEdit | virtual
SetUseMask(BOOL bUseMask) | CXTPMaskEditT< CEdit > | inline
SetUseVisualStyle(BOOL bUseVisualStyle=TRUE) | CXTPEdit |
ShowBorder() const | CXTPEdit |
ShowThemedBorder(BOOL bShowThemedBorder) | CXTPEdit |
~CXTPBrowseEdit() | CXTPBrowseEdit | virtual
~CXTPEdit() | CXTPEdit | virtual
~CXTPItemEdit() | CXTPItemEdit | virtual


Toolkit Pro: Member List

CXTPPropertyGridItems Member List

This is the complete list of members for CXTPPropertyGridItems, including all inherited members.

AddTail(CXTPPropertyGridItem *pItem) | CXTPPropertyGridItems | protected
AddTail(CXTPPropertyGridItems *pItems) | CXTPPropertyGridItems | protected
Clear() | CXTPPropertyGridItems |
CXTPCmdTarget() | CXTPCmdTarget |
CXTPPropertyGridItems() | CXTPPropertyGridItems | protected
Find(CXTPPropertyGridItem *pItem) const | CXTPPropertyGridItems |
FindItem(UINT nID) const | CXTPPropertyGridItems |
FindItem(LPCTSTR strCaption) const | CXTPPropertyGridItems |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAt(int nIndex) const | CXTPPropertyGridItems |
GetCount() const | CXTPPropertyGridItems |
InsertAt(int nIndex, CXTPPropertyGridItem *pItem) | CXTPPropertyGridItems | protected
IsEmpty() const | CXTPPropertyGridItems |
RemoveAt(int nIndex) | CXTPPropertyGridItems |
Sort() | CXTPPropertyGridItems |


Toolkit Pro: Member List

CXTPTabClientSticker Member List

This is the complete list of members for CXTPTabClientSticker, including all inherited members.

Create() | CXTPStickerBase |
CXTPStickerBase() | CXTPStickerBase |
CXTPTabClientSticker(CXTPTabClientWnd *pTabClientWnd, int nTabWorkspace) | CXTPTabClientSticker |
GetTargetTabClientWnd() const | CXTPTabClientSticker |
HitTest(POINT pt) const | CXTPTabClientSticker |
m_stickers | CXTPStickerBase | protected
~CXTPStickerBase() | CXTPStickerBase | virtual
~CXTPTabClientSticker() | CXTPTabClientSticker | virtual


Toolkit Pro: XTPSystemMetrics.h Source File

  • Source
  • Common
XTPSystemMetrics.h
Go to the documentation of this file.
1
23#if !defined(__XTPSYSTEMMETRICS_H__)
24# define __XTPSYSTEMMETRICS_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
37class _XTP_EXT_CLASS CXTPSystemMetrics
38{
39 friend class CXTPSingleton<CXTPSystemMetrics>;
40
41public:
46 CXTPSystemMetrics();
47
52 void RefreshMetrics();
53
54public:
55 int m_nBorderY;
56 int m_nCaptionY;
57 int m_nSizeFrameY;
60 int m_nSmallIconX;
61 int m_nSmallIconY;
63 int m_nIconX;
64 int m_nIconY;
66 CSize GetSmallIconSize() const; /* Small icon width and height. */
67 CSize GetIconSize() const; /* Icon width and height. */
68};
70AFX_INLINE CSize CXTPSystemMetrics::GetSmallIconSize() const
71{
72 return CSize(m_nSmallIconX, m_nSmallIconY);
73}
74
75AFX_INLINE CSize CXTPSystemMetrics::GetIconSize() const
76{
77 return CSize(m_nIconX, m_nIconY);
78}
79
80_XTP_EXT_CLASS CXTPSystemMetrics* AFX_CDECL XTPSystemMetrics();
87class _XTP_EXT_CLASS CXTPDeviceCaps
88{
89 friend class CXTPSingleton<CXTPDeviceCaps>;
90
91public:
96 CXTPDeviceCaps();
97
102 void RefreshMetrics();
103
104public:
105 int m_nLogPixelsX;
106 int m_nLogPixelsY;
107};
108
109_XTP_EXT_CLASS CXTPDeviceCaps* AFX_CDECL XTPDeviceCaps();
110
111# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
113#endif // !defined(__XTPSYSTEMMETRICS_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPDeviceCaps
The CXTPDeviceCaps class is used to store and update sytem information.
Definition XTPSystemMetrics.h:88
CXTPDeviceCaps::m_nLogPixelsY
int m_nLogPixelsY
Y location, see LOGPIXELSY.
Definition XTPSystemMetrics.h:106
CXTPDeviceCaps::CXTPDeviceCaps
CXTPDeviceCaps()
Call this member to refresh the metrics for this class.
CXTPDeviceCaps::m_nLogPixelsX
int m_nLogPixelsX
X location, see LOGPIXELSX.
Definition XTPSystemMetrics.h:105
CXTPDeviceCaps::RefreshMetrics
void RefreshMetrics()
Call this member to refresh the metrics for this class.
CXTPSingleton
Implements Singleton design pattern.
Definition XTPSingleton.h:215
CXTPSystemMetrics
The CXTPSystemMetrics class is used to store and update sytem information.
Definition XTPSystemMetrics.h:38
CXTPSystemMetrics::m_nBorderY
int m_nBorderY
The height of a window border, in pixels.
Definition XTPSystemMetrics.h:55
CXTPSystemMetrics::m_nSmallIconX
int m_nSmallIconX
Small icon width, see SM_CXSMICON.
Definition XTPSystemMetrics.h:60
CXTPSystemMetrics::m_nCaptionY
int m_nCaptionY
The height of a caption area, in pixels.
Definition XTPSystemMetrics.h:56
CXTPSystemMetrics::m_nIconY
int m_nIconY
Icon height see, SM_CYICON.
Definition XTPSystemMetrics.h:64
CXTPSystemMetrics::m_nSizeFrameY
int m_nSizeFrameY
The thickness of the sizing border around the perimeter of a window that can be resized,...
Definition XTPSystemMetrics.h:57
CXTPSystemMetrics::CXTPSystemMetrics
CXTPSystemMetrics()
Call this member to refresh the metrics for this class.
CXTPSystemMetrics::m_nSmallIconY
int m_nSmallIconY
Small icon height, see SM_CYSMICON.
Definition XTPSystemMetrics.h:61
CXTPSystemMetrics::m_nIconX
int m_nIconX
Icon width see, SM_CXICON.
Definition XTPSystemMetrics.h:63
CXTPSystemMetrics::RefreshMetrics
void RefreshMetrics()
Call this member to refresh the metrics for this class.


Toolkit Pro: Member List

  • CXTPSyntaxEditBufferCommand
  • CXTPSyntaxEditBufferKeepOverwriteSettings
CXTPSyntaxEditBufferCommand::CXTPSyntaxEditBufferKeepOverwriteSettings Member List

This is the complete list of members for CXTPSyntaxEditBufferCommand::CXTPSyntaxEditBufferKeepOverwriteSettings, including all inherited members.

CXTPSyntaxEditBufferKeepOverwriteSettings(CXTPSyntaxEditBufferManager *pBufferMgr) | CXTPSyntaxEditBufferCommand::CXTPSyntaxEditBufferKeepOverwriteSettings |
~CXTPSyntaxEditBufferKeepOverwriteSettings() | CXTPSyntaxEditBufferCommand::CXTPSyntaxEditBufferKeepOverwriteSettings | virtual


Toolkit Pro: XTPCustomizeSheet.h Source File

  • Source
  • CommandBars
  • Customize
XTPCustomizeSheet.h
Go to the documentation of this file.
1
23#if !defined(__XTPCUSTOMIZESHEET_H__) && defined(_XTP_INCLUDE_CONTROLS)
24# define __XTPCUSTOMIZESHEET_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPCommandBars;
34class CXTPCustomizeToolbarsPage;
35class CXTPCustomizeCommandsPage;
36class CXTPImageManager;
37class CXTPPropertyPage;
38class CXTPPopupBar;
39class CXTPControl;
40
46class _XTP_EXT_CLASS CXTPCustomizeSheet : public CXTPPropertySheet
47{
48public:
56 CXTPCustomizeSheet(CXTPCommandBars* pCommandBars, UINT iSelectPage = 0);
57
62 virtual ~CXTPCustomizeSheet();
63
64public:
74 CXTPPopupBar* GetContextMenu() const;
75
100 CXTPImageManager* GetCustomIcons() const;
101
111 int MessageBox(LPCTSTR lpszText, UINT nType = MB_OK);
112
120 CXTPControl* GetDragControl() const;
121
122public:
130 CXTPCustomizeCommandsPage* GetCommandsPage() const;
131
139 CXTPCustomizeToolbarsPage* GetToolbarsPage() const;
140
148 CXTPCommandBars* GetCommandBars() const;
149
155 INT_PTR DoModal();
156
163 void ContextMenu(CPoint point);
164
171 void AddPage(CXTPPropertyPage* pPage, int nIndex = -1);
172
173protected:
175 DECLARE_MESSAGE_MAP()
176
177 //{{AFX_VIRTUAL(CXTPCustomizeSheet)
178 BOOL OnInitDialog();
179 BOOL PreTranslateMessage(MSG* pMsg);
180 BOOL OnCmdMsg(UINT nID, int nCode, void* pExtra, AFX_CMDHANDLERINFO* pHandlerInfo);
181 //}}AFX_VIRTUAL
182
183 //{{AFX_MSG(CXTPCustomizeSheet)
184 afx_msg void OnCustomizeDefaultStyle();
185 afx_msg void OnCustomizeImageAndText();
186 afx_msg void OnCustomizeTextOnly();
187 afx_msg void OnCustomizeBeginGroup();
188 afx_msg void OnCustomizeDelete();
189 afx_msg void OnCustomizeCopyImage();
190 afx_msg void OnCustomizePasteImage();
191 afx_msg void OnCustomizeResetImage();
192 afx_msg void OnCustomizeEditImage();
193 afx_msg void OnCustomizeReset();
194 afx_msg LRESULT OnCustomizeName(WPARAM wParam, LPARAM lParam);
195 afx_msg void OnUpdateCustomizeDefaultStyle(CCmdUI* pCmdUI);
196 afx_msg void OnUpdateCustomizeImageAndText(CCmdUI* pCmdUI);
197 afx_msg void OnUpdateCustomizeTextOnly(CCmdUI* pCmdUI);
198 afx_msg void OnUpdateCustomizeBeginGroup(CCmdUI* pCmdUI);
199 afx_msg void OnUpdateCustomizeName(CCmdUI* pCmdUI);
200 afx_msg void OnUpdateCustomizeCopyImage(CCmdUI* pCmdUI);
201 afx_msg void OnUpdateCustomizePasteImage(CCmdUI* pCmdUI);
202 afx_msg void OnUpdateCustomizeResetImage(CCmdUI* pCmdUI);
203 afx_msg void OnUpdateCustomizeReset(CCmdUI* pCmdUI);
204 afx_msg void OnUpdateCustomizeEditImage(CCmdUI* pCmdUI);
205 afx_msg void OnSysKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags);
206 afx_msg void OnInitCommandsPopup(CXTPPopupBar* pPopupBar);
207 afx_msg void OnGrabFocus();
208 //}}AFX_MSG
211private:
212 BOOL FilterMouse(WPARAM wParam, LPARAM lParam);
213 BOOL FilterKey(WPARAM wParam, LPARAM lParam);
214 BOOL FilterMessage(WPARAM wParam, LPARAM lParam);
215 void CreateContextMenu();
216 BOOL IsAllowChangeStyle(CXTPControl* pControl) const;
217 virtual BOOL CreateClient();
218
219public:
220 BOOL m_bHookMainFrame;
221
222protected:
223 CXTPCustomizeToolbarsPage* m_pPageToolBars;
224 CXTPCustomizeCommandsPage* m_pPageCommands;
225 CWnd* m_pWndParent;
226 CXTPCommandBars* m_pCommandBars;
227 CXTPPopupBar* m_pContextMenu;
229 CXTPImageManager* m_pCustomIcons;
233private:
234 DECLARE_DYNAMIC(CXTPCustomizeSheet)
235
236 class CCustomizeButton;
237 class CCustomizeEdit;
238};
239
241
242AFX_INLINE CXTPCustomizeCommandsPage* CXTPCustomizeSheet::GetCommandsPage() const
243{
244 return m_pPageCommands;
245}
246AFX_INLINE CXTPCustomizeToolbarsPage* CXTPCustomizeSheet::GetToolbarsPage() const
247{
248 return m_pPageToolBars;
249}
250
251AFX_INLINE CXTPCommandBars* CXTPCustomizeSheet::GetCommandBars() const
252{
253 return m_pCommandBars;
254}
255AFX_INLINE CXTPPopupBar* CXTPCustomizeSheet::GetContextMenu() const
256{
257 return m_pContextMenu;
258}
259AFX_INLINE CXTPImageManager* CXTPCustomizeSheet::GetCustomIcons() const
260{
261 return m_pCustomIcons;
262}
264# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
265#endif // #if !defined(__XTPCUSTOMIZESHEET_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCommandBars
CXTPCommandBars is a standalone class.
Definition XTPCommandBars.h:165
CXTPControl
CXTPControl is a CXTPCmdTarget derived class.
Definition XTPControl.h:841
CXTPCustomizeCommandsPage
CXTPCustomizeCommandsPage is a CPropertyPage derived class.
Definition XTPCustomizePageCommands.h:130
CXTPCustomizeSheet
CXTPCustomizeSheet is a CPropertySheet derived class.
Definition XTPCustomizeSheet.h:47
CXTPCustomizeSheet::ContextMenu
void ContextMenu(CPoint point)
This method shows the context menu for toolbars.
CXTPCustomizeSheet::GetCommandBars
CXTPCommandBars * GetCommandBars() const
Returns the parent Command Bars class.
Definition XTPCustomizeSheet.h:251
CXTPCustomizeSheet::AddPage
void AddPage(CXTPPropertyPage *pPage, int nIndex=-1)
Adds the supplied page with the rightmost tab in the property sheet.
CXTPCustomizeSheet::GetToolbarsPage
CXTPCustomizeToolbarsPage * GetToolbarsPage() const
Returns the Toolbars PropertyPage.
Definition XTPCustomizeSheet.h:246
CXTPCustomizeSheet::~CXTPCustomizeSheet
virtual ~CXTPCustomizeSheet()
Destroys a CXTPCustomizeSheet object, handles cleanup and deallocation.
CXTPCustomizeSheet::GetDragControl
CXTPControl * GetDragControl() const
Call this member to retrieve the current customized control.
CXTPCustomizeSheet::GetContextMenu
CXTPPopupBar * GetContextMenu() const
Call this member to get a pointer to the context menu that is displayed in customization mode when a ...
Definition XTPCustomizeSheet.h:255
CXTPCustomizeSheet::MessageBox
int MessageBox(LPCTSTR lpszText, UINT nType=MB_OK)
Displays a message box.
CXTPCustomizeSheet::CXTPCustomizeSheet
CXTPCustomizeSheet(CXTPCommandBars *pCommandBars, UINT iSelectPage=0)
Constructs a CXTPCustomizeSheet object.
CXTPCustomizeSheet::GetCustomIcons
CXTPImageManager * GetCustomIcons() const
Retrieves collection of custom icons that can be selected for a control during customization mode.
Definition XTPCustomizeSheet.h:259
CXTPCustomizeSheet::DoModal
INT_PTR DoModal()
Call this method to show customize dialog.
CXTPCustomizeToolbarsPage
CXTPCustomizeToolbarsPage is a CPropertyPage derived class.
Definition XTPCustomizePageToolbars.h:64
CXTPImageManager
CXTPImageManager is a standalone class.
Definition XTPImageManager.h:1898
CXTPPopupBar
CXTPPopupBar is a CXTPCommandBar derived class.
Definition XTPPopupBar.h:42
CXTPPropertyPage
CXTPPropertyPage is a CPropertyPage derived class.
Definition XTPPropertyPage.h:43
CXTPPropertySheet
CXTPPropertySheet is a CXTPDialogEx derived class.
Definition XTPPropertySheet.h:65


Toolkit Pro: XTPSynchro.h Source File

  • Source
  • Common
XTPSynchro.h
Go to the documentation of this file.
1
23#if !defined(__XTPSYNCHRO_H__)
24# define __XTPSYNCHRO_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
34# ifdef _DEBUG
35# define XTP_ASYNC_ASSERT(expr) \
36 if (!(expr)) \
37 DebugBreak();
38# else
39# define XTP_ASYNC_ASSERT(expr)
40# endif
41
42# define XTP_SYNC_MAX_EXPONENTIAL_TIMEOUT 0x400
43
44namespace XTPDetails
45{
46struct XTPSynchroPrivateUseTag
47{
48};
49} // namespace XTPDetails
50
57class _XTP_EXT_CLASS CXTPSimpleEvent
58{
59 long m_bState;
61public:
68 explicit CXTPSimpleEvent(BOOL bInitialState);
69
74 void Reset();
75
80 void Set();
81
88 BOOL IsSignaled() const;
89
94 void Wait();
95
97private:
101 CXTPSimpleEvent(const CXTPSimpleEvent&);
102 CXTPSimpleEvent& operator=(const CXTPSimpleEvent&);
104};
105
111class _XTP_EXT_CLASS CXTPSimpleCriticalSection
112{
113 long m_nLock;
114 long m_nRecursionCounter;
115 DWORD m_dwThreadId;
116public:
121 CXTPSimpleCriticalSection()
122 : m_nLock(0)
123 , m_nRecursionCounter(0)
124 , m_dwThreadId(0)
125 {
126 }
127
132 ~CXTPSimpleCriticalSection();
133
142 void Enter();
143
150 void Leave();
151
156 class CLock
157 {
158 CXTPSimpleCriticalSection& m_cs;
159
160 public:
166 explicit CLock(CXTPSimpleCriticalSection& cs)
167 : m_cs(cs)
168 {
169 m_cs.Enter();
170 }
171
176 ~CLock()
177 {
178 m_cs.Leave();
179 }
180 };
181
183private:
184 // noncopyable
185 CXTPSimpleCriticalSection(const CXTPSimpleCriticalSection&);
186 CXTPSimpleCriticalSection& operator=(const CXTPSimpleCriticalSection&);
188};
189
194class _XTP_EXT_CLASS CXTPRWCriticalSection
195{
196public:
201 CXTPRWCriticalSection();
202
207 ~CXTPRWCriticalSection();
208
209public:
210 class CSharedLock;
211 class CExclusiveLock;
212
222 BOOL IsLockedSharedly() const volatile;
223
230 BOOL IsLockedExclusively() const volatile;
231
240 void LockShared();
241
246 void UnlockShared();
247
257 void LockExclusive();
258
263 void UnlockExclusive();
264
266private:
267# ifdef _DEBUG
268 class Diagnostic;
269 friend class Diagnostic;
270 static Diagnostic m_Diagnostic;
271# endif
272
273 void PushLocalSharedLockState();
274 void PopSharedLockState();
275 void LockShared(BOOL bPopMode);
276 void UnlockShared(BOOL bPushMode);
277 long IncrementLocalSharedLockCounter();
278 long DecrementLocalSharedLockCounter();
279 long GetLocalSharedLockCounter() const;
280
281private:
282 long m_nSharedLockCounter;
283 long m_nExclusiveLockCounter;
284 DWORD m_dwExclusiveLockTid;
286 CXTPSimpleCriticalSection m_csGeneral;
287 CXTPSimpleEvent m_sharedLockEvent;
289 static const DWORD m_nLocalSharedLockCounterTlsIdx;
290
291 typedef CMap<const CXTPRWCriticalSection*, const CXTPRWCriticalSection*, long, long>
292 LocalSharedLockCounterMap;
294};
295
300class CXTPRWCriticalSection::CSharedLock
301{
302public:
308 explicit CSharedLock(CXTPRWCriticalSection& cs)
309 : m_pCS(&cs)
310 {
311 m_pCS->LockShared();
312 }
313
319 ~CSharedLock()
320 {
321 if (NULL != m_pCS)
322 {
323 m_pCS->UnlockShared();
324 }
325 }
326
328public:
329 CSharedLock(CXTPRWCriticalSection* pCS, XTPDetails::XTPSynchroPrivateUseTag)
330 : m_pCS(pCS)
331 {
332 if (NULL != m_pCS)
333 {
334 m_pCS->LockShared();
335 }
336 }
337
338private:
339 CSharedLock(const CSharedLock&);
341private:
342 CXTPRWCriticalSection* m_pCS;
344};
345
350class CXTPRWCriticalSection::CExclusiveLock
351{
352public:
359 explicit CExclusiveLock(CXTPRWCriticalSection& cs)
360 : m_pCS(&cs)
361 {
362 m_pCS->LockExclusive();
363 }
364
370 ~CExclusiveLock()
371 {
372 if (NULL != m_pCS)
373 {
374 m_pCS->UnlockExclusive();
375 }
376 }
377
379public:
380 CExclusiveLock(CXTPRWCriticalSection* pCS, XTPDetails::XTPSynchroPrivateUseTag)
381 : m_pCS(pCS)
382 {
383 if (NULL != m_pCS)
384 {
385 m_pCS->LockExclusive();
386 }
387 }
388
389private:
390 CExclusiveLock(const CExclusiveLock&); // deleted
391
392private:
393 CXTPRWCriticalSection* m_pCS;
395};
396
402# define XTP_RWCS_LOCK_SHARED_SCOPE(cs) \
403 CXTPRWCriticalSection::CSharedLock $__xtpRWCSSharedLock(cs)
404
410# define XTP_RWCS_LOCK_EXCLUSIVE_SCOPE(cs) \
411 CXTPRWCriticalSection::CExclusiveLock $__xtpRWCSExclusiveLock(cs)
412
421template<class Adaptee, class RWLock>
422class CXTPAsyncGuard : public CXTPBlockStatementBase
423{
424public:
431 CXTPAsyncGuard(Adaptee& adaptee, CXTPRWCriticalSection& cs)
432 : m_locker(cs)
433 , m_adaptee(adaptee)
434 , m_pConditionCounter(NULL)
435 {
436 }
437
447 CXTPAsyncGuard(Adaptee& adaptee, CXTPRWCriticalSection& cs, long& nConditionCounter)
448 : m_locker(1 == InterlockedIncrement(&nConditionCounter) ? &cs : NULL,
449 XTPDetails::XTPSynchroPrivateUseTag())
450 , m_adaptee(adaptee)
451 , m_pConditionCounter(&nConditionCounter)
452 {
453 _ASSERTE(0 < nConditionCounter);
454 }
455
461 CXTPAsyncGuard(const CXTPAsyncGuard& rhs)
462 : m_locker(rhs.m_locker.m_pCS)
463 , m_adaptee(rhs.m_adaptee)
464 , m_pConditionCounter(rhs.m_pConditionCounter)
465 {
466 if (NULL != m_pConditionCounter)
467 {
468 InterlockedIncrement(m_pConditionCounter);
469 }
470 }
471
478 ~CXTPAsyncGuard()
479 {
480 if (NULL != m_pConditionCounter)
481 {
482 long nConditionCounter = InterlockedDecrement(m_pConditionCounter);
483 _ASSERTE(0 <= nConditionCounter);
484 UNREFERENCED_PARAMETER(nConditionCounter);
485 }
486 }
487
494 Adaptee* operator->()
495 {
496 return &m_adaptee;
497 }
498
505 const Adaptee* operator->() const
506 {
507 return &m_adaptee;
508 }
509
516 Adaptee& operator*()
517 {
518 return m_adaptee;
519 }
520
527 const Adaptee& operator*() const
528 {
529 return m_adaptee;
530 }
531
538 operator Adaptee*()
539 {
540 return &m_adaptee;
541 }
542
549 operator const Adaptee*() const
550 {
551 return &m_adaptee;
552 }
553
555private:
556 RWLock m_locker;
557 Adaptee& m_adaptee;
558 long* m_pConditionCounter;
560};
561
563namespace XTPDetails
564{
565template<class T>
566struct XTPAsyncGuardShortcut
567{
568 typedef CXTPAsyncGuard<T, CXTPRWCriticalSection::CSharedLock> XTPAsyncSharedGuard;
569 typedef CXTPAsyncGuard<T, CXTPRWCriticalSection::CExclusiveLock> XTPAsyncExclusiveGuard;
570 typedef CXTPAsyncGuard<const T, CXTPRWCriticalSection::CSharedLock> XTPAsyncConstSharedGuard;
571 typedef CXTPAsyncGuard<const T, CXTPRWCriticalSection::CExclusiveLock>
572 XTPAsyncConstExclusiveGuard;
573};
574
575class CXTPConditionBlock : public CXTPBlockStatementBase
576{
577 long& m_nConditionCounter;
578
579public:
580 CXTPConditionBlock(long& nConditionCounter)
581 : m_nConditionCounter(nConditionCounter)
582 {
583 _ASSERTE(0 <= m_nConditionCounter);
584 InterlockedIncrement(&m_nConditionCounter);
585 }
586
587 ~CXTPConditionBlock()
588 {
589 long nConditionCounter = InterlockedDecrement(&m_nConditionCounter);
590 _ASSERTE(0 <= nConditionCounter);
591 UNREFERENCED_PARAMETER(nConditionCounter);
592 }
593};
594} // namespace XTPDetails
601class CXTPSynchronized
602{
603public:
610 CXTPRWCriticalSection& GetAccessCriticalSection() const
611 {
612 return m_cs;
613 }
614
616protected:
617 CXTPSynchronized()
618 {
619 }
620
621private:
622 mutable CXTPRWCriticalSection m_cs;
624};
625
634template<class T>
635AFX_INLINE CXTPAsyncGuard<T, CXTPRWCriticalSection::CSharedLock> XTPAccessShared(T* pObject)
636{
637 _ASSERTE(NULL != pObject);
638 return CXTPAsyncGuard<T, CXTPRWCriticalSection::CSharedLock>(
639 *pObject, pObject->CXTPSynchronized::GetAccessCriticalSection());
640}
641
653template<class T>
654AFX_INLINE CXTPAsyncGuard<T, CXTPRWCriticalSection::CSharedLock>
655 XTPAccessShared(T* pObject, long& nConditionCounter)
656{
657 _ASSERTE(NULL != pObject);
658 return CXTPAsyncGuard<T, CXTPRWCriticalSection::CSharedLock>(
659 *pObject, pObject->CXTPSynchronized::GetAccessCriticalSection(), nConditionCounter);
660}
661
670template<class T>
671AFX_INLINE CXTPAsyncGuard<T, CXTPRWCriticalSection::CExclusiveLock> XTPAccessExclusive(T* pObject)
672{
673 _ASSERTE(NULL != pObject);
674 return CXTPAsyncGuard<T, CXTPRWCriticalSection::CExclusiveLock>(
675 *pObject, pObject->CXTPSynchronized::GetAccessCriticalSection());
676}
677
689template<class T>
690AFX_INLINE CXTPAsyncGuard<T, CXTPRWCriticalSection::CExclusiveLock>
691 XTPAccessExclusive(T* pObject, long& nConditionCounter)
692{
693 _ASSERTE(NULL != pObject);
694 return CXTPAsyncGuard<T, CXTPRWCriticalSection::CExclusiveLock>(
695 *pObject, pObject->CXTPSynchronized::GetAccessCriticalSection(), nConditionCounter);
696}
697
705# define XTP_GUARD_SHARED_(Type, Object, Guard) \
706 XTP_BLOCKSTATEMENT(::XTPDetails::XTPAsyncGuardShortcut<Type>::XTPAsyncSharedGuard, Guard, \
707 XTPAccessShared(Object))
708
719# define XTP_GUARD_SHARED_COND_(Type, Object, Guard, ConditionCounter) \
720 XTP_BLOCKSTATEMENT(::XTPDetails::XTPAsyncGuardShortcut<Type>::XTPAsyncSharedGuard, Guard, \
721 XTPAccessShared(Object, ConditionCounter))
722
729# define XTP_GUARD_SHARED(Type, Object) XTP_GUARD_SHARED_(Type, Object, $__xtpGuard)
730
740# define XTP_GUARD_SHARED_COND(Type, Object, ConditionCounter) \
741 XTP_GUARD_SHARED_COND_(Type, Object, $__xtpGuard, ConditionCounter)
742
750# define XTP_GUARD_SHARED_CONST_(Type, Object, Guard) \
751 XTP_BLOCKSTATEMENT(::XTPDetails::XTPAsyncGuardShortcut<Type>::XTPAsyncConstSharedGuard, \
752 Guard, XTPAccessShared(Object))
753
764# define XTP_GUARD_SHARED_COND_CONST_(Type, Object, Guard, ConditionCounter) \
765 XTP_BLOCKSTATEMENT(::XTPDetails::XTPAsyncGuardShortcut<Type>::XTPAsyncConstSharedGuard, \
766 Guard, XTPAccessShared(Object, ConditionCounter))
767
774# define XTP_GUARD_SHARED_CONST(Type, Object) XTP_GUARD_SHARED_CONST_(Type, Object, $__xtpGuard)
775
785# define XTP_GUARD_SHARED_COND_CONST(Type, Object, ConditionCounter) \
786 XTP_GUARD_SHARED_COND_CONST_(Type, Object, $__xtpGuard, ConditionCounter)
787
795# define XTP_GUARD_EXCLUSIVE_(Type, Object, Guard) \
796 XTP_BLOCKSTATEMENT(::XTPDetails::XTPAsyncGuardShortcut<Type>::XTPAsyncExclusiveGuard, \
797 Guard, XTPAccessExclusive(Object))
798
809# define XTP_GUARD_EXCLUSIVE_COND_(Type, Object, Guard, ConditionCounter) \
810 XTP_BLOCKSTATEMENT(::XTPDetails::XTPAsyncGuardShortcut<Type>::XTPAsyncExclusiveGuard, \
811 Guard, XTPAccessExclusive(Object, ConditionCounter))
812
819# define XTP_GUARD_EXCLUSIVE(Type, Object) XTP_GUARD_EXCLUSIVE_(Type, Object, $__xtpGuard)
820
830# define XTP_GUARD_EXCLUSIVE_COND(Type, Object, ConditionCounter) \
831 XTP_GUARD_EXCLUSIVE_COND_(Type, Object, $__xtpGuard, ConditionCounter)
832
840# define XTP_GUARD_EXCLUSIVE_CONST_(Type, Object, Guard) \
841 XTP_BLOCKSTATEMENT(::XTPDetails::XTPAsyncGuardShortcut<Type>::XTPAsyncConstExclusiveGuard, \
842 Guard, XTPAccessExclusive(Object))
843
854# define XTP_GUARD_EXCLUSIVE_CONST_COND_(Type, Object, Guard, ConditionCounter) \
855 XTP_BLOCKSTATEMENT(::XTPDetails::XTPAsyncGuardShortcut<Type>::XTPAsyncConstExclusiveGuard, \
856 Guard, XTPAccessExclusive(Object, ConditionCounter))
857
864# define XTP_GUARD_EXCLUSIVE_CONST(Type, Object) \
865 XTP_GUARD_EXCLUSIVE_CONST_(Type, Object, $__xtpGuard)
866
876# define XTP_GUARD_EXCLUSIVE_COND_CONST(Type, Object, ConditionCounter) \
877 XTP_GUARD_EXCLUSIVE_COND_CONST_(Type, Object, $__xtpGuard, ConditionCounter)
878
879# define XTP_ENTER_GUARD_CONDITION(ConditionCounter) \
880 XTP_BLOCKSTATEMENT(::XTPDetails::CXTPConditionBlock, $__xtpConditionBlock, ConditionCounter)
881
882# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
883
885#endif // !defined(__XTPSYNCHRO_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPAccessExclusive
AFX_INLINE CXTPAsyncGuard< T, CXTPRWCriticalSection::CExclusiveLock > XTPAccessExclusive(T *pObject)
A convenience function for building an exclusive-lock guard for an object specified.
Definition XTPSynchro.h:671
XTPAccessShared
AFX_INLINE CXTPAsyncGuard< T, CXTPRWCriticalSection::CSharedLock > XTPAccessShared(T *pObject)
A convenience function for building a shared-lock guard for an object specified.
Definition XTPSynchro.h:635
CXTPAsyncGuard
A convenience class for guarding an adapted object reference by a RW-lock provided.
Definition XTPSynchro.h:423
CXTPAsyncGuard::~CXTPAsyncGuard
~CXTPAsyncGuard()
Handles guard destruction.
Definition XTPSynchro.h:478
CXTPAsyncGuard::operator->
Adaptee * operator->()
Accesses an adapted object's pointer.
Definition XTPSynchro.h:494
CXTPAsyncGuard::operator->
const Adaptee * operator->() const
Accesses an adapted object's pointer.
Definition XTPSynchro.h:505
CXTPAsyncGuard::operator*
Adaptee & operator*()
Accesses an adapted object's reference.
Definition XTPSynchro.h:516
CXTPAsyncGuard::CXTPAsyncGuard
CXTPAsyncGuard(Adaptee &adaptee, CXTPRWCriticalSection &cs, long &nConditionCounter)
Constructs the guard object.
Definition XTPSynchro.h:447
CXTPAsyncGuard::operator*
const Adaptee & operator*() const
Accesses an adapted object's reference.
Definition XTPSynchro.h:527
CXTPAsyncGuard::CXTPAsyncGuard
CXTPAsyncGuard(const CXTPAsyncGuard &rhs)
Copies the guard object.
Definition XTPSynchro.h:461
CXTPAsyncGuard::CXTPAsyncGuard
CXTPAsyncGuard(Adaptee &adaptee, CXTPRWCriticalSection &cs)
Constructs the guard object.
Definition XTPSynchro.h:431
CXTPRWCriticalSection::CExclusiveLock
A convenience class for obtaining exclusive lock for a scope.
Definition XTPSynchro.h:351
CXTPRWCriticalSection::CExclusiveLock::~CExclusiveLock
~CExclusiveLock()
Destructs exclusive lock instance, releases exclusive lock on critical section provided during constr...
Definition XTPSynchro.h:370
CXTPRWCriticalSection::CExclusiveLock::CExclusiveLock
CExclusiveLock(CXTPRWCriticalSection &cs)
Constructs exclusive lock instance, obtains exclusive lock on critical section provided.
Definition XTPSynchro.h:359
CXTPRWCriticalSection::CSharedLock
A convenience class for obtaining shared lock for a scope.
Definition XTPSynchro.h:301
CXTPRWCriticalSection::CSharedLock::CSharedLock
CSharedLock(CXTPRWCriticalSection &cs)
Constructs shared lock instance, obtains shared lock on critical section provided.
Definition XTPSynchro.h:308
CXTPRWCriticalSection::CSharedLock::~CSharedLock
~CSharedLock()
Destructs shared lock instance, releases shared lock on critical section provided during construction...
Definition XTPSynchro.h:319
CXTPRWCriticalSection
Implements recursive read-write lock synchronization pattern.
Definition XTPSynchro.h:195
CXTPRWCriticalSection::IsLockedSharedly
BOOL IsLockedSharedly() const volatile
Determines if critical section is currently locked in shared mode.
CXTPRWCriticalSection::~CXTPRWCriticalSection
~CXTPRWCriticalSection()
Handles read-write lock critical section.
CXTPRWCriticalSection::UnlockShared
void UnlockShared()
Leaves shared lock mode.
CXTPRWCriticalSection::LockShared
void LockShared()
Enters shared lock mode.
CXTPRWCriticalSection::CXTPRWCriticalSection
CXTPRWCriticalSection()
Constructs read-write lock critical section.
CXTPRWCriticalSection::UnlockExclusive
void UnlockExclusive()
Leaves exclusive lock mode.
CXTPRWCriticalSection::IsLockedExclusively
BOOL IsLockedExclusively() const volatile
Determines if critical section is currently locked exclusively.
CXTPRWCriticalSection::LockExclusive
void LockExclusive()
Enters exclusive lock mode.
CXTPSimpleCriticalSection::CLock
A helper class for locking a scope or providing exception safe locking.
Definition XTPSynchro.h:157
CXTPSimpleCriticalSection::CLock::~CLock
~CLock()
Unlocks the previously locked critical.
Definition XTPSynchro.h:176
CXTPSimpleCriticalSection::CLock::CLock
CLock(CXTPSimpleCriticalSection &cs)
Locks a critical section passed.
Definition XTPSynchro.h:166
CXTPSimpleCriticalSection
Implements simple and lightweight synchronization critical section primitive.
Definition XTPSynchro.h:112
CXTPSimpleCriticalSection::~CXTPSimpleCriticalSection
~CXTPSimpleCriticalSection()
Handles critical section destruction.
CXTPSimpleCriticalSection::Enter
void Enter()
Enters critical section.
CXTPSimpleCriticalSection::Leave
void Leave()
Releases the critical section.
CXTPSimpleCriticalSection::CXTPSimpleCriticalSection
CXTPSimpleCriticalSection()
Construct critical section.
Definition XTPSynchro.h:121
CXTPSimpleEvent
Implements no-named simple and lightweight synchronization event primitive.
Definition XTPSynchro.h:58
CXTPSimpleEvent::Reset
void Reset()
Resets an event to non-signaled state.
CXTPSimpleEvent::Set
void Set()
Sets an event to signaled state.
CXTPSimpleEvent::Wait
void Wait()
Waits infinitely for an event to enter signaled states.
CXTPSimpleEvent::CXTPSimpleEvent
CXTPSimpleEvent(BOOL bInitialState)
Constructs an event object.
CXTPSimpleEvent::IsSignaled
BOOL IsSignaled() const
Determines if an event is in signaled state.
CXTPSynchronized
A base class for a synchronized object.
Definition XTPSynchro.h:602
CXTPSynchronized::GetAccessCriticalSection
CXTPRWCriticalSection & GetAccessCriticalSection() const
Accesses a synchronized object's critical section.
Definition XTPSynchro.h:610


Toolkit Pro: Member List

CXTPColorSelectorCtrlThemeOffice2003 Member List

This is the complete list of members for CXTPColorSelectorCtrlThemeOffice2003, including all inherited members.

CalcSize(CXTPColorSelectorCtrl *pOwner) | CXTPColorSelectorCtrlTheme | virtual
CreateAutoButton(CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked) | CXTPColorSelectorCtrlTheme | virtual
CreateColorButtons(CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked) | CXTPColorSelectorCtrlTheme | virtual
CreateExtendedButtons(CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked) | CXTPColorSelectorCtrlTheme | virtual
CreateMoreButton(CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked) | CXTPColorSelectorCtrlTheme | virtual
CreateRecentColorButtons(CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked) | CXTPColorSelectorCtrlTheme | virtual
CreateThemeButtons(CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked) | CXTPColorSelectorCtrlTheme | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPColorSelectorCtrlTheme() | CXTPColorSelectorCtrlTheme |
CXTPColorSelectorCtrlThemeOffice2003() | CXTPColorSelectorCtrlThemeOffice2003 |
CXTPColorSelectorCtrlThemeOfficeXP() | CXTPColorSelectorCtrlThemeOfficeXP |
CXTPControlTheme() | CXTPControlTheme |
DrawColorCell(CDC *pDC, CXTPColorSelectorCtrl *pOwner, CXTPColorSelectorCtrl::COLOR_CELL *pColorCell, BOOL bHighlight, BOOL bPressed) | CXTPColorSelectorCtrlTheme | virtual
DrawColorSelector(CDC *pDC, CXTPColorSelectorCtrl *pOwner) | CXTPColorSelectorCtrlTheme | virtual
FillBackground(CDC *pDC, CXTPColorSelectorCtrl *pOwner, const CRect &rect) | CXTPColorSelectorCtrlTheme | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetButtonSize() const | CXTPColorSelectorCtrlTheme | virtual
GetThemeStyle() const | CXTPControlTheme |
m_bThinBorder | CXTPColorSelectorCtrlTheme |
m_crBack | CXTPColorSelectorCtrlTheme |
m_crBackChecked | CXTPColorSelectorCtrlTheme |
m_crBackHilight | CXTPColorSelectorCtrlTheme |
m_crBackPressed | CXTPColorSelectorCtrlTheme |
m_crBorder | CXTPColorSelectorCtrlTheme |
m_crBorderHilight | CXTPColorSelectorCtrlTheme |
m_crBorderPressed | CXTPColorSelectorCtrlTheme |
m_crPopupBorder | CXTPColorSelectorCtrlTheme |
m_crText | CXTPColorSelectorCtrlTheme |
m_crTextPressed | CXTPColorSelectorCtrlTheme |
m_nAutoButton | CXTPColorSelectorCtrlTheme |
m_nCaption | CXTPColorSelectorCtrlTheme |
m_nMargin | CXTPColorSelectorCtrlTheme |
m_nTheme | CXTPControlTheme | protected
m_rcRecentText | CXTPColorSelectorCtrlTheme |
m_rcStandardText | CXTPColorSelectorCtrlTheme |
m_rcThemeText | CXTPColorSelectorCtrlTheme |
m_sizeButton | CXTPColorSelectorCtrlTheme |
RefreshMetrics(CXTPColorSelectorCtrl *pOwner) | CXTPColorSelectorCtrlThemeOffice2003 | virtual
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static


Toolkit Pro: XTPMarkupDelegate.h Source File

  • Source
  • Markup
XTPMarkupDelegate.h
Go to the documentation of this file.
1
23#if !defined(__XTPMARKUPDELEGATE_H__)
24# define __XTPMARKUPDELEGATE_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPMarkupRoutedEventArgs;
34
35class _XTP_EXT_CLASS CXTPMarkupDelegate : public CXTPMarkupObject
36{
38 DECLARE_DYNAMIC(CXTPMarkupDelegate);
40public:
41 CXTPMarkupDelegate();
42
43 virtual void Execute(CXTPMarkupObject* /*pSender*/, CXTPMarkupRoutedEventArgs* /*pArgs*/);
44};
45
46template<class T>
47class CXTPMarkupClassDelegate : public CXTPMarkupDelegate
48{
49public:
50 typedef void (T::*ROUTEDEVENTHANDLER)(CXTPMarkupObject* pSender,
51 CXTPMarkupRoutedEventArgs* pArgs);
52
53public:
54 CXTPMarkupClassDelegate(T* pObject, ROUTEDEVENTHANDLER pHandler)
55 : m_pObject(pObject)
56 , m_pHandler(pHandler)
57 {
58 _ASSERTE(NULL != pObject);
59 _ASSERTE(NULL != pHandler);
60 }
61
62 virtual void Execute(CXTPMarkupObject* pSender, CXTPMarkupRoutedEventArgs* pArgs)
63 {
64 (m_pObject->*m_pHandler)(pSender, pArgs);
65 }
66
67protected:
68 T* m_pObject;
69 ROUTEDEVENTHANDLER m_pHandler;
70};
71
72class _XTP_EXT_CLASS CXTPMarkupFunctionDelegate : public CXTPMarkupDelegate
73{
74 DECLARE_DYNAMIC(CXTPMarkupFunctionDelegate);
75
76public:
77 typedef void(AFX_CDECL* ROUTEDEVENTHANDLER)(CXTPMarkupObject* pSender,
78 CXTPMarkupRoutedEventArgs* pArgs);
79
80public:
81 CXTPMarkupFunctionDelegate(ROUTEDEVENTHANDLER pHandler);
82
83 virtual void Execute(CXTPMarkupObject* pSender, CXTPMarkupRoutedEventArgs* pArgs);
84
85protected:
86 ROUTEDEVENTHANDLER m_pHandler;
87};
88
89class _XTP_EXT_CLASS CXTPMarkupDispatchDelegate : public CXTPMarkupDelegate
90{
91 DECLARE_DYNAMIC(CXTPMarkupDispatchDelegate);
92
93public:
94 CXTPMarkupDispatchDelegate(IDispatch* pDisp);
95 ~CXTPMarkupDispatchDelegate();
96
97 IDispatch* GetDelegateDispatch(BOOL bAddRef = TRUE) const;
98
99 virtual void Execute(CXTPMarkupObject* pSender, CXTPMarkupRoutedEventArgs* pArgs);
100
101protected:
102 CXTPMarkupDispatchDelegate(const CXTPMarkupDispatchDelegate&);
103 CXTPMarkupDispatchDelegate& operator=(const CXTPMarkupDispatchDelegate&);
104
105 IDispatch* m_pDisp;
106};
107
108template<class T, typename EVENTHANDLER>
109AFX_INLINE CXTPMarkupDelegate* CreateMarkupClassDelegate(T* pClass, EVENTHANDLER pfnDelegate)
110{
111 return new CXTPMarkupClassDelegate<T>(
112 pClass, (typename CXTPMarkupClassDelegate<T>::ROUTEDEVENTHANDLER)pfnDelegate);
113}
114
115template<typename EVENTHANDLER>
116AFX_INLINE CXTPMarkupDelegate* CreateMarkupFunctionDelegate(EVENTHANDLER pfnDelegate)
117{
118 return new CXTPMarkupFunctionDelegate(
119 (CXTPMarkupFunctionDelegate::ROUTEDEVENTHANDLER)pfnDelegate);
120}
121
122# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
124#endif // !defined(__XTPMARKUPDELEGATE_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h


Toolkit Pro: XTPMarkupPathGeometry.h Source File

  • Source
  • Markup
  • Shapes
XTPMarkupPathGeometry.h
Go to the documentation of this file.
1
23#if !defined(__XTPMARKUPPATHGEOMETRY_H__)
24# define __XTPMARKUPPATHGEOMETRY_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPMarkupBuilder;
34class CXTPMarkupObject;
35class CXTPMarkupDependencyProperty;
36
37class _XTP_EXT_CLASS CXTPMarkupPathGeometry : public CXTPMarkupObject
38{
40 DECLARE_MARKUPCLASS(CXTPMarkupPathGeometry);
42protected:
43 CXTPMarkupPathGeometry();
44 ~CXTPMarkupPathGeometry();
45
46protected:
47 void SetContentObject(CXTPMarkupBuilder* pBuilder, CXTPMarkupObject* pContent);
48 CXTPMarkupObject* ConvertFrom(CXTPMarkupBuilder* pBuilder, CXTPMarkupObject* pObject) const;
49
50public:
51 static CXTPMarkupDependencyProperty* m_pPropertyGeometryFigures;
52};
53
54# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
56#endif // !defined(__XTPMARKUPPATHGEOMETRY_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h


Toolkit Pro: Member List

CXTPHexEdit Member List

This is the complete list of members for CXTPHexEdit, including all inherited members.

Create(DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID) | CXTPHexEdit | virtual
Create(LPCTSTR lpszClassName, LPCTSTR lpszWindowName, DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID, CCreateContext *pContext=NULL) | CXTPHexEdit | virtual
CXTPHexEdit() | CXTPHexEdit |
editAscii enum value | CXTPHexEdit | protected
editHigh enum value | CXTPHexEdit | protected
editLow enum value | CXTPHexEdit | protected
EditMode enum name | CXTPHexEdit | protected
editNone enum value | CXTPHexEdit | protected
EnableCaret(bool bEnable) | CXTPHexEdit |
EnableScrollBars(bool bVertical, bool bHorizontal) | CXTPHexEdit |
GetActualBackColor() | CXTPHexEdit |
GetActualHighlightBackColor() | CXTPHexEdit |
GetActualHighlightTextColor() | CXTPHexEdit |
GetActualTextColor() | CXTPHexEdit |
GetAllowDeletes() const | CXTPHexEdit |
GetBackColor() | CXTPHexEdit |
GetData(LPBYTE pData, int nBufferLength) | CXTPHexEdit |
GetDisabledBackColor() | CXTPHexEdit |
GetDisabledHighlightBackColor() | CXTPHexEdit |
GetDisabledHighlightTextColor() | CXTPHexEdit |
GetDisabledTextColor() | CXTPHexEdit |
GetHighlightBackColor() | CXTPHexEdit |
GetHighlightTextColor() | CXTPHexEdit |
GetSel() | CXTPHexEdit |
GetSel(int &nSelStart, int &nSelEnd) | CXTPHexEdit |
GetTextColor() | CXTPHexEdit |
IsReadOnly() const | CXTPHexEdit |
m_bAddressIsWide | CXTPHexEdit |
m_bAllowDeletes | CXTPHexEdit |
m_bDynamicBPR | CXTPHexEdit |
m_bShowAddress | CXTPHexEdit |
m_bShowAscii | CXTPHexEdit |
m_bShowCaret | CXTPHexEdit | protected
m_bShowHex | CXTPHexEdit |
m_bUpdate | CXTPHexEdit |
m_crBack | CXTPHexEdit | protected
m_crDisabledBack | CXTPHexEdit | protected
m_crDisabledHighlightBack | CXTPHexEdit | protected
m_crDisabledHighlightText | CXTPHexEdit | protected
m_crDisabledText | CXTPHexEdit | protected
m_crHighlightBack | CXTPHexEdit | protected
m_crHighlightText | CXTPHexEdit | protected
m_crText | CXTPHexEdit | protected
m_dwBaseAddress | CXTPHexEdit |
m_eEditMode | CXTPHexEdit |
m_nBytePerRow | CXTPHexEdit |
m_nCurrentAddress | CXTPHexEdit |
m_nLength | CXTPHexEdit |
m_nLineHeight | CXTPHexEdit |
m_nLinesPerPage | CXTPHexEdit |
m_nMaxLength | CXTPHexEdit |
m_nNullWidth | CXTPHexEdit |
m_nOffAddress | CXTPHexEdit |
m_nOffAscii | CXTPHexEdit |
m_nOffHex | CXTPHexEdit |
m_nSelEnd | CXTPHexEdit |
m_nSelStart | CXTPHexEdit |
m_nTopIndex | CXTPHexEdit |
m_pData | CXTPHexEdit |
m_ptEditPos | CXTPHexEdit |
m_szCaret | CXTPHexEdit | protected
m_xtpFontHex | CXTPHexEdit | protected
OnChange() | CXTPHexEdit | virtual
RestoreDefaultFont() | CXTPHexEdit |
SetAddressBase(DWORD dwBase) | CXTPHexEdit |
SetAllowDeletes(bool bVal=true) | CXTPHexEdit |
SetBackColor(COLORREF crBack) | CXTPHexEdit |
SetBPR(int nBytePerRow) | CXTPHexEdit |
SetData(LPBYTE pData, int nLength, int nMaxLength=0) | CXTPHexEdit |
SetDisabledBackColor(COLORREF crDisabledBack) | CXTPHexEdit |
SetDisabledHighlightBackColor(COLORREF crDisabledHighlight) | CXTPHexEdit |
SetDisabledHighlightTextColor(COLORREF crDisabledHighlightText) | CXTPHexEdit |
SetDisabledTextColor(COLORREF crDisabledText) | CXTPHexEdit |
SetHexFont(CFont *pFont) | CXTPHexEdit |
SetHexFont(LOGFONT *pLogFont) | CXTPHexEdit |
SetHighlightBackColor(COLORREF crHighlight) | CXTPHexEdit |
SetHighlightTextColor(COLORREF crHighlightText) | CXTPHexEdit |
SetOptions(BOOL bShowAddress, BOOL bShowHex, BOOL bShowAscii, BOOL bAddressIsWide) | CXTPHexEdit |
SetSel(int nSelStart, int nSelEnd) | CXTPHexEdit |
SetTextColor(COLORREF crText) | CXTPHexEdit |
~CXTPHexEdit() | CXTPHexEdit | virtual


Toolkit Pro: XTPMessageBarThemeResource.h Source File

  • Source
  • CommandBars
  • MessageBar
XTPMessageBarThemeResource.h
Go to the documentation of this file.
1
23#if !defined(__XTPMESSAGEBARTHEMERESOURCE_H__)
24# define __XTPMESSAGEBARTHEMERESOURCE_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPResourceTheme;
34class CXTPMessageBar;
35class CXTPMessageBarButton;
36
37class _XTP_EXT_CLASS CXTPMessageBarThemeResource : public CXTPMessageBarPaintManager
38{
39public:
40 CXTPMessageBarThemeResource(CXTPResourceTheme* pTheme);
41
48 virtual void FillMessageBar(CDC* pDC, CXTPMessageBar* pBar);
49
56 virtual void DrawMessageBarButton(CDC* pDC, CXTPMessageBarButton* pButton);
57
62 virtual CSize GetDefaultButtonSize() const;
63
68 virtual int GetHeight() const;
69
70protected:
71 CXTPResourceTheme* m_pTheme;
72};
73
75# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
76#endif // !defined(__XTPMESSAGEBARTHEMERESOURCE_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPMessageBarButton
CXTPMessageBarButton is a standalone class.
Definition XTPMessageBar.h:48
CXTPMessageBar
CXTPMessageBar is a CControlBar derived class.
Definition XTPMessageBar.h:88
CXTPMessageBarPaintManager
The CXTPMessageBarPaintManager class is used by the message bar to perform standard paint routines.
Definition XTPMessageBarPaintManager.h:39
CXTPMessageBarPaintManager::GetDefaultButtonSize
virtual CSize GetDefaultButtonSize() const
CXTPMessageBarPaintManager::DrawMessageBarButton
virtual void DrawMessageBarButton(CDC *pDC, CXTPMessageBarButton *pButton)
Call this member to draw a button in the message bar.
CXTPMessageBarPaintManager::FillMessageBar
virtual void FillMessageBar(CDC *pDC, CXTPMessageBar *pBar)
Draws the message bar.
CXTPMessageBarPaintManager::GetHeight
virtual int GetHeight() const
CXTPResourceTheme
The CXTPResourceTheme class is used to enable a resource style theme for Command Bars.
Definition XTPCommandBarsResourceTheme.h:46


Toolkit Pro: XTPDockingPaneThemeOffice2007Visio.h Source File

  • Source
  • DockingPane
  • Themes
XTPDockingPaneThemeOffice2007Visio.h
Go to the documentation of this file.
1
23#if !defined(__XTPDOCKINGPANETHEMEOFFICE2007VISIO_H__)
24# define __XTPDOCKINGPANETHEMEOFFICE2007VISIO_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
41class _XTP_EXT_CLASS CXTPDockingPaneOffice2007VisioTheme
42 : public CXTPDockingPaneOffice2003VisioTheme
43{
44public:
49 CXTPDockingPaneOffice2007VisioTheme();
50};
51
52# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
54#endif // !defined(__XTPDOCKINGPANETHEMEOFFICE2007VISIO_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPDockingPaneOffice2003VisioTheme
CXTPDockingPaneOffice2003VisioTheme is a CXTPDockingPaneOffice2002VisioTheme derived class that repre...
Definition XTPDockingPaneThemeOffice2003Visio.h:43
CXTPDockingPaneOffice2007VisioTheme
CXTPDockingPaneOffice2007VisioTheme is a CXTPDockingPaneOffice2003VisioTheme derived class that repre...
Definition XTPDockingPaneThemeOffice2007Visio.h:43
CXTPDockingPaneOffice2007VisioTheme::CXTPDockingPaneOffice2007VisioTheme
CXTPDockingPaneOffice2007VisioTheme()
Constructs a CXTPDockingPaneOffice2007VisioTheme object.


Toolkit Pro: Member List

CXTPDockingPaneVisualStudio2022Theme Member List

This is the complete list of members for CXTPDockingPaneVisualStudio2022Theme, including all inherited members.

AdjustCaptionRect(const CXTPDockingPaneTabbedContainer *pPane, CRect &rc) | CXTPDockingPaneVisualStudio2012Theme | virtual
CXTPDockingPaneDefaultTheme::AdjustCaptionRect(const CXTPDockingPaneSidePanel *pPane, CRect &rc) | CXTPDockingPanePaintManager | virtual
AdjustClientRect(CXTPDockingPaneTabbedContainer *pPane, CRect &rc, BOOL bApply) | CXTPDockingPaneVisualStudio2012Theme | virtual
CXTPDockingPaneDefaultTheme::AdjustClientRect(CXTPDockingPaneSidePanel *pPane, CRect &rect) | CXTPDockingPanePaintManager | virtual
ClipAndAddEllipsisIfNeeded(CDC *pDC, CString &strTitle, int nCaptionWidth) const | CXTPDockingPanePaintManager | protected
CXTPCmdTarget() | CXTPCmdTarget |
CXTPDockingPaneDefaultTheme() | CXTPDockingPaneDefaultTheme |
CXTPDockingPanePaintManager() | CXTPDockingPanePaintManager | protected
CXTPDockingPaneVisualStudio2012Theme() | CXTPDockingPaneVisualStudio2012Theme |
CXTPDockingPaneVisualStudio2022Theme() | CXTPDockingPaneVisualStudio2022Theme |
DeletePaneColorSets() | CXTPDockingPaneVisualStudio2012Theme | protected
DrawAutoHidePanel(CDC *pDC, CRect rc, XTPDockingPaneDirection direction) | CXTPDockingPaneVisualStudio2022Theme | virtual
DrawCaption(CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc) | CXTPDockingPaneVisualStudio2012Theme | virtual
DrawCaptionButton(CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton) | CXTPDockingPaneVisualStudio2012Theme | virtual
DrawCaptionButtonEntry(CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton, CSize szOffset) | CXTPDockingPanePaintManager | protectedvirtual
DrawCaptionButtonEntry(CDC *pDC, CXTPDockingPaneCaptionButton *pButton, CPoint pt, COLORREF clrButton) | CXTPDockingPanePaintManager | protectedvirtual
DrawCaptionButtons(CDC *pDC, CXTPDockingPaneCaptionButtons *pButtons, CRect &rcCaption, COLORREF clr, int nButtonSize, int nButtonGap, BOOL bVertical=FALSE) | CXTPDockingPanePaintManager | virtual
DrawCaptionPart(CDC *pDC, CXTPDockingPaneBase *pPane, CRect rcCaption, const CString &strTitle, BOOL bActive, BOOL bVertical) | CXTPDockingPaneDefaultTheme | protectedvirtual
DrawCaptionText(CDC *pDC, const CString &strTitle, CRect rc, BOOL bVertical, BOOL bCalcWidth=FALSE) | CXTPDockingPanePaintManager |
DrawDottedLine(CDC *pDC, int x, int y, int nSize, COLORREF clr, BOOL bVertical) | CXTPDockingPaneVisualStudio2012Theme | protected
DrawFloatingFrame(CDC *pDC, CXTPDockingPaneMiniWnd *pPane, CRect rc) | CXTPDockingPaneVisualStudio2012Theme | virtual
DrawGripper(CDC *pDC, CRect rcGripper, COLORREF clr, BOOL bVertical) | CXTPDockingPaneVisualStudio2012Theme | protected
DrawPane(CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc) | CXTPDockingPaneVisualStudio2012Theme | virtual
DrawSidePanel(CDC *pDC, CXTPDockingPaneSidePanel *pPane, CRect rc) | CXTPDockingPaneVisualStudio2012Theme | virtual
DrawSplitter(CDC *pDC, CXTPDockingPaneSplitterWnd *pSplitter) | CXTPDockingPaneVisualStudio2022Theme | virtual
DrawTitleBar(CDC *pDC, CXTPDockingPaneBase *pPane, CRect rc, BOOL bVertical) | CXTPDockingPaneVisualStudio2022Theme | protectedvirtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCaptionButtonStyle() const | CXTPDockingPanePaintManager |
GetCaptionGripperRect(const CXTPDockingPaneTabbedContainer *pPane) | CXTPDockingPanePaintManager | virtual
GetCaptionHeight() const | CXTPDockingPanePaintManager |
GetCaptionRect(const CXTPDockingPaneTabbedContainer *pPane, CRect &rc) | CXTPDockingPanePaintManager | virtual
GetColorSet(BOOL bActive) | CXTPDockingPaneVisualStudio2012Theme | protectedvirtual
GetCurrentSystemTheme() const | CXTPDockingPanePaintManager |
GetCustomTitleBrush(BOOL bActive, BOOL bVertical) const | CXTPDockingPanePaintManager |
GetPaneCaptionRect(const CXTPDockingPaneSidePanel *pPane) | CXTPDockingPaneVisualStudio2012Theme | virtual
GetPanelPaintManager() const | CXTPDockingPanePaintManager |
GetSplitterStyle() const | CXTPDockingPanePaintManager |
GetTabPaintManager() const | CXTPDockingPanePaintManager |
GetTabsHeight() const | CXTPDockingPanePaintManager |
GetXtremeColor(UINT nIndex) | CXTPDockingPanePaintManager |
Line(CDC *pDC, int x0, int y0, int x1, int y1, int nPen) | CXTPDockingPanePaintManager |
Line(CDC *pDC, int x0, int y0, int x1, int y1) | CXTPDockingPanePaintManager |
m_arrColor | CXTPDockingPanePaintManager | protected
m_bDestroyCustomTitleBrushes | CXTPDockingPanePaintManager | protected
m_bDrawCaptionIcon | CXTPDockingPanePaintManager |
m_bDrawSingleTab | CXTPDockingPanePaintManager |
m_bHighlightActiveCaption | CXTPDockingPanePaintManager |
m_bLunaTheme | CXTPDockingPanePaintManager | protected
m_bShowCaption | CXTPDockingPanePaintManager |
m_bUseBoldCaptionFont | CXTPDockingPanePaintManager |
m_bUseOfficeFont | CXTPDockingPanePaintManager | protected
m_bUseStandardFont | CXTPDockingPanePaintManager | protected
m_clrActiveCaption | CXTPDockingPanePaintManager |
m_clrActiveCaptionText | CXTPDockingPanePaintManager |
m_clrBackground | CXTPDockingPanePaintManager |
m_clrCaptionBorder | CXTPDockingPaneVisualStudio2022Theme | protected
m_clrDisabledCaptionText | CXTPDockingPanePaintManager |
m_clrNormalCaption | CXTPDockingPanePaintManager |
m_clrNormalCaptionText | CXTPDockingPanePaintManager |
m_clrSplitter | CXTPDockingPanePaintManager |
m_clrSplitterGradient | CXTPDockingPanePaintManager |
m_clrSplitterGripper | CXTPDockingPanePaintManager |
m_dwSplitterStyle | CXTPDockingPanePaintManager | protected
m_hbrActiveTitleHorz | CXTPDockingPanePaintManager | protected
m_hbrActiveTitleVert | CXTPDockingPanePaintManager | protected
m_hbrInactiveTitleHorz | CXTPDockingPanePaintManager | protected
m_hbrInactiveTitleVert | CXTPDockingPanePaintManager | protected
m_nCaptionButtonStyle | CXTPDockingPanePaintManager | protected
m_nCaptionFontGap | CXTPDockingPanePaintManager | protected
m_nFontSize | CXTPDockingPaneVisualStudio2012Theme | protected
m_nSplitterIndent | CXTPDockingPanePaintManager |
m_nSplitterSize | CXTPDockingPanePaintManager |
m_nTabsHeight | CXTPDockingPanePaintManager | protected
m_nTitleHeight | CXTPDockingPanePaintManager | protected
m_pcsActive | CXTPDockingPaneVisualStudio2012Theme | protected
m_pcsInactive | CXTPDockingPaneVisualStudio2012Theme | protected
m_pPanelPaintManager | CXTPDockingPanePaintManager | protected
m_pTabPaintManager | CXTPDockingPanePaintManager | protected
m_rcCaptionMargin | CXTPDockingPanePaintManager | protected
m_strFontFace | CXTPDockingPaneVisualStudio2012Theme | protected
m_strOfficeFont | CXTPDockingPanePaintManager | protected
m_systemTheme | CXTPDockingPanePaintManager | protected
m_themeButton | CXTPDockingPanePaintManager | protected
m_themeCurrent | CXTPDockingPanePaintManager | protected
m_themeExplorer | CXTPDockingPanePaintManager | protected
m_themeRebar | CXTPDockingPanePaintManager | protected
m_themeToolbar | CXTPDockingPanePaintManager | protected
m_themeWindow | CXTPDockingPanePaintManager | protected
m_xtpFontTitle | CXTPDockingPanePaintManager | protected
m_xtpFontTitleVertical | CXTPDockingPanePaintManager | protected
Pixel(CDC *pDC, int xPos, int yPos, int nPen) | CXTPDockingPanePaintManager |
Rectangle(CDC *pDC, CRect rc, int nPenEntry, int nPenBorder) | CXTPDockingPanePaintManager |
RefreshMetrics() | CXTPDockingPaneVisualStudio2022Theme | virtual
SetCaptionButtonStyle(XTPDockingPaneCaptionButtonStyle nStyle) | CXTPDockingPanePaintManager |
SetCaptionFontIndirect(LOGFONT *pLogFont, BOOL bUseStandardFont=FALSE) | CXTPDockingPanePaintManager |
SetColors(int cElements, CONST INT *lpaElements, CONST COLORREF *lpaRgbValues) | CXTPDockingPanePaintManager |
SetCustomTitleBrushes(HBRUSH hbrActiveTitleHorz, HBRUSH hbrInactiveTitleHorz=NULL, HBRUSH hbrActiveTitleVert=NULL, HBRUSH hbrInactiveTitleVert=NULL, BOOL bDestroyOnCleanup=FALSE) | CXTPDockingPanePaintManager |
SetLunaTheme(XTPCurrentSystemTheme systemTheme) | CXTPDockingPanePaintManager |
SetPaneColorSets(CXTPDockingPaneColorSet *pcsActive, CXTPDockingPaneColorSet *pcsInactive) | CXTPDockingPaneVisualStudio2012Theme | protected
SetPanelPaintManager(CXTPTabPaintManager *pManager) | CXTPDockingPanePaintManager |
SetSplitterStyle(DWORD dwStyle) | CXTPDockingPanePaintManager |
SetTabPaintManager(CXTPTabPaintManager *pManager) | CXTPDockingPanePaintManager |
UseOfficeFont(BOOL bUseOfficeFont) | CXTPDockingPanePaintManager |
~CXTPDockingPanePaintManager() | CXTPDockingPanePaintManager | protectedvirtual
~CXTPDockingPaneVisualStudio2012Theme() | CXTPDockingPaneVisualStudio2012Theme | virtual
~CXTPDockingPaneVisualStudio2022Theme() | CXTPDockingPaneVisualStudio2022Theme | virtual


Toolkit Pro: XTPButtonThemeVisualStudio2012.h Source File

  • Source
  • Controls
  • Button
  • Themes
XTPButtonThemeVisualStudio2012.h
Go to the documentation of this file.
1
23#if !defined(__XTPBUTTONTHEMEVISUALSTUDIO2012_H__)
24# define __XTPBUTTONTHEMEVISUALSTUDIO2012_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPButtonThemeVisualStudio2012 : public CXTPButtonThemeOffice2013
39{
40public:
46 CXTPButtonThemeVisualStudio2012(BOOL bLight);
47
54 void RefreshMetrics(CXTPButton* pButton);
55
64 virtual COLORREF GetTextColor(CXTPButton* pButton);
65
73 virtual void DrawCheckBoxMark(CDC* pDC, CXTPButton* pButton);
74
82 virtual void DrawRadioButtonMark(CDC* pDC, CXTPButton* pButton);
83
91 virtual void DrawButtonBackground(CDC* pDC, CXTPButton* pButton);
92
93protected:
94 BOOL m_bLight;
95};
96
97# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
99#endif //#if !defined(__XTPBUTTONTHEMEVISUALSTUDIO2012_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPButton
Push Button control.
Definition XTPButton.h:109
CXTPButtonThemeOffice2013
CXTPButtonThemeOffice2013 is a class used to perform Office 2013 theme drawing tasks.
Definition XTPButtonThemeOffice2013.h:39
CXTPButtonThemeVisualStudio2012
CXTPButtonThemeVisualStudio2012 is a class used to perform Visual Studio 2012 theme drawing tasks.
Definition XTPButtonThemeVisualStudio2012.h:39
CXTPButtonThemeVisualStudio2012::GetTextColor
virtual COLORREF GetTextColor(CXTPButton *pButton)
Call this member function to retrieve the color used to draw the button text.
CXTPButtonThemeVisualStudio2012::DrawCheckBoxMark
virtual void DrawCheckBoxMark(CDC *pDC, CXTPButton *pButton)
This member function is called to draw the check box mark for the button control.
CXTPButtonThemeVisualStudio2012::DrawButtonBackground
virtual void DrawButtonBackground(CDC *pDC, CXTPButton *pButton)
This member function is called to draw the background for the button control.
CXTPButtonThemeVisualStudio2012::RefreshMetrics
void RefreshMetrics(CXTPButton *pButton)
This member function is called by the theme manager to refresh the visual styles used by each compone...
CXTPButtonThemeVisualStudio2012::m_bLight
BOOL m_bLight
TRUE when drawing light theme.
Definition XTPButtonThemeVisualStudio2012.h:94
CXTPButtonThemeVisualStudio2012::DrawRadioButtonMark
virtual void DrawRadioButtonMark(CDC *pDC, CXTPButton *pButton)
This member function is called to draw the radio mark for the button control.
CXTPButtonThemeVisualStudio2012::CXTPButtonThemeVisualStudio2012
CXTPButtonThemeVisualStudio2012(BOOL bLight)
Constructs a CXTPButtonThemeVisualStudio2012 object.


Toolkit Pro: XTPChart2dPyramidSeriesStyle.h Source File

  • Source
  • Chart
  • Styles
  • Pyramid
  • 2D
XTPChart2dPyramidSeriesStyle.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHART2DPYRAMIDSERIESSTYLE_H__)
24# define __XTPCHART2DPYRAMIDSERIESSTYLE_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartSeriesView;
34class CXTPChartBorder;
35class CXTPChartFillStyle;
36
48class _XTP_EXT_CLASS CXTPChartPyramidSeriesStyle : public CXTPChartPyramidSeriesStyleBase
49{
50 DECLARE_SERIAL(CXTPChartPyramidSeriesStyle);
51
52public:
57 CXTPChartPyramidSeriesStyle();
58
59protected:
67 virtual CXTPChartDiagram* CreateDiagram();
68
79 virtual CXTPChartSeriesView* CreateView(CXTPChartSeries* pSeries,
80 CXTPChartDiagramView* pDiagramView);
81
92 virtual BOOL IsStyleDiagram(CXTPChartDiagram* pDiagram) const;
93
94# ifdef _XTP_ACTIVEX
95public:
97 DECLARE_DISPATCH_MAP()
98 DECLARE_INTERFACE_MAP()
99 DECLARE_OLETYPELIB_EX(CXTPChartPyramidSeriesStyle);
100 DECLARE_OLECREATE_EX(CXTPChartPyramidSeriesStyle)
102# endif
103};
105# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
106#endif //#if !defined(__XTPCHART2DPYRAMIDSERIESSTYLE_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartBorder
This class abstracts the border of a chart, it is a kind of chart element.
Definition XTPChartBorder.h:42
CXTPChartDiagram
This class represents a chart diagram, which is a kind of CXTPChartElement.
Definition XTPChartDiagram.h:48
CXTPChartDiagramView
This class represents the view of a chart diagram, which is a kind of CXTPChartElementView.
Definition XTPChartDiagramView.h:49
CXTPChartFillStyle
This class abstracts a fill style used to fill the background of various chart elements.
Definition XTPChartFillStyle.h:43
CXTPChartPyramidSeriesStyleBase
This class abstracts the basic style of a pyramid series.
Definition XTPChartPyramidSeriesStyleBase.h:45
CXTPChartPyramidSeriesStyle
This class abstracts the basic style of a pyramid series.
Definition XTPChart2dPyramidSeriesStyle.h:49
CXTPChartPyramidSeriesStyle::IsStyleDiagram
virtual BOOL IsStyleDiagram(CXTPChartDiagram *pDiagram) const
Call this function to check whether a chart diagram object passed is a kind of CXTPChart2dPyramidDiag...
CXTPChartPyramidSeriesStyle::CXTPChartPyramidSeriesStyle
CXTPChartPyramidSeriesStyle()
Constructs a CXTPChartPyramidSeriesStyle object.
CXTPChartPyramidSeriesStyle::CreateView
virtual CXTPChartSeriesView * CreateView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Call this function to create the view of the pyramid series.
CXTPChartPyramidSeriesStyle::CreateDiagram
virtual CXTPChartDiagram * CreateDiagram()
Call this function to create the pyramid diagram object.
CXTPChartSeries
This class represents a series in the chart, which is a kind of CXTPChartElement.
Definition XTPChartSeries.h:50


Toolkit Pro: Member List

CXTPPropertyGridInplaceMonthCal Member List

This is the complete list of members for CXTPPropertyGridInplaceMonthCal, including all inherited members.

CXTPPropertyGridInplaceMonthCal(CXTPPropertyGridItemDate *pItem) | CXTPPropertyGridInplaceMonthCal | inline
GetMinReqRect(RECT *pRect) const | CXTPPropertyGridInplaceMonthCal |
m_pItem | CXTPPropertyGridInplaceMonthCal | protected
OnAccept() | CXTPPropertyGridInplaceMonthCal | protected
OnCancel() | CXTPPropertyGridInplaceMonthCal | protected


Toolkit Pro: XTPMarkupRowDefinition.h Source File

  • Source
  • Markup
  • Controls
XTPMarkupRowDefinition.h
Go to the documentation of this file.
1
23#if !defined(__XTPMARKUPROWDEFINITION_H__)
24# define __XTPMARKUPROWDEFINITION_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPMarkupDependencyProperty;
34class CXTPMarkupGridLength;
35
41class _XTP_EXT_CLASS CXTPMarkupRowDefinition : public CXTPMarkupDefinitionBase
42{
44 DECLARE_MARKUPCLASS(CXTPMarkupRowDefinition);
46public:
51 CXTPMarkupRowDefinition();
52
53public:
59 void SetMinHeight(int nHeight);
60
66 void SetMaxHeight(int nHeight);
67
73 void SetHeight(int nHeight);
74
80 void SetHeight(CXTPMarkupGridLength* pLength);
81
83 // Implementation
84public:
85 static CXTPMarkupDependencyProperty* m_pHeightProperty;
86 static CXTPMarkupDependencyProperty* m_pMinHeightProperty;
87 static CXTPMarkupDependencyProperty* m_pMaxHeightProperty;
91public:
92 DECLARE_DISPATCH_MAP()
93# ifdef _XTP_ACTIVEX
94 DECLARE_INTERFACE_MAP()
95 DECLARE_OLETYPELIB_EX(CXTPMarkupRowDefinition);
96# endif
97
98 afx_msg void OleSetMinHeight(int nHeight);
99 afx_msg void OleSetMaxHeight(int nHeight);
100 afx_msg void OleSetHeight(int nHeight);
101 afx_msg int OleGetMinHeight();
102 afx_msg int OleGetMaxHeight();
103 afx_msg int OleGetHeight();
104 afx_msg int OleGetUnitType();
105 afx_msg void OleSetUnitType(int nType);
107};
108
109# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
111#endif // !defined(__XTPMARKUPROWDEFINITION_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPMarkupDefinitionBase
CXTPMarkupDefinitionBase is the base class for CXTPMarkupColumnDefinition and CXTPMarkupRowDefinition...
Definition XTPMarkupDefinitionBase.h:45
CXTPMarkupGridLength
CXTPMarkupGridLength is a class defined length of grid rows and columns.
Definition XTPMarkupGridLength.h:41
CXTPMarkupRowDefinition
CXTPMarkupRowDefinition is a CXTPMarkupDefinitionBase derived class.
Definition XTPMarkupRowDefinition.h:42
CXTPMarkupRowDefinition::SetMaxHeight
void SetMaxHeight(int nHeight)
Sets the maximum height constraint for the row.
CXTPMarkupRowDefinition::SetHeight
void SetHeight(CXTPMarkupGridLength *pLength)
Sets the height for the row.
CXTPMarkupRowDefinition::SetMinHeight
void SetMinHeight(int nHeight)
Sets the minimum height constraint for the row.
CXTPMarkupRowDefinition::CXTPMarkupRowDefinition
CXTPMarkupRowDefinition()
Constructs a CXTPMarkupRowDefinition object.
CXTPMarkupRowDefinition::SetHeight
void SetHeight(int nHeight)
Sets the height for the row.


Toolkit Pro: Member List

CXTPDockingPaneTabThemeNativeWindows11 Member List

This is the complete list of members for CXTPDockingPaneTabThemeNativeWindows11, including all inherited members.

AdjustClientRect(CXTPTabManager *pTabManager, CRect &rcClient) | CXTPTabPaintManagerTheme | virtual
CXTPDockingPaneTabTheme2012() | CXTPDockingPaneTabTheme2012 |
CXTPDockingPaneTabThemeNativeWindows11() | CXTPDockingPaneTabThemeNativeWindows11 |
CXTPTabPaintManagerTheme() | CXTPTabPaintManagerTheme |
CXTPTabThemeFlat() | CXTPTabThemeFlat | inline
DrawSingleButton(CDC *pDC, CXTPTabManagerItem *pItem) | CXTPDockingPaneTabThemeNativeWindows11 | virtual
DrawTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl) | CXTPTabPaintManagerTheme | virtual
DrawText(CDC *pDC, CXTPTabManager *pManager, const CString &str, LPRECT lpRect, UINT nFormat) | CXTPDockingPaneTabTheme2012 | virtual
DrawWorkspacePart(CDC *pDC, LPRECT lpRect, XTPTabWorkspacePart workspacePart) | CXTPTabPaintManagerTheme | virtual
FillButton(CDC *pDC, CXTPTabManagerItem *pItem, LPPOINT pts, int nCount, XTPTabPosition tabPosition, BOOL bAbsolute=FALSE) | CXTPTabPaintManagerTheme |
FillTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl) | CXTPTabThemeFlat | virtual
GetButtonDrawRect(const CXTPTabManagerItem *pItem) | CXTPTabPaintManagerTheme | virtual
GetButtonHeight(const CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetButtonLength(CDC *pDC, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerTheme | virtual
GetClientMargin() | CXTPTabPaintManagerTheme | virtual
GetClientRect(CRect rcControl, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetColorSet() const | CXTPTabPaintManagerTheme |
GetDefaultColorSet() | CXTPTabThemeFlat | inlinevirtual
GetHeaderClipBox(CDC *pDC, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetHeaderHeight(CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme |
GetHeaderMargin() | CXTPTabPaintManagerTheme | virtual
GetHeaderRect(CRect rcControl, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetSupportedColorSets() | CXTPTabPaintManagerTheme | inlinevirtual
m_bButtonsReverseZOrder | CXTPTabPaintManagerTheme | protected
m_nButtonHeight | CXTPTabPaintManagerTheme | protected
m_nRowMargin | CXTPTabPaintManagerTheme |
m_pPaintManager | CXTPTabPaintManagerTheme | protected
m_rcHeaderMargin | CXTPTabPaintManagerTheme |
RefreshMetrics() | CXTPDockingPaneTabTheme2012 | virtual
RepositionTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcClient) | CXTPTabPaintManagerTheme | virtual
~CXTPTabPaintManagerTheme() | CXTPTabPaintManagerTheme | virtual


Toolkit Pro: XTPCommandBarsOptions.h Source File

  • Source
  • CommandBars
XTPCommandBarsOptions.h
Go to the documentation of this file.
1
23#if !defined(__XTPCOMMANDBARSOPTIONS_H__)
24# define __XTPCOMMANDBARSOPTIONS_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPCommandBars;
34class CXTPPropExchange;
35
45class _XTP_EXT_CLASS CXTPCommandBarsOptions : public CXTPCmdTarget
46{
47public:
52 CXTPCommandBarsOptions();
53
54public:
60 void Serialize(CArchive& ar);
61
68 void DoPropExchange(CXTPPropExchange* pPX, BOOL bUserOptionsOnly = FALSE);
69
80 void ShowKeyboardCues(XTPKeyboardCuesShow keyboardCues);
81
91 XTPKeyboardCuesShow GetShowKeyboardCues() const;
92
102 BOOL IsDpiBitmapScalingEnabled() const;
103
112 void EnableDpiBitmapScaling(BOOL bEnable = TRUE);
113
122 BOOL IsDpiGalleryItemScalingEnabled() const;
123
131 void EnableDpiGalleryItemScaling(BOOL bEnable = TRUE);
132
134 _XTP_DEPRECATED_IN_FAVOR2(EnableDpiGalleryItemScaling, EnableDpiBitmapScaling)
135 void SetDPIScallingOptions(BOOL bScaleGalleryItems, BOOL bScaleToolbarIcons = TRUE);
136
137 _XTP_DEPRECATED_IN_FAVOR(IsDpiGalleryItemScalingEnabled)
138 BOOL GetGalleryItemsScalling() const;
139
140 _XTP_DEPRECATED_IN_FAVOR(IsDpiBitmapScalingEnabled)
141 BOOL GetToolbarsIconsScalling() const;
144public:
145 BOOL bAlwaysShowFullMenus;
146 BOOL bShowFullAfterDelay;
147 BOOL bToolBarScreenTips;
148 BOOL bToolBarAccelTips;
149 BOOL bLargeIcons;
150 BOOL bSyncFloatingBars;
151 BOOL bShowExpandButtonAlways;
152 BOOL bDblClickFloat;
153 BOOL bShowTextBelowIcons;
154 BOOL bAltDragCustomization;
156 BOOL bAutoHideUnusedPopups; // TRUE to hide unused pop-up controls. This is similar to how the
157 // Windows Start menu hides infrequently used pop-ups.*/
158 BOOL bDirtyState;
161 BOOL bShowPopupBarToolTips;
162 BOOL bShowContextMenuAccelerators;
164 XTPAnimationType animationType;
165 BOOL bAutoUpdateShortcuts;
166 DWORD keyboardCuesUse;
167 BOOL bFlyByStatus;
169 CSize szIcons;
170 CSize szLargeIcons;
171 CSize szPopupIcons;
173 BOOL bUseAltNumPadKeys;
174 BOOL bUseSystemSaveBitsStyle;
176 BOOL bDisableCommandIfNoHandler;
177 BOOL bWrapLargePopups;
179 CMap<UINT, UINT, BOOL, BOOL> m_mapHiddenCommands;
180 CMap<UINT, UINT, BOOL, BOOL> m_mapUsedCommands;
182 BOOL bShowKeyboardTips;
183 BOOL bShowMiniToolbarTips;
185 BOOL bShowPopupButtonsSelectedToolbarOnly;
188protected:
189 // DPI-scalling parameters
190 BOOL m_bAutoScaleDpiGalleryItems;
192 BOOL m_bAutoScaleDpiToolbarIcons;
195private:
196 BOOL m_bAutoScaleDpiToolbarIconsModified;
197
198private:
199 CXTPCommandBars* m_pCommandBars;
200 XTPKeyboardCuesShow keyboardCuesShow;
201
202# ifdef _XTP_COMMANDBARS_ACTIVEX
205 long nUpdatePeriod;
206 DECLARE_DISPATCH_MAP()
207 DECLARE_INTERFACE_MAP()
208
209 DECLARE_OLETYPELIB_EX(CXTPCommandBarsOptions);
210
211public:
212 afx_msg BOOL OleGetOfficeStyleDisabledIcons();
213 afx_msg void OleSetOfficeStyleDisabledIcons(BOOL bOfficeStyleDisabledIcons);
214 afx_msg BOOL OleGetFadedIcons();
215 afx_msg void OleSetFadedIcons(BOOL);
216 afx_msg BOOL OleGetDisabledIcons();
217 afx_msg void OleSetDisabledIcons(BOOL);
218 afx_msg BOOL OleGetIconsWithShadow();
219 afx_msg void OleSetIconsWithShadow(BOOL);
220 afx_msg void OleSetIconSize(BOOL bBigIcons, long cx, long cy);
221 afx_msg int OleGetIconWidth(BOOL bLargeIcons);
222 afx_msg int OleGetIconHeight(BOOL bLargeIcons);
223 afx_msg void OleSetPopupIconSize(long cx, long cy);
224 afx_msg int OleGetPopupIconWidth();
225 afx_msg int OleGetPopupIconHeight();
226 afx_msg void OleAddHiddenCommand(long nIDCommand);
227 afx_msg BOOL OleGetLunaColors();
228 afx_msg void OleSetLunaColors(BOOL bLunaColors);
229 afx_msg BOOL OleGetUseSharedImageList();
230 afx_msg void OleSetUseSharedImageList(BOOL bUseSharedImageList);
231 afx_msg void OleSetFont(LPFONTDISP pFontDisp);
232 afx_msg double OleGetMaxPopupWidth();
233 afx_msg void OleSetMaxPopupWidth(double dMaxWidthDivisor);
234 LPFONTDISP OleGetFont();
235 afx_msg BOOL OleIsBalloonStyleSupported();
236 afx_msg int OleGetShowKeyboardCues();
237 afx_msg LPFONTDISP OleGetSmallCaptionFont();
238 afx_msg LPFONTDISP OleGetComboBoxFont();
239 afx_msg void OleSetSmallCaptionFont(LPFONTDISP pFontDisp);
240 afx_msg void OleSetComboBoxFont(LPFONTDISP pFontDisp);
241 afx_msg void OleSetDPIScallingOptions(BOOL bScaleGalleryItems, BOOL bScaleToolbarIcons);
242 afx_msg BOOL OleIsDPIScallingEnabled();
243 afx_msg COLORREF OleGetVSStateColor();
244 afx_msg void OleSetVSStateColor(COLORREF clr);
245 afx_msg void OleSetShowPopupButtonsSelectedToolbarOnly(BOOL bVal);
246 afx_msg BOOL OleGetShowPopupButtonsSelectedToolbarOnly();
247
248 afx_msg void OleUpdatePeriodChanged();
249 afx_msg void OleRemoveHiddenCommands();
250 DECLARE_PROPERTY(ExpandHoverDelay, long);
251 DECLARE_PROPERTY(ExpandDelay, long);
252
253 BOOL bSyncActiveFloatingFrames;
254
256# endif
257
258 friend class CXTPCommandBars;
259};
260
261static const TCHAR _xtpCommandBarOptionsSection[] = _T("%s-Options");
262
264# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
265#endif // !defined(__XTPCOMMANDBARSOPTIONS_H__)
XTPKeyboardCuesShow
XTPKeyboardCuesShow
Enumerated type used to determine menu underlines.
Definition XTPCommandBarsDefines.h:337
XTPAnimationType
XTPAnimationType
Enumerated type used to determine the animation effect of pop-up bars.
Definition XTPCommandBarsDefines.h:373
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPCommandBars
CXTPCommandBars is a standalone class.
Definition XTPCommandBars.h:165
CXTPCommandBarsOptions
Options of the command bars.
Definition XTPCommandBarsOptions.h:46
CXTPCommandBarsOptions::bShowContextMenuAccelerators
BOOL bShowContextMenuAccelerators
TRUE to show accelerators in context menus.
Definition XTPCommandBarsOptions.h:162
CXTPCommandBarsOptions::EnableDpiGalleryItemScaling
void EnableDpiGalleryItemScaling(BOOL bEnable=TRUE)
Sets DPI gallery item scaling flag.
CXTPCommandBarsOptions::bShowExpandButtonAlways
BOOL bShowExpandButtonAlways
TRUE to show expand buttons always.
Definition XTPCommandBarsOptions.h:151
CXTPCommandBarsOptions::szPopupIcons
CSize szPopupIcons
Size of icons displayed in pop-up menus.
Definition XTPCommandBarsOptions.h:171
CXTPCommandBarsOptions::bUseAltNumPadKeys
BOOL bUseAltNumPadKeys
TRUE to allow activate menu with Alt + num pad key.
Definition XTPCommandBarsOptions.h:173
CXTPCommandBarsOptions::bToolBarScreenTips
BOOL bToolBarScreenTips
TRUE to show toolbar's tooltips.
Definition XTPCommandBarsOptions.h:147
CXTPCommandBarsOptions::bShowFullAfterDelay
BOOL bShowFullAfterDelay
TRUE to show full menus after short delay.
Definition XTPCommandBarsOptions.h:146
CXTPCommandBarsOptions::DoPropExchange
void DoPropExchange(CXTPPropExchange *pPX, BOOL bUserOptionsOnly=FALSE)
Either reads options from or writes options to an archive.
CXTPCommandBarsOptions::bAltDragCustomization
BOOL bAltDragCustomization
Allows users to change a toolbar button's position by dragging it while holding down ALT.
Definition XTPCommandBarsOptions.h:154
CXTPCommandBarsOptions::bSyncFloatingBars
BOOL bSyncFloatingBars
TRUE to hide floating bars when site frame deactivated.
Definition XTPCommandBarsOptions.h:150
CXTPCommandBarsOptions::bLargeIcons
BOOL bLargeIcons
TRUE to use large toolbars icons.
Definition XTPCommandBarsOptions.h:149
CXTPCommandBarsOptions::bShowPopupBarToolTips
BOOL bShowPopupBarToolTips
TRUE to display ToolTips for controls in pop-up menus.
Definition XTPCommandBarsOptions.h:161
CXTPCommandBarsOptions::m_mapUsedCommands
CMap< UINT, UINT, BOOL, BOOL > m_mapUsedCommands
Used commands array.
Definition XTPCommandBarsOptions.h:180
CXTPCommandBarsOptions::ShowKeyboardCues
void ShowKeyboardCues(XTPKeyboardCuesShow keyboardCues)
Call this method to enable/disable menu underlines.
CXTPCommandBarsOptions::GetShowKeyboardCues
XTPKeyboardCuesShow GetShowKeyboardCues() const
Call this method to get menu underlines state.
CXTPCommandBarsOptions::bShowPopupButtonsSelectedToolbarOnly
BOOL bShowPopupButtonsSelectedToolbarOnly
TRUE to show only popup with current icons only.
Definition XTPCommandBarsOptions.h:185
CXTPCommandBarsOptions::IsDpiBitmapScalingEnabled
BOOL IsDpiBitmapScalingEnabled() const
Gets DPI bitmap scaling flag.
CXTPCommandBarsOptions::bShowKeyboardTips
BOOL bShowKeyboardTips
TRUE to use keyboard tips.
Definition XTPCommandBarsOptions.h:182
CXTPCommandBarsOptions::szIcons
CSize szIcons
Size of the normal icons.
Definition XTPCommandBarsOptions.h:169
CXTPCommandBarsOptions::m_bAutoScaleDpiToolbarIcons
BOOL m_bAutoScaleDpiToolbarIcons
FALSE by default.
Definition XTPCommandBarsOptions.h:192
CXTPCommandBarsOptions::EnableDpiBitmapScaling
void EnableDpiBitmapScaling(BOOL bEnable=TRUE)
Sets DPI bitmap scaling flag.
CXTPCommandBarsOptions::m_mapHiddenCommands
CMap< UINT, UINT, BOOL, BOOL > m_mapHiddenCommands
Hidden command array.
Definition XTPCommandBarsOptions.h:179
CXTPCommandBarsOptions::bAutoUpdateShortcuts
BOOL bAutoUpdateShortcuts
TRUE to update shortcuts from accelerator table.
Definition XTPCommandBarsOptions.h:165
CXTPCommandBarsOptions::bWrapLargePopups
BOOL bWrapLargePopups
Wrap controls for large pop-ups instead scroll them.
Definition XTPCommandBarsOptions.h:177
CXTPCommandBarsOptions::CXTPCommandBarsOptions
CXTPCommandBarsOptions()
Constructs an CXTPCommandBarsOptions object.
CXTPCommandBarsOptions::bDirtyState
BOOL bDirtyState
TRUE if the user has done any type of customization to menus or toolbars.
Definition XTPCommandBarsOptions.h:158
CXTPCommandBarsOptions::Serialize
void Serialize(CArchive &ar)
Either reads options from or writes options to an archive.
CXTPCommandBarsOptions::bDisableCommandIfNoHandler
BOOL bDisableCommandIfNoHandler
TRUE to disable commands if no handler is presented.
Definition XTPCommandBarsOptions.h:176
CXTPCommandBarsOptions::m_bAutoScaleDpiGalleryItems
BOOL m_bAutoScaleDpiGalleryItems
TRUE by default.
Definition XTPCommandBarsOptions.h:190
CXTPCommandBarsOptions::IsDpiGalleryItemScalingEnabled
BOOL IsDpiGalleryItemScalingEnabled() const
Gets DPI gallery item scaling flag.
CXTPCommandBarsOptions::bShowMiniToolbarTips
BOOL bShowMiniToolbarTips
TRUE to show tips for controls in a mini toolbar, default is FALSE.
Definition XTPCommandBarsOptions.h:183
CXTPCommandBarsOptions::bAlwaysShowFullMenus
BOOL bAlwaysShowFullMenus
TRUE to show full menus always.
Definition XTPCommandBarsOptions.h:145
CXTPCommandBarsOptions::keyboardCuesUse
DWORD keyboardCuesUse
Keyboard cues used.
Definition XTPCommandBarsOptions.h:166
CXTPCommandBarsOptions::animationType
XTPAnimationType animationType
Animation type.
Definition XTPCommandBarsOptions.h:164
CXTPCommandBarsOptions::szLargeIcons
CSize szLargeIcons
Size of the large icons.
Definition XTPCommandBarsOptions.h:170
CXTPCommandBarsOptions::bUseSystemSaveBitsStyle
BOOL bUseSystemSaveBitsStyle
TRUE to use CS_SAVEBITS class style for pop-ups and shadows.
Definition XTPCommandBarsOptions.h:174
CXTPCommandBarsOptions::bDblClickFloat
BOOL bDblClickFloat
TRUE to make toolbar floating be double-clicking.
Definition XTPCommandBarsOptions.h:152
CXTPCommandBarsOptions::bToolBarAccelTips
BOOL bToolBarAccelTips
TRUE to add accelerators to tooltips.
Definition XTPCommandBarsOptions.h:148
CXTPCommandBarsOptions::bFlyByStatus
BOOL bFlyByStatus
Status bar displays information about the button.
Definition XTPCommandBarsOptions.h:167
CXTPCommandBarsOptions::bShowTextBelowIcons
BOOL bShowTextBelowIcons
TRUE to show captions below icons.
Definition XTPCommandBarsOptions.h:153
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72


Toolkit Pro: XTPDockingPaneBaseContainer.h Source File

  • Source
  • DockingPane
XTPDockingPaneBaseContainer.h
Go to the documentation of this file.
1
23#if !defined(__XTPDOCKINGPANEBASECONTAINER_H__)
24# define __XTPDOCKINGPANEBASECONTAINER_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPDockingPaneBaseContainer : public CXTPDockingPaneBase
39{
40protected:
61 CXTPDockingPaneBaseContainer(XTPDockingPaneType type, CXTPDockingPaneLayout* pLayout);
62
68 virtual ~CXTPDockingPaneBaseContainer();
69
70public:
80 virtual POSITION ContainPane(CXTPDockingPaneBase* pPane) const;
81
105 virtual void FindPane(XTPDockingPaneType type, CXTPDockingPaneBaseList* pList) const;
106
116 POSITION GetHeadPosition() const;
117
131 CXTPDockingPaneBase* GetNext(POSITION& pos) const;
132
141 CXTPDockingPaneBase* GetFirstPane() const;
142
151 CXTPDockingPaneBase* GetLastPane() const;
152
159 CXTPDockingPaneBaseList& GetPanes();
160
168 BOOL OnAction(XTPDockingPaneAction action);
169
170protected:
177 virtual BOOL IsEmpty() const;
178
179protected:
180 CXTPDockingPaneBaseList m_lstPanes;
181};
182
183AFX_INLINE CXTPDockingPaneBaseList& CXTPDockingPaneBaseContainer::GetPanes()
184{
185 return m_lstPanes;
186}
188# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
189#endif // #if !defined(__XTPDOCKINGPANEBASECONTAINER_H__)
XTPDisableNoisyWarnings.h
XTPDockingPaneType
XTPDockingPaneType
Docking pane type.
Definition XTPDockingPaneDefines.h:77
CXTPDockingPaneBaseList
CList< CXTPDockingPaneBase *, CXTPDockingPaneBase * > CXTPDockingPaneBaseList
This list is used for maintaining a CXTPDockingPaneBase collection.
Definition XTPDockingPaneDefines.h:482
XTPDockingPaneAction
XTPDockingPaneAction
Actions a docking pane is currently performing.
Definition XTPDockingPaneDefines.h:268
XTPEnableNoisyWarnings.h
CXTPDockingPaneBaseContainer
CXTPDockingPaneBaseContainer is a CXTPDockingPaneBase derived class.
Definition XTPDockingPaneBaseContainer.h:39
CXTPDockingPaneBaseContainer::ContainPane
virtual POSITION ContainPane(CXTPDockingPaneBase *pPane) const
Call this member to determine if one pane is contained in the collection of another.
CXTPDockingPaneBaseContainer::OnAction
BOOL OnAction(XTPDockingPaneAction action)
This method is called if some action occurs.
CXTPDockingPaneBaseContainer::GetLastPane
CXTPDockingPaneBase * GetLastPane() const
This method retrieves the last pane in the container.
CXTPDockingPaneBaseContainer::m_lstPanes
CXTPDockingPaneBaseList m_lstPanes
Child panes collection.
Definition XTPDockingPaneBaseContainer.h:180
CXTPDockingPaneBaseContainer::FindPane
virtual void FindPane(XTPDockingPaneType type, CXTPDockingPaneBaseList *pList) const
Call this member to find all panes of a specific XTPDockingPaneType within the container.
CXTPDockingPaneBaseContainer::GetNext
CXTPDockingPaneBase * GetNext(POSITION &pos) const
Gets the pane element identified by rPosition, then sets rPosition to the POSITION value of the next ...
CXTPDockingPaneBaseContainer::~CXTPDockingPaneBaseContainer
virtual ~CXTPDockingPaneBaseContainer()
Destroys a CXTPDockingPaneBase object, handles cleanup and deallocation.
CXTPDockingPaneBaseContainer::CXTPDockingPaneBaseContainer
CXTPDockingPaneBaseContainer(XTPDockingPaneType type, CXTPDockingPaneLayout *pLayout)
Protected constructor.
CXTPDockingPaneBaseContainer::GetHeadPosition
POSITION GetHeadPosition() const
This method retrieves the position of the first pane of this container.
CXTPDockingPaneBaseContainer::GetFirstPane
CXTPDockingPaneBase * GetFirstPane() const
This method retrieves the first pane in the container.
CXTPDockingPaneBaseContainer::IsEmpty
virtual BOOL IsEmpty() const
Call this member to determine if there are no children panes.
CXTPDockingPaneBaseContainer::GetPanes
CXTPDockingPaneBaseList & GetPanes()
Call this member to retrieve the collection of child panes.
Definition XTPDockingPaneBaseContainer.h:183
CXTPDockingPaneBase
CXTPDockingPaneBase is a standalone class.
Definition XTPDockingPaneBase.h:69
CXTPDockingPaneLayout
CXTPDockingPaneLayout is a standalone class.
Definition XTPDockingPaneLayout.h:54


Toolkit Pro: Member List

CXTPSplitterWndThemeVisualStudio2019 Member List

This is the complete list of members for CXTPSplitterWndThemeVisualStudio2019, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPControlTheme() | CXTPControlTheme |
CXTPSplitterWndTheme() | CXTPSplitterWndTheme |
CXTPSplitterWndThemeOffice2013() | CXTPSplitterWndThemeOffice2013 |
CXTPSplitterWndThemeOfficeXP() | CXTPSplitterWndThemeOfficeXP |
CXTPSplitterWndThemeVisualStudio2019() | CXTPSplitterWndThemeVisualStudio2019 |
DrawSplitter(CDC *pDC, CXTPSplitterWnd *pSplitter, int nType, const CRect &rectArg) | CXTPSplitterWndTheme | virtual
EnableTabColors(BOOL bEnable=TRUE) | CXTPSplitterWndTheme |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetThemeStyle() const | CXTPControlTheme |
GetTrackBrush() | CXTPSplitterWndThemeOfficeXP | virtual
m_bTabColors | CXTPSplitterWndTheme |
m_crBack | CXTPSplitterWndTheme |
m_crBoxBack | CXTPSplitterWndTheme |
m_crInnerBorder | CXTPSplitterWndTheme |
m_crInnerBoxBorder | CXTPSplitterWndTheme |
m_crOuterBorder | CXTPSplitterWndTheme |
m_crOuterBoxBorder | CXTPSplitterWndTheme |
m_nTheme | CXTPControlTheme | protected
RefreshMetrics() | CXTPSplitterWndThemeOffice2013 | virtual
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static


Toolkit Pro: XTPEditListBox.h Source File

  • Source
  • Controls
  • ListBox
XTPEditListBox.h
Go to the documentation of this file.
1
23#if !defined(__XTEDITLISTBOX_H__)
24# define __XTEDITLISTBOX_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
34
48class _XTP_EXT_CLASS CXTPEditListBoxToolBar : public CStatic
49{
51 DECLARE_DYNAMIC(CXTPEditListBoxToolBar)
53public:
58 CXTPEditListBoxToolBar();
59
64 virtual ~CXTPEditListBoxToolBar();
65
66public:
76 virtual void Initialize(bool bAutoFont = true);
77
85 CXTPButton& GetNewButton();
86
94 CXTPButton& GetDeleteButton();
95
103 CXTPButton& GetUpButton();
104
112 CXTPButton& GetDownButton();
113
119 void EnableEdit(bool bEnable);
120
135 void SetButtonTheme(XTPControlTheme eTheme);
136
138 //{{AFX_VIRTUAL(CXTPEditListBoxToolBar)
139 virtual BOOL PreTranslateMessage(MSG* pMsg);
140 //}}AFX_VIRTUAL
150 virtual void DrawText(CDC* pDC, CRect& rcClient);
151
159 virtual void MoveButtons();
160
170 virtual void SendCommand(UINT nCmdID);
171
178 CToolTipCtrl& GetTooltipControl();
179
188 void SetTheme(XTPControlTheme nTheme);
189
190 void RefreshMetrics();
191
192protected:
194 DECLARE_MESSAGE_MAP()
195
196 //{{AFX_MSG(CXTPEditListBoxToolBar)
197 afx_msg void OnButtonNew();
198 afx_msg void OnButtonDelete();
199 afx_msg void OnButtonUp();
200 afx_msg void OnButtonDown();
201 afx_msg void OnWindowPosChanged(WINDOWPOS FAR* lpwndpos);
202 afx_msg BOOL OnEraseBkgnd(CDC* pDC);
203 afx_msg void OnPaint();
204 afx_msg void OnNcPaint();
205 afx_msg void OnEnable(BOOL bEnable);
206 afx_msg void OnShowWindow(BOOL bShow, UINT nStatus);
207 afx_msg LRESULT OnSetTheme(WPARAM wParam, LPARAM lParam);
208 //}}AFX_MSG
211protected:
212 bool m_bShowUpDownButtons;
213 bool m_bShowNewDeleteButtons;
214 bool m_bEnableEdit;
215 CRect m_arClipRect[4];
216 CXTPButton m_arButton[4];
217 CToolTipCtrl m_tooltip;
219 CXTPPaintManagerColor m_clrBackground;
220 CXTPPaintManagerColor m_clrBorder;
221 CXTPPaintManagerColor m_clrText;
222 XTPControlTheme m_theme;
224 friend class CXTPEditListBox;
225};
226
228
229AFX_INLINE CXTPButton& CXTPEditListBoxToolBar::GetNewButton()
230{
231 return m_arButton[0];
232}
233AFX_INLINE CXTPButton& CXTPEditListBoxToolBar::GetDeleteButton()
234{
235 return m_arButton[1];
236}
237AFX_INLINE CXTPButton& CXTPEditListBoxToolBar::GetUpButton()
238{
239 return m_arButton[2];
240}
241AFX_INLINE CXTPButton& CXTPEditListBoxToolBar::GetDownButton()
242{
243 return m_arButton[3];
244}
245AFX_INLINE void CXTPEditListBoxToolBar::EnableEdit(bool bEnable)
246{
247 m_bEnableEdit = bEnable;
248}
249AFX_INLINE CToolTipCtrl& CXTPEditListBoxToolBar::GetTooltipControl()
250{
251 return m_tooltip;
252}
255// forwards
256class CXTPItemEdit;
257
258const DWORD LBS_XTP_DEFAULT = 0x0000;
259const DWORD LBS_XTP_CHOOSEDIR = 0x0001;
260const DWORD LBS_XTP_CHOOSEFILE = 0x0002;
261const DWORD LBS_XTP_NOTOOLBAR = 0x0008;
262const DWORD LBS_XTP_BROWSE = 0x0010;
263const DWORD LBS_XTP_HIDE_UP_DOWN = 0x0020;
264const DWORD LBS_XTP_ONLY_UP_DOWN = 0x0040;
265const DWORD LBS_XTP_BROWSE_ONLY = 0x0080;
274class _XTP_EXT_CLASS CXTPEditListBox : public CXTPListBox
275{
277 DECLARE_DYNAMIC(CXTPEditListBox)
279public:
284 CXTPEditListBox();
285
290 virtual ~CXTPEditListBox();
291
292public:
310 void SetListEditStyle(UINT nTitle, DWORD dwLStyle = LBS_XTP_DEFAULT);
311
329 void SetListEditStyle(LPCTSTR lpszTitle, DWORD dwLStyle = LBS_XTP_DEFAULT);
330
342 int GetCurrentIndex();
343
349 void EditItem(int iItem);
350
359 virtual void GetEditItemText();
360
366 void SetEditText(LPCTSTR pcszText);
367
377 CXTPEditListBoxToolBar& GetEditGroup();
378
386 void SetDlgFilter(LPCTSTR lpszFilter = NULL);
387
394 void SetDlgInitialDir(LPCTSTR lpszInitialDir);
395
402 bool HasToolbar();
403
409 void EnableEdit(bool bEnable);
410
420 virtual void Initialize(bool bAutoFont = true);
421
430 virtual void RecalcLayout();
431
436 virtual void RefreshMetrics();
437
446 void SetNewItemDefaultText(LPCTSTR lpszItemDefaultText);
447
453 virtual void MoveItemUp(int nIndex);
454
460 virtual void MoveItemDown(int nIndex);
461
462protected:
470 virtual BOOL CreateEditGroup(bool bAutoFont = true);
471
481 virtual void EditListItem(BOOL bNewItem);
482
487 virtual void DeleteItem();
488
489# if _MSC_VER > 1200
490 using CListBox::DeleteItem;
491# endif
492
499 virtual CXTPItemEdit* CreateEditControl(CRect rcItem);
500
501protected:
503 DECLARE_MESSAGE_MAP()
504
505 //{{AFX_VIRTUAL(CXTPEditListBox)
506 virtual BOOL PreTranslateMessage(MSG* pMsg);
507 virtual COLORREF GetBackColor();
508 //}}AFX_VIRTUAL
509
510 //{{AFX_MSG(CXTPEditListBox)
511 afx_msg void OnEndLabelEdit();
512 afx_msg void OnItemBrowse();
513 afx_msg void OnNewItem();
514 afx_msg void OnDeleteItem();
515 afx_msg void OnMoveItemUp();
516 afx_msg void OnMoveItemDown();
517 afx_msg void OnLButtonDblClk(UINT nFlags, CPoint point);
518 afx_msg void OnLButtonDown(UINT nFlags, CPoint point);
519 afx_msg void OnNcLButtonDown(UINT nHitTest, CPoint point);
520 afx_msg void OnNcMButtonDown(UINT nHitTest, CPoint point);
521 afx_msg void OnNcRButtonDown(UINT nHitTest, CPoint point);
522 afx_msg void OnWindowPosChanged(WINDOWPOS FAR* lpwndpos);
523 afx_msg void OnEnable(BOOL bEnable);
524 afx_msg void OnShowWindow(BOOL bShow, UINT nStatus);
525 afx_msg BOOL OnMouseWheel(UINT nFlags, short zDelta, CPoint pt);
526 afx_msg void OnSize(UINT nType, int cx, int cy);
527 //}}AFX_MSG
530protected:
531 CWnd* m_pParentWnd;
532 CString m_strItemDefaultText;
533 int m_nIndex;
534 BOOL m_bNewItem;
535 bool m_bEnableEdit;
536 DWORD m_dwLStyle;
537 CString m_strTitle;
538 CString m_strFilter;
539 CString m_strInitialDir;
540 CString m_strItemText;
541 CXTPItemEdit* m_pItemEdit;
542 CXTPEditListBoxToolBar m_editGroup;
544};
545
547
548AFX_INLINE int CXTPEditListBox::GetCurrentIndex()
549{
550 return m_nIndex;
551}
552AFX_INLINE CXTPEditListBoxToolBar& CXTPEditListBox::GetEditGroup()
553{
554 return m_editGroup;
555}
556AFX_INLINE void CXTPEditListBox::SetDlgFilter(LPCTSTR lpszFilter /*=NULL*/)
557{
558 m_strFilter = lpszFilter;
559}
560AFX_INLINE void CXTPEditListBox::SetDlgInitialDir(LPCTSTR lpszInitialDir /*=NULL*/)
561{
562 m_strInitialDir = lpszInitialDir;
563}
564AFX_INLINE bool CXTPEditListBox::HasToolbar()
565{
566 return ((m_dwLStyle & LBS_XTP_NOTOOLBAR) == 0);
567}
568AFX_INLINE void CXTPEditListBox::EnableEdit(bool bEnable)
569{
570 m_bEnableEdit = bEnable;
571 m_editGroup.EnableEdit(bEnable);
572}
573AFX_INLINE void CXTPEditListBox::SetNewItemDefaultText(LPCTSTR lpszItemDefaultText)
574{
575 m_strItemDefaultText = lpszItemDefaultText;
576}
578# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
580#endif // #if !defined(__XTEDITLISTBOX_H__)
XTPControlTheme
XTPControlTheme
Enumeration used to determine the active theme style.
Definition XTPControlTheme.h:43
XTPDisableNoisyWarnings.h
LBS_XTP_CHOOSEDIR
const DWORD LBS_XTP_CHOOSEDIR
Definition XTPEditListBox.h:259
LBS_XTP_CHOOSEFILE
const DWORD LBS_XTP_CHOOSEFILE
Definition XTPEditListBox.h:260
LBS_XTP_HIDE_UP_DOWN
const DWORD LBS_XTP_HIDE_UP_DOWN
Hide Up/Down buttons.
Definition XTPEditListBox.h:263
LBS_XTP_ONLY_UP_DOWN
const DWORD LBS_XTP_ONLY_UP_DOWN
Only Up/Down buttons.
Definition XTPEditListBox.h:264
LBS_XTP_DEFAULT
const DWORD LBS_XTP_DEFAULT
Definition XTPEditListBox.h:258
LBS_XTP_BROWSE_ONLY
const DWORD LBS_XTP_BROWSE_ONLY
Browse button.
Definition XTPEditListBox.h:265
LBS_XTP_NOTOOLBAR
const DWORD LBS_XTP_NOTOOLBAR
Definition XTPEditListBox.h:261
LBS_XTP_BROWSE
const DWORD LBS_XTP_BROWSE
Browse button.
Definition XTPEditListBox.h:262
XTPEnableNoisyWarnings.h
CXTPButton
Push Button control.
Definition XTPButton.h:109
CXTPEditListBox
CXTPEditListBox is a CXTPListBox derived class.
Definition XTPEditListBox.h:275
CXTPEditListBox::DeleteItem
virtual void DeleteItem()
Deletes the currently selected item.
CXTPEditListBox::HasToolbar
bool HasToolbar()
Call this member function to determine if the edit list has a toolbar.
CXTPEditListBox::EditItem
void EditItem(int iItem)
This member function will enable editing for the list box item.
CXTPEditListBox::CXTPEditListBox
CXTPEditListBox()
Constructs a CXTPEditListBox object.
CXTPEditListBox::RecalcLayout
virtual void RecalcLayout()
Recalculates the toolbar layout for the CXTPEditListBox.
CXTPEditListBox::GetEditItemText
virtual void GetEditItemText()
Retrieves the edited item's text label.
CXTPEditListBox::SetDlgInitialDir
void SetDlgInitialDir(LPCTSTR lpszInitialDir)
This member function sets the initial directory for the file dialog.
CXTPEditListBox::EnableEdit
void EnableEdit(bool bEnable)
This member function will enable/disable editing.
CXTPEditListBox::Initialize
virtual void Initialize(bool bAutoFont=true)
Initializes the CXTPEditListBox control.
CXTPEditListBox::GetCurrentIndex
int GetCurrentIndex()
Retrieves the current item index.
CXTPEditListBox::SetNewItemDefaultText
void SetNewItemDefaultText(LPCTSTR lpszItemDefaultText)
Sets the default text for new items.
CXTPEditListBox::SetEditText
void SetEditText(LPCTSTR pcszText)
This method is called to set in-place edit text.
CXTPEditListBox::CreateEditGroup
virtual BOOL CreateEditGroup(bool bAutoFont=true)
This member function will create the edit group control.
CXTPEditListBox::GetEditGroup
CXTPEditListBoxToolBar & GetEditGroup()
Retrieves a pointer to the CXTPEditListBoxToolBar toolbar.
CXTPEditListBox::CreateEditControl
virtual CXTPItemEdit * CreateEditControl(CRect rcItem)
This method is called to create an in-place edit control.
CXTPEditListBox::EditListItem
virtual void EditListItem(BOOL bNewItem)
Enables editing for the currently selected item.
CXTPEditListBox::MoveItemDown
virtual void MoveItemDown(int nIndex)
Moves an item down.
CXTPEditListBox::SetListEditStyle
void SetListEditStyle(UINT nTitle, DWORD dwLStyle=LBS_XTP_DEFAULT)
Sets the edit style for the edit list box.
CXTPEditListBox::RefreshMetrics
virtual void RefreshMetrics()
Call this member function to refresh theme colors and redraw the control.
CXTPEditListBox::SetDlgFilter
void SetDlgFilter(LPCTSTR lpszFilter=NULL)
Call this member function to set the default filter for the file dialog.
CXTPEditListBox::~CXTPEditListBox
virtual ~CXTPEditListBox()
Destroys a CXTPEditListBox object, handles cleanup and deallocation.
CXTPEditListBox::SetListEditStyle
void SetListEditStyle(LPCTSTR lpszTitle, DWORD dwLStyle=LBS_XTP_DEFAULT)
Sets the edit style for the edit list box.
CXTPEditListBox::MoveItemUp
virtual void MoveItemUp(int nIndex)
Moves an item up.
CXTPEditListBoxToolBar
CXTPEditListBoxToolBar is a CStatic derived class.
Definition XTPEditListBox.h:49
CXTPEditListBoxToolBar::DrawText
virtual void DrawText(CDC *pDC, CRect &rcClient)
This member function is called by the CXTPEditListBoxToolBar object to render a text display for the ...
CXTPEditListBoxToolBar::MoveButtons
virtual void MoveButtons()
Recalculates the button layout within the CXTPEditListBoxToolBar window.
CXTPEditListBoxToolBar::SetButtonTheme
void SetButtonTheme(XTPControlTheme eTheme)
Call this member to switch the visual theme of the control.
CXTPEditListBoxToolBar::~CXTPEditListBoxToolBar
virtual ~CXTPEditListBoxToolBar()
Destroys a CXTPEditListBoxToolBar object, handles cleanup and deallocation.
CXTPEditListBoxToolBar::GetDeleteButton
CXTPButton & GetDeleteButton()
This member function returns a reference to the delete button of the edit group.
CXTPEditListBoxToolBar::GetNewButton
CXTPButton & GetNewButton()
This member function returns a reference to the new button of the edit group.
CXTPEditListBoxToolBar::GetDownButton
CXTPButton & GetDownButton()
This member function returns a reference to the down button of the edit group.
CXTPEditListBoxToolBar::EnableEdit
void EnableEdit(bool bEnable)
This member function will enable/disable editing.
CXTPEditListBoxToolBar::Initialize
virtual void Initialize(bool bAutoFont=true)
Initializes the CXTPEditListBoxToolBar control.
CXTPEditListBoxToolBar::SetTheme
void SetTheme(XTPControlTheme nTheme)
This member function sets the drawing theme for the control.
CXTPEditListBoxToolBar::CXTPEditListBoxToolBar
CXTPEditListBoxToolBar()
Constructs a CXTPEditListBoxToolBar object.
CXTPEditListBoxToolBar::GetUpButton
CXTPButton & GetUpButton()
This member function returns a reference to the up button of the edit group.
CXTPEditListBoxToolBar::SendCommand
virtual void SendCommand(UINT nCmdID)
Sends a notification to the owner window.
CXTPEditListBoxToolBar::GetTooltipControl
CToolTipCtrl & GetTooltipControl()
This member function returns a reference to the tooltip control.
CXTPItemEdit
CXTPItemEdit is a CXTPBrowseEdit derived class.
Definition XTPBrowseEdit.h:454
CXTPListBox
CXTPListBox is a CListBox derived class.
Definition XTPListBox.h:127
CXTPPaintManagerColor
The CXTPPaintManagerColor class is used to manage COLORREF values for determining default and applica...
Definition XTPColorManager.h:117


Toolkit Pro: Member List

  • XTP_CALENDAR_USERACTION_PARAMS
  • SCROLLDAYBUTTONACTION_PARAMS
XTP_CALENDAR_USERACTION_PARAMS::SCROLLDAYBUTTONACTION_PARAMS Member List

This is the complete list of members for XTP_CALENDAR_USERACTION_PARAMS::SCROLLDAYBUTTONACTION_PARAMS, including all inherited members.

nButton | XTP_CALENDAR_USERACTION_PARAMS::SCROLLDAYBUTTONACTION_PARAMS
pViewGroup | XTP_CALENDAR_USERACTION_PARAMS::SCROLLDAYBUTTONACTION_PARAMS


Toolkit Pro: Member List

CXTPCalendarVisualStudio2015Theme Member List

This is the complete list of members for CXTPCalendarVisualStudio2015Theme, including all inherited members.

_GetAtGrow_BusyStatusBrushValue(int eBusyStatus, BOOL bGrow) | CXTPCalendarPaintManager | protected
_Init() | CXTPCalendarPaintManager | virtual
AddViewPart(CXTPCalendarViewPart *pPart) | CXTPCalendarPaintManager | protected
AdjustTimeFont(CDC *pDC, CRect rcCell) | CXTPCalendarPaintManager |
BEGIN_VIEW_PART(ControlPart, XTPCalendarViewPart) virtual void RefreshMetrics() | CXTPCalendarPaintManager |
CalcEventSize(CDC *c, CXTPCalendarTimeLineViewEvent *pViewEvent) | CXTPCalendarPaintManager | virtual
CalcWidth(CDC *pDC, const CString &strHour, const CString &strMin, int nHourHeight, int &nWidth) | CXTPCalendarPaintManager |
CXTPCalendarOffice2000Theme() | CXTPCalendarOffice2000Theme |
CXTPCalendarOffice2013Theme() | CXTPCalendarOffice2013Theme |
CXTPCalendarPaintManager() | CXTPCalendarPaintManager |
CXTPCalendarVisualStudio2015Theme() | CXTPCalendarVisualStudio2015Theme |
CXTPCmdTarget() | CXTPCmdTarget |
DrawBigHourCell(CDC *pDC, CRect rc, CString strHour, CString strMin, int nRowPerHour, BOOL bFillBackground=TRUE, BOOL bCurrentTime=FALSE) | CXTPCalendarPaintManager | virtual
DrawBitmap(CImageList *pImageList, CDC *pDC, CRect rcView, int iIcon, UINT uFlags=0) | CXTPCalendarPaintManager | virtual
DrawBitmap(UINT nIDResource, CDC *pDC, CRect rcBitmap) | CXTPCalendarPaintManager | virtual
DrawBorder(CDC *pDC, CRect rcView, CXTPCalendarWeekViewEvent *pWeekViewEvent) | CXTPCalendarPaintManager | virtual
DrawBusyStatus(CDC *pDC, CRect &rcRect, int eBusyStatus) | CXTPCalendarPaintManager | virtual
DrawBusyStatus(CDC *pDC, CRgn &rgnBusy, int eBusyStatus) | CXTPCalendarPaintManager | virtual
DrawClock(CDC *pDC, COleDateTime dtClockTime, CRect rcView, COLORREF clrBackground, XTPCalendarClockAlignFlags cafAlign) | CXTPCalendarPaintManager | virtual
DrawDayHeader(CDC *pDC, CRect rcDay, int nHeaderHeight, CString strHeader, BOOL bIsCurrent=FALSE, BOOL bIsSelected=FALSE) | CXTPCalendarPaintManager | virtual
DrawEvent(CDC *pDC, const CRect &rcEvents, CXTPCalendarTimeLineViewEvent *pViewEvent) | CXTPCalendarPaintManager | virtual
DrawExpandSigns(CDC *pDC, CXTPCalendarDayView *pView, const CRect &rcTSHours) | CXTPCalendarPaintManager | virtual
DrawGroup(CDC *pDC, const CRect &rcRect, CXTPCalendarTimeLineViewGroup *pGroup) | CXTPCalendarPaintManager | virtual
DrawHeader(CDC *pDC, CRect &rcHeader, BOOL bIsSelected, BOOL bIsCurrent, const CXTPPaintManagerColorGradient &grclr, COLORREF clrUnderLineHdr) | CXTPCalendarOffice2013Theme | virtual
CXTPCalendarOffice2000Theme::DrawHeader(CDC *pDC, CRect &rcHeader, BOOL bIsSelected, BOOL bIsCurrent) | CXTPCalendarPaintManager | virtual
DrawHorizontalLine(CDC *pDC, int xPos, int yPos, int cx) | CXTPCalendarPaintManager | virtual
DrawHourCell(CDC *pDC, CRect rc, CString strText, BOOL bFillBackground=TRUE, BOOL bCurrentTime=FALSE) | CXTPCalendarPaintManager | virtual
DrawIconChar(CDC *pDC, CRect rc, TCHAR ch) | CXTPCalendarPaintManager | virtual
DrawIcons(CDC *pDC, CXTPCalendarViewEvent *pViewEvent) | CXTPCalendarPaintManager | virtual
DrawLine(CDC *pDC, int xPos, int yPos, int cx, int cy) | CXTPCalendarPaintManager | virtual
DrawNowLine(CDC *pDC, CXTPCalendarDayView *pView, CRect rc, int y, BOOL bDrawBk=FALSE) | CXTPCalendarPaintManager | virtual
DrawNowLine(CDC *pDC, CXTPCalendarDayView *pView, CXTPCalendarDayViewTimeScale *pScale, CRect rc, int y, BOOL bDrawBk=FALSE) | CXTPCalendarPaintManager | virtual
DrawShadow(CDC *pDC, const CRect &rcRect) | CXTPCalendarPaintManager | virtual
DrawSubj(CDC *pDC, CXTPCalendarWeekViewEvent *pWeekViewEvent) | CXTPCalendarPaintManager | virtual
DrawTimes(CDC *pDC, CXTPCalendarWeekViewEvent *pWeekViewEvent) | CXTPCalendarPaintManager | virtual
DrawVerticalLine(CDC *pDC, int xPos, int yPos, int cy) | CXTPCalendarPaintManager | virtual
EnableTheme(BOOL bEnableTheme) | CXTPCalendarPaintManager |
END_VIEW_PART(ControlPart) BEGIN_VIEW_PART(DayViewTimeScaleHeaderPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewTimeScaleHeaderPart) BEGIN_VIEW_PART(DayViewTimeScaleCellPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewTimeScaleCellPart) BEGIN_VIEW_PART(DayViewCellPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewCellPart) BEGIN_VIEW_PART(DayViewWorkCellPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewWorkCellPart) BEGIN_VIEW_PART(DayViewNonworkCellPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewNonworkCellPart) BEGIN_VIEW_PART(DayMonthViewHeaderPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayMonthViewHeaderPart) BEGIN_VIEW_PART(DayViewHeaderPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewHeaderPart) BEGIN_VIEW_PART(DayViewGroupHeaderPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewGroupHeaderPart) BEGIN_VIEW_PART(DayViewAllDayEventsPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewAllDayEventsPart) BEGIN_VIEW_PART(DayViewAllDayEventScrollIconsPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewAllDayEventScrollIconsPart) BEGIN_VIEW_PART(DayViewEventPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewEventPart) BEGIN_VIEW_PART(MonthViewGridPart | CXTPCalendarPaintManager |
END_VIEW_PART(MonthViewGridPart) BEGIN_VIEW_PART(MonthViewHeaderPart | CXTPCalendarPaintManager |
END_VIEW_PART(MonthViewHeaderPart) BEGIN_VIEW_PART(MonthViewEventPart | CXTPCalendarPaintManager |
END_VIEW_PART(MonthViewEventPart) BEGIN_VIEW_PART(WeekViewPart | CXTPCalendarPaintManager |
END_VIEW_PART(WeekViewPart) BEGIN_VIEW_PART(WeekViewEventPart | CXTPCalendarPaintManager |
END_VIEW_PART(WeekViewEventPart) BEGIN_VIEW_PART(TimeLineViewTimeScalePart_Day | CXTPCalendarPaintManager |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAskItemTextFlags() const | CXTPCalendarPaintManager |
GetBusyStatusBrush(int nBusyStatus) | CXTPCalendarPaintManager |
GetClockSize() | CXTPCalendarPaintManager | virtual
GetCurrentSystemTheme() | CXTPCalendarPaintManager |
GetEventBackColor(CXTPCalendarEvent *pEvent) | CXTPCalendarOffice2013Theme | virtual
CXTPCalendarOffice2000Theme::GetEventBackColor(CXTPCalendarEvent *pEvent, COLORREF crDefault) | CXTPCalendarPaintManager | virtual
GetEventEdgeColor(CXTPCalendarEvent *pEvent) | CXTPCalendarOffice2013Theme | virtual
GetExpandSignSize() | CXTPCalendarPaintManager | virtual
GetPaintTheme() const | CXTPCalendarPaintManager | virtual
GetParams(CXTPCalendarDayViewGroup *pViewGroup, XTP_CALENDAR_DAYVIEWCELL_PARAMS *rCellParams) | CXTPCalendarPaintManager | virtual
idxExpandSignDown enum value | CXTPCalendarPaintManager | protected
idxExpandSignUp enum value | CXTPCalendarPaintManager | protected
idxMeeting enum value | CXTPCalendarPaintManager | protected
idxPrivate enum value | CXTPCalendarPaintManager | protected
idxRecurrenceException enum value | CXTPCalendarPaintManager | protected
idxRecurrenceOccurrence enum value | CXTPCalendarPaintManager | protected
idxReminder enum value | CXTPCalendarPaintManager | protected
InitBusyStatusDefaultColors() | CXTPCalendarPaintManager | protectedvirtual
IsThemeEnabled() | CXTPCalendarPaintManager |
m_arBusyStatusBrushes | CXTPCalendarPaintManager | protected
m_arStartCol | CXTPCalendarPaintManager |
m_arStartRow | CXTPCalendarPaintManager |
m_bEnableTheme | CXTPCalendarPaintManager | protected
m_bmpElsewherePattern | CXTPCalendarPaintManager | protected
m_bmpTentativePattern | CXTPCalendarPaintManager | protected
m_bShowMinutes | CXTPCalendarPaintManager |
m_clr3DShadow | CXTPCalendarPaintManager |
m_clrBackground | CXTPCalendarPaintManager |
m_clrBackground2 | CXTPCalendarPaintManager |
m_clrBackgroundSlave | CXTPCalendarPaintManager |
m_clrBorders | CXTPCalendarPaintManager |
m_clrButtonFace | CXTPCalendarPaintManager |
m_clrButtonFaceText | CXTPCalendarPaintManager |
m_clrClassicUnderline | CXTPCalendarPaintManager |
m_clrEventBar | CXTPCalendarPaintManager |
m_clrEventBarLine | CXTPCalendarPaintManager |
m_clrEventBorderLine | CXTPCalendarPaintManager |
m_clrHeaderBottomLine | CXTPCalendarPaintManager |
m_clrHighlight | CXTPCalendarPaintManager |
m_clrHour | CXTPCalendarPaintManager |
m_clrSelectedBackground | CXTPCalendarPaintManager |
m_clrSelectedText | CXTPCalendarPaintManager |
m_clrShadow | CXTPCalendarPaintManager |
m_clrText | CXTPCalendarPaintManager |
m_clrTextHighLightColor | CXTPCalendarPaintManager |
m_clrTextNormalColor | CXTPCalendarPaintManager |
m_clrTimeScaleBackground | CXTPCalendarPaintManager |
m_clrTimeScaleHightlite | CXTPCalendarPaintManager |
m_clrTimeScaleText | CXTPCalendarPaintManager |
m_clrUnderLineHdr | CXTPCalendarPaintManager | protected
m_clrWeekendBackground | CXTPCalendarPaintManager |
m_clrWindow | CXTPCalendarPaintManager |
m_clrWindowText | CXTPCalendarPaintManager |
m_CurrSystemTheme | CXTPCalendarPaintManager | protected
m_dwAskItemTextFlags | CXTPCalendarPaintManager | protected
m_fntTimeText | CXTPCalendarPaintManager |
m_grclrClassicSelDay | CXTPCalendarPaintManager |
m_grclrToday | CXTPCalendarPaintManager |
m_lstViewParts | CXTPCalendarPaintManager | protected
m_nHourWidth | CXTPCalendarPaintManager |
m_nMinWidth | CXTPCalendarPaintManager |
m_nPaintTheme | CXTPCalendarPaintManager | protected
m_pControl | CXTPCalendarPaintManager | protected
m_pExpandSigns | CXTPCalendarPaintManager | protected
m_pGlyphs | CXTPCalendarPaintManager | protected
m_pGlyphsFont | CXTPCalendarPaintManager | protected
m_PrintPageWidth | CXTPCalendarPaintManager |
m_szClockRect | CXTPCalendarPaintManager | protected
m_xtpBrushElsewhere | CXTPCalendarPaintManager | protected
m_xtpBrushTentative | CXTPCalendarPaintManager | protected
OnDraw(CDC *pDC, CXTPCalendarDayView *pView, CRect rc, CString strText) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarDayViewGroup *pViewGroup, CRect rc, const XTP_CALENDAR_DAYVIEWCELL_PARAMS &cellParams) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarDayViewDay *pViewDay, CRect rc, CString strText) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarDayViewGroup *pViewGroup, CRect rc, CString strText) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarDayViewGroup *pViewGroup, CRect rc, BOOL bSelected) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarDayViewGroup *pViewGroup, BOOL bDrawUp, BOOL bDrawDown, const CRect &rcIconUp, const CRect &rcIconDown, BOOL bHighlightUp, BOOL bHighlightDown) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarDayViewEvent *pViewEvent) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarMonthView *pMonthView, CRect rc, int nCollIndex, CString strText) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarWeekView *pWeekView) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarWeekViewEvent *pWeekViewEvent) | CXTPCalendarPaintManager | virtual
OnDrawDayDate(CDC *pDC, CRect rc, BOOL bToday, BOOL bSelected, BOOL bFirstMonthDay, CString strText) | CXTPCalendarPaintManager | virtual
OnDrawEvent(CDC *pDC, CXTPCalendarMonthViewEvent *pViewEvent) | CXTPCalendarPaintManager | virtual
OnDrawGrid(CDC *pDC, CXTPCalendarMonthView *pMonthView) | CXTPCalendarPaintManager | virtual
RefreshMetrics() | CXTPCalendarOffice2013Theme | virtual
SetAskItemTextFlags(DWORD dwFlags) | CXTPCalendarPaintManager |
SetBusyStatusBrush(int nBusyStatus, CBrush *pBrush, BOOL bAutodeleteBrush) | CXTPCalendarPaintManager |
SetControl(CXTPCalendarControl *pControl) | CXTPCalendarPaintManager | virtual
SetPaintTheme(XTPCalendarTheme ePaintTheme) | CXTPCalendarPaintManager | virtual
UpdateEventCategoriesDefaultColors() | CXTPCalendarOffice2013Theme | virtual
UpdateEventLabelsDefaultColors() | CXTPCalendarOffice2013Theme | virtual
UpdateGlyphs() | CXTPCalendarOffice2013Theme | virtual
XTPEnumEventGlyphs enum name | CXTPCalendarPaintManager | protected
XTPEnumExpandSigns enum name | CXTPCalendarPaintManager | protected
~CTimeLineViewPart() | CXTPCalendarPaintManager | virtual
~CXTPCalendarOffice2000Theme() | CXTPCalendarOffice2000Theme | virtual
~CXTPCalendarOffice2013Theme() | CXTPCalendarOffice2013Theme | virtual
~CXTPCalendarPaintManager() | CXTPCalendarPaintManager | virtual
~CXTPCalendarVisualStudio2015Theme() | CXTPCalendarVisualStudio2015Theme | virtual


Toolkit Pro: XTPMarkupRun.h Source File

  • Source
  • Markup
  • Text
XTPMarkupRun.h
Go to the documentation of this file.
1
23#if !defined(__XTPMARKUPRUN_H__)
24# define __XTPMARKUPRUN_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPMarkupDependencyProperty;
34class CXTPMarkupFont;
35class CXTPMarkupDrawingContext;
36class CXTPMarkupBuilder;
37class CXTPMarkupObject;
38class CXTPMarkupString;
39struct XTPMarkupFontMetrics;
40
41class _XTP_EXT_CLASS CXTPMarkupRun : public CXTPMarkupInline
42{
44 DECLARE_MARKUPCLASS(CXTPMarkupRun)
46protected:
47 CXTPMarkupRun();
48 virtual ~CXTPMarkupRun();
49
50protected:
51 virtual void OnFinalRelease();
52
53public:
54 CString GetText() const;
55 LPCWSTR GetTextW() const;
56 void SetText(LPCWSTR lpszText);
57 void SetText(CXTPMarkupString* pText);
58
59public:
60 virtual POSITION GetContentStartPosition() const;
61 virtual void GetContentNextPosition(POSITION& pos) const;
62 virtual BOOL IsWordBreakPosition(POSITION pos) const;
63 virtual BOOL IsLineBreakPosition(POSITION pos) const;
64 virtual BOOL IsCaretReturnPosition(POSITION pos) const;
65 virtual BOOL IsWhiteSpacePosition(POSITION pos) const;
66 virtual CSize Measure(CXTPMarkupDrawingContext* pDC, POSITION posStart, POSITION posEnd);
67 virtual void Measure(CXTPMarkupDrawingContext* pDC, POSITION posStart, POSITION posEnd,
68 CXTPSizeF& size);
69 virtual void Render(CXTPMarkupDrawingContext* pDC, CRect rc, POSITION posStart,
70 POSITION posEnd);
71
72protected:
73 virtual void GetLogFont(LOGFONT* lf) const;
74
75protected:
76 virtual void SetContentObject(CXTPMarkupBuilder* pBuilder, CXTPMarkupObject* pContent);
77 virtual BOOL HasContentObject() const;
78 virtual void PrepareMeasure(CXTPMarkupDrawingContext* pDC);
79
81public:
82 DECLARE_DISPATCH_MAP()
83# ifdef _XTP_ACTIVEX
84 DECLARE_INTERFACE_MAP()
85 DECLARE_OLETYPELIB_EX(CXTPMarkupRun);
86# endif
87
88 afx_msg VARIANT OleGetText();
89 afx_msg void OleSetText(const VARIANT& lpCaption);
90
93protected:
94 int m_nBaseline;
95 virtual int GetBaseline() const;
96 virtual const XTPMarkupFontMetrics* GetFontMetrics() const;
97
98 CXTPMarkupFont* m_pFont;
99
100private:
101 XTPMarkupFontMetrics* m_pFontMetrics;
102
103public:
104 static CXTPMarkupDependencyProperty* m_pTextProperty;
105};
106
107# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
109#endif // !defined(__XTPMARKUPRUN_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPSizeT
This class incapsulates size data.
Definition XTPSize.h:40


Toolkit Pro: XTPDockingPaneTabColorSet2015.h Source File

  • Source
  • DockingPane
  • TabColorSets
XTPDockingPaneTabColorSet2015.h
Go to the documentation of this file.
1
23#if !defined(__XTPDOCKINGPANETABCOLORSET2015_H__)
24# define __XTPDOCKINGPANETABCOLORSET2015_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPDockingPaneTabColorSet2015 : public CXTPDockingPaneTabColorSet2012
39{
40public:
45 CXTPDockingPaneTabColorSet2015();
46
61 virtual void FillHeader(CDC* pDC, CRect rc, CXTPTabManager* pTabManager);
62};
63
64# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
66#endif // !defined(__XTPDOCKINGPANETABCOLORSET2015_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPDockingPaneTabColorSet2012
Helper class used to initialize default colors for a theme from an .INI resource and handle drawing r...
Definition XTPDockingPaneTabColorSet2012.h:39
CXTPDockingPaneTabColorSet2015
Helper class used to initialize default colors for a theme from an .INI resource and handle drawing r...
Definition XTPDockingPaneTabColorSet2015.h:39
CXTPDockingPaneTabColorSet2015::FillHeader
virtual void FillHeader(CDC *pDC, CRect rc, CXTPTabManager *pTabManager)
This member is called to fill the header of the TabClient of the tab manager.
CXTPDockingPaneTabColorSet2015::CXTPDockingPaneTabColorSet2015
CXTPDockingPaneTabColorSet2015()
Default class constructor.
CXTPTabManager
CXTPTabManager is the base class for docking pane tabs, tab control tabs, and MDI client tabs.
Definition XTPTabManager.h:87


Toolkit Pro: Member List

CXTPTaskPanelVisualStudio2019Theme Member List

This is the complete list of members for CXTPTaskPanelVisualStudio2019Theme, including all inherited members.

BlendColor(COLORREF clrFrom, COLORREF clrTo, int nAlpha) | CXTPTaskPanelPaintManager | protected
CreateGripperBitmaps() | CXTPTaskPanelPaintManager | protected
CreateGripperIcon(HICON &hIcon, UINT nIDResource, COLORREF clrGripperBack) | CXTPTaskPanelPaintManager | protected
CXTPTaskPanelPaintManager() | CXTPTaskPanelPaintManager |
CXTPTaskPanelPaintManagerPlain() | CXTPTaskPanelPaintManagerPlain |
CXTPTaskPanelToolboxTheme() | CXTPTaskPanelToolboxTheme |
CXTPTaskPanelVisualStudio2005Theme() | CXTPTaskPanelVisualStudio2005Theme |
CXTPTaskPanelVisualStudio2012Theme(BOOL bLight=TRUE) | CXTPTaskPanelVisualStudio2012Theme |
CXTPTaskPanelVisualStudio2019Theme() | CXTPTaskPanelVisualStudio2019Theme |
DrawCaptionGripper(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelPaintManager | protectedvirtual
DrawCaptionGripperBitmap(CDC *pDC, CXTPTaskPanelGroup *pGroup, BOOL bExpanded, BOOL bHot, CRect rc) | CXTPTaskPanelPaintManager | protected
DrawCaptionGripperSigns(CDC *pDC, CPoint pt, COLORREF clr, BOOL bExpanded) | CXTPTaskPanelPaintManager | protected
DrawDragArrow(CDC *pDC, CXTPTaskPanelItem *pItem, CRect rc, BOOL bAfter=FALSE) | CXTPTaskPanelPaintManager | protectedvirtual
DrawFocusRect(CDC *pDC, CRect rc) | CXTPTaskPanelPaintManager | protectedvirtual
DrawGroupCaption(CDC *pDC, CXTPTaskPanelGroup *pGroup, BOOL bDraw) | CXTPTaskPanelToolboxTheme | virtual
DrawGroupCaptionBackground(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelVisualStudio2012Theme | virtual
DrawGroupClient(CDC *pDC, CXTPTaskPanelGroup *pGroup) | CXTPTaskPanelPaintManager | virtual
DrawGroupClientFace(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelVisualStudio2012Theme | virtual
DrawGroupClientItems(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelPaintManager | protectedvirtual
DrawGroupItem(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw) | CXTPTaskPanelPaintManager | virtual
DrawGroupItemFrame(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc) | CXTPTaskPanelVisualStudio2012Theme | virtual
DrawGroupItemImage(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw) | CXTPTaskPanelPaintManager | protected
DrawGroupItemImageWithText(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw) | CXTPTaskPanelPaintManager | protected
DrawGroupItemImageWithTextBelow(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw) | CXTPTaskPanelPaintManager | protected
DrawItemCaption(CDC *pDC, CXTPTaskPanelItem *pItem, CRect rcText, UINT nFormat) | CXTPTaskPanelVisualStudio2012Theme | virtual
DrawItemImage(CDC *pDC, CXTPTaskPanelItem *pItem, CPoint ptIcon, CXTPImageManagerIcon *pImage, CSize szIcon) | CXTPTaskPanelPaintManager | protectedvirtual
DrawScrollButton(CDC *pDC, CXTPTaskPanelScrollButton *pScrollButton) | CXTPTaskPanelPaintManager | virtual
FillGroupClientFace(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelVisualStudio2012Theme | virtual
FillTaskPanel(CDC *pDC, CXTPTaskPanel *pTaskPanel) | CXTPTaskPanelVisualStudio2012Theme | virtual
FreeBitmaps() | CXTPTaskPanelPaintManager | protected
GetCaptionGripperWidth(CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelPaintManager | protectedvirtual
GetControlMargins(const CXTPTaskPanel *pPanel) | CXTPTaskPanelPaintManager | virtual
GetGroupColors(BOOL bSpecial) | CXTPTaskPanelPaintManager |
GetGroupColors(CXTPTaskPanelGroup *pGroup) | CXTPTaskPanelPaintManager | virtual
GetGroupInnerMargins(const CXTPTaskPanelGroup *pGroup) | CXTPTaskPanelPaintManager | virtual
GetGroupOuterMargins(const CXTPTaskPanelGroup *pGroup) | CXTPTaskPanelPaintManager | virtual
GetGroupSpacing(const CXTPTaskPanel *pPanel) | CXTPTaskPanelPaintManager | virtual
GetHighlightOffset(CXTPTaskPanelGroupItem *pItem) | CXTPTaskPanelPaintManager | protectedvirtual
GetItemFont(CXTPTaskPanelItem *pItem) | CXTPTaskPanelPaintManager | virtual
GetItemIconPadding(const CXTPTaskPanelItem *pItem) | CXTPTaskPanelPaintManager | virtual
GetItemInnerMargins(const CXTPTaskPanelGroupItem *pItem) | CXTPTaskPanelPaintManager | virtual
GetItemOuterMargins(const CXTPTaskPanelGroupItem *pItem) | CXTPTaskPanelPaintManager | virtual
m_bBoldCaption | CXTPTaskPanelPaintManager |
m_bCaptionScrollButton | CXTPTaskPanelPaintManager |
m_bEmbossedDisabledText | CXTPTaskPanelPaintManager |
m_bEmulateEplorerTheme | CXTPTaskPanelPaintManager |
m_bInvertDragRect | CXTPTaskPanelPaintManager |
m_bLeftRoundedCorner | CXTPTaskPanelPaintManager | protected
m_bmpGrippers | CXTPTaskPanelPaintManager | protected
m_bOfficeBorder | CXTPTaskPanelPaintManager | protected
m_bOfficeCaption | CXTPTaskPanelPaintManagerPlain | protected
m_bOfficeHighlight | CXTPTaskPanelPaintManager |
m_bRightRoundedCorner | CXTPTaskPanelPaintManager | protected
m_bRoundedFrame | CXTPTaskPanelPaintManagerPlain | protected
m_bUseBitmapGrippers | CXTPTaskPanelPaintManager | protected
m_bUseStandardCaptionFont | CXTPTaskPanelPaintManager | protected
m_bUseStandardItemsFont | CXTPTaskPanelPaintManager | protected
m_clrBackground | CXTPTaskPanelPaintManager | protected
m_clrHighlightBorder | CXTPTaskPanelPaintManager | protected
m_clrHighlightHot | CXTPTaskPanelPaintManager | protected
m_clrHighlightPressed | CXTPTaskPanelPaintManager | protected
m_clrHighlightSelected | CXTPTaskPanelPaintManager | protected
m_clrSelectedText | CXTPTaskPanelVisualStudio2012Theme | protected
m_clrSelectedTextWithoutFocus | CXTPTaskPanelVisualStudio2012Theme | protected
m_clrSelectedWithoutFocus | CXTPTaskPanelVisualStudio2012Theme | protected
m_clrText | CXTPTaskPanelVisualStudio2012Theme | protected
m_eGripper | CXTPTaskPanelPaintManager |
m_groupNormal | CXTPTaskPanelPaintManager | protected
m_groupSpecial | CXTPTaskPanelPaintManager | protected
m_hGripperNormal | CXTPTaskPanelPaintManager | protected
m_hGripperSpecial | CXTPTaskPanelPaintManager | protected
m_nCaptionHeight | CXTPTaskPanelPaintManager | protected
m_nCaptionTextFormat | CXTPTaskPanelPaintManager | protected
m_nGroupSpacing | CXTPTaskPanelPaintManager |
m_nItemTextFormat | CXTPTaskPanelPaintManager | protected
m_rcControlMargins | CXTPTaskPanelPaintManager |
m_rcGroupIconPadding | CXTPTaskPanelPaintManager |
m_rcGroupInnerMargins | CXTPTaskPanelPaintManager |
m_rcGroupOuterMargins | CXTPTaskPanelPaintManager |
m_rcImageLayoutIconPadding | CXTPTaskPanelPaintManager |
m_rcItemIconPadding | CXTPTaskPanelPaintManager |
m_rcItemInnerMargins | CXTPTaskPanelPaintManager |
m_rcItemOuterMargins | CXTPTaskPanelPaintManager |
m_xtpFontCaption | CXTPTaskPanelPaintManager | protected
m_xtpFontIcon | CXTPTaskPanelPaintManager | protected
m_xtpFontIconBold | CXTPTaskPanelPaintManager | protected
m_xtpFontIconHot | CXTPTaskPanelPaintManager | protected
m_xtpFontIconHotBold | CXTPTaskPanelPaintManager | protected
Rectangle(CDC *pDC, CRect rc, COLORREF clrPen, COLORREF clrBrush) | CXTPTaskPanelPaintManager | protected
rectDefault | CXTPTaskPanelPaintManager | static
RefreshMetrics() | CXTPTaskPanelVisualStudio2019Theme | virtual
SetCaptionFontIndirect(LOGFONT *pLogFont, BOOL bUseStandardCaptionFont=FALSE) | CXTPTaskPanelPaintManager |
SetItemsFontIndirect(LOGFONT *pLogFont, BOOL bUseStandardItemsFont=FALSE) | CXTPTaskPanelPaintManager |
SetTextFormat(int nTextFormat, BOOL bCaption=FALSE) | CXTPTaskPanelPaintManager |
~CXTPTaskPanelPaintManager() | CXTPTaskPanelPaintManager | virtual
~CXTPTaskPanelVisualStudio2012Theme() | CXTPTaskPanelVisualStudio2012Theme | virtual
~CXTPTaskPanelVisualStudio2019Theme() | CXTPTaskPanelVisualStudio2019Theme | virtual


Toolkit Pro: XTPTabManager.h Source File

  • Source
  • TabManager
XTPTabManager.h
Go to the documentation of this file.
1
23#if !defined(__XTPTABMANAGER_H__)
24# define __XTPTABMANAGER_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPTabManagerNavigateButton;
34class CXTPTabManagerNavigateButtons;
35class CXTPTabManagerItem;
36class CXTPTabManagerAtom;
37class CXTPTabManager;
38class CXTPTabPaintManagerColorSet;
39class CXTPTabPaintManagerTheme;
40
72const UINT WM_XTP_GETTABCOLOR = (WM_USER + 9400 + 1);
73
74class CXTPTabPaintManager;
75class CXTPImageManagerIcon;
76class CXTPMarkupContext;
77class CXTPMarkupUIElement;
78
86class _XTP_EXT_CLASS CXTPTabManager : public CXTPTabManagerAtom
87{
88protected:
89 class CNavigateButtonArrow;
90 class CNavigateButtonArrowLeft;
91 class CNavigateButtonArrowRight;
92 class CNavigateButtonClose;
93 class CNavigateButtonTabClose;
94
95public:
101 struct ROW_ITEMS
102 {
103 int nFirstItem;
104 int nLastItem;
105 };
106
107protected:
112 class CRowIndexer
113 {
114 public:
120 CRowIndexer(CXTPTabManager* pManager);
121
126 ~CRowIndexer();
127
128 public:
136 ROW_ITEMS* CreateIndexer(int nRowCount);
137
144 ROW_ITEMS* GetRowItems() const;
145
146 private:
147 ROW_ITEMS* m_pRowItems;
148 int m_nRowCount;
149 CXTPTabManager* m_pManager;
150
151 friend class CXTPTabManager;
152 };
153
154public:
159 CXTPTabManager();
160
165 virtual ~CXTPTabManager();
166
167public:
175 CXTPTabManagerItem* GetItem(int nIndex) const;
176
184 BOOL DeleteItem(int nItem);
185
190 void DeleteAllItems();
191
198 int GetItemCount() const;
199
200public:
208 virtual CString GetItemCaption(const CXTPTabManagerItem* pItem) const;
209
217 virtual HICON GetItemIcon(const CXTPTabManagerItem* pItem) const;
218
228 virtual COLORREF GetItemColor(const CXTPTabManagerItem* pItem) const;
229
242 virtual CString GetItemTooltip(const CXTPTabManagerItem* pItem) const;
243
255 virtual void OnItemsChanged();
256
257public:
272 void SetCurSel(int nIndex);
273
289 int GetCurSel() const;
290
304 virtual void SetSelectedItem(CXTPTabManagerItem* pItem);
305
313 virtual void SetFocusedItem(CXTPTabManagerItem* pItem);
314
326 CXTPTabManagerItem* GetSelectedItem() const;
327
344 CXTPTabManagerItem* HitTest(CPoint point) const;
345
360 CXTPTabManagerNavigateButton* HitTestNavigateButton(CPoint point, BOOL bHeaderOnly,
361 int* pnIndex = NULL) const;
362
383 virtual void GetItemMetrics(CSize* szNormal, CSize* szMin = NULL, CSize* szMax = NULL) const;
384
405 void SetItemMetrics(CSize szNormal, CSize szMin = CSize(0, 0), CSize szMax = CSize(0, 0));
406
413 void MoveItem(CXTPTabManagerItem* pItem, int nIndex);
414
421 void ShowCloseItemButton(
422 XTPTabNavigateButtonFlags bCloseItemButton = xtpTabNavigateButtonAlways);
423
424public:
436 virtual int GetItemsLength() const;
437
454 int GetRectLength(CRect rc) const;
455
472 CXTPTabManagerNavigateButton* FindNavigateButton(UINT nID) const;
473
483 BOOL IsHorizontalPosition() const;
484
521 int GetHeaderOffset() const;
522
563 void SetHeaderOffset(int nOffset);
564
572 void EnsureVisible(CXTPTabManagerItem* pItem);
573
574public:
587 virtual CXTPTabPaintManager* GetPaintManager() const = 0;
588
598 virtual void SetPaintManager(CXTPTabPaintManager* pPaintManager);
599
609 virtual void RedrawControl(LPCRECT lpRect, BOOL bAnimate) = 0;
610
620 virtual BOOL IsAllowReorder() const;
621
630 virtual void SetAllowReorder(BOOL bAllowReorder);
631
644 virtual BOOL IsDrawStaticFrame() const;
645
663 virtual BOOL DrawIcon(CDC* pDC, CPoint pt, CXTPTabManagerItem* pItem, BOOL bDraw,
664 CSize& szIcon) const = 0;
665
688 void EnableTabThemeTexture(HWND hWnd, BOOL bEnable = TRUE);
689
690public:
720 CXTPTabPaintManagerColorSet* SetColor(XTPTabColorStyle tabColor);
721
738 CXTPTabPaintManagerColorSet* SetColorSet(CXTPTabPaintManagerColorSet* pColorSet);
739
758 CXTPTabPaintManagerTheme* SetAppearance(XTPTabAppearanceStyle tabAppearance);
759
782 CXTPTabPaintManagerTheme* SetAppearanceSet(CXTPTabPaintManagerTheme* pAppearanceSet);
783
801 CXTPTabPaintManagerTheme* GetAppearanceSet() const;
802
814 CXTPTabPaintManagerColorSet* GetColorSet() const;
815
829 XTPTabAppearanceStyle GetAppearance() const;
830
842 XTPTabColorStyle GetColor() const;
843
862 void SetPosition(XTPTabPosition tabPosition);
863
891 void SetLayoutStyle(XTPTabLayoutStyle tabLayout);
892
906 virtual XTPTabPosition GetPosition() const;
907
921 XTPTabLayoutStyle GetLayout() const;
922
928 void ShowIcons(BOOL bShowIcons);
929
948 void SetActive(BOOL bActive);
949
968 BOOL IsActive() const;
969
978 CRect GetControlRect() const;
979
988 CRect GetClientRect() const;
989
998 CRect GetHeaderRect() const;
999
1011 int GetRowCount() const;
1012
1019 virtual void OnScrollHeader(BOOL bRight);
1020
1029 CXTPTabManagerNavigateButtons* GetNavigateButtons();
1030
1045 CXTPTabManagerItem* FindNextFocusable(int nIndex, int nDirection) const;
1046
1047public:
1067 void PerformMouseMove(HWND hWnd, CPoint pt);
1068
1103 BOOL PerformClick(HWND hWnd, CPoint pt, BOOL bNoItemClick = FALSE);
1104
1121 virtual INT_PTR PerformToolHitTest(HWND hWnd, CPoint point, TOOLINFO* pTI) const;
1122
1132 virtual BOOL PerformKeyDown(HWND hWnd, UINT nChar);
1133
1142 virtual BOOL DrawParentBackground(CDC* pDC, CRect rc);
1143
1144public:
1155 int GetNavigateButtonCount() const;
1156
1168 CXTPTabManagerNavigateButton* GetNavigateButton(int nIndex) const;
1169
1170public:
1177 void EnableMarkup(BOOL bEnable = TRUE);
1178
1185 virtual CXTPMarkupContext* GetMarkupContext() const;
1186
1187protected:
1198 virtual BOOL IsNavigateButtonAutomaticVisible(CXTPTabManagerNavigateButton* pButton);
1199
1207 virtual BOOL IsNavigateButtonVisible(CXTPTabManagerNavigateButton* pButton);
1208
1217 virtual void OnItemClick(CXTPTabManagerItem* pItem);
1218
1227 virtual BOOL OnBeforeItemClick(CXTPTabManagerItem* pItem);
1228
1245 virtual void ReOrder(HWND hWnd, CPoint pt, CXTPTabManagerItem* pItem);
1246
1253 virtual void OnSwitchItem(CXTPTabManagerItem* pItem1, CXTPTabManagerItem* pItem2);
1254
1262 virtual void OnItemOrderChanged(CXTPTabManagerItem* pItem, int nOldIndex, int nNewIndex);
1263
1283 virtual void OnNavigateButtonClick(CXTPTabManagerNavigateButton* pButton);
1284
1304 virtual void OnNavigateButtonClick(UINT nID);
1305
1319 virtual BOOL IsMouseLocked() const;
1320
1338 CXTPTabManagerItem* AddItem(int nItem, CXTPTabManagerItem* pItem = NULL);
1339
1347 virtual BOOL HeaderHasFocus() const;
1348
1349protected:
1359 void TrackClick(HWND hWnd, CPoint pt, CXTPTabManagerItem* pItem);
1360
1368 virtual void OnItemHandleChanged(CXTPTabManagerItem* pItem, HWND hwndOld, HWND hwndNew);
1369
1370protected:
1371 CXTPTabManagerItem* m_pSelected;
1372 CXTPTabManagerItem* m_pHighlighted;
1374 CXTPTabManagerItem* m_pPressed;
1376 CXTPTabManagerNavigateButton* m_pHighlightedNavigateButton;
1379 int m_nHeaderOffset;
1382 BOOL m_bAllowReorder;
1383 BOOL m_bActive;
1386 XTPTabNavigateButtonFlags m_bCloseItemButton;
1388 CRect m_rcHeaderRect;
1389 CRect m_rcControl;
1391 CRect m_rcClient;
1393 CArray<CXTPTabManagerItem*, CXTPTabManagerItem*> m_arrItems;
1395 CXTPTabManagerNavigateButtons m_arrNavigateButtons;
1398 CRowIndexer* m_pRowIndexer;
1399 int m_nScrollDelta;
1400 CXTPMarkupContext* m_pMarkupContext;
1402private:
1403 friend class CXTPTabManagerItem;
1404 friend class CXTPTabPaintManager;
1405 friend class CXTPTabManagerNavigateButton;
1406 friend class CXTPTabClientWnd;
1407};
1408
1410// CXTPTabManager
1411
1412AFX_INLINE int CXTPTabManager::GetItemCount() const
1413{
1414 return (int)m_arrItems.GetSize();
1415}
1416AFX_INLINE CXTPTabManagerItem* CXTPTabManager::GetItem(int nIndex) const
1417{
1418 return nIndex >= 0 && nIndex < GetItemCount() ? m_arrItems[nIndex] : NULL;
1419}
1420AFX_INLINE int CXTPTabManager::GetNavigateButtonCount() const
1421{
1422 return (int)m_arrNavigateButtons.GetSize();
1423}
1424AFX_INLINE CXTPTabManagerNavigateButton* CXTPTabManager::GetNavigateButton(int nIndex) const
1425{
1426 return nIndex >= 0 && nIndex < GetNavigateButtonCount() ? m_arrNavigateButtons[nIndex] : NULL;
1427}
1428AFX_INLINE CXTPTabManagerItem* CXTPTabManager::GetSelectedItem() const
1429{
1430 return m_pSelected;
1431}
1432AFX_INLINE BOOL CXTPTabManager::IsHorizontalPosition() const
1433{
1434 return (GetPosition() == xtpTabPositionBottom || GetPosition() == xtpTabPositionTop);
1435}
1436AFX_INLINE int CXTPTabManager::GetRectLength(CRect rc) const
1437{
1438 if (IsHorizontalPosition())
1439 return rc.Width();
1440 return rc.Height();
1441}
1442AFX_INLINE int CXTPTabManager::GetHeaderOffset() const
1443{
1444 return m_nHeaderOffset;
1445}
1446AFX_INLINE void CXTPTabManager::OnNavigateButtonClick(UINT)
1447{
1448}
1449AFX_INLINE void CXTPTabManager::OnNavigateButtonClick(CXTPTabManagerNavigateButton* pButton)
1450{
1451 OnNavigateButtonClick(pButton->GetID());
1452}
1453AFX_INLINE BOOL CXTPTabManager::IsAllowReorder() const
1454{
1455 return m_bAllowReorder;
1456}
1457AFX_INLINE void CXTPTabManager::SetAllowReorder(BOOL bAllowReorder)
1458{
1459 m_bAllowReorder = bAllowReorder;
1460}
1461AFX_INLINE void CXTPTabManager::SetPaintManager(CXTPTabPaintManager* /*pPaintManager*/)
1462{
1463}
1464AFX_INLINE BOOL CXTPTabManager::IsActive() const
1465{
1466 return m_bActive;
1467}
1468AFX_INLINE CRect CXTPTabManager::GetControlRect() const
1469{
1470 return m_rcControl;
1471}
1472AFX_INLINE CRect CXTPTabManager::GetClientRect() const
1473{
1474 return m_rcClient;
1475}
1476AFX_INLINE CRect CXTPTabManager::GetHeaderRect() const
1477{
1478 return m_rcHeaderRect;
1479}
1480AFX_INLINE BOOL CXTPTabManager::IsMouseLocked() const
1481{
1482 return FALSE;
1483}
1484AFX_INLINE int CXTPTabManager::GetRowCount() const
1485{
1486 return m_pRowIndexer->m_nRowCount;
1487}
1488AFX_INLINE BOOL CXTPTabManager::HeaderHasFocus() const
1489{
1490 return FALSE;
1491}
1492AFX_INLINE BOOL CXTPTabManagerItem::IsFocused() const
1493{
1494 return IsSelected() && m_pTabManager->HeaderHasFocus();
1495}
1496AFX_INLINE CXTPMarkupUIElement* CXTPTabManagerItem::GetMarkupUIElement() const
1497{
1498 return m_pMarkupUIElement;
1499}
1500AFX_INLINE CXTPTabManager::ROW_ITEMS* CXTPTabManager::CRowIndexer::GetRowItems() const
1501{
1502 return m_pRowItems;
1503}
1504AFX_INLINE CXTPTabManagerNavigateButtons* CXTPTabManager::GetNavigateButtons()
1505{
1506 return &m_arrNavigateButtons;
1507}
1508AFX_INLINE void CXTPTabManager::OnItemHandleChanged(CXTPTabManagerItem*, HWND, HWND)
1509{
1510}
1511AFX_INLINE BOOL CXTPTabManager::DrawParentBackground(CDC* /*pDC*/, CRect /*rc*/)
1512{
1513 return FALSE;
1514}
1515AFX_INLINE void CXTPTabManager::ShowCloseItemButton(XTPTabNavigateButtonFlags bCloseItemButton)
1516{
1517 m_bCloseItemButton = bCloseItemButton;
1518}
1519AFX_INLINE CXTPMarkupContext* CXTPTabManager::GetMarkupContext() const
1520{
1521 return m_pMarkupContext;
1522}
1523AFX_INLINE void CXTPTabManager::OnSwitchItem(CXTPTabManagerItem* /*pItem1*/,
1524 CXTPTabManagerItem* /*pItem2*/)
1525{
1526}
1527AFX_INLINE void CXTPTabManager::OnItemOrderChanged(CXTPTabManagerItem* /*pItem*/, int /*nOldIndex*/,
1528 int /*nNewIndex*/)
1529{
1530}
1531
1532# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
1534#endif // !defined(__XTPTABMANAGER_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
WM_XTP_GETTABCOLOR
const UINT WM_XTP_GETTABCOLOR
The WM_XTP_GETTABCOLOR message is sent to an MDI child window to retrieve the color that will be used...
Definition XTPTabManager.h:72
XTPTabNavigateButtonFlags
XTPTabNavigateButtonFlags
XTPTabNavigateButtonFlags is an enumeration used to indicate when a navigate button will be displayed...
Definition XTPTabManagerDefines.h:68
xtpTabNavigateButtonAlways
@ xtpTabNavigateButtonAlways
Always display the navigate button.
Definition XTPTabManagerDefines.h:71
XTPTabAppearanceStyle
XTPTabAppearanceStyle
XTPTabAppearanceStyle is an enumeration used to set the appearance of tabs.
Definition XTPTabManagerDefines.h:84
XTPTabPosition
XTPTabPosition
XTPTabPosition is an enumeration used to set the position of tabs.
Definition XTPTabManagerDefines.h:200
xtpTabPositionTop
@ xtpTabPositionTop
Tabs will be drawn on the Top.
Definition XTPTabManagerDefines.h:201
xtpTabPositionBottom
@ xtpTabPositionBottom
Tabs will be drawn on the Bottom.
Definition XTPTabManagerDefines.h:203
XTPTabLayoutStyle
XTPTabLayoutStyle
XTPTabLayoutStyle is an enumeration used to set the layout of tabs.
Definition XTPTabManagerDefines.h:217
XTPTabColorStyle
XTPTabColorStyle
XTPTabColorStyle is an enumeration used to set the color style of tabs.
Definition XTPTabManagerDefines.h:139
CXTPImageManagerIcon
Icons holder class.
Definition XTPImageManager.h:622
CXTPMarkupContext
CXTPMarkupContext is a standalone class used to provide common settings for Markup objects.
Definition XTPMarkupContext.h:128
CXTPMarkupUIElement
Base class for XML Markup core level implementations.
Definition XTPMarkupUIElement.h:43
CXTPTabClientWnd
CXTPTabClientWnd is a CWnd derived class.
Definition XTPTabClientWnd.h:383
CXTPTabManager::CRowIndexer
Helper class used to collect the indices of rows for a multi-row tab manager.
Definition XTPTabManager.h:113
CXTPTabManager::CRowIndexer::CRowIndexer
CRowIndexer(CXTPTabManager *pManager)
Constructs a CRowIndexer object.
CXTPTabManager::CRowIndexer::~CRowIndexer
~CRowIndexer()
Destroys a CRowIndexer object, handles cleanup and deallocation.
CXTPTabManager::CRowIndexer::CreateIndexer
ROW_ITEMS * CreateIndexer(int nRowCount)
Creates the array of indices for the multi-row tab manager.
CXTPTabManager::CRowIndexer::GetRowItems
ROW_ITEMS * GetRowItems() const
Gets the array of indices of the multi-row tab manager.
Definition XTPTabManager.h:1500
CXTPTabManagerAtom
CXTPTabManagerAtom is a class that has only one purpose; to catch the event when a property of the Pa...
Definition XTPTabManagerAtom.h:49
CXTPTabManager
CXTPTabManager is the base class for docking pane tabs, tab control tabs, and MDI client tabs.
Definition XTPTabManager.h:87
CXTPTabManager::IsNavigateButtonAutomaticVisible
virtual BOOL IsNavigateButtonAutomaticVisible(CXTPTabManagerNavigateButton *pButton)
Determines if a specified tab navigation button is automatically displayed.
CXTPTabManager::SetAppearance
CXTPTabPaintManagerTheme * SetAppearance(XTPTabAppearanceStyle tabAppearance)
Applies one of the "built-in" appearance sets for the tabs.
CXTPTabManager::SetActive
void SetActive(BOOL bActive)
Specifies if this tab group should be active/inactive.
CXTPTabManager::EnableTabThemeTexture
void EnableTabThemeTexture(HWND hWnd, BOOL bEnable=TRUE)
Enables/disables Windows XP themed back color.
CXTPTabManager::EnsureVisible
void EnsureVisible(CXTPTabManagerItem *pItem)
Ensures that a specified tab is visible.
CXTPTabManager::GetLayout
XTPTabLayoutStyle GetLayout() const
Gets the tab layout style.
CXTPTabManager::m_bActive
BOOL m_bActive
TRUE if the MDITabClient tab group is active.
Definition XTPTabManager.h:1383
CXTPTabManager::GetSelectedItem
CXTPTabManagerItem * GetSelectedItem() const
Gets the currently selected tab item.
Definition XTPTabManager.h:1428
CXTPTabManager::SetItemMetrics
void SetItemMetrics(CSize szNormal, CSize szMin=CSize(0, 0), CSize szMax=CSize(0, 0))
Sets the minimum, maximum, and normal lengths for tab buttons.
CXTPTabManager::GetRowCount
int GetRowCount() const
Gets the number of rows of tabs in the tab control.
Definition XTPTabManager.h:1484
CXTPTabManager::GetControlRect
CRect GetControlRect() const
Gets the bounding rectangle of the tab manager control area.
Definition XTPTabManager.h:1468
CXTPTabManager::GetNavigateButtonCount
int GetNavigateButtonCount() const
Gets the total number of tab navigation buttons within the collection of tab navigation buttons.
Definition XTPTabManager.h:1420
CXTPTabManager::OnSwitchItem
virtual void OnSwitchItem(CXTPTabManagerItem *pItem1, CXTPTabManagerItem *pItem2)
This method is called by ReOrder when two tab items are switched.
Definition XTPTabManager.h:1523
CXTPTabManager::PerformMouseMove
void PerformMouseMove(HWND hWnd, CPoint pt)
This method is called when the mouse cursor moves.
CXTPTabManager::MoveItem
void MoveItem(CXTPTabManagerItem *pItem, int nIndex)
Sets the position of a specified tab item.
CXTPTabManager::OnScrollHeader
virtual void OnScrollHeader(BOOL bRight)
This method is called when the user presses either the left or right navigation buttons.
CXTPTabManager::DrawIcon
virtual BOOL DrawIcon(CDC *pDC, CPoint pt, CXTPTabManagerItem *pItem, BOOL bDraw, CSize &szIcon) const =0
This method is called when the icon of a tab must be redrawn (e.g.
CXTPTabManager::EnableMarkup
void EnableMarkup(BOOL bEnable=TRUE)
Enables/disables markup for the tab captions.
CXTPTabManager::DeleteItem
BOOL DeleteItem(int nItem)
Deletes a tab item by its index.
CXTPTabManager::IsNavigateButtonVisible
virtual BOOL IsNavigateButtonVisible(CXTPTabManagerNavigateButton *pButton)
Determines if a specified tab navigation button is visible.
CXTPTabManager::OnItemHandleChanged
virtual void OnItemHandleChanged(CXTPTabManagerItem *pItem, HWND hwndOld, HWND hwndNew)
This method is called when the handle of a tab item is changed.
Definition XTPTabManager.h:1508
CXTPTabManager::m_pSelected
CXTPTabManagerItem * m_pSelected
Tab currently selected (i.e.
Definition XTPTabManager.h:1371
CXTPTabManager::SetColor
CXTPTabPaintManagerColorSet * SetColor(XTPTabColorStyle tabColor)
Applies one of the "built-in" color sets for the tabs.
CXTPTabManager::DeleteAllItems
void DeleteAllItems()
Deletes all tab items from the tab manager.
CXTPTabManager::HitTestNavigateButton
CXTPTabManagerNavigateButton * HitTestNavigateButton(CPoint point, BOOL bHeaderOnly, int *pnIndex=NULL) const
Determines which navigation button is at a specified point, if any.
CXTPTabManager::GetItemIcon
virtual HICON GetItemIcon(const CXTPTabManagerItem *pItem) const
Retrieves the icon of a specified tab item.
CXTPTabManager::OnItemOrderChanged
virtual void OnItemOrderChanged(CXTPTabManagerItem *pItem, int nOldIndex, int nNewIndex)
This method is called by ReOrder when a tab item's position is changed.
Definition XTPTabManager.h:1527
CXTPTabManager::GetAppearance
XTPTabAppearanceStyle GetAppearance() const
Gets the currently applied "built-in appearance set.
CXTPTabManager::GetNavigateButton
CXTPTabManagerNavigateButton * GetNavigateButton(int nIndex) const
Retrieves the tab navigation button at a specified index within the collection of tab navigation butt...
Definition XTPTabManager.h:1424
CXTPTabManager::SetLayoutStyle
void SetLayoutStyle(XTPTabLayoutStyle tabLayout)
Sets the tab layout style.
CXTPTabManager::SetAllowReorder
virtual void SetAllowReorder(BOOL bAllowReorder)
Specifies if tabs should be allowed to be reordered.
Definition XTPTabManager.h:1457
CXTPTabManager::GetCurSel
int GetCurSel() const
Gets the index of the currently selected tab item within the collection of tab items.
CXTPTabManager::GetPaintManager
virtual CXTPTabPaintManager * GetPaintManager() const =0
Gets the tab paint manager.
CXTPTabManager::GetItemColor
virtual COLORREF GetItemColor(const CXTPTabManagerItem *pItem) const
Retrieves the tab button color of a specified tab item.
CXTPTabManager::m_pRowIndexer
CRowIndexer * m_pRowIndexer
Row indexer.
Definition XTPTabManager.h:1398
CXTPTabManager::GetHeaderOffset
int GetHeaderOffset() const
Gets the scroll offset of the tabs in the tab header.
Definition XTPTabManager.h:1442
CXTPTabManager::m_bAllowReorder
BOOL m_bAllowReorder
TRUE to allow tabs to be reordered.
Definition XTPTabManager.h:1382
CXTPTabManager::FindNavigateButton
CXTPTabManagerNavigateButton * FindNavigateButton(UINT nID) const
Retrieves a specified tab navigation button (i.e.
CXTPTabManager::HeaderHasFocus
virtual BOOL HeaderHasFocus() const
The implementation should return TRUE if the header has focus or FALSE otherwise.
Definition XTPTabManager.h:1488
CXTPTabManager::IsAllowReorder
virtual BOOL IsAllowReorder() const
Determines if tabs are allowed to be reordered.
Definition XTPTabManager.h:1453
CXTPTabManager::GetItemTooltip
virtual CString GetItemTooltip(const CXTPTabManagerItem *pItem) const
Retrieves the tooltip of a specified tab item.
CXTPTabManager::ReOrder
virtual void ReOrder(HWND hWnd, CPoint pt, CXTPTabManagerItem *pItem)
This method is called when a tab item is clicked and dragged within the tab header.
CXTPTabManager::GetHeaderRect
CRect GetHeaderRect() const
Gets the bounding rectangle of the tab client header area.
Definition XTPTabManager.h:1476
CXTPTabManager::FindNextFocusable
CXTPTabManagerItem * FindNextFocusable(int nIndex, int nDirection) const
Retrieves the next/previous focusable tab item from a specified index.
CXTPTabManager::SetCurSel
void SetCurSel(int nIndex)
Sets the index for the currently selected tab item within the collection of tab items.
CXTPTabManager::IsActive
BOOL IsActive() const
Determines if this tab group is active/inactive.
Definition XTPTabManager.h:1464
CXTPTabManager::IsDrawStaticFrame
virtual BOOL IsDrawStaticFrame() const
Determines if a static frame is used.
CXTPTabManager::GetItemsLength
virtual int GetItemsLength() const
Gets the total width of all of the tab buttons.
CXTPTabManager::GetMarkupContext
virtual CXTPMarkupContext * GetMarkupContext() const
Gets the markup context.
Definition XTPTabManager.h:1519
CXTPTabManager::m_bCloseItemButton
XTPTabNavigateButtonFlags m_bCloseItemButton
TRUE to show the close button for tabs.
Definition XTPTabManager.h:1386
CXTPTabManager::IsMouseLocked
virtual BOOL IsMouseLocked() const
Determines if the MouseMove event has been disabled.
Definition XTPTabManager.h:1480
CXTPTabManager::SetAppearanceSet
CXTPTabPaintManagerTheme * SetAppearanceSet(CXTPTabPaintManagerTheme *pAppearanceSet)
Applies a custom appearance set for the tabs.
CXTPTabManager::m_pMarkupContext
CXTPMarkupContext * m_pMarkupContext
Markup context of the tab manager.
Definition XTPTabManager.h:1400
CXTPTabManager::OnNavigateButtonClick
virtual void OnNavigateButtonClick(CXTPTabManagerNavigateButton *pButton)
This method is called when a tab navigation button is clicked.
Definition XTPTabManager.h:1449
CXTPTabManager::m_nHeaderOffset
int m_nHeaderOffset
Scroll offset, this is how much the tabs in the tab header have been scrolled using the left and righ...
Definition XTPTabManager.h:1379
CXTPTabManager::GetColor
XTPTabColorStyle GetColor() const
Gets the currently applied "built-in" color set.
CXTPTabManager::PerformKeyDown
virtual BOOL PerformKeyDown(HWND hWnd, UINT nChar)
This method is called to process a WM_KEYDOWN event for the tab manager.
CXTPTabManager::OnItemClick
virtual void OnItemClick(CXTPTabManagerItem *pItem)
This method is called when a tab button is clicked to select the tab item that was clicked.
CXTPTabManager::~CXTPTabManager
virtual ~CXTPTabManager()
Destroys a CXTPTabManager object, handles cleanup and deallocation.
CXTPTabManager::IsHorizontalPosition
BOOL IsHorizontalPosition() const
Determines if the tabs are positioned horizontally.
Definition XTPTabManager.h:1432
CXTPTabManager::m_pHighlightedNavigateButton
CXTPTabManagerNavigateButton * m_pHighlightedNavigateButton
Pointer to highlighted navigate button.
Definition XTPTabManager.h:1376
CXTPTabManager::HitTest
CXTPTabManagerItem * HitTest(CPoint point) const
Determines which tab is at a specified point, if any.
CXTPTabManager::AddItem
CXTPTabManagerItem * AddItem(int nItem, CXTPTabManagerItem *pItem=NULL)
Adds a specified tab item to the collection of tab items.
CXTPTabManager::GetPosition
virtual XTPTabPosition GetPosition() const
Gets the tab position.
CXTPTabManager::GetClientRect
CRect GetClientRect() const
Gets the bounding rectangle of the tab client area.
Definition XTPTabManager.h:1472
CXTPTabManager::m_pHighlighted
CXTPTabManagerItem * m_pHighlighted
Tab currently highlighted (i.e.
Definition XTPTabManager.h:1372
CXTPTabManager::GetItemCount
int GetItemCount() const
Gets the number of tab items in the tab manager.
Definition XTPTabManager.h:1412
CXTPTabManager::GetColorSet
CXTPTabPaintManagerColorSet * GetColorSet() const
Gets the currently applied custom color set.
CXTPTabManager::GetNavigateButtons
CXTPTabManagerNavigateButtons * GetNavigateButtons()
Gets the collection of navigation buttons.
Definition XTPTabManager.h:1504
CXTPTabManager::SetFocusedItem
virtual void SetFocusedItem(CXTPTabManagerItem *pItem)
Sets the focused tab item.
CXTPTabManager::PerformClick
BOOL PerformClick(HWND hWnd, CPoint pt, BOOL bNoItemClick=FALSE)
This method is called when the user presses the left mouse button.
CXTPTabManager::GetItem
CXTPTabManagerItem * GetItem(int nIndex) const
Retrieves a tab item by its index.
Definition XTPTabManager.h:1416
CXTPTabManager::m_arrItems
CArray< CXTPTabManagerItem *, CXTPTabManagerItem * > m_arrItems
Bounding rectangle of the tab client area.
Definition XTPTabManager.h:1393
CXTPTabManager::OnBeforeItemClick
virtual BOOL OnBeforeItemClick(CXTPTabManagerItem *pItem)
This method is called before a tab item is clicked.
CXTPTabManager::GetItemMetrics
virtual void GetItemMetrics(CSize *szNormal, CSize *szMin=NULL, CSize *szMax=NULL) const
Gets the minimum, maximum, and normal lengths of tab buttons.
CXTPTabManager::DrawParentBackground
virtual BOOL DrawParentBackground(CDC *pDC, CRect rc)
Draws the parent background under the tab control.
Definition XTPTabManager.h:1511
CXTPTabManager::RedrawControl
virtual void RedrawControl(LPCRECT lpRect, BOOL bAnimate)=0
This method is called when the visual properties of the tabs are changed (e.g.
CXTPTabManager::GetRectLength
int GetRectLength(CRect rc) const
Gets the length of the bounding rectangle of the tab client header area.
Definition XTPTabManager.h:1436
CXTPTabManager::m_rcHeaderRect
CRect m_rcHeaderRect
Bounding rectangle of the tab header area.
Definition XTPTabManager.h:1388
CXTPTabManager::ShowIcons
void ShowIcons(BOOL bShowIcons)
Shows/hides tab icons.
CXTPTabManager::SetHeaderOffset
void SetHeaderOffset(int nOffset)
Sets the scroll offset for the tabs in the tab header.
CXTPTabManager::m_arrNavigateButtons
CXTPTabManagerNavigateButtons m_arrNavigateButtons
Collection of tab navigation buttons for this tab manager.
Definition XTPTabManager.h:1395
CXTPTabManager::CXTPTabManager
CXTPTabManager()
Constructs a CXTPTabManager object.
CXTPTabManager::GetAppearanceSet
CXTPTabPaintManagerTheme * GetAppearanceSet() const
Gets the currently applied custom appearance set.
CXTPTabManager::SetSelectedItem
virtual void SetSelectedItem(CXTPTabManagerItem *pItem)
Sets the currently selected tab item.
CXTPTabManager::SetColorSet
CXTPTabPaintManagerColorSet * SetColorSet(CXTPTabPaintManagerColorSet *pColorSet)
Applies a custom color set for the tabs.
CXTPTabManager::PerformToolHitTest
virtual INT_PTR PerformToolHitTest(HWND hWnd, CPoint point, TOOLINFO *pTI) const
Determines which tab is beneath the mouse cursor, if any, and stores the tooltip information of the t...
CXTPTabManager::m_nScrollDelta
int m_nScrollDelta
Scroll header delta.
Definition XTPTabManager.h:1399
CXTPTabManager::TrackClick
void TrackClick(HWND hWnd, CPoint pt, CXTPTabManagerItem *pItem)
Activates and tracks a specified tab item on mouse click.
CXTPTabManager::m_rcControl
CRect m_rcControl
Bounding rectangle of the tab manager control.
Definition XTPTabManager.h:1389
CXTPTabManager::OnItemsChanged
virtual void OnItemsChanged()
This method is called when tab items are changed (i.e.
CXTPTabManager::SetPosition
void SetPosition(XTPTabPosition tabPosition)
Sets the tab position.
CXTPTabManager::GetItemCaption
virtual CString GetItemCaption(const CXTPTabManagerItem *pItem) const
Retrieves the caption text of a specified tab item.
CXTPTabManager::ShowCloseItemButton
void ShowCloseItemButton(XTPTabNavigateButtonFlags bCloseItemButton=xtpTabNavigateButtonAlways)
Call this member to show close button for each tab.
Definition XTPTabManager.h:1515
CXTPTabManager::m_pPressed
CXTPTabManagerItem * m_pPressed
Pointer to the currently pressed tab.
Definition XTPTabManager.h:1374
CXTPTabManager::SetPaintManager
virtual void SetPaintManager(CXTPTabPaintManager *pPaintManager)
Sets the tab paint manager.
Definition XTPTabManager.h:1461
CXTPTabManagerItem
CXTPTabManagerItem is the base class for the tabs that appear in the command bars tab workspace,...
Definition XTPTabManagerItem.h:44
CXTPTabManagerItem::IsSelected
BOOL IsSelected() const
Determines the selected state of this tab (i.e.
CXTPTabManagerItem::m_pMarkupUIElement
CXTPMarkupUIElement * m_pMarkupUIElement
Markup element pointer.
Definition XTPTabManagerItem.h:507
CXTPTabManagerItem::m_pTabManager
CXTPTabManager * m_pTabManager
Pointer to the parent item.
Definition XTPTabManagerItem.h:501
CXTPTabManagerItem::IsFocused
BOOL IsFocused() const
Determines the focused state of this tab.
Definition XTPTabManager.h:1492
CXTPTabManagerItem::GetMarkupUIElement
CXTPMarkupUIElement * GetMarkupUIElement() const
Gets the Markup element used to render the caption of this tab.
Definition XTPTabManager.h:1496
CXTPTabManagerNavigateButton
CXTPTabManagerNavigateButton is a class used to represent a tab navigation button.
Definition XTPTabManagerNavigateButton.h:74
CXTPTabManagerNavigateButton::GetID
UINT GetID() const
Gets the identifier of the navigation button.
Definition XTPTabManagerNavigateButton.h:398
CXTPTabManagerNavigateButtons
CXTPTabManagerNavigateButtons is a class used to represent a collection of tab navigation buttons.
Definition XTPTabManagerNavigateButtons.h:39
CXTPTabManagerNavigateButtons::GetSize
int GetSize() const
Gets the number of tab navigation buttons in the collection.
Definition XTPTabManagerNavigateButtons.h:127
CXTPTabPaintManagerColorSet
CXTPTabPaintManagerColorSet represents the colors for all of the components of the tab manager (e....
Definition XTPTabPaintManagerColorSet.h:50
CXTPTabPaintManager
CXTPTabPaintManager is used to store the color and appearance information of the tabs in the tab mana...
Definition XTPTabPaintManager.h:48
CXTPTabPaintManagerTheme
CXTPTabPaintManagerTheme is a class that represents the appearance of all components of the tab manag...
Definition XTPTabPaintManagerTheme.h:56
CXTPTabManager::ROW_ITEMS
Helper structure that contains the first and last item indices of rows of the tab manager.
Definition XTPTabManager.h:102
CXTPTabManager::ROW_ITEMS::nFirstItem
int nFirstItem
First item index of row.
Definition XTPTabManager.h:103
CXTPTabManager::ROW_ITEMS::nLastItem
int nLastItem
Last item index of row.
Definition XTPTabManager.h:104


Toolkit Pro: XTPMarkupRoutedEventArgs.h Source File

  • Source
  • Markup
XTPMarkupRoutedEventArgs.h
Go to the documentation of this file.
1
23#if !defined(__XTPMARKUPROUTEDEVENTARGS_H__)
24# define __XTPMARKUPROUTEDEVENTARGS_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPMarkupRoutedEvent;
34class CXTPMarkupObject;
35
36class _XTP_EXT_CLASS CXTPMarkupRoutedEventArgs : public CXTPMarkupObject
37{
38public:
39 CXTPMarkupRoutedEventArgs();
40 CXTPMarkupRoutedEventArgs(CXTPMarkupRoutedEvent* pEvent, CXTPMarkupObject* pSource);
41
42public:
43 CXTPMarkupRoutedEvent* GetEvent() const;
44
45 BOOL IsHandled() const;
46 void SetHandled();
47
48 CXTPMarkupObject* GetSource() const;
49 void SetSource(CXTPMarkupObject* pSource);
50
51protected:
52 CXTPMarkupRoutedEvent* m_pEvent;
53 CXTPMarkupObject* m_pSource;
54 BOOL m_bHandled;
55
56 friend class CXTPMarkupInputElement;
57
58 DECLARE_DISPATCH_MAP()
59# ifdef _XTP_ACTIVEX
60 DECLARE_INTERFACE_MAP()
61 DECLARE_OLETYPELIB_EX(CXTPMarkupRoutedEventArgs);
62# endif
63
64 afx_msg BOOL OleGetHandled();
65 afx_msg void OleSetHandled(BOOL bHandled);
66 afx_msg LPDISPATCH OleGetEvent();
67 afx_msg LPDISPATCH OleGetSource();
68};
69
70AFX_INLINE CXTPMarkupRoutedEvent* CXTPMarkupRoutedEventArgs::GetEvent() const
71{
72 return m_pEvent;
73}
74
75AFX_INLINE BOOL CXTPMarkupRoutedEventArgs::IsHandled() const
76{
77 return m_bHandled;
78}
79
80AFX_INLINE void CXTPMarkupRoutedEventArgs::SetHandled()
81{
82 m_bHandled = TRUE;
83}
84
85AFX_INLINE CXTPMarkupObject* CXTPMarkupRoutedEventArgs::GetSource() const
86{
87 return m_pSource;
88}
89
90AFX_INLINE void CXTPMarkupRoutedEventArgs::SetSource(CXTPMarkupObject* pSource)
91{
92 m_pSource = pSource;
93}
94
95# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
97#endif // !defined(__XTPMARKUPROUTEDEVENTARGS_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h


Toolkit Pro: XTPMarkupSkewTransform.h Source File

  • Source
  • Markup
  • Transform
XTPMarkupSkewTransform.h
Go to the documentation of this file.
1
23#if !defined(__XTPMARKUPSKEWTRANSFORM_H__)
24# define __XTPMARKUPSKEWTRANSFORM_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPMarkupTransformationMatrix;
34class CXTPMarkupDependencyProperty;
35
40class _XTP_EXT_CLASS CXTPMarkupSkewTransform : public CXTPMarkupTransform
41{
43 DECLARE_MARKUPCLASS(CXTPMarkupSkewTransform);
45public:
52 double GetAngleX() const;
53
59 void SetAngleX(double angleX);
60
67 double GetAngleY() const;
68
74 void SetAngleY(double angleY);
75
82 double GetCenterX() const;
83
90 void SetCenterX(double centerX);
91
98 double GetCenterY() const;
99
105 void SetCenterY(double centerY);
106
114 virtual CXTPMarkupTransformationMatrix*
115 ApplyTransform(const CXTPMarkupTransformationMatrix* pMatrix);
116
117private:
118 DECLARE_DISPATCH_MAP();
119 afx_msg double OleGetAngleX();
120 afx_msg void OleSetAngleX(double angleX);
121 afx_msg double OleGetAngleY();
122 afx_msg void OleSetAngleY(double angleY);
123 afx_msg double OleGetCenterX();
124 afx_msg void OleSetCenterX(double centerX);
125 afx_msg double OleGetCenterY();
126 afx_msg void OleSetCenterY(double centerY);
127
128public:
129 static CXTPMarkupDependencyProperty* m_pPropertyAngleX;
130 static CXTPMarkupDependencyProperty* m_pPropertyAngleY;
131 static CXTPMarkupDependencyProperty* m_pPropertyCenterX;
132 static CXTPMarkupDependencyProperty* m_pPropertyCenterY;
133};
134
135# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
137#endif // !defined(__XTPMARKUPSKEWTRANSFORM_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPMarkupSkewTransform
Default SkewTransform implementation.
Definition XTPMarkupSkewTransform.h:41
CXTPMarkupSkewTransform::SetAngleY
void SetAngleY(double angleY)
Sets the angle Y value.
CXTPMarkupSkewTransform::m_pPropertyAngleX
static CXTPMarkupDependencyProperty * m_pPropertyAngleX
AngleX property.
Definition XTPMarkupSkewTransform.h:129
CXTPMarkupSkewTransform::SetAngleX
void SetAngleX(double angleX)
Sets the angle X value.
CXTPMarkupSkewTransform::SetCenterX
void SetCenterX(double centerX)
Sets the center X value.
CXTPMarkupSkewTransform::m_pPropertyCenterY
static CXTPMarkupDependencyProperty * m_pPropertyCenterY
CenterY property.
Definition XTPMarkupSkewTransform.h:132
CXTPMarkupSkewTransform::m_pPropertyCenterX
static CXTPMarkupDependencyProperty * m_pPropertyCenterX
CenterX property.
Definition XTPMarkupSkewTransform.h:131
CXTPMarkupSkewTransform::GetCenterX
double GetCenterX() const
Gets the center X value.
CXTPMarkupSkewTransform::GetAngleY
double GetAngleY() const
Gets the angle Y value.
CXTPMarkupSkewTransform::ApplyTransform
virtual CXTPMarkupTransformationMatrix * ApplyTransform(const CXTPMarkupTransformationMatrix *pMatrix)
Does nothing in default implementation.
CXTPMarkupSkewTransform::m_pPropertyAngleY
static CXTPMarkupDependencyProperty * m_pPropertyAngleY
AngleY property.
Definition XTPMarkupSkewTransform.h:130
CXTPMarkupSkewTransform::GetCenterY
double GetCenterY() const
Gets the center Y value.
CXTPMarkupSkewTransform::SetCenterY
void SetCenterY(double centerY)
Sets the center Y value.
CXTPMarkupSkewTransform::GetAngleX
double GetAngleX() const
Gets the angle X value.
CXTPMarkupTransform
Base class for all markup transformation objects.
Definition XTPMarkupTransform.h:43
CXTPMarkupTransformationMatrix
An abstract class for device context transformation matrix.
Definition XTPMarkupTransformationMatrix.h:40


Toolkit Pro: Member List

XTP_CALENDAR_HITTESTINFO_TIMELINE_VIEW Member List

This is the complete list of members for XTP_CALENDAR_HITTESTINFO_TIMELINE_VIEW, including all inherited members.

bTimePartValid | XTP_CALENDAR_HITTESTINFO |
dayPOS | XTP_CALENDAR_HITTESTINFO |
nDay | XTP_CALENDAR_HITTESTINFO |
nEvent | XTP_CALENDAR_HITTESTINFO |
nGroup | XTP_CALENDAR_HITTESTINFO |
operator!=(const XTP_CALENDAR_HITTESTINFO &hitInfo2) | XTP_CALENDAR_HITTESTINFO | inline
operator==(const XTP_CALENDAR_HITTESTINFO &hitInfo2) | XTP_CALENDAR_HITTESTINFO |
pViewDay | XTP_CALENDAR_HITTESTINFO |
pViewEvent | XTP_CALENDAR_HITTESTINFO |
pViewGroup | XTP_CALENDAR_HITTESTINFO |
uHitCode | XTP_CALENDAR_HITTESTINFO |
XTP_CALENDAR_HITTESTINFO() | XTP_CALENDAR_HITTESTINFO | inline
XTP_CALENDAR_HITTESTINFO_TIMELINE_VIEW() | XTP_CALENDAR_HITTESTINFO_TIMELINE_VIEW | inline
~XTP_CALENDAR_HITTESTINFO() | XTP_CALENDAR_HITTESTINFO | inlinevirtual


Toolkit Pro: Member List

  • CXTPRWCriticalSection
  • CSharedLock
CXTPRWCriticalSection::CSharedLock Member List

This is the complete list of members for CXTPRWCriticalSection::CSharedLock, including all inherited members.

CSharedLock(CXTPRWCriticalSection &cs) | CXTPRWCriticalSection::CSharedLock | inlineexplicit
~CSharedLock() | CXTPRWCriticalSection::CSharedLock | inline


Toolkit Pro: Member List

CXTPSyntaxEditInsertStringCommand Member List

This is the complete list of members for CXTPSyntaxEditInsertStringCommand, including all inherited members.

CXTPSyntaxEditBufferCommand(CXTPSyntaxEditBufferManager *pMgr, LPCTSTR szText, const XTP_EDIT_LINECOL &lcFrom, const XTP_EDIT_LINECOL &lcTo) | CXTPSyntaxEditBufferCommand | protected
CXTPSyntaxEditCommand() | CXTPSyntaxEditCommand | protected
CXTPSyntaxEditInsertStringCommand(CXTPSyntaxEditBufferManager *pMgr, LPCTSTR szText, const XTP_EDIT_LINECOL &lcFrom, const XTP_EDIT_LINECOL &lcTo) | CXTPSyntaxEditInsertStringCommand |
DoDeleteText(XTP_EDIT_LINECOL &lcFrom, XTP_EDIT_LINECOL &lcTo, CXTPSyntaxEditCtrl *pEditCtrl) | CXTPSyntaxEditBufferCommand | protected
DoInsertText(XTP_EDIT_LINECOL &lcFrom, XTP_EDIT_LINECOL &lcTo, CXTPSyntaxEditCtrl *pEditCtrl) | CXTPSyntaxEditBufferCommand | protected
Execute(XTP_EDIT_LINECOL &lcFrom, XTP_EDIT_LINECOL &lcTo, CXTPSyntaxEditCtrl *pEditCtrl) | CXTPSyntaxEditInsertStringCommand | virtual
GetCommandText() const | CXTPSyntaxEditCommand | virtual
GetDataSize() const | CXTPSyntaxEditBufferCommand | protectedvirtual
m_lcFrom | CXTPSyntaxEditBufferCommand | protected
m_lcTo | CXTPSyntaxEditBufferCommand | protected
m_pBufferMgr | CXTPSyntaxEditBufferCommand | protected
m_strCommandText | CXTPSyntaxEditCommand | protected
m_strText | CXTPSyntaxEditBufferCommand | protected
SetCommandText(LPCTSTR szText) | CXTPSyntaxEditCommand | virtual
SetPositionInternally(CXTPSyntaxEditCtrl *pEditCtrl, const XTP_EDIT_LINECOL &lcPos) | CXTPSyntaxEditCommand | protectedstatic
UnExecute(XTP_EDIT_LINECOL &lcFrom, XTP_EDIT_LINECOL &lcTo, CXTPSyntaxEditCtrl *pEditCtrl) | CXTPSyntaxEditInsertStringCommand | virtual
~CXTPSyntaxEditBufferCommand() | CXTPSyntaxEditBufferCommand | virtual
~CXTPSyntaxEditCommand() | CXTPSyntaxEditCommand | virtual
~CXTPSyntaxEditInsertStringCommand() | CXTPSyntaxEditInsertStringCommand | virtual


Toolkit Pro: XTPStatusBarPane.h Source File

  • Source
  • CommandBars
  • StatusBar
  • Panes
XTPStatusBarPane.h
Go to the documentation of this file.
1
23#if !defined(__XTPSTATUSBARPANE_H__)
24# define __XTPSTATUSBARPANE_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPStatusBarPane : public CXTPCmdTarget
39{
40private:
42 DECLARE_DYNAMIC(CXTPStatusBarPane)
44public:
49 CXTPStatusBarPane();
50
55 virtual ~CXTPStatusBarPane();
56
57public:
66 void SetText(LPCTSTR lpszText);
67
75 void SetCaption(LPCTSTR lpszCaption);
76
84 CString GetCaption() const;
85
96 void SetValue(LPCTSTR lpszValue);
97
105 CString GetValue() const;
106
115 CString GetText() const;
116
124 void SetWidth(int nWidth);
125
134 virtual int GetWidth();
135
142 void SetStyle(UINT nStyle);
143
150 UINT GetStyle() const;
151
158 UINT GetID() const;
159
166 int GetIndex() const;
167
172 void Remove();
173
182 BOOL IsVisible() const;
183
192 void SetVisible(BOOL bVisible, BOOL bRecalcLayout = TRUE);
193
200 void SetTextColor(COLORREF clrText);
201
208 void SetTextGrayColor(COLORREF clrText);
209
216 COLORREF GetTextColor() const;
217
224 COLORREF GetTextGrayColor() const;
225
232 void SetBackgroundColor(COLORREF clrBackground);
233
240 COLORREF GetBackgroundColor() const;
241
247 void SetTextFont(CFont* pFntText);
248
254 void SetTextFont(PLOGFONT pLogfText);
255
262 virtual CFont* GetTextFont();
263
272 int GetIconIndex() const;
273
281 void SetIconIndex(int nIconIndex);
282
288 void SetTextAlignment(int nAlign);
289
296 int GetTextAlignment() const;
297
307 void SetTooltip(LPCTSTR lpszTooltip);
308
318 CString GetTooltip() const;
319
324 void BestFit();
325
333 int GetBestFit();
334
340 void SetBeginGroup(BOOL bBeginGroup = TRUE);
341
349 BOOL GetBeginGroup() const;
350
357 CXTPStatusBar* GetStatusBar() const;
358
365 virtual CXTPImageManagerIcon* GetImage() const;
366
373 CRect GetMargins() const;
374
381 CRect GetPadding() const;
382
393 void SetMargins(int nLeft, int nTop, int nRight, int nBottom);
394
403 void SetPadding(int nLeft, int nTop, int nRight, int nBottom);
404
416 void SetButton(BOOL bButton = TRUE);
417
424 BOOL IsButton() const;
425
432 BOOL IsEnabled() const;
433
439 void SetEnabled(BOOL bEnabled);
440
449 BOOL IsHighlighted() const;
450
457 BOOL IsPressed() const;
458
473 void SetCustomizationVisible(BOOL bVisible);
474
481 BOOL GetCustomizationVisible() const;
482
490 BOOL IsChecked() const;
491
497 void SetChecked(BOOL bChecked);
498
511 BOOL HasBorders() const;
512
520 void ShowBorders(BOOL bShowBorders);
521
526 void Redraw() const;
527
534 CRect GetRect() const;
535
542 CXTPMarkupUIElement* GetMarkupUIElement() const;
543
550 void SetDark(BOOL bDark = TRUE);
551
558 BOOL IsDark() const;
559
560protected:
567 virtual void OnDraw(CDC* pDC, CRect rcItem);
568
576 virtual void OnLButtonDown(CPoint point);
577
583 virtual void OnMouseMove(CPoint point);
584
597 virtual INT_PTR OnToolHitTest(CPoint point, TOOLINFO* pTI) const;
598
599protected:
600 UINT m_nID;
601 int m_cxText;
603 UINT m_nStyle;
604 CString m_strText;
605 DWORD m_dwHideFlags;
606 COLORREF m_clrText;
607 COLORREF m_clrTextGray;
608 COLORREF m_clrBackground;
609 CString m_strToolTip;
611 CRect m_rcPane;
613 HWND m_hWndPane;
614 BOOL m_bAutoDeleteWnd;
615 int m_nAlignment;
617 CXTPStatusBar* m_pStatusBar;
618 int m_nIndex;
619 CXTPFont m_xtpFontText;
620 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CFont, m_fntText, m_xtpFontText, GetTextFontHandle);
621 int m_nIconIndex;
622 CRect m_rcPadding;
623 CRect m_rcMargins;
624 BOOL m_bButton;
625 BOOL m_bPressed;
626 CXTPMarkupUIElement* m_pMarkupUIElement;
627 BOOL m_bBeginGroup;
628 CString m_strCaption;
630 CString m_strValue;
632 int m_nBestFit;
633 BOOL m_bCustomizable;
634 BOOL m_bIsDark;
636# ifdef _XTP_COMMANDBARS_ACTIVEX
638 DECLARE_DISPATCH_MAP()
639 DECLARE_INTERFACE_MAP()
640 DECLARE_OLETYPELIB_EX(CXTPStatusBarPane);
641
642 afx_msg BSTR OleGetText();
643 afx_msg LPFONTDISP OleGetFont();
644 afx_msg void OleSetFont(LPFONTDISP pFontDisp);
645 afx_msg HWND OleGetHandle();
646 afx_msg void OleSetHandle(HWND hWnd);
647 afx_msg int OleGetHideFlags();
648 afx_msg void OleSetHideFlags(int dwHideFlags);
649 afx_msg void OleSetVisible(BOOL bVisible);
650 afx_msg void OleRedrawPane();
651 afx_msg void OleGetRect(long* pLeft, long* pTop, long* pRight, long* pBottom);
652 afx_msg BOOL OleGetDark();
653 afx_msg void OleSetDark(BOOL fDark);
654
656# endif
657 friend class CXTPStatusBar;
658};
659
661
662AFX_INLINE void CXTPStatusBarPane::SetCaption(LPCTSTR lpszCaption)
663{
664 m_strCaption = lpszCaption;
665}
666
667AFX_INLINE CString CXTPStatusBarPane::GetCaption() const
668{
669 return m_strCaption;
670}
671
672AFX_INLINE void CXTPStatusBarPane::SetValue(LPCTSTR lpszValue)
673{
674 m_strValue = lpszValue;
675}
676
677AFX_INLINE CString CXTPStatusBarPane::GetValue() const
678{
679 return m_strValue;
680}
681
682AFX_INLINE BOOL CXTPStatusBarPane::IsHighlighted() const
683{
684 return m_pStatusBar->m_pHighlightedPane == this;
685}
686
687AFX_INLINE BOOL CXTPStatusBarPane::IsPressed() const
688{
689 return m_bPressed;
690}
691
692AFX_INLINE void CXTPStatusBarPane::SetBeginGroup(BOOL bBeginGroup)
693{
694 m_bBeginGroup = bBeginGroup;
695}
696
697AFX_INLINE BOOL CXTPStatusBarPane::GetBeginGroup() const
698{
699 return m_bBeginGroup;
700}
701
702AFX_INLINE BOOL CXTPStatusBarPane::HasBorders() const
703{
704 return ((m_nStyle & SBPS_NOBORDERS) == 0);
705}
706
707AFX_INLINE void CXTPStatusBarPane::ShowBorders(BOOL bShowBorders)
708{
709 SetStyle(bShowBorders ? m_nStyle & ~SBPS_NOBORDERS : m_nStyle | SBPS_NOBORDERS);
710}
711
712AFX_INLINE CXTPMarkupUIElement* CXTPStatusBarPane::GetMarkupUIElement() const
713{
714 return m_pMarkupUIElement;
715}
716
717AFX_INLINE void CXTPStatusBarPane::SetDark(BOOL bDark /*= TRUE*/)
718{
719 m_bIsDark = bDark;
720}
721
722AFX_INLINE BOOL CXTPStatusBarPane::IsDark() const
723{
724 return m_bIsDark;
725}
726
728# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
729#endif // !defined(__XTPSTATUSBARPANE_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPFont
Provides a convenient object oriented interface for HFONT GDI object and uses GDI handle caching.
Definition XTPGdiObjects.h:414
CXTPImageManagerIcon
Icons holder class.
Definition XTPImageManager.h:622
CXTPMarkupUIElement
Base class for XML Markup core level implementations.
Definition XTPMarkupUIElement.h:43
CXTPStatusBar
CXTPStatusBar is a CControlBar derived class.
Definition XTPStatusBar.h:52
CXTPStatusBar::m_pHighlightedPane
CXTPStatusBarPane * m_pHighlightedPane
Pane currently highlighted.
Definition XTPStatusBar.h:710
CXTPStatusBarPane
CXTPStatusBarPane is a CXTPCmdTarget derived class.
Definition XTPStatusBarPane.h:39
CXTPStatusBarPane::GetID
UINT GetID() const
Call this member function to get the ID of a status bar's pane.
CXTPStatusBarPane::SetText
void SetText(LPCTSTR lpszText)
Call this member to set the text caption that is displayed in this pane.
CXTPStatusBarPane::SetVisible
void SetVisible(BOOL bVisible, BOOL bRecalcLayout=TRUE)
Call this member to set the visibility of the pane.
CXTPStatusBarPane::IsVisible
BOOL IsVisible() const
Call this member to determine if the pane is visible.
CXTPStatusBarPane::GetValue
CString GetValue() const
Gets the value of the pane.
Definition XTPStatusBarPane.h:677
CXTPStatusBarPane::ShowBorders
void ShowBorders(BOOL bShowBorders)
Call this member function to show the pane borders.
Definition XTPStatusBarPane.h:707
CXTPStatusBarPane::m_strText
CString m_strText
Text in the pane.
Definition XTPStatusBarPane.h:604
CXTPStatusBarPane::Remove
void Remove()
Call this member function to remove the pane.
CXTPStatusBarPane::m_nID
UINT m_nID
IDC of indicator: 0 => normal text area.
Definition XTPStatusBarPane.h:600
CXTPStatusBarPane::SetPadding
void SetPadding(int nLeft, int nTop, int nRight, int nBottom)
Sets the padding placed around the text of a pane in pixels.
CXTPStatusBarPane::m_strToolTip
CString m_strToolTip
Tooltip text for the item.
Definition XTPStatusBarPane.h:609
CXTPStatusBarPane::m_rcPane
CRect m_rcPane
Bounding rectangle for the pane.
Definition XTPStatusBarPane.h:611
CXTPStatusBarPane::Redraw
void Redraw() const
Call this member function to redraw the pane.
CXTPStatusBarPane::m_clrTextGray
COLORREF m_clrTextGray
Disabled text color.
Definition XTPStatusBarPane.h:607
CXTPStatusBarPane::IsPressed
BOOL IsPressed() const
Call this method to determine if the pane button is pressed.
Definition XTPStatusBarPane.h:687
CXTPStatusBarPane::SetIconIndex
void SetIconIndex(int nIconIndex)
Call this method to set the icon index of an item.
CXTPStatusBarPane::m_rcMargins
CRect m_rcMargins
Margins of the pane.
Definition XTPStatusBarPane.h:623
CXTPStatusBarPane::GetTextAlignment
int GetTextAlignment() const
Call this member function to get the alignment of an item text.
CXTPStatusBarPane::BestFit
void BestFit()
Fits the width of the pane to its text width.
CXTPStatusBarPane::m_hWndPane
HWND m_hWndPane
Child handle.
Definition XTPStatusBarPane.h:613
CXTPStatusBarPane::HasBorders
BOOL HasBorders() const
Call this member function to determine if the pane has borders enabled.
Definition XTPStatusBarPane.h:702
CXTPStatusBarPane::m_pStatusBar
CXTPStatusBar * m_pStatusBar
Parent StatusBar object.
Definition XTPStatusBarPane.h:617
CXTPStatusBarPane::SetBeginGroup
void SetBeginGroup(BOOL bBeginGroup=TRUE)
Call this method to add a separator before the pane.
Definition XTPStatusBarPane.h:692
CXTPStatusBarPane::SetDark
void SetDark(BOOL bDark=TRUE)
Some themes may display status bar panes as dark.
Definition XTPStatusBarPane.h:717
CXTPStatusBarPane::SetTextAlignment
void SetTextAlignment(int nAlign)
Call this member function to set the alignment of an item text.
CXTPStatusBarPane::SetChecked
void SetChecked(BOOL bChecked)
Call this member to set the checked state of a pane.
CXTPStatusBarPane::GetWidth
virtual int GetWidth()
Call this member to get the width of the pane.
CXTPStatusBarPane::OnToolHitTest
virtual INT_PTR OnToolHitTest(CPoint point, TOOLINFO *pTI) const
The framework calls this member function to determine whether a point is in the bounding rectangle of...
CXTPStatusBarPane::m_cxText
int m_cxText
Width of the string area in pixels.
Definition XTPStatusBarPane.h:601
CXTPStatusBarPane::GetPadding
CRect GetPadding() const
Gets the padding placed around the Text of a pane.
CXTPStatusBarPane::GetTextFont
virtual CFont * GetTextFont()
Call this member function to set the font of an item text.
CXTPStatusBarPane::m_nIndex
int m_nIndex
Index of the item.
Definition XTPStatusBarPane.h:618
CXTPStatusBarPane::m_nAlignment
int m_nAlignment
Alignment of the item.
Definition XTPStatusBarPane.h:615
CXTPStatusBarPane::GetTextColor
COLORREF GetTextColor() const
Call this member function to get the color of an item text.
CXTPStatusBarPane::GetRect
CRect GetRect() const
Call this member to get the bounding rectangle for the pane.
CXTPStatusBarPane::m_nStyle
UINT m_nStyle
Style flags (SBPS_*).
Definition XTPStatusBarPane.h:603
CXTPStatusBarPane::SetCaption
void SetCaption(LPCTSTR lpszCaption)
Sets the text that is displayed for the pane in the status bar customization window.
Definition XTPStatusBarPane.h:662
CXTPStatusBarPane::OnDraw
virtual void OnDraw(CDC *pDC, CRect rcItem)
This method is called to draw a pane item.
CXTPStatusBarPane::SetMargins
void SetMargins(int nLeft, int nTop, int nRight, int nBottom)
Call this method to set margins for the pane.
CXTPStatusBarPane::GetIconIndex
int GetIconIndex() const
Retrieves icon index.
CXTPStatusBarPane::m_nBestFit
int m_nBestFit
Width for the pane to have the best fit.
Definition XTPStatusBarPane.h:632
CXTPStatusBarPane::~CXTPStatusBarPane
virtual ~CXTPStatusBarPane()
Destroys a CXTPStatusBarPane object, handles cleanup and deallocation.
CXTPStatusBarPane::SetEnabled
void SetEnabled(BOOL bEnabled)
Specifies whether the switch pane is enabled or disabled.
CXTPStatusBarPane::IsDark
BOOL IsDark() const
Determines if a pane is to be drawn as dark in some themes.
Definition XTPStatusBarPane.h:722
CXTPStatusBarPane::m_pMarkupUIElement
CXTPMarkupUIElement * m_pMarkupUIElement
Markup Context.
Definition XTPStatusBarPane.h:626
CXTPStatusBarPane::SetBackgroundColor
void SetBackgroundColor(COLORREF clrBackground)
Call this member function to set the color of an item background.
CXTPStatusBarPane::SetButton
void SetButton(BOOL bButton=TRUE)
Specifies whether the pane will also act as a button.
CXTPStatusBarPane::GetStatusBar
CXTPStatusBar * GetStatusBar() const
Call this member function to get the parent status bar object.
CXTPStatusBarPane::GetCaption
CString GetCaption() const
Gets the text that is displayed for the pane in the status bar customization window.
Definition XTPStatusBarPane.h:667
CXTPStatusBarPane::m_bBeginGroup
BOOL m_bBeginGroup
TRUE if the pane begins a group.
Definition XTPStatusBarPane.h:627
CXTPStatusBarPane::SetTextFont
void SetTextFont(CFont *pFntText)
Call this member function to set the font of an item text.
CXTPStatusBarPane::IsButton
BOOL IsButton() const
Specifies whether the pane will also act as a button.
CXTPStatusBarPane::GetTextGrayColor
COLORREF GetTextGrayColor() const
Call this member function to get the disabled color of an item text.
CXTPStatusBarPane::m_strValue
CString m_strValue
The value of the pane.
Definition XTPStatusBarPane.h:630
CXTPStatusBarPane::SetTextColor
void SetTextColor(COLORREF clrText)
Call this member function to set the color of an item text.
CXTPStatusBarPane::GetCustomizationVisible
BOOL GetCustomizationVisible() const
Gets whether customization is enabled.
CXTPStatusBarPane::m_clrBackground
COLORREF m_clrBackground
Background color.
Definition XTPStatusBarPane.h:608
CXTPStatusBarPane::SetValue
void SetValue(LPCTSTR lpszValue)
Sets the value of the pane.
Definition XTPStatusBarPane.h:672
CXTPStatusBarPane::GetStyle
UINT GetStyle() const
Call this member function to get the style of a status bar's pane.
CXTPStatusBarPane::SetTextGrayColor
void SetTextGrayColor(COLORREF clrText)
Call this member function to set the disabled color of an item text.
CXTPStatusBarPane::m_bAutoDeleteWnd
BOOL m_bAutoDeleteWnd
TRUE to auto delete child.
Definition XTPStatusBarPane.h:614
CXTPStatusBarPane::SetTooltip
void SetTooltip(LPCTSTR lpszTooltip)
Call this member to set the tooltip for this pane.
CXTPStatusBarPane::GetText
CString GetText() const
Call this member to get the text caption of the pane.
CXTPStatusBarPane::SetCustomizationVisible
void SetCustomizationVisible(BOOL bVisible)
Enables or disables status bar customization.
CXTPStatusBarPane::SetStyle
void SetStyle(UINT nStyle)
Call this member function to set the style of a status bar's pane.
CXTPStatusBarPane::IsHighlighted
BOOL IsHighlighted() const
This member is called to determine if the pane button is currently highlighted.
Definition XTPStatusBarPane.h:682
CXTPStatusBarPane::m_nIconIndex
int m_nIconIndex
Icon index of the pane.
Definition XTPStatusBarPane.h:621
CXTPStatusBarPane::GetBeginGroup
BOOL GetBeginGroup() const
Gets a boolean value indicating whether the pane has a separator placed before it and thus begins a n...
Definition XTPStatusBarPane.h:697
CXTPStatusBarPane::OnMouseMove
virtual void OnMouseMove(CPoint point)
This member is called when the mouse cursor moves.
CXTPStatusBarPane::GetBestFit
int GetBestFit()
Gets the best fit width which fits the width of the pane to the its text width.
CXTPStatusBarPane::GetMargins
CRect GetMargins() const
CXTPStatusBarPane::SetTextFont
void SetTextFont(PLOGFONT pLogfText)
Call this member function to set the font of an item text.
CXTPStatusBarPane::OnLButtonDown
virtual void OnLButtonDown(CPoint point)
This member function is used to process left mouse button events.
CXTPStatusBarPane::GetBackgroundColor
COLORREF GetBackgroundColor() const
Call this member to get the background color of an item.
CXTPStatusBarPane::m_bButton
BOOL m_bButton
TRUE if pane is clickable button.
Definition XTPStatusBarPane.h:624
CXTPStatusBarPane::m_clrText
COLORREF m_clrText
Text color.
Definition XTPStatusBarPane.h:606
CXTPStatusBarPane::m_bPressed
BOOL m_bPressed
TRUE if button was pressed.
Definition XTPStatusBarPane.h:625
CXTPStatusBarPane::SetWidth
void SetWidth(int nWidth)
Call this member to set the width of this pane.
CXTPStatusBarPane::IsChecked
BOOL IsChecked() const
Call this member function to determine if the pane button state is checked.
CXTPStatusBarPane::GetImage
virtual CXTPImageManagerIcon * GetImage() const
This method is called to get an image of the pane.
CXTPStatusBarPane::GetIndex
int GetIndex() const
Call this member function to get the index of a status bar's pane.
CXTPStatusBarPane::m_bCustomizable
BOOL m_bCustomizable
True to enable customization, False to disable customization.
Definition XTPStatusBarPane.h:633
CXTPStatusBarPane::m_rcPadding
CRect m_rcPadding
Margins of the pane.
Definition XTPStatusBarPane.h:622
CXTPStatusBarPane::CXTPStatusBarPane
CXTPStatusBarPane()
Constructs a CXTPStatusBarPane object.
CXTPStatusBarPane::m_dwHideFlags
DWORD m_dwHideFlags
TRUE if pane is visible.
Definition XTPStatusBarPane.h:605
CXTPStatusBarPane::m_bIsDark
BOOL m_bIsDark
True if a pane should be dark in some themes.
Definition XTPStatusBarPane.h:634
CXTPStatusBarPane::GetTooltip
CString GetTooltip() const
Call this member to get the tooltip displayed when the mouse pointer is positioned over the pane.
CXTPStatusBarPane::IsEnabled
BOOL IsEnabled() const
Gets a boolean value indicating whether the switch pane is enabled.
CXTPStatusBarPane::GetMarkupUIElement
CXTPMarkupUIElement * GetMarkupUIElement() const
This member function is used to get the stored CXTPMarkupUIElement object.
Definition XTPStatusBarPane.h:712
CXTPStatusBarPane::m_xtpFontText
CXTPFont m_xtpFontText
Font of an item text.
Definition XTPStatusBarPane.h:619
CXTPStatusBarPane::m_strCaption
CString m_strCaption
The text that is displayed for the pane in the status bar customization window.
Definition XTPStatusBarPane.h:628


Toolkit Pro: XTPCommandBarsVisualStudio2017Theme.h Source File

  • Source
  • CommandBars
  • Themes
XTPCommandBarsVisualStudio2017Theme.h
Go to the documentation of this file.
1
23#if !defined(__XTPCOMMANDBARSVISUALSTUDIO2017THEME_H__)
24# define __XTPCOMMANDBARSVISUALSTUDIO2017THEME_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
40class _XTP_EXT_CLASS CXTPCommandBarsVisualStudio2017Theme : public CXTPCommandBarsOffice2013Theme
41{
43 DECLARE_DYNAMIC(CXTPCommandBarsVisualStudio2017Theme)
45public:
50 CXTPCommandBarsVisualStudio2017Theme();
51
57 virtual ~CXTPCommandBarsVisualStudio2017Theme();
58
66 virtual void SetStateColor(COLORREF clrState = COLORREF_NULL);
67
75 virtual COLORREF GetStateColor() const;
76
77protected:
86 virtual void DrawSplitButtonFrame(CDC* pDC, CXTPControl* pButton, CRect rc);
87
101 virtual void DrawRectangle(CDC* pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled,
102 BOOL bChecked, BOOL bPopuped, XTPBarType barType,
103 XTPBarPosition barPosition);
104
119 virtual void DrawRectangle(CDC* pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled,
120 BOOL bChecked, BOOL bPopuped, XTPBarType barType,
121 XTPBarPosition barPosition, int nID);
122
131 virtual BOOL DrawRectangle(CDC* pDC, CXTPControl* pButton);
132
139 virtual COLORREF GetControlTextColor(CXTPControl* pButton);
140
152 virtual void DrawGalleryItemBack(CDC* pDC, CRect rcItem, BOOL bEnabled, BOOL bSelected,
153 BOOL bPressed, BOOL bChecked, XTPBarType barType);
154
164 virtual void DrawCheckRect(CDC* pDC, CRect rc, COLORREF clrFore, COLORREF clrBack);
165
175 virtual CSize DrawCommandBarGripper(CDC* pDC, CXTPCommandBar* pBar, BOOL bDraw = TRUE);
176
186 virtual CSize DrawControlComboBox(CDC* pDC, CXTPControlComboBox* pComboBox, BOOL bDraw);
187};
188
206_XTP_EXT_CLASS BOOL AFX_CDECL XTPSetVS2017StateColor(CXTPCommandBars* pCommandBars,
207 COLORREF clrState = COLORREF_NULL);
208
210# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
211#endif // !defined(__XTPCOMMANDBARSVISUALSTUDIO2017THEME_H__)
XTPBarType
XTPBarType
Type of the command bar.
Definition XTPCommandBarsDefines.h:77
XTPBarPosition
XTPBarPosition
Position of the command bar.
Definition XTPCommandBarsDefines.h:52
XTPSetVS2017StateColor
_XTP_EXT_CLASS BOOL AFX_CDECL XTPSetVS2017StateColor(CXTPCommandBars *pCommandBars, COLORREF clrState=COLORREF_NULL)
Call XTPSetVS2017StateColor to set the border and status bar colors for this theme to indicate state ...
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCommandBar
CXTPCommandBar is a CWnd derived class.
Definition XTPCommandBar.h:66
CXTPCommandBars
CXTPCommandBars is a standalone class.
Definition XTPCommandBars.h:165
CXTPCommandBarsOffice2013Theme
The CXTPCommandBarsOffice2013Theme class is used to enable an Office 2013 style theme for Command Bar...
Definition XTPCommandBarsOffice2013Theme.h:63
CXTPCommandBarsVisualStudio2017Theme
The CXTPCommandBarsVisualStudio2017Theme class is used to enable a Visual Studio 2017 style theme for...
Definition XTPCommandBarsVisualStudio2017Theme.h:41
CXTPCommandBarsVisualStudio2017Theme::DrawCheckRect
virtual void DrawCheckRect(CDC *pDC, CRect rc, COLORREF clrFore, COLORREF clrBack)
Helper class called by DrawRectangle to render a checkmark background and border.
CXTPCommandBarsVisualStudio2017Theme::DrawCommandBarGripper
virtual CSize DrawCommandBarGripper(CDC *pDC, CXTPCommandBar *pBar, BOOL bDraw=TRUE)
This method is called to draw the command bar's gripper.
CXTPCommandBarsVisualStudio2017Theme::DrawControlComboBox
virtual CSize DrawControlComboBox(CDC *pDC, CXTPControlComboBox *pComboBox, BOOL bDraw)
This method is called to draw the control.
CXTPCommandBarsVisualStudio2017Theme::DrawSplitButtonFrame
virtual void DrawSplitButtonFrame(CDC *pDC, CXTPControl *pButton, CRect rc)
This method is called to draw the frame for the SplitButton control.
CXTPCommandBarsVisualStudio2017Theme::DrawGalleryItemBack
virtual void DrawGalleryItemBack(CDC *pDC, CRect rcItem, BOOL bEnabled, BOOL bSelected, BOOL bPressed, BOOL bChecked, XTPBarType barType)
This method is called to draw the background for a gallery menu item.
CXTPCommandBarsVisualStudio2017Theme::SetStateColor
virtual void SetStateColor(COLORREF clrState=COLORREF_NULL)
Call this member function to set the application state color for the frame border and status bar.
CXTPCommandBarsVisualStudio2017Theme::DrawRectangle
virtual BOOL DrawRectangle(CDC *pDC, CXTPControl *pButton)
This method is called to fill the control's face.
CXTPCommandBarsVisualStudio2017Theme::CXTPCommandBarsVisualStudio2017Theme
CXTPCommandBarsVisualStudio2017Theme()
Constructs a CXTPCommandBarsVisualStudio2017Theme object.
CXTPCommandBarsVisualStudio2017Theme::GetControlTextColor
virtual COLORREF GetControlTextColor(CXTPControl *pButton)
This method returns the control text color to draw.
CXTPCommandBarsVisualStudio2017Theme::GetStateColor
virtual COLORREF GetStateColor() const
Call this member function to get the application state color for the frame border and status bar.
CXTPCommandBarsVisualStudio2017Theme::DrawRectangle
virtual void DrawRectangle(CDC *pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition)
This method is called to fill the control's face.
CXTPCommandBarsVisualStudio2017Theme::DrawRectangle
virtual void DrawRectangle(CDC *pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition, int nID)
This method is called to fill the control's face.
CXTPCommandBarsVisualStudio2017Theme::~CXTPCommandBarsVisualStudio2017Theme
virtual ~CXTPCommandBarsVisualStudio2017Theme()
Destroys a CXTPCommandBarsVisualStudio2017Theme object, handles cleanup and deallocation.
CXTPControlComboBox
CXTPControlComboBox is a CXTPControl derived class.
Definition XTPControlComboBox.h:381
CXTPControl
CXTPControl is a CXTPCmdTarget derived class.
Definition XTPControl.h:841


Toolkit Pro: XTPControlCustom.h Source File

  • Source
  • CommandBars
XTPControlCustom.h
Go to the documentation of this file.
1
23#if !defined(__XTPCONTROLCUSTOM_H__)
24# define __XTPCONTROLCUSTOM_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPCommandBars;
34
48enum XTPControlCustomVerticalOptions
49{
50 xtpVerticalHide,
51 xtpVerticalShow,
52 xtpVerticalButton
53};
54
60class _XTP_EXT_CLASS CXTPControlCustom
61 : public CXTPControlButton
62 , public CXTPHookManagerHookAble
63{
64public:
69 CXTPControlCustom();
70
75 ~CXTPControlCustom();
76
77public:
86 static CXTPControlCustom* AFX_CDECL CreateControlCustom(CWnd* pWndChild);
87
88public:
94 void SetControl(CWnd* pWnd);
95
102 CWnd* GetControl();
103
109 void SetSize(CSize szControl);
110
119 void SetBorders(int cxRight, int cxTop, int cxLeft, int cxBottom);
120
135 void SetVerticalPositionOption(XTPControlCustomVerticalOptions options);
136
141 virtual void OnEnabledChanged();
142
143protected:
149 virtual void SetRect(CRect rcControl);
150
158 virtual CSize GetSize(CDC* pDC);
159
165 virtual void Draw(CDC* pDC);
166
174 virtual void SetHideFlags(DWORD dwFlags);
175
183 virtual void OnActionChanged(int nProperty);
184
235 virtual void OnCalcDynamicSize(DWORD dwMode);
236
242 virtual void DoPropExchange(CXTPPropExchange* pPX);
243
250 virtual void Copy(CXTPControl* pControl, BOOL bRecursive = FALSE);
251
258 virtual void OnClick(BOOL bKeyboard = FALSE, CPoint pt = CPoint(0, 0));
259
269 virtual BOOL DoCustomDragOver(CXTPCommandBar* pCommandBar, CPoint point,
270 DROPEFFECT& dropEffect);
271
284 int OnHookMessage(HWND hWnd, UINT nMessage, WPARAM& wParam, LPARAM& lParam, LRESULT& lResult);
285
291 virtual void OnRemoved();
292
293private:
294 CWnd* FindChildWindow(CXTPCommandBars* pCommandBars, UINT nID);
295 void ShowHideChildControl();
296
297protected:
298 HWND m_hwndControl;
299 CRect m_rcBorders;
300 BOOL m_bControlVisible;
301 CSize m_szControl;
302 XTPControlCustomVerticalOptions m_verticalOptions;
303 int m_nControlID;
305public:
306# ifdef _XTP_COMMANDBARS_ACTIVEX
309 DECLARE_DISPATCH_MAP()
310 DECLARE_INTERFACE_MAP()
311
312 afx_msg long OleGetHandle();
313 afx_msg void OleSetHandle(long nHandle);
314
315 enum
316 {
317 dispidHandle = 50L,
318 };
319 DECLARE_OLETYPELIB_EX(CXTPControlCustom);
320
321 void OleSetSize(int, int);
322
324# endif
325 DECLARE_XTP_CONTROL(CXTPControlCustom)
326};
328# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
329#endif // #if !defined(__XTPCONTROLCUSTOM_H__)
DECLARE_XTP_CONTROL
#define DECLARE_XTP_CONTROL(class_name)
This macro generates the C++ header code necessary for a CXTPControl-derived class that can be serial...
Definition XTPCommandBarsDefines.h:1169
XTPControlCustomVerticalOptions
XTPControlCustomVerticalOptions
Vertical options enumerator.
Definition XTPControlCustom.h:49
xtpVerticalShow
@ xtpVerticalShow
To show control if parent toolbar vertically docked.
Definition XTPControlCustom.h:51
xtpVerticalHide
@ xtpVerticalHide
To hide control if parent toolbar vertically docked.
Definition XTPControlCustom.h:50
xtpVerticalButton
@ xtpVerticalButton
To show control as button.
Definition XTPControlCustom.h:52
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCommandBar
CXTPCommandBar is a CWnd derived class.
Definition XTPCommandBar.h:66
CXTPCommandBars
CXTPCommandBars is a standalone class.
Definition XTPCommandBars.h:165
CXTPControlButton
CXTPControlButton is a CXTPControl derived class.
Definition XTPControlButton.h:39
CXTPControlCustom
CXTPControlCustom is a CXTPControlButton derived class.
Definition XTPControlCustom.h:63
CXTPControlCustom::DoPropExchange
virtual void DoPropExchange(CXTPPropExchange *pPX)
Either eads this object from or writes this object to an archive.
CXTPControlCustom::OnActionChanged
virtual void OnActionChanged(int nProperty)
This method is called when the action property is changed.
CXTPControlCustom::OnRemoved
virtual void OnRemoved()
This method is called when a control is removed from the parent controls collection.
CXTPControlCustom::CXTPControlCustom
CXTPControlCustom()
Constructs a CXTPControlCustom object.
CXTPControlCustom::m_bControlVisible
BOOL m_bControlVisible
TRUE if child window is visible.
Definition XTPControlCustom.h:300
CXTPControlCustom::SetSize
void SetSize(CSize szControl)
This method sets the child window size.
CXTPControlCustom::OnClick
virtual void OnClick(BOOL bKeyboard=FALSE, CPoint pt=CPoint(0, 0))
This method is called when the user clicks the control.
CXTPControlCustom::OnCalcDynamicSize
virtual void OnCalcDynamicSize(DWORD dwMode)
This method is called before recalculating the parent command bar size to calculate the dimensions of...
CXTPControlCustom::m_hwndControl
HWND m_hwndControl
The child window.
Definition XTPControlCustom.h:298
CXTPControlCustom::OnHookMessage
int OnHookMessage(HWND hWnd, UINT nMessage, WPARAM &wParam, LPARAM &lParam, LRESULT &lResult)
This member function is called by WindowProc, or is called during message reflection.
CXTPControlCustom::DoCustomDragOver
virtual BOOL DoCustomDragOver(CXTPCommandBar *pCommandBar, CPoint point, DROPEFFECT &dropEffect)
The implementation may implement a custom drag over handling logic in this method.
CXTPControlCustom::m_verticalOptions
XTPControlCustomVerticalOptions m_verticalOptions
Vertical options.
Definition XTPControlCustom.h:302
CXTPControlCustom::SetBorders
void SetBorders(int cxRight, int cxTop, int cxLeft, int cxBottom)
This method sets the margins of the child window.
CXTPControlCustom::SetVerticalPositionOption
void SetVerticalPositionOption(XTPControlCustomVerticalOptions options)
Call this method to set vertical options to the control.
CXTPControlCustom::Draw
virtual void Draw(CDC *pDC)
This method is called to draw the control.
CXTPControlCustom::GetControl
CWnd * GetControl()
Call this method to retrieve the child window of the control.
CXTPControlCustom::SetRect
virtual void SetRect(CRect rcControl)
Call this member to set the bounding rectangle of the control.
CXTPControlCustom::SetHideFlags
virtual void SetHideFlags(DWORD dwFlags)
This method is called to hide the control.
CXTPControlCustom::m_nControlID
int m_nControlID
ID of the custom control.
Definition XTPControlCustom.h:303
CXTPControlCustom::SetControl
void SetControl(CWnd *pWnd)
Call this method to attach the window to the control.
CXTPControlCustom::CreateControlCustom
static CXTPControlCustom *AFX_CDECL CreateControlCustom(CWnd *pWndChild)
Call this method to create a new CXTPControlCustom object with pWndChild as a child window.
CXTPControlCustom::GetSize
virtual CSize GetSize(CDC *pDC)
This method is called to determine the size of the control.
CXTPControlCustom::m_rcBorders
CRect m_rcBorders
Borders.
Definition XTPControlCustom.h:299
CXTPControlCustom::OnEnabledChanged
virtual void OnEnabledChanged()
This method is called when the control's enabled state is changed.
CXTPControlCustom::~CXTPControlCustom
~CXTPControlCustom()
Destroys a CXTPControlCustom object, handles cleanup and deallocation.
CXTPControlCustom::Copy
virtual void Copy(CXTPControl *pControl, BOOL bRecursive=FALSE)
This method is called to copy the control.
CXTPControlCustom::m_szControl
CSize m_szControl
Size of the control.
Definition XTPControlCustom.h:301
CXTPControl
CXTPControl is a CXTPCmdTarget derived class.
Definition XTPControl.h:841
CXTPHookManagerHookAble
HookAble interface.
Definition XTPHookManager.h:42
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72


Toolkit Pro: Member List

CXTPChartMarkupElementDeviceCommand Member List

This is the complete list of members for CXTPChartMarkupElementDeviceCommand, including all inherited members.

AddChildCommand(CXTPChartDeviceCommand *pCommand) | CXTPChartDeviceCommand |
AfterExecute(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
ApplySeriesStyle(CXTPChartSeriesStyle *pStyle) | CXTPChartDeviceCommand | virtual
BeforeExecute(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
BindView(CXTPChartElementView *pView) | CXTPChartDeviceCommand |
Commit() | CXTPChartDeviceCommand |
CXTPChartDeviceCommand() | CXTPChartDeviceCommand |
CXTPChartMarkupElementDeviceCommand(CXTPMarkupUIElement *pMarkupUIElement, CXTPChartFont *pFont, const CXTPChartColor &color, const CXTPChartRectF &rectangle) | CXTPChartMarkupElementDeviceCommand |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPObservable() | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | protected
Execute(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
ExecuteOverride(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
GetBoundView() const | CXTPChartDeviceCommand |
GetChildCommand(int nIndex) const | CXTPChartDeviceCommand |
GetChildCommandCount() const | CXTPChartDeviceCommand |
GetCurrentDC() const | CXTPChartDeviceCommand |
GetPassNumber() const | CXTPChartDeviceCommand |
HitTest(CPoint point, CXTPChartElement *pParent) const | CXTPChartMarkupElementDeviceCommand | virtual
Is3D() const | CXTPChartObject |
IsCommitted() const | CXTPChartDeviceCommand |
IsEnabled() const | CXTPChartDeviceCommand | virtual
m_arrChildren | CXTPChartDeviceCommand | protected
m_color | CXTPChartMarkupElementDeviceCommand | protected
m_pFont | CXTPChartMarkupElementDeviceCommand | protected
m_pMarkupUIElement | CXTPChartMarkupElementDeviceCommand | protected
m_rect | CXTPChartMarkupElementDeviceCommand | protected
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Prepare(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
PrepareOverride(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
SetEnabled(BOOL bEnabled=TRUE) | CXTPChartDeviceCommand |
Subscribe(CXTPChartDeviceCommandEvents *pObserver, CXTPSubscriptionList< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > *pSubcriptionList=NULL) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > |
Unsubscribe(CXTPChartDeviceCommandEvents *pObserver) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > |
~CXTPChartDeviceCommand() | CXTPChartDeviceCommand | virtual
~CXTPChartMarkupElementDeviceCommand() | CXTPChartMarkupElementDeviceCommand |
~CXTPObservable() | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | protected


Toolkit Pro: XTPEditThemeVisualStudio2022.h Source File

  • Source
  • Controls
  • Edit
  • Themes
XTPEditThemeVisualStudio2022.h
Go to the documentation of this file.
1
23#if !defined(__XTPEDITTHEMEVISUALSTUDIO2022_H__)
24# define __XTPEDITTHEMEVISUALSTUDIO2022_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
37class _XTP_EXT_CLASS CXTPEditThemeVisualStudio2022 : public CXTPEditThemeOffice2013
38{
39public:
44 CXTPEditThemeVisualStudio2022();
45
50 virtual ~CXTPEditThemeVisualStudio2022();
51};
52
53# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
55#endif // __XTPEDITTHEMEVISUALSTUDIO2022_H__
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPEditThemeOffice2013
CXTPEditThemeOffice2013 is a class used to perform theme drawing tasks.
Definition XTPEditThemeOffice2013.h:38
CXTPEditThemeVisualStudio2022
CXTPEditThemeVisualStudio2022 is a class used to perform theme drawing tasks.
Definition XTPEditThemeVisualStudio2022.h:38
CXTPEditThemeVisualStudio2022::~CXTPEditThemeVisualStudio2022
virtual ~CXTPEditThemeVisualStudio2022()
Destructor, handles cleanup and deallocation.
CXTPEditThemeVisualStudio2022::CXTPEditThemeVisualStudio2022
CXTPEditThemeVisualStudio2022()
Constructs a CXTPEditThemeVisualStudio2022 object.


Toolkit Pro: XTPChart2dPieSeriesPointView.h Source File

  • Source
  • Chart
  • Styles
  • Pie
  • 2D
XTPChart2dPieSeriesPointView.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHART2DPIESERIESPOINTVIEW_H__)
24# define __XTPCHART2DPIESERIESPOINTVIEW_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
44class _XTP_EXT_CLASS CXTPChartPieSeriesPointView : public CXTPChartPieSeriesPointViewBase
45{
46public:
54 CXTPChartPieSeriesPointView(CXTPChartSeriesPoint* pPoint, CXTPChartElementView* pParentView);
55
64 CXTPChartPieSeriesPointView(CXTPChartSeriesPoint* pPoint, CXTPChartElementView* pParentView,
65 BOOL bAddToParent);
66
67public:
74 virtual void CalculateLayout(double& dAngle);
75
76protected:
89 virtual CXTPChartDeviceCommand* CreateDeviceCommand(CXTPChartDeviceContext* pDC);
90
101 virtual CXTPChartDeviceCommand* CreateLegendDeviceCommand(CXTPChartDeviceContext* pDC,
102 CRect rcBounds);
103};
105# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
106#endif //#if !defined(__XTPCHART2DPIESERIESPOINTVIEW_H__)
pPoint
const CPoint * pPoint
return 0 or xtpCalendarHitTestDayExpandButton
Definition XTPCalendarThemeOffice2007.h:150
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartElementView
This class represents the view of a chart element.
Definition XTPChartElementView.h:47
CXTPChartPieSeriesPointViewBase
This class abstracts the view of a pie series point.
Definition XTPChartPieSeriesPointViewBase.h:50
CXTPChartPieSeriesPointView
This class abstracts the view of a pie series point.
Definition XTPChart2dPieSeriesPointView.h:45
CXTPChartPieSeriesPointView::CXTPChartPieSeriesPointView
CXTPChartPieSeriesPointView(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Constructs a CXTPChartPieSeriesPointView object.
CXTPChartPieSeriesPointView::CalculateLayout
virtual void CalculateLayout(double &dAngle)
Use this function to calculate the layout of the pie series point.
CXTPChartPieSeriesPointView::CreateDeviceCommand
virtual CXTPChartDeviceCommand * CreateDeviceCommand(CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
CXTPChartPieSeriesPointView::CreateLegendDeviceCommand
virtual CXTPChartDeviceCommand * CreateLegendDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcBounds)
This function creates a label view drawing command object.
CXTPChartPieSeriesPointView::CXTPChartPieSeriesPointView
CXTPChartPieSeriesPointView(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView, BOOL bAddToParent)
Constructs a CXTPChartPieSeriesPointView object.
CXTPChartSeriesPoint
CXTPChartSeriesPoint is a kind of CXTPChartElement.
Definition XTPChartSeriesPoint.h:43


Toolkit Pro: XTPChartSeriesPoint.h Source File

  • Source
  • Chart
XTPChartSeriesPoint.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTSERIESPOINT_H__)
24# define __XTPCHARTSERIESPOINT_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartSeries;
34class CXTPChartSeriesView;
35class CXTPChartSeriesPointCollection;
36
42class _XTP_EXT_CLASS CXTPChartSeriesPoint : public CXTPChartElement
43{
44 DECLARE_DYNAMIC(CXTPChartSeriesPoint);
45
46public:
51 CXTPChartSeriesPoint();
52
60 CXTPChartSeriesPoint(const CXTPChartString& strArgument, double dValue);
61
69 CXTPChartSeriesPoint(double dArgument, double dValue);
70
80 CXTPChartSeriesPoint(double dArgument, double dValue1, double dValue2);
81
91 CXTPChartSeriesPoint(const CXTPChartString& strArgument, double dValue1, double dValue2);
92
104 CXTPChartSeriesPoint(const CXTPChartString& strArgument, double dValue1, double dValue2,
105 double dValue3, double dValue4);
106
118 CXTPChartSeriesPoint(double dArgument, double dValue1, double dValue2, double dValue3,
119 double dValue4);
120
125 virtual ~CXTPChartSeriesPoint();
126
127public:
137 double GetValue(int nIndex) const;
138
146 void SetValue(int nIndex, double dValue);
147
148 CXTPChartColor GetColor() const;
149 void SetColor(const CXTPChartColor& clr);
150
158 CXTPChartString GetArgument() const;
159
167 double GetArgumentValue() const;
168
175 void SetArgumentValue(double dArgument);
176
184 double GetInternalArgumentValue() const;
185
192 void SetInternalArgumentValue(double dInternalArgument);
193
201 int GetPaletteIndex() const;
202
211 CXTPChartSeriesPoint* GetPreviousPoint() const;
212
221 CXTPChartSeriesPoint* GetNextPoint() const;
222
232 void SetLegendText(LPCTSTR lpszLegendText);
233
235 _XTP_DEPRECATED_IN_FAVOR(SetLegendText)
236 void SetLegentText(LPCTSTR lpszLegendText)
237 {
238 SetLegendText(lpszLegendText);
239 }
252 CXTPChartString GetLegendText() const;
253
261 int GetValueLength() const;
262
269 void SetValueLength(int nLength);
270
271 CXTPChartSeries* GetSeries() const;
272
282 void SetTooltipText(LPCTSTR lpszTooltip);
283
291 CXTPChartString GetTooltipText() const;
292
299 void SetLabelText(LPCTSTR lpszLabelText);
300
308 CXTPChartString GetLabelText() const;
309
310public:
311 virtual void DoPropExchange(CXTPPropExchange* pPX);
312
313protected:
318 void CommonConstruct();
319
320protected:
321 CXTPChartString m_strArgument;
322 double m_dArgument;
323 double m_dValues[4];
324 int m_nLength;
325 double m_dInternalArgument;
326 int m_nPaletteIndex;
327 int m_nIndex;
329 CXTPChartString m_strLegentText;
331 CXTPChartString m_strTooltipText;
332
333 CXTPChartString m_strLabelText;
334
335 CXTPChartColor m_clrPoint;
336
337public:
338 BOOL m_bSpecial;
339
340# ifdef _XTP_ACTIVEX
341public:
343 DECLARE_DISPATCH_MAP()
344 DECLARE_INTERFACE_MAP()
345 DECLARE_OLETYPELIB_EX(CXTPChartSeriesPoint);
346
347 afx_msg LPDISPATCH OleGetPreviousPoint();
348 afx_msg LPDISPATCH OleGetNextPoint();
349 afx_msg void OleSetArgumentValue(double dNewValue);
350 afx_msg void OleSetArgumentString(LPCTSTR lpszText);
351 afx_msg BSTR OleGetArgumentString();
352 afx_msg void OleSetSpecial(BOOL bSpecial);
353 afx_msg BOOL OleGetSpecial();
354 afx_msg BSTR OleGetLegendText();
355 afx_msg void OleSetLegendText(LPCTSTR lpszText);
356 afx_msg BSTR OleGetLabelText();
357 afx_msg void OleSetLabelText(LPCTSTR lpszText);
358 afx_msg OLE_COLOR OleGetColor();
359 afx_msg void OleSetColor(OLE_COLOR clr);
361# endif
362
363protected:
364 friend class CXTPChartSeriesPointCollection;
365 friend class CXTPChartContent;
366 friend class CXTPChartSeriesVirtualPointCollection;
367 friend class CXTPChartSeriesTrendlinePointCollection;
368};
369
375class _XTP_EXT_CLASS CXTPChartSeriesPointCollection : public CXTPChartElementCollection
376{
378 DECLARE_DYNAMIC(CXTPChartSeriesPointCollection)
380public:
385 CXTPChartSeriesPointCollection();
386
391 virtual ~CXTPChartSeriesPointCollection();
392
393public:
404 CXTPChartSeriesPoint* Add(CXTPChartSeriesPoint* pPoint);
405
416 virtual CXTPChartSeriesPoint* GetAt(int nIndex) const;
417
428 void AddPoints(int nCount);
429
439 virtual double GetArithmeticMean(int nValue) const;
440
450 virtual double GetVariance(int nValue) const;
451
461 virtual double GetStandardDeviation(int nValue) const;
462
474 virtual double GetMovingAverage(int nValue, int nFrom, int nTo) const;
475
482 virtual double GetMinimum(int nValue) const;
483
490 virtual double GetMaximum(int nValue) const;
491
492 virtual void GetSlopeQualitative(int nValue, double& dSlope, double& dIntercept) const;
493 virtual void GetSlopeNumerical(int nValue, double& dSlope, double& dIntercept) const;
494
495public:
496 virtual void DoPropExchange(CXTPPropExchange* pPX);
497
498protected:
499# ifdef _XTP_ACTIVEX
500public:
502 DECLARE_DISPATCH_MAP()
503 DECLARE_INTERFACE_MAP()
504
505 DECLARE_OLETYPELIB_EX(CXTPChartSeriesPointCollection);
506
507 afx_msg long OleGetItemCount();
508 afx_msg LPDISPATCH OleGetItem(long nIndex);
509 DECLARE_ENUM_VARIANT(CXTPChartSeriesPointCollection)
510 afx_msg LPDISPATCH OleAdd(const VARIANT& varArgument, const VARIANT& varValue);
511 afx_msg LPDISPATCH OleAdd4(const VARIANT& varArgument, double varValue1, double varValue2,
512 double varValue3, double varValue4);
513 afx_msg LPDISPATCH OleAdd2(const VARIANT& varArgument, double varValue1, double varValue2);
514
516# endif
517 friend class CXTPChartSeries;
518};
519
521// CXTPChartSeriesVirtualPointCollection
522
523class _XTP_EXT_CLASS CXTPChartSeriesVirtualPointCollection : public CXTPChartSeriesPointCollection
524{
525 DECLARE_DYNAMIC(CXTPChartSeriesVirtualPointCollection);
526 typedef double(CALLBACK* GETPOINTVALUEPTR)(CXTPChartSeries* pSeries, double x);
527
528public:
529 CXTPChartSeriesVirtualPointCollection(double dMinRange, double dMaxRange, double dStep,
530 GETPOINTVALUEPTR pCallbackPtr);
531 virtual ~CXTPChartSeriesVirtualPointCollection();
532
533public:
534 virtual CXTPChartSeriesPoint* GetAt(int nIndex) const;
535
536 virtual int GetCount() const;
537
538protected:
539 double m_dMinRange;
540 double m_dMaxRange;
541 double m_dStep;
542 int m_nCount;
543 CXTPChartSeriesPoint* m_pVirtualPoint;
544 GETPOINTVALUEPTR m_pCallbackPtr;
545};
546
547AFX_INLINE CXTPChartSeriesPoint* CXTPChartSeriesPointCollection::GetAt(int nIndex) const
548{
549 return nIndex >= 0 && nIndex < m_arrElements.GetSize()
550 ? (CXTPChartSeriesPoint*)m_arrElements.GetAt(nIndex)
551 : NULL;
552}
553
554AFX_INLINE CXTPChartString CXTPChartSeriesPoint::GetArgument() const
555{
556 return m_strArgument;
557}
558
559AFX_INLINE double CXTPChartSeriesPoint::GetArgumentValue() const
560{
561 return m_dArgument;
562}
563
564AFX_INLINE double CXTPChartSeriesPoint::GetInternalArgumentValue() const
565{
566 return m_dInternalArgument;
567}
568
569AFX_INLINE void CXTPChartSeriesPoint::SetInternalArgumentValue(double dInternalArgument)
570{
571 m_dInternalArgument = dInternalArgument;
572}
573
574AFX_INLINE int CXTPChartSeriesPoint::GetPaletteIndex() const
575{
576 return m_nPaletteIndex;
577}
578AFX_INLINE void CXTPChartSeriesPoint::SetLegendText(LPCTSTR lpszLegendText)
579{
580 m_strLegentText = lpszLegendText;
581 OnChartChanged();
582}
583AFX_INLINE CXTPChartString CXTPChartSeriesPoint::GetLegendText() const
584{
585 return m_strLegentText;
586}
587
588AFX_INLINE int CXTPChartSeriesPoint::GetValueLength() const
589{
590 return m_nLength;
591}
592
593AFX_INLINE void CXTPChartSeriesPoint::SetValueLength(int nLength)
594{
595 m_nLength = nLength;
596}
597
598AFX_INLINE CXTPChartColor CXTPChartSeriesPoint::GetColor() const
599{
600 return m_clrPoint;
601}
602AFX_INLINE void CXTPChartSeriesPoint::SetColor(const CXTPChartColor& clr)
603{
604 m_clrPoint = clr;
605 OnChartChanged();
606}
607AFX_INLINE CXTPChartString CXTPChartSeriesPoint::GetTooltipText() const
608{
609 return m_strTooltipText;
610}
611AFX_INLINE void CXTPChartSeriesPoint::SetTooltipText(LPCTSTR lpszTooltip)
612{
613 m_strTooltipText = lpszTooltip;
614}
615AFX_INLINE CXTPChartString CXTPChartSeriesPoint::GetLabelText() const
616{
617 return m_strLabelText;
618}
619AFX_INLINE void CXTPChartSeriesPoint::SetLabelText(LPCTSTR lpszLabelText)
620{
621 m_strLabelText = lpszLabelText;
622 OnChartChanged();
623}
624AFX_INLINE void CXTPChartSeriesPoint::SetArgumentValue(double dArgument)
625{
626 m_dArgument = dArgument;
627 OnChartChanged();
628}
630# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
631#endif //#if !defined(__XTPCHARTSERIESPOINT_H__)
pPoint
const CPoint * pPoint
return 0 or xtpCalendarHitTestDayExpandButton
Definition XTPCalendarThemeOffice2007.h:150
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartColor
This class abstracts a color entity.
Definition XTPChartTypes.h:51
CXTPChartContent
This class represents chart content, which is a kind of CXTPChartElement.
Definition XTPChartContent.h:66
CXTPChartElementCollection
This class abstracts a chart collection.
Definition XTPChartElement.h:358
CXTPChartElementCollection::m_arrElements
CArray< CXTPChartElement *, CXTPChartElement * > m_arrElements
Array of CXTPChartElement pointer.
Definition XTPChartElement.h:450
CXTPChartElement
This class abstracts a chart element, this class acts as a base class for all chart elements.
Definition XTPChartElement.h:131
CXTPChartElement::OnChartChanged
virtual void OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic propertie...
CXTPChartSeries
This class represents a series in the chart, which is a kind of CXTPChartElement.
Definition XTPChartSeries.h:50
CXTPChartSeriesPointCollection
CXTPChartSeriesPointCollection class represents a collection of chart series points.
Definition XTPChartSeriesPoint.h:376
CXTPChartSeriesPointCollection::DoPropExchange
virtual void DoPropExchange(CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
CXTPChartSeriesPointCollection::CXTPChartSeriesPointCollection
CXTPChartSeriesPointCollection()
Constructs CXTPChartSeriesPointCollection object.
CXTPChartSeriesPointCollection::GetMovingAverage
virtual double GetMovingAverage(int nValue, int nFrom, int nTo) const
Call this method to get the moving average of the point collection.
CXTPChartSeriesPointCollection::GetArithmeticMean
virtual double GetArithmeticMean(int nValue) const
Call this method to get the arithmetic mean of the point collection.
CXTPChartSeriesPointCollection::Add
CXTPChartSeriesPoint * Add(CXTPChartSeriesPoint *pPoint)
This function adds a point represented by the class CXTPChartSeriesPoint to the internal array of poi...
CXTPChartSeriesPointCollection::GetMaximum
virtual double GetMaximum(int nValue) const
Call this method to get the maximum of the point collection.
CXTPChartSeriesPointCollection::~CXTPChartSeriesPointCollection
virtual ~CXTPChartSeriesPointCollection()
Destroys a CXTPChartSeriesPointCollection object, handles cleanup.
CXTPChartSeriesPointCollection::GetMinimum
virtual double GetMinimum(int nValue) const
Call this method to get the minimum of the point collection.
CXTPChartSeriesPointCollection::AddPoints
void AddPoints(int nCount)
Call this method to add a batch of points.
CXTPChartSeriesPointCollection::GetVariance
virtual double GetVariance(int nValue) const
Call this method to get the variance of the point collection.
CXTPChartSeriesPointCollection::GetAt
virtual CXTPChartSeriesPoint * GetAt(int nIndex) const
Call this function to get the pointer to the CXTPChartSeriesPoint object at a particular index.
Definition XTPChartSeriesPoint.h:547
CXTPChartSeriesPointCollection::GetStandardDeviation
virtual double GetStandardDeviation(int nValue) const
Call this method to get the standard deviation of the point collection.
CXTPChartSeriesPoint
CXTPChartSeriesPoint is a kind of CXTPChartElement.
Definition XTPChartSeriesPoint.h:43
CXTPChartSeriesPoint::SetLabelText
void SetLabelText(LPCTSTR lpszLabelText)
Sets point label text.
Definition XTPChartSeriesPoint.h:619
CXTPChartSeriesPoint::CXTPChartSeriesPoint
CXTPChartSeriesPoint(double dArgument, double dValue1, double dValue2, double dValue3, double dValue4)
Constructor overload which makes a CXTPChartSeriesPoint object from an argument and four values.
CXTPChartSeriesPoint::DoPropExchange
virtual void DoPropExchange(CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
CXTPChartSeriesPoint::SetTooltipText
void SetTooltipText(LPCTSTR lpszTooltip)
Call this member to set the tooltip of the action.
Definition XTPChartSeriesPoint.h:611
CXTPChartSeriesPoint::CXTPChartSeriesPoint
CXTPChartSeriesPoint(double dArgument, double dValue)
Constructor makes a CXTPChartSeriesPoint object from the parameters.
CXTPChartSeriesPoint::SetValue
void SetValue(int nIndex, double dValue)
Sets the value at a specified index.
CXTPChartSeriesPoint::m_nLength
int m_nLength
The size of the array, m_dValues.
Definition XTPChartSeriesPoint.h:324
CXTPChartSeriesPoint::GetLabelText
CXTPChartString GetLabelText() const
Gets point label text.
Definition XTPChartSeriesPoint.h:615
CXTPChartSeriesPoint::GetArgumentValue
double GetArgumentValue() const
Gets the double value of the argument of a point.
Definition XTPChartSeriesPoint.h:559
CXTPChartSeriesPoint::m_nIndex
int m_nIndex
Number of elements present in the array m_dValues.
Definition XTPChartSeriesPoint.h:327
CXTPChartSeriesPoint::CXTPChartSeriesPoint
CXTPChartSeriesPoint()
Default constructor, makes a CXTPChartSeriesPoint object.
CXTPChartSeriesPoint::GetValueLength
int GetValueLength() const
Gets the current value length in characters.
Definition XTPChartSeriesPoint.h:588
CXTPChartSeriesPoint::GetPreviousPoint
CXTPChartSeriesPoint * GetPreviousPoint() const
This function returns the previous point in the series.
CXTPChartSeriesPoint::SetLegendText
void SetLegendText(LPCTSTR lpszLegendText)
Sets new point legend text.
Definition XTPChartSeriesPoint.h:578
CXTPChartSeriesPoint::SetArgumentValue
void SetArgumentValue(double dArgument)
Sets the double value of the argument of a point.
Definition XTPChartSeriesPoint.h:624
CXTPChartSeriesPoint::GetArgument
CXTPChartString GetArgument() const
This function returns the string argument of a point.
Definition XTPChartSeriesPoint.h:554
CXTPChartSeriesPoint::m_dArgument
double m_dArgument
Double value of argument.
Definition XTPChartSeriesPoint.h:322
CXTPChartSeriesPoint::m_dInternalArgument
double m_dInternalArgument
The double value of the string argument.
Definition XTPChartSeriesPoint.h:325
CXTPChartSeriesPoint::GetInternalArgumentValue
double GetInternalArgumentValue() const
Gets the double value of the string argument of a point.
Definition XTPChartSeriesPoint.h:564
CXTPChartSeriesPoint::GetTooltipText
CXTPChartString GetTooltipText() const
Call this member to get the action's tooltip.
Definition XTPChartSeriesPoint.h:607
CXTPChartSeriesPoint::GetPaletteIndex
int GetPaletteIndex() const
This function returns the palette index used.
Definition XTPChartSeriesPoint.h:574
CXTPChartSeriesPoint::~CXTPChartSeriesPoint
virtual ~CXTPChartSeriesPoint()
Destroys a CXTPChartSeriesPoint object, handles cleanup.
CXTPChartSeriesPoint::CommonConstruct
void CommonConstruct()
This function handles so internal, argument type conversions.
CXTPChartSeriesPoint::CXTPChartSeriesPoint
CXTPChartSeriesPoint(const CXTPChartString &strArgument, double dValue)
Overloaded constructor makes a CXTPChartSeriesPoint object.
CXTPChartSeriesPoint::m_strArgument
CXTPChartString m_strArgument
String argument.
Definition XTPChartSeriesPoint.h:321
CXTPChartSeriesPoint::m_nPaletteIndex
int m_nPaletteIndex
The chosen palette index.
Definition XTPChartSeriesPoint.h:326
CXTPChartSeriesPoint::GetLegendText
CXTPChartString GetLegendText() const
Obtains current point legend text.
Definition XTPChartSeriesPoint.h:583
CXTPChartSeriesPoint::CXTPChartSeriesPoint
CXTPChartSeriesPoint(const CXTPChartString &strArgument, double dValue1, double dValue2, double dValue3, double dValue4)
Constructor overload which makes a CXTPChartSeriesPoint object from an argument and four values.
CXTPChartSeriesPoint::CXTPChartSeriesPoint
CXTPChartSeriesPoint(const CXTPChartString &strArgument, double dValue1, double dValue2)
Constructor overload which makes a CXTPChartSeriesPoint object from an argument and a pair of values.
CXTPChartSeriesPoint::SetInternalArgumentValue
void SetInternalArgumentValue(double dInternalArgument)
Sets the double value of the string argument of a point.
Definition XTPChartSeriesPoint.h:569
CXTPChartSeriesPoint::m_strLegentText
CXTPChartString m_strLegentText
Text to show in legend.
Definition XTPChartSeriesPoint.h:329
CXTPChartSeriesPoint::CXTPChartSeriesPoint
CXTPChartSeriesPoint(double dArgument, double dValue1, double dValue2)
Constructor overload which makes a CXTPChartSeriesPoint object from an argument and a pair of values.
CXTPChartSeriesPoint::GetValue
double GetValue(int nIndex) const
Gets the value at a specified index.
CXTPChartSeriesPoint::GetNextPoint
CXTPChartSeriesPoint * GetNextPoint() const
This function returns the next point in the series.
CXTPChartSeriesPoint::SetValueLength
void SetValueLength(int nLength)
Sets the current value length in characters.
Definition XTPChartSeriesPoint.h:593
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72


Toolkit Pro: XTPMaskEditT.h Source File

  • Source
  • Common
XTPMaskEditT.h
Go to the documentation of this file.
1
23#if !defined(__XTMASKEDITEX_H__)
24# define __XTMASKEDITEX_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/XTPCasting.h"
32
33# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
34
35// deprecated
36# define CXTMaskEditT CXTPMaskEditT
37
43template<class TBase>
44class CXTPMaskEditT : public TBase
45{
46public:
51 CXTPMaskEditT()
52 : m_nStartChar(0)
53 , m_nEndChar(0)
54 , m_bUseMask(TRUE)
55 , m_bOverType(FALSE)
56 , m_bRedo(FALSE)
57 , m_bModified(FALSE)
58 , m_chPrompt(_T('_'))
59 , m_strMask(_T(""))
60 , m_strDefault(_T(""))
61 , m_strUndoBuffer(_T(""))
62 , m_strWindowText(_T(""))
63 , m_strLiteral(_T(""))
64 , m_bUpdateUndo(TRUE)
65 {
66 }
67
68public:
75 void SetUseMask(BOOL bUseMask)
76 {
77 m_bUseMask = bUseMask;
78 }
79
87 BOOL CanUseMask() const
88 {
89 return m_bUseMask && TBase::m_hWnd && ((TBase::GetStyle() & ES_READONLY) == 0)
90 && !m_strMask.IsEmpty();
91 }
92
99 void SetOverType(BOOL bOverType)
100 {
101 m_bOverType = bOverType;
102 }
103
110 BOOL CanOverType() const
111 {
112 return m_bOverType;
113 }
114
123 BOOL PosInRange(int iPos) const
124 {
125 return ((iPos >= 0) && (iPos < m_strLiteral.GetLength()));
126 }
127
135 TCHAR GetPromptChar() const
136 {
137 return m_chPrompt;
138 }
139
147 CString GetPromptString(int nLength) const
148 {
149 CString strPrompt;
150
151 while (nLength--)
152 strPrompt += m_chPrompt;
153
154 return strPrompt;
155 }
156
164 void SetPromptChar(TCHAR ch, BOOL bAutoReplace = TRUE)
165 {
166 if (m_chPrompt == ch)
167 return;
168
169 if (bAutoReplace)
170 {
171 GetMaskState();
172
173 for (int i = 0; i < m_strLiteral.GetLength(); i++)
174 if (m_strLiteral[i] == m_chPrompt)
175 m_strLiteral.SetAt(i, ch);
176
177 for (int j = 0; j < m_strWindowText.GetLength(); j++)
178 if (m_strWindowText[j] == m_chPrompt)
179 m_strWindowText.SetAt(j, ch);
180
181 SetMaskState();
182 }
183
184 m_chPrompt = ch;
185 }
186
193 afx_msg BOOL MaskCut()
194 {
195 if (!CanUseMask())
196 return static_cast<BOOL>(TBase::DefWindowProc(WM_CUT, 0, 0));
197
198 MaskCopy();
199 MaskClear();
200
201 return TRUE;
202 }
203
210 afx_msg BOOL MaskCopy()
211 {
212 if (!CanUseMask())
213 return static_cast<BOOL>(TBase::DefWindowProc(WM_COPY, 0, 0));
214
215 GetMaskState();
216
217 CString strMaskedText = GetMaskedText(m_nStartChar, m_nEndChar);
218 CopyToClipboard(strMaskedText);
219
220 return TRUE;
221 }
222
229 void MaskReplaceSel(LPCTSTR lpszNewText)
230 {
231 _ASSERTE(CanUseMask());
232
233 if (m_nStartChar != m_nEndChar)
234 MaskDeleteSel();
235
236 int x = m_nStartChar, nNewTextLen = (int)_tcslen(lpszNewText);
237 int nWindowTextLen = m_strWindowText.GetLength();
238
239 if (x >= nWindowTextLen)
240 return;
241
242 for (int i = 0; i < nNewTextLen; ++i)
243 {
244 TCHAR ch = lpszNewText[i];
245
246 if (ch == m_chPrompt || CheckChar(ch, x))
247 {
248 InsertCharAt(x, ch);
249 x++;
250
251 while (x < nWindowTextLen && !IsPromptPos(x))
252 x++;
253
254 if (x >= m_strWindowText.GetLength())
255 break;
256 }
257 }
258 CorrectPosition(x);
259 m_nStartChar = m_nEndChar = x;
260 }
261
268 afx_msg BOOL MaskPaste()
269 {
270 if (!CanUseMask())
271 return static_cast<BOOL>(TBase::DefWindowProc(WM_PASTE, 0, 0));
272
273 GetMaskState();
274
275 if (!TBase::OpenClipboard())
276 return FALSE;
277
278# ifndef _UNICODE
279 HGLOBAL hglbPaste = ::GetClipboardData(CF_TEXT);
280# else
281 HGLOBAL hglbPaste = ::GetClipboardData(CF_UNICODETEXT);
282# endif
283
284 if (hglbPaste != NULL)
285 {
286 TCHAR* lpszClipboard = (TCHAR*)GlobalLock(hglbPaste);
287
288 MaskReplaceSel(lpszClipboard);
289
290 GlobalUnlock(hglbPaste);
291
292 SetMaskState();
293 }
294 ::CloseClipboard();
295
296 return TRUE;
297 }
298
303 void MaskDeleteSel()
304 {
305 if (m_nStartChar == m_nEndChar)
306 return;
307
308 CString strMaskedText = GetMaskedText(m_nEndChar);
309 SetMaskedText(strMaskedText, m_nStartChar, FALSE);
310
311 m_nEndChar = m_nStartChar;
312 }
313
319 afx_msg BOOL MaskClear()
320 {
321 if (!CanUseMask())
322 return static_cast<BOOL>(TBase::DefWindowProc(WM_CLEAR, 0, 0));
323
324 GetMaskState();
325
326 MaskDeleteSel();
327
328 SetMaskState();
329
330 return TRUE;
331 }
332
338 afx_msg BOOL MaskUndo()
339 {
340 if (!CanUseMask())
341 {
342 return static_cast<BOOL>(TBase::DefWindowProc(EM_UNDO, 0, 0));
343 }
344 else
345 {
346 MaskGetSel();
347
348 if (m_bRedo)
349 {
350 TBase::SetWindowText(m_strRedoBuffer);
351 }
352 else
353 {
354 TBase::GetWindowText(m_strRedoBuffer);
355 TBase::SetWindowText(m_strUndoBuffer);
356 }
357
358 m_bRedo = !m_bRedo;
359 m_bModified = TRUE;
360
361 m_nEndChar = m_nStartChar;
362 TBase::SetSel(m_nStartChar, m_nEndChar);
363 }
364
365 return TRUE;
366 }
367
373 afx_msg void MaskSelectAll()
374 {
375 if (!CanUseMask())
376 {
377 TBase::SetSel(0, -1);
378 }
379 else
380 {
381 m_nStartChar = 0;
382 CorrectPosition(m_nStartChar);
383 TBase::SetSel(m_nStartChar, -1);
384 }
385 }
386
393 BOOL IsModified() const
394 {
395 return m_bModified;
396 }
397
412 void SetMaskedText(LPCTSTR lpszMaskedText, int iPos = 0, BOOL bUpdateWindow = TRUE)
413 {
414 int nMaskedTextLength = (int)_tcslen(lpszMaskedText);
415
416 m_strWindowText = m_strWindowText.Left(iPos);
417 int nIndex = 0;
418
419 for (; (iPos < m_strLiteral.GetLength()) && (nIndex < nMaskedTextLength); iPos++)
420 {
421 TCHAR uChar = lpszMaskedText[nIndex];
422
423 if (IsPromptPos(iPos) && ((uChar == m_chPrompt) || ProcessMask(uChar, iPos)))
424 {
425 m_strWindowText += (TCHAR)uChar;
426 nIndex++;
427 }
428 else
429 {
430 m_strWindowText += m_strLiteral[iPos];
431 }
432 }
433
434 if (bUpdateWindow)
435 {
436 SetMaskState(FALSE);
437 }
438 else
439 {
440 CorrectWindowText();
441 }
442 }
443
480 virtual BOOL SetEditMask(LPCTSTR lpszMask, LPCTSTR lpszLiteral, LPCTSTR lpszDefault = NULL)
481 {
482 _ASSERTE(lpszMask);
483 _ASSERTE(lpszLiteral);
484
485 // initialize the mask for the control.
486 m_strMask = lpszMask;
487 m_strLiteral = lpszLiteral;
488
489 _ASSERTE(m_strMask.GetLength() == m_strLiteral.GetLength());
490
491 if (m_strMask.GetLength() != m_strLiteral.GetLength())
492 return FALSE;
493
494 if (lpszDefault == NULL)
495 {
496 m_strWindowText = m_strDefault = lpszLiteral;
497 }
498 else
499 {
500 m_strWindowText = m_strDefault = lpszDefault;
501
502 if (m_strDefault.GetLength() != m_strLiteral.GetLength())
503 {
504 SetMaskedText(m_strDefault, 0, FALSE);
505 m_strDefault = m_strWindowText;
506 }
507 }
508
509 _ASSERTE(m_strWindowText.GetLength() == m_strLiteral.GetLength());
510
511 // set the window text for the control.
512 m_bRedo = FALSE;
513 m_bModified = FALSE;
514 TBase::SetWindowText(m_strWindowText);
515
516 m_strUndoBuffer = m_strWindowText;
517 return TRUE;
518 }
519
528 TCHAR ConvertUnicodeAlpha(TCHAR nChar, BOOL bUpperCase) const
529 {
530 CString strTemp(nChar);
531 if (bUpperCase)
532 strTemp.MakeUpper();
533 else
534 strTemp.MakeLower();
535 return strTemp[0];
536 }
537
547 virtual BOOL CheckChar(TCHAR& nChar, int nPos)
548 {
549 // do not use mask
550 if (!CanUseMask())
551 return FALSE;
552
553 // control character, OK
554 if (!IsPrintChar(nChar))
555 return TRUE;
556
557 // make sure the string is not longer than the mask
558 if (nPos >= m_strMask.GetLength())
559 return FALSE;
560
561 if (!IsPromptPos(nPos))
562 return FALSE;
563
564 return ProcessMask(nChar, nPos);
565 }
566
576 virtual BOOL ProcessMask(TCHAR& nChar, int nEndPos)
577 {
578 _ASSERTE(nEndPos < m_strMask.GetLength());
579 if (nEndPos < 0 || nEndPos >= m_strMask.GetLength())
580 return FALSE;
581
582 // check the key against the mask
583 wint_t tChar = static_cast<wint_t>(nChar);
584 switch (m_strMask.GetAt(nEndPos))
585 {
586 case '0': // digit only //completely changed this
587 return ('0' <= tChar && tChar <= '9');
588
589 case '9': // digit or space
590 return ('0' <= tChar && tChar <= '9') || _istspace(tChar);
591
592 case '#': // digit or space or '+' or '-'
593 return ('0' <= tChar && tChar <= '9') || _istspace(tChar) || tChar == _T('-')
594 || tChar == _T('+');
595
596 case 'd': // decimal
597 return ('0' <= tChar && tChar <= '9') || _istspace(tChar) || tChar == _T('-')
598 || tChar == _T('+') || tChar == _T('.') || tChar == _T(',');
599
600 case 'L': // alpha only
601 return IsAlphaChar(nChar);
602
603 case '?': // alpha or space
604 return IsAlphaChar(nChar) || _istspace(tChar);
605
606 case 'A': // alpha numeric only
607 return _istalnum(tChar) || IsAlphaChar(nChar);
608
609 case 'a': // alpha numeric or space
610 return _istalnum(tChar) || IsAlphaChar(nChar) || _istspace(tChar);
611
612 case '&': // all print character only
613 return IsPrintChar(nChar);
614
615 case 'H': // hex digit uppercase
616 return ('0' <= tChar && tChar <= '9') || ('A' <= tChar && tChar <= 'F')
617 || ('a' <= tChar && tChar <= 'f' ? (nChar ^= 0x20, TRUE) : FALSE);
618
619 case 'h': // hex digit lowercase
620 return ('0' <= tChar && tChar <= '9') || ('a' <= tChar && tChar <= 'f')
621 || ('A' <= tChar && tChar <= 'F' ? (nChar ^= 0x20, TRUE) : FALSE);
622
623 case 'X': // uppercase hex digit or space
624 return ('0' <= tChar && tChar <= '9') || ('A' <= tChar && tChar <= 'F')
625 || ('a' <= tChar && tChar <= 'f' ? (nChar ^= 0x20, TRUE) : FALSE)
626 || _istspace(tChar);
627
628 case 'x': // lowercase hex digit or space
629 return ('0' <= tChar && tChar <= '9') || ('a' <= tChar && tChar <= 'f')
630 || ('A' <= tChar && tChar <= 'F' ? (nChar ^= 0x20, TRUE) : FALSE)
631 || _istspace(tChar);
632
633 case 'C': // Uppercase ASCII character
634 return ('a' <= tChar && tChar <= 'z' ? (nChar ^= 0x20, TRUE)
635 : 'A' <= tChar && tChar <= 'Z');
636
637 case 'c': // Lowercase ASCII character
638 return ('A' <= tChar && tChar <= 'Z' ? (nChar ^= 0x20, TRUE)
639 : 'a' <= tChar && tChar <= 'z');
640
641 case '>':
642 if (IsAlphaChar(nChar))
643 {
644 nChar = ConvertUnicodeAlpha(nChar, TRUE);
645 return TRUE;
646 }
647 return FALSE;
648
649 case '<':
650 if (IsAlphaChar(nChar))
651 {
652 nChar = ConvertUnicodeAlpha(nChar, FALSE);
653 return TRUE;
654 }
655 return FALSE;
656 }
657
658 return FALSE;
659 }
660
661public:
671 virtual BOOL PreTranslateMessage(MSG* pMsg)
672 {
673 if (!CanUseMask())
674 return TBase::PreTranslateMessage(pMsg);
675
676 // intercept Ctrl+C (copy), Ctrl+V (paste), Ctrl+X (cut) and Ctrl+Z (undo)
677 // before CEdit base class gets a hold of them.
678
679 if (pMsg->message == WM_KEYDOWN)
680 {
681 if (::GetKeyState(VK_SUBTRACT) < 0)
682 {
683 OnChar('-', 1, 1);
684 return TRUE;
685 }
686
687 if (::GetKeyState(VK_ADD) < 0)
688 {
689 OnChar('+', 1, 1);
690 return TRUE;
691 }
692
693 if (::GetKeyState(VK_CONTROL) < 0)
694 {
695 switch (pMsg->wParam)
696 {
697 case 'X':
698 case 'x':
699 {
700 MaskCut();
701 return TRUE;
702 }
703
704 case 'C':
705 case 'c':
706 {
707 MaskCopy();
708 return TRUE;
709 }
710
711 case 'V':
712 case 'v':
713 {
714 MaskPaste();
715 return TRUE;
716 }
717
718 case 'Z':
719 case 'z':
720 {
721 MaskUndo();
722 return TRUE;
723 }
724 }
725 }
726 }
727
728 return TBase::PreTranslateMessage(pMsg);
729 }
730
736 void DeleteCharAt(int iPos)
737 {
738 _ASSERTE(PosInRange(iPos));
739
740 if (!PosInRange(iPos))
741 return;
742
743 CString strMaskedText = GetMaskedText(iPos + 1) + m_chPrompt;
744
745 SetMaskedText(strMaskedText, iPos, FALSE);
746 }
747
754 void InsertCharAt(int iPos, TCHAR nChar)
755 {
756 _ASSERTE(PosInRange(iPos));
757
758 if (!PosInRange(iPos))
759 return;
760
761 CString strMaskedText = CString(nChar) + GetMaskedText(iPos);
762
763 SetMaskedText(strMaskedText, iPos, FALSE);
764 }
765
773 BOOL CopyToClipboard(const CString& strText)
774 {
775 if (!TBase::OpenClipboard())
776 return FALSE;
777
778 ::EmptyClipboard();
779
780 SIZE_T nLen = (strText.GetLength() + 1) * sizeof(TCHAR);
781 HGLOBAL hglbCopy = ::GlobalAlloc(GMEM_MOVEABLE, nLen);
782
783 if (hglbCopy == NULL)
784 {
785 ::CloseClipboard();
786 return FALSE;
787 }
788
789 LPTSTR lptstrCopy = (TCHAR*)GlobalLock(hglbCopy);
790 STRCPY_S(lptstrCopy, XTPToSizeTChecked(strText.GetLength() + 1), (LPCTSTR)strText);
791 GlobalUnlock(hglbCopy);
792
793# ifndef _UNICODE
794 ::SetClipboardData(CF_TEXT, hglbCopy);
795# else
796 ::SetClipboardData(CF_UNICODETEXT, hglbCopy);
797# endif
798
799 if (!::CloseClipboard())
800 return FALSE;
801
802 return TRUE;
803 }
804
813 CString GetMaskedText(int nStartPos = 0, int nEndPos = -1) const
814 {
815 if (nEndPos == -1)
816 nEndPos = m_strWindowText.GetLength();
817 else
818 nEndPos = min(nEndPos, m_strWindowText.GetLength());
819
820 CString strBuffer;
821
822 for (int i = nStartPos; i < nEndPos; ++i)
823 {
824 if (IsPromptPos(i))
825 {
826 strBuffer += m_strWindowText[i];
827 }
828 }
829
830 return strBuffer;
831 }
832
833protected:
835 afx_msg void OnKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags)
836 {
837 if (!CanUseMask())
838 {
839 TBase::OnKeyDown(nChar, nRepCnt, nFlags); // default processing.
840 return;
841 }
842
843 BOOL bShift = (::GetKeyState(VK_SHIFT) < 0);
844 BOOL bCtrl = (::GetKeyState(VK_CONTROL) < 0);
845
846 switch (nChar)
847 {
848 case VK_UP:
849 case VK_LEFT:
850 case VK_HOME:
851 {
852 TBase::OnKeyDown(nChar, nRepCnt, nFlags);
853
854 GetMaskState(FALSE);
855
856 int iStartChar = m_nStartChar;
857 CorrectPosition(iStartChar, FALSE);
858
859 if (m_nStartChar < iStartChar)
860 {
861 m_nStartChar = iStartChar;
862
863 if (!bShift)
864 m_nEndChar = iStartChar;
865 }
866
867 SetMaskState();
868 }
869 return;
870
871 case VK_DOWN:
872 case VK_RIGHT:
873 case VK_END:
874 {
875 TBase::OnKeyDown(nChar, nRepCnt, nFlags);
876
877 GetMaskState(FALSE);
878
879 int iEndChar = m_nEndChar;
880 CorrectPosition(iEndChar);
881
882 if (m_nEndChar > iEndChar)
883 {
884 m_nEndChar = iEndChar;
885
886 if (!bShift)
887 m_nStartChar = iEndChar;
888 }
889
890 SetMaskState();
891 }
892 return;
893
894 case VK_INSERT:
895 {
896 if (bCtrl)
897 {
898 MaskCopy();
899 }
900 else if (bShift)
901 {
902 MaskPaste();
903 }
904 else
905 {
906 m_bOverType = !m_bOverType; // set the type-over flag
907 }
908 }
909 return;
910
911 case VK_DELETE:
912 {
913 GetMaskState();
914
915 if (m_nStartChar == m_nEndChar)
916 {
917 m_nEndChar = m_nStartChar + 1;
918 }
919 else if (bShift)
920 {
921 MaskCopy();
922 }
923
924 MaskDeleteSel();
925 SetMaskState();
926 }
927 return;
928
929 case VK_SPACE:
930 {
931 GetMaskState();
932
933 if (!PosInRange(m_nStartChar) || !IsPromptPos(m_nStartChar))
934 {
935 NotifyPosNotInRange();
936 return;
937 }
938
939 TCHAR chSpace = _T(' ');
940 if (ProcessMask(chSpace, m_nStartChar))
941 {
942 ProcessChar(chSpace);
943 }
944
945 SetMaskState();
946 }
947 return;
948
949 case VK_BACK:
950 {
951 GetMaskState(FALSE);
952
953 if (((m_nStartChar > 0) || (m_nStartChar == 0 && m_nEndChar != 0))
954 && (m_nStartChar <= m_strLiteral.GetLength()))
955 {
956 if (m_nStartChar == m_nEndChar)
957 {
958 m_nStartChar--;
959 CorrectPosition(m_nStartChar, FALSE);
960
961 if (m_bOverType && PosInRange(m_nStartChar))
962 {
963 m_strWindowText.SetAt(m_nStartChar, m_strDefault[m_nStartChar]);
964 m_nEndChar = m_nStartChar;
965 }
966 }
967
968 MaskDeleteSel();
969 SetMaskState();
970 }
971 else
972 {
973 NotifyPosNotInRange();
974 }
975 }
976 return;
977 }
978
979 TBase::OnKeyDown(nChar, nRepCnt, nFlags);
980 }
981
982 void ProcessChar(TCHAR nChar)
983 {
984 int iLen = m_strLiteral.GetLength();
985
986 if (m_nStartChar >= iLen)
987 {
988 NotifyPosNotInRange();
989 return;
990 }
991
992 if (m_nStartChar != m_nEndChar)
993 {
994 MaskDeleteSel();
995 }
996
997 _ASSERTE(m_nStartChar == m_nEndChar);
998
999 CorrectPosition(m_nStartChar);
1000
1001 if (CanOverType())
1002 {
1003 m_strWindowText.SetAt(m_nStartChar, nChar);
1004 }
1005 else
1006 {
1007 InsertCharAt(m_nStartChar, nChar);
1008 }
1009
1010 if (m_nStartChar < iLen)
1011 m_nStartChar++;
1012
1013 CorrectPosition(m_nStartChar);
1014
1015 m_nEndChar = m_nStartChar;
1016 }
1017
1018 afx_msg void OnChar(UINT nChar, UINT nRepCnt, UINT nFlags)
1019 {
1020 if (!CanUseMask())
1021 {
1022 TBase::OnChar(nChar, nRepCnt, nFlags);
1023 return;
1024 }
1025
1026 switch (nChar)
1027 {
1028 case VK_SPACE:
1029 case VK_BACK: return; // handled in WM_KEYDOWN
1030 }
1031
1032 GetMaskState();
1033
1034 if (!PosInRange(m_nStartChar) || !IsPromptPos(m_nStartChar))
1035 {
1036 NotifyPosNotInRange();
1037 return;
1038 }
1039
1040 TCHAR ch = (TCHAR)nChar;
1041
1042 if (!CheckChar(ch, m_nStartChar))
1043 {
1044 NotifyInvalidCharacter(ch, m_strMask[m_nStartChar]);
1045 return;
1046 }
1047
1048 if (IsPrintChar(ch))
1049 {
1050 ProcessChar(ch);
1051 SetMaskState(FALSE);
1052 }
1053 else
1054 {
1055 if (nChar != 127)
1056 TBase::OnChar(nChar, nRepCnt, nFlags);
1057 }
1058 }
1059
1060 afx_msg void OnSetFocus(CWnd* pOldWnd)
1061 {
1062 TBase::OnSetFocus(pOldWnd);
1063
1064 if (!CanUseMask())
1065 {
1066 return;
1067 }
1068
1069 MaskGetSel();
1070 CorrectPosition(m_nStartChar);
1071
1072 m_nEndChar = m_nStartChar;
1073 TBase::SetSel(m_nStartChar, m_nEndChar);
1074 }
1075
1076 afx_msg void OnUpdateEditUndo(CCmdUI* pCmdUI)
1077 {
1078 if (!CanUseMask())
1079 {
1080 pCmdUI->Enable(TBase::CanUndo());
1081 }
1082 else
1083 {
1084 pCmdUI->Enable(m_bModified);
1085 }
1086 }
1087
1088 // Some goodies
1089 BOOL CorrectPosition(int& iPos, BOOL bForward = TRUE) // used internally
1090 {
1091 int iLen = m_strLiteral.GetLength();
1092
1093 if (IsPromptPos(iPos))
1094 return TRUE;
1095
1096 if (bForward)
1097 {
1098 for (; iPos < iLen; iPos++)
1099 {
1100 if (IsPromptPos(iPos))
1101 return TRUE;
1102 }
1103
1104 for (; iPos >= 0; iPos--)
1105 {
1106 if (IsPromptPos(iPos - 1))
1107 return FALSE;
1108 }
1109 }
1110 else
1111 {
1112 for (; iPos >= 0; iPos--)
1113 {
1114 if (IsPromptPos(iPos))
1115 return TRUE;
1116 }
1117
1118 for (; iPos < iLen; iPos++)
1119 {
1120 if (IsPromptPos(iPos))
1121 return FALSE;
1122 }
1123 }
1124
1125 return FALSE;
1126 }
1127
1128 virtual BOOL IsPrintChar(TCHAR nChar)
1129 {
1130 return _istprint(static_cast<wint_t>(nChar)) || IsAlphaChar(nChar);
1131 }
1139 virtual BOOL IsAlphaChar(TCHAR nChar)
1140 {
1141 if (_istalpha(static_cast<wint_t>(nChar)))
1142 return TRUE;
1143
1144 if (ConvertUnicodeAlpha(nChar, TRUE) != nChar)
1145 return TRUE;
1146
1147 if (ConvertUnicodeAlpha(nChar, FALSE) != nChar)
1148 return TRUE;
1149
1150 return FALSE;
1151 }
1152
1153 virtual void NotifyPosNotInRange()
1154 {
1155 ::MessageBeep((UINT)-1);
1156 }
1157
1158 virtual void NotifyInvalidCharacter(TCHAR /*nChar*/, TCHAR /*chMask*/)
1159 {
1160 ::MessageBeep((UINT)-1);
1161 }
1162
1163 BOOL IsPromptPos(int nPos) const
1164 {
1165 return IsPromptPos(m_strLiteral, nPos);
1166 }
1167
1168 BOOL IsPromptPos(const CString& strLiteral, int nPos) const
1169 {
1170 return (nPos >= 0 && nPos < strLiteral.GetLength()) && (strLiteral[nPos] == m_chPrompt);
1171 }
1172
1173 void CorrectWindowText()
1174 {
1175 int nLiteralLength = m_strLiteral.GetLength();
1176 int nWindowTextLength = m_strWindowText.GetLength();
1177
1178 if (nWindowTextLength > nLiteralLength)
1179 {
1180 m_strWindowText = m_strWindowText.Left(nLiteralLength);
1181 }
1182 else if (nWindowTextLength < nLiteralLength)
1183 {
1184 m_strWindowText += m_strLiteral.Mid(nWindowTextLength,
1185 nLiteralLength - nWindowTextLength);
1186 }
1187 }
1188
1189 void GetMaskState(BOOL bCorrectSelection = TRUE)
1190 {
1191 if (!TBase::m_hWnd)
1192 return;
1193
1194 _ASSERTE(m_bUseMask);
1195
1196 MaskGetSel();
1197 TBase::GetWindowText(m_strWindowText);
1198
1199 _ASSERTE(m_strDefault.GetLength() == m_strLiteral.GetLength());
1200 _ASSERTE(m_strMask.GetLength() == m_strLiteral.GetLength());
1201
1202 CorrectWindowText();
1203
1204 if (bCorrectSelection)
1205 {
1206 CorrectPosition(m_nStartChar);
1207 CorrectPosition(m_nEndChar);
1208
1209 if (m_nEndChar < m_nStartChar)
1210 m_nEndChar = m_nStartChar;
1211 }
1212 }
1213
1214 void MaskGetSel() // To allow CEdit and CRichEditCtrl
1215 {
1216 if (TBase::m_hWnd)
1217 {
1218 TBase::SendMessage(EM_GETSEL, (WPARAM)&m_nStartChar, (LPARAM)&m_nEndChar);
1219 }
1220 }
1221
1222 void SetMaskState(BOOL bUpdateUndo = TRUE)
1223 {
1224 if (!TBase::m_hWnd)
1225 return;
1226
1227 _ASSERTE(m_bUseMask);
1228
1229 CString strWindowText;
1230 TBase::GetWindowText(strWindowText);
1231
1232 CorrectWindowText();
1233 TBase::HideCaret();
1234
1235 if (strWindowText != m_strWindowText)
1236 {
1237 TBase::SetWindowText(m_strWindowText);
1238
1239 if (bUpdateUndo || m_bUpdateUndo)
1240 m_strUndoBuffer = strWindowText;
1241
1242 m_bRedo = FALSE;
1243 m_bModified = TRUE;
1244 }
1245
1246 m_bUpdateUndo = bUpdateUndo;
1247
1248 TBase::SetSel(m_nStartChar, m_nEndChar);
1249 TBase::ShowCaret();
1250 }
1251
1266 virtual BOOL OnCommand(WPARAM wParam, LPARAM lParam)
1267 {
1268 switch (LOWORD(wParam))
1269 {
1270 case ID_EDIT_CUT: MaskCut(); return TRUE;
1271
1272 case ID_EDIT_COPY: MaskCopy(); return TRUE;
1273
1274 case ID_EDIT_PASTE: MaskPaste(); return TRUE;
1275
1276 case ID_EDIT_CLEAR: MaskClear(); return TRUE;
1277
1278 case ID_EDIT_UNDO: MaskUndo(); return TRUE;
1279
1280 case ID_EDIT_SELECT_ALL: MaskSelectAll(); return TRUE;
1281 }
1282 return TBase::OnCommand(wParam, lParam);
1283 }
1284
1285protected:
1286 int m_nStartChar;
1287 int m_nEndChar;
1289 BOOL m_bUseMask;
1290 BOOL m_bOverType;
1291 BOOL m_bRedo;
1292 BOOL m_bModified;
1293 TCHAR m_chPrompt;
1294 CString m_strMask;
1295 CString m_strDefault;
1296 CString m_strUndoBuffer;
1297 CString m_strRedoBuffer;
1298 CString m_strWindowText;
1299 CString m_strLiteral;
1300 BOOL m_bUpdateUndo;
1301};
1302
1304# define ON_MESSAGE_BOOL(message, memberFxn) \
1305 { \
1306 message, 0, 0, \
1307 0, AfxSig_bv, (AFX_PMSG)(AFX_PMSGW)(BOOL(AFX_MSG_CALL CWnd::*)(void)) & memberFxn \
1308 },
1309
1310# define ON_MASKEDIT_REFLECT \
1311 ON_MESSAGE_BOOL(WM_CUT, MaskCut) \
1312 ON_MESSAGE_BOOL(WM_PASTE, MaskPaste) \
1313 ON_MESSAGE_BOOL(WM_CLEAR, MaskClear) \
1314 ON_MESSAGE_BOOL(WM_UNDO, MaskUndo) \
1315 ON_MESSAGE_BOOL(WM_COPY, MaskCopy) \
1316 ON_WM_KEYDOWN() \
1317 ON_WM_CHAR() \
1318 ON_WM_SETFOCUS
1319
1322
1323# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
1325#endif // #if !defined(__XTMASKEDITEX_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPMaskEditT
CXTPMaskEditT is a template class.
Definition XTPMaskEditT.h:45
CXTPMaskEditT::m_bUpdateUndo
BOOL m_bUpdateUndo
TRUE to update undo.
Definition XTPMaskEditT.h:1300
CXTPMaskEditT::ConvertUnicodeAlpha
TCHAR ConvertUnicodeAlpha(TCHAR nChar, BOOL bUpperCase) const
Converts character to Upper/Lower case.
Definition XTPMaskEditT.h:528
CXTPMaskEditT::SetOverType
void SetOverType(BOOL bOverType)
This member function is called to enable or disable type over, also known as insert mode.
Definition XTPMaskEditT.h:99
CXTPMaskEditT::m_bOverType
BOOL m_bOverType
TRUE to over type the text, set with VK_INSERT key press.
Definition XTPMaskEditT.h:1290
CXTPMaskEditT::GetPromptString
CString GetPromptString(int nLength) const
This helper member function retrieves the string contains nLength prompt characters.
Definition XTPMaskEditT.h:147
CXTPMaskEditT::InsertCharAt
void InsertCharAt(int iPos, TCHAR nChar)
Inserts character to specified position.
Definition XTPMaskEditT.h:754
CXTPMaskEditT::DeleteCharAt
void DeleteCharAt(int iPos)
Deletes character in specified position.
Definition XTPMaskEditT.h:736
CXTPMaskEditT::m_strUndoBuffer
CString m_strUndoBuffer
Holds the contents of the undo buffer.
Definition XTPMaskEditT.h:1296
CXTPMaskEditT::m_bUseMask
BOOL m_bUseMask
TRUE to use the edit mask.
Definition XTPMaskEditT.h:1289
CXTPMaskEditT::m_strDefault
CString m_strDefault
Contains the edit controls default display text.
Definition XTPMaskEditT.h:1295
CXTPMaskEditT::m_bModified
BOOL m_bModified
TRUE if mask edit has been modified.
Definition XTPMaskEditT.h:1292
CXTPMaskEditT::MaskSelectAll
afx_msg void MaskSelectAll()
This member function is called to select all text in the mask edit control.
Definition XTPMaskEditT.h:373
CXTPMaskEditT::m_strLiteral
CString m_strLiteral
Literal format that restricts where the user can enter text.
Definition XTPMaskEditT.h:1299
CXTPMaskEditT::CXTPMaskEditT
CXTPMaskEditT()
Constructs a CXTPMaskEditT object.
Definition XTPMaskEditT.h:51
CXTPMaskEditT::MaskDeleteSel
void MaskDeleteSel()
This member function is called to delete the selection.
Definition XTPMaskEditT.h:303
CXTPMaskEditT::MaskUndo
afx_msg BOOL MaskUndo()
This member function is called to undo the previous action.
Definition XTPMaskEditT.h:338
CXTPMaskEditT::m_nStartChar
int m_nStartChar
Current position of the first character in the current selection.
Definition XTPMaskEditT.h:1286
CXTPMaskEditT::CheckChar
virtual BOOL CheckChar(TCHAR &nChar, int nPos)
This member function is used internally to validate the character indicated by 'nChar'.
Definition XTPMaskEditT.h:547
CXTPMaskEditT::SetMaskedText
void SetMaskedText(LPCTSTR lpszMaskedText, int iPos=0, BOOL bUpdateWindow=TRUE)
This method called to set masked text for the edit control.
Definition XTPMaskEditT.h:412
CXTPMaskEditT::MaskClear
afx_msg BOOL MaskClear()
This member function is called to clear the current text selection.
Definition XTPMaskEditT.h:319
CXTPMaskEditT::MaskCopy
afx_msg BOOL MaskCopy()
This member function is called to perform a copy operation using the currently selected text.
Definition XTPMaskEditT.h:210
CXTPMaskEditT::m_strWindowText
CString m_strWindowText
Buffer that holds the actual edit text.
Definition XTPMaskEditT.h:1298
CXTPMaskEditT::m_strMask
CString m_strMask
Buffer that holds the actual edit mask value.
Definition XTPMaskEditT.h:1294
CXTPMaskEditT::MaskReplaceSel
void MaskReplaceSel(LPCTSTR lpszNewText)
This member function is called to perform a replace operation using the currently selected text.
Definition XTPMaskEditT.h:229
CXTPMaskEditT::m_strRedoBuffer
CString m_strRedoBuffer
Holds the contents of the redo buffer.
Definition XTPMaskEditT.h:1297
CXTPMaskEditT::IsModified
BOOL IsModified() const
This member function is called to determine if the text has been modified.
Definition XTPMaskEditT.h:393
CXTPMaskEditT::m_nEndChar
int m_nEndChar
Current position of the first non-selected character past the end of the current selection.
Definition XTPMaskEditT.h:1287
CXTPMaskEditT::OnCommand
virtual BOOL OnCommand(WPARAM wParam, LPARAM lParam)
The framework calls this member function when the user selects an item from a menu.
Definition XTPMaskEditT.h:1266
CXTPMaskEditT::CanUseMask
BOOL CanUseMask() const
This member function is called to determine if the mask for the edit control can be used.
Definition XTPMaskEditT.h:87
CXTPMaskEditT::PosInRange
BOOL PosInRange(int iPos) const
This member function is called to determine if the index specified by 'iPos' is a valid index for the...
Definition XTPMaskEditT.h:123
CXTPMaskEditT::ProcessMask
virtual BOOL ProcessMask(TCHAR &nChar, int nEndPos)
This member function is used internally to process the character passed in by 'nChar' whose index is ...
Definition XTPMaskEditT.h:576
CXTPMaskEditT::m_chPrompt
TCHAR m_chPrompt
Prompt character used to identify the text entry.
Definition XTPMaskEditT.h:1293
CXTPMaskEditT::MaskCut
afx_msg BOOL MaskCut()
This member function is called to perform a cut operation using the currently selected text.
Definition XTPMaskEditT.h:193
CXTPMaskEditT::PreTranslateMessage
virtual BOOL PreTranslateMessage(MSG *pMsg)
Used by class CWinApp to translate window messages before they are dispatched to theTranslateMessage ...
Definition XTPMaskEditT.h:671
CXTPMaskEditT::CanOverType
BOOL CanOverType() const
This member function is called to determine if type over has been enabled.
Definition XTPMaskEditT.h:110
CXTPMaskEditT::GetMaskedText
CString GetMaskedText(int nStartPos=0, int nEndPos=-1) const
Retrieves masked text of the control.
Definition XTPMaskEditT.h:813
CXTPMaskEditT::MaskPaste
afx_msg BOOL MaskPaste()
This member function is called to perform a paste operation using the current clipboard text.
Definition XTPMaskEditT.h:268
CXTPMaskEditT::SetPromptChar
void SetPromptChar(TCHAR ch, BOOL bAutoReplace=TRUE)
This member function is called to set the prompt character that is displayed to the user that indicat...
Definition XTPMaskEditT.h:164
CXTPMaskEditT::SetUseMask
void SetUseMask(BOOL bUseMask)
Call this member function to enable or disable the mask for the mask edit control.
Definition XTPMaskEditT.h:75
CXTPMaskEditT::SetEditMask
virtual BOOL SetEditMask(LPCTSTR lpszMask, LPCTSTR lpszLiteral, LPCTSTR lpszDefault=NULL)
This member function will set the mask for the edit control.
Definition XTPMaskEditT.h:480
CXTPMaskEditT::GetPromptChar
TCHAR GetPromptChar() const
This member function retrieves the character that is currently used as the mask prompt.
Definition XTPMaskEditT.h:135
CXTPMaskEditT::CopyToClipboard
BOOL CopyToClipboard(const CString &strText)
Copies text to system clipboard.
Definition XTPMaskEditT.h:773
CXTPMaskEditT::m_bRedo
BOOL m_bRedo
TRUE to redo, or FALSE to undo.
Definition XTPMaskEditT.h:1291


Toolkit Pro: XTPScrollBarThemeWindowsClassic.h Source File

  • Source
  • Common
  • ScrollBar
  • Themes
XTPScrollBarThemeWindowsClassic.h
Go to the documentation of this file.
1
23#if !defined(__XTPSCROLLBARTHEMEWINDOWSCLASSIC_H__)
24# define __XTPSCROLLBARTHEMEWINDOWSCLASSIC_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPScrollBarThemeWindowsClassic : public CXTPScrollBarPaintManager
39{
40protected:
48 virtual void DrawButtons(CDC* pDC, CXTPScrollBase* pScroll, XTPScrollMetricsV* pMetrics);
49
57 virtual void DrawTracker(CDC* pDC, CXTPScrollBase* pScroll, XTPScrollMetricsV* pMetrics);
58
66 virtual void DrawButtons(CDC* pDC, CXTPScrollBase* pScroll, XTPScrollMetricsH* pMetrics);
67
75 virtual void DrawTracker(CDC* pDC, CXTPScrollBase* pScroll, XTPScrollMetricsH* pMetrics);
76
83 virtual void DrawGripper(CDC* pDC, CXTPScrollBase* pScroll);
84};
85
86# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
88#endif /*__XTPSCROLLBARTHEMEWINDOWSCLASSIC_H__*/
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPScrollBarPaintManager
CXTPScrollBarPaintManager is standalone class used to draw CXTPCommandBarScrollBarCtrl object.
Definition XTPScrollBarPaintManager.h:40
CXTPScrollBarThemeWindowsClassic
Scrollbar paint manager used to draw classic Windows scrollbars.
Definition XTPScrollBarThemeWindowsClassic.h:39
CXTPScrollBarThemeWindowsClassic::DrawButtons
virtual void DrawButtons(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar buttons only.
CXTPScrollBarThemeWindowsClassic::DrawTracker
virtual void DrawTracker(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar trackers only.
CXTPScrollBarThemeWindowsClassic::DrawGripper
virtual void DrawGripper(CDC *pDC, CXTPScrollBase *pScroll)
Draws scrollbar gripper only.
CXTPScrollBarThemeWindowsClassic::DrawButtons
virtual void DrawButtons(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws vertical scrollbar buttons only.
CXTPScrollBarThemeWindowsClassic::DrawTracker
virtual void DrawTracker(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws vertical scrollbar trackers only.
CXTPScrollBase
CXTPScrollBase is the base class for all scrollable objects.
Definition XTPScrollBase.h:222


Toolkit Pro: Member List

XTP_URI Member List

This is the complete list of members for XTP_URI, including all inherited members.

file | XTP_URI
lpName | XTP_URI
lpType | XTP_URI
res | XTP_URI
reserved | XTP_URI
szFilePath | XTP_URI
type | XTP_URI


Toolkit Pro: Member List

CXTPCalendarMemoryDataProvider Member List

This is the complete list of members for CXTPCalendarMemoryDataProvider, including all inherited members.

_Load(CXTPPropExchange *pPX) | CXTPCalendarMemoryDataProvider | protectedvirtual
_Save(CXTPPropExchange *pPX) | CXTPCalendarMemoryDataProvider | protectedvirtual
AddEvent(CXTPCalendarEvent *pEvent) | CXTPCalendarData | virtual
AddEventCategory(UINT uID, CString strName, COLORREF crBorder, COLORREF crBkBase) | CXTPCalendarData | virtual
AddEventLabel(int nID, CString strName, COLORREF crLabel) | CXTPCalendarData | virtual
AddEvents(CXTPCalendarEvents *pEvents) | CXTPCalendarData | virtual
ChangeEvent(CXTPCalendarEvent *pNewEvent) | CXTPCalendarData | virtual
ClearCache() | CXTPCalendarData | virtual
ClearEventCategoryList() | CXTPCalendarData | virtual
ClearEventLabelList() | CXTPCalendarData | virtual
Close() | CXTPCalendarMemoryDataProvider | virtual
Create() | CXTPCalendarMemoryDataProvider | virtual
CreateDataProvider(LPCTSTR lpszConnectionString) | CXTPCalendarData | static
CreateDataProvider(XTPCalendarDataProvider eDataProvider) | CXTPCalendarData | static
CreateNewEvent(DWORD dwEventID=XTP_CALENDAR_UNKNOWN_EVENT_ID) | CXTPCalendarData | virtual
CreateNewRecurrencePattern(DWORD dwPatternID=XTP_CALENDAR_UNKNOWN_RECURRENCE_PATTERN_ID) | CXTPCalendarData | virtual
CXTPCalendarData() | CXTPCalendarData |
CXTPCalendarMemoryDataProvider() | CXTPCalendarMemoryDataProvider |
CXTPCmdTarget() | CXTPCmdTarget |
DataProviderTypeFromConStr(LPCTSTR lpszConnectionString, XTPCalendarDataProvider eDPDefault=xtpCalendarDataProviderUnknown) | CXTPCalendarData | static
DataSourceFromConStr(LPCTSTR lpszConnectionString) | CXTPCalendarData | static
DeleteEvent(CXTPCalendarEvent *pEvent) | CXTPCalendarData | virtual
DoCreate_Event(CXTPCalendarEvent *pEvent, DWORD &rdwNewEventID) | CXTPCalendarMemoryDataProvider | protectedvirtual
DoCreate_RPattern(CXTPCalendarRecurrencePattern *pPattern, DWORD &rdwNewPatternID) | CXTPCalendarMemoryDataProvider | protectedvirtual
DoDelete_Event(CXTPCalendarEvent *pEvent) | CXTPCalendarMemoryDataProvider | protectedvirtual
DoDelete_RPattern(CXTPCalendarRecurrencePattern *pPattern) | CXTPCalendarMemoryDataProvider | protectedvirtual
DoGetAllEvents_raw() | CXTPCalendarMemoryDataProvider | protectedvirtual
DoGetUpcomingEvents(COleDateTime dtFrom, COleDateTimeSpan spPeriod) | CXTPCalendarMemoryDataProvider | protectedvirtual
DoPropExchange(CXTPPropExchange *pPX) | CXTPCalendarMemoryDataProvider | virtual
DoRead_Event(DWORD dwEventID) | CXTPCalendarMemoryDataProvider | protectedvirtual
DoRead_RPattern(DWORD dwPatternID) | CXTPCalendarMemoryDataProvider | protectedvirtual
DoRemoveAllEvents() | CXTPCalendarMemoryDataProvider | protectedvirtual
DoRetrieveDayEvents(COleDateTime dtDay) | CXTPCalendarMemoryDataProvider | protectedvirtual
DoUpdate_Event(CXTPCalendarEvent *pEvent) | CXTPCalendarMemoryDataProvider | protectedvirtual
DoUpdate_RPattern(CXTPCalendarRecurrencePattern *pPattern) | CXTPCalendarMemoryDataProvider | protectedvirtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAllEvents_raw() | CXTPCalendarData | virtual
GetCacheMode() const | CXTPCalendarData | virtual
GetConnection() const | CXTPCalendarData | virtual
GetConnectionString() const | CXTPCalendarData | virtual
GetCustomProperties() const | CXTPCalendarData | virtual
GetDataSource() | CXTPCalendarData | virtual
GetEvent(DWORD dwEventID) | CXTPCalendarData | virtual
GetEventCategories() const | CXTPCalendarData | virtual
GetLabelList() const | CXTPCalendarData | virtual
GetNextFreeTempID() | CXTPCalendarData | protectedstatic
GetRecurrencePattern(DWORD dwPatternID) | CXTPCalendarData | virtual
GetSchedules() const | CXTPCalendarData | virtual
GetType() const | CXTPCalendarData | virtual
GetUpcomingEvents(COleDateTime dtFrom=(DATE) 0, COleDateTimeSpan spPeriod=(DATE) 0) | CXTPCalendarData | virtual
IsOpen() const | CXTPCalendarData | virtual
m_bDisableNotificationsSending | CXTPCalendarData | protected
m_bOpened | CXTPCalendarData | protected
m_pCalendarOptions | CXTPCalendarData | protected
m_pConnection | CXTPCalendarData | protected
m_pCustomProperties | CXTPCalendarData | protected
m_pEventCategories | CXTPCalendarData | protected
m_pLabelList | CXTPCalendarData | protected
m_pSchedules | CXTPCalendarData | protected
m_strConnectionString | CXTPCalendarData | protected
m_typeProvider | CXTPCalendarData | protected
ms_dwNextFreeTempID | CXTPCalendarData | protectedstatic
OnTimeZoneChanged() | CXTPCalendarMemoryDataProvider | inlineprotectedvirtual
Open() | CXTPCalendarMemoryDataProvider | virtual
RemoveAllEvents() | CXTPCalendarData | virtual
RestoreEventCategoryList() | CXTPCalendarData | virtual
RestoreEventLabelList() | CXTPCalendarData | virtual
RetrieveDayEvents(COleDateTime dtDay) | CXTPCalendarData | virtual
RetrieveEvents(COleDateTime dtStartDay, COleDateTime dtEndDay) | CXTPCalendarMemoryDataProvider | virtual
Save() | CXTPCalendarMemoryDataProvider | virtual
SendNotification(XTP_NOTIFY_CODE EventCode, WPARAM wParam, LPARAM lParam) | CXTPCalendarData | protectedvirtual
Serialize(CArchive &ar) | CXTPCalendarMemoryDataProvider | virtual
SetCacheMode(int eCacheMode, CXTPCalendarData *pCacheDataProvider=NULL) | CXTPCalendarData | virtual
SetConnectionString(LPCTSTR lpszConnectionString) | CXTPCalendarData | virtual
SetLabelList(CXTPCalendarEventLabels *pLabelList) | CXTPCalendarData | virtual
UpdateEventCategories(COLORREF *pClrBkBase, COLORREF *pClrBorder, int nCount) | CXTPCalendarData |
UpdateEventLabels(COLORREF *clrEventColors, UINT uCount) | CXTPCalendarData | virtual
~CXTPCalendarData() | CXTPCalendarData | virtual
~CXTPCalendarMemoryDataProvider() | CXTPCalendarMemoryDataProvider | virtual


Toolkit Pro: Member List

CXTPChart3dPyramidSeriesLabelsView Member List

This is the complete list of members for CXTPChart3dPyramidSeriesLabelsView, including all inherited members.

AddChildView(CXTPChartElementView *pChildView) | CXTPChartElementView |
CreateDeviceCommand(CXTPChartDeviceContext *pDC) | CXTPChart3dPyramidSeriesLabelsView | virtual
CXTPChart3dPyramidSeriesLabelsView(CXTPChartElementView *pParentView) | CXTPChart3dPyramidSeriesLabelsView |
CXTPChartElementView(CXTPChartElementView *pParentView) | CXTPChartElementView |
CXTPChartElementView(CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartElementView |
CXTPChartElementView(CXTPChartContainer *pContainer) | CXTPChartElementView |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
GetAt(int nIndex) const | CXTPChartElementView |
GetBounds() const | CXTPChartElementView |
GetBounds(BOOL bIncludingChildren) const | CXTPChartElementView |
GetChildren() | CXTPChartElementView |
GetCount() const | CXTPChartElementView |
GetParentView() const | CXTPChartElementView |
Is3D() const | CXTPChartObject |
m_arrChildren | CXTPChartElementView | protected
m_pContainer | CXTPChartElementView | protected
m_pParentView | CXTPChartElementView | protected
m_rcBounds | CXTPChartElementView | protected
ResolveOverlapping() | CXTPChart3dPyramidSeriesLabelsView |
~CXTPChartElementView() | CXTPChartElementView | protectedvirtual


Toolkit Pro: Member List

  • CXTPListBase
  • ROWCOLOR
CXTPListBase::ROWCOLOR Member List

This is the complete list of members for CXTPListBase::ROWCOLOR, including all inherited members.

crBack | CXTPListBase::ROWCOLOR
crText | CXTPListBase::ROWCOLOR
iRow | CXTPListBase::ROWCOLOR
lParam | CXTPListBase::ROWCOLOR


Toolkit Pro: XTPTabThemeVisualStudio2017.h Source File

  • Source
  • TabManager
  • Themes
XTPTabThemeVisualStudio2017.h
Go to the documentation of this file.
1
23#if !defined(__XTPTABTHEMEVISUALSTUDIO2017_H__)
24# define __XTPTABTHEMEVISUALSTUDIO2017_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
37class _XTP_EXT_CLASS CXTPTabThemeVisualStudio2017 : public CXTPTabThemeVisualStudio2015
38{
39public:
44 CXTPTabThemeVisualStudio2017();
45
54 virtual void RefreshMetrics();
55
64 virtual XTPTabColorStyle GetDefaultColorSet()
65 {
66 return xtpTabColorVisualStudio2017;
67 }
68};
69
70# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
72#endif // __XTPTABTHEMEVISUALSTUDIO2017_H__
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPTabColorStyle
XTPTabColorStyle
XTPTabColorStyle is an enumeration used to set the color style of tabs.
Definition XTPTabManagerDefines.h:139
xtpTabColorVisualStudio2017
@ xtpTabColorVisualStudio2017
Tabs will use the Visual Studio 2017 color style for the currently set Appearance.
Definition XTPTabManagerDefines.h:170
CXTPTabThemeVisualStudio2015
CXTPTabThemeVisualStudio2015 implements a Visual Studio 2015 tab appearance.
Definition XTPTabThemeVisualStudio2015.h:38
CXTPTabThemeVisualStudio2017
CXTPTabThemeVisualStudio2017 implements a Visual Studio 2017 tab appearance.
Definition XTPTabThemeVisualStudio2017.h:38
CXTPTabThemeVisualStudio2017::GetDefaultColorSet
virtual XTPTabColorStyle GetDefaultColorSet()
Gets the default value of the color set for this theme.
Definition XTPTabThemeVisualStudio2017.h:64
CXTPTabThemeVisualStudio2017::CXTPTabThemeVisualStudio2017
CXTPTabThemeVisualStudio2017()
Constructs a CXTPTabThemeVisualStudio2017 object.
CXTPTabThemeVisualStudio2017::RefreshMetrics
virtual void RefreshMetrics()
Refreshes the appearance metrics.


Toolkit Pro: Member List

  • CXTPSyntaxEditCtrl
  • CAverageVal
CXTPSyntaxEditCtrl::CAverageVal Member List

This is the complete list of members for CXTPSyntaxEditCtrl::CAverageVal, including all inherited members.

AddValue(UINT uVal) | CXTPSyntaxEditCtrl::CAverageVal |
CAverageVal(int nDataSize=100) | CXTPSyntaxEditCtrl::CAverageVal |
GetAverageValue(UINT uDefaultIfNoData=0) | CXTPSyntaxEditCtrl::CAverageVal |
m_arData | CXTPSyntaxEditCtrl::CAverageVal | protected
m_nDataSize | CXTPSyntaxEditCtrl::CAverageVal | protected
m_nNextIndex | CXTPSyntaxEditCtrl::CAverageVal | protected


Toolkit Pro: Member List

CXTPChartLineSeriesErrorBarView Member List

This is the complete list of members for CXTPChartLineSeriesErrorBarView, including all inherited members.

AddChildView(CXTPChartElementView *pChildView) | CXTPChartElementView |
CXTPChartElementView(CXTPChartElementView *pParentView) | CXTPChartElementView |
CXTPChartElementView(CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartElementView |
CXTPChartElementView(CXTPChartContainer *pContainer) | CXTPChartElementView |
CXTPChartLineSeriesErrorBarView(CXTPChartErrorBar *pErrorBar, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView) | CXTPChartLineSeriesErrorBarView |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
GetAt(int nIndex) const | CXTPChartElementView |
GetBounds() const | CXTPChartElementView |
GetBounds(BOOL bIncludingChildren) const | CXTPChartElementView |
GetChildren() | CXTPChartElementView |
GetCount() const | CXTPChartElementView |
GetParentView() const | CXTPChartElementView |
Is3D() const | CXTPChartObject |
m_arrChildren | CXTPChartElementView | protected
m_pContainer | CXTPChartElementView | protected
m_pParentView | CXTPChartElementView | protected
m_rcBounds | CXTPChartElementView | protected
~CXTPChartElementView() | CXTPChartElementView | protectedvirtual


Toolkit Pro: Member List

CXTPGridRecordItemControls Member List

This is the complete list of members for CXTPGridRecordItemControls, including all inherited members.

Add(ARG_TYPE newElement) | CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE > | virtual
AddControl(int nType, int nIndex=-1) | CXTPGridRecordItemControls |
AddControl(CXTPGridRecordItemControl *pControl, int nIndex=-1) | CXTPGridRecordItemControls |
AddIfNeed(ARG_TYPE newElement) | CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE > | virtual
Append(const CXTPArrayT &src) | CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE > | virtual
Copy(const CXTPArrayT &src) | CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE > | virtual
CopyFrom(CXTPGridRecordItemControls *pSrc) | CXTPGridRecordItemControls | virtual
CXTPArrayT() | CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE > |
CXTPCmdTarget() | CXTPCmdTarget |
CXTPGridRecordItemControls() | CXTPGridRecordItemControls |
CXTPGridRecordItemControls(CXTPGridRecordItem *pRecordItem) | CXTPGridRecordItemControls |
DoPropExchange(CXTPPropExchange *pPX) | CXTPGridRecordItemControls | virtual
ElementAt(int nIndex) | CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE > | virtual
FindElement(ARG_TYPE nElement) const | CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE > | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAt(int nIndex) const | CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE > | virtual
GetData() const | CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE > | virtual
GetData() | CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE > | virtual
GetSize() const | CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE > | virtual
InsertAt(int nIndex, ARG_TYPE newElement, int nCount=1) | CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE > | virtual
InsertAt(int nStartIndex, CXTPArrayT *pNewArray) | CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE > | virtual
m_arElements | CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE > | protected
m_pRecordItem | CXTPGridRecordItemControls |
operator[](int nIndex) const | CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE > |
operator[](int nIndex) | CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE > |
RefreshIndexes(int nIndexStart=0) | CXTPGridRecordItemControls | protectedvirtual
RemoveAll() | CXTPGridRecordItemControls | virtual
RemoveAt(int nIndex) | CXTPGridRecordItemControls | virtual
RemoveAt(int nIndex, int nCount) | CXTPGridRecordItemControls | virtual
RemoveElement(ARG_TYPE nElement) | CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE > | virtual
SetAt(int nIndex, ARG_TYPE newElement) | CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE > | virtual
SetAtGrow(int nIndex, ARG_TYPE newElement) | CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE > | virtual
SetSize(int nNewSize, int nGrowBy=-1) | CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE > | virtual
~CXTPArrayT() | CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE > | virtual
~CXTPGridRecordItemControls() | CXTPGridRecordItemControls |


Toolkit Pro: XTPMarkupGdiPlusDeviceContext.h Source File

  • Source
  • Markup
  • DeviceContext
XTPMarkupGdiPlusDeviceContext.h
Go to the documentation of this file.
1
23#if !defined(__XTPMARKUPGDIPLUSDEVICECONTEXT_H__)
24# define __XTPMARKUPGDIPLUSDEVICECONTEXT_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33struct IXTPMarkupDeviceDependentImageSite;
34class CXTPMarkupTransformationMatrix;
35class CXTPMarkupDeviceDependentImage;
36class CXTPMarkupDedicatedDC;
37class CXTPMarkupStrokeStyle;
38class CXTPMarkupBrush;
39class CXTPMarkupThickness;
40class CXTPImageManagerIcon;
41class CXTPMarkupFont;
42
43class _XTP_EXT_CLASS CXTPMarkupGdiPlusDeviceContext : public CXTPMarkupDeviceContext
44{
45 DECLARE_DYNAMIC(CXTPMarkupGdiPlusDeviceContext);
46 class DedicatedDC;
47
48public:
49 CXTPMarkupGdiPlusDeviceContext(Gdiplus::GpGraphics* pGpGraphics, BOOL bSharedAccess = TRUE);
50 virtual ~CXTPMarkupGdiPlusDeviceContext();
51
52public:
53 virtual void GetClipBox(LPRECT lpRect);
54 virtual void IntersectClipRect(const RECT& rcLayoutClip);
55 virtual HRGN SaveClipRegion();
56 virtual void RestoreClipRegion(HRGN hRgn);
57 virtual void OffsetViewport(const POINT& ptViewortOrg);
58 virtual XTPMarkupSmoothingMode SetSmoothingMode(XTPMarkupSmoothingMode smoothingMode,
59 BOOL bUseTextSmoothing);
60 virtual CXTPMarkupTransformationMatrix* GetTransformationMatrix() const;
61 virtual void SetTransformationMatrix(CXTPMarkupTransformationMatrix* pMatrix);
62
63 virtual CXTPMarkupDedicatedDC* GetDedicatedDC(const RECT& rect);
64 virtual CXTPMarkupDeviceDependentImage*
65 CreateDeviceDependentImage(IXTPMarkupDeviceDependentImageSite* pSite) const;
66
67 virtual void Ellipse(CRect rc, CXTPMarkupStrokeStyle* pStrokeStyle,
68 CXTPMarkupBrush* pFillBrush);
69 virtual void DrawRectangle(CRect rc, CXTPMarkupBrush* pBrush, CXTPMarkupThickness* pThickness);
70 virtual void FillRectangle(CRect rc, CXTPMarkupBrush* pBrush);
71 virtual void DrawLine(int x1, int y1, int x2, int y2, CXTPMarkupStrokeStyle* pStrokeStyle);
72 virtual void Polyline(const POINT* points, int nCount, CXTPMarkupStrokeStyle* pStrokeStyle);
73 virtual void Polyline(const void* points, int nCount, CXTPMarkupStrokeStyle* pStrokeStyle);
74 virtual void Polygon(const POINT* points, int nCount, CXTPMarkupStrokeStyle* pStrokeStyle,
75 CXTPMarkupBrush* pFillBrush);
76 virtual void Polygon(const void* points, int nCount, CXTPMarkupStrokeStyle* pStrokeStyle,
77 CXTPMarkupBrush* pFillBrush);
78
79 virtual void DrawPath(CXTPMarkupPathData* pData, CXTPMarkupStrokeStyle* pStrokeStyle,
80 CXTPMarkupBrush* pFillBrush);
81
82 virtual void DrawImage(CXTPImageManagerIcon* pIcon, CRect rc);
83 virtual void DrawVectorImage(CXTPImageManagerIcon* pIcon, CRect rc,
84 CXTPMarkupDeviceDependentImage* pImage);
85 virtual void DrawImage(CXTPMarkupDeviceDependentImage* pImage, CRect rc);
86
87 virtual BOOL GetFontMetrics(CXTPMarkupFont* pFont, XTPMarkupFontMetrics* pMetrics);
88 virtual void SetTextFont(CXTPMarkupFont* pFont);
89 virtual void SetTextColor(CXTPMarkupBrush* pBrush);
90 virtual SIZE MeasureString(LPCWSTR lpszText, int nCount) const;
91 virtual void MeasureString(LPCWSTR lpszText, int nCount, CXTPSizeF& size) const;
92 virtual void DrawString(LPCWSTR lpszString, UINT nCount, LPCRECT lpRect);
93
94 virtual HDC GetDC();
95 virtual void ReleaseDC(HDC hDC);
96 virtual void Flush();
97
98public:
100 _XTP_DEPRECATED
101 static CXTPGdiPlus* AFX_CDECL GetGdiPlus();
104 static void AFX_CDECL Register(BOOL bInit);
105
106 static Gdiplus::GpGraphics* AFX_CDECL CreateGraphics(HDC hDC, HDC hAttribDC);
107 Gdiplus::GpGraphics* GetGraphics() const;
108
109protected:
110 void Init(BOOL bReInit = FALSE);
111 BOOL IsRTL() const;
112 Gdiplus::Status GdipCreateBitmapFromHICON_Fixed(HICON hicon, Gdiplus::GpBitmap** bitmap) const;
113 Gdiplus::GpFont* AccessFont();
114 const Gdiplus::GpFont* AccessFont() const;
115 void ApplySmoothingMode();
116 Gdiplus::GpBrush* CreateGpBrush(CXTPMarkupBrush* pBrush, LPCRECT lpRect) const;
117 Gdiplus::GpBrush* CreateGpBrush(CXTPMarkupBrush* pBrush, const Gdiplus::GpRectF& lpRect) const;
118 Gdiplus::GpPen* CreateGpPen(CXTPMarkupStrokeStyle* pStrokeStyle, LPCRECT lpRect) const;
119 Gdiplus::GpPen* CreateGpPen(CXTPMarkupStrokeStyle* pStrokeStyle,
120 const Gdiplus::GpRectF& lpRect) const;
121 CRect GetPointsBoundRect(const POINT* points, int nCount) const;
122 Gdiplus::GpRectF GetPointsBoundRect(const Gdiplus::GpPointF* points, int nCount) const;
123 BOOL IsGDIBrush(CXTPMarkupBrush* pBrush) const;
124 Gdiplus::GpBitmap* IconToGdiplusBitmap(CXTPImageManagerIcon* pIcon, CSize& szImage) const;
125 void DrawGpImage(Gdiplus::GpImage* pImage, CRect rc, CSize size,
126 CXTPMarkupContext* pContext = NULL) const;
127
128protected:
129 Gdiplus::PixelOffsetMode m_defaultPixelOffsetMode;
130 Gdiplus::SmoothingMode m_gdipSmoothingMode;
131 Gdiplus::InterpolationMode m_gdipInterpolationMode;
132 Gdiplus::TextRenderingHint m_gdipTextRenderingHint;
134 _XTP_DEPRECATED CXTPGdiPlus* m_pGdiPlus;
136 BOOL m_bGpGraphicsSharedAccess;
137 Gdiplus::GpGraphics* m_pGraphics;
138 Gdiplus::GpFont* m_pGpFont;
139 Gdiplus::GpBrush* m_pGpTextBrush;
140 Gdiplus::GpStringFormat* m_pGpStringFormat;
141 BOOL m_bRTL;
142};
143
144# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
146#endif // !defined(__XTPMARKUPGDIPLUSDEVICECONTEXT_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPMarkupSmoothingMode
XTPMarkupSmoothingMode
Defines markup smoothing mode.
Definition XTPMarkupContext.h:69
CXTPImageManagerIcon
Icons holder class.
Definition XTPImageManager.h:622
CXTPMarkupContext
CXTPMarkupContext is a standalone class used to provide common settings for Markup objects.
Definition XTPMarkupContext.h:128
CXTPMarkupDeviceDependentImage
Implements an abstract device dependent image.
Definition XTPMarkupDeviceDependentImage.h:73
CXTPMarkupThickness
The CXTPMarkupThickness class describes the thickness of the left, top, right, and bottom sides of a ...
Definition XTPMarkupThickness.h:42
CXTPMarkupTransformationMatrix
An abstract class for device context transformation matrix.
Definition XTPMarkupTransformationMatrix.h:40
CXTPSizeT
This class incapsulates size data.
Definition XTPSize.h:40
IXTPMarkupDeviceDependentImageSite
Describes an image site interface.
Definition XTPMarkupDeviceDependentImage.h:40


Toolkit Pro: XTPMarkupGridLength.h Source File

  • Source
  • Markup
  • Controls
XTPMarkupGridLength.h
Go to the documentation of this file.
1
23#if !defined(__XTPMARKUPGRIDLENGTH_H__)
24# define __XTPMARKUPGRIDLENGTH_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPMarkupObject;
34class CXTPMarkupBuilder;
35
40class _XTP_EXT_CLASS CXTPMarkupGridLength : public CXTPMarkupObject
41{
43 DECLARE_MARKUPCLASS(CXTPMarkupGridLength);
45public:
50 enum GridUnitType
51 {
52 unitTypeAuto,
53 unitTypePixel,
54 unitTypeStar
55 };
56
57public:
65 CXTPMarkupGridLength(double nValue = 0, GridUnitType type = unitTypePixel);
66
76 GridUnitType GetUnitType() const;
77
84 double GetValue() const;
85
92 BOOL IsStar() const
93 {
94 return m_type == unitTypeStar;
95 }
96
103 BOOL IsAuto() const
104 {
105 return m_type == unitTypeAuto;
106 }
107
108public:
117 CXTPMarkupObject* ConvertFrom(CXTPMarkupBuilder* pBuilder, CXTPMarkupObject* pObject) const;
118
119public:
120 double m_nValue;
121 GridUnitType m_type;
122};
123
124AFX_INLINE CXTPMarkupGridLength::GridUnitType CXTPMarkupGridLength::GetUnitType() const
125{
126 return m_type;
127};
128
129AFX_INLINE double CXTPMarkupGridLength::GetValue() const
130{
131 return m_nValue;
132}
133
134# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
136#endif // !defined(__XTPMARKUPGRIDLENGTH_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPMarkupGridLength
CXTPMarkupGridLength is a class defined length of grid rows and columns.
Definition XTPMarkupGridLength.h:41
CXTPMarkupGridLength::GetUnitType
GridUnitType GetUnitType() const
Gets the unit type of the length.
Definition XTPMarkupGridLength.h:124
CXTPMarkupGridLength::m_type
GridUnitType m_type
Unit type.
Definition XTPMarkupGridLength.h:121
CXTPMarkupGridLength::GetValue
double GetValue() const
Gets the value of the length.
Definition XTPMarkupGridLength.h:129
CXTPMarkupGridLength::IsAuto
BOOL IsAuto() const
Determines if the length is calculated automatically (unitTypeAuto).
Definition XTPMarkupGridLength.h:103
CXTPMarkupGridLength::CXTPMarkupGridLength
CXTPMarkupGridLength(double nValue=0, GridUnitType type=unitTypePixel)
Constructs a CXTPMarkupGridLength object.
CXTPMarkupGridLength::m_nValue
double m_nValue
Value.
Definition XTPMarkupGridLength.h:120
CXTPMarkupGridLength::ConvertFrom
CXTPMarkupObject * ConvertFrom(CXTPMarkupBuilder *pBuilder, CXTPMarkupObject *pObject) const
Helper method used to convert string to length.
CXTPMarkupGridLength::IsStar
BOOL IsStar() const
Determines if the length is calculated in percents (unitTypeStar).
Definition XTPMarkupGridLength.h:92
CXTPMarkupGridLength::GridUnitType
GridUnitType
Unit type of the length.
Definition XTPMarkupGridLength.h:51
CXTPMarkupGridLength::unitTypePixel
@ unitTypePixel
Length in pixels.
Definition XTPMarkupGridLength.h:53
CXTPMarkupGridLength::unitTypeAuto
@ unitTypeAuto
Automatically calculated length.
Definition XTPMarkupGridLength.h:52


Toolkit Pro: XTPRibbonBackstageSeparatorThemeVisualStudio2022.h Source File

  • Source
  • Ribbon
  • Backstage
XTPRibbonBackstageSeparatorThemeVisualStudio2022.h
Go to the documentation of this file.
1
23#if !defined(__XTPRIBBONBACKSTAGESEPARATORTHEMEVISUALSTUDIO2022_H__)
24# define __XTPRIBBONBACKSTAGESEPARATORTHEMEVISUALSTUDIO2022_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPRibbonBackstageSeparator;
34
35class _XTP_EXT_CLASS CXTPRibbonBackstageSeparatorThemeVisualStudio2022
36 : public CXTPRibbonBackstageSeparatorThemeOffice2013
37{
38public:
39 CXTPRibbonBackstageSeparatorThemeVisualStudio2022();
40};
41
42# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
44#endif // !defined(__XTPRIBBONBACKSTAGESEPARATORTHEMEVISUALSTUDIO2022_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h


Toolkit Pro: Member List

  • CXTPStatusBarSwitchPane
  • SWITCH
CXTPStatusBarSwitchPane::SWITCH Member List

This is the complete list of members for CXTPStatusBarSwitchPane::SWITCH, including all inherited members.

bChecked | CXTPStatusBarSwitchPane::SWITCH
bEnabled | CXTPStatusBarSwitchPane::SWITCH
bHighlighted | CXTPStatusBarSwitchPane::SWITCH
bPressed | CXTPStatusBarSwitchPane::SWITCH
nID | CXTPStatusBarSwitchPane::SWITCH
nWidth | CXTPStatusBarSwitchPane::SWITCH
strToolTip | CXTPStatusBarSwitchPane::SWITCH


Toolkit Pro: Member List

CXTPChartBarSeriesView Member List

This is the complete list of members for CXTPChartBarSeriesView, including all inherited members.

AddChildView(CXTPChartElementView *pChildView) | CXTPChartElementView |
BeforeUpdateRange(CXTPChartDeviceContext *pDC) | CXTPChartBarSeriesView | protected
CreateDeviceCommand(CXTPChartDeviceContext *pDC) | CXTPChartElementView | virtual
CreateLegendDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcBounds) | CXTPChartBarSeriesView | protectedvirtual
CreateSeriesPointView(CXTPChartDeviceContext *pDC, CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView) | CXTPChartBarSeriesView | protected
CXTPChartBarSeriesView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView) | CXTPChartBarSeriesView |
CXTPChartElementView(CXTPChartElementView *pParentView) | CXTPChartElementView |
CXTPChartElementView(CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartElementView |
CXTPChartElementView(CXTPChartContainer *pContainer) | CXTPChartElementView |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
GetAt(int nIndex) const | CXTPChartElementView |
GetBounds() const | CXTPChartElementView |
GetBounds(BOOL bIncludingChildren) const | CXTPChartElementView |
GetChildren() | CXTPChartElementView |
GetCount() const | CXTPChartElementView |
GetParentView() const | CXTPChartElementView |
Is3D() const | CXTPChartObject |
m_arrChildren | CXTPChartElementView | protected
m_nBarCount | CXTPChartBarSeriesView | protected
m_nBarIndex | CXTPChartBarSeriesView | protected
m_pContainer | CXTPChartElementView | protected
m_pParentView | CXTPChartElementView | protected
m_rcBounds | CXTPChartElementView | protected
~CXTPChartElementView() | CXTPChartElementView | protectedvirtual
~CXTPChartLegendItemView() | CXTPChartLegendItemView | inlinevirtual


Toolkit Pro: Member List

CXTPImageManagerVectorImageHandle Member List

This is the complete list of members for CXTPImageManagerVectorImageHandle, including all inherited members.

CreateMarkupHandle(CXTPMarkupContext *pContext, BOOL bSharedContext, HGLOBAL SerializationData) | CXTPImageManagerVectorImageHandle | static
CreateMarkupHandle(CXTPMarkupContext *pContext, BOOL bSharedContext, IStream *pStream) | CXTPImageManagerVectorImageHandle | static
CreateMarkupHandle(CXTPMarkupContext *pContext, BOOL bSharedContext, LPCSTR lpszCode, INT_PTR nLength=-1) | CXTPImageManagerVectorImageHandle | static
CreateMarkupHandle(CXTPMarkupContext *pContext, BOOL bSharedContext, LPCWSTR lpszCode, INT_PTR nLength=-1) | CXTPImageManagerVectorImageHandle | static
CreateSvgHandle(HGLOBAL SerializationData) | CXTPImageManagerVectorImageHandle | static
CreateSvgHandle(IStream *pStream) | CXTPImageManagerVectorImageHandle | static
CreateSvgHandle(LPCSTR lpszCode, INT_PTR nLength=-1) | CXTPImageManagerVectorImageHandle | static
CXTPImageManagerVectorImageHandle() | CXTPImageManagerVectorImageHandle |
CXTPImageManagerVectorImageHandle(const CXTPImageManagerVectorImageHandle &rhs) | CXTPImageManagerVectorImageHandle |
DirectDraw(PVOID pBits, SIZE_T cbSize, CPoint pt, CSize szIcon) | CXTPImageManagerVectorImageHandle |
Draw(CDC *pDC, CPoint pt, CSize szIcon) | CXTPImageManagerVectorImageHandle |
GetDataStream() const | CXTPImageManagerVectorImageHandle |
GetMarkupContext() | CXTPImageManagerVectorImageHandle |
GetSerializationData() const | CXTPImageManagerVectorImageHandle |
IsDirectDrawSupported() const | CXTPImageManagerVectorImageHandle |
IsMarkupImage() const | CXTPImageManagerVectorImageHandle |
IsSvgImage() const | CXTPImageManagerVectorImageHandle |
operator BOOL() const | CXTPImageManagerVectorImageHandle |
operator=(const CXTPImageManagerVectorImageHandle &rhs) | CXTPImageManagerVectorImageHandle |
~CXTPImageManagerVectorImageHandle() | CXTPImageManagerVectorImageHandle | virtual


Toolkit Pro: Member List

CXTPSyntaxEditCtrl Member List

This is the complete list of members for CXTPSyntaxEditCtrl, including all inherited members.

_EnableScrollBarNotify(DWORD dwScrollBar, DWORD dwState) | CXTPSyntaxEditCtrl | protectedvirtual
_RecalcHScrollMaxWidth() | CXTPSyntaxEditCtrl |
_RecalcScrollBars() | CXTPSyntaxEditCtrl |
_SubtractSelSizeFromPos(XTP_EDIT_LINECOL lcDispPos) | CXTPSyntaxEditCtrl | protected
_UpdateIMEStatus() | CXTPSyntaxEditCtrl |
AddRemoveBookmark(int nRow) | CXTPSyntaxEditCtrl |
AddRemoveBreakPoint(int nRow) | CXTPSyntaxEditCtrl |
ApplyTheme(CString strTheme) | CXTPSyntaxEditCtrl |
CalcAbsCol(LPCTSTR szText, int nDispCol) const | CXTPSyntaxEditCtrl |
CalcAbsCol(int nTextRow, int nDispCol) const | CXTPSyntaxEditCtrl |
CalcAveDataSize(int nRowStart, int nRowEnd) | CXTPSyntaxEditCtrl | protectedvirtual
CalcDispCol(LPCTSTR szText, int nActualCol) const | CXTPSyntaxEditCtrl |
CalcDispCol(int nTextRow, int nActualCol) const | CXTPSyntaxEditCtrl |
CalcEditRects(CRect *prcBookMarks=NULL, CRect *prcLineNum=NULL, CRect *prcNodes=NULL, CRect *prcText=NULL, const CRect *prcClient=NULL) const | CXTPSyntaxEditCtrl | virtual
CalcMaximumWidth(LPCTSTR szText) | CXTPSyntaxEditCtrl | protected
CalculateDocumentRow(int nStartDocumentRow, int nRowDelta) | CXTPSyntaxEditCtrl | protected
CalculateEditbarLength(CDC *pDC=NULL) | CXTPSyntaxEditCtrl |
CalculateVisibleRow(int nStartDocumentRow, int nDocumentRow) | CXTPSyntaxEditCtrl | protected
CalculateVisibleRow_(int nStartDocumentRow, int nDocumentRow) | CXTPSyntaxEditCtrl | protected
CalcValidDispCol(LPCTSTR szText, int iCol) const | CXTPSyntaxEditCtrl |
CancelRightButtonDrag() | CXTPSyntaxEditCtrl |
CanEditDoc() const | CXTPSyntaxEditCtrl | virtual
CanRedo() const | CXTPSyntaxEditCtrl |
CanUndo() const | CXTPSyntaxEditCtrl |
ClearOnScreenSchCache(int nRowFrom) | CXTPSyntaxEditCtrl | protected
CollapseAll() | CXTPSyntaxEditCtrl |
CollapseExpandBlock(int nRow) | CXTPSyntaxEditCtrl |
Copy() | CXTPSyntaxEditCtrl |
CopyOrMoveText(BOOL bCopy) | CXTPSyntaxEditCtrl |
Create(CWnd *pParent, BOOL bHorzScroll, BOOL bVertScroll, CXTPSyntaxEditBufferManager *pBuffer=NULL, CCreateContext *lpCS=NULL, UINT nID=0) | CXTPSyntaxEditCtrl |
CreateInsertText(LPTSTR szText, CString &strTextToIns, int &iNewRow, int &iNewCol, int &iNewDispCol, int &iEditRowFrom, int &iEditRowTo, int &iChainActionCount) | CXTPSyntaxEditCtrl |
Cut() | CXTPSyntaxEditCtrl |
CXTPSyntaxEditCtrl() | CXTPSyntaxEditCtrl |
DecreaseIndent() | CXTPSyntaxEditCtrl |
DeleteBookmark(int nRow) | CXTPSyntaxEditCtrl |
DeleteBreakpoint(int nRow) | CXTPSyntaxEditCtrl |
DeleteBuffer(int iRowFrom, int iColFrom, int iRowTo, int iColTo, int nFlags=0) | CXTPSyntaxEditCtrl |
DeleteChar(int iRow, int iCol, XTPSyntaxEditDeletePos pos) | CXTPSyntaxEditCtrl |
DeleteSelectedLines(int iForceDeleteRow) | CXTPSyntaxEditCtrl |
DeleteSelection() | CXTPSyntaxEditCtrl |
DoAutoIndentIfNeed(int nBaseDocRow, int nDispCol_prev) | CXTPSyntaxEditCtrl | protectedvirtual
DoChangeSelectionCase(BOOL bUpper) | CXTPSyntaxEditCtrl | protected
DoChangeSelectionTabify(BOOL bTabify) | CXTPSyntaxEditCtrl | protected
DoUndoRedo(int nActionsCount, BOOL bUndoRedo) | CXTPSyntaxEditCtrl | protected
Draw(CDC *pDC, const CRect &rcRect) | CXTPSyntaxEditCtrl | virtual
EnableEditAccelerators(BOOL bEnable) | CXTPSyntaxEditCtrl |
EnableOleDrag(BOOL bEnableDrag=TRUE) | CXTPSyntaxEditCtrl |
EnableScrollBarCtrl(int nBar, BOOL bEnable=TRUE) | CXTPSyntaxEditCtrl |
EnableVirtualSpace(BOOL bEnable, BOOL bUpdateReg=FALSE) | CXTPSyntaxEditCtrl |
EnableWhiteSpace(BOOL bShow=TRUE) | CXTPSyntaxEditCtrl |
EnsureVisibleCol(int nDispRow, int nDispCol) | CXTPSyntaxEditCtrl |
EnsureVisibleRow(int nTextRow) | CXTPSyntaxEditCtrl |
ExpandAll() | CXTPSyntaxEditCtrl |
ExpandChars(CDC *pDC, LPCTSTR pszChars, int nCurPos, CString &strBufer) | CXTPSyntaxEditCtrl | protected
FillTabs(CString &rstrTextToIns, int nDispCol) | CXTPSyntaxEditCtrl |
Find(LPCTSTR szText, BOOL bMatchWholeWord, BOOL bMatchCase, BOOL bSearchDown, BOOL bRedraw=TRUE, int nStartRow=-1, int nStartCol=-1) | CXTPSyntaxEditCtrl |
FindWord(UINT nFindWhat) | CXTPSyntaxEditCtrl |
FindWordEx(UINT nFindWhat, int nTextRow, int nCol, XTP_EDIT_LINECOL &rlcWordStart, XTP_EDIT_LINECOL &rlcWordEnd, BOOL &rbOverSpace) | CXTPSyntaxEditCtrl |
FindWordEx_str(UINT nFindWhat, XTP_EDIT_LINECOL lcPos_str, XTP_EDIT_LINECOL &rlcWordStart, XTP_EDIT_LINECOL &rlcWordEnd, BOOL &rbOverSpace) | CXTPSyntaxEditCtrl |
GetAutoCompleteWnd() const | CXTPSyntaxEditCtrl |
GetAutoIndent() const | CXTPSyntaxEditCtrl |
GetAutoscrollDirection(int *pnCols=NULL, int *pnRows=NULL) | CXTPSyntaxEditCtrl | protectedvirtual
GetBlockFromPt(const CPoint &ptMouse) const | CXTPSyntaxEditCtrl | protected
GetCollapsableBlocksInfo(int nTextRow, CXTPSyntaxEditRowsBlockArray &rArBlocks) const | CXTPSyntaxEditCtrl | virtual
GetCollapsedBlockLen(int nStartRow, int &rnLen) const | CXTPSyntaxEditCtrl | protected
GetCollapsedText(XTP_EDIT_COLLAPSEDBLOCK *pCoDrawBlk, int nMaxLinesCount=150) const | CXTPSyntaxEditCtrl | protected
GetCollapsibleNodes() const | CXTPSyntaxEditCtrl |
GetColorScheme() | CXTPSyntaxEditCtrl | inline
GetConfigFile() const | CXTPSyntaxEditCtrl |
GetCurAbsCol() const | CXTPSyntaxEditCtrl |
GetCurCol() const | CXTPSyntaxEditCtrl |
GetCurrentDocumentRow() const | CXTPSyntaxEditCtrl | protected
GetCurrentTheme() const | CXTPSyntaxEditCtrl |
GetCurrentVisibleRow() | CXTPSyntaxEditCtrl | protected
GetCurRow() const | CXTPSyntaxEditCtrl |
GetDefaultCfgFilePath() | CXTPSyntaxEditCtrl | protected
GetDocumentRow(int nVisibleRow) | CXTPSyntaxEditCtrl | protected
GetDrawTextProcessor() | CXTPSyntaxEditCtrl |
GetEditBuffer() const | CXTPSyntaxEditCtrl |
GetEffectiveParent() const | CXTPSyntaxEditCtrl |
GetHorzScrollBar() const | CXTPSyntaxEditCtrl |
GetLexConfigurationManager() const | CXTPSyntaxEditCtrl |
GetLineMarksManager() const | CXTPSyntaxEditCtrl |
GetLineNodeRect(int nDispRow, CRect &rcNode, CRect *prcNodeFull=NULL) const | CXTPSyntaxEditCtrl |
GetLineNumbers() const | CXTPSyntaxEditCtrl |
GetLineText(int nRow, BOOL bAddCRLF=FALSE, int iCRLFStyle=-1) const | CXTPSyntaxEditCtrl |
GetLineText(int nRow, CString &strBuffer, BOOL bAddCRLF=FALSE, int iCRLFStyle=-1) const | CXTPSyntaxEditCtrl |
GetModulePath() | CXTPSyntaxEditCtrl | static
GetOnScreenSch(int nForRow) | CXTPSyntaxEditCtrl | protected
GetPaintManager() const | CXTPSyntaxEditCtrl |
GetRedoTextList() | CXTPSyntaxEditCtrl |
GetRegValues() | CXTPSyntaxEditCtrl | protected
GetRowBkColor(int nRow) const | CXTPSyntaxEditCtrl | virtual
GetRowColor(int nRow) const | CXTPSyntaxEditCtrl | virtual
GetRowColors(int nTextRow, int nColFrom, int nColTo, const XTP_EDIT_COLORVALUES &clrDefault, CXTPSyntaxEditTextBlockList *rBlocks) | CXTPSyntaxEditCtrl | virtual
GetRowCount() const | CXTPSyntaxEditCtrl |
GetRowNodes(int nRow, DWORD &dwType) const | CXTPSyntaxEditCtrl | protected
GetRowPerPage() const | CXTPSyntaxEditCtrl |
GetScrollBarCtrl(int nBar) const | CXTPSyntaxEditCtrl | virtual
GetScrollInfo(int nBar, LPSCROLLINFO lpScrollInfo, UINT nMask=SIF_ALL) | CXTPSyntaxEditCtrl |
GetScrollLimit(int nBar) | CXTPSyntaxEditCtrl |
GetScrollPos(int nBar) const | CXTPSyntaxEditCtrl |
GetScrollRange(int nBar, LPINT lpMinPos, LPINT lpMaxPos) const | CXTPSyntaxEditCtrl |
GetSelection() | CXTPSyntaxEditCtrl |
GetSelectionBuffer(UINT nFormat) | CXTPSyntaxEditCtrl |
GetSelectionText(CString &strText) | CXTPSyntaxEditCtrl |
GetSelMargin() const | CXTPSyntaxEditCtrl |
GetSyntaxColor() const | CXTPSyntaxEditCtrl |
GetSyntaxScheme() | CXTPSyntaxEditCtrl | inline
GetTabSize() const | CXTPSyntaxEditCtrl |
GetTabWithSpace() const | CXTPSyntaxEditCtrl |
GetText(int nMaxLen=-1) const | CXTPSyntaxEditCtrl |
GetText(CMemFile &memFile, int nMaxLen=-1) const | CXTPSyntaxEditCtrl |
GetThemes() | CXTPSyntaxEditCtrl |
GetTopRow() const | CXTPSyntaxEditCtrl |
GetUndoTextList() | CXTPSyntaxEditCtrl |
GetVertScrollBar() const | CXTPSyntaxEditCtrl |
GetVisibleRow(int nDocumentRow) | CXTPSyntaxEditCtrl | protected
GetVisibleRowsCount(int nMaxDocRow=-1) | CXTPSyntaxEditCtrl | protected
GetWideCaret() const | CXTPSyntaxEditCtrl |
GoToRow(int iRow, BOOL bSelectRow=FALSE) | CXTPSyntaxEditCtrl |
HandleDrop(BOOL bCopy) | CXTPSyntaxEditCtrl |
HasBookmarks() const | CXTPSyntaxEditCtrl |
HasBreakpoints() const | CXTPSyntaxEditCtrl |
HasRowMark(int nRow, const XTP_EDIT_LINEMARKTYPE &lmType, XTP_EDIT_LMPARAM *pParam=NULL) const | CXTPSyntaxEditCtrl |
IncreaseIndent() | CXTPSyntaxEditCtrl |
InsertRow(int nRow, LPCTSTR pcszText, BOOL bCanUndo) | CXTPSyntaxEditCtrl |
InsertString(LPCTSTR szText, int iRow, int iCol, BOOL bDeleteSelection=TRUE) | CXTPSyntaxEditCtrl |
InsertTextBlock(LPCTSTR szText, int iRow, int iCol, BOOL bDeleteSelection=TRUE) | CXTPSyntaxEditCtrl |
InvalidateRow(int nRow) | CXTPSyntaxEditCtrl |
InvalidateRows(int nRowFrom=-1, int nRowTo=-1) | CXTPSyntaxEditCtrl |
IsActive() const | CXTPSyntaxEditCtrl |
IsConfigFileMode() | CXTPSyntaxEditCtrl | inline
IsCreateScrollbarOnParent() const | CXTPSyntaxEditCtrl |
IsEnabledEditAccelerators() const | CXTPSyntaxEditCtrl |
IsEnabledVirtualSpace() const | CXTPSyntaxEditCtrl |
IsEnabledWhiteSpace() const | CXTPSyntaxEditCtrl |
IsHideCaret() const | CXTPSyntaxEditCtrl |
IsReadOnly() const | CXTPSyntaxEditCtrl |
IsRightButtonDrag() const | CXTPSyntaxEditCtrl |
IsRowValid(int nDispRow) const | CXTPSyntaxEditCtrl |
IsRowVisible(int iRow) const | CXTPSyntaxEditCtrl |
IsSelectionExist() const | CXTPSyntaxEditCtrl |
IsViewOnly() const | CXTPSyntaxEditCtrl |
LowercaseSelection() | CXTPSyntaxEditCtrl |
m_arCollapsedTextRows | CXTPSyntaxEditCtrl | protected
m_arOnScreenSchCache | CXTPSyntaxEditCtrl | protected
m_arValidDispRows | CXTPSyntaxEditCtrl | protected
m_aveRedrawScreenTime | CXTPSyntaxEditCtrl | protected
m_bActivateOnFocus | CXTPSyntaxEditCtrl | protected
m_bCaseSensitive | CXTPSyntaxEditCtrl | protected
m_bConfigFileMode | CXTPSyntaxEditCtrl | protected
m_bCreateScrollbarOnParent | CXTPSyntaxEditCtrl | protected
m_bDisableRedraw | CXTPSyntaxEditCtrl |
m_bDragging | CXTPSyntaxEditCtrl | protected
m_bDroppable | CXTPSyntaxEditCtrl | protected
m_bEnableOleDrag | CXTPSyntaxEditCtrl | protected
m_bFocused | CXTPSyntaxEditCtrl | protected
m_bHorzScrollBar | CXTPSyntaxEditCtrl | protected
m_bIMEsupported | CXTPSyntaxEditCtrl | protected
m_bIsActive | CXTPSyntaxEditCtrl | protected
m_bIsDragging | CXTPSyntaxEditCtrl | protected
m_bIsScrollingEndRow | CXTPSyntaxEditCtrl | protected
m_bIsSmartIndent | CXTPSyntaxEditCtrl | protected
m_bmpCache | CXTPSyntaxEditCtrl | protected
m_bPageDirty | CXTPSyntaxEditCtrl | protected
m_bRightButtonDrag | CXTPSyntaxEditCtrl | protected
m_bScrolling | CXTPSyntaxEditCtrl | protected
m_bTokensLoaded | CXTPSyntaxEditCtrl | protected
m_bUseMonitor | CXTPSyntaxEditCtrl |
m_bVertScrollBar | CXTPSyntaxEditCtrl | protected
m_bWndCreateInProgress | CXTPSyntaxEditCtrl | protected
m_chPrevLeadByte | CXTPSyntaxEditCtrl | protected
m_dwAutoScrollDirection | CXTPSyntaxEditCtrl | protected
m_dwInsertPos | CXTPSyntaxEditCtrl | protected
m_dwLastRedrawTime | CXTPSyntaxEditCtrl | protected
m_fcCollapsable | CXTPSyntaxEditCtrl | protected
m_fcRowColors | CXTPSyntaxEditCtrl | protected
m_mapInternalRowBkColor | CXTPSyntaxEditCtrl | protected
m_mapInternalRowForeColor | CXTPSyntaxEditCtrl | protected
m_nAutoIndentCol | CXTPSyntaxEditCtrl | protected
m_nAverageLineLen | CXTPSyntaxEditCtrl | protected
m_nBottomCalculatedRow | CXTPSyntaxEditCtrl | protected
m_nCollapsedTextRowsCount | CXTPSyntaxEditCtrl | protected
m_nCurrentCol | CXTPSyntaxEditCtrl | protected
m_nCurrentDocumentRow | CXTPSyntaxEditCtrl | protected
m_nDispCol | CXTPSyntaxEditCtrl | protected
m_nEditbarLength | CXTPSyntaxEditCtrl | protected
m_nHScrollMaxWidth | CXTPSyntaxEditCtrl | protected
m_nInsertSpaceCount | CXTPSyntaxEditCtrl | protected
m_nInsertTabCount | CXTPSyntaxEditCtrl | protected
m_nLineNumLength | CXTPSyntaxEditCtrl | protected
m_nMarginLength | CXTPSyntaxEditCtrl | protected
m_nNodesWidth | CXTPSyntaxEditCtrl | protected
m_nTopCalculatedRow | CXTPSyntaxEditCtrl | protected
m_nTopRow | CXTPSyntaxEditCtrl | protected
m_nWheelScroll | CXTPSyntaxEditCtrl | protected
m_pAutoComplete | CXTPSyntaxEditCtrl | protected
m_pBuffer | CXTPSyntaxEditCtrl | protected
m_pDrawTextProcessor | CXTPSyntaxEditCtrl | protected
m_pImmWrapper | CXTPSyntaxEditCtrl | protected
m_pPaintManeger | CXTPSyntaxEditCtrl | protected
m_pParentWnd | CXTPSyntaxEditCtrl | protected
m_pSelection | CXTPSyntaxEditCtrl | protected
m_ptDropPos | CXTPSyntaxEditCtrl | protected
m_pToolTip | CXTPSyntaxEditCtrl | protected
m_ptPrevMouse | CXTPSyntaxEditCtrl | protected
m_sIniSet | CXTPSyntaxEditCtrl | protected
m_sPassedIniSet | CXTPSyntaxEditCtrl | protected
m_strColorScheme | CXTPSyntaxEditCtrl | protected
m_strDefaultCfgFilePath | CXTPSyntaxEditCtrl | protected
m_strSyntaxScheme | CXTPSyntaxEditCtrl | protected
MatchText(int nRow, LPCTSTR szLineText, LPCTSTR szMatchText, int nStartPos, BOOL bMatchWholeWord, BOOL bMatchCase, BOOL bSearchForward, BOOL bRedraw=TRUE) | CXTPSyntaxEditCtrl |
MoveCurrentVisibleRowDown(int nCount) | CXTPSyntaxEditCtrl | protected
MoveCurrentVisibleRowUp(int nCount) | CXTPSyntaxEditCtrl | protected
NextBookmark() | CXTPSyntaxEditCtrl |
NotifyCurRowCol(int nRow, int nCol) const | CXTPSyntaxEditCtrl |
NotifyEditChanged(int iRowFrom, int iRowTo, UINT nActions) | CXTPSyntaxEditCtrl |
NotifyMarginLBtnClick(int nRow, int nDispRow) const | CXTPSyntaxEditCtrl | virtual
NotifyMouseEvent(UINT uCode, UINT nFlags, const CPoint &point) const | CXTPSyntaxEditCtrl | virtual
NotifyParent(UINT uCode) const | CXTPSyntaxEditCtrl | virtual
NotifyParseEvent(XTP_NOTIFY_CODE code, WPARAM wParam, LPARAM lParam) | CXTPSyntaxEditCtrl | protected
NotifySelInit() const | CXTPSyntaxEditCtrl | virtual
OnBeforeEditChanged(int nRow, int nCol) | CXTPSyntaxEditCtrl | protected
OnEditChanged(int nRowFrom, int nColFrom, int nRowTo, int nColTo, int eEditAction) | CXTPSyntaxEditCtrl | protected
OnEditChanged(const XTP_EDIT_LINECOL &LCFrom, const XTP_EDIT_LINECOL &LCTo, int eEditAction) | CXTPSyntaxEditCtrl | protected
OnLexCfgWasChanged(XTP_NOTIFY_CODE code, WPARAM wParam, LPARAM lParam) | CXTPSyntaxEditCtrl | protected
OnParseEvent(XTP_NOTIFY_CODE code, WPARAM wParam, LPARAM lParam) | CXTPSyntaxEditCtrl | protected
operator=(const CXTPSyntaxEditCtrl &src) | CXTPSyntaxEditCtrl |
Paste() | CXTPSyntaxEditCtrl |
PrevBookmark() | CXTPSyntaxEditCtrl |
PrintPage(CDC *pDC, const CRect &rcRect, int nFlags=0) | CXTPSyntaxEditCtrl | virtual
ProcessCollapsedBlockDblClick(const CPoint &ptMouse) | CXTPSyntaxEditCtrl | protected
ProcessCollapsedText(CDC *pDC, XTP_EDIT_COLLAPSEDBLOCK *pCoDrawBlk, CRect &rcCoBlk) | CXTPSyntaxEditCtrl | protected
ProcessCollapsedTextEx(CDC *pDC, XTP_EDIT_COLLAPSEDBLOCK *pCoDrawBlk, const XTP_EDIT_TEXTBLOCK &txtBlk, CRect &rcCoBlk) | CXTPSyntaxEditCtrl | protected
RecalcHorzScrollPos() | CXTPSyntaxEditCtrl |
RecalcScrollBars() | CXTPSyntaxEditCtrl |
RecalcVertScrollPos() | CXTPSyntaxEditCtrl |
Redo(int nActionsCount=1) | CXTPSyntaxEditCtrl |
RedrawLineMarks() | CXTPSyntaxEditCtrl | protectedvirtual
RefreshColors() | CXTPSyntaxEditCtrl | virtual
RefreshLineMarks(XTP_EDIT_NMHDR_EDITCHANGED *pEditChanged) | CXTPSyntaxEditCtrl | protectedvirtual
RegisterWindowClass(HINSTANCE hInstance=NULL) | CXTPSyntaxEditCtrl | protected
ReloadSyntaxConfigFileMode() | CXTPSyntaxEditCtrl |
ReloadSyntaxStringMode() | CXTPSyntaxEditCtrl |
RemoveRow(int nRow, BOOL bCanUndo) | CXTPSyntaxEditCtrl |
ReplaceAll(LPCTSTR szFindText, LPCTSTR szReplaceText, BOOL bMatchWholeWord, BOOL bMatchCase) | CXTPSyntaxEditCtrl |
ReplaceSel(LPCTSTR szNewText) | CXTPSyntaxEditCtrl |
RepositionBars(UINT nIDFirst, UINT nIDLast, UINT nIDLeftOver, UINT nFlag=CWnd::reposDefault, LPRECT lpRectParam=NULL, LPCRECT lpRectClient=NULL, BOOL bStretch=TRUE) | CXTPSyntaxEditCtrl |
RestoreCursor() | CXTPSyntaxEditCtrl |
RowColFromPoint(CPoint pt, int *pRow, int *pCol, int *pDispRow=NULL, int *pDispCol=NULL, BOOL bVirtualSpace=-1) | CXTPSyntaxEditCtrl |
Scroll(int xPos, int yPos) | CXTPSyntaxEditCtrl |
ScrollWindow(int xAmount, int yAmount, LPCRECT lpRect=NULL, LPCRECT lpClipRect=NULL) | CXTPSyntaxEditCtrl |
ScrollWindowEx(int dx, int dy, LPCRECT lpRectScroll, LPCRECT lpRectClip, CRgn *prgnUpdate, LPRECT lpRectUpdate, UINT flags) | CXTPSyntaxEditCtrl |
Select(int nRow1, int nDispCol1, int nRow2, int nDispCol2, BOOL bRedraw=TRUE) | CXTPSyntaxEditCtrl |
SelectAll() | CXTPSyntaxEditCtrl |
SelectWord(CPoint point) | CXTPSyntaxEditCtrl |
SetActive(BOOL bIsActive) | CXTPSyntaxEditCtrl | virtual
SetAutoCompleteList() | CXTPSyntaxEditCtrl | protectedvirtual
SetAutoIndent(BOOL bAutoIndent, BOOL bUpdateReg=FALSE) | CXTPSyntaxEditCtrl |
SetCollapsibleNodes(BOOL bDrawNodes, BOOL bUpdateReg=FALSE) | CXTPSyntaxEditCtrl |
SetConfigFile(LPCTSTR szPath, BOOL bConfigFileMode=TRUE) | CXTPSyntaxEditCtrl |
SetCreateScrollbarOnParent(BOOL nSet) | CXTPSyntaxEditCtrl |
SetCurCaretPos(int nTextRow, int nDispCol, BOOL bRowColNotify=TRUE, BOOL bEnsureVisible=TRUE) | CXTPSyntaxEditCtrl |
SetCurPos(int nTextRow, int nDispCol, BOOL bRemainSelected=FALSE, BOOL bForceVisible=TRUE) | CXTPSyntaxEditCtrl |
SetCurrentDocumentRow(int nRow) | CXTPSyntaxEditCtrl | protected
SetDocModified(BOOL bModified=TRUE) | CXTPSyntaxEditCtrl | protected
SetDropPos(int iRow, int iCol) | CXTPSyntaxEditCtrl |
SetFontIndirect(LPLOGFONT pLogfont, BOOL bUpdateReg=FALSE) | CXTPSyntaxEditCtrl |
SetHideCaret(BOOL bHide) | CXTPSyntaxEditCtrl |
SetLineNumbers(BOOL bLineNumbers, BOOL bUpdateReg=FALSE) | CXTPSyntaxEditCtrl |
SetOverwriteMode(BOOL bOverwriteMode) | CXTPSyntaxEditCtrl |
SetPaintManager(CXTPSyntaxEditPaintManager *pPaintManager) | CXTPSyntaxEditCtrl | virtual
SetPassedIniSet(CString sPassedIniSet) | CXTPSyntaxEditCtrl | inline
SetReadOnly(BOOL bReadOnly=TRUE) | CXTPSyntaxEditCtrl | virtual
SetRightButtonDrag(BOOL bRightButtonDrag=TRUE) | CXTPSyntaxEditCtrl |
SetRowBkColor(int nRow, COLORREF crBack) | CXTPSyntaxEditCtrl |
SetRowColor(int nRow, COLORREF clrFront) | CXTPSyntaxEditCtrl |
SetRowText(int nRow, LPCTSTR pcszText, BOOL bCanUndo) | CXTPSyntaxEditCtrl |
SetRowValid(int nDispRow) | CXTPSyntaxEditCtrl |
SetScrollBars(BOOL bHorzSBar, BOOL bVertSBar, BOOL bUpdateReg=FALSE) | CXTPSyntaxEditCtrl |
SetScrollInfo(int nBar, LPSCROLLINFO lpScrollInfo, BOOL bRedraw=TRUE) | CXTPSyntaxEditCtrl |
SetScrollPos(int nBar, int nPos, BOOL bRedraw=TRUE) | CXTPSyntaxEditCtrl |
SetScrollRange(int nBar, int nMinPos, int nMaxPos, BOOL bRedraw=TRUE) | CXTPSyntaxEditCtrl |
SetSelMargin(BOOL bSelMargin, BOOL bUpdateReg=FALSE) | CXTPSyntaxEditCtrl |
SetSyntaxAndColorScheme(CString sSyntaxScheme, CString sColorScheme, BOOL bScheme=FALSE, BOOL bColors=FALSE) | CXTPSyntaxEditCtrl |
SetSyntaxColor(BOOL bSyntaxColor, BOOL bUpdateReg=FALSE) | CXTPSyntaxEditCtrl |
SetTabSize(int nTabSize, BOOL bUpdateReg=FALSE) | CXTPSyntaxEditCtrl |
SetTabWithSpace(BOOL bTabWithSpace, BOOL bUpdateReg=FALSE) | CXTPSyntaxEditCtrl |
SetText(LPCTSTR pcszText) | CXTPSyntaxEditCtrl |
SetTopRow(int iRow) | CXTPSyntaxEditCtrl |
SetViewOnly(BOOL bViewOnly) | CXTPSyntaxEditCtrl |
SetWideCaret(BOOL bWideCaret, BOOL bUpdateReg=FALSE) | CXTPSyntaxEditCtrl |
ShiftCurrentVisibleRowDown(int nCount, BOOL bChangeCaret=FALSE) | CXTPSyntaxEditCtrl | protected
ShiftCurrentVisibleRowUp(int nCount, BOOL bChangeCaret=FALSE) | CXTPSyntaxEditCtrl | protected
ShowCollapsedToolTip(const CPoint &ptMouse) | CXTPSyntaxEditCtrl | protected
ShowDefaultContextMenu() | CXTPSyntaxEditCtrl |
ShowHScrollBar(BOOL bShow=TRUE) | CXTPSyntaxEditCtrl |
ShowScrollBar(UINT nBar, BOOL bShow=TRUE) | CXTPSyntaxEditCtrl |
TabifySelection() | CXTPSyntaxEditCtrl |
Undo(int nActionsCount=1) | CXTPSyntaxEditCtrl |
Unselect() | CXTPSyntaxEditCtrl |
UnTabifySelection() | CXTPSyntaxEditCtrl |
UpdateRowInfoInternally(int nTextRow) | CXTPSyntaxEditCtrl | protected
UpdateScrollPos(DWORD dwUpdate=XTP_EDIT_UPDATE_ALL) | CXTPSyntaxEditCtrl | protected
UppercaseSelection() | CXTPSyntaxEditCtrl |
ValidateCol(const int nRow, int &nCol, int &nAbsCol) | CXTPSyntaxEditCtrl |
xtpBottom enum value | CXTPSyntaxEditCtrl | protected
xtpLeft enum value | CXTPSyntaxEditCtrl | protected
xtpRight enum value | CXTPSyntaxEditCtrl | protected
XTPScrolDirection enum name | CXTPSyntaxEditCtrl | protected
xtpTop enum value | CXTPSyntaxEditCtrl | protected
~CXTPSyntaxEditCtrl() | CXTPSyntaxEditCtrl | virtual


Toolkit Pro: XTPCustomizePageMenus.h Source File

  • Source
  • CommandBars
  • Customize
XTPCustomizePageMenus.h
Go to the documentation of this file.
1
23#if !defined(__XTPCUSTOMIZEMENUSPAGE_H__) && defined(_XTP_INCLUDE_CONTROLS)
24# define __XTPCUSTOMIZEMENUSPAGE_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPToolBar;
34class CXTPCustomizeSheet;
35
41class _XTP_EXT_CLASS CXTPCustomizeMenusPage : public CXTPPropertyPage
42{
46public:
54 CXTPCustomizeMenusPage(CXTPCustomizeSheet* pSheet);
55
61 ~CXTPCustomizeMenusPage();
62
63protected:
68 void CommitContextMenu();
69
73protected:
75 DECLARE_MESSAGE_MAP()
76
77 //{{AFX_VIRTUAL(CXTPCustomizeMenusPage)
78protected:
79 virtual void DoDataExchange(CDataExchange* pDX); // DDX/DDV support
80 //}}AFX_VIRTUAL
81
82 //{{AFX_MSG(CXTPCustomizeMenusPage)
83 virtual BOOL OnInitDialog();
84 afx_msg void OnSelectionChangedAppmenus();
85 afx_msg void OnSelectionChangedContextmenus();
86 afx_msg void OnDestroy();
87 afx_msg void OnButtonResetContextMenu();
88 afx_msg void OnButtonResetAppMenu();
89 afx_msg HBRUSH OnCtlColor(CDC* pDC, CWnd* pWnd, UINT nCtlColor);
90 //}}AFX_MSG
93 // Dialog Data
94public:
96 enum
97 {
98 IDD = XTP_IDD_PAGE_MENUS
99 };
102 // {{AFX_DATA(CXTPCustomizeMenusPage)
103
104 CStatic m_wndIcon;
105# ifdef _XTP_INCLUDE_CONTROLS
106 COLORREF m_clrText;
107 CXTPComboBox m_cmbContextMenus;
108 CXTPComboBox m_cmbAppMenus;
109 CXTPButton m_btnResetApp;
110 CXTPButton m_btnResetContent;
111# else
112 CComboBox m_cmbContextMenus;
113 CComboBox m_cmbAppMenus;
114 CButton m_btnResetApp;
115 CButton m_btnResetContent;
116# endif
117 CXTPGroupLine m_wndApplicationMenus;
118 CXTPGroupLine m_wndContextMenus;
119
120 // }}AFX_DATA
121
122protected:
123 CXTPToolBar* m_pContextMenu;
124 CXTPCustomizeSheet* m_pSheet;
125 CPoint m_ptContextMenu;
126 CString m_strDefaultMenu;
127 CString m_strDefaultMenuDesc;
128};
130# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
131#endif // !defined(__XTPCUSTOMIZEMENUSPAGE_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPButton
Push Button control.
Definition XTPButton.h:109
CXTPComboBox
The CXTPComboBox class provides the functionality of a themed Windows combobox.
Definition XTPComboBox.h:42
CXTPCustomizeMenusPage
CXTPCustomizeMenusPage is a CPropertyPage derived class.
Definition XTPCustomizePageMenus.h:42
CXTPCustomizeMenusPage::CommitContextMenu
void CommitContextMenu()
This method is called to save user changes.
CXTPCustomizeMenusPage::~CXTPCustomizeMenusPage
~CXTPCustomizeMenusPage()
Destroys a CXTPCustomizeMenusPage object, handles cleanup and deallocation.
CXTPCustomizeMenusPage::m_strDefaultMenu
CString m_strDefaultMenu
Default menu caption.
Definition XTPCustomizePageMenus.h:126
CXTPCustomizeMenusPage::m_strDefaultMenuDesc
CString m_strDefaultMenuDesc
Default menu description.
Definition XTPCustomizePageMenus.h:127
CXTPCustomizeMenusPage::m_pSheet
CXTPCustomizeSheet * m_pSheet
Parent sheet.
Definition XTPCustomizePageMenus.h:124
CXTPCustomizeMenusPage::m_ptContextMenu
CPoint m_ptContextMenu
Last position of context menu.
Definition XTPCustomizePageMenus.h:125
CXTPCustomizeMenusPage::CXTPCustomizeMenusPage
CXTPCustomizeMenusPage(CXTPCustomizeSheet *pSheet)
Construction.
CXTPCustomizeMenusPage::m_pContextMenu
CXTPToolBar * m_pContextMenu
Active context menu.
Definition XTPCustomizePageMenus.h:123
CXTPCustomizeMenusPage::m_wndIcon
CStatic m_wndIcon
Implementation.
Definition XTPCustomizePageMenus.h:104
CXTPCustomizeSheet
CXTPCustomizeSheet is a CPropertySheet derived class.
Definition XTPCustomizeSheet.h:47
CXTPGroupLine
CXTPGroupLine is a CStatic derived class.
Definition XTPCustomizePageOptions.h:43
CXTPPropertyPage
CXTPPropertyPage is a CPropertyPage derived class.
Definition XTPPropertyPage.h:43
CXTPToolBar
CXTPToolBar is a CXTPCommandBar derived class.
Definition XTPToolBar.h:42


Toolkit Pro: Member List

CXTPShortcutBarVisualStudio2022Theme Member List

This is the complete list of members for CXTPShortcutBarVisualStudio2022Theme, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPShortcutBarOffice2003Theme() | CXTPShortcutBarOffice2003Theme |
CXTPShortcutBarOffice2013Theme() | CXTPShortcutBarOffice2013Theme |
CXTPShortcutBarPaintManager() | CXTPShortcutBarPaintManager |
CXTPShortcutBarResourceTheme() | CXTPShortcutBarResourceTheme |
CXTPShortcutBarVisualStudio2022Theme() | CXTPShortcutBarVisualStudio2022Theme |
DrawExpandButton(CDC *pDC, CRect rc) | CXTPShortcutBarOffice2013Theme | virtual
DrawGripper(CDC *pDC, CXTPShortcutBar *pShortcutBar, BOOL bDraw) | CXTPShortcutBarOffice2013Theme | virtual
DrawImage(CDC *pDC, CPoint pt, CSize sz, CXTPImageManagerIcon *pImage, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled) | CXTPShortcutBarOffice2003Theme | virtual
DrawNavigationItem(CDC *pDC, CXTPShortcutBarItem *pItem) | CXTPShortcutBarPaintManager | virtual
DrawPaneCaption(CDC *pDC, CXTPShortcutBarPane *pPane, BOOL bDraw) | CXTPShortcutBarResourceTheme | virtual
DrawPaneItemCaption(CDC *pDC, CXTPShortcutBarPaneItem *pItem, BOOL bDraw) | CXTPShortcutBarVisualStudio2022Theme | virtual
DrawShortcutBarFrame(CDC *pDC, CXTPShortcutBar *pShortcutBar) | CXTPShortcutBarOffice2003Theme | virtual
DrawShortcutItem(CDC *pDC, CXTPShortcutBarItem *pItem) | CXTPShortcutBarPaintManager | virtual
FillNavigationItemEntry(CDC *pDC, CXTPShortcutBarItem *pItem) | CXTPShortcutBarVisualStudio2022Theme | virtual
FillShortcutBar(CDC *pDC, CXTPShortcutBar *pShortcutBar) | CXTPShortcutBarOffice2013Theme | virtual
FillShortcutItemEntry(CDC *pDC, CXTPShortcutBarItem *pItem) | CXTPShortcutBarVisualStudio2022Theme | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
IsShortcutItemTruncated(CDC *pDC, CXTPShortcutBarItem *pItem) | CXTPShortcutBarPaintManager |
Line(CDC *pDC, int x0, int y0, int x1, int y1, int nPen) | CXTPShortcutBarPaintManager |
m_bBoldItemCaptionFont | CXTPShortcutBarPaintManager |
m_bClearTypeTextQuality | CXTPShortcutBarPaintManager |
m_bHiliteBorders | CXTPShortcutBarVisualStudio2022Theme | protected
m_bNavigationButton | CXTPShortcutBarPaintManager |
m_bShowTopLeftCaptionShadow | CXTPShortcutBarOffice2003Theme |
m_bUseStandardFont | CXTPShortcutBarPaintManager |
m_clrBackHiliteSelected | CXTPShortcutBarVisualStudio2022Theme | protected
m_clrBorderHilite | CXTPShortcutBarVisualStudio2022Theme | protected
m_clrCaptionText | CXTPShortcutBarOffice2003Theme |
m_clrDisabledText | CXTPShortcutBarPaintManager |
m_clrGlyph | CXTPShortcutBarOffice2013Theme | protected
m_clrGlyphExpanded | CXTPShortcutBarOffice2013Theme | protected
m_clrGlyphFill | CXTPShortcutBarOffice2013Theme | protected
m_clrGlyphPushed | CXTPShortcutBarOffice2013Theme | protected
m_clrHotText | CXTPShortcutBarPaintManager |
m_clrItemCaptionShadow | CXTPShortcutBarOffice2003Theme |
m_clrItemCaptionText | CXTPShortcutBarOffice2003Theme |
m_clrItemCaptionTop | CXTPShortcutBarOffice2003Theme |
m_clrNormalText | CXTPShortcutBarPaintManager |
m_clrPushedText | CXTPShortcutBarPaintManager |
m_clrSelectedText | CXTPShortcutBarPaintManager |
m_clrShortcutItemShadow | CXTPShortcutBarPaintManager |
m_grcCaption | CXTPShortcutBarOffice2003Theme |
m_grcHot | CXTPShortcutBarPaintManager |
m_grcItemCaption | CXTPShortcutBarOffice2003Theme |
m_grcItemHotCaption | CXTPShortcutBarOffice2003Theme |
m_grcPushed | CXTPShortcutBarPaintManager |
m_grcSelected | CXTPShortcutBarPaintManager |
m_grcShortcutBarGripper | CXTPShortcutBarPaintManager |
m_grcShortcutItem | CXTPShortcutBarPaintManager |
m_nExpandedIconWidth | CXTPShortcutBarPaintManager |
m_nNormalIconWidth | CXTPShortcutBarPaintManager |
m_nPaneItemHeight | CXTPShortcutBarPaintManager |
m_pExpandIcon | CXTPShortcutBarPaintManager |
m_rcCaptionPadding | CXTPShortcutBarPaintManager |
m_rcItemCaptionPadding | CXTPShortcutBarPaintManager |
m_strOfficeFont | CXTPShortcutBarPaintManager |
m_xtpFontPaneCaption | CXTPShortcutBarPaintManager |
m_xtpFontPaneItemCaption | CXTPShortcutBarPaintManager |
m_xtpFontText | CXTPShortcutBarPaintManager |
m_xtpFontVerticalText | CXTPShortcutBarPaintManager |
Rectangle(CDC *pDC, CRect rc, int nPen, int nBrush) | CXTPShortcutBarPaintManager |
RefreshMetrics() | CXTPShortcutBarVisualStudio2022Theme | virtual
~CXTPShortcutBarOffice2013Theme() | CXTPShortcutBarOffice2013Theme | virtual
~CXTPShortcutBarPaintManager() | CXTPShortcutBarPaintManager | virtual
~CXTPShortcutBarVisualStudio2022Theme() | CXTPShortcutBarVisualStudio2022Theme | virtual


Toolkit Pro: Member List

CXTPProgressThemeVisualStudio2022 Member List

This is the complete list of members for CXTPProgressThemeVisualStudio2022, including all inherited members.

CXTPProgressPaintManager(CXTPPaintManager *pPaintManager) | CXTPProgressPaintManager |
CXTPProgressThemeOffice2013(CXTPPaintManager *pPaintManager) | CXTPProgressThemeOffice2013 |
CXTPProgressThemeVisualStudio2022(CXTPPaintManager *pPaintManager) | CXTPProgressThemeVisualStudio2022 |
DrawProgress(CDC *pDC, CXTPProgressBase *pProgressBar) | CXTPProgressThemeOffice2013 | virtual
GetPaintManager() const | CXTPProgressPaintManager |
m_clrBack | CXTPProgressThemeOffice2013 | protected
m_clrBar | CXTPProgressThemeOffice2013 | protected
m_clrBorder | CXTPProgressThemeOffice2013 | protected
m_cyProgress | CXTPProgressPaintManager |
m_pPaintManager | CXTPProgressPaintManager | protected
RefreshMetrics() | CXTPProgressThemeOffice2013 | virtual
~CXTPProgressPaintManager() | CXTPProgressPaintManager | virtual
~CXTPProgressThemeOffice2013() | CXTPProgressThemeOffice2013 | virtual
~CXTPProgressThemeVisualStudio2022() | CXTPProgressThemeVisualStudio2022 | virtual


Toolkit Pro: XTPEditThemeFlat.h Source File

  • Source
  • Controls
  • Edit
  • Themes
XTPEditThemeFlat.h
Go to the documentation of this file.
1
23#if !defined(__XTPEDITTHEMEFLAT_H__)
24# define __XTPEDITTHEMEFLAT_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
37class _XTP_EXT_CLASS CXTPEditThemeFlat : public CXTPEditThemeOfficeXP
38{
39public:
44 CXTPEditThemeFlat();
45
50 virtual ~CXTPEditThemeFlat();
51
58 virtual void RefreshMetrics(CXTPEdit* pEdit);
59};
60
61# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
63#endif // __XTPEDITTHEMEFLAT_H__
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPEdit
CXTPEdit is a CEdit derived class.
Definition XTPEdit.h:129
CXTPEditThemeFlat
CXTPEditThemeFlat is a class used to perform theme drawing tasks.
Definition XTPEditThemeFlat.h:38
CXTPEditThemeFlat::CXTPEditThemeFlat
CXTPEditThemeFlat()
Constructs a CXTPEditThemeFlat object.
CXTPEditThemeFlat::~CXTPEditThemeFlat
virtual ~CXTPEditThemeFlat()
Destructor, handles cleanup and deallocation.
CXTPEditThemeFlat::RefreshMetrics
virtual void RefreshMetrics(CXTPEdit *pEdit)
This member function is called by the theme manager to refresh the visual styles used by each compone...
CXTPEditThemeOfficeXP
CXTPEditThemeOfficeXP is a class used to perform theme drawing tasks.
Definition XTPEditThemeOfficeXP.h:38


Toolkit Pro: Member List

XTP_CALENDAR_PATTERN_END Member List

This is the complete list of members for XTP_CALENDAR_PATTERN_END, including all inherited members.

m_dtPatternEndDate | XTP_CALENDAR_PATTERN_END |
m_nEndAfterOccurrences | XTP_CALENDAR_PATTERN_END |
m_nUseEnd | XTP_CALENDAR_PATTERN_END |
operator=(const XTP_CALENDAR_PATTERN_END &rSrc) | XTP_CALENDAR_PATTERN_END | inline
XTP_CALENDAR_PATTERN_END() | XTP_CALENDAR_PATTERN_END | inline
~XTP_CALENDAR_PATTERN_END() | XTP_CALENDAR_PATTERN_END | inlinevirtual


Toolkit Pro: Member List

CXTPGridRecordItemConstraint Member List

This is the complete list of members for CXTPGridRecordItemConstraint, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPGridRecordItemConstraint() | CXTPGridRecordItemConstraint |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetIndex() const | CXTPGridRecordItemConstraint |
m_dwData | CXTPGridRecordItemConstraint |
m_nIndex | CXTPGridRecordItemConstraint | protected
m_strConstraint | CXTPGridRecordItemConstraint |


Toolkit Pro: Member List

CXTPSkinObjectHeader Member List

This is the complete list of members for CXTPSkinObjectHeader, including all inherited members.

CXTPSkinObject() | CXTPSkinObject | protected
CXTPSkinObjectFrame() | CXTPSkinObjectFrame |
CXTPSkinObjectHeader() | CXTPSkinObjectHeader |
GetAccessCriticalSection() const | CXTPSynchronized | inline
GetBorders() const | CXTPSkinObjectFrame |
GetCaptionButtons() | CXTPSkinObjectFrame |
GetClassName() const | CXTPSkinObject |
GetClientBrush(CDC *pDC) | CXTPSkinObjectFrame | virtual
GetColor(int nIndex) const | CXTPSkinObject |
GetMetrics() const | CXTPSkinObject |
GetSkinClass() const | CXTPSkinObject |
GetSkinManager() const | CXTPSkinObject |
IsActive() const | CXTPSkinObjectFrame |
m_arrButtons | CXTPSkinObjectFrame | protected
m_bActive | CXTPSkinObjectFrame | protected
m_bActiveX | CXTPSkinObject | protected
m_bLockFrameDraw | CXTPSkinObjectFrame |
m_bMDIClient | CXTPSkinObjectFrame | protected
m_bRegionChanged | CXTPSkinObjectFrame | protected
m_bWindowsForms | CXTPSkinObject | protected
m_dwDialogTexture | CXTPSkinObjectFrame |
m_dwExStyle | CXTPSkinObjectFrame | protected
m_dwStyle | CXTPSkinObjectFrame | protected
m_pButtonHot | CXTPSkinObjectFrame | protected
m_pButtonPressed | CXTPSkinObjectFrame | protected
m_pManager | CXTPSkinObject | protected
m_pOldWndProc | CXTPSkinObject | protected
m_pSBTrack | CXTPSkinObjectFrame | protected
m_rcBorders | CXTPSkinObjectFrame | protected
m_spi | CXTPSkinObjectFrame | protected
m_strClassName | CXTPSkinObject | protected
m_szFrameRegion | CXTPSkinObjectFrame | protected
OnHookAttached(LPCREATESTRUCT lpcs, BOOL bAuto) | CXTPSkinObjectFrame | protectedvirtual
OnHookDetached(BOOL bAuto) | CXTPSkinObjectFrame | protectedvirtual
OnSkinChanged(BOOL bPrevState, BOOL bNewState) | CXTPSkinObjectFrame | protectedvirtual
RedrawScrollBar(int nBar) | CXTPSkinObjectFrame |
RefreshMetrics() | CXTPSkinObjectFrame | protectedvirtual
~CXTPSkinObject() | CXTPSkinObject | protected
~CXTPSkinObjectFrame() | CXTPSkinObjectFrame | virtual
~CXTPSkinObjectHeader() | CXTPSkinObjectHeader | virtual


Toolkit Pro: Member List

CXTPMessageBarThemeVisualStudio2022 Member List

This is the complete list of members for CXTPMessageBarThemeVisualStudio2022, including all inherited members.

CXTPMessageBarPaintManager(CXTPPaintManager *pPaintManager) | CXTPMessageBarPaintManager |
CXTPMessageBarThemeOffice2013(CXTPPaintManager *pPaintManager) | CXTPMessageBarThemeOffice2013 |
CXTPMessageBarThemeVisualStudio2022(CXTPPaintManager *pPaintManager) | CXTPMessageBarThemeVisualStudio2022 |
DrawMessageBarButton(CDC *pDC, CXTPMessageBarButton *pButton) | CXTPMessageBarThemeOffice2013 | virtual
FillMessageBar(CDC *pDC, CXTPMessageBar *pBar) | CXTPMessageBarThemeOffice2013 | virtual
GetCloseButtonRect(int x, int y, int cy) | CXTPMessageBarThemeOffice2013 | virtual
GetDefaultButtonSize() const | CXTPMessageBarPaintManager | virtual
GetHeight() const | CXTPMessageBarPaintManager | virtual
GetPadding() const | CXTPMessageBarPaintManager | virtual
m_clrBack | CXTPMessageBarPaintManager | protected
m_clrBorder | CXTPMessageBarPaintManager | protected
m_clrButtonBack | CXTPMessageBarThemeOffice2013 | protected
m_clrButtonBackHilite | CXTPMessageBarThemeOffice2013 | protected
m_clrButtonBackPushed | CXTPMessageBarThemeOffice2013 | protected
m_clrButtonBorder | CXTPMessageBarThemeOffice2013 | protected
m_clrButtonBorderHilite | CXTPMessageBarThemeOffice2013 | protected
m_clrButtonBorderPushed | CXTPMessageBarThemeOffice2013 | protected
m_clrInfoBack | CXTPMessageBarPaintManager | protected
m_clrText | CXTPMessageBarPaintManager | protected
m_clrTextHilite | CXTPMessageBarThemeOffice2013 | protected
m_pPaintManager | CXTPMessageBarPaintManager | protected
RefreshMetrics() | CXTPMessageBarThemeOffice2013 | virtual
~CXTPMessageBarPaintManager() | CXTPMessageBarPaintManager | inlinevirtual


Toolkit Pro: Member List

CXTPDockingPanePanelColorSetNativeWindows10 Member List

This is the complete list of members for CXTPDockingPanePanelColorSetNativeWindows10, including all inherited members.

CXTPDockingPanePanelColorSet2012() | CXTPDockingPanePanelColorSet2012 |
CXTPDockingPanePanelColorSetNativeWindows10() | CXTPDockingPanePanelColorSetNativeWindows10 |
CXTPTabPaintManagerColorSet() | CXTPTabPaintManagerColorSet |
FillClient(CDC *pDC, CRect rc, CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
FillHeader(CDC *pDC, CRect rc, CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
FillNavigateButton(CDC *pDC, CXTPTabManagerNavigateButton *pButton, CRect &rc) | CXTPDockingPanePanelColorSet2012 | virtual
FillPropertyButton(CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerColorSet | virtual
FillStateButton(CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerColorSet | virtual
GetClientColor(CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
GetItemColor(CXTPTabManagerItem *pItem) | CXTPDockingPanePanelColorSet2012 | virtual
GradientFill(CDC *pDC, CRect rc, COLORREF clrLight, COLORREF clrDark, XTPTabPosition position) | CXTPTabPaintManagerColorSet |
IsAppThemed() const | CXTPTabPaintManagerColorSet | virtual
m_clrActiveFilesBack | CXTPTabPaintManagerColorSet |
m_clrActiveFilesBackHighlighted | CXTPTabPaintManagerColorSet |
m_clrActiveFilesBackPressed | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyph | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyphHighlighted | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyphPressed | CXTPTabPaintManagerColorSet |
m_clrAutoHideFace | CXTPTabPaintManagerColorSet |
m_clrBorderHighlight | CXTPTabPaintManagerColorSet |
m_clrButtonBorder | CXTPTabPaintManagerColorSet |
m_clrButtonBorderHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonBorderHot | CXTPTabPaintManagerColorSet |
m_clrButtonBorderKeyTips | CXTPTabPaintManagerColorSet |
m_clrButtonBorderTabContext1 | CXTPTabPaintManagerColorSet |
m_clrButtonBorderTabContext2 | CXTPTabPaintManagerColorSet |
m_clrButtonHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonHighlightedClose | CXTPTabPaintManagerColorSet |
m_clrButtonNormal | CXTPTabPaintManagerColorSet |
m_clrButtonPressed | CXTPTabPaintManagerColorSet |
m_clrButtonSelected | CXTPTabPaintManagerColorSet |
m_clrButtonSelectedHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonSelectedPressed | CXTPTabPaintManagerColorSet |
m_clrControlFace | CXTPTabPaintManagerColorSet |
m_clrFrameBorder | CXTPTabPaintManagerColorSet |
m_clrHeaderFace | CXTPTabPaintManagerColorSet |
m_clrPaneFace | CXTPTabPaintManagerColorSet |
m_clrTabClientBack | CXTPTabPaintManagerColorSet |
m_clrTabClientBorder | CXTPTabPaintManagerColorSet |
m_clrTextDisabled | CXTPTabPaintManagerColorSet |
m_clrTextHighlight | CXTPTabPaintManagerColorSet |
m_clrTextHighlightClose | CXTPTabPaintManagerColorSet |
m_clrTextNormal | CXTPTabPaintManagerColorSet |
m_clrTextPressed | CXTPTabPaintManagerColorSet |
m_clrTextSelected | CXTPTabPaintManagerColorSet |
m_clrTextSelectedHighlighted | CXTPTabPaintManagerColorSet |
m_clrTextSelectedPressed | CXTPTabPaintManagerColorSet |
m_csExcelNormal | CXTPTabPaintManagerColorSet |
m_csExcelSelected | CXTPTabPaintManagerColorSet |
m_csPropertyPage | CXTPTabPaintManagerColorSet |
m_csPropertyPage2003 | CXTPTabPaintManagerColorSet |
m_csStateButton | CXTPTabPaintManagerColorSet |
m_pPaintManager | CXTPTabPaintManagerColorSet | protected
RefreshMetrics() | CXTPDockingPanePanelColorSetNativeWindows10 | virtual
SelectClipRgn(CDC *pDC, CRect rcClient, CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
SetTextColor(CDC *pDC, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerColorSet | virtual
~CXTPTabPaintManagerColorSet() | CXTPTabPaintManagerColorSet | virtual


Toolkit Pro: Member List

CXTPResourceImage Member List

This is the complete list of members for CXTPResourceImage, including all inherited members.

ConvertToBits(HBITMAP hBitmap) | CXTPResourceImage | protected
CXTPCmdTarget() | CXTPCmdTarget |
CXTPResourceImage(CXTPResourceImages *pImages) | CXTPResourceImage |
DrawImage(CDC *pDC, const CRect &rcDest, CRect rcSrc) | CXTPResourceImage |
DrawImage(CDC *pDC, const CRect &rcDest, CRect rcSrc, CRect rcSizingMargins) | CXTPResourceImage |
DrawImage(CDC *pDC, const CRect &rcDest, CRect rcSrc, const CRect &rcSizingMargins, COLORREF clrTransparent) | CXTPResourceImage |
DrawImage(CDC *pDC, const CRect &rcDest, CRect rcSrc, const CRect &rcSizingMargins, COLORREF clrTransparent, DWORD dwFlags) | CXTPResourceImage |
DrawImageFlipped(BOOL bFlip) | CXTPResourceImage |
DrawImagePart(CDC *pDCDest, CRect rcDest, CDC *pDCSrc, CRect rcSrc) const | CXTPResourceImage | protected
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetBitmapPixel(CPoint pt, COLORREF &clrPixel) | CXTPResourceImage |
GetExtent() const | CXTPResourceImage |
GetHeight() const | CXTPResourceImage |
GetSource(int nState=0, int nCount=1) const | CXTPResourceImage |
GetWidth() const | CXTPResourceImage |
InvertBitmap() | CXTPResourceImage | protected
IsAlphaImage() const | CXTPResourceImage |
LoadFile(HMODULE hModule, LPCTSTR lpszBitmapFileName) | CXTPResourceImage |
m_bAlpha | CXTPResourceImage | protected
m_bFlipped | CXTPResourceImage | protected
m_bImageOrientaionPreserved | CXTPResourceImage | protected
m_bInvert | CXTPResourceImage | protected
m_bMultiply | CXTPResourceImage | protected
m_pBits | CXTPResourceImage | protected
m_pImages | CXTPResourceImage | protected
m_szExtent | CXTPResourceImage | protected
Premultiply() | CXTPResourceImage |
PreserveOrientation() | CXTPResourceImage |
SetBitmap(HBITMAP hBitmap, BOOL bAlpha=FALSE) | CXTPResourceImage |
~CXTPResourceImage() | CXTPResourceImage | virtual


Toolkit Pro: Member List

CXTPSplitPath Member List

This is the complete list of members for CXTPSplitPath, including all inherited members.

CXTPSplitPath(LPCTSTR lpszPathBuffer=NULL) | CXTPSplitPath |
GetDir() const | CXTPSplitPath |
GetDrive() const | CXTPSplitPath |
GetExt() const | CXTPSplitPath |
GetFName() const | CXTPSplitPath |
GetFullName() const | CXTPSplitPath |
GetFullPath() const | CXTPSplitPath |
m_szDir | CXTPSplitPath | protected
m_szDrive | CXTPSplitPath | protected
m_szExt | CXTPSplitPath | protected
m_szFName | CXTPSplitPath | protected
SplitPath(LPCTSTR lpszPathBuffer) | CXTPSplitPath |
~CXTPSplitPath() | CXTPSplitPath | virtual


Toolkit Pro: XTPGridThemeNativeWindows10.h Source File

  • Source
  • GridControl
  • Themes
XTPGridThemeNativeWindows10.h
Go to the documentation of this file.
1
23#if !defined(__XTPGRIDTHEMENATIVEWINDOWS10_H__)
24# define __XTPGRIDTHEMENATIVEWINDOWS10_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPGridThemeNativeWindows10 : public CXTPGridThemeOffice2013
39{
40public:
45 CXTPGridThemeNativeWindows10();
46
52 virtual void RefreshMetrics();
53};
55# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
56#endif //#if !defined(__XTPGRIDTHEMENATIVEWINDOWS10_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPGridThemeNativeWindows10
CXTPGridThemeNativeWindows10 is a CXTPGridThemeOffice2013 derived class that represents a Native Wind...
Definition XTPGridThemeNativeWindows10.h:39
CXTPGridThemeNativeWindows10::CXTPGridThemeNativeWindows10
CXTPGridThemeNativeWindows10()
Default paint manager constructor, handles properties initialization.
CXTPGridThemeNativeWindows10::RefreshMetrics
virtual void RefreshMetrics()
This method is called to refresh the visual metrics of the Grid control.
CXTPGridThemeOffice2013
CXTPGridThemeOffice2013 is a CXTPGridPaintManager derived class that represents an Office 2013 style ...
Definition XTPGridThemeOffice2013.h:39


Toolkit Pro: XTPMarkupExtension.h Source File

  • Source
  • Markup
  • Extensions
XTPMarkupExtension.h
Go to the documentation of this file.
1
23#if !defined(__XTPMARKUPEXTENSION_H__)
24# define __XTPMARKUPEXTENSION_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
37class _XTP_EXT_CLASS CXTPMarkupExtension : public CXTPMarkupObject
38{
40 DECLARE_MARKUPCLASS(CXTPMarkupExtension);
42protected:
47 CXTPMarkupExtension();
48};
49
50# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
52#endif // !defined(__XTPMARKUPEXTENSION_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPMarkupExtension
Base class for all markup extension objects.
Definition XTPMarkupExtension.h:38
CXTPMarkupExtension::CXTPMarkupExtension
CXTPMarkupExtension()
Constructs markup extension object.


Toolkit Pro: XTPTabColorSetOffice2007.h Source File

  • Source
  • TabManager
  • ColorSets
XTPTabColorSetOffice2007.h
Go to the documentation of this file.
1
23#if !defined(__XTPTABCOLORSETOFFICE2007_H__)
24# define __XTPTABCOLORSETOFFICE2007_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
37class _XTP_EXT_CLASS CXTPTabColorSetOffice2007 : public CXTPTabColorSetOffice2003
38{
39public:
47 virtual void RefreshMetrics();
48
66 void FillNavigateButton(CDC* pDC, CXTPTabManagerNavigateButton* pButton, CRect& rc);
67
68protected:
69 CXTPPaintManagerColor m_clrButtonText;
70};
71
72# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
74#endif // !defined(__XTPTABCOLORSETOFFICE2007_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPPaintManagerColor
The CXTPPaintManagerColor class is used to manage COLORREF values for determining default and applica...
Definition XTPColorManager.h:117
CXTPTabColorSetOffice2003
CXTPTabColorSetOffice2003 implements an Office 2003 tab color set.
Definition XTPTabColorSetOffice2003.h:44
CXTPTabColorSetOffice2007
CXTPTabColorSetOffice2007 implements an Office 2007 tab color set.
Definition XTPTabColorSetOffice2007.h:38
CXTPTabColorSetOffice2007::FillNavigateButton
void FillNavigateButton(CDC *pDC, CXTPTabManagerNavigateButton *pButton, CRect &rc)
Fills a specified tab navigation button.
CXTPTabColorSetOffice2007::m_clrButtonText
CXTPPaintManagerColor m_clrButtonText
Text color.
Definition XTPTabColorSetOffice2007.h:69
CXTPTabColorSetOffice2007::RefreshMetrics
virtual void RefreshMetrics()
Refreshes the visual metrics of the tabs.
CXTPTabManagerNavigateButton
CXTPTabManagerNavigateButton is a class used to represent a tab navigation button.
Definition XTPTabManagerNavigateButton.h:74


Toolkit Pro: Member List

CXTPTaskPanelShortcutBarOffice2003Theme Member List

This is the complete list of members for CXTPTaskPanelShortcutBarOffice2003Theme, including all inherited members.

BlendColor(COLORREF clrFrom, COLORREF clrTo, int nAlpha) | CXTPTaskPanelPaintManager | protected
CreateGripperBitmaps() | CXTPTaskPanelPaintManager | protected
CreateGripperIcon(HICON &hIcon, UINT nIDResource, COLORREF clrGripperBack) | CXTPTaskPanelPaintManager | protected
CXTPTaskPanelListViewOffice2003Theme() | CXTPTaskPanelListViewOffice2003Theme |
CXTPTaskPanelListViewOfficeXPTheme() | CXTPTaskPanelListViewOfficeXPTheme |
CXTPTaskPanelListViewTheme() | CXTPTaskPanelListViewTheme |
CXTPTaskPanelPaintManager() | CXTPTaskPanelPaintManager |
CXTPTaskPanelPaintManagerPlain() | CXTPTaskPanelPaintManagerPlain |
CXTPTaskPanelShortcutBarOffice2003Theme() | CXTPTaskPanelShortcutBarOffice2003Theme |
CXTPTaskPanelToolboxTheme() | CXTPTaskPanelToolboxTheme |
DrawCaptionGripper(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelPaintManager | protectedvirtual
DrawCaptionGripperBitmap(CDC *pDC, CXTPTaskPanelGroup *pGroup, BOOL bExpanded, BOOL bHot, CRect rc) | CXTPTaskPanelPaintManager | protected
DrawCaptionGripperSigns(CDC *pDC, CPoint pt, COLORREF clr, BOOL bExpanded) | CXTPTaskPanelPaintManager | protected
DrawDragArrow(CDC *pDC, CXTPTaskPanelItem *pItem, CRect rc, BOOL bAfter=FALSE) | CXTPTaskPanelPaintManager | protectedvirtual
DrawFocusRect(CDC *pDC, CRect rc) | CXTPTaskPanelPaintManager | protectedvirtual
DrawGroupCaption(CDC *pDC, CXTPTaskPanelGroup *pGroup, BOOL bDraw) | CXTPTaskPanelToolboxTheme | virtual
DrawGroupCaptionBackground(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelShortcutBarOffice2003Theme | protectedvirtual
DrawGroupClient(CDC *pDC, CXTPTaskPanelGroup *pGroup) | CXTPTaskPanelPaintManager | virtual
DrawGroupClientFace(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelShortcutBarOffice2003Theme | protectedvirtual
DrawGroupClientItems(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelPaintManager | protectedvirtual
DrawGroupItem(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw) | CXTPTaskPanelPaintManager | virtual
DrawGroupItemFrame(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc) | CXTPTaskPanelPaintManager | virtual
DrawGroupItemImage(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw) | CXTPTaskPanelPaintManager | protected
DrawGroupItemImageWithText(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw) | CXTPTaskPanelPaintManager | protected
DrawGroupItemImageWithTextBelow(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw) | CXTPTaskPanelPaintManager | protected
DrawItemCaption(CDC *pDC, CXTPTaskPanelItem *pItem, CRect rcText, UINT nFormat) | CXTPTaskPanelPaintManager | protectedvirtual
DrawItemImage(CDC *pDC, CXTPTaskPanelItem *pItem, CPoint ptIcon, CXTPImageManagerIcon *pImage, CSize szIcon) | CXTPTaskPanelPaintManager | protectedvirtual
DrawScrollButton(CDC *pDC, CXTPTaskPanelScrollButton *pScrollButton) | CXTPTaskPanelPaintManager | virtual
FillGroupClientFace(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelShortcutBarOffice2003Theme | protectedvirtual
FillTaskPanel(CDC *pDC, CXTPTaskPanel *pTaskPanel) | CXTPTaskPanelShortcutBarOffice2003Theme | protectedvirtual
FreeBitmaps() | CXTPTaskPanelPaintManager | protected
GetCaptionGripperWidth(CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelPaintManager | protectedvirtual
GetControlMargins(const CXTPTaskPanel *pPanel) | CXTPTaskPanelPaintManager | virtual
GetGroupColors(BOOL bSpecial) | CXTPTaskPanelPaintManager |
GetGroupColors(CXTPTaskPanelGroup *pGroup) | CXTPTaskPanelPaintManager | virtual
GetGroupInnerMargins(const CXTPTaskPanelGroup *pGroup) | CXTPTaskPanelPaintManager | virtual
GetGroupOuterMargins(const CXTPTaskPanelGroup *pGroup) | CXTPTaskPanelPaintManager | virtual
GetGroupSpacing(const CXTPTaskPanel *pPanel) | CXTPTaskPanelPaintManager | virtual
GetHighlightOffset(CXTPTaskPanelGroupItem *pItem) | CXTPTaskPanelPaintManager | protectedvirtual
GetItemFont(CXTPTaskPanelItem *pItem) | CXTPTaskPanelPaintManager | virtual
GetItemIconPadding(const CXTPTaskPanelItem *pItem) | CXTPTaskPanelPaintManager | virtual
GetItemInnerMargins(const CXTPTaskPanelGroupItem *pItem) | CXTPTaskPanelPaintManager | virtual
GetItemOuterMargins(const CXTPTaskPanelGroupItem *pItem) | CXTPTaskPanelPaintManager | virtual
m_bBoldCaption | CXTPTaskPanelPaintManager |
m_bCaptionScrollButton | CXTPTaskPanelPaintManager |
m_bEmbossedDisabledText | CXTPTaskPanelPaintManager |
m_bEmulateEplorerTheme | CXTPTaskPanelPaintManager |
m_bInvertDragRect | CXTPTaskPanelPaintManager |
m_bLeftRoundedCorner | CXTPTaskPanelPaintManager | protected
m_bmpGrippers | CXTPTaskPanelPaintManager | protected
m_bOfficeBorder | CXTPTaskPanelPaintManager | protected
m_bOfficeCaption | CXTPTaskPanelPaintManagerPlain | protected
m_bOfficeHighlight | CXTPTaskPanelPaintManager |
m_bRightRoundedCorner | CXTPTaskPanelPaintManager | protected
m_bRoundedFrame | CXTPTaskPanelPaintManagerPlain | protected
m_bUseBitmapGrippers | CXTPTaskPanelPaintManager | protected
m_bUseStandardCaptionFont | CXTPTaskPanelPaintManager | protected
m_bUseStandardItemsFont | CXTPTaskPanelPaintManager | protected
m_clrBackground | CXTPTaskPanelPaintManager | protected
m_clrHighlightBorder | CXTPTaskPanelPaintManager | protected
m_clrHighlightHot | CXTPTaskPanelPaintManager | protected
m_clrHighlightPressed | CXTPTaskPanelPaintManager | protected
m_clrHighlightSelected | CXTPTaskPanelPaintManager | protected
m_eGripper | CXTPTaskPanelPaintManager |
m_grcHot | CXTPTaskPanelListViewOffice2003Theme |
m_grcPushed | CXTPTaskPanelListViewOffice2003Theme |
m_groupNormal | CXTPTaskPanelPaintManager | protected
m_groupSpecial | CXTPTaskPanelPaintManager | protected
m_hGripperNormal | CXTPTaskPanelPaintManager | protected
m_hGripperSpecial | CXTPTaskPanelPaintManager | protected
m_nCaptionHeight | CXTPTaskPanelPaintManager | protected
m_nCaptionTextFormat | CXTPTaskPanelPaintManager | protected
m_nGroupSpacing | CXTPTaskPanelPaintManager |
m_nItemTextFormat | CXTPTaskPanelPaintManager | protected
m_rcControlMargins | CXTPTaskPanelPaintManager |
m_rcGroupIconPadding | CXTPTaskPanelPaintManager |
m_rcGroupInnerMargins | CXTPTaskPanelPaintManager |
m_rcGroupOuterMargins | CXTPTaskPanelPaintManager |
m_rcImageLayoutIconPadding | CXTPTaskPanelPaintManager |
m_rcItemIconPadding | CXTPTaskPanelPaintManager |
m_rcItemInnerMargins | CXTPTaskPanelPaintManager |
m_rcItemOuterMargins | CXTPTaskPanelPaintManager |
m_xtpFontCaption | CXTPTaskPanelPaintManager | protected
m_xtpFontIcon | CXTPTaskPanelPaintManager | protected
m_xtpFontIconBold | CXTPTaskPanelPaintManager | protected
m_xtpFontIconHot | CXTPTaskPanelPaintManager | protected
m_xtpFontIconHotBold | CXTPTaskPanelPaintManager | protected
Rectangle(CDC *pDC, CRect rc, COLORREF clrPen, COLORREF clrBrush) | CXTPTaskPanelPaintManager | protected
rectDefault | CXTPTaskPanelPaintManager | static
RefreshMetrics() | CXTPTaskPanelShortcutBarOffice2003Theme | virtual
SetCaptionFontIndirect(LOGFONT *pLogFont, BOOL bUseStandardCaptionFont=FALSE) | CXTPTaskPanelPaintManager |
SetItemsFontIndirect(LOGFONT *pLogFont, BOOL bUseStandardItemsFont=FALSE) | CXTPTaskPanelPaintManager |
SetTextFormat(int nTextFormat, BOOL bCaption=FALSE) | CXTPTaskPanelPaintManager |
~CXTPTaskPanelPaintManager() | CXTPTaskPanelPaintManager | virtual


Toolkit Pro: Member List

XTP_LVITEMDATA Member List

This is the complete list of members for XTP_LVITEMDATA, including all inherited members.

lpi | XTP_LVITEMDATA
lpsfParent | XTP_LVITEMDATA
ulAttribs | XTP_LVITEMDATA


Toolkit Pro: Member List

CXTPRibbonTabPopupToolBar Member List

This is the complete list of members for CXTPRibbonTabPopupToolBar, including all inherited members.

AdjustExcludeRect(CRect &rc, BOOL bVertical) | CXTPPopupBar | protectedvirtual
Animate() | CXTPPopupBar | protectedvirtual
CalcDynamicLayout(int nLength, DWORD nMode) | CXTPRibbonTabPopupToolBar | virtual
CalculatePopupRect(CPoint ptPopup, CSize sz) | CXTPRibbonTabPopupToolBar | virtual
Copy(CXTPCommandBar *pCommandBar, BOOL bRecursive=FALSE) | CXTPPopupBar | protectedvirtual
Create() | CXTPPopupBar | virtual
CreateKeyboardTips() | CXTPRibbonTabPopupToolBar | virtual
CreatePopupBar(CXTPCommandBars *pCommandBars) | CXTPPopupBar | static
CreatePopupToolBar(CXTPCommandBars *pCommandBars) | CXTPPopupToolBar | static
CXTPCommandBar() | CXTPCommandBar | protected
CXTPHookManagerHookAble() | CXTPHookManagerHookAble |
CXTPPopupBar() | CXTPPopupBar | protected
CXTPRibbonTabPopupToolBar(CXTPRibbonTab *pRibbonTab) | CXTPRibbonTabPopupToolBar |
DelayLayout() | CXTPCommandBar |
DelayRedraw() | CXTPPopupBar | inlineprotectedvirtual
DestroyWindow() | CXTPPopupBar |
DisableShadow() | CXTPPopupBar |
DoPropExchange(CXTPPropExchange *pPX) | CXTPPopupBar | protectedvirtual
DrawCommandBar(CDC *pDC, CRect rcClipBox) | CXTPRibbonTabPopupToolBar | virtual
EnableAnimation(BOOL bEnable=TRUE) | CXTPCommandBar |
EnableCustomization(BOOL bEnable=TRUE) | CXTPCommandBar |
EnableDoubleBuffer(BOOL bEnable=TRUE) | CXTPCommandBar |
EnsureVisible(CXTPControl *pControl) | CXTPRibbonTabPopupToolBar | virtual
ExpandBar() | CXTPPopupBar |
FillCommandBarEntry(CDC *pDC) | CXTPCommandBar | virtual
FindAccel(TCHAR chAccel) const | CXTPCommandBar |
FindAccelEx(UINT chAccel, BOOL &bSelectOnly) const | CXTPCommandBar |
GenerateCommandBarList(DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam) | CXTPCommandBar | protectedvirtual
GetActiveDocTemplate() const | CXTPCommandBar | protected
GetBarID() const | CXTPCommandBar |
GetBorders() | CXTPPopupBar | virtual
GetButtonSize() const | CXTPRibbonTabPopupToolBar | virtual
GetCommandBarData() const | CXTPCommandBar |
GetCommandBars() const | CXTPCommandBar |
GetControl(int nIndex) const | CXTPCommandBar |
GetControlCount() const | CXTPCommandBar |
GetControlPopup() const | CXTPPopupBar |
GetControls() const | CXTPCommandBar |
GetDefaultButtonStyle() const | CXTPCommandBar |
GetDefaultItem(UINT gmdiFlags, BOOL fByPos=FALSE) | CXTPPopupBar |
GetFlags() const | CXTPCommandBar |
GetFrameSite() const | CXTPCommandBar |
GetGroupsRect() const | CXTPRibbonTabPopupToolBar |
GetIconSize() const | CXTPRibbonTabPopupToolBar | virtual
GetImageManager() const | CXTPCommandBar |
GetLargeIconSize(BOOL bAutoSize) const | CXTPCommandBar |
GetOwnerSite() const | CXTPCommandBar |
GetPaintManager() const | CXTPCommandBar |
GetParentCommandBar() const | CXTPPopupBar | protectedvirtual
GetPosition() const | CXTPCommandBar |
GetRootParent() const | CXTPCommandBar |
GetSelected() const | CXTPCommandBar |
GetShowGripper() const | CXTPCommandBar |
GetSite() const | CXTPCommandBar |
GetTextOrientation() const | CXTPCommandBar |
GetTitle() const | CXTPCommandBar |
GetTrackFocus() const | CXTPCommandBar |
GetType() const | CXTPCommandBar |
GetWidth() const | CXTPCommandBar |
HideKeyboardTips() | CXTPCommandBar |
HitTestGroup(CPoint point) const | CXTPRibbonTabPopupToolBar |
InvalidateParents() | CXTPCommandBar |
IsAnimationEnabled() const | CXTPCommandBar |
IsContextMenu() const | CXTPPopupBar |
IsCustomizable() const | CXTPCommandBar | virtual
IsCustomizeDialogPresent() const | CXTPCommandBar |
IsCustomizeMode() const | CXTPCommandBar |
IsDialogBar() const | CXTPCommandBar | virtual
IsDoubleGripper() const | CXTPPopupBar |
IsHelpMode() const | CXTPCommandBar | protected
IsKeyboardCuesVisible() const | CXTPRibbonTabPopupToolBar | virtual
IsKeyboardTipsVisible() const | CXTPCommandBar |
IsLayoutRTL() const | CXTPCommandBar |
IsMenuTitleBar() const | CXTPCommandBar | virtual
IsPopupBar() const | CXTPPopupBar | virtual
IsResizable() const | CXTPPopupBar | virtual
IsRibbonBar() const | CXTPCommandBar | virtual
IsTearOffPopup(CString &strCaption, UINT &nID, int &nWidth) | CXTPPopupBar |
IsTextBelowIcons() const | CXTPCommandBar |
IsTrackingMode() const | CXTPCommandBar |
IsVisible() const | CXTPPopupBar | virtual
LoadMenu(CMenu *pMenu, BOOL bRemoveControls=TRUE) | CXTPCommandBar | virtual
LoadToolBar(UINT nIDResource, BOOL bLoadIcons=TRUE) | CXTPCommandBar | virtual
LockMouseMove(CXTPControl *pControl) | CXTPCommandBar |
LockRedraw() | CXTPCommandBar |
m_bAnimatePopup | CXTPCommandBar | protected
m_barPosition | CXTPCommandBar | protected
m_barType | CXTPCommandBar | protected
m_bAutoDestroy | CXTPHookManagerHookAble |
m_bCloseable | CXTPCommandBar | protected
m_bCollapsed | CXTPPopupBar | protected
m_bComboBar | CXTPCommandBar |
m_bContextMenu | CXTPPopupBar | protected
m_bCustomizable | CXTPCommandBar | protected
m_bCustomizeDialogPresent | CXTPCommandBar | protected
m_bDoubleGripper | CXTPPopupBar | protected
m_bDynamicLayout | CXTPPopupBar | protected
m_bExecOnRButton | CXTPCommandBar | protected
m_bExpanded | CXTPPopupBar | protected
m_bExpanding | CXTPPopupBar | protected
m_bGrabFocus | CXTPCommandBar | protected
m_bIgnoreUpdateHandler | CXTPCommandBar | protected
m_bKeyboardSelect | CXTPCommandBar | protected
m_bMultiLine | CXTPCommandBar | protected
m_bRecursePopup | CXTPCommandBar | protected
m_bResizable | CXTPPopupBar | protected
m_bShowShadow | CXTPPopupBar | protected
m_bTearOffPopup | CXTPPopupBar | protected
m_bTearOffSelected | CXTPPopupBar | protected
m_bTearOffTracking | CXTPPopupBar | protected
m_bTextBelow | CXTPCommandBar | protected
m_bTracking | CXTPCommandBar | protected
m_bTrackOnHover | CXTPCommandBar |
m_buttonStyle | CXTPCommandBar | protected
m_bVerticalMarker | CXTPCommandBar | protected
m_dMaxWidthDivisor | CXTPPopupBar | static
m_dwData | CXTPCommandBar | protected
m_dwFlags | CXTPCommandBar | protected
m_dwStyle | CXTPCommandBar | protected
m_hwndFocus | CXTPCommandBar | protected
m_nBarID | CXTPCommandBar | protected
m_nIdleFlags | CXTPCommandBar | protected
m_nLockRedraw | CXTPCommandBar | protected
m_nMaxHeight | CXTPPopupBar | protected
m_nMRUWidth | CXTPCommandBar | protected
m_nPopuped | CXTPCommandBar | protected
m_nSelected | CXTPCommandBar | protected
m_nStateFlags | CXTPCommandBar |
m_nTearOffID | CXTPPopupBar | protected
m_nTearOffTimer | CXTPPopupBar | protected
m_nTearOffWidth | CXTPPopupBar | protected
m_nTextOrientation | CXTPCommandBar | protected
m_pAnimation | CXTPCommandBar | protected
m_pCommandBars | CXTPCommandBar | protected
m_pControlPopup | CXTPPopupBar | protected
m_pControls | CXTPCommandBar | protected
m_pImageManager | CXTPCommandBar | protected
m_popupFlags | CXTPPopupBar | protected
m_pOwner | CXTPCommandBar | protected
m_pPaintManager | CXTPCommandBar | protected
m_pReturnCmd | CXTPCommandBar | protected
m_pRibbonBar | CXTPRibbonTabPopupToolBar |
m_pRibbonTab | CXTPRibbonTabPopupToolBar |
m_pSite | CXTPCommandBar | protected
m_pTearOffBar | CXTPPopupBar | protected
m_pToolTipContext | CXTPCommandBar | protected
m_ptPopup | CXTPPopupBar | protected
m_rcBorders | CXTPPopupBar | protected
m_rcExclude | CXTPPopupBar | protected
m_rcGroups | CXTPRibbonTabPopupToolBar |
m_rcMarker | CXTPCommandBar | protected
m_rcResizeGripper | CXTPPopupBar | protected
m_rcTearOffGripper | CXTPPopupBar | protected
m_strTearOffCaption | CXTPPopupBar | protected
m_strTitle | CXTPCommandBar | protected
m_szButtons | CXTPCommandBar | protected
m_szButtonSpacing | CXTPCommandBar | protected
m_szIcons | CXTPCommandBar | protected
m_szTearOffBar | CXTPPopupBar | protected
OnControlsChanged() | CXTPPopupBar | protectedvirtual
OnControlSelected(BOOL bSelected, CXTPControl *pControl) | CXTPCommandBar | virtual
OnCustomizeDragEnter(CXTPControl *pDataObject, CPoint point) | CXTPCommandBar | virtual
OnCustomizeDragLeave() | CXTPCommandBar | virtual
OnCustomizeDragOver(CXTPControl *pDataObject, CPoint point) | CXTPCommandBar | virtual
OnCustomizeDrop(CXTPControl *pDataObject, DROPEFFECT &dropEffect, CPoint ptDrop, CPoint ptDrag) | CXTPCommandBar | virtual
OnGroupsScroll(BOOL bScrollLeft) | CXTPRibbonTabPopupToolBar |
OnHookAttached(HWND hWnd) | CXTPHookManagerHookAble | virtual
OnHookDetached() | CXTPHookManagerHookAble | virtual
OnHookKeyDown(UINT nChar, LPARAM lParam) | CXTPPopupBar | protectedvirtual
OnHookMessage(HWND hWnd, UINT nMessage, WPARAM &wParam, LPARAM &lParam, LRESULT &lResult) | CXTPCommandBar | virtual
OnKeyboardTip(CXTPCommandBarKeyboardTip *pTip) | CXTPRibbonTabPopupToolBar | virtual
OnKeyboardTipChar(UINT chAccel) | CXTPCommandBar |
OnMouseHitTest(CPoint pt) | CXTPCommandBar | protectedvirtual
OnPostHookMessage(HWND hWnd, UINT nMessage, WPARAM &wParam, LPARAM &lParam, LRESULT &lResult) | CXTPHookManagerHookAble | virtual
OnRecalcLayout() | CXTPPopupBar | protectedvirtual
OnRemoved() | CXTPCommandBar | protectedvirtual
OnToolHitTest(CPoint point, TOOLINFO *pTI) const | CXTPRibbonTabPopupToolBar |
OnTrackEnter() | CXTPCommandBar | virtual
OnTrackLost() | CXTPCommandBar | virtual
Popup(int xPos, int yPos, LPCRECT rcExclude) | CXTPPopupBar |
Popup(CXTPControlPopup *pControlPopup, BOOL bSelectFirst=FALSE) | CXTPPopupBar | virtual
ProcessSpecialKey(XTPSpecialKey key) | CXTPRibbonTabPopupToolBar | protectedvirtual
PumpMessage() | CXTPPopupBar |
Redraw(LPCRECT lpRect=0, BOOL bAnimate=TRUE) | CXTPCommandBar | virtual
RestoreCommandBarList(CXTPCommandBarList *pCommandBarList) | CXTPCommandBar | protectedvirtual
s_nExpandDelay | CXTPCommandBar | static
s_nExpandHoverDelay | CXTPCommandBar | static
s_nHoverDelay | CXTPCommandBar | static
SetBarID(UINT nID) | CXTPCommandBar |
SetBorders(CRect rcBorders) | CXTPPopupBar |
SetButtons(UINT *pButtons, int nCount) | CXTPCommandBar |
SetButtonSize(CSize size) | CXTPCommandBar |
SetCommandBarData(DWORD_PTR dwData) | CXTPCommandBar |
SetCommandBars(CXTPCommandBars *pCommandBars) | CXTPCommandBar |
SetControls(CXTPControls *pControls) | CXTPCommandBar |
SetDefaultButtonStyle(XTPButtonStyle buttonStyle) | CXTPCommandBar |
SetDefaultItem(UINT uItem, BOOL fByPos=FALSE) | CXTPPopupBar |
SetDoubleGripper(BOOL bDoubleGripper=TRUE) | CXTPPopupBar |
SetFlags(DWORD dwFlagsAdd, DWORD dwFlagsRemove=0) | CXTPCommandBar |
SetGrabFocus(BOOL bGrabFocus) | CXTPCommandBar |
SetIconSize(CSize size) | CXTPCommandBar |
SetImageManager(CXTPImageManager *pImageManager) | CXTPCommandBar |
SetPaintManager(CXTPPaintManager *pPaintManager) | CXTPCommandBar |
SetPopuped(int nPopuped, BOOL bKeyboard=FALSE) | CXTPCommandBar |
SetPopupFlags(DWORD dwPopupFlags) | CXTPPopupBar |
SetPopupToolBar(BOOL bToolBarType) | CXTPPopupBar |
SetPosition(XTPBarPosition barPosition) | CXTPCommandBar | virtual
SetSelected(int nSelected, BOOL bKeyboard=FALSE) | CXTPPopupBar | protectedvirtual
SetShowGripper(BOOL bShow) | CXTPCommandBar |
SetStatusText(const CString &strDescription) | CXTPCommandBar |
SetTearOffPopup(LPCTSTR lpszCaption, UINT nID, int nWidth=400) | CXTPPopupBar |
SetTextOrientation(XTPBarTextOrientation nTextOrientation) | CXTPCommandBar |
SetTitle(LPCTSTR lpszTitle) | CXTPCommandBar |
SetTrackFocus(HWND hwnd) | CXTPCommandBar |
SetTrackingMode(int bMode, BOOL bSelectFirst=TRUE, BOOL bKeyboard=FALSE) | CXTPRibbonTabPopupToolBar | virtual
SetVisible(BOOL bVisible) | CXTPCommandBar | virtual
SetWidth(int nWidth) | CXTPCommandBar |
ShowTextBelowIcons(BOOL bTextBelow=TRUE) | CXTPCommandBar |
UnlockMouseMove() | CXTPCommandBar |
UnlockRedraw() | CXTPCommandBar |
UpdateExpandingState() | CXTPPopupBar | protected
UpdateFlags() | CXTPPopupBar | protectedvirtual
UpdateLocation(CSize sz) | CXTPPopupBar | protected
UpdateShortcuts() | CXTPCommandBar | protectedvirtual
~CXTPCommandBar() | CXTPCommandBar | protectedvirtual
~CXTPHookManagerHookAble() | CXTPHookManagerHookAble | virtual
~CXTPPopupBar() | CXTPPopupBar | protectedvirtual
~CXTPRibbonTabPopupToolBar() | CXTPRibbonTabPopupToolBar |


Toolkit Pro: Member List

CXTPSyntaxEditTextIterator Member List

This is the complete list of members for CXTPSyntaxEditTextIterator, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPSyntaxEditTextIterator(CXTPSyntaxEditBufferManager *pData) | CXTPSyntaxEditTextIterator |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetBuffer(int nOffsetB) const | CXTPSyntaxEditTextIterator | protected
GetEOL() const | CXTPSyntaxEditTextIterator | virtual
GetFileExt() const | CXTPSyntaxEditTextIterator | virtual
GetLineLen(int nLine, BOOL bWithEOL=FALSE) const | CXTPSyntaxEditTextIterator | virtual
GetLineLenBytes(int nLine, BOOL bWithEOL) const | CXTPSyntaxEditTextIterator | virtual
GetMaxBackOffset() const | CXTPSyntaxEditTextIterator | virtual
GetPosLC() const | CXTPSyntaxEditTextIterator | virtual
GetPosLC_last(BOOL bWithEOL) const | CXTPSyntaxEditTextIterator | virtual
GetText(int nCharsBuf=512) | CXTPSyntaxEditTextIterator | virtual
IsEOF() const | CXTPSyntaxEditTextIterator | virtual
LCPosAdd(XTP_EDIT_LINECOL &rLC, int nCharsAdd) const | CXTPSyntaxEditTextIterator | virtual
LCPosDec(XTP_EDIT_LINECOL &rLC) const | CXTPSyntaxEditTextIterator | virtual
m_arBuffer | CXTPSyntaxEditTextIterator | protected
m_bEOF | CXTPSyntaxEditTextIterator | protected
m_LCpos | CXTPSyntaxEditTextIterator | protected
m_mapLine2Len | CXTPSyntaxEditTextIterator | protected
m_nBufOffsetB | CXTPSyntaxEditTextIterator | protected
m_nBufOffsetB_max | CXTPSyntaxEditTextIterator | protected
m_nBufOffsetB_normal | CXTPSyntaxEditTextIterator | protected
m_nBufSizeB | CXTPSyntaxEditTextIterator | protected
m_nNextLine | CXTPSyntaxEditTextIterator | protected
m_nTmpOffsetB | CXTPSyntaxEditTextIterator | protected
m_nTmpOffsetC | CXTPSyntaxEditTextIterator | protected
m_pData | CXTPSyntaxEditTextIterator | protected
SeekBegin() | CXTPSyntaxEditTextIterator | virtual
SeekNext(DWORD dwChars=1, int nCharsBuf=512) | CXTPSyntaxEditTextIterator | virtual
SeekPos(const XTP_EDIT_LINECOL &posLC, HANDLE hBreakEvent=NULL) | CXTPSyntaxEditTextIterator | virtual
SeekPrev() | CXTPSyntaxEditTextIterator | virtual
SetTxtOffset(int nOffsetChars) | CXTPSyntaxEditTextIterator | virtual
~CXTPSyntaxEditTextIterator(void) | CXTPSyntaxEditTextIterator | virtual


Toolkit Pro: XTPComboBoxThemeOffice2003.h Source File

  • Source
  • Controls
  • Combo
  • Themes
XTPComboBoxThemeOffice2003.h
Go to the documentation of this file.
1
23#ifndef XTPComboBoxThemeOffice2003_h__
24# define XTPComboBoxThemeOffice2003_h__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPComboBoxThemeOffice2003 : public CXTPComboBoxTheme
39{
40protected:
41 BOOL m_bHighlight;
42
43public:
48 CXTPComboBoxThemeOffice2003();
49
54 virtual ~CXTPComboBoxThemeOffice2003();
55
56 virtual void DrawBackground(CDC* pDC, CXTPComboBox* pComboBox);
57
66 virtual void DrawButton(CDC* pDC, CXTPComboBox* pComboBox, CRect rcBtn);
67
74 virtual void RefreshMetrics(CXTPComboBox* pComboBox);
75};
76
77# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
79#endif // XTPComboBoxThemeOffice2003_h__
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPComboBox
The CXTPComboBox class provides the functionality of a themed Windows combobox.
Definition XTPComboBox.h:42
CXTPComboBoxTheme
CXTPComboBoxTheme is a class used to perform ComboBox Theme drawing tasks.
Definition XTPComboBoxTheme.h:42
CXTPComboBoxThemeOffice2003
Used as the paint manager for a combobox control to render an Office 2003 appearance.
Definition XTPComboBoxThemeOffice2003.h:39
CXTPComboBoxThemeOffice2003::CXTPComboBoxThemeOffice2003
CXTPComboBoxThemeOffice2003()
Default constructor.
CXTPComboBoxThemeOffice2003::~CXTPComboBoxThemeOffice2003
virtual ~CXTPComboBoxThemeOffice2003()
Destructor handles cleanup and deallocation.
CXTPComboBoxThemeOffice2003::RefreshMetrics
virtual void RefreshMetrics(CXTPComboBox *pComboBox)
This member function is called by the theme manager to refresh the visual styles used by each compone...
CXTPComboBoxThemeOffice2003::DrawButton
virtual void DrawButton(CDC *pDC, CXTPComboBox *pComboBox, CRect rcBtn)
Called by the paint manager to draw the button portion of the combobox control.
CXTPComboBoxThemeOffice2003::DrawBackground
virtual void DrawBackground(CDC *pDC, CXTPComboBox *pComboBox)
This member function is called to draw the combobox background.


Toolkit Pro: Member List

CXTPRibbonTheme Member List

This is the complete list of members for CXTPRibbonTheme, including all inherited members.

AdjustExcludeRect(CRect &rc, CXTPControl *pControl, BOOL bVertical) | CXTPRibbonTheme | protectedvirtual
Animate(CDC *pDestDC, CDC *pSrcDC, CRect rc, XTPAnimationType animationType) | CXTPPaintManager | virtual
AnimateExpanding(CXTPCommandBar *pCommandBar, CDC *pDestDC, CDC *pSrcDC, BOOL bExpandDown) | CXTPPaintManager | virtual
BaseTheme() | CXTPRibbonTheme | inlineprotectedvirtual
CreateGradientCircle() | CXTPCommandBarsOffice2003Theme | protected
CreateTheme(XTPPaintTheme paintTheme) | CXTPPaintManager | static
CXTPCmdTarget() | CXTPCmdTarget |
CXTPCommandBarsOffice2003Theme() | CXTPCommandBarsOffice2003Theme |
CXTPCommandBarsOfficeXPTheme() | CXTPCommandBarsOfficeXPTheme |
CXTPObservable() | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | protected
CXTPPaintManager() | CXTPPaintManager | protected
CXTPResourceTheme() | CXTPResourceTheme |
CXTPRibbonTheme() | CXTPRibbonTheme |
Draw3dRect(CDC *pDC, LPCRECT rc, int nTopLeft, int nBottomRight) | CXTPPaintManager |
Draw3dRect(CDC *pDC, LPCRECT rc, int frameThickness, COLORREF clrPen, COLORREF clrBrush) | CXTPPaintManager |
CXTPPaintManager::DrawCheckMark(CDC *pDC, CRect rcCheck, COLORREF clr=0) | CXTPPaintManager | inline
DrawComboExpandMark(CDC *pDC, CRect rc, COLORREF clr) | CXTPPaintManager | virtual
DrawCommandBarGripper(CDC *pDC, CXTPCommandBar *pBar, BOOL bDraw=TRUE) | CXTPRibbonTheme | protectedvirtual
DrawCommandBarGroupSeparator(CDC *pDC, CXTPCommandBar *pBar, CXTPControl *pLeftControl, CXTPControl *pRightControl, BOOL bDraw=TRUE) | CXTPPaintManager | virtual
DrawCommandBarSeparator(CDC *pDC, CXTPCommandBar *pBar, CXTPControl *pControl, BOOL bDraw) | CXTPRibbonTheme | protectedvirtual
DrawControl(CDC *pDC, CXTPControl *pButton, BOOL bDraw=TRUE) | CXTPPaintManager |
DrawControlCheckBoxMark(CDC *pDC, CRect rc, BOOL bDraw, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled) | CXTPCommandBarsOfficeXPTheme | protectedvirtual
DrawControlCheckBoxMark(CDC *pDC, CXTPControl *pButton, CRect rc, BOOL bDraw) | CXTPCommandBarsOfficeXPTheme | protectedvirtual
DrawControlComboBox(CDC *pDC, CXTPControlComboBox *pComboBox, BOOL bDraw) | CXTPRibbonTheme | protectedvirtual
DrawControlEdit(CDC *pDC, CXTPControlEdit *pControlEdit, BOOL bDraw) | CXTPRibbonTheme | protectedvirtual
DrawControlEntry(CDC *pDC, CXTPControl *pButton) | CXTPRibbonTheme | protectedvirtual
DrawControlMDIButton(CDC *pDC, CXTPControlButton *pButton) | CXTPPaintManager | virtual
DrawControlPopupGlyph(CDC *pDC, CXTPControl *pButton) | CXTPRibbonTheme | protectedvirtual
DrawControlPopupParent(CDC *pDC, CXTPControl *pButton, BOOL bDraw) | CXTPCommandBarsOfficeXPTheme | protectedvirtual
DrawControlRadioButtonMark(CDC *pDC, CRect rc, BOOL bDraw, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled) | CXTPCommandBarsOfficeXPTheme | protectedvirtual
DrawControlText(CDC *pDC, CXTPControl *pControl, CRect rcText, BOOL bDraw, BOOL bVert, BOOL bCentered, BOOL bTriangled) | CXTPPaintManager |
DrawControlToolBarParent(CDC *pDC, CXTPControl *pButton, BOOL bDraw) | CXTPPaintManager | virtual
DrawDialogBarGripper(CDC *pDC, CXTPDialogBar *pBar, BOOL bDraw) | CXTPCommandBarsOffice2003Theme | protectedvirtual
DrawDropDownGlyph(CDC *pDC, CXTPControl *pControl, CPoint pt, BOOL bSelected, BOOL bPopuped, BOOL bEnabled, BOOL bVert) | CXTPPaintManager | virtual
DrawExpandGlyph(CDC *pDC, CXTPControl *pButton, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clr) | CXTPPaintManager | virtual
DrawExpandGlyph(CDC *pDC, CXTPControl *pButton, COLORREF clr, BOOL bVertical) | CXTPPaintManager | virtual
DrawGalleryItemBack(CDC *pDC, CRect rcItem, BOOL bEnabled, BOOL bSelected, BOOL bPressed, BOOL bChecked, XTPBarType barType) | CXTPPaintManager | virtual
DrawHiddenGlyph(CDC *pDC, CXTPControl *pButton, COLORREF clr, BOOL bVertical) | CXTPPaintManager | virtual
DrawImage(CDC *pDC, CPoint pt, CSize sz, CXTPImageManagerIcon *pImage, BOOL bSelected, BOOL bPressed, BOOL bEnabled=TRUE, BOOL bChecked=FALSE, BOOL bPopuped=FALSE, BOOL bToolBarImage=TRUE) | CXTPCommandBarsOfficeXPTheme | protectedvirtual
DrawKeyboardTip(CDC *pDC, CXTPCommandBarKeyboardTip *pWnd, BOOL bSetRegion) | CXTPRibbonTheme | protectedvirtual
DrawListBoxControl(CDC *pDC, CXTPControl *pButton, CRect rc, BOOL bSelected, BOOL bDraw, CXTPCommandBars *pCommandBars=0) | CXTPCommandBarsOfficeXPTheme | virtual
DrawPopupBarCheckMark(CDC *pDC, CRect rcCheck, BOOL bEnabled, COLORREF clr) | CXTPRibbonTheme | protectedvirtual
DrawPopupBarGripper(CDC *pDC, int xPos, int yPos, int cx, int cy, BOOL bExpanded=FALSE) | CXTPRibbonTheme | protectedvirtual
DrawPopupBarRadioMark(CDC *pDC, CRect rcCheck, BOOL bEnabled, COLORREF clr) | CXTPRibbonTheme | protectedvirtual
DrawPopupResizeGripper(CDC *pDC, CRect rcGripper, int nFlags) | CXTPRibbonTheme | protectedvirtual
DrawRectangle(CDC *pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition) | CXTPRibbonTheme | protectedvirtual
DrawRectangle(CDC *pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition, int nID) | CXTPRibbonTheme | protectedvirtual
DrawRectangle(CDC *pDC, CXTPControl *pButton) | CXTPRibbonTheme | protectedvirtual
DrawSpecialControl(CDC *pDC, XTPSpecialControl controlType, CXTPControl *pButton, CXTPCommandBar *pBar, BOOL bDraw, LPVOID lpParam) | CXTPRibbonTheme | protectedvirtual
DrawSplitButtonFrame(CDC *pDC, CXTPControl *pButton, CRect rc) | CXTPRibbonTheme | protectedvirtual
DrawSplitButtonPopup(CDC *pDC, CXTPControl *pButton) | CXTPRibbonTheme | protectedvirtual
DrawStatusBarGripper(CDC *pDC, CRect rcClient) | CXTPRibbonTheme | protectedvirtual
DrawStatusBarPaneBorder(CDC *pDC, CRect rc, CXTPStatusBarPane *pPane, BOOL bGripperPane) | CXTPRibbonTheme | protectedvirtual
DrawStatusBarPaneSeparator(CDC *pDC, CRect rc, CXTPStatusBarPane *pPane) | CXTPRibbonTheme | protectedvirtual
DrawStatusBarSwitchPane(CDC *pDC, CRect rcItem, CXTPStatusBarSwitchPane *pPane) | CXTPRibbonTheme | protectedvirtual
DrawTearOffGripper(CDC *pDC, CRect rcGripper, BOOL bSelected, BOOL bDraw) | CXTPCommandBarsOffice2003Theme | protectedvirtual
ExcludeCorners(CDC *pDC, CRect rc) | CXTPCommandBarsOffice2003Theme |
FillCommandBarEntry(CDC *pDC, CXTPCommandBar *pBar) | CXTPRibbonTheme | protectedvirtual
FillDockBar(CDC *pDC, CXTPDockBar *pBar) | CXTPCommandBarsOffice2003Theme | protectedvirtual
FillIntersectRect(CDC *pDC, CXTPPopupBar *pPopupBar, COLORREF clr) | CXTPCommandBarsOfficeXPTheme | protected
FillPopupLabelEntry(CDC *pDC, CRect rc) | CXTPRibbonTheme | protectedvirtual
FillStatusBar(CDC *pDC, CXTPStatusBar *pBar) | CXTPRibbonTheme | protectedvirtual
FillWorkspace(CDC *pDC, CRect rc, CRect rcExclude) | CXTPResourceTheme | virtual
FontExists(LPCTSTR lpszFaceName) | CXTPPaintManager | static
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCommandBarBorders(CXTPCommandBar *pBar) | CXTPCommandBarsOffice2003Theme | protectedvirtual
GetCommandBarFont(CXTPCommandBar *pCommandBar) | CXTPPaintManager | virtual
GetControlBackColor(CXTPControl *pButton) | CXTPPaintManager | virtual
GetControlEditBackColor(CXTPControl *pControl) | CXTPRibbonTheme | protectedvirtual
GetControlFont(CXTPControl *pControl) | CXTPPaintManager | virtual
GetControlHeight() const | CXTPPaintManager |
GetControlTextColor(CXTPControl *pButton) | CXTPRibbonTheme | protectedvirtual
GetControlTextOrientation(CXTPControl *pControl) | CXTPPaintManager | virtual
GetCurrentSystemTheme() | CXTPPaintManager |
GetCurrentTheme() | CXTPPaintManager | inline
GetDefaultCommandBarSize(CXTPCommandBar *pBar) | CXTPPaintManager | virtual
GetFramePaintManager() | CXTPResourceTheme | virtual
GetGalleryPaintManager() const | CXTPPaintManager | virtual
GetGlobalPaintManager() | CXTPPaintManager | static
GetIconFont() | CXTPPaintManager |
GetIconsInfo() | CXTPPaintManager |
GetImages() const | CXTPResourceTheme |
GetInstanceAddRef() | CXTPPaintManager | static
GetMessageBarPaintManager() | CXTPPaintManager | virtual
GetModernBitmap(UINT nIDResource) | CXTPCommandBarsOffice2003Theme | static
GetPopupBarGripperWidth(CXTPCommandBar *pBar) | CXTPPaintManager | virtual
GetProgressPaintManager() const | CXTPPaintManager | virtual
GetRectangleTextColor(BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition) | CXTPRibbonTheme | protectedvirtual
GetRegularBoldFont() | CXTPPaintManager |
GetRegularFont() | CXTPPaintManager |
GetRibbonPaintManager() | CXTPResourceTheme | virtual
GetScrollBarPaintManager() const | CXTPPaintManager | virtual
GetShadowManager() const | CXTPPaintManager |
GetShadowOptions() const | CXTPPaintManager |
GetSliderPaintManager() const | CXTPPaintManager | virtual
GetSmCaptionFont() | CXTPPaintManager |
GetSplitButtonCommandRect(CXTPControl *pButton) | CXTPPaintManager | virtual
GetStatusBarPaintManager() | CXTPPaintManager | virtual
GetXtremeColor(UINT nIndex) | CXTPPaintManager |
GradientFill(CDC *pDC, LPRECT lpRect, COLORREF crFrom, COLORREF crTo, BOOL bHorz, LPCRECT lpRectClip=NULL) | CXTPPaintManager |
HasFloatingBarGradientEntry(CXTPCommandBar *pBar) | CXTPCommandBarsOffice2003Theme | protectedvirtual
HorizontalLine(CDC *pDC, int x0, int y0, int x1, COLORREF clrPen) | CXTPPaintManager |
IsImagesAvailable() | CXTPRibbonTheme | protected
IsUseSystemAccentColorEnabled() const | CXTPPaintManager |
Line(CDC *pDC, CPoint p0, CPoint p1) | CXTPPaintManager |
Line(CDC *pDC, int x0, int y0, int x1, int y1, const int nPen) | CXTPPaintManager |
Line(CDC *pDC, int x0, int y0, int x1, int y1, COLORREF clrPen) | CXTPPaintManager |
LoadImage(LPCTSTR lpszFileName) | CXTPResourceTheme |
LoadModernToolbarIcons(UINT nIDResource) | CXTPCommandBarsOffice2003Theme | static
LoadModernToolbarIcons(UINT nIDResource, UINT *pCommands, int nCount, CSize szIcon=CSize(16, 15)) | CXTPCommandBarsOffice2003Theme | static
m_arrColor | CXTPPaintManager | protected
m_bAutoResizeIcons | CXTPPaintManager |
m_bClearTypeTextQuality | CXTPPaintManager |
m_bEmbossedDisabledText | CXTPPaintManager | protected
m_bEnableAnimation | CXTPPaintManager |
m_bFlatMenuBar | CXTPPaintManager |
m_bFlatToolBar | CXTPPaintManager |
m_bLunaTheme | CXTPCommandBarsOffice2003Theme |
m_bOffice2007Padding | CXTPPaintManager |
m_bOffsetPopupLabelText | CXTPPaintManager |
m_bPlainSeparators | CXTPCommandBarsOffice2003Theme |
m_bSelectImageInPopupBar | CXTPPaintManager |
m_bShowKeyboardCues | CXTPPaintManager | protected
m_bShowShadow | CXTPPaintManager |
m_bThemedCheckBox | CXTPPaintManager |
m_bThemedStatusBar | CXTPPaintManager |
m_bThickCheckMark | CXTPPaintManager |
m_bUseOfficeFont | CXTPPaintManager |
m_bUseStandardFont | CXTPPaintManager | protected
m_bWrapCaptionBelowText | CXTPPaintManager |
m_clrCommandBar | CXTPCommandBarsOffice2003Theme |
m_clrControlEditDisabledBorder | CXTPRibbonTheme | protected
m_clrControlEditNormal | CXTPRibbonTheme | protected
m_clrControlEditSelected | CXTPRibbonTheme | protected
m_clrDisabledIcon | CXTPPaintManager |
m_clrDockBar | CXTPCommandBarsOffice2003Theme |
m_clrFloatingGripper | CXTPPaintManager |
m_clrFloatingGripperText | CXTPPaintManager |
m_clrMenuExpand | CXTPCommandBarsOffice2003Theme |
m_clrMenuExpandedGripper | CXTPCommandBarsOffice2003Theme |
m_clrMenuGripper | CXTPCommandBarsOffice2003Theme |
m_clrMenuPopupGripperShadow | CXTPRibbonTheme | protected
m_clrMenuPopupSeparator | CXTPRibbonTheme | protected
m_clrMessageBarText | CXTPPaintManager |
m_clrPopupControl | CXTPCommandBarsOffice2003Theme |
m_clrRibbonGrayText | CXTPRibbonTheme | protected
m_clrRibbonText | CXTPRibbonTheme | protected
m_clrTearOffGripper | CXTPCommandBarsOffice2003Theme |
m_clrToolbarExpand | CXTPCommandBarsOffice2003Theme |
m_clrToolbarShadow | CXTPCommandBarsOffice2003Theme |
m_fontIcon | CXTPPaintManager |
m_fontIconBold | CXTPPaintManager |
m_fontSmCaption | CXTPPaintManager |
m_fontToolTip | CXTPPaintManager |
m_grcLunaChecked | CXTPCommandBarsOffice2003Theme |
m_grcLunaPushed | CXTPCommandBarsOffice2003Theme |
m_grcLunaSelected | CXTPCommandBarsOffice2003Theme |
m_iconsInfo | CXTPPaintManager | protected
m_ilGradientCircle | CXTPCommandBarsOffice2003Theme |
m_nAnimationSteps | CXTPPaintManager | protected
m_nAnimationTime | CXTPPaintManager | protected
m_nEditHeight | CXTPPaintManager | protected
m_nFontHeight | CXTPPaintManager | protected
m_nPopupBarTextPadding | CXTPPaintManager |
m_nRibbonCaptionHeight | CXTPResourceTheme | protected
m_nSplitButtonDropDownHeight | CXTPPaintManager |
m_nSplitButtonDropDownWidth | CXTPPaintManager |
m_nSplitButtonPopupWidth | CXTPPaintManager |
m_nStatusBarMinHeight | CXTPPaintManager |
m_nTextHeight | CXTPPaintManager |
m_pfnSetLayeredWindowAttributes | CXTPPaintManager |
m_pFramePaintManager | CXTPPaintManager |
m_pGalleryPaintManager | CXTPPaintManager |
m_pProgressPaintManager | CXTPPaintManager |
m_pRibbonPaintManager | CXTPPaintManager |
m_pScrollBarPaintManager | CXTPPaintManager |
m_pShadowManager | CXTPPaintManager | protected
m_pSliderPaintManager | CXTPPaintManager |
m_pStatusBarPaintManager | CXTPPaintManager |
m_rcMessageBarMargin | CXTPPaintManager |
m_rcStatusBarBorder | CXTPPaintManager |
m_strOfficeFont | CXTPPaintManager |
m_systemTheme | CXTPPaintManager | protected
m_themeButton | CXTPPaintManager | protected
m_themeCurrent | CXTPPaintManager | protected
m_themeStatusBar | CXTPPaintManager | protected
m_xtpFontRegular | CXTPPaintManager | protected
m_xtpFontRegularBold | CXTPPaintManager | protected
m_xtpFontVert | CXTPPaintManager | protected
m_xtpFontVertBold | CXTPPaintManager | protected
Notify(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *)) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
Notify(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1), A1 arg1) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
Notify(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
Notify(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamic(void(T::*method)(O *)) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1), A1 arg1) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *)) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1), A1 arg1) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyReversed(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *)) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyReversed(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1), A1 arg1) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyReversed(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyReversed(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
Pixel(CDC *pDC, int xPos, int yPos, int nPen) | CXTPPaintManager |
Rectangle(CDC *pDC, LPCRECT rc, int nPen, const int nBrush) | CXTPPaintManager |
Rectangle(CDC *pDC, LPCRECT rc, COLORREF clrPen, COLORREF clrBrush) | CXTPPaintManager |
RefreshMetrics() | CXTPRibbonTheme | virtual
ReleaseInstance() | CXTPPaintManager | static
RequiresResourceImages() | CXTPResourceTheme | virtual
RoundRect(CDC *pDC, LPCRECT rc, COLORREF clrPen, COLORREF clrBrush) | CXTPPaintManager |
SetAnimationDelay(int nAnimationSteps, int nAnimationTime) | CXTPPaintManager |
SetColors(int cElements, CONST INT *lpaElements, CONST COLORREF *lpaRgbValues) | CXTPPaintManager |
SetCommandBarRegion(CXTPCommandBar *pCommandBar) | CXTPRibbonTheme | protectedvirtual
SetCommandBarsFontIndirect(LOGFONT *pLogFont, BOOL bUseStandardFont=FALSE) | CXTPPaintManager |
SetCustomTheme(CXTPPaintManager *pTheme) | CXTPPaintManager | static
SetGlobalPaintManager(CXTPPaintManager *pPaintManager) | CXTPPaintManager | static
SetImageHandle(HMODULE hResource, LPCTSTR lpszIniFileName) | CXTPResourceTheme | virtual
SetImages(CXTPResourceImages *pImages) | CXTPResourceTheme |
SetLunaTheme(XTPCurrentSystemTheme systemTheme) | CXTPPaintManager |
SetRibbonPaintManager(CXTPRibbonPaintManager *pRibbonPaintManager) | CXTPRibbonTheme |
SetRoundRectRegion(CWnd *pWnd) | CXTPRibbonTheme | protected
SetTheme(XTPPaintTheme paintTheme) | CXTPPaintManager | static
StripMnemonics(CString &strClear) | CXTPPaintManager | static
Subscribe(IXTPPaintManagerEvents *pObserver, CXTPSubscriptionList< CXTPPaintManager, IXTPPaintManagerEvents > *pSubcriptionList=NULL) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > |
Triangle(CDC *pDC, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clr) | CXTPPaintManager | static
Unsubscribe(IXTPPaintManagerEvents *pObserver) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > |
UpdateColors() | CXTPPaintManager | virtual
UpdateFonts() | CXTPPaintManager | virtual
UpdateRTLCaption(CString &strCaption) | CXTPPaintManager | virtual
UseOfficeFont(bool bUseOfficeFont) | CXTPPaintManager |
VerticalLine(CDC *pDC, int x0, int y0, int y1, COLORREF clrPen) | CXTPPaintManager |
~CXTPCommandBarsOffice2003Theme() | CXTPCommandBarsOffice2003Theme | virtual
~CXTPObservable() | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | protected
~CXTPPaintManager() | CXTPPaintManager | protectedvirtual
~CXTPResourceTheme() | CXTPResourceTheme | virtual
~CXTPRibbonTheme() | CXTPRibbonTheme | virtual


Toolkit Pro: Member List

XTP_EDIT_NMHDR_ENABLESCROLLBAR Member List

This is the complete list of members for XTP_EDIT_NMHDR_ENABLESCROLLBAR, including all inherited members.

dwScrollBar | XTP_EDIT_NMHDR_ENABLESCROLLBAR
dwState | XTP_EDIT_NMHDR_ENABLESCROLLBAR
nmhdr | XTP_EDIT_NMHDR_ENABLESCROLLBAR


Toolkit Pro: XTPSkinManagerApiHookConfig.h Source File

  • Source
  • SkinFramework
  • ApiHook
XTPSkinManagerApiHookConfig.h
Go to the documentation of this file.
1
23#if !defined(__XTPSKINMANAGERAPIHOOKCONFIG_H__)
24# define __XTPSKINMANAGERAPIHOOKCONFIG_H__
25
26// Uncomment definition of XTP_SKINFRAMEWORK_USE_LEGACY_API_HOOK and re-build ToolkitPro
27// in order to use the legacy API hook implementation that has been in place
28// prior to introducing the Detours API hooks.
29// Refer to the "Microsoft Detours base API hook core for SkinFramework" FAQ article
30// - https://codejock.com/support/articles/mfc/skinframework/detours.asp
31//# define XTP_SKINFRAMEWORK_USE_LEGACY_API_HOOK
32
35# if _MSC_VER > 1000
36# pragma once
37# endif // _MSC_VER > 1000
38
39# if !defined(XTP_SKINFRAMEWORK_USE_LEGACY_API_HOOK)
40# if defined(_WIN32_WINNT) && (0x400 <= _WIN32_WINNT)
41# define XTP_SKINFRAMEWORK_USE_DETOURS_API_HOOK
42# else
43# define XTP_SKINFRAMEWORK_USE_LEGACY_API_HOOK
44# endif
45# endif
46
47# if (defined(_XTP_ACTIVEX) && !defined(XTP_SKINFRAMEWORK_USE_LEGACY_API_HOOK))
48# define XTP_SKINFRAMEWORK_USE_LEGACY_API_HOOK
49# endif
50
51# if !defined(_M_IX86) && !defined(_M_X64)
52# error Unsupported target processor architecture. Only x86 and x64 are supported.
53# endif
55#endif // !defined(__XTPSKINMANAGERAPIHOOKCONFIG_H__)


Toolkit Pro: Member List

CXTPCalendarDayViewGroup Member List

This is the complete list of members for CXTPCalendarDayViewGroup, including all inherited members.

AddResource(CXTPCalendarResource *pResource, BOOL bWithAddRef) | CXTPCalendarViewGroup | virtual
AdjustDayEvents(CDC *pDC) | CXTPCalendarDayViewGroup | virtual
AdjustLayout(CDC *pDC, const CRect &rcGroup) | CXTPCalendarDayViewGroup | virtual
AdjustLayout2(CDC *pDC, const CRect &rcGroup) | CXTPCalendarDayViewGroup | virtual
CXTPCalendarDayViewGroup(CXTPCalendarDayViewDay *pViewDay) | CXTPCalendarDayViewGroup |
CXTPCalendarViewGroup(CXTPCalendarViewDay *pViewDay) | CXTPCalendarViewGroup |
CXTPCalendarViewGroupT(CXTPCalendarDayViewDay *pViewDay) | CXTPCalendarViewGroupT< CXTPCalendarDayViewDay, CXTPCalendarDayViewEvent, CXTPCalendarDayViewGroup > | inline
CXTPCalendarWMHandler() | CXTPCalendarWMHandler |
CXTPCmdTarget() | CXTPCmdTarget |
Draw(CDC *pDC) | CXTPCalendarDayViewGroup | virtual
ExchangeEventPlace(CXTPCalendarViewEvent *pViewEvent, int nNewPlace) | CXTPCalendarViewGroup | virtual
FillHitTestEx(XTP_CALENDAR_HITTESTINFO *pHitTest) const | CXTPCalendarDayViewGroup | protectedvirtual
FindMinMaxGroupDayEvents(CXTPCalendarDayViewEvent *&rpMin, CXTPCalendarDayViewEvent *&rpMax) const | CXTPCalendarDayViewGroup |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAllDayEventsRect() const | CXTPCalendarDayViewGroup | virtual
GetAllDayEventsScrollButtonRect(XTP_DAY_VIEW_GROUP_LAYOUT::XTPEnumHotItem nButton) const | CXTPCalendarDayViewGroup |
GetBusyStatus(COleDateTime dtTime) const | CXTPCalendarDayViewGroup | virtual
GetCalendarControl() const | CXTPCalendarViewGroup | virtual
GetCaption() const | CXTPCalendarViewGroup | virtual
GetCellDateTime(int nCell) const | CXTPCalendarDayViewGroup |
GetCellEvents(int nCell, TViewEventsCollection *pViewEvents, COleDateTime &rdtMinEventTime, COleDateTime &rdtMaxEventTime) | CXTPCalendarDayViewGroup | protectedvirtual
GetCellRect(int nCell) const | CXTPCalendarDayViewGroup |
GetCellViewPart(const COleDateTime &dtDateTime) const | CXTPCalendarDayViewGroup | protectedvirtual
GetChildHandlerAt(int nIndex) const | CXTPCalendarViewGroup | virtual
GetChildHandlersCount() const | CXTPCalendarViewGroup | virtual
GetDataProvider() const | CXTPCalendarViewGroup | virtual
GetDateTimeCell(const COleDateTime &dtTime, BOOL bForEndTime) const | CXTPCalendarDayViewGroup |
GetEventsCountInAllDayArea() const | CXTPCalendarDayViewGroup |
GetFirstVisibleAllDayEvent() const | CXTPCalendarDayViewGroup |
GetGroupIndex() const | CXTPCalendarViewGroup | virtual
GetHeaderRect() const | CXTPCalendarViewGroup | inlinevirtual
GetLastVisibleAllDayEvent() const | CXTPCalendarDayViewGroup |
GetRect() const | CXTPCalendarViewGroup | inlinevirtual
GetResources() const | CXTPCalendarViewGroup | virtual
GetRowCount() const | CXTPCalendarDayViewGroup |
GetRowHeight() const | CXTPCalendarDayViewGroup |
GetScheduleID() const | CXTPCalendarViewGroup | virtual
GetTooltipRect(const CPoint &ptHit, const XTP_CALENDAR_HITTESTINFO &hitInfo) const | CXTPCalendarDayViewGroup | virtual
GetTopRow() const | CXTPCalendarDayViewGroup |
GetViewDay() const | CXTPCalendarViewGroupT< CXTPCalendarDayViewDay, CXTPCalendarDayViewEvent, CXTPCalendarDayViewGroup > | inline
GetViewDay_() const | CXTPCalendarViewGroup |
GetViewEvent(int nIndex) const | CXTPCalendarViewGroupT< CXTPCalendarDayViewDay, CXTPCalendarDayViewEvent, CXTPCalendarDayViewGroup > | inlinevirtual
GetViewEvent_(int nIndex) const | CXTPCalendarViewGroup |
GetViewEventByEvent_(CXTPCalendarEvent *pEvent) const | CXTPCalendarViewGroup | virtual
GetViewEventByPlace_(int nEventPlace) const | CXTPCalendarViewGroup | virtual
GetViewEventsCount() const | CXTPCalendarViewGroup |
GetVisibleRowCount() const | CXTPCalendarDayViewGroup |
HitTest(CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const | CXTPCalendarViewGroup | virtual
HitTestAllDayEventsScrollIcons(CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const | CXTPCalendarDayViewGroup | virtual
HitTestDateTime(XTP_CALENDAR_HITTESTINFO *pHitTest) const | CXTPCalendarDayViewGroup | protectedvirtual
HitTestEx(CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const | CXTPCalendarDayViewGroup | virtual
IsDownAllDayEventsScrollButtonVisible() const | CXTPCalendarDayViewGroup |
IsExpandDown() const | CXTPCalendarDayViewGroup |
IsExpandUp() const | CXTPCalendarDayViewGroup |
IsGroupHeaderVisible() const | CXTPCalendarDayViewGroup |
IsShowAllDayEventsDownScrollButton() const | CXTPCalendarDayViewGroup |
IsShowAllDayEventsUpScrollButton() const | CXTPCalendarDayViewGroup |
IsUpAllDayEventsScrollButtonVisible() const | CXTPCalendarDayViewGroup |
IsWorkDateTime(const COleDateTime &dtDateTime) const | CXTPCalendarDayViewGroup |
KillTimer(UINT uTimerID) | CXTPCalendarViewGroup | protectedvirtual
m_arEvents | CXTPCalendarViewGroup | protected
m_bExpandDOWN | CXTPCalendarDayViewGroup | protected
m_bExpandUP | CXTPCalendarDayViewGroup | protected
m_Layout | CXTPCalendarViewGroup | protected
m_LayoutX | CXTPCalendarDayViewGroup | protected
m_pResources | CXTPCalendarViewGroup | protected
m_pViewDay | CXTPCalendarViewGroup | protected
NeedScrollAllDayEvents() const | CXTPCalendarDayViewGroup |
OnAllDaysAreaClick(UINT nFlags, CPoint point) | CXTPCalendarDayViewGroup | protected
OnBeforeDestroy() | CXTPCalendarWMHandler | virtual
OnChar(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnKeyUp(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnLButtonDblClk(UINT nFlags, CPoint point) | CXTPCalendarDayViewGroup | protectedvirtual
OnLButtonDown(UINT nFlags, CPoint point) | CXTPCalendarDayViewGroup | protectedvirtual
OnLButtonUp(UINT nFlags, CPoint point) | CXTPCalendarWMHandler | virtual
OnMouseMove(UINT nFlags, CPoint point) | CXTPCalendarDayViewGroup | protectedvirtual
OnPostAdjustLayout() | CXTPCalendarWMHandler | virtual
OnPrePopulate(CXTPCalendarEvents *pEvents) | CXTPCalendarViewGroup | protectedvirtual
OnSysKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnTimer(UINT_PTR uTimerID) | CXTPCalendarWMHandler | virtual
OnWndMsg(UINT message, WPARAM wParam, LPARAM lParam, LRESULT *pResult) | CXTPCalendarWMHandler | virtual
Populate(COleDateTime dtDayDate) | CXTPCalendarViewGroup | virtual
ScrollIcon_ScrollAllDayEventsDown() | CXTPCalendarDayViewGroup |
ScrollIcon_ScrollAllDayEventsUp() | CXTPCalendarDayViewGroup |
SetExpandDown() | CXTPCalendarDayViewGroup |
SetExpandUp() | CXTPCalendarDayViewGroup |
SetResources(CXTPCalendarResources *pResources) | CXTPCalendarViewGroup | virtual
SetShowAllDayEventsDownScrollButton(BOOL bShow) | CXTPCalendarDayViewGroup |
SetShowAllDayEventsUpScrollButton(BOOL bShow) | CXTPCalendarDayViewGroup |
SetTimer(UINT uTimeOut_ms) | CXTPCalendarViewGroup | protectedvirtual
TBase typedef | CXTPCalendarDayViewGroup |
TViewDay typedef | CXTPCalendarViewGroupT< CXTPCalendarDayViewDay, CXTPCalendarDayViewEvent, CXTPCalendarDayViewGroup > |
UserAction_OnScrollAllDayEvents(XTP_DAY_VIEW_GROUP_LAYOUT::XTPEnumHotItem eHotBtn) | CXTPCalendarDayViewGroup |
UserAction_OnScrollDay(XTPCalendarScrollDayButton eButton) | CXTPCalendarDayViewGroup |
~CXTPCalendarDayViewGroup() | CXTPCalendarDayViewGroup | virtual
~CXTPCalendarViewGroup() | CXTPCalendarViewGroup | virtual
~CXTPCalendarViewGroupT() | CXTPCalendarViewGroupT< CXTPCalendarDayViewDay, CXTPCalendarDayViewEvent, CXTPCalendarDayViewGroup > | inlinevirtual


Toolkit Pro: Member List

CXTPShortcutBarVisualStudio2019Theme Member List

This is the complete list of members for CXTPShortcutBarVisualStudio2019Theme, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPShortcutBarOffice2003Theme() | CXTPShortcutBarOffice2003Theme |
CXTPShortcutBarOffice2013Theme() | CXTPShortcutBarOffice2013Theme |
CXTPShortcutBarPaintManager() | CXTPShortcutBarPaintManager |
CXTPShortcutBarResourceTheme() | CXTPShortcutBarResourceTheme |
CXTPShortcutBarVisualStudio2019Theme() | CXTPShortcutBarVisualStudio2019Theme |
DrawExpandButton(CDC *pDC, CRect rc) | CXTPShortcutBarOffice2013Theme | virtual
DrawGripper(CDC *pDC, CXTPShortcutBar *pShortcutBar, BOOL bDraw) | CXTPShortcutBarOffice2013Theme | virtual
DrawImage(CDC *pDC, CPoint pt, CSize sz, CXTPImageManagerIcon *pImage, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled) | CXTPShortcutBarOffice2003Theme | virtual
DrawNavigationItem(CDC *pDC, CXTPShortcutBarItem *pItem) | CXTPShortcutBarPaintManager | virtual
DrawPaneCaption(CDC *pDC, CXTPShortcutBarPane *pPane, BOOL bDraw) | CXTPShortcutBarResourceTheme | virtual
DrawPaneItemCaption(CDC *pDC, CXTPShortcutBarPaneItem *pItem, BOOL bDraw) | CXTPShortcutBarVisualStudio2019Theme | virtual
DrawShortcutBarFrame(CDC *pDC, CXTPShortcutBar *pShortcutBar) | CXTPShortcutBarOffice2003Theme | virtual
DrawShortcutItem(CDC *pDC, CXTPShortcutBarItem *pItem) | CXTPShortcutBarPaintManager | virtual
FillNavigationItemEntry(CDC *pDC, CXTPShortcutBarItem *pItem) | CXTPShortcutBarVisualStudio2019Theme | virtual
FillShortcutBar(CDC *pDC, CXTPShortcutBar *pShortcutBar) | CXTPShortcutBarOffice2013Theme | virtual
FillShortcutItemEntry(CDC *pDC, CXTPShortcutBarItem *pItem) | CXTPShortcutBarVisualStudio2019Theme | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
IsShortcutItemTruncated(CDC *pDC, CXTPShortcutBarItem *pItem) | CXTPShortcutBarPaintManager |
Line(CDC *pDC, int x0, int y0, int x1, int y1, int nPen) | CXTPShortcutBarPaintManager |
m_bBoldItemCaptionFont | CXTPShortcutBarPaintManager |
m_bClearTypeTextQuality | CXTPShortcutBarPaintManager |
m_bHiliteBorders | CXTPShortcutBarVisualStudio2019Theme | protected
m_bNavigationButton | CXTPShortcutBarPaintManager |
m_bShowTopLeftCaptionShadow | CXTPShortcutBarOffice2003Theme |
m_bUseStandardFont | CXTPShortcutBarPaintManager |
m_clrBackHiliteSelected | CXTPShortcutBarVisualStudio2019Theme | protected
m_clrBorderHilite | CXTPShortcutBarVisualStudio2019Theme | protected
m_clrCaptionText | CXTPShortcutBarOffice2003Theme |
m_clrDisabledText | CXTPShortcutBarPaintManager |
m_clrGlyph | CXTPShortcutBarOffice2013Theme | protected
m_clrGlyphExpanded | CXTPShortcutBarOffice2013Theme | protected
m_clrGlyphFill | CXTPShortcutBarOffice2013Theme | protected
m_clrGlyphPushed | CXTPShortcutBarOffice2013Theme | protected
m_clrHotText | CXTPShortcutBarPaintManager |
m_clrItemCaptionShadow | CXTPShortcutBarOffice2003Theme |
m_clrItemCaptionText | CXTPShortcutBarOffice2003Theme |
m_clrItemCaptionTop | CXTPShortcutBarOffice2003Theme |
m_clrNormalText | CXTPShortcutBarPaintManager |
m_clrPushedText | CXTPShortcutBarPaintManager |
m_clrSelectedText | CXTPShortcutBarPaintManager |
m_clrShortcutItemShadow | CXTPShortcutBarPaintManager |
m_grcCaption | CXTPShortcutBarOffice2003Theme |
m_grcHot | CXTPShortcutBarPaintManager |
m_grcItemCaption | CXTPShortcutBarOffice2003Theme |
m_grcItemHotCaption | CXTPShortcutBarOffice2003Theme |
m_grcPushed | CXTPShortcutBarPaintManager |
m_grcSelected | CXTPShortcutBarPaintManager |
m_grcShortcutBarGripper | CXTPShortcutBarPaintManager |
m_grcShortcutItem | CXTPShortcutBarPaintManager |
m_nExpandedIconWidth | CXTPShortcutBarPaintManager |
m_nNormalIconWidth | CXTPShortcutBarPaintManager |
m_nPaneItemHeight | CXTPShortcutBarPaintManager |
m_pExpandIcon | CXTPShortcutBarPaintManager |
m_rcCaptionPadding | CXTPShortcutBarPaintManager |
m_rcItemCaptionPadding | CXTPShortcutBarPaintManager |
m_strOfficeFont | CXTPShortcutBarPaintManager |
m_xtpFontPaneCaption | CXTPShortcutBarPaintManager |
m_xtpFontPaneItemCaption | CXTPShortcutBarPaintManager |
m_xtpFontText | CXTPShortcutBarPaintManager |
m_xtpFontVerticalText | CXTPShortcutBarPaintManager |
Rectangle(CDC *pDC, CRect rc, int nPen, int nBrush) | CXTPShortcutBarPaintManager |
RefreshMetrics() | CXTPShortcutBarVisualStudio2019Theme | virtual
~CXTPShortcutBarOffice2013Theme() | CXTPShortcutBarOffice2013Theme | virtual
~CXTPShortcutBarPaintManager() | CXTPShortcutBarPaintManager | virtual
~CXTPShortcutBarVisualStudio2019Theme() | CXTPShortcutBarVisualStudio2019Theme | virtual


Toolkit Pro: XTPTaskDialogControls.h Source File

  • Source
  • Controls
  • Dialog
XTPTaskDialogControls.h
Go to the documentation of this file.
1
23#if !defined(__XTPTASKLINKCTRL_H__)
24# define __XTPTASKLINKCTRL_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPTaskDialogLinkCtrl : public CStatic
39{
40public:
47 struct LINKITEM
48 {
49 DWORD nStart;
50 int nIndex;
51 CString strLabel;
52 CString strUrl;
54 CArray<RECT, RECT&> arrParts;
55 };
56
57 typedef CArray<LINKITEM*, LINKITEM*> CTaskLinkItemArray;
59 DECLARE_DYNCREATE(CXTPTaskDialogLinkCtrl)
61public:
66 CXTPTaskDialogLinkCtrl();
67
72 virtual ~CXTPTaskDialogLinkCtrl();
73
94 virtual BOOL Create(const CRect& rect, CString& strBuffer, CFont* pFont, CWnd* pParentWnd);
95
96# if _MSC_VER > 1200
97 using CStatic::Create;
98 using CWnd::Create;
99# endif
100
107 LINKITEM* GetFocusedLink() const;
108
114 void FocusItem(int iFocusItem);
115
124 LINKITEM* HitTest(CPoint pt) const;
125
137 DWORD GetLinkPos(CString strBuffer, int iPos = 0);
138
148 BOOL ExtractLinks(CString& strBuffer);
149
155 void SetBackColor(COLORREF crBack);
162 COLORREF GetBackColor() const;
168 void SetTextColor(COLORREF crText);
175 COLORREF GetTextColor() const;
181 void SetTextLinkColor(COLORREF crTextLink);
188 COLORREF GetTextLinkColor() const;
189
190private:
191 void DrawText(CDC* pDC, CRect rClient);
192 void DrawTextPart(CDC* pDC, int& x, int& y, int nWidth, CString strBuffer, LINKITEM* pItem);
193 int DrawTextPartText(CDC* pDC, CString strBuffer, int x, int y, LINKITEM* pItem);
194 void RemoveAllLinks();
195
196protected:
198 DECLARE_MESSAGE_MAP()
199
200 //{{AFX_VIRTUAL(CXTPTaskDialogLinkCtrl)
201 BOOL PreCreateWindow(CREATESTRUCT& cs);
202 void PreSubclassWindow();
203 //}}AFX_VIRTUAL
204
205 //{{AFX_MSG(CXTPTaskDialogLinkCtrl)
206 afx_msg void OnPaint();
207 afx_msg BOOL OnEraseBkgnd(CDC* pDC);
208 afx_msg BOOL OnSetCursor(CWnd* pWnd, UINT nHitTest, UINT message);
209 afx_msg void OnLButtonDown(UINT nFlags, CPoint point);
210 afx_msg void OnLButtonUp(UINT nFlags, CPoint point);
211 afx_msg LRESULT OnNcHitTest(CPoint /*point*/);
212 afx_msg void OnSetFocus(CWnd* pOldWnd);
213 afx_msg void OnKillFocus(CWnd* pNewWnd);
214 afx_msg UINT OnGetDlgCode();
215 afx_msg void OnKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags);
216 afx_msg LRESULT OnUpdateUIState(WPARAM wParam, LPARAM lParam);
217 LRESULT OnSetText(WPARAM wParam, LPARAM lParam);
218 //}}AFX_MSG
221protected:
222 int m_nFocused;
224 CXTPFont m_xtpFontUL;
225 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CFont, m_fontUL, m_xtpFontUL, GetULFontHandle);
226
227 CString m_strBuffer;
228 HCURSOR m_hcurHand;
229 COLORREF m_crBack;
230 COLORREF m_crText;
231 COLORREF m_crTextLink;
232 CTaskLinkItemArray m_arrLinks;
233 BOOL m_bPreSubclassWindow;
234};
235
240class _XTP_EXT_CLASS CXTPTaskButtonTheme : public CXTPButtonTheme
241{
242public:
243 CXTPTaskButtonTheme(BOOL bThemeReady);
244 CXTPTaskButtonTheme();
245 virtual void RefreshMetrics(CXTPButton* pButton);
246 void SetTitleFont(CFont* FontTitle);
247 CFont* GetTitleFont();
248
249protected:
250 virtual BOOL DrawButtonThemeBackground(CDC* pDC, CXTPButton* pButton);
251 virtual BOOL DrawWinThemeBackground(CDC* pDC, CXTPButton* pButton);
252 virtual void DrawButtonText(CDC* pDC, CXTPButton* pButton);
253 virtual COLORREF GetTextColor(CXTPButton* pButton);
254 virtual void GetButtonText(CXTPButton* pButton);
255 virtual void DrawButtonIcon(CDC* pDC, CXTPButton* pButton);
256 virtual void DrawButton(CDC* pDC, CXTPButton* pButton);
257
258 CPoint GetTextPosition(CDC* pDC, CSize sizeText, CXTPButton* pButton);
259
260 CFont* m_pFontTitle;
261 CPoint m_ptMargin;
262 CString m_strButton;
263 CString m_strCaptText;
264 CString m_strNoteText;
265 CBitmap m_bmpBackClassic;
266 CBitmap m_bmpBackThemed;
267 CXTPPaintManagerColor m_crTextHilite;
268 CXTPPaintManagerColor m_crBackSelected;
269 CXTPPaintManagerColor m_crBorderActive;
270 BOOL m_bThemeReady;
271};
272
277class _XTP_EXT_CLASS CXTPTaskButtonThemeExpando : public CXTPButtonTheme
278{
279public:
280 CXTPTaskButtonThemeExpando();
281
282 void DrawButton(CDC* pDC, CXTPButton* pButton);
283};
284
289class _XTP_EXT_CLASS CXTPTaskDialogProgressCtrl : public CProgressCtrl
290{
291public:
292 CXTPTaskDialogProgressCtrl();
293
294protected:
295 DECLARE_MESSAGE_MAP()
296
297 //{{AFX_VIRTUAL(CXTPTaskDialogProgressCtrl)
298 //}}AFX_VIRTUAL
299
300 //{{AFX_MSG(CXTPTaskDialogProgressCtrl)
301 afx_msg void OnPaint();
302 afx_msg void OnTimer(UINT_PTR nIDEvent);
303 afx_msg LRESULT OnStartMarquee(WPARAM wParam, LPARAM lParam);
304 afx_msg LRESULT OnSetState(WPARAM wParam, LPARAM lParam);
305 //}}AFX_MSG
306
307protected:
308 int m_nState;
309 int m_nMarqueePos;
310 UINT m_nMarqueeDelay;
311 BOOL m_bMarquee;
312};
314AFX_INLINE void CXTPTaskDialogLinkCtrl::SetBackColor(COLORREF crBack)
315{
316 m_crBack = crBack;
317}
318AFX_INLINE COLORREF CXTPTaskDialogLinkCtrl::GetBackColor() const
319{
320 return m_crBack;
321}
322AFX_INLINE void CXTPTaskDialogLinkCtrl::SetTextColor(COLORREF crText)
323{
324 m_crText = crText;
325}
326AFX_INLINE COLORREF CXTPTaskDialogLinkCtrl::GetTextColor() const
327{
328 return m_crText;
329}
330AFX_INLINE void CXTPTaskDialogLinkCtrl::SetTextLinkColor(COLORREF crTextLink)
331{
332 m_crTextLink = crTextLink;
333}
334AFX_INLINE COLORREF CXTPTaskDialogLinkCtrl::GetTextLinkColor() const
335{
336 return m_crTextLink;
337}
338
340
341//{{AFX_INSERT_LOCATION}}
342// Microsoft Visual C++ will insert additional declarations immediately before the previous line.
344# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
346#endif // !defined(__XTPTASKLINKCTRL_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPButton
Push Button control.
Definition XTPButton.h:109
CXTPButtonTheme
CXTPButtonTheme is a class used to perform Button Theme drawing tasks.
Definition XTPButtonTheme.h:51
CXTPFont
Provides a convenient object oriented interface for HFONT GDI object and uses GDI handle caching.
Definition XTPGdiObjects.h:414
CXTPPaintManagerColor
The CXTPPaintManagerColor class is used to manage COLORREF values for determining default and applica...
Definition XTPColorManager.h:117
CXTPTaskButtonThemeExpando
CXTPTaskButtonThemeExpando.
Definition XTPTaskDialogControls.h:278
CXTPTaskButtonThemeExpando::DrawButton
void DrawButton(CDC *pDC, CXTPButton *pButton)
This member function is called to the button.
CXTPTaskButtonTheme
CXTPTaskButtonTheme.
Definition XTPTaskDialogControls.h:241
CXTPTaskButtonTheme::GetTextColor
virtual COLORREF GetTextColor(CXTPButton *pButton)
Call this member function to return the color used to draw the button text.
CXTPTaskButtonTheme::DrawButton
virtual void DrawButton(CDC *pDC, CXTPButton *pButton)
This member function is called to the button.
CXTPTaskButtonTheme::RefreshMetrics
virtual void RefreshMetrics(CXTPButton *pButton)
This member function is called by the theme manager to refresh the visual styles used by each compone...
CXTPTaskDialogLinkCtrl
CXTPTaskDialogLinkCtrl is a CStatic derived class that is used to display a text block that contains ...
Definition XTPTaskDialogControls.h:39
CXTPTaskDialogLinkCtrl::GetTextLinkColor
COLORREF GetTextLinkColor() const
Call this member function to retrieve the link control's text link color.
CXTPTaskDialogLinkCtrl::SetTextLinkColor
void SetTextLinkColor(COLORREF crTextLink)
Call this member function to set the text link color for the link control.
CXTPTaskDialogLinkCtrl::CXTPTaskDialogLinkCtrl
CXTPTaskDialogLinkCtrl()
Constructs a CXTPTaskDialogLinkCtrl object.
CXTPTaskDialogLinkCtrl::Create
virtual BOOL Create(const CRect &rect, CString &strBuffer, CFont *pFont, CWnd *pParentWnd)
Call this member function to create a CXTPTaskDialogLinkCtrl text control.
CXTPTaskDialogLinkCtrl::ExtractLinks
BOOL ExtractLinks(CString &strBuffer)
This member function is called to extract link information from the specified string buffer and store...
CXTPTaskDialogLinkCtrl::GetLinkPos
DWORD GetLinkPos(CString strBuffer, int iPos=0)
This member function is called to retrieve the character index of the first link located after the in...
CXTPTaskDialogLinkCtrl::GetTextColor
COLORREF GetTextColor() const
Call this member function to retrieve the link control's text color.
CXTPTaskDialogLinkCtrl::GetFocusedLink
LINKITEM * GetFocusedLink() const
Call this member function to return the focused link.
CXTPTaskDialogLinkCtrl::SetBackColor
void SetBackColor(COLORREF crBack)
Call this member function to set the background color for the link control.
CXTPTaskDialogLinkCtrl::GetBackColor
COLORREF GetBackColor() const
Call this member function to retrieve the link control's background color.
CXTPTaskDialogLinkCtrl::FocusItem
void FocusItem(int iFocusItem)
Call this member function to set the focus to a specified link.
CXTPTaskDialogLinkCtrl::HitTest
LINKITEM * HitTest(CPoint pt) const
Call this member function to return the link information from the specified cursor position.
CXTPTaskDialogLinkCtrl::SetTextColor
void SetTextColor(COLORREF crText)
Call this member function to set the text color for the link control.
CXTPTaskDialogLinkCtrl::~CXTPTaskDialogLinkCtrl
virtual ~CXTPTaskDialogLinkCtrl()
Destroys a CXTPTaskDialogLinkCtrl object, handles cleanup and deallocation.
CXTPTaskDialogProgressCtrl
CXTPTaskDialogProgressCtrl.
Definition XTPTaskDialogControls.h:290
CXTPTaskDialogLinkCtrl::LINKITEM
LINKITEM is used to set and retrieve information about a link item.
Definition XTPTaskDialogControls.h:48
CXTPTaskDialogLinkCtrl::LINKITEM::nIndex
int nIndex
Character index of the character nearest the specified point.
Definition XTPTaskDialogControls.h:50
CXTPTaskDialogLinkCtrl::LINKITEM::nStart
DWORD nStart
Starting character position.
Definition XTPTaskDialogControls.h:49
CXTPTaskDialogLinkCtrl::LINKITEM::strUrl
CString strUrl
Specifies the display string for the link.
Definition XTPTaskDialogControls.h:52
CXTPTaskDialogLinkCtrl::LINKITEM::strLabel
CString strLabel
Specifies the execute string for the link.
Definition XTPTaskDialogControls.h:51


Toolkit Pro: Member List

CXTPGaugeTraits Member List

This is the complete list of members for CXTPGaugeTraits, including all inherited members.

CXTPGaugeTraits() | CXTPGaugeTraits
CXTPGaugeTraits(IStream &stream, CString strTraitsArg=CString()) | CXTPGaugeTraits
CXTPGaugeTraits(CString strTraits, CString strTraitsArg=CString()) | CXTPGaugeTraits
EnumCustomTraits() const | CXTPGaugeTraits
GetCustomTrait(CString strJsonPath) const | CXTPGaugeTraits
GetNextCustomTrait(POSITION &pos, CString &strJsonPath, COleVariant *&pValue) const | CXTPGaugeTraits
GetResourceModule() const | CXTPGaugeTraits
GetResourceNamespace() const | CXTPGaugeTraits
GetResourcePath() const | CXTPGaugeTraits
GetTraits() const | CXTPGaugeTraits
GetTraitsArgument() const | CXTPGaugeTraits
SetCustomTrait(CString strJsonPath, COleVariant vtValue) | CXTPGaugeTraits
SetResourceModule(HMODULE hResMod, LPCTSTR pNamespace=NULL) | CXTPGaugeTraits
SetResourcePath(CString strPath) | CXTPGaugeTraits
SetTraits(CString strTraits) | CXTPGaugeTraits
SetTraitsArgument(CString strTraitsArg) | CXTPGaugeTraits
~CXTPGaugeTraits() | CXTPGaugeTraits


Toolkit Pro: Member List

CXTPButtonThemeOffice2000 Member List

This is the complete list of members for CXTPButtonThemeOffice2000, including all inherited members.

CXTPButtonTheme() | CXTPButtonTheme |
CXTPButtonThemeOffice2000() | CXTPButtonThemeOffice2000 |
CXTPButtonThemeUltraFlat() | CXTPButtonThemeUltraFlat |
CXTPCmdTarget() | CXTPCmdTarget |
CXTPControlTheme() | CXTPControlTheme |
DrawButton(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
DrawButtonBackground(CDC *pDC, CXTPButton *pButton) | CXTPButtonThemeOffice2000 | virtual
DrawButtonText(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme |
DrawButtonVisualStyleBackground(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
DrawCheckBoxMark(CDC *pDC, CXTPButton *pButton) | CXTPButtonThemeUltraFlat | virtual
DrawFocusRect(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
DrawGroupBox(CDC *pDC, CXTPButton *pButton) | CXTPButtonThemeUltraFlat | virtual
DrawPushButtonDropDown(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
DrawPushButtonIcon(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
DrawPushButtonText(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
DrawRadioButtonMark(CDC *pDC, CXTPButton *pButton) | CXTPButtonThemeUltraFlat | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetTextColor(CXTPButton *pButton) | CXTPButtonTheme | virtual
GetThemeStyle() const | CXTPControlTheme |
m_crBack | CXTPButtonTheme |
m_crBackChecked | CXTPButtonThemeUltraFlat |
m_crBackHilite | CXTPButtonThemeUltraFlat |
m_crBackPushed | CXTPButtonThemeUltraFlat |
m_crBorder3DHilite | CXTPButtonTheme |
m_crBorder3DShadow | CXTPButtonTheme |
m_crBorderHilite | CXTPButtonTheme |
m_crBorderPushed | CXTPButtonThemeUltraFlat |
m_crBorderShadow | CXTPButtonTheme |
m_crCheckMark | CXTPButtonThemeUltraFlat |
m_crText | CXTPButtonTheme |
m_crTextCheck | CXTPButtonTheme |
m_crTextDisabled | CXTPButtonTheme |
m_crTextHilite | CXTPButtonThemeUltraFlat |
m_crTextPushed | CXTPButtonThemeUltraFlat |
m_nTheme | CXTPControlTheme | protected
RefreshMetrics(CXTPButton *pButton) | CXTPButtonThemeUltraFlat | virtual
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static
~CXTPButtonTheme() | CXTPButtonTheme | virtual


Toolkit Pro: Member List

CXTPCalendarData Member List

This is the complete list of members for CXTPCalendarData, including all inherited members.

AddEvent(CXTPCalendarEvent *pEvent) | CXTPCalendarData | virtual
AddEventCategory(UINT uID, CString strName, COLORREF crBorder, COLORREF crBkBase) | CXTPCalendarData | virtual
AddEventLabel(int nID, CString strName, COLORREF crLabel) | CXTPCalendarData | virtual
AddEvents(CXTPCalendarEvents *pEvents) | CXTPCalendarData | virtual
ChangeEvent(CXTPCalendarEvent *pNewEvent) | CXTPCalendarData | virtual
ClearCache() | CXTPCalendarData | virtual
ClearEventCategoryList() | CXTPCalendarData | virtual
ClearEventLabelList() | CXTPCalendarData | virtual
Close() | CXTPCalendarData | virtual
Create() | CXTPCalendarData | virtual
CreateDataProvider(LPCTSTR lpszConnectionString) | CXTPCalendarData | static
CreateDataProvider(XTPCalendarDataProvider eDataProvider) | CXTPCalendarData | static
CreateNewEvent(DWORD dwEventID=XTP_CALENDAR_UNKNOWN_EVENT_ID) | CXTPCalendarData | virtual
CreateNewRecurrencePattern(DWORD dwPatternID=XTP_CALENDAR_UNKNOWN_RECURRENCE_PATTERN_ID) | CXTPCalendarData | virtual
CXTPCalendarData() | CXTPCalendarData |
CXTPCmdTarget() | CXTPCmdTarget |
DataProviderTypeFromConStr(LPCTSTR lpszConnectionString, XTPCalendarDataProvider eDPDefault=xtpCalendarDataProviderUnknown) | CXTPCalendarData | static
DataSourceFromConStr(LPCTSTR lpszConnectionString) | CXTPCalendarData | static
DeleteEvent(CXTPCalendarEvent *pEvent) | CXTPCalendarData | virtual
DoCreate_Event(CXTPCalendarEvent *pEvent, DWORD &rdwNewEventID) | CXTPCalendarData | protectedvirtual
DoCreate_RPattern(CXTPCalendarRecurrencePattern *pPattern, DWORD &rdwNewPatternID) | CXTPCalendarData | protectedvirtual
DoDelete_Event(CXTPCalendarEvent *pEvent) | CXTPCalendarData | protectedvirtual
DoDelete_RPattern(CXTPCalendarRecurrencePattern *pPattern) | CXTPCalendarData | protectedvirtual
DoGetAllEvents_raw() | CXTPCalendarData | protectedvirtual
DoGetUpcomingEvents(COleDateTime dtFrom, COleDateTimeSpan spPeriod) | CXTPCalendarData | protectedvirtual
DoRead_Event(DWORD dwEventID) | CXTPCalendarData | protectedvirtual
DoRead_RPattern(DWORD dwPatternID) | CXTPCalendarData | protectedvirtual
DoRemoveAllEvents() | CXTPCalendarData | protectedvirtual
DoRetrieveDayEvents(COleDateTime dtDay) | CXTPCalendarData | protectedvirtual
DoUpdate_Event(CXTPCalendarEvent *pEvent) | CXTPCalendarData | protectedvirtual
DoUpdate_RPattern(CXTPCalendarRecurrencePattern *pPattern) | CXTPCalendarData | protectedvirtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAllEvents_raw() | CXTPCalendarData | virtual
GetCacheMode() const | CXTPCalendarData | virtual
GetConnection() const | CXTPCalendarData | virtual
GetConnectionString() const | CXTPCalendarData | virtual
GetCustomProperties() const | CXTPCalendarData | virtual
GetDataSource() | CXTPCalendarData | virtual
GetEvent(DWORD dwEventID) | CXTPCalendarData | virtual
GetEventCategories() const | CXTPCalendarData | virtual
GetLabelList() const | CXTPCalendarData | virtual
GetNextFreeTempID() | CXTPCalendarData | protectedstatic
GetRecurrencePattern(DWORD dwPatternID) | CXTPCalendarData | virtual
GetSchedules() const | CXTPCalendarData | virtual
GetType() const | CXTPCalendarData | virtual
GetUpcomingEvents(COleDateTime dtFrom=(DATE) 0, COleDateTimeSpan spPeriod=(DATE) 0) | CXTPCalendarData | virtual
IsOpen() const | CXTPCalendarData | virtual
m_bDisableNotificationsSending | CXTPCalendarData | protected
m_bOpened | CXTPCalendarData | protected
m_pCalendarOptions | CXTPCalendarData | protected
m_pConnection | CXTPCalendarData | protected
m_pCustomProperties | CXTPCalendarData | protected
m_pEventCategories | CXTPCalendarData | protected
m_pLabelList | CXTPCalendarData | protected
m_pSchedules | CXTPCalendarData | protected
m_strConnectionString | CXTPCalendarData | protected
m_typeProvider | CXTPCalendarData | protected
ms_dwNextFreeTempID | CXTPCalendarData | protectedstatic
OnTimeZoneChanged() | CXTPCalendarData | inlineprotectedvirtual
Open() | CXTPCalendarData | virtual
RemoveAllEvents() | CXTPCalendarData | virtual
RestoreEventCategoryList() | CXTPCalendarData | virtual
RestoreEventLabelList() | CXTPCalendarData | virtual
RetrieveDayEvents(COleDateTime dtDay) | CXTPCalendarData | virtual
Save() | CXTPCalendarData | virtual
SendNotification(XTP_NOTIFY_CODE EventCode, WPARAM wParam, LPARAM lParam) | CXTPCalendarData | protectedvirtual
SetCacheMode(int eCacheMode, CXTPCalendarData *pCacheDataProvider=NULL) | CXTPCalendarData | virtual
SetConnectionString(LPCTSTR lpszConnectionString) | CXTPCalendarData | virtual
SetLabelList(CXTPCalendarEventLabels *pLabelList) | CXTPCalendarData | virtual
UpdateEventCategories(COLORREF *pClrBkBase, COLORREF *pClrBorder, int nCount) | CXTPCalendarData |
UpdateEventLabels(COLORREF *clrEventColors, UINT uCount) | CXTPCalendarData | virtual
~CXTPCalendarData() | CXTPCalendarData | virtual


Toolkit Pro: Member List

CXTPTabThemeVisualStudio2003 Member List

This is the complete list of members for CXTPTabThemeVisualStudio2003, including all inherited members.

AdjustClientRect(CXTPTabManager *pTabManager, CRect &rcClient) | CXTPTabPaintManagerTheme | virtual
CXTPTabPaintManagerTheme() | CXTPTabPaintManagerTheme |
CXTPTabThemeVisualStudio2003() | CXTPTabThemeVisualStudio2003 | inline
DrawSingleButton(CDC *pDC, CXTPTabManagerItem *pItem) | CXTPTabThemeVisualStudio2003 | virtual
DrawTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl) | CXTPTabPaintManagerTheme | virtual
DrawText(CDC *pDC, CXTPTabManager *pManager, const CString &str, LPRECT lpRect, UINT nFormat) | CXTPTabPaintManagerTheme | virtual
DrawWorkspacePart(CDC *pDC, LPRECT lpRect, XTPTabWorkspacePart workspacePart) | CXTPTabPaintManagerTheme | virtual
FillButton(CDC *pDC, CXTPTabManagerItem *pItem, LPPOINT pts, int nCount, XTPTabPosition tabPosition, BOOL bAbsolute=FALSE) | CXTPTabPaintManagerTheme |
FillTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl) | CXTPTabThemeVisualStudio2003 | virtual
GetButtonDrawRect(const CXTPTabManagerItem *pItem) | CXTPTabPaintManagerTheme | virtual
GetButtonHeight(const CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetButtonLength(CDC *pDC, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerTheme | virtual
GetClientMargin() | CXTPTabPaintManagerTheme | virtual
GetClientRect(CRect rcControl, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetColorSet() const | CXTPTabPaintManagerTheme |
GetDefaultColorSet() | CXTPTabThemeVisualStudio2003 | inlinevirtual
GetHeaderClipBox(CDC *pDC, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetHeaderHeight(CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme |
GetHeaderMargin() | CXTPTabPaintManagerTheme | virtual
GetHeaderRect(CRect rcControl, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetSupportedColorSets() | CXTPTabPaintManagerTheme | inlinevirtual
m_bButtonsReverseZOrder | CXTPTabPaintManagerTheme | protected
m_nButtonHeight | CXTPTabPaintManagerTheme | protected
m_nRowMargin | CXTPTabPaintManagerTheme |
m_pPaintManager | CXTPTabPaintManagerTheme | protected
m_rcHeaderMargin | CXTPTabPaintManagerTheme |
RefreshMetrics() | CXTPTabPaintManagerTheme | virtual
RepositionTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcClient) | CXTPTabPaintManagerTheme | virtual
~CXTPTabPaintManagerTheme() | CXTPTabPaintManagerTheme | virtual


Toolkit Pro: XTPCalendarCaptionBarVisualStudio2019Theme.h Source File

  • Source
  • Calendar
  • CaptionBar
  • Themes
XTPCalendarCaptionBarVisualStudio2019Theme.h
Go to the documentation of this file.
1
22#if !defined(__XTPCALENDARCAPTIONBARVISUALSTUDIO2019THEME_H__)
23# define __XTPCALENDARCAPTIONBARVISUALSTUDIO2019THEME_H__
24
25# if _MSC_VER > 1000
26# pragma once
27# endif // _MSC_VER > 1000
28
29# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
30
36class _XTP_EXT_CLASS CXTPCalendarCaptionBarVisualStudio2019Theme
37 : public CXTPCalendarCaptionBarOffice2013Theme
38{
39public:
48 CXTPCalendarCaptionBarVisualStudio2019Theme(CXTPCalendarCaptionBarTheme* pTheme = NULL);
49
56 virtual ~CXTPCalendarCaptionBarVisualStudio2019Theme();
57};
58
59# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
60#endif // !defined(__XTPCALENDARCAPTIONBARVISUALSTUDIO2019THEME_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCalendarCaptionBarOffice2013Theme
CXTPCalendarCaptionBarOffice2013Theme is a CXTPCalendarCaptionBarOffice2003Theme derived class that r...
Definition XTPCalendarCaptionBarOffice2013Theme.h:38
CXTPCalendarCaptionBarTheme
This class CalendarCaptionBar control drawing, user interaction logic and interaction logic with atta...
Definition XTPCalendarCaptionBarTheme.h:48
CXTPCalendarCaptionBarVisualStudio2019Theme
CXTPCalendarCaptionBarVisualStudio2019Theme is a CXTPCalendarCaptionBarOffice2013Theme derived class ...
Definition XTPCalendarCaptionBarVisualStudio2019Theme.h:38
CXTPCalendarCaptionBarVisualStudio2019Theme::~CXTPCalendarCaptionBarVisualStudio2019Theme
virtual ~CXTPCalendarCaptionBarVisualStudio2019Theme()
Default paint manager destructor.
CXTPCalendarCaptionBarVisualStudio2019Theme::CXTPCalendarCaptionBarVisualStudio2019Theme
CXTPCalendarCaptionBarVisualStudio2019Theme(CXTPCalendarCaptionBarTheme *pTheme=NULL)
Default paint manager constructor.


Toolkit Pro: XTPDatePickerControl.h Source File

  • Source
  • Calendar
  • DatePicker
XTPDatePickerControl.h
Go to the documentation of this file.
1
22#if !defined(_XTPDATEPICKERCONTROL_H__)
23# define _XTPDATEPICKERCONTROL_H__
24
25# if _MSC_VER > 1000
26# pragma once
27# endif // _MSC_VER > 1000
28
30// CXTPDatePickerControl window
31
32# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
33
34class CXTPDatePickerPaintManager;
35class CXTPDatePickerItemMonth;
36class CXTPDatePickerDaysCollection;
37class CXTPDatePickerList;
38class CXTPDatePickerControl;
39class CXTPNotifyConnection;
40class CXTPNotifySink;
41
52struct _XTP_EXT_CLASS XTP_DAYITEM_METRICS : public CXTPCmdTarget
53{
60 CFont* GetFont();
67 void SetFont(CFont* pFont);
68
69 COLORREF clrForeground;
70 COLORREF clrBackground;
72 XTP_DAYITEM_METRICS();
73 virtual ~XTP_DAYITEM_METRICS(){};
74
75private:
76 CXTPFont m_xtpFontText;
77 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CFont, m_fntText, m_xtpFontText, GetTextFontHandle);
78
79# ifdef _XTP_ACTIVEX
80
81 CPictureHolder m_olePicture;
83 DECLARE_DISPATCH_MAP()
84 DECLARE_INTERFACE_MAP()
85
86public:
87 LPFONTDISP OleGetFont();
88 void OleSetFont(LPFONTDISP pFontDisp);
89
90 LPPICTUREDISP OleGetPicture();
91
96 void OleSetPicture(LPPICTUREDISP pPictureDisp);
97
105 CPictureHolder* GetPictureHolder();
106
107# endif
108};
109
110# ifdef _XTP_ACTIVEX
111AFX_INLINE CPictureHolder* XTP_DAYITEM_METRICS::GetPictureHolder()
112{
113 return &m_olePicture;
114}
115# endif
116
125struct XTP_NC_DATEPICKER_BUTTON
126{
127 NMHDR hdr;
128 int nID;
130};
131
146typedef void(CALLBACK* PFNITEMMETRICS)(CXTPDatePickerControl* pDatePicker,
147 const COleDateTime& rDateTime,
148 XTP_DAYITEM_METRICS* pDayItemMetrics, void* pUserData);
149
150const UINT XTP_NC_DATEPICKER_BUTTON_CLICK = (NM_FIRST - 50);
151const UINT XTP_NC_DATEPICKER_SELECTION_CHANGED = (NM_FIRST - 51);
152const UINT XTP_DATEPICKER_TIMERID = 255;
153const UINT XTP_DATEPICKER_TIMER_INTERVAL = 200;
154const UINT XTP_SELECTION_INFINITE = (UINT)-1;
160enum XTPDatePickerBorderStyle
161{
162 xtpDatePickerBorderNone,
163 xtpDatePickerBorder3D,
164 xtpDatePickerBorderOffice,
165 xtpDatePickerBorderStatic
166};
167
175class _XTP_EXT_CLASS CXTPDatePickerButton
176{
177public:
185 CXTPDatePickerButton();
186
191 virtual ~CXTPDatePickerButton()
192 {
193 }
194
207 virtual CString GetCaption() const;
208
221 virtual void SetCaption(LPCTSTR pcszCaption);
222
223public:
224 int m_nID;
227 CRect m_rcButton;
230 BOOL m_bVisible;
232 BOOL m_bPressed;
234 BOOL m_bHighlight;
237protected:
238 CString m_strCaption;
239};
240
255class _XTP_EXT_CLASS CXTPDatePickerButtons
256 : public CArray<CXTPDatePickerButton*, CXTPDatePickerButton*>
257{
258public:
267 int GetVisibleButtonCount() const;
268
281 CXTPDatePickerButton* Find(int nID) const;
282
295 CXTPDatePickerButton* HitTest(CPoint point) const;
296};
297
330class _XTP_EXT_CLASS CXTPDatePickerControl : public CWnd
331{
332 friend class CXTPDatePickerItemMonth;
333 friend class CXTPDatePickerDaysCollection;
334 friend class CXTPCalendarController;
335
336public:
344 enum DatePickerMouseMode
345 {
346 mouseNothing,
347 mouseScrollingLeft,
348 mouseScrollingRight,
349 mouseSelecting,
351 mouseDeselecting,
353 mouseTrackingHeaderList
354 };
355 // Construction
356public:
384 CXTPDatePickerControl();
385
390 virtual ~CXTPDatePickerControl();
391
392public:
408 virtual BOOL Create(DWORD dwStyle, const RECT& rect, CWnd* pParentWnd, UINT nID,
409 CCreateContext* pContext = NULL);
410
424 virtual BOOL GoModal(const RECT& rect, CWnd* pParentWnd = NULL);
425
435 BOOL IsModal() const;
436
450 CXTPDatePickerPaintManager* GetPaintManager() const;
451
462 virtual void RedrawControl();
463
477 void SetTheme(CXTPDatePickerPaintManager* pPaintManager = NULL);
478
492 BOOL IsAutoSize() const;
493
510 void SetAutoSize(BOOL bAuto = TRUE);
511
528 virtual void SetCallbackDayMetrics(PFNITEMMETRICS pFunc, void* pParam = NULL);
529
542 PFNITEMMETRICS GetCallbackDayMetrics() const;
543
557 virtual void GetDayMetrics(COleDateTime& dtDay, XTP_DAYITEM_METRICS* pDayMetics);
558
570 void SetFirstDayOfWeek(int nDay);
571
589 int GetFirstDayOfWeek() const;
590
608 void SetFirstWeekOfYearDays(int nDays);
609
621 int GetFirstWeekOfYearDays() const;
622
638 virtual void SetButtonsVisible(BOOL bShowToday, BOOL bShowNone);
639
654 virtual BOOL IsTodayButtonVisible();
655
670 virtual BOOL IsNoneButtonVisible();
671
689 void SetHighlightToday(BOOL bValue);
690
706 BOOL GetHighlightToday() const;
707
714 virtual void SetLayoutRTL(BOOL bRightToLeft);
715
732 virtual void SetShowWeekNumbers(BOOL bValue);
733
753 BOOL GetShowWeekNumbers() const;
754
776 void SetShowNonMonthDays(BOOL bShow);
777
798 BOOL GetShowNonMonthDays() const;
799
812 void SetBorderStyle(XTPDatePickerBorderStyle borderStyle);
813
825 XTPDatePickerBorderStyle GetBorderStyle() const;
826
847 virtual void SetGridSize(int nRows, int nCols, BOOL bRestrictMode = FALSE);
848
859 int GetRows() const;
860
872 int GetCols() const;
873
896 virtual CXTPDatePickerItemMonth* HitTest(CPoint ptMouse) const;
897
922 virtual DWORD HitTest(PMCHITTESTINFO pMCHitTest) const;
923
937 virtual void ScrollLeft(int nMonthCount = 1);
938
952 virtual void ScrollRight(int nMonthCount = 1);
953
997 virtual LRESULT SendMessageToParent(int nMessage, NMHDR* pNMHDR = NULL);
998
1016 virtual BOOL IsSelected(const COleDateTime& dtDay) const;
1017
1034 virtual BOOL IsFocused(const COleDateTime& dtDay) const;
1035
1048 virtual void ClearFocus();
1049
1063 virtual void Select(const COleDateTime& dtDay);
1064
1077 virtual void Deselect(const COleDateTime& dtDay);
1078
1092 virtual void EnsureVisible(const COleDateTime& dtDate);
1093
1105 virtual void EnsureVisibleSelection();
1106
1120 virtual void EnsureVisibleFocus();
1121
1138 void SetMonthName(int nMonth, LPCTSTR strMonthName);
1139
1159 CString GetMonthName(int nMonth) const;
1160
1175 void EnableSysYearMonthFormat(BOOL nEnable);
1176
1191 void SetDayOfWeekName(int nDayOfWeek, LPCTSTR strDayOfWeekName);
1192
1212 CString GetDayOfWeekName(int nDayOfWeek) const;
1213
1233 virtual BOOL GetSelRange(COleDateTime& refMinRange, COleDateTime& refMaxRange) const;
1234
1257 virtual BOOL SetSelRange(const COleDateTime& refMinRange, const COleDateTime& refMaxRange);
1258
1283 virtual BOOL GetMinReqRect(RECT* pRect) const;
1284
1311 virtual BOOL GetMinReqRect(RECT* pRect, int nRows, int nCols) const;
1312
1330 virtual BOOL SizeMinReq(BOOL bRepaint = TRUE);
1331
1347 int GetMonthDelta() const;
1348
1364 void SetMonthDelta(int iDelta);
1365
1383 virtual BOOL GetCurSel(COleDateTime& refDateTime) const;
1384
1401 virtual BOOL SetCurSel(const COleDateTime& refDateTime);
1402
1419 int GetMaxSelCount() const;
1420
1437 void SetMaxSelCount(int nMax = XTP_SELECTION_INFINITE);
1438
1457 void AllowNoncontinuousSelection(BOOL bAllow = TRUE);
1458
1477 BOOL IsAllowNoncontinuousSelection() const;
1478
1487 BOOL IsMultiSelectionMode() const;
1488
1499 void SetMultiSelectionMode(BOOL bMultiSelectionMode);
1500
1519 virtual BOOL GetToday(COleDateTime& refDateTime) const;
1520
1537 virtual void SetToday(const COleDateTime& refDateTime);
1538
1565 virtual DWORD GetRange(COleDateTime* pMinRange, COleDateTime* pMaxRange) const;
1566
1585 virtual BOOL SetRange(const COleDateTime* pMinRange, const COleDateTime* pMaxRange);
1586
1614 virtual int GetMonthRange(COleDateTime& refMinRange, COleDateTime& refMaxRange,
1615 DWORD dwFlags) const;
1616
1628 virtual BOOL GetVisibleRange(COleDateTime& refFirstVisibleDay,
1629 COleDateTime& refLastVisibleDay) const;
1630
1641 virtual void SetDesiredVisibleAndFullRange(COleDateTime FirstVisibleDay,
1642 COleDateTime LastVisibleDay, COleDateTime FirstDay,
1643 COleDateTime LastDay);
1644
1658 int GetButtonCount() const;
1659
1675 CXTPDatePickerButton* GetButton(int nIndex) const;
1676
1690 virtual void AddButton(UINT nID);
1691
1704 CXTPNotifyConnection* GetConnection() const;
1705
1719 CXTPDatePickerDaysCollection* GetSelectedDays() const;
1720
1732 virtual void AdjustLayout();
1733
1740 XTPCalendarTheme GetPaintTheme() const;
1741
1748 void SetPaintTheme(XTPCalendarTheme ePaintTheme);
1749
1759 BOOL RegisterWindowClass(HINSTANCE hInstance = NULL);
1760
1761 BOOL IsLimitMonthDaysSelection() const;
1762 void SetLimitMonthDaysSelection(BOOL bLimitMonthDaysSelection);
1763
1764protected:
1783 virtual void SendNotification(XTP_NOTIFY_CODE EventCode, WPARAM wParam = 0, LPARAM lParam = 0);
1784
1785protected:
1800 virtual void InitNames();
1801
1814 virtual void Populate();
1815
1828 virtual void _RedrawControl(BOOL bUpdateNow);
1829
1836 virtual void ClearMonths();
1837
1846 virtual void OnDraw(CDC* pDC);
1847
1856 virtual void DrawButtons(CDC* pDC);
1866 virtual void AdjustLayout(CRect rcClient);
1867
1877 virtual CSize CalcButtonSize() const;
1878
1887 virtual void SetButtonRect();
1888
1900 virtual void CalcButtonBandRect();
1901
1912 virtual void ProcessButtons(CPoint point);
1913
1927 virtual void ShowListHeader(CRect rcHeader, COleDateTime dtMonth);
1928
1949 static BOOL AFX_CDECL ShiftDate(COleDateTime& refDate, int nMonthCount);
1950
1962 virtual CSize SetGridDimentions(CRect rcGrid);
1963
1973 virtual void CreateMonthArray();
1974
1987 virtual void PreSubclassWindow();
1988
2003 virtual void OnButtonClick(UINT nID);
2004
2005protected:
2006 DatePickerMouseMode m_mouseMode;
2009 int m_nLockUpdateCount;
2012 int m_nTimerID;
2014 CRect m_rcControl;
2016 CXTPDatePickerPaintManager* m_pPaintManager;
2019 BOOL m_bAutoSize;
2020 BOOL m_bIsModal;
2023 BOOL m_bChanged;
2026 CBitmap m_bmpCache;
2028 int m_nRows;
2030 int m_nColumns;
2033 int m_nDesiredRows;
2034 int m_nDesiredColumns;
2036 CXTPNotifyConnection* m_pConnection;
2039 COleDateTime m_dtMinRange;
2041 COleDateTime m_dtMaxRange;
2043 COleDateTime m_dtToday;
2045 COleDateTime m_dtFirstMonth;
2047 int m_nFirstDayOfWeek;
2049 int m_nFirstWeekOfYearDays;
2052 PFNITEMMETRICS m_pfnCallback;
2054 void* m_pCallbackParam;
2057 CArray<CXTPDatePickerItemMonth*, CXTPDatePickerItemMonth*>
2058 m_arrMonths;
2060 CXTPDatePickerDaysCollection* m_pSelectedDays;
2063 BOOL m_bHighlightToday;
2065 BOOL m_bShowWeekNumbers;
2067 BOOL m_bShowNonMonthDays;
2069 XTPDatePickerBorderStyle m_borderStyle;
2071 int m_nMaxSelectionDays;
2073 int m_nMonthDelta;
2077 BOOL m_bLimitMonthDaysSelection;
2080 COleDateTime m_dtFirstClicked;
2082 COleDateTime m_dtLastClicked;
2084 BOOL m_bSelectWeek;
2086 COleDateTime m_dtFocused;
2088 COleDateTime m_dtFSelBase;
2092 CXTPDatePickerList* m_pListControl;
2095 CString* m_arMonthNames;
2096 CString* m_arDayOfWeekNames;
2099 CRect m_rcGrid;
2101 CXTPDatePickerButtons m_arrButtons;
2103 BOOL m_bAllowNoncontinuousSelection;
2104 BOOL m_bMultiSelectionMode;
2107 CXTPDatePickerButton* m_pButtonCaptured;
2108 BOOL m_bRightToLeft;
2110 LCID m_lcidActiveLocale;
2111
2112 enum XTPEnumMovmentStep
2113 {
2114 stepDay = 1,
2115 stepWeek = 2,
2116 stepMonth = 3,
2117 stepYear = 4,
2118
2119 stepWeekBE = 10,
2120 stepMonthBE = 11
2121 };
2122 enum XTPEnumMovmentDirection
2123 {
2124 dirNext = 1,
2125 dirPrev = -1
2126 };
2127
2128 class CXTPSelectionHelper
2129 {
2130 public:
2131 CXTPSelectionHelper(CXTPDatePickerControl* pControl);
2132
2133 void RemoveFocus();
2134
2135 void MoveFocus(int eStep, int eDirection, BOOL bContinuouse, BOOL bSaveSel);
2136 void SelUnselFocus();
2137
2138 void _TmpSaveFocus();
2139 void _TmpRestoreFocus();
2140
2141 protected:
2142 void InitFocusIfNeed();
2143
2144 void _MoveFocus(int eStep, int eDirection);
2145
2146 CXTPDatePickerControl* m_pDP;
2147
2148 COleDateTime m_dtFocusedTmp;
2149 COleDateTime m_dtFSelBaseTmp;
2150 };
2151 friend class CXTPSelectionHelper;
2152
2153protected:
2154 // AFX_MSG(CXTPDatePickerControl)
2155 afx_msg BOOL OnEraseBkgnd(CDC* pDC);
2156 afx_msg int OnCreate(LPCREATESTRUCT lp);
2157 afx_msg void OnPaint();
2158 afx_msg LRESULT OnPrintClient(WPARAM wParam, LPARAM /*lParam*/);
2159 afx_msg void OnLButtonDown(UINT nFlags, CPoint point);
2160 afx_msg void OnLButtonUp(UINT nFlags, CPoint point);
2161 afx_msg void OnLButtonDblClk(UINT nFlags, CPoint point);
2162 afx_msg void OnCaptureChanged(CWnd* pWnd);
2163 afx_msg void OnCancelMode();
2164 afx_msg void OnMouseMove(UINT nFlags, CPoint point);
2165 afx_msg void OnSize(UINT nType, int cx, int cy);
2166 afx_msg void OnTimeChange();
2167 afx_msg void OnTimer(UINT_PTR nIDEvent);
2168 afx_msg void OnSysColorChange();
2169 afx_msg void OnKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags);
2170 afx_msg void OnMouseLeave();
2171 afx_msg BOOL OnSetCursor(CWnd* pWnd, UINT nHitTest, UINT message);
2172 afx_msg void OnSetFocus(CWnd* pOldWnd);
2173 afx_msg void OnKillFocus(CWnd* pNewWnd);
2174 afx_msg UINT OnGetDlgCode();
2175 afx_msg void OnDestroy();
2176 afx_msg void OnEnable(BOOL bEnable);
2177 //}}AFX_MSG
2178
2179 virtual void OnFinalRelease();
2180
2182 DECLARE_MESSAGE_MAP()
2185private:
2186 virtual BOOL Create(LPCTSTR lpszClassName, LPCTSTR lpszWindowName, DWORD dwStyle,
2187 const RECT& rect, CWnd* pParentWnd, UINT nID,
2188 CCreateContext* pContext = NULL);
2189
2190 virtual void _EndModalIfNeed();
2191
2192 CXTPNotifySink* m_pSink;
2193 void OnEventResourceImagesChanged(XTP_NOTIFY_CODE Event, WPARAM wParam, LPARAM lParam);
2194
2195public:
2196 BOOL m_bDeleteOnFinalRelease;
2197 BOOL m_bYearsTriangle;
2198 BOOL m_bRestrictMode;
2199 CString m_strYearMonthFormat;
2200};
2201
2203
2204AFX_INLINE CXTPDatePickerPaintManager* CXTPDatePickerControl::GetPaintManager() const
2205{
2206 return m_pPaintManager;
2207}
2208AFX_INLINE BOOL CXTPDatePickerControl::IsModal() const
2209{
2210 return m_bIsModal;
2211}
2212AFX_INLINE BOOL CXTPDatePickerControl::IsAutoSize() const
2213{
2214 return m_bAutoSize;
2215}
2216AFX_INLINE void CXTPDatePickerControl::SetCallbackDayMetrics(PFNITEMMETRICS pFunc, void* pParam)
2217{
2218 m_pfnCallback = pFunc;
2219 m_pCallbackParam = pParam;
2220}
2221AFX_INLINE PFNITEMMETRICS CXTPDatePickerControl::GetCallbackDayMetrics() const
2222{
2223 return m_pfnCallback;
2224}
2225AFX_INLINE void CXTPDatePickerControl::SetFirstDayOfWeek(int nDay)
2226{
2227 _ASSERTE(nDay >= 1 && nDay <= 7);
2228 if (nDay >= 1 && nDay <= 7 && nDay != m_nFirstDayOfWeek)
2229 {
2230 m_nFirstDayOfWeek = nDay;
2231 Populate();
2232 }
2233}
2234AFX_INLINE int CXTPDatePickerControl::GetFirstDayOfWeek() const
2235{
2236 return m_nFirstDayOfWeek;
2237}
2238AFX_INLINE void CXTPDatePickerControl::SetFirstWeekOfYearDays(int nDays)
2239{
2240 _ASSERTE(nDays >= 1 && nDays <= 7);
2241 if (nDays >= 1 && nDays <= 7 && nDays != m_nFirstWeekOfYearDays)
2242 {
2243 m_nFirstWeekOfYearDays = nDays;
2244 RedrawControl();
2245 }
2246}
2247AFX_INLINE int CXTPDatePickerControl::GetFirstWeekOfYearDays() const
2248{
2249 return m_nFirstWeekOfYearDays;
2250}
2251AFX_INLINE BOOL CXTPDatePickerControl::GetHighlightToday() const
2252{
2253 return m_bHighlightToday;
2254}
2255AFX_INLINE BOOL CXTPDatePickerControl::GetShowWeekNumbers() const
2256{
2257 return m_bShowWeekNumbers;
2258}
2259AFX_INLINE int CXTPDatePickerControl::GetRows() const
2260{
2261 return m_nRows;
2262}
2263AFX_INLINE int CXTPDatePickerControl::GetCols() const
2264{
2265 return m_nColumns;
2266}
2267AFX_INLINE void CXTPDatePickerControl::SetMonthName(int nMonth, LPCTSTR strMonthName)
2268{
2269 _ASSERTE(nMonth >= 1 && nMonth <= 12);
2270 m_arMonthNames[nMonth - 1] = strMonthName;
2271}
2272AFX_INLINE CString CXTPDatePickerControl::GetMonthName(int nMonth) const
2273{
2274 return nMonth >= 1 && nMonth <= 12 ? m_arMonthNames[nMonth - 1] : CString();
2275}
2276AFX_INLINE void CXTPDatePickerControl::SetDayOfWeekName(int nDayOfWeek, LPCTSTR strDayOfWeekName)
2277{
2278 _ASSERTE(nDayOfWeek >= 1 && nDayOfWeek <= 7);
2279 m_arDayOfWeekNames[nDayOfWeek - 1] = strDayOfWeekName;
2280}
2281AFX_INLINE CString CXTPDatePickerControl::GetDayOfWeekName(int nDayOfWeek) const
2282{
2283 return nDayOfWeek >= 1 && nDayOfWeek <= 7 ? m_arDayOfWeekNames[nDayOfWeek - 1] : CString();
2284}
2285AFX_INLINE BOOL CXTPDatePickerControl::GetShowNonMonthDays() const
2286{
2287 return m_bShowNonMonthDays;
2288}
2289AFX_INLINE XTPDatePickerBorderStyle CXTPDatePickerControl::GetBorderStyle() const
2290{
2291 return m_borderStyle;
2292}
2293AFX_INLINE int CXTPDatePickerControl::GetMaxSelCount() const
2294{
2295 return m_nMaxSelectionDays;
2296}
2297AFX_INLINE int CXTPDatePickerControl::GetMonthDelta() const
2298{
2299 return m_nMonthDelta ? m_nMonthDelta : 1;
2300}
2301AFX_INLINE void CXTPDatePickerControl::SetMonthDelta(int iDelta)
2302{
2303 m_nMonthDelta = iDelta;
2304}
2305AFX_INLINE BOOL CXTPDatePickerControl::GetToday(COleDateTime& refDateTime) const
2306{
2307 refDateTime = m_dtToday;
2308 return TRUE;
2309}
2310AFX_INLINE int CXTPDatePickerControl::GetButtonCount() const
2311{
2312 return (int)m_arrButtons.GetSize();
2313}
2314AFX_INLINE CXTPDatePickerButton* CXTPDatePickerControl::GetButton(int nIndex) const
2315{
2316 return m_arrButtons[nIndex];
2317}
2318AFX_INLINE CXTPNotifyConnection* CXTPDatePickerControl::GetConnection() const
2319{
2320 return m_pConnection;
2321}
2322AFX_INLINE BOOL CXTPDatePickerControl::IsAllowNoncontinuousSelection() const
2323{
2324 return m_bAllowNoncontinuousSelection;
2325}
2326AFX_INLINE CXTPDatePickerDaysCollection* CXTPDatePickerControl::GetSelectedDays() const
2327{
2328 return m_pSelectedDays;
2329}
2330AFX_INLINE void CXTPDatePickerControl::AdjustLayout()
2331{
2332 InitNames();
2333 AdjustLayout(m_rcControl);
2334}
2335
2336AFX_INLINE BOOL CXTPDatePickerControl::Create(LPCTSTR lpszClassName, LPCTSTR lpszWindowName,
2337 DWORD dwStyle, const RECT& rect, CWnd* pParentWnd,
2338 UINT nID, CCreateContext* pContext)
2339{
2340 return CWnd::Create(lpszClassName, lpszWindowName, dwStyle, rect, pParentWnd, nID, pContext);
2341}
2342
2343AFX_INLINE BOOL CXTPDatePickerControl::IsMultiSelectionMode() const
2344{
2345 return m_bMultiSelectionMode;
2346}
2347AFX_INLINE void CXTPDatePickerControl::SetMultiSelectionMode(BOOL bMultiSelectionMode)
2348{
2349 m_bMultiSelectionMode = bMultiSelectionMode;
2350}
2351
2352AFX_INLINE BOOL CXTPDatePickerControl::IsLimitMonthDaysSelection() const
2353{
2354 return m_bLimitMonthDaysSelection;
2355}
2356AFX_INLINE void CXTPDatePickerControl::SetLimitMonthDaysSelection(BOOL bLimitMonthDaysSelection)
2357{
2358 m_bLimitMonthDaysSelection = bLimitMonthDaysSelection;
2359}
2360
2361# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
2362#endif // !defined(_XTPDATEPICKERCONTROL_H__)
XTPCalendarTheme
XTPCalendarTheme
Paint themes used by calendar.
Definition XTPCalendarDefines.h:62
XTP_DATEPICKER_TIMERID
const UINT XTP_DATEPICKER_TIMERID
Date picker timer ID.
Definition XTPDatePickerControl.h:152
XTP_NC_DATEPICKER_SELECTION_CHANGED
const UINT XTP_NC_DATEPICKER_SELECTION_CHANGED
Notify ID to parent window.
Definition XTPDatePickerControl.h:151
XTP_DATEPICKER_TIMER_INTERVAL
const UINT XTP_DATEPICKER_TIMER_INTERVAL
Date picker timer interval.
Definition XTPDatePickerControl.h:153
XTP_SELECTION_INFINITE
const UINT XTP_SELECTION_INFINITE
Infinite number of selected days.
Definition XTPDatePickerControl.h:154
XTPDatePickerBorderStyle
XTPDatePickerBorderStyle
Border style of Date picker control.
Definition XTPDatePickerControl.h:161
xtpDatePickerBorderNone
@ xtpDatePickerBorderNone
No border.
Definition XTPDatePickerControl.h:162
xtpDatePickerBorder3D
@ xtpDatePickerBorder3D
3D border.
Definition XTPDatePickerControl.h:163
xtpDatePickerBorderOffice
@ xtpDatePickerBorderOffice
Office-like border.
Definition XTPDatePickerControl.h:164
xtpDatePickerBorderStatic
@ xtpDatePickerBorderStatic
Static border.
Definition XTPDatePickerControl.h:165
XTP_NC_DATEPICKER_BUTTON_CLICK
const UINT XTP_NC_DATEPICKER_BUTTON_CLICK
Notify ID to parent window.
Definition XTPDatePickerControl.h:150
PFNITEMMETRICS
void(CALLBACK * PFNITEMMETRICS)(CXTPDatePickerControl *pDatePicker, const COleDateTime &rDateTime, XTP_DAYITEM_METRICS *pDayItemMetrics, void *pUserData)
Callback function definition for the IsITEMMETRICS function.
Definition XTPDatePickerControl.h:146
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCalendarController
Class CXTPCalendarController provides a connection between a CXTPCalendarControl object and a CXTPDat...
Definition XTPCalendarController.h:54
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPDatePickerButton
This class represents a DatePicker button.
Definition XTPDatePickerControl.h:176
CXTPDatePickerButton::CXTPDatePickerButton
CXTPDatePickerButton()
Default button constructor.
CXTPDatePickerButton::GetCaption
virtual CString GetCaption() const
Get a button caption.
CXTPDatePickerButton::~CXTPDatePickerButton
virtual ~CXTPDatePickerButton()
Destroys a CXTPDatePickerButton object, handles cleanup and deallocation.
Definition XTPDatePickerControl.h:191
CXTPDatePickerButton::m_bHighlight
BOOL m_bHighlight
This member variable is used to indicate if a button is highlighted.
Definition XTPDatePickerControl.h:234
CXTPDatePickerButton::m_bVisible
BOOL m_bVisible
This member variable is used to indicate if a button is visible.
Definition XTPDatePickerControl.h:230
CXTPDatePickerButton::m_rcButton
CRect m_rcButton
This member variable is used to specify the bounding rectangle coordinates of a button.
Definition XTPDatePickerControl.h:227
CXTPDatePickerButton::m_bPressed
BOOL m_bPressed
This member variable is used to indicate if a button is pressed.
Definition XTPDatePickerControl.h:232
CXTPDatePickerButton::SetCaption
virtual void SetCaption(LPCTSTR pcszCaption)
Set a button caption.
CXTPDatePickerButton::m_nID
int m_nID
This member variable is used to specify the identifier of the button.
Definition XTPDatePickerControl.h:224
CXTPDatePickerButton::m_strCaption
CString m_strCaption
This member variable is used to specify the caption of the button.
Definition XTPDatePickerControl.h:238
CXTPDatePickerButtons
Class CXTPDatePickerButtons represents a collection of buttons.
Definition XTPDatePickerControl.h:257
CXTPDatePickerButtons::Find
CXTPDatePickerButton * Find(int nID) const
This member function finds buttons by their ID property.
CXTPDatePickerButtons::GetVisibleButtonCount
int GetVisibleButtonCount() const
Call this member function to retrieve the current count of visible buttons.
CXTPDatePickerButtons::HitTest
CXTPDatePickerButton * HitTest(CPoint point) const
This member function determines which button is affected by the mouse pointer.
CXTPDatePickerControl
Class CXTPDatePickerControl encapsulates the functionality of a date and time picker control.
Definition XTPDatePickerControl.h:331
CXTPDatePickerControl::SetLayoutRTL
virtual void SetLayoutRTL(BOOL bRightToLeft)
Call this member to set right-to-left mode.
CXTPDatePickerControl::SetCallbackDayMetrics
virtual void SetCallbackDayMetrics(PFNITEMMETRICS pFunc, void *pParam=NULL)
This member function sets the user-defined day metrics callback function.
Definition XTPDatePickerControl.h:2216
CXTPDatePickerControl::HitTest
virtual DWORD HitTest(PMCHITTESTINFO pMCHitTest) const
This member function finds the month item at the provided point.
CXTPDatePickerControl::m_nColumns
int m_nColumns
This member variable is used to specify the number of columns in the column month's grid.
Definition XTPDatePickerControl.h:2030
CXTPDatePickerControl::SetMonthName
void SetMonthName(int nMonth, LPCTSTR strMonthName)
This member function sets the user-defined month name.
Definition XTPDatePickerControl.h:2267
CXTPDatePickerControl::m_dtMaxRange
COleDateTime m_dtMaxRange
This member variable specifies the maximum allowable date for a date picker control.
Definition XTPDatePickerControl.h:2041
CXTPDatePickerControl::m_nRows
int m_nRows
This member variable is used to specify the number of rows in the column month's grid.
Definition XTPDatePickerControl.h:2028
CXTPDatePickerControl::GetMonthDelta
int GetMonthDelta() const
This member function retrieves the scroll rate for the date picker control.
Definition XTPDatePickerControl.h:2297
CXTPDatePickerControl::m_borderStyle
XTPDatePickerBorderStyle m_borderStyle
This member variable is a flag that determines if the control displays a 3D border.
Definition XTPDatePickerControl.h:2069
CXTPDatePickerControl::ShiftDate
static BOOL AFX_CDECL ShiftDate(COleDateTime &refDate, int nMonthCount)
This function shifts the specified date for the specified number of months.
CXTPDatePickerControl::GetSelRange
virtual BOOL GetSelRange(COleDateTime &refMinRange, COleDateTime &refMaxRange) const
This member function retrieves date information representing the upper and lower limits of the date r...
CXTPDatePickerControl::m_nMonthDelta
int m_nMonthDelta
This member variable is used to specify the number of months set as the control's scroll rate.
Definition XTPDatePickerControl.h:2073
CXTPDatePickerControl::m_nMaxSelectionDays
int m_nMaxSelectionDays
This member variable is used to specify the maximum number of selected days.
Definition XTPDatePickerControl.h:2071
CXTPDatePickerControl::GetVisibleRange
virtual BOOL GetVisibleRange(COleDateTime &refFirstVisibleDay, COleDateTime &refLastVisibleDay) const
This member function retrieves the first and last displayed days dates.
CXTPDatePickerControl::m_bHighlightToday
BOOL m_bHighlightToday
This member variable is used as a flag to determine if the "Today" date is highlighted.
Definition XTPDatePickerControl.h:2063
CXTPDatePickerControl::GetMonthRange
virtual int GetMonthRange(COleDateTime &refMinRange, COleDateTime &refMaxRange, DWORD dwFlags) const
This member function retrieves date information representing the high and low limits of a date picker...
CXTPDatePickerControl::SetHighlightToday
void SetHighlightToday(BOOL bValue)
Call this member function to enable or disable highlighting of the "Today" cell.
CXTPDatePickerControl::m_dtLastClicked
COleDateTime m_dtLastClicked
This member variable is used to specify the day that was clicked last in the mouse selection.
Definition XTPDatePickerControl.h:2082
CXTPDatePickerControl::SetAutoSize
void SetAutoSize(BOOL bAuto=TRUE)
This function sets the AutoSize mode.
CXTPDatePickerControl::GetRange
virtual DWORD GetRange(COleDateTime *pMinRange, COleDateTime *pMaxRange) const
This member function retrieves the current minimum and maximum dates set in a date picker control.
CXTPDatePickerControl::GetButtonCount
int GetButtonCount() const
This member function returns the number of CXTPDatePickerButton items shown on the control.
Definition XTPDatePickerControl.h:2310
CXTPDatePickerControl::RegisterWindowClass
BOOL RegisterWindowClass(HINSTANCE hInstance=NULL)
This member function registers the window class if it has not already been registered.
CXTPDatePickerControl::m_dtFSelBase
COleDateTime m_dtFSelBase
This member variable is used to specify start day of the continuous selection.
Definition XTPDatePickerControl.h:2088
CXTPDatePickerControl::SetShowNonMonthDays
void SetShowNonMonthDays(BOOL bShow)
Call this member function to show or hide non-month days.
CXTPDatePickerControl::EnableSysYearMonthFormat
void EnableSysYearMonthFormat(BOOL nEnable)
This member function sets the system-defined format of year_month string.
CXTPDatePickerControl::CXTPDatePickerControl
CXTPDatePickerControl()
Default constructor is used to construct a CXTPDatePickerControl object.
CXTPDatePickerControl::GetCols
int GetCols() const
Call this member function to obtain the number of columns in the months grid.
Definition XTPDatePickerControl.h:2263
CXTPDatePickerControl::m_bMultiSelectionMode
BOOL m_bMultiSelectionMode
TRUE if multiselection mode enabled (i.e.
Definition XTPDatePickerControl.h:2104
CXTPDatePickerControl::m_bSelectWeek
BOOL m_bSelectWeek
TRUE when user is started selecting the whole week.
Definition XTPDatePickerControl.h:2084
CXTPDatePickerControl::m_bmpCache
CBitmap m_bmpCache
This member variable is a cached window bitmap.
Definition XTPDatePickerControl.h:2026
CXTPDatePickerControl::SetCurSel
virtual BOOL SetCurSel(const COleDateTime &refDateTime)
This member function sets the currently selected date for the date picker control.
CXTPDatePickerControl::m_arrButtons
CXTPDatePickerButtons m_arrButtons
This member variable is an array of control buttons.
Definition XTPDatePickerControl.h:2101
CXTPDatePickerControl::DatePickerMouseMode
DatePickerMouseMode
Enumeration of operational mouse modes.
Definition XTPDatePickerControl.h:345
CXTPDatePickerControl::mouseScrollingRight
@ mouseScrollingRight
User pressed right scroll triangle and is holding the button.
Definition XTPDatePickerControl.h:348
CXTPDatePickerControl::mouseNothing
@ mouseNothing
No mouse activity by the user.
Definition XTPDatePickerControl.h:346
CXTPDatePickerControl::mouseScrollingLeft
@ mouseScrollingLeft
User pressed left scroll triangle and is holding the button.
Definition XTPDatePickerControl.h:347
CXTPDatePickerControl::m_pButtonCaptured
CXTPDatePickerButton * m_pButtonCaptured
Pointer to a date picker button.
Definition XTPDatePickerControl.h:2107
CXTPDatePickerControl::GetShowWeekNumbers
BOOL GetShowWeekNumbers() const
Call this member function to determine if the week numbers are visible.
Definition XTPDatePickerControl.h:2255
CXTPDatePickerControl::IsAllowNoncontinuousSelection
BOOL IsAllowNoncontinuousSelection() const
This member function returns the flag which shows whether control allows non-continuous days selectio...
Definition XTPDatePickerControl.h:2322
CXTPDatePickerControl::GetFirstWeekOfYearDays
int GetFirstWeekOfYearDays() const
This member function obtains the current required number of year days in the first week of the year.
Definition XTPDatePickerControl.h:2247
CXTPDatePickerControl::GetBorderStyle
XTPDatePickerBorderStyle GetBorderStyle() const
Call this member function to determine if the border is visible.
Definition XTPDatePickerControl.h:2289
CXTPDatePickerControl::GoModal
virtual BOOL GoModal(const RECT &rect, CWnd *pParentWnd=NULL)
This member function implements pop-up window behavior for the Date Picker control.
CXTPDatePickerControl::Populate
virtual void Populate()
This member function performs control population, creating the view from the data.
CXTPDatePickerControl::GetFirstDayOfWeek
int GetFirstDayOfWeek() const
This member function obtains the first day of the week that is displayed in the leftmost column of th...
Definition XTPDatePickerControl.h:2234
CXTPDatePickerControl::IsNoneButtonVisible
virtual BOOL IsNoneButtonVisible()
This function returns the boolean visibility flag of the "None" button.
CXTPDatePickerControl::m_nLockUpdateCount
int m_nLockUpdateCount
This member variable is used as a counter that is used to count the update locks.
Definition XTPDatePickerControl.h:2009
CXTPDatePickerControl::GetToday
virtual BOOL GetToday(COleDateTime &refDateTime) const
This member function retrieves the date information for the date specified as "Today" for the date pi...
Definition XTPDatePickerControl.h:2305
CXTPDatePickerControl::m_bLimitMonthDaysSelection
BOOL m_bLimitMonthDaysSelection
This member variable is a flag that determines to select if the "non-month days".
Definition XTPDatePickerControl.h:2077
CXTPDatePickerControl::IsMultiSelectionMode
BOOL IsMultiSelectionMode() const
Determines if the multiple selection mode is enabled.
Definition XTPDatePickerControl.h:2343
CXTPDatePickerControl::EnsureVisibleSelection
virtual void EnsureVisibleSelection()
Call this member function to ensure that the selection range is visible.
CXTPDatePickerControl::SetDayOfWeekName
void SetDayOfWeekName(int nDayOfWeek, LPCTSTR strDayOfWeekName)
This member function sets the user-defined DayOfWeek name.
Definition XTPDatePickerControl.h:2276
CXTPDatePickerControl::m_pfnCallback
PFNITEMMETRICS m_pfnCallback
This member variable is a pointer to the user's IsSpecialDay function.
Definition XTPDatePickerControl.h:2052
CXTPDatePickerControl::m_nDesiredColumns
int m_nDesiredColumns
The desired columns.
Definition XTPDatePickerControl.h:2034
CXTPDatePickerControl::RedrawControl
virtual void RedrawControl()
This member function redraws the control windows.
CXTPDatePickerControl::m_pSelectedDays
CXTPDatePickerDaysCollection * m_pSelectedDays
This member variable is a collection of selected days.
Definition XTPDatePickerControl.h:2060
CXTPDatePickerControl::m_dtToday
COleDateTime m_dtToday
This member variable is used to specify the "Today" date for a date picker control.
Definition XTPDatePickerControl.h:2043
CXTPDatePickerControl::m_pConnection
CXTPNotifyConnection * m_pConnection
This member variable is a connection object that is used to send notifications.
Definition XTPDatePickerControl.h:2036
CXTPDatePickerControl::GetButton
CXTPDatePickerButton * GetButton(int nIndex) const
This member function returns a pointer to the CXTPDatePickerButton object using its numeric index.
Definition XTPDatePickerControl.h:2314
CXTPDatePickerControl::m_bShowWeekNumbers
BOOL m_bShowWeekNumbers
This member variable is a flag that determines if the "weeknumbers" are displayed.
Definition XTPDatePickerControl.h:2065
CXTPDatePickerControl::SetFirstWeekOfYearDays
void SetFirstWeekOfYearDays(int nDays)
This member function sets the required number of this year days in the first week of the year.
Definition XTPDatePickerControl.h:2238
CXTPDatePickerControl::SetDesiredVisibleAndFullRange
virtual void SetDesiredVisibleAndFullRange(COleDateTime FirstVisibleDay, COleDateTime LastVisibleDay, COleDateTime FirstDay, COleDateTime LastDay)
This member function allows scrolling between FirstDay and LastDay and tries to show the initial visi...
CXTPDatePickerControl::SetShowWeekNumbers
virtual void SetShowWeekNumbers(BOOL bValue)
Call this member function to show or hide the week numbers.
CXTPDatePickerControl::SetFirstDayOfWeek
void SetFirstDayOfWeek(int nDay)
This member function sets the day of the week that is displayed in the leftmost column of the calenda...
Definition XTPDatePickerControl.h:2225
CXTPDatePickerControl::SetGridDimentions
virtual CSize SetGridDimentions(CRect rcGrid)
This member function sets new dimensions for the month grid.
CXTPDatePickerControl::m_bAllowNoncontinuousSelection
BOOL m_bAllowNoncontinuousSelection
TRUE to allow Noncontinuous selection.
Definition XTPDatePickerControl.h:2103
CXTPDatePickerControl::SetPaintTheme
void SetPaintTheme(XTPCalendarTheme ePaintTheme)
This member function is used to set current paint theme.
CXTPDatePickerControl::GetDayOfWeekName
CString GetDayOfWeekName(int nDayOfWeek) const
This member function returns the DayOfWeek name associated with the integer value of nDayOfWeek.
Definition XTPDatePickerControl.h:2281
CXTPDatePickerControl::SetButtonsVisible
virtual void SetButtonsVisible(BOOL bShowToday, BOOL bShowNone)
This function sets visibility for the "Today" and "None" buttons.
CXTPDatePickerControl::Create
virtual BOOL Create(DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID, CCreateContext *pContext=NULL)
This member function is used to create the Date Picker Control Window.
CXTPDatePickerControl::SetGridSize
virtual void SetGridSize(int nRows, int nCols, BOOL bRestrictMode=FALSE)
Call this member function to set the number of months in the control's grid.
CXTPDatePickerControl::GetMinReqRect
virtual BOOL GetMinReqRect(RECT *pRect, int nRows, int nCols) const
This member function retrieves the minimum size required to show a full month in the date picker cont...
CXTPDatePickerControl::GetSelectedDays
CXTPDatePickerDaysCollection * GetSelectedDays() const
Returns a collection of the days selected in the date picker.
Definition XTPDatePickerControl.h:2326
CXTPDatePickerControl::AllowNoncontinuousSelection
void AllowNoncontinuousSelection(BOOL bAllow=TRUE)
This member function sets the flag which shows whether control allows non-continuous days selection o...
CXTPDatePickerControl::GetCurSel
virtual BOOL GetCurSel(COleDateTime &refDateTime) const
This member function retrieves the system time as indicated by the currently-selected date.
CXTPDatePickerControl::SetMultiSelectionMode
void SetMultiSelectionMode(BOOL bMultiSelectionMode)
Enables/disables the multiple selection mode for the control.
Definition XTPDatePickerControl.h:2347
CXTPDatePickerControl::GetCallbackDayMetrics
PFNITEMMETRICS GetCallbackDayMetrics() const
This member function returns the day metrics callback function.
Definition XTPDatePickerControl.h:2221
CXTPDatePickerControl::m_bShowNonMonthDays
BOOL m_bShowNonMonthDays
This member variable is a flag that determines if the "non-monthdays" are displayed.
Definition XTPDatePickerControl.h:2067
CXTPDatePickerControl::IsSelected
virtual BOOL IsSelected(const COleDateTime &dtDay) const
This function checks a specific date to determine if it is contained in the control's selection.
CXTPDatePickerControl::m_arMonthNames
CString * m_arMonthNames
This member variable contains the localized month names values.
Definition XTPDatePickerControl.h:2095
CXTPDatePickerControl::SetSelRange
virtual BOOL SetSelRange(const COleDateTime &refMinRange, const COleDateTime &refMaxRange)
This member function sets the selection for a date picker control to a given date range.
CXTPDatePickerControl::m_arDayOfWeekNames
CString * m_arDayOfWeekNames
This member variable contains the day abbreviation for drawing.
Definition XTPDatePickerControl.h:2096
CXTPDatePickerControl::m_dtFirstMonth
COleDateTime m_dtFirstMonth
This member variable is used to specify the first month in the grid.
Definition XTPDatePickerControl.h:2045
CXTPDatePickerControl::_RedrawControl
virtual void _RedrawControl(BOOL bUpdateNow)
This member function redraws the control windows.
CXTPDatePickerControl::ShowListHeader
virtual void ShowListHeader(CRect rcHeader, COleDateTime dtMonth)
This member function shows a CXTPDatePickerList control at the coordinates specified by rcHeader.
CXTPDatePickerControl::m_bAutoSize
BOOL m_bAutoSize
This member variable is used as the AutoSize flag.
Definition XTPDatePickerControl.h:2019
CXTPDatePickerControl::Deselect
virtual void Deselect(const COleDateTime &dtDay)
Call this member function to de-select the specified day.
CXTPDatePickerControl::SetMaxSelCount
void SetMaxSelCount(int nMax=XTP_SELECTION_INFINITE)
This member function sets the maximum number of days that can be selected in a date picker control.
CXTPDatePickerControl::m_mouseMode
DatePickerMouseMode m_mouseMode
This member variable is used to specify the current Mouse operating mode.
Definition XTPDatePickerControl.h:2006
CXTPDatePickerControl::GetMonthName
CString GetMonthName(int nMonth) const
This member function returns the month name of the given integer value.
Definition XTPDatePickerControl.h:2272
CXTPDatePickerControl::IsAutoSize
BOOL IsAutoSize() const
This function is called to determine if AutoSize mode is set.
Definition XTPDatePickerControl.h:2212
CXTPDatePickerControl::m_rcGrid
CRect m_rcGrid
Months grid rect.
Definition XTPDatePickerControl.h:2099
CXTPDatePickerControl::m_pListControl
CXTPDatePickerList * m_pListControl
This member variable is used to specify the "headermonth list" pop-up control.
Definition XTPDatePickerControl.h:2092
CXTPDatePickerControl::SendNotification
virtual void SendNotification(XTP_NOTIFY_CODE EventCode, WPARAM wParam=0, LPARAM lParam=0)
This member function sends a notification to all control's event subscribers.
CXTPDatePickerControl::PreSubclassWindow
virtual void PreSubclassWindow()
This member function is called by the framework to allow other necessary sub-classing to occur before...
CXTPDatePickerControl::Select
virtual void Select(const COleDateTime &dtDay)
Call this member function to select a specific day.
CXTPDatePickerControl::m_nFirstDayOfWeek
int m_nFirstDayOfWeek
This member variable is used to specify the first day of the week to display (1-Sunday,...
Definition XTPDatePickerControl.h:2047
CXTPDatePickerControl::m_dtFocused
COleDateTime m_dtFocused
This member variable is used to specify the focused day.
Definition XTPDatePickerControl.h:2086
CXTPDatePickerControl::GetDayMetrics
virtual void GetDayMetrics(COleDateTime &dtDay, XTP_DAYITEM_METRICS *pDayMetics)
This member function returns the day item drawing metrics.
CXTPDatePickerControl::m_pPaintManager
CXTPDatePickerPaintManager * m_pPaintManager
This member variable is a pointer to the paint manager.
Definition XTPDatePickerControl.h:2016
CXTPDatePickerControl::InitNames
virtual void InitNames()
This member function initializes the month and day names depending on localization.
CXTPDatePickerControl::GetShowNonMonthDays
BOOL GetShowNonMonthDays() const
Call this member function to determine if the non-month days are visible.
Definition XTPDatePickerControl.h:2285
CXTPDatePickerControl::IsModal
BOOL IsModal() const
Is the control runs in modal mode.
Definition XTPDatePickerControl.h:2208
CXTPDatePickerControl::m_dtMinRange
COleDateTime m_dtMinRange
This member variable specifies the minimum allowable date for a date picker control.
Definition XTPDatePickerControl.h:2039
CXTPDatePickerControl::m_pCallbackParam
void * m_pCallbackParam
This member variable is a pointer to the user's additional parameter for the callback function.
Definition XTPDatePickerControl.h:2054
CXTPDatePickerControl::ClearFocus
virtual void ClearFocus()
This function clear focused attribute if it is set.
CXTPDatePickerControl::CalcButtonSize
virtual CSize CalcButtonSize() const
This member function calculates the size of the button.
CXTPDatePickerControl::m_arrMonths
CArray< CXTPDatePickerItemMonth *, CXTPDatePickerItemMonth * > m_arrMonths
This member variable is an internal storage for the month items.
Definition XTPDatePickerControl.h:2058
CXTPDatePickerControl::CreateMonthArray
virtual void CreateMonthArray()
This member function creates the internal month array.
CXTPDatePickerControl::SetButtonRect
virtual void SetButtonRect()
Call this member function to calculate and set the button's bounding rectangle.
CXTPDatePickerControl::OnDraw
virtual void OnDraw(CDC *pDC)
This member function is used to perform all drawing logic.
CXTPDatePickerControl::EnsureVisible
virtual void EnsureVisible(const COleDateTime &dtDate)
Call this member function to ensure that a specified COleDateTime item is visible.
CXTPDatePickerControl::GetMaxSelCount
int GetMaxSelCount() const
This member function retrieves the current maximum number of days that can be selected in a date pick...
Definition XTPDatePickerControl.h:2293
CXTPDatePickerControl::SizeMinReq
virtual BOOL SizeMinReq(BOOL bRepaint=TRUE)
This member function adjusts the date picker control to the minimum size required to display one mont...
CXTPDatePickerControl::ScrollRight
virtual void ScrollRight(int nMonthCount=1)
This member function scrolls the control's months grid to the right by the specified amount of months...
CXTPDatePickerControl::GetMinReqRect
virtual BOOL GetMinReqRect(RECT *pRect) const
This member function retrieves the minimum size required to show a full month in the date picker cont...
CXTPDatePickerControl::SetToday
virtual void SetToday(const COleDateTime &refDateTime)
This member function sets the calendar control to the current day.
CXTPDatePickerControl::SendMessageToParent
virtual LRESULT SendMessageToParent(int nMessage, NMHDR *pNMHDR=NULL)
Call this member function to send notifications to the parent window.
CXTPDatePickerControl::OnButtonClick
virtual void OnButtonClick(UINT nID)
This member function is used to process the control's button clicks.
CXTPDatePickerControl::m_bIsModal
BOOL m_bIsModal
This member variable is used to specify if the control is used as a pop-up window.
Definition XTPDatePickerControl.h:2020
CXTPDatePickerControl::m_bChanged
BOOL m_bChanged
This member variable is used to determine if the control requires redrawing.
Definition XTPDatePickerControl.h:2023
CXTPDatePickerControl::AddButton
virtual void AddButton(UINT nID)
This member function adds one more buttons to the control.
CXTPDatePickerControl::GetPaintTheme
XTPCalendarTheme GetPaintTheme() const
This member function is used to obtain current paint theme.
CXTPDatePickerControl::IsTodayButtonVisible
virtual BOOL IsTodayButtonVisible()
This member function is used to obtain the value of the visibility flag for the "Today" button.
CXTPDatePickerControl::EnsureVisibleFocus
virtual void EnsureVisibleFocus()
Call this member function to ensure that the focused item is visible.
CXTPDatePickerControl::SetRange
virtual BOOL SetRange(const COleDateTime *pMinRange, const COleDateTime *pMaxRange)
This member function sets the minimum and maximum allowable dates for a date picker control.
CXTPDatePickerControl::m_bRightToLeft
BOOL m_bRightToLeft
TRUE to display calendar components in Right-To-Left (RTL) format.
Definition XTPDatePickerControl.h:2108
CXTPDatePickerControl::IsFocused
virtual BOOL IsFocused(const COleDateTime &dtDay) const
This function checks a specific date to determine if it is focused.
CXTPDatePickerControl::GetRows
int GetRows() const
Call this member function to obtain the number of rows in the months grid.
Definition XTPDatePickerControl.h:2259
CXTPDatePickerControl::AdjustLayout
virtual void AdjustLayout(CRect rcClient)
This member function adjusts the layout of all sub-items depending on the current window client size.
CXTPDatePickerControl::SetMonthDelta
void SetMonthDelta(int iDelta)
This member function sets the scroll rate for the date picker control.
Definition XTPDatePickerControl.h:2301
CXTPDatePickerControl::ClearMonths
virtual void ClearMonths()
This member function is used to cleanup the months array.
CXTPDatePickerControl::GetHighlightToday
BOOL GetHighlightToday() const
Call this member function to determine whether the "Today" cell highlighting is enabled or disabled.
Definition XTPDatePickerControl.h:2251
CXTPDatePickerControl::ScrollLeft
virtual void ScrollLeft(int nMonthCount=1)
This member function scrolls the control's months grid to the left by the specified number of months.
CXTPDatePickerControl::m_nFirstWeekOfYearDays
int m_nFirstWeekOfYearDays
This member variable is used to specify the number of days of the new year in the first week of this ...
Definition XTPDatePickerControl.h:2049
CXTPDatePickerControl::GetConnection
CXTPNotifyConnection * GetConnection() const
This member function obtains a notification connection object pointer.
Definition XTPDatePickerControl.h:2318
CXTPDatePickerControl::m_nTimerID
int m_nTimerID
This member variable is used to specify the control timer ID.
Definition XTPDatePickerControl.h:2012
CXTPDatePickerControl::m_nDesiredRows
int m_nDesiredRows
The desired rows.
Definition XTPDatePickerControl.h:2033
CXTPDatePickerControl::AdjustLayout
virtual void AdjustLayout()
This member function adjusts the layout of all sub-items depending on the current window client size.
Definition XTPDatePickerControl.h:2330
CXTPDatePickerControl::HitTest
virtual CXTPDatePickerItemMonth * HitTest(CPoint ptMouse) const
This member function finds the month item at the provided point.
CXTPDatePickerControl::m_rcControl
CRect m_rcControl
This data member is used to store the control drawing coordinates.
Definition XTPDatePickerControl.h:2014
CXTPDatePickerControl::SetTheme
void SetTheme(CXTPDatePickerPaintManager *pPaintManager=NULL)
This member function sets the new control drawing theme.
CXTPDatePickerControl::CalcButtonBandRect
virtual void CalcButtonBandRect()
Call this member function to calculate and set the button's band rectangle.
CXTPDatePickerControl::ProcessButtons
virtual void ProcessButtons(CPoint point)
This member function is used to implement button behavior.
CXTPDatePickerControl::m_dtFirstClicked
COleDateTime m_dtFirstClicked
This member variable is used to specify the day that was clicked before starting the mouse selection.
Definition XTPDatePickerControl.h:2080
CXTPDatePickerControl::SetBorderStyle
void SetBorderStyle(XTPDatePickerBorderStyle borderStyle)
Call this member function to set borders style around the control.
CXTPDatePickerControl::~CXTPDatePickerControl
virtual ~CXTPDatePickerControl()
Destroys a CXTPDatePickerControl object, handles cleanup and deallocation.
CXTPDatePickerControl::DrawButtons
virtual void DrawButtons(CDC *pDC)
Call this member function to draw the calendar's buttons.
CXTPDatePickerDaysCollection
Definition XTPDatePickerDaysCollection.h:44
CXTPDatePickerItemMonth
Class CXTPDatePickerItemMonth represents one month inside the date picker month grid.
Definition XTPDatePickerItemMonth.h:54
CXTPDatePickerList
This class provides the functionality of a list control which displays month names.
Definition XTPDatePickerList.h:46
CXTPDatePickerPaintManager
Class CXTPDatePickerPaintManager handles most of the drawing activities for the DatePicker control.
Definition XTPDatePickerPaintManager.h:55
CXTPFont
Provides a convenient object oriented interface for HFONT GDI object and uses GDI handle caching.
Definition XTPGdiObjects.h:414
CXTPNotifyConnection
This class is used as implementation of Connection interface in a XTPNotification mechanism.
Definition XTPNotifyConnection.h:88
XTP_DAYITEM_METRICS
This structure represents a set of parameters which are used to display day items.
Definition XTPDatePickerControl.h:53
XTP_DAYITEM_METRICS::SetFont
void SetFont(CFont *pFont)
Set a new font for the day item.
XTP_DAYITEM_METRICS::clrForeground
COLORREF clrForeground
A COLORREF object that contains the item's foreground color.
Definition XTPDatePickerControl.h:69
XTP_DAYITEM_METRICS::clrBackground
COLORREF clrBackground
A COLORREF object that contains the item's background color.
Definition XTPDatePickerControl.h:70
XTP_DAYITEM_METRICS::GetFont
CFont * GetFont()
Get day item font.
XTP_NC_DATEPICKER_BUTTON
Structure used to send button notification messages.
Definition XTPDatePickerControl.h:126
XTP_NC_DATEPICKER_BUTTON::hdr
NMHDR hdr
Contains information about a notification message.
Definition XTPDatePickerControl.h:127
XTP_NC_DATEPICKER_BUTTON::nID
int nID
Date picker button ID (could be XTP_IDS_DATEPICKER_TODAY or XTP_IDS_DATEPICKER_NONE)
Definition XTPDatePickerControl.h:128


Toolkit Pro: XTPMarkupUnderline.h Source File

  • Source
  • Markup
  • Text
XTPMarkupUnderline.h
Go to the documentation of this file.
1
23#if !defined(__XTPMARKUPUNDERLINE_H__)
24# define __XTPMARKUPUNDERLINE_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class _XTP_EXT_CLASS CXTPMarkupUnderline : public CXTPMarkupSpan
34{
36 DECLARE_MARKUPCLASS(CXTPMarkupUnderline)
38protected:
39 CXTPMarkupUnderline();
40
42public:
43 DECLARE_DISPATCH_MAP()
44# ifdef _XTP_ACTIVEX
45 DECLARE_INTERFACE_MAP()
46 DECLARE_OLETYPELIB_EX(CXTPMarkupUnderline);
47# endif
48
50};
51
52# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
54#endif // !defined(__XTPMARKUPUNDERLINE_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h


Toolkit Pro: Member List

CXTPPoint3T< T > Member List

This is the complete list of members for CXTPPoint3T< T >, including all inherited members.

CXTPPoint3T() | CXTPPoint3T< T > | inline
CXTPPoint3T(T x, T y, T z=T(0)) | CXTPPoint3T< T > | inline
CXTPPoint3T(const CXTPPoint2i &point) | CXTPPoint3T< T > | inline
CXTPPoint3T(const CXTPPoint2f &point) | CXTPPoint3T< T > | inline
CXTPPoint3T(const CXTPPoint2d &point) | CXTPPoint3T< T > | inline
CXTPPoint3T(const CXTPPoint3i &point) | CXTPPoint3T< T > | inline
CXTPPoint3T(const CXTPPoint3f &point) | CXTPPoint3T< T > | inline
CXTPPoint3T(const CXTPPoint3d &point) | CXTPPoint3T< T > | inline
IsZero() const | CXTPPoint3T< T > | inline
Offset(T dx, T dy, T dz=T(0)) | CXTPPoint3T< T > | inline
operator CXTPPoint2d() const | CXTPPoint3T< T > | inline
operator CXTPPoint2f() const | CXTPPoint3T< T > | inline
operator CXTPPoint2i() const | CXTPPoint3T< T > | inline
operator CXTPPoint3d() const | CXTPPoint3T< T > | inline
operator CXTPPoint3f() const | CXTPPoint3T< T > | inline
operator CXTPPoint3i() const | CXTPPoint3T< T > | inline
operator!=(const CXTPPoint3T &point) const | CXTPPoint3T< T > | inline
operator==(const CXTPPoint3T &point) const | CXTPPoint3T< T > | inline
Round() const | CXTPPoint3T< T > | inline
SetPoint(T x, T y, T z=T(0)) | CXTPPoint3T< T > | inline
X | CXTPPoint3T< T > |
Y | CXTPPoint3T< T > |
Z | CXTPPoint3T< T > |


Toolkit Pro: Member List

CXTPDockingPaneDefaultTheme Member List

This is the complete list of members for CXTPDockingPaneDefaultTheme, including all inherited members.

AdjustCaptionRect(const CXTPDockingPaneSidePanel *pPane, CRect &rc) | CXTPDockingPanePaintManager | virtual
AdjustCaptionRect(const CXTPDockingPaneTabbedContainer *pPane, CRect &rc) | CXTPDockingPanePaintManager | virtual
AdjustClientRect(CXTPDockingPaneSidePanel *pPane, CRect &rect) | CXTPDockingPanePaintManager | virtual
AdjustClientRect(CXTPDockingPaneTabbedContainer *pPane, CRect &rect, BOOL bApply) | CXTPDockingPanePaintManager | virtual
ClipAndAddEllipsisIfNeeded(CDC *pDC, CString &strTitle, int nCaptionWidth) const | CXTPDockingPanePaintManager | protected
CXTPCmdTarget() | CXTPCmdTarget |
CXTPDockingPaneDefaultTheme() | CXTPDockingPaneDefaultTheme |
CXTPDockingPanePaintManager() | CXTPDockingPanePaintManager | protected
DrawAutoHidePanel(CDC *pDC, CRect rc, XTPDockingPaneDirection direction) | CXTPDockingPanePaintManager | virtual
DrawCaption(CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc) | CXTPDockingPaneDefaultTheme | virtual
DrawCaptionButton(CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton) | CXTPDockingPanePaintManager | virtual
DrawCaptionButtonEntry(CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton, CSize szOffset) | CXTPDockingPanePaintManager | protectedvirtual
DrawCaptionButtonEntry(CDC *pDC, CXTPDockingPaneCaptionButton *pButton, CPoint pt, COLORREF clrButton) | CXTPDockingPanePaintManager | protectedvirtual
DrawCaptionButtons(CDC *pDC, CXTPDockingPaneCaptionButtons *pButtons, CRect &rcCaption, COLORREF clr, int nButtonSize, int nButtonGap, BOOL bVertical=FALSE) | CXTPDockingPanePaintManager | virtual
DrawCaptionPart(CDC *pDC, CXTPDockingPaneBase *pPane, CRect rcCaption, const CString &strTitle, BOOL bActive, BOOL bVertical) | CXTPDockingPaneDefaultTheme | protectedvirtual
DrawCaptionText(CDC *pDC, const CString &strTitle, CRect rc, BOOL bVertical, BOOL bCalcWidth=FALSE) | CXTPDockingPanePaintManager |
DrawFloatingFrame(CDC *pDC, CXTPDockingPaneMiniWnd *pPane, CRect rc) | CXTPDockingPaneDefaultTheme | virtual
DrawPane(CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc) | CXTPDockingPanePaintManager | virtual
DrawSidePanel(CDC *pDC, CXTPDockingPaneSidePanel *pPane, CRect rc) | CXTPDockingPaneDefaultTheme | virtual
DrawSplitter(CDC *pDC, CXTPDockingPaneSplitterWnd *pSplitter) | CXTPDockingPanePaintManager | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCaptionButtonStyle() const | CXTPDockingPanePaintManager |
GetCaptionGripperRect(const CXTPDockingPaneTabbedContainer *pPane) | CXTPDockingPanePaintManager | virtual
GetCaptionHeight() const | CXTPDockingPanePaintManager |
GetCaptionRect(const CXTPDockingPaneTabbedContainer *pPane, CRect &rc) | CXTPDockingPanePaintManager | virtual
GetCurrentSystemTheme() const | CXTPDockingPanePaintManager |
GetCustomTitleBrush(BOOL bActive, BOOL bVertical) const | CXTPDockingPanePaintManager |
GetPaneCaptionRect(const CXTPDockingPaneSidePanel *pPane) | CXTPDockingPanePaintManager | virtual
GetPanelPaintManager() const | CXTPDockingPanePaintManager |
GetSplitterStyle() const | CXTPDockingPanePaintManager |
GetTabPaintManager() const | CXTPDockingPanePaintManager |
GetTabsHeight() const | CXTPDockingPanePaintManager |
GetXtremeColor(UINT nIndex) | CXTPDockingPanePaintManager |
Line(CDC *pDC, int x0, int y0, int x1, int y1, int nPen) | CXTPDockingPanePaintManager |
Line(CDC *pDC, int x0, int y0, int x1, int y1) | CXTPDockingPanePaintManager |
m_arrColor | CXTPDockingPanePaintManager | protected
m_bDestroyCustomTitleBrushes | CXTPDockingPanePaintManager | protected
m_bDrawCaptionIcon | CXTPDockingPanePaintManager |
m_bDrawSingleTab | CXTPDockingPanePaintManager |
m_bHighlightActiveCaption | CXTPDockingPanePaintManager |
m_bLunaTheme | CXTPDockingPanePaintManager | protected
m_bShowCaption | CXTPDockingPanePaintManager |
m_bUseBoldCaptionFont | CXTPDockingPanePaintManager |
m_bUseOfficeFont | CXTPDockingPanePaintManager | protected
m_bUseStandardFont | CXTPDockingPanePaintManager | protected
m_clrActiveCaption | CXTPDockingPanePaintManager |
m_clrActiveCaptionText | CXTPDockingPanePaintManager |
m_clrBackground | CXTPDockingPanePaintManager |
m_clrDisabledCaptionText | CXTPDockingPanePaintManager |
m_clrNormalCaption | CXTPDockingPanePaintManager |
m_clrNormalCaptionText | CXTPDockingPanePaintManager |
m_clrSplitter | CXTPDockingPanePaintManager |
m_clrSplitterGradient | CXTPDockingPanePaintManager |
m_clrSplitterGripper | CXTPDockingPanePaintManager |
m_dwSplitterStyle | CXTPDockingPanePaintManager | protected
m_hbrActiveTitleHorz | CXTPDockingPanePaintManager | protected
m_hbrActiveTitleVert | CXTPDockingPanePaintManager | protected
m_hbrInactiveTitleHorz | CXTPDockingPanePaintManager | protected
m_hbrInactiveTitleVert | CXTPDockingPanePaintManager | protected
m_nCaptionButtonStyle | CXTPDockingPanePaintManager | protected
m_nCaptionFontGap | CXTPDockingPanePaintManager | protected
m_nSplitterIndent | CXTPDockingPanePaintManager |
m_nSplitterSize | CXTPDockingPanePaintManager |
m_nTabsHeight | CXTPDockingPanePaintManager | protected
m_nTitleHeight | CXTPDockingPanePaintManager | protected
m_pPanelPaintManager | CXTPDockingPanePaintManager | protected
m_pTabPaintManager | CXTPDockingPanePaintManager | protected
m_rcCaptionMargin | CXTPDockingPanePaintManager | protected
m_strOfficeFont | CXTPDockingPanePaintManager | protected
m_systemTheme | CXTPDockingPanePaintManager | protected
m_themeButton | CXTPDockingPanePaintManager | protected
m_themeCurrent | CXTPDockingPanePaintManager | protected
m_themeExplorer | CXTPDockingPanePaintManager | protected
m_themeRebar | CXTPDockingPanePaintManager | protected
m_themeToolbar | CXTPDockingPanePaintManager | protected
m_themeWindow | CXTPDockingPanePaintManager | protected
m_xtpFontTitle | CXTPDockingPanePaintManager | protected
m_xtpFontTitleVertical | CXTPDockingPanePaintManager | protected
Pixel(CDC *pDC, int xPos, int yPos, int nPen) | CXTPDockingPanePaintManager |
Rectangle(CDC *pDC, CRect rc, int nPenEntry, int nPenBorder) | CXTPDockingPanePaintManager |
RefreshMetrics() | CXTPDockingPaneDefaultTheme | virtual
SetCaptionButtonStyle(XTPDockingPaneCaptionButtonStyle nStyle) | CXTPDockingPanePaintManager |
SetCaptionFontIndirect(LOGFONT *pLogFont, BOOL bUseStandardFont=FALSE) | CXTPDockingPanePaintManager |
SetColors(int cElements, CONST INT *lpaElements, CONST COLORREF *lpaRgbValues) | CXTPDockingPanePaintManager |
SetCustomTitleBrushes(HBRUSH hbrActiveTitleHorz, HBRUSH hbrInactiveTitleHorz=NULL, HBRUSH hbrActiveTitleVert=NULL, HBRUSH hbrInactiveTitleVert=NULL, BOOL bDestroyOnCleanup=FALSE) | CXTPDockingPanePaintManager |
SetLunaTheme(XTPCurrentSystemTheme systemTheme) | CXTPDockingPanePaintManager |
SetPanelPaintManager(CXTPTabPaintManager *pManager) | CXTPDockingPanePaintManager |
SetSplitterStyle(DWORD dwStyle) | CXTPDockingPanePaintManager |
SetTabPaintManager(CXTPTabPaintManager *pManager) | CXTPDockingPanePaintManager |
UseOfficeFont(BOOL bUseOfficeFont) | CXTPDockingPanePaintManager |
~CXTPDockingPanePaintManager() | CXTPDockingPanePaintManager | protectedvirtual


Toolkit Pro: Member List

CXTPEditThemeOffice2000 Member List

This is the complete list of members for CXTPEditThemeOffice2000, including all inherited members.

AdjustBuddyRect(CWnd *pBuddy, CRect &rcUpDown, int nAlignment) | CXTPEditThemeDefault | virtual
CtlColor(CDC *pDC, UINT nCtlColor, CXTPEdit *pEdit) | CXTPEditThemeDefault | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPControlTheme() | CXTPControlTheme |
CXTPEditTheme() | CXTPEditTheme |
CXTPEditThemeDefault() | CXTPEditThemeDefault |
CXTPEditThemeOffice2000() | CXTPEditThemeOffice2000 |
DrawBuddyBorders(CWnd *pBuddy, CDC *pDC, CRect rc, int nAlignment, CXTPEdit *pEdit) | CXTPEditThemeOffice2000 | virtual
DrawBuddyBorders(CDC *pDC, CRect rc, int nAlignment, CXTPEdit *pEdit) | CXTPEditThemeOffice2000 | virtual
DrawFrame(CDC *pDC, CRect rc, int nSize, CBrush *pBrush) | CXTPEditTheme | virtual
DrawNcBorders(CDC *pDC, CRect rcWnd, CXTPEdit *pEdit) | CXTPEditThemeOffice2000 | virtual
DrawNcBordersDefault(CDC *pDC, CRect rcWnd, CXTPEdit *pEdit) | CXTPEditThemeDefault | protectedvirtual
DrawNcScrollBack(CDC *pDC, CRect rcWnd, CXTPEdit *pEdit) | CXTPEditThemeDefault | virtual
FillRect(CDC *pDC, int x, int y, int cx, int cy, CBrush *pBrush) | CXTPEditTheme | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetClientBrush(CDC *pDC, CXTPEdit *pEdit) | CXTPEditTheme | virtual
GetThemeID() const | CXTPEditTheme |
GetThemeStyle() const | CXTPControlTheme |
IsFlatStyle() const | CXTPEditTheme |
m_bFlatStyle | CXTPEditTheme | protected
m_bUseWinTheme | CXTPEditTheme | protected
m_clrBack | CXTPEditTheme |
m_clrBackNonClient | CXTPEditTheme |
m_clrBorder | CXTPEditTheme |
m_clrText | CXTPEditTheme |
m_clrTextReadOnly | CXTPEditTheme |
m_nTheme | CXTPEditTheme | protected
m_winTheme | CXTPEditTheme | protected
m_xtpBrushBack | CXTPEditTheme |
RedrawFocusedFrame() const | CXTPEditThemeOffice2000 | virtual
RefreshMetrics(CXTPEdit *pEdit) | CXTPEditThemeOffice2000 | virtual
SetFlatStyle(BOOL bFlatStyle) | CXTPEditTheme |
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static
UseWinTheme(BOOL bUseWinTheme) | CXTPEditTheme |
~CXTPEditTheme() | CXTPEditTheme | virtual
~CXTPEditThemeDefault() | CXTPEditThemeDefault | virtual
~CXTPEditThemeOffice2000() | CXTPEditThemeOffice2000 | virtual


Toolkit Pro: XTPWebBrowserControlSite.h Source File

  • Source
  • Controls
  • WebBrowser
  • Providers
XTPWebBrowserControlSite.h
Go to the documentation of this file.
1
22#if !defined(__XTPWEBBROWSERCONTROLSITE_H__)
23
25# define __XTPWEBBROWSERCONTROLSITE_H__
26
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableAdvancedWarnings.h"
32
33# pragma warning(push)
34// C4464: relative include path contains '..'
35# pragma warning(disable : 4464)
36
37# pragma push_macro("AFX_DATA")
38# undef AFX_DATA
39# define AFX_DATA AFX_DATA_IMPORT
40# if (_MSC_VER >= 1300)
41# include <..\src\mfc\occimpl.h>
42# else
43# include <..\src\occimpl.h>
44# endif
45# pragma pop_macro("AFX_DATA")
46
47# pragma warning(pop)
48
49# include "Common/Base/Diagnostic/XTPEnableAdvancedWarnings.h"
50
51# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
52
53class CXTPWebBrowserProvider;
54class CXTPWebBrowserAggregate;
55
56class CXTPWebBrowserControlSite : public COleControlSite
57{
58 CXTPWebBrowserProvider* m_pProvider;
59 CXTPWebBrowserAggregate* m_pAggregate;
60
61public:
62 CXTPWebBrowserControlSite(COleControlContainer* pCtrlCont, CXTPWebBrowserProvider* pProvider);
63 virtual ~CXTPWebBrowserControlSite();
64
65 virtual BOOL OnCreateAggregates();
66
67 DECLARE_INTERFACE_MAP()
68};
69
70# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
71
72#endif
73
XTPDisableAdvancedWarnings.h
XTPDisableNoisyWarnings.h
XTPEnableAdvancedWarnings.h
XTPEnableNoisyWarnings.h
CXTPWebBrowserProvider
Implements the base class for a WebBrowser provider.
Definition XTPWebBrowserProvider.h:56


Toolkit Pro: Member List

CXTPPropertyPage Member List

This is the complete list of members for CXTPPropertyPage, including all inherited members.

AdjustResizeRect(CSize &rcWindow) | CXTPResize | protectedvirtual
AutoLoadPlacement(LPCTSTR pszSection) | CXTPResize |
CResizeItemArray typedef | CXTPResize | protected
CXTPPropertyPage() | CXTPPropertyPage |
CXTPPropertyPage(UINT nIDTemplate, UINT nIDCaption=0) | CXTPPropertyPage |
CXTPPropertyPage(LPCTSTR lpszTemplateName, UINT nIDCaption=0) | CXTPPropertyPage |
CXTPResize(CWnd *pWnd, const UINT nFlags=0) | CXTPResize |
Defer(HDWP &hdwp, CXTPResizeItem *pItem, int dx, int dy) | CXTPResize | protectedvirtual
GetCaption() const | CXTPPropertyPage |
GetMinMaxInfo(MINMAXINFO *pMMI) | CXTPResize | protected
HasFlag(XTPResize eFlag) | CXTPResize | protected
Init() | CXTPResize | protectedvirtual
LoadPlacement(LPCTSTR pszSection) | CXTPResize |
m_arrItems | CXTPResize | protected
m_bModified | CXTPPropertyPage | protected
m_dwData | CXTPPropertyPage |
m_nFlagsXX | CXTPResize | protected
m_pSheet | CXTPPropertyPage | protected
m_pWnd | CXTPResize | protected
m_scSizeIcon | CXTPResize | protected
m_strSection | CXTPResize | protected
m_szInitWindow | CXTPResize | protected
m_szMax | CXTPResize | protected
m_szMin | CXTPResize | protected
m_szWindow | CXTPResize | protected
Offset(CPoint ptOffset) | CXTPResize | protected
RemoveAllControls() | CXTPResize | protected
RemoveResize(UINT nID) | CXTPResize | protected
Reset() | CXTPResize | protected
SavePlacement(LPCTSTR pszSection) | CXTPResize |
SetCaption(LPCTSTR lpszCaption) | CXTPPropertyPage |
SetFlag(XTPResize eFlag) | CXTPResize | protected
SetMaxSize(CSize &sz) | CXTPResize |
SetMinSize(CSize &sz) | CXTPResize |
SetResize(UINT nID, XTP_RESIZE left, XTP_RESIZE top, XTP_RESIZE right, XTP_RESIZE bottom) | CXTPResize |
SetResize(UINT nID, const XTP_RESIZERECT &rrcSizing) | CXTPResize |
SetResize(UINT nID, HWND hWnd, const XTP_RESIZERECT &rrcSizing) | CXTPResize |
SetResize(UINT nID, HWND hWnd, const XTP_RESIZEPOINT &rpTopLeft, const XTP_RESIZEPOINT &rpBottomRight) | CXTPResize |
SetResize(UINT nID, const XTP_RESIZEPOINT &rpTopLeft, const XTP_RESIZEPOINT &rpBottomRight) | CXTPResize |
SetResize(CWnd *pWnd, const CXTPResizeRect &rrcSizing, CRect rcWindow) | CXTPResize | protected
Size() | CXTPResize | protectedvirtual
UpdateControlRect(CWnd *pWnd) | CXTPResize | protected
UpdatePage(void) | CXTPPropertyPage | virtual
~CXTPPropertyPage() | CXTPPropertyPage |
~CXTPResize() | CXTPResize | virtual


Toolkit Pro: XTPBrowseEdit.h Source File

  • Source
  • Controls
  • Edit
XTPBrowseEdit.h
Go to the documentation of this file.
1
23#if !defined(__XTPBROWSEEDIT_H__)
24# define __XTPBROWSEEDIT_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPBrowseEdit;
34
35# define XTP_IDC_LBOX_EDIT 101
36
43class _XTP_EXT_CLASS CXTPBrowseButton : public CXTPButton
44{
46 DECLARE_DYNAMIC(CXTPBrowseButton)
48public:
53 CXTPBrowseButton();
54
59 virtual ~CXTPBrowseButton();
60
61public:
74 virtual BOOL Create(CXTPBrowseEdit* pEditWnd, DWORD dwBStyle, UINT nID, UINT nMenu = (UINT)-1,
75 UINT nSubMenuIndx = (UINT)-1);
76
91 void SetBrowseStyle(DWORD dwxStyle);
92
93protected:
95 DECLARE_MESSAGE_MAP()
96
97 //{{AFX_VIRTUAL(CXTPItemEdit)
98 virtual BOOL PreTranslateMessage(MSG* pMsg);
99 virtual void OnClicked();
100 //}}AFX_VIRTUAL
101
102 //{{AFX_MSG(CXTPBrowseButton)
103 afx_msg void OnEnable(BOOL bEnable);
104 afx_msg void OnBtnClicked();
105 //}}AFX_MSG
108private:
109 BOOL Create(LPCTSTR lpszClassName, LPCTSTR lpszWindowName, DWORD dwStyle, const RECT& rect,
110 CWnd* pParentWnd, UINT nID, CCreateContext* pContext = NULL);
111 BOOL Create(LPCTSTR lpszCaption, DWORD dwStyle, const RECT& rect, CWnd* pParentWnd, UINT nID);
112
113protected:
114 DWORD m_dwBStyle;
115 UINT m_nID;
116 UINT m_nMenu;
117 UINT m_nSubMenuIndx;
118 CXTPBrowseEdit* m_pEditWnd;
120 friend class CXTPBrowseEdit;
121};
122
129class _XTP_EXT_CLASS CXTPBrowseEdit : public CXTPEdit
130{
132 DECLARE_DYNAMIC(CXTPBrowseEdit)
134public:
139 CXTPBrowseEdit();
140
145 virtual ~CXTPBrowseEdit();
146
147public:
155 bool IsBrowsing();
156
163 void SetGap(int nGap);
164
172 virtual void SetFileDialog(CFileDialog* pFileDialog);
173
180 virtual void SetDlgOpenFile(BOOL bOpenFileDialog = TRUE);
181
188 void SetDlgDefExt(LPCTSTR lpszDefExt = NULL);
189
196 void SetDlgFileName(LPCTSTR lpszFileName = NULL);
197
203 virtual void SetDlgStyle(DWORD dwFlags = OFN_HIDEREADONLY | OFN_OVERWRITEPROMPT);
204
211 void SetDlgFilter(LPCTSTR lpszFilter = NULL);
212
219 void SetDlgTitle(LPCTSTR lpszTitle = NULL);
220
227 void SetDlgInitialDir(LPCTSTR lpszInitialDir);
228
273 virtual bool Initialize(CWnd* pParentWnd, DWORD dwBStyle, UINT nMenu = 0, int nSubMenuIndx = 0);
274
312 virtual bool Initialize(CWnd* pParentWnd);
313
319 virtual void OnBrowse();
320
326 virtual void ChooseDirectory();
327
333 virtual void ChooseFile();
334
341 virtual void PopupMenu();
342
348 virtual void PositionBrowseButton();
349
356 CXTPBrowseButton* GetBrowseButton();
357
358protected:
360 //{{AFX_MSG(CXTPBrowseEdit)
361 afx_msg void OnEnable(BOOL bEnable);
362 afx_msg void OnShowWindow(BOOL bShow, UINT nStatus);
363 afx_msg void OnWindowPosChanged(WINDOWPOS FAR* lpwndpos);
364 //}}AFX_MSG
365 DECLARE_MESSAGE_MAP()
368public:
369 static int m_nDefaultGap;
371protected:
372 int m_nGap;
373 bool m_bBrowsing;
374 BOOL m_bOpenFileDialog;
376 UINT m_nMenu;
377 UINT m_nSubMenuIndx;
378 DWORD m_dwFlags;
379 DWORD m_dwBStyle;
380 CString m_strDefExt;
381 CString m_strFileName;
382 CString m_strFilter;
383 CString m_strInitialDir;
384 CString m_strTitle;
385 CFileDialog* m_pFileDialog;
386 CXTPBrowseButton m_btnBrowse;
387};
390AFX_INLINE bool CXTPBrowseEdit::Initialize(CWnd* pParentWnd)
391{
392 return CXTPEdit::Initialize(pParentWnd);
393}
394AFX_INLINE void CXTPBrowseEdit::SetGap(int nGap)
395{
396 _ASSERTE(nGap >= 0);
397 m_nGap = nGap;
398}
399AFX_INLINE void CXTPBrowseEdit::SetFileDialog(CFileDialog* pFileDialog /*=NULL*/)
400{
401 m_pFileDialog = pFileDialog;
402}
403AFX_INLINE void CXTPBrowseEdit::SetDlgOpenFile(BOOL bOpenFileDialog /*=TRUE*/)
404{
405 m_bOpenFileDialog = bOpenFileDialog;
406}
407AFX_INLINE void CXTPBrowseEdit::SetDlgDefExt(LPCTSTR strDefExt /*=NULL*/)
408{
409 m_strDefExt = strDefExt;
410}
411AFX_INLINE void CXTPBrowseEdit::SetDlgFileName(LPCTSTR strFileName /*=NULL*/)
412{
413 m_strFileName = strFileName;
414}
415AFX_INLINE void
416 CXTPBrowseEdit::SetDlgStyle(DWORD dwFlags /*=OFN_HIDEREADONLY | OFN_OVERWRITEPROMPT*/)
417{
418 m_dwFlags = dwFlags;
419}
420AFX_INLINE void CXTPBrowseEdit::SetDlgFilter(LPCTSTR strFilter /*=NULL*/)
421{
422 m_strFilter = strFilter;
423}
424AFX_INLINE void CXTPBrowseEdit::SetDlgTitle(LPCTSTR strTitle /*=NULL*/)
425{
426 m_strTitle = strTitle;
427}
428AFX_INLINE bool CXTPBrowseEdit::IsBrowsing()
429{
430 return m_bBrowsing;
431}
432AFX_INLINE void CXTPBrowseEdit::SetDlgInitialDir(LPCTSTR lpszInitialDir)
433{
434 m_strInitialDir = lpszInitialDir;
435}
437const DWORD BES_XTP_CHOOSEDIR = 0x0001;
439const DWORD BES_XTP_CHOOSEFILE = 0x0002;
441const DWORD BES_XTP_POPUPMENU = 0x0004;
443const DWORD BES_XTP_BROWSE = 0x0010;
453class _XTP_EXT_CLASS CXTPItemEdit : public CXTPBrowseEdit
454{
456 DECLARE_DYNAMIC(CXTPItemEdit)
458public:
464 CXTPItemEdit();
465
479 BOOL Create(CWnd* pParent, const CRect& rect, CString& strWindowText,
480 DWORD dwBStyle = BES_XTP_CHOOSEDIR, bool bAutoDelete = true);
481
482# if _MSC_VER > 1200
483 using CWnd::Create;
484# endif
485
490 virtual ~CXTPItemEdit();
491
492public:
500 virtual void EndLabelEdit();
501
502protected:
504 //{{AFX_VIRTUAL(CXTPItemEdit)
505public:
506 virtual BOOL PreTranslateMessage(MSG* pMsg);
507
508protected:
509 virtual void PostNcDestroy();
510 //}}AFX_VIRTUAL
511
512 //{{AFX_MSG(CXTPItemEdit)
513 afx_msg void OnKillFocus(CWnd* pNewWnd);
514 afx_msg void OnChar(UINT nChar, UINT nRepCnt, UINT nFlags);
515 //}}AFX_MSG
516 DECLARE_MESSAGE_MAP()
519public:
520 bool m_bModified;
521 bool m_bAutoDelete;
522 bool m_bEscapeKey;
523 CString m_strWindowText;
525protected:
526 bool m_bClosePosted;
527};
528
530
531AFX_INLINE BOOL CXTPBrowseButton::Create(LPCTSTR lpszClassName, LPCTSTR lpszWindowName,
532 DWORD dwStyle, const RECT& rect, CWnd* pParentWnd,
533 UINT nID, CCreateContext* pContext)
534{
535 return CWnd::Create(lpszClassName, lpszWindowName, dwStyle, rect, pParentWnd, nID, pContext);
536}
537AFX_INLINE BOOL CXTPBrowseButton::Create(LPCTSTR lpszCaption, DWORD dwStyle, const RECT& rect,
538 CWnd* pParentWnd, UINT nID)
539{
540 return CButton::Create(lpszCaption, dwStyle, rect, pParentWnd, nID);
541}
542AFX_INLINE CXTPBrowseButton* CXTPBrowseEdit::GetBrowseButton()
543{
544 return &m_btnBrowse;
545}
547# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
549#endif // #if !defined(__XTPBROWSEEDIT_H__)
BES_XTP_POPUPMENU
const DWORD BES_XTP_POPUPMENU
Display a popup menu for the dialog.
Definition XTPBrowseEdit.h:441
BES_XTP_CHOOSEDIR
const DWORD BES_XTP_CHOOSEDIR
Display a choose directory dialog.
Definition XTPBrowseEdit.h:437
BES_XTP_CHOOSEFILE
const DWORD BES_XTP_CHOOSEFILE
Display a choose file dialog.
Definition XTPBrowseEdit.h:439
BES_XTP_BROWSE
const DWORD BES_XTP_BROWSE
Display a user-defined dialog for browsing.
Definition XTPBrowseEdit.h:443
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPBrowseButton
CXTPBrowseButton is a CXTPButton derived class.
Definition XTPBrowseEdit.h:44
CXTPBrowseButton::Create
virtual BOOL Create(CXTPBrowseEdit *pEditWnd, DWORD dwBStyle, UINT nID, UINT nMenu=(UINT) -1, UINT nSubMenuIndx=(UINT) -1)
This member function is called to create the browse button used by the edit control.
CXTPBrowseButton::CXTPBrowseButton
CXTPBrowseButton()
Constructs a CXTPBrowseButton object.
CXTPBrowseButton::SetBrowseStyle
void SetBrowseStyle(DWORD dwxStyle)
This member function will set the browse style for the button.
CXTPBrowseButton::~CXTPBrowseButton
virtual ~CXTPBrowseButton()
Destroys a CXTPBrowseButton object, handles cleanup and deallocation.
CXTPBrowseEdit
CXTPBrowseEdit is a CXTPEdit derived class.
Definition XTPBrowseEdit.h:130
CXTPBrowseEdit::SetDlgOpenFile
virtual void SetDlgOpenFile(BOOL bOpenFileDialog=TRUE)
This member function will set the File Open dialog style.
CXTPBrowseEdit::OnBrowse
virtual void OnBrowse()
This member function is called whenever the browse button is pressed and can be overridden to perform...
CXTPBrowseEdit::PositionBrowseButton
virtual void PositionBrowseButton()
This member function is called by the browse edit control to position the browse button in relation t...
CXTPBrowseEdit::~CXTPBrowseEdit
virtual ~CXTPBrowseEdit()
Destroys a CXTPBrowseEdit object, handles cleanup and deallocation.
CXTPBrowseEdit::SetGap
void SetGap(int nGap)
Call this member function to set the gap between the browse button and the edit window.
CXTPBrowseEdit::IsBrowsing
bool IsBrowsing()
Call this member function to determine if the browse edit control is in the middle of a browse operat...
CXTPBrowseEdit::SetDlgInitialDir
void SetDlgInitialDir(LPCTSTR lpszInitialDir)
This member function sets the initial directory for the directory dialog.
CXTPBrowseEdit::Initialize
virtual bool Initialize(CWnd *pParentWnd)
This member function is called to initialize the browse edit control.
CXTPBrowseEdit::SetDlgDefExt
void SetDlgDefExt(LPCTSTR lpszDefExt=NULL)
This member function sets the default extension for the File Open dialog.
CXTPBrowseEdit::ChooseFile
virtual void ChooseFile()
This member function is called by the browse edit control to display a File Open dialog.
CXTPBrowseEdit::CXTPBrowseEdit
CXTPBrowseEdit()
Constructs a CXTPBrowseEdit object.
CXTPBrowseEdit::SetDlgTitle
void SetDlgTitle(LPCTSTR lpszTitle=NULL)
This member function sets the title for the directory dialog.
CXTPBrowseEdit::PopupMenu
virtual void PopupMenu()
This member function is called by the browse edit control to create and track a pop-up menu.
CXTPBrowseEdit::ChooseDirectory
virtual void ChooseDirectory()
This member function is called by the browse edit control to display a directory chooser dialog.
CXTPBrowseEdit::GetBrowseButton
CXTPBrowseButton * GetBrowseButton()
Call this member function to get a reference to the browse button.
CXTPBrowseEdit::SetDlgStyle
virtual void SetDlgStyle(DWORD dwFlags=OFN_HIDEREADONLY|OFN_OVERWRITEPROMPT)
This member function sets the style flags for the File Open dialog.
CXTPBrowseEdit::SetFileDialog
virtual void SetFileDialog(CFileDialog *pFileDialog)
This member function will set a CFileDialog derived class object to be the file open dialog.
CXTPBrowseEdit::Initialize
virtual bool Initialize(CWnd *pParentWnd, DWORD dwBStyle, UINT nMenu=0, int nSubMenuIndx=0)
This member function is called to initialize the browse edit control.
CXTPBrowseEdit::SetDlgFilter
void SetDlgFilter(LPCTSTR lpszFilter=NULL)
This member function sets the file filter for the File Open dialog.
CXTPBrowseEdit::SetDlgFileName
void SetDlgFileName(LPCTSTR lpszFileName=NULL)
This member function sets the default file name for the File Open dialog.
CXTPButton
Push Button control.
Definition XTPButton.h:109
CXTPEdit
CXTPEdit is a CEdit derived class.
Definition XTPEdit.h:129
CXTPItemEdit
CXTPItemEdit is a CXTPBrowseEdit derived class.
Definition XTPBrowseEdit.h:454
CXTPItemEdit::~CXTPItemEdit
virtual ~CXTPItemEdit()
Destroys a CXTPItemEdit object, handles cleanup and deallocation.
CXTPItemEdit::Create
BOOL Create(CWnd *pParent, const CRect &rect, CString &strWindowText, DWORD dwBStyle=BES_XTP_CHOOSEDIR, bool bAutoDelete=true)
Constructs a CXTPItemEdit object that can be used as an "in-place" edit field and can be dynamically ...
CXTPItemEdit::CXTPItemEdit
CXTPItemEdit()
Constructs a CXTPItemEdit object that can be used as an "in-place" edit field and can be dynamically ...
CXTPItemEdit::EndLabelEdit
virtual void EndLabelEdit()
This member function is called whenever the control loses focus.


Toolkit Pro: Member List

CXTPSplitterWndThemeOffice2003 Member List

This is the complete list of members for CXTPSplitterWndThemeOffice2003, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPControlTheme() | CXTPControlTheme |
CXTPSplitterWndTheme() | CXTPSplitterWndTheme |
CXTPSplitterWndThemeOffice2003() | CXTPSplitterWndThemeOffice2003 |
CXTPSplitterWndThemeOfficeXP() | CXTPSplitterWndThemeOfficeXP |
DrawSplitter(CDC *pDC, CXTPSplitterWnd *pSplitter, int nType, const CRect &rectArg) | CXTPSplitterWndThemeOffice2003 | virtual
EnableTabColors(BOOL bEnable=TRUE) | CXTPSplitterWndTheme |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetThemeStyle() const | CXTPControlTheme |
GetTrackBrush() | CXTPSplitterWndThemeOfficeXP | virtual
m_bTabColors | CXTPSplitterWndTheme |
m_crBack | CXTPSplitterWndTheme |
m_crBoxBack | CXTPSplitterWndTheme |
m_crInnerBorder | CXTPSplitterWndTheme |
m_crInnerBoxBorder | CXTPSplitterWndTheme |
m_crOuterBorder | CXTPSplitterWndTheme |
m_crOuterBoxBorder | CXTPSplitterWndTheme |
m_nTheme | CXTPControlTheme | protected
RefreshMetrics() | CXTPSplitterWndThemeOffice2003 | virtual
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static


Toolkit Pro: Member List

CXTPSynchronized Member List

This is the complete list of members for CXTPSynchronized, including all inherited members.

GetAccessCriticalSection() const CXTPSynchronized inline


Toolkit Pro: Member List

CXTPShortcutBarNativeWindows10Theme Member List

This is the complete list of members for CXTPShortcutBarNativeWindows10Theme, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPShortcutBarNativeWindows10Theme() | CXTPShortcutBarNativeWindows10Theme |
CXTPShortcutBarOffice2003Theme() | CXTPShortcutBarOffice2003Theme |
CXTPShortcutBarOffice2013Theme() | CXTPShortcutBarOffice2013Theme |
CXTPShortcutBarPaintManager() | CXTPShortcutBarPaintManager |
CXTPShortcutBarResourceTheme() | CXTPShortcutBarResourceTheme |
DrawExpandButton(CDC *pDC, CRect rc) | CXTPShortcutBarOffice2013Theme | virtual
DrawGripper(CDC *pDC, CXTPShortcutBar *pShortcutBar, BOOL bDraw) | CXTPShortcutBarOffice2013Theme | virtual
DrawImage(CDC *pDC, CPoint pt, CSize sz, CXTPImageManagerIcon *pImage, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled) | CXTPShortcutBarOffice2003Theme | virtual
DrawNavigationItem(CDC *pDC, CXTPShortcutBarItem *pItem) | CXTPShortcutBarPaintManager | virtual
DrawPaneCaption(CDC *pDC, CXTPShortcutBarPane *pPane, BOOL bDraw) | CXTPShortcutBarResourceTheme | virtual
DrawPaneItemCaption(CDC *pDC, CXTPShortcutBarPaneItem *pItem, BOOL bDraw) | CXTPShortcutBarNativeWindows10Theme | virtual
DrawShortcutBarFrame(CDC *pDC, CXTPShortcutBar *pShortcutBar) | CXTPShortcutBarOffice2003Theme | virtual
DrawShortcutItem(CDC *pDC, CXTPShortcutBarItem *pItem) | CXTPShortcutBarPaintManager | virtual
FillNavigationItemEntry(CDC *pDC, CXTPShortcutBarItem *pItem) | CXTPShortcutBarNativeWindows10Theme | virtual
FillShortcutBar(CDC *pDC, CXTPShortcutBar *pShortcutBar) | CXTPShortcutBarOffice2013Theme | virtual
FillShortcutItemEntry(CDC *pDC, CXTPShortcutBarItem *pItem) | CXTPShortcutBarNativeWindows10Theme | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
IsShortcutItemTruncated(CDC *pDC, CXTPShortcutBarItem *pItem) | CXTPShortcutBarPaintManager |
Line(CDC *pDC, int x0, int y0, int x1, int y1, int nPen) | CXTPShortcutBarPaintManager |
m_bBoldItemCaptionFont | CXTPShortcutBarPaintManager |
m_bClearTypeTextQuality | CXTPShortcutBarPaintManager |
m_bHiliteBorders | CXTPShortcutBarNativeWindows10Theme | protected
m_bNavigationButton | CXTPShortcutBarPaintManager |
m_bShowTopLeftCaptionShadow | CXTPShortcutBarOffice2003Theme |
m_bUseStandardFont | CXTPShortcutBarPaintManager |
m_clrBackHiliteSelected | CXTPShortcutBarNativeWindows10Theme | protected
m_clrBorderHilite | CXTPShortcutBarNativeWindows10Theme | protected
m_clrCaptionText | CXTPShortcutBarOffice2003Theme |
m_clrDisabledText | CXTPShortcutBarPaintManager |
m_clrGlyph | CXTPShortcutBarOffice2013Theme | protected
m_clrGlyphExpanded | CXTPShortcutBarOffice2013Theme | protected
m_clrGlyphFill | CXTPShortcutBarOffice2013Theme | protected
m_clrGlyphPushed | CXTPShortcutBarOffice2013Theme | protected
m_clrHotText | CXTPShortcutBarPaintManager |
m_clrItemCaptionShadow | CXTPShortcutBarOffice2003Theme |
m_clrItemCaptionText | CXTPShortcutBarOffice2003Theme |
m_clrItemCaptionTop | CXTPShortcutBarOffice2003Theme |
m_clrNormalText | CXTPShortcutBarPaintManager |
m_clrPushedText | CXTPShortcutBarPaintManager |
m_clrSelectedText | CXTPShortcutBarPaintManager |
m_clrShortcutItemShadow | CXTPShortcutBarPaintManager |
m_grcCaption | CXTPShortcutBarOffice2003Theme |
m_grcHot | CXTPShortcutBarPaintManager |
m_grcItemCaption | CXTPShortcutBarOffice2003Theme |
m_grcItemHotCaption | CXTPShortcutBarOffice2003Theme |
m_grcPushed | CXTPShortcutBarPaintManager |
m_grcSelected | CXTPShortcutBarPaintManager |
m_grcShortcutBarGripper | CXTPShortcutBarPaintManager |
m_grcShortcutItem | CXTPShortcutBarPaintManager |
m_nExpandedIconWidth | CXTPShortcutBarPaintManager |
m_nNormalIconWidth | CXTPShortcutBarPaintManager |
m_nPaneItemHeight | CXTPShortcutBarPaintManager |
m_pExpandIcon | CXTPShortcutBarPaintManager |
m_rcCaptionPadding | CXTPShortcutBarPaintManager |
m_rcItemCaptionPadding | CXTPShortcutBarPaintManager |
m_strOfficeFont | CXTPShortcutBarPaintManager |
m_xtpFontPaneCaption | CXTPShortcutBarPaintManager |
m_xtpFontPaneItemCaption | CXTPShortcutBarPaintManager |
m_xtpFontText | CXTPShortcutBarPaintManager |
m_xtpFontVerticalText | CXTPShortcutBarPaintManager |
Rectangle(CDC *pDC, CRect rc, int nPen, int nBrush) | CXTPShortcutBarPaintManager |
RefreshMetrics() | CXTPShortcutBarNativeWindows10Theme | virtual
~CXTPShortcutBarNativeWindows10Theme() | CXTPShortcutBarNativeWindows10Theme | virtual
~CXTPShortcutBarOffice2013Theme() | CXTPShortcutBarOffice2013Theme | virtual
~CXTPShortcutBarPaintManager() | CXTPShortcutBarPaintManager | virtual


Toolkit Pro: XTPDockingPanePanelTheme2022.h Source File

  • Source
  • DockingPane
  • TabThemes
XTPDockingPanePanelTheme2022.h
Go to the documentation of this file.
1
23#if !defined(__XTPDOCKINGPANEPANELTHEME2022_H__)
24# define __XTPDOCKINGPANEPANELTHEME2022_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPDockingPanePanelTheme2022 : public CXTPDockingPanePanelTheme2012
39{
40public:
45 CXTPDockingPanePanelTheme2022();
46};
47
48# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
50#endif // !defined(__XTPDOCKINGPANEPANELTHEME2022_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPDockingPanePanelTheme2012
Helper class used to initialize default colors for a theme from an .INI resource and handle drawing r...
Definition XTPDockingPanePanelTheme2012.h:39
CXTPDockingPanePanelTheme2022
Helper class used to initialize default colors for a theme from an .INI resource and handle drawing r...
Definition XTPDockingPanePanelTheme2022.h:39
CXTPDockingPanePanelTheme2022::CXTPDockingPanePanelTheme2022
CXTPDockingPanePanelTheme2022()
Default class constructor.


Toolkit Pro: Member List

CXTPControlGalleryNativeWindows10Theme Member List

This is the complete list of members for CXTPControlGalleryNativeWindows10Theme, including all inherited members.

CXTPControlGalleryNativeWindows10Theme(CXTPPaintManager *pPaintManager) | CXTPControlGalleryNativeWindows10Theme |
CXTPControlGalleryOffice2013Theme(CXTPPaintManager *pPaintManager) | CXTPControlGalleryOffice2013Theme |
CXTPControlGalleryPaintManager(CXTPPaintManager *pPaintManager) | CXTPControlGalleryPaintManager |
DrawLabel(CDC *pDC, CXTPControlGalleryItem *pLabel, CRect rc) | CXTPControlGalleryPaintManager | virtual
DrawPopupScrollBar(CDC *pDC, CXTPControlGallery *pGallery) | CXTPControlGalleryOffice2013Theme | virtual
FillControl(CDC *pDC, CXTPControlGallery *pGallery, CRect rc) | CXTPControlGalleryOffice2013Theme | protectedvirtual
m_cxPopup | CXTPControlGalleryPaintManager |
m_cyPopupDown | CXTPControlGalleryPaintManager |
m_cyPopupUp | CXTPControlGalleryPaintManager |
RefreshMetrics() | CXTPControlGalleryOffice2013Theme | virtual


Toolkit Pro: XTPMiniToolBar.h Source File

  • Source
  • CommandBars
XTPMiniToolBar.h
Go to the documentation of this file.
1
23#if !defined(__XTPMINITOOLBAR_H__)
24# define __XTPMINITOOLBAR_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
34// CXTPMiniToolBar window
35
49class _XTP_EXT_CLASS CXTPMiniToolBar : public CXTPPopupToolBar
50{
51 DECLARE_XTP_COMMANDBAR(CXTPMiniToolBar);
52
53public:
61 static CXTPMiniToolBar* AFX_CDECL CreateMiniToolBar(CXTPCommandBars* pCommandBars);
62
63protected:
68 CXTPMiniToolBar();
69
75 virtual ~CXTPMiniToolBar();
76
77public:
89 virtual BOOL TrackMiniBar(UINT nFlags, int xPos, int yPos);
90
103 virtual BOOL TrackPopupMenu(CXTPPopupBar* pPopupMenu, UINT nFlags, int xPos, int yPos);
104
113 virtual BOOL OnHookKeyDown(UINT nChar, LPARAM lParam);
114
123 void SetCustomControlKeyboardInteraction(BOOL bInteract = TRUE);
124
125 BOOL IsCustomControlKeyboardInteraction() const;
126
127protected:
132 virtual void PumpMessage();
133
138 virtual void UpdateOpacity();
139
146 BOOL CursorInWindow() const;
147
149 DECLARE_MESSAGE_MAP()
150
151 //{{AFX_VIRTUAL(CXTPMiniToolBar)
152
153 virtual void Animate();
154 virtual BOOL SetTrackingMode(int bMode, BOOL bSelectFirst = TRUE, BOOL bKeyboard = FALSE);
155 virtual INT_PTR OnToolHitTest(CPoint point, TOOLINFO* pTI) const;
156 virtual int OnHookMessage(HWND hWnd, UINT nMessage, WPARAM& wParam, LPARAM& lParam,
157 LRESULT& lResult);
158
159 //}}AFX_VIRTUAL
160
161 //{{AFX_MSG(CXTPMiniToolBar)
162 //}}AFX_MSG
163
166# ifdef _XTP_COMMANDBARS_ACTIVEX
168 DECLARE_DISPATCH_MAP()
169 DECLARE_OLETYPELIB_EX(CXTPMiniToolBar);
170 DECLARE_INTERFACE_MAP()
171
172 long OlePopupMiniToolBar(const VARIANT& varFlags, const VARIANT& x, const VARIANT& y);
173 long OlePopupContextMenu(LPDISPATCH lpDispatch, const VARIANT& varFlags, const VARIANT& x,
174 const VARIANT& y);
175
177# endif
178
179protected:
191 typedef BOOL(WINAPI* LPFNUPDATELAYEREDWINDOW)(HWND hwnd, HDC hdcDst, POINT* pptDst, SIZE* psize,
192 HDC hdcSrc, POINT* pptSrc, COLORREF crKey,
193 BLENDFUNCTION* pblend, DWORD dwFlags);
194
206 typedef BOOL(WINAPI* PFNSETLAYEREDWINDOWATTRIBUTES)(HWND hwnd, COLORREF crKey, BYTE bAlpha,
207 DWORD dwFlags);
208
209 PFNSETLAYEREDWINDOWATTRIBUTES m_pfnSetLayeredWindowAttributes;
211 LPFNUPDATELAYEREDWINDOW m_pfnUpdateLayeredWindow;
214 BOOL m_bActivated;
215 int m_nOpacity;
216 BOOL m_bTracking;
217 CXTPPopupBar* m_pContextMenu;
219 BOOL m_bCustomControlKeyboardInteraction;
220};
221
223# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
224#endif // !defined(__XTPMINITOOLBAR_H__)
DECLARE_XTP_COMMANDBAR
#define DECLARE_XTP_COMMANDBAR(class_name)
This macro generates the C++ header code necessary for a CXTPCommandBar-derived class that can be ser...
Definition XTPCommandBarsDefines.h:1234
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCommandBars
CXTPCommandBars is a standalone class.
Definition XTPCommandBars.h:165
CXTPMiniToolBar
Represents a MiniToolbar object.
Definition XTPMiniToolBar.h:50
CXTPMiniToolBar::~CXTPMiniToolBar
virtual ~CXTPMiniToolBar()
Destroys a CXTPMiniToolBar object, handles cleanup and deallocation.
CXTPMiniToolBar::SetCustomControlKeyboardInteraction
void SetCustomControlKeyboardInteraction(BOOL bInteract=TRUE)
Call this method to enable/disable keyboard interaction with custom controls.
CXTPMiniToolBar::PumpMessage
virtual void PumpMessage()
Translates all messages in the message queue.
CXTPMiniToolBar::TrackPopupMenu
virtual BOOL TrackPopupMenu(CXTPPopupBar *pPopupMenu, UINT nFlags, int xPos, int yPos)
Call this member to display a floating pop-up menu at the specified location.
CXTPMiniToolBar::UpdateOpacity
virtual void UpdateOpacity()
Updates the opacity of the mini toolbar and pop-up menu.
CXTPMiniToolBar::m_pfnSetLayeredWindowAttributes
PFNSETLAYEREDWINDOWATTRIBUTES m_pfnSetLayeredWindowAttributes
Point to Transparency proc in USER32.dll module.
Definition XTPMiniToolBar.h:209
CXTPMiniToolBar::CreateMiniToolBar
static CXTPMiniToolBar *AFX_CDECL CreateMiniToolBar(CXTPCommandBars *pCommandBars)
Call this method to create a CXTPMiniToolBar class.
CXTPMiniToolBar::OnHookKeyDown
virtual BOOL OnHookKeyDown(UINT nChar, LPARAM lParam)
The framework calls this member function when a non-system key is pressed.
CXTPMiniToolBar::m_pfnUpdateLayeredWindow
LPFNUPDATELAYEREDWINDOW m_pfnUpdateLayeredWindow
Point to UpdateLayeredWindow proc in USER32.dll module.
Definition XTPMiniToolBar.h:211
CXTPMiniToolBar::m_bActivated
BOOL m_bActivated
TRUE if the mini toolbar is activated.
Definition XTPMiniToolBar.h:214
CXTPMiniToolBar::TrackMiniBar
virtual BOOL TrackMiniBar(UINT nFlags, int xPos, int yPos)
Call this method to show the minibar in a specific position.
CXTPMiniToolBar::m_nOpacity
int m_nOpacity
Opacity level.
Definition XTPMiniToolBar.h:215
CXTPMiniToolBar::CursorInWindow
BOOL CursorInWindow() const
Specifies whether the mouse cursor is hovered over the mini toolbar.
CXTPMiniToolBar::m_pContextMenu
CXTPPopupBar * m_pContextMenu
Context menu that is displayed in customization mode when a user right-clicks on a control.
Definition XTPMiniToolBar.h:217
CXTPMiniToolBar::CXTPMiniToolBar
CXTPMiniToolBar()
Constructs a CXTPMiniToolBar object.
CXTPMiniToolBar::m_bTracking
BOOL m_bTracking
TRUE if the command bar is in tracking mode.
Definition XTPMiniToolBar.h:216
CXTPPopupBar
CXTPPopupBar is a CXTPCommandBar derived class.
Definition XTPPopupBar.h:42
CXTPPopupToolBar
CXTPPopupToolBar is a CXTPPopupBar derived class.
Definition XTPPopupBar.h:492


Toolkit Pro: Member List

CXTPMarkupThickness Member List

This is the complete list of members for CXTPMarkupThickness, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPMarkupThickness() | CXTPMarkupThickness |
CXTPMarkupThickness(const CXTPMarkupThickness &other) | CXTPMarkupThickness |
CXTPMarkupThickness(long nThickness) | CXTPMarkupThickness |
CXTPMarkupThickness(long nXThickness, long nYThickness) | CXTPMarkupThickness |
CXTPMarkupThickness(long nLeft, long nTop, long nRight, long nBottom) | CXTPMarkupThickness |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetBottom() const | CXTPMarkupThickness |
GetLeft() const | CXTPMarkupThickness |
GetRight() const | CXTPMarkupThickness |
GetTop() const | CXTPMarkupThickness |
SetLeft(long nThickness) | CXTPMarkupThickness |


Toolkit Pro: XTPMarkupMouseWheelEventArgs.h Source File

  • Source
  • Markup
XTPMarkupMouseWheelEventArgs.h
Go to the documentation of this file.
1
23#if !defined(__XTPMMARKUPMOUSEWHEELEVENTARGS_H__)
24# define __XTPMMARKUPMOUSEWHEELEVENTARGS_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class _XTP_EXT_CLASS CXTPMarkupMouseWheelEventArgs : public CXTPMarkupMouseEventArgs
34{
35public:
36 CXTPMarkupMouseWheelEventArgs();
37
38public:
39 int m_nDelta;
40};
41
42# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
44#endif // !defined(__XTPMMARKUPMOUSEWHEELEVENTARGS_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h


Toolkit Pro: Member List

CXTPCalendarThemeStringValue Member List

This is the complete list of members for CXTPCalendarThemeStringValue, including all inherited members.

CopySettings(const CXTPCalendarThemeCustomizableXValueT< CString, LPCTSTR > &refSrc) | CXTPCalendarThemeCustomizableXValueT< CString, LPCTSTR > | inline
CXTPCalendarThemeCustomizableXValueT() | CXTPCalendarThemeCustomizableXValueT< CString, LPCTSTR > | inline
CXTPCalendarThemeStringValue() | CXTPCalendarThemeStringValue |
DoDestroy(CString &refValue) | CXTPCalendarThemeStringValue | inlineprotectedvirtual
DoPropExchange(CXTPPropExchange *pPX, LPCTSTR pcszPropName) | CXTPCalendarThemeStringValue | virtual
DoPX_Value(CXTPPropExchange *pPX, LPCTSTR pcszPropName, CString &rXValue, BOOL bStandard) | CXTPCalendarThemeStringValue | protected
GetStandardValue() const | CXTPCalendarThemeCustomizableXValueT< CString, LPCTSTR > | inlinevirtual
GetValue() const | CXTPCalendarThemeCustomizableXValueT< CString, LPCTSTR > | inlinevirtual
GetValueX() const | CXTPCalendarThemeCustomizableXValueT< CString, LPCTSTR > | inlinevirtual
IsCustomValue() const | CXTPCalendarThemeCustomizableXValueT< CString, LPCTSTR > | inlinevirtual
IsDefaultValue() const | CXTPCalendarThemeCustomizableXValueT< CString, LPCTSTR > | inlinevirtual
IsStandardValue() const | CXTPCalendarThemeCustomizableXValueT< CString, LPCTSTR > | inlinevirtual
m_bAutoDestroy_Custom | CXTPCalendarThemeCustomizableXValueT< CString, LPCTSTR > | protected
m_bAutoDestroy_Standard | CXTPCalendarThemeCustomizableXValueT< CString, LPCTSTR > | protected
m_bIsCustomSet | CXTPCalendarThemeCustomizableXValueT< CString, LPCTSTR > | protected
m_bIsStandardSet | CXTPCalendarThemeCustomizableXValueT< CString, LPCTSTR > | protected
m_ValueCustom | CXTPCalendarThemeCustomizableXValueT< CString, LPCTSTR > | protected
m_ValueStandard | CXTPCalendarThemeCustomizableXValueT< CString, LPCTSTR > | protected
operator const CString &() const | CXTPCalendarThemeStringValue | inline
operator LPCTSTR() const | CXTPCalendarThemeCustomizableXValueT< CString, LPCTSTR > | inline
operator=(LPCTSTR pcszValue) | CXTPCalendarThemeStringValue |
Serialize(CArchive &ar) | CXTPCalendarThemeCustomizableXValueT< CString, LPCTSTR > | inlinevirtual
SetCustomValue(LPCTSTR refValue, BOOL bAutoDestroy) | CXTPCalendarThemeCustomizableXValueT< CString, LPCTSTR > | inlinevirtual
SetCustomValue(LPCTSTR refValue) | CXTPCalendarThemeCustomizableXValueT< CString, LPCTSTR > | inlinevirtual
SetDefaultValue() | CXTPCalendarThemeCustomizableXValueT< CString, LPCTSTR > | inlinevirtual
SetStandardValue(LPCTSTR refValue, BOOL bAutoDestroy) | CXTPCalendarThemeCustomizableXValueT< CString, LPCTSTR > | inlinevirtual
SetStandardValue(LPCTSTR refValue) | CXTPCalendarThemeCustomizableXValueT< CString, LPCTSTR > | inlinevirtual
~CXTPCalendarThemeCustomizableXValueT() | CXTPCalendarThemeCustomizableXValueT< CString, LPCTSTR > | inlinevirtual


Toolkit Pro: Member List

CXTPDockingPaneNativeWindows10Theme Member List

This is the complete list of members for CXTPDockingPaneNativeWindows10Theme, including all inherited members.

AdjustCaptionRect(const CXTPDockingPaneTabbedContainer *pPane, CRect &rc) | CXTPDockingPaneVisualStudio2012Theme | virtual
CXTPDockingPaneDefaultTheme::AdjustCaptionRect(const CXTPDockingPaneSidePanel *pPane, CRect &rc) | CXTPDockingPanePaintManager | virtual
AdjustClientRect(CXTPDockingPaneTabbedContainer *pPane, CRect &rc, BOOL bApply) | CXTPDockingPaneVisualStudio2012Theme | virtual
CXTPDockingPaneDefaultTheme::AdjustClientRect(CXTPDockingPaneSidePanel *pPane, CRect &rect) | CXTPDockingPanePaintManager | virtual
ClipAndAddEllipsisIfNeeded(CDC *pDC, CString &strTitle, int nCaptionWidth) const | CXTPDockingPanePaintManager | protected
CXTPCmdTarget() | CXTPCmdTarget |
CXTPDockingPaneDefaultTheme() | CXTPDockingPaneDefaultTheme |
CXTPDockingPaneNativeWindows10Theme() | CXTPDockingPaneNativeWindows10Theme |
CXTPDockingPanePaintManager() | CXTPDockingPanePaintManager | protected
CXTPDockingPaneVisualStudio2012Theme() | CXTPDockingPaneVisualStudio2012Theme |
DeletePaneColorSets() | CXTPDockingPaneVisualStudio2012Theme | protected
DrawAutoHidePanel(CDC *pDC, CRect rc, XTPDockingPaneDirection direction) | CXTPDockingPaneNativeWindows10Theme | virtual
DrawCaption(CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc) | CXTPDockingPaneVisualStudio2012Theme | virtual
DrawCaptionButton(CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton) | CXTPDockingPaneVisualStudio2012Theme | virtual
DrawCaptionButtonEntry(CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton, CSize szOffset) | CXTPDockingPanePaintManager | protectedvirtual
DrawCaptionButtonEntry(CDC *pDC, CXTPDockingPaneCaptionButton *pButton, CPoint pt, COLORREF clrButton) | CXTPDockingPanePaintManager | protectedvirtual
DrawCaptionButtons(CDC *pDC, CXTPDockingPaneCaptionButtons *pButtons, CRect &rcCaption, COLORREF clr, int nButtonSize, int nButtonGap, BOOL bVertical=FALSE) | CXTPDockingPanePaintManager | virtual
DrawCaptionPart(CDC *pDC, CXTPDockingPaneBase *pPane, CRect rcCaption, const CString &strTitle, BOOL bActive, BOOL bVertical) | CXTPDockingPaneDefaultTheme | protectedvirtual
DrawCaptionText(CDC *pDC, const CString &strTitle, CRect rc, BOOL bVertical, BOOL bCalcWidth=FALSE) | CXTPDockingPanePaintManager |
DrawDottedLine(CDC *pDC, int x, int y, int nSize, COLORREF clr, BOOL bVertical) | CXTPDockingPaneVisualStudio2012Theme | protected
DrawFloatingFrame(CDC *pDC, CXTPDockingPaneMiniWnd *pPane, CRect rc) | CXTPDockingPaneVisualStudio2012Theme | virtual
DrawGripper(CDC *pDC, CRect rcGripper, COLORREF clr, BOOL bVertical) | CXTPDockingPaneVisualStudio2012Theme | protected
DrawPane(CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc) | CXTPDockingPaneVisualStudio2012Theme | virtual
DrawSidePanel(CDC *pDC, CXTPDockingPaneSidePanel *pPane, CRect rc) | CXTPDockingPaneVisualStudio2012Theme | virtual
DrawSplitter(CDC *pDC, CXTPDockingPaneSplitterWnd *pSplitter) | CXTPDockingPaneNativeWindows10Theme | virtual
DrawTitleBar(CDC *pDC, CXTPDockingPaneBase *pPane, CRect rc, BOOL bVertical) | CXTPDockingPaneNativeWindows10Theme | protectedvirtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCaptionButtonStyle() const | CXTPDockingPanePaintManager |
GetCaptionGripperRect(const CXTPDockingPaneTabbedContainer *pPane) | CXTPDockingPanePaintManager | virtual
GetCaptionHeight() const | CXTPDockingPanePaintManager |
GetCaptionRect(const CXTPDockingPaneTabbedContainer *pPane, CRect &rc) | CXTPDockingPanePaintManager | virtual
GetColorSet(BOOL bActive) | CXTPDockingPaneVisualStudio2012Theme | protectedvirtual
GetCurrentSystemTheme() const | CXTPDockingPanePaintManager |
GetCustomTitleBrush(BOOL bActive, BOOL bVertical) const | CXTPDockingPanePaintManager |
GetPaneCaptionRect(const CXTPDockingPaneSidePanel *pPane) | CXTPDockingPaneVisualStudio2012Theme | virtual
GetPanelPaintManager() const | CXTPDockingPanePaintManager |
GetSplitterStyle() const | CXTPDockingPanePaintManager |
GetTabPaintManager() const | CXTPDockingPanePaintManager |
GetTabsHeight() const | CXTPDockingPanePaintManager |
GetXtremeColor(UINT nIndex) | CXTPDockingPanePaintManager |
Line(CDC *pDC, int x0, int y0, int x1, int y1, int nPen) | CXTPDockingPanePaintManager |
Line(CDC *pDC, int x0, int y0, int x1, int y1) | CXTPDockingPanePaintManager |
m_arrColor | CXTPDockingPanePaintManager | protected
m_bDestroyCustomTitleBrushes | CXTPDockingPanePaintManager | protected
m_bDrawCaptionIcon | CXTPDockingPanePaintManager |
m_bDrawSingleTab | CXTPDockingPanePaintManager |
m_bHighlightActiveCaption | CXTPDockingPanePaintManager |
m_bLunaTheme | CXTPDockingPanePaintManager | protected
m_bShowCaption | CXTPDockingPanePaintManager |
m_bUseBoldCaptionFont | CXTPDockingPanePaintManager |
m_bUseOfficeFont | CXTPDockingPanePaintManager | protected
m_bUseStandardFont | CXTPDockingPanePaintManager | protected
m_clrActiveCaption | CXTPDockingPanePaintManager |
m_clrActiveCaptionText | CXTPDockingPanePaintManager |
m_clrBackground | CXTPDockingPanePaintManager |
m_clrCaptionBorder | CXTPDockingPaneNativeWindows10Theme | protected
m_clrDisabledCaptionText | CXTPDockingPanePaintManager |
m_clrNormalCaption | CXTPDockingPanePaintManager |
m_clrNormalCaptionText | CXTPDockingPanePaintManager |
m_clrSplitter | CXTPDockingPanePaintManager |
m_clrSplitterGradient | CXTPDockingPanePaintManager |
m_clrSplitterGripper | CXTPDockingPanePaintManager |
m_dwSplitterStyle | CXTPDockingPanePaintManager | protected
m_hbrActiveTitleHorz | CXTPDockingPanePaintManager | protected
m_hbrActiveTitleVert | CXTPDockingPanePaintManager | protected
m_hbrInactiveTitleHorz | CXTPDockingPanePaintManager | protected
m_hbrInactiveTitleVert | CXTPDockingPanePaintManager | protected
m_nCaptionButtonStyle | CXTPDockingPanePaintManager | protected
m_nCaptionFontGap | CXTPDockingPanePaintManager | protected
m_nFontSize | CXTPDockingPaneVisualStudio2012Theme | protected
m_nSplitterIndent | CXTPDockingPanePaintManager |
m_nSplitterSize | CXTPDockingPanePaintManager |
m_nTabsHeight | CXTPDockingPanePaintManager | protected
m_nTitleHeight | CXTPDockingPanePaintManager | protected
m_pcsActive | CXTPDockingPaneVisualStudio2012Theme | protected
m_pcsInactive | CXTPDockingPaneVisualStudio2012Theme | protected
m_pPanelPaintManager | CXTPDockingPanePaintManager | protected
m_pTabPaintManager | CXTPDockingPanePaintManager | protected
m_rcCaptionMargin | CXTPDockingPanePaintManager | protected
m_strFontFace | CXTPDockingPaneVisualStudio2012Theme | protected
m_strOfficeFont | CXTPDockingPanePaintManager | protected
m_systemTheme | CXTPDockingPanePaintManager | protected
m_themeButton | CXTPDockingPanePaintManager | protected
m_themeCurrent | CXTPDockingPanePaintManager | protected
m_themeExplorer | CXTPDockingPanePaintManager | protected
m_themeRebar | CXTPDockingPanePaintManager | protected
m_themeToolbar | CXTPDockingPanePaintManager | protected
m_themeWindow | CXTPDockingPanePaintManager | protected
m_xtpFontTitle | CXTPDockingPanePaintManager | protected
m_xtpFontTitleVertical | CXTPDockingPanePaintManager | protected
Pixel(CDC *pDC, int xPos, int yPos, int nPen) | CXTPDockingPanePaintManager |
Rectangle(CDC *pDC, CRect rc, int nPenEntry, int nPenBorder) | CXTPDockingPanePaintManager |
RefreshMetrics() | CXTPDockingPaneNativeWindows10Theme | virtual
SetCaptionButtonStyle(XTPDockingPaneCaptionButtonStyle nStyle) | CXTPDockingPanePaintManager |
SetCaptionFontIndirect(LOGFONT *pLogFont, BOOL bUseStandardFont=FALSE) | CXTPDockingPanePaintManager |
SetColors(int cElements, CONST INT *lpaElements, CONST COLORREF *lpaRgbValues) | CXTPDockingPanePaintManager |
SetCustomTitleBrushes(HBRUSH hbrActiveTitleHorz, HBRUSH hbrInactiveTitleHorz=NULL, HBRUSH hbrActiveTitleVert=NULL, HBRUSH hbrInactiveTitleVert=NULL, BOOL bDestroyOnCleanup=FALSE) | CXTPDockingPanePaintManager |
SetLunaTheme(XTPCurrentSystemTheme systemTheme) | CXTPDockingPanePaintManager |
SetPaneColorSets(CXTPDockingPaneColorSet *pcsActive, CXTPDockingPaneColorSet *pcsInactive) | CXTPDockingPaneVisualStudio2012Theme | protected
SetPanelPaintManager(CXTPTabPaintManager *pManager) | CXTPDockingPanePaintManager |
SetSplitterStyle(DWORD dwStyle) | CXTPDockingPanePaintManager |
SetTabPaintManager(CXTPTabPaintManager *pManager) | CXTPDockingPanePaintManager |
UseOfficeFont(BOOL bUseOfficeFont) | CXTPDockingPanePaintManager |
~CXTPDockingPaneNativeWindows10Theme() | CXTPDockingPaneNativeWindows10Theme | virtual
~CXTPDockingPanePaintManager() | CXTPDockingPanePaintManager | protectedvirtual
~CXTPDockingPaneVisualStudio2012Theme() | CXTPDockingPaneVisualStudio2012Theme | virtual


Toolkit Pro: Member List

CXTPFlowGraphUndoSetConnectionPositionCommand Member List

This is the complete list of members for CXTPFlowGraphUndoSetConnectionPositionCommand, including all inherited members.

CXTPFlowGraphUndoCommand(int nID) | CXTPFlowGraphUndoCommand | protected
CXTPFlowGraphUndoSetConnectionPositionCommand(CXTPFlowGraphConnection *pConnection, CPoint ptOldPosition) | CXTPFlowGraphUndoSetConnectionPositionCommand |
GetID() const | CXTPFlowGraphUndoCommand |
m_nID | CXTPFlowGraphUndoCommand | protected
m_pConnection | CXTPFlowGraphUndoSetConnectionPositionCommand | protected
m_ptOldPosition | CXTPFlowGraphUndoSetConnectionPositionCommand | protected
Undo() | CXTPFlowGraphUndoSetConnectionPositionCommand | protectedvirtual
~CXTPFlowGraphUndoCommand() | CXTPFlowGraphUndoCommand | protectedvirtual
~CXTPFlowGraphUndoSetConnectionPositionCommand() | CXTPFlowGraphUndoSetConnectionPositionCommand | virtual


Toolkit Pro: Member List

CXTPDockingPaneMiniWnd Member List

This is the complete list of members for CXTPDockingPaneMiniWnd, including all inherited members.

Clone(CXTPDockingPaneLayout *pLayout, CXTPPaneToPaneMap *pMap, DWORD dwIgnoredOptions=0) | CXTPDockingPaneBase | protectedvirtual
Collapse(BOOL bDelay=FALSE) | CXTPDockingPaneMiniWnd |
ContainPane(CXTPDockingPaneBase *pPane) const | CXTPDockingPaneBase | virtual
Copy(CXTPDockingPaneBase *pClone, CXTPPaneToPaneMap *pMap, DWORD dwIgnoredOptions) | CXTPDockingPaneMiniWnd | protectedvirtual
Create(CRect rc) | CXTPDockingPaneMiniWnd | protectedvirtual
CreateContainer() | CXTPDockingPaneMiniWnd | protectedvirtual
CXTPDockingPaneBase(XTPDockingPaneType type, CXTPDockingPaneLayout *pLayout) | CXTPDockingPaneBase | protected
CXTPDockingPaneMiniWnd(CXTPDockingPaneLayout *pLayout) | CXTPDockingPaneMiniWnd | protected
DeletePane()=0 | CXTPDockingPaneBase | protectedpure virtual
DoPropExchange(CXTPPropExchange *pPX) | CXTPDockingPaneMiniWnd | protectedvirtual
DoSlideStep(BOOL bActivate=FALSE) | CXTPDockingPaneMiniWnd | protected
Expand() | CXTPDockingPaneMiniWnd |
FindCaptionButton(int nID) const | CXTPDockingPaneBase |
FindPane(XTPDockingPaneType type, CXTPDockingPaneBaseList *pList) const | CXTPDockingPaneMiniWnd | protectedvirtual
GetCaptionButtons() const | CXTPDockingPaneBase |
GetContainer() const | CXTPDockingPaneBase |
GetDockingPaneManager() const | CXTPDockingPaneBase |
GetDockingSite() const | CXTPDockingPaneBase | virtual
GetMinMaxInfo(LPMINMAXINFO pMinMaxInfo) const | CXTPDockingPaneMiniWnd | protectedvirtual
GetPaintManager() const | CXTPDockingPaneBase |
GetPaneHwnd() const | CXTPDockingPaneMiniWnd | protectedvirtual
GetPaneWindowRect() const | CXTPDockingPaneBase |
GetSelectedPane() const | CXTPDockingPaneMiniWnd | protected
GetTitle() const | CXTPDockingPaneMiniWnd | virtual
GetTopPane() const | CXTPDockingPaneMiniWnd |
GetType() const | CXTPDockingPaneBase |
Init(CXTPDockingPaneBase *pPane, CRect rc) | CXTPDockingPaneMiniWnd | protectedvirtual
InvalidatePane(BOOL bSelectionChanged) | CXTPDockingPaneMiniWnd | protectedvirtual
IsActive() const | CXTPDockingPaneMiniWnd | virtual
IsCaptionButtonVisible(CXTPDockingPaneCaptionButton *pButton) | CXTPDockingPaneMiniWnd | protectedvirtual
IsCaptionVertical() const | CXTPDockingPaneMiniWnd | virtual
IsCollapsed() const | CXTPDockingPaneMiniWnd |
IsEmpty() const | CXTPDockingPaneBase | virtual
IsHidden() const | CXTPDockingPaneBase | virtual
IsThemed() const | CXTPDockingPaneMiniWnd | protected
m_bCloseEnabled | CXTPDockingPaneMiniWnd | protected
m_bCollapsed | CXTPDockingPaneMiniWnd | protected
m_bDelayInvalidate | CXTPDockingPaneMiniWnd | protected
m_bExpanded | CXTPDockingPaneMiniWnd | protected
m_bShowPinButton | CXTPDockingPaneMiniWnd | static
m_bSlideOut | CXTPDockingPaneMiniWnd | protected
m_nDeactivationCount | CXTPDockingPaneMiniWnd | protected
m_nExpandedHeight | CXTPDockingPaneMiniWnd | protected
m_nSlideStep | CXTPDockingPaneMiniWnd | protected
m_nStepsCount | CXTPDockingPaneMiniWnd | protected
m_pCaptionButtons | CXTPDockingPaneBase | protected
m_pDockingSite | CXTPDockingPaneBase | protected
m_pLayout | CXTPDockingPaneBase | protected
m_pParentContainer | CXTPDockingPaneBase | protected
m_pTopContainer | CXTPDockingPaneMiniWnd | protected
m_rcWindow | CXTPDockingPaneBase | protected
m_szDocking | CXTPDockingPaneBase | protected
m_type | CXTPDockingPaneBase | protected
OnAction(XTPDockingPaneAction action) | CXTPDockingPaneMiniWnd | protected
OnCaptionButtonClick(CXTPDockingPaneCaptionButton *pButton) | CXTPDockingPaneMiniWnd | protectedvirtual
OnCaptionButtonDown(CXTPDockingPaneCaptionButton *pButton) | CXTPDockingPaneMiniWnd | protectedvirtual
OnCaptionButtonRectChanged(CXTPDockingPaneCaptionButton *pButton) | CXTPDockingPaneBase | protectedvirtual
OnChildContainerChanged(CXTPDockingPaneBase *pContainer) | CXTPDockingPaneMiniWnd | protectedvirtual
OnFocusChanged() | CXTPDockingPaneMiniWnd | protectedvirtual
OnParentContainerChanged(CXTPDockingPaneBase *pContainer) | CXTPDockingPaneBase | protectedvirtual
OnPinButtonClick() | CXTPDockingPaneMiniWnd | protected
OnSizeParent(CWnd *pParent, CRect rect, LPVOID lParam) | CXTPDockingPaneBase | protectedvirtual
OnThemedChanged() | CXTPDockingPaneMiniWnd | protected
RedrawPane() | CXTPDockingPaneMiniWnd | protectedvirtual
RemovePane(CXTPDockingPaneBase *pPane) | CXTPDockingPaneMiniWnd | protectedvirtual
SetDockingSite(CWnd *pFrame) | CXTPDockingPaneBase | protectedvirtual
SetParentContainer(CXTPDockingPaneBase *pContainer) | CXTPDockingPaneBase | protectedvirtual
UpdateWindowOpacity() | CXTPDockingPaneMiniWnd | protectedvirtual
~CXTPDockingPaneBase() | CXTPDockingPaneBase | protectedvirtual
~CXTPDockingPaneMiniWnd() | CXTPDockingPaneMiniWnd | protected


Toolkit Pro: XTPCalendarVisualStudio2017Theme.h Source File

  • Source
  • Calendar
  • Themes
XTPCalendarVisualStudio2017Theme.h
Go to the documentation of this file.
1
22#if !defined(__XTPCALENDARVISUALSTUDIO2017THEME_H__)
23# define __XTPCALENDARVISUALSTUDIO2017THEME_H__
24
25# if _MSC_VER > 1000
26# pragma once
27# endif // _MSC_VER > 1000
28
29# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
30
36class _XTP_EXT_CLASS CXTPCalendarVisualStudio2017Theme : public CXTPCalendarOffice2013Theme
37{
38public:
47 CXTPCalendarVisualStudio2017Theme();
48
55 virtual ~CXTPCalendarVisualStudio2017Theme();
56};
57
58# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
59#endif // !defined(__XTPCALENDARVISUALSTUDIO2017THEME_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCalendarOffice2013Theme
CXTPCalendarOffice2013Theme is a CXTPCalendarOffice2000Theme derived class that represents the Office...
Definition XTPCalendarOffice2013Theme.h:37
CXTPCalendarVisualStudio2017Theme
CXTPCalendarVisualStudio2017Theme is a CXTPCalendarOffice2013Theme derived class that represents the ...
Definition XTPCalendarVisualStudio2017Theme.h:37
CXTPCalendarVisualStudio2017Theme::CXTPCalendarVisualStudio2017Theme
CXTPCalendarVisualStudio2017Theme()
Default paint manager constructor.
CXTPCalendarVisualStudio2017Theme::~CXTPCalendarVisualStudio2017Theme
virtual ~CXTPCalendarVisualStudio2017Theme()
Default paint manager destructor.


Toolkit Pro: Member List

CXTPWinApp Member List

This is the complete list of members for CXTPWinApp, including all inherited members.

CXTPWinApp(int xtpComInit=xtpComInitAppDefault) | CXTPWinApp |
~CXTPWinApp() | CXTPWinApp | virtual


Toolkit Pro: Member List

CXTPChartPyramidSeriesViewBase Member List

This is the complete list of members for CXTPChartPyramidSeriesViewBase, including all inherited members.

AddChildView(CXTPChartElementView *pChildView) | CXTPChartElementView |
CalculateLabelLayout(CXTPChartDeviceContext *pDC) | CXTPChartPyramidSeriesViewBase |
CalculatePointLayout(CXTPChartDeviceContext *pDC, CRect rcBounds)=0 | CXTPChartPyramidSeriesViewBase | pure virtual
CreateDeviceCommand(CXTPChartDeviceContext *pDC)=0 | CXTPChartPyramidSeriesViewBase | protectedpure virtual
CreateDiagramDomain(CXTPChartDeviceContext *pDC, CRect rcBounds) | CXTPChartPyramidSeriesViewBase | virtual
CreateLegendDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcBounds)=0 | CXTPChartPyramidSeriesViewBase | protectedpure virtual
CreateLegendDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcBounds, CXTPChartColor color1, CXTPChartColor color2, CXTPChartColor clrBorder)=0 | CXTPChartPyramidSeriesViewBase | pure virtual
CreateSeriesPointView(CXTPChartDeviceContext *pDC, CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)=0 | CXTPChartPyramidSeriesViewBase | protectedpure virtual
CXTPChartElementView(CXTPChartElementView *pParentView) | CXTPChartElementView |
CXTPChartElementView(CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartElementView |
CXTPChartElementView(CXTPChartContainer *pContainer) | CXTPChartElementView |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartPyramidSeriesViewBase(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView) | CXTPChartPyramidSeriesViewBase |
GetAt(int nIndex) const | CXTPChartElementView |
GetBounds() const | CXTPChartElementView |
GetBounds(BOOL bIncludingChildren) const | CXTPChartElementView |
GetChildren() | CXTPChartElementView |
GetCount() const | CXTPChartElementView |
GetDomain() const | CXTPChartPyramidSeriesViewBase |
GetInnerBounds() const | CXTPChartPyramidSeriesViewBase | virtual
GetMaxLabelWidth() const | CXTPChartPyramidSeriesViewBase |
GetParentView() const | CXTPChartElementView |
Is3D() const | CXTPChartObject |
m_arrChildren | CXTPChartElementView | protected
m_pContainer | CXTPChartElementView | protected
m_pDomain | CXTPChartPyramidSeriesViewBase | protected
m_pParentView | CXTPChartElementView | protected
m_rcBounds | CXTPChartElementView | protected
~CXTPChartElementView() | CXTPChartElementView | protectedvirtual
~CXTPChartLegendItemView() | CXTPChartLegendItemView | inlinevirtual
~CXTPChartPyramidSeriesViewBase() | CXTPChartPyramidSeriesViewBase | virtual


Toolkit Pro: XTPSliderThemeVisualStudio2022.h Source File

  • Source
  • CommandBars
  • Slider
XTPSliderThemeVisualStudio2022.h
Go to the documentation of this file.
1
23#if !defined(__XTPSLIDERTHEMEVISUALSTUDIO2022_H__)
24# define __XTPSLIDERTHEMEVISUALSTUDIO2022_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class _XTP_EXT_CLASS CXTPSliderThemeVisualStudio2022 : public CXTPSliderThemeOffice2013
34{
35public:
36 CXTPSliderThemeVisualStudio2022(CXTPPaintManager* pPaintManager);
37};
38
40# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
41#endif // !defined(__XTPSLIDERTHEMEVISUALSTUDIO2022_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPPaintManager
Paint manager of the command bars.
Definition XTPPaintManager.h:199


Toolkit Pro: XTPPropExchangeRegistry.h Source File

  • Source
  • Common
  • PropExchange
XTPPropExchangeRegistry.h
Go to the documentation of this file.
1
23#if !defined(__XTPPROPEXCHANGEREGISTRY_H__)
24# define __XTPPROPEXCHANGEREGISTRY_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
49class _XTP_EXT_CLASS CXTPPropExchangeRegistry : public CXTPPropExchange
50{
52 DECLARE_DYNAMIC(CXTPPropExchangeRegistry)
54public:
63 CXTPPropExchangeRegistry(BOOL bLoading, HKEY hParentKey, LPCTSTR lpszSection);
64
70 ~CXTPPropExchangeRegistry();
71
96 virtual BOOL ExchangeProp(LPCTSTR pszPropName, VARTYPE vtProp, void* pvProp,
97 const void* pvDefault = NULL);
98
109 virtual BOOL ExchangeBlobProp(LPCTSTR pszPropName, BYTE*& pData, DWORD& nBytes);
110
117 BOOL IsSectionExists(LPCTSTR lpszSection);
118
125 BOOL IsPropertyExists(LPCTSTR pszPropName);
126
142 virtual CXTPPropExchange* GetSection(LPCTSTR lpszSection);
143
148 virtual void EmptySection();
149
156 virtual BOOL OnBeforeExchange();
157
164 virtual BOOL IsAllowBlobValues() const;
165
166private:
167 LONG DelRegTreeHelper(HKEY hParentKey, LPCTSTR lpszKeyName);
168
169protected:
170 HKEY m_hSectionKey;
171 HKEY m_hParentKey;
172 CString m_strSectionName;
173 BOOL m_bCloseParentKey;
174};
175
176AFX_INLINE BOOL CXTPPropExchangeRegistry::IsAllowBlobValues() const
177{
178 return TRUE;
179}
180
181# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
183#endif // !defined(__XTPPROPEXCHANGEREGISTRY_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72
CXTPPropExchange::IsAllowBlobValues
virtual BOOL IsAllowBlobValues() const
Call this method to determine if storage allows exchange plain blob values.
CXTPPropExchangeRegistry
CXTPPropExchangeRegistry is CXTPPropExchange derived class.
Definition XTPPropExchangeRegistry.h:50
CXTPPropExchangeRegistry::m_strSectionName
CString m_strSectionName
Section name.
Definition XTPPropExchangeRegistry.h:172
CXTPPropExchangeRegistry::GetSection
virtual CXTPPropExchange * GetSection(LPCTSTR lpszSection)
This method creates new section for text base storages (CXTPPropExchangeXMLNode and CXTPPropExchangeR...
CXTPPropExchangeRegistry::m_hParentKey
HKEY m_hParentKey
Parent registry key.
Definition XTPPropExchangeRegistry.h:171
CXTPPropExchangeRegistry::ExchangeBlobProp
virtual BOOL ExchangeBlobProp(LPCTSTR pszPropName, BYTE *&pData, DWORD &nBytes)
This method serializes a property that stores binary large object (BLOB) data.
CXTPPropExchangeRegistry::IsPropertyExists
BOOL IsPropertyExists(LPCTSTR pszPropName)
Call this method to check if property entry exists.
CXTPPropExchangeRegistry::IsAllowBlobValues
virtual BOOL IsAllowBlobValues() const
Call this method to determine if storage allows exchange plain blob values.
Definition XTPPropExchangeRegistry.h:176
CXTPPropExchangeRegistry::CXTPPropExchangeRegistry
CXTPPropExchangeRegistry(BOOL bLoading, HKEY hParentKey, LPCTSTR lpszSection)
Constructs CXTPPropExchangeRegistry a object.
CXTPPropExchangeRegistry::~CXTPPropExchangeRegistry
~CXTPPropExchangeRegistry()
Destroys a CXTPPropExchangeRegistry object, handles cleanup and deallocation.
CXTPPropExchangeRegistry::EmptySection
virtual void EmptySection()
Call this method to free section information before storing.
CXTPPropExchangeRegistry::m_bCloseParentKey
BOOL m_bCloseParentKey
TRUE to automatically close parent key.
Definition XTPPropExchangeRegistry.h:173
CXTPPropExchangeRegistry::IsSectionExists
BOOL IsSectionExists(LPCTSTR lpszSection)
Call this method to check if section exists.
CXTPPropExchangeRegistry::OnBeforeExchange
virtual BOOL OnBeforeExchange()
This method is called before exchange properties.
CXTPPropExchangeRegistry::ExchangeProp
virtual BOOL ExchangeProp(LPCTSTR pszPropName, VARTYPE vtProp, void *pvProp, const void *pvDefault=NULL)
Exchanges a property between a storage medium and the control.
CXTPPropExchangeRegistry::m_hSectionKey
HKEY m_hSectionKey
Current registry key.
Definition XTPPropExchangeRegistry.h:170


Toolkit Pro: Member List

CXTPHookManagerHookAble Member List

This is the complete list of members for CXTPHookManagerHookAble, including all inherited members.

CXTPHookManagerHookAble() | CXTPHookManagerHookAble |
m_bAutoDestroy | CXTPHookManagerHookAble |
OnHookAttached(HWND hWnd) | CXTPHookManagerHookAble | virtual
OnHookDetached() | CXTPHookManagerHookAble | virtual
OnHookMessage(HWND hWnd, UINT nMessage, WPARAM &wParam, LPARAM &lParam, LRESULT &lResult) | CXTPHookManagerHookAble | virtual
OnPostHookMessage(HWND hWnd, UINT nMessage, WPARAM &wParam, LPARAM &lParam, LRESULT &lResult) | CXTPHookManagerHookAble | virtual
~CXTPHookManagerHookAble() | CXTPHookManagerHookAble | virtual


Toolkit Pro: XTPCalendarView.h Source File

  • Source
  • Calendar
XTPCalendarView.h
Go to the documentation of this file.
1
22#if !defined(_XTPCALENDARVIEW_H__)
23# define _XTPCALENDARVIEW_H__
24
25# if _MSC_VER > 1000
26# pragma once
27# endif // _MSC_VER > 1000
28
29# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
30
31class CXTPCalendarControl;
32class CXTPCalendarPaintManager;
33class CXTPCalendarTheme;
34
35class CXTPCalendarViewDay;
36class CXTPCalendarViewEvent;
37class CXTPCalendarViewEvents;
38class CXTPCalendarEvent;
39class CXTPCalendarEvents;
40class CXTPCalendarViewPart;
41class CXTPCalendarResources;
42class CXTPCalendarData;
43class CXTPCalendarOptions;
44
45struct XTP_CALENDAR_HITTESTINFO;
46typedef DWORD XTP_NOTIFY_CODE;
47
48 XTP_DEFINE_SMART_PTR_INTERNAL(CXTPCalendarEvent)
49 XTP_DEFINE_SMART_PTR_INTERNAL(CXTPCalendarEvents)
50 XTP_DEFINE_SMART_PTR_INTERNAL(CXTPCalendarViewEvent)
51 XTP_DEFINE_SMART_PTR_INTERNAL(CXTPCalendarViewEvents)
52
53
54
55
59# define XTP_CALENDAR_START_EDIT_SUBJECT_TIMEOUT_MS 400
60
65static const LPCTSTR XTPCALENDARCTRL_CF_EVENT = _T("XTPCalendar_CF_Event");
66
67enum XTPEnumCalendarUpdateResult
68{
69 xtpCalendar_Skip = 0,
70 xtpCalendar_Redraw = 1,
71 xtpCalendar_Populate = 2
72};
73//===========================================================================
74// use project settings to define _TRACE_EDITING_ON
75# ifdef _TRACE_EDITING_ON
76# define TRACE_MOUSE TRACE
77# define TRACE_KEYBOARD TRACE
78# define TRACE_DRAGGING TRACE
79# define TRACE_EDIT_SUBJECT TRACE
80# else
81# define TRACE_MOUSE
82# define TRACE_KEYBOARD
83# define TRACE_DRAGGING
84# define TRACE_EDIT_SUBJECT
85# endif
86//===========================================================================
87
99class _XTP_EXT_CLASS CXTPCalendarWMHandler : public CXTPCmdTarget
100{
101 DECLARE_DYNAMIC(CXTPCalendarWMHandler)
102 typedef CXTPCmdTarget TBase;
103
104public:
109 CXTPCalendarWMHandler();
110
129 virtual int GetChildHandlersCount() const;
130
145 virtual CXTPCalendarWMHandler* GetChildHandlerAt(int nIndex) const;
146
162 virtual BOOL OnLButtonDown(UINT nFlags, CPoint point);
163
179 virtual BOOL OnLButtonUp(UINT nFlags, CPoint point);
180
196 virtual BOOL OnLButtonDblClk(UINT nFlags, CPoint point);
197
211 virtual void OnMouseMove(UINT nFlags, CPoint point);
212
228 virtual void OnChar(UINT nChar, UINT nRepCnt, UINT nFlags);
229
244 virtual void OnKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags);
245
260 virtual void OnKeyUp(UINT nChar, UINT nRepCnt, UINT nFlags);
261
278 virtual BOOL OnSysKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags);
279
290 virtual BOOL OnTimer(UINT_PTR uTimerID);
291
303 virtual BOOL OnWndMsg(UINT message, WPARAM wParam, LPARAM lParam, LRESULT* pResult);
304
314 virtual void OnPostAdjustLayout();
315
321 virtual void OnBeforeDestroy();
322
323 virtual void OnFinalRelease();
324};
325
359class _XTP_EXT_CLASS CXTPCalendarView : public CXTPCalendarWMHandler
360{
361 friend class CXTPCalendarControl;
362 friend class CXTPCalendarViewDay;
363 friend class CXTPCalendarViewEvent;
364 friend class CXTPCalendarResource;
365 friend class CXTPCalendarTheme;
366 friend class CXTPCalendarDayViewGroup;
367
368 DECLARE_DYNAMIC(CXTPCalendarView)
369
370 typedef CXTPCalendarWMHandler TBase;
371
372private:
373 CUIntArray m_DiscreteSelection;
374
375public:
382 UINT GetDiscreteSelectionCount() const;
383
392 COleDateTime GetDiscreteSelectionValue(UINT id) const;
393
402 BOOL AddToDiscreteSelection(UINT id);
403
412 BOOL IsInDiscreteSelection(UINT id) const;
413
418 void ClearDiscreteSelection();
419
428 CXTPCalendarView(CXTPCalendarControl* pCalendarControl);
429
437 virtual ~CXTPCalendarView();
438
451 virtual XTPCalendarViewType GetViewType() const = 0;
452
458 virtual void Populate();
459
480 virtual void AdjustLayout(CDC* pDC, const CRect& rcView, BOOL bCallPostAdjustLayout = TRUE);
481
502 virtual void AdjustLayout2(CDC* pDC, const CRect& rcView, BOOL bCallPostAdjustLayout = TRUE);
503
512 virtual void RedrawControl();
513
527 virtual void ShowDay(const COleDateTime& date, BOOL bSelect = TRUE) = 0;
528
540 virtual void ScrollV(int nPos, int nPos_raw)
541 {
542 UNREFERENCED_PARAMETER(nPos);
543 UNREFERENCED_PARAMETER(nPos_raw);
544 }
545
557 virtual void ScrollH(int nPos, int nPos_raw)
558 {
559 UNREFERENCED_PARAMETER(nPos);
560 UNREFERENCED_PARAMETER(nPos_raw);
561 }
562
569 virtual void OnScrollEnd(int nBar)
570 {
571 UNREFERENCED_PARAMETER(nBar);
572 }
573
586 virtual BOOL GetScrollBarInfoV(SCROLLINFO* pSI) const
587 {
588 UNREFERENCED_PARAMETER(pSI);
589 return FALSE;
590 }
604 virtual BOOL GetScrollBarInfoH(SCROLLINFO* pSI, int* pnScrollStep = NULL) const
605 {
606 UNREFERENCED_PARAMETER(pSI);
607 UNREFERENCED_PARAMETER(pnScrollStep);
608 return FALSE;
609 }
610
618 virtual void OnDraw(CDC* pDC);
619
635 virtual void Draw(CDC* pDC)
636 {
637 UNREFERENCED_PARAMETER(pDC);
638 }
639
655 virtual void Draw2(CDC* pDC)
656 {
657 UNREFERENCED_PARAMETER(pDC);
658 // Draw(pDC);
659 }
660
677 virtual BOOL OnLButtonDown(UINT nFlags, CPoint point);
678
694 virtual BOOL OnLButtonUp(UINT nFlags, CPoint point);
695
710 virtual void OnMouseMove(UINT nFlags, CPoint point);
711
729 virtual BOOL OnLButtonDblClk(UINT nFlags, CPoint point);
730
746 virtual void OnChar(UINT nChar, UINT nRepCnt, UINT nFlags);
747
764 virtual void OnKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags);
765
782 virtual BOOL OnSysKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags);
783
790 CRect GetViewRect() const;
791
806 virtual int GetChildHandlersCount() const;
807
822 virtual CXTPCalendarWMHandler* GetChildHandlerAt(int nIndex) const;
823
836 virtual int GetViewDayCount() const;
837
854 virtual COleDateTime GetViewDayDate(int nIndex) const = 0;
855
872 virtual CXTPCalendarViewDay* GetViewDay_(int nIndex) const;
873
890 virtual CXTPCalendarViewDay* _GetViewDay(const COleDateTime& dtDay) const;
891
909 virtual BOOL HitTest(CPoint pt, XTP_CALENDAR_HITTESTINFO* pHitTest) const;
910
925 virtual BOOL HitTestEx(CPoint pt, XTP_CALENDAR_HITTESTINFO* pHitTest) const;
926
936 virtual XTPCalendarDraggingMode GetDraggingMode() const;
937
947 virtual CXTPCalendarPaintManager* GetPaintManager() const;
948
962 virtual CXTPCalendarTheme* GetTheme() const;
963
973 CXTPCalendarControl* GetCalendarControl() const;
974
993 CXTPCalendarOptions* GetCalendarOptions() const;
994
1005 virtual CXTPCalendarResources* GetResources() const;
1006
1017 virtual void SetResources(CXTPCalendarResources* pResources);
1018
1024 virtual void UnselectAllEvents();
1025
1042 virtual void SelectEvent(CXTPCalendarEvent* pEvent, BOOL bSelect = TRUE);
1043
1060 void SelectViewEvent(CXTPCalendarViewEvent* pViewEvent, BOOL bSelect = TRUE);
1061
1073 virtual void SelectDay(CXTPCalendarViewDay* pDay, int nGroupIndex = 0);
1074
1092 virtual CXTPCalendarViewEvents* GetSelectedViewEvents() const;
1093
1109 virtual CXTPCalendarViewEventsPtr GetSelectedEvents() const;
1110
1120 CXTPCalendarViewEvent* GetLastSelectedViewEvent() const;
1121
1130 virtual BOOL HasSelectedViewEvent() const;
1131
1143 BOOL IsSingleEventSelected() const;
1144
1153 int FindLastSelectedDay() const;
1154
1165 COleDateTime GetLastSelectedDate() const;
1166
1192 virtual BOOL GetSelection(COleDateTime* pBegin = NULL, COleDateTime* pEnd = NULL,
1193 BOOL* pbAllDayEvent = NULL, int* pnGroupIndex = NULL,
1194 COleDateTimeSpan* pspSelectionResolution = NULL) const;
1195
1209 void SetSelection(const COleDateTime& dtBegin, const COleDateTime& dtEnd,
1210 BOOL bAllDayEvent = FALSE, int nGroupIndex = 0);
1211
1220 void ResetSelection();
1221
1234 BOOL SelectionContains(COleDateTime date, int nGroupIndex = -1, BOOL* pbAllDaySelection = NULL);
1235
1247 virtual void SelectDay(COleDateTime dtSelDay, int nGroupIndex = 0);
1248
1257 virtual int GetRowHeight() const;
1258
1272 virtual CXTPCalendarEventsPtr RetrieveDayEvents(CXTPCalendarResource* pRC, COleDateTime dtDay);
1273
1281 virtual BOOL IsEditingSubject() const;
1282
1291 virtual CRect GetSubjectEditorRect() const;
1292
1304 virtual CRect GetTooltipRect(const CPoint& ptHit,
1305 const XTP_CALENDAR_HITTESTINFO& hitInfo) const;
1306
1313 virtual void ShowToolTip(BOOL bShow = TRUE);
1314
1322 virtual UINT GetShowToolTipTimeOut() const;
1323
1331 virtual void OnUpdateEditingSubject(CString strNewSubject);
1332
1341 virtual BOOL CanUndo() const;
1342
1351 virtual BOOL CanRedo() const;
1352
1359 virtual BOOL Undo();
1360
1367 virtual BOOL Redo();
1368
1373 virtual void EmptyUndoBuffer();
1374
1384 virtual CString FormatEventTime(COleDateTime dtTime) const;
1385
1403 void SetCustomTimeFormat(const CString& strFormat);
1404
1409 void ResetCustomTimeFormat();
1410
1417 virtual CString GetDayHeaderFormat() const;
1418
1425 virtual void SetDayHeaderFormat(LPCTSTR sFmt);
1426
1438 virtual BOOL CanCut() const;
1439
1451 virtual BOOL CanCopy() const;
1452
1464 virtual BOOL CanPaste() const;
1465
1476 virtual BOOL Cut();
1477
1488 virtual BOOL Copy();
1489
1500 virtual BOOL Paste();
1501
1510 virtual CXTPCalendarEvent* GetDraggingEventOrig() const;
1511
1519 virtual CXTPCalendarEvent* GetDraggingEventNew() const;
1520
1530 virtual BOOL SetDraggingEvent(CXTPCalendarEvent* pEventOrig);
1531
1539 virtual BOOL CommitDraggingEvent();
1540
1546 virtual void CancelDraggingEvent();
1547
1557 virtual void OnStartDragging(CPoint point, XTP_CALENDAR_HITTESTINFO* pHitTest);
1558
1570 virtual BOOL OnDragging(CPoint point, XTP_CALENDAR_HITTESTINFO* pHitTest);
1571
1583 virtual BOOL OnEndDragging(CPoint point, XTP_CALENDAR_HITTESTINFO* pHitInfo);
1584
1592 virtual void StartEditSubject(CXTPCalendarViewEvent* pViewEvent);
1593
1605 virtual void EndEditSubject(XTPCalendarEndEditSubjectAction eAction,
1606 BOOL bUpdateControl = TRUE);
1607
1616 virtual UINT GetStartEditSubjectTimeOut() const;
1617
1627 virtual void StartEditNewEventInplace(LPCTSTR pcszInitialSubject);
1628
1641 virtual CXTPCalendarViewEvent* FindViewEvent(CXTPCalendarEvent* pEvent,
1642 COleDateTime dtDay) const;
1643
1644 virtual CXTPCalendarViewEvent* FindViewEventByGroup(CXTPCalendarEvent* pEvent,
1645 COleDateTime dtDay, int nScheduleID) const;
1662 virtual CXTPCalendarViewEvent* FindEventToEditByTAB(COleDateTime dtMinStart, BOOL bReverse,
1663 CXTPCalendarEvent* pAfterEvent = NULL);
1664
1675 virtual COleDateTime GetNextTimeEditByTAB() const;
1676
1691 virtual void UpdateNextTimeEditByTAB(COleDateTime dtNext, BOOL bReverse, BOOL bReset = FALSE);
1692
1705 virtual void ProcessDaySelection(XTP_CALENDAR_HITTESTINFO* pInfo, UINT nFlags);
1706
1715 virtual void SelectDays(COleDateTime dtNewSel);
1716
1727 virtual void ProcessEventSelection(XTP_CALENDAR_HITTESTINFO* pInfo, UINT nFlags);
1728
1739 virtual void EnableVScroll(BOOL bEnable = TRUE);
1740
1751 virtual void EnableHScroll(BOOL bEnable = TRUE);
1752
1760 virtual BOOL IsHScrollEnabled() const;
1761
1769 virtual BOOL IsVScrollEnabled() const;
1770
1786 virtual void SetDayHeaderFormatLong(LPCTSTR pcszCustomFormat);
1787
1803 virtual void SetDayHeaderFormatMiddle(LPCTSTR pcszCustomFormat);
1804
1820 virtual void SetDayHeaderFormatShort(LPCTSTR pcszCustomFormat);
1821
1837 virtual void SetDayHeaderFormatShortest(LPCTSTR pcszCustomFormat);
1838
1845 virtual BOOL IsTodayVisible() const;
1846
1854 virtual CString GetItemTextEventTimeMax() const;
1855
1869 virtual void CalculateHeaderFormat(CDC* pDC, int nWidth, CFont* pTextFont);
1870
1871 COleDateTime GetDateTimeDay(const COleDateTime& dt, BOOL bWholeDayEvent) const;
1872
1873protected:
1883 virtual UINT SetTimer(UINT uTimeOut_ms);
1884
1891 virtual void KillTimer(UINT uTimerID);
1892
1902 virtual BOOL OnTimer(UINT_PTR uTimerID);
1903
1904 /*
1905 * @brief
1906 * This member function is used to perform additional adjustments
1907 * in some kinds of views.
1908 *
1909 * @details
1910 * Call this member function to perform additional adjustments after
1911 * all adjustment activities are completed.
1912 */
1913 // virtual void OnPostAdjustLayout();
1914
1920 virtual void OnBeforeDestroy();
1921
1939 virtual void OnActivateView(BOOL bActivate, CXTPCalendarView* pActivateView,
1940 CXTPCalendarView* pInactiveView);
1941
1962 virtual void SendNotification(XTP_NOTIFY_CODE EventCode, WPARAM wParam = 0, LPARAM lParam = 0);
1963
1972 virtual void _CalculateEventTimeFormat();
1973
1991 virtual CString _GetMaxWidthFormat(CDC* pDC, CString strFormat, BOOL bMonth) const;
1992
2007 virtual int _GetMaxWidth(CDC* pDC, CString strFormat) const;
2008
2020 virtual void _RemoveYearPart(CString& strFormat);
2021
2037 virtual void _ReadDefaultHeaderFormats();
2038
2065 virtual CString _GetDayHeaderFormat(int nLevel) const;
2066
2082 virtual BOOL _CanSubjectEditor(UINT idEditCmd) const;
2083
2094 virtual CWnd* _GetSubjectEditorWnd() const;
2095
2119 virtual COleDataSource* _CopySelectedEvents(DWORD dwCopyFlags = 0);
2120
2145 virtual CXTPCalendarEventsPtr _ReadEventsFromClipboard(COleDataObject* pData,
2146 DWORD* pdwCopyFlags = NULL);
2147
2156 virtual COleDateTimeSpan GetEventDurationMin() const;
2157
2174 virtual BOOL _Undo(CXTPCalendarEvent* pEvent = NULL);
2175
2176 void _ReSelectSelectEvents();
2177
2192 virtual XTPEnumCalendarUpdateResult OnEventChanged_InDataProvider(XTP_NOTIFY_CODE nfCode,
2193 CXTPCalendarEvent* pEvent);
2194
2195protected:
2201 class CUndoBuffer;
2202
2211 BOOL _IsDragModeCopyMove(int eDragMode) const;
2212
2227 BOOL IsEditOperationDisabledNotify(XTPCalendarEditOperation eOperation,
2228 CXTPCalendarViewEvent* pEventView) const;
2229
2245 BOOL OnBeforeEditOperationNotify(XTPCalendarEditOperation eOperation,
2246 CXTPCalendarViewEvent* pEventView);
2247
2263 BOOL OnBeforeEditOperationNotify(XTPCalendarEditOperation eOperation,
2264 CXTPCalendarViewEvents* pEventViews);
2265
2285 BOOL OnBeforePasteNotify(CXTPCalendarEvent* pEvent, BOOL bPasteWillChangeExistingEvent);
2286
2303 BOOL OnInPlaceCreateEvent(LPCTSTR pcszInitialSubject);
2304
2311 class _XTP_EXT_CLASS CSelectionChangedContext
2312 {
2313 public:
2327 CSelectionChangedContext(CXTPCalendarView* pView,
2328 int eSelType = xtpCalendarSelectionUnknown);
2329
2335 virtual ~CSelectionChangedContext();
2336
2337 private:
2338 CXTPCalendarView* m_pView;
2339 int m_eSelType;
2340 };
2341
2342protected:
2349 class CSelectionChanged_ContextData
2350 {
2351 public:
2356 CSelectionChanged_ContextData();
2357
2358 int m_nLockCount;
2359 int m_nLockCount_Day;
2360 int m_nLockCount_Event;
2362 BOOL m_bRequest_Day;
2363 BOOL m_bRequest_Event;
2364 };
2365
2366 CSelectionChanged_ContextData m_cntSelChanged;
2369 friend class CSelectionChangedContext;
2370 friend class CXTPCalendarViewSelection;
2371
2372protected:
2373 int m_eUndoMode;
2374 BOOL m_bResetUndoBuffer;
2376 CUndoBuffer* m_pPrevUndoBuffer;
2377 CUndoBuffer* m_pUndoBuffer;
2379private:
2380 BOOL _EditOperationNotify(XTP_NOTIFY_CODE ncEvent, XTPCalendarEditOperation eOperation,
2381 CXTPCalendarViewEvent* pEventView,
2382 CXTPCalendarViewEvents* pEventViews = NULL) const;
2383
2384 XTPCalendarDraggingMode _GetDraggingMode(XTP_CALENDAR_HITTESTINFO* pHitTest) const;
2385 XTPCalendarEditOperation _DragMod2Operation(int eDragMode);
2386
2387 virtual CXTPCalendarData* _GetDataProviderBySelection(UINT* puScheduleID = NULL);
2388 virtual CXTPCalendarData* _GetDataProviderByConnStr(LPCTSTR pcszConnStr,
2389 BOOL bCompareNoCase = TRUE);
2390 virtual BOOL _IsScheduleVisible(CXTPCalendarData* pDataProvider, UINT uScheduleID);
2391
2392protected:
2393 XTP_VIEW_LAYOUT& GetLayout_();
2394 const XTP_VIEW_LAYOUT& GetLayout_() const;
2395 virtual BOOL IsUseCellAlignedDraggingInTimeArea() const;
2396
2397protected:
2398 XTP_VIEW_LAYOUT m_Layout;
2408 struct SEventTimeFormatInfo
2409 {
2410 CString strFormat;
2411 CString strAM;
2412 CString strPM;
2413 BOOL b24_HFormat;
2414 BOOL isCustom;
2415
2420 SEventTimeFormatInfo()
2421 {
2422 b24_HFormat = FALSE;
2423 isCustom = FALSE;
2424 }
2425 };
2426
2427 SEventTimeFormatInfo m_EventTimeFormat;
2429 CString m_strHeaderFormat;
2431 CString m_strDayHeaderFormatLong;
2432 CString m_strDayHeaderFormatMiddle;
2433 CString m_strDayHeaderFormatShort;
2434 CString m_strDayHeaderFormatShortest;
2436 CString m_strDayHeaderFormatDefaultLong;
2437 CString m_strDayHeaderFormatDefaultMiddle;
2439 CString m_strDayHeaderFormatDefaultShort;
2440 CString m_strDayHeaderFormatDefaultShortest;
2443 CRect m_rcView;
2444 CRect m_rcTooltip;
2447protected:
2448 CXTPCalendarEventPtr m_ptrDraggingEventOrig;
2449 CXTPCalendarEventPtr m_ptrDraggingEventNew;
2451 COleDateTimeSpan m_spDraggingStartOffset;
2453 CPoint m_ptStartDragging;
2455 XTPCalendarDraggingMode m_eDraggingMode;
2456 BOOL m_bStartedClickInside;
2458 CXTPCalendarViewEventPtr m_ptrEditingViewEvent;
2462 CXTPCalendarViewEvent* m_pLastEvent;
2463 UINT m_nTimerID_StartEditSubject;
2464 UINT m_nTimerID_ShowToolTip;
2466 CXTPCalendarControl* m_pControl;
2468 CXTPCalendarViewEvents* m_pSelectedEvents;
2470 XTP_CALENDAR_HITTESTINFO m_LastHitInfo;
2474 UINT m_nKeyStateTimerID;
2476 XTP_CALENDAR_VIEWSELECTION m_selectedBlock;
2478 BOOL m_bScrollV_Disabled;
2479 BOOL m_bScrollH_Disabled;
2481 CXTPCalendarResources* m_pResources;
2483 CPoint m_ptLBtnUpMousePos;
2484 CPoint m_ptLBtnDownMousePos;
2485
2486protected:
2487 mutable CXTPCalendarPtrCollectionT<CXTPCalendarViewDay> m_arDays;
2490# ifdef _XTP_ACTIVEX
2491
2492 DECLARE_DISPATCH_MAP()
2493 DECLARE_INTERFACE_MAP()
2494
2495 DECLARE_OLETYPELIB_EX(CXTPCalendarView);
2496
2497protected:
2498 void OleResetSelection();
2499 void OleSetSelection(DATE Begin, DATE End, BOOL bAllDay);
2500 BOOL OleGetSelection(DATE* pBegin, DATE* pEnd, VARIANT_BOOL* pvbAllDay);
2501 BOOL OleGetSelectionV(VARIANT* pBegin, VARIANT* pEnd, VARIANT* pvbAllDay);
2502 LPDISPATCH OleSelection();
2503
2504 LPDISPATCH OleHitTest();
2505 LPDISPATCH OleHitTestEx(long X, long Y);
2506
2507 void OleShowDay(DATE dt, const VARIANT& Select);
2508 int OleGetItemCount();
2509 LPDISPATCH OleGetItem(long nIndex);
2510
2511 LPDISPATCH OleGetSelectedEvents();
2512 void OleSelectViewEvent(LPDISPATCH pViewEventDisp, BOOL bSelect);
2513 void OleUnselectAllEvents();
2514
2515 void OleEnableVScroll(BOOL bEnable);
2516 void OleEnableHScroll(BOOL bEnable);
2517
2518 LPDISPATCH OleGetMultipleResources();
2519 void OleSetMultipleResources(LPDISPATCH pDispResources);
2520 BOOL OleCanStartEdit();
2521
2522 DECLARE_ENUM_VARIANT(CXTPCalendarView)
2523
2524private:
2525 CXTPCalendarViewSelection* m_pSelOleWrapper;
2526
2527# endif
2528};
2529
2569template<class _TViewDay>
2570class CXTPCalendarViewT : public CXTPCalendarView
2571{
2572public:
2584 CXTPCalendarViewT(CXTPCalendarControl* pCalendarControl, XTPCalendarViewType nViewType)
2585 : CXTPCalendarView(pCalendarControl)
2586 {
2587 m_nViewType = nViewType;
2588 }
2589
2597 virtual ~CXTPCalendarViewT(){};
2598
2607 virtual XTPCalendarViewType GetViewType() const
2608 {
2609 return m_nViewType;
2610 }
2611
2628 virtual _TViewDay* GetViewDay(int nIndex) const
2629 {
2630 return (_TViewDay*)GetViewDay_(nIndex);
2631 }
2632
2633private:
2634 XTPCalendarViewType m_nViewType;
2635};
2636
2637AFX_INLINE CXTPCalendarControl* CXTPCalendarView::GetCalendarControl() const
2638{
2639 return this ? m_pControl : NULL;
2640}
2641AFX_INLINE CRect CXTPCalendarView::GetViewRect() const
2642{
2643 return m_rcView;
2644}
2645AFX_INLINE XTPCalendarDraggingMode CXTPCalendarView::GetDraggingMode() const
2646{
2647 return m_eDraggingMode;
2648}
2649AFX_INLINE int CXTPCalendarView::GetRowHeight() const
2650{
2651 return m_Layout.m_nRowHeight;
2652}
2653AFX_INLINE UINT CXTPCalendarView::GetStartEditSubjectTimeOut() const
2654{
2655 return XTP_CALENDAR_START_EDIT_SUBJECT_TIMEOUT_MS;
2656}
2657AFX_INLINE BOOL CXTPCalendarView::IsEditingSubject() const
2658{
2659 return !!m_ptrEditingViewEvent;
2660}
2661AFX_INLINE CString CXTPCalendarView::GetDayHeaderFormat() const
2662{
2663 return m_strHeaderFormat;
2664}
2665AFX_INLINE void CXTPCalendarView::SetDayHeaderFormat(LPCTSTR sFmt)
2666{
2667 m_strHeaderFormat = sFmt;
2668}
2669AFX_INLINE BOOL CXTPCalendarView::_IsDragModeCopyMove(int eDragMode) const
2670{
2671 return eDragMode == xtpCalendaDragModeCopy || eDragMode == xtpCalendaDragModeMove;
2672}
2673AFX_INLINE XTPCalendarEditOperation CXTPCalendarView::_DragMod2Operation(int eDragMode)
2674{
2675 return (XTPCalendarEditOperation)eDragMode;
2676}
2677AFX_INLINE void CXTPCalendarView::EnableVScroll(BOOL bEnable)
2678{
2679 m_bScrollV_Disabled = !bEnable;
2680}
2681AFX_INLINE void CXTPCalendarView::EnableHScroll(BOOL bEnable)
2682{
2683 m_bScrollH_Disabled = !bEnable;
2684}
2685AFX_INLINE BOOL CXTPCalendarView::IsHScrollEnabled() const
2686{
2687 return !m_bScrollH_Disabled;
2688}
2689AFX_INLINE BOOL CXTPCalendarView::IsVScrollEnabled() const
2690{
2691 return !m_bScrollV_Disabled;
2692}
2693AFX_INLINE void CXTPCalendarView::SetDayHeaderFormatLong(LPCTSTR pcszCustomFormat)
2694{
2695 m_strDayHeaderFormatLong = pcszCustomFormat;
2696}
2697AFX_INLINE void CXTPCalendarView::SetDayHeaderFormatShortest(LPCTSTR pcszCustomFormat)
2698{
2699 m_strDayHeaderFormatShortest = pcszCustomFormat;
2700}
2701AFX_INLINE void CXTPCalendarView::SetDayHeaderFormatMiddle(LPCTSTR pcszCustomFormat)
2702{
2703 m_strDayHeaderFormatMiddle = pcszCustomFormat;
2704}
2705AFX_INLINE void CXTPCalendarView::SetDayHeaderFormatShort(LPCTSTR pcszCustomFormat)
2706{
2707 m_strDayHeaderFormatShort = pcszCustomFormat;
2708}
2709AFX_INLINE int CXTPCalendarView::GetChildHandlersCount() const
2710{
2711 return GetViewDayCount();
2712}
2713AFX_INLINE XTP_VIEW_LAYOUT& CXTPCalendarView::GetLayout_()
2714{
2715 return m_Layout;
2716}
2717AFX_INLINE const XTP_VIEW_LAYOUT& CXTPCalendarView::GetLayout_() const
2718{
2719 return m_Layout;
2720}
2721AFX_INLINE BOOL CXTPCalendarView::IsUseCellAlignedDraggingInTimeArea() const
2722{
2723 return FALSE;
2724}
2725AFX_INLINE UINT CXTPCalendarView::GetShowToolTipTimeOut() const
2726{
2727 return XTP_CALENDAR_SHOW_BUTTON_TIMEOUT_MS;
2728}
2729AFX_INLINE void CXTPCalendarView::ClearDiscreteSelection()
2730{
2731 m_DiscreteSelection.RemoveAll();
2732}
2733AFX_INLINE UINT CXTPCalendarView::GetDiscreteSelectionCount() const
2734{
2735 return (UINT)m_DiscreteSelection.GetSize();
2736}
2737
2738AFX_INLINE int CXTPCalendarView::GetViewDayCount() const
2739{
2740 return m_arDays.GetCount();
2741}
2742
2744
2745# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
2746#endif // !defined(_XTPCALENDARVIEW_H__)
XTPCalendarViewType
XTPCalendarViewType
Enumeration used to determine the calendar view type in use.
Definition XTPCalendarDefines.h:361
XTP_CALENDAR_SHOW_BUTTON_TIMEOUT_MS
#define XTP_CALENDAR_SHOW_BUTTON_TIMEOUT_MS
Timeout before appearing event tool tip window.
Definition XTPCalendarDefines.h:153
XTPCalendarEditOperation
XTPCalendarEditOperation
Enumerates customizable event edit operations.
Definition XTPCalendarDefines.h:1264
xtpCalendarSelectionUnknown
@ xtpCalendarSelectionUnknown
Unknown selection value.
Definition XTPCalendarDefines.h:1297
XTPCalendarDraggingMode
XTPCalendarDraggingMode
Enumerates allowable dragging mode state codes.
Definition XTPCalendarDefines.h:504
xtpCalendaDragModeCopy
@ xtpCalendaDragModeCopy
Copying event.
Definition XTPCalendarDefines.h:507
xtpCalendaDragModeMove
@ xtpCalendaDragModeMove
Moving event.
Definition XTPCalendarDefines.h:508
XTPCalendarEndEditSubjectAction
XTPCalendarEndEditSubjectAction
Enumerates allowable flags for driving subject editors.
Definition XTPCalendarDefines.h:521
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTP_DEFINE_SMART_PTR_INTERNAL
#define XTP_DEFINE_SMART_PTR_INTERNAL(ClassName)
Define smart pointer for the specified class as ClassNamePtr.
Definition XTPSmartPtrInternalT.h:47
CXTPCalendarControl
Class CXTPCalendarControl implements the calendar's view interface.
Definition XTPCalendarControl.h:126
CXTPCalendarData
This class defines an abstract representation of the Calendar control data with all necessary methods...
Definition XTPCalendarData.h:97
CXTPCalendarDayViewGroup
This class represents a single resource view portion of the Calendar Day View.
Definition XTPCalendarDayViewDay.h:53
CXTPCalendarEvent
This class represents the data of a single Event used in the Calendar control.
Definition XTPCalendarEvent.h:77
CXTPCalendarEvents
This class represents a simple array collection of CXTPCalendarEvent objects.
Definition XTPCalendarEvents.h:55
CXTPCalendarOptions
Structure contains all calendar options.
Definition XTPCalendarOptions.h:77
CXTPCalendarPaintManager
Utility class, handles most of the drawing activities.
Definition XTPCalendarPaintManager.h:150
CXTPCalendarPtrCollectionT
This class represents a simple array collection of objects.
Definition XTPCalendarPtrCollectionT.h:48
CXTPCalendarPtrCollectionT::GetCount
virtual int GetCount() const
This member function is used to obtain the number of elements in the collection.
Definition XTPCalendarPtrCollectionT.h:659
CXTPCalendarResource
Class CXTPCalendarResource represents a calendar for some subject like a person, a shared resource,...
Definition XTPCalendarResource.h:339
CXTPCalendarResources
This class represents a simple array collection of CXTPCalendarResource objects.
Definition XTPCalendarResource.h:555
CXTPCalendarView::CSelectionChanged_ContextData
This class defines an internal structure used as a counter on selection changes, which is needed to r...
Definition XTPCalendarView.h:2350
CXTPCalendarView::CSelectionChanged_ContextData::m_nLockCount
int m_nLockCount
Selection change notification global Lock counter.
Definition XTPCalendarView.h:2358
CXTPCalendarView::CSelectionChanged_ContextData::CSelectionChanged_ContextData
CSelectionChanged_ContextData()
Default object constructor.
CXTPCalendarView::CSelectionChanged_ContextData::m_bRequest_Day
BOOL m_bRequest_Day
Days selection change send notification request.
Definition XTPCalendarView.h:2362
CXTPCalendarView::CSelectionChanged_ContextData::m_nLockCount_Day
int m_nLockCount_Day
Days selection change notification Lock counter.
Definition XTPCalendarView.h:2359
CXTPCalendarView::CSelectionChanged_ContextData::m_bRequest_Event
BOOL m_bRequest_Event
Events selection change send notification request.
Definition XTPCalendarView.h:2363
CXTPCalendarView::CSelectionChanged_ContextData::m_nLockCount_Event
int m_nLockCount_Event
Events selection change notification Lock counter.
Definition XTPCalendarView.h:2360
CXTPCalendarView::CSelectionChangedContext
Class CSelectionChangedContext is used to avoid multiple sending of an XTP_NC_CALENDAR_SELECTION_CHAN...
Definition XTPCalendarView.h:2312
CXTPCalendarView::CSelectionChangedContext::CSelectionChangedContext
CSelectionChangedContext(CXTPCalendarView *pView, int eSelType=xtpCalendarSelectionUnknown)
Constructs a CSelectionChangedContext object.
CXTPCalendarView::CSelectionChangedContext::~CSelectionChangedContext
virtual ~CSelectionChangedContext()
Destroys a CSelectionChangedContext object and send notification(s) if this is last locker object.
CXTPCalendarViewDay
This class represents the day view portion of the CalendarView.
Definition XTPCalendarViewDay.h:555
CXTPCalendarViewEvent
This class represents an event view portion of the CalendarViewGroup.
Definition XTPCalendarViewEvent.h:106
CXTPCalendarViewEvents
This class is used as a collection of Event View objects.
Definition XTPCalendarViewEvent.h:1004
CXTPCalendarView
This class represents the view portion of the Calendar control.
Definition XTPCalendarView.h:360
CXTPCalendarView::CanCut
virtual BOOL CanCut() const
Call this member function to determine if it is possible to perform a Cut operation.
CXTPCalendarView::_CalculateEventTimeFormat
virtual void _CalculateEventTimeFormat()
This member function is used to create the time format string.
CXTPCalendarView::m_Layout
XTP_VIEW_LAYOUT m_Layout
Layout data.
Definition XTPCalendarView.h:2398
CXTPCalendarView::GetCalendarOptions
CXTPCalendarOptions * GetCalendarOptions() const
Call this member function to get direct access to calendar options data.
CXTPCalendarView::GetTooltipRect
virtual CRect GetTooltipRect(const CPoint &ptHit, const XTP_CALENDAR_HITTESTINFO &hitInfo) const
Call this member function to obtain the bounding rectangle of the tooltip space (currently this is on...
CXTPCalendarView::SetDayHeaderFormatShortest
virtual void SetDayHeaderFormatShortest(LPCTSTR pcszCustomFormat)
This member function(s) is used to set the date format string for the day view.
Definition XTPCalendarView.h:2697
CXTPCalendarView::SetDayHeaderFormatMiddle
virtual void SetDayHeaderFormatMiddle(LPCTSTR pcszCustomFormat)
This member function(s) is used to set the date format string for the day view.
Definition XTPCalendarView.h:2701
CXTPCalendarView::OnLButtonDown
virtual BOOL OnLButtonDown(UINT nFlags, CPoint point)
This member function is used to process left mouse button events.
CXTPCalendarView::m_pUndoBuffer
CUndoBuffer * m_pUndoBuffer
Undo buffer object.
Definition XTPCalendarView.h:2377
CXTPCalendarView::_IsDragModeCopyMove
BOOL _IsDragModeCopyMove(int eDragMode) const
This method is used to determine Copy or Move dragging mode.
Definition XTPCalendarView.h:2669
CXTPCalendarView::Copy
virtual BOOL Copy()
This member function is used to perform a Copy operation.
CXTPCalendarView::m_EventTimeFormat
SEventTimeFormatInfo m_EventTimeFormat
Information used to format events times.
Definition XTPCalendarView.h:2427
CXTPCalendarView::GetViewDayCount
virtual int GetViewDayCount() const
Call this member function to obtain the number of "day views" in the view collection.
Definition XTPCalendarView.h:2738
CXTPCalendarView::_CopySelectedEvents
virtual COleDataSource * _CopySelectedEvents(DWORD dwCopyFlags=0)
This member function is used to copy selected events and CXTPCalendarEvent objects,...
CXTPCalendarView::Draw2
virtual void Draw2(CDC *pDC)
This member function is used to draw the view content using the specified device context.
Definition XTPCalendarView.h:655
CXTPCalendarView::IsInDiscreteSelection
BOOL IsInDiscreteSelection(UINT id) const
This member function checks if an event is in the selection.
CXTPCalendarView::GetEventDurationMin
virtual COleDateTimeSpan GetEventDurationMin() const
This member function is used to obtain the minimum event duration visible in the current view.
CXTPCalendarView::StartEditNewEventInplace
virtual void StartEditNewEventInplace(LPCTSTR pcszInitialSubject)
This member function is used to create a new event and start subject editing.
CXTPCalendarView::IsVScrollEnabled
virtual BOOL IsVScrollEnabled() const
This member function(s) is used to obtain the status of the vertical or horizontal scrolling features...
Definition XTPCalendarView.h:2689
CXTPCalendarView::GetRowHeight
virtual int GetRowHeight() const
Call this member function to determine the row height required to display the event.
Definition XTPCalendarView.h:2649
CXTPCalendarView::OnChar
virtual void OnChar(UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process keyboard events.
CXTPCalendarView::AdjustLayout
virtual void AdjustLayout(CDC *pDC, const CRect &rcView, BOOL bCallPostAdjustLayout=TRUE)
This member function is used to adjust the view's layout depending on the window client size and call...
CXTPCalendarView::AdjustLayout2
virtual void AdjustLayout2(CDC *pDC, const CRect &rcView, BOOL bCallPostAdjustLayout=TRUE)
This member function is used to adjust the view's layout depending on the window client size and call...
CXTPCalendarView::m_ptrEditingViewEvent
CXTPCalendarViewEventPtr m_ptrEditingViewEvent
Currently editing subject event view or event view requested to edit subject by timeout.
Definition XTPCalendarView.h:2458
CXTPCalendarView::OnEventChanged_InDataProvider
virtual XTPEnumCalendarUpdateResult OnEventChanged_InDataProvider(XTP_NOTIFY_CODE nfCode, CXTPCalendarEvent *pEvent)
This member function handles the changing of an event in the associated data provider.
CXTPCalendarView::m_ptrDraggingEventNew
CXTPCalendarEventPtr m_ptrDraggingEventNew
Editing event object.
Definition XTPCalendarView.h:2449
CXTPCalendarView::UpdateNextTimeEditByTAB
virtual void UpdateNextTimeEditByTAB(COleDateTime dtNext, BOOL bReverse, BOOL bReset=FALSE)
This member function is used to set the next date and time to start the find event view for editing e...
CXTPCalendarView::CanRedo
virtual BOOL CanRedo() const
Call this member function to determine if a redo operation is possible for the subject editor.
CXTPCalendarView::OnStartDragging
virtual void OnStartDragging(CPoint point, XTP_CALENDAR_HITTESTINFO *pHitTest)
This member function is used to start the event editing (dragging).
CXTPCalendarView::m_pResources
CXTPCalendarResources * m_pResources
Resources array.
Definition XTPCalendarView.h:2481
CXTPCalendarView::GetDraggingEventNew
virtual CXTPCalendarEvent * GetDraggingEventNew() const
This member function is used to obtain the event object that is currently being edited.
CXTPCalendarView::SelectEvent
virtual void SelectEvent(CXTPCalendarEvent *pEvent, BOOL bSelect=TRUE)
This member function is used to select or un-select the provided event.
CXTPCalendarView::_CanSubjectEditor
virtual BOOL _CanSubjectEditor(UINT idEditCmd) const
This member function is used to determine if the specified editing operation command is possible for ...
CXTPCalendarView::CommitDraggingEvent
virtual BOOL CommitDraggingEvent()
This member function is used to commit the event editing (dragging) operation.
CXTPCalendarView::SelectDay
virtual void SelectDay(COleDateTime dtSelDay, int nGroupIndex=0)
This member function is used to select or un-select the day identified by the provided date.
CXTPCalendarView::GetItemTextEventTimeMax
virtual CString GetItemTextEventTimeMax() const
This member function is called by the calendar framework to retrieve an event time string of maximum ...
CXTPCalendarView::m_strDayHeaderFormatDefaultMiddle
CString m_strDayHeaderFormatDefaultMiddle
Day header Middle date format default string.
Definition XTPCalendarView.h:2437
CXTPCalendarView::ShowDay
virtual void ShowDay(const COleDateTime &date, BOOL bSelect=TRUE)=0
This member function is used to show the specified day in the calendar view.
CXTPCalendarView::_Undo
virtual BOOL _Undo(CXTPCalendarEvent *pEvent=NULL)
This member function is used to perform an undo/redo operation for the specified event.
CXTPCalendarView::OnSysKeyDown
virtual BOOL OnSysKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process system keyboard events.
CXTPCalendarView::CanCopy
virtual BOOL CanCopy() const
Call this member function to determine if it is possible to perform a Copy operation.
CXTPCalendarView::SelectionContains
BOOL SelectionContains(COleDateTime date, int nGroupIndex=-1, BOOL *pbAllDaySelection=NULL)
This member function is used to determine if a date time value is contained inside the selection.
CXTPCalendarView::m_pControl
CXTPCalendarControl * m_pControl
Pointer to the owner control object.
Definition XTPCalendarView.h:2466
CXTPCalendarView::ResetSelection
void ResetSelection()
This member function resets the current selection - set it empty.
CXTPCalendarView::FormatEventTime
virtual CString FormatEventTime(COleDateTime dtTime) const
This member function is used to format the time using the provided format.
CXTPCalendarView::_GetMaxWidth
virtual int _GetMaxWidth(CDC *pDC, CString strFormat) const
This member function is used to calculate, in pixels, the max date width for the specified format str...
CXTPCalendarView::Populate
virtual void Populate()
This member function is used to populate the view with data for all items contained in the view.
CXTPCalendarView::EnableVScroll
virtual void EnableVScroll(BOOL bEnable=TRUE)
This member function(s) is used to disable or enable vertical or horizontal scrolling of the view (by...
Definition XTPCalendarView.h:2677
CXTPCalendarView::OnScrollEnd
virtual void OnScrollEnd(int nBar)
This member function is used to force scroll to the end of the scroll range.
Definition XTPCalendarView.h:569
CXTPCalendarView::OnEndDragging
virtual BOOL OnEndDragging(CPoint point, XTP_CALENDAR_HITTESTINFO *pHitInfo)
This member function is used to finish the event editing (dragging) operation.
CXTPCalendarView::HitTest
virtual BOOL HitTest(CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const
This member function is used to determines which view item, if any, is at a specified position index,...
CXTPCalendarView::IsSingleEventSelected
BOOL IsSingleEventSelected() const
This member function is used to determine if just one event is selected.
CXTPCalendarView::m_selectedBlock
XTP_CALENDAR_VIEWSELECTION m_selectedBlock
Current selection.
Definition XTPCalendarView.h:2476
CXTPCalendarView::GetViewDayDate
virtual COleDateTime GetViewDayDate(int nIndex) const =0
Call this member function to obtain the date of the day view by the day's index.
CXTPCalendarView::m_strDayHeaderFormatShortest
CString m_strDayHeaderFormatShortest
Day header Shortest date format custom string.
Definition XTPCalendarView.h:2434
CXTPCalendarView::RedrawControl
virtual void RedrawControl()
This member function is used to perform the redrawing of the control's layout.
CXTPCalendarView::OnLButtonUp
virtual BOOL OnLButtonUp(UINT nFlags, CPoint point)
This member function is used to process left mouse button events.
CXTPCalendarView::_GetSubjectEditorWnd
virtual CWnd * _GetSubjectEditorWnd() const
This member function is used to obtain a pointer to the event subject editor window.
CXTPCalendarView::FindViewEvent
virtual CXTPCalendarViewEvent * FindViewEvent(CXTPCalendarEvent *pEvent, COleDateTime dtDay) const
This member function is used to obtain the event view object for the specified event and day.
CXTPCalendarView::GetSelection
virtual BOOL GetSelection(COleDateTime *pBegin=NULL, COleDateTime *pEnd=NULL, BOOL *pbAllDayEvent=NULL, int *pnGroupIndex=NULL, COleDateTimeSpan *pspSelectionResolution=NULL) const
This member function is used to obtain the view's selection.
CXTPCalendarView::GetResources
virtual CXTPCalendarResources * GetResources() const
Call this member function to obtain a pointer to the associated Calendar Resources collection object.
CXTPCalendarView::CanUndo
virtual BOOL CanUndo() const
Call this member function to determine if you can perform an undo operation for the subject editor.
CXTPCalendarView::Paste
virtual BOOL Paste()
This member function is used to perform a Paste operation.
CXTPCalendarView::IsHScrollEnabled
virtual BOOL IsHScrollEnabled() const
This member function(s) is used to obtain the status of the vertical or horizontal scrolling features...
Definition XTPCalendarView.h:2685
CXTPCalendarView::KillTimer
virtual void KillTimer(UINT uTimerID)
This member function is used to destroy a timer event.
CXTPCalendarView::ScrollH
virtual void ScrollH(int nPos, int nPos_raw)
Scroll horizontally.
Definition XTPCalendarView.h:557
CXTPCalendarView::GetLastSelectedViewEvent
CXTPCalendarViewEvent * GetLastSelectedViewEvent() const
This member function is used to obtain the last selected event view.
CXTPCalendarView::OnActivateView
virtual void OnActivateView(BOOL bActivate, CXTPCalendarView *pActivateView, CXTPCalendarView *pInactiveView)
This member function is called by the framework view when it is activated or deactivated.
CXTPCalendarView::m_pSelectedEvents
CXTPCalendarViewEvents * m_pSelectedEvents
Selected Events;.
Definition XTPCalendarView.h:2468
CXTPCalendarView::SelectDay
virtual void SelectDay(CXTPCalendarViewDay *pDay, int nGroupIndex=0)
This member function is used to select or un-select the provided day, including all of the day's even...
CXTPCalendarView::m_arDays
CXTPCalendarPtrCollectionT< CXTPCalendarViewDay > m_arDays
Stores the view day collection.
Definition XTPCalendarView.h:2487
CXTPCalendarView::OnKeyDown
virtual void OnKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to processes keyboard events.
CXTPCalendarView::m_strHeaderFormat
CString m_strHeaderFormat
Day header active date format string.
Definition XTPCalendarView.h:2429
CXTPCalendarView::StartEditSubject
virtual void StartEditSubject(CXTPCalendarViewEvent *pViewEvent)
This member function is used to start the event subject editing.
CXTPCalendarView::m_cntSelChanged
CSelectionChanged_ContextData m_cntSelChanged
Counter on selection changes,.
Definition XTPCalendarView.h:2366
CXTPCalendarView::m_strDayHeaderFormatDefaultLong
CString m_strDayHeaderFormatDefaultLong
Day header Long date format default string.
Definition XTPCalendarView.h:2436
CXTPCalendarView::m_pPrevUndoBuffer
CUndoBuffer * m_pPrevUndoBuffer
Undo buffer data after last undo buffer clean.
Definition XTPCalendarView.h:2376
CXTPCalendarView::ProcessDaySelection
virtual void ProcessDaySelection(XTP_CALENDAR_HITTESTINFO *pInfo, UINT nFlags)
This member function is used to process the days selection that are selected with the mouse.
CXTPCalendarView::_ReadEventsFromClipboard
virtual CXTPCalendarEventsPtr _ReadEventsFromClipboard(COleDataObject *pData, DWORD *pdwCopyFlags=NULL)
This member function is used to read events and CXTPCalendarEvent objects, from a COleDataSource obje...
CXTPCalendarView::SetDraggingEvent
virtual BOOL SetDraggingEvent(CXTPCalendarEvent *pEventOrig)
This member function is used to prepare the event to event editing (dragging) operation.
CXTPCalendarView::m_rcTooltip
CRect m_rcTooltip
Last shown tooltip rect (while GetTooltipRect returns calculated currently required tooltip rect)
Definition XTPCalendarView.h:2444
CXTPCalendarView::IsEditOperationDisabledNotify
BOOL IsEditOperationDisabledNotify(XTPCalendarEditOperation eOperation, CXTPCalendarViewEvent *pEventView) const
This method is used to determine if specified editing operation is disabled.
CXTPCalendarView::GetPaintManager
virtual CXTPCalendarPaintManager * GetPaintManager() const
Call this member function to obtain the PaintManager object.
CXTPCalendarView::CalculateHeaderFormat
virtual void CalculateHeaderFormat(CDC *pDC, int nWidth, CFont *pTextFont)
This member function creates the day header format string.
CXTPCalendarView::_RemoveYearPart
virtual void _RemoveYearPart(CString &strFormat)
This member function is used to remove the year part from the specified format string.
CXTPCalendarView::Draw
virtual void Draw(CDC *pDC)
This member function is used to draw the view content using the specified device context.
Definition XTPCalendarView.h:635
CXTPCalendarView::m_ptStartDragging
CPoint m_ptStartDragging
Request to start dragging operation from this point.
Definition XTPCalendarView.h:2453
CXTPCalendarView::m_eDraggingMode
XTPCalendarDraggingMode m_eDraggingMode
Editing event mode.
Definition XTPCalendarView.h:2455
CXTPCalendarView::OnBeforeEditOperationNotify
BOOL OnBeforeEditOperationNotify(XTPCalendarEditOperation eOperation, CXTPCalendarViewEvent *pEventView)
This method is used to customize or disable specified editing operation.
CXTPCalendarView::ProcessEventSelection
virtual void ProcessEventSelection(XTP_CALENDAR_HITTESTINFO *pInfo, UINT nFlags)
This member function is used to process events that are selected with the mouse.
CXTPCalendarView::SetDayHeaderFormatLong
virtual void SetDayHeaderFormatLong(LPCTSTR pcszCustomFormat)
This member function(s) is used to set the date format string for the day view.
Definition XTPCalendarView.h:2693
CXTPCalendarView::_GetViewDay
virtual CXTPCalendarViewDay * _GetViewDay(const COleDateTime &dtDay) const
Call this member function to obtain the CXTPCalendarViewDay object by the day's index.
CXTPCalendarView::m_bResetUndoBuffer
BOOL m_bResetUndoBuffer
Clean undo buffer before add next undo action.
Definition XTPCalendarView.h:2374
CXTPCalendarView::OnBeforePasteNotify
BOOL OnBeforePasteNotify(CXTPCalendarEvent *pEvent, BOOL bPasteWillChangeExistingEvent)
This method is used to customize or disable paste editing operation.
CXTPCalendarView::OnBeforeEditOperationNotify
BOOL OnBeforeEditOperationNotify(XTPCalendarEditOperation eOperation, CXTPCalendarViewEvents *pEventViews)
This method is used to customize or disable specified editing operation.
CXTPCalendarView::RetrieveDayEvents
virtual CXTPCalendarEventsPtr RetrieveDayEvents(CXTPCalendarResource *pRC, COleDateTime dtDay)
Call this member function to get the collection of the day's events.
CXTPCalendarView::Cut
virtual BOOL Cut()
This member function is used to perform a Cut operation.
CXTPCalendarView::GetNextTimeEditByTAB
virtual COleDateTime GetNextTimeEditByTAB() const
This member function is used to obtain the next date and time to start the find event view for editin...
CXTPCalendarView::OnDragging
virtual BOOL OnDragging(CPoint point, XTP_CALENDAR_HITTESTINFO *pHitTest)
This member function is used to perform the event editing (dragging) operation step.
CXTPCalendarView::GetDayHeaderFormat
virtual CString GetDayHeaderFormat() const
Call this member function to determine the current format string.
Definition XTPCalendarView.h:2661
CXTPCalendarView::SelectViewEvent
void SelectViewEvent(CXTPCalendarViewEvent *pViewEvent, BOOL bSelect=TRUE)
This member function is used to select or un-select the provided event.
CXTPCalendarView::SendNotification
virtual void SendNotification(XTP_NOTIFY_CODE EventCode, WPARAM wParam=0, LPARAM lParam=0)
This member function is used to send a notification from the parent Calendar control.
CXTPCalendarView::SelectDays
virtual void SelectDays(COleDateTime dtNewSel)
This member function is used to change the days selection depending on the previous state of the sele...
CXTPCalendarView::GetSubjectEditorRect
virtual CRect GetSubjectEditorRect() const
Call this member function to obtain the bounding rectangle of the subject editor.
CXTPCalendarView::GetSelectedEvents
virtual CXTPCalendarViewEventsPtr GetSelectedEvents() const
Call this member function to obtain a pointer to a selected event's views collection.
CXTPCalendarView::SetDayHeaderFormat
virtual void SetDayHeaderFormat(LPCTSTR sFmt)
Call this member function to set the day header format.
Definition XTPCalendarView.h:2665
CXTPCalendarView::GetDraggingEventOrig
virtual CXTPCalendarEvent * GetDraggingEventOrig() const
This member function is used to obtain the event object before the start of the event editing (draggi...
CXTPCalendarView::Undo
virtual BOOL Undo()
This member function is used to perform an Undo operation.
CXTPCalendarView::m_rcView
CRect m_rcView
Client rect.
Definition XTPCalendarView.h:2443
CXTPCalendarView::UnselectAllEvents
virtual void UnselectAllEvents()
Call this member function to un-select all of the events of the current view.
CXTPCalendarView::GetViewRect
CRect GetViewRect() const
Call this member function to obtain the view's bounding rectangle.
Definition XTPCalendarView.h:2641
CXTPCalendarView::OnUpdateEditingSubject
virtual void OnUpdateEditingSubject(CString strNewSubject)
Call this member function to set the new subject text for the editing event.
CXTPCalendarView::GetDraggingMode
virtual XTPCalendarDraggingMode GetDraggingMode() const
Call this member function to determine the current dragging mode.
Definition XTPCalendarView.h:2645
CXTPCalendarView::OnInPlaceCreateEvent
BOOL OnInPlaceCreateEvent(LPCTSTR pcszInitialSubject)
This method is used to customize or disable xtpCalendarEO_InPlaceCreateEvent editing operation.
CXTPCalendarView::m_ptrDraggingEventOrig
CXTPCalendarEventPtr m_ptrDraggingEventOrig
Event object before start event editing.
Definition XTPCalendarView.h:2448
CXTPCalendarView::m_strDayHeaderFormatDefaultShort
CString m_strDayHeaderFormatDefaultShort
Day header Short date format default string.
Definition XTPCalendarView.h:2439
CXTPCalendarView::m_strDayHeaderFormatDefaultShortest
CString m_strDayHeaderFormatDefaultShortest
Day header Shortest date format default string.
Definition XTPCalendarView.h:2440
CXTPCalendarView::SetCustomTimeFormat
void SetCustomTimeFormat(const CString &strFormat)
This member function is used to set custom time format for view.
CXTPCalendarView::ResetCustomTimeFormat
void ResetCustomTimeFormat()
Reset custom time format to default.
CXTPCalendarView::GetSelectedViewEvents
virtual CXTPCalendarViewEvents * GetSelectedViewEvents() const
Call this member function to obtain a pointer to a selected event's views.
CXTPCalendarView::m_bScrollH_Disabled
BOOL m_bScrollH_Disabled
Is horizontal scrolling disabled for a view.
Definition XTPCalendarView.h:2479
CXTPCalendarView::CXTPCalendarView
CXTPCalendarView(CXTPCalendarControl *pCalendarControl)
Default object constructor.
CXTPCalendarView::AddToDiscreteSelection
BOOL AddToDiscreteSelection(UINT id)
This member function adds an event to the selection by using its event ordinal number.
CXTPCalendarView::_GetDayHeaderFormat
virtual CString _GetDayHeaderFormat(int nLevel) const
This member function gets a custom or default day header date format string.
CXTPCalendarView::m_strDayHeaderFormatShort
CString m_strDayHeaderFormatShort
Day header Short date format custom string.
Definition XTPCalendarView.h:2433
CXTPCalendarView::ShowToolTip
virtual void ShowToolTip(BOOL bShow=TRUE)
This member function is used to show/hide a ToolTip rectangle.
CXTPCalendarView::ClearDiscreteSelection
void ClearDiscreteSelection()
This member function is used to Clear Discrete Selection.
Definition XTPCalendarView.h:2729
CXTPCalendarView::OnDraw
virtual void OnDraw(CDC *pDC)
This member function performs all of the drawing logic of the calendar view.
CXTPCalendarView::FindEventToEditByTAB
virtual CXTPCalendarViewEvent * FindEventToEditByTAB(COleDateTime dtMinStart, BOOL bReverse, CXTPCalendarEvent *pAfterEvent=NULL)
This member function is used to obtain the next event view object used for editing events by pressing...
CXTPCalendarView::m_strDayHeaderFormatMiddle
CString m_strDayHeaderFormatMiddle
Day header Middle date format custom string.
Definition XTPCalendarView.h:2432
CXTPCalendarView::m_nTimerID_StartEditSubject
UINT m_nTimerID_StartEditSubject
Timer ID of edit event subject request.
Definition XTPCalendarView.h:2463
CXTPCalendarView::SetTimer
virtual UINT SetTimer(UINT uTimeOut_ms)
This member function is used to create a timer event.
CXTPCalendarView::GetChildHandlerAt
virtual CXTPCalendarWMHandler * GetChildHandlerAt(int nIndex) const
Call this method to get a handler object at the specified numeric index.
CXTPCalendarView::IsEditingSubject
virtual BOOL IsEditingSubject() const
Call this member function to determine if the subject is in an editable mode.
Definition XTPCalendarView.h:2657
CXTPCalendarView::SetDayHeaderFormatShort
virtual void SetDayHeaderFormatShort(LPCTSTR pcszCustomFormat)
This member function(s) is used to set the date format string for the day view.
Definition XTPCalendarView.h:2705
CXTPCalendarView::m_eUndoMode
int m_eUndoMode
Undo mode, see XTPCalendarUndoMode.
Definition XTPCalendarView.h:2373
CXTPCalendarView::m_nKeyStateTimerID
UINT m_nKeyStateTimerID
Timer ID to check Keys state (like Control).
Definition XTPCalendarView.h:2474
CXTPCalendarView::CancelDraggingEvent
virtual void CancelDraggingEvent()
This member function is used to cancel the event editing (dragging) operation.
CXTPCalendarView::m_strDayHeaderFormatLong
CString m_strDayHeaderFormatLong
Day header Long date format custom string.
Definition XTPCalendarView.h:2431
CXTPCalendarView::GetCalendarControl
CXTPCalendarControl * GetCalendarControl() const
Call this member function to obtain a pointer to the Calendar Control object.
Definition XTPCalendarView.h:2637
CXTPCalendarView::OnMouseMove
virtual void OnMouseMove(UINT nFlags, CPoint point)
This member function is used to process mouse movement events.
CXTPCalendarView::GetDiscreteSelectionCount
UINT GetDiscreteSelectionCount() const
This member function is used to get the number of selected events.
Definition XTPCalendarView.h:2733
CXTPCalendarView::SetResources
virtual void SetResources(CXTPCalendarResources *pResources)
This member function sets the new Resources collection for the view.
CXTPCalendarView::GetTheme
virtual CXTPCalendarTheme * GetTheme() const
This member function obtains a pointer to the associated theme object.
CXTPCalendarView::HasSelectedViewEvent
virtual BOOL HasSelectedViewEvent() const
Call this member function to determine if any view event is selected.
CXTPCalendarView::IsTodayVisible
virtual BOOL IsTodayVisible() const
Call this member function to determine if Today is visible.
CXTPCalendarView::EndEditSubject
virtual void EndEditSubject(XTPCalendarEndEditSubjectAction eAction, BOOL bUpdateControl=TRUE)
This member function is used to finish the event subject editing.
CXTPCalendarView::SetSelection
void SetSelection(const COleDateTime &dtBegin, const COleDateTime &dtEnd, BOOL bAllDayEvent=FALSE, int nGroupIndex=0)
This member function sets the new selection for the view.
CXTPCalendarView::OnBeforeDestroy
virtual void OnBeforeDestroy()
This member function is called by the framework before destroying the view.
CXTPCalendarView::m_bScrollV_Disabled
BOOL m_bScrollV_Disabled
Is vertical scrolling disabled for a view.
Definition XTPCalendarView.h:2478
CXTPCalendarView::EnableHScroll
virtual void EnableHScroll(BOOL bEnable=TRUE)
This member function(s) is used to disable or enable vertical or horizontal scrolling of the view (by...
Definition XTPCalendarView.h:2681
CXTPCalendarView::GetShowToolTipTimeOut
virtual UINT GetShowToolTipTimeOut() const
This member function is used to obtain the timeout value for displaying a tooltip.
Definition XTPCalendarView.h:2725
CXTPCalendarView::_GetMaxWidthFormat
virtual CString _GetMaxWidthFormat(CDC *pDC, CString strFormat, BOOL bMonth) const
This function is used to calculate the max width of the date used in the specified format string.
CXTPCalendarView::OnTimer
virtual BOOL OnTimer(UINT_PTR uTimerID)
The framework calls this member function after each interval specified in the SetTimer member functio...
CXTPCalendarView::GetStartEditSubjectTimeOut
virtual UINT GetStartEditSubjectTimeOut() const
This member function is used to obtain the time value after a mouse click event in the subject editin...
Definition XTPCalendarView.h:2653
CXTPCalendarView::EmptyUndoBuffer
virtual void EmptyUndoBuffer()
This member function is used to erase the undo buffer.
CXTPCalendarView::FindLastSelectedDay
int FindLastSelectedDay() const
This member function is used to obtain the last selected day index.
CXTPCalendarView::GetScrollBarInfoV
virtual BOOL GetScrollBarInfoV(SCROLLINFO *pSI) const
This member function is used to retrieve the information about a scroll bar state.
Definition XTPCalendarView.h:586
CXTPCalendarView::Redo
virtual BOOL Redo()
This member function is used to perform a Redo operation.
CXTPCalendarView::CanPaste
virtual BOOL CanPaste() const
Call this member function to determine if it is possible to perform a Paste operation.
CXTPCalendarView::m_nTimerID_ShowToolTip
UINT m_nTimerID_ShowToolTip
Timer ID of start show tooltip request.
Definition XTPCalendarView.h:2464
CXTPCalendarView::m_spDraggingStartOffset
COleDateTimeSpan m_spDraggingStartOffset
Start dragging operation offset from the beginning of the event.
Definition XTPCalendarView.h:2451
CXTPCalendarView::GetScrollBarInfoH
virtual BOOL GetScrollBarInfoH(SCROLLINFO *pSI, int *pnScrollStep=NULL) const
This member function is used to retrieve the information about a scroll bar state.
Definition XTPCalendarView.h:604
CXTPCalendarView::m_bStartedClickInside
BOOL m_bStartedClickInside
Is OnLButtonDown was inside view rect.
Definition XTPCalendarView.h:2456
CXTPCalendarView::~CXTPCalendarView
virtual ~CXTPCalendarView()
Default class destructor.
CXTPCalendarView::GetChildHandlersCount
virtual int GetChildHandlersCount() const
This member function is used to obtain the number of CXTPCalendarWMHandler elements in the descendant...
Definition XTPCalendarView.h:2709
CXTPCalendarView::OnLButtonDblClk
virtual BOOL OnLButtonDblClk(UINT nFlags, CPoint point)
This member function is used to process mouse double-click events.
CXTPCalendarView::m_pLastEvent
CXTPCalendarViewEvent * m_pLastEvent
Last selected event.
Definition XTPCalendarView.h:2462
CXTPCalendarView::m_LastHitInfo
XTP_CALENDAR_HITTESTINFO m_LastHitInfo
Last HitInfo data.
Definition XTPCalendarView.h:2470
CXTPCalendarView::GetViewType
virtual XTPCalendarViewType GetViewType() const =0
Call this member function to obtain the view type flag.
CXTPCalendarView::GetLastSelectedDate
COleDateTime GetLastSelectedDate() const
This member function is used to obtain the last selected day date.
CXTPCalendarView::ScrollV
virtual void ScrollV(int nPos, int nPos_raw)
Scroll vertically.
Definition XTPCalendarView.h:540
CXTPCalendarView::GetDiscreteSelectionValue
COleDateTime GetDiscreteSelectionValue(UINT id) const
This member function gets a selected event by using its event ordinal number.
CXTPCalendarView::_ReadDefaultHeaderFormats
virtual void _ReadDefaultHeaderFormats()
This member function is used to build day header date format default strings.
CXTPCalendarView::HitTestEx
virtual BOOL HitTestEx(CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const
This member function is used to determine which view item, if any, is at a specified position index,...
CXTPCalendarView::GetViewDay_
virtual CXTPCalendarViewDay * GetViewDay_(int nIndex) const
Call this member function to obtain the CXTPCalendarViewDay object by the day's index.
CXTPCalendarViewPart
Helper base class to implement parts for calendar paint manager.
Definition XTPCalendarViewPart.h:1228
CXTPCalendarViewT
This template class represents a view portion of the Calendar control.
Definition XTPCalendarView.h:2571
CXTPCalendarViewT::~CXTPCalendarViewT
virtual ~CXTPCalendarViewT()
Default class destructor.
Definition XTPCalendarView.h:2597
CXTPCalendarViewT::GetViewType
virtual XTPCalendarViewType GetViewType() const
Call this member function to obtain the view type flag.
Definition XTPCalendarView.h:2607
CXTPCalendarViewT::GetViewDay
virtual _TViewDay * GetViewDay(int nIndex) const
Call this member function to obtain a _TViewDay object corresponding with the day's index.
Definition XTPCalendarView.h:2628
CXTPCalendarViewT::CXTPCalendarViewT
CXTPCalendarViewT(CXTPCalendarControl *pCalendarControl, XTPCalendarViewType nViewType)
Default object constructor.
Definition XTPCalendarView.h:2584
CXTPCalendarWMHandler
This class helps to handle Windows messages (WM_*) processing portion of the Calendar control views.
Definition XTPCalendarView.h:100
CXTPCalendarWMHandler::OnLButtonDown
virtual BOOL OnLButtonDown(UINT nFlags, CPoint point)
This member function is used to process left mouse button down events.
CXTPCalendarWMHandler::OnChar
virtual void OnChar(UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process keyboard events.
CXTPCalendarWMHandler::OnSysKeyDown
virtual BOOL OnSysKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process key-up keyboard events.
CXTPCalendarWMHandler::OnPostAdjustLayout
virtual void OnPostAdjustLayout()
This member function is used to perform additional adjustments in some kinds of views.
CXTPCalendarWMHandler::OnLButtonUp
virtual BOOL OnLButtonUp(UINT nFlags, CPoint point)
This member function is used to process left mouse button up events.
CXTPCalendarWMHandler::OnKeyDown
virtual void OnKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process key-down keyboard events.
CXTPCalendarWMHandler::OnKeyUp
virtual void OnKeyUp(UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process key-up keyboard events.
CXTPCalendarWMHandler::OnWndMsg
virtual BOOL OnWndMsg(UINT message, WPARAM wParam, LPARAM lParam, LRESULT *pResult)
This method is called by framework after default message processing.
CXTPCalendarWMHandler::GetChildHandlersCount
virtual int GetChildHandlersCount() const
This member function is used to obtain the number of CXTPCalendarWMHandler elements in the descendant...
CXTPCalendarWMHandler::CXTPCalendarWMHandler
CXTPCalendarWMHandler()
Default object constructor.
CXTPCalendarWMHandler::GetChildHandlerAt
virtual CXTPCalendarWMHandler * GetChildHandlerAt(int nIndex) const
Call this method to get a handler object at the specified numeric index.
CXTPCalendarWMHandler::OnMouseMove
virtual void OnMouseMove(UINT nFlags, CPoint point)
This member function is used to process mouse movement events.
CXTPCalendarWMHandler::OnBeforeDestroy
virtual void OnBeforeDestroy()
This member function is called by the framework before destroying the view.
CXTPCalendarWMHandler::OnTimer
virtual BOOL OnTimer(UINT_PTR uTimerID)
The framework calls this member function after each interval specified in the SetTimer member functio...
CXTPCalendarWMHandler::OnLButtonDblClk
virtual BOOL OnLButtonDblClk(UINT nFlags, CPoint point)
This member function is used to process left mouse button double click events.
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPCalendarView::SEventTimeFormatInfo
Definition XTPCalendarView.h:2409
CXTPCalendarView::SEventTimeFormatInfo::SEventTimeFormatInfo
SEventTimeFormatInfo()
Default object constructor.
Definition XTPCalendarView.h:2420
CXTPCalendarView::SEventTimeFormatInfo::strFormat
CString strFormat
Time format string.
Definition XTPCalendarView.h:2410
CXTPCalendarView::SEventTimeFormatInfo::strPM
CString strPM
PM symbol.
Definition XTPCalendarView.h:2412
CXTPCalendarView::SEventTimeFormatInfo::b24_HFormat
BOOL b24_HFormat
Is 24 hours time format.
Definition XTPCalendarView.h:2413
CXTPCalendarView::SEventTimeFormatInfo::strAM
CString strAM
AM symbol.
Definition XTPCalendarView.h:2411
XTP_CALENDAR_HITTESTINFO
Basic set of parameters transferred from calendar items to mouse handlers.
Definition XTPCalendarDefines.h:856
XTP_CALENDAR_VIEWSELECTION
Structure contains the calendar day view selection block.
Definition XTPCalendarDefines.h:615


Toolkit Pro: XTPChartOpenGLTransformationDeviceCommand.h Source File

  • Source
  • Chart
  • Drawing
  • OpenGL
XTPChartOpenGLTransformationDeviceCommand.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTOPENGLTRANSFORMATIONDEVICECOMMAND_H__)
24# define __XTPCHARTOPENGLTRANSFORMATIONDEVICECOMMAND_H__
25
26# if _MSC_VER >= 1000
27# pragma once
28# endif // _MSC_VER >= 1000
29
30# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
31
32template<class T>
33class CXTPMatrix;
34
35class CXTPChart3dRotation;
36
37class _XTP_EXT_CLASS CXTPChartOpenGLSaveMatrixDeviceCommand : public CXTPChart3dDeviceCommand
38{
39public:
40 CXTPChartOpenGLSaveMatrixDeviceCommand();
41
42public:
43 virtual void BeforeExecute(CXTPChartDeviceContext* pDC);
44 virtual void AfterExecute(CXTPChartDeviceContext* pDC);
45};
46
47class _XTP_EXT_CLASS CXTPChartOpenGLLoadIdentityDeviceCommand : public CXTPChart3dDeviceCommand
48{
49public:
50 CXTPChartOpenGLLoadIdentityDeviceCommand();
51
52public:
53 virtual void ExecuteOverride(CXTPChartDeviceContext* pDC);
54};
55
56class _XTP_EXT_CLASS CXTPChartOpenGLMultiplyMatrixDeviceCommand : public CXTPChart3dDeviceCommand
57{
58public:
59 CXTPChartOpenGLMultiplyMatrixDeviceCommand(const CXTPMatrix<double>& matrix, BOOL bPushMatrix);
60 ~CXTPChartOpenGLMultiplyMatrixDeviceCommand();
61
62public:
63 virtual void BeforeExecute(CXTPChartDeviceContext* pDC);
64 virtual void ExecuteOverride(CXTPChartDeviceContext* pDC);
65 virtual void AfterExecute(CXTPChartDeviceContext* pDC);
66
67private:
68 CXTPMatrix<double>* m_pMatrix;
69 BOOL m_bPushMatrix;
70};
71
77class _XTP_EXT_CLASS CXTPChartOpenGLRotateDeviceCommand : public CXTPChart3dRotateDeviceCommand
78{
79public:
86 CXTPChartOpenGLRotateDeviceCommand(const CXTPChart3dRotation& rotation);
87
88public:
97 virtual void ExecuteOverride(CXTPChartDeviceContext* pDC);
98};
99
105class _XTP_EXT_CLASS CXTPChartOpenGLTranslateDeviceCommand
106 : public CXTPChart3dTranslateDeviceCommand
107{
108public:
116 CXTPChartOpenGLTranslateDeviceCommand(double dx, double dy, double dz);
117
118public:
127 virtual void ExecuteOverride(CXTPChartDeviceContext* pDC);
128};
129
130# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
131#endif //#if !defined(__XTPCHARTOPENGLTRANSFORMATIONDEVICECOMMAND_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChart3dDeviceCommand
Defines a common implementation interface for chart 3D drawing commands.
Definition XTPChartDeviceCommand.h:368
CXTPChart3dRotateDeviceCommand
Base class implementation for 3D chart rotation device command.
Definition XTPChartTransformationDeviceCommand.h:96
CXTPChart3dRotation
Represents a 3D rotation primitive for chart objects using Euler angles Yaw, Pitch and Roll in degree...
Definition XTPChartTypes.h:639
CXTPChart3dTranslateDeviceCommand
Base class implementation for 3D chart translation device command.
Definition XTPChartTransformationDeviceCommand.h:148
CXTPChartDeviceCommand::AfterExecute
virtual void AfterExecute(CXTPChartDeviceContext *pDC)
This method gets called after a command is executed which allows for the customization of command beh...
CXTPChartDeviceCommand::BeforeExecute
virtual void BeforeExecute(CXTPChartDeviceContext *pDC)
This method gets called before a command is executed which allows for the customization of command be...
CXTPChartDeviceCommand::ExecuteOverride
virtual void ExecuteOverride(CXTPChartDeviceContext *pDC)
Override this function to write the drawing code for specific objects.
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPMatrix
Represents a matrix object built upon a continuos array of elements and provides basic algorithms for...
Definition XTPMatrix.h:40


Toolkit Pro: XTPMarkupCanvas.h Source File

  • Source
  • Markup
  • Controls
XTPMarkupCanvas.h
Go to the documentation of this file.
1
23#if !defined(__XTPMARKUPCANVAS_H__)
24# define __XTPMARKUPCANVAS_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPMarkupUIElement;
34class CXTPMarkupDrawingContext;
35class CXTPMarkupDependencyProperty;
36
37class _XTP_EXT_CLASS CXTPMarkupCanvas : public CXTPMarkupPanel
38{
40 DECLARE_MARKUPCLASS(CXTPMarkupCanvas)
42protected:
43 CXTPMarkupCanvas();
44 virtual ~CXTPMarkupCanvas();
45
46public:
47 static void AFX_CDECL SetLeft(CXTPMarkupUIElement* pElement, int nLeft);
48 static void AFX_CDECL SetTop(CXTPMarkupUIElement* pElement, int nTop);
49 static void AFX_CDECL SetRight(CXTPMarkupUIElement* pElement, int nRight);
50 static void AFX_CDECL SetBottom(CXTPMarkupUIElement* pElement, int nBottom);
51
52 static int AFX_CDECL GetLeft(CXTPMarkupUIElement* pElement);
53 static int AFX_CDECL GetTop(CXTPMarkupUIElement* pElement);
54 static int AFX_CDECL GetRight(CXTPMarkupUIElement* pElement);
55 static int AFX_CDECL GetBottom(CXTPMarkupUIElement* pElement);
56
57 static BOOL AFX_CDECL TryGetLeft(CXTPMarkupUIElement* pElement, int& nValue);
58 static BOOL AFX_CDECL TryGetTop(CXTPMarkupUIElement* pElement, int& nValue);
59 static BOOL AFX_CDECL TryGetRight(CXTPMarkupUIElement* pElement, int& nValue);
60 static BOOL AFX_CDECL TryGetBottom(CXTPMarkupUIElement* pElement, int& nValue);
61
62protected:
73 virtual CSize MeasureOverride(CXTPMarkupDrawingContext* pDC, CSize availableSize);
74 virtual CSize ArrangeOverride(CSize arrangeSize);
75
77public:
78 DECLARE_DISPATCH_MAP()
79# ifdef _XTP_ACTIVEX
80 DECLARE_INTERFACE_MAP()
81 DECLARE_OLETYPELIB_EX(CXTPMarkupTextBlock);
82# endif
83
84 afx_msg void OleSetLeft(LPDISPATCH lpElementDisp, int nValue);
85 afx_msg void OleSetRight(LPDISPATCH lpElementDisp, int nValue);
86 afx_msg void OleSetTop(LPDISPATCH lpElementDisp, int nValue);
87 afx_msg void OleSetBottom(LPDISPATCH lpElementDisp, int nValue);
88 afx_msg int OleGetLeft(LPDISPATCH lpElementDisp);
89 afx_msg int OleGetTop(LPDISPATCH lpElementDisp);
90 afx_msg int OleGetRight(LPDISPATCH lpElementDisp);
91 afx_msg int OleGetBottom(LPDISPATCH lpElementDisp);
94public:
95 static CXTPMarkupDependencyProperty* m_pTopProperty;
96 static CXTPMarkupDependencyProperty* m_pLeftProperty;
97 static CXTPMarkupDependencyProperty* m_pRightProperty;
98 static CXTPMarkupDependencyProperty* m_pBottomProperty;
99};
100
101# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
103#endif // !defined(__XTPMARKUPCANVAS_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPMarkupPanel
CXTPMarkupPanel is a CXTPMarkupFrameworkElement derived class.
Definition XTPMarkupPanel.h:48
CXTPMarkupTextBlock
CXTPMarkupTextBlock is a CXTPMarkupFrameworkElement derived class.
Definition XTPMarkupTextBlock.h:86
CXTPMarkupUIElement
Base class for XML Markup core level implementations.
Definition XTPMarkupUIElement.h:43


Toolkit Pro: Member List

CXTPButtonThemeResource Member List

This is the complete list of members for CXTPButtonThemeResource, including all inherited members.

CXTPButtonTheme() | CXTPButtonTheme |
CXTPButtonThemeResource() | CXTPButtonThemeResource |
CXTPButtonThemeUltraFlat() | CXTPButtonThemeUltraFlat |
CXTPCmdTarget() | CXTPCmdTarget |
CXTPControlTheme() | CXTPControlTheme |
DrawButton(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
DrawButtonBackground(CDC *pDC, CXTPButton *pButton) | CXTPButtonThemeResource | virtual
DrawButtonText(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme |
DrawButtonVisualStyleBackground(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
DrawCheckBoxMark(CDC *pDC, CXTPButton *pButton) | CXTPButtonThemeResource | virtual
DrawFocusRect(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
DrawGroupBox(CDC *pDC, CXTPButton *pButton) | CXTPButtonThemeUltraFlat | virtual
DrawPushButtonDropDown(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
DrawPushButtonIcon(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
DrawPushButtonText(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
DrawRadioButtonMark(CDC *pDC, CXTPButton *pButton) | CXTPButtonThemeResource | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetTextColor(CXTPButton *pButton) | CXTPButtonTheme | virtual
GetThemeStyle() const | CXTPControlTheme |
m_crBack | CXTPButtonTheme |
m_crBackChecked | CXTPButtonThemeUltraFlat |
m_crBackHilite | CXTPButtonThemeUltraFlat |
m_crBackPushed | CXTPButtonThemeUltraFlat |
m_crBorder3DHilite | CXTPButtonTheme |
m_crBorder3DShadow | CXTPButtonTheme |
m_crBorderHilite | CXTPButtonTheme |
m_crBorderPushed | CXTPButtonThemeUltraFlat |
m_crBorderShadow | CXTPButtonTheme |
m_crCheckMark | CXTPButtonThemeUltraFlat |
m_crText | CXTPButtonTheme |
m_crTextCheck | CXTPButtonTheme |
m_crTextDisabled | CXTPButtonTheme |
m_crTextHilite | CXTPButtonThemeUltraFlat |
m_crTextPushed | CXTPButtonThemeUltraFlat |
m_nTheme | CXTPControlTheme | protected
RefreshMetrics(CXTPButton *pButton) | CXTPButtonThemeResource | virtual
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static
~CXTPButtonTheme() | CXTPButtonTheme | virtual


Toolkit Pro: Member List

CXTPControlMarkupLabel Member List

This is the complete list of members for CXTPControlMarkupLabel, including all inherited members.

AssignDocTemplate(UINT nIDResource) | CXTPControl |
ClickToolBarButton(CRect rcActiveRect=CRect(0, 0, 0, 0)) | CXTPControl | protected
Compare(CXTPControl *pOther) | CXTPControl | virtual
Copy(CXTPControl *pControl, BOOL bRecursive=FALSE) | CXTPControl | virtual
CustomizeStartDrag(CPoint point) | CXTPControl | protectedvirtual
CustomizeStartResize(CPoint point) | CXTPControl | protectedvirtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPControl() | CXTPControl | protected
CXTPControlMarkupLabel() | CXTPControlMarkupLabel |
DelayLayoutParent() | CXTPControl |
DelayRedrawParent() | CXTPControl |
DoCustomDragOver(CXTPCommandBar *pCommandBar, CPoint point, DROPEFFECT &dropEffect) | CXTPControl | protectedvirtual
DoPropExchange(CXTPPropExchange *pPX) | CXTPControl | virtual
Draw(CDC *pDC) | CXTPControlMarkupLabel | protectedvirtual
ExcludeDocTemplate(UINT nIDResource) | CXTPControl |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
FromUI(CCmdUI *pCmdUI) | CXTPControl | static
GenerateCommandBarList(DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam) | CXTPControl | protectedvirtual
GetAction() const | CXTPControl |
GetBeginGroup() const | CXTPControl |
GetButtonSize() const | CXTPControl | virtual
GetCaption() const | CXTPControl | virtual
GetCategory() const | CXTPControl |
GetChecked() const | CXTPControl |
GetCloseSubMenuOnClick() const | CXTPControl |
GetCommandBar() const | CXTPControl | virtual
GetControls() const | CXTPControl |
GetCustomizeMinHeight() const | CXTPControl | protectedvirtual
GetCustomizeMinWidth() const | CXTPControl | protectedvirtual
GetCustomShortcutText() const | CXTPControl |
GetDescription() const | CXTPControl | virtual
GetEnabled() const | CXTPControl |
GetExecuteOnPressInterval() const | CXTPControl |
GetExpanded() const | CXTPControl |
GetFlags() const | CXTPControl |
GetHeight() const | CXTPControl |
GetHelpId() const | CXTPControl |
GetHideFlags() const | CXTPControl |
GetIconId() const | CXTPControl |
GetIconSize() const | CXTPControl | virtual
GetID() const | CXTPControl |
GetImage(int nWidth=16) const | CXTPControl | virtual
GetImageManager() const | CXTPControl |
GetIndex() const | CXTPControl |
GetKeyboardTip() const | CXTPControl |
GetPaintManager() const | CXTPControl |
GetParameter() const | CXTPControl |
GetParent() const | CXTPControl |
GetPopuped() const | CXTPControl | virtual
GetPressed() const | CXTPControl | virtual
GetRect() const | CXTPControl |
GetRibbonGroup() const | CXTPControl |
GetRowRect() const | CXTPControl |
GetShortcutText() const | CXTPControl |
GetSize(CDC *pDC) | CXTPControlMarkupLabel | protectedvirtual
GetStyle() const | CXTPControl |
GetTag() const | CXTPControl |
GetTooltip() const | CXTPControl | virtual
GetType() const | CXTPControl |
GetWidth() const | CXTPControl |
GetWrap() const | CXTPControl |
HasDwmCompositedRect() const | CXTPControl |
IsCaptionVisible() const | CXTPControl | virtual
IsCursorOver() const | CXTPControl |
IsCustomizeMode() const | CXTPControl | protected
IsCustomizeMovable() const | CXTPControl | virtual
IsCustomizeResizeAllow() const | CXTPControl | protectedvirtual
IsFocusable() const | CXTPControl | protectedvirtual
IsFocused() const | CXTPControl | virtual
IsItemDefault() const | CXTPControl |
IsLayoutChanged() | CXTPControl | protected
IsLayoutRTL() const | CXTPControl | protected
IsOnQuickAccess() const | CXTPControl |
IsTemporary() const | CXTPControl |
IsTransparent() const | CXTPControl | inlinevirtual
IsVisible(DWORD dwSkipFlags=0) const | CXTPControl | virtual
m_bBeginGroup | CXTPControl | protected
m_bChecked | CXTPControl | protected
m_bCloseSubMenuOnClick | CXTPControl | protected
m_bDefaultItem | CXTPControl | protected
m_bEnabled | CXTPControl | protected
m_bExpanded | CXTPControl | protected
m_bLayoutRTL | CXTPControl | protected
m_bOnQuickAccess | CXTPControl | protected
m_bPressed | CXTPControl | protected
m_bSelected | CXTPControl | protected
m_bTemporary | CXTPControl | protected
m_buttonCustomStyle | CXTPControl | protected
m_buttonRibbonStyle | CXTPControl | protected
m_buttonStyle | CXTPControl | protected
m_bWrap | CXTPControl | protected
m_controlType | CXTPControl | protected
m_dwFlags | CXTPControl | protected
m_dwHideFlags | CXTPControl | protected
m_mapDocTemplatesAssigned | CXTPControl | protected
m_mapDocTemplatesExcluded | CXTPControl | protected
m_nCustomIconId | CXTPControl | protected
m_nExecuteOnPressInterval | CXTPControl | protected
m_nHeight | CXTPControl | protected
m_nHelpId | CXTPControl | protected
m_nIconId | CXTPControl | protected
m_nId | CXTPControl | protected
m_nIndex | CXTPControl | protected
m_nTag | CXTPControl | protected
m_nWidth | CXTPControl | protected
m_pAction | CXTPControl | protected
m_pControls | CXTPControl | protected
m_pMarkupUIElement | CXTPControlMarkupLabel | protected
m_pParent | CXTPControl | protected
m_pRibbonGroup | CXTPControl | protected
m_rcControl | CXTPControl | protected
m_rcRow | CXTPControl | protected
m_strCaption | CXTPControl | protected
m_strCategory | CXTPControl | protected
m_strCustomCaption | CXTPControl | protected
m_strDescriptionText | CXTPControl | protected
m_strKeyboardTip | CXTPControl | protected
m_strParameter | CXTPControl | protected
m_strShortcutText | CXTPControl | protected
m_strShortcutTextAuto | CXTPControl | protected
m_strTooltipText | CXTPControl | protected
m_szIcon | CXTPControl | protected
NotifySite(UINT code) | CXTPControl |
NotifySite(UINT code, NMXTPCONTROL *pNM) | CXTPControl |
NotifySite(CWnd *pSite, UINT code, NMXTPCONTROL *pNM) | CXTPControl |
OnActionChanged(int nProperty) | CXTPControl | protectedvirtual
OnActionChanging(int nProperty) | CXTPControl | protectedvirtual
OnCalcDynamicSize(DWORD dwMode) | CXTPControl | virtual
OnCaptionChanged() | CXTPControlMarkupLabel | protectedvirtual
OnCustomizeDragOver(CXTPControl *pDataObject, CPoint point, DROPEFFECT &dropEffect) | CXTPControl | protectedvirtual
OnCustomizeMouseMove(CPoint point) | CXTPControl | protected
OnEnabledChanged() | CXTPControl | virtual
OnExecute() | CXTPControl | virtual
OnHookKeyDown(UINT nChar, LPARAM lParam) | CXTPControl | protectedvirtual
OnHookMouseWheel(UINT nFlags, short zDelta, CPoint point) | CXTPControl | protectedvirtual
OnIdleUpdate() | CXTPControl | protectedvirtual
OnLButtonDblClk(CPoint point) | CXTPControl | protectedvirtual
OnLButtonDown(CPoint point) | CXTPControl | protectedvirtual
OnLButtonUp(CPoint point) | CXTPControl | protectedvirtual
OnMouseHover() | CXTPControl | protectedvirtual
OnMouseMove(CPoint point) | CXTPControl | protectedvirtual
OnRButtonDown(CPoint point) | CXTPControl | protectedvirtual
OnRButtonUp(CPoint point) | CXTPControl | protectedvirtual
OnRemoved() | CXTPControl | protectedvirtual
OnSetPopup(BOOL bPopup) | CXTPControl | protectedvirtual
OnSetSelected(int bSelected) | CXTPControl | protectedvirtual
OnThemeChanged() | CXTPControlMarkupLabel | protectedvirtual
OnToolHitTest(CPoint point, TOOLINFO *pTI) const | CXTPControl | protectedvirtual
OnUnderlineActivate() | CXTPControl | virtual
RedrawParent(BOOL bAnimate=TRUE) | CXTPControl |
Reset() | CXTPControl |
RestoreCommandBarList(CXTPCommandBarList *pCommandBarList) | CXTPControl | protectedvirtual
ScreenToClient(CPoint *point) | CXTPControl | protected
SetAction(CXTPControlAction *pAction) | CXTPControl | virtual
SetBeginGroup(BOOL bBeginGroup) | CXTPControl | virtual
SetCaption(LPCTSTR lpszCaption) | CXTPControl |
SetCaption(UINT nIDCaption) | CXTPControl |
SetCategory(LPCTSTR lpszCategory) | CXTPControl |
SetChecked(BOOL bChecked) | CXTPControl | virtual
SetCloseSubMenuOnClick(BOOL bCloseOnClick) | CXTPControl |
SetCustomIcon(HICON hIcon) | CXTPControl |
SetCustomShortcutText(LPCTSTR lpszCustomShortcutText) | CXTPControl |
SetDescription(LPCTSTR lpszDescription) | CXTPControl |
SetEnabled(BOOL bEnabled) | CXTPControl | virtual
SetExecuteOnPressInterval(int nExecuteOnPressInterval) | CXTPControl |
SetExpanded(BOOL bExpanded) | CXTPControl | protected
SetFlags(DWORD dwFlags) | CXTPControl |
SetFocused(BOOL bFocused) | CXTPControl | virtual
SetHeight(int nHeight) | CXTPControl | virtual
SetHelpId(int nId) | CXTPControl |
SetHideFlag(XTPControlHideFlags dwFlag, BOOL bSet) | CXTPControl |
SetHideFlags(DWORD dwFlags) | CXTPControl | virtual
SetHideWrap(BOOL bHide) | CXTPControl |
SetIconId(int nId) | CXTPControl |
SetIconSize(CSize szIcon) | CXTPControl |
SetID(int nId) | CXTPControl |
SetIndex(int nIndex) | CXTPControl | inlineprotected
SetItemDefault(BOOL bDefault) | CXTPControl |
SetKeyboardTip(LPCTSTR lpszKeyboardTip) | CXTPControl |
SetOnQuickAccess(BOOL bOnQuicAccess=FALSE) | CXTPControl |
SetParameter(LPCTSTR lpszParameter) | CXTPControl |
SetParent(CXTPCommandBar *pParent) | CXTPControl | inlineprotectedvirtual
SetPressed(BOOL bPressed) | CXTPControl |
SetPrompt(LPCTSTR lpszPrompt) | CXTPControl |
SetRect(CRect rcControl) | CXTPControl | virtual
SetRowRect(CRect rcRow) | CXTPControl |
SetShortcutText(LPCTSTR lpszShortcutText) | CXTPControl |
SetStyle(XTPButtonStyle buttonStyle) | CXTPControl |
SetTag(DWORD_PTR dwTag) | CXTPControl |
SetTooltip(LPCTSTR lpszTooltip) | CXTPControl |
SetVisible(BOOL bVisible) | CXTPControl |
SetWidth(int nWidth) | CXTPControl | virtual
SetWrap(BOOL bWrap) | CXTPControl |
~CXTPControl() | CXTPControl | protectedvirtual
~CXTPControlMarkupLabel() | CXTPControlMarkupLabel |


Toolkit Pro: Member List

CXTPWebViewProvider Member List

This is the complete list of members for CXTPWebViewProvider, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPWebBrowserProvider(IXTPWebBrowserHost &host) | CXTPWebBrowserProvider | protected
CXTPWebViewProvider(IXTPWebBrowserHost &host) | CXTPWebViewProvider |
ExecuteScript(LPCWSTR pText, CComVariant *pvtResult=NULL) | CXTPWebViewProvider | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetBrowserObject() const | CXTPWebBrowserProvider |
GetClientInterface(REFIID riid) const | CXTPWebBrowserProvider |
IsAvailable() | CXTPWebViewProvider | static
m_Host | CXTPWebBrowserProvider | protected
RemoveClientInterface(REFIID riid) | CXTPWebBrowserProvider |
SetClientInterface(REFIID riid, IUnknown *pUnk) | CXTPWebBrowserProvider |
~CXTPWebBrowserProvider() | CXTPWebBrowserProvider | virtual
~CXTPWebViewProvider() | CXTPWebViewProvider |


Toolkit Pro: XTPRibbonBackstageButtonThemeNativeWindows11.h Source File

  • Source
  • Ribbon
  • Backstage
XTPRibbonBackstageButtonThemeNativeWindows11.h
Go to the documentation of this file.
1
23#if !defined(__XTPRIBBONBACKSTAGEBUTTONTHEMENATIVEWINDOWS11T_H__)
24# define __XTPRIBBONBACKSTAGEBUTTONTHEMENATIVEWINDOWS11T_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class _XTP_EXT_CLASS CXTPRibbonBackstageButtonThemeNativeWindows11
34 : public CXTPButtonThemeNativeWindows11
35{
36public:
37 CXTPRibbonBackstageButtonThemeNativeWindows11();
38
39public:
40 void DrawButtonBackground(CDC* pDC, CXTPButton* pButton);
41
42protected:
43 friend class CBackstageButtonCtrl;
44};
45
46# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
48#endif // !defined(__XTPRIBBONBACKSTAGEBUTTONTHEMENATIVEWINDOWS11T_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPButton
Push Button control.
Definition XTPButton.h:109
CXTPButtonThemeNativeWindows11
CXTPButtonThemeNativeWindows11 is a class used to perform Visual Studio 2015 theme drawing tasks.
Definition XTPButtonThemeNativeWindows11.h:39
CXTPButtonThemeOffice2013::DrawButtonBackground
virtual void DrawButtonBackground(CDC *pDC, CXTPButton *pButton)
This member function is called to draw the background for the button.


Toolkit Pro: Member List

CXTPListBoxThemeVisualStudio2022 Member List

This is the complete list of members for CXTPListBoxThemeVisualStudio2022, including all inherited members.

CXTPListBoxThemeOffice2013() | CXTPListBoxThemeOffice2013 |
CXTPListBoxThemeVisualStudio2022() | CXTPListBoxThemeVisualStudio2022 |
DrawItem(CDC *pDC, CXTPListBox *pListBox, LPDRAWITEMSTRUCT lpDIS) | CXTPListBoxThemeOffice2013 | virtual
DrawItemText(CDC *pDC, CRect rcText, CXTPListBox *pListBox, LPDRAWITEMSTRUCT lpDIS) | CXTPListBoxTheme | virtual
DrawNcBorders(CDC *pDC, CRect rc) | CXTPListBoxThemeOffice2013 | virtual
GetBackColor() | CXTPListBoxThemeOffice2013 | virtual
m_clrBack | CXTPListBoxThemeOffice2013 |
m_clrBorder | CXTPListBoxThemeOffice2013 |
m_clrItemBack | CXTPListBoxThemeOffice2013 |
m_clrItemBackHighlight | CXTPListBoxThemeOffice2013 |
m_clrItemBackSelected | CXTPListBoxThemeOffice2013 |
m_clrItemBorder | CXTPListBoxThemeOffice2013 |
m_clrItemBorderHighlight | CXTPListBoxThemeOffice2013 |
m_clrItemBorderSelected | CXTPListBoxThemeOffice2013 |
m_clrItemText | CXTPListBoxThemeOffice2013 |
m_clrItemTextHighlight | CXTPListBoxThemeOffice2013 |
m_clrItemTextSelected | CXTPListBoxThemeOffice2013 |
RefreshMetrics() | CXTPListBoxThemeOffice2013 | virtual
~CXTPListBoxTheme() | CXTPListBoxTheme | inlinevirtual


Toolkit Pro: Member List

CXTPPropExchangeRegistry Member List

This is the complete list of members for CXTPPropExchangeRegistry, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPPropExchange() | CXTPPropExchange |
CXTPPropExchangeRegistry(BOOL bLoading, HKEY hParentKey, LPCTSTR lpszSection) | CXTPPropExchangeRegistry |
EmptySection() | CXTPPropExchangeRegistry | virtual
ExchangeBlobProp(LPCTSTR pszPropName, BYTE *&pData, DWORD &nBytes) | CXTPPropExchangeRegistry | virtual
ExchangeLocale() | CXTPPropExchange |
ExchangeObjectInstance(CObject *&pObject, CRuntimeClass *pObjectRuntime) | CXTPPropExchange | virtual
ExchangeProp(LPCTSTR pszPropName, VARTYPE vtProp, void *pvProp, const void *pvDefault=NULL) | CXTPPropExchangeRegistry | virtual
ExchangeRuntimeClass(LPCTSTR pszPropName, CRuntimeClass *&pClass, CRuntimeClass *pDefaultClass) | CXTPPropExchange | virtual
ExchangeSchema() | CXTPPropExchange |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetArchive(LPCTSTR pszPropName) | CXTPPropExchange | virtual
GetEnumerator(LPCTSTR lpszSection) | CXTPPropExchange | virtual
GetSchema() const | CXTPPropExchange |
GetSection(LPCTSTR lpszSection) | CXTPPropExchangeRegistry | virtual
InitSection(CXTPPropExchange *pRootSection) | CXTPPropExchange | protected
IsAllowBlobValues() const | CXTPPropExchangeRegistry | virtual
IsAllowDefaultValues() const | CXTPPropExchange | virtual
IsLoading() const | CXTPPropExchange |
IsPropertyExists(LPCTSTR pszPropName) | CXTPPropExchangeRegistry |
IsRootSection() const | CXTPPropExchange |
IsSectionExists(LPCTSTR lpszSection) | CXTPPropExchangeRegistry |
IsStoring() const | CXTPPropExchange |
m_bChildSection | CXTPPropExchange | protected
m_bCloseParentKey | CXTPPropExchangeRegistry | protected
m_bEmptySection | CXTPPropExchange | protected
m_bInitialized | CXTPPropExchange | protected
m_bLoading | CXTPPropExchange | protected
m_bUseDefaultOnLoad | CXTPPropExchange | protected
m_bUseDefaultOnSave | CXTPPropExchange | protected
m_dwData | CXTPPropExchange |
m_hParentKey | CXTPPropExchangeRegistry | protected
m_hSectionKey | CXTPPropExchangeRegistry | protected
m_lcidDateTime | CXTPPropExchange | static
m_nSchema | CXTPPropExchange | protected
m_pOwner | CXTPPropExchange |
m_strSectionName | CXTPPropExchangeRegistry | protected
OnBeforeExchange() | CXTPPropExchangeRegistry | virtual
Read(LPCTSTR pszPropName, void *lpBuf, UINT nCount) | CXTPPropExchange | virtual
ReadCount() | CXTPPropExchange | virtual
ReleaseArchive(LPCTSTR pszPropName, CArchive *pArchive) | CXTPPropExchange | virtual
SetSchema(UINT nSchemaVersion) | CXTPPropExchange |
UseDefaultOnLoad(BOOL bUseDefaultOnLoad=TRUE) | CXTPPropExchange |
UseDefaultOnSave(BOOL bUseDefaultOnSave=TRUE) | CXTPPropExchange |
Write(LPCTSTR pszPropName, const void *lpBuf, UINT nCount) | CXTPPropExchange | virtual
WriteCount(DWORD dwCount) | CXTPPropExchange | virtual
~CXTPPropExchange() | CXTPPropExchange | virtual
~CXTPPropExchangeRegistry() | CXTPPropExchangeRegistry |


Toolkit Pro: XTPDockingPaneTabTheme2022.h Source File

  • Source
  • DockingPane
  • TabThemes
XTPDockingPaneTabTheme2022.h
Go to the documentation of this file.
1
23#if !defined(__XTPDOCKINGPANETABTHEME2022_H__)
24# define __XTPDOCKINGPANETABTHEME2022_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPDockingPaneTabTheme2022 : public CXTPDockingPaneTabTheme2012
39{
40public:
45 CXTPDockingPaneTabTheme2022();
46
63 virtual void DrawSingleButton(CDC* pDC, CXTPTabManagerItem* pItem);
64};
65
66# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
68#endif // !defined(__XTPDOCKINGPANETABTHEME2022_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPDockingPaneTabTheme2012
Helper class used to initialize default colors for a theme from an .INI resource and handle drawing r...
Definition XTPDockingPaneTabTheme2012.h:39
CXTPDockingPaneTabTheme2022
Helper class used to initialize default colors for a theme from an .INI resource and handle drawing r...
Definition XTPDockingPaneTabTheme2022.h:39
CXTPDockingPaneTabTheme2022::DrawSingleButton
virtual void DrawSingleButton(CDC *pDC, CXTPTabManagerItem *pItem)
This method is called to draw a single tab button in the tab client header area.
CXTPDockingPaneTabTheme2022::CXTPDockingPaneTabTheme2022
CXTPDockingPaneTabTheme2022()
Default class constructor.
CXTPTabManagerItem
CXTPTabManagerItem is the base class for the tabs that appear in the command bars tab workspace,...
Definition XTPTabManagerItem.h:44


Toolkit Pro: Member List

CXTPPropertyGridItemNumber Member List

This is the complete list of members for CXTPPropertyGridItemNumber, including all inherited members.

AddChildItem(CXTPPropertyGridItem *pItem) | CXTPPropertyGridItem |
AddComboButton() | CXTPPropertyGridItem |
AddExpandButton() | CXTPPropertyGridItem |
AddSliderControl() | CXTPPropertyGridItem |
AddSpinButton() | CXTPPropertyGridItem |
BindToNumber(long *pBindNumber) | CXTPPropertyGridItemNumber | virtual
BindToString(CString *pBindString) | CXTPPropertyGridItem |
Collapse() | CXTPPropertyGridItem |
CXTPCmdTarget() | CXTPCmdTarget |
CXTPPropertyGridItem(LPCTSTR lpszCaption, LPCTSTR strValue=NULL, CString *pBindString=NULL) | CXTPPropertyGridItem |
CXTPPropertyGridItem(UINT nID, LPCTSTR strValue=NULL, CString *pBindString=NULL) | CXTPPropertyGridItem |
CXTPPropertyGridItemNumber(LPCTSTR strCaption, long nValue=0, long *pBindNumber=NULL) | CXTPPropertyGridItemNumber |
CXTPPropertyGridItemNumber(UINT nID, long nValue=0, long *pBindNumber=NULL) | CXTPPropertyGridItemNumber |
EnsureVisible() | CXTPPropertyGridItem |
Expand() | CXTPPropertyGridItem |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCaption() const | CXTPPropertyGridItem |
GetCaptionMetrics() const | CXTPPropertyGridItem |
GetChilds() const | CXTPPropertyGridItem |
GetConstraintEdit() const | CXTPPropertyGridItem |
GetConstraints() const | CXTPPropertyGridItem |
GetDefaultValue() const | CXTPPropertyGridItem |
GetDescription() const | CXTPPropertyGridItem |
GetDropDownItemCount() const | CXTPPropertyGridItem |
GetEditStyle() const | CXTPPropertyGridItem | virtual
GetFlags() const | CXTPPropertyGridItem |
GetGrid() const | CXTPPropertyGridItem |
GetHeight() const | CXTPPropertyGridItem |
GetID() const | CXTPPropertyGridItem |
GetIndent() const | CXTPPropertyGridItem |
GetIndex() const | CXTPPropertyGridItem |
GetInplaceButtons() const | CXTPPropertyGridItem |
GetInplaceControls() const | CXTPPropertyGridItem |
GetInPlacedEditValue() | CXTPPropertyGridItem | inlineprotectedvirtual
GetInplaceEdit() | CXTPPropertyGridItem | virtual
GetInplaceList() | CXTPPropertyGridItem | protectedvirtual
GetItemData() const | CXTPPropertyGridItem |
GetItemRect() const | CXTPPropertyGridItem |
GetMarkupCaption() const | CXTPPropertyGridItem |
GetMarkupDescription() const | CXTPPropertyGridItem |
GetMarkupTemplate() const | CXTPPropertyGridItem | virtual
GetMarkupValue() const | CXTPPropertyGridItem |
GetMaskedText() const | CXTPPropertyGridItem |
GetMetrics(BOOL bValueMetrics, BOOL bCreate=TRUE) const | CXTPPropertyGridItem |
GetMultiLinesCount() const | CXTPPropertyGridItem |
GetNumber() const | CXTPPropertyGridItemNumber | virtual
GetParentItem() const | CXTPPropertyGridItem |
GetReadOnly() const | CXTPPropertyGridItem | virtual
GetTooltip() const | CXTPPropertyGridItem |
GetValue() const | CXTPPropertyGridItem |
GetValueMetrics() const | CXTPPropertyGridItem |
GetValueRect() | CXTPPropertyGridItem | virtual
GetViewValue() | CXTPPropertyGridItem | virtual
HasChilds() const | CXTPPropertyGridItem |
HasParent(CXTPPropertyGridItem *pParent) | CXTPPropertyGridItem |
HasVisibleChilds() const | CXTPPropertyGridItem |
InsertChildItem(int nIndex, CXTPPropertyGridItem *pItem) | CXTPPropertyGridItem |
IsAllowEdit() const | CXTPPropertyGridItem | virtual
IsCategory() const | CXTPPropertyGridItem |
IsExpandable() const | CXTPPropertyGridItem |
IsExpanded() const | CXTPPropertyGridItem |
IsHidden() const | CXTPPropertyGridItem |
IsInplaceButtonVisible(CXTPPropertyGridInplaceButton *pButton) const | CXTPPropertyGridItem | virtual
IsMultiLine() const | CXTPPropertyGridItem |
IsSelected() const | CXTPPropertyGridItem |
IsValueChanged() const | CXTPPropertyGridItem | virtual
IsVisible() const | CXTPPropertyGridItem |
m_bAutoComplete | CXTPPropertyGridItem | protected
m_bCategory | CXTPPropertyGridItem | protected
m_bConstraintEdit | CXTPPropertyGridItem | protected
m_bExpandable | CXTPPropertyGridItem | protected
m_bExpanded | CXTPPropertyGridItem | protected
m_bHidden | CXTPPropertyGridItem | protected
m_bPassword | CXTPPropertyGridItem | protected
m_bReadOnly | CXTPPropertyGridItem | protected
m_bUseMask | CXTPPropertyGridItem | protected
m_bVisible | CXTPPropertyGridItem | protected
m_chPrompt | CXTPPropertyGridItem | protected
m_dwData | CXTPPropertyGridItem | protected
m_dwEditStyle | CXTPPropertyGridItem | protected
m_nDropDownItemCount | CXTPPropertyGridItem | protected
m_nFlags | CXTPPropertyGridItem | protected
m_nHeight | CXTPPropertyGridItem | protected
m_nID | CXTPPropertyGridItem | protected
m_nIndent | CXTPPropertyGridItem | protected
m_nIndex | CXTPPropertyGridItem | protected
m_nLinesCount | CXTPPropertyGridItem | protected
m_nValue | CXTPPropertyGridItemNumber | protected
m_pBindNumber | CXTPPropertyGridItemNumber | protected
m_pBindString | CXTPPropertyGridItem | protected
m_pCaptionMetrics | CXTPPropertyGridItem | mutableprotected
m_pChilds | CXTPPropertyGridItem | protected
m_pConstraints | CXTPPropertyGridItem | protected
m_pGrid | CXTPPropertyGridItem | protected
m_pInplaceButtons | CXTPPropertyGridItem | protected
m_pInplaceControls | CXTPPropertyGridItem | protected
m_pMarkupCaption | CXTPPropertyGridItem | protected
m_pMarkupDescription | CXTPPropertyGridItem | protected
m_pMarkupValue | CXTPPropertyGridItem | protected
m_pParent | CXTPPropertyGridItem | protected
m_pValueMetrics | CXTPPropertyGridItem | mutableprotected
m_strCaption | CXTPPropertyGridItem | protected
m_strDefaultValue | CXTPPropertyGridItem | protected
m_strDescription | CXTPPropertyGridItem | protected
m_strFormat | CXTPPropertyGridItem | protected
m_strLiteral | CXTPPropertyGridItem | protected
m_strMarkupTemplate | CXTPPropertyGridItem | protected
m_strMask | CXTPPropertyGridItem | protected
m_strTooltip | CXTPPropertyGridItem | protected
m_strValue | CXTPPropertyGridItem | protected
MeasureItem(LPMEASUREITEMSTRUCT lpMeasureItemStruct) | CXTPPropertyGridItem | virtual
Move(CXTPPropertyGridItem *pParent, int nIndex=-1) | CXTPPropertyGridItem |
NotifyValueChanged() | CXTPPropertyGridItem | protected
OnAddChildItem() | CXTPPropertyGridItem | protectedvirtual
OnAfterEdit(CString &strValue) | CXTPPropertyGridItem | virtual
OnBeforeInsert() | CXTPPropertyGridItemNumber | protectedvirtual
OnCancelEdit() | CXTPPropertyGridItem | virtual
OnCaptionChanged() | CXTPPropertyGridItem | protectedvirtual
OnChar(UINT nChar) | CXTPPropertyGridItem | protectedvirtual
OnConstraintsChanged() | CXTPPropertyGridItem | protectedvirtual
OnDeselect() | CXTPPropertyGridItem | protectedvirtual
OnDrawItemConstraint(CDC *pDC, CXTPPropertyGridItemConstraint *pConstraint, CRect rc, BOOL bSelected) | CXTPPropertyGridItem | virtual
OnDrawItemValue(CDC &dc, CRect rcValue) | CXTPPropertyGridItem | virtual
OnIndexChanged() | CXTPPropertyGridItem | protectedvirtual
OnInpaceControlFocus(BOOL bForward) | CXTPPropertyGridItem | protectedvirtual
OnInplaceButtonDown(CXTPPropertyGridInplaceButton *pButton) | CXTPPropertyGridItem | protectedvirtual
OnKeyDown(UINT nChar) | CXTPPropertyGridItem | protectedvirtual
OnLButtonDblClk(UINT nFlags, CPoint point) | CXTPPropertyGridItem | protectedvirtual
OnLButtonDown(UINT nFlags, CPoint point) | CXTPPropertyGridItem | protectedvirtual
OnLButtonUp(UINT nFlags, CPoint point) | CXTPPropertyGridItem | protectedvirtual
OnMarkupChanged() | CXTPPropertyGridItem | virtual
OnMergeItemConstraint(CDC *pDC, CXTPPropertyGridItemConstraint *pConstraint) | CXTPPropertyGridItem | virtual
OnRButtonDown(UINT nFlags, CPoint point) | CXTPPropertyGridItem | protectedvirtual
OnRequestEdit() | CXTPPropertyGridItem | virtual
OnSelect() | CXTPPropertyGridItem | protectedvirtual
OnValidateEdit() | CXTPPropertyGridItem | virtual
OnValueChanged(CString strValue) | CXTPPropertyGridItem | virtual
PtInValueRect(CPoint point) | CXTPPropertyGridItem | protected
RedrawItem() | CXTPPropertyGridItem |
Remove() | CXTPPropertyGridItem |
ResetValue() | CXTPPropertyGridItem | virtual
Select() | CXTPPropertyGridItem |
SelectNextConstraint() | CXTPPropertyGridItem | protected
SetAutoComplete(BOOL bAutoComplete=TRUE) | CXTPPropertyGridItem |
SetCaption(LPCTSTR lpszCaption) | CXTPPropertyGridItem |
SetConstraintEdit(BOOL bConstraintEdit=TRUE) | CXTPPropertyGridItem |
SetDefaultValue(LPCTSTR lpszDefaultValue) | CXTPPropertyGridItem |
SetDescription(LPCTSTR lpszDescription) | CXTPPropertyGridItem |
SetDropDownItemCount(int nDropDownItemCount) | CXTPPropertyGridItem |
SetEditStyle(DWORD dwEditStyle) | CXTPPropertyGridItem |
SetEditText(const CString &str) | CXTPPropertyGridItem | protectedvirtual
SetExpandable(BOOL bExpandable) | CXTPPropertyGridItem |
SetFlags(UINT nFlags) | CXTPPropertyGridItem |
SetFocusToInplaceControl() | CXTPPropertyGridItem | virtual
SetHeight(int nHeight) | CXTPPropertyGridItem |
SetHidden(BOOL bHidden) | CXTPPropertyGridItem |
SetID(UINT nID) | CXTPPropertyGridItem |
SetItemData(DWORD_PTR dwData) | CXTPPropertyGridItem |
SetMarkupTemplate(LPCTSTR lpstrMarkupTemplate) | CXTPPropertyGridItem |
SetMask(LPCTSTR strMask, LPCTSTR strLiteral, TCHAR chPrompt=_T('_')) | CXTPPropertyGridItem |
SetMaskedText(LPCTSTR lpszMaskedText) | CXTPPropertyGridItem |
SetMultiLinesCount(int nLinesCount) | CXTPPropertyGridItem |
SetNumber(long nValue) | CXTPPropertyGridItemNumber | virtual
SetPasswordMask(TCHAR chMask=_T(' *')) | CXTPPropertyGridItem |
SetPrompt(LPCTSTR lpszPrompt) | CXTPPropertyGridItem |
SetReadOnly(BOOL bReadOnly=TRUE) | CXTPPropertyGridItem | virtual
SetTooltip(LPCTSTR lpstrTooltip) | CXTPPropertyGridItem |
SetValue(CString strValue) | CXTPPropertyGridItemNumber | protectedvirtual
SetVisible(BOOL bVisible) | CXTPPropertyGridItem | protectedvirtual
~CXTPPropertyGridItem() | CXTPPropertyGridItem | virtual
~CXTPPropertyGridItemNumber() | CXTPPropertyGridItemNumber | virtual


Toolkit Pro: XTPCommandBarsVisualStudio6Theme.h Source File

  • Source
  • CommandBars
  • Themes
XTPCommandBarsVisualStudio6Theme.h
Go to the documentation of this file.
1
23#if !defined(__XTPCOMMANDBARSVISUALSTUDIO6THEME_H__)
24# define __XTPCOMMANDBARSVISUALSTUDIO6THEME_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class _XTP_EXT_CLASS CXTPVisualStudio6Theme : public CXTPCommandBarsOffice2000Theme
34{
35 CSize DrawCommandBarGripper(CDC* pDC, CXTPCommandBar* pBar, BOOL bDraw);
36};
37
39# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
40#endif // !defined(__XTPCOMMANDBARSVISUALSTUDIO6THEME_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCommandBar
CXTPCommandBar is a CWnd derived class.
Definition XTPCommandBar.h:66
CXTPCommandBarsOffice2000Theme
The CXTPCommandBarsOffice2000Theme class is used to enable an Office 2000 style theme for Command Bar...
Definition XTPCommandBarsOffice2000Theme.h:41
CXTPCommandBarsOffice2000Theme::DrawCommandBarGripper
virtual CSize DrawCommandBarGripper(CDC *pDC, CXTPCommandBar *pBar, BOOL bDraw=TRUE)
This method is called to draw the command bar's gripper.


Toolkit Pro: Member List

CXTPStatusBarThemeVisualStudio2017 Member List

This is the complete list of members for CXTPStatusBarThemeVisualStudio2017, including all inherited members.

CXTPStatusBarThemeOffice2013(CXTPPaintManager *pPaintManager) | CXTPStatusBarThemeOffice2013 |
CXTPStatusBarThemeVisualStudio2017(CXTPPaintManager *pPaintManager) | CXTPStatusBarThemeVisualStudio2017 |
DrawStatusBarButtonFace(CDC *pDC, CRect rcItem, CXTPStatusBarPane *pPane) | CXTPStatusBarThemeOffice2013 | virtual
DrawStatusBarGripper(CDC *pDC, CRect rcClient) | CXTPStatusBarThemeVisualStudio2017 | virtual
DrawStatusBarPaneBorder(CDC *pDC, CRect rc, CXTPStatusBarPane *pPane, BOOL bGripperPane) | CXTPStatusBarThemeOffice2013 | virtual
DrawStatusBarPaneEntry(CDC *pDC, CRect rcItem, CXTPStatusBarPane *pPane) | CXTPStatusBarThemeOffice2013 | virtual
DrawStatusBarPaneSeparator(CDC *pDC, CRect rc, CXTPStatusBarPane *pPane) | CXTPStatusBarThemeOffice2013 | virtual
DrawStatusBarSwitchPane(CDC *pDC, CRect rcItem, CXTPStatusBarSwitchPane *pPane) | CXTPStatusBarThemeOffice2013 | virtual
FillStatusBar(CDC *pDC, CXTPStatusBar *pBar) | CXTPStatusBarThemeOffice2013 | virtual
GetStateColor() const | CXTPStatusBarThemeVisualStudio2017 | virtual
GetTextColor(CXTPStatusBarPane *pPane) | CXTPStatusBarThemeOffice2013 | virtual
m_clrButtonBack | CXTPStatusBarThemeOffice2013 | protected
m_clrButtonBackChecked | CXTPStatusBarThemeOffice2013 | protected
m_clrButtonBackHighlight | CXTPStatusBarThemeOffice2013 | protected
m_clrButtonBackPushed | CXTPStatusBarThemeOffice2013 | protected
m_clrButtonTextChecked | CXTPStatusBarThemeOffice2013 | protected
m_clrButtonTextHighlight | CXTPStatusBarThemeOffice2013 | protected
m_clrButtonTextPushed | CXTPStatusBarThemeOffice2013 | protected
RefreshMetrics() | CXTPStatusBarThemeVisualStudio2017 | virtual
SetStateColor(COLORREF clrState) | CXTPStatusBarThemeVisualStudio2017 | virtual
~CXTPStatusBarThemeVisualStudio2017() | CXTPStatusBarThemeVisualStudio2017 |


Toolkit Pro: XTPMarkupButtonBase.h Source File

  • Source
  • Markup
  • Controls
XTPMarkupButtonBase.h
Go to the documentation of this file.
1
23#if !defined(__XTPMARKUPBUTTONBASE_H__)
24# define __XTPMARKUPBUTTONBASE_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPWinThemeWrapper;
34class CXTPMarkupDependencyProperty;
35class CXTPMarkupRoutedEvent;
36class CXTPMarkupMouseEventArgs;
37class CXTPMarkupMouseButtonEventArgs;
38class CXTPMarkupDispatchDelegate;
39
45class _XTP_EXT_CLASS CXTPMarkupButtonBase : public CXTPMarkupContentControl
46{
48 DECLARE_MARKUPCLASS(CXTPMarkupButtonBase);
50protected:
55 CXTPMarkupButtonBase();
56
61 ~CXTPMarkupButtonBase();
62
63public:
70 BOOL IsPressed() const;
71
72protected:
77 virtual void OnClick();
78
80 // Implementation
81protected:
82 void OnMouseLeave(CXTPMarkupMouseEventArgs* e);
83 void OnMouseEnter(CXTPMarkupMouseEventArgs* e);
84
85 void OnMouseLeftButtonUp(CXTPMarkupMouseButtonEventArgs* e);
86 void OnMouseLeftButtonDown(CXTPMarkupMouseButtonEventArgs* e);
87
88 void OnLostMouseCapture(CXTPMarkupMouseEventArgs* e);
89
90protected:
91 void SetPressed(BOOL bPressed);
92
93 void UseParentBackground(HDC destHdc, HDC srcHdc, CRect srcRect) const;
94
95protected:
96 BOOL m_bPushed;
97 BOOL m_bMouseOver;
98 CXTPWinThemeWrapper* m_themeButton;
99
100public:
101 static CXTPMarkupDependencyProperty* m_pIsPressedProperty;
102 static CXTPMarkupRoutedEvent* m_pClickEvent;
103
107public:
108 DECLARE_DISPATCH_MAP()
109# ifdef _XTP_ACTIVEX
110 DECLARE_INTERFACE_MAP()
111 DECLARE_OLETYPELIB_EX(CXTPMarkupButtonBase);
112# endif
113
114 afx_msg BOOL OleGetIsPressed();
115 afx_msg void OleSetIsPressed(BOOL bValue);
116 afx_msg LPDISPATCH OleGetClickEvent();
117 afx_msg LPDISPATCH OleGetClick();
118 afx_msg void OleSetClick(LPDISPATCH pDisp);
119
122private:
123 CXTPMarkupDispatchDelegate* m_pClick;
124};
125
126# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
128#endif // !defined(__XTPMARKUPBUTTONBASE_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPMarkupButtonBase
CXTPMarkupButtonBase is a CXTPMarkupContentControl derived class.
Definition XTPMarkupButtonBase.h:46
CXTPMarkupButtonBase::OnClick
virtual void OnClick()
Virtual method called when the user clicks the button.
CXTPMarkupButtonBase::CXTPMarkupButtonBase
CXTPMarkupButtonBase()
Constructs a CXTPMarkupButtonBase object.
CXTPMarkupButtonBase::~CXTPMarkupButtonBase
~CXTPMarkupButtonBase()
Destroys a CXTPMarkupButtonBase object, handles cleanup and deallocation.
CXTPMarkupButtonBase::IsPressed
BOOL IsPressed() const
Determines if the button is currently pressed.
CXTPMarkupContentControl
CXTPMarkupContentControl is a CXTPMarkupControl derived class.
Definition XTPMarkupContentControl.h:45
CXTPWinThemeWrapper
The CXTPWinThemeWrapper class wraps the UxTheme.dll visual theme API.
Definition XTPWinThemeWrapper.h:188


Toolkit Pro: Member List

XTP_EDIT_SENMBOOKMARK Member List

This is the complete list of members for XTP_EDIT_SENMBOOKMARK, including all inherited members.

hDC | XTP_EDIT_SENMBOOKMARK
nmhdr | XTP_EDIT_SENMBOOKMARK
nRow | XTP_EDIT_SENMBOOKMARK
rcBookmark | XTP_EDIT_SENMBOOKMARK


Toolkit Pro: Member List

CXTPPreviewCtrl Member List

This is the complete list of members for CXTPPreviewCtrl, including all inherited members.

AddDefaultProviders() | CXTPPreviewCtrl |
AddProvider(IXTPPreviewProvider *provider, LPCTSTR associations=NULL) | CXTPPreviewCtrl |
Create(DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID, CCreateContext *pContext=NULL) | CXTPPreviewCtrl | virtual
CreateEx(DWORD dwExStyle, DWORD dwStyle, int x, int y, int nWidth, int nHeight, HWND hWndParent, HMENU nIDorHMenu, LPVOID lpParam=NULL) | CXTPPreviewCtrl | virtual
CreateEx(DWORD dwExStyle, DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID, LPVOID lpParam=NULL) | CXTPPreviewCtrl | virtual
CXTPPreviewCtrl() | CXTPPreviewCtrl |
EnableAutoPreviewActivate(BOOL bEnable=TRUE) | CXTPPreviewCtrl |
GetBackgroundColor() const | CXTPPreviewCtrl |
GetForegroundColor() const | CXTPPreviewCtrl |
IsAutoPreviewActivateEnabled() const | CXTPPreviewCtrl |
Preview(LPCTSTR lpFilePath) | CXTPPreviewCtrl |
Preview(IStream *pStream, LPCTSTR lpImpliedFileName) | CXTPPreviewCtrl |
RegisterWindowClass(HINSTANCE hInstance=NULL) | CXTPPreviewCtrl |
Reset() | CXTPPreviewCtrl |
SetBackgroundColor(COLORREF cr) | CXTPPreviewCtrl |
SetFailedMessage(LPCTSTR message) | CXTPPreviewCtrl |
SetForegroundColor(COLORREF cr) | CXTPPreviewCtrl |
SetLoadingMessage(LPCTSTR message) | CXTPPreviewCtrl |
~CXTPPreviewCtrl() | CXTPPreviewCtrl | virtual


Toolkit Pro: Member List

XTP_NM_GRIDROWRESIZE Member List

This is the complete list of members for XTP_NM_GRIDROWRESIZE, including all inherited members.

hdr | XTP_NM_GRIDROWRESIZE
nNewHeight | XTP_NM_GRIDROWRESIZE
nPrevHeight | XTP_NM_GRIDROWRESIZE
pRow | XTP_NM_GRIDROWRESIZE


Toolkit Pro: XTPListBoxThemeNativeWindows10.h Source File

  • Source
  • Controls
  • ListBox
  • Themes
XTPListBoxThemeNativeWindows10.h
Go to the documentation of this file.
1
23#if !defined(__XTPLISTBOXTHEMENATIVEWINDOWS10_H__)
24# define __XTPLISTBOXTHEMENATIVEWINDOWS10_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPListBoxThemeNativeWindows10 : public CXTPListBoxThemeOffice2013
39{
40public:
45 CXTPListBoxThemeNativeWindows10();
46};
47
48# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
50#endif // !defined(__XTPLISTBOXTHEMENATIVEWINDOWS10_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPListBoxThemeNativeWindows10
CXTPListBoxThemeNativeWindows10 is used by CXTPListBox to draw a Native Windows 10 style list box.
Definition XTPListBoxThemeNativeWindows10.h:39
CXTPListBoxThemeNativeWindows10::CXTPListBoxThemeNativeWindows10
CXTPListBoxThemeNativeWindows10()
Default constructor.
CXTPListBoxThemeOffice2013
CXTPListBoxThemeOffice2013 is used by CXTPListBox to draw an Office 2013 style list box.
Definition XTPListBoxThemeOffice2013.h:39


Toolkit Pro: Member List

CXTPTabColorSetDefault Member List

This is the complete list of members for CXTPTabColorSetDefault, including all inherited members.

CXTPTabPaintManagerColorSet() | CXTPTabPaintManagerColorSet |
FillClient(CDC *pDC, CRect rc, CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
FillHeader(CDC *pDC, CRect rc, CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
FillNavigateButton(CDC *pDC, CXTPTabManagerNavigateButton *pButton, CRect &rc) | CXTPTabColorSetDefault | virtual
FillPropertyButton(CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerColorSet | virtual
FillStateButton(CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerColorSet | virtual
GetClientColor(CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
GetItemColor(CXTPTabManagerItem *pItem) | CXTPTabPaintManagerColorSet | virtual
GradientFill(CDC *pDC, CRect rc, COLORREF clrLight, COLORREF clrDark, XTPTabPosition position) | CXTPTabPaintManagerColorSet |
IsAppThemed() const | CXTPTabPaintManagerColorSet | virtual
m_clrActiveFilesBack | CXTPTabPaintManagerColorSet |
m_clrActiveFilesBackHighlighted | CXTPTabPaintManagerColorSet |
m_clrActiveFilesBackPressed | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyph | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyphHighlighted | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyphPressed | CXTPTabPaintManagerColorSet |
m_clrAutoHideFace | CXTPTabPaintManagerColorSet |
m_clrBorderHighlight | CXTPTabPaintManagerColorSet |
m_clrButtonBorder | CXTPTabPaintManagerColorSet |
m_clrButtonBorderHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonBorderHot | CXTPTabPaintManagerColorSet |
m_clrButtonBorderKeyTips | CXTPTabPaintManagerColorSet |
m_clrButtonBorderTabContext1 | CXTPTabPaintManagerColorSet |
m_clrButtonBorderTabContext2 | CXTPTabPaintManagerColorSet |
m_clrButtonHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonHighlightedClose | CXTPTabPaintManagerColorSet |
m_clrButtonNormal | CXTPTabPaintManagerColorSet |
m_clrButtonPressed | CXTPTabPaintManagerColorSet |
m_clrButtonSelected | CXTPTabPaintManagerColorSet |
m_clrButtonSelectedHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonSelectedPressed | CXTPTabPaintManagerColorSet |
m_clrControlFace | CXTPTabPaintManagerColorSet |
m_clrFrameBorder | CXTPTabPaintManagerColorSet |
m_clrHeaderFace | CXTPTabPaintManagerColorSet |
m_clrPaneFace | CXTPTabPaintManagerColorSet |
m_clrTabClientBack | CXTPTabPaintManagerColorSet |
m_clrTabClientBorder | CXTPTabPaintManagerColorSet |
m_clrTextDisabled | CXTPTabPaintManagerColorSet |
m_clrTextHighlight | CXTPTabPaintManagerColorSet |
m_clrTextHighlightClose | CXTPTabPaintManagerColorSet |
m_clrTextNormal | CXTPTabPaintManagerColorSet |
m_clrTextPressed | CXTPTabPaintManagerColorSet |
m_clrTextSelected | CXTPTabPaintManagerColorSet |
m_clrTextSelectedHighlighted | CXTPTabPaintManagerColorSet |
m_clrTextSelectedPressed | CXTPTabPaintManagerColorSet |
m_csExcelNormal | CXTPTabPaintManagerColorSet |
m_csExcelSelected | CXTPTabPaintManagerColorSet |
m_csPropertyPage | CXTPTabPaintManagerColorSet |
m_csPropertyPage2003 | CXTPTabPaintManagerColorSet |
m_csStateButton | CXTPTabPaintManagerColorSet |
m_pPaintManager | CXTPTabPaintManagerColorSet | protected
RefreshMetrics() | CXTPTabColorSetDefault | virtual
SelectClipRgn(CDC *pDC, CRect rcClient, CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
SetTextColor(CDC *pDC, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerColorSet | virtual
~CXTPTabPaintManagerColorSet() | CXTPTabPaintManagerColorSet | virtual


Toolkit Pro: XTPControlGalleryOffice2013Theme.h Source File

  • Source
  • CommandBars
  • Gallery
XTPControlGalleryOffice2013Theme.h
Go to the documentation of this file.
1
23#if !defined(__XTPCONTROLGALLERYOFFICE2013THEME_H__)
24# define __XTPCONTROLGALLERYOFFICE2013THEME_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
40class _XTP_EXT_CLASS CXTPControlGalleryOffice2013Theme : public CXTPControlGalleryPaintManager
41{
42public:
48 CXTPControlGalleryOffice2013Theme(CXTPPaintManager* pPaintManager);
49
50protected:
51 void DrawScrollButton(CDC* pDC, const CRect& rc, int type, CXTPControlGallery* pGallery);
52
60 virtual void FillControl(CDC* pDC, CXTPControlGallery* pGallery, CRect rc);
61
62public:
67 virtual void RefreshMetrics();
68
77 virtual void DrawPopupScrollBar(CDC* pDC, CXTPControlGallery* pGallery);
78
79protected:
80 COLORREF m_clrBack;
81 COLORREF m_clrScrollTriangle;
82 COLORREF m_clrScrollTriangleDisabled;
83 COLORREF m_clrScrollTriangleHot;
84 COLORREF m_clrScrollTrianglePressed;
85 COLORREF m_clrScrollBorderDisabled;
86 COLORREF m_clrScrollBorderNormal;
87 COLORREF m_clrScrollBorderHot;
88 COLORREF m_clrScrollFillHot;
89 COLORREF m_clrScrollFillPressed;
90};
91
93# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
94#endif // !defined(__XTPCONTROLGALLERYOFFICE2013THEME_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPControlGallery
CXTPControlGallery is a CXTPControlPopup derived class.
Definition XTPControlGallery.h:63
CXTPControlGalleryOffice2013Theme
The CXTPControlGalleryResourceTheme class is used to enable a Gallery Office 2013 style theme for Com...
Definition XTPControlGalleryOffice2013Theme.h:41
CXTPControlGalleryOffice2013Theme::CXTPControlGalleryOffice2013Theme
CXTPControlGalleryOffice2013Theme(CXTPPaintManager *pPaintManager)
Constructs a CXTPControlGalleryOffice2013Theme object.
CXTPControlGalleryOffice2013Theme::DrawPopupScrollBar
virtual void DrawPopupScrollBar(CDC *pDC, CXTPControlGallery *pGallery)
This method is called to draw the scrollbar of the inplace gallery.
CXTPControlGalleryOffice2013Theme::FillControl
virtual void FillControl(CDC *pDC, CXTPControlGallery *pGallery, CRect rc)
This method is called to draw the background of the gallery.
CXTPControlGalleryOffice2013Theme::RefreshMetrics
virtual void RefreshMetrics()
This method is called to refresh the visual metrics of the manager.
CXTPControlGalleryPaintManager
CXTPControlGalleryPaintManager is a standalone class used to draw a CXTPControlGallery object.
Definition XTPControlGallery.h:682
CXTPPaintManager
Paint manager of the command bars.
Definition XTPPaintManager.h:199


Toolkit Pro: XTPDockingPaneThemeNativeWindows10.h Source File

  • Source
  • DockingPane
  • Themes
XTPDockingPaneThemeNativeWindows10.h
Go to the documentation of this file.
1
23#if !defined(__XTPDOCKINGPANETHEMENATIVEWINDOWS10_H__)
24# define __XTPDOCKINGPANETHEMENATIVEWINDOWS10_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPDockingPaneNativeWindows10Theme
39 : public CXTPDockingPaneVisualStudio2012Theme
40{
41public:
46 CXTPDockingPaneNativeWindows10Theme();
47
53 virtual ~CXTPDockingPaneNativeWindows10Theme();
54
60 virtual void RefreshMetrics();
61
68 virtual void DrawSplitter(CDC* pDC, CXTPDockingPaneSplitterWnd* pSplitter);
69
79 virtual void DrawAutoHidePanel(CDC* pDC, CRect rc, XTPDockingPaneDirection direction);
80
81protected:
91 virtual void DrawTitleBar(CDC* pDC, CXTPDockingPaneBase* pPane, CRect rc, BOOL bVertical);
92
93 COLORREF m_clrCaptionBorder;
94};
95
96# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
98#endif // !defined(__XTPDOCKINGPANETHEMENATIVEWINDOWS10_H__)
XTPDisableNoisyWarnings.h
XTPDockingPaneDirection
XTPDockingPaneDirection
Docking direction enumeration.
Definition XTPDockingPaneDefines.h:51
XTPEnableNoisyWarnings.h
CXTPDockingPaneBase
CXTPDockingPaneBase is a standalone class.
Definition XTPDockingPaneBase.h:69
CXTPDockingPaneNativeWindows10Theme
CXTPDockingPaneNativeWindows10Theme is used to define drawing routines specific to a Native Windows 1...
Definition XTPDockingPaneThemeNativeWindows10.h:40
CXTPDockingPaneNativeWindows10Theme::~CXTPDockingPaneNativeWindows10Theme
virtual ~CXTPDockingPaneNativeWindows10Theme()
Destroys a CXTPDockingPaneNativeWindows10Theme object, handles cleanup and deallocation.
CXTPDockingPaneNativeWindows10Theme::DrawTitleBar
virtual void DrawTitleBar(CDC *pDC, CXTPDockingPaneBase *pPane, CRect rc, BOOL bVertical)
This member function is called to draw a title bar for the docking pane.
CXTPDockingPaneNativeWindows10Theme::DrawSplitter
virtual void DrawSplitter(CDC *pDC, CXTPDockingPaneSplitterWnd *pSplitter)
Override this method to draw a splitter.
CXTPDockingPaneNativeWindows10Theme::CXTPDockingPaneNativeWindows10Theme
CXTPDockingPaneNativeWindows10Theme()
Constructs a CXTPDockingPaneNativeWindows10Theme object.
CXTPDockingPaneNativeWindows10Theme::DrawAutoHidePanel
virtual void DrawAutoHidePanel(CDC *pDC, CRect rc, XTPDockingPaneDirection direction)
This method is called by the framework to draw the docking pane auto-hide panel background and splitt...
CXTPDockingPaneNativeWindows10Theme::RefreshMetrics
virtual void RefreshMetrics()
This member function is used to initialize default colors for a theme from an .INI resource.
CXTPDockingPaneNativeWindows10Theme::m_clrCaptionBorder
COLORREF m_clrCaptionBorder
Caption border color.
Definition XTPDockingPaneThemeNativeWindows10.h:93
CXTPDockingPaneSplitterWnd
CXTPDockingPaneSplitterWnd is a CWnd derived class.
Definition XTPDockingPaneSplitterContainer.h:42
CXTPDockingPaneVisualStudio2012Theme
CXTPDockingPaneVisualStudio2012Theme is used to define drawing routines specific to a Visual Studio 2...
Definition XTPDockingPaneThemeVisualStudio2012.h:41


Toolkit Pro: Member List

CXTPMarqueeCtrlThemeVisualStudio2019 Member List

This is the complete list of members for CXTPMarqueeCtrlThemeVisualStudio2019, including all inherited members.

CXTPMarqueeCtrlPaintManager() | CXTPMarqueeCtrlPaintManager |
CXTPMarqueeCtrlThemeOffice2000() | CXTPMarqueeCtrlThemeOffice2000 |
CXTPMarqueeCtrlThemeOffice2013() | CXTPMarqueeCtrlThemeOffice2013 |
CXTPMarqueeCtrlThemeVisualStudio2019() | CXTPMarqueeCtrlThemeVisualStudio2019 |
DeflateRect(CDC *pDC, CRect &rcClient) | CXTPMarqueeCtrlPaintManager | protectedvirtual
DrawBackground(CXTPMarqueeCtrl *pWndCtrl, CDC *pDC, CRect &rcClient) | CXTPMarqueeCtrlPaintManager | virtual
DrawChunk(CXTPMarqueeCtrl *pWndCtrl, CDC *pDC, CXTPCompatibleDC &dcChunk, int i, int &x, int &y, int cx, int cy) | CXTPMarqueeCtrlPaintManager | protectedvirtual
DrawMarquee(CXTPMarqueeCtrl *pWndCtrl, CDC *pDC, CRect &rcClient) | CXTPMarqueeCtrlPaintManager | virtual
GetBackColor() | CXTPMarqueeCtrlPaintManager |
GetBarColor() | CXTPMarqueeCtrlPaintManager |
GetBorderColor() | CXTPMarqueeCtrlPaintManager |
m_bUseWinTheme | CXTPMarqueeCtrlPaintManager | protected
m_clr3DHilite | CXTPMarqueeCtrlPaintManager | protected
m_clr3DShadow | CXTPMarqueeCtrlPaintManager | protected
m_clrBack | CXTPMarqueeCtrlPaintManager | protected
m_clrBar | CXTPMarqueeCtrlPaintManager | protected
m_nTheme | CXTPMarqueeCtrlPaintManager | protected
m_winTheme | CXTPMarqueeCtrlPaintManager | protected
RefreshMetrics() | CXTPMarqueeCtrlThemeOffice2013 | virtual
SetBackColor(COLORREF clrNew) | CXTPMarqueeCtrlPaintManager |
SetBarColor(COLORREF clrNew) | CXTPMarqueeCtrlPaintManager |
SetBorderColor(COLORREF clrNew) | CXTPMarqueeCtrlPaintManager |
UseWinThemes(BOOL bUseWinThemes=TRUE) | CXTPMarqueeCtrlPaintManager |
UsingWinThemes(BOOL bCheckReady=FALSE) | CXTPMarqueeCtrlPaintManager |
~CXTPMarqueeCtrlPaintManager() | CXTPMarqueeCtrlPaintManager | virtual


Toolkit Pro: Member List

CXTPChartPolygonAntialiasingDeviceCommand Member List

This is the complete list of members for CXTPChartPolygonAntialiasingDeviceCommand, including all inherited members.

AddChildCommand(CXTPChartDeviceCommand *pCommand) | CXTPChartDeviceCommand |
AfterExecute(CXTPChartDeviceContext *pDC)=0 | CXTPChartPolygonAntialiasingDeviceCommand | pure virtual
ApplySeriesStyle(CXTPChartSeriesStyle *pStyle) | CXTPChartDeviceCommand | virtual
BeforeExecute(CXTPChartDeviceContext *pDC)=0 | CXTPChartPolygonAntialiasingDeviceCommand | pure virtual
BindView(CXTPChartElementView *pView) | CXTPChartDeviceCommand |
Commit() | CXTPChartDeviceCommand |
CXTPChartDeviceCommand() | CXTPChartDeviceCommand |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartPolygonAntialiasingDeviceCommand(BOOL bAntiAlias=TRUE) | CXTPChartPolygonAntialiasingDeviceCommand |
CXTPObservable() | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | protected
Execute(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
ExecuteOverride(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
GetBoundView() const | CXTPChartDeviceCommand |
GetChildCommand(int nIndex) const | CXTPChartDeviceCommand |
GetChildCommandCount() const | CXTPChartDeviceCommand |
GetCurrentDC() const | CXTPChartDeviceCommand |
GetPassNumber() const | CXTPChartDeviceCommand |
HitTest(CPoint point, CXTPChartElement *pParent) const | CXTPChartDeviceCommand | virtual
Is3D() const | CXTPChartObject |
IsCommitted() const | CXTPChartDeviceCommand |
IsEnabled() const | CXTPChartDeviceCommand | virtual
m_arrChildren | CXTPChartDeviceCommand | protected
m_bAntiAlias | CXTPChartPolygonAntialiasingDeviceCommand | protected
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Prepare(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
PrepareOverride(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
SetEnabled(BOOL bEnabled=TRUE) | CXTPChartDeviceCommand |
Subscribe(CXTPChartDeviceCommandEvents *pObserver, CXTPSubscriptionList< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > *pSubcriptionList=NULL) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > |
Unsubscribe(CXTPChartDeviceCommandEvents *pObserver) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > |
~CXTPChartDeviceCommand() | CXTPChartDeviceCommand | virtual
~CXTPObservable() | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | protected


Toolkit Pro: Member List

CXTPChart3dFunnelSeriesView Member List

This is the complete list of members for CXTPChart3dFunnelSeriesView, including all inherited members.

AddChildView(CXTPChartElementView *pChildView) | CXTPChartElementView |
CalculateLabelLayout(CXTPChartDeviceContext *pDC) | CXTPChartFunnelSeriesViewBase |
CalculatePointLayout(CXTPChartDeviceContext *pDC, CRect rcBounds) | CXTPChart3dFunnelSeriesView | virtual
CreateDeviceCommand(CXTPChartDeviceContext *pDC) | CXTPChart3dFunnelSeriesView | protectedvirtual
CreateDiagramDomain(CXTPChartDeviceContext *pDC, CRect rcBounds) | CXTPChartFunnelSeriesViewBase | virtual
CreateLegendDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcBounds) | CXTPChart3dFunnelSeriesView | protectedvirtual
CreateLegendDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcBounds, CXTPChartColor color1, CXTPChartColor color2, CXTPChartColor clrBorder) | CXTPChart3dFunnelSeriesView | protectedvirtual
CreateSeriesPointView(CXTPChartDeviceContext *pDC, CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView) | CXTPChart3dFunnelSeriesView | protectedvirtual
CXTPChart3dFunnelSeriesView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView) | CXTPChart3dFunnelSeriesView |
CXTPChartElementView(CXTPChartElementView *pParentView) | CXTPChartElementView |
CXTPChartElementView(CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartElementView |
CXTPChartElementView(CXTPChartContainer *pContainer) | CXTPChartElementView |
CXTPChartFunnelSeriesViewBase(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView) | CXTPChartFunnelSeriesViewBase |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
GetAt(int nIndex) const | CXTPChartElementView |
GetBounds() const | CXTPChartElementView |
GetBounds(BOOL bIncludingChildren) const | CXTPChartElementView |
GetChildren() | CXTPChartElementView |
GetCount() const | CXTPChartElementView |
GetDomain() const | CXTPChartFunnelSeriesViewBase |
GetInnerBounds() const | CXTPChartFunnelSeriesViewBase | virtual
GetMaxLabelWidth() const | CXTPChartFunnelSeriesViewBase |
GetParentView() const | CXTPChartElementView |
Is3D() const | CXTPChartObject |
m_arrChildren | CXTPChartElementView | protected
m_pContainer | CXTPChartElementView | protected
m_pDomain | CXTPChartFunnelSeriesViewBase | protected
m_pParentView | CXTPChartElementView | protected
m_rcBounds | CXTPChartElementView | protected
~CXTPChartElementView() | CXTPChartElementView | protectedvirtual
~CXTPChartFunnelSeriesViewBase() | CXTPChartFunnelSeriesViewBase | virtual
~CXTPChartLegendItemView() | CXTPChartLegendItemView | inlinevirtual


Toolkit Pro: Member List

CXTPTabColorSetVisualStudio2019 Member List

This is the complete list of members for CXTPTabColorSetVisualStudio2019, including all inherited members.

CXTPTabPaintManagerColorSet() | CXTPTabPaintManagerColorSet |
FillClient(CDC *pDC, CRect rc, CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
FillHeader(CDC *pDC, CRect rc, CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
FillNavigateButton(CDC *pDC, CXTPTabManagerNavigateButton *pButton, CRect &rc) | CXTPTabColorSetVisualStudio2015 | virtual
FillPropertyButton(CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem) | CXTPTabColorSetVisualStudio2015 | virtual
FillStateButton(CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerColorSet | virtual
GetClientColor(CXTPTabManager *pTabManager) | CXTPTabColorSetVisualStudio2015 | virtual
GetItemColor(CXTPTabManagerItem *pItem) | CXTPTabColorSetVisualStudio2015 | virtual
GradientFill(CDC *pDC, CRect rc, COLORREF clrLight, COLORREF clrDark, XTPTabPosition position) | CXTPTabPaintManagerColorSet |
IsAppThemed() const | CXTPTabPaintManagerColorSet | virtual
m_clrActiveFilesBack | CXTPTabPaintManagerColorSet |
m_clrActiveFilesBackHighlighted | CXTPTabPaintManagerColorSet |
m_clrActiveFilesBackPressed | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyph | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyphHighlighted | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyphPressed | CXTPTabPaintManagerColorSet |
m_clrAutoHideFace | CXTPTabPaintManagerColorSet |
m_clrBorderHighlight | CXTPTabPaintManagerColorSet |
m_clrButtonBorder | CXTPTabPaintManagerColorSet |
m_clrButtonBorderHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonBorderHot | CXTPTabPaintManagerColorSet |
m_clrButtonBorderKeyTips | CXTPTabPaintManagerColorSet |
m_clrButtonBorderTabContext1 | CXTPTabPaintManagerColorSet |
m_clrButtonBorderTabContext2 | CXTPTabPaintManagerColorSet |
m_clrButtonHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonHighlightedClose | CXTPTabPaintManagerColorSet |
m_clrButtonNormal | CXTPTabPaintManagerColorSet |
m_clrButtonPressed | CXTPTabPaintManagerColorSet |
m_clrButtonSelected | CXTPTabPaintManagerColorSet |
m_clrButtonSelectedHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonSelectedPressed | CXTPTabPaintManagerColorSet |
m_clrControlFace | CXTPTabPaintManagerColorSet |
m_clrFrameBorder | CXTPTabPaintManagerColorSet |
m_clrHeaderFace | CXTPTabPaintManagerColorSet |
m_clrPaneFace | CXTPTabPaintManagerColorSet |
m_clrTabClientBack | CXTPTabPaintManagerColorSet |
m_clrTabClientBorder | CXTPTabPaintManagerColorSet |
m_clrTextDisabled | CXTPTabPaintManagerColorSet |
m_clrTextHighlight | CXTPTabPaintManagerColorSet |
m_clrTextHighlightClose | CXTPTabPaintManagerColorSet |
m_clrTextNormal | CXTPTabPaintManagerColorSet |
m_clrTextPressed | CXTPTabPaintManagerColorSet |
m_clrTextSelected | CXTPTabPaintManagerColorSet |
m_clrTextSelectedHighlighted | CXTPTabPaintManagerColorSet |
m_clrTextSelectedPressed | CXTPTabPaintManagerColorSet |
m_csExcelNormal | CXTPTabPaintManagerColorSet |
m_csExcelSelected | CXTPTabPaintManagerColorSet |
m_csPropertyPage | CXTPTabPaintManagerColorSet |
m_csPropertyPage2003 | CXTPTabPaintManagerColorSet |
m_csStateButton | CXTPTabPaintManagerColorSet |
m_pPaintManager | CXTPTabPaintManagerColorSet | protected
RefreshMetrics() | CXTPTabColorSetVisualStudio2019 | virtual
SelectClipRgn(CDC *pDC, CRect rcClient, CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
SetTextColor(CDC *pDC, CXTPTabManagerItem *pItem) | CXTPTabColorSetVisualStudio2015 | virtual
~CXTPTabPaintManagerColorSet() | CXTPTabPaintManagerColorSet | virtual


Toolkit Pro: Member List

XTP_TPNGROUPEXPANDING Member List

This is the complete list of members for XTP_TPNGROUPEXPANDING, including all inherited members.

bExpanding | XTP_TPNGROUPEXPANDING
pGroup | XTP_TPNGROUPEXPANDING


Toolkit Pro: Member List

CXTPChartAxisGridLines Member List

This is the complete list of members for CXTPChartAxisGridLines, including all inherited members.

CXTPChartAxisGridLines(CXTPChartAxis *pAxis) | CXTPChartAxisGridLines |
CXTPChartElement() | CXTPChartElement |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
DoPropExchange(CXTPPropExchange *pPX) | CXTPChartAxisGridLines | virtual
GetAppearance() const | CXTPChartElement |
GetAxis() const | CXTPChartAxisGridLines |
GetColor() const | CXTPChartAxisGridLines |
GetContent() const | CXTPChartElement |
GetLineStyle() const | CXTPChartAxisGridLines |
GetMinorColor() const | CXTPChartAxisGridLines |
GetMinorLineStyle() const | CXTPChartAxisGridLines |
GetOwner() const | CXTPChartElement |
Is3D() const | CXTPChartObject |
IsMinorVisible() const | CXTPChartAxisGridLines |
IsVisible() const | CXTPChartAxisGridLines |
m_bMinorVisible | CXTPChartAxisGridLines | protected
m_bVisible | CXTPChartAxisGridLines | protected
m_clrColor | CXTPChartAxisGridLines | protected
m_clrMinorColor | CXTPChartAxisGridLines | protected
m_pLineStyle | CXTPChartAxisGridLines | protected
m_pMinorLineStyle | CXTPChartAxisGridLines | protected
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartElement | virtual
Release() | CXTPChartElement | virtual
SetMinorVisible(BOOL bMinorVisible) | CXTPChartAxisGridLines |
SetVisible(BOOL bVisible) | CXTPChartAxisGridLines |
~CXTPChartAxisGridLines() | CXTPChartAxisGridLines | virtual
~CXTPChartElement() | CXTPChartElement | virtual


Toolkit Pro: Member List

CXTPChartObject Member List

This is the complete list of members for CXTPChartObject, including all inherited members.

CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
Is3D() const | CXTPChartObject |


Toolkit Pro: Member List

CXTPControlGalleryVisualStudio2015Theme Member List

This is the complete list of members for CXTPControlGalleryVisualStudio2015Theme, including all inherited members.

CXTPControlGalleryOffice2013Theme(CXTPPaintManager *pPaintManager) | CXTPControlGalleryOffice2013Theme |
CXTPControlGalleryPaintManager(CXTPPaintManager *pPaintManager) | CXTPControlGalleryPaintManager |
CXTPControlGalleryVisualStudio2015Theme(CXTPPaintManager *pPaintManager) | CXTPControlGalleryVisualStudio2015Theme |
DrawLabel(CDC *pDC, CXTPControlGalleryItem *pLabel, CRect rc) | CXTPControlGalleryPaintManager | virtual
DrawPopupScrollBar(CDC *pDC, CXTPControlGallery *pGallery) | CXTPControlGalleryOffice2013Theme | virtual
FillControl(CDC *pDC, CXTPControlGallery *pGallery, CRect rc) | CXTPControlGalleryOffice2013Theme | protectedvirtual
m_cxPopup | CXTPControlGalleryPaintManager |
m_cyPopupDown | CXTPControlGalleryPaintManager |
m_cyPopupUp | CXTPControlGalleryPaintManager |
RefreshMetrics() | CXTPControlGalleryOffice2013Theme | virtual


Toolkit Pro: Member List

CXTPGaugeBaseType Member List

This is the complete list of members for CXTPGaugeBaseType, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPGaugeBaseType() | CXTPGaugeBaseType | protected
DumpTraits(CString &strTraits) const | CXTPGaugeBaseType |
EnableAutomaticUpdate(BOOL bEnable=TRUE) | CXTPGaugeBaseType |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetTrait(LPCTSTR pJPath, COleVariant &vtValue) const | CXTPGaugeBaseType |
GetTypeName() const =0 | CXTPGaugeBaseType | pure virtual
InvokeAction(LPCTSTR lpName, const COleVariant &vtArg=COleVariant(), COleVariant *pvtResult=NULL) | CXTPGaugeBaseType |
IsAutomaticUpdateEnabled() const | CXTPGaugeBaseType |
SetTrait(LPCTSTR pJPath, const COleVariant &vtValue) | CXTPGaugeBaseType |
Update() | CXTPGaugeBaseType |
~CXTPGaugeBaseType() | CXTPGaugeBaseType |


Toolkit Pro: Member List

CXTPCaptionButtonThemeOffice2003 Member List

This is the complete list of members for CXTPCaptionButtonThemeOffice2003, including all inherited members.

CXTPButtonTheme() | CXTPButtonTheme |
CXTPButtonThemeOffice2003() | CXTPButtonThemeOffice2003 |
CXTPButtonThemeOfficeXP() | CXTPButtonThemeOfficeXP |
CXTPButtonThemeUltraFlat() | CXTPButtonThemeUltraFlat |
CXTPCmdTarget() | CXTPCmdTarget |
CXTPControlTheme() | CXTPControlTheme |
DrawButton(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
DrawButtonBackground(CDC *pDC, CXTPButton *pButton) | CXTPCaptionButtonThemeOffice2003 | protectedvirtual
DrawButtonText(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme |
DrawButtonVisualStyleBackground(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
DrawCheckBoxMark(CDC *pDC, CXTPButton *pButton) | CXTPButtonThemeUltraFlat | virtual
DrawFocusRect(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
DrawGroupBox(CDC *pDC, CXTPButton *pButton) | CXTPButtonThemeUltraFlat | virtual
DrawPushButtonDropDown(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
DrawPushButtonIcon(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
DrawPushButtonText(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
DrawRadioButtonMark(CDC *pDC, CXTPButton *pButton) | CXTPButtonThemeUltraFlat | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetTextColor(CXTPButton *pButton) | CXTPCaptionButtonThemeOffice2003 | protectedvirtual
GetThemeStyle() const | CXTPControlTheme |
m_crBack | CXTPButtonTheme |
m_crBackChecked | CXTPButtonThemeUltraFlat |
m_crBackHilite | CXTPButtonThemeUltraFlat |
m_crBackPushed | CXTPButtonThemeUltraFlat |
m_crBorder3DHilite | CXTPButtonTheme |
m_crBorder3DShadow | CXTPButtonTheme |
m_crBorderHilite | CXTPButtonTheme |
m_crBorderPushed | CXTPButtonThemeUltraFlat |
m_crBorderShadow | CXTPButtonTheme |
m_crCheckMark | CXTPButtonThemeUltraFlat |
m_crText | CXTPButtonTheme |
m_crTextCheck | CXTPButtonTheme |
m_crTextDisabled | CXTPButtonTheme |
m_crTextHilite | CXTPButtonThemeUltraFlat |
m_crTextPushed | CXTPButtonThemeUltraFlat |
m_nTheme | CXTPControlTheme | protected
RefreshMetrics(CXTPButton *pButton) | CXTPButtonThemeOffice2003 | virtual
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static
~CXTPButtonTheme() | CXTPButtonTheme | virtual


Toolkit Pro: Member List

CXTPCalendarPaintManager Member List

This is the complete list of members for CXTPCalendarPaintManager, including all inherited members.

_GetAtGrow_BusyStatusBrushValue(int eBusyStatus, BOOL bGrow) | CXTPCalendarPaintManager | protected
_Init() | CXTPCalendarPaintManager | virtual
AddViewPart(CXTPCalendarViewPart *pPart) | CXTPCalendarPaintManager | protected
AdjustTimeFont(CDC *pDC, CRect rcCell) | CXTPCalendarPaintManager |
BEGIN_VIEW_PART(ControlPart, XTPCalendarViewPart) virtual void RefreshMetrics() | CXTPCalendarPaintManager |
CalcEventSize(CDC *c, CXTPCalendarTimeLineViewEvent *pViewEvent) | CXTPCalendarPaintManager | virtual
CalcWidth(CDC *pDC, const CString &strHour, const CString &strMin, int nHourHeight, int &nWidth) | CXTPCalendarPaintManager |
CXTPCalendarPaintManager() | CXTPCalendarPaintManager |
CXTPCmdTarget() | CXTPCmdTarget |
DrawBigHourCell(CDC *pDC, CRect rc, CString strHour, CString strMin, int nRowPerHour, BOOL bFillBackground=TRUE, BOOL bCurrentTime=FALSE) | CXTPCalendarPaintManager | virtual
DrawBitmap(CImageList *pImageList, CDC *pDC, CRect rcView, int iIcon, UINT uFlags=0) | CXTPCalendarPaintManager | virtual
DrawBitmap(UINT nIDResource, CDC *pDC, CRect rcBitmap) | CXTPCalendarPaintManager | virtual
DrawBorder(CDC *pDC, CRect rcView, CXTPCalendarWeekViewEvent *pWeekViewEvent) | CXTPCalendarPaintManager | virtual
DrawBusyStatus(CDC *pDC, CRect &rcRect, int eBusyStatus) | CXTPCalendarPaintManager | virtual
DrawBusyStatus(CDC *pDC, CRgn &rgnBusy, int eBusyStatus) | CXTPCalendarPaintManager | virtual
DrawClock(CDC *pDC, COleDateTime dtClockTime, CRect rcView, COLORREF clrBackground, XTPCalendarClockAlignFlags cafAlign) | CXTPCalendarPaintManager | virtual
DrawDayHeader(CDC *pDC, CRect rcDay, int nHeaderHeight, CString strHeader, BOOL bIsCurrent=FALSE, BOOL bIsSelected=FALSE) | CXTPCalendarPaintManager | virtual
DrawEvent(CDC *pDC, const CRect &rcEvents, CXTPCalendarTimeLineViewEvent *pViewEvent) | CXTPCalendarPaintManager | virtual
DrawExpandSigns(CDC *pDC, CXTPCalendarDayView *pView, const CRect &rcTSHours) | CXTPCalendarPaintManager | virtual
DrawGroup(CDC *pDC, const CRect &rcRect, CXTPCalendarTimeLineViewGroup *pGroup) | CXTPCalendarPaintManager | virtual
DrawHeader(CDC *pDC, CRect &rcHeader, BOOL bIsSelected, BOOL bIsCurrent) | CXTPCalendarPaintManager | virtual
DrawHeader(CDC *pDC, CRect &rcHeader, BOOL bIsSelected, BOOL bIsCurrent, const CXTPPaintManagerColorGradient &grclr, COLORREF clrUnderLineHdr) | CXTPCalendarPaintManager | virtual
DrawHorizontalLine(CDC *pDC, int xPos, int yPos, int cx) | CXTPCalendarPaintManager | virtual
DrawHourCell(CDC *pDC, CRect rc, CString strText, BOOL bFillBackground=TRUE, BOOL bCurrentTime=FALSE) | CXTPCalendarPaintManager | virtual
DrawIconChar(CDC *pDC, CRect rc, TCHAR ch) | CXTPCalendarPaintManager | virtual
DrawIcons(CDC *pDC, CXTPCalendarViewEvent *pViewEvent) | CXTPCalendarPaintManager | virtual
DrawLine(CDC *pDC, int xPos, int yPos, int cx, int cy) | CXTPCalendarPaintManager | virtual
DrawNowLine(CDC *pDC, CXTPCalendarDayView *pView, CRect rc, int y, BOOL bDrawBk=FALSE) | CXTPCalendarPaintManager | virtual
DrawNowLine(CDC *pDC, CXTPCalendarDayView *pView, CXTPCalendarDayViewTimeScale *pScale, CRect rc, int y, BOOL bDrawBk=FALSE) | CXTPCalendarPaintManager | virtual
DrawShadow(CDC *pDC, const CRect &rcRect) | CXTPCalendarPaintManager | virtual
DrawSubj(CDC *pDC, CXTPCalendarWeekViewEvent *pWeekViewEvent) | CXTPCalendarPaintManager | virtual
DrawTimes(CDC *pDC, CXTPCalendarWeekViewEvent *pWeekViewEvent) | CXTPCalendarPaintManager | virtual
DrawVerticalLine(CDC *pDC, int xPos, int yPos, int cy) | CXTPCalendarPaintManager | virtual
EnableTheme(BOOL bEnableTheme) | CXTPCalendarPaintManager |
END_VIEW_PART(ControlPart) BEGIN_VIEW_PART(DayViewTimeScaleHeaderPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewTimeScaleHeaderPart) BEGIN_VIEW_PART(DayViewTimeScaleCellPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewTimeScaleCellPart) BEGIN_VIEW_PART(DayViewCellPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewCellPart) BEGIN_VIEW_PART(DayViewWorkCellPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewWorkCellPart) BEGIN_VIEW_PART(DayViewNonworkCellPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewNonworkCellPart) BEGIN_VIEW_PART(DayMonthViewHeaderPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayMonthViewHeaderPart) BEGIN_VIEW_PART(DayViewHeaderPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewHeaderPart) BEGIN_VIEW_PART(DayViewGroupHeaderPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewGroupHeaderPart) BEGIN_VIEW_PART(DayViewAllDayEventsPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewAllDayEventsPart) BEGIN_VIEW_PART(DayViewAllDayEventScrollIconsPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewAllDayEventScrollIconsPart) BEGIN_VIEW_PART(DayViewEventPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewEventPart) BEGIN_VIEW_PART(MonthViewGridPart | CXTPCalendarPaintManager |
END_VIEW_PART(MonthViewGridPart) BEGIN_VIEW_PART(MonthViewHeaderPart | CXTPCalendarPaintManager |
END_VIEW_PART(MonthViewHeaderPart) BEGIN_VIEW_PART(MonthViewEventPart | CXTPCalendarPaintManager |
END_VIEW_PART(MonthViewEventPart) BEGIN_VIEW_PART(WeekViewPart | CXTPCalendarPaintManager |
END_VIEW_PART(WeekViewPart) BEGIN_VIEW_PART(WeekViewEventPart | CXTPCalendarPaintManager |
END_VIEW_PART(WeekViewEventPart) BEGIN_VIEW_PART(TimeLineViewTimeScalePart_Day | CXTPCalendarPaintManager |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAskItemTextFlags() const | CXTPCalendarPaintManager |
GetBusyStatusBrush(int nBusyStatus) | CXTPCalendarPaintManager |
GetClockSize() | CXTPCalendarPaintManager | virtual
GetCurrentSystemTheme() | CXTPCalendarPaintManager |
GetEventBackColor(CXTPCalendarEvent *pEvent, COLORREF crDefault) | CXTPCalendarPaintManager | virtual
GetExpandSignSize() | CXTPCalendarPaintManager | virtual
GetPaintTheme() const | CXTPCalendarPaintManager | virtual
GetParams(CXTPCalendarDayViewGroup *pViewGroup, XTP_CALENDAR_DAYVIEWCELL_PARAMS *rCellParams) | CXTPCalendarPaintManager | virtual
idxExpandSignDown enum value | CXTPCalendarPaintManager | protected
idxExpandSignUp enum value | CXTPCalendarPaintManager | protected
idxMeeting enum value | CXTPCalendarPaintManager | protected
idxPrivate enum value | CXTPCalendarPaintManager | protected
idxRecurrenceException enum value | CXTPCalendarPaintManager | protected
idxRecurrenceOccurrence enum value | CXTPCalendarPaintManager | protected
idxReminder enum value | CXTPCalendarPaintManager | protected
InitBusyStatusDefaultColors() | CXTPCalendarPaintManager | protectedvirtual
IsThemeEnabled() | CXTPCalendarPaintManager |
m_arBusyStatusBrushes | CXTPCalendarPaintManager | protected
m_arStartCol | CXTPCalendarPaintManager |
m_arStartRow | CXTPCalendarPaintManager |
m_bEnableTheme | CXTPCalendarPaintManager | protected
m_bmpElsewherePattern | CXTPCalendarPaintManager | protected
m_bmpTentativePattern | CXTPCalendarPaintManager | protected
m_bShowMinutes | CXTPCalendarPaintManager |
m_clr3DShadow | CXTPCalendarPaintManager |
m_clrBackground | CXTPCalendarPaintManager |
m_clrBackground2 | CXTPCalendarPaintManager |
m_clrBackgroundSlave | CXTPCalendarPaintManager |
m_clrBorders | CXTPCalendarPaintManager |
m_clrButtonFace | CXTPCalendarPaintManager |
m_clrButtonFaceText | CXTPCalendarPaintManager |
m_clrClassicUnderline | CXTPCalendarPaintManager |
m_clrEventBar | CXTPCalendarPaintManager |
m_clrEventBarLine | CXTPCalendarPaintManager |
m_clrEventBorderLine | CXTPCalendarPaintManager |
m_clrHeaderBottomLine | CXTPCalendarPaintManager |
m_clrHighlight | CXTPCalendarPaintManager |
m_clrHour | CXTPCalendarPaintManager |
m_clrMultiDayEventFrameColor | CXTPCalendarPaintManager |
m_clrSelectedBackground | CXTPCalendarPaintManager |
m_clrSelectedText | CXTPCalendarPaintManager |
m_clrShadow | CXTPCalendarPaintManager |
m_clrText | CXTPCalendarPaintManager |
m_clrTextHighLightColor | CXTPCalendarPaintManager |
m_clrTextNormalColor | CXTPCalendarPaintManager |
m_clrTimeScaleBackground | CXTPCalendarPaintManager |
m_clrTimeScaleHightlite | CXTPCalendarPaintManager |
m_clrTimeScaleText | CXTPCalendarPaintManager |
m_clrUnderLineHdr | CXTPCalendarPaintManager | protected
m_clrWeekendBackground | CXTPCalendarPaintManager |
m_clrWindow | CXTPCalendarPaintManager |
m_clrWindowText | CXTPCalendarPaintManager |
m_CurrSystemTheme | CXTPCalendarPaintManager | protected
m_dwAskItemTextFlags | CXTPCalendarPaintManager | protected
m_fntTimeText | CXTPCalendarPaintManager |
m_grclrClassicSelDay | CXTPCalendarPaintManager |
m_grclrToday | CXTPCalendarPaintManager |
m_lstViewParts | CXTPCalendarPaintManager | protected
m_nHourWidth | CXTPCalendarPaintManager |
m_nMinWidth | CXTPCalendarPaintManager |
m_nPaintTheme | CXTPCalendarPaintManager | protected
m_pControl | CXTPCalendarPaintManager | protected
m_pExpandSigns | CXTPCalendarPaintManager | protected
m_pGlyphs | CXTPCalendarPaintManager | protected
m_pGlyphsFont | CXTPCalendarPaintManager | protected
m_PrintPageWidth | CXTPCalendarPaintManager |
m_szClockRect | CXTPCalendarPaintManager | protected
m_xtpBrushElsewhere | CXTPCalendarPaintManager | protected
m_xtpBrushTentative | CXTPCalendarPaintManager | protected
OnDraw(CDC *pDC, CXTPCalendarDayView *pView, CRect rc, CString strText) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarDayViewGroup *pViewGroup, CRect rc, const XTP_CALENDAR_DAYVIEWCELL_PARAMS &cellParams) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarDayViewDay *pViewDay, CRect rc, CString strText) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarDayViewGroup *pViewGroup, CRect rc, CString strText) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarDayViewGroup *pViewGroup, CRect rc, BOOL bSelected) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarDayViewGroup *pViewGroup, BOOL bDrawUp, BOOL bDrawDown, const CRect &rcIconUp, const CRect &rcIconDown, BOOL bHighlightUp, BOOL bHighlightDown) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarDayViewEvent *pViewEvent) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarMonthView *pMonthView, CRect rc, int nCollIndex, CString strText) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarWeekView *pWeekView) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarWeekViewEvent *pWeekViewEvent) | CXTPCalendarPaintManager | virtual
OnDrawDayDate(CDC *pDC, CRect rc, BOOL bToday, BOOL bSelected, BOOL bFirstMonthDay, CString strText) | CXTPCalendarPaintManager | virtual
OnDrawEvent(CDC *pDC, CXTPCalendarMonthViewEvent *pViewEvent) | CXTPCalendarPaintManager | virtual
OnDrawGrid(CDC *pDC, CXTPCalendarMonthView *pMonthView) | CXTPCalendarPaintManager | virtual
RefreshMetrics() | CXTPCalendarPaintManager | virtual
RefreshMetrics() | CXTPCalendarPaintManager | virtual
RefreshMetrics() | CXTPCalendarPaintManager | virtual
RefreshMetrics() | CXTPCalendarPaintManager | virtual
RefreshMetrics() | CXTPCalendarPaintManager | virtual
RefreshMetrics() | CXTPCalendarPaintManager | inlinevirtual
RefreshMetrics() | CXTPCalendarPaintManager | virtual
RefreshMetrics() | CXTPCalendarPaintManager | virtual
RefreshMetrics() | CXTPCalendarPaintManager | virtual
RefreshMetrics() | CXTPCalendarPaintManager | virtual
RefreshMetrics() | CXTPCalendarPaintManager | virtual
RefreshMetrics() | CXTPCalendarPaintManager | inlinevirtual
RefreshMetrics() | CXTPCalendarPaintManager | virtual
RefreshMetrics() | CXTPCalendarPaintManager | virtual
SetAskItemTextFlags(DWORD dwFlags) | CXTPCalendarPaintManager |
SetBusyStatusBrush(int nBusyStatus, CBrush *pBrush, BOOL bAutodeleteBrush) | CXTPCalendarPaintManager |
SetControl(CXTPCalendarControl *pControl) | CXTPCalendarPaintManager | virtual
SetPaintTheme(XTPCalendarTheme ePaintTheme) | CXTPCalendarPaintManager | virtual
UpdateEventCategoriesDefaultColors() | CXTPCalendarPaintManager | virtual
UpdateEventLabelsDefaultColors() | CXTPCalendarPaintManager | virtual
UpdateGlyphs() | CXTPCalendarPaintManager | virtual
XTPEnumEventGlyphs enum name | CXTPCalendarPaintManager | protected
XTPEnumExpandSigns enum name | CXTPCalendarPaintManager | protected
~CTimeLineViewPart() | CXTPCalendarPaintManager | virtual
~CXTPCalendarPaintManager() | CXTPCalendarPaintManager | virtual


Toolkit Pro: Member List

  • CXTPTabManager
  • CRowIndexer
CXTPTabManager::CRowIndexer Member List

This is the complete list of members for CXTPTabManager::CRowIndexer, including all inherited members.

CreateIndexer(int nRowCount) | CXTPTabManager::CRowIndexer
CRowIndexer(CXTPTabManager *pManager) | CXTPTabManager::CRowIndexer
GetRowItems() const | CXTPTabManager::CRowIndexer
~CRowIndexer() | CXTPTabManager::CRowIndexer


Toolkit Pro: XTPTabThemePropertyPageAccess2007.h Source File

  • Source
  • TabManager
  • Themes
XTPTabThemePropertyPageAccess2007.h
Go to the documentation of this file.
1
23#if !defined(__XTPTABTHEMEPROPERTYPAGEACCESS2007_H__)
24# define __XTPTABTHEMEPROPERTYPAGEACCESS2007_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
43class _XTP_EXT_CLASS CAppearanceSetPropertyPageAccess2007 : public CAppearanceSetPropertyPage2007
44{
45public:
50 CAppearanceSetPropertyPageAccess2007()
51 {
52 m_rcHeaderMargin.SetRect(4, 1, 0, 0);
53 }
54
55protected:
64 virtual void RefreshMetrics();
65
84 virtual void DrawSingleButton(CDC* pDC, CXTPTabManagerItem* pItem);
85
105 virtual CRect FillTabControl(CXTPTabManager* pTabManager, CDC* pDC, CRect rcControl);
106
115 virtual XTPTabColorStyle GetDefaultColorSet()
116 {
117 return xtpTabColorOffice2007Access;
118 }
119
130 CRect GetButtonDrawRect(const CXTPTabManagerItem* pItem);
131
146 virtual CRect GetHeaderMargin()
147 {
148 return CRect(m_rcHeaderMargin.left, m_rcHeaderMargin.top,
149 m_rcHeaderMargin.right + m_nButtonHeight / 2, m_rcHeaderMargin.bottom);
150 }
151
152private:
153 void DrawButtonBackground(CDC* pDC, CXTPTabManagerItem* pItem, CRect rc);
154};
155
156# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
158#endif // !defined(__XTPTABTHEMEPROPERTYPAGEACCESS2007_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPTabColorStyle
XTPTabColorStyle
XTPTabColorStyle is an enumeration used to set the color style of tabs.
Definition XTPTabManagerDefines.h:139
xtpTabColorOffice2007Access
@ xtpTabColorOffice2007Access
Tabs will use the Office 2007 Access color style for the currently set Appearance.
Definition XTPTabManagerDefines.h:148
CAppearanceSetPropertyPage2007
CAppearanceSetPropertyPage2007 implements an Office 2007 tab appearance.
Definition XTPTabThemePropertyPage2007.h:44
CAppearanceSetPropertyPageAccess2007
CAppearanceSetPropertyPageAccess2007 implements an Office 2007 tab appearance.
Definition XTPTabThemePropertyPageAccess2007.h:44
CAppearanceSetPropertyPageAccess2007::GetDefaultColorSet
virtual XTPTabColorStyle GetDefaultColorSet()
Gets the default value of the color set for this theme.
Definition XTPTabThemePropertyPageAccess2007.h:115
CAppearanceSetPropertyPageAccess2007::GetHeaderMargin
virtual CRect GetHeaderMargin()
Gets the top, left, right, and bottom margins of the tab header.
Definition XTPTabThemePropertyPageAccess2007.h:146
CAppearanceSetPropertyPageAccess2007::FillTabControl
virtual CRect FillTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl)
Fills both the tab header and the tab client area and then draws the tab client frame.
CAppearanceSetPropertyPageAccess2007::GetButtonDrawRect
CRect GetButtonDrawRect(const CXTPTabManagerItem *pItem)
Retrieves the bounding rectangle of a specified drawing item.
CAppearanceSetPropertyPageAccess2007::CAppearanceSetPropertyPageAccess2007
CAppearanceSetPropertyPageAccess2007()
Constructs a CAppearanceSetPropertyPageAccess2007 object.
Definition XTPTabThemePropertyPageAccess2007.h:50
CAppearanceSetPropertyPageAccess2007::DrawSingleButton
virtual void DrawSingleButton(CDC *pDC, CXTPTabManagerItem *pItem)
Draws a single tab button in the tab client header area.
CAppearanceSetPropertyPageAccess2007::RefreshMetrics
virtual void RefreshMetrics()
Refreshes the appearance metrics.
CXTPTabManager
CXTPTabManager is the base class for docking pane tabs, tab control tabs, and MDI client tabs.
Definition XTPTabManager.h:87
CXTPTabManagerItem
CXTPTabManagerItem is the base class for the tabs that appear in the command bars tab workspace,...
Definition XTPTabManagerItem.h:44


Toolkit Pro: Member List

CXTPChartDiagram3DAppearance Member List

This is the complete list of members for CXTPChartDiagram3DAppearance, including all inherited members.

Antialiasing | CXTPChartDiagram3DAppearance |
ApplyToDeviceContext(CXTPChartDeviceContext *pDC) | CXTPChartDiagram3DAppearance | virtual
CXTPChartDiagram3DAppearance(CXTPChartElement *pOwner) | CXTPChartDiagram3DAppearance |
CXTPChartElement() | CXTPChartElement |
CXTPChartElementAppearance(CXTPChartElement *pOwner) | CXTPChartElementAppearance |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
DefaultAntialiasing | CXTPChartDiagram3DAppearance | static
DefaultLightAmbientColor | CXTPChartDiagram3DAppearance | static
DefaultLightDiffuseColor | CXTPChartDiagram3DAppearance | static
DefaultLightModelAmbientColor | CXTPChartDiagram3DAppearance | static
DefaultLightPosition | CXTPChartDiagram3DAppearance | static
DefaultLightSpecularColor | CXTPChartDiagram3DAppearance | static
DefaultMaterialDiffuseColor | CXTPChartDiagram3DAppearance | static
DefaultMaterialEmissionColor | CXTPChartDiagram3DAppearance | static
DefaultMaterialShininess | CXTPChartDiagram3DAppearance | static
DefaultMaterialSpecularColor | CXTPChartDiagram3DAppearance | static
DoPropExchange(CXTPPropExchange *pPX) | CXTPChartDiagram3DAppearance | virtual
GetAppearance() const | CXTPChartElement |
GetContent() const | CXTPChartElement |
GetOwner() const | CXTPChartElement |
Is3D() const | CXTPChartObject |
LightAmbientColor | CXTPChartDiagram3DAppearance |
LightDiffuseColor | CXTPChartDiagram3DAppearance |
LightModelAmbientColor | CXTPChartDiagram3DAppearance |
LightSpecularColor | CXTPChartDiagram3DAppearance |
MaterialDiffuseColor | CXTPChartDiagram3DAppearance |
MaterialEmissionColor | CXTPChartDiagram3DAppearance |
MaterialShininess | CXTPChartDiagram3DAppearance |
MaterialSpecularColor | CXTPChartDiagram3DAppearance |
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartElement | virtual
Release() | CXTPChartElement | virtual
~CXTPChartDiagram3DAppearance() | CXTPChartDiagram3DAppearance | virtual
~CXTPChartElement() | CXTPChartElement | virtual
~CXTPChartElementAppearance() | CXTPChartElementAppearance | virtual


Toolkit Pro: XTPDockingPaneThemeVisualStudio2012.h Source File

  • Source
  • DockingPane
  • Themes
XTPDockingPaneThemeVisualStudio2012.h
Go to the documentation of this file.
1
23#if !defined(__XTPDOCKINGPANETHEMEVISUALSTUDIO2012_H__)
24# define __XTPDOCKINGPANETHEMEVISUALSTUDIO2012_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPResourceImages;
34
40class _XTP_EXT_CLASS CXTPDockingPaneVisualStudio2012Theme : public CXTPDockingPaneDefaultTheme
41{
42public:
47 CXTPDockingPaneVisualStudio2012Theme();
48
54 virtual ~CXTPDockingPaneVisualStudio2012Theme();
55
61 virtual void RefreshMetrics();
62
70 virtual CRect GetPaneCaptionRect(const CXTPDockingPaneSidePanel* pPane);
71
80 virtual void AdjustClientRect(CXTPDockingPaneTabbedContainer* pPane, CRect& rc, BOOL bApply);
81
82# if _MSC_VER > 1200
83 using CXTPDockingPanePaintManager::AdjustClientRect;
84# endif
85
94 virtual void AdjustCaptionRect(const CXTPDockingPaneTabbedContainer* pPane, CRect& rc);
95
96# if _MSC_VER > 1200
97 using CXTPDockingPanePaintManager::AdjustCaptionRect;
98# endif
99
106 virtual void DrawSplitter(CDC* pDC, CXTPDockingPaneSplitterWnd* pSplitter);
107
115 virtual void DrawCaption(CDC* pDC, CXTPDockingPaneTabbedContainer* pPane, CRect rc);
116
124 virtual void DrawFloatingFrame(CDC* pDC, CXTPDockingPaneMiniWnd* pPane, CRect rc);
125
133 virtual void DrawPane(CDC* pDC, CXTPDockingPaneTabbedContainer* pPane, CRect rc);
134
142 virtual void DrawSidePanel(CDC* pDC, CXTPDockingPaneSidePanel* pPane, CRect rc);
143
151 virtual void DrawCaptionButton(CDC* pDC, CXTPDockingPaneCaptionButton* pButton,
152 COLORREF clrButton);
153
163 virtual void DrawAutoHidePanel(CDC* pDC, CRect rc, XTPDockingPaneDirection direction);
164
165protected:
175 virtual void DrawTitleBar(CDC* pDC, CXTPDockingPaneBase* pPane, CRect rc, BOOL bVertical);
176
186 void DrawGripper(CDC* pDC, CRect rcGripper, COLORREF clr, BOOL bVertical);
187
198 void DrawDottedLine(CDC* pDC, int x, int y, int nSize, COLORREF clr, BOOL bVertical);
199
210 virtual CXTPDockingPaneColorSet* GetColorSet(BOOL bActive);
211
221 void SetPaneColorSets(CXTPDockingPaneColorSet* pcsActive, CXTPDockingPaneColorSet* pcsInactive);
222
228 void DeletePaneColorSets();
229
230 CXTPDockingPaneColorSet* m_pcsActive;
231 CXTPDockingPaneColorSet* m_pcsInactive;
232 CString m_strFontFace;
233 int m_nFontSize;
234};
235
236AFX_INLINE CXTPDockingPaneColorSet* CXTPDockingPaneVisualStudio2012Theme::GetColorSet(BOOL bActive)
237{
238 return bActive ? m_pcsActive : m_pcsInactive;
239}
240
241# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
243#endif // !defined(__XTPDOCKINGPANETHEMEVISUALSTUDIO2012_H__)
XTPDisableNoisyWarnings.h
XTPDockingPaneDirection
XTPDockingPaneDirection
Docking direction enumeration.
Definition XTPDockingPaneDefines.h:51
XTPEnableNoisyWarnings.h
CXTPDockingPaneBase
CXTPDockingPaneBase is a standalone class.
Definition XTPDockingPaneBase.h:69
CXTPDockingPaneCaptionButton
CXTPDockingPaneCaptionButton is a standalone internal class.
Definition XTPDockingPaneCaptionButton.h:38
CXTPDockingPaneColorSet
Helper class used to initialize default colors for a theme from an .INI resource.
Definition XTPDockingPaneColorSet.h:39
CXTPDockingPaneDefaultTheme
CXTPDockingPaneDefaultTheme is a CXTPDockingPanePaintManager derived class that represents a classic ...
Definition XTPDockingPaneThemeDefault.h:41
CXTPDockingPaneMiniWnd
CXTPDockingPaneMiniWnd is a multiple inheritance class derived from CMiniFrameWnd and CXTPDockingPane...
Definition XTPDockingPaneMiniWnd.h:42
CXTPDockingPanePaintManager::AdjustClientRect
virtual void AdjustClientRect(CXTPDockingPaneSidePanel *pPane, CRect &rect)
Override this member to change the client rectangle of the child docking pane.
CXTPDockingPanePaintManager::AdjustCaptionRect
virtual void AdjustCaptionRect(const CXTPDockingPaneSidePanel *pPane, CRect &rc)
Override this member to change the caption rectangle of the child docking pane.
CXTPDockingPaneSidePanel
CXTPDockingPaneSidePanel is a multiple inheritance class derived from CWnd and CXTPDockingPaneBase.
Definition XTPDockingPaneSidePanel.h:45
CXTPDockingPaneSplitterWnd
CXTPDockingPaneSplitterWnd is a CWnd derived class.
Definition XTPDockingPaneSplitterContainer.h:42
CXTPDockingPaneTabbedContainer
CXTPDockingPaneTabbedContainer is a multiple inheritance class derived from CWnd and CXTPDockingPaneB...
Definition XTPDockingPaneTabbedContainer.h:47
CXTPDockingPaneVisualStudio2012Theme
CXTPDockingPaneVisualStudio2012Theme is used to define drawing routines specific to a Visual Studio 2...
Definition XTPDockingPaneThemeVisualStudio2012.h:41
CXTPDockingPaneVisualStudio2012Theme::GetColorSet
virtual CXTPDockingPaneColorSet * GetColorSet(BOOL bActive)
Call this member function to retrieve the active or inactive color set for the Docking Pane using the...
Definition XTPDockingPaneThemeVisualStudio2012.h:236
CXTPDockingPaneVisualStudio2012Theme::CXTPDockingPaneVisualStudio2012Theme
CXTPDockingPaneVisualStudio2012Theme()
Constructs a CXTPDockingPaneVisualStudio2012Theme object.
CXTPDockingPaneVisualStudio2012Theme::DrawCaptionButton
virtual void DrawCaptionButton(CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton)
Override this member function to draw a button for a tabbed caption.
CXTPDockingPaneVisualStudio2012Theme::DrawPane
virtual void DrawPane(CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc)
Override this member function to draw a tabbed container.
CXTPDockingPaneVisualStudio2012Theme::DrawFloatingFrame
virtual void DrawFloatingFrame(CDC *pDC, CXTPDockingPaneMiniWnd *pPane, CRect rc)
Call this method to draw the frame of a floating window.
CXTPDockingPaneVisualStudio2012Theme::GetPaneCaptionRect
virtual CRect GetPaneCaptionRect(const CXTPDockingPaneSidePanel *pPane)
Call this method to get the pane's caption rectangle.
CXTPDockingPaneVisualStudio2012Theme::DrawTitleBar
virtual void DrawTitleBar(CDC *pDC, CXTPDockingPaneBase *pPane, CRect rc, BOOL bVertical)
This member function is called to draw a title bar for the docking pane.
CXTPDockingPaneVisualStudio2012Theme::AdjustClientRect
virtual void AdjustClientRect(CXTPDockingPaneTabbedContainer *pPane, CRect &rc, BOOL bApply)
Override this member to change the client rectangle of the child docking pane.
CXTPDockingPaneVisualStudio2012Theme::DrawSplitter
virtual void DrawSplitter(CDC *pDC, CXTPDockingPaneSplitterWnd *pSplitter)
Override this method to draw a splitter.
CXTPDockingPaneVisualStudio2012Theme::m_nFontSize
int m_nFontSize
Font size in points.
Definition XTPDockingPaneThemeVisualStudio2012.h:233
CXTPDockingPaneVisualStudio2012Theme::DrawCaption
virtual void DrawCaption(CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc)
Override this member function to draw a caption.
CXTPDockingPaneVisualStudio2012Theme::DrawDottedLine
void DrawDottedLine(CDC *pDC, int x, int y, int nSize, COLORREF clr, BOOL bVertical)
This member function is called to draw a dotted line.
CXTPDockingPaneVisualStudio2012Theme::AdjustCaptionRect
virtual void AdjustCaptionRect(const CXTPDockingPaneTabbedContainer *pPane, CRect &rc)
Override this member to change the caption rectangle of the child docking pane.
CXTPDockingPaneVisualStudio2012Theme::DrawGripper
void DrawGripper(CDC *pDC, CRect rcGripper, COLORREF clr, BOOL bVertical)
This member function is called to draw a gripper for the docking pane.
CXTPDockingPaneVisualStudio2012Theme::DrawAutoHidePanel
virtual void DrawAutoHidePanel(CDC *pDC, CRect rc, XTPDockingPaneDirection direction)
This method is called by the framework to draw the docking pane auto-hide panel background and splitt...
CXTPDockingPaneVisualStudio2012Theme::m_pcsInactive
CXTPDockingPaneColorSet * m_pcsInactive
Inactive state docking pane colors.
Definition XTPDockingPaneThemeVisualStudio2012.h:231
CXTPDockingPaneVisualStudio2012Theme::DrawSidePanel
virtual void DrawSidePanel(CDC *pDC, CXTPDockingPaneSidePanel *pPane, CRect rc)
Override this member function to draw the side panel.
CXTPDockingPaneVisualStudio2012Theme::m_pcsActive
CXTPDockingPaneColorSet * m_pcsActive
Active state docking pane colors.
Definition XTPDockingPaneThemeVisualStudio2012.h:230
CXTPDockingPaneVisualStudio2012Theme::DeletePaneColorSets
void DeletePaneColorSets()
Called to free the memory allocated for the docking pane active and inactive color sets.
CXTPDockingPaneVisualStudio2012Theme::m_strFontFace
CString m_strFontFace
Font face name.
Definition XTPDockingPaneThemeVisualStudio2012.h:232
CXTPDockingPaneVisualStudio2012Theme::RefreshMetrics
virtual void RefreshMetrics()
This member function is used to initialize default colors for a theme from an .INI resource.
CXTPDockingPaneVisualStudio2012Theme::~CXTPDockingPaneVisualStudio2012Theme
virtual ~CXTPDockingPaneVisualStudio2012Theme()
Destroys a CXTPDockingPaneVisualStudio2012Theme object, handles cleanup and deallocation.
CXTPDockingPaneVisualStudio2012Theme::SetPaneColorSets
void SetPaneColorSets(CXTPDockingPaneColorSet *pcsActive, CXTPDockingPaneColorSet *pcsInactive)
Called to initialize the active and inactive colors sets for the docking pane theme.
CXTPResourceImages
Implements resource image collection and its operations.
Definition XTPResourceImage.h:257


Toolkit Pro: XTPGifPreviewProvider.h Source File

  • Source
  • Controls
  • Preview
  • Providers
  • GIF
XTPGifPreviewProvider.h
Go to the documentation of this file.
1
23#if !defined(__XTPGIFPREVIEWPROVIDER_H__)
24# define __XTPGIFPREVIEWPROVIDER_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
40class _XTP_EXT_CLASS CXTPGifPreviewProvider : public CXTPPreviewProviderBase
41{
42private:
43 virtual LPCTSTR GetDefaultFileAssociations() const;
44 virtual IXTPPreview* CreatePreview(LPCTSTR pFilePath, HWND hwndParent);
45 virtual IXTPPreview* CreatePreview(IStream& stream, LPCTSTR pImpliedFileName, HWND hwndParent);
46};
47
48# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
50#endif // #if !defined(__XTPGIFPREVIEWPROVIDER_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPGifPreviewProvider
Provides a preview handler for static and animated GIF files.
Definition XTPGifPreviewProvider.h:41
CXTPPreviewProviderBase
Base class for a preview provider which implements common behavior to be exposed by a preview provide...
Definition XTPPreviewAbstract.h:251
IXTPPreview
The base interface for a preview handler implementation.
Definition XTPPreviewAbstract.h:40
IXTPPreviewProvider::GetDefaultFileAssociations
virtual LPCTSTR GetDefaultFileAssociations() const =0
Obtains the list of file extensions supported by the associated preview implementation.
IXTPPreviewProvider::CreatePreview
virtual IXTPPreview * CreatePreview(LPCTSTR pFilePath, HWND hwndParent)=0
Creates a preview object for the specified file.


Toolkit Pro: Member List

CXTPChartFunnelDiagram Member List

This is the complete list of members for CXTPChartFunnelDiagram, including all inherited members.

CalculateSeriesLayout(CXTPChartDeviceContext *pDC, CXTPChartDiagramView *pView) | CXTPChartFunnelDiagramBase< BaseDiagram > | virtual
CreateView(CXTPChartDeviceContext *pDC, CXTPChartElementView *pParent) | CXTPChartFunnelDiagram | virtual
CXTPChartFunnelDiagram() | CXTPChartFunnelDiagram |
CXTPChartFunnelDiagramBase() | CXTPChartFunnelDiagramBase< BaseDiagram > |


Toolkit Pro: XTPTaskbarManager.h Source File

  • Source
  • Controls
  • Shell
XTPTaskbarManager.h
Go to the documentation of this file.
1
23#if !defined(__XTPTASKBARMANAGER_H__)
24# define __XTPTASKBARMANAGER_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33interface ITaskbarList3;
34interface ICustomDestinationList;
35interface IObjectArray;
36interface IShellItem;
37interface IShellLinkW;
38
39enum XTPTaskbarProgressFlag
40{
41 xtpProgressFlagNoProgress = 0,
42 xtpProgressFlagIndeterminate = 0x1,
43 xtpProgressFlagNormal = 0x2,
44 xtpProgressFlagError = 0x4,
45 xtpProgressFlagPaused = 0x8
46};
47
48class _XTP_EXT_CLASS CXTPTaskbarManagerJumpList : public CXTPCmdTarget
49{
50protected:
51 struct CTask
52 {
53 CString m_strPath;
54 CString m_strArguments;
55 CString m_strTitle;
56 CString m_strIconPath;
57 CString m_strWorkingDir;
58 int m_nIconIndex;
59 };
60
61protected:
62 CXTPTaskbarManagerJumpList();
63 ~CXTPTaskbarManagerJumpList();
64
65public:
66 void AddTask(LPCTSTR lpszPath, LPCTSTR lpszArgument, LPCTSTR lpszTitle, LPCTSTR lpszIconPath,
67 int nIconIndex = -1);
68 void AddTask(LPCTSTR lpszPath, LPCTSTR lpszArgument, LPCTSTR lpszTitle, LPCTSTR lpszIconPath,
69 LPCTSTR lpszWorkingDir, int nIconIndex = -1);
70 void Clear();
71 void CommitList();
72 void SetAppID(LPCWSTR lpszAppID);
73 void AppendKnownCategory(UINT uiCategory);
74
75private:
76 void DeleteList();
77 void BuildList();
78
79private:
80 HRESULT AddUserTasks();
81 HRESULT AddCustomCategory();
82
83 void AddTaskImpl(LPCTSTR lpszPath, LPCTSTR lpszArgument, LPCTSTR lpszTitle,
84 LPCTSTR lpszIconPath, LPCTSTR lpszWorkingDir, int nIconIndex);
85 HRESULT CreateShellLink(LPCWSTR lpszApp, LPCWSTR lpszCommandLine, LPCWSTR lpszTitle,
86 LPCWSTR lpszIconPath, LPCWSTR lpszWorkingDir, int nIconIndex,
87 IShellLinkW** ppSL);
88 BOOL IsItemInArray(IShellItem* pSI, IObjectArray* pArray);
89
90private:
91 ICustomDestinationList* m_pcdl;
92 IObjectArray* m_poaRemoved;
93 CString m_sAppID;
94 UINT m_uiCategory;
95
96 friend class CXTPTaskbarManager;
97
98 CArray<CTask, CTask&> m_arrTask;
99
100# ifdef _XTP_ACTIVEX
102public:
103 DECLARE_DISPATCH_MAP()
104 DECLARE_INTERFACE_MAP()
105 DECLARE_OLETYPELIB_EX(CXTPTaskbarManagerJumpList);
106
107 void OleAddTask(LPCTSTR lpszPath, LPCTSTR lpszArgument, LPCTSTR lpszTitle, LPCTSTR lpszIconPath,
108 int nIconIndex = -1);
109 void OleAddTaskEx(LPCTSTR lpszPath, LPCTSTR lpszArgument, LPCTSTR lpszTitle,
110 LPCTSTR lpszIconPath, LPCTSTR lpszWorkingDir, int nIconIndex = -1);
111
113# endif
114};
116AFX_INLINE void CXTPTaskbarManagerJumpList::SetAppID(LPCWSTR lpszAppID)
117{
118 m_sAppID = lpszAppID;
119}
120AFX_INLINE void CXTPTaskbarManagerJumpList::AppendKnownCategory(UINT uiCategory)
121{
122 m_uiCategory = uiCategory;
123}
125class _XTP_EXT_CLASS CXTPTaskbarManager
126{
127 // Constructor
128public:
129 CXTPTaskbarManager();
130 virtual ~CXTPTaskbarManager();
131
132public:
133 void SetProgressBarRange(HWND hWndParent, int nRangeMin, int nRangeMax);
134 void SetProgressBarPosition(HWND hWndParent, int nProgressPos);
135 void SetProgressBarState(HWND hWndParent, int nFlags);
136
137 BOOL SetOverlayIcon(HWND hWndParent, HICON hIcon, LPCTSTR lpszDescription);
138 BOOL SetOverlayIcon(HWND hWndParent, UINT nIDResource, LPCTSTR lpszDescription);
139
140public:
141 CXTPTaskbarManagerJumpList* GetJumpList() const;
142
143 // Implementation
144protected:
145 int m_nProgressBarRangeMax;
146 int m_nProgressBarRangeMin;
147
148 ITaskbarList3* m_pTaskbarList3;
149
150 CXTPTaskbarManagerJumpList* m_pJumpList;
151};
153AFX_INLINE CXTPTaskbarManagerJumpList* CXTPTaskbarManager::GetJumpList() const
154{
155 return m_pJumpList;
156}
158# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
160#endif // #if !defined(__XTPTASKBARMANAGER_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122


Toolkit Pro: XTPTabColorSetVisualStudio2019.h Source File

  • Source
  • TabManager
  • ColorSets
XTPTabColorSetVisualStudio2019.h
Go to the documentation of this file.
1
23#if !defined(__XTPTABCOLORSETVISUALSTUDIO2019_H__)
24# define __XTPTABCOLORSETVISUALSTUDIO2019_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
37class _XTP_EXT_CLASS CXTPTabColorSetVisualStudio2019 : public CXTPTabColorSetVisualStudio2017
38{
39public:
40 CXTPTabColorSetVisualStudio2019();
41
49 virtual void RefreshMetrics();
50};
51
52# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
54#endif // !defined(__XTPTABCOLORSETVISUALSTUDIO2019_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPTabColorSetVisualStudio2017
CXTPTabColorSetVisualStudio2017 implements a Visual Studio 2017 tab color set.
Definition XTPTabColorSetVisualStudio2017.h:38
CXTPTabColorSetVisualStudio2019
CXTPTabColorSetVisualStudio2019 implements a Visual Studio 2019 tab color set.
Definition XTPTabColorSetVisualStudio2019.h:38
CXTPTabColorSetVisualStudio2019::RefreshMetrics
virtual void RefreshMetrics()
Refreshes the visual metrics of the tabs.


Toolkit Pro: Member List

CXTPDockingPaneOffice2002VisioTheme Member List

This is the complete list of members for CXTPDockingPaneOffice2002VisioTheme, including all inherited members.

AdjustCaptionRect(const CXTPDockingPaneTabbedContainer *pPane, CRect &rc) | CXTPDockingPaneOffice2002VisioTheme | virtual
CXTPDockingPaneVisualStudio2003Theme::AdjustCaptionRect(const CXTPDockingPaneSidePanel *pPane, CRect &rc) | CXTPDockingPanePaintManager | virtual
AdjustClientRect(CXTPDockingPaneSidePanel *pPane, CRect &rect) | CXTPDockingPanePaintManager | virtual
AdjustClientRect(CXTPDockingPaneTabbedContainer *pPane, CRect &rect, BOOL bApply) | CXTPDockingPanePaintManager | virtual
ClipAndAddEllipsisIfNeeded(CDC *pDC, CString &strTitle, int nCaptionWidth) const | CXTPDockingPanePaintManager | protected
CXTPCmdTarget() | CXTPCmdTarget |
CXTPDockingPaneDefaultTheme() | CXTPDockingPaneDefaultTheme |
CXTPDockingPaneGripperedTheme() | CXTPDockingPaneGripperedTheme |
CXTPDockingPaneOffice2002VisioTheme() | CXTPDockingPaneOffice2002VisioTheme |
CXTPDockingPanePaintManager() | CXTPDockingPanePaintManager | protected
CXTPDockingPaneVisualStudio2003Theme() | CXTPDockingPaneVisualStudio2003Theme |
DrawAutoHidePanel(CDC *pDC, CRect rc, XTPDockingPaneDirection direction) | CXTPDockingPanePaintManager | virtual
DrawCaption(CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc) | CXTPDockingPaneOffice2002VisioTheme | virtual
DrawCaptionButton(CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton) | CXTPDockingPanePaintManager | virtual
DrawCaptionButtonEntry(CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton, CSize szOffset) | CXTPDockingPanePaintManager | protectedvirtual
DrawCaptionButtonEntry(CDC *pDC, CXTPDockingPaneCaptionButton *pButton, CPoint pt, COLORREF clrButton) | CXTPDockingPanePaintManager | protectedvirtual
DrawCaptionButtons(CDC *pDC, CXTPDockingPaneCaptionButtons *pButtons, CRect &rcCaption, COLORREF clr, int nButtonSize, int nButtonGap, BOOL bVertical=FALSE) | CXTPDockingPanePaintManager | virtual
DrawCaptionPart(CDC *pDC, CXTPDockingPaneBase *pPane, CRect rcCaption, const CString &strTitle, BOOL bActive, BOOL bVertical) | CXTPDockingPaneVisualStudio2003Theme | protectedvirtual
DrawCaptionText(CDC *pDC, const CString &strTitle, CRect rc, BOOL bVertical, BOOL bCalcWidth=FALSE) | CXTPDockingPanePaintManager |
DrawFloatingFrame(CDC *pDC, CXTPDockingPaneMiniWnd *pPane, CRect rc) | CXTPDockingPaneOffice2002VisioTheme | virtual
DrawPane(CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc) | CXTPDockingPaneOffice2002VisioTheme | virtual
DrawSidePanel(CDC *pDC, CXTPDockingPaneSidePanel *pPane, CRect rc) | CXTPDockingPaneDefaultTheme | virtual
DrawSplitter(CDC *pDC, CXTPDockingPaneSplitterWnd *pSplitter) | CXTPDockingPanePaintManager | virtual
FillCaptionPart(CDC *pDC, CXTPDockingPaneBase *pPane, CRect rcCaption, BOOL bActive, BOOL bVertical) | CXTPDockingPaneVisualStudio2003Theme | protectedvirtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCaptionButtonStyle() const | CXTPDockingPanePaintManager |
GetCaptionGripperRect(const CXTPDockingPaneTabbedContainer *pPane) | CXTPDockingPanePaintManager | virtual
GetCaptionHeight() const | CXTPDockingPanePaintManager |
GetCaptionRect(const CXTPDockingPaneTabbedContainer *pPane, CRect &rc) | CXTPDockingPanePaintManager | virtual
GetCurrentSystemTheme() const | CXTPDockingPanePaintManager |
GetCustomTitleBrush(BOOL bActive, BOOL bVertical) const | CXTPDockingPanePaintManager |
GetPaneCaptionRect(const CXTPDockingPaneSidePanel *pPane) | CXTPDockingPanePaintManager | virtual
GetPanelPaintManager() const | CXTPDockingPanePaintManager |
GetSplitterStyle() const | CXTPDockingPanePaintManager |
GetTabPaintManager() const | CXTPDockingPanePaintManager |
GetTabsHeight() const | CXTPDockingPanePaintManager |
GetXtremeColor(UINT nIndex) | CXTPDockingPanePaintManager |
Line(CDC *pDC, int x0, int y0, int x1, int y1, int nPen) | CXTPDockingPanePaintManager |
Line(CDC *pDC, int x0, int y0, int x1, int y1) | CXTPDockingPanePaintManager |
m_arrColor | CXTPDockingPanePaintManager | protected
m_bDestroyCustomTitleBrushes | CXTPDockingPanePaintManager | protected
m_bDrawCaptionIcon | CXTPDockingPanePaintManager |
m_bDrawSingleTab | CXTPDockingPanePaintManager |
m_bGradientCaption | CXTPDockingPaneVisualStudio2003Theme | protected
m_bHighlightActiveCaption | CXTPDockingPanePaintManager |
m_bLunaTheme | CXTPDockingPanePaintManager | protected
m_bShowCaption | CXTPDockingPanePaintManager |
m_bUseBoldCaptionFont | CXTPDockingPanePaintManager |
m_bUseOfficeFont | CXTPDockingPanePaintManager | protected
m_bUseStandardFont | CXTPDockingPanePaintManager | protected
m_clrActiveCaption | CXTPDockingPanePaintManager |
m_clrActiveCaptionText | CXTPDockingPanePaintManager |
m_clrBackground | CXTPDockingPanePaintManager |
m_clrDisabledCaptionText | CXTPDockingPanePaintManager |
m_clrNormalCaption | CXTPDockingPanePaintManager |
m_clrNormalCaptionText | CXTPDockingPanePaintManager |
m_clrSplitter | CXTPDockingPanePaintManager |
m_clrSplitterGradient | CXTPDockingPanePaintManager |
m_clrSplitterGripper | CXTPDockingPanePaintManager |
m_dwSplitterStyle | CXTPDockingPanePaintManager | protected
m_hbrActiveTitleHorz | CXTPDockingPanePaintManager | protected
m_hbrActiveTitleVert | CXTPDockingPanePaintManager | protected
m_hbrInactiveTitleHorz | CXTPDockingPanePaintManager | protected
m_hbrInactiveTitleVert | CXTPDockingPanePaintManager | protected
m_nCaptionButtonStyle | CXTPDockingPanePaintManager | protected
m_nCaptionFontGap | CXTPDockingPanePaintManager | protected
m_nSplitterIndent | CXTPDockingPanePaintManager |
m_nSplitterSize | CXTPDockingPanePaintManager |
m_nTabsHeight | CXTPDockingPanePaintManager | protected
m_nTitleHeight | CXTPDockingPanePaintManager | protected
m_pPanelPaintManager | CXTPDockingPanePaintManager | protected
m_pTabPaintManager | CXTPDockingPanePaintManager | protected
m_rcCaptionMargin | CXTPDockingPanePaintManager | protected
m_strOfficeFont | CXTPDockingPanePaintManager | protected
m_systemTheme | CXTPDockingPanePaintManager | protected
m_themeButton | CXTPDockingPanePaintManager | protected
m_themeCurrent | CXTPDockingPanePaintManager | protected
m_themeExplorer | CXTPDockingPanePaintManager | protected
m_themeRebar | CXTPDockingPanePaintManager | protected
m_themeToolbar | CXTPDockingPanePaintManager | protected
m_themeWindow | CXTPDockingPanePaintManager | protected
m_xtpFontTitle | CXTPDockingPanePaintManager | protected
m_xtpFontTitleVertical | CXTPDockingPanePaintManager | protected
Pixel(CDC *pDC, int xPos, int yPos, int nPen) | CXTPDockingPanePaintManager |
Rectangle(CDC *pDC, CRect rc, int nPenEntry, int nPenBorder) | CXTPDockingPanePaintManager |
RefreshMetrics() | CXTPDockingPaneOffice2002VisioTheme | virtual
SetCaptionButtonStyle(XTPDockingPaneCaptionButtonStyle nStyle) | CXTPDockingPanePaintManager |
SetCaptionFontIndirect(LOGFONT *pLogFont, BOOL bUseStandardFont=FALSE) | CXTPDockingPanePaintManager |
SetColors(int cElements, CONST INT *lpaElements, CONST COLORREF *lpaRgbValues) | CXTPDockingPanePaintManager |
SetCustomTitleBrushes(HBRUSH hbrActiveTitleHorz, HBRUSH hbrInactiveTitleHorz=NULL, HBRUSH hbrActiveTitleVert=NULL, HBRUSH hbrInactiveTitleVert=NULL, BOOL bDestroyOnCleanup=FALSE) | CXTPDockingPanePaintManager |
SetLunaTheme(XTPCurrentSystemTheme systemTheme) | CXTPDockingPanePaintManager |
SetPanelPaintManager(CXTPTabPaintManager *pManager) | CXTPDockingPanePaintManager |
SetSplitterStyle(DWORD dwStyle) | CXTPDockingPanePaintManager |
SetTabPaintManager(CXTPTabPaintManager *pManager) | CXTPDockingPanePaintManager |
UseOfficeFont(BOOL bUseOfficeFont) | CXTPDockingPanePaintManager |
~CXTPDockingPanePaintManager() | CXTPDockingPanePaintManager | protectedvirtual


Toolkit Pro: XTPChart3dPieDeviceCommandEvents.h Source File

  • Source
  • Chart
  • Styles
  • Pie
  • 3D
  • Commands
XTPChart3dPieDeviceCommandEvents.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHART3DPIEDEVICECOMMANDEVENTS_H__)
24# define __XTPCHART3DPIEDEVICECOMMANDEVENTS_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
37class _XTP_EXT_CLASS CXTPChart3dPieDeviceCommandEvents
38 : public CXTPChartDeviceCommandEvents
39 , public CXTPTypeIdProvider<CXTPChart3dPieDeviceCommandEvents, CXTPChartDeviceCommandEvents>
40{
41protected:
46 CXTPChart3dPieDeviceCommandEvents();
47
48public:
57 virtual void OnSetConnectorPoints(CXTPChartDeviceCommand* pCommand, CXTPPoint3d ptShapeCenter,
58 CXTPPoint3d ptOuterCenter);
59};
61# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
62#endif //#if !defined(__XTPCHART3DPIEDEVICECOMMANDEVENTS_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChart3dPieDeviceCommandEvents
Defines interface for 3D chart pie device command event sink.
Definition XTPChart3dPieDeviceCommandEvents.h:40
CXTPChart3dPieDeviceCommandEvents::OnSetConnectorPoints
virtual void OnSetConnectorPoints(CXTPChartDeviceCommand *pCommand, CXTPPoint3d ptShapeCenter, CXTPPoint3d ptOuterCenter)
Gets called when pie connector points are computed.
CXTPChart3dPieDeviceCommandEvents::CXTPChart3dPieDeviceCommandEvents
CXTPChart3dPieDeviceCommandEvents()
Constructs a CXTPChart3dPieDeviceCommandEvents object.
CXTPChartDeviceCommandEvents
Defines a callback interface for a chart device command event sink.
Definition XTPChartDeviceCommand.h:48
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPPoint3T< double >


Toolkit Pro: Member List

CXTPResizeItem Member List

This is the complete list of members for CXTPResizeItem, including all inherited members.

CXTPResizeItem(CWnd *pWnd, const CXTPResizeRect &rrcSizing, CRect &rcWindow, BOOL bAutoDelete) | CXTPResizeItem |
m_bAutoDelete | CXTPResizeItem |
m_bInitialSize | CXTPResizeItem |
m_bIsGroupBox | CXTPResizeItem |
m_pWnd | CXTPResizeItem |
m_rrcInitWindow | CXTPResizeItem |
m_rrcSizing | CXTPResizeItem |
m_rrcWindow | CXTPResizeItem |
MakeTransparent(CXTPResize *pXTPResize) | CXTPResizeItem | virtual
~CXTPResizeItem() | CXTPResizeItem | virtual


Toolkit Pro: Member List

  • CXTPDatePickerDaysCollection
  • SELECTED_BLOCK
CXTPDatePickerDaysCollection::SELECTED_BLOCK Member List

This is the complete list of members for CXTPDatePickerDaysCollection::SELECTED_BLOCK, including all inherited members.

nDateBegin | CXTPDatePickerDaysCollection::SELECTED_BLOCK
nDateEnd | CXTPDatePickerDaysCollection::SELECTED_BLOCK


Toolkit Pro: XTPTearOffFrame.h Source File

  • Source
  • CommandBars
  • TabClient
XTPTearOffFrame.h
Go to the documentation of this file.
1
23#if !defined(__XTPTEAROFFFRAMEWND_H__)
24# define __XTPTEAROFFFRAMEWND_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
34class CXTPMultiDocTemplate : public CMultiDocTemplate
35{
36 friend class CXTPTearOffFrame;
37 friend class CXTPTabClientWnd;
38# ifndef _XTP_COMMANDBARS_ACTIVEX
39# ifdef _XTP_INCLUDE_DOCKINGPANE
40 friend class CXTPDockingPaneManager;
41# endif
42# endif
43
44 CXTPMultiDocTemplate();
45};
46
47// //{{AFX_MSG_MAP(CChildFrame)
48// //}}AFX_MSG_MAP
75const UINT WM_XTP_TEAROFF_ACTIVATE = (WM_XTP_COMMANDBARS_BASE + 33);
76
83class CXTPTearOffFrame
84 : public CXTPMDIFrameWnd
85 , CXTPCommandBarsFrameHook
86{
87 DECLARE_DYNCREATE(CXTPTearOffFrame);
88
89public:
94 CXTPTearOffFrame();
95
100 virtual ~CXTPTearOffFrame();
101
107 virtual BOOL DestroyWindow();
108
115 void Init(CXTPTabClientWnd* pTabClient, CXTPTabManagerItem* pTabItem);
116
122 void Update(CXTPTabClientWnd* pTabClient);
123
130 CXTPTabClientWnd* GetTabClient() const;
131
138 BOOL IsFrameBeingDragged() const;
139
140 virtual HMENU GetWindowMenuPopup(HMENU hMenuBar);
141
142private:
143 afx_msg int OnCreate(LPCREATESTRUCT lpCreateStruct);
144 afx_msg void OnEnterSizeMove();
145 afx_msg void OnMove(int x, int y);
146 afx_msg void OnExitSizeMove();
147 afx_msg LRESULT OnEnterSizeMove(WPARAM wParam, LPARAM lParam);
148 afx_msg LRESULT OnExitSizeMove(WPARAM wParam, LPARAM lParam);
149 afx_msg void OnClose();
150 afx_msg LRESULT OnTabbarMouseMsg(WPARAM wParam, LPARAM lParam);
151 afx_msg void OnActivate(UINT nState, CWnd* pWndOther, BOOL bMinimized);
152 afx_msg LRESULT OnTabbarNewItem(WPARAM wParam, LPARAM lParam);
153 afx_msg LRESULT OnSetActiveWorkspace(WPARAM wParam, LPARAM lParam);
155 DECLARE_MESSAGE_MAP()
157private:
158 BOOL m_bIsFrameDragging;
159 HCURSOR m_hCursor;
160 HCURSOR m_hCursorNew;
161 CXTPTabClientWnd m_wndTabClient;
162 CRect m_rcPrev;
163 CXTPTabClientContext* m_pTabClientContext;
164
165 CRect m_rcDragRect;
166 CXTPTabClientWnd* pTargetTabPrev;
167 void UpdateDragRect();
168
169 void ChangeMDIChildFrame(CXTPTabClientWnd* pTarget, int nOldWorkspace, int nSticker);
170 CXTPTabClientWnd::CWorkspace*
171 ChangeItemWorkspace(CXTPTabClientWnd* pTarget, int nOldWorkspace, int nSticker,
172 CXTPTabClientWnd::CWorkspace* pExistingWorkspace = NULL);
173
174 friend class CXTPMDIFrameWndEx;
175};
176
178# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
179#endif // !defined(__XTPTEAROFFFRAMEWND_H__)
WM_XTP_COMMANDBARS_BASE
const UINT WM_XTP_COMMANDBARS_BASE
Base message for CommandBars.
Definition XTPCommandBarsDefines.h:442
XTPDisableNoisyWarnings.h
CXTPCommandBarsFrameHook
CXTPCommandBarsFrameHook is a CXTPHookManagerHookAble derived class.
Definition XTPFrameHook.h:56
CXTPDockingPaneManager
CXTPDockingPaneManager is a CWnd derived class.
Definition XTPDockingPaneManager.h:58
CXTPMDIFrameWndEx
CXTPMDIFrameWndEx is a CXTPMDIFrameWnd derived class.
Definition XTPFrameWnd.h:318
CXTPMDIFrameWnd
CXTPMDIFrameWnd is a CXTPFrameWndBase derived class.
Definition XTPFrameWnd.h:292
CXTPTabClientContext
CXTPTabClientContext is a standalone class.
Definition XTPTabClientContext.h:68
CXTPTabClientWnd
CXTPTabClientWnd is a CWnd derived class.
Definition XTPTabClientWnd.h:383
CXTPTabManagerItem
CXTPTabManagerItem is the base class for the tabs that appear in the command bars tab workspace,...
Definition XTPTabManagerItem.h:44
CXTPTearOffFrame
The class represents a floating torn off frame.
Definition XTPTearOffFrame.h:86
CXTPTearOffFrame::Update
void Update(CXTPTabClientWnd *pTabClient)
Updates an associated tab client object and and all related frame states.
CXTPTearOffFrame::CXTPTearOffFrame
CXTPTearOffFrame()
Construct frame object.
CXTPTearOffFrame::IsFrameBeingDragged
BOOL IsFrameBeingDragged() const
Determines if the frame is being dragged.
CXTPTearOffFrame::Init
void Init(CXTPTabClientWnd *pTabClient, CXTPTabManagerItem *pTabItem)
Initializes frame object.
CXTPTearOffFrame::DestroyWindow
virtual BOOL DestroyWindow()
Handles frame window destruction.
CXTPTearOffFrame::GetTabClient
CXTPTabClientWnd * GetTabClient() const
Obtains an associated tab client object pointer.
CXTPTearOffFrame::~CXTPTearOffFrame
virtual ~CXTPTearOffFrame()
Handles resources cleanup.


Toolkit Pro: Member List

CXTPTaskPanelGroups Member List

This is the complete list of members for CXTPTaskPanelGroups, including all inherited members.

Add(CXTPTaskPanelItem *pItem, UINT nID) | CXTPTaskPanelItems |
Add(CXTPTaskPanelItem *pItem, UINT nID, LPCTSTR lpCaption, LPCTSTR lpTooltip=NULL) | CXTPTaskPanelItems |
Clear(BOOL bReposition=TRUE) | CXTPTaskPanelItems |
CXTPCmdTarget() | CXTPCmdTarget |
CXTPTaskPanelGroups(CXTPTaskPanel *pPanel) | CXTPTaskPanelGroups |
CXTPTaskPanelItems(CXTPTaskPanel *pPanel=NULL) | CXTPTaskPanelItems |
DoPropExchange(CXTPPropExchange *pPX) | CXTPTaskPanelItems |
Find(UINT nID) const | CXTPTaskPanelItems |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAt(int nIndex) const | CXTPTaskPanelItems |
GetCount() const | CXTPTaskPanelItems |
GetDefaultItemClass() const | CXTPTaskPanelGroups | virtual
GetFirstVisibleItem() const | CXTPTaskPanelItems |
GetIndex(const CXTPTaskPanelItem *pItem) const | CXTPTaskPanelItems |
GetLastVisibleItem() const | CXTPTaskPanelItems |
GetNextVisibleIndex(int nIndex, int nDirection) const | CXTPTaskPanelItems |
GetOwner() const | CXTPTaskPanelItems |
InsertAt(int nIndex, CXTPTaskPanelItem *pItem) | CXTPTaskPanelItems |
m_arrItems | CXTPTaskPanelItems | protected
m_pOwner | CXTPTaskPanelItems | protected
m_pPanel | CXTPTaskPanelItems | protected
Move(CXTPTaskPanelItem *pItem, int nIndex) | CXTPTaskPanelItems |
Remove(CXTPTaskPanelItem *pItem) | CXTPTaskPanelItems |
RemoveAt(int nIndex) | CXTPTaskPanelItems |
~CXTPTaskPanelItems() | CXTPTaskPanelItems | virtual


Toolkit Pro: XTPMarkupGdiPlusMatrixTransform.h Source File

  • Source
  • Markup
  • Transform
XTPMarkupGdiPlusMatrixTransform.h
Go to the documentation of this file.
1
23#if !defined(__XTPMARKUPGDIPLUSMATRIXTRANSFORM_H__)
24# define __XTPMARKUPGDIPLUSMATRIXTRANSFORM_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPGdiPlus;
34
39class _XTP_EXT_CLASS CXTPMarkupGdiPlusMatrixTransform
40 : public CXTPMarkupGdiPlusTransformObject<CXTPMarkupMatrixTransform>
41{
43 DECLARE_MARKUPCLASS(CXTPMarkupGdiPlusMatrixTransform);
45public:
50 CXTPMarkupGdiPlusMatrixTransform();
51
60 virtual BOOL TransformMatrix(const CXTPGdiPlus* pReserved, GpMatrix* pMatrix);
61};
62
63# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
65#endif // !defined(__XTPMARKUPGDIPLUSMATRIXTRANSFORM_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPMarkupGdiPlusMatrixTransform
GDI+ MatrixTransform implementation.
Definition XTPMarkupGdiPlusMatrixTransform.h:41
CXTPMarkupGdiPlusMatrixTransform::CXTPMarkupGdiPlusMatrixTransform
CXTPMarkupGdiPlusMatrixTransform()
Constructs a CXTPMarkupGdiPlusMatrixTransform object.
CXTPMarkupGdiPlusMatrixTransform::TransformMatrix
virtual BOOL TransformMatrix(const CXTPGdiPlus *pReserved, GpMatrix *pMatrix)
Performs GDI+ matrix scaling.
CXTPMarkupGdiPlusTransformObject
Base class for all GDI+ markup transformation objects.
Definition XTPMarkupGdiPlusTransformObject.h:91


Toolkit Pro: Member List

CXTPRibbonGroup Member List

This is the complete list of members for CXTPRibbonGroup, including all inherited members.

Add(XTPControlType controlType, int nId, LPCTSTR lpszParameter=NULL, int nBefore=-1, BOOL bTemporary=FALSE) | CXTPRibbonGroup |
Add(CXTPControl *pControl, int nId, LPCTSTR lpszParameter=NULL, int nBefore=-1, BOOL bTemporary=FALSE) | CXTPRibbonGroup |
AddClone(CXTPControl *pControl, int nBefore, BOOL bRecursive=FALSE) | CXTPRibbonGroup |
AllowReduce(int nAllowReduceLevel=0) | CXTPRibbonGroup |
Copy(CXTPRibbonGroup *pGroup) | CXTPRibbonGroup | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPRibbonGroup() | CXTPRibbonGroup |
DoPropExchange(CXTPPropExchange *pPX) | CXTPRibbonGroup | virtual
Draw(CDC *pDC, CRect rcClipBox) | CXTPRibbonGroup | virtual
FindControl(int nId) const | CXTPRibbonGroup |
FindControl(XTPControlType type, int nId, BOOL bVisible, BOOL bRecursive) const | CXTPRibbonGroup |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAllowReduceLevel() const | CXTPRibbonGroup |
GetAt(int nIndex) const | CXTPRibbonGroup |
GetCaption() const | CXTPRibbonGroup |
GetCaptionRect() const | CXTPRibbonGroup |
GetControlGroupOption() const | CXTPRibbonGroup |
GetControlGroupPopup() const | CXTPRibbonGroup |
GetCount() const | CXTPRibbonGroup |
GetIconId() const | CXTPRibbonGroup |
GetID() const | CXTPRibbonGroup |
GetIndex() const | CXTPRibbonGroup |
GetMinimumWidth(CDC *pDC) | CXTPRibbonGroup | protectedvirtual
GetParent() const | CXTPRibbonGroup |
GetParentTab() const | CXTPRibbonGroup |
GetRect() const | CXTPRibbonGroup |
GetRibbonBar() const | CXTPRibbonGroup |
IndexOf(CXTPControl *pControl) const | CXTPRibbonGroup |
InsertAt(CXTPControl *pControl, int nBefore=-1) | CXTPRibbonGroup |
IsControlsCentering() const | CXTPRibbonGroup |
IsControlsGrouping() const | CXTPRibbonGroup |
IsHighlighted() const | CXTPRibbonGroup |
IsOptionButtonVisible() const | CXTPRibbonGroup |
IsReduced() const | CXTPRibbonGroup |
IsVisible() const | CXTPRibbonGroup |
LoadToolBar(UINT nIDResource, BOOL bLoadIcons=TRUE) | CXTPRibbonGroup |
m_arrControls | CXTPRibbonGroup | protected
m_bAutoArrangeEditCaption | CXTPRibbonGroup | protected
m_bControlsCentering | CXTPRibbonGroup | protected
m_bControlsGrouping | CXTPRibbonGroup | protected
m_bReduced | CXTPRibbonGroup | protected
m_bShowOptionButton | CXTPRibbonGroup | protected
m_bVisible | CXTPRibbonGroup | protected
m_nAllowReduce | CXTPRibbonGroup | protected
m_nIconId | CXTPRibbonGroup | protected
m_nId | CXTPRibbonGroup | protected
m_nIndex | CXTPRibbonGroup | protected
m_nRowCount | CXTPRibbonGroup | protected
m_pControlGroupOption | CXTPRibbonGroup | protected
m_pControlGroupPopup | CXTPRibbonGroup | protected
m_pGroups | CXTPRibbonGroup | protected
m_pParent | CXTPRibbonGroup | protected
m_pRibbonBar | CXTPRibbonGroup | protected
m_rcGroup | CXTPRibbonGroup | protected
m_strCaption | CXTPRibbonGroup | protected
OnAfterCalcSize() | CXTPRibbonGroup | protectedvirtual
OnBeforeCalcSize(CDC *pDC) | CXTPRibbonGroup | protectedvirtual
OnCalcDynamicSize(CDC *pDC) | CXTPRibbonGroup | protectedvirtual
OnExtendSize(int nWidthAvail) | CXTPRibbonGroup | protectedvirtual
OnGroupAdded() | CXTPRibbonGroup | protectedvirtual
OnGroupRemoved() | CXTPRibbonGroup | protectedvirtual
OnReduceSize(int nLevel, int nWidthAvail) | CXTPRibbonGroup | protectedvirtual
Remove(CXTPControl *pControl) | CXTPRibbonGroup |
RemoveAll() | CXTPRibbonGroup |
RemoveAt(int nIndex) | CXTPRibbonGroup |
RepositionControls(CDC *pDC) | CXTPRibbonGroup | protectedvirtual
SetArrangeEditCaption(BOOL bArrangeEditCaption) | CXTPRibbonGroup |
SetButtons(UINT *pButtons, int nCount) | CXTPRibbonGroup |
SetCaption(LPCTSTR lpszCaption) | CXTPRibbonGroup |
SetControlsCentering(BOOL bControlsCentering=TRUE) | CXTPRibbonGroup |
SetControlsGrouping(BOOL bControlsGrouping=TRUE) | CXTPRibbonGroup |
SetControlType(CXTPControl *pControl, XTPControlType type) | CXTPRibbonGroup |
SetIconId(int nId) | CXTPRibbonGroup |
SetID(int nId) | CXTPRibbonGroup |
SetRect(CRect rc) | CXTPRibbonGroup | virtual
SetVisible(BOOL bVisible) | CXTPRibbonGroup |
ShowOptionButton(BOOL bShowOptionButton=TRUE) | CXTPRibbonGroup |
~CXTPRibbonGroup() | CXTPRibbonGroup | virtual


Toolkit Pro: Member List

XTP_NM_GRIDSTATECHANGED Member List

This is the complete list of members for XTP_NM_GRIDSTATECHANGED, including all inherited members.

hdr | XTP_NM_GRIDSTATECHANGED
nBegin | XTP_NM_GRIDSTATECHANGED
nEnd | XTP_NM_GRIDSTATECHANGED


Toolkit Pro: Member List

CXTPChartAxisStrips Member List

This is the complete list of members for CXTPChartAxisStrips, including all inherited members.

Add(CXTPChartAxisStrip *pStrip) | CXTPChartAxisStrips |
CXTPChartAxisStrips(CXTPChartAxis *pAxis) | CXTPChartAxisStrips |
CXTPChartElement() | CXTPChartElement |
CXTPChartElementCollection() | CXTPChartElementCollection |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
DoPropExchange(CXTPPropExchange *pPX) | CXTPChartAxisStrips | virtual
GetAppearance() const | CXTPChartElement |
GetAt(int nIndex) const | CXTPChartAxisStrips |
GetContent() const | CXTPChartElement |
GetCount() const | CXTPChartElementCollection | virtual
GetOwner() const | CXTPChartElement |
IndexOf(CXTPChartElement *pElement) const | CXTPChartElementCollection |
InsertAt(int nIndex, CXTPChartElement *pElement) | CXTPChartElementCollection |
Is3D() const | CXTPChartObject |
m_arrElements | CXTPChartElementCollection | protected
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartElement | virtual
Release() | CXTPChartElementCollection | virtual
Remove(CXTPChartElement *pElement) | CXTPChartElementCollection | virtual
RemoveAll() | CXTPChartElementCollection | virtual
RemoveAt(int nIndex) | CXTPChartElementCollection | virtual
~CXTPChartAxisStrips() | CXTPChartAxisStrips | virtual
~CXTPChartElement() | CXTPChartElement | virtual
~CXTPChartElementCollection() | CXTPChartElementCollection |


Toolkit Pro: Member List

CXTPMarkupStackPanel Member List

This is the complete list of members for CXTPMarkupStackPanel, including all inherited members.

ApplyRenderTransform(CXTPMarkupDrawingContext *pContext) | CXTPMarkupUIElement | protectedvirtual
Arrange(CRect rcFinalRect) | CXTPMarkupUIElement |
ArrangeCore(CRect rcFinalRect) | CXTPMarkupUIElement | protectedvirtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPMarkupFrameworkElement() | CXTPMarkupFrameworkElement | protected
CXTPMarkupPanel() | CXTPMarkupPanel | protected
CXTPMarkupStackPanel() | CXTPMarkupStackPanel | protected
CXTPMarkupUIElement() | CXTPMarkupUIElement | protected
CXTPMarkupVisual() | CXTPMarkupVisual |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAbsoluteVisualOffset() const | CXTPMarkupVisual | protected
GetActualSize() const | CXTPMarkupFrameworkElement |
GetBackground() const | CXTPMarkupPanel |
GetBoundRect() const | CXTPMarkupVisual |
GetChildren() const | CXTPMarkupPanel |
GetClipToBounds() const | CXTPMarkupFrameworkElement |
GetDesiredSize() const | CXTPMarkupUIElement |
GetFinalRect() const | CXTPMarkupUIElement |
GetHeight() const | CXTPMarkupFrameworkElement |
GetHorizontalAlignment() const | CXTPMarkupFrameworkElement |
GetLayoutClip(CRect &rc) const | CXTPMarkupUIElement | protectedvirtual
GetLogicalChild(int nIndex) const | CXTPMarkupVisual | virtual
GetLogicalChildrenCount() const | CXTPMarkupVisual | virtual
GetMargin() const | CXTPMarkupFrameworkElement |
GetMaxHeight() const | CXTPMarkupFrameworkElement |
GetMaxWidth() const | CXTPMarkupFrameworkElement |
GetMinHeight() const | CXTPMarkupFrameworkElement |
GetMinWidth() const | CXTPMarkupFrameworkElement |
GetOpacity() const | CXTPMarkupUIElement | protectedvirtual
GetOrientation() const | CXTPMarkupStackPanel |
GetRenderSize() const | CXTPMarkupVisual |
GetRenderTransform() const | CXTPMarkupUIElement | protected
GetStyle() const | CXTPMarkupFrameworkElement |
GetTag() const | CXTPMarkupFrameworkElement |
GetUpdateRect() const | CXTPMarkupVisual |
GetVerticalAlignment() const | CXTPMarkupFrameworkElement |
GetVisibility() const | CXTPMarkupUIElement |
GetVisualChild(int nIndex) const | CXTPMarkupVisual | virtual
GetVisualChildrenCount() const | CXTPMarkupVisual | virtual
GetVisualOffset() const | CXTPMarkupVisual |
GetVisualParent() const | CXTPMarkupVisual |
GetWidth() const | CXTPMarkupFrameworkElement |
InputHitTest(CPoint point) const | CXTPMarkupVisual |
InputHitTestOverride(CPoint point) const | CXTPMarkupVisual | protectedvirtual
InvalidateArrange() | CXTPMarkupUIElement | virtual
InvalidateMeasure() | CXTPMarkupUIElement | virtual
InvalidateMeasureOverride(CXTPMarkupDrawingContext *pDC) | CXTPMarkupUIElement | protectedvirtual
InvalidateVisual() | CXTPMarkupUIElement | virtual
IsEnabled() const | CXTPMarkupUIElement |
IsFocusable() const | CXTPMarkupUIElement |
IsVisible() const | CXTPMarkupUIElement | virtual
m_bArrangeDirty | CXTPMarkupUIElement | protected
m_bArrangeInProgress | CXTPMarkupUIElement | protected
m_bMeasureDirty | CXTPMarkupUIElement | protected
m_bMeasureInProgress | CXTPMarkupUIElement | protected
m_bNeverArranged | CXTPMarkupUIElement | protected
m_bNeverMeasured | CXTPMarkupUIElement | protected
m_pClipToBoundsProperty | CXTPMarkupUIElement | static
m_pFocusableProperty | CXTPMarkupUIElement | static
m_pIsEnabledProperty | CXTPMarkupUIElement | static
m_pOpacityProperty | CXTPMarkupUIElement | static
m_pRenderTransformOriginProperty | CXTPMarkupUIElement | static
m_pRenderTransformProperty | CXTPMarkupUIElement | static
m_ptVisualOffset | CXTPMarkupVisual | protected
m_pVisibilityProperty | CXTPMarkupUIElement | static
m_rcBoundRect | CXTPMarkupVisual | protected
m_rcFinalRect | CXTPMarkupUIElement | protected
m_rcPrevUpdateRect | CXTPMarkupVisual | protected
m_rcUpdateRect | CXTPMarkupVisual | protected
m_szDesiredSize | CXTPMarkupUIElement | protected
m_szPreviousAvailableSize | CXTPMarkupUIElement | protected
m_szRenderSize | CXTPMarkupVisual | protected
Measure(CXTPMarkupDrawingContext *pDC, CSize szAvailableSize) | CXTPMarkupUIElement |
MeasureCore(CXTPMarkupDrawingContext *pDC, CSize szAvailableSize) | CXTPMarkupUIElement | protectedvirtual
OnRender(CXTPMarkupDrawingContext *drawingContext) | CXTPMarkupVisual | protectedvirtual
OnRenderFocusVisual(CXTPMarkupDrawingContext *drawingContext) | CXTPMarkupVisual | protectedvirtual
PtInRectTransform(const RECT &rect, const POINT &point) const | CXTPMarkupVisual | protected
Render(CXTPMarkupDrawingContext *drawingContext) | CXTPMarkupVisual |
RenderClipped(CXTPMarkupDrawingContext *drawingContext) | CXTPMarkupVisual | protectedvirtual
RestoreRenderTransform(CXTPMarkupDrawingContext *pContext, TransformationMatrices &matrices) | CXTPMarkupUIElement | protectedvirtual
SetBackground(CXTPMarkupBrush *pBrush) | CXTPMarkupPanel |
SetClipToBounds(BOOL bClipToBounds) | CXTPMarkupFrameworkElement |
SetHeight(int nHeight) | CXTPMarkupFrameworkElement |
SetHorizontalAlignment(XTPMarkupHorizontalAlignment alignment) | CXTPMarkupFrameworkElement |
SetMargin(int nLeft, int nTop, int nRight, int nBottom) | CXTPMarkupFrameworkElement |
SetMargin(int nMargin) | CXTPMarkupFrameworkElement |
SetMaxHeight(int nHeight) | CXTPMarkupFrameworkElement |
SetMaxWidth(int nWidth) | CXTPMarkupFrameworkElement |
SetMinHeight(int nHeight) | CXTPMarkupFrameworkElement |
SetMinWidth(int nWidth) | CXTPMarkupFrameworkElement |
SetOrientation(XTPMarkupOrientation orientation) | CXTPMarkupStackPanel |
SetTag(CXTPMarkupObject *pTag) | CXTPMarkupFrameworkElement |
SetVerticalAlignment(XTPMarkupVerticalAlignment alignment) | CXTPMarkupFrameworkElement |
SetVisibility(XTPMarkupVisibility visibility) | CXTPMarkupUIElement |
SetWidth(int nWidth) | CXTPMarkupFrameworkElement |
~CXTPMarkupFrameworkElement() | CXTPMarkupFrameworkElement | protectedvirtual
~CXTPMarkupPanel() | CXTPMarkupPanel | protectedvirtual
~CXTPMarkupStackPanel() | CXTPMarkupStackPanel | protectedvirtual
~CXTPMarkupUIElement() | CXTPMarkupUIElement | protectedvirtual
~CXTPMarkupVisual() | CXTPMarkupVisual | virtual


Toolkit Pro: Member List

CXTPCalendarEventPropertiesDlg Member List

This is the complete list of members for CXTPCalendarEventPropertiesDlg, including all inherited members.

CXTPCalendarEventPropertiesDlg(CXTPCalendarControl *pControl, BOOL bAddEvent, CWnd *pParent=NULL, CXTPCalendarEvent *pEditingEvent=NULL, UINT nIDTemplate=CXTPCalendarEventPropertiesDlg::IDD, COleDateTime dtInitial=COleDateTime::GetCurrentTime()) | CXTPCalendarEventPropertiesDlg |
InitReminderComboBox() | CXTPCalendarEventPropertiesDlg | protectedvirtual
m_bAddEvent | CXTPCalendarEventPropertiesDlg | protected
m_bAllDayEvent | CXTPCalendarEventPropertiesDlg | protected
m_bHScrollEnabled | CXTPCalendarEventPropertiesDlg | protected
m_bMeeting | CXTPCalendarEventPropertiesDlg | protected
m_bOccurrence | CXTPCalendarEventPropertiesDlg |
m_bPrivate | CXTPCalendarEventPropertiesDlg | protected
m_bRecurrenceUpdate | CXTPCalendarEventPropertiesDlg |
m_bReminder | CXTPCalendarEventPropertiesDlg | protected
m_bVScrollEnabled | CXTPCalendarEventPropertiesDlg | protected
m_ctrlScheduleIDCB | CXTPCalendarEventPropertiesDlg | protected
m_ctrlScheduleLabel | CXTPCalendarEventPropertiesDlg | protected
m_ctrlScheduleSet | CXTPCalendarEventPropertiesDlg | protected
m_dNewEventID | CXTPCalendarEventPropertiesDlg | protected
m_dtEndDate | CXTPCalendarEventPropertiesDlg | protected
m_dtEndTime | CXTPCalendarEventPropertiesDlg | protected
m_dtStartDate | CXTPCalendarEventPropertiesDlg | protected
m_dtStartTime | CXTPCalendarEventPropertiesDlg | protected
m_nAllDayEventSet | CXTPCalendarEventPropertiesDlg | protected
m_nBusyStatus | CXTPCalendarEventPropertiesDlg | protected
m_pOwnerWnd | CXTPCalendarEventPropertiesDlg | protected
m_ptrControl | CXTPCalendarEventPropertiesDlg | protected
m_ptrEditingEvent | CXTPCalendarEventPropertiesDlg | protected
m_strBody | CXTPCalendarEventPropertiesDlg | protected
m_strLocation | CXTPCalendarEventPropertiesDlg | protected
m_strSubject | CXTPCalendarEventPropertiesDlg | protected
m_wndBusyStatusCombo | CXTPCalendarEventPropertiesDlg | protected
m_wndCategoryCombo | CXTPCalendarEventPropertiesDlg | protected
m_wndLabelCombo | CXTPCalendarEventPropertiesDlg | protected
m_wndReminderCombo | CXTPCalendarEventPropertiesDlg | protected
UpdateControlsFromEvent() | CXTPCalendarEventPropertiesDlg | protectedvirtual
UpdateControlsState() | CXTPCalendarEventPropertiesDlg | protectedvirtual
~CXTPCalendarEventPropertiesDlg() | CXTPCalendarEventPropertiesDlg | inlinevirtual


Toolkit Pro: Member List

CXTPAsyncGuard< Adaptee, RWLock > Member List

This is the complete list of members for CXTPAsyncGuard< Adaptee, RWLock >, including all inherited members.

CXTPAsyncGuard(Adaptee &adaptee, CXTPRWCriticalSection &cs) | CXTPAsyncGuard< Adaptee, RWLock > | inline
CXTPAsyncGuard(Adaptee &adaptee, CXTPRWCriticalSection &cs, long &nConditionCounter) | CXTPAsyncGuard< Adaptee, RWLock > | inline
CXTPAsyncGuard(const CXTPAsyncGuard &rhs) | CXTPAsyncGuard< Adaptee, RWLock > | inline
operator Adaptee *() | CXTPAsyncGuard< Adaptee, RWLock > | inline
operator const Adaptee *() const | CXTPAsyncGuard< Adaptee, RWLock > | inline
operator*() | CXTPAsyncGuard< Adaptee, RWLock > | inline
operator*() const | CXTPAsyncGuard< Adaptee, RWLock > | inline
operator->() | CXTPAsyncGuard< Adaptee, RWLock > | inline
operator->() const | CXTPAsyncGuard< Adaptee, RWLock > | inline
~CXTPAsyncGuard() | CXTPAsyncGuard< Adaptee, RWLock > | inline


Toolkit Pro: Member List

CXTPSyntaxEditLexTokensDef Member List

This is the complete list of members for CXTPSyntaxEditLexTokensDef, including all inherited members.

CXTPSyntaxEditLexTokensDef() | CXTPSyntaxEditLexTokensDef | inline
CXTPSyntaxEditLexTokensDef(const CXTPSyntaxEditLexTokensDef &rSrc) | CXTPSyntaxEditLexTokensDef |
m_arEndSeps | CXTPSyntaxEditLexTokensDef |
m_arStartSeps | CXTPSyntaxEditLexTokensDef |
m_arTokens | CXTPSyntaxEditLexTokensDef |
operator=(const CXTPSyntaxEditLexTokensDef &rSrc) | CXTPSyntaxEditLexTokensDef |
~CXTPSyntaxEditLexTokensDef() | CXTPSyntaxEditLexTokensDef | virtual


Toolkit Pro: XTPTabThemeNativeWindows10.h Source File

  • Source
  • TabManager
  • Themes
XTPTabThemeNativeWindows10.h
Go to the documentation of this file.
1
23#if !defined(__XTPTABTHEMENATIVEWINDOWS10_H__)
24# define __XTPTABTHEMENATIVEWINDOWS10_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
37class _XTP_EXT_CLASS CXTPTabThemeNativeWindows10 : public CXTPTabThemeOffice2013
38{
39public:
44 CXTPTabThemeNativeWindows10();
45
54 virtual void RefreshMetrics();
55
64 virtual XTPTabColorStyle GetDefaultColorSet()
65 {
66 return xtpTabColorNativeWindows10;
67 }
68};
69
70# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
72#endif // __XTPTABTHEMENATIVEWINDOWS10_H__
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPTabColorStyle
XTPTabColorStyle
XTPTabColorStyle is an enumeration used to set the color style of tabs.
Definition XTPTabManagerDefines.h:139
xtpTabColorNativeWindows10
@ xtpTabColorNativeWindows10
Tabs will use the Native Windows 10 color style for the currently set Appearance.
Definition XTPTabManagerDefines.h:168
CXTPTabThemeNativeWindows10
CXTPTabThemeNativeWindows10 implements a Native Windows 10 tab appearance.
Definition XTPTabThemeNativeWindows10.h:38
CXTPTabThemeNativeWindows10::GetDefaultColorSet
virtual XTPTabColorStyle GetDefaultColorSet()
Gets the default value of the color set for this theme.
Definition XTPTabThemeNativeWindows10.h:64
CXTPTabThemeNativeWindows10::CXTPTabThemeNativeWindows10
CXTPTabThemeNativeWindows10()
Constructs a CXTPTabThemeNativeWindows10 object.
CXTPTabThemeNativeWindows10::RefreshMetrics
virtual void RefreshMetrics()
Refreshes the appearance metrics.
CXTPTabThemeOffice2013
CXTPTabThemeOffice2013 implements an Office 2013 tab appearance.
Definition XTPTabThemeOffice2013.h:38


Toolkit Pro: Member List

CXTPCalendarCaptionBarOffice2000Theme Member List

This is the complete list of members for CXTPCalendarCaptionBarOffice2000Theme, including all inherited members.

CXTPCalendarCaptionBarOffice2000Theme(CXTPCalendarCaptionBarTheme *pTheme=NULL) | CXTPCalendarCaptionBarOffice2000Theme |
CXTPCalendarCaptionBarPaintManager(CXTPCalendarCaptionBarTheme *pTheme=NULL) | CXTPCalendarCaptionBarPaintManager |
CXTPCmdTarget() | CXTPCmdTarget |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetPaintTheme() const | CXTPCalendarCaptionBarPaintManager | virtual
m_clrBorders | CXTPCalendarCaptionBarPaintManager | protected
m_clrScrollDateBarBk | CXTPCalendarCaptionBarPaintManager | protected
m_clrScrollTriangleColor | CXTPCalendarCaptionBarPaintManager | protected
m_clrSwitchViewBarBk | CXTPCalendarCaptionBarPaintManager | protected
m_clrTextColor | CXTPCalendarCaptionBarPaintManager | protected
m_fntTextFont | CXTPCalendarCaptionBarPaintManager | protected
m_pTheme | CXTPCalendarCaptionBarPaintManager | protected
RefreshMetrics() | CXTPCalendarCaptionBarOffice2000Theme | virtual
~CXTPCalendarCaptionBarOffice2000Theme() | CXTPCalendarCaptionBarOffice2000Theme | virtual
~CXTPCalendarCaptionBarPaintManager() | CXTPCalendarCaptionBarPaintManager | virtual


Toolkit Pro: Member List

CXTPMessageBarThemeOffice2013 Member List

This is the complete list of members for CXTPMessageBarThemeOffice2013, including all inherited members.

CXTPMessageBarPaintManager(CXTPPaintManager *pPaintManager) | CXTPMessageBarPaintManager |
CXTPMessageBarThemeOffice2013(CXTPPaintManager *pPaintManager) | CXTPMessageBarThemeOffice2013 |
DrawMessageBarButton(CDC *pDC, CXTPMessageBarButton *pButton) | CXTPMessageBarThemeOffice2013 | virtual
FillMessageBar(CDC *pDC, CXTPMessageBar *pBar) | CXTPMessageBarThemeOffice2013 | virtual
GetCloseButtonRect(int x, int y, int cy) | CXTPMessageBarThemeOffice2013 | virtual
GetDefaultButtonSize() const | CXTPMessageBarPaintManager | virtual
GetHeight() const | CXTPMessageBarPaintManager | virtual
GetPadding() const | CXTPMessageBarPaintManager | virtual
m_clrBack | CXTPMessageBarPaintManager | protected
m_clrBorder | CXTPMessageBarPaintManager | protected
m_clrButtonBack | CXTPMessageBarThemeOffice2013 | protected
m_clrButtonBackHilite | CXTPMessageBarThemeOffice2013 | protected
m_clrButtonBackPushed | CXTPMessageBarThemeOffice2013 | protected
m_clrButtonBorder | CXTPMessageBarThemeOffice2013 | protected
m_clrButtonBorderHilite | CXTPMessageBarThemeOffice2013 | protected
m_clrButtonBorderPushed | CXTPMessageBarThemeOffice2013 | protected
m_clrInfoBack | CXTPMessageBarPaintManager | protected
m_clrText | CXTPMessageBarPaintManager | protected
m_clrTextHilite | CXTPMessageBarThemeOffice2013 | protected
m_pPaintManager | CXTPMessageBarPaintManager | protected
RefreshMetrics() | CXTPMessageBarThemeOffice2013 | virtual
~CXTPMessageBarPaintManager() | CXTPMessageBarPaintManager | inlinevirtual


Toolkit Pro: XTPChartLineSeriesView.h Source File

  • Source
  • Chart
  • Styles
  • Line
XTPChartLineSeriesView.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTLINESERIESVIEW_H__)
24# define __XTPCHARTLINESERIESVIEW_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
33# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
34#endif // !defined(__XTPCHARTLINESERIESVIEW_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h


Toolkit Pro: Member List

CXTPHeapString Member List

This is the complete list of members for CXTPHeapString, including all inherited members.

_AllocStringData(int nNewStrLen) | CXTPHeapString | protectedvirtual
_FreeStringData() | CXTPHeapString | protectedvirtual
AllocSysString() const | CXTPHeapString | virtual
CXTPHeapString() | CXTPHeapString |
CXTPHeapString(LPCTSTR pcszString) | CXTPHeapString |
IsEmpty() const | CXTPHeapString | virtual
m_nStrLen | CXTPHeapString | protected
m_pcszString | CXTPHeapString | protected
operator CString() const | CXTPHeapString |
operator LPCTSTR() const | CXTPHeapString |
operator!=(LPCTSTR pcszString) const | CXTPHeapString |
operator=(LPCTSTR pcszString) | CXTPHeapString |
operator==(LPCTSTR pcszString) const | CXTPHeapString |
SetString(LPCTSTR pcszString) | CXTPHeapString | virtual
~CXTPHeapString() | CXTPHeapString | virtual


Toolkit Pro: XTPCaptionButtonThemeOfficeXP.h Source File

  • Source
  • Controls
  • Static
  • Themes
XTPCaptionButtonThemeOfficeXP.h
Go to the documentation of this file.
1
23#if !defined(__XTPCAPTIONBUTTONTHEMEOFFICEXP_H__)
24# define __XTPCAPTIONBUTTONTHEMEOFFICEXP_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
39class _XTP_EXT_CLASS CXTPCaptionButtonThemeOfficeXP : public CXTPButtonThemeOfficeXP
40{
41public:
47 CXTPCaptionButtonThemeOfficeXP();
48
49protected:
56 virtual void DrawButtonText(CDC* pDC, CXTPButton* pButton);
57
64 virtual void DrawButtonBackground(CDC* pDC, CXTPButton* pButton);
65
73 virtual COLORREF GetTextColor(CXTPButton* pButton);
74};
75
76# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
78#endif // !defined(__XTPCAPTIONBUTTONTHEMEOFFICEXP_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPButton
Push Button control.
Definition XTPButton.h:109
CXTPButtonThemeOfficeXP
CXTPButtonThemeOfficeXP is a class used to perform Office XP Theme drawing tasks.
Definition XTPButtonThemeOfficeXP.h:39
CXTPCaptionButtonThemeOfficeXP
Class CXTPCaptionButtonThemeOfficeXP is a CXTPButtonOfficeXPTheme derived class.
Definition XTPCaptionButtonThemeOfficeXP.h:40
CXTPCaptionButtonThemeOfficeXP::GetTextColor
virtual COLORREF GetTextColor(CXTPButton *pButton)
Call this member function to get the text color of the button caption.
CXTPCaptionButtonThemeOfficeXP::CXTPCaptionButtonThemeOfficeXP
CXTPCaptionButtonThemeOfficeXP()
Default class constructor.
CXTPCaptionButtonThemeOfficeXP::DrawButtonText
virtual void DrawButtonText(CDC *pDC, CXTPButton *pButton)
Call this member function to draw the button caption text.
CXTPCaptionButtonThemeOfficeXP::DrawButtonBackground
virtual void DrawButtonBackground(CDC *pDC, CXTPButton *pButton)
Call this member function to draw the background of the button caption.


Toolkit Pro: XTPChartPieDeviceCommand.h Source File

  • Source
  • Chart
  • Drawing
XTPChartPieDeviceCommand.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTPIEDEVICECOMMAND_H__)
24# define __XTPCHARTPIEDEVICECOMMAND_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
37class _XTP_EXT_CLASS CXTPChartPieDeviceCommandImpl
38{
39 friend class CXTPChartPieDeviceCommand;
40 friend class CXTPChart3dPieDeviceCommand;
41
42private:
55 CXTPChartPieDeviceCommandImpl(const CXTPPoint3d& ptCenter, double dMajorSemiAxis,
56 double dMinorSemiAxis, double dStartAngle, double dSweepAngle,
57 double dDepth, double nHolePercent);
58
59protected:
64 virtual ~CXTPChartPieDeviceCommandImpl();
65
66public:
67 CXTPPoint3d m_ptCenter;
68 double m_dMajorSemiAxis;
69 double m_dMinorSemiAxis;
70 double m_dStartAngle;
71 double m_dSweepAngle;
72 double m_dDepth;
73 double m_dHolePercent;
75 double m_dInnerMajorSemiAxis;
76 double m_dInnerMinorSemiAxis;
78 double m_dFacetSize;
79 double m_dRadius;
80 double m_dCorrectedDepth;
81 double m_dInnerRadius;
83 BOOL m_bDoughnut;
84};
85
90class _XTP_EXT_CLASS CXTPChartPieDeviceCommand
91 : public CXTPChartDeviceCommand
92 , protected CXTPChartPieDeviceCommandImpl
93{
94protected:
107 CXTPChartPieDeviceCommand(const CXTPPoint3d& ptCenter, double dMajorSemiAxis,
108 double dMinorSemiAxis, double dStartAngle, double dSweepAngle,
109 double dDepth, double nHolePercent);
110};
111
112// CXTPChart2dPieDeviceCommand alias is necessary fo consistency.
113typedef CXTPChartPieDeviceCommand CXTPChart2dPieDeviceCommand;
114
119class _XTP_EXT_CLASS CXTPChart3dPieDeviceCommand
120 : public CXTPChart3dDeviceCommand
121 , protected CXTPChartPieDeviceCommandImpl
122{
123protected:
139 CXTPChart3dPieDeviceCommand(XTPChart3dAntialiasingPolicy nAntialiasingPolicy,
140 const CXTPPoint3d& ptCenter, double dMajorSemiAxis,
141 double dMinorSemiAxis, double dStartAngle, double dSweepAngle,
142 double dDepth, double nHolePercent);
143};
145# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
146#endif //#if !defined(__XTPCHARTPIEDEVICECOMMAND_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChart3dDeviceCommand
Defines a common implementation interface for chart 3D drawing commands.
Definition XTPChartDeviceCommand.h:368
CXTPChart3dPieDeviceCommand
Base class implementation for 3D pie chart device command.
Definition XTPChartPieDeviceCommand.h:122
CXTPChart3dPieDeviceCommand::CXTPChart3dPieDeviceCommand
CXTPChart3dPieDeviceCommand(XTPChart3dAntialiasingPolicy nAntialiasingPolicy, const CXTPPoint3d &ptCenter, double dMajorSemiAxis, double dMinorSemiAxis, double dStartAngle, double dSweepAngle, double dDepth, double nHolePercent)
Constructs a CXTPChartPieDeviceCommand object.
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPChartPieDeviceCommand
Base class implementation for 2D pie chart device command.
Definition XTPChartPieDeviceCommand.h:93
CXTPChartPieDeviceCommand::CXTPChartPieDeviceCommand
CXTPChartPieDeviceCommand(const CXTPPoint3d &ptCenter, double dMajorSemiAxis, double dMinorSemiAxis, double dStartAngle, double dSweepAngle, double dDepth, double nHolePercent)
Constructs a CXTPChartPieDeviceCommand object.
CXTPChartPieDeviceCommandImpl
This class is a common implementation for a pie chart device command.
Definition XTPChartPieDeviceCommand.h:38
CXTPChartPieDeviceCommandImpl::m_dInnerMinorSemiAxis
double m_dInnerMinorSemiAxis
The inner size of the minor semi axis of the ellipse.
Definition XTPChartPieDeviceCommand.h:76
CXTPChartPieDeviceCommandImpl::m_ptCenter
CXTPPoint3d m_ptCenter
The center point of the pie.
Definition XTPChartPieDeviceCommand.h:67
CXTPChartPieDeviceCommandImpl::m_dMajorSemiAxis
double m_dMajorSemiAxis
The major semi axis of the ellipse.
Definition XTPChartPieDeviceCommand.h:68
CXTPChartPieDeviceCommandImpl::m_dFacetSize
double m_dFacetSize
Facet size.
Definition XTPChartPieDeviceCommand.h:78
CXTPChartPieDeviceCommandImpl::m_dCorrectedDepth
double m_dCorrectedDepth
Pie corrected depth.
Definition XTPChartPieDeviceCommand.h:80
CXTPChartPieDeviceCommandImpl::m_dInnerRadius
double m_dInnerRadius
Pie inner radius.
Definition XTPChartPieDeviceCommand.h:81
CXTPChartPieDeviceCommandImpl::m_dSweepAngle
double m_dSweepAngle
The sweep angle of the pie.
Definition XTPChartPieDeviceCommand.h:71
CXTPChartPieDeviceCommandImpl::m_dHolePercent
double m_dHolePercent
Determines the size of the hole when drawing a doughnut.
Definition XTPChartPieDeviceCommand.h:73
CXTPChartPieDeviceCommandImpl::m_dMinorSemiAxis
double m_dMinorSemiAxis
The minor semi axis of the ellipse.
Definition XTPChartPieDeviceCommand.h:69
CXTPChartPieDeviceCommandImpl::m_dRadius
double m_dRadius
Pie radius.
Definition XTPChartPieDeviceCommand.h:79
CXTPChartPieDeviceCommandImpl::m_bDoughnut
BOOL m_bDoughnut
TRUE indicates doughnut style.
Definition XTPChartPieDeviceCommand.h:83
CXTPChartPieDeviceCommandImpl::~CXTPChartPieDeviceCommandImpl
virtual ~CXTPChartPieDeviceCommandImpl()
Handles object destruction.
CXTPChartPieDeviceCommandImpl::m_dInnerMajorSemiAxis
double m_dInnerMajorSemiAxis
The inner size of the major semi axis of the ellipse.
Definition XTPChartPieDeviceCommand.h:75
CXTPChartPieDeviceCommandImpl::m_dDepth
double m_dDepth
The depth of the pie or torus.
Definition XTPChartPieDeviceCommand.h:72
CXTPChartPieDeviceCommandImpl::m_dStartAngle
double m_dStartAngle
The start angle of the pie.
Definition XTPChartPieDeviceCommand.h:70
CXTPPoint3T< double >


Toolkit Pro: Member List

CXTPChartPieSeriesViewBase Member List

This is the complete list of members for CXTPChartPieSeriesViewBase, including all inherited members.

AddChildView(CXTPChartElementView *pChildView) | CXTPChartElementView |
CalculateLabelLayout(CXTPChartDeviceContext *pDC) | CXTPChartPieSeriesViewBase | virtual
CalculatePointLayout(CXTPChartDeviceContext *pDC, CRect rcBounds)=0 | CXTPChartPieSeriesViewBase | pure virtual
CreateDeviceCommand(CXTPChartDeviceContext *pDC)=0 | CXTPChartPieSeriesViewBase | protectedpure virtual
CreateDiagramDomain(CXTPChartDeviceContext *pDC, CRect rcBounds) | CXTPChartPieSeriesViewBase | virtual
CreateLegendDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcBounds)=0 | CXTPChartPieSeriesViewBase | protectedpure virtual
CreateSeriesPointView(CXTPChartDeviceContext *pDC, CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)=0 | CXTPChartPieSeriesViewBase | protectedpure virtual
CXTPChartElementView(CXTPChartElementView *pParentView) | CXTPChartElementView |
CXTPChartElementView(CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartElementView |
CXTPChartElementView(CXTPChartContainer *pContainer) | CXTPChartElementView |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartPieSeriesViewBase(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView) | CXTPChartPieSeriesViewBase | protected
GetAt(int nIndex) const | CXTPChartElementView |
GetBounds() const | CXTPChartElementView |
GetBounds(BOOL bIncludingChildren) const | CXTPChartElementView |
GetChildren() | CXTPChartElementView |
GetCount() const | CXTPChartElementView |
GetDomain() const | CXTPChartPieSeriesViewBase |
GetInnerBounds() const | CXTPChartPieSeriesViewBase |
GetMaxLabelWidth() const | CXTPChartPieSeriesViewBase |
GetParentView() const | CXTPChartElementView |
Is3D() const | CXTPChartObject |
m_arrChildren | CXTPChartElementView | protected
m_pContainer | CXTPChartElementView | protected
m_pParentView | CXTPChartElementView | protected
m_rcBounds | CXTPChartElementView | protected
~CXTPChartElementView() | CXTPChartElementView | protectedvirtual
~CXTPChartLegendItemView() | CXTPChartLegendItemView | inlinevirtual
~CXTPChartPieSeriesViewBase() | CXTPChartPieSeriesViewBase | virtual


Toolkit Pro: Member List

CXTPChartMarker Member List

This is the complete list of members for CXTPChartMarker, including all inherited members.

CreateDeviceCommand(CXTPChartDeviceContext *pDC, const CXTPChartPointF &point, CXTPChartColor color, CXTPChartColor color2, CXTPChartColor colorBorder) | CXTPChartMarker | virtual
CreateDeviceCommand(CXTPChartDeviceContext *pDC, const CXTPChartPointF &point, int nWidth, CXTPChartColor color, CXTPChartColor color2, CXTPChartColor colorBorder) | CXTPChartMarker | virtual
CXTPChartElement() | CXTPChartElement |
CXTPChartMarker(CXTPChartSeriesStyle *pOwner) | CXTPChartMarker |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
DoPropExchange(CXTPPropExchange *pPX) | CXTPChartMarker | virtual
GetAppearance() const | CXTPChartElement |
GetContent() const | CXTPChartElement |
GetOwner() const | CXTPChartElement |
Is3D() const | CXTPChartObject |
m_bBorderVisible | CXTPChartMarker | protected
m_bVisible | CXTPChartMarker | protected
m_clrBorderColor | CXTPChartMarker | protected
m_clrColor | CXTPChartMarker | protected
m_nSize | CXTPChartMarker | protected
m_nType | CXTPChartMarker | protected
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartElement | virtual
Release() | CXTPChartElement | virtual
~CXTPChartElement() | CXTPChartElement | virtual
~CXTPChartMarker() | CXTPChartMarker | virtual


Toolkit Pro: XTPChartBubbleSeriesLabel.h Source File

  • Source
  • Chart
  • Styles
  • Point
XTPChartBubbleSeriesLabel.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTBUBBLESERIESLABEL_H__)
24# define __XTPCHARTBUBBLESERIESLABEL_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartSeriesView;
34
40class _XTP_EXT_CLASS CXTPChartBubbleSeriesLabel : public CXTPChartSeriesLabel
41{
42 DECLARE_SERIAL(CXTPChartBubbleSeriesLabel);
43
44public:
49 CXTPChartBubbleSeriesLabel();
50
55 virtual ~CXTPChartBubbleSeriesLabel();
56
57public:
58public:
71 virtual CXTPChartElementView* CreateView(CXTPChartDeviceContext* pDC,
72 CXTPChartSeriesPointView* pPointView,
73 CXTPChartElementView* pParentView);
74
75protected:
76};
77
83class _XTP_EXT_CLASS CXTPChartBubbleSeriesLabelView : public CXTPChartDiagram2DSeriesLabelView
84{
85public:
94 CXTPChartBubbleSeriesLabelView(CXTPChartSeriesLabel* pLabel,
95 CXTPChartSeriesPointView* pPointView,
96 CXTPChartElementView* pParentView);
97
98 using CXTPChartDiagram2DSeriesLabelView::CreateDeviceCommand;
99
112 virtual CXTPChartDeviceCommand* CreateDeviceCommand(CXTPChartDeviceContext* pDC);
113
114 void CalculateLayout(CXTPChartDeviceContext* pDC);
115};
117# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
118#endif //#if !defined(__XTPCHARTBUBBLESERIESLABEL_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartBubbleSeriesLabel
CXTPChartBubbleSeriesLabel is a kind of CXTPChartSeriesLabel.
Definition XTPChartBubbleSeriesLabel.h:41
CXTPChartBubbleSeriesLabel::~CXTPChartBubbleSeriesLabel
virtual ~CXTPChartBubbleSeriesLabel()
Destroys a CXTPChartBubbleSeriesLabel object, handles cleanup.
CXTPChartBubbleSeriesLabel::CXTPChartBubbleSeriesLabel
CXTPChartBubbleSeriesLabel()
Constructs a CXTPChartBubbleSeriesLabel object.
CXTPChartBubbleSeriesLabel::CreateView
virtual CXTPChartElementView * CreateView(CXTPChartDeviceContext *pDC, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView)
This function creates the view (CXTPChartBubbleSeriesLabelView) of the bubble series.
CXTPChartBubbleSeriesLabelView
CXTPChartBubbleSeriesLabelView is a kind of CXTPChartSeriesLabelView.
Definition XTPChartBubbleSeriesLabel.h:84
CXTPChartBubbleSeriesLabelView::CXTPChartBubbleSeriesLabelView
CXTPChartBubbleSeriesLabelView(CXTPChartSeriesLabel *pLabel, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView)
Constructs a CXTPChartBubbleSeriesLabelView object.
CXTPChartBubbleSeriesLabelView::CreateDeviceCommand
virtual CXTPChartDeviceCommand * CreateDeviceCommand(CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartDiagram2DSeriesLabelView
This class abstracts the view of the label of a point series.
Definition XTPChartDiagram2DSeriesLabel.h:69
CXTPChartDiagram2DSeriesLabelView::CreateDeviceCommand
virtual CXTPChartDeviceCommand * CreateDeviceCommand(CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
CXTPChartElementView
This class represents the view of a chart element.
Definition XTPChartElementView.h:47
CXTPChartSeriesLabel
This class abstracts the label of a series.
Definition XTPChartSeriesLabel.h:49
CXTPChartSeriesPointView
Represents chart series point view.
Definition XTPChartSeriesPointView.h:48


Toolkit Pro: XTPCommandBarsDefines.h Source File

  • Source
  • CommandBars
XTPCommandBarsDefines.h
Go to the documentation of this file.
1
23#if !defined(__XTPCOMMANDBARDEFINES_H__)
24# define __XTPCOMMANDBARDEFINES_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPControl;
34class CXTPCommandBar;
35class CXTPPopupBar;
36
51enum XTPBarPosition
52{
53 xtpBarTop = 0,
54 xtpBarBottom = 1,
55 xtpBarLeft = 2,
56 xtpBarRight = 3,
57 xtpBarFloating = 4,
58 xtpBarPopup = 5,
59 xtpBarListBox = 6,
60 xtpBarNone = 7
61};
62
76enum XTPBarType
77{
78 xtpBarTypeMenuBar,
79 xtpBarTypeNormal,
80 xtpBarTypePopup,
81 xtpBarTypeRibbon
82};
83
90enum XTPBarTextOrientation
91{
92 xtpBarTextAuto,
94 xtpBarTextVertical,
95 xtpBarTextHorizontal
96};
97
110enum XTPControlType
111{
112 xtpControlError,
113 xtpControlButton,
114 xtpControlPopup,
115 xtpControlButtonPopup,
116 xtpControlSplitButtonPopup,
117 xtpControlComboBox,
118 xtpControlEdit,
119 xtpControlCustom,
120 xtpControlLabel,
121 xtpControlCheckBox,
122 xtpControlGallery,
123 xtpControlRadioButton
124};
125
137enum XTPControlFlags
138{
139 xtpFlagRightAlign = 1,
140 xtpFlagSkipFocus = 2,
141 xtpFlagLeftPopup = 4,
142 xtpFlagManualUpdate = 8,
143 xtpFlagNoMovable = 16,
144 xtpFlagControlStretched = 32,
145 xtpFlagShowPopupBarTip = 64,
146 xtpFlagWrapRow = 128,
147 xtpFlagRibbonTabBackground = 256
148};
149
161enum XTPControlHideFlags
162{
163 xtpNoHide = 0,
164 xtpHideGeneric = 1,
165 xtpHideWrap = 2,
167 xtpHideDockingPosition = 4,
171 xtpHideScroll = 8,
173 xtpHideCustomize = 16,
177 xtpHideExpand = 32,
179 xtpHideDocTemplate = 64,
181 xtpHideRibbonTab = 128
182};
183
196enum XTPButtonStyle
197{
198 xtpButtonUndefined = -1,
199 xtpButtonAutomatic = 0,
200 xtpButtonCaption = 1,
201 xtpButtonIcon = 2,
202 xtpButtonIconAndCaption = 3,
203 xtpButtonIconAndCaptionBelow = 4,
205 xtpButtonCaptionAndDescription = 5
207};
208
213# define xtpComboNormal xtpButtonAutomatic
214
219# define xtpComboLabel xtpButtonCaption
220
232enum XTPPaintTheme
233{
234 xtpThemeNone = -1,
235 xtpThemeOffice2000 = 0,
236 xtpThemeOfficeXP = 1,
237 xtpThemeOffice2003 = 2,
238 xtpThemeNativeWinXP = 3,
239 xtpThemeVisualStudio2005 = 4,
240 xtpThemeResource = 5,
241 xtpThemeRibbon = 6,
242 xtpThemeVisualStudio2008 = 7,
243 xtpThemeVisualStudio6 = 8,
244 xtpThemeVisualStudio2010 = 9,
245 xtpThemeCustom = 10,
246 xtpThemeOffice2007System = 11,
247 xtpThemeOffice2013 = 12,
248 xtpThemeOffice2016 = xtpThemeOffice2013,
249 xtpThemeVisualStudio2012 = 13,
250 xtpThemeVisualStudio2012Light = 14,
251 xtpThemeVisualStudio2012Dark = 15,
252 xtpThemeVisualStudio2015 = 16,
253 xtpThemeNativeWindows10 = 17,
254 xtpThemeVisualStudio2017 = 18,
255 xtpThemeVisualStudio2019 = 19,
256 xtpThemeVisualStudio2022 = 20,
257 xtpThemeNativeWindows11 = 21,
258};
259
261# define xtpThemeWhidbey xtpThemeVisualStudio2005 // old names.
262# define xtpThemeOffice2007 xtpThemeResource
279enum XTPMenuBarFlags
280{
281 xtpFlagHideMinimizeBox = 0x0100L,
282 xtpFlagHideMaximizeBox = 0x0200L,
283 xtpFlagIgnoreSetMenuMessage = 0x0400L,
284 xtpFlagUseMDIMenus = 0x0800L,
285 xtpFlagHideClose = 0x1000L,
286 xtpFlagHideMDIButtons = xtpFlagHideMinimizeBox | xtpFlagHideMaximizeBox
287 | xtpFlagHideClose,
289 xtpFlagAddMDISysPopup = 0x2000L
293};
294
310enum XTPToolBarFlags
311{
312 xtpFlagAlignTop = 0x000001,
313 xtpFlagAlignBottom = 0x000002,
314 xtpFlagAlignLeft = 0x000004,
315 xtpFlagAlignRight = 0x000008,
316 xtpFlagAlignAny = (xtpFlagAlignTop | xtpFlagAlignBottom | xtpFlagAlignLeft
317 | xtpFlagAlignRight),
318 xtpFlagFloating = 0x000010,
319 xtpFlagHideWrap = 0x000020,
320 xtpFlagStretched = 0x000040,
321 xtpFlagNoBorders = 0x000080,
323 xtpFlagStretchedShared = 0x100000,
324 xtpFlagSmartLayout = 0x200000
325};
326
336enum XTPKeyboardCuesShow
337{
338 xtpKeyboardCuesShowAlways,
339 xtpKeyboardCuesShowNever,
340 xtpKeyboardCuesShowWindowsDefault
341};
342
352enum XTPKeyboardCuesUse
353{
354 xtpKeyboardCuesUseMenuOnly = 0,
355 xtpKeyboardCuesUseAll = 1,
356 xtpKeyboardCuesUseNone = 2,
357 xtpKeyboardCuesUseAmpersandOnly = 4
359};
360
372enum XTPAnimationType
373{
374 xtpAnimateWindowsDefault,
375 xtpAnimateRandom,
376 xtpAnimateUnfold,
377 xtpAnimateSlide,
378 xtpAnimateFade,
379 xtpAnimateNone
380};
381
388enum XTPPopupDirection
389{
390 xtpPopupRight = 0,
391 xtpPopupLeft = 1,
392 xtpPopupDown = 2,
393 xtpPopupUp = 4
394};
395
406enum XTPSpecialKey
407{
408 xtpKeyNext,
409 xtpKeyPrev,
410 xtpKeyBack,
411 xtpKeyPopup,
412 xtpKeyEscape,
413 xtpKeyReturn,
414 xtpKeyHome,
415 xtpKeyEnd,
416 xtpKeyLeft,
417 xtpKeyRight,
418 xtpKeySpace
419};
420
430enum XTPIdleFlags
431{
432 xtpIdleLayout = 1,
433 xtpIdleRedraw = 2
434};
435
436# include "Common/XTPPropExchange.inc"
437
442const UINT WM_XTP_COMMANDBARS_BASE = (WM_USER + 9300);
443
471const UINT WM_XTP_TOOLBARVISIBLECHANGED = (WM_XTP_COMMANDBARS_BASE + 1);
472
503const UINT WM_XTP_CONTROLSELECTED = (WM_XTP_COMMANDBARS_BASE + 2);
504
528const UINT WM_XTP_DRAGCONTROLCHANGED = (WM_XTP_COMMANDBARS_BASE + 3);
529
560const UINT WM_XTP_INITMENU = (WM_XTP_COMMANDBARS_BASE + 4);
561
611const UINT WM_XTP_CONTROLRBUTTONUP = (WM_XTP_COMMANDBARS_BASE + 5);
612
640const UINT WM_XTP_COMMANDBARKEYDOWN = (WM_XTP_COMMANDBARS_BASE + 6);
641
667const UINT WM_XTP_INITCOMMANDSPOPUP = (WM_XTP_COMMANDBARS_BASE + 7);
668
699const UINT WM_XTP_TOOLBARCONTEXTMENU = (WM_XTP_COMMANDBARS_BASE + 8);
700
704# define ON_XTP_INITCOMMANDSPOPUP()
706# undef ON_XTP_INITCOMMANDSPOPUP
707# define ON_XTP_INITCOMMANDSPOPUP() \
708 { WM_XTP_INITCOMMANDSPOPUP, \
709 0, \
710 0, \
711 0, \
712 AfxSig_vs, \
713 (AFX_PMSG)(AFX_PMSGW)(void (AFX_MSG_CALL CWnd::*)(CXTPPopupBar*)) \
714 & OnInitCommandsPopup },
742const UINT WM_XTP_UNINITCOMMANDSPOPUP = (WM_XTP_COMMANDBARS_BASE + 9);
743
747# define ON_XTP_UNINITCOMMANDSPOPUP()
749# undef ON_XTP_UNINITCOMMANDSPOPUP
750# define ON_XTP_UNINITCOMMANDSPOPUP() \
751 { WM_XTP_UNINITCOMMANDSPOPUP, \
752 0, \
753 0, \
754 0, \
755 AfxSig_vs, \
756 (AFX_PMSG)(AFX_PMSGW)(void (AFX_MSG_CALL CWnd::*)(CXTPPopupBar*)) \
757 & OnUninitCommandsPopup },
768typedef struct
769{
770 NMHDR hdr;
771 CXTPControl* pControl;
772} NMXTPCONTROL, FAR* LPNMXTPCONTROL;
773
817const UINT CBN_XTP_EXECUTE = 100;
818
822# define ON_XTP_EXECUTE(id, memberFxn)
824# undef ON_XTP_EXECUTE
825# define ON_XTP_EXECUTE(id, memberFxn) ON_NOTIFY(CBN_XTP_EXECUTE, id, memberFxn)
831# define ON_XTP_EXECUTE_RANGE(id, idLast, memberFxn)
833# undef ON_XTP_EXECUTE_RANGE
834# define ON_XTP_EXECUTE_RANGE(id, idLast, memberFxn) \
835 ON_NOTIFY_EX_RANGE(CBN_XTP_EXECUTE, id, idLast, memberFxn)
848typedef struct
849{
850 UINT nID;
851 CXTPControl* pControl;
852 BOOL bToolBar;
853 int nIndex;
854 CMenu* pMenu;
855 CXTPCommandBar* pCommandBar;
856 CString strCaption;
857 XTPControlType controlType;
858 XTPButtonStyle buttonStyle;
859} XTP_COMMANDBARS_CREATECONTROL, FAR* LPCREATECONTROLSTRUCT;
860
893const UINT WM_XTP_BEFORECREATECONTROL = (WM_XTP_COMMANDBARS_BASE + 10);
894
898# define ON_XTP_CREATECONTROL()
900# undef ON_XTP_CREATECONTROL
901# define ON_XTP_CREATECONTROL() \
902 { WM_XTP_BEFORECREATECONTROL, \
903 0, \
904 0, \
905 0, \
906 AfxSig_is, \
907 (AFX_PMSG)(AFX_PMSGW)(int (AFX_MSG_CALL CWnd::*)(LPCREATECONTROLSTRUCT)) \
908 & OnCreateControl },
944const UINT WM_XTP_AFTERCREATECONTROL = (WM_XTP_COMMANDBARS_BASE + 11);
945
949# define ON_XTP_AFTERCREATECONTROL()
951# undef ON_XTP_AFTERCREATECONTROL
952# define ON_XTP_AFTERCREATECONTROL() \
953 { WM_XTP_AFTERCREATECONTROL, \
954 0, \
955 0, \
956 0, \
957 AfxSig_vs, \
958 (AFX_PMSG)(AFX_PMSGW)(void (AFX_MSG_CALL CWnd::*)(LPCREATECONTROLSTRUCT)) \
959 & OnAfterCreateControl },
991const UINT WM_XTP_GETTABICON = (WM_XTP_COMMANDBARS_BASE + 12);
992
1003typedef struct
1004{
1005 CXTPCommandBar* pCommandBar;
1006 BOOL bPopup;
1007 BOOL bExpandBar;
1008 BOOL bCustomBar;
1009 BOOL bTearOffBar;
1010 LPCTSTR lpcstrCaption;
1011 UINT nID;
1012} XTP_COMMANDBARS_CREATEBAR, FAR* LPCREATEBARSTRUCT;
1013
1049const UINT WM_XTP_CREATECOMMANDBAR = (WM_XTP_COMMANDBARS_BASE + 13);
1050
1078const UINT WM_XTP_MESSAGEBARCLOSED = (WM_XTP_COMMANDBARS_BASE + 21);
1079
1086const UINT WM_XTP_SETBAKSTAGEBUTTONKEYTIP = (WM_XTP_COMMANDBARS_BASE + 31);
1087
1094const UINT WM_XTP_SETBAKSTAGEBUTTONKEYTIPDRAWFLAG = (WM_XTP_COMMANDBARS_BASE + 32);
1095
1125# define XTP_CN_UPDATE_CUSTOMIZE_COMMAND_UI ((UINT)(INT_MIN + 1))
1126
1130# define ON_XTP_CREATECOMMANDBAR()
1132# undef ON_XTP_CREATECOMMANDBAR
1133# define ON_XTP_CREATECOMMANDBAR() \
1134 { WM_XTP_CREATECOMMANDBAR, \
1135 0, \
1136 0, \
1137 0, \
1138 AfxSig_is, \
1139 (AFX_PMSG)(AFX_PMSGW)(int (AFX_MSG_CALL CWnd::*)(LPCREATEBARSTRUCT)) \
1140 & OnCreateCommandBar },
1169# define DECLARE_XTP_CONTROL(class_name)
1171# undef DECLARE_XTP_CONTROL
1172# define DECLARE_XTP_CONTROL(class_name) \
1173 DECLARE_SERIAL(class_name) \
1174 virtual CXTPControl* Clone(BOOL bRecursive);
1195# define IMPLEMENT_XTP_CONTROL(class_name, base_class_name)
1197# undef IMPLEMENT_XTP_CONTROL
1198# define IMPLEMENT_XTP_CONTROL(class_name, base_class_name) \
1199 IMPLEMENT_SERIAL(class_name, base_class_name, VERSIONABLE_SCHEMA | _XTP_SCHEMA_CURRENT) \
1200 CXTPControl* class_name::Clone(BOOL bRecursive) \
1201 { \
1202 class_name* pButton = (class_name*)class_name::CreateObject(); \
1203 pButton->Copy(this, bRecursive); \
1204 return pButton; \
1205 }
1234# define DECLARE_XTP_COMMANDBAR(class_name)
1236# undef DECLARE_XTP_COMMANDBAR
1237# define DECLARE_XTP_COMMANDBAR(class_name) \
1238 DECLARE_SERIAL(class_name) \
1239 virtual CXTPCommandBar* Clone(BOOL bRecursive);
1263# define IMPLEMENT_XTP_COMMANDBAR(class_name, base_class_name)
1265# undef IMPLEMENT_XTP_COMMANDBAR
1266# define IMPLEMENT_XTP_COMMANDBAR(class_name, base_class_name) \
1267 IMPLEMENT_SERIAL(class_name, base_class_name, VERSIONABLE_SCHEMA | _XTP_SCHEMA_CURRENT) \
1268 CXTPCommandBar* class_name::Clone(BOOL bRecursive) \
1269 { \
1270 class_name* pCommandBar = (class_name*)class_name::CreateObject(); \
1271 pCommandBar->Copy(this, bRecursive); \
1272 return pCommandBar; \
1273 }
1274
1275// Internal defines
1276# define TRUE_POPUP 2
1277# define TRUE_KEYBOARD 2
1278# define TRUE_KEYBOARD_NEXT 2
1279# define TRUE_KEYBOARD_PREV 3
1280# define TRUE_SPLITCOMMAND 4
1281# define TRUE_SPLITDROPDOWN 5
1282# define XTP_EDITSPIN_UP 4
1283# define XTP_EDITSPIN_DOWN 5
1284# define XTP_EDITBUDDYBUTTON 6
1285# define FALSE_EXIT 2
1286# define LM_HIDEWRAP 0x80
1287# define LM_POPUP 0x100
1288
1289AFX_INLINE BOOL IsKeyboardSelected(BOOL bSelected)
1290{
1291 return bSelected == TRUE_KEYBOARD_NEXT || bSelected == TRUE_KEYBOARD_PREV;
1292}
1293AFX_INLINE BOOL IsControlCommandEnabled(BOOL bEnabled)
1294{
1295 return bEnabled && bEnabled != TRUE_SPLITDROPDOWN;
1296}
1297AFX_INLINE BOOL IsControlDropDownEnabled(BOOL bEnabled)
1298{
1299 return bEnabled && bEnabled != TRUE_SPLITCOMMAND;
1300}
1301
1302// ActiveX commands
1303# define WM_XTP_COMMAND (WM_XTP_COMMANDBARS_BASE + 14)
1304# define WM_XTP_UPDATE_COMMAND (WM_XTP_COMMANDBARS_BASE + 15)
1305# define WM_XTP_CUSTOMIZATION_RESETTOOLBAR (WM_XTP_COMMANDBARS_BASE + 16)
1306# define WM_XTP_CUSTOMIZATION_ADDTOOLBAR (WM_XTP_COMMANDBARS_BASE + 17)
1307# define WM_XTP_CUSTOMIZATION_DELETETOOLBAR (WM_XTP_COMMANDBARS_BASE + 18)
1308# define WM_XTP_TEAROFFDONE (WM_XTP_COMMANDBARS_BASE + 19)
1309# define WM_XTP_DELAYEXECUTE (WM_XTP_COMMANDBARS_BASE + 20)
1310
1311# define XTP_CN_REDRAWPARENT 1
1312
1313# ifndef TPM_RECURSE
1314# define TPM_RECURSE 0x0001L
1315# endif
1316
1317# ifndef _XTP_INCLUDE_COMMANDBARS
1318# undef _XTP_COMMANDBARS_ACTIVEX
1319# endif
1331AFX_INLINE BOOL IsDockingPosition(XTPBarPosition barPosition)
1332{
1333 return barPosition == xtpBarLeft || barPosition == xtpBarTop || barPosition == xtpBarRight
1334 || barPosition == xtpBarBottom;
1335}
1336
1346AFX_INLINE BOOL IsCaptionStyle(XTPButtonStyle buttonStyle)
1347{
1348 return buttonStyle == xtpButtonCaption || buttonStyle == xtpButtonIconAndCaption;
1349}
1350
1360AFX_INLINE BOOL IsPopupControlType(XTPControlType controlType)
1361{
1362 return controlType == xtpControlPopup || controlType == xtpControlButtonPopup
1363 || controlType == xtpControlSplitButtonPopup;
1364}
1365
1375AFX_INLINE BOOL IsVerticalPosition(XTPBarPosition barPosition)
1376{
1377 return barPosition == xtpBarLeft || barPosition == xtpBarRight || barPosition == xtpBarPopup;
1378}
1379
1388AFX_INLINE BOOL IsAnimateType(XTPAnimationType animationType)
1389{
1390 return animationType == xtpAnimateFade || animationType == xtpAnimateSlide
1391 || animationType == xtpAnimateUnfold;
1392}
1394# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
1395#endif //#if !defined(__XTPCOMMANDBARDEFINES_H__)
WM_XTP_COMMANDBARKEYDOWN
const UINT WM_XTP_COMMANDBARKEYDOWN
The WM_XTP_COMMANDBARKEYDOWN is sent to the CXTPCommandBars site when the user presses a key.
Definition XTPCommandBarsDefines.h:640
XTPKeyboardCuesUse
XTPKeyboardCuesUse
Enumerated type used to determine if menu underlines execute pop-ups.
Definition XTPCommandBarsDefines.h:353
xtpKeyboardCuesUseMenuOnly
@ xtpKeyboardCuesUseMenuOnly
Activate only menu by using underlines.
Definition XTPCommandBarsDefines.h:354
xtpKeyboardCuesUseAll
@ xtpKeyboardCuesUseAll
Activate menu and tool bars by using underlines.
Definition XTPCommandBarsDefines.h:355
xtpKeyboardCuesUseNone
@ xtpKeyboardCuesUseNone
No using underlines.
Definition XTPCommandBarsDefines.h:356
xtpKeyboardCuesUseAmpersandOnly
@ xtpKeyboardCuesUseAmpersandOnly
Activates menu items with ampersand only (by default first character used if no ampersand found).
Definition XTPCommandBarsDefines.h:357
XTPControlType
XTPControlType
Type of the control.
Definition XTPCommandBarsDefines.h:111
xtpControlSplitButtonPopup
@ xtpControlSplitButtonPopup
Split button pop-up.
Definition XTPCommandBarsDefines.h:116
xtpControlLabel
@ xtpControlLabel
Label control.
Definition XTPCommandBarsDefines.h:120
xtpControlCustom
@ xtpControlCustom
Custom control.
Definition XTPCommandBarsDefines.h:119
xtpControlCheckBox
@ xtpControlCheckBox
CheckBox control.
Definition XTPCommandBarsDefines.h:121
xtpControlComboBox
@ xtpControlComboBox
Combobox button.
Definition XTPCommandBarsDefines.h:117
xtpControlButton
@ xtpControlButton
Button type.
Definition XTPCommandBarsDefines.h:113
xtpControlEdit
@ xtpControlEdit
Edit control.
Definition XTPCommandBarsDefines.h:118
xtpControlPopup
@ xtpControlPopup
Pop-up type.
Definition XTPCommandBarsDefines.h:114
xtpControlError
@ xtpControlError
Type is not defined.
Definition XTPCommandBarsDefines.h:112
xtpControlButtonPopup
@ xtpControlButtonPopup
Button pop-up.
Definition XTPCommandBarsDefines.h:115
xtpControlGallery
@ xtpControlGallery
Gallery control.
Definition XTPCommandBarsDefines.h:122
xtpControlRadioButton
@ xtpControlRadioButton
Radio Button control.
Definition XTPCommandBarsDefines.h:123
IsPopupControlType
AFX_INLINE BOOL IsPopupControlType(XTPControlType controlType)
Call this member to determine if the specified control type is pop-up control, a button pop-up contro...
Definition XTPCommandBarsDefines.h:1360
WM_XTP_CONTROLRBUTTONUP
const UINT WM_XTP_CONTROLRBUTTONUP
The WM_XTP_CONTROLRBUTTONUP is sent to the CXTPCommandBars site when the menu user presses the right ...
Definition XTPCommandBarsDefines.h:611
WM_XTP_MESSAGEBARCLOSED
const UINT WM_XTP_MESSAGEBARCLOSED
The WM_XTP_MESSAGEBARCLOSED is sent to the CXTPCommandBars site when the user clicks the Close button...
Definition XTPCommandBarsDefines.h:1078
IsCaptionStyle
AFX_INLINE BOOL IsCaptionStyle(XTPButtonStyle buttonStyle)
Call this member to determine if the specified button style is button caption or button icon and capt...
Definition XTPCommandBarsDefines.h:1346
WM_XTP_AFTERCREATECONTROL
const UINT WM_XTP_AFTERCREATECONTROL
The WM_XTP_AFTERCREATECONTROL is sent to the CXTPCommandBars site after a new CXTPControl object is c...
Definition XTPCommandBarsDefines.h:944
XTPBarType
XTPBarType
Type of the command bar.
Definition XTPCommandBarsDefines.h:77
xtpBarTypeRibbon
@ xtpBarTypeRibbon
Command bar is a CXTPRibbonBar.
Definition XTPCommandBarsDefines.h:81
xtpBarTypePopup
@ xtpBarTypePopup
Command bar is a CXTPPopupBar.
Definition XTPCommandBarsDefines.h:80
xtpBarTypeNormal
@ xtpBarTypeNormal
Command bar is a CXTPToolBar.
Definition XTPCommandBarsDefines.h:79
xtpBarTypeMenuBar
@ xtpBarTypeMenuBar
Command bar is a CXTPMenuBar.
Definition XTPCommandBarsDefines.h:78
XTPIdleFlags
XTPIdleFlags
Flags for idle routine.
Definition XTPCommandBarsDefines.h:431
xtpIdleRedraw
@ xtpIdleRedraw
Delay redraw of command bar.
Definition XTPCommandBarsDefines.h:433
xtpIdleLayout
@ xtpIdleLayout
Delay recalculate layout of command bar.
Definition XTPCommandBarsDefines.h:432
WM_XTP_GETTABICON
const UINT WM_XTP_GETTABICON
The WM_XTP_GETTABICON message is sent to a MDI child window to retrieve the icon that will be used fo...
Definition XTPCommandBarsDefines.h:991
WM_XTP_SETBAKSTAGEBUTTONKEYTIP
const UINT WM_XTP_SETBAKSTAGEBUTTONKEYTIP
The WM_XTP_SETBAKSTAGEBUTTONKEYTIP is sent to the CXTPRibbonBackstageButton when the keyboard tip cha...
Definition XTPCommandBarsDefines.h:1086
XTPToolBarFlags
XTPToolBarFlags
Docking flags.
Definition XTPCommandBarsDefines.h:311
xtpFlagStretched
@ xtpFlagStretched
Bar is stretched.
Definition XTPCommandBarsDefines.h:320
xtpFlagAlignTop
@ xtpFlagAlignTop
Allows docking at the top of the client area.
Definition XTPCommandBarsDefines.h:312
xtpFlagFloating
@ xtpFlagFloating
Allows floating.
Definition XTPCommandBarsDefines.h:318
xtpFlagAlignAny
@ xtpFlagAlignAny
Allows docking on any side of the client area.
Definition XTPCommandBarsDefines.h:316
xtpFlagSmartLayout
@ xtpFlagSmartLayout
Smart layout enabled.
Definition XTPCommandBarsDefines.h:324
xtpFlagAlignRight
@ xtpFlagAlignRight
Allows docking on the right side of the client area.
Definition XTPCommandBarsDefines.h:315
xtpFlagAlignBottom
@ xtpFlagAlignBottom
Allows docking at the bottom of the client area.
Definition XTPCommandBarsDefines.h:313
xtpFlagStretchedShared
@ xtpFlagStretchedShared
Bar is stretched, but does not fill whole row.
Definition XTPCommandBarsDefines.h:323
xtpFlagNoBorders
@ xtpFlagNoBorders
Bar has no borders, this will cause CXTPPaintManager::IsFlatToolBar() to return TRUE.
Definition XTPCommandBarsDefines.h:321
xtpFlagAlignLeft
@ xtpFlagAlignLeft
Allows docking on the left side of the client area.
Definition XTPCommandBarsDefines.h:314
xtpFlagHideWrap
@ xtpFlagHideWrap
Allow to hide wrapped controls.
Definition XTPCommandBarsDefines.h:319
XTPButtonStyle
XTPButtonStyle
Button's styles.
Definition XTPCommandBarsDefines.h:197
xtpButtonIconAndCaptionBelow
@ xtpButtonIconAndCaptionBelow
Button draw icon and draw caption below icon.
Definition XTPCommandBarsDefines.h:203
xtpButtonIcon
@ xtpButtonIcon
Button draw only icon.
Definition XTPCommandBarsDefines.h:201
xtpButtonUndefined
@ xtpButtonUndefined
Automatic style.
Definition XTPCommandBarsDefines.h:198
xtpButtonIconAndCaption
@ xtpButtonIconAndCaption
Button draw icon and caption.
Definition XTPCommandBarsDefines.h:202
xtpButtonCaptionAndDescription
@ xtpButtonCaptionAndDescription
Button draw icon, caption and description for pop-up bar.
Definition XTPCommandBarsDefines.h:205
xtpButtonAutomatic
@ xtpButtonAutomatic
Automatic style.
Definition XTPCommandBarsDefines.h:199
xtpButtonCaption
@ xtpButtonCaption
Button draw only caption.
Definition XTPCommandBarsDefines.h:200
XTPPopupDirection
XTPPopupDirection
Docking direction enumerator.
Definition XTPCommandBarsDefines.h:389
xtpPopupRight
@ xtpPopupRight
Pop-up Bar will be opened right of control.
Definition XTPCommandBarsDefines.h:390
xtpPopupLeft
@ xtpPopupLeft
Pop-up Bar will be opened left of control.
Definition XTPCommandBarsDefines.h:391
xtpPopupDown
@ xtpPopupDown
Pop-up Bar will be opened bottom of control.
Definition XTPCommandBarsDefines.h:392
xtpPopupUp
@ xtpPopupUp
Pop-up Bar will be opened top of control.
Definition XTPCommandBarsDefines.h:393
XTPSpecialKey
XTPSpecialKey
Special keys enumerator.
Definition XTPCommandBarsDefines.h:407
xtpKeyLeft
@ xtpKeyLeft
Select left.
Definition XTPCommandBarsDefines.h:416
xtpKeyEnd
@ xtpKeyEnd
Select last key.
Definition XTPCommandBarsDefines.h:415
xtpKeyPopup
@ xtpKeyPopup
Open selected pop-up key.
Definition XTPCommandBarsDefines.h:411
xtpKeyReturn
@ xtpKeyReturn
Return key.
Definition XTPCommandBarsDefines.h:413
xtpKeyHome
@ xtpKeyHome
Select first key.
Definition XTPCommandBarsDefines.h:414
xtpKeyBack
@ xtpKeyBack
Close active pop-up key.
Definition XTPCommandBarsDefines.h:410
xtpKeyNext
@ xtpKeyNext
Select next key.
Definition XTPCommandBarsDefines.h:408
xtpKeySpace
@ xtpKeySpace
Space.
Definition XTPCommandBarsDefines.h:418
xtpKeyRight
@ xtpKeyRight
Select right.
Definition XTPCommandBarsDefines.h:417
xtpKeyEscape
@ xtpKeyEscape
Escape key.
Definition XTPCommandBarsDefines.h:412
xtpKeyPrev
@ xtpKeyPrev
Select previous key.
Definition XTPCommandBarsDefines.h:409
XTPBarTextOrientation
XTPBarTextOrientation
Command bar text orientation flags.
Definition XTPCommandBarsDefines.h:91
xtpBarTextAuto
@ xtpBarTextAuto
Lets the Commandbars decide the best orientation.
Definition XTPCommandBarsDefines.h:92
xtpBarTextVertical
@ xtpBarTextVertical
Display text in the bar vertically, regardless of bar location.
Definition XTPCommandBarsDefines.h:94
xtpBarTextHorizontal
@ xtpBarTextHorizontal
Display text in the bar horizontally, regardless of bar location.
Definition XTPCommandBarsDefines.h:95
XTPBarPosition
XTPBarPosition
Position of the command bar.
Definition XTPCommandBarsDefines.h:52
xtpBarPopup
@ xtpBarPopup
Pop-up.
Definition XTPCommandBarsDefines.h:58
xtpBarBottom
@ xtpBarBottom
Docked at bottom.
Definition XTPCommandBarsDefines.h:54
xtpBarLeft
@ xtpBarLeft
Docked at left.
Definition XTPCommandBarsDefines.h:55
xtpBarNone
@ xtpBarNone
None.
Definition XTPCommandBarsDefines.h:60
xtpBarFloating
@ xtpBarFloating
Floated.
Definition XTPCommandBarsDefines.h:57
xtpBarTop
@ xtpBarTop
Docked at top.
Definition XTPCommandBarsDefines.h:53
xtpBarRight
@ xtpBarRight
Docked at right.
Definition XTPCommandBarsDefines.h:56
xtpBarListBox
@ xtpBarListBox
List box.
Definition XTPCommandBarsDefines.h:59
XTPKeyboardCuesShow
XTPKeyboardCuesShow
Enumerated type used to determine menu underlines.
Definition XTPCommandBarsDefines.h:337
xtpKeyboardCuesShowNever
@ xtpKeyboardCuesShowNever
Never show keyboard cues.
Definition XTPCommandBarsDefines.h:339
xtpKeyboardCuesShowAlways
@ xtpKeyboardCuesShowAlways
Show keyboard cues always.
Definition XTPCommandBarsDefines.h:338
xtpKeyboardCuesShowWindowsDefault
@ xtpKeyboardCuesShowWindowsDefault
System defined.
Definition XTPCommandBarsDefines.h:340
XTPControlHideFlags
XTPControlHideFlags
Control's hide flags, these are flags that specify why a control is hidden.
Definition XTPCommandBarsDefines.h:162
xtpHideWrap
@ xtpHideWrap
Control is hidden by wrap.
Definition XTPCommandBarsDefines.h:165
xtpNoHide
@ xtpNoHide
Control is visible.
Definition XTPCommandBarsDefines.h:163
xtpHideCustomize
@ xtpHideCustomize
Control is hidden by customize settings.
Definition XTPCommandBarsDefines.h:173
xtpHideGeneric
@ xtpHideGeneric
Control is hidden by generic reason.
Definition XTPCommandBarsDefines.h:164
xtpHideScroll
@ xtpHideScroll
Control is hidden by scrolling.
Definition XTPCommandBarsDefines.h:171
xtpHideDocTemplate
@ xtpHideDocTemplate
Control is hidden because active template excluded from its list.
Definition XTPCommandBarsDefines.h:179
xtpHideDockingPosition
@ xtpHideDockingPosition
Control is hidden by docking position.
Definition XTPCommandBarsDefines.h:167
xtpHideRibbonTab
@ xtpHideRibbonTab
Control is hidden because inactive ribbon tab.
Definition XTPCommandBarsDefines.h:181
xtpHideExpand
@ xtpHideExpand
If the control is rarely used and it is not visible because the intelligent menus option on and the c...
Definition XTPCommandBarsDefines.h:177
WM_XTP_INITCOMMANDSPOPUP
const UINT WM_XTP_INITCOMMANDSPOPUP
The WM_XTP_INITCOMMANDSPOPUP is sent to the CXTPCommandBars site when a pop-up menu is about to becom...
Definition XTPCommandBarsDefines.h:667
WM_XTP_BEFORECREATECONTROL
const UINT WM_XTP_BEFORECREATECONTROL
The WM_XTP_BEFORECREATECONTROL is sent to the CXTPCommandBars site when a new CXTPControl object is c...
Definition XTPCommandBarsDefines.h:893
IsVerticalPosition
AFX_INLINE BOOL IsVerticalPosition(XTPBarPosition barPosition)
Call this member to determine if the specified bar position is left, right, or is a pop-up toolbar.
Definition XTPCommandBarsDefines.h:1375
WM_XTP_UNINITCOMMANDSPOPUP
const UINT WM_XTP_UNINITCOMMANDSPOPUP
The WM_XTP_UNINITCOMMANDSPOPUP is sent to the CXTPCommandBars site when a pop-up menu has been closed...
Definition XTPCommandBarsDefines.h:742
WM_XTP_SETBAKSTAGEBUTTONKEYTIPDRAWFLAG
const UINT WM_XTP_SETBAKSTAGEBUTTONKEYTIPDRAWFLAG
The WM_XTP_SETBAKSTAGEBUTTONKEYTIPDRAWFLAG is sent to the CXTPRibbonBackstageButton to show/hide the ...
Definition XTPCommandBarsDefines.h:1094
XTPAnimationType
XTPAnimationType
Enumerated type used to determine the animation effect of pop-up bars.
Definition XTPCommandBarsDefines.h:373
xtpAnimateSlide
@ xtpAnimateSlide
Slide in from left.
Definition XTPCommandBarsDefines.h:377
xtpAnimateUnfold
@ xtpAnimateUnfold
Unfold top to bottom.
Definition XTPCommandBarsDefines.h:376
xtpAnimateFade
@ xtpAnimateFade
Fade-in.
Definition XTPCommandBarsDefines.h:378
xtpAnimateNone
@ xtpAnimateNone
No animation.
Definition XTPCommandBarsDefines.h:379
xtpAnimateWindowsDefault
@ xtpAnimateWindowsDefault
As defined in the "Display" settings.
Definition XTPCommandBarsDefines.h:374
xtpAnimateRandom
@ xtpAnimateRandom
Any of the first three in random selection.
Definition XTPCommandBarsDefines.h:375
XTPPaintTheme
XTPPaintTheme
Paint themes used by command bars.
Definition XTPCommandBarsDefines.h:233
xtpThemeVisualStudio2022
@ xtpThemeVisualStudio2022
Visual Studio 2022 theme, uses INI file.
Definition XTPCommandBarsDefines.h:256
xtpThemeVisualStudio2015
@ xtpThemeVisualStudio2015
Visual Studio 2015 theme, uses INI file.
Definition XTPCommandBarsDefines.h:252
xtpThemeOffice2013
@ xtpThemeOffice2013
Office 2013 theme.
Definition XTPCommandBarsDefines.h:247
xtpThemeCustom
@ xtpThemeCustom
Custom theme.
Definition XTPCommandBarsDefines.h:245
xtpThemeVisualStudio2005
@ xtpThemeVisualStudio2005
Visual Studio 2005 theme.
Definition XTPCommandBarsDefines.h:239
xtpThemeNativeWinXP
@ xtpThemeNativeWinXP
Windows XP and later native theme support.
Definition XTPCommandBarsDefines.h:238
xtpThemeVisualStudio2008
@ xtpThemeVisualStudio2008
Visual Studio 2008 theme.
Definition XTPCommandBarsDefines.h:242
xtpThemeOffice2007System
@ xtpThemeOffice2007System
Office 2007 theme with system colors.
Definition XTPCommandBarsDefines.h:246
xtpThemeNativeWindows10
@ xtpThemeNativeWindows10
Windows 10.
Definition XTPCommandBarsDefines.h:253
xtpThemeVisualStudio2010
@ xtpThemeVisualStudio2010
Visual Studio 2010 theme.
Definition XTPCommandBarsDefines.h:244
xtpThemeVisualStudio2017
@ xtpThemeVisualStudio2017
Visual Studio 2017 theme, uses INI file.
Definition XTPCommandBarsDefines.h:254
xtpThemeVisualStudio2012
@ xtpThemeVisualStudio2012
Visual Studio 2012 theme, uses INI file.
Definition XTPCommandBarsDefines.h:249
xtpThemeOffice2003
@ xtpThemeOffice2003
Office 2003 theme.
Definition XTPCommandBarsDefines.h:237
xtpThemeNone
@ xtpThemeNone
No theme selected.
Definition XTPCommandBarsDefines.h:234
xtpThemeNativeWindows11
@ xtpThemeNativeWindows11
Windows 11.
Definition XTPCommandBarsDefines.h:257
xtpThemeOffice2000
@ xtpThemeOffice2000
Office 2000 theme.
Definition XTPCommandBarsDefines.h:235
xtpThemeOfficeXP
@ xtpThemeOfficeXP
Office XP theme.
Definition XTPCommandBarsDefines.h:236
xtpThemeVisualStudio2019
@ xtpThemeVisualStudio2019
Visual Studio 2019 theme, uses INI file.
Definition XTPCommandBarsDefines.h:255
xtpThemeVisualStudio6
@ xtpThemeVisualStudio6
Visual Studio 6 theme.
Definition XTPCommandBarsDefines.h:243
xtpThemeVisualStudio2012Dark
@ xtpThemeVisualStudio2012Dark
Visual Studio 2012 dark theme.
Definition XTPCommandBarsDefines.h:251
xtpThemeRibbon
@ xtpThemeRibbon
Office 2007 style ribbon theme.
Definition XTPCommandBarsDefines.h:241
xtpThemeVisualStudio2012Light
@ xtpThemeVisualStudio2012Light
Visual Studio 2012 light theme.
Definition XTPCommandBarsDefines.h:250
xtpThemeResource
@ xtpThemeResource
Office 2007 theme.
Definition XTPCommandBarsDefines.h:240
xtpThemeOffice2016
@ xtpThemeOffice2016
Office 2016 theme.
Definition XTPCommandBarsDefines.h:248
IsDockingPosition
AFX_INLINE BOOL IsDockingPosition(XTPBarPosition barPosition)
Call this member to determine if the specified bar position is left, top, right, or bottom.
Definition XTPCommandBarsDefines.h:1331
WM_XTP_TOOLBARVISIBLECHANGED
const UINT WM_XTP_TOOLBARVISIBLECHANGED
The WM_XTP_TOOLBARVISIBLECHANGED is sent to the CXTPCommandBars site when the user shows/hides a tool...
Definition XTPCommandBarsDefines.h:471
WM_XTP_DRAGCONTROLCHANGED
const UINT WM_XTP_DRAGCONTROLCHANGED
The WM_XTP_DRAGCONTROLCHANGED is sent to the CXTPCommandBars site when the user select a button of a ...
Definition XTPCommandBarsDefines.h:528
WM_XTP_CREATECOMMANDBAR
const UINT WM_XTP_CREATECOMMANDBAR
The WM_XTP_CREATECOMMANDBAR is sent to the CXTPCommandBars site when a new CXTPCommandBars object is ...
Definition XTPCommandBarsDefines.h:1049
WM_XTP_COMMANDBARS_BASE
const UINT WM_XTP_COMMANDBARS_BASE
Base message for CommandBars.
Definition XTPCommandBarsDefines.h:442
WM_XTP_CONTROLSELECTED
const UINT WM_XTP_CONTROLSELECTED
The WM_XTP_CONTROLSELECTED is sent to the CXTPCommandBars site when the user selects a CXTPCommandBar...
Definition XTPCommandBarsDefines.h:503
WM_XTP_INITMENU
const UINT WM_XTP_INITMENU
The WM_XTP_INITMENU is sent to the CXTPCommandBars site when the menu is about to become active.
Definition XTPCommandBarsDefines.h:560
XTPMenuBarFlags
XTPMenuBarFlags
Menubar system button flags.
Definition XTPCommandBarsDefines.h:280
xtpFlagIgnoreSetMenuMessage
@ xtpFlagIgnoreSetMenuMessage
To ignore MDI menus.
Definition XTPCommandBarsDefines.h:283
xtpFlagHideMinimizeBox
@ xtpFlagHideMinimizeBox
To hide minimize box.
Definition XTPCommandBarsDefines.h:281
xtpFlagHideMaximizeBox
@ xtpFlagHideMaximizeBox
To hide maximize box.
Definition XTPCommandBarsDefines.h:282
xtpFlagHideClose
@ xtpFlagHideClose
To hide close button.
Definition XTPCommandBarsDefines.h:285
xtpFlagAddMDISysPopup
@ xtpFlagAddMDISysPopup
To add system MDI pop-up bar.
Definition XTPCommandBarsDefines.h:289
xtpFlagUseMDIMenus
@ xtpFlagUseMDIMenus
To use MDI menus.
Definition XTPCommandBarsDefines.h:284
xtpFlagHideMDIButtons
@ xtpFlagHideMDIButtons
Specifies to hide all MDI buttons displayed on the Command Bar.
Definition XTPCommandBarsDefines.h:286
XTPControlFlags
XTPControlFlags
Flags of the control.
Definition XTPCommandBarsDefines.h:138
xtpFlagWrapRow
@ xtpFlagWrapRow
Wrap row for toolbar or pop-up bar.
Definition XTPCommandBarsDefines.h:146
xtpFlagControlStretched
@ xtpFlagControlStretched
Control is stretched in parent command bar.
Definition XTPCommandBarsDefines.h:144
xtpFlagRibbonTabBackground
@ xtpFlagRibbonTabBackground
Control is on the right side of Ribbon tabs.
Definition XTPCommandBarsDefines.h:147
xtpFlagNoMovable
@ xtpFlagNoMovable
To disable customization.
Definition XTPCommandBarsDefines.h:143
xtpFlagLeftPopup
@ xtpFlagLeftPopup
To Pop up child bar left.
Definition XTPCommandBarsDefines.h:141
xtpFlagShowPopupBarTip
@ xtpFlagShowPopupBarTip
Show tooltip always
Definition XTPCommandBarsDefines.h:145
xtpFlagManualUpdate
@ xtpFlagManualUpdate
Control is manually updated.
Definition XTPCommandBarsDefines.h:142
xtpFlagRightAlign
@ xtpFlagRightAlign
Control is right aligned.
Definition XTPCommandBarsDefines.h:139
xtpFlagSkipFocus
@ xtpFlagSkipFocus
Control does not have focus.
Definition XTPCommandBarsDefines.h:140
IsAnimateType
AFX_INLINE BOOL IsAnimateType(XTPAnimationType animationType)
Call this member to determine if the menu animation type is set to fade, slide, or unfold.
Definition XTPCommandBarsDefines.h:1388
CBN_XTP_EXECUTE
const UINT CBN_XTP_EXECUTE
The CBN_XTP_EXECUTE is sent to the CXTPCommandBars site when the user clicks an item of a CXTPCommand...
Definition XTPCommandBarsDefines.h:817
WM_XTP_TOOLBARCONTEXTMENU
const UINT WM_XTP_TOOLBARCONTEXTMENU
The WM_XTP_TOOLBARCONTEXTMENU is sent to the CXTPCommandBars site when context menu is about to becom...
Definition XTPCommandBarsDefines.h:699
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCommandBar
CXTPCommandBar is a CWnd derived class.
Definition XTPCommandBar.h:66
CXTPControl
CXTPControl is a CXTPCmdTarget derived class.
Definition XTPControl.h:841
CXTPPopupBar
CXTPPopupBar is a CXTPCommandBar derived class.
Definition XTPPopupBar.h:42
NMXTPCONTROL
This structure is passed as a parameter in CBN_XTP_EXECUTE message.
Definition XTPCommandBarsDefines.h:769
NMXTPCONTROL::hdr
NMHDR hdr
NMHDR structure that contains additional information about this notification.
Definition XTPCommandBarsDefines.h:770
NMXTPCONTROL::pControl
CXTPControl * pControl
Pointer to the control that caused the event.
Definition XTPCommandBarsDefines.h:771
XTP_COMMANDBARS_CREATEBAR
Creates a bar structure.
Definition XTPCommandBarsDefines.h:1004
XTP_COMMANDBARS_CREATEBAR::lpcstrCaption
LPCTSTR lpcstrCaption
Caption of the command bar.
Definition XTPCommandBarsDefines.h:1010
XTP_COMMANDBARS_CREATEBAR::bExpandBar
BOOL bExpandBar
TRUE if it is an expanded pop-up.
Definition XTPCommandBarsDefines.h:1007
XTP_COMMANDBARS_CREATEBAR::nID
UINT nID
Identifier of the command bar.
Definition XTPCommandBarsDefines.h:1011
XTP_COMMANDBARS_CREATEBAR::bTearOffBar
BOOL bTearOffBar
TRUE if it is a user tear-off pop-up.
Definition XTPCommandBarsDefines.h:1009
XTP_COMMANDBARS_CREATEBAR::bCustomBar
BOOL bCustomBar
TRUE if it is a user-defined toolbar.
Definition XTPCommandBarsDefines.h:1008
XTP_COMMANDBARS_CREATEBAR::bPopup
BOOL bPopup
TRUE if it is a pop-up command bar.
Definition XTPCommandBarsDefines.h:1006
XTP_COMMANDBARS_CREATEBAR::pCommandBar
CXTPCommandBar * pCommandBar
Created command bar.
Definition XTPCommandBarsDefines.h:1005
XTP_COMMANDBARS_CREATECONTROL
Creates a control structure.
Definition XTPCommandBarsDefines.h:849
XTP_COMMANDBARS_CREATECONTROL::controlType
XTPControlType controlType
Type of the control.
Definition XTPCommandBarsDefines.h:857
XTP_COMMANDBARS_CREATECONTROL::nIndex
int nIndex
Index of the control to be created.
Definition XTPCommandBarsDefines.h:853
XTP_COMMANDBARS_CREATECONTROL::pMenu
CMenu * pMenu
A Pointer to CMenu object.
Definition XTPCommandBarsDefines.h:854
XTP_COMMANDBARS_CREATECONTROL::nID
UINT nID
Identifier of the control to be created.
Definition XTPCommandBarsDefines.h:850
XTP_COMMANDBARS_CREATECONTROL::bToolBar
BOOL bToolBar
TRUE if control is toolbar located.
Definition XTPCommandBarsDefines.h:852
XTP_COMMANDBARS_CREATECONTROL::strCaption
CString strCaption
Caption of the control to be created.
Definition XTPCommandBarsDefines.h:856
XTP_COMMANDBARS_CREATECONTROL::pCommandBar
CXTPCommandBar * pCommandBar
Pointer to the parent command bar class.
Definition XTPCommandBarsDefines.h:855
XTP_COMMANDBARS_CREATECONTROL::buttonStyle
XTPButtonStyle buttonStyle
Button Style of the control.
Definition XTPCommandBarsDefines.h:858
XTP_COMMANDBARS_CREATECONTROL::pControl
CXTPControl * pControl
Control to be created.
Definition XTPCommandBarsDefines.h:851


Toolkit Pro: XTPGridBehavior.h Source File

  • Source
  • GridControl
  • Behavior
XTPGridBehavior.h
Go to the documentation of this file.
1
23#if !defined(__XTPGRIDBEHAVIOR_H__)
24# define __XTPGRIDBEHAVIOR_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
36enum XTPGridMouseButton
37{
38 xtpGridMouseButtonNone,
39 xtpGridMouseButtonLeft,
40 xtpGridMouseButtonMiddle,
41 xtpGridMouseButtonRight
42};
47enum XTPGridMouseEvent
48{
49 xtpGridMouseEventButtonDown,
50 xtpGridMouseEventButtonUp
51};
56enum XTPGridBehavior
57{
58 xtpGridBehaviorOutlook2003 = 0x00001100,
61 xtpGridBehaviorOutlook2007 = 0x00001200,
64 xtpGridBehaviorOutlook2010 = 0x00001400,
68 xtpGridBehaviorExcel2003 = 0x10001100,
70 xtpGridBehaviorExcel2007 = 0x10001200,
72 xtpGridBehaviorExcel2010 = 0x10001400,
75 xtpGridBehaviorCodejock1340 = 0x20001340,
77 xtpGridBehaviorCodejock1341 = 0x20001341,
79 xtpGridBehaviorCodejock1342 = 0x20001342,
81 xtpGridBehaviorCodejock1501 = 0x20001501,
83 xtpGridBehaviorCodejock1502 = 0x20001502,
85 xtpGridBehaviorCodejockDefault = 0x20000000
86};
87
89// Key events
91
92class _XTP_EXT_CLASS CXTPGridBehaviorRowKeyDown
93{
94};
95
96class _XTP_EXT_CLASS CXTPGridBehaviorRowKeyUp
97{
98};
99
101// Mouse events
103
104class _XTP_EXT_CLASS CXTPGridBehaviorRowModifier : public CXTPCmdTarget
105{
106public:
107 CXTPGridBehaviorRowModifier();
108 void Reset();
109
110 BOOL bFocusRow;
111 BOOL bFocusRowTemporarily;
113 BOOL bSelectRow;
114 BOOL bSelectRowTemporarily;
115 BOOL bMultipleSelection;
117 BOOL bKeepSelection;
118 BOOL bKeepFocus;
120 BOOL bFocusCancelsSelect;
122protected:
123# ifdef _XTP_ACTIVEX
125 DECLARE_OLETYPELIB_EX(CXTPGridBehaviorRowModifier);
126 DECLARE_DISPATCH_MAP()
127 DECLARE_INTERFACE_MAP()
128
129 XTP_DECLARE_PROPERTY(FocusRow, BOOL);
130 XTP_DECLARE_PROPERTY(FocusRowTemporarily, BOOL);
131 XTP_DECLARE_PROPERTY(SelectRow, BOOL);
132 XTP_DECLARE_PROPERTY(SelectRowTemporarily, BOOL);
133 XTP_DECLARE_PROPERTY(MultipleSelection, BOOL);
134 XTP_DECLARE_PROPERTY(KeepSelection, BOOL);
135 XTP_DECLARE_PROPERTY(KeepFocus, BOOL);
137# endif // _XTP_ACTIVEX
138};
139
140class _XTP_EXT_CLASS CXTPGridBehaviorRowMouseButton : public CXTPCmdTarget
141{
142public:
143 CXTPGridBehaviorRowMouseButton(XTPGridMouseButton button, XTPGridMouseEvent event);
144 virtual ~CXTPGridBehaviorRowMouseButton();
145
146 void Reset();
147
148public:
149 CXTPGridBehaviorRowModifier* None;
150 CXTPGridBehaviorRowModifier* Control;
151 CXTPGridBehaviorRowModifier* Shift;
152
153 BOOL bFocusColumn;
154 BOOL bEnsureVisible;
156 BOOL bClick;
157 BOOL bContextMenu;
158 BOOL bCheckSelectedRows;
160 BOOL bDragBegin;
161 BOOL bDragEnd;
162 BOOL bDragSelectGroup;
164public:
165 const XTPGridMouseButton m_button;
166 const XTPGridMouseEvent m_event;
167
168protected:
169# ifdef _XTP_ACTIVEX
171 DECLARE_DISPATCH_MAP()
172 DECLARE_INTERFACE_MAP()
173 DECLARE_OLETYPELIB_EX(CXTPGridBehaviorRowMouseButton);
174
175 afx_msg LPDISPATCH OleGetNone();
176 afx_msg LPDISPATCH OleGetControl();
177 afx_msg LPDISPATCH OleGetShift();
178
179 XTP_DECLARE_PROPERTY(FocusColumn, BOOL);
180 XTP_DECLARE_PROPERTY(EnsureVisible, BOOL);
181
182 XTP_DECLARE_PROPERTY(Click, BOOL);
183 XTP_DECLARE_PROPERTY(ContextMenu, BOOL);
184 XTP_DECLARE_PROPERTY(CheckSelectedRows, BOOL);
185
186 XTP_DECLARE_PROPERTY(DragBegin, BOOL);
187 XTP_DECLARE_PROPERTY(DragEnd, BOOL);
188 XTP_DECLARE_PROPERTY(DragSelectGroup, BOOL);
190# endif // _XTP_ACTIVEX
191};
192
193class _XTP_EXT_CLASS CXTPGridBehaviorRowMouse : public CXTPCmdTarget
194{
195public:
196 CXTPGridBehaviorRowMouse(XTPGridMouseEvent event);
197 virtual ~CXTPGridBehaviorRowMouse();
198
199 CXTPGridBehaviorRowMouseButton* Left;
200 CXTPGridBehaviorRowMouseButton* Right;
201
202protected:
203# ifdef _XTP_ACTIVEX
205 DECLARE_DISPATCH_MAP()
206 DECLARE_INTERFACE_MAP()
207 DECLARE_OLETYPELIB_EX(CXTPGridBehaviorRowMouse);
208
209 afx_msg LPDISPATCH OleGetLeft();
210 afx_msg LPDISPATCH OleGetRight();
212# endif // _XTP_ACTIVEX
213};
214
215class _XTP_EXT_CLASS CXTPGridBehaviorRow : public CXTPCmdTarget
216{
217public:
218 CXTPGridBehaviorRow();
219 virtual ~CXTPGridBehaviorRow();
220
221public:
222 CXTPGridBehaviorRowMouse* MouseDown;
223 CXTPGridBehaviorRowMouse* MouseUp;
224
225# ifdef _XTP_ACTIVEX
226protected:
228 DECLARE_DISPATCH_MAP()
229 DECLARE_INTERFACE_MAP()
230 DECLARE_OLETYPELIB_EX(CXTPGridBehaviorRow);
231
232 afx_msg LPDISPATCH OleGetMouseDown();
233 afx_msg LPDISPATCH OleGetMouseUp();
235# endif // _XTP_ACTIVEX
236};
237
240//
241
242class _XTP_EXT_CLASS CXTPGridNotificationsPopulate : public CXTPCmdTarget
243{
244public:
245 CXTPGridNotificationsPopulate();
246 virtual ~CXTPGridNotificationsPopulate();
247
248public:
249 BOOL bFocusChanging;
250 BOOL bSelectionChanging;
251 BOOL bSelectionChanged;
252
253# ifdef _XTP_ACTIVEX
254protected:
256 DECLARE_DISPATCH_MAP()
257 DECLARE_INTERFACE_MAP()
258 DECLARE_OLETYPELIB_EX(CXTPGridNotificationsPopulate);
259
260 XTP_DECLARE_PROPERTY(FocusChangingNotification, BOOL);
261 XTP_DECLARE_PROPERTY(SelectionChangingNotification, BOOL);
262 XTP_DECLARE_PROPERTY(SelectionChangedNotification, BOOL);
264# endif // _XTP_ACTIVEX
265};
266
267class _XTP_EXT_CLASS CXTPGridNotificationsSelectedRows : public CXTPCmdTarget
268{
269public:
270 CXTPGridNotificationsSelectedRows();
271 virtual ~CXTPGridNotificationsSelectedRows();
272
273public:
274 BOOL bClear;
275 BOOL bAdd;
276 BOOL bRemove;
277
278# ifdef _XTP_ACTIVEX
279protected:
281 DECLARE_DISPATCH_MAP()
282 DECLARE_INTERFACE_MAP()
283 DECLARE_OLETYPELIB_EX(CXTPGridNotificationsSelectedRows);
284
285 XTP_DECLARE_PROPERTY(ClearNotification, BOOL);
286 XTP_DECLARE_PROPERTY(AddNotification, BOOL);
287 XTP_DECLARE_PROPERTY(RemoveNotification, BOOL);
289# endif // _XTP_ACTIVEX
290};
291
292class _XTP_EXT_CLASS CXTPGridNotificationsRow : public CXTPCmdTarget
293{
294public:
295 CXTPGridNotificationsRow();
296 virtual ~CXTPGridNotificationsRow();
297
298public:
299 BOOL bRowExpanded;
300
301# ifdef _XTP_ACTIVEX
302protected:
304 DECLARE_DISPATCH_MAP()
305 DECLARE_INTERFACE_MAP()
306 DECLARE_OLETYPELIB_EX(CXTPGridNotificationsRow);
307
308 XTP_DECLARE_PROPERTY(RowExpandedNotification, BOOL);
310# endif // _XTP_ACTIVEX
311};
312
313class _XTP_EXT_CLASS CXTPGridNotifications : public CXTPCmdTarget
314{
315public:
316 CXTPGridNotifications();
317 virtual ~CXTPGridNotifications();
318
319public:
320 CXTPGridNotificationsPopulate* Populate;
321 CXTPGridNotificationsSelectedRows* SelectedRows;
322 CXTPGridNotificationsRow* Row;
323
324# ifdef _XTP_ACTIVEX
325protected:
327 DECLARE_DISPATCH_MAP()
328 DECLARE_INTERFACE_MAP()
329 DECLARE_OLETYPELIB_EX(CXTPGridNotifications);
330
331 afx_msg LPDISPATCH OleGetPopulate();
332 afx_msg LPDISPATCH OleGetSelectedRows();
333 afx_msg LPDISPATCH OleGetRow();
335# endif // _XTP_ACTIVEX
336};
337
338class _XTP_EXT_CLASS CXTPGridBehavior : public CXTPCmdTarget
339{
340public:
341 CXTPGridBehavior(XTPGridBehavior behavior);
342 virtual ~CXTPGridBehavior();
343
344 void SetScheme(XTPGridBehavior behavior);
345
346public:
347 CXTPGridBehaviorRow* Row;
348 CXTPGridBehaviorRow* GroupRow;
349
350 CXTPGridNotifications* Notifications;
351
352private:
353 void SetSchemeOutlook();
354 void SetSchemeExcel();
355 void SetSchemeCodejock134x();
356 void SetSchemeCodejock1501();
357 void SetSchemeCodejock1502();
358 void SetSchemeCodejockDefault();
359
360 XTPGridBehavior m_scheme;
362# ifdef _XTP_ACTIVEX
363protected:
365 DECLARE_DISPATCH_MAP()
366 DECLARE_INTERFACE_MAP()
367 DECLARE_OLETYPELIB_EX(CXTPGridBehavior);
368
369 XTP_DECLARE_PROPERTY(Scheme, XTPGridBehavior);
370
371 afx_msg LPDISPATCH OleGetRow();
372 afx_msg LPDISPATCH OleGetGroupRow();
373 afx_msg LPDISPATCH OleGetNotifications();
375# endif // _XTP_ACTIVEX
376};
377
380# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
381#endif //#if !defined(__XTPGRIDBEHAVIOR_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPGridBehavior
XTPGridBehavior
Defines grid behavior.
Definition XTPGridBehavior.h:57
xtpGridBehaviorCodejockDefault
@ xtpGridBehaviorCodejockDefault
The latest default behavior.
Definition XTPGridBehavior.h:85
xtpGridBehaviorOutlook2010
@ xtpGridBehaviorOutlook2010
Specifies behavior similar to Outlook 2010 that was the default behavior of the control's version 14....
Definition XTPGridBehavior.h:64
xtpGridBehaviorExcel2003
@ xtpGridBehaviorExcel2003
Specifies behavior similar to Excel 2003 that was the default behavior of the control's version 11....
Definition XTPGridBehavior.h:68
xtpGridBehaviorOutlook2007
@ xtpGridBehaviorOutlook2007
Specifies behavior similar to Outlook 2007 that was the default behavior of the control's version 12....
Definition XTPGridBehavior.h:61
xtpGridBehaviorCodejock1340
@ xtpGridBehaviorCodejock1340
The default behavior of the control's version 13.4.0.
Definition XTPGridBehavior.h:75
xtpGridBehaviorExcel2010
@ xtpGridBehaviorExcel2010
Specifies behavior similar to Excel 2010 that was the default behavior of the control's version 14....
Definition XTPGridBehavior.h:72
xtpGridBehaviorCodejock1502
@ xtpGridBehaviorCodejock1502
The default behavior of the control's version 15.0.2.
Definition XTPGridBehavior.h:83
xtpGridBehaviorOutlook2003
@ xtpGridBehaviorOutlook2003
Specifies behavior similar to Outlook 2003 that was the default behavior of the control's version 11....
Definition XTPGridBehavior.h:58
xtpGridBehaviorCodejock1341
@ xtpGridBehaviorCodejock1341
The default behavior of the control's version 13.4.1.
Definition XTPGridBehavior.h:77
xtpGridBehaviorCodejock1342
@ xtpGridBehaviorCodejock1342
The default behavior of the control's version 13.4.2.
Definition XTPGridBehavior.h:79
xtpGridBehaviorCodejock1501
@ xtpGridBehaviorCodejock1501
The default behavior of the control's version 15.0.1.
Definition XTPGridBehavior.h:81
xtpGridBehaviorExcel2007
@ xtpGridBehaviorExcel2007
Specifies behavior similar to Excel 2007 that was the default behavior of the control's version 12....
Definition XTPGridBehavior.h:70
XTPGridMouseEvent
XTPGridMouseEvent
Defines a mouse event.
Definition XTPGridBehavior.h:48
xtpGridMouseEventButtonDown
@ xtpGridMouseEventButtonDown
Specifies a mouse button down mouse event.
Definition XTPGridBehavior.h:49
xtpGridMouseEventButtonUp
@ xtpGridMouseEventButtonUp
Specifies a mouse button up event.
Definition XTPGridBehavior.h:50
XTPGridMouseButton
XTPGridMouseButton
Defines a mouse button.
Definition XTPGridBehavior.h:37
xtpGridMouseButtonMiddle
@ xtpGridMouseButtonMiddle
Specifies a middle mouse button.
Definition XTPGridBehavior.h:40
xtpGridMouseButtonLeft
@ xtpGridMouseButtonLeft
Specifies a left mouse button.
Definition XTPGridBehavior.h:39
xtpGridMouseButtonRight
@ xtpGridMouseButtonRight
Specifies a right mouse button.
Definition XTPGridBehavior.h:41
xtpGridMouseButtonNone
@ xtpGridMouseButtonNone
No mouse button.
Definition XTPGridBehavior.h:38
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122


Toolkit Pro: Member List

CXTPPopupThemeMSN Member List

This is the complete list of members for CXTPPopupThemeMSN, including all inherited members.

CXTPPopupPaintManager() | CXTPPopupPaintManager |
CXTPPopupThemeMSN() | CXTPPopupThemeMSN |
CXTPPopupThemeOffice2000() | CXTPPopupThemeOffice2000 |
DrawBackground(CDC *pDC, CXTPPopupControl *pControl, CRect rcClient) | CXTPPopupThemeMSN | virtual
DrawButton(CDC *pDC, CXTPPopupItem *pItem) | CXTPPopupPaintManager | virtual
DrawItem(CDC *pDC, CXTPPopupItem *pItem) | CXTPPopupPaintManager |
DrawItemIcon(CDC *pDC, CXTPPopupItem *pItem) | CXTPPopupPaintManager | virtual
m_clrBackground | CXTPPopupPaintManager |
m_clrButtonPressed | CXTPPopupPaintManager |
m_clrButtonPressedBorder | CXTPPopupPaintManager |
m_clrButtonSelected | CXTPPopupPaintManager |
m_clrButtonSelectedBorder | CXTPPopupPaintManager |
m_clrFrame | CXTPPopupPaintManager |
m_clrText | CXTPPopupPaintManager |
m_xtpFontText | CXTPPopupPaintManager |
RefreshMetrics() | CXTPPopupThemeMSN | virtual
SetFont(HFONT hFont) | CXTPPopupPaintManager |
~CXTPPopupPaintManager() | CXTPPopupPaintManager | virtual
~CXTPPopupThemeMSN() | CXTPPopupThemeMSN | virtual
~CXTPPopupThemeOffice2000() | CXTPPopupThemeOffice2000 | virtual


Toolkit Pro: Member List

CXTPPropertyGridUpdateContext Member List

This is the complete list of members for CXTPPropertyGridUpdateContext, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPPropertyGridUpdateContext() | CXTPPropertyGridUpdateContext |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
IsEmpty() const | CXTPPropertyGridUpdateContext |
m_mapState | CXTPPropertyGridUpdateContext | protected
m_nSelected | CXTPPropertyGridUpdateContext | protected
m_nTopIndex | CXTPPropertyGridUpdateContext | protected
m_propertySort | CXTPPropertyGridUpdateContext | protected


Toolkit Pro: XTPChartAxisGridLines.h Source File

  • Source
  • Chart
  • Diagram
  • Axis
XTPChartAxisGridLines.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTAXISGRIDLINES_H__)
24# define __XTPCHARTAXISGRIDLINES_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartAxis;
34class CXTPChartLineStyle;
35
41class _XTP_EXT_CLASS CXTPChartAxisGridLines : public CXTPChartElement
42{
43public:
50 CXTPChartAxisGridLines(CXTPChartAxis* pAxis);
51
56 virtual ~CXTPChartAxisGridLines();
57
58public:
65 BOOL IsVisible() const;
66
74 void SetVisible(BOOL bVisible);
75
82 BOOL IsMinorVisible() const;
83
91 void SetMinorVisible(BOOL bMinorVisible);
92
99 CXTPChartColor GetColor() const;
100
107 CXTPChartColor GetMinorColor() const;
108
116 CXTPChartLineStyle* GetLineStyle() const;
117
125 CXTPChartLineStyle* GetMinorLineStyle() const;
126
127public:
135 CXTPChartAxis* GetAxis() const;
136
137public:
138 void DoPropExchange(CXTPPropExchange* pPX);
139
140# ifdef _XTP_ACTIVEX
141public:
143 DECLARE_DISPATCH_MAP()
144 DECLARE_INTERFACE_MAP()
145 DECLARE_OLETYPELIB_EX(CXTPChartAxisGridLines);
146 LPDISPATCH OleGetLineStyle();
147 LPDISPATCH OleGetMinorLineStyle();
149# endif
150
151protected:
152 BOOL m_bVisible;
153 BOOL m_bMinorVisible;
154 CXTPChartColor m_clrColor;
155 CXTPChartColor m_clrMinorColor;
157 CXTPChartLineStyle* m_pLineStyle;
158 CXTPChartLineStyle* m_pMinorLineStyle;
159};
160
161AFX_INLINE CXTPChartAxis* CXTPChartAxisGridLines::GetAxis() const
162{
163 return (CXTPChartAxis*)m_pOwner;
164}
165AFX_INLINE BOOL CXTPChartAxisGridLines::IsVisible() const
166{
167 return m_bVisible;
168}
169AFX_INLINE BOOL CXTPChartAxisGridLines::IsMinorVisible() const
170{
171 return m_bMinorVisible;
172}
173AFX_INLINE void CXTPChartAxisGridLines::SetVisible(BOOL bVisible)
174{
175 m_bVisible = bVisible;
176 OnChartChanged();
177}
178AFX_INLINE CXTPChartLineStyle* CXTPChartAxisGridLines::GetLineStyle() const
179{
180 return m_pLineStyle;
181}
182AFX_INLINE CXTPChartLineStyle* CXTPChartAxisGridLines::GetMinorLineStyle() const
183{
184 return m_pMinorLineStyle;
185}
186AFX_INLINE void CXTPChartAxisGridLines::SetMinorVisible(BOOL bMinorVisible)
187{
188 m_bMinorVisible = bMinorVisible;
189 OnChartChanged();
190}
192# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
193#endif //#if !defined(__XTPCHARTAXISGRIDLINES_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartAxisGridLines
CXTPChartAxisGridLines is a kind of CXTPChartElement, This class represents the grid lines parallel t...
Definition XTPChartAxisGridLines.h:42
CXTPChartAxisGridLines::GetAxis
CXTPChartAxis * GetAxis() const
Call this function to get the axis object to which the grid lines are associated.
Definition XTPChartAxisGridLines.h:161
CXTPChartAxisGridLines::DoPropExchange
void DoPropExchange(CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
CXTPChartAxisGridLines::GetMinorColor
CXTPChartColor GetMinorColor() const
Use this function to get the color of the minor grid lines.
CXTPChartAxisGridLines::SetVisible
void SetVisible(BOOL bVisible)
Call this function to set the visibility of the grid lines.
Definition XTPChartAxisGridLines.h:173
CXTPChartAxisGridLines::m_clrColor
CXTPChartColor m_clrColor
ARGB value of the grid lines color.
Definition XTPChartAxisGridLines.h:154
CXTPChartAxisGridLines::GetColor
CXTPChartColor GetColor() const
Use this function to get the color of the grid lines.
CXTPChartAxisGridLines::GetMinorLineStyle
CXTPChartLineStyle * GetMinorLineStyle() const
Use this function to get the minor grid line style used.
Definition XTPChartAxisGridLines.h:182
CXTPChartAxisGridLines::m_pLineStyle
CXTPChartLineStyle * m_pLineStyle
The grid line style.
Definition XTPChartAxisGridLines.h:157
CXTPChartAxisGridLines::m_bMinorVisible
BOOL m_bMinorVisible
TRUE if the minor grid lines are visible, FALSE if not.
Definition XTPChartAxisGridLines.h:153
CXTPChartAxisGridLines::IsVisible
BOOL IsVisible() const
Call this function to check the visibility of the grid lines.
Definition XTPChartAxisGridLines.h:165
CXTPChartAxisGridLines::IsMinorVisible
BOOL IsMinorVisible() const
Call this function to check the visibility of the minor grid lines.
Definition XTPChartAxisGridLines.h:169
CXTPChartAxisGridLines::m_bVisible
BOOL m_bVisible
TRUE if the grid lines are visible, FALSE if not.
Definition XTPChartAxisGridLines.h:152
CXTPChartAxisGridLines::m_pMinorLineStyle
CXTPChartLineStyle * m_pMinorLineStyle
The minor grid line style.
Definition XTPChartAxisGridLines.h:158
CXTPChartAxisGridLines::CXTPChartAxisGridLines
CXTPChartAxisGridLines(CXTPChartAxis *pAxis)
Constructs a CXTPChartAxisGridLines object.
CXTPChartAxisGridLines::m_clrMinorColor
CXTPChartColor m_clrMinorColor
ARGB value of the minor grid lines color.
Definition XTPChartAxisGridLines.h:155
CXTPChartAxisGridLines::~CXTPChartAxisGridLines
virtual ~CXTPChartAxisGridLines()
Destroys a CXTPChartAxisGridLines object, handles cleanup.
CXTPChartAxisGridLines::GetLineStyle
CXTPChartLineStyle * GetLineStyle() const
Use this function to get the grid line style used.
Definition XTPChartAxisGridLines.h:178
CXTPChartAxisGridLines::SetMinorVisible
void SetMinorVisible(BOOL bMinorVisible)
Call this function to set the visibility of the minor grid lines.
Definition XTPChartAxisGridLines.h:186
CXTPChartAxis
This abstract base class represents a chart axis as a kind of chart element.
Definition XTPChartAxis.h:86
CXTPChartColor
This class abstracts a color entity.
Definition XTPChartTypes.h:51
CXTPChartElement
This class abstracts a chart element, this class acts as a base class for all chart elements.
Definition XTPChartElement.h:131
CXTPChartElement::OnChartChanged
virtual void OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic propertie...
CXTPChartLineStyle
This class represents a chart line style, which is a kind of CXTPCmdTarget.
Definition XTPChartLineStyle.h:43
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72


Toolkit Pro: XTPButton.h Source File

  • Source
  • Controls
  • Button
XTPButton.h
Go to the documentation of this file.
1
23#if !defined(__XTPBUTTON_H__)
24# define __XTPBUTTON_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPImageManager;
34class CXTPImageManagerIcon;
35class CXTPMarkupContext;
36class CXTPMarkupUIElement;
37class CXTPButtonTheme;
38class CXTPImageManagerIconHandle;
39class CXTPToolTipContext;
40
49enum XTPButtonTextImageRelation
50{
51 xtpButtonOverlay,
52 xtpButtonImageAboveText,
53 xtpButtonTextAboveImage,
54 xtpButtonImageBeforeText,
55 xtpButtonTextBeforeImage
56};
57
65enum XTPPushButtonStyle
66{
67 xtpButtonNormal,
68 xtpButtonDropDown,
70 xtpButtonDropDownRight,
72 xtpButtonSplitDropDown,
76 xtpButtonDropDownNoGlyph
77};
78
89enum XTPGroupBoxBorderStyle
90{
91 xtpGroupBoxBorder,
92 xtpGroupBoxSingleLine,
93 xtpGroupBoxNone
94};
95
96# define BST_INCLICK 0x0010
97# define BST_CAPTURED 0x0020
98# define BST_MOUSE 0x0040
99
100# ifndef CXTPButtonBase
101# define CXTPButtonBase CButton
102# endif
103
108class _XTP_EXT_CLASS CXTPButton : public CXTPButtonBase
109{
111# ifndef _XTP_ACTIVEX_BUTTON
112 DECLARE_DYNAMIC(CXTPButton)
113# else
114 DECLARE_DYNAMIC(CXTPOleButton)
115# endif
117public:
122 CXTPButton();
123
128 virtual ~CXTPButton();
129
130public:
138 BYTE GetButtonStyle() const;
139
147 virtual BOOL IsPushed();
148
157 virtual BOOL IsHighlighted();
158
167 virtual BOOL GetChecked();
168
180 void SetChecked(BOOL bChecked);
181
191 BOOL GetFlatStyle() const;
192
201 void SetFlatStyle(BOOL bFlatStyle = TRUE);
202
222 BOOL GetUseVisualStyle() const;
223
243 void SetUseVisualStyle(BOOL bUseVisualStyle = TRUE);
244
253 long GetBorderGap() const;
254
262 void SetBorderGap(int nBorderGap);
263
271 XTPPushButtonStyle GetPushButtonStyle() const;
272
283 void SetPushButtonStyle(XTPPushButtonStyle nPushButtonStyle);
284
291 virtual int GetTextAlignment() const;
292
298 void SetTextAlignment(DWORD dwAlignment);
299
306 virtual int GetImageAlignment() const;
307
313 void SetImageAlignment(DWORD dwAlignment);
314
322 XTPButtonTextImageRelation GetTextImageRelation() const;
323
330 void SetTextImageRelation(XTPButtonTextImageRelation relation);
331
340 long GetImageGap() const;
341
349 void SetImageGap(int nImageGap);
350
358 virtual CSize GetImageSize();
359
370 virtual BOOL IsDpiImageScalingEnabled() const;
371
378 virtual void SetDpiImageScaling(BOOL bEnable);
379
387 CXTPImageManagerIcon* GetIcon() const;
388
395 virtual void DrawImage(CDC* pDC, CRect rc);
396
404 XTPGroupBoxBorderStyle GetBorderStyle() const;
405
412 void SetBorderStyle(XTPGroupBoxBorderStyle style);
413
421 BOOL GetShowFocus() const;
422
429 void SetShowFocus(BOOL bShowFocus);
430
450 virtual BOOL SetTheme(XTPControlTheme eTheme);
451
459 virtual void SetTheme(CXTPButtonTheme* pPaintManager);
460
467 CXTPButtonTheme* GetTheme();
468
474 void RedrawButton(BOOL bUpdateWindow = FALSE);
475
483 BOOL IsDropDownStyle() const;
484
492 virtual CRect GetButtonRect();
493
500 void SetBuddy(CWnd* pWndBuddy, BOOL bMoveButton = TRUE);
501
507 void SetTooltip(LPCTSTR lpszTooltip);
508
515 CString GetTooltip() const;
516
523 CXTPToolTipContext* GetToolTipContext() const;
524
538 virtual BOOL SetIcon(CSize size, HICON hIcon, HICON hIconHot = NULL, BOOL bRedraw = TRUE);
539
553 virtual BOOL SetIcon(CSize size, UINT nID, UINT nHotID = 0, BOOL bRedraw = TRUE);
554
568 virtual BOOL SetIcon(CSize size, LPCTSTR lpszID, LPCTSTR lpszHotID = NULL, BOOL bRedraw = TRUE);
569
582 BOOL SetIcon(CSize size, CXTPImageManagerIcon* pIcon, BOOL bRedraw = TRUE);
583
597 virtual BOOL SetIcon(CSize size, const CXTPImageManagerIconHandle& hIconHandle,
598 const CXTPImageManagerIconHandle& hIconHotHandle, BOOL bRedraw = TRUE);
611 virtual BOOL SetBitmap(CSize size, UINT nID, BOOL bRedraw = TRUE);
612
619 virtual CString GetButtonText();
620
628 CSize GetGlyphSize(BOOL bCheckBox);
629
636 BOOL IsPushButton() const;
637
644 void EnableMarkup(BOOL bEnableMarkup = TRUE);
645
652 virtual COLORREF GetButtonTextColor();
653
660 virtual COLORREF GetButtonBackColor();
661
666 virtual void InternalTextChanged();
667
674 CXTPMarkupContext* GetMarkupContext() const;
675
683 CXTPMarkupUIElement* GetMarkupUIElement();
684
685protected:
690 virtual void OnDropDown();
691
698 virtual void OnDraw(CDC* pDC);
699
704 void DoDropDown();
705
710 virtual void RefreshMetrics();
711
712protected:
715 //{{AFX_VIRTUAL(CXTPButton)
716 virtual void DoDraw(CDC* pDC);
717 virtual BOOL OnWndMsg(UINT message, WPARAM wParam, LPARAM lParam, LRESULT* pResult);
718 virtual INT_PTR OnToolHitTest(CPoint point, TOOLINFO* pTI) const;
719 //}}AFX_VIRTUAL
720
721 //{{AFX_MSG(CXTPButton)
722 // Window
723 afx_msg int OnCreate(LPCREATESTRUCT lpCreateStruct);
724 afx_msg BOOL OnEraseBkgnd(CDC* pDC);
725 afx_msg void OnPaint();
726 // Focus
727 afx_msg void OnSetFocus(CWnd* pOldWnd);
728 afx_msg void OnKillFocus(CWnd* pNewWnd);
729 // Mouse
730 afx_msg void OnLButtonDown(UINT nFlags, CPoint point);
731 afx_msg void OnLButtonUp(UINT nFlags, CPoint point);
732 afx_msg void OnMouseMove(UINT nFlags, CPoint point);
733 afx_msg void OnMouseLeave();
734 //
735 afx_msg LRESULT OnSetStyle(WPARAM wParam, LPARAM lParam);
736 afx_msg LRESULT OnSetState(WPARAM wParam, LPARAM lParam);
737 afx_msg LRESULT OnSetCheck(WPARAM wParam, LPARAM lParam);
738 afx_msg void OnChar(UINT nChar, UINT nRepCnt, UINT nFlags);
739 afx_msg void OnKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags);
740 afx_msg void OnInvalidate();
741 afx_msg LRESULT OnCaptureChanged(WPARAM, LPARAM);
742 afx_msg LRESULT OnDefaultAndInvalidate(WPARAM, LPARAM);
743 afx_msg LRESULT OnUpdateUIState(WPARAM wParam, LPARAM lParam);
744 afx_msg LRESULT OnSetText(WPARAM wParam, LPARAM lParam);
745 afx_msg LRESULT OnPrintClient(WPARAM wParam, LPARAM lParam);
746 afx_msg LRESULT OnGetDlgCode(WPARAM wParam, LPARAM lParam);
747 afx_msg LRESULT OnSetTheme(WPARAM wParam, LPARAM lParam);
748 //}}AFX_MSG
749 DECLARE_MESSAGE_MAP()
750 DECLARE_INTERFACE_MAP()
751 XTP_DECLARE_CMDTARGETPROVIDER_INTERFACE()
752
755public:
756 BOOL m_bPushed;
757 BOOL m_bHot;
758 CXTPButtonTheme* m_pTheme;
759 BOOL m_bChecked;
761 BOOL m_bFlatStyle;
762 BOOL m_bUseVisualStyle;
764 long m_nImageAlignment;
765 long m_nBorderGap;
767 long m_nPushButtonStyle;
769 BOOL m_bEnableMarkup;
771 long m_nImageGap;
772 long m_nTextImageRelation;
773 CXTPImageManagerIcon* m_pIcon;
775 CSize m_szVectorIcon;
776 long m_nBorderStyle;
777 BOOL m_bShowFocus;
779 HWND m_hWndBuddy;
780 CXTPToolTipContext* m_pToolTipContext;
782 CString m_strTooltip;
784protected:
785 CXTPMarkupContext* m_pMarkupContext;
786 CXTPMarkupUIElement* m_pUIElement;
787 BOOL m_bImageDPIScaling;
789private:
790 BOOL m_bImageDPIScalingModified;
791};
793AFX_INLINE BOOL CXTPButton::IsPushed()
794{
795 return m_bPushed;
796}
797AFX_INLINE BOOL CXTPButton::GetFlatStyle() const
798{
799 return m_bFlatStyle;
800}
801AFX_INLINE BOOL CXTPButton::GetUseVisualStyle() const
802{
803 return m_bUseVisualStyle;
804}
805AFX_INLINE long CXTPButton::GetBorderGap() const
806{
807 return m_nBorderGap;
808}
809AFX_INLINE XTPPushButtonStyle CXTPButton::GetPushButtonStyle() const
810{
811 return static_cast< XTPPushButtonStyle >(m_nPushButtonStyle);
812}
813AFX_INLINE int CXTPButton::GetImageAlignment() const
814{
815 return m_nImageAlignment;
816}
817AFX_INLINE XTPButtonTextImageRelation CXTPButton::GetTextImageRelation() const
818{
819 return static_cast< XTPButtonTextImageRelation >(m_nTextImageRelation);
820}
821AFX_INLINE long CXTPButton::GetImageGap() const
822{
823 return m_nImageGap;
824}
825AFX_INLINE void CXTPButton::SetImageGap(int nImageGap)
826{
827 m_nImageGap = nImageGap;
828}
829AFX_INLINE CXTPImageManagerIcon* CXTPButton::GetIcon() const
830{
831 return m_pIcon;
832}
833AFX_INLINE XTPGroupBoxBorderStyle CXTPButton::GetBorderStyle() const
834{
835 return static_cast< XTPGroupBoxBorderStyle >(m_nBorderStyle);
836}
837AFX_INLINE void CXTPButton::SetBorderStyle(XTPGroupBoxBorderStyle style)
838{
839 m_nBorderStyle = style;
840}
841AFX_INLINE BOOL CXTPButton::GetShowFocus() const
842{
843 return m_bShowFocus;
844}
845AFX_INLINE void CXTPButton::SetShowFocus(BOOL bShowFocus)
846{
847 m_bShowFocus = bShowFocus;
848}
849AFX_INLINE CXTPMarkupContext* CXTPButton::GetMarkupContext() const
850{
851 return m_pMarkupContext;
852}
853AFX_INLINE CXTPMarkupUIElement* CXTPButton::GetMarkupUIElement()
854{
855 return m_pUIElement;
856}
857AFX_INLINE void CXTPButton::SetTooltip(LPCTSTR lpszTooltip)
858{
859 m_strTooltip = lpszTooltip;
860}
861AFX_INLINE CString CXTPButton::GetTooltip() const
862{
863 return m_strTooltip;
864}
865AFX_INLINE CXTPToolTipContext* CXTPButton::GetToolTipContext() const
866{
867 return m_pToolTipContext;
868}
869AFX_INLINE CXTPButtonTheme* CXTPButton::GetTheme()
870{
871 return m_pTheme;
872}
874# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
876#endif // #if !defined(__XTPBUTTON_H__)
XTPButtonTextImageRelation
XTPButtonTextImageRelation
Image and text relationship settings for a push button control.
Definition XTPButton.h:50
xtpButtonTextBeforeImage
@ xtpButtonTextBeforeImage
Text is displayed before/to the left of the image.
Definition XTPButton.h:55
xtpButtonImageAboveText
@ xtpButtonImageAboveText
Image is displayed above the text.
Definition XTPButton.h:52
xtpButtonImageBeforeText
@ xtpButtonImageBeforeText
Image is displayed before/to the left of the text.
Definition XTPButton.h:54
xtpButtonOverlay
@ xtpButtonOverlay
Image is displayed over top of the text.
Definition XTPButton.h:51
xtpButtonTextAboveImage
@ xtpButtonTextAboveImage
Text is displayed above the image.
Definition XTPButton.h:53
XTPGroupBoxBorderStyle
XTPGroupBoxBorderStyle
Determines the group box border style for the control.
Definition XTPButton.h:90
xtpGroupBoxSingleLine
@ xtpGroupBoxSingleLine
Single line with caption.
Definition XTPButton.h:92
xtpGroupBoxBorder
@ xtpGroupBoxBorder
Complete frame with caption.
Definition XTPButton.h:91
xtpGroupBoxNone
@ xtpGroupBoxNone
No frame or caption.
Definition XTPButton.h:93
XTPPushButtonStyle
XTPPushButtonStyle
PushButton styles.
Definition XTPButton.h:66
xtpButtonDropDownNoGlyph
@ xtpButtonDropDownNoGlyph
Do not display the drop down arrow.
Definition XTPButton.h:76
xtpButtonDropDown
@ xtpButtonDropDown
Dropdown button.
Definition XTPButton.h:68
xtpButtonDropDownRight
@ xtpButtonDropDownRight
Dropdown button.
Definition XTPButton.h:70
xtpButtonSplitDropDown
@ xtpButtonSplitDropDown
Split button.
Definition XTPButton.h:72
xtpButtonNormal
@ xtpButtonNormal
Normal push button.
Definition XTPButton.h:67
XTPControlTheme
XTPControlTheme
Enumeration used to determine the active theme style.
Definition XTPControlTheme.h:43
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTP_DECLARE_CMDTARGETPROVIDER_INTERFACE
#define XTP_DECLARE_CMDTARGETPROVIDER_INTERFACE()
When deriving from CXTPCmdTarget is not possible this macro can be used in addition to standard DECLA...
Definition XTPFramework.h:89
CXTPButton
Push Button control.
Definition XTPButton.h:109
CXTPButton::GetPushButtonStyle
XTPPushButtonStyle GetPushButtonStyle() const
This function retrieves a flag from the XTPPushButtonStyle enumeration that specifies the current sty...
CXTPButton::GetToolTipContext
CXTPToolTipContext * GetToolTipContext() const
Call this method to get a pointer to the tooltip context.
CXTPButton::SetBitmap
virtual BOOL SetBitmap(CSize size, UINT nID, BOOL bRedraw=TRUE)
This member function will set the bitmap associated with the button.
CXTPButton::SetIcon
BOOL SetIcon(CSize size, CXTPImageManagerIcon *pIcon, BOOL bRedraw=TRUE)
This member function will set the normal and hot state icons for the push button.
CXTPButton::SetPushButtonStyle
void SetPushButtonStyle(XTPPushButtonStyle nPushButtonStyle)
This member function will set the display style for the button.
CXTPButton::GetImageSize
virtual CSize GetImageSize()
Call this member function to return the size of the image displayed for the button control.
CXTPButton::SetBorderStyle
void SetBorderStyle(XTPGroupBoxBorderStyle style)
Sets the border style of the control.
CXTPButton::SetUseVisualStyle
void SetUseVisualStyle(BOOL bUseVisualStyle=TRUE)
Enables Windows XP visual styles for the control.
CXTPButton::IsDpiImageScalingEnabled
virtual BOOL IsDpiImageScalingEnabled() const
Call this member to check if DPI scaling of images is enabled.
CXTPButton::GetChecked
virtual BOOL GetChecked()
Call this member function to determine if the checked state has been defined for the button control.
CXTPButton::SetIcon
virtual BOOL SetIcon(CSize size, UINT nID, UINT nHotID=0, BOOL bRedraw=TRUE)
This member function will set the normal and hot state icons for the push button.
CXTPButton::SetIcon
virtual BOOL SetIcon(CSize size, HICON hIcon, HICON hIconHot=NULL, BOOL bRedraw=TRUE)
This member function will set the normal and hot state icons for the push button.
CXTPButton::SetIcon
virtual BOOL SetIcon(CSize size, LPCTSTR lpszID, LPCTSTR lpszHotID=NULL, BOOL bRedraw=TRUE)
This member function will set the normal and hot state icons for the push button.
CXTPButton::GetTextImageRelation
XTPButtonTextImageRelation GetTextImageRelation() const
Gets the text and image relation in the button.
CXTPButton::GetFlatStyle
BOOL GetFlatStyle() const
Gets the flat style appearance of the button control.
CXTPButton::SetTextAlignment
void SetTextAlignment(DWORD dwAlignment)
Sets the alignment of the text on the button control.
CXTPButton::IsPushButton
BOOL IsPushButton() const
Determines if the button is a push button or a drop down button.
CXTPButton::SetImageAlignment
void SetImageAlignment(DWORD dwAlignment)
Sets the alignment of the image on the button control.
CXTPButton::SetIcon
virtual BOOL SetIcon(CSize size, const CXTPImageManagerIconHandle &hIconHandle, const CXTPImageManagerIconHandle &hIconHotHandle, BOOL bRedraw=TRUE)
This member function will set the normal and hot state icons for the push button.
CXTPButton::OnDropDown
virtual void OnDropDown()
Occurs when the drop down button is dropped down.
CXTPButton::GetMarkupUIElement
CXTPMarkupUIElement * GetMarkupUIElement()
Call this method to get the markup element that renders the caption of the control.
CXTPButton::GetTextAlignment
virtual int GetTextAlignment() const
Gets the alignment of the text on the button control.
CXTPButton::SetChecked
void SetChecked(BOOL bChecked)
Sets the highlight state for the button control.
CXTPButton::GetShowFocus
BOOL GetShowFocus() const
Gets whether a focus rectangle is drawn around the contents of a button when the button has focus.
CXTPButton::EnableMarkup
void EnableMarkup(BOOL bEnableMarkup=TRUE)
Allows the use of a XAML snippet to be used for the text of panes in the control.
CXTPButton::IsPushed
virtual BOOL IsPushed()
Call this member function to determine if the the button is currently being pushed.
CXTPButton::GetButtonStyle
BYTE GetButtonStyle() const
Retrieves the button styles for this object.
CXTPButton::InternalTextChanged
virtual void InternalTextChanged()
This member function is called when the text has changed.
CXTPButton::RedrawButton
void RedrawButton(BOOL bUpdateWindow=FALSE)
Redraws the button.
CXTPButton::GetImageAlignment
virtual int GetImageAlignment() const
Gets the alignment of the image on the button control.
CXTPButton::SetTheme
virtual void SetTheme(CXTPButtonTheme *pPaintManager)
Call this member to switch the visual theme of the control.
CXTPButton::GetBorderStyle
XTPGroupBoxBorderStyle GetBorderStyle() const
Gets the border style of the control.
CXTPButton::GetBorderGap
long GetBorderGap() const
Call this member function to retrieve the gap between the button's image and border.
CXTPButton::CXTPButton
CXTPButton()
Constructs a CXTPButton object.
CXTPButton::SetTextImageRelation
void SetTextImageRelation(XTPButtonTextImageRelation relation)
Sets the text and image relation in the button.
CXTPButton::SetFlatStyle
void SetFlatStyle(BOOL bFlatStyle=TRUE)
Sets the flat style appearance of the button control.
CXTPButton::SetTheme
virtual BOOL SetTheme(XTPControlTheme eTheme)
Call this member to switch the visual theme of the control.
CXTPButton::SetImageGap
void SetImageGap(int nImageGap)
Call this member function to set the gap between the button's text and image.
CXTPButton::GetButtonText
virtual CString GetButtonText()
Call this member function to return the button's text minus the '&'.
CXTPButton::SetBorderGap
void SetBorderGap(int nBorderGap)
Call this member function to set the gap between the button's image and border.
CXTPButton::SetBuddy
void SetBuddy(CWnd *pWndBuddy, BOOL bMoveButton=TRUE)
Sets the control used as the buddy control.
CXTPButton::GetTheme
CXTPButtonTheme * GetTheme()
Call this member function to get a pointer to the currently selected theme.
CXTPButton::GetUseVisualStyle
BOOL GetUseVisualStyle() const
Determines if the control is drawn using visual styles/SkinFramework, if supported.
CXTPButton::GetButtonRect
virtual CRect GetButtonRect()
This member function is called to determine the size and location of the button.
CXTPButton::OnDraw
virtual void OnDraw(CDC *pDC)
This member function performs all of the drawing logic of the calendar control window.
CXTPButton::SetTooltip
void SetTooltip(LPCTSTR lpszTooltip)
Associates tooltip text with the button.
CXTPButton::SetDpiImageScaling
virtual void SetDpiImageScaling(BOOL bEnable)
Call this member to enable/disable DPI scaling of images.
CXTPButton::GetButtonTextColor
virtual COLORREF GetButtonTextColor()
Gets the button's text color.
CXTPButton::GetButtonBackColor
virtual COLORREF GetButtonBackColor()
Gets the button's back color.
CXTPButton::~CXTPButton
virtual ~CXTPButton()
Destroys a CXTPButton object, handles cleanup and deallocation.
CXTPButton::DoDropDown
void DoDropDown()
Manually drops down a drop down button.
CXTPButton::GetImageGap
long GetImageGap() const
Call this member function to retrieve the gap between the button's text and image.
CXTPButton::GetIcon
CXTPImageManagerIcon * GetIcon() const
Call this member function to return a pointer to the image manager for the button control.
CXTPButton::GetMarkupContext
CXTPMarkupContext * GetMarkupContext() const
Retrieves a pointer to the markup context.
CXTPButton::RefreshMetrics
virtual void RefreshMetrics()
Call this member function to refresh theme colors and redraw the control.
CXTPButton::IsHighlighted
virtual BOOL IsHighlighted()
Call this member function to determine if the the button is currently being highlighted (mouse over).
CXTPButton::SetShowFocus
void SetShowFocus(BOOL bShowFocus)
Sets whether a focus rectangle is drawn around the contents of a button when the button has focus.
CXTPButton::GetGlyphSize
CSize GetGlyphSize(BOOL bCheckBox)
Retrieves the size of the check box glyph.
CXTPButton::IsDropDownStyle
BOOL IsDropDownStyle() const
This member function is called to determine if the buttons have a drop down arrow and if it is drop d...
CXTPButton::DrawImage
virtual void DrawImage(CDC *pDC, CRect rc)
This method is called to draw the image of the control.
CXTPButton::GetTooltip
CString GetTooltip() const
Call this member to retrieve the button's tooltip.
CXTPButtonTheme
CXTPButtonTheme is a class used to perform Button Theme drawing tasks.
Definition XTPButtonTheme.h:51
CXTPImageManager
CXTPImageManager is a standalone class.
Definition XTPImageManager.h:1898
CXTPImageManagerIconHandle
CXTPImageManagerIconHandle is a HICON wrapper class.
Definition XTPImageManager.h:384
CXTPImageManagerIcon
Icons holder class.
Definition XTPImageManager.h:622
CXTPMarkupContext
CXTPMarkupContext is a standalone class used to provide common settings for Markup objects.
Definition XTPMarkupContext.h:128
CXTPMarkupUIElement
Base class for XML Markup core level implementations.
Definition XTPMarkupUIElement.h:43
CXTPToolTipContext
CXTPToolTipContext is a CXTPCmdTarget derived class.
Definition XTPToolTipContext.h:291


Toolkit Pro: XTPDockingPaneThemeOffice2007Word.h Source File

  • Source
  • DockingPane
  • Themes
XTPDockingPaneThemeOffice2007Word.h
Go to the documentation of this file.
1
23#if !defined(__XTPDOCKINGPANETHEMEOFFICE2007WORD_H__)
24# define __XTPDOCKINGPANETHEMEOFFICE2007WORD_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
41class _XTP_EXT_CLASS CXTPDockingPaneOffice2007WordTheme : public CXTPDockingPaneOffice2003Theme
42{
43public:
48 CXTPDockingPaneOffice2007WordTheme();
49
50public:
55 void RefreshMetrics();
56
64 void DrawCaption(CDC* pDC, CXTPDockingPaneTabbedContainer* pPane, CRect rc);
65
76 void DrawCaptionPart(CDC* pDC, CXTPDockingPaneBase* pPane, CRect rcCaption,
77 const CString& strTitle, BOOL bActive, BOOL bVertical);
78
87 void AdjustClientRect(CXTPDockingPaneTabbedContainer* pPane, CRect& rect, BOOL bApply);
88
89# if _MSC_VER > 1200
90 using CXTPDockingPanePaintManager::AdjustClientRect;
91# endif
92
100 void DrawPane(CDC* pDC, CXTPDockingPaneTabbedContainer* pPane, CRect rc);
101
109 BOOL PaneHasBorders(CXTPDockingPaneTabbedContainer* pPane) const;
110
111protected:
112 BOOL m_bOffice2010Style;
113};
114
115# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
117#endif // !defined(__XTPDOCKINGPANETHEMEOFFICE2007WORD_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPDockingPaneBase
CXTPDockingPaneBase is a standalone class.
Definition XTPDockingPaneBase.h:69
CXTPDockingPaneOffice2003Theme
CXTPDockingPaneOffice2003Theme is a CXTPDockingPaneVisualStudio2003Theme derived class that represent...
Definition XTPDockingPaneThemeOffice2003.h:41
CXTPDockingPaneOffice2007WordTheme
CXTPDockingPaneOffice2007WordTheme is a CXTPDockingPaneOffice2003Theme derived class that represents ...
Definition XTPDockingPaneThemeOffice2007Word.h:42
CXTPDockingPaneOffice2007WordTheme::CXTPDockingPaneOffice2007WordTheme
CXTPDockingPaneOffice2007WordTheme()
Constructs a CXTPDockingPaneOffice2007WordTheme object.
CXTPDockingPaneOffice2007WordTheme::DrawCaptionPart
void DrawCaptionPart(CDC *pDC, CXTPDockingPaneBase *pPane, CRect rcCaption, const CString &strTitle, BOOL bActive, BOOL bVertical)
Draws the common part of a tabbed and floating caption.
CXTPDockingPaneOffice2007WordTheme::PaneHasBorders
BOOL PaneHasBorders(CXTPDockingPaneTabbedContainer *pPane) const
Determines if a pane has borders (if title is visible).
CXTPDockingPaneOffice2007WordTheme::AdjustClientRect
void AdjustClientRect(CXTPDockingPaneTabbedContainer *pPane, CRect &rect, BOOL bApply)
Override this member to change the client rectangle of the child docking pane.
CXTPDockingPaneOffice2007WordTheme::RefreshMetrics
void RefreshMetrics()
This method is called to refresh the visual metrics of the pane.
CXTPDockingPaneOffice2007WordTheme::DrawPane
void DrawPane(CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc)
Override this member function to draw a tabbed container.
CXTPDockingPaneOffice2007WordTheme::DrawCaption
void DrawCaption(CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc)
Override this member function to draw a caption.
CXTPDockingPanePaintManager::AdjustClientRect
virtual void AdjustClientRect(CXTPDockingPaneSidePanel *pPane, CRect &rect)
Override this member to change the client rectangle of the child docking pane.
CXTPDockingPaneTabbedContainer
CXTPDockingPaneTabbedContainer is a multiple inheritance class derived from CWnd and CXTPDockingPaneB...
Definition XTPDockingPaneTabbedContainer.h:47


Toolkit Pro: XTPChartLineDeviceCommand.h Source File

  • Source
  • Chart
  • Drawing
XTPChartLineDeviceCommand.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTLINEDEVICECOMMAND_H__)
24# define __XTPCHARTLINEDEVICECOMMAND_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33// Array type used for dashed chart lines.
34typedef CArray<float, float> CXTPChartLineDashArray;
35
40class _XTP_EXT_CLASS CXTPChartLineDeviceCommand : public CXTPChartDeviceCommand
41{
42protected:
52 CXTPChartLineDeviceCommand(const CXTPPoint2f& p1, const CXTPPoint2f& p2,
53 const CXTPChartColor& color, int thickness);
54
65 virtual CXTPChartElement* HitTest(CPoint point, CXTPChartElement* pParent) const;
66
67protected:
68 CXTPPoint2f m_p1;
69 CXTPPoint2f m_p2;
70 CXTPChartColor m_color;
71 int m_nThickness;
72};
73
78class _XTP_EXT_CLASS CXTPChartPolylineDeviceCommand : public CXTPChartDeviceCommand
79{
80protected:
88 CXTPChartPolylineDeviceCommand(const CXTPChartPoints& p, int thickness);
89
90protected:
91 CXTPChartPoints m_p;
92 int m_nThickness;
93};
94
99class _XTP_EXT_CLASS CXTPChartSplineDeviceCommand : public CXTPChartDeviceCommand
100{
101protected:
109 CXTPChartSplineDeviceCommand(const CXTPChartPoints& p, int thickness);
110
111protected:
112 CXTPChartPoints m_p;
113 int m_nThickness;
114};
115
120class _XTP_EXT_CLASS CXTPChart3dLineDeviceCommand : public CXTPChartDeviceCommand
121{
122protected:
132 CXTPChart3dLineDeviceCommand(const CXTPPoint3d& p1, const CXTPPoint3d& p2,
133 const CXTPChartColor& color, int thickness);
134
145 virtual CXTPChartElement* HitTest(CPoint point, CXTPChartElement* pParent) const;
146
154 virtual void AfterExecute(CXTPChartDeviceContext* pDC);
155
156protected:
157 CXTPPoint3d m_p1;
158 CXTPPoint3d m_p2;
159 CXTPChartColor m_color;
160 int m_nThickness;
162private:
163 BOOL m_bProjected;
164 CPoint m_pt2d1;
165 CPoint m_pt2d2;
166};
168# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
169#endif //#if !defined(__XTPCHARTLINEDEVICECOMMAND_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChart3dLineDeviceCommand
Provides an interface for 3D line drawing device command.
Definition XTPChartLineDeviceCommand.h:121
CXTPChart3dLineDeviceCommand::AfterExecute
virtual void AfterExecute(CXTPChartDeviceContext *pDC)
This method gets called after a command is executed which allows for the customization of command beh...
CXTPChart3dLineDeviceCommand::m_color
CXTPChartColor m_color
The line color.
Definition XTPChartLineDeviceCommand.h:159
CXTPChart3dLineDeviceCommand::m_nThickness
int m_nThickness
The thickness of the line.
Definition XTPChartLineDeviceCommand.h:160
CXTPChart3dLineDeviceCommand::m_p1
CXTPPoint3d m_p1
The first point.
Definition XTPChartLineDeviceCommand.h:157
CXTPChart3dLineDeviceCommand::m_p2
CXTPPoint3d m_p2
The second point.
Definition XTPChartLineDeviceCommand.h:158
CXTPChart3dLineDeviceCommand::HitTest
virtual CXTPChartElement * HitTest(CPoint point, CXTPChartElement *pParent) const
Performs recursive hit testing of the element at the specified point.
CXTPChart3dLineDeviceCommand::CXTPChart3dLineDeviceCommand
CXTPChart3dLineDeviceCommand(const CXTPPoint3d &p1, const CXTPPoint3d &p2, const CXTPChartColor &color, int thickness)
Constructs a CXTPChart3dLineDeviceCommand object.
CXTPChartColor
This class abstracts a color entity.
Definition XTPChartTypes.h:51
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartElement
This class abstracts a chart element, this class acts as a base class for all chart elements.
Definition XTPChartElement.h:131
CXTPChartLineDeviceCommand
Provides an interface for 2D line drawing device command.
Definition XTPChartLineDeviceCommand.h:41
CXTPChartLineDeviceCommand::CXTPChartLineDeviceCommand
CXTPChartLineDeviceCommand(const CXTPPoint2f &p1, const CXTPPoint2f &p2, const CXTPChartColor &color, int thickness)
Constructs a CXTPChartLineDeviceCommand object.
CXTPChartLineDeviceCommand::m_p1
CXTPPoint2f m_p1
The first point.
Definition XTPChartLineDeviceCommand.h:68
CXTPChartLineDeviceCommand::m_p2
CXTPPoint2f m_p2
The second point.
Definition XTPChartLineDeviceCommand.h:69
CXTPChartLineDeviceCommand::m_color
CXTPChartColor m_color
The line color.
Definition XTPChartLineDeviceCommand.h:70
CXTPChartLineDeviceCommand::m_nThickness
int m_nThickness
The thickness of the line.
Definition XTPChartLineDeviceCommand.h:71
CXTPChartLineDeviceCommand::HitTest
virtual CXTPChartElement * HitTest(CPoint point, CXTPChartElement *pParent) const
Performs recursive hit testing of the element at the specified point.
CXTPChartPolylineDeviceCommand
Provides an interface for 2D poly-line drawing device command.
Definition XTPChartLineDeviceCommand.h:79
CXTPChartPolylineDeviceCommand::CXTPChartPolylineDeviceCommand
CXTPChartPolylineDeviceCommand(const CXTPChartPoints &p, int thickness)
Constructs a CXTPChartPolylineDeviceCommand object.
CXTPChartPolylineDeviceCommand::m_nThickness
int m_nThickness
Line thickness in pixels.
Definition XTPChartLineDeviceCommand.h:92
CXTPChartPolylineDeviceCommand::m_p
CXTPChartPoints m_p
A collection of poly-line points.
Definition XTPChartLineDeviceCommand.h:91
CXTPChartSplineDeviceCommand
Provides an interface for 2D spline drawing device command.
Definition XTPChartLineDeviceCommand.h:100
CXTPChartSplineDeviceCommand::CXTPChartSplineDeviceCommand
CXTPChartSplineDeviceCommand(const CXTPChartPoints &p, int thickness)
Constructs a CXTPChartSplineDeviceCommand object.
CXTPChartSplineDeviceCommand::m_nThickness
int m_nThickness
Line thickness in pixels.
Definition XTPChartLineDeviceCommand.h:113
CXTPChartSplineDeviceCommand::m_p
CXTPChartPoints m_p
A collection of spline points.
Definition XTPChartLineDeviceCommand.h:112
CXTPPoint2T< float >
CXTPPoint3T< double >


Toolkit Pro: XTPDockingPaneThemeWinNative.h Source File

  • Source
  • DockingPane
  • Themes
XTPDockingPaneThemeWinNative.h
Go to the documentation of this file.
1
23#if !defined(__XTPDOCKINGPANETHEMEWINNATIVE_H__)
24# define __XTPDOCKINGPANETHEMEWINNATIVE_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
40class _XTP_EXT_CLASS CXTPDockingPaneWinNativeTheme : public CXTPDockingPaneVisualStudio2003Theme
41{
42public:
47 CXTPDockingPaneWinNativeTheme();
48
53 virtual void RefreshMetrics();
54
62 virtual void DrawCaption(CDC* pDC, CXTPDockingPaneTabbedContainer* pPane, CRect rc);
63
71 void DrawFloatingFrame(CDC* pDC, CXTPDockingPaneMiniWnd* pPane, CRect rc);
72
80 void DrawSidePanel(CDC* pDC, CXTPDockingPaneSidePanel* pPane, CRect rc);
81
82protected:
93 virtual void DrawCaptionPart(CDC* pDC, CXTPDockingPaneBase* pPane, CRect rcCaption,
94 const CString& strTitle, BOOL bActive, BOOL bVertical);
95
96protected:
97};
98
99# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
101#endif // !defined(__XTPDOCKINGPANETHEMEWINNATIVE_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPDockingPaneBase
CXTPDockingPaneBase is a standalone class.
Definition XTPDockingPaneBase.h:69
CXTPDockingPaneMiniWnd
CXTPDockingPaneMiniWnd is a multiple inheritance class derived from CMiniFrameWnd and CXTPDockingPane...
Definition XTPDockingPaneMiniWnd.h:42
CXTPDockingPaneSidePanel
CXTPDockingPaneSidePanel is a multiple inheritance class derived from CWnd and CXTPDockingPaneBase.
Definition XTPDockingPaneSidePanel.h:45
CXTPDockingPaneTabbedContainer
CXTPDockingPaneTabbedContainer is a multiple inheritance class derived from CWnd and CXTPDockingPaneB...
Definition XTPDockingPaneTabbedContainer.h:47
CXTPDockingPaneVisualStudio2003Theme
CXTPDockingPaneVisualStudio2003Theme is a CXTPDockingPaneGripperedTheme derived class that represents...
Definition XTPDockingPaneThemeVisualStudio2003.h:42
CXTPDockingPaneWinNativeTheme
CXTPDockingPaneWinNativeTheme is a CXTPDockingPaneVisualStudio2003Theme derived class that represents...
Definition XTPDockingPaneThemeWinNative.h:41
CXTPDockingPaneWinNativeTheme::CXTPDockingPaneWinNativeTheme
CXTPDockingPaneWinNativeTheme()
Constructs a CXTPDockingPaneWinNativeTheme object.
CXTPDockingPaneWinNativeTheme::DrawFloatingFrame
void DrawFloatingFrame(CDC *pDC, CXTPDockingPaneMiniWnd *pPane, CRect rc)
Call this method to draw the frame of a floating window.
CXTPDockingPaneWinNativeTheme::DrawCaption
virtual void DrawCaption(CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc)
Override this member function to draw a caption.
CXTPDockingPaneWinNativeTheme::RefreshMetrics
virtual void RefreshMetrics()
This method is called to refresh the visual metrics of the pane.
CXTPDockingPaneWinNativeTheme::DrawCaptionPart
virtual void DrawCaptionPart(CDC *pDC, CXTPDockingPaneBase *pPane, CRect rcCaption, const CString &strTitle, BOOL bActive, BOOL bVertical)
Draws the common part of a tabbed and floating caption.
CXTPDockingPaneWinNativeTheme::DrawSidePanel
void DrawSidePanel(CDC *pDC, CXTPDockingPaneSidePanel *pPane, CRect rc)
Override this member function to draw the side panel.


Toolkit Pro: Member List

CXTPTaskPanelGroupItems Member List

This is the complete list of members for CXTPTaskPanelGroupItems, including all inherited members.

Add(CXTPTaskPanelItem *pItem, UINT nID) | CXTPTaskPanelItems |
Add(CXTPTaskPanelItem *pItem, UINT nID, LPCTSTR lpCaption, LPCTSTR lpTooltip=NULL) | CXTPTaskPanelItems |
Clear(BOOL bReposition=TRUE) | CXTPTaskPanelItems |
CXTPCmdTarget() | CXTPCmdTarget |
CXTPTaskPanelGroupItems(CXTPTaskPanel *pPanel) | CXTPTaskPanelGroupItems |
CXTPTaskPanelItems(CXTPTaskPanel *pPanel=NULL) | CXTPTaskPanelItems |
DoPropExchange(CXTPPropExchange *pPX) | CXTPTaskPanelItems |
Find(UINT nID) const | CXTPTaskPanelItems |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAt(int nIndex) const | CXTPTaskPanelItems |
GetCount() const | CXTPTaskPanelItems |
GetDefaultItemClass() const | CXTPTaskPanelGroupItems | virtual
GetFirstVisibleItem() const | CXTPTaskPanelItems |
GetIndex(const CXTPTaskPanelItem *pItem) const | CXTPTaskPanelItems |
GetLastVisibleItem() const | CXTPTaskPanelItems |
GetNextVisibleIndex(int nIndex, int nDirection) const | CXTPTaskPanelItems |
GetOwner() const | CXTPTaskPanelItems |
InsertAt(int nIndex, CXTPTaskPanelItem *pItem) | CXTPTaskPanelItems |
m_arrItems | CXTPTaskPanelItems | protected
m_pOwner | CXTPTaskPanelItems | protected
m_pPanel | CXTPTaskPanelItems | protected
Move(CXTPTaskPanelItem *pItem, int nIndex) | CXTPTaskPanelItems |
Remove(CXTPTaskPanelItem *pItem) | CXTPTaskPanelItems |
RemoveAt(int nIndex) | CXTPTaskPanelItems |
~CXTPTaskPanelItems() | CXTPTaskPanelItems | virtual


Toolkit Pro: XTPChartOpenGLPieDeviceCommand.h Source File

  • Source
  • Chart
  • Styles
  • Pie
  • 3D
  • Commands
  • OpenGL
XTPChartOpenGLPieDeviceCommand.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTOPENGLPIEDEVICECOMMAND_H__)
24# define __XTPCHARTOPENGLPIEDEVICECOMMAND_H__
25
26# if _MSC_VER >= 1000
27# pragma once
28# endif // _MSC_VER >= 1000
29
30# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
31
32class CXTPChart3dPieSeriesStyle;
33class CXTPChartDeviceContext;
34class CXTPChartSeriesStyle;
35class CXTPChartOpenGLDeviceContext;
36
43class _XTP_EXT_CLASS CXTPChartOpenGLPieDeviceCommand : public CXTPChart3dPieDeviceCommand
44{
45public:
46 CXTPChartOpenGLPieDeviceCommand(const CXTPPoint3d& center, double radius, double startAngle,
47 double sweepAngle, double depth, double holePercent,
48 const CXTPChartRectF& gradientBounds,
49 const CXTPChartColor& color, const CXTPChartColor& color2,
50 BOOL bStartGap = FALSE, BOOL bEndGap = FALSE);
51 ~CXTPChartOpenGLPieDeviceCommand();
52
53protected:
54 virtual CXTPChartElement* HitTest(CPoint point, CXTPChartElement* pParent) const;
55
56 virtual void ExecuteOverride(CXTPChartDeviceContext* pDC);
57 virtual void ApplySeriesStyle(CXTPChartSeriesStyle* pStyle);
58 virtual void PrepareOverride(CXTPChartDeviceContext* pDC);
59
60protected:
61 CXTPChartRectF m_rcGradientBounds;
62 CXTPChartColor m_color;
63 CXTPChartColor m_color2;
64 CXTPChart3dPieSeriesStyle* m_pStyle;
65 GLuint m_listId;
66 BOOL m_bStartGap;
67 BOOL m_bEndGap;
68
69private:
70 struct BarRingInfo;
71 struct TorusRingInfo;
72
73 CXTPPoint3d AFX_CDECL GetBarPieSliceCenter(int n, ...) const;
74
75 void DrawBarPie(CXTPChartOpenGLDeviceContext& dc, double dFromAngle, double dToAngle);
76 void DrawBarPie_OpenShape(CXTPChartOpenGLDeviceContext& dc, const BarRingInfo& ring);
77 void DrawBarPie_Shape(CXTPChartOpenGLDeviceContext& dc, const BarRingInfo& ringFrom,
78 const BarRingInfo& ringTo);
79 void DrawBarPie_CloseShape(CXTPChartOpenGLDeviceContext& dc, const BarRingInfo& ring);
80
81 void DrawTorusPie(CXTPChartOpenGLDeviceContext& dc, double dFromAngle, double dToAngle);
82 void DrawTorusPie_OpenShape(CXTPChartOpenGLDeviceContext& dc, const TorusRingInfo& ring);
83 void DrawTorusPie_Shape(CXTPChartOpenGLDeviceContext& dc, const TorusRingInfo& ringFrom,
84 const TorusRingInfo& ringTo);
85 void DrawTorusPie_CloseShape(CXTPChartOpenGLDeviceContext& dc, const TorusRingInfo& ring);
86
87 void ComputeConnectorPoints(double dFromAngle, double dToAngle);
88
89private:
90 BOOL m_bPrepared;
91 CXTPChart3dBox m_3dBox;
92 CXTPPoint3d m_ptCenterConnectorPoint;
93 CXTPPoint3d m_ptOuterConnectorPoint;
94};
95
96# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
97#endif //#if !defined(__XTPCHARTOPENGLPIEDEVICECOMMAND_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChart3dBox
Represents a 3D box build around included points and provides useful and fast operations.
Definition XTPChartTypes.h:728
CXTPChart3dPieDeviceCommand
Base class implementation for 3D pie chart device command.
Definition XTPChartPieDeviceCommand.h:122
CXTPChart3dPieSeriesStyle
This class abstracts the pie series style.
Definition XTPChart3dPieSeriesStyle.h:48
CXTPChartColor
This class abstracts a color entity.
Definition XTPChartTypes.h:51
CXTPChartDeviceCommand::ApplySeriesStyle
virtual void ApplySeriesStyle(CXTPChartSeriesStyle *pStyle)
Applies series style to the current element.
CXTPChartDeviceCommand::PrepareOverride
virtual void PrepareOverride(CXTPChartDeviceContext *pDC)
Derived implementation must override this method for implementing implementation specific preparation...
CXTPChartDeviceCommand::HitTest
virtual CXTPChartElement * HitTest(CPoint point, CXTPChartElement *pParent) const
Performs recursive hit testing of the element at the specified point.
CXTPChartDeviceCommand::ExecuteOverride
virtual void ExecuteOverride(CXTPChartDeviceContext *pDC)
Override this function to write the drawing code for specific objects.
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartElement
This class abstracts a chart element, this class acts as a base class for all chart elements.
Definition XTPChartElement.h:131
CXTPChartSeriesStyle
CXTPChartSeriesStyle is a CXTPChartElement derived class.
Definition XTPChartSeriesStyle.h:49
CXTPPoint3T< double >
CXTPRectT< float >


Toolkit Pro: Member List

CXTPPropertyGridItemSize Member List

This is the complete list of members for CXTPPropertyGridItemSize, including all inherited members.

AddChildItem(CXTPPropertyGridItem *pItem) | CXTPPropertyGridItem |
AddComboButton() | CXTPPropertyGridItem |
AddExpandButton() | CXTPPropertyGridItem |
AddSliderControl() | CXTPPropertyGridItem |
AddSpinButton() | CXTPPropertyGridItem |
BindToSize(CSize *pBindSize) | CXTPPropertyGridItemSize | virtual
BindToString(CString *pBindString) | CXTPPropertyGridItem |
Collapse() | CXTPPropertyGridItem |
CXTPCmdTarget() | CXTPCmdTarget |
CXTPPropertyGridItem(LPCTSTR lpszCaption, LPCTSTR strValue=NULL, CString *pBindString=NULL) | CXTPPropertyGridItem |
CXTPPropertyGridItem(UINT nID, LPCTSTR strValue=NULL, CString *pBindString=NULL) | CXTPPropertyGridItem |
CXTPPropertyGridItemSize(LPCTSTR strCaption, CSize size=0, CSize *pBindSize=NULL) | CXTPPropertyGridItemSize |
CXTPPropertyGridItemSize(UINT nID, CSize size=0, CSize *pBindSize=NULL) | CXTPPropertyGridItemSize |
EnsureVisible() | CXTPPropertyGridItem |
Expand() | CXTPPropertyGridItem |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCaption() const | CXTPPropertyGridItem |
GetCaptionMetrics() const | CXTPPropertyGridItem |
GetChilds() const | CXTPPropertyGridItem |
GetConstraintEdit() const | CXTPPropertyGridItem |
GetConstraints() const | CXTPPropertyGridItem |
GetDefaultValue() const | CXTPPropertyGridItem |
GetDescription() const | CXTPPropertyGridItem |
GetDropDownItemCount() const | CXTPPropertyGridItem |
GetEditStyle() const | CXTPPropertyGridItem | virtual
GetFlags() const | CXTPPropertyGridItem |
GetGrid() const | CXTPPropertyGridItem |
GetHeight() const | CXTPPropertyGridItem |
GetID() const | CXTPPropertyGridItem |
GetIndent() const | CXTPPropertyGridItem |
GetIndex() const | CXTPPropertyGridItem |
GetInplaceButtons() const | CXTPPropertyGridItem |
GetInplaceControls() const | CXTPPropertyGridItem |
GetInPlacedEditValue() | CXTPPropertyGridItem | inlineprotectedvirtual
GetInplaceEdit() | CXTPPropertyGridItem | virtual
GetInplaceList() | CXTPPropertyGridItem | protectedvirtual
GetItemData() const | CXTPPropertyGridItem |
GetItemRect() const | CXTPPropertyGridItem |
GetMarkupCaption() const | CXTPPropertyGridItem |
GetMarkupDescription() const | CXTPPropertyGridItem |
GetMarkupTemplate() const | CXTPPropertyGridItem | virtual
GetMarkupValue() const | CXTPPropertyGridItem |
GetMaskedText() const | CXTPPropertyGridItem |
GetMetrics(BOOL bValueMetrics, BOOL bCreate=TRUE) const | CXTPPropertyGridItem |
GetMultiLinesCount() const | CXTPPropertyGridItem |
GetParentItem() const | CXTPPropertyGridItem |
GetReadOnly() const | CXTPPropertyGridItem | virtual
GetSize() const | CXTPPropertyGridItemSize | virtual
GetTooltip() const | CXTPPropertyGridItem |
GetValue() const | CXTPPropertyGridItem |
GetValueMetrics() const | CXTPPropertyGridItem |
GetValueRect() | CXTPPropertyGridItem | virtual
GetViewValue() | CXTPPropertyGridItem | virtual
HasChilds() const | CXTPPropertyGridItem |
HasParent(CXTPPropertyGridItem *pParent) | CXTPPropertyGridItem |
HasVisibleChilds() const | CXTPPropertyGridItem |
InsertChildItem(int nIndex, CXTPPropertyGridItem *pItem) | CXTPPropertyGridItem |
IsAllowEdit() const | CXTPPropertyGridItem | virtual
IsCategory() const | CXTPPropertyGridItem |
IsExpandable() const | CXTPPropertyGridItem |
IsExpanded() const | CXTPPropertyGridItem |
IsHidden() const | CXTPPropertyGridItem |
IsInplaceButtonVisible(CXTPPropertyGridInplaceButton *pButton) const | CXTPPropertyGridItem | virtual
IsMultiLine() const | CXTPPropertyGridItem |
IsSelected() const | CXTPPropertyGridItem |
IsValueChanged() const | CXTPPropertyGridItem | virtual
IsVisible() const | CXTPPropertyGridItem |
m_bAutoComplete | CXTPPropertyGridItem | protected
m_bCategory | CXTPPropertyGridItem | protected
m_bConstraintEdit | CXTPPropertyGridItem | protected
m_bExpandable | CXTPPropertyGridItem | protected
m_bExpanded | CXTPPropertyGridItem | protected
m_bHidden | CXTPPropertyGridItem | protected
m_bPassword | CXTPPropertyGridItem | protected
m_bReadOnly | CXTPPropertyGridItem | protected
m_bUseMask | CXTPPropertyGridItem | protected
m_bVisible | CXTPPropertyGridItem | protected
m_chPrompt | CXTPPropertyGridItem | protected
m_dwData | CXTPPropertyGridItem | protected
m_dwEditStyle | CXTPPropertyGridItem | protected
m_nDropDownItemCount | CXTPPropertyGridItem | protected
m_nFlags | CXTPPropertyGridItem | protected
m_nHeight | CXTPPropertyGridItem | protected
m_nID | CXTPPropertyGridItem | protected
m_nIndent | CXTPPropertyGridItem | protected
m_nIndex | CXTPPropertyGridItem | protected
m_nLinesCount | CXTPPropertyGridItem | protected
m_pBindString | CXTPPropertyGridItem | protected
m_pCaptionMetrics | CXTPPropertyGridItem | mutableprotected
m_pChilds | CXTPPropertyGridItem | protected
m_pConstraints | CXTPPropertyGridItem | protected
m_pGrid | CXTPPropertyGridItem | protected
m_pInplaceButtons | CXTPPropertyGridItem | protected
m_pInplaceControls | CXTPPropertyGridItem | protected
m_pMarkupCaption | CXTPPropertyGridItem | protected
m_pMarkupDescription | CXTPPropertyGridItem | protected
m_pMarkupValue | CXTPPropertyGridItem | protected
m_pParent | CXTPPropertyGridItem | protected
m_pValueMetrics | CXTPPropertyGridItem | mutableprotected
m_strCaption | CXTPPropertyGridItem | protected
m_strDefaultValue | CXTPPropertyGridItem | protected
m_strDescription | CXTPPropertyGridItem | protected
m_strFormat | CXTPPropertyGridItem | protected
m_strLiteral | CXTPPropertyGridItem | protected
m_strMarkupTemplate | CXTPPropertyGridItem | protected
m_strMask | CXTPPropertyGridItem | protected
m_strTooltip | CXTPPropertyGridItem | protected
m_strValue | CXTPPropertyGridItem | protected
MeasureItem(LPMEASUREITEMSTRUCT lpMeasureItemStruct) | CXTPPropertyGridItem | virtual
Move(CXTPPropertyGridItem *pParent, int nIndex=-1) | CXTPPropertyGridItem |
NotifyValueChanged() | CXTPPropertyGridItem | protected
OnAfterEdit(CString &strValue) | CXTPPropertyGridItem | virtual
OnBeforeInsert() | CXTPPropertyGridItemSize | protectedvirtual
OnCancelEdit() | CXTPPropertyGridItem | virtual
OnCaptionChanged() | CXTPPropertyGridItem | protectedvirtual
OnChar(UINT nChar) | CXTPPropertyGridItem | protectedvirtual
OnConstraintsChanged() | CXTPPropertyGridItem | protectedvirtual
OnDeselect() | CXTPPropertyGridItem | protectedvirtual
OnDrawItemConstraint(CDC *pDC, CXTPPropertyGridItemConstraint *pConstraint, CRect rc, BOOL bSelected) | CXTPPropertyGridItem | virtual
OnDrawItemValue(CDC &dc, CRect rcValue) | CXTPPropertyGridItem | virtual
OnIndexChanged() | CXTPPropertyGridItem | protectedvirtual
OnInpaceControlFocus(BOOL bForward) | CXTPPropertyGridItem | protectedvirtual
OnInplaceButtonDown(CXTPPropertyGridInplaceButton *pButton) | CXTPPropertyGridItem | protectedvirtual
OnKeyDown(UINT nChar) | CXTPPropertyGridItem | protectedvirtual
OnLButtonDblClk(UINT nFlags, CPoint point) | CXTPPropertyGridItem | protectedvirtual
OnLButtonDown(UINT nFlags, CPoint point) | CXTPPropertyGridItem | protectedvirtual
OnLButtonUp(UINT nFlags, CPoint point) | CXTPPropertyGridItem | protectedvirtual
OnMarkupChanged() | CXTPPropertyGridItem | virtual
OnMergeItemConstraint(CDC *pDC, CXTPPropertyGridItemConstraint *pConstraint) | CXTPPropertyGridItem | virtual
OnRButtonDown(UINT nFlags, CPoint point) | CXTPPropertyGridItem | protectedvirtual
OnRequestEdit() | CXTPPropertyGridItem | virtual
OnSelect() | CXTPPropertyGridItem | protectedvirtual
OnValidateEdit() | CXTPPropertyGridItem | virtual
OnValueChanged(CString strValue) | CXTPPropertyGridItem | virtual
PtInValueRect(CPoint point) | CXTPPropertyGridItem | protected
RedrawItem() | CXTPPropertyGridItem |
Remove() | CXTPPropertyGridItem |
ResetValue() | CXTPPropertyGridItem | virtual
Select() | CXTPPropertyGridItem |
SelectNextConstraint() | CXTPPropertyGridItem | protected
SetAutoComplete(BOOL bAutoComplete=TRUE) | CXTPPropertyGridItem |
SetCaption(LPCTSTR lpszCaption) | CXTPPropertyGridItem |
SetConstraintEdit(BOOL bConstraintEdit=TRUE) | CXTPPropertyGridItem |
SetDefaultValue(LPCTSTR lpszDefaultValue) | CXTPPropertyGridItem |
SetDescription(LPCTSTR lpszDescription) | CXTPPropertyGridItem |
SetDropDownItemCount(int nDropDownItemCount) | CXTPPropertyGridItem |
SetEditStyle(DWORD dwEditStyle) | CXTPPropertyGridItem |
SetEditText(const CString &str) | CXTPPropertyGridItem | protectedvirtual
SetExpandable(BOOL bExpandable) | CXTPPropertyGridItem |
SetFlags(UINT nFlags) | CXTPPropertyGridItem |
SetFocusToInplaceControl() | CXTPPropertyGridItem | virtual
CXTPPropertyGridItem::SetHeight(int nHeight) | CXTPPropertyGridItem |
SetHidden(BOOL bHidden) | CXTPPropertyGridItem |
SetID(UINT nID) | CXTPPropertyGridItem |
SetItemData(DWORD_PTR dwData) | CXTPPropertyGridItem |
SetMarkupTemplate(LPCTSTR lpstrMarkupTemplate) | CXTPPropertyGridItem |
SetMask(LPCTSTR strMask, LPCTSTR strLiteral, TCHAR chPrompt=_T('_')) | CXTPPropertyGridItem |
SetMaskedText(LPCTSTR lpszMaskedText) | CXTPPropertyGridItem |
SetMultiLinesCount(int nLinesCount) | CXTPPropertyGridItem |
SetPasswordMask(TCHAR chMask=_T(' *')) | CXTPPropertyGridItem |
SetPrompt(LPCTSTR lpszPrompt) | CXTPPropertyGridItem |
SetReadOnly(BOOL bReadOnly=TRUE) | CXTPPropertyGridItem | virtual
SetSize(CSize size) | CXTPPropertyGridItemSize | virtual
SetTooltip(LPCTSTR lpstrTooltip) | CXTPPropertyGridItem |
SetVisible(BOOL bVisible) | CXTPPropertyGridItem | protectedvirtual
~CXTPPropertyGridItem() | CXTPPropertyGridItem | virtual
~CXTPPropertyGridItemSize() | CXTPPropertyGridItemSize | virtual


Toolkit Pro: Member List

CXTPCalendarMonthView Member List

This is the complete list of members for CXTPCalendarMonthView, including all inherited members.

_CalculateDateFormats(CDC *pDC) | CXTPCalendarMonthView | protected
_CalculateEventCaptionFormat(CDC *pDC) | CXTPCalendarMonthView | protected
_CalculateEventTimeFormat() | CXTPCalendarView | protectedvirtual
_CanSubjectEditor(UINT idEditCmd) const | CXTPCalendarView | protectedvirtual
_CopySelectedEvents(DWORD dwCopyFlags=0) | CXTPCalendarView | protectedvirtual
_FormatDayDate(COleDateTime dtDay, BOOL bLong) | CXTPCalendarMonthView |
_GetDayHeaderFormat(int nLevel) const | CXTPCalendarView | protectedvirtual
_GetMaxWidth(CDC *pDC, CString strFormat) const | CXTPCalendarView | protectedvirtual
_GetMaxWidthFormat(CDC *pDC, CString strFormat, BOOL bMonth) const | CXTPCalendarView | protectedvirtual
_GetSubjectEditorWnd() const | CXTPCalendarView | protectedvirtual
_GetViewDay(const COleDateTime &dtDay) const | CXTPCalendarView | virtual
_IsDragModeCopyMove(int eDragMode) const | CXTPCalendarView | protected
_ReadDefaultDateFormats() | CXTPCalendarMonthView | protected
_ReadDefaultHeaderFormats() | CXTPCalendarView | protectedvirtual
_ReadEventsFromClipboard(COleDataObject *pData, DWORD *pdwCopyFlags=NULL) | CXTPCalendarView | protectedvirtual
_RemoveYearPart(CString &strFormat) | CXTPCalendarView | protectedvirtual
_SplitDateFormat(const CString &strDateFormat, CStringArray &rarTokens) | CXTPCalendarMonthView | protected
_Undo(CXTPCalendarEvent *pEvent=NULL) | CXTPCalendarView | protectedvirtual
AddToDiscreteSelection(UINT id) | CXTPCalendarView |
AdjustLayout(CDC *pDC, const CRect &rcView, BOOL bCallPostAdjustLayout=TRUE) | CXTPCalendarMonthView | virtual
AdjustLayout2(CDC *pDC, const CRect &rcView, BOOL bCallPostAdjustLayout=TRUE) | CXTPCalendarMonthView | virtual
CalculateHeaderFormat(CDC *pDC, int nWidth, CFont *pTextFont) | CXTPCalendarView | virtual
CancelDraggingEvent() | CXTPCalendarView | virtual
CanCopy() const | CXTPCalendarView | virtual
CanCut() const | CXTPCalendarView | virtual
CanPaste() const | CXTPCalendarView | virtual
CanRedo() const | CXTPCalendarView | virtual
CanUndo() const | CXTPCalendarView | virtual
ClearDiscreteSelection() | CXTPCalendarView |
CommitDraggingEvent() | CXTPCalendarView | virtual
Copy() | CXTPCalendarView | virtual
Cut() | CXTPCalendarView | virtual
CXTPCalendarMonthView(CXTPCalendarControl *pCalendarControl) | CXTPCalendarMonthView |
CXTPCalendarView(CXTPCalendarControl *pCalendarControl) | CXTPCalendarView |
CXTPCalendarViewT(CXTPCalendarControl *pCalendarControl, XTPCalendarViewType nViewType) | CXTPCalendarViewT< CXTPCalendarMonthViewDay > | inline
CXTPCalendarWMHandler() | CXTPCalendarWMHandler |
CXTPCmdTarget() | CXTPCmdTarget |
Draw(CDC *pDC) | CXTPCalendarMonthView | virtual
Draw2(CDC *pDC) | CXTPCalendarMonthView | virtual
EmptyUndoBuffer() | CXTPCalendarView | virtual
EnableHScroll(BOOL bEnable=TRUE) | CXTPCalendarView | virtual
EnableVScroll(BOOL bEnable=TRUE) | CXTPCalendarView | virtual
EndEditSubject(XTPCalendarEndEditSubjectAction eAction, BOOL bUpdateControl=TRUE) | CXTPCalendarView | virtual
FindEventToEditByTAB(COleDateTime dtMinStart, BOOL bReverse, CXTPCalendarEvent *pAfterEvent=NULL) | CXTPCalendarView | virtual
FindLastSelectedDay() const | CXTPCalendarView |
FindViewEvent(CXTPCalendarEvent *pEvent, COleDateTime dtDay) const | CXTPCalendarView | virtual
FormatEventTime(COleDateTime dtTime) const | CXTPCalendarView | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCalendarControl() const | CXTPCalendarView |
GetCalendarOptions() const | CXTPCalendarView |
GetChildHandlerAt(int nIndex) const | CXTPCalendarView | virtual
GetChildHandlersCount() const | CXTPCalendarView | virtual
GetDayHeaderFormat() const | CXTPCalendarView | virtual
GetDiscreteSelectionCount() const | CXTPCalendarView |
GetDiscreteSelectionValue(UINT id) const | CXTPCalendarView |
GetDraggingEventNew() const | CXTPCalendarView | virtual
GetDraggingEventOrig() const | CXTPCalendarView | virtual
GetDraggingMode() const | CXTPCalendarView | virtual
GetEventCaptionFormat() const | CXTPCalendarMonthView | virtual
GetEventDurationMin() const | CXTPCalendarView | protectedvirtual
GetEventTimeWidth() const | CXTPCalendarMonthView | virtual
GetGrid() const | CXTPCalendarMonthView |
GetItemTextEventTimeMax() const | CXTPCalendarView | virtual
GetLastSelectedDate() const | CXTPCalendarView |
GetLastSelectedViewEvent() const | CXTPCalendarView |
GetNextTimeEditByTAB() const | CXTPCalendarView | virtual
GetPaintManager() const | CXTPCalendarView | virtual
GetResources() const | CXTPCalendarView | virtual
GetRowHeight() const | CXTPCalendarView | virtual
GetScrollBarInfoH(SCROLLINFO *pSI, int *pnScrollStep=NULL) const | CXTPCalendarView | inlinevirtual
GetScrollBarInfoV(SCROLLINFO *pSI) const | CXTPCalendarMonthView | virtual
GetSelectedEvents() const | CXTPCalendarView | virtual
GetSelectedViewEvents() const | CXTPCalendarView | virtual
GetSelection(COleDateTime *pBegin=NULL, COleDateTime *pEnd=NULL, BOOL *pbAllDayEvent=NULL, int *pnGroupIndex=NULL, COleDateTimeSpan *pspSelectionResolution=NULL) const | CXTPCalendarView | virtual
GetShowToolTipTimeOut() const | CXTPCalendarView | virtual
GetStartEditSubjectTimeOut() const | CXTPCalendarView | virtual
GetSubjectEditorRect() const | CXTPCalendarView | virtual
GetTheme() const | CXTPCalendarView | virtual
GetTooltipRect(const CPoint &ptHit, const XTP_CALENDAR_HITTESTINFO &hitInfo) const | CXTPCalendarView | virtual
GetViewDay(int nIndex) const | CXTPCalendarViewT< CXTPCalendarMonthViewDay > | inlinevirtual
GetViewDay_(int nIndex) const | CXTPCalendarMonthView | virtual
GetViewDayCount() const | CXTPCalendarView | virtual
GetViewDayDate(int nIndex) const | CXTPCalendarMonthView | virtual
GetViewRect() const | CXTPCalendarView |
GetViewType() const | CXTPCalendarViewT< CXTPCalendarMonthViewDay > | inlinevirtual
GetWeekDayTextIfNeed(CString *pstrText, int nWeekDay) | CXTPCalendarMonthView | virtual
HasSelectedViewEvent() const | CXTPCalendarView | virtual
HitTest(CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const | CXTPCalendarView | virtual
HitTestEx(CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const | CXTPCalendarView | virtual
IsEditingSubject() const | CXTPCalendarView | virtual
IsEditOperationDisabledNotify(XTPCalendarEditOperation eOperation, CXTPCalendarViewEvent *pEventView) const | CXTPCalendarView | protected
IsHScrollEnabled() const | CXTPCalendarView | virtual
IsInDiscreteSelection(UINT id) const | CXTPCalendarView |
IsSingleEventSelected() const | CXTPCalendarView |
IsTodayVisible() const | CXTPCalendarView | virtual
IsVScrollEnabled() const | CXTPCalendarView | virtual
KillTimer(UINT uTimerID) | CXTPCalendarView | protectedvirtual
m_arDays | CXTPCalendarView | mutableprotected
m_bDraftMode | CXTPCalendarMonthView |
m_bResetUndoBuffer | CXTPCalendarView | protected
m_bScrollH_Disabled | CXTPCalendarView | protected
m_bScrollV_Disabled | CXTPCalendarView | protected
m_bStartedClickInside | CXTPCalendarView | protected
m_cntSelChanged | CXTPCalendarView | protected
m_DayPOS_LastSelected | CXTPCalendarMonthView | protected
m_dtLightColorDateBase | CXTPCalendarMonthView | protected
m_eDraggingMode | CXTPCalendarView | protected
m_eUndoMode | CXTPCalendarView | protected
m_EventTimeFormat | CXTPCalendarView | protected
m_LastHitInfo | CXTPCalendarView | protected
m_Layout | CXTPCalendarView | protected
m_nEventCaptionFormat | CXTPCalendarMonthView | protected
m_nEventTimeWidth | CXTPCalendarMonthView | protected
m_nKeyStateTimerID | CXTPCalendarView | protected
m_nTimerID_ShowToolTip | CXTPCalendarView | protected
m_nTimerID_StartEditSubject | CXTPCalendarView | protected
m_pControl | CXTPCalendarView | protected
m_pGrid | CXTPCalendarMonthView | protected
m_pLastEvent | CXTPCalendarView | protected
m_pPrevUndoBuffer | CXTPCalendarView | protected
m_pResources | CXTPCalendarView | protected
m_pSelectedEvents | CXTPCalendarView | protected
m_ptrDraggingEventNew | CXTPCalendarView | protected
m_ptrDraggingEventOrig | CXTPCalendarView | protected
m_ptrEditingViewEvent | CXTPCalendarView | protected
m_ptStartDragging | CXTPCalendarView | protected
m_pUndoBuffer | CXTPCalendarView | protected
m_rcTooltip | CXTPCalendarView | protected
m_rcView | CXTPCalendarView | protected
m_selectedBlock | CXTPCalendarView | protected
m_spDraggingStartOffset | CXTPCalendarView | protected
m_strDayHeaderFormatDefaultLong | CXTPCalendarView | protected
m_strDayHeaderFormatDefaultMiddle | CXTPCalendarView | protected
m_strDayHeaderFormatDefaultShort | CXTPCalendarView | protected
m_strDayHeaderFormatDefaultShortest | CXTPCalendarView | protected
m_strDayHeaderFormatLong | CXTPCalendarView | protected
m_strDayHeaderFormatMiddle | CXTPCalendarView | protected
m_strDayHeaderFormatShort | CXTPCalendarView | protected
m_strDayHeaderFormatShortest | CXTPCalendarView | protected
m_strHeaderFormat | CXTPCalendarView | protected
m_strLongDateFormat | CXTPCalendarMonthView | protected
m_strSmallDateFormat | CXTPCalendarMonthView | protected
OnActivateView(BOOL bActivate, CXTPCalendarView *pActivateView, CXTPCalendarView *pInactiveView) | CXTPCalendarView | protectedvirtual
OnBeforeDestroy() | CXTPCalendarView | protectedvirtual
OnBeforeEditOperationNotify(XTPCalendarEditOperation eOperation, CXTPCalendarViewEvent *pEventView) | CXTPCalendarView | protected
OnBeforeEditOperationNotify(XTPCalendarEditOperation eOperation, CXTPCalendarViewEvents *pEventViews) | CXTPCalendarView | protected
OnBeforePasteNotify(CXTPCalendarEvent *pEvent, BOOL bPasteWillChangeExistingEvent) | CXTPCalendarView | protected
OnChar(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarView | virtual
OnDragging(CPoint point, XTP_CALENDAR_HITTESTINFO *pHitTest) | CXTPCalendarView | virtual
OnDraw(CDC *pDC) | CXTPCalendarView | virtual
OnEndDragging(CPoint point, XTP_CALENDAR_HITTESTINFO *pHitInfo) | CXTPCalendarView | virtual
OnEventChanged_InDataProvider(XTP_NOTIFY_CODE nfCode, CXTPCalendarEvent *pEvent) | CXTPCalendarView | protectedvirtual
OnInPlaceCreateEvent(LPCTSTR pcszInitialSubject) | CXTPCalendarView | protected
OnKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarMonthView | virtual
OnKeyUp(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnLButtonDblClk(UINT nFlags, CPoint point) | CXTPCalendarView | virtual
OnLButtonDown(UINT nFlags, CPoint point) | CXTPCalendarMonthView | virtual
OnLButtonUp(UINT nFlags, CPoint point) | CXTPCalendarView | virtual
OnMouseMove(UINT nFlags, CPoint point) | CXTPCalendarMonthView | virtual
OnPostAdjustLayout() | CXTPCalendarWMHandler | virtual
OnScrollEnd(int nBar) | CXTPCalendarView | inlinevirtual
OnStartDragging(CPoint point, XTP_CALENDAR_HITTESTINFO *pHitTest) | CXTPCalendarView | virtual
OnSysKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarView | virtual
OnTimer(UINT_PTR uTimerID) | CXTPCalendarView | protectedvirtual
OnUpdateEditingSubject(CString strNewSubject) | CXTPCalendarView | virtual
OnWndMsg(UINT message, WPARAM wParam, LPARAM lParam, LRESULT *pResult) | CXTPCalendarWMHandler | virtual
Paste() | CXTPCalendarView | virtual
Populate() | CXTPCalendarMonthView | virtual
ProcessDaySelection(XTP_CALENDAR_HITTESTINFO *pInfo, UINT nFlags) | CXTPCalendarView | virtual
ProcessEventSelection(XTP_CALENDAR_HITTESTINFO *pInfo, UINT nFlags) | CXTPCalendarView | virtual
Redo() | CXTPCalendarView | virtual
RedrawControl() | CXTPCalendarView | virtual
ResetCustomTimeFormat() | CXTPCalendarView |
ResetSelection() | CXTPCalendarView |
RetrieveDayEvents(CXTPCalendarResource *pRC, COleDateTime dtDay) | CXTPCalendarView | virtual
ScrollH(int nPos, int nPos_raw) | CXTPCalendarView | inlinevirtual
ScrollV(int nPos, int nPos_raw) | CXTPCalendarMonthView | virtual
SelectDay(CXTPCalendarViewDay *pDay, int nGroupIndex=0) | CXTPCalendarView | virtual
SelectDay(COleDateTime dtSelDay, int nGroupIndex=0) | CXTPCalendarView | virtual
SelectDays(COleDateTime dtNewSel) | CXTPCalendarView | virtual
SelectEvent(CXTPCalendarEvent *pEvent, BOOL bSelect=TRUE) | CXTPCalendarView | virtual
SelectionContains(COleDateTime date, int nGroupIndex=-1, BOOL *pbAllDaySelection=NULL) | CXTPCalendarView |
SelectViewEvent(CXTPCalendarViewEvent *pViewEvent, BOOL bSelect=TRUE) | CXTPCalendarView |
SendNotification(XTP_NOTIFY_CODE EventCode, WPARAM wParam=0, LPARAM lParam=0) | CXTPCalendarView | protectedvirtual
SetCustomTimeFormat(const CString &strFormat) | CXTPCalendarView |
SetDayHeaderFormat(LPCTSTR sFmt) | CXTPCalendarView | virtual
SetDayHeaderFormatLong(LPCTSTR pcszCustomFormat) | CXTPCalendarView | virtual
SetDayHeaderFormatMiddle(LPCTSTR pcszCustomFormat) | CXTPCalendarView | virtual
SetDayHeaderFormatShort(LPCTSTR pcszCustomFormat) | CXTPCalendarView | virtual
SetDayHeaderFormatShortest(LPCTSTR pcszCustomFormat) | CXTPCalendarView | virtual
SetDraggingEvent(CXTPCalendarEvent *pEventOrig) | CXTPCalendarView | virtual
SetLongDayHeaderFormat(LPCTSTR pcszCustomFormat) | CXTPCalendarMonthView |
SetResources(CXTPCalendarResources *pResources) | CXTPCalendarView | virtual
SetSelection(const COleDateTime &dtBegin, const COleDateTime &dtEnd, BOOL bAllDayEvent=FALSE, int nGroupIndex=0) | CXTPCalendarView |
SetSmallDayHeaderFormat(LPCTSTR pcszCustomFormat) | CXTPCalendarMonthView |
SetTimer(UINT uTimeOut_ms) | CXTPCalendarView | protectedvirtual
ShowDay(const COleDateTime &date, BOOL bSelect=TRUE) | CXTPCalendarMonthView | virtual
ShowToolTip(BOOL bShow=TRUE) | CXTPCalendarView | virtual
StartEditNewEventInplace(LPCTSTR pcszInitialSubject) | CXTPCalendarView | virtual
StartEditSubject(CXTPCalendarViewEvent *pViewEvent) | CXTPCalendarView | virtual
TBase typedef | CXTPCalendarMonthView |
Undo() | CXTPCalendarView | virtual
UnselectAllEvents() | CXTPCalendarView | virtual
UpdateNextTimeEditByTAB(COleDateTime dtNext, BOOL bReverse, BOOL bReset=FALSE) | CXTPCalendarView | virtual
~CXTPCalendarMonthView() | CXTPCalendarMonthView | virtual
~CXTPCalendarView() | CXTPCalendarView | virtual
~CXTPCalendarViewT() | CXTPCalendarViewT< CXTPCalendarMonthViewDay > | inlinevirtual


Toolkit Pro: Member List

CXTPDatePickerList Member List

This is the complete list of members for CXTPDatePickerList, including all inherited members.

Create(CRect rcList) | CXTPDatePickerList |
CXTPDatePickerList(CXTPDatePickerControl *pControl, COleDateTime dtStartMonth) | CXTPDatePickerList |
GetListSize() const | CXTPDatePickerList | protected
GetMonthInterval() const | CXTPDatePickerList |
IsSelected(int nX, CRect rcItem) const | CXTPDatePickerList | protected
m_dtMiddleMonth | CXTPDatePickerList | protected
m_dtSelMonth | CXTPDatePickerList | protected
m_dtStartMonth | CXTPDatePickerList | protected
m_nItemsAbove | CXTPDatePickerList | protected
m_nItemsBelow | CXTPDatePickerList | protected
m_pControl | CXTPDatePickerList | protected
m_rcListControl | CXTPDatePickerList | protected
ScrollDown(int nCount=1) | CXTPDatePickerList |
ScrollUp(int nCount=1) | CXTPDatePickerList |
~CXTPDatePickerList() | CXTPDatePickerList | virtual


Toolkit Pro: Member List

CXTPGridThemeVisualStudio2022 Member List

This is the complete list of members for CXTPGridThemeVisualStudio2022, including all inherited members.

CalcColumnHeight(CDC *pDC, CXTPGridColumn *pColumn, int nTotalWidth=0) | CXTPGridPaintManager | protectedvirtual
CalculateRowHeight(CDC *pDC, const CString &strText, int nMaxWidth, BOOL bWordBreak=TRUE) | CXTPGridPaintManager | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPGridPaintManager() | CXTPGridPaintManager |
CXTPGridThemeOffice2013() | CXTPGridThemeOffice2013 |
CXTPGridThemeVisualStudio2022() | CXTPGridThemeVisualStudio2022 |
DrawBitmap(CDC *pDC, CXTPGridControl *pControl, CRect rcColumn, int iImage) | CXTPGridPaintManager | virtual
DrawCollapsedBitmap(CDC *pDC, const CXTPGridRow *pRow, CRect &rcBitmap) | CXTPGridThemeOffice2013 | virtual
DrawColumn(CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn, BOOL bDrawExternal=FALSE, int nShadowWidth=0) | CXTPGridPaintManager | virtual
DrawColumnBackground(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, BOOL &bColumnPressed, BOOL &bDraggingFromHeader, CXTPGridHeader *pHeader=NULL) | CXTPGridThemeOffice2013 | virtual
DrawColumnFooter(CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn) | CXTPGridPaintManager | virtual
DrawColumnFooterDivider(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn) | CXTPGridPaintManager | virtual
DrawColumnIcon(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, CRect rcIcon, int iIcon) | CXTPGridPaintManager | virtual
DrawColumnText(CDC *pDC, CRect rcText, CString strCaption, int nHeaderAlignment, BOOL bIsHeader, BOOL bColumnPressed) | CXTPGridThemeOffice2013 | virtual
DrawConnector(CDC *pDC, CPoint ptFrom, CPoint ptTo) | CXTPGridPaintManager |
DrawFocusedRow(CDC *pDC, CRect rcRow) | CXTPGridThemeOffice2013 | virtual
DrawFreezeColsDivider(CDC *pDC, const CRect &rc, CXTPGridControl *pControl, CXTPGridRow *pRow=NULL) | CXTPGridPaintManager | virtual
DrawGlyph(CDC *pDC, CRect rcColumn, int iImage) | CXTPGridPaintManager | virtual
DrawGrid(CDC *pDC, XTPGridOrientation orientation, CRect rcGrid) | CXTPGridPaintManager | virtual
DrawGridPattern(CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush) | CXTPGridPaintManager | protectedvirtual
DrawGridPattern(CDC *pDC, CXTPBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush) | CXTPGridPaintManager | protectedvirtual
DrawGridPattern(CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr) | CXTPGridPaintManager | protectedvirtual
DrawGroupRow(CDC *pDC, CXTPGridGroupRow *pRow, CRect rcRow, XTP_GRIDRECORDITEM_METRICS *pMetrics) | CXTPGridThemeOffice2013 | virtual
DrawHorizontalLine(CDC *pDC, int xPos, int yPos, int cx, COLORREF clr) | CXTPGridPaintManager |
DrawInplaceButton(CDC *pDC, CXTPGridInplaceButton *pButton) | CXTPGridPaintManager | virtual
DrawInplaceButtonFrame(CDC *pDC, CXTPGridInplaceButton *pButton) | CXTPGridPaintManager | protectedvirtual
DrawInplaceButtonIcon(CDC *pDC, CXTPGridInplaceButton *pButton) | CXTPGridPaintManager | protectedvirtual
DrawInplaceComboButton(CDC *pDC, CRect *pRc) | CXTPGridPaintManager | virtual
DrawInplaceExpandButton(CDC *pDC, CRect *pRc) | CXTPGridPaintManager | virtual
DrawInplaceSpinButton(CDC *pDC, CRect *pRc) | CXTPGridPaintManager | virtual
DrawItemBitmap(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CRect &rcItem, int nImage) | CXTPGridPaintManager | virtual
DrawItemCaption(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics) | CXTPGridPaintManager | virtual
DrawItemControl(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CXTPGridRecordItemControl *pControl, CRect &rcItem) | CXTPGridPaintManager | virtual
DrawLink(int *pnCurrDrawPos, XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CXTPGridHyperlink *pHyperlink, CString strText, CRect rcLink, int nFlag, BOOL bTrim=FALSE) | CXTPGridPaintManager | protectedvirtual
DrawMultiLineText(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, BOOL bWordBreak=TRUE) | CXTPGridPaintManager | protectedvirtual
DrawNoGroupByText(CDC *pDC, CRect rcItem) | CXTPGridPaintManager | virtual
DrawRowNumber(CDC *pDC, CRect rcNumber, CXTPGridRow *pRow) | CXTPGridPaintManager | virtual
DrawSectionDivider(CDC *pDC, const CRect &rc, XTPGridSectionDividerPosition dividerPosition, XTPGridSectionDividerStyle dividerStyle, CXTPPaintManagerColor dividerColor) | CXTPGridPaintManager |
DrawShellIcon(CDC *pDC, CRect rcColumn, int iImage) | CXTPGridPaintManager | virtual
DrawSingleLineText(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nStartPos, int nEndPos, int nActualWidth) | CXTPGridPaintManager | protectedvirtual
DrawString(int *pnCurrDrawPos, CDC *pDC, const CString &strDraw, CRect rcDraw, UINT nFormat) | CXTPGridPaintManager | protectedvirtual
DrawTextLine(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nFlag, int &nCharCounter, int &nHyperlinkCounter) | CXTPGridPaintManager | protectedvirtual
DrawTreeStructure(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CRect rcItem, CSize sizeGlyph) | CXTPGridPaintManager | virtual
DrawTriangle(CDC *pDC, CRect rcTriangle, BOOL bToDown, BOOL bDraggingFromHeader, int nShadowWidth, BOOL bColumnPressed) | CXTPGridThemeOffice2013 | virtual
DrawVerticalLine(CDC *pDC, int xPos, int yPos, int cy, COLORREF clr) | CXTPGridPaintManager |
DrawVerticalTimeLineMarker(CDC *pDC, int xPos, CXTPGridControl *pControl, COLORREF color=RGB(0, 255, 0)) | CXTPGridPaintManager | virtual
EnablePreviewMode(BOOL bIsPreviewMode) | CXTPGridPaintManager |
FillFooter(CDC *pDC, CRect rcFooter) | CXTPGridPaintManager | virtual
FillGroupByControl(CDC *pDC, CRect &rcGroupBy) | CXTPGridPaintManager | virtual
FillGroupRowMetrics(CXTPGridGroupRow *pRow, XTP_GRIDRECORDITEM_METRICS *pMetrics, BOOL bPrinting) | CXTPGridThemeOffice2013 | virtual
FillHeaderControl(CDC *pDC, CRect rcHeader) | CXTPGridPaintManager | virtual
FillIndent(CDC *pDC, CRect rcRow) | CXTPGridPaintManager | virtual
FillItemShade(CDC *pDC, CRect rcItem) | CXTPGridPaintManager | virtual
FillRow(CDC *pDC, CXTPGridRow *pRow, CRect rcRow) | CXTPGridPaintManager | virtual
FindRowAdjacentToMerged(const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, BOOL bUpward) | CXTPGridPaintManager |
FindRowAdjacentToMergedEx(const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, int &nAdjRowIndex, BOOL bUpward) | CXTPGridPaintManager |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetColumnOffice2007CustomThemeBaseColor() const | CXTPGridPaintManager |
GetColumnStyle() const | CXTPGridPaintManager |
GetControlBackColor(CXTPGridControl *pControl) | CXTPGridPaintManager | virtual
GetFooterHeight(CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0) | CXTPGridPaintManager | virtual
GetFreezeColsDividerStyle() const | CXTPGridPaintManager |
GetGlyphs() const | CXTPGridPaintManager |
GetHeaderHeight() | CXTPGridPaintManager | virtual
GetHeaderHeight(CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0) | CXTPGridPaintManager | virtual
GetItemHeight(XTP_GRIDRECORDITEM_DRAWARGS &drawArgs, int nWidth) | CXTPGridPaintManager |
GetMaxPreviewLines() | CXTPGridPaintManager |
GetPreviewItemHeight(CDC *pDC, CXTPGridRow *pRow, int nWidth, int nHeight) | CXTPGridPaintManager | virtual
GetPreviewLinesCount(CDC *pDC, CRect &rcText, const CString &strText) | CXTPGridPaintManager |
GetRowHeight(CDC *pDC, CXTPGridRow *pRow) | CXTPGridThemeOffice2013 | virtual
GetRowHeight(CDC *pDC, CXTPGridRow *pRow, int nTotalWidth) | CXTPGridThemeOffice2013 | virtual
GetRowHeightEx(CDC *pDC, CXTPGridRow *pRow, int nTotalWidth, const BOOL firstLevel=TRUE) | CXTPGridPaintManager |
GetSectionDividerHeight(XTPGridFixedRowsDividerStyle dividerStyle) | CXTPGridPaintManager |
GetTextFont() | CXTPGridPaintManager |
IsColumHotTrackingEnabled() const | CXTPGridPaintManager | virtual
IsColumnPlusMinusSign() const | CXTPGridPaintManager |
IsColumnWidthWYSIWYG() const | CXTPGridPaintManager |
IsDrawGridForEmptySpace() const | CXTPGridPaintManager |
IsFixedInplaceButtonHeight() const | CXTPGridPaintManager |
IsFixedRowHeight() const | CXTPGridPaintManager |
IsGridVisible(BOOL bVertical) const | CXTPGridPaintManager |
IsGridVisible(XTPGridOrientation orientation) const | CXTPGridPaintManager |
IsLastColumnWidthWYSIWYG() const | CXTPGridPaintManager |
IsPreviewMode() const | CXTPGridPaintManager |
IsPrintGroupRowIcon() const | CXTPGridPaintManager |
IsShowWYSIWYGMarkers() const | CXTPGridPaintManager |
IsUseDropMarker() const | CXTPGridPaintManager |
LoadGlyphs() | CXTPGridThemeOffice2013 | virtual
m_arStartCol | CXTPGridPaintManager |
m_bAllowMergeCells | CXTPGridPaintManager |
m_bBaseTreeIndent | CXTPGridPaintManager |
m_bCleanTooltip | CXTPGridPaintManager |
m_bColumnPlusMinusSign | CXTPGridPaintManager | protected
m_bColumnWidthWYSIWYG | CXTPGridPaintManager | protected
m_bCompactText | CXTPGridPaintManager |
m_bDrawGridForEmptySpace | CXTPGridPaintManager | protected
m_bFixedInplaceButtonHeight | CXTPGridPaintManager | protected
m_bFixedRowHeight | CXTPGridPaintManager | protected
m_bForceDynamicMarkupForCell | CXTPGridPaintManager |
m_bForceShowDropMarker | CXTPGridPaintManager |
m_bForceShowTooltip | CXTPGridPaintManager |
m_bGrayIfDisable | CXTPGridPaintManager |
m_bGroupRowTextBold | CXTPGridPaintManager |
m_bHideSelection | CXTPGridPaintManager |
m_bHotTracking | CXTPGridPaintManager |
m_bInvertColumnOnClick | CXTPGridPaintManager |
m_bIsPreviewMode | CXTPGridPaintManager | protected
m_bLastColumnWidthWYSIWYG | CXTPGridPaintManager | protected
m_bMakeUpper | CXTPGridPaintManager |
m_bMoveScrollbarOnFixedColumnsIndent | CXTPGridPaintManager |
m_bPrintGroupRowIcon | CXTPGridPaintManager | protected
m_bPrintPageRectangle | CXTPGridPaintManager |
m_bPrintSortTriangle | CXTPGridPaintManager |
m_bPrintVirtualPageNumber | CXTPGridPaintManager |
m_bPrintWatermark | CXTPGridPaintManager |
m_bRecOrRowNum | CXTPGridPaintManager |
m_bRevertAlignment | CXTPGridPaintManager |
m_bShadeGroupHeadings | CXTPGridPaintManager |
m_bShadeSortColumn | CXTPGridPaintManager |
m_bShowLockIcon | CXTPGridPaintManager |
m_bShowNonActiveInPlaceButton | CXTPGridPaintManager |
m_bShowWYSIWYGMarkers | CXTPGridPaintManager | protected
m_bSortTriangleOffsetFromRight | CXTPGridPaintManager |
m_bThemedInplaceButtons | CXTPGridPaintManager |
m_bUseAlternativeBackground | CXTPGridPaintManager |
m_bUseDropMarker | CXTPGridPaintManager |
m_bUseEditTextAlignment | CXTPGridPaintManager |
m_bUseGroupRowSelectionState | CXTPGridPaintManager |
m_bUseShellIcon | CXTPGridPaintManager |
m_clrAlternativeBackground | CXTPGridPaintManager |
m_clrBoldText | CXTPGridPaintManager |
m_clrBoldTextHighlight | CXTPGridPaintManager |
m_clrBtnFace | CXTPGridPaintManager |
m_clrBtnFacePressed | CXTPGridPaintManager |
m_clrBtnText | CXTPGridPaintManager |
m_clrCaptionText | CXTPGridPaintManager |
m_clrCaptionTextPressed | CXTPGridPaintManager |
m_clrColumnOffice2007CustomTheme | CXTPGridPaintManager |
m_clrConnector | CXTPGridPaintManager |
m_clrControlBack | CXTPGridPaintManager |
m_clrControlDark | CXTPGridPaintManager |
m_clrControlLightLight | CXTPGridPaintManager |
m_clrDisableBitmapDarkest | CXTPGridPaintManager |
m_clrDisableBitmapLightest | CXTPGridPaintManager |
m_clrFormulaSubSum | CXTPGridPaintManager |
m_clrFormulaSum | CXTPGridPaintManager |
m_clrFreezeColsDivider | CXTPGridPaintManager |
m_clrGlyph | CXTPGridThemeOffice2013 |
m_clrGlyphBorder | CXTPGridThemeOffice2013 |
m_clrGlyphContract | CXTPGridThemeOffice2013 |
m_clrGlyphExpand | CXTPGridThemeOffice2013 |
m_clrGlyphHighlight | CXTPGridThemeOffice2013 |
m_clrGradientColumnSeparator | CXTPGridPaintManager |
m_clrGradientColumnShadow | CXTPGridPaintManager |
m_clrGroupBoxBack | CXTPGridPaintManager |
m_clrGroupRowText | CXTPGridPaintManager |
m_clrGroupShadeBack | CXTPGridPaintManager |
m_clrGroupShadeBorder | CXTPGridPaintManager |
m_clrGroupShadeText | CXTPGridPaintManager |
m_clrHeaderControl | CXTPGridPaintManager |
m_clrHighlight | CXTPGridPaintManager |
m_clrHighlightText | CXTPGridPaintManager |
m_clrHotDivider | CXTPGridPaintManager |
m_clrIndentControl | CXTPGridPaintManager |
m_clrItemShade | CXTPGridPaintManager |
m_clrPreviewText | CXTPGridPaintManager |
m_clrSelectedRow | CXTPGridPaintManager |
m_clrSelectedRowText | CXTPGridPaintManager |
m_clrWindowText | CXTPGridPaintManager |
m_columnStyle | CXTPGridPaintManager | protected
m_crlNoGroupByText | CXTPGridPaintManager |
m_grcGradientColumn | CXTPGridPaintManager |
m_grcGradientColumnHot | CXTPGridPaintManager |
m_grcGradientColumnPushed | CXTPGridPaintManager |
m_iRecOrRowStart | CXTPGridPaintManager |
m_nBaseParentRecordIndent | CXTPGridPaintManager |
m_nFixedColumnsIndent | CXTPGridPaintManager |
m_nFooterHeight | CXTPGridPaintManager | protected
m_nFreezeColsDividerStyle | CXTPGridPaintManager | protected
m_nGridLineStylePreviousH | CXTPGridPaintManager | protected
m_nGridLineStylePreviousV | CXTPGridPaintManager | protected
m_nGroupGridLineHeight | CXTPGridPaintManager | protected
m_nGroupGridLineStyle | CXTPGridPaintManager | protected
m_nHeaderHeight | CXTPGridPaintManager | protected
m_nMaxPreviewLines | CXTPGridPaintManager | protected
m_nResizingWidth | CXTPGridPaintManager | protected
m_nRowHeight | CXTPGridPaintManager | protected
m_nRowHeightDefault | CXTPGridPaintManager |
m_nTextIndentForGroupRowsWithNoIcon | CXTPGridPaintManager |
m_nTreeColumnLineLength | CXTPGridPaintManager |
m_nTreeIndent | CXTPGridPaintManager |
m_nTreeStructureStyle | CXTPGridPaintManager |
m_nTreeTextIndent | CXTPGridPaintManager |
m_nTreeTextIndentGroupRow | CXTPGridPaintManager |
m_nTreeTextIndentRowChildren | CXTPGridPaintManager |
m_nTreeTextIndentRowParent | CXTPGridPaintManager |
m_pControl | CXTPGridPaintManager | protected
m_pGlyphs | CXTPGridPaintManager | protected
m_pHyperlinkHoverStyle | CXTPGridPaintManager |
m_pHyperlinkStyle | CXTPGridPaintManager |
m_pMarkupUIElement_NoGroupBy | CXTPGridPaintManager | protected
m_PrintPageWidth | CXTPGridPaintManager |
m_rcPreviewIndent | CXTPGridPaintManager |
m_RecordNumberWidth | CXTPGridPaintManager |
m_strCollapse | CXTPGridPaintManager |
m_strDecreasing | CXTPGridPaintManager |
m_strExpand | CXTPGridPaintManager |
m_strIncreasing | CXTPGridPaintManager |
m_strMarkupUIElement_NoGroupBy | CXTPGridPaintManager | protected
m_strNoFieldsAvailable | CXTPGridPaintManager |
m_strNoGroupBy | CXTPGridPaintManager |
m_strNoItems | CXTPGridPaintManager |
m_strSortBy | CXTPGridPaintManager |
m_szGlyph | CXTPGridPaintManager | protected
m_themeButton | CXTPGridPaintManager | protected
m_themeCombo | CXTPGridPaintManager | protected
m_themeHeader | CXTPGridPaintManager | protected
m_themeSpin | CXTPGridPaintManager | protected
m_treeStructureStyle | CXTPGridPaintManager |
m_xtpBrushGroupGridLineStyle | CXTPGridPaintManager | protected
m_xtpBrushHorizontalGrid | CXTPGridPaintManager | protected
m_xtpBrushTreeStructure | CXTPGridPaintManager | protected
m_xtpBrushVeriticalGrid | CXTPGridPaintManager | protected
m_xtpFontBoldText | CXTPGridPaintManager |
m_xtpFontCaption | CXTPGridPaintManager |
m_xtpFontPreview | CXTPGridPaintManager |
m_xtpFontText | CXTPGridPaintManager |
OnDrawAction(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs) | CXTPGridPaintManager | virtual
RecalcTotalHightOfMergedRows(CXTPGridColumns *pColumns, CDC *pDC, CXTPGridRow *pRow, int nRowHeight, int nTotalWidth) | CXTPGridPaintManager |
RefreshMetrics() | CXTPGridThemeVisualStudio2022 | virtual
SetCaptionFont(LOGFONT &lf) | CXTPGridPaintManager |
SetColumnOffice2007CustomThemeBaseColor(COLORREF clrBaseColor) | CXTPGridPaintManager |
SetColumnPlusMinusSign(BOOL bDraw) | CXTPGridPaintManager |
SetColumnStyle(XTPGridColumnStyle columnStyle) | CXTPGridPaintManager |
SetColumnWidthWYSIWYG(BOOL bColumnWidthWYSIWYG) | CXTPGridPaintManager |
SetDrawGridForEmptySpace(BOOL bDrawGrid) | CXTPGridPaintManager |
SetFixedRowHeight(BOOL bFixedRowHeight) | CXTPGridPaintManager |
SetFreezeColsDividerStyle(int nStyle) | CXTPGridPaintManager |
SetGridControl(CXTPGridControl *pControl) | CXTPGridPaintManager | virtual
SetHeaderHeight(int nHeight) | CXTPGridPaintManager | virtual
SetInplaceButtonHeight(BOOL bFixedInplaceButtonHeight) | CXTPGridPaintManager |
SetLastColumnWidthWYSIWYG(BOOL bColumnWidthWYSIWYG) | CXTPGridPaintManager |
SetMaxPreviewLines(int nMaxLines) | CXTPGridPaintManager |
SetPreviewIndent(int nLeft, int nTop, int nRight, int nBottom) | CXTPGridPaintManager |
SetPrintGroupRowIcon(BOOL bDraw) | CXTPGridPaintManager |
SetTextFont(LOGFONT &lf) | CXTPGridPaintManager |
ShowWYSIWYGMarkers(BOOL bSet) | CXTPGridPaintManager |
~CXTPGridPaintManager() | CXTPGridPaintManager | virtual


Toolkit Pro: XTPCalendarCaptionBarNativeWindows11Theme.h Source File

  • Source
  • Calendar
  • CaptionBar
  • Themes
XTPCalendarCaptionBarNativeWindows11Theme.h
Go to the documentation of this file.
1
22#if !defined(__XTPCALENDARCAPTIONBARNATIVEWINDOWS11THEME_H__)
23# define __XTPCALENDARCAPTIONBARNATIVEWINDOWS11THEME_H__
24
25# if _MSC_VER > 1000
26# pragma once
27# endif // _MSC_VER > 1000
28
29# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
30
36class _XTP_EXT_CLASS CXTPCalendarCaptionBarNativeWindows11Theme
37 : public CXTPCalendarCaptionBarOffice2013Theme
38{
39public:
48 CXTPCalendarCaptionBarNativeWindows11Theme(CXTPCalendarCaptionBarTheme* pTheme = NULL);
49
56 virtual ~CXTPCalendarCaptionBarNativeWindows11Theme();
57};
58
59# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
60#endif // !defined(__XTPCALENDARCAPTIONBARNATIVEWINDOWS11THEME_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCalendarCaptionBarNativeWindows11Theme
CXTPCalendarCaptionBarNativeWindows11Theme is a CXTPCalendarCaptionBarOffice2013Theme derived class t...
Definition XTPCalendarCaptionBarNativeWindows11Theme.h:38
CXTPCalendarCaptionBarNativeWindows11Theme::~CXTPCalendarCaptionBarNativeWindows11Theme
virtual ~CXTPCalendarCaptionBarNativeWindows11Theme()
Default paint manager destructor.
CXTPCalendarCaptionBarNativeWindows11Theme::CXTPCalendarCaptionBarNativeWindows11Theme
CXTPCalendarCaptionBarNativeWindows11Theme(CXTPCalendarCaptionBarTheme *pTheme=NULL)
Default paint manager constructor.
CXTPCalendarCaptionBarOffice2013Theme
CXTPCalendarCaptionBarOffice2013Theme is a CXTPCalendarCaptionBarOffice2003Theme derived class that r...
Definition XTPCalendarCaptionBarOffice2013Theme.h:38
CXTPCalendarCaptionBarTheme
This class CalendarCaptionBar control drawing, user interaction logic and interaction logic with atta...
Definition XTPCalendarCaptionBarTheme.h:48


Toolkit Pro: Member List

CXTPDialogScrollBarContainer< Parent > Member List

This is the complete list of members for CXTPDialogScrollBarContainer< Parent >, including all inherited members.

CreateScrollBarCtrl(DWORD dwStyle, UINT nID) | CXTPScrollBarContainer< Parent > | inline
CXTPDialogScrollBarContainer() | CXTPDialogScrollBarContainer< Parent > | inlineprotected
CXTPDialogScrollBarContainer(LPCTSTR lpszTemplateName, CWnd *pParentWnd=NULL) | CXTPDialogScrollBarContainer< Parent > | inlineexplicitprotected
CXTPDialogScrollBarContainer(UINT nIDTemplate, CWnd *pParentWnd=NULL) | CXTPDialogScrollBarContainer< Parent > | inlineexplicitprotected
CXTPScrollBarContainer() | CXTPScrollBarContainer< Parent > | inlineprotected
EnableScrollBar(int nSBFlags, UINT nArrowFlags=ESB_ENABLE_BOTH) | CXTPScrollBarContainer< Parent > | inline
GetScrollBarCtrl(int nBar) const | CXTPScrollBarContainer< Parent > | inlinevirtual
OptimizeChildrenClipping() | CXTPScrollBarContainer< Parent > | inline
RefreshScrollBarMetrics() | CXTPScrollBarContainer< Parent > | inline
SetScrollBarClass(CRuntimeClass *pClass=NULL) | CXTPScrollBarContainer< Parent > | inline
SetScrollBarTheme(XTPScrollBarTheme theme) | CXTPScrollBarContainer< Parent > | inline
ShowScrollBar(UINT nBar, BOOL bShow=TRUE) | CXTPScrollBarContainer< Parent > | inline


Toolkit Pro: Member List

CXTPNotifyConnection Member List

This is the complete list of members for CXTPNotifyConnection, including all inherited members.

Advise(XTP_NOTIFY_CODE dwNotifyCode, CXTPNotifySinkBase *pSink) | CXTPNotifyConnection |
CXTPCmdTarget() | CXTPCmdTarget |
CXTPNotifyConnection() | CXTPNotifyConnection |
FindConnection(XTP_CONNECTION_ID ConnectionID) | CXTPNotifyConnection | protected
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetDataLock() | CXTPNotifyConnection | protectedvirtual
m_arrConnections | CXTPNotifyConnection | protected
m_arrSendQueueCache | CXTPNotifyConnection | protected
m_emptyLocker | CXTPNotifyConnection | protected
m_nSendQueueCacheSize | CXTPNotifyConnection | protected
RemoveAll() | CXTPNotifyConnection |
SendEvent(XTP_NOTIFY_CODE dwNotifyCode, WPARAM wParam, LPARAM lParam, DWORD dwFlags=0) | CXTPNotifyConnection |
Unadvise(XTP_CONNECTION_ID ConnectionID) | CXTPNotifyConnection |
~CXTPNotifyConnection() | CXTPNotifyConnection | virtual


Toolkit Pro: Member List

CXTPRibbonCustomizeQuickAccessPage Member List

This is the complete list of members for CXTPRibbonCustomizeQuickAccessPage, including all inherited members.

AddCategories(UINT nIDResource, BOOL bListSubItems=FALSE) | CXTPRibbonCustomizeQuickAccessPage |
AddCategories(CXTPControls *pControls) | CXTPRibbonCustomizeQuickAccessPage |
AddCategory(LPCTSTR strCategory, CMenu *pMenu, BOOL bListSubItems=FALSE) | CXTPRibbonCustomizeQuickAccessPage |
AdjustResizeRect(CSize &rcWindow) | CXTPResize | protectedvirtual
AutoLoadPlacement(LPCTSTR pszSection) | CXTPResize |
CResizeItemArray typedef | CXTPResize | protected
CXTPPropertyPage() | CXTPPropertyPage |
CXTPPropertyPage(UINT nIDTemplate, UINT nIDCaption=0) | CXTPPropertyPage |
CXTPPropertyPage(LPCTSTR lpszTemplateName, UINT nIDCaption=0) | CXTPPropertyPage |
CXTPResize(CWnd *pWnd, const UINT nFlags=0) | CXTPResize |
CXTPRibbonCustomizeQuickAccessPage(CXTPCustomizeSheet *pSheet, UINT nIDTemplate=(UINT) -1) | CXTPRibbonCustomizeQuickAccessPage |
CXTPRibbonCustomizeQuickAccessPage(CXTPCommandBars *pCommandBars) | CXTPRibbonCustomizeQuickAccessPage |
Defer(HDWP &hdwp, CXTPResizeItem *pItem, int dx, int dy) | CXTPResize | protectedvirtual
GetCaption() const | CXTPPropertyPage |
GetControls(LPCTSTR strCategory) | CXTPRibbonCustomizeQuickAccessPage |
GetMinMaxInfo(MINMAXINFO *pMMI) | CXTPResize | protected
GetRibbonBar() | CXTPRibbonCustomizeQuickAccessPage |
HasFlag(XTPResize eFlag) | CXTPResize | protected
Init() | CXTPResize | protectedvirtual
InsertCategory(LPCTSTR strCategory, int nIndex=-1) | CXTPRibbonCustomizeQuickAccessPage |
LoadPlacement(LPCTSTR pszSection) | CXTPResize |
m_arrCategories | CXTPRibbonCustomizeQuickAccessPage | protected
m_arrItems | CXTPResize | protected
m_bModified | CXTPPropertyPage | protected
m_bShowQuickAccessBelow | CXTPRibbonCustomizeQuickAccessPage |
m_dwData | CXTPPropertyPage |
m_lstCategories | CXTPRibbonCustomizeQuickAccessPage |
m_lstCommands | CXTPRibbonCustomizeQuickAccessPage |
m_lstQuickAccess | CXTPRibbonCustomizeQuickAccessPage |
m_nFlagsXX | CXTPResize | protected
m_pCommandBars | CXTPRibbonCustomizeQuickAccessPage | protected
m_pSheet | CXTPRibbonCustomizeQuickAccessPage | protected
m_pWnd | CXTPResize | protected
m_scSizeIcon | CXTPResize | protected
m_strSection | CXTPResize | protected
m_szInitWindow | CXTPResize | protected
m_szMax | CXTPResize | protected
m_szMin | CXTPResize | protected
m_szWindow | CXTPResize | protected
Offset(CPoint ptOffset) | CXTPResize | protected
RefreshQuickAccessList() | CXTPRibbonCustomizeQuickAccessPage | protected
RemoveAllControls() | CXTPResize | protected
RemoveResize(UINT nID) | CXTPResize | protected
Reset() | CXTPResize | protected
SavePlacement(LPCTSTR pszSection) | CXTPResize |
SetCaption(LPCTSTR lpszCaption) | CXTPPropertyPage |
SetFlag(XTPResize eFlag) | CXTPResize | protected
SetMaxSize(CSize &sz) | CXTPResize |
SetMinSize(CSize &sz) | CXTPResize |
SetResize(UINT nID, XTP_RESIZE left, XTP_RESIZE top, XTP_RESIZE right, XTP_RESIZE bottom) | CXTPResize |
SetResize(UINT nID, const XTP_RESIZERECT &rrcSizing) | CXTPResize |
SetResize(UINT nID, HWND hWnd, const XTP_RESIZERECT &rrcSizing) | CXTPResize |
SetResize(UINT nID, HWND hWnd, const XTP_RESIZEPOINT &rpTopLeft, const XTP_RESIZEPOINT &rpBottomRight) | CXTPResize |
SetResize(UINT nID, const XTP_RESIZEPOINT &rpTopLeft, const XTP_RESIZEPOINT &rpBottomRight) | CXTPResize |
SetResize(CWnd *pWnd, const CXTPResizeRect &rrcSizing, CRect rcWindow) | CXTPResize | protected
Size() | CXTPResize | protectedvirtual
UpdateControlRect(CWnd *pWnd) | CXTPResize | protected
UpdatePage(void) | CXTPRibbonCustomizeQuickAccessPage | virtual
~CXTPPropertyPage() | CXTPPropertyPage |
~CXTPResize() | CXTPResize | virtual
~CXTPRibbonCustomizeQuickAccessPage() | CXTPRibbonCustomizeQuickAccessPage |


Toolkit Pro: Member List

CXTPGridThemeExplorer Member List

This is the complete list of members for CXTPGridThemeExplorer, including all inherited members.

CalcColumnHeight(CDC *pDC, CXTPGridColumn *pColumn, int nTotalWidth=0) | CXTPGridPaintManager | protectedvirtual
CalculateRowHeight(CDC *pDC, const CString &strText, int nMaxWidth, BOOL bWordBreak=TRUE) | CXTPGridPaintManager | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPGridPaintManager() | CXTPGridPaintManager |
CXTPGridThemeExplorer() | CXTPGridThemeExplorer |
DrawBitmap(CDC *pDC, CXTPGridControl *pControl, CRect rcColumn, int iImage) | CXTPGridPaintManager | virtual
DrawCollapsedBitmap(CDC *pDC, const CXTPGridRow *pRow, CRect &rcBitmap) | CXTPGridPaintManager | virtual
DrawColumn(CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn, BOOL bDrawExternal=FALSE, int nShadowWidth=0) | CXTPGridPaintManager | virtual
DrawColumnBackground(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, BOOL &bColumnPressed, BOOL &bDraggingFromHeader, CXTPGridHeader *pHeader=NULL) | CXTPGridThemeExplorer | virtual
DrawColumnFooter(CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn) | CXTPGridPaintManager | virtual
DrawColumnFooterDivider(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn) | CXTPGridPaintManager | virtual
DrawColumnIcon(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, CRect rcIcon, int iIcon) | CXTPGridPaintManager | virtual
DrawColumnText(CDC *pDC, CRect rcText, CString strCaption, int nHeaderAlignment, BOOL bIsHeader, BOOL bColumnPressed) | CXTPGridPaintManager | virtual
DrawConnector(CDC *pDC, CPoint ptFrom, CPoint ptTo) | CXTPGridPaintManager |
DrawFocusedRow(CDC *pDC, CRect rcRow) | CXTPGridPaintManager | virtual
DrawFreezeColsDivider(CDC *pDC, const CRect &rc, CXTPGridControl *pControl, CXTPGridRow *pRow=NULL) | CXTPGridPaintManager | virtual
DrawGlyph(CDC *pDC, CRect rcColumn, int iImage) | CXTPGridThemeExplorer | virtual
DrawGrid(CDC *pDC, XTPGridOrientation orientation, CRect rcGrid) | CXTPGridPaintManager | virtual
DrawGridPattern(CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush) | CXTPGridPaintManager | protectedvirtual
DrawGridPattern(CDC *pDC, CXTPBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush) | CXTPGridPaintManager | protectedvirtual
DrawGridPattern(CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr) | CXTPGridPaintManager | protectedvirtual
DrawGroupRow(CDC *pDC, CXTPGridGroupRow *pRow, CRect rcRow, XTP_GRIDRECORDITEM_METRICS *pMetrics) | CXTPGridPaintManager | virtual
DrawHorizontalLine(CDC *pDC, int xPos, int yPos, int cx, COLORREF clr) | CXTPGridPaintManager |
DrawInplaceButton(CDC *pDC, CXTPGridInplaceButton *pButton) | CXTPGridPaintManager | virtual
DrawInplaceButtonFrame(CDC *pDC, CXTPGridInplaceButton *pButton) | CXTPGridPaintManager | protectedvirtual
DrawInplaceButtonIcon(CDC *pDC, CXTPGridInplaceButton *pButton) | CXTPGridPaintManager | protectedvirtual
DrawInplaceComboButton(CDC *pDC, CRect *pRc) | CXTPGridPaintManager | virtual
DrawInplaceExpandButton(CDC *pDC, CRect *pRc) | CXTPGridPaintManager | virtual
DrawInplaceSpinButton(CDC *pDC, CRect *pRc) | CXTPGridPaintManager | virtual
DrawItemBitmap(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CRect &rcItem, int nImage) | CXTPGridPaintManager | virtual
DrawItemCaption(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics) | CXTPGridPaintManager | virtual
DrawItemControl(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CXTPGridRecordItemControl *pControl, CRect &rcItem) | CXTPGridPaintManager | virtual
DrawLink(int *pnCurrDrawPos, XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CXTPGridHyperlink *pHyperlink, CString strText, CRect rcLink, int nFlag, BOOL bTrim=FALSE) | CXTPGridPaintManager | protectedvirtual
DrawMultiLineText(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, BOOL bWordBreak=TRUE) | CXTPGridPaintManager | protectedvirtual
DrawNoGroupByText(CDC *pDC, CRect rcItem) | CXTPGridPaintManager | virtual
DrawRowNumber(CDC *pDC, CRect rcNumber, CXTPGridRow *pRow) | CXTPGridPaintManager | virtual
DrawSectionDivider(CDC *pDC, const CRect &rc, XTPGridSectionDividerPosition dividerPosition, XTPGridSectionDividerStyle dividerStyle, CXTPPaintManagerColor dividerColor) | CXTPGridThemeExplorer |
DrawShellIcon(CDC *pDC, CRect rcColumn, int iImage) | CXTPGridPaintManager | virtual
DrawSingleLineText(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nStartPos, int nEndPos, int nActualWidth) | CXTPGridPaintManager | protectedvirtual
DrawString(int *pnCurrDrawPos, CDC *pDC, const CString &strDraw, CRect rcDraw, UINT nFormat) | CXTPGridPaintManager | protectedvirtual
DrawTextLine(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nFlag, int &nCharCounter, int &nHyperlinkCounter) | CXTPGridPaintManager | protectedvirtual
DrawTreeStructure(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CRect rcItem, CSize sizeGlyph) | CXTPGridPaintManager | virtual
DrawTriangle(CDC *pDC, CRect rcTriangle, BOOL bToDown, int nShadowWidth=0) | CXTPGridThemeExplorer | virtual
DrawTriangle(CDC *pDC, CRect rcTriangle, BOOL bToDown, BOOL bDraggingFromHeader, int nShadowWidth, BOOL bColumnPressed) | CXTPGridThemeExplorer | virtual
DrawVerticalLine(CDC *pDC, int xPos, int yPos, int cy, COLORREF clr) | CXTPGridPaintManager |
DrawVerticalTimeLineMarker(CDC *pDC, int xPos, CXTPGridControl *pControl, COLORREF color=RGB(0, 255, 0)) | CXTPGridPaintManager | virtual
EnablePreviewMode(BOOL bIsPreviewMode) | CXTPGridPaintManager |
FillFooter(CDC *pDC, CRect rcFooter) | CXTPGridPaintManager | virtual
FillGroupByControl(CDC *pDC, CRect &rcGroupBy) | CXTPGridPaintManager | virtual
FillGroupRowMetrics(CXTPGridGroupRow *pRow, XTP_GRIDRECORDITEM_METRICS *pMetrics, BOOL bPrinting) | CXTPGridPaintManager | virtual
FillHeaderControl(CDC *pDC, CRect rcHeader) | CXTPGridPaintManager | virtual
FillIndent(CDC *pDC, CRect rcRow) | CXTPGridPaintManager | virtual
FillItemShade(CDC *pDC, CRect rcItem) | CXTPGridPaintManager | virtual
FillRow(CDC *pDC, CXTPGridRow *pRow, CRect rcRow) | CXTPGridPaintManager | virtual
FindRowAdjacentToMerged(const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, BOOL bUpward) | CXTPGridPaintManager |
FindRowAdjacentToMergedEx(const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, int &nAdjRowIndex, BOOL bUpward) | CXTPGridPaintManager |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetColumnOffice2007CustomThemeBaseColor() const | CXTPGridPaintManager |
GetColumnStyle() const | CXTPGridPaintManager |
GetControlBackColor(CXTPGridControl *pControl) | CXTPGridPaintManager | virtual
GetFooterHeight(CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0) | CXTPGridPaintManager | virtual
GetFreezeColsDividerStyle() const | CXTPGridPaintManager |
GetGlyphs() const | CXTPGridPaintManager |
GetHeaderHeight() | CXTPGridPaintManager | virtual
GetHeaderHeight(CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0) | CXTPGridPaintManager | virtual
GetItemHeight(XTP_GRIDRECORDITEM_DRAWARGS &drawArgs, int nWidth) | CXTPGridPaintManager |
GetMaxPreviewLines() | CXTPGridPaintManager |
GetPreviewItemHeight(CDC *pDC, CXTPGridRow *pRow, int nWidth, int nHeight) | CXTPGridPaintManager | virtual
GetPreviewLinesCount(CDC *pDC, CRect &rcText, const CString &strText) | CXTPGridPaintManager |
GetRowHeight(CDC *pDC, CXTPGridRow *pRow) | CXTPGridPaintManager | virtual
GetRowHeight(CDC *pDC, CXTPGridRow *pRow, int nTotalWidth) | CXTPGridPaintManager | virtual
GetRowHeightEx(CDC *pDC, CXTPGridRow *pRow, int nTotalWidth, const BOOL firstLevel=TRUE) | CXTPGridPaintManager |
GetSectionDividerHeight(XTPGridFixedRowsDividerStyle dividerStyle) | CXTPGridPaintManager |
GetTextFont() | CXTPGridPaintManager |
IsColumHotTrackingEnabled() const | CXTPGridThemeExplorer | virtual
IsColumnPlusMinusSign() const | CXTPGridPaintManager |
IsColumnWidthWYSIWYG() const | CXTPGridPaintManager |
IsDrawGridForEmptySpace() const | CXTPGridPaintManager |
IsFixedInplaceButtonHeight() const | CXTPGridPaintManager |
IsFixedRowHeight() const | CXTPGridPaintManager |
IsGridVisible(BOOL bVertical) const | CXTPGridPaintManager |
IsGridVisible(XTPGridOrientation orientation) const | CXTPGridPaintManager |
IsLastColumnWidthWYSIWYG() const | CXTPGridPaintManager |
IsPreviewMode() const | CXTPGridPaintManager |
IsPrintGroupRowIcon() const | CXTPGridPaintManager |
IsShowWYSIWYGMarkers() const | CXTPGridPaintManager |
IsUseDropMarker() const | CXTPGridPaintManager |
LoadGlyphs() | CXTPGridPaintManager | virtual
m_arStartCol | CXTPGridPaintManager |
m_bAllowMergeCells | CXTPGridPaintManager |
m_bBaseTreeIndent | CXTPGridPaintManager |
m_bCleanTooltip | CXTPGridPaintManager |
m_bColumnPlusMinusSign | CXTPGridPaintManager | protected
m_bColumnWidthWYSIWYG | CXTPGridPaintManager | protected
m_bCompactText | CXTPGridPaintManager |
m_bDrawGridForEmptySpace | CXTPGridPaintManager | protected
m_bFixedInplaceButtonHeight | CXTPGridPaintManager | protected
m_bFixedRowHeight | CXTPGridPaintManager | protected
m_bForceDynamicMarkupForCell | CXTPGridPaintManager |
m_bForceShowDropMarker | CXTPGridPaintManager |
m_bForceShowTooltip | CXTPGridPaintManager |
m_bGrayIfDisable | CXTPGridPaintManager |
m_bGroupRowTextBold | CXTPGridPaintManager |
m_bHideSelection | CXTPGridPaintManager |
m_bHotTracking | CXTPGridPaintManager |
m_bInvertColumnOnClick | CXTPGridPaintManager |
m_bIsPreviewMode | CXTPGridPaintManager | protected
m_bLastColumnWidthWYSIWYG | CXTPGridPaintManager | protected
m_bMakeUpper | CXTPGridPaintManager |
m_bMoveScrollbarOnFixedColumnsIndent | CXTPGridPaintManager |
m_bPrintGroupRowIcon | CXTPGridPaintManager | protected
m_bPrintPageRectangle | CXTPGridPaintManager |
m_bPrintSortTriangle | CXTPGridPaintManager |
m_bPrintVirtualPageNumber | CXTPGridPaintManager |
m_bPrintWatermark | CXTPGridPaintManager |
m_bRecOrRowNum | CXTPGridPaintManager |
m_bRevertAlignment | CXTPGridPaintManager |
m_bShadeGroupHeadings | CXTPGridPaintManager |
m_bShadeSortColumn | CXTPGridPaintManager |
m_bShowLockIcon | CXTPGridPaintManager |
m_bShowNonActiveInPlaceButton | CXTPGridPaintManager |
m_bShowWYSIWYGMarkers | CXTPGridPaintManager | protected
m_bSortTriangleOffsetFromRight | CXTPGridPaintManager |
m_bThemedInplaceButtons | CXTPGridPaintManager |
m_bUseAlternativeBackground | CXTPGridPaintManager |
m_bUseDropMarker | CXTPGridPaintManager |
m_bUseEditTextAlignment | CXTPGridPaintManager |
m_bUseGroupRowSelectionState | CXTPGridPaintManager |
m_bUseShellIcon | CXTPGridPaintManager |
m_clrAlternativeBackground | CXTPGridPaintManager |
m_clrBoldText | CXTPGridPaintManager |
m_clrBoldTextHighlight | CXTPGridPaintManager |
m_clrBtnFace | CXTPGridPaintManager |
m_clrBtnFacePressed | CXTPGridPaintManager |
m_clrBtnText | CXTPGridPaintManager |
m_clrCaptionText | CXTPGridPaintManager |
m_clrCaptionTextPressed | CXTPGridPaintManager |
m_clrColumnOffice2007CustomTheme | CXTPGridPaintManager |
m_clrConnector | CXTPGridPaintManager |
m_clrControlBack | CXTPGridPaintManager |
m_clrControlDark | CXTPGridPaintManager |
m_clrControlLightLight | CXTPGridPaintManager |
m_clrDisableBitmapDarkest | CXTPGridPaintManager |
m_clrDisableBitmapLightest | CXTPGridPaintManager |
m_clrFormulaSubSum | CXTPGridPaintManager |
m_clrFormulaSum | CXTPGridPaintManager |
m_clrFreezeColsDivider | CXTPGridPaintManager |
m_clrGradientColumnSeparator | CXTPGridPaintManager |
m_clrGradientColumnShadow | CXTPGridPaintManager |
m_clrGroupBoxBack | CXTPGridPaintManager |
m_clrGroupRowText | CXTPGridPaintManager |
m_clrGroupShadeBack | CXTPGridPaintManager |
m_clrGroupShadeBorder | CXTPGridPaintManager |
m_clrGroupShadeText | CXTPGridPaintManager |
m_clrHeaderControl | CXTPGridPaintManager |
m_clrHighlight | CXTPGridPaintManager |
m_clrHighlightText | CXTPGridPaintManager |
m_clrHotDivider | CXTPGridPaintManager |
m_clrIndentControl | CXTPGridPaintManager |
m_clrItemShade | CXTPGridPaintManager |
m_clrPreviewText | CXTPGridPaintManager |
m_clrSelectedRow | CXTPGridPaintManager |
m_clrSelectedRowText | CXTPGridPaintManager |
m_clrWindowText | CXTPGridPaintManager |
m_columnStyle | CXTPGridPaintManager | protected
m_crlNoGroupByText | CXTPGridPaintManager |
m_grcGradientColumn | CXTPGridPaintManager |
m_grcGradientColumnHot | CXTPGridPaintManager |
m_grcGradientColumnPushed | CXTPGridPaintManager |
m_iRecOrRowStart | CXTPGridPaintManager |
m_nBaseParentRecordIndent | CXTPGridPaintManager |
m_nFixedColumnsIndent | CXTPGridPaintManager |
m_nFooterHeight | CXTPGridPaintManager | protected
m_nFreezeColsDividerStyle | CXTPGridPaintManager | protected
m_nGridLineStylePreviousH | CXTPGridPaintManager | protected
m_nGridLineStylePreviousV | CXTPGridPaintManager | protected
m_nGroupGridLineHeight | CXTPGridPaintManager | protected
m_nGroupGridLineStyle | CXTPGridPaintManager | protected
m_nHeaderHeight | CXTPGridPaintManager | protected
m_nMaxPreviewLines | CXTPGridPaintManager | protected
m_nResizingWidth | CXTPGridPaintManager | protected
m_nRowHeight | CXTPGridPaintManager | protected
m_nRowHeightDefault | CXTPGridPaintManager |
m_nTextIndentForGroupRowsWithNoIcon | CXTPGridPaintManager |
m_nTreeColumnLineLength | CXTPGridPaintManager |
m_nTreeIndent | CXTPGridPaintManager |
m_nTreeStructureStyle | CXTPGridPaintManager |
m_nTreeTextIndent | CXTPGridPaintManager |
m_nTreeTextIndentGroupRow | CXTPGridPaintManager |
m_nTreeTextIndentRowChildren | CXTPGridPaintManager |
m_nTreeTextIndentRowParent | CXTPGridPaintManager |
m_pControl | CXTPGridPaintManager | protected
m_pGlyphs | CXTPGridPaintManager | protected
m_pHyperlinkHoverStyle | CXTPGridPaintManager |
m_pHyperlinkStyle | CXTPGridPaintManager |
m_pMarkupUIElement_NoGroupBy | CXTPGridPaintManager | protected
m_PrintPageWidth | CXTPGridPaintManager |
m_rcPreviewIndent | CXTPGridPaintManager |
m_RecordNumberWidth | CXTPGridPaintManager |
m_strCollapse | CXTPGridPaintManager |
m_strDecreasing | CXTPGridPaintManager |
m_strExpand | CXTPGridPaintManager |
m_strIncreasing | CXTPGridPaintManager |
m_strMarkupUIElement_NoGroupBy | CXTPGridPaintManager | protected
m_strNoFieldsAvailable | CXTPGridPaintManager |
m_strNoGroupBy | CXTPGridPaintManager |
m_strNoItems | CXTPGridPaintManager |
m_strSortBy | CXTPGridPaintManager |
m_szGlyph | CXTPGridPaintManager | protected
m_themeButton | CXTPGridPaintManager | protected
m_themeCombo | CXTPGridPaintManager | protected
m_themeHeader | CXTPGridPaintManager | protected
m_themeSpin | CXTPGridPaintManager | protected
m_treeStructureStyle | CXTPGridPaintManager |
m_xtpBrushGroupGridLineStyle | CXTPGridPaintManager | protected
m_xtpBrushHorizontalGrid | CXTPGridPaintManager | protected
m_xtpBrushTreeStructure | CXTPGridPaintManager | protected
m_xtpBrushVeriticalGrid | CXTPGridPaintManager | protected
m_xtpFontBoldText | CXTPGridPaintManager |
m_xtpFontCaption | CXTPGridPaintManager |
m_xtpFontPreview | CXTPGridPaintManager |
m_xtpFontText | CXTPGridPaintManager |
OnDrawAction(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs) | CXTPGridPaintManager | virtual
RecalcTotalHightOfMergedRows(CXTPGridColumns *pColumns, CDC *pDC, CXTPGridRow *pRow, int nRowHeight, int nTotalWidth) | CXTPGridPaintManager |
RefreshMetrics() | CXTPGridPaintManager | virtual
SetCaptionFont(LOGFONT &lf) | CXTPGridPaintManager |
SetColumnOffice2007CustomThemeBaseColor(COLORREF clrBaseColor) | CXTPGridPaintManager |
SetColumnPlusMinusSign(BOOL bDraw) | CXTPGridPaintManager |
SetColumnStyle(XTPGridColumnStyle columnStyle) | CXTPGridPaintManager |
SetColumnWidthWYSIWYG(BOOL bColumnWidthWYSIWYG) | CXTPGridPaintManager |
SetDrawGridForEmptySpace(BOOL bDrawGrid) | CXTPGridPaintManager |
SetFixedRowHeight(BOOL bFixedRowHeight) | CXTPGridPaintManager |
SetFreezeColsDividerStyle(int nStyle) | CXTPGridPaintManager |
SetGridControl(CXTPGridControl *pControl) | CXTPGridPaintManager | virtual
SetHeaderHeight(int nHeight) | CXTPGridPaintManager | virtual
SetInplaceButtonHeight(BOOL bFixedInplaceButtonHeight) | CXTPGridPaintManager |
SetLastColumnWidthWYSIWYG(BOOL bColumnWidthWYSIWYG) | CXTPGridPaintManager |
SetMaxPreviewLines(int nMaxLines) | CXTPGridPaintManager |
SetPreviewIndent(int nLeft, int nTop, int nRight, int nBottom) | CXTPGridPaintManager |
SetPrintGroupRowIcon(BOOL bDraw) | CXTPGridPaintManager |
SetTextFont(LOGFONT &lf) | CXTPGridPaintManager |
ShowWYSIWYGMarkers(BOOL bSet) | CXTPGridPaintManager |
~CXTPGridPaintManager() | CXTPGridPaintManager | virtual


Toolkit Pro: Member List

CXTPTrackThemeVisualStudio2015 Member List

This is the complete list of members for CXTPTrackThemeVisualStudio2015, including all inherited members.

CalcColumnHeight(CDC *pDC, CXTPGridColumn *pColumn, int nTotalWidth=0) | CXTPGridPaintManager | protectedvirtual
CalculateRowHeight(CDC *pDC, const CString &strText, int nMaxWidth, BOOL bWordBreak=TRUE) | CXTPGridPaintManager | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPGridPaintManager() | CXTPGridPaintManager |
CXTPTrackPaintManager() | CXTPTrackPaintManager |
CXTPTrackThemeOffice2013() | CXTPTrackThemeOffice2013 |
CXTPTrackThemeVisualStudio2015() | CXTPTrackThemeVisualStudio2015 |
DrawBitmap(CDC *pDC, CXTPGridControl *pControl, CRect rcColumn, int iImage) | CXTPGridPaintManager | virtual
DrawCollapsedBitmap(CDC *pDC, const CXTPGridRow *pRow, CRect &rcBitmap) | CXTPGridPaintManager | virtual
DrawColumn(CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn, BOOL bDrawExternal=FALSE, int nShadowWidth=0) | CXTPGridPaintManager | virtual
DrawColumnBackground(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, BOOL &bColumnPressed, BOOL &bDraggingFromHeader, CXTPGridHeader *pHeader=NULL) | CXTPTrackThemeOffice2013 | virtual
DrawColumnFooter(CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn) | CXTPGridPaintManager | virtual
DrawColumnFooterDivider(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn) | CXTPGridPaintManager | virtual
DrawColumnIcon(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, CRect rcIcon, int iIcon) | CXTPGridPaintManager | virtual
DrawColumnText(CDC *pDC, CRect rcText, CString strCaption, int nHeaderAlignment, BOOL bIsHeader, BOOL bColumnPressed) | CXTPTrackThemeOffice2013 | virtual
DrawConnector(CDC *pDC, CPoint ptFrom, CPoint ptTo) | CXTPGridPaintManager |
DrawFocusedRow(CDC *pDC, CRect rcRow) | CXTPTrackThemeOffice2013 | virtual
DrawFreezeColsDivider(CDC *pDC, const CRect &rc, CXTPGridControl *pControl, CXTPGridRow *pRow=NULL) | CXTPGridPaintManager | virtual
DrawGlyph(CDC *pDC, CRect rcColumn, int iImage) | CXTPGridPaintManager | virtual
DrawGrid(CDC *pDC, XTPGridOrientation orientation, CRect rcGrid) | CXTPGridPaintManager | virtual
DrawGridPattern(CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush) | CXTPGridPaintManager | protectedvirtual
DrawGridPattern(CDC *pDC, CXTPBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush) | CXTPGridPaintManager | protectedvirtual
DrawGridPattern(CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr) | CXTPGridPaintManager | protectedvirtual
DrawGroupRow(CDC *pDC, CXTPGridGroupRow *pRow, CRect rcRow, XTP_GRIDRECORDITEM_METRICS *pMetrics) | CXTPTrackThemeOffice2013 | virtual
DrawHorizontalLine(CDC *pDC, int xPos, int yPos, int cx, COLORREF clr) | CXTPGridPaintManager |
DrawInplaceButton(CDC *pDC, CXTPGridInplaceButton *pButton) | CXTPGridPaintManager | virtual
DrawInplaceButtonFrame(CDC *pDC, CXTPGridInplaceButton *pButton) | CXTPGridPaintManager | protectedvirtual
DrawInplaceButtonIcon(CDC *pDC, CXTPGridInplaceButton *pButton) | CXTPGridPaintManager | protectedvirtual
DrawInplaceComboButton(CDC *pDC, CRect *pRc) | CXTPGridPaintManager | virtual
DrawInplaceExpandButton(CDC *pDC, CRect *pRc) | CXTPGridPaintManager | virtual
DrawInplaceSpinButton(CDC *pDC, CRect *pRc) | CXTPGridPaintManager | virtual
DrawItemBitmap(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CRect &rcItem, int nImage) | CXTPGridPaintManager | virtual
DrawItemCaption(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics) | CXTPGridPaintManager | virtual
DrawItemControl(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CXTPGridRecordItemControl *pControl, CRect &rcItem) | CXTPGridPaintManager | virtual
DrawLink(int *pnCurrDrawPos, XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CXTPGridHyperlink *pHyperlink, CString strText, CRect rcLink, int nFlag, BOOL bTrim=FALSE) | CXTPGridPaintManager | protectedvirtual
DrawMarkers(CDC *pDC) | CXTPTrackPaintManager | virtual
DrawMultiLineText(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, BOOL bWordBreak=TRUE) | CXTPGridPaintManager | protectedvirtual
DrawNoGroupByText(CDC *pDC, CRect rcItem) | CXTPGridPaintManager | virtual
DrawRowNumber(CDC *pDC, CRect rcNumber, CXTPGridRow *pRow) | CXTPGridPaintManager | virtual
DrawSectionDivider(CDC *pDC, const CRect &rc, XTPGridSectionDividerPosition dividerPosition, XTPGridSectionDividerStyle dividerStyle, CXTPPaintManagerColor dividerColor) | CXTPGridPaintManager |
DrawShellIcon(CDC *pDC, CRect rcColumn, int iImage) | CXTPGridPaintManager | virtual
DrawSingleLineText(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nStartPos, int nEndPos, int nActualWidth) | CXTPGridPaintManager | protectedvirtual
DrawString(int *pnCurrDrawPos, CDC *pDC, const CString &strDraw, CRect rcDraw, UINT nFormat) | CXTPGridPaintManager | protectedvirtual
DrawTextLine(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nFlag, int &nCharCounter, int &nHyperlinkCounter) | CXTPGridPaintManager | protectedvirtual
DrawTimeLine(CDC *pDC) | CXTPTrackPaintManager | virtual
DrawTrackHeader(CDC *pDC) | CXTPTrackPaintManager | virtual
DrawTreeStructure(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CRect rcItem, CSize sizeGlyph) | CXTPGridPaintManager | virtual
DrawTriangle(CDC *pDC, CRect rcTriangle, BOOL bToDown, BOOL bDraggingFromHeader, int nShadowWidth, BOOL bColumnPressed) | CXTPTrackThemeOffice2013 | virtual
DrawVerticalLine(CDC *pDC, int xPos, int yPos, int cy, COLORREF clr) | CXTPGridPaintManager |
DrawVerticalTimeLineMarker(CDC *pDC, int xPos, CXTPGridControl *pControl, COLORREF color=RGB(0, 255, 0)) | CXTPGridPaintManager | virtual
EnablePreviewMode(BOOL bIsPreviewMode) | CXTPGridPaintManager |
FillFooter(CDC *pDC, CRect rcFooter) | CXTPGridPaintManager | virtual
FillGroupByControl(CDC *pDC, CRect &rcGroupBy) | CXTPGridPaintManager | virtual
FillGroupRowMetrics(CXTPGridGroupRow *pRow, XTP_GRIDRECORDITEM_METRICS *pMetrics, BOOL bPrinting) | CXTPTrackThemeOffice2013 | virtual
FillHeaderControl(CDC *pDC, CRect rcHeader) | CXTPGridPaintManager | virtual
FillIndent(CDC *pDC, CRect rcRow) | CXTPGridPaintManager | virtual
FillItemShade(CDC *pDC, CRect rcItem) | CXTPGridPaintManager | virtual
FillRow(CDC *pDC, CXTPGridRow *pRow, CRect rcRow) | CXTPGridPaintManager | virtual
FindRowAdjacentToMerged(const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, BOOL bUpward) | CXTPGridPaintManager |
FindRowAdjacentToMergedEx(const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, int &nAdjRowIndex, BOOL bUpward) | CXTPGridPaintManager |
FormatTime(int nPosition) | CXTPTrackPaintManager | virtual
FormatTimeLineTick(int nPosition, COLORREF &clrTick, int &nTickLength) | CXTPTrackPaintManager | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetColumnOffice2007CustomThemeBaseColor() const | CXTPGridPaintManager |
GetColumnStyle() const | CXTPGridPaintManager |
GetControlBackColor(CXTPGridControl *pControl) | CXTPGridPaintManager | virtual
GetFooterHeight(CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0) | CXTPGridPaintManager | virtual
GetFreezeColsDividerStyle() const | CXTPGridPaintManager |
GetGlyphs() const | CXTPGridPaintManager |
GetHeaderHeight() | CXTPGridPaintManager | virtual
GetHeaderHeight(CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0) | CXTPGridPaintManager | virtual
GetItemHeight(XTP_GRIDRECORDITEM_DRAWARGS &drawArgs, int nWidth) | CXTPGridPaintManager |
GetMaxPreviewLines() | CXTPGridPaintManager |
GetPreviewItemHeight(CDC *pDC, CXTPGridRow *pRow, int nWidth, int nHeight) | CXTPGridPaintManager | virtual
GetPreviewLinesCount(CDC *pDC, CRect &rcText, const CString &strText) | CXTPGridPaintManager |
GetRowHeight(CDC *pDC, CXTPGridRow *pRow) | CXTPTrackThemeOffice2013 | virtual
CXTPTrackPaintManager::GetRowHeight(CDC *pDC, CXTPGridRow *pRow, int nTotalWidth) | CXTPGridPaintManager | virtual
GetRowHeightEx(CDC *pDC, CXTPGridRow *pRow, int nTotalWidth, const BOOL firstLevel=TRUE) | CXTPGridPaintManager |
GetSectionDividerHeight(XTPGridFixedRowsDividerStyle dividerStyle) | CXTPGridPaintManager |
GetTextFont() | CXTPGridPaintManager |
IsColumHotTrackingEnabled() const | CXTPGridPaintManager | virtual
IsColumnPlusMinusSign() const | CXTPGridPaintManager |
IsColumnWidthWYSIWYG() const | CXTPGridPaintManager |
IsDrawGridForEmptySpace() const | CXTPGridPaintManager |
IsFixedInplaceButtonHeight() const | CXTPGridPaintManager |
IsFixedRowHeight() const | CXTPGridPaintManager |
IsGridVisible(BOOL bVertical) const | CXTPGridPaintManager |
IsGridVisible(XTPGridOrientation orientation) const | CXTPGridPaintManager |
IsLastColumnWidthWYSIWYG() const | CXTPGridPaintManager |
IsPreviewMode() const | CXTPGridPaintManager |
IsPrintGroupRowIcon() const | CXTPGridPaintManager |
IsShowWYSIWYGMarkers() const | CXTPGridPaintManager |
IsUseDropMarker() const | CXTPGridPaintManager |
LoadGlyphs() | CXTPTrackThemeOffice2013 | virtual
m_arStartCol | CXTPGridPaintManager |
m_bAllowMergeCells | CXTPGridPaintManager |
m_bBaseTreeIndent | CXTPGridPaintManager |
m_bCleanTooltip | CXTPGridPaintManager |
m_bColumnPlusMinusSign | CXTPGridPaintManager | protected
m_bColumnWidthWYSIWYG | CXTPGridPaintManager | protected
m_bCompactText | CXTPGridPaintManager |
m_bDrawGridForEmptySpace | CXTPGridPaintManager | protected
m_bFixedInplaceButtonHeight | CXTPGridPaintManager | protected
m_bFixedRowHeight | CXTPGridPaintManager | protected
m_bForceDynamicMarkupForCell | CXTPGridPaintManager |
m_bForceShowDropMarker | CXTPGridPaintManager |
m_bForceShowTooltip | CXTPGridPaintManager |
m_bGrayIfDisable | CXTPGridPaintManager |
m_bGroupRowTextBold | CXTPGridPaintManager |
m_bHideSelection | CXTPGridPaintManager |
m_bHotTracking | CXTPGridPaintManager |
m_bInvertColumnOnClick | CXTPGridPaintManager |
m_bIsPreviewMode | CXTPGridPaintManager | protected
m_bLastColumnWidthWYSIWYG | CXTPGridPaintManager | protected
m_bMakeUpper | CXTPGridPaintManager |
m_bMoveScrollbarOnFixedColumnsIndent | CXTPGridPaintManager |
m_bPrintGroupRowIcon | CXTPGridPaintManager | protected
m_bPrintPageRectangle | CXTPGridPaintManager |
m_bPrintSortTriangle | CXTPGridPaintManager |
m_bPrintVirtualPageNumber | CXTPGridPaintManager |
m_bPrintWatermark | CXTPGridPaintManager |
m_bRecOrRowNum | CXTPGridPaintManager |
m_bRevertAlignment | CXTPGridPaintManager |
m_bShadeGroupHeadings | CXTPGridPaintManager |
m_bShadeSortColumn | CXTPGridPaintManager |
m_bShowLockIcon | CXTPGridPaintManager |
m_bShowNonActiveInPlaceButton | CXTPGridPaintManager |
m_bShowWYSIWYGMarkers | CXTPGridPaintManager | protected
m_bSortTriangleOffsetFromRight | CXTPGridPaintManager |
m_bThemedInplaceButtons | CXTPGridPaintManager |
m_bUseAlternativeBackground | CXTPGridPaintManager |
m_bUseDropMarker | CXTPGridPaintManager |
m_bUseEditTextAlignment | CXTPGridPaintManager |
m_bUseGroupRowSelectionState | CXTPGridPaintManager |
m_bUseShellIcon | CXTPGridPaintManager |
m_clrAlternativeBackground | CXTPGridPaintManager |
m_clrBoldText | CXTPGridPaintManager |
m_clrBoldTextHighlight | CXTPGridPaintManager |
m_clrBtnFace | CXTPGridPaintManager |
m_clrBtnFacePressed | CXTPGridPaintManager |
m_clrBtnText | CXTPGridPaintManager |
m_clrCaptionText | CXTPGridPaintManager |
m_clrCaptionTextPressed | CXTPGridPaintManager |
m_clrColumnOffice2007CustomTheme | CXTPGridPaintManager |
m_clrConnector | CXTPGridPaintManager |
m_clrControlBack | CXTPGridPaintManager |
m_clrControlDark | CXTPGridPaintManager |
m_clrControlLightLight | CXTPGridPaintManager |
m_clrDisableBitmapDarkest | CXTPGridPaintManager |
m_clrDisableBitmapLightest | CXTPGridPaintManager |
m_clrFormulaSubSum | CXTPGridPaintManager |
m_clrFormulaSum | CXTPGridPaintManager |
m_clrFreezeColsDivider | CXTPGridPaintManager |
m_clrGlyph | CXTPTrackThemeOffice2013 |
m_clrGlyphHighlight | CXTPTrackThemeOffice2013 |
m_clrGradientColumnSeparator | CXTPGridPaintManager |
m_clrGradientColumnShadow | CXTPGridPaintManager |
m_clrGroupBoxBack | CXTPGridPaintManager |
m_clrGroupRowText | CXTPGridPaintManager |
m_clrGroupShadeBack | CXTPGridPaintManager |
m_clrGroupShadeBorder | CXTPGridPaintManager |
m_clrGroupShadeText | CXTPGridPaintManager |
m_clrHeaderControl | CXTPGridPaintManager |
m_clrHighlight | CXTPGridPaintManager |
m_clrHighlightText | CXTPGridPaintManager |
m_clrHotDivider | CXTPGridPaintManager |
m_clrIndentControl | CXTPGridPaintManager |
m_clrItemShade | CXTPGridPaintManager |
m_clrMarker | CXTPTrackPaintManager |
m_clrMarkerBack | CXTPTrackPaintManager |
m_clrMarkerBorder | CXTPTrackPaintManager |
m_clrPreviewText | CXTPGridPaintManager |
m_clrScrollBarBorderDark | CXTPTrackPaintManager |
m_clrScrollBarBorderLight | CXTPTrackPaintManager |
m_clrScrollBarDark | CXTPTrackPaintManager |
m_clrScrollBarLight | CXTPTrackPaintManager |
m_clrSelectedArea | CXTPTrackPaintManager |
m_clrSelectedBorder | CXTPTrackThemeOffice2013 |
m_clrSelectedRow | CXTPGridPaintManager |
m_clrSelectedRowText | CXTPGridPaintManager |
m_clrTimeHeaderBorder | CXTPTrackPaintManager |
m_clrTimeHeaderDark | CXTPTrackPaintManager |
m_clrTimeHeaderDarkDark | CXTPTrackPaintManager |
m_clrTimeHeaderDivider | CXTPTrackPaintManager |
m_clrTimeLinePosition | CXTPTrackPaintManager |
m_clrTimeLineTick | CXTPTrackPaintManager |
m_clrTimeSliderBackground | CXTPTrackPaintManager |
m_clrTrackHeader | CXTPTrackPaintManager |
m_clrTrackMarkerBorder | CXTPTrackPaintManager |
m_clrTrackMarkerText | CXTPTrackPaintManager |
m_clrTrackMarkerTextBack | CXTPTrackPaintManager |
m_clrTrackMarkerTextBorder | CXTPTrackPaintManager |
m_clrTrackTimeArea | CXTPTrackPaintManager |
m_clrWindowText | CXTPGridPaintManager |
m_clrWorkArea | CXTPTrackPaintManager |
m_clrWorkAreaScrollBarBorder | CXTPTrackPaintManager |
m_clrWorkAreaScrollBarDark | CXTPTrackPaintManager |
m_clrWorkAreaScrollBarLight | CXTPTrackPaintManager |
m_columnStyle | CXTPGridPaintManager | protected
m_crlNoGroupByText | CXTPGridPaintManager |
m_grcGradientColumn | CXTPGridPaintManager |
m_grcGradientColumnHot | CXTPGridPaintManager |
m_grcGradientColumnPushed | CXTPGridPaintManager |
m_iRecOrRowStart | CXTPGridPaintManager |
m_nBaseParentRecordIndent | CXTPGridPaintManager |
m_nFixedColumnsIndent | CXTPGridPaintManager |
m_nFooterHeight | CXTPGridPaintManager | protected
m_nFreezeColsDividerStyle | CXTPGridPaintManager | protected
m_nGridLineStylePreviousH | CXTPGridPaintManager | protected
m_nGridLineStylePreviousV | CXTPGridPaintManager | protected
m_nGroupGridLineHeight | CXTPGridPaintManager | protected
m_nGroupGridLineStyle | CXTPGridPaintManager | protected
m_nHeaderHeight | CXTPGridPaintManager | protected
m_nMaxPreviewLines | CXTPGridPaintManager | protected
m_nResizingWidth | CXTPGridPaintManager | protected
m_nRowHeight | CXTPGridPaintManager | protected
m_nRowHeightDefault | CXTPGridPaintManager |
m_nTextIndentForGroupRowsWithNoIcon | CXTPGridPaintManager |
m_nTreeColumnLineLength | CXTPGridPaintManager |
m_nTreeIndent | CXTPGridPaintManager |
m_nTreeStructureStyle | CXTPGridPaintManager |
m_nTreeTextIndent | CXTPGridPaintManager |
m_nTreeTextIndentGroupRow | CXTPGridPaintManager |
m_nTreeTextIndentRowChildren | CXTPGridPaintManager |
m_nTreeTextIndentRowParent | CXTPGridPaintManager |
m_pControl | CXTPGridPaintManager | protected
m_pGlyphs | CXTPGridPaintManager | protected
m_pHyperlinkHoverStyle | CXTPGridPaintManager |
m_pHyperlinkStyle | CXTPGridPaintManager |
m_pMarkupUIElement_NoGroupBy | CXTPGridPaintManager | protected
m_PrintPageWidth | CXTPGridPaintManager |
m_rcPreviewIndent | CXTPGridPaintManager |
m_RecordNumberWidth | CXTPGridPaintManager |
m_strCollapse | CXTPGridPaintManager |
m_strDecreasing | CXTPGridPaintManager |
m_strExpand | CXTPGridPaintManager |
m_strIncreasing | CXTPGridPaintManager |
m_strMarkupUIElement_NoGroupBy | CXTPGridPaintManager | protected
m_strNoFieldsAvailable | CXTPGridPaintManager |
m_strNoGroupBy | CXTPGridPaintManager |
m_strNoItems | CXTPGridPaintManager |
m_strSortBy | CXTPGridPaintManager |
m_szGlyph | CXTPGridPaintManager | protected
m_themeButton | CXTPGridPaintManager | protected
m_themeCombo | CXTPGridPaintManager | protected
m_themeHeader | CXTPGridPaintManager | protected
m_themeSpin | CXTPGridPaintManager | protected
m_treeStructureStyle | CXTPGridPaintManager |
m_xtpBrushGroupGridLineStyle | CXTPGridPaintManager | protected
m_xtpBrushHorizontalGrid | CXTPGridPaintManager | protected
m_xtpBrushTreeStructure | CXTPGridPaintManager | protected
m_xtpBrushVeriticalGrid | CXTPGridPaintManager | protected
m_xtpFontBoldText | CXTPGridPaintManager |
m_xtpFontCaption | CXTPGridPaintManager |
m_xtpFontPreview | CXTPGridPaintManager |
m_xtpFontText | CXTPGridPaintManager |
OnDrawAction(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs) | CXTPGridPaintManager | virtual
RecalcTotalHightOfMergedRows(CXTPGridColumns *pColumns, CDC *pDC, CXTPGridRow *pRow, int nRowHeight, int nTotalWidth) | CXTPGridPaintManager |
RefreshMetrics() | CXTPTrackThemeVisualStudio2015 | virtual
SetCaptionFont(LOGFONT &lf) | CXTPGridPaintManager |
SetColumnOffice2007CustomThemeBaseColor(COLORREF clrBaseColor) | CXTPGridPaintManager |
SetColumnPlusMinusSign(BOOL bDraw) | CXTPGridPaintManager |
SetColumnWidthWYSIWYG(BOOL bColumnWidthWYSIWYG) | CXTPGridPaintManager |
SetDrawGridForEmptySpace(BOOL bDrawGrid) | CXTPGridPaintManager |
SetFixedRowHeight(BOOL bFixedRowHeight) | CXTPGridPaintManager |
SetFreezeColsDividerStyle(int nStyle) | CXTPGridPaintManager |
SetGridControl(CXTPGridControl *pControl) | CXTPGridPaintManager | virtual
SetHeaderHeight(int nHeight) | CXTPGridPaintManager | virtual
SetInplaceButtonHeight(BOOL bFixedInplaceButtonHeight) | CXTPGridPaintManager |
SetLastColumnWidthWYSIWYG(BOOL bColumnWidthWYSIWYG) | CXTPGridPaintManager |
SetMaxPreviewLines(int nMaxLines) | CXTPGridPaintManager |
SetPreviewIndent(int nLeft, int nTop, int nRight, int nBottom) | CXTPGridPaintManager |
SetPrintGroupRowIcon(BOOL bDraw) | CXTPGridPaintManager |
SetTextFont(LOGFONT &lf) | CXTPGridPaintManager |
ShowWYSIWYGMarkers(BOOL bSet) | CXTPGridPaintManager |
~CXTPGridPaintManager() | CXTPGridPaintManager | virtual
~CXTPTrackPaintManager() | CXTPTrackPaintManager |


Toolkit Pro: XTPRibbonGroups.h Source File

  • Source
  • Ribbon
XTPRibbonGroups.h
Go to the documentation of this file.
1
23#if !defined(__XTPRIBBONGROUPS_H__)
24# define __XTPRIBBONGROUPS_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPRibbonGroup;
34class CXTPRibbonTab;
35
50class _XTP_EXT_CLASS CXTPRibbonGroups : public CXTPCmdTarget
51{
52public:
57 CXTPRibbonGroups();
58
63 virtual ~CXTPRibbonGroups();
64
65public:
71 void Copy(CXTPRibbonGroups* pGroups);
72
79 void RemoveAll();
80
88 void Remove(int nIndex);
89
97 void Remove(CXTPRibbonGroup* pGroup);
98
119 CXTPRibbonGroup* InsertAt(int nIndex, LPCTSTR lpszCaption, int nId = -1);
120
139 CXTPRibbonGroup* InsertAt(int nIndex, CXTPRibbonGroup* pGroup);
140
156 CXTPRibbonGroup* Add(LPCTSTR lpszCaption, int nId = -1);
157
168 int GetCount() const;
169
185 CXTPRibbonGroup* GetAt(int nIndex) const;
186
196 CXTPRibbonGroup* HitTest(CPoint point) const;
197
207 CXTPRibbonBar* GetRibbonBar() const;
208
218 CXTPRibbonTab* GetParentTab() const;
219
230 void CalcDynamicSize(CDC* pDC, int nLength, DWORD dwMode, const CRect& rcBorder);
231
237 virtual void DoPropExchange(CXTPPropExchange* pPX);
238
239public:
246 int GetScrollPos() const;
247
248protected:
250 int _CalcSmartLayoutToolBar(int* pWidth);
251 void _ReduceSmartLayoutToolBar(CDC* pDC, int* pWidth, int nWidth);
254private:
255 void RefreshIndexes();
256
257protected:
258# ifdef _XTP_COMMANDBARS_ACTIVEX
261 afx_msg LPDISPATCH OleInsertGroup(int nIndex, LPCTSTR lpszTitle, int nId);
262 afx_msg long OleGetItemCount();
263 afx_msg LPDISPATCH OleGetItem(int nIndex);
264 afx_msg LPDISPATCH OleAddGroup(LPCTSTR lpszTitle, int nId);
265 afx_msg LPDISPATCH OleGetRibbonTab();
266 afx_msg void OleRemoveAt(int nIndex);
267
268 DECLARE_DISPATCH_MAP()
269 DECLARE_OLETYPELIB_EX(CXTPRibbonGroups);
270 DECLARE_INTERFACE_MAP()
271 DECLARE_ENUM_VARIANT(CXTPRibbonGroups);
272
274# endif
275
276protected:
277 CArray<CXTPRibbonGroup*, CXTPRibbonGroup*> m_arrGroups;
278 CXTPRibbonTab* m_pParentTab;
280 int m_nGroupsScrollPos;
281 friend class CXTPRibbonTab;
282 friend class CXTPRibbonBar;
283};
284
285AFX_INLINE int CXTPRibbonGroups::GetCount() const
286{
287 return (int)m_arrGroups.GetSize();
288}
289AFX_INLINE CXTPRibbonGroup* CXTPRibbonGroups::GetAt(int nIndex) const
290{
291 _ASSERTE(nIndex < m_arrGroups.GetSize());
292 return (nIndex >= 0 && nIndex < m_arrGroups.GetSize()) ? m_arrGroups.GetAt(nIndex) : NULL;
293}
294AFX_INLINE CXTPRibbonTab* CXTPRibbonGroups::GetParentTab() const
295{
296 return m_pParentTab;
297}
298AFX_INLINE int CXTPRibbonGroups::GetScrollPos() const
299{
300 return m_nGroupsScrollPos;
301}
302
303# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
305#endif // !defined(__XTPRIBBONGROUPS_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72
CXTPRibbonBar
CXTPRibbonBar is a CXTPMenuBar derived class.
Definition XTPRibbonBar.h:69
CXTPRibbonGroup
Represents a single group that is added to a CXTPRibbonTab.
Definition XTPRibbonGroup.h:70
CXTPRibbonGroups
Represents a collection of CXTPRibbonGroup objects.
Definition XTPRibbonGroups.h:51
CXTPRibbonGroups::GetCount
int GetCount() const
Retrieves the total number of CXTPRibbonGroup objects that have been added to the CXTPRibbonTab.
Definition XTPRibbonGroups.h:285
CXTPRibbonGroups::Copy
void Copy(CXTPRibbonGroups *pGroups)
Copies all groups from a CXTPRibbonGroups object.
CXTPRibbonGroups::DoPropExchange
virtual void DoPropExchange(CXTPPropExchange *pPX)
Reads/writes this object from/to an archive.
CXTPRibbonGroups::CalcDynamicSize
void CalcDynamicSize(CDC *pDC, int nLength, DWORD dwMode, const CRect &rcBorder)
This method is called internally to reposition groups and controls.
CXTPRibbonGroups::GetAt
CXTPRibbonGroup * GetAt(int nIndex) const
Gets the CXTPRibbonGroup object that has been added to the CXTPRibbonTab at a specified index.
Definition XTPRibbonGroups.h:289
CXTPRibbonGroups::InsertAt
CXTPRibbonGroup * InsertAt(int nIndex, LPCTSTR lpszCaption, int nId=-1)
Adds a CXTPRibbonGroup to a CXTPRibbonTab at a specific location.
CXTPRibbonGroups::Remove
void Remove(CXTPRibbonGroup *pGroup)
Removes a specified group.
CXTPRibbonGroups::HitTest
CXTPRibbonGroup * HitTest(CPoint point) const
This member function determines which ribbon group, if any, is at a specified position.
CXTPRibbonGroups::Remove
void Remove(int nIndex)
Removes a specified group.
CXTPRibbonGroups::GetRibbonBar
CXTPRibbonBar * GetRibbonBar() const
Gets the CXTPRibbonBar object that the CXTPRibbonGroup belongs to.
CXTPRibbonGroups::m_arrGroups
CArray< CXTPRibbonGroup *, CXTPRibbonGroup * > m_arrGroups
Collection of groups.
Definition XTPRibbonGroups.h:277
CXTPRibbonGroups::m_pParentTab
CXTPRibbonTab * m_pParentTab
A pointer to the CXTPRibbonTab object the CXTPRibbonGroup belongs to.
Definition XTPRibbonGroups.h:278
CXTPRibbonGroups::CXTPRibbonGroups
CXTPRibbonGroups()
Constructs a CXTPRibbonGroups object.
CXTPRibbonGroups::RemoveAll
void RemoveAll()
Removes all groups.
CXTPRibbonGroups::InsertAt
CXTPRibbonGroup * InsertAt(int nIndex, CXTPRibbonGroup *pGroup)
Adds a CXTPRibbonGroup to a CXTPRibbonTab at a specific location.
CXTPRibbonGroups::GetScrollPos
int GetScrollPos() const
Gets the group scroll position.
Definition XTPRibbonGroups.h:298
CXTPRibbonGroups::Add
CXTPRibbonGroup * Add(LPCTSTR lpszCaption, int nId=-1)
Adds a CXTPRibbonGroup to a CXTPRibbonTab.
CXTPRibbonGroups::m_nGroupsScrollPos
int m_nGroupsScrollPos
Group scroll position.
Definition XTPRibbonGroups.h:280
CXTPRibbonGroups::GetParentTab
CXTPRibbonTab * GetParentTab() const
Gets the CXTPRibbonTab object that the CXTPRibbonGroup belongs to.
Definition XTPRibbonGroups.h:294
CXTPRibbonGroups::~CXTPRibbonGroups
virtual ~CXTPRibbonGroups()
Destroys a CXTPRibbonGroups object, handles cleanup and deallocation.
CXTPRibbonTab
Represents a tab in the Ribbon Bar.
Definition XTPRibbonTab.h:116


Toolkit Pro: Member List

CXTPMDIWndTab Member List

This is the complete list of members for CXTPMDIWndTab, including all inherited members.

CXTPMDIWndTab() | CXTPMDIWndTab |
GetChildWndText(HWND hWnd) const | CXTPMDIWndTab |
GetFrameWnd(int iIndex=-1) const | CXTPMDIWndTab |
GetFrameWnd(CPoint point) const | CXTPMDIWndTab |
Init() | CXTPMDIWndTab | protectedvirtual
InitializeFont() | CXTPMDIWndTab | protectedvirtual
InsertTabWnd(CMDIChildWnd *pChildFrame, BOOL bRecalcLayout=TRUE) | CXTPMDIWndTab | protectedvirtual
Install(CMDIFrameWnd *pMDIFrameWnd, DWORD dwStyle=TCS_BOTTOM|TCS_HOTTRACK, BOOL bNoIcons=TRUE) | CXTPMDIWndTab | virtual
m_arMDIChildern | CXTPMDIWndTab | protected
m_bNoIcons | CXTPMDIWndTab | protected
m_dwInitSignature | CXTPMDIWndTab | protected
m_hActiveChild | CXTPMDIWndTab | protected
m_iBorderGap | CXTPMDIWndTab | protected
m_iHitTest | CXTPMDIWndTab | protected
m_imageList | CXTPMDIWndTab | protected
m_mapTabIcons | CXTPMDIWndTab | protected
m_mapTabLabels | CXTPMDIWndTab | protected
m_nDefCmd | CXTPMDIWndTab | protected
m_nPos | CXTPMDIWndTab | protected
m_pMDIClientWnd | CXTPMDIWndTab | protected
m_pMDIFrameWnd | CXTPMDIWndTab | protected
m_popupMenuID | CXTPMDIWndTab | protected
OnMDIActivate(HWND hWnd) | CXTPMDIWndTab | protectedvirtual
OnMDICreate(HWND hWnd) | CXTPMDIWndTab | protectedvirtual
OnMDIDestroy(HWND hWnd) | CXTPMDIWndTab | protectedvirtual
RecalcLayout(BOOL bDelayRecalc) | CXTPMDIWndTab | protectedvirtual
RefreshActiveSel() | CXTPMDIWndTab | protected
RefreshIndexes() | CXTPMDIWndTab | protected
RefreshTabLabels() | CXTPMDIWndTab | protected
SetBorderGap(int iSize) | CXTPMDIWndTab |
SetMenuID(UINT popupMenuID, int nPos=0, UINT nDefCmd=(UINT) -1) | CXTPMDIWndTab |
SetTabIcon(int iIndex, HICON &hIcon) | CXTPMDIWndTab |
SetTabIcon(HWND hChildWnd, HICON &hIcon) | CXTPMDIWndTab |
SetTabLabel(int iIndex, CString &strLabel) | CXTPMDIWndTab |
SetTabLabel(HWND hChildWnd, CString &strLabel) | CXTPMDIWndTab |
TabFromPoint(CPoint point) const | CXTPMDIWndTab |
UnInstall() | CXTPMDIWndTab | virtual
~CXTPMDIWndTab() | CXTPMDIWndTab | virtual


Toolkit Pro: XTPMarkupHyperlink.h Source File

  • Source
  • Markup
  • Text
XTPMarkupHyperlink.h
Go to the documentation of this file.
1
23#if !defined(__XTPMARKUPHYPERLINK_H__)
24# define __XTPMARKUPHYPERLINK_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPMarkupRoutedEvent;
34class CXTPMarkupMouseButtonEventArgs;
35
36class _XTP_EXT_CLASS CXTPMarkupHyperlink : public CXTPMarkupSpan
37{
39 DECLARE_MARKUPCLASS(CXTPMarkupHyperlink)
41protected:
42 CXTPMarkupHyperlink();
43
44protected:
45 virtual void OnMouseLeftButtonUp(CXTPMarkupMouseButtonEventArgs* e);
46 virtual void OnMouseLeftButtonDown(CXTPMarkupMouseButtonEventArgs* e);
47
48protected:
49 virtual void OnClick();
50
52public:
53 DECLARE_DISPATCH_MAP()
54# ifdef _XTP_ACTIVEX
55 DECLARE_INTERFACE_MAP()
56 DECLARE_OLETYPELIB_EX(CXTPMarkupHyperlink);
57# endif
58
59 afx_msg LPDISPATCH OleGetClickEvent();
60
63protected:
64 BOOL m_bPressed;
65
66public:
67 static CXTPMarkupRoutedEvent* m_pClickEvent;
68};
69
70# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
72#endif // !defined(__XTPMARKUPHYPERLINK_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h


Toolkit Pro: Member List

CXTPTaskPanelGroup Member List

This is the complete list of members for CXTPTaskPanelGroup, including all inherited members.

AddControlItem(HWND hWnd) | CXTPTaskPanelGroup |
AddLinkItem(UINT nID, int nImage=-1) | CXTPTaskPanelGroup |
AddLinkItem(UINT nID, LPCTSTR lpCaption, LPCTSTR lpTooltip=NULL, int nImage=-1) | CXTPTaskPanelGroup |
AddTextItem(LPCTSTR strText) | CXTPTaskPanelGroup |
AllowDrag(long nAllowDrag=xtpTaskItemAllowDragDefault) | CXTPTaskPanelItem |
AllowDrop(BOOL bAllowDrop) | CXTPTaskPanelItem |
CacheGlobalData() | CXTPTaskPanelItem |
CalcInsideHeight() | CXTPTaskPanelGroup | protected
CopyToClipboard() | CXTPTaskPanelItem |
CreateFromOleData(COleDataObject *pDataObject) | CXTPTaskPanelItem | static
CreateFromOleFile(CFile *pDataObject) | CXTPTaskPanelItem | static
CXTPCmdTarget() | CXTPCmdTarget |
CXTPTaskPanelGroup(CXTPTaskPanel *pPanel=NULL) | CXTPTaskPanelGroup |
CXTPTaskPanelItem() | CXTPTaskPanelItem | protected
DoPropExchange(CXTPPropExchange *pPX) | CXTPTaskPanelGroup | virtual
DrawCaptionText(CDC *pDC, CRect rc, UINT nFormat) | CXTPTaskPanelItem | virtual
EnsureVisible(CXTPTaskPanelGroupItem *pItem, BOOL bUpdateScrollButtons=TRUE) | CXTPTaskPanelGroup |
CXTPTaskPanelItem::EnsureVisible() | CXTPTaskPanelItem |
FindItem(int nID) const | CXTPTaskPanelGroup |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAt(int nIndex) const | CXTPTaskPanelGroup |
GetCaption() const | CXTPTaskPanelItem |
GetCaptionHeight() const | CXTPTaskPanelGroup |
GetCaptionRect() const | CXTPTaskPanelGroup |
GetCaptionTextSize(CDC *pDC, CRect rc, UINT nFormat) | CXTPTaskPanelItem | virtual
GetClientRect() const | CXTPTaskPanelGroup |
GetEnabled() const | CXTPTaskPanelItem |
GetExpandedClientHeight() const | CXTPTaskPanelGroup |
GetHitTestRect() const | CXTPTaskPanelGroup | virtual
GetIconIndex() const | CXTPTaskPanelItem |
GetIconPadding() | CXTPTaskPanelItem |
GetID() const | CXTPTaskPanelItem |
GetImage(int nWidth) const | CXTPTaskPanelItem |
GetIndex() const | CXTPTaskPanelItem |
GetInnerMargins() | CXTPTaskPanelGroup |
GetInvalidateRect() const | CXTPTaskPanelGroup | virtual
GetItemCount() const | CXTPTaskPanelGroup |
GetItemData() const | CXTPTaskPanelItem |
GetItemFont() const | CXTPTaskPanelItem |
GetItemGroup() const | CXTPTaskPanelItem | virtual
GetItemIconSize() const | CXTPTaskPanelGroup |
GetItemLayout() const | CXTPTaskPanelGroup |
GetItems() const | CXTPTaskPanelGroup |
GetItemsInRow() const | CXTPTaskPanelGroup |
GetMarkupUIElement() const | CXTPTaskPanelItem |
GetMinimumClientHeight() const | CXTPTaskPanelGroup |
GetNextVisibleItem(int nIndex, int nDirection=+1) const | CXTPTaskPanelGroup |
GetOffsetItem() const | CXTPTaskPanelGroup |
GetOuterMargins() | CXTPTaskPanelGroup |
GetPaintManager() const | CXTPTaskPanelItem |
GetParentItems() const | CXTPTaskPanelItem |
GetScrollOffsetPos() const | CXTPTaskPanelGroup |
GetTargetCaptionRect() const | CXTPTaskPanelGroup |
GetTargetClientRect() const | CXTPTaskPanelGroup |
GetTaskPanel() const | CXTPTaskPanelItem |
GetTextRect(UINT *pFormat=0) const | CXTPTaskPanelItem |
GetTooltip() const | CXTPTaskPanelItem |
GetType() const | CXTPTaskPanelItem |
HitTest(CPoint pt, CRect *lpRect=0) const | CXTPTaskPanelGroup |
IsAcceptFocus() const | CXTPTaskPanelGroup | virtual
IsAllowDrag() const | CXTPTaskPanelItem |
IsAllowDrop() const | CXTPTaskPanelItem |
IsCaptionVisible() const | CXTPTaskPanelGroup |
IsChildItemDragOver() const | CXTPTaskPanelGroup |
IsDirty() const | CXTPTaskPanelGroup |
IsDroppedOff() const | CXTPTaskPanelItem |
IsExpandable() const | CXTPTaskPanelGroup |
IsExpanded() const | CXTPTaskPanelGroup |
IsExpanding() const | CXTPTaskPanelGroup |
IsGroup() const | CXTPTaskPanelItem |
IsItemDragging() const | CXTPTaskPanelItem |
IsItemDragOver() const | CXTPTaskPanelItem |
IsItemFocused() const | CXTPTaskPanelItem |
IsItemHot() const | CXTPTaskPanelItem |
IsItemPressed() const | CXTPTaskPanelItem |
IsItemVisible(CXTPTaskPanelGroupItem *pItem, BOOL bAllowPart) const | CXTPTaskPanelGroup |
IsScrollButtonEnabled(BOOL bScrollButtonUp) const | CXTPTaskPanelGroup |
IsSpecialGroup() const | CXTPTaskPanelGroup |
IsVisible() const | CXTPTaskPanelItem |
m_bAllowDrop | CXTPTaskPanelItem | protected
m_bCaptionVisible | CXTPTaskPanelGroup | protected
m_bEnabled | CXTPTaskPanelItem | protected
m_bExpandable | CXTPTaskPanelGroup | protected
m_bExpanded | CXTPTaskPanelGroup | protected
m_bExpanding | CXTPTaskPanelGroup | protected
m_bSpecial | CXTPTaskPanelGroup | protected
m_bVisible | CXTPTaskPanelItem | protected
m_dwData | CXTPTaskPanelItem | protected
m_itemLayout | CXTPTaskPanelGroup | protected
m_nAllowDrag | CXTPTaskPanelItem | protected
m_nBackgroundAlignemnt | CXTPTaskPanelGroup | protected
m_nBackgroundImage | CXTPTaskPanelGroup | protected
m_nCaptionHeight | CXTPTaskPanelGroup | protected
m_nExpandedClientHeight | CXTPTaskPanelGroup | protected
m_nIconIndex | CXTPTaskPanelItem | protected
m_nID | CXTPTaskPanelItem | protected
m_nItemsInRow | CXTPTaskPanelGroup | protected
m_nMinClientHeight | CXTPTaskPanelGroup | protected
m_nScrollOffset | CXTPTaskPanelGroup | protected
m_nTextFormat | CXTPTaskPanelItem | protected
m_pItems | CXTPTaskPanelGroup | protected
m_pMarkupUIElement | CXTPTaskPanelItem | protected
m_pPanel | CXTPTaskPanelItem | protected
m_rcGroupCurrent | CXTPTaskPanelGroup | protected
m_rcGroupTarget | CXTPTaskPanelGroup | protected
m_rcIconPadding | CXTPTaskPanelItem | protected
m_rcMarginsInner | CXTPTaskPanelGroup | protected
m_rcMarginsOuter | CXTPTaskPanelGroup | protected
m_rcText | CXTPTaskPanelItem | protected
m_strCaption | CXTPTaskPanelItem | protected
m_strTooltip | CXTPTaskPanelItem | protected
m_szItemIcon | CXTPTaskPanelGroup | protected
m_typeItem | CXTPTaskPanelItem | protected
m_xtpFontItem | CXTPTaskPanelItem | protected
OnAnimate(int nStep) | CXTPTaskPanelGroup |
OnCalcClientHeight(CDC *pDC, CRect rc) | CXTPTaskPanelGroup | protectedvirtual
OnFillClient(CDC *pDC, CRect rc) | CXTPTaskPanelGroup | virtual
OnInserted() | CXTPTaskPanelItem | protectedvirtual
OnPaint(CDC *pDC) | CXTPTaskPanelGroup |
OnRemoved() | CXTPTaskPanelGroup | protectedvirtual
OnReposition(CRect rc, BOOL bRecalcOnly=TRUE) | CXTPTaskPanelGroup |
PasteFromClipboard() | CXTPTaskPanelItem | static
RedrawPanel(BOOL bAnimate=FALSE) const | CXTPTaskPanelItem |
Remove() | CXTPTaskPanelItem |
RepositionPanel() const | CXTPTaskPanelItem |
Scroll(int nDelta) | CXTPTaskPanelGroup |
SetCaption(LPCTSTR lpszCaption) | CXTPTaskPanelItem |
SetClientBitmap(UINT nID, COLORREF clrTransparent, int nBackgroundAlignment=DT_RIGHT|DT_BOTTOM) | CXTPTaskPanelGroup |
SetEnabled(BOOL bEnabled) | CXTPTaskPanelItem |
SetExpandable(BOOL bExpandable) | CXTPTaskPanelGroup |
SetExpanded(BOOL bExpanded) | CXTPTaskPanelGroup |
SetIconIndex(int nIndex) | CXTPTaskPanelItem |
SetIconSize(CSize szItemIcon) | CXTPTaskPanelGroup |
SetID(UINT nID) | CXTPTaskPanelItem |
SetID(UINT nID, LPCTSTR lpCaption, LPCTSTR lpTooltip=NULL) | CXTPTaskPanelItem |
SetItemData(DWORD_PTR dwData) | CXTPTaskPanelItem |
SetItemFont(LOGFONT *pLogFont) | CXTPTaskPanelItem |
SetItemLayout(XTPTaskPanelItemLayout itemLayout) | CXTPTaskPanelGroup |
SetMinimumClientHeight(int nMinClientHeight) | CXTPTaskPanelGroup |
SetOffsetItem(int nScrollOffset, BOOL bUpdateScrollButtons=TRUE) | CXTPTaskPanelGroup |
SetSelectedItem(CXTPTaskPanelGroupItem *pItem) | CXTPTaskPanelGroup |
SetSpecialGroup(BOOL bSpecial=TRUE) | CXTPTaskPanelGroup |
SetTextRect(CDC *pDC, CRect rc, UINT nFormat) | CXTPTaskPanelItem |
SetTooltip(LPCTSTR lpszTooltip) | CXTPTaskPanelItem |
SetType(XTPTaskPanelItemType typeItem) | CXTPTaskPanelItem |
SetVisible(BOOL bVisible) | CXTPTaskPanelItem |
ShowCaption(BOOL bShow) | CXTPTaskPanelGroup |
~CXTPTaskPanelGroup() | CXTPTaskPanelGroup | virtual
~CXTPTaskPanelItem() | CXTPTaskPanelItem | virtual


Toolkit Pro: Member List

CXTPPaintManagerColor Member List

This is the complete list of members for CXTPPaintManagerColor, including all inherited members.

CXTPPaintManagerColor() | CXTPPaintManagerColor |
CXTPPaintManagerColor(COLORREF clr) | CXTPPaintManagerColor |
GetStandardColor() const | CXTPPaintManagerColor |
IsCustomValue() const | CXTPPaintManagerColor |
IsDefaultValue() const | CXTPPaintManagerColor |
IsStandardValue() const | CXTPPaintManagerColor |
m_clrCustomValue | CXTPPaintManagerColor | protected
m_clrStandardValue | CXTPPaintManagerColor | protected
operator COLORREF() const | CXTPPaintManagerColor |
operator=(COLORREF clr) | CXTPPaintManagerColor |
operator=(const CXTPPaintManagerColor &refclr) | CXTPPaintManagerColor |
Serialize(CArchive &ar) | CXTPPaintManagerColor | virtual
SetCustomValue(COLORREF clr) | CXTPPaintManagerColor |
SetDefaultValue() | CXTPPaintManagerColor |
SetStandardValue(COLORREF clr) | CXTPPaintManagerColor |
~CXTPPaintManagerColor() | CXTPPaintManagerColor | inlinevirtual


Toolkit Pro: Member List

XTP_LC_TIMEFORMAT Member List

This is the complete list of members for XTP_LC_TIMEFORMAT, including all inherited members.


Toolkit Pro: Member List

CXTPScrollBarThemeResource Member List

This is the complete list of members for CXTPScrollBarThemeResource, including all inherited members.

CalcHScroll(CXTPScrollBase *pScroll, XTPScrollMetricsH *pHScroll) | CXTPScrollBarPaintManager | protectedstatic
CalcVScroll(CXTPScrollBase *pScroll, XTPScrollMetricsV *pVScroll) | CXTPScrollBarPaintManager | protectedstatic
CXTPScrollBarPaintManager() | CXTPScrollBarPaintManager |
DrawArrowGlyph(CDC *pDC, CRect rcArrow, XTPArrowGlyph glyph, BOOL bEnabled, COLORREF clrText=COLORREF_NULL) | CXTPScrollBarPaintManager | protected
DrawArrows(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics) | CXTPScrollBarThemeResource | protectedvirtual
DrawArrows(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics) | CXTPScrollBarThemeResource | protectedvirtual
DrawBackground(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics) | CXTPScrollBarThemeResource | protectedvirtual
DrawBackground(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics) | CXTPScrollBarThemeResource | protectedvirtual
DrawButtons(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics) | CXTPScrollBarThemeResource | protectedvirtual
DrawButtons(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics) | CXTPScrollBarThemeResource | protectedvirtual
DrawGripper(CDC *pDC, CXTPScrollBase *pScroll) | CXTPScrollBarThemeResource | protectedvirtual
DrawScrollBar(CDC *pDC, CXTPScrollBase *pScrollBar) | CXTPScrollBarThemeResource | protectedvirtual
DrawThumbButton(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics) | CXTPScrollBarThemeResource | protectedvirtual
DrawThumbButton(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics) | CXTPScrollBarThemeResource | protectedvirtual
DrawTracker(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics) | CXTPScrollBarThemeResource | protectedvirtual
DrawTracker(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics) | CXTPScrollBarThemeResource | protectedvirtual
LoadImage(LPCTSTR lpszImageFile) | CXTPScrollBarThemeResource | protected
m_crBack | CXTPScrollBarPaintManager |
m_crBackHilite | CXTPScrollBarPaintManager |
m_crBackPushed | CXTPScrollBarPaintManager |
m_crBorder | CXTPScrollBarPaintManager |
m_crBorderHilite | CXTPScrollBarPaintManager |
m_cThumb | CXTPScrollBarPaintManager |
m_cxHScroll | CXTPScrollBarPaintManager |
m_cxVScroll | CXTPScrollBarPaintManager |
m_cyHScroll | CXTPScrollBarPaintManager |
m_cyVScroll | CXTPScrollBarPaintManager |
RefreshMetrics() | CXTPScrollBarPaintManager | virtual


Toolkit Pro: XTPDatePickerVisualStudio2019Theme.h Source File

  • Source
  • Calendar
  • DatePicker
  • Themes
XTPDatePickerVisualStudio2019Theme.h
Go to the documentation of this file.
1
22#if !defined(_XTPDATEPICKERVISUALSTUDIO2019THEME_H__)
23# define _XTPDATEPICKERVISUALSTUDIO2019THEME_H__
24
25# if _MSC_VER > 1000
26# pragma once
27# endif // _MSC_VER > 1000
28
29# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
30
51class _XTP_EXT_CLASS CXTPDatePickerThemeVisualStudio2019 : public CXTPDatePickerThemeOffice2013
52{
53public:
62 CXTPDatePickerThemeVisualStudio2019();
63
70 virtual ~CXTPDatePickerThemeVisualStudio2019();
71};
72
73# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
74#endif // !defined(_XTPDATEPICKERVISUALSTUDIO2019THEME_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPDatePickerThemeOffice2013
Class CXTPDatePickerThemeOffice2013 is derived from CXTPDatePickerPaintManager for rendering an Offic...
Definition XTPDatePickerOffice2013Theme.h:52
CXTPDatePickerThemeVisualStudio2019
Class CXTPDatePickerThemeVisualStudio2019 is derived from CXTPDatePickerThemeOffice2013 for rendering...
Definition XTPDatePickerVisualStudio2019Theme.h:52
CXTPDatePickerThemeVisualStudio2019::CXTPDatePickerThemeVisualStudio2019
CXTPDatePickerThemeVisualStudio2019()
Default paint manager constructor.
CXTPDatePickerThemeVisualStudio2019::~CXTPDatePickerThemeVisualStudio2019
virtual ~CXTPDatePickerThemeVisualStudio2019()
Default paint manager destructor.


Toolkit Pro: XTPTabThemeNativeWindows11.h Source File

  • Source
  • TabManager
  • Themes
XTPTabThemeNativeWindows11.h
Go to the documentation of this file.
1
23#if !defined(__XTPTABTHEMENATIVEWINDOWS11_H__)
24# define __XTPTABTHEMENATIVEWINDOWS11_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
37class _XTP_EXT_CLASS CXTPTabThemeNativeWindows11 : public CXTPTabThemeOffice2013
38{
39public:
44 CXTPTabThemeNativeWindows11();
45
54 virtual void RefreshMetrics();
55
64 virtual XTPTabColorStyle GetDefaultColorSet()
65 {
66 return xtpTabColorNativeWindows11;
67 }
68};
69
70# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
72#endif // __XTPTABTHEMENATIVEWINDOWS11_H__
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPTabColorStyle
XTPTabColorStyle
XTPTabColorStyle is an enumeration used to set the color style of tabs.
Definition XTPTabManagerDefines.h:139
xtpTabColorNativeWindows11
@ xtpTabColorNativeWindows11
Tabs will use the Native Windows 11 color style for the currently set Appearance.
Definition XTPTabManagerDefines.h:176
CXTPTabThemeNativeWindows11
CXTPTabThemeNativeWindows11 implements a Native Windows 10 tab appearance.
Definition XTPTabThemeNativeWindows11.h:38
CXTPTabThemeNativeWindows11::GetDefaultColorSet
virtual XTPTabColorStyle GetDefaultColorSet()
Gets the default value of the color set for this theme.
Definition XTPTabThemeNativeWindows11.h:64
CXTPTabThemeNativeWindows11::CXTPTabThemeNativeWindows11
CXTPTabThemeNativeWindows11()
Constructs a CXTPTabThemeNativeWindows11 object.
CXTPTabThemeNativeWindows11::RefreshMetrics
virtual void RefreshMetrics()
Refreshes the appearance metrics.
CXTPTabThemeOffice2013
CXTPTabThemeOffice2013 implements an Office 2013 tab appearance.
Definition XTPTabThemeOffice2013.h:38


Toolkit Pro: XTPChart2dPieSeriesView.h Source File

  • Source
  • Chart
  • Styles
  • Pie
  • 2D
XTPChart2dPieSeriesView.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHART2DPIESERIESVIEW_H__)
24# define __XTPCHART2DPIESERIESVIEW_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
44class _XTP_EXT_CLASS CXTPChartPieSeriesView : public CXTPChartPieSeriesViewBase
45{
46public:
54 CXTPChartPieSeriesView(CXTPChartSeries* pSeries, CXTPChartDiagramView* pDiagramView);
55
56public:
64 virtual void CalculatePointLayout(CXTPChartDeviceContext* pDC, CRect rcBounds);
65
66protected:
78 virtual CXTPChartSeriesPointView* CreateSeriesPointView(CXTPChartDeviceContext* pDC,
79 CXTPChartSeriesPoint* pPoint,
80 CXTPChartElementView* pParentView);
81
94 virtual CXTPChartDeviceCommand* CreateDeviceCommand(CXTPChartDeviceContext* pDC);
95
106 virtual CXTPChartDeviceCommand* CreateLegendDeviceCommand(CXTPChartDeviceContext* pDC,
107 CRect rcBounds);
108};
110# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
111#endif //#if !defined(__XTPCHART2DPIESERIESVIEW_H__)
pPoint
const CPoint * pPoint
return 0 or xtpCalendarHitTestDayExpandButton
Definition XTPCalendarThemeOffice2007.h:150
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartDiagramView
This class represents the view of a chart diagram, which is a kind of CXTPChartElementView.
Definition XTPChartDiagramView.h:49
CXTPChartElementView
This class represents the view of a chart element.
Definition XTPChartElementView.h:47
CXTPChartPieSeriesViewBase
This class abstracts the view of a pie series.
Definition XTPChartPieSeriesViewBase.h:45
CXTPChartPieSeriesView
This class abstracts the view of a pie series.
Definition XTPChart2dPieSeriesView.h:45
CXTPChartPieSeriesView::CalculatePointLayout
virtual void CalculatePointLayout(CXTPChartDeviceContext *pDC, CRect rcBounds)
Call this function to calculate the pie series point layout.
CXTPChartPieSeriesView::CXTPChartPieSeriesView
CXTPChartPieSeriesView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Constructs a CXTPChartPieSeriesView object.
CXTPChartPieSeriesView::CreateDeviceCommand
virtual CXTPChartDeviceCommand * CreateDeviceCommand(CXTPChartDeviceContext *pDC)
This function creates a view drawing command object.
CXTPChartPieSeriesView::CreateLegendDeviceCommand
virtual CXTPChartDeviceCommand * CreateLegendDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcBounds)
This function creates a label view drawing command object.
CXTPChartPieSeriesView::CreateSeriesPointView
virtual CXTPChartSeriesPointView * CreateSeriesPointView(CXTPChartDeviceContext *pDC, CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Use this function to create the pie series point view object.
CXTPChartSeries
This class represents a series in the chart, which is a kind of CXTPChartElement.
Definition XTPChartSeries.h:50
CXTPChartSeriesPoint
CXTPChartSeriesPoint is a kind of CXTPChartElement.
Definition XTPChartSeriesPoint.h:43
CXTPChartSeriesPointView
Represents chart series point view.
Definition XTPChartSeriesPointView.h:48


Toolkit Pro: XTPGridSelectedRows.h Source File

  • Source
  • GridControl
XTPGridSelectedRows.h
Go to the documentation of this file.
1
23#if !defined(__XTPGRIDSELECTEDROWS_H__)
24# define __XTPGRIDSELECTEDROWS_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPGridRow;
34class CXTPGridRecord;
35class CXTPGridRecordItem;
36class CXTPGridControl;
37class CXTPGridColumns;
38
72class _XTP_EXT_CLASS CXTPGridSelectedRows : public CXTPCmdTarget
73{
74public:
91 CXTPGridSelectedRows(CXTPGridControl* pControl);
92
105 void SelectBlock(int nBlockBegin, int nBlockEnd, BOOL bControlKey = TRUE);
106
112 BOOL Clear();
113
120 BOOL Clear(BOOL bNotifyOnClear);
121
137 BOOL Add(CXTPGridRow* pRow);
138
147 void AddBlock(int nIndexBegin, int nIndexEnd, BOOL bDeselectIfSelected = FALSE);
148
163 void Remove(CXTPGridRow* pRow);
164
180 BOOL Contains(const CXTPGridRow* pRow);
181
203 void Invert(CXTPGridRow* pRow);
204
218 BOOL Select(CXTPGridRow* pRow);
219
230 void DeselectBlock(int ib, int ie, BOOL bCollapsed);
231
240 int GetCount();
241
254 CXTPGridRow* GetAt(int nIndex);
255
268 POSITION GetFirstSelectedRowPosition();
269
279 CXTPGridRow* GetNextSelectedRow(POSITION& pos);
280
287 BOOL IsChanged() const;
288
295 void SetChanged(BOOL bChanged = TRUE);
296
307 BOOL SwapIfNeed(int& indexB, int& indexE);
308
324 void SetNotifyOnClear(BOOL bNotifyOnClear = TRUE);
325
341 BOOL GetNotifyOnClear() const;
342
350 XTPGridRowType GetRowType() const;
351
352protected:
354 BOOL _NotifySelChanging(XTPGridSelectionChangeType nType, CXTPGridRow* pRow = NULL);
355 void _NotifyStateChanged(int nBegin, int nEnd);
356 void _InsertBlock(int nIndexInsert, int nIndexBegin, int nIndexEnd);
357 void _OnExpanded(int nIndex, int nCount);
358 void _OnCollapsed(int nIndex, int nCount);
359
360 struct SELECTED_BLOCK
361 {
362 int nIndexBegin;
363 int nIndexEnd;
364 };
365
366 CXTPGridControl* m_pControl;
367 int m_nRowBlockBegin;
368 int m_nPosSelected;
369 BOOL m_bNotifyOnClear;
375 CArray<SELECTED_BLOCK, SELECTED_BLOCK&> m_arrSelectedBlocks;
376
377 BOOL m_bChanged;
378 XTPGridRowType m_nRowType;
382# ifdef _XTP_ACTIVEX
384 DECLARE_DISPATCH_MAP()
385 DECLARE_INTERFACE_MAP()
386
387 DECLARE_OLETYPELIB_EX(CXTPGridSelectedRows);
388
389 afx_msg void OleAdd(LPDISPATCH lpRow);
390 afx_msg void OleDeleteAll();
391 afx_msg LPDISPATCH OleGetItem(long nIndex);
392 int OleGetItemCount();
393
394 DECLARE_ENUM_VARIANTLIST(CXTPGridSelectedRows);
395
396 enum
397 {
398 dispidCount = 1L,
399 };
400
402# endif
404 friend class CXTPGridControl;
405 friend class CXTPGridSection;
407};
408
409AFX_INLINE void CXTPGridSelectedRows::SetNotifyOnClear(BOOL bNotifyOnClear)
410{
411 m_bNotifyOnClear = bNotifyOnClear;
412}
413
414AFX_INLINE BOOL CXTPGridSelectedRows::GetNotifyOnClear() const
415{
416 return m_bNotifyOnClear;
417}
418
419AFX_INLINE BOOL CXTPGridSelectedRows::IsChanged() const
420{
421 return m_bChanged;
422}
423
424AFX_INLINE void CXTPGridSelectedRows::SetChanged(BOOL bChanged)
425{
426 m_bChanged = bChanged;
427}
428
429AFX_INLINE XTPGridRowType CXTPGridSelectedRows::GetRowType() const
430{
431 return m_nRowType;
432}
434# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
435#endif //#if !defined(__XTPGRIDSELECTEDROWS_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPGridRowType
XTPGridRowType
This enum defines body, header, and footer rows.
Definition XTPGridDefines.h:94
XTPGridSelectionChangeType
XTPGridSelectionChangeType
This enumeration defines the selection change action.
Definition XTPGridRows.h:46
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPGridColumns
This class is a collection of grid column objects.
Definition XTPGridColumns.h:54
CXTPGridControl
The CXTPGridControl class provides an implementation of the Grid control.
Definition XTPGridControl.h:479
CXTPGridRecord
CXTPGridRecord represents a collection of CXTPGridRecordItem objects or objects of classes that are c...
Definition XTPGridRecord.h:59
CXTPGridRecordItem
Class for working with single list cell.
Definition XTPGridRecordItem.h:600
CXTPGridRow
CXTPGridRow class represents a row of the Grid control window.
Definition XTPGridRow.h:71
CXTPGridSection
Represents a grid section.
Definition XTPGridSection.h:61
CXTPGridSelectedRows
Encapsulates a collection of CXTPGridRow pointers that represent the selected rows in a Grid control.
Definition XTPGridSelectedRows.h:73
CXTPGridSelectedRows::Remove
void Remove(CXTPGridRow *pRow)
Removes a row from the selection.
CXTPGridSelectedRows::Select
BOOL Select(CXTPGridRow *pRow)
Clears the initial selection and selects a specified row.
CXTPGridSelectedRows::SetChanged
void SetChanged(BOOL bChanged=TRUE)
Specifies if the selection was changed.
Definition XTPGridSelectedRows.h:424
CXTPGridSelectedRows::IsChanged
BOOL IsChanged() const
Determines if the selection was changed.
Definition XTPGridSelectedRows.h:419
CXTPGridSelectedRows::Clear
BOOL Clear(BOOL bNotifyOnClear)
Clears itself, removing all elements from the selection.
CXTPGridSelectedRows::GetNextSelectedRow
CXTPGridRow * GetNextSelectedRow(POSITION &pos)
Gets the next selected row in the list Grid control.
CXTPGridSelectedRows::Add
BOOL Add(CXTPGridRow *pRow)
Adds a row to the selection.
CXTPGridSelectedRows::CXTPGridSelectedRows
CXTPGridSelectedRows(CXTPGridControl *pControl)
Constructs an empty CXTPGridSelectedRows collection.
CXTPGridSelectedRows::GetAt
CXTPGridRow * GetAt(int nIndex)
Retrieves a specified row by its index.
CXTPGridSelectedRows::AddBlock
void AddBlock(int nIndexBegin, int nIndexEnd, BOOL bDeselectIfSelected=FALSE)
Adds a block to the selection.
CXTPGridSelectedRows::Contains
BOOL Contains(const CXTPGridRow *pRow)
Determines if a specified row is contained within the selection.
CXTPGridSelectedRows::Clear
BOOL Clear()
Clears itself, removing all elements from the selection.
CXTPGridSelectedRows::GetNotifyOnClear
BOOL GetNotifyOnClear() const
Determines if clear notifications are enabled/disabled during CXTPGridSelectedRows::Select and Select...
Definition XTPGridSelectedRows.h:414
CXTPGridSelectedRows::SelectBlock
void SelectBlock(int nBlockBegin, int nBlockEnd, BOOL bControlKey=TRUE)
Selects a block of rows.
CXTPGridSelectedRows::GetCount
int GetCount()
Gets the number of selected rows in the collection.
CXTPGridSelectedRows::GetRowType
XTPGridRowType GetRowType() const
Gets the type of the selected rows (i.e.
Definition XTPGridSelectedRows.h:429
CXTPGridSelectedRows::Invert
void Invert(CXTPGridRow *pRow)
Inverts the selection for a specified row.
CXTPGridSelectedRows::SetNotifyOnClear
void SetNotifyOnClear(BOOL bNotifyOnClear=TRUE)
Specifies if clear notifications are enabled/disabled during CXTPGridSelectedRows::Select and SelectB...
Definition XTPGridSelectedRows.h:409
CXTPGridSelectedRows::DeselectBlock
void DeselectBlock(int ib, int ie, BOOL bCollapsed)
Removes block [ib:ie] from the selection.
CXTPGridSelectedRows::SwapIfNeed
BOOL SwapIfNeed(int &indexB, int &indexE)
Swaps two integers.
CXTPGridSelectedRows::GetFirstSelectedRowPosition
POSITION GetFirstSelectedRowPosition()
Gets the position of the first selected row in the list Grid control.


Toolkit Pro: XTPSkinObjectSpin.h Source File

  • Source
  • SkinFramework
XTPSkinObjectSpin.h
Go to the documentation of this file.
1
23#if !defined(__XTPSKINOBJECTSPIN_H__)
24# define __XTPSKINOBJECTSPIN_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPSkinObjectSpin : public CXTPSkinObjectFrame
39{
41 DECLARE_DYNCREATE(CXTPSkinObjectSpin)
43public:
48 CXTPSkinObjectSpin();
49
54 virtual ~CXTPSkinObjectSpin();
55
56 void OnDraw(CDC* pDC);
57
58protected:
60 UINT HitTest(CPoint pt);
61
62protected:
63 DECLARE_MESSAGE_MAP()
64
65 //{{AFX_VIRTUAL(CXTPSkinObjectSpin)
66 //}}AFX_VIRTUAL
67
68 //{{AFX_MSG(CXTPSkinObjectSpin)
69 afx_msg BOOL OnEraseBkgnd(CDC* pDC);
70 afx_msg void OnPaint();
71 afx_msg void OnMouseMove(UINT nFlags, CPoint point);
72 afx_msg void OnMouseLeave();
73 afx_msg void OnTimer(UINT_PTR nIDEvent);
74 afx_msg void OnLButtonUp(UINT nFlags, CPoint point);
75 afx_msg void OnLButtonDown(UINT nFlags, CPoint point);
76 afx_msg LRESULT OnPrintClient(WPARAM wParam, LPARAM lParam);
77 //}}AFX_MSG
78protected:
79 UINT m_nHotButton;
80 UINT m_nPressedButton;
82};
83
84# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
86#endif // !defined(__XTPSKINOBJECTSPIN_H__)
XTPDisableNoisyWarnings.h
CXTPSkinObjectFrame
CXTPSkinObjectFrame is a CXTPSkinObject derived class.
Definition XTPSkinObjectFrame.h:75
CXTPSkinObjectSpin
CXTPSkinObjectSpin is a CXTPSkinObjectFrame derived class.
Definition XTPSkinObjectSpin.h:39
CXTPSkinObjectSpin::~CXTPSkinObjectSpin
virtual ~CXTPSkinObjectSpin()
Destroys a CXTPSkinObjectSpin object, handles cleanup and deallocation.
CXTPSkinObjectSpin::CXTPSkinObjectSpin
CXTPSkinObjectSpin()
Constructs a CXTPSkinObjectSpin object.


Toolkit Pro: Member List

CXTPBrush Member List

This is the complete list of members for CXTPBrush, including all inherited members.

__declspec(property(get=GetSafeHandle)) HGDIOBJ m_hObject | CXTPGdiObject |
CreateBrushIndirect(const LOGBRUSH *lpLogBrush) | CXTPBrush |
CreateDIBPatternBrush(HGLOBAL hPackedDIB, UINT nUsage) | CXTPBrush |
CreateDIBPatternBrush(const void *lpPackedDIB, UINT nUsage) | CXTPBrush |
CreateHatchBrush(int nIndex, COLORREF crColor) | CXTPBrush |
CreatePatternBrush(CBitmap *pBitmap) | CXTPBrush |
CreateSolidBrush(COLORREF crColor) | CXTPBrush |
CreateStockObject(int nIndex) | CXTPGdiObject |
CreateSysColorBrush(int nIndex) | CXTPBrush |
CXTPBrush() | CXTPBrush |
CXTPBrush(COLORREF crColor) | CXTPBrush |
CXTPBrush(int nIndex, COLORREF crColor) | CXTPBrush |
CXTPBrush(CBitmap *pBitmap) | CXTPBrush |
CXTPGdiObject() | CXTPGdiObject | protected
DeleteObject() | CXTPGdiObject |
GetLogBrush(LOGBRUSH *pLogBrush) | CXTPBrush |
GetNativeGdiObject() | CXTPBrush |
GetNativeGdiObject() const | CXTPBrush |
GetObject(int nCount, LPVOID lpObject) const | CXTPGdiObject |
GetObjectType() const | CXTPGdiObject |
GetSafeHandle() const | CXTPGdiObject |
IsHandleOwnershipGuaranteed() const | CXTPGdiObject |
operator CBrush &() | CXTPBrush |
operator CGdiObject &() | CXTPGdiObject |
operator const CBrush &() const | CXTPBrush |
operator const CGdiObject &() const | CXTPGdiObject |
operator HBRUSH() const | CXTPBrush |
operator HGDIOBJ() const | CXTPGdiObject |
operator!=(const CXTPGdiObject &obj) const | CXTPGdiObject |
operator==(const CXTPGdiObject &obj) const | CXTPGdiObject |
SetHandleOwnershipNotGuaranteed() | CXTPGdiObject |
~CXTPBrush() | CXTPBrush |
~CXTPGdiObject()=0 | CXTPGdiObject | pure virtual


Toolkit Pro: XTPCalendarResourceTheme.h Source File

  • Source
  • Calendar
  • Themes
XTPCalendarResourceTheme.h
Go to the documentation of this file.
1
22#if !defined(__XTPCALENDARRESOURCETHEME_H__)
23# define __XTPCALENDARRESOURCETHEME_H__
24
25# if _MSC_VER > 1000
26# pragma once
27# endif // _MSC_VER > 1000
28
29# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
30
36class _XTP_EXT_CLASS CXTPCalendarResourceTheme : public CXTPCalendarPaintManager
37{
38public:
47 CXTPCalendarResourceTheme();
48
55 virtual ~CXTPCalendarResourceTheme();
56
64 virtual void RefreshMetrics();
65
66 virtual COLORREF GetColor2(LPCTSTR pcszColorName, COLORREF clrDefault);
67};
68
69# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
70#endif // !defined(__XTPCALENDARRESOURCETHEME_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCalendarPaintManager
Utility class, handles most of the drawing activities.
Definition XTPCalendarPaintManager.h:150
CXTPCalendarResourceTheme
CXTPCalendarResourceTheme is a CXTPCalendarPaintManager derived class that represents the Resource ca...
Definition XTPCalendarResourceTheme.h:37
CXTPCalendarResourceTheme::CXTPCalendarResourceTheme
CXTPCalendarResourceTheme()
Default paint manager constructor.
CXTPCalendarResourceTheme::~CXTPCalendarResourceTheme
virtual ~CXTPCalendarResourceTheme()
Default paint manager destructor.
CXTPCalendarResourceTheme::RefreshMetrics
virtual void RefreshMetrics()
This member function is used to initialize all drawing defaults.


Toolkit Pro: Member List

CXTPCalendarTimeLineViewTimeScalePart Member List

This is the complete list of members for CXTPCalendarTimeLineViewTimeScalePart, including all inherited members.

CalcHeigt(CDC *pDC) | CXTPCalendarTimeLineViewTimeScalePart | virtual
CXTPCalendarTimeLineViewTimeScalePart(CXTPCalendarViewPart *pParentPart=NULL) | CXTPCalendarTimeLineViewTimeScalePart |
CXTPCalendarViewPart(CXTPCalendarViewPart *pParentPart=NULL) | CXTPCalendarViewPart |
CXTPCmdTarget() | CXTPCmdTarget |
Draw(CDC *pDC, const CRect &rcRect, CXTPCalendarTimeLineView *pView) | CXTPCalendarTimeLineViewTimeScalePart | virtual
DrawHeader(CDC *pDC, const CRect &rcRect, CXTPCalendarTimeLineView *pView, int nLabelInterval) | CXTPCalendarTimeLineViewTimeScalePart | virtual
DrawLine_CenterLR(CDC *pDC, const CString &str, LPRECT lpRect, UINT nFormat) | CXTPCalendarViewPart |
DrawLineEx(CDC *pDC, const CString &str, LPRECT lpRect, UINT nFormatNormal, UINT nFormatSmall) | CXTPCalendarViewPart |
DrawText(CDC *pDC, const CString &str, LPRECT lpRect, UINT nFormat, COLORREF clrText=COLORREF_NULL, CFont *pFont=NULL) | CXTPCalendarViewPart |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetBackgroundColor() | CXTPCalendarViewPart | virtual
GetHeaderDateFormat(int nLabelInterval) | CXTPCalendarTimeLineViewTimeScalePart | virtual
GetHeaderHeight() | CXTPCalendarTimeLineViewTimeScalePart | inlinevirtual
GetTextColor() | CXTPCalendarViewPart | virtual
GetTextExtent(CDC *pDC, const CString &str) | CXTPCalendarViewPart |
GetTextFont() | CXTPCalendarViewPart | virtual
m_clrBackground | CXTPCalendarViewPart |
m_clrTextColor | CXTPCalendarViewPart |
m_fntScaleHeaderText | CXTPCalendarTimeLineViewTimeScalePart |
m_fntText | CXTPCalendarViewPart |
m_pPaintManager | CXTPCalendarViewPart |
m_pParentPart | CXTPCalendarViewPart |
RefreshMetrics() | CXTPCalendarTimeLineViewTimeScalePart | virtual
SetBackgroundColor(COLORREF clr) | CXTPCalendarViewPart |
SetTextColor(COLORREF clr) | CXTPCalendarViewPart |
SetTextFont(LOGFONT *pLogFont) | CXTPCalendarViewPart |
~CXTPCalendarViewPart() | CXTPCalendarViewPart | virtual


Toolkit Pro: Member List

CXTPCommandBarsModernUITheme Member List

This is the complete list of members for CXTPCommandBarsModernUITheme, including all inherited members.

AdjustExcludeRect(CRect &rc, CXTPControl *pControl, BOOL bVertical) | CXTPCommandBarsOfficeXPTheme | virtual
Animate(CDC *pDestDC, CDC *pSrcDC, CRect rc, XTPAnimationType animationType) | CXTPPaintManager | virtual
AnimateExpanding(CXTPCommandBar *pCommandBar, CDC *pDestDC, CDC *pSrcDC, BOOL bExpandDown) | CXTPPaintManager | virtual
BaseTheme() | CXTPCommandBarsOfficeXPTheme | inlineprotectedvirtual
CreateTheme(XTPPaintTheme paintTheme) | CXTPPaintManager | static
CXTPCmdTarget() | CXTPCmdTarget |
CXTPCommandBarsModernUITheme() | CXTPCommandBarsModernUITheme |
CXTPCommandBarsOfficeXPTheme() | CXTPCommandBarsOfficeXPTheme |
CXTPObservable() | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | protected
CXTPPaintManager() | CXTPPaintManager | protected
Draw3dRect(CDC *pDC, LPCRECT rc, int nTopLeft, int nBottomRight) | CXTPPaintManager |
Draw3dRect(CDC *pDC, LPCRECT rc, int frameThickness, COLORREF clrPen, COLORREF clrBrush) | CXTPPaintManager |
CXTPPaintManager::DrawCheckMark(CDC *pDC, CRect rcCheck, COLORREF clr=0) | CXTPPaintManager | inline
DrawComboExpandMark(CDC *pDC, CRect rc, COLORREF clr) | CXTPPaintManager | virtual
DrawCommandBarGripper(CDC *pDC, CXTPCommandBar *pBar, BOOL bDraw=TRUE) | CXTPCommandBarsOfficeXPTheme | virtual
DrawCommandBarGroupSeparator(CDC *pDC, CXTPCommandBar *pBar, CXTPControl *pLeftControl, CXTPControl *pRightControl, BOOL bDraw=TRUE) | CXTPPaintManager | virtual
DrawCommandBarSeparator(CDC *pDC, CXTPCommandBar *pBar, CXTPControl *pControl, BOOL bDraw=TRUE) | CXTPCommandBarsOfficeXPTheme | virtual
DrawControl(CDC *pDC, CXTPControl *pButton, BOOL bDraw=TRUE) | CXTPPaintManager |
DrawControlCheckBoxMark(CDC *pDC, CRect rc, BOOL bDraw, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled) | CXTPCommandBarsOfficeXPTheme | protectedvirtual
DrawControlCheckBoxMark(CDC *pDC, CXTPControl *pButton, CRect rc, BOOL bDraw) | CXTPCommandBarsOfficeXPTheme | protectedvirtual
DrawControlComboBox(CDC *pDC, CXTPControlComboBox *pComboBox, BOOL bDraw) | CXTPCommandBarsOfficeXPTheme | protectedvirtual
DrawControlEdit(CDC *pDC, CXTPControlEdit *pEdit, BOOL bDraw) | CXTPCommandBarsOfficeXPTheme | protectedvirtual
DrawControlEntry(CDC *pDC, CXTPControl *pButton) | CXTPPaintManager | virtual
DrawControlMDIButton(CDC *pDC, CXTPControlButton *pButton) | CXTPPaintManager | virtual
DrawControlPopupParent(CDC *pDC, CXTPControl *pButton, BOOL bDraw) | CXTPCommandBarsOfficeXPTheme | protectedvirtual
DrawControlRadioButtonMark(CDC *pDC, CRect rc, BOOL bDraw, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled) | CXTPCommandBarsOfficeXPTheme | protectedvirtual
DrawControlText(CDC *pDC, CXTPControl *pControl, CRect rcText, BOOL bDraw, BOOL bVert, BOOL bCentered, BOOL bTriangled) | CXTPPaintManager |
DrawControlToolBarParent(CDC *pDC, CXTPControl *pButton, BOOL bDraw) | CXTPPaintManager | virtual
DrawDialogBarGripper(CDC *pDC, CXTPDialogBar *pBar, BOOL bDraw) | CXTPCommandBarsOfficeXPTheme | virtual
DrawDropDownGlyph(CDC *pDC, CXTPControl *pControl, CPoint pt, BOOL bSelected, BOOL bPopuped, BOOL bEnabled, BOOL bVert) | CXTPPaintManager | virtual
DrawExpandGlyph(CDC *pDC, CXTPControl *pButton, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clr) | CXTPPaintManager | virtual
DrawExpandGlyph(CDC *pDC, CXTPControl *pButton, COLORREF clr, BOOL bVertical) | CXTPPaintManager | virtual
DrawGalleryItemBack(CDC *pDC, CRect rcItem, BOOL bEnabled, BOOL bSelected, BOOL bPressed, BOOL bChecked, XTPBarType barType) | CXTPPaintManager | virtual
DrawHiddenGlyph(CDC *pDC, CXTPControl *pButton, COLORREF clr, BOOL bVertical) | CXTPPaintManager | virtual
DrawImage(CDC *pDC, CPoint pt, CSize sz, CXTPImageManagerIcon *pImage, BOOL bSelected, BOOL bPressed, BOOL bEnabled=TRUE, BOOL bChecked=FALSE, BOOL bPopuped=FALSE, BOOL bToolBarImage=TRUE) | CXTPCommandBarsOfficeXPTheme | protectedvirtual
DrawListBoxControl(CDC *pDC, CXTPControl *pButton, CRect rc, BOOL bSelected, BOOL bDraw, CXTPCommandBars *pCommandBars=0) | CXTPCommandBarsOfficeXPTheme | virtual
DrawPopupBarCheckMark(CDC *pDC, CRect rcCheck, BOOL bEnabled, COLORREF clr) | CXTPPaintManager | virtual
DrawPopupBarGripper(CDC *pDC, int xPos, int yPos, int cx, int cy, BOOL bExpanded=FALSE) | CXTPCommandBarsOfficeXPTheme | protectedvirtual
DrawPopupBarRadioMark(CDC *pDC, CRect rcCheck, BOOL bEnabled, COLORREF clr) | CXTPPaintManager | virtual
DrawPopupResizeGripper(CDC *pDC, CRect rcGripper, int nFlags) | CXTPCommandBarsOfficeXPTheme | virtual
DrawRectangle(CDC *pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition) | CXTPCommandBarsOfficeXPTheme | protectedvirtual
DrawRectangle(CDC *pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition, int nID) | CXTPCommandBarsOfficeXPTheme | protectedvirtual
DrawRectangle(CDC *pDC, CXTPControl *pButton) | CXTPCommandBarsOfficeXPTheme | protectedvirtual
DrawSpecialControl(CDC *pDC, XTPSpecialControl controlType, CXTPControl *pButton, CXTPCommandBar *pBar, BOOL bDraw, LPVOID lpParam) | CXTPPaintManager | virtual
DrawSplitButtonFrame(CDC *pDC, CXTPControl *pButton, CRect rc) | CXTPCommandBarsOfficeXPTheme | protectedvirtual
DrawTearOffGripper(CDC *pDC, CRect rcGripper, BOOL bSelected, BOOL bDraw) | CXTPCommandBarsOfficeXPTheme | virtual
FillCommandBarEntry(CDC *pDC, CXTPCommandBar *pBar) | CXTPCommandBarsOfficeXPTheme | virtual
FillDockBar(CDC *pDC, CXTPDockBar *pBar) | CXTPPaintManager | virtual
FillIntersectRect(CDC *pDC, CXTPPopupBar *pPopupBar, COLORREF clr) | CXTPCommandBarsOfficeXPTheme | protected
FillWorkspace(CDC *pDC, CRect rc, CRect rcExclude) | CXTPPaintManager | virtual
FontExists(LPCTSTR lpszFaceName) | CXTPPaintManager | static
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCommandBarBorders(CXTPCommandBar *pBar) | CXTPPaintManager | virtual
GetCommandBarFont(CXTPCommandBar *pCommandBar) | CXTPPaintManager | virtual
GetControlBackColor(CXTPControl *pButton) | CXTPPaintManager | virtual
GetControlEditBackColor(CXTPControl *pControl) | CXTPPaintManager | virtual
GetControlFont(CXTPControl *pControl) | CXTPPaintManager | virtual
GetControlHeight() const | CXTPPaintManager |
GetControlTextColor(CXTPControl *pButton) | CXTPPaintManager | virtual
GetControlTextOrientation(CXTPControl *pControl) | CXTPPaintManager | virtual
GetCurrentSystemTheme() | CXTPPaintManager |
GetCurrentTheme() | CXTPPaintManager | inline
GetDefaultCommandBarSize(CXTPCommandBar *pBar) | CXTPPaintManager | virtual
GetFramePaintManager() | CXTPCommandBarsModernUITheme | virtual
GetGalleryPaintManager() const | CXTPPaintManager | virtual
GetGlobalPaintManager() | CXTPPaintManager | static
GetIconFont() | CXTPPaintManager |
GetIconsInfo() | CXTPPaintManager |
GetInstanceAddRef() | CXTPPaintManager | static
GetMarkupContext() | CXTPCommandBarsModernUITheme | virtual
GetMessageBarPaintManager() | CXTPPaintManager | virtual
GetPopupBarGripperWidth(CXTPCommandBar *pBar) | CXTPPaintManager | virtual
GetProgressPaintManager() const | CXTPPaintManager | virtual
GetRectangleTextColor(BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition) | CXTPCommandBarsOfficeXPTheme | virtual
GetRegularBoldFont() | CXTPPaintManager |
GetRegularFont() | CXTPPaintManager |
GetRibbonPaintManager() | CXTPCommandBarsModernUITheme | virtual
GetScrollBarPaintManager() const | CXTPPaintManager | virtual
GetShadowManager() const | CXTPPaintManager |
GetShadowOptions() const | CXTPPaintManager |
GetSliderPaintManager() const | CXTPPaintManager | virtual
GetSmCaptionFont() | CXTPPaintManager |
GetSplitButtonCommandRect(CXTPControl *pButton) | CXTPPaintManager | virtual
GetStatusBarPaintManager() | CXTPPaintManager | virtual
GetXtremeColor(UINT nIndex) | CXTPPaintManager |
GradientFill(CDC *pDC, LPRECT lpRect, COLORREF crFrom, COLORREF crTo, BOOL bHorz, LPCRECT lpRectClip=NULL) | CXTPPaintManager |
HorizontalLine(CDC *pDC, int x0, int y0, int x1, COLORREF clrPen) | CXTPPaintManager |
IsUseSystemAccentColorEnabled() const | CXTPPaintManager |
Line(CDC *pDC, CPoint p0, CPoint p1) | CXTPPaintManager |
Line(CDC *pDC, int x0, int y0, int x1, int y1, const int nPen) | CXTPPaintManager |
Line(CDC *pDC, int x0, int y0, int x1, int y1, COLORREF clrPen) | CXTPPaintManager |
m_arrColor | CXTPPaintManager | protected
m_bAutoResizeIcons | CXTPPaintManager |
m_bClearTypeTextQuality | CXTPPaintManager |
m_bEmbossedDisabledText | CXTPPaintManager | protected
m_bEnableAnimation | CXTPPaintManager |
m_bFlatMenuBar | CXTPPaintManager |
m_bFlatToolBar | CXTPPaintManager |
m_bOffice2007Padding | CXTPPaintManager |
m_bOffsetPopupLabelText | CXTPPaintManager |
m_bSelectImageInPopupBar | CXTPPaintManager |
m_bShowKeyboardCues | CXTPPaintManager | protected
m_bShowShadow | CXTPPaintManager |
m_bThemedCheckBox | CXTPPaintManager |
m_bThemedStatusBar | CXTPPaintManager |
m_bThickCheckMark | CXTPPaintManager |
m_bUseOfficeFont | CXTPPaintManager |
m_bUseStandardFont | CXTPPaintManager | protected
m_bWrapCaptionBelowText | CXTPPaintManager |
m_clrDisabledIcon | CXTPPaintManager |
m_clrFloatingGripper | CXTPPaintManager |
m_clrFloatingGripperText | CXTPPaintManager |
m_clrMessageBarText | CXTPPaintManager |
m_fontIcon | CXTPPaintManager |
m_fontIconBold | CXTPPaintManager |
m_fontSmCaption | CXTPPaintManager |
m_fontToolTip | CXTPPaintManager |
m_iconsInfo | CXTPPaintManager | protected
m_nAnimationSteps | CXTPPaintManager | protected
m_nAnimationTime | CXTPPaintManager | protected
m_nEditHeight | CXTPPaintManager | protected
m_nFontHeight | CXTPPaintManager | protected
m_nPopupBarTextPadding | CXTPPaintManager |
m_nSplitButtonDropDownHeight | CXTPPaintManager |
m_nSplitButtonDropDownWidth | CXTPPaintManager |
m_nSplitButtonPopupWidth | CXTPPaintManager |
m_nStatusBarMinHeight | CXTPPaintManager |
m_nTextHeight | CXTPPaintManager |
m_pfnSetLayeredWindowAttributes | CXTPPaintManager |
m_pFramePaintManager | CXTPPaintManager |
m_pGalleryPaintManager | CXTPPaintManager |
m_pImages | CXTPCommandBarsModernUITheme | protected
m_pMarkupContext | CXTPCommandBarsModernUITheme | protected
m_pProgressPaintManager | CXTPPaintManager |
m_pRibbonPaintManager | CXTPPaintManager |
m_pScrollBarPaintManager | CXTPPaintManager |
m_pShadowManager | CXTPPaintManager | protected
m_pSliderPaintManager | CXTPPaintManager |
m_pStatusBarPaintManager | CXTPPaintManager |
m_rcMessageBarMargin | CXTPPaintManager |
m_rcStatusBarBorder | CXTPPaintManager |
m_strOfficeFont | CXTPPaintManager |
m_systemTheme | CXTPPaintManager | protected
m_themeButton | CXTPPaintManager | protected
m_themeCurrent | CXTPPaintManager | protected
m_themeStatusBar | CXTPPaintManager | protected
m_xtpFontRegular | CXTPPaintManager | protected
m_xtpFontRegularBold | CXTPPaintManager | protected
m_xtpFontVert | CXTPPaintManager | protected
m_xtpFontVertBold | CXTPPaintManager | protected
Notify(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *)) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
Notify(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1), A1 arg1) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
Notify(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
Notify(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamic(void(T::*method)(O *)) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1), A1 arg1) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *)) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1), A1 arg1) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyReversed(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *)) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyReversed(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1), A1 arg1) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyReversed(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyReversed(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
Pixel(CDC *pDC, int xPos, int yPos, int nPen) | CXTPPaintManager |
Rectangle(CDC *pDC, LPCRECT rc, int nPen, const int nBrush) | CXTPPaintManager |
Rectangle(CDC *pDC, LPCRECT rc, COLORREF clrPen, COLORREF clrBrush) | CXTPPaintManager |
RefreshMetrics() | CXTPCommandBarsModernUITheme | protectedvirtual
ReleaseInstance() | CXTPPaintManager | static
RequiresResourceImages() | CXTPPaintManager | virtual
RoundRect(CDC *pDC, LPCRECT rc, COLORREF clrPen, COLORREF clrBrush) | CXTPPaintManager |
SetAnimationDelay(int nAnimationSteps, int nAnimationTime) | CXTPPaintManager |
SetColors(int cElements, CONST INT *lpaElements, CONST COLORREF *lpaRgbValues) | CXTPPaintManager |
SetCommandBarRegion(CXTPCommandBar *pCommandBar) | CXTPPaintManager | virtual
SetCommandBarsFontIndirect(LOGFONT *pLogFont, BOOL bUseStandardFont=FALSE) | CXTPPaintManager |
SetCustomTheme(CXTPPaintManager *pTheme) | CXTPPaintManager | static
SetGlobalPaintManager(CXTPPaintManager *pPaintManager) | CXTPPaintManager | static
SetImageHandle(HMODULE hResource, LPCTSTR lpszIniFileName) | CXTPPaintManager | virtual
SetLunaTheme(XTPCurrentSystemTheme systemTheme) | CXTPPaintManager |
SetTheme(XTPPaintTheme paintTheme) | CXTPPaintManager | static
StripMnemonics(CString &strClear) | CXTPPaintManager | static
Subscribe(IXTPPaintManagerEvents *pObserver, CXTPSubscriptionList< CXTPPaintManager, IXTPPaintManagerEvents > *pSubcriptionList=NULL) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > |
Triangle(CDC *pDC, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clr) | CXTPPaintManager | static
Unsubscribe(IXTPPaintManagerEvents *pObserver) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > |
UpdateColors() | CXTPPaintManager | virtual
UpdateFonts() | CXTPPaintManager | virtual
UpdateRTLCaption(CString &strCaption) | CXTPPaintManager | virtual
UseOfficeFont(bool bUseOfficeFont) | CXTPPaintManager |
VerticalLine(CDC *pDC, int x0, int y0, int y1, COLORREF clrPen) | CXTPPaintManager |
~CXTPCommandBarsModernUITheme() | CXTPCommandBarsModernUITheme | virtual
~CXTPObservable() | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | protected
~CXTPPaintManager() | CXTPPaintManager | protectedvirtual


Toolkit Pro: XTPCommandBarsNativeXPTheme.h Source File

  • Source
  • CommandBars
  • Themes
XTPCommandBarsNativeXPTheme.h
Go to the documentation of this file.
1
23#if !defined(__XTPCOMMANDBARSNATIVEXPTHEME_H__)
24# define __XTPCOMMANDBARSNATIVEXPTHEME_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
40class _XTP_EXT_CLASS CXTPCommandBarsNativeXPTheme : public CXTPCommandBarsOffice2000Theme
41{
43 DECLARE_DYNAMIC(CXTPCommandBarsNativeXPTheme)
45public:
50 CXTPCommandBarsNativeXPTheme();
51
56 ~CXTPCommandBarsNativeXPTheme();
57
58protected:
63 virtual void RefreshMetrics();
64
71 virtual void FillCommandBarEntry(CDC* pDC, CXTPCommandBar* pBar);
72
86 virtual void DrawRectangle(CDC* pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled,
87 BOOL bChecked, BOOL bPopuped, XTPBarType barType,
88 XTPBarPosition barPosition);
89
98 virtual BOOL DrawRectangle(CDC* pDC, CXTPControl* pButton);
99
106 void DrawControlEntry(CDC* pDC, CXTPControl* pButton);
107
114 COLORREF GetControlTextColor(CXTPControl* pButton);
115
125 virtual CSize DrawCommandBarGripper(CDC* pDC, CXTPCommandBar* pBar, BOOL bDraw = TRUE);
126
133 virtual void FillDockBar(CDC* pDC, CXTPDockBar* pBar);
134
142 void FillDockBarRect(CDC* pDC, CWnd* pWnd, CWnd* pFrame);
143
151 void AdjustExcludeRect(CRect& rc, CXTPControl* pControl, BOOL bVertical);
152
160 void DrawSplitButtonFrame(CDC* pDC, CXTPControl* pButton, CRect rcButton);
161
170 virtual void DrawControlEditFrame(CDC* pDC, CRect rc, BOOL bEnabled, BOOL bSelected);
171
181 virtual void DrawControlComboBoxButton(CDC* pDC, CRect rcBtn, BOOL bEnabled, BOOL bSelected,
182 BOOL bDropped);
183
193 virtual CSize DrawDialogBarGripper(CDC* pDC, CXTPDialogBar* pBar, BOOL bDraw);
194
205 virtual CSize DrawCommandBarSeparator(CDC* pDC, CXTPCommandBar* pBar, CXTPControl* pControl,
206 BOOL bDraw = TRUE);
207
220 virtual COLORREF GetRectangleTextColor(BOOL bSelected, BOOL bPressed, BOOL bEnabled,
221 BOOL bChecked, BOOL bPopuped, XTPBarType barType,
222 XTPBarPosition barPosition);
223
230 virtual XTPPaintTheme BaseTheme()
231 {
232 return xtpThemeNativeWinXP;
233 }
234
241 BOOL IsThemeEnabled() const;
242
249 virtual void DrawControlEditSpin(CDC* pDC, CXTPControlEdit* pControlEdit);
250
264 virtual CSize DrawSpecialControl(CDC* pDC, XTPSpecialControl controlType, CXTPControl* pButton,
265 CXTPCommandBar* pBar, BOOL bDraw, LPVOID lpParam);
266
279 virtual void DrawPopupBarGripper(CDC* pDC, int xPos, int yPos, int cx, int cy,
280 BOOL bExpanded = FALSE);
281
290 virtual void DrawPopupBarCheckMark(CDC* pDC, CRect rcCheck, BOOL bEnabled, COLORREF clr);
291
300 virtual void DrawPopupBarRadioMark(CDC* pDC, CRect rcCheck, BOOL bEnabled, COLORREF clr);
301
309 virtual int GetPopupBarGripperWidth(CXTPCommandBar* pBar);
310
317 virtual void DrawControlMDIButton(CDC* pDC, CXTPControlButton* pButton);
318
319protected:
320 CXTPWinThemeWrapper* m_themeRebar;
321 CXTPWinThemeWrapper* m_themeToolbar;
322 CXTPWinThemeWrapper* m_themeCombo;
323 CXTPWinThemeWrapper* m_themeWindow;
324 CXTPWinThemeWrapper* m_themeSpin;
325 CXTPWinThemeWrapper* m_themeMenu;
326 COLORREF m_clrEdgeShadowColor;
327 COLORREF m_clrEdgeHighLightColor;
328 BOOL m_bFlatMenus;
330 COLORREF m_clrSelectedText;
331 COLORREF m_clrPressedText;
332};
333
334# define CXTPNativeXPTheme CXTPCommandBarsNativeXPTheme // Old name
335
337# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
338#endif // !defined(__XTPCOMMANDBARSNATIVEXPTHEME_H__)
XTPBarType
XTPBarType
Type of the command bar.
Definition XTPCommandBarsDefines.h:77
XTPBarPosition
XTPBarPosition
Position of the command bar.
Definition XTPCommandBarsDefines.h:52
XTPPaintTheme
XTPPaintTheme
Paint themes used by command bars.
Definition XTPCommandBarsDefines.h:233
xtpThemeNativeWinXP
@ xtpThemeNativeWinXP
Windows XP and later native theme support.
Definition XTPCommandBarsDefines.h:238
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPSpecialControl
XTPSpecialControl
Special control with extended drawing.
Definition XTPPaintManager.h:80
CXTPCommandBar
CXTPCommandBar is a CWnd derived class.
Definition XTPCommandBar.h:66
CXTPCommandBarsNativeXPTheme
The CXTPCommandBarsNativeXPTheme class is used to enable a Native Windows XP style theme for Command ...
Definition XTPCommandBarsNativeXPTheme.h:41
CXTPCommandBarsNativeXPTheme::AdjustExcludeRect
void AdjustExcludeRect(CRect &rc, CXTPControl *pControl, BOOL bVertical)
This method is called to determine the offset of a pop-up bar.
CXTPCommandBarsNativeXPTheme::DrawSpecialControl
virtual CSize DrawSpecialControl(CDC *pDC, XTPSpecialControl controlType, CXTPControl *pButton, CXTPCommandBar *pBar, BOOL bDraw, LPVOID lpParam)
This method is called to draw the specified controls.
CXTPCommandBarsNativeXPTheme::m_themeSpin
CXTPWinThemeWrapper * m_themeSpin
Window theme helper.
Definition XTPCommandBarsNativeXPTheme.h:324
CXTPCommandBarsNativeXPTheme::DrawControlComboBoxButton
virtual void DrawControlComboBoxButton(CDC *pDC, CRect rcBtn, BOOL bEnabled, BOOL bSelected, BOOL bDropped)
This method is called to draw the button of a combobox control.
CXTPCommandBarsNativeXPTheme::DrawPopupBarRadioMark
virtual void DrawPopupBarRadioMark(CDC *pDC, CRect rcCheck, BOOL bEnabled, COLORREF clr)
Call this member function to draw a radio button.
CXTPCommandBarsNativeXPTheme::DrawCommandBarGripper
virtual CSize DrawCommandBarGripper(CDC *pDC, CXTPCommandBar *pBar, BOOL bDraw=TRUE)
This method is called to draw the command bar's gripper.
CXTPCommandBarsNativeXPTheme::m_themeToolbar
CXTPWinThemeWrapper * m_themeToolbar
Toolbar theme helper.
Definition XTPCommandBarsNativeXPTheme.h:321
CXTPCommandBarsNativeXPTheme::DrawSplitButtonFrame
void DrawSplitButtonFrame(CDC *pDC, CXTPControl *pButton, CRect rcButton)
Draws a split button frame.
CXTPCommandBarsNativeXPTheme::DrawControlEditSpin
virtual void DrawControlEditSpin(CDC *pDC, CXTPControlEdit *pControlEdit)
This method draws edit control spin buttons.
CXTPCommandBarsNativeXPTheme::m_clrPressedText
COLORREF m_clrPressedText
Pressed text color.
Definition XTPCommandBarsNativeXPTheme.h:331
CXTPCommandBarsNativeXPTheme::m_bFlatMenus
BOOL m_bFlatMenus
TRUE if OS flat menu option enabled.
Definition XTPCommandBarsNativeXPTheme.h:328
CXTPCommandBarsNativeXPTheme::DrawControlEntry
void DrawControlEntry(CDC *pDC, CXTPControl *pButton)
This method is called to fill the control's face.
CXTPCommandBarsNativeXPTheme::GetRectangleTextColor
virtual COLORREF GetRectangleTextColor(BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition)
This method retrieves a buttons text color.
CXTPCommandBarsNativeXPTheme::FillDockBarRect
void FillDockBarRect(CDC *pDC, CWnd *pWnd, CWnd *pFrame)
This method is called to fill a dockbar.
CXTPCommandBarsNativeXPTheme::m_clrSelectedText
COLORREF m_clrSelectedText
Selected text color.
Definition XTPCommandBarsNativeXPTheme.h:330
CXTPCommandBarsNativeXPTheme::DrawRectangle
virtual BOOL DrawRectangle(CDC *pDC, CXTPControl *pButton)
This method is called to fill the control's face.
CXTPCommandBarsNativeXPTheme::m_themeRebar
CXTPWinThemeWrapper * m_themeRebar
Rebar theme helper.
Definition XTPCommandBarsNativeXPTheme.h:320
CXTPCommandBarsNativeXPTheme::GetControlTextColor
COLORREF GetControlTextColor(CXTPControl *pButton)
This method returns the control text color to draw.
CXTPCommandBarsNativeXPTheme::IsThemeEnabled
BOOL IsThemeEnabled() const
Determines if WinXP theme is enabled.
CXTPCommandBarsNativeXPTheme::m_themeMenu
CXTPWinThemeWrapper * m_themeMenu
Menu theme helper.
Definition XTPCommandBarsNativeXPTheme.h:325
CXTPCommandBarsNativeXPTheme::m_clrEdgeHighLightColor
COLORREF m_clrEdgeHighLightColor
Color of toolbar top line.
Definition XTPCommandBarsNativeXPTheme.h:327
CXTPCommandBarsNativeXPTheme::GetPopupBarGripperWidth
virtual int GetPopupBarGripperWidth(CXTPCommandBar *pBar)
Calculates the gripper of a pop-up bar.
CXTPCommandBarsNativeXPTheme::DrawPopupBarGripper
virtual void DrawPopupBarGripper(CDC *pDC, int xPos, int yPos, int cx, int cy, BOOL bExpanded=FALSE)
This method is called to draw a pop-up bar's right gripper.
CXTPCommandBarsNativeXPTheme::FillCommandBarEntry
virtual void FillCommandBarEntry(CDC *pDC, CXTPCommandBar *pBar)
This method is called to fill the command bar's face.
CXTPCommandBarsNativeXPTheme::CXTPCommandBarsNativeXPTheme
CXTPCommandBarsNativeXPTheme()
Constructs a CXTPCommandBarsNativeXPTheme object.
CXTPCommandBarsNativeXPTheme::DrawControlEditFrame
virtual void DrawControlEditFrame(CDC *pDC, CRect rc, BOOL bEnabled, BOOL bSelected)
This method is called to draw the frame of edit control.
CXTPCommandBarsNativeXPTheme::~CXTPCommandBarsNativeXPTheme
~CXTPCommandBarsNativeXPTheme()
Destroys a CXTPCommandBarsNativeXPTheme object, handles cleanup and deallocation.
CXTPCommandBarsNativeXPTheme::DrawPopupBarCheckMark
virtual void DrawPopupBarCheckMark(CDC *pDC, CRect rcCheck, BOOL bEnabled, COLORREF clr)
Call this member function to draw a check mark.
CXTPCommandBarsNativeXPTheme::BaseTheme
virtual XTPPaintTheme BaseTheme()
Retrieves the base theme of the manager.
Definition XTPCommandBarsNativeXPTheme.h:230
CXTPCommandBarsNativeXPTheme::m_clrEdgeShadowColor
COLORREF m_clrEdgeShadowColor
Color of toolbar bottom line.
Definition XTPCommandBarsNativeXPTheme.h:326
CXTPCommandBarsNativeXPTheme::m_themeWindow
CXTPWinThemeWrapper * m_themeWindow
Window theme helper.
Definition XTPCommandBarsNativeXPTheme.h:323
CXTPCommandBarsNativeXPTheme::RefreshMetrics
virtual void RefreshMetrics()
This method is called to refresh the visual metrics of the manager.
CXTPCommandBarsNativeXPTheme::DrawRectangle
virtual void DrawRectangle(CDC *pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition)
This method is called to fill the control's face.
CXTPCommandBarsNativeXPTheme::DrawCommandBarSeparator
virtual CSize DrawCommandBarSeparator(CDC *pDC, CXTPCommandBar *pBar, CXTPControl *pControl, BOOL bDraw=TRUE)
This method is called to draw a command bar's separator.
CXTPCommandBarsNativeXPTheme::m_themeCombo
CXTPWinThemeWrapper * m_themeCombo
ComboBox theme helper.
Definition XTPCommandBarsNativeXPTheme.h:322
CXTPCommandBarsNativeXPTheme::DrawDialogBarGripper
virtual CSize DrawDialogBarGripper(CDC *pDC, CXTPDialogBar *pBar, BOOL bDraw)
Call this member to draw the gripper of a dialog bar.
CXTPCommandBarsNativeXPTheme::DrawControlMDIButton
virtual void DrawControlMDIButton(CDC *pDC, CXTPControlButton *pButton)
Call this member function to draw Menu MDI buttons.
CXTPCommandBarsNativeXPTheme::FillDockBar
virtual void FillDockBar(CDC *pDC, CXTPDockBar *pBar)
This method is called to fill a dockbar.
CXTPCommandBarsOffice2000Theme
The CXTPCommandBarsOffice2000Theme class is used to enable an Office 2000 style theme for Command Bar...
Definition XTPCommandBarsOffice2000Theme.h:41
CXTPControlButton
CXTPControlButton is a CXTPControl derived class.
Definition XTPControlButton.h:39
CXTPControlEdit
CXTPControlEdit is a CXTPControl derived class.
Definition XTPControlEdit.h:274
CXTPControl
CXTPControl is a CXTPCmdTarget derived class.
Definition XTPControl.h:841
CXTPDialogBar
CXTPDialogBar is a CXTPToolBar derived class.
Definition XTPDialogBar.h:41
CXTPDockBar
CXTPDockBar is a CWnd derived class.
Definition XTPDockBar.h:42
CXTPWinThemeWrapper
The CXTPWinThemeWrapper class wraps the UxTheme.dll visual theme API.
Definition XTPWinThemeWrapper.h:188


Toolkit Pro: XTPPropertyGridItemColor.h Source File

  • Source
  • PropertyGrid
XTPPropertyGridItemColor.h
Go to the documentation of this file.
1
23#if !defined(__XTPPROPERTYGRIDITEMCOLOR_H__)
24# define __XTPPROPERTYGRIDITEMCOLOR_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
42enum XTPPropertyGridItemColorEditor
43{
44 xtpPropertyGridItemColorPopup,
45 xtpPropertyGridItemColorStandardDialog,
46 xtpPropertyGridItemColorExtendedDialog
47};
48
54class _XTP_EXT_CLASS CXTPPropertyGridItemColor : public CXTPPropertyGridItem
55{
56public:
92 CXTPPropertyGridItemColor(LPCTSTR strCaption, COLORREF clr = 0, COLORREF* pBindColor = NULL);
93
129 CXTPPropertyGridItemColor(UINT nID, COLORREF clr = 0, COLORREF* pBindColor = NULL);
130
135 virtual ~CXTPPropertyGridItemColor();
136
137public:
143 virtual void SetColor(COLORREF clr);
144
151 virtual COLORREF GetColor() const;
152
160 static COLORREF AFX_CDECL StringToRGB(LPCTSTR str);
161
169 static CString AFX_CDECL RGBToString(COLORREF clr);
170
194 virtual void BindToColor(COLORREF* pBindColor);
195
196public:
211 void SetEditorStyle(XTPPropertyGridItemColorEditor editor);
212
222 XTPPropertyGridItemColorEditor GetEditorStyle();
223
224protected:
235 virtual BOOL OnDrawItemValue(CDC& dc, CRect rcValue);
236
244 virtual CRect GetValueRect();
245
253 virtual void SetValue(CString strValue);
254
264 virtual void OnInplaceButtonDown(CXTPPropertyGridInplaceButton* pButton);
265
279 virtual void OnBeforeInsert();
280
281protected:
282 COLORREF m_clrValue;
283 COLORREF* m_pBindColor;
285 XTPPropertyGridItemColorEditor m_colorEditor;
287private:
288 DECLARE_DYNAMIC(CXTPPropertyGridItemColor)
289
290# ifdef _XTP_ACTIVEX
292 afx_msg void OleSetValue(const VARIANT* varValue);
293 afx_msg const VARIANT OleGetValue();
294
295 DECLARE_DISPATCH_MAP()
296 DECLARE_INTERFACE_MAP()
297
298 DECLARE_OLETYPELIB_EX(CXTPPropertyGridItemColor)
299
300 void BindDispatch();
302# endif
303};
304
306
307AFX_INLINE COLORREF CXTPPropertyGridItemColor::GetColor() const
308{
309 return m_clrValue;
310}
312# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
313#endif //#if !defined(__XTPPROPERTYGRIDITEMCOLOR_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPPropertyGridItemColorEditor
XTPPropertyGridItemColorEditor
Editor type for CXTPPropertyGridItemColor item.
Definition XTPPropertyGridItemColor.h:43
xtpPropertyGridItemColorStandardDialog
@ xtpPropertyGridItemColorStandardDialog
Standard color dialog editor.
Definition XTPPropertyGridItemColor.h:45
xtpPropertyGridItemColorExtendedDialog
@ xtpPropertyGridItemColorExtendedDialog
Extended color Editor editor.
Definition XTPPropertyGridItemColor.h:46
xtpPropertyGridItemColorPopup
@ xtpPropertyGridItemColorPopup
Color pop-up editor.
Definition XTPPropertyGridItemColor.h:44
CXTPPropertyGridInplaceButton
CXTPPropertyGridInplaceButton is a CXTPCmdTarget derived class.
Definition XTPPropertyGridInplaceButton.h:50
CXTPPropertyGridItemColor
CXTPPropertyGridItemColor is a CXTPPropertyGridItem derived class.
Definition XTPPropertyGridItemColor.h:55
CXTPPropertyGridItemColor::CXTPPropertyGridItemColor
CXTPPropertyGridItemColor(UINT nID, COLORREF clr=0, COLORREF *pBindColor=NULL)
Constructs a CXTPPropertyGridItemColor object.
CXTPPropertyGridItemColor::StringToRGB
static COLORREF AFX_CDECL StringToRGB(LPCTSTR str)
Converts a specified string to a COLORREF.
CXTPPropertyGridItemColor::OnBeforeInsert
virtual void OnBeforeInsert()
This method is called before the item becomes visible in the property grid.
CXTPPropertyGridItemColor::SetColor
virtual void SetColor(COLORREF clr)
Sets the COLORREF value for the item.
CXTPPropertyGridItemColor::OnDrawItemValue
virtual BOOL OnDrawItemValue(CDC &dc, CRect rcValue)
This method is called when an item is drawn.
CXTPPropertyGridItemColor::SetValue
virtual void SetValue(CString strValue)
Sets the value of the item.
CXTPPropertyGridItemColor::m_clrValue
COLORREF m_clrValue
Color value of the item.
Definition XTPPropertyGridItemColor.h:282
CXTPPropertyGridItemColor::RGBToString
static CString AFX_CDECL RGBToString(COLORREF clr)
Converts a specified COLORREF to a string.
CXTPPropertyGridItemColor::m_pBindColor
COLORREF * m_pBindColor
Pointer to the variable bound to this item.
Definition XTPPropertyGridItemColor.h:283
CXTPPropertyGridItemColor::m_colorEditor
XTPPropertyGridItemColorEditor m_colorEditor
Editor type of the item.
Definition XTPPropertyGridItemColor.h:285
CXTPPropertyGridItemColor::GetValueRect
virtual CRect GetValueRect()
Gets the bounding rectangle of the item value's text.
CXTPPropertyGridItemColor::CXTPPropertyGridItemColor
CXTPPropertyGridItemColor(LPCTSTR strCaption, COLORREF clr=0, COLORREF *pBindColor=NULL)
Constructs a CXTPPropertyGridItemColor object.
CXTPPropertyGridItemColor::SetEditorStyle
void SetEditorStyle(XTPPropertyGridItemColorEditor editor)
Sets the editor type for the item.
CXTPPropertyGridItemColor::OnInplaceButtonDown
virtual void OnInplaceButtonDown(CXTPPropertyGridInplaceButton *pButton)
This method is called when the user presses the in-place button.
CXTPPropertyGridItemColor::BindToColor
virtual void BindToColor(COLORREF *pBindColor)
Binds the item to a specified COLORREF value.
CXTPPropertyGridItemColor::GetColor
virtual COLORREF GetColor() const
Gets the COLORREF value of the item.
Definition XTPPropertyGridItemColor.h:307
CXTPPropertyGridItemColor::~CXTPPropertyGridItemColor
virtual ~CXTPPropertyGridItemColor()
Destroys a CXTPPropertyGridItemColor object.
CXTPPropertyGridItemColor::GetEditorStyle
XTPPropertyGridItemColorEditor GetEditorStyle()
Gets the editor type of the item.
CXTPPropertyGridItem
CXTPPropertyGridItem is the base class representing an item of the Property Grid control.
Definition XTPPropertyGridItem.h:523


Toolkit Pro: Member List

CXTPWebBrowserCtrl Member List

This is the complete list of members for CXTPWebBrowserCtrl, including all inherited members.

Create(DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID, CCreateContext *pContext=NULL) | CXTPWebBrowserCtrl | virtual
CreateEx(DWORD dwExStyle, DWORD dwStyle, int x, int y, int nWidth, int nHeight, HWND hWndParent, HMENU nIDorHMenu, LPVOID lpParam=NULL) | CXTPWebBrowserCtrl | virtual
CreateEx(DWORD dwExStyle, DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID, LPVOID lpParam=NULL) | CXTPWebBrowserCtrl | virtual
CXTPWebBrowserCtrl(XTPWebBrowserProvider nProvider=xtpWebBrowserLatest) | CXTPWebBrowserCtrl |
ExecuteScript(LPCWSTR pText, CComVariant *pvtResult=NULL) | CXTPWebBrowserCtrl |
GetBrowserObject() const | CXTPWebBrowserCtrl |
GetEventSink() const | CXTPWebBrowserCtrl |
GetExternal() const | CXTPWebBrowserCtrl | virtual
GetProperty(const CString &strName) const | CXTPWebBrowserCtrl | virtual
GetProvider() const | CXTPWebBrowserCtrl |
GetProviderType() const | CXTPWebBrowserCtrl |
LoadHtml(LPCTSTR pHtml) | CXTPWebBrowserCtrl |
Navigate(LPCTSTR pUrl) | CXTPWebBrowserCtrl |
ReCreateProvider() | CXTPWebBrowserCtrl |
RegisterWindowClass(HINSTANCE hInstance=NULL) | CXTPWebBrowserCtrl |
SetEventSink(IXTPWebBrowserEventSink *pEventSink) | CXTPWebBrowserCtrl |
SetExternal(IDispatch *pExternal) | CXTPWebBrowserCtrl |
SetProperty(const CString &strName, COleVariant *pvtValue) | CXTPWebBrowserCtrl |
SetProviderType(XTPWebBrowserProvider nProvider) | CXTPWebBrowserCtrl |
WaitUntilReady() | CXTPWebBrowserCtrl |
~CXTPWebBrowserCtrl() | CXTPWebBrowserCtrl | virtual


Toolkit Pro: Member List

XTP_EVENT_IN_PLACE_CREATE_EVENT_OPERATION_PARAMS Member List

This is the complete list of members for XTP_EVENT_IN_PLACE_CREATE_EVENT_OPERATION_PARAMS, including all inherited members.

eOperation | XTP_EVENT_EDIT_OPERATION_PARAMS
nRefCounter | XTP_EVENT_EDIT_OPERATION_PARAMS
pcszInitialSubject | XTP_EVENT_IN_PLACE_CREATE_EVENT_OPERATION_PARAMS
pEventViews | XTP_EVENT_EDIT_OPERATION_PARAMS


Toolkit Pro: Member List

CXTPChartLineSeriesView Member List

This is the complete list of members for CXTPChartLineSeriesView, including all inherited members.

AddChildView(CXTPChartElementView *pChildView) | CXTPChartElementView |
CreateDeviceCommand(CXTPChartDeviceContext *pDC) | CXTPChartLineSeriesView | protectedvirtual
CreateLegendDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcBounds) | CXTPChartLineSeriesView | protectedvirtual
CreateSeriesPointView(CXTPChartDeviceContext *pDC, CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView) | CXTPChartLineSeriesView | protected
CXTPChartElementView(CXTPChartElementView *pParentView) | CXTPChartElementView |
CXTPChartElementView(CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartElementView |
CXTPChartElementView(CXTPChartContainer *pContainer) | CXTPChartElementView |
CXTPChartLineSeriesView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView, BOOL bSortPoints=TRUE) | CXTPChartLineSeriesView |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
GetAt(int nIndex) const | CXTPChartElementView |
GetBounds() const | CXTPChartElementView |
GetBounds(BOOL bIncludingChildren) const | CXTPChartElementView |
GetChildren() | CXTPChartElementView |
GetCount() const | CXTPChartElementView |
GetParentView() const | CXTPChartElementView |
Is3D() const | CXTPChartObject |
m_arrChildren | CXTPChartElementView | protected
m_pContainer | CXTPChartElementView | protected
m_pParentView | CXTPChartElementView | protected
m_rcBounds | CXTPChartElementView | protected
~CXTPChartElementView() | CXTPChartElementView | protectedvirtual
~CXTPChartLegendItemView() | CXTPChartLegendItemView | inlinevirtual


Toolkit Pro: Member List

CXTPPopupBar Member List

This is the complete list of members for CXTPPopupBar, including all inherited members.

AdjustExcludeRect(CRect &rc, BOOL bVertical) | CXTPPopupBar | protectedvirtual
Animate() | CXTPPopupBar | protectedvirtual
CalcDynamicLayout(int nLength, DWORD dwMode) | CXTPPopupBar | virtual
CalculatePopupRect(CPoint ptPopup, CSize sz) | CXTPPopupBar | virtual
Copy(CXTPCommandBar *pCommandBar, BOOL bRecursive=FALSE) | CXTPPopupBar | protectedvirtual
Create() | CXTPPopupBar | virtual
CreateKeyboardTips() | CXTPCommandBar | virtual
CreatePopupBar(CXTPCommandBars *pCommandBars) | CXTPPopupBar | static
CXTPCommandBar() | CXTPCommandBar | protected
CXTPHookManagerHookAble() | CXTPHookManagerHookAble |
CXTPPopupBar() | CXTPPopupBar | protected
DelayLayout() | CXTPCommandBar |
DelayRedraw() | CXTPPopupBar | inlineprotectedvirtual
DestroyWindow() | CXTPPopupBar |
DisableShadow() | CXTPPopupBar |
DoPropExchange(CXTPPropExchange *pPX) | CXTPPopupBar | protectedvirtual
DrawCommandBar(CDC *pDC, CRect rcClipBox) | CXTPPopupBar | protectedvirtual
EnableAnimation(BOOL bEnable=TRUE) | CXTPCommandBar |
EnableCustomization(BOOL bEnable=TRUE) | CXTPCommandBar |
EnableDoubleBuffer(BOOL bEnable=TRUE) | CXTPCommandBar |
EnsureVisible(CXTPControl *pControl) | CXTPCommandBar | virtual
ExpandBar() | CXTPPopupBar |
FillCommandBarEntry(CDC *pDC) | CXTPCommandBar | virtual
FindAccel(TCHAR chAccel) const | CXTPCommandBar |
FindAccelEx(UINT chAccel, BOOL &bSelectOnly) const | CXTPCommandBar |
GenerateCommandBarList(DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam) | CXTPCommandBar | protectedvirtual
GetActiveDocTemplate() const | CXTPCommandBar | protected
GetBarID() const | CXTPCommandBar |
GetBorders() | CXTPPopupBar | virtual
GetButtonSize() const | CXTPCommandBar | virtual
GetCommandBarData() const | CXTPCommandBar |
GetCommandBars() const | CXTPCommandBar |
GetControl(int nIndex) const | CXTPCommandBar |
GetControlCount() const | CXTPCommandBar |
GetControlPopup() const | CXTPPopupBar |
GetControls() const | CXTPCommandBar |
GetDefaultButtonStyle() const | CXTPCommandBar |
GetDefaultItem(UINT gmdiFlags, BOOL fByPos=FALSE) | CXTPPopupBar |
GetFlags() const | CXTPCommandBar |
GetFrameSite() const | CXTPCommandBar |
GetIconSize() const | CXTPCommandBar | virtual
GetImageManager() const | CXTPCommandBar |
GetLargeIconSize(BOOL bAutoSize) const | CXTPCommandBar |
GetOwnerSite() const | CXTPCommandBar |
GetPaintManager() const | CXTPCommandBar |
GetParentCommandBar() const | CXTPPopupBar | protectedvirtual
GetPosition() const | CXTPCommandBar |
GetRootParent() const | CXTPCommandBar |
GetSelected() const | CXTPCommandBar |
GetShowGripper() const | CXTPCommandBar |
GetSite() const | CXTPCommandBar |
GetTextOrientation() const | CXTPCommandBar |
GetTitle() const | CXTPCommandBar |
GetTrackFocus() const | CXTPCommandBar |
GetType() const | CXTPCommandBar |
GetWidth() const | CXTPCommandBar |
HideKeyboardTips() | CXTPCommandBar |
InvalidateParents() | CXTPCommandBar |
IsAnimationEnabled() const | CXTPCommandBar |
IsContextMenu() const | CXTPPopupBar |
IsCustomizable() const | CXTPCommandBar | virtual
IsCustomizeDialogPresent() const | CXTPCommandBar |
IsCustomizeMode() const | CXTPCommandBar |
IsDialogBar() const | CXTPCommandBar | virtual
IsDoubleGripper() const | CXTPPopupBar |
IsHelpMode() const | CXTPCommandBar | protected
IsKeyboardCuesVisible() const | CXTPCommandBar | virtual
IsKeyboardTipsVisible() const | CXTPCommandBar |
IsLayoutRTL() const | CXTPCommandBar |
IsMenuTitleBar() const | CXTPCommandBar | virtual
IsPopupBar() const | CXTPPopupBar | virtual
IsResizable() const | CXTPPopupBar | virtual
IsRibbonBar() const | CXTPCommandBar | virtual
IsTearOffPopup(CString &strCaption, UINT &nID, int &nWidth) | CXTPPopupBar |
IsTextBelowIcons() const | CXTPCommandBar |
IsTrackingMode() const | CXTPCommandBar |
IsVisible() const | CXTPPopupBar | virtual
LoadMenu(CMenu *pMenu, BOOL bRemoveControls=TRUE) | CXTPCommandBar | virtual
LoadToolBar(UINT nIDResource, BOOL bLoadIcons=TRUE) | CXTPCommandBar | virtual
LockMouseMove(CXTPControl *pControl) | CXTPCommandBar |
LockRedraw() | CXTPCommandBar |
m_bAnimatePopup | CXTPCommandBar | protected
m_barPosition | CXTPCommandBar | protected
m_barType | CXTPCommandBar | protected
m_bAutoDestroy | CXTPHookManagerHookAble |
m_bCloseable | CXTPCommandBar | protected
m_bCollapsed | CXTPPopupBar | protected
m_bComboBar | CXTPCommandBar |
m_bContextMenu | CXTPPopupBar | protected
m_bCustomizable | CXTPCommandBar | protected
m_bCustomizeDialogPresent | CXTPCommandBar | protected
m_bDoubleGripper | CXTPPopupBar | protected
m_bDynamicLayout | CXTPPopupBar | protected
m_bExecOnRButton | CXTPCommandBar | protected
m_bExpanded | CXTPPopupBar | protected
m_bExpanding | CXTPPopupBar | protected
m_bGrabFocus | CXTPCommandBar | protected
m_bIgnoreUpdateHandler | CXTPCommandBar | protected
m_bKeyboardSelect | CXTPCommandBar | protected
m_bMultiLine | CXTPCommandBar | protected
m_bRecursePopup | CXTPCommandBar | protected
m_bResizable | CXTPPopupBar | protected
m_bShowShadow | CXTPPopupBar | protected
m_bTearOffPopup | CXTPPopupBar | protected
m_bTearOffSelected | CXTPPopupBar | protected
m_bTearOffTracking | CXTPPopupBar | protected
m_bTextBelow | CXTPCommandBar | protected
m_bTracking | CXTPCommandBar | protected
m_bTrackOnHover | CXTPCommandBar |
m_buttonStyle | CXTPCommandBar | protected
m_bVerticalMarker | CXTPCommandBar | protected
m_dMaxWidthDivisor | CXTPPopupBar | static
m_dwData | CXTPCommandBar | protected
m_dwFlags | CXTPCommandBar | protected
m_dwStyle | CXTPCommandBar | protected
m_hwndFocus | CXTPCommandBar | protected
m_nBarID | CXTPCommandBar | protected
m_nIdleFlags | CXTPCommandBar | protected
m_nLockRedraw | CXTPCommandBar | protected
m_nMaxHeight | CXTPPopupBar | protected
m_nMRUWidth | CXTPCommandBar | protected
m_nPopuped | CXTPCommandBar | protected
m_nSelected | CXTPCommandBar | protected
m_nStateFlags | CXTPCommandBar |
m_nTearOffID | CXTPPopupBar | protected
m_nTearOffTimer | CXTPPopupBar | protected
m_nTearOffWidth | CXTPPopupBar | protected
m_nTextOrientation | CXTPCommandBar | protected
m_pAnimation | CXTPCommandBar | protected
m_pCommandBars | CXTPCommandBar | protected
m_pControlPopup | CXTPPopupBar | protected
m_pControls | CXTPCommandBar | protected
m_pImageManager | CXTPCommandBar | protected
m_popupFlags | CXTPPopupBar | protected
m_pOwner | CXTPCommandBar | protected
m_pPaintManager | CXTPCommandBar | protected
m_pReturnCmd | CXTPCommandBar | protected
m_pSite | CXTPCommandBar | protected
m_pTearOffBar | CXTPPopupBar | protected
m_pToolTipContext | CXTPCommandBar | protected
m_ptPopup | CXTPPopupBar | protected
m_rcBorders | CXTPPopupBar | protected
m_rcExclude | CXTPPopupBar | protected
m_rcMarker | CXTPCommandBar | protected
m_rcResizeGripper | CXTPPopupBar | protected
m_rcTearOffGripper | CXTPPopupBar | protected
m_strTearOffCaption | CXTPPopupBar | protected
m_strTitle | CXTPCommandBar | protected
m_szButtons | CXTPCommandBar | protected
m_szButtonSpacing | CXTPCommandBar | protected
m_szIcons | CXTPCommandBar | protected
m_szTearOffBar | CXTPPopupBar | protected
OnControlsChanged() | CXTPPopupBar | protectedvirtual
OnControlSelected(BOOL bSelected, CXTPControl *pControl) | CXTPCommandBar | virtual
OnCustomizeDragEnter(CXTPControl *pDataObject, CPoint point) | CXTPCommandBar | virtual
OnCustomizeDragLeave() | CXTPCommandBar | virtual
OnCustomizeDragOver(CXTPControl *pDataObject, CPoint point) | CXTPCommandBar | virtual
OnCustomizeDrop(CXTPControl *pDataObject, DROPEFFECT &dropEffect, CPoint ptDrop, CPoint ptDrag) | CXTPCommandBar | virtual
OnHookAttached(HWND hWnd) | CXTPHookManagerHookAble | virtual
OnHookDetached() | CXTPHookManagerHookAble | virtual
OnHookKeyDown(UINT nChar, LPARAM lParam) | CXTPPopupBar | protectedvirtual
OnHookMessage(HWND hWnd, UINT nMessage, WPARAM &wParam, LPARAM &lParam, LRESULT &lResult) | CXTPCommandBar | virtual
OnKeyboardTip(CXTPCommandBarKeyboardTip *pTip) | CXTPCommandBar | virtual
OnKeyboardTipChar(UINT chAccel) | CXTPCommandBar |
OnMouseHitTest(CPoint pt) | CXTPCommandBar | protectedvirtual
OnPostHookMessage(HWND hWnd, UINT nMessage, WPARAM &wParam, LPARAM &lParam, LRESULT &lResult) | CXTPHookManagerHookAble | virtual
OnRecalcLayout() | CXTPPopupBar | protectedvirtual
OnRemoved() | CXTPCommandBar | protectedvirtual
OnTrackEnter() | CXTPCommandBar | virtual
OnTrackLost() | CXTPCommandBar | virtual
Popup(int xPos, int yPos, LPCRECT rcExclude) | CXTPPopupBar |
Popup(CXTPControlPopup *pControlPopup, BOOL bSelectFirst=FALSE) | CXTPPopupBar | virtual
ProcessSpecialKey(XTPSpecialKey key) | CXTPCommandBar | protectedvirtual
PumpMessage() | CXTPPopupBar |
Redraw(LPCRECT lpRect=0, BOOL bAnimate=TRUE) | CXTPCommandBar | virtual
RestoreCommandBarList(CXTPCommandBarList *pCommandBarList) | CXTPCommandBar | protectedvirtual
s_nExpandDelay | CXTPCommandBar | static
s_nExpandHoverDelay | CXTPCommandBar | static
s_nHoverDelay | CXTPCommandBar | static
SetBarID(UINT nID) | CXTPCommandBar |
SetBorders(CRect rcBorders) | CXTPPopupBar |
SetButtons(UINT *pButtons, int nCount) | CXTPCommandBar |
SetButtonSize(CSize size) | CXTPCommandBar |
SetCommandBarData(DWORD_PTR dwData) | CXTPCommandBar |
SetCommandBars(CXTPCommandBars *pCommandBars) | CXTPCommandBar |
SetControls(CXTPControls *pControls) | CXTPCommandBar |
SetDefaultButtonStyle(XTPButtonStyle buttonStyle) | CXTPCommandBar |
SetDefaultItem(UINT uItem, BOOL fByPos=FALSE) | CXTPPopupBar |
SetDoubleGripper(BOOL bDoubleGripper=TRUE) | CXTPPopupBar |
SetFlags(DWORD dwFlagsAdd, DWORD dwFlagsRemove=0) | CXTPCommandBar |
SetGrabFocus(BOOL bGrabFocus) | CXTPCommandBar |
SetIconSize(CSize size) | CXTPCommandBar |
SetImageManager(CXTPImageManager *pImageManager) | CXTPCommandBar |
SetPaintManager(CXTPPaintManager *pPaintManager) | CXTPCommandBar |
SetPopuped(int nPopuped, BOOL bKeyboard=FALSE) | CXTPCommandBar |
SetPopupFlags(DWORD dwPopupFlags) | CXTPPopupBar |
SetPopupToolBar(BOOL bToolBarType) | CXTPPopupBar |
SetPosition(XTPBarPosition barPosition) | CXTPCommandBar | virtual
SetSelected(int nSelected, BOOL bKeyboard=FALSE) | CXTPPopupBar | protectedvirtual
SetShowGripper(BOOL bShow) | CXTPCommandBar |
SetStatusText(const CString &strDescription) | CXTPCommandBar |
SetTearOffPopup(LPCTSTR lpszCaption, UINT nID, int nWidth=400) | CXTPPopupBar |
SetTextOrientation(XTPBarTextOrientation nTextOrientation) | CXTPCommandBar |
SetTitle(LPCTSTR lpszTitle) | CXTPCommandBar |
SetTrackFocus(HWND hwnd) | CXTPCommandBar |
SetTrackingMode(int bMode, BOOL bSelectFirst=TRUE, BOOL bKeyboard=FALSE) | CXTPPopupBar | virtual
SetVisible(BOOL bVisible) | CXTPCommandBar | virtual
SetWidth(int nWidth) | CXTPCommandBar |
ShowTextBelowIcons(BOOL bTextBelow=TRUE) | CXTPCommandBar |
UnlockMouseMove() | CXTPCommandBar |
UnlockRedraw() | CXTPCommandBar |
UpdateExpandingState() | CXTPPopupBar | protected
UpdateFlags() | CXTPPopupBar | protectedvirtual
UpdateLocation(CSize sz) | CXTPPopupBar | protected
UpdateShortcuts() | CXTPCommandBar | protectedvirtual
~CXTPCommandBar() | CXTPCommandBar | protectedvirtual
~CXTPHookManagerHookAble() | CXTPHookManagerHookAble | virtual
~CXTPPopupBar() | CXTPPopupBar | protectedvirtual


Toolkit Pro: Member List

CXTPCustomizeMenusPage Member List

This is the complete list of members for CXTPCustomizeMenusPage, including all inherited members.

AdjustResizeRect(CSize &rcWindow) | CXTPResize | protectedvirtual
AutoLoadPlacement(LPCTSTR pszSection) | CXTPResize |
CommitContextMenu() | CXTPCustomizeMenusPage | protected
CResizeItemArray typedef | CXTPResize | protected
CXTPCustomizeMenusPage(CXTPCustomizeSheet *pSheet) | CXTPCustomizeMenusPage |
CXTPPropertyPage() | CXTPPropertyPage |
CXTPPropertyPage(UINT nIDTemplate, UINT nIDCaption=0) | CXTPPropertyPage |
CXTPPropertyPage(LPCTSTR lpszTemplateName, UINT nIDCaption=0) | CXTPPropertyPage |
CXTPResize(CWnd *pWnd, const UINT nFlags=0) | CXTPResize |
Defer(HDWP &hdwp, CXTPResizeItem *pItem, int dx, int dy) | CXTPResize | protectedvirtual
GetCaption() const | CXTPPropertyPage |
GetMinMaxInfo(MINMAXINFO *pMMI) | CXTPResize | protected
HasFlag(XTPResize eFlag) | CXTPResize | protected
Init() | CXTPResize | protectedvirtual
LoadPlacement(LPCTSTR pszSection) | CXTPResize |
m_arrItems | CXTPResize | protected
m_bModified | CXTPPropertyPage | protected
m_dwData | CXTPPropertyPage |
m_nFlagsXX | CXTPResize | protected
m_pContextMenu | CXTPCustomizeMenusPage | protected
m_pSheet | CXTPCustomizeMenusPage | protected
m_ptContextMenu | CXTPCustomizeMenusPage | protected
m_pWnd | CXTPResize | protected
m_scSizeIcon | CXTPResize | protected
m_strDefaultMenu | CXTPCustomizeMenusPage | protected
m_strDefaultMenuDesc | CXTPCustomizeMenusPage | protected
m_strSection | CXTPResize | protected
m_szInitWindow | CXTPResize | protected
m_szMax | CXTPResize | protected
m_szMin | CXTPResize | protected
m_szWindow | CXTPResize | protected
m_wndIcon | CXTPCustomizeMenusPage |
Offset(CPoint ptOffset) | CXTPResize | protected
RemoveAllControls() | CXTPResize | protected
RemoveResize(UINT nID) | CXTPResize | protected
Reset() | CXTPResize | protected
SavePlacement(LPCTSTR pszSection) | CXTPResize |
SetCaption(LPCTSTR lpszCaption) | CXTPPropertyPage |
SetFlag(XTPResize eFlag) | CXTPResize | protected
SetMaxSize(CSize &sz) | CXTPResize |
SetMinSize(CSize &sz) | CXTPResize |
SetResize(UINT nID, XTP_RESIZE left, XTP_RESIZE top, XTP_RESIZE right, XTP_RESIZE bottom) | CXTPResize |
SetResize(UINT nID, const XTP_RESIZERECT &rrcSizing) | CXTPResize |
SetResize(UINT nID, HWND hWnd, const XTP_RESIZERECT &rrcSizing) | CXTPResize |
SetResize(UINT nID, HWND hWnd, const XTP_RESIZEPOINT &rpTopLeft, const XTP_RESIZEPOINT &rpBottomRight) | CXTPResize |
SetResize(UINT nID, const XTP_RESIZEPOINT &rpTopLeft, const XTP_RESIZEPOINT &rpBottomRight) | CXTPResize |
SetResize(CWnd *pWnd, const CXTPResizeRect &rrcSizing, CRect rcWindow) | CXTPResize | protected
Size() | CXTPResize | protectedvirtual
UpdateControlRect(CWnd *pWnd) | CXTPResize | protected
UpdatePage(void) | CXTPPropertyPage | virtual
~CXTPCustomizeMenusPage() | CXTPCustomizeMenusPage |
~CXTPPropertyPage() | CXTPPropertyPage |
~CXTPResize() | CXTPResize | virtual


Toolkit Pro: Member List

CXTPMarkupUIElementCollection Member List

This is the complete list of members for CXTPMarkupUIElementCollection, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPMarkupUIElementCollection() | CXTPMarkupUIElementCollection |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetItem(int nIndex) const | CXTPMarkupUIElementCollection |
OnChanged() | CXTPMarkupUIElementCollection | protected
~CXTPMarkupUIElementCollection() | CXTPMarkupUIElementCollection |


Toolkit Pro: Member List

CXTPPropertyGridInplaceSpinButton Member List

This is the complete list of members for CXTPPropertyGridInplaceSpinButton, including all inherited members.

CXTPPropertyGridInplaceControl(CXTPPropertyGridItem *pItem) | CXTPPropertyGridInplaceControl |
CXTPPropertyGridInplaceSpinButton(CXTPPropertyGridItem *pItem) | CXTPPropertyGridInplaceSpinButton |
GetMax() const | CXTPPropertyGridInplaceSpinButton |
GetMin() const | CXTPPropertyGridInplaceSpinButton |
GetSpinButtonCtrl() const | CXTPPropertyGridInplaceSpinButton |
m_nMax | CXTPPropertyGridInplaceSpinButton | protected
m_nMin | CXTPPropertyGridInplaceSpinButton | protected
m_nWidth | CXTPPropertyGridInplaceControl | protected
m_pItem | CXTPPropertyGridInplaceControl | protected
OnAdjustValueRect(CRect &rcValue) | CXTPPropertyGridInplaceSpinButton | virtual
OnCreateWindow(CRect &rcValue) | CXTPPropertyGridInplaceSpinButton | virtual
OnDestroyWindow() | CXTPPropertyGridInplaceControl | virtual
OnEditMouseWheel(CEdit *pEdit, short zDelta) | CXTPPropertyGridInplaceSpinButton | virtual
OnValueChanged() | CXTPPropertyGridInplaceSpinButton | virtual
SetMax(int nMax) | CXTPPropertyGridInplaceSpinButton |
SetMin(int nMin) | CXTPPropertyGridInplaceSpinButton |


Toolkit Pro: Member List

CXTPGridThickness Member List

This is the complete list of members for CXTPGridThickness, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPGridThickness() | CXTPGridThickness |
CXTPGridThickness(const CXTPGridThickness &thickness) | CXTPGridThickness |
CXTPGridThickness(const int nThickness) | CXTPGridThickness |
CXTPGridThickness(const int nLeft, const int nTop, const int nRight, const int nBottom) | CXTPGridThickness |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetBottom() const | CXTPGridThickness |
GetLeft() const | CXTPGridThickness |
GetRight() const | CXTPGridThickness |
GetTop() const | CXTPGridThickness |
m_nBottom | CXTPGridThickness | protected
m_nLeft | CXTPGridThickness | protected
m_nRight | CXTPGridThickness | protected
m_nTop | CXTPGridThickness | protected
operator=(const CXTPGridThickness &thickness) | CXTPGridThickness |
operator=(const int nThickness) | CXTPGridThickness |
Set(const CXTPGridThickness &thickness) | CXTPGridThickness |
Set(const int nThickness) | CXTPGridThickness |
Set(const int nLeft, const int nTop, const int nRight, const int nBottom) | CXTPGridThickness |
SetBottom(const int nThickness) | CXTPGridThickness |
SetLeft(const int nThickness) | CXTPGridThickness |
SetRight(const int nThickness) | CXTPGridThickness |
SetTop(const int nThickness) | CXTPGridThickness |


Toolkit Pro: Member List

CXTPMarkupExtension Member List

This is the complete list of members for CXTPMarkupExtension, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPMarkupExtension() | CXTPMarkupExtension | protected
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static


Toolkit Pro: Member List

XTP_EDIT_FONTOPTIONS Member List

This is the complete list of members for XTP_EDIT_FONTOPTIONS, including all inherited members.

XTP_EDIT_FONTOPTIONS() XTP_EDIT_FONTOPTIONS


Toolkit Pro: XTPDatePickerDaysCollection.h Source File

  • Source
  • Calendar
  • DatePicker
XTPDatePickerDaysCollection.h
Go to the documentation of this file.
1
22#if !defined(_XTPDATEPICKERDAYSCOLLECTION_H__)
23# define _XTPDATEPICKERDAYSCOLLECTION_H__
24
25# if _MSC_VER > 1000
26# pragma once
27# endif // _MSC_VER > 1000
28
29// XTPDatePickerDaysCollection.h : header file
31
32# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
33
34class CXTPDatePickerControl;
35class CXTPDatePickerItemDay;
36
43class _XTP_EXT_CLASS CXTPDatePickerDaysCollection : public CXTPCmdTarget
44{
45 friend class CXTPDatePickerControl;
46
47public:
61 struct SELECTED_BLOCK
62 {
63 long nDateBegin;
64 long nDateEnd;
65 };
66
67public:
76 CXTPDatePickerDaysCollection(CXTPDatePickerControl* pControl);
77
86 virtual ~CXTPDatePickerDaysCollection();
87
92 void Clear();
93
107 void Add(const COleDateTime& dtDay);
108
118 void Select(const COleDateTime& dtDay);
119
129 void SelectRange(const COleDateTime& dtDayBegin, const COleDateTime& dtDayEnd);
130
142 void Remove(const COleDateTime& dtDay);
143
157 BOOL Contains(const COleDateTime& dtDay) const;
158
167 int GetSelectedDaysCount() const;
168
175 int GetSelectedBlocksCount() const;
176
185 SELECTED_BLOCK GetSelectedBlock(int nIndex) const;
186
199 BOOL GetMinMaxRange(COleDateTime& refMinRange, COleDateTime& refMaxRange) const;
200
201private:
202 void _InsertBlock(int nIndexInsert, long nDateBegin, long nDateEnd);
203 void AddBlock(long nBegin, long nEnd);
204
205 // Attributes
206protected:
207 CXTPDatePickerControl* m_pControl;
209 CArray<SELECTED_BLOCK, SELECTED_BLOCK&> m_arrSelectedBlocks;
212# ifdef _XTP_ACTIVEX
213
214 DECLARE_DISPATCH_MAP()
215 DECLARE_INTERFACE_MAP()
216
217 DECLARE_OLETYPELIB_EX(CXTPDatePickerDaysCollection);
218 DECLARE_ENUM_VARIANT(CXTPDatePickerDaysCollection);
219
220 int OleGetItemCount();
221 LPDISPATCH OleGetItem(long nIndex);
222 BOOL OleGetAllowNoncontinuousSelection();
223 void OleSetAllowNoncontinuousSelection(BOOL bSet);
224
225# endif
226};
227
228AFX_INLINE int CXTPDatePickerDaysCollection::GetSelectedBlocksCount() const
229{
230 return (int)m_arrSelectedBlocks.GetSize();
231}
232AFX_INLINE CXTPDatePickerDaysCollection::SELECTED_BLOCK
233 CXTPDatePickerDaysCollection::GetSelectedBlock(int nIndex) const
234{
235 _ASSERTE(nIndex >= 0 && nIndex < (int)m_arrSelectedBlocks.GetSize());
236 return m_arrSelectedBlocks[nIndex];
237}
238
239# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
240#endif // !defined(_XTPDATEPICKERDAYSCOLLECTION_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPDatePickerControl
Class CXTPDatePickerControl encapsulates the functionality of a date and time picker control.
Definition XTPDatePickerControl.h:331
CXTPDatePickerDaysCollection
Definition XTPDatePickerDaysCollection.h:44
CXTPDatePickerDaysCollection::m_pControl
CXTPDatePickerControl * m_pControl
This member variable is a pointer to the parent control.
Definition XTPDatePickerDaysCollection.h:207
CXTPDatePickerDaysCollection::GetSelectedBlocksCount
int GetSelectedBlocksCount() const
Call this member function to count the number of selected blocks.
Definition XTPDatePickerDaysCollection.h:228
CXTPDatePickerDaysCollection::CXTPDatePickerDaysCollection
CXTPDatePickerDaysCollection(CXTPDatePickerControl *pControl)
Default collection constructor.
CXTPDatePickerDaysCollection::~CXTPDatePickerDaysCollection
virtual ~CXTPDatePickerDaysCollection()
Default collection destructor.
CXTPDatePickerDaysCollection::GetMinMaxRange
BOOL GetMinMaxRange(COleDateTime &refMinRange, COleDateTime &refMaxRange) const
Call this member function to determine the minimum and the maximum day in the collection.
CXTPDatePickerDaysCollection::m_arrSelectedBlocks
CArray< SELECTED_BLOCK, SELECTED_BLOCK & > m_arrSelectedBlocks
Contains an array of the selected dates blocks.
Definition XTPDatePickerDaysCollection.h:209
CXTPDatePickerDaysCollection::SelectRange
void SelectRange(const COleDateTime &dtDayBegin, const COleDateTime &dtDayEnd)
Call this member function to select days.
CXTPDatePickerDaysCollection::Select
void Select(const COleDateTime &dtDay)
Call this member function to select a day.
CXTPDatePickerDaysCollection::Clear
void Clear()
Call this member function to clear the day collection.
CXTPDatePickerDaysCollection::GetSelectedDaysCount
int GetSelectedDaysCount() const
Call this member function to count the number of days in the collection.
CXTPDatePickerDaysCollection::Contains
BOOL Contains(const COleDateTime &dtDay) const
Call this member function to determine if a day is contained in the collection.
CXTPDatePickerDaysCollection::Add
void Add(const COleDateTime &dtDay)
Call this member function to add a day to the collection.
CXTPDatePickerDaysCollection::Remove
void Remove(const COleDateTime &dtDay)
Call this member function to remove a day from the collection.
CXTPDatePickerDaysCollection::GetSelectedBlock
SELECTED_BLOCK GetSelectedBlock(int nIndex) const
Call this member function to get the selected block by its index.
Definition XTPDatePickerDaysCollection.h:233
CXTPDatePickerItemDay
Class CXTPDatePickerItemDay represents one displayed day item in the calendar.
Definition XTPDatePickerItemDay.h:47
CXTPDatePickerDaysCollection::SELECTED_BLOCK
Selected block structure.
Definition XTPDatePickerDaysCollection.h:62
CXTPDatePickerDaysCollection::SELECTED_BLOCK::nDateEnd
long nDateEnd
End date.
Definition XTPDatePickerDaysCollection.h:64
CXTPDatePickerDaysCollection::SELECTED_BLOCK::nDateBegin
long nDateBegin
Begin date.
Definition XTPDatePickerDaysCollection.h:63


Toolkit Pro: XTPMessageBarThemeOffice2013.h Source File

  • Source
  • CommandBars
  • MessageBar
XTPMessageBarThemeOffice2013.h
Go to the documentation of this file.
1
23#if !defined(__XTPMESSAGEBARTHEMEOFFICE2013_H__)
24# define __XTPMESSAGEBARTHEMEOFFICE2013_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPPaintManager;
34class CXTPMessageBar;
35class CXTPMessageBarButton;
36
42class _XTP_EXT_CLASS CXTPMessageBarThemeOffice2013 : public CXTPMessageBarPaintManager
43{
44public:
50 CXTPMessageBarThemeOffice2013(CXTPPaintManager* pPaintManager);
51
56 virtual void RefreshMetrics();
57
64 virtual void FillMessageBar(CDC* pDC, CXTPMessageBar* pBar);
65
72 virtual void DrawMessageBarButton(CDC* pDC, CXTPMessageBarButton* pButton);
73
83 virtual CRect GetCloseButtonRect(int x, int y, int cy);
84
85protected:
86 CRect m_rcBorders;
87 CXTPPaintManagerColor m_clrTextHilite;
88 CXTPPaintManagerColor m_clrButtonBack;
89 CXTPPaintManagerColor m_clrButtonBackHilite;
90 CXTPPaintManagerColor m_clrButtonBackPushed;
91 CXTPPaintManagerColor m_clrButtonBorder;
92 CXTPPaintManagerColor m_clrButtonBorderHilite;
93 CXTPPaintManagerColor m_clrButtonBorderPushed;
95private:
96 friend class CXTPPaintManager;
97};
98
100# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
101#endif // !defined(__XTPMESSAGEBARTHEMEOFFICE2013_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPMessageBarButton
CXTPMessageBarButton is a standalone class.
Definition XTPMessageBar.h:48
CXTPMessageBar
CXTPMessageBar is a CControlBar derived class.
Definition XTPMessageBar.h:88
CXTPMessageBarPaintManager
The CXTPMessageBarPaintManager class is used by the message bar to perform standard paint routines.
Definition XTPMessageBarPaintManager.h:39
CXTPMessageBarThemeOffice2013
The CXTPMessageBarThemeOffice2013 class is used by the message bar to draw an Office 2013 style messa...
Definition XTPMessageBarThemeOffice2013.h:43
CXTPMessageBarThemeOffice2013::m_clrButtonBorder
CXTPPaintManagerColor m_clrButtonBorder
Message bar button border color.
Definition XTPMessageBarThemeOffice2013.h:91
CXTPMessageBarThemeOffice2013::m_clrButtonBack
CXTPPaintManagerColor m_clrButtonBack
Message bar button background color.
Definition XTPMessageBarThemeOffice2013.h:88
CXTPMessageBarThemeOffice2013::m_clrButtonBorderPushed
CXTPPaintManagerColor m_clrButtonBorderPushed
Message bar button border pushed color.
Definition XTPMessageBarThemeOffice2013.h:93
CXTPMessageBarThemeOffice2013::DrawMessageBarButton
virtual void DrawMessageBarButton(CDC *pDC, CXTPMessageBarButton *pButton)
Call this member to draw a button in the message bar.
CXTPMessageBarThemeOffice2013::GetCloseButtonRect
virtual CRect GetCloseButtonRect(int x, int y, int cy)
Call this member to retrieve the close button coordinates.
CXTPMessageBarThemeOffice2013::m_clrButtonBackPushed
CXTPPaintManagerColor m_clrButtonBackPushed
Message bar button background pushed color.
Definition XTPMessageBarThemeOffice2013.h:90
CXTPMessageBarThemeOffice2013::CXTPMessageBarThemeOffice2013
CXTPMessageBarThemeOffice2013(CXTPPaintManager *pPaintManager)
Message bar constructor.
CXTPMessageBarThemeOffice2013::FillMessageBar
virtual void FillMessageBar(CDC *pDC, CXTPMessageBar *pBar)
Draws the message bar.
CXTPMessageBarThemeOffice2013::m_clrButtonBorderHilite
CXTPPaintManagerColor m_clrButtonBorderHilite
Message bar button border hilite color.
Definition XTPMessageBarThemeOffice2013.h:92
CXTPMessageBarThemeOffice2013::RefreshMetrics
virtual void RefreshMetrics()
Call to update class colors and settings.
CXTPMessageBarThemeOffice2013::m_clrButtonBackHilite
CXTPPaintManagerColor m_clrButtonBackHilite
Message bar button background hilite color.
Definition XTPMessageBarThemeOffice2013.h:89
CXTPMessageBarThemeOffice2013::m_clrTextHilite
CXTPPaintManagerColor m_clrTextHilite
Message bar text hilite color.
Definition XTPMessageBarThemeOffice2013.h:87
CXTPPaintManagerColor
The CXTPPaintManagerColor class is used to manage COLORREF values for determining default and applica...
Definition XTPColorManager.h:117
CXTPPaintManager
Paint manager of the command bars.
Definition XTPPaintManager.h:199


Toolkit Pro: Member List

CXTPPreviewView Member List

This is the complete list of members for CXTPPreviewView, including all inherited members.

CXTPPreviewView(int nPageCount=9) | CXTPPreviewView | protected
GetCommandBar() | CXTPPreviewView |
GetZoomState() const | CXTPPreviewView |
m_Across | CXTPPreviewView | protected
m_cxPixelsPerInch | CXTPPreviewView | protected
m_cyPixelsPerInch | CXTPPreviewView | protected
m_Down | CXTPPreviewView | protected
m_PageOffset | CXTPPreviewView | protected
m_pCommandBar | CXTPPreviewView | protected
m_pPageInfo2 | CXTPPreviewView | protected
SetZoomState(UINT nNewState, UINT nPage, CPoint point) | CXTPPreviewView |
~CXTPPreviewView() | CXTPPreviewView | protectedvirtual


Toolkit Pro: XTPDockingPaneTabColorSetOfficePanel.h Source File

  • Source
  • DockingPane
  • TabColorSets
XTPDockingPaneTabColorSetOfficePanel.h
Go to the documentation of this file.
1
23#if !defined(__XTPDOCKINGPANETABCOLORSETOFFICEPANEL_H__)
24# define __XTPDOCKINGPANETABCOLORSETOFFICEPANEL_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPDockingPaneTabColorSetOfficePanel
39 : public CXTPDockingPaneTabColorSetVisualStudio2003
40{
41public:
46 CXTPDockingPaneTabColorSetOfficePanel();
47
53 virtual void RefreshMetrics();
54};
55
56# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
58#endif // !defined(__XTPDOCKINGPANETABCOLORSETOFFICEPANEL_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPDockingPaneTabColorSetOfficePanel
Helper class used to initialize default colors for a theme from an .INI resource and handle drawing r...
Definition XTPDockingPaneTabColorSetOfficePanel.h:40
CXTPDockingPaneTabColorSetOfficePanel::CXTPDockingPaneTabColorSetOfficePanel
CXTPDockingPaneTabColorSetOfficePanel()
Default class constructor.
CXTPDockingPaneTabColorSetOfficePanel::RefreshMetrics
virtual void RefreshMetrics()
This member function is used to initialize default colors for a theme from an .INI resource.
CXTPDockingPaneTabColorSetVisualStudio2003
Helper class used to initialize default colors for a theme from an .INI resource and handle drawing r...
Definition XTPDockingPaneTabColorSetVisualStudio2003.h:39


Toolkit Pro: XTPChartPyramidSeriesViewBase.h Source File

  • Source
  • Chart
  • Styles
  • Pyramid
  • Base
XTPChartPyramidSeriesViewBase.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTPYRAMIDSERIESVIEWBASE_H__)
24# define __XTPCHARTPYRAMIDSERIESVIEWBASE_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartDeviceCommand;
34class CXTPChartSeriesPointView;
35class CXTPChartElementView;
36class CXTPChartSeriesPoint;
37class CXTPChartDeviceContext;
38class CXTPChartSeries;
39class CXTPChartDiagramView;
40class CXTPChartDiagramDomain;
41
46class _XTP_EXT_CLASS CXTPChartPyramidSeriesViewBase : public CXTPChartSeriesView
47{
48 DECLARE_DYNAMIC(CXTPChartPyramidSeriesViewBase);
49
50public:
58 CXTPChartPyramidSeriesViewBase(CXTPChartSeries* pSeries, CXTPChartDiagramView* pDiagramView);
59
64 virtual ~CXTPChartPyramidSeriesViewBase();
65
66public:
74 virtual void CalculatePointLayout(CXTPChartDeviceContext* pDC, CRect rcBounds) = 0;
75
82 void CalculateLabelLayout(CXTPChartDeviceContext* pDC);
83
95 virtual CXTPChartDiagramDomain* CreateDiagramDomain(CXTPChartDeviceContext* pDC,
96 CRect rcBounds);
97
105 virtual CXTPChartRectF GetInnerBounds() const;
106
115 CXTPChartDiagramDomain* GetDomain() const;
116
124 int GetMaxLabelWidth() const;
125
126protected:
138 virtual CXTPChartSeriesPointView* CreateSeriesPointView(CXTPChartDeviceContext* pDC,
139 CXTPChartSeriesPoint* pPoint,
140 CXTPChartElementView* pParentView) = 0;
141
154 virtual CXTPChartDeviceCommand* CreateDeviceCommand(CXTPChartDeviceContext* pDC) = 0;
155
166 virtual CXTPChartDeviceCommand* CreateLegendDeviceCommand(CXTPChartDeviceContext* pDC,
167 CRect rcBounds) = 0;
168
169public:
183 virtual CXTPChartDeviceCommand* CreateLegendDeviceCommand(CXTPChartDeviceContext* pDC,
184 CRect rcBounds, CXTPChartColor color1,
185 CXTPChartColor color2,
186 CXTPChartColor clrBorder) = 0;
187
189 void CalculateValues();
192protected:
193 CXTPChartDiagramDomain* m_pDomain;
194 int m_nMaxLabelWidth;
195};
196
197AFX_INLINE CXTPChartDiagramDomain* CXTPChartPyramidSeriesViewBase::GetDomain() const
198{
199 return m_pDomain;
200}
201
202AFX_INLINE int CXTPChartPyramidSeriesViewBase::GetMaxLabelWidth() const
203{
204 return m_nMaxLabelWidth;
205}
207# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
208#endif //#if !defined(__XTPCHARTPYRAMIDSERIESVIEWBASE_H__)
pPoint
const CPoint * pPoint
return 0 or xtpCalendarHitTestDayExpandButton
Definition XTPCalendarThemeOffice2007.h:150
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartColor
This class abstracts a color entity.
Definition XTPChartTypes.h:51
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartDiagramDomain
Represents a virtual diagram rectangular domain area.
Definition XTPChartDiagram.h:159
CXTPChartDiagramView
This class represents the view of a chart diagram, which is a kind of CXTPChartElementView.
Definition XTPChartDiagramView.h:49
CXTPChartElementView
This class represents the view of a chart element.
Definition XTPChartElementView.h:47
CXTPChartPyramidSeriesViewBase
This class abstracts the view of a pyramid series.
Definition XTPChartPyramidSeriesViewBase.h:47
CXTPChartPyramidSeriesViewBase::GetInnerBounds
virtual CXTPChartRectF GetInnerBounds() const
Call this function to get the inner bounds of the diagram.
CXTPChartPyramidSeriesViewBase::CalculateLabelLayout
void CalculateLabelLayout(CXTPChartDeviceContext *pDC)
Call this function to calculate the pyramid series label layout.
CXTPChartPyramidSeriesViewBase::CreateDeviceCommand
virtual CXTPChartDeviceCommand * CreateDeviceCommand(CXTPChartDeviceContext *pDC)=0
This function creates a CXTPChartDeviceCommand object.
CXTPChartPyramidSeriesViewBase::CreateLegendDeviceCommand
virtual CXTPChartDeviceCommand * CreateLegendDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcBounds)=0
These functions create a label view drawing command object.
CXTPChartPyramidSeriesViewBase::CreateDiagramDomain
virtual CXTPChartDiagramDomain * CreateDiagramDomain(CXTPChartDeviceContext *pDC, CRect rcBounds)
Call this function to create the pyramid diagram domain object associated with this object.
CXTPChartPyramidSeriesViewBase::CreateSeriesPointView
virtual CXTPChartSeriesPointView * CreateSeriesPointView(CXTPChartDeviceContext *pDC, CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)=0
Use this function to create the pyramid series point view object.
CXTPChartPyramidSeriesViewBase::GetMaxLabelWidth
int GetMaxLabelWidth() const
Obtains the maximum allowed label width.
Definition XTPChartPyramidSeriesViewBase.h:202
CXTPChartPyramidSeriesViewBase::m_pDomain
CXTPChartDiagramDomain * m_pDomain
Pointer to the diagram domain.
Definition XTPChartPyramidSeriesViewBase.h:193
CXTPChartPyramidSeriesViewBase::GetDomain
CXTPChartDiagramDomain * GetDomain() const
Use this function to get the pyramid diagram domain object associated with this object.
Definition XTPChartPyramidSeriesViewBase.h:197
CXTPChartPyramidSeriesViewBase::~CXTPChartPyramidSeriesViewBase
virtual ~CXTPChartPyramidSeriesViewBase()
Destroys a CXTPChartPyramidSeriesViewBase object, handles cleanup.
CXTPChartPyramidSeriesViewBase::CreateLegendDeviceCommand
virtual CXTPChartDeviceCommand * CreateLegendDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcBounds, CXTPChartColor color1, CXTPChartColor color2, CXTPChartColor clrBorder)=0
These functions create a label view drawing command object.
CXTPChartPyramidSeriesViewBase::CalculatePointLayout
virtual void CalculatePointLayout(CXTPChartDeviceContext *pDC, CRect rcBounds)=0
Call this function to calculate the pyramid series point layout.
CXTPChartPyramidSeriesViewBase::CXTPChartPyramidSeriesViewBase
CXTPChartPyramidSeriesViewBase(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Constructs a CXTPChartPyramidSeriesViewBase object.
CXTPChartSeries
This class represents a series in the chart, which is a kind of CXTPChartElement.
Definition XTPChartSeries.h:50
CXTPChartSeriesPoint
CXTPChartSeriesPoint is a kind of CXTPChartElement.
Definition XTPChartSeriesPoint.h:43
CXTPChartSeriesPointView
Represents chart series point view.
Definition XTPChartSeriesPointView.h:48
CXTPRectT< float >


Toolkit Pro: Member List

CXTPMessageBarThemeNativeWindows10 Member List

This is the complete list of members for CXTPMessageBarThemeNativeWindows10, including all inherited members.

CXTPMessageBarPaintManager(CXTPPaintManager *pPaintManager) | CXTPMessageBarPaintManager |
CXTPMessageBarThemeNativeWindows10(CXTPPaintManager *pPaintManager) | CXTPMessageBarThemeNativeWindows10 |
CXTPMessageBarThemeOffice2013(CXTPPaintManager *pPaintManager) | CXTPMessageBarThemeOffice2013 |
DrawMessageBarButton(CDC *pDC, CXTPMessageBarButton *pButton) | CXTPMessageBarThemeOffice2013 | virtual
FillMessageBar(CDC *pDC, CXTPMessageBar *pBar) | CXTPMessageBarThemeOffice2013 | virtual
GetCloseButtonRect(int x, int y, int cy) | CXTPMessageBarThemeOffice2013 | virtual
GetDefaultButtonSize() const | CXTPMessageBarPaintManager | virtual
GetHeight() const | CXTPMessageBarPaintManager | virtual
GetPadding() const | CXTPMessageBarPaintManager | virtual
m_clrBack | CXTPMessageBarPaintManager | protected
m_clrBorder | CXTPMessageBarPaintManager | protected
m_clrButtonBack | CXTPMessageBarThemeOffice2013 | protected
m_clrButtonBackHilite | CXTPMessageBarThemeOffice2013 | protected
m_clrButtonBackPushed | CXTPMessageBarThemeOffice2013 | protected
m_clrButtonBorder | CXTPMessageBarThemeOffice2013 | protected
m_clrButtonBorderHilite | CXTPMessageBarThemeOffice2013 | protected
m_clrButtonBorderPushed | CXTPMessageBarThemeOffice2013 | protected
m_clrInfoBack | CXTPMessageBarPaintManager | protected
m_clrText | CXTPMessageBarPaintManager | protected
m_clrTextHilite | CXTPMessageBarThemeOffice2013 | protected
m_pPaintManager | CXTPMessageBarPaintManager | protected
RefreshMetrics() | CXTPMessageBarThemeOffice2013 | virtual
~CXTPMessageBarPaintManager() | CXTPMessageBarPaintManager | inlinevirtual


Toolkit Pro: Member List

CXTPSwitchViewButtonPart Member List

This is the complete list of members for CXTPSwitchViewButtonPart, including all inherited members.

AdjustLayout(CDC *pDC, const CRect &rcRect) | CXTPSwitchViewButtonPart | virtual
CXTPCalendarCaptionBarThemePart(CXTPCalendarCaptionBarTheme *pTheme, int nPartID) | CXTPCalendarCaptionBarThemePart |
CXTPCalendarWMHandler() | CXTPCalendarWMHandler |
CXTPCmdTarget() | CXTPCmdTarget |
Draw(CDC *pDC) | CXTPSwitchViewButtonPart | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCheck() const | CXTPCalendarCaptionBarThemePart | virtual
GetChildHandlerAt(int nIndex) const | CXTPCalendarWMHandler | virtual
GetChildHandlersCount() const | CXTPCalendarWMHandler | virtual
GetPaintManager() const | CXTPCalendarCaptionBarThemePart |
GetPaintTheme() const | CXTPCalendarCaptionBarThemePart | virtual
GetPartID() const | CXTPCalendarCaptionBarThemePart | virtual
GetRect() const | CXTPCalendarCaptionBarThemePart | virtual
GetState() const | CXTPCalendarCaptionBarThemePart |
GetText() const | CXTPCalendarCaptionBarThemePart | virtual
GetTextColor() | CXTPCalendarCaptionBarThemePart | virtual
GetTheme() const | CXTPCalendarCaptionBarThemePart | virtual
HitTest(const CPoint &pt) const | CXTPCalendarCaptionBarThemePart | virtual
IsVisible() const | CXTPCalendarCaptionBarThemePart | virtual
m_bVisible | CXTPCalendarCaptionBarThemePart | protected
m_clrTextColor | CXTPCalendarCaptionBarThemePart |
m_nPartID | CXTPCalendarCaptionBarThemePart | protected
m_nState | CXTPCalendarCaptionBarThemePart |
m_pTheme | CXTPCalendarCaptionBarThemePart | protected
m_rcRect | CXTPCalendarCaptionBarThemePart |
m_strText | CXTPCalendarCaptionBarThemePart |
OnBeforeDestroy() | CXTPCalendarWMHandler | virtual
OnChar(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnKeyUp(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnLButtonDblClk(UINT nFlags, CPoint point) | CXTPCalendarWMHandler | virtual
OnLButtonDown(UINT nFlags, CPoint point) | CXTPCalendarCaptionBarThemePart | virtual
OnLButtonUp(UINT nFlags, CPoint point) | CXTPCalendarCaptionBarThemePart | virtual
OnMouseMove(UINT nFlags, CPoint point) | CXTPCalendarCaptionBarThemePart | virtual
OnPostAdjustLayout() | CXTPCalendarWMHandler | virtual
OnSysKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnTimer(UINT_PTR uTimerID) | CXTPCalendarWMHandler | virtual
OnWndMsg(UINT message, WPARAM wParam, LPARAM lParam, LRESULT *pResult) | CXTPCalendarWMHandler | virtual
Redraw(BOOL bUpdateNow=FALSE) | CXTPCalendarCaptionBarThemePart | virtual
RefreshMetrics() | CXTPSwitchViewButtonPart | virtual
SetCheck(int nCheck) | CXTPCalendarCaptionBarThemePart | virtual
SetState(int nState) | CXTPCalendarCaptionBarThemePart | virtual
SetText(LPCTSTR pcszText) | CXTPCalendarCaptionBarThemePart | virtual
SetVisible(BOOL bVisible) | CXTPCalendarCaptionBarThemePart | virtual
~CXTPCalendarCaptionBarThemePart() | CXTPCalendarCaptionBarThemePart | virtual


Toolkit Pro: XTPToolBar.h Source File

  • Source
  • CommandBars
XTPToolBar.h
Go to the documentation of this file.
1
23#if !defined(__XTPTOOLBAR_H__)
24# define __XTPTOOLBAR_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPDockBar;
34class CXTPCommandBars;
35class CXTPDockContext;
36
41class _XTP_EXT_CLASS CXTPToolBar : public CXTPCommandBar
42{
43public:
45 class CToolBarInfo;
48 class CXTPPushRoutingFrame
49 {
50 protected:
51 CFrameWnd* pOldRoutingFrame;
52 _AFX_THREAD_STATE* pThreadState;
53
54 public:
55 CXTPPushRoutingFrame(CFrameWnd* pNewRoutingFrame)
56 {
57 pThreadState = AfxGetThreadState();
58 pOldRoutingFrame = pThreadState->m_pRoutingFrame;
59 pThreadState->m_pRoutingFrame = pNewRoutingFrame;
60 }
61 ~CXTPPushRoutingFrame()
62 {
63 pThreadState->m_pRoutingFrame = pOldRoutingFrame;
64 }
65 };
66
67private:
68 class CControlButtonExpand;
69 class CControlButtonHide;
70
71public:
76 CXTPToolBar();
77
82 ~CXTPToolBar();
83
84public:
91 virtual void SetVisible(BOOL bVisible);
92
99 virtual BOOL IsVisible() const
100 {
101 return m_bVisible;
102 }
103
111 BOOL SetPosition(XTPBarPosition barPosition);
112
121 BOOL LoadToolBar(UINT nIDResource, BOOL bLoadIcons = TRUE);
122
123public:
133 BOOL CreateToolBar(DWORD dwStyle, CWnd* pParentWnd, UINT nID = AFX_IDW_TOOLBAR);
134
140 void GetBarInfo(CToolBarInfo* pInfo);
141
147 void SetBarInfo(CToolBarInfo* pInfo);
148
158 virtual CSize CalcDockingLayout(int nLength, DWORD dwMode, int nWidth = 0);
159
169 virtual CSize CalcDynamicLayout(int nLength, DWORD dwMode);
170
185 void EnableDocking(DWORD dwFlags = xtpFlagAlignAny | xtpFlagFloating | xtpFlagHideWrap);
186
193 BOOL IsBuiltIn() const;
194
201 CXTPDockBar* GetDockBar() const;
202
208 virtual void Reset(BOOL bShowWarningMessage);
209
216 void OnSetPreviewMode(BOOL bPreview);
217
227 BOOL OnHookKeyDown(UINT nChar, LPARAM lParam);
228
234 void SetContextMenuPresent(BOOL bPresent);
235
244 BOOL IsContextMenuPresent() const;
245
251 void SetCustomizeDialogPresent(BOOL bPresent);
252
261 BOOL IsCustomizeDialogPresent() const;
262
269 void ModifyBarStyle(DWORD dwRemove, DWORD dwAdd);
270
277 void SetCloseable(BOOL bCloseable);
278
286 BOOL IsCloseable() const;
287
299 BOOL IsTemporary() const;
300
311 void SetTemporary(BOOL bTemporary);
312
319 void ShowExpandButton(BOOL bShowExpandButton);
320
325 void OnRecalcLayout();
326
335 BOOL IsWindowVisible() const;
336
345 static BOOL AFX_CDECL DoUpdateCustomizeMenuControl(CXTPControl* pControl, CCmdTarget* pTarget);
346
347protected:
356 virtual BOOL Create(CWnd* pParentWnd, BOOL bFloat);
357
363 virtual void DoPropExchange(CXTPPropExchange* pPX);
364
371 virtual void Copy(CXTPCommandBar* pCommandBar, BOOL bRecursive = FALSE);
372
373protected:
380 virtual CRect GetBorders();
381
386 virtual void OnPaintManagerChanged();
387
388protected:
395 virtual BOOL ShouldSerializeBar();
396
405 virtual void MergeToolBar(CXTPCommandBar* pCommandBar, BOOL bSilent);
406
416 virtual void MergeToolBar(CXTPCommandBar* pCommandBar, BOOL bSilent,
417 int nDefaultConfirmationChoice);
418
419private:
420 CSize _CalcDynamicLayout(int nLength, DWORD dwMode);
421
422 void BuildCustomizePopup(CXTPCommandBar* pExpandBar);
423 int _FindNearest(CXTPControls* pControls, CXTPControl* pFind, int nPos,
424 BOOL bVisible = FALSE) const;
425 void _RestoreDeletedControls();
426 void _GetHiddenControls(CXTPCommandBar* pExpandBar);
427
428 BOOL IsFloatingFrameFocused() const;
429
430protected:
431 virtual void BeforeCustomizeControlAdd(CXTPControl* pControl);
432
433# ifdef _XTP_COMMANDBARS_ACTIVEX
435 DECLARE_DISPATCH_MAP()
436 afx_msg void OleReset();
437 afx_msg void OleDelete();
438
439public:
440 virtual void OleEnableCustomization();
442# endif
443
444protected:
445 CXTPDockBar* m_pDockBar;
446 CXTPDockContext* m_pDockContext;
447 BOOL m_bBuiltIn;
448 BOOL m_bTearOff;
449 BOOL m_bPreviewVisible;
450 BOOL m_bPreviewMode;
451 BOOL m_bTemporary;
453 BOOL m_bShowExpandButton;
454 BOOL m_bContextMenuPresent;
455 BOOL m_bInRecalcLayout;
456 BOOL m_bVisible;
458protected:
460 DECLARE_MESSAGE_MAP()
461
462 //{{AFX_MSG(CXTPToolBar)
463 afx_msg BOOL OnSetCursor(CWnd* pWnd, UINT nHitTest, UINT message);
464 afx_msg void OnRButtonDown(UINT nFlags, CPoint point);
465 afx_msg BOOL OnNcCreate(LPCREATESTRUCT lpCreateStruct);
466 afx_msg BOOL OnNcActivate(BOOL bActive);
467 afx_msg LRESULT OnFloatStatus(WPARAM wParam, LPARAM);
468 afx_msg int OnMouseActivate(CWnd* pDesktopWnd, UINT nHitTest, UINT message);
469 afx_msg void OnLButtonDown(UINT nFlags, CPoint point);
470 afx_msg LRESULT OnNcHitTest(CPoint point);
471 afx_msg void OnNcLButtonDown(UINT nHitTest, CPoint point);
472 afx_msg void OnSetFocus(CWnd* pOldWnd);
473 afx_msg void OnClose();
474 afx_msg LRESULT OnSizeParent(WPARAM, LPARAM lParam);
475 afx_msg void OnLButtonDblClk(UINT nFlags, CPoint pt);
476 //}}AFX_MSG
479private:
480 BOOL Create(LPCTSTR lpszClassName, LPCTSTR lpszWindowName, DWORD dwStyle, const RECT& rect,
481 CWnd* pParentWnd, UINT nID, CCreateContext* pContext = NULL);
483 DECLARE_XTP_COMMANDBAR(CXTPToolBar)
486private:
487 friend class CXTPCommandBars;
488 friend class CXTPDockContext;
489 friend class CXTPDockBar;
490 friend class CXTPCustomizeToolbarsPage;
491 friend class CXTPPopupBar;
492 friend class CControlButtonExpand;
493};
494
496
497AFX_INLINE BOOL CXTPToolBar::IsBuiltIn() const
498{
499 return m_bBuiltIn;
500}
501AFX_INLINE CXTPDockBar* CXTPToolBar::GetDockBar() const
502{
503 return m_pDockBar;
504}
505AFX_INLINE void CXTPToolBar::SetContextMenuPresent(BOOL bPresent)
506{
507 m_bContextMenuPresent = bPresent;
508}
509AFX_INLINE BOOL CXTPToolBar::IsContextMenuPresent() const
510{
511 return m_bContextMenuPresent;
512}
513AFX_INLINE void CXTPToolBar::SetCustomizeDialogPresent(BOOL bPresent)
514{
515 m_bCustomizeDialogPresent = bPresent;
516}
517AFX_INLINE BOOL CXTPToolBar::IsCustomizeDialogPresent() const
518{
519 return m_bCustomizeDialogPresent;
520}
521AFX_INLINE void CXTPToolBar::ModifyBarStyle(DWORD dwRemove, DWORD dwAdd)
522{
523 m_dwStyle |= dwAdd;
524 m_dwStyle &= ~dwRemove;
525}
526AFX_INLINE void CXTPToolBar::SetCloseable(BOOL bCloseable)
527{
528 m_bCloseable = bCloseable;
529}
530AFX_INLINE BOOL CXTPToolBar::IsCloseable() const
531{
532 return m_bCloseable;
533}
534AFX_INLINE BOOL CXTPToolBar::IsTemporary() const
535{
536 return m_bTemporary;
537}
538AFX_INLINE void CXTPToolBar::SetTemporary(BOOL bTemporary)
539{
540 m_bTemporary = bTemporary;
541}
542AFX_INLINE BOOL CXTPToolBar::Create(LPCTSTR lpszClassName, LPCTSTR lpszWindowName, DWORD dwStyle,
543 const RECT& rect, CWnd* pParentWnd, UINT nID,
544 CCreateContext* pContext)
545{
546 return CWnd::Create(lpszClassName, lpszWindowName, dwStyle, rect, pParentWnd, nID, pContext);
547}
548AFX_INLINE void CXTPToolBar::ShowExpandButton(BOOL bShowExpandButton)
549{
550 m_bShowExpandButton = bShowExpandButton;
551 DelayLayout();
552}
553AFX_INLINE void CXTPToolBar::OnPaintManagerChanged()
554{
555}
557# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
558#endif //#if !defined(__XTPTOOLBAR_H__)
xtpFlagFloating
@ xtpFlagFloating
Allows floating.
Definition XTPCommandBarsDefines.h:318
xtpFlagAlignAny
@ xtpFlagAlignAny
Allows docking on any side of the client area.
Definition XTPCommandBarsDefines.h:316
xtpFlagHideWrap
@ xtpFlagHideWrap
Allow to hide wrapped controls.
Definition XTPCommandBarsDefines.h:319
XTPBarPosition
XTPBarPosition
Position of the command bar.
Definition XTPCommandBarsDefines.h:52
DECLARE_XTP_COMMANDBAR
#define DECLARE_XTP_COMMANDBAR(class_name)
This macro generates the C++ header code necessary for a CXTPCommandBar-derived class that can be ser...
Definition XTPCommandBarsDefines.h:1234
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCommandBar
CXTPCommandBar is a CWnd derived class.
Definition XTPCommandBar.h:66
CXTPCommandBar::m_bCloseable
BOOL m_bCloseable
TRUE if the CommandBar can be closed and-or Hidden.
Definition XTPCommandBar.h:1198
CXTPCommandBar::m_bCustomizeDialogPresent
BOOL m_bCustomizeDialogPresent
TRUE if the command bar is present in Customize dialog.
Definition XTPCommandBar.h:1204
CXTPCommandBar::IsCustomizeDialogPresent
BOOL IsCustomizeDialogPresent() const
Call this method to check if the command bar is present in Customize dialog.
Definition XTPCommandBar.h:1399
CXTPCommandBar::DelayLayout
void DelayLayout()
Call this member to recalculate the layout.
Definition XTPCommandBar.h:1331
CXTPCommandBars
CXTPCommandBars is a standalone class.
Definition XTPCommandBars.h:165
CXTPControl
CXTPControl is a CXTPCmdTarget derived class.
Definition XTPControl.h:841
CXTPControls
CXTPControls is a CXTPCmdTarget derived class.
Definition XTPControls.h:47
CXTPCustomizeToolbarsPage
CXTPCustomizeToolbarsPage is a CPropertyPage derived class.
Definition XTPCustomizePageToolbars.h:64
CXTPDockBar
CXTPDockBar is a CWnd derived class.
Definition XTPDockBar.h:42
CXTPDockContext
CXTPDockContext is a standalone class.
Definition XTPDockContext.h:41
CXTPPopupBar
CXTPPopupBar is a CXTPCommandBar derived class.
Definition XTPPopupBar.h:42
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72
CXTPToolBar
CXTPToolBar is a CXTPCommandBar derived class.
Definition XTPToolBar.h:42
CXTPToolBar::DoPropExchange
virtual void DoPropExchange(CXTPPropExchange *pPX)
Either reads this object from or writes this object to an archive.
CXTPToolBar::GetDockBar
CXTPDockBar * GetDockBar() const
Retrieves the parent dock bar.
Definition XTPToolBar.h:501
CXTPToolBar::m_pDockBar
CXTPDockBar * m_pDockBar
Parent dock bar.
Definition XTPToolBar.h:445
CXTPToolBar::SetTemporary
void SetTemporary(BOOL bTemporary)
Call this method to set the control to temporary.
Definition XTPToolBar.h:538
CXTPToolBar::IsTemporary
BOOL IsTemporary() const
Call this method to determine if the control is temporary.
Definition XTPToolBar.h:534
CXTPToolBar::IsVisible
virtual BOOL IsVisible() const
Call this member to check the visibility of the toolbar.
Definition XTPToolBar.h:99
CXTPToolBar::OnPaintManagerChanged
virtual void OnPaintManagerChanged()
This method is called when the paint manager is changed.
Definition XTPToolBar.h:553
CXTPToolBar::Create
virtual BOOL Create(CWnd *pParentWnd, BOOL bFloat)
Creates a toolbar.
CXTPToolBar::~CXTPToolBar
~CXTPToolBar()
Destroys a CXTPToolBar object, handles cleanup and deallocation.
CXTPToolBar::OnHookKeyDown
BOOL OnHookKeyDown(UINT nChar, LPARAM lParam)
The framework calls this member function when a non-system key is pressed.
CXTPToolBar::ModifyBarStyle
void ModifyBarStyle(DWORD dwRemove, DWORD dwAdd)
Modifies the styles of the toolbar.
Definition XTPToolBar.h:521
CXTPToolBar::MergeToolBar
virtual void MergeToolBar(CXTPCommandBar *pCommandBar, BOOL bSilent)
This method is called to restore a toolbar to a previous state.
CXTPToolBar::GetBarInfo
void GetBarInfo(CToolBarInfo *pInfo)
Retrieves bar information for serialization routines.
CXTPToolBar::Reset
virtual void Reset(BOOL bShowWarningMessage)
Resets the controls to their original state.
CXTPToolBar::m_pDockContext
CXTPDockContext * m_pDockContext
Docking context.
Definition XTPToolBar.h:446
CXTPToolBar::m_bTemporary
BOOL m_bTemporary
TRUE if Toolbar is temporary (If it will be saved when the CommandBar layout is saved....
Definition XTPToolBar.h:451
CXTPToolBar::IsCloseable
BOOL IsCloseable() const
Call this method to retrieve the closeable property of the command bar.
Definition XTPToolBar.h:530
CXTPToolBar::CreateToolBar
BOOL CreateToolBar(DWORD dwStyle, CWnd *pParentWnd, UINT nID=AFX_IDW_TOOLBAR)
This method creates the ToolBar control.
CXTPToolBar::CalcDockingLayout
virtual CSize CalcDockingLayout(int nLength, DWORD dwMode, int nWidth=0)
This method calculates the dimensions of a toolbar.
CXTPToolBar::SetVisible
virtual void SetVisible(BOOL bVisible)
Call this member to set the visibility of the toolbar.
CXTPToolBar::m_bPreviewMode
BOOL m_bPreviewMode
TRUE if Toolbar was visible in preview mode.
Definition XTPToolBar.h:450
CXTPToolBar::SetContextMenuPresent
void SetContextMenuPresent(BOOL bPresent)
Call this method to show/hide the toolbar in a context menu.
Definition XTPToolBar.h:505
CXTPToolBar::DoUpdateCustomizeMenuControl
static BOOL AFX_CDECL DoUpdateCustomizeMenuControl(CXTPControl *pControl, CCmdTarget *pTarget)
Tries to update a Customize menu control.
CXTPToolBar::CXTPToolBar
CXTPToolBar()
Constructs a CXTPToolBar object.
CXTPToolBar::EnableDocking
void EnableDocking(DWORD dwFlags=xtpFlagAlignAny|xtpFlagFloating|xtpFlagHideWrap)
Call this method to set docking flags.
CXTPToolBar::ShowExpandButton
void ShowExpandButton(BOOL bShowExpandButton)
Call this method to show/hide the expand button of the toolbar.
Definition XTPToolBar.h:548
CXTPToolBar::m_bPreviewVisible
BOOL m_bPreviewVisible
TRUE if Toolbar was visible in preview mode.
Definition XTPToolBar.h:449
CXTPToolBar::ShouldSerializeBar
virtual BOOL ShouldSerializeBar()
Call this method to check if the toolbar has changed and must be saved.
CXTPToolBar::OnSetPreviewMode
void OnSetPreviewMode(BOOL bPreview)
Call this method to show/hide toolbars in preview mode.
CXTPToolBar::m_bVisible
BOOL m_bVisible
TRUE if the command bar is visible.
Definition XTPToolBar.h:456
CXTPToolBar::SetCustomizeDialogPresent
void SetCustomizeDialogPresent(BOOL bPresent)
Call this method to show/hide the toolbar in a customize dialog.
Definition XTPToolBar.h:513
CXTPToolBar::SetBarInfo
void SetBarInfo(CToolBarInfo *pInfo)
Sets bar information.
CXTPToolBar::SetCloseable
void SetCloseable(BOOL bCloseable)
Call this method to enable/disable the closeable property of the command bar.
Definition XTPToolBar.h:526
CXTPToolBar::IsCustomizeDialogPresent
BOOL IsCustomizeDialogPresent() const
Call this member to determine if this toolbar is included in the customize dialog.
Definition XTPToolBar.h:517
CXTPToolBar::MergeToolBar
virtual void MergeToolBar(CXTPCommandBar *pCommandBar, BOOL bSilent, int nDefaultConfirmationChoice)
This method is called to restore a toolbar to a previous state.
CXTPToolBar::m_bShowExpandButton
BOOL m_bShowExpandButton
TRUE to show expand button of toolbar.
Definition XTPToolBar.h:453
CXTPToolBar::m_bTearOff
BOOL m_bTearOff
TRUE if toolbar is tear-offed.
Definition XTPToolBar.h:448
CXTPToolBar::LoadToolBar
BOOL LoadToolBar(UINT nIDResource, BOOL bLoadIcons=TRUE)
Call this member function to load the toolbar specified by nIDResource.
CXTPToolBar::IsWindowVisible
BOOL IsWindowVisible() const
Determines if the toolbar is visible on the screen.
CXTPToolBar::Copy
virtual void Copy(CXTPCommandBar *pCommandBar, BOOL bRecursive=FALSE)
This method makes a copy of the command bar.
CXTPToolBar::SetPosition
BOOL SetPosition(XTPBarPosition barPosition)
Call this member to set the position of the toolbar.
CXTPToolBar::IsContextMenuPresent
BOOL IsContextMenuPresent() const
Call this member to determine if this toolbar is included in the right-click context menu.
Definition XTPToolBar.h:509
CXTPToolBar::CalcDynamicLayout
virtual CSize CalcDynamicLayout(int nLength, DWORD dwMode)
This method calculates the dimensions of a toolbar.
CXTPToolBar::OnRecalcLayout
void OnRecalcLayout()
This method recalculates the position of the toolbar.
CXTPToolBar::m_bContextMenuPresent
BOOL m_bContextMenuPresent
TRUE if the command bar is present in context menu.
Definition XTPToolBar.h:454
CXTPToolBar::m_bInRecalcLayout
BOOL m_bInRecalcLayout
TRUE if RecalcLayout method is called.
Definition XTPToolBar.h:455
CXTPToolBar::m_bBuiltIn
BOOL m_bBuiltIn
TRUE if toolbar is built-in.
Definition XTPToolBar.h:447
CXTPToolBar::GetBorders
virtual CRect GetBorders()
This method retrieves the borders of the toolbar.


Toolkit Pro: Member List

CXTPCalendarCaptionBarVisualStudio2017Theme Member List

This is the complete list of members for CXTPCalendarCaptionBarVisualStudio2017Theme, including all inherited members.

CXTPCalendarCaptionBarOffice2000Theme(CXTPCalendarCaptionBarTheme *pTheme=NULL) | CXTPCalendarCaptionBarOffice2000Theme |
CXTPCalendarCaptionBarOffice2003Theme(CXTPCalendarCaptionBarTheme *pTheme=NULL) | CXTPCalendarCaptionBarOffice2003Theme |
CXTPCalendarCaptionBarOffice2013Theme(CXTPCalendarCaptionBarTheme *pTheme=NULL) | CXTPCalendarCaptionBarOffice2013Theme |
CXTPCalendarCaptionBarOfficeXPTheme(CXTPCalendarCaptionBarTheme *pTheme=NULL) | CXTPCalendarCaptionBarOfficeXPTheme |
CXTPCalendarCaptionBarPaintManager(CXTPCalendarCaptionBarTheme *pTheme=NULL) | CXTPCalendarCaptionBarPaintManager |
CXTPCalendarCaptionBarVisualStudio2017Theme(CXTPCalendarCaptionBarTheme *pTheme=NULL) | CXTPCalendarCaptionBarVisualStudio2017Theme |
CXTPCmdTarget() | CXTPCmdTarget |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetPaintTheme() const | CXTPCalendarCaptionBarPaintManager | virtual
m_clrBorders | CXTPCalendarCaptionBarPaintManager | protected
m_clrScrollDateBarBk | CXTPCalendarCaptionBarPaintManager | protected
m_clrScrollTriangleColor | CXTPCalendarCaptionBarPaintManager | protected
m_clrSwitchViewBarBk | CXTPCalendarCaptionBarPaintManager | protected
m_clrTextColor | CXTPCalendarCaptionBarPaintManager | protected
m_fntTextFont | CXTPCalendarCaptionBarPaintManager | protected
m_pTheme | CXTPCalendarCaptionBarPaintManager | protected
RefreshMetrics() | CXTPCalendarCaptionBarOffice2013Theme | virtual
~CXTPCalendarCaptionBarOffice2000Theme() | CXTPCalendarCaptionBarOffice2000Theme | virtual
~CXTPCalendarCaptionBarOffice2003Theme() | CXTPCalendarCaptionBarOffice2003Theme | virtual
~CXTPCalendarCaptionBarOffice2013Theme() | CXTPCalendarCaptionBarOffice2013Theme | virtual
~CXTPCalendarCaptionBarOfficeXPTheme() | CXTPCalendarCaptionBarOfficeXPTheme | virtual
~CXTPCalendarCaptionBarPaintManager() | CXTPCalendarCaptionBarPaintManager | virtual
~CXTPCalendarCaptionBarVisualStudio2017Theme() | CXTPCalendarCaptionBarVisualStudio2017Theme | virtual


Toolkit Pro: XTPTaskPanelExplorerThemePlain.h Source File

  • Source
  • TaskPanel
  • Themes
XTPTaskPanelExplorerThemePlain.h
Go to the documentation of this file.
1
23#ifndef XTPTaskPanelExplorerThemePlain_h__
24# define XTPTaskPanelExplorerThemePlain_h__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
39class _XTP_EXT_CLASS CXTPTaskPanelExplorerThemePlain : public CXTPTaskPanelPaintManagerPlain
40{
41public:
46 CXTPTaskPanelExplorerThemePlain();
47
52 void RefreshMetrics();
53
54 BOOL m_bExplorerTheme;
89 CRect DrawCaptionGripper(CDC* pDC, CXTPTaskPanelGroup* pGroup, CRect rc);
90};
92# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
93#endif // XTPTaskPanelExplorerThemePlain_h__
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPTaskPanelExplorerThemePlain
CXTPTaskPanelExplorerThemePlain represents a classic Explorer style theme.
Definition XTPTaskPanelExplorerThemePlain.h:40
CXTPTaskPanelExplorerThemePlain::CXTPTaskPanelExplorerThemePlain
CXTPTaskPanelExplorerThemePlain()
Constructs a CXTPTaskPanelExplorerThemePlain object.
CXTPTaskPanelExplorerThemePlain::DrawCaptionGripper
CRect DrawCaptionGripper(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Draws the caption gripper.
CXTPTaskPanelExplorerThemePlain::m_bExplorerTheme
BOOL m_bExplorerTheme
TRUE to use Explorer theme under WinXP and to use Office 2000 under older OSes.
Definition XTPTaskPanelExplorerThemePlain.h:54
CXTPTaskPanelExplorerThemePlain::RefreshMetrics
void RefreshMetrics()
Refreshes the visual metrics of the task panel.
CXTPTaskPanelGroup
CXTPTaskPanelGroup is used in a Task Panel control to represent a group.
Definition XTPTaskPanelGroup.h:45
CXTPTaskPanelPaintManagerPlain
Base class theme that all other themes are derived from.
Definition XTPTaskPanelPaintManagerPlain.h:41


Toolkit Pro: XTPChartErrorBar.h Source File

  • Source
  • Chart
XTPChartErrorBar.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTERRORBAR_H__)
24# define __XTPCHARTERRORBAR_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartLineStyle;
34
35class _XTP_EXT_CLASS CXTPChartErrorBar : public CXTPChartElement
36{
38 DECLARE_SERIAL(CXTPChartErrorBar)
40public:
45 CXTPChartErrorBar();
46
51 virtual ~CXTPChartErrorBar();
52
53public:
54 virtual CXTPChartElementView* CreateView(CXTPChartDeviceContext* pDC,
55 CXTPChartSeriesPointView* pPointView,
56 CXTPChartElementView* pParentView);
57
58 BOOL IsVisible() const;
59
60 void SetVisible(BOOL bVisible);
61
62 XTPChartErrorBarEndStyle GetEndStyle() const;
63
64 void SetEndStyle(XTPChartErrorBarEndStyle endStyle);
65
66 XTPChartErrorBarType GetType() const;
67
68 void SetType(XTPChartErrorBarType type);
69
70 XTPChartErrorBarDirection GetDirection() const;
71
72 void SetDirection(XTPChartErrorBarDirection direction);
73
74 double GetAmount() const;
75
76 void SetAmount(double dAmount);
77
78 double GetValuePlus() const;
79
80 void SetValuePlus(double dValuePlus);
81
82 double GetValueMinus() const;
83
84 void SetValueMinus(double dValueMinus);
85
86 CXTPChartLineStyle* GetLineStyle() const;
87
88 void SetLineStyle(CXTPChartLineStyle* pLineStyle);
89
90 CXTPChartColor GetLineColor() const;
91
92 void SetLineColor(CXTPChartColor clrLine);
93
94public:
95 XTPChartErrorBarPosition GetPosition() const;
96
97private:
98 BOOL m_bVisible;
99 XTPChartErrorBarEndStyle m_endStyle;
100 XTPChartErrorBarType m_type;
101 XTPChartErrorBarDirection m_direction;
102
103 int m_nCapLength;
104
105 double m_dAmount;
106 double m_dValuePlus;
107 double m_dValueMinus;
109 CXTPChartLineStyle* m_pLineStyle;
110 CXTPChartColor m_clrLine;
111
112protected:
113 friend class CXTPChartSeriesStyle;
114 friend class CXTPChartErrorBarView;
115
116# ifdef _XTP_ACTIVEX
117public:
119 DECLARE_DISPATCH_MAP()
120 DECLARE_INTERFACE_MAP()
121 DECLARE_OLETYPELIB_EX(CXTPChartErrorBar);
122 LPDISPATCH OleGetLineStyle();
123 OLE_COLOR OleGetLineColor();
124 void OleSetLineColor(OLE_COLOR clr);
126# endif
127};
128
129AFX_INLINE BOOL CXTPChartErrorBar::IsVisible() const
130{
131 return m_bVisible;
132}
133
134AFX_INLINE void CXTPChartErrorBar::SetVisible(BOOL bVisible)
135{
136 m_bVisible = bVisible;
137 OnChartChanged();
138}
139
140AFX_INLINE XTPChartErrorBarType CXTPChartErrorBar::GetType() const
141{
142 return m_type;
143}
144
145AFX_INLINE void CXTPChartErrorBar::SetType(XTPChartErrorBarType type)
146{
147 m_type = type;
148 OnChartChanged();
149}
150
151AFX_INLINE XTPChartErrorBarEndStyle CXTPChartErrorBar::GetEndStyle() const
152{
153 return m_endStyle;
154}
155
156AFX_INLINE void CXTPChartErrorBar::SetEndStyle(XTPChartErrorBarEndStyle endStyle)
157{
158 m_endStyle = endStyle;
159 OnChartChanged();
160}
161
162AFX_INLINE XTPChartErrorBarDirection CXTPChartErrorBar::GetDirection() const
163{
164 return m_direction;
165}
166
167AFX_INLINE void CXTPChartErrorBar::SetDirection(XTPChartErrorBarDirection direction)
168{
169 m_direction = direction;
170}
171
172AFX_INLINE double CXTPChartErrorBar::GetAmount() const
173{
174 return m_dAmount;
175}
176
177AFX_INLINE void CXTPChartErrorBar::SetAmount(double dAmount)
178{
179 m_dAmount = dAmount;
180}
181
182AFX_INLINE double CXTPChartErrorBar::GetValuePlus() const
183{
184 return m_dValuePlus;
185}
186
187AFX_INLINE void CXTPChartErrorBar::SetValuePlus(double dValuePlus)
188{
189 m_dValuePlus = dValuePlus;
190}
191
192AFX_INLINE double CXTPChartErrorBar::GetValueMinus() const
193{
194 return m_dValueMinus;
195}
196
197AFX_INLINE void CXTPChartErrorBar::SetValueMinus(double dValueMinus)
198{
199 m_dValueMinus = dValueMinus;
200}
201
202AFX_INLINE CXTPChartLineStyle* CXTPChartErrorBar::GetLineStyle() const
203{
204 return m_pLineStyle;
205}
206
207AFX_INLINE void CXTPChartErrorBar::SetLineStyle(CXTPChartLineStyle* pLineStyle)
208{
209 m_pLineStyle = pLineStyle;
210}
211
212AFX_INLINE CXTPChartColor CXTPChartErrorBar::GetLineColor() const
213{
214 return m_clrLine;
215}
216
217AFX_INLINE void CXTPChartErrorBar::SetLineColor(CXTPChartColor clrLine)
218{
219 m_clrLine = clrLine;
220}
221
222class _XTP_EXT_CLASS CXTPChartErrorBarView : public CXTPChartElementView
223{
224public:
225 CXTPChartErrorBarView(CXTPChartErrorBar* pErrorBar, CXTPChartSeriesPointView* pPointView,
226 CXTPChartElementView* pParentView);
227
228 void GetValues(double& dCenter, double& dPlus, double& dMinus) const;
229
230protected:
231 virtual CXTPChartDeviceCommand* CreateDeviceCommand(CXTPChartDeviceContext* pDC);
232
237 virtual double GetAnchorAngle(XTPChartErrorBarPosition position) const;
238
239protected:
240 CXTPChartErrorBar* m_pErrorBar;
241 CXTPChartSeriesPointView* m_pPointView;
242};
244# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
245#endif //#if !defined(__XTPCHARTERRORBAR_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartColor
This class abstracts a color entity.
Definition XTPChartTypes.h:51
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartElement
This class abstracts a chart element, this class acts as a base class for all chart elements.
Definition XTPChartElement.h:131
CXTPChartElement::OnChartChanged
virtual void OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic propertie...
CXTPChartElementView
This class represents the view of a chart element.
Definition XTPChartElementView.h:47
CXTPChartLineStyle
This class represents a chart line style, which is a kind of CXTPCmdTarget.
Definition XTPChartLineStyle.h:43
CXTPChartSeriesPointView
Represents chart series point view.
Definition XTPChartSeriesPointView.h:48
CXTPChartSeriesStyle
CXTPChartSeriesStyle is a CXTPChartElement derived class.
Definition XTPChartSeriesStyle.h:49


Toolkit Pro: Member List

CXTPCaptionTheme Member List

This is the complete list of members for CXTPCaptionTheme, including all inherited members.

CXTPCaptionTheme() | CXTPCaptionTheme |
CXTPCmdTarget() | CXTPCmdTarget |
CXTPControlTheme() | CXTPControlTheme |
DrawCaptionBack(CDC *pDC, CXTPCaption *pCaption, CRect &rcItem) | CXTPCaptionTheme | virtual
DrawCaptionIcon(CDC *pDC, CXTPCaption *pCaption, CRect &rcItem) | CXTPCaptionTheme | virtual
DrawCaptionText(CDC *pDC, CXTPCaption *pCaption) | CXTPCaptionTheme | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetThemeStyle() const | CXTPControlTheme |
m_clrEdgeLight | CXTPCaptionTheme |
m_clrEdgeShadow | CXTPCaptionTheme |
m_nTheme | CXTPControlTheme | protected
RefreshMetrics(CXTPCaption *pCaption) | CXTPCaptionTheme | virtual
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static


Toolkit Pro: Member List

CXTPColorSetCaptionButton Member List

This is the complete list of members for CXTPColorSetCaptionButton, including all inherited members.

m_clrBackground | CXTPColorSetCaptionButton |
m_clrFill | CXTPColorSetCaptionButton |
m_clrOutline | CXTPColorSetCaptionButton |
RefreshMetrics(CString strSectionName) | CXTPColorSetCaptionButton | virtual
~CXTPColorSetCaptionButton() | CXTPColorSetCaptionButton | inlinevirtual


Toolkit Pro: Member List

CXTPComboBoxThemeOfficeXPFlat Member List

This is the complete list of members for CXTPComboBoxThemeOfficeXPFlat, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPComboBoxTheme() | CXTPComboBoxTheme |
CXTPComboBoxThemeOfficeXPFlat(XTPControlTheme nTheme) | CXTPComboBoxThemeOfficeXPFlat |
CXTPControlTheme() | CXTPControlTheme |
DrawBackground(CDC *pDC, CXTPComboBox *pComboBox) | CXTPComboBoxThemeOfficeXPFlat | virtual
DrawButton(CDC *pDC, CXTPComboBox *pComboBox, CRect rcBtn) | CXTPComboBoxThemeOfficeXPFlat | virtual
DrawButtonTriangle(CDC *pDC, CXTPComboBox *pComboBox, CRect rcBtn) | CXTPComboBoxTheme | virtual
DrawComboBox(CDC *pDC, CXTPComboBox *pComboBox) | CXTPComboBoxTheme | virtual
DrawFrame(HDC hdc, LPRECT lprc, int nSize, HBRUSH hBrush) | CXTPComboBoxTheme | virtual
FillSolidRect(HDC hdc, int x, int y, int cx, int cy, HBRUSH hBrush) | CXTPComboBoxTheme | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetBackColor() const | CXTPComboBoxTheme |
GetBackgroundBrush() const | CXTPComboBoxTheme |
GetTextColor() const | CXTPComboBoxTheme |
GetThemeStyle() const | CXTPControlTheme |
m_clrBackDisabled | CXTPComboBoxTheme |
m_clrBackground | CXTPComboBoxTheme |
m_clrBackHighlight | CXTPComboBoxTheme |
m_clrBorderDisabled | CXTPComboBoxTheme |
m_clrBorderHot | CXTPComboBoxTheme |
m_clrBorderNormal | CXTPComboBoxTheme |
m_clrButtonArrowHot | CXTPComboBoxTheme |
m_clrButtonArrowNormal | CXTPComboBoxTheme |
m_clrButtonArrowPressed | CXTPComboBoxTheme |
m_clrButtonHot | CXTPComboBoxTheme |
m_clrButtonNormal | CXTPComboBoxTheme |
m_clrButtonPressed | CXTPComboBoxTheme |
m_clrText | CXTPComboBoxTheme |
m_clrTextDisabled | CXTPComboBoxTheme |
m_clrTextHighlight | CXTPComboBoxTheme |
m_grcButton | CXTPComboBoxTheme |
m_grcButtonHilite | CXTPComboBoxTheme |
m_grcButtonPushed | CXTPComboBoxTheme |
m_nTheme | CXTPComboBoxThemeOfficeXPFlat |
m_nThumbWidth | CXTPComboBoxTheme | protected
m_themeComboBox | CXTPComboBoxTheme | protected
m_xtpBrushBackground | CXTPComboBoxTheme | protected
RefreshMetrics(CXTPComboBox *pComboBox) | CXTPComboBoxThemeOfficeXPFlat | virtual
ResetBackColor() | CXTPComboBoxTheme |
ResetTextColor() | CXTPComboBoxTheme |
SetBackColor(COLORREF clrBackground) | CXTPComboBoxTheme |
SetTextColor(COLORREF clrText) | CXTPComboBoxTheme |
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static
UpdateBackgroundBrush() | CXTPComboBoxTheme | protected
~CXTPComboBoxTheme() | CXTPComboBoxTheme | virtual
~CXTPComboBoxThemeOfficeXPFlat() | CXTPComboBoxThemeOfficeXPFlat | virtual


Toolkit Pro: XTPTrackThemeVisualStudio2015.h Source File

  • Source
  • GridControl
  • TrackControl
  • Themes
XTPTrackThemeVisualStudio2015.h
Go to the documentation of this file.
1
23#if !defined(__XTPTRACKTHEMEVISUALSTUDIO2015_H__)
24# define __XTPTRACKTHEMEVISUALSTUDIO2015_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPTrackThemeVisualStudio2015 : public CXTPTrackThemeOffice2013
39{
40public:
45 CXTPTrackThemeVisualStudio2015();
46
52 virtual void RefreshMetrics();
53};
55# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
56#endif //#if !defined(__XTPTRACKTHEMEVISUALSTUDIO2015_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPTrackThemeOffice2013
CXTPTrackThemeOffice2013 is a CXTPTrackPaintManager derived class that represents an Office 2013 styl...
Definition XTPTrackThemeOffice2013.h:39
CXTPTrackThemeVisualStudio2015
CXTPTrackThemeVisualStudio2015 is a CXTPTrackThemeOffice2013 derived class that represents a Visual S...
Definition XTPTrackThemeVisualStudio2015.h:39
CXTPTrackThemeVisualStudio2015::CXTPTrackThemeVisualStudio2015
CXTPTrackThemeVisualStudio2015()
Default paint manager constructor, handles properties initialization.
CXTPTrackThemeVisualStudio2015::RefreshMetrics
virtual void RefreshMetrics()
This method is called to refresh the visual metrics of the track control.


Toolkit Pro: XTPDockingPaneThemeVisualStudio6.h Source File

  • Source
  • DockingPane
  • Themes
XTPDockingPaneThemeVisualStudio6.h
Go to the documentation of this file.
1
23#if !defined(__XTPDOCKINGPANETHEMEVISUALSTUDIO6_H__)
24# define __XTPDOCKINGPANETHEMEVISUALSTUDIO6_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
40class _XTP_EXT_CLASS CXTPDockingPaneVisualStudio6Theme : public CXTPDockingPaneGripperedTheme
41{
42public:
47 CXTPDockingPaneVisualStudio6Theme();
48
49protected:
60 virtual void DrawCaptionPart(CDC* pDC, CXTPDockingPaneBase* pPane, CRect rcCaption,
61 const CString& strTitle, BOOL bActive, BOOL bVertical);
62};
63
64# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
66#endif // !defined(__XTPDOCKINGPANETHEMEVISUALSTUDIO6_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPDockingPaneBase
CXTPDockingPaneBase is a standalone class.
Definition XTPDockingPaneBase.h:69
CXTPDockingPaneGripperedTheme
CXTPDockingPaneGripperedTheme is a CXTPDockingPaneDefaultTheme derived class that represents a grippe...
Definition XTPDockingPaneThemeGrippered.h:41
CXTPDockingPaneVisualStudio6Theme
CXTPDockingPaneVisualStudio6Theme is a CXTPDockingPaneGripperedTheme derived class that represents a ...
Definition XTPDockingPaneThemeVisualStudio6.h:41
CXTPDockingPaneVisualStudio6Theme::CXTPDockingPaneVisualStudio6Theme
CXTPDockingPaneVisualStudio6Theme()
Constructs a CXTPDockingPaneVisualStudio6Theme object.
CXTPDockingPaneVisualStudio6Theme::DrawCaptionPart
virtual void DrawCaptionPart(CDC *pDC, CXTPDockingPaneBase *pPane, CRect rcCaption, const CString &strTitle, BOOL bActive, BOOL bVertical)
Draws the common part of a tabbed and floating caption.


Toolkit Pro: XTPChartLineSeriesErrorBar.h Source File

  • Source
  • Chart
  • Styles
  • Line
XTPChartLineSeriesErrorBar.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTLINESERIESERRORBAR_H__)
24# define __XTPCHARTLINESERIESERRORBAR_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartSeriesView;
34
35class _XTP_EXT_CLASS CXTPChartLineSeriesErrorBar : public CXTPChartErrorBar
36{
37 DECLARE_SERIAL(CXTPChartLineSeriesErrorBar);
38
39public:
44 CXTPChartLineSeriesErrorBar();
45
50 virtual ~CXTPChartLineSeriesErrorBar();
51
52public:
63 virtual CXTPChartElementView* CreateView(CXTPChartDeviceContext* pDC,
64 CXTPChartSeriesPointView* pPointView,
65 CXTPChartElementView* pParentView);
66
67 void DoPropExchange(CXTPPropExchange* pPX);
68
69public:
70# ifdef _XTP_ACTIVEX
71public:
73 DECLARE_DISPATCH_MAP()
74 DECLARE_INTERFACE_MAP()
75 DECLARE_OLETYPELIB_EX(CXTPChartLineSeriesErrorBar);
77# endif
78};
79
85class _XTP_EXT_CLASS CXTPChartLineSeriesErrorBarView : public CXTPChartErrorBarView
86{
87public:
96 CXTPChartLineSeriesErrorBarView(CXTPChartErrorBar* pErrorBar,
97 CXTPChartSeriesPointView* pPointView,
98 CXTPChartElementView* pParentView);
99
100 void CalculateLayout(CXTPChartDeviceContext* pDC);
101};
103# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
104#endif //#if !defined(__XTPCHARTLINESERIESERRORBAR_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartElement::DoPropExchange
virtual void DoPropExchange(CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
CXTPChartElementView
This class represents the view of a chart element.
Definition XTPChartElementView.h:47
CXTPChartLineSeriesErrorBarView
This class abstracts the view of the label of a bar series, it is a kind of point series label view.
Definition XTPChartLineSeriesErrorBar.h:86
CXTPChartLineSeriesErrorBarView::CXTPChartLineSeriesErrorBarView
CXTPChartLineSeriesErrorBarView(CXTPChartErrorBar *pErrorBar, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView)
Constructs a CXTPChartLineSeriesErrorBarView object.
CXTPChartSeriesPointView
Represents chart series point view.
Definition XTPChartSeriesPointView.h:48
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72


Toolkit Pro: Member List

CXTPOriginalControls Member List

This is the complete list of members for CXTPOriginalControls, including all inherited members.

Add(CXTPControl *pControl, int nId, LPCTSTR lpszParameter=NULL, int nBefore=-1, BOOL bTemporary=FALSE) | CXTPControls |
Add(XTPControlType controlType, int nId, LPCTSTR lpszParameter=NULL, int nBefore=-1, BOOL bTemporary=FALSE) | CXTPControls |
Add(CXTPControl *pControl) | CXTPControls |
AddClone(CXTPControl *pClone, int nBefore=-1, BOOL bRecursive=FALSE) | CXTPControls |
AddMenuItem(CMenu *pMenu, int nIndex) | CXTPControls |
CalcDynamicSize(CDC *pDC, int nLength, DWORD dwMode, const CRect &rcBorder, int nWidth=0) | CXTPControls |
CalcPopupSize(CDC *pDC, int nLength, int nWidth, const CRect &rcBorder) | CXTPControls |
ClearOriginalControls() | CXTPControls |
CommandToIndex(int nIDFind) const | CXTPControls |
Compare(const CXTPControls *pControls) | CXTPControls |
Copy(CXTPControls *pControls, BOOL bRecursive=FALSE) | CXTPControls | virtual
CreateOriginalControls() | CXTPControls |
CXTPCmdTarget() | CXTPCmdTarget |
CXTPControls() | CXTPControls |
CXTPOriginalControls() | CXTPOriginalControls |
DoPropExchange(CXTPPropExchange *pPX) | CXTPControls | virtual
Duplicate(BOOL bRecursive=FALSE) | CXTPControls |
FindControl(int nId) const | CXTPControls |
FindControl(XTPControlType type, int nId, BOOL bVisible, BOOL bRecursive) const | CXTPControls |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAt(int nIndex) const | CXTPControls |
GetCommandBars() const | CXTPControls |
GetCount() const | CXTPControls |
GetFirst() const | CXTPControls |
GetNext(CXTPControl *&pControl) const | CXTPControls |
GetNext(long nIndex, int nDirection=+1, BOOL bKeyboard=TRUE, BOOL bSkipTemporary=FALSE, BOOL bSkipCollapsed=TRUE) const | CXTPControls |
GetOriginalControls() const | CXTPControls |
GetParent() const | CXTPControls |
GetVisibleAt(int nIndex, BOOL bIgnoreWraps=FALSE) const | CXTPControls |
GetVisibleCount(BOOL bIgnoreWrap=FALSE) const | CXTPControls |
HitTest(CPoint point) const | CXTPControls |
InsertAt(CXTPControl *pControl, int nBefore) | CXTPControls |
IsChanged() const | CXTPControls |
IsOriginalControls() const | CXTPControls |
LoadMenu(CMenu *pMenu) | CXTPControls |
m_arrControls | CXTPControls | protected
m_bOriginalControls | CXTPControls | protected
m_pCommandBars | CXTPControls | protected
m_pOriginalControls | CXTPControls | protected
m_pParent | CXTPControls | protected
MoveBefore(CXTPControl *pControl, int nBefore) | CXTPControls |
OnControlAdded(CXTPControl *pControl) | CXTPControls | protectedvirtual
OnControlRemoved(CXTPControl *pControl) | CXTPControls | protectedvirtual
OnControlRemoving(CXTPControl *pControl) | CXTPControls | protectedvirtual
Remove(CXTPControl *pControl) | CXTPControls | virtual
Remove(int nIndex) | CXTPControls |
RemoveAll() | CXTPControls |
SetCommandBars(CXTPCommandBars *pCommandBars) | CXTPControls |
SetControlType(CXTPControl *pControl, XTPControlType type) | CXTPControls |
SetControlType(int nIndex, XTPControlType type) | CXTPControls |
SetOriginalControls(CXTPOriginalControls *pControls) | CXTPControls |
SetParent(CXTPCommandBar *pParent) | CXTPControls |
ShouldSerializeControl(CXTPControl *pControl) | CXTPControls | virtual
Sort() | CXTPControls |
~CXTPControls() | CXTPControls | virtual


Toolkit Pro: XTPGridDragDrop.h Source File

  • Source
  • GridControl
XTPGridDragDrop.h
Go to the documentation of this file.
1
23#if !defined(__XTPGRIDDRAGDROP_H__)
24# define __XTPGRIDDRAGDROP_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPGridHeader;
34class CXTPGridPaintManager;
35class CXTPGridColumn;
36
42class _XTP_EXT_CLASS CXTPGridHeaderDragWnd : public CWnd
43{
44public:
49 CXTPGridHeaderDragWnd();
50
55 virtual ~CXTPGridHeaderDragWnd();
56
57public:
68 virtual BOOL Create(CRect rect, CXTPGridHeader* pHeader, CXTPGridPaintManager* pPaintManager,
69 CXTPGridColumn* pColumn);
70
71protected:
79 virtual void OnDraw(CDC* pDC, CRect rcClient);
80
81protected:
83 //{{AFX_MSG(CXTPGridHeaderDragWnd)
84 afx_msg void OnPaint();
85 afx_msg BOOL OnEraseBkgnd(CDC* pDC);
86 afx_msg void OnTimer(UINT_PTR nIDEvent);
87 //}}AFX_MSG
88
89 //{{AFX_VIRTUAL(CXTPGridHeaderDragWnd)
90 virtual void PostNcDestroy();
91 //}}AFX_VIRTUAL
94private:
95 BOOL Create(LPCTSTR lpszClassName, LPCTSTR lpszWindowName, DWORD dwStyle, const RECT& rect,
96 CWnd* pParentWnd, UINT nID, CCreateContext* pContext = NULL);
98 DECLARE_MESSAGE_MAP()
100protected:
101 CXTPGridHeader* m_pHeader;
102 CXTPGridPaintManager* m_pPaintManager;
103 CXTPGridColumn* m_pColumn;
104};
105
111class _XTP_EXT_CLASS CXTPGridHeaderDropWnd : public CWnd
112{
113public:
119 CXTPGridHeaderDropWnd(COLORREF crColor);
120
125 virtual ~CXTPGridHeaderDropWnd();
126
127public:
134 void SetWindowPos(int xPos, int yPos);
135
144 virtual BOOL Create(CWnd* pParentWnd, int nHeight);
145
146protected:
148 //{{AFX_VIRTUAL(CXTPGridHeaderDropWnd)
149 virtual void PostNcDestroy();
150 //}}AFX_VIRTUAL
151
152 //{{AFX_MSG(CXTPGridHeaderDropWnd)
153 afx_msg BOOL OnEraseBkgnd(CDC* pDC);
154 //}}AFX_MSG
157private:
158 BOOL Create(LPCTSTR lpszClassName, LPCTSTR lpszWindowName, DWORD dwStyle, const RECT& rect,
159 CWnd* pParentWnd, UINT nID, CCreateContext* pContext = NULL);
161 DECLARE_MESSAGE_MAP()
163protected:
164 COLORREF m_clr;
165 CRgn m_rgn;
166 int m_nHeight;
167};
168
170
171AFX_INLINE BOOL CXTPGridHeaderDragWnd::Create(LPCTSTR lpszClassName, LPCTSTR lpszWindowName,
172 DWORD dwStyle, const RECT& rect, CWnd* pParentWnd,
173 UINT nID, CCreateContext* pContext)
174{
175 return CWnd::Create(lpszClassName, lpszWindowName, dwStyle, rect, pParentWnd, nID, pContext);
176}
177AFX_INLINE BOOL CXTPGridHeaderDropWnd::Create(LPCTSTR lpszClassName, LPCTSTR lpszWindowName,
178 DWORD dwStyle, const RECT& rect, CWnd* pParentWnd,
179 UINT nID, CCreateContext* pContext)
180{
181 return CWnd::Create(lpszClassName, lpszWindowName, dwStyle, rect, pParentWnd, nID, pContext);
182}
184# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
185#endif //#if !defined(__XTPGRIDDRAGDROP_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPGridColumn
Represents a grid column item with its properties and operations.
Definition XTPGridColumn.h:107
CXTPGridHeaderDragWnd
CXTPGridHeaderDragWnd is a CWnd derived class.
Definition XTPGridDragDrop.h:43
CXTPGridHeaderDragWnd::Create
virtual BOOL Create(CRect rect, CXTPGridHeader *pHeader, CXTPGridPaintManager *pPaintManager, CXTPGridColumn *pColumn)
Creates a dragging window with the specified parameters.
CXTPGridHeaderDragWnd::~CXTPGridHeaderDragWnd
virtual ~CXTPGridHeaderDragWnd()
Destroys a CXTPGridHeaderDragWnd object, handles cleanup and deallocation.
CXTPGridHeaderDragWnd::CXTPGridHeaderDragWnd
CXTPGridHeaderDragWnd()
Creates a CXTPGridHeaderDragWnd object.
CXTPGridHeaderDragWnd::OnDraw
virtual void OnDraw(CDC *pDC, CRect rcClient)
Called by the framework to draw the contents of the window using the specified device context.
CXTPGridHeaderDropWnd
CXTPGridHeaderDropWnd is a CWnd derived class.
Definition XTPGridDragDrop.h:112
CXTPGridHeaderDropWnd::Create
virtual BOOL Create(CWnd *pParentWnd, int nHeight)
Creates a drop window with a specified gap inside.
CXTPGridHeaderDropWnd::~CXTPGridHeaderDropWnd
virtual ~CXTPGridHeaderDropWnd()
Destroys a CXTPGridHeaderDropWnd object, handles cleanup and deallocation.
CXTPGridHeaderDropWnd::SetWindowPos
void SetWindowPos(int xPos, int yPos)
Changes the window position.
CXTPGridHeaderDropWnd::CXTPGridHeaderDropWnd
CXTPGridHeaderDropWnd(COLORREF crColor)
Creates a CXTPGridHeaderDropWnd object.
CXTPGridHeader
A grid header is a part of the grid window positioned above columns of text or numbers.
Definition XTPGridHeader.h:173
CXTPGridPaintManager
Utility class that handles most drawing activities.
Definition XTPGridPaintManager.h:76


Toolkit Pro: Member List

CXTPImageEditorDlg Member List

This is the complete list of members for CXTPImageEditorDlg, including all inherited members.

CXTPImageEditorDlg(CWnd *pParent=NULL, BOOL bCommandBarsEditor=FALSE) | CXTPImageEditorDlg
GetIcon(CXTPImageManagerIconHandle *pHandle) | CXTPImageEditorDlg
IDD enum value | CXTPImageEditorDlg
SetIcon(CXTPImageManagerIconHandle &pHandle) | CXTPImageEditorDlg
SetIconSize(CSize szIcon) | CXTPImageEditorDlg


Toolkit Pro: Member List

CXTPTrackKey Member List

This is the complete list of members for CXTPTrackKey, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPTrackBlock() | CXTPTrackBlock |
CXTPTrackKey() | CXTPTrackKey |
DoPropExchange(CXTPPropExchange *pPX) | CXTPTrackBlock |
Draw(CDC *pDC, CRect rc, BOOL bSelected) | CXTPTrackKey | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCaption() const | CXTPTrackBlock |
GetDescriptionText() const | CXTPTrackBlock |
GetHeightPercent() const | CXTPTrackBlock |
GetIndex() const | CXTPTrackBlock |
GetItem() const | CXTPTrackBlock |
GetLength() const | CXTPTrackBlock |
GetMaxLength() const | CXTPTrackBlock |
GetMinLength() const | CXTPTrackBlock |
GetPosition() const | CXTPTrackBlock |
GetRect() const | CXTPTrackBlock |
GetTooltip() const | CXTPTrackBlock | virtual
GetVerticalAlignment() const | CXTPTrackBlock |
IsKey() const | CXTPTrackKey | virtual
IsLocked() const | CXTPTrackBlock |
IsResizable() const | CXTPTrackBlock | virtual
IsSelected() const | CXTPTrackBlock |
m_bDragging | CXTPTrackBlock | protected
m_bLocked | CXTPTrackBlock |
m_clrBlock | CXTPTrackBlock |
m_dHeightPercent | CXTPTrackBlock |
m_nIndex | CXTPTrackBlock | protected
m_nLastDragTime | CXTPTrackBlock | protected
m_nLength | CXTPTrackBlock |
m_nMaxLength | CXTPTrackBlock | protected
m_nMinLength | CXTPTrackBlock | protected
m_nMRUPosition | CXTPTrackBlock | protected
m_nPosition | CXTPTrackBlock |
m_nVerticalAlignment | CXTPTrackBlock |
m_pItem | CXTPTrackBlock |
m_rcBlock | CXTPTrackBlock |
m_strCaption | CXTPTrackBlock |
m_strDescription | CXTPTrackBlock | protected
m_strToolTip | CXTPTrackBlock | protected
Remove() | CXTPTrackBlock |
Select(BOOL bSelect=TRUE) | CXTPTrackBlock |
SetCaption(LPCTSTR lpszCaption) | CXTPTrackBlock |
SetColor(COLORREF clr) | CXTPTrackBlock |
SetDescriptionText(LPCTSTR lpszDescriptionText) | CXTPTrackBlock |
SetHeightPercent(double dHeightPercent) | CXTPTrackBlock |
SetLength(int nLength) | CXTPTrackBlock |
SetLocked(BOOL bLocked=TRUE) | CXTPTrackBlock |
SetMaxLength(int nMaxLength) | CXTPTrackBlock |
SetMinLength(int nMinLength) | CXTPTrackBlock |
SetPosition(int nPosition) | CXTPTrackBlock |
SetTooltip(LPCTSTR lpszTooltip) | CXTPTrackBlock |
SetVerticalAlignment(int nAlignment) | CXTPTrackBlock |


Toolkit Pro: Member List

CXTPFlowGraphNodes Member List

This is the complete list of members for CXTPFlowGraphNodes, including all inherited members.

AddCustomNode(CXTPFlowGraphNodeCustom *pNode=NULL) | CXTPFlowGraphNodes |
AddNode(CXTPFlowGraphNode *pNode) | CXTPFlowGraphNodes |
CXTPCmdTarget() | CXTPCmdTarget |
CXTPFlowGraphNodes(CXTPFlowGraphPage *pPage) | CXTPFlowGraphNodes | protected
DoPropExchange(CXTPPropExchange *pPX) | CXTPFlowGraphNodes |
FindNode(int nId) const | CXTPFlowGraphNodes |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAt(int nIndex) const | CXTPFlowGraphNodes |
GetCount() const | CXTPFlowGraphNodes |
m_arrNodes | CXTPFlowGraphNodes | protected
m_pPage | CXTPFlowGraphNodes | protected
MoveToFront(CXTPFlowGraphNode *pNode) | CXTPFlowGraphNodes |
Remove(CXTPFlowGraphNode *pNode) | CXTPFlowGraphNodes |
RemoveAll() | CXTPFlowGraphNodes |
RemoveAt(int nIndex) | CXTPFlowGraphNodes |
~CXTPFlowGraphNodes() | CXTPFlowGraphNodes | protectedvirtual


Toolkit Pro: Member List

CXTPPaintManager Member List

This is the complete list of members for CXTPPaintManager, including all inherited members.

AdjustExcludeRect(CRect &rc, CXTPControl *pControl, BOOL bVertical)=0 | CXTPPaintManager | pure virtual
Animate(CDC *pDestDC, CDC *pSrcDC, CRect rc, XTPAnimationType animationType) | CXTPPaintManager | virtual
AnimateExpanding(CXTPCommandBar *pCommandBar, CDC *pDestDC, CDC *pSrcDC, BOOL bExpandDown) | CXTPPaintManager | virtual
BaseTheme()=0 | CXTPPaintManager | pure virtual
CreateTheme(XTPPaintTheme paintTheme) | CXTPPaintManager | static
CXTPCmdTarget() | CXTPCmdTarget |
CXTPObservable() | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | protected
CXTPPaintManager() | CXTPPaintManager | protected
Draw3dRect(CDC *pDC, LPCRECT rc, int nTopLeft, int nBottomRight) | CXTPPaintManager |
Draw3dRect(CDC *pDC, LPCRECT rc, int frameThickness, COLORREF clrPen, COLORREF clrBrush) | CXTPPaintManager |
DrawCheckMark(CDC *pDC, CRect rcCheck, COLORREF clr=0) | CXTPPaintManager | inline
DrawComboExpandMark(CDC *pDC, CRect rc, COLORREF clr) | CXTPPaintManager | virtual
DrawCommandBarGripper(CDC *pDC, CXTPCommandBar *pBar, BOOL bDraw=TRUE) | CXTPPaintManager | virtual
DrawCommandBarGroupSeparator(CDC *pDC, CXTPCommandBar *pBar, CXTPControl *pLeftControl, CXTPControl *pRightControl, BOOL bDraw=TRUE) | CXTPPaintManager | virtual
DrawCommandBarSeparator(CDC *pDC, CXTPCommandBar *pBar, CXTPControl *pControl, BOOL bDraw=TRUE)=0 | CXTPPaintManager | pure virtual
DrawControl(CDC *pDC, CXTPControl *pButton, BOOL bDraw=TRUE) | CXTPPaintManager |
DrawControlCheckBoxMark(CDC *pDC, CRect rc, BOOL bDraw, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled) | CXTPPaintManager | virtual
DrawControlCheckBoxMark(CDC *pDC, CXTPControl *pButton, CRect rc, BOOL bDraw) | CXTPPaintManager | virtual
DrawControlComboBox(CDC *pDC, CXTPControlComboBox *pCombo, BOOL bDraw) | CXTPPaintManager | virtual
DrawControlEdit(CDC *pDC, CXTPControlEdit *pEdit, BOOL bDraw) | CXTPPaintManager | virtual
DrawControlEntry(CDC *pDC, CXTPControl *pButton) | CXTPPaintManager | virtual
DrawControlMDIButton(CDC *pDC, CXTPControlButton *pButton) | CXTPPaintManager | virtual
DrawControlPopupParent(CDC *pDC, CXTPControl *pButton, BOOL bDraw) | CXTPPaintManager | virtual
DrawControlRadioButtonMark(CDC *pDC, CRect rc, BOOL bDraw, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled) | CXTPPaintManager | virtual
DrawControlText(CDC *pDC, CXTPControl *pControl, CRect rcText, BOOL bDraw, BOOL bVert, BOOL bCentered, BOOL bTriangled) | CXTPPaintManager |
DrawControlToolBarParent(CDC *pDC, CXTPControl *pButton, BOOL bDraw) | CXTPPaintManager | virtual
DrawDialogBarGripper(CDC *pDC, CXTPDialogBar *pBar, BOOL bDraw)=0 | CXTPPaintManager | pure virtual
DrawDropDownGlyph(CDC *pDC, CXTPControl *pControl, CPoint pt, BOOL bSelected, BOOL bPopuped, BOOL bEnabled, BOOL bVert) | CXTPPaintManager | virtual
DrawExpandGlyph(CDC *pDC, CXTPControl *pButton, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clr) | CXTPPaintManager | virtual
DrawExpandGlyph(CDC *pDC, CXTPControl *pButton, COLORREF clr, BOOL bVertical) | CXTPPaintManager | virtual
DrawGalleryItemBack(CDC *pDC, CRect rcItem, BOOL bEnabled, BOOL bSelected, BOOL bPressed, BOOL bChecked, XTPBarType barType) | CXTPPaintManager | virtual
DrawHiddenGlyph(CDC *pDC, CXTPControl *pButton, COLORREF clr, BOOL bVertical) | CXTPPaintManager | virtual
DrawImage(CDC *pDC, CPoint pt, CSize sz, CXTPImageManagerIcon *pImage, BOOL bSelected, BOOL bPressed, BOOL bEnabled=TRUE, BOOL bChecked=FALSE, BOOL bPopuped=FALSE, BOOL bToolBarImage=TRUE)=0 | CXTPPaintManager | pure virtual
DrawListBoxControl(CDC *pDC, CXTPControl *pButton, CRect rc, BOOL bSelected, BOOL bDraw, CXTPCommandBars *pCommandBars=0)=0 | CXTPPaintManager | pure virtual
DrawPopupBarCheckMark(CDC *pDC, CRect rcCheck, BOOL bEnabled, COLORREF clr) | CXTPPaintManager | virtual
DrawPopupBarGripper(CDC *pDC, int xPos, int yPos, int cx, int cy, BOOL bExpanded=FALSE) | CXTPPaintManager | virtual
DrawPopupBarRadioMark(CDC *pDC, CRect rcCheck, BOOL bEnabled, COLORREF clr) | CXTPPaintManager | virtual
DrawPopupResizeGripper(CDC *pDC, CRect rcGripper, int nFlags)=0 | CXTPPaintManager | pure virtual
DrawRectangle(CDC *pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition)=0 | CXTPPaintManager | pure virtual
DrawRectangle(CDC *pDC, CXTPControl *pButton) | CXTPPaintManager | virtual
DrawSpecialControl(CDC *pDC, XTPSpecialControl controlType, CXTPControl *pButton, CXTPCommandBar *pBar, BOOL bDraw, LPVOID lpParam) | CXTPPaintManager | virtual
DrawSplitButtonFrame(CDC *pDC, CXTPControl *pButton, CRect rc)=0 | CXTPPaintManager | pure virtual
DrawTearOffGripper(CDC *pDC, CRect rcGripper, BOOL bSelected, BOOL bDraw)=0 | CXTPPaintManager | pure virtual
FillCommandBarEntry(CDC *pDC, CXTPCommandBar *pBar)=0 | CXTPPaintManager | pure virtual
FillDockBar(CDC *pDC, CXTPDockBar *pBar) | CXTPPaintManager | virtual
FillWorkspace(CDC *pDC, CRect rc, CRect rcExclude) | CXTPPaintManager | virtual
FontExists(LPCTSTR lpszFaceName) | CXTPPaintManager | static
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCommandBarBorders(CXTPCommandBar *pBar) | CXTPPaintManager | virtual
GetCommandBarFont(CXTPCommandBar *pCommandBar) | CXTPPaintManager | virtual
GetControlBackColor(CXTPControl *pButton) | CXTPPaintManager | virtual
GetControlEditBackColor(CXTPControl *pControl) | CXTPPaintManager | virtual
GetControlFont(CXTPControl *pControl) | CXTPPaintManager | virtual
GetControlHeight() const | CXTPPaintManager |
GetControlTextColor(CXTPControl *pButton) | CXTPPaintManager | virtual
GetControlTextOrientation(CXTPControl *pControl) | CXTPPaintManager | virtual
GetCurrentSystemTheme() | CXTPPaintManager |
GetCurrentTheme() | CXTPPaintManager | inline
GetDefaultCommandBarSize(CXTPCommandBar *pBar) | CXTPPaintManager | virtual
GetFramePaintManager() | CXTPPaintManager | virtual
GetGalleryPaintManager() const | CXTPPaintManager | virtual
GetGlobalPaintManager() | CXTPPaintManager | static
GetIconFont() | CXTPPaintManager |
GetIconsInfo() | CXTPPaintManager |
GetInstanceAddRef() | CXTPPaintManager | static
GetMessageBarPaintManager() | CXTPPaintManager | virtual
GetPopupBarGripperWidth(CXTPCommandBar *pBar) | CXTPPaintManager | virtual
GetProgressPaintManager() const | CXTPPaintManager | virtual
GetRectangleTextColor(BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition)=0 | CXTPPaintManager | pure virtual
GetRegularBoldFont() | CXTPPaintManager |
GetRegularFont() | CXTPPaintManager |
GetRibbonPaintManager() | CXTPPaintManager | virtual
GetScrollBarPaintManager() const | CXTPPaintManager | virtual
GetShadowManager() const | CXTPPaintManager |
GetShadowOptions() const | CXTPPaintManager |
GetSliderPaintManager() const | CXTPPaintManager | virtual
GetSmCaptionFont() | CXTPPaintManager |
GetSplitButtonCommandRect(CXTPControl *pButton) | CXTPPaintManager | virtual
GetStatusBarPaintManager() | CXTPPaintManager | virtual
GetXtremeColor(UINT nIndex) | CXTPPaintManager |
GradientFill(CDC *pDC, LPRECT lpRect, COLORREF crFrom, COLORREF crTo, BOOL bHorz, LPCRECT lpRectClip=NULL) | CXTPPaintManager |
HorizontalLine(CDC *pDC, int x0, int y0, int x1, COLORREF clrPen) | CXTPPaintManager |
IsUseSystemAccentColorEnabled() const | CXTPPaintManager |
Line(CDC *pDC, CPoint p0, CPoint p1) | CXTPPaintManager |
Line(CDC *pDC, int x0, int y0, int x1, int y1, const int nPen) | CXTPPaintManager |
Line(CDC *pDC, int x0, int y0, int x1, int y1, COLORREF clrPen) | CXTPPaintManager |
m_arrColor | CXTPPaintManager | protected
m_bAutoResizeIcons | CXTPPaintManager |
m_bClearTypeTextQuality | CXTPPaintManager |
m_bEmbossedDisabledText | CXTPPaintManager | protected
m_bEnableAnimation | CXTPPaintManager |
m_bFlatMenuBar | CXTPPaintManager |
m_bFlatToolBar | CXTPPaintManager |
m_bOffice2007Padding | CXTPPaintManager |
m_bOffsetPopupLabelText | CXTPPaintManager |
m_bSelectImageInPopupBar | CXTPPaintManager |
m_bShowKeyboardCues | CXTPPaintManager | protected
m_bShowShadow | CXTPPaintManager |
m_bThemedCheckBox | CXTPPaintManager |
m_bThemedStatusBar | CXTPPaintManager |
m_bThickCheckMark | CXTPPaintManager |
m_bUseOfficeFont | CXTPPaintManager |
m_bUseStandardFont | CXTPPaintManager | protected
m_bWrapCaptionBelowText | CXTPPaintManager |
m_clrDisabledIcon | CXTPPaintManager |
m_clrFloatingGripper | CXTPPaintManager |
m_clrFloatingGripperText | CXTPPaintManager |
m_clrMessageBarText | CXTPPaintManager |
m_fontIcon | CXTPPaintManager |
m_fontIconBold | CXTPPaintManager |
m_fontSmCaption | CXTPPaintManager |
m_fontToolTip | CXTPPaintManager |
m_iconsInfo | CXTPPaintManager | protected
m_nAnimationSteps | CXTPPaintManager | protected
m_nAnimationTime | CXTPPaintManager | protected
m_nEditHeight | CXTPPaintManager | protected
m_nFontHeight | CXTPPaintManager | protected
m_nPopupBarTextPadding | CXTPPaintManager |
m_nSplitButtonDropDownHeight | CXTPPaintManager |
m_nSplitButtonDropDownWidth | CXTPPaintManager |
m_nSplitButtonPopupWidth | CXTPPaintManager |
m_nStatusBarMinHeight | CXTPPaintManager |
m_nTextHeight | CXTPPaintManager |
m_pfnSetLayeredWindowAttributes | CXTPPaintManager |
m_pFramePaintManager | CXTPPaintManager |
m_pGalleryPaintManager | CXTPPaintManager |
m_pProgressPaintManager | CXTPPaintManager |
m_pRibbonPaintManager | CXTPPaintManager |
m_pScrollBarPaintManager | CXTPPaintManager |
m_pShadowManager | CXTPPaintManager | protected
m_pSliderPaintManager | CXTPPaintManager |
m_pStatusBarPaintManager | CXTPPaintManager |
m_rcMessageBarMargin | CXTPPaintManager |
m_rcStatusBarBorder | CXTPPaintManager |
m_strOfficeFont | CXTPPaintManager |
m_systemTheme | CXTPPaintManager | protected
m_themeButton | CXTPPaintManager | protected
m_themeCurrent | CXTPPaintManager | protected
m_themeStatusBar | CXTPPaintManager | protected
m_xtpFontRegular | CXTPPaintManager | protected
m_xtpFontRegularBold | CXTPPaintManager | protected
m_xtpFontVert | CXTPPaintManager | protected
m_xtpFontVertBold | CXTPPaintManager | protected
Notify(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *)) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
Notify(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1), A1 arg1) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
Notify(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
Notify(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamic(void(T::*method)(O *)) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1), A1 arg1) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *)) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1), A1 arg1) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyReversed(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *)) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyReversed(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1), A1 arg1) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyReversed(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyReversed(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
Pixel(CDC *pDC, int xPos, int yPos, int nPen) | CXTPPaintManager |
Rectangle(CDC *pDC, LPCRECT rc, int nPen, const int nBrush) | CXTPPaintManager |
Rectangle(CDC *pDC, LPCRECT rc, COLORREF clrPen, COLORREF clrBrush) | CXTPPaintManager |
RefreshMetrics() | CXTPPaintManager | virtual
ReleaseInstance() | CXTPPaintManager | static
RequiresResourceImages() | CXTPPaintManager | virtual
RoundRect(CDC *pDC, LPCRECT rc, COLORREF clrPen, COLORREF clrBrush) | CXTPPaintManager |
SetAnimationDelay(int nAnimationSteps, int nAnimationTime) | CXTPPaintManager |
SetColors(int cElements, CONST INT *lpaElements, CONST COLORREF *lpaRgbValues) | CXTPPaintManager |
SetCommandBarRegion(CXTPCommandBar *pCommandBar) | CXTPPaintManager | virtual
SetCommandBarsFontIndirect(LOGFONT *pLogFont, BOOL bUseStandardFont=FALSE) | CXTPPaintManager |
SetCustomTheme(CXTPPaintManager *pTheme) | CXTPPaintManager | static
SetGlobalPaintManager(CXTPPaintManager *pPaintManager) | CXTPPaintManager | static
SetImageHandle(HMODULE hResource, LPCTSTR lpszIniFileName) | CXTPPaintManager | virtual
SetLunaTheme(XTPCurrentSystemTheme systemTheme) | CXTPPaintManager |
SetTheme(XTPPaintTheme paintTheme) | CXTPPaintManager | static
StripMnemonics(CString &strClear) | CXTPPaintManager | static
Subscribe(IXTPPaintManagerEvents *pObserver, CXTPSubscriptionList< CXTPPaintManager, IXTPPaintManagerEvents > *pSubcriptionList=NULL) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > |
Triangle(CDC *pDC, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clr) | CXTPPaintManager | static
Unsubscribe(IXTPPaintManagerEvents *pObserver) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > |
UpdateColors() | CXTPPaintManager | virtual
UpdateFonts() | CXTPPaintManager | virtual
UpdateRTLCaption(CString &strCaption) | CXTPPaintManager | virtual
UseOfficeFont(bool bUseOfficeFont) | CXTPPaintManager |
VerticalLine(CDC *pDC, int x0, int y0, int y1, COLORREF clrPen) | CXTPPaintManager |
XTPPaintManager() | CXTPPaintManager | friend
~CXTPObservable() | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | protected
~CXTPPaintManager() | CXTPPaintManager | protectedvirtual


Toolkit Pro: Member List

CXTPCalendarTypedPtrAutoDeleteArray< BASE_CLASS, PTR_TYPE > Member List

This is the complete list of members for CXTPCalendarTypedPtrAutoDeleteArray< BASE_CLASS, PTR_TYPE >, including all inherited members.

CXTPCalendarTypedPtrAutoDeleteArray() | CXTPCalendarTypedPtrAutoDeleteArray< BASE_CLASS, PTR_TYPE > | inline
RemoveAll() | CXTPCalendarTypedPtrAutoDeleteArray< BASE_CLASS, PTR_TYPE > | inlinevirtual
TBase typedef | CXTPCalendarTypedPtrAutoDeleteArray< BASE_CLASS, PTR_TYPE > |
~CXTPCalendarTypedPtrAutoDeleteArray() | CXTPCalendarTypedPtrAutoDeleteArray< BASE_CLASS, PTR_TYPE > | inlinevirtual


Toolkit Pro: Member List

CXTPCalendarTypedPtrAutoDeleteMap< KEY, TPtr > Member List

This is the complete list of members for CXTPCalendarTypedPtrAutoDeleteMap< KEY, TPtr >, including all inherited members.

operator[](KEY key) | CXTPCalendarTypedPtrAutoDeleteMap< KEY, TPtr > | inline
RemoveAll(BOOL bDeletePtr=TRUE) | CXTPCalendarTypedPtrAutoDeleteMap< KEY, TPtr > | inlinevirtual
RemoveKey(KEY key, BOOL bDeletePtr=TRUE) | CXTPCalendarTypedPtrAutoDeleteMap< KEY, TPtr > | inlinevirtual
SetAt(KEY key, TPtr pValue, BOOL bDeletePrevPtr=TRUE) | CXTPCalendarTypedPtrAutoDeleteMap< KEY, TPtr > | inlinevirtual
~CXTPCalendarTypedPtrAutoDeleteMap() | CXTPCalendarTypedPtrAutoDeleteMap< KEY, TPtr > | inlinevirtual


Toolkit Pro: XTPStatusBarThemeVisualStudio2015.h Source File

  • Source
  • CommandBars
  • StatusBar
XTPStatusBarThemeVisualStudio2015.h
Go to the documentation of this file.
1
23#if !defined(__XTPXTPSTATUSBARTHEMEVISUALSTUDIO2015_H__)
24# define __XTPXTPSTATUSBARTHEMEVISUALSTUDIO2015_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPStatusBarThemeVisualStudio2015
39 : public CXTPStatusBarThemeOffice2013
40 , private IXTPApplicationEvents
41{
42public:
48 CXTPStatusBarThemeVisualStudio2015(CXTPPaintManager* pPaintManager);
49
54 ~CXTPStatusBarThemeVisualStudio2015();
55
62 virtual void DrawStatusBarGripper(CDC* pDC, CRect rcClient);
63
69 virtual void RefreshMetrics();
70
78 virtual void SetStateColor(COLORREF clrState);
79
86 virtual COLORREF GetStateColor() const;
87
88private:
89 virtual void OnAmbientPropertyChanged(CXTPApplication* pApplication,
90 XTPApplicationAmbientProperty nProperty);
91 void UpdateStateColor();
92
93 BOOL m_bAutomaticStateColor;
94};
95
97# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
98#endif // !defined(__XTPXTPSTATUSBARTHEMEVISUALSTUDIO2015_H__)
XTPApplicationAmbientProperty
XTPApplicationAmbientProperty
Global ambient property identifiers.
Definition XTPApplication.h:46
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPApplication
Defines a global XTP application object interface.
Definition XTPApplication.h:151
CXTPPaintManager
Paint manager of the command bars.
Definition XTPPaintManager.h:199
CXTPStatusBarThemeOffice2013
The CXTPStatusBarThemeVisualStudio2015 class is used to enable the Office 2013 style theme for the st...
Definition XTPStatusBarThemeOffice2013.h:39
CXTPStatusBarThemeVisualStudio2015
The CXTPStatusBarThemeVisualStudio2015 class is used to enable the Visual Studio 2015 style theme for...
Definition XTPStatusBarThemeVisualStudio2015.h:41
CXTPStatusBarThemeVisualStudio2015::DrawStatusBarGripper
virtual void DrawStatusBarGripper(CDC *pDC, CRect rcClient)
This method is called to draw the status bar's gripper.
CXTPStatusBarThemeVisualStudio2015::SetStateColor
virtual void SetStateColor(COLORREF clrState)
Call this member function to sets the application state color for the status bar.
CXTPStatusBarThemeVisualStudio2015::~CXTPStatusBarThemeVisualStudio2015
~CXTPStatusBarThemeVisualStudio2015()
Handles object destruction.
CXTPStatusBarThemeVisualStudio2015::CXTPStatusBarThemeVisualStudio2015
CXTPStatusBarThemeVisualStudio2015(CXTPPaintManager *pPaintManager)
Constructs a CXTPStatusBarThemeVisualStudio2015 object.
CXTPStatusBarThemeVisualStudio2015::RefreshMetrics
virtual void RefreshMetrics()
This method is called to refresh colors and other theme specific metrics for the paint manager.
CXTPStatusBarThemeVisualStudio2015::GetStateColor
virtual COLORREF GetStateColor() const
Call this member function to gets the application state color for the status bar.
IXTPApplicationEvents
Defines a callback interface for XTP application event sink.
Definition XTPApplication.h:82
IXTPApplicationEvents::OnAmbientPropertyChanged
virtual void OnAmbientPropertyChanged(CXTPApplication *pApplication, XTPApplicationAmbientProperty nProperty)
Called by framework when an ambient property is changed.
Definition XTPApplication.h:130


Toolkit Pro: XTPPreviewAbstract.h Source File

  • Source
  • Controls
  • Preview
XTPPreviewAbstract.h
Go to the documentation of this file.
1
23#if !defined(__XTPPREVIEWABSTRACT_H__)
24# define __XTPPREVIEWABSTRACT_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
39struct IXTPPreview
40{
45 virtual ~IXTPPreview()
46 {
47 }
48
56 virtual BOOL IsReady() const = 0;
57
65 virtual BOOL IsAvailable() const = 0;
66
76 virtual BOOL HasOwnNavigator() const = 0;
77
85 virtual UINT GetNumberOfPages() const = 0;
86
95 virtual SIZE GetPreferredPageSize() const = 0;
96
103 virtual void GoToPage(UINT page) = 0;
104
114 virtual void Draw(HDC dc, SIZE clientSize, RECT updateRect) = 0;
115
126 virtual BOOL OnHostWndMsg(LPMSG msg, LRESULT* result) = 0;
127
136 virtual BOOL SupportsCompositedParent() const = 0;
137
142 virtual void Activate() = 0;
143};
144
151struct IXTPPreviewHost
152{
157 virtual ~IXTPPreviewHost()
158 {
159 }
160
167 virtual COLORREF GetBackgroundColor() const = 0;
168
175 virtual COLORREF GetForegroundColor() const = 0;
176};
177
184struct IXTPPreviewProvider
185{
190 virtual ~IXTPPreviewProvider()
191 {
192 }
193
199 virtual void BindHost(IXTPPreviewHost& host) = 0;
200
212 virtual LPCTSTR GetDefaultFileAssociations() const = 0;
213
223 virtual IXTPPreview* CreatePreview(LPCTSTR pFilePath, HWND hwndParent) = 0;
224
237 virtual IXTPPreview* CreatePreview(IStream& stream, LPCTSTR pImpliedFileName,
238 HWND hwndParent) = 0;
239};
240
241class CXTPPreviewCtrl;
242
250class _XTP_EXT_CLASS CXTPPreviewProviderBase : public IXTPPreviewProvider
251{
252 friend class CXTPPreviewCtrl;
253
254protected:
259 CXTPPreviewProviderBase();
260
267 void BindHost(IXTPPreviewHost& host);
268
275 IXTPPreviewHost& GetHost() const;
276
277private:
278 mutable IXTPPreviewHost* m_pHost;
279};
281AFX_INLINE CXTPPreviewProviderBase::CXTPPreviewProviderBase()
282 : m_pHost(NULL)
283{
284}
285
286AFX_INLINE void CXTPPreviewProviderBase::BindHost(IXTPPreviewHost& host)
287{
288 m_pHost = &host;
289}
290
291AFX_INLINE IXTPPreviewHost& CXTPPreviewProviderBase::GetHost() const
292{
293 _ASSERTE(NULL != m_pHost);
294 return *m_pHost;
295}
297# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
299#endif // #if !defined(__XTPPREVIEWABSTRACT_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPPreviewCtrl
Implements the preview control that can display visual preview data provided by the best matching pre...
Definition XTPPreviewCtrl.h:42
CXTPPreviewProviderBase
Base class for a preview provider which implements common behavior to be exposed by a preview provide...
Definition XTPPreviewAbstract.h:251
CXTPPreviewProviderBase::CXTPPreviewProviderBase
CXTPPreviewProviderBase()
Handles object construction.
CXTPPreviewProviderBase::BindHost
void BindHost(IXTPPreviewHost &host)
The method is called by the host preview control when the provider is initially bound to the host.
CXTPPreviewProviderBase::GetHost
IXTPPreviewHost & GetHost() const
Obtains the preview host interface that the provider is bound to.
IXTPPreviewHost
Interface implemented by the preview host control.
Definition XTPPreviewAbstract.h:152
IXTPPreviewHost::~IXTPPreviewHost
virtual ~IXTPPreviewHost()
Handles object destruction.
Definition XTPPreviewAbstract.h:157
IXTPPreviewHost::GetBackgroundColor
virtual COLORREF GetBackgroundColor() const =0
Obtains the background color used by the host control.
IXTPPreviewHost::GetForegroundColor
virtual COLORREF GetForegroundColor() const =0
Obtains the foreground color used by the host control.
IXTPPreview
The base interface for a preview handler implementation.
Definition XTPPreviewAbstract.h:40
IXTPPreview::GetNumberOfPages
virtual UINT GetNumberOfPages() const =0
Retrieves the number of pages available for the common page navigator.
IXTPPreview::~IXTPPreview
virtual ~IXTPPreview()
Handles object destruction.
Definition XTPPreviewAbstract.h:45
IXTPPreview::Draw
virtual void Draw(HDC dc, SIZE clientSize, RECT updateRect)=0
This method is called every time the preview has to draw itself into the available client area.
IXTPPreview::GoToPage
virtual void GoToPage(UINT page)=0
If pages are supported by the preview, then it should cause navigation to the specified page number.
IXTPPreview::OnHostWndMsg
virtual BOOL OnHostWndMsg(LPMSG msg, LRESULT *result)=0
Handles a window message sent to the host preview control.
IXTPPreview::GetPreferredPageSize
virtual SIZE GetPreferredPageSize() const =0
Obtains the preferred page size in pixels if that is required by the preview.
IXTPPreview::SupportsCompositedParent
virtual BOOL SupportsCompositedParent() const =0
Determines if the preview implementation is compatible with composited top level windows (i....
IXTPPreview::IsAvailable
virtual BOOL IsAvailable() const =0
Determines if the preview is available (i.e.
IXTPPreview::IsReady
virtual BOOL IsReady() const =0
Returns TRUE if the handler has attempted and finished loading the preview regardless of the actual l...
IXTPPreview::HasOwnNavigator
virtual BOOL HasOwnNavigator() const =0
Determines if the handler implements its own page navigator.
IXTPPreview::Activate
virtual void Activate()=0
Activate preview.
IXTPPreviewProvider
Interface to be implemented by a preview provider.
Definition XTPPreviewAbstract.h:185
IXTPPreviewProvider::CreatePreview
virtual IXTPPreview * CreatePreview(IStream &stream, LPCTSTR pImpliedFileName, HWND hwndParent)=0
Creates a preview object for the specified file.
IXTPPreviewProvider::~IXTPPreviewProvider
virtual ~IXTPPreviewProvider()
Handles object destruction.
Definition XTPPreviewAbstract.h:190
IXTPPreviewProvider::GetDefaultFileAssociations
virtual LPCTSTR GetDefaultFileAssociations() const =0
Obtains the list of file extensions supported by the associated preview implementation.
IXTPPreviewProvider::BindHost
virtual void BindHost(IXTPPreviewHost &host)=0
This method is called by the host control when it first binds the provider.
IXTPPreviewProvider::CreatePreview
virtual IXTPPreview * CreatePreview(LPCTSTR pFilePath, HWND hwndParent)=0
Creates a preview object for the specified file.


Toolkit Pro: XTPPropertyGridItemBool.h Source File

  • Source
  • PropertyGrid
XTPPropertyGridItemBool.h
Go to the documentation of this file.
1
23#if !defined(__XTPPROPERTYGRIDITEMBOOL_H__)
24# define __XTPPROPERTYGRIDITEMBOOL_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPPropertyGridItemBool : public CXTPPropertyGridItem
39{
40public:
76 CXTPPropertyGridItemBool(LPCTSTR strCaption, BOOL bValue = FALSE, BOOL* pBindBool = NULL);
77
113 CXTPPropertyGridItemBool(UINT nID, BOOL bValue = FALSE, BOOL* pBindBool = NULL);
114
119 virtual ~CXTPPropertyGridItemBool();
120
126 virtual void SetBool(BOOL bValue);
127
135 virtual BOOL GetBool() const;
136
160 virtual void BindToBool(BOOL* pBindBool);
161
173 BOOL SetTrueFalseText(LPCTSTR strTrueText, LPCTSTR strFalseText);
174
175public:
183 void SetCheckBoxStyle(BOOL bCheckBoxStyle = TRUE);
184
193 BOOL IsCheckBoxStyle() const;
194
195protected:
203 virtual void SetValue(CString strValue);
204
219 BOOL SetValueText(CString& strValueText, LPCTSTR strNewText);
220
234 virtual void OnBeforeInsert();
235
236protected:
247 virtual BOOL OnDrawItemValue(CDC& dc, CRect rcValue);
248
261 virtual CString GetViewValue();
262
273 virtual BOOL OnLButtonDown(UINT nFlags, CPoint point);
274
289 virtual BOOL OnKeyDown(UINT nChar);
290
299 virtual void OnLButtonDblClk(UINT nFlags, CPoint point);
300
311 BOOL PtInCheckBoxRect(CPoint point);
312
313private:
314 void _Init(BOOL bValue);
315
316protected:
317 BOOL m_bValue;
318 BOOL* m_pBindBool;
319 CString m_strTrueText;
320 CString m_strFalseText;
321 BOOL m_bCheckBoxStyle;
323private:
324 DECLARE_DYNAMIC(CXTPPropertyGridItemBool)
325
326# ifdef _XTP_ACTIVEX
328 afx_msg void OleSetValue(const VARIANT* varValue);
329 afx_msg const VARIANT OleGetValue();
330
331 DECLARE_DISPATCH_MAP()
332 DECLARE_INTERFACE_MAP()
333
334 DECLARE_OLETYPELIB_EX(CXTPPropertyGridItemDouble)
335
336 void BindDispatch();
338# endif
339};
340
379class _XTP_EXT_CLASS CXTPPropertyGridItemEnum : public CXTPPropertyGridItem
380{
381public:
418 CXTPPropertyGridItemEnum(LPCTSTR strCaption, int nValue = 0, int* pBindEnum = NULL);
419
456 CXTPPropertyGridItemEnum(UINT nID, int nValue = 0, int* pBindEnum = NULL);
457
462 virtual ~CXTPPropertyGridItemEnum();
463
473 virtual void SetEnum(int nValue);
474
483 virtual void SetEnum(CXTPPropertyGridItemConstraint* pConstraint);
484
494 virtual int GetEnum() const;
495
519 virtual void BindToEnum(int* pBindEnum);
520
521protected:
529 virtual void SetValue(CString strValue);
530
544 virtual void OnBeforeInsert();
545
553 virtual void OnConstraintsChanged();
554
555private:
556 void _Init(int nValue);
557
558protected:
559 int m_nValue;
561 int* m_pBindEnum;
563private:
564 DECLARE_DYNAMIC(CXTPPropertyGridItemEnum)
565
566# ifdef _XTP_ACTIVEX
568 afx_msg void OleSetValue(const VARIANT* varValue);
569 afx_msg const VARIANT OleGetValue();
570
571 void BindDispatch();
573# endif
574};
575
577
578AFX_INLINE BOOL CXTPPropertyGridItemBool::GetBool() const
579{
580 return m_bValue;
581}
582AFX_INLINE int CXTPPropertyGridItemEnum::GetEnum() const
583{
584 return m_nValue;
585}
587# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
588#endif // #if !defined(__XTPPROPERTYGRIDITEMBOOL_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPPropertyGridItemBool
CXTPPropertyGridItemBool is a CXTPPropertyGridItem derived class.
Definition XTPPropertyGridItemBool.h:39
CXTPPropertyGridItemBool::OnKeyDown
virtual BOOL OnKeyDown(UINT nChar)
This method is called when the user presses a key.
CXTPPropertyGridItemBool::OnLButtonDown
virtual BOOL OnLButtonDown(UINT nFlags, CPoint point)
This method is called when the user presses the left mouse button on the item.
CXTPPropertyGridItemBool::OnBeforeInsert
virtual void OnBeforeInsert()
This method is called before the item becomes visible in the property grid.
CXTPPropertyGridItemBool::PtInCheckBoxRect
BOOL PtInCheckBoxRect(CPoint point)
Determines if a specified point is inside the checkbox displayed if the item has a checkbox style.
CXTPPropertyGridItemBool::BindToBool
virtual void BindToBool(BOOL *pBindBool)
Binds the item to a specified BOOL value.
CXTPPropertyGridItemBool::OnLButtonDblClk
virtual void OnLButtonDblClk(UINT nFlags, CPoint point)
This method is called when the user double-clicks the left mouse button on the item.
CXTPPropertyGridItemBool::OnDrawItemValue
virtual BOOL OnDrawItemValue(CDC &dc, CRect rcValue)
This method is called when an item is drawn.
CXTPPropertyGridItemBool::CXTPPropertyGridItemBool
CXTPPropertyGridItemBool(LPCTSTR strCaption, BOOL bValue=FALSE, BOOL *pBindBool=NULL)
Constructs a CXTPPropertyGridItemBool object.
CXTPPropertyGridItemBool::SetValue
virtual void SetValue(CString strValue)
Sets the value of the item.
CXTPPropertyGridItemBool::m_bValue
BOOL m_bValue
Value of the item.
Definition XTPPropertyGridItemBool.h:317
CXTPPropertyGridItemBool::IsCheckBoxStyle
BOOL IsCheckBoxStyle() const
Determines if the item is drawn as a check box frame.
CXTPPropertyGridItemBool::CXTPPropertyGridItemBool
CXTPPropertyGridItemBool(UINT nID, BOOL bValue=FALSE, BOOL *pBindBool=NULL)
Constructs a CXTPPropertyGridItemBool object.
CXTPPropertyGridItemBool::m_bCheckBoxStyle
BOOL m_bCheckBoxStyle
Checkbox style.
Definition XTPPropertyGridItemBool.h:321
CXTPPropertyGridItemBool::m_pBindBool
BOOL * m_pBindBool
Pointer to the variable bound to this item.
Definition XTPPropertyGridItemBool.h:318
CXTPPropertyGridItemBool::m_strTrueText
CString m_strTrueText
Text of the TRUE label.
Definition XTPPropertyGridItemBool.h:319
CXTPPropertyGridItemBool::GetViewValue
virtual CString GetViewValue()
Gets the value of the item that the user is currently viewing.
CXTPPropertyGridItemBool::SetCheckBoxStyle
void SetCheckBoxStyle(BOOL bCheckBoxStyle=TRUE)
Specifies if the item should be drawn as a check box frame.
CXTPPropertyGridItemBool::SetBool
virtual void SetBool(BOOL bValue)
Sets the BOOL value for the item.
CXTPPropertyGridItemBool::m_strFalseText
CString m_strFalseText
Text of the FALSE label.
Definition XTPPropertyGridItemBool.h:320
CXTPPropertyGridItemBool::SetValueText
BOOL SetValueText(CString &strValueText, LPCTSTR strNewText)
Searches the drop list for labels with the value specified by strValueText and updates them with the ...
CXTPPropertyGridItemBool::SetTrueFalseText
BOOL SetTrueFalseText(LPCTSTR strTrueText, LPCTSTR strFalseText)
Sets the values for the TRUE and FALSE labels in the drop list.
CXTPPropertyGridItemBool::~CXTPPropertyGridItemBool
virtual ~CXTPPropertyGridItemBool()
Destroys a CXTPPropertyGridItemBool object.
CXTPPropertyGridItemBool::GetBool
virtual BOOL GetBool() const
Gets the BOOL value of the item.
Definition XTPPropertyGridItemBool.h:578
CXTPPropertyGridItemConstraint
CXTPPropertyGridItemConstraint is a CXTPCmdTarget derived class.
Definition XTPPropertyGridItem.h:271
CXTPPropertyGridItemDouble
CXTPPropertyGridItemDouble is a CXTPPropertyGridItem derived class.
Definition XTPPropertyGridItemNumber.h:209
CXTPPropertyGridItemEnum
CXTPPropertyGridItemEnum is a CXTPPropertyGridItem derived class.
Definition XTPPropertyGridItemBool.h:380
CXTPPropertyGridItemEnum::SetEnum
virtual void SetEnum(int nValue)
The first method sets the value for the item.
CXTPPropertyGridItemEnum::OnConstraintsChanged
virtual void OnConstraintsChanged()
This method is called when constraints are added to the item (i.e.
CXTPPropertyGridItemEnum::OnBeforeInsert
virtual void OnBeforeInsert()
This method is called before the item becomes visible in the property grid.
CXTPPropertyGridItemEnum::m_nValue
int m_nValue
Value of the item.
Definition XTPPropertyGridItemBool.h:559
CXTPPropertyGridItemEnum::GetEnum
virtual int GetEnum() const
Gets the value of the item.
Definition XTPPropertyGridItemBool.h:582
CXTPPropertyGridItemEnum::SetValue
virtual void SetValue(CString strValue)
Sets the value of the item.
CXTPPropertyGridItemEnum::BindToEnum
virtual void BindToEnum(int *pBindEnum)
Binds the item to a specified integer value.
CXTPPropertyGridItemEnum::~CXTPPropertyGridItemEnum
virtual ~CXTPPropertyGridItemEnum()
Destroys a CXTPPropertyGridItemEnum object.
CXTPPropertyGridItemEnum::m_pBindEnum
int * m_pBindEnum
Pointer to the variable bound to this item.
Definition XTPPropertyGridItemBool.h:561
CXTPPropertyGridItemEnum::SetEnum
virtual void SetEnum(CXTPPropertyGridItemConstraint *pConstraint)
The first method sets the value for the item.
CXTPPropertyGridItemEnum::CXTPPropertyGridItemEnum
CXTPPropertyGridItemEnum(UINT nID, int nValue=0, int *pBindEnum=NULL)
Constructs a CXTPPropertyGridItemEnum object.
CXTPPropertyGridItemEnum::CXTPPropertyGridItemEnum
CXTPPropertyGridItemEnum(LPCTSTR strCaption, int nValue=0, int *pBindEnum=NULL)
Constructs a CXTPPropertyGridItemEnum object.
CXTPPropertyGridItem
CXTPPropertyGridItem is the base class representing an item of the Property Grid control.
Definition XTPPropertyGridItem.h:523


Toolkit Pro: Member List

CXTPColorSetStateMenuTitleBar Member List

This is the complete list of members for CXTPColorSetStateMenuTitleBar, including all inherited members.

clrBack | CXTPColorSetStateButton |
clrBackChecked | CXTPColorSetStateButton |
clrBackCheckedHighlight | CXTPColorSetStateButton |
clrBackDisabled | CXTPColorSetStateButton |
clrBackHighlight | CXTPColorSetStateButton |
clrBackPushed | CXTPColorSetStateButton |
clrBorder | CXTPColorSetStateButton |
clrBorderChecked | CXTPColorSetStateButton |
clrBorderCheckedHighlight | CXTPColorSetStateButton |
clrBorderDisabled | CXTPColorSetStateButton |
clrBorderHighlight | CXTPColorSetStateButton |
clrBorderPushed | CXTPColorSetStateButton |
clrText | CXTPColorSetStateButton |
clrTextChecked | CXTPColorSetStateButton |
clrTextCheckedHighlight | CXTPColorSetStateButton |
clrTextDisabled | CXTPColorSetStateButton |
clrTextHighlight | CXTPColorSetStateButton |
clrTextPushed | CXTPColorSetStateButton |
CXTPCmdTarget() | CXTPCmdTarget |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
RefreshColors()=0 | CXTPColorSetStateButton | pure virtual


Toolkit Pro: Member List

CXTPPropertyGridNativeWindows11Theme Member List

This is the complete list of members for CXTPPropertyGridNativeWindows11Theme, including all inherited members.

AdjustItemCaptionRect(CXTPPropertyGridItem *pItem, CRect &rcCaption) | CXTPPropertyGridPaintManager | virtual
AdjustItemValueRect(CXTPPropertyGridItem *pItem, CRect &rcValue) | CXTPPropertyGridPaintManager | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPPropertyGridNativeWindows11Theme(CXTPPropertyGrid *pGrid) | CXTPPropertyGridNativeWindows11Theme |
CXTPPropertyGridPaintManager(CXTPPropertyGrid *pGrid) | CXTPPropertyGridPaintManager |
CXTPPropertyGridVisualStudio2010Theme(CXTPPropertyGrid *pGrid) | CXTPPropertyGridVisualStudio2010Theme |
DrawCategoryCaptionBackground(CDC *pDC, CXTPPropertyGridItem *pItem, CRect rc) | CXTPPropertyGridPaintManager | virtual
DrawCheckBox(CDC *pDC, CXTPPropertyGridItemBool *pButton) | CXTPPropertyGridPaintManager | virtual
DrawCheckMark(CDC *pDC, CRect rc, BOOL bEnabled, BOOL bChecked) | CXTPPropertyGridPaintManager | virtual
DrawExpandButton(CDC &dc, CXTPPropertyGridItem *pItem, CRect rcCaption) | CXTPPropertyGridNativeWindows11Theme | virtual
DrawInplaceButtons(CDC *pDC, PDRAWITEMSTRUCT lpDrawItemStruct, CXTPPropertyGridItem *pItem, CRect rcValue) | CXTPPropertyGridPaintManager | virtual
DrawInplaceListItem(CDC *pDC, CXTPPropertyGridItemConstraint *pConstraint, CRect rc, BOOL bSelected) | CXTPPropertyGridPaintManager | virtual
DrawItem(PDRAWITEMSTRUCT lpDrawItemStruct) | CXTPPropertyGridPaintManager | virtual
DrawItemCaption(CDC *pDC, CXTPPropertyGridItem *pItem, CRect rcCaption) | CXTPPropertyGridPaintManager | virtual
DrawItemValue(CDC *pDC, CXTPPropertyGridItem *pItem, CRect rcValue) | CXTPPropertyGridPaintManager | virtual
DrawPropertyGridBorder(CDC *pDC, RECT &rcBorder, XTPPropertyGridWindow nWindow) | CXTPPropertyGridPaintManager | virtual
DrawRadioMark(CDC *pDC, CRect rc, BOOL bEnabled, BOOL bChecked) | CXTPPropertyGridPaintManager | virtual
FillInplaceButton(CDC *pDC, CXTPPropertyGridInplaceButton *pButton) | CXTPPropertyGridPaintManager | virtual
FillPropertyGrid(CDC *pDC) | CXTPPropertyGridPaintManager | virtual
FillPropertyGridView(CDC *pDC) | CXTPPropertyGridPaintManager | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetItemBackColor(CXTPPropertyGridItem *pItem, BOOL bValuePart) | CXTPPropertyGridPaintManager | virtual
GetItemFont(CXTPPropertyGridItem *pItem, BOOL bValuePart) | CXTPPropertyGridPaintManager | virtual
GetItemMetrics() const | CXTPPropertyGridPaintManager |
GetItemsBorderHeight() const | CXTPPropertyGridPaintManager | virtual
GetItemTextColor(CXTPPropertyGridItem *pItem, BOOL bValuePart) | CXTPPropertyGridPaintManager | virtual
GetScrollBarTheme() const | CXTPPropertyGridNativeWindows11Theme | virtual
GetSplitterRect(CRect rc, BOOL bIsHelp) | CXTPPropertyGridPaintManager |
HitTestVerbs(CDC *pDC, CRect rcVerbs, CPoint pt) | CXTPPropertyGridPaintManager |
m_bThinSplitter | CXTPPropertyGridPaintManager | protected
m_bTransparent | CXTPPropertyGridPaintManager |
m_buttonsStyle | CXTPPropertyGridPaintManager |
m_clrCategorySeparator | CXTPPropertyGridPaintManager |
m_clrFace | CXTPPropertyGridPaintManager |
m_clrHighlight | CXTPPropertyGridPaintManager |
m_clrHighlightText | CXTPPropertyGridPaintManager |
m_clrNonHighlightBack | CXTPPropertyGridPaintManager |
m_clrNonHighlightText | CXTPPropertyGridPaintManager |
m_clrShadow | CXTPPropertyGridPaintManager |
m_clrSplitter | CXTPPropertyGridPaintManager |
m_nHelpHeight | CXTPPropertyGridPaintManager | protected
m_nItemsBorderHeight | CXTPPropertyGridPaintManager | protected
m_nSplitterHeight | CXTPPropertyGridPaintManager | protected
m_nVerbsHeight | CXTPPropertyGridPaintManager | protected
m_pGrid | CXTPPropertyGridPaintManager | protected
m_pMetrics | CXTPPropertyGridPaintManager | protected
m_themeButton | CXTPPropertyGridPaintManager |
m_themeCombo | CXTPPropertyGridPaintManager |
m_themeTree | CXTPPropertyGridPaintManager |
MeasureItem(LPMEASUREITEMSTRUCT lpMeasureItemStruct) | CXTPPropertyGridPaintManager | virtual
OnNcCalcSize(RECT &rc) | CXTPPropertyGridPaintManager | virtual
RefreshMetrics() | CXTPPropertyGridNativeWindows11Theme | virtual
SetItemsBorderHeight(int nHeight) | CXTPPropertyGridPaintManager | virtual
SetThinSplitter(BOOL bThinSplitter) | CXTPPropertyGridPaintManager | virtual
~CXTPPropertyGridPaintManager() | CXTPPropertyGridPaintManager | virtual
~CXTPPropertyGridVisualStudio2010Theme() | CXTPPropertyGridVisualStudio2010Theme |


Toolkit Pro: XTPFrameThemeNativeWindows10.h Source File

  • Source
  • CommandBars
  • Frame
XTPFrameThemeNativeWindows10.h
Go to the documentation of this file.
1
23#if !defined(__XTPFRAMETHEMENATIVEWINDOWS10_H__)
24# define __XTPFRAMETHEMENATIVEWINDOWS10_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPPaintManager;
34class CXTPCommandBarsFrameHook;
35class CXTPRibbonBar;
36
37class _XTP_EXT_CLASS CXTPFrameThemeNativeWindows10
38 : public CXTPFrameThemeOffice2013
39 , public IXTPApplicationEvents
40 , private IXTPPaintManagerCustomAccentColorProvider
41{
42public:
43 CXTPFrameThemeNativeWindows10(CXTPPaintManager* pPaintManager);
44
45 virtual ~CXTPFrameThemeNativeWindows10();
46
47public:
52 virtual void RefreshMetrics();
53
65 virtual void DrawFrameCaptionButton(CDC* pDC, CRect rc, int nId, BOOL bSelected, BOOL bPressed,
66 BOOL bActive);
67
80 virtual void DrawFrameCaptionButton(CDC* pDC, CRect rc, int nId, BOOL bSelected, BOOL bPressed,
81 BOOL bActive, CXTPRibbonBar* pRibbonBar);
82
91 virtual void SetStateColor(COLORREF clrState);
92
101 virtual COLORREF GetStateColor() const;
102
103 virtual CXTPFrameShadow* CreateShadow(CWnd* pFrame);
104
105 virtual void OnShadowedFrameActiveStateChanged(BOOL bActive, CWnd* pFrame,
106 CXTPFrameShadow* pShadow);
107
115 virtual void LoadParts(HZIP hZip, CXTPMarkupContext* pMarkupContext);
116
123 virtual void LoadParts(BOOL bReload = FALSE);
124
125private:
126 void UpdateAccentColors();
127
128 virtual void OnAmbientPropertyChanged(CXTPApplication* pApplication,
129 XTPApplicationAmbientProperty nProperty);
130
131private:
132 // IXTPPaintManagerCustomAccentColorProvider overrides
133
134 virtual COLORREF GetCustomAccentColor(XTPPaintManagerAccentColor nColor);
135
136protected:
137 COLORREF m_clrShadowColorActive;
138 COLORREF m_clrShadowColorInactive;
139
140 CXTPModernUIFrameCaptionButton* m_pButtonRestoreActive;
141 CXTPModernUIFrameCaptionButton* m_pButtonRestoreInactive;
142 CXTPModernUIFrameCaptionButton* m_pButtonRestorePressed;
143 CXTPModernUIFrameCaptionButton* m_pButtonRestoreHot;
144};
146# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
147#endif // !defined(__XTPFRAMETHEMENATIVEWINDOWS10_H__)
XTPApplicationAmbientProperty
XTPApplicationAmbientProperty
Global ambient property identifiers.
Definition XTPApplication.h:46
XTPPaintManagerAccentColor
XTPPaintManagerAccentColor
Defines a set of accent related colors.
Definition XTPColorManager.h:900
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPApplication
Defines a global XTP application object interface.
Definition XTPApplication.h:151
CXTPCommandBarsFrameHook
CXTPCommandBarsFrameHook is a CXTPHookManagerHookAble derived class.
Definition XTPFrameHook.h:56
CXTPFramePaintManager::OnShadowedFrameActiveStateChanged
virtual void OnShadowedFrameActiveStateChanged(BOOL bActive, CWnd *pFrame, CXTPFrameShadow *pShadow)
An implementation can override this method in order to change frame appearance when a window gets act...
CXTPFrameShadow
The class represents frame shadow object.
Definition XTPFrameShadow.h:47
CXTPMarkupContext
CXTPMarkupContext is a standalone class used to provide common settings for Markup objects.
Definition XTPMarkupContext.h:128
CXTPPaintManager
Paint manager of the command bars.
Definition XTPPaintManager.h:199
CXTPRibbonBar
CXTPRibbonBar is a CXTPMenuBar derived class.
Definition XTPRibbonBar.h:69
IXTPApplicationEvents
Defines a callback interface for XTP application event sink.
Definition XTPApplication.h:82
IXTPApplicationEvents::OnAmbientPropertyChanged
virtual void OnAmbientPropertyChanged(CXTPApplication *pApplication, XTPApplicationAmbientProperty nProperty)
Called by framework when an ambient property is changed.
Definition XTPApplication.h:130


Toolkit Pro: Member List

CXTPDockingPaneTabTheme2019 Member List

This is the complete list of members for CXTPDockingPaneTabTheme2019, including all inherited members.

AdjustClientRect(CXTPTabManager *pTabManager, CRect &rcClient) | CXTPTabPaintManagerTheme | virtual
CXTPDockingPaneTabTheme2012() | CXTPDockingPaneTabTheme2012 |
CXTPDockingPaneTabTheme2019() | CXTPDockingPaneTabTheme2019 |
CXTPTabPaintManagerTheme() | CXTPTabPaintManagerTheme |
CXTPTabThemeFlat() | CXTPTabThemeFlat | inline
DrawSingleButton(CDC *pDC, CXTPTabManagerItem *pItem) | CXTPDockingPaneTabTheme2019 | virtual
DrawTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl) | CXTPTabPaintManagerTheme | virtual
DrawText(CDC *pDC, CXTPTabManager *pManager, const CString &str, LPRECT lpRect, UINT nFormat) | CXTPDockingPaneTabTheme2012 | virtual
DrawWorkspacePart(CDC *pDC, LPRECT lpRect, XTPTabWorkspacePart workspacePart) | CXTPTabPaintManagerTheme | virtual
FillButton(CDC *pDC, CXTPTabManagerItem *pItem, LPPOINT pts, int nCount, XTPTabPosition tabPosition, BOOL bAbsolute=FALSE) | CXTPTabPaintManagerTheme |
FillTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl) | CXTPTabThemeFlat | virtual
GetButtonDrawRect(const CXTPTabManagerItem *pItem) | CXTPTabPaintManagerTheme | virtual
GetButtonHeight(const CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetButtonLength(CDC *pDC, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerTheme | virtual
GetClientMargin() | CXTPTabPaintManagerTheme | virtual
GetClientRect(CRect rcControl, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetColorSet() const | CXTPTabPaintManagerTheme |
GetDefaultColorSet() | CXTPTabThemeFlat | inlinevirtual
GetHeaderClipBox(CDC *pDC, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetHeaderHeight(CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme |
GetHeaderMargin() | CXTPTabPaintManagerTheme | virtual
GetHeaderRect(CRect rcControl, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetSupportedColorSets() | CXTPTabPaintManagerTheme | inlinevirtual
m_bButtonsReverseZOrder | CXTPTabPaintManagerTheme | protected
m_nButtonHeight | CXTPTabPaintManagerTheme | protected
m_nRowMargin | CXTPTabPaintManagerTheme |
m_pPaintManager | CXTPTabPaintManagerTheme | protected
m_rcHeaderMargin | CXTPTabPaintManagerTheme |
RefreshMetrics() | CXTPDockingPaneTabTheme2012 | virtual
RepositionTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcClient) | CXTPTabPaintManagerTheme | virtual
~CXTPTabPaintManagerTheme() | CXTPTabPaintManagerTheme | virtual


Toolkit Pro: Member List

CXTPTabThemeVisualStudio2017 Member List

This is the complete list of members for CXTPTabThemeVisualStudio2017, including all inherited members.

AdjustClientRect(CXTPTabManager *pTabManager, CRect &rcClient) | CXTPTabPaintManagerTheme | virtual
CXTPTabPaintManagerTheme() | CXTPTabPaintManagerTheme |
CXTPTabThemeFlat() | CXTPTabThemeFlat | inline
CXTPTabThemeVisualStudio2015() | CXTPTabThemeVisualStudio2015 |
CXTPTabThemeVisualStudio2017() | CXTPTabThemeVisualStudio2017 |
DrawSingleButton(CDC *pDC, CXTPTabManagerItem *pItem) | CXTPTabThemeVisualStudio2012 | virtual
DrawTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl) | CXTPTabPaintManagerTheme | virtual
DrawText(CDC *pDC, CXTPTabManager *pManager, const CString &str, LPRECT lpRect, UINT nFormat) | CXTPTabPaintManagerTheme | virtual
DrawWorkspacePart(CDC *pDC, LPRECT lpRect, XTPTabWorkspacePart workspacePart) | CXTPTabThemeVisualStudio2012 | virtual
FillButton(CDC *pDC, CXTPTabManagerItem *pItem, LPPOINT pts, int nCount, XTPTabPosition tabPosition, BOOL bAbsolute=FALSE) | CXTPTabPaintManagerTheme |
FillTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl) | CXTPTabThemeFlat | virtual
GetButtonDrawRect(const CXTPTabManagerItem *pItem) | CXTPTabPaintManagerTheme | virtual
GetButtonHeight(const CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetButtonLength(CDC *pDC, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerTheme | virtual
GetClientMargin() | CXTPTabPaintManagerTheme | virtual
GetClientRect(CRect rcControl, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetColorSet() const | CXTPTabPaintManagerTheme |
GetDefaultColorSet() | CXTPTabThemeVisualStudio2017 | inlinevirtual
GetHeaderClipBox(CDC *pDC, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetHeaderHeight(CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme |
GetHeaderMargin() | CXTPTabPaintManagerTheme | virtual
GetHeaderRect(CRect rcControl, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetSupportedColorSets() | CXTPTabPaintManagerTheme | inlinevirtual
m_bButtonsReverseZOrder | CXTPTabPaintManagerTheme | protected
m_nButtonHeight | CXTPTabPaintManagerTheme | protected
m_nRowMargin | CXTPTabPaintManagerTheme |
m_pPaintManager | CXTPTabPaintManagerTheme | protected
m_rcHeaderMargin | CXTPTabPaintManagerTheme |
RefreshMetrics() | CXTPTabThemeVisualStudio2017 | virtual
RepositionTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcClient) | CXTPTabPaintManagerTheme | virtual
~CXTPTabPaintManagerTheme() | CXTPTabPaintManagerTheme | virtual


Toolkit Pro: Member List

CXTPChartPyramidDiagramView Member List

This is the complete list of members for CXTPChartPyramidDiagramView, including all inherited members.

AddChildView(CXTPChartElementView *pChildView) | CXTPChartElementView |
CalculateView(CXTPChartDeviceContext *pDC, CRect rcBounds) | CXTPChartDiagramView | virtual
CreateDeviceCommand(CXTPChartDeviceContext *pDC) | CXTPChartDiagramView | protectedvirtual
CreateView(CXTPChartDeviceContext *pDC) | CXTPChartDiagramView | virtual
CXTPChartDiagramView(CXTPChartDiagram *pDiagram, CXTPChartElementView *pParentView) | CXTPChartDiagramView |
CXTPChartElementView(CXTPChartElementView *pParentView) | CXTPChartElementView |
CXTPChartElementView(CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartElementView |
CXTPChartElementView(CXTPChartContainer *pContainer) | CXTPChartElementView |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartPyramidDiagramView(CXTPChartDiagram *pDiagram, CXTPChartElementView *pParent) | CXTPChartPyramidDiagramView |
GetAt(int nIndex) const | CXTPChartElementView |
GetBounds() const | CXTPChartDiagramView |
CXTPChartElementView::GetBounds(BOOL bIncludingChildren) const | CXTPChartElementView |
GetChildren() | CXTPChartElementView |
GetCount() const | CXTPChartElementView |
GetDiagram() const | CXTPChartDiagramView |
GetLabelsView() const | CXTPChartDiagramView |
GetParentView() const | CXTPChartElementView |
GetSeriesView() const | CXTPChartDiagramView |
Is3D() const | CXTPChartObject |
m_arrChildren | CXTPChartElementView | protected
m_pContainer | CXTPChartElementView | protected
m_pDiagram | CXTPChartDiagramView | protected
m_pLabelsView | CXTPChartDiagramView | protected
m_pParentView | CXTPChartElementView | protected
m_pSeriesView | CXTPChartDiagramView | protected
m_pTitlesView | CXTPChartDiagramView | protected
m_rcBounds | CXTPChartDiagramView | protected
OnMouseWheel(UINT nFlags, short zDelta, CPoint pt) | CXTPChartDiagramView | virtual
UpdateRange(CXTPChartDeviceContext *pDC) | CXTPChartDiagramView | virtual
~CXTPChartElementView() | CXTPChartElementView | protectedvirtual


Toolkit Pro: Member List

CXTPHeaderCtrlThemeOfficeXP Member List

This is the complete list of members for CXTPHeaderCtrlThemeOfficeXP, including all inherited members.

CleanUp(CXTPHeaderCtrl *pHeaderCtrl) | CXTPHeaderCtrlTheme | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPControlTheme() | CXTPControlTheme |
CXTPHeaderCtrlTheme() | CXTPHeaderCtrlTheme |
CXTPHeaderCtrlThemeOfficeXP() | CXTPHeaderCtrlThemeOfficeXP |
DrawHeader(CDC *pDC, CXTPHeaderCtrl *pHeaderCtrl) | CXTPHeaderCtrlTheme | virtual
DrawSortArrow(CDC *pDC, LPPOINT ptsArrow, BOOL bAscending) | CXTPHeaderCtrlTheme | protectedvirtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetDrawStyle() const | CXTPHeaderCtrlTheme | virtual
GetThemeStyle() const | CXTPControlTheme |
GetThemeWrapper() | CXTPHeaderCtrlTheme |
HasSortArrow() | CXTPHeaderCtrlTheme |
Layout(LPHDLAYOUT lpHDL, CXTPHeaderCtrl *pHeaderCtrl) | CXTPHeaderCtrlTheme | virtual
m_bUseWinThemes | CXTPHeaderCtrlTheme | protected
m_cr3DDkShadow | CXTPHeaderCtrlTheme | protected
m_cr3DFace | CXTPHeaderCtrlTheme | protected
m_cr3DHighLight | CXTPHeaderCtrlTheme | protected
m_cr3DShadow | CXTPHeaderCtrlTheme | protected
m_crText | CXTPHeaderCtrlTheme | protected
m_dwDrawStyle | CXTPHeaderCtrlTheme | protected
m_iArrowPadding | CXTPHeaderCtrlTheme | protected
m_nTheme | CXTPControlTheme | protected
m_sizeArrow | CXTPHeaderCtrlTheme | protected
m_sizePadding | CXTPHeaderCtrlTheme | protected
m_themeHeader | CXTPHeaderCtrlTheme | protected
OnDrawBackground(LPDRAWITEMSTRUCT lpDIS) | CXTPHeaderCtrlThemeOfficeXP | protectedvirtual
OnDrawBackgroundWinThemed(LPDRAWITEMSTRUCT lpDIS) | CXTPHeaderCtrlTheme | protectedvirtual
OnDrawItemBackground(LPDRAWITEMSTRUCT lpDIS) | CXTPHeaderCtrlThemeOfficeXP | protectedvirtual
OnDrawItemBackgroundWinThemed(LPDRAWITEMSTRUCT lpDIS) | CXTPHeaderCtrlTheme | protectedvirtual
OnDrawItemBitmap(LPDRAWITEMSTRUCT lpDIS, CRect &rcText, CXTPHeaderCtrl *pHeaderCtrl) | CXTPHeaderCtrlTheme | protectedvirtual
OnDrawItemSortArrow(LPDRAWITEMSTRUCT lpDIS, BOOL bAscending) | CXTPHeaderCtrlTheme | protectedvirtual
OnDrawItemText(LPDRAWITEMSTRUCT lpDIS, CXTPHeaderCtrl *pHeaderCtrl) | CXTPHeaderCtrlTheme | protectedvirtual
RefreshMetrics(CXTPHeaderCtrl *pHeader) | CXTPHeaderCtrlTheme | virtual
SetBitmap(int iCol, UINT uBitmapID, BOOL bRemove, COLORREF crMask, CXTPHeaderCtrl *pHeaderCtrl) | CXTPHeaderCtrlTheme | virtual
SetDrawStyle(DWORD dwDrawStyle, CXTPHeaderCtrl *pHeaderCtrl) | CXTPHeaderCtrlTheme | virtual
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static
UseWinXPThemes(CXTPHeaderCtrl *pHeaderCtrl) | CXTPHeaderCtrlTheme | virtual
~CXTPHeaderCtrlTheme() | CXTPHeaderCtrlTheme | virtual
~CXTPHeaderCtrlThemeOfficeXP() | CXTPHeaderCtrlThemeOfficeXP | virtual


Toolkit Pro: XTPToolTipContext.h Source File

  • Source
  • Common
XTPToolTipContext.h
Go to the documentation of this file.
1
23#if !defined(__XTPTOOLTIPCONTEXT_H__)
24# define __XTPTOOLTIPCONTEXT_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPImageManager;
34class CXTPImageManagerIcon;
35
37const UINT XTP_TTM_WINDOWFROMPOINT = (WM_USER + 9800);
38const UINT XTP_TTM_SETIMAGE = (WM_USER + 9801);
39
40# ifndef TTI_NONE
41# define TTI_NONE 0
42# define TTI_INFO 1
43# define TTI_WARNING 2
44# define TTI_ERROR 3
45# endif
46
47# define XTP_TTS_OFFICEFRAME 0x1000
48# define XTP_TTS_NOSHADOW 0x2000
49# define XTP_TTS_OFFICE2007FRAME 0x4000
50# define XTP_TTS_OFFICE2013FRAME 0x8000
51
52struct XTP_TOOLTIP_CONTEXT
53{
54 LPTSTR lpszDescription;
55 LPTSTR lpszTitle;
56 CXTPImageManager* pImageManager;
57 RECT rcExclude;
58 CCmdTarget* pObject;
59};
60
61struct XTP_TOOLTIP_TOOLINFO
62{
63 UINT cbSize;
64 UINT uFlags;
65 HWND hwnd;
66 UINT_PTR uId;
67 RECT rect;
68 HINSTANCE hinst;
69 LPTSTR lpszText;
70};
71
72struct XTP_TOOLTIP_TOOLINFO_EX : public XTP_TOOLTIP_TOOLINFO
73{
74 XTP_TOOLTIP_CONTEXT* pToolInfo;
75};
87enum XTPToolTipStyle
88{
89 xtpToolTipStandard,
90 xtpToolTipBalloon,
91 xtpToolTipOffice,
92 xtpToolTipRTF,
93 xtpToolTipLuna,
94 xtpToolTipResource,
95 xtpToolTipHTML,
96 xtpToolTipMarkup,
97 xtpToolTipOffice2013,
98 xtpToolTipOffice2016 = xtpToolTipOffice2013
99};
100
101// Obsolete
102# define xtpToolTipOffice2007 xtpToolTipResource
103
104class CXTPToolTipContext;
105
111class _XTP_EXT_CLASS CXTPToolTipContextToolTip : public CWnd
112{
114 DECLARE_DYNAMIC(CXTPToolTipContextToolTip)
116public:
122 CXTPToolTipContextToolTip(CXTPToolTipContext* pContext);
123
128 virtual ~CXTPToolTipContextToolTip();
129
131 struct TOOLITEM
132 {
133 CString strCaption;
134 BOOL bAutoCaption;
135 UINT uFlags;
136 CRect rect;
137 HINSTANCE hinst;
138 HWND hwnd;
139 UINT_PTR uId;
140 CRect rectExclude;
141
142 BOOL IsEqual(TOOLITEM* pItem)
143 {
144 return (pItem && hwnd == pItem->hwnd && uId == pItem->uId) || (!pItem && !hwnd);
145 }
146 BOOL IsEmpty()
147 {
148 return hwnd == 0;
149 }
150 void Reset()
151 {
152 strCaption.Empty();
153 uFlags = 0;
154 hwnd = 0;
155 uId = (UINT)-1;
156 hinst = 0;
157 rect.SetRectEmpty();
158 rectExclude.SetRectEmpty();
159 }
160 void Assign(TOOLITEM* pItem)
161 {
162 if (pItem)
163 *this = *pItem;
164 else
165 Reset();
166 }
167 };
168
169public:
170 BOOL Create(CWnd* pParentWnd, DWORD dwStyle);
171
172public:
173 BOOL AddTool(LPTOOLINFO lpToolInfo);
174 void Activate(BOOL bActivate);
175 void DelTool(LPTOOLINFO lpToolInfo);
176 void RelayEvent(LPMSG lpMsg);
178protected:
188 virtual CSize GetToolSize(TOOLITEM* lpToolInfo);
189
197 virtual void DrawEntry(CDC* pDC, TOOLITEM* lpToolInfo, CRect rc);
198
206 virtual void DrawBackground(CDC* pDC, TOOLITEM* lpToolInfo, CRect rc);
207
209protected:
210 virtual void OnVisibleChanged(BOOL /*bVisble*/)
211 {
212 }
213 BOOL IsVisible() const
214 {
215 return GetSafeHwnd() && IsWindowVisible();
216 }
217 TOOLITEM* FindTool();
218
219 CString GetToolText(TOOLITEM* lpToolInfo);
220 void SetVisibleTool(TOOLITEM* lpToolInfo);
221
222 static LRESULT CALLBACK MouseProc(int nCode, WPARAM wParam, LPARAM lParam);
223 void HookMouseMove(BOOL bSetupHook);
224 void EnsureVisible(CRect& rcToolTip);
225 int GetMaxTipWidth() const;
226 void SetRoundRectRegion(CWnd* pWnd);
229protected:
231 DECLARE_MESSAGE_MAP()
232
233 //{{AFX_VIRTUAL(CXTPToolTipContextToolTip)
234 //}}AFX_VIRTUAL
235
236 //{{AFX_MSG(CXTPToolTipContextToolTip)
237 afx_msg LRESULT OnAddTool(WPARAM wParam, LPARAM lParam);
238 afx_msg LRESULT OnActivate(WPARAM wParam, LPARAM lParam);
239 afx_msg LRESULT OnDelTool(WPARAM wParam, LPARAM lParam);
240 afx_msg LRESULT OnRelayEvent(WPARAM, LPARAM lParam);
241 afx_msg LRESULT OnSetTitle(WPARAM, LPARAM lParam);
242 afx_msg LRESULT OnUpdateTipText(WPARAM, LPARAM lParam);
243 afx_msg void OnPaint();
244 afx_msg LRESULT OnPrintClient(WPARAM wParam, LPARAM lParam);
245 afx_msg BOOL OnEraseBkgnd(CDC* pDC);
246 afx_msg LRESULT OnNcHitTest(CPoint point);
247 afx_msg int OnMouseActivate(CWnd* pDesktopWnd, UINT nHitTest, UINT message);
248 afx_msg void OnMouseMove(UINT nFlags, CPoint point);
249 afx_msg void OnTimer(UINT_PTR nIDEvent);
250 afx_msg LRESULT OnWindowFromPoint(WPARAM, LPARAM);
251 afx_msg LRESULT OnSetImage(WPARAM, LPARAM);
252 afx_msg LRESULT OnSetDelayTime(WPARAM, LPARAM lParam);
253 afx_msg void OnDestroy();
254 //}}AFX_MSG
256private:
257 BOOL Create(LPCTSTR lpszClassName, LPCTSTR lpszWindowName, DWORD dwStyle, const RECT& rect,
258 CWnd* pParentWnd, UINT nID, CCreateContext* pContext = NULL);
259
260protected:
261 CArray<TOOLITEM*, TOOLITEM*> m_arrTools;
262 BOOL m_bActive;
263 CXTPToolTipContext* m_pContext;
264 static HHOOK m_hHookMouse;
265 static CXTPToolTipContextToolTip* m_pWndMonitor;
267 TOOLITEM m_toolVisible;
268 TOOLITEM m_toolDisabled;
269 TOOLITEM m_toolDelay;
270 UINT_PTR m_nDelayTimer;
271 DWORD m_dwLastTip;
272 UINT m_nDelayInitial;
274 UINT m_nDelayReshow;
276 UINT m_nDelayAutoPop;
278 UINT_PTR m_nAutoPopTimer;
279 CString m_strTitle;
280 CXTPImageManagerIcon* m_pIcon;
281 BOOL m_bWindowRegion;
282 UINT_PTR m_nToolTipBeingShownUid;
283};
284
290class _XTP_EXT_CLASS CXTPToolTipContext : public CXTPCmdTarget
291{
292public:
293 class CRichEditToolTip;
294 class CHTMLToolTip;
295 class CStandardToolTip;
296 class CLunaToolTip;
297 class CMarkupToolTip;
298 class COfficeToolTip;
299 class COffice2013ToolTip;
300
301public:
306 CXTPToolTipContext();
307
312 virtual ~CXTPToolTipContext();
313
314public:
323 void ShowTitleAndDescription(BOOL bShowTitleAndDescription = TRUE, int nIconTitle = TTI_INFO);
324
333 BOOL IsShowTitleAndDescription() const;
334
344 void ShowImage(BOOL bShowImage, int nImageBase = 0, int nImageSize = ICON_BIG);
345
352 void SetVectorIconSize(CSize szSmall, CSize szLarge);
353
364 BOOL IsDpiBitmapScalingEnabled() const;
365
375 void EnableDpiBitmapScaling(BOOL bEnable = TRUE);
376
378 _XTP_DEPRECATED_IN_FAVOR(IsDpiBitmapScalingEnabled)
379 BOOL IsImageDPIScalingEnabled() const;
380 _XTP_DEPRECATED_IN_FAVOR(EnableDpiBitmapScaling)
381 void EnableImageDPIScaling(BOOL bScale);
396 void SetStyle(XTPToolTipStyle toolStyle);
397
405 XTPToolTipStyle GetStyle() const;
406
412 BOOL IsBalloonStyleSupported() const;
413
414public:
420 void SetMaxTipWidth(int iWidth);
421
428 int GetMaxTipWidth() const;
429
436 COLORREF GetTipBkColor() const;
437
443 void SetTipBkColor(COLORREF clr);
444
451 COLORREF GetTipTextColor() const;
452
458 void SetMargin(LPCRECT lprc);
459
464 CRect GetMargin() const;
465
471 void SetTipTextColor(COLORREF clr);
472
482 void ModifyToolTipStyle(DWORD dwRemove, DWORD dwAdd);
483
490 DWORD GetControlStyle() const;
491
501 void SetDelayTime(DWORD dwDuration, int iTime);
502
508 void CancelToolTips();
509
515 void SetFont(CFont* pFont);
516
523 CFont* GetFont();
524
530 void SetFontIndirect(LOGFONT* lpLogFont);
531
540 void SetToolTipCtrl(CXTPToolTipContextToolTip* pToolTipCtrl);
541
547 void StripEllipsisFromToolTip(BOOL bSet);
548
555 BOOL GetStripEllipsisFromToolTip() const;
556
565 virtual CWnd* CreateToolTip(CWnd* pOwner);
566
567protected:
569 virtual INT_PTR OnToolHitTest(CWnd* pWnd, CPoint point, TOOLINFO* pToolInf);
570
571public:
572 static void AFX_CDECL FillInToolInfo(TOOLINFO* pTI, HWND hWnd, CRect rect, INT_PTR nHit,
573 const CString& strToolTip);
574 static void AFX_CDECL FillInToolInfo(TOOLINFO* pTI, HWND hWnd, CRect rect, INT_PTR nHit,
575 const CString& strToolTip, const CString& strTitle,
576 const CString& strDescription,
577 CXTPImageManager* pImageManager = 0);
578
579 void FilterToolTipMessage(CWnd* pWndHost, MSG* pMsg);
580 void FilterToolTipMessage(CWnd* pWndHost, UINT message, WPARAM wParam, LPARAM lParam);
581 void FilterToolTipMessageHelper(CWnd* pWndHost, MSG* pMsg, BOOL bIgnoreFlags);
582
583 void RelayToolTipMessage(CWnd* pToolTip, MSG* pMsg);
584
585 void SetModuleToolTipContext();
586 static void PASCAL FilterToolTipMessageStatic(MSG* pMsg, CWnd* pWnd);
587
588 static int AFX_CDECL GetCursorHeight();
589
590 void DrawBackground(CDC* pDC, CRect rc);
591
594private:
595 friend class CXTPToolTipContextToolTip;
596 friend class CRichEditToolTip;
597 friend class COffice2013ToolTip;
598
599protected:
600 BOOL m_bShowTitleAndDescription;
601 BOOL m_bShowImage;
602 BOOL m_nImageSize;
603 CSize m_szVectorIconSmall;
604 CSize m_szVectorIconLarge;
605 int m_nImageBase;
606 BOOL m_bImageDPIScaling;
607 XTPToolTipStyle m_toolStyle;
608 DWORD m_dwComCtlVersion;
609 int m_nIconTitle;
610 int m_nMaxTipWidth;
611 DWORD m_dwStyle;
612 CRect m_rcMargin;
616 int m_nDelayInitial;
618 int m_nDelayReshow;
620 int m_nDelayAutoPop;
623 CWnd* m_pToolTip;
624 XTP_TOOLTIP_TOOLINFO_EX m_lastInfo;
625 static CXTPToolTipContext* m_pModuleContext;
627 COLORREF m_clrTipBkColor;
628 COLORREF m_clrTipTextColor;
630 BOOL m_bStripEllipsisFromToolTip;
633 CXTPFont m_xtpFont;
634 CXTPFont m_xtpFontTitle;
636 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CFont, m_fnt, m_xtpFont, GetFontHandle);
637 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CFont, m_fntTitle, m_xtpFontTitle, GetTitleFontHandle);
638
639private:
640 BOOL m_bImageDPIScalingModified;
641
642# ifdef _XTP_ACTIVEX
644public:
645 DECLARE_INTERFACE_MAP()
646 DECLARE_DISPATCH_MAP()
647 DECLARE_OLETYPELIB_EX(CXTPToolTipContext);
648
649 afx_msg void OleSetMargin(long left, long top, long right, long bottom);
650 LPFONTDISP OleGetFont();
651 void OleSetFont(LPFONTDISP pFontDisp);
652 void OleShowImage(BOOL bShowImage, int nImageBase);
653 void OleSetVectorIconSize(long cx, long cy);
654
655 DECLARE_PROPERTY(ShowOfficeBorder, BOOL);
656 DECLARE_PROPERTY(ShowShadow, BOOL);
657
659# endif
660};
662AFX_INLINE CRect CXTPToolTipContext::GetMargin() const
663{
664 return m_rcMargin;
665}
666AFX_INLINE BOOL CXTPToolTipContextToolTip::Create(LPCTSTR lpszClassName, LPCTSTR lpszWindowName,
667 DWORD dwStyle, const RECT& rect, CWnd* pParentWnd,
668 UINT nID, CCreateContext* pContext)
669{
670 return CWnd::Create(lpszClassName, lpszWindowName, dwStyle, rect, pParentWnd, nID, pContext);
671}
672AFX_INLINE DWORD CXTPToolTipContext::GetControlStyle() const
673{
674 return m_dwStyle;
675}
676AFX_INLINE BOOL CXTPToolTipContext::IsShowTitleAndDescription() const
677{
678 return m_bShowTitleAndDescription;
679}
680AFX_INLINE CFont* CXTPToolTipContext::GetFont()
681{
682 return &m_xtpFont;
683}
684AFX_INLINE void CXTPToolTipContext::StripEllipsisFromToolTip(BOOL bSet)
685{
686 m_bStripEllipsisFromToolTip = bSet;
687}
688AFX_INLINE BOOL CXTPToolTipContext::GetStripEllipsisFromToolTip() const
689{
690 return m_bStripEllipsisFromToolTip;
691}
692
693AFX_INLINE BOOL CXTPToolTipContext::IsImageDPIScalingEnabled() const
694{
695 return IsDpiBitmapScalingEnabled();
696}
697
698AFX_INLINE void CXTPToolTipContext::EnableImageDPIScaling(BOOL bScale)
699{
700 EnableDpiBitmapScaling(bScale);
701}
703# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
705#endif // !defined(__XTPTOOLTIPCONTEXT_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPToolTipStyle
XTPToolTipStyle
Enumeration used to determine styles for tooltips.
Definition XTPToolTipContext.h:88
xtpToolTipOffice2013
@ xtpToolTipOffice2013
Office 2013 tooltip window style.
Definition XTPToolTipContext.h:97
xtpToolTipOffice
@ xtpToolTipOffice
Office tooltip window style
Definition XTPToolTipContext.h:91
xtpToolTipBalloon
@ xtpToolTipBalloon
Balloon tooltip window style
Definition XTPToolTipContext.h:90
xtpToolTipResource
@ xtpToolTipResource
Office 2007 window style
Definition XTPToolTipContext.h:94
xtpToolTipRTF
@ xtpToolTipRTF
RTF tooltip window style
Definition XTPToolTipContext.h:92
xtpToolTipStandard
@ xtpToolTipStandard
Standard tooltip window style
Definition XTPToolTipContext.h:89
xtpToolTipOffice2016
@ xtpToolTipOffice2016
Office 2016 tooltip window style.
Definition XTPToolTipContext.h:98
xtpToolTipHTML
@ xtpToolTipHTML
HTML tooltip style
Definition XTPToolTipContext.h:95
xtpToolTipLuna
@ xtpToolTipLuna
Luna tooltip window style
Definition XTPToolTipContext.h:93
xtpToolTipMarkup
@ xtpToolTipMarkup
HTML tooltip style
Definition XTPToolTipContext.h:96
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPFont
Provides a convenient object oriented interface for HFONT GDI object and uses GDI handle caching.
Definition XTPGdiObjects.h:414
CXTPImageManager
CXTPImageManager is a standalone class.
Definition XTPImageManager.h:1898
CXTPImageManagerIcon
Icons holder class.
Definition XTPImageManager.h:622
CXTPToolTipContext
CXTPToolTipContext is a CXTPCmdTarget derived class.
Definition XTPToolTipContext.h:291
CXTPToolTipContext::SetTipTextColor
void SetTipTextColor(COLORREF clr)
Sets the text color in a tooltip window.
CXTPToolTipContext::m_dwComCtlVersion
DWORD m_dwComCtlVersion
CommCtrl.dll version.
Definition XTPToolTipContext.h:608
CXTPToolTipContext::ShowImage
void ShowImage(BOOL bShowImage, int nImageBase=0, int nImageSize=ICON_BIG)
Call this method to show image in tooltip.
CXTPToolTipContext::IsShowTitleAndDescription
BOOL IsShowTitleAndDescription() const
Determines if TitleAndDescription option was set.
CXTPToolTipContext::m_xtpFont
CXTPFont m_xtpFont
Font of the tool tip.
Definition XTPToolTipContext.h:633
CXTPToolTipContext::GetTipTextColor
COLORREF GetTipTextColor() const
Retrieves the text color in a tooltip window.
CXTPToolTipContext::ModifyToolTipStyle
void ModifyToolTipStyle(DWORD dwRemove, DWORD dwAdd)
Modifies the styles of the tool tip.
CXTPToolTipContext::SetStyle
void SetStyle(XTPToolTipStyle toolStyle)
Call this member to set the style of the tooltip.
CXTPToolTipContext::SetTipBkColor
void SetTipBkColor(COLORREF clr)
Sets the background color in a tooltip window.
CXTPToolTipContext::m_nImageBase
int m_nImageBase
This value will be added to tool identifier to retrieve image for tip.
Definition XTPToolTipContext.h:605
CXTPToolTipContext::GetStripEllipsisFromToolTip
BOOL GetStripEllipsisFromToolTip() const
Call this method to determine if ellipsis will be removed from tip title.
CXTPToolTipContext::GetStyle
XTPToolTipStyle GetStyle() const
Call this member to get the style of the tooltip.
CXTPToolTipContext::m_toolStyle
XTPToolTipStyle m_toolStyle
Tooltip style.
Definition XTPToolTipContext.h:607
CXTPToolTipContext::GetMargin
CRect GetMargin() const
CXTPToolTipContext::IsBalloonStyleSupported
BOOL IsBalloonStyleSupported() const
Call this method to determine if Balloon tooltips supported by the system.
CXTPToolTipContext::SetFont
void SetFont(CFont *pFont)
Call this method to set the custom font for tooltips.
CXTPToolTipContext::m_xtpFontTitle
CXTPFont m_xtpFontTitle
Font of the tool tip title.
Definition XTPToolTipContext.h:634
CXTPToolTipContext::m_pToolTip
CWnd * m_pToolTip
Owned Tooltip window.
Definition XTPToolTipContext.h:623
CXTPToolTipContext::SetVectorIconSize
void SetVectorIconSize(CSize szSmall, CSize szLarge)
Call this method to set size of vector icon in tooltip.
CXTPToolTipContext::m_nDelayReshow
int m_nDelayReshow
The length of time it takes for subsequent tool tip windows to appear as the pointer moves from one t...
Definition XTPToolTipContext.h:618
CXTPToolTipContext::~CXTPToolTipContext
virtual ~CXTPToolTipContext()
Destroys a CXTPToolTipContext object, handles cleanup and deallocation.
CXTPToolTipContext::ShowTitleAndDescription
void ShowTitleAndDescription(BOOL bShowTitleAndDescription=TRUE, int nIconTitle=TTI_INFO)
Call this method to show title and description part of tooltip window.
CXTPToolTipContext::CXTPToolTipContext
CXTPToolTipContext()
Constructs a CXTPToolTipContext object.
CXTPToolTipContext::SetFontIndirect
void SetFontIndirect(LOGFONT *lpLogFont)
Call this method to set custom font for tooltips.
CXTPToolTipContext::IsDpiBitmapScalingEnabled
BOOL IsDpiBitmapScalingEnabled() const
Gets DPI bitmap scaling flag.
CXTPToolTipContext::SetDelayTime
void SetDelayTime(DWORD dwDuration, int iTime)
Call this function to set the delay time for a tool tip control.
CXTPToolTipContext::m_lastInfo
XTP_TOOLTIP_TOOLINFO_EX m_lastInfo
Last tooltip info.
Definition XTPToolTipContext.h:624
CXTPToolTipContext::m_nIconTitle
int m_nIconTitle
Icon title for extended tooltip.
Definition XTPToolTipContext.h:609
CXTPToolTipContext::m_bImageDPIScaling
BOOL m_bImageDPIScaling
Enables DPI scaling of images.
Definition XTPToolTipContext.h:606
CXTPToolTipContext::m_pModuleContext
static CXTPToolTipContext * m_pModuleContext
Tooltip for current module.
Definition XTPToolTipContext.h:625
CXTPToolTipContext::SetMargin
void SetMargin(LPCRECT lprc)
Sets the top, left, bottom, and right margins for a tooltip window.
CXTPToolTipContext::m_bShowTitleAndDescription
BOOL m_bShowTitleAndDescription
TRUE to show title and description for tooltip.
Definition XTPToolTipContext.h:600
CXTPToolTipContext::m_clrTipBkColor
COLORREF m_clrTipBkColor
Background color in a tooltip window.
Definition XTPToolTipContext.h:627
CXTPToolTipContext::EnableDpiBitmapScaling
void EnableDpiBitmapScaling(BOOL bEnable=TRUE)
Sets DPI bitmap scaling flag.
CXTPToolTipContext::GetTipBkColor
COLORREF GetTipBkColor() const
Retrieves the background color in a tooltip window.
CXTPToolTipContext::m_nImageSize
BOOL m_nImageSize
Size of images in tooltip.
Definition XTPToolTipContext.h:602
CXTPToolTipContext::m_dwStyle
DWORD m_dwStyle
Tooltip style.
Definition XTPToolTipContext.h:611
CXTPToolTipContext::m_nDelayAutoPop
int m_nDelayAutoPop
the length of time a tooltip window remains visible if the pointer is stationary within a tool's boun...
Definition XTPToolTipContext.h:620
CXTPToolTipContext::StripEllipsisFromToolTip
void StripEllipsisFromToolTip(BOOL bSet)
Call this method to remove ellipsis from tip title.
CXTPToolTipContext::m_clrTipTextColor
COLORREF m_clrTipTextColor
Text color in a tooltip window.
Definition XTPToolTipContext.h:628
CXTPToolTipContext::CancelToolTips
void CancelToolTips()
Call this member function to remove a tooltip from the screen if a tooltip is currently displayed.
CXTPToolTipContext::GetMaxTipWidth
int GetMaxTipWidth() const
Retrieves the maximum width for a tooltip window.
CXTPToolTipContext::SetToolTipCtrl
void SetToolTipCtrl(CXTPToolTipContextToolTip *pToolTipCtrl)
Call this method to set custom tooltip ctrl.
CXTPToolTipContext::SetMaxTipWidth
void SetMaxTipWidth(int iWidth)
Sets the maximum width for a tooltip window.
CXTPToolTipContext::m_nMaxTipWidth
int m_nMaxTipWidth
Maximum width of tooltip window.
Definition XTPToolTipContext.h:610
CXTPToolTipContext::GetFont
CFont * GetFont()
Call this method to get the custom font for tooltips.
CXTPToolTipContext::m_rcMargin
CRect m_rcMargin
Margin or "padding" placed around the tooltip text.
Definition XTPToolTipContext.h:612
CXTPToolTipContext::m_nDelayInitial
int m_nDelayInitial
The length of time the pointer must remain stationary within a tool's bounding rectangle before the t...
Definition XTPToolTipContext.h:616
CXTPToolTipContext::m_bStripEllipsisFromToolTip
BOOL m_bStripEllipsisFromToolTip
TRUE to remove ellipses from tip caption (defailt is TRUE)
Definition XTPToolTipContext.h:630
CXTPToolTipContext::GetControlStyle
DWORD GetControlStyle() const
CXTPToolTipContext::CreateToolTip
virtual CWnd * CreateToolTip(CWnd *pOwner)
This method is called to create tooltip window.
CXTPToolTipContext::m_szVectorIconSmall
CSize m_szVectorIconSmall
Size of small vector icon.
Definition XTPToolTipContext.h:603
CXTPToolTipContext::m_szVectorIconLarge
CSize m_szVectorIconLarge
Size of large vector icon.
Definition XTPToolTipContext.h:604
CXTPToolTipContext::m_bShowImage
BOOL m_bShowImage
TRUE to show images in tooltip.
Definition XTPToolTipContext.h:601
CXTPToolTipContextToolTip
CXTPToolTipContextToolTip is CWnd derived class, the base class for custom tool tips.
Definition XTPToolTipContext.h:112
CXTPToolTipContextToolTip::~CXTPToolTipContextToolTip
virtual ~CXTPToolTipContextToolTip()
Destroys a CXTPToolTipContextToolTip object, handles cleanup and deallocation.
CXTPToolTipContextToolTip::DrawBackground
virtual void DrawBackground(CDC *pDC, TOOLITEM *lpToolInfo, CRect rc)
This method is called to draw background of tool tip.
CXTPToolTipContextToolTip::DrawEntry
virtual void DrawEntry(CDC *pDC, TOOLITEM *lpToolInfo, CRect rc)
This method is called to draw face of tool tip.
CXTPToolTipContextToolTip::GetToolSize
virtual CSize GetToolSize(TOOLITEM *lpToolInfo)
This method is called to retrieve size of tool tip to show.
CXTPToolTipContextToolTip::CXTPToolTipContextToolTip
CXTPToolTipContextToolTip(CXTPToolTipContext *pContext)
Constructs a CXTPToolTipContextToolTip object.


Toolkit Pro: Member List

CXTPGridThemeDefault Member List

This is the complete list of members for CXTPGridThemeDefault, including all inherited members.

CalcColumnHeight(CDC *pDC, CXTPGridColumn *pColumn, int nTotalWidth=0) | CXTPGridPaintManager | protectedvirtual
CalculateRowHeight(CDC *pDC, const CString &strText, int nMaxWidth, BOOL bWordBreak=TRUE) | CXTPGridPaintManager | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPGridPaintManager() | CXTPGridPaintManager |
CXTPGridThemeDefault() | CXTPGridThemeDefault |
DrawBitmap(CDC *pDC, CXTPGridControl *pControl, CRect rcColumn, int iImage) | CXTPGridPaintManager | virtual
DrawCollapsedBitmap(CDC *pDC, const CXTPGridRow *pRow, CRect &rcBitmap) | CXTPGridPaintManager | virtual
DrawColumn(CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn, BOOL bDrawExternal=FALSE, int nShadowWidth=0) | CXTPGridPaintManager | virtual
DrawColumnBackground(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, BOOL &bColumnPressed, BOOL &bDraggingFromHeader, CXTPGridHeader *pHeader=NULL) | CXTPGridThemeDefault | virtual
DrawColumnFooter(CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn) | CXTPGridPaintManager | virtual
DrawColumnFooterDivider(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn) | CXTPGridPaintManager | virtual
DrawColumnIcon(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, CRect rcIcon, int iIcon) | CXTPGridPaintManager | virtual
DrawColumnText(CDC *pDC, CRect rcText, CString strCaption, int nHeaderAlignment, BOOL bIsHeader, BOOL bColumnPressed) | CXTPGridPaintManager | virtual
DrawConnector(CDC *pDC, CPoint ptFrom, CPoint ptTo) | CXTPGridPaintManager |
DrawFocusedRow(CDC *pDC, CRect rcRow) | CXTPGridPaintManager | virtual
DrawFreezeColsDivider(CDC *pDC, const CRect &rc, CXTPGridControl *pControl, CXTPGridRow *pRow=NULL) | CXTPGridPaintManager | virtual
DrawGlyph(CDC *pDC, CRect rcColumn, int iImage) | CXTPGridPaintManager | virtual
DrawGrid(CDC *pDC, XTPGridOrientation orientation, CRect rcGrid) | CXTPGridPaintManager | virtual
DrawGridPattern(CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush) | CXTPGridPaintManager | protectedvirtual
DrawGridPattern(CDC *pDC, CXTPBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush) | CXTPGridPaintManager | protectedvirtual
DrawGridPattern(CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr) | CXTPGridPaintManager | protectedvirtual
DrawGroupRow(CDC *pDC, CXTPGridGroupRow *pRow, CRect rcRow, XTP_GRIDRECORDITEM_METRICS *pMetrics) | CXTPGridPaintManager | virtual
DrawHorizontalLine(CDC *pDC, int xPos, int yPos, int cx, COLORREF clr) | CXTPGridPaintManager |
DrawInplaceButton(CDC *pDC, CXTPGridInplaceButton *pButton) | CXTPGridPaintManager | virtual
DrawInplaceButtonFrame(CDC *pDC, CXTPGridInplaceButton *pButton) | CXTPGridPaintManager | protectedvirtual
DrawInplaceButtonIcon(CDC *pDC, CXTPGridInplaceButton *pButton) | CXTPGridPaintManager | protectedvirtual
DrawInplaceComboButton(CDC *pDC, CRect *pRc) | CXTPGridPaintManager | virtual
DrawInplaceExpandButton(CDC *pDC, CRect *pRc) | CXTPGridPaintManager | virtual
DrawInplaceSpinButton(CDC *pDC, CRect *pRc) | CXTPGridPaintManager | virtual
DrawItemBitmap(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CRect &rcItem, int nImage) | CXTPGridPaintManager | virtual
DrawItemCaption(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics) | CXTPGridPaintManager | virtual
DrawItemControl(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CXTPGridRecordItemControl *pControl, CRect &rcItem) | CXTPGridPaintManager | virtual
DrawLink(int *pnCurrDrawPos, XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CXTPGridHyperlink *pHyperlink, CString strText, CRect rcLink, int nFlag, BOOL bTrim=FALSE) | CXTPGridPaintManager | protectedvirtual
DrawMultiLineText(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, BOOL bWordBreak=TRUE) | CXTPGridPaintManager | protectedvirtual
DrawNoGroupByText(CDC *pDC, CRect rcItem) | CXTPGridPaintManager | virtual
DrawRowNumber(CDC *pDC, CRect rcNumber, CXTPGridRow *pRow) | CXTPGridPaintManager | virtual
DrawSectionDivider(CDC *pDC, const CRect &rc, XTPGridSectionDividerPosition dividerPosition, XTPGridSectionDividerStyle dividerStyle, CXTPPaintManagerColor dividerColor) | CXTPGridPaintManager |
DrawShellIcon(CDC *pDC, CRect rcColumn, int iImage) | CXTPGridPaintManager | virtual
DrawSingleLineText(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nStartPos, int nEndPos, int nActualWidth) | CXTPGridPaintManager | protectedvirtual
DrawString(int *pnCurrDrawPos, CDC *pDC, const CString &strDraw, CRect rcDraw, UINT nFormat) | CXTPGridPaintManager | protectedvirtual
DrawTextLine(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nFlag, int &nCharCounter, int &nHyperlinkCounter) | CXTPGridPaintManager | protectedvirtual
DrawTreeStructure(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CRect rcItem, CSize sizeGlyph) | CXTPGridPaintManager | virtual
DrawTriangle(CDC *pDC, CRect rcTriangle, BOOL bToDown, BOOL bDraggingFromHeader, int nShadowWidth, BOOL bColumnPressed) | CXTPGridPaintManager | virtual
DrawVerticalLine(CDC *pDC, int xPos, int yPos, int cy, COLORREF clr) | CXTPGridPaintManager |
DrawVerticalTimeLineMarker(CDC *pDC, int xPos, CXTPGridControl *pControl, COLORREF color=RGB(0, 255, 0)) | CXTPGridPaintManager | virtual
EnablePreviewMode(BOOL bIsPreviewMode) | CXTPGridPaintManager |
FillFooter(CDC *pDC, CRect rcFooter) | CXTPGridPaintManager | virtual
FillGroupByControl(CDC *pDC, CRect &rcGroupBy) | CXTPGridPaintManager | virtual
FillGroupRowMetrics(CXTPGridGroupRow *pRow, XTP_GRIDRECORDITEM_METRICS *pMetrics, BOOL bPrinting) | CXTPGridPaintManager | virtual
FillHeaderControl(CDC *pDC, CRect rcHeader) | CXTPGridPaintManager | virtual
FillIndent(CDC *pDC, CRect rcRow) | CXTPGridPaintManager | virtual
FillItemShade(CDC *pDC, CRect rcItem) | CXTPGridPaintManager | virtual
FillRow(CDC *pDC, CXTPGridRow *pRow, CRect rcRow) | CXTPGridPaintManager | virtual
FindRowAdjacentToMerged(const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, BOOL bUpward) | CXTPGridPaintManager |
FindRowAdjacentToMergedEx(const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, int &nAdjRowIndex, BOOL bUpward) | CXTPGridPaintManager |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetColumnOffice2007CustomThemeBaseColor() const | CXTPGridPaintManager |
GetColumnStyle() const | CXTPGridPaintManager |
GetControlBackColor(CXTPGridControl *pControl) | CXTPGridPaintManager | virtual
GetFooterHeight(CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0) | CXTPGridPaintManager | virtual
GetFreezeColsDividerStyle() const | CXTPGridPaintManager |
GetGlyphs() const | CXTPGridPaintManager |
GetHeaderHeight() | CXTPGridPaintManager | virtual
GetHeaderHeight(CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0) | CXTPGridPaintManager | virtual
GetItemHeight(XTP_GRIDRECORDITEM_DRAWARGS &drawArgs, int nWidth) | CXTPGridPaintManager |
GetMaxPreviewLines() | CXTPGridPaintManager |
GetPreviewItemHeight(CDC *pDC, CXTPGridRow *pRow, int nWidth, int nHeight) | CXTPGridPaintManager | virtual
GetPreviewLinesCount(CDC *pDC, CRect &rcText, const CString &strText) | CXTPGridPaintManager |
GetRowHeight(CDC *pDC, CXTPGridRow *pRow) | CXTPGridPaintManager | virtual
GetRowHeight(CDC *pDC, CXTPGridRow *pRow, int nTotalWidth) | CXTPGridPaintManager | virtual
GetRowHeightEx(CDC *pDC, CXTPGridRow *pRow, int nTotalWidth, const BOOL firstLevel=TRUE) | CXTPGridPaintManager |
GetSectionDividerHeight(XTPGridFixedRowsDividerStyle dividerStyle) | CXTPGridPaintManager |
GetTextFont() | CXTPGridPaintManager |
IsColumHotTrackingEnabled() const | CXTPGridPaintManager | virtual
IsColumnPlusMinusSign() const | CXTPGridPaintManager |
IsColumnWidthWYSIWYG() const | CXTPGridPaintManager |
IsDrawGridForEmptySpace() const | CXTPGridPaintManager |
IsFixedInplaceButtonHeight() const | CXTPGridPaintManager |
IsFixedRowHeight() const | CXTPGridPaintManager |
IsGridVisible(BOOL bVertical) const | CXTPGridPaintManager |
IsGridVisible(XTPGridOrientation orientation) const | CXTPGridPaintManager |
IsLastColumnWidthWYSIWYG() const | CXTPGridPaintManager |
IsPreviewMode() const | CXTPGridPaintManager |
IsPrintGroupRowIcon() const | CXTPGridPaintManager |
IsShowWYSIWYGMarkers() const | CXTPGridPaintManager |
IsUseDropMarker() const | CXTPGridPaintManager |
LoadGlyphs() | CXTPGridPaintManager | virtual
m_arStartCol | CXTPGridPaintManager |
m_bAllowMergeCells | CXTPGridPaintManager |
m_bBaseTreeIndent | CXTPGridPaintManager |
m_bCleanTooltip | CXTPGridPaintManager |
m_bColumnPlusMinusSign | CXTPGridPaintManager | protected
m_bColumnWidthWYSIWYG | CXTPGridPaintManager | protected
m_bCompactText | CXTPGridPaintManager |
m_bDrawGridForEmptySpace | CXTPGridPaintManager | protected
m_bFixedInplaceButtonHeight | CXTPGridPaintManager | protected
m_bFixedRowHeight | CXTPGridPaintManager | protected
m_bForceDynamicMarkupForCell | CXTPGridPaintManager |
m_bForceShowDropMarker | CXTPGridPaintManager |
m_bForceShowTooltip | CXTPGridPaintManager |
m_bGrayIfDisable | CXTPGridPaintManager |
m_bGroupRowTextBold | CXTPGridPaintManager |
m_bHideSelection | CXTPGridPaintManager |
m_bHotTracking | CXTPGridPaintManager |
m_bInvertColumnOnClick | CXTPGridPaintManager |
m_bIsPreviewMode | CXTPGridPaintManager | protected
m_bLastColumnWidthWYSIWYG | CXTPGridPaintManager | protected
m_bMakeUpper | CXTPGridPaintManager |
m_bMoveScrollbarOnFixedColumnsIndent | CXTPGridPaintManager |
m_bPrintGroupRowIcon | CXTPGridPaintManager | protected
m_bPrintPageRectangle | CXTPGridPaintManager |
m_bPrintSortTriangle | CXTPGridPaintManager |
m_bPrintVirtualPageNumber | CXTPGridPaintManager |
m_bPrintWatermark | CXTPGridPaintManager |
m_bRecOrRowNum | CXTPGridPaintManager |
m_bRevertAlignment | CXTPGridPaintManager |
m_bShadeGroupHeadings | CXTPGridPaintManager |
m_bShadeSortColumn | CXTPGridPaintManager |
m_bShowLockIcon | CXTPGridPaintManager |
m_bShowNonActiveInPlaceButton | CXTPGridPaintManager |
m_bShowWYSIWYGMarkers | CXTPGridPaintManager | protected
m_bSortTriangleOffsetFromRight | CXTPGridPaintManager |
m_bThemedInplaceButtons | CXTPGridPaintManager |
m_bUseAlternativeBackground | CXTPGridPaintManager |
m_bUseDropMarker | CXTPGridPaintManager |
m_bUseEditTextAlignment | CXTPGridPaintManager |
m_bUseGroupRowSelectionState | CXTPGridPaintManager |
m_bUseShellIcon | CXTPGridPaintManager |
m_clrAlternativeBackground | CXTPGridPaintManager |
m_clrBoldText | CXTPGridPaintManager |
m_clrBoldTextHighlight | CXTPGridPaintManager |
m_clrBtnFace | CXTPGridPaintManager |
m_clrBtnFacePressed | CXTPGridPaintManager |
m_clrBtnText | CXTPGridPaintManager |
m_clrCaptionText | CXTPGridPaintManager |
m_clrCaptionTextPressed | CXTPGridPaintManager |
m_clrColumnOffice2007CustomTheme | CXTPGridPaintManager |
m_clrConnector | CXTPGridPaintManager |
m_clrControlBack | CXTPGridPaintManager |
m_clrControlDark | CXTPGridPaintManager |
m_clrControlLightLight | CXTPGridPaintManager |
m_clrDisableBitmapDarkest | CXTPGridPaintManager |
m_clrDisableBitmapLightest | CXTPGridPaintManager |
m_clrFormulaSubSum | CXTPGridPaintManager |
m_clrFormulaSum | CXTPGridPaintManager |
m_clrFreezeColsDivider | CXTPGridPaintManager |
m_clrGradientColumnSeparator | CXTPGridPaintManager |
m_clrGradientColumnShadow | CXTPGridPaintManager |
m_clrGroupBoxBack | CXTPGridPaintManager |
m_clrGroupRowText | CXTPGridPaintManager |
m_clrGroupShadeBack | CXTPGridPaintManager |
m_clrGroupShadeBorder | CXTPGridPaintManager |
m_clrGroupShadeText | CXTPGridPaintManager |
m_clrHeaderControl | CXTPGridPaintManager |
m_clrHighlight | CXTPGridPaintManager |
m_clrHighlightText | CXTPGridPaintManager |
m_clrHotDivider | CXTPGridPaintManager |
m_clrIndentControl | CXTPGridPaintManager |
m_clrItemShade | CXTPGridPaintManager |
m_clrPreviewText | CXTPGridPaintManager |
m_clrSelectedRow | CXTPGridPaintManager |
m_clrSelectedRowText | CXTPGridPaintManager |
m_clrWindowText | CXTPGridPaintManager |
m_columnStyle | CXTPGridPaintManager | protected
m_crlNoGroupByText | CXTPGridPaintManager |
m_grcGradientColumn | CXTPGridPaintManager |
m_grcGradientColumnHot | CXTPGridPaintManager |
m_grcGradientColumnPushed | CXTPGridPaintManager |
m_iRecOrRowStart | CXTPGridPaintManager |
m_nBaseParentRecordIndent | CXTPGridPaintManager |
m_nFixedColumnsIndent | CXTPGridPaintManager |
m_nFooterHeight | CXTPGridPaintManager | protected
m_nFreezeColsDividerStyle | CXTPGridPaintManager | protected
m_nGridLineStylePreviousH | CXTPGridPaintManager | protected
m_nGridLineStylePreviousV | CXTPGridPaintManager | protected
m_nGroupGridLineHeight | CXTPGridPaintManager | protected
m_nGroupGridLineStyle | CXTPGridPaintManager | protected
m_nHeaderHeight | CXTPGridPaintManager | protected
m_nMaxPreviewLines | CXTPGridPaintManager | protected
m_nResizingWidth | CXTPGridPaintManager | protected
m_nRowHeight | CXTPGridPaintManager | protected
m_nRowHeightDefault | CXTPGridPaintManager |
m_nTextIndentForGroupRowsWithNoIcon | CXTPGridPaintManager |
m_nTreeColumnLineLength | CXTPGridPaintManager |
m_nTreeIndent | CXTPGridPaintManager |
m_nTreeStructureStyle | CXTPGridPaintManager |
m_nTreeTextIndent | CXTPGridPaintManager |
m_nTreeTextIndentGroupRow | CXTPGridPaintManager |
m_nTreeTextIndentRowChildren | CXTPGridPaintManager |
m_nTreeTextIndentRowParent | CXTPGridPaintManager |
m_pControl | CXTPGridPaintManager | protected
m_pGlyphs | CXTPGridPaintManager | protected
m_pHyperlinkHoverStyle | CXTPGridPaintManager |
m_pHyperlinkStyle | CXTPGridPaintManager |
m_pMarkupUIElement_NoGroupBy | CXTPGridPaintManager | protected
m_PrintPageWidth | CXTPGridPaintManager |
m_rcPreviewIndent | CXTPGridPaintManager |
m_RecordNumberWidth | CXTPGridPaintManager |
m_strCollapse | CXTPGridPaintManager |
m_strDecreasing | CXTPGridPaintManager |
m_strExpand | CXTPGridPaintManager |
m_strIncreasing | CXTPGridPaintManager |
m_strMarkupUIElement_NoGroupBy | CXTPGridPaintManager | protected
m_strNoFieldsAvailable | CXTPGridPaintManager |
m_strNoGroupBy | CXTPGridPaintManager |
m_strNoItems | CXTPGridPaintManager |
m_strSortBy | CXTPGridPaintManager |
m_szGlyph | CXTPGridPaintManager | protected
m_themeButton | CXTPGridPaintManager | protected
m_themeCombo | CXTPGridPaintManager | protected
m_themeHeader | CXTPGridPaintManager | protected
m_themeSpin | CXTPGridPaintManager | protected
m_treeStructureStyle | CXTPGridPaintManager |
m_xtpBrushGroupGridLineStyle | CXTPGridPaintManager | protected
m_xtpBrushHorizontalGrid | CXTPGridPaintManager | protected
m_xtpBrushTreeStructure | CXTPGridPaintManager | protected
m_xtpBrushVeriticalGrid | CXTPGridPaintManager | protected
m_xtpFontBoldText | CXTPGridPaintManager |
m_xtpFontCaption | CXTPGridPaintManager |
m_xtpFontPreview | CXTPGridPaintManager |
m_xtpFontText | CXTPGridPaintManager |
OnDrawAction(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs) | CXTPGridPaintManager | virtual
RecalcTotalHightOfMergedRows(CXTPGridColumns *pColumns, CDC *pDC, CXTPGridRow *pRow, int nRowHeight, int nTotalWidth) | CXTPGridPaintManager |
RefreshMetrics() | CXTPGridPaintManager | virtual
SetCaptionFont(LOGFONT &lf) | CXTPGridPaintManager |
SetColumnOffice2007CustomThemeBaseColor(COLORREF clrBaseColor) | CXTPGridPaintManager |
SetColumnPlusMinusSign(BOOL bDraw) | CXTPGridPaintManager |
SetColumnStyle(XTPGridColumnStyle columnStyle) | CXTPGridPaintManager |
SetColumnWidthWYSIWYG(BOOL bColumnWidthWYSIWYG) | CXTPGridPaintManager |
SetDrawGridForEmptySpace(BOOL bDrawGrid) | CXTPGridPaintManager |
SetFixedRowHeight(BOOL bFixedRowHeight) | CXTPGridPaintManager |
SetFreezeColsDividerStyle(int nStyle) | CXTPGridPaintManager |
SetGridControl(CXTPGridControl *pControl) | CXTPGridPaintManager | virtual
SetHeaderHeight(int nHeight) | CXTPGridPaintManager | virtual
SetInplaceButtonHeight(BOOL bFixedInplaceButtonHeight) | CXTPGridPaintManager |
SetLastColumnWidthWYSIWYG(BOOL bColumnWidthWYSIWYG) | CXTPGridPaintManager |
SetMaxPreviewLines(int nMaxLines) | CXTPGridPaintManager |
SetPreviewIndent(int nLeft, int nTop, int nRight, int nBottom) | CXTPGridPaintManager |
SetPrintGroupRowIcon(BOOL bDraw) | CXTPGridPaintManager |
SetTextFont(LOGFONT &lf) | CXTPGridPaintManager |
ShowWYSIWYGMarkers(BOOL bSet) | CXTPGridPaintManager |
~CXTPGridPaintManager() | CXTPGridPaintManager | virtual


Toolkit Pro: Member List

CXTPCalendarWeekViewGroup Member List

This is the complete list of members for CXTPCalendarWeekViewGroup, including all inherited members.

AddResource(CXTPCalendarResource *pResource, BOOL bWithAddRef) | CXTPCalendarViewGroup | virtual
AdjustLayout(CDC *pDC, const CRect &rcGroup) | CXTPCalendarViewGroup | virtual
AdjustLayout2(CDC *pDC, const CRect &rcGroup) | CXTPCalendarViewGroup | virtual
CXTPCalendarViewGroup(CXTPCalendarViewDay *pViewDay) | CXTPCalendarViewGroup |
CXTPCalendarViewGroupT(CXTPCalendarWeekViewDay *pViewDay) | CXTPCalendarViewGroupT< CXTPCalendarWeekViewDay, CXTPCalendarWeekViewEvent, CXTPCalendarWeekViewGroup > | inline
CXTPCalendarWeekViewGroup(CXTPCalendarWeekViewDay *pViewDay) | CXTPCalendarWeekViewGroup |
CXTPCalendarWMHandler() | CXTPCalendarWMHandler |
CXTPCmdTarget() | CXTPCmdTarget |
Draw(CDC *pDC) | CXTPCalendarViewGroup | virtual
ExchangeEventPlace(CXTPCalendarViewEvent *pViewEvent, int nNewPlace) | CXTPCalendarViewGroup | virtual
FillHitTestEx(XTP_CALENDAR_HITTESTINFO *pHitTest) const | CXTPCalendarWeekViewGroup | protectedvirtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCalendarControl() const | CXTPCalendarViewGroup | virtual
GetCaption() const | CXTPCalendarViewGroup | virtual
GetChildHandlerAt(int nIndex) const | CXTPCalendarViewGroup | virtual
GetChildHandlersCount() const | CXTPCalendarViewGroup | virtual
GetDataProvider() const | CXTPCalendarViewGroup | virtual
GetGroupIndex() const | CXTPCalendarViewGroup | virtual
GetHeaderRect() const | CXTPCalendarViewGroup | inlinevirtual
GetRect() const | CXTPCalendarViewGroup | inlinevirtual
GetResources() const | CXTPCalendarViewGroup | virtual
GetScheduleID() const | CXTPCalendarViewGroup | virtual
GetTooltipRect(const CPoint &ptHit, const XTP_CALENDAR_HITTESTINFO &hitInfo) const | CXTPCalendarViewGroup | virtual
GetViewDay() const | CXTPCalendarViewGroupT< CXTPCalendarWeekViewDay, CXTPCalendarWeekViewEvent, CXTPCalendarWeekViewGroup > | inline
GetViewDay_() const | CXTPCalendarViewGroup |
GetViewEvent(int nIndex) const | CXTPCalendarViewGroupT< CXTPCalendarWeekViewDay, CXTPCalendarWeekViewEvent, CXTPCalendarWeekViewGroup > | inlinevirtual
GetViewEvent_(int nIndex) const | CXTPCalendarViewGroup |
GetViewEventByEvent_(CXTPCalendarEvent *pEvent) const | CXTPCalendarViewGroup | virtual
GetViewEventByPlace_(int nEventPlace) const | CXTPCalendarViewGroup | virtual
GetViewEventsCount() const | CXTPCalendarViewGroup |
HitTest(CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const | CXTPCalendarViewGroup | virtual
HitTestEx(CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const | CXTPCalendarViewGroup | virtual
KillTimer(UINT uTimerID) | CXTPCalendarViewGroup | protectedvirtual
m_arEvents | CXTPCalendarViewGroup | protected
m_Layout | CXTPCalendarViewGroup | protected
m_pResources | CXTPCalendarViewGroup | protected
m_pViewDay | CXTPCalendarViewGroup | protected
OnBeforeDestroy() | CXTPCalendarWMHandler | virtual
OnChar(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnKeyUp(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnLButtonDblClk(UINT nFlags, CPoint point) | CXTPCalendarWMHandler | virtual
OnLButtonDown(UINT nFlags, CPoint point) | CXTPCalendarWMHandler | virtual
OnLButtonUp(UINT nFlags, CPoint point) | CXTPCalendarWMHandler | virtual
OnMouseMove(UINT nFlags, CPoint point) | CXTPCalendarWMHandler | virtual
OnPostAdjustLayout() | CXTPCalendarWMHandler | virtual
OnPrePopulate(CXTPCalendarEvents *pEvents) | CXTPCalendarViewGroup | protectedvirtual
OnSysKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnTimer(UINT_PTR uTimerID) | CXTPCalendarWMHandler | virtual
OnWndMsg(UINT message, WPARAM wParam, LPARAM lParam, LRESULT *pResult) | CXTPCalendarWMHandler | virtual
Populate(COleDateTime dtDayDate) | CXTPCalendarViewGroup | virtual
SetResources(CXTPCalendarResources *pResources) | CXTPCalendarViewGroup | virtual
SetTimer(UINT uTimeOut_ms) | CXTPCalendarViewGroup | protectedvirtual
TBase typedef | CXTPCalendarWeekViewGroup |
TViewDay typedef | CXTPCalendarViewGroupT< CXTPCalendarWeekViewDay, CXTPCalendarWeekViewEvent, CXTPCalendarWeekViewGroup > |
~CXTPCalendarViewGroup() | CXTPCalendarViewGroup | virtual
~CXTPCalendarViewGroupT() | CXTPCalendarViewGroupT< CXTPCalendarWeekViewDay, CXTPCalendarWeekViewEvent, CXTPCalendarWeekViewGroup > | inlinevirtual
~CXTPCalendarWeekViewGroup() | CXTPCalendarWeekViewGroup | virtual


Toolkit Pro: Member List

CXTPChart3dPieSeriesLabel Member List

This is the complete list of members for CXTPChart3dPieSeriesLabel, including all inherited members.

CreateView(CXTPChartDeviceContext *pDC, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView) | CXTPChart3dPieSeriesLabel | protectedvirtual
CXTPChart3dPieSeriesLabel() | CXTPChart3dPieSeriesLabel |
CXTPChartElement() | CXTPChartElement |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartPieSeriesLabelBase() | CXTPChartPieSeriesLabelBase |
CXTPChartSeriesLabel() | CXTPChartSeriesLabel |
DoPropExchange(CXTPPropExchange *pPX) | CXTPChartPieSeriesLabelBase | virtual
GetAntialiasing() const | CXTPChartSeriesLabel | virtual
GetAppearance() const | CXTPChartElement |
GetBackColor() const | CXTPChartSeriesLabel |
GetContent() const | CXTPChartElement |
GetFont() const | CXTPChartSeriesLabel | virtual
GetFormat() const | CXTPChartSeriesLabel |
GetLineColor() const | CXTPChartSeriesLabel |
GetLineLength() const | CXTPChartSeriesLabel |
GetOwner() const | CXTPChartElement |
GetPosition() const | CXTPChartPieSeriesLabelBase |
GetShowLines() const | CXTPChartSeriesLabel |
GetStyle() const | CXTPChartPieSeriesLabelBase |
GetTextColor() const | CXTPChartSeriesLabel |
GetTransparency() const | CXTPChartSeriesLabel |
Is3D() const | CXTPChartObject |
IsInside() const | CXTPChartPieSeriesLabelBase |
IsVisible() const | CXTPChartSeriesLabel |
m_bAntialiasing | CXTPChartSeriesLabel | protected
m_bShowLines | CXTPChartSeriesLabel | protected
m_bVisible | CXTPChartSeriesLabel | protected
m_clrBackColor | CXTPChartSeriesLabel | protected
m_clrLineColor | CXTPChartSeriesLabel | protected
m_clrTextColor | CXTPChartSeriesLabel | protected
m_nLineLength | CXTPChartSeriesLabel | protected
m_nPosition | CXTPChartPieSeriesLabelBase | protected
m_nTransparency | CXTPChartSeriesLabel | protected
m_pBorder | CXTPChartSeriesLabel | protected
m_pFont | CXTPChartSeriesLabel | protected
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartElement | virtual
Release() | CXTPChartElement | virtual
SetAntialiasing(BOOL bAntialiasing) | CXTPChartSeriesLabel |
SetBackColor(const CXTPChartColor &clrBackColor) | CXTPChartSeriesLabel |
SetFont(CXTPChartFont *pFont) | CXTPChartSeriesLabel |
SetFormat(LPCTSTR lpszFormat) | CXTPChartSeriesLabel |
SetLineColor(const CXTPChartColor &clrBackColor) | CXTPChartSeriesLabel |
SetLineLength(int nLineLength) | CXTPChartSeriesLabel |
SetPosition(XTPChartPieLabelPosition nPosition) | CXTPChartPieSeriesLabelBase |
SetShowLines(BOOL bShowLines) | CXTPChartSeriesLabel |
SetTextColor(const CXTPChartColor &clrTextColor) | CXTPChartSeriesLabel |
SetTransparency(int nTransparency) | CXTPChartSeriesLabel |
SetVisible(BOOL bVisible) | CXTPChartSeriesLabel |
~CXTPChartElement() | CXTPChartElement | virtual
~CXTPChartPieSeriesLabelBase() | CXTPChartPieSeriesLabelBase | virtual
~CXTPChartSeriesLabel() | CXTPChartSeriesLabel | virtual


Toolkit Pro: XTPFlowGraphNodeCustom.h Source File

  • Source
  • FlowGraph
XTPFlowGraphNodeCustom.h
Go to the documentation of this file.
1
23#if !defined(__XTPFLOWGRAPHNODECUSTOM_H__)
24# define __XTPFLOWGRAPHNODECUSTOM_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPMarkupPath;
34class CXTPMarkupPathData;
35
36# define XAML_MARKUP_TAG_NODEPATH L"nodePath"
37# define XAML_MARKUP_TAG_NODECANVAS L"nodeCanvas"
38# define XAML_MARKUP_TAG_NODEBORDER L"nodeBorder"
39
40# define XAML_MARKUP_PROPERTY_CONNECTIONPOINTS_AS_RHOMBUS L"Rhombus"
41# define XAML_MARKUP_PROPERTY_CONNECTIONPOINTS_IN_CENTER L"Center"
42
49enum XTPFlowGraphCustomNodeCaptionPosition
50{
51 xtpFlowGraphCustomNodeCaptionCenter = 0,
52 xtpFlowGraphCustomNodeCaptionBelow
53};
54
59enum XTPFlowGraphCustomNodeFillType
60{
61 xtpFlowGraphCustomNodeFillSolid = 0,
62 xtpFlowGraphCustomNodeFillGradientHorizontal,
63 xtpFlowGraphCustomNodeFillGradientVertical,
64 xtpFlowGraphCustomNodeFillGradientDiagonalLeft,
66 xtpFlowGraphCustomNodeFillGradientDiagonalRight,
68 xtpFlowGraphCustomNodeFillGradientCenterHorizontal,
70 xtpFlowGraphCustomNodeFillGradientCenterVertical
72};
73
93class _XTP_EXT_CLASS CXTPFlowGraphNodeCustom : public CXTPFlowGraphNode
94{
96 DECLARE_SERIAL(CXTPFlowGraphNodeCustom);
98protected:
107 CXTPMarkupPathData* CreateStretchedPathData(const CXTPMarkupPath* pNodePath) const;
108
116 CRect GetPointRect(CPoint point) const;
117
118public:
123 CXTPFlowGraphNodeCustom();
124
130 ~CXTPFlowGraphNodeCustom();
131
137 void SetCaptionPosition(XTPFlowGraphCustomNodeCaptionPosition pos);
138
145 XTPFlowGraphCustomNodeCaptionPosition GetCaptionPosition() const;
146
153 CRect GetSelectionRect();
154
155public:
156 // virtual methods of CXTPFlowGraphNode
157
158 // custom controls cannot be placed inside custom nodes. Virtual methods below must be empty
159
160 virtual void SetWindowHandle(HWND)
161 {
162 }
163 virtual void SetWindowSize(CSize)
164 {
165 }
166 virtual void UpdateWindowPosition()
167 {
168 }
169 virtual void DrawWindowContent(CXTPFlowGraphDrawContext*)
170 {
171 }
172
173 virtual void UpdateMarkupPointColor(CXTPFlowGraphConnectionPoint*)
174 {
175 }
176
177 virtual void SetDefaultMarkup(){}; // no default markup for a custom node
178
179 virtual void SetColor(COLORREF clr, BYTE bAlpha = 255);
180
181 virtual BOOL IsCustomMarkup() const
182 {
183 return TRUE;
184 }
185
186 virtual void SetSize(CSize sz);
187
188 virtual void AddNamedConnectionPoints(
189 LPCTSTR /*szName*/, XTPFlowGraphConnectionPointType /*type = xtpFlowGraphPointNone*/,
190 LPCTSTR /*szCaption = NULL*/)
191 {
192 } // you cannot add connection points manually
193
194 virtual void UpdateConnectionPoints(CXTPMarkupObject* pRootElement);
195
196 virtual void UpdateColorRecursive(CXTPMarkupObject* pRootElement, COLORREF clrColor);
197
198 virtual CRect GetBoundingRectangle(BOOL bIncludeConnectionPointsEllipses = TRUE) const;
199
200 virtual CXTPMarkupTextBlock* UpdateMarkupCaption();
201
202 virtual void UpdateCaptionColor();
203
204 virtual void CalcMinSize();
205
206 virtual void DoPropExchange(CXTPPropExchange* pPX);
207
208 virtual CXTPFlowGraphConnectionPoint* HitTestConnectionPoint(CPoint point);
209
210public:
211 // alpha for gradients is not yet supported by the markup engine
212 // http://msdn.microsoft.com/en-us/library/ms743320.aspx
213
214 void SetColor(COLORREF clrOne, COLORREF clrTwo, XTPFlowGraphCustomNodeFillType fType,
215 BYTE bAlpha = 255);
216
217 COLORREF GetSecondColor() const;
218
219 void SetSecondColor(COLORREF clrSecondColor);
220
221 XTPFlowGraphCustomNodeFillType GetFillType() const;
222
223 void SetFillType(XTPFlowGraphCustomNodeFillType newType);
224
225protected:
226 XTPFlowGraphCustomNodeCaptionPosition m_CaptionPosition;
227
228 COLORREF m_clrSecondColor;
229
230 XTPFlowGraphCustomNodeFillType m_FillType;
231
232public:
233# ifdef _XTP_ACTIVEX
236 DECLARE_DISPATCH_MAP()
237 DECLARE_INTERFACE_MAP()
238
239 DECLARE_OLETYPELIB_EX(CXTPFlowGraphNodeCustom)
240
241 afx_msg void OleSetCaptionPosition(int nStyle);
242 afx_msg int OleGetCaptionPosition();
243
244 afx_msg void OleSetMarkupText(LPCTSTR lpszMarkupText);
245 afx_msg BSTR OleGetMarkupText();
246
247 afx_msg void OleSetSecondColor(OLE_COLOR clr);
248 afx_msg OLE_COLOR OleGetSecondColor();
249
250 afx_msg void OleSetFillType(int nType);
251 afx_msg int OleGetFillType();
252
254# endif
255};
257# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
258#endif //#if !defined(__XTPFLOWGRAPHNODECUSTOM_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPFlowGraphConnectionPointType
XTPFlowGraphConnectionPointType
Node connection point types (input/output).
Definition XTPFlowGraphNode.h:85
XTPFlowGraphCustomNodeCaptionPosition
XTPFlowGraphCustomNodeCaptionPosition
Defines the position for a caption of a custom markup node.
Definition XTPFlowGraphNodeCustom.h:50
xtpFlowGraphCustomNodeCaptionBelow
@ xtpFlowGraphCustomNodeCaptionBelow
Below the shape.
Definition XTPFlowGraphNodeCustom.h:52
xtpFlowGraphCustomNodeCaptionCenter
@ xtpFlowGraphCustomNodeCaptionCenter
Center of the shape; default behavior.
Definition XTPFlowGraphNodeCustom.h:51
XTPFlowGraphCustomNodeFillType
XTPFlowGraphCustomNodeFillType
Path (figure) fill type.
Definition XTPFlowGraphNodeCustom.h:60
xtpFlowGraphCustomNodeFillGradientCenterHorizontal
@ xtpFlowGraphCustomNodeFillGradientCenterHorizontal
Specifies a center horizontal gradient fill type.
Definition XTPFlowGraphNodeCustom.h:68
xtpFlowGraphCustomNodeFillSolid
@ xtpFlowGraphCustomNodeFillSolid
Specifies a solid fill type.
Definition XTPFlowGraphNodeCustom.h:61
xtpFlowGraphCustomNodeFillGradientCenterVertical
@ xtpFlowGraphCustomNodeFillGradientCenterVertical
Specifies a center verticl gradient fill type.
Definition XTPFlowGraphNodeCustom.h:70
xtpFlowGraphCustomNodeFillGradientDiagonalRight
@ xtpFlowGraphCustomNodeFillGradientDiagonalRight
Specifies a right diagonal gradient fill type.
Definition XTPFlowGraphNodeCustom.h:66
xtpFlowGraphCustomNodeFillGradientDiagonalLeft
@ xtpFlowGraphCustomNodeFillGradientDiagonalLeft
Specifies a left diagonal gradient fill type.
Definition XTPFlowGraphNodeCustom.h:64
xtpFlowGraphCustomNodeFillGradientHorizontal
@ xtpFlowGraphCustomNodeFillGradientHorizontal
Specifies a horizontal gradient fill type.
Definition XTPFlowGraphNodeCustom.h:62
xtpFlowGraphCustomNodeFillGradientVertical
@ xtpFlowGraphCustomNodeFillGradientVertical
Specifies a vertical gradient fill type.
Definition XTPFlowGraphNodeCustom.h:63
CXTPFlowGraphConnectionPoint
Represents a connection point for a node.
Definition XTPFlowGraphConnectionPoint.h:46
CXTPFlowGraphNodeCustom
Represents a Node object defined by custom XAML markup.
Definition XTPFlowGraphNodeCustom.h:94
CXTPFlowGraphNodeCustom::GetCaptionPosition
XTPFlowGraphCustomNodeCaptionPosition GetCaptionPosition() const
Gets the Node's caption position.
CXTPFlowGraphNodeCustom::DoPropExchange
virtual void DoPropExchange(CXTPPropExchange *pPX)
Call this member function to store/load a Node using the specified data object.
CXTPFlowGraphNodeCustom::UpdateCaptionColor
virtual void UpdateCaptionColor()
Updates the foreground color of the CXTPMarkupTextBlock element of the Node's caption.
CXTPFlowGraphNodeCustom::~CXTPFlowGraphNodeCustom
~CXTPFlowGraphNodeCustom()
Destroys a CXTPFlowGraphNodeCustom object, handles cleanup and deallocation.
CXTPFlowGraphNodeCustom::SetDefaultMarkup
virtual void SetDefaultMarkup()
Sets the default XAML Markup for a default Node with zero table rows.
Definition XTPFlowGraphNodeCustom.h:177
CXTPFlowGraphNodeCustom::CalcMinSize
virtual void CalcMinSize()
A virtual method that calculates the minimum size of the Node (used in resizing mechanism).
CXTPFlowGraphNodeCustom::CXTPFlowGraphNodeCustom
CXTPFlowGraphNodeCustom()
Constructs a CXTPFlowGraphNodeCustom object.
CXTPFlowGraphNodeCustom::GetPointRect
CRect GetPointRect(CPoint point) const
Retrieves a rectangle with a specified point in the center of it.
CXTPFlowGraphNodeCustom::SetCaptionPosition
void SetCaptionPosition(XTPFlowGraphCustomNodeCaptionPosition pos)
Sets the Node's caption position.
CXTPFlowGraphNodeCustom::AddNamedConnectionPoints
virtual void AddNamedConnectionPoints(LPCTSTR, XTPFlowGraphConnectionPointType, LPCTSTR)
Adds a table row to the Node (of default type), with none, one, or two real connection points.
Definition XTPFlowGraphNodeCustom.h:188
CXTPFlowGraphNodeCustom::UpdateWindowPosition
virtual void UpdateWindowPosition()
Updates the window position of the attached external control.
Definition XTPFlowGraphNodeCustom.h:166
CXTPFlowGraphNodeCustom::SetWindowSize
virtual void SetWindowSize(CSize)
Sets the size of the window for the external control that is attached to the Node (if applicable).
Definition XTPFlowGraphNodeCustom.h:163
CXTPFlowGraphNodeCustom::SetWindowHandle
virtual void SetWindowHandle(HWND)
Call this member to associate an object with the Node.
Definition XTPFlowGraphNodeCustom.h:160
CXTPFlowGraphNodeCustom::UpdateMarkupCaption
virtual CXTPMarkupTextBlock * UpdateMarkupCaption()
Updates Node's caption <TextBlock> element with Node's caption text (m_strCaption).
CXTPFlowGraphNodeCustom::GetSelectionRect
CRect GetSelectionRect()
Retrieves the Node's selection rectangle (visible only when the Node is selected).
CXTPFlowGraphNodeCustom::UpdateMarkupPointColor
virtual void UpdateMarkupPointColor(CXTPFlowGraphConnectionPoint *)
Updates the Markup point color (when changed or restored using DoPropExchange).
Definition XTPFlowGraphNodeCustom.h:173
CXTPFlowGraphNodeCustom::HitTestConnectionPoint
virtual CXTPFlowGraphConnectionPoint * HitTestConnectionPoint(CPoint point)
Determines which connection point, if any, is at a specified point.
CXTPFlowGraphNodeCustom::IsCustomMarkup
virtual BOOL IsCustomMarkup() const
A virtual function that determines if the Node is a custom Node (a Node with custom XAML markup).
Definition XTPFlowGraphNodeCustom.h:181
CXTPFlowGraphNodeCustom::UpdateConnectionPoints
virtual void UpdateConnectionPoints(CXTPMarkupObject *pRootElement)
A virtual method that finds and updates real connection points in the Markup.
CXTPFlowGraphNodeCustom::UpdateColorRecursive
virtual void UpdateColorRecursive(CXTPMarkupObject *pRootElement, COLORREF clrColor)
A recursive method to update/set the color of a Node.
CXTPFlowGraphNodeCustom::SetColor
virtual void SetColor(COLORREF clr, BYTE bAlpha=255)
Sets the color for the Node.
CXTPFlowGraphNodeCustom::SetSize
virtual void SetSize(CSize sz)
Sets the size for the Node (Node's Markup!).
CXTPFlowGraphNodeCustom::DrawWindowContent
virtual void DrawWindowContent(CXTPFlowGraphDrawContext *)
Draws the contents of the Node.
Definition XTPFlowGraphNodeCustom.h:169
CXTPFlowGraphNodeCustom::CreateStretchedPathData
CXTPMarkupPathData * CreateStretchedPathData(const CXTPMarkupPath *pNodePath) const
Retrieves a stretched path from a specified path based on the render size the Node.
CXTPFlowGraphNode
Represents a Node object.
Definition XTPFlowGraphNode.h:116
CXTPFlowGraphNode::SetColor
virtual void SetColor(COLORREF clr, BYTE bAlpha=255)
Sets the color for the Node.
CXTPMarkupTextBlock
CXTPMarkupTextBlock is a CXTPMarkupFrameworkElement derived class.
Definition XTPMarkupTextBlock.h:86
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72


Toolkit Pro: Member List

CXTPGaugeStateType Member List

This is the complete list of members for CXTPGaugeStateType, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPGaugeBaseType() | CXTPGaugeBaseType | protected
DumpTraits(CString &strTraits) const | CXTPGaugeBaseType |
EnableAutomaticUpdate(BOOL bEnable=TRUE) | CXTPGaugeBaseType |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetState() const | CXTPGaugeStateType |
GetStateCount() const | CXTPGaugeStateType |
GetTrait(LPCTSTR pJPath, COleVariant &vtValue) const | CXTPGaugeBaseType |
GetTypeName() const | CXTPGaugeStateType | virtual
InvokeAction(LPCTSTR lpName, const COleVariant &vtArg=COleVariant(), COleVariant *pvtResult=NULL) | CXTPGaugeBaseType |
IsAutomaticUpdateEnabled() const | CXTPGaugeBaseType |
SetState(UINT nState) | CXTPGaugeStateType |
SetTrait(LPCTSTR pJPath, const COleVariant &vtValue) | CXTPGaugeBaseType |
Update() | CXTPGaugeBaseType |
~CXTPGaugeBaseType() | CXTPGaugeBaseType |
~CXTPGaugeStateType() | CXTPGaugeStateType |


Toolkit Pro: Member List

CXTPChart3dFunnelSeriesLabelDeviceCommand Member List

This is the complete list of members for CXTPChart3dFunnelSeriesLabelDeviceCommand, including all inherited members.

AddChildCommand(CXTPChartDeviceCommand *pCommand) | CXTPChartDeviceCommand |
AfterExecute(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
ApplySeriesStyle(CXTPChartSeriesStyle *pStyle) | CXTPChartDeviceCommand | virtual
BeforeExecute(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
BindView(CXTPChartElementView *pView) | CXTPChartDeviceCommand |
Commit() | CXTPChartDeviceCommand |
ComputeConnectorVector(CXTPChart3dDeviceContext *pDC) | CXTPChart3dFunnelSeriesLabelDeviceCommand |
ComputeLabel(CXTPChart3dDeviceContext *pDC) | CXTPChart3dFunnelSeriesLabelDeviceCommand |
CXTPChart3dDeviceCommand(XTPChart3dAntialiasingPolicy nAntialiasingPolicy) | CXTPChart3dDeviceCommand | protected
CXTPChart3dFunnelSeriesLabelDeviceCommand(CXTPChart3dFunnelSeriesLabelView *pSeriesLabelView) | CXTPChart3dFunnelSeriesLabelDeviceCommand |
CXTPChartDeviceCommand() | CXTPChartDeviceCommand |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPObservable() | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | protected
Execute(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
ExecuteOverride(CXTPChartDeviceContext *pDC) | CXTPChart3dFunnelSeriesLabelDeviceCommand | virtual
GetBoundView() const | CXTPChartDeviceCommand |
GetChildCommand(int nIndex) const | CXTPChartDeviceCommand |
GetChildCommandCount() const | CXTPChartDeviceCommand |
GetConnectorEndpointVerticalOffset() const | CXTPChart3dFunnelSeriesLabelDeviceCommand |
GetConnectorLength() const | CXTPChart3dFunnelSeriesLabelDeviceCommand |
GetCurrentDC() const | CXTPChartDeviceCommand |
GetLabelRect() const | CXTPChart3dFunnelSeriesLabelDeviceCommand |
GetPassNumber() const | CXTPChartDeviceCommand |
GetSeriesLabelView() const | CXTPChart3dFunnelSeriesLabelDeviceCommand |
HitTest(CPoint point, CXTPChartElement *pParent) const | CXTPChartDeviceCommand | virtual
Is3D() const | CXTPChartObject |
IsCommitted() const | CXTPChartDeviceCommand |
IsEnabled() const | CXTPChart3dDeviceCommand | virtual
IsFailed() const | CXTPChart3dFunnelSeriesLabelDeviceCommand |
m_arrChildren | CXTPChartDeviceCommand | protected
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Prepare(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
PrepareOverride(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
SetConnectorEndpointVerticalOffset(double yOffset) | CXTPChart3dFunnelSeriesLabelDeviceCommand |
SetConnectorLength(double dLength) | CXTPChart3dFunnelSeriesLabelDeviceCommand |
SetEnabled(BOOL bEnabled=TRUE) | CXTPChartDeviceCommand |
SetFailed() | CXTPChart3dFunnelSeriesLabelDeviceCommand |
SetLabelRect(CRect rcLabel) | CXTPChart3dFunnelSeriesLabelDeviceCommand |
Subscribe(CXTPChartDeviceCommandEvents *pObserver, CXTPSubscriptionList< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > *pSubcriptionList=NULL) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > |
Unsubscribe(CXTPChartDeviceCommandEvents *pObserver) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > |
~CXTPChartDeviceCommand() | CXTPChartDeviceCommand | virtual
~CXTPObservable() | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | protected


Toolkit Pro: XTPShellListCtrlView.h Source File

  • Source
  • Controls
  • Shell
XTPShellListCtrlView.h
Go to the documentation of this file.
1
23#if !defined(__XTPSHELLLISTCTRLVIEW_H__)
24# define __XTPSHELLLISTCTRLVIEW_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33DECLARE_SHELLLIST_BASE(CXTPShellListViewBase, CListView, CXTPShellListBase)
34DECLARE_SHELLLIST_BASE(CXTPShellListCtrlBase, CListCtrl, CXTPShellListBase)
35
36
41class _XTP_EXT_CLASS CXTPShellListView : public CXTPShellListViewBase
42{
44 DECLARE_DYNCREATE(CXTPShellListView)
46public:
51 CXTPShellListView();
52
57 virtual ~CXTPShellListView();
58
59protected:
70 void OnDblclk(NMHDR* pNMHDR, LRESULT* pResult);
71
72protected:
74 DECLARE_MESSAGE_MAP()
75
76 //{{AFX_VIRTUAL(CXTPShellListView)
77 virtual BOOL PreCreateWindow(CREATESTRUCT& cs);
78 virtual void OnUpdate(CView* pSender, LPARAM lHint, CObject* pHint);
79 //}}AFX_VIRTUAL
80
81 //{{AFX_MSG(CXTPShellListView)
82 afx_msg LRESULT OnUpdateShell(WPARAM wParam, LPARAM lParam);
83 afx_msg void OnKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags);
84 //}}AFX_MSG
86};
87
93class _XTP_EXT_CLASS CXTPShellListCtrl : public CXTPShellListCtrlBase
94{
95public:
100 CXTPShellListCtrl();
101
106 virtual ~CXTPShellListCtrl();
107
108public:
114 virtual void AssociateTree(CWnd* pWnd);
115
116protected:
118 DECLARE_MESSAGE_MAP()
119
120 //{{AFX_MSG(CXTPShellListCtrl)
121 afx_msg void OnDblclk(NMHDR* pNMHDR, LRESULT* pResult);
122 afx_msg LRESULT OnUpdateShell(WPARAM wParam, LPARAM lParam);
123 afx_msg void OnKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags);
124 //}}AFX_MSG
127protected:
128 CWnd* m_pTreeCtrl;
130 bool m_bInitControl;
131};
132
134# define CXTPShellList CXTPShellListCtrl
138
139AFX_INLINE void CXTPShellListCtrl::AssociateTree(CWnd* pWnd)
140{
141 _ASSERTE(pWnd);
142 m_pTreeCtrl = pWnd;
143}
152class _XTP_EXT_CLASS CXTPShellListCtrlEx : public CXTPShellListCtrl
153{
154public:
159 CXTPShellListCtrlEx();
160
165 virtual ~CXTPShellListCtrlEx();
166
167public:
175 bool BrowseToFolder(LPCTSTR lpszPath);
176
185 void SetSyncWnd(CWnd* pSyncWnd);
186
187protected:
189 DECLARE_MESSAGE_MAP()
190
191 //{{AFX_VIRTUAL(CXTPShellListCtrlEx)
192 //}}AFX_VIRTUAL
193
194 //{{AFX_MSG(CXTPShellListCtrlEx)
195 afx_msg void OnLButtonDblClk(UINT nFlags, CPoint point);
196 //}}AFX_MSG
199protected:
200 CWnd* m_pSyncWnd;
201 CString m_strItemPath;
203};
204
206
207AFX_INLINE void CXTPShellListCtrlEx::SetSyncWnd(CWnd* pSyncWnd)
208{
209 m_pSyncWnd = pSyncWnd;
210}
212# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
214#endif // !defined(__XTPSHELLLISTCTRLVIEW_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPShellListBase
CXTPShellListBase is a multiple inheritance class derived from CXTPListView and CXTPShellPidl.
Definition XTPShellListBase.h:43
CXTPShellListCtrlEx
CXTPShellListCtrlEx is a CXTPShellListCtrl derived class.
Definition XTPShellListCtrlView.h:153
CXTPShellListCtrlEx::SetSyncWnd
void SetSyncWnd(CWnd *pSyncWnd)
This member function will associate a CWnd object with the shell list control.
CXTPShellListCtrlEx::CXTPShellListCtrlEx
CXTPShellListCtrlEx()
Constructs a CXTPShellListCtrlEx object.
CXTPShellListCtrlEx::~CXTPShellListCtrlEx
virtual ~CXTPShellListCtrlEx()
Destroys a CXTPShellListCtrlEx object, handles cleanup and deallocation.
CXTPShellListCtrlEx::BrowseToFolder
bool BrowseToFolder(LPCTSTR lpszPath)
This member function is called to browse to a particular file folder.
CXTPShellListCtrl
CXTPShellListCtrl is a multiple inheritance class derived from CXTPListCtrl and CXTPShellPidl.
Definition XTPShellListCtrlView.h:94
CXTPShellListCtrl::m_pTreeCtrl
CWnd * m_pTreeCtrl
Window that receives update notification, usually a CXTPShellTreeCtrl.
Definition XTPShellListCtrlView.h:128
CXTPShellListCtrl::~CXTPShellListCtrl
virtual ~CXTPShellListCtrl()
Destroys a CXTPShellListCtrl object, handles cleanup and deallocation.
CXTPShellListCtrl::AssociateTree
virtual void AssociateTree(CWnd *pWnd)
Call this member function to associate the tree control with the list.
CXTPShellListCtrl::CXTPShellListCtrl
CXTPShellListCtrl()
Constructs a CXTPShellListCtrl object.
CXTPShellListView
CXTPShellListView is a multiple inheritance class derived from CXTPListView and CXTPShellPidl.
Definition XTPShellListCtrlView.h:42
CXTPShellListView::OnDblclk
void OnDblclk(NMHDR *pNMHDR, LRESULT *pResult)
Occurs when the user double clicks on the list control.
CXTPShellListView::~CXTPShellListView
virtual ~CXTPShellListView()
Destroys a CXTPShellListView object, handles cleanup and deallocation.
CXTPShellListView::CXTPShellListView
CXTPShellListView()
Constructs a CXTPShellListView object.


Toolkit Pro: Member List

CXTPDockingPaneAutoHideWnd Member List

This is the complete list of members for CXTPDockingPaneAutoHideWnd, including all inherited members.

GetPane() const | CXTPDockingPaneAutoHideWnd |
m_dAnimationDelay | CXTPDockingPaneAutoHideWnd | static
m_nAnimationDuration | CXTPDockingPaneAutoHideWnd | static
m_nAnimationInterval | CXTPDockingPaneAutoHideWnd | static
m_nInactiveCollapseDelay | CXTPDockingPaneAutoHideWnd | static
m_nMouseHoverDelay | CXTPDockingPaneAutoHideWnd | static


Toolkit Pro: XTPMarkupEllipse.h Source File

  • Source
  • Markup
  • Shapes
XTPMarkupEllipse.h
Go to the documentation of this file.
1
23#if !defined(__XTPMARKUPELLIPSE_H__)
24# define __XTPMARKUPELLIPSE_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPMarkupDrawingContext;
34class CXTPMarkupInputElement;
35
36class _XTP_EXT_CLASS CXTPMarkupEllipse : public CXTPMarkupShape
37{
39 DECLARE_MARKUPCLASS(CXTPMarkupEllipse)
41protected:
42 CXTPMarkupEllipse();
43 ~CXTPMarkupEllipse();
44
45protected:
46 virtual CSize MeasureOverride(CXTPMarkupDrawingContext* pDC, CSize szAvailableSize);
47 virtual void OnRender(CXTPMarkupDrawingContext* pDC);
48
49 virtual CXTPMarkupInputElement* InputHitTestOverride(CPoint point) const;
50
51public:
53public:
54 DECLARE_DISPATCH_MAP()
55# ifdef _XTP_ACTIVEX
56 DECLARE_INTERFACE_MAP()
57 DECLARE_OLETYPELIB_EX(CXTPMarkupEllipse);
58# endif
59
61};
62
63# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
65#endif // !defined(__XTPMARKUPELLIPSE_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPMarkupVisual::InputHitTestOverride
virtual CXTPMarkupInputElement * InputHitTestOverride(CPoint point) const
Override this method in the derived class to provide visual hit testing of a child object.
CXTPMarkupVisual::OnRender
virtual void OnRender(CXTPMarkupDrawingContext *drawingContext)
When overridden in a derived class, participates in rendering operations that are directed by the lay...
Definition XTPMarkupInputElement.h:515


Toolkit Pro: Member List

CXTPTaskPanelPaintManagerPlain Member List

This is the complete list of members for CXTPTaskPanelPaintManagerPlain, including all inherited members.

BlendColor(COLORREF clrFrom, COLORREF clrTo, int nAlpha) | CXTPTaskPanelPaintManager | protected
CreateGripperBitmaps() | CXTPTaskPanelPaintManager | protected
CreateGripperIcon(HICON &hIcon, UINT nIDResource, COLORREF clrGripperBack) | CXTPTaskPanelPaintManager | protected
CXTPTaskPanelPaintManager() | CXTPTaskPanelPaintManager |
CXTPTaskPanelPaintManagerPlain() | CXTPTaskPanelPaintManagerPlain |
DrawCaptionGripper(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelPaintManager | protectedvirtual
DrawCaptionGripperBitmap(CDC *pDC, CXTPTaskPanelGroup *pGroup, BOOL bExpanded, BOOL bHot, CRect rc) | CXTPTaskPanelPaintManager | protected
DrawCaptionGripperSigns(CDC *pDC, CPoint pt, COLORREF clr, BOOL bExpanded) | CXTPTaskPanelPaintManager | protected
DrawDragArrow(CDC *pDC, CXTPTaskPanelItem *pItem, CRect rc, BOOL bAfter=FALSE) | CXTPTaskPanelPaintManager | protectedvirtual
DrawFocusRect(CDC *pDC, CRect rc) | CXTPTaskPanelPaintManager | protectedvirtual
DrawGroupCaption(CDC *pDC, CXTPTaskPanelGroup *pGroup, BOOL bDraw) | CXTPTaskPanelPaintManagerPlain | virtual
DrawGroupClient(CDC *pDC, CXTPTaskPanelGroup *pGroup) | CXTPTaskPanelPaintManager | virtual
DrawGroupClientFace(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelPaintManagerPlain | virtual
DrawGroupClientItems(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelPaintManager | protectedvirtual
DrawGroupItem(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw) | CXTPTaskPanelPaintManager | virtual
DrawGroupItemFrame(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc) | CXTPTaskPanelPaintManager | virtual
DrawGroupItemImage(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw) | CXTPTaskPanelPaintManager | protected
DrawGroupItemImageWithText(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw) | CXTPTaskPanelPaintManager | protected
DrawGroupItemImageWithTextBelow(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw) | CXTPTaskPanelPaintManager | protected
DrawItemCaption(CDC *pDC, CXTPTaskPanelItem *pItem, CRect rcText, UINT nFormat) | CXTPTaskPanelPaintManager | protectedvirtual
DrawItemImage(CDC *pDC, CXTPTaskPanelItem *pItem, CPoint ptIcon, CXTPImageManagerIcon *pImage, CSize szIcon) | CXTPTaskPanelPaintManager | protectedvirtual
DrawScrollButton(CDC *pDC, CXTPTaskPanelScrollButton *pScrollButton) | CXTPTaskPanelPaintManager | virtual
FillGroupClientFace(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelPaintManagerPlain | virtual
FillTaskPanel(CDC *pDC, CXTPTaskPanel *pTaskPanel) | CXTPTaskPanelPaintManagerPlain | virtual
FreeBitmaps() | CXTPTaskPanelPaintManager | protected
GetCaptionGripperWidth(CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelPaintManager | protectedvirtual
GetControlMargins(const CXTPTaskPanel *pPanel) | CXTPTaskPanelPaintManager | virtual
GetGroupColors(BOOL bSpecial) | CXTPTaskPanelPaintManager |
GetGroupColors(CXTPTaskPanelGroup *pGroup) | CXTPTaskPanelPaintManager | virtual
GetGroupInnerMargins(const CXTPTaskPanelGroup *pGroup) | CXTPTaskPanelPaintManager | virtual
GetGroupOuterMargins(const CXTPTaskPanelGroup *pGroup) | CXTPTaskPanelPaintManager | virtual
GetGroupSpacing(const CXTPTaskPanel *pPanel) | CXTPTaskPanelPaintManager | virtual
GetHighlightOffset(CXTPTaskPanelGroupItem *pItem) | CXTPTaskPanelPaintManager | protectedvirtual
GetItemFont(CXTPTaskPanelItem *pItem) | CXTPTaskPanelPaintManager | virtual
GetItemIconPadding(const CXTPTaskPanelItem *pItem) | CXTPTaskPanelPaintManager | virtual
GetItemInnerMargins(const CXTPTaskPanelGroupItem *pItem) | CXTPTaskPanelPaintManager | virtual
GetItemOuterMargins(const CXTPTaskPanelGroupItem *pItem) | CXTPTaskPanelPaintManager | virtual
m_bBoldCaption | CXTPTaskPanelPaintManager |
m_bCaptionScrollButton | CXTPTaskPanelPaintManager |
m_bEmbossedDisabledText | CXTPTaskPanelPaintManager |
m_bEmulateEplorerTheme | CXTPTaskPanelPaintManager |
m_bInvertDragRect | CXTPTaskPanelPaintManager |
m_bLeftRoundedCorner | CXTPTaskPanelPaintManager | protected
m_bmpGrippers | CXTPTaskPanelPaintManager | protected
m_bOfficeBorder | CXTPTaskPanelPaintManager | protected
m_bOfficeCaption | CXTPTaskPanelPaintManagerPlain | protected
m_bOfficeHighlight | CXTPTaskPanelPaintManager |
m_bRightRoundedCorner | CXTPTaskPanelPaintManager | protected
m_bRoundedFrame | CXTPTaskPanelPaintManagerPlain | protected
m_bUseBitmapGrippers | CXTPTaskPanelPaintManager | protected
m_bUseStandardCaptionFont | CXTPTaskPanelPaintManager | protected
m_bUseStandardItemsFont | CXTPTaskPanelPaintManager | protected
m_clrBackground | CXTPTaskPanelPaintManager | protected
m_clrHighlightBorder | CXTPTaskPanelPaintManager | protected
m_clrHighlightHot | CXTPTaskPanelPaintManager | protected
m_clrHighlightPressed | CXTPTaskPanelPaintManager | protected
m_clrHighlightSelected | CXTPTaskPanelPaintManager | protected
m_eGripper | CXTPTaskPanelPaintManager |
m_groupNormal | CXTPTaskPanelPaintManager | protected
m_groupSpecial | CXTPTaskPanelPaintManager | protected
m_hGripperNormal | CXTPTaskPanelPaintManager | protected
m_hGripperSpecial | CXTPTaskPanelPaintManager | protected
m_nCaptionHeight | CXTPTaskPanelPaintManager | protected
m_nCaptionTextFormat | CXTPTaskPanelPaintManager | protected
m_nGroupSpacing | CXTPTaskPanelPaintManager |
m_nItemTextFormat | CXTPTaskPanelPaintManager | protected
m_rcControlMargins | CXTPTaskPanelPaintManager |
m_rcGroupIconPadding | CXTPTaskPanelPaintManager |
m_rcGroupInnerMargins | CXTPTaskPanelPaintManager |
m_rcGroupOuterMargins | CXTPTaskPanelPaintManager |
m_rcImageLayoutIconPadding | CXTPTaskPanelPaintManager |
m_rcItemIconPadding | CXTPTaskPanelPaintManager |
m_rcItemInnerMargins | CXTPTaskPanelPaintManager |
m_rcItemOuterMargins | CXTPTaskPanelPaintManager |
m_xtpFontCaption | CXTPTaskPanelPaintManager | protected
m_xtpFontIcon | CXTPTaskPanelPaintManager | protected
m_xtpFontIconBold | CXTPTaskPanelPaintManager | protected
m_xtpFontIconHot | CXTPTaskPanelPaintManager | protected
m_xtpFontIconHotBold | CXTPTaskPanelPaintManager | protected
Rectangle(CDC *pDC, CRect rc, COLORREF clrPen, COLORREF clrBrush) | CXTPTaskPanelPaintManager | protected
rectDefault | CXTPTaskPanelPaintManager | static
RefreshMetrics() | CXTPTaskPanelPaintManagerPlain | virtual
SetCaptionFontIndirect(LOGFONT *pLogFont, BOOL bUseStandardCaptionFont=FALSE) | CXTPTaskPanelPaintManager |
SetItemsFontIndirect(LOGFONT *pLogFont, BOOL bUseStandardItemsFont=FALSE) | CXTPTaskPanelPaintManager |
SetTextFormat(int nTextFormat, BOOL bCaption=FALSE) | CXTPTaskPanelPaintManager |
~CXTPTaskPanelPaintManager() | CXTPTaskPanelPaintManager | virtual


Toolkit Pro: Member List

CXTPSkinObjectTrackBar Member List

This is the complete list of members for CXTPSkinObjectTrackBar, including all inherited members.

CXTPSkinObject() | CXTPSkinObject | protected
CXTPSkinObjectFrame() | CXTPSkinObjectFrame |
CXTPSkinObjectTrackBar() | CXTPSkinObjectTrackBar |
GetAccessCriticalSection() const | CXTPSynchronized | inline
GetBorders() const | CXTPSkinObjectFrame |
GetCaptionButtons() | CXTPSkinObjectFrame |
GetClassName() const | CXTPSkinObject |
GetClientBrush(CDC *pDC) | CXTPSkinObjectFrame | virtual
GetColor(int nIndex) const | CXTPSkinObject |
GetMetrics() const | CXTPSkinObject |
GetSkinClass() const | CXTPSkinObject |
GetSkinManager() const | CXTPSkinObject |
IsActive() const | CXTPSkinObjectFrame |
m_arrButtons | CXTPSkinObjectFrame | protected
m_bActive | CXTPSkinObjectFrame | protected
m_bActiveX | CXTPSkinObject | protected
m_bLockFrameDraw | CXTPSkinObjectFrame |
m_bMDIClient | CXTPSkinObjectFrame | protected
m_bRegionChanged | CXTPSkinObjectFrame | protected
m_bWindowsForms | CXTPSkinObject | protected
m_dwDialogTexture | CXTPSkinObjectFrame |
m_dwExStyle | CXTPSkinObjectFrame | protected
m_dwStyle | CXTPSkinObjectFrame | protected
m_pButtonHot | CXTPSkinObjectFrame | protected
m_pButtonPressed | CXTPSkinObjectFrame | protected
m_pManager | CXTPSkinObject | protected
m_pOldWndProc | CXTPSkinObject | protected
m_pSBTrack | CXTPSkinObjectFrame | protected
m_rcBorders | CXTPSkinObjectFrame | protected
m_spi | CXTPSkinObjectFrame | protected
m_strClassName | CXTPSkinObject | protected
m_szFrameRegion | CXTPSkinObjectFrame | protected
OnHookAttached(LPCREATESTRUCT lpcs, BOOL bAuto) | CXTPSkinObjectFrame | protectedvirtual
OnHookDetached(BOOL bAuto) | CXTPSkinObjectFrame | protectedvirtual
OnSkinChanged(BOOL bPrevState, BOOL bNewState) | CXTPSkinObjectFrame | protectedvirtual
RedrawScrollBar(int nBar) | CXTPSkinObjectFrame |
RefreshMetrics() | CXTPSkinObjectFrame | protectedvirtual
~CXTPSkinObject() | CXTPSkinObject | protected
~CXTPSkinObjectFrame() | CXTPSkinObjectFrame | virtual
~CXTPSkinObjectTrackBar() | CXTPSkinObjectTrackBar | virtual


Toolkit Pro: XTPDockingPaneColorSet2022.h Source File

  • Source
  • DockingPane
  • ColorSets
XTPDockingPaneColorSet2022.h
Go to the documentation of this file.
1
23#if !defined(__XTPDOCKINGPANECOLORSET2022_H__)
24# define __XTPDOCKINGPANECOLORSET2022_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPDockingPaneColorSet2022 : public CXTPDockingPaneColorSet
39{
40public:
47 virtual void RefreshMetrics(CString strSection);
48};
49
50# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
52#endif // !defined(__XTPDOCKINGPANECOLORSET2022_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPDockingPaneColorSet2022
Helper class used to initialize default colors for a theme from an .INI resource.
Definition XTPDockingPaneColorSet2022.h:39
CXTPDockingPaneColorSet2022::RefreshMetrics
virtual void RefreshMetrics(CString strSection)
This member function is used to initialize default colors for a theme from an .INI resource.
CXTPDockingPaneColorSet
Helper class used to initialize default colors for a theme from an .INI resource.
Definition XTPDockingPaneColorSet.h:39


Toolkit Pro: XTPMarkupEventHandlerMap.h Source File

  • Source
  • Markup
XTPMarkupEventHandlerMap.h
Go to the documentation of this file.
1
23#if !defined(__XTPMARKUPEVENTHANDLERMAP_H__)
24# define __XTPMARKUPEVENTHANDLERMAP_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class _XTP_EXT_CLASS CXTPMarkupEventHandlerMap
34{
35public:
36 CXTPMarkupEventHandlerMap();
37 ~CXTPMarkupEventHandlerMap();
38
39public:
40 void Add(CXTPMarkupRoutedEvent* pEvent, CXTPMarkupDelegate* pDelegate);
41 BOOL Remove(CXTPMarkupRoutedEvent* pEvent, CXTPMarkupDelegate* pDelegate);
42 void RemoveAll();
43 void Raise(CXTPMarkupObject* pSender, CXTPMarkupRoutedEventArgs* pEventArgs);
44
45protected:
46 CMap<CXTPMarkupRoutedEvent*, CXTPMarkupRoutedEvent*, CPtrList*, CPtrList*> m_mapHandlers;
47};
48
49# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
51#endif // !defined(__XTPMARKUPEVENTHANDLERMAP_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h


Toolkit Pro: Member List

CXTPChartAxisAppearance Member List

This is the complete list of members for CXTPChartAxisAppearance, including all inherited members.

ApplyToDeviceContext(CXTPChartDeviceContext *pDC) | CXTPChartElementAppearance | virtual
AxisLabelTextColor | CXTPChartAxisAppearance |
AxisTitleTextColor | CXTPChartAxisAppearance |
Color | CXTPChartAxisAppearance |
ConstantLineColor | CXTPChartAxisAppearance |
ConstantLineTextColor | CXTPChartAxisAppearance |
CXTPChartAxisAppearance(CXTPChartElement *pOwner) | CXTPChartAxisAppearance |
CXTPChartElement() | CXTPChartElement |
CXTPChartElementAppearance(CXTPChartElement *pOwner) | CXTPChartElementAppearance |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
DoPropExchange(CXTPPropExchange *pPX) | CXTPChartAxisAppearance | virtual
GetAppearance() const | CXTPChartElement |
GetContent() const | CXTPChartElement |
GetOwner() const | CXTPChartElement |
GridLinesColor | CXTPChartAxisAppearance |
GridLinesMinorColor | CXTPChartAxisAppearance |
InterlacedColor | CXTPChartAxisAppearance |
InterlacedColor2 | CXTPChartAxisAppearance |
InterlacedFillStyle | CXTPChartAxisAppearance |
Is3D() const | CXTPChartObject |
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartElement | virtual
Release() | CXTPChartElement | virtual
StripColor | CXTPChartAxisAppearance |
StripColor2 | CXTPChartAxisAppearance |
~CXTPChartAxisAppearance() | CXTPChartAxisAppearance | virtual
~CXTPChartElement() | CXTPChartElement | virtual
~CXTPChartElementAppearance() | CXTPChartElementAppearance | virtual


Toolkit Pro: XTPRibbonBackstageViewThemeVisualStudio2019.h Source File

  • Source
  • Ribbon
  • Backstage
XTPRibbonBackstageViewThemeVisualStudio2019.h
Go to the documentation of this file.
1
23#if !defined(__XTPRIBBONBACKSTAGEVIEWTHEMEVISUALSTUDIO2019_H__)
24# define __XTPRIBBONBACKSTAGEVIEWTHEMEVISUALSTUDIO2019_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class _XTP_EXT_CLASS CXTPRibbonBackstageViewThemeVisualStudio2019
34 : public CXTPRibbonBackstageViewThemeOffice2013
35{
36public:
37 CXTPRibbonBackstageViewThemeVisualStudio2019();
38 ~CXTPRibbonBackstageViewThemeVisualStudio2019();
39};
40
41# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
43#endif // !defined(__XTPRIBBONBACKSTAGEVIEWTHEMEVISUALSTUDIO2019_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h


Toolkit Pro: XTPBrowseDialog.h Source File

  • Source
  • Controls
  • Dialog
XTPBrowseDialog.h
Go to the documentation of this file.
1
23#if !defined(__XTPBROWSEDIALOG_H__)
24# define __XTPBROWSEDIALOG_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
42class _XTP_EXT_CLASS CXTPBrowseDialog : public CCommonDialog
43{
44public:
51 CXTPBrowseDialog(CWnd* pParent = NULL);
52
57 virtual ~CXTPBrowseDialog();
58
59public:
67 INT_PTR DoModal();
68
74 void SetOwner(HWND hWnd);
75
83 HWND GetOwner();
84
96 void SetPidlRoot(LPCITEMIDLIST pidl);
97
106 LPCITEMIDLIST GetPidlRoot();
107
116 void SetDisplayName(LPCTSTR szDisplayName);
117
125 LPCTSTR GetDisplayName();
126
134 void SetTitle(LPCTSTR szTitle);
135
144 LPCTSTR GetTitle();
145
235 void SetOptions(UINT uf);
236
244 UINT GetOptions();
245
255 void SetCallback(BFFCALLBACK pf);
256
265 BFFCALLBACK GetCallback();
266
274 void SetData(LPARAM lp);
275
284 LPARAM GetData();
285
294 void SetSelPath(LPCTSTR szSelPath);
295
303 LPCTSTR GetSelPath();
304
312 int GetImage();
313
330 static int CALLBACK BrowseCtrlCallback(HWND hwnd, UINT uMsg, LPARAM lParam, LPARAM lpData);
331
332protected:
337 TCHAR m_szSelPath[MAX_PATH];
338 BROWSEINFO m_bi;
339
340private:
341 CString m_strTitle;
342};
343
345
346AFX_INLINE void CXTPBrowseDialog::SetOwner(HWND hWnd)
347{
348 m_bi.hwndOwner = hWnd;
349}
350AFX_INLINE HWND CXTPBrowseDialog::GetOwner()
351{
352 return m_bi.hwndOwner;
353}
354AFX_INLINE void CXTPBrowseDialog::SetPidlRoot(LPCITEMIDLIST pidl)
355{
356 m_bi.pidlRoot = pidl;
357}
358AFX_INLINE LPCITEMIDLIST CXTPBrowseDialog::GetPidlRoot()
359{
360 return m_bi.pidlRoot;
361}
362AFX_INLINE void CXTPBrowseDialog::SetDisplayName(LPCTSTR szDisplayName)
363{
364 m_bi.pszDisplayName = (LPTSTR)szDisplayName;
365}
366AFX_INLINE LPCTSTR CXTPBrowseDialog::GetDisplayName()
367{
368 return m_bi.pszDisplayName;
369}
370AFX_INLINE void CXTPBrowseDialog::SetTitle(LPCTSTR szTitle)
371{
372 m_bi.lpszTitle = szTitle;
373}
374AFX_INLINE LPCTSTR CXTPBrowseDialog::GetTitle()
375{
376 return m_bi.lpszTitle;
377}
378AFX_INLINE void CXTPBrowseDialog::SetOptions(UINT uf)
379{
380 m_bi.ulFlags = uf;
381}
382AFX_INLINE UINT CXTPBrowseDialog::GetOptions()
383{
384 return m_bi.ulFlags;
385}
386AFX_INLINE void CXTPBrowseDialog::SetCallback(BFFCALLBACK pf)
387{
388 m_bi.lpfn = pf;
389}
390AFX_INLINE BFFCALLBACK CXTPBrowseDialog::GetCallback()
391{
392 return m_bi.lpfn;
393}
394AFX_INLINE void CXTPBrowseDialog::SetData(LPARAM lp)
395{
396 m_bi.lParam = lp;
397}
398AFX_INLINE LPARAM CXTPBrowseDialog::GetData()
399{
400 return m_bi.lParam;
401}
402AFX_INLINE LPCTSTR CXTPBrowseDialog::GetSelPath()
403{
404 return m_szSelPath;
405}
406AFX_INLINE int CXTPBrowseDialog::GetImage()
407{
408 return m_bi.iImage;
409}
412# ifndef BIF_BROWSEINCLUDEURLS
413# define BIF_BROWSEINCLUDEURLS \
414 0x0080 // Allow URLs to be displayed or entered. (Requires BIF_USENEWUI)
415# endif
416
417# ifndef BIF_NEWDIALOGSTYLE
418# define BIF_NEWDIALOGSTYLE 0x0040 // Use the new dialog layout with the ability to resize
419# endif
420
421# ifndef BIF_NONEWFOLDERBUTTON
422# define BIF_NONEWFOLDERBUTTON \
423 0x0200 // Do not add the "New Folder" button to the dialog. Only applicable with
424 // BIF_NEWDIALOGSTYLE.
425# endif
426
427# ifndef BIF_NOTRANSLATETARGETS
428# define BIF_NOTRANSLATETARGETS 0x0400 // don't traverse target as shortcut
429# endif
430
431# ifndef BIF_SHAREABLE
432# define BIF_SHAREABLE \
433 0x8000 // sharable resources displayed (remote shares, requires BIF_USENEWUI)
434# endif
435
436# ifndef BIF_UAHINT
437# define BIF_UAHINT \
438 0x0100 // Add a UA hint to the dialog, in place of the edit box. May not be combined
439 // with BIF_EDITBOX
440# endif
441
442# ifndef BIF_USENEWUI
443# define BIF_USENEWUI (BIF_NEWDIALOGSTYLE | BIF_EDITBOX)
444# endif
447# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
449#endif // !defined(__XTPBROWSEDIALOG_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPBrowseDialog
CXTPBrowseDialog is derived from the BROWSEINFO structure.
Definition XTPBrowseDialog.h:43
CXTPBrowseDialog::SetOwner
void SetOwner(HWND hWnd)
Call this member function to set the owner window for the dialog box.
CXTPBrowseDialog::SetDisplayName
void SetDisplayName(LPCTSTR szDisplayName)
Call this member function to set the address for the display name that the dialog box will use.
CXTPBrowseDialog::BrowseCtrlCallback
static int CALLBACK BrowseCtrlCallback(HWND hwnd, UINT uMsg, LPARAM lParam, LPARAM lpData)
Application defined callback.
CXTPBrowseDialog::GetOwner
HWND GetOwner()
Call this member function to get an HWND handle to the owner window for the dialog box.
CXTPBrowseDialog::GetSelPath
LPCTSTR GetSelPath()
Call this member function to get a NULL-terminated string that represents the currently selected dire...
CXTPBrowseDialog::m_szSelPath
TCHAR m_szSelPath[MAX_PATH]
NULL-terminated string that represents the selected directory.
Definition XTPBrowseDialog.h:337
CXTPBrowseDialog::~CXTPBrowseDialog
virtual ~CXTPBrowseDialog()
Destroys a CXTPBrowseDialog object, handles cleanup and deallocation.
CXTPBrowseDialog::GetOptions
UINT GetOptions()
Call this member function to return the flags specifying the options that have been set for the dialo...
CXTPBrowseDialog::GetImage
int GetImage()
Call this member function to get the index to the system image list of the image associated with the ...
CXTPBrowseDialog::SetCallback
void SetCallback(BFFCALLBACK pf)
Call this member function to define the address for the BrowseCallbackProc function that is to be cal...
CXTPBrowseDialog::GetCallback
BFFCALLBACK GetCallback()
Call this member function to return the address for the BrowseCallbackProc function that is called wh...
CXTPBrowseDialog::CXTPBrowseDialog
CXTPBrowseDialog(CWnd *pParent=NULL)
Constructs a CXTPBrowseDialog object.
CXTPBrowseDialog::GetPidlRoot
LPCITEMIDLIST GetPidlRoot()
Call this member function to return the address of the ITEMIDLIST structure that was specified for th...
CXTPBrowseDialog::SetPidlRoot
void SetPidlRoot(LPCITEMIDLIST pidl)
Call this member function to set the address of an ITEMIDLIST structure which specifies the location ...
CXTPBrowseDialog::SetOptions
void SetOptions(UINT uf)
Call this member function to set the flags for specifying the options for the browse dialog box.
CXTPBrowseDialog::DoModal
INT_PTR DoModal()
Call this member function to invoke the browse dialog box and to return the dialog box result when do...
CXTPBrowseDialog::SetData
void SetData(LPARAM lp)
Call this member function to set the application data that is passed to the callback function.
CXTPBrowseDialog::SetSelPath
void SetSelPath(LPCTSTR szSelPath)
Call this member function to set the initial path to select when the browse dialog is first opened.
CXTPBrowseDialog::GetData
LPARAM GetData()
Retrieves application data that was set to be passed to the callback function.
CXTPBrowseDialog::GetDisplayName
LPCTSTR GetDisplayName()
Call this member function to return the display name that is used by the browse dialog box.
CXTPBrowseDialog::SetTitle
void SetTitle(LPCTSTR szTitle)
Call this member function to set the title for the browse dialog box.
CXTPBrowseDialog::GetTitle
LPCTSTR GetTitle()
Call this member function to return a NULL-terminated string that represents the title that was set f...


Toolkit Pro: XTPRibbonBar.h Source File

  • Source
  • Ribbon
XTPRibbonBar.h
Go to the documentation of this file.
1
23#if !defined(__XTPRIBBONBAR_H__)
24# define __XTPRIBBONBAR_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPRibbonQuickAccessControls;
34class CXTPRibbonTab;
35class CXTPRibbonControlTab;
36class CXTPTabPaintManager;
37class CXTPRibbonBar;
38class CXTPRibbonGroup;
39class CXTPCommandBarsFrameHook;
40class CXTPRibbonTabContextHeaders;
41class CXTPRibbonGroups;
42class CXTPRibbonPaintManager;
43class CXTPRibbonControlSystemButton;
44
50# define WM_XTP_RIBBONMINIMIZE (WM_XTP_COMMANDBARS_BASE + 25)
51
52# define WM_XTP_CUSTOMIZATION_RIBBONRESET (WM_XTP_COMMANDBARS_BASE + 27)
53
66class _XTP_EXT_CLASS CXTPRibbonBar
67 : public CXTPMenuBar
68 , public CXTPRibbonScrollableBar
69{
70private:
71 class CControlQuickAccessMorePopup;
72 class CControlQuickAccessCommand;
73
74private:
76 DECLARE_XTP_COMMANDBAR(CXTPRibbonBar)
78public:
83 CXTPRibbonBar();
84
89 virtual ~CXTPRibbonBar();
90
91public:
101 CXTPRibbonTab* AddTab(LPCTSTR lpszCaption);
111 CXTPRibbonTab* AddTab(int nID);
112
123 CXTPRibbonTab* InsertTab(int nItem, int nID);
124
136 CXTPRibbonTab* InsertTab(int nItem, LPCTSTR lpszCaption, int nID = 0);
137
148 CXTPRibbonTab* InsertTab(int nItem, CXTPRibbonTab* pTab);
149
158 CXTPRibbonTab* GetSelectedTab() const;
159
169 CXTPRibbonTab* GetTab(int nIndex) const;
170
180 CXTPRibbonTab* FindTab(int nId) const;
181
191 CXTPRibbonGroup* FindGroup(int nId) const;
192
201 int GetTabCount() const;
202
211 CXTPRibbonPaintManager* GetRibbonPaintManager() const;
212
220 void SetCurSel(int nIndex);
221
228 CSize GetButtonSize() const;
229
238 int GetCurSel() const;
239
251 CXTPTabPaintManager* GetTabPaintManager() const;
252
261 CXTPRibbonGroup* GetHighlightedGroup() const;
262
269 BOOL IsActive() const;
270
279 BOOL IsGroupsVisible() const;
280
289 BOOL IsTabsVisible() const;
290
297 BOOL IsRibbonBarVisible() const;
298
304 virtual void SetVisible(BOOL bVisible);
305
313 void SetGroupsVisible(BOOL bVisible);
314
322 void SetTabsVisible(BOOL bVisible);
323
331 CXTPRibbonControlTab* GetControlTab() const;
332
342 void SetMinimumVisibleWidth(int nMinVisibleWidth);
343
354 void SetMinimumVisibleSize(int nMinVisibleWidth, int nMinVisibleHeight);
355
364 int GetMinimumVisibleWidth() const;
365
373 CXTPRibbonQuickAccessControls* GetQuickAccessControls() const;
374
383 CXTPControlPopup* AddSystemButton(int nID = 0);
384
393 CXTPRibbonControlSystemButton* GetSystemButton() const;
394
404 virtual BOOL IsRibbonBar() const;
405
412 void RemoveAllTabs();
413
421 void RemoveTab(int nIndex);
422
428 virtual void EnsureVisible(CXTPControl* pControl);
429
430 BOOL OnFrameMouseWheel(BOOL bForward);
431
432public:
440 void EnableFrameTheme(BOOL bEnable = TRUE);
441
450 BOOL IsFrameThemeEnabled() const;
451
460 void ShowQuickAccessBelowRibbon(BOOL bBelow = TRUE);
461
471 BOOL IsQuickAccessBelowRibbon() const;
472
480 void ShowQuickAccess(BOOL bShow = TRUE);
481
490 BOOL IsQuickAccessVisible() const;
491
499 void AllowQuickAccessDuplicates(BOOL bAllow);
500
508 void AllowQuickAccessCustomization(BOOL bAllow);
509
518 BOOL IsAllowQuickAccessDuplicates() const;
519
525 void SelectNextTab(BOOL bNext);
526
532 virtual void SetRibbonMinimized(BOOL bMinimized);
533
540 BOOL IsRibbonMinimized() const;
541
548 void AllowMinimize(BOOL bAllow);
549
550public:
560 void RebuildControls(CXTPRibbonTab* pSelected);
561
571 CRect GetTabControlRect() const;
572
582 CRect GetCaptionRect() const;
583
593 CRect GetCaptionTextRect() const;
594
604 CRect GetQuickAccessRect() const;
605
615 CXTPRibbonGroup* HitTestGroup(CPoint point) const;
616
625 virtual int GetTabsHeight() const;
626
635 int GetQuickAccessHeight() const;
636
643 int CalcQuickAccessHeight();
644
653 virtual int GetGroupsHeight();
654
663 virtual int CalcClientHeight();
664
671 CRect GetGroupsRect() const;
672
682 virtual int CalcGroupsHeight();
683
691 void SetGroupsHeight(int nHeight);
692
701 int GetCaptionHeight() const;
702
712 CXTPRibbonTabContextHeaders* GetContextHeaders() const;
713
721 BOOL IsQuickAccessControl(CXTPControl* pControl) const;
722
730 virtual BOOL IsAllowQuickAccessControl(CXTPControl* pControl);
731
738 virtual void DrawCommandBar(CDC* pDC, CRect rcClipBox);
739
748 CXTPCommandBarsFrameHook* GetFrameHook() const;
749
756 BOOL IsDwmEnabled() const;
757
763 void SetFontHeight(int nFontHeight);
764
771 int GetFontHeight() const;
772
779 BOOL IsCaptionVisible() const;
780
787 void ShowCaptionAlways(BOOL bShowCaption);
788
796 BOOL GetShowCaptionAlways() const;
797
806 virtual CSize GetIconSize() const;
807
814 CXTPControl* GetControlQuickAccess() const;
815
822 BOOL IsKeyboardCuesVisible() const;
823
829 void Reset(BOOL bShowWarningMessage);
830
837 BOOL IsBackstageViewVisible() const;
838
845 void SetQuickAccessEmptyIconId(int nIconId);
846
856 BOOL PassKeyboardInputToBackstageView(UINT message, WPARAM wParam, LPARAM lParam);
857
858protected:
866 virtual BOOL OnTabChanging(CXTPRibbonTab* pTab);
867
873 virtual void OnTabChanged(CXTPRibbonTab* pTab);
874
886 virtual int CalcGroupsHeight(int nClientHeight);
887
896 virtual CXTPRibbonTabPopupToolBar* CreateTabPopupToolBar(CXTPRibbonTab* pTab);
897
905 BOOL IsControlEnabled(const CXTPControl* pControl) const;
906
908protected:
916 void GenerateCommandBarList(DWORD& nID, CXTPCommandBarList* pCommandBarList,
917 XTP_COMMANDBARS_PROPEXCHANGE_PARAM* pParam);
918
925 void RestoreCommandBarList(CXTPCommandBarList* pCommandBarList);
926
927 void DoPropExchange(CXTPPropExchange* pPX);
928 void Copy(CXTPCommandBar* pCommandBar, BOOL bRecursive = FALSE);
929 virtual CXTPPopupBar* CreateContextMenu(CXTPControl* pSelectedControl);
930 virtual CXTPPopupBar* CreateMoreQuickAccessContextMenu();
931 virtual BOOL ShouldSerializeBar();
932 virtual void MergeToolBar(CXTPCommandBar* pCommandBar, BOOL bSilent);
933 virtual void MergeToolBar(CXTPCommandBar* pCommandBar, BOOL bSilent,
934 int nDefaultConfirmationChoice);
935 int HitTestCaption(CPoint point) const;
936 void RepositionCaptionButtons();
937 void RepositionContextHeaders();
938 void AddCaptionButton(int nId, BOOL bAdd, BOOL bEnabled, CRect& rcCaption);
939 BOOL ShrinkContextHeaders(int nLeft, int nRight);
940 void ShowContextMenu(CPoint point, CXTPControl* pSelectedControl);
941 virtual void CreateKeyboardTips();
942 virtual void OnKeyboardTip(CXTPCommandBarKeyboardTip* pTip);
943 virtual void OnCustomizeDrop(CXTPControl* pDataObject, DROPEFFECT& dropEffect, CPoint ptDrop,
944 CPoint ptDrag);
945 void RefreshSysButtons();
946 virtual BOOL ProcessSpecialKey(XTPSpecialKey key);
947
948protected:
949public:
950 virtual CSize CalcDockingLayout(int nLength, DWORD dwMode, int nWidth = 0);
951 void Reposition(int cx, int cy);
952 void RepositionGroups(CDC* pDC, CRect rcGroups);
953 virtual BOOL PreviewAccel(UINT chAccel);
954
955 BOOL IsCaptionBarInBackstageMode() const;
956 void SetCaptionBarBackstageMode(BOOL bMode);
957 int GetBackstageModeMenuWidth() const;
958 void SetBackstageModeMenuWidth(int nWidth);
959 int GetBackstageSysButtonTop() const;
960 void SetBackstageSysButtonTop(int nTop);
961 int GetBackstageSysButtonBottom() const;
962 void SetBackstageSysButtonBottom(int nBottom);
963
973 virtual BOOL SetTrackingMode(int bMode, BOOL bSelectFirst = TRUE, BOOL bKeyboard = FALSE);
974 int OnHookMessage(HWND /*hWnd*/, UINT nMessage, WPARAM& wParam, LPARAM& lParam,
975 LRESULT& /*lResult*/);
976 void OnRemoved();
977 void OnGroupsScroll(BOOL bScrollLeft);
978 int GetRibbonTopBorder() const;
979 void CustomizeFindDropIndex(CXTPControl* pDataObject, const CPoint& point, CRect& rcMarker,
980 int& nDropIndex, BOOL& bDropAfter);
981
984protected:
986 DECLARE_MESSAGE_MAP()
987 //{{AFX_VIRTUAL(CXTPRibbonBar)
988 //}}AFX_VIRTUAL
989
990 //{{AFX_MSG(CXTPRibbonBar)
991 afx_msg void OnMouseLeave();
992 afx_msg void OnMouseMove(UINT nFlags, CPoint point);
993 afx_msg INT_PTR OnToolHitTest(CPoint point, TOOLINFO* pTI) const;
994 afx_msg void OnSysColorChange();
995 afx_msg void OnLButtonDown(UINT nFlags, CPoint point);
996 afx_msg void OnRButtonUp(UINT nFlags, CPoint point);
997 void OnPopupRButtonUp(CXTPCommandBar* pCommandBar, CPoint point);
998 afx_msg void OnLButtonDblClk(UINT nFlags, CPoint point);
999 afx_msg int OnCreate(LPCREATESTRUCT lpCreateStruct);
1000 afx_msg BOOL OnSetCursor(CWnd* pWnd, UINT nHitTest, UINT message);
1001 afx_msg void OnShowWindow(BOOL bShow, UINT nStatus);
1002 afx_msg void OnRButtonDown(UINT nFlags, CPoint point);
1003 afx_msg void OnCustomizePlaceQuickAccess(UINT nCommand);
1004 afx_msg LRESULT OnCustomizeCommand(WPARAM wParam, LPARAM lParam);
1005 afx_msg LRESULT OnNcHitTest(CPoint point);
1006
1007 //}}AFX_MSG
1010protected:
1011# ifdef _XTP_COMMANDBARS_ACTIVEX
1013 afx_msg LPDISPATCH OleInsertTab(int nIndex, LPCTSTR lpszTitle);
1014 afx_msg long OleGetItemCount();
1015 afx_msg LPDISPATCH OleGetItem(int nIndex);
1016 afx_msg LPDISPATCH OleAddSystemButton();
1017 afx_msg LPDISPATCH OleGetSystemButton();
1018 afx_msg void OleSetSelectedTab(LPDISPATCH lpTab);
1019 afx_msg LPDISPATCH OleGetSelectedTab();
1020 afx_msg void OleEnableFrameTheme();
1021
1022 afx_msg LPDISPATCH OleGetRibbonPaintManager();
1023 afx_msg LPDISPATCH OleGetTabPaintManager();
1024 afx_msg LPDISPATCH OleGetQuickAccessControls();
1025 afx_msg LPDISPATCH OleFindGroup(int nID);
1026 afx_msg LPDISPATCH OleFindTab(int nID);
1027 virtual void OleEnableCustomization();
1028 afx_msg LPDISPATCH OleGetControlQuickAccess();
1029 afx_msg LPDISPATCH OleGetControlSystemButton();
1030 afx_msg void OleSetRibbonMinimized(BOOL bNewValue);
1031 afx_msg long OleGetGroupsHeight();
1032 afx_msg void OleSetGroupsHeight(long nHeight);
1033 afx_msg long OleGetClientHeight();
1034 afx_msg void OleSetClientHeight(long nHeight);
1035
1036 DECLARE_DISPATCH_MAP()
1037 DECLARE_OLETYPELIB_EX(CXTPRibbonBar);
1038 DECLARE_INTERFACE_MAP()
1039 DECLARE_ENUM_VARIANT(CXTPRibbonBar);
1041# endif
1042
1043protected:
1044 CRect m_rcTabControl;
1045 CRect m_rcGroups;
1046 CRect m_rcCaption;
1047 CRect m_rcCaptionText;
1048 CRect m_rcHeader;
1049 CRect m_rcQuickAccess;
1051 BOOL m_bRibbonBarVisible;
1052 BOOL m_bGroupsVisible;
1053 BOOL m_bTabsVisible;
1054 BOOL m_bShowQuickAccessBelow;
1055 BOOL m_bShowQuickAccess;
1056 BOOL m_bAllowQuickAccessDuplicates;
1057 BOOL m_bAllowQuickAccessCustomization;
1058 BOOL m_bGroupReducedChanged;
1059 int m_nQuickAccessHeight;
1060 BOOL m_bAllowMinimize;
1062 CXTPRibbonQuickAccessControls* m_pQuickAccessControls;
1064 CXTPRibbonControlTab* m_pControlTab;
1065 CXTPControl* m_pControlQuickAccess;
1066 CXTPControl* m_pControlQuickAccessMore;
1067 CXTPRibbonControlSystemButton* m_pControlSystemButton;
1068 BOOL m_bMinimizeOnDblClick;
1070 int m_nMinVisibleWidth;
1071 int m_nMinVisibleHeight;
1073 CXTPRibbonTabContextHeaders* m_pContextHeaders;
1074 int m_nCustomGroupsHeight;
1075 int m_nCustomClientHeight;
1077 BOOL m_bMinimized;
1078 BOOL m_bShowCaptionAlways;
1079 CString m_strCaptionText;
1081 const int m_nQuickAccessHeightDiff;
1082 int m_nQuickAccessEmptyIconId;
1083
1084 BOOL m_bIsCaptionBarInBackstageMode;
1085 int m_nBackstageMenuWidth;
1087 int m_nBackstageSysButtonTop;
1088 int m_nBackstageSysButtonBottom;
1090private:
1091 friend class CXTPRibbonControlTab;
1092 friend class CXTPRibbonBarControlQuickAccessPopup;
1093 friend class CControlQuickAccessMorePopup;
1094 friend class CXTPRibbonGroup;
1095 friend class CXTPRibbonControls;
1096 friend class CXTPRibbonGroups;
1097 friend class CXTPRibbonTabPopupToolBar;
1098};
1099
1100AFX_INLINE CRect CXTPRibbonBar::GetTabControlRect() const
1101{
1102 return m_rcTabControl;
1103}
1104
1105AFX_INLINE CXTPRibbonGroup* CXTPRibbonBar::GetHighlightedGroup() const
1106{
1107 return m_pHighlightedGroup;
1108}
1110AFX_INLINE CXTPRibbonGroup* CXTPRibbonScrollableBar::GetHighlightedGroup() const
1111{
1112 return m_pHighlightedGroup;
1113}
1115AFX_INLINE CXTPRibbonControlTab* CXTPRibbonBar::GetControlTab() const
1116{
1117 return m_pControlTab;
1118}
1119
1120AFX_INLINE void CXTPRibbonBar::SetMinimumVisibleWidth(int nMinVisibleWidth)
1121{
1122 m_nMinVisibleWidth = nMinVisibleWidth;
1123}
1124
1125AFX_INLINE void CXTPRibbonBar::SetMinimumVisibleSize(int nMinVisibleWidth, int nMinVisibleHeight)
1126{
1127 m_nMinVisibleWidth = nMinVisibleWidth;
1128 m_nMinVisibleHeight = nMinVisibleHeight;
1129}
1130
1131AFX_INLINE int CXTPRibbonBar::GetMinimumVisibleWidth() const
1132{
1133 return m_nMinVisibleWidth;
1134}
1135
1136AFX_INLINE CRect CXTPRibbonBar::GetCaptionRect() const
1137{
1138 return m_rcCaption;
1139}
1140
1141AFX_INLINE CRect CXTPRibbonBar::GetCaptionTextRect() const
1142{
1143 return m_rcCaptionText;
1144}
1145
1146AFX_INLINE CRect CXTPRibbonBar::GetQuickAccessRect() const
1147{
1148 return m_rcQuickAccess;
1149}
1150
1151AFX_INLINE CXTPRibbonQuickAccessControls* CXTPRibbonBar::GetQuickAccessControls() const
1152{
1153 return m_pQuickAccessControls;
1154}
1155
1156AFX_INLINE CXTPRibbonControlSystemButton* CXTPRibbonBar::GetSystemButton() const
1157{
1158 return m_pControlSystemButton;
1159}
1160
1161AFX_INLINE BOOL CXTPRibbonBar::IsRibbonBarVisible() const
1162{
1163 return m_bVisible && m_bRibbonBarVisible;
1164}
1165
1166AFX_INLINE CXTPRibbonTabContextHeaders* CXTPRibbonBar::GetContextHeaders() const
1167{
1168 return m_pContextHeaders;
1169}
1170
1171AFX_INLINE BOOL CXTPRibbonBar::IsRibbonBar() const
1172{
1173 return TRUE;
1174}
1175
1176AFX_INLINE void CXTPRibbonBar::ShowQuickAccess(BOOL bShow)
1177{
1178 m_bShowQuickAccess = bShow;
1179 OnRecalcLayout();
1180}
1181
1182AFX_INLINE BOOL CXTPRibbonBar::IsQuickAccessVisible() const
1183{
1184 return m_bShowQuickAccess;
1185}
1186
1187AFX_INLINE void CXTPRibbonBar::AllowQuickAccessDuplicates(BOOL bAllow)
1188{
1189 m_bAllowQuickAccessDuplicates = bAllow;
1190}
1191
1192AFX_INLINE void CXTPRibbonBar::AllowQuickAccessCustomization(BOOL bAllow)
1193{
1194 m_bAllowQuickAccessCustomization = bAllow;
1195}
1196
1197AFX_INLINE BOOL CXTPRibbonBar::IsAllowQuickAccessDuplicates() const
1198{
1199 return m_bAllowQuickAccessDuplicates;
1200}
1201
1202AFX_INLINE void CXTPRibbonBar::SetGroupsHeight(int nHeight)
1203{
1204 m_nCustomGroupsHeight = nHeight;
1205}
1206
1207AFX_INLINE void CXTPRibbonBar::AllowMinimize(BOOL bAllow)
1208{
1209 m_bAllowMinimize = bAllow;
1210}
1211
1212AFX_INLINE CRect CXTPRibbonBar::GetGroupsRect() const
1213{
1214 return m_rcGroups;
1215}
1216
1217AFX_INLINE void CXTPRibbonBar::ShowCaptionAlways(BOOL bShowCaption)
1218{
1219 m_bShowCaptionAlways = bShowCaption;
1220}
1221
1222AFX_INLINE BOOL CXTPRibbonBar::GetShowCaptionAlways() const
1223{
1224 return m_bShowCaptionAlways;
1225}
1226
1227AFX_INLINE CXTPControl* CXTPRibbonBar::GetControlQuickAccess() const
1228{
1229 return m_pControlQuickAccess;
1230}
1231
1232AFX_INLINE void CXTPRibbonBar::SetQuickAccessEmptyIconId(int nIconId)
1233{
1234 m_nQuickAccessEmptyIconId = nIconId;
1235}
1237AFX_INLINE BOOL CXTPRibbonBar::IsCaptionBarInBackstageMode() const
1238{
1239 return m_bIsCaptionBarInBackstageMode;
1240}
1241
1242AFX_INLINE void CXTPRibbonBar::SetCaptionBarBackstageMode(BOOL bMode)
1243{
1244 m_bIsCaptionBarInBackstageMode = bMode;
1245}
1246
1247AFX_INLINE int CXTPRibbonBar::GetBackstageModeMenuWidth() const
1248{
1249 return m_nBackstageMenuWidth;
1250}
1251
1252AFX_INLINE void CXTPRibbonBar::SetBackstageModeMenuWidth(int nWidth)
1253{
1254 m_nBackstageMenuWidth = nWidth;
1255}
1256
1257AFX_INLINE int CXTPRibbonBar::GetBackstageSysButtonTop() const
1258{
1259 return m_nBackstageSysButtonTop;
1260}
1261
1262AFX_INLINE void CXTPRibbonBar::SetBackstageSysButtonTop(int nTop)
1263{
1264 m_nBackstageSysButtonTop = nTop;
1265}
1266
1267AFX_INLINE int CXTPRibbonBar::GetBackstageSysButtonBottom() const
1268{
1269 return m_nBackstageSysButtonBottom;
1270}
1271
1272AFX_INLINE void CXTPRibbonBar::SetBackstageSysButtonBottom(int nBottom)
1273{
1274 m_nBackstageSysButtonBottom = nBottom;
1275}
1277# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
1279#endif // !defined(__XTPRIBBONBAR_H__)
XTPSpecialKey
XTPSpecialKey
Special keys enumerator.
Definition XTPCommandBarsDefines.h:407
DECLARE_XTP_COMMANDBAR
#define DECLARE_XTP_COMMANDBAR(class_name)
This macro generates the C++ header code necessary for a CXTPCommandBar-derived class that can be ser...
Definition XTPCommandBarsDefines.h:1234
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCommandBar
CXTPCommandBar is a CWnd derived class.
Definition XTPCommandBar.h:66
CXTPCommandBar::OnRemoved
virtual void OnRemoved()
This method is called when a toolbar is removed from the command bars collection.
CXTPCommandBar::CreateKeyboardTips
virtual void CreateKeyboardTips()
This method is called to create a keyboard tips collection for the command bar.
CXTPCommandBar::OnKeyboardTip
virtual void OnKeyboardTip(CXTPCommandBarKeyboardTip *pTip)
This method is called when a keyboard tip is found for the command bar.
CXTPCommandBar::SetTrackingMode
virtual BOOL SetTrackingMode(int bMode, BOOL bSelectFirst=TRUE, BOOL bKeyboard=FALSE)
Call this member to change the tracking state.
CXTPCommandBar::OnCustomizeDrop
virtual void OnCustomizeDrop(CXTPControl *pDataObject, DROPEFFECT &dropEffect, CPoint ptDrop, CPoint ptDrag)
This method is called when a control is dropped to the command bar.
CXTPCommandBar::ProcessSpecialKey
virtual BOOL ProcessSpecialKey(XTPSpecialKey key)
This method is called to process special keys.
CXTPCommandBar::IsRibbonBar
virtual BOOL IsRibbonBar() const
Call this member function to determine if the command bar is a CXTPRibbonBar.
Definition XTPCommandBar.h:1459
CXTPCommandBarKeyboardTip
CXTPCommandBarKeyboardTip is a CWnd derived class which represents a keyboard tip single window.
Definition XTPCommandBarKeyboardTip.h:41
CXTPCommandBarList
CXTPCommandBarList is a CList derived class.
Definition XTPCommandBarList.h:42
CXTPCommandBarsFrameHook
CXTPCommandBarsFrameHook is a CXTPHookManagerHookAble derived class.
Definition XTPFrameHook.h:56
CXTPControl
CXTPControl is a CXTPCmdTarget derived class.
Definition XTPControl.h:841
CXTPControlPopup
CXTPControlPopup is a CXTPControl derived class.
Definition XTPControlPopup.h:42
CXTPMenuBar
CXTPMenuBar is a CXTPToolBar derived class.
Definition XTPMenuBar.h:141
CXTPMenuBar::DoPropExchange
void DoPropExchange(CXTPPropExchange *pPX)
Either reads this object from or writes this object to an archive.
CXTPMenuBar::OnHookMessage
int OnHookMessage(HWND hWnd, UINT nMessage, WPARAM &wParam, LPARAM &lParam, LRESULT &lResult)
This member function is called by WindowProc, or is called during message reflection.
CXTPMenuBar::RestoreCommandBarList
void RestoreCommandBarList(CXTPCommandBarList *pCommandBarList)
Call this method during the serialization process to restore pop-ups from a list of command bars.
CXTPMenuBar::GenerateCommandBarList
void GenerateCommandBarList(DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam)
Call this method to assign self-identifiers for the serialization process.
CXTPMenuBar::ShouldSerializeBar
BOOL ShouldSerializeBar()
Call this method to check if the toolbar has changed and must be saved.
CXTPMenuBar::RefreshSysButtons
virtual void RefreshSysButtons()
Call this method to update the system buttons of the menu bar.
CXTPMenuBar::Copy
virtual void Copy(CXTPCommandBar *pCommandBar, BOOL bRecursive=FALSE)
This method makes a copy of the command bar.
CXTPPopupBar
CXTPPopupBar is a CXTPCommandBar derived class.
Definition XTPPopupBar.h:42
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72
CXTPRibbonBar
CXTPRibbonBar is a CXTPMenuBar derived class.
Definition XTPRibbonBar.h:69
CXTPRibbonBar::RemoveTab
void RemoveTab(int nIndex)
Call this member to remove a single tab.
CXTPRibbonBar::m_bMinimized
BOOL m_bMinimized
TRUE if the Ribbon is currently minimized.
Definition XTPRibbonBar.h:1077
CXTPRibbonBar::IsKeyboardCuesVisible
BOOL IsKeyboardCuesVisible() const
Call this method to determine if keyboard cues are visible.
CXTPRibbonBar::GetTabControlRect
CRect GetTabControlRect() const
Gets the bounding rectangle of the ribbon tabs.
Definition XTPRibbonBar.h:1100
CXTPRibbonBar::GetTabsHeight
virtual int GetTabsHeight() const
Gets the tabs area height.
CXTPRibbonBar::DrawCommandBar
virtual void DrawCommandBar(CDC *pDC, CRect rcClipBox)
This method is called to draw the command bar in the given context.
CXTPRibbonBar::IsActive
BOOL IsActive() const
Determines if the Ribbon state is active/inactive.
CXTPRibbonBar::m_pControlQuickAccess
CXTPControl * m_pControlQuickAccess
Quick Access menu control.
Definition XTPRibbonBar.h:1065
CXTPRibbonBar::m_nQuickAccessHeight
int m_nQuickAccessHeight
Quick Access height.
Definition XTPRibbonBar.h:1059
CXTPRibbonBar::m_bIsCaptionBarInBackstageMode
BOOL m_bIsCaptionBarInBackstageMode
Is backstage active.
Definition XTPRibbonBar.h:1084
CXTPRibbonBar::m_rcTabControl
CRect m_rcTabControl
Bounding rectangle of tabs.
Definition XTPRibbonBar.h:1044
CXTPRibbonBar::SetQuickAccessEmptyIconId
void SetQuickAccessEmptyIconId(int nIconId)
Call this method to set the icon ID that will be used if the user adds a new control to Quick Access ...
Definition XTPRibbonBar.h:1232
CXTPRibbonBar::GetTab
CXTPRibbonTab * GetTab(int nIndex) const
Call this method to retrieve the tab at a specified position.
CXTPRibbonBar::SetGroupsHeight
void SetGroupsHeight(int nHeight)
Sets the height of the ribbon groups.
Definition XTPRibbonBar.h:1202
CXTPRibbonBar::m_pControlTab
CXTPRibbonControlTab * m_pControlTab
Control tab pointer.
Definition XTPRibbonBar.h:1064
CXTPRibbonBar::IsTabsVisible
BOOL IsTabsVisible() const
Determines if the tabs part of the ribbon bar is visible.
CXTPRibbonBar::AddTab
CXTPRibbonTab * AddTab(int nID)
Call this method to add a new tab to the ribbon bar.
CXTPRibbonBar::GetTabPaintManager
CXTPTabPaintManager * GetTabPaintManager() const
Call this member to get a pointer to the tab paint manager.
CXTPRibbonBar::IsRibbonMinimized
BOOL IsRibbonMinimized() const
Determines if the ribon bar is minimized.
CXTPRibbonBar::EnsureVisible
virtual void EnsureVisible(CXTPControl *pControl)
Call this method to make sure that a control is visible on the ribbon bar.
CXTPRibbonBar::AllowQuickAccessDuplicates
void AllowQuickAccessDuplicates(BOOL bAllow)
Call this method to allow for duplicate controls for Quick Access.
Definition XTPRibbonBar.h:1187
CXTPRibbonBar::GetHighlightedGroup
CXTPRibbonGroup * GetHighlightedGroup() const
Call this method to get the highlighted group.
Definition XTPRibbonBar.h:1105
CXTPRibbonBar::m_bGroupsVisible
BOOL m_bGroupsVisible
TRUE if groups is visible.
Definition XTPRibbonBar.h:1052
CXTPRibbonBar::FindTab
CXTPRibbonTab * FindTab(int nId) const
Call this method to find a tab with a specified identifier.
CXTPRibbonBar::CreateTabPopupToolBar
virtual CXTPRibbonTabPopupToolBar * CreateTabPopupToolBar(CXTPRibbonTab *pTab)
Creates a new pop-up toolbar object for a provided tab.
CXTPRibbonBar::m_nMinVisibleWidth
int m_nMinVisibleWidth
Minimum width before ribbon bar disappears.
Definition XTPRibbonBar.h:1070
CXTPRibbonBar::SetMinimumVisibleSize
void SetMinimumVisibleSize(int nMinVisibleWidth, int nMinVisibleHeight)
Call this method to set the minimum width/height before the ribbon bar disappears.
Definition XTPRibbonBar.h:1125
CXTPRibbonBar::EnableFrameTheme
void EnableFrameTheme(BOOL bEnable=TRUE)
Call this method to enable/disable Office 2007 frame.
CXTPRibbonBar::GetFrameHook
CXTPCommandBarsFrameHook * GetFrameHook() const
Retrieves the CXTPCommandBarsFrameHook object used to skin the frame.
CXTPRibbonBar::m_nBackstageSysButtonBottom
int m_nBackstageSysButtonBottom
The buttom of the sysbutton on the backstage.
Definition XTPRibbonBar.h:1088
CXTPRibbonBar::IsBackstageViewVisible
BOOL IsBackstageViewVisible() const
Determines if backstage view is visible.
CXTPRibbonBar::InsertTab
CXTPRibbonTab * InsertTab(int nItem, int nID)
Call this method to insert a new tab to the ribbon bar at a specified position.
CXTPRibbonBar::SetRibbonMinimized
virtual void SetRibbonMinimized(BOOL bMinimized)
Call this method to minimize the ribbon bar.
CXTPRibbonBar::GetGroupsRect
CRect GetGroupsRect() const
Gets the ribbon groups bounding rectangle.
Definition XTPRibbonBar.h:1212
CXTPRibbonBar::GetCurSel
int GetCurSel() const
Call this method to get the index of the currently selected tab.
CXTPRibbonBar::m_pQuickAccessControls
CXTPRibbonQuickAccessControls * m_pQuickAccessControls
Quick Access controls (not used now).
Definition XTPRibbonBar.h:1062
CXTPRibbonBar::~CXTPRibbonBar
virtual ~CXTPRibbonBar()
Destroys a CXTPRibbonBar object, handles cleanup and deallocation.
CXTPRibbonBar::CalcClientHeight
virtual int CalcClientHeight()
Gets the group client area height.
CXTPRibbonBar::GetQuickAccessRect
CRect GetQuickAccessRect() const
Gets the bounding rectangle of the ribbon Quick Access controls.
Definition XTPRibbonBar.h:1146
CXTPRibbonBar::SetVisible
virtual void SetVisible(BOOL bVisible)
Call this member function to show/hide the ribbon.
CXTPRibbonBar::AllowQuickAccessCustomization
void AllowQuickAccessCustomization(BOOL bAllow)
Call this method to allow for customization of Quick Access.
Definition XTPRibbonBar.h:1192
CXTPRibbonBar::CalcQuickAccessHeight
int CalcQuickAccessHeight()
Calculates the Quick Access area height.
CXTPRibbonBar::m_nMinVisibleHeight
int m_nMinVisibleHeight
Minimum height before ribbon bar disappears.
Definition XTPRibbonBar.h:1071
CXTPRibbonBar::SetFontHeight
void SetFontHeight(int nFontHeight)
Sets the font height for the ribbon bar.
CXTPRibbonBar::AllowMinimize
void AllowMinimize(BOOL bAllow)
Call this method to allow/disallow the minimize feature of the ribbon bar.
Definition XTPRibbonBar.h:1207
CXTPRibbonBar::m_bShowQuickAccess
BOOL m_bShowQuickAccess
TRUE to show Quick Access.
Definition XTPRibbonBar.h:1055
CXTPRibbonBar::GetMinimumVisibleWidth
int GetMinimumVisibleWidth() const
Call this method to get the minimum width before the ribbon bar disappears.
Definition XTPRibbonBar.h:1131
CXTPRibbonBar::IsQuickAccessVisible
BOOL IsQuickAccessVisible() const
Determines if Quick Access is visible.
Definition XTPRibbonBar.h:1182
CXTPRibbonBar::InsertTab
CXTPRibbonTab * InsertTab(int nItem, LPCTSTR lpszCaption, int nID=0)
Call this method to insert a new tab to the ribbon bar at a specified position.
CXTPRibbonBar::m_rcCaption
CRect m_rcCaption
Caption bounding rectangle.
Definition XTPRibbonBar.h:1046
CXTPRibbonBar::GetControlQuickAccess
CXTPControl * GetControlQuickAccess() const
Call this method to get a pointer to the Quick Access button.
Definition XTPRibbonBar.h:1227
CXTPRibbonBar::IsControlEnabled
BOOL IsControlEnabled(const CXTPControl *pControl) const
Determines whether a control is enabled.
CXTPRibbonBar::IsFrameThemeEnabled
BOOL IsFrameThemeEnabled() const
Determines if Office 2007 frame is enabled/disabled.
CXTPRibbonBar::GetQuickAccessHeight
int GetQuickAccessHeight() const
Gets the Quick Access area height.
CXTPRibbonBar::SetCurSel
void SetCurSel(int nIndex)
Call this method to set the currently selected tab.
CXTPRibbonBar::GetCaptionRect
CRect GetCaptionRect() const
Gets the bounding rectangle of the ribbon caption.
Definition XTPRibbonBar.h:1136
CXTPRibbonBar::GetShowCaptionAlways
BOOL GetShowCaptionAlways() const
Determines if the caption is shown/hidden if the frame theme is not enabled.
Definition XTPRibbonBar.h:1222
CXTPRibbonBar::IsQuickAccessBelowRibbon
BOOL IsQuickAccessBelowRibbon() const
Determines if Quick Access controls are shown below/above the ribbon bar.
CXTPRibbonBar::m_bRibbonBarVisible
BOOL m_bRibbonBarVisible
TRUE if the ribbon bar is visible.
Definition XTPRibbonBar.h:1051
CXTPRibbonBar::GetContextHeaders
CXTPRibbonTabContextHeaders * GetContextHeaders() const
Retrieves the collection of context headers.
Definition XTPRibbonBar.h:1166
CXTPRibbonBar::m_rcGroups
CRect m_rcGroups
Groups bounding rectangle.
Definition XTPRibbonBar.h:1045
CXTPRibbonBar::RebuildControls
void RebuildControls(CXTPRibbonTab *pSelected)
When switching tabs, RebuildControls first deletes all of the controls from the old tab groups.
CXTPRibbonBar::IsCaptionVisible
BOOL IsCaptionVisible() const
Determines if the caption part of the ribbon is visible.
CXTPRibbonBar::m_pControlQuickAccessMore
CXTPControl * m_pControlQuickAccessMore
Quick Access more control.
Definition XTPRibbonBar.h:1066
CXTPRibbonBar::m_bGroupReducedChanged
BOOL m_bGroupReducedChanged
Some group appear in resize handler.
Definition XTPRibbonBar.h:1058
CXTPRibbonBar::m_bAllowQuickAccessDuplicates
BOOL m_bAllowQuickAccessDuplicates
TRUE to allow Quick Access duplicates.
Definition XTPRibbonBar.h:1056
CXTPRibbonBar::m_bTabsVisible
BOOL m_bTabsVisible
TRUE if tabs are visible.
Definition XTPRibbonBar.h:1053
CXTPRibbonBar::GetCaptionTextRect
CRect GetCaptionTextRect() const
Gets the bounding rectangle of the ribbon caption text.
Definition XTPRibbonBar.h:1141
CXTPRibbonBar::GetTabCount
int GetTabCount() const
Retrieves the number of tabs in the ribbon bar.
CXTPRibbonBar::CalcGroupsHeight
virtual int CalcGroupsHeight(int nClientHeight)
Calculates the ribbon groups height using the GetLargeIconSize method and the height of the captions.
CXTPRibbonBar::ShowCaptionAlways
void ShowCaptionAlways(BOOL bShowCaption)
Call this method to show/hide the caption if the frame theme is not enabled.
Definition XTPRibbonBar.h:1217
CXTPRibbonBar::CXTPRibbonBar
CXTPRibbonBar()
Constructs a CXTPRibbonBar object.
CXTPRibbonBar::GetFontHeight
int GetFontHeight() const
Gets the font height of the ribbon bar.
CXTPRibbonBar::SetTabsVisible
void SetTabsVisible(BOOL bVisible)
Call this method to show/hide the tabs part of the ribbon bar.
CXTPRibbonBar::GetSystemButton
CXTPRibbonControlSystemButton * GetSystemButton() const
Call this method to get the Ribbon top-left system button.
Definition XTPRibbonBar.h:1156
CXTPRibbonBar::IsRibbonBarVisible
BOOL IsRibbonBarVisible() const
Determines if the ribbon bar is visible.
Definition XTPRibbonBar.h:1161
CXTPRibbonBar::m_nBackstageMenuWidth
int m_nBackstageMenuWidth
The width of the panel with commands and tabs in the backstage.
Definition XTPRibbonBar.h:1085
CXTPRibbonBar::ShowQuickAccessBelowRibbon
void ShowQuickAccessBelowRibbon(BOOL bBelow=TRUE)
Call this method to show Quick Access controls below/above the ribbon bar.
CXTPRibbonBar::m_strCaptionText
CString m_strCaptionText
Caption text.
Definition XTPRibbonBar.h:1079
CXTPRibbonBar::ShowQuickAccess
void ShowQuickAccess(BOOL bShow=TRUE)
Call this method to show/hide Quick Access.
Definition XTPRibbonBar.h:1176
CXTPRibbonBar::m_nCustomClientHeight
int m_nCustomClientHeight
Custom client height.
Definition XTPRibbonBar.h:1075
CXTPRibbonBar::m_bShowQuickAccessBelow
BOOL m_bShowQuickAccessBelow
TRUE to show Quick Access controls below the ribbon bar.
Definition XTPRibbonBar.h:1054
CXTPRibbonBar::AddSystemButton
CXTPControlPopup * AddSystemButton(int nID=0)
Call this method to add the Ribbon top-left system button.
CXTPRibbonBar::m_bMinimizeOnDblClick
BOOL m_bMinimizeOnDblClick
TRUE to allow the ribbon to be minimized/maximized when double clicked.
Definition XTPRibbonBar.h:1068
CXTPRibbonBar::OnTabChanging
virtual BOOL OnTabChanging(CXTPRibbonTab *pTab)
This virtual method is called when the current tab is about to be changed.
CXTPRibbonBar::OnTabChanged
virtual void OnTabChanged(CXTPRibbonTab *pTab)
This virtual method called when the current tab is changed.
CXTPRibbonBar::GetButtonSize
CSize GetButtonSize() const
Call this function to get the size of the command bar button.
CXTPRibbonBar::m_bShowCaptionAlways
BOOL m_bShowCaptionAlways
TRUE to show caption even if EnableFrameTheme was not called.
Definition XTPRibbonBar.h:1078
CXTPRibbonBar::m_pControlSystemButton
CXTPRibbonControlSystemButton * m_pControlSystemButton
System button control.
Definition XTPRibbonBar.h:1067
CXTPRibbonBar::GetCaptionHeight
int GetCaptionHeight() const
Gets the caption height of the ribbon bar, in pixels.
CXTPRibbonBar::m_bAllowMinimize
BOOL m_bAllowMinimize
TRUE to allow minimize ribbon.
Definition XTPRibbonBar.h:1060
CXTPRibbonBar::m_bAllowQuickAccessCustomization
BOOL m_bAllowQuickAccessCustomization
TRUE to allow Quick Access customization.
Definition XTPRibbonBar.h:1057
CXTPRibbonBar::GetIconSize
virtual CSize GetIconSize() const
Call this member function to get the size of the toolbar icon.
CXTPRibbonBar::IsGroupsVisible
BOOL IsGroupsVisible() const
Determines if the groups part of the ribbon bar is visible.
CXTPRibbonBar::GetSelectedTab
CXTPRibbonTab * GetSelectedTab() const
Call this method to get the currently selected tab.
CXTPRibbonBar::SelectNextTab
void SelectNextTab(BOOL bNext)
Call this method to select the next/previous tab.
CXTPRibbonBar::IsRibbonBar
virtual BOOL IsRibbonBar() const
Call this member function to determine if the command bar is a CXTPRibbonBar.
Definition XTPRibbonBar.h:1171
CXTPRibbonBar::IsAllowQuickAccessControl
virtual BOOL IsAllowQuickAccessControl(CXTPControl *pControl)
Determines if a control can be added to Quick Access controls.
CXTPRibbonBar::InsertTab
CXTPRibbonTab * InsertTab(int nItem, CXTPRibbonTab *pTab)
Call this method to insert a new tab to the ribbon bar at a specified position.
CXTPRibbonBar::m_nCustomGroupsHeight
int m_nCustomGroupsHeight
Custom groups height.
Definition XTPRibbonBar.h:1074
CXTPRibbonBar::FindGroup
CXTPRibbonGroup * FindGroup(int nId) const
Call this method to find a group with a specified identifier.
CXTPRibbonBar::HitTestGroup
CXTPRibbonGroup * HitTestGroup(CPoint point) const
This member function determines which ribbon group, if any, is at a specified position.
CXTPRibbonBar::m_rcQuickAccess
CRect m_rcQuickAccess
Quick Access bounding rectangle.
Definition XTPRibbonBar.h:1049
CXTPRibbonBar::AddTab
CXTPRibbonTab * AddTab(LPCTSTR lpszCaption)
Call this method to add a new tab to the ribbon bar.
CXTPRibbonBar::SetMinimumVisibleWidth
void SetMinimumVisibleWidth(int nMinVisibleWidth)
Call this method to set the minimum width/height before the ribbon bar disappears.
Definition XTPRibbonBar.h:1120
CXTPRibbonBar::IsQuickAccessControl
BOOL IsQuickAccessControl(CXTPControl *pControl) const
Determines if a control belongs to Quick Access controls.
CXTPRibbonBar::GetControlTab
CXTPRibbonControlTab * GetControlTab() const
Call this method to get the CXTPRibbonControlTab object that represents ribbon tabs.
Definition XTPRibbonBar.h:1115
CXTPRibbonBar::m_nBackstageSysButtonTop
int m_nBackstageSysButtonTop
The top of the sysbutton on the backstage.
Definition XTPRibbonBar.h:1087
CXTPRibbonBar::IsAllowQuickAccessDuplicates
BOOL IsAllowQuickAccessDuplicates() const
Determines if duplicate controls are allowed for Quick Access.
Definition XTPRibbonBar.h:1197
CXTPRibbonBar::CalcGroupsHeight
virtual int CalcGroupsHeight()
Calculates the ribbon groups height using the GetLargeIconSize method and the height of the captions.
CXTPRibbonBar::GetQuickAccessControls
CXTPRibbonQuickAccessControls * GetQuickAccessControls() const
Retrieves the collection of Quick Access controls.
Definition XTPRibbonBar.h:1151
CXTPRibbonBar::GetGroupsHeight
virtual int GetGroupsHeight()
Gets the group area height.
CXTPRibbonBar::PassKeyboardInputToBackstageView
BOOL PassKeyboardInputToBackstageView(UINT message, WPARAM wParam, LPARAM lParam)
Call this method to allow the backstage view to process keyboard input if it is active.
CXTPRibbonBar::SetGroupsVisible
void SetGroupsVisible(BOOL bVisible)
Call this method to show/hide the groups part of the ribbon bar.
CXTPRibbonBar::IsDwmEnabled
BOOL IsDwmEnabled() const
Determines if Vista Glass effect is enabled for the ribbon bar.
CXTPRibbonBar::GetRibbonPaintManager
CXTPRibbonPaintManager * GetRibbonPaintManager() const
Retrieves the ribbon paint manager.
CXTPRibbonBar::m_pContextHeaders
CXTPRibbonTabContextHeaders * m_pContextHeaders
Context header collection.
Definition XTPRibbonBar.h:1073
CXTPRibbonBar::m_rcCaptionText
CRect m_rcCaptionText
Caption text bounding rectangle.
Definition XTPRibbonBar.h:1047
CXTPRibbonBar::m_rcHeader
CRect m_rcHeader
Header bounding rectangle.
Definition XTPRibbonBar.h:1048
CXTPRibbonBar::Reset
void Reset(BOOL bShowWarningMessage)
Resets the ribbon/Quick Access toolbar.
CXTPRibbonBar::RemoveAllTabs
void RemoveAllTabs()
Call this member to remove all tabs.
CXTPRibbonControlSystemButton
CXTPRibbonControlSystemButton is a CXTPControlPopup derived class used as a system button for a Ribbo...
Definition XTPRibbonSystemButton.h:39
CXTPRibbonControlTab
CXTPRibbonControlTab is a CXTPTabManager derived class.
Definition XTPRibbonControlTab.h:56
CXTPRibbonControls
CXTPRibbonControls is a CXTPControls derived class.
Definition XTPRibbonQuickAccessControls.h:39
CXTPRibbonGroup
Represents a single group that is added to a CXTPRibbonTab.
Definition XTPRibbonGroup.h:70
CXTPRibbonGroups
Represents a collection of CXTPRibbonGroup objects.
Definition XTPRibbonGroups.h:51
CXTPRibbonPaintManager
Standalone class used by CXTPRibbonBar as a paint manager.
Definition XTPRibbonPaintManager.h:51
CXTPRibbonQuickAccessControls
CXTPRibbonQuickAccessControls is a CXTPControls derived class.
Definition XTPRibbonQuickAccessControls.h:93
CXTPRibbonTab
Represents a tab in the Ribbon Bar.
Definition XTPRibbonTab.h:116
CXTPRibbonTabPopupToolBar
Implements a pop-up when the Ribbon is in minimzed mode.
Definition XTPRibbonPopups.h:113
CXTPTabPaintManager
CXTPTabPaintManager is used to store the color and appearance information of the tabs in the tab mana...
Definition XTPTabPaintManager.h:48
CXTPToolBar::MergeToolBar
virtual void MergeToolBar(CXTPCommandBar *pCommandBar, BOOL bSilent)
This method is called to restore a toolbar to a previous state.
CXTPToolBar::CalcDockingLayout
virtual CSize CalcDockingLayout(int nLength, DWORD dwMode, int nWidth=0)
This method calculates the dimensions of a toolbar.
CXTPToolBar::m_bVisible
BOOL m_bVisible
TRUE if the command bar is visible.
Definition XTPToolBar.h:456
CXTPToolBar::OnRecalcLayout
void OnRecalcLayout()
This method recalculates the position of the toolbar.
XTP_COMMANDBARS_PROPEXCHANGE_PARAM
XTP_COMMANDBARS_PROPEXCHANGE_PARAM is a structure used to store the CommandBar's save settings.
Definition XTPCommandBars.h:88


Toolkit Pro: Member List

CXTPTrackThemeOffice2003Luna Member List

This is the complete list of members for CXTPTrackThemeOffice2003Luna, including all inherited members.

CalcColumnHeight(CDC *pDC, CXTPGridColumn *pColumn, int nTotalWidth=0) | CXTPGridPaintManager | protectedvirtual
CalculateRowHeight(CDC *pDC, const CString &strText, int nMaxWidth, BOOL bWordBreak=TRUE) | CXTPGridPaintManager | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPGridPaintManager() | CXTPGridPaintManager |
CXTPTrackPaintManager() | CXTPTrackPaintManager |
CXTPTrackThemeOffice2003Luna() | CXTPTrackThemeOffice2003Luna |
DrawBitmap(CDC *pDC, CXTPGridControl *pControl, CRect rcColumn, int iImage) | CXTPGridPaintManager | virtual
DrawCollapsedBitmap(CDC *pDC, const CXTPGridRow *pRow, CRect &rcBitmap) | CXTPGridPaintManager | virtual
DrawColumn(CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn, BOOL bDrawExternal=FALSE, int nShadowWidth=0) | CXTPGridPaintManager | virtual
DrawColumnBackground(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, BOOL &bColumnPressed, BOOL &bDraggingFromHeader, CXTPGridHeader *pHeader=NULL) | CXTPTrackThemeOffice2003Luna | virtual
DrawColumnFooter(CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn) | CXTPGridPaintManager | virtual
DrawColumnFooterDivider(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn) | CXTPTrackThemeOffice2003Luna | virtual
DrawColumnIcon(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, CRect rcIcon, int iIcon) | CXTPGridPaintManager | virtual
DrawColumnText(CDC *pDC, CRect rcText, CString strCaption, int nHeaderAlignment, BOOL bIsHeader, BOOL bColumnPressed) | CXTPGridPaintManager | virtual
DrawConnector(CDC *pDC, CPoint ptFrom, CPoint ptTo) | CXTPGridPaintManager |
DrawFocusedRow(CDC *pDC, CRect rcRow) | CXTPGridPaintManager | virtual
DrawFreezeColsDivider(CDC *pDC, const CRect &rc, CXTPGridControl *pControl, CXTPGridRow *pRow=NULL) | CXTPGridPaintManager | virtual
DrawGlyph(CDC *pDC, CRect rcColumn, int iImage) | CXTPGridPaintManager | virtual
DrawGrid(CDC *pDC, XTPGridOrientation orientation, CRect rcGrid) | CXTPGridPaintManager | virtual
DrawGridPattern(CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush) | CXTPGridPaintManager | protectedvirtual
DrawGridPattern(CDC *pDC, CXTPBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush) | CXTPGridPaintManager | protectedvirtual
DrawGridPattern(CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr) | CXTPGridPaintManager | protectedvirtual
DrawGroupRow(CDC *pDC, CXTPGridGroupRow *pRow, CRect rcRow, XTP_GRIDRECORDITEM_METRICS *pMetrics) | CXTPGridPaintManager | virtual
DrawHorizontalLine(CDC *pDC, int xPos, int yPos, int cx, COLORREF clr) | CXTPGridPaintManager |
DrawInplaceButton(CDC *pDC, CXTPGridInplaceButton *pButton) | CXTPGridPaintManager | virtual
DrawInplaceButtonFrame(CDC *pDC, CXTPGridInplaceButton *pButton) | CXTPGridPaintManager | protectedvirtual
DrawInplaceButtonIcon(CDC *pDC, CXTPGridInplaceButton *pButton) | CXTPGridPaintManager | protectedvirtual
DrawInplaceComboButton(CDC *pDC, CRect *pRc) | CXTPGridPaintManager | virtual
DrawInplaceExpandButton(CDC *pDC, CRect *pRc) | CXTPGridPaintManager | virtual
DrawInplaceSpinButton(CDC *pDC, CRect *pRc) | CXTPGridPaintManager | virtual
DrawItemBitmap(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CRect &rcItem, int nImage) | CXTPGridPaintManager | virtual
DrawItemCaption(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics) | CXTPGridPaintManager | virtual
DrawItemControl(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CXTPGridRecordItemControl *pControl, CRect &rcItem) | CXTPGridPaintManager | virtual
DrawLink(int *pnCurrDrawPos, XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CXTPGridHyperlink *pHyperlink, CString strText, CRect rcLink, int nFlag, BOOL bTrim=FALSE) | CXTPGridPaintManager | protectedvirtual
DrawMarkers(CDC *pDC) | CXTPTrackPaintManager | virtual
DrawMultiLineText(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, BOOL bWordBreak=TRUE) | CXTPGridPaintManager | protectedvirtual
DrawNoGroupByText(CDC *pDC, CRect rcItem) | CXTPGridPaintManager | virtual
DrawRowNumber(CDC *pDC, CRect rcNumber, CXTPGridRow *pRow) | CXTPGridPaintManager | virtual
DrawSectionDivider(CDC *pDC, const CRect &rc, XTPGridSectionDividerPosition dividerPosition, XTPGridSectionDividerStyle dividerStyle, CXTPPaintManagerColor dividerColor) | CXTPTrackThemeOffice2003Luna |
DrawShellIcon(CDC *pDC, CRect rcColumn, int iImage) | CXTPGridPaintManager | virtual
DrawSingleLineText(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nStartPos, int nEndPos, int nActualWidth) | CXTPGridPaintManager | protectedvirtual
DrawString(int *pnCurrDrawPos, CDC *pDC, const CString &strDraw, CRect rcDraw, UINT nFormat) | CXTPGridPaintManager | protectedvirtual
DrawTextLine(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nFlag, int &nCharCounter, int &nHyperlinkCounter) | CXTPGridPaintManager | protectedvirtual
DrawTimeLine(CDC *pDC) | CXTPTrackPaintManager | virtual
DrawTrackHeader(CDC *pDC) | CXTPTrackPaintManager | virtual
DrawTreeStructure(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CRect rcItem, CSize sizeGlyph) | CXTPGridPaintManager | virtual
DrawTriangle(CDC *pDC, CRect rcTriangle, BOOL bToDown, BOOL bDraggingFromHeader, int nShadowWidth, BOOL bColumnPressed) | CXTPGridPaintManager | virtual
DrawVerticalLine(CDC *pDC, int xPos, int yPos, int cy, COLORREF clr) | CXTPGridPaintManager |
DrawVerticalTimeLineMarker(CDC *pDC, int xPos, CXTPGridControl *pControl, COLORREF color=RGB(0, 255, 0)) | CXTPGridPaintManager | virtual
EnablePreviewMode(BOOL bIsPreviewMode) | CXTPGridPaintManager |
FillFooter(CDC *pDC, CRect rcFooter) | CXTPTrackThemeOffice2003Luna | virtual
FillGroupByControl(CDC *pDC, CRect &rcGroupBy) | CXTPGridPaintManager | virtual
FillGroupRowMetrics(CXTPGridGroupRow *pRow, XTP_GRIDRECORDITEM_METRICS *pMetrics, BOOL bPrinting) | CXTPGridPaintManager | virtual
FillHeaderControl(CDC *pDC, CRect rcHeader) | CXTPGridPaintManager | virtual
FillIndent(CDC *pDC, CRect rcRow) | CXTPGridPaintManager | virtual
FillItemShade(CDC *pDC, CRect rcItem) | CXTPGridPaintManager | virtual
FillRow(CDC *pDC, CXTPGridRow *pRow, CRect rcRow) | CXTPGridPaintManager | virtual
FindRowAdjacentToMerged(const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, BOOL bUpward) | CXTPGridPaintManager |
FindRowAdjacentToMergedEx(const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, int &nAdjRowIndex, BOOL bUpward) | CXTPGridPaintManager |
FormatTime(int nPosition) | CXTPTrackPaintManager | virtual
FormatTimeLineTick(int nPosition, COLORREF &clrTick, int &nTickLength) | CXTPTrackPaintManager | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetColumnOffice2007CustomThemeBaseColor() const | CXTPGridPaintManager |
GetColumnStyle() const | CXTPGridPaintManager |
GetControlBackColor(CXTPGridControl *pControl) | CXTPGridPaintManager | virtual
GetFooterHeight(CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0) | CXTPGridPaintManager | virtual
GetFreezeColsDividerStyle() const | CXTPGridPaintManager |
GetGlyphs() const | CXTPGridPaintManager |
GetHeaderHeight() | CXTPGridPaintManager | virtual
GetHeaderHeight(CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0) | CXTPGridPaintManager | virtual
GetItemHeight(XTP_GRIDRECORDITEM_DRAWARGS &drawArgs, int nWidth) | CXTPGridPaintManager |
GetMaxPreviewLines() | CXTPGridPaintManager |
GetPreviewItemHeight(CDC *pDC, CXTPGridRow *pRow, int nWidth, int nHeight) | CXTPGridPaintManager | virtual
GetPreviewLinesCount(CDC *pDC, CRect &rcText, const CString &strText) | CXTPGridPaintManager |
GetRowHeight(CDC *pDC, CXTPGridRow *pRow) | CXTPGridPaintManager | virtual
GetRowHeight(CDC *pDC, CXTPGridRow *pRow, int nTotalWidth) | CXTPGridPaintManager | virtual
GetRowHeightEx(CDC *pDC, CXTPGridRow *pRow, int nTotalWidth, const BOOL firstLevel=TRUE) | CXTPGridPaintManager |
GetSectionDividerHeight(XTPGridFixedRowsDividerStyle dividerStyle) | CXTPGridPaintManager |
GetTextFont() | CXTPGridPaintManager |
IsColumHotTrackingEnabled() const | CXTPTrackThemeOffice2003Luna | virtual
IsColumnPlusMinusSign() const | CXTPGridPaintManager |
IsColumnWidthWYSIWYG() const | CXTPGridPaintManager |
IsDrawGridForEmptySpace() const | CXTPGridPaintManager |
IsFixedInplaceButtonHeight() const | CXTPGridPaintManager |
IsFixedRowHeight() const | CXTPGridPaintManager |
IsGridVisible(BOOL bVertical) const | CXTPGridPaintManager |
IsGridVisible(XTPGridOrientation orientation) const | CXTPGridPaintManager |
IsLastColumnWidthWYSIWYG() const | CXTPGridPaintManager |
IsPreviewMode() const | CXTPGridPaintManager |
IsPrintGroupRowIcon() const | CXTPGridPaintManager |
IsShowWYSIWYGMarkers() const | CXTPGridPaintManager |
IsUseDropMarker() const | CXTPGridPaintManager |
LoadGlyphs() | CXTPGridPaintManager | virtual
m_arStartCol | CXTPGridPaintManager |
m_bAllowMergeCells | CXTPGridPaintManager |
m_bBaseTreeIndent | CXTPGridPaintManager |
m_bCleanTooltip | CXTPGridPaintManager |
m_bColumnPlusMinusSign | CXTPGridPaintManager | protected
m_bColumnWidthWYSIWYG | CXTPGridPaintManager | protected
m_bCompactText | CXTPGridPaintManager |
m_bDrawGridForEmptySpace | CXTPGridPaintManager | protected
m_bFixedInplaceButtonHeight | CXTPGridPaintManager | protected
m_bFixedRowHeight | CXTPGridPaintManager | protected
m_bForceDynamicMarkupForCell | CXTPGridPaintManager |
m_bForceShowDropMarker | CXTPGridPaintManager |
m_bForceShowTooltip | CXTPGridPaintManager |
m_bGrayIfDisable | CXTPGridPaintManager |
m_bGroupRowTextBold | CXTPGridPaintManager |
m_bHideSelection | CXTPGridPaintManager |
m_bHotTracking | CXTPGridPaintManager |
m_bInvertColumnOnClick | CXTPGridPaintManager |
m_bIsPreviewMode | CXTPGridPaintManager | protected
m_bLastColumnWidthWYSIWYG | CXTPGridPaintManager | protected
m_bMakeUpper | CXTPGridPaintManager |
m_bMoveScrollbarOnFixedColumnsIndent | CXTPGridPaintManager |
m_bPrintGroupRowIcon | CXTPGridPaintManager | protected
m_bPrintPageRectangle | CXTPGridPaintManager |
m_bPrintSortTriangle | CXTPGridPaintManager |
m_bPrintVirtualPageNumber | CXTPGridPaintManager |
m_bPrintWatermark | CXTPGridPaintManager |
m_bRecOrRowNum | CXTPGridPaintManager |
m_bRevertAlignment | CXTPGridPaintManager |
m_bShadeGroupHeadings | CXTPGridPaintManager |
m_bShadeSortColumn | CXTPGridPaintManager |
m_bShowLockIcon | CXTPGridPaintManager |
m_bShowNonActiveInPlaceButton | CXTPGridPaintManager |
m_bShowWYSIWYGMarkers | CXTPGridPaintManager | protected
m_bSortTriangleOffsetFromRight | CXTPGridPaintManager |
m_bThemedInplaceButtons | CXTPGridPaintManager |
m_bUseAlternativeBackground | CXTPGridPaintManager |
m_bUseDropMarker | CXTPGridPaintManager |
m_bUseEditTextAlignment | CXTPGridPaintManager |
m_bUseGroupRowSelectionState | CXTPGridPaintManager |
m_bUseShellIcon | CXTPGridPaintManager |
m_clrAlternativeBackground | CXTPGridPaintManager |
m_clrBoldText | CXTPGridPaintManager |
m_clrBoldTextHighlight | CXTPGridPaintManager |
m_clrBtnFace | CXTPGridPaintManager |
m_clrBtnFacePressed | CXTPGridPaintManager |
m_clrBtnText | CXTPGridPaintManager |
m_clrCaptionText | CXTPGridPaintManager |
m_clrCaptionTextPressed | CXTPGridPaintManager |
m_clrColumnOffice2007CustomTheme | CXTPGridPaintManager |
m_clrConnector | CXTPGridPaintManager |
m_clrControlBack | CXTPGridPaintManager |
m_clrControlDark | CXTPGridPaintManager |
m_clrControlLightLight | CXTPGridPaintManager |
m_clrDisableBitmapDarkest | CXTPGridPaintManager |
m_clrDisableBitmapLightest | CXTPGridPaintManager |
m_clrFormulaSubSum | CXTPGridPaintManager |
m_clrFormulaSum | CXTPGridPaintManager |
m_clrFreezeColsDivider | CXTPGridPaintManager |
m_clrGradientColumnSeparator | CXTPGridPaintManager |
m_clrGradientColumnShadow | CXTPGridPaintManager |
m_clrGroupBoxBack | CXTPGridPaintManager |
m_clrGroupRowText | CXTPGridPaintManager |
m_clrGroupShadeBack | CXTPGridPaintManager |
m_clrGroupShadeBorder | CXTPGridPaintManager |
m_clrGroupShadeText | CXTPGridPaintManager |
m_clrHeaderControl | CXTPGridPaintManager |
m_clrHighlight | CXTPGridPaintManager |
m_clrHighlightText | CXTPGridPaintManager |
m_clrHotDivider | CXTPGridPaintManager |
m_clrIndentControl | CXTPGridPaintManager |
m_clrItemShade | CXTPGridPaintManager |
m_clrMarker | CXTPTrackPaintManager |
m_clrMarkerBack | CXTPTrackPaintManager |
m_clrMarkerBorder | CXTPTrackPaintManager |
m_clrPreviewText | CXTPGridPaintManager |
m_clrScrollBarBorderDark | CXTPTrackPaintManager |
m_clrScrollBarBorderLight | CXTPTrackPaintManager |
m_clrScrollBarDark | CXTPTrackPaintManager |
m_clrScrollBarLight | CXTPTrackPaintManager |
m_clrSelectedArea | CXTPTrackPaintManager |
m_clrSelectedRow | CXTPGridPaintManager |
m_clrSelectedRowText | CXTPGridPaintManager |
m_clrTimeHeaderBorder | CXTPTrackPaintManager |
m_clrTimeHeaderDark | CXTPTrackPaintManager |
m_clrTimeHeaderDarkDark | CXTPTrackPaintManager |
m_clrTimeHeaderDivider | CXTPTrackPaintManager |
m_clrTimeLinePosition | CXTPTrackPaintManager |
m_clrTimeLineTick | CXTPTrackPaintManager |
m_clrTimeSliderBackground | CXTPTrackPaintManager |
m_clrTrackHeader | CXTPTrackPaintManager |
m_clrTrackMarkerBorder | CXTPTrackPaintManager |
m_clrTrackMarkerText | CXTPTrackPaintManager |
m_clrTrackMarkerTextBack | CXTPTrackPaintManager |
m_clrTrackMarkerTextBorder | CXTPTrackPaintManager |
m_clrTrackTimeArea | CXTPTrackPaintManager |
m_clrWindowText | CXTPGridPaintManager |
m_clrWorkArea | CXTPTrackPaintManager |
m_clrWorkAreaScrollBarBorder | CXTPTrackPaintManager |
m_clrWorkAreaScrollBarDark | CXTPTrackPaintManager |
m_clrWorkAreaScrollBarLight | CXTPTrackPaintManager |
m_columnStyle | CXTPGridPaintManager | protected
m_crlNoGroupByText | CXTPGridPaintManager |
m_grcGradientColumn | CXTPGridPaintManager |
m_grcGradientColumnHot | CXTPGridPaintManager |
m_grcGradientColumnPushed | CXTPGridPaintManager |
m_iRecOrRowStart | CXTPGridPaintManager |
m_nBaseParentRecordIndent | CXTPGridPaintManager |
m_nFixedColumnsIndent | CXTPGridPaintManager |
m_nFooterHeight | CXTPGridPaintManager | protected
m_nFreezeColsDividerStyle | CXTPGridPaintManager | protected
m_nGridLineStylePreviousH | CXTPGridPaintManager | protected
m_nGridLineStylePreviousV | CXTPGridPaintManager | protected
m_nGroupGridLineHeight | CXTPGridPaintManager | protected
m_nGroupGridLineStyle | CXTPGridPaintManager | protected
m_nHeaderHeight | CXTPGridPaintManager | protected
m_nMaxPreviewLines | CXTPGridPaintManager | protected
m_nResizingWidth | CXTPGridPaintManager | protected
m_nRowHeight | CXTPGridPaintManager | protected
m_nRowHeightDefault | CXTPGridPaintManager |
m_nTextIndentForGroupRowsWithNoIcon | CXTPGridPaintManager |
m_nTreeColumnLineLength | CXTPGridPaintManager |
m_nTreeIndent | CXTPGridPaintManager |
m_nTreeStructureStyle | CXTPGridPaintManager |
m_nTreeTextIndent | CXTPGridPaintManager |
m_nTreeTextIndentGroupRow | CXTPGridPaintManager |
m_nTreeTextIndentRowChildren | CXTPGridPaintManager |
m_nTreeTextIndentRowParent | CXTPGridPaintManager |
m_pControl | CXTPGridPaintManager | protected
m_pGlyphs | CXTPGridPaintManager | protected
m_pHyperlinkHoverStyle | CXTPGridPaintManager |
m_pHyperlinkStyle | CXTPGridPaintManager |
m_pMarkupUIElement_NoGroupBy | CXTPGridPaintManager | protected
m_PrintPageWidth | CXTPGridPaintManager |
m_rcPreviewIndent | CXTPGridPaintManager |
m_RecordNumberWidth | CXTPGridPaintManager |
m_strCollapse | CXTPGridPaintManager |
m_strDecreasing | CXTPGridPaintManager |
m_strExpand | CXTPGridPaintManager |
m_strIncreasing | CXTPGridPaintManager |
m_strMarkupUIElement_NoGroupBy | CXTPGridPaintManager | protected
m_strNoFieldsAvailable | CXTPGridPaintManager |
m_strNoGroupBy | CXTPGridPaintManager |
m_strNoItems | CXTPGridPaintManager |
m_strSortBy | CXTPGridPaintManager |
m_szGlyph | CXTPGridPaintManager | protected
m_themeButton | CXTPGridPaintManager | protected
m_themeCombo | CXTPGridPaintManager | protected
m_themeHeader | CXTPGridPaintManager | protected
m_themeSpin | CXTPGridPaintManager | protected
m_treeStructureStyle | CXTPGridPaintManager |
m_xtpBrushGroupGridLineStyle | CXTPGridPaintManager | protected
m_xtpBrushHorizontalGrid | CXTPGridPaintManager | protected
m_xtpBrushTreeStructure | CXTPGridPaintManager | protected
m_xtpBrushVeriticalGrid | CXTPGridPaintManager | protected
m_xtpFontBoldText | CXTPGridPaintManager |
m_xtpFontCaption | CXTPGridPaintManager |
m_xtpFontPreview | CXTPGridPaintManager |
m_xtpFontText | CXTPGridPaintManager |
OnDrawAction(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs) | CXTPGridPaintManager | virtual
RecalcTotalHightOfMergedRows(CXTPGridColumns *pColumns, CDC *pDC, CXTPGridRow *pRow, int nRowHeight, int nTotalWidth) | CXTPGridPaintManager |
RefreshMetrics() | CXTPTrackThemeOffice2003Luna | virtual
SetCaptionFont(LOGFONT &lf) | CXTPGridPaintManager |
SetColumnOffice2007CustomThemeBaseColor(COLORREF clrBaseColor) | CXTPGridPaintManager |
SetColumnPlusMinusSign(BOOL bDraw) | CXTPGridPaintManager |
SetColumnWidthWYSIWYG(BOOL bColumnWidthWYSIWYG) | CXTPGridPaintManager |
SetDrawGridForEmptySpace(BOOL bDrawGrid) | CXTPGridPaintManager |
SetFixedRowHeight(BOOL bFixedRowHeight) | CXTPGridPaintManager |
SetFreezeColsDividerStyle(int nStyle) | CXTPGridPaintManager |
SetGridControl(CXTPGridControl *pControl) | CXTPGridPaintManager | virtual
SetHeaderHeight(int nHeight) | CXTPGridPaintManager | virtual
SetInplaceButtonHeight(BOOL bFixedInplaceButtonHeight) | CXTPGridPaintManager |
SetLastColumnWidthWYSIWYG(BOOL bColumnWidthWYSIWYG) | CXTPGridPaintManager |
SetMaxPreviewLines(int nMaxLines) | CXTPGridPaintManager |
SetPreviewIndent(int nLeft, int nTop, int nRight, int nBottom) | CXTPGridPaintManager |
SetPrintGroupRowIcon(BOOL bDraw) | CXTPGridPaintManager |
SetTextFont(LOGFONT &lf) | CXTPGridPaintManager |
ShowWYSIWYGMarkers(BOOL bSet) | CXTPGridPaintManager |
~CXTPGridPaintManager() | CXTPGridPaintManager | virtual
~CXTPTrackPaintManager() | CXTPTrackPaintManager |


Toolkit Pro: XTPFunctions.h Source File

  • Source
  • Controls
  • Util
XTPFunctions.h
Go to the documentation of this file.
1
23#if !defined(__XTPFUNCTIONS_H__)
24# define __XTPFUNCTIONS_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33# if defined(XTP_INIT_BY_REGULAR_DLL)
34
59_XTP_EXT_CLASS void AFXAPI XTPInitDLL();
60
61# endif //#if defined(XTP_INIT_BY_REGULAR_DLL)
62
63class CXTPImageManager;
64
74_XTP_EXT_CLASS void AFXAPI XTPChangeWindowFont(CWnd* pWnd, CFont* pFont);
75
89_XTP_EXT_CLASS void AFXAPI XTPDrawEmbossed(CDC* pDC, CImageList& imageList, int nIndex,
90 CPoint point, BOOL bInColor);
91
102_XTP_EXT_CLASS void AFXAPI XTPDrawShadedRect(CDC* pDC, CRect& rect);
103
114_XTP_EXT_CLASS HWND AFXAPI XTPChildWindowFromPoint(HWND hWnd, POINT point);
115
128_XTP_EXT_CLASS BOOL AFXAPI XTPPathExists(LPCTSTR lpszFileName);
129
152_XTP_EXT_CLASS CWnd* AFXAPI XTPCreateView(CWnd* pParentWnd, CRuntimeClass* pViewClass,
153 CDocument* pDocument = NULL,
154 CCreateContext* pContext = NULL,
155 DWORD dwStyle = AFX_WS_DEFAULT_VIEW,
156 CWnd* pOwnerWnd = NULL, UINT nID = AFX_IDW_PANE_FIRST);
157
213_XTP_EXT_CLASS BOOL AFXAPI XTPContextMenu(CMenu* pPopup, UINT nFlags, int xPos, int yPos,
214 CWnd* pWnd, int nIDBitmap, BOOL bNoNotify = TRUE);
215
268_XTP_EXT_CLASS BOOL AFXAPI XTPContextMenu(CMenu* pPopup, UINT nFlags, int xPos, int yPos,
269 CWnd* pWnd, CXTPImageManager* pImageManager,
270 BOOL bNoNotify = TRUE);
271
273
274# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
276#endif // #if !defined(__XTPFUNCTIONS_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPDrawEmbossed
_XTP_EXT_CLASS void AFXAPI XTPDrawEmbossed(CDC *pDC, CImageList &imageList, int nIndex, CPoint point, BOOL bInColor)
The XTPDrawEmbossed function will draw an embossed icon onto the specified device context from the im...
XTPContextMenu
_XTP_EXT_CLASS BOOL AFXAPI XTPContextMenu(CMenu *pPopup, UINT nFlags, int xPos, int yPos, CWnd *pWnd, int nIDBitmap, BOOL bNoNotify=TRUE)
Call this member function to display a context menu that is compatible with both pro and standard ver...
XTPCreateView
_XTP_EXT_CLASS CWnd *AFXAPI XTPCreateView(CWnd *pParentWnd, CRuntimeClass *pViewClass, CDocument *pDocument=NULL, CCreateContext *pContext=NULL, DWORD dwStyle=AFX_WS_DEFAULT_VIEW, CWnd *pOwnerWnd=NULL, UINT nID=AFX_IDW_PANE_FIRST)
Creates a view based on a CRuntimeClass object.
XTPDrawShadedRect
_XTP_EXT_CLASS void AFXAPI XTPDrawShadedRect(CDC *pDC, CRect &rect)
Renders a shadow onto the specified device context.
XTPChangeWindowFont
_XTP_EXT_CLASS void AFXAPI XTPChangeWindowFont(CWnd *pWnd, CFont *pFont)
The XTPChangeWindowFont function will set the font for the window specified by pWnd and all of the ch...
XTPPathExists
_XTP_EXT_CLASS BOOL AFXAPI XTPPathExists(LPCTSTR lpszFileName)
The XTPPathExists function searches a directory for a file or sub-directory whose name matches the sp...
XTPChildWindowFromPoint
_XTP_EXT_CLASS HWND AFXAPI XTPChildWindowFromPoint(HWND hWnd, POINT point)
The XTPChildWindowFromPoint function will retrieve an HWND handle for the child window (if any) locat...
CXTPImageManager
CXTPImageManager is a standalone class.
Definition XTPImageManager.h:1898


Toolkit Pro: Member List

CXTPControlComboBoxList Member List

This is the complete list of members for CXTPControlComboBoxList, including all inherited members.

AdjustExcludeRect(CRect &rc, BOOL bVertical) | CXTPPopupBar | protectedvirtual
Animate() | CXTPPopupBar | protectedvirtual
CalcDynamicLayout(int nLength, DWORD dwMode) | CXTPPopupBar | virtual
CalculatePopupRect(CPoint ptPopup, CSize sz) | CXTPPopupBar | virtual
Copy(CXTPCommandBar *pCommandBar, BOOL bRecursive=FALSE) | CXTPControlComboBoxList | protectedvirtual
Create() | CXTPPopupBar | virtual
CreateKeyboardTips() | CXTPCommandBar | virtual
CreateListBox() | CXTPControlComboBoxList | virtual
CreatePopupBar(CXTPCommandBars *pCommandBars) | CXTPPopupBar | static
CXTPCommandBar() | CXTPCommandBar | protected
CXTPControlComboBoxList() | CXTPControlComboBoxList |
CXTPControlComboBoxPopupBar() | CXTPControlComboBoxPopupBar |
CXTPHookManagerHookAble() | CXTPHookManagerHookAble |
CXTPPopupBar() | CXTPPopupBar | protected
DelayLayout() | CXTPCommandBar |
DelayRedraw() | CXTPPopupBar | inlineprotectedvirtual
DestroyWindow() | CXTPPopupBar |
DisableShadow() | CXTPPopupBar |
DoPropExchange(CXTPPropExchange *pPX) | CXTPControlComboBoxList | protectedvirtual
DrawCommandBar(CDC *pDC, CRect rcClipBox) | CXTPControlComboBoxList | protectedvirtual
DrawItem(LPDRAWITEMSTRUCT lpDrawItemStruct) | CXTPControlComboBoxList | protectedvirtual
EnableAnimation(BOOL bEnable=TRUE) | CXTPCommandBar |
EnableCustomization(BOOL bEnable=TRUE) | CXTPCommandBar |
EnableDoubleBuffer(BOOL bEnable=TRUE) | CXTPCommandBar |
EnsureVisible(CXTPControl *pControl) | CXTPCommandBar | virtual
ExpandBar() | CXTPPopupBar |
FillCommandBarEntry(CDC *pDC) | CXTPCommandBar | virtual
FindAccel(TCHAR chAccel) const | CXTPCommandBar |
FindAccelEx(UINT chAccel, BOOL &bSelectOnly) const | CXTPCommandBar |
GenerateCommandBarList(DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam) | CXTPCommandBar | protectedvirtual
GetActiveDocTemplate() const | CXTPCommandBar | protected
GetBarID() const | CXTPCommandBar |
GetBorders() | CXTPPopupBar | virtual
GetButtonSize() const | CXTPCommandBar | virtual
GetCommandBarData() const | CXTPCommandBar |
GetCommandBars() const | CXTPCommandBar |
GetControl(int nIndex) const | CXTPCommandBar |
GetControlCount() const | CXTPCommandBar |
GetControlPopup() const | CXTPPopupBar |
GetControls() const | CXTPCommandBar |
GetDefaultButtonStyle() const | CXTPCommandBar |
GetDefaultItem(UINT gmdiFlags, BOOL fByPos=FALSE) | CXTPPopupBar |
GetFlags() const | CXTPCommandBar |
GetFrameSite() const | CXTPCommandBar |
GetIconSize() const | CXTPCommandBar | virtual
GetImageManager() const | CXTPCommandBar |
GetLargeIconSize(BOOL bAutoSize) const | CXTPCommandBar |
GetListBoxCtrl() const | CXTPControlComboBoxList |
GetOwnerSite() const | CXTPCommandBar |
GetPaintManager() const | CXTPCommandBar |
GetParentCommandBar() const | CXTPPopupBar | protectedvirtual
GetPosition() const | CXTPCommandBar |
GetRootParent() const | CXTPCommandBar |
GetSelected() const | CXTPCommandBar |
GetShowGripper() const | CXTPCommandBar |
GetSite() const | CXTPCommandBar |
GetTextOrientation() const | CXTPCommandBar |
GetTitle() const | CXTPCommandBar |
GetTrackFocus() const | CXTPCommandBar |
GetType() const | CXTPCommandBar |
GetWidth() const | CXTPCommandBar |
HideKeyboardTips() | CXTPCommandBar |
InvalidateParents() | CXTPCommandBar |
IsAnimationEnabled() const | CXTPCommandBar |
IsContextMenu() const | CXTPPopupBar |
IsCustomizable() const | CXTPControlComboBoxList | inlineprotectedvirtual
IsCustomizeDialogPresent() const | CXTPCommandBar |
IsCustomizeMode() const | CXTPCommandBar |
IsDialogBar() const | CXTPCommandBar | virtual
IsDoubleGripper() const | CXTPPopupBar |
IsHelpMode() const | CXTPCommandBar | protected
IsKeyboardCuesVisible() const | CXTPCommandBar | virtual
IsKeyboardTipsVisible() const | CXTPCommandBar |
IsLayoutRTL() const | CXTPCommandBar |
IsMenuTitleBar() const | CXTPCommandBar | virtual
IsPopupBar() const | CXTPPopupBar | virtual
IsResizable() const | CXTPPopupBar | virtual
IsRibbonBar() const | CXTPCommandBar | virtual
IsTearOffPopup(CString &strCaption, UINT &nID, int &nWidth) | CXTPPopupBar |
IsTextBelowIcons() const | CXTPCommandBar |
IsTrackingMode() const | CXTPCommandBar |
IsVisible() const | CXTPPopupBar | virtual
LoadMenu(CMenu *pMenu, BOOL bRemoveControls=TRUE) | CXTPCommandBar | virtual
LoadToolBar(UINT nIDResource, BOOL bLoadIcons=TRUE) | CXTPCommandBar | virtual
LockMouseMove(CXTPControl *pControl) | CXTPCommandBar |
LockRedraw() | CXTPCommandBar |
m_bAnimatePopup | CXTPCommandBar | protected
m_barPosition | CXTPCommandBar | protected
m_barType | CXTPCommandBar | protected
m_bAutoDestroy | CXTPHookManagerHookAble |
m_bCloseable | CXTPCommandBar | protected
m_bCollapsed | CXTPPopupBar | protected
m_bComboBar | CXTPCommandBar |
m_bContextMenu | CXTPPopupBar | protected
m_bCustomizable | CXTPCommandBar | protected
m_bCustomizeDialogPresent | CXTPCommandBar | protected
m_bDoubleGripper | CXTPPopupBar | protected
m_bDynamicLayout | CXTPPopupBar | protected
m_bExecOnRButton | CXTPCommandBar | protected
m_bExpanded | CXTPPopupBar | protected
m_bExpanding | CXTPPopupBar | protected
m_bGrabFocus | CXTPCommandBar | protected
m_bIgnoreUpdateHandler | CXTPCommandBar | protected
m_bKeyboardSelect | CXTPCommandBar | protected
m_bMultiLine | CXTPCommandBar | protected
m_bRecursePopup | CXTPCommandBar | protected
m_bResizable | CXTPPopupBar | protected
m_bShowShadow | CXTPPopupBar | protected
m_bTearOffPopup | CXTPPopupBar | protected
m_bTearOffSelected | CXTPPopupBar | protected
m_bTearOffTracking | CXTPPopupBar | protected
m_bTextBelow | CXTPCommandBar | protected
m_bTracking | CXTPCommandBar | protected
m_bTrackOnHover | CXTPCommandBar |
m_buttonStyle | CXTPCommandBar | protected
m_bVerticalMarker | CXTPCommandBar | protected
m_dMaxWidthDivisor | CXTPPopupBar | static
m_dwData | CXTPCommandBar | protected
m_dwFlags | CXTPCommandBar | protected
m_dwStyle | CXTPCommandBar | protected
m_hwndFocus | CXTPCommandBar | protected
m_nBarID | CXTPCommandBar | protected
m_nIdleFlags | CXTPCommandBar | protected
m_nLockRedraw | CXTPCommandBar | protected
m_nMaxHeight | CXTPPopupBar | protected
m_nMRUWidth | CXTPCommandBar | protected
m_nPopuped | CXTPCommandBar | protected
m_nSelected | CXTPCommandBar | protected
m_nStateFlags | CXTPCommandBar |
m_nTearOffID | CXTPPopupBar | protected
m_nTearOffTimer | CXTPPopupBar | protected
m_nTearOffWidth | CXTPPopupBar | protected
m_nTextOrientation | CXTPCommandBar | protected
m_pAnimation | CXTPCommandBar | protected
m_pCommandBars | CXTPCommandBar | protected
m_pControlPopup | CXTPPopupBar | protected
m_pControls | CXTPCommandBar | protected
m_pImageManager | CXTPCommandBar | protected
m_popupFlags | CXTPPopupBar | protected
m_pOwner | CXTPCommandBar | protected
m_pPaintManager | CXTPCommandBar | protected
m_pReturnCmd | CXTPCommandBar | protected
m_pSite | CXTPCommandBar | protected
m_pTearOffBar | CXTPPopupBar | protected
m_pToolTipContext | CXTPCommandBar | protected
m_ptPopup | CXTPPopupBar | protected
m_rcBorders | CXTPPopupBar | protected
m_rcExclude | CXTPPopupBar | protected
m_rcMarker | CXTPCommandBar | protected
m_rcResizeGripper | CXTPPopupBar | protected
m_rcTearOffGripper | CXTPPopupBar | protected
m_strTearOffCaption | CXTPPopupBar | protected
m_strTitle | CXTPCommandBar | protected
m_szButtons | CXTPCommandBar | protected
m_szButtonSpacing | CXTPCommandBar | protected
m_szIcons | CXTPCommandBar | protected
m_szTearOffBar | CXTPPopupBar | protected
MeasureItem(LPMEASUREITEMSTRUCT lpMeasureItemStruct) | CXTPControlComboBoxList | protectedvirtual
OnControlsChanged() | CXTPPopupBar | protectedvirtual
OnControlSelected(BOOL bSelected, CXTPControl *pControl) | CXTPCommandBar | virtual
OnCustomizeDragEnter(CXTPControl *pDataObject, CPoint point) | CXTPCommandBar | virtual
OnCustomizeDragLeave() | CXTPCommandBar | virtual
OnCustomizeDragOver(CXTPControl *pDataObject, CPoint point) | CXTPCommandBar | virtual
OnCustomizeDrop(CXTPControl *pDataObject, DROPEFFECT &dropEffect, CPoint ptDrop, CPoint ptDrag) | CXTPCommandBar | virtual
OnHookAttached(HWND hWnd) | CXTPHookManagerHookAble | virtual
OnHookDetached() | CXTPHookManagerHookAble | virtual
OnHookKeyDown(UINT nChar, LPARAM lParam) | CXTPControlComboBoxList | protectedvirtual
OnHookMessage(HWND hWnd, UINT nMessage, WPARAM &wParam, LPARAM &lParam, LRESULT &lResult) | CXTPControlComboBoxList | protectedvirtual
OnKeyboardTip(CXTPCommandBarKeyboardTip *pTip) | CXTPCommandBar | virtual
OnKeyboardTipChar(UINT chAccel) | CXTPCommandBar |
OnMouseHitTest(CPoint pt) | CXTPCommandBar | protectedvirtual
OnPostHookMessage(HWND hWnd, UINT nMessage, WPARAM &wParam, LPARAM &lParam, LRESULT &lResult) | CXTPHookManagerHookAble | virtual
OnRecalcLayout() | CXTPPopupBar | protectedvirtual
OnRemoved() | CXTPCommandBar | protectedvirtual
OnTrackEnter() | CXTPCommandBar | virtual
OnTrackLost() | CXTPCommandBar | virtual
Popup(CXTPControlPopup *pControlPopup, BOOL bSelectFirst=FALSE) | CXTPControlComboBoxList | protectedvirtual
CXTPControlComboBoxPopupBar::Popup(int xPos, int yPos, LPCRECT rcExclude) | CXTPPopupBar |
ProcessHookKeyDown(CXTPControlComboBox *pComboBox, UINT nChar, LPARAM lParam) | CXTPControlComboBoxList | protected
ProcessSpecialKey(XTPSpecialKey key) | CXTPCommandBar | protectedvirtual
PumpMessage() | CXTPPopupBar |
Redraw(LPCRECT lpRect=0, BOOL bAnimate=TRUE) | CXTPCommandBar | virtual
RestoreCommandBarList(CXTPCommandBarList *pCommandBarList) | CXTPCommandBar | protectedvirtual
s_nExpandDelay | CXTPCommandBar | static
s_nExpandHoverDelay | CXTPCommandBar | static
s_nHoverDelay | CXTPCommandBar | static
SetBarID(UINT nID) | CXTPCommandBar |
SetBorders(CRect rcBorders) | CXTPPopupBar |
SetButtons(UINT *pButtons, int nCount) | CXTPCommandBar |
SetButtonSize(CSize size) | CXTPCommandBar |
SetCommandBarData(DWORD_PTR dwData) | CXTPCommandBar |
SetCommandBars(CXTPCommandBars *pCommandBars) | CXTPCommandBar |
SetControls(CXTPControls *pControls) | CXTPCommandBar |
SetDefaultButtonStyle(XTPButtonStyle buttonStyle) | CXTPCommandBar |
SetDefaultItem(UINT uItem, BOOL fByPos=FALSE) | CXTPPopupBar |
SetDoubleGripper(BOOL bDoubleGripper=TRUE) | CXTPPopupBar |
SetFlags(DWORD dwFlagsAdd, DWORD dwFlagsRemove=0) | CXTPCommandBar |
SetGrabFocus(BOOL bGrabFocus) | CXTPCommandBar |
SetIconSize(CSize size) | CXTPCommandBar |
SetImageManager(CXTPImageManager *pImageManager) | CXTPCommandBar |
SetPaintManager(CXTPPaintManager *pPaintManager) | CXTPCommandBar |
SetPopuped(int nPopuped, BOOL bKeyboard=FALSE) | CXTPCommandBar |
SetPopupFlags(DWORD dwPopupFlags) | CXTPPopupBar |
SetPopupToolBar(BOOL bToolBarType) | CXTPPopupBar |
SetPosition(XTPBarPosition barPosition) | CXTPCommandBar | virtual
SetSelected(int nSelected, BOOL bKeyboard=FALSE) | CXTPPopupBar | protectedvirtual
SetShowGripper(BOOL bShow) | CXTPCommandBar |
SetStatusText(const CString &strDescription) | CXTPCommandBar |
SetTearOffPopup(LPCTSTR lpszCaption, UINT nID, int nWidth=400) | CXTPPopupBar |
SetTextOrientation(XTPBarTextOrientation nTextOrientation) | CXTPCommandBar |
SetTitle(LPCTSTR lpszTitle) | CXTPCommandBar |
SetTrackFocus(HWND hwnd) | CXTPCommandBar |
SetTrackingMode(int bMode, BOOL bSelectFirst, BOOL bKeyboard=FALSE) | CXTPControlComboBoxList | protectedvirtual
SetVisible(BOOL bVisible) | CXTPCommandBar | virtual
SetWidth(int nWidth) | CXTPCommandBar |
ShowTextBelowIcons(BOOL bTextBelow=TRUE) | CXTPCommandBar |
UnlockMouseMove() | CXTPCommandBar |
UnlockRedraw() | CXTPCommandBar |
UpdateExpandingState() | CXTPPopupBar | protected
UpdateFlags() | CXTPPopupBar | protectedvirtual
UpdateLocation(CSize sz) | CXTPPopupBar | protected
UpdateShortcuts() | CXTPCommandBar | protectedvirtual
~CXTPCommandBar() | CXTPCommandBar | protectedvirtual
~CXTPHookManagerHookAble() | CXTPHookManagerHookAble | virtual
~CXTPPopupBar() | CXTPPopupBar | protectedvirtual


Toolkit Pro: Member List

CXTPRibbonThemeVisualStudio2015 Member List

This is the complete list of members for CXTPRibbonThemeVisualStudio2015, including all inherited members.

CreateTabPaintManager() | CXTPRibbonPaintManager | protectedvirtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPRibbonMarkupTheme(CXTPPaintManager *pPaintManager) | CXTPRibbonMarkupTheme |
CXTPRibbonOffice2013Theme(CXTPPaintManager *pPaintManager) | CXTPRibbonOffice2013Theme |
CXTPRibbonPaintManager(CXTPPaintManager *pPaintManager) | CXTPRibbonPaintManager |
CXTPRibbonThemeVisualStudio2015(CXTPPaintManager *pPaintManager) | CXTPRibbonThemeVisualStudio2015 |
DrawBackImage(CDC *pDC, CXTPRibbonBar *pRibbonBar) | CXTPRibbonOffice2013Theme | protectedvirtual
DrawControlGroupOption(CDC *pDC, CXTPControl *pControlGroupOption, BOOL bDraw) | CXTPRibbonMarkupTheme | virtual
DrawControlGroupPopup(CDC *pDC, CXTPControlPopup *pControlGroupPopup, BOOL bDraw) | CXTPRibbonMarkupTheme | virtual
DrawDwmCaptionText(CDC *pDC, CRect rcCaptionText, CString strText, CWnd *pSite, BOOL bActive) | CXTPRibbonPaintManager | protected
DrawGroup(CDC *pDC, CXTPRibbonGroup *pGroup) | CXTPRibbonMarkupTheme | virtual
DrawQuickAccessControl(CDC *pDC, CXTPRibbonBar *pRibbon, CXTPControl *pControl) | CXTPRibbonOffice2013Theme | virtual
DrawRibbonApplicationIcon(CDC *pDC, CXTPRibbonBar *pRibbonBar, CRect rc, HICON hIcon) | CXTPRibbonPaintManager | protected
DrawRibbonFrameCaption(CDC *pDC, CXTPRibbonBar *pRibbonBar, BOOL bActive) | CXTPRibbonOffice2013Theme | virtual
DrawRibbonFrameCaptionBar(CDC *pDC, CXTPRibbonBar *pRibbonBar, BOOL bActive) | CXTPRibbonOffice2013Theme | virtual
DrawRibbonFrameContextHeaders(CDC *pDC, CXTPRibbonBar *pRibbonBar, CXTPRibbonTabContextHeaders *pContextHeaders) | CXTPRibbonOffice2013Theme | virtual
DrawRibbonFramePart(CDC *pDC, CXTPRibbonBar *pRibbonBar) | CXTPRibbonPaintManager | virtual
DrawRibbonFrameSystemButton(CDC *pDC, CXTPRibbonControlSystemButton *pControl, CRect rc) | CXTPRibbonOffice2013Theme | virtual
DrawRibbonGroupControlEntry(CDC *pDC, CXTPControl *pButton) | CXTPRibbonMarkupTheme | virtual
DrawRibbonGroupPopupToolBar(CDC *pDC, CXTPRibbonGroup *pRibbonGroup) | CXTPRibbonMarkupTheme | virtual
DrawRibbonQuickAccessButton(CDC *pDC, CXTPControlPopup *pControl) | CXTPRibbonMarkupTheme | virtual
DrawRibbonQuickAccessControls(CDC *pDC, CXTPRibbonBar *pRibbonBar) | CXTPRibbonMarkupTheme | virtual
DrawRibbonQuickAccessMoreButton(CDC *pDC, CXTPControlPopup *pControl) | CXTPRibbonMarkupTheme | virtual
DrawRibbonScrollButton(CDC *pDC, CXTPControl *pControl, BOOL bScrollLeft) | CXTPRibbonMarkupTheme | virtual
DrawRibbonTab(CDC *pDC, CXTPRibbonTab *pItem) | CXTPRibbonOffice2013Theme | virtual
DrawSystemPopupBarButton(CDC *pDC, CXTPControl *pButton) | CXTPRibbonMarkupTheme | virtual
FillGroupPopupToolBar(CDC *pDC, CXTPRibbonGroup *pGroup, CXTPCommandBar *pCommandBar) | CXTPRibbonMarkupTheme | virtual
FillGroupRect(CDC *pDC, CXTPRibbonTab *pActiveTab, CRect rcGroups) | CXTPRibbonMarkupTheme | virtual
FillMorePopupToolBarEntry(CDC *pDC, CXTPCommandBar *pBar) | CXTPRibbonMarkupTheme | virtual
FillRibbonBar(CDC *pDC, CXTPRibbonBar *pRibbonBar) | CXTPRibbonOffice2013Theme | virtual
FillRibbonTabControl(CDC *pDC, CXTPRibbonBar *pRibbonBar, CRect rcControl) | CXTPRibbonMarkupTheme | virtual
FillSystemPopupBarEntry(CDC *pDC, CXTPPopupBar *pBar) | CXTPRibbonMarkupTheme | virtual
FillTabPopupToolBar(CDC *pDC, CXTPPopupToolBar *pPopupToolBar) | CXTPRibbonPaintManager | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetBackImageName() | CXTPRibbonOffice2013Theme | protectedvirtual
GetControlGroupOptionSize() const | CXTPRibbonMarkupTheme | virtual
GetEditHeight() const | CXTPRibbonPaintManager |
GetFontHeight() const | CXTPRibbonPaintManager |
GetFramePaintManager() const | CXTPRibbonPaintManager |
GetGroupCaptionHeight() const | CXTPRibbonPaintManager |
GetImages() const | CXTPRibbonPaintManager |
GetRibbonCaptionHeight(const CXTPRibbonBar *pRibbonBar) const | CXTPRibbonOffice2013Theme | virtual
GetTabPaintManager() const | CXTPRibbonPaintManager |
LoadImage(LPCTSTR lpszFileName) | CXTPRibbonPaintManager |
LoadParts(BOOL bReload=FALSE) | CXTPRibbonOffice2013Theme | protectedvirtual
CXTPRibbonMarkupTheme::LoadParts(HZIP hZip, CXTPMarkupContext *pMarkupContext=NULL) | CXTPRibbonMarkupTheme |
m_bFlatFrame | CXTPRibbonPaintManager |
m_bHotTrackingGroups | CXTPRibbonPaintManager |
m_clrBackstageSysButtonBack2013Highlighted | CXTPRibbonMarkupTheme | protected
m_clrBackstageSysButtonBack2013Normal | CXTPRibbonMarkupTheme | protected
m_clrFileButtonText | CXTPRibbonPaintManager | protected
m_clrHeader | CXTPRibbonOffice2013Theme | protected
m_clrMinimizedFrameEdgeHighLight | CXTPRibbonPaintManager | protected
m_clrMinimizedFrameEdgeShadow | CXTPRibbonPaintManager | protected
m_clrRecentFileListEdgeHighLight | CXTPRibbonPaintManager |
m_clrRecentFileListEdgeShadow | CXTPRibbonPaintManager |
m_clrRibbonBorder | CXTPRibbonPaintManager | protected
m_clrRibbonFace | CXTPRibbonPaintManager | protected
m_clrRibbonGroupCaptionText | CXTPRibbonPaintManager | protected
m_clrRibbonInactiveFace | CXTPRibbonPaintManager | protected
m_clrRibbonInactiveFaceState | CXTPRibbonOffice2013Theme | protected
m_clrRibbonTabDelimeter | CXTPRibbonOffice2013Theme | protected
m_clrTabBackackstageLeft | CXTPRibbonOffice2013Theme | protected
m_clrTabBackackstageRight | CXTPRibbonOffice2013Theme | protected
m_clrTabBackInactiveState | CXTPRibbonOffice2013Theme | protected
m_fontGroupCaption | CXTPRibbonPaintManager |
m_nGroupCaptionHeight | CXTPRibbonPaintManager |
m_nGroupSpacing | CXTPRibbonPaintManager |
m_nTabsHeight | CXTPRibbonPaintManager |
m_pMarkupContext | CXTPRibbonMarkupTheme | protected
m_pPaintManager | CXTPRibbonPaintManager | protected
m_pTabPaintManager | CXTPRibbonPaintManager | protected
m_rcFileButtonMargin | CXTPRibbonPaintManager | protected
m_strHighlightedPrefix | CXTPRibbonMarkupTheme | protected
m_strNormalPrefix | CXTPRibbonMarkupTheme | protected
RefreshMetrics() | CXTPRibbonOffice2013Theme | virtual
RenderMarkup(CDC *pDC, CRect rc, LPCTSTR lpszText) | CXTPRibbonMarkupTheme |
RenderMarkup(CDC *pDC, CRect rc, XTPRibbonThemePart part) | CXTPRibbonMarkupTheme |
SetBackImage(int nImage) | CXTPRibbonOffice2013Theme | virtual
SetFontHeight(int nFontHeight) | CXTPRibbonPaintManager |
~CXTPRibbonMarkupTheme() | CXTPRibbonMarkupTheme | virtual
~CXTPRibbonOffice2013Theme() | CXTPRibbonOffice2013Theme | virtual
~CXTPRibbonPaintManager() | CXTPRibbonPaintManager | virtual
~CXTPRibbonThemeVisualStudio2015() | CXTPRibbonThemeVisualStudio2015 | virtual


Toolkit Pro: Member List

CXTPCalendarSchedules Member List

This is the complete list of members for CXTPCalendarSchedules, including all inherited members.

_GetNextID() const | CXTPCalendarSchedules | protectedvirtual
_Load(CXTPPropExchange *pPX) | CXTPCalendarSchedules | protectedvirtual
_Save(CXTPPropExchange *pPX) | CXTPCalendarSchedules | protectedvirtual
Add(CXTPCalendarSchedule *pNewElement) | CXTPCalendarPtrCollectionT< CXTPCalendarSchedule > | virtual
Add(CXTPCalendarSchedule *pNewElement, BOOL bWithAddRef) | CXTPCalendarPtrCollectionT< CXTPCalendarSchedule > | virtual
AddNewSchedule(LPCTSTR pcszScheduleName) | CXTPCalendarSchedules | virtual
Append(const CXTPCalendarPtrCollectionT< CXTPCalendarSchedule > *pElementsArray) | CXTPCalendarPtrCollectionT< CXTPCalendarSchedule > | virtual
CXTPCalendarPtrCollectionT() | CXTPCalendarPtrCollectionT< CXTPCalendarSchedule > |
CXTPCalendarSchedules() | CXTPCalendarSchedules |
CXTPCmdTarget() | CXTPCmdTarget |
DoPropExchange(CXTPPropExchange *pPX) | CXTPCalendarSchedules | virtual
Find(const CXTPCalendarSchedule *pElement) const | CXTPCalendarPtrCollectionT< CXTPCalendarSchedule > | virtual
FindIndex(UINT uScheduleID) const | CXTPCalendarSchedules | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAt(int nIndex) const | CXTPCalendarPtrCollectionT< CXTPCalendarSchedule > | virtual
GetAt(int nIndex, BOOL bWithAddRef) const | CXTPCalendarPtrCollectionT< CXTPCalendarSchedule > | virtual
GetCount() const | CXTPCalendarPtrCollectionT< CXTPCalendarSchedule > | virtual
GetScheduleName(UINT uScheduleID) const | CXTPCalendarSchedules | virtual
InsertAt(int nIndex, CXTPCalendarSchedule *pElement) | CXTPCalendarPtrCollectionT< CXTPCalendarSchedule > | virtual
m_arElements | CXTPCalendarPtrCollectionT< CXTPCalendarSchedule > | protected
Remove(CXTPCalendarSchedule *pElement) | CXTPCalendarPtrCollectionT< CXTPCalendarSchedule > | virtual
RemoveAll() | CXTPCalendarPtrCollectionT< CXTPCalendarSchedule > | virtual
RemoveAt(int nIndex) | CXTPCalendarPtrCollectionT< CXTPCalendarSchedule > | virtual
RemoveSchedule(UINT uScheduleID) | CXTPCalendarSchedules | virtual
SetAt(int nIndex, CXTPCalendarSchedule *pElement) | CXTPCalendarPtrCollectionT< CXTPCalendarSchedule > | virtual
SetScheduleName(UINT uScheduleID, LPCTSTR pcszNewName) | CXTPCalendarSchedules | virtual
SetSize(int nNewSize) | CXTPCalendarPtrCollectionT< CXTPCalendarSchedule > | virtual
TObjectPtr typedef | CXTPCalendarPtrCollectionT< CXTPCalendarSchedule > | protected
~CXTPCalendarPtrCollectionT() | CXTPCalendarPtrCollectionT< CXTPCalendarSchedule > | virtual
~CXTPCalendarSchedules() | CXTPCalendarSchedules | virtual


Toolkit Pro: XTPFontManager.h Source File

  • Source
  • Common
XTPFontManager.h
Go to the documentation of this file.
1
23#if !defined(__XTPFONTMANAGER_H__)
24# define __XTPFONTMANAGER_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
39class _XTP_EXT_CLASS CXTPFontManager
40{
45 CXTPFontManager();
47 friend _XTP_EXT_CLASS CXTPFontManager* AFX_CDECL XTPFontManager();
48
49 friend class CXTPSingleton<CXTPFontManager>;
51public:
61 BOOL FontExists(LPCTSTR lpszFaceName);
62
69 void CreateFonts(LOGFONT lf);
70
79 CFont& GetFont();
80
89 CFont& GetFontBold();
90
99 CFont& GetFontItalic();
100
109 CFont& GetFontItalicBold();
110
119 CFont& GetFontVertical();
120
129 CFont& GetFontVerticalBold();
130
131protected:
132 CXTPFont m_xtpFont;
133 CXTPFont m_xtpFontBold;
134 CXTPFont m_xtpFontItalic;
135 CXTPFont m_xtpFontItalicBold;
136 CXTPFont m_xtpFontVertical;
137 CXTPFont m_xtpFontVerticalBold;
139 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CFont, m_font, m_xtpFont, GetFontHandle);
140 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CFont, m_fontBold, m_xtpFontBold, GetBoldFontHandle);
141 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CFont, m_fontItalic, m_xtpFontItalic,
142 GetItalicFontHandle);
143 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CFont, m_fontItalicBold, m_xtpFontItalicBold,
144 GetItalicBoldFontHandle);
145 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CFont, m_fontVertical, m_xtpFontVertical,
146 GetVerticalFontHandle);
147 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CFont, m_fontVerticalBold, m_xtpFontVerticalBold,
148 GetVerticalBoldFontHandle);
149};
150
151AFX_INLINE CFont& CXTPFontManager::GetFont()
152{
153 return m_xtpFont;
154}
155AFX_INLINE CFont& CXTPFontManager::GetFontBold()
156{
157 return m_xtpFontBold;
158}
159AFX_INLINE CFont& CXTPFontManager::GetFontItalic()
160{
161 return m_xtpFontItalic;
162}
163AFX_INLINE CFont& CXTPFontManager::GetFontItalicBold()
164{
165 return m_xtpFontItalicBold;
166}
167AFX_INLINE CFont& CXTPFontManager::GetFontVertical()
168{
169 return m_xtpFontVertical;
170}
171AFX_INLINE CFont& CXTPFontManager::GetFontVerticalBold()
172{
173 return m_xtpFontVerticalBold;
174}
175
187_XTP_EXT_CLASS CXTPFontManager* AFX_CDECL XTPFontManager();
188
189# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
191#endif // !defined(__XTPFONTMANAGER_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPFontManager
_XTP_EXT_CLASS CXTPFontManager *AFX_CDECL XTPFontManager()
Call this function to access CXTPFontManager members.
CXTPFont
Provides a convenient object oriented interface for HFONT GDI object and uses GDI handle caching.
Definition XTPGdiObjects.h:414
CXTPFontManager
Singleton class to manage fonts used by library windows and controls.
Definition XTPFontManager.h:40
CXTPFontManager::GetFontItalic
CFont & GetFontItalic()
Retrieves a reference to the italic library font managed by CXTPFontManager.
Definition XTPFontManager.h:159
CXTPFontManager::m_xtpFontVerticalBold
CXTPFont m_xtpFontVerticalBold
Default vertical bold font.
Definition XTPFontManager.h:137
CXTPFontManager::GetFont
CFont & GetFont()
Retrieves a reference to the standard library font managed by CXTPFontManager.
Definition XTPFontManager.h:151
CXTPFontManager::m_xtpFont
CXTPFont m_xtpFont
Default font.
Definition XTPFontManager.h:132
CXTPFontManager::GetFontVerticalBold
CFont & GetFontVerticalBold()
Retrieves a reference to the vertical bold library font managed by CXTPFontManager.
Definition XTPFontManager.h:171
CXTPFontManager::m_xtpFontItalicBold
CXTPFont m_xtpFontItalicBold
Default italic bold font.
Definition XTPFontManager.h:135
CXTPFontManager::GetFontBold
CFont & GetFontBold()
Retrieves a reference to the bold library font managed by CXTPFontManager.
Definition XTPFontManager.h:155
CXTPFontManager::m_xtpFontVertical
CXTPFont m_xtpFontVertical
Default vertical font.
Definition XTPFontManager.h:136
CXTPFontManager::CreateFonts
void CreateFonts(LOGFONT lf)
Call this member to create system fonts using the specified LOGFONT structure.
CXTPFontManager::m_xtpFontBold
CXTPFont m_xtpFontBold
Default bold font.
Definition XTPFontManager.h:133
CXTPFontManager::m_xtpFontItalic
CXTPFont m_xtpFontItalic
Default italic font.
Definition XTPFontManager.h:134
CXTPFontManager::GetFontItalicBold
CFont & GetFontItalicBold()
Retrieves a reference to the italic standard library font managed by CXTPFontManager.
Definition XTPFontManager.h:163
CXTPFontManager::GetFontVertical
CFont & GetFontVertical()
Retrieves a reference to the vertical library font managed by CXTPFontManager.
Definition XTPFontManager.h:167
CXTPFontManager::FontExists
BOOL FontExists(LPCTSTR lpszFaceName)
Call this member function to determine if the specified font exists.
CXTPSingleton
Implements Singleton design pattern.
Definition XTPSingleton.h:215


Toolkit Pro: XTPCalendarTip.h Source File

  • Source
  • Calendar
XTPCalendarTip.h
Go to the documentation of this file.
1
22#if !defined(__XTPCalendarTip_H__)
23# define __XTPCalendarTip_H__
24
25# if _MSC_VER >= 1000
26# pragma once
27# endif // _MSC_VER >= 1000
28
29# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
30
50class _XTP_EXT_CLASS CXTPCalendarTip : public CWnd
51{
52 // Construction
53public:
77 CXTPCalendarTip();
78
83 virtual ~CXTPCalendarTip();
84
116 virtual BOOL Create(CWnd* pParentWnd);
117
118 // Attributes
119public:
128 CString GetTooltipText() const;
129
141 void SetTooltipText(LPCTSTR str);
142
149 void SetFont(CFont* pFont);
150
164 void SetHoverRect(CRect rc);
165
174 CRect GetHoverRect() const;
175
183 BOOL IsAdvancedMode() const;
184
191 void SetAdvancedMode(BOOL bMode = TRUE);
192
202 void SetTheme(CXTPCalendarTheme* pTheme);
203
204 // Operations
205public:
230 void Activate(BOOL bActive, BOOL bAdvanced = FALSE);
231
246 CSize CalcToolTipRect(BOOL bFull = FALSE);
247
248protected:
249 DECLARE_MESSAGE_MAP()
250
251 //{{AFX_MSG(CXTPCalendarTip)
252 afx_msg LRESULT OnNcHitTest(CPoint point);
253 afx_msg BOOL OnEraseBkgnd(CDC*);
254 afx_msg void OnPaint();
255 //}}AFX_MSG
256
257private:
258 BOOL Create(LPCTSTR lpszClassName, LPCTSTR lpszWindowName, DWORD dwStyle, const RECT& rect,
259 CWnd* pParentWnd, UINT nID, CCreateContext* pContext = NULL);
260
261protected:
262 CRect m_rcHover;
263 CFont* m_pFont;
264 CWnd* m_pParentWnd;
265 CString m_strTooltipText;
266 BOOL m_bAdvancedMode;
267 CXTPCalendarTheme* m_pTheme;
268};
269
270AFX_INLINE BOOL CXTPCalendarTip::Create(LPCTSTR lpszClassName, LPCTSTR lpszWindowName,
271 DWORD dwStyle, const RECT& rect, CWnd* pParentWnd, UINT nID,
272 CCreateContext* pContext)
273{
274 return CWnd::Create(lpszClassName, lpszWindowName, dwStyle, rect, pParentWnd, nID, pContext);
275}
276AFX_INLINE CString CXTPCalendarTip::GetTooltipText() const
277{
278 return m_strTooltipText;
279}
280AFX_INLINE void CXTPCalendarTip::SetTooltipText(LPCTSTR str)
281{
282 m_strTooltipText = str;
283}
284AFX_INLINE void CXTPCalendarTip::SetFont(CFont* pFont)
285{
286 m_pFont = pFont;
287}
288AFX_INLINE void CXTPCalendarTip::SetHoverRect(CRect rc)
289{
290 m_rcHover = rc;
291 MoveWindow(rc);
292}
293AFX_INLINE CRect CXTPCalendarTip::GetHoverRect() const
294{
295 return m_rcHover;
296}
297AFX_INLINE void CXTPCalendarTip::SetAdvancedMode(BOOL bMode)
298{
299 m_bAdvancedMode = bMode;
300}
301AFX_INLINE BOOL CXTPCalendarTip::IsAdvancedMode() const
302{
303 return m_bAdvancedMode;
304}
305
306# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
307#endif // !defined(__XTPCalendarTip_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCalendarTip
The CXTPCalendarTip class emulates the functionality of a "tool tip" control.
Definition XTPCalendarTip.h:51
CXTPCalendarTip::GetTooltipText
CString GetTooltipText() const
This member function is used to obtain the tooltip text string.
Definition XTPCalendarTip.h:276
CXTPCalendarTip::~CXTPCalendarTip
virtual ~CXTPCalendarTip()
Destroys a CXTPCalendarTip object and handles cleanup and deallocation.
CXTPCalendarTip::Activate
void Activate(BOOL bActive, BOOL bAdvanced=FALSE)
Call this function to activate or deactivate a tool tip control.
CXTPCalendarTip::IsAdvancedMode
BOOL IsAdvancedMode() const
This function is used to check whether advanced mode is enabled.
Definition XTPCalendarTip.h:301
CXTPCalendarTip::CXTPCalendarTip
CXTPCalendarTip()
Constructs a CXTPCalendarTip object.
CXTPCalendarTip::SetTheme
void SetTheme(CXTPCalendarTheme *pTheme)
This member function sets (or disables) the new control drawing theme.
CXTPCalendarTip::SetFont
void SetFont(CFont *pFont)
This member function is used to set the tooltip text font.
Definition XTPCalendarTip.h:284
CXTPCalendarTip::SetTooltipText
void SetTooltipText(LPCTSTR str)
This member function is used to set the new tooltip text.
Definition XTPCalendarTip.h:280
CXTPCalendarTip::SetHoverRect
void SetHoverRect(CRect rc)
This member function is used to set the coordinates of the tooltip hover rectangle.
Definition XTPCalendarTip.h:288
CXTPCalendarTip::CalcToolTipRect
CSize CalcToolTipRect(BOOL bFull=FALSE)
This function is used to calculate the tooltip rectangle.
CXTPCalendarTip::GetHoverRect
CRect GetHoverRect() const
This function is used to obtain the coordinates of a tooltip hover rectangle.
Definition XTPCalendarTip.h:293
CXTPCalendarTip::Create
virtual BOOL Create(CWnd *pParentWnd)
This member function is used to create a report tip window.
CXTPCalendarTip::SetAdvancedMode
void SetAdvancedMode(BOOL bMode=TRUE)
This function is used to set the advanced mode flag.
Definition XTPCalendarTip.h:297


Toolkit Pro: XTPComboBoxThemeOfficeXPFlat.h Source File

  • Source
  • Controls
  • Combo
  • Themes
XTPComboBoxThemeOfficeXPFlat.h
Go to the documentation of this file.
1
23#ifndef XTPComboBoxThemeOfficeXP_h__
24# define XTPComboBoxThemeOfficeXP_h__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPComboBoxThemeOfficeXPFlat : public CXTPComboBoxTheme
39{
40public:
46 CXTPComboBoxThemeOfficeXPFlat(XTPControlTheme nTheme);
47
52 virtual ~CXTPComboBoxThemeOfficeXPFlat();
53
61 virtual void DrawBackground(CDC* pDC, CXTPComboBox* pComboBox);
62
71 virtual void DrawButton(CDC* pDC, CXTPComboBox* pComboBox, CRect rcBtn);
72
79 virtual void RefreshMetrics(CXTPComboBox* pComboBox);
80
81 XTPControlTheme m_nTheme;
82};
83
84# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
86#endif // XTPComboBoxThemeOfficeXP_h__
XTPControlTheme
XTPControlTheme
Enumeration used to determine the active theme style.
Definition XTPControlTheme.h:43
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPComboBox
The CXTPComboBox class provides the functionality of a themed Windows combobox.
Definition XTPComboBox.h:42
CXTPComboBoxTheme
CXTPComboBoxTheme is a class used to perform ComboBox Theme drawing tasks.
Definition XTPComboBoxTheme.h:42
CXTPComboBoxThemeOfficeXPFlat
Used as the paint manager for a combobox control to render an Office XP Flat appearance.
Definition XTPComboBoxThemeOfficeXPFlat.h:39
CXTPComboBoxThemeOfficeXPFlat::CXTPComboBoxThemeOfficeXPFlat
CXTPComboBoxThemeOfficeXPFlat(XTPControlTheme nTheme)
Default constructor.
CXTPComboBoxThemeOfficeXPFlat::RefreshMetrics
virtual void RefreshMetrics(CXTPComboBox *pComboBox)
This member function is called by the theme manager to refresh the visual styles used by each compone...
CXTPComboBoxThemeOfficeXPFlat::~CXTPComboBoxThemeOfficeXPFlat
virtual ~CXTPComboBoxThemeOfficeXPFlat()
Destructor handles cleanup and deallocation.
CXTPComboBoxThemeOfficeXPFlat::m_nTheme
XTPControlTheme m_nTheme
Office XP, Flat or Ultra Flat.
Definition XTPComboBoxThemeOfficeXPFlat.h:81
CXTPComboBoxThemeOfficeXPFlat::DrawButton
virtual void DrawButton(CDC *pDC, CXTPComboBox *pComboBox, CRect rcBtn)
Called by the paint manager to draw the button portion of the combobox control.
CXTPComboBoxThemeOfficeXPFlat::DrawBackground
virtual void DrawBackground(CDC *pDC, CXTPComboBox *pComboBox)
Called by the paint manager to draw the background for the combobox control.


Toolkit Pro: Member List

CXTPDatePickerControl Member List

This is the complete list of members for CXTPDatePickerControl, including all inherited members.

_RedrawControl(BOOL bUpdateNow) | CXTPDatePickerControl | protectedvirtual
AddButton(UINT nID) | CXTPDatePickerControl | virtual
AdjustLayout() | CXTPDatePickerControl | virtual
AdjustLayout(CRect rcClient) | CXTPDatePickerControl | protectedvirtual
AllowNoncontinuousSelection(BOOL bAllow=TRUE) | CXTPDatePickerControl |
CalcButtonBandRect() | CXTPDatePickerControl | protectedvirtual
CalcButtonSize() const | CXTPDatePickerControl | protectedvirtual
ClearFocus() | CXTPDatePickerControl | virtual
ClearMonths() | CXTPDatePickerControl | protectedvirtual
Create(DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID, CCreateContext *pContext=NULL) | CXTPDatePickerControl | virtual
CreateMonthArray() | CXTPDatePickerControl | protectedvirtual
CXTPDatePickerControl() | CXTPDatePickerControl |
DatePickerMouseMode enum name | CXTPDatePickerControl |
Deselect(const COleDateTime &dtDay) | CXTPDatePickerControl | virtual
DrawButtons(CDC *pDC) | CXTPDatePickerControl | protectedvirtual
EnableSysYearMonthFormat(BOOL nEnable) | CXTPDatePickerControl |
EnsureVisible(const COleDateTime &dtDate) | CXTPDatePickerControl | virtual
EnsureVisibleFocus() | CXTPDatePickerControl | virtual
EnsureVisibleSelection() | CXTPDatePickerControl | virtual
GetBorderStyle() const | CXTPDatePickerControl |
GetButton(int nIndex) const | CXTPDatePickerControl |
GetButtonCount() const | CXTPDatePickerControl |
GetCallbackDayMetrics() const | CXTPDatePickerControl |
GetCols() const | CXTPDatePickerControl |
GetConnection() const | CXTPDatePickerControl |
GetCurSel(COleDateTime &refDateTime) const | CXTPDatePickerControl | virtual
GetDayMetrics(COleDateTime &dtDay, XTP_DAYITEM_METRICS *pDayMetics) | CXTPDatePickerControl | virtual
GetDayOfWeekName(int nDayOfWeek) const | CXTPDatePickerControl |
GetFirstDayOfWeek() const | CXTPDatePickerControl |
GetFirstWeekOfYearDays() const | CXTPDatePickerControl |
GetHighlightToday() const | CXTPDatePickerControl |
GetMaxSelCount() const | CXTPDatePickerControl |
GetMinReqRect(RECT *pRect) const | CXTPDatePickerControl | virtual
GetMinReqRect(RECT *pRect, int nRows, int nCols) const | CXTPDatePickerControl | virtual
GetMonthDelta() const | CXTPDatePickerControl |
GetMonthName(int nMonth) const | CXTPDatePickerControl |
GetMonthRange(COleDateTime &refMinRange, COleDateTime &refMaxRange, DWORD dwFlags) const | CXTPDatePickerControl | virtual
GetPaintManager() const | CXTPDatePickerControl |
GetPaintTheme() const | CXTPDatePickerControl |
GetRange(COleDateTime *pMinRange, COleDateTime *pMaxRange) const | CXTPDatePickerControl | virtual
GetRows() const | CXTPDatePickerControl |
GetSelectedDays() const | CXTPDatePickerControl |
GetSelRange(COleDateTime &refMinRange, COleDateTime &refMaxRange) const | CXTPDatePickerControl | virtual
GetShowNonMonthDays() const | CXTPDatePickerControl |
GetShowWeekNumbers() const | CXTPDatePickerControl |
GetToday(COleDateTime &refDateTime) const | CXTPDatePickerControl | virtual
GetVisibleRange(COleDateTime &refFirstVisibleDay, COleDateTime &refLastVisibleDay) const | CXTPDatePickerControl | virtual
GoModal(const RECT &rect, CWnd *pParentWnd=NULL) | CXTPDatePickerControl | virtual
HitTest(CPoint ptMouse) const | CXTPDatePickerControl | virtual
HitTest(PMCHITTESTINFO pMCHitTest) const | CXTPDatePickerControl | virtual
InitNames() | CXTPDatePickerControl | protectedvirtual
IsAllowNoncontinuousSelection() const | CXTPDatePickerControl |
IsAutoSize() const | CXTPDatePickerControl |
IsFocused(const COleDateTime &dtDay) const | CXTPDatePickerControl | virtual
IsModal() const | CXTPDatePickerControl |
IsMultiSelectionMode() const | CXTPDatePickerControl |
IsNoneButtonVisible() | CXTPDatePickerControl | virtual
IsSelected(const COleDateTime &dtDay) const | CXTPDatePickerControl | virtual
IsTodayButtonVisible() | CXTPDatePickerControl | virtual
m_arDayOfWeekNames | CXTPDatePickerControl | protected
m_arMonthNames | CXTPDatePickerControl | protected
m_arrButtons | CXTPDatePickerControl | protected
m_arrMonths | CXTPDatePickerControl | protected
m_bAllowNoncontinuousSelection | CXTPDatePickerControl | protected
m_bAutoSize | CXTPDatePickerControl | protected
m_bChanged | CXTPDatePickerControl | protected
m_bDeleteOnFinalRelease | CXTPDatePickerControl |
m_bHighlightToday | CXTPDatePickerControl | protected
m_bIsModal | CXTPDatePickerControl | protected
m_bLimitMonthDaysSelection | CXTPDatePickerControl | protected
m_bmpCache | CXTPDatePickerControl | protected
m_bMultiSelectionMode | CXTPDatePickerControl | protected
m_borderStyle | CXTPDatePickerControl | protected
m_bRestrictMode | CXTPDatePickerControl |
m_bRightToLeft | CXTPDatePickerControl | protected
m_bSelectWeek | CXTPDatePickerControl | protected
m_bShowNonMonthDays | CXTPDatePickerControl | protected
m_bShowWeekNumbers | CXTPDatePickerControl | protected
m_bYearsTriangle | CXTPDatePickerControl |
m_dtFirstClicked | CXTPDatePickerControl | protected
m_dtFirstMonth | CXTPDatePickerControl | protected
m_dtFocused | CXTPDatePickerControl | protected
m_dtFSelBase | CXTPDatePickerControl | protected
m_dtLastClicked | CXTPDatePickerControl | protected
m_dtMaxRange | CXTPDatePickerControl | protected
m_dtMinRange | CXTPDatePickerControl | protected
m_dtToday | CXTPDatePickerControl | protected
m_mouseMode | CXTPDatePickerControl | protected
m_nColumns | CXTPDatePickerControl | protected
m_nDesiredColumns | CXTPDatePickerControl | protected
m_nDesiredRows | CXTPDatePickerControl | protected
m_nFirstDayOfWeek | CXTPDatePickerControl | protected
m_nFirstWeekOfYearDays | CXTPDatePickerControl | protected
m_nLockUpdateCount | CXTPDatePickerControl | protected
m_nMaxSelectionDays | CXTPDatePickerControl | protected
m_nMonthDelta | CXTPDatePickerControl | protected
m_nRows | CXTPDatePickerControl | protected
m_nTimerID | CXTPDatePickerControl | protected
m_pButtonCaptured | CXTPDatePickerControl | protected
m_pCallbackParam | CXTPDatePickerControl | protected
m_pConnection | CXTPDatePickerControl | protected
m_pfnCallback | CXTPDatePickerControl | protected
m_pListControl | CXTPDatePickerControl | protected
m_pPaintManager | CXTPDatePickerControl | protected
m_pSelectedDays | CXTPDatePickerControl | protected
m_rcControl | CXTPDatePickerControl | protected
m_rcGrid | CXTPDatePickerControl | protected
m_strYearMonthFormat | CXTPDatePickerControl |
mouseDeselecting enum value | CXTPDatePickerControl |
mouseNothing enum value | CXTPDatePickerControl |
mouseScrollingLeft enum value | CXTPDatePickerControl |
mouseScrollingRight enum value | CXTPDatePickerControl |
mouseSelecting enum value | CXTPDatePickerControl |
mouseTrackingHeaderList enum value | CXTPDatePickerControl |
OnButtonClick(UINT nID) | CXTPDatePickerControl | protectedvirtual
OnDraw(CDC *pDC) | CXTPDatePickerControl | protectedvirtual
Populate() | CXTPDatePickerControl | protectedvirtual
PreSubclassWindow() | CXTPDatePickerControl | protectedvirtual
ProcessButtons(CPoint point) | CXTPDatePickerControl | protectedvirtual
RedrawControl() | CXTPDatePickerControl | virtual
RegisterWindowClass(HINSTANCE hInstance=NULL) | CXTPDatePickerControl |
ScrollLeft(int nMonthCount=1) | CXTPDatePickerControl | virtual
ScrollRight(int nMonthCount=1) | CXTPDatePickerControl | virtual
Select(const COleDateTime &dtDay) | CXTPDatePickerControl | virtual
SendMessageToParent(int nMessage, NMHDR *pNMHDR=NULL) | CXTPDatePickerControl | virtual
SendNotification(XTP_NOTIFY_CODE EventCode, WPARAM wParam=0, LPARAM lParam=0) | CXTPDatePickerControl | protectedvirtual
SetAutoSize(BOOL bAuto=TRUE) | CXTPDatePickerControl |
SetBorderStyle(XTPDatePickerBorderStyle borderStyle) | CXTPDatePickerControl |
SetButtonRect() | CXTPDatePickerControl | protectedvirtual
SetButtonsVisible(BOOL bShowToday, BOOL bShowNone) | CXTPDatePickerControl | virtual
SetCallbackDayMetrics(PFNITEMMETRICS pFunc, void *pParam=NULL) | CXTPDatePickerControl | virtual
SetCurSel(const COleDateTime &refDateTime) | CXTPDatePickerControl | virtual
SetDayOfWeekName(int nDayOfWeek, LPCTSTR strDayOfWeekName) | CXTPDatePickerControl |
SetDesiredVisibleAndFullRange(COleDateTime FirstVisibleDay, COleDateTime LastVisibleDay, COleDateTime FirstDay, COleDateTime LastDay) | CXTPDatePickerControl | virtual
SetFirstDayOfWeek(int nDay) | CXTPDatePickerControl |
SetFirstWeekOfYearDays(int nDays) | CXTPDatePickerControl |
SetGridDimentions(CRect rcGrid) | CXTPDatePickerControl | protectedvirtual
SetGridSize(int nRows, int nCols, BOOL bRestrictMode=FALSE) | CXTPDatePickerControl | virtual
SetHighlightToday(BOOL bValue) | CXTPDatePickerControl |
SetLayoutRTL(BOOL bRightToLeft) | CXTPDatePickerControl | virtual
SetMaxSelCount(int nMax=XTP_SELECTION_INFINITE) | CXTPDatePickerControl |
SetMonthDelta(int iDelta) | CXTPDatePickerControl |
SetMonthName(int nMonth, LPCTSTR strMonthName) | CXTPDatePickerControl |
SetMultiSelectionMode(BOOL bMultiSelectionMode) | CXTPDatePickerControl |
SetPaintTheme(XTPCalendarTheme ePaintTheme) | CXTPDatePickerControl |
SetRange(const COleDateTime *pMinRange, const COleDateTime *pMaxRange) | CXTPDatePickerControl | virtual
SetSelRange(const COleDateTime &refMinRange, const COleDateTime &refMaxRange) | CXTPDatePickerControl | virtual
SetShowNonMonthDays(BOOL bShow) | CXTPDatePickerControl |
SetShowWeekNumbers(BOOL bValue) | CXTPDatePickerControl | virtual
SetTheme(CXTPDatePickerPaintManager *pPaintManager=NULL) | CXTPDatePickerControl |
SetToday(const COleDateTime &refDateTime) | CXTPDatePickerControl | virtual
ShiftDate(COleDateTime &refDate, int nMonthCount) | CXTPDatePickerControl | protectedstatic
ShowListHeader(CRect rcHeader, COleDateTime dtMonth) | CXTPDatePickerControl | protectedvirtual
SizeMinReq(BOOL bRepaint=TRUE) | CXTPDatePickerControl | virtual
~CXTPDatePickerControl() | CXTPDatePickerControl | virtual


Toolkit Pro: Member List

CXTPResizeDialog Member List

This is the complete list of members for CXTPResizeDialog, including all inherited members.

AdjustResizeRect(CSize &rcWindow) | CXTPResize | protectedvirtual
AutoLoadPlacement(LPCTSTR pszSection) | CXTPResize |
CResizeItemArray typedef | CXTPResize | protected
CXTPResize(CWnd *pWnd, const UINT nFlags=0) | CXTPResize |
CXTPResizeDialog() | CXTPResizeDialog |
CXTPResizeDialog(const UINT nID, CWnd *pParent=0, const UINT nFlags=0) | CXTPResizeDialog |
CXTPResizeDialog(LPCTSTR lpszTemplateName, CWnd *pParent=0, const UINT nFlags=0) | CXTPResizeDialog |
Defer(HDWP &hdwp, CXTPResizeItem *pItem, int dx, int dy) | CXTPResize | protectedvirtual
GetMinMaxInfo(MINMAXINFO *pMMI) | CXTPResize | protected
HasFlag(XTPResize eFlag) | CXTPResize | protected
Init() | CXTPResize | protectedvirtual
LoadPlacement(LPCTSTR pszSection) | CXTPResize |
m_arrItems | CXTPResize | protected
m_nDialogID | CXTPResizeDialog | protected
m_nFlagsXX | CXTPResize | protected
m_pWnd | CXTPResize | protected
m_scSizeIcon | CXTPResize | protected
m_strSection | CXTPResize | protected
m_szInitWindow | CXTPResize | protected
m_szMax | CXTPResize | protected
m_szMin | CXTPResize | protected
m_szWindow | CXTPResize | protected
Offset(CPoint ptOffset) | CXTPResize | protected
RemoveAllControls() | CXTPResize | protected
RemoveResize(UINT nID) | CXTPResize | protected
Reset() | CXTPResize | protected
SavePlacement(LPCTSTR pszSection) | CXTPResize |
SetFlag(XTPResize eFlag) | CXTPResize | protected
SetMaxSize(CSize &sz) | CXTPResize |
SetMinSize(CSize &sz) | CXTPResize |
SetResize(UINT nID, XTP_RESIZE left, XTP_RESIZE top, XTP_RESIZE right, XTP_RESIZE bottom) | CXTPResize |
SetResize(UINT nID, const XTP_RESIZERECT &rrcSizing) | CXTPResize |
SetResize(UINT nID, HWND hWnd, const XTP_RESIZERECT &rrcSizing) | CXTPResize |
SetResize(UINT nID, HWND hWnd, const XTP_RESIZEPOINT &rpTopLeft, const XTP_RESIZEPOINT &rpBottomRight) | CXTPResize |
SetResize(UINT nID, const XTP_RESIZEPOINT &rpTopLeft, const XTP_RESIZEPOINT &rpBottomRight) | CXTPResize |
SetResize(CWnd *pWnd, const CXTPResizeRect &rrcSizing, CRect rcWindow) | CXTPResize | protected
Size() | CXTPResize | protectedvirtual
UpdateControlRect(CWnd *pWnd) | CXTPResize | protected
~CXTPResize() | CXTPResize | virtual


Toolkit Pro: XTPTaskPanelGroupItem.h Source File

  • Source
  • TaskPanel
XTPTaskPanelGroupItem.h
Go to the documentation of this file.
1
23#if !defined(__XTPTASKPANELGROUPITEM_H__)
24# define __XTPTASKPANELGROUPITEM_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPTaskPanelGroupItem : public CXTPTaskPanelItem
39{
41 DECLARE_SERIAL(CXTPTaskPanelGroupItem)
43public:
48 CXTPTaskPanelGroupItem();
49
54 virtual ~CXTPTaskPanelGroupItem();
55
56public:
63 virtual CRect OnReposition(CRect rc);
64
71 virtual void OnDrawItem(CDC* pDC, CRect rc);
72
79 CRect& GetMargins();
80
87 CRect GetItemRect() const;
88
94 void SetItemRect(LPCRECT lpRect);
95
102 CXTPTaskPanelGroup* GetItemGroup() const;
103
109 void SetBold(BOOL bBold = TRUE);
110
117 BOOL IsBold() const;
118
124 void SetControlHandle(HWND hWnd);
125
132 HWND GetControlHandle() const;
133
139 void OnAnimate(int nStep);
140
154 void SetSize(CSize szItem, BOOL bAutoHeight = FALSE);
155
162 COLORREF GetBackColor() const;
163
170 COLORREF GetTextColor() const;
171
177 void SetTextColor(COLORREF clrText);
178
190 CRect GetHitTestRect() const;
191
201 BOOL IsItemSelected() const;
202
213 void SetItemSelected(BOOL bSelected);
214
220 virtual void DoPropExchange(CXTPPropExchange* pPX);
221
227 void SetDragText(LPCTSTR lpszDragText);
228
235 virtual CString GetDragText() const;
236
250 BOOL PrepareDrag(COleDataSource& srcItem, BOOL bCacheTextData = TRUE);
251
260 CSize GetSize() const;
261
272 BOOL IsAutoHeight() const;
273
274protected:
276 // System accessibility Support
277
278 virtual HRESULT GetAccessibleDefaultAction(VARIANT varChild, BSTR* pszDefaultAction);
279 virtual HRESULT AccessibleDoDefaultAction(VARIANT varChild);
280 virtual HRESULT GetAccessibleState(VARIANT varChild, VARIANT* pvarState);
281 virtual HRESULT AccessibleSelect(long flagsSelect, VARIANT varChild);
284private:
285 void GetPreviewBitmap(CWnd* pWnd, CBitmap& bmp);
286
287protected:
288 CRect m_rcMargins;
289 CRect m_rcItem;
291 BOOL m_bBold;
292 BOOL m_bSelected;
294 HWND m_hWnd;
296 CSize m_szItem;
298 CBitmap m_bmpPreview;
303 CSize m_szPreview;
304 CString m_strDragText;
305 BOOL m_bAutoHeight;
306 COLORREF m_clrText;
308# ifdef _XTP_ACTIVEX
311 afx_msg void OleSetMargins(long nLeft, long nTop, long nRight, long nBottom);
312 afx_msg void OleSetControl(LPDISPATCH lpDispatch);
313
314 afx_msg LPDISPATCH OleGetControl()
315 {
316 return NULL;
317 }
318 afx_msg HWND OleGetHandle();
319 afx_msg void OleSetHandle(HWND);
320 afx_msg BSTR OlegGetDragText();
321 afx_msg void OleSetSize(long cx, long cy, BOOL bAutHeight);
322 afx_msg void OleRedrawPanel();
323 afx_msg void OleGetRect(long* nLeft, long* nTop, long* nRight, long* nBottom);
324
325 DECLARE_DISPATCH_MAP()
326 DECLARE_INTERFACE_MAP()
327
328 DECLARE_OLETYPELIB_EX(CXTPTaskPanelGroupItem)
329
330 enum
331 {
332 dispidBold = 10L,
333 dispidSetMargins = 11L,
334 dispidControl = 12L,
335 };
336
338# endif
339
340 friend class CXTPTaskPanelGroup;
341};
342
343AFX_INLINE CRect& CXTPTaskPanelGroupItem::GetMargins()
344{
345 return m_rcMargins;
346}
347AFX_INLINE CRect CXTPTaskPanelGroupItem::GetItemRect() const
348{
349 return m_rcItem;
350}
351AFX_INLINE void CXTPTaskPanelGroupItem::SetItemRect(LPCRECT lpRect)
352{
353 ::CopyRect(&m_rcItem, lpRect);
354}
355AFX_INLINE CSize CXTPTaskPanelGroupItem::GetSize() const
356{
357 return m_szItem;
358}
359AFX_INLINE BOOL CXTPTaskPanelGroupItem::IsAutoHeight() const
360{
361 return m_bAutoHeight;
362}
363AFX_INLINE COLORREF CXTPTaskPanelGroupItem::GetTextColor() const
364{
365 return m_clrText;
366}
367AFX_INLINE void CXTPTaskPanelGroupItem::SetTextColor(COLORREF clr)
368{
369 m_clrText = clr;
370 RedrawPanel();
371}
372
373# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
375#endif // !defined(__XTPTASKPANELGROUPITEM_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72
CXTPTaskPanelGroup
CXTPTaskPanelGroup is used in a Task Panel control to represent a group.
Definition XTPTaskPanelGroup.h:45
CXTPTaskPanelGroupItem
CXTPTaskPanelGroupItem is used in a TaskPanel control to represent a single item of a group.
Definition XTPTaskPanelGroupItem.h:39
CXTPTaskPanelGroupItem::IsBold
BOOL IsBold() const
Determines if bold font is enabled/disabled for the group item.
CXTPTaskPanelGroupItem::DoPropExchange
virtual void DoPropExchange(CXTPPropExchange *pPX)
Reads/writes this object from/to an archive.
CXTPTaskPanelGroupItem::GetTextColor
COLORREF GetTextColor() const
Gets the text color of the group item.
Definition XTPTaskPanelGroupItem.h:363
CXTPTaskPanelGroupItem::CXTPTaskPanelGroupItem
CXTPTaskPanelGroupItem()
Constructs a CXTPTaskPanelGroupItem object.
CXTPTaskPanelGroupItem::~CXTPTaskPanelGroupItem
virtual ~CXTPTaskPanelGroupItem()
Destroys a CXTPTaskPanelGroupItem object, handles cleanup and deallocation.
CXTPTaskPanelGroupItem::m_bmpPreview
CBitmap m_bmpPreview
Internally used.
Definition XTPTaskPanelGroupItem.h:298
CXTPTaskPanelGroupItem::SetSize
void SetSize(CSize szItem, BOOL bAutoHeight=FALSE)
Sets the size of the group item.
CXTPTaskPanelGroupItem::m_rcMargins
CRect m_rcMargins
Item's margins.
Definition XTPTaskPanelGroupItem.h:288
CXTPTaskPanelGroupItem::m_hWnd
HWND m_hWnd
Only used for items of type xtpTaskItemTypeControl; this is the control's child window.
Definition XTPTaskPanelGroupItem.h:294
CXTPTaskPanelGroupItem::m_bBold
BOOL m_bBold
TRUE to use bold font.
Definition XTPTaskPanelGroupItem.h:291
CXTPTaskPanelGroupItem::GetHitTestRect
CRect GetHitTestRect() const
Gets the rectangle of the "tooltip zone".
CXTPTaskPanelGroupItem::m_strDragText
CString m_strDragText
Drag text of the item.
Definition XTPTaskPanelGroupItem.h:304
CXTPTaskPanelGroupItem::m_bSelected
BOOL m_bSelected
TRUE if the item is currently selected.
Definition XTPTaskPanelGroupItem.h:292
CXTPTaskPanelGroupItem::GetItemGroup
CXTPTaskPanelGroup * GetItemGroup() const
Gets the parent group of the item.
CXTPTaskPanelGroupItem::GetSize
CSize GetSize() const
Gets the size of the group item.
Definition XTPTaskPanelGroupItem.h:355
CXTPTaskPanelGroupItem::GetDragText
virtual CString GetDragText() const
Gets the drag text of the group item.
CXTPTaskPanelGroupItem::SetControlHandle
void SetControlHandle(HWND hWnd)
Sets the window handle for the group item.
CXTPTaskPanelGroupItem::GetControlHandle
HWND GetControlHandle() const
Gets the window handle of the group item.
CXTPTaskPanelGroupItem::m_rcItem
CRect m_rcItem
Rectangle of the item.
Definition XTPTaskPanelGroupItem.h:289
CXTPTaskPanelGroupItem::GetBackColor
COLORREF GetBackColor() const
Gets the backcolor of the group item.
CXTPTaskPanelGroupItem::OnReposition
virtual CRect OnReposition(CRect rc)
This method is called when the group item must be repositioned.
CXTPTaskPanelGroupItem::SetItemRect
void SetItemRect(LPCRECT lpRect)
Sets the bounding rectangle for the group item.
Definition XTPTaskPanelGroupItem.h:351
CXTPTaskPanelGroupItem::m_szItem
CSize m_szItem
Size of the item.
Definition XTPTaskPanelGroupItem.h:296
CXTPTaskPanelGroupItem::GetItemRect
CRect GetItemRect() const
Gets the bounding rectangle of the group item.
Definition XTPTaskPanelGroupItem.h:347
CXTPTaskPanelGroupItem::IsItemSelected
BOOL IsItemSelected() const
Gets the selected state of the group item.
CXTPTaskPanelGroupItem::PrepareDrag
BOOL PrepareDrag(COleDataSource &srcItem, BOOL bCacheTextData=TRUE)
Caches the COleDataSource object containing the group item being dragged.
CXTPTaskPanelGroupItem::GetMargins
CRect & GetMargins()
Gets the margins of the group item.
Definition XTPTaskPanelGroupItem.h:343
CXTPTaskPanelGroupItem::SetItemSelected
void SetItemSelected(BOOL bSelected)
Sets the selected state of the group item.
CXTPTaskPanelGroupItem::m_bAutoHeight
BOOL m_bAutoHeight
TRUE if the item stretched inside its group.
Definition XTPTaskPanelGroupItem.h:305
CXTPTaskPanelGroupItem::m_clrText
COLORREF m_clrText
Text color.
Definition XTPTaskPanelGroupItem.h:306
CXTPTaskPanelGroupItem::SetDragText
void SetDragText(LPCTSTR lpszDragText)
Sets the drag text for the group item.
CXTPTaskPanelGroupItem::m_szPreview
CSize m_szPreview
Last preview bitmap size.
Definition XTPTaskPanelGroupItem.h:303
CXTPTaskPanelGroupItem::SetTextColor
void SetTextColor(COLORREF clrText)
Sets the text color for the group item.
Definition XTPTaskPanelGroupItem.h:367
CXTPTaskPanelGroupItem::IsAutoHeight
BOOL IsAutoHeight() const
Determines if auto-height is enabled/disabled for the group item.
Definition XTPTaskPanelGroupItem.h:359
CXTPTaskPanelGroupItem::OnAnimate
void OnAnimate(int nStep)
This method is called when an animation step is executed.
CXTPTaskPanelGroupItem::SetBold
void SetBold(BOOL bBold=TRUE)
Enables/disables bold font for the group item.
CXTPTaskPanelGroupItem::OnDrawItem
virtual void OnDrawItem(CDC *pDC, CRect rc)
This method is called to draw the group item.
CXTPTaskPanelItem
CXTPTaskPanelItem is used in a Task Panel control to represent a single item.
Definition XTPTaskPanelItem.h:49
CXTPTaskPanelItem::RedrawPanel
void RedrawPanel(BOOL bAnimate=FALSE) const
Redraws the parent Task Panel control.


Toolkit Pro: Member List

CXTPMarqueeCtrl Member List

This is the complete list of members for CXTPMarqueeCtrl, including all inherited members.

CXTPMarqueeCtrl() | CXTPMarqueeCtrl |
GetPaintManager() const | CXTPMarqueeCtrl |
IsMarquee() | CXTPMarqueeCtrl |
IsSmooth() | CXTPMarqueeCtrl |
IsVertical() | CXTPMarqueeCtrl |
m_bIsSubclassed | CXTPMarqueeCtrl | protected
m_chAlpha | CXTPMarqueeCtrl | protected
m_cxChunk | CXTPMarqueeCtrl | protected
m_nGap | CXTPMarqueeCtrl | protected
m_nPos | CXTPMarqueeCtrl | protected
m_pPaintManager | CXTPMarqueeCtrl | protected
OnInitControl() | CXTPMarqueeCtrl | protectedvirtual
RefreshMetrics() | CXTPMarqueeCtrl |
SetColors(COLORREF crBack, COLORREF crChunk) | CXTPMarqueeCtrl |
SetMarquee(BOOL bMarqueeMode=TRUE, int nInterval=50, int nGap=2, int cx=12, int *piTrans=NULL) | CXTPMarqueeCtrl |
SetTheme(CXTPMarqueeCtrlPaintManager *pPaintManager=NULL) | CXTPMarqueeCtrl |
SetTheme(XTPControlTheme nTheme) | CXTPMarqueeCtrl |
UseWinThemes() | CXTPMarqueeCtrl | protectedvirtual
~CXTPMarqueeCtrl() | CXTPMarqueeCtrl | virtual


Toolkit Pro: XTPEditThemeOffice2013.h Source File

  • Source
  • Controls
  • Edit
  • Themes
XTPEditThemeOffice2013.h
Go to the documentation of this file.
1
23#if !defined(__XTPEDITTHEMEOFFICE2013_H__)
24# define __XTPEDITTHEMEOFFICE2013_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
37class _XTP_EXT_CLASS CXTPEditThemeOffice2013 : public CXTPEditThemeOfficeXP
38{
39public:
44 CXTPEditThemeOffice2013();
45
50 virtual ~CXTPEditThemeOffice2013();
51
58 virtual void RefreshMetrics(CXTPEdit* pEdit);
59};
60
61# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
63#endif // __XTPEDITTHEMEOFFICE2013_H__
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPEdit
CXTPEdit is a CEdit derived class.
Definition XTPEdit.h:129
CXTPEditThemeOffice2013
CXTPEditThemeOffice2013 is a class used to perform theme drawing tasks.
Definition XTPEditThemeOffice2013.h:38
CXTPEditThemeOffice2013::~CXTPEditThemeOffice2013
virtual ~CXTPEditThemeOffice2013()
Destructor, handles cleanup and deallocation.
CXTPEditThemeOffice2013::CXTPEditThemeOffice2013
CXTPEditThemeOffice2013()
Constructs a CXTPEditThemeOffice2013 object.
CXTPEditThemeOffice2013::RefreshMetrics
virtual void RefreshMetrics(CXTPEdit *pEdit)
This member function is called by the theme manager to refresh the visual styles used by each compone...
CXTPEditThemeOfficeXP
CXTPEditThemeOfficeXP is a class used to perform theme drawing tasks.
Definition XTPEditThemeOfficeXP.h:38


Toolkit Pro: Member List

CXTPCalendarEventColorDlg Member List

This is the complete list of members for CXTPCalendarEventColorDlg, including all inherited members.

CXTPCalendarEventColorDlg(BOOL bCategories, CXTPCalendarControl *pCalendarCtrl, CWnd *pParent=NULL) | CXTPCalendarEventColorDlg |
m_bCategories | CXTPCalendarEventColorDlg | protected
m_pCalendarCtrl | CXTPCalendarEventColorDlg | protected
m_pEvent | CXTPCalendarEventColorDlg | protected
UpdateSelColor(int nIndex=LB_ERR) | CXTPCalendarEventColorDlg | protected


Toolkit Pro: Member List

XTP_DOCKINGPANE_INFO Member List

This is the complete list of members for XTP_DOCKINGPANE_INFO, including all inherited members.

pDockingHolder | XTP_DOCKINGPANE_INFO
pFloatingHolder | XTP_DOCKINGPANE_INFO
pLastHolder | XTP_DOCKINGPANE_INFO
pPane | XTP_DOCKINGPANE_INFO


Toolkit Pro: Member List

CXTPColorPopup Member List

This is the complete list of members for CXTPColorPopup, including all inherited members.

AddListener(HWND hwndListener) | CXTPColorPopup |
AddRecentColor(COLORREF clrRecent) | CXTPColorSelectorCtrl | static
CalcSize() | CXTPColorSelectorCtrl | protectedvirtual
CColorCellList typedef | CXTPColorSelectorCtrl | protected
CListenerArray typedef | CXTPColorSelectorCtrl | protected
Create(CRect &rect, CWnd *pParentWnd, DWORD dwPopup, COLORREF clrColor, COLORREF clrDefault=CLR_DEFAULT) | CXTPColorPopup | virtual
CXTPColorSelectorCtrl::Create(CRect rect, CWnd *pParentWnd, DWORD dwPopup, COLORREF clrColor, COLORREF clrDefault=CLR_DEFAULT) | CXTPColorSelectorCtrl |
CXTPColorPopup(BOOL bAutoDelete=FALSE, LPARAM callerParam=0) | CXTPColorPopup |
CXTPColorSelectorCtrl() | CXTPColorSelectorCtrl |
DisplayShadow(BOOL bDisplayShadow=TRUE) | CXTPColorPopup |
DrawColorSelector(CDC *pDC) | CXTPColorSelectorCtrl | protected
EndSelection(int nCurSel) | CXTPColorPopup | protectedvirtual
GetBorderRect() const | CXTPColorSelectorCtrl |
GetButtonSize() const | CXTPColorSelectorCtrl |
GetCellFromIndex(int iIndex) | CXTPColorSelectorCtrl |
GetColorCellList() | CXTPColorSelectorCtrl |
GetCurColor() const | CXTPColorSelectorCtrl |
GetCurSel(COLOR_CELL *pColorCell) | CXTPColorSelectorCtrl |
GetCurSel() const | CXTPColorSelectorCtrl |
GetCustomTitle() | CXTPColorSelectorCtrl |
GetDefColor() const | CXTPColorSelectorCtrl |
GetExtendedColors() | CXTPColorSelectorCtrl |
GetExtendedCount() const | CXTPColorSelectorCtrl |
GetNumCols() const | CXTPColorSelectorCtrl |
GetPopupStyle() const | CXTPColorSelectorCtrl |
GetPressed() const | CXTPColorSelectorCtrl |
GetRecentColors() | CXTPColorSelectorCtrl | static
GetStandardColors() | CXTPColorSelectorCtrl |
GetStandardTitle() | CXTPColorSelectorCtrl |
GetTheme() | CXTPColorSelectorCtrl |
GetThemeColors() | CXTPColorSelectorCtrl |
GetThemeTip(LPCTSTR lpszColor, LPCTSTR lpszDesc, int nShade) | CXTPColorSelectorCtrl |
GetThemeTitle() | CXTPColorSelectorCtrl |
GetToolTipCtrl() | CXTPColorSelectorCtrl |
HasCaptions() const | CXTPColorSelectorCtrl |
IsColorDlgVisible() | CXTPColorSelectorCtrl |
IsColorStatic(CDC *pDC) const | CXTPColorSelectorCtrl |
LookUpColor(const COLORREF crFind) | CXTPColorSelectorCtrl | protected
m_arCells | CXTPColorSelectorCtrl | protected
m_arRecentColors | CXTPColorSelectorCtrl | static
m_arStandardColors | CXTPColorSelectorCtrl | protected
m_arThemeColors | CXTPColorSelectorCtrl | protected
m_bAutoDelete | CXTPColorPopup | protected
m_bCaptions | CXTPColorSelectorCtrl | protected
m_bDisplayShadow | CXTPColorPopup | protected
m_callerParam | CXTPColorPopup | protected
m_clrColor | CXTPColorSelectorCtrl | protected
m_clrDefault | CXTPColorSelectorCtrl | protected
m_dwPopup | CXTPColorSelectorCtrl | protected
m_listeners | CXTPColorSelectorCtrl | protected
m_nCols | CXTPColorSelectorCtrl | protected
m_nCurSel | CXTPColorSelectorCtrl | protected
m_nExtendedColors | CXTPColorSelectorCtrl | protected
m_nPressed | CXTPColorSelectorCtrl | protected
m_pColorDlg | CXTPColorSelectorCtrl | protected
m_pExtendedColors | CXTPColorSelectorCtrl | protected
m_point | CXTPColorSelectorCtrl | protected
m_pParentWnd | CXTPColorSelectorCtrl | protected
m_pShadowManager | CXTPColorPopup | protected
m_pTheme | CXTPColorSelectorCtrl | protected
m_rcBorders | CXTPColorSelectorCtrl | protected
m_rcExclude | CXTPColorPopup | protected
m_rcWnd | CXTPColorSelectorCtrl | protected
m_strTitleCustom | CXTPColorSelectorCtrl | protected
m_strTitleRecent | CXTPColorSelectorCtrl | static
m_strTitleStandard | CXTPColorSelectorCtrl | protected
m_strTitleTheme | CXTPColorSelectorCtrl | protected
m_tooltip | CXTPColorSelectorCtrl | protected
ModifyPopupStyle(DWORD dwRemove, DWORD dwAdd) | CXTPColorSelectorCtrl |
OnEndSelection(int nCurSel, LPARAM callerParam) | CXTPColorSelectorCtrl | protectedvirtual
RefreshMetrics() | CXTPColorSelectorCtrl | protectedvirtual
RemoveListener(HWND hwndListener) | CXTPColorSelectorCtrl |
ResetRecentColors() | CXTPColorSelectorCtrl | static
SelectColor(COLORREF clr) | CXTPColorSelectorCtrl |
SelectColorCell(COLOR_CELL *pColorCell) | CXTPColorSelectorCtrl | virtual
SetBorders(int l=0, int t=0, int r=0, int b=0) | CXTPColorSelectorCtrl |
SetColors(XTP_PICK_BUTTON *pColors, int nCount, int nCols=8, LPCTSTR lpszTitle=NULL) | CXTPColorSelectorCtrl |
SetColors(CXTPPickBtnArray &arColors, const XTP_PICK_BUTTON *pColors, const int nCount) | CXTPColorSelectorCtrl | protected
SetCurSel(int nIndex) | CXTPColorSelectorCtrl |
SetRecentColors(const CUIntArray &arRecentColors, LPCTSTR lpszTitle=NULL) | CXTPColorSelectorCtrl | static
SetStandardColors(XTP_PICK_BUTTON *pColors=NULL, int nCount=10, int nCols=10, LPCTSTR lpszTitle=NULL) | CXTPColorSelectorCtrl |
SetStandardColors(CXTPPickBtnArray &arColors, int nCols=10, LPCTSTR lpszTitle=NULL) | CXTPColorSelectorCtrl |
SetTheme(XTPControlTheme eTheme) | CXTPColorSelectorCtrl |
SetTheme(CXTPColorSelectorCtrlTheme *pTheme) | CXTPColorSelectorCtrl |
SetThemeColors(XTP_PICK_BUTTON *pColors=NULL, int nCount=10, LPCTSTR lpszTitle=NULL, UINT *pStringIDs=NULL, int ppShadeMatrix[6][10]=NULL) | CXTPColorSelectorCtrl |
SetThemeColors(XTP_PICK_BUTTON *pColors, int nCount, LPCTSTR lpszTitle, LPCTSTR *ppszStrings, int ppShadeMatrix[6][10]) | CXTPColorSelectorCtrl |
SetThemeColors(CXTPPickBtnArray &arColors, int nCols=10, LPCTSTR lpszTitle=NULL) | CXTPColorSelectorCtrl |
ShowCaptions(BOOL bShow) | CXTPColorSelectorCtrl |
~CXTPColorPopup() | CXTPColorPopup | virtual
~CXTPColorSelectorCtrl() | CXTPColorSelectorCtrl | virtual


Toolkit Pro: Member List

CXTPChartPyramidSeriesView Member List

This is the complete list of members for CXTPChartPyramidSeriesView, including all inherited members.

AddChildView(CXTPChartElementView *pChildView) | CXTPChartElementView |
CalculateLabelLayout(CXTPChartDeviceContext *pDC) | CXTPChartPyramidSeriesViewBase |
CalculatePointLayout(CXTPChartDeviceContext *pDC, CRect rcBounds) | CXTPChartPyramidSeriesView | virtual
CreateDeviceCommand(CXTPChartDeviceContext *pDC) | CXTPChartPyramidSeriesView | protectedvirtual
CreateDiagramDomain(CXTPChartDeviceContext *pDC, CRect rcBounds) | CXTPChartPyramidSeriesViewBase | virtual
CreateLegendDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcBounds) | CXTPChartPyramidSeriesView | protectedvirtual
CreateLegendDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcBounds, CXTPChartColor color1, CXTPChartColor color2, CXTPChartColor clrBorder) | CXTPChartPyramidSeriesView | virtual
CreateSeriesPointView(CXTPChartDeviceContext *pDC, CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView) | CXTPChartPyramidSeriesView | protectedvirtual
CXTPChartElementView(CXTPChartElementView *pParentView) | CXTPChartElementView |
CXTPChartElementView(CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartElementView |
CXTPChartElementView(CXTPChartContainer *pContainer) | CXTPChartElementView |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartPyramidSeriesView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView) | CXTPChartPyramidSeriesView |
CXTPChartPyramidSeriesViewBase(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView) | CXTPChartPyramidSeriesViewBase |
GetAt(int nIndex) const | CXTPChartElementView |
GetBounds() const | CXTPChartElementView |
GetBounds(BOOL bIncludingChildren) const | CXTPChartElementView |
GetChildren() | CXTPChartElementView |
GetCount() const | CXTPChartElementView |
GetDomain() const | CXTPChartPyramidSeriesViewBase |
GetInnerBounds() const | CXTPChartPyramidSeriesView | protectedvirtual
GetMaxLabelWidth() const | CXTPChartPyramidSeriesViewBase |
GetParentView() const | CXTPChartElementView |
Is3D() const | CXTPChartObject |
m_arrChildren | CXTPChartElementView | protected
m_pContainer | CXTPChartElementView | protected
m_pDomain | CXTPChartPyramidSeriesViewBase | protected
m_pParentView | CXTPChartElementView | protected
m_rcBounds | CXTPChartElementView | protected
~CXTPChartElementView() | CXTPChartElementView | protectedvirtual
~CXTPChartLegendItemView() | CXTPChartLegendItemView | inlinevirtual
~CXTPChartPyramidSeriesViewBase() | CXTPChartPyramidSeriesViewBase | virtual


Toolkit Pro: XTPProgressThemeNativeWindows10.h Source File

  • Source
  • CommandBars
  • Progress
XTPProgressThemeNativeWindows10.h
Go to the documentation of this file.
1
23#if !defined(__XTPPROGRESSTHEMENATIVEWINDOWS10_H__)
24# define __XTPPROGRESSTHEMENATIVEWINDOWS10_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPProgressBase;
34class CXTPPaintManager;
35
40class _XTP_EXT_CLASS CXTPProgressThemeNativeWindows10 : public CXTPProgressThemeOffice2013
41{
42public:
48 CXTPProgressThemeNativeWindows10(CXTPPaintManager* pPaintManager);
49
55 virtual ~CXTPProgressThemeNativeWindows10();
56};
57
59# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
60#endif // !defined(__XTPPROGRESSTHEMENATIVEWINDOWS10_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPPaintManager
Paint manager of the command bars.
Definition XTPPaintManager.h:199
CXTPProgressBase
CXTPControlProgressBase is base class for all progress objects.
Definition XTPProgressBase.h:40
CXTPProgressThemeNativeWindows10
CXTPProgressThemeNativeWindows10 object.
Definition XTPProgressThemeNativeWindows10.h:41
CXTPProgressThemeNativeWindows10::~CXTPProgressThemeNativeWindows10
virtual ~CXTPProgressThemeNativeWindows10()
Destroys a CXTPProgressThemeNativeWindows10 object, handles cleanup and deallocation.
CXTPProgressThemeNativeWindows10::CXTPProgressThemeNativeWindows10
CXTPProgressThemeNativeWindows10(CXTPPaintManager *pPaintManager)
Constructs a CXTPProgressThemeNativeWindows10 object.
CXTPProgressThemeOffice2013
CXTPProgressThemeOffice2013 object.
Definition XTPProgressThemeOffice2013.h:41


Toolkit Pro: Member List

CXTPControlPopup Member List

This is the complete list of members for CXTPControlPopup, including all inherited members.

AdjustExcludeRect(CRect &rc, BOOL bVertical) | CXTPControlPopup | virtual
AssignDocTemplate(UINT nIDResource) | CXTPControl |
ClickToolBarButton(CRect rcActiveRect=CRect(0, 0, 0, 0)) | CXTPControl | protected
Compare(CXTPControl *pOther) | CXTPControlPopup | protectedvirtual
ContainsPopup(CXTPControlPopup *pControlPopup) | CXTPControlPopup | protected
Copy(CXTPControl *pControl, BOOL bRecursive=FALSE) | CXTPControlPopup | virtual
CreateControlPopup(XTPControlType controlType) | CXTPControlPopup | static
CustomizeStartDrag(CPoint point) | CXTPControl | protectedvirtual
CustomizeStartResize(CPoint point) | CXTPControl | protectedvirtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPControl() | CXTPControl | protected
CXTPControlButton() | CXTPControlButton |
CXTPControlPopup() | CXTPControlPopup |
DelayLayoutParent() | CXTPControl |
DelayRedrawParent() | CXTPControl |
DoCustomDragOver(CXTPCommandBar *pCommandBar, CPoint point, DROPEFFECT &dropEffect) | CXTPControlPopup | protectedvirtual
DoPropExchange(CXTPPropExchange *pPX) | CXTPControlPopup | virtual
Draw(CDC *pDC) | CXTPControl | virtual
ExcludeDocTemplate(UINT nIDResource) | CXTPControl |
ExpandCommandBar() | CXTPControlPopup | protected
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
FromUI(CCmdUI *pCmdUI) | CXTPControl | static
GenerateCommandBarList(DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam) | CXTPControl | protectedvirtual
GetAction() const | CXTPControl |
GetBeginGroup() const | CXTPControl |
GetButtonSize() const | CXTPControl | virtual
GetCaption() const | CXTPControlPopup | virtual
GetCategory() const | CXTPControl |
GetChecked() const | CXTPControl |
GetCloseSubMenuOnClick() const | CXTPControl |
GetCommandBar() const | CXTPControlPopup | virtual
GetControls() const | CXTPControl |
GetCustomizeMinHeight() const | CXTPControl | protectedvirtual
GetCustomizeMinWidth() const | CXTPControl | protectedvirtual
GetCustomShortcutText() const | CXTPControl |
GetDescription() const | CXTPControl | virtual
GetEnabled() const | CXTPControl |
GetExecuteOnPressInterval() const | CXTPControl |
GetExpanded() const | CXTPControl |
GetFlags() const | CXTPControl |
GetHeight() const | CXTPControl |
GetHelpId() const | CXTPControl |
GetHideFlags() const | CXTPControl |
GetIconId() const | CXTPControl |
GetIconSize() const | CXTPControl | virtual
GetID() const | CXTPControl |
GetImage(int nWidth=16) const | CXTPControl | virtual
GetImageManager() const | CXTPControl |
GetIndex() const | CXTPControl |
GetKeyboardTip() const | CXTPControl |
GetPaintManager() const | CXTPControl |
GetParameter() const | CXTPControl |
GetParent() const | CXTPControl |
GetPopuped() const | CXTPControlPopup | virtual
GetPressed() const | CXTPControl | virtual
GetRect() const | CXTPControl |
GetRibbonGroup() const | CXTPControl |
GetRowRect() const | CXTPControl |
GetSelected() const | CXTPControl | virtual
GetShortcutText() const | CXTPControl |
GetSize(CDC *pDC) | CXTPControl | virtual
GetStyle() const | CXTPControl |
GetStyleEx() const | CXTPControlButton |
GetTag() const | CXTPControl |
GetTooltip() const | CXTPControl | virtual
GetType() const | CXTPControl |
GetWidth() const | CXTPControl |
GetWrap() const | CXTPControl |
HasDwmCompositedRect() const | CXTPControl |
IsCaptionVisible() const | CXTPControl | virtual
IsCursorOver() const | CXTPControl |
IsCustomizeMode() const | CXTPControl | protected
IsCustomizeMovable() const | CXTPControl | virtual
IsCustomizeResizeAllow() const | CXTPControl | protectedvirtual
IsFocusable() const | CXTPControl | protectedvirtual
IsFocused() const | CXTPControl | virtual
IsItemDefault() const | CXTPControl |
IsLayoutChanged() | CXTPControl | protected
IsLayoutRTL() const | CXTPControl | protected
IsOnQuickAccess() const | CXTPControl |
IsTemporary() const | CXTPControl |
IsTransparent() const | CXTPControl | inlinevirtual
IsVisible(DWORD dwSkipFlags=0) const | CXTPControl | virtual
m_bBeginGroup | CXTPControl | protected
m_bChecked | CXTPControl | protected
m_bCloseSubMenuOnClick | CXTPControl | protected
m_bDefaultItem | CXTPControl | protected
m_bEnabled | CXTPControl | protected
m_bExpanded | CXTPControl | protected
m_bLayoutRTL | CXTPControl | protected
m_bOnQuickAccess | CXTPControl | protected
m_bPopup | CXTPControlPopup | protected
m_bPressed | CXTPControl | protected
m_bSelected | CXTPControl | protected
m_bShowShadow | CXTPControlPopup | protected
m_bTemporary | CXTPControl | protected
m_buttonCustomStyle | CXTPControl | protected
m_buttonRibbonStyle | CXTPControl | protected
m_buttonStyle | CXTPControl | protected
m_buttonStyleEx | CXTPControlButton | protected
m_bWrap | CXTPControl | protected
m_controlType | CXTPControl | protected
m_dwCommandBarID | CXTPControlPopup | protected
m_dwFlags | CXTPControl | protected
m_dwHideFlags | CXTPControl | protected
m_mapDocTemplatesAssigned | CXTPControl | protected
m_mapDocTemplatesExcluded | CXTPControl | protected
m_nCustomIconId | CXTPControl | protected
m_nExecuteOnPressInterval | CXTPControl | protected
m_nHeight | CXTPControl | protected
m_nHelpId | CXTPControl | protected
m_nIconId | CXTPControl | protected
m_nId | CXTPControl | protected
m_nIndex | CXTPControl | protected
m_nTag | CXTPControl | protected
m_nWidth | CXTPControl | protected
m_pAction | CXTPControl | protected
m_pCommandBar | CXTPControlPopup | protected
m_pControls | CXTPControl | protected
m_pParent | CXTPControl | protected
m_pRibbonGroup | CXTPControl | protected
m_rcControl | CXTPControl | protected
m_rcRow | CXTPControl | protected
m_strCaption | CXTPControl | protected
m_strCategory | CXTPControl | protected
m_strCustomCaption | CXTPControl | protected
m_strDescriptionText | CXTPControl | protected
m_strKeyboardTip | CXTPControl | protected
m_strParameter | CXTPControl | protected
m_strShortcutText | CXTPControl | protected
m_strShortcutTextAuto | CXTPControl | protected
m_strTooltipText | CXTPControl | protected
m_szIcon | CXTPControl | protected
NotifySite(UINT code) | CXTPControl |
NotifySite(UINT code, NMXTPCONTROL *pNM) | CXTPControl |
NotifySite(CWnd *pSite, UINT code, NMXTPCONTROL *pNM) | CXTPControl |
OnActionChanged(int nProperty) | CXTPControl | protectedvirtual
OnActionChanging(int nProperty) | CXTPControl | protectedvirtual
OnCalcDynamicSize(DWORD dwMode) | CXTPControl | virtual
OnCaptionChanged() | CXTPControl | protectedvirtual
OnClick(BOOL bKeyboard=FALSE, CPoint pt=CPoint(0, 0)) | CXTPControlPopup | protectedvirtual
OnCustomizeDragOver(CXTPControl *pDataObject, CPoint point, DROPEFFECT &dropEffect) | CXTPControlPopup | protectedvirtual
OnCustomizeMouseMove(CPoint point) | CXTPControl | protected
OnEnabledChanged() | CXTPControl | virtual
OnExecute() | CXTPControl | virtual
OnHookKeyDown(UINT nChar, LPARAM lParam) | CXTPControl | protectedvirtual
OnHookMouseWheel(UINT nFlags, short zDelta, CPoint point) | CXTPControl | protectedvirtual
OnIdleUpdate() | CXTPControl | protectedvirtual
OnLButtonDblClk(CPoint point) | CXTPControlPopup | protectedvirtual
OnLButtonDown(CPoint point) | CXTPControl | protectedvirtual
OnLButtonUp(CPoint point) | CXTPControlPopup | protectedvirtual
OnMouseHover() | CXTPControlPopup | protectedvirtual
OnMouseMove(CPoint point) | CXTPControlPopup | protectedvirtual
OnRButtonDown(CPoint point) | CXTPControl | protectedvirtual
OnRButtonUp(CPoint point) | CXTPControl | protectedvirtual
OnRemoved() | CXTPControl | protectedvirtual
OnSetPopup(BOOL bPopup) | CXTPControlPopup | protectedvirtual
OnSetSelected(int bSelected) | CXTPControlPopup | protectedvirtual
OnThemeChanged() | CXTPControl | virtual
OnToolHitTest(CPoint point, TOOLINFO *pTI) const | CXTPControl | protectedvirtual
OnUnderlineActivate() | CXTPControlPopup | virtual
RedrawParent(BOOL bAnimate=TRUE) | CXTPControl |
Reset() | CXTPControl |
RestoreCommandBarList(CXTPCommandBarList *pCommandBarList) | CXTPControlPopup | protectedvirtual
ScreenToClient(CPoint *point) | CXTPControl | protected
SetAction(CXTPControlAction *pAction) | CXTPControl | virtual
SetBeginGroup(BOOL bBeginGroup) | CXTPControl | virtual
SetCaption(LPCTSTR lpszCaption) | CXTPControl |
SetCaption(UINT nIDCaption) | CXTPControl |
SetCategory(LPCTSTR lpszCategory) | CXTPControl |
SetChecked(BOOL bChecked) | CXTPControl | virtual
SetCloseSubMenuOnClick(BOOL bCloseOnClick) | CXTPControl |
SetCommandBar(CMenu *pMenu) | CXTPControlPopup |
SetCommandBar(CXTPCommandBar *pBar) | CXTPControlPopup |
SetCustomIcon(HICON hIcon) | CXTPControl |
SetCustomShortcutText(LPCTSTR lpszCustomShortcutText) | CXTPControl |
SetDescription(LPCTSTR lpszDescription) | CXTPControl |
SetEnabled(BOOL bEnabled) | CXTPControl | virtual
SetExecuteOnPressInterval(int nExecuteOnPressInterval) | CXTPControl |
SetExpanded(BOOL bExpanded) | CXTPControl | protected
SetFlags(DWORD dwFlags) | CXTPControl |
SetFocused(BOOL bFocused) | CXTPControl | virtual
SetHeight(int nHeight) | CXTPControl | virtual
SetHelpId(int nId) | CXTPControl |
SetHideFlag(XTPControlHideFlags dwFlag, BOOL bSet) | CXTPControl |
SetHideFlags(DWORD dwFlags) | CXTPControl | virtual
SetHideWrap(BOOL bHide) | CXTPControl |
SetIconId(int nId) | CXTPControl |
SetIconSize(CSize szIcon) | CXTPControl |
SetID(int nId) | CXTPControl |
SetIndex(int nIndex) | CXTPControl | inlineprotected
SetItemDefault(BOOL bDefault) | CXTPControl |
SetKeyboardTip(LPCTSTR lpszKeyboardTip) | CXTPControl |
SetOnQuickAccess(BOOL bOnQuicAccess=FALSE) | CXTPControl |
SetParameter(LPCTSTR lpszParameter) | CXTPControl |
SetParent(CXTPCommandBar *pParent) | CXTPControl | inlineprotectedvirtual
SetPressed(BOOL bPressed) | CXTPControl |
SetPrompt(LPCTSTR lpszPrompt) | CXTPControl |
SetRect(CRect rcControl) | CXTPControl | virtual
SetRowRect(CRect rcRow) | CXTPControl |
SetShortcutText(LPCTSTR lpszShortcutText) | CXTPControl |
SetStyle(XTPButtonStyle buttonStyle) | CXTPControl |
SetStyleEx(XTPButtonStyle buttonStyle) | CXTPControlButton |
SetTag(DWORD_PTR dwTag) | CXTPControl |
SetTooltip(LPCTSTR lpszTooltip) | CXTPControl |
SetVisible(BOOL bVisible) | CXTPControl |
SetWidth(int nWidth) | CXTPControl | virtual
SetWrap(BOOL bWrap) | CXTPControl |
UpdateShadow() | CXTPControlPopup | protectedvirtual
~CXTPControl() | CXTPControl | protectedvirtual
~CXTPControlButton() | CXTPControlButton | virtual
~CXTPControlPopup() | CXTPControlPopup | virtual


Toolkit Pro: Member List

CXTPResizeRect Member List

This is the complete list of members for CXTPResizeRect, including all inherited members.

bottom | XTP_RESIZERECT
CXTPResizeRect() | CXTPResizeRect
CXTPResizeRect(const RECT &rc) | CXTPResizeRect
CXTPResizeRect(const XTP_RESIZERECT &rrc) | CXTPResizeRect
CXTPResizeRect(XTP_RESIZE l, XTP_RESIZE t, XTP_RESIZE r, XTP_RESIZE b) | CXTPResizeRect
Height() | CXTPResizeRect
IsNormalized() | CXTPResizeRect
left | XTP_RESIZERECT
operator CRect() | CXTPResizeRect
operator!=(const XTP_RESIZERECT &rrc) | CXTPResizeRect
operator&(const XTP_RESIZERECT &rrc) | CXTPResizeRect
operator+(const XTP_RESIZERECT &rrc) | CXTPResizeRect
operator+=(const XTP_RESIZERECT &rrc) | CXTPResizeRect
operator=(const RECT &rc) | CXTPResizeRect
operator=(const XTP_RESIZERECT &rrc) | CXTPResizeRect
operator==(const XTP_RESIZERECT &rrc) | CXTPResizeRect
right | XTP_RESIZERECT
top | XTP_RESIZERECT
Width() | CXTPResizeRect


Toolkit Pro: Member List

CXTPSkinObjectProgress Member List

This is the complete list of members for CXTPSkinObjectProgress, including all inherited members.

CXTPSkinObject() | CXTPSkinObject | protected
CXTPSkinObjectFrame() | CXTPSkinObjectFrame |
CXTPSkinObjectProgress() | CXTPSkinObjectProgress |
GetAccessCriticalSection() const | CXTPSynchronized | inline
GetBorders() const | CXTPSkinObjectFrame |
GetCaptionButtons() | CXTPSkinObjectFrame |
GetClassName() const | CXTPSkinObject |
GetClientBrush(CDC *pDC) | CXTPSkinObjectFrame | virtual
GetColor(int nIndex) const | CXTPSkinObject |
GetMetrics() const | CXTPSkinObject |
GetSkinClass() const | CXTPSkinObject |
GetSkinManager() const | CXTPSkinObject |
IsActive() const | CXTPSkinObjectFrame |
m_arrButtons | CXTPSkinObjectFrame | protected
m_bActive | CXTPSkinObjectFrame | protected
m_bActiveX | CXTPSkinObject | protected
m_bLockFrameDraw | CXTPSkinObjectFrame |
m_bMDIClient | CXTPSkinObjectFrame | protected
m_bRegionChanged | CXTPSkinObjectFrame | protected
m_bWindowsForms | CXTPSkinObject | protected
m_dwDialogTexture | CXTPSkinObjectFrame |
m_dwExStyle | CXTPSkinObjectFrame | protected
m_dwStyle | CXTPSkinObjectFrame | protected
m_pButtonHot | CXTPSkinObjectFrame | protected
m_pButtonPressed | CXTPSkinObjectFrame | protected
m_pManager | CXTPSkinObject | protected
m_pOldWndProc | CXTPSkinObject | protected
m_pSBTrack | CXTPSkinObjectFrame | protected
m_rcBorders | CXTPSkinObjectFrame | protected
m_spi | CXTPSkinObjectFrame | protected
m_strClassName | CXTPSkinObject | protected
m_szFrameRegion | CXTPSkinObjectFrame | protected
OnHookAttached(LPCREATESTRUCT lpcs, BOOL bAuto) | CXTPSkinObjectFrame | protectedvirtual
OnHookDetached(BOOL bAuto) | CXTPSkinObjectFrame | protectedvirtual
OnSkinChanged(BOOL bPrevState, BOOL bNewState) | CXTPSkinObjectFrame | protectedvirtual
RedrawScrollBar(int nBar) | CXTPSkinObjectFrame |
RefreshMetrics() | CXTPSkinObjectFrame | protectedvirtual
~CXTPSkinObject() | CXTPSkinObject | protected
~CXTPSkinObjectFrame() | CXTPSkinObjectFrame | virtual
~CXTPSkinObjectProgress() | CXTPSkinObjectProgress | virtual


Toolkit Pro: Member List

  • CXTPTabManager
  • ROW_ITEMS
CXTPTabManager::ROW_ITEMS Member List

This is the complete list of members for CXTPTabManager::ROW_ITEMS, including all inherited members.

nFirstItem | CXTPTabManager::ROW_ITEMS
nLastItem | CXTPTabManager::ROW_ITEMS


Toolkit Pro: Member List

XTP_NC_DATEPICKER_BUTTON Member List

This is the complete list of members for XTP_NC_DATEPICKER_BUTTON, including all inherited members.

hdr | XTP_NC_DATEPICKER_BUTTON
nID | XTP_NC_DATEPICKER_BUTTON


Toolkit Pro: XTPMsgPreview.h Source File

  • Source
  • Controls
  • Preview
  • Providers
  • MSG
XTPMsgPreview.h
Go to the documentation of this file.
1
24#if !defined(__XTPMSGPREVIEW_H__)
25# define __XTPMSGPREVIEW_H__
26
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPMsgPreviewDialog;
34class CXTPMsgPreviewProvider;
35
36class _XTP_EXT_CLASS CXTPMsgPreview : public IXTPPreview
37{
38public:
39 CXTPMsgPreview();
40 ~CXTPMsgPreview();
41
42private:
43 virtual BOOL IsReady() const;
44 virtual BOOL IsAvailable() const;
45 virtual BOOL HasOwnNavigator() const;
46 virtual UINT GetNumberOfPages() const;
47 virtual SIZE GetPreferredPageSize() const;
48 virtual void GoToPage(UINT page);
49 virtual void Draw(HDC dc, SIZE clientSize, RECT updateRect);
50 virtual BOOL OnHostWndMsg(LPMSG msg, LRESULT* result);
51 virtual BOOL SupportsCompositedParent() const;
52 virtual void Activate();
53
54private:
55 BOOL m_bCreated;
56 BOOL m_bLoadFinished;
57 BOOL m_bLoadSuccess;
58 CXTPMsgPreviewDialog* m_MsgDialog;
59
60private:
61 typedef struct _TEXTFIEDS
62 {
63 CString m_To;
64 CString m_Date;
65 CString m_Subject;
66 CString m_CC;
67 CString m_BCC;
68 CString m_Attachments;
69 CString m_Body;
70
71 CString m_ReceiverName;
72 CString m_SenderName;
73 CString m_SenderMail;
74 CString m_ReceiverMail;
75 } TextFields;
76
77 class CStatStg
78 {
79 public:
80 STATSTG m_statStg;
81 ~CStatStg()
82 {
83 CoTaskMemFree(m_statStg.pwcsName);
84 }
85 };
86
87 friend class CXTPMsgPreviewProvider;
88 BOOL CreateMsgDialog(HWND parent);
89 BOOL LoadMsg(LPCTSTR pFilePath);
90 BOOL LoadMsg(IStream* pStream, LPCTSTR pImpliedFileName);
91 static BOOL MustRead(CString& tag);
92 static BOOL ReadStream(CStatStg& stg, CString& val, CString type, IStorage* pStorage);
93 static void PlaceValue(TextFields& fields, CString val, CString tag);
94 static BOOL ReadAttachmentStorage(TextFields& fields, LPOLESTR storageName, IStorage* pStorage);
95 void FillFields(TextFields fields);
96};
97
98# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
99#endif // #if !defined(__XTPMSGPREVIEW_H__)
100
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPMsgPreviewProvider
Provides a preview handler for the Outlook Message (MSG) file type.
Definition XTPMsgPreviewProvider.h:41
IXTPPreview
The base interface for a preview handler implementation.
Definition XTPPreviewAbstract.h:40
IXTPPreview::GetNumberOfPages
virtual UINT GetNumberOfPages() const =0
Retrieves the number of pages available for the common page navigator.
IXTPPreview::Draw
virtual void Draw(HDC dc, SIZE clientSize, RECT updateRect)=0
This method is called every time the preview has to draw itself into the available client area.
IXTPPreview::GoToPage
virtual void GoToPage(UINT page)=0
If pages are supported by the preview, then it should cause navigation to the specified page number.
IXTPPreview::OnHostWndMsg
virtual BOOL OnHostWndMsg(LPMSG msg, LRESULT *result)=0
Handles a window message sent to the host preview control.
IXTPPreview::GetPreferredPageSize
virtual SIZE GetPreferredPageSize() const =0
Obtains the preferred page size in pixels if that is required by the preview.
IXTPPreview::SupportsCompositedParent
virtual BOOL SupportsCompositedParent() const =0
Determines if the preview implementation is compatible with composited top level windows (i....
IXTPPreview::IsAvailable
virtual BOOL IsAvailable() const =0
Determines if the preview is available (i.e.
IXTPPreview::IsReady
virtual BOOL IsReady() const =0
Returns TRUE if the handler has attempted and finished loading the preview regardless of the actual l...
IXTPPreview::HasOwnNavigator
virtual BOOL HasOwnNavigator() const =0
Determines if the handler implements its own page navigator.
IXTPPreview::Activate
virtual void Activate()=0
Activate preview.


Toolkit Pro: XTPSkinObjectEdit.h Source File

  • Source
  • SkinFramework
XTPSkinObjectEdit.h
Go to the documentation of this file.
1
23#if !defined(__XTPSKINOBJECTEDIT_H__)
24# define __XTPSKINOBJECTEDIT_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPSkinObjectEdit : public CXTPSkinObjectUser32Control
39{
41 DECLARE_DYNCREATE(CXTPSkinObjectEdit)
43public:
48 CXTPSkinObjectEdit();
49
54 virtual ~CXTPSkinObjectEdit();
55
56protected:
58 void DrawFrame(CDC* pDC);
59 virtual int GetClientBrushMessage();
60
61protected:
62 DECLARE_MESSAGE_MAP()
63
64 //{{AFX_VIRTUAL(CXTPSkinObjectEdit)
65 //}}AFX_VIRTUAL
66
67 //{{AFX_MSG(CXTPSkinObjectEdit)
68 //}}AFX_MSG
70};
71
72# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
74#endif // !defined(__XTPSKINOBJECTEDIT_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPSkinObjectEdit
CXTPSkinObjectEdit is a CXTPSkinObjectUser32Control derived class.
Definition XTPSkinObjectEdit.h:39
CXTPSkinObjectEdit::~CXTPSkinObjectEdit
virtual ~CXTPSkinObjectEdit()
Destroys a CXTPSkinObjectEdit object, handles cleanup and deallocation.
CXTPSkinObjectEdit::CXTPSkinObjectEdit
CXTPSkinObjectEdit()
Constructs a CXTPSkinObjectEdit object.
CXTPSkinObjectUser32Control
CXTPSkinObjectUser32Control is a CXTPSkinObjectFrame derived class.
Definition XTPSkinObjectFrame.h:400


Toolkit Pro: XTPWindowList.h Source File

  • Source
  • Controls
  • Dialog
XTPWindowList.h
Go to the documentation of this file.
1
23#if !defined(_XTPWINDOWLIST_H__)
24# define _XTPWINDOWLIST_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
37class _XTP_EXT_CLASS CXTPWindowList : public CXTPResizeDialog
38{
40 DECLARE_DYNAMIC(CXTPWindowList)
42public:
48 CXTPWindowList(CMDIFrameWnd* pMDIFrameWnd);
49
55 CXTPWindowList(HWND hWndMDIClient);
56
57public:
63 void SetWindowIcon(HICON hIcon)
64 {
65 m_hIcon = hIcon;
66 }
67
68protected:
74 virtual void InsertMDIChild(HWND hwndMDIChildWnd);
75
83 virtual CString GetChildWndText(HWND hWnd) const;
84
90 void RestoreAndMinimize();
91
97 virtual void SetEnableButtons();
98
105 void FillMDIClientWindowList(HWND hWnd);
106
112 virtual void FillMDIWindowList();
113
118 virtual void SelectMDIActive();
119
120protected:
122 DECLARE_MESSAGE_MAP()
123
124 //{{AFX_VIRTUAL(CXTPWindowList)
125 virtual void DoDataExchange(CDataExchange* pDX); // DDX/DDV support
126 //}}AFX_VIRTUAL
127
128 //{{AFX_MSG(CXTPWindowList)
129 virtual BOOL OnInitDialog();
130 afx_msg void OnSelchangeLBox();
131 afx_msg void OnBtnActivate();
132 afx_msg void OnBtnSave();
133 afx_msg void OnBtnClosewindows();
134 afx_msg void OnBtnTilehorz();
135 afx_msg void OnBtnTilevert();
136 afx_msg void OnBtnCascade();
137 afx_msg void OnBtnMinimize();
138 afx_msg void OnDrawItem(int nIDCtl, LPDRAWITEMSTRUCT lpDrawItemStruct);
139 afx_msg void OnDestroy();
140 //}}AFX_MSG
143protected:
145 //{{AFX_DATA(CXTPWindowList)
146 CButton m_btnMinimize;
147 CButton m_btnCascade;
148 CButton m_btnOk;
149 CButton m_btnTileVert;
150 CButton m_btnTileHorz;
151 CButton m_btnSave;
152 CButton m_btnClose;
153 CButton m_btnActivate;
154 //}}AFX_DATA
157 HWND m_hWndMDIClient;
158 HICON m_hIcon;
159 CMDIFrameWnd* m_pMDIFrameWnd;
160 CXTPListBox m_lboxWindows;
161};
162
163# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
165#endif // !defined(_XTPWINDOWLIST_H__)
XTPDisableNoisyWarnings.h
CXTPListBox
CXTPListBox is a CListBox derived class.
Definition XTPListBox.h:127
CXTPResizeDialog
CXTPResizeDialog is a multiple inheritance class derived from CDialog and CXTPResize.
Definition XTPResizeDialog.h:42
CXTPWindowList
CXTPWindowList dialog.
Definition XTPWindowList.h:38
CXTPWindowList::CXTPWindowList
CXTPWindowList(CMDIFrameWnd *pMDIFrameWnd)
Constructs a CXTPWindowList object.
CXTPWindowList::FillMDIWindowList
virtual void FillMDIWindowList()
Call this member function to populate the window list with currently open MDI children.
CXTPWindowList::SetEnableButtons
virtual void SetEnableButtons()
Call this member function to enable/disable button controls for the window list dialog depending on s...
CXTPWindowList::InsertMDIChild
virtual void InsertMDIChild(HWND hwndMDIChildWnd)
Call this member function to add a MDI child to the window list.
CXTPWindowList::SetWindowIcon
void SetWindowIcon(HICON hIcon)
Call this member function to set the dialog's icon.
Definition XTPWindowList.h:63
CXTPWindowList::SelectMDIActive
virtual void SelectMDIActive()
Call this member function to select the active MDI child window.
CXTPWindowList::GetChildWndText
virtual CString GetChildWndText(HWND hWnd) const
Call this member function to retrieve a MDI child window's text.
CXTPWindowList::CXTPWindowList
CXTPWindowList(HWND hWndMDIClient)
Constructs a CXTPWindowList object.
CXTPWindowList::RestoreAndMinimize
void RestoreAndMinimize()
Call this member function to toggle the restore/minimize state for selected MDI children.
CXTPWindowList::FillMDIClientWindowList
void FillMDIClientWindowList(HWND hWnd)
Call this member function to populate the window list with MDI children.


Toolkit Pro: XTPChartPointSeriesErrorBar.h Source File

  • Source
  • Chart
  • Styles
  • Point
XTPChartPointSeriesErrorBar.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTPOINTSERIESERRORBAR_H__)
24# define __XTPCHARTPOINTSERIESERRORBAR_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartSeriesView;
34
35class _XTP_EXT_CLASS CXTPChartPointSeriesErrorBar : public CXTPChartErrorBar
36{
37 DECLARE_SERIAL(CXTPChartPointSeriesErrorBar);
38
39public:
44 CXTPChartPointSeriesErrorBar();
45
50 virtual ~CXTPChartPointSeriesErrorBar();
51
52public:
63 virtual CXTPChartElementView* CreateView(CXTPChartDeviceContext* pDC,
64 CXTPChartSeriesPointView* pPointView,
65 CXTPChartElementView* pParentView);
66
67 void DoPropExchange(CXTPPropExchange* pPX);
68
69public:
70# ifdef _XTP_ACTIVEX
71public:
73 DECLARE_DISPATCH_MAP()
74 DECLARE_INTERFACE_MAP()
75 DECLARE_OLETYPELIB_EX(CXTPChartPointSeriesErrorBar);
77# endif
78};
79
85class _XTP_EXT_CLASS CXTPChartPointSeriesErrorBarView : public CXTPChartErrorBarView
86{
87public:
96 CXTPChartPointSeriesErrorBarView(CXTPChartErrorBar* pErrorBar,
97 CXTPChartSeriesPointView* pPointView,
98 CXTPChartElementView* pParentView);
99
100 void CalculateLayout(CXTPChartDeviceContext* pDC);
101};
103# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
104#endif //#if !defined(__XTPCHARTPOINTSERIESERRORBAR_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartElement::DoPropExchange
virtual void DoPropExchange(CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
CXTPChartElementView
This class represents the view of a chart element.
Definition XTPChartElementView.h:47
CXTPChartPointSeriesErrorBarView
This class abstracts the view of the label of a bar series.
Definition XTPChartPointSeriesErrorBar.h:86
CXTPChartPointSeriesErrorBarView::CXTPChartPointSeriesErrorBarView
CXTPChartPointSeriesErrorBarView(CXTPChartErrorBar *pErrorBar, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView)
Constructs a CXTPChartPointSeriesErrorBarView object.
CXTPChartSeriesPointView
Represents chart series point view.
Definition XTPChartSeriesPointView.h:48
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72


Toolkit Pro: Member List

CXTPColorSelectorCtrlThemeVisualStudio2022 Member List

This is the complete list of members for CXTPColorSelectorCtrlThemeVisualStudio2022, including all inherited members.

CalcSize(CXTPColorSelectorCtrl *pOwner) | CXTPColorSelectorCtrlThemeOffice2013 | virtual
CreateAutoButton(CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked) | CXTPColorSelectorCtrlThemeOffice2013 | virtual
CreateColorButtons(CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked) | CXTPColorSelectorCtrlTheme | virtual
CreateExtendedButtons(CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked) | CXTPColorSelectorCtrlThemeOffice2013 | virtual
CreateMoreButton(CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked) | CXTPColorSelectorCtrlThemeOffice2013 | virtual
CreateRecentColorButtons(CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked) | CXTPColorSelectorCtrlThemeOffice2013 | virtual
CreateThemeButtons(CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked) | CXTPColorSelectorCtrlThemeOffice2013 | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPColorSelectorCtrlTheme() | CXTPColorSelectorCtrlTheme |
CXTPColorSelectorCtrlThemeOffice2013() | CXTPColorSelectorCtrlThemeOffice2013 |
CXTPColorSelectorCtrlThemeVisualStudio2015() | CXTPColorSelectorCtrlThemeVisualStudio2015 |
CXTPColorSelectorCtrlThemeVisualStudio2022() | CXTPColorSelectorCtrlThemeVisualStudio2022 |
CXTPControlTheme() | CXTPControlTheme |
DrawBorder(CDC *pDC, CRect rcItem, CRect rcBorder, COLORREF crBorder) | CXTPColorSelectorCtrlThemeOffice2013 | virtual
DrawColor(CDC *pDC, CXTPColorSelectorCtrl *pOwner, CXTPColorSelectorCtrl::COLOR_CELL *pColorCell, CRect rcItem, BOOL bChecked, BOOL bHighlight, BOOL bPressed) | CXTPColorSelectorCtrlThemeOffice2013 | virtual
DrawColorCell(CDC *pDC, CXTPColorSelectorCtrl *pOwner, CXTPColorSelectorCtrl::COLOR_CELL *pColorCell, BOOL bHighlight, BOOL bPressed) | CXTPColorSelectorCtrlThemeVisualStudio2015 | virtual
DrawColorSelector(CDC *pDC, CXTPColorSelectorCtrl *pOwner) | CXTPColorSelectorCtrlThemeOffice2013 | virtual
FillBackground(CDC *pDC, CXTPColorSelectorCtrl *pOwner, const CRect &rect) | CXTPColorSelectorCtrlTheme | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetButtonSize() const | CXTPColorSelectorCtrlTheme | virtual
GetThemeStyle() const | CXTPControlTheme |
m_bThinBorder | CXTPColorSelectorCtrlTheme |
m_crBack | CXTPColorSelectorCtrlTheme |
m_crBackChecked | CXTPColorSelectorCtrlTheme |
m_crBackHilight | CXTPColorSelectorCtrlTheme |
m_crBackPressed | CXTPColorSelectorCtrlTheme |
m_crBorder | CXTPColorSelectorCtrlTheme |
m_crBorderHilight | CXTPColorSelectorCtrlTheme |
m_crBorderInside | CXTPColorSelectorCtrlThemeOffice2013 | protected
m_crBorderPressed | CXTPColorSelectorCtrlTheme |
m_crPopupBorder | CXTPColorSelectorCtrlTheme |
m_crText | CXTPColorSelectorCtrlTheme |
m_crTextPressed | CXTPColorSelectorCtrlTheme |
m_crTitleBack | CXTPColorSelectorCtrlThemeOffice2013 | protected
m_crTitleText | CXTPColorSelectorCtrlThemeOffice2013 | protected
m_nAutoButton | CXTPColorSelectorCtrlTheme |
m_nCaption | CXTPColorSelectorCtrlTheme |
m_nMargin | CXTPColorSelectorCtrlTheme |
m_nTheme | CXTPControlTheme | protected
m_rcRecentText | CXTPColorSelectorCtrlTheme |
m_rcStandardText | CXTPColorSelectorCtrlTheme |
m_rcThemeText | CXTPColorSelectorCtrlTheme |
m_sizeButton | CXTPColorSelectorCtrlTheme |
RefreshMetrics(CXTPColorSelectorCtrl *pOwner) | CXTPColorSelectorCtrlThemeVisualStudio2015 | virtual
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static


Toolkit Pro: XTPChart2dPie.h Source File

  • Source
  • Chart
  • Types
  • 2D
XTPChart2dPie.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHART2DPIE_H__)
24# define __XTPCHART2DPIE_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartDeviceCommand;
34class CXTPChartEllipse;
35
40class _XTP_EXT_CLASS CXTPChartPie : public CXTPChartPieBase
41{
42public:
53 CXTPChartPie(double dStartAngle, double dFinishAngle, const CXTPChartEllipse& ellipse,
54 int nDepthPercent, int nHolePercent);
55
56public:
70 virtual CXTPChartDeviceCommand* CreatePieDeviceCommand(const CXTPChartColor& color,
71 const CXTPChartColor& color2,
72 const CXTPChartPointF& basePoint);
73
87 virtual CXTPChartDeviceCommand* CreateBoundedPieDeviceCommand(const CXTPChartColor& color,
88 int nThickness,
89 const CXTPChartPointF& basePoint);
90};
92# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
93#endif //#if !defined(__XTPCHART2DPIE_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartColor
This class abstracts a color entity.
Definition XTPChartTypes.h:51
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPChartEllipse
This class abstracts an ellipse.
Definition XTPChartPie.h:42
CXTPChartPieBase
This class abstracts a pie chart.
Definition XTPChartPie.h:176
CXTPChartPie
This class abstracts a pie chart.
Definition XTPChart2dPie.h:41
CXTPChartPie::CreatePieDeviceCommand
virtual CXTPChartDeviceCommand * CreatePieDeviceCommand(const CXTPChartColor &color, const CXTPChartColor &color2, const CXTPChartPointF &basePoint)
This function creates a CXTPChartDeviceCommand object.
CXTPChartPie::CXTPChartPie
CXTPChartPie(double dStartAngle, double dFinishAngle, const CXTPChartEllipse &ellipse, int nDepthPercent, int nHolePercent)
Constructs a CXTPChartPieBase object.
CXTPChartPie::CreateBoundedPieDeviceCommand
virtual CXTPChartDeviceCommand * CreateBoundedPieDeviceCommand(const CXTPChartColor &color, int nThickness, const CXTPChartPointF &basePoint)
This function creates a CXTPChartDeviceCommand object.
CXTPPoint2T< float >


Toolkit Pro: XTPComboBoxThemeVisualStudio2015.h Source File

  • Source
  • Controls
  • Combo
  • Themes
XTPComboBoxThemeVisualStudio2015.h
Go to the documentation of this file.
1
23#if !defined(__XTPCOMBOBOXTHEMEVISUALSTUDIO2015_H__)
24# define __XTPCOMBOBOXTHEMEVISUALSTUDIO2015_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPComboBoxThemeVisualStudio2015 : public CXTPComboBoxThemeOffice2013
39{
40public:
45 CXTPComboBoxThemeVisualStudio2015();
46
51 virtual ~CXTPComboBoxThemeVisualStudio2015();
52
59 virtual void RefreshMetrics(CXTPComboBox* pComboBox);
60
69 virtual void DrawButton(CDC* pDC, CXTPComboBox* pComboBox, CRect rcBtn);
70};
71
72# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
74#endif // __XTPCOMBOBOXTHEMEVISUALSTUDIO2015_H__
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPComboBox
The CXTPComboBox class provides the functionality of a themed Windows combobox.
Definition XTPComboBox.h:42
CXTPComboBoxThemeOffice2013
Used as the paint manager for a combobox control to render an Office 2013 appearance.
Definition XTPComboBoxThemeOffice2013.h:39
CXTPComboBoxThemeVisualStudio2015
Used as the paint manager for a combobox control to render a Visual Studio 2015 appearance.
Definition XTPComboBoxThemeVisualStudio2015.h:39
CXTPComboBoxThemeVisualStudio2015::~CXTPComboBoxThemeVisualStudio2015
virtual ~CXTPComboBoxThemeVisualStudio2015()
Destructor handles cleanup and deallocation.
CXTPComboBoxThemeVisualStudio2015::RefreshMetrics
virtual void RefreshMetrics(CXTPComboBox *pComboBox)
This member function is called by the theme manager to refresh the visual styles used by each compone...
CXTPComboBoxThemeVisualStudio2015::DrawButton
virtual void DrawButton(CDC *pDC, CXTPComboBox *pComboBox, CRect rcBtn)
Called by the paint manager to draw the button portion of the combobox control.
CXTPComboBoxThemeVisualStudio2015::CXTPComboBoxThemeVisualStudio2015
CXTPComboBoxThemeVisualStudio2015()
Default constructor.


Toolkit Pro: Member List

CXTPChartTimeScaleTypeMap Member List

This is the complete list of members for CXTPChartTimeScaleTypeMap, including all inherited members.

Create(CXTPChartAxis *pAxis) | CXTPChartScaleTypeMap | static
CXTPChartElement() | CXTPChartElement |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartScaleTypeMap(CXTPChartAxis *pAxis) | CXTPChartScaleTypeMap |
DoPropExchange(CXTPPropExchange *pPX) | CXTPChartElement | virtual
GetAppearance() const | CXTPChartElement |
GetAxis() const | CXTPChartScaleTypeMap |
GetContent() const | CXTPChartElement |
GetOwner() const | CXTPChartElement |
InternalToValue(CXTPChartNumberFormat *pFromat, double dValue) const | CXTPChartTimeScaleTypeMap | virtual
Is3D() const | CXTPChartObject |
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartElement | virtual
Release() | CXTPChartElement | virtual
UpdateSeries(CXTPChartAxisView *pAxisView) | CXTPChartScaleTypeMap | virtual
UpdateSeries(CXTPChartSeries *pSeries) | CXTPChartScaleTypeMap | virtual
UpdateSeriesPointArgument(CXTPChartSeriesPoint *pPoint) | CXTPChartTimeScaleTypeMap | protectedvirtual
ValueToInternal(const CXTPChartString &strValue) const | CXTPChartTimeScaleTypeMap | virtual
~CXTPChartElement() | CXTPChartElement | virtual
~CXTPChartScaleTypeMap() | CXTPChartScaleTypeMap | virtual


Toolkit Pro: Member List

CXTPScrollableTreeCtrlT< TreeBase > Member List

This is the complete list of members for CXTPScrollableTreeCtrlT< TreeBase >, including all inherited members.

Create(LPCTSTR lpszClassName, LPCTSTR lpszWindowName, DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID, CCreateContext *pContext=NULL) | CXTPScrollable< TreeBase > | virtual
CreateEx(DWORD dwExStyle, LPCTSTR lpszClassName, LPCTSTR lpszWindowName, DWORD dwStyle, int x, int y, int nWidth, int nHeight, HWND hWndParent, HMENU nIDorHMenu, LPVOID lpParam=NULL) | CXTPScrollable< TreeBase > | virtual
CreateEx(DWORD dwExStyle, LPCTSTR lpszClassName, LPCTSTR lpszWindowName, DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID, LPVOID lpParam=NULL) | CXTPScrollable< TreeBase > | virtual
CXTPScrollable() | CXTPScrollable< TreeBase > |
CXTPScrollableTreeCtrlT() | CXTPScrollableTreeCtrlT< TreeBase > |
EnableDefaultBorderDrawing(BOOL bEnable=TRUE) | CXTPScrollable< TreeBase > |
InitScrollBars() | CXTPScrollable< TreeBase > |
SetScrollBarTheme(XTPScrollBarTheme nTheme) | CXTPScrollable< TreeBase > |
~IXTPScrollable() | IXTPScrollable | inlinevirtual


Toolkit Pro: XTPDatePickerItemMonth.h Source File

  • Source
  • Calendar
  • DatePicker
XTPDatePickerItemMonth.h
Go to the documentation of this file.
1
22#if !defined(_XTPDATEPICKERITEMMONTH_H__)
23# define _XTPDATEPICKERITEMMONTH_H__
24
25# if _MSC_VER > 1000
26# pragma once
27# endif // _MSC_VER > 1000
28
29# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
30
32const UINT XTP_MAX_WEEKS = (UINT)6;
33
35const UINT XTP_WEEK_DAYS = (UINT)7;
36
37class CXTPDatePickerControl;
38class CXTPDatePickerItemDay;
39
53class _XTP_EXT_CLASS CXTPDatePickerItemMonth : public CXTPCmdTarget
54{
55 friend class CXTPDatePickerControl;
56 friend class CXTPDatePickerPaintManager;
57
58public:
77 CXTPDatePickerItemMonth(CXTPDatePickerControl* pControl, COleDateTime dtMonth, int nRow,
78 int nCol);
79
88 virtual ~CXTPDatePickerItemMonth();
89
114 void AdjustLayout(CRect rcClient, BOOL bIsAuto = FALSE);
115
130 virtual void Draw(CDC* pDC);
131
142 COleDateTime GetMonth() const;
143
162 BOOL GetShowDaysBefore() const;
163
180 BOOL GetShowDaysAfter() const;
181
198 void SetShowDaysBefore(BOOL bShow);
199
216 void SetShowDaysAfter(BOOL bShow);
217
235 BOOL GetShowLeftScroll() const;
236
254 BOOL GetShowRightScroll() const;
255
278 void SetShowScrolling(BOOL bLeftScroll, BOOL bRightScroll);
279
308 CXTPDatePickerItemDay* GetDay(int nIndex) const;
309
319 int GetDayCount() const;
320
342 CXTPDatePickerItemDay* HitTest(CPoint point, BOOL bCheckVisible = TRUE) const;
343
344protected:
351 void ClearDays();
352
359 void PopulateDays();
360
373 void OnLButtonDown(UINT nFlags, CPoint point);
374
387 void OnLButtonUp(UINT nFlags, CPoint point);
388
400 void OnMouseMove(UINT nFlags, CPoint point);
401
412 BOOL OnSetCursor(CPoint point);
413
431 void ByFontAdjustLayout(CRect rcClient);
432
449 void AutoAdjustLayout(CRect rcClient);
450
451 // Attributes
452public:
457 CXTPDatePickerControl* m_pControl;
458
463 int m_nRow;
464
469 int m_nColumn;
470
475 COleDateTime m_dtMonth;
476
482 BOOL m_bShowDaysBefore;
483
489 BOOL m_bShowDaysAfter;
490
496 BOOL m_bShowLeftScroll;
497
503 BOOL m_bShowRightScroll;
504
509 CRect m_rcMonth;
510
515 CRect m_rcHeader;
516
521 CRect m_rcDaysOfWeek;
522
527 CRect m_rcWeekNumbers;
528
533 CRect m_rcDaysArea;
534
539 CRect m_rcLeftScroll;
540
545 CRect m_rcRightScroll;
546
547protected:
553 CArray<CXTPDatePickerItemDay*, CXTPDatePickerItemDay*> m_arrDays;
554
555private:
556 static void AFX_CDECL Swap(COleDateTime& dtFirst, COleDateTime& dtSecond);
557};
558
559AFX_INLINE COleDateTime CXTPDatePickerItemMonth::GetMonth() const
560{
561 return m_dtMonth;
562}
563AFX_INLINE BOOL CXTPDatePickerItemMonth::GetShowDaysBefore() const
564{
565 return m_bShowDaysBefore;
566}
567AFX_INLINE BOOL CXTPDatePickerItemMonth::GetShowDaysAfter() const
568{
569 return m_bShowDaysAfter;
570}
571AFX_INLINE void CXTPDatePickerItemMonth::SetShowDaysBefore(BOOL bShow)
572{
573 m_bShowDaysBefore = bShow;
574}
575AFX_INLINE void CXTPDatePickerItemMonth::SetShowDaysAfter(BOOL bShow)
576{
577 m_bShowDaysAfter = bShow;
578}
579AFX_INLINE BOOL CXTPDatePickerItemMonth::GetShowLeftScroll() const
580{
581 return m_bShowLeftScroll;
582}
583AFX_INLINE BOOL CXTPDatePickerItemMonth::GetShowRightScroll() const
584{
585 return m_bShowRightScroll;
586}
587AFX_INLINE void CXTPDatePickerItemMonth::SetShowScrolling(BOOL bLeftScroll, BOOL bRightScroll)
588{
589 m_bShowLeftScroll = bLeftScroll;
590 m_bShowRightScroll = bRightScroll;
591}
592AFX_INLINE void AFX_CDECL CXTPDatePickerItemMonth::Swap(COleDateTime& dtFirst,
593 COleDateTime& dtSecond)
594{
595 COleDateTime dtTemp = dtFirst;
596 dtFirst = dtSecond;
597 dtSecond = dtTemp;
598}
599
600# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
601#endif // !defined(_XTPDATEPICKERITEMMONTH_H__)
XTP_WEEK_DAYS
const UINT XTP_WEEK_DAYS
Number of days in the week.
Definition XTPDatePickerItemMonth.h:35
XTP_MAX_WEEKS
const UINT XTP_MAX_WEEKS
Maximum amount of weeks shown in one month area.
Definition XTPDatePickerItemMonth.h:32
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPDatePickerControl
Class CXTPDatePickerControl encapsulates the functionality of a date and time picker control.
Definition XTPDatePickerControl.h:331
CXTPDatePickerItemDay
Class CXTPDatePickerItemDay represents one displayed day item in the calendar.
Definition XTPDatePickerItemDay.h:47
CXTPDatePickerItemMonth
Class CXTPDatePickerItemMonth represents one month inside the date picker month grid.
Definition XTPDatePickerItemMonth.h:54
CXTPDatePickerItemMonth::m_arrDays
CArray< CXTPDatePickerItemDay *, CXTPDatePickerItemDay * > m_arrDays
This member variable is a CArray<CXTPDatePickerItemDay*, CXTPDatePickerItemDay*> object that is used ...
Definition XTPDatePickerItemMonth.h:553
CXTPDatePickerItemMonth::ClearDays
void ClearDays()
Call this member function to cleanup the days array.
CXTPDatePickerItemMonth::AutoAdjustLayout
void AutoAdjustLayout(CRect rcClient)
This member function is used to calculate the size of the header, days of week, week numbers,...
CXTPDatePickerItemMonth::m_bShowRightScroll
BOOL m_bShowRightScroll
This member variable is a BOOL that is used to determine if the "right scroll triangle" is visible.
Definition XTPDatePickerItemMonth.h:503
CXTPDatePickerItemMonth::OnMouseMove
void OnMouseMove(UINT nFlags, CPoint point)
This function is called to process mouse move messages.
CXTPDatePickerItemMonth::m_pControl
CXTPDatePickerControl * m_pControl
This member variable is a CXTPDatePickerControl object pointer to the parent control.
Definition XTPDatePickerItemMonth.h:457
CXTPDatePickerItemMonth::GetShowRightScroll
BOOL GetShowRightScroll() const
Call this member function to determine if the right scroll triangle is visible.
Definition XTPDatePickerItemMonth.h:583
CXTPDatePickerItemMonth::m_rcDaysArea
CRect m_rcDaysArea
This member variable is a CRect object that contains the coordinates of the month's "all days" area.
Definition XTPDatePickerItemMonth.h:533
CXTPDatePickerItemMonth::m_rcDaysOfWeek
CRect m_rcDaysOfWeek
This member variable is a CRect object that contains the coordinates of the month's "week days" area.
Definition XTPDatePickerItemMonth.h:521
CXTPDatePickerItemMonth::m_rcLeftScroll
CRect m_rcLeftScroll
This member variable is a CRect object that contains the coordinates of the left scroll triangle area...
Definition XTPDatePickerItemMonth.h:539
CXTPDatePickerItemMonth::SetShowScrolling
void SetShowScrolling(BOOL bLeftScroll, BOOL bRightScroll)
Call this member function to add the left and the right scrolling triangles.
Definition XTPDatePickerItemMonth.h:587
CXTPDatePickerItemMonth::m_nColumn
int m_nColumn
This member variable is an int that is used for the column month index.
Definition XTPDatePickerItemMonth.h:469
CXTPDatePickerItemMonth::m_nRow
int m_nRow
This member variable is an int that is used for the row month index.
Definition XTPDatePickerItemMonth.h:463
CXTPDatePickerItemMonth::SetShowDaysAfter
void SetShowDaysAfter(BOOL bShow)
Call this member function to set whether days after this month are shown.
Definition XTPDatePickerItemMonth.h:575
CXTPDatePickerItemMonth::m_rcMonth
CRect m_rcMonth
This member variable is a CRect object that contains the coordinates of the total month's area.
Definition XTPDatePickerItemMonth.h:509
CXTPDatePickerItemMonth::PopulateDays
void PopulateDays()
Call this member function to populate the day objects.
CXTPDatePickerItemMonth::~CXTPDatePickerItemMonth
virtual ~CXTPDatePickerItemMonth()
Default collection destructor.
CXTPDatePickerItemMonth::m_bShowDaysAfter
BOOL m_bShowDaysAfter
This member variable is a BOOL that is used to indicate if the "days after this month" are visible.
Definition XTPDatePickerItemMonth.h:489
CXTPDatePickerItemMonth::Draw
virtual void Draw(CDC *pDC)
Call this member function to perform drawing logic.
CXTPDatePickerItemMonth::SetShowDaysBefore
void SetShowDaysBefore(BOOL bShow)
Call this member function to set whether days before this month are shown.
Definition XTPDatePickerItemMonth.h:571
CXTPDatePickerItemMonth::GetShowDaysBefore
BOOL GetShowDaysBefore() const
Call this member function to determine if the days before a given month are displayed.
Definition XTPDatePickerItemMonth.h:563
CXTPDatePickerItemMonth::ByFontAdjustLayout
void ByFontAdjustLayout(CRect rcClient)
Call this member function to calculate sizes and counts by font metrics.
CXTPDatePickerItemMonth::m_dtMonth
COleDateTime m_dtMonth
This member variable is COleDateTime object that is used as the date with the month definition for th...
Definition XTPDatePickerItemMonth.h:475
CXTPDatePickerItemMonth::m_rcWeekNumbers
CRect m_rcWeekNumbers
This member variable is a CRect object that contains the coordinates of the month's week numbers area...
Definition XTPDatePickerItemMonth.h:527
CXTPDatePickerItemMonth::GetShowLeftScroll
BOOL GetShowLeftScroll() const
Call this member function to determine if the left scroll triangle is visible.
Definition XTPDatePickerItemMonth.h:579
CXTPDatePickerItemMonth::m_bShowDaysBefore
BOOL m_bShowDaysBefore
This member variable is a BOOL that is used to determine if the "days before this month" are visible.
Definition XTPDatePickerItemMonth.h:482
CXTPDatePickerItemMonth::OnLButtonUp
void OnLButtonUp(UINT nFlags, CPoint point)
This member function is called to process left button up mouse messages.
CXTPDatePickerItemMonth::HitTest
CXTPDatePickerItemDay * HitTest(CPoint point, BOOL bCheckVisible=TRUE) const
Call this function to return the day where the mouse cursor was located when the left mouse button wa...
CXTPDatePickerItemMonth::m_rcRightScroll
CRect m_rcRightScroll
This member variable is a CRect object that contains the coordinates of the right scroll triangle are...
Definition XTPDatePickerItemMonth.h:545
CXTPDatePickerItemMonth::CXTPDatePickerItemMonth
CXTPDatePickerItemMonth(CXTPDatePickerControl *pControl, COleDateTime dtMonth, int nRow, int nCol)
Default CXTPDatePickerItemMonth object constructor.
CXTPDatePickerItemMonth::OnSetCursor
BOOL OnSetCursor(CPoint point)
This member function is called to process changing cursor message.
CXTPDatePickerItemMonth::GetMonth
COleDateTime GetMonth() const
Call this member function to obtain the month date.
Definition XTPDatePickerItemMonth.h:559
CXTPDatePickerItemMonth::GetDayCount
int GetDayCount() const
Call this member function to obtain the number of day items in the month collection.
CXTPDatePickerItemMonth::AdjustLayout
void AdjustLayout(CRect rcClient, BOOL bIsAuto=FALSE)
Call this member function to adjust the layout of all sub-items.
CXTPDatePickerItemMonth::m_bShowLeftScroll
BOOL m_bShowLeftScroll
This member variable is a BOOL that is used to determine if the "left scroll triangle" is visible.
Definition XTPDatePickerItemMonth.h:496
CXTPDatePickerItemMonth::OnLButtonDown
void OnLButtonDown(UINT nFlags, CPoint point)
This member function is called to process left button down mouse messages.
CXTPDatePickerItemMonth::GetDay
CXTPDatePickerItemDay * GetDay(int nIndex) const
Call this member function to obtain the day item by its index in the day collection of the month.
CXTPDatePickerItemMonth::m_rcHeader
CRect m_rcHeader
This member variable is a CRect object that contains the coordinates of the month's header area.
Definition XTPDatePickerItemMonth.h:515
CXTPDatePickerItemMonth::GetShowDaysAfter
BOOL GetShowDaysAfter() const
Call this member function to determine whether to show the days after this month.
Definition XTPDatePickerItemMonth.h:567
CXTPDatePickerPaintManager
Class CXTPDatePickerPaintManager handles most of the drawing activities for the DatePicker control.
Definition XTPDatePickerPaintManager.h:55


Toolkit Pro: Member List

CXTPCommandBarsNativeWindows11Theme Member List

This is the complete list of members for CXTPCommandBarsNativeWindows11Theme, including all inherited members.

AdjustExcludeRect(CRect &rc, CXTPControl *pControl, BOOL bVertical) | CXTPCommandBarsOfficeXPTheme | virtual
Animate(CDC *pDestDC, CDC *pSrcDC, CRect rc, XTPAnimationType animationType) | CXTPPaintManager | virtual
AnimateExpanding(CXTPCommandBar *pCommandBar, CDC *pDestDC, CDC *pSrcDC, BOOL bExpandDown) | CXTPPaintManager | virtual
BaseTheme() | CXTPCommandBarsOffice2013Theme | virtual
CreateTheme(XTPPaintTheme paintTheme) | CXTPPaintManager | static
CXTPCmdTarget() | CXTPCmdTarget |
CXTPCommandBarsModernUITheme() | CXTPCommandBarsModernUITheme |
CXTPCommandBarsNativeWindows11Theme() | CXTPCommandBarsNativeWindows11Theme |
CXTPCommandBarsOffice2013Theme() | CXTPCommandBarsOffice2013Theme |
CXTPCommandBarsOfficeXPTheme() | CXTPCommandBarsOfficeXPTheme |
CXTPObservable() | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | protected
CXTPPaintManager() | CXTPPaintManager | protected
Draw3dRect(CDC *pDC, LPCRECT rc, int nTopLeft, int nBottomRight) | CXTPPaintManager |
Draw3dRect(CDC *pDC, LPCRECT rc, int frameThickness, COLORREF clrPen, COLORREF clrBrush) | CXTPPaintManager |
CXTPPaintManager::DrawCheckMark(CDC *pDC, CRect rcCheck, COLORREF clr=0) | CXTPPaintManager | inline
DrawCheckRect(CDC *pDC, CRect rc, COLORREF clrFore, COLORREF clrBack) | CXTPCommandBarsNativeWindows11Theme | protectedvirtual
DrawComboExpandMark(CDC *pDC, CRect rc, COLORREF clr) | CXTPPaintManager | virtual
DrawCommandBarGripper(CDC *pDC, CXTPCommandBar *pBar, BOOL bDraw=TRUE) | CXTPCommandBarsNativeWindows11Theme | protectedvirtual
DrawCommandBarGroupSeparator(CDC *pDC, CXTPCommandBar *pBar, CXTPControl *pLeftControl, CXTPControl *pRightControl, BOOL bDraw) | CXTPCommandBarsOffice2013Theme | virtual
DrawCommandBarSeparator(CDC *pDC, CXTPCommandBar *pBar, CXTPControl *pControl, BOOL bDraw=TRUE) | CXTPCommandBarsOffice2013Theme | protectedvirtual
DrawControl(CDC *pDC, CXTPControl *pButton, BOOL bDraw=TRUE) | CXTPPaintManager |
DrawControlCheckBoxMark(CDC *pDC, CXTPControl *pButton, CRect rc, BOOL bDraw) | CXTPCommandBarsOffice2013Theme | protectedvirtual
DrawControlCheckBoxMark(CDC *pDC, CRect rc, BOOL bDraw, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled) | CXTPCommandBarsOffice2013Theme | protectedvirtual
DrawControlComboBox(CDC *pDC, CXTPControlComboBox *pComboBox, BOOL bDraw) | CXTPCommandBarsNativeWindows11Theme | protectedvirtual
DrawControlEdit(CDC *pDC, CXTPControlEdit *pEdit, BOOL bDraw) | CXTPCommandBarsOffice2013Theme | virtual
DrawControlEntry(CDC *pDC, CXTPControl *pButton) | CXTPPaintManager | virtual
DrawControlMDIButton(CDC *pDC, CXTPControlButton *pButton) | CXTPCommandBarsOffice2013Theme | protectedvirtual
DrawControlPopupParent(CDC *pDC, CXTPControl *pButton, BOOL bDraw) | CXTPCommandBarsOfficeXPTheme | protectedvirtual
DrawControlRadioButtonMark(CDC *pDC, CRect rc, BOOL bDraw, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled) | CXTPCommandBarsOffice2013Theme | protectedvirtual
DrawControlText(CDC *pDC, CXTPControl *pControl, CRect rcText, BOOL bDraw, BOOL bVert, BOOL bCentered, BOOL bTriangled) | CXTPPaintManager |
DrawControlToolBarParent(CDC *pDC, CXTPControl *pButton, BOOL bDraw) | CXTPPaintManager | virtual
DrawDialogBarGripper(CDC *pDC, CXTPDialogBar *pBar, BOOL bDraw) | CXTPCommandBarsOfficeXPTheme | virtual
DrawDropDownGlyph(CDC *pDC, CXTPControl *pControl, CPoint pt, BOOL bSelected, BOOL bPopuped, BOOL bEnabled, BOOL bVert) | CXTPCommandBarsOffice2013Theme | protectedvirtual
DrawExpandGlyph(CDC *pDC, CXTPControl *pButton, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clr) | CXTPCommandBarsOffice2013Theme | protectedvirtual
DrawExpandGlyph(CDC *pDC, CXTPControl *pButton, COLORREF clr, BOOL bVertical) | CXTPCommandBarsOffice2013Theme | protectedvirtual
DrawFrameBorder(CDC *pDC, CRect rc, int nBorderThickness, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition) | CXTPCommandBarsOffice2013Theme | protected
DrawGalleryItemBack(CDC *pDC, CRect rcItem, BOOL bEnabled, BOOL bSelected, BOOL bPressed, BOOL bChecked, XTPBarType barType) | CXTPCommandBarsNativeWindows11Theme | protectedvirtual
DrawHiddenGlyph(CDC *pDC, CXTPControl *pButton, COLORREF clr, BOOL bVertical) | CXTPCommandBarsOffice2013Theme | protectedvirtual
DrawImage(CDC *pDC, CPoint pt, CSize sz, CXTPImageManagerIcon *pImage, BOOL bSelected, BOOL bPressed, BOOL bEnabled=TRUE, BOOL bChecked=FALSE, BOOL bPopuped=FALSE, BOOL bToolBarImage=TRUE) | CXTPCommandBarsOfficeXPTheme | protectedvirtual
DrawListBoxControl(CDC *pDC, CXTPControl *pButton, CRect rc, BOOL bSelected, BOOL bDraw, CXTPCommandBars *pCommandBars=0) | CXTPCommandBarsOfficeXPTheme | virtual
DrawPopupBarCheckMark(CDC *pDC, CRect rcCheck, BOOL bEnabled, COLORREF clr) | CXTPPaintManager | virtual
DrawPopupBarGripper(CDC *pDC, int xPos, int yPos, int cx, int cy, BOOL bExpanded=FALSE) | CXTPCommandBarsOffice2013Theme | protectedvirtual
DrawPopupBarRadioMark(CDC *pDC, CRect rcCheck, BOOL bEnabled, COLORREF clr) | CXTPPaintManager | virtual
DrawPopupResizeGripper(CDC *pDC, CRect rcGripper, int nFlags) | CXTPCommandBarsOfficeXPTheme | virtual
DrawRectangle(CDC *pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition) | CXTPCommandBarsNativeWindows11Theme | protectedvirtual
DrawRectangle(CDC *pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition, int nID) | CXTPCommandBarsNativeWindows11Theme | protectedvirtual
DrawRectangle(CDC *pDC, CXTPControl *pButton) | CXTPCommandBarsNativeWindows11Theme | protectedvirtual
DrawSpecialControl(CDC *pDC, XTPSpecialControl controlType, CXTPControl *pButton, CXTPCommandBar *pBar, BOOL bDraw, LPVOID lpParam) | CXTPPaintManager | virtual
DrawSplitButtonFrame(CDC *pDC, CXTPControl *pButton, CRect rc) | CXTPCommandBarsNativeWindows11Theme | protectedvirtual
DrawTearOffGripper(CDC *pDC, CRect rcGripper, BOOL bSelected, BOOL bDraw) | CXTPCommandBarsOfficeXPTheme | virtual
FillCommandBarEntry(CDC *pDC, CXTPCommandBar *pBar) | CXTPCommandBarsNativeWindows11Theme | virtual
FillDockBar(CDC *pDC, CXTPDockBar *pBar) | CXTPCommandBarsNativeWindows11Theme | virtual
FillIntersectRect(CDC *pDC, CXTPPopupBar *pPopupBar, COLORREF clr) | CXTPCommandBarsOfficeXPTheme | protected
FillWorkspace(CDC *pDC, CRect rc, CRect rcExclude) | CXTPCommandBarsOffice2013Theme | virtual
FontExists(LPCTSTR lpszFaceName) | CXTPPaintManager | static
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCommandBarBorders(CXTPCommandBar *pBar) | CXTPCommandBarsNativeWindows11Theme | virtual
GetCommandBarFont(CXTPCommandBar *pCommandBar) | CXTPPaintManager | virtual
GetControlBackColor(CXTPControl *pButton) | CXTPCommandBarsOffice2013Theme | protectedvirtual
GetControlEditBackColor(CXTPControl *pControl) | CXTPCommandBarsOffice2013Theme | virtual
GetControlFont(CXTPControl *pControl) | CXTPPaintManager | virtual
GetControlHeight() const | CXTPPaintManager |
GetControlTextColor(CXTPControl *pButton) | CXTPCommandBarsNativeWindows11Theme | protectedvirtual
GetControlTextOrientation(CXTPControl *pControl) | CXTPPaintManager | virtual
GetCurrentSystemTheme() | CXTPPaintManager |
GetCurrentTheme() | CXTPPaintManager | inline
GetDefaultCommandBarSize(CXTPCommandBar *pBar) | CXTPPaintManager | virtual
GetFramePaintManager() | CXTPCommandBarsModernUITheme | virtual
GetGalleryPaintManager() const | CXTPPaintManager | virtual
GetGlobalPaintManager() | CXTPPaintManager | static
GetIconFont() | CXTPPaintManager |
GetIconsInfo() | CXTPPaintManager |
GetInstanceAddRef() | CXTPPaintManager | static
GetMarkupContext() | CXTPCommandBarsModernUITheme | virtual
GetMessageBarPaintManager() | CXTPPaintManager | virtual
GetPopupBarGripperWidth(CXTPCommandBar *pBar) | CXTPPaintManager | virtual
GetProgressPaintManager() const | CXTPPaintManager | virtual
GetRectangleTextColor(BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition) | CXTPCommandBarsOffice2013Theme | protectedvirtual
GetRegularBoldFont() | CXTPPaintManager |
GetRegularFont() | CXTPPaintManager |
GetRibbonPaintManager() | CXTPCommandBarsModernUITheme | virtual
GetScrollBarPaintManager() const | CXTPPaintManager | virtual
GetShadowManager() const | CXTPPaintManager |
GetShadowOptions() const | CXTPPaintManager |
GetSliderPaintManager() const | CXTPPaintManager | virtual
GetSmCaptionFont() | CXTPPaintManager |
GetSplitButtonCommandRect(CXTPControl *pButton) | CXTPPaintManager | virtual
GetStateColor() const | CXTPCommandBarsNativeWindows11Theme | virtual
GetStatusBarPaintManager() | CXTPPaintManager | virtual
GetXtremeColor(UINT nIndex) | CXTPPaintManager |
GradientFill(CDC *pDC, LPRECT lpRect, COLORREF crFrom, COLORREF crTo, BOOL bHorz, LPCRECT lpRectClip=NULL) | CXTPPaintManager |
HorizontalLine(CDC *pDC, int x0, int y0, int x1, COLORREF clrPen) | CXTPPaintManager |
IsUseSystemAccentColorEnabled() const | CXTPPaintManager |
Line(CDC *pDC, CPoint p0, CPoint p1) | CXTPPaintManager |
Line(CDC *pDC, int x0, int y0, int x1, int y1, const int nPen) | CXTPPaintManager |
Line(CDC *pDC, int x0, int y0, int x1, int y1, COLORREF clrPen) | CXTPPaintManager |
m_arrColor | CXTPPaintManager | protected
m_bAutoResizeIcons | CXTPPaintManager |
m_bClearTypeTextQuality | CXTPPaintManager |
m_bEmbossedDisabledText | CXTPPaintManager | protected
m_bEnableAnimation | CXTPPaintManager |
m_bFlatMenuBar | CXTPPaintManager |
m_bFlatToolBar | CXTPPaintManager |
m_bIntersect | CXTPCommandBarsOffice2013Theme | protected
m_bOffice2007Padding | CXTPPaintManager |
m_bOffsetPopupLabelText | CXTPPaintManager |
m_bSelectImageInPopupBar | CXTPPaintManager |
m_bShowKeyboardCues | CXTPPaintManager | protected
m_bShowShadow | CXTPPaintManager |
m_bThemedCheckBox | CXTPPaintManager |
m_bThemedStatusBar | CXTPPaintManager |
m_bThickCheckMark | CXTPPaintManager |
m_bUseOfficeFont | CXTPPaintManager |
m_bUseStandardFont | CXTPPaintManager | protected
m_bWrapCaptionBelowText | CXTPPaintManager |
m_clr3DShadow | CXTPCommandBarsOffice2013Theme | protected
m_clrActiveBack | CXTPCommandBarsNativeWindows11Theme | protected
m_clrBack | CXTPCommandBarsOffice2013Theme | protected
m_clrBtnFace | CXTPCommandBarsOffice2013Theme | protected
m_clrCaptionButtonFill | CXTPCommandBarsOffice2013Theme | protected
m_clrDisabledIcon | CXTPPaintManager |
m_clrFloatingGripper | CXTPPaintManager |
m_clrFloatingGripperText | CXTPPaintManager |
m_clrGlyph | CXTPCommandBarsOffice2013Theme | protected
m_clrGlyphDisabled | CXTPCommandBarsOffice2013Theme | protected
m_clrGlyphHighlight | CXTPCommandBarsOffice2013Theme | protected
m_clrGlyphPushed | CXTPCommandBarsOffice2013Theme | protected
m_clrHighlight | CXTPCommandBarsOffice2013Theme | protected
m_clrInactiveBack | CXTPCommandBarsNativeWindows11Theme | protected
m_clrMessageBarText | CXTPCommandBarsOffice2013Theme | protected
m_clrWorkspace | CXTPCommandBarsOffice2013Theme | protected
m_csCheckBox | CXTPCommandBarsOffice2013Theme | protected
m_csCheckMark | CXTPCommandBarsOffice2013Theme | protected
m_csComboBox | CXTPCommandBarsOffice2013Theme | protected
m_csMenu | CXTPCommandBarsOffice2013Theme | protected
m_csMenuTitleBar | CXTPCommandBarsOffice2013Theme | protected
m_csRibbon | CXTPCommandBarsOffice2013Theme | protected
m_csToolbar | CXTPCommandBarsOffice2013Theme | protected
m_fontIcon | CXTPPaintManager |
m_fontIconBold | CXTPPaintManager |
m_fontSmCaption | CXTPPaintManager |
m_fontToolTip | CXTPPaintManager |
m_iconsInfo | CXTPPaintManager | protected
m_nAnimationSteps | CXTPPaintManager | protected
m_nAnimationTime | CXTPPaintManager | protected
m_nEditHeight | CXTPPaintManager | protected
m_nFontHeight | CXTPPaintManager | protected
m_nPopupBarTextPadding | CXTPPaintManager |
m_nSplitButtonDropDownHeight | CXTPPaintManager |
m_nSplitButtonDropDownWidth | CXTPPaintManager |
m_nSplitButtonPopupWidth | CXTPPaintManager |
m_nStatusBarMinHeight | CXTPPaintManager |
m_nTextHeight | CXTPPaintManager |
m_pfnSetLayeredWindowAttributes | CXTPPaintManager |
m_pFramePaintManager | CXTPPaintManager |
m_pGalleryPaintManager | CXTPPaintManager |
m_pImages | CXTPCommandBarsModernUITheme | protected
m_pMarkupContext | CXTPCommandBarsModernUITheme | protected
m_pProgressPaintManager | CXTPPaintManager |
m_pRibbonPaintManager | CXTPPaintManager |
m_pScrollBarPaintManager | CXTPPaintManager |
m_pShadowManager | CXTPPaintManager | protected
m_pSliderPaintManager | CXTPPaintManager |
m_pStatusBarPaintManager | CXTPPaintManager |
m_rcMessageBarMargin | CXTPPaintManager |
m_rcStatusBarBorder | CXTPPaintManager |
m_strOfficeFont | CXTPPaintManager |
m_systemTheme | CXTPPaintManager | protected
m_themeButton | CXTPPaintManager | protected
m_themeCurrent | CXTPPaintManager | protected
m_themeStatusBar | CXTPPaintManager | protected
m_xtpFontRegular | CXTPPaintManager | protected
m_xtpFontRegularBold | CXTPPaintManager | protected
m_xtpFontVert | CXTPPaintManager | protected
m_xtpFontVertBold | CXTPPaintManager | protected
Notify(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *)) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
Notify(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1), A1 arg1) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
Notify(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
Notify(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamic(void(T::*method)(O *)) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1), A1 arg1) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *)) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1), A1 arg1) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyReversed(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *)) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyReversed(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1), A1 arg1) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyReversed(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyReversed(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
Pixel(CDC *pDC, int xPos, int yPos, int nPen) | CXTPPaintManager |
Rectangle(CDC *pDC, LPCRECT rc, int nPen, const int nBrush) | CXTPPaintManager |
Rectangle(CDC *pDC, LPCRECT rc, COLORREF clrPen, COLORREF clrBrush) | CXTPPaintManager |
RefreshMetrics() | CXTPCommandBarsNativeWindows11Theme | protectedvirtual
RefreshStandardColors() | CXTPCommandBarsOffice2013Theme | protectedvirtual
ReleaseInstance() | CXTPPaintManager | static
RequiresResourceImages() | CXTPCommandBarsOffice2013Theme | virtual
RoundRect(CDC *pDC, LPCRECT rc, COLORREF clrPen, COLORREF clrBrush) | CXTPPaintManager |
SetAnimationDelay(int nAnimationSteps, int nAnimationTime) | CXTPPaintManager |
SetColors(int cElements, CONST INT *lpaElements, CONST COLORREF *lpaRgbValues) | CXTPPaintManager |
SetCommandBarRegion(CXTPCommandBar *pCommandBar) | CXTPPaintManager | virtual
SetCommandBarsFontIndirect(LOGFONT *pLogFont, BOOL bUseStandardFont=FALSE) | CXTPPaintManager |
SetCustomTheme(CXTPPaintManager *pTheme) | CXTPPaintManager | static
SetGlobalPaintManager(CXTPPaintManager *pPaintManager) | CXTPPaintManager | static
SetImageHandle(HMODULE hResource, LPCTSTR lpszIniFileName) | CXTPPaintManager | virtual
SetLunaTheme(XTPCurrentSystemTheme systemTheme) | CXTPPaintManager |
SetStateColor(COLORREF clrState=COLORREF_NULL) | CXTPCommandBarsNativeWindows11Theme | virtual
SetTheme(XTPPaintTheme paintTheme) | CXTPPaintManager | static
StripMnemonics(CString &strClear) | CXTPPaintManager | static
Subscribe(IXTPPaintManagerEvents *pObserver, CXTPSubscriptionList< CXTPPaintManager, IXTPPaintManagerEvents > *pSubcriptionList=NULL) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > |
Triangle(CDC *pDC, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clr) | CXTPPaintManager | static
Unsubscribe(IXTPPaintManagerEvents *pObserver) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > |
UpdateColors() | CXTPPaintManager | virtual
UpdateFonts() | CXTPPaintManager | virtual
UpdateRTLCaption(CString &strCaption) | CXTPPaintManager | virtual
UseOfficeFont(bool bUseOfficeFont) | CXTPPaintManager |
VerticalLine(CDC *pDC, int x0, int y0, int y1, COLORREF clrPen) | CXTPPaintManager |
~CXTPCommandBarsModernUITheme() | CXTPCommandBarsModernUITheme | virtual
~CXTPCommandBarsNativeWindows11Theme() | CXTPCommandBarsNativeWindows11Theme | virtual
~CXTPCommandBarsOffice2013Theme() | CXTPCommandBarsOffice2013Theme | virtual
~CXTPObservable() | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | protected
~CXTPPaintManager() | CXTPPaintManager | protectedvirtual


Toolkit Pro: Member List

CXTPCalendarNativeWindows11Theme Member List

This is the complete list of members for CXTPCalendarNativeWindows11Theme, including all inherited members.

_GetAtGrow_BusyStatusBrushValue(int eBusyStatus, BOOL bGrow) | CXTPCalendarPaintManager | protected
_Init() | CXTPCalendarPaintManager | virtual
AddViewPart(CXTPCalendarViewPart *pPart) | CXTPCalendarPaintManager | protected
AdjustTimeFont(CDC *pDC, CRect rcCell) | CXTPCalendarPaintManager |
BEGIN_VIEW_PART(ControlPart, XTPCalendarViewPart) virtual void RefreshMetrics() | CXTPCalendarPaintManager |
CalcEventSize(CDC *c, CXTPCalendarTimeLineViewEvent *pViewEvent) | CXTPCalendarPaintManager | virtual
CalcWidth(CDC *pDC, const CString &strHour, const CString &strMin, int nHourHeight, int &nWidth) | CXTPCalendarPaintManager |
CXTPCalendarNativeWindows11Theme() | CXTPCalendarNativeWindows11Theme |
CXTPCalendarOffice2000Theme() | CXTPCalendarOffice2000Theme |
CXTPCalendarOffice2013Theme() | CXTPCalendarOffice2013Theme |
CXTPCalendarPaintManager() | CXTPCalendarPaintManager |
CXTPCmdTarget() | CXTPCmdTarget |
DrawBigHourCell(CDC *pDC, CRect rc, CString strHour, CString strMin, int nRowPerHour, BOOL bFillBackground=TRUE, BOOL bCurrentTime=FALSE) | CXTPCalendarPaintManager | virtual
DrawBitmap(CImageList *pImageList, CDC *pDC, CRect rcView, int iIcon, UINT uFlags=0) | CXTPCalendarPaintManager | virtual
DrawBitmap(UINT nIDResource, CDC *pDC, CRect rcBitmap) | CXTPCalendarPaintManager | virtual
DrawBorder(CDC *pDC, CRect rcView, CXTPCalendarWeekViewEvent *pWeekViewEvent) | CXTPCalendarPaintManager | virtual
DrawBusyStatus(CDC *pDC, CRect &rcRect, int eBusyStatus) | CXTPCalendarPaintManager | virtual
DrawBusyStatus(CDC *pDC, CRgn &rgnBusy, int eBusyStatus) | CXTPCalendarPaintManager | virtual
DrawClock(CDC *pDC, COleDateTime dtClockTime, CRect rcView, COLORREF clrBackground, XTPCalendarClockAlignFlags cafAlign) | CXTPCalendarPaintManager | virtual
DrawDayHeader(CDC *pDC, CRect rcDay, int nHeaderHeight, CString strHeader, BOOL bIsCurrent=FALSE, BOOL bIsSelected=FALSE) | CXTPCalendarPaintManager | virtual
DrawEvent(CDC *pDC, const CRect &rcEvents, CXTPCalendarTimeLineViewEvent *pViewEvent) | CXTPCalendarPaintManager | virtual
DrawExpandSigns(CDC *pDC, CXTPCalendarDayView *pView, const CRect &rcTSHours) | CXTPCalendarPaintManager | virtual
DrawGroup(CDC *pDC, const CRect &rcRect, CXTPCalendarTimeLineViewGroup *pGroup) | CXTPCalendarPaintManager | virtual
DrawHeader(CDC *pDC, CRect &rcHeader, BOOL bIsSelected, BOOL bIsCurrent, const CXTPPaintManagerColorGradient &grclr, COLORREF clrUnderLineHdr) | CXTPCalendarOffice2013Theme | virtual
CXTPCalendarOffice2000Theme::DrawHeader(CDC *pDC, CRect &rcHeader, BOOL bIsSelected, BOOL bIsCurrent) | CXTPCalendarPaintManager | virtual
DrawHorizontalLine(CDC *pDC, int xPos, int yPos, int cx) | CXTPCalendarPaintManager | virtual
DrawHourCell(CDC *pDC, CRect rc, CString strText, BOOL bFillBackground=TRUE, BOOL bCurrentTime=FALSE) | CXTPCalendarPaintManager | virtual
DrawIconChar(CDC *pDC, CRect rc, TCHAR ch) | CXTPCalendarPaintManager | virtual
DrawIcons(CDC *pDC, CXTPCalendarViewEvent *pViewEvent) | CXTPCalendarPaintManager | virtual
DrawLine(CDC *pDC, int xPos, int yPos, int cx, int cy) | CXTPCalendarPaintManager | virtual
DrawNowLine(CDC *pDC, CXTPCalendarDayView *pView, CRect rc, int y, BOOL bDrawBk=FALSE) | CXTPCalendarPaintManager | virtual
DrawNowLine(CDC *pDC, CXTPCalendarDayView *pView, CXTPCalendarDayViewTimeScale *pScale, CRect rc, int y, BOOL bDrawBk=FALSE) | CXTPCalendarPaintManager | virtual
DrawShadow(CDC *pDC, const CRect &rcRect) | CXTPCalendarPaintManager | virtual
DrawSubj(CDC *pDC, CXTPCalendarWeekViewEvent *pWeekViewEvent) | CXTPCalendarPaintManager | virtual
DrawTimes(CDC *pDC, CXTPCalendarWeekViewEvent *pWeekViewEvent) | CXTPCalendarPaintManager | virtual
DrawVerticalLine(CDC *pDC, int xPos, int yPos, int cy) | CXTPCalendarPaintManager | virtual
EnableTheme(BOOL bEnableTheme) | CXTPCalendarPaintManager |
END_VIEW_PART(ControlPart) BEGIN_VIEW_PART(DayViewTimeScaleHeaderPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewTimeScaleHeaderPart) BEGIN_VIEW_PART(DayViewTimeScaleCellPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewTimeScaleCellPart) BEGIN_VIEW_PART(DayViewCellPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewCellPart) BEGIN_VIEW_PART(DayViewWorkCellPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewWorkCellPart) BEGIN_VIEW_PART(DayViewNonworkCellPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewNonworkCellPart) BEGIN_VIEW_PART(DayMonthViewHeaderPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayMonthViewHeaderPart) BEGIN_VIEW_PART(DayViewHeaderPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewHeaderPart) BEGIN_VIEW_PART(DayViewGroupHeaderPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewGroupHeaderPart) BEGIN_VIEW_PART(DayViewAllDayEventsPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewAllDayEventsPart) BEGIN_VIEW_PART(DayViewAllDayEventScrollIconsPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewAllDayEventScrollIconsPart) BEGIN_VIEW_PART(DayViewEventPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewEventPart) BEGIN_VIEW_PART(MonthViewGridPart | CXTPCalendarPaintManager |
END_VIEW_PART(MonthViewGridPart) BEGIN_VIEW_PART(MonthViewHeaderPart | CXTPCalendarPaintManager |
END_VIEW_PART(MonthViewHeaderPart) BEGIN_VIEW_PART(MonthViewEventPart | CXTPCalendarPaintManager |
END_VIEW_PART(MonthViewEventPart) BEGIN_VIEW_PART(WeekViewPart | CXTPCalendarPaintManager |
END_VIEW_PART(WeekViewPart) BEGIN_VIEW_PART(WeekViewEventPart | CXTPCalendarPaintManager |
END_VIEW_PART(WeekViewEventPart) BEGIN_VIEW_PART(TimeLineViewTimeScalePart_Day | CXTPCalendarPaintManager |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAskItemTextFlags() const | CXTPCalendarPaintManager |
GetBusyStatusBrush(int nBusyStatus) | CXTPCalendarPaintManager |
GetClockSize() | CXTPCalendarPaintManager | virtual
GetCurrentSystemTheme() | CXTPCalendarPaintManager |
GetEventBackColor(CXTPCalendarEvent *pEvent) | CXTPCalendarOffice2013Theme | virtual
CXTPCalendarOffice2000Theme::GetEventBackColor(CXTPCalendarEvent *pEvent, COLORREF crDefault) | CXTPCalendarPaintManager | virtual
GetEventEdgeColor(CXTPCalendarEvent *pEvent) | CXTPCalendarOffice2013Theme | virtual
GetExpandSignSize() | CXTPCalendarPaintManager | virtual
GetPaintTheme() const | CXTPCalendarPaintManager | virtual
GetParams(CXTPCalendarDayViewGroup *pViewGroup, XTP_CALENDAR_DAYVIEWCELL_PARAMS *rCellParams) | CXTPCalendarPaintManager | virtual
idxExpandSignDown enum value | CXTPCalendarPaintManager | protected
idxExpandSignUp enum value | CXTPCalendarPaintManager | protected
idxMeeting enum value | CXTPCalendarPaintManager | protected
idxPrivate enum value | CXTPCalendarPaintManager | protected
idxRecurrenceException enum value | CXTPCalendarPaintManager | protected
idxRecurrenceOccurrence enum value | CXTPCalendarPaintManager | protected
idxReminder enum value | CXTPCalendarPaintManager | protected
InitBusyStatusDefaultColors() | CXTPCalendarPaintManager | protectedvirtual
IsThemeEnabled() | CXTPCalendarPaintManager |
m_arBusyStatusBrushes | CXTPCalendarPaintManager | protected
m_arStartCol | CXTPCalendarPaintManager |
m_arStartRow | CXTPCalendarPaintManager |
m_bEnableTheme | CXTPCalendarPaintManager | protected
m_bmpElsewherePattern | CXTPCalendarPaintManager | protected
m_bmpTentativePattern | CXTPCalendarPaintManager | protected
m_bShowMinutes | CXTPCalendarPaintManager |
m_clr3DShadow | CXTPCalendarPaintManager |
m_clrBackground | CXTPCalendarPaintManager |
m_clrBackground2 | CXTPCalendarPaintManager |
m_clrBackgroundSlave | CXTPCalendarPaintManager |
m_clrBorders | CXTPCalendarPaintManager |
m_clrButtonFace | CXTPCalendarPaintManager |
m_clrButtonFaceText | CXTPCalendarPaintManager |
m_clrClassicUnderline | CXTPCalendarPaintManager |
m_clrEventBar | CXTPCalendarPaintManager |
m_clrEventBarLine | CXTPCalendarPaintManager |
m_clrEventBorderLine | CXTPCalendarPaintManager |
m_clrHeaderBottomLine | CXTPCalendarPaintManager |
m_clrHighlight | CXTPCalendarPaintManager |
m_clrHour | CXTPCalendarPaintManager |
m_clrSelectedBackground | CXTPCalendarPaintManager |
m_clrSelectedText | CXTPCalendarPaintManager |
m_clrShadow | CXTPCalendarPaintManager |
m_clrText | CXTPCalendarPaintManager |
m_clrTextHighLightColor | CXTPCalendarPaintManager |
m_clrTextNormalColor | CXTPCalendarPaintManager |
m_clrTimeScaleBackground | CXTPCalendarPaintManager |
m_clrTimeScaleHightlite | CXTPCalendarPaintManager |
m_clrTimeScaleText | CXTPCalendarPaintManager |
m_clrUnderLineHdr | CXTPCalendarPaintManager | protected
m_clrWeekendBackground | CXTPCalendarPaintManager |
m_clrWindow | CXTPCalendarPaintManager |
m_clrWindowText | CXTPCalendarPaintManager |
m_CurrSystemTheme | CXTPCalendarPaintManager | protected
m_dwAskItemTextFlags | CXTPCalendarPaintManager | protected
m_fntTimeText | CXTPCalendarPaintManager |
m_grclrClassicSelDay | CXTPCalendarPaintManager |
m_grclrToday | CXTPCalendarPaintManager |
m_lstViewParts | CXTPCalendarPaintManager | protected
m_nHourWidth | CXTPCalendarPaintManager |
m_nMinWidth | CXTPCalendarPaintManager |
m_nPaintTheme | CXTPCalendarPaintManager | protected
m_pControl | CXTPCalendarPaintManager | protected
m_pExpandSigns | CXTPCalendarPaintManager | protected
m_pGlyphs | CXTPCalendarPaintManager | protected
m_pGlyphsFont | CXTPCalendarPaintManager | protected
m_PrintPageWidth | CXTPCalendarPaintManager |
m_szClockRect | CXTPCalendarPaintManager | protected
m_xtpBrushElsewhere | CXTPCalendarPaintManager | protected
m_xtpBrushTentative | CXTPCalendarPaintManager | protected
OnDraw(CDC *pDC, CXTPCalendarDayView *pView, CRect rc, CString strText) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarDayViewGroup *pViewGroup, CRect rc, const XTP_CALENDAR_DAYVIEWCELL_PARAMS &cellParams) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarDayViewDay *pViewDay, CRect rc, CString strText) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarDayViewGroup *pViewGroup, CRect rc, CString strText) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarDayViewGroup *pViewGroup, CRect rc, BOOL bSelected) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarDayViewGroup *pViewGroup, BOOL bDrawUp, BOOL bDrawDown, const CRect &rcIconUp, const CRect &rcIconDown, BOOL bHighlightUp, BOOL bHighlightDown) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarDayViewEvent *pViewEvent) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarMonthView *pMonthView, CRect rc, int nCollIndex, CString strText) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarWeekView *pWeekView) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarWeekViewEvent *pWeekViewEvent) | CXTPCalendarPaintManager | virtual
OnDrawDayDate(CDC *pDC, CRect rc, BOOL bToday, BOOL bSelected, BOOL bFirstMonthDay, CString strText) | CXTPCalendarPaintManager | virtual
OnDrawEvent(CDC *pDC, CXTPCalendarMonthViewEvent *pViewEvent) | CXTPCalendarPaintManager | virtual
OnDrawGrid(CDC *pDC, CXTPCalendarMonthView *pMonthView) | CXTPCalendarPaintManager | virtual
RefreshMetrics() | CXTPCalendarOffice2013Theme | virtual
SetAskItemTextFlags(DWORD dwFlags) | CXTPCalendarPaintManager |
SetBusyStatusBrush(int nBusyStatus, CBrush *pBrush, BOOL bAutodeleteBrush) | CXTPCalendarPaintManager |
SetControl(CXTPCalendarControl *pControl) | CXTPCalendarPaintManager | virtual
SetPaintTheme(XTPCalendarTheme ePaintTheme) | CXTPCalendarPaintManager | virtual
UpdateEventCategoriesDefaultColors() | CXTPCalendarOffice2013Theme | virtual
UpdateEventLabelsDefaultColors() | CXTPCalendarOffice2013Theme | virtual
UpdateGlyphs() | CXTPCalendarOffice2013Theme | virtual
XTPEnumEventGlyphs enum name | CXTPCalendarPaintManager | protected
XTPEnumExpandSigns enum name | CXTPCalendarPaintManager | protected
~CTimeLineViewPart() | CXTPCalendarPaintManager | virtual
~CXTPCalendarNativeWindows11Theme() | CXTPCalendarNativeWindows11Theme | virtual
~CXTPCalendarOffice2000Theme() | CXTPCalendarOffice2000Theme | virtual
~CXTPCalendarOffice2013Theme() | CXTPCalendarOffice2013Theme | virtual
~CXTPCalendarPaintManager() | CXTPCalendarPaintManager | virtual


Toolkit Pro: XTPChartRadarSplineSeriesStyle.h Source File

  • Source
  • Chart
  • Styles
  • Radar
XTPChartRadarSplineSeriesStyle.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTRADARSPLINESERIESSTYLE_H__)
24# define __XTPCHARTRADARSPLINESERIESSTYLE_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartSeriesView;
34class CXTPChartLineStyle;
35
41class _XTP_EXT_CLASS CXTPChartRadarSplineSeriesStyle : public CXTPChartRadarLineSeriesStyle
42{
44 DECLARE_SERIAL(CXTPChartRadarSplineSeriesStyle)
46public:
51 CXTPChartRadarSplineSeriesStyle();
52
57 virtual ~CXTPChartRadarSplineSeriesStyle();
58
59public:
60protected:
71 virtual CXTPChartSeriesView* CreateView(CXTPChartSeries* pSeries,
72 CXTPChartDiagramView* pDiagramView);
73
74protected:
75# ifdef _XTP_ACTIVEX
76public:
78 DECLARE_DISPATCH_MAP()
79 DECLARE_INTERFACE_MAP()
80 DECLARE_OLETYPELIB_EX(CXTPChartRadarSplineSeriesStyle);
81 DECLARE_OLECREATE_EX(CXTPChartRadarSplineSeriesStyle)
83# endif
84
85protected:
86};
87
93class _XTP_EXT_CLASS CXTPChartRadarSplineSeriesView : public CXTPChartRadarLineSeriesView
94{
95public:
103 CXTPChartRadarSplineSeriesView(CXTPChartSeries* pSeries, CXTPChartDiagramView* pDiagramView);
104
105protected:
117 CXTPChartSeriesPointView* CreateSeriesPointView(CXTPChartDeviceContext* pDC,
118 CXTPChartSeriesPoint* pPoint,
119 CXTPChartElementView* pParentView);
120
133 virtual CXTPChartDeviceCommand* CreateDeviceCommand(CXTPChartDeviceContext* pDC);
134};
136# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
137#endif //#if !defined(__XTPCHARTRADARSPLINESERIESSTYLE_H__)
pPoint
const CPoint * pPoint
return 0 or xtpCalendarHitTestDayExpandButton
Definition XTPCalendarThemeOffice2007.h:150
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartDiagramView
This class represents the view of a chart diagram, which is a kind of CXTPChartElementView.
Definition XTPChartDiagramView.h:49
CXTPChartElementView
This class represents the view of a chart element.
Definition XTPChartElementView.h:47
CXTPChartLineStyle
This class represents a chart line style, which is a kind of CXTPCmdTarget.
Definition XTPChartLineStyle.h:43
CXTPChartRadarLineSeriesStyle
This class represents a line series style, which is a kind of CXTPChartSeriesStyle.
Definition XTPChartRadarLineSeriesStyle.h:47
CXTPChartRadarLineSeriesView
This class represents the view of a point series, which is a kind of CXTPChartSeriesView.
Definition XTPChartRadarLineSeriesView.h:42
CXTPChartRadarSplineSeriesStyle
This class represents the spline series style in the chart.
Definition XTPChartRadarSplineSeriesStyle.h:42
CXTPChartRadarSplineSeriesStyle::CXTPChartRadarSplineSeriesStyle
CXTPChartRadarSplineSeriesStyle()
Constructs a CXTPChartRadarSplineSeriesStyle object.
CXTPChartRadarSplineSeriesStyle::CreateView
virtual CXTPChartSeriesView * CreateView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Call this function to create a view of the spline series.
CXTPChartRadarSplineSeriesStyle::~CXTPChartRadarSplineSeriesStyle
virtual ~CXTPChartRadarSplineSeriesStyle()
Destroys a CXTPChartRadarSplineSeriesStyle object, handles cleanup.
CXTPChartRadarSplineSeriesView
This class represents the view of a spline series, which is a kind of CXTPChartSeriesView.
Definition XTPChartRadarSplineSeriesStyle.h:94
CXTPChartRadarSplineSeriesView::CXTPChartRadarSplineSeriesView
CXTPChartRadarSplineSeriesView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Constructs a CXTPChartRadarSplineSeriesView object.
CXTPChartRadarSplineSeriesView::CreateDeviceCommand
virtual CXTPChartDeviceCommand * CreateDeviceCommand(CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
CXTPChartRadarSplineSeriesView::CreateSeriesPointView
CXTPChartSeriesPointView * CreateSeriesPointView(CXTPChartDeviceContext *pDC, CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Call this function to create a view of the spline series point.
CXTPChartSeries
This class represents a series in the chart, which is a kind of CXTPChartElement.
Definition XTPChartSeries.h:50
CXTPChartSeriesPoint
CXTPChartSeriesPoint is a kind of CXTPChartElement.
Definition XTPChartSeriesPoint.h:43
CXTPChartSeriesPointView
Represents chart series point view.
Definition XTPChartSeriesPointView.h:48


Toolkit Pro: XTPFlowGraphPaintManager.h Source File

  • Source
  • FlowGraph
XTPFlowGraphPaintManager.h
Go to the documentation of this file.
1
23#if !defined(__XTPFLOWGRAPHPAINTMANAGER_H__)
24# define __XTPFLOWGRAPHPAINTMANAGER_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPFlowGraphControl;
34class CXTPFlowGraphDrawContext;
35class CXTPFlowGraphNode;
36class CXTPFlowGraphConnectionPoint;
37class CXTPFlowGraphConnection;
38class CXTPFlowGraphNodeGroup;
39class CXTPFlowGraphElement;
40
41namespace Gdiplus
42{
43class Font;
44}
45
55enum XTPFlowGraphConnectorType
56{
57 xtpFlowGraphConnectorStraight = 0,
58 xtpFlowGraphConnectorStraightArrow = 1,
59 xtpFlowGraphConnectorStraightDoubleArrow = 3,
60 xtpFlowGraphConnectorCurved = 4,
61 xtpFlowGraphConnectorCurvedArrow = 5,
62 xtpFlowGraphConnectorCurvedDoubleArrow = 7,
63 xtpFlowGraphConnectorElbow = 8,
64 xtpFlowGraphConnectorElbowArrow = 9,
65 xtpFlowGraphConnectorElbowDoubleArrow = 11
66};
67
68# define IsStraightConnection(type) ((type >> 2) == 0)
69# define IsCurvedConnection(type) ((type & 4))
70# define IsElbowConnection(type) ((type & 8))
71
72# define HasStartingArrow(type) ((type & 2))
73# define HasEndingArrow(type) ((type & 1))
74
79class _XTP_EXT_CLASS CXTPFlowGraphPaintManager : public CXTPCmdTarget
80{
81public:
86 CXTPFlowGraphPaintManager();
92 virtual ~CXTPFlowGraphPaintManager();
93
94protected:
95 BOOL CalculateConnectionPointsPositions(CXTPFlowGraphConnection* pConnection, CPoint& p1,
96 CPoint& p2);
97
98public:
107 virtual void DrawControlBackground(CXTPFlowGraphDrawContext* pDC,
108 CXTPFlowGraphControl* pControl, BOOL bPrintToFile = FALSE,
109 const CRect& drawRect = CRect(0, 0, 0, 0));
110
115 virtual void RefreshMetrics();
116
126 virtual void RecalcConnectionLayout(CXTPFlowGraphDrawContext* pDC,
127 CXTPFlowGraphConnection* pConnection);
128
136 virtual void DrawConnection(CXTPFlowGraphDrawContext* pDC,
137 CXTPFlowGraphConnection* pConnection);
138
147 virtual CRect GetNodeBoundingRectangle(CXTPFlowGraphNode* pNode);
148
157 void DrawTransparentRectangle(CXTPFlowGraphDrawContext* pDC, CRect rect, COLORREF clrColor);
158
166 virtual void DrawNodeGroup(CXTPFlowGraphDrawContext* pDC, CXTPFlowGraphNodeGroup* pNodeGroup);
167
177 virtual BOOL HitTestConnectionArea(const CXTPFlowGraphConnectionPoint* pPoint, CPoint point);
178
187 virtual CRect GetCaptionRect(CXTPFlowGraphElement* pNode);
188
194 virtual void Cleanup();
195
207 static COLORREF AFX_CDECL GetDarkColor(COLORREF clrBackground);
208
209public:
210 COLORREF m_clrBackground;
211 COLORREF m_clrSelection;
213 COLORREF m_clrSelectionInactive;
215 COLORREF m_clrTextColor;
216 COLORREF m_clrTextColorSelected;
219 COLORREF m_clrGridColor;
221 COLORREF m_clrNodeBackground;
223 LOGFONT m_lfText;
224 LOGFONT m_lfCaption;
226 int m_nNodeFrameSize;
227 int m_nPointTextMargin;
230 COLORREF m_clrConnection;
232 int m_nEllipseSize;
233 BOOL m_bShowGrid;
235 BOOL m_bShowNodeGroupsAlways;
237 BOOL m_bAlwaysDrawConnectionPoints;
239 BOOL m_bRecalcConnectionLayoutWhenNeeded;
242 BOOL m_bChangeNodeColorWhenSelected;
246 XTPFlowGraphConnectorType m_nConnectorType;
248 double m_dMinZoomLevelBackground;
252 double m_dMinZoomLevelConnectionPoints;
256 double m_dMinZoomLevelConnections;
260 double m_dMinZoomLevelGDIQuality;
265protected:
266# ifdef _XTP_ACTIVEX
269 DECLARE_DISPATCH_MAP()
270 DECLARE_INTERFACE_MAP()
271
272 DECLARE_OLETYPELIB_EX(CXTPFlowGraphPaintManager)
273
274 afx_msg void OleSetFont(LPFONTDISP pFontDisp);
275 afx_msg LPFONTDISP OleGetFont();
276 afx_msg void OleSetCaptionFont(LPFONTDISP pFontDisp);
277 afx_msg LPFONTDISP OleGetCaptionFont();
278
280# endif
281};
283# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
284#endif //#if !defined(__XTPFLOWGRAPHPAINTMANAGER_H__)
pPoint
const CPoint * pPoint
return 0 or xtpCalendarHitTestDayExpandButton
Definition XTPCalendarThemeOffice2007.h:150
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPFlowGraphConnectorType
XTPFlowGraphConnectorType
Node connector styles.
Definition XTPFlowGraphPaintManager.h:56
xtpFlowGraphConnectorCurvedArrow
@ xtpFlowGraphConnectorCurvedArrow
00000101
Definition XTPFlowGraphPaintManager.h:61
xtpFlowGraphConnectorCurved
@ xtpFlowGraphConnectorCurved
00000100
Definition XTPFlowGraphPaintManager.h:60
xtpFlowGraphConnectorElbow
@ xtpFlowGraphConnectorElbow
00001000
Definition XTPFlowGraphPaintManager.h:63
xtpFlowGraphConnectorElbowDoubleArrow
@ xtpFlowGraphConnectorElbowDoubleArrow
00001011
Definition XTPFlowGraphPaintManager.h:65
xtpFlowGraphConnectorStraight
@ xtpFlowGraphConnectorStraight
00000000
Definition XTPFlowGraphPaintManager.h:57
xtpFlowGraphConnectorCurvedDoubleArrow
@ xtpFlowGraphConnectorCurvedDoubleArrow
00000111
Definition XTPFlowGraphPaintManager.h:62
xtpFlowGraphConnectorElbowArrow
@ xtpFlowGraphConnectorElbowArrow
00001001
Definition XTPFlowGraphPaintManager.h:64
xtpFlowGraphConnectorStraightDoubleArrow
@ xtpFlowGraphConnectorStraightDoubleArrow
00000011
Definition XTPFlowGraphPaintManager.h:59
xtpFlowGraphConnectorStraightArrow
@ xtpFlowGraphConnectorStraightArrow
00000001
Definition XTPFlowGraphPaintManager.h:58
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPFlowGraphConnection
Represents a connection.
Definition XTPFlowGraphConnection.h:49
CXTPFlowGraphConnectionPoint
Represents a connection point for a node.
Definition XTPFlowGraphConnectionPoint.h:46
CXTPFlowGraphControl
Flow Graph Control.
Definition XTPFlowGraphControl.h:173
CXTPFlowGraphElement
Base class for all elements in the flow graph.
Definition XTPFlowGraphElement.h:46
CXTPFlowGraphNodeGroup
Represents a group of Nodes.
Definition XTPFlowGraphNodeGroup.h:47
CXTPFlowGraphNode
Represents a Node object.
Definition XTPFlowGraphNode.h:116
CXTPFlowGraphPaintManager
Handles most of the drawing activities of the flow graph.
Definition XTPFlowGraphPaintManager.h:80
CXTPFlowGraphPaintManager::m_bChangeNodeColorWhenSelected
BOOL m_bChangeNodeColorWhenSelected
TRUE by default.
Definition XTPFlowGraphPaintManager.h:242
CXTPFlowGraphPaintManager::m_nEllipseSize
int m_nEllipseSize
Specifies the size of connection points.
Definition XTPFlowGraphPaintManager.h:232
CXTPFlowGraphPaintManager::m_dMinZoomLevelConnectionPoints
double m_dMinZoomLevelConnectionPoints
Specifies the minimum zoom level to stop drawing connection points in the flow graph.
Definition XTPFlowGraphPaintManager.h:252
CXTPFlowGraphPaintManager::RecalcConnectionLayout
virtual void RecalcConnectionLayout(CXTPFlowGraphDrawContext *pDC, CXTPFlowGraphConnection *pConnection)
Recalculates the layout of the connection.
CXTPFlowGraphPaintManager::m_clrConnection
COLORREF m_clrConnection
Specifies the color of the connection lines that connect connection points.
Definition XTPFlowGraphPaintManager.h:230
CXTPFlowGraphPaintManager::m_bRecalcConnectionLayoutWhenNeeded
BOOL m_bRecalcConnectionLayoutWhenNeeded
Recalculates the end points of a connection its selected state changes.
Definition XTPFlowGraphPaintManager.h:239
CXTPFlowGraphPaintManager::m_lfCaption
LOGFONT m_lfCaption
Gets/sets the font used for Node captions.
Definition XTPFlowGraphPaintManager.h:224
CXTPFlowGraphPaintManager::Cleanup
virtual void Cleanup()
Cleans up allocated resources used by the paint manager that have been allocated during draw routines...
CXTPFlowGraphPaintManager::m_dMinZoomLevelGDIQuality
double m_dMinZoomLevelGDIQuality
Specifies the minimum zoom level to stop using GDI quality when drawing elements in the flow graph.
Definition XTPFlowGraphPaintManager.h:260
CXTPFlowGraphPaintManager::m_bAlwaysDrawConnectionPoints
BOOL m_bAlwaysDrawConnectionPoints
Specifies whether to draw connection points always draw only on active Nodes.
Definition XTPFlowGraphPaintManager.h:237
CXTPFlowGraphPaintManager::CXTPFlowGraphPaintManager
CXTPFlowGraphPaintManager()
Constructs a CXTPFlowGraphPaintManager object.
CXTPFlowGraphPaintManager::m_clrGridColor
COLORREF m_clrGridColor
Specifies the color used for grid lines.
Definition XTPFlowGraphPaintManager.h:219
CXTPFlowGraphPaintManager::m_dMinZoomLevelConnections
double m_dMinZoomLevelConnections
Specifies the minimum zoom level to stop drawing connections in the flow graph.
Definition XTPFlowGraphPaintManager.h:256
CXTPFlowGraphPaintManager::m_dMinZoomLevelBackground
double m_dMinZoomLevelBackground
Specifies the minimum zoom level to stop drawing the background of the flow graph.
Definition XTPFlowGraphPaintManager.h:248
CXTPFlowGraphPaintManager::m_clrTextColor
COLORREF m_clrTextColor
Specifies the color used for text.
Definition XTPFlowGraphPaintManager.h:215
CXTPFlowGraphPaintManager::m_bShowNodeGroupsAlways
BOOL m_bShowNodeGroupsAlways
Specifies whether to always show Node groups, even if a non-grouped Node is selected (or if no Nodes ...
Definition XTPFlowGraphPaintManager.h:235
CXTPFlowGraphPaintManager::DrawTransparentRectangle
void DrawTransparentRectangle(CXTPFlowGraphDrawContext *pDC, CRect rect, COLORREF clrColor)
This method is called to draw a transparent rectangle on the graph control.
CXTPFlowGraphPaintManager::m_nConnectorType
XTPFlowGraphConnectorType m_nConnectorType
Node connector style.
Definition XTPFlowGraphPaintManager.h:246
CXTPFlowGraphPaintManager::GetDarkColor
static COLORREF AFX_CDECL GetDarkColor(COLORREF clrBackground)
Creates and retrieves a darker color of a specified color.
CXTPFlowGraphPaintManager::m_nNodeFrameSize
int m_nNodeFrameSize
Gets/sets the size of the border-frame of a Node.
Definition XTPFlowGraphPaintManager.h:226
CXTPFlowGraphPaintManager::DrawConnection
virtual void DrawConnection(CXTPFlowGraphDrawContext *pDC, CXTPFlowGraphConnection *pConnection)
This method is called to draw a single connection in the flow graph control.
CXTPFlowGraphPaintManager::m_bShowGrid
BOOL m_bShowGrid
Specifies whether to show the grid for the flow graph.
Definition XTPFlowGraphPaintManager.h:233
CXTPFlowGraphPaintManager::m_clrNodeBackground
COLORREF m_clrNodeBackground
Gets/sets the background color used for Nodes.
Definition XTPFlowGraphPaintManager.h:221
CXTPFlowGraphPaintManager::m_clrSelection
COLORREF m_clrSelection
Specifies the color used for selected Node's connection points' rectangles.
Definition XTPFlowGraphPaintManager.h:211
CXTPFlowGraphPaintManager::m_lfText
LOGFONT m_lfText
Gets/sets the font used for connection captions.
Definition XTPFlowGraphPaintManager.h:223
CXTPFlowGraphPaintManager::m_nPointTextMargin
int m_nPointTextMargin
Specifies the margin to place between a connection's caption text and the connection's connection poi...
Definition XTPFlowGraphPaintManager.h:227
CXTPFlowGraphPaintManager::m_clrSelectionInactive
COLORREF m_clrSelectionInactive
Specifies the color used for selected Node's (inactive).
Definition XTPFlowGraphPaintManager.h:213
CXTPFlowGraphPaintManager::m_clrTextColorSelected
COLORREF m_clrTextColorSelected
Specifies the color used for text when a Node is selected.
Definition XTPFlowGraphPaintManager.h:216
CXTPFlowGraphPaintManager::m_clrBackground
COLORREF m_clrBackground
Specifies the background "canvas" color for the flow graph.
Definition XTPFlowGraphPaintManager.h:210
CXTPFlowGraphPaintManager::~CXTPFlowGraphPaintManager
virtual ~CXTPFlowGraphPaintManager()
Destroys a CXTPFlowGraphPaintManager object, handles cleanup and deallocation.
CXTPFlowGraphPaintManager::DrawNodeGroup
virtual void DrawNodeGroup(CXTPFlowGraphDrawContext *pDC, CXTPFlowGraphNodeGroup *pNodeGroup)
This method is called to draw a single Node group in the flow graph control.
CXTPFlowGraphPaintManager::HitTestConnectionArea
virtual BOOL HitTestConnectionArea(const CXTPFlowGraphConnectionPoint *pPoint, CPoint point)
Determines if the specified point is within the connection area.
CXTPFlowGraphPaintManager::DrawControlBackground
virtual void DrawControlBackground(CXTPFlowGraphDrawContext *pDC, CXTPFlowGraphControl *pControl, BOOL bPrintToFile=FALSE, const CRect &drawRect=CRect(0, 0, 0, 0))
Draws the background for the flow graph control.
CXTPFlowGraphPaintManager::GetNodeBoundingRectangle
virtual CRect GetNodeBoundingRectangle(CXTPFlowGraphNode *pNode)
Retrieves the bounding rectangle for the specified Node.
CXTPFlowGraphPaintManager::RefreshMetrics
virtual void RefreshMetrics()
This method is called to refresh the visual metrics of the flow graph.
CXTPFlowGraphPaintManager::GetCaptionRect
virtual CRect GetCaptionRect(CXTPFlowGraphElement *pNode)
Retrieves the bounding rectangle for the caption of the specified Node.


Toolkit Pro: XTPMarkupDefinitionBase.h Source File

  • Source
  • Markup
  • Controls
XTPMarkupDefinitionBase.h
Go to the documentation of this file.
1
23#if !defined(__XTPMARKUPDEFINITIONBASE_H__)
24# define __XTPMARKUPDEFINITIONBASE_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPMarkupGrid;
34class CXTPMarkupObject;
35class CXTPMarkupPropertyChangedEventArgs;
36class CXTPMarkupGridLength;
37
44class _XTP_EXT_CLASS CXTPMarkupDefinitionBase : public CXTPMarkupFrameworkContentElement
45{
47 DECLARE_MARKUPCLASS(CXTPMarkupDefinitionBase);
49protected:
56 CXTPMarkupDefinitionBase(BOOL bIsColumnDefinition = FALSE);
57
58public:
65 int GetUserMinSize() const;
66
73 int GetUserMaxSize() const;
74
81 CXTPMarkupGridLength* GetUserSize() const;
82
84 // Implementation
85private:
86 void OnBeforeLayout();
87 void UpdateMinSize(int nMinSize);
88 double GetPreferredSize() const;
89
90protected:
91 static void AFX_CDECL OnDefinitionPropertyChanged(CXTPMarkupObject* d,
92 CXTPMarkupPropertyChangedEventArgs* /*e*/);
93
94protected:
95 BOOL m_bIsColumnDefinition;
96 int m_nMinSize;
97 int m_nSizeType;
98 double m_nMeasureSize;
99 double m_nSizeCache;
100 int m_nFinalOffset;
101
102 friend class CXTPMarkupGrid;
106public:
107 DECLARE_DISPATCH_MAP()
108# ifdef _XTP_ACTIVEX
109 DECLARE_INTERFACE_MAP()
110 DECLARE_OLETYPELIB_EX(CXTPMarkupDefinitionBase);
111# endif
112
114};
115
116# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
118#endif // !defined(__XTPMARKUPDEFINITIONBASE_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPMarkupDefinitionBase
CXTPMarkupDefinitionBase is the base class for CXTPMarkupColumnDefinition and CXTPMarkupRowDefinition...
Definition XTPMarkupDefinitionBase.h:45
CXTPMarkupDefinitionBase::GetUserMaxSize
int GetUserMaxSize() const
Retrieves the maximum constraint for user-defined column or row size.
CXTPMarkupDefinitionBase::CXTPMarkupDefinitionBase
CXTPMarkupDefinitionBase(BOOL bIsColumnDefinition=FALSE)
Constructs a CXTPMarkupDefinitionBase object.
CXTPMarkupDefinitionBase::GetUserMinSize
int GetUserMinSize() const
Retrieves the minimum constraint for user-defined column or row size.
CXTPMarkupDefinitionBase::GetUserSize
CXTPMarkupGridLength * GetUserSize() const
Retrieves the user-defined column or row size.
CXTPMarkupGrid
CXTPMarkupGrid is a CXTPMarkupPanel derived class.
Definition XTPMarkupGrid.h:89
CXTPMarkupGridLength
CXTPMarkupGridLength is a class defined length of grid rows and columns.
Definition XTPMarkupGridLength.h:41


Toolkit Pro: Member List

CXTPShortcutBarPaintManager Member List

This is the complete list of members for CXTPShortcutBarPaintManager, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPShortcutBarPaintManager() | CXTPShortcutBarPaintManager |
DrawExpandButton(CDC *pDC, CRect rc) | CXTPShortcutBarPaintManager | virtual
DrawGripper(CDC *pDC, CXTPShortcutBar *pShortcutBar, BOOL bDraw)=0 | CXTPShortcutBarPaintManager | pure virtual
DrawImage(CDC *pDC, CPoint pt, CSize sz, CXTPImageManagerIcon *pImage, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled)=0 | CXTPShortcutBarPaintManager | pure virtual
DrawNavigationItem(CDC *pDC, CXTPShortcutBarItem *pItem) | CXTPShortcutBarPaintManager | virtual
DrawPaneCaption(CDC *pDC, CXTPShortcutBarPane *pPane, BOOL bDraw) | CXTPShortcutBarPaintManager | virtual
DrawPaneItemCaption(CDC *pDC, CXTPShortcutBarPaneItem *pItem, BOOL bDraw) | CXTPShortcutBarPaintManager | virtual
DrawShortcutBarFrame(CDC *pDC, CXTPShortcutBar *pShortcutBar)=0 | CXTPShortcutBarPaintManager | pure virtual
DrawShortcutItem(CDC *pDC, CXTPShortcutBarItem *pItem) | CXTPShortcutBarPaintManager | virtual
FillNavigationItemEntry(CDC *pDC, CXTPShortcutBarItem *pItem) | CXTPShortcutBarPaintManager | virtual
FillShortcutBar(CDC *pDC, CXTPShortcutBar *pShortcutBar)=0 | CXTPShortcutBarPaintManager | pure virtual
FillShortcutItemEntry(CDC *pDC, CXTPShortcutBarItem *pItem)=0 | CXTPShortcutBarPaintManager | pure virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
IsShortcutItemTruncated(CDC *pDC, CXTPShortcutBarItem *pItem) | CXTPShortcutBarPaintManager |
Line(CDC *pDC, int x0, int y0, int x1, int y1, int nPen) | CXTPShortcutBarPaintManager |
m_bBoldItemCaptionFont | CXTPShortcutBarPaintManager |
m_bClearTypeTextQuality | CXTPShortcutBarPaintManager |
m_bNavigationButton | CXTPShortcutBarPaintManager |
m_bUseStandardFont | CXTPShortcutBarPaintManager |
m_clrDisabledText | CXTPShortcutBarPaintManager |
m_clrHotText | CXTPShortcutBarPaintManager |
m_clrNormalText | CXTPShortcutBarPaintManager |
m_clrPushedText | CXTPShortcutBarPaintManager |
m_clrSelectedText | CXTPShortcutBarPaintManager |
m_clrShortcutItemShadow | CXTPShortcutBarPaintManager |
m_grcHot | CXTPShortcutBarPaintManager |
m_grcPushed | CXTPShortcutBarPaintManager |
m_grcSelected | CXTPShortcutBarPaintManager |
m_grcShortcutBarGripper | CXTPShortcutBarPaintManager |
m_grcShortcutItem | CXTPShortcutBarPaintManager |
m_nExpandedIconWidth | CXTPShortcutBarPaintManager |
m_nNormalIconWidth | CXTPShortcutBarPaintManager |
m_nPaneItemHeight | CXTPShortcutBarPaintManager |
m_pExpandIcon | CXTPShortcutBarPaintManager |
m_rcCaptionPadding | CXTPShortcutBarPaintManager |
m_rcItemCaptionPadding | CXTPShortcutBarPaintManager |
m_strOfficeFont | CXTPShortcutBarPaintManager |
m_xtpFontPaneCaption | CXTPShortcutBarPaintManager |
m_xtpFontPaneItemCaption | CXTPShortcutBarPaintManager |
m_xtpFontText | CXTPShortcutBarPaintManager |
m_xtpFontVerticalText | CXTPShortcutBarPaintManager |
Rectangle(CDC *pDC, CRect rc, int nPen, int nBrush) | CXTPShortcutBarPaintManager |
RefreshMetrics() | CXTPShortcutBarPaintManager | virtual
~CXTPShortcutBarPaintManager() | CXTPShortcutBarPaintManager | virtual


Toolkit Pro: Member List

CXTPTreeVisualStudio2019Theme Member List

This is the complete list of members for CXTPTreeVisualStudio2019Theme, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPControlTheme() | CXTPControlTheme |
CXTPTreeOffice2013Theme() | CXTPTreeOffice2013Theme |
CXTPTreeTheme() | CXTPTreeTheme |
CXTPTreeVisualStudio2019Theme() | CXTPTreeVisualStudio2019Theme |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetItemBackColor(UINT uState, bool bTreeHasFocus, DWORD dwStyle, COLORREF crTextDef, CTreeCtrl *pTreeBase) const | CXTPTreeTheme | virtual
GetItemTextColor(UINT uState, bool bTreeHasFocus, DWORD dwStyle, COLORREF crBackDef, CTreeCtrl *pTreeBase) const | CXTPTreeTheme | virtual
GetThemeStyle() const | CXTPControlTheme |
GetTreeBackColor() const | CXTPTreeTheme | virtual
GetTreeTextColor() const | CXTPTreeTheme | virtual
IsDrawFocusRect() const | CXTPTreeTheme | inline
IsThemeDark() const | CXTPTreeTheme | inlinevirtual
m_bDarkTheme | CXTPTreeTheme | protected
m_bDrawFocusRect | CXTPTreeTheme | protected
m_crBack | CXTPTreeTheme | protected
m_crBackDisabled | CXTPTreeTheme | protected
m_crBackSelected | CXTPTreeTheme | protected
m_crBackSelectedDisabled | CXTPTreeTheme | protected
m_crBackSelectedInactive | CXTPTreeTheme | protected
m_crText | CXTPTreeTheme | protected
m_crTextDisabled | CXTPTreeTheme | protected
m_crTextSelected | CXTPTreeTheme | protected
m_crTextSelectedDisabled | CXTPTreeTheme | protected
m_crTextSelectedInactive | CXTPTreeTheme | protected
m_nTheme | CXTPControlTheme | protected
RefreshMetrics(CXTPTreeBase *pTreeBase) | CXTPTreeOffice2013Theme | virtual
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static
~CXTPTreeTheme() | CXTPTreeTheme | virtual


Toolkit Pro: XTPCommandBarsVisualStudio2008Theme.h Source File

  • Source
  • CommandBars
  • Themes
XTPCommandBarsVisualStudio2008Theme.h
Go to the documentation of this file.
1
23#if !defined(__XTPCOMMANDBARSVISUALSTUDIO2008THEME_H__)
24# define __XTPCOMMANDBARSVISUALSTUDIO2008THEME_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
40class _XTP_EXT_CLASS CXTPVisualStudio2008Theme : public CXTPVisualStudio2005Theme
41{
42public:
47 CXTPVisualStudio2008Theme();
48
53 virtual ~CXTPVisualStudio2008Theme();
54
59 void RefreshMetrics();
60
61public:
69 virtual CRect GetCommandBarBorders(CXTPCommandBar* pBar);
70
83 virtual void DrawPopupBarGripper(CDC* pDC, int xPos, int yPos, int cx, int cy, BOOL bExpanded);
84
98 virtual void DrawRectangle(CDC* pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled,
99 BOOL bChecked, BOOL bPopuped, XTPBarType barType,
100 XTPBarPosition barPosition);
101
116 virtual void DrawRectangle(CDC* pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled,
117 BOOL bChecked, BOOL bPopuped, XTPBarType barType,
118 XTPBarPosition barPosition, int nID);
119
128 virtual BOOL DrawRectangle(CDC* pDC, CXTPControl* pButton);
129
143 virtual COLORREF GetRectangleTextColor(BOOL bSelected, BOOL bPressed, BOOL bEnabled,
144 BOOL bChecked, BOOL bPopuped, XTPBarType barType,
145 XTPBarPosition barPosition);
146
154 virtual void AdjustExcludeRect(CRect& rc, CXTPControl* pControl, BOOL bVertical);
155
166 virtual CSize DrawCommandBarSeparator(CDC* pDC, CXTPCommandBar* pBar, CXTPControl* pControl,
167 BOOL bDraw);
168
169public:
180 static void AFX_CDECL AlphaPixel(CDC* pDC, int xPos, int yPos, COLORREF clr, int nAlpha);
181
190 static void AFX_CDECL AlphaBorder(CDC* pDC, CRect rc, COLORREF clrBorder);
191
192public:
199 virtual XTPPaintTheme BaseTheme()
200 {
201 return xtpThemeVisualStudio2008;
202 }
203
204public:
205 CXTPPaintManagerColorGradient m_clrMenuSelection;
207 CXTPPaintManagerColor m_clrMenuSelectionBorder;
209 CXTPPaintManagerColor m_clrMenuSelectionText;
211};
212
214# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
215#endif // !defined(__XTPCOMMANDBARSVISUALSTUDIO2008THEME_H__)
XTPBarType
XTPBarType
Type of the command bar.
Definition XTPCommandBarsDefines.h:77
XTPBarPosition
XTPBarPosition
Position of the command bar.
Definition XTPCommandBarsDefines.h:52
XTPPaintTheme
XTPPaintTheme
Paint themes used by command bars.
Definition XTPCommandBarsDefines.h:233
xtpThemeVisualStudio2008
@ xtpThemeVisualStudio2008
Visual Studio 2008 theme.
Definition XTPCommandBarsDefines.h:242
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCommandBar
CXTPCommandBar is a CWnd derived class.
Definition XTPCommandBar.h:66
CXTPControl
CXTPControl is a CXTPCmdTarget derived class.
Definition XTPControl.h:841
CXTPPaintManagerColorGradient
The CXTPPaintManagerColorGradient class is used to manage COLORREF values for determining light and d...
Definition XTPColorManager.h:301
CXTPPaintManagerColor
The CXTPPaintManagerColor class is used to manage COLORREF values for determining default and applica...
Definition XTPColorManager.h:117
CXTPVisualStudio2005Theme
The CXTPVisualStudio2005Theme class is used to enable a Visual Studio 2005 style theme for Command Ba...
Definition XTPCommandBarsVisualStudio2005Theme.h:41
CXTPVisualStudio2008Theme
The CXTPVisualStudio2008Theme class is used to enable a Visual Studio 2008 style theme for Command Ba...
Definition XTPCommandBarsVisualStudio2008Theme.h:41
CXTPVisualStudio2008Theme::DrawPopupBarGripper
virtual void DrawPopupBarGripper(CDC *pDC, int xPos, int yPos, int cx, int cy, BOOL bExpanded)
This method is called to draw a pop-up bar's right gripper.
CXTPVisualStudio2008Theme::DrawCommandBarSeparator
virtual CSize DrawCommandBarSeparator(CDC *pDC, CXTPCommandBar *pBar, CXTPControl *pControl, BOOL bDraw)
This method is called to draw a command bar's separator.
CXTPVisualStudio2008Theme::GetCommandBarBorders
virtual CRect GetCommandBarBorders(CXTPCommandBar *pBar)
This method is called to retrieve the command bar's borders.
CXTPVisualStudio2008Theme::AlphaBorder
static void AFX_CDECL AlphaBorder(CDC *pDC, CRect rc, COLORREF clrBorder)
Draws a border around a specified rectangle.
CXTPVisualStudio2008Theme::m_clrMenuSelectionBorder
CXTPPaintManagerColor m_clrMenuSelectionBorder
Color used to draw the border of the current menu selection.
Definition XTPCommandBarsVisualStudio2008Theme.h:207
CXTPVisualStudio2008Theme::GetRectangleTextColor
virtual COLORREF GetRectangleTextColor(BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition)
This method retrieves a button's text color.
CXTPVisualStudio2008Theme::DrawRectangle
virtual BOOL DrawRectangle(CDC *pDC, CXTPControl *pButton)
This method is called to fill the control's face.
CXTPVisualStudio2008Theme::AdjustExcludeRect
virtual void AdjustExcludeRect(CRect &rc, CXTPControl *pControl, BOOL bVertical)
This method is called to determine the offset of a pop-up bar.
CXTPVisualStudio2008Theme::~CXTPVisualStudio2008Theme
virtual ~CXTPVisualStudio2008Theme()
Destroys a CXTPVisualStudio2008Theme object, handles cleanup and deallocation.
CXTPVisualStudio2008Theme::AlphaPixel
static void AFX_CDECL AlphaPixel(CDC *pDC, int xPos, int yPos, COLORREF clr, int nAlpha)
Draws pixel in specific position with specify Alpha.
CXTPVisualStudio2008Theme::m_clrMenuSelection
CXTPPaintManagerColorGradient m_clrMenuSelection
Gradient used to draw the current menu selection.
Definition XTPCommandBarsVisualStudio2008Theme.h:205
CXTPVisualStudio2008Theme::m_clrMenuSelectionText
CXTPPaintManagerColor m_clrMenuSelectionText
Color used to draw the text of the current menu selection.
Definition XTPCommandBarsVisualStudio2008Theme.h:209
CXTPVisualStudio2008Theme::CXTPVisualStudio2008Theme
CXTPVisualStudio2008Theme()
Constructs a CXTPVisualStudio2008Theme object.
CXTPVisualStudio2008Theme::BaseTheme
virtual XTPPaintTheme BaseTheme()
Retrieves the base theme of the manager.
Definition XTPCommandBarsVisualStudio2008Theme.h:199
CXTPVisualStudio2008Theme::RefreshMetrics
void RefreshMetrics()
This method is called to refresh the visual metrics of the manager.
CXTPVisualStudio2008Theme::DrawRectangle
virtual void DrawRectangle(CDC *pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition)
This method is called to fill the control's face.
CXTPVisualStudio2008Theme::DrawRectangle
virtual void DrawRectangle(CDC *pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition, int nID)
This method is called to fill the control's face.


Toolkit Pro: XTPOpenGLUtils.h Source File

  • Source
  • GraphicLibrary
  • OpenGL
XTPOpenGLUtils.h
Go to the documentation of this file.
1
23#if !defined(__XTPOPENGLUTILS_H__)
24# define __XTPOPENGLUTILS_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33template<class T>
34class CXTPMatrix;
35
40class _XTP_EXT_CLASS CXTPOpenGLUtils
41{
42public:
44# ifdef _DEBUG
45 // Debugging
46 static void DebugAxes(double dSize);
47 static void DebugBox(const CXTPPoint3d& ptMin, const CXTPPoint3d& ptMax, BOOL bSolid = FALSE);
48 static void DebugNormal(const CXTPPoint3d& a, const CXTPPoint3d& b, const CXTPPoint3d& c,
49 const CXTPPoint3d& n, double dLen = 5.);
50 static void DebugNormal(const CXTPPoint3d& v, const CXTPPoint3d& n, double dLen = 5.);
51# endif /*_DEBUG*/
59 static void Vertex(const CXTPPoint3d& ptVertex);
60
67 static void Vertex(const CXTPPoint3d& ptVertex, const CXTPPoint3d& vNormal);
68
76 static void Rotate(double dYaw, double dPitch, double dRoll);
77
93 static BOOL Project(const CXTPPoint3d& pt3d, CPoint& pt2d, double* pdWinZ = NULL);
94
110 static BOOL Unproject(const CPoint& pt2d, CXTPPoint3d& pt3d, double dWinZ = 0.);
111
118 static void MultiplyByMatrix(CXTPPoint3d& v, const CXTPMatrix<double>& matrix);
119
126 static void MultiplyByMatrix(CXTPPoint3d& v, GLenum name);
127
143 static CXTPPoint3d ComputeTriangleNormal(const CXTPPoint3d& vA, const CXTPPoint3d& vB,
144 const CXTPPoint3d& vC, bool ccw = false);
145};
146
147# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
149#endif // #if !defined(__XTPOPENGLUTILS_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPMatrix
Represents a matrix object built upon a continuos array of elements and provides basic algorithms for...
Definition XTPMatrix.h:40
CXTPOpenGLUtils
Provides a set of common OpenGL utilities.
Definition XTPOpenGLUtils.h:41
CXTPOpenGLUtils::MultiplyByMatrix
static void MultiplyByMatrix(CXTPPoint3d &v, GLenum name)
Multiplies a vector by a specified OpenGL matrix.
CXTPOpenGLUtils::Project
static BOOL Project(const CXTPPoint3d &pt3d, CPoint &pt2d, double *pdWinZ=NULL)
Projects 3D space coordinates between the near and far planes to 2D space coordinates of the current ...
CXTPOpenGLUtils::Vertex
static void Vertex(const CXTPPoint3d &ptVertex)
Sets a vertex from point coordinates.
CXTPOpenGLUtils::Rotate
static void Rotate(double dYaw, double dPitch, double dRoll)
Rotates the active matrix using Euler angles.
CXTPOpenGLUtils::Vertex
static void Vertex(const CXTPPoint3d &ptVertex, const CXTPPoint3d &vNormal)
Sets a vertex and its normal from point coordinates.
CXTPOpenGLUtils::MultiplyByMatrix
static void MultiplyByMatrix(CXTPPoint3d &v, const CXTPMatrix< double > &matrix)
Multiplies a vector by a specified matrix.
CXTPOpenGLUtils::Unproject
static BOOL Unproject(const CPoint &pt2d, CXTPPoint3d &pt3d, double dWinZ=0.)
Unprojects 2D space coordinates of the current viewport to 3D space coordinates between the near and ...
CXTPOpenGLUtils::ComputeTriangleNormal
static CXTPPoint3d ComputeTriangleNormal(const CXTPPoint3d &vA, const CXTPPoint3d &vB, const CXTPPoint3d &vC, bool ccw=false)
Computes a normal for a specified triangle.
CXTPPoint3T< double >


Toolkit Pro: XTPDialogBar.h Source File

  • Source
  • CommandBars
XTPDialogBar.h
Go to the documentation of this file.
1
23#if !defined(__XTPDIALOGBAR_H__)
24# define __XTPDIALOGBAR_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPPopupBar;
34
40class _XTP_EXT_CLASS CXTPDialogBar : public CXTPToolBar
41{
43 class CControlButtonHide;
44 class CControlCaptionPopup;
45 class CCaptionPopupBar;
48public:
53 CXTPDialogBar();
54
59 virtual ~CXTPDialogBar();
60
61public:
69 void SetChild(CWnd* pChild);
70
81 void SetCaption(LPCTSTR lpszCaption);
82
89 CString GetCaption() const;
90
99 void SetCaptionVisible(BOOL bVisible);
100
112 void SetCaptionPopup(int nMenuResourceID);
113
122 CXTPPopupBar* GetCaptionPopup() const;
123
135 void SetResizable(BOOL bResizable);
136
149 void SetSize(CSize sz);
150
157 BOOL IsActive() const;
158
159protected:
169 CSize CalcDockingLayout(int nLength, DWORD dwMode, int nWidth);
170
180 CSize CalcDynamicLayout(int nLength, DWORD dwMode);
181
190 BOOL IsDialogBar() const;
191
198 void OnResize(CRect rcWindow, int nHitTest);
199
209 CSize CalcSize(int nLength, DWORD dwMode, CSize szClient);
210
218 int OnMouseHitTest(CPoint pt);
219
226 CRect GetMargins();
227
233 void MoveChildWindow(CRect rc);
234
235protected:
237 DECLARE_MESSAGE_MAP()
238
239 //{{AFX_MSG(CXTPDialogBar)
240 afx_msg LRESULT OnNcHitTest(CPoint point);
241 afx_msg void OnSize(UINT nType, int cx, int cy);
242 afx_msg LRESULT OnIdleUpdateCmdUI(WPARAM wParam, LPARAM lParam);
243 //}}AFX_MSG
246protected:
247 CRect m_rcBorders;
248 BOOL m_bResizable;
249 CSize m_szMinTrackRect;
250 BOOL m_bCaptionVisible;
251 BOOL m_bCaptionPopup;
252 int m_nCaptionHeight;
253 CSize m_szDockingClient;
254 CSize m_szFloatingClient;
255 HWND m_hwndChild;
256 CString m_strCaption;
257 CXTPPopupBar* m_pPopupBar;
258 BOOL m_bActive;
260protected:
261# ifdef _XTP_COMMANDBARS_ACTIVEX
264 DECLARE_DISPATCH_MAP()
265 DECLARE_OLETYPELIB_EX(CXTPDialogBar);
266 DECLARE_INTERFACE_MAP()
267
268 afx_msg LPDISPATCH OleGetCaptionPopupBar();
269 afx_msg void OleSetChildHandle(HWND hWnd);
270 afx_msg HWND OleGetChildHandle();
271 afx_msg void OleSetSize(int cx, int cy);
272
274# endif
275
276 DECLARE_XTP_COMMANDBAR(CXTPDialogBar)
277
278 friend class CXTPToolBar;
279 friend class CXTPDockContext;
280};
281
283
284AFX_INLINE BOOL CXTPDialogBar::IsDialogBar() const
285{
286 return TRUE;
287}
288AFX_INLINE CXTPPopupBar* CXTPDialogBar::GetCaptionPopup() const
289{
290 return m_pPopupBar;
291}
292AFX_INLINE void CXTPDialogBar::SetResizable(BOOL bResizable)
293{
294 m_bResizable = bResizable;
295}
296AFX_INLINE BOOL CXTPDialogBar::IsActive() const
297{
298 return m_bActive;
299}
301# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
302#endif //#if !defined(__XTPDIALOGBAR_H__)
DECLARE_XTP_COMMANDBAR
#define DECLARE_XTP_COMMANDBAR(class_name)
This macro generates the C++ header code necessary for a CXTPCommandBar-derived class that can be ser...
Definition XTPCommandBarsDefines.h:1234
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCommandBar::IsDialogBar
virtual BOOL IsDialogBar() const
Call this member function to determine if the command bar is a CXTPDialogBar.
Definition XTPCommandBar.h:1403
CXTPDialogBar
CXTPDialogBar is a CXTPToolBar derived class.
Definition XTPDialogBar.h:41
CXTPDialogBar::m_bActive
BOOL m_bActive
TRUE if the dialog bar has an active caption.
Definition XTPDialogBar.h:258
CXTPDialogBar::GetMargins
CRect GetMargins()
Retrieves the client margins of the dialog bar.
CXTPDialogBar::~CXTPDialogBar
virtual ~CXTPDialogBar()
Destroys a CXTPDialogBar object, handles cleanup and deallocation.
CXTPDialogBar::GetCaption
CString GetCaption() const
Call this member to retrieve the text displayed in the caption pop-up.
CXTPDialogBar::OnMouseHitTest
int OnMouseHitTest(CPoint pt)
This method is called to determine mouse hit code.
CXTPDialogBar::SetCaption
void SetCaption(LPCTSTR lpszCaption)
Call this member to set the text that will be displayed in the dialog bar's caption pop-up.
CXTPDialogBar::CXTPDialogBar
CXTPDialogBar()
Constructs a CXTPDialogBar object.
CXTPDialogBar::GetCaptionPopup
CXTPPopupBar * GetCaptionPopup() const
Call this member to retrieve a pointer to the CXTPPopupBar that is displayed when the caption pop-up ...
Definition XTPDialogBar.h:288
CXTPDialogBar::IsActive
BOOL IsActive() const
Call this member function to get the child pane state.
Definition XTPDialogBar.h:296
CXTPDialogBar::SetCaptionPopup
void SetCaptionPopup(int nMenuResourceID)
Call this member to tell the caption pop-up which CMenu pop-up to display when the the caption pop-up...
CXTPDialogBar::SetCaptionVisible
void SetCaptionVisible(BOOL bVisible)
Call this member to hide the caption pop-up control (and close button).
CXTPDialogBar::CalcSize
CSize CalcSize(int nLength, DWORD dwMode, CSize szClient)
This method calculates the dimensions of a dialog bar.
CXTPDialogBar::SetSize
void SetSize(CSize sz)
Call this member to set the width and height of the dialog bar child window.
CXTPDialogBar::IsDialogBar
BOOL IsDialogBar() const
Call this member function to determine if the CommandBar is a CXTPDialogBar.
Definition XTPDialogBar.h:284
CXTPDialogBar::SetResizable
void SetResizable(BOOL bResizable)
Call this member to specify whether the dialog bar will be re-sizable.
Definition XTPDialogBar.h:292
CXTPDialogBar::m_pPopupBar
CXTPPopupBar * m_pPopupBar
Pointer to caption pop-up bar.
Definition XTPDialogBar.h:257
CXTPDialogBar::SetChild
void SetChild(CWnd *pChild)
Call this member to specify the child window displayed under the dialog bar.
CXTPDialogBar::m_bResizable
BOOL m_bResizable
TRUE if the child window and dialog bar are re-sizable.
Definition XTPDialogBar.h:248
CXTPDialogBar::CalcDockingLayout
CSize CalcDockingLayout(int nLength, DWORD dwMode, int nWidth)
This method calculates the dimensions of a toolbar.
CXTPDialogBar::MoveChildWindow
void MoveChildWindow(CRect rc)
This method is called to reposition the child window in the dialog bar.
CXTPDialogBar::OnResize
void OnResize(CRect rcWindow, int nHitTest)
This method is called when the user resizes the dialog bar.
CXTPDialogBar::CalcDynamicLayout
CSize CalcDynamicLayout(int nLength, DWORD dwMode)
This method calculates the dimensions of a toolbar.
CXTPDockContext
CXTPDockContext is a standalone class.
Definition XTPDockContext.h:41
CXTPPopupBar
CXTPPopupBar is a CXTPCommandBar derived class.
Definition XTPPopupBar.h:42
CXTPToolBar
CXTPToolBar is a CXTPCommandBar derived class.
Definition XTPToolBar.h:42


Toolkit Pro: XTPTrackThemeExplorer.h Source File

  • Source
  • GridControl
  • TrackControl
  • Themes
XTPTrackThemeExplorer.h
Go to the documentation of this file.
1
23#if !defined(__XTPTRACKTHEMEExplorer_H__)
24# define __XTPTRACKTHEMEExplorer_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPTrackThemeExplorer : public CXTPTrackPaintManager
39{
40public:
45 CXTPTrackThemeExplorer();
46
78 virtual void DrawTriangle(CDC* pDC, CRect rcTriangle, BOOL bToDown, int nShadowWidth = 0);
79
80 using CXTPTrackPaintManager::DrawTriangle;
81
91 virtual CSize DrawGlyph(CDC* pDC, CRect rcColumn, int iImage);
92
104 virtual BOOL IsColumHotTrackingEnabled() const;
105
117 virtual void DrawColumnBackground(CDC* pDC, CXTPGridColumn* pColumn, CRect rcColumn,
118 BOOL& bColumnPressed, BOOL& bDraggingFromHeader,
119 CXTPGridHeader* pHeader = NULL);
120
133 void DrawSectionDivider(CDC* pDC, const CRect& rc,
134 XTPGridSectionDividerPosition dividerPosition,
135 XTPGridSectionDividerStyle dividerStyle,
136 CXTPPaintManagerColor dividerColor);
137};
139# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
140#endif //#if !defined(__XTPTRACKTHEMEExplorer_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPGridSectionDividerPosition
XTPGridSectionDividerPosition
Section divider position.
Definition XTPGridDefines.h:258
XTPGridSectionDividerStyle
XTPGridSectionDividerStyle
Represent the header/footer rows divider style.
Definition XTPGridDefines.h:227
CXTPGridColumn
Represents a grid column item with its properties and operations.
Definition XTPGridColumn.h:107
CXTPGridHeader
A grid header is a part of the grid window positioned above columns of text or numbers.
Definition XTPGridHeader.h:173
CXTPGridPaintManager::DrawTriangle
virtual void DrawTriangle(CDC *pDC, CRect rcTriangle, BOOL bToDown, BOOL bDraggingFromHeader, int nShadowWidth, BOOL bColumnPressed)
Draws a triangle that shows the sort order of the column.
CXTPPaintManagerColor
The CXTPPaintManagerColor class is used to manage COLORREF values for determining default and applica...
Definition XTPColorManager.h:117
CXTPTrackPaintManager
This class represents a track control paint manager.
Definition XTPTrackPaintManager.h:41
CXTPTrackThemeExplorer
CXTPTrackThemeExplorer is a CXTPTrackPaintManager derived class that represents an Explorer style the...
Definition XTPTrackThemeExplorer.h:39
CXTPTrackThemeExplorer::DrawTriangle
virtual void DrawTriangle(CDC *pDC, CRect rcTriangle, BOOL bToDown, int nShadowWidth=0)
Draws a triangle that shows the sort order of the column.
CXTPTrackThemeExplorer::CXTPTrackThemeExplorer
CXTPTrackThemeExplorer()
Default paint manager constructor, handles properties initialization.
CXTPTrackThemeExplorer::DrawSectionDivider
void DrawSectionDivider(CDC *pDC, const CRect &rc, XTPGridSectionDividerPosition dividerPosition, XTPGridSectionDividerStyle dividerStyle, CXTPPaintManagerColor dividerColor)
Draws the divider between grid sections (e.g.
CXTPTrackThemeExplorer::DrawColumnBackground
virtual void DrawColumnBackground(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, BOOL &bColumnPressed, BOOL &bDraggingFromHeader, CXTPGridHeader *pHeader=NULL)
This method is called to draw the background of a column using the current column style.
CXTPTrackThemeExplorer::IsColumHotTrackingEnabled
virtual BOOL IsColumHotTrackingEnabled() const
Determines if hot tracking is enabled for the current column style.
CXTPTrackThemeExplorer::DrawGlyph
virtual CSize DrawGlyph(CDC *pDC, CRect rcColumn, int iImage)
Draws the standard glyphs of the Grid control.


Toolkit Pro: Member List

CXTPSyntaxEditBufferManager Member List

This is the complete list of members for CXTPSyntaxEditBufferManager, including all inherited members.

CalcAveDataSize(int nRowStart, int nRowEnd) | CXTPSyntaxEditBufferManager | protectedvirtual
CalcMaxLineTextLength(int nLineFrom=-1, int nLineTo=-1, BOOL bExpandTabs=FALSE) const | CXTPSyntaxEditBufferManager |
ChangeCase(int nRow, int nDispFrom, int nDispTo, BOOL bUpper, BOOL bCanUndo=TRUE) | CXTPSyntaxEditBufferManager |
ChangeTabification(int nRow, int nDispFrom, int nDispTo, BOOL bTabify, BOOL bCanUndo=TRUE) | CXTPSyntaxEditBufferManager |
CleanUp() | CXTPSyntaxEditBufferManager | protected
Close() | CXTPSyntaxEditBufferManager |
ColToStrPos(int nLine, int nDispCol) const | CXTPSyntaxEditBufferManager | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPSyntaxEditBufferManager() | CXTPSyntaxEditBufferManager |
DeleteText(int iRowFrom, int iColFrom, int iRowTo, int iColTo, BOOL bCanUndo=TRUE, BOOL bDispCol=FALSE) | CXTPSyntaxEditBufferManager |
EnableParser(BOOL bEnable) | CXTPSyntaxEditBufferManager |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetBuffer(int row1, int col1, int row2, int col2, CMemFile &file, BOOL bColumnSelection=FALSE, BOOL bForceDOSStyleCRLF=FALSE) | CXTPSyntaxEditBufferManager |
GetBuffer(const XTP_EDIT_LINECOL &lcStart, const XTP_EDIT_LINECOL &lcEnd, CMemFile &file, BOOL bColumnSelection=FALSE, BOOL bForceDOSStyleCRLF=FALSE) | CXTPSyntaxEditBufferManager |
GetCodePage() const | CXTPSyntaxEditBufferManager |
GetConfigFile() const | CXTPSyntaxEditBufferManager |
GetConnection() const | CXTPSyntaxEditBufferManager |
GetCurCRLF() const | CXTPSyntaxEditBufferManager |
GetCurCRLFType() const | CXTPSyntaxEditBufferManager |
GetFileExt() const | CXTPSyntaxEditBufferManager |
GetLexConfigurationManager() const | CXTPSyntaxEditBufferManager |
GetLexParser() const | CXTPSyntaxEditBufferManager |
GetLineMarksManager() const | CXTPSyntaxEditBufferManager |
GetLineText(int iLine, CString &strText, BOOL bAddCRLF=FALSE, int iCRLFStyle=-1) | CXTPSyntaxEditBufferManager |
GetLineText(int iLine, BOOL bAddCRLF=FALSE, int iCRLFStyle=-1) const | CXTPSyntaxEditBufferManager |
GetLineTextLength(int iLine, BOOL bAddCRLF=FALSE, int iCRLFStyle=-1) const | CXTPSyntaxEditBufferManager |
GetLineTextLengthC(int iLine, BOOL bAddCRLF=FALSE, int iCRLFStyle=-1) const | CXTPSyntaxEditBufferManager |
GetMasterTextSchema(const CString &strExt) const | CXTPSyntaxEditBufferManager |
GetMaxLineTextLength() const | CXTPSyntaxEditBufferManager |
GetOverwriteFlag() const | CXTPSyntaxEditBufferManager |
GetRowCount() const | CXTPSyntaxEditBufferManager |
GetTabSize() const | CXTPSyntaxEditBufferManager |
GetUndoRedoManager() const | CXTPSyntaxEditBufferManager |
InsertText(LPCTSTR szText, int iRow, int iCol, BOOL bCanUndo=TRUE, XTP_EDIT_LINECOL *pFinalLC=NULL) | CXTPSyntaxEditBufferManager |
InsertTextBlock(LPCTSTR szText, int nRow, int nCol, BOOL bCanUndo=TRUE, XTP_EDIT_LINECOL *pFinalLC=NULL) | CXTPSyntaxEditBufferManager |
IsModified() const | CXTPSyntaxEditBufferManager |
IsParserEnabled() const | CXTPSyntaxEditBufferManager |
IsTextCRLF(LPCTSTR szCompText, BOOL bMatchReverse=FALSE) const | CXTPSyntaxEditBufferManager |
Load(CFile *pFile, LPCTSTR pcszFileExt=NULL) | CXTPSyntaxEditBufferManager |
m_bIsParserEnabled | CXTPSyntaxEditBufferManager | protected
m_bOverwrite | CXTPSyntaxEditBufferManager | protected
m_bUnicodeFileFormat | CXTPSyntaxEditBufferManager | protected
m_iCRLFStyle | CXTPSyntaxEditBufferManager | protected
m_nAverageLineLen | CXTPSyntaxEditBufferManager | protected
m_nCodePage | CXTPSyntaxEditBufferManager | protected
m_nTabSize | CXTPSyntaxEditBufferManager | protected
m_pConnection | CXTPSyntaxEditBufferManager | protected
m_pLexParser | CXTPSyntaxEditBufferManager | protected
m_pLineMarksManager | CXTPSyntaxEditBufferManager | protected
m_ptrDefaultLexConfigurationManager | CXTPSyntaxEditBufferManager | protected
m_ptrLexConfigurationManager | CXTPSyntaxEditBufferManager | protected
m_pUndoRedoManager | CXTPSyntaxEditBufferManager | protected
m_strFileExt | CXTPSyntaxEditBufferManager | protected
m_Strings | CXTPSyntaxEditBufferManager | protected
RemoveLine(int nRow, BOOL bCanUndo=TRUE, int nRowsCount=1) | CXTPSyntaxEditBufferManager |
Serialize(CArchive &ar) | CXTPSyntaxEditBufferManager | virtual
SerializeEx(CArchive &ar, BOOL bUnicode=-1, BOOL bWriteUnicodeFilePrefix=TRUE, UINT nCodePage=(UINT) -1, LPCTSTR pcszFileExt=NULL, int nDataSizeLimit=-1) | CXTPSyntaxEditBufferManager | virtual
SetConfigFile(LPCTSTR szPath) | CXTPSyntaxEditBufferManager |
SetCRLFStyle(int nStyle) | CXTPSyntaxEditBufferManager |
SetFileExt(const CString &strExt) | CXTPSyntaxEditBufferManager |
SetLexConfigurationManager(CXTPSyntaxEditConfigurationManager *pMan) | CXTPSyntaxEditBufferManager |
SetOverwriteFlag(BOOL bOverwrite) | CXTPSyntaxEditBufferManager |
SetTabSize(int nTabSize, BOOL bUpdateReg=FALSE) | CXTPSyntaxEditBufferManager |
StrPosToCol(int nLine, int nStrPos) const | CXTPSyntaxEditBufferManager | virtual
~CXTPSyntaxEditBufferManager() | CXTPSyntaxEditBufferManager |


Toolkit Pro: Member List

CXTPChartDiagramDomain Member List

This is the complete list of members for CXTPChartDiagramDomain, including all inherited members.

CXTPChartDiagramDomain(const CXTPChartRectF &rcInnerBounds) | CXTPChartDiagramDomain
GetInnerBounds() const | CXTPChartDiagramDomain


Toolkit Pro: Member List

CXTPDockingPaneSplitterContainer Member List

This is the complete list of members for CXTPDockingPaneSplitterContainer, including all inherited members.

Clone(CXTPDockingPaneLayout *pLayout, CXTPPaneToPaneMap *pMap, DWORD dwIgnoredOptions=0) | CXTPDockingPaneBase | protectedvirtual
ContainPane(CXTPDockingPaneBase *pPane) const | CXTPDockingPaneBaseContainer | virtual
Copy(CXTPDockingPaneBase *pClone, CXTPPaneToPaneMap *pMap, DWORD dwIgnoredOptions) | CXTPDockingPaneSplitterContainer | protectedvirtual
CreateContainer() | CXTPDockingPaneBase | protectedvirtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPDockingPaneBase(XTPDockingPaneType type, CXTPDockingPaneLayout *pLayout) | CXTPDockingPaneBase | protected
CXTPDockingPaneBaseContainer(XTPDockingPaneType type, CXTPDockingPaneLayout *pLayout) | CXTPDockingPaneBaseContainer | protected
CXTPDockingPaneSplitterContainer(CXTPDockingPaneLayout *pLayout) | CXTPDockingPaneSplitterContainer | protected
DeletePane() | CXTPDockingPaneSplitterContainer | protectedvirtual
DoPropExchange(CXTPPropExchange *pPX) | CXTPDockingPaneSplitterContainer | protectedvirtual
FindCaptionButton(int nID) const | CXTPDockingPaneBase |
FindChildPane(XTPDockingPaneType type, CXTPDockingPaneBaseList *pList) const | CXTPDockingPaneSplitterContainer |
FindPane(XTPDockingPaneType type, CXTPDockingPaneBaseList *pList) const | CXTPDockingPaneBaseContainer | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCaptionButtons() const | CXTPDockingPaneBase |
GetContainer() const | CXTPDockingPaneBase |
GetDockingPaneManager() const | CXTPDockingPaneBase |
GetDockingSite() const | CXTPDockingPaneBase | virtual
GetFirstPane() const | CXTPDockingPaneBaseContainer |
GetHeadPosition() const | CXTPDockingPaneBaseContainer |
GetLastPane() const | CXTPDockingPaneBaseContainer |
GetMinMaxInfo(LPMINMAXINFO pMinMaxInfo) const | CXTPDockingPaneSplitterContainer | virtual
GetNext(POSITION &pos) const | CXTPDockingPaneBaseContainer |
GetPaintManager() const | CXTPDockingPaneBase |
GetPaneHwnd() const | CXTPDockingPaneBase | virtual
GetPanes() | CXTPDockingPaneBaseContainer |
GetPaneWindowRect() const | CXTPDockingPaneBase |
GetTitle() const | CXTPDockingPaneBase | virtual
GetType() const | CXTPDockingPaneBase |
Init(CXTPDockingPaneBase *pPane, BOOL bHoriz, CWnd *pFrame) | CXTPDockingPaneSplitterContainer | protected
InvalidatePane(BOOL bSelectionChanged) | CXTPDockingPaneBase | virtual
IsActive() const | CXTPDockingPaneBase | virtual
IsCaptionButtonVisible(CXTPDockingPaneCaptionButton *pButton) | CXTPDockingPaneBase | protectedvirtual
IsCaptionVertical() const | CXTPDockingPaneBase | virtual
IsEmpty() const | CXTPDockingPaneBaseContainer | protectedvirtual
IsHidden() const | CXTPDockingPaneBase | virtual
IsHoriz() const | CXTPDockingPaneSplitterContainer | inline
m_bHoriz | CXTPDockingPaneSplitterContainer | protected
m_bRecalcLayout | CXTPDockingPaneSplitterContainer | protected
m_lstPanes | CXTPDockingPaneBaseContainer | protected
m_lstSpliters | CXTPDockingPaneSplitterContainer | protected
m_pCaptionButtons | CXTPDockingPaneBase | protected
m_pDockingSite | CXTPDockingPaneBase | protected
m_pLayout | CXTPDockingPaneBase | protected
m_pParentContainer | CXTPDockingPaneBase | protected
m_rcWindow | CXTPDockingPaneBase | protected
m_szDocking | CXTPDockingPaneBase | protected
m_type | CXTPDockingPaneBase | protected
NormalizeDockingSize() | CXTPDockingPaneSplitterContainer | protected
OnAction(XTPDockingPaneAction action) | CXTPDockingPaneBaseContainer |
OnCaptionButtonRectChanged(CXTPDockingPaneCaptionButton *pButton) | CXTPDockingPaneBase | protectedvirtual
OnChildContainerChanged(CXTPDockingPaneBase *pContainer) | CXTPDockingPaneSplitterContainer | protectedvirtual
OnCreateSplitter() | CXTPDockingPaneSplitterContainer | protectedvirtual
OnFocusChanged() | CXTPDockingPaneBase | protectedvirtual
OnParentContainerChanged(CXTPDockingPaneBase *pContainer) | CXTPDockingPaneSplitterContainer | protectedvirtual
OnSizeParent(CWnd *pParent, CRect rect, LPVOID lParam) | CXTPDockingPaneSplitterContainer | virtual
RedrawPane() | CXTPDockingPaneBase | virtual
RemovePane(CXTPDockingPaneBase *pPane) | CXTPDockingPaneSplitterContainer | protectedvirtual
SetDockingSite(CWnd *pFrame) | CXTPDockingPaneBase | protectedvirtual
SetParentContainer(CXTPDockingPaneBase *pContainer) | CXTPDockingPaneBase | protectedvirtual
~CXTPDockingPaneBase() | CXTPDockingPaneBase | protectedvirtual
~CXTPDockingPaneBaseContainer() | CXTPDockingPaneBaseContainer | protectedvirtual
~CXTPDockingPaneSplitterContainer() | CXTPDockingPaneSplitterContainer | protectedvirtual


Toolkit Pro: XTPTrackControl.h Source File

  • Source
  • GridControl
  • TrackControl
XTPTrackControl.h
Go to the documentation of this file.
1
23#if !defined(__XTPTRACKCONTROL_H__)
24# define __XTPTRACKCONTROL_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPTrackBlock;
34class CXTPTrackMarker;
35class CXTPTrackSelectedBlocks;
36class CXTPTrackMarkers;
37
43# define XTP_NM_TRACK_SLIDERCHANGED (NM_FIRST - 200)
44
50# define XTP_NM_TRACK_TIMELINECHANGED (NM_FIRST - 201)
51
57# define XTP_NM_TRACK_MARKERCHANGED (NM_FIRST - 202)
58
64# define XTP_NM_TRACK_BLOCKCHANGED (NM_FIRST - 203)
65
71# define XTP_NM_TRACK_SELECTEDBLOCKSCHANGED (NM_FIRST - 204)
72
77struct XTP_NM_TRACKCONTROL
78{
79 NMHDR hdr;
80 CXTPTrackBlock* pBlock;
81 CXTPTrackMarker* pMarker;
82};
83
96enum XTPTrackMouseCursorMode
97{
98 xtpTrackCursorNothing,
99 xtpTrackCursorDrag,
100 xtpTrackCursorResize
101};
102
103class CXTPTrackPaintManager;
104class CXTPTrackUndoManager;
105
112class _XTP_EXT_CLASS CXTPTrackControl : public CXTPGridControl
113{
114public:
119 CXTPTrackControl();
120
125 ~CXTPTrackControl();
126
127public:
135 BOOL RegisterWindowClass(HINSTANCE hInstance = NULL);
136
142 void SetTimeLinePosition(int nTimeLinePos);
143
150 int GetTimeLinePosition() const;
151
158 int GetTimeLineMin() const;
159
166 int GetTimeLineMax() const;
167
174 void SetWorkArea(int nWorkAreaMin, int nWorkAreaMax);
175
182 void SetViewPort(int nViewPortMin, int nViewPortMax);
183
190 void SetTimeLineRange(int nTimeScaleMin, int nTimeScaleMax);
191
198 int GetWorkAreaMin() const;
199
206 int GetWorkAreaMax() const;
207
214 int GetViewPortMin() const;
215
222 int GetViewPortMax() const;
223
230 CXTPTrackPaintManager* GetTrackPaintManager() const;
231
232public:
242 void DoPropExchange(CXTPPropExchange* pPX);
243
244public:
251 CXTPTrackSelectedBlocks* GetSelectedBlocks() const;
252
253public:
258 void Populate();
259
275 int DrawRows(CDC* pDC, CRect& rcClient, int y, CXTPGridRows* pRows, int nTopRow,
276 int nColumnFrom, int nColumnTo, int* pnHeight);
277
284 int GetTrackOffset() const;
285
291 void AdjustLayout();
292
299 CXTPGridColumn* GetTrackColumn() const;
300
308 int PositionToTrack(int nPosition);
309
317 int TrackToPosition(int nTrack) const;
318
325 int GetTrackColumnIndex() const;
326
336 int GetSnapMargin() const;
337
344 CRect GetTimelineArea() const;
345
351 void EnsureVisible(CXTPTrackBlock* pBlock);
352
364 CXTPTrackMarkers* GetMarkers() const;
365
378 CXTPTrackUndoManager* GetUndoManager() const;
379
389 virtual BOOL HitTest(CPoint pt, CXTPGridHitTestInfo* pInfo) const;
390
391public:
403 LRESULT SendMessageToParent(UINT nMessage, CXTPTrackBlock* pBlock = NULL,
404 CXTPTrackMarker* pMarker = NULL) const;
405
406public:
412 void StartDragBlocks(BOOL bResize);
413
423 int SnapPosition(int nPosition);
424
429 void StartDragSelection();
430
435 void AdjustTrackColumnWidth();
436
437 void SetPaintManager(CXTPTrackPaintManager* pPaintManager);
438 void SetTheme(XTPGridPaintTheme paintTheme, BOOL bEnableMetrics /*=FALSE*/);
439
446 void SetMouseCursorMode(XTPTrackMouseCursorMode enMode);
447
455 XTPTrackMouseCursorMode GetMouseCursorMode() const;
456
457 CPoint m_ptStartDrag;
459protected:
461 DECLARE_MESSAGE_MAP()
462
463 afx_msg BOOL OnSetCursor(CWnd* pWnd, UINT nHitTest, UINT message);
464 afx_msg UINT OnGetDlgCode();
465 afx_msg void OnKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags);
466 afx_msg void OnLButtonDown(UINT nFlags, CPoint point);
467
468 void OnMoveBlock(CPoint pt, BOOL bResize);
469 void OnMoveSelection(CPoint pt);
470 void CreateDragBlocks();
471 void ReleaseDragBlocks();
472 void OnDraw(CDC* pDC);
475protected:
476 int m_nTimeLineMin;
477 int m_nTimeLineMax;
479 double m_nViewPortMin;
480 double m_nViewPortMax;
482 int m_nOldTrackWidth;
483 double m_nOldTrackViewPortRange;
485 int m_nWorkAreaMin;
486 int m_nWorkAreaMax;
488 int m_nTimeLinePosition;
489 int m_nTrackColumnIndex;
491 CRect m_rcSelectedArea;
493 CXTPTrackMarkers* m_pMarkers;
495 CRect m_rcTimelineArea;
501 struct DRAGBLOCK
502 {
503 int nOldPos;
504 int nOldLength;
505 CRect rcOrigin;
506 CXTPTrackBlock* pBlock;
507 };
508 CArray<DRAGBLOCK, DRAGBLOCK&> m_arrDragBlocks;
511 CXTPTrackSelectedBlocks* m_pSelectedBlocks;
512 CXTPTrackUndoManager* m_pUndoManager;
514 XTPTrackMouseCursorMode m_mouseCursorMode;
516public:
517 HCURSOR m_hMoveCursor;
518 HCURSOR m_hResizeCursor;
520 int m_nSnapMargin;
522 BOOL m_bSnapToBlocks;
524 BOOL m_bSnapToMarkers;
527 BOOL m_bScaleOnResize;
530 BOOL m_bFlexibleDrag;
533 BOOL m_bAllowBlockRemove;
535 BOOL m_bAllowBlockScale;
536 BOOL m_bAllowBlockMove;
538 BOOL m_bShowWorkArea;
539 BOOL m_bShowTimeLinePosition;
540
541 CString m_strTimeFormat;
543 friend class CXTPTrackControlItem;
544};
545
546AFX_INLINE int CXTPTrackControl::GetTimeLinePosition() const
547{
548 return m_nTimeLinePosition;
549}
550
551AFX_INLINE void CXTPTrackControl::SetWorkArea(int nWorkAreaMin, int nWorkAreaMax)
552{
553 m_nWorkAreaMin = nWorkAreaMin;
554 m_nWorkAreaMax = nWorkAreaMax;
555 RedrawControl();
556}
557
558AFX_INLINE void CXTPTrackControl::SetTimeLineRange(int nTimeScaleMin, int nTimeScaleMax)
559{
560 m_nTimeLineMin = nTimeScaleMin;
561 m_nTimeLineMax = nTimeScaleMax;
562 RedrawControl();
563}
564
565AFX_INLINE int CXTPTrackControl::GetWorkAreaMin() const
566{
567 return m_nWorkAreaMin;
568}
569
570AFX_INLINE int CXTPTrackControl::GetWorkAreaMax() const
571{
572 return m_nWorkAreaMax;
573}
574
575AFX_INLINE int CXTPTrackControl::GetViewPortMin() const
576{
577 return (int)m_nViewPortMin;
578}
579
580AFX_INLINE int CXTPTrackControl::GetViewPortMax() const
581{
582 return (int)m_nViewPortMax;
583}
584
585AFX_INLINE int CXTPTrackControl::GetTimeLineMin() const
586{
587 return m_nTimeLineMin;
588}
589
590AFX_INLINE int CXTPTrackControl::GetTimeLineMax() const
591{
592 return m_nTimeLineMax;
593}
594
595AFX_INLINE int CXTPTrackControl::GetSnapMargin() const
596{
597 return m_nSnapMargin;
598}
599
600AFX_INLINE CRect CXTPTrackControl::GetTimelineArea() const
601{
602 return m_rcTimelineArea;
603}
604
605AFX_INLINE CXTPTrackPaintManager* CXTPTrackControl::GetTrackPaintManager() const
606{
607 return (CXTPTrackPaintManager*)GetPaintManager();
608}
609
610AFX_INLINE CXTPTrackSelectedBlocks* CXTPTrackControl::GetSelectedBlocks() const
611{
612 return m_pSelectedBlocks;
613}
614
615AFX_INLINE CXTPTrackMarkers* CXTPTrackControl::GetMarkers() const
616{
617 return m_pMarkers;
618}
619
620AFX_INLINE CXTPTrackUndoManager* CXTPTrackControl::GetUndoManager() const
621{
622 return m_pUndoManager;
623}
624
625AFX_INLINE void CXTPTrackControl::SetMouseCursorMode(XTPTrackMouseCursorMode enMode)
626{
627 m_mouseCursorMode = enMode;
628}
629
630AFX_INLINE XTPTrackMouseCursorMode CXTPTrackControl::GetMouseCursorMode() const
631{
632 return m_mouseCursorMode;
633}
635# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
636#endif //#if !defined(__XTPTRACKCONTROL_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPGridPaintTheme
XTPGridPaintTheme
Visual theme enumeration.
Definition XTPGridDefines.h:299
XTPTrackMouseCursorMode
XTPTrackMouseCursorMode
Enumeration of operational mouse cursor modes.
Definition XTPTrackControl.h:97
xtpTrackCursorResize
@ xtpTrackCursorResize
User is resizing something.
Definition XTPTrackControl.h:100
xtpTrackCursorDrag
@ xtpTrackCursorDrag
User is dragging something.
Definition XTPTrackControl.h:99
xtpTrackCursorNothing
@ xtpTrackCursorNothing
User is just watching.
Definition XTPTrackControl.h:98
CXTPGridColumn
Represents a grid column item with its properties and operations.
Definition XTPGridColumn.h:107
CXTPGridControl
The CXTPGridControl class provides an implementation of the Grid control.
Definition XTPGridControl.h:479
CXTPGridControl::RedrawControl
void RedrawControl()
Initiates Grid control redrawing.
CXTPGridControl::GetPaintManager
CXTPGridPaintManager * GetPaintManager() const
Gets the paint manager object used to draw the Grid control window.
Definition XTPGridControl.h:4421
CXTPGridControl::SetPaintManager
void SetPaintManager(CXTPGridPaintManager *pPaintManager)
Sets the paint manager object used to draw the Grid control window.
CXTPGridRows
This class represents a rows collection class.
Definition XTPGridRows.h:108
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72
CXTPTrackBlock
This class represents a track control block.
Definition XTPTrackBlock.h:42
CXTPTrackControl
This class represents a track control.
Definition XTPTrackControl.h:113
CXTPTrackControl::GetTimelineArea
CRect GetTimelineArea() const
Gets the time line area.
Definition XTPTrackControl.h:600
CXTPTrackControl::m_arrDragBlocks
CArray< DRAGBLOCK, DRAGBLOCK & > m_arrDragBlocks
The collection of blocks which are being dragged.
Definition XTPTrackControl.h:508
CXTPTrackControl::m_nViewPortMin
double m_nViewPortMin
Minimum value for the view port.
Definition XTPTrackControl.h:479
CXTPTrackControl::AdjustLayout
void AdjustLayout()
Adjusts the layout of the track control when there is a change in the metrics of the control.
CXTPTrackControl::PositionToTrack
int PositionToTrack(int nPosition)
Converts a coordinate point on the track control to a track point.
CXTPTrackControl::StartDragSelection
void StartDragSelection()
Call this function when you are about to start drag selection.
CXTPTrackControl::DoPropExchange
void DoPropExchange(CXTPPropExchange *pPX)
Call this member function to store/load the properties related to the track control.
CXTPTrackControl::m_bSnapToMarkers
BOOL m_bSnapToMarkers
TRUE if the current block is is about to be snapped to the markers, FALSE otherwise.
Definition XTPTrackControl.h:524
CXTPTrackControl::RegisterWindowClass
BOOL RegisterWindowClass(HINSTANCE hInstance=NULL)
Registers the window class if it has not already been registered.
CXTPTrackControl::m_pUndoManager
CXTPTrackUndoManager * m_pUndoManager
The pointer to the undo manager object.
Definition XTPTrackControl.h:512
CXTPTrackControl::GetWorkAreaMax
int GetWorkAreaMax() const
Gets the maximum value of the work area range.
Definition XTPTrackControl.h:570
CXTPTrackControl::GetViewPortMin
int GetViewPortMin() const
Gets the minimum value of the view port.
Definition XTPTrackControl.h:575
CXTPTrackControl::GetTrackColumn
CXTPGridColumn * GetTrackColumn() const
Gets the track column.
CXTPTrackControl::GetWorkAreaMin
int GetWorkAreaMin() const
Gets the minimum value of the work area range.
Definition XTPTrackControl.h:565
CXTPTrackControl::GetViewPortMax
int GetViewPortMax() const
Gets the maximum value of the view port.
Definition XTPTrackControl.h:580
CXTPTrackControl::m_bAllowBlockMove
BOOL m_bAllowBlockMove
Specifies whether the user can move a block.
Definition XTPTrackControl.h:536
CXTPTrackControl::m_bSnapToBlocks
BOOL m_bSnapToBlocks
TRUE if the current block is about to be snapped to the blocks, otherwise.
Definition XTPTrackControl.h:522
CXTPTrackControl::SendMessageToParent
LRESULT SendMessageToParent(UINT nMessage, CXTPTrackBlock *pBlock=NULL, CXTPTrackMarker *pMarker=NULL) const
Sends messages to the parent window of the track control.
CXTPTrackControl::SetWorkArea
void SetWorkArea(int nWorkAreaMin, int nWorkAreaMax)
Sets the bounds of the work area.
Definition XTPTrackControl.h:551
CXTPTrackControl::SetTimeLinePosition
void SetTimeLinePosition(int nTimeLinePos)
Sets the time line position.
CXTPTrackControl::DrawRows
int DrawRows(CDC *pDC, CRect &rcClient, int y, CXTPGridRows *pRows, int nTopRow, int nColumnFrom, int nColumnTo, int *pnHeight)
Draws all rows in the provided device context.
CXTPTrackControl::CXTPTrackControl
CXTPTrackControl()
Constructs a CXTPTrackControl object.
CXTPTrackControl::m_nTimeLineMin
int m_nTimeLineMin
Minimum value for the time line.
Definition XTPTrackControl.h:476
CXTPTrackControl::StartDragBlocks
void StartDragBlocks(BOOL bResize)
Call this function when you are about to start dragging a block.
CXTPTrackControl::m_hResizeCursor
HCURSOR m_hResizeCursor
The cursor while resizing the blocks.
Definition XTPTrackControl.h:518
CXTPTrackControl::m_hMoveCursor
HCURSOR m_hMoveCursor
The cursor while moving the blocks.
Definition XTPTrackControl.h:517
CXTPTrackControl::m_ptStartDrag
CPoint m_ptStartDrag
The point in which dragging starts.
Definition XTPTrackControl.h:457
CXTPTrackControl::SetMouseCursorMode
void SetMouseCursorMode(XTPTrackMouseCursorMode enMode)
Sets the mouse cursor mode.
Definition XTPTrackControl.h:625
CXTPTrackControl::m_nWorkAreaMax
int m_nWorkAreaMax
The maximum value for the work area.
Definition XTPTrackControl.h:486
CXTPTrackControl::m_bFlexibleDrag
BOOL m_bFlexibleDrag
Enables or disables flexible dragging of blocks in the track control.
Definition XTPTrackControl.h:530
CXTPTrackControl::m_strTimeFormat
CString m_strTimeFormat
The string which specifies the time format.
Definition XTPTrackControl.h:541
CXTPTrackControl::GetSnapMargin
int GetSnapMargin() const
Gets the snap margin.
Definition XTPTrackControl.h:595
CXTPTrackControl::GetTimeLinePosition
int GetTimeLinePosition() const
Gets the time line position.
Definition XTPTrackControl.h:546
CXTPTrackControl::m_nSnapMargin
int m_nSnapMargin
The snap margin, specifies the margin that a block must be dragged into before it will snap to anothe...
Definition XTPTrackControl.h:520
CXTPTrackControl::GetTrackPaintManager
CXTPTrackPaintManager * GetTrackPaintManager() const
Gets the track paint manager associated with this control.
Definition XTPTrackControl.h:605
CXTPTrackControl::m_bShowWorkArea
BOOL m_bShowWorkArea
TRUE to show the work area and FALSE to hide it.
Definition XTPTrackControl.h:538
CXTPTrackControl::m_nTimeLinePosition
int m_nTimeLinePosition
The trim line position.
Definition XTPTrackControl.h:488
CXTPTrackControl::SetViewPort
void SetViewPort(int nViewPortMin, int nViewPortMax)
Sets the view port of the work area.
CXTPTrackControl::m_nTimeLineMax
int m_nTimeLineMax
Maximum value for the time line.
Definition XTPTrackControl.h:477
CXTPTrackControl::m_bAllowBlockScale
BOOL m_bAllowBlockScale
Specifies whether the user can resize a block.
Definition XTPTrackControl.h:535
CXTPTrackControl::GetTrackOffset
int GetTrackOffset() const
Gets the track offset.
CXTPTrackControl::SetTimeLineRange
void SetTimeLineRange(int nTimeScaleMin, int nTimeScaleMax)
Sets the time line range.
Definition XTPTrackControl.h:558
CXTPTrackControl::GetTimeLineMin
int GetTimeLineMin() const
Gets the minimum time line position.
Definition XTPTrackControl.h:585
CXTPTrackControl::m_rcTimelineArea
CRect m_rcTimelineArea
The area of the time line.
Definition XTPTrackControl.h:495
CXTPTrackControl::GetUndoManager
CXTPTrackUndoManager * GetUndoManager() const
Gets the undo manager associated with the track control.
Definition XTPTrackControl.h:620
CXTPTrackControl::GetSelectedBlocks
CXTPTrackSelectedBlocks * GetSelectedBlocks() const
Gets the selected blocks in the track control.
Definition XTPTrackControl.h:610
CXTPTrackControl::HitTest
virtual BOOL HitTest(CPoint pt, CXTPGridHitTestInfo *pInfo) const
Determines which grid part, if any, is at a specified point.
CXTPTrackControl::GetTimeLineMax
int GetTimeLineMax() const
Gets the maximum time line position.
Definition XTPTrackControl.h:590
CXTPTrackControl::Populate
void Populate()
Populates the track control with the records.
CXTPTrackControl::m_bScaleOnResize
BOOL m_bScaleOnResize
Specifies whether to scale the track control view area when resizing the track control.
Definition XTPTrackControl.h:527
CXTPTrackControl::GetTrackColumnIndex
int GetTrackColumnIndex() const
Gets the index of the track column.
CXTPTrackControl::TrackToPosition
int TrackToPosition(int nTrack) const
Converts a track point to a coordinate point on the track control.
CXTPTrackControl::m_mouseCursorMode
XTPTrackMouseCursorMode m_mouseCursorMode
Current mouse operation mode.
Definition XTPTrackControl.h:514
CXTPTrackControl::GetMouseCursorMode
XTPTrackMouseCursorMode GetMouseCursorMode() const
Gets the mouse cursor mode.
Definition XTPTrackControl.h:630
CXTPTrackControl::EnsureVisible
void EnsureVisible(CXTPTrackBlock *pBlock)
Call this function to ensure that a specified block is visible.
CXTPTrackControl::m_nViewPortMax
double m_nViewPortMax
Maximum value for the view port.
Definition XTPTrackControl.h:480
CXTPTrackControl::m_nWorkAreaMin
int m_nWorkAreaMin
The minimum value for the work area.
Definition XTPTrackControl.h:485
CXTPTrackControl::m_bAllowBlockRemove
BOOL m_bAllowBlockRemove
Specifies whether the user can move blocks from one track to another.
Definition XTPTrackControl.h:533
CXTPTrackControl::~CXTPTrackControl
~CXTPTrackControl()
Destroys a CXTPTrackControl object, handles cleanup and deallocation.
CXTPTrackControl::SnapPosition
int SnapPosition(int nPosition)
Gets a snap position for a block at a specified position on the track.
CXTPTrackControl::m_pMarkers
CXTPTrackMarkers * m_pMarkers
The marker collection object.
Definition XTPTrackControl.h:493
CXTPTrackControl::AdjustTrackColumnWidth
void AdjustTrackColumnWidth()
Adjusts the track column width.
CXTPTrackControl::GetMarkers
CXTPTrackMarkers * GetMarkers() const
Gets the track markers object associated with the track control.
Definition XTPTrackControl.h:615
CXTPTrackControl::m_pSelectedBlocks
CXTPTrackSelectedBlocks * m_pSelectedBlocks
The pointer to the selected blocks object.
Definition XTPTrackControl.h:511
CXTPTrackControlItem
This class represents a container cell for a set of blocks and keys and inherits basic functionality ...
Definition XTPTrackControlItem.h:45
CXTPTrackMarker
This class represents a track control marker.
Definition XTPTrackBlock.h:438
CXTPTrackMarkers
This class abstracts the track control markers.
Definition XTPTrackBlock.h:539
CXTPTrackPaintManager
This class represents a track control paint manager.
Definition XTPTrackPaintManager.h:41
CXTPTrackSelectedBlocks
This class abstracts the selected blocks of the track control.
Definition XTPTrackBlock.h:671
CXTPTrackUndoManager
This class abstracts an undo manager.
Definition XTPTrackUndoManager.h:371
CXTPTrackControl::DRAGBLOCK
This structure abstracts the state of block being dragged.
Definition XTPTrackControl.h:502
CXTPTrackControl::DRAGBLOCK::pBlock
CXTPTrackBlock * pBlock
Pointer to the block.
Definition XTPTrackControl.h:506
CXTPTrackControl::DRAGBLOCK::nOldLength
int nOldLength
The old length.
Definition XTPTrackControl.h:504
CXTPTrackControl::DRAGBLOCK::rcOrigin
CRect rcOrigin
The original rectangle.
Definition XTPTrackControl.h:505
CXTPTrackControl::DRAGBLOCK::nOldPos
int nOldPos
The old position.
Definition XTPTrackControl.h:503
XTP_NM_TRACKCONTROL
This structure contains notification details.
Definition XTPTrackControl.h:78
XTP_NM_TRACKCONTROL::pBlock
CXTPTrackBlock * pBlock
The track block.
Definition XTPTrackControl.h:80
XTP_NM_TRACKCONTROL::hdr
NMHDR hdr
The NMHDR instance.
Definition XTPTrackControl.h:79
XTP_NM_TRACKCONTROL::pMarker
CXTPTrackMarker * pMarker
The track marker.
Definition XTPTrackControl.h:81


Toolkit Pro: Member List

CXTPShortcutListBoxThemeOfficeXP Member List

This is the complete list of members for CXTPShortcutListBoxThemeOfficeXP, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPControlTheme() | CXTPControlTheme |
CXTPShortcutListBoxTheme() | CXTPShortcutListBoxTheme |
CXTPShortcutListBoxThemeOfficeXP() | CXTPShortcutListBoxThemeOfficeXP |
DrawImage(CDC *pDC, CRect &rcIcon, CXTPImageManagerIcon *pImage, BOOL bEnabled, BOOL bSelected, BOOL bPressed) | CXTPShortcutListBoxThemeOfficeXP | protectedvirtual
DrawItem(CXTPShortcutListBox *pMenuListBox, LPDRAWITEMSTRUCT lpDIS) | CXTPShortcutListBoxTheme | virtual
DrawText(CDC *pDC, CRect &rcText, CXTPShortcutListBox::CONTENT_ITEM *pCI) | CXTPShortcutListBoxThemeOfficeXP | protectedvirtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetBackColor() | CXTPShortcutListBoxTheme |
GetTextColor() | CXTPShortcutListBoxTheme |
GetThemeStyle() const | CXTPControlTheme |
m_crgBack | CXTPShortcutListBoxTheme |
m_crgItemBackHot | CXTPShortcutListBoxTheme |
m_crgItemBackPressed | CXTPShortcutListBoxTheme |
m_crgItemBorder | CXTPShortcutListBoxTheme |
m_crItemText | CXTPShortcutListBoxTheme |
m_crItemTextDisabled | CXTPShortcutListBoxTheme |
m_cxIcon | CXTPShortcutListBoxTheme |
m_cyEdge | CXTPShortcutListBoxTheme |
m_cyIcon | CXTPShortcutListBoxTheme |
m_nTheme | CXTPControlTheme | protected
RefreshMetrics(CXTPShortcutListBox *pList) | CXTPShortcutListBoxThemeOfficeXP | virtual
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static
~CXTPShortcutListBoxTheme() | CXTPShortcutListBoxTheme | virtual


Toolkit Pro: XTPResourceImageList.h Source File

  • Source
  • Common
XTPResourceImageList.h
Go to the documentation of this file.
1
23#if !defined(__XTPRESOURCEIMAGELIST_H__)
24# define __XTPRESOURCEIMAGELIST_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class _XTP_EXT_CLASS CXTPResourceImageList : public CXTPResourceImages
34{
35 DECLARE_DYNCREATE(CXTPResourceImageList)
36 friend class CXTPResourceImage;
37
38public:
39 CXTPResourceImageList();
40 virtual ~CXTPResourceImageList();
41
42 CXTPResourceImage* GetBitmap(UINT nID);
43
44 CXTPResourceImage* SetBitmap(HBITMAP hBitmap, UINT nID, BOOL bAlptha, BOOL bCopyBitmap = TRUE);
45
46 BOOL SetBitmap(CXTPResourceImage* pImage, UINT nID, BOOL bCallAddRef);
47
48 BOOL LoadBitmap(LPCTSTR lpcszPath, UINT nID);
49
50 BOOL Remove(UINT nID);
51 void RemoveAll();
52
53protected:
54 CMap<UINT, UINT, CXTPResourceImage*, CXTPResourceImage*> m_mapID2Image;
55
56protected:
57# ifdef _XTP_ACTIVEX
58 DECLARE_DISPATCH_MAP()
59 DECLARE_INTERFACE_MAP()
60
61 DECLARE_OLETYPELIB_EX(CXTPResourceImageList);
62
63 void OnFinalRelease();
64
65 // Only for Calendar package
66# ifdef XTP_CALENDAR_SITENOTIFY_KEY
67 DECLARE_OLECREATE_EX(CXTPResourceImageList)
68# endif
69
70 BOOL OleAddBitmap(OLE_HANDLE ohBitmap, UINT nID);
71# endif
72};
73
74# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
76#endif // !defined(__XTPRESOURCEIMAGELIST_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPResourceImage
Represent a resource image and provides basic images functions.
Definition XTPResourceImage.h:48
CXTPResourceImages
Implements resource image collection and its operations.
Definition XTPResourceImage.h:257
CXTPResourceImages::LoadBitmap
BOOL LoadBitmap(CBitmap *pBitmap, LPCTSTR lpszResourceName)
Loads a bitmap from the currently assigned resource module.
CXTPResourceImages::RemoveAll
void RemoveAll()
Removes all loaded images only.


Toolkit Pro: Member List

CXTPChartPyramidDiagramBase< BaseDiagram > Member List

This is the complete list of members for CXTPChartPyramidDiagramBase< BaseDiagram >, including all inherited members.

CalculateSeriesLayout(CXTPChartDeviceContext *pDC, CXTPChartDiagramView *pView) | CXTPChartPyramidDiagramBase< BaseDiagram > | virtual
CreateView(CXTPChartDeviceContext *pDC, CXTPChartElementView *pParent)=0 | CXTPChartPyramidDiagramBase< BaseDiagram > | pure virtual
CXTPChartPyramidDiagramBase() | CXTPChartPyramidDiagramBase< BaseDiagram > | protected


Toolkit Pro: Member List

CXTPChartAxisConstantLine Member List

This is the complete list of members for CXTPChartAxisConstantLine, including all inherited members.

CreateLegendDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcBounds) | CXTPChartAxisConstantLine | protectedvirtual
CXTPChartAxisConstantLine() | CXTPChartAxisConstantLine |
CXTPChartElement() | CXTPChartElement |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
DoPropExchange(CXTPPropExchange *pPX) | CXTPChartAxisConstantLine | virtual
GetActualColor() const | CXTPChartAxisConstantLine |
GetActualTextColor() const | CXTPChartAxisConstantLine |
GetAlignment() const | CXTPChartAxisConstantLine |
GetAntialiasing() const | CXTPChartAxisConstantLine | virtual
GetAppearance() const | CXTPChartElement |
GetAxisValue() const | CXTPChartAxisConstantLine |
GetAxisValueInternal() const | CXTPChartAxisConstantLine |
GetContent() const | CXTPChartElement |
GetFont() const | CXTPChartAxisConstantLine | virtual
GetLegendName() const | CXTPChartAxisConstantLine | virtual
GetLineStyle() const | CXTPChartAxisConstantLine |
GetOwner() const | CXTPChartElement |
GetText() const | CXTPChartAxisConstantLine |
GetTextColor() const | CXTPChartAxisConstantLine |
Is3D() const | CXTPChartObject |
IsLegendVisible() const | CXTPChartAxisConstantLine |
IsVisible() const | CXTPChartAxisConstantLine |
m_bAntialiasing | CXTPChartAxisConstantLine | protected
m_bLegendVisible | CXTPChartAxisConstantLine | protected
m_bShowBehind | CXTPChartAxisConstantLine | protected
m_bShowTextBelow | CXTPChartAxisConstantLine | protected
m_bVisible | CXTPChartAxisConstantLine | protected
m_clrColor | CXTPChartAxisConstantLine | protected
m_clrTextColor | CXTPChartAxisConstantLine | protected
m_nAlignment | CXTPChartAxisConstantLine | protected
m_pFont | CXTPChartAxisConstantLine | protected
m_pLineStyle | CXTPChartAxisConstantLine | protected
m_strAxisValue | CXTPChartAxisConstantLine | protected
m_strLegendName | CXTPChartAxisConstantLine | protected
m_strText | CXTPChartAxisConstantLine | protected
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartElement | virtual
Release() | CXTPChartElement | virtual
SetAlignment(XTPChartStringAlignment nAlignment) | CXTPChartAxisConstantLine |
SetAntialiasing(BOOL bAntialiasing) | CXTPChartAxisConstantLine |
SetAxisValue(LPCTSTR lpszValue) | CXTPChartAxisConstantLine |
SetAxisValue(double dValue) | CXTPChartAxisConstantLine |
SetFont(CXTPChartFont *pFont) | CXTPChartAxisConstantLine |
SetLegendName(const CXTPChartString &strName) | CXTPChartAxisConstantLine |
SetLegendVisible(BOOL bVisible) | CXTPChartAxisConstantLine |
SetText(const CXTPChartString &lpszTitle) | CXTPChartAxisConstantLine |
SetTextColor(const CXTPChartColor &clrTextColor) | CXTPChartAxisConstantLine |
SetVisible(BOOL bVisible) | CXTPChartAxisConstantLine |
~CXTPChartAxisConstantLine() | CXTPChartAxisConstantLine | virtual
~CXTPChartElement() | CXTPChartElement | virtual
~CXTPChartLegendItemView() | CXTPChartLegendItemView | inlinevirtual


Toolkit Pro: XTPGridFilterEditControl.h Source File

  • Source
  • GridControl
XTPGridFilterEditControl.h
Go to the documentation of this file.
1
23#if !defined(__XTPGRIDFILTEREDITCONTROL_H__)
24# define __XTPGRIDFILTEREDITCONTROL_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
56class _XTP_EXT_CLASS CXTPGridFilterEditControl : public CEdit
57{
58public:
80 CXTPGridFilterEditControl();
81
86 ~CXTPGridFilterEditControl();
87
88public:
102 BOOL SetGridCtrl(CXTPGridControl* pGridCtrl);
103
105 _XTP_DEPRECATED_IN_FAVOR(SetGridCtrl)
106 BOOL SetReportCtrl(CXTPGridControl* pGridCtrl);
117 CXTPGridControl* GetGridCtrl();
118
120 _XTP_DEPRECATED_IN_FAVOR(GetGridCtrl)
121 CXTPGridControl* GetReportCtrl();
129 void SetText(const CString& lpszText);
130
137 CString GetText() const;
138
151 void SetHint(LPCTSTR lpszHint);
152
163 CString GetHint() const;
164
165protected:
167 DECLARE_MESSAGE_MAP()
168
169 //{{AFX_MSG(CXTPGridFilterEditControl)
170 afx_msg BOOL OnChange();
171 afx_msg void OnPaint();
172 //}}AFX_MSG
175protected:
176 CXTPGridControl* m_pGridCtrl;
177 CString m_strHint;
179};
181AFX_INLINE BOOL CXTPGridFilterEditControl::SetReportCtrl(CXTPGridControl* pGridCtrl)
182{
183 return SetGridCtrl(pGridCtrl);
184}
185
186AFX_INLINE CXTPGridControl* CXTPGridFilterEditControl::GetReportCtrl()
187{
188 return GetGridCtrl();
189}
190
191# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
192#endif //#if !defined(__XTPGRIDFILTEREDITCONTROL_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPGridControl
The CXTPGridControl class provides an implementation of the Grid control.
Definition XTPGridControl.h:479
CXTPGridFilterEditControl
The CXTPGridFilterEditControl class provides the functionality of the filter string edit control asso...
Definition XTPGridFilterEditControl.h:57
CXTPGridFilterEditControl::GetGridCtrl
CXTPGridControl * GetGridCtrl()
Gets the associated Grid control.
CXTPGridFilterEditControl::SetHint
void SetHint(LPCTSTR lpszHint)
Sets the edit hint for the control (i.e.
CXTPGridFilterEditControl::SetGridCtrl
BOOL SetGridCtrl(CXTPGridControl *pGridCtrl)
Sets the associated Grid control.
CXTPGridFilterEditControl::CXTPGridFilterEditControl
CXTPGridFilterEditControl()
Constructs a CXTPGridFilterEditControl object.
CXTPGridFilterEditControl::GetText
CString GetText() const
Gets the edit control text.
CXTPGridFilterEditControl::GetHint
CString GetHint() const
Gets the edit hint of the control (i.e.
CXTPGridFilterEditControl::SetText
void SetText(const CString &lpszText)
Sets the edit control text.
CXTPGridFilterEditControl::~CXTPGridFilterEditControl
~CXTPGridFilterEditControl()
Destroys a CXTPGridFilterEditControl object, handles cleanup and deallocation.


Toolkit Pro: XTPSyntaxEditDrawTextProcessor.h Source File

  • Source
  • SyntaxEdit
XTPSyntaxEditDrawTextProcessor.h
Go to the documentation of this file.
1
23#if !defined(__XTPSYNTAXEDITDRAWTEXTPROCESSOR_H__)
24# define __XTPSYNTAXEDITDRAWTEXTPROCESSOR_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
34template<class TYPE, class ARG_TYPE>
35class CXTPReserveArray : protected CArray<TYPE, ARG_TYPE>
36{
37 typedef CArray<TYPE, ARG_TYPE> Parent;
38
39protected:
40 int m_nDataSize;
41
42public:
43 CXTPReserveArray()
44 {
45 m_nDataSize = 0;
46 }
47
48 int GetDataSize() const
49 {
50 return m_nDataSize;
51 }
52
53 void SetDataSize(int nDataSize, int nReservedSize = -1, int nGrowBy = -1)
54 {
55 _ASSERTE(nReservedSize == -1 || nReservedSize >= nDataSize);
56 nReservedSize = max(nReservedSize, nDataSize);
57
58 m_nDataSize = nDataSize;
59 CArray<TYPE, ARG_TYPE>::SetSize(nReservedSize, nGrowBy);
60 }
61
62 void AddData(ARG_TYPE newElement)
63 {
64 CArray<TYPE, ARG_TYPE>::SetAtGrow(m_nDataSize, newElement);
65 m_nDataSize++;
66 }
67
68 void RemoveAll()
69 {
70 m_nDataSize = 0;
71 }
72
73 TYPE operator[](int nIndex) const
74 {
75 _ASSERTE(nIndex >= 0 && nIndex < GetDataSize());
76 return CArray<TYPE, ARG_TYPE>::GetAt(nIndex);
77 }
78 TYPE& operator[](int nIndex)
79 {
80 _ASSERTE(nIndex >= 0 && nIndex < GetDataSize());
81 return CArray<TYPE, ARG_TYPE>::ElementAt(nIndex);
82 }
83
84 // Direct Access to the element data (may return NULL)
85 const TYPE* GetData() const
86 {
87 return CArray<TYPE, ARG_TYPE>::GetData();
88 }
89
90 TYPE* GetData()
91 {
92 return CArray<TYPE, ARG_TYPE>::GetData();
93 }
94};
103class _XTP_EXT_CLASS CXTPSyntaxEditDrawTextProcessor
104{
105public:
110 CXTPSyntaxEditDrawTextProcessor();
111
120 CRect GetTextRect() const;
121
129 void SetTextRect(const CRect& rcRect);
130
139 int GetRowHeight() const;
140
151 int RecalcRowHeight(CDC* pDC, CFont* pFont);
152
163 int GetRowsCount(BOOL bWithPartlyVisible) const;
164
173 int GetTabSize() const;
174
184 void SetTabSize(int nTabSize);
185
194 int GetScrollXOffset() const;
195
203 void SetScrollXOffset(int nOffsetX);
204
213 const TEXTMETRIC& GetTextMetrics() const;
214
223 int GetSpaceWidth() const;
224
236 int AlignColIdxToTabs(int nRow, int nCol, BOOL bVirtualSpace = FALSE);
237
252 int GetColPosX(int nRow, int nCol, int* pnCharWidth = NULL, BOOL bVirtualSpace = FALSE) const;
253
267 BOOL ColFromXPos(int nRow, int nX, int& rnCol, BOOL bVirtualSpace = FALSE) const;
268
278 int GetRowWidth(int nRow) const;
279
288 int GetRowsMaxWidth() const;
289
304 BOOL HitTest(const CPoint& pt, int& rnRow, int& rnCol, BOOL bVirtualSpace = FALSE) const;
305
317 BOOL HitTestRow(int nY, int& rnRow) const;
318
326 void ResetRowInfo(int nRow);
327
341 int DrawRowPart(CDC* pDC, int nRow, LPCTSTR pcszText, int nchCount = -1);
342
362 int PrintRowPart(CDC* pDC, int nRow, int nPosY, UINT nFlags, LPCTSTR pcszText,
363 int nchCount = -1, int* pnPrintedTextLen = NULL);
364
375 int ExpandChars(LPCTSTR pszChars, CString& strBuffer, int nDispPos = 0,
376 BOOL bEnableWhiteSpace = FALSE);
377
384 void SetRowTabPositions(int nRow, LPCTSTR pcszOrigRowText);
385
395 int DispPosToStrPos(int nRow, int nDispPos, BOOL bVirtualSpace) const;
396
406 int StrPosToDispPos(int nRow, int nStrPos, BOOL bVirtualSpace = FALSE) const;
407
422 CPoint SetCaretPos(CWnd* pWnd, const CSize& szSize, int nRow, int& rnCol,
423 BOOL bHideCaret = FALSE, BOOL bVirtualSpace = FALSE);
424
439 CPoint SetCaretByPoint(CWnd* pWnd, const CPoint& pt, const CSize& szSize, int& rnRow,
440 int& rnCol, BOOL bVirtualSpace = FALSE);
441
442public:
444 class _XTP_EXT_CLASS CXTPRowInfo : public CXTPCmdTarget
445 {
446 public:
447 CXTPRowInfo()
448 {
449 nMaxWidth = 0;
450 const int cnReservedSize = 4096;
451 arCharsEnds.SetDataSize(0, cnReservedSize, cnReservedSize);
452
453 arTabs.SetDataSize(0, cnReservedSize, cnReservedSize);
454 arDispCol2StrPos.SetDataSize(0, cnReservedSize, cnReservedSize);
455 arStrPos2DispCol.SetDataSize(0, cnReservedSize, cnReservedSize);
456 }
457
458 void Reset()
459 {
460 nMaxWidth = 0;
461 arCharsEnds.RemoveAll();
462 }
463
464 int nMaxWidth;
465
466 CXTPReserveArray<int, int> arCharsEnds;
467
468 CXTPReserveArray<BYTE, BYTE> arTabs;
469 CXTPReserveArray<int, int> arDispCol2StrPos;
470 CXTPReserveArray<int, int> arStrPos2DispCol;
471 };
472
473 CXTPRowInfo* GetRowInfo(int nRow) const;
476private:
477 void DrawTextOfSize(CDC* pDC, int nX, int nY, const SIZE& textSize, const RECT& rcText,
478 LPCTSTR pcszText, int nchCount) const;
479
480protected:
481 int m_nTabSize;
482 TEXTMETRIC m_tmText;
483 int m_nSpaceWidth;
485 CRect m_rcTextRect;
486 int m_nRowHeight;
487 int m_nScrollXOffset;
489 int m_nDrawingRow;
490 int m_nNextRowPosX;
492 int m_nPrintingRow;
493 CPoint m_ptNextPrintPos;
494 BOOL m_bUseOutputDC;
497 typedef CXTPInternalCollectionT<CXTPRowInfo> CXTPRowsInfoArray;
498 mutable CXTPRowsInfoArray m_arRows;
501protected:
503 // temporary buffers
504 CArray<int, int> m_arBuf_aDx;
505 CXTPReserveArray<TCHAR, TCHAR> m_arExpandCharsBuffer;
507};
508
509AFX_INLINE const TEXTMETRIC& CXTPSyntaxEditDrawTextProcessor::GetTextMetrics() const
510{
511 return m_tmText;
512}
513AFX_INLINE CRect CXTPSyntaxEditDrawTextProcessor::GetTextRect() const
514{
515 return m_rcTextRect;
516}
517AFX_INLINE void CXTPSyntaxEditDrawTextProcessor::SetTextRect(const CRect& rcRect)
518{
519 m_rcTextRect = rcRect;
520}
521AFX_INLINE int CXTPSyntaxEditDrawTextProcessor::GetRowHeight() const
522{
523 return m_nRowHeight;
524}
525AFX_INLINE int CXTPSyntaxEditDrawTextProcessor::GetTabSize() const
526{
527 return m_nTabSize;
528}
529AFX_INLINE void CXTPSyntaxEditDrawTextProcessor::SetTabSize(int nTabSize)
530{
531 m_nTabSize = nTabSize;
532}
533AFX_INLINE int CXTPSyntaxEditDrawTextProcessor::GetScrollXOffset() const
534{
535 return m_nScrollXOffset;
536}
537AFX_INLINE int CXTPSyntaxEditDrawTextProcessor::GetRowsCount(BOOL bWithPartlyVisible) const
538{
539 int nHeight = m_rcTextRect.Height();
540 int nRowH = max(1, m_nRowHeight);
541 int nPartly = bWithPartlyVisible ? 1 : 0;
542
543 return nHeight / nRowH + ((nHeight % nRowH) ? nPartly : 0);
544}
545AFX_INLINE int CXTPSyntaxEditDrawTextProcessor::GetSpaceWidth() const
546{
547 return m_nSpaceWidth;
548}
549
550# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
552#endif // !defined(__XTPSYNTAXEDITDRAWTEXTPROCESSOR_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPInternalCollectionT
Definition XTPSmartPtrInternalT.h:387
CXTPSyntaxEditDrawTextProcessor
This helper class is used by CXTPSyntaxEditCtrl as the Draw Text Processor.
Definition XTPSyntaxEditDrawTextProcessor.h:104
CXTPSyntaxEditDrawTextProcessor::AlignColIdxToTabs
int AlignColIdxToTabs(int nRow, int nCol, BOOL bVirtualSpace=FALSE)
Aligns a specified column index to tab borders.
CXTPSyntaxEditDrawTextProcessor::m_nDrawingRow
int m_nDrawingRow
Currently drawing row.
Definition XTPSyntaxEditDrawTextProcessor.h:489
CXTPSyntaxEditDrawTextProcessor::GetRowHeight
int GetRowHeight() const
Gets the height of a single row.
Definition XTPSyntaxEditDrawTextProcessor.h:521
CXTPSyntaxEditDrawTextProcessor::RecalcRowHeight
int RecalcRowHeight(CDC *pDC, CFont *pFont)
Recalculates the height of a single row.
CXTPSyntaxEditDrawTextProcessor::StrPosToDispPos
int StrPosToDispPos(int nRow, int nStrPos, BOOL bVirtualSpace=FALSE) const
Converts string position to display position.
CXTPSyntaxEditDrawTextProcessor::GetTextRect
CRect GetTextRect() const
Gets the text rectangle.
Definition XTPSyntaxEditDrawTextProcessor.h:513
CXTPSyntaxEditDrawTextProcessor::GetSpaceWidth
int GetSpaceWidth() const
Gets the space character width, in pixels.
Definition XTPSyntaxEditDrawTextProcessor.h:545
CXTPSyntaxEditDrawTextProcessor::SetCaretByPoint
CPoint SetCaretByPoint(CWnd *pWnd, const CPoint &pt, const CSize &szSize, int &rnRow, int &rnCol, BOOL bVirtualSpace=FALSE)
Sets the caret position.
CXTPSyntaxEditDrawTextProcessor::SetCaretPos
CPoint SetCaretPos(CWnd *pWnd, const CSize &szSize, int nRow, int &rnCol, BOOL bHideCaret=FALSE, BOOL bVirtualSpace=FALSE)
Sets the caret position.
CXTPSyntaxEditDrawTextProcessor::GetTextMetrics
const TEXTMETRIC & GetTextMetrics() const
Gets the current text metrics.
Definition XTPSyntaxEditDrawTextProcessor.h:509
CXTPSyntaxEditDrawTextProcessor::ExpandChars
int ExpandChars(LPCTSTR pszChars, CString &strBuffer, int nDispPos=0, BOOL bEnableWhiteSpace=FALSE)
Expands the character set by putting spaces in the position of tabs.
CXTPSyntaxEditDrawTextProcessor::m_nPrintingRow
int m_nPrintingRow
Currently printing row.
Definition XTPSyntaxEditDrawTextProcessor.h:492
CXTPSyntaxEditDrawTextProcessor::m_nRowHeight
int m_nRowHeight
Row height.
Definition XTPSyntaxEditDrawTextProcessor.h:486
CXTPSyntaxEditDrawTextProcessor::m_tmText
TEXTMETRIC m_tmText
Text metrics.
Definition XTPSyntaxEditDrawTextProcessor.h:482
CXTPSyntaxEditDrawTextProcessor::GetRowWidth
int GetRowWidth(int nRow) const
Retrieves the width (in pixels) of a specified row.
CXTPSyntaxEditDrawTextProcessor::m_nScrollXOffset
int m_nScrollXOffset
Scroll offset for the x- coordinate.
Definition XTPSyntaxEditDrawTextProcessor.h:487
CXTPSyntaxEditDrawTextProcessor::PrintRowPart
int PrintRowPart(CDC *pDC, int nRow, int nPosY, UINT nFlags, LPCTSTR pcszText, int nchCount=-1, int *pnPrintedTextLen=NULL)
Use this member function to draw row part and store characters positions.
CXTPSyntaxEditDrawTextProcessor::GetRowsMaxWidth
int GetRowsMaxWidth() const
Gets the maximum width (in pixels) of all visible rows.
CXTPSyntaxEditDrawTextProcessor::DrawRowPart
int DrawRowPart(CDC *pDC, int nRow, LPCTSTR pcszText, int nchCount=-1)
Draws the row part and stores character positions.
CXTPSyntaxEditDrawTextProcessor::HitTestRow
BOOL HitTestRow(int nY, int &rnRow) const
Gets the row, if any, at a specified y- position.
CXTPSyntaxEditDrawTextProcessor::SetTextRect
void SetTextRect(const CRect &rcRect)
Sets the text rectangle.
Definition XTPSyntaxEditDrawTextProcessor.h:517
CXTPSyntaxEditDrawTextProcessor::GetScrollXOffset
int GetScrollXOffset() const
Gets the scroll offset for the x- coordinate.
Definition XTPSyntaxEditDrawTextProcessor.h:533
CXTPSyntaxEditDrawTextProcessor::GetTabSize
int GetTabSize() const
Gets the tab size.
Definition XTPSyntaxEditDrawTextProcessor.h:525
CXTPSyntaxEditDrawTextProcessor::ColFromXPos
BOOL ColFromXPos(int nRow, int nX, int &rnCol, BOOL bVirtualSpace=FALSE) const
Gets the column at a specified x- position.
CXTPSyntaxEditDrawTextProcessor::m_bUseOutputDC
BOOL m_bUseOutputDC
TRUE to use the output DC for calculations.
Definition XTPSyntaxEditDrawTextProcessor.h:494
CXTPSyntaxEditDrawTextProcessor::m_nNextRowPosX
int m_nNextRowPosX
x- offset to draw the next row part.
Definition XTPSyntaxEditDrawTextProcessor.h:490
CXTPSyntaxEditDrawTextProcessor::GetRowsCount
int GetRowsCount(BOOL bWithPartlyVisible) const
Gets the number of visible rows for the text rectangle.
Definition XTPSyntaxEditDrawTextProcessor.h:537
CXTPSyntaxEditDrawTextProcessor::m_ptNextPrintPos
CPoint m_ptNextPrintPos
x- and y- offset to print the next row part.
Definition XTPSyntaxEditDrawTextProcessor.h:493
CXTPSyntaxEditDrawTextProcessor::GetColPosX
int GetColPosX(int nRow, int nCol, int *pnCharWidth=NULL, BOOL bVirtualSpace=FALSE) const
Gets the starting x- position of a specified column.
CXTPSyntaxEditDrawTextProcessor::DispPosToStrPos
int DispPosToStrPos(int nRow, int nDispPos, BOOL bVirtualSpace) const
Converts display position to string position.
CXTPSyntaxEditDrawTextProcessor::SetScrollXOffset
void SetScrollXOffset(int nOffsetX)
Sets the scroll offset for the x- coordinate.
CXTPSyntaxEditDrawTextProcessor::m_rcTextRect
CRect m_rcTextRect
Text rectangle.
Definition XTPSyntaxEditDrawTextProcessor.h:485
CXTPSyntaxEditDrawTextProcessor::m_nSpaceWidth
int m_nSpaceWidth
Space character width.
Definition XTPSyntaxEditDrawTextProcessor.h:483
CXTPSyntaxEditDrawTextProcessor::SetTabSize
void SetTabSize(int nTabSize)
Sets the tab size.
Definition XTPSyntaxEditDrawTextProcessor.h:529
CXTPSyntaxEditDrawTextProcessor::ResetRowInfo
void ResetRowInfo(int nRow)
Clears the cached row information of a specified row.
CXTPSyntaxEditDrawTextProcessor::SetRowTabPositions
void SetRowTabPositions(int nRow, LPCTSTR pcszOrigRowText)
Sets the tab positions for a specified row.
CXTPSyntaxEditDrawTextProcessor::HitTest
BOOL HitTest(const CPoint &pt, int &rnRow, int &rnCol, BOOL bVirtualSpace=FALSE) const
Gets the row and column, if any, at a specified point.
CXTPSyntaxEditDrawTextProcessor::m_nTabSize
int m_nTabSize
Tab size.
Definition XTPSyntaxEditDrawTextProcessor.h:481
CXTPSyntaxEditDrawTextProcessor::CXTPSyntaxEditDrawTextProcessor
CXTPSyntaxEditDrawTextProcessor()
Default object constructor.


Toolkit Pro: Member List

CXTPIconHandle Member List

This is the complete list of members for CXTPIconHandle, including all inherited members.

CXTPIconHandle() | CXTPIconHandle |
CXTPIconHandle(HICON hIcon) | CXTPIconHandle |
GetExtent() const | CXTPIconHandle |
GetExtent(HICON hIcon) | CXTPIconHandle | static
m_hIcon | CXTPIconHandle | protected
operator HICON() const | CXTPIconHandle |
operator=(HICON hIcon) | CXTPIconHandle |
ScaleToFit(CSize desiredExtent) const | CXTPIconHandle |
ScaleToFit(HICON hIcon, CSize desiredExtent) | CXTPIconHandle | static
~CXTPIconHandle() | CXTPIconHandle | virtual


Toolkit Pro: Member List

CXTPChartAxisCustomLabel Member List

This is the complete list of members for CXTPChartAxisCustomLabel, including all inherited members.

CXTPChartAxisCustomLabel() | CXTPChartAxisCustomLabel |
CXTPChartElement() | CXTPChartElement |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
DoPropExchange(CXTPPropExchange *pPX) | CXTPChartAxisCustomLabel | virtual
GetAppearance() const | CXTPChartElement |
GetAxisValue() const | CXTPChartAxisCustomLabel |
GetAxisValueInternal() const | CXTPChartAxisCustomLabel |
GetContent() const | CXTPChartElement |
GetOwner() const | CXTPChartElement |
GetText() const | CXTPChartAxisCustomLabel |
Is3D() const | CXTPChartObject |
m_strAxisValue | CXTPChartAxisCustomLabel | protected
m_strText | CXTPChartAxisCustomLabel | protected
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartElement | virtual
Release() | CXTPChartElement | virtual
SetAxisValue(LPCTSTR lpszValue) | CXTPChartAxisCustomLabel |
SetAxisValue(double dValue) | CXTPChartAxisCustomLabel |
SetText(const CXTPChartString &lpszTitle) | CXTPChartAxisCustomLabel |
~CXTPChartAxisCustomLabel() | CXTPChartAxisCustomLabel | virtual
~CXTPChartElement() | CXTPChartElement | virtual


Toolkit Pro: Member List

CXTPControlLabel Member List

This is the complete list of members for CXTPControlLabel, including all inherited members.

AssignDocTemplate(UINT nIDResource) | CXTPControl |
ClickToolBarButton(CRect rcActiveRect=CRect(0, 0, 0, 0)) | CXTPControl | protected
Compare(CXTPControl *pOther) | CXTPControl | virtual
Copy(CXTPControl *pControl, BOOL bRecursive=FALSE) | CXTPControl | virtual
CustomizeStartDrag(CPoint point) | CXTPControl | protectedvirtual
CustomizeStartResize(CPoint point) | CXTPControl | protectedvirtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPControl() | CXTPControl | protected
DelayLayoutParent() | CXTPControl |
DelayRedrawParent() | CXTPControl |
DoCustomDragOver(CXTPCommandBar *pCommandBar, CPoint point, DROPEFFECT &dropEffect) | CXTPControl | protectedvirtual
DoPropExchange(CXTPPropExchange *pPX) | CXTPControl | virtual
Draw(CDC *pDC) | CXTPControl | virtual
ExcludeDocTemplate(UINT nIDResource) | CXTPControl |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
FromUI(CCmdUI *pCmdUI) | CXTPControl | static
GenerateCommandBarList(DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam) | CXTPControl | protectedvirtual
GetAction() const | CXTPControl |
GetBeginGroup() const | CXTPControl |
GetButtonSize() const | CXTPControl | virtual
GetCaption() const | CXTPControl | virtual
GetCategory() const | CXTPControl |
GetChecked() const | CXTPControl |
GetCloseSubMenuOnClick() const | CXTPControl |
GetCommandBar() const | CXTPControl | virtual
GetControls() const | CXTPControl |
GetCustomizeMinHeight() const | CXTPControl | protectedvirtual
GetCustomizeMinWidth() const | CXTPControl | protectedvirtual
GetCustomShortcutText() const | CXTPControl |
GetDescription() const | CXTPControl | virtual
GetEnabled() const | CXTPControl |
GetExecuteOnPressInterval() const | CXTPControl |
GetExpanded() const | CXTPControl |
GetFlags() const | CXTPControl |
GetHeight() const | CXTPControl |
GetHelpId() const | CXTPControl |
GetHideFlags() const | CXTPControl |
GetIconId() const | CXTPControl |
GetIconSize() const | CXTPControl | virtual
GetID() const | CXTPControl |
GetImage(int nWidth=16) const | CXTPControl | virtual
GetImageManager() const | CXTPControl |
GetIndex() const | CXTPControl |
GetKeyboardTip() const | CXTPControl |
GetPaintManager() const | CXTPControl |
GetParameter() const | CXTPControl |
GetParent() const | CXTPControl |
GetPopuped() const | CXTPControl | virtual
GetPressed() const | CXTPControl | virtual
GetRect() const | CXTPControl |
GetRibbonGroup() const | CXTPControl |
GetRowRect() const | CXTPControl |
GetShortcutText() const | CXTPControl |
GetSize(CDC *pDC) | CXTPControl | virtual
GetStyle() const | CXTPControl |
GetTag() const | CXTPControl |
GetTooltip() const | CXTPControl | virtual
GetType() const | CXTPControl |
GetWidth() const | CXTPControl |
GetWrap() const | CXTPControl |
HasDwmCompositedRect() const | CXTPControl |
IsCaptionVisible() const | CXTPControl | virtual
IsCursorOver() const | CXTPControl |
IsCustomizeMode() const | CXTPControl | protected
IsCustomizeMovable() const | CXTPControl | virtual
IsCustomizeResizeAllow() const | CXTPControl | protectedvirtual
IsFocusable() const | CXTPControl | protectedvirtual
IsFocused() const | CXTPControl | virtual
IsItemDefault() const | CXTPControl |
IsLayoutChanged() | CXTPControl | protected
IsLayoutRTL() const | CXTPControl | protected
IsOnQuickAccess() const | CXTPControl |
IsTemporary() const | CXTPControl |
IsTransparent() const | CXTPControl | inlinevirtual
IsVisible(DWORD dwSkipFlags=0) const | CXTPControl | virtual
m_bBeginGroup | CXTPControl | protected
m_bChecked | CXTPControl | protected
m_bCloseSubMenuOnClick | CXTPControl | protected
m_bDefaultItem | CXTPControl | protected
m_bEnabled | CXTPControl | protected
m_bExpanded | CXTPControl | protected
m_bLayoutRTL | CXTPControl | protected
m_bOnQuickAccess | CXTPControl | protected
m_bPressed | CXTPControl | protected
m_bSelected | CXTPControl | protected
m_bTemporary | CXTPControl | protected
m_buttonCustomStyle | CXTPControl | protected
m_buttonRibbonStyle | CXTPControl | protected
m_buttonStyle | CXTPControl | protected
m_bWrap | CXTPControl | protected
m_controlType | CXTPControl | protected
m_dwFlags | CXTPControl | protected
m_dwHideFlags | CXTPControl | protected
m_mapDocTemplatesAssigned | CXTPControl | protected
m_mapDocTemplatesExcluded | CXTPControl | protected
m_nCustomIconId | CXTPControl | protected
m_nExecuteOnPressInterval | CXTPControl | protected
m_nHeight | CXTPControl | protected
m_nHelpId | CXTPControl | protected
m_nIconId | CXTPControl | protected
m_nId | CXTPControl | protected
m_nIndex | CXTPControl | protected
m_nTag | CXTPControl | protected
m_nWidth | CXTPControl | protected
m_pAction | CXTPControl | protected
m_pControls | CXTPControl | protected
m_pParent | CXTPControl | protected
m_pRibbonGroup | CXTPControl | protected
m_rcControl | CXTPControl | protected
m_rcRow | CXTPControl | protected
m_strCaption | CXTPControl | protected
m_strCategory | CXTPControl | protected
m_strCustomCaption | CXTPControl | protected
m_strDescriptionText | CXTPControl | protected
m_strKeyboardTip | CXTPControl | protected
m_strParameter | CXTPControl | protected
m_strShortcutText | CXTPControl | protected
m_strShortcutTextAuto | CXTPControl | protected
m_strTooltipText | CXTPControl | protected
m_szIcon | CXTPControl | protected
NotifySite(UINT code) | CXTPControl |
NotifySite(UINT code, NMXTPCONTROL *pNM) | CXTPControl |
NotifySite(CWnd *pSite, UINT code, NMXTPCONTROL *pNM) | CXTPControl |
OnActionChanged(int nProperty) | CXTPControl | protectedvirtual
OnActionChanging(int nProperty) | CXTPControl | protectedvirtual
OnCalcDynamicSize(DWORD dwMode) | CXTPControl | virtual
OnCaptionChanged() | CXTPControl | protectedvirtual
OnCustomizeDragOver(CXTPControl *pDataObject, CPoint point, DROPEFFECT &dropEffect) | CXTPControl | protectedvirtual
OnCustomizeMouseMove(CPoint point) | CXTPControl | protected
OnEnabledChanged() | CXTPControl | virtual
OnExecute() | CXTPControl | virtual
OnHookKeyDown(UINT nChar, LPARAM lParam) | CXTPControl | protectedvirtual
OnHookMouseWheel(UINT nFlags, short zDelta, CPoint point) | CXTPControl | protectedvirtual
OnIdleUpdate() | CXTPControl | protectedvirtual
OnLButtonDblClk(CPoint point) | CXTPControl | protectedvirtual
OnLButtonDown(CPoint point) | CXTPControl | protectedvirtual
OnLButtonUp(CPoint point) | CXTPControl | protectedvirtual
OnMouseHover() | CXTPControl | protectedvirtual
OnMouseMove(CPoint point) | CXTPControl | protectedvirtual
OnRButtonDown(CPoint point) | CXTPControl | protectedvirtual
OnRButtonUp(CPoint point) | CXTPControl | protectedvirtual
OnRemoved() | CXTPControl | protectedvirtual
OnSetPopup(BOOL bPopup) | CXTPControl | protectedvirtual
OnSetSelected(int bSelected) | CXTPControl | protectedvirtual
OnThemeChanged() | CXTPControl | virtual
OnToolHitTest(CPoint point, TOOLINFO *pTI) const | CXTPControl | protectedvirtual
OnUnderlineActivate() | CXTPControl | virtual
RedrawParent(BOOL bAnimate=TRUE) | CXTPControl |
Reset() | CXTPControl |
RestoreCommandBarList(CXTPCommandBarList *pCommandBarList) | CXTPControl | protectedvirtual
ScreenToClient(CPoint *point) | CXTPControl | protected
SetAction(CXTPControlAction *pAction) | CXTPControl | virtual
SetBeginGroup(BOOL bBeginGroup) | CXTPControl | virtual
SetCaption(LPCTSTR lpszCaption) | CXTPControl |
SetCaption(UINT nIDCaption) | CXTPControl |
SetCategory(LPCTSTR lpszCategory) | CXTPControl |
SetChecked(BOOL bChecked) | CXTPControl | virtual
SetCloseSubMenuOnClick(BOOL bCloseOnClick) | CXTPControl |
SetCustomIcon(HICON hIcon) | CXTPControl |
SetCustomShortcutText(LPCTSTR lpszCustomShortcutText) | CXTPControl |
SetDescription(LPCTSTR lpszDescription) | CXTPControl |
SetEnabled(BOOL bEnabled) | CXTPControl | virtual
SetExecuteOnPressInterval(int nExecuteOnPressInterval) | CXTPControl |
SetExpanded(BOOL bExpanded) | CXTPControl | protected
SetFlags(DWORD dwFlags) | CXTPControl |
SetFocused(BOOL bFocused) | CXTPControl | virtual
SetHeight(int nHeight) | CXTPControl | virtual
SetHelpId(int nId) | CXTPControl |
SetHideFlag(XTPControlHideFlags dwFlag, BOOL bSet) | CXTPControl |
SetHideFlags(DWORD dwFlags) | CXTPControl | virtual
SetHideWrap(BOOL bHide) | CXTPControl |
SetIconId(int nId) | CXTPControl |
SetIconSize(CSize szIcon) | CXTPControl |
SetID(int nId) | CXTPControl |
SetIndex(int nIndex) | CXTPControl | inlineprotected
SetItemDefault(BOOL bDefault) | CXTPControl |
SetKeyboardTip(LPCTSTR lpszKeyboardTip) | CXTPControl |
SetOnQuickAccess(BOOL bOnQuicAccess=FALSE) | CXTPControl |
SetParameter(LPCTSTR lpszParameter) | CXTPControl |
SetParent(CXTPCommandBar *pParent) | CXTPControl | inlineprotectedvirtual
SetPressed(BOOL bPressed) | CXTPControl |
SetPrompt(LPCTSTR lpszPrompt) | CXTPControl |
SetRect(CRect rcControl) | CXTPControl | virtual
SetRowRect(CRect rcRow) | CXTPControl |
SetShortcutText(LPCTSTR lpszShortcutText) | CXTPControl |
SetStyle(XTPButtonStyle buttonStyle) | CXTPControl |
SetTag(DWORD_PTR dwTag) | CXTPControl |
SetTooltip(LPCTSTR lpszTooltip) | CXTPControl |
SetVisible(BOOL bVisible) | CXTPControl |
SetWidth(int nWidth) | CXTPControl | virtual
SetWrap(BOOL bWrap) | CXTPControl |
~CXTPControl() | CXTPControl | protectedvirtual


Toolkit Pro: XTPRibbonQuickAccessControls.h Source File

  • Source
  • Ribbon
XTPRibbonQuickAccessControls.h
Go to the documentation of this file.
1
23#if !defined(__XTPRIBBONQUICKACCESSCONTROLS_H__)
24# define __XTPRIBBONQUICKACCESSCONTROLS_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPRibbonControls : public CXTPControls
39{
41 DECLARE_DYNCREATE(CXTPRibbonControls)
43public:
48 CXTPRibbonControls();
49
50protected:
56 virtual void OnControlRemoved(CXTPControl* pControl);
57
66 virtual BOOL OnControlRemoving(CXTPControl* pControl);
67
76 virtual BOOL ShouldSerializeControl(CXTPControl* pControl);
77
84 virtual void Copy(CXTPControls* pControls, BOOL bRecursive = FALSE);
85};
86
92class _XTP_EXT_CLASS CXTPRibbonQuickAccessControls : public CXTPControls
93{
94public:
99 CXTPRibbonQuickAccessControls();
100
105 virtual ~CXTPRibbonQuickAccessControls();
106
107public:
113 void Remove(CXTPControl* pControl);
114
119 void Reset();
120
128 CXTPControl* FindDuplicate(CXTPControl* pControl);
129
137 int IndexOf(CXTPControl* pControl) const;
138
139protected:
145 virtual void OnControlAdded(CXTPControl* pControl);
146
152 virtual void OnControlRemoved(CXTPControl* pControl);
153
154protected:
156 virtual void RefreshIndexes();
158};
159
160# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
162#endif // !defined(__XTPRIBBONQUICKACCESSCONTROLS_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPControl
CXTPControl is a CXTPCmdTarget derived class.
Definition XTPControl.h:841
CXTPControls
CXTPControls is a CXTPCmdTarget derived class.
Definition XTPControls.h:47
CXTPRibbonControls
CXTPRibbonControls is a CXTPControls derived class.
Definition XTPRibbonQuickAccessControls.h:39
CXTPRibbonControls::CXTPRibbonControls
CXTPRibbonControls()
Constructs a CXTPRibbonControls object.
CXTPRibbonControls::Copy
virtual void Copy(CXTPControls *pControls, BOOL bRecursive=FALSE)
This method is called to copy controls.
CXTPRibbonControls::ShouldSerializeControl
virtual BOOL ShouldSerializeControl(CXTPControl *pControl)
This method is called to check if a control has changed and must be saved.
CXTPRibbonControls::OnControlRemoving
virtual BOOL OnControlRemoving(CXTPControl *pControl)
This method is called when a control is about to be removed from the collection.
CXTPRibbonControls::OnControlRemoved
virtual void OnControlRemoved(CXTPControl *pControl)
This method is called when a control is removed from the collection.
CXTPRibbonQuickAccessControls
CXTPRibbonQuickAccessControls is a CXTPControls derived class.
Definition XTPRibbonQuickAccessControls.h:93
CXTPRibbonQuickAccessControls::OnControlAdded
virtual void OnControlAdded(CXTPControl *pControl)
This method is called when a control is added to the collection.
CXTPRibbonQuickAccessControls::Reset
void Reset()
Call this method to reset Quick Access controls.
CXTPRibbonQuickAccessControls::FindDuplicate
CXTPControl * FindDuplicate(CXTPControl *pControl)
Call this method to find a duplicate of a control.
CXTPRibbonQuickAccessControls::~CXTPRibbonQuickAccessControls
virtual ~CXTPRibbonQuickAccessControls()
Destroys a CXTPRibbonQuickAccessControls object, handles cleanup and deallocation.
CXTPRibbonQuickAccessControls::Remove
void Remove(CXTPControl *pControl)
Call this member to remove a control.
CXTPRibbonQuickAccessControls::CXTPRibbonQuickAccessControls
CXTPRibbonQuickAccessControls()
Constructs a CXTPRibbonQuickAccessControls object.
CXTPRibbonQuickAccessControls::IndexOf
int IndexOf(CXTPControl *pControl) const
Retrieves the index of a specified control from the Quick Access bar.
CXTPRibbonQuickAccessControls::OnControlRemoved
virtual void OnControlRemoved(CXTPControl *pControl)
This method is called when a control is removed from the collection.


Toolkit Pro: Member List

CXTPDialogBar Member List

This is the complete list of members for CXTPDialogBar, including all inherited members.

CalcDockingLayout(int nLength, DWORD dwMode, int nWidth) | CXTPDialogBar | protectedvirtual
CalcDynamicLayout(int nLength, DWORD dwMode) | CXTPDialogBar | protectedvirtual
CalcSize(int nLength, DWORD dwMode, CSize szClient) | CXTPDialogBar | protected
Copy(CXTPCommandBar *pCommandBar, BOOL bRecursive=FALSE) | CXTPToolBar | protectedvirtual
Create(CWnd *pParentWnd, BOOL bFloat) | CXTPToolBar | protectedvirtual
CreateKeyboardTips() | CXTPCommandBar | virtual
CreateToolBar(DWORD dwStyle, CWnd *pParentWnd, UINT nID=AFX_IDW_TOOLBAR) | CXTPToolBar |
CXTPCommandBar() | CXTPCommandBar | protected
CXTPDialogBar() | CXTPDialogBar |
CXTPHookManagerHookAble() | CXTPHookManagerHookAble |
CXTPToolBar() | CXTPToolBar |
DelayLayout() | CXTPCommandBar |
DelayRedraw() | CXTPCommandBar | virtual
DoPropExchange(CXTPPropExchange *pPX) | CXTPToolBar | protectedvirtual
DoUpdateCustomizeMenuControl(CXTPControl *pControl, CCmdTarget *pTarget) | CXTPToolBar | static
DrawCommandBar(CDC *pDC, CRect rcClipBox) | CXTPCommandBar | virtual
EnableAnimation(BOOL bEnable=TRUE) | CXTPCommandBar |
EnableCustomization(BOOL bEnable=TRUE) | CXTPCommandBar |
EnableDocking(DWORD dwFlags=xtpFlagAlignAny|xtpFlagFloating|xtpFlagHideWrap) | CXTPToolBar |
EnableDoubleBuffer(BOOL bEnable=TRUE) | CXTPCommandBar |
EnsureVisible(CXTPControl *pControl) | CXTPCommandBar | virtual
FillCommandBarEntry(CDC *pDC) | CXTPCommandBar | virtual
FindAccel(TCHAR chAccel) const | CXTPCommandBar |
FindAccelEx(UINT chAccel, BOOL &bSelectOnly) const | CXTPCommandBar |
GenerateCommandBarList(DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam) | CXTPCommandBar | protectedvirtual
GetActiveDocTemplate() const | CXTPCommandBar | protected
GetBarID() const | CXTPCommandBar |
GetBarInfo(CToolBarInfo *pInfo) | CXTPToolBar |
GetBorders() | CXTPToolBar | protectedvirtual
GetButtonSize() const | CXTPCommandBar | virtual
GetCaption() const | CXTPDialogBar |
GetCaptionPopup() const | CXTPDialogBar |
GetCommandBarData() const | CXTPCommandBar |
GetCommandBars() const | CXTPCommandBar |
GetControl(int nIndex) const | CXTPCommandBar |
GetControlCount() const | CXTPCommandBar |
GetControls() const | CXTPCommandBar |
GetDefaultButtonStyle() const | CXTPCommandBar |
GetDockBar() const | CXTPToolBar |
GetFlags() const | CXTPCommandBar |
GetFrameSite() const | CXTPCommandBar |
GetIconSize() const | CXTPCommandBar | virtual
GetImageManager() const | CXTPCommandBar |
GetLargeIconSize(BOOL bAutoSize) const | CXTPCommandBar |
GetMargins() | CXTPDialogBar | protected
GetOwnerSite() const | CXTPCommandBar |
GetPaintManager() const | CXTPCommandBar |
GetParentCommandBar() const | CXTPCommandBar | virtual
GetPosition() const | CXTPCommandBar |
GetRootParent() const | CXTPCommandBar |
GetSelected() const | CXTPCommandBar |
GetShowGripper() const | CXTPCommandBar |
GetSite() const | CXTPCommandBar |
GetTextOrientation() const | CXTPCommandBar |
GetTitle() const | CXTPCommandBar |
GetTrackFocus() const | CXTPCommandBar |
GetType() const | CXTPCommandBar |
GetWidth() const | CXTPCommandBar |
HideKeyboardTips() | CXTPCommandBar |
InvalidateParents() | CXTPCommandBar |
IsActive() const | CXTPDialogBar |
IsAnimationEnabled() const | CXTPCommandBar |
IsBuiltIn() const | CXTPToolBar |
IsCloseable() const | CXTPToolBar |
IsContextMenuPresent() const | CXTPToolBar |
IsCustomizable() const | CXTPCommandBar | virtual
IsCustomizeDialogPresent() const | CXTPToolBar |
IsCustomizeMode() const | CXTPCommandBar |
IsDialogBar() const | CXTPDialogBar | protectedvirtual
IsHelpMode() const | CXTPCommandBar | protected
IsKeyboardCuesVisible() const | CXTPCommandBar | virtual
IsKeyboardTipsVisible() const | CXTPCommandBar |
IsLayoutRTL() const | CXTPCommandBar |
IsMenuTitleBar() const | CXTPCommandBar | virtual
IsPopupBar() const | CXTPCommandBar | virtual
IsResizable() const | CXTPCommandBar | virtual
IsRibbonBar() const | CXTPCommandBar | virtual
IsTemporary() const | CXTPToolBar |
IsTextBelowIcons() const | CXTPCommandBar |
IsTrackingMode() const | CXTPCommandBar |
IsVisible() const | CXTPToolBar | inlinevirtual
IsWindowVisible() const | CXTPToolBar |
LoadMenu(CMenu *pMenu, BOOL bRemoveControls=TRUE) | CXTPCommandBar | virtual
LoadToolBar(UINT nIDResource, BOOL bLoadIcons=TRUE) | CXTPToolBar | virtual
LockMouseMove(CXTPControl *pControl) | CXTPCommandBar |
LockRedraw() | CXTPCommandBar |
m_bActive | CXTPDialogBar | protected
m_bAnimatePopup | CXTPCommandBar | protected
m_barPosition | CXTPCommandBar | protected
m_barType | CXTPCommandBar | protected
m_bAutoDestroy | CXTPHookManagerHookAble |
m_bBuiltIn | CXTPToolBar | protected
m_bCaptionPopup | CXTPDialogBar | protected
m_bCaptionVisible | CXTPDialogBar | protected
m_bCloseable | CXTPCommandBar | protected
m_bComboBar | CXTPCommandBar |
m_bContextMenuPresent | CXTPToolBar | protected
m_bCustomizable | CXTPCommandBar | protected
m_bCustomizeDialogPresent | CXTPCommandBar | protected
m_bExecOnRButton | CXTPCommandBar | protected
m_bGrabFocus | CXTPCommandBar | protected
m_bIgnoreUpdateHandler | CXTPCommandBar | protected
m_bInRecalcLayout | CXTPToolBar | protected
m_bKeyboardSelect | CXTPCommandBar | protected
m_bMultiLine | CXTPCommandBar | protected
m_bPreviewMode | CXTPToolBar | protected
m_bPreviewVisible | CXTPToolBar | protected
m_bRecursePopup | CXTPCommandBar | protected
m_bResizable | CXTPDialogBar | protected
m_bShowExpandButton | CXTPToolBar | protected
m_bTearOff | CXTPToolBar | protected
m_bTemporary | CXTPToolBar | protected
m_bTextBelow | CXTPCommandBar | protected
m_bTracking | CXTPCommandBar | protected
m_bTrackOnHover | CXTPCommandBar |
m_buttonStyle | CXTPCommandBar | protected
m_bVerticalMarker | CXTPCommandBar | protected
m_bVisible | CXTPToolBar | protected
m_dwData | CXTPCommandBar | protected
m_dwFlags | CXTPCommandBar | protected
m_dwStyle | CXTPCommandBar | protected
m_hwndChild | CXTPDialogBar | protected
m_hwndFocus | CXTPCommandBar | protected
m_nBarID | CXTPCommandBar | protected
m_nCaptionHeight | CXTPDialogBar | protected
m_nIdleFlags | CXTPCommandBar | protected
m_nLockRedraw | CXTPCommandBar | protected
m_nMRUWidth | CXTPCommandBar | protected
m_nPopuped | CXTPCommandBar | protected
m_nSelected | CXTPCommandBar | protected
m_nStateFlags | CXTPCommandBar |
m_nTextOrientation | CXTPCommandBar | protected
m_pAnimation | CXTPCommandBar | protected
m_pCommandBars | CXTPCommandBar | protected
m_pControls | CXTPCommandBar | protected
m_pDockBar | CXTPToolBar | protected
m_pDockContext | CXTPToolBar | protected
m_pImageManager | CXTPCommandBar | protected
m_pOwner | CXTPCommandBar | protected
m_pPaintManager | CXTPCommandBar | protected
m_pPopupBar | CXTPDialogBar | protected
m_pReturnCmd | CXTPCommandBar | protected
m_pSite | CXTPCommandBar | protected
m_pToolTipContext | CXTPCommandBar | protected
m_rcBorders | CXTPDialogBar | protected
m_rcMarker | CXTPCommandBar | protected
m_strCaption | CXTPDialogBar | protected
m_strTitle | CXTPCommandBar | protected
m_szButtons | CXTPCommandBar | protected
m_szButtonSpacing | CXTPCommandBar | protected
m_szDockingClient | CXTPDialogBar | protected
m_szFloatingClient | CXTPDialogBar | protected
m_szIcons | CXTPCommandBar | protected
m_szMinTrackRect | CXTPDialogBar | protected
MergeToolBar(CXTPCommandBar *pCommandBar, BOOL bSilent) | CXTPToolBar | protectedvirtual
MergeToolBar(CXTPCommandBar *pCommandBar, BOOL bSilent, int nDefaultConfirmationChoice) | CXTPToolBar | protectedvirtual
ModifyBarStyle(DWORD dwRemove, DWORD dwAdd) | CXTPToolBar |
MoveChildWindow(CRect rc) | CXTPDialogBar | protected
OnControlsChanged() | CXTPCommandBar | protectedvirtual
OnControlSelected(BOOL bSelected, CXTPControl *pControl) | CXTPCommandBar | virtual
OnCustomizeDragEnter(CXTPControl *pDataObject, CPoint point) | CXTPCommandBar | virtual
OnCustomizeDragLeave() | CXTPCommandBar | virtual
OnCustomizeDragOver(CXTPControl *pDataObject, CPoint point) | CXTPCommandBar | virtual
OnCustomizeDrop(CXTPControl *pDataObject, DROPEFFECT &dropEffect, CPoint ptDrop, CPoint ptDrag) | CXTPCommandBar | virtual
OnHookAttached(HWND hWnd) | CXTPHookManagerHookAble | virtual
OnHookDetached() | CXTPHookManagerHookAble | virtual
OnHookKeyDown(UINT nChar, LPARAM lParam) | CXTPToolBar | virtual
OnHookMessage(HWND hWnd, UINT nMessage, WPARAM &wParam, LPARAM &lParam, LRESULT &lResult) | CXTPCommandBar | virtual
OnKeyboardTip(CXTPCommandBarKeyboardTip *pTip) | CXTPCommandBar | virtual
OnKeyboardTipChar(UINT chAccel) | CXTPCommandBar |
OnMouseHitTest(CPoint pt) | CXTPDialogBar | protectedvirtual
OnPaintManagerChanged() | CXTPToolBar | protectedvirtual
OnPostHookMessage(HWND hWnd, UINT nMessage, WPARAM &wParam, LPARAM &lParam, LRESULT &lResult) | CXTPHookManagerHookAble | virtual
OnRecalcLayout() | CXTPToolBar | virtual
OnRemoved() | CXTPCommandBar | protectedvirtual
OnResize(CRect rcWindow, int nHitTest) | CXTPDialogBar | protected
OnSetPreviewMode(BOOL bPreview) | CXTPToolBar |
OnTrackEnter() | CXTPCommandBar | virtual
OnTrackLost() | CXTPCommandBar | virtual
Popup(CXTPControlPopup *pControlPopup, BOOL bSelectFirst=FALSE) | CXTPCommandBar | virtual
ProcessSpecialKey(XTPSpecialKey key) | CXTPCommandBar | protectedvirtual
Redraw(LPCRECT lpRect=0, BOOL bAnimate=TRUE) | CXTPCommandBar | virtual
Reset(BOOL bShowWarningMessage) | CXTPToolBar | virtual
RestoreCommandBarList(CXTPCommandBarList *pCommandBarList) | CXTPCommandBar | protectedvirtual
s_nExpandDelay | CXTPCommandBar | static
s_nExpandHoverDelay | CXTPCommandBar | static
s_nHoverDelay | CXTPCommandBar | static
SetBarID(UINT nID) | CXTPCommandBar |
SetBarInfo(CToolBarInfo *pInfo) | CXTPToolBar |
SetButtons(UINT *pButtons, int nCount) | CXTPCommandBar |
SetButtonSize(CSize size) | CXTPCommandBar |
SetCaption(LPCTSTR lpszCaption) | CXTPDialogBar |
SetCaptionPopup(int nMenuResourceID) | CXTPDialogBar |
SetCaptionVisible(BOOL bVisible) | CXTPDialogBar |
SetChild(CWnd *pChild) | CXTPDialogBar |
SetCloseable(BOOL bCloseable) | CXTPToolBar |
SetCommandBarData(DWORD_PTR dwData) | CXTPCommandBar |
SetCommandBars(CXTPCommandBars *pCommandBars) | CXTPCommandBar |
SetContextMenuPresent(BOOL bPresent) | CXTPToolBar |
SetControls(CXTPControls *pControls) | CXTPCommandBar |
SetCustomizeDialogPresent(BOOL bPresent) | CXTPToolBar |
SetDefaultButtonStyle(XTPButtonStyle buttonStyle) | CXTPCommandBar |
SetFlags(DWORD dwFlagsAdd, DWORD dwFlagsRemove=0) | CXTPCommandBar |
SetGrabFocus(BOOL bGrabFocus) | CXTPCommandBar |
SetIconSize(CSize size) | CXTPCommandBar |
SetImageManager(CXTPImageManager *pImageManager) | CXTPCommandBar |
SetPaintManager(CXTPPaintManager *pPaintManager) | CXTPCommandBar |
SetPopuped(int nPopuped, BOOL bKeyboard=FALSE) | CXTPCommandBar |
SetPosition(XTPBarPosition barPosition) | CXTPToolBar | virtual
SetResizable(BOOL bResizable) | CXTPDialogBar |
SetSelected(int nSelected, BOOL bKeyboard=FALSE) | CXTPCommandBar | virtual
SetShowGripper(BOOL bShow) | CXTPCommandBar |
SetSize(CSize sz) | CXTPDialogBar |
SetStatusText(const CString &strDescription) | CXTPCommandBar |
SetTemporary(BOOL bTemporary) | CXTPToolBar |
SetTextOrientation(XTPBarTextOrientation nTextOrientation) | CXTPCommandBar |
SetTitle(LPCTSTR lpszTitle) | CXTPCommandBar |
SetTrackFocus(HWND hwnd) | CXTPCommandBar |
SetTrackingMode(int bMode, BOOL bSelectFirst=TRUE, BOOL bKeyboard=FALSE) | CXTPCommandBar | virtual
SetVisible(BOOL bVisible) | CXTPToolBar | virtual
SetWidth(int nWidth) | CXTPCommandBar |
ShouldSerializeBar() | CXTPToolBar | protectedvirtual
ShowExpandButton(BOOL bShowExpandButton) | CXTPToolBar |
ShowTextBelowIcons(BOOL bTextBelow=TRUE) | CXTPCommandBar |
UnlockMouseMove() | CXTPCommandBar |
UnlockRedraw() | CXTPCommandBar |
UpdateShortcuts() | CXTPCommandBar | protectedvirtual
~CXTPCommandBar() | CXTPCommandBar | protectedvirtual
~CXTPDialogBar() | CXTPDialogBar | virtual
~CXTPHookManagerHookAble() | CXTPHookManagerHookAble | virtual
~CXTPToolBar() | CXTPToolBar |


Toolkit Pro: Member List

CXTPMarkupUIElement Member List

This is the complete list of members for CXTPMarkupUIElement, including all inherited members.

ApplyRenderTransform(CXTPMarkupDrawingContext *pContext) | CXTPMarkupUIElement | protectedvirtual
Arrange(CRect rcFinalRect) | CXTPMarkupUIElement |
ArrangeCore(CRect rcFinalRect) | CXTPMarkupUIElement | protectedvirtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPMarkupUIElement() | CXTPMarkupUIElement | protected
CXTPMarkupVisual() | CXTPMarkupVisual |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAbsoluteVisualOffset() const | CXTPMarkupVisual | protected
GetBoundRect() const | CXTPMarkupVisual |
GetDesiredSize() const | CXTPMarkupUIElement |
GetFinalRect() const | CXTPMarkupUIElement |
GetLayoutClip(CRect &rc) const | CXTPMarkupUIElement | protectedvirtual
GetLogicalChild(int nIndex) const | CXTPMarkupVisual | virtual
GetLogicalChildrenCount() const | CXTPMarkupVisual | virtual
GetOpacity() const | CXTPMarkupUIElement | protectedvirtual
GetRenderSize() const | CXTPMarkupVisual |
GetRenderTransform() const | CXTPMarkupUIElement | protected
GetUpdateRect() const | CXTPMarkupVisual |
GetVisibility() const | CXTPMarkupUIElement |
GetVisualChild(int nIndex) const | CXTPMarkupVisual | virtual
GetVisualChildrenCount() const | CXTPMarkupVisual | virtual
GetVisualOffset() const | CXTPMarkupVisual |
GetVisualParent() const | CXTPMarkupVisual |
InputHitTest(CPoint point) const | CXTPMarkupVisual |
InputHitTestOverride(CPoint point) const | CXTPMarkupVisual | protectedvirtual
InvalidateArrange() | CXTPMarkupUIElement | virtual
InvalidateMeasure() | CXTPMarkupUIElement | virtual
InvalidateMeasureOverride(CXTPMarkupDrawingContext *pDC) | CXTPMarkupUIElement | protectedvirtual
InvalidateVisual() | CXTPMarkupUIElement | virtual
IsEnabled() const | CXTPMarkupUIElement |
IsFocusable() const | CXTPMarkupUIElement |
IsVisible() const | CXTPMarkupUIElement | virtual
m_bArrangeDirty | CXTPMarkupUIElement | protected
m_bArrangeInProgress | CXTPMarkupUIElement | protected
m_bMeasureDirty | CXTPMarkupUIElement | protected
m_bMeasureInProgress | CXTPMarkupUIElement | protected
m_bNeverArranged | CXTPMarkupUIElement | protected
m_bNeverMeasured | CXTPMarkupUIElement | protected
m_pClipToBoundsProperty | CXTPMarkupUIElement | static
m_pFocusableProperty | CXTPMarkupUIElement | static
m_pIsEnabledProperty | CXTPMarkupUIElement | static
m_pOpacityProperty | CXTPMarkupUIElement | static
m_pRenderTransformOriginProperty | CXTPMarkupUIElement | static
m_pRenderTransformProperty | CXTPMarkupUIElement | static
m_ptVisualOffset | CXTPMarkupVisual | protected
m_pVisibilityProperty | CXTPMarkupUIElement | static
m_rcBoundRect | CXTPMarkupVisual | protected
m_rcFinalRect | CXTPMarkupUIElement | protected
m_rcPrevUpdateRect | CXTPMarkupVisual | protected
m_rcUpdateRect | CXTPMarkupVisual | protected
m_szDesiredSize | CXTPMarkupUIElement | protected
m_szPreviousAvailableSize | CXTPMarkupUIElement | protected
m_szRenderSize | CXTPMarkupVisual | protected
Measure(CXTPMarkupDrawingContext *pDC, CSize szAvailableSize) | CXTPMarkupUIElement |
MeasureCore(CXTPMarkupDrawingContext *pDC, CSize szAvailableSize) | CXTPMarkupUIElement | protectedvirtual
OnRender(CXTPMarkupDrawingContext *drawingContext) | CXTPMarkupVisual | protectedvirtual
OnRenderFocusVisual(CXTPMarkupDrawingContext *drawingContext) | CXTPMarkupVisual | protectedvirtual
PtInRectTransform(const RECT &rect, const POINT &point) const | CXTPMarkupVisual | protected
Render(CXTPMarkupDrawingContext *drawingContext) | CXTPMarkupVisual |
RenderClipped(CXTPMarkupDrawingContext *drawingContext) | CXTPMarkupVisual | protectedvirtual
RestoreRenderTransform(CXTPMarkupDrawingContext *pContext, TransformationMatrices &matrices) | CXTPMarkupUIElement | protectedvirtual
SetVisibility(XTPMarkupVisibility visibility) | CXTPMarkupUIElement |
~CXTPMarkupUIElement() | CXTPMarkupUIElement | protectedvirtual
~CXTPMarkupVisual() | CXTPMarkupVisual | virtual


Toolkit Pro: XTPTabColorSetVisualStudio2017.h Source File

  • Source
  • TabManager
  • ColorSets
XTPTabColorSetVisualStudio2017.h
Go to the documentation of this file.
1
23#if !defined(__XTPTABCOLORSETVISUALSTUDIO2017_H__)
24# define __XTPTABCOLORSETVISUALSTUDIO2017_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
37class _XTP_EXT_CLASS CXTPTabColorSetVisualStudio2017 : public CXTPTabColorSetVisualStudio2015
38{
39public:
40 CXTPTabColorSetVisualStudio2017();
41
49 virtual void RefreshMetrics();
50};
51
52# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
54#endif // !defined(__XTPTABCOLORSETVISUALSTUDIO2017_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPTabColorSetVisualStudio2015
CXTPTabColorSetVisualStudio2015 implements a Visual Studio 2015 tab color set.
Definition XTPTabColorSetVisualStudio2015.h:38
CXTPTabColorSetVisualStudio2017
CXTPTabColorSetVisualStudio2017 implements a Visual Studio 2017 tab color set.
Definition XTPTabColorSetVisualStudio2017.h:38
CXTPTabColorSetVisualStudio2017::RefreshMetrics
virtual void RefreshMetrics()
Refreshes the visual metrics of the tabs.


Toolkit Pro: XTPGaugeStateType.h Source File

  • Source
  • Gauge
  • Types
XTPGaugeStateType.h
Go to the documentation of this file.
1
22#if !defined(__XTPGAUGESTATETYPE_H__)
23# define __XTPGAUGESTATETYPE_H__
24
25# if _MSC_VER > 1000
26# pragma once
27# endif // _MSC_VER > 1000
28
29# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
30
43class _XTP_EXT_CLASS CXTPGaugeStateType : public CXTPGaugeBaseType
44{
45 DECLARE_DYNCREATE(CXTPGaugeStateType);
46
47private:
48 CXTPGaugeStateType();
49
50public:
55 ~CXTPGaugeStateType();
56
63 virtual LPCWSTR GetTypeName() const;
64
76 UINT GetState() const;
77
91 BOOL SetState(UINT nState);
92
100 UINT GetStateCount() const;
101
102protected:
104 virtual void OnUpdate();
107private:
108 mutable UINT* m_pState;
109 mutable UINT m_nStateCount;
110 BOOL m_bInSetState;
111};
112
113# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
114
115#endif // !defined(__XTPGAUGESTATETYPE_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPGaugeBaseType
A base class for all gauge types.
Definition XTPGaugeBaseType.h:44
CXTPGaugeStateType
Implements a State gauge type.
Definition XTPGaugeStateType.h:44
CXTPGaugeStateType::~CXTPGaugeStateType
~CXTPGaugeStateType()
Handles gauge type object destruction.
CXTPGaugeStateType::GetState
UINT GetState() const
Gets the current state value.
CXTPGaugeStateType::SetState
BOOL SetState(UINT nState)
Sets the current state value.
CXTPGaugeStateType::GetTypeName
virtual LPCWSTR GetTypeName() const
Obtains implementation specified type name.
CXTPGaugeStateType::GetStateCount
UINT GetStateCount() const
Obtains the supported number of states that is the number of elements of the 'states' array specified...


Toolkit Pro: XTPTabManagerNavigateButton.h Source File

  • Source
  • TabManager
XTPTabManagerNavigateButton.h
Go to the documentation of this file.
1
23#if !defined(__XTPTABMANAGERNAVIGATEBUTTON_H__)
24# define __XTPTABMANAGERNAVIGATEBUTTON_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPTabManager;
34class CXTPTabManagerItem;
35
73class _XTP_EXT_CLASS CXTPTabManagerNavigateButton
74{
75public:
92 CXTPTabManagerNavigateButton(CXTPTabManager* pManager, UINT nID,
93 XTPTabNavigateButtonFlags dwFlags);
94
95protected:
100 virtual ~CXTPTabManagerNavigateButton();
101
102public:
116 virtual void AdjustWidth(int& nWidth);
117
126 void SetFlags(XTPTabNavigateButtonFlags dwFlags);
127
137 XTPTabNavigateButtonFlags GetFlags() const;
138
147 virtual CSize GetSize() const;
148
155 CXTPTabManagerItem* GetItem() const;
156
162 void Draw(CDC* pDC);
163
183 virtual void PerformClick(HWND hWnd, CPoint pt);
184
192 BOOL IsEnabled() const;
193
206 BOOL IsPressed() const;
207
223 BOOL IsHighlighted() const;
224
231 BOOL IsOwnerSelected() const;
232
239 BOOL IsOwnerHighlighted() const;
240
249 BOOL IsOwnerNull() const;
250
261 BOOL IsOwnerActive() const;
262
269 BOOL IsVisible() const;
270
277 CRect GetRect() const;
278
284 void SetRect(CRect rcButton);
285
296 UINT GetID() const;
297
304 virtual void Reposition(CRect& rcNavigateButtons);
305
316 void SetTooltip(LPCTSTR lpszTooltip);
317
329 CString GetTooltip() const;
330
342 virtual void DrawEntry(CDC* pDC, CRect rc, COLORREF clr, BOOL bEnabled) = 0;
343
351 virtual void OnExecute(BOOL bTick);
352
353protected:
354 UINT m_nID;
355 XTPTabNavigateButtonFlags m_dwFlags;
357 CXTPTabManager* m_pManager;
359 CRect m_rcButton;
361 BOOL m_bEnabled;
362 BOOL m_bPressed;
363 CString m_strToolTip;
364 CXTPTabManagerItem* m_pItem;
366private:
367 friend class CXTPTabManager;
368 friend class CXTPTabManagerNavigateButtons;
369};
370
372// CXTPTabManagerNavigateButton
373
374AFX_INLINE void CXTPTabManagerNavigateButton::SetFlags(XTPTabNavigateButtonFlags dwFlags)
375{
376 m_dwFlags = dwFlags;
377}
378AFX_INLINE XTPTabNavigateButtonFlags CXTPTabManagerNavigateButton::GetFlags() const
379{
380 return m_dwFlags;
381}
382AFX_INLINE BOOL CXTPTabManagerNavigateButton::IsEnabled() const
383{
384 return m_bEnabled;
385}
386AFX_INLINE BOOL CXTPTabManagerNavigateButton::IsPressed() const
387{
388 return m_bPressed;
389}
390AFX_INLINE CRect CXTPTabManagerNavigateButton::GetRect() const
391{
392 return m_rcButton;
393}
394AFX_INLINE BOOL CXTPTabManagerNavigateButton::IsVisible() const
395{
396 return !m_rcButton.IsRectEmpty();
397}
398AFX_INLINE UINT CXTPTabManagerNavigateButton::GetID() const
399{
400 return m_nID;
401}
402AFX_INLINE void CXTPTabManagerNavigateButton::SetTooltip(LPCTSTR lpszTooltip)
403{
404 m_strToolTip = lpszTooltip;
405}
406AFX_INLINE CString CXTPTabManagerNavigateButton::GetTooltip() const
407{
408 return m_strToolTip;
409}
410AFX_INLINE CXTPTabManagerItem* CXTPTabManagerNavigateButton::GetItem() const
411{
412 return m_pItem;
413}
414
415# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
417#endif // !defined(__XTPTABMANAGERNAVIGATEBUTTON_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPTabNavigateButtonFlags
XTPTabNavigateButtonFlags
XTPTabNavigateButtonFlags is an enumeration used to indicate when a navigate button will be displayed...
Definition XTPTabManagerDefines.h:68
CXTPTabManager
CXTPTabManager is the base class for docking pane tabs, tab control tabs, and MDI client tabs.
Definition XTPTabManager.h:87
CXTPTabManagerItem
CXTPTabManagerItem is the base class for the tabs that appear in the command bars tab workspace,...
Definition XTPTabManagerItem.h:44
CXTPTabManagerNavigateButton
CXTPTabManagerNavigateButton is a class used to represent a tab navigation button.
Definition XTPTabManagerNavigateButton.h:74
CXTPTabManagerNavigateButton::DrawEntry
virtual void DrawEntry(CDC *pDC, CRect rc, COLORREF clr, BOOL bEnabled)=0
Draws a symbol in the navigation button (i.e.
CXTPTabManagerNavigateButton::m_nID
UINT m_nID
ID of the navigation button.
Definition XTPTabManagerNavigateButton.h:354
CXTPTabManagerNavigateButton::IsOwnerActive
BOOL IsOwnerActive() const
Determines if this tab group is active/inactive.
CXTPTabManagerNavigateButton::m_pManager
CXTPTabManager * m_pManager
Pointer to the tab manager the navigation buttons are drawn on.
Definition XTPTabManagerNavigateButton.h:357
CXTPTabManagerNavigateButton::IsHighlighted
BOOL IsHighlighted() const
Determines the highlighted state of the navigation button.
CXTPTabManagerNavigateButton::m_strToolTip
CString m_strToolTip
Tooltip for the button.
Definition XTPTabManagerNavigateButton.h:363
CXTPTabManagerNavigateButton::SetTooltip
void SetTooltip(LPCTSTR lpszTooltip)
Sets the tooltip for the navigation button.
Definition XTPTabManagerNavigateButton.h:402
CXTPTabManagerNavigateButton::IsPressed
BOOL IsPressed() const
Determines the pressed state of the navigation button.
Definition XTPTabManagerNavigateButton.h:386
CXTPTabManagerNavigateButton::AdjustWidth
virtual void AdjustWidth(int &nWidth)
Adjusts the width of the tab header area.
CXTPTabManagerNavigateButton::IsEnabled
BOOL IsEnabled() const
Determines if the navigation button is enabled/disabled.
Definition XTPTabManagerNavigateButton.h:382
CXTPTabManagerNavigateButton::SetRect
void SetRect(CRect rcButton)
Sets the bounding rectangle for the navigation button.
CXTPTabManagerNavigateButton::m_dwFlags
XTPTabNavigateButtonFlags m_dwFlags
Flag that indicates when the navigation button will be drawn.
Definition XTPTabManagerNavigateButton.h:355
CXTPTabManagerNavigateButton::IsOwnerNull
BOOL IsOwnerNull() const
Determines if the navigation button is either a common navigation item or owned by a tab item.
CXTPTabManagerNavigateButton::Reposition
virtual void Reposition(CRect &rcNavigateButtons)
Updates the position of the navigation button.
CXTPTabManagerNavigateButton::PerformClick
virtual void PerformClick(HWND hWnd, CPoint pt)
This method is called when the user presses the left mouse button.
CXTPTabManagerNavigateButton::~CXTPTabManagerNavigateButton
virtual ~CXTPTabManagerNavigateButton()
Destroys a CXTPTabManagerNavigateButton object, handles cleanup and deallocation.
CXTPTabManagerNavigateButton::IsVisible
BOOL IsVisible() const
Determines the visible state of the navigation button.
Definition XTPTabManagerNavigateButton.h:394
CXTPTabManagerNavigateButton::GetSize
virtual CSize GetSize() const
Gets the size of the navigation button.
CXTPTabManagerNavigateButton::GetItem
CXTPTabManagerItem * GetItem() const
Gets the parent item of the navigation button.
Definition XTPTabManagerNavigateButton.h:410
CXTPTabManagerNavigateButton::m_pItem
CXTPTabManagerItem * m_pItem
Owner item.
Definition XTPTabManagerNavigateButton.h:364
CXTPTabManagerNavigateButton::IsOwnerHighlighted
BOOL IsOwnerHighlighted() const
Determines the highlighted state of the owner tab button.
CXTPTabManagerNavigateButton::GetID
UINT GetID() const
Gets the identifier of the navigation button.
Definition XTPTabManagerNavigateButton.h:398
CXTPTabManagerNavigateButton::GetFlags
XTPTabNavigateButtonFlags GetFlags() const
Determines when the navigation button is displayed.
Definition XTPTabManagerNavigateButton.h:378
CXTPTabManagerNavigateButton::OnExecute
virtual void OnExecute(BOOL bTick)
This method is called when a navigation button is clicked.
CXTPTabManagerNavigateButton::m_rcButton
CRect m_rcButton
Bounding rectangle of the navigation button.
Definition XTPTabManagerNavigateButton.h:359
CXTPTabManagerNavigateButton::Draw
void Draw(CDC *pDC)
Draws the navigation button in the tab header area.
CXTPTabManagerNavigateButton::GetTooltip
CString GetTooltip() const
Gets the tooltip of the navigation button.
Definition XTPTabManagerNavigateButton.h:406
CXTPTabManagerNavigateButton::m_bPressed
BOOL m_bPressed
TRUE if the navigation button is pressed/clicked.
Definition XTPTabManagerNavigateButton.h:362
CXTPTabManagerNavigateButton::IsOwnerSelected
BOOL IsOwnerSelected() const
Determines the selected state of the owner tab button.
CXTPTabManagerNavigateButton::CXTPTabManagerNavigateButton
CXTPTabManagerNavigateButton(CXTPTabManager *pManager, UINT nID, XTPTabNavigateButtonFlags dwFlags)
Constructs a CXTPTabManagerNavigateButton object.
CXTPTabManagerNavigateButton::GetRect
CRect GetRect() const
Gets the bounding rectangle of the navigation button.
Definition XTPTabManagerNavigateButton.h:390
CXTPTabManagerNavigateButton::SetFlags
void SetFlags(XTPTabNavigateButtonFlags dwFlags)
Specifies when the navigation button is displayed.
Definition XTPTabManagerNavigateButton.h:374
CXTPTabManagerNavigateButton::m_bEnabled
BOOL m_bEnabled
TRUE if the navigation button is enabled.
Definition XTPTabManagerNavigateButton.h:361
CXTPTabManagerNavigateButtons
CXTPTabManagerNavigateButtons is a class used to represent a collection of tab navigation buttons.
Definition XTPTabManagerNavigateButtons.h:39


Toolkit Pro: XTPTaskPanelListViewOfficeXPTheme.h Source File

  • Source
  • TaskPanel
  • Themes
XTPTaskPanelListViewOfficeXPTheme.h
Go to the documentation of this file.
1
23#ifndef XTPTaskPanelListViewOfficeXPTheme_h__
24# define XTPTaskPanelListViewOfficeXPTheme_h__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
39class _XTP_EXT_CLASS CXTPTaskPanelListViewOfficeXPTheme : public CXTPTaskPanelListViewTheme
40{
41public:
46 CXTPTaskPanelListViewOfficeXPTheme();
47
52 void RefreshMetrics();
53};
55# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
56#endif // XTPTaskPanelListViewOfficeXPTheme_h__
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPTaskPanelListViewOfficeXPTheme
CXTPTaskPanelListViewOfficeXPTheme represents a List View Office XP style theme.
Definition XTPTaskPanelListViewOfficeXPTheme.h:40
CXTPTaskPanelListViewOfficeXPTheme::CXTPTaskPanelListViewOfficeXPTheme
CXTPTaskPanelListViewOfficeXPTheme()
Constructs a CXTPTaskPanelListViewOfficeXPTheme object.
CXTPTaskPanelListViewOfficeXPTheme::RefreshMetrics
void RefreshMetrics()
Refreshes the visual metrics of the task panel.
CXTPTaskPanelListViewTheme
CXTPTaskPanelListViewTheme class represents a List View style theme.
Definition XTPTaskPanelListViewTheme.h:40


Toolkit Pro: XTPChartNumberFormat.h Source File

  • Source
  • Chart
  • Utils
XTPChartNumberFormat.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTNUMBERFORMAT_H__)
24# define __XTPCHARTNUMBERFORMAT_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartColor;
34class CXTPChartDeviceCommand;
35class CXTPPropExchange;
36class CXTPChartSeriesPoint;
37
42enum XTPChartNumberFormatCategory
43{
44 xtpChartGeneral,
45 xtpChartNumber,
46 xtpChartCurrency,
47 xtpChartPercentage,
48 xtpChartScientific
49};
50
55enum XTPChartDateTimeFormatCategory
56{
57 xtpChartDateTimeGeneral,
58 xtpChartDateTimeLongDate,
59 xtpChartDateTimeShortDate,
60 xtpChartDateTimeLongTime,
61 xtpChartDateTimeShortTime,
62 xtpChartDateTimeMonthAndDay,
63 xtpChartDateTimeMonthAndYear,
64 xtpChartDateTimeCustom,
65};
66
71class _XTP_EXT_CLASS CXTPChartNumberFormat : public CXTPChartElement
72{
73public:
80 CXTPChartNumberFormat(CXTPChartElement* pOwner);
81
86 virtual ~CXTPChartNumberFormat();
87
88public:
93 CString GetPattern() const;
94
107 void SetPattern(LPCTSTR lpszPattern);
108
113 XTPChartNumberFormatCategory GetCategory() const;
114
122 void SetCategory(XTPChartNumberFormatCategory nCategory);
123
131 int GetDecimalPlaces() const;
132
140 void SetDecimalPlaces(int nDecimalPlaces);
141
146 BOOL GetUseThousandSeparator() const;
147
154 void SetUseThousandSeparator(BOOL bThousandSeparator);
155
160 LCID GetLocale() const;
161
168 void SetLocale(LCID nLocale);
169
174 CString GetCurrencySymbol() const;
175
182 void SetCurrencySymbol(LPCTSTR lpszCurrencySymbol);
183
184 XTPChartDateTimeFormatCategory GetDateTimeCategory() const;
185
186 void SetDateTimeCategory(XTPChartDateTimeFormatCategory category);
187
188 CString GetDateTimeFormat() const;
189 void SetDateTimeFormat(LPCTSTR lpszDateTimeFormat);
190
191public:
203 static BOOL AFX_CDECL IsUseResourceFileLocale();
204
219 static void AFX_CDECL SetUseResourceFileLocale(BOOL bUseResourceFileLocale);
220
231 static LCID AFX_CDECL GetActiveLCID();
232
240 virtual CString FormatNumber(double dValue) const;
241
249 virtual CString FormatString(LPCTSTR lpszValue) const;
250
258 virtual CString FormatDate(COleDateTime& dt) const;
259
268 virtual CString FormatPoint(CXTPChartSeriesPoint* pSeriesPoint, double dValue) const;
269
270public:
282 void DoPropExchange(CXTPPropExchange* pPX);
283
284protected:
285 CString DoubleToString(double dMark) const;
286 void CreateNumberFormat();
287 void CreateCurrencyFormat();
288 void CreateDateTimeFormat();
289 int GetLocaleLong(LCTYPE LCType) const;
290 CString GetLocaleString(LCTYPE LCType, int nMaxLength);
291
292protected:
293 CString m_strPattern;
294 XTPChartNumberFormatCategory m_nCategory;
295 int m_nDecimalPlaces;
296 BOOL m_bUseThousandSeparator;
297 LCID m_nLocale;
298 CString m_strCurrencySymbol;
299 XTPChartDateTimeFormatCategory m_nDateTimeCategory;
300
301 NUMBERFMT m_fmtNumber;
302 CURRENCYFMT m_fmtCurrency;
303
304 CString m_strDateTimeFormat;
305 CString m_strActiveDateTimeFormat;
306
307# ifdef _XTP_ACTIVEX
308public:
310 DECLARE_DISPATCH_MAP()
311 DECLARE_INTERFACE_MAP()
312 DECLARE_OLETYPELIB_EX(CXTPChartNumberFormat);
313
314 afx_msg BSTR OleGetPattern();
315 afx_msg void OleSetPattern(LPCTSTR lpszValue);
316 afx_msg BSTR OleGetCurrencySymbol();
317 afx_msg void OleSetCurrencySymbol(LPCTSTR lpszValue);
318 afx_msg BSTR OleGetDateDateTimeFormat();
320# endif
321
322private:
323 static BOOL s_bUseResourceFileLocale;
324};
325
326AFX_INLINE CString CXTPChartNumberFormat::GetPattern() const
327{
328 return m_strPattern;
329}
330AFX_INLINE void CXTPChartNumberFormat::SetPattern(LPCTSTR lpszPattern)
331{
332 m_strPattern = lpszPattern;
333 OnChartChanged();
334}
335AFX_INLINE XTPChartNumberFormatCategory CXTPChartNumberFormat::GetCategory() const
336{
337 return m_nCategory;
338}
339AFX_INLINE void CXTPChartNumberFormat::SetCategory(XTPChartNumberFormatCategory nCategory)
340{
341 m_nCategory = nCategory;
342 OnChartChanged();
343}
344AFX_INLINE int CXTPChartNumberFormat::GetDecimalPlaces() const
345{
346 return m_nDecimalPlaces;
347}
348AFX_INLINE void CXTPChartNumberFormat::SetDecimalPlaces(int nDecimalPlaces)
349{
350 m_nDecimalPlaces = nDecimalPlaces;
351 CreateNumberFormat();
352 CreateCurrencyFormat();
353 OnChartChanged();
354}
355AFX_INLINE BOOL CXTPChartNumberFormat::GetUseThousandSeparator() const
356{
357 return m_bUseThousandSeparator;
358}
359AFX_INLINE void CXTPChartNumberFormat::SetUseThousandSeparator(BOOL bThousandSeparator)
360{
361 m_bUseThousandSeparator = bThousandSeparator;
362 CreateNumberFormat();
363 CreateCurrencyFormat();
364 OnChartChanged();
365}
366
367AFX_INLINE LCID CXTPChartNumberFormat::GetLocale() const
368{
369 return m_nLocale;
370}
371AFX_INLINE void CXTPChartNumberFormat::SetLocale(LCID nLocale)
372{
373 m_nLocale = nLocale;
374 CreateNumberFormat();
375 CreateCurrencyFormat();
376 CreateDateTimeFormat();
377 OnChartChanged();
378}
379AFX_INLINE void CXTPChartNumberFormat::SetCurrencySymbol(LPCTSTR lpszCurrencySymbol)
380{
381 m_strCurrencySymbol = lpszCurrencySymbol;
382 CreateCurrencyFormat();
383 OnChartChanged();
384}
385AFX_INLINE CString CXTPChartNumberFormat::GetCurrencySymbol() const
386{
387 return m_strCurrencySymbol;
388}
389AFX_INLINE void CXTPChartNumberFormat::SetDateTimeCategory(XTPChartDateTimeFormatCategory category)
390{
391 m_nDateTimeCategory = category;
392 CreateDateTimeFormat();
393 OnChartChanged();
394}
395AFX_INLINE XTPChartDateTimeFormatCategory CXTPChartNumberFormat::GetDateTimeCategory() const
396{
397 return m_nDateTimeCategory;
398}
399AFX_INLINE CString CXTPChartNumberFormat::GetDateTimeFormat() const
400{
401 return m_strDateTimeFormat;
402}
403AFX_INLINE void CXTPChartNumberFormat::SetDateTimeFormat(LPCTSTR lpszDateTimeFormat)
404{
405 m_strDateTimeFormat = lpszDateTimeFormat;
406 CreateDateTimeFormat();
407 OnChartChanged();
408}
410# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
411#endif //#if !defined(__XTPCHARTNUMBERFORMAT_H__)
XTPChartNumberFormatCategory
XTPChartNumberFormatCategory
Format category used by CXTPChartNumberFormat.
Definition XTPChartNumberFormat.h:43
xtpChartCurrency
@ xtpChartCurrency
Currency ($10,000,000.12)
Definition XTPChartNumberFormat.h:46
xtpChartNumber
@ xtpChartNumber
Number (10,000,000.12)
Definition XTPChartNumberFormat.h:45
xtpChartGeneral
@ xtpChartGeneral
General (100000.123)
Definition XTPChartNumberFormat.h:44
xtpChartPercentage
@ xtpChartPercentage
Percent (99.12%)
Definition XTPChartNumberFormat.h:47
xtpChartScientific
@ xtpChartScientific
Scientific (12.12e+005)
Definition XTPChartNumberFormat.h:48
XTPChartDateTimeFormatCategory
XTPChartDateTimeFormatCategory
DateTime Format category used by CXTPChartNumberFormat.
Definition XTPChartNumberFormat.h:56
xtpChartDateTimeCustom
@ xtpChartDateTimeCustom
Specifies custom date time format.
Definition XTPChartNumberFormat.h:64
xtpChartDateTimeMonthAndYear
@ xtpChartDateTimeMonthAndYear
Specifies month and year format.
Definition XTPChartNumberFormat.h:63
xtpChartDateTimeGeneral
@ xtpChartDateTimeGeneral
Specifies general date time format.
Definition XTPChartNumberFormat.h:57
xtpChartDateTimeShortDate
@ xtpChartDateTimeShortDate
Specifies short date format.
Definition XTPChartNumberFormat.h:59
xtpChartDateTimeShortTime
@ xtpChartDateTimeShortTime
Specifies short time format.
Definition XTPChartNumberFormat.h:61
xtpChartDateTimeMonthAndDay
@ xtpChartDateTimeMonthAndDay
Specifies month and day format.
Definition XTPChartNumberFormat.h:62
xtpChartDateTimeLongTime
@ xtpChartDateTimeLongTime
Specifies long time format.
Definition XTPChartNumberFormat.h:60
xtpChartDateTimeLongDate
@ xtpChartDateTimeLongDate
Specifies long date format.
Definition XTPChartNumberFormat.h:58
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartColor
This class abstracts a color entity.
Definition XTPChartTypes.h:51
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPChartElement
This class abstracts a chart element, this class acts as a base class for all chart elements.
Definition XTPChartElement.h:131
CXTPChartElement::OnChartChanged
virtual void OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic propertie...
CXTPChartNumberFormat
This class helper is used to format number to string.
Definition XTPChartNumberFormat.h:72
CXTPChartNumberFormat::FormatString
virtual CString FormatString(LPCTSTR lpszValue) const
Call this method to format string.
CXTPChartNumberFormat::DoPropExchange
void DoPropExchange(CXTPPropExchange *pPX)
Call this member function to store/Load the properties of chart boundary object using the specified d...
CXTPChartNumberFormat::SetCategory
void SetCategory(XTPChartNumberFormatCategory nCategory)
Call this method to specify format category of double value (Number, Currency, Percent,...
Definition XTPChartNumberFormat.h:339
CXTPChartNumberFormat::SetUseThousandSeparator
void SetUseThousandSeparator(BOOL bThousandSeparator)
Call this method to use thousand separator for xtpChartNumber category of numbers.
Definition XTPChartNumberFormat.h:359
CXTPChartNumberFormat::SetPattern
void SetPattern(LPCTSTR lpszPattern)
Call this method to set a new pattern.
Definition XTPChartNumberFormat.h:330
CXTPChartNumberFormat::SetCurrencySymbol
void SetCurrencySymbol(LPCTSTR lpszCurrencySymbol)
Call this method to set a new currency symbol for the xtpChartCurrency category.
Definition XTPChartNumberFormat.h:379
CXTPChartNumberFormat::GetCurrencySymbol
CString GetCurrencySymbol() const
Definition XTPChartNumberFormat.h:385
CXTPChartNumberFormat::m_nLocale
LCID m_nLocale
Current locale.
Definition XTPChartNumberFormat.h:297
CXTPChartNumberFormat::m_strCurrencySymbol
CString m_strCurrencySymbol
Currency symbol.
Definition XTPChartNumberFormat.h:298
CXTPChartNumberFormat::SetDecimalPlaces
void SetDecimalPlaces(int nDecimalPlaces)
Call this method to set number of digits after decimal points.
Definition XTPChartNumberFormat.h:348
CXTPChartNumberFormat::~CXTPChartNumberFormat
virtual ~CXTPChartNumberFormat()
Destroys a CXTPChartNumberFormat object, handles cleanup.
CXTPChartNumberFormat::GetLocale
LCID GetLocale() const
Definition XTPChartNumberFormat.h:367
CXTPChartNumberFormat::FormatNumber
virtual CString FormatNumber(double dValue) const
Call this method to format number to string.
CXTPChartNumberFormat::SetUseResourceFileLocale
static void AFX_CDECL SetUseResourceFileLocale(BOOL bUseResourceFileLocale)
Used to set which locale is to be used as an the active locale: current user locale or resource file ...
CXTPChartNumberFormat::m_nDecimalPlaces
int m_nDecimalPlaces
Number of digits after decimal places.
Definition XTPChartNumberFormat.h:295
CXTPChartNumberFormat::m_nCategory
XTPChartNumberFormatCategory m_nCategory
Format category.
Definition XTPChartNumberFormat.h:294
CXTPChartNumberFormat::m_bUseThousandSeparator
BOOL m_bUseThousandSeparator
TRUE to separate thousands.
Definition XTPChartNumberFormat.h:296
CXTPChartNumberFormat::m_strPattern
CString m_strPattern
Format pattern.
Definition XTPChartNumberFormat.h:293
CXTPChartNumberFormat::GetCategory
XTPChartNumberFormatCategory GetCategory() const
Definition XTPChartNumberFormat.h:335
CXTPChartNumberFormat::GetUseThousandSeparator
BOOL GetUseThousandSeparator() const
Definition XTPChartNumberFormat.h:355
CXTPChartNumberFormat::FormatPoint
virtual CString FormatPoint(CXTPChartSeriesPoint *pSeriesPoint, double dValue) const
Call this method to format value to string.
CXTPChartNumberFormat::SetLocale
void SetLocale(LCID nLocale)
Call this method to specify locale that will be used to format numbers.
Definition XTPChartNumberFormat.h:371
CXTPChartNumberFormat::GetDecimalPlaces
int GetDecimalPlaces() const
Definition XTPChartNumberFormat.h:344
CXTPChartNumberFormat::IsUseResourceFileLocale
static BOOL AFX_CDECL IsUseResourceFileLocale()
Determines which locale is to be used as an active locale: current user locale or resource file local...
CXTPChartNumberFormat::GetActiveLCID
static LCID AFX_CDECL GetActiveLCID()
Returns active locale ID (current user locale or resource file locale).
CXTPChartNumberFormat::CXTPChartNumberFormat
CXTPChartNumberFormat(CXTPChartElement *pOwner)
Constructs a CXTPChartNumberFormat object.
CXTPChartNumberFormat::GetPattern
CString GetPattern() const
Definition XTPChartNumberFormat.h:326
CXTPChartNumberFormat::FormatDate
virtual CString FormatDate(COleDateTime &dt) const
Call this method to format COleDateTime value to string.
CXTPChartSeriesPoint
CXTPChartSeriesPoint is a kind of CXTPChartElement.
Definition XTPChartSeriesPoint.h:43
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72


Toolkit Pro: Member List

CXTPDockingPanePanelColorSet2012 Member List

This is the complete list of members for CXTPDockingPanePanelColorSet2012, including all inherited members.

CXTPDockingPanePanelColorSet2012() | CXTPDockingPanePanelColorSet2012 |
CXTPTabPaintManagerColorSet() | CXTPTabPaintManagerColorSet |
FillClient(CDC *pDC, CRect rc, CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
FillHeader(CDC *pDC, CRect rc, CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
FillNavigateButton(CDC *pDC, CXTPTabManagerNavigateButton *pButton, CRect &rc) | CXTPDockingPanePanelColorSet2012 | virtual
FillPropertyButton(CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerColorSet | virtual
FillStateButton(CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerColorSet | virtual
GetClientColor(CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
GetItemColor(CXTPTabManagerItem *pItem) | CXTPDockingPanePanelColorSet2012 | virtual
GradientFill(CDC *pDC, CRect rc, COLORREF clrLight, COLORREF clrDark, XTPTabPosition position) | CXTPTabPaintManagerColorSet |
IsAppThemed() const | CXTPTabPaintManagerColorSet | virtual
m_clrActiveFilesBack | CXTPTabPaintManagerColorSet |
m_clrActiveFilesBackHighlighted | CXTPTabPaintManagerColorSet |
m_clrActiveFilesBackPressed | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyph | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyphHighlighted | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyphPressed | CXTPTabPaintManagerColorSet |
m_clrAutoHideFace | CXTPTabPaintManagerColorSet |
m_clrBorderHighlight | CXTPTabPaintManagerColorSet |
m_clrButtonBorder | CXTPTabPaintManagerColorSet |
m_clrButtonBorderHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonBorderHot | CXTPTabPaintManagerColorSet |
m_clrButtonBorderKeyTips | CXTPTabPaintManagerColorSet |
m_clrButtonBorderTabContext1 | CXTPTabPaintManagerColorSet |
m_clrButtonBorderTabContext2 | CXTPTabPaintManagerColorSet |
m_clrButtonHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonHighlightedClose | CXTPTabPaintManagerColorSet |
m_clrButtonNormal | CXTPTabPaintManagerColorSet |
m_clrButtonPressed | CXTPTabPaintManagerColorSet |
m_clrButtonSelected | CXTPTabPaintManagerColorSet |
m_clrButtonSelectedHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonSelectedPressed | CXTPTabPaintManagerColorSet |
m_clrControlFace | CXTPTabPaintManagerColorSet |
m_clrFrameBorder | CXTPTabPaintManagerColorSet |
m_clrHeaderFace | CXTPTabPaintManagerColorSet |
m_clrPaneFace | CXTPTabPaintManagerColorSet |
m_clrTabClientBack | CXTPTabPaintManagerColorSet |
m_clrTabClientBorder | CXTPTabPaintManagerColorSet |
m_clrTextDisabled | CXTPTabPaintManagerColorSet |
m_clrTextHighlight | CXTPTabPaintManagerColorSet |
m_clrTextHighlightClose | CXTPTabPaintManagerColorSet |
m_clrTextNormal | CXTPTabPaintManagerColorSet |
m_clrTextPressed | CXTPTabPaintManagerColorSet |
m_clrTextSelected | CXTPTabPaintManagerColorSet |
m_clrTextSelectedHighlighted | CXTPTabPaintManagerColorSet |
m_clrTextSelectedPressed | CXTPTabPaintManagerColorSet |
m_csExcelNormal | CXTPTabPaintManagerColorSet |
m_csExcelSelected | CXTPTabPaintManagerColorSet |
m_csPropertyPage | CXTPTabPaintManagerColorSet |
m_csPropertyPage2003 | CXTPTabPaintManagerColorSet |
m_csStateButton | CXTPTabPaintManagerColorSet |
m_pPaintManager | CXTPTabPaintManagerColorSet | protected
RefreshMetrics() | CXTPDockingPanePanelColorSet2012 | virtual
SelectClipRgn(CDC *pDC, CRect rcClient, CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
SetTextColor(CDC *pDC, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerColorSet | virtual
~CXTPTabPaintManagerColorSet() | CXTPTabPaintManagerColorSet | virtual


Toolkit Pro: Member List

CXTPFlowGraphUndoGroupCommand Member List

This is the complete list of members for CXTPFlowGraphUndoGroupCommand, including all inherited members.

Add(CXTPFlowGraphUndoCommand *pCommand) | CXTPFlowGraphUndoGroupCommand |
CXTPFlowGraphUndoCommand(int nID) | CXTPFlowGraphUndoCommand | protected
CXTPFlowGraphUndoGroupCommand(CXTPFlowGraphUndoManager *pManager) | CXTPFlowGraphUndoGroupCommand | protected
GetCount() const | CXTPFlowGraphUndoGroupCommand |
GetID() const | CXTPFlowGraphUndoCommand |
m_arrUndoCommands | CXTPFlowGraphUndoGroupCommand | protected
m_nID | CXTPFlowGraphUndoCommand | protected
m_pManager | CXTPFlowGraphUndoGroupCommand | protected
Undo() | CXTPFlowGraphUndoGroupCommand | virtual
~CXTPFlowGraphUndoCommand() | CXTPFlowGraphUndoCommand | protectedvirtual
~CXTPFlowGraphUndoGroupCommand() | CXTPFlowGraphUndoGroupCommand | protectedvirtual


Toolkit Pro: Member List

CXTPCalendarThemeBOOLValue Member List

This is the complete list of members for CXTPCalendarThemeBOOLValue, including all inherited members.

CopySettings(const CXTPCalendarThemeCustomizableXValueT< BOOL, BOOL > &refSrc) | CXTPCalendarThemeCustomizableXValueT< BOOL, BOOL > | inline
CXTPCalendarThemeBOOLValue() | CXTPCalendarThemeBOOLValue |
CXTPCalendarThemeCustomizableXValueT() | CXTPCalendarThemeCustomizableXValueT< BOOL, BOOL > | inline
DoDestroy(BOOL &refValue) | CXTPCalendarThemeCustomizableXValueT< BOOL, BOOL > | inlinevirtual
DoPropExchange(CXTPPropExchange *pPX, LPCTSTR pcszPropName) | CXTPCalendarThemeBOOLValue | virtual
DoPX_Value(CXTPPropExchange *pPX, LPCTSTR pcszPropName, BOOL &rXValue, BOOL bStandard) | CXTPCalendarThemeBOOLValue | protected
GetStandardValue() const | CXTPCalendarThemeCustomizableXValueT< BOOL, BOOL > | inlinevirtual
GetValue() const | CXTPCalendarThemeCustomizableXValueT< BOOL, BOOL > | inlinevirtual
GetValueX() const | CXTPCalendarThemeCustomizableXValueT< BOOL, BOOL > | inlinevirtual
IsCustomValue() const | CXTPCalendarThemeCustomizableXValueT< BOOL, BOOL > | inlinevirtual
IsDefaultValue() const | CXTPCalendarThemeCustomizableXValueT< BOOL, BOOL > | inlinevirtual
IsStandardValue() const | CXTPCalendarThemeCustomizableXValueT< BOOL, BOOL > | inlinevirtual
m_bAutoDestroy_Custom | CXTPCalendarThemeCustomizableXValueT< BOOL, BOOL > | protected
m_bAutoDestroy_Standard | CXTPCalendarThemeCustomizableXValueT< BOOL, BOOL > | protected
m_bIsCustomSet | CXTPCalendarThemeCustomizableXValueT< BOOL, BOOL > | protected
m_bIsStandardSet | CXTPCalendarThemeCustomizableXValueT< BOOL, BOOL > | protected
m_ValueCustom | CXTPCalendarThemeCustomizableXValueT< BOOL, BOOL > | protected
m_ValueStandard | CXTPCalendarThemeCustomizableXValueT< BOOL, BOOL > | protected
operator BOOL() const | CXTPCalendarThemeCustomizableXValueT< BOOL, BOOL > | inline
operator=(BOOL bValue) | CXTPCalendarThemeBOOLValue |
Serialize(CArchive &ar) | CXTPCalendarThemeCustomizableXValueT< BOOL, BOOL > | inlinevirtual
SetCustomValue(BOOL refValue, BOOL bAutoDestroy) | CXTPCalendarThemeCustomizableXValueT< BOOL, BOOL > | inlinevirtual
SetCustomValue(BOOL refValue) | CXTPCalendarThemeCustomizableXValueT< BOOL, BOOL > | inlinevirtual
SetDefaultValue() | CXTPCalendarThemeCustomizableXValueT< BOOL, BOOL > | inlinevirtual
SetStandardValue(BOOL refValue, BOOL bAutoDestroy) | CXTPCalendarThemeCustomizableXValueT< BOOL, BOOL > | inlinevirtual
SetStandardValue(BOOL refValue) | CXTPCalendarThemeCustomizableXValueT< BOOL, BOOL > | inlinevirtual
~CXTPCalendarThemeCustomizableXValueT() | CXTPCalendarThemeCustomizableXValueT< BOOL, BOOL > | inlinevirtual


Toolkit Pro: XTPRichRender.h Source File

  • Source
  • Common
XTPRichRender.h
Go to the documentation of this file.
1
23#if !defined(__XTPRICHRENDER_H__)
24# define __XTPRICHRENDER_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32# pragma warning(push)
33// C4616: #pragma warning : warning number '...' out of range, must be between '4001' and '4999'
34// C4619: #pragma warning : there is no warning number 'number'
35// C5204: '...': class has virtual functions, but its trivial destructor is not virtual; instances
36// of objects derived from this class may not be destructed correctly
37# pragma warning(disable : 4616 4619 5204)
38
40# ifndef _TEXTSERV_H
41# define _TEXTSERV_H
42
43EXTERN_C const IID IID_ITextServices;
44EXTERN_C const IID IID_ITextHost;
45
46// Note: error code is first outside of range reserved for OLE.
47# define S_MSG_KEY_IGNORED MAKE_HRESULT(SEVERITY_SUCCESS, FACILITY_ITF, 0x201)
48
49// Enums used by property methods
50
51/*
52 * TXTBACKSTYLE
53 *
54 * @enum Defines different background styles control
55 */
56enum TXTBACKSTYLE
57{
58 TXTBACK_TRANSPARENT = 0, //@emem background should show through
59 TXTBACK_OPAQUE, //@emem erase background
60};
61
62/*
63 * TXTHITRESULT
64 *
65 * @enum Defines different hitresults
66 */
67enum TXTHITRESULT
68{
69 TXTHITRESULT_NOHIT = 0, //@emem no hit
70 TXTHITRESULT_TRANSPARENT = 1, //@emem point is within the text's rectangle, but
71 // in a transparent region
72 TXTHITRESULT_CLOSE = 2, //@emem point is close to the text
73 TXTHITRESULT_HIT = 3 //@emem dead-on hit
74};
75
76/*
77 * TXTNATURALSIZE
78 *
79 * @enum useful values for TxGetNaturalSize.
80 *
81 * @xref <mf CTxtEdit::TxGetNaturalSize>
82 */
83enum TXTNATURALSIZE
84{
85 TXTNS_FITTOCONTENT = 1, //@emem Get a size that fits the content
86 TXTNS_ROUNDTOLINE = 2 //@emem Round to the nearest whole line.
87};
88
89/*
90 * TXTVIEW
91 *
92 * @enum useful values for TxDraw lViewId parameter
93 *
94 * @xref <mf CTxtEdit::TxDraw>
95 */
96enum TXTVIEW
97{
98 TXTVIEW_ACTIVE = 0,
99 TXTVIEW_INACTIVE = -1
100};
101
102/*
103 * CHANGETYPE
104 *
105 * @enum used for CHANGENOTIFY.dwChangeType; indicates what happened
106 * for a particular change.
107 */
108enum CHANGETYPE
109{
110 CN_GENERIC = 0, //@emem Nothing special happened
111 CN_TEXTCHANGED = 1, //@emem the text changed
112 CN_NEWUNDO = 2, //@emem A new undo action was added
113 CN_NEWREDO = 4 //@emem A new redo action was added
114};
115
116/*
117 * @struct CHANGENOTIFY |
118 *
119 * passed during an EN_CHANGE notification; contains information about
120 * what actually happened for a change.
121 */
122struct CHANGENOTIFY
123{
124 DWORD dwChangeType; //@field TEXT changed, etc
125 void* pvCookieData; //@field cookie for the undo action
126 // associated with the change.
127};
128
129// The TxGetPropertyBits and OnTxPropertyBitsChange methods can pass the following bits:
130
131// NB!!! Do NOT rely on the ordering of these bits yet; the are subject
132// to change.
133# define TXTBIT_RICHTEXT 1 // rich-text control
134# define TXTBIT_MULTILINE 2 // single vs multi-line control
135# define TXTBIT_READONLY 4 // read only text
136# define TXTBIT_SHOWACCELERATOR 8 // underline accelerator character
137# define TXTBIT_USEPASSWORD 0x10 // use password char to display text
138# define TXTBIT_HIDESELECTION 0x20 // show selection when inactive
139# define TXTBIT_SAVESELECTION 0x40 // remember selection when inactive
140# define TXTBIT_AUTOWORDSEL 0x80 // auto-word selection
141# define TXTBIT_VERTICAL 0x100 // vertical
142# define TXTBIT_SELBARCHANGE \
143 0x200 // notification that the selection bar width
144 // has changed.
145 // FUTURE: move this bit to the end to
146 // maintain the division between
147 // properties and notifications.
148# define TXTBIT_WORDWRAP \
149 0x400 // if set, then multi-line controls
150 // should wrap words to fit the available
151 // display
152# define TXTBIT_ALLOWBEEP 0x800 // enable/disable beeping
153# define TXTBIT_DISABLEDRAG 0x1000 // disable/enable dragging
154# define TXTBIT_VIEWINSETCHANGE 0x2000 // the inset changed
155# define TXTBIT_BACKSTYLECHANGE 0x4000
156# define TXTBIT_MAXLENGTHCHANGE 0x8000
157# define TXTBIT_SCROLLBARCHANGE 0x10000
158# define TXTBIT_CHARFORMATCHANGE 0x20000
159# define TXTBIT_PARAFORMATCHANGE 0x40000
160# define TXTBIT_EXTENTCHANGE 0x80000
161# define TXTBIT_CLIENTRECTCHANGE 0x100000 // the client rectangle changed
162# define TXTBIT_USECURRENTBKG \
163 0x200000 // tells the renderer to use the current background
164 // color rather than the system default for an entire line
165
166/*
167 * ITextServices
168 *
169 * @class An interface extending Microsoft's Text Object Model to provide
170 * extra functionality for windowless operation. In conjunction
171 * with ITextHost, ITextServices provides the means by which the
172 * the RichEdit control can be used *without* creating a window.
173 *
174 * @base public | IUnknown
175 */
176class ITextServices : public IUnknown
177{
178public:
179 //@cmember Generic Send Message interface
180 virtual HRESULT TxSendMessage(UINT msg, WPARAM wparam, LPARAM lparam, LRESULT* plresult) = 0;
181
182 //@cmember Rendering
183 virtual HRESULT TxDraw(DWORD dwDrawAspect, LONG lindex, void* pvAspect, DVTARGETDEVICE* ptd,
184 HDC hdcDraw, HDC hicTargetDev, LPCRECTL lprcBounds, LPCRECTL lprcWBounds,
185 LPRECT lprcUpdate, BOOL(CALLBACK* pfnContinue)(DWORD), DWORD dwContinue,
186 LONG lViewId) = 0;
187
188 //@cmember Horizontal scrollbar support
189 virtual HRESULT TxGetHScroll(LONG* plMin, LONG* plMax, LONG* plPos, LONG* plPage,
190 BOOL* pfEnabled) = 0;
191
192 //@cmember Horizontal scrollbar support
193 virtual HRESULT TxGetVScroll(LONG* plMin, LONG* plMax, LONG* plPos, LONG* plPage,
194 BOOL* pfEnabled) = 0;
195
196 //@cmember Setcursor
197 virtual HRESULT OnTxSetCursor(DWORD dwDrawAspect, LONG lindex, void* pvAspect,
198 DVTARGETDEVICE* ptd, HDC hdcDraw, HDC hicTargetDev,
199 LPCRECT lprcClient, INT x, INT y) = 0;
200
201 //@cmember Hit-test
202 virtual HRESULT TxQueryHitPoint(DWORD dwDrawAspect, LONG lindex, void* pvAspect,
203 DVTARGETDEVICE* ptd, HDC hdcDraw, HDC hicTargetDev,
204 LPCRECT lprcClient, INT x, INT y, DWORD* pHitResult) = 0;
205
206 //@cmember Inplace activate notification
207 virtual HRESULT OnTxInPlaceActivate(LPCRECT prcClient) = 0;
208
209 //@cmember Inplace deactivate notification
210 virtual HRESULT OnTxInPlaceDeactivate() = 0;
211
212 //@cmember UI activate notification
213 virtual HRESULT OnTxUIActivate() = 0;
214
215 //@cmember UI deactivate notification
216 virtual HRESULT OnTxUIDeactivate() = 0;
217
218 //@cmember Get text in control
219 virtual HRESULT TxGetText(BSTR* pbstrText) = 0;
220
221 //@cmember Set text in control
222 virtual HRESULT TxSetText(LPCWSTR pszText) = 0;
223
224 //@cmember Get x position of
225 virtual HRESULT TxGetCurTargetX(LONG*) = 0;
226 //@cmember Get baseline position
227 virtual HRESULT TxGetBaseLinePos(LONG*) = 0;
228
229 //@cmember Get Size to fit / Natural size
230 virtual HRESULT TxGetNaturalSize(DWORD dwAspect, HDC hdcDraw, HDC hicTargetDev,
231 DVTARGETDEVICE* ptd, DWORD dwMode, const SIZEL* psizelExtent,
232 LONG* pwidth, LONG* pheight) = 0;
233
234 //@cmember Drag & drop
235 virtual HRESULT TxGetDropTarget(IDropTarget** ppDropTarget) = 0;
236
237 //@cmember Bulk bit property change notifications
238 virtual HRESULT OnTxPropertyBitsChange(DWORD dwMask, DWORD dwBits) = 0;
239
240 //@cmember Fetch the cached drawing size
241 virtual HRESULT TxGetCachedSize(DWORD* pdwWidth, DWORD* pdwHeight) = 0;
242};
243
244/*
245 * ITextHost
246 *
247 * @class Interface to be used by text services to obtain text host services
248 *
249 * @base public | IUnknown
250 */
251class ITextHost : public IUnknown
252{
253public:
254 //@cmember Get the DC for the host
255 virtual HDC TxGetDC() = 0;
256
257 //@cmember Release the DC gotten from the host
258 virtual INT TxReleaseDC(HDC hdc) = 0;
259
260 //@cmember Show the scroll bar
261 virtual BOOL TxShowScrollBar(INT fnBar, BOOL fShow) = 0;
262
263 //@cmember Enable the scroll bar
264 virtual BOOL TxEnableScrollBar(INT fuSBFlags, INT fuArrowflags) = 0;
265
266 //@cmember Set the scroll range
267 virtual BOOL TxSetScrollRange(INT fnBar, LONG nMinPos, INT nMaxPos, BOOL fRedraw) = 0;
268
269 //@cmember Set the scroll position
270 virtual BOOL TxSetScrollPos(INT fnBar, INT nPos, BOOL fRedraw) = 0;
271
272 //@cmember InvalidateRect
273 virtual void TxInvalidateRect(LPCRECT prc, BOOL fMode) = 0;
274
275 //@cmember Send a WM_PAINT to the window
276 virtual void TxViewChange(BOOL fUpdate) = 0;
277
278 //@cmember Create the caret
279 virtual BOOL TxCreateCaret(HBITMAP hbmp, INT xWidth, INT yHeight) = 0;
280
281 //@cmember Show the caret
282 virtual BOOL TxShowCaret(BOOL fShow) = 0;
283
284 //@cmember Set the caret position
285 virtual BOOL TxSetCaretPos(INT x, INT y) = 0;
286
287 //@cmember Create a timer with the specified timeout
288 virtual BOOL TxSetTimer(UINT idTimer, UINT uTimeout) = 0;
289
290 //@cmember Destroy a timer
291 virtual void TxKillTimer(UINT idTimer) = 0;
292
293 //@cmember Scroll the content of the specified window's client area
294 virtual void TxScrollWindowEx(INT dx, INT dy, LPCRECT lprcScroll, LPCRECT lprcClip,
295 HRGN hrgnUpdate, LPRECT lprcUpdate, UINT fuScroll) = 0;
296
297 //@cmember Get mouse capture
298 virtual void TxSetCapture(BOOL fCapture) = 0;
299
300 //@cmember Set the focus to the text window
301 virtual void TxSetFocus() = 0;
302
303 //@cmember Establish a new cursor shape
304 virtual void TxSetCursor(HCURSOR hcur, BOOL fText) = 0;
305
306 //@cmember Converts screen coordinates of a specified point to the client coordinates
307 virtual BOOL TxScreenToClient(LPPOINT lppt) = 0;
308
309 //@cmember Converts the client coordinates of a specified point to screen coordinates
310 virtual BOOL TxClientToScreen(LPPOINT lppt) = 0;
311
312 //@cmember Request host to activate text services
313 virtual HRESULT TxActivate(LONG* plOldState) = 0;
314
315 //@cmember Request host to deactivate text services
316 virtual HRESULT TxDeactivate(LONG lNewState) = 0;
317
318 //@cmember Retrieves the coordinates of a window's client area
319 virtual HRESULT TxGetClientRect(LPRECT prc) = 0;
320
321 //@cmember Get the view rectangle relative to the inset
322 virtual HRESULT TxGetViewInset(LPRECT prc) = 0;
323
324 //@cmember Get the default character format for the text
325 virtual HRESULT TxGetCharFormat(const CHARFORMATW** ppCF) = 0;
326
327 //@cmember Get the default paragraph format for the text
328 virtual HRESULT TxGetParaFormat(const PARAFORMAT** ppPF) = 0;
329
330 //@cmember Get the background color for the window
331 virtual COLORREF TxGetSysColor(int nIndex) = 0;
332
333 //@cmember Get the background (either opaque or transparent)
334 virtual HRESULT TxGetBackStyle(TXTBACKSTYLE* pstyle) = 0;
335
336 //@cmember Get the maximum length for the text
337 virtual HRESULT TxGetMaxLength(DWORD* plength) = 0;
338
339 //@cmember Get the bits representing requested scroll bars for the window
340 virtual HRESULT TxGetScrollBars(DWORD* pdwScrollBar) = 0;
341
342 //@cmember Get the character to display for password input
343 virtual HRESULT TxGetPasswordChar(TCHAR* pch) = 0;
344
345 //@cmember Get the accelerator character
346 virtual HRESULT TxGetAcceleratorPos(LONG* pcp) = 0;
347
348 //@cmember Get the native size
349 virtual HRESULT TxGetExtent(LPSIZEL lpExtent) = 0;
350
351 //@cmember Notify host that default character format has changed
352 virtual HRESULT OnTxCharFormatChange(const CHARFORMATW* pcf) = 0;
353
354 //@cmember Notify host that default paragraph format has changed
355 virtual HRESULT OnTxParaFormatChange(const PARAFORMAT* ppf) = 0;
356
357 //@cmember Bulk access to bit properties
358 virtual HRESULT TxGetPropertyBits(DWORD dwMask, DWORD* pdwBits) = 0;
359
360 //@cmember Notify host of events
361 virtual HRESULT TxNotify(DWORD iNotify, void* pv) = 0;
362
363 // Far East Methods for getting the Input Context
364 //#ifdef WIN95_IME
365 virtual XTP_HIMC TxImmGetContext() = 0;
366 virtual void TxImmReleaseContext(XTP_HIMC himc) = 0;
367 //#endif
368
369 //@cmember Returns HIMETRIC size of the control bar.
370 virtual HRESULT TxGetSelectionBarWidth(LONG* lSelBarWidth) = 0;
371};
372
373//+-----------------------------------------------------------------------
374// Factories
375//------------------------------------------------------------------------
376
377// Text Services factory
378STDAPI CreateTextServices(IUnknown* punkOuter, ITextHost* pITextHost, IUnknown** ppUnk);
379
380typedef HRESULT(STDAPICALLTYPE* PCreateTextServices)(IUnknown* punkOuter, ITextHost* pITextHost,
381 IUnknown** ppUnk);
382
383# endif // _TEXTSERV_H
384
385interface ITextRange;
386
387class _XTP_EXT_CLASS CXTPRichRender : public CXTPCmdTarget
388{
389public:
390 CXTPRichRender();
391 ~CXTPRichRender();
392
393 CSize GetTextExtent(CDC* pDC, int nMaxWidth);
394 void DrawText(CDC* pDC, LPCRECT lpRect);
395 LRESULT SetText(LPCTSTR lpszText);
396 void SetDefaultCharFormat(CHARFORMATW* pcf);
397
398 ITextServices* GetTextService() const;
399
400 DECLARE_INTERFACE_MAP()
401
402 BEGIN_INTERFACE_PART(TextHost, ITextHost)
403 HDC TxGetDC();
404 INT TxReleaseDC(HDC hdc);
405 BOOL TxShowScrollBar(INT fnBar, BOOL fShow);
406 BOOL TxEnableScrollBar(INT fuSBFlags, INT fuArrowflags);
407 BOOL TxSetScrollRange(INT fnBar, LONG nMinPos, INT nMaxPos, BOOL fRedraw);
408 BOOL TxSetScrollPos(INT fnBar, INT nPos, BOOL fRedraw);
409 void TxInvalidateRect(LPCRECT prc, BOOL fMode);
410 void TxViewChange(BOOL fUpdate);
411 BOOL TxCreateCaret(HBITMAP hbmp, INT xWidth, INT yHeight);
412 BOOL TxShowCaret(BOOL fShow);
413 BOOL TxSetCaretPos(INT x, INT y);
414 BOOL TxSetTimer(UINT idTimer, UINT uTimeout);
415 void TxKillTimer(UINT idTimer);
416 void TxScrollWindowEx(INT dx, INT dy, LPCRECT lprcScroll, LPCRECT lprcClip, HRGN hrgnUpdate,
417 LPRECT lprcUpdate, UINT fuScroll);
418 void TxSetCapture(BOOL fCapture);
419 void TxSetFocus();
420 void TxSetCursor(HCURSOR hcur, BOOL fText);
421 BOOL TxScreenToClient(LPPOINT lppt);
422 BOOL TxClientToScreen(LPPOINT lppt);
423 HRESULT TxActivate(LONG* plOldState);
424 HRESULT TxDeactivate(LONG lNewState);
425 HRESULT TxGetClientRect(LPRECT prc);
426 HRESULT TxGetViewInset(LPRECT prc);
427 HRESULT TxGetCharFormat(const CHARFORMATW** ppCF);
428 HRESULT TxGetParaFormat(const PARAFORMAT** ppPF);
429 COLORREF TxGetSysColor(int nIndex);
430 HRESULT TxGetBackStyle(TXTBACKSTYLE* pstyle);
431 HRESULT TxGetMaxLength(DWORD* plength);
432 HRESULT TxGetScrollBars(DWORD* pdwScrollBar);
433 HRESULT TxGetPasswordChar(TCHAR* pch);
434 HRESULT TxGetAcceleratorPos(LONG* pcp);
435 HRESULT TxGetExtent(LPSIZEL lpExtent);
436 HRESULT OnTxCharFormatChange(const CHARFORMATW* pcf);
437 HRESULT OnTxParaFormatChange(const PARAFORMAT* ppf);
438 HRESULT TxGetPropertyBits(DWORD dwMask, DWORD* pdwBits);
439 HRESULT TxNotify(DWORD iNotify, void* pv);
440 XTP_HIMC TxImmGetContext();
441 void TxImmReleaseContext(XTP_HIMC himc);
442 HRESULT TxGetSelectionBarWidth(LONG* lSelBarWidth);
443 END_INTERFACE_PART(TextHost)
444
445 static DWORD CALLBACK RichTextCtrlCallbackIn(DWORD_PTR dwCookie, LPBYTE pbBuff, LONG cb,
446 LONG* pcb);
447
448private:
449 ITextServices* m_pTextService;
450 CHARFORMATW m_charformat;
451 PARAFORMAT m_paraformat;
452 HMODULE m_hModule;
453 CSize m_sizeEditMin;
454};
455
456AFX_INLINE ITextServices* CXTPRichRender::GetTextService() const
457{
458 return m_pTextService;
459}
460
461# pragma warning(pop)
463# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
465#endif // !defined(__XTPRICHRENDER_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122


Toolkit Pro: XTPTabPaintManagerColorSet.h Source File

  • Source
  • TabManager
XTPTabPaintManagerColorSet.h
Go to the documentation of this file.
1
23#if !defined(__XTPTABPAINTMANAGERCOLORSET_H__)
24# define __XTPTABPAINTMANAGERCOLORSET_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPTabManagerItem;
34class CXTPTabManager;
35class CXTPTabManagerNavigateButton;
36class CXTPTabPaintManager;
37
49class _XTP_EXT_CLASS CXTPTabPaintManagerColorSet
50{
51public:
73 struct COLORSET_TAB_EXCEL
74 {
75 CXTPPaintManagerColor clrLeftInnerBorder;
77 CXTPPaintManagerColor clrTopInnerBorder;
79 CXTPPaintManagerColor clrRightInnerBorder;
81 CXTPPaintManagerColor clrLeftOuterBorder;
83 CXTPPaintManagerColor clrRightOuterBorder;
85 CXTPPaintManagerColor clrTopOuterBorder;
87 };
88
110 struct COLORSET_TAB_PROPERTYPAGE
111 {
112 CXTPPaintManagerColor clrHighlight;
114 CXTPPaintManagerColor clrShadow;
115 CXTPPaintManagerColor clrDarkShadow;
116 };
117
133 struct COLORSET_TAB_PROPERTYPAGE2003
134 {
135 CXTPPaintManagerColor clrDarkShadow;
136 CXTPPaintManagerColor clrFrameBorder;
137 CXTPPaintManagerColor clrBorderLeftHighlight;
139 CXTPPaintManagerColor clrBorderTopHighlight;
141 };
142
157 struct COLORSET_TAB_STATEBUTTON
158 {
159 CXTPPaintManagerColorGradient clrFace;
160 CXTPPaintManagerColorGradient clrBorder;
162 };
163
164public:
169 CXTPTabPaintManagerColorSet();
170
175 virtual ~CXTPTabPaintManagerColorSet();
176
177public:
185 virtual void RefreshMetrics();
186
187public:
194 virtual void SetTextColor(CDC* pDC, CXTPTabManagerItem* pItem);
195
210 virtual void FillHeader(CDC* pDC, CRect rc, CXTPTabManager* pTabManager);
211
225 virtual COLORREF FillClient(CDC* pDC, CRect rc, CXTPTabManager* pTabManager);
226
234 virtual COLORREF GetClientColor(CXTPTabManager* pTabManager);
235
249 virtual void FillStateButton(CDC* pDC, CRect rcItem, CXTPTabManagerItem* pItem);
250
266 virtual COLORREF FillPropertyButton(CDC* pDC, CRect rcItem, CXTPTabManagerItem* pItem);
267
276 virtual void SelectClipRgn(CDC* pDC, CRect rcClient, CXTPTabManager* pTabManager);
277
294 virtual void FillNavigateButton(CDC* pDC, CXTPTabManagerNavigateButton* pButton, CRect& rc) = 0;
295
309 virtual COLORREF GetItemColor(CXTPTabManagerItem* pItem);
310
331 void GradientFill(CDC* pDC, CRect rc, COLORREF clrLight, COLORREF clrDark,
332 XTPTabPosition position);
333
345 virtual BOOL IsAppThemed() const;
346
347public:
348 CXTPPaintManagerColorGradient m_clrHeaderFace;
349 CXTPPaintManagerColorGradient m_clrAutoHideFace;
353 CXTPPaintManagerColor m_clrFrameBorder;
355 CXTPPaintManagerColor m_clrControlFace;
357 CXTPPaintManagerColor m_clrPaneFace;
358 CXTPPaintManagerColor m_clrBorderHighlight;
359 CXTPPaintManagerColor m_clrTabClientBack;
360 CXTPPaintManagerColor m_clrTabClientBorder;
361 CXTPPaintManagerColor m_clrButtonNormal;
363 CXTPPaintManagerColor m_clrButtonPressed;
364 CXTPPaintManagerColor m_clrButtonHighlighted;
366 CXTPPaintManagerColor m_clrButtonHighlightedClose;
368 CXTPPaintManagerColor m_clrButtonBorderHighlighted;
370 CXTPPaintManagerColor m_clrButtonBorderTabContext1;
372 CXTPPaintManagerColor m_clrButtonBorderTabContext2;
374 CXTPPaintManagerColor m_clrButtonBorderKeyTips;
376 CXTPPaintManagerColor m_clrButtonSelected;
377 CXTPPaintManagerColor m_clrButtonSelectedPressed;
379 CXTPPaintManagerColor m_clrButtonSelectedHighlighted;
381 CXTPPaintManagerColor m_clrButtonBorder;
382 CXTPPaintManagerColor m_clrButtonBorderHot;
384 CXTPPaintManagerColor m_clrTextNormal;
386 CXTPPaintManagerColor m_clrTextPressed;
389 CXTPPaintManagerColor m_clrTextHighlight;
391 CXTPPaintManagerColor m_clrTextHighlightClose;
393 CXTPPaintManagerColor m_clrTextSelected;
396 CXTPPaintManagerColor m_clrTextSelectedPressed;
400 CXTPPaintManagerColor m_clrTextSelectedHighlighted;
403 CXTPPaintManagerColor m_clrTextDisabled;
405 CXTPPaintManagerColor m_clrActiveFilesGlyph;
406 CXTPPaintManagerColor m_clrActiveFilesGlyphHighlighted;
408 CXTPPaintManagerColor m_clrActiveFilesGlyphPressed;
409 CXTPPaintManagerColor m_clrActiveFilesBack;
411 CXTPPaintManagerColor m_clrActiveFilesBackHighlighted;
413 CXTPPaintManagerColor m_clrActiveFilesBackPressed;
415 COLORSET_TAB_STATEBUTTON m_csStateButton;
416 COLORSET_TAB_PROPERTYPAGE m_csPropertyPage;
417 COLORSET_TAB_PROPERTYPAGE2003 m_csPropertyPage2003;
418 COLORSET_TAB_EXCEL m_csExcelSelected;
419 COLORSET_TAB_EXCEL m_csExcelNormal;
420 CXTPPaintManagerColor m_clrFrameHighlightBorder;
421
423 __declspec(property(get = GetTextSelected,
424 put = SetTextSelected)) CXTPPaintManagerColor& m_clrSelectedText;
425
426 _XTP_DEPRECATED_IN_FAVOR(m_clrTextSelected)
427
428 CXTPPaintManagerColor& GetTextSelected();
429
430 _XTP_DEPRECATED_IN_FAVOR(m_clrTextSelected)
431 const CXTPPaintManagerColor& GetTextSelected() const;
432
433 _XTP_DEPRECATED_IN_FAVOR(m_clrTextSelected)
434 CXTPPaintManagerColor& SetTextSelected(const CXTPPaintManagerColor& clr);
435
438protected:
439 CXTPTabPaintManager* m_pPaintManager;
441 friend class CXTPTabPaintManager;
442};
444AFX_INLINE void CXTPTabPaintManagerColorSet::SelectClipRgn(CDC* /*pDC*/, CRect /*rcClient*/,
445 CXTPTabManager* /*pTabManager*/)
446{
447}
448
449AFX_INLINE CXTPPaintManagerColor& CXTPTabPaintManagerColorSet::GetTextSelected()
450{
451 return m_clrTextSelected;
452}
453
454AFX_INLINE const CXTPPaintManagerColor& CXTPTabPaintManagerColorSet::GetTextSelected() const
455{
456 return m_clrTextSelected;
457}
458
459AFX_INLINE CXTPPaintManagerColor&
460 CXTPTabPaintManagerColorSet::SetTextSelected(const CXTPPaintManagerColor& clr)
461{
462 m_clrTextSelected = clr;
463 return m_clrTextSelected;
464}
466# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
468#endif // !defined(__XTPTABPAINTMANAGERCOLORSET_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPTabPosition
XTPTabPosition
XTPTabPosition is an enumeration used to set the position of tabs.
Definition XTPTabManagerDefines.h:200
CXTPPaintManagerColorGradient
The CXTPPaintManagerColorGradient class is used to manage COLORREF values for determining light and d...
Definition XTPColorManager.h:301
CXTPPaintManagerColor
The CXTPPaintManagerColor class is used to manage COLORREF values for determining default and applica...
Definition XTPColorManager.h:117
CXTPTabManager
CXTPTabManager is the base class for docking pane tabs, tab control tabs, and MDI client tabs.
Definition XTPTabManager.h:87
CXTPTabManagerItem
CXTPTabManagerItem is the base class for the tabs that appear in the command bars tab workspace,...
Definition XTPTabManagerItem.h:44
CXTPTabManagerNavigateButton
CXTPTabManagerNavigateButton is a class used to represent a tab navigation button.
Definition XTPTabManagerNavigateButton.h:74
CXTPTabPaintManagerColorSet
CXTPTabPaintManagerColorSet represents the colors for all of the components of the tab manager (e....
Definition XTPTabPaintManagerColorSet.h:50
CXTPTabPaintManagerColorSet::m_clrButtonSelectedPressed
CXTPPaintManagerColor m_clrButtonSelectedPressed
Color of the currently selected tab when pressed.
Definition XTPTabPaintManagerColorSet.h:377
CXTPTabPaintManagerColorSet::FillNavigateButton
virtual void FillNavigateButton(CDC *pDC, CXTPTabManagerNavigateButton *pButton, CRect &rc)=0
Fills a specified tab navigation button.
CXTPTabPaintManagerColorSet::m_csStateButton
COLORSET_TAB_STATEBUTTON m_csStateButton
Color set of state button style tabs.
Definition XTPTabPaintManagerColorSet.h:415
CXTPTabPaintManagerColorSet::m_clrTextDisabled
CXTPPaintManagerColor m_clrTextDisabled
Color of text when a tab is disabled.
Definition XTPTabPaintManagerColorSet.h:403
CXTPTabPaintManagerColorSet::m_clrTextHighlight
CXTPPaintManagerColor m_clrTextHighlight
Color of text on mouse over when hot tracking is enabled.
Definition XTPTabPaintManagerColorSet.h:389
CXTPTabPaintManagerColorSet::FillHeader
virtual void FillHeader(CDC *pDC, CRect rc, CXTPTabManager *pTabManager)
Fills the header of the tab client of a specified tab manager.
CXTPTabPaintManagerColorSet::m_clrButtonBorder
CXTPPaintManagerColor m_clrButtonBorder
Tab button border (edge) color.
Definition XTPTabPaintManagerColorSet.h:381
CXTPTabPaintManagerColorSet::m_clrTextPressed
CXTPPaintManagerColor m_clrTextPressed
Color of text in a "pressed" tab button.
Definition XTPTabPaintManagerColorSet.h:386
CXTPTabPaintManagerColorSet::GetItemColor
virtual COLORREF GetItemColor(CXTPTabManagerItem *pItem)
Retrieves the color of a specified tab.
CXTPTabPaintManagerColorSet::m_clrActiveFilesGlyphHighlighted
CXTPPaintManagerColor m_clrActiveFilesGlyphHighlighted
Color of highlighted navigation button.
Definition XTPTabPaintManagerColorSet.h:406
CXTPTabPaintManagerColorSet::m_clrTabClientBorder
CXTPPaintManagerColor m_clrTabClientBorder
Border color for the tab client area.
Definition XTPTabPaintManagerColorSet.h:360
CXTPTabPaintManagerColorSet::m_clrBorderHighlight
CXTPPaintManagerColor m_clrBorderHighlight
Color of the highlight border.
Definition XTPTabPaintManagerColorSet.h:358
CXTPTabPaintManagerColorSet::FillClient
virtual COLORREF FillClient(CDC *pDC, CRect rc, CXTPTabManager *pTabManager)
Fills the tab client area of a specified tab manager.
CXTPTabPaintManagerColorSet::m_clrPaneFace
CXTPPaintManagerColor m_clrPaneFace
Color of the control pane foreground.
Definition XTPTabPaintManagerColorSet.h:357
CXTPTabPaintManagerColorSet::m_clrActiveFilesGlyphPressed
CXTPPaintManagerColor m_clrActiveFilesGlyphPressed
Color of selected navigation button.
Definition XTPTabPaintManagerColorSet.h:408
CXTPTabPaintManagerColorSet::m_csExcelNormal
COLORSET_TAB_EXCEL m_csExcelNormal
Color set of normal Excel style tabs.
Definition XTPTabPaintManagerColorSet.h:419
CXTPTabPaintManagerColorSet::GradientFill
void GradientFill(CDC *pDC, CRect rc, COLORREF clrLight, COLORREF clrDark, XTPTabPosition position)
Performs a gradient fill of a rectangle with a color that smoothly fades from top to bottom.
CXTPTabPaintManagerColorSet::m_clrActiveFilesBack
CXTPPaintManagerColor m_clrActiveFilesBack
Color of highlighted navigation button background.
Definition XTPTabPaintManagerColorSet.h:409
CXTPTabPaintManagerColorSet::m_clrButtonNormal
CXTPPaintManagerColor m_clrButtonNormal
Color of normal tabs.
Definition XTPTabPaintManagerColorSet.h:361
CXTPTabPaintManagerColorSet::CXTPTabPaintManagerColorSet
CXTPTabPaintManagerColorSet()
Constructs a CXTPTabPaintManagerColorSet object.
CXTPTabPaintManagerColorSet::m_clrButtonSelectedHighlighted
CXTPPaintManagerColor m_clrButtonSelectedHighlighted
Color of the currently selected tab when highlighted.
Definition XTPTabPaintManagerColorSet.h:379
CXTPTabPaintManagerColorSet::m_clrActiveFilesBackPressed
CXTPPaintManagerColor m_clrActiveFilesBackPressed
Color of selected navigation button background.
Definition XTPTabPaintManagerColorSet.h:413
CXTPTabPaintManagerColorSet::IsAppThemed
virtual BOOL IsAppThemed() const
Determines if Windows XP themes are enabled and if a Windows XP theme is currently used.
CXTPTabPaintManagerColorSet::m_clrTextSelectedPressed
CXTPPaintManagerColor m_clrTextSelectedPressed
Color of text in a "pressed" tab button.
Definition XTPTabPaintManagerColorSet.h:396
CXTPTabPaintManagerColorSet::m_clrTabClientBack
CXTPPaintManagerColor m_clrTabClientBack
Background color for the tab client area.
Definition XTPTabPaintManagerColorSet.h:359
CXTPTabPaintManagerColorSet::m_clrTextHighlightClose
CXTPPaintManagerColor m_clrTextHighlightClose
Color of close button text on mouse over when hot tracking is enabled.
Definition XTPTabPaintManagerColorSet.h:391
CXTPTabPaintManagerColorSet::m_clrTextSelected
CXTPPaintManagerColor m_clrTextSelected
Color of text in a "selected" tab button.
Definition XTPTabPaintManagerColorSet.h:393
CXTPTabPaintManagerColorSet::m_clrAutoHideFace
CXTPPaintManagerColorGradient m_clrAutoHideFace
Color set of the auto-hide panel background.
Definition XTPTabPaintManagerColorSet.h:349
CXTPTabPaintManagerColorSet::m_clrButtonHighlightedClose
CXTPPaintManagerColor m_clrButtonHighlightedClose
Tab close button color on mouse over when hot tracking is enabled.
Definition XTPTabPaintManagerColorSet.h:366
CXTPTabPaintManagerColorSet::m_clrButtonBorderHighlighted
CXTPPaintManagerColor m_clrButtonBorderHighlighted
Tab button border color on mouse over when hot tracking is enabled.
Definition XTPTabPaintManagerColorSet.h:368
CXTPTabPaintManagerColorSet::m_clrHeaderFace
CXTPPaintManagerColorGradient m_clrHeaderFace
Color set of the tab header background.
Definition XTPTabPaintManagerColorSet.h:348
CXTPTabPaintManagerColorSet::m_clrActiveFilesGlyph
CXTPPaintManagerColor m_clrActiveFilesGlyph
Color of navigation button.
Definition XTPTabPaintManagerColorSet.h:405
CXTPTabPaintManagerColorSet::m_clrButtonBorderHot
CXTPPaintManagerColor m_clrButtonBorderHot
Tab button highlight or pressed border (edge) color.
Definition XTPTabPaintManagerColorSet.h:382
CXTPTabPaintManagerColorSet::m_csPropertyPage2003
COLORSET_TAB_PROPERTYPAGE2003 m_csPropertyPage2003
Color set of Office 2003 style tabs.
Definition XTPTabPaintManagerColorSet.h:417
CXTPTabPaintManagerColorSet::~CXTPTabPaintManagerColorSet
virtual ~CXTPTabPaintManagerColorSet()
Destroys a CXTPTabPaintManagerColorSet object, handles cleanup and deallocation.
CXTPTabPaintManagerColorSet::m_clrTextSelectedHighlighted
CXTPPaintManagerColor m_clrTextSelectedHighlighted
Color of text for tabs in all non-active groups of tabs in MDITabClient.
Definition XTPTabPaintManagerColorSet.h:400
CXTPTabPaintManagerColorSet::FillStateButton
virtual void FillStateButton(CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem)
Fills a specified tab button when XTPTabAppearanceStyle is xtpTabAppearanceStateButtons.
CXTPTabPaintManagerColorSet::m_csExcelSelected
COLORSET_TAB_EXCEL m_csExcelSelected
Color set of selected (focused) Excel style tabs.
Definition XTPTabPaintManagerColorSet.h:418
CXTPTabPaintManagerColorSet::SelectClipRgn
virtual void SelectClipRgn(CDC *pDC, CRect rcClient, CXTPTabManager *pTabManager)
Sets a clipping region for the specified tab client area.
CXTPTabPaintManagerColorSet::m_clrFrameBorder
CXTPPaintManagerColor m_clrFrameBorder
Color of the border placed around the tab buttons and the tab client.
Definition XTPTabPaintManagerColorSet.h:353
CXTPTabPaintManagerColorSet::m_clrButtonBorderTabContext2
CXTPPaintManagerColor m_clrButtonBorderTabContext2
Tab button border color with tab context.
Definition XTPTabPaintManagerColorSet.h:372
CXTPTabPaintManagerColorSet::m_csPropertyPage
COLORSET_TAB_PROPERTYPAGE m_csPropertyPage
Color set of visual studio style tabs.
Definition XTPTabPaintManagerColorSet.h:416
CXTPTabPaintManagerColorSet::m_clrTextNormal
CXTPPaintManagerColor m_clrTextNormal
Color of text in a normal tab.
Definition XTPTabPaintManagerColorSet.h:384
CXTPTabPaintManagerColorSet::m_clrButtonBorderTabContext1
CXTPPaintManagerColor m_clrButtonBorderTabContext1
Tab button border color with tab context.
Definition XTPTabPaintManagerColorSet.h:370
CXTPTabPaintManagerColorSet::RefreshMetrics
virtual void RefreshMetrics()
Refreshes the visual metrics of the tabs.
CXTPTabPaintManagerColorSet::m_clrButtonHighlighted
CXTPPaintManagerColor m_clrButtonHighlighted
Tab button color on mouse over when hot tracking is enabled.
Definition XTPTabPaintManagerColorSet.h:364
CXTPTabPaintManagerColorSet::m_clrControlFace
CXTPPaintManagerColor m_clrControlFace
Color of the control foreground.
Definition XTPTabPaintManagerColorSet.h:355
CXTPTabPaintManagerColorSet::GetClientColor
virtual COLORREF GetClientColor(CXTPTabManager *pTabManager)
Obtains client background color.
CXTPTabPaintManagerColorSet::m_pPaintManager
CXTPTabPaintManager * m_pPaintManager
Self paint manager pointer.
Definition XTPTabPaintManagerColorSet.h:439
CXTPTabPaintManagerColorSet::SetTextColor
virtual void SetTextColor(CDC *pDC, CXTPTabManagerItem *pItem)
Sets the text color for the tab.
CXTPTabPaintManagerColorSet::FillPropertyButton
virtual COLORREF FillPropertyButton(CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem)
Fills a specified tab button.
CXTPTabPaintManagerColorSet::m_clrActiveFilesBackHighlighted
CXTPPaintManagerColor m_clrActiveFilesBackHighlighted
Color of navigation button background.
Definition XTPTabPaintManagerColorSet.h:411
CXTPTabPaintManagerColorSet::m_clrButtonPressed
CXTPPaintManagerColor m_clrButtonPressed
Tab pressed button color.
Definition XTPTabPaintManagerColorSet.h:363
CXTPTabPaintManagerColorSet::m_clrButtonBorderKeyTips
CXTPPaintManagerColor m_clrButtonBorderKeyTips
Tab button border color when ALT button is pressed.
Definition XTPTabPaintManagerColorSet.h:374
CXTPTabPaintManagerColorSet::m_clrButtonSelected
CXTPPaintManagerColor m_clrButtonSelected
Color of the currently selected tab.
Definition XTPTabPaintManagerColorSet.h:376
CXTPTabPaintManager
CXTPTabPaintManager is used to store the color and appearance information of the tabs in the tab mana...
Definition XTPTabPaintManager.h:48
CXTPTabPaintManagerColorSet::COLORSET_TAB_EXCEL
Colors used for Excel tab button colorization.
Definition XTPTabPaintManagerColorSet.h:74
CXTPTabPaintManagerColorSet::COLORSET_TAB_EXCEL::clrRightInnerBorder
CXTPPaintManagerColor clrRightInnerBorder
Color of the right inner border of the tab button.
Definition XTPTabPaintManagerColorSet.h:79
CXTPTabPaintManagerColorSet::COLORSET_TAB_EXCEL::clrTopOuterBorder
CXTPPaintManagerColor clrTopOuterBorder
Color of the top outer border of the tab button.
Definition XTPTabPaintManagerColorSet.h:85
CXTPTabPaintManagerColorSet::COLORSET_TAB_EXCEL::clrRightOuterBorder
CXTPPaintManagerColor clrRightOuterBorder
Color of the right outer border of the tab button.
Definition XTPTabPaintManagerColorSet.h:83
CXTPTabPaintManagerColorSet::COLORSET_TAB_EXCEL::clrLeftOuterBorder
CXTPPaintManagerColor clrLeftOuterBorder
Color of the left outer border of the tab button.
Definition XTPTabPaintManagerColorSet.h:81
CXTPTabPaintManagerColorSet::COLORSET_TAB_EXCEL::clrLeftInnerBorder
CXTPPaintManagerColor clrLeftInnerBorder
Color of the left inner border of the tab button.
Definition XTPTabPaintManagerColorSet.h:75
CXTPTabPaintManagerColorSet::COLORSET_TAB_EXCEL::clrTopInnerBorder
CXTPPaintManagerColor clrTopInnerBorder
Color of the top inner border of the tab button.
Definition XTPTabPaintManagerColorSet.h:77
CXTPTabPaintManagerColorSet::COLORSET_TAB_PROPERTYPAGE2003
Colors used for Office 2003 tab button colorization.
Definition XTPTabPaintManagerColorSet.h:134
CXTPTabPaintManagerColorSet::COLORSET_TAB_PROPERTYPAGE2003::clrBorderTopHighlight
CXTPPaintManagerColor clrBorderTopHighlight
Color of the top border of a tab button.
Definition XTPTabPaintManagerColorSet.h:139
CXTPTabPaintManagerColorSet::COLORSET_TAB_PROPERTYPAGE2003::clrFrameBorder
CXTPPaintManagerColor clrFrameBorder
Color of the XTPTabClientFrame.
Definition XTPTabPaintManagerColorSet.h:136
CXTPTabPaintManagerColorSet::COLORSET_TAB_PROPERTYPAGE2003::clrBorderLeftHighlight
CXTPPaintManagerColor clrBorderLeftHighlight
Color of the left border of a tab button.
Definition XTPTabPaintManagerColorSet.h:137
CXTPTabPaintManagerColorSet::COLORSET_TAB_PROPERTYPAGE2003::clrDarkShadow
CXTPPaintManagerColor clrDarkShadow
Color of the shadow of a tab button.
Definition XTPTabPaintManagerColorSet.h:135
CXTPTabPaintManagerColorSet::COLORSET_TAB_PROPERTYPAGE
Colors used for Office 2000 tab button colorization.
Definition XTPTabPaintManagerColorSet.h:111
CXTPTabPaintManagerColorSet::COLORSET_TAB_PROPERTYPAGE::clrShadow
CXTPPaintManagerColor clrShadow
Color of the tab button's shadow.
Definition XTPTabPaintManagerColorSet.h:114
CXTPTabPaintManagerColorSet::COLORSET_TAB_PROPERTYPAGE::clrHighlight
CXTPPaintManagerColor clrHighlight
Color of tab button on mouse over when hot tracking is enabled.
Definition XTPTabPaintManagerColorSet.h:112
CXTPTabPaintManagerColorSet::COLORSET_TAB_PROPERTYPAGE::clrDarkShadow
CXTPPaintManagerColor clrDarkShadow
Color of the tab button's dark shadow.
Definition XTPTabPaintManagerColorSet.h:115
CXTPTabPaintManagerColorSet::COLORSET_TAB_STATEBUTTON
Colors used for "State Button" tab button colorization.
Definition XTPTabPaintManagerColorSet.h:158
CXTPTabPaintManagerColorSet::COLORSET_TAB_STATEBUTTON::clrFace
CXTPPaintManagerColorGradient clrFace
Color of the currently selected tab button.
Definition XTPTabPaintManagerColorSet.h:159
CXTPTabPaintManagerColorSet::COLORSET_TAB_STATEBUTTON::clrBorder
CXTPPaintManagerColorGradient clrBorder
Border color of the currently selected tab button.
Definition XTPTabPaintManagerColorSet.h:160


Toolkit Pro: Member List

CXTPDockingPanePanelTheme2022 Member List

This is the complete list of members for CXTPDockingPanePanelTheme2022, including all inherited members.

AdjustClientRect(CXTPTabManager *pTabManager, CRect &rcClient) | CXTPTabPaintManagerTheme | virtual
CXTPDockingPanePanelTheme2012() | CXTPDockingPanePanelTheme2012 |
CXTPDockingPanePanelTheme2022() | CXTPDockingPanePanelTheme2022 |
CXTPTabPaintManagerTheme() | CXTPTabPaintManagerTheme |
CXTPTabThemeFlat() | CXTPTabThemeFlat | inline
DrawSingleButton(CDC *pDC, CXTPTabManagerItem *pItem) | CXTPDockingPanePanelTheme2012 | virtual
DrawTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl) | CXTPTabPaintManagerTheme | virtual
DrawText(CDC *pDC, CXTPTabManager *pManager, const CString &str, LPRECT lpRect, UINT nFormat) | CXTPTabPaintManagerTheme | virtual
DrawWorkspacePart(CDC *pDC, LPRECT lpRect, XTPTabWorkspacePart workspacePart) | CXTPTabPaintManagerTheme | virtual
FillButton(CDC *pDC, CXTPTabManagerItem *pItem, LPPOINT pts, int nCount, XTPTabPosition tabPosition, BOOL bAbsolute=FALSE) | CXTPTabPaintManagerTheme |
FillTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl) | CXTPTabThemeFlat | virtual
GetButtonDrawRect(const CXTPTabManagerItem *pItem) | CXTPTabPaintManagerTheme | virtual
GetButtonHeight(const CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetButtonLength(CDC *pDC, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerTheme | virtual
GetClientMargin() | CXTPTabPaintManagerTheme | virtual
GetClientRect(CRect rcControl, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetColorSet() const | CXTPTabPaintManagerTheme |
GetDefaultColorSet() | CXTPTabThemeFlat | inlinevirtual
GetHeaderClipBox(CDC *pDC, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetHeaderHeight(CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme |
GetHeaderMargin() | CXTPTabPaintManagerTheme | virtual
GetHeaderRect(CRect rcControl, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetSupportedColorSets() | CXTPTabPaintManagerTheme | inlinevirtual
m_bButtonsReverseZOrder | CXTPTabPaintManagerTheme | protected
m_nButtonHeight | CXTPTabPaintManagerTheme | protected
m_nGripperWidth | CXTPDockingPanePanelTheme2012 | protected
m_nRowMargin | CXTPTabPaintManagerTheme |
m_pPaintManager | CXTPTabPaintManagerTheme | protected
m_rcHeaderMargin | CXTPTabPaintManagerTheme |
RefreshMetrics() | CXTPDockingPanePanelTheme2012 | virtual
RepositionTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcClient) | CXTPTabPaintManagerTheme | virtual
~CXTPTabPaintManagerTheme() | CXTPTabPaintManagerTheme | virtual


Toolkit Pro: Member List

CXTPGridHyperlinks Member List

This is the complete list of members for CXTPGridHyperlinks, including all inherited members.

Add(ARG_TYPE newElement) | CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE > | virtual
AddIfNeed(ARG_TYPE newElement) | CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE > | virtual
Append(const CXTPArrayT &src) | CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE > | virtual
Copy(const CXTPArrayT &src) | CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE > | virtual
CopyFrom(CXTPGridHyperlinks *pSrc) | CXTPGridHyperlinks | virtual
CXTPArrayT() | CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE > |
CXTPCmdTarget() | CXTPCmdTarget |
CXTPGridHyperlinks() | CXTPGridHyperlinks |
DoPropExchange(CXTPPropExchange *pPX) | CXTPGridHyperlinks | virtual
ElementAt(int nIndex) | CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE > | virtual
FindElement(ARG_TYPE nElement) const | CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE > | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAt(int nIndex) const | CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE > | virtual
GetData() const | CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE > | virtual
GetData() | CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE > | virtual
GetSize() const | CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE > | virtual
InsertAt(int nIndex, ARG_TYPE newElement, int nCount=1) | CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE > | virtual
InsertAt(int nStartIndex, CXTPArrayT *pNewArray) | CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE > | virtual
m_arElements | CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE > | protected
operator delete(void *p) | CXTPHeapObjectT< CXTPGridHyperlinks_base, CXTPGridDataAllocator > | inline
operator new(size_t nSize) | CXTPHeapObjectT< CXTPGridHyperlinks_base, CXTPGridDataAllocator > | inline
operator[](int nIndex) const | CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE > |
operator[](int nIndex) | CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE > |
RemoveAll() | CXTPGridHyperlinks | virtual
RemoveAt(int nIndex) | CXTPGridHyperlinks | virtual
RemoveAt(int nIndex, int nCount) | CXTPGridHyperlinks | virtual
RemoveElement(ARG_TYPE nElement) | CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE > | virtual
SetAt(int nIndex, ARG_TYPE newElement) | CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE > | virtual
SetAtGrow(int nIndex, ARG_TYPE newElement) | CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE > | virtual
SetSize(int nNewSize, int nGrowBy=-1) | CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE > | virtual
~CXTPArrayT() | CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE > | virtual
~CXTPGridHyperlinks() | CXTPGridHyperlinks | virtual


Toolkit Pro: XTPDockingPanePanelTheme2019.h Source File

  • Source
  • DockingPane
  • TabThemes
XTPDockingPanePanelTheme2019.h
Go to the documentation of this file.
1
23#if !defined(__XTPDOCKINGPANEPANELTHEME2019_H__)
24# define __XTPDOCKINGPANEPANELTHEME2019_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPDockingPanePanelTheme2019 : public CXTPDockingPanePanelTheme2012
39{
40public:
45 CXTPDockingPanePanelTheme2019();
46};
47
48# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
50#endif // !defined(__XTPDOCKINGPANEPANELTHEME2019_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPDockingPanePanelTheme2012
Helper class used to initialize default colors for a theme from an .INI resource and handle drawing r...
Definition XTPDockingPanePanelTheme2012.h:39
CXTPDockingPanePanelTheme2019
Helper class used to initialize default colors for a theme from an .INI resource and handle drawing r...
Definition XTPDockingPanePanelTheme2019.h:39
CXTPDockingPanePanelTheme2019::CXTPDockingPanePanelTheme2019
CXTPDockingPanePanelTheme2019()
Default class constructor.


Toolkit Pro: XTPSyntaxEditLexClassSubObjDef.h Source File

  • Source
  • SyntaxEdit
XTPSyntaxEditLexClassSubObjDef.h
Go to the documentation of this file.
1
23#if !defined(__XTPSYNTAXEDITLEXCLASSSUBOBJDEF_H__)
24# define __XTPSYNTAXEDITLEXCLASSSUBOBJDEF_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33# pragma warning(disable : 4097)
34
36namespace XTPSyntaxEditLexAnalyser
38{
40# define XTP_EDIT_LEX_CLASS_OBJ_MEMBER_NAME(_Name, _str) \
41 inline LPCTSTR _Name() \
42 { \
43 return _str; \
44 }
45
46# define XTP_EDIT_LEX_CLASS_OBJ_MEMBER(id, _member) \
47 public: \
48 TBase::_Type##id _member; \
49 \
50 protected: \
51 virtual void SetSubMember##id() \
52 { \
53 m_p##id = &_member; \
54 }
55
56# define XTP_EDIT_DEFINE_LEX_CLASS_OBJ_BASE_N1(subN1) \
57 CXTPSyntaxEditLexObj_SpecCollT<CXTPSyntaxEditLexVariantPtrArrayExAutomatT<subN1> >
58
59# define XTP_EDIT_DEFINE_LEX_CLASS_OBJ_BASE_N2(subN1, subN2) \
60 CXTPSyntaxEditLexObj_SpecCollT<CXTPSyntaxEditLexVariantPtrArrayExAutomatT<subN1>, \
61 CXTPSyntaxEditLexVariantPtrArrayExAutomatT<subN2> >
62
63# define XTP_EDIT_DEFINE_LEX_CLASS_OBJ_BASE_N3(subN1, subN2, subN3) \
64 CXTPSyntaxEditLexObj_SpecCollT<CXTPSyntaxEditLexVariantPtrArrayExAutomatT<subN1>, \
65 CXTPSyntaxEditLexVariantPtrArrayExAutomatT<subN2>, \
66 CXTPSyntaxEditLexVariantPtrArrayExAutomatT<subN3> >
67
68# define XTP_EDIT_DEFINE_LEX_CLASS_OBJ(objClass, DEF_BASE_Nx) \
69 class objClass : public DEF_BASE_Nx \
70 { \
71 public: \
72 typedef DEF_BASE_Nx TBase; \
73 objClass() \
74 { \
75 SetSubMembers(); \
76 }; \
77 virtual ~objClass(){};
78
79# define XTP_EDIT_DEFINE_LEX_CLASS_OBJ_N1(objClass, subN1) \
80 XTP_EDIT_DEFINE_LEX_CLASS_OBJ(objClass, XTP_EDIT_DEFINE_LEX_CLASS_OBJ_BASE_N1(subN1))
81
82# define XTP_EDIT_DEFINE_LEX_CLASS_OBJ_N2(objClass, subN1, subN2) \
83 XTP_EDIT_DEFINE_LEX_CLASS_OBJ(objClass, XTP_EDIT_DEFINE_LEX_CLASS_OBJ_BASE_N2(subN1, subN2))
84
85# define XTP_EDIT_DEFINE_LEX_CLASS_OBJ_N3(objClass, subN1, subN2, subN3) \
86 XTP_EDIT_DEFINE_LEX_CLASS_OBJ(objClass, \
87 XTP_EDIT_DEFINE_LEX_CLASS_OBJ_BASE_N3(subN1, subN2, subN3))
88
89# define XTP_EDIT_DEFINE_LEX_CLASS_OBJ_END \
90 } \
91 ;
93
94//= Prevoius =============================================================
95XTP_EDIT_LEX_CLASS_OBJ_MEMBER_NAME(FnName_previous_class, _T("previous:class"))
96XTP_EDIT_LEX_CLASS_OBJ_MEMBER_NAME(FnName_previous_tag, _T("previous:tag"))
97XTP_EDIT_LEX_CLASS_OBJ_MEMBER_NAME(FnName_previous_tag_separators, _T("previous:tag:separators"))
98
99XTP_EDIT_DEFINE_LEX_CLASS_OBJ_N3(CXTPSyntaxEditLexObj_Previous, FnName_previous_class,
100 FnName_previous_tag, FnName_previous_tag_separators)
101XTP_EDIT_LEX_CLASS_OBJ_MEMBER(0, m_class)
102XTP_EDIT_LEX_CLASS_OBJ_MEMBER(1, m_tag)
103XTP_EDIT_LEX_CLASS_OBJ_MEMBER(2, m_tag_separators)
104XTP_EDIT_DEFINE_LEX_CLASS_OBJ_END
105
106//= Start ================================================================
107XTP_EDIT_LEX_CLASS_OBJ_MEMBER_NAME(FnName_start_class, _T("start:class"))
108XTP_EDIT_LEX_CLASS_OBJ_MEMBER_NAME(FnName_start_tag, _T("start:tag"))
109
110XTP_EDIT_DEFINE_LEX_CLASS_OBJ_N2(CXTPSyntaxEditLexObj_Start, FnName_start_class, FnName_start_tag)
111XTP_EDIT_LEX_CLASS_OBJ_MEMBER(0, m_class)
112XTP_EDIT_LEX_CLASS_OBJ_MEMBER(1, m_tag)
113XTP_EDIT_DEFINE_LEX_CLASS_OBJ_END
114
115//= End ================================================================
116XTP_EDIT_LEX_CLASS_OBJ_MEMBER_NAME(FnName_end_class, _T("end:class"))
117XTP_EDIT_LEX_CLASS_OBJ_MEMBER_NAME(FnName_end_tag, _T("end:tag"))
118XTP_EDIT_LEX_CLASS_OBJ_MEMBER_NAME(FnName_end_separators, _T("end:separators"))
119
120XTP_EDIT_DEFINE_LEX_CLASS_OBJ_N3(CXTPSyntaxEditLexObj_End, FnName_end_class, FnName_end_tag,
121 FnName_end_separators)
122XTP_EDIT_LEX_CLASS_OBJ_MEMBER(0, m_class)
123XTP_EDIT_LEX_CLASS_OBJ_MEMBER(1, m_tag)
124XTP_EDIT_LEX_CLASS_OBJ_MEMBER(2, m_separators)
125XTP_EDIT_DEFINE_LEX_CLASS_OBJ_END
126
127//= Token ================================================================
128XTP_EDIT_LEX_CLASS_OBJ_MEMBER_NAME(FnName_tokeFnName_tag, _T("token:tag"))
129XTP_EDIT_LEX_CLASS_OBJ_MEMBER_NAME(FnName_tokeFnName_start_separators, _T("token:start:separators"))
130XTP_EDIT_LEX_CLASS_OBJ_MEMBER_NAME(FnName_tokeFnName_end_separators, _T("token:end:separators"))
131
132XTP_EDIT_DEFINE_LEX_CLASS_OBJ_N3(CXTPSyntaxEditLexObj_Token, FnName_tokeFnName_tag,
133 FnName_tokeFnName_start_separators,
134 FnName_tokeFnName_end_separators)
135XTP_EDIT_LEX_CLASS_OBJ_MEMBER(0, m_tag)
136XTP_EDIT_LEX_CLASS_OBJ_MEMBER(1, m_start_separators)
137XTP_EDIT_LEX_CLASS_OBJ_MEMBER(2, m_end_separators)
138XTP_EDIT_DEFINE_LEX_CLASS_OBJ_END
139
140//= Skip ================================================================
141XTP_EDIT_LEX_CLASS_OBJ_MEMBER_NAME(FnName_skip_tag, _T("skip:tag"))
142
143XTP_EDIT_DEFINE_LEX_CLASS_OBJ_N1(CXTPSyntaxEditLexObj_Skip, FnName_skip_tag)
144XTP_EDIT_LEX_CLASS_OBJ_MEMBER(0, m_tag)
145XTP_EDIT_DEFINE_LEX_CLASS_OBJ_END
146
147//= active tags (INTERNAL OBJECT) ================================================================
148XTP_EDIT_LEX_CLASS_OBJ_MEMBER_NAME(FnName_active_tags, _T("_active_tags"))
149
150class CXTPSyntaxEditLexObj_ActiveTags
151 : public CXTPSyntaxEditLexVariantPtrArrayExAutomatT<FnName_active_tags>
152{
153 typedef CXTPSyntaxEditLexVariantPtrArrayExT<FnName_active_tags> TBase;
154
155public:
156 virtual ~CXTPSyntaxEditLexObj_ActiveTags(){};
157};
160} // namespace XTPSyntaxEditLexAnalyser
161
163
164# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
166#endif // !defined(__XTPSYNTAXEDITLEXCLASSSUBOBJDEF_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h


Toolkit Pro: XTPPropExchangeArchive.h Source File

  • Source
  • Common
  • PropExchange
XTPPropExchangeArchive.h
Go to the documentation of this file.
1
23#if !defined(__XTPPROPEXCHANGEARCHIVE_H__)
24# define __XTPPROPEXCHANGEARCHIVE_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
51class _XTP_EXT_CLASS CXTPPropExchangeArchive : public CXTPPropExchange
52{
54 DECLARE_DYNAMIC(CXTPPropExchangeArchive)
56public:
63 CXTPPropExchangeArchive(CArchive& ar);
64
89 virtual BOOL ExchangeProp(LPCTSTR pszPropName, VARTYPE vtProp, void* pvProp,
90 const void* pvDefault = NULL);
91
102 virtual BOOL ExchangeBlobProp(LPCTSTR pszPropName, BYTE*& pData, DWORD& nBytes);
103
113 virtual BOOL ExchangeRuntimeClass(LPCTSTR pszPropName, CRuntimeClass*& pClass,
114 CRuntimeClass* pDefaultClass);
115
124 virtual BOOL ExchangeObjectInstance(CObject*& pObject, CRuntimeClass* pObjectRuntime);
125
134 virtual CArchive* GetArchive(LPCTSTR pszPropName);
135
143 virtual void ReleaseArchive(LPCTSTR pszPropName, CArchive* pArchive);
144
152 virtual void Write(LPCTSTR pszPropName, const void* lpBuf, UINT nCount);
153
164 virtual UINT Read(LPCTSTR pszPropName, void* lpBuf, UINT nCount);
165
172 virtual BOOL IsAllowDefaultValues() const;
173
180 virtual BOOL IsAllowBlobValues() const;
181
197 CXTPPropExchange* GetSection(LPCTSTR lpszSection);
198
205 virtual void WriteCount(DWORD dwCount);
206
214 virtual DWORD ReadCount();
215
216 CArchive& GetSelfArchive();
217
218private:
219 CXTPPropExchangeArchive& operator=(const CXTPPropExchangeArchive&)
220 {
221 _ASSERTE(FALSE);
222 return *this;
223 }
224
225protected:
227 virtual void ExchangeSchemaSafe();
228
229 class CSelfArchive : public CArchive
230 {
231 public:
232 CSelfArchive(CFile* pFile, UINT nMode, int nBufSize = 4096, void* lpBuf = NULL);
233 friend class CXTPPropExchangeArchive;
234 };
237 CSelfArchive& m_ar;
239};
241AFX_INLINE BOOL CXTPPropExchangeArchive::IsAllowDefaultValues() const
242{
243 return FALSE;
244}
245
246AFX_INLINE BOOL CXTPPropExchangeArchive::IsAllowBlobValues() const
247{
248 return TRUE;
249}
250
251AFX_INLINE CArchive& CXTPPropExchangeArchive::GetSelfArchive()
252{
253 return m_ar;
254}
256# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
258#endif // !defined(__XTPPROPEXCHANGEARCHIVE_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPPropExchangeArchive
CXTPPropExchangeArchive is CXTPPropExchange derived class.
Definition XTPPropExchangeArchive.h:52
CXTPPropExchangeArchive::ExchangeRuntimeClass
virtual BOOL ExchangeRuntimeClass(LPCTSTR pszPropName, CRuntimeClass *&pClass, CRuntimeClass *pDefaultClass)
Exchanges a CRuntimeClass between a storage and the class.
CXTPPropExchangeArchive::Write
virtual void Write(LPCTSTR pszPropName, const void *lpBuf, UINT nCount)
Writes a specified number of bytes.
CXTPPropExchangeArchive::ReleaseArchive
virtual void ReleaseArchive(LPCTSTR pszPropName, CArchive *pArchive)
This method releases CArchive pointer.
CXTPPropExchangeArchive::ExchangeBlobProp
virtual BOOL ExchangeBlobProp(LPCTSTR pszPropName, BYTE *&pData, DWORD &nBytes)
This method serializes a property that stores binary large object (BLOB) data.
CXTPPropExchangeArchive::WriteCount
virtual void WriteCount(DWORD dwCount)
Use this member function to write DWORD number to storage.
CXTPPropExchangeArchive::m_ar
CSelfArchive & m_ar
Contains the underlying CArchive for this CXTPPropExchangeArchive object.
Definition XTPPropExchangeArchive.h:237
CXTPPropExchangeArchive::GetArchive
virtual CArchive * GetArchive(LPCTSTR pszPropName)
This method create new Archive to serialize.
CXTPPropExchangeArchive::CXTPPropExchangeArchive
CXTPPropExchangeArchive(CArchive &ar)
Constructs a CXTPPropExchangeArchive object.
CXTPPropExchangeArchive::GetSection
CXTPPropExchange * GetSection(LPCTSTR lpszSection)
This method creates new section for text base storages (CXTPPropExchangeXMLNode and CXTPPropExchangeR...
CXTPPropExchangeArchive::IsAllowDefaultValues
virtual BOOL IsAllowDefaultValues() const
Call this method to determine if storage supported default values.
CXTPPropExchangeArchive::ExchangeObjectInstance
virtual BOOL ExchangeObjectInstance(CObject *&pObject, CRuntimeClass *pObjectRuntime)
Exchanges a class instance.
CXTPPropExchangeArchive::Read
virtual UINT Read(LPCTSTR pszPropName, void *lpBuf, UINT nCount)
Reads a specified number of bytes.
CXTPPropExchangeArchive::ExchangeProp
virtual BOOL ExchangeProp(LPCTSTR pszPropName, VARTYPE vtProp, void *pvProp, const void *pvDefault=NULL)
Exchanges a property between a storage medium and the control.
CXTPPropExchangeArchive::ReadCount
virtual DWORD ReadCount()
Use this member function to read DWORD number from storage.
CXTPPropExchangeArchive::IsAllowBlobValues
virtual BOOL IsAllowBlobValues() const
Call this method to determine if storage allows exchange plain blob values.
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72


Toolkit Pro: Member List

CXTPDatePickerItemMonth Member List

This is the complete list of members for CXTPDatePickerItemMonth, including all inherited members.

AdjustLayout(CRect rcClient, BOOL bIsAuto=FALSE) | CXTPDatePickerItemMonth |
AutoAdjustLayout(CRect rcClient) | CXTPDatePickerItemMonth | protected
ByFontAdjustLayout(CRect rcClient) | CXTPDatePickerItemMonth | protected
ClearDays() | CXTPDatePickerItemMonth | protected
CXTPCmdTarget() | CXTPCmdTarget |
CXTPDatePickerItemMonth(CXTPDatePickerControl *pControl, COleDateTime dtMonth, int nRow, int nCol) | CXTPDatePickerItemMonth |
Draw(CDC *pDC) | CXTPDatePickerItemMonth | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetDay(int nIndex) const | CXTPDatePickerItemMonth |
GetDayCount() const | CXTPDatePickerItemMonth |
GetMonth() const | CXTPDatePickerItemMonth |
GetShowDaysAfter() const | CXTPDatePickerItemMonth |
GetShowDaysBefore() const | CXTPDatePickerItemMonth |
GetShowLeftScroll() const | CXTPDatePickerItemMonth |
GetShowRightScroll() const | CXTPDatePickerItemMonth |
HitTest(CPoint point, BOOL bCheckVisible=TRUE) const | CXTPDatePickerItemMonth |
m_arrDays | CXTPDatePickerItemMonth | protected
m_bShowDaysAfter | CXTPDatePickerItemMonth |
m_bShowDaysBefore | CXTPDatePickerItemMonth |
m_bShowLeftScroll | CXTPDatePickerItemMonth |
m_bShowRightScroll | CXTPDatePickerItemMonth |
m_dtMonth | CXTPDatePickerItemMonth |
m_nColumn | CXTPDatePickerItemMonth |
m_nRow | CXTPDatePickerItemMonth |
m_pControl | CXTPDatePickerItemMonth |
m_rcDaysArea | CXTPDatePickerItemMonth |
m_rcDaysOfWeek | CXTPDatePickerItemMonth |
m_rcHeader | CXTPDatePickerItemMonth |
m_rcLeftScroll | CXTPDatePickerItemMonth |
m_rcMonth | CXTPDatePickerItemMonth |
m_rcRightScroll | CXTPDatePickerItemMonth |
m_rcWeekNumbers | CXTPDatePickerItemMonth |
OnLButtonDown(UINT nFlags, CPoint point) | CXTPDatePickerItemMonth | protected
OnLButtonUp(UINT nFlags, CPoint point) | CXTPDatePickerItemMonth | protected
OnMouseMove(UINT nFlags, CPoint point) | CXTPDatePickerItemMonth | protected
OnSetCursor(CPoint point) | CXTPDatePickerItemMonth | protected
PopulateDays() | CXTPDatePickerItemMonth | protected
SetShowDaysAfter(BOOL bShow) | CXTPDatePickerItemMonth |
SetShowDaysBefore(BOOL bShow) | CXTPDatePickerItemMonth |
SetShowScrolling(BOOL bLeftScroll, BOOL bRightScroll) | CXTPDatePickerItemMonth |
~CXTPDatePickerItemMonth() | CXTPDatePickerItemMonth | virtual


Toolkit Pro: Member List

CXTPSyntaxEditPropertiesPageFont Member List

This is the complete list of members for CXTPSyntaxEditPropertiesPageFont, including all inherited members.

CreateSafeFontIndirect(CFont &editFont, const LOGFONT &lf) | CXTPSyntaxEditPropertiesPageFont |
CXTPSyntaxEditPropertiesPageFont(CXTPSyntaxEditView *pEditView=NULL) | CXTPSyntaxEditPropertiesPageFont |
GetEditFont() | CXTPSyntaxEditPropertiesPageFont |
GetLBText(CComboBox &comboBox, CString &csItemText) | CXTPSyntaxEditPropertiesPageFont | protected
GetPaintManager() | CXTPSyntaxEditPropertiesPageFont | protected
GetSafeLogFont(LOGFONT &lf) | CXTPSyntaxEditPropertiesPageFont |
InitColorComboxes() | CXTPSyntaxEditPropertiesPageFont | protected
InitFontCombo() | CXTPSyntaxEditPropertiesPageFont | protected
InitScriptCombo() | CXTPSyntaxEditPropertiesPageFont | protected
InitSizeCombo() | CXTPSyntaxEditPropertiesPageFont | protected
InitStyleCombo() | CXTPSyntaxEditPropertiesPageFont | protected
m_bModified | CXTPSyntaxEditPropertiesPageFont | protected
m_iCharSet | CXTPSyntaxEditPropertiesPageFont | protected
m_pEditView | CXTPSyntaxEditPropertiesPageFont | protected
m_uFaceSize | CXTPSyntaxEditPropertiesPageFont | protected
m_xtpFontEdit | CXTPSyntaxEditPropertiesPageFont | protected
ReadRegistryValues() | CXTPSyntaxEditPropertiesPageFont | protected
SetModified(BOOL bChanged=TRUE) | CXTPSyntaxEditPropertiesPageFont | protected
UpdateSampleColors() | CXTPSyntaxEditPropertiesPageFont | protected
UpdateSampleFont() | CXTPSyntaxEditPropertiesPageFont | protected
WriteRegistryValues() | CXTPSyntaxEditPropertiesPageFont | protected
~CXTPSyntaxEditPropertiesPageFont() | CXTPSyntaxEditPropertiesPageFont | virtual


Toolkit Pro: XTPMarkupRotateTransform.h Source File

  • Source
  • Markup
  • Transform
XTPMarkupRotateTransform.h
Go to the documentation of this file.
1
23#if !defined(__XTPMARKUPROTATETRANSFORM_H__)
24# define __XTPMARKUPROTATETRANSFORM_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPMarkupTransformationMatrix;
34class CXTPMarkupDependencyProperty;
35
40class _XTP_EXT_CLASS CXTPMarkupRotateTransform : public CXTPMarkupTransform
41{
43 DECLARE_MARKUPCLASS(CXTPMarkupRotateTransform);
45public:
52 double GetAngle() const;
53
59 void SetAngle(double angle);
60
67 double GetCenterX() const;
68
75 void SetCenterX(double centerX);
76
83 double GetCenterY() const;
84
90 void SetCenterY(double centerY);
91
99 virtual CXTPMarkupTransformationMatrix*
100 ApplyTransform(const CXTPMarkupTransformationMatrix* pMatrix);
101
102private:
103 DECLARE_DISPATCH_MAP();
104 afx_msg double OleGetAngle();
105 afx_msg void OleSetAngle(double angle);
106 afx_msg double OleGetCenterX();
107 afx_msg void OleSetCenterX(double centerX);
108 afx_msg double OleGetCenterY();
109 afx_msg void OleSetCenterY(double centerY);
110
111public:
112 static CXTPMarkupDependencyProperty* m_pPropertyAngle;
113 static CXTPMarkupDependencyProperty* m_pPropertyCenterX;
114 static CXTPMarkupDependencyProperty* m_pPropertyCenterY;
115};
116
117# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
119#endif // !defined(__XTPMARKUPROTATETRANSFORM_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPMarkupRotateTransform
Default RotateTransform implementation.
Definition XTPMarkupRotateTransform.h:41
CXTPMarkupRotateTransform::m_pPropertyAngle
static CXTPMarkupDependencyProperty * m_pPropertyAngle
Angle property.
Definition XTPMarkupRotateTransform.h:112
CXTPMarkupRotateTransform::SetAngle
void SetAngle(double angle)
Sets the angle value.
CXTPMarkupRotateTransform::SetCenterX
void SetCenterX(double centerX)
Sets the center X value.
CXTPMarkupRotateTransform::m_pPropertyCenterY
static CXTPMarkupDependencyProperty * m_pPropertyCenterY
CenterY property.
Definition XTPMarkupRotateTransform.h:114
CXTPMarkupRotateTransform::m_pPropertyCenterX
static CXTPMarkupDependencyProperty * m_pPropertyCenterX
CenterX property.
Definition XTPMarkupRotateTransform.h:113
CXTPMarkupRotateTransform::GetCenterX
double GetCenterX() const
Gets the center X value.
CXTPMarkupRotateTransform::ApplyTransform
virtual CXTPMarkupTransformationMatrix * ApplyTransform(const CXTPMarkupTransformationMatrix *pMatrix)
Does nothing in default implementation.
CXTPMarkupRotateTransform::GetAngle
double GetAngle() const
Gets the angle value.
CXTPMarkupRotateTransform::GetCenterY
double GetCenterY() const
Gets the center Y value.
CXTPMarkupRotateTransform::SetCenterY
void SetCenterY(double centerY)
Sets the center Y value.
CXTPMarkupTransform
Base class for all markup transformation objects.
Definition XTPMarkupTransform.h:43
CXTPMarkupTransformationMatrix
An abstract class for device context transformation matrix.
Definition XTPMarkupTransformationMatrix.h:40


Toolkit Pro: Member List

CXTPCalendarCaptionBarThemePart Member List

This is the complete list of members for CXTPCalendarCaptionBarThemePart, including all inherited members.

AdjustLayout(CDC *pDC, const CRect &rcRect) | CXTPCalendarCaptionBarThemePart | virtual
CXTPCalendarCaptionBarThemePart(CXTPCalendarCaptionBarTheme *pTheme, int nPartID) | CXTPCalendarCaptionBarThemePart |
CXTPCalendarWMHandler() | CXTPCalendarWMHandler |
CXTPCmdTarget() | CXTPCmdTarget |
Draw(CDC *pDC) | CXTPCalendarCaptionBarThemePart | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCheck() const | CXTPCalendarCaptionBarThemePart | virtual
GetChildHandlerAt(int nIndex) const | CXTPCalendarWMHandler | virtual
GetChildHandlersCount() const | CXTPCalendarWMHandler | virtual
GetPaintManager() const | CXTPCalendarCaptionBarThemePart |
GetPaintTheme() const | CXTPCalendarCaptionBarThemePart | virtual
GetPartID() const | CXTPCalendarCaptionBarThemePart | virtual
GetRect() const | CXTPCalendarCaptionBarThemePart | virtual
GetState() const | CXTPCalendarCaptionBarThemePart |
GetText() const | CXTPCalendarCaptionBarThemePart | virtual
GetTextColor() | CXTPCalendarCaptionBarThemePart | virtual
GetTheme() const | CXTPCalendarCaptionBarThemePart | virtual
HitTest(const CPoint &pt) const | CXTPCalendarCaptionBarThemePart | virtual
IsVisible() const | CXTPCalendarCaptionBarThemePart | virtual
m_bVisible | CXTPCalendarCaptionBarThemePart | protected
m_clrTextColor | CXTPCalendarCaptionBarThemePart |
m_nPartID | CXTPCalendarCaptionBarThemePart | protected
m_nState | CXTPCalendarCaptionBarThemePart |
m_pTheme | CXTPCalendarCaptionBarThemePart | protected
m_rcRect | CXTPCalendarCaptionBarThemePart |
m_strText | CXTPCalendarCaptionBarThemePart |
OnBeforeDestroy() | CXTPCalendarWMHandler | virtual
OnChar(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnKeyUp(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnLButtonDblClk(UINT nFlags, CPoint point) | CXTPCalendarWMHandler | virtual
OnLButtonDown(UINT nFlags, CPoint point) | CXTPCalendarCaptionBarThemePart | virtual
OnLButtonUp(UINT nFlags, CPoint point) | CXTPCalendarCaptionBarThemePart | virtual
OnMouseMove(UINT nFlags, CPoint point) | CXTPCalendarCaptionBarThemePart | virtual
OnPostAdjustLayout() | CXTPCalendarWMHandler | virtual
OnSysKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnTimer(UINT_PTR uTimerID) | CXTPCalendarWMHandler | virtual
OnWndMsg(UINT message, WPARAM wParam, LPARAM lParam, LRESULT *pResult) | CXTPCalendarWMHandler | virtual
Redraw(BOOL bUpdateNow=FALSE) | CXTPCalendarCaptionBarThemePart | virtual
RefreshMetrics() | CXTPCalendarCaptionBarThemePart | inlinevirtual
SetCheck(int nCheck) | CXTPCalendarCaptionBarThemePart | virtual
SetState(int nState) | CXTPCalendarCaptionBarThemePart | virtual
SetText(LPCTSTR pcszText) | CXTPCalendarCaptionBarThemePart | virtual
SetVisible(BOOL bVisible) | CXTPCalendarCaptionBarThemePart | virtual
~CXTPCalendarCaptionBarThemePart() | CXTPCalendarCaptionBarThemePart | virtual


Toolkit Pro: Member List

CXTPColorSelectorCtrlThemeVisualStudio2019 Member List

This is the complete list of members for CXTPColorSelectorCtrlThemeVisualStudio2019, including all inherited members.

CalcSize(CXTPColorSelectorCtrl *pOwner) | CXTPColorSelectorCtrlThemeOffice2013 | virtual
CreateAutoButton(CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked) | CXTPColorSelectorCtrlThemeOffice2013 | virtual
CreateColorButtons(CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked) | CXTPColorSelectorCtrlTheme | virtual
CreateExtendedButtons(CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked) | CXTPColorSelectorCtrlThemeOffice2013 | virtual
CreateMoreButton(CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked) | CXTPColorSelectorCtrlThemeOffice2013 | virtual
CreateRecentColorButtons(CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked) | CXTPColorSelectorCtrlThemeOffice2013 | virtual
CreateThemeButtons(CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked) | CXTPColorSelectorCtrlThemeOffice2013 | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPColorSelectorCtrlTheme() | CXTPColorSelectorCtrlTheme |
CXTPColorSelectorCtrlThemeOffice2013() | CXTPColorSelectorCtrlThemeOffice2013 |
CXTPColorSelectorCtrlThemeVisualStudio2015() | CXTPColorSelectorCtrlThemeVisualStudio2015 |
CXTPColorSelectorCtrlThemeVisualStudio2019() | CXTPColorSelectorCtrlThemeVisualStudio2019 |
CXTPControlTheme() | CXTPControlTheme |
DrawBorder(CDC *pDC, CRect rcItem, CRect rcBorder, COLORREF crBorder) | CXTPColorSelectorCtrlThemeOffice2013 | virtual
DrawColor(CDC *pDC, CXTPColorSelectorCtrl *pOwner, CXTPColorSelectorCtrl::COLOR_CELL *pColorCell, CRect rcItem, BOOL bChecked, BOOL bHighlight, BOOL bPressed) | CXTPColorSelectorCtrlThemeOffice2013 | virtual
DrawColorCell(CDC *pDC, CXTPColorSelectorCtrl *pOwner, CXTPColorSelectorCtrl::COLOR_CELL *pColorCell, BOOL bHighlight, BOOL bPressed) | CXTPColorSelectorCtrlThemeVisualStudio2015 | virtual
DrawColorSelector(CDC *pDC, CXTPColorSelectorCtrl *pOwner) | CXTPColorSelectorCtrlThemeOffice2013 | virtual
FillBackground(CDC *pDC, CXTPColorSelectorCtrl *pOwner, const CRect &rect) | CXTPColorSelectorCtrlTheme | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetButtonSize() const | CXTPColorSelectorCtrlTheme | virtual
GetThemeStyle() const | CXTPControlTheme |
m_bThinBorder | CXTPColorSelectorCtrlTheme |
m_crBack | CXTPColorSelectorCtrlTheme |
m_crBackChecked | CXTPColorSelectorCtrlTheme |
m_crBackHilight | CXTPColorSelectorCtrlTheme |
m_crBackPressed | CXTPColorSelectorCtrlTheme |
m_crBorder | CXTPColorSelectorCtrlTheme |
m_crBorderHilight | CXTPColorSelectorCtrlTheme |
m_crBorderInside | CXTPColorSelectorCtrlThemeOffice2013 | protected
m_crBorderPressed | CXTPColorSelectorCtrlTheme |
m_crPopupBorder | CXTPColorSelectorCtrlTheme |
m_crText | CXTPColorSelectorCtrlTheme |
m_crTextPressed | CXTPColorSelectorCtrlTheme |
m_crTitleBack | CXTPColorSelectorCtrlThemeOffice2013 | protected
m_crTitleText | CXTPColorSelectorCtrlThemeOffice2013 | protected
m_nAutoButton | CXTPColorSelectorCtrlTheme |
m_nCaption | CXTPColorSelectorCtrlTheme |
m_nMargin | CXTPColorSelectorCtrlTheme |
m_nTheme | CXTPControlTheme | protected
m_rcRecentText | CXTPColorSelectorCtrlTheme |
m_rcStandardText | CXTPColorSelectorCtrlTheme |
m_rcThemeText | CXTPColorSelectorCtrlTheme |
m_sizeButton | CXTPColorSelectorCtrlTheme |
RefreshMetrics(CXTPColorSelectorCtrl *pOwner) | CXTPColorSelectorCtrlThemeVisualStudio2015 | virtual
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static


Toolkit Pro: XTPChartOpenGLPyramidDeviceCommand.h Source File

  • Source
  • Chart
  • Styles
  • Pyramid
  • 3D
  • Commands
  • OpenGL
XTPChartOpenGLPyramidDeviceCommand.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTOPENGLPYRAMIDDEVICECOMMAND_H__)
24# define __XTPCHARTOPENGLPYRAMIDDEVICECOMMAND_H__
25
26# if _MSC_VER >= 1000
27# pragma once
28# endif // _MSC_VER >= 1000
29
30# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
31
32class CXTPChart3dPyramidSeriesStyle;
33class CXTPChartDeviceContext;
34class CXTPChartSeriesStyle;
35class CXTPChartOpenGLDeviceContext;
36
43class _XTP_EXT_CLASS CXTPChartOpenGLPyramidDeviceCommand : public CXTPChart3dDeviceCommand
44{
45public:
60 CXTPChartOpenGLPyramidDeviceCommand(const CXTPPoint3d& center, double dWidth, double dHeight,
61 double dFrom, double dTo, const CXTPChartColor& color,
62 BOOL bSmoothEdges);
63
68 ~CXTPChartOpenGLPyramidDeviceCommand();
69
70protected:
82 virtual CXTPChartElement* HitTest(CPoint point, CXTPChartElement* pParent) const;
83
90 virtual void ExecuteOverride(CXTPChartDeviceContext* pDC);
91
98 virtual void ApplySeriesStyle(CXTPChartSeriesStyle* pStyle);
99
110 virtual void PrepareOverride(CXTPChartDeviceContext* pDC);
111
112private:
113 void DrawTriangle(CXTPChartOpenGLDeviceContext& dc, const CXTPPoint3d& a, const CXTPPoint3d& va,
114 const CXTPPoint3d& b, const CXTPPoint3d& vb, const CXTPPoint3d& c,
115 const CXTPPoint3d& vc);
116 void DrawPyramidSlice(CXTPChartOpenGLDeviceContext& dc);
117
118 void ComputeConnectorPoints(CXTPChartOpenGLDeviceContext& dc);
119
120private:
121 BOOL m_bPrepared;
122 CXTPChart3dBox m_3dBox;
123 CXTPPoint3d m_ptCenterConnectorPoint;
124 CXTPPoint3d m_ptOuterConnectorPoint;
125 CXTPChartColor m_color;
126 CXTPChart3dPyramidSeriesStyle* m_pStyle;
127 GLuint m_listId;
128 double m_dWidth;
129 double m_dHeight;
130 double m_dFrom;
131 double m_dTo;
132 CXTPPoint3d m_ptCenter;
133 BOOL m_bSmoothEdges;
134 CArray<CXTPPoint3d, const CXTPPoint3d&> m_arMidFacePoints;
135};
136
137# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
138#endif //#if !defined(__XTPCHARTOPENGLPYRAMIDDEVICECOMMAND_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChart3dBox
Represents a 3D box build around included points and provides useful and fast operations.
Definition XTPChartTypes.h:728
CXTPChart3dDeviceCommand
Defines a common implementation interface for chart 3D drawing commands.
Definition XTPChartDeviceCommand.h:368
CXTPChart3dPyramidSeriesStyle
This class abstracts the basic style of a pyramid series.
Definition XTPChart3dPyramidSeriesStyle.h:49
CXTPChartColor
This class abstracts a color entity.
Definition XTPChartTypes.h:51
CXTPChartDeviceCommand::ApplySeriesStyle
virtual void ApplySeriesStyle(CXTPChartSeriesStyle *pStyle)
Applies series style to the current element.
CXTPChartDeviceCommand::PrepareOverride
virtual void PrepareOverride(CXTPChartDeviceContext *pDC)
Derived implementation must override this method for implementing implementation specific preparation...
CXTPChartDeviceCommand::HitTest
virtual CXTPChartElement * HitTest(CPoint point, CXTPChartElement *pParent) const
Performs recursive hit testing of the element at the specified point.
CXTPChartDeviceCommand::ExecuteOverride
virtual void ExecuteOverride(CXTPChartDeviceContext *pDC)
Override this function to write the drawing code for specific objects.
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartElement
This class abstracts a chart element, this class acts as a base class for all chart elements.
Definition XTPChartElement.h:131
CXTPChartSeriesStyle
CXTPChartSeriesStyle is a CXTPChartElement derived class.
Definition XTPChartSeriesStyle.h:49
CXTPPoint3T< double >


Toolkit Pro: Member List

CXTPTabManagerItem Member List

This is the complete list of members for CXTPTabManagerItem, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPTabManagerItem() | CXTPTabManagerItem | protected
DrawImage(CDC *pDC, CRect rcIcon, CXTPImageManagerIcon *pImage) | CXTPTabManagerItem |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetButtonLength() const | CXTPTabManagerItem |
GetCaption() const | CXTPTabManagerItem | virtual
GetColor() | CXTPTabManagerItem |
GetContentLength() const | CXTPTabManagerItem |
GetData() const | CXTPTabManagerItem |
GetHandle() const | CXTPTabManagerItem |
GetImageIndex() const | CXTPTabManagerItem |
GetIndex() const | CXTPTabManagerItem |
GetItemRow() const | CXTPTabManagerItem |
GetMarkupUIElement() const | CXTPTabManagerItem |
GetNavigateButtons() | CXTPTabManagerItem |
GetRect() const | CXTPTabManagerItem |
GetTabManager() const | CXTPTabManagerItem |
GetTooltip() const | CXTPTabManagerItem |
IsClosable() const | CXTPTabManagerItem |
IsEnabled() const | CXTPTabManagerItem |
IsFocused() const | CXTPTabManagerItem |
IsHighlighted() const | CXTPTabManagerItem |
IsItemShrinked() const | CXTPTabManagerItem |
IsNewWindowTab() | CXTPTabManagerItem |
IsPressed() const | CXTPTabManagerItem |
IsSelected() const | CXTPTabManagerItem |
IsVisible() const | CXTPTabManagerItem |
m_arrNavigateButtons | CXTPTabManagerItem | protected
m_bClosable | CXTPTabManagerItem | protected
m_bEnabled | CXTPTabManagerItem | protected
m_bNewWindowTab | CXTPTabManagerItem | protected
m_bVisible | CXTPTabManagerItem | protected
m_clrItem | CXTPTabManagerItem | protected
m_dwData | CXTPTabManagerItem | protected
m_hIcon | CXTPTabManagerItem | protected
m_hWnd | CXTPTabManagerItem | protected
m_nButtonLength | CXTPTabManagerItem | protected
m_nContentLength | CXTPTabManagerItem | protected
m_nImage | CXTPTabManagerItem | protected
m_nIndex | CXTPTabManagerItem | protected
m_nItemRow | CXTPTabManagerItem | protected
m_pMarkupUIElement | CXTPTabManagerItem | protected
m_pTabManager | CXTPTabManagerItem | protected
m_rcItem | CXTPTabManagerItem | protected
m_strCaption | CXTPTabManagerItem | protected
m_strToolTip | CXTPTabManagerItem | protected
Move(int nIndex) | CXTPTabManagerItem |
OnRemoved() | CXTPTabManagerItem | protectedvirtual
Remove() | CXTPTabManagerItem |
Reposition() | CXTPTabManagerItem | protected
Select() | CXTPTabManagerItem |
SetCaption(LPCTSTR lpszCaption) | CXTPTabManagerItem |
SetClosable(BOOL bClosable) | CXTPTabManagerItem |
SetColor(COLORREF clr) | CXTPTabManagerItem |
SetData(DWORD_PTR dwData) | CXTPTabManagerItem |
SetEnabled(BOOL bEnabled) | CXTPTabManagerItem |
SetHandle(HWND hWnd) | CXTPTabManagerItem |
SetImageIndex(int nImage) | CXTPTabManagerItem |
SetNewWindowTab() | CXTPTabManagerItem |
SetRect(CRect rcItem) | CXTPTabManagerItem |
SetTooltip(LPCTSTR lpszTooltip) | CXTPTabManagerItem |
SetVisible(BOOL bVisible) | CXTPTabManagerItem | virtual
~CXTPTabManagerItem() | CXTPTabManagerItem | protectedvirtual


Toolkit Pro: XTPSplitterWnd.h Source File

  • Source
  • Controls
  • Splitter
XTPSplitterWnd.h
Go to the documentation of this file.
1
23#if !defined(__XTPSPLITTERWND_H__)
24# define __XTPSPLITTERWND_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPSplitterWndTheme;
34
40class _XTP_EXT_CLASS CXTPSplitterWnd : public CXTPScrollBarContainer<CSplitterWnd>
41{
43 DECLARE_DYNAMIC(CXTPSplitterWnd)
45public:
50 CXTPSplitterWnd();
51
56 virtual ~CXTPSplitterWnd();
57
58public:
71 BOOL SetTheme(XTPControlTheme eTheme);
72
79 BOOL SetTheme(CXTPSplitterWndTheme* pTheme);
80
88 CXTPSplitterWndTheme* GetTheme() const;
89
97 virtual void ShowColumn();
98
106 virtual void HideColumn(int nColHide);
107
115 virtual void ShowRow();
116
124 virtual void HideRow(int nRowHide);
125
138 virtual BOOL SwitchView(int nRow, int nCol, CView* pNewView);
139
152 virtual CView* ReplaceView(int nRow, int nCol, CView* pNewView);
153
166 virtual CView* ReplaceView(int nRow, int nCol, CRuntimeClass* pViewClass);
167
177 void EnableFullDrag(int nFullDrag);
178
185 void EnableDotTracker(BOOL bEnable);
186
193 void EnableBorder(BOOL bBorder);
194
202 BOOL IsBorderVisible() const;
203
209 void EnableNoSize(BOOL bEnable);
210
220 int GetHiddenColIndex() const;
221
231 int GetHiddenRowIndex() const;
232
254 virtual void SetActivePane(int row, int col, CWnd* pWnd = NULL);
255
262 BOOL FullDragWindows() const;
263
266 //-----------------------------------------------------------------------
267 // Note: The following functions are deprecated and could be removed
268 // in a future release.
269 //-----------------------------------------------------------------------
270
271 _XTP_DEPRECATED_IN_FAVOR(EnableFullDrag)
272 void SetFullDrag(BOOL bFullDrag);
273
274 _XTP_DEPRECATED_IN_FAVOR_("EnableFullDrag(), EnableDotTracker or EnableNoSize()")
275 virtual void SetSplitterStyle(DWORD dwxStyle);
276
277 _XTP_DEPRECATED virtual DWORD GetSplitterStyle();
278
279 _XTP_DEPRECATED_IN_FAVOR(SetTheme)
280 virtual void EnableFlatLook(BOOL bFlatSplitter);
281
284protected:
289 virtual void RefreshMetrics();
290
297 void PrintClient(CDC* pDC);
298
300 DECLARE_MESSAGE_MAP()
301
302 //{{AFX_VIRTUAL(CXTPSplitterWnd)
303 virtual void SetSplitCursor(int ht);
304 virtual void OnInvertTracker(const CRect& rect);
305 virtual void StartTracking(int ht);
306 virtual void StopTracking(BOOL bAccept);
307 virtual void DrawTracker(const CRect& rect, CBrush* pBrush);
308 virtual void OnDrawSplitter(CDC* pDC, ESplitType nType, const CRect& rectArg);
309 virtual BOOL OnWndMsg(UINT message, WPARAM wParam, LPARAM lParam, LRESULT* pResult);
310 //}}AFX_VIRTUAL
311
312 //{{AFX_MSG(CXTPSplitterWnd)
313 afx_msg LRESULT OnSetTheme(WPARAM wParam, LPARAM lParam);
314 afx_msg void OnMouseMove(UINT nFlags, CPoint point);
315 //}}AFX_MSG
316 afx_msg LRESULT OnNcHitTest(CPoint point);
319protected:
320 int m_nHiddenCol;
321 int m_nHiddenRow;
322 int m_nFullDrag;
324 BOOL m_bFullDrag;
325 BOOL m_bDotTracker;
326 BOOL m_bNoSize;
327 BOOL m_bShowBorder;
328 BOOL m_bClipStyles;
329 BOOL m_bSubclassed;
330 CPoint m_point;
331 CXTPSplitterWndTheme* m_pTheme;
332};
333
335
336AFX_INLINE int CXTPSplitterWnd::GetHiddenColIndex() const
337{
338 return m_nHiddenCol;
339}
340AFX_INLINE int CXTPSplitterWnd::GetHiddenRowIndex() const
341{
342 return m_nHiddenRow;
343}
344AFX_INLINE CXTPSplitterWndTheme* CXTPSplitterWnd::GetTheme() const
345{
346 return m_pTheme;
347}
348AFX_INLINE void CXTPSplitterWnd::EnableFullDrag(int nFullDrag)
349{
350 m_nFullDrag = nFullDrag;
351}
352AFX_INLINE void CXTPSplitterWnd::EnableDotTracker(BOOL bEnable)
353{
354 m_bDotTracker = bEnable;
355}
356AFX_INLINE void CXTPSplitterWnd::EnableNoSize(BOOL bEnable)
357{
358 m_bNoSize = bEnable;
359}
360AFX_INLINE void CXTPSplitterWnd::EnableBorder(BOOL bBorder)
361{
362 m_bShowBorder = bBorder;
363
364 if (::IsWindow(m_hWnd))
365 RedrawWindow();
366}
367AFX_INLINE BOOL CXTPSplitterWnd::IsBorderVisible() const
368{
369 return m_bShowBorder;
370}
378class _XTP_EXT_CLASS CXTPSplitterWndEx : public CXTPSplitterWnd
379{
381 DECLARE_DYNAMIC(CXTPSplitterWndEx)
383public:
388 CXTPSplitterWndEx();
389
394 virtual ~CXTPSplitterWndEx();
395
396public:
407 virtual void ShowTopBorder(bool bShowTopBorder = true, int cyTopBorderGap = 7);
408
409protected:
419 virtual void GetInsideRect(CRect& rect) const;
420
421public:
435 virtual void RecalcLayout();
436
470 virtual void OnDrawSplitter(CDC* pDC, ESplitType nType, const CRect& rectArg);
471
472private:
473 static void AFX_CDECL DeferClientPos(AFX_SIZEPARENTPARAMS* lpLayout, CWnd* pWnd, int x, int y,
474 int cx, int cy, BOOL bScrollBar);
475
476 static void AFX_CDECL LayoutRowCol(CSplitterWnd::CRowColInfo* pInfoArray, int nMax, int nSize,
477 int nSizeSplitter);
478
479protected:
481 DECLARE_MESSAGE_MAP()
482
483 //{{AFX_MSG(CXTPSplitterWndEx)
484 afx_msg void OnPaint();
485 afx_msg BOOL OnEraseBkgnd(CDC* pDC);
486 //}}AFX_MSG
489protected:
490 int m_cyTopBorderGap;
491 bool m_bShowTopBorder;
492};
493
495
496AFX_INLINE void CXTPSplitterWndEx::ShowTopBorder(bool bShowTopBorder, int cyTopBorderGap)
497{
498 m_bShowTopBorder = bShowTopBorder;
499 m_cyTopBorderGap = cyTopBorderGap;
500}
503const DWORD XTP_SPLIT_DOTTRACKER = 0x0001; // deprecated see EnableDotTracker().
504const DWORD XTP_SPLIT_NOFULLDRAG = 0x0002; // deprecated see EnableFullDrag().
505const DWORD XTP_SPLIT_NOBORDER = 0x0004; // deprecated see EnableBorder().
506const DWORD XTP_SPLIT_NOSIZE = 0x0008; // deprecated see EnableNoSize().
509# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
511#endif // !defined(__XTPSPLITTERWND_H__)
XTPControlTheme
XTPControlTheme
Enumeration used to determine the active theme style.
Definition XTPControlTheme.h:43
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPScrollBarContainer
CXTPScrollBarContainer class adds XTP scroll bars to a class derived from CWnd.
Definition XTPScrollBarContainer.h:113
CXTPSplitterWndEx
CXTPSplitterWndEx is a CXTPSplitterWnd derived class.
Definition XTPSplitterWnd.h:379
CXTPSplitterWndEx::CXTPSplitterWndEx
CXTPSplitterWndEx()
Constructs a CXTPSplitterWndEx object.
CXTPSplitterWndEx::RecalcLayout
virtual void RecalcLayout()
Call this member function to correctly redisplay the splitter window after you have adjusted row and ...
CXTPSplitterWndEx::~CXTPSplitterWndEx
virtual ~CXTPSplitterWndEx()
Destroys a CXTPSplitterWndEx object, handles cleanup and deallocation.
CXTPSplitterWndEx::GetInsideRect
virtual void GetInsideRect(CRect &rect) const
Called to retrieve the client area excluding the inside 3D borders.
CXTPSplitterWndEx::ShowTopBorder
virtual void ShowTopBorder(bool bShowTopBorder=true, int cyTopBorderGap=7)
Call this member function to show a top border for the splitter window, similar to Outlook.
CXTPSplitterWndEx::OnDrawSplitter
virtual void OnDrawSplitter(CDC *pDC, ESplitType nType, const CRect &rectArg)
Renders an image of a split window.
CXTPSplitterWnd
CXTPSplitterWnd is a CSplitterWnd derived class.
Definition XTPSplitterWnd.h:41
CXTPSplitterWnd::EnableDotTracker
void EnableDotTracker(BOOL bEnable)
Call this member function to enable dotted tracker display rather than the default.
CXTPSplitterWnd::CXTPSplitterWnd
CXTPSplitterWnd()
Constructs a CXTPSplitterWnd object.
CXTPSplitterWnd::EnableBorder
void EnableBorder(BOOL bBorder)
Call this member function to show/hide the borders for the splitter client area.
CXTPSplitterWnd::~CXTPSplitterWnd
virtual ~CXTPSplitterWnd()
Destroys a CXTPSplitterWnd object, handles cleanup and deallocation.
CXTPSplitterWnd::ShowRow
virtual void ShowRow()
This member function is called to show the row that was previously hidden.
CXTPSplitterWnd::HideColumn
virtual void HideColumn(int nColHide)
This member function will hide a column based upon its index.
CXTPSplitterWnd::FullDragWindows
BOOL FullDragWindows() const
Call this member function to check if full window dragging is enabled.
CXTPSplitterWnd::SetActivePane
virtual void SetActivePane(int row, int col, CWnd *pWnd=NULL)
Sets a pane to be the active one in the frame.
CXTPSplitterWnd::EnableFullDrag
void EnableFullDrag(int nFullDrag)
Call this method to enable full drag windows.
CXTPSplitterWnd::HideRow
virtual void HideRow(int nRowHide)
This member function will hide a row based upon its index.
CXTPSplitterWnd::EnableNoSize
void EnableNoSize(BOOL bEnable)
Call this member function to disable resizing splitter pane windows.
CXTPSplitterWnd::SwitchView
virtual BOOL SwitchView(int nRow, int nCol, CView *pNewView)
This member function is called to switch (or swap) a splitter view with another.
CXTPSplitterWnd::GetTheme
CXTPSplitterWndTheme * GetTheme() const
Call this member function to get a pointer to the currently selected theme.
CXTPSplitterWnd::ReplaceView
virtual CView * ReplaceView(int nRow, int nCol, CRuntimeClass *pViewClass)
This member function is called to replace an existing splitter view with another.
CXTPSplitterWnd::SetTheme
BOOL SetTheme(XTPControlTheme eTheme)
Call this member to switch the visual theme of the control.
CXTPSplitterWnd::ShowColumn
virtual void ShowColumn()
This member function is called to show the column that was previously hidden.
CXTPSplitterWnd::GetHiddenRowIndex
int GetHiddenRowIndex() const
Call this member function to return the index of the row that is currently hidden.
CXTPSplitterWnd::IsBorderVisible
BOOL IsBorderVisible() const
Call this member function to determine the visibility of borders for the splitter client area.
CXTPSplitterWnd::SetTheme
BOOL SetTheme(CXTPSplitterWndTheme *pTheme)
Call this member to switch the visual theme of the control.
CXTPSplitterWnd::ReplaceView
virtual CView * ReplaceView(int nRow, int nCol, CView *pNewView)
This member function is called to replace an existing splitter view with another.
CXTPSplitterWnd::GetHiddenColIndex
int GetHiddenColIndex() const
Call this member function to retrieve the index of the column that is currently hidden.
CXTPSplitterWndTheme
Class CXTPSplitterWndTheme is derived from CXTPControlTheme.
Definition XTPSplitterWndTheme.h:41


Toolkit Pro: Member List

CXTPCommandBarsVisualStudio2019Theme Member List

This is the complete list of members for CXTPCommandBarsVisualStudio2019Theme, including all inherited members.

AdjustExcludeRect(CRect &rc, CXTPControl *pControl, BOOL bVertical) | CXTPCommandBarsOfficeXPTheme | virtual
Animate(CDC *pDestDC, CDC *pSrcDC, CRect rc, XTPAnimationType animationType) | CXTPPaintManager | virtual
AnimateExpanding(CXTPCommandBar *pCommandBar, CDC *pDestDC, CDC *pSrcDC, BOOL bExpandDown) | CXTPPaintManager | virtual
BaseTheme() | CXTPCommandBarsOffice2013Theme | virtual
CreateTheme(XTPPaintTheme paintTheme) | CXTPPaintManager | static
CXTPCmdTarget() | CXTPCmdTarget |
CXTPCommandBarsModernUITheme() | CXTPCommandBarsModernUITheme |
CXTPCommandBarsOffice2013Theme() | CXTPCommandBarsOffice2013Theme |
CXTPCommandBarsOfficeXPTheme() | CXTPCommandBarsOfficeXPTheme |
CXTPCommandBarsVisualStudio2019Theme() | CXTPCommandBarsVisualStudio2019Theme |
CXTPObservable() | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | protected
CXTPPaintManager() | CXTPPaintManager | protected
Draw3dRect(CDC *pDC, LPCRECT rc, int nTopLeft, int nBottomRight) | CXTPPaintManager |
Draw3dRect(CDC *pDC, LPCRECT rc, int frameThickness, COLORREF clrPen, COLORREF clrBrush) | CXTPPaintManager |
CXTPPaintManager::DrawCheckMark(CDC *pDC, CRect rcCheck, COLORREF clr=0) | CXTPPaintManager | inline
DrawCheckRect(CDC *pDC, CRect rc, COLORREF clrFore, COLORREF clrBack) | CXTPCommandBarsVisualStudio2019Theme | protectedvirtual
DrawComboExpandMark(CDC *pDC, CRect rc, COLORREF clr) | CXTPPaintManager | virtual
DrawCommandBarGripper(CDC *pDC, CXTPCommandBar *pBar, BOOL bDraw=TRUE) | CXTPCommandBarsVisualStudio2019Theme | protectedvirtual
DrawCommandBarGroupSeparator(CDC *pDC, CXTPCommandBar *pBar, CXTPControl *pLeftControl, CXTPControl *pRightControl, BOOL bDraw) | CXTPCommandBarsOffice2013Theme | virtual
DrawCommandBarSeparator(CDC *pDC, CXTPCommandBar *pBar, CXTPControl *pControl, BOOL bDraw=TRUE) | CXTPCommandBarsOffice2013Theme | protectedvirtual
DrawControl(CDC *pDC, CXTPControl *pButton, BOOL bDraw=TRUE) | CXTPPaintManager |
DrawControlCheckBoxMark(CDC *pDC, CXTPControl *pButton, CRect rc, BOOL bDraw) | CXTPCommandBarsOffice2013Theme | protectedvirtual
DrawControlCheckBoxMark(CDC *pDC, CRect rc, BOOL bDraw, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled) | CXTPCommandBarsOffice2013Theme | protectedvirtual
DrawControlComboBox(CDC *pDC, CXTPControlComboBox *pComboBox, BOOL bDraw) | CXTPCommandBarsVisualStudio2019Theme | protectedvirtual
DrawControlEdit(CDC *pDC, CXTPControlEdit *pEdit, BOOL bDraw) | CXTPCommandBarsOffice2013Theme | virtual
DrawControlEntry(CDC *pDC, CXTPControl *pButton) | CXTPPaintManager | virtual
DrawControlMDIButton(CDC *pDC, CXTPControlButton *pButton) | CXTPCommandBarsOffice2013Theme | protectedvirtual
DrawControlPopupParent(CDC *pDC, CXTPControl *pButton, BOOL bDraw) | CXTPCommandBarsOfficeXPTheme | protectedvirtual
DrawControlRadioButtonMark(CDC *pDC, CRect rc, BOOL bDraw, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled) | CXTPCommandBarsOffice2013Theme | protectedvirtual
DrawControlText(CDC *pDC, CXTPControl *pControl, CRect rcText, BOOL bDraw, BOOL bVert, BOOL bCentered, BOOL bTriangled) | CXTPPaintManager |
DrawControlToolBarParent(CDC *pDC, CXTPControl *pButton, BOOL bDraw) | CXTPPaintManager | virtual
DrawDialogBarGripper(CDC *pDC, CXTPDialogBar *pBar, BOOL bDraw) | CXTPCommandBarsOfficeXPTheme | virtual
DrawDropDownGlyph(CDC *pDC, CXTPControl *pControl, CPoint pt, BOOL bSelected, BOOL bPopuped, BOOL bEnabled, BOOL bVert) | CXTPCommandBarsOffice2013Theme | protectedvirtual
DrawExpandGlyph(CDC *pDC, CXTPControl *pButton, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clr) | CXTPCommandBarsOffice2013Theme | protectedvirtual
DrawExpandGlyph(CDC *pDC, CXTPControl *pButton, COLORREF clr, BOOL bVertical) | CXTPCommandBarsOffice2013Theme | protectedvirtual
DrawFrameBorder(CDC *pDC, CRect rc, int nBorderThickness, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition) | CXTPCommandBarsOffice2013Theme | protected
DrawGalleryItemBack(CDC *pDC, CRect rcItem, BOOL bEnabled, BOOL bSelected, BOOL bPressed, BOOL bChecked, XTPBarType barType) | CXTPCommandBarsVisualStudio2019Theme | protectedvirtual
DrawHiddenGlyph(CDC *pDC, CXTPControl *pButton, COLORREF clr, BOOL bVertical) | CXTPCommandBarsOffice2013Theme | protectedvirtual
DrawImage(CDC *pDC, CPoint pt, CSize sz, CXTPImageManagerIcon *pImage, BOOL bSelected, BOOL bPressed, BOOL bEnabled=TRUE, BOOL bChecked=FALSE, BOOL bPopuped=FALSE, BOOL bToolBarImage=TRUE) | CXTPCommandBarsOfficeXPTheme | protectedvirtual
DrawListBoxControl(CDC *pDC, CXTPControl *pButton, CRect rc, BOOL bSelected, BOOL bDraw, CXTPCommandBars *pCommandBars=0) | CXTPCommandBarsOfficeXPTheme | virtual
DrawPopupBarCheckMark(CDC *pDC, CRect rcCheck, BOOL bEnabled, COLORREF clr) | CXTPPaintManager | virtual
DrawPopupBarGripper(CDC *pDC, int xPos, int yPos, int cx, int cy, BOOL bExpanded=FALSE) | CXTPCommandBarsOffice2013Theme | protectedvirtual
DrawPopupBarRadioMark(CDC *pDC, CRect rcCheck, BOOL bEnabled, COLORREF clr) | CXTPPaintManager | virtual
DrawPopupResizeGripper(CDC *pDC, CRect rcGripper, int nFlags) | CXTPCommandBarsOfficeXPTheme | virtual
DrawRectangle(CDC *pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition) | CXTPCommandBarsVisualStudio2019Theme | protectedvirtual
DrawRectangle(CDC *pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition, int nID) | CXTPCommandBarsVisualStudio2019Theme | protectedvirtual
DrawRectangle(CDC *pDC, CXTPControl *pButton) | CXTPCommandBarsVisualStudio2019Theme | protectedvirtual
DrawSpecialControl(CDC *pDC, XTPSpecialControl controlType, CXTPControl *pButton, CXTPCommandBar *pBar, BOOL bDraw, LPVOID lpParam) | CXTPPaintManager | virtual
DrawSplitButtonFrame(CDC *pDC, CXTPControl *pButton, CRect rc) | CXTPCommandBarsVisualStudio2019Theme | protectedvirtual
DrawTearOffGripper(CDC *pDC, CRect rcGripper, BOOL bSelected, BOOL bDraw) | CXTPCommandBarsOfficeXPTheme | virtual
FillCommandBarEntry(CDC *pDC, CXTPCommandBar *pBar) | CXTPCommandBarsOffice2013Theme | virtual
FillDockBar(CDC *pDC, CXTPDockBar *pBar) | CXTPCommandBarsOffice2013Theme | virtual
FillIntersectRect(CDC *pDC, CXTPPopupBar *pPopupBar, COLORREF clr) | CXTPCommandBarsOfficeXPTheme | protected
FillWorkspace(CDC *pDC, CRect rc, CRect rcExclude) | CXTPCommandBarsOffice2013Theme | virtual
FontExists(LPCTSTR lpszFaceName) | CXTPPaintManager | static
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCommandBarBorders(CXTPCommandBar *pBar) | CXTPPaintManager | virtual
GetCommandBarFont(CXTPCommandBar *pCommandBar) | CXTPPaintManager | virtual
GetControlBackColor(CXTPControl *pButton) | CXTPCommandBarsOffice2013Theme | protectedvirtual
GetControlEditBackColor(CXTPControl *pControl) | CXTPCommandBarsOffice2013Theme | virtual
GetControlFont(CXTPControl *pControl) | CXTPPaintManager | virtual
GetControlHeight() const | CXTPPaintManager |
GetControlTextColor(CXTPControl *pButton) | CXTPCommandBarsVisualStudio2019Theme | protectedvirtual
GetControlTextOrientation(CXTPControl *pControl) | CXTPPaintManager | virtual
GetCurrentSystemTheme() | CXTPPaintManager |
GetCurrentTheme() | CXTPPaintManager | inline
GetDefaultCommandBarSize(CXTPCommandBar *pBar) | CXTPPaintManager | virtual
GetFramePaintManager() | CXTPCommandBarsModernUITheme | virtual
GetGalleryPaintManager() const | CXTPPaintManager | virtual
GetGlobalPaintManager() | CXTPPaintManager | static
GetIconFont() | CXTPPaintManager |
GetIconsInfo() | CXTPPaintManager |
GetInstanceAddRef() | CXTPPaintManager | static
GetMarkupContext() | CXTPCommandBarsModernUITheme | virtual
GetMessageBarPaintManager() | CXTPPaintManager | virtual
GetPopupBarGripperWidth(CXTPCommandBar *pBar) | CXTPPaintManager | virtual
GetProgressPaintManager() const | CXTPPaintManager | virtual
GetRectangleTextColor(BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition) | CXTPCommandBarsOffice2013Theme | protectedvirtual
GetRegularBoldFont() | CXTPPaintManager |
GetRegularFont() | CXTPPaintManager |
GetRibbonPaintManager() | CXTPCommandBarsModernUITheme | virtual
GetScrollBarPaintManager() const | CXTPPaintManager | virtual
GetShadowManager() const | CXTPPaintManager |
GetShadowOptions() const | CXTPPaintManager |
GetSliderPaintManager() const | CXTPPaintManager | virtual
GetSmCaptionFont() | CXTPPaintManager |
GetSplitButtonCommandRect(CXTPControl *pButton) | CXTPPaintManager | virtual
GetStateColor() const | CXTPCommandBarsVisualStudio2019Theme | virtual
GetStatusBarPaintManager() | CXTPPaintManager | virtual
GetXtremeColor(UINT nIndex) | CXTPPaintManager |
GradientFill(CDC *pDC, LPRECT lpRect, COLORREF crFrom, COLORREF crTo, BOOL bHorz, LPCRECT lpRectClip=NULL) | CXTPPaintManager |
HorizontalLine(CDC *pDC, int x0, int y0, int x1, COLORREF clrPen) | CXTPPaintManager |
IsUseSystemAccentColorEnabled() const | CXTPPaintManager |
Line(CDC *pDC, CPoint p0, CPoint p1) | CXTPPaintManager |
Line(CDC *pDC, int x0, int y0, int x1, int y1, const int nPen) | CXTPPaintManager |
Line(CDC *pDC, int x0, int y0, int x1, int y1, COLORREF clrPen) | CXTPPaintManager |
m_arrColor | CXTPPaintManager | protected
m_bAutoResizeIcons | CXTPPaintManager |
m_bClearTypeTextQuality | CXTPPaintManager |
m_bEmbossedDisabledText | CXTPPaintManager | protected
m_bEnableAnimation | CXTPPaintManager |
m_bFlatMenuBar | CXTPPaintManager |
m_bFlatToolBar | CXTPPaintManager |
m_bIntersect | CXTPCommandBarsOffice2013Theme | protected
m_bOffice2007Padding | CXTPPaintManager |
m_bOffsetPopupLabelText | CXTPPaintManager |
m_bSelectImageInPopupBar | CXTPPaintManager |
m_bShowKeyboardCues | CXTPPaintManager | protected
m_bShowShadow | CXTPPaintManager |
m_bThemedCheckBox | CXTPPaintManager |
m_bThemedStatusBar | CXTPPaintManager |
m_bThickCheckMark | CXTPPaintManager |
m_bUseOfficeFont | CXTPPaintManager |
m_bUseStandardFont | CXTPPaintManager | protected
m_bWrapCaptionBelowText | CXTPPaintManager |
m_clr3DShadow | CXTPCommandBarsOffice2013Theme | protected
m_clrBack | CXTPCommandBarsOffice2013Theme | protected
m_clrBtnFace | CXTPCommandBarsOffice2013Theme | protected
m_clrCaptionButtonFill | CXTPCommandBarsOffice2013Theme | protected
m_clrDisabledIcon | CXTPPaintManager |
m_clrFloatingGripper | CXTPPaintManager |
m_clrFloatingGripperText | CXTPPaintManager |
m_clrGlyph | CXTPCommandBarsOffice2013Theme | protected
m_clrGlyphDisabled | CXTPCommandBarsOffice2013Theme | protected
m_clrGlyphHighlight | CXTPCommandBarsOffice2013Theme | protected
m_clrGlyphPushed | CXTPCommandBarsOffice2013Theme | protected
m_clrHighlight | CXTPCommandBarsOffice2013Theme | protected
m_clrMessageBarText | CXTPCommandBarsOffice2013Theme | protected
m_clrWorkspace | CXTPCommandBarsOffice2013Theme | protected
m_csCheckBox | CXTPCommandBarsOffice2013Theme | protected
m_csCheckMark | CXTPCommandBarsOffice2013Theme | protected
m_csComboBox | CXTPCommandBarsOffice2013Theme | protected
m_csMenu | CXTPCommandBarsOffice2013Theme | protected
m_csMenuTitleBar | CXTPCommandBarsOffice2013Theme | protected
m_csRibbon | CXTPCommandBarsOffice2013Theme | protected
m_csToolbar | CXTPCommandBarsOffice2013Theme | protected
m_fontIcon | CXTPPaintManager |
m_fontIconBold | CXTPPaintManager |
m_fontSmCaption | CXTPPaintManager |
m_fontToolTip | CXTPPaintManager |
m_iconsInfo | CXTPPaintManager | protected
m_nAnimationSteps | CXTPPaintManager | protected
m_nAnimationTime | CXTPPaintManager | protected
m_nEditHeight | CXTPPaintManager | protected
m_nFontHeight | CXTPPaintManager | protected
m_nPopupBarTextPadding | CXTPPaintManager |
m_nSplitButtonDropDownHeight | CXTPPaintManager |
m_nSplitButtonDropDownWidth | CXTPPaintManager |
m_nSplitButtonPopupWidth | CXTPPaintManager |
m_nStatusBarMinHeight | CXTPPaintManager |
m_nTextHeight | CXTPPaintManager |
m_pfnSetLayeredWindowAttributes | CXTPPaintManager |
m_pFramePaintManager | CXTPPaintManager |
m_pGalleryPaintManager | CXTPPaintManager |
m_pImages | CXTPCommandBarsModernUITheme | protected
m_pMarkupContext | CXTPCommandBarsModernUITheme | protected
m_pProgressPaintManager | CXTPPaintManager |
m_pRibbonPaintManager | CXTPPaintManager |
m_pScrollBarPaintManager | CXTPPaintManager |
m_pShadowManager | CXTPPaintManager | protected
m_pSliderPaintManager | CXTPPaintManager |
m_pStatusBarPaintManager | CXTPPaintManager |
m_rcMessageBarMargin | CXTPPaintManager |
m_rcStatusBarBorder | CXTPPaintManager |
m_strOfficeFont | CXTPPaintManager |
m_systemTheme | CXTPPaintManager | protected
m_themeButton | CXTPPaintManager | protected
m_themeCurrent | CXTPPaintManager | protected
m_themeStatusBar | CXTPPaintManager | protected
m_xtpFontRegular | CXTPPaintManager | protected
m_xtpFontRegularBold | CXTPPaintManager | protected
m_xtpFontVert | CXTPPaintManager | protected
m_xtpFontVertBold | CXTPPaintManager | protected
Notify(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *)) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
Notify(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1), A1 arg1) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
Notify(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
Notify(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamic(void(T::*method)(O *)) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1), A1 arg1) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *)) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1), A1 arg1) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyReversed(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *)) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyReversed(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1), A1 arg1) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyReversed(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyReversed(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
Pixel(CDC *pDC, int xPos, int yPos, int nPen) | CXTPPaintManager |
Rectangle(CDC *pDC, LPCRECT rc, int nPen, const int nBrush) | CXTPPaintManager |
Rectangle(CDC *pDC, LPCRECT rc, COLORREF clrPen, COLORREF clrBrush) | CXTPPaintManager |
RefreshMetrics() | CXTPCommandBarsOffice2013Theme | protectedvirtual
RefreshStandardColors() | CXTPCommandBarsOffice2013Theme | protectedvirtual
ReleaseInstance() | CXTPPaintManager | static
RequiresResourceImages() | CXTPCommandBarsOffice2013Theme | virtual
RoundRect(CDC *pDC, LPCRECT rc, COLORREF clrPen, COLORREF clrBrush) | CXTPPaintManager |
SetAnimationDelay(int nAnimationSteps, int nAnimationTime) | CXTPPaintManager |
SetColors(int cElements, CONST INT *lpaElements, CONST COLORREF *lpaRgbValues) | CXTPPaintManager |
SetCommandBarRegion(CXTPCommandBar *pCommandBar) | CXTPPaintManager | virtual
SetCommandBarsFontIndirect(LOGFONT *pLogFont, BOOL bUseStandardFont=FALSE) | CXTPPaintManager |
SetCustomTheme(CXTPPaintManager *pTheme) | CXTPPaintManager | static
SetGlobalPaintManager(CXTPPaintManager *pPaintManager) | CXTPPaintManager | static
SetImageHandle(HMODULE hResource, LPCTSTR lpszIniFileName) | CXTPPaintManager | virtual
SetLunaTheme(XTPCurrentSystemTheme systemTheme) | CXTPPaintManager |
SetStateColor(COLORREF clrState=COLORREF_NULL) | CXTPCommandBarsVisualStudio2019Theme | virtual
SetTheme(XTPPaintTheme paintTheme) | CXTPPaintManager | static
StripMnemonics(CString &strClear) | CXTPPaintManager | static
Subscribe(IXTPPaintManagerEvents *pObserver, CXTPSubscriptionList< CXTPPaintManager, IXTPPaintManagerEvents > *pSubcriptionList=NULL) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > |
Triangle(CDC *pDC, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clr) | CXTPPaintManager | static
Unsubscribe(IXTPPaintManagerEvents *pObserver) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > |
UpdateColors() | CXTPPaintManager | virtual
UpdateFonts() | CXTPPaintManager | virtual
UpdateRTLCaption(CString &strCaption) | CXTPPaintManager | virtual
UseOfficeFont(bool bUseOfficeFont) | CXTPPaintManager |
VerticalLine(CDC *pDC, int x0, int y0, int y1, COLORREF clrPen) | CXTPPaintManager |
~CXTPCommandBarsModernUITheme() | CXTPCommandBarsModernUITheme | virtual
~CXTPCommandBarsOffice2013Theme() | CXTPCommandBarsOffice2013Theme | virtual
~CXTPCommandBarsVisualStudio2019Theme() | CXTPCommandBarsVisualStudio2019Theme | virtual
~CXTPObservable() | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | protected
~CXTPPaintManager() | CXTPPaintManager | protectedvirtual


Toolkit Pro: XTPSliderThemeVisualStudio2017.h Source File

  • Source
  • CommandBars
  • Slider
XTPSliderThemeVisualStudio2017.h
Go to the documentation of this file.
1
23#if !defined(__XTPSLIDERTHEMEVISUALSTUDIO2017_H__)
24# define __XTPSLIDERTHEMEVISUALSTUDIO2017_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class _XTP_EXT_CLASS CXTPSliderThemeVisualStudio2017 : public CXTPSliderThemeOffice2013
34{
35public:
36 CXTPSliderThemeVisualStudio2017(CXTPPaintManager* pPaintManager);
37};
38
40# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
41#endif // !defined(__XTPSLIDERTHEMEVISUALSTUDIO2017_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPPaintManager
Paint manager of the command bars.
Definition XTPPaintManager.h:199


Toolkit Pro: Member List

CXTPSyntaxEditPropertiesPageEdit Member List

This is the complete list of members for CXTPSyntaxEditPropertiesPageEdit, including all inherited members.

CXTPSyntaxEditPropertiesPageEdit(CXTPSyntaxEditView *pEditView=NULL) | CXTPSyntaxEditPropertiesPageEdit |
m_bModified | CXTPSyntaxEditPropertiesPageEdit | protected
m_pEditView | CXTPSyntaxEditPropertiesPageEdit | protected
ReadRegistryValues() | CXTPSyntaxEditPropertiesPageEdit | protected
SetModified(BOOL bChanged=TRUE) | CXTPSyntaxEditPropertiesPageEdit | protected
WriteRegistryValues() | CXTPSyntaxEditPropertiesPageEdit | protected
~CXTPSyntaxEditPropertiesPageEdit() | CXTPSyntaxEditPropertiesPageEdit | virtual


Toolkit Pro: XTPNotifyConnection.h Source File

  • Source
  • Common
XTPNotifyConnection.h
Go to the documentation of this file.
1
23#ifndef _XTPNOTIFYCONNECTION_H__
24# define _XTPNOTIFYCONNECTION_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
34class CXTPNotifySinkBase;
35
36typedef DWORD_PTR XTP_CONNECTION_ID;
37typedef DWORD XTP_NOTIFY_CODE;
38
43const UINT WM_XTP_COMMON_BASE = (WM_USER + 9550);
44
56static const XTP_NOTIFY_CODE XTP_NC_COMMON_RESOURCEIMAGES_CHANGED = (WM_XTP_COMMON_BASE + 1);
63enum XTPNotifyFlags
64{
65 xtpNotifyPostMessage = 0x80000000,
66 xtpNotifyGuarantyPost = 0x40000000,
69 xtpNotifyDirectCallForOneThread = 0x20000000
71};
72
87class _XTP_EXT_CLASS CXTPNotifyConnection : public CXTPCmdTarget
88{
89public:
96 CXTPNotifyConnection();
97
104 virtual ~CXTPNotifyConnection();
105
106public:
125 XTP_CONNECTION_ID Advise(XTP_NOTIFY_CODE dwNotifyCode, CXTPNotifySinkBase* pSink);
126
139 void Unadvise(XTP_CONNECTION_ID ConnectionID);
140
150 void RemoveAll();
151
169 BOOL SendEvent(XTP_NOTIFY_CODE dwNotifyCode, WPARAM wParam, LPARAM lParam, DWORD dwFlags = 0);
170
171protected:
186 int FindConnection(XTP_CONNECTION_ID ConnectionID);
187
200 virtual CSyncObject* GetDataLock();
201
210 struct CONNECTION_DESCRIPTOR
211 {
212 XTP_NOTIFY_CODE dwNotifyCode;
213 CXTPNotifySinkBase* pSink;
214 XTP_CONNECTION_ID dwConnectionID;
216 };
217
227 class CEmptySyncObject : public CSyncObject
228 {
229 public:
234 CEmptySyncObject();
235
248 virtual BOOL Lock(DWORD dwTimeout = INFINITE);
249
260 virtual BOOL Unlock();
261
275 virtual BOOL Unlock(LONG lCount, LPLONG lPrevCount = NULL);
276 };
277
278protected:
279 CArray<CONNECTION_DESCRIPTOR*, CONNECTION_DESCRIPTOR*>
280 m_arrConnections;
282 CArray<CONNECTION_DESCRIPTOR, CONNECTION_DESCRIPTOR&>
283 m_arrSendQueueCache;
284 int m_nSendQueueCacheSize;
285 CEmptySyncObject m_emptyLocker;
286};
287
302class _XTP_EXT_CLASS CXTPNotifyConnectionMT : public CXTPNotifyConnection
303{
304public:
309 CXTPNotifyConnectionMT();
310
315 virtual ~CXTPNotifyConnectionMT();
316
339 BOOL PostEvent(XTP_NOTIFY_CODE dwNotifyCode, WPARAM wParam, LPARAM lParam, DWORD dwFlags = 0);
340
341protected:
352 virtual CSyncObject* GetDataLock();
353
354 CCriticalSection m_DataLockerCS;
355};
356
358static LPCTSTR XTP_NOTIFICATION_SINK_MT_ON_EVENT_MSG = _T("XTPNotificationSinkMTOnEvent");
359const UINT xtp_wm_NotificationSinkMTOnEvent = RegisterWindowMessage(
360 XTP_NOTIFICATION_SINK_MT_ON_EVENT_MSG);
378class _XTP_EXT_CLASS CXTPNotifySinkBase
379{
380public:
387 CXTPNotifySinkBase();
388
389protected:
396 virtual ~CXTPNotifySinkBase();
397
398public:
414 virtual void OnEvent(XTP_NOTIFY_CODE dwNotifyCode, WPARAM wParam, LPARAM lParam,
415 DWORD dwFlags) = 0;
416
417public:
429 void UnadviseAll();
430
444 void Unadvise(XTP_CONNECTION_ID id);
445
446protected:
465 XTP_CONNECTION_ID Advise(CXTPNotifyConnection* pConnection, XTP_NOTIFY_CODE dwNotifyCode);
466
467protected:
468 virtual void OnUnadvise(XTP_NOTIFY_CODE dwNotifyCode);
469
470protected:
478 struct ADVISE_DESCRIPTOR
479 {
480 XTP_NOTIFY_CODE dwNotifyCode;
481 CXTPNotifyConnection* pConnection;
483 XTP_CONNECTION_ID dwConnectionID;
485 };
486
487 CMap<XTP_CONNECTION_ID, XTP_CONNECTION_ID&, ADVISE_DESCRIPTOR, ADVISE_DESCRIPTOR&>
488 m_mapAdviseData;
490};
491
493
494AFX_INLINE BOOL CXTPNotifyConnection::CEmptySyncObject::Lock(DWORD /*dwTimeout*/)
495{
496 return TRUE;
497}
498AFX_INLINE BOOL CXTPNotifyConnection::CEmptySyncObject::Unlock()
499{
500 return TRUE;
501}
502AFX_INLINE BOOL CXTPNotifyConnection::CEmptySyncObject::Unlock(LONG /*lCount*/,
503 LPLONG /*lPrevCount = NULL*/)
504{
505 return TRUE;
506}
507AFX_INLINE CSyncObject* CXTPNotifyConnection::GetDataLock()
508{
509 return &m_emptyLocker;
510}
511AFX_INLINE CSyncObject* CXTPNotifyConnectionMT::GetDataLock()
512{
513 return &m_DataLockerCS;
514}
515AFX_INLINE BOOL CXTPNotifyConnectionMT::PostEvent(XTP_NOTIFY_CODE dwNotifyCode, WPARAM wParam,
516 LPARAM lParam, DWORD dwFlags)
517{
518 return SendEvent(dwNotifyCode, wParam, lParam, dwFlags | xtpNotifyPostMessage);
519}
520
521template<class ownerClassName, class _CInformator>
522class CXTPNotifySinkBaseImpl : public CXTPNotifySinkBase
523{
524public:
525 CXTPNotifySinkBaseImpl()
526 {
527 m_mapHandlers.InitHashTable(101, FALSE);
528 }
529 virtual ~CXTPNotifySinkBaseImpl()
530 {
531 UnadviseAll();
532 };
533
534public:
535 typedef void (ownerClassName::*T_pfHandler)(XTP_NOTIFY_CODE dwNotifyCode, WPARAM wParam,
536 LPARAM lParam);
537
538 XTP_CONNECTION_ID Advise(CXTPNotifyConnection* pConnection, XTP_NOTIFY_CODE dwNotifyCode,
539 T_pfHandler pfHandler)
540 {
541 m_mapHandlers.SetAt(dwNotifyCode, pfHandler);
542 return CXTPNotifySinkBase::Advise(pConnection, dwNotifyCode);
543 }
544
545 virtual void OnEvent(XTP_NOTIFY_CODE dwNotifyCode, WPARAM wParam, LPARAM lParam,
546 DWORD /*dwFlags*/)
547 {
548 ownerClassName* pThis = _CInformator::GetPThis((BYTE*)this);
549
550 if (!pThis)
551 {
552 _ASSERTE(FALSE);
553 return;
554 }
555
556 T_pfHandler pfHandler = 0;
557 if (m_mapHandlers.Lookup(dwNotifyCode, pfHandler) && (pfHandler != NULL))
558 {
559 (pThis->*(pfHandler))(dwNotifyCode, wParam, lParam);
560 return;
561 }
562
563 // WARNING. no handler found. ???
564 _ASSERTE(FALSE);
565 }
566
567protected:
568 CMap<XTP_NOTIFY_CODE, XTP_NOTIFY_CODE, T_pfHandler, T_pfHandler> m_mapHandlers;
569};
570
571class _XTP_EXT_CLASS CXTPNotifySinkImplMTMsgWnd : public CWnd
572{
573public:
574 CXTPNotifySinkImplMTMsgWnd();
575 virtual ~CXTPNotifySinkImplMTMsgWnd();
576
577protected:
578 virtual LRESULT OnInterThreadEvent(WPARAM pEventData, LPARAM reserved) = 0;
579
580 afx_msg LRESULT HandleInterThreadEvent(WPARAM pEventData, LPARAM reserved);
581
582 virtual BOOL CreateWnd();
583
584 DECLARE_MESSAGE_MAP()
585};
586
587//=== Multithreaded sink implementation =====================================
588struct XTP_INTER_THREAD_EVENT_DATA
589{
590 XTP_NOTIFY_CODE dwNotifyCode;
591 WPARAM wParam;
592 LPARAM lParam;
593 DWORD dwFlags;
594};
595
596# define DECLARE_XTP_SINKEX(ownerClassName, MemberName, _CSinkClass) \
597 class C_##MemberName##_Informator \
598 { \
599 public: \
600 static ownerClassName* AFX_CDECL GetPThis(BYTE* pSink) \
601 { \
602 ownerClassName* pThis = (( \
603 ownerClassName*)((BYTE*)pSink - offsetof(ownerClassName, MemberName))); \
604 return pThis; \
605 }; \
606 }; \
607 friend class C_##MemberName##_Informator; \
608 typedef _CSinkClass<ownerClassName, C_##MemberName##_Informator> T_##MemberName; \
609 T_##MemberName MemberName;
610
638# define DECLARE_XTP_SINK(ownerClassName, MemberName) \
639 DECLARE_XTP_SINKEX(ownerClassName, MemberName, CXTPNotifySinkBaseImpl) \
640 friend class CXTPNotifySinkBaseImpl<ownerClassName, C_##MemberName##_Informator>;
641
644class _XTP_EXT_CLASS CXTPNotifySinkDelegate
645{
646public:
647 virtual ~CXTPNotifySinkDelegate();
648
649public:
650 virtual void OnEvent(XTP_NOTIFY_CODE dwNotifyCode, WPARAM wParam, LPARAM lParam) = 0;
651};
652
653template<class T>
654class CXTPNotifySinkClassDelegate : public CXTPNotifySinkDelegate
655{
656public:
657 typedef void (T::*EVENTHANDLER)(XTP_NOTIFY_CODE dwNotifyCode, WPARAM wParam, LPARAM lParam);
658
659public:
660 CXTPNotifySinkClassDelegate(T* pObject, EVENTHANDLER pHandler)
661 {
662 m_pObject = pObject;
663 m_pHandler = pHandler;
664 }
665
666 virtual void OnEvent(XTP_NOTIFY_CODE dwNotifyCode, WPARAM wParam, LPARAM lParam)
667 {
668 (m_pObject->*m_pHandler)(dwNotifyCode, wParam, lParam);
669 }
670
671protected:
672 T* m_pObject;
673 EVENTHANDLER m_pHandler;
674};
675
676template<class T, typename EVENTHANDLER>
677AFX_INLINE CXTPNotifySinkDelegate* CreateNotfySinkClassDelegate(T* pClass, EVENTHANDLER pfnDelegate)
678{
679 return new CXTPNotifySinkClassDelegate<T>(
680 pClass, (typename CXTPNotifySinkClassDelegate<T>::EVENTHANDLER)pfnDelegate);
681}
682
685class _XTP_EXT_CLASS CXTPNotifySink : public CXTPNotifySinkBase
686{
687public:
688 CXTPNotifySink();
689
690protected:
691 ~CXTPNotifySink();
692
693public:
694 void Delete();
695
696public:
697 XTP_CONNECTION_ID Advise(CXTPNotifyConnection* pConnection, XTP_NOTIFY_CODE dwNotifyCode,
698 CXTPNotifySinkDelegate* pDelegate);
699
700 virtual void OnEvent(XTP_NOTIFY_CODE dwNotifyCode, WPARAM wParam, LPARAM lParam,
701 DWORD /*dwFlags*/);
702
703protected:
704 virtual void OnUnadvise(XTP_NOTIFY_CODE dwNotifyCode);
705
706protected:
707 CMap<XTP_NOTIFY_CODE, XTP_NOTIFY_CODE, CXTPNotifySinkDelegate*, CXTPNotifySinkDelegate*>
708 m_mapHandlers;
709};
710
711class _XTP_EXT_CLASS CXTPNotifySinkMT
712 : public CXTPNotifySink
713 , public CXTPNotifySinkImplMTMsgWnd
714{
715public:
716 CXTPNotifySinkMT(BOOL bInitInternal = TRUE);
717
718 virtual ~CXTPNotifySinkMT();
719
720public:
721 virtual void OnEvent(XTP_NOTIFY_CODE dwNotifyCode, WPARAM wParam, LPARAM lParam, DWORD dwFlags);
722
723protected:
724 virtual LRESULT OnInterThreadEvent(WPARAM pEventData, LPARAM dwPostDataID);
725
726protected:
727 CMap<DWORD, DWORD, XTP_INTER_THREAD_EVENT_DATA, XTP_INTER_THREAD_EVENT_DATA&> m_PostedEvents;
728 DWORD m_dwNexDataID;
729
730 BOOL m_bWndCreated;
731 DWORD m_dwOwnerThreadID;
732 CCriticalSection m_DataCS;
733
734private:
735 DWORD m_dwTraceFlag0;
736};
738AFX_INLINE CXTPNotifySinkDelegate::~CXTPNotifySinkDelegate()
739{
740}
742# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
744#endif // !defined(_XTPNOTIFYCONNECTION_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
WM_XTP_COMMON_BASE
const UINT WM_XTP_COMMON_BASE
Defines a base ID for common notifications.
Definition XTPNotifyConnection.h:43
XTPNotifyFlags
XTPNotifyFlags
RANGE for WM_XTP_COMMON_BASE {+ 1 ... + 49}.
Definition XTPNotifyConnection.h:64
xtpNotifyGuarantyPost
@ xtpNotifyGuarantyPost
Used together with nofPostMessage.
Definition XTPNotifyConnection.h:66
xtpNotifyDirectCallForOneThread
@ xtpNotifyDirectCallForOneThread
Event handler will be called directly if sender and receiver are in one thread.
Definition XTPNotifyConnection.h:69
xtpNotifyPostMessage
@ xtpNotifyPostMessage
Event will be posted.
Definition XTPNotifyConnection.h:65
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPNotifyConnection::CEmptySyncObject
This struct is derived from CSyncObject and should be used instead of CCriticalSection to improve per...
Definition XTPNotifyConnection.h:228
CXTPNotifyConnection::CEmptySyncObject::Unlock
virtual BOOL Unlock(LONG lCount, LPLONG lPrevCount=NULL)
Set object state as unlocked.
CXTPNotifyConnection::CEmptySyncObject::Lock
virtual BOOL Lock(DWORD dwTimeout=INFINITE)
Set object state as locked.
CXTPNotifyConnection::CEmptySyncObject::Unlock
virtual BOOL Unlock()
Set object state as unlocked.
CXTPNotifyConnection::CEmptySyncObject::CEmptySyncObject
CEmptySyncObject()
Default object constructor.
CXTPNotifyConnection
This class is used as implementation of Connection interface in a XTPNotification mechanism.
Definition XTPNotifyConnection.h:88
CXTPNotifyConnection::Advise
XTP_CONNECTION_ID Advise(XTP_NOTIFY_CODE dwNotifyCode, CXTPNotifySinkBase *pSink)
Establishes a connection between the connection object and a sink object.
CXTPNotifyConnection::Unadvise
void Unadvise(XTP_CONNECTION_ID ConnectionID)
Terminate a connection between the connection object and a sink object.
CXTPNotifyConnection::m_arrSendQueueCache
CArray< CONNECTION_DESCRIPTOR, CONNECTION_DESCRIPTOR & > m_arrSendQueueCache
used in SendEvent method for safety reason
Definition XTPNotifyConnection.h:283
CXTPNotifyConnection::m_nSendQueueCacheSize
int m_nSendQueueCacheSize
used in SendEvent method together with m_arrSendQueueCache.
Definition XTPNotifyConnection.h:284
CXTPNotifyConnection::~CXTPNotifyConnection
virtual ~CXTPNotifyConnection()
Default object destructor.
CXTPNotifyConnection::m_emptyLocker
CEmptySyncObject m_emptyLocker
Pseudo-locker object.
Definition XTPNotifyConnection.h:285
CXTPNotifyConnection::CXTPNotifyConnection
CXTPNotifyConnection()
Default object constructor.
CXTPNotifyConnection::RemoveAll
void RemoveAll()
Remove All connections information.
CXTPNotifyConnection::m_arrConnections
CArray< CONNECTION_DESCRIPTOR *, CONNECTION_DESCRIPTOR * > m_arrConnections
store connections between a Connection object, Notification code and the sink object.
Definition XTPNotifyConnection.h:280
CXTPNotifyConnection::FindConnection
int FindConnection(XTP_CONNECTION_ID ConnectionID)
Find connection information in the m_arConnections array.
CXTPNotifyConnection::SendEvent
BOOL SendEvent(XTP_NOTIFY_CODE dwNotifyCode, WPARAM wParam, LPARAM lParam, DWORD dwFlags=0)
Send event with specified EventCode.
CXTPNotifyConnection::GetDataLock
virtual CSyncObject * GetDataLock()
Get synchronization object to lock internal class data.
CXTPNotifyConnectionMT
This class is used as thread-safety implementation of Connection interface in a XTPNotification mecha...
Definition XTPNotifyConnection.h:303
CXTPNotifyConnectionMT::~CXTPNotifyConnectionMT
virtual ~CXTPNotifyConnectionMT()
Default object destructor.
CXTPNotifyConnectionMT::CXTPNotifyConnectionMT
CXTPNotifyConnectionMT()
Default object constructor.
CXTPNotifyConnectionMT::PostEvent
BOOL PostEvent(XTP_NOTIFY_CODE dwNotifyCode, WPARAM wParam, LPARAM lParam, DWORD dwFlags=0)
Post event with specified EventCode.
CXTPNotifyConnectionMT::GetDataLock
virtual CSyncObject * GetDataLock()
Get synchronization object to lock internal class data.
CXTPNotifyConnectionMT::m_DataLockerCS
CCriticalSection m_DataLockerCS
Data locker object.
Definition XTPNotifyConnection.h:354
CXTPNotifySinkBase
This class is used as implementation of Sink interface in a XTPNotification mechanism.
Definition XTPNotifyConnection.h:379
CXTPNotifySinkBase::Advise
XTP_CONNECTION_ID Advise(CXTPNotifyConnection *pConnection, XTP_NOTIFY_CODE dwNotifyCode)
Establishes a connection between the connection object and a sink object.
CXTPNotifySinkBase::OnEvent
virtual void OnEvent(XTP_NOTIFY_CODE dwNotifyCode, WPARAM wParam, LPARAM lParam, DWORD dwFlags)=0
Event with specified dwNotifyCode was occurred.
CXTPNotifySinkBase::~CXTPNotifySinkBase
virtual ~CXTPNotifySinkBase()
Default object destructor.
CXTPNotifySinkBase::CXTPNotifySinkBase
CXTPNotifySinkBase()
Default object constructor.
CXTPNotifySinkBase::Unadvise
void Unadvise(XTP_CONNECTION_ID id)
Terminate a connection between the connection object and this sink object.
CXTPNotifySinkBase::m_mapAdviseData
CMap< XTP_CONNECTION_ID, XTP_CONNECTION_ID &, ADVISE_DESCRIPTOR, ADVISE_DESCRIPTOR & > m_mapAdviseData
store connections between a Connection objects, Notification code and this sink object.
Definition XTPNotifyConnection.h:488
CXTPNotifySinkBase::UnadviseAll
void UnadviseAll()
Terminate all connections between the connection object(s) and this sink object.
CXTPNotifyConnection::CONNECTION_DESCRIPTOR
This struct is used in the implementation of the class CXTPNotifyConnection to store connection betwe...
Definition XTPNotifyConnection.h:211
CXTPNotifyConnection::CONNECTION_DESCRIPTOR::dwNotifyCode
XTP_NOTIFY_CODE dwNotifyCode
The Notification code.
Definition XTPNotifyConnection.h:212
CXTPNotifyConnection::CONNECTION_DESCRIPTOR::pSink
CXTPNotifySinkBase * pSink
The pointer to the sink object.
Definition XTPNotifyConnection.h:213
CXTPNotifyConnection::CONNECTION_DESCRIPTOR::dwConnectionID
XTP_CONNECTION_ID dwConnectionID
The unique connection ID used for Unadvise() method.
Definition XTPNotifyConnection.h:214
CXTPNotifySinkBase::ADVISE_DESCRIPTOR
This struct is used in to store connection between a Connection object(s), Notification code and the ...
Definition XTPNotifyConnection.h:479
CXTPNotifySinkBase::ADVISE_DESCRIPTOR::dwNotifyCode
XTP_NOTIFY_CODE dwNotifyCode
The Notification code.
Definition XTPNotifyConnection.h:480
CXTPNotifySinkBase::ADVISE_DESCRIPTOR::pConnection
CXTPNotifyConnection * pConnection
The pointer to the connection object.
Definition XTPNotifyConnection.h:481
CXTPNotifySinkBase::ADVISE_DESCRIPTOR::dwConnectionID
XTP_CONNECTION_ID dwConnectionID
Original Connection ID returned by pConnection->Advise() method.
Definition XTPNotifyConnection.h:483


Toolkit Pro: Member List

XTP_NM_SELECTION_CHANGING Member List

This is the complete list of members for XTP_NM_SELECTION_CHANGING, including all inherited members.

hdr | XTP_NM_SELECTION_CHANGING
nType | XTP_NM_SELECTION_CHANGING
pRow | XTP_NM_SELECTION_CHANGING


Toolkit Pro: Member List

XTP_NM_GRIDCOLUMNORDERCHANGED Member List

This is the complete list of members for XTP_NM_GRIDCOLUMNORDERCHANGED, including all inherited members.

hdr | XTP_NM_GRIDCOLUMNORDERCHANGED
nReason | XTP_NM_GRIDCOLUMNORDERCHANGED
pColumn | XTP_NM_GRIDCOLUMNORDERCHANGED


Toolkit Pro: XTPCommandBarAnimation.h Source File

  • Source
  • CommandBars
XTPCommandBarAnimation.h
Go to the documentation of this file.
1
23#if !defined(__XTPRIBBONANIMATION_H__)
24# define __XTPRIBBONANIMATION_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
34class CXTPCommandBar;
35
36# define XTP_TID_ANIMATION 0xACD43
37
38class _XTP_EXT_CLASS CXTPCommandBarAnimation
39{
40protected:
41 struct CAnimateInfo
42 {
43 CAnimateInfo();
44 ~CAnimateInfo();
45
46 HBITMAP hbmSrc;
47 BYTE* pSrcBits;
48
49 HBITMAP hbmSrcBack;
50 BYTE* pSrcBackBits;
51
52 RECT rcPaint;
53 int m_nAnimation;
54 CArray<RECT, RECT&> arrExclude;
55 };
56
57public:
58 CXTPCommandBarAnimation(CXTPCommandBar* pCommandBar);
59 ~CXTPCommandBarAnimation();
60
61public:
62 void OnPaint(CPaintDC& paintDC);
63 void RedrawRect(LPCRECT lpRect, BOOL bAnimate);
64 void OnAnimate();
65 void OnDestroy();
66
67protected:
68 void RemoveAnimations();
69 void AnimateRect(CClientDC& dc, CAnimateInfo* pai);
70 void RemoveIntersections(LPCRECT rcPaint, BOOL bAddExclude);
71
72 void AlphaBlendU(PBYTE pDest, PBYTE pSrcBack, int cx, int cy, PBYTE pSrc, BYTE byAlpha);
73 void AddAnimation(CClientDC& dc, CAnimateInfo* pai);
74
75 BOOL IsAnimationEnabled() const;
76
77public:
78 CXTPCommandBar* m_pParent;
79 CBitmap m_bmpCache;
80 BOOL m_bInvalidate;
81 UINT_PTR m_nTimer;
82
83 BOOL m_bAnimation;
84 BOOL m_bDoubleBuffer;
85
86protected:
87 CArray<CAnimateInfo*, CAnimateInfo*> m_arrAnimation;
88};
89
93# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
94#endif // !defined(__XTPRIBBONANIMATION_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCommandBar
CXTPCommandBar is a CWnd derived class.
Definition XTPCommandBar.h:66


Toolkit Pro: Member List

CXTPChartFunnelSeriesPointView Member List

This is the complete list of members for CXTPChartFunnelSeriesPointView, including all inherited members.

AddChildView(CXTPChartElementView *pChildView) | CXTPChartElementView |
CalculateLayout(int nIndex, int nCount, double dFrom, double dTo) | CXTPChartFunnelSeriesPointViewBase | virtual
CreateDeviceCommand(CXTPChartDeviceContext *pDC) | CXTPChartFunnelSeriesPointView | protectedvirtual
CreateLegendDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcBounds) | CXTPChartFunnelSeriesPointViewBase | protectedvirtual
CXTPChartElementView(CXTPChartElementView *pParentView) | CXTPChartElementView |
CXTPChartElementView(CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartElementView |
CXTPChartElementView(CXTPChartContainer *pContainer) | CXTPChartElementView |
CXTPChartFunnelSeriesPointView(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView) | CXTPChartFunnelSeriesPointView |
CXTPChartFunnelSeriesPointView(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartFunnelSeriesPointView |
CXTPChartFunnelSeriesPointViewBase(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView) | CXTPChartFunnelSeriesPointViewBase |
CXTPChartFunnelSeriesPointViewBase(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartFunnelSeriesPointViewBase |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartSeriesPointView(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView) | CXTPChartSeriesPointView |
CXTPChartSeriesPointView(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartSeriesPointView |
GetAt(int nIndex) const | CXTPChartElementView |
GetBorderActualColor() const | CXTPChartFunnelSeriesPointViewBase |
GetBounds() const | CXTPChartElementView |
GetBounds(BOOL bIncludingChildren) const | CXTPChartElementView |
GetChildren() | CXTPChartElementView |
GetColor() const | CXTPChartSeriesPointView |
GetColor2() const | CXTPChartSeriesPointView |
GetCount() const | CXTPChartElementView |
GetInternalValue() const | CXTPChartSeriesPointView |
GetLegendName() const | CXTPChartSeriesPointView | virtual
GetParentView() const | CXTPChartElementView |
GetPoint() const | CXTPChartSeriesPointView |
GetSeriesView() const | CXTPChartSeriesPointView |
Is3D() const | CXTPChartObject |
m_arrChildren | CXTPChartElementView | protected
m_dInternalValue | CXTPChartSeriesPointView |
m_dValue | CXTPChartFunnelSeriesPointViewBase | protected
m_pContainer | CXTPChartElementView | protected
m_pParentView | CXTPChartElementView | protected
m_pPoint | CXTPChartSeriesPointView | protected
m_rcBounds | CXTPChartElementView | protected
UpdateMinMaxRange(double &nMinValue, double &nMaxValue) const | CXTPChartSeriesPointView | virtual
~CXTPChartElementView() | CXTPChartElementView | protectedvirtual
~CXTPChartFunnelSeriesPointViewBase() | CXTPChartFunnelSeriesPointViewBase | virtual
~CXTPChartLegendItemView() | CXTPChartLegendItemView | inlinevirtual


Toolkit Pro: Member List

CXTPDockingPanePanelThemeNativeWindows11 Member List

This is the complete list of members for CXTPDockingPanePanelThemeNativeWindows11, including all inherited members.

AdjustClientRect(CXTPTabManager *pTabManager, CRect &rcClient) | CXTPTabPaintManagerTheme | virtual
CXTPDockingPanePanelTheme2012() | CXTPDockingPanePanelTheme2012 |
CXTPDockingPanePanelThemeNativeWindows11() | CXTPDockingPanePanelThemeNativeWindows11 |
CXTPTabPaintManagerTheme() | CXTPTabPaintManagerTheme |
CXTPTabThemeFlat() | CXTPTabThemeFlat | inline
DrawSingleButton(CDC *pDC, CXTPTabManagerItem *pItem) | CXTPDockingPanePanelTheme2012 | virtual
DrawTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl) | CXTPTabPaintManagerTheme | virtual
DrawText(CDC *pDC, CXTPTabManager *pManager, const CString &str, LPRECT lpRect, UINT nFormat) | CXTPTabPaintManagerTheme | virtual
DrawWorkspacePart(CDC *pDC, LPRECT lpRect, XTPTabWorkspacePart workspacePart) | CXTPTabPaintManagerTheme | virtual
FillButton(CDC *pDC, CXTPTabManagerItem *pItem, LPPOINT pts, int nCount, XTPTabPosition tabPosition, BOOL bAbsolute=FALSE) | CXTPTabPaintManagerTheme |
FillTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl) | CXTPTabThemeFlat | virtual
GetButtonDrawRect(const CXTPTabManagerItem *pItem) | CXTPTabPaintManagerTheme | virtual
GetButtonHeight(const CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetButtonLength(CDC *pDC, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerTheme | virtual
GetClientMargin() | CXTPTabPaintManagerTheme | virtual
GetClientRect(CRect rcControl, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetColorSet() const | CXTPTabPaintManagerTheme |
GetDefaultColorSet() | CXTPTabThemeFlat | inlinevirtual
GetHeaderClipBox(CDC *pDC, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetHeaderHeight(CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme |
GetHeaderMargin() | CXTPTabPaintManagerTheme | virtual
GetHeaderRect(CRect rcControl, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetSupportedColorSets() | CXTPTabPaintManagerTheme | inlinevirtual
m_bButtonsReverseZOrder | CXTPTabPaintManagerTheme | protected
m_nButtonHeight | CXTPTabPaintManagerTheme | protected
m_nGripperWidth | CXTPDockingPanePanelTheme2012 | protected
m_nRowMargin | CXTPTabPaintManagerTheme |
m_pPaintManager | CXTPTabPaintManagerTheme | protected
m_rcHeaderMargin | CXTPTabPaintManagerTheme |
RefreshMetrics() | CXTPDockingPanePanelTheme2012 | virtual
RepositionTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcClient) | CXTPTabPaintManagerTheme | virtual
~CXTPTabPaintManagerTheme() | CXTPTabPaintManagerTheme | virtual


Toolkit Pro: Member List

CXTPChartFunnelDiagramBase< BaseDiagram > Member List

This is the complete list of members for CXTPChartFunnelDiagramBase< BaseDiagram >, including all inherited members.

CalculateSeriesLayout(CXTPChartDeviceContext *pDC, CXTPChartDiagramView *pView) | CXTPChartFunnelDiagramBase< BaseDiagram > | virtual
CreateView(CXTPChartDeviceContext *pDC, CXTPChartElementView *pParent)=0 | CXTPChartFunnelDiagramBase< BaseDiagram > | pure virtual
CXTPChartFunnelDiagramBase() | CXTPChartFunnelDiagramBase< BaseDiagram > |


Toolkit Pro: XTPRibbonBackstageButtonThemeVisualStudio2017.h Source File

  • Source
  • Ribbon
  • Backstage
XTPRibbonBackstageButtonThemeVisualStudio2017.h
Go to the documentation of this file.
1
23#if !defined(__XTPRIBBONBACKSTAGEBUTTONTHEMEVISUALSTUDIO2017T_H__)
24# define __XTPRIBBONBACKSTAGEBUTTONTHEMEVISUALSTUDIO2017T_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class _XTP_EXT_CLASS CXTPRibbonBackstageButtonThemeVisualStudio2017
34 : public CXTPButtonThemeVisualStudio2017
35{
36public:
37 CXTPRibbonBackstageButtonThemeVisualStudio2017();
38
39public:
40 void DrawButtonBackground(CDC* pDC, CXTPButton* pButton);
41
42protected:
43 friend class CBackstageButtonCtrl;
44};
45
46# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
48#endif // !defined(__XTPRIBBONBACKSTAGEBUTTONTHEMEVISUALSTUDIO2017T_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPButton
Push Button control.
Definition XTPButton.h:109
CXTPButtonThemeOffice2013::DrawButtonBackground
virtual void DrawButtonBackground(CDC *pDC, CXTPButton *pButton)
This member function is called to draw the background for the button.
CXTPButtonThemeVisualStudio2017
CXTPButtonThemeVisualStudio2017 is a class used to perform Visual Studio 2017 theme drawing tasks.
Definition XTPButtonThemeVisualStudio2017.h:39


Toolkit Pro: Member List

CXTPClientCursorPos Member List

This is the complete list of members for CXTPClientCursorPos, including all inherited members.

CXTPClientCursorPos(CWnd *pWnd) CXTPClientCursorPos


Toolkit Pro: XTPSyntaxEditSelection.h Source File

  • Source
  • SyntaxEdit
XTPSyntaxEditSelection.h
Go to the documentation of this file.
1
23#if !defined(__XTPSYNTAXEDITSELECTION_H__)
24# define __XTPSYNTAXEDITSELECTION_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
34# ifdef _XTP_ACTIVEX
35class CXTPSyntaxEditSelPosEx_imp;
36class CXTPSyntaxEditSelPosExNormal_imp;
37# endif
47class _XTP_EXT_CLASS CXTPSyntaxEditSelection : public CXTPCmdTarget
48{
50 friend class CXTPSyntaxEditCtrl;
51 friend class CXTPSyntaxEditSelection;
52
53 DECLARE_DYNAMIC(CXTPSyntaxEditSelection)
55public:
60 CXTPSyntaxEditSelection();
61
67 CXTPSyntaxEditSelection(const CXTPSyntaxEditSelection& rSrc);
68
73 virtual ~CXTPSyntaxEditSelection();
74
87 const XTP_EDIT_LINECOL& GetStart_str() const;
88
101 const XTP_EDIT_LINECOL& GetEnd_str() const;
102
115 const XTP_EDIT_LINECOL& GetStart_disp() const;
116
129 const XTP_EDIT_LINECOL& GetEnd_disp() const;
130
142 XTP_EDIT_LINECOL GetNormalStart_str() const;
143
155 XTP_EDIT_LINECOL
156 GetNormalStart_disp() const;
157
169 XTP_EDIT_LINECOL GetNormalEnd_str() const;
170
182 XTP_EDIT_LINECOL GetNormalEnd_disp() const;
183
194 void SetStart_str(int nTextRow, int nStrPos);
195
206 void SetStart_disp(int nTextRow, int nDispCol);
207
218 void SetEnd_str(int nTextRow, int nStrPos);
219
230 void SetEnd_disp(int nTextRow, int nDispCol);
231
243 void Reset_str(int nTextRow, int nStrPos);
244
256 void Reset_disp(int nTextRow, int nDispCol);
257
265 BOOL IsWordSelectionMode() const;
266
274 BOOL IsbBlockSelectionMode() const;
275
282 BOOL IsSelExist() const;
283
290 BOOL IsSelNormal() const;
291
302 BOOL IsInSel_str(int nTextRow, int nStrPos) const;
303
312 BOOL IsInSel_disp(int nTextRow, int nDispCol) const;
313
325 BOOL IsIntersectSel_str(int nTextRow, int nStrPos1, int nStrPos2) const;
326
338 BOOL IsIntersectSel_disp(int nTextRow, int nDispCol1, int nDispCol2) const;
339
349 BOOL operator==(const CXTPSyntaxEditSelection& rSrc) const;
350
360 BOOL operator!=(const CXTPSyntaxEditSelection& rSrc) const;
361
370 const CXTPSyntaxEditSelection& operator=(const CXTPSyntaxEditSelection& rSrc);
371
373 int GetSelStartForRow_str(int nTextRow, int nDispLine);
374 int GetSelEndForRow_str(int nTextRow, int nDispLine, BOOL* pbInfinitSelEnd);
377protected:
379 BOOL _IsInSel(BOOL bStr, int nTextRow, int nColX) const;
380 BOOL _IsIntersectSel(BOOL bStr, int nTextRow, int nCol1, int nCol2) const;
383protected:
384 BOOL bSelectingRunning;
385 BOOL bWordSelectionMode;
386 BOOL bBlockSelectionMode;
387 int nSelStartTextRowFromLeftBar;
390private:
391 CXTPSyntaxEditCtrl* m_pOwnerCtrl;
392
393 XTP_EDIT_LINECOL selStart_disp;
394 XTP_EDIT_LINECOL selEnd_disp;
395
396 XTP_EDIT_LINECOL selStart_str;
397 XTP_EDIT_LINECOL selEnd_str;
398
399protected:
400# ifdef _XTP_ACTIVEX
403 DECLARE_DISPATCH_MAP()
404 DECLARE_INTERFACE_MAP()
405
406 DECLARE_OLETYPELIB_EX(CXTPSyntaxEditSelection)
407
408 LPDISPATCH OleGetStart();
409 LPDISPATCH OleGetEnd();
410 LPDISPATCH OleGetNormalStart();
411 LPDISPATCH OleGetNormalEnd();
412
413 BSTR OleGetText();
414 void OleSetText(LPCTSTR pcszSelText);
415 void OleReset();
416
417 CXTPSyntaxEditSelPosEx_imp* m_pAxStart;
418 CXTPSyntaxEditSelPosEx_imp* m_pAxEnd;
419
420 CXTPSyntaxEditSelPosExNormal_imp* m_pAxNormalStart;
421 CXTPSyntaxEditSelPosExNormal_imp* m_pAxNormalEnd;
423# endif
424};
425
426# ifdef _XTP_ACTIVEX
429class _XTP_EXT_CLASS CXTPSyntaxEditTextPosition_imp : public CXTPCmdTarget
430{
431 DECLARE_DYNAMIC(CXTPSyntaxEditTextPosition_imp)
432public:
433 CXTPSyntaxEditTextPosition_imp();
434
435 virtual long OleGetRow() = 0;
436 virtual long OleGetCol() = 0;
437 virtual long OleGetStrPos() = 0;
438
439 virtual void Ole_SetPos(long nRow, long nCol) = 0;
440 virtual void Ole_SetPosStr(long nRow, long nStrPos) = 0;
441
442 virtual void OleSetRow(long nRow)
443 {
444 Ole_SetPos(nRow, OleGetCol());
445 };
446
447 virtual void OleSetCol(long nCol)
448 {
449 Ole_SetPos(OleGetRow(), nCol);
450 };
451
452 virtual void OleSetStrPos(long nStrPos)
453 {
454 Ole_SetPosStr(OleGetRow(), nStrPos);
455 };
456
457protected:
458 DECLARE_DISPATCH_MAP()
459 DECLARE_INTERFACE_MAP()
460
461 DECLARE_OLETYPELIB_EX(CXTPSyntaxEditTextPosition_imp)
462};
463
465class _XTP_EXT_CLASS CXTPSyntaxEditSelPosEx_imp : public CXTPSyntaxEditTextPosition_imp
466{
467public:
468 CXTPSyntaxEditSelPosEx_imp(CXTPSyntaxEditSelection* pOwner, BOOL bUseStart);
469
470 virtual long OleGetRow();
471 virtual long OleGetCol();
472 virtual long OleGetStrPos();
473
474 virtual void Ole_SetPos(long nRow, long nCol);
475 virtual void Ole_SetPosStr(long nRow, long nStrPos);
476
477 void Detach()
478 {
479 m_pOwner = NULL;
480 }
481
482protected:
483 CXTPSyntaxEditSelection* m_pOwner;
484 BOOL m_bUseStart;
485};
486
488class _XTP_EXT_CLASS CXTPSyntaxEditSelPosExNormal_imp : public CXTPSyntaxEditSelPosEx_imp
489{
490public:
491 CXTPSyntaxEditSelPosExNormal_imp(CXTPSyntaxEditSelection* pOwner, BOOL bUseStart);
492
493 virtual long OleGetRow();
494 virtual long OleGetCol();
495 virtual long OleGetStrPos();
496
497 virtual void Ole_SetPos(long nRow, long nCol);
498 virtual void Ole_SetPosStr(long nRow, long nStrPos);
499};
501# endif
502
504AFX_INLINE const XTP_EDIT_LINECOL& CXTPSyntaxEditSelection::GetStart_str() const
505{
506 return selStart_str;
507}
508AFX_INLINE const XTP_EDIT_LINECOL& CXTPSyntaxEditSelection::GetEnd_str() const
509{
510 return selEnd_str;
511}
512AFX_INLINE const XTP_EDIT_LINECOL& CXTPSyntaxEditSelection::GetStart_disp() const
513{
514 return selStart_disp;
515}
516AFX_INLINE const XTP_EDIT_LINECOL& CXTPSyntaxEditSelection::GetEnd_disp() const
517{
518 return selEnd_disp;
519}
520AFX_INLINE BOOL CXTPSyntaxEditSelection::IsWordSelectionMode() const
521{
522 return bWordSelectionMode;
523}
524AFX_INLINE BOOL CXTPSyntaxEditSelection::IsbBlockSelectionMode() const
525{
526 return bBlockSelectionMode;
527}
528AFX_INLINE XTP_EDIT_LINECOL CXTPSyntaxEditSelection::GetNormalStart_str() const
529{
530 if (bBlockSelectionMode)
531 return XTP_EDIT_LINECOL::min2(selStart_str, selEnd_str);
532 return selStart_str <= selEnd_str ? selStart_str : selEnd_str;
533}
534AFX_INLINE XTP_EDIT_LINECOL CXTPSyntaxEditSelection::GetNormalEnd_str() const
535{
536 if (bBlockSelectionMode)
537 return XTP_EDIT_LINECOL::max2(selStart_str, selEnd_str);
538 return selEnd_str <= selStart_str ? selStart_str : selEnd_str;
539}
540AFX_INLINE XTP_EDIT_LINECOL CXTPSyntaxEditSelection::GetNormalStart_disp() const
541{
542 if (bBlockSelectionMode)
543 return XTP_EDIT_LINECOL::min2(selStart_disp, selEnd_disp);
544 return selStart_disp <= selEnd_disp ? selStart_disp : selEnd_disp;
545}
546AFX_INLINE XTP_EDIT_LINECOL CXTPSyntaxEditSelection::GetNormalEnd_disp() const
547{
548 if (bBlockSelectionMode)
549 return XTP_EDIT_LINECOL::max2(selStart_disp, selEnd_disp);
550 return selEnd_disp <= selStart_disp ? selStart_disp : selEnd_disp;
551}
552AFX_INLINE BOOL CXTPSyntaxEditSelection::IsSelNormal() const
553{
554 return selStart_disp <= selEnd_disp;
555}
556AFX_INLINE BOOL CXTPSyntaxEditSelection::IsInSel_str(int nTextRow, int nStrPos) const
557{
558 _ASSERTE(nStrPos >= 0);
559 return _IsInSel(TRUE, nTextRow, nStrPos);
560}
561AFX_INLINE BOOL CXTPSyntaxEditSelection::IsInSel_disp(int nTextRow, int nDispCol) const
562{
563 return _IsInSel(FALSE, nTextRow, nDispCol);
564}
565AFX_INLINE BOOL CXTPSyntaxEditSelection::IsIntersectSel_str(int nTextRow, int nStrPos1,
566 int nStrPos2) const
567{
568 return _IsIntersectSel(TRUE, nTextRow, nStrPos1, nStrPos2);
569}
570AFX_INLINE BOOL CXTPSyntaxEditSelection::IsIntersectSel_disp(int nTextRow, int nDispCol1,
571 int nDispCol2) const
572{
573 return _IsIntersectSel(FALSE, nTextRow, nDispCol1, nDispCol2);
574}
575
576# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
578#endif // !defined(__XTPSYNTAXEDITSELECTION_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPSyntaxEditCtrl
This class is the main CWnd-based editor class.
Definition XTPSyntaxEditCtrl.h:114
CXTPSyntaxEditSelection
This class is used to represent syntax edit text selection and allows for selection properties to be ...
Definition XTPSyntaxEditSelection.h:48
CXTPSyntaxEditSelection::IsbBlockSelectionMode
BOOL IsbBlockSelectionMode() const
Determines if the selection mode is 'Block' (enabled by pressing and holding Alt before selecting).
Definition XTPSyntaxEditSelection.h:524
CXTPSyntaxEditSelection::nSelStartTextRowFromLeftBar
int nSelStartTextRowFromLeftBar
Stores the start selection line for full line selecting (from the left bar).
Definition XTPSyntaxEditSelection.h:387
CXTPSyntaxEditSelection::bSelectingRunning
BOOL bSelectingRunning
Stores the 'SelectingRunning' mode.
Definition XTPSyntaxEditSelection.h:384
CXTPSyntaxEditSelection::SetEnd_disp
void SetEnd_disp(int nTextRow, int nDispCol)
Sets the selection end position.
CXTPSyntaxEditSelection::Reset_str
void Reset_str(int nTextRow, int nStrPos)
Sets the selection start and end positions.
CXTPSyntaxEditSelection::IsSelNormal
BOOL IsSelNormal() const
Determines if the selection is 'Normal' (i.e.
Definition XTPSyntaxEditSelection.h:552
CXTPSyntaxEditSelection::bBlockSelectionMode
BOOL bBlockSelectionMode
TRUE if the selection mode is 'Block', otherwise FALSE.
Definition XTPSyntaxEditSelection.h:386
CXTPSyntaxEditSelection::operator==
BOOL operator==(const CXTPSyntaxEditSelection &rSrc) const
Equality operator.
CXTPSyntaxEditSelection::GetStart_disp
const XTP_EDIT_LINECOL & GetStart_disp() const
Gets the selection start position where the column is a one-based column index on the screen.
Definition XTPSyntaxEditSelection.h:512
CXTPSyntaxEditSelection::bWordSelectionMode
BOOL bWordSelectionMode
TRUE if the selection mode is 'Word', otherwise FALSE.
Definition XTPSyntaxEditSelection.h:385
CXTPSyntaxEditSelection::CXTPSyntaxEditSelection
CXTPSyntaxEditSelection(const CXTPSyntaxEditSelection &rSrc)
Copy constructor.
CXTPSyntaxEditSelection::IsInSel_disp
BOOL IsInSel_disp(int nTextRow, int nDispCol) const
Determines if a specified position is inside the selection.
Definition XTPSyntaxEditSelection.h:561
CXTPSyntaxEditSelection::IsWordSelectionMode
BOOL IsWordSelectionMode() const
Determines if the selection mode is 'Word' (enabled by pressing and holding Ctrl before selecting).
Definition XTPSyntaxEditSelection.h:520
CXTPSyntaxEditSelection::Reset_disp
void Reset_disp(int nTextRow, int nDispCol)
Sets the selection start and end positions.
CXTPSyntaxEditSelection::CXTPSyntaxEditSelection
CXTPSyntaxEditSelection()
Default object constructor.
CXTPSyntaxEditSelection::SetStart_disp
void SetStart_disp(int nTextRow, int nDispCol)
Sets the selection start position.
CXTPSyntaxEditSelection::IsIntersectSel_str
BOOL IsIntersectSel_str(int nTextRow, int nStrPos1, int nStrPos2) const
Determines if a specified text range intersects the selection.
Definition XTPSyntaxEditSelection.h:565
CXTPSyntaxEditSelection::GetNormalEnd_str
XTP_EDIT_LINECOL GetNormalEnd_str() const
Gets the normalized selection end.
Definition XTPSyntaxEditSelection.h:534
CXTPSyntaxEditSelection::GetEnd_disp
const XTP_EDIT_LINECOL & GetEnd_disp() const
Gets the selection end position where the column is a one-based column index on the screen.
Definition XTPSyntaxEditSelection.h:516
CXTPSyntaxEditSelection::IsInSel_str
BOOL IsInSel_str(int nTextRow, int nStrPos) const
Determines if a specified position is inside the selection.
Definition XTPSyntaxEditSelection.h:556
CXTPSyntaxEditSelection::GetNormalEnd_disp
XTP_EDIT_LINECOL GetNormalEnd_disp() const
Gets the normalized selection end.
Definition XTPSyntaxEditSelection.h:546
CXTPSyntaxEditSelection::GetNormalStart_str
XTP_EDIT_LINECOL GetNormalStart_str() const
Gets the normalized selection start.
Definition XTPSyntaxEditSelection.h:528
CXTPSyntaxEditSelection::SetStart_str
void SetStart_str(int nTextRow, int nStrPos)
Sets the selection start position.
CXTPSyntaxEditSelection::IsSelExist
BOOL IsSelExist() const
Determines if the selection exists (i.e.
CXTPSyntaxEditSelection::operator!=
BOOL operator!=(const CXTPSyntaxEditSelection &rSrc) const
Non-Equality operator.
CXTPSyntaxEditSelection::~CXTPSyntaxEditSelection
virtual ~CXTPSyntaxEditSelection()
Default object destructor.
CXTPSyntaxEditSelection::GetNormalStart_disp
XTP_EDIT_LINECOL GetNormalStart_disp() const
Gets the normalized selection start.
Definition XTPSyntaxEditSelection.h:540
CXTPSyntaxEditSelection::operator=
const CXTPSyntaxEditSelection & operator=(const CXTPSyntaxEditSelection &rSrc)
Copy operator.
CXTPSyntaxEditSelection::GetStart_str
const XTP_EDIT_LINECOL & GetStart_str() const
Gets the selection start position where the column is a zero-based char index in the string.
Definition XTPSyntaxEditSelection.h:504
CXTPSyntaxEditSelection::SetEnd_str
void SetEnd_str(int nTextRow, int nStrPos)
Sets the selection end position.
CXTPSyntaxEditSelection::IsIntersectSel_disp
BOOL IsIntersectSel_disp(int nTextRow, int nDispCol1, int nDispCol2) const
Determines if a specified text range intersects the selection.
Definition XTPSyntaxEditSelection.h:570
CXTPSyntaxEditSelection::GetEnd_str
const XTP_EDIT_LINECOL & GetEnd_str() const
Gets the selection end position where the column is a zero-based char index in the string.
Definition XTPSyntaxEditSelection.h:508
XTP_EDIT_LINECOL
The XTP_EDIT_LINECOL structure represents the coordinates of text items on the displaying context in ...
Definition XTPSyntaxEditStruct.h:54
XTP_EDIT_LINECOL::max2
static const XTP_EDIT_LINECOL AFX_CDECL max2(const XTP_EDIT_LINECOL &pos1, const XTP_EDIT_LINECOL &pos2)
Gets a minimum/maximum of two XTP_EDIT_LINECOL values.
XTP_EDIT_LINECOL::min2
static const XTP_EDIT_LINECOL AFX_CDECL min2(const XTP_EDIT_LINECOL &pos1, const XTP_EDIT_LINECOL &pos2)
Gets a minimum/maximum of two XTP_EDIT_LINECOL values.


Toolkit Pro: XTPTabBase.h Source File

  • Source
  • Controls
  • Tab
XTPTabBase.h
Go to the documentation of this file.
1
23#ifndef __XTTABCTRLBASE_H__
24# define __XTTABCTRLBASE_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPTabCtrlButtons;
34class CXTPTabBaseTheme;
35
48enum XTPNavBtnState
49{
50 xtpNavBtnArrows = 1,
51 xtpNavBtnClose = 2,
52 xtpNavBtnShowAll = 3
53};
54
60class _XTP_EXT_CLASS CXTPTabBase
61{
62public:
67 CXTPTabBase();
68
73 virtual ~CXTPTabBase();
74
75public:
85 CTabCtrl* GetTabCtrlImpl();
86
96 CXTPTabCtrlButtons* GetButtons();
97
105 virtual void GetChildRect(CRect& rcChild) const;
106
123 void ShowNavButtons(DWORD dwFlags);
124
137 BOOL SetTheme(XTPControlTheme eTheme);
138
147 CXTPTabBaseTheme* GetTheme();
148
149protected:
154 virtual void RefreshMetrics();
155
163 virtual BOOL Init();
164
170 void ImplAttach(CTabCtrl* pTabCtrl);
171
178 virtual void OnAddPadding(CString& strLabelText);
179
180public:
181 bool m_bBoldFont;
182 bool m_bXPBorder;
183 BOOL m_bAutoCondensing;
185protected:
186 CTabCtrl* m_pTabCtrl;
187 CXTPTabCtrlButtons* m_pNavBtns;
188 CXTPTabBaseTheme* m_pTheme;
189 BOOL m_bSubclassed;
192 virtual void PreSubclassWindow();
193 virtual BOOL PreCreateWindow(CREATESTRUCT& cs);
197 afx_msg void OnPaint();
198 afx_msg BOOL OnEraseBkgnd(CDC* pDC);
199 afx_msg void OnSettingChange(UINT uFlags, LPCTSTR lpszSection);
200 afx_msg void OnSysColorChange();
201 afx_msg int OnCreate(LPCREATESTRUCT lpCreateStruct);
202 afx_msg LRESULT OnSetTheme(WPARAM wParam, LPARAM lParam);
204};
206AFX_INLINE CTabCtrl* CXTPTabBase::GetTabCtrlImpl()
207{
208 return m_pTabCtrl;
209}
210AFX_INLINE CXTPTabCtrlButtons* CXTPTabBase::GetButtons()
211{
212 return m_pNavBtns;
213}
214AFX_INLINE CXTPTabBaseTheme* CXTPTabBase::GetTheme()
215{
216 return m_pTheme;
217}
218
219# define DECLARE_TABCTRL_BASE(ClassName, Tab, Base) \
220 class _XTP_EXT_CLASS ClassName \
221 : public Tab \
222 , public Base \
223 { \
224 protected: \
225 virtual void PreSubclassWindow() \
226 { \
227 Tab::PreSubclassWindow(); \
228 Base::PreSubclassWindow(); \
229 } \
230 virtual BOOL PreCreateWindow(CREATESTRUCT& cs) \
231 { \
232 if (!Tab::PreCreateWindow(cs)) \
233 return FALSE; \
234 return Base::PreCreateWindow(cs); \
235 } \
236 afx_msg void OnPaint() \
237 { \
238 Base::OnPaint(); \
239 } \
240 afx_msg BOOL OnEraseBkgnd(CDC* pDC) \
241 { \
242 return Base::OnEraseBkgnd(pDC); \
243 } \
244 afx_msg void OnSettingChange(UINT uFlags, LPCTSTR lpszSection) \
245 { \
246 Base::OnSettingChange(uFlags, lpszSection); \
247 } \
248 afx_msg void OnSysColorChange() \
249 { \
250 Base::OnSysColorChange(); \
251 } \
252 afx_msg int OnCreate(LPCREATESTRUCT lpCreateStruct) \
253 { \
254 if (Tab::OnCreate(lpCreateStruct) == -1) \
255 return -1; \
256 return Base::OnCreate(lpCreateStruct); \
257 } \
258 afx_msg LRESULT OnSetTheme(WPARAM wParam, LPARAM lParam) \
259 { \
260 return Base::OnSetTheme(wParam, lParam); \
261 } \
262 };
263
264# define ON_TABCTRL_REFLECT \
265 ON_MESSAGE(WM_XTP_SETCONTROLTHEME, OnSetTheme) \
266 ON_WM_PAINT() \
267 ON_WM_ERASEBKGND() \
268 ON_WM_SETTINGCHANGE() \
269 ON_WM_SYSCOLORCHANGE() \
270 ON_WM_CREATE
278class _XTP_EXT_CLASS CXTPTabExBase : public CXTPTabBase
279{
280private:
281 struct ITEMANDWIDTH;
282
283public:
288 CXTPTabExBase();
289
294 virtual ~CXTPTabExBase();
295
296public:
305 void EnableRedraw(BOOL bRedraw);
306
312 virtual void InitializeFont();
313
323 virtual CToolTipCtrl* GetTips();
324
332 virtual void SetTips(CToolTipCtrl* pWndTip);
333
342 virtual void AddToolTip(UINT nIDTab, LPCTSTR lpszText);
343
350 virtual void UpdateToolTip(int nIDTab, LPCTSTR lpszText);
351
358 virtual void UpdateToolTip(CRuntimeClass* pViewClass, LPCTSTR lpszText);
359
365 virtual void ResetToolTips();
366
374 virtual BOOL EnableToolTipsEx(BOOL bEnable);
375
389 virtual BOOL AddView(LPCTSTR lpszLabel, CView* pView, int iIndex = -1, int iIconIndex = -1,
390 LPARAM lParam = 0);
391
407 virtual BOOL AddView(LPCTSTR lpszLabel, CRuntimeClass* pViewClass, CDocument* pDoc = NULL,
408 CCreateContext* pContext = NULL, int iIndex = -1, int iIconIndex = -1,
409 LPARAM lParam = 0);
410
425 virtual BOOL AddControl(LPCTSTR lpszLabel, CWnd* pWnd, int iIndex = -1, int iIconIndex = -1,
426 LPARAM lParam = 0);
427
436 virtual CWnd* GetView(int nView);
437
446 virtual CWnd* GetView(CRuntimeClass* pViewClass);
447
455 virtual CWnd* GetActiveView();
456
463 virtual void ActivateView(CWnd* pTabView);
464
471 virtual void SetActiveView(int nActiveTab);
472
479 virtual void SetActiveView(CWnd* pTabView);
480
487 virtual void SetActiveView(CRuntimeClass* pViewClass);
488
496 virtual void DeleteView(int nView, BOOL bDestroyWnd = TRUE);
497
505 virtual void DeleteView(CWnd* pView, BOOL bDestroyWnd = TRUE);
506
514 virtual void DeleteView(CRuntimeClass* pViewClass, BOOL bDestroyWnd = TRUE);
515
524 virtual LPCTSTR GetViewName(int nView);
525
534 virtual LPCTSTR GetViewName(CRuntimeClass* pViewClass);
535
542 virtual void RecalcLayout();
543
552 virtual BOOL Defer(HDWP& hDWP, CWnd* pView);
553
559 virtual void ResizeTabView(CWnd* pView);
560
568 virtual void RemoveListItem(POSITION pos, BOOL bDestroyWnd = TRUE);
569
578 virtual BOOL RemoveAllTabs(BOOL bDestroyWnd = TRUE);
579
590 virtual int GetTabFromPoint(CPoint point);
591
601 virtual BOOL IsChildView(CWnd* pView);
602
611 BOOL SetTabText(int nTab, LPCTSTR lpszLabel);
612
621 BOOL SetTabText(CWnd* pView, LPCTSTR lpszLabel);
622
631 BOOL SetTabText(CRuntimeClass* pViewClass, LPCTSTR lpszLabel);
632
640 CWnd* NextView();
641
649 CWnd* PrevView();
650
665 void SetAutoCondense(BOOL bEnable);
666
674 BOOL GetAutoCondense();
675
689 virtual BOOL ModifyTabStyle(DWORD dwRemove, DWORD dwAdd, UINT nFlags = 0);
690
698 CView* GetLastKnownChildView();
699
707 virtual void SetMenuID(UINT popupMenuID, int nPos = 0);
708
716 virtual UINT GetMenuID();
717
724 virtual void SendInitialUpdate(BOOL bInitialUpdate);
725
726protected:
733 virtual void OnThemeChanged();
734
742 virtual void OnSelChanging();
743
751 virtual void OnSelChange();
752
763 BOOL UpdateTabLabel(int nTab, CXTPTcbItem* pMember, LPCTSTR lpszLabel);
764
775 virtual CWnd* CreateTabView(CRuntimeClass* pViewClass, CDocument* pDocument,
776 CCreateContext* pContext);
777
788 int CalculateTabWidth(CDC* pDC, CString& sLabel, bool bHasIcon);
789
796 void Condense();
797
805 virtual BOOL Init();
806
808 virtual BOOL OnCmdMsg(UINT nID, int nCode, void* pExtra, AFX_CMDHANDLERINFO* pHandlerInfo);
809 virtual BOOL PreTranslateMessage(MSG* pMsg);
810 virtual void OnPreWindowPosChanged(WINDOWPOS FAR* lpwndpos);
811 virtual void OnPostWindowPosChanged();
815 afx_msg void OnRButtonDown(UINT nFlags, CPoint point);
816 afx_msg void OnDestroy();
817 afx_msg BOOL OnSelchange(NMHDR* pNMHDR, LRESULT* pResult);
818 afx_msg BOOL OnSelchanging(NMHDR* pNMHDR, LRESULT* pResult);
821public:
822 CList<CXTPTcbItem*, CXTPTcbItem*> m_tcbItems;
824protected:
825 int m_nPos;
826 UINT m_popupMenuID;
827 BOOL m_bInitialUpdate;
828 CWnd* m_pParentWnd;
830 CView* m_pLastActiveView;
832 CFrameWnd* m_pParentFrame;
834private:
835 int m_nOldIndex;
836};
837
839AFX_INLINE CWnd* CXTPTabExBase::GetActiveView()
840{
841 return GetView(m_pTabCtrl->GetCurSel());
842}
843AFX_INLINE CView* CXTPTabExBase::GetLastKnownChildView()
844{
845 return m_pLastActiveView;
846}
847AFX_INLINE void CXTPTabExBase::SetMenuID(UINT popupMenuID, int nPos)
848{
849 m_popupMenuID = popupMenuID;
850 m_nPos = nPos;
851}
852AFX_INLINE UINT CXTPTabExBase::GetMenuID()
853{
854 _ASSERTE(::IsWindow(m_pTabCtrl->GetSafeHwnd()));
855 return m_popupMenuID;
856}
857AFX_INLINE void CXTPTabExBase::SendInitialUpdate(BOOL bInitialUpdate)
858{
859 m_bInitialUpdate = bInitialUpdate;
860}
864class _XTP_EXT_CLASS CXTPTabCtrlBaseEx
865 : public CXTPTabExBase // CXTPTabCtrlBaseEx deprecated, use CXTPTabExBase instead (included for
866 // backward compatibility).
867{
868public:
869 virtual BOOL EnableToolTipsImpl(BOOL bEnable)
870 {
871 return CXTPTabExBase::EnableToolTipsEx(bEnable);
872 }
873
874protected:
875 void OnRButtonDownImpl(UINT nFlags, CPoint point)
876 {
877 CXTPTabExBase::OnRButtonDown(nFlags, point);
878 }
879 int OnCreateImpl_Post(LPCREATESTRUCT lpCreateStruct)
880 {
881 return CXTPTabExBase::OnCreate(lpCreateStruct);
882 }
883 void OnDestroyImpl_Pre()
884 {
885 CXTPTabExBase::OnDestroy();
886 }
887 BOOL OnSelchangeImpl(NMHDR* pNMHDR, LRESULT* pResult)
888 {
889 return CXTPTabExBase::OnSelchange(pNMHDR, pResult);
890 }
891 BOOL OnSelchangingImpl(NMHDR* pNMHDR, LRESULT* pResult)
892 {
893 return CXTPTabExBase::OnSelchanging(pNMHDR, pResult);
894 }
895 void OnWindowPosChangedImpl_Pre(WINDOWPOS FAR* lpwndpos)
896 {
897 CXTPTabExBase::OnPreWindowPosChanged(lpwndpos);
898 }
899 void OnWindowPosChangedImpl_Post(WINDOWPOS FAR*)
900 {
901 CXTPTabExBase::OnPostWindowPosChanged();
902 }
903 BOOL PreTranslateMessageImpl(MSG* pMsg)
904 {
905 return CXTPTabExBase::PreTranslateMessage(pMsg);
906 }
907 void PreSubclassWindowImpl_Post()
908 {
909 CXTPTabExBase::PreSubclassWindow();
910 }
911 BOOL OnCmdMsgImpl_Pre(UINT nID, int nCode, void* pExtra, AFX_CMDHANDLERINFO* pHandlerInfo)
912 {
913 return CXTPTabExBase::OnCmdMsg(nID, nCode, pExtra, pHandlerInfo);
914 }
915 LRESULT OnInitializeImpl(WPARAM, LPARAM)
916 {
917 _ASSERTE(0);
918 return 0;
919 }
920 void OnInitialUpdateImpl()
921 {
922 CXTPTabExBase::Init();
923 }
924};
925
926# define DECLARE_TABCTRLEX_BASE(ClassName, Tab, Base) \
927 class _XTP_EXT_CLASS ClassName \
928 : public Tab \
929 , public Base \
930 { \
931 protected: \
932 virtual void PreSubclassWindow() \
933 { \
934 Tab::PreSubclassWindow(); \
935 Base::PreSubclassWindow(); \
936 } \
937 virtual BOOL PreCreateWindow(CREATESTRUCT& cs) \
938 { \
939 if (!Tab::PreCreateWindow(cs)) \
940 return FALSE; \
941 return Base::PreCreateWindow(cs); \
942 } \
943 virtual BOOL OnCmdMsg(UINT nID, int nCode, void* pExtra, \
944 AFX_CMDHANDLERINFO* pHandlerInfo) \
945 { \
946 if (Base::OnCmdMsg(nID, nCode, pExtra, pHandlerInfo)) \
947 return TRUE; \
948 return Tab::OnCmdMsg(nID, nCode, pExtra, pHandlerInfo); \
949 } \
950 virtual BOOL PreTranslateMessage(MSG* pMsg) \
951 { \
952 if (Base::PreTranslateMessage(pMsg)) \
953 return TRUE; \
954 return Tab::PreTranslateMessage(pMsg); \
955 } \
956 afx_msg void OnPaint() \
957 { \
958 Base::OnPaint(); \
959 } \
960 afx_msg BOOL OnEraseBkgnd(CDC* pDC) \
961 { \
962 return Base::OnEraseBkgnd(pDC); \
963 } \
964 afx_msg void OnSettingChange(UINT uFlags, LPCTSTR lpszSection) \
965 { \
966 Tab::OnSettingChange(uFlags, lpszSection); \
967 Base::OnSettingChange(uFlags, lpszSection); \
968 } \
969 afx_msg void OnSysColorChange() \
970 { \
971 Tab::OnSysColorChange(); \
972 Base::OnSysColorChange(); \
973 } \
974 afx_msg int OnCreate(LPCREATESTRUCT lpCreateStruct) \
975 { \
976 if (Tab::OnCreate(lpCreateStruct) == -1) \
977 return -1; \
978 return Base::OnCreate(lpCreateStruct); \
979 } \
980 afx_msg void OnRButtonDown(UINT nFlags, CPoint point) \
981 { \
982 Base::OnRButtonDown(nFlags, point); \
983 } \
984 afx_msg void OnDestroy() \
985 { \
986 Base::OnDestroy(); \
987 Tab::OnDestroy(); \
988 } \
989 afx_msg BOOL OnSelchange(NMHDR* pNMHDR, LRESULT* pResult) \
990 { \
991 return Base::OnSelchange(pNMHDR, pResult); \
992 } \
993 afx_msg BOOL OnSelchanging(NMHDR* pNMHDR, LRESULT* pResult) \
994 { \
995 return Base::OnSelchanging(pNMHDR, pResult); \
996 } \
997 afx_msg void OnWindowPosChanged(WINDOWPOS FAR* lpwndpos) \
998 { \
999 Base::OnPreWindowPosChanged(lpwndpos); \
1000 Tab::OnWindowPosChanged(lpwndpos); \
1001 Base::OnPostWindowPosChanged(); \
1002 } \
1003 afx_msg LRESULT OnSetTheme(WPARAM wParam, LPARAM lParam) \
1004 { \
1005 return Base::OnSetTheme(wParam, lParam); \
1006 } \
1007 };
1008
1009# define ON_TABCTRLEX_REFLECT \
1010 ON_WM_CREATE() \
1011 ON_WM_DESTROY() \
1012 ON_WM_RBUTTONDOWN() \
1013 ON_WM_WINDOWPOSCHANGED() \
1014 ON_NOTIFY_REFLECT_EX(TCN_SELCHANGE, OnSelchange) \
1015 ON_NOTIFY_REFLECT_EX(TCN_SELCHANGING, OnSelchanging) \
1016 ON_TABCTRL_REFLECT
1019# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
1021#endif // __XTTABCTRLBASE_H__
XTPControlTheme
XTPControlTheme
Enumeration used to determine the active theme style.
Definition XTPControlTheme.h:43
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPNavBtnState
XTPNavBtnState
Enumeration used to determine the navigation button display for a CXTPTabCtrl object.
Definition XTPTabBase.h:49
xtpNavBtnShowAll
@ xtpNavBtnShowAll
Display arrow and close buttons.
Definition XTPTabBase.h:52
xtpNavBtnArrows
@ xtpNavBtnArrows
Display arrow buttons.
Definition XTPTabBase.h:50
xtpNavBtnClose
@ xtpNavBtnClose
Display close button.
Definition XTPTabBase.h:51
CXTPTabBase
CXTPTabBase is a standalone base class.
Definition XTPTabBase.h:61
CXTPTabBase::GetChildRect
virtual void GetChildRect(CRect &rcChild) const
This member function copies the child coordinates of the CTabCtrl client area into the object referen...
CXTPTabBase::GetTabCtrlImpl
CTabCtrl * GetTabCtrlImpl()
Retrieves a pointer to the associated tab control.
CXTPTabBase::m_bXPBorder
bool m_bXPBorder
true to draw an XP border around the tab child window.
Definition XTPTabBase.h:182
CXTPTabBase::ShowNavButtons
void ShowNavButtons(DWORD dwFlags)
Call this member function to set the visibility of the navigation buttons.
CXTPTabBase::~CXTPTabBase
virtual ~CXTPTabBase()
Destroys a CXTPTabBase object, handles cleanup and deallocation.
CXTPTabBase::m_bBoldFont
bool m_bBoldFont
true to set the selected tab font to bold.
Definition XTPTabBase.h:181
CXTPTabBase::GetTheme
CXTPTabBaseTheme * GetTheme()
Call this member function to get a pointer to the currently selected theme.
CXTPTabBase::SetTheme
BOOL SetTheme(XTPControlTheme eTheme)
Call this member to switch the visual theme of the control.
CXTPTabBase::Init
virtual BOOL Init()
This member function is called by the CXTPTabBase class to perform initialization when the window is ...
CXTPTabBase::m_pNavBtns
CXTPTabCtrlButtons * m_pNavBtns
Arrow buttons.
Definition XTPTabBase.h:187
CXTPTabBase::m_pTheme
CXTPTabBaseTheme * m_pTheme
Pointer to the current theme object.
Definition XTPTabBase.h:188
CXTPTabBase::ImplAttach
void ImplAttach(CTabCtrl *pTabCtrl)
Call this member function to associate the tab control with this object.
CXTPTabBase::m_bSubclassed
BOOL m_bSubclassed
TRUE if the window was sub-classed.
Definition XTPTabBase.h:189
CXTPTabBase::OnAddPadding
virtual void OnAddPadding(CString &strLabelText)
This member function is called by the tab control to add padding to a tab label for use with XP style...
CXTPTabBase::m_pTabCtrl
CTabCtrl * m_pTabCtrl
Pointer to the tab control associated with this object.
Definition XTPTabBase.h:186
CXTPTabBase::RefreshMetrics
virtual void RefreshMetrics()
Call this member function to refresh theme colors and redraw the control.
CXTPTabBase::m_bAutoCondensing
BOOL m_bAutoCondensing
TRUE for auto-condensing tabs.
Definition XTPTabBase.h:183
CXTPTabBase::GetButtons
CXTPTabCtrlButtons * GetButtons()
Retrieves a pointer to the tab control navigation button object.
CXTPTabBase::CXTPTabBase
CXTPTabBase()
Constructs a CXTPTabBase object.
CXTPTabBaseTheme
CXTPTabBaseTheme is used to draw the CXTPTabBase object.
Definition XTPTabBaseTheme.h:46
CXTPTabCtrlButtons
CXTPTabCtrlButtons is a CWnd derived class.
Definition XTPTabCtrlButtons.h:90
CXTPTabExBase
CXTPTabExBase is a standalone base class.
Definition XTPTabBase.h:279
CXTPTabExBase::SetActiveView
virtual void SetActiveView(int nActiveTab)
This member function will set a view active based on the specified runtime class.
CXTPTabExBase::PrevView
CWnd * PrevView()
This member function is called to activate the previous view in the tab control.
CXTPTabExBase::DeleteView
virtual void DeleteView(int nView, BOOL bDestroyWnd=TRUE)
This member function will remove a view based on the specified tab index.
CXTPTabExBase::OnThemeChanged
virtual void OnThemeChanged()
This member function is called whenever the theme has changed.
CXTPTabExBase::GetTabFromPoint
virtual int GetTabFromPoint(CPoint point)
Call this member function to retrieve the tab index from the current cursor position.
CXTPTabExBase::DeleteView
virtual void DeleteView(CRuntimeClass *pViewClass, BOOL bDestroyWnd=TRUE)
This member function will remove a view based on the specified tab index.
CXTPTabExBase::EnableToolTipsEx
virtual BOOL EnableToolTipsEx(BOOL bEnable)
Call this member function to enable/disable tooltip usage.
CXTPTabExBase::GetTips
virtual CToolTipCtrl * GetTips()
This member function retrieves the handle of the tooltip control associated with the tab control.
CXTPTabExBase::GetView
virtual CWnd * GetView(int nView)
This member function retrieves a pointer to a view from the specified runtime class.
CXTPTabExBase::RecalcLayout
virtual void RecalcLayout()
This member function is called when the tab control is resized.
CXTPTabExBase::UpdateToolTip
virtual void UpdateToolTip(int nIDTab, LPCTSTR lpszText)
Call this function to update the tooltip text for the specified tab.
CXTPTabExBase::CreateTabView
virtual CWnd * CreateTabView(CRuntimeClass *pViewClass, CDocument *pDocument, CCreateContext *pContext)
This member function creates the CWnd object that is associated with a tab control item.
CXTPTabExBase::OnSelChanging
virtual void OnSelChanging()
Override this member function to handle a TCN_SELCHANGING event in your derived class to provide addi...
CXTPTabExBase::SetTips
virtual void SetTips(CToolTipCtrl *pWndTip)
Call this function to assign a tooltip control to the tab control.
CXTPTabExBase::UpdateToolTip
virtual void UpdateToolTip(CRuntimeClass *pViewClass, LPCTSTR lpszText)
Call this function to update the tooltip text for the specified tab.
CXTPTabExBase::ResetToolTips
virtual void ResetToolTips()
This member function is called to reset the values for the tooltip control based upon the information...
CXTPTabExBase::Condense
void Condense()
This member function is used internally by the tab control to shrink, or un-shrink,...
CXTPTabExBase::m_pParentWnd
CWnd * m_pParentWnd
Pointer to the parent and will equal 'm_pParentFrame' in non-dialog applications.
Definition XTPTabBase.h:828
CXTPTabExBase::OnSelChange
virtual void OnSelChange()
Override this member function to handle a TCN_SELCHANGE event in your derived class to provide additi...
CXTPTabExBase::GetViewName
virtual LPCTSTR GetViewName(CRuntimeClass *pViewClass)
This member function will return the name for a view based on the tab index.
CXTPTabExBase::GetLastKnownChildView
CView * GetLastKnownChildView()
This member function is used to get the last known view that belongs to the frame.
CXTPTabExBase::m_nPos
int m_nPos
Index of the pop-up menu contained in the menu.
Definition XTPTabBase.h:825
CXTPTabExBase::m_pParentFrame
CFrameWnd * m_pParentFrame
Pointer to the parent frame.
Definition XTPTabBase.h:832
CXTPTabExBase::AddView
virtual BOOL AddView(LPCTSTR lpszLabel, CRuntimeClass *pViewClass, CDocument *pDoc=NULL, CCreateContext *pContext=NULL, int iIndex=-1, int iIconIndex=-1, LPARAM lParam=0)
Call this member function to add a view to the tab control associated with this view.
CXTPTabExBase::AddToolTip
virtual void AddToolTip(UINT nIDTab, LPCTSTR lpszText)
Call this function to register a tab with the tooltip control so that the information stored in the t...
CXTPTabExBase::SetTabText
BOOL SetTabText(CRuntimeClass *pViewClass, LPCTSTR lpszLabel)
Call this member function to set the text for the specified tab.
CXTPTabExBase::SendInitialUpdate
virtual void SendInitialUpdate(BOOL bInitialUpdate)
Call this member function to allow a WM_INITIALUPATE message to be sent to views after creation.
CXTPTabExBase::Init
virtual BOOL Init()
This member function is called by the CXTPTabExBase class to perform initialization when the window i...
CXTPTabExBase::m_pLastActiveView
CView * m_pLastActiveView
Pointer to the last active view that belongs to the main frame window.
Definition XTPTabBase.h:830
CXTPTabExBase::SetAutoCondense
void SetAutoCondense(BOOL bEnable)
Call this member function to enable/disable the tab auto-condensing mode.
CXTPTabExBase::GetViewName
virtual LPCTSTR GetViewName(int nView)
This member function will return the name for a view based on the tab index.
CXTPTabExBase::AddControl
virtual BOOL AddControl(LPCTSTR lpszLabel, CWnd *pWnd, int iIndex=-1, int iIconIndex=-1, LPARAM lParam=0)
This member function is called to add a control to the tab control associated with this view.
CXTPTabExBase::GetAutoCondense
BOOL GetAutoCondense()
This member function returns the state of the tab control's auto-condense mode.
CXTPTabExBase::Defer
virtual BOOL Defer(HDWP &hDWP, CWnd *pView)
Helper methods.
CXTPTabExBase::UpdateTabLabel
BOOL UpdateTabLabel(int nTab, CXTPTcbItem *pMember, LPCTSTR lpszLabel)
This member function is called to set the tooltip and tab text for the specified tab.
CXTPTabExBase::~CXTPTabExBase
virtual ~CXTPTabExBase()
Destroys a CXTPTabExBase object, handles cleanup and deallocation.
CXTPTabExBase::GetView
virtual CWnd * GetView(CRuntimeClass *pViewClass)
This member function retrieves a pointer to a view from the specified runtime class.
CXTPTabExBase::m_tcbItems
CList< CXTPTcbItem *, CXTPTcbItem * > m_tcbItems
Template list containing tab information.
Definition XTPTabBase.h:822
CXTPTabExBase::ResizeTabView
virtual void ResizeTabView(CWnd *pView)
Call this member function to resize the tab view specified by 'pView'.
CXTPTabExBase::SetTabText
BOOL SetTabText(int nTab, LPCTSTR lpszLabel)
Call this member function to set the text for the specified tab.
CXTPTabExBase::m_bInitialUpdate
BOOL m_bInitialUpdate
TRUE to send initial update to views when created.
Definition XTPTabBase.h:827
CXTPTabExBase::CalculateTabWidth
int CalculateTabWidth(CDC *pDC, CString &sLabel, bool bHasIcon)
This member function is used internally by the tab control to calculate the width of a tab based on i...
CXTPTabExBase::EnableRedraw
void EnableRedraw(BOOL bRedraw)
Call this member function to enable/disable the control from being redrawn or updated.
CXTPTabExBase::SetTabText
BOOL SetTabText(CWnd *pView, LPCTSTR lpszLabel)
Call this member function to set the text for the specified tab.
CXTPTabExBase::m_popupMenuID
UINT m_popupMenuID
Pop-up menu resource ID.
Definition XTPTabBase.h:826
CXTPTabExBase::SetMenuID
virtual void SetMenuID(UINT popupMenuID, int nPos=0)
This member function is used to set the resource ID for the pop-up menu used by the tab control.
CXTPTabExBase::DeleteView
virtual void DeleteView(CWnd *pView, BOOL bDestroyWnd=TRUE)
This member function will remove a view based on the specified tab index.
CXTPTabExBase::AddView
virtual BOOL AddView(LPCTSTR lpszLabel, CView *pView, int iIndex=-1, int iIconIndex=-1, LPARAM lParam=0)
Call this member function to add a view to the tab control associated with this view.
CXTPTabExBase::ModifyTabStyle
virtual BOOL ModifyTabStyle(DWORD dwRemove, DWORD dwAdd, UINT nFlags=0)
This member function will modify the style for the tab control associated with this view and set the ...
CXTPTabExBase::IsChildView
virtual BOOL IsChildView(CWnd *pView)
Call this member function to see if the specified CWnd object is a child of the tab control.
CXTPTabExBase::NextView
CWnd * NextView()
This member function is called to activate the next view in the tab control.
CXTPTabExBase::InitializeFont
virtual void InitializeFont()
This member function is called to initialize the font for the tab control associated with this view.
CXTPTabExBase::GetMenuID
virtual UINT GetMenuID()
This member function returns the menu resource associated with the tab control.
CXTPTabExBase::GetActiveView
virtual CWnd * GetActiveView()
This member function retrieves a pointer to the active view associated with the selected tab.
CXTPTabExBase::CXTPTabExBase
CXTPTabExBase()
Constructs a CXTPTabExBase object.
CXTPTabExBase::SetActiveView
virtual void SetActiveView(CWnd *pTabView)
This member function will set a view active based on the specified runtime class.
CXTPTabExBase::SetActiveView
virtual void SetActiveView(CRuntimeClass *pViewClass)
This member function will set a view active based on the specified runtime class.
CXTPTabExBase::RemoveAllTabs
virtual BOOL RemoveAllTabs(BOOL bDestroyWnd=TRUE)
Call this member function to remove all tabs, including all associated views.
CXTPTabExBase::RemoveListItem
virtual void RemoveListItem(POSITION pos, BOOL bDestroyWnd=TRUE)
This member function is used by the tab control bar to remove an item from the tab view list.
CXTPTabExBase::ActivateView
virtual void ActivateView(CWnd *pTabView)
This member function is called to activate the specified view and deactivate all remaining views.
CXTPTcbItem
The CXTPTcbItem class is used to maintain information for a particular tab item in a CXTPExcelTabCtrl...
Definition XTPGlobal.h:41


Toolkit Pro: Member List

CXTPTrackPaintManager Member List

This is the complete list of members for CXTPTrackPaintManager, including all inherited members.

CalcColumnHeight(CDC *pDC, CXTPGridColumn *pColumn, int nTotalWidth=0) | CXTPGridPaintManager | protectedvirtual
CalculateRowHeight(CDC *pDC, const CString &strText, int nMaxWidth, BOOL bWordBreak=TRUE) | CXTPGridPaintManager | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPGridPaintManager() | CXTPGridPaintManager |
CXTPTrackPaintManager() | CXTPTrackPaintManager |
DrawBitmap(CDC *pDC, CXTPGridControl *pControl, CRect rcColumn, int iImage) | CXTPGridPaintManager | virtual
DrawCollapsedBitmap(CDC *pDC, const CXTPGridRow *pRow, CRect &rcBitmap) | CXTPGridPaintManager | virtual
DrawColumn(CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn, BOOL bDrawExternal=FALSE, int nShadowWidth=0) | CXTPGridPaintManager | virtual
DrawColumnBackground(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, BOOL &bColumnPressed, BOOL &bDraggingFromHeader, CXTPGridHeader *pHeader=NULL) | CXTPGridPaintManager | protectedvirtual
DrawColumnFooter(CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn) | CXTPGridPaintManager | virtual
DrawColumnFooterDivider(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn) | CXTPGridPaintManager | virtual
DrawColumnIcon(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, CRect rcIcon, int iIcon) | CXTPGridPaintManager | virtual
DrawColumnText(CDC *pDC, CRect rcText, CString strCaption, int nHeaderAlignment, BOOL bIsHeader, BOOL bColumnPressed) | CXTPGridPaintManager | virtual
DrawConnector(CDC *pDC, CPoint ptFrom, CPoint ptTo) | CXTPGridPaintManager |
DrawFocusedRow(CDC *pDC, CRect rcRow) | CXTPGridPaintManager | virtual
DrawFreezeColsDivider(CDC *pDC, const CRect &rc, CXTPGridControl *pControl, CXTPGridRow *pRow=NULL) | CXTPGridPaintManager | virtual
DrawGlyph(CDC *pDC, CRect rcColumn, int iImage) | CXTPGridPaintManager | virtual
DrawGrid(CDC *pDC, XTPGridOrientation orientation, CRect rcGrid) | CXTPGridPaintManager | virtual
DrawGridPattern(CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush) | CXTPGridPaintManager | protectedvirtual
DrawGridPattern(CDC *pDC, CXTPBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush) | CXTPGridPaintManager | protectedvirtual
DrawGridPattern(CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr) | CXTPGridPaintManager | protectedvirtual
DrawGroupRow(CDC *pDC, CXTPGridGroupRow *pRow, CRect rcRow, XTP_GRIDRECORDITEM_METRICS *pMetrics) | CXTPGridPaintManager | virtual
DrawHorizontalLine(CDC *pDC, int xPos, int yPos, int cx, COLORREF clr) | CXTPGridPaintManager |
DrawInplaceButton(CDC *pDC, CXTPGridInplaceButton *pButton) | CXTPGridPaintManager | virtual
DrawInplaceButtonFrame(CDC *pDC, CXTPGridInplaceButton *pButton) | CXTPGridPaintManager | protectedvirtual
DrawInplaceButtonIcon(CDC *pDC, CXTPGridInplaceButton *pButton) | CXTPGridPaintManager | protectedvirtual
DrawInplaceComboButton(CDC *pDC, CRect *pRc) | CXTPGridPaintManager | virtual
DrawInplaceExpandButton(CDC *pDC, CRect *pRc) | CXTPGridPaintManager | virtual
DrawInplaceSpinButton(CDC *pDC, CRect *pRc) | CXTPGridPaintManager | virtual
DrawItemBitmap(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CRect &rcItem, int nImage) | CXTPGridPaintManager | virtual
DrawItemCaption(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics) | CXTPGridPaintManager | virtual
DrawItemControl(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CXTPGridRecordItemControl *pControl, CRect &rcItem) | CXTPGridPaintManager | virtual
DrawLink(int *pnCurrDrawPos, XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CXTPGridHyperlink *pHyperlink, CString strText, CRect rcLink, int nFlag, BOOL bTrim=FALSE) | CXTPGridPaintManager | protectedvirtual
DrawMarkers(CDC *pDC) | CXTPTrackPaintManager | virtual
DrawMultiLineText(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, BOOL bWordBreak=TRUE) | CXTPGridPaintManager | protectedvirtual
DrawNoGroupByText(CDC *pDC, CRect rcItem) | CXTPGridPaintManager | virtual
DrawRowNumber(CDC *pDC, CRect rcNumber, CXTPGridRow *pRow) | CXTPGridPaintManager | virtual
DrawSectionDivider(CDC *pDC, const CRect &rc, XTPGridSectionDividerPosition dividerPosition, XTPGridSectionDividerStyle dividerStyle, CXTPPaintManagerColor dividerColor) | CXTPGridPaintManager |
DrawShellIcon(CDC *pDC, CRect rcColumn, int iImage) | CXTPGridPaintManager | virtual
DrawSingleLineText(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nStartPos, int nEndPos, int nActualWidth) | CXTPGridPaintManager | protectedvirtual
DrawString(int *pnCurrDrawPos, CDC *pDC, const CString &strDraw, CRect rcDraw, UINT nFormat) | CXTPGridPaintManager | protectedvirtual
DrawTextLine(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nFlag, int &nCharCounter, int &nHyperlinkCounter) | CXTPGridPaintManager | protectedvirtual
DrawTimeLine(CDC *pDC) | CXTPTrackPaintManager | virtual
DrawTrackHeader(CDC *pDC) | CXTPTrackPaintManager | virtual
DrawTreeStructure(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CRect rcItem, CSize sizeGlyph) | CXTPGridPaintManager | virtual
DrawTriangle(CDC *pDC, CRect rcTriangle, BOOL bToDown, BOOL bDraggingFromHeader, int nShadowWidth, BOOL bColumnPressed) | CXTPGridPaintManager | virtual
DrawVerticalLine(CDC *pDC, int xPos, int yPos, int cy, COLORREF clr) | CXTPGridPaintManager |
DrawVerticalTimeLineMarker(CDC *pDC, int xPos, CXTPGridControl *pControl, COLORREF color=RGB(0, 255, 0)) | CXTPGridPaintManager | virtual
EnablePreviewMode(BOOL bIsPreviewMode) | CXTPGridPaintManager |
FillFooter(CDC *pDC, CRect rcFooter) | CXTPGridPaintManager | virtual
FillGroupByControl(CDC *pDC, CRect &rcGroupBy) | CXTPGridPaintManager | virtual
FillGroupRowMetrics(CXTPGridGroupRow *pRow, XTP_GRIDRECORDITEM_METRICS *pMetrics, BOOL bPrinting) | CXTPGridPaintManager | virtual
FillHeaderControl(CDC *pDC, CRect rcHeader) | CXTPGridPaintManager | virtual
FillIndent(CDC *pDC, CRect rcRow) | CXTPGridPaintManager | virtual
FillItemShade(CDC *pDC, CRect rcItem) | CXTPGridPaintManager | virtual
FillRow(CDC *pDC, CXTPGridRow *pRow, CRect rcRow) | CXTPGridPaintManager | virtual
FindRowAdjacentToMerged(const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, BOOL bUpward) | CXTPGridPaintManager |
FindRowAdjacentToMergedEx(const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, int &nAdjRowIndex, BOOL bUpward) | CXTPGridPaintManager |
FormatTime(int nPosition) | CXTPTrackPaintManager | virtual
FormatTimeLineTick(int nPosition, COLORREF &clrTick, int &nTickLength) | CXTPTrackPaintManager | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetColumnOffice2007CustomThemeBaseColor() const | CXTPGridPaintManager |
GetColumnStyle() const | CXTPGridPaintManager |
GetControlBackColor(CXTPGridControl *pControl) | CXTPGridPaintManager | virtual
GetFooterHeight(CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0) | CXTPGridPaintManager | virtual
GetFreezeColsDividerStyle() const | CXTPGridPaintManager |
GetGlyphs() const | CXTPGridPaintManager |
GetHeaderHeight() | CXTPGridPaintManager | virtual
GetHeaderHeight(CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0) | CXTPGridPaintManager | virtual
GetItemHeight(XTP_GRIDRECORDITEM_DRAWARGS &drawArgs, int nWidth) | CXTPGridPaintManager |
GetMaxPreviewLines() | CXTPGridPaintManager |
GetPreviewItemHeight(CDC *pDC, CXTPGridRow *pRow, int nWidth, int nHeight) | CXTPGridPaintManager | virtual
GetPreviewLinesCount(CDC *pDC, CRect &rcText, const CString &strText) | CXTPGridPaintManager |
GetRowHeight(CDC *pDC, CXTPGridRow *pRow) | CXTPGridPaintManager | virtual
GetRowHeight(CDC *pDC, CXTPGridRow *pRow, int nTotalWidth) | CXTPGridPaintManager | virtual
GetRowHeightEx(CDC *pDC, CXTPGridRow *pRow, int nTotalWidth, const BOOL firstLevel=TRUE) | CXTPGridPaintManager |
GetSectionDividerHeight(XTPGridFixedRowsDividerStyle dividerStyle) | CXTPGridPaintManager |
GetTextFont() | CXTPGridPaintManager |
IsColumHotTrackingEnabled() const | CXTPGridPaintManager | virtual
IsColumnPlusMinusSign() const | CXTPGridPaintManager |
IsColumnWidthWYSIWYG() const | CXTPGridPaintManager |
IsDrawGridForEmptySpace() const | CXTPGridPaintManager |
IsFixedInplaceButtonHeight() const | CXTPGridPaintManager |
IsFixedRowHeight() const | CXTPGridPaintManager |
IsGridVisible(BOOL bVertical) const | CXTPGridPaintManager |
IsGridVisible(XTPGridOrientation orientation) const | CXTPGridPaintManager |
IsLastColumnWidthWYSIWYG() const | CXTPGridPaintManager |
IsPreviewMode() const | CXTPGridPaintManager |
IsPrintGroupRowIcon() const | CXTPGridPaintManager |
IsShowWYSIWYGMarkers() const | CXTPGridPaintManager |
IsUseDropMarker() const | CXTPGridPaintManager |
LoadGlyphs() | CXTPGridPaintManager | virtual
m_arStartCol | CXTPGridPaintManager |
m_bAllowMergeCells | CXTPGridPaintManager |
m_bBaseTreeIndent | CXTPGridPaintManager |
m_bCleanTooltip | CXTPGridPaintManager |
m_bColumnPlusMinusSign | CXTPGridPaintManager | protected
m_bColumnWidthWYSIWYG | CXTPGridPaintManager | protected
m_bCompactText | CXTPGridPaintManager |
m_bDrawGridForEmptySpace | CXTPGridPaintManager | protected
m_bFixedInplaceButtonHeight | CXTPGridPaintManager | protected
m_bFixedRowHeight | CXTPGridPaintManager | protected
m_bForceDynamicMarkupForCell | CXTPGridPaintManager |
m_bForceShowDropMarker | CXTPGridPaintManager |
m_bForceShowTooltip | CXTPGridPaintManager |
m_bGrayIfDisable | CXTPGridPaintManager |
m_bGroupRowTextBold | CXTPGridPaintManager |
m_bHideSelection | CXTPGridPaintManager |
m_bHotTracking | CXTPGridPaintManager |
m_bInvertColumnOnClick | CXTPGridPaintManager |
m_bIsPreviewMode | CXTPGridPaintManager | protected
m_bLastColumnWidthWYSIWYG | CXTPGridPaintManager | protected
m_bMakeUpper | CXTPGridPaintManager |
m_bMoveScrollbarOnFixedColumnsIndent | CXTPGridPaintManager |
m_bPrintGroupRowIcon | CXTPGridPaintManager | protected
m_bPrintPageRectangle | CXTPGridPaintManager |
m_bPrintSortTriangle | CXTPGridPaintManager |
m_bPrintVirtualPageNumber | CXTPGridPaintManager |
m_bPrintWatermark | CXTPGridPaintManager |
m_bRecOrRowNum | CXTPGridPaintManager |
m_bRevertAlignment | CXTPGridPaintManager |
m_bShadeGroupHeadings | CXTPGridPaintManager |
m_bShadeSortColumn | CXTPGridPaintManager |
m_bShowLockIcon | CXTPGridPaintManager |
m_bShowNonActiveInPlaceButton | CXTPGridPaintManager |
m_bShowWYSIWYGMarkers | CXTPGridPaintManager | protected
m_bSortTriangleOffsetFromRight | CXTPGridPaintManager |
m_bThemedInplaceButtons | CXTPGridPaintManager |
m_bUseAlternativeBackground | CXTPGridPaintManager |
m_bUseDropMarker | CXTPGridPaintManager |
m_bUseEditTextAlignment | CXTPGridPaintManager |
m_bUseGroupRowSelectionState | CXTPGridPaintManager |
m_bUseShellIcon | CXTPGridPaintManager |
m_clrAlternativeBackground | CXTPGridPaintManager |
m_clrBoldText | CXTPGridPaintManager |
m_clrBoldTextHighlight | CXTPGridPaintManager |
m_clrBtnFace | CXTPGridPaintManager |
m_clrBtnFacePressed | CXTPGridPaintManager |
m_clrBtnText | CXTPGridPaintManager |
m_clrCaptionText | CXTPGridPaintManager |
m_clrCaptionTextPressed | CXTPGridPaintManager |
m_clrColumnOffice2007CustomTheme | CXTPGridPaintManager |
m_clrConnector | CXTPGridPaintManager |
m_clrControlBack | CXTPGridPaintManager |
m_clrControlDark | CXTPGridPaintManager |
m_clrControlLightLight | CXTPGridPaintManager |
m_clrDisableBitmapDarkest | CXTPGridPaintManager |
m_clrDisableBitmapLightest | CXTPGridPaintManager |
m_clrFormulaSubSum | CXTPGridPaintManager |
m_clrFormulaSum | CXTPGridPaintManager |
m_clrFreezeColsDivider | CXTPGridPaintManager |
m_clrGradientColumnSeparator | CXTPGridPaintManager |
m_clrGradientColumnShadow | CXTPGridPaintManager |
m_clrGroupBoxBack | CXTPGridPaintManager |
m_clrGroupRowText | CXTPGridPaintManager |
m_clrGroupShadeBack | CXTPGridPaintManager |
m_clrGroupShadeBorder | CXTPGridPaintManager |
m_clrGroupShadeText | CXTPGridPaintManager |
m_clrHeaderControl | CXTPGridPaintManager |
m_clrHighlight | CXTPGridPaintManager |
m_clrHighlightText | CXTPGridPaintManager |
m_clrHotDivider | CXTPGridPaintManager |
m_clrIndentControl | CXTPGridPaintManager |
m_clrItemShade | CXTPGridPaintManager |
m_clrMarker | CXTPTrackPaintManager |
m_clrMarkerBack | CXTPTrackPaintManager |
m_clrMarkerBorder | CXTPTrackPaintManager |
m_clrPreviewText | CXTPGridPaintManager |
m_clrScrollBarBorderDark | CXTPTrackPaintManager |
m_clrScrollBarBorderLight | CXTPTrackPaintManager |
m_clrScrollBarDark | CXTPTrackPaintManager |
m_clrScrollBarLight | CXTPTrackPaintManager |
m_clrSelectedArea | CXTPTrackPaintManager |
m_clrSelectedRow | CXTPGridPaintManager |
m_clrSelectedRowText | CXTPGridPaintManager |
m_clrTimeHeaderBorder | CXTPTrackPaintManager |
m_clrTimeHeaderDark | CXTPTrackPaintManager |
m_clrTimeHeaderDarkDark | CXTPTrackPaintManager |
m_clrTimeHeaderDivider | CXTPTrackPaintManager |
m_clrTimeLinePosition | CXTPTrackPaintManager |
m_clrTimeLineTick | CXTPTrackPaintManager |
m_clrTimeSliderBackground | CXTPTrackPaintManager |
m_clrTrackHeader | CXTPTrackPaintManager |
m_clrTrackMarkerBorder | CXTPTrackPaintManager |
m_clrTrackMarkerText | CXTPTrackPaintManager |
m_clrTrackMarkerTextBack | CXTPTrackPaintManager |
m_clrTrackMarkerTextBorder | CXTPTrackPaintManager |
m_clrTrackTimeArea | CXTPTrackPaintManager |
m_clrWindowText | CXTPGridPaintManager |
m_clrWorkArea | CXTPTrackPaintManager |
m_clrWorkAreaScrollBarBorder | CXTPTrackPaintManager |
m_clrWorkAreaScrollBarDark | CXTPTrackPaintManager |
m_clrWorkAreaScrollBarLight | CXTPTrackPaintManager |
m_columnStyle | CXTPGridPaintManager | protected
m_crlNoGroupByText | CXTPGridPaintManager |
m_grcGradientColumn | CXTPGridPaintManager |
m_grcGradientColumnHot | CXTPGridPaintManager |
m_grcGradientColumnPushed | CXTPGridPaintManager |
m_iRecOrRowStart | CXTPGridPaintManager |
m_nBaseParentRecordIndent | CXTPGridPaintManager |
m_nFixedColumnsIndent | CXTPGridPaintManager |
m_nFooterHeight | CXTPGridPaintManager | protected
m_nFreezeColsDividerStyle | CXTPGridPaintManager | protected
m_nGridLineStylePreviousH | CXTPGridPaintManager | protected
m_nGridLineStylePreviousV | CXTPGridPaintManager | protected
m_nGroupGridLineHeight | CXTPGridPaintManager | protected
m_nGroupGridLineStyle | CXTPGridPaintManager | protected
m_nHeaderHeight | CXTPGridPaintManager | protected
m_nMaxPreviewLines | CXTPGridPaintManager | protected
m_nResizingWidth | CXTPGridPaintManager | protected
m_nRowHeight | CXTPGridPaintManager | protected
m_nRowHeightDefault | CXTPGridPaintManager |
m_nTextIndentForGroupRowsWithNoIcon | CXTPGridPaintManager |
m_nTreeColumnLineLength | CXTPGridPaintManager |
m_nTreeIndent | CXTPGridPaintManager |
m_nTreeStructureStyle | CXTPGridPaintManager |
m_nTreeTextIndent | CXTPGridPaintManager |
m_nTreeTextIndentGroupRow | CXTPGridPaintManager |
m_nTreeTextIndentRowChildren | CXTPGridPaintManager |
m_nTreeTextIndentRowParent | CXTPGridPaintManager |
m_pControl | CXTPGridPaintManager | protected
m_pGlyphs | CXTPGridPaintManager | protected
m_pHyperlinkHoverStyle | CXTPGridPaintManager |
m_pHyperlinkStyle | CXTPGridPaintManager |
m_pMarkupUIElement_NoGroupBy | CXTPGridPaintManager | protected
m_PrintPageWidth | CXTPGridPaintManager |
m_rcPreviewIndent | CXTPGridPaintManager |
m_RecordNumberWidth | CXTPGridPaintManager |
m_strCollapse | CXTPGridPaintManager |
m_strDecreasing | CXTPGridPaintManager |
m_strExpand | CXTPGridPaintManager |
m_strIncreasing | CXTPGridPaintManager |
m_strMarkupUIElement_NoGroupBy | CXTPGridPaintManager | protected
m_strNoFieldsAvailable | CXTPGridPaintManager |
m_strNoGroupBy | CXTPGridPaintManager |
m_strNoItems | CXTPGridPaintManager |
m_strSortBy | CXTPGridPaintManager |
m_szGlyph | CXTPGridPaintManager | protected
m_themeButton | CXTPGridPaintManager | protected
m_themeCombo | CXTPGridPaintManager | protected
m_themeHeader | CXTPGridPaintManager | protected
m_themeSpin | CXTPGridPaintManager | protected
m_treeStructureStyle | CXTPGridPaintManager |
m_xtpBrushGroupGridLineStyle | CXTPGridPaintManager | protected
m_xtpBrushHorizontalGrid | CXTPGridPaintManager | protected
m_xtpBrushTreeStructure | CXTPGridPaintManager | protected
m_xtpBrushVeriticalGrid | CXTPGridPaintManager | protected
m_xtpFontBoldText | CXTPGridPaintManager |
m_xtpFontCaption | CXTPGridPaintManager |
m_xtpFontPreview | CXTPGridPaintManager |
m_xtpFontText | CXTPGridPaintManager |
OnDrawAction(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs) | CXTPGridPaintManager | virtual
RecalcTotalHightOfMergedRows(CXTPGridColumns *pColumns, CDC *pDC, CXTPGridRow *pRow, int nRowHeight, int nTotalWidth) | CXTPGridPaintManager |
RefreshMetrics() | CXTPTrackPaintManager | virtual
SetCaptionFont(LOGFONT &lf) | CXTPGridPaintManager |
SetColumnOffice2007CustomThemeBaseColor(COLORREF clrBaseColor) | CXTPGridPaintManager |
SetColumnPlusMinusSign(BOOL bDraw) | CXTPGridPaintManager |
SetColumnWidthWYSIWYG(BOOL bColumnWidthWYSIWYG) | CXTPGridPaintManager |
SetDrawGridForEmptySpace(BOOL bDrawGrid) | CXTPGridPaintManager |
SetFixedRowHeight(BOOL bFixedRowHeight) | CXTPGridPaintManager |
SetFreezeColsDividerStyle(int nStyle) | CXTPGridPaintManager |
SetGridControl(CXTPGridControl *pControl) | CXTPGridPaintManager | virtual
SetHeaderHeight(int nHeight) | CXTPGridPaintManager | virtual
SetInplaceButtonHeight(BOOL bFixedInplaceButtonHeight) | CXTPGridPaintManager |
SetLastColumnWidthWYSIWYG(BOOL bColumnWidthWYSIWYG) | CXTPGridPaintManager |
SetMaxPreviewLines(int nMaxLines) | CXTPGridPaintManager |
SetPreviewIndent(int nLeft, int nTop, int nRight, int nBottom) | CXTPGridPaintManager |
SetPrintGroupRowIcon(BOOL bDraw) | CXTPGridPaintManager |
SetTextFont(LOGFONT &lf) | CXTPGridPaintManager |
ShowWYSIWYGMarkers(BOOL bSet) | CXTPGridPaintManager |
~CXTPGridPaintManager() | CXTPGridPaintManager | virtual
~CXTPTrackPaintManager() | CXTPTrackPaintManager |


Toolkit Pro: Member List

XTP_NM_GRIDREQUESTEDIT Member List

This is the complete list of members for XTP_NM_GRIDREQUESTEDIT, including all inherited members.

bCancel | XTP_NM_GRIDREQUESTEDIT
hdr | XTP_NM_GRIDRECORDITEM
nHyperlink | XTP_NM_GRIDRECORDITEM
pColumn | XTP_NM_GRIDRECORDITEM
pItem | XTP_NM_GRIDRECORDITEM
pRow | XTP_NM_GRIDRECORDITEM
pt | XTP_NM_GRIDRECORDITEM


Toolkit Pro: Member List

CXTPChartAxisConstantLines Member List

This is the complete list of members for CXTPChartAxisConstantLines, including all inherited members.

Add(CXTPChartAxisConstantLine *pConstantLine) | CXTPChartAxisConstantLines |
CXTPChartAxisConstantLines(CXTPChartAxis *pAxis) | CXTPChartAxisConstantLines |
CXTPChartElement() | CXTPChartElement |
CXTPChartElementCollection() | CXTPChartElementCollection |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
DoPropExchange(CXTPPropExchange *pPX) | CXTPChartAxisConstantLines | virtual
GetAppearance() const | CXTPChartElement |
GetAt(int nIndex) const | CXTPChartAxisConstantLines |
GetContent() const | CXTPChartElement |
GetCount() const | CXTPChartElementCollection | virtual
GetOwner() const | CXTPChartElement |
IndexOf(CXTPChartElement *pElement) const | CXTPChartElementCollection |
InsertAt(int nIndex, CXTPChartElement *pElement) | CXTPChartElementCollection |
Is3D() const | CXTPChartObject |
m_arrElements | CXTPChartElementCollection | protected
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartElement | virtual
Release() | CXTPChartElementCollection | virtual
Remove(CXTPChartElement *pElement) | CXTPChartElementCollection | virtual
RemoveAll() | CXTPChartElementCollection | virtual
RemoveAt(int nIndex) | CXTPChartElementCollection | virtual
~CXTPChartAxisConstantLines() | CXTPChartAxisConstantLines | virtual
~CXTPChartElement() | CXTPChartElement | virtual
~CXTPChartElementCollection() | CXTPChartElementCollection |


Toolkit Pro: XTPChartGdiRectangleDeviceCommand.h Source File

  • Source
  • Chart
  • Drawing
  • Gdi
XTPChartGdiRectangleDeviceCommand.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTGDIRECTANGLEDEVICECOMMAND_H__)
24# define __XTPCHARTGDIRECTANGLEDEVICECOMMAND_H__
25
26# if _MSC_VER >= 1000
27# pragma once
28# endif // _MSC_VER >= 1000
29
30# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
31
32namespace Gdiplus
33{
34class GpPath;
35}
36
43class _XTP_EXT_CLASS CXTPChartGdiBoundedRectangleDeviceCommand
44 : public CXTPChartRectangleDeviceCommand
45{
46public:
55 CXTPChartGdiBoundedRectangleDeviceCommand(const CXTPChartRectF& rect,
56 const CXTPChartColor& color, int thickness);
57
58protected:
67 void ExecuteOverride(CXTPChartDeviceContext* pDC);
68
76 virtual void BeforeExecute(CXTPChartDeviceContext* pDC);
77
85 virtual void AfterExecute(CXTPChartDeviceContext* pDC);
86
87protected:
88 CXTPChartColor m_color;
89 int m_thickness;
90 int m_OldSmoothingMode;
91 int m_OldPixelOffsetMode;
92 int m_OldInterpolationMode;
93};
94
95class _XTP_EXT_CLASS CXTPChartGdiInnerBorderDeviceCommand
96 : public CXTPChartGdiBoundedRectangleDeviceCommand
97{
98public:
107 CXTPChartGdiInnerBorderDeviceCommand(const CXTPChartRectF& rect, const CXTPChartColor& color,
108 int thickness);
109};
110
117class _XTP_EXT_CLASS CXTPChartGdiSolidRectangleDeviceCommand
118 : public CXTPChartRectangleDeviceCommand
119{
120public:
128 CXTPChartGdiSolidRectangleDeviceCommand(const CXTPChartRectF& rect,
129 const CXTPChartColor& color);
130
131protected:
140 void ExecuteOverride(CXTPChartDeviceContext* pDC);
141
142protected:
143 CXTPChartColor m_color;
144};
145
152class _XTP_EXT_CLASS CXTPChartGdiGradientRectangleDeviceCommand
153 : public CXTPChartRectangleDeviceCommand
154{
155public:
166 CXTPChartGdiGradientRectangleDeviceCommand(const CXTPChartRectF& rect,
167 const CXTPChartColor& color,
168 const CXTPChartColor& color2,
169 XTPChartLinearGradientMode nMode);
170
171protected:
180 void ExecuteOverride(CXTPChartDeviceContext* pDC);
181
182protected:
183 CXTPChartColor m_color;
184 CXTPChartColor m_color2;
185 XTPChartLinearGradientMode m_nMode;
186};
187
194class _XTP_EXT_CLASS CXTPChartGdiHatchRectangleDeviceCommand
195 : public CXTPChartRectangleDeviceCommand
196{
197public:
207 CXTPChartGdiHatchRectangleDeviceCommand(const CXTPChartRectF& rect, const CXTPChartColor& color,
208 const CXTPChartColor& color2,
209 XTPChartHatchStyle nStyle);
210
211protected:
220 void ExecuteOverride(CXTPChartDeviceContext* pDC);
221
222protected:
223 CXTPChartColor m_color;
224 CXTPChartColor m_color2;
225 XTPChartHatchStyle m_nStyle;
226};
227
228# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
229#endif //#if !defined(__XTPCHARTGDIRECTANGLEDEVICECOMMAND_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartColor
This class abstracts a color entity.
Definition XTPChartTypes.h:51
CXTPChartDeviceCommand::AfterExecute
virtual void AfterExecute(CXTPChartDeviceContext *pDC)
This method gets called after a command is executed which allows for the customization of command beh...
CXTPChartDeviceCommand::BeforeExecute
virtual void BeforeExecute(CXTPChartDeviceContext *pDC)
This method gets called before a command is executed which allows for the customization of command be...
CXTPChartDeviceCommand::ExecuteOverride
virtual void ExecuteOverride(CXTPChartDeviceContext *pDC)
Override this function to write the drawing code for specific objects.
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartRectangleDeviceCommand
Base class implementation for 2D chart rectangle device command.
Definition XTPChartRectangleDeviceCommand.h:38
CXTPRectT< float >


Toolkit Pro: Member List

CXTPTrackUndoAddBlockCommand Member List

This is the complete list of members for CXTPTrackUndoAddBlockCommand, including all inherited members.

CXTPTrackUndoAddBlockCommand(CXTPTrackBlock *pBlock) | CXTPTrackUndoAddBlockCommand |
CXTPTrackUndoCommand(int nID) | CXTPTrackUndoCommand | protected
GetID() const | CXTPTrackUndoCommand |
m_nID | CXTPTrackUndoCommand | protected
m_pBlock | CXTPTrackUndoAddBlockCommand | protected
Undo() | CXTPTrackUndoAddBlockCommand | protectedvirtual
~CXTPTrackUndoAddBlockCommand() | CXTPTrackUndoAddBlockCommand | virtual
~CXTPTrackUndoCommand() | CXTPTrackUndoCommand | protectedvirtual


Toolkit Pro: XTPButtonThemeOffice2000.h Source File

  • Source
  • Controls
  • Button
  • Themes
XTPButtonThemeOffice2000.h
Go to the documentation of this file.
1
23#if !defined(__XTPBUTTONTHEMEOFFICE2000_H__)
24# define __XTPBUTTONTHEMEOFFICE2000_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPButtonThemeOffice2000 : public CXTPButtonThemeUltraFlat
39{
40public:
45 CXTPButtonThemeOffice2000();
46
53 void DrawButtonBackground(CDC* pDC, CXTPButton* pButton);
54};
55
56# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
58#endif //#if !defined(__XTPBUTTONTHEMEOFFICE2000_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPButton
Push Button control.
Definition XTPButton.h:109
CXTPButtonThemeOffice2000
CXTPButtonThemeOffice2000 is a class used to perform Office 2000 Theme drawing tasks.
Definition XTPButtonThemeOffice2000.h:39
CXTPButtonThemeOffice2000::CXTPButtonThemeOffice2000
CXTPButtonThemeOffice2000()
Constructs a CXTPButtonThemeOffice2000 object.
CXTPButtonThemeOffice2000::DrawButtonBackground
void DrawButtonBackground(CDC *pDC, CXTPButton *pButton)
This member function is called to draw the background for the button.
CXTPButtonThemeUltraFlat
CXTPButtonThemeUltraFlat is a class used to perform Ultra Flat Theme drawing tasks.
Definition XTPButtonThemeUltraFlat.h:39


Toolkit Pro: XTPChartStackedBarSeriesStyle.h Source File

  • Source
  • Chart
  • Styles
  • Bar
XTPChartStackedBarSeriesStyle.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTSTACKEDBARSERIESSTYLE_H__)
24# define __XTPCHARTSTACKEDBARSERIESSTYLE_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartSeriesView;
34
46class _XTP_EXT_CLASS CXTPChartStackedBarSeriesStyle : public CXTPChartBarSeriesStyle
47{
49 DECLARE_SERIAL(CXTPChartStackedBarSeriesStyle)
51public:
56 CXTPChartStackedBarSeriesStyle();
57
62 virtual ~CXTPChartStackedBarSeriesStyle();
63
64public:
65 void SetStackHeight(double dLevel = 100);
66 double GetStackHeight() const;
67
68 void SetStackGroup(int nStackGroup);
69 int GetStackGroup() const;
70
71public:
72public:
73 void DoPropExchange(CXTPPropExchange* pPX);
74
75protected:
89 virtual CXTPChartSeriesView* CreateView(CXTPChartSeries* pSeries,
90 CXTPChartDiagramView* pDiagramView);
91
103 virtual void CorrectAxisSideMargins(CXTPChartAxis* pAxis, double nMinValue, double nMaxValue,
104 double& nCorrection);
105
106protected:
107 double m_dStackHeight;
108 int m_nStackGroup;
109
110# ifdef _XTP_ACTIVEX
111public:
113 DECLARE_DISPATCH_MAP()
114 DECLARE_INTERFACE_MAP()
115 DECLARE_OLETYPELIB_EX(CXTPChartStackedBarSeriesStyle);
116 DECLARE_OLECREATE_EX(CXTPChartStackedBarSeriesStyle)
117
118 double OleGetStackHeight();
119 void OleSetStackHeight(double dStackHeight);
121# endif
122};
123
129class _XTP_EXT_CLASS CXTPChartStackedBarSeriesView : public CXTPChartBarSeriesView
130{
131public:
139 CXTPChartStackedBarSeriesView(CXTPChartSeries* pSeries, CXTPChartDiagramView* pDiagramView);
140 virtual ~CXTPChartStackedBarSeriesView();
141
142protected:
155 CXTPChartSeriesPointView* CreateSeriesPointView(CXTPChartDeviceContext* pDC,
156 CXTPChartSeriesPoint* pPoint,
157 CXTPChartElementView* pParentView);
158
165 void UpdateRange(CXTPChartDeviceContext* pDC);
166
167protected:
168 friend class CXTPChartStackedBarSeriesPointView;
169};
170
176class _XTP_EXT_CLASS CXTPChartStackedBarSeriesPointView : public CXTPChartBarSeriesPointView
177{
178public:
186 CXTPChartStackedBarSeriesPointView(CXTPChartSeriesPoint* pPoint,
187 CXTPChartElementView* pParentView);
188
189public:
190 CXTPChartRectF GetScreenRect() const;
191
192public:
204 virtual CXTPChartDeviceCommand* CreateDeviceCommand(CXTPChartDeviceContext* pDC);
205
206public:
207protected:
208 double m_dValueFrom;
209 double m_dValueTo;
210 friend class CXTPChartStackedBarSeriesView;
211};
212
213AFX_INLINE void CXTPChartStackedBarSeriesStyle::SetStackHeight(double dStackHeight)
214{
215 m_dStackHeight = dStackHeight;
216 OnChartChanged();
217}
218AFX_INLINE double CXTPChartStackedBarSeriesStyle::GetStackHeight() const
219{
220 return m_dStackHeight;
221}
222
223AFX_INLINE void CXTPChartStackedBarSeriesStyle::SetStackGroup(int nStackGroup)
224{
225 m_nStackGroup = nStackGroup;
226 OnChartChanged();
227}
228AFX_INLINE int CXTPChartStackedBarSeriesStyle::GetStackGroup() const
229{
230 return m_nStackGroup;
231}
233# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
234#endif //#if !defined(__XTPCHARTSTACKEDBARSERIESSTYLE_H__)
pPoint
const CPoint * pPoint
return 0 or xtpCalendarHitTestDayExpandButton
Definition XTPCalendarThemeOffice2007.h:150
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartAxis
This abstract base class represents a chart axis as a kind of chart element.
Definition XTPChartAxis.h:86
CXTPChartBarSeriesPointView
This class represents the view of a bar series point, which is a kind of CXTPChartPointSeriesPointVie...
Definition XTPChartBarSeriesView.h:105
CXTPChartBarSeriesStyle
This class represents a bar series style for the chart, which is a kind of CXTPChartSeriesStyle.
Definition XTPChartBarSeriesStyle.h:47
CXTPChartBarSeriesView
This class represents the view of a bar series, which is a kind of CXTPChartSeriesView.
Definition XTPChartBarSeriesView.h:41
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartDiagramView
This class represents the view of a chart diagram, which is a kind of CXTPChartElementView.
Definition XTPChartDiagramView.h:49
CXTPChartElement::OnChartChanged
virtual void OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic propertie...
CXTPChartElementView
This class represents the view of a chart element.
Definition XTPChartElementView.h:47
CXTPChartSeries
This class represents a series in the chart, which is a kind of CXTPChartElement.
Definition XTPChartSeries.h:50
CXTPChartSeriesPoint
CXTPChartSeriesPoint is a kind of CXTPChartElement.
Definition XTPChartSeriesPoint.h:43
CXTPChartSeriesPointView
Represents chart series point view.
Definition XTPChartSeriesPointView.h:48
CXTPChartStackedBarSeriesPointView
This class represents the view of a bar series point, which is a kind of CXTPChartPointSeriesPointVie...
Definition XTPChartStackedBarSeriesStyle.h:177
CXTPChartStackedBarSeriesPointView::CreateDeviceCommand
virtual CXTPChartDeviceCommand * CreateDeviceCommand(CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
CXTPChartStackedBarSeriesPointView::CXTPChartStackedBarSeriesPointView
CXTPChartStackedBarSeriesPointView(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Constructs a CXTPChartStackedBarSeriesPointView object.
CXTPChartStackedBarSeriesStyle
This class represents a bar series style for the chart, which is a kind of CXTPChartSeriesStyle.
Definition XTPChartStackedBarSeriesStyle.h:47
CXTPChartStackedBarSeriesStyle::DoPropExchange
void DoPropExchange(CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
CXTPChartStackedBarSeriesStyle::CreateView
virtual CXTPChartSeriesView * CreateView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Call this function to create the view of the bar series.
CXTPChartStackedBarSeriesStyle::CXTPChartStackedBarSeriesStyle
CXTPChartStackedBarSeriesStyle()
Constructs a CXTPChartStackedBarSeriesStyle object.
CXTPChartStackedBarSeriesStyle::CorrectAxisSideMargins
virtual void CorrectAxisSideMargins(CXTPChartAxis *pAxis, double nMinValue, double nMaxValue, double &nCorrection)
Call this function to correct the axis side margins.
CXTPChartStackedBarSeriesStyle::~CXTPChartStackedBarSeriesStyle
virtual ~CXTPChartStackedBarSeriesStyle()
Destroys a CXTPChartStackedBarSeriesStyle object, handles cleanup.
CXTPChartStackedBarSeriesView
This class represents the view of a bar series, which is a kind of CXTPChartSeriesView.
Definition XTPChartStackedBarSeriesStyle.h:130
CXTPChartStackedBarSeriesView::CreateSeriesPointView
CXTPChartSeriesPointView * CreateSeriesPointView(CXTPChartDeviceContext *pDC, CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Call this function to create a view of the bar series point.
CXTPChartStackedBarSeriesView::UpdateRange
void UpdateRange(CXTPChartDeviceContext *pDC)
Call this function to calculate the layout of the bar series.
CXTPChartStackedBarSeriesView::CXTPChartStackedBarSeriesView
CXTPChartStackedBarSeriesView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Constructs a CXTPChartStackedBarSeriesView object.
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72
CXTPRectT< float >


Toolkit Pro: XTPDockingPaneThemeVisualStudio2017.h Source File

  • Source
  • DockingPane
  • Themes
XTPDockingPaneThemeVisualStudio2017.h
Go to the documentation of this file.
1
23#if !defined(__XTPDOCKINGPANETHEMEVISUALSTUDIO2017_H__)
24# define __XTPDOCKINGPANETHEMEVISUALSTUDIO2017_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPDockingPaneVisualStudio2017Theme
39 : public CXTPDockingPaneVisualStudio2012Theme
40{
41public:
46 CXTPDockingPaneVisualStudio2017Theme();
47
53 virtual ~CXTPDockingPaneVisualStudio2017Theme();
54
60 virtual void RefreshMetrics();
61
68 virtual void DrawSplitter(CDC* pDC, CXTPDockingPaneSplitterWnd* pSplitter);
69
79 virtual void DrawAutoHidePanel(CDC* pDC, CRect rc, XTPDockingPaneDirection direction);
80
81protected:
91 virtual void DrawTitleBar(CDC* pDC, CXTPDockingPaneBase* pPane, CRect rc, BOOL bVertical);
92
93 COLORREF m_clrCaptionBorder;
94};
95
96# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
98#endif // !defined(__XTPDOCKINGPANETHEMEVISUALSTUDIO2017_H__)
XTPDisableNoisyWarnings.h
XTPDockingPaneDirection
XTPDockingPaneDirection
Docking direction enumeration.
Definition XTPDockingPaneDefines.h:51
XTPEnableNoisyWarnings.h
CXTPDockingPaneBase
CXTPDockingPaneBase is a standalone class.
Definition XTPDockingPaneBase.h:69
CXTPDockingPaneSplitterWnd
CXTPDockingPaneSplitterWnd is a CWnd derived class.
Definition XTPDockingPaneSplitterContainer.h:42
CXTPDockingPaneVisualStudio2012Theme
CXTPDockingPaneVisualStudio2012Theme is used to define drawing routines specific to a Visual Studio 2...
Definition XTPDockingPaneThemeVisualStudio2012.h:41
CXTPDockingPaneVisualStudio2017Theme
CXTPDockingPaneVisualStudio2017Theme is used to define drawing routines specific to a Visual Studio 2...
Definition XTPDockingPaneThemeVisualStudio2017.h:40
CXTPDockingPaneVisualStudio2017Theme::~CXTPDockingPaneVisualStudio2017Theme
virtual ~CXTPDockingPaneVisualStudio2017Theme()
Destroys a CXTPDockingPaneVisualStudio2017Theme object, handles cleanup and deallocation.
CXTPDockingPaneVisualStudio2017Theme::CXTPDockingPaneVisualStudio2017Theme
CXTPDockingPaneVisualStudio2017Theme()
Constructs a CXTPDockingPaneVisualStudio2017Theme object.
CXTPDockingPaneVisualStudio2017Theme::DrawTitleBar
virtual void DrawTitleBar(CDC *pDC, CXTPDockingPaneBase *pPane, CRect rc, BOOL bVertical)
This member function is called to draw a title bar for the docking pane.
CXTPDockingPaneVisualStudio2017Theme::DrawSplitter
virtual void DrawSplitter(CDC *pDC, CXTPDockingPaneSplitterWnd *pSplitter)
Override this method to draw a splitter.
CXTPDockingPaneVisualStudio2017Theme::DrawAutoHidePanel
virtual void DrawAutoHidePanel(CDC *pDC, CRect rc, XTPDockingPaneDirection direction)
This method is called by the framework to draw the docking pane auto-hide panel background and splitt...
CXTPDockingPaneVisualStudio2017Theme::RefreshMetrics
virtual void RefreshMetrics()
This member function is used to initialize default colors for a theme from an .INI resource.
CXTPDockingPaneVisualStudio2017Theme::m_clrCaptionBorder
COLORREF m_clrCaptionBorder
Caption border color.
Definition XTPDockingPaneThemeVisualStudio2017.h:93


Toolkit Pro: Member List

CXTPListBoxThemeVisualStudio2015 Member List

This is the complete list of members for CXTPListBoxThemeVisualStudio2015, including all inherited members.

CXTPListBoxThemeOffice2013() | CXTPListBoxThemeOffice2013 |
CXTPListBoxThemeVisualStudio2015() | CXTPListBoxThemeVisualStudio2015 |
DrawItem(CDC *pDC, CXTPListBox *pListBox, LPDRAWITEMSTRUCT lpDIS) | CXTPListBoxThemeOffice2013 | virtual
DrawItemText(CDC *pDC, CRect rcText, CXTPListBox *pListBox, LPDRAWITEMSTRUCT lpDIS) | CXTPListBoxTheme | virtual
DrawNcBorders(CDC *pDC, CRect rc) | CXTPListBoxThemeOffice2013 | virtual
GetBackColor() | CXTPListBoxThemeOffice2013 | virtual
m_clrBack | CXTPListBoxThemeOffice2013 |
m_clrBorder | CXTPListBoxThemeOffice2013 |
m_clrItemBack | CXTPListBoxThemeOffice2013 |
m_clrItemBackHighlight | CXTPListBoxThemeOffice2013 |
m_clrItemBackSelected | CXTPListBoxThemeOffice2013 |
m_clrItemBorder | CXTPListBoxThemeOffice2013 |
m_clrItemBorderHighlight | CXTPListBoxThemeOffice2013 |
m_clrItemBorderSelected | CXTPListBoxThemeOffice2013 |
m_clrItemText | CXTPListBoxThemeOffice2013 |
m_clrItemTextHighlight | CXTPListBoxThemeOffice2013 |
m_clrItemTextSelected | CXTPListBoxThemeOffice2013 |
RefreshMetrics() | CXTPListBoxThemeOffice2013 | virtual
~CXTPListBoxTheme() | CXTPListBoxTheme | inlinevirtual


Toolkit Pro: Member List

CXTPCalendarViewEvents Member List

This is the complete list of members for CXTPCalendarViewEvents, including all inherited members.

Add(CXTPCalendarViewEvent *pNewElement) | CXTPCalendarPtrCollectionT< CXTPCalendarViewEvent > | virtual
Add(CXTPCalendarViewEvent *pNewElement, BOOL bWithAddRef) | CXTPCalendarPtrCollectionT< CXTPCalendarViewEvent > | virtual
Append(const CXTPCalendarPtrCollectionT< CXTPCalendarViewEvent > *pElementsArray) | CXTPCalendarPtrCollectionT< CXTPCalendarViewEvent > | virtual
CXTPCalendarPtrCollectionT() | CXTPCalendarPtrCollectionT< CXTPCalendarViewEvent > |
CXTPCalendarViewEvents() | CXTPCalendarViewEvents |
CXTPCmdTarget() | CXTPCmdTarget |
Find(const CXTPCalendarEvent *pEvent) const | CXTPCalendarViewEvents | virtual
CXTPCalendarPtrCollectionT< CXTPCalendarViewEvent >::Find(const CXTPCalendarViewEvent *pElement) const | CXTPCalendarPtrCollectionT< CXTPCalendarViewEvent > | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAt(int nIndex) const | CXTPCalendarPtrCollectionT< CXTPCalendarViewEvent > | virtual
GetAt(int nIndex, BOOL bWithAddRef) const | CXTPCalendarPtrCollectionT< CXTPCalendarViewEvent > | virtual
GetCount() const | CXTPCalendarPtrCollectionT< CXTPCalendarViewEvent > | virtual
InsertAt(int nIndex, CXTPCalendarViewEvent *pElement) | CXTPCalendarPtrCollectionT< CXTPCalendarViewEvent > | virtual
m_arElements | CXTPCalendarPtrCollectionT< CXTPCalendarViewEvent > | protected
Remove(CXTPCalendarEvent *pEvent) | CXTPCalendarViewEvents | virtual
CXTPCalendarPtrCollectionT< CXTPCalendarViewEvent >::Remove(CXTPCalendarViewEvent *pElement) | CXTPCalendarPtrCollectionT< CXTPCalendarViewEvent > | virtual
RemoveAll() | CXTPCalendarPtrCollectionT< CXTPCalendarViewEvent > | virtual
RemoveAt(int nIndex) | CXTPCalendarPtrCollectionT< CXTPCalendarViewEvent > | virtual
SetAt(int nIndex, CXTPCalendarViewEvent *pElement) | CXTPCalendarPtrCollectionT< CXTPCalendarViewEvent > | virtual
SetSize(int nNewSize) | CXTPCalendarPtrCollectionT< CXTPCalendarViewEvent > | virtual
TObjectPtr typedef | CXTPCalendarPtrCollectionT< CXTPCalendarViewEvent > | protected
~CXTPCalendarPtrCollectionT() | CXTPCalendarPtrCollectionT< CXTPCalendarViewEvent > | virtual
~CXTPCalendarViewEvents() | CXTPCalendarViewEvents | virtual


Toolkit Pro: Member List

CXTPChartBorder Member List

This is the complete list of members for CXTPChartBorder, including all inherited members.

CreateDeviceCommand(const CXTPChartRectF &rcBounds, const CXTPChartColor &color) | CXTPChartBorder | virtual
CreateInnerBorderDeviceCommand(const CXTPChartRectF &rcBounds, const CXTPChartColor &color) | CXTPChartBorder | virtual
CXTPChartBorder(CXTPChartElement *pOwner) | CXTPChartBorder |
CXTPChartElement() | CXTPChartElement |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
DoPropExchange(CXTPPropExchange *pPX) | CXTPChartBorder | virtual
GetAppearance() const | CXTPChartElement |
GetColor() const | CXTPChartBorder |
GetContent() const | CXTPChartElement |
GetOwner() const | CXTPChartElement |
GetThickness() const | CXTPChartBorder |
Is3D() const | CXTPChartObject |
IsVisible() const | CXTPChartBorder |
m_bVisible | CXTPChartBorder | protected
m_clrColor | CXTPChartBorder | protected
m_nThickness | CXTPChartBorder | protected
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartElement | virtual
Release() | CXTPChartElement | virtual
SetThickness(int Thickness) | CXTPChartBorder |
~CXTPChartBorder() | CXTPChartBorder | virtual
~CXTPChartElement() | CXTPChartElement | virtual


Toolkit Pro: Member List

CXTPTabColorSetVisualStudio2017 Member List

This is the complete list of members for CXTPTabColorSetVisualStudio2017, including all inherited members.

CXTPTabPaintManagerColorSet() | CXTPTabPaintManagerColorSet |
FillClient(CDC *pDC, CRect rc, CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
FillHeader(CDC *pDC, CRect rc, CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
FillNavigateButton(CDC *pDC, CXTPTabManagerNavigateButton *pButton, CRect &rc) | CXTPTabColorSetVisualStudio2015 | virtual
FillPropertyButton(CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem) | CXTPTabColorSetVisualStudio2015 | virtual
FillStateButton(CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerColorSet | virtual
GetClientColor(CXTPTabManager *pTabManager) | CXTPTabColorSetVisualStudio2015 | virtual
GetItemColor(CXTPTabManagerItem *pItem) | CXTPTabColorSetVisualStudio2015 | virtual
GradientFill(CDC *pDC, CRect rc, COLORREF clrLight, COLORREF clrDark, XTPTabPosition position) | CXTPTabPaintManagerColorSet |
IsAppThemed() const | CXTPTabPaintManagerColorSet | virtual
m_clrActiveFilesBack | CXTPTabPaintManagerColorSet |
m_clrActiveFilesBackHighlighted | CXTPTabPaintManagerColorSet |
m_clrActiveFilesBackPressed | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyph | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyphHighlighted | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyphPressed | CXTPTabPaintManagerColorSet |
m_clrAutoHideFace | CXTPTabPaintManagerColorSet |
m_clrBorderHighlight | CXTPTabPaintManagerColorSet |
m_clrButtonBorder | CXTPTabPaintManagerColorSet |
m_clrButtonBorderHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonBorderHot | CXTPTabPaintManagerColorSet |
m_clrButtonBorderKeyTips | CXTPTabPaintManagerColorSet |
m_clrButtonBorderTabContext1 | CXTPTabPaintManagerColorSet |
m_clrButtonBorderTabContext2 | CXTPTabPaintManagerColorSet |
m_clrButtonHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonHighlightedClose | CXTPTabPaintManagerColorSet |
m_clrButtonNormal | CXTPTabPaintManagerColorSet |
m_clrButtonPressed | CXTPTabPaintManagerColorSet |
m_clrButtonSelected | CXTPTabPaintManagerColorSet |
m_clrButtonSelectedHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonSelectedPressed | CXTPTabPaintManagerColorSet |
m_clrControlFace | CXTPTabPaintManagerColorSet |
m_clrFrameBorder | CXTPTabPaintManagerColorSet |
m_clrHeaderFace | CXTPTabPaintManagerColorSet |
m_clrPaneFace | CXTPTabPaintManagerColorSet |
m_clrTabClientBack | CXTPTabPaintManagerColorSet |
m_clrTabClientBorder | CXTPTabPaintManagerColorSet |
m_clrTextDisabled | CXTPTabPaintManagerColorSet |
m_clrTextHighlight | CXTPTabPaintManagerColorSet |
m_clrTextHighlightClose | CXTPTabPaintManagerColorSet |
m_clrTextNormal | CXTPTabPaintManagerColorSet |
m_clrTextPressed | CXTPTabPaintManagerColorSet |
m_clrTextSelected | CXTPTabPaintManagerColorSet |
m_clrTextSelectedHighlighted | CXTPTabPaintManagerColorSet |
m_clrTextSelectedPressed | CXTPTabPaintManagerColorSet |
m_csExcelNormal | CXTPTabPaintManagerColorSet |
m_csExcelSelected | CXTPTabPaintManagerColorSet |
m_csPropertyPage | CXTPTabPaintManagerColorSet |
m_csPropertyPage2003 | CXTPTabPaintManagerColorSet |
m_csStateButton | CXTPTabPaintManagerColorSet |
m_pPaintManager | CXTPTabPaintManagerColorSet | protected
RefreshMetrics() | CXTPTabColorSetVisualStudio2017 | virtual
SelectClipRgn(CDC *pDC, CRect rcClient, CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
SetTextColor(CDC *pDC, CXTPTabManagerItem *pItem) | CXTPTabColorSetVisualStudio2015 | virtual
~CXTPTabPaintManagerColorSet() | CXTPTabPaintManagerColorSet | virtual


Toolkit Pro: Member List

CXTPRibbonBar Member List

This is the complete list of members for CXTPRibbonBar, including all inherited members.

AddMDIMenu(UINT nIDResource) | CXTPMenuBar |
AddSystemButton(int nID=0) | CXTPRibbonBar |
AddTab(LPCTSTR lpszCaption) | CXTPRibbonBar |
AddTab(int nID) | CXTPRibbonBar |
AllowMinimize(BOOL bAllow) | CXTPRibbonBar |
AllowQuickAccessCustomization(BOOL bAllow) | CXTPRibbonBar |
AllowQuickAccessDuplicates(BOOL bAllow) | CXTPRibbonBar |
CalcClientHeight() | CXTPRibbonBar | virtual
CalcDockingLayout(int nLength, DWORD dwMode, int nWidth=0) | CXTPToolBar | virtual
CalcDynamicLayout(int nLength, DWORD dwMode) | CXTPToolBar | virtual
CalcGroupsHeight() | CXTPRibbonBar | virtual
CalcGroupsHeight(int nClientHeight) | CXTPRibbonBar | protectedvirtual
CalcQuickAccessHeight() | CXTPRibbonBar |
Copy(CXTPCommandBar *pCommandBar, BOOL bRecursive=FALSE) | CXTPMenuBar | protectedvirtual
Create(CWnd *pParentWnd, BOOL bFloat) | CXTPToolBar | protectedvirtual
CreateKeyboardTips() | CXTPCommandBar | virtual
CreateTabPopupToolBar(CXTPRibbonTab *pTab) | CXTPRibbonBar | protectedvirtual
CreateToolBar(DWORD dwStyle, CWnd *pParentWnd, UINT nID=AFX_IDW_TOOLBAR) | CXTPToolBar |
CXTPCommandBar() | CXTPCommandBar | protected
CXTPHookManagerHookAble() | CXTPHookManagerHookAble |
CXTPMenuBar() | CXTPMenuBar |
CXTPRibbonBar() | CXTPRibbonBar |
CXTPToolBar() | CXTPToolBar |
DelayLayout() | CXTPCommandBar |
DelayRedraw() | CXTPCommandBar | virtual
DoPropExchange(CXTPPropExchange *pPX) | CXTPMenuBar | protectedvirtual
DoUpdateCustomizeMenuControl(CXTPControl *pControl, CCmdTarget *pTarget) | CXTPToolBar | static
DrawCommandBar(CDC *pDC, CRect rcClipBox) | CXTPRibbonBar | virtual
EnableAnimation(BOOL bEnable=TRUE) | CXTPCommandBar |
EnableCustomization(BOOL bEnable=TRUE) | CXTPCommandBar |
EnableDocking(DWORD dwFlags=xtpFlagAlignAny|xtpFlagFloating|xtpFlagHideWrap) | CXTPToolBar |
EnableDoubleBuffer(BOOL bEnable=TRUE) | CXTPCommandBar |
EnableFrameTheme(BOOL bEnable=TRUE) | CXTPRibbonBar |
EnsureVisible(CXTPControl *pControl) | CXTPRibbonBar | virtual
FillCommandBarEntry(CDC *pDC) | CXTPCommandBar | virtual
FindAccel(TCHAR chAccel) const | CXTPCommandBar |
FindAccelEx(UINT chAccel, BOOL &bSelectOnly) const | CXTPCommandBar |
FindGroup(int nId) const | CXTPRibbonBar |
FindTab(int nId) const | CXTPRibbonBar |
FreeMDIMenus() | CXTPMenuBar |
GenerateCommandBarList(DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam) | CXTPMenuBar | protectedvirtual
GetActiveDocTemplate() const | CXTPCommandBar | protected
GetActiveMdiChildWnd(BOOL *bMaximized=NULL) | CXTPMenuBar | protected
GetBarID() const | CXTPCommandBar |
GetBarInfo(CToolBarInfo *pInfo) | CXTPToolBar |
GetBorders() | CXTPToolBar | protectedvirtual
GetButtonSize() const | CXTPRibbonBar | virtual
GetCaptionHeight() const | CXTPRibbonBar |
GetCaptionRect() const | CXTPRibbonBar |
GetCaptionTextRect() const | CXTPRibbonBar |
GetCommandBarData() const | CXTPCommandBar |
GetCommandBars() const | CXTPCommandBar |
GetContextHeaders() const | CXTPRibbonBar |
GetControl(int nIndex) const | CXTPCommandBar |
GetControlCount() const | CXTPCommandBar |
GetControlQuickAccess() const | CXTPRibbonBar |
GetControls() const | CXTPCommandBar |
GetControlTab() const | CXTPRibbonBar |
GetCurrentMenuResource() const | CXTPMenuBar |
GetCurSel() const | CXTPRibbonBar |
GetDefaultButtonStyle() const | CXTPCommandBar |
GetDefaultMenuResource() const | CXTPMenuBar |
GetDockBar() const | CXTPToolBar |
GetFlags() const | CXTPCommandBar |
GetFontHeight() const | CXTPRibbonBar |
GetFrameHook() const | CXTPRibbonBar |
GetFrameSite() const | CXTPCommandBar |
GetGroupsHeight() | CXTPRibbonBar | virtual
GetGroupsRect() const | CXTPRibbonBar |
GetHighlightedGroup() const | CXTPRibbonBar |
GetIconSize() const | CXTPRibbonBar | virtual
GetImageManager() const | CXTPCommandBar |
GetLargeIconSize(BOOL bAutoSize) const | CXTPCommandBar |
GetMDIMenus() const | CXTPMenuBar |
GetMinimumVisibleWidth() const | CXTPRibbonBar |
GetOwnerSite() const | CXTPCommandBar |
GetPaintManager() const | CXTPCommandBar |
GetParentCommandBar() const | CXTPCommandBar | virtual
GetPosition() const | CXTPCommandBar |
GetQuickAccessControls() const | CXTPRibbonBar |
GetQuickAccessHeight() const | CXTPRibbonBar |
GetQuickAccessRect() const | CXTPRibbonBar |
GetRibbonPaintManager() const | CXTPRibbonBar |
GetRootParent() const | CXTPCommandBar |
GetSelected() const | CXTPCommandBar |
GetSelectedTab() const | CXTPRibbonBar |
GetShowCaptionAlways() const | CXTPRibbonBar |
GetShowGripper() const | CXTPCommandBar |
GetSite() const | CXTPCommandBar |
GetSystemButton() const | CXTPRibbonBar |
GetTab(int nIndex) const | CXTPRibbonBar |
GetTabControlRect() const | CXTPRibbonBar |
GetTabCount() const | CXTPRibbonBar |
GetTabPaintManager() const | CXTPRibbonBar |
GetTabsHeight() const | CXTPRibbonBar | virtual
GetTextOrientation() const | CXTPCommandBar |
GetTitle() const | CXTPCommandBar |
GetTrackFocus() const | CXTPCommandBar |
GetType() const | CXTPCommandBar |
GetWidth() const | CXTPCommandBar |
HideKeyboardTips() | CXTPCommandBar |
HitTestGroup(CPoint point) const | CXTPRibbonBar |
InsertTab(int nItem, int nID) | CXTPRibbonBar |
InsertTab(int nItem, LPCTSTR lpszCaption, int nID=0) | CXTPRibbonBar |
InsertTab(int nItem, CXTPRibbonTab *pTab) | CXTPRibbonBar |
InvalidateParents() | CXTPCommandBar |
IsActive() const | CXTPRibbonBar |
IsAllowQuickAccessControl(CXTPControl *pControl) | CXTPRibbonBar | virtual
IsAllowQuickAccessDuplicates() const | CXTPRibbonBar |
IsAnimationEnabled() const | CXTPCommandBar |
IsBackstageViewVisible() const | CXTPRibbonBar |
IsBuiltIn() const | CXTPToolBar |
IsCaptionVisible() const | CXTPRibbonBar |
IsCloseable() const | CXTPToolBar |
IsContextMenuPresent() const | CXTPToolBar |
IsControlEnabled(const CXTPControl *pControl) const | CXTPRibbonBar | protectedvirtual
IsCustomizable() const | CXTPCommandBar | virtual
IsCustomizeDialogPresent() const | CXTPToolBar |
IsCustomizeMode() const | CXTPCommandBar |
IsDialogBar() const | CXTPCommandBar | virtual
IsDwmEnabled() const | CXTPRibbonBar |
IsFrameThemeEnabled() const | CXTPRibbonBar |
IsGroupsVisible() const | CXTPRibbonBar |
IsHelpMode() const | CXTPCommandBar | protected
IsKeyboardCuesVisible() const | CXTPRibbonBar | virtual
IsKeyboardTipsVisible() const | CXTPCommandBar |
IsLayoutRTL() const | CXTPCommandBar |
IsMenuTitleBar() const | CXTPCommandBar | virtual
IsPopupBar() const | CXTPCommandBar | virtual
IsQuickAccessBelowRibbon() const | CXTPRibbonBar |
IsQuickAccessControl(CXTPControl *pControl) const | CXTPRibbonBar |
IsQuickAccessVisible() const | CXTPRibbonBar |
IsResizable() const | CXTPCommandBar | virtual
IsRibbonBar() const | CXTPRibbonBar | virtual
IsRibbonBarVisible() const | CXTPRibbonBar |
IsRibbonMinimized() const | CXTPRibbonBar |
IsTabsVisible() const | CXTPRibbonBar |
IsTemporary() const | CXTPToolBar |
IsTextBelowIcons() const | CXTPCommandBar |
IsTrackingMode() const | CXTPCommandBar |
IsVisible() const | CXTPToolBar | inlinevirtual
IsWindowVisible() const | CXTPToolBar |
LoadMenu(CMenu *pMenu, BOOL bRemoveControls=TRUE) | CXTPCommandBar | virtual
LoadMenuBar(UINT nIDResource) | CXTPMenuBar | virtual
LoadToolBar(UINT nIDResource, BOOL bLoadIcons=TRUE) | CXTPToolBar | virtual
LockMouseMove(CXTPControl *pControl) | CXTPCommandBar |
LockRedraw() | CXTPCommandBar |
m_bAllowMinimize | CXTPRibbonBar | protected
m_bAllowQuickAccessCustomization | CXTPRibbonBar | protected
m_bAllowQuickAccessDuplicates | CXTPRibbonBar | protected
m_bAnimatePopup | CXTPCommandBar | protected
m_barPosition | CXTPCommandBar | protected
m_barType | CXTPCommandBar | protected
m_bAutoDestroy | CXTPHookManagerHookAble |
m_bBuiltIn | CXTPToolBar | protected
m_bCloseable | CXTPCommandBar | protected
m_bComboBar | CXTPCommandBar |
m_bContextMenuPresent | CXTPToolBar | protected
m_bCustomizable | CXTPCommandBar | protected
m_bCustomizeDialogPresent | CXTPCommandBar | protected
m_bExecOnRButton | CXTPCommandBar | protected
m_bGrabFocus | CXTPCommandBar | protected
m_bGroupReducedChanged | CXTPRibbonBar | protected
m_bGroupsVisible | CXTPRibbonBar | protected
m_bIgnoreUpdateHandler | CXTPCommandBar | protected
m_bInRecalcLayout | CXTPToolBar | protected
m_bIsCaptionBarInBackstageMode | CXTPRibbonBar | protected
m_bKeyboardSelect | CXTPCommandBar | protected
m_bMdiApp | CXTPMenuBar | protected
m_bMinimized | CXTPRibbonBar | protected
m_bMinimizeOnDblClick | CXTPRibbonBar | protected
m_bMultiLine | CXTPCommandBar | protected
m_bPreviewMode | CXTPToolBar | protected
m_bPreviewVisible | CXTPToolBar | protected
m_bRecursePopup | CXTPCommandBar | protected
m_bRibbonBarVisible | CXTPRibbonBar | protected
m_bShowCaptionAlways | CXTPRibbonBar | protected
m_bShowExpandButton | CXTPToolBar | protected
m_bShowQuickAccess | CXTPRibbonBar | protected
m_bShowQuickAccessBelow | CXTPRibbonBar | protected
m_bTabsVisible | CXTPRibbonBar | protected
m_bTearOff | CXTPToolBar | protected
m_bTemporary | CXTPToolBar | protected
m_bTextBelow | CXTPCommandBar | protected
m_bTracking | CXTPCommandBar | protected
m_bTrackOnHover | CXTPCommandBar |
m_buttonStyle | CXTPCommandBar | protected
m_bVerticalMarker | CXTPCommandBar | protected
m_bVisible | CXTPToolBar | protected
m_dwData | CXTPCommandBar | protected
m_dwFlags | CXTPCommandBar | protected
m_dwStyle | CXTPCommandBar | protected
m_hMenuDefault | CXTPMenuBar | protected
m_hWndActiveChild | CXTPMenuBar | protected
m_hwndFocus | CXTPCommandBar | protected
m_nBackstageMenuWidth | CXTPRibbonBar | protected
m_nBackstageSysButtonBottom | CXTPRibbonBar | protected
m_nBackstageSysButtonTop | CXTPRibbonBar | protected
m_nBarID | CXTPCommandBar | protected
m_nCustomClientHeight | CXTPRibbonBar | protected
m_nCustomGroupsHeight | CXTPRibbonBar | protected
m_nIdleFlags | CXTPCommandBar | protected
m_nIDResource | CXTPMenuBar | protected
m_nIDResourceCurrent | CXTPMenuBar | protected
m_nLockRedraw | CXTPCommandBar | protected
m_nMinVisibleHeight | CXTPRibbonBar | protected
m_nMinVisibleWidth | CXTPRibbonBar | protected
m_nMRUWidth | CXTPCommandBar | protected
m_nPopuped | CXTPCommandBar | protected
m_nQuickAccessHeight | CXTPRibbonBar | protected
m_nSelected | CXTPCommandBar | protected
m_nStateFlags | CXTPCommandBar |
m_nTextOrientation | CXTPCommandBar | protected
m_pAnimation | CXTPCommandBar | protected
m_pCommandBars | CXTPCommandBar | protected
m_pContextHeaders | CXTPRibbonBar | protected
m_pControlQuickAccess | CXTPRibbonBar | protected
m_pControlQuickAccessMore | CXTPRibbonBar | protected
m_pControls | CXTPCommandBar | protected
m_pControlSystemButton | CXTPRibbonBar | protected
m_pControlTab | CXTPRibbonBar | protected
m_pDockBar | CXTPToolBar | protected
m_pDockContext | CXTPToolBar | protected
m_pImageManager | CXTPCommandBar | protected
m_pMDIMenus | CXTPMenuBar | protected
m_pOwner | CXTPCommandBar | protected
m_pPaintManager | CXTPCommandBar | protected
m_pQuickAccessControls | CXTPRibbonBar | protected
m_pReturnCmd | CXTPCommandBar | protected
m_pSite | CXTPCommandBar | protected
m_pToolTipContext | CXTPCommandBar | protected
m_rcCaption | CXTPRibbonBar | protected
m_rcCaptionText | CXTPRibbonBar | protected
m_rcGroups | CXTPRibbonBar | protected
m_rcHeader | CXTPRibbonBar | protected
m_rcMarker | CXTPCommandBar | protected
m_rcQuickAccess | CXTPRibbonBar | protected
m_rcTabControl | CXTPRibbonBar | protected
m_strCaptionText | CXTPRibbonBar | protected
m_strTitle | CXTPCommandBar | protected
m_szButtons | CXTPCommandBar | protected
m_szButtonSpacing | CXTPCommandBar | protected
m_szIcons | CXTPCommandBar | protected
MergeToolBar(CXTPCommandBar *pCommandBar, BOOL bSilent) | CXTPToolBar | protectedvirtual
MergeToolBar(CXTPCommandBar *pCommandBar, BOOL bSilent, int nDefaultConfirmationChoice) | CXTPToolBar | protectedvirtual
ModifyBarStyle(DWORD dwRemove, DWORD dwAdd) | CXTPToolBar |
OnControlsChanged() | CXTPCommandBar | protectedvirtual
OnControlSelected(BOOL bSelected, CXTPControl *pControl) | CXTPCommandBar | virtual
OnCustomizeDragEnter(CXTPControl *pDataObject, CPoint point) | CXTPCommandBar | virtual
OnCustomizeDragLeave() | CXTPCommandBar | virtual
OnCustomizeDragOver(CXTPControl *pDataObject, CPoint point) | CXTPCommandBar | virtual
OnCustomizeDrop(CXTPControl *pDataObject, DROPEFFECT &dropEffect, CPoint ptDrop, CPoint ptDrag) | CXTPCommandBar | virtual
OnHookAttached(HWND hWnd) | CXTPHookManagerHookAble | virtual
OnHookDetached() | CXTPHookManagerHookAble | virtual
OnHookKeyDown(UINT nChar, LPARAM lParam) | CXTPToolBar | virtual
OnHookMessage(HWND hWnd, UINT nMessage, WPARAM &wParam, LPARAM &lParam, LRESULT &lResult) | CXTPMenuBar | protectedvirtual
OnKeyboardTip(CXTPCommandBarKeyboardTip *pTip) | CXTPCommandBar | virtual
OnKeyboardTipChar(UINT chAccel) | CXTPCommandBar |
OnMouseHitTest(CPoint pt) | CXTPCommandBar | protectedvirtual
OnPaintManagerChanged() | CXTPToolBar | protectedvirtual
OnPostHookMessage(HWND hWnd, UINT nMessage, WPARAM &wParam, LPARAM &lParam, LRESULT &lResult) | CXTPHookManagerHookAble | virtual
OnRecalcLayout() | CXTPToolBar | virtual
OnRemoved() | CXTPCommandBar | protectedvirtual
OnSetPreviewMode(BOOL bPreview) | CXTPToolBar |
OnTabChanged(CXTPRibbonTab *pTab) | CXTPRibbonBar | protectedvirtual
OnTabChanging(CXTPRibbonTab *pTab) | CXTPRibbonBar | protectedvirtual
OnTrackEnter() | CXTPCommandBar | virtual
OnTrackLost() | CXTPCommandBar | virtual
PassKeyboardInputToBackstageView(UINT message, WPARAM wParam, LPARAM lParam) | CXTPRibbonBar |
Popup(CXTPControlPopup *pControlPopup, BOOL bSelectFirst=FALSE) | CXTPCommandBar | virtual
ProcessSpecialKey(XTPSpecialKey key) | CXTPCommandBar | protectedvirtual
RebuildControls(CXTPRibbonTab *pSelected) | CXTPRibbonBar |
Redraw(LPCRECT lpRect=0, BOOL bAnimate=TRUE) | CXTPCommandBar | virtual
RefreshMenu() | CXTPMenuBar |
RefreshSysButtons() | CXTPMenuBar | protectedvirtual
RemoveAllTabs() | CXTPRibbonBar |
RemoveTab(int nIndex) | CXTPRibbonBar |
Reset(BOOL bShowWarningMessage) | CXTPRibbonBar | virtual
RestoreCommandBarList(CXTPCommandBarList *pCommandBarList) | CXTPMenuBar | protectedvirtual
s_nExpandDelay | CXTPCommandBar | static
s_nExpandHoverDelay | CXTPCommandBar | static
s_nHoverDelay | CXTPCommandBar | static
SelectNextTab(BOOL bNext) | CXTPRibbonBar |
SetBarID(UINT nID) | CXTPCommandBar |
SetBarInfo(CToolBarInfo *pInfo) | CXTPToolBar |
SetButtons(UINT *pButtons, int nCount) | CXTPCommandBar |
SetButtonSize(CSize size) | CXTPCommandBar |
SetCloseable(BOOL bCloseable) | CXTPToolBar |
SetCommandBarData(DWORD_PTR dwData) | CXTPCommandBar |
SetCommandBars(CXTPCommandBars *pCommandBars) | CXTPCommandBar |
SetContextMenuPresent(BOOL bPresent) | CXTPToolBar |
SetControls(CXTPControls *pControls) | CXTPCommandBar |
SetCurSel(int nIndex) | CXTPRibbonBar |
SetCustomizeDialogPresent(BOOL bPresent) | CXTPToolBar |
SetDefaultButtonStyle(XTPButtonStyle buttonStyle) | CXTPCommandBar |
SetFlags(DWORD dwFlagsAdd, DWORD dwFlagsRemove=0) | CXTPCommandBar |
SetFontHeight(int nFontHeight) | CXTPRibbonBar |
SetGrabFocus(BOOL bGrabFocus) | CXTPCommandBar |
SetGroupsHeight(int nHeight) | CXTPRibbonBar |
SetGroupsVisible(BOOL bVisible) | CXTPRibbonBar |
SetIconSize(CSize size) | CXTPCommandBar |
SetImageManager(CXTPImageManager *pImageManager) | CXTPCommandBar |
SetMinimumVisibleSize(int nMinVisibleWidth, int nMinVisibleHeight) | CXTPRibbonBar |
SetMinimumVisibleWidth(int nMinVisibleWidth) | CXTPRibbonBar |
SetPaintManager(CXTPPaintManager *pPaintManager) | CXTPCommandBar |
SetPopuped(int nPopuped, BOOL bKeyboard=FALSE) | CXTPCommandBar |
SetPosition(XTPBarPosition barPosition) | CXTPToolBar | virtual
SetQuickAccessEmptyIconId(int nIconId) | CXTPRibbonBar |
SetRibbonMinimized(BOOL bMinimized) | CXTPRibbonBar | virtual
SetSelected(int nSelected, BOOL bKeyboard=FALSE) | CXTPCommandBar | virtual
SetShowGripper(BOOL bShow) | CXTPCommandBar |
SetStatusText(const CString &strDescription) | CXTPCommandBar |
SetTabsVisible(BOOL bVisible) | CXTPRibbonBar |
SetTemporary(BOOL bTemporary) | CXTPToolBar |
SetTextOrientation(XTPBarTextOrientation nTextOrientation) | CXTPCommandBar |
SetTitle(LPCTSTR lpszTitle) | CXTPCommandBar |
SetTrackFocus(HWND hwnd) | CXTPCommandBar |
SetTrackingMode(int bMode, BOOL bSelectFirst=TRUE, BOOL bKeyboard=FALSE) | CXTPCommandBar | virtual
SetupHook() | CXTPMenuBar | protected
SetupMenu() | CXTPMenuBar | protected
SetVisible(BOOL bVisible) | CXTPRibbonBar | virtual
SetWidth(int nWidth) | CXTPCommandBar |
ShouldSerializeBar() | CXTPMenuBar | protectedvirtual
ShowCaptionAlways(BOOL bShowCaption) | CXTPRibbonBar |
ShowExpandButton(BOOL bShowExpandButton) | CXTPToolBar |
ShowQuickAccess(BOOL bShow=TRUE) | CXTPRibbonBar |
ShowQuickAccessBelowRibbon(BOOL bBelow=TRUE) | CXTPRibbonBar |
ShowTextBelowIcons(BOOL bTextBelow=TRUE) | CXTPCommandBar |
SwitchActiveMenu() | CXTPMenuBar |
SwitchMDIMenu(UINT nIDMenu, CMenu *pMenu=NULL) | CXTPMenuBar | virtual
SwitchMDIMenu(HMENU hMenu) | CXTPMenuBar | protected
SyncActiveMdiChild() | CXTPMenuBar | protected
UnlockMouseMove() | CXTPCommandBar |
UnlockRedraw() | CXTPCommandBar |
UpdateShortcuts() | CXTPCommandBar | protectedvirtual
~CXTPCommandBar() | CXTPCommandBar | protectedvirtual
~CXTPHookManagerHookAble() | CXTPHookManagerHookAble | virtual
~CXTPMenuBar() | CXTPMenuBar |
~CXTPRibbonBar() | CXTPRibbonBar | virtual
~CXTPToolBar() | CXTPToolBar |


Toolkit Pro: Member List

XTP_NM_TRACKCONTROL Member List

This is the complete list of members for XTP_NM_TRACKCONTROL, including all inherited members.

hdr | XTP_NM_TRACKCONTROL
pBlock | XTP_NM_TRACKCONTROL
pMarker | XTP_NM_TRACKCONTROL


Toolkit Pro: XTPControlPopupColor.h Source File

  • Source
  • CommandBars
XTPControlPopupColor.h
Go to the documentation of this file.
1
23#if !defined(__XTPCONTROLPOPUPCOLOR_H__)
24# define __XTPCONTROLPOPUPCOLOR_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPImageManagerIcon;
34class CXTPImageManagerIconHandle;
35
41class _XTP_EXT_CLASS CXTPControlPopupColor : public CXTPControlPopup
42{
44 DECLARE_XTP_CONTROL(CXTPControlPopupColor)
47public:
52 CXTPControlPopupColor();
53
59 ~CXTPControlPopupColor();
60
66 void SetColor(COLORREF clr);
67
74 COLORREF GetColor() const;
75
76protected:
83 void Copy(CXTPControl* pControl, BOOL bRecursive = FALSE);
84
85private:
86 void RedrawIcon(CXTPImageManagerIcon* pImage, CXTPImageManagerIconHandle& hIcon);
87 void RedrawVectorIcon(CXTPImageManagerVectorImageHandle pIcon, UINT nWidth,
88 XTPImageState state);
89
90private:
91 COLORREF m_clr;
92
93# ifdef _XTP_COMMANDBARS_ACTIVEX
96 DECLARE_DISPATCH_MAP()
97 DECLARE_INTERFACE_MAP()
98
99 DECLARE_OLETYPELIB_EX(CXTPControlPopupColor);
101# endif
102};
103
109class _XTP_EXT_CLASS CXTPControlButtonColor : public CXTPControlButton
110{
112 DECLARE_XTP_CONTROL(CXTPControlButtonColor)
114public:
119 CXTPControlButtonColor();
120
127 COLORREF GetColor() const;
128
134 void SetColor(COLORREF clr);
135
136protected:
143 void Copy(CXTPControl* pControl, BOOL bRecursive = FALSE);
144
150 void DoPropExchange(CXTPPropExchange* pPX);
151
159 CSize GetSize(CDC* pDC);
160
166 void Draw(CDC* pDC);
167
168protected:
169 COLORREF m_clr;
171};
172
178class _XTP_EXT_CLASS CXTPControlColorSelector : public CXTPControl
179{
181 DECLARE_XTP_CONTROL(CXTPControlColorSelector)
188 struct CColorInfo;
189
190public:
195 CXTPControlColorSelector();
196
203 COLORREF GetColor() const;
204
210 void SetColor(COLORREF clr);
211
212protected:
220 CSize GetSize(CDC* pDC);
221
227 void Draw(CDC* pDC);
228
234 void OnMouseMove(CPoint point);
235
243 BOOL OnSetSelected(int bSelected);
244
251 void OnClick(BOOL bKeyboard = FALSE, CPoint pt = CPoint(0, 0));
252
257 void OnExecute();
258
264 void OnLButtonUp(CPoint point);
265
266protected:
280 virtual INT_PTR OnToolHitTest(CPoint point, TOOLINFO* pTI) const;
281
282private:
283 CRect GetRect(int nIndex) const;
284 int HitTest(CPoint point) const;
285
286 BOOL IsFocused() const;
287 BOOL OnHookKeyDown(UINT nChar, LPARAM /*lParam*/);
288 void SetSelectedItem(int nItem);
289 int GetItemCount() const;
290
291private:
292 int m_nSelected;
293 int m_nPressed;
294 COLORREF m_clr;
295
296# ifdef _XTP_COMMANDBARS_ACTIVEX
299 DECLARE_DISPATCH_MAP()
300 DECLARE_INTERFACE_MAP()
301
302 DECLARE_OLETYPELIB_EX(CXTPControlPopupColor);
304# endif
305};
306
307// Obsolete define
308# define XTP_IDS_AUTOMATIC XTP_IDS_CLR_AUTOMATIC
309# define XTP_IDS_MORE_COLORS XTP_IDS_CLR_MORE
311# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
312#endif // #if !defined(__XTPCONTROLPOPUPCOLOR_H__)
DECLARE_XTP_CONTROL
#define DECLARE_XTP_CONTROL(class_name)
This macro generates the C++ header code necessary for a CXTPControl-derived class that can be serial...
Definition XTPCommandBarsDefines.h:1169
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPImageState
XTPImageState
Image state enumerators.
Definition XTPImageManager.h:55
CXTPControlButtonColor
CXTPControlButtonColor is a CXTPControlButton derived class.
Definition XTPControlPopupColor.h:110
CXTPControlButtonColor::Copy
void Copy(CXTPControl *pControl, BOOL bRecursive=FALSE)
This method is called to copy the control.
CXTPControlButtonColor::m_clr
COLORREF m_clr
Color of the color bar displayed in the color button under the "pin" icon.
Definition XTPControlPopupColor.h:169
CXTPControlButtonColor::DoPropExchange
void DoPropExchange(CXTPPropExchange *pPX)
Either reads this object from or writes this object to an archive.
CXTPControlButtonColor::GetColor
COLORREF GetColor() const
Call this member to retrieve the color of the control.
CXTPControlButtonColor::SetColor
void SetColor(COLORREF clr)
Call this method to set the color of the control.
CXTPControlButtonColor::GetSize
CSize GetSize(CDC *pDC)
This method is called to determine the size of the control.
CXTPControlButtonColor::Draw
void Draw(CDC *pDC)
This method is called to draw the control.
CXTPControlButtonColor::CXTPControlButtonColor
CXTPControlButtonColor()
Constructs a CXTPControlButtonColor object.
CXTPControlButton
CXTPControlButton is a CXTPControl derived class.
Definition XTPControlButton.h:39
CXTPControlColorSelector
CXTPControlColorSelector is a CXTPControl derived class.
Definition XTPControlPopupColor.h:179
CXTPControlColorSelector::OnLButtonUp
void OnLButtonUp(CPoint point)
This member is called when the user releases the left mouse button.
CXTPControlColorSelector::OnMouseMove
void OnMouseMove(CPoint point)
This member is called when the mouse cursor moves.
CXTPControlColorSelector::GetColor
COLORREF GetColor() const
Call this member to retrieve the color of the selector control.
CXTPControlColorSelector::OnToolHitTest
virtual INT_PTR OnToolHitTest(CPoint point, TOOLINFO *pTI) const
The framework calls this member function to determine whether a point is in the bounding rectangle of...
CXTPControlColorSelector::CXTPControlColorSelector
CXTPControlColorSelector()
Constructs a CXTPControlColorSelector object.
CXTPControlColorSelector::SetColor
void SetColor(COLORREF clr)
Call this method to set the color of the control.
CXTPControlColorSelector::GetSize
CSize GetSize(CDC *pDC)
This method is called to determine the size of the control.
CXTPControlColorSelector::OnSetSelected
BOOL OnSetSelected(int bSelected)
This method is called when the control becomes selected.
CXTPControlColorSelector::OnClick
void OnClick(BOOL bKeyboard=FALSE, CPoint pt=CPoint(0, 0))
This method is called when the user clicks the control.
CXTPControlColorSelector::OnExecute
void OnExecute()
This method is called when the control is executed.
CXTPControlColorSelector::Draw
void Draw(CDC *pDC)
This method is called to draw the control.
CXTPControl
CXTPControl is a CXTPCmdTarget derived class.
Definition XTPControl.h:841
CXTPControl::OnHookKeyDown
virtual BOOL OnHookKeyDown(UINT nChar, LPARAM lParam)
This method is called when a non-system key is pressed.
Definition XTPControl.h:2726
CXTPControl::IsFocused
virtual BOOL IsFocused() const
Call this member to check the focused state of the control.
Definition XTPControl.h:2755
CXTPControl::GetRect
CRect GetRect() const
Call this member to get the bounding rectangle of the control.
Definition XTPControl.h:2584
CXTPControlPopupColor
CXTPControlPopupColor is a CXTPControlPopup derived class.
Definition XTPControlPopupColor.h:42
CXTPControlPopupColor::Copy
void Copy(CXTPControl *pControl, BOOL bRecursive=FALSE)
This method is called to copy the control.
CXTPControlPopupColor::GetColor
COLORREF GetColor() const
Call this member to retrieve the control color.
CXTPControlPopupColor::~CXTPControlPopupColor
~CXTPControlPopupColor()
Destroys a CXTPControlPopupColor object, handles cleanup and deallocation.
CXTPControlPopupColor::SetColor
void SetColor(COLORREF clr)
Call this member to set the picker color.
CXTPControlPopupColor::CXTPControlPopupColor
CXTPControlPopupColor()
Constructs a CXTPControlPopupColor object.
CXTPControlPopup
CXTPControlPopup is a CXTPControl derived class.
Definition XTPControlPopup.h:42
CXTPImageManagerIconHandle
CXTPImageManagerIconHandle is a HICON wrapper class.
Definition XTPImageManager.h:384
CXTPImageManagerIcon
Icons holder class.
Definition XTPImageManager.h:622
CXTPImageManagerVectorImageHandle
Represents a generic interface for a vector image of any possible format to be used with CXTPImageMan...
Definition XTPImageManager.h:90
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72


Toolkit Pro: Member List

CXTPMarkupStaticExtensionDoubleProperty Member List

This is the complete list of members for CXTPMarkupStaticExtensionDoubleProperty, including all inherited members.

CXTPMarkupStaticExtension(LPCWSTR lpzName, BOOL bProperty) | CXTPMarkupStaticExtension | protected
CXTPMarkupStaticExtension(LPCWSTR lpzName) | CXTPMarkupStaticExtension |
CXTPMarkupStaticExtensionDoubleProperty(LPCWSTR lpzName, double dblValue=0) | CXTPMarkupStaticExtensionDoubleProperty |
CXTPMarkupStaticExtensionProperty(LPCWSTR lpzName, CXTPMarkupObject *pObject=NULL) | CXTPMarkupStaticExtensionProperty |
Extend(CXTPMarkupStaticExtension *pExtension, BOOL bReplace=FALSE) | CXTPMarkupStaticExtension |
FindExtension(LPCWSTR lpzName) const | CXTPMarkupStaticExtension |
GetName() const | CXTPMarkupStaticExtension |
GetRawValue() const | CXTPMarkupStaticExtensionDoubleProperty |
GetValue() | CXTPMarkupStaticExtensionProperty |
IsProperty() const | CXTPMarkupStaticExtension |
OnPrepareValue() | CXTPMarkupStaticExtension | inlineprotectedvirtual
Parse(LPCWSTR lpzValue, LPCWSTR &lpzSubValue) | CXTPMarkupStaticExtension | static
ProvideValue() | CXTPMarkupStaticExtensionProperty | virtual
ProvideValue(LPCWSTR lpzValue) | CXTPMarkupStaticExtensionProperty | virtual
SetValue(double dblValue) | CXTPMarkupStaticExtensionDoubleProperty |
CXTPMarkupStaticExtensionProperty::SetValue(CXTPMarkupObject *pObject) | CXTPMarkupStaticExtensionProperty |
~CXTPMarkupStaticExtension() | CXTPMarkupStaticExtension | virtual
~CXTPMarkupStaticExtensionProperty() | CXTPMarkupStaticExtensionProperty |


Toolkit Pro: Member List

CXTPChart3dPieDiagram Member List

This is the complete list of members for CXTPChart3dPieDiagram, including all inherited members.

CalculateSeriesLayout(CXTPChartDeviceContext *pDC, CXTPChartDiagramView *pView) | CXTPChartPieDiagramBase< BaseDiagram > | virtual
CreateView(CXTPChartDeviceContext *pDC, CXTPChartElementView *pParent) | CXTPChart3dPieDiagram | virtual
CXTPChart3dPieDiagram() | CXTPChart3dPieDiagram |
CXTPChartPieDiagramBase() | CXTPChartPieDiagramBase< BaseDiagram > | protected


Toolkit Pro: XTPChartRadarLineSeriesStyle.h Source File

  • Source
  • Chart
  • Styles
  • Radar
XTPChartRadarLineSeriesStyle.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTRADARLINESERIESSTYLE_H__)
24# define __XTPCHARTRADARLINESERIESSTYLE_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartSeriesView;
34class CXTPChartLineStyle;
35
46class _XTP_EXT_CLASS CXTPChartRadarLineSeriesStyle : public CXTPChartRadarPointSeriesStyle
47{
49 DECLARE_SERIAL(CXTPChartRadarLineSeriesStyle)
51public:
56 CXTPChartRadarLineSeriesStyle();
57
62 virtual ~CXTPChartRadarLineSeriesStyle();
63
64public:
65 void DoPropExchange(CXTPPropExchange* pPX);
66
67public:
75 CXTPChartLineStyle* GetLineStyle() const;
76
77protected:
88 virtual CXTPChartSeriesView* CreateView(CXTPChartSeries* pSeries,
89 CXTPChartDiagramView* pDiagramView);
90
91# ifdef _XTP_ACTIVEX
92public:
94 DECLARE_DISPATCH_MAP()
95 DECLARE_INTERFACE_MAP()
96 DECLARE_OLETYPELIB_EX(CXTPChartRadarLineSeriesStyle);
97 DECLARE_OLECREATE_EX(CXTPChartRadarLineSeriesStyle)
98 LPDISPATCH OleGetLineStyle();
99
101# endif
102
103protected:
104 CXTPChartLineStyle* m_pLineStyle; // The line style.
105};
106
107AFX_INLINE CXTPChartLineStyle* CXTPChartRadarLineSeriesStyle::GetLineStyle() const
108{
109 return m_pLineStyle;
110}
112# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
113#endif //#if !defined(__XTPCHARTRADARLINESERIESSTYLE_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartDiagramView
This class represents the view of a chart diagram, which is a kind of CXTPChartElementView.
Definition XTPChartDiagramView.h:49
CXTPChartLineStyle
This class represents a chart line style, which is a kind of CXTPCmdTarget.
Definition XTPChartLineStyle.h:43
CXTPChartRadarLineSeriesStyle
This class represents a line series style, which is a kind of CXTPChartSeriesStyle.
Definition XTPChartRadarLineSeriesStyle.h:47
CXTPChartRadarLineSeriesStyle::DoPropExchange
void DoPropExchange(CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
CXTPChartRadarLineSeriesStyle::~CXTPChartRadarLineSeriesStyle
virtual ~CXTPChartRadarLineSeriesStyle()
Destroys a CXTPChartRadarLineSeriesStyle object, handles cleanup.
CXTPChartRadarLineSeriesStyle::CreateView
virtual CXTPChartSeriesView * CreateView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Call this function to create the view of the point series.
CXTPChartRadarLineSeriesStyle::CXTPChartRadarLineSeriesStyle
CXTPChartRadarLineSeriesStyle()
Constructs a CXTPChartRadarLineSeriesStyle object.
CXTPChartRadarLineSeriesStyle::GetLineStyle
CXTPChartLineStyle * GetLineStyle() const
Call this function to get the line style of the line series.
Definition XTPChartRadarLineSeriesStyle.h:107
CXTPChartRadarPointSeriesStyle
This class represents a line series style, which is a kind of CXTPChartSeriesStyle.
Definition XTPChartRadarPointSeriesStyle.h:47
CXTPChartSeries
This class represents a series in the chart, which is a kind of CXTPChartElement.
Definition XTPChartSeries.h:50
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72


Toolkit Pro: Member List

CXTPGridThemeVisualStudio2017 Member List

This is the complete list of members for CXTPGridThemeVisualStudio2017, including all inherited members.

CalcColumnHeight(CDC *pDC, CXTPGridColumn *pColumn, int nTotalWidth=0) | CXTPGridPaintManager | protectedvirtual
CalculateRowHeight(CDC *pDC, const CString &strText, int nMaxWidth, BOOL bWordBreak=TRUE) | CXTPGridPaintManager | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPGridPaintManager() | CXTPGridPaintManager |
CXTPGridThemeOffice2013() | CXTPGridThemeOffice2013 |
CXTPGridThemeVisualStudio2017() | CXTPGridThemeVisualStudio2017 |
DrawBitmap(CDC *pDC, CXTPGridControl *pControl, CRect rcColumn, int iImage) | CXTPGridPaintManager | virtual
DrawCollapsedBitmap(CDC *pDC, const CXTPGridRow *pRow, CRect &rcBitmap) | CXTPGridThemeOffice2013 | virtual
DrawColumn(CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn, BOOL bDrawExternal=FALSE, int nShadowWidth=0) | CXTPGridPaintManager | virtual
DrawColumnBackground(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, BOOL &bColumnPressed, BOOL &bDraggingFromHeader, CXTPGridHeader *pHeader=NULL) | CXTPGridThemeOffice2013 | virtual
DrawColumnFooter(CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn) | CXTPGridPaintManager | virtual
DrawColumnFooterDivider(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn) | CXTPGridPaintManager | virtual
DrawColumnIcon(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, CRect rcIcon, int iIcon) | CXTPGridPaintManager | virtual
DrawColumnText(CDC *pDC, CRect rcText, CString strCaption, int nHeaderAlignment, BOOL bIsHeader, BOOL bColumnPressed) | CXTPGridThemeOffice2013 | virtual
DrawConnector(CDC *pDC, CPoint ptFrom, CPoint ptTo) | CXTPGridPaintManager |
DrawFocusedRow(CDC *pDC, CRect rcRow) | CXTPGridThemeOffice2013 | virtual
DrawFreezeColsDivider(CDC *pDC, const CRect &rc, CXTPGridControl *pControl, CXTPGridRow *pRow=NULL) | CXTPGridPaintManager | virtual
DrawGlyph(CDC *pDC, CRect rcColumn, int iImage) | CXTPGridPaintManager | virtual
DrawGrid(CDC *pDC, XTPGridOrientation orientation, CRect rcGrid) | CXTPGridPaintManager | virtual
DrawGridPattern(CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush) | CXTPGridPaintManager | protectedvirtual
DrawGridPattern(CDC *pDC, CXTPBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush) | CXTPGridPaintManager | protectedvirtual
DrawGridPattern(CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr) | CXTPGridPaintManager | protectedvirtual
DrawGroupRow(CDC *pDC, CXTPGridGroupRow *pRow, CRect rcRow, XTP_GRIDRECORDITEM_METRICS *pMetrics) | CXTPGridThemeOffice2013 | virtual
DrawHorizontalLine(CDC *pDC, int xPos, int yPos, int cx, COLORREF clr) | CXTPGridPaintManager |
DrawInplaceButton(CDC *pDC, CXTPGridInplaceButton *pButton) | CXTPGridPaintManager | virtual
DrawInplaceButtonFrame(CDC *pDC, CXTPGridInplaceButton *pButton) | CXTPGridPaintManager | protectedvirtual
DrawInplaceButtonIcon(CDC *pDC, CXTPGridInplaceButton *pButton) | CXTPGridPaintManager | protectedvirtual
DrawInplaceComboButton(CDC *pDC, CRect *pRc) | CXTPGridPaintManager | virtual
DrawInplaceExpandButton(CDC *pDC, CRect *pRc) | CXTPGridPaintManager | virtual
DrawInplaceSpinButton(CDC *pDC, CRect *pRc) | CXTPGridPaintManager | virtual
DrawItemBitmap(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CRect &rcItem, int nImage) | CXTPGridPaintManager | virtual
DrawItemCaption(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics) | CXTPGridPaintManager | virtual
DrawItemControl(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CXTPGridRecordItemControl *pControl, CRect &rcItem) | CXTPGridPaintManager | virtual
DrawLink(int *pnCurrDrawPos, XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CXTPGridHyperlink *pHyperlink, CString strText, CRect rcLink, int nFlag, BOOL bTrim=FALSE) | CXTPGridPaintManager | protectedvirtual
DrawMultiLineText(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, BOOL bWordBreak=TRUE) | CXTPGridPaintManager | protectedvirtual
DrawNoGroupByText(CDC *pDC, CRect rcItem) | CXTPGridPaintManager | virtual
DrawRowNumber(CDC *pDC, CRect rcNumber, CXTPGridRow *pRow) | CXTPGridPaintManager | virtual
DrawSectionDivider(CDC *pDC, const CRect &rc, XTPGridSectionDividerPosition dividerPosition, XTPGridSectionDividerStyle dividerStyle, CXTPPaintManagerColor dividerColor) | CXTPGridPaintManager |
DrawShellIcon(CDC *pDC, CRect rcColumn, int iImage) | CXTPGridPaintManager | virtual
DrawSingleLineText(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nStartPos, int nEndPos, int nActualWidth) | CXTPGridPaintManager | protectedvirtual
DrawString(int *pnCurrDrawPos, CDC *pDC, const CString &strDraw, CRect rcDraw, UINT nFormat) | CXTPGridPaintManager | protectedvirtual
DrawTextLine(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nFlag, int &nCharCounter, int &nHyperlinkCounter) | CXTPGridPaintManager | protectedvirtual
DrawTreeStructure(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CRect rcItem, CSize sizeGlyph) | CXTPGridPaintManager | virtual
DrawTriangle(CDC *pDC, CRect rcTriangle, BOOL bToDown, BOOL bDraggingFromHeader, int nShadowWidth, BOOL bColumnPressed) | CXTPGridThemeOffice2013 | virtual
DrawVerticalLine(CDC *pDC, int xPos, int yPos, int cy, COLORREF clr) | CXTPGridPaintManager |
DrawVerticalTimeLineMarker(CDC *pDC, int xPos, CXTPGridControl *pControl, COLORREF color=RGB(0, 255, 0)) | CXTPGridPaintManager | virtual
EnablePreviewMode(BOOL bIsPreviewMode) | CXTPGridPaintManager |
FillFooter(CDC *pDC, CRect rcFooter) | CXTPGridPaintManager | virtual
FillGroupByControl(CDC *pDC, CRect &rcGroupBy) | CXTPGridPaintManager | virtual
FillGroupRowMetrics(CXTPGridGroupRow *pRow, XTP_GRIDRECORDITEM_METRICS *pMetrics, BOOL bPrinting) | CXTPGridThemeOffice2013 | virtual
FillHeaderControl(CDC *pDC, CRect rcHeader) | CXTPGridPaintManager | virtual
FillIndent(CDC *pDC, CRect rcRow) | CXTPGridPaintManager | virtual
FillItemShade(CDC *pDC, CRect rcItem) | CXTPGridPaintManager | virtual
FillRow(CDC *pDC, CXTPGridRow *pRow, CRect rcRow) | CXTPGridPaintManager | virtual
FindRowAdjacentToMerged(const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, BOOL bUpward) | CXTPGridPaintManager |
FindRowAdjacentToMergedEx(const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, int &nAdjRowIndex, BOOL bUpward) | CXTPGridPaintManager |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetColumnOffice2007CustomThemeBaseColor() const | CXTPGridPaintManager |
GetColumnStyle() const | CXTPGridPaintManager |
GetControlBackColor(CXTPGridControl *pControl) | CXTPGridPaintManager | virtual
GetFooterHeight(CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0) | CXTPGridPaintManager | virtual
GetFreezeColsDividerStyle() const | CXTPGridPaintManager |
GetGlyphs() const | CXTPGridPaintManager |
GetHeaderHeight() | CXTPGridPaintManager | virtual
GetHeaderHeight(CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0) | CXTPGridPaintManager | virtual
GetItemHeight(XTP_GRIDRECORDITEM_DRAWARGS &drawArgs, int nWidth) | CXTPGridPaintManager |
GetMaxPreviewLines() | CXTPGridPaintManager |
GetPreviewItemHeight(CDC *pDC, CXTPGridRow *pRow, int nWidth, int nHeight) | CXTPGridPaintManager | virtual
GetPreviewLinesCount(CDC *pDC, CRect &rcText, const CString &strText) | CXTPGridPaintManager |
GetRowHeight(CDC *pDC, CXTPGridRow *pRow) | CXTPGridThemeOffice2013 | virtual
GetRowHeight(CDC *pDC, CXTPGridRow *pRow, int nTotalWidth) | CXTPGridThemeOffice2013 | virtual
GetRowHeightEx(CDC *pDC, CXTPGridRow *pRow, int nTotalWidth, const BOOL firstLevel=TRUE) | CXTPGridPaintManager |
GetSectionDividerHeight(XTPGridFixedRowsDividerStyle dividerStyle) | CXTPGridPaintManager |
GetTextFont() | CXTPGridPaintManager |
IsColumHotTrackingEnabled() const | CXTPGridPaintManager | virtual
IsColumnPlusMinusSign() const | CXTPGridPaintManager |
IsColumnWidthWYSIWYG() const | CXTPGridPaintManager |
IsDrawGridForEmptySpace() const | CXTPGridPaintManager |
IsFixedInplaceButtonHeight() const | CXTPGridPaintManager |
IsFixedRowHeight() const | CXTPGridPaintManager |
IsGridVisible(BOOL bVertical) const | CXTPGridPaintManager |
IsGridVisible(XTPGridOrientation orientation) const | CXTPGridPaintManager |
IsLastColumnWidthWYSIWYG() const | CXTPGridPaintManager |
IsPreviewMode() const | CXTPGridPaintManager |
IsPrintGroupRowIcon() const | CXTPGridPaintManager |
IsShowWYSIWYGMarkers() const | CXTPGridPaintManager |
IsUseDropMarker() const | CXTPGridPaintManager |
LoadGlyphs() | CXTPGridThemeOffice2013 | virtual
m_arStartCol | CXTPGridPaintManager |
m_bAllowMergeCells | CXTPGridPaintManager |
m_bBaseTreeIndent | CXTPGridPaintManager |
m_bCleanTooltip | CXTPGridPaintManager |
m_bColumnPlusMinusSign | CXTPGridPaintManager | protected
m_bColumnWidthWYSIWYG | CXTPGridPaintManager | protected
m_bCompactText | CXTPGridPaintManager |
m_bDrawGridForEmptySpace | CXTPGridPaintManager | protected
m_bFixedInplaceButtonHeight | CXTPGridPaintManager | protected
m_bFixedRowHeight | CXTPGridPaintManager | protected
m_bForceDynamicMarkupForCell | CXTPGridPaintManager |
m_bForceShowDropMarker | CXTPGridPaintManager |
m_bForceShowTooltip | CXTPGridPaintManager |
m_bGrayIfDisable | CXTPGridPaintManager |
m_bGroupRowTextBold | CXTPGridPaintManager |
m_bHideSelection | CXTPGridPaintManager |
m_bHotTracking | CXTPGridPaintManager |
m_bInvertColumnOnClick | CXTPGridPaintManager |
m_bIsPreviewMode | CXTPGridPaintManager | protected
m_bLastColumnWidthWYSIWYG | CXTPGridPaintManager | protected
m_bMakeUpper | CXTPGridPaintManager |
m_bMoveScrollbarOnFixedColumnsIndent | CXTPGridPaintManager |
m_bPrintGroupRowIcon | CXTPGridPaintManager | protected
m_bPrintPageRectangle | CXTPGridPaintManager |
m_bPrintSortTriangle | CXTPGridPaintManager |
m_bPrintVirtualPageNumber | CXTPGridPaintManager |
m_bPrintWatermark | CXTPGridPaintManager |
m_bRecOrRowNum | CXTPGridPaintManager |
m_bRevertAlignment | CXTPGridPaintManager |
m_bShadeGroupHeadings | CXTPGridPaintManager |
m_bShadeSortColumn | CXTPGridPaintManager |
m_bShowLockIcon | CXTPGridPaintManager |
m_bShowNonActiveInPlaceButton | CXTPGridPaintManager |
m_bShowWYSIWYGMarkers | CXTPGridPaintManager | protected
m_bSortTriangleOffsetFromRight | CXTPGridPaintManager |
m_bThemedInplaceButtons | CXTPGridPaintManager |
m_bUseAlternativeBackground | CXTPGridPaintManager |
m_bUseDropMarker | CXTPGridPaintManager |
m_bUseEditTextAlignment | CXTPGridPaintManager |
m_bUseGroupRowSelectionState | CXTPGridPaintManager |
m_bUseShellIcon | CXTPGridPaintManager |
m_clrAlternativeBackground | CXTPGridPaintManager |
m_clrBoldText | CXTPGridPaintManager |
m_clrBoldTextHighlight | CXTPGridPaintManager |
m_clrBtnFace | CXTPGridPaintManager |
m_clrBtnFacePressed | CXTPGridPaintManager |
m_clrBtnText | CXTPGridPaintManager |
m_clrCaptionText | CXTPGridPaintManager |
m_clrCaptionTextPressed | CXTPGridPaintManager |
m_clrColumnOffice2007CustomTheme | CXTPGridPaintManager |
m_clrConnector | CXTPGridPaintManager |
m_clrControlBack | CXTPGridPaintManager |
m_clrControlDark | CXTPGridPaintManager |
m_clrControlLightLight | CXTPGridPaintManager |
m_clrDisableBitmapDarkest | CXTPGridPaintManager |
m_clrDisableBitmapLightest | CXTPGridPaintManager |
m_clrFormulaSubSum | CXTPGridPaintManager |
m_clrFormulaSum | CXTPGridPaintManager |
m_clrFreezeColsDivider | CXTPGridPaintManager |
m_clrGlyph | CXTPGridThemeOffice2013 |
m_clrGlyphBorder | CXTPGridThemeOffice2013 |
m_clrGlyphContract | CXTPGridThemeOffice2013 |
m_clrGlyphExpand | CXTPGridThemeOffice2013 |
m_clrGlyphHighlight | CXTPGridThemeOffice2013 |
m_clrGradientColumnSeparator | CXTPGridPaintManager |
m_clrGradientColumnShadow | CXTPGridPaintManager |
m_clrGroupBoxBack | CXTPGridPaintManager |
m_clrGroupRowText | CXTPGridPaintManager |
m_clrGroupShadeBack | CXTPGridPaintManager |
m_clrGroupShadeBorder | CXTPGridPaintManager |
m_clrGroupShadeText | CXTPGridPaintManager |
m_clrHeaderControl | CXTPGridPaintManager |
m_clrHighlight | CXTPGridPaintManager |
m_clrHighlightText | CXTPGridPaintManager |
m_clrHotDivider | CXTPGridPaintManager |
m_clrIndentControl | CXTPGridPaintManager |
m_clrItemShade | CXTPGridPaintManager |
m_clrPreviewText | CXTPGridPaintManager |
m_clrSelectedRow | CXTPGridPaintManager |
m_clrSelectedRowText | CXTPGridPaintManager |
m_clrWindowText | CXTPGridPaintManager |
m_columnStyle | CXTPGridPaintManager | protected
m_crlNoGroupByText | CXTPGridPaintManager |
m_grcGradientColumn | CXTPGridPaintManager |
m_grcGradientColumnHot | CXTPGridPaintManager |
m_grcGradientColumnPushed | CXTPGridPaintManager |
m_iRecOrRowStart | CXTPGridPaintManager |
m_nBaseParentRecordIndent | CXTPGridPaintManager |
m_nFixedColumnsIndent | CXTPGridPaintManager |
m_nFooterHeight | CXTPGridPaintManager | protected
m_nFreezeColsDividerStyle | CXTPGridPaintManager | protected
m_nGridLineStylePreviousH | CXTPGridPaintManager | protected
m_nGridLineStylePreviousV | CXTPGridPaintManager | protected
m_nGroupGridLineHeight | CXTPGridPaintManager | protected
m_nGroupGridLineStyle | CXTPGridPaintManager | protected
m_nHeaderHeight | CXTPGridPaintManager | protected
m_nMaxPreviewLines | CXTPGridPaintManager | protected
m_nResizingWidth | CXTPGridPaintManager | protected
m_nRowHeight | CXTPGridPaintManager | protected
m_nRowHeightDefault | CXTPGridPaintManager |
m_nTextIndentForGroupRowsWithNoIcon | CXTPGridPaintManager |
m_nTreeColumnLineLength | CXTPGridPaintManager |
m_nTreeIndent | CXTPGridPaintManager |
m_nTreeStructureStyle | CXTPGridPaintManager |
m_nTreeTextIndent | CXTPGridPaintManager |
m_nTreeTextIndentGroupRow | CXTPGridPaintManager |
m_nTreeTextIndentRowChildren | CXTPGridPaintManager |
m_nTreeTextIndentRowParent | CXTPGridPaintManager |
m_pControl | CXTPGridPaintManager | protected
m_pGlyphs | CXTPGridPaintManager | protected
m_pHyperlinkHoverStyle | CXTPGridPaintManager |
m_pHyperlinkStyle | CXTPGridPaintManager |
m_pMarkupUIElement_NoGroupBy | CXTPGridPaintManager | protected
m_PrintPageWidth | CXTPGridPaintManager |
m_rcPreviewIndent | CXTPGridPaintManager |
m_RecordNumberWidth | CXTPGridPaintManager |
m_strCollapse | CXTPGridPaintManager |
m_strDecreasing | CXTPGridPaintManager |
m_strExpand | CXTPGridPaintManager |
m_strIncreasing | CXTPGridPaintManager |
m_strMarkupUIElement_NoGroupBy | CXTPGridPaintManager | protected
m_strNoFieldsAvailable | CXTPGridPaintManager |
m_strNoGroupBy | CXTPGridPaintManager |
m_strNoItems | CXTPGridPaintManager |
m_strSortBy | CXTPGridPaintManager |
m_szGlyph | CXTPGridPaintManager | protected
m_themeButton | CXTPGridPaintManager | protected
m_themeCombo | CXTPGridPaintManager | protected
m_themeHeader | CXTPGridPaintManager | protected
m_themeSpin | CXTPGridPaintManager | protected
m_treeStructureStyle | CXTPGridPaintManager |
m_xtpBrushGroupGridLineStyle | CXTPGridPaintManager | protected
m_xtpBrushHorizontalGrid | CXTPGridPaintManager | protected
m_xtpBrushTreeStructure | CXTPGridPaintManager | protected
m_xtpBrushVeriticalGrid | CXTPGridPaintManager | protected
m_xtpFontBoldText | CXTPGridPaintManager |
m_xtpFontCaption | CXTPGridPaintManager |
m_xtpFontPreview | CXTPGridPaintManager |
m_xtpFontText | CXTPGridPaintManager |
OnDrawAction(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs) | CXTPGridPaintManager | virtual
RecalcTotalHightOfMergedRows(CXTPGridColumns *pColumns, CDC *pDC, CXTPGridRow *pRow, int nRowHeight, int nTotalWidth) | CXTPGridPaintManager |
RefreshMetrics() | CXTPGridThemeVisualStudio2017 | virtual
SetCaptionFont(LOGFONT &lf) | CXTPGridPaintManager |
SetColumnOffice2007CustomThemeBaseColor(COLORREF clrBaseColor) | CXTPGridPaintManager |
SetColumnPlusMinusSign(BOOL bDraw) | CXTPGridPaintManager |
SetColumnStyle(XTPGridColumnStyle columnStyle) | CXTPGridPaintManager |
SetColumnWidthWYSIWYG(BOOL bColumnWidthWYSIWYG) | CXTPGridPaintManager |
SetDrawGridForEmptySpace(BOOL bDrawGrid) | CXTPGridPaintManager |
SetFixedRowHeight(BOOL bFixedRowHeight) | CXTPGridPaintManager |
SetFreezeColsDividerStyle(int nStyle) | CXTPGridPaintManager |
SetGridControl(CXTPGridControl *pControl) | CXTPGridPaintManager | virtual
SetHeaderHeight(int nHeight) | CXTPGridPaintManager | virtual
SetInplaceButtonHeight(BOOL bFixedInplaceButtonHeight) | CXTPGridPaintManager |
SetLastColumnWidthWYSIWYG(BOOL bColumnWidthWYSIWYG) | CXTPGridPaintManager |
SetMaxPreviewLines(int nMaxLines) | CXTPGridPaintManager |
SetPreviewIndent(int nLeft, int nTop, int nRight, int nBottom) | CXTPGridPaintManager |
SetPrintGroupRowIcon(BOOL bDraw) | CXTPGridPaintManager |
SetTextFont(LOGFONT &lf) | CXTPGridPaintManager |
ShowWYSIWYGMarkers(BOOL bSet) | CXTPGridPaintManager |
~CXTPGridPaintManager() | CXTPGridPaintManager | virtual


Toolkit Pro: XTPChartGdiLineDeviceCommand.h Source File

  • Source
  • Chart
  • Drawing
  • Gdi
XTPChartGdiLineDeviceCommand.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTGDILINEDEVICECOMMAND_H__)
24# define __XTPCHARTGDILINEDEVICECOMMAND_H__
25
26# if _MSC_VER >= 1000
27# pragma once
28# endif // _MSC_VER >= 1000
29
30# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
31
38class _XTP_EXT_CLASS CXTPChartGdiSolidLineDeviceCommand : public CXTPChartLineDeviceCommand
39{
40public:
50 CXTPChartGdiSolidLineDeviceCommand(const CXTPPoint2f& p1, const CXTPPoint2f& p2,
51 const CXTPChartColor& color, int thickness);
52
53protected:
62 void ExecuteOverride(CXTPChartDeviceContext* pDC);
63
71 virtual void BeforeExecute(CXTPChartDeviceContext* pDC);
72
80 virtual void AfterExecute(CXTPChartDeviceContext* pDC);
81
82protected:
83 int m_OldPixelOffsetMode;
84 int m_OldInterpolationMode;
85};
86
93class _XTP_EXT_CLASS CXTPChartGdiSolidPolylineDeviceCommand : public CXTPChartPolylineDeviceCommand
94{
95public:
105 CXTPChartGdiSolidPolylineDeviceCommand(const CXTPChartPoints& p, const CXTPChartColor& color,
106 int thickness);
107
108protected:
117 void ExecuteOverride(CXTPChartDeviceContext* pDC);
118
119protected:
120 CXTPChartColor m_color;
121};
122
123class _XTP_EXT_CLASS CXTPChartGdiSplineDeviceCommand : public CXTPChartSplineDeviceCommand
124{
125protected:
126 CXTPChartGdiSplineDeviceCommand(const CXTPChartPoints& p, int thickness);
127
128protected:
129 CXTPChartElement* HitTest(CPoint point, CXTPChartElement* pParent) const;
130
131protected:
132 CXTPChartPoints m_p;
133 int m_nThickness;
134};
135
142class _XTP_EXT_CLASS CXTPChartGdiSolidSplineDeviceCommand : public CXTPChartSplineDeviceCommand
143{
144public:
153 CXTPChartGdiSolidSplineDeviceCommand(const CXTPChartPoints& p, const CXTPChartColor& color,
154 int thickness);
155
156protected:
165 void ExecuteOverride(CXTPChartDeviceContext* pDC);
166
167protected:
168 CXTPChartColor m_color;
169};
170
177class _XTP_EXT_CLASS CXTPChartGdiDashedLineDeviceCommand : public CXTPChartLineDeviceCommand
178{
179public:
199 CXTPChartGdiDashedLineDeviceCommand(const CXTPPoint2f& p1, const CXTPPoint2f& p2,
200 const CXTPChartColor& color, int thickness,
201 XTPChartDashStyle nDashStyle,
202 const CXTPChartLineDashArray& dashArray);
203
204protected:
212 void ExecuteOverride(CXTPChartDeviceContext* pDC);
213
214protected:
215 XTPChartDashStyle m_nDashStyle;
216 CXTPChartLineDashArray m_arrDashArray;
217};
218
225class _XTP_EXT_CLASS CXTPChartGdiDashedSplineDeviceCommand : public CXTPChartSplineDeviceCommand
226{
227public:
246 CXTPChartGdiDashedSplineDeviceCommand(const CXTPChartPoints& p, const CXTPChartColor& color,
247 int thickness, XTPChartDashStyle nDashStyle,
248 const CXTPChartLineDashArray& dashArray);
249
250protected:
259 void ExecuteOverride(CXTPChartDeviceContext* pDC);
260
261protected:
262 CXTPChartColor m_color;
263 XTPChartDashStyle m_nDashStyle;
264 CXTPChartLineDashArray m_arrDashArray;
265};
266
273class _XTP_EXT_CLASS CXTPChartGdiDashedPolylineDeviceCommand : public CXTPChartPolylineDeviceCommand
274{
275public:
295 CXTPChartGdiDashedPolylineDeviceCommand(const CXTPChartPoints& p, const CXTPChartColor& color,
296 int thickness, XTPChartDashStyle nDashStyle,
297 const CXTPChartLineDashArray& dashArray);
298
299protected:
308 void ExecuteOverride(CXTPChartDeviceContext* pDC);
309
320 CXTPChartElement* HitTest(CPoint point, CXTPChartElement* pParent) const;
321
322protected:
323 CXTPChartColor m_color;
324 XTPChartDashStyle m_nDashStyle;
325 CXTPChartLineDashArray m_arrDashArray;
326};
327
328# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
329#endif //#if !defined(__XTPCHARTGDILINEDEVICECOMMAND_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartColor
This class abstracts a color entity.
Definition XTPChartTypes.h:51
CXTPChartDeviceCommand::AfterExecute
virtual void AfterExecute(CXTPChartDeviceContext *pDC)
This method gets called after a command is executed which allows for the customization of command beh...
CXTPChartDeviceCommand::BeforeExecute
virtual void BeforeExecute(CXTPChartDeviceContext *pDC)
This method gets called before a command is executed which allows for the customization of command be...
CXTPChartDeviceCommand::ExecuteOverride
virtual void ExecuteOverride(CXTPChartDeviceContext *pDC)
Override this function to write the drawing code for specific objects.
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartElement
This class abstracts a chart element, this class acts as a base class for all chart elements.
Definition XTPChartElement.h:131
CXTPChartLineDeviceCommand
Provides an interface for 2D line drawing device command.
Definition XTPChartLineDeviceCommand.h:41
CXTPChartLineDeviceCommand::m_color
CXTPChartColor m_color
The line color.
Definition XTPChartLineDeviceCommand.h:70
CXTPChartLineDeviceCommand::m_nThickness
int m_nThickness
The thickness of the line.
Definition XTPChartLineDeviceCommand.h:71
CXTPChartLineDeviceCommand::HitTest
virtual CXTPChartElement * HitTest(CPoint point, CXTPChartElement *pParent) const
Performs recursive hit testing of the element at the specified point.
CXTPChartPolylineDeviceCommand
Provides an interface for 2D poly-line drawing device command.
Definition XTPChartLineDeviceCommand.h:79
CXTPChartSplineDeviceCommand
Provides an interface for 2D spline drawing device command.
Definition XTPChartLineDeviceCommand.h:100
CXTPPoint2T< float >


Toolkit Pro: Member List

CXTPListBoxThemeVisualStudio2019 Member List

This is the complete list of members for CXTPListBoxThemeVisualStudio2019, including all inherited members.

CXTPListBoxThemeOffice2013() | CXTPListBoxThemeOffice2013 |
CXTPListBoxThemeVisualStudio2019() | CXTPListBoxThemeVisualStudio2019 |
DrawItem(CDC *pDC, CXTPListBox *pListBox, LPDRAWITEMSTRUCT lpDIS) | CXTPListBoxThemeOffice2013 | virtual
DrawItemText(CDC *pDC, CRect rcText, CXTPListBox *pListBox, LPDRAWITEMSTRUCT lpDIS) | CXTPListBoxTheme | virtual
DrawNcBorders(CDC *pDC, CRect rc) | CXTPListBoxThemeOffice2013 | virtual
GetBackColor() | CXTPListBoxThemeOffice2013 | virtual
m_clrBack | CXTPListBoxThemeOffice2013 |
m_clrBorder | CXTPListBoxThemeOffice2013 |
m_clrItemBack | CXTPListBoxThemeOffice2013 |
m_clrItemBackHighlight | CXTPListBoxThemeOffice2013 |
m_clrItemBackSelected | CXTPListBoxThemeOffice2013 |
m_clrItemBorder | CXTPListBoxThemeOffice2013 |
m_clrItemBorderHighlight | CXTPListBoxThemeOffice2013 |
m_clrItemBorderSelected | CXTPListBoxThemeOffice2013 |
m_clrItemText | CXTPListBoxThemeOffice2013 |
m_clrItemTextHighlight | CXTPListBoxThemeOffice2013 |
m_clrItemTextSelected | CXTPListBoxThemeOffice2013 |
RefreshMetrics() | CXTPListBoxThemeOffice2013 | virtual
~CXTPListBoxTheme() | CXTPListBoxTheme | inlinevirtual


Toolkit Pro: XTPCalendarRecurrencePattern.h Source File

  • Source
  • Calendar
XTPCalendarRecurrencePattern.h
Go to the documentation of this file.
1
22#if !defined(_XTPCALENDARRECURRENCEPATTERN_H__)
23# define _XTPCALENDARRECURRENCEPATTERN_H__
24
25# if _MSC_VER > 1000
26# pragma once
27# endif // _MSC_VER > 1000
28
29# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
30
32class CXTPCalendarData;
33class CXTPCalendarEvent;
34class CXTPCalendarEvents;
35class CXTPPropExchange;
36class CXTPCalendarCustomProperties;
37
38 XTP_DEFINE_SMART_PTR_INTERNAL(CXTPCalendarEvent)
39 XTP_DEFINE_SMART_PTR_INTERNAL(CXTPCalendarEvents)
40 XTP_DEFINE_SMART_PTR_INTERNAL(CXTPCalendarRecurrencePattern)
41
42
47class _XTP_EXT_CLASS CXTPCalendarReminderForOccurrence
48{
49public:
56 CXTPCalendarReminderForOccurrence();
57
65 virtual ~CXTPCalendarReminderForOccurrence();
66
67 DATE m_dtOccurrenceStartTime;
68 DATE m_dtOccurrenceEndTime;
70 int m_nbIsReminder;
71 DATE m_dtNextReminderTime_Snoozed;
83 const CXTPCalendarReminderForOccurrence&
84 operator=(const CXTPCalendarReminderForOccurrence& rSrc);
85};
86
92class _XTP_EXT_CLASS CXTPCalendarReminderForOccurrenceArray
93 : public CArray<CXTPCalendarReminderForOccurrence, const CXTPCalendarReminderForOccurrence&>
94{
95public:
102 CXTPCalendarReminderForOccurrenceArray();
103
114 virtual ~CXTPCalendarReminderForOccurrenceArray();
115
127 int Find(CXTPCalendarEvent* pOccEvent) const;
128
141 int Find(DATE dtOccStartTime, DATE dtOccEndTime) const;
142
156 int UpdateOccIfNeed(CXTPCalendarEvent* pOccEvent, CXTPCalendarRecurrencePattern* pPattern);
157
173 static int AFX_CDECL UpdateOccIfNeedEx(CXTPCalendarEvent* pOccEvent,
174 const CXTPCalendarReminderForOccurrence* pOccRmdData,
175 CXTPCalendarRecurrencePattern* pPattern);
176
188 BOOL Load(CXTPCalendarCustomProperties* pProps);
189
205 BOOL Save(CXTPCalendarCustomProperties* pProps, CXTPCalendarRecurrencePattern* pPattern);
206
219 static void AFX_CDECL ClearProperties(CXTPCalendarCustomProperties* pProps);
220
221private:
222 static void AFX_CDECL _PropName(LPCTSTR pcszProp, int nIndex, CString& rstrPropNameI);
223};
224
238struct XTP_CALENDAR_RECURRENCE_OPTIONS
239{
240public:
245 struct PATTERN_DAILY
246 {
247 BOOL bEveryWeekDayOnly;
248 int nIntervalDays;
250 };
255 struct PATTERN_WEEKLY
256 {
257 int nIntervalWeeks;
259 int nDayOfWeekMask;
261 };
266 struct PATTERN_MONTHLY
267 {
268 int nIntervalMonths;
270 int nDayOfMonth;
272 };
277 struct PATTERN_MONTHNTH
278 {
279 int nIntervalMonths;
281 int nWhichDay;
282 int nWhichDayMask;
283 };
288 struct PATTERN_YEARLY
289 {
290 int nMonthOfYear;
291 int nDayOfMonth;
292 };
297 struct PATTERN_YEARNTH
298 {
299 int nWhichDay;
300 int nWhichDayMask;
301 int nMonthOfYear;
302 };
303
304public:
309 XTP_CALENDAR_RECURRENCE_OPTIONS()
310 {
311 memset(this, 0, sizeof(*this));
312 };
313
322 const XTP_CALENDAR_RECURRENCE_OPTIONS& operator=(const XTP_CALENDAR_RECURRENCE_OPTIONS& rSrc)
323 {
324 memcpy(this, &rSrc, sizeof(*this));
325 return *this;
326 }
327
328public:
329 XTPCalendarEventRecurrenceType m_nRecurrenceType;
332 // union stores active set of pattern parameters.
333 union {
334 PATTERN_DAILY m_Daily;
335 PATTERN_WEEKLY m_Weekly;
336 PATTERN_MONTHLY m_Monthly;
337 PATTERN_MONTHNTH m_MonthNth;
338 PATTERN_YEARLY m_Yearly;
339 PATTERN_YEARNTH m_YearNth;
340 };
341
356 void GetData(long& rnData1, long& rnData2, long& rnData3, long& rnData4) const
357 {
358 rnData1 = m_nRecurrenceType;
359 rnData2 = m_YearNth.nWhichDay;
360 rnData3 = m_YearNth.nWhichDayMask;
361 rnData4 = m_YearNth.nMonthOfYear;
362 }
363
379 void SetData(long nData1, long nData2, long nData3, long nData4)
380 {
381 _ASSERTE(nData1 >= 0 && nData1 <= 6);
383 m_nRecurrenceType = (XTPCalendarEventRecurrenceType)nData1;
384 m_YearNth.nWhichDay = nData2;
385 m_YearNth.nWhichDayMask = nData3;
386 m_YearNth.nMonthOfYear = nData4;
387 }
388};
389
397class _XTP_EXT_CLASS CXTPCalendarRecurrencePattern : public CXTPCmdTarget
398{
400 friend class CXTPCalendarData;
401 friend class CXTPCalendarEvent;
402 DECLARE_DYNAMIC(CXTPCalendarRecurrencePattern)
404protected:
413 CXTPCalendarRecurrencePattern(CXTPCalendarData* pDataProvider);
414
415public:
425 virtual ~CXTPCalendarRecurrencePattern();
426
435 virtual DWORD GetPatternID() const;
436
445 virtual COleDateTime GetStartTime() const;
446
455 virtual void SetStartTime(COleDateTime dtStart);
456
466 virtual int GetDurationMinutes() const;
467
476 virtual void SetDurationMinutes(int nMinutes);
477
487 virtual COleDateTimeSpan GetDuration() const;
488
499 virtual COleDateTime GetStartOccurrenceTime(COleDateTime dtOccurrenceStartDate) const;
500
513 virtual COleDateTime GetEndOccurrenceTime(COleDateTime dtOccurrenceStartDate) const;
514
525 virtual int GetRecurrenceType() const;
526
536 virtual const XTP_CALENDAR_RECURRENCE_OPTIONS& GetRecurrenceOptions() const;
537
547 virtual void SetRecurrenceOptions(const XTP_CALENDAR_RECURRENCE_OPTIONS& Options);
548
557 virtual COleDateTime GetPatternStartDate() const;
558
567 virtual void SetPatternStartDate(COleDateTime dtStart);
568
577 virtual COleDateTime GetPatternEndDate() const;
578
588 virtual void SetPatternEndDate(COleDateTime dtEnd);
589
601 virtual int GetEndAfterOccurrences() const;
602
615 virtual void SetEndAfterOccurrences(int nOccurrences);
616
628 virtual BOOL IsNoEndDate() const;
629
638 virtual void SetNoEndDate();
639
648 virtual XTPCalendarPatternEnd GetUseEndMethod() const;
649
659 virtual const XTP_CALENDAR_PATTERN_END& GetPatternEnd() const;
660
669 virtual void SetPatternEnd(const XTP_CALENDAR_PATTERN_END& patternEnd);
670
682 virtual void GetOccurrencesDates(CXTPCalendarDatesArray& rArDates, COleDateTime dtStart,
683 COleDateTime dtEnd) const;
684
702 virtual BOOL GetOccurrences(CXTPCalendarEvents* pEventsArray, COleDateTime dtStart,
703 COleDateTime dtEnd, CXTPCalendarEvent* pMasterEvent);
704
714 virtual CXTPCalendarRecurrencePatternPtr ClonePattern();
715
729 virtual BOOL Update(CXTPCalendarRecurrencePattern* pNewData);
730
739 virtual DWORD GetMasterEventID() const;
740
749 virtual void SetMasterEventID(DWORD dwEventID);
750
758 virtual CXTPCalendarEventPtr GetMasterEvent() const;
759
774 virtual BOOL SetException(CXTPCalendarEvent* pException,
775 CXTPCalendarEvent* pMasterEventToUpdate = NULL);
776
793 virtual BOOL RemoveException(CXTPCalendarEvent* pException,
794 CXTPCalendarEvent* pMasterEventToUpdate = NULL);
795
806 virtual void RemoveAllExceptions();
807
820 virtual CXTPCalendarEventsPtr GetExceptions();
821
833 virtual void DoPropExchange(CXTPPropExchange* pPX);
834
843 CXTPCalendarCustomProperties* GetCustomProperties() const;
844
845protected:
854 void SetPatternID(DWORD dwID);
855
856private:
857 void _GetOccurrenceStartEnd(const COleDateTime& dtOccStartDate, COleDateTime& rdtOccStart,
858 COleDateTime& rdtOccEnd) const;
859
860public:
872 virtual int FindExceptionIndex(COleDateTime dtStartOrig, COleDateTime dtEndOrig) const;
873
888 virtual CXTPCalendarEvent* FindException(COleDateTime dtStartOrig,
889 COleDateTime dtEndOrig) const;
890
907 virtual BOOL FindExceptions(CXTPCalendarEvents* pEvents, COleDateTime dtStart,
908 COleDateTime dtEnd) const;
909
920 CXTPCalendarReminderForOccurrenceArray* GetOccReminders();
921
936 void SetOccReminder(CXTPCalendarEvent* pOccEvent,
937 int nbIsReminder = xtpCalendarRmdPrm_DontChange,
938 DATE dtNextReminderTime_Snoozed = xtpCalendarRmdPrm_DontChange);
939
940 // void ResetReminderForOccFromThePast(CXTPCalendarEvent* pMasterEvent);
941
942private:
943 DWORD m_dwPatternID;
944 DWORD m_dwMasterEventID;
945
946 CXTPCalendarReminderForOccurrenceArray m_arOccReminders;
947 CXTPCalendarEvents* m_parExceptionEvents;
948 CXTPCalendarData* m_ptrDataProvider;
949
950 COleDateTime m_dtStartTime;
951 int m_nDurationMinutes;
952
953 XTP_CALENDAR_RECURRENCE_OPTIONS m_Options;
954
955 COleDateTime m_dtPatternStartDate;
956
957 XTP_CALENDAR_PATTERN_END m_PatternEnd;
958
959 CXTPCalendarCustomProperties* m_pCustomProperties;
961# ifdef _XTP_ACTIVEX
962
963 DECLARE_DISPATCH_MAP()
964 DECLARE_INTERFACE_MAP()
965
966 DECLARE_OLETYPELIB_EX(CXTPCalendarRecurrencePattern);
967
968 afx_msg DATE OleGetStartTime();
969 afx_msg void OleSetStartTime(DATE dt);
970 DATE OleGetStartDate();
971 void OleSetStartDate(DATE dt);
972 DATE OleGetEndDate();
973 void OleSetEndDate(DATE dt);
974 long OleGetEndAfterOccurrences();
975 void OleSetEndAfterOccurrences(int nOccurrences);
976 LPDISPATCH OleGetMasterEvent();
977 LPDISPATCH OleGetOptions();
978 LPDISPATCH OleGetExceptions();
979 LPDISPATCH OleCustomProperties();
980
981 void OleSetException(LPDISPATCH pExcEventDisp);
982 void OleRemoveException(LPDISPATCH pExcEventDisp);
983 void OleRemoveAllExceptions();
984
985 long OleGetId();
986
987# endif
988};
989//===========================================================================
990
992AFX_INLINE DWORD CXTPCalendarRecurrencePattern::GetPatternID() const
993{
994 return m_dwPatternID;
995}
996AFX_INLINE COleDateTime CXTPCalendarRecurrencePattern::GetStartTime() const
997{
998 return m_dtStartTime;
999}
1000AFX_INLINE void CXTPCalendarRecurrencePattern::SetStartTime(COleDateTime dtStart)
1001{
1002 m_dtStartTime = dtStart;
1003}
1004AFX_INLINE int CXTPCalendarRecurrencePattern::GetDurationMinutes() const
1005{
1006 return m_nDurationMinutes;
1007}
1008AFX_INLINE void CXTPCalendarRecurrencePattern::SetDurationMinutes(int nMinutes)
1009{
1010 m_nDurationMinutes = nMinutes;
1011}
1012AFX_INLINE int CXTPCalendarRecurrencePattern::GetRecurrenceType() const
1013{
1014 return m_Options.m_nRecurrenceType;
1015}
1016AFX_INLINE const XTP_CALENDAR_RECURRENCE_OPTIONS&
1017 CXTPCalendarRecurrencePattern::GetRecurrenceOptions() const
1018{
1019 return m_Options;
1020}
1021AFX_INLINE const XTP_CALENDAR_PATTERN_END& CXTPCalendarRecurrencePattern::GetPatternEnd() const
1022{
1023 return m_PatternEnd;
1024}
1025AFX_INLINE COleDateTime CXTPCalendarRecurrencePattern::GetPatternStartDate() const
1026{
1027 return m_dtPatternStartDate;
1028}
1029AFX_INLINE COleDateTime CXTPCalendarRecurrencePattern::GetPatternEndDate() const
1030{
1031 return m_PatternEnd.m_dtPatternEndDate;
1032}
1033AFX_INLINE int CXTPCalendarRecurrencePattern::GetEndAfterOccurrences() const
1034{
1035 return m_PatternEnd.m_nEndAfterOccurrences;
1036}
1037AFX_INLINE void CXTPCalendarRecurrencePattern::SetEndAfterOccurrences(int nOccurrences)
1038{
1039 m_PatternEnd.m_nEndAfterOccurrences = nOccurrences;
1040 m_PatternEnd.m_nUseEnd = xtpCalendarPatternEndAfterOccurrences;
1041}
1042AFX_INLINE BOOL CXTPCalendarRecurrencePattern::IsNoEndDate() const
1043{
1044 return (m_PatternEnd.m_nUseEnd == xtpCalendarPatternEndNoDate);
1045}
1046AFX_INLINE void CXTPCalendarRecurrencePattern::SetNoEndDate()
1047{
1048 m_PatternEnd.m_nUseEnd = xtpCalendarPatternEndNoDate;
1049}
1050AFX_INLINE XTPCalendarPatternEnd CXTPCalendarRecurrencePattern::GetUseEndMethod() const
1051{
1052 return m_PatternEnd.m_nUseEnd;
1053}
1054AFX_INLINE DWORD CXTPCalendarRecurrencePattern::GetMasterEventID() const
1055{
1056 return m_dwMasterEventID;
1057}
1058AFX_INLINE void CXTPCalendarRecurrencePattern::SetMasterEventID(DWORD dwEventID)
1059{
1060 m_dwMasterEventID = dwEventID;
1061}
1062AFX_INLINE CXTPCalendarCustomProperties* CXTPCalendarRecurrencePattern::GetCustomProperties() const
1063{
1064 return m_pCustomProperties;
1065}
1066AFX_INLINE CXTPCalendarReminderForOccurrenceArray* CXTPCalendarRecurrencePattern::GetOccReminders()
1067{
1068 return &m_arOccReminders;
1069}
1070
1071# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
1072#endif // !defined(_XTPCALENDARRECURRENCEPATTERN_H__)
xtpCalendarRmdPrm_DontChange
@ xtpCalendarRmdPrm_DontChange
Do not change reminders time value.
Definition XTPCalendarDefines.h:565
XTPCalendarPatternEnd
XTPCalendarPatternEnd
Specify the end of the recurrence pattern type.
Definition XTPCalendarDefines.h:241
xtpCalendarPatternEndNoDate
@ xtpCalendarPatternEndNoDate
Recurrence pattern has no End.
Definition XTPCalendarDefines.h:246
xtpCalendarPatternEndAfterOccurrences
@ xtpCalendarPatternEndAfterOccurrences
End of the recurrence pattern specified by the.
Definition XTPCalendarDefines.h:243
XTPCalendarEventRecurrenceType
XTPCalendarEventRecurrenceType
Enumerates Recurrence Pattern Types.
Definition XTPCalendarDefines.h:254
CXTPCalendarDatesArray
CArray< COleDateTime, COleDateTime & > CXTPCalendarDatesArray
Type definition for an array of dates.
Definition XTPCalendarDefines.h:234
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTP_DEFINE_SMART_PTR_INTERNAL
#define XTP_DEFINE_SMART_PTR_INTERNAL(ClassName)
Define smart pointer for the specified class as ClassNamePtr.
Definition XTPSmartPtrInternalT.h:47
CXTPCalendarCustomProperties
This class is used to store properties collection.
Definition XTPCalendarCustomProperties.h:44
CXTPCalendarData
This class defines an abstract representation of the Calendar control data with all necessary methods...
Definition XTPCalendarData.h:97
CXTPCalendarEvent
This class represents the data of a single Event used in the Calendar control.
Definition XTPCalendarEvent.h:77
CXTPCalendarEvents
This class represents a simple array collection of CXTPCalendarEvent objects.
Definition XTPCalendarEvents.h:55
CXTPCalendarRecurrencePattern
This class represents a recurrence pattern and stores data to build a schedule for recurrence events.
Definition XTPCalendarRecurrencePattern.h:398
CXTPCalendarRecurrencePattern::SetDurationMinutes
virtual void SetDurationMinutes(int nMinutes)
This member function is used to set the new duration value.
Definition XTPCalendarRecurrencePattern.h:1008
CXTPCalendarRecurrencePattern::GetRecurrenceOptions
virtual const XTP_CALENDAR_RECURRENCE_OPTIONS & GetRecurrenceOptions() const
This member function is used to obtain a set of recurrence options.
Definition XTPCalendarRecurrencePattern.h:1017
CXTPCalendarRecurrencePattern::GetOccurrencesDates
virtual void GetOccurrencesDates(CXTPCalendarDatesArray &rArDates, COleDateTime dtStart, COleDateTime dtEnd) const
This member function is used to obtain the occurrence dates from the pattern in the given interval.
CXTPCalendarRecurrencePattern::DoPropExchange
virtual void DoPropExchange(CXTPPropExchange *pPX)
Call this member function to Store/Load a recurrence pattern using the specified data object.
CXTPCalendarRecurrencePattern::GetDurationMinutes
virtual int GetDurationMinutes() const
Call this member function to get a duration in minutes.
Definition XTPCalendarRecurrencePattern.h:1004
CXTPCalendarRecurrencePattern::SetPatternID
void SetPatternID(DWORD dwID)
This member function is used to assign an ID to a pattern.
CXTPCalendarRecurrencePattern::SetRecurrenceOptions
virtual void SetRecurrenceOptions(const XTP_CALENDAR_RECURRENCE_OPTIONS &Options)
This member function is used to set the recurrence options.
CXTPCalendarRecurrencePattern::GetOccReminders
CXTPCalendarReminderForOccurrenceArray * GetOccReminders()
This member function is used to retrieve a collection of reminders settings for occurrences of this r...
Definition XTPCalendarRecurrencePattern.h:1066
CXTPCalendarRecurrencePattern::SetEndAfterOccurrences
virtual void SetEndAfterOccurrences(int nOccurrences)
This member function is used to set the "End After occurrences" recurrence pattern option.
Definition XTPCalendarRecurrencePattern.h:1037
CXTPCalendarRecurrencePattern::GetPatternID
virtual DWORD GetPatternID() const
Returns a unique pattern ID.
Definition XTPCalendarRecurrencePattern.h:992
CXTPCalendarRecurrencePattern::Update
virtual BOOL Update(CXTPCalendarRecurrencePattern *pNewData)
This member function is used to update the pattern data from the given pattern.
CXTPCalendarRecurrencePattern::FindException
virtual CXTPCalendarEvent * FindException(COleDateTime dtStartOrig, COleDateTime dtEndOrig) const
This member function is used to find the exception event by its original start and end dates.
CXTPCalendarRecurrencePattern::GetRecurrenceType
virtual int GetRecurrenceType() const
This member function is used to obtain the value of the recurrence type flag.
Definition XTPCalendarRecurrencePattern.h:1012
CXTPCalendarRecurrencePattern::SetOccReminder
void SetOccReminder(CXTPCalendarEvent *pOccEvent, int nbIsReminder=xtpCalendarRmdPrm_DontChange, DATE dtNextReminderTime_Snoozed=xtpCalendarRmdPrm_DontChange)
This member function is used to setup an occurrence with new Reminder settings.
CXTPCalendarRecurrencePattern::CXTPCalendarRecurrencePattern
CXTPCalendarRecurrencePattern(CXTPCalendarData *pDataProvider)
Protected pattern constructor.
CXTPCalendarRecurrencePattern::SetPatternStartDate
virtual void SetPatternStartDate(COleDateTime dtStart)
This member function is used to set the new start pattern date and time.
CXTPCalendarRecurrencePattern::GetEndAfterOccurrences
virtual int GetEndAfterOccurrences() const
This member function is used to obtain the "End After occurrences" recurrence pattern option.
Definition XTPCalendarRecurrencePattern.h:1033
CXTPCalendarRecurrencePattern::FindExceptions
virtual BOOL FindExceptions(CXTPCalendarEvents *pEvents, COleDateTime dtStart, COleDateTime dtEnd) const
This member function is used to find an exception event by its original start and end dates.
CXTPCalendarRecurrencePattern::SetMasterEventID
virtual void SetMasterEventID(DWORD dwEventID)
This member function is used to set the master event ID value.
Definition XTPCalendarRecurrencePattern.h:1058
CXTPCalendarRecurrencePattern::GetMasterEvent
virtual CXTPCalendarEventPtr GetMasterEvent() const
This member function is used to obtain a pointer to the read-only interface of the master event.
CXTPCalendarRecurrencePattern::GetCustomProperties
CXTPCalendarCustomProperties * GetCustomProperties() const
Get custom (named, user-defined) properties collection.
Definition XTPCalendarRecurrencePattern.h:1062
CXTPCalendarRecurrencePattern::FindExceptionIndex
virtual int FindExceptionIndex(COleDateTime dtStartOrig, COleDateTime dtEndOrig) const
This member function is used to find the index of the exception event by its original start and end d...
CXTPCalendarRecurrencePattern::GetMasterEventID
virtual DWORD GetMasterEventID() const
This member function is used to obtain the master event ID value.
Definition XTPCalendarRecurrencePattern.h:1054
CXTPCalendarRecurrencePattern::GetPatternEndDate
virtual COleDateTime GetPatternEndDate() const
Call this member function to obtain the end pattern DateTime.
Definition XTPCalendarRecurrencePattern.h:1029
CXTPCalendarRecurrencePattern::GetStartTime
virtual COleDateTime GetStartTime() const
Call this member function to get start date-time.
Definition XTPCalendarRecurrencePattern.h:996
CXTPCalendarRecurrencePattern::GetDuration
virtual COleDateTimeSpan GetDuration() const
Call this member function to get the duration as a COleDateTimeSpan object.
CXTPCalendarRecurrencePattern::RemoveException
virtual BOOL RemoveException(CXTPCalendarEvent *pException, CXTPCalendarEvent *pMasterEventToUpdate=NULL)
This member function is used to remove an exception from the master event.
CXTPCalendarRecurrencePattern::GetStartOccurrenceTime
virtual COleDateTime GetStartOccurrenceTime(COleDateTime dtOccurrenceStartDate) const
Call this member function to get the occurrence start date-time.
CXTPCalendarRecurrencePattern::IsNoEndDate
virtual BOOL IsNoEndDate() const
This member function is used to determine if the pattern has an end date.
Definition XTPCalendarRecurrencePattern.h:1042
CXTPCalendarRecurrencePattern::GetExceptions
virtual CXTPCalendarEventsPtr GetExceptions()
This member function is used to return the read-only collection with the exception events.
CXTPCalendarRecurrencePattern::GetPatternStartDate
virtual COleDateTime GetPatternStartDate() const
Call this member function to obtain the start pattern DateTime.
Definition XTPCalendarRecurrencePattern.h:1025
CXTPCalendarRecurrencePattern::~CXTPCalendarRecurrencePattern
virtual ~CXTPCalendarRecurrencePattern()
Default class destructor.
CXTPCalendarRecurrencePattern::RemoveAllExceptions
virtual void RemoveAllExceptions()
This member function is used to remove all of the exceptions from the master event.
CXTPCalendarRecurrencePattern::GetOccurrences
virtual BOOL GetOccurrences(CXTPCalendarEvents *pEventsArray, COleDateTime dtStart, COleDateTime dtEnd, CXTPCalendarEvent *pMasterEvent)
This member function is used to obtain the occurrence dates from the pattern in the given interval.
CXTPCalendarRecurrencePattern::GetEndOccurrenceTime
virtual COleDateTime GetEndOccurrenceTime(COleDateTime dtOccurrenceStartDate) const
Call this member function to get the occurrence end date-time by its start time.
CXTPCalendarRecurrencePattern::SetPatternEndDate
virtual void SetPatternEndDate(COleDateTime dtEnd)
This member function is used to set the new end pattern date.
CXTPCalendarRecurrencePattern::SetPatternEnd
virtual void SetPatternEnd(const XTP_CALENDAR_PATTERN_END &patternEnd)
Call this method to set the end pattern value.
CXTPCalendarRecurrencePattern::SetException
virtual BOOL SetException(CXTPCalendarEvent *pException, CXTPCalendarEvent *pMasterEventToUpdate=NULL)
This member function is used to add an exception to the master event.
CXTPCalendarRecurrencePattern::GetPatternEnd
virtual const XTP_CALENDAR_PATTERN_END & GetPatternEnd() const
Call this method to retrieve the end pattern value.
Definition XTPCalendarRecurrencePattern.h:1021
CXTPCalendarRecurrencePattern::GetUseEndMethod
virtual XTPCalendarPatternEnd GetUseEndMethod() const
Call this method to retrieve the value of the "use end" flag.
Definition XTPCalendarRecurrencePattern.h:1050
CXTPCalendarRecurrencePattern::ClonePattern
virtual CXTPCalendarRecurrencePatternPtr ClonePattern()
This member function is used to obtain a pointer to the read-write copy of the pattern object.
CXTPCalendarRecurrencePattern::SetNoEndDate
virtual void SetNoEndDate()
This member function is used to reset the pattern end date.
Definition XTPCalendarRecurrencePattern.h:1046
CXTPCalendarRecurrencePattern::SetStartTime
virtual void SetStartTime(COleDateTime dtStart)
This member function is used to set the new start date and time.
Definition XTPCalendarRecurrencePattern.h:1000
CXTPCalendarReminderForOccurrenceArray
This class implements a collection of CXTPCalendarReminderForOccurrence objects as well as some commo...
Definition XTPCalendarRecurrencePattern.h:94
CXTPCalendarReminderForOccurrenceArray::UpdateOccIfNeedEx
static int AFX_CDECL UpdateOccIfNeedEx(CXTPCalendarEvent *pOccEvent, const CXTPCalendarReminderForOccurrence *pOccRmdData, CXTPCalendarRecurrencePattern *pPattern)
Updates occurrence custom properties with the values from the provided CXTPCalendarReminderForOccurre...
CXTPCalendarReminderForOccurrenceArray::Save
BOOL Save(CXTPCalendarCustomProperties *pProps, CXTPCalendarRecurrencePattern *pPattern)
Saves an array of occurrences information to the Calendar Custom Properties object.
CXTPCalendarReminderForOccurrenceArray::Find
int Find(CXTPCalendarEvent *pOccEvent) const
Finds an index of the occurrence event.
CXTPCalendarReminderForOccurrenceArray::Find
int Find(DATE dtOccStartTime, DATE dtOccEndTime) const
Finds an index of the occurrence event by its start and end time.
CXTPCalendarReminderForOccurrenceArray::~CXTPCalendarReminderForOccurrenceArray
virtual ~CXTPCalendarReminderForOccurrenceArray()
Default collection destructorparameteparam.
CXTPCalendarReminderForOccurrenceArray::UpdateOccIfNeed
int UpdateOccIfNeed(CXTPCalendarEvent *pOccEvent, CXTPCalendarRecurrencePattern *pPattern)
Updates occurrence custom properties with the values from the array if the necessary one is found the...
CXTPCalendarReminderForOccurrenceArray::ClearProperties
static void AFX_CDECL ClearProperties(CXTPCalendarCustomProperties *pProps)
An utility method which clears all occurrences custom properties which was previously set by Save met...
CXTPCalendarReminderForOccurrenceArray::CXTPCalendarReminderForOccurrenceArray
CXTPCalendarReminderForOccurrenceArray()
Default collection constructor.
CXTPCalendarReminderForOccurrenceArray::Load
BOOL Load(CXTPCalendarCustomProperties *pProps)
Loads an array of occurrences information from the Calendar Custom Properties object.
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72
XTP_CALENDAR_PATTERN_END
This structure describes parameters of the end of the recurrence pattern type.
Definition XTPCalendarDefines.h:1102
XTP_CALENDAR_PATTERN_END::m_nUseEnd
XTPCalendarPatternEnd m_nUseEnd
End type.
Definition XTPCalendarDefines.h:1155
XTP_CALENDAR_PATTERN_END::m_dtPatternEndDate
COleDateTime m_dtPatternEndDate
End date.
Definition XTPCalendarDefines.h:1157
XTP_CALENDAR_PATTERN_END::m_nEndAfterOccurrences
int m_nEndAfterOccurrences
End number of occurrences.
Definition XTPCalendarDefines.h:1158
XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_DAILY
Defines a group of parameters to describe the Daily pattern.
Definition XTPCalendarRecurrencePattern.h:246
XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_DAILY::bEveryWeekDayOnly
BOOL bEveryWeekDayOnly
Flag determines if the event occurs every week day.
Definition XTPCalendarRecurrencePattern.h:247
XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_DAILY::nIntervalDays
int nIntervalDays
Event occurs every nIntervalDays days beginning from a start date.
Definition XTPCalendarRecurrencePattern.h:248
XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_MONTHLY
Defines a group of parameters to describe the Month pattern.
Definition XTPCalendarRecurrencePattern.h:267
XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_MONTHLY::nDayOfMonth
int nDayOfMonth
Determines the day of the month when an event occurs.
Definition XTPCalendarRecurrencePattern.h:270
XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_MONTHLY::nIntervalMonths
int nIntervalMonths
Event occurs every nIntervalMonths with the first month beginning from the start date.
Definition XTPCalendarRecurrencePattern.h:268
XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_MONTHNTH
Defines a group of parameters to describe the Month pattern.
Definition XTPCalendarRecurrencePattern.h:278
XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_MONTHNTH::nWhichDay
int nWhichDay
Determines the day of the month or nth order of day.
Definition XTPCalendarRecurrencePattern.h:281
XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_MONTHNTH::nIntervalMonths
int nIntervalMonths
Event occurs every nIntervalMonths month beginning from start date.
Definition XTPCalendarRecurrencePattern.h:279
XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_MONTHNTH::nWhichDayMask
int nWhichDayMask
Weekday code.
Definition XTPCalendarRecurrencePattern.h:282
XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_WEEKLY
Defines a group of parameters to describe the Weekly pattern.
Definition XTPCalendarRecurrencePattern.h:256
XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_WEEKLY::nDayOfWeekMask
int nDayOfWeekMask
Determines the days of the week when an event occurs.
Definition XTPCalendarRecurrencePattern.h:259
XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_WEEKLY::nIntervalWeeks
int nIntervalWeeks
Event occurs every nIntervalWeeks with the first week beginning from a start date.
Definition XTPCalendarRecurrencePattern.h:257
XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_YEARLY
Defines a group of parameters to describe the Year pattern.
Definition XTPCalendarRecurrencePattern.h:289
XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_YEARLY::nDayOfMonth
int nDayOfMonth
The day of month that the event occurs on.
Definition XTPCalendarRecurrencePattern.h:291
XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_YEARLY::nMonthOfYear
int nMonthOfYear
The month of every year that the event occurs on.
Definition XTPCalendarRecurrencePattern.h:290
XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_YEARNTH
Defines a group of parameters to describe the Year pattern.
Definition XTPCalendarRecurrencePattern.h:298
XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_YEARNTH::nWhichDay
int nWhichDay
Determines the day of the month or the nth order of the day.
Definition XTPCalendarRecurrencePattern.h:299
XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_YEARNTH::nMonthOfYear
int nMonthOfYear
Month of the year.
Definition XTPCalendarRecurrencePattern.h:301
XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_YEARNTH::nWhichDayMask
int nWhichDayMask
Weekday code.
Definition XTPCalendarRecurrencePattern.h:300
XTP_CALENDAR_RECURRENCE_OPTIONS
This structure defines a set of Recurrence Pattern options and is used by a CXTPRecurrencePattern to ...
Definition XTPCalendarRecurrencePattern.h:239
XTP_CALENDAR_RECURRENCE_OPTIONS::m_Monthly
PATTERN_MONTHLY m_Monthly
Options for Monthly Recurrence type.
Definition XTPCalendarRecurrencePattern.h:336
XTP_CALENDAR_RECURRENCE_OPTIONS::m_Weekly
PATTERN_WEEKLY m_Weekly
Options for Weekly Recurrence type.
Definition XTPCalendarRecurrencePattern.h:335
XTP_CALENDAR_RECURRENCE_OPTIONS::m_nRecurrenceType
XTPCalendarEventRecurrenceType m_nRecurrenceType
Recurrence type, See Also: XTPCalendarEventRecurrenceType.
Definition XTPCalendarRecurrencePattern.h:329
XTP_CALENDAR_RECURRENCE_OPTIONS::m_Yearly
PATTERN_YEARLY m_Yearly
Options for Yearly Recurrence type.
Definition XTPCalendarRecurrencePattern.h:338
XTP_CALENDAR_RECURRENCE_OPTIONS::m_YearNth
PATTERN_YEARNTH m_YearNth
Options for YearNth Recurrence type.
Definition XTPCalendarRecurrencePattern.h:339
XTP_CALENDAR_RECURRENCE_OPTIONS::m_MonthNth
PATTERN_MONTHNTH m_MonthNth
Options for MonthNth Recurrence type.
Definition XTPCalendarRecurrencePattern.h:337
XTP_CALENDAR_RECURRENCE_OPTIONS::GetData
void GetData(long &rnData1, long &rnData2, long &rnData3, long &rnData4) const
Saves this object data as 4 long values.
Definition XTPCalendarRecurrencePattern.h:356
XTP_CALENDAR_RECURRENCE_OPTIONS::XTP_CALENDAR_RECURRENCE_OPTIONS
XTP_CALENDAR_RECURRENCE_OPTIONS()
Default class constructor.
Definition XTPCalendarRecurrencePattern.h:309
XTP_CALENDAR_RECURRENCE_OPTIONS::operator=
const XTP_CALENDAR_RECURRENCE_OPTIONS & operator=(const XTP_CALENDAR_RECURRENCE_OPTIONS &rSrc)
Copy operator.
Definition XTPCalendarRecurrencePattern.h:322
XTP_CALENDAR_RECURRENCE_OPTIONS::m_Daily
PATTERN_DAILY m_Daily
Options for Daily Recurrence type.
Definition XTPCalendarRecurrencePattern.h:334
XTP_CALENDAR_RECURRENCE_OPTIONS::SetData
void SetData(long nData1, long nData2, long nData3, long nData4)
Restore this object data from 4 long values previously retrieved using GetData() member function.
Definition XTPCalendarRecurrencePattern.h:379


Toolkit Pro: Member List

CXTPButtonThemeNativeWindows11 Member List

This is the complete list of members for CXTPButtonThemeNativeWindows11, including all inherited members.

CXTPButtonTheme() | CXTPButtonTheme |
CXTPButtonThemeNativeWindows11() | CXTPButtonThemeNativeWindows11 |
CXTPButtonThemeUltraFlat() | CXTPButtonThemeUltraFlat |
CXTPCmdTarget() | CXTPCmdTarget |
CXTPControlTheme() | CXTPControlTheme |
DrawButton(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
DrawButtonBackground(CDC *pDC, CXTPButton *pButton) | CXTPButtonThemeOffice2013 | virtual
DrawButtonText(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme |
DrawButtonVisualStyleBackground(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
DrawCheckBoxMark(CDC *pDC, CXTPButton *pButton) | CXTPButtonThemeOffice2013 | virtual
DrawFocusRect(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
DrawGroupBox(CDC *pDC, CXTPButton *pButton) | CXTPButtonThemeOffice2013 | virtual
DrawPushButtonDropDown(CDC *pDC, CXTPButton *pButton) | CXTPButtonThemeOffice2013 | virtual
DrawPushButtonIcon(CDC *pDC, CXTPButton *pButton) | CXTPButtonThemeOffice2013 | virtual
DrawPushButtonText(CDC *pDC, CXTPButton *pButton) | CXTPButtonThemeOffice2013 | virtual
DrawRadioButtonMark(CDC *pDC, CXTPButton *pButton) | CXTPButtonThemeOffice2013 | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetTextColor(CXTPButton *pButton) | CXTPButtonThemeOffice2013 | virtual
GetThemeStyle() const | CXTPControlTheme |
m_crBack | CXTPButtonTheme |
m_crBackChecked | CXTPButtonThemeUltraFlat |
m_crBackDisabled | CXTPButtonThemeOffice2013 | protected
m_crBackHilite | CXTPButtonThemeUltraFlat |
m_crBackPushed | CXTPButtonThemeUltraFlat |
m_crBorder | CXTPButtonThemeOffice2013 | protected
m_crBorder3DHilite | CXTPButtonTheme |
m_crBorder3DShadow | CXTPButtonTheme |
m_crBorderDefault | CXTPButtonThemeOffice2013 | protected
m_crBorderDisabled | CXTPButtonThemeOffice2013 | protected
m_crBorderHilite | CXTPButtonTheme |
m_crBorderPushed | CXTPButtonThemeUltraFlat |
m_crBorderShadow | CXTPButtonTheme |
m_crCheckMark | CXTPButtonThemeUltraFlat |
m_crMark | CXTPButtonThemeOffice2013 | protected
m_crMarkDisabled | CXTPButtonThemeOffice2013 | protected
m_crMarkHilite | CXTPButtonThemeOffice2013 | protected
m_crMarkPushed | CXTPButtonThemeOffice2013 | protected
m_crText | CXTPButtonTheme |
m_crTextCheck | CXTPButtonTheme |
m_crTextDisabled | CXTPButtonTheme |
m_crTextHilite | CXTPButtonThemeUltraFlat |
m_crTextPushed | CXTPButtonThemeUltraFlat |
m_nTheme | CXTPControlTheme | protected
RefreshMetrics(CXTPButton *pButton) | CXTPButtonThemeNativeWindows11 | virtual
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static
~CXTPButtonTheme() | CXTPButtonTheme | virtual


Toolkit Pro: Member List

CXTPChartPieDiagram Member List

This is the complete list of members for CXTPChartPieDiagram, including all inherited members.

CalculateSeriesLayout(CXTPChartDeviceContext *pDC, CXTPChartDiagramView *pView) | CXTPChartPieDiagramBase< BaseDiagram > | virtual
CreateView(CXTPChartDeviceContext *pDC, CXTPChartElementView *pParent) | CXTPChartPieDiagram | virtual
CXTPChartPieDiagram() | CXTPChartPieDiagram |
CXTPChartPieDiagramBase() | CXTPChartPieDiagramBase< BaseDiagram > | protected


Toolkit Pro: Member List

CXTPSyntaxEditReplaceStringCommand Member List

This is the complete list of members for CXTPSyntaxEditReplaceStringCommand, including all inherited members.

CXTPSyntaxEditBufferCommand(CXTPSyntaxEditBufferManager *pMgr, LPCTSTR szText, const XTP_EDIT_LINECOL &lcFrom, const XTP_EDIT_LINECOL &lcTo) | CXTPSyntaxEditBufferCommand | protected
CXTPSyntaxEditCommand() | CXTPSyntaxEditCommand | protected
CXTPSyntaxEditReplaceStringCommand(CXTPSyntaxEditBufferManager *pMgr, LPCTSTR szText, LPCTSTR szReplacedText, const XTP_EDIT_LINECOL &lcFrom, const XTP_EDIT_LINECOL &lcTo) | CXTPSyntaxEditReplaceStringCommand |
DoDeleteText(XTP_EDIT_LINECOL &lcFrom, XTP_EDIT_LINECOL &lcTo, CXTPSyntaxEditCtrl *pEditCtrl) | CXTPSyntaxEditBufferCommand | protected
DoInsertText(XTP_EDIT_LINECOL &lcFrom, XTP_EDIT_LINECOL &lcTo, CXTPSyntaxEditCtrl *pEditCtrl) | CXTPSyntaxEditBufferCommand | protected
DoReplaceText(LPCTSTR szText, XTP_EDIT_LINECOL &lcFrom, XTP_EDIT_LINECOL &lcTo, CXTPSyntaxEditCtrl *pEditCtrl) | CXTPSyntaxEditReplaceStringCommand | protected
Execute(XTP_EDIT_LINECOL &lcFrom, XTP_EDIT_LINECOL &lcTo, CXTPSyntaxEditCtrl *pEditCtrl) | CXTPSyntaxEditReplaceStringCommand | virtual
GetCommandText() const | CXTPSyntaxEditCommand | virtual
GetDataSize() const | CXTPSyntaxEditReplaceStringCommand | virtual
m_lcFrom | CXTPSyntaxEditBufferCommand | protected
m_lcTo | CXTPSyntaxEditBufferCommand | protected
m_pBufferMgr | CXTPSyntaxEditBufferCommand | protected
m_strCommandText | CXTPSyntaxEditCommand | protected
m_strReplacedText | CXTPSyntaxEditReplaceStringCommand | protected
m_strText | CXTPSyntaxEditBufferCommand | protected
SetCommandText(LPCTSTR szText) | CXTPSyntaxEditCommand | virtual
SetPositionInternally(CXTPSyntaxEditCtrl *pEditCtrl, const XTP_EDIT_LINECOL &lcPos) | CXTPSyntaxEditCommand | protectedstatic
UnExecute(XTP_EDIT_LINECOL &lcFrom, XTP_EDIT_LINECOL &lcTo, CXTPSyntaxEditCtrl *pEditCtrl) | CXTPSyntaxEditReplaceStringCommand | virtual
~CXTPSyntaxEditBufferCommand() | CXTPSyntaxEditBufferCommand | virtual
~CXTPSyntaxEditCommand() | CXTPSyntaxEditCommand | virtual
~CXTPSyntaxEditReplaceStringCommand() | CXTPSyntaxEditReplaceStringCommand | virtual


Toolkit Pro: Member List

CXTPChartPyramidSeriesLabelBase Member List

This is the complete list of members for CXTPChartPyramidSeriesLabelBase, including all inherited members.

CreateView(CXTPChartDeviceContext *pDC, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView)=0 | CXTPChartPyramidSeriesLabelBase | protectedpure virtual
CXTPChartElement() | CXTPChartElement |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartPyramidSeriesLabelBase() | CXTPChartPyramidSeriesLabelBase |
CXTPChartSeriesLabel() | CXTPChartSeriesLabel |
DoPropExchange(CXTPPropExchange *pPX) | CXTPChartPyramidSeriesLabelBase | virtual
GetAntialiasing() const | CXTPChartSeriesLabel | virtual
GetAppearance() const | CXTPChartElement |
GetBackColor() const | CXTPChartSeriesLabel |
GetContent() const | CXTPChartElement |
GetFont() const | CXTPChartSeriesLabel | virtual
GetFormat() const | CXTPChartSeriesLabel |
GetLineColor() const | CXTPChartSeriesLabel |
GetLineLength() const | CXTPChartSeriesLabel |
GetOwner() const | CXTPChartElement |
GetPosition() const | CXTPChartPyramidSeriesLabelBase |
GetShowLines() const | CXTPChartSeriesLabel |
GetStyle() const | CXTPChartPyramidSeriesLabelBase |
GetTextColor() const | CXTPChartSeriesLabel |
GetTransparency() const | CXTPChartSeriesLabel |
Is3D() const | CXTPChartObject |
IsInside() const | CXTPChartPyramidSeriesLabelBase |
IsVisible() const | CXTPChartSeriesLabel |
m_bAntialiasing | CXTPChartSeriesLabel | protected
m_bShowLines | CXTPChartSeriesLabel | protected
m_bVisible | CXTPChartSeriesLabel | protected
m_clrBackColor | CXTPChartSeriesLabel | protected
m_clrLineColor | CXTPChartSeriesLabel | protected
m_clrTextColor | CXTPChartSeriesLabel | protected
m_nLineLength | CXTPChartSeriesLabel | protected
m_nPosition | CXTPChartPyramidSeriesLabelBase | protected
m_nTransparency | CXTPChartSeriesLabel | protected
m_pBorder | CXTPChartSeriesLabel | protected
m_pFont | CXTPChartSeriesLabel | protected
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartElement | virtual
Release() | CXTPChartElement | virtual
SetAntialiasing(BOOL bAntialiasing) | CXTPChartSeriesLabel |
SetBackColor(const CXTPChartColor &clrBackColor) | CXTPChartSeriesLabel |
SetFont(CXTPChartFont *pFont) | CXTPChartSeriesLabel |
SetFormat(LPCTSTR lpszFormat) | CXTPChartSeriesLabel |
SetLineColor(const CXTPChartColor &clrBackColor) | CXTPChartSeriesLabel |
SetLineLength(int nLineLength) | CXTPChartSeriesLabel |
SetPosition(XTPChartPyramidLabelPosition nPosition) | CXTPChartPyramidSeriesLabelBase |
SetShowLines(BOOL bShowLines) | CXTPChartSeriesLabel |
SetTextColor(const CXTPChartColor &clrTextColor) | CXTPChartSeriesLabel |
SetTransparency(int nTransparency) | CXTPChartSeriesLabel |
SetVisible(BOOL bVisible) | CXTPChartSeriesLabel |
~CXTPChartElement() | CXTPChartElement | virtual
~CXTPChartPyramidSeriesLabelBase() | CXTPChartPyramidSeriesLabelBase | virtual
~CXTPChartSeriesLabel() | CXTPChartSeriesLabel | virtual


Toolkit Pro: XTPTabClientDraggingContents.h Source File

  • Source
  • CommandBars
  • TabClient
XTPTabClientDraggingContents.h
Go to the documentation of this file.
1
23#if !defined(__XTPTABCLIENTDRAGGINGCONTENTS_H__)
24# define __XTPTABCLIENTDRAGGINGCONTENTS_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
37class CXTPTabClientDraggingContents : public CWnd
38{
39 DECLARE_DYNCREATE(CXTPTabClientDraggingContents);
40
41 CXTPTabClientDraggingContents();
42 CXTPTabClientDraggingContents(CXTPTabClientWnd* pTabClientWnd);
43
44public:
49 virtual ~CXTPTabClientDraggingContents();
50
57 BOOL Create();
58
59 using CWnd::Create;
60
69 int GetHeight() const;
70
79 int GetWidth() const;
80
81private:
82 int m_Height;
83 int m_Width;
84 int m_imgHeight;
85 int m_imgWidth;
86 int m_borderX;
87 int m_borderY;
89 DECLARE_MESSAGE_MAP()
90
91 //{{AFX_MSG(CXTPDockingPaneContextStickerWnd)
92 afx_msg BOOL OnEraseBkgnd(CDC* pDC);
93 afx_msg void OnPaint();
94 //}}AFX_MSG
97 CXTPTabClientWnd* m_pTarget;
98 CBitmap m_bitmap;
99};
100
101AFX_INLINE int CXTPTabClientDraggingContents::GetHeight() const
102{
103 return m_Height;
104}
105
106AFX_INLINE int CXTPTabClientDraggingContents::GetWidth() const
107{
108 return m_Width;
109}
110
112# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
113#endif // !defined(__XTPTABCLIENTDRAGGINGCONTENTS_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPTabClientDraggingContents
Managers tab client dragging contents.
Definition XTPTabClientDraggingContents.h:38
CXTPTabClientDraggingContents::GetWidth
int GetWidth() const
Obtains contents width.
Definition XTPTabClientDraggingContents.h:106
CXTPTabClientDraggingContents::~CXTPTabClientDraggingContents
virtual ~CXTPTabClientDraggingContents()
Performs resource cleanup on object destruction.
CXTPTabClientDraggingContents::GetHeight
int GetHeight() const
Obtains contents height.
Definition XTPTabClientDraggingContents.h:101
CXTPTabClientDraggingContents::Create
BOOL Create()
Create the contents object.
CXTPTabClientWnd
CXTPTabClientWnd is a CWnd derived class.
Definition XTPTabClientWnd.h:383


Toolkit Pro: Member List

CXTPDockingPaneTabTheme2013 Member List

This is the complete list of members for CXTPDockingPaneTabTheme2013, including all inherited members.

AdjustClientRect(CXTPTabManager *pTabManager, CRect &rcClient) | CXTPTabPaintManagerTheme | virtual
CXTPDockingPaneTabTheme2013() | CXTPDockingPaneTabTheme2013 |
CXTPTabPaintManagerTheme() | CXTPTabPaintManagerTheme |
CXTPTabThemeFlat() | CXTPTabThemeFlat | inline
DrawSingleButton(CDC *pDC, CXTPTabManagerItem *pItem) | CXTPDockingPaneTabTheme2013 | virtual
DrawTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl) | CXTPTabPaintManagerTheme | virtual
DrawText(CDC *pDC, CXTPTabManager *pManager, const CString &str, LPRECT lpRect, UINT nFormat) | CXTPTabPaintManagerTheme | virtual
DrawWorkspacePart(CDC *pDC, LPRECT lpRect, XTPTabWorkspacePart workspacePart) | CXTPTabPaintManagerTheme | virtual
FillButton(CDC *pDC, CXTPTabManagerItem *pItem, LPPOINT pts, int nCount, XTPTabPosition tabPosition, BOOL bAbsolute=FALSE) | CXTPTabPaintManagerTheme |
FillTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl) | CXTPTabThemeFlat | virtual
GetButtonDrawRect(const CXTPTabManagerItem *pItem) | CXTPTabPaintManagerTheme | virtual
GetButtonHeight(const CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetButtonLength(CDC *pDC, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerTheme | virtual
GetClientMargin() | CXTPTabPaintManagerTheme | virtual
GetClientRect(CRect rcControl, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetColorSet() const | CXTPTabPaintManagerTheme |
GetDefaultColorSet() | CXTPTabThemeFlat | inlinevirtual
GetHeaderClipBox(CDC *pDC, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetHeaderHeight(CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme |
GetHeaderMargin() | CXTPTabPaintManagerTheme | virtual
GetHeaderRect(CRect rcControl, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetSupportedColorSets() | CXTPTabPaintManagerTheme | inlinevirtual
m_bButtonsReverseZOrder | CXTPTabPaintManagerTheme | protected
m_nButtonHeight | CXTPTabPaintManagerTheme | protected
m_nRowMargin | CXTPTabPaintManagerTheme |
m_pPaintManager | CXTPTabPaintManagerTheme | protected
m_rcHeaderMargin | CXTPTabPaintManagerTheme |
RefreshMetrics() | CXTPDockingPaneTabTheme2013 | virtual
RepositionTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcClient) | CXTPTabPaintManagerTheme | virtual
~CXTPTabPaintManagerTheme() | CXTPTabPaintManagerTheme | virtual


Toolkit Pro: Member List

CXTPSkinObjectReBar Member List

This is the complete list of members for CXTPSkinObjectReBar, including all inherited members.

CXTPSkinObject() | CXTPSkinObject | protected
CXTPSkinObjectFrame() | CXTPSkinObjectFrame |
CXTPSkinObjectReBar() | CXTPSkinObjectReBar |
GetAccessCriticalSection() const | CXTPSynchronized | inline
GetBorders() const | CXTPSkinObjectFrame |
GetCaptionButtons() | CXTPSkinObjectFrame |
GetClassName() const | CXTPSkinObject |
GetClientBrush(CDC *pDC) | CXTPSkinObjectFrame | virtual
GetColor(int nIndex) const | CXTPSkinObject |
GetMetrics() const | CXTPSkinObject |
GetSkinClass() const | CXTPSkinObject |
GetSkinManager() const | CXTPSkinObject |
IsActive() const | CXTPSkinObjectFrame |
m_arrButtons | CXTPSkinObjectFrame | protected
m_bActive | CXTPSkinObjectFrame | protected
m_bActiveX | CXTPSkinObject | protected
m_bLockFrameDraw | CXTPSkinObjectFrame |
m_bMDIClient | CXTPSkinObjectFrame | protected
m_bRegionChanged | CXTPSkinObjectFrame | protected
m_bWindowsForms | CXTPSkinObject | protected
m_dwDialogTexture | CXTPSkinObjectFrame |
m_dwExStyle | CXTPSkinObjectFrame | protected
m_dwStyle | CXTPSkinObjectFrame | protected
m_pButtonHot | CXTPSkinObjectFrame | protected
m_pButtonPressed | CXTPSkinObjectFrame | protected
m_pManager | CXTPSkinObject | protected
m_pOldWndProc | CXTPSkinObject | protected
m_pSBTrack | CXTPSkinObjectFrame | protected
m_rcBorders | CXTPSkinObjectFrame | protected
m_spi | CXTPSkinObjectFrame | protected
m_strClassName | CXTPSkinObject | protected
m_szFrameRegion | CXTPSkinObjectFrame | protected
OnHookAttached(LPCREATESTRUCT lpcs, BOOL bAuto) | CXTPSkinObjectFrame | protectedvirtual
OnHookDetached(BOOL bAuto) | CXTPSkinObjectFrame | protectedvirtual
OnSkinChanged(BOOL bPrevState, BOOL bNewState) | CXTPSkinObjectFrame | protectedvirtual
RedrawScrollBar(int nBar) | CXTPSkinObjectFrame |
RefreshMetrics() | CXTPSkinObjectFrame | protectedvirtual
~CXTPSkinObject() | CXTPSkinObject | protected
~CXTPSkinObjectFrame() | CXTPSkinObjectFrame | virtual
~CXTPSkinObjectReBar() | CXTPSkinObjectReBar | virtual


Toolkit Pro: Member List

CXTPChartDiagram2DSeriesLabelView Member List

This is the complete list of members for CXTPChartDiagram2DSeriesLabelView, including all inherited members.

AddChildView(CXTPChartElementView *pChildView) | CXTPChartElementView |
CreateDeviceCommand(CXTPChartDeviceContext *pDC) | CXTPChartDiagram2DSeriesLabelView | virtual
CreateDeviceCommand(CXTPChartDeviceContext *pDC, CXTPChartPointF ptCenterPoint) | CXTPChartDiagram2DSeriesLabelView | virtual
CreateDeviceCommand(CXTPChartDeviceContext *pDC, CXTPChartPointF ptCenterPoint, const CXTPChartString &text) | CXTPChartDiagram2DSeriesLabelView | virtual
CreateDeviceCommand(CXTPChartDeviceContext *pDC, const CXTPChartPointF &ptAnchorPoint, double dAnchorAngle, const CXTPChartString &text) | CXTPChartDiagram2DSeriesLabelView | virtual
CXTPChartDiagram2DSeriesLabelView(CXTPChartSeriesLabel *pLabel, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView) | CXTPChartDiagram2DSeriesLabelView |
CXTPChartElementView(CXTPChartElementView *pParentView) | CXTPChartElementView |
CXTPChartElementView(CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartElementView |
CXTPChartElementView(CXTPChartContainer *pContainer) | CXTPChartElementView |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
GetAnchorPoint() const | CXTPChartDiagram2DSeriesLabelView | virtual
GetAt(int nIndex) const | CXTPChartElementView |
GetBounds() const | CXTPChartElementView |
GetBounds(BOOL bIncludingChildren) const | CXTPChartElementView |
GetChildren() | CXTPChartElementView |
GetCount() const | CXTPChartElementView |
GetParentView() const | CXTPChartElementView |
Is3D() const | CXTPChartObject |
m_arrChildren | CXTPChartElementView | protected
m_pContainer | CXTPChartElementView | protected
m_pParentView | CXTPChartElementView | protected
m_rcBounds | CXTPChartElementView | protected
~CXTPChartElementView() | CXTPChartElementView | protectedvirtual


Toolkit Pro: XTPControl.h Source File

  • Source
  • CommandBars
XTPControl.h
Go to the documentation of this file.
1
23#if !defined(__XTPCONTROL_H__)
24# define __XTPCONTROL_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPControl;
34class CXTPControls;
35class CXTPCommandBar;
36class CXTPImageManager;
37class CXTPImageManagerIcon;
38class CXTPPaintManager;
39class CXTPPropExchange;
40class CXTPRibbonGroup;
41class CXTPCommandBarList;
42class CXTPCommandBars;
43struct XTP_COMMANDBARS_PROPEXCHANGE_PARAM;
44
45class CXTPControlActions;
46
52class _XTP_EXT_CLASS CXTPControlAction : public CXTPCmdTarget
53{
55 DECLARE_DYNAMIC(CXTPControlAction)
57protected:
63 CXTPControlAction(CXTPControlActions* pActions);
64
69 ~CXTPControlAction();
70
71public:
79 void SetCaption(LPCTSTR lpszCaption);
80
88 void SetCaption(UINT nIDCaption);
89
96 int GetID() const;
97
104 CString GetCaption() const;
105
113 void SetDescription(LPCTSTR lpszDescription);
114
133 void SetPrompt(LPCTSTR lpszPrompt);
134
141 CString GetDescription() const;
142
148 void SetIconId(int nId);
149
156 int GetIconId() const;
157
163 void SetHelpId(int nId);
164
171 int GetHelpId() const;
172
180 void SetEnabled(BOOL bEnabled);
181
188 BOOL GetEnabled() const;
189
197 void SetChecked(BOOL bChecked);
198
205 BOOL GetChecked() const;
206
213 BOOL IsVisible() const;
214
220 void SetVisible(BOOL bVisible);
221
227 void SetTag(DWORD_PTR dwTag);
228
236 DWORD_PTR GetTag() const;
237
243 void SetCategory(LPCTSTR lpszCategory);
244
251 CString GetCategory() const;
252
260 void SetTooltip(LPCTSTR lpszTooltip);
261
268 CString GetTooltip() const;
269
275 void SetShortcutText(LPCTSTR lpszShortcutText);
276
283 CString GetShortcutText() const;
284
290 void SetCustomShortcutText(LPCTSTR lpszCustomShortcutText);
291
298 CString GetCustomShortcutText() const;
299
305 void SetKeyboardTip(LPCTSTR lpszKeyboardTip);
306
313 CString GetKeyboardTip() const;
314
321 void SetEditHint(LPCTSTR lpszEditHint);
322
330 CString GetEditHint() const;
331
365 void SetKey(LPCTSTR lpszKey);
366
401 CString GetKey() const;
402
409 CXTPCommandBars* GetCommandBars() const;
410
411public:
419 CXTPControl* GetControl(int nIndex) const;
420
427 int GetCount() const;
428
429public:
434 void RedrawControls();
435
440 void RepositionControls();
441
442public:
448 void DoPropExchange(CXTPPropExchange* pPX);
449
450protected:
458 void AddControl(CXTPControl* pControl);
459
467 void RemoveControl(CXTPControl* pControl);
468
473 void OnRemoved();
474
482 void OnChanged(int nProperty);
483
491 void OnChanging(int nProperty);
492
493# ifdef _XTP_COMMANDBARS_ACTIVEX
496 DECLARE_DISPATCH_MAP()
497
498 DECLARE_OLETYPELIB_EX(CXTPControlAction);
499
500 afx_msg void OleSetCaption(LPCTSTR lpszCaption);
501 afx_msg BSTR OleGetCaption();
502 BSTR OleGetEditHint();
503 COleVariant m_oleTag;
504
505 enum
506 {
507 dispidCaption = 4L,
508 dispidDescriptionText = 5L,
509 dispidId = 6L,
510 dispidParameter = 8L,
511 dispidShortcutText = 9L,
512 dispidTooltipText = 10L,
513 dispidVisible = 12L,
514 dispidEnabled = 13L,
515 dispidChecked = 14L,
516 dispidIconId = 15L,
517 dispidCategory = 19L,
518 };
519
521# endif
522
523public:
524 CCmdTarget* m_pTarget;
526protected:
527 DWORD_PTR m_nTag;
528 int m_nId;
529 int m_nIconId;
530 int m_nHelpId;
531 BOOL m_bEnabled;
532 BOOL m_bChecked;
533 BOOL m_bVisible;
534 CString m_strCaption;
535 CString m_strTooltipText;
536 CString m_strDescriptionText;
537 CString m_strCategory;
538 CString m_strShortcutText;
539 CString m_strEditHint;
540 CString m_strKeyboardTip;
541 CString m_strKey;
542 CString m_strCustomShortcutText;
544 CArray<CXTPControl*, CXTPControl*> m_arrControls;
545 CXTPControlActions* m_pActions;
547private:
548 friend class CXTPControl;
549 friend class CXTPControls;
550 friend class CXTPControlActions;
551};
552
553AFX_INLINE void CXTPControlAction::SetShortcutText(LPCTSTR lpszShortcutText)
554{
555 m_strShortcutText = lpszShortcutText;
556}
557AFX_INLINE CString CXTPControlAction::GetShortcutText() const
558{
559 return m_strShortcutText;
560}
561AFX_INLINE void CXTPControlAction::SetCustomShortcutText(LPCTSTR lpszCustomShortcutText)
562{
563 m_strCustomShortcutText = lpszCustomShortcutText;
564}
565AFX_INLINE CString CXTPControlAction::GetCustomShortcutText() const
566{
567 return m_strCustomShortcutText;
568}
569AFX_INLINE void CXTPControlAction::SetDescription(LPCTSTR lpszDescription)
570{
571 m_strDescriptionText = lpszDescription;
572}
573AFX_INLINE CString CXTPControlAction::GetDescription() const
574{
575 return m_strDescriptionText;
576}
577AFX_INLINE CString CXTPControlAction::GetTooltip() const
578{
579 return m_strTooltipText;
580}
581AFX_INLINE void CXTPControlAction::SetTooltip(LPCTSTR lpszTooltip)
582{
583 m_strTooltipText = lpszTooltip;
584}
585AFX_INLINE CString CXTPControlAction::GetKey() const
586{
587 return m_strKey;
588}
589AFX_INLINE void CXTPControlAction::SetKey(LPCTSTR lpszKey)
590{
591 m_strKey = lpszKey;
592}
593AFX_INLINE CString CXTPControlAction::GetCaption() const
594{
595 return m_strCaption.IsEmpty() ? m_strTooltipText : m_strCaption;
596}
597AFX_INLINE CString CXTPControlAction::GetEditHint() const
598{
599 return m_strEditHint;
600}
601AFX_INLINE int CXTPControlAction::GetID() const
602{
603 return m_nId;
604}
605AFX_INLINE void CXTPControlAction::SetIconId(int nId)
606{
607 if (m_nIconId != nId)
608 {
609 m_nIconId = nId;
610 RedrawControls();
611 }
612}
613AFX_INLINE int CXTPControlAction::GetIconId() const
614{
615 return m_nIconId <= 0 ? m_nId : m_nIconId;
616}
617AFX_INLINE void CXTPControlAction::SetHelpId(int nId)
618{
619 m_nHelpId = nId;
620}
621AFX_INLINE int CXTPControlAction::GetHelpId() const
622{
623 return m_nHelpId <= 0 ? m_nId : m_nHelpId;
624}
625
626AFX_INLINE void CXTPControlAction::SetEnabled(BOOL bEnabled)
627{
628 if (m_bEnabled != bEnabled)
629 {
630 m_bEnabled = bEnabled;
631 OnChanged(0);
632 RedrawControls();
633 }
634}
635AFX_INLINE BOOL CXTPControlAction::GetChecked() const
636{
637 return m_bChecked;
638}
639AFX_INLINE void CXTPControlAction::SetChecked(BOOL bChecked)
640{
641 if (m_bChecked != bChecked)
642 {
643 m_bChecked = bChecked;
644 OnChanged(1);
645 RedrawControls();
646 }
647}
648AFX_INLINE BOOL CXTPControlAction::IsVisible() const
649{
650 return m_bVisible;
651}
652AFX_INLINE void CXTPControlAction::SetVisible(BOOL bVisible)
653{
654 if (m_bVisible != bVisible)
655 {
656 m_bVisible = bVisible;
657 OnChanged(2);
658 RepositionControls();
659 }
660}
661AFX_INLINE void CXTPControlAction::SetCategory(LPCTSTR lpszCategory)
662{
663 m_strCategory = lpszCategory;
664}
665AFX_INLINE CString CXTPControlAction::GetCategory() const
666{
667 return m_strCategory;
668}
669AFX_INLINE void CXTPControlAction::SetTag(DWORD_PTR dwTag)
670{
671 m_nTag = dwTag;
672}
673AFX_INLINE DWORD_PTR CXTPControlAction::GetTag() const
674{
675 return m_nTag;
676}
677AFX_INLINE void CXTPControlAction::SetKeyboardTip(LPCTSTR lpszKeyboardTip)
678{
679 m_strKeyboardTip = lpszKeyboardTip;
680}
681AFX_INLINE CString CXTPControlAction::GetKeyboardTip() const
682{
683 return m_strKeyboardTip;
684}
685
691class _XTP_EXT_CLASS CXTPControlActions : public CXTPCmdTarget
692{
693protected:
699 CXTPControlActions(CXTPCommandBars* pCommandBars);
700
705 ~CXTPControlActions();
706
707public:
715 CXTPControlAction* GetAt(int nIndex) const;
716
723 int GetCount() const;
724
732 CXTPControlAction* FindAction(int nId) const;
733
741 CXTPControlAction* Add(int nId);
742
751 CXTPControlAction* Add(int nId, CXTPControlAction* pAction);
752
758 void DoPropExchange(CXTPPropExchange* pPX);
759
764 void RemoveAll();
765
771 void Remove(int nId);
772
778 void CreateFromMenu(CMenu* pMenu);
779
780protected:
781# ifdef _XTP_COMMANDBARS_ACTIVEX
784 DECLARE_DISPATCH_MAP()
785 DECLARE_INTERFACE_MAP()
786
787 DECLARE_OLETYPELIB_EX(CXTPControlActions);
788 DECLARE_ENUM_VARIANT(CXTPControlActions);
789
790 afx_msg long OleGetItemCount();
791 afx_msg LPDISPATCH OleGetItem(long nIndex);
792 afx_msg LPDISPATCH OleAdd(int nId, LPCTSTR lpszCaption, LPCTSTR lpszTooltipText,
793 LPCTSTR lpszDescriptionText, LPCTSTR lpszCategory);
794
795 afx_msg LPDISPATCH OleFind(int nId);
796 afx_msg VOID OleRemove(int nId);
797
798 enum
799 {
800 dispidCount = 1L,
801 dispidAdd = 2L,
802 dispidFindControl = 4L,
803 dispidRemove = 6L,
804 };
805
807# endif
808
809protected:
815 void Insert(CXTPControlAction* pAction);
816
823 void SetActionId(CXTPControlAction* pAction, int nId);
824
825protected:
826 CArray<CXTPControlAction*, CXTPControlAction*> m_arrActions;
827 CXTPCommandBars* m_pCommandBars;
829 friend class CXTPCommandBars;
830 friend class CXTPControlAction;
831};
832
838class _XTP_EXT_CLASS CXTPControl
839 : public CXTPCmdTarget
840 , public CXTPAccessible
841{
842private:
843 class CDocTemplateMap : public CMap<UINT, UINT, BOOL, BOOL>
844 {
845 public:
846 void Copy(CDocTemplateMap& map);
847 };
848
849protected:
854 CXTPControl();
855
860 virtual ~CXTPControl();
861
862public:
875 void SetStyle(XTPButtonStyle buttonStyle);
876
883 XTPButtonStyle GetStyle() const;
884
885public:
893 void SetCaption(LPCTSTR lpszCaption);
894
902 void SetCaption(UINT nIDCaption);
903
910 virtual CString GetCaption() const;
911
917 void SetShortcutText(LPCTSTR lpszShortcutText);
918
925 CString GetShortcutText() const;
926
934 void SetDescription(LPCTSTR lpszDescription);
935
942 virtual CString GetDescription() const;
943
951 void SetTooltip(LPCTSTR lpszTooltip);
952
959 virtual CString GetTooltip() const;
960
966 void SetKeyboardTip(LPCTSTR lpszKeyboardTip);
967
974 CString GetKeyboardTip() const;
975
981 void SetCustomShortcutText(LPCTSTR lpszCustomShortcutText);
982
990 CString GetCustomShortcutText() const;
991
1002 void SetParameter(LPCTSTR lpszParameter);
1003
1012 CString GetParameter() const;
1013
1019 void SetID(int nId);
1020
1027 int GetID() const;
1028
1035 long GetIndex() const;
1036
1042 void SetIconId(int nId);
1043
1050 int GetIconId() const;
1051
1057 void SetHelpId(int nId);
1058
1065 int GetHelpId() const;
1066
1072 virtual void SetBeginGroup(BOOL bBeginGroup);
1073
1080 BOOL GetBeginGroup() const;
1081
1091 virtual void SetEnabled(BOOL bEnabled);
1092
1099 BOOL GetEnabled() const;
1100
1105 virtual void OnEnabledChanged();
1106
1116 virtual void SetChecked(BOOL bChecked);
1117
1124 BOOL GetChecked() const;
1125
1132 virtual int GetSelected() const;
1133
1140 void SetOnQuickAccess(BOOL bOnQuicAccess = FALSE);
1141
1148 BOOL IsOnQuickAccess() const;
1149
1155 virtual void SetFocused(BOOL bFocused);
1156
1163 virtual BOOL IsFocused() const;
1164
1170 void SetPressed(BOOL bPressed);
1171
1178 virtual BOOL GetPressed() const;
1179
1185 virtual void SetRect(CRect rcControl);
1186
1193 CRect GetRect() const;
1194
1201 CXTPCommandBar* GetParent() const;
1202
1212 virtual BOOL IsVisible(DWORD dwSkipFlags = 0) const;
1213
1220 virtual BOOL IsCaptionVisible() const;
1221
1228 void SetVisible(BOOL bVisible);
1229
1236 CXTPControls* GetControls() const;
1237
1256 XTPControlType GetType() const;
1257
1275 void SetFlags(DWORD dwFlags);
1276
1285 DWORD GetFlags() const;
1286
1292 void SetTag(DWORD_PTR dwTag);
1293
1301 DWORD_PTR GetTag() const;
1302
1310 virtual BOOL Compare(CXTPControl* pOther);
1311
1318 virtual CXTPCommandBar* GetCommandBar() const;
1319
1330 void SetCloseSubMenuOnClick(BOOL bCloseOnClick);
1331
1342 BOOL GetCloseSubMenuOnClick() const;
1343
1352 void SetExecuteOnPressInterval(int nExecuteOnPressInterval);
1353
1363 int GetExecuteOnPressInterval() const;
1364
1375 CXTPRibbonGroup* GetRibbonGroup() const;
1376
1383 virtual BOOL IsTransparent() const
1384 {
1385 return FALSE;
1386 }
1387
1388public:
1394 void SetHideWrap(BOOL bHide);
1395
1415 virtual void SetHideFlags(DWORD dwFlags);
1416
1431 BOOL SetHideFlag(XTPControlHideFlags dwFlag, BOOL bSet);
1432
1453 DWORD GetHideFlags() const;
1454
1461 CRect GetRowRect() const;
1462
1471 BOOL GetWrap() const;
1472
1478 void SetRowRect(CRect rcRow);
1479
1487 void SetWrap(BOOL bWrap);
1488
1495 BOOL GetExpanded() const;
1496
1503 BOOL IsCursorOver() const;
1504
1509 virtual void OnExecute();
1510
1518 virtual CSize GetSize(CDC* pDC);
1519
1525 virtual void Draw(CDC* pDC);
1526
1577 virtual void OnCalcDynamicSize(DWORD dwMode);
1578
1583 void DelayRedrawParent();
1584
1589 void DelayLayoutParent();
1590
1596 void SetCategory(LPCTSTR lpszCategory);
1597
1604 CString GetCategory() const;
1605
1612 CXTPImageManager* GetImageManager() const;
1613
1620 CXTPPaintManager* GetPaintManager() const;
1621
1629 virtual CXTPImageManagerIcon* GetImage(int nWidth = 16) const;
1630
1640 void AssignDocTemplate(UINT nIDResource);
1641
1651 void ExcludeDocTemplate(UINT nIDResource);
1652
1663 BOOL IsItemDefault() const;
1664
1674 void SetItemDefault(BOOL bDefault);
1675
1684 BOOL IsTemporary() const;
1685
1696 void Reset();
1697
1717 void SetPrompt(LPCTSTR lpszPrompt);
1718
1726 static CXTPControl* AFX_CDECL FromUI(CCmdUI* pCmdUI);
1727
1735 void SetCustomIcon(HICON hIcon);
1736
1742 virtual void DoPropExchange(CXTPPropExchange* pPX);
1743
1748 virtual void OnUnderlineActivate();
1749
1756 virtual BOOL GetPopuped() const;
1757
1763 void RedrawParent(BOOL bAnimate = TRUE);
1764
1772 LRESULT NotifySite(UINT code);
1773
1782 LRESULT NotifySite(UINT code, NMXTPCONTROL* pNM);
1783
1793 LRESULT NotifySite(CWnd* pSite, UINT code, NMXTPCONTROL* pNM);
1794
1802 virtual void SetAction(CXTPControlAction* pAction);
1803
1812 CXTPControlAction* GetAction() const;
1813
1818 virtual void OnThemeChanged();
1819
1825 virtual void SetWidth(int nWidth);
1826
1832 virtual void SetHeight(int nHeight);
1833
1842 int GetWidth() const;
1843
1852 int GetHeight() const;
1853
1860 BOOL HasDwmCompositedRect() const;
1861
1868 virtual CSize GetButtonSize() const;
1869
1877 virtual CSize GetIconSize() const;
1878
1886 void SetIconSize(CSize szIcon);
1887
1894 virtual void Copy(CXTPControl* pControl, BOOL bRecursive = FALSE);
1895
1902 virtual void OnClick(BOOL bKeyboard = FALSE, CPoint pt = CPoint(0, 0));
1903
1912 virtual BOOL IsCustomizeMovable() const;
1913
1914protected:
1923 virtual BOOL IsFocusable() const;
1924
1931 void SetIndex(int nIndex)
1932 {
1933 m_nIndex = nIndex;
1934 }
1935
1941 void SetExpanded(BOOL bExpanded);
1942
1951 virtual BOOL OnHookKeyDown(UINT nChar, LPARAM lParam);
1952
1962 virtual BOOL OnHookMouseWheel(UINT nFlags, short zDelta, CPoint point);
1963
1969 virtual void SetParent(CXTPCommandBar* pParent)
1970 {
1971 m_pParent = pParent;
1972 }
1973
1981 void ScreenToClient(CPoint* point);
1982
1988 void ClickToolBarButton(CRect rcActiveRect = CRect(0, 0, 0, 0));
1989
1997 virtual BOOL OnSetPopup(BOOL bPopup);
1998
2004 virtual void OnLButtonUp(CPoint point);
2005
2011 virtual void OnLButtonDown(CPoint point);
2012
2019 virtual BOOL OnRButtonDown(CPoint point);
2020
2027 virtual BOOL OnRButtonUp(CPoint point);
2028
2036 virtual BOOL OnLButtonDblClk(CPoint point);
2037
2043 virtual void OnMouseMove(CPoint point);
2044
2049 virtual void OnMouseHover();
2050
2058 virtual BOOL OnSetSelected(int bSelected);
2059
2066 BOOL IsCustomizeMode() const;
2067
2075 virtual void CustomizeStartDrag(CPoint point);
2076
2086 virtual BOOL CustomizeStartResize(CPoint point);
2087
2095 virtual void OnCustomizeDragOver(CXTPControl* pDataObject, CPoint point,
2096 DROPEFFECT& dropEffect);
2097
2107 virtual BOOL DoCustomDragOver(CXTPCommandBar* pCommandBar, CPoint point,
2108 DROPEFFECT& dropEffect);
2109
2111 _XTP_DEPRECATED_IN_FAVOR(DoCustomDragOver)
2112 virtual BOOL IsCustomizeDragOverAvail(CXTPCommandBar* pCommandBar, CPoint point,
2113 DROPEFFECT& dropEffect)
2114 {
2115 return DoCustomDragOver(pCommandBar, point, dropEffect);
2116 }
2125 virtual BOOL IsCustomizeResizeAllow() const;
2126
2138 virtual int GetCustomizeMinWidth() const;
2139
2151 virtual int GetCustomizeMinHeight() const;
2152
2158 void OnCustomizeMouseMove(CPoint point);
2159
2164 virtual void OnIdleUpdate();
2165
2171 virtual void OnRemoved();
2172
2186 virtual INT_PTR OnToolHitTest(CPoint point, TOOLINFO* pTI) const;
2187
2188protected:
2198 virtual void RestoreCommandBarList(CXTPCommandBarList* pCommandBarList);
2199
2209 virtual void GenerateCommandBarList(DWORD& nID, CXTPCommandBarList* pCommandBarList,
2210 XTP_COMMANDBARS_PROPEXCHANGE_PARAM* pParam);
2211
2219 virtual void OnActionChanged(int nProperty);
2220
2228 virtual void OnActionChanging(int nProperty);
2229
2230protected:
2235 virtual void OnCaptionChanged();
2236
2244 BOOL IsLayoutRTL() const;
2245
2253 BOOL IsLayoutChanged();
2254
2255protected:
2257 virtual HRESULT GetAccessibleParent(IDispatch** ppdispParent);
2258 virtual HRESULT GetAccessibleDescription(VARIANT varChild, BSTR* pszDescription);
2259 virtual HRESULT GetAccessibleChildCount(long* pcountChildren);
2260 virtual HRESULT GetAccessibleChild(VARIANT varChild, IDispatch** ppdispChild);
2261 virtual HRESULT GetAccessibleName(VARIANT varChild, BSTR* pszName);
2262 virtual HRESULT GetAccessibleRole(VARIANT varChild, VARIANT* pvarRole);
2263 virtual HRESULT AccessibleLocation(long* pxLeft, long* pyTop, long* pcxWidth, long* pcyHeight,
2264 VARIANT varChild);
2265 virtual HRESULT AccessibleHitTest(long xLeft, long yTop, VARIANT* pvarChild);
2266 virtual HRESULT GetAccessibleState(VARIANT varChild, VARIANT* pvarState);
2267 virtual CCmdTarget* GetAccessible();
2268 virtual HRESULT GetAccessibleDefaultAction(VARIANT varChild, BSTR* pszDefaultAction);
2269 virtual HRESULT AccessibleDoDefaultAction(VARIANT varChild);
2270 virtual HRESULT AccessibleSelect(long flagsSelect, VARIANT varChild);
2271 virtual HRESULT GetAccessibleKeyboardShortcut(VARIANT /*varChild*/,
2272 BSTR* /*pszKeyboardShortcut*/);
2273
2274 DECLARE_INTERFACE_MAP()
2275
2276 virtual BOOL OnCmdMsg(UINT nID, int nCode, void* pExtra, AFX_CMDHANDLERINFO* pHandlerInfo);
2277
2280private:
2281 void OnInvertTracker(CDC* pDC, CRect rect);
2282 BOOL NeedPressOnExecute() const;
2283
2284protected:
2285 DWORD_PTR m_nTag;
2286 int m_nIndex;
2287 int m_nId;
2288 int m_nIconId;
2289 int m_nHelpId;
2290 int m_nCustomIconId;
2291 BOOL m_bWrap;
2292 BOOL m_bBeginGroup;
2293 BOOL m_bEnabled;
2294 BOOL m_bChecked;
2295 BOOL m_bSelected;
2296 BOOL m_bPressed;
2297 BOOL m_bTemporary;
2298 BOOL m_bOnQuickAccess;
2299 CRect m_rcRow;
2300 CRect m_rcControl;
2301 DWORD m_dwHideFlags;
2302 DWORD m_dwFlags;
2303 CString m_strCaption;
2304 CString m_strCustomCaption;
2305 CString m_strShortcutText;
2306 CString m_strShortcutTextAuto;
2307 CString m_strTooltipText;
2308 CString m_strDescriptionText;
2309 CString m_strParameter;
2310 CString m_strKeyboardTip;
2311 CXTPControls* m_pControls;
2312 XTPControlType m_controlType;
2313 CXTPCommandBar* m_pParent;
2314 BOOL m_bExpanded;
2315 CString m_strCustomShortcutText;
2316
2317 CString m_strCategory;
2318 BOOL m_bDefaultItem;
2320 CDocTemplateMap m_mapDocTemplatesAssigned;
2321 CDocTemplateMap m_mapDocTemplatesExcluded;
2323 XTPButtonStyle m_buttonStyle;
2324 XTPButtonStyle m_buttonCustomStyle;
2325 XTPButtonStyle m_buttonRibbonStyle;
2327 BOOL m_bCloseSubMenuOnClick;
2329 CXTPRibbonGroup* m_pRibbonGroup;
2331 CXTPControlAction* m_pAction;
2332 int m_nWidth;
2333 int m_nHeight;
2335 int m_nExecuteOnPressInterval;
2337 CSize m_szIcon;
2339 BOOL m_bLayoutRTL;
2341# ifdef _XTP_COMMANDBARS_ACTIVEX
2344 DECLARE_DISPATCH_MAP()
2345
2346 DECLARE_OLETYPELIB_EX(CXTPControl);
2347
2348 afx_msg LPDISPATCH OleControls();
2349 afx_msg LPDISPATCH OleParent();
2350 afx_msg long OleGetIndex();
2351 afx_msg long OleGetType();
2352 afx_msg void OleDelete();
2353 afx_msg LPDISPATCH OleCopy(LPDISPATCH lpDispBar, const VARIANT& varBefore);
2354 afx_msg LPDISPATCH OleClone(const VARIANT& varBefore);
2355
2356 afx_msg void OleSetFocus();
2357 afx_msg void OleExecute();
2358
2359 afx_msg void OleSetCaption(LPCTSTR lpszCaption);
2360 afx_msg BSTR OleGetCaption();
2361 afx_msg void OleGetRect(long* pLeft, long* pTop, long* pRight, long* pBottom);
2362 afx_msg LPDISPATCH OleGetRibbonGroup();
2363 afx_msg void OleSetIconSize(long cx, long cy);
2364 afx_msg LPDISPATCH OleGetCommandBar();
2365
2366 afx_msg int OleGetStyle();
2367 afx_msg void OleSetStyle(int nStyle);
2368 afx_msg void OleSetDescription(LPCTSTR lpszCaption);
2369 afx_msg BSTR OleGetDescription();
2370 afx_msg BSTR OleGetTooltipText();
2371 afx_msg void OleSetTooltipText(LPCTSTR lpszCaption);
2372 afx_msg void OleSetCategory(LPCTSTR lpszCaption);
2373 afx_msg BSTR OleGetCategory();
2374 afx_msg void OleSetShortcutText(LPCTSTR lpszCaption);
2375 afx_msg BSTR OleGetShortcutText();
2376 afx_msg void OleSetCustomShortcutText(LPCTSTR lpszCustomShortcutText);
2377 afx_msg BSTR OleGetCustomShortcutText();
2378 afx_msg LPDISPATCH OleGetAction();
2379 afx_msg void OleSetAction(LPDISPATCH lpDisp);
2380 afx_msg BOOL OleGetVisible();
2381 afx_msg int OleGetWidth();
2382 afx_msg void OleSetWidth(int nWidth);
2383 afx_msg int OleGetHeight();
2384 afx_msg void OleSetHeight(int nHeight);
2385 afx_msg int OleGetTop();
2386 afx_msg int OleGetLeft();
2387 enum
2388 {
2389 dispidControls = 1L,
2390 dispidParent = 2L,
2391 dispidBeginGroup = 3L,
2392 dispidCaption = 4L,
2393 dispidDescriptionText = 5L,
2394 dispidId = 6L,
2395 dispidIndex = 7L,
2396 dispidParameter = 8L,
2397 dispidShortcutText = 9L,
2398 dispidTooltipText = 10L,
2399 dispidType = 11,
2400 dispidVisible = 12L,
2401 dispidEnabled = 13L,
2402 dispidChecked = 14L,
2403 dispidIconId = 15L,
2404 dispidDelete = 16L,
2405 dispidDefaultItem = 17L,
2406 dispidFalgs = 18L,
2407 dispidCategory = 19L,
2408 dispidCopy = 20L,
2409 dispidSetFocus = 21L,
2410 dispidExecute = 22L,
2411 };
2412
2414# endif
2415
2416private:
2417 DECLARE_XTP_CONTROL(CXTPControl)
2418
2419 friend class CXTPRibbonBuilder;
2420 friend class CXTPControls;
2421 friend class CXTPCommandBar;
2422 friend class CXTPToolBar;
2423 friend class CXTPPopupBar;
2424 friend class CXTPCustomizeSheet;
2425 friend class CXTPCustomizeDropSource;
2426 friend class CXTPRibbonGroup;
2427 friend class CXTPRibbonGroups;
2428 friend class CXTPRibbonBar;
2429 friend class CXTPRibbonControls;
2430 friend class CXTPControlAction;
2431 friend class CXTPRibbonQuickAccessControls;
2432};
2433
2435
2436AFX_INLINE BOOL CXTPControl::IsOnQuickAccess() const
2437{
2438 return m_bOnQuickAccess;
2439}
2440
2441AFX_INLINE void CXTPControl::SetOnQuickAccess(BOOL bOnQuickAccess)
2442{
2443 m_bOnQuickAccess = bOnQuickAccess;
2444}
2445
2446AFX_INLINE long CXTPControl::GetIndex() const
2447{
2448 return m_nIndex;
2449}
2450AFX_INLINE void CXTPControl::SetShortcutText(LPCTSTR lpszShortcutText)
2451{
2452 m_strShortcutText = lpszShortcutText;
2453}
2454AFX_INLINE CString CXTPControl::GetShortcutText() const
2455{
2456 return !m_strShortcutText.IsEmpty()
2457 ? m_strShortcutText
2458 : m_pAction && !m_pAction->GetShortcutText().IsEmpty() ? m_pAction->GetShortcutText()
2459 : m_strShortcutTextAuto;
2460}
2461AFX_INLINE void CXTPControl::SetCustomShortcutText(LPCTSTR lpszCustomShortcutText)
2462{
2463 m_strCustomShortcutText = lpszCustomShortcutText;
2464}
2465AFX_INLINE CString CXTPControl::GetCustomShortcutText() const
2466{
2467 return !m_strCustomShortcutText.IsEmpty()
2468 ? m_strCustomShortcutText
2469 : m_pAction && !m_pAction->GetCustomShortcutText().IsEmpty()
2470 ? m_pAction->GetCustomShortcutText()
2471 : m_strShortcutTextAuto;
2472}
2473AFX_INLINE void CXTPControl::SetDescription(LPCTSTR lpszDescription)
2474{
2475 m_strDescriptionText = lpszDescription;
2476}
2477AFX_INLINE CString CXTPControl::GetDescription() const
2478{
2479 return !m_strDescriptionText.IsEmpty() ? m_strDescriptionText
2480 : m_pAction ? m_pAction->GetDescription() : CString();
2481}
2482AFX_INLINE CString CXTPControl::GetTooltip() const
2483{
2484 return !m_strTooltipText.IsEmpty() ? m_strTooltipText
2485 : m_pAction ? m_pAction->GetTooltip() : CString();
2486}
2487AFX_INLINE void CXTPControl::SetTooltip(LPCTSTR lpszTooltip)
2488{
2489 m_strTooltipText = lpszTooltip;
2490}
2491AFX_INLINE CString CXTPControl::GetCaption() const
2492{
2493 return !m_strCustomCaption.IsEmpty()
2494 ? m_strCustomCaption
2495 : !m_strCaption.IsEmpty() ? m_strCaption
2496 : m_pAction ? m_pAction->GetCaption() : CString();
2497}
2498AFX_INLINE void CXTPControl::SetParameter(LPCTSTR lpszParameter)
2499{
2500 m_strParameter = lpszParameter;
2501}
2502AFX_INLINE CString CXTPControl::GetParameter() const
2503{
2504 return m_strParameter;
2505}
2506AFX_INLINE int CXTPControl::GetID() const
2507{
2508 return m_nId;
2509}
2510AFX_INLINE void CXTPControl::SetIconId(int nId)
2511{
2512 if (m_nIconId != nId)
2513 {
2514 m_nIconId = nId;
2515 RedrawParent(FALSE);
2516 }
2517}
2518AFX_INLINE int CXTPControl::GetIconId() const
2519{
2520 return m_nCustomIconId != 0
2521 ? m_nCustomIconId
2522 : m_nIconId > 0 ? m_nIconId : m_pAction ? m_pAction->GetIconId() : m_nId;
2523}
2524AFX_INLINE void CXTPControl::SetHelpId(int nId)
2525{
2526 m_nHelpId = nId;
2527}
2528AFX_INLINE int CXTPControl::GetHelpId() const
2529{
2530 return m_nHelpId > 0 ? m_nHelpId : m_pAction ? m_pAction->GetHelpId() : m_nId;
2531}
2532AFX_INLINE void CXTPControl::SetBeginGroup(BOOL bBeginGroup)
2533{
2534 if (m_bBeginGroup != bBeginGroup)
2535 {
2536 m_bBeginGroup = bBeginGroup;
2537 DelayLayoutParent();
2538 }
2539}
2540AFX_INLINE BOOL CXTPControl::GetBeginGroup() const
2541{
2542 return m_bBeginGroup;
2543}
2544AFX_INLINE void CXTPControl::OnEnabledChanged()
2545{
2546}
2547AFX_INLINE void CXTPControl::SetEnabled(BOOL bEnabled)
2548{
2549 if (m_bEnabled != bEnabled)
2550 {
2551 m_bEnabled = bEnabled;
2552 OnEnabledChanged();
2553 RedrawParent();
2554 }
2555}
2556AFX_INLINE BOOL CXTPControl::GetChecked() const
2557{
2558 return m_bChecked == -1 && m_pAction ? m_pAction->GetChecked() : m_bChecked;
2559}
2560AFX_INLINE void CXTPControl::SetChecked(BOOL bChecked)
2561{
2562 if (m_bChecked != bChecked)
2563 {
2564 m_bChecked = bChecked;
2565 RedrawParent();
2566 }
2567}
2568AFX_INLINE int CXTPControl::GetSelected() const
2569{
2570 return m_bSelected;
2571}
2572AFX_INLINE BOOL CXTPControl::GetPressed() const
2573{
2574 return m_bPressed;
2575}
2576AFX_INLINE void CXTPControl::SetPressed(BOOL bPressed)
2577{
2578 m_bPressed = bPressed;
2579}
2580AFX_INLINE void CXTPControl::SetRect(CRect rcControl)
2581{
2582 m_rcControl = rcControl;
2583}
2584AFX_INLINE CRect CXTPControl::GetRect() const
2585{
2586 return m_rcControl;
2587}
2588AFX_INLINE CXTPCommandBar* CXTPControl::GetParent() const
2589{
2590 return m_pParent;
2591}
2592AFX_INLINE BOOL CXTPControl::IsVisible(DWORD dwSkipFlags) const
2593{
2594 if (m_pAction && !m_pAction->IsVisible())
2595 return FALSE;
2596 return (m_dwHideFlags & ~dwSkipFlags) == xtpNoHide;
2597}
2598AFX_INLINE void CXTPControl::SetHideFlags(DWORD dwFlags)
2599{
2600 m_dwHideFlags = dwFlags;
2601}
2602AFX_INLINE BOOL CXTPControl::SetHideFlag(XTPControlHideFlags dwFlag, BOOL bHide)
2603{
2604 DWORD dwHideFlags = m_dwHideFlags;
2605 if (bHide)
2606 SetHideFlags(m_dwHideFlags | dwFlag);
2607 else
2608 SetHideFlags(m_dwHideFlags & ~dwFlag);
2609 return dwHideFlags != m_dwHideFlags;
2610}
2611
2612AFX_INLINE void CXTPControl::SetHideWrap(BOOL bHide)
2613{
2614 SetHideFlag(xtpHideWrap, bHide);
2615}
2616AFX_INLINE DWORD CXTPControl::GetHideFlags() const
2617{
2618 return m_dwHideFlags;
2619}
2620AFX_INLINE CRect CXTPControl::GetRowRect() const
2621{
2622 return m_rcRow;
2623}
2624AFX_INLINE void CXTPControl::SetRowRect(CRect rcRow)
2625{
2626 m_rcRow = rcRow;
2627}
2628AFX_INLINE BOOL CXTPControl::GetWrap() const
2629{
2630 return m_bWrap;
2631}
2632AFX_INLINE void CXTPControl::SetWrap(BOOL bWrap)
2633{
2634 m_bWrap = bWrap;
2635}
2636AFX_INLINE CXTPControls* CXTPControl::GetControls() const
2637{
2638 return m_pControls;
2639}
2640
2641AFX_INLINE BOOL CXTPControl::IsTemporary() const
2642{
2643 return m_bTemporary;
2644}
2645AFX_INLINE XTPControlType CXTPControl::GetType() const
2646{
2647 return m_controlType;
2648}
2649AFX_INLINE BOOL CXTPControl::GetExpanded() const
2650{
2651 return m_bExpanded;
2652}
2653AFX_INLINE void CXTPControl::SetCategory(LPCTSTR lpszCategory)
2654{
2655 m_strCategory = lpszCategory;
2656}
2657AFX_INLINE CString CXTPControl::GetCategory() const
2658{
2659 return !m_strCategory.IsEmpty() ? m_strCategory
2660 : m_pAction ? m_pAction->GetCategory() : CString();
2661}
2662AFX_INLINE void CXTPControl::SetTag(DWORD_PTR dwTag)
2663{
2664 m_nTag = dwTag;
2665}
2666AFX_INLINE DWORD_PTR CXTPControl::GetTag() const
2667{
2668 return m_nTag;
2669}
2670AFX_INLINE void CXTPControl::AssignDocTemplate(UINT nIDResource)
2671{
2672 m_mapDocTemplatesAssigned.SetAt(nIDResource, TRUE);
2673}
2674AFX_INLINE void CXTPControl::ExcludeDocTemplate(UINT nIDResource)
2675{
2676 m_mapDocTemplatesExcluded.SetAt(nIDResource, TRUE);
2677}
2678AFX_INLINE void CXTPControl::OnClick(BOOL /*bKeyboard = FALSE*/, CPoint /*pt = CPoint(0, 0)*/)
2679{
2680}
2681AFX_INLINE void CXTPControl::SetStyle(XTPButtonStyle buttonStyle)
2682{
2683 if (m_buttonStyle != buttonStyle)
2684 {
2685 m_buttonStyle = buttonStyle;
2686 DelayLayoutParent();
2687 }
2688}
2689AFX_INLINE CXTPCommandBar* CXTPControl::GetCommandBar() const
2690{
2691 return NULL;
2692}
2693AFX_INLINE void CXTPControl::SetCloseSubMenuOnClick(BOOL bCloseOnClick)
2694{
2695 m_bCloseSubMenuOnClick = bCloseOnClick;
2696}
2697
2698AFX_INLINE BOOL CXTPControl::GetCloseSubMenuOnClick() const
2699{
2700 return m_bCloseSubMenuOnClick;
2701}
2702AFX_INLINE int CXTPControl::GetCustomizeMinWidth() const
2703{
2704 return 0;
2705}
2706AFX_INLINE int CXTPControl::GetCustomizeMinHeight() const
2707{
2708 return 0;
2709}
2710AFX_INLINE void CXTPControl::SetWidth(int nWidth)
2711{
2712 if (m_nWidth != nWidth)
2713 {
2714 m_nWidth = nWidth;
2715 DelayLayoutParent();
2716 }
2717}
2718AFX_INLINE void CXTPControl::SetHeight(int nHeight)
2719{
2720 if (m_nHeight != nHeight)
2721 {
2722 m_nHeight = nHeight;
2723 DelayLayoutParent();
2724 }
2725}
2726AFX_INLINE BOOL CXTPControl::OnHookKeyDown(UINT /*nChar*/, LPARAM /*lParam*/)
2727{
2728 return FALSE;
2729}
2730AFX_INLINE BOOL CXTPControl::OnSetPopup(BOOL /*bPopup*/)
2731{
2732 return FALSE;
2733}
2734AFX_INLINE void CXTPControl::OnLButtonUp(CPoint /*point*/)
2735{
2736}
2737AFX_INLINE BOOL CXTPControl::OnRButtonDown(CPoint /*point*/)
2738{
2739 return FALSE;
2740}
2741AFX_INLINE BOOL CXTPControl::OnRButtonUp(CPoint /*point*/)
2742{
2743 return FALSE;
2744}
2745AFX_INLINE void CXTPControl::OnMouseMove(CPoint /*point*/)
2746{
2747}
2748AFX_INLINE BOOL CXTPControl::IsFocusable() const
2749{
2750 return FALSE;
2751}
2752AFX_INLINE void CXTPControl::SetFocused(BOOL /*bFocused*/)
2753{
2754}
2755AFX_INLINE BOOL CXTPControl::IsFocused() const
2756{
2757 return FALSE;
2758}
2759AFX_INLINE void CXTPControl::OnCalcDynamicSize(DWORD /*dwMode*/)
2760{
2761}
2762
2763AFX_INLINE CXTPRibbonGroup* CXTPControl::GetRibbonGroup() const
2764{
2765 return m_pRibbonGroup;
2766}
2767AFX_INLINE BOOL CXTPControl::OnHookMouseWheel(UINT /*nFlags*/, short /*zDelta*/, CPoint /*pt*/)
2768{
2769 return FALSE;
2770}
2771AFX_INLINE BOOL CXTPControl::GetPopuped() const
2772{
2773 return FALSE;
2774}
2775AFX_INLINE void CXTPControl::OnIdleUpdate()
2776{
2777}
2778AFX_INLINE CXTPControlAction* CXTPControl::GetAction() const
2779{
2780 return m_pAction;
2781}
2782AFX_INLINE void CXTPControl::OnThemeChanged()
2783{
2784}
2785AFX_INLINE int CXTPControl::GetWidth() const
2786{
2787 return m_nWidth;
2788}
2789AFX_INLINE int CXTPControl::GetHeight() const
2790{
2791 return m_nHeight;
2792}
2793AFX_INLINE void CXTPControl::OnActionChanging(int /*nProperty*/)
2794{
2795}
2796AFX_INLINE void CXTPControl::SetExecuteOnPressInterval(int nExecuteOnPressInterval)
2797{
2798 m_nExecuteOnPressInterval = nExecuteOnPressInterval;
2799}
2800AFX_INLINE int CXTPControl::GetExecuteOnPressInterval() const
2801{
2802 return m_nExecuteOnPressInterval;
2803}
2804AFX_INLINE void CXTPControl::SetKeyboardTip(LPCTSTR lpszKeyboardTip)
2805{
2806 m_strKeyboardTip = lpszKeyboardTip;
2807}
2808AFX_INLINE CString CXTPControl::GetKeyboardTip() const
2809{
2810 return !m_strKeyboardTip.IsEmpty() ? m_strKeyboardTip
2811 : m_pAction ? m_pAction->GetKeyboardTip() : CString();
2812}
2813AFX_INLINE INT_PTR CXTPControl::OnToolHitTest(CPoint /*point*/, TOOLINFO* /*pTI*/) const
2814{
2815 return -1;
2816}
2817AFX_INLINE void CXTPControl::SetIconSize(CSize szIcon)
2818{
2819 m_szIcon = szIcon;
2820 RedrawParent(FALSE);
2821}
2822AFX_INLINE void CXTPControl::OnCaptionChanged()
2823{
2824}
2826# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
2827#endif // #if !defined(__XTPCONTROL_H__)
XTPControlType
XTPControlType
Type of the control.
Definition XTPCommandBarsDefines.h:111
XTPButtonStyle
XTPButtonStyle
Button's styles.
Definition XTPCommandBarsDefines.h:197
XTPControlHideFlags
XTPControlHideFlags
Control's hide flags, these are flags that specify why a control is hidden.
Definition XTPCommandBarsDefines.h:162
xtpHideWrap
@ xtpHideWrap
Control is hidden by wrap.
Definition XTPCommandBarsDefines.h:165
xtpNoHide
@ xtpNoHide
Control is visible.
Definition XTPCommandBarsDefines.h:163
DECLARE_XTP_CONTROL
#define DECLARE_XTP_CONTROL(class_name)
This macro generates the C++ header code necessary for a CXTPControl-derived class that can be serial...
Definition XTPCommandBarsDefines.h:1169
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPCommandBar
CXTPCommandBar is a CWnd derived class.
Definition XTPCommandBar.h:66
CXTPCommandBarList
CXTPCommandBarList is a CList derived class.
Definition XTPCommandBarList.h:42
CXTPCommandBars
CXTPCommandBars is a standalone class.
Definition XTPCommandBars.h:165
CXTPControlAction
CXTPControlAction is a CXTPCmdTarget derived class.
Definition XTPControl.h:53
CXTPControlAction::SetShortcutText
void SetShortcutText(LPCTSTR lpszShortcutText)
Call this member to set the shortcut string to the action.
Definition XTPControl.h:553
CXTPControlAction::SetCaption
void SetCaption(UINT nIDCaption)
Call this member to set the caption of the action.
CXTPControlAction::DoPropExchange
void DoPropExchange(CXTPPropExchange *pPX)
Either reads this object from or writes this object to an archive.
CXTPControlAction::GetCount
int GetCount() const
Call this member to get the number of controls associated with an action.
CXTPControlAction::m_strTooltipText
CString m_strTooltipText
Tooltip text.
Definition XTPControl.h:535
CXTPControlAction::m_arrControls
CArray< CXTPControl *, CXTPControl * > m_arrControls
Associated controls.
Definition XTPControl.h:544
CXTPControlAction::SetTooltip
void SetTooltip(LPCTSTR lpszTooltip)
Call this member to set the tooltip of the action.
Definition XTPControl.h:581
CXTPControlAction::~CXTPControlAction
~CXTPControlAction()
Destroys a CXTPControlAction object, handles cleanup and deallocation.
CXTPControlAction::OnChanged
void OnChanged(int nProperty)
This method is called when the property of an action is changed.
CXTPControlAction::GetID
int GetID() const
Call this member to get the action's identifier.
Definition XTPControl.h:601
CXTPControlAction::SetVisible
void SetVisible(BOOL bVisible)
Call this member to set the visibility of an action.
Definition XTPControl.h:652
CXTPControlAction::SetPrompt
void SetPrompt(LPCTSTR lpszPrompt)
Call this member to load a string from a STRINGTABLE resource to set the tooltip and description of a...
CXTPControlAction::SetDescription
void SetDescription(LPCTSTR lpszDescription)
Call this member to set the description of the action.
Definition XTPControl.h:569
CXTPControlAction::GetControl
CXTPControl * GetControl(int nIndex) const
Call this member to get a control associated with an action.
CXTPControlAction::m_nTag
DWORD_PTR m_nTag
Action tag.
Definition XTPControl.h:527
CXTPControlAction::SetKeyboardTip
void SetKeyboardTip(LPCTSTR lpszKeyboardTip)
Call this member to set the keyboard tip to the action.
Definition XTPControl.h:677
CXTPControlAction::GetShortcutText
CString GetShortcutText() const
Call this member to get the action's shortcut.
Definition XTPControl.h:557
CXTPControlAction::m_strCustomShortcutText
CString m_strCustomShortcutText
Custom Shortcut Text.
Definition XTPControl.h:542
CXTPControlAction::m_nHelpId
int m_nHelpId
Help identifier.
Definition XTPControl.h:530
CXTPControlAction::IsVisible
BOOL IsVisible() const
Call this member to get the visibility of an action.
Definition XTPControl.h:648
CXTPControlAction::GetIconId
int GetIconId() const
Call this member to get the icon's identifier.
Definition XTPControl.h:613
CXTPControlAction::m_strCategory
CString m_strCategory
Category of the action.
Definition XTPControl.h:537
CXTPControlAction::SetCaption
void SetCaption(LPCTSTR lpszCaption)
Call this member to set the caption of the action.
CXTPControlAction::m_strKey
CString m_strKey
Key.
Definition XTPControl.h:541
CXTPControlAction::GetDescription
CString GetDescription() const
Call this member to get the action's description.
Definition XTPControl.h:573
CXTPControlAction::RepositionControls
void RepositionControls()
Call this member to reposition all controls associated with actions.
CXTPControlAction::m_bChecked
BOOL m_bChecked
TRUE if the action is checked.
Definition XTPControl.h:532
CXTPControlAction::SetCategory
void SetCategory(LPCTSTR lpszCategory)
Call this method to set the category of the action.
Definition XTPControl.h:661
CXTPControlAction::GetChecked
BOOL GetChecked() const
Call this member to get the checked state of an action.
Definition XTPControl.h:635
CXTPControlAction::GetEditHint
CString GetEditHint() const
Call this member to get the grayed-out text displayed in the edit and combo controls which provides a...
Definition XTPControl.h:597
CXTPControlAction::m_strKeyboardTip
CString m_strKeyboardTip
Keyboard tip.
Definition XTPControl.h:540
CXTPControlAction::GetCaption
CString GetCaption() const
Call this member to get the action's caption.
Definition XTPControl.h:593
CXTPControlAction::m_nIconId
int m_nIconId
Identifier of the action's image.
Definition XTPControl.h:529
CXTPControlAction::SetTag
void SetTag(DWORD_PTR dwTag)
This method sets the 32-bit value associated with the action.
Definition XTPControl.h:669
CXTPControlAction::GetCustomShortcutText
CString GetCustomShortcutText() const
Call this member to get the action's custom shortcut text.
Definition XTPControl.h:565
CXTPControlAction::OnRemoved
void OnRemoved()
This method is called before an action is removed.
CXTPControlAction::SetChecked
void SetChecked(BOOL bChecked)
Call this member to set the checked state of an action.
Definition XTPControl.h:639
CXTPControlAction::GetKey
CString GetKey() const
Gets the "string" version of the ID given to a command in the CommandBars Designer (For use with Comm...
Definition XTPControl.h:585
CXTPControlAction::AddControl
void AddControl(CXTPControl *pControl)
This method is called when a new control is attached to an action.
CXTPControlAction::CXTPControlAction
CXTPControlAction(CXTPControlActions *pActions)
Constructs a CXTPControlAction object.
CXTPControlAction::GetTag
DWORD_PTR GetTag() const
This method retrieves the application-supplied, 32-bit value associated with the action.
Definition XTPControl.h:673
CXTPControlAction::SetKey
void SetKey(LPCTSTR lpszKey)
"String" version of the ID given to a command in the CommandBars Designer (For use with CommandBars d...
Definition XTPControl.h:589
CXTPControlAction::m_bVisible
BOOL m_bVisible
TRUE if the action is visible.
Definition XTPControl.h:533
CXTPControlAction::SetCustomShortcutText
void SetCustomShortcutText(LPCTSTR lpszCustomShortcutText)
Call this member to set the custom shortcut string to the action.
Definition XTPControl.h:561
CXTPControlAction::RedrawControls
void RedrawControls()
Call this member to redraw all controls associated with actions.
CXTPControlAction::m_strShortcutText
CString m_strShortcutText
Shortcut text.
Definition XTPControl.h:538
CXTPControlAction::SetEditHint
void SetEditHint(LPCTSTR lpszEditHint)
Call this member to set the grayed-out text displayed in the edit and combo controls which provides a...
CXTPControlAction::SetIconId
void SetIconId(int nId)
Call this member to set the action icon's identifier.
Definition XTPControl.h:605
CXTPControlAction::GetTooltip
CString GetTooltip() const
Call this member to get the action's tooltip.
Definition XTPControl.h:577
CXTPControlAction::GetCategory
CString GetCategory() const
Call this method to retrieve the category of the action.
Definition XTPControl.h:665
CXTPControlAction::m_pActions
CXTPControlActions * m_pActions
Parent actions object.
Definition XTPControl.h:545
CXTPControlAction::GetKeyboardTip
CString GetKeyboardTip() const
Call this member to get the action's keyboard tip.
Definition XTPControl.h:681
CXTPControlAction::RemoveControl
void RemoveControl(CXTPControl *pControl)
This method is called to remove a control from the actions list.
CXTPControlAction::m_strDescriptionText
CString m_strDescriptionText
Description text.
Definition XTPControl.h:536
CXTPControlAction::m_pTarget
CCmdTarget * m_pTarget
Parameter of action.
Definition XTPControl.h:524
CXTPControlAction::GetEnabled
BOOL GetEnabled() const
Call this member to get the state of the action.
CXTPControlAction::GetCommandBars
CXTPCommandBars * GetCommandBars() const
Call this member to get a pointer to the owner CommandBars.
CXTPControlAction::SetEnabled
void SetEnabled(BOOL bEnabled)
Call this member to enable or disable the action.
Definition XTPControl.h:626
CXTPControlAction::m_strEditHint
CString m_strEditHint
Edit Hint for Combo and Edit Controls.
Definition XTPControl.h:539
CXTPControlAction::SetHelpId
void SetHelpId(int nId)
Call this member to set the action help identifier.
Definition XTPControl.h:617
CXTPControlAction::OnChanging
void OnChanging(int nProperty)
This method is called when the property of an action is about to be changed.
CXTPControlAction::m_bEnabled
BOOL m_bEnabled
TRUE if the action is enabled.
Definition XTPControl.h:531
CXTPControlAction::GetHelpId
int GetHelpId() const
Call this member to get the help identifier.
Definition XTPControl.h:621
CXTPControlAction::m_strCaption
CString m_strCaption
Caption of the action.
Definition XTPControl.h:534
CXTPControlAction::m_nId
int m_nId
Identifier of the action.
Definition XTPControl.h:528
CXTPControlActions
CXTPControlActions is a CXTPCmdTarget derived class.
Definition XTPControl.h:692
CXTPControlActions::SetActionId
void SetActionId(CXTPControlAction *pAction, int nId)
Sets or updates the control ID associated with an action.
CXTPControlActions::DoPropExchange
void DoPropExchange(CXTPPropExchange *pPX)
Either reads this object from or writes this object to an archive.
CXTPControlActions::GetCount
int GetCount() const
Call this member to get the count of the actions.
CXTPControlActions::GetAt
CXTPControlAction * GetAt(int nIndex) const
Call this member to return the action at the specified index.
CXTPControlActions::~CXTPControlActions
~CXTPControlActions()
Destroys a CXTPControlActions object, handles cleanup and deallocation.
CXTPControlActions::CXTPControlActions
CXTPControlActions(CXTPCommandBars *pCommandBars)
Constructs a CXTPControlActions object.
CXTPControlActions::Add
CXTPControlAction * Add(int nId, CXTPControlAction *pAction)
Call this member to add a new action.
CXTPControlActions::Remove
void Remove(int nId)
Removes the action of a control by using the ID of the control.
CXTPControlActions::Insert
void Insert(CXTPControlAction *pAction)
Inserts an existing CXTPControlAction into the collection of actions.
CXTPControlActions::RemoveAll
void RemoveAll()
Call this member to remove all actions.
CXTPControlActions::CreateFromMenu
void CreateFromMenu(CMenu *pMenu)
Call this method to create actions using menu commands.
CXTPControlActions::Add
CXTPControlAction * Add(int nId)
Call this member to add a new action.
CXTPControlActions::m_pCommandBars
CXTPCommandBars * m_pCommandBars
Parent CommandBars object.
Definition XTPControl.h:827
CXTPControlActions::FindAction
CXTPControlAction * FindAction(int nId) const
Call this member to find the specified action.
CXTPControlActions::m_arrActions
CArray< CXTPControlAction *, CXTPControlAction * > m_arrActions
Actions array.
Definition XTPControl.h:826
CXTPControl
CXTPControl is a CXTPCmdTarget derived class.
Definition XTPControl.h:841
CXTPControl::OnLButtonUp
virtual void OnLButtonUp(CPoint point)
This member is called when the user releases the left mouse button.
Definition XTPControl.h:2734
CXTPControl::CXTPControl
CXTPControl()
Constructs a CXTPControl object.
CXTPControl::GetRowRect
CRect GetRowRect() const
Call this method to retrieve the position of the control's row.
Definition XTPControl.h:2620
CXTPControl::GetWrap
BOOL GetWrap() const
Call this method to check if the control is wrapped.
Definition XTPControl.h:2628
CXTPControl::SetFocused
virtual void SetFocused(BOOL bFocused)
Call this member to set the focused state of the control.
Definition XTPControl.h:2752
CXTPControl::m_bWrap
BOOL m_bWrap
TRUE if the control is wrapped.
Definition XTPControl.h:2291
CXTPControl::SetWidth
virtual void SetWidth(int nWidth)
Call this member to set the width of the control.
Definition XTPControl.h:2710
CXTPControl::IsCustomizeResizeAllow
virtual BOOL IsCustomizeResizeAllow() const
This member checks if the user can resize the control.
CXTPControl::DoPropExchange
virtual void DoPropExchange(CXTPPropExchange *pPX)
Either reads this object from or writes this object to an archive.
CXTPControl::SetHideFlag
BOOL SetHideFlag(XTPControlHideFlags dwFlag, BOOL bSet)
Call this member to set/remove hide flags.
Definition XTPControl.h:2602
CXTPControl::~CXTPControl
virtual ~CXTPControl()
Destroys a CXTPControl object, handles cleanup and deallocation.
CXTPControl::SetShortcutText
void SetShortcutText(LPCTSTR lpszShortcutText)
Call this member to set the shortcut string to the control.
Definition XTPControl.h:2450
CXTPControl::GenerateCommandBarList
virtual void GenerateCommandBarList(DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam)
This method is called from SaveCommandBars to save all child command bars.
CXTPControl::GetExecuteOnPressInterval
int GetExecuteOnPressInterval() const
Call this method to get the delay (in milliseconds) between WM_COMMAND messages while a button is pre...
Definition XTPControl.h:2800
CXTPControl::SetItemDefault
void SetItemDefault(BOOL bDefault)
Call this method to set a control to be a default menu item.
CXTPControl::IsTemporary
BOOL IsTemporary() const
Call this method to determine if a control is temporary.
Definition XTPControl.h:2641
CXTPControl::SetCaption
void SetCaption(UINT nIDCaption)
Call this member to set the caption of the control.
CXTPControl::OnActionChanged
virtual void OnActionChanged(int nProperty)
This method is called when an action property is changed.
CXTPControl::DelayRedrawParent
void DelayRedrawParent()
Call this method to redraw the parent command bar.
CXTPControl::NotifySite
LRESULT NotifySite(UINT code, NMXTPCONTROL *pNM)
This method is called to send message code to the parent site window.
CXTPControl::GetHideFlags
DWORD GetHideFlags() const
Call this method to retrieve hidden flags.
Definition XTPControl.h:2616
CXTPControl::m_strTooltipText
CString m_strTooltipText
Tooltip text.
Definition XTPControl.h:2307
CXTPControl::SetPressed
void SetPressed(BOOL bPressed)
Call this member to set the pressed state of the control.
Definition XTPControl.h:2576
CXTPControl::SetTooltip
void SetTooltip(LPCTSTR lpszTooltip)
Call this member to set the tooltip of the control.
Definition XTPControl.h:2487
CXTPControl::m_bCloseSubMenuOnClick
BOOL m_bCloseSubMenuOnClick
TRUE is sub-menus are closed as soon as a control is clicked.
Definition XTPControl.h:2327
CXTPControl::OnRemoved
virtual void OnRemoved()
This method is called when a control is removed from the parent controls collection.
CXTPControl::m_pParent
CXTPCommandBar * m_pParent
The Parent command bar.
Definition XTPControl.h:2313
CXTPControl::GetWidth
int GetWidth() const
Call this member to get the width of the control.
Definition XTPControl.h:2785
CXTPControl::OnCaptionChanged
virtual void OnCaptionChanged()
This method is called when the control's caption is changed.
Definition XTPControl.h:2822
CXTPControl::GetButtonSize
virtual CSize GetButtonSize() const
Call this function to get the size of the command bar button.
CXTPControl::GetSelected
virtual int GetSelected() const
Call this member to check if the control is selected.
Definition XTPControl.h:2568
CXTPControl::GetID
int GetID() const
Call this member to get the control's identifier.
Definition XTPControl.h:2506
CXTPControl::NotifySite
LRESULT NotifySite(CWnd *pSite, UINT code, NMXTPCONTROL *pNM)
This method is called to send message code to the parent site window.
CXTPControl::IsCustomizeMode
BOOL IsCustomizeMode() const
Call this method to determine if command bars is in customize mode.
CXTPControl::GetPaintManager
CXTPPaintManager * GetPaintManager() const
Call this method to retrieve the paint manager.
CXTPControl::DelayLayoutParent
void DelayLayoutParent()
Call this method to recalculate the parent command bar size.
CXTPControl::m_pRibbonGroup
CXTPRibbonGroup * m_pRibbonGroup
Ribbon group of control.
Definition XTPControl.h:2329
CXTPControl::IsCustomizeMovable
virtual BOOL IsCustomizeMovable() const
This method is called to determine if control can be repositioned in customize mode.
CXTPControl::Reset
void Reset()
Call this member to reset the icon and caption of a control to its default settings before it was cus...
CXTPControl::m_bExpanded
BOOL m_bExpanded
TRUE if the control is expanded.
Definition XTPControl.h:2314
CXTPControl::SetPrompt
void SetPrompt(LPCTSTR lpszPrompt)
Call this member to load a string from a STRINGTABLE resource to set the tooltip and description of a...
CXTPControl::OnExecute
virtual void OnExecute()
This method is called when the control is executed.
CXTPControl::SetIndex
void SetIndex(int nIndex)
This method is called to assign the order of the control in the controls list.
Definition XTPControl.h:1931
CXTPControl::SetFlags
void SetFlags(DWORD dwFlags)
Call this member to set the flags of the control.
CXTPControl::SetDescription
void SetDescription(LPCTSTR lpszDescription)
Call this member to set the description of the control.
Definition XTPControl.h:2473
CXTPControl::SetHideWrap
void SetHideWrap(BOOL bHide)
This method is called to hide the control.
Definition XTPControl.h:2612
CXTPControl::IsLayoutRTL
BOOL IsLayoutRTL() const
Determines if right-to-left (RTL) mode is set.
CXTPControl::m_bSelected
BOOL m_bSelected
TRUE if the control is selected.
Definition XTPControl.h:2295
CXTPControl::RedrawParent
void RedrawParent(BOOL bAnimate=TRUE)
This method is called to redraw the parent command bar.
CXTPControl::m_bTemporary
BOOL m_bTemporary
TRUE if the control is temporary.
Definition XTPControl.h:2297
CXTPControl::GetParent
CXTPCommandBar * GetParent() const
Call this member to get the parent command bar.
Definition XTPControl.h:2588
CXTPControl::SetOnQuickAccess
void SetOnQuickAccess(BOOL bOnQuicAccess=FALSE)
Call this member to set whether a control should be a part of the Quick Access panel.
Definition XTPControl.h:2441
CXTPControl::SetStyle
void SetStyle(XTPButtonStyle buttonStyle)
Call this member to set the style of the control.
Definition XTPControl.h:2681
CXTPControl::DoCustomDragOver
virtual BOOL DoCustomDragOver(CXTPCommandBar *pCommandBar, CPoint point, DROPEFFECT &dropEffect)
The implementation may implement a custom drag over handling logic in this method.
CXTPControl::GetAction
CXTPControlAction * GetAction() const
Call this method to retrieve an action associated with control.
Definition XTPControl.h:2778
CXTPControl::IsVisible
virtual BOOL IsVisible(DWORD dwSkipFlags=0) const
Call this member to determine if the control is visible.
Definition XTPControl.h:2592
CXTPControl::m_nTag
DWORD_PTR m_nTag
Control tag.
Definition XTPControl.h:2285
CXTPControl::OnActionChanging
virtual void OnActionChanging(int nProperty)
This method is called when an action property is about to be changed.
Definition XTPControl.h:2793
CXTPControl::OnHookKeyDown
virtual BOOL OnHookKeyDown(UINT nChar, LPARAM lParam)
This method is called when a non-system key is pressed.
Definition XTPControl.h:2726
CXTPControl::SetKeyboardTip
void SetKeyboardTip(LPCTSTR lpszKeyboardTip)
Call this member to set the keyboard tip to the control.
Definition XTPControl.h:2804
CXTPControl::GetShortcutText
CString GetShortcutText() const
Call this member to get the control's shortcut.
Definition XTPControl.h:2454
CXTPControl::OnMouseHover
virtual void OnMouseHover()
Called after the mouse hovers over the control.
CXTPControl::m_nIndex
int m_nIndex
Index of the control.
Definition XTPControl.h:2286
CXTPControl::SetHeight
virtual void SetHeight(int nHeight)
Call this member to set the height of the control.
Definition XTPControl.h:2718
CXTPControl::GetExpanded
BOOL GetExpanded() const
Call this member to check if the control is expanded.
Definition XTPControl.h:2649
CXTPControl::SetCloseSubMenuOnClick
void SetCloseSubMenuOnClick(BOOL bCloseOnClick)
Call this member function to enable/disable the closing of sub-menus when a control is clicked in the...
Definition XTPControl.h:2693
CXTPControl::CustomizeStartResize
virtual BOOL CustomizeStartResize(CPoint point)
This method is called when user starts to resize control in customize mode.
CXTPControl::SetVisible
void SetVisible(BOOL bVisible)
Call this member to set the visibility of the control.
CXTPControl::ExcludeDocTemplate
void ExcludeDocTemplate(UINT nIDResource)
Call this method to exclude the document template from control.
Definition XTPControl.h:2674
CXTPControl::SetBeginGroup
virtual void SetBeginGroup(BOOL bBeginGroup)
Call this member to begin a new group using a separator.
Definition XTPControl.h:2532
CXTPControl::GetType
XTPControlType GetType() const
Call this member to get the control's type.
Definition XTPControl.h:2645
CXTPControl::m_strShortcutTextAuto
CString m_strShortcutTextAuto
Shortcut text.
Definition XTPControl.h:2306
CXTPControl::GetIndex
long GetIndex() const
Call this member to get the index of the control.
Definition XTPControl.h:2446
CXTPControl::GetControls
CXTPControls * GetControls() const
Call this member to get the parent controls collection.
Definition XTPControl.h:2636
CXTPControl::m_nHelpId
int m_nHelpId
Help identifier.
Definition XTPControl.h:2289
CXTPControl::ClickToolBarButton
void ClickToolBarButton(CRect rcActiveRect=CRect(0, 0, 0, 0))
This helper method is called when the user clicks the toolbar's button.
CXTPControl::IsItemDefault
BOOL IsItemDefault() const
Call this method to check if a control is a default menu item.
CXTPControl::GetIconId
int GetIconId() const
Call this member to get the icon's identifier.
Definition XTPControl.h:2518
CXTPControl::OnUnderlineActivate
virtual void OnUnderlineActivate()
This method is called when the user activates the control using its underline.
CXTPControl::m_strCategory
CString m_strCategory
Category of the control.
Definition XTPControl.h:2317
CXTPControl::m_nWidth
int m_nWidth
Width of the control.
Definition XTPControl.h:2332
CXTPControl::OnCalcDynamicSize
virtual void OnCalcDynamicSize(DWORD dwMode)
This method is called before recalculating the parent command bar size to calculate the dimensions of...
Definition XTPControl.h:2759
CXTPControl::SetCaption
void SetCaption(LPCTSTR lpszCaption)
Call this member to set the caption of the control.
CXTPControl::Draw
virtual void Draw(CDC *pDC)
This method is called to draw the control.
CXTPControl::SetID
void SetID(int nId)
Call this member to set the identifier of the control.
CXTPControl::GetCommandBar
virtual CXTPCommandBar * GetCommandBar() const
Call this member to get the child command bar.
Definition XTPControl.h:2689
CXTPControl::OnToolHitTest
virtual INT_PTR OnToolHitTest(CPoint point, TOOLINFO *pTI) const
The framework calls this member function to determine whether a point is in the bounding rectangle of...
Definition XTPControl.h:2813
CXTPControl::IsOnQuickAccess
BOOL IsOnQuickAccess() const
Call this member to check if a control is a part of the Quick Access panel.
Definition XTPControl.h:2436
CXTPControl::GetFlags
DWORD GetFlags() const
Call this member to retrieve control special flags.
CXTPControl::GetDescription
virtual CString GetDescription() const
Call this member to get the control's description.
Definition XTPControl.h:2477
CXTPControl::m_nExecuteOnPressInterval
int m_nExecuteOnPressInterval
Delay between each message when control is pressed.
Definition XTPControl.h:2335
CXTPControl::IsLayoutChanged
BOOL IsLayoutChanged()
Call this member to determine if the layout has changed (RTL to LTR or LTR to RLT).
CXTPControl::OnLButtonDblClk
virtual BOOL OnLButtonDblClk(CPoint point)
This member is called when the user double-clicks the left mouse button.
CXTPControl::OnClick
virtual void OnClick(BOOL bKeyboard=FALSE, CPoint pt=CPoint(0, 0))
This method is called when the user clicks the control.
Definition XTPControl.h:2678
CXTPControl::SetRect
virtual void SetRect(CRect rcControl)
This member is called to set the bounding rectangle of the control.
Definition XTPControl.h:2580
CXTPControl::m_szIcon
CSize m_szIcon
The size of the icon used for the control.
Definition XTPControl.h:2337
CXTPControl::m_mapDocTemplatesExcluded
CDocTemplateMap m_mapDocTemplatesExcluded
Excluded templates.
Definition XTPControl.h:2321
CXTPControl::m_bChecked
BOOL m_bChecked
TRUE if the control is checked.
Definition XTPControl.h:2294
CXTPControl::SetCategory
void SetCategory(LPCTSTR lpszCategory)
Call this method to set the category of the control.
Definition XTPControl.h:2653
CXTPControl::GetChecked
BOOL GetChecked() const
Call this member to get the checked state of the control.
Definition XTPControl.h:2556
CXTPControl::OnIdleUpdate
virtual void OnIdleUpdate()
This virtual method is called in idle-time processing.
Definition XTPControl.h:2775
CXTPControl::m_strKeyboardTip
CString m_strKeyboardTip
Keyboard tip.
Definition XTPControl.h:2310
CXTPControl::GetPopuped
virtual BOOL GetPopuped() const
Call this member to get the control's pop-up state.
Definition XTPControl.h:2771
CXTPControl::IsTransparent
virtual BOOL IsTransparent() const
Determines if the control needs to draw its background.
Definition XTPControl.h:1383
CXTPControl::m_rcRow
CRect m_rcRow
Bounding rectangle of the control's row.
Definition XTPControl.h:2299
CXTPControl::OnCustomizeDragOver
virtual void OnCustomizeDragOver(CXTPControl *pDataObject, CPoint point, DROPEFFECT &dropEffect)
This member is called when the user moves the mouse over the control.
CXTPControl::GetCaption
virtual CString GetCaption() const
Call this member to get the control's caption.
Definition XTPControl.h:2491
CXTPControl::SetWrap
void SetWrap(BOOL bWrap)
Call this member to set the control to wrapped.
Definition XTPControl.h:2632
CXTPControl::m_bBeginGroup
BOOL m_bBeginGroup
TRUE if the control starts new group.
Definition XTPControl.h:2292
CXTPControl::m_nIconId
int m_nIconId
Identifier of the control's image.
Definition XTPControl.h:2288
CXTPControl::SetTag
void SetTag(DWORD_PTR dwTag)
This method sets the 32-bit value associated with the control.
Definition XTPControl.h:2662
CXTPControl::GetCustomShortcutText
CString GetCustomShortcutText() const
Call this member to get the control's text displayed for the shortcut in a pop-up menu.
Definition XTPControl.h:2465
CXTPControl::GetHeight
int GetHeight() const
Call this member to get the height of the control.
Definition XTPControl.h:2789
CXTPControl::SetChecked
virtual void SetChecked(BOOL bChecked)
Call this member to set the checked state of the control.
Definition XTPControl.h:2560
CXTPControl::OnSetSelected
virtual BOOL OnSetSelected(int bSelected)
This method is called when the control becomes selected.
CXTPControl::OnEnabledChanged
virtual void OnEnabledChanged()
This method is called when a control's enabled state is changed.
Definition XTPControl.h:2544
CXTPControl::m_nCustomIconId
int m_nCustomIconId
Identifier of the control's custom image.
Definition XTPControl.h:2290
CXTPControl::m_strParameter
CString m_strParameter
Parameter text.
Definition XTPControl.h:2309
CXTPControl::GetTag
DWORD_PTR GetTag() const
This method retrieves the application-supplied, 32-bit value associated with the control.
Definition XTPControl.h:2666
CXTPControl::m_pControls
CXTPControls * m_pControls
Parent control collection.
Definition XTPControl.h:2311
CXTPControl::OnMouseMove
virtual void OnMouseMove(CPoint point)
This member is called when the mouse cursor moves.
Definition XTPControl.h:2745
CXTPControl::SetCustomIcon
void SetCustomIcon(HICON hIcon)
Call this member to set a custom icon to this control.
CXTPControl::GetCustomizeMinWidth
virtual int GetCustomizeMinWidth() const
Retrieves the available minimum width of control.
Definition XTPControl.h:2702
CXTPControl::SetHideFlags
virtual void SetHideFlags(DWORD dwFlags)
This method is called to hide the control.
Definition XTPControl.h:2598
CXTPControl::RestoreCommandBarList
virtual void RestoreCommandBarList(CXTPCommandBarList *pCommandBarList)
This method is called from LoadCommandBars to restore controls and its child command bars.
CXTPControl::SetRowRect
void SetRowRect(CRect rcRow)
Call this method to set the row of the control.
Definition XTPControl.h:2624
CXTPControl::OnCustomizeMouseMove
void OnCustomizeMouseMove(CPoint point)
This member is called when the mouse cursor moves in customized mode.
CXTPControl::m_mapDocTemplatesAssigned
CDocTemplateMap m_mapDocTemplatesAssigned
Assigned templates.
Definition XTPControl.h:2320
CXTPControl::SetParameter
void SetParameter(LPCTSTR lpszParameter)
Call this member to set the parameter of the control.
Definition XTPControl.h:2498
CXTPControl::SetCustomShortcutText
void SetCustomShortcutText(LPCTSTR lpszCustomShortcutText)
Call this member to set the text displayed for the shortcut in a pop-up menu.
Definition XTPControl.h:2461
CXTPControl::GetImage
virtual CXTPImageManagerIcon * GetImage(int nWidth=16) const
Call this method to retrieve the image of the control.
CXTPControl::GetImageManager
CXTPImageManager * GetImageManager() const
Call this method to retrieve the image manager.
CXTPControl::GetIconSize
virtual CSize GetIconSize() const
Call this member function to get the size of a toolbar icon.
CXTPControl::IsFocusable
virtual BOOL IsFocusable() const
This method is called to check if the control can accept focus.
Definition XTPControl.h:2748
CXTPControl::m_strShortcutText
CString m_strShortcutText
Shortcut text.
Definition XTPControl.h:2305
CXTPControl::GetBeginGroup
BOOL GetBeginGroup() const
Call this member to determine if the control has a separator.
Definition XTPControl.h:2540
CXTPControl::SetIconId
void SetIconId(int nId)
Call this member to set the control icon's identifier.
Definition XTPControl.h:2510
CXTPControl::OnRButtonUp
virtual BOOL OnRButtonUp(CPoint point)
This member is called when the user releases the right mouse button.
Definition XTPControl.h:2741
CXTPControl::GetPressed
virtual BOOL GetPressed() const
Call this member to check the pressed state of the control.
Definition XTPControl.h:2572
CXTPControl::OnLButtonDown
virtual void OnLButtonDown(CPoint point)
This member is called when the user presses the left mouse button down.
CXTPControl::NotifySite
LRESULT NotifySite(UINT code)
This method is called to send message code to the parent site window.
CXTPControl::GetCustomizeMinHeight
virtual int GetCustomizeMinHeight() const
Retrieves available minimum height of the control.
Definition XTPControl.h:2706
CXTPControl::GetSize
virtual CSize GetSize(CDC *pDC)
This method is called to determine the size of the control.
CXTPControl::m_controlType
XTPControlType m_controlType
Type of the control.
Definition XTPControl.h:2312
CXTPControl::FromUI
static CXTPControl *AFX_CDECL FromUI(CCmdUI *pCmdUI)
Call this member to retrieve CXTPControl from a CCmdUI structure.
CXTPControl::Compare
virtual BOOL Compare(CXTPControl *pOther)
Call this member to compare controls.
CXTPControl::m_buttonStyle
XTPButtonStyle m_buttonStyle
Button Style.
Definition XTPControl.h:2323
CXTPControl::SetIconSize
void SetIconSize(CSize szIcon)
Call this member function to set the size of an icon for an individual control.
Definition XTPControl.h:2817
CXTPControl::GetTooltip
virtual CString GetTooltip() const
Call this member to get the control's tooltip.
Definition XTPControl.h:2482
CXTPControl::GetCategory
CString GetCategory() const
Call this method to retrieve the category of the control.
Definition XTPControl.h:2657
CXTPControl::m_bPressed
BOOL m_bPressed
TRUE if the control is pushed.
Definition XTPControl.h:2296
CXTPControl::GetRibbonGroup
CXTPRibbonGroup * GetRibbonGroup() const
Returns the ribbon group that the control belongs to.
Definition XTPControl.h:2763
CXTPControl::SetAction
virtual void SetAction(CXTPControlAction *pAction)
Call this method to manually assign an action for control.
CXTPControl::GetStyle
XTPButtonStyle GetStyle() const
Call this member to get the control's style.
CXTPControl::SetExpanded
void SetExpanded(BOOL bExpanded)
This method is called to set the control's expanded state.
CXTPControl::CustomizeStartDrag
virtual void CustomizeStartDrag(CPoint point)
This member is called when the user starts to drag the control in customize mode.
CXTPControl::OnThemeChanged
virtual void OnThemeChanged()
This method is called when the paint manager theme is changed.
Definition XTPControl.h:2782
CXTPControl::GetKeyboardTip
CString GetKeyboardTip() const
Call this member to get the keyboard tip.
Definition XTPControl.h:2808
CXTPControl::IsFocused
virtual BOOL IsFocused() const
Call this member to check the focused state of the control.
Definition XTPControl.h:2755
CXTPControl::IsCursorOver
BOOL IsCursorOver() const
Call this member to determine if the mouse pointer is over the control.
CXTPControl::m_strDescriptionText
CString m_strDescriptionText
Description text.
Definition XTPControl.h:2308
CXTPControl::GetRect
CRect GetRect() const
Call this member to get the bounding rectangle of the control.
Definition XTPControl.h:2584
CXTPControl::GetParameter
CString GetParameter() const
Call this member to get the control's parameter.
Definition XTPControl.h:2502
CXTPControl::OnSetPopup
virtual BOOL OnSetPopup(BOOL bPopup)
This method is called to pop-up the control.
Definition XTPControl.h:2730
CXTPControl::IsCaptionVisible
virtual BOOL IsCaptionVisible() const
Call this member to determine if the caption of the control is visible.
CXTPControl::GetCloseSubMenuOnClick
BOOL GetCloseSubMenuOnClick() const
Call this member function to check if sub-menus will close as soon as a control is clicked.
Definition XTPControl.h:2698
CXTPControl::OnRButtonDown
virtual BOOL OnRButtonDown(CPoint point)
This member is called when the user press the right mouse button.
Definition XTPControl.h:2737
CXTPControl::ScreenToClient
void ScreenToClient(CPoint *point)
The ScreenToClient function converts the screen coordinates of a specified point on the screen.
CXTPControl::OnHookMouseWheel
virtual BOOL OnHookMouseWheel(UINT nFlags, short zDelta, CPoint point)
This method is called when the user rotates the mouse wheel.
Definition XTPControl.h:2767
CXTPControl::GetEnabled
BOOL GetEnabled() const
Call this member to check if the control is enabled.
CXTPControl::m_rcControl
CRect m_rcControl
Bounding rectangle of the control.
Definition XTPControl.h:2300
CXTPControl::SetParent
virtual void SetParent(CXTPCommandBar *pParent)
This method is called to assign a parent command bar object.
Definition XTPControl.h:1969
CXTPControl::SetExecuteOnPressInterval
void SetExecuteOnPressInterval(int nExecuteOnPressInterval)
Call this method to set the delay (in milliseconds) between WM_COMMAND messages while a button is pre...
Definition XTPControl.h:2796
CXTPControl::m_dwHideFlags
DWORD m_dwHideFlags
Hidden flags.
Definition XTPControl.h:2301
CXTPControl::SetEnabled
virtual void SetEnabled(BOOL bEnabled)
Call this member to enable/disable the control.
Definition XTPControl.h:2547
CXTPControl::AssignDocTemplate
void AssignDocTemplate(UINT nIDResource)
Call this method to assign a document template to the control.
Definition XTPControl.h:2670
CXTPControl::m_bOnQuickAccess
BOOL m_bOnQuickAccess
TRUE if the control is a part of Quick Access panel.
Definition XTPControl.h:2298
CXTPControl::m_nHeight
int m_nHeight
Height of the control.
Definition XTPControl.h:2333
CXTPControl::Copy
virtual void Copy(CXTPControl *pControl, BOOL bRecursive=FALSE)
This method is called to copy the control.
CXTPControl::SetHelpId
void SetHelpId(int nId)
Call this member to set the control help identifier.
Definition XTPControl.h:2524
CXTPControl::m_bEnabled
BOOL m_bEnabled
TRUE if the control is enabled.
Definition XTPControl.h:2293
CXTPControl::m_pAction
CXTPControlAction * m_pAction
Action of the control.
Definition XTPControl.h:2331
CXTPControl::GetHelpId
int GetHelpId() const
Call this member to get the help identifier.
Definition XTPControl.h:2528
CXTPControl::m_strCustomCaption
CString m_strCustomCaption
User-defined caption.
Definition XTPControl.h:2304
CXTPControl::HasDwmCompositedRect
BOOL HasDwmCompositedRect() const
This method is called to determine if control has a Vista DWM transparent area.
CXTPControl::m_strCaption
CString m_strCaption
Caption of the control.
Definition XTPControl.h:2303
CXTPControl::m_nId
int m_nId
Identifier of the control.
Definition XTPControl.h:2287
CXTPControls
CXTPControls is a CXTPCmdTarget derived class.
Definition XTPControls.h:47
CXTPCustomizeSheet
CXTPCustomizeSheet is a CPropertySheet derived class.
Definition XTPCustomizeSheet.h:47
CXTPImageManager
CXTPImageManager is a standalone class.
Definition XTPImageManager.h:1898
CXTPImageManagerIcon
Icons holder class.
Definition XTPImageManager.h:622
CXTPPaintManager
Paint manager of the command bars.
Definition XTPPaintManager.h:199
CXTPPopupBar
CXTPPopupBar is a CXTPCommandBar derived class.
Definition XTPPopupBar.h:42
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72
CXTPRibbonBar
CXTPRibbonBar is a CXTPMenuBar derived class.
Definition XTPRibbonBar.h:69
CXTPRibbonControls
CXTPRibbonControls is a CXTPControls derived class.
Definition XTPRibbonQuickAccessControls.h:39
CXTPRibbonGroup
Represents a single group that is added to a CXTPRibbonTab.
Definition XTPRibbonGroup.h:70
CXTPRibbonGroups
Represents a collection of CXTPRibbonGroup objects.
Definition XTPRibbonGroups.h:51
CXTPRibbonQuickAccessControls
CXTPRibbonQuickAccessControls is a CXTPControls derived class.
Definition XTPRibbonQuickAccessControls.h:93
CXTPToolBar
CXTPToolBar is a CXTPCommandBar derived class.
Definition XTPToolBar.h:42
NMXTPCONTROL
This structure is passed as a parameter in CBN_XTP_EXECUTE message.
Definition XTPCommandBarsDefines.h:769
XTP_COMMANDBARS_PROPEXCHANGE_PARAM
XTP_COMMANDBARS_PROPEXCHANGE_PARAM is a structure used to store the CommandBar's save settings.
Definition XTPCommandBars.h:88


Toolkit Pro: XTPChart2dPieDiagramView.h Source File

  • Source
  • Chart
  • Styles
  • Pie
  • 2D
XTPChart2dPieDiagramView.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHART2DPIEDIAGRAMVIEW_H__)
24# define __XTPCHART2DPIEDIAGRAMVIEW_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartPieBase;
34class CXTPChartDiagramDomain;
35
47class _XTP_EXT_CLASS CXTPChartPieDiagramView : public CXTPChartDiagramView
48{
49public:
57 CXTPChartPieDiagramView(CXTPChartDiagram* pDiagram, CXTPChartElementView* pParent);
58
59protected:
60};
62# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
63#endif //#if !defined(__XTPCHART2DPIEDIAGRAMVIEW_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartDiagramDomain
Represents a virtual diagram rectangular domain area.
Definition XTPChartDiagram.h:159
CXTPChartDiagram
This class represents a chart diagram, which is a kind of CXTPChartElement.
Definition XTPChartDiagram.h:48
CXTPChartDiagramView
This class represents the view of a chart diagram, which is a kind of CXTPChartElementView.
Definition XTPChartDiagramView.h:49
CXTPChartElementView
This class represents the view of a chart element.
Definition XTPChartElementView.h:47
CXTPChartPieBase
This class abstracts a pie chart.
Definition XTPChartPie.h:176
CXTPChartPieDiagramView
This class abstracts the view of a pie diagram.
Definition XTPChart2dPieDiagramView.h:48
CXTPChartPieDiagramView::CXTPChartPieDiagramView
CXTPChartPieDiagramView(CXTPChartDiagram *pDiagram, CXTPChartElementView *pParent)
Constructs a CXTPChartPieDiagramView object.


Toolkit Pro: XTPProgressThemeWindowsUx.h Source File

  • Source
  • CommandBars
  • Progress
XTPProgressThemeWindowsUx.h
Go to the documentation of this file.
1
23#if !defined(__XTPPROGRESSTHEMEWINDOWSUX_H__)
24# define __XTPPROGRESSTHEMEWINDOWSUX_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class _XTP_EXT_CLASS CXTPProgressThemeWindowsUx : public CXTPProgressPaintManager
34{
35public:
36 CXTPProgressThemeWindowsUx(CXTPPaintManager* pPaintManager);
37
43 virtual ~CXTPProgressThemeWindowsUx();
44
45public:
50 virtual void RefreshMetrics();
51
52 virtual void DrawProgress(CDC* pDC, CXTPProgressBase* pGallery);
53
54protected:
55 CXTPWinThemeWrapper* m_themeProgress;
56};
57
59# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
60#endif // !defined(__XTPPROGRESSTHEMEWINDOWSUX_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPPaintManager
Paint manager of the command bars.
Definition XTPPaintManager.h:199
CXTPProgressBase
CXTPControlProgressBase is base class for all progress objects.
Definition XTPProgressBase.h:40
CXTPProgressPaintManager
CXTPProgressPaintManager object.
Definition XTPProgressPaintManager.h:41
CXTPProgressPaintManager::RefreshMetrics
virtual void RefreshMetrics()
Recalculates metrics.
CXTPProgressPaintManager::DrawProgress
virtual void DrawProgress(CDC *pDC, CXTPProgressBase *pProgressBar)
This method is called to draw progress.
CXTPWinThemeWrapper
The CXTPWinThemeWrapper class wraps the UxTheme.dll visual theme API.
Definition XTPWinThemeWrapper.h:188


Toolkit Pro: XTPPropertyGridItem.h Source File

  • Source
  • PropertyGrid
XTPPropertyGridItem.h
Go to the documentation of this file.
1
23#if !defined(__XTPPROPERTYGRIDITEM_H__)
24# define __XTPPROPERTYGRIDITEM_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33// class forwards.
34
35class CXTPPropertyGridView;
36class CXTPPropertyGridItem;
37class CXTPPropertyGridItemMetrics;
38class CXTPImageManagerIcon;
39class CXTPPropertyGridInplaceButtons;
40class CXTPPropertyGridInplaceSlider;
41class CXTPPropertyGridInplaceSpinButton;
42class CXTPPropertyGridInplaceControls;
43class CXTPMarkupUIElement;
44class CXTPPropertyGridInplaceEdit;
45class CXTPPropertyGridInplaceList;
46class CXTPPropertyGridInplaceButton;
47
72extern _XTP_EXT_CLASS const int XTP_PGI_EXPAND_BORDER;
73const TCHAR XTP_PG_ITEMVALUE_TO_REPLACE_IN_MARKUP[] = _T("%value%");
74
86enum XTPPropertyGridItemFlags
87{
88 xtpPropertyGridItemHasEdit = 1,
89 xtpPropertyGridItemHasExpandButton = 2,
90 xtpPropertyGridItemHasComboButton = 4
91};
92
94_XTP_DEPRECATED_IN_FAVOR(xtpPropertyGridItemHasEdit)
95const XTPPropertyGridItemFlags xtpGridItemHasEdit = xtpPropertyGridItemHasEdit;
96
97_XTP_DEPRECATED_IN_FAVOR(xtpGridItemHasExpandButton)
98const XTPPropertyGridItemFlags xtpGridItemHasExpandButton = xtpPropertyGridItemHasExpandButton;
99
100_XTP_DEPRECATED_IN_FAVOR(xtpGridItemHasComboButton)
101const XTPPropertyGridItemFlags xtpGridItemHasComboButton = xtpPropertyGridItemHasComboButton;
109class _XTP_EXT_CLASS CXTPPropertyGridItems : public CXTPCmdTarget
110{
111public:
119 CXTPPropertyGridItem* FindItem(UINT nID) const;
120
128 CXTPPropertyGridItem* FindItem(LPCTSTR strCaption) const;
129
139 int Find(CXTPPropertyGridItem* pItem) const;
140
145 void Clear();
146
153 long GetCount() const;
154
162 BOOL IsEmpty() const;
163
172 CXTPPropertyGridItem* GetAt(int nIndex) const;
173
179 void RemoveAt(int nIndex);
180
189 void Sort();
190
191protected:
196 CXTPPropertyGridItems();
197
206 void AddTail(CXTPPropertyGridItem* pItem);
207
216 void AddTail(CXTPPropertyGridItems* pItems);
217
225 void InsertAt(int nIndex, CXTPPropertyGridItem* pItem);
226
227private:
228 static int AFX_CDECL CompareFunc(const CXTPPropertyGridItem** ppItem1,
229 const CXTPPropertyGridItem** ppItem2);
230
231private:
232 CArray<CXTPPropertyGridItem*, CXTPPropertyGridItem*> m_arrItems;
233 // CXTPPropertyGridView* m_pGrid;
234
235# ifdef _XTP_ACTIVEX
238 DECLARE_DISPATCH_MAP()
239 DECLARE_INTERFACE_MAP()
240
241 DECLARE_OLETYPELIB_EX(CXTPPropertyGridItems)
242 DECLARE_ENUM_VARIANT(CXTPPropertyGridItems)
243
244 afx_msg long OleGetItemCount();
245 afx_msg LPDISPATCH OleItem(long nIndex);
246 afx_msg LPDISPATCH OleGetItem(long nIndex);
247
248 afx_msg void OleClear();
249 afx_msg void OleRemove(long nIndex);
250
251 enum
252 {
253 dispidCount = 1L,
254 dispidRemove = 2L,
255 dispidClear = 3L,
256 };
257
259# endif
260 friend class CXTPPropertyGridItem;
261 friend class CXTPPropertyGridView;
262 friend class CXTPPropertyGrid;
263};
264
270class _XTP_EXT_CLASS CXTPPropertyGridItemConstraint : public CXTPCmdTarget
271{
272public:
277 CXTPPropertyGridItemConstraint();
278
285 virtual int GetIndex() const;
286
295 virtual CXTPImageManagerIcon* GetImage() const;
296
297public:
298 CString m_strConstraint;
302 DWORD_PTR m_dwData; // The 32-bit value associated with the item.
303 int m_nImage;
304 BOOL m_bEnabled;
305protected:
306 int m_nIndex;
307 CXTPPropertyGridItem* m_pItem;
309# ifdef _XTP_ACTIVEX
311 DECLARE_DISPATCH_MAP()
312 DECLARE_INTERFACE_MAP()
313
314 DECLARE_OLETYPELIB_EX(CXTPPropertyGridItemConstraint);
315
317# endif
318 friend class CXTPPropertyGridItemConstraints;
319};
320
337class _XTP_EXT_CLASS CXTPPropertyGridItemConstraints : public CXTPCmdTarget
338{
339protected:
345 CXTPPropertyGridItemConstraints(CXTPPropertyGridItem* pItem);
346
352 ~CXTPPropertyGridItemConstraints();
353
354public:
366 virtual CXTPPropertyGridItemConstraint* AddConstraint(LPCTSTR str, DWORD_PTR dwData = 0,
367 int nImage = -1);
368
375 int GetCount() const;
376
384 BOOL IsEmpty() const;
385
392 void RemoveAll();
393
401 void RemoveAt(int nIndex);
402
408 void SetCurrent(int nIndex);
409
416 int GetCurrent() const;
417
425 int FindConstraint(LPCTSTR str) const;
426
434 int FindConstraint(DWORD_PTR dwData) const;
435
451 CString GetAt(int nIndex) const;
452
466 CXTPPropertyGridItemConstraint* GetConstraintAt(int nIndex) const;
467
472 virtual void Sort();
473
474private:
475 static int AFX_CDECL CompareFunc(const CXTPPropertyGridItemConstraint** ppConstraint1,
476 const CXTPPropertyGridItemConstraint** ppConstraint2);
477
478private:
479 CArray<CXTPPropertyGridItemConstraint*, CXTPPropertyGridItemConstraint*> m_arrConstraints;
480 int m_nCurrent;
481 CXTPPropertyGridItem* m_pItem;
482
483# ifdef _XTP_ACTIVEX
486public:
487 DECLARE_DISPATCH_MAP()
488 DECLARE_INTERFACE_MAP()
489
490 DECLARE_OLETYPELIB_EX(CXTPPropertyGridItemConstraints)
491
492 afx_msg long OleGetItemCount();
493 afx_msg LPDISPATCH OleItem(long nIndex);
494 afx_msg LPDISPATCH OleGetItem(long nIndex);
495 afx_msg void OleClear();
496 afx_msg void OleRemove(long nIndex);
497 afx_msg void OleAdd(LPCTSTR strItem, const VARIANT* Data);
498
499 DECLARE_ENUM_VARIANT(CXTPPropertyGridItemConstraints)
500
501 enum
502 {
503 dispidCount = 1L,
504 dispidRemove = 2L,
505 dispidAdd = 3L,
506 dispidClear = 4L,
507 };
508
510# endif
511
512 friend class CXTPPropertyGridItem;
513};
514
520class _XTP_EXT_CLASS CXTPPropertyGridItem
521 : public CXTPCmdTarget
522 , public CXTPAccessible
523{
524public:
560 CXTPPropertyGridItem(LPCTSTR lpszCaption, LPCTSTR strValue = NULL, CString* pBindString = NULL);
561
597 CXTPPropertyGridItem(UINT nID, LPCTSTR strValue = NULL, CString* pBindString = NULL);
598
603 virtual ~CXTPPropertyGridItem();
604
605public:
613 void SetCaption(LPCTSTR lpszCaption);
614
629 void SetPrompt(LPCTSTR lpszPrompt);
630
640 void SetDescription(LPCTSTR lpszDescription);
641
649 void SetMarkupTemplate(LPCTSTR lpstrMarkupTemplate);
650
658 void SetTooltip(LPCTSTR lpstrTooltip);
659
668 CString GetTooltip() const;
669
676 virtual void SetReadOnly(BOOL bReadOnly = TRUE);
677
683 void SetID(UINT nID);
684
697 void SetFlags(UINT nFlags);
698
705 CString GetCaption() const;
706
715 CString GetDescription() const;
716
723 virtual CString GetMarkupTemplate() const;
724
732 virtual BOOL GetReadOnly() const;
733
741 virtual BOOL IsAllowEdit() const;
742
749 UINT GetID() const;
750
757 int GetIndex() const;
758
765 CString GetValue() const;
766
773 CString GetDefaultValue() const;
774
786 UINT GetFlags() const;
787
794 BOOL IsCategory() const;
795
803 CXTPPropertyGridItem* AddChildItem(CXTPPropertyGridItem* pItem);
804
811 void Move(CXTPPropertyGridItem* pParent, int nIndex = -1);
812
821 CXTPPropertyGridItem* InsertChildItem(int nIndex, CXTPPropertyGridItem* pItem);
822
829 BOOL HasChilds() const;
830
837 BOOL HasVisibleChilds() const;
838
845 CXTPPropertyGridItems* GetChilds() const;
846
854 BOOL HasParent(CXTPPropertyGridItem* pParent);
855
867 CXTPPropertyGridItemConstraints* GetConstraints() const;
868
878 void SetConstraintEdit(BOOL bConstraintEdit = TRUE);
879
886 void SetAutoComplete(BOOL bAutoComplete = TRUE);
887
898 BOOL GetConstraintEdit() const;
899
904 void Expand();
905
910 void Collapse();
911
917 void SetExpandable(BOOL bExpandable);
918
925 BOOL IsExpandable() const;
926
931 void Select();
932
939 CRect GetItemRect() const;
940
948 virtual CRect GetValueRect();
949
957 virtual void SetValue(CString strValue);
958
964 void SetHidden(BOOL bHidden);
965
972 BOOL IsHidden() const;
973
980 virtual void OnValueChanged(CString strValue);
981
987 virtual void OnMarkupChanged();
988
995 CXTPPropertyGridView* GetGrid() const;
996
1003 BOOL IsVisible() const;
1004
1011 BOOL IsExpanded() const;
1012
1019 CXTPPropertyGridItem* GetParentItem() const;
1020
1027 int GetIndent() const;
1028
1039 virtual BOOL OnDrawItemValue(CDC& dc, CRect rcValue);
1040
1051 virtual void OnDrawItemConstraint(CDC* pDC, CXTPPropertyGridItemConstraint* pConstraint,
1052 CRect rc, BOOL bSelected);
1053
1063 virtual CSize OnMergeItemConstraint(CDC* pDC, CXTPPropertyGridItemConstraint* pConstraint);
1064
1071 virtual void MeasureItem(LPMEASUREITEMSTRUCT lpMeasureItemStruct);
1072
1079 BOOL IsSelected() const;
1080
1104 void BindToString(CString* pBindString);
1105
1110 void Remove();
1111
1164 void SetMask(LPCTSTR strMask, LPCTSTR strLiteral, TCHAR chPrompt = _T('_'));
1165
1179 void SetPasswordMask(TCHAR chMask = _T('*'));
1180
1191 CString GetMaskedText() const;
1192
1204 virtual BOOL IsValueChanged() const;
1205
1212 virtual void ResetValue();
1213
1221 void SetDefaultValue(LPCTSTR lpszDefaultValue);
1222
1234 void SetMaskedText(LPCTSTR lpszMaskedText);
1235
1248 virtual CString GetViewValue();
1249
1255 void SetItemData(DWORD_PTR dwData);
1256
1263 DWORD_PTR GetItemData() const;
1264
1271 virtual CXTPPropertyGridInplaceEdit& GetInplaceEdit();
1272
1277 virtual void SetFocusToInplaceControl();
1278
1288 virtual BOOL IsInplaceButtonVisible(CXTPPropertyGridInplaceButton* pButton) const;
1289
1296 CXTPPropertyGridInplaceButtons* GetInplaceButtons() const;
1297
1304 CXTPPropertyGridInplaceControls* GetInplaceControls() const;
1305
1310 void AddComboButton();
1311
1316 void AddExpandButton();
1317
1324 CXTPPropertyGridInplaceSlider* AddSliderControl();
1325
1332 CXTPPropertyGridInplaceSpinButton* AddSpinButton();
1333
1343 CXTPPropertyGridItemMetrics* GetValueMetrics() const;
1344
1354 CXTPPropertyGridItemMetrics* GetCaptionMetrics() const;
1355
1369 CXTPPropertyGridItemMetrics* GetMetrics(BOOL bValueMetrics, BOOL bCreate = TRUE) const;
1370
1377 int GetHeight() const;
1378
1388 void SetHeight(int nHeight);
1389
1398 BOOL IsMultiLine() const;
1399
1406 int GetMultiLinesCount() const;
1407
1415 void SetMultiLinesCount(int nLinesCount);
1416
1421 void EnsureVisible();
1422
1429 virtual BOOL OnRequestEdit();
1430
1438 virtual BOOL OnAfterEdit(CString& strValue);
1439
1444 virtual void OnCancelEdit();
1445
1454 void SetEditStyle(DWORD dwEditStyle);
1455
1461 void SetDropDownItemCount(int nDropDownItemCount);
1462
1471 int GetDropDownItemCount() const;
1472
1477 virtual void OnValidateEdit();
1478
1487 CXTPMarkupUIElement* GetMarkupCaption() const;
1488
1497 CXTPMarkupUIElement* GetMarkupDescription() const;
1498
1507 CXTPMarkupUIElement* GetMarkupValue() const;
1508
1518 virtual DWORD GetEditStyle() const;
1519
1524 void RedrawItem();
1525
1526protected:
1532 virtual void SetVisible(BOOL bVisible);
1533
1538 virtual void OnIndexChanged();
1539
1544 virtual void OnSelect();
1545
1550 virtual void OnDeselect();
1551
1559 virtual BOOL OnChar(UINT nChar);
1560
1569 virtual void OnLButtonDblClk(UINT nFlags, CPoint point);
1570
1579 virtual void OnRButtonDown(UINT nFlags, CPoint point);
1580
1591 virtual BOOL OnLButtonDown(UINT nFlags, CPoint point);
1592
1601 virtual void OnLButtonUp(UINT nFlags, CPoint point);
1602
1610 virtual BOOL OnKeyDown(UINT nChar);
1611
1616 virtual void OnAddChildItem();
1617
1624 virtual void OnInplaceButtonDown(CXTPPropertyGridInplaceButton* pButton);
1625
1632 virtual CXTPPropertyGridInplaceList& GetInplaceList();
1633
1639 virtual void SetEditText(const CString& str);
1640
1654 virtual void OnBeforeInsert();
1655
1663 virtual void OnConstraintsChanged();
1664
1669 virtual void OnCaptionChanged();
1670
1680 virtual BOOL OnInpaceControlFocus(BOOL bForward);
1681
1688 virtual CString GetInPlacedEditValue()
1689 {
1690 return m_strValue;
1691 }
1692
1699 void NotifyValueChanged();
1700
1701protected:
1708 BOOL SelectNextConstraint();
1709
1717 BOOL PtInValueRect(CPoint point);
1718
1719protected:
1721 // System accessibility Support
1722 virtual HRESULT GetAccessibleParent(IDispatch** ppdispParent);
1723 virtual HRESULT GetAccessibleDescription(VARIANT varChild, BSTR* pszDescription);
1724 virtual HRESULT GetAccessibleName(VARIANT varChild, BSTR* pszName);
1725 virtual HRESULT GetAccessibleRole(VARIANT varChild, VARIANT* pvarRole);
1726 virtual HRESULT AccessibleLocation(long* pxLeft, long* pyTop, long* pcxWidth, long* pcyHeight,
1727 VARIANT varChild);
1728 virtual HRESULT AccessibleHitTest(long xLeft, long yTop, VARIANT* pvarChild);
1729 virtual HRESULT GetAccessibleState(VARIANT varChild, VARIANT* pvarState);
1730 virtual CCmdTarget* GetAccessible();
1731 virtual HRESULT AccessibleSelect(long flagsSelect, VARIANT varChild);
1732 virtual HRESULT GetAccessibleValue(VARIANT varChild, BSTR* pszValue);
1733 DECLARE_INTERFACE_MAP()
1736protected:
1737 static int AFX_CDECL NextNumber(LPCTSTR& str);
1738
1739private:
1740 void Init();
1741 void Refresh(BOOL bInvalidate = TRUE);
1742 void Clear();
1743 CRect GetInplaceWindowsRect();
1744 void SetIndent(int nIndent);
1745 void RefreshHeight();
1746
1747protected:
1748 BOOL m_bConstraintEdit;
1749 int m_nIndex;
1750 int m_nIndent;
1751 UINT m_nID;
1752 UINT m_nFlags;
1753 BOOL m_bReadOnly;
1755 BOOL m_bVisible;
1756 BOOL m_bCategory;
1757 BOOL m_bExpandable;
1758 BOOL m_bExpanded;
1759 CString m_strValue;
1760 CString m_strDefaultValue;
1761 CString m_strCaption;
1762 CString m_strDescription;
1763 CString m_strTooltip;
1764 CXTPPropertyGridItem* m_pParent;
1765 CXTPPropertyGridView* m_pGrid;
1766 CXTPPropertyGridItems* m_pChilds;
1767 CXTPPropertyGridItemConstraints* m_pConstraints;
1768 BOOL m_bAutoComplete;
1769 mutable CXTPPropertyGridItemMetrics* m_pValueMetrics;
1770 mutable CXTPPropertyGridItemMetrics* m_pCaptionMetrics;
1771 CXTPPropertyGridInplaceButtons* m_pInplaceButtons;
1772 CXTPPropertyGridInplaceControls* m_pInplaceControls;
1773 int m_nDropDownItemCount;
1774 CString* m_pBindString;
1775 CString m_strFormat;
1776 CString m_strMask;
1777 CString m_strLiteral;
1779 CString m_strMarkupTemplate;
1782 TCHAR m_chPrompt;
1784 BOOL m_bUseMask;
1785 BOOL m_bPassword;
1787 DWORD_PTR m_dwData;
1788 BOOL m_bHidden;
1789 int m_nHeight;
1790 int m_nLinesCount;
1791 DWORD m_dwEditStyle;
1792 CXTPMarkupUIElement* m_pMarkupCaption;
1793 CXTPMarkupUIElement* m_pMarkupDescription;
1794 CXTPMarkupUIElement* m_pMarkupValue;
1796 friend class CXTPPropertyGridItems;
1797 friend class CXTPPropertyGridView;
1798 friend class CXTPPropertyGridInplaceEdit;
1799 friend class CXTPPropertyGridInplaceButton;
1800
1801 DECLARE_DYNAMIC(CXTPPropertyGridItem)
1802
1803# ifdef _XTP_ACTIVEX
1806protected:
1807 DISPID m_dispidBinded;
1808 COleDispatchDriver m_dispDriverBinded;
1809 COleVariant m_oleTag;
1810
1811 DECLARE_DISPATCH_MAP()
1812
1813 DECLARE_OLETYPELIB_EX(CXTPPropertyGridItem)
1814
1815 afx_msg LPDISPATCH OleInsertChildItem(int nIndex, long nType, LPCTSTR strTitle,
1816 const VARIANT* varValue);
1817 afx_msg LPDISPATCH OleAddChildItem(long nType, LPCTSTR strTitle, const VARIANT* varValue);
1818 afx_msg LPDISPATCH OleAddChildItemBinded(long nType, LPDISPATCH lpHandler,
1819 LPCTSTR lpzsProperty);
1820 afx_msg LPDISPATCH OleInsertChildItemBinded(long nIndex, long nType, LPDISPATCH lpHandler,
1821 LPCTSTR lpzsProperty);
1822 afx_msg BOOL OleGetExpanded();
1823 afx_msg void OleSetExpanded(BOOL bExpanded);
1824 afx_msg BOOL OleGetSelected();
1825 afx_msg BSTR OleGetDescription();
1826 afx_msg void OleSetSelected(BOOL bSelected);
1827 afx_msg LPDISPATCH OleGetParent();
1828 afx_msg LPDISPATCH OleGetChilds();
1829 afx_msg LPDISPATCH OleGetConstraints();
1830 afx_msg long OleGetType();
1831 afx_msg BSTR OleGetMaskedText();
1832
1833 afx_msg virtual const VARIANT OleGetValue();
1834 afx_msg virtual void OleSetValue(const VARIANT* varValue);
1835 afx_msg void OleSetMask(LPCTSTR strMask, LPCTSTR strLiteral, const VARIANT* pPrompt);
1836 afx_msg LPDISPATCH OleAddInplaceButton(UINT Id);
1837 afx_msg LPDISPATCH OleAddSliderControl();
1838 afx_msg LPDISPATCH OleAddSpinButton();
1839 afx_msg LPDISPATCH OleGetButtons();
1840 afx_msg int OleGetHeight();
1841 afx_msg int OleGetMultiLinesCount();
1842 afx_msg void OleGetRect(long* pLeft, long* pTop, long* pRight, long* pBottom);
1843 afx_msg void OleStartEdit();
1844 virtual void BindDispatch();
1845 afx_msg LPDISPATCH OleGetValueMetrics();
1846 afx_msg LPDISPATCH OleGetCaptionMetrics();
1847 afx_msg BSTR OleGetCaption();
1848 afx_msg void OleSetCaption(LPCTSTR lpszCaption);
1849
1850 afx_msg BSTR OleGetMarkupTemplate();
1851 afx_msg void OleSetMarkupTemplate(LPCTSTR lpszMarkupTemplate);
1852
1853 long m_nType;
1854 enum
1855 {
1856 dispidValue = 0L,
1857 dispidExpanded = 1L,
1858 dispidReadOnly = 2L,
1859 dispidSelected = 3L,
1860 dispidCaption = 4L,
1861 dispidDescription = 5L,
1862 dispidTag = 6L,
1863 dispidFlags = 7L,
1864 dispidConstraintEdit = 8L,
1865 dispidFormat = 9L,
1866 dispidConstraints = 97L,
1867 dispidChilds = 98L,
1868 dispidParent = 99L,
1869 dispidAddChildItem = 100L,
1870 dispidType = 101L,
1871 dispidAddChildItemBinded = 102,
1872 dispidMarkupTemplate = 121
1873 };
1874
1876# endif
1877
1878 friend class CXTPPropertyGridItemConstraints;
1879 friend class CXTPPropertyGrid;
1880};
1881
1889class _XTP_EXT_CLASS CXTPPropertyGridItemCategory : public CXTPPropertyGridItem
1890{
1891public:
1903 CXTPPropertyGridItemCategory(LPCTSTR strCaption);
1904
1916 CXTPPropertyGridItemCategory(UINT nID);
1917};
1918
1920AFX_INLINE long CXTPPropertyGridItems::GetCount() const
1921{
1922 return (long)m_arrItems.GetSize();
1923}
1924AFX_INLINE BOOL CXTPPropertyGridItems::IsEmpty() const
1925{
1926 return GetCount() == 0;
1927}
1928AFX_INLINE void CXTPPropertyGridItems::AddTail(CXTPPropertyGridItem* pItem)
1929{
1930 m_arrItems.Add(pItem);
1931}
1932AFX_INLINE void CXTPPropertyGridItems::InsertAt(int nIndex, CXTPPropertyGridItem* pItem)
1933{
1934 m_arrItems.InsertAt(nIndex, pItem);
1935}
1936AFX_INLINE BOOL CXTPPropertyGridItem::HasChilds() const
1937{
1938 return !m_pChilds->IsEmpty();
1939}
1940AFX_INLINE void CXTPPropertyGridItem::SetCaption(LPCTSTR lpszCaption)
1941{
1942 CString strCaption(lpszCaption);
1943 if (m_strCaption != strCaption)
1944 {
1945 m_strCaption = strCaption;
1946 OnCaptionChanged();
1947 }
1948}
1949AFX_INLINE CString CXTPPropertyGridItem::GetCaption() const
1950{
1951 return m_strCaption;
1952}
1953AFX_INLINE CString CXTPPropertyGridItem::GetDescription() const
1954{
1955 return m_strDescription;
1956}
1957AFX_INLINE CString CXTPPropertyGridItem::GetMarkupTemplate() const
1958{
1959 return m_strMarkupTemplate;
1960}
1961AFX_INLINE BOOL CXTPPropertyGridItem::GetReadOnly() const
1962{
1963 return m_bReadOnly;
1964}
1965AFX_INLINE void CXTPPropertyGridItem::SetID(UINT nID)
1966{
1967 m_nID = nID;
1968}
1969AFX_INLINE UINT CXTPPropertyGridItem::GetID() const
1970{
1971 return m_nID;
1972}
1973AFX_INLINE CString CXTPPropertyGridItem::GetValue() const
1974{
1975 return m_strValue;
1976}
1977AFX_INLINE CString CXTPPropertyGridItem::GetDefaultValue() const
1978{
1979 return m_strDefaultValue;
1980}
1981AFX_INLINE BOOL CXTPPropertyGridItem::IsCategory() const
1982{
1983 return m_bCategory;
1984}
1985AFX_INLINE CXTPPropertyGridView* CXTPPropertyGridItem::GetGrid() const
1986{
1987 return m_pGrid;
1988}
1989AFX_INLINE BOOL CXTPPropertyGridItem::OnDrawItemValue(CDC&, CRect)
1990{
1991 return FALSE;
1992}
1993AFX_INLINE BOOL CXTPPropertyGridItem::IsVisible() const
1994{
1995 return m_bVisible;
1996}
1997AFX_INLINE BOOL CXTPPropertyGridItem::IsExpanded() const
1998{
1999 return m_bExpanded;
2000}
2001AFX_INLINE void CXTPPropertyGridItem::SetExpandable(BOOL bExpandable)
2002{
2003 m_bExpandable = bExpandable;
2004}
2005AFX_INLINE BOOL CXTPPropertyGridItem::IsExpandable() const
2006{
2007 return m_bExpandable;
2008}
2009AFX_INLINE CXTPPropertyGridItem* CXTPPropertyGridItem::GetParentItem() const
2010{
2011 return m_pParent;
2012}
2013AFX_INLINE CXTPPropertyGridItems* CXTPPropertyGridItem::GetChilds() const
2014{
2015 return m_pChilds;
2016}
2017AFX_INLINE int CXTPPropertyGridItem::GetIndent() const
2018{
2019 return m_nIndent;
2020}
2021AFX_INLINE void CXTPPropertyGridItem::SetConstraintEdit(BOOL bConstraintEdit)
2022{
2023 m_bConstraintEdit = bConstraintEdit;
2024}
2025AFX_INLINE BOOL CXTPPropertyGridItem::GetConstraintEdit() const
2026{
2027 return m_bConstraintEdit;
2028}
2029AFX_INLINE void CXTPPropertyGridItem::SetPasswordMask(TCHAR chMask)
2030{
2031 m_bPassword = TRUE;
2032 m_chPrompt = chMask;
2033}
2034AFX_INLINE void CXTPPropertyGridItem::OnRButtonDown(UINT, CPoint)
2035{
2036}
2037AFX_INLINE void CXTPPropertyGridItem::OnConstraintsChanged()
2038{
2039}
2040AFX_INLINE void CXTPPropertyGridItem::SetItemData(DWORD_PTR dwData)
2041{
2042 m_dwData = dwData;
2043}
2044AFX_INLINE DWORD_PTR CXTPPropertyGridItem::GetItemData() const
2045{
2046 return m_dwData;
2047}
2048AFX_INLINE void CXTPPropertyGridItem::SetVisible(BOOL bVisible)
2049{
2050 m_bVisible = bVisible;
2051}
2052AFX_INLINE void CXTPPropertyGridItem::OnIndexChanged()
2053{
2054}
2055AFX_INLINE CXTPPropertyGridItemConstraints* CXTPPropertyGridItem::GetConstraints() const
2056{
2057 return m_pConstraints;
2058}
2059AFX_INLINE int CXTPPropertyGridItemConstraints::GetCount() const
2060{
2061 return (int)m_arrConstraints.GetSize();
2062}
2063AFX_INLINE BOOL CXTPPropertyGridItemConstraints::IsEmpty() const
2064{
2065 return GetCount() == 0;
2066}
2067AFX_INLINE void CXTPPropertyGridItemConstraints::SetCurrent(int nIndex)
2068{
2069 m_nCurrent = nIndex;
2070}
2071AFX_INLINE int CXTPPropertyGridItemConstraints::GetCurrent() const
2072{
2073 return m_nCurrent;
2074}
2075AFX_INLINE int CXTPPropertyGridItemConstraint::GetIndex() const
2076{
2077 return m_nIndex;
2078}
2079
2080AFX_INLINE int CXTPPropertyGridItem::GetHeight() const
2081{
2082 return m_nHeight;
2083}
2084AFX_INLINE BOOL CXTPPropertyGridItem::IsMultiLine() const
2085{
2086 return m_nLinesCount > 1;
2087}
2088AFX_INLINE int CXTPPropertyGridItem::GetMultiLinesCount() const
2089{
2090 return m_nLinesCount;
2091}
2092AFX_INLINE void CXTPPropertyGridItem::SetEditStyle(DWORD dwEditStyle)
2093{
2094 m_dwEditStyle = dwEditStyle;
2095}
2096AFX_INLINE BOOL CXTPPropertyGridItem::OnKeyDown(UINT /*nChar*/)
2097{
2098 return FALSE;
2099}
2100AFX_INLINE void CXTPPropertyGridItem::SetDropDownItemCount(int nDropDownItemCount)
2101{
2102 m_nDropDownItemCount = nDropDownItemCount;
2103}
2104AFX_INLINE int CXTPPropertyGridItem::GetDropDownItemCount() const
2105{
2106 return m_nDropDownItemCount;
2107}
2108AFX_INLINE void CXTPPropertyGridItem::SetAutoComplete(BOOL bAutoComplete)
2109{
2110 m_bAutoComplete = bAutoComplete;
2111}
2112AFX_INLINE void CXTPPropertyGridItem::SetTooltip(LPCTSTR lpstrTooltip)
2113{
2114 m_strTooltip = lpstrTooltip;
2115}
2116AFX_INLINE CString CXTPPropertyGridItem::GetTooltip() const
2117{
2118 return m_strTooltip;
2119}
2120AFX_INLINE CXTPMarkupUIElement* CXTPPropertyGridItem::GetMarkupCaption() const
2121{
2122 return m_pMarkupCaption;
2123}
2124AFX_INLINE CXTPMarkupUIElement* CXTPPropertyGridItem::GetMarkupDescription() const
2125{
2126 return m_pMarkupDescription;
2127}
2128AFX_INLINE CXTPMarkupUIElement* CXTPPropertyGridItem::GetMarkupValue() const
2129{
2130 return m_pMarkupValue;
2131}
2133# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
2134#endif // #if !defined(__XTPPROPERTYGRIDITEM_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTP_PGI_EXPAND_BORDER
_XTP_EXT_CLASS const int XTP_PGI_EXPAND_BORDER
This constant is used to determine the "gutter" width of the property grid.
XTPPropertyGridItemFlags
XTPPropertyGridItemFlags
Flags that indicate which styles to set for the grid item.
Definition XTPPropertyGridItem.h:87
xtpPropertyGridItemHasExpandButton
@ xtpPropertyGridItemHasExpandButton
Item has an expand button.
Definition XTPPropertyGridItem.h:89
xtpPropertyGridItemHasComboButton
@ xtpPropertyGridItemHasComboButton
Item has a combo button.
Definition XTPPropertyGridItem.h:90
xtpPropertyGridItemHasEdit
@ xtpPropertyGridItemHasEdit
Item has an edit control.
Definition XTPPropertyGridItem.h:88
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPImageManagerIcon
Icons holder class.
Definition XTPImageManager.h:622
CXTPMarkupUIElement
Base class for XML Markup core level implementations.
Definition XTPMarkupUIElement.h:43
CXTPPropertyGrid
CXTPPropertyGrid is a CWnd derived class.
Definition XTPPropertyGrid.h:402
CXTPPropertyGridInplaceButton
CXTPPropertyGridInplaceButton is a CXTPCmdTarget derived class.
Definition XTPPropertyGridInplaceButton.h:50
CXTPPropertyGridInplaceButtons
CXTPPropertyGridInplaceButtons is a CXTPCmdTarget derived class.
Definition XTPPropertyGridInplaceButton.h:372
CXTPPropertyGridInplaceControls
CXTPPropertyGridInplaceControls is a standalone class that represents a collection of CXTPPropertyGri...
Definition XTPPropertyGridInplaceEdit.h:552
CXTPPropertyGridInplaceEdit
CXTPPropertyGridInplaceEdit is a CEdit derived class.
Definition XTPPropertyGridInplaceEdit.h:44
CXTPPropertyGridInplaceList
CXTPPropertyGridInplaceList is a CListBox derived class.
Definition XTPPropertyGridInplaceList.h:44
CXTPPropertyGridInplaceSlider
CXTPPropertyGridInplaceSlider is a CXTPPropertyGridInplaceControl derived class.
Definition XTPPropertyGridInplaceEdit.h:248
CXTPPropertyGridInplaceSpinButton
CXTPPropertyGridInplaceSpinButton is a CXTPPropertyGridInplaceControl derived class.
Definition XTPPropertyGridInplaceEdit.h:410
CXTPPropertyGridItemCategory
CXTPPropertyGridItemCategory is a CXTPPropertyGridItem derived class.
Definition XTPPropertyGridItem.h:1890
CXTPPropertyGridItemCategory::CXTPPropertyGridItemCategory
CXTPPropertyGridItemCategory(LPCTSTR strCaption)
Constructs a CXTPPropertyGridItemCategory object.
CXTPPropertyGridItemCategory::CXTPPropertyGridItemCategory
CXTPPropertyGridItemCategory(UINT nID)
Constructs a CXTPPropertyGridItemCategory object.
CXTPPropertyGridItemConstraint
CXTPPropertyGridItemConstraint is a CXTPCmdTarget derived class.
Definition XTPPropertyGridItem.h:271
CXTPPropertyGridItemConstraint::GetIndex
virtual int GetIndex() const
Retrieves the index of this constraint within the collection of constraints.
Definition XTPPropertyGridItem.h:2075
CXTPPropertyGridItemConstraint::CXTPPropertyGridItemConstraint
CXTPPropertyGridItemConstraint()
Constructs a CXTPPropertyGridItemConstraint object.
CXTPPropertyGridItemConstraint::m_nImage
int m_nImage
Image index.
Definition XTPPropertyGridItem.h:303
CXTPPropertyGridItemConstraint::m_nIndex
int m_nIndex
Index of this constraint.
Definition XTPPropertyGridItem.h:306
CXTPPropertyGridItemConstraint::m_strConstraint
CString m_strConstraint
Caption text of this constraint.
Definition XTPPropertyGridItem.h:298
CXTPPropertyGridItemConstraint::m_dwData
DWORD_PTR m_dwData
text displayed for this constraint.
Definition XTPPropertyGridItem.h:302
CXTPPropertyGridItemConstraint::m_pItem
CXTPPropertyGridItem * m_pItem
Parent item.
Definition XTPPropertyGridItem.h:307
CXTPPropertyGridItemConstraint::GetImage
virtual CXTPImageManagerIcon * GetImage() const
Retrieves the image of this constraint so that it can be used outside of Codejock components.
CXTPPropertyGridItemConstraint::m_bEnabled
BOOL m_bEnabled
TRUE if this constraint is enabled.
Definition XTPPropertyGridItem.h:304
CXTPPropertyGridItemConstraints
CXTPPropertyGridItemConstraints is a CXTPCmdTarget derived class.
Definition XTPPropertyGridItem.h:338
CXTPPropertyGridItemConstraints::GetCount
int GetCount() const
Gets the number of constraints in the collection.
Definition XTPPropertyGridItem.h:2059
CXTPPropertyGridItemConstraints::FindConstraint
int FindConstraint(DWORD_PTR dwData) const
Retrieves the index of a specified constraint.
CXTPPropertyGridItemConstraints::Sort
virtual void Sort()
Sorts constraints alphabetically.
CXTPPropertyGridItemConstraints::GetCurrent
int GetCurrent() const
Gets the index of the current constraint.
Definition XTPPropertyGridItem.h:2071
CXTPPropertyGridItemConstraints::GetConstraintAt
CXTPPropertyGridItemConstraint * GetConstraintAt(int nIndex) const
Retrieves the constraint at a specified index within the collection.
CXTPPropertyGridItemConstraints::AddConstraint
virtual CXTPPropertyGridItemConstraint * AddConstraint(LPCTSTR str, DWORD_PTR dwData=0, int nImage=-1)
Adds a specified constraint to the collection of constraints.
CXTPPropertyGridItemConstraints::~CXTPPropertyGridItemConstraints
~CXTPPropertyGridItemConstraints()
Destroys a CXTPPropertyGridItemConstraints object, handles cleanup and deallocation.
CXTPPropertyGridItemConstraints::GetAt
CString GetAt(int nIndex) const
Retrieves the caption of the constraint at a specified index within the collection.
CXTPPropertyGridItemConstraints::RemoveAll
void RemoveAll()
Removes all constraints from the collection.
CXTPPropertyGridItemConstraints::CXTPPropertyGridItemConstraints
CXTPPropertyGridItemConstraints(CXTPPropertyGridItem *pItem)
Constructs a CXTPPropertyGridItemConstraints object.
CXTPPropertyGridItemConstraints::FindConstraint
int FindConstraint(LPCTSTR str) const
Retrieves the index of a specified constraint.
CXTPPropertyGridItemConstraints::IsEmpty
BOOL IsEmpty() const
Determines if any constraints have been added to the collection.
Definition XTPPropertyGridItem.h:2063
CXTPPropertyGridItemConstraints::SetCurrent
void SetCurrent(int nIndex)
Sets the current constraint.
Definition XTPPropertyGridItem.h:2067
CXTPPropertyGridItemConstraints::RemoveAt
void RemoveAt(int nIndex)
Removes the constraint at a specified index within the collection.
CXTPPropertyGridItem
CXTPPropertyGridItem is the base class representing an item of the Property Grid control.
Definition XTPPropertyGridItem.h:523
CXTPPropertyGridItem::NotifyValueChanged
void NotifyValueChanged()
This method is called when the item's value is changed.
CXTPPropertyGridItem::Move
void Move(CXTPPropertyGridItem *pParent, int nIndex=-1)
Moves the item to another category.
CXTPPropertyGridItem::GetMetrics
CXTPPropertyGridItemMetrics * GetMetrics(BOOL bValueMetrics, BOOL bCreate=TRUE) const
Gets the metrics of the value/caption part.
CXTPPropertyGridItem::OnDeselect
virtual void OnDeselect()
This method is called when an item is de-selected.
CXTPPropertyGridItem::GetConstraints
CXTPPropertyGridItemConstraints * GetConstraints() const
Gets the item's list of constraints.
Definition XTPPropertyGridItem.h:2055
CXTPPropertyGridItem::SetDefaultValue
void SetDefaultValue(LPCTSTR lpszDefaultValue)
Sets the default value for the item.
CXTPPropertyGridItem::OnLButtonDown
virtual BOOL OnLButtonDown(UINT nFlags, CPoint point)
This method is called when the user presses the left mouse button on the item.
CXTPPropertyGridItem::GetValue
CString GetValue() const
Gets the value of the item.
Definition XTPPropertyGridItem.h:1973
CXTPPropertyGridItem::IsMultiLine
BOOL IsMultiLine() const
Determines if the item is multi-line (i.e.
Definition XTPPropertyGridItem.h:2084
CXTPPropertyGridItem::m_pChilds
CXTPPropertyGridItems * m_pChilds
Child items.
Definition XTPPropertyGridItem.h:1766
CXTPPropertyGridItem::Remove
void Remove()
Removes this item.
CXTPPropertyGridItem::m_nID
UINT m_nID
Identifier of the item.
Definition XTPPropertyGridItem.h:1751
CXTPPropertyGridItem::m_pParent
CXTPPropertyGridItem * m_pParent
Parent item.
Definition XTPPropertyGridItem.h:1764
CXTPPropertyGridItem::m_strTooltip
CString m_strTooltip
Tooltip text.
Definition XTPPropertyGridItem.h:1763
CXTPPropertyGridItem::OnMarkupChanged
virtual void OnMarkupChanged()
This method is called when the markup text of the item is changed.
CXTPPropertyGridItem::OnRequestEdit
virtual BOOL OnRequestEdit()
This method is called before the user begins editing the item.
CXTPPropertyGridItem::m_bAutoComplete
BOOL m_bAutoComplete
TRUE to enable auto-complete for the item.
Definition XTPPropertyGridItem.h:1768
CXTPPropertyGridItem::GetDefaultValue
CString GetDefaultValue() const
Gets the default value of the item.
Definition XTPPropertyGridItem.h:1977
CXTPPropertyGridItem::IsSelected
BOOL IsSelected() const
Determines the selected stae of the item.
CXTPPropertyGridItem::ResetValue
virtual void ResetValue()
Resets the value of the item to its default value.
CXTPPropertyGridItem::OnIndexChanged
virtual void OnIndexChanged()
This method is called when the index of the item is changed.
Definition XTPPropertyGridItem.h:2052
CXTPPropertyGridItem::GetMarkupDescription
CXTPMarkupUIElement * GetMarkupDescription() const
Gets the CXTPMarkupUIElement object that renders the description of the item in the Help pane.
Definition XTPPropertyGridItem.h:2124
CXTPPropertyGridItem::SetDropDownItemCount
void SetDropDownItemCount(int nDropDownItemCount)
Sets the number of items in the dropdown list.
Definition XTPPropertyGridItem.h:2100
CXTPPropertyGridItem::m_dwEditStyle
DWORD m_dwEditStyle
Edit style.
Definition XTPPropertyGridItem.h:1791
CXTPPropertyGridItem::OnBeforeInsert
virtual void OnBeforeInsert()
This method is called before the item becomes visible in the property grid.
CXTPPropertyGridItem::SetMultiLinesCount
void SetMultiLinesCount(int nLinesCount)
Sets the number of lines for the item.
CXTPPropertyGridItem::OnLButtonUp
virtual void OnLButtonUp(UINT nFlags, CPoint point)
This method is called when the user releases the left mouse button on the item.
CXTPPropertyGridItem::OnInpaceControlFocus
virtual BOOL OnInpaceControlFocus(BOOL bForward)
This method is called by the property grid to set focus to an in-place child window.
CXTPPropertyGridItem::OnKeyDown
virtual BOOL OnKeyDown(UINT nChar)
This method is called when a non-system key is pressed.
Definition XTPPropertyGridItem.h:2096
CXTPPropertyGridItem::SetMarkupTemplate
void SetMarkupTemplate(LPCTSTR lpstrMarkupTemplate)
Sets the markup text for the item.
CXTPPropertyGridItem::GetFlags
UINT GetFlags() const
Gets the flags of the item.
CXTPPropertyGridItem::OnDrawItemValue
virtual BOOL OnDrawItemValue(CDC &dc, CRect rcValue)
This method is called when an item is drawn.
Definition XTPPropertyGridItem.h:1989
CXTPPropertyGridItem::Collapse
void Collapse()
Collapses the item.
CXTPPropertyGridItem::SetVisible
virtual void SetVisible(BOOL bVisible)
Sets the visible state of the item.
Definition XTPPropertyGridItem.h:2048
CXTPPropertyGridItem::m_pMarkupDescription
CXTPMarkupUIElement * m_pMarkupDescription
Markup UIElement for item's description.
Definition XTPPropertyGridItem.h:1793
CXTPPropertyGridItem::m_strDefaultValue
CString m_strDefaultValue
Default value of the item.
Definition XTPPropertyGridItem.h:1760
CXTPPropertyGridItem::IsCategory
BOOL IsCategory() const
Determines if the item is a category.
Definition XTPPropertyGridItem.h:1981
CXTPPropertyGridItem::InsertChildItem
CXTPPropertyGridItem * InsertChildItem(int nIndex, CXTPPropertyGridItem *pItem)
Inserts a child item.
CXTPPropertyGridItem::m_bExpanded
BOOL m_bExpanded
TRUE if the item is expanded.
Definition XTPPropertyGridItem.h:1758
CXTPPropertyGridItem::SetConstraintEdit
void SetConstraintEdit(BOOL bConstraintEdit=TRUE)
Enables/disables constraint editing mode.
Definition XTPPropertyGridItem.h:2021
CXTPPropertyGridItem::SetPrompt
void SetPrompt(LPCTSTR lpszPrompt)
Loads a string from a STRINGTABLE resource to set the caption and description for the item.
CXTPPropertyGridItem::GetGrid
CXTPPropertyGridView * GetGrid() const
Gets the parent window.
Definition XTPPropertyGridItem.h:1985
CXTPPropertyGridItem::OnLButtonDblClk
virtual void OnLButtonDblClk(UINT nFlags, CPoint point)
This method is called when the user double-clicks the left mouse button on the item.
CXTPPropertyGridItem::HasVisibleChilds
BOOL HasVisibleChilds() const
Determines if the item has visible children.
CXTPPropertyGridItem::EnsureVisible
void EnsureVisible()
Ensures that this item is visible.
CXTPPropertyGridItem::SetTooltip
void SetTooltip(LPCTSTR lpstrTooltip)
Sets the tooltip text for the item.
Definition XTPPropertyGridItem.h:2112
CXTPPropertyGridItem::SetValue
virtual void SetValue(CString strValue)
Sets the value of the item.
CXTPPropertyGridItem::GetInplaceControls
CXTPPropertyGridInplaceControls * GetInplaceControls() const
Gets the collection of in-place controls of the item.
CXTPPropertyGridItem::SetMaskedText
void SetMaskedText(LPCTSTR lpszMaskedText)
Sets the actual text value for the item without mask characters.
CXTPPropertyGridItem::BindToString
void BindToString(CString *pBindString)
Binds the item to a specified CString object.
CXTPPropertyGridItem::OnDrawItemConstraint
virtual void OnDrawItemConstraint(CDC *pDC, CXTPPropertyGridItemConstraint *pConstraint, CRect rc, BOOL bSelected)
This method is called when a constraint in an in-place list is drawn.
CXTPPropertyGridItem::GetItemData
DWORD_PTR GetItemData() const
Gets the application-supplied, 32-bit value associated with the item.
Definition XTPPropertyGridItem.h:2044
CXTPPropertyGridItem::m_bCategory
BOOL m_bCategory
TRUE if the item is a category.
Definition XTPPropertyGridItem.h:1756
CXTPPropertyGridItem::GetMarkupCaption
CXTPMarkupUIElement * GetMarkupCaption() const
Gets the CXTPMarkupUIElement object that renders the caption of the item.
Definition XTPPropertyGridItem.h:2120
CXTPPropertyGridItem::IsExpandable
BOOL IsExpandable() const
Determines if the item is expandable by the user.
Definition XTPPropertyGridItem.h:2005
CXTPPropertyGridItem::SetEditStyle
void SetEditStyle(DWORD dwEditStyle)
Sets the edit style for the item.
Definition XTPPropertyGridItem.h:2092
CXTPPropertyGridItem::m_strDescription
CString m_strDescription
Description of the item.
Definition XTPPropertyGridItem.h:1762
CXTPPropertyGridItem::GetItemRect
CRect GetItemRect() const
Gets the bounding rectangle of the item.
CXTPPropertyGridItem::IsExpanded
BOOL IsExpanded() const
Determines the expanded state of the item.
Definition XTPPropertyGridItem.h:1997
CXTPPropertyGridItem::AddExpandButton
void AddExpandButton()
Adds a standard expand button.
CXTPPropertyGridItem::GetReadOnly
virtual BOOL GetReadOnly() const
Determines if the item state is set to read-only or to read/write.
Definition XTPPropertyGridItem.h:1961
CXTPPropertyGridItem::AddComboButton
void AddComboButton()
Adds a standard combo button.
CXTPPropertyGridItem::AddSliderControl
CXTPPropertyGridInplaceSlider * AddSliderControl()
Adds a slider control.
CXTPPropertyGridItem::AddChildItem
CXTPPropertyGridItem * AddChildItem(CXTPPropertyGridItem *pItem)
Adds a child item.
CXTPPropertyGridItem::SetCaption
void SetCaption(LPCTSTR lpszCaption)
Sets the caption text for the item.
Definition XTPPropertyGridItem.h:1940
CXTPPropertyGridItem::OnConstraintsChanged
virtual void OnConstraintsChanged()
This method is called when constraints are added to the item (i.e.
Definition XTPPropertyGridItem.h:2037
CXTPPropertyGridItem::GetEditStyle
virtual DWORD GetEditStyle() const
Gets the edit style of the item.
CXTPPropertyGridItem::MeasureItem
virtual void MeasureItem(LPMEASUREITEMSTRUCT lpMeasureItemStruct)
Override this method and fill in a specified MEASUREITEMSTRUCT structure to inform Windows of the lis...
CXTPPropertyGridItem::m_pGrid
CXTPPropertyGridView * m_pGrid
Parent grid class.
Definition XTPPropertyGridItem.h:1765
CXTPPropertyGridItem::IsVisible
BOOL IsVisible() const
Determines the visible state of the item.
Definition XTPPropertyGridItem.h:1993
CXTPPropertyGridItem::SetItemData
void SetItemData(DWORD_PTR dwData)
Sets the 32-bit value associated with the item.
Definition XTPPropertyGridItem.h:2040
CXTPPropertyGridItem::CXTPPropertyGridItem
CXTPPropertyGridItem(LPCTSTR lpszCaption, LPCTSTR strValue=NULL, CString *pBindString=NULL)
Constructs a CXTPPropertyGridItem object.
CXTPPropertyGridItem::Expand
void Expand()
Expands the item.
CXTPPropertyGridItem::OnAfterEdit
virtual BOOL OnAfterEdit(CString &strValue)
This method is called before the user applies a new value to the item.
CXTPPropertyGridItem::m_pMarkupValue
CXTPMarkupUIElement * m_pMarkupValue
Markup UIElement for item's value.
Definition XTPPropertyGridItem.h:1794
CXTPPropertyGridItem::m_nIndent
int m_nIndent
Indent of the item.
Definition XTPPropertyGridItem.h:1750
CXTPPropertyGridItem::m_pConstraints
CXTPPropertyGridItemConstraints * m_pConstraints
Item's constraints.
Definition XTPPropertyGridItem.h:1767
CXTPPropertyGridItem::m_pMarkupCaption
CXTPMarkupUIElement * m_pMarkupCaption
Markup UIElement for item's caption.
Definition XTPPropertyGridItem.h:1792
CXTPPropertyGridItem::GetMultiLinesCount
int GetMultiLinesCount() const
Gets the number of lines of the item.
Definition XTPPropertyGridItem.h:2088
CXTPPropertyGridItem::GetChilds
CXTPPropertyGridItems * GetChilds() const
Gets the item's list of child items.
Definition XTPPropertyGridItem.h:2013
CXTPPropertyGridItem::GetDescription
CString GetDescription() const
Gets the description text of the item.
Definition XTPPropertyGridItem.h:1953
CXTPPropertyGridItem::GetCaptionMetrics
CXTPPropertyGridItemMetrics * GetCaptionMetrics() const
Gets the metrics of the caption part.
CXTPPropertyGridItem::GetViewValue
virtual CString GetViewValue()
Gets the value of the item that the user is currently viewing.
CXTPPropertyGridItem::HasParent
BOOL HasParent(CXTPPropertyGridItem *pParent)
Determines if the item has a specified item as a parent.
CXTPPropertyGridItem::m_nLinesCount
int m_nLinesCount
Number of lines in a multi-line item.
Definition XTPPropertyGridItem.h:1790
CXTPPropertyGridItem::OnValueChanged
virtual void OnValueChanged(CString strValue)
This method is called when the value of the item is changed.
CXTPPropertyGridItem::GetDropDownItemCount
int GetDropDownItemCount() const
Gets the number of items in the dropdown list.
Definition XTPPropertyGridItem.h:2104
CXTPPropertyGridItem::OnSelect
virtual void OnSelect()
This method is called when an item is selected.
CXTPPropertyGridItem::PtInValueRect
BOOL PtInValueRect(CPoint point)
Determines if a specified point is within the value rectangle.
CXTPPropertyGridItem::AddSpinButton
CXTPPropertyGridInplaceSpinButton * AddSpinButton()
Adds a spin button control.
CXTPPropertyGridItem::IsAllowEdit
virtual BOOL IsAllowEdit() const
Determines if items in the property grid are allowed to be edited by the user.
CXTPPropertyGridItem::GetCaption
CString GetCaption() const
Gets the caption text of the item.
Definition XTPPropertyGridItem.h:1949
CXTPPropertyGridItem::GetID
UINT GetID() const
Gets the identifier of the item.
Definition XTPPropertyGridItem.h:1969
CXTPPropertyGridItem::GetMaskedText
CString GetMaskedText() const
Gets the actual text value of the item without mask characters.
CXTPPropertyGridItem::m_strValue
CString m_strValue
Value of the item.
Definition XTPPropertyGridItem.h:1759
CXTPPropertyGridItem::SetHeight
void SetHeight(int nHeight)
Sets the variable height of the item.
CXTPPropertyGridItem::m_bExpandable
BOOL m_bExpandable
TRUE if the item can be expanded.
Definition XTPPropertyGridItem.h:1757
CXTPPropertyGridItem::GetHeight
int GetHeight() const
Gets the variable height of the item.
Definition XTPPropertyGridItem.h:2080
CXTPPropertyGridItem::m_chPrompt
TCHAR m_chPrompt
Character used as a space holder for a character.
Definition XTPPropertyGridItem.h:1782
CXTPPropertyGridItem::GetInplaceList
virtual CXTPPropertyGridInplaceList & GetInplaceList()
Gets the in-place list control of the item.
CXTPPropertyGridItem::GetInplaceButtons
CXTPPropertyGridInplaceButtons * GetInplaceButtons() const
Gets the collection of in-place buttons of the item.
CXTPPropertyGridItem::SetEditText
virtual void SetEditText(const CString &str)
Sets the text for the in-place edit control.
CXTPPropertyGridItem::GetValueRect
virtual CRect GetValueRect()
Gets the bounding rectangle of the item value's text.
CXTPPropertyGridItem::Select
void Select()
Selects the item.
CXTPPropertyGridItem::GetInplaceEdit
virtual CXTPPropertyGridInplaceEdit & GetInplaceEdit()
Gets the in-place edit control of the item.
CXTPPropertyGridItem::GetMarkupTemplate
virtual CString GetMarkupTemplate() const
Gets the markup text of the item.
Definition XTPPropertyGridItem.h:1957
CXTPPropertyGridItem::GetConstraintEdit
BOOL GetConstraintEdit() const
Determines if constraint editing mode is enabled/disabled.
Definition XTPPropertyGridItem.h:2025
CXTPPropertyGridItem::SelectNextConstraint
BOOL SelectNextConstraint()
Selects the next constraint in the list of constraints.
CXTPPropertyGridItem::m_bVisible
BOOL m_bVisible
Visibility of the item.
Definition XTPPropertyGridItem.h:1755
CXTPPropertyGridItem::m_bConstraintEdit
BOOL m_bConstraintEdit
TRUE to constraint edit.
Definition XTPPropertyGridItem.h:1748
CXTPPropertyGridItem::OnCancelEdit
virtual void OnCancelEdit()
This method is called if the user cancels editing the item.
CXTPPropertyGridItem::m_bReadOnly
BOOL m_bReadOnly
TRUE if the item state is set to read-only, FALSE if the item state is set to read/write.
Definition XTPPropertyGridItem.h:1753
CXTPPropertyGridItem::IsInplaceButtonVisible
virtual BOOL IsInplaceButtonVisible(CXTPPropertyGridInplaceButton *pButton) const
Determines if a specified in-place button is visible.
CXTPPropertyGridItem::GetValueMetrics
CXTPPropertyGridItemMetrics * GetValueMetrics() const
Gets the metrics of the value part.
CXTPPropertyGridItem::GetMarkupValue
CXTPMarkupUIElement * GetMarkupValue() const
Gets the CXTPMarkupUIElement object that renders the value of the item in the property grid.
Definition XTPPropertyGridItem.h:2128
CXTPPropertyGridItem::~CXTPPropertyGridItem
virtual ~CXTPPropertyGridItem()
Destroys a CXTPPropertyGridItem object, handles cleanup and deallocation.
CXTPPropertyGridItem::SetFlags
void SetFlags(UINT nFlags)
Sets a specific flag for the item.
CXTPPropertyGridItem::SetID
void SetID(UINT nID)
Sets the identifier for the item.
Definition XTPPropertyGridItem.h:1965
CXTPPropertyGridItem::SetExpandable
void SetExpandable(BOOL bExpandable)
Specifies if the item should be expandable by the user.
Definition XTPPropertyGridItem.h:2001
CXTPPropertyGridItem::SetReadOnly
virtual void SetReadOnly(BOOL bReadOnly=TRUE)
Specifies if the item state should be set to read-only or to read/write.
CXTPPropertyGridItem::OnValidateEdit
virtual void OnValidateEdit()
This method is called to check the value from the in-place edit control.
CXTPPropertyGridItem::m_dwData
DWORD_PTR m_dwData
The 32-bit value associated with the item.
Definition XTPPropertyGridItem.h:1787
CXTPPropertyGridItem::IsValueChanged
virtual BOOL IsValueChanged() const
Determines if the value of the item was changed by the user.
CXTPPropertyGridItem::SetMask
void SetMask(LPCTSTR strMask, LPCTSTR strLiteral, TCHAR chPrompt=_T('_'))
Applies a specified mask to a CXTPPropertyGridItem data field to create a restrictive field for text ...
CXTPPropertyGridItem::IsHidden
BOOL IsHidden() const
Determines if the item is hidden/shown.
CXTPPropertyGridItem::GetParentItem
CXTPPropertyGridItem * GetParentItem() const
Gets the parent item of this item, if any.
Definition XTPPropertyGridItem.h:2009
CXTPPropertyGridItem::CXTPPropertyGridItem
CXTPPropertyGridItem(UINT nID, LPCTSTR strValue=NULL, CString *pBindString=NULL)
Constructs a CXTPPropertyGridItem object.
CXTPPropertyGridItem::GetTooltip
CString GetTooltip() const
Gets the tooltip text of the item.
Definition XTPPropertyGridItem.h:2116
CXTPPropertyGridItem::OnAddChildItem
virtual void OnAddChildItem()
This method is called when an item is added to the parent.
CXTPPropertyGridItem::SetPasswordMask
void SetPasswordMask(TCHAR chMask=_T(' *'))
Sets a password mask for the item.
Definition XTPPropertyGridItem.h:2029
CXTPPropertyGridItem::OnInplaceButtonDown
virtual void OnInplaceButtonDown(CXTPPropertyGridInplaceButton *pButton)
This method is called when the user presses the in-place button.
CXTPPropertyGridItem::OnMergeItemConstraint
virtual CSize OnMergeItemConstraint(CDC *pDC, CXTPPropertyGridItemConstraint *pConstraint)
This method is called to get size of constraint in in-place list.
CXTPPropertyGridItem::m_bPassword
BOOL m_bPassword
TRUE to use a password mask.
Definition XTPPropertyGridItem.h:1785
CXTPPropertyGridItem::RedrawItem
void RedrawItem()
Redraws the item.
CXTPPropertyGridItem::OnCaptionChanged
virtual void OnCaptionChanged()
This method is called when the caption of the item is changed.
CXTPPropertyGridItem::SetDescription
void SetDescription(LPCTSTR lpszDescription)
Sets the description text for the item.
CXTPPropertyGridItem::GetInPlacedEditValue
virtual CString GetInPlacedEditValue()
Gets the text of the in-place edit control.
Definition XTPPropertyGridItem.h:1688
CXTPPropertyGridItem::m_strMarkupTemplate
CString m_strMarkupTemplate
String that represents item's display when markup is on.
Definition XTPPropertyGridItem.h:1779
CXTPPropertyGridItem::SetAutoComplete
void SetAutoComplete(BOOL bAutoComplete=TRUE)
Enables/disables auto-complete for the constraint list.
Definition XTPPropertyGridItem.h:2108
CXTPPropertyGridItem::SetHidden
void SetHidden(BOOL bHidden)
Hides/shows the item.
CXTPPropertyGridItem::GetIndex
int GetIndex() const
Gets the index of the item within the property grid list.
CXTPPropertyGridItem::m_nDropDownItemCount
int m_nDropDownItemCount
Maximum drop down items.
Definition XTPPropertyGridItem.h:1773
CXTPPropertyGridItem::HasChilds
BOOL HasChilds() const
Determines if the item has children.
Definition XTPPropertyGridItem.h:1936
CXTPPropertyGridItem::OnChar
virtual BOOL OnChar(UINT nChar)
This method is called when a key is pressed.
CXTPPropertyGridItem::OnRButtonDown
virtual void OnRButtonDown(UINT nFlags, CPoint point)
This method is called when the user presses the right mouse button on the item.
Definition XTPPropertyGridItem.h:2034
CXTPPropertyGridItem::SetFocusToInplaceControl
virtual void SetFocusToInplaceControl()
Sets focus to the in-place control of the item.
CXTPPropertyGridItem::m_nHeight
int m_nHeight
Item's height; -1 to use the default.
Definition XTPPropertyGridItem.h:1789
CXTPPropertyGridItem::GetIndent
int GetIndent() const
Gets the indent of the item.
Definition XTPPropertyGridItem.h:2017
CXTPPropertyGridItem::m_strCaption
CString m_strCaption
Caption of the item.
Definition XTPPropertyGridItem.h:1761
CXTPPropertyGridItemMetrics
Standalone class used by CXTPPropertyGridPaintManager to store item metrics.
Definition XTPPropertyGridPaintManager.h:50
CXTPPropertyGridItems
CXTPPropertyGridItems is a CList derived class.
Definition XTPPropertyGridItem.h:110
CXTPPropertyGridItems::CXTPPropertyGridItems
CXTPPropertyGridItems()
Constructs a CXTPPropertyGridItems object.
CXTPPropertyGridItems::Find
int Find(CXTPPropertyGridItem *pItem) const
Retrieves the index of a specified item within the collection of items.
CXTPPropertyGridItems::FindItem
CXTPPropertyGridItem * FindItem(LPCTSTR strCaption) const
Retrieves an item by its caption.
CXTPPropertyGridItems::GetAt
CXTPPropertyGridItem * GetAt(int nIndex) const
Retrieves the item at a specified index within the collection of items.
CXTPPropertyGridItems::InsertAt
void InsertAt(int nIndex, CXTPPropertyGridItem *pItem)
Inserts a specified item at a specified index within the property grid's collection of items.
Definition XTPPropertyGridItem.h:1932
CXTPPropertyGridItems::AddTail
void AddTail(CXTPPropertyGridItem *pItem)
Adds an item/collection of items to the end (tail) of the property grid's collection of items.
Definition XTPPropertyGridItem.h:1928
CXTPPropertyGridItems::Clear
void Clear()
Clears all items from the collection of items.
CXTPPropertyGridItems::IsEmpty
BOOL IsEmpty() const
Determines if any items have been added to the property grid.
Definition XTPPropertyGridItem.h:1924
CXTPPropertyGridItems::GetCount
long GetCount() const
Gets the number of items within the collection of items.
Definition XTPPropertyGridItem.h:1920
CXTPPropertyGridItems::RemoveAt
void RemoveAt(int nIndex)
Removes the item at a specified index within the collection of items.
CXTPPropertyGridItems::Sort
void Sort()
Sorts the collection of items in alphabetical order.
CXTPPropertyGridItems::FindItem
CXTPPropertyGridItem * FindItem(UINT nID) const
Retrieves an item by its identifier.
CXTPPropertyGridItems::AddTail
void AddTail(CXTPPropertyGridItems *pItems)
Adds an item/collection of items to the end (tail) of the property grid's collection of items.
CXTPPropertyGridView
CXTPPropertyGridView is a CListBox derived class.
Definition XTPPropertyGridView.h:49


Toolkit Pro: Member List

CXTPChartPyramidSeriesStyleBase Member List

This is the complete list of members for CXTPChartPyramidSeriesStyleBase, including all inherited members.

ApplyTo(CXTPChartDeviceCommand *pCommand) | CXTPChartSeriesStyle | virtual
CorrectAxisSideMargins(CXTPChartAxis *pAxis, double nMinValue, double nMaxValue, double &nCorrection) | CXTPChartSeriesStyle | virtual
CreateDiagram()=0 | CXTPChartPyramidSeriesStyleBase | protectedpure virtual
CreateView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)=0 | CXTPChartPyramidSeriesStyleBase | protectedpure virtual
CXTPChartElement() | CXTPChartElement |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartPyramidSeriesStyleBase() | CXTPChartPyramidSeriesStyleBase |
CXTPChartSeriesStyle() | CXTPChartSeriesStyle |
DoPropExchange(CXTPPropExchange *pPX) | CXTPChartPyramidSeriesStyleBase | virtual
Enable3dEdgeSmoothing(BOOL bEnable=TRUE) | CXTPChartSeriesStyle | virtual
Get3dRotation() const | CXTPChartSeriesStyle | virtual
GetAppearance() const | CXTPChartElement |
GetBorder() const | CXTPChartPyramidSeriesStyleBase |
GetColor() const | CXTPChartSeriesStyle | virtual
GetContent() const | CXTPChartElement |
GetErrorBar() const | CXTPChartSeriesStyle | virtual
GetFillStyle() const | CXTPChartPyramidSeriesStyleBase |
GetHeightToWidthRatio() const | CXTPChartPyramidSeriesStyleBase |
GetLabel() const | CXTPChartSeriesStyle | virtual
GetOwner() const | CXTPChartElement |
GetPointDistance() const | CXTPChartPyramidSeriesStyleBase |
GetSeriesPointValueIndex() const | CXTPChartSeriesStyle | virtual
GetStyleAppearance() const | CXTPChartSeriesStyle | virtual
GetTransparency() const | CXTPChartSeriesStyle | virtual
Is3D() const | CXTPChartObject |
Is3dEdgeSmoothingEnabled() const | CXTPChartSeriesStyle | virtual
IsColorEach() const | CXTPChartSeriesStyle | virtual
IsStyleDiagram(CXTPChartDiagram *pDiagram) const =0 | CXTPChartPyramidSeriesStyleBase | protectedpure virtual
m_bColorEach | CXTPChartSeriesStyle | protected
m_bSmooth3dEdges | CXTPChartSeriesStyle | protected
m_clrColor | CXTPChartSeriesStyle | protected
m_nTransparency | CXTPChartSeriesStyle | protected
m_pErrorBar | CXTPChartSeriesStyle | protected
m_pLabel | CXTPChartSeriesStyle | protected
m_Rotation3d | CXTPChartSeriesStyle | protected
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartElement | virtual
Release() | CXTPChartElement | virtual
Set3dRotation(const CXTPChart3dRotation &rotation) | CXTPChartSeriesStyle | virtual
Set3dRotation(double dYaw, double dPitch, double dRoll) | CXTPChartSeriesStyle | virtual
SetColor(CXTPChartColor clr) | CXTPChartSeriesStyle | virtual
SetColorEach(BOOL bColorEach) | CXTPChartSeriesStyle | virtual
SetErrorBar(CXTPChartErrorBar *pErrorBar) | CXTPChartSeriesStyle | virtual
SetHeightToWidthRatio(double dRatio) | CXTPChartPyramidSeriesStyleBase |
SetLabel(CXTPChartSeriesLabel *pLabel) | CXTPChartSeriesStyle | virtual
SetPointDistance(int nPointDistance) | CXTPChartPyramidSeriesStyleBase |
SetTransparency(int nTransparency) | CXTPChartSeriesStyle | virtual
~CXTPChartElement() | CXTPChartElement | virtual
~CXTPChartPyramidSeriesStyleBase() | CXTPChartPyramidSeriesStyleBase | virtual
~CXTPChartSeriesStyle() | CXTPChartSeriesStyle | virtual


Toolkit Pro: Member List

CXTPTaskPanelListViewOffice2003Theme Member List

This is the complete list of members for CXTPTaskPanelListViewOffice2003Theme, including all inherited members.

BlendColor(COLORREF clrFrom, COLORREF clrTo, int nAlpha) | CXTPTaskPanelPaintManager | protected
CreateGripperBitmaps() | CXTPTaskPanelPaintManager | protected
CreateGripperIcon(HICON &hIcon, UINT nIDResource, COLORREF clrGripperBack) | CXTPTaskPanelPaintManager | protected
CXTPTaskPanelListViewOffice2003Theme() | CXTPTaskPanelListViewOffice2003Theme |
CXTPTaskPanelListViewOfficeXPTheme() | CXTPTaskPanelListViewOfficeXPTheme |
CXTPTaskPanelListViewTheme() | CXTPTaskPanelListViewTheme |
CXTPTaskPanelPaintManager() | CXTPTaskPanelPaintManager |
CXTPTaskPanelPaintManagerPlain() | CXTPTaskPanelPaintManagerPlain |
CXTPTaskPanelToolboxTheme() | CXTPTaskPanelToolboxTheme |
DrawCaptionGripper(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelPaintManager | protectedvirtual
DrawCaptionGripperBitmap(CDC *pDC, CXTPTaskPanelGroup *pGroup, BOOL bExpanded, BOOL bHot, CRect rc) | CXTPTaskPanelPaintManager | protected
DrawCaptionGripperSigns(CDC *pDC, CPoint pt, COLORREF clr, BOOL bExpanded) | CXTPTaskPanelPaintManager | protected
DrawDragArrow(CDC *pDC, CXTPTaskPanelItem *pItem, CRect rc, BOOL bAfter=FALSE) | CXTPTaskPanelPaintManager | protectedvirtual
DrawFocusRect(CDC *pDC, CRect rc) | CXTPTaskPanelPaintManager | protectedvirtual
DrawGroupCaption(CDC *pDC, CXTPTaskPanelGroup *pGroup, BOOL bDraw) | CXTPTaskPanelToolboxTheme | virtual
DrawGroupCaptionBackground(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelListViewOffice2003Theme | virtual
DrawGroupClient(CDC *pDC, CXTPTaskPanelGroup *pGroup) | CXTPTaskPanelPaintManager | virtual
DrawGroupClientFace(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelPaintManagerPlain | virtual
DrawGroupClientItems(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelPaintManager | protectedvirtual
DrawGroupItem(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw) | CXTPTaskPanelPaintManager | virtual
DrawGroupItemFrame(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc) | CXTPTaskPanelPaintManager | virtual
DrawGroupItemImage(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw) | CXTPTaskPanelPaintManager | protected
DrawGroupItemImageWithText(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw) | CXTPTaskPanelPaintManager | protected
DrawGroupItemImageWithTextBelow(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw) | CXTPTaskPanelPaintManager | protected
DrawItemCaption(CDC *pDC, CXTPTaskPanelItem *pItem, CRect rcText, UINT nFormat) | CXTPTaskPanelPaintManager | protectedvirtual
DrawItemImage(CDC *pDC, CXTPTaskPanelItem *pItem, CPoint ptIcon, CXTPImageManagerIcon *pImage, CSize szIcon) | CXTPTaskPanelPaintManager | protectedvirtual
DrawScrollButton(CDC *pDC, CXTPTaskPanelScrollButton *pScrollButton) | CXTPTaskPanelPaintManager | virtual
FillGroupClientFace(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelPaintManagerPlain | virtual
FillTaskPanel(CDC *pDC, CXTPTaskPanel *pTaskPanel) | CXTPTaskPanelPaintManagerPlain | virtual
FreeBitmaps() | CXTPTaskPanelPaintManager | protected
GetCaptionGripperWidth(CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelPaintManager | protectedvirtual
GetControlMargins(const CXTPTaskPanel *pPanel) | CXTPTaskPanelPaintManager | virtual
GetGroupColors(BOOL bSpecial) | CXTPTaskPanelPaintManager |
GetGroupColors(CXTPTaskPanelGroup *pGroup) | CXTPTaskPanelPaintManager | virtual
GetGroupInnerMargins(const CXTPTaskPanelGroup *pGroup) | CXTPTaskPanelPaintManager | virtual
GetGroupOuterMargins(const CXTPTaskPanelGroup *pGroup) | CXTPTaskPanelPaintManager | virtual
GetGroupSpacing(const CXTPTaskPanel *pPanel) | CXTPTaskPanelPaintManager | virtual
GetHighlightOffset(CXTPTaskPanelGroupItem *pItem) | CXTPTaskPanelPaintManager | protectedvirtual
GetItemFont(CXTPTaskPanelItem *pItem) | CXTPTaskPanelPaintManager | virtual
GetItemIconPadding(const CXTPTaskPanelItem *pItem) | CXTPTaskPanelPaintManager | virtual
GetItemInnerMargins(const CXTPTaskPanelGroupItem *pItem) | CXTPTaskPanelPaintManager | virtual
GetItemOuterMargins(const CXTPTaskPanelGroupItem *pItem) | CXTPTaskPanelPaintManager | virtual
m_bBoldCaption | CXTPTaskPanelPaintManager |
m_bCaptionScrollButton | CXTPTaskPanelPaintManager |
m_bEmbossedDisabledText | CXTPTaskPanelPaintManager |
m_bEmulateEplorerTheme | CXTPTaskPanelPaintManager |
m_bInvertDragRect | CXTPTaskPanelPaintManager |
m_bLeftRoundedCorner | CXTPTaskPanelPaintManager | protected
m_bmpGrippers | CXTPTaskPanelPaintManager | protected
m_bOfficeBorder | CXTPTaskPanelPaintManager | protected
m_bOfficeCaption | CXTPTaskPanelPaintManagerPlain | protected
m_bOfficeHighlight | CXTPTaskPanelPaintManager |
m_bRightRoundedCorner | CXTPTaskPanelPaintManager | protected
m_bRoundedFrame | CXTPTaskPanelPaintManagerPlain | protected
m_bUseBitmapGrippers | CXTPTaskPanelPaintManager | protected
m_bUseStandardCaptionFont | CXTPTaskPanelPaintManager | protected
m_bUseStandardItemsFont | CXTPTaskPanelPaintManager | protected
m_clrBackground | CXTPTaskPanelPaintManager | protected
m_clrHighlightBorder | CXTPTaskPanelPaintManager | protected
m_clrHighlightHot | CXTPTaskPanelPaintManager | protected
m_clrHighlightPressed | CXTPTaskPanelPaintManager | protected
m_clrHighlightSelected | CXTPTaskPanelPaintManager | protected
m_eGripper | CXTPTaskPanelPaintManager |
m_grcHot | CXTPTaskPanelListViewOffice2003Theme |
m_grcPushed | CXTPTaskPanelListViewOffice2003Theme |
m_groupNormal | CXTPTaskPanelPaintManager | protected
m_groupSpecial | CXTPTaskPanelPaintManager | protected
m_hGripperNormal | CXTPTaskPanelPaintManager | protected
m_hGripperSpecial | CXTPTaskPanelPaintManager | protected
m_nCaptionHeight | CXTPTaskPanelPaintManager | protected
m_nCaptionTextFormat | CXTPTaskPanelPaintManager | protected
m_nGroupSpacing | CXTPTaskPanelPaintManager |
m_nItemTextFormat | CXTPTaskPanelPaintManager | protected
m_rcControlMargins | CXTPTaskPanelPaintManager |
m_rcGroupIconPadding | CXTPTaskPanelPaintManager |
m_rcGroupInnerMargins | CXTPTaskPanelPaintManager |
m_rcGroupOuterMargins | CXTPTaskPanelPaintManager |
m_rcImageLayoutIconPadding | CXTPTaskPanelPaintManager |
m_rcItemIconPadding | CXTPTaskPanelPaintManager |
m_rcItemInnerMargins | CXTPTaskPanelPaintManager |
m_rcItemOuterMargins | CXTPTaskPanelPaintManager |
m_xtpFontCaption | CXTPTaskPanelPaintManager | protected
m_xtpFontIcon | CXTPTaskPanelPaintManager | protected
m_xtpFontIconBold | CXTPTaskPanelPaintManager | protected
m_xtpFontIconHot | CXTPTaskPanelPaintManager | protected
m_xtpFontIconHotBold | CXTPTaskPanelPaintManager | protected
Rectangle(CDC *pDC, CRect rc, COLORREF clrPen, COLORREF clrBrush) | CXTPTaskPanelPaintManager | protected
rectDefault | CXTPTaskPanelPaintManager | static
RefreshMetrics() | CXTPTaskPanelListViewOffice2003Theme | virtual
SetCaptionFontIndirect(LOGFONT *pLogFont, BOOL bUseStandardCaptionFont=FALSE) | CXTPTaskPanelPaintManager |
SetItemsFontIndirect(LOGFONT *pLogFont, BOOL bUseStandardItemsFont=FALSE) | CXTPTaskPanelPaintManager |
SetTextFormat(int nTextFormat, BOOL bCaption=FALSE) | CXTPTaskPanelPaintManager |
~CXTPTaskPanelPaintManager() | CXTPTaskPanelPaintManager | virtual


Toolkit Pro: XTPDockingPaneThemeOffice2002Visio.h Source File

  • Source
  • DockingPane
  • Themes
XTPDockingPaneThemeOffice2002Visio.h
Go to the documentation of this file.
1
23#if !defined(__XTPDOCKINGPANETHEMEOFFICE2002VISIO_H__)
24# define __XTPDOCKINGPANETHEMEOFFICE2002VISIO_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
41class _XTP_EXT_CLASS CXTPDockingPaneOffice2002VisioTheme
42 : public CXTPDockingPaneVisualStudio2003Theme
43{
44public:
49 CXTPDockingPaneOffice2002VisioTheme();
50
55 void RefreshMetrics();
56
64 void DrawCaption(CDC* pDC, CXTPDockingPaneTabbedContainer* pPane, CRect rc);
65
73 void DrawPane(CDC* pDC, CXTPDockingPaneTabbedContainer* pPane, CRect rc);
74
82 void AdjustCaptionRect(const CXTPDockingPaneTabbedContainer* pPane, CRect& rc);
83
84# if _MSC_VER > 1200
85 using CXTPDockingPanePaintManager::AdjustCaptionRect;
86# endif
87
95 void DrawFloatingFrame(CDC* pDC, CXTPDockingPaneMiniWnd* pPane, CRect rc);
96};
97
98# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
100#endif // !defined(__XTPDOCKINGPANETHEMEOFFICE2002VISIO_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPDockingPaneMiniWnd
CXTPDockingPaneMiniWnd is a multiple inheritance class derived from CMiniFrameWnd and CXTPDockingPane...
Definition XTPDockingPaneMiniWnd.h:42
CXTPDockingPaneOffice2002VisioTheme
CXTPDockingPaneOffice2002VisioTheme is a CXTPDockingPaneVisualStudio2003Theme derived class that repr...
Definition XTPDockingPaneThemeOffice2002Visio.h:43
CXTPDockingPaneOffice2002VisioTheme::CXTPDockingPaneOffice2002VisioTheme
CXTPDockingPaneOffice2002VisioTheme()
Constructs a CXTPDockingPaneOffice2002VisioTheme object.
CXTPDockingPaneOffice2002VisioTheme::AdjustCaptionRect
void AdjustCaptionRect(const CXTPDockingPaneTabbedContainer *pPane, CRect &rc)
Override this member to change the caption rectangle of the child docking pane.
CXTPDockingPaneOffice2002VisioTheme::DrawFloatingFrame
void DrawFloatingFrame(CDC *pDC, CXTPDockingPaneMiniWnd *pPane, CRect rc)
Call this method to draw the frame of a floating window.
CXTPDockingPaneOffice2002VisioTheme::RefreshMetrics
void RefreshMetrics()
This method is called to refresh the visual metrics of the pane.
CXTPDockingPaneOffice2002VisioTheme::DrawPane
void DrawPane(CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc)
Override this member function to draw a tabbed container.
CXTPDockingPaneOffice2002VisioTheme::DrawCaption
void DrawCaption(CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc)
Override this member function to draw a caption.
CXTPDockingPanePaintManager::AdjustCaptionRect
virtual void AdjustCaptionRect(const CXTPDockingPaneSidePanel *pPane, CRect &rc)
Override this member to change the caption rectangle of the child docking pane.
CXTPDockingPaneTabbedContainer
CXTPDockingPaneTabbedContainer is a multiple inheritance class derived from CWnd and CXTPDockingPaneB...
Definition XTPDockingPaneTabbedContainer.h:47
CXTPDockingPaneVisualStudio2003Theme
CXTPDockingPaneVisualStudio2003Theme is a CXTPDockingPaneGripperedTheme derived class that represents...
Definition XTPDockingPaneThemeVisualStudio2003.h:42


Toolkit Pro: Member List

XTP_GRIDRECORDITEM_METRICS Member List

This is the complete list of members for XTP_GRIDRECORDITEM_METRICS, including all inherited members.

clrBackground | XTP_GRIDRECORDITEM_METRICS |
clrForeground | XTP_GRIDRECORDITEM_METRICS |
CXTPCmdTarget() | CXTPCmdTarget |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
nColumnAlignment | XTP_GRIDRECORDITEM_METRICS |
nGroupRowIcon | XTP_GRIDRECORDITEM_METRICS |
nGroupRowIconAlignment | XTP_GRIDRECORDITEM_METRICS |
nItemIcon | XTP_GRIDRECORDITEM_METRICS |
nVirtRowFlags | XTP_GRIDRECORDITEM_METRICS |
nVirtRowLevel | XTP_GRIDRECORDITEM_METRICS |
pFont | XTP_GRIDRECORDITEM_METRICS |
strText | XTP_GRIDRECORDITEM_METRICS |


Toolkit Pro: XTPMarkupInlineUIContainer.h Source File

  • Source
  • Markup
  • Text
XTPMarkupInlineUIContainer.h
Go to the documentation of this file.
1
23#if !defined(__XTPMARKUPINLINEUICONTAINER_H__)
24# define __XTPMARKUPINLINEUICONTAINER_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPMarkupObject;
34class CXTPMarkupUIElement;
35class CXTPMarkupBuilder;
36class CXTPMarkupDrawingContext;
37
38class _XTP_EXT_CLASS CXTPMarkupInlineUIContainer : public CXTPMarkupInline
39{
41 DECLARE_MARKUPCLASS(CXTPMarkupInlineUIContainer);
43protected:
44 CXTPMarkupInlineUIContainer();
45 CXTPMarkupInlineUIContainer(CXTPMarkupUIElement* pElement);
46 ~CXTPMarkupInlineUIContainer();
47
48public:
49 void SetChild(CXTPMarkupUIElement* pElement);
50 CXTPMarkupUIElement* GetChild() const;
51
52public:
53 virtual POSITION GetContentStartPosition() const;
54 virtual void GetContentNextPosition(POSITION& pos) const;
55 virtual BOOL IsWordBreakPosition(POSITION pos) const;
56 virtual void Render(CXTPMarkupDrawingContext* pDC, CRect rc, POSITION posStart,
57 POSITION posEnd);
58 virtual CSize Measure(CXTPMarkupDrawingContext* pDC, POSITION posStart, POSITION posEnd);
59 virtual void Measure(CXTPMarkupDrawingContext* pDC, POSITION posStart, POSITION posEnd,
60 CXTPSizeF& size);
61 virtual void Arrange(CRect rcFinalRect, POSITION posStart, POSITION posEnd);
62
63protected:
64 virtual BOOL HasContentObject() const;
65 virtual void SetContentObject(CXTPMarkupBuilder* pBuilder, CXTPMarkupObject* pContent);
66 virtual int GetLogicalChildrenCount() const;
67 virtual CXTPMarkupObject* GetLogicalChild(int nIndex) const;
68
69 CXTPMarkupInputElement* InputHitTest(CPoint point) const;
70
72public:
73 DECLARE_DISPATCH_MAP()
74# ifdef _XTP_ACTIVEX
75 DECLARE_INTERFACE_MAP()
76 DECLARE_OLETYPELIB_EX(CXTPMarkupInlineUIContainer);
77# endif
78
79 afx_msg LPDISPATCH OleGetChild();
80 afx_msg void OleSetChild(LPDISPATCH lpDisp);
81
84protected:
85 CXTPMarkupUIElement* m_pChild;
86};
87
88AFX_INLINE int CXTPMarkupInlineUIContainer::GetLogicalChildrenCount() const
89{
90 return m_pChild ? 1 : 0;
91}
92
93AFX_INLINE CXTPMarkupObject* CXTPMarkupInlineUIContainer::GetLogicalChild(int nIndex) const
94{
95 return nIndex == 0 ? (CXTPMarkupObject*)m_pChild : NULL;
96}
97
98# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
100#endif // !defined(__XTPMARKUPINLINEUICONTAINER_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPMarkupUIElement
Base class for XML Markup core level implementations.
Definition XTPMarkupUIElement.h:43
CXTPSizeT
This class incapsulates size data.
Definition XTPSize.h:40


Toolkit Pro: Member List

CXTPMiniToolBar Member List

This is the complete list of members for CXTPMiniToolBar, including all inherited members.

AdjustExcludeRect(CRect &rc, BOOL bVertical) | CXTPPopupBar | protectedvirtual
Animate() | CXTPPopupBar | protectedvirtual
CalcDynamicLayout(int nLength, DWORD dwMode) | CXTPPopupToolBar | protectedvirtual
CalculatePopupRect(CPoint ptPopup, CSize sz) | CXTPPopupBar | virtual
Copy(CXTPCommandBar *pCommandBar, BOOL bRecursive=FALSE) | CXTPPopupBar | protectedvirtual
Create() | CXTPPopupBar | virtual
CreateKeyboardTips() | CXTPCommandBar | virtual
CreateMiniToolBar(CXTPCommandBars *pCommandBars) | CXTPMiniToolBar | static
CreatePopupBar(CXTPCommandBars *pCommandBars) | CXTPPopupBar | static
CreatePopupToolBar(CXTPCommandBars *pCommandBars) | CXTPPopupToolBar | static
CursorInWindow() const | CXTPMiniToolBar | protected
CXTPCommandBar() | CXTPCommandBar | protected
CXTPHookManagerHookAble() | CXTPHookManagerHookAble |
CXTPMiniToolBar() | CXTPMiniToolBar | protected
CXTPPopupBar() | CXTPPopupBar | protected
DelayLayout() | CXTPCommandBar |
DelayRedraw() | CXTPPopupBar | inlineprotectedvirtual
DestroyWindow() | CXTPPopupBar |
DisableShadow() | CXTPPopupBar |
DoPropExchange(CXTPPropExchange *pPX) | CXTPPopupBar | protectedvirtual
DrawCommandBar(CDC *pDC, CRect rcClipBox) | CXTPPopupBar | protectedvirtual
EnableAnimation(BOOL bEnable=TRUE) | CXTPCommandBar |
EnableCustomization(BOOL bEnable=TRUE) | CXTPCommandBar |
EnableDoubleBuffer(BOOL bEnable=TRUE) | CXTPCommandBar |
EnsureVisible(CXTPControl *pControl) | CXTPCommandBar | virtual
ExpandBar() | CXTPPopupBar |
FillCommandBarEntry(CDC *pDC) | CXTPCommandBar | virtual
FindAccel(TCHAR chAccel) const | CXTPCommandBar |
FindAccelEx(UINT chAccel, BOOL &bSelectOnly) const | CXTPCommandBar |
GenerateCommandBarList(DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam) | CXTPCommandBar | protectedvirtual
GetActiveDocTemplate() const | CXTPCommandBar | protected
GetBarID() const | CXTPCommandBar |
GetBorders() | CXTPPopupBar | virtual
GetButtonSize() const | CXTPCommandBar | virtual
GetCommandBarData() const | CXTPCommandBar |
GetCommandBars() const | CXTPCommandBar |
GetControl(int nIndex) const | CXTPCommandBar |
GetControlCount() const | CXTPCommandBar |
GetControlPopup() const | CXTPPopupBar |
GetControls() const | CXTPCommandBar |
GetDefaultButtonStyle() const | CXTPCommandBar |
GetDefaultItem(UINT gmdiFlags, BOOL fByPos=FALSE) | CXTPPopupBar |
GetFlags() const | CXTPCommandBar |
GetFrameSite() const | CXTPCommandBar |
GetIconSize() const | CXTPCommandBar | virtual
GetImageManager() const | CXTPCommandBar |
GetLargeIconSize(BOOL bAutoSize) const | CXTPCommandBar |
GetOwnerSite() const | CXTPCommandBar |
GetPaintManager() const | CXTPCommandBar |
GetParentCommandBar() const | CXTPPopupBar | protectedvirtual
GetPosition() const | CXTPCommandBar |
GetRootParent() const | CXTPCommandBar |
GetSelected() const | CXTPCommandBar |
GetShowGripper() const | CXTPCommandBar |
GetSite() const | CXTPCommandBar |
GetTextOrientation() const | CXTPCommandBar |
GetTitle() const | CXTPCommandBar |
GetTrackFocus() const | CXTPCommandBar |
GetType() const | CXTPCommandBar |
GetWidth() const | CXTPCommandBar |
HideKeyboardTips() | CXTPCommandBar |
InvalidateParents() | CXTPCommandBar |
IsAnimationEnabled() const | CXTPCommandBar |
IsContextMenu() const | CXTPPopupBar |
IsCustomizable() const | CXTPCommandBar | virtual
IsCustomizeDialogPresent() const | CXTPCommandBar |
IsCustomizeMode() const | CXTPCommandBar |
IsDialogBar() const | CXTPCommandBar | virtual
IsDoubleGripper() const | CXTPPopupBar |
IsHelpMode() const | CXTPCommandBar | protected
IsKeyboardCuesVisible() const | CXTPCommandBar | virtual
IsKeyboardTipsVisible() const | CXTPCommandBar |
IsLayoutRTL() const | CXTPCommandBar |
IsMenuTitleBar() const | CXTPCommandBar | virtual
IsPopupBar() const | CXTPPopupBar | virtual
IsResizable() const | CXTPPopupBar | virtual
IsRibbonBar() const | CXTPCommandBar | virtual
IsTearOffPopup(CString &strCaption, UINT &nID, int &nWidth) | CXTPPopupBar |
IsTextBelowIcons() const | CXTPCommandBar |
IsTrackingMode() const | CXTPCommandBar |
IsVisible() const | CXTPPopupBar | virtual
LoadMenu(CMenu *pMenu, BOOL bRemoveControls=TRUE) | CXTPCommandBar | virtual
LoadToolBar(UINT nIDResource, BOOL bLoadIcons=TRUE) | CXTPCommandBar | virtual
LockMouseMove(CXTPControl *pControl) | CXTPCommandBar |
LockRedraw() | CXTPCommandBar |
LPFNUPDATELAYEREDWINDOW typedef | CXTPMiniToolBar | protected
m_bActivated | CXTPMiniToolBar | protected
m_bAnimatePopup | CXTPCommandBar | protected
m_barPosition | CXTPCommandBar | protected
m_barType | CXTPCommandBar | protected
m_bAutoDestroy | CXTPHookManagerHookAble |
m_bCloseable | CXTPCommandBar | protected
m_bCollapsed | CXTPPopupBar | protected
m_bComboBar | CXTPCommandBar |
m_bContextMenu | CXTPPopupBar | protected
m_bCustomizable | CXTPCommandBar | protected
m_bCustomizeDialogPresent | CXTPCommandBar | protected
m_bDoubleGripper | CXTPPopupBar | protected
m_bDynamicLayout | CXTPPopupBar | protected
m_bExecOnRButton | CXTPCommandBar | protected
m_bExpanded | CXTPPopupBar | protected
m_bExpanding | CXTPPopupBar | protected
m_bGrabFocus | CXTPCommandBar | protected
m_bIgnoreUpdateHandler | CXTPCommandBar | protected
m_bKeyboardSelect | CXTPCommandBar | protected
m_bMultiLine | CXTPCommandBar | protected
m_bRecursePopup | CXTPCommandBar | protected
m_bResizable | CXTPPopupBar | protected
m_bShowShadow | CXTPPopupBar | protected
m_bTearOffPopup | CXTPPopupBar | protected
m_bTearOffSelected | CXTPPopupBar | protected
m_bTearOffTracking | CXTPPopupBar | protected
m_bTextBelow | CXTPCommandBar | protected
m_bTracking | CXTPMiniToolBar | protected
m_bTrackOnHover | CXTPCommandBar |
m_buttonStyle | CXTPCommandBar | protected
m_bVerticalMarker | CXTPCommandBar | protected
m_dMaxWidthDivisor | CXTPPopupBar | static
m_dwData | CXTPCommandBar | protected
m_dwFlags | CXTPCommandBar | protected
m_dwStyle | CXTPCommandBar | protected
m_hwndFocus | CXTPCommandBar | protected
m_nBarID | CXTPCommandBar | protected
m_nIdleFlags | CXTPCommandBar | protected
m_nLockRedraw | CXTPCommandBar | protected
m_nMaxHeight | CXTPPopupBar | protected
m_nMRUWidth | CXTPCommandBar | protected
m_nOpacity | CXTPMiniToolBar | protected
m_nPopuped | CXTPCommandBar | protected
m_nSelected | CXTPCommandBar | protected
m_nStateFlags | CXTPCommandBar |
m_nTearOffID | CXTPPopupBar | protected
m_nTearOffTimer | CXTPPopupBar | protected
m_nTearOffWidth | CXTPPopupBar | protected
m_nTextOrientation | CXTPCommandBar | protected
m_pAnimation | CXTPCommandBar | protected
m_pCommandBars | CXTPCommandBar | protected
m_pContextMenu | CXTPMiniToolBar | protected
m_pControlPopup | CXTPPopupBar | protected
m_pControls | CXTPCommandBar | protected
m_pfnSetLayeredWindowAttributes | CXTPMiniToolBar | protected
m_pfnUpdateLayeredWindow | CXTPMiniToolBar | protected
m_pImageManager | CXTPCommandBar | protected
m_popupFlags | CXTPPopupBar | protected
m_pOwner | CXTPCommandBar | protected
m_pPaintManager | CXTPCommandBar | protected
m_pReturnCmd | CXTPCommandBar | protected
m_pSite | CXTPCommandBar | protected
m_pTearOffBar | CXTPPopupBar | protected
m_pToolTipContext | CXTPCommandBar | protected
m_ptPopup | CXTPPopupBar | protected
m_rcBorders | CXTPPopupBar | protected
m_rcExclude | CXTPPopupBar | protected
m_rcMarker | CXTPCommandBar | protected
m_rcResizeGripper | CXTPPopupBar | protected
m_rcTearOffGripper | CXTPPopupBar | protected
m_strTearOffCaption | CXTPPopupBar | protected
m_strTitle | CXTPCommandBar | protected
m_szButtons | CXTPCommandBar | protected
m_szButtonSpacing | CXTPCommandBar | protected
m_szIcons | CXTPCommandBar | protected
m_szTearOffBar | CXTPPopupBar | protected
OnControlsChanged() | CXTPPopupBar | protectedvirtual
OnControlSelected(BOOL bSelected, CXTPControl *pControl) | CXTPCommandBar | virtual
OnCustomizeDragEnter(CXTPControl *pDataObject, CPoint point) | CXTPCommandBar | virtual
OnCustomizeDragLeave() | CXTPCommandBar | virtual
OnCustomizeDragOver(CXTPControl *pDataObject, CPoint point) | CXTPCommandBar | virtual
OnCustomizeDrop(CXTPControl *pDataObject, DROPEFFECT &dropEffect, CPoint ptDrop, CPoint ptDrag) | CXTPCommandBar | virtual
OnHookAttached(HWND hWnd) | CXTPHookManagerHookAble | virtual
OnHookDetached() | CXTPHookManagerHookAble | virtual
OnHookKeyDown(UINT nChar, LPARAM lParam) | CXTPMiniToolBar | virtual
OnHookMessage(HWND hWnd, UINT nMessage, WPARAM &wParam, LPARAM &lParam, LRESULT &lResult) | CXTPCommandBar | virtual
OnKeyboardTip(CXTPCommandBarKeyboardTip *pTip) | CXTPCommandBar | virtual
OnKeyboardTipChar(UINT chAccel) | CXTPCommandBar |
OnMouseHitTest(CPoint pt) | CXTPCommandBar | protectedvirtual
OnPostHookMessage(HWND hWnd, UINT nMessage, WPARAM &wParam, LPARAM &lParam, LRESULT &lResult) | CXTPHookManagerHookAble | virtual
OnRecalcLayout() | CXTPPopupBar | protectedvirtual
OnRemoved() | CXTPCommandBar | protectedvirtual
OnTrackEnter() | CXTPCommandBar | virtual
OnTrackLost() | CXTPCommandBar | virtual
PFNSETLAYEREDWINDOWATTRIBUTES typedef | CXTPMiniToolBar | protected
Popup(int xPos, int yPos, LPCRECT rcExclude) | CXTPPopupBar |
Popup(CXTPControlPopup *pControlPopup, BOOL bSelectFirst=FALSE) | CXTPPopupBar | virtual
ProcessSpecialKey(XTPSpecialKey key) | CXTPCommandBar | protectedvirtual
PumpMessage() | CXTPMiniToolBar | protectedvirtual
Redraw(LPCRECT lpRect=0, BOOL bAnimate=TRUE) | CXTPCommandBar | virtual
RestoreCommandBarList(CXTPCommandBarList *pCommandBarList) | CXTPCommandBar | protectedvirtual
s_nExpandDelay | CXTPCommandBar | static
s_nExpandHoverDelay | CXTPCommandBar | static
s_nHoverDelay | CXTPCommandBar | static
SetBarID(UINT nID) | CXTPCommandBar |
SetBorders(CRect rcBorders) | CXTPPopupBar |
SetButtons(UINT *pButtons, int nCount) | CXTPCommandBar |
SetButtonSize(CSize size) | CXTPCommandBar |
SetCommandBarData(DWORD_PTR dwData) | CXTPCommandBar |
SetCommandBars(CXTPCommandBars *pCommandBars) | CXTPCommandBar |
SetControls(CXTPControls *pControls) | CXTPCommandBar |
SetCustomControlKeyboardInteraction(BOOL bInteract=TRUE) | CXTPMiniToolBar |
SetDefaultButtonStyle(XTPButtonStyle buttonStyle) | CXTPCommandBar |
SetDefaultItem(UINT uItem, BOOL fByPos=FALSE) | CXTPPopupBar |
SetDoubleGripper(BOOL bDoubleGripper=TRUE) | CXTPPopupBar |
SetFlags(DWORD dwFlagsAdd, DWORD dwFlagsRemove=0) | CXTPCommandBar |
SetGrabFocus(BOOL bGrabFocus) | CXTPCommandBar |
SetIconSize(CSize size) | CXTPCommandBar |
SetImageManager(CXTPImageManager *pImageManager) | CXTPCommandBar |
SetPaintManager(CXTPPaintManager *pPaintManager) | CXTPCommandBar |
SetPopuped(int nPopuped, BOOL bKeyboard=FALSE) | CXTPCommandBar |
SetPopupFlags(DWORD dwPopupFlags) | CXTPPopupBar |
SetPopupToolBar(BOOL bToolBarType) | CXTPPopupBar |
SetPosition(XTPBarPosition barPosition) | CXTPCommandBar | virtual
SetSelected(int nSelected, BOOL bKeyboard=FALSE) | CXTPPopupBar | protectedvirtual
SetShowGripper(BOOL bShow) | CXTPCommandBar |
SetStatusText(const CString &strDescription) | CXTPCommandBar |
SetTearOffPopup(LPCTSTR lpszCaption, UINT nID, int nWidth=400) | CXTPPopupBar |
SetTextOrientation(XTPBarTextOrientation nTextOrientation) | CXTPCommandBar |
SetTitle(LPCTSTR lpszTitle) | CXTPCommandBar |
SetTrackFocus(HWND hwnd) | CXTPCommandBar |
SetTrackingMode(int bMode, BOOL bSelectFirst=TRUE, BOOL bKeyboard=FALSE) | CXTPPopupBar | virtual
SetVisible(BOOL bVisible) | CXTPCommandBar | virtual
SetWidth(int nWidth) | CXTPCommandBar |
ShowTextBelowIcons(BOOL bTextBelow=TRUE) | CXTPCommandBar |
TrackMiniBar(UINT nFlags, int xPos, int yPos) | CXTPMiniToolBar | virtual
TrackPopupMenu(CXTPPopupBar *pPopupMenu, UINT nFlags, int xPos, int yPos) | CXTPMiniToolBar | virtual
UnlockMouseMove() | CXTPCommandBar |
UnlockRedraw() | CXTPCommandBar |
UpdateExpandingState() | CXTPPopupBar | protected
UpdateFlags() | CXTPPopupBar | protectedvirtual
UpdateLocation(CSize sz) | CXTPPopupBar | protected
UpdateOpacity() | CXTPMiniToolBar | protectedvirtual
UpdateShortcuts() | CXTPCommandBar | protectedvirtual
~CXTPCommandBar() | CXTPCommandBar | protectedvirtual
~CXTPHookManagerHookAble() | CXTPHookManagerHookAble | virtual
~CXTPMiniToolBar() | CXTPMiniToolBar | protectedvirtual
~CXTPPopupBar() | CXTPPopupBar | protectedvirtual


Toolkit Pro: XTPGridHyperlink.h Source File

  • Source
  • GridControl
XTPGridHyperlink.h
Go to the documentation of this file.
1
23#if !defined(__XTPGRIDRECORDHYPERLINK_H__)
24# define __XTPGRIDRECORDHYPERLINK_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPPropExchange;
34
39class _XTP_EXT_CLASS CXTPGridHyperlinkStyle : public CXTPCmdTarget
40{
41public:
48 CXTPGridHyperlinkStyle(COLORREF color, XTPGridTextDecoration textDecoration);
49
56 COLORREF GetColor() const;
57
63 void SetColor(COLORREF color);
64
71 XTPGridTextDecoration GetTextDecoration() const;
72
78 void SetTextDecoration(XTPGridTextDecoration textDecoration);
79
80protected:
81# ifdef _XTP_ACTIVEX
83 DECLARE_DISPATCH_MAP()
84 DECLARE_INTERFACE_MAP()
85 DECLARE_OLETYPELIB_EX(CXTPGridHyperlinkStyle);
86
87# define DECLARE_PROPERTY_UN(theProperty, theType) \
88 afx_msg theType OleGet##theProperty(); \
89 afx_msg void OleSet##theProperty(theType);
90
91 DECLARE_PROPERTY_UN(Color, COLORREF);
92 DECLARE_PROPERTY_UN(TextDecoration, int);
93
95# endif
96
97private:
98 COLORREF m_color;
99 XTPGridTextDecoration m_textDecoration;
100};
101
110class _XTP_EXT_CLASS CXTPGridHyperlink
111 : public CXTPHeapObjectT<CXTPCmdTarget, CXTPGridDataAllocator>
112{
114 DECLARE_DYNAMIC(CXTPGridHyperlink)
116public:
124 CXTPGridHyperlink(int nHyperTextBegin = 0, int nHyperTextLen = 0);
125
130 virtual ~CXTPGridHyperlink();
131
138 virtual void DoPropExchange(CXTPPropExchange* pPX);
139
140public:
141 CRect m_rcHyperSpot;
142 int m_nHyperTextBegin;
144 int m_nHyperTextLen;
146protected:
147# ifdef _XTP_ACTIVEX
149 DECLARE_DISPATCH_MAP()
150 DECLARE_INTERFACE_MAP()
151
152 DECLARE_OLETYPELIB_EX(CXTPGridHyperlink);
154# endif
155};
156
161typedef CXTPArrayT<CXTPGridHyperlink*, CXTPGridHyperlink*, LPDISPATCH> CXTPGridHyperlinks_base;
162
169class _XTP_EXT_CLASS CXTPGridHyperlinks
170 : public CXTPHeapObjectT<CXTPGridHyperlinks_base, CXTPGridDataAllocator>
171
172{
174 DECLARE_DYNAMIC(CXTPGridHyperlinks)
175 typedef CXTPArrayT<CXTPGridHyperlink*, CXTPGridHyperlink*, LPDISPATCH> TBase;
177public:
182 CXTPGridHyperlinks();
183
188 virtual ~CXTPGridHyperlinks();
189
196 virtual void DoPropExchange(CXTPPropExchange* pPX);
197
205 virtual void RemoveAt(int nIndex);
206
215 virtual void RemoveAt(int nIndex, int nCount);
216
223 virtual void RemoveAll();
224
231 virtual void CopyFrom(CXTPGridHyperlinks* pSrc);
232
233protected:
234# ifdef _XTP_ACTIVEX
236 DECLARE_DISPATCH_MAP()
237 DECLARE_INTERFACE_MAP()
238
239 DECLARE_OLETYPELIB_EX(CXTPGridHyperlinks);
240 DECLARE_ENUM_VARIANT(CXTPGridHyperlinks)
241
242 virtual LPDISPATCH OleGetItem(long nIndex);
243 afx_msg LPDISPATCH OleAddHyperlink(long nHyperTextBegin, long nHyperTextLen);
245# endif
246};
247
249
250# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
252#endif // !defined(__XTPGRIDRECORDHYPERLINK_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPGridTextDecoration
XTPGridTextDecoration
Enumeration of hyperlink text decorations.
Definition XTPGridDefines.h:284
CXTPGridHyperlinks_base
CXTPArrayT< CXTPGridHyperlink *, CXTPGridHyperlink *, LPDISPATCH > CXTPGridHyperlinks_base
This typedef is used to declare a base class for CXTPGridHyperlinks.
Definition XTPGridHyperlink.h:161
CXTPArrayT
This class represents a simple array of typed elements.
Definition XTPSmartPtrInternalT.h:490
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPGridHyperlink
This class represents hyperlinks.
Definition XTPGridHyperlink.h:112
CXTPGridHyperlink::DoPropExchange
virtual void DoPropExchange(CXTPPropExchange *pPX)
Call this member function to store/load a grid hyperlink using the specified data object.
CXTPGridHyperlink::m_nHyperTextBegin
int m_nHyperTextBegin
Start position of the hyperlink item text in the parent item caption.
Definition XTPGridHyperlink.h:142
CXTPGridHyperlink::~CXTPGridHyperlink
virtual ~CXTPGridHyperlink()
Destroys a CXTPGridHyperlink object, handles cleanup and deallocation.
CXTPGridHyperlink::m_rcHyperSpot
CRect m_rcHyperSpot
Hyperlink draw place.
Definition XTPGridHyperlink.h:141
CXTPGridHyperlink::m_nHyperTextLen
int m_nHyperTextLen
The length of the hyperlink item text.
Definition XTPGridHyperlink.h:144
CXTPGridHyperlink::CXTPGridHyperlink
CXTPGridHyperlink(int nHyperTextBegin=0, int nHyperTextLen=0)
Default CXTPGridHyperlink constructor.
CXTPGridHyperlinkStyle
This class stores the anchor styles.
Definition XTPGridHyperlink.h:40
CXTPGridHyperlinkStyle::SetColor
void SetColor(COLORREF color)
Sets the color for the anchor text.
CXTPGridHyperlinkStyle::GetColor
COLORREF GetColor() const
Gets the color of the anchor text.
CXTPGridHyperlinkStyle::SetTextDecoration
void SetTextDecoration(XTPGridTextDecoration textDecoration)
Sets the text decoration for the anchor text.
CXTPGridHyperlinkStyle::CXTPGridHyperlinkStyle
CXTPGridHyperlinkStyle(COLORREF color, XTPGridTextDecoration textDecoration)
Constructs the object and initializes the color and text decoration.
CXTPGridHyperlinkStyle::GetTextDecoration
XTPGridTextDecoration GetTextDecoration() const
Gets the text decoration of the anchor text.
CXTPGridHyperlinks
This class represents an array of pointers to CXTPGridHyperlink objects.
Definition XTPGridHyperlink.h:172
CXTPGridHyperlinks::DoPropExchange
virtual void DoPropExchange(CXTPPropExchange *pPX)
Call this member function to store/load a grid hyperlinks collection using the specified data object.
CXTPGridHyperlinks::CXTPGridHyperlinks
CXTPGridHyperlinks()
Default CXTPGridHyperlink constructor.
CXTPGridHyperlinks::RemoveAt
virtual void RemoveAt(int nIndex, int nCount)
Removes the hyperlink at a specified index from the collection.
CXTPGridHyperlinks::RemoveAll
virtual void RemoveAll()
Removes all hyperlinks from the collection.
CXTPGridHyperlinks::CopyFrom
virtual void CopyFrom(CXTPGridHyperlinks *pSrc)
Copies all members from a specified CXTPGridHyperlinks object to this CXTPGridHyperlinks object.
CXTPGridHyperlinks::RemoveAt
virtual void RemoveAt(int nIndex)
Removes the hyperlink at a specified index from the collection.
CXTPGridHyperlinks::~CXTPGridHyperlinks
virtual ~CXTPGridHyperlinks()
Destroys a CXTPGridHyperlinks object, handles cleanup and deallocation.
CXTPHeapObjectT
This template class used as a helper class to override new/delete operators and use custom heap alloc...
Definition XTPCustomHeap.h:335
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72


Toolkit Pro: Member List

  • CXTPCalendarData
  • CXTPDPCache
CXTPCalendarData::CXTPDPCache Member List

This is the complete list of members for CXTPCalendarData::CXTPDPCache, including all inherited members.

_AddToCacheIfNeed(CXTPCalendarRecurrencePattern *pPattern) | CXTPCalendarData::CXTPDPCache | virtual
AddToCache(CXTPCalendarEvents *pEvents, COleDateTime dtDay) | CXTPCalendarData::CXTPDPCache | virtual
AddToCacheIfNeed(CXTPCalendarEvent *pEvent) | CXTPCalendarData::CXTPDPCache | virtual
CXTPDPCache() | CXTPCalendarData::CXTPDPCache |
IsDayInCache(COleDateTime dtDay) | CXTPCalendarData::CXTPDPCache | virtual
IsEventInCache(CXTPCalendarEvent *pEvent) | CXTPCalendarData::CXTPDPCache | virtual
SafeClose() | CXTPCalendarData::CXTPDPCache |
SafeRemoveAll() | CXTPCalendarData::CXTPDPCache |
SetDayInCache(COleDateTime dtDay, BOOL bSet=TRUE) | CXTPCalendarData::CXTPDPCache | virtual
~CXTPDPCache() | CXTPCalendarData::CXTPDPCache | virtual


Toolkit Pro: XTPPropertyGridToolTip.h Source File

  • Source
  • PropertyGrid
XTPPropertyGridToolTip.h
Go to the documentation of this file.
1
23#if !defined(__XTPPROPERTYGRIDTOOLTIP_H__)
24# define __XTPPROPERTYGRIDTOOLTIP_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPPropertyGridToolTip : public CWnd
39{
40public:
45 CXTPPropertyGridToolTip();
46
54 void Activate(BOOL bActive, CXTPPropertyGridItem* pItem, BOOL bValuePart);
55
61 void Create(CXTPPropertyGridView* pParentWnd);
62
63protected:
65 DECLARE_MESSAGE_MAP()
66
67 //{{AFX_MSG(CXTPPropertyGridView)
68 afx_msg BOOL OnEraseBkgnd(CDC*);
69 afx_msg void OnPaint();
70 afx_msg LRESULT OnNcHitTest(CPoint point);
71 //}}AFX_MSG
74private:
75 BOOL Create(LPCTSTR lpszClassName, LPCTSTR lpszWindowName, DWORD dwStyle, const RECT& rect,
76 CWnd* pParentWnd, UINT nID, CCreateContext* pContext = NULL);
77
78protected:
79 CXTPPropertyGridView* m_pGrid;
81 CXTPFont m_xtpFont;
82 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CFont, m_fnt, m_xtpFont, GetFontHandle);
83
84 friend class CXTPPropertyGridView;
85};
86
88AFX_INLINE BOOL CXTPPropertyGridToolTip::Create(LPCTSTR lpszClassName, LPCTSTR lpszWindowName,
89 DWORD dwStyle, const RECT& rect, CWnd* pParentWnd,
90 UINT nID, CCreateContext* pContext)
91{
92 return CWnd::Create(lpszClassName, lpszWindowName, dwStyle, rect, pParentWnd, nID, pContext);
93}
96# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
98#endif // __XTPPROPERTYGRIDTOOLTIP_H__
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPFont
Provides a convenient object oriented interface for HFONT GDI object and uses GDI handle caching.
Definition XTPGdiObjects.h:414
CXTPPropertyGridItem
CXTPPropertyGridItem is the base class representing an item of the Property Grid control.
Definition XTPPropertyGridItem.h:523
CXTPPropertyGridToolTip
CXTPPropertyGridToolTip is a CWnd derived class.
Definition XTPPropertyGridToolTip.h:39
CXTPPropertyGridToolTip::Create
void Create(CXTPPropertyGridView *pParentWnd)
Creates a tooltip control.
CXTPPropertyGridToolTip::Activate
void Activate(BOOL bActive, CXTPPropertyGridItem *pItem, BOOL bValuePart)
Activates/destroys the tooltip control.
CXTPPropertyGridToolTip::CXTPPropertyGridToolTip
CXTPPropertyGridToolTip()
Constructs a CXTPPropertyGridToolTip object.
CXTPPropertyGridView
CXTPPropertyGridView is a CListBox derived class.
Definition XTPPropertyGridView.h:49


Toolkit Pro: Member List

CXTPDockingPaneColorSet2022 Member List

This is the complete list of members for CXTPDockingPaneColorSet2022, including all inherited members.

GetButtonColorSet(CXTPDockingPaneCaptionButton *pButton) | CXTPDockingPaneColorSet | virtual
m_clrBackground | CXTPDockingPaneColorSet |
m_clrBorder | CXTPDockingPaneColorSet |
m_clrCaption | CXTPDockingPaneColorSet |
m_clrGripper | CXTPDockingPaneColorSet |
m_clrSplitter | CXTPDockingPaneColorSet |
m_clrText | CXTPDockingPaneColorSet |
m_csCaptionButtonHot | CXTPDockingPaneColorSet | protected
m_csCaptionButtonNormal | CXTPDockingPaneColorSet | protected
m_csCaptionButtonPressed | CXTPDockingPaneColorSet | protected
RefreshMetrics(CString strSection) | CXTPDockingPaneColorSet2022 | virtual
~CXTPDockingPaneColorSet() | CXTPDockingPaneColorSet | virtual


Toolkit Pro: XTPDisableAdvancedWarnings.h Source File

  • Source
  • Common
  • Base
  • Diagnostic
XTPDisableAdvancedWarnings.h
Go to the documentation of this file.
1
24#define XTP_DISABLE_ADVANCED_WARNINGS
25#include "Common/Base/Diagnostic/XTPEnableAdvancedWarnings.h"
26
XTPEnableAdvancedWarnings.h


Toolkit Pro: XTPGridRecordItemPreview.h Source File

  • Source
  • GridControl
  • ItemTypes
XTPGridRecordItemPreview.h
Go to the documentation of this file.
1
23#if !defined(__XTPGRIDRECORDITEMPREVIEW_H__)
24# define __XTPGRIDRECORDITEMPREVIEW_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
43class _XTP_EXT_CLASS CXTPGridRecordItemPreview : public CXTPGridRecordItem
44{
46 DECLARE_SERIAL(CXTPGridRecordItemPreview)
48public:
54 CXTPGridRecordItemPreview(LPCTSTR szPreviewText = _T(""));
55
61 void SetPreviewText(LPCTSTR strPreviewText);
62
69 virtual CString GetPreviewText();
70
80 virtual int GetPreviewHeight(CDC* pDC, CXTPGridRow* pRow, int nWidth);
81
89 CString GetCaption(CXTPGridColumn* pColumn);
90
91 using CXTPGridRecordItem::GetCaption;
92
98 virtual void SetCaption(LPCTSTR strCaption);
99
108 virtual void OnDrawCaption(XTP_GRIDRECORDITEM_DRAWARGS* pDrawArgs,
109 XTP_GRIDRECORDITEM_METRICS* pMetrics);
110
125 virtual void GetItemMetrics(XTP_GRIDRECORDITEM_DRAWARGS* pDrawArgs,
126 XTP_GRIDRECORDITEM_METRICS* pItemMetrics);
127
134 BOOL IsPreviewItem() const;
135
143 virtual void OnEditChanged(XTP_GRIDRECORDITEM_ARGS* pItemArgs, LPCTSTR szText);
144
153 virtual void GetCaptionRect(XTP_GRIDRECORDITEM_ARGS* pDrawArgs, CRect& rcItem);
154
161 virtual void DoPropExchange(CXTPPropExchange* pPX);
162
163protected:
164 virtual void OnBeginEdit(XTP_GRIDRECORDITEM_ARGS* pItemArgs);
165
166protected:
167 CString m_strPreviewText;
168};
169
170AFX_INLINE CString CXTPGridRecordItemPreview::GetPreviewText()
171{
172 return m_strPreviewText;
173}
174
175AFX_INLINE BOOL CXTPGridRecordItemPreview::IsPreviewItem() const
176{
177 return TRUE;
178}
179
180# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
182#endif // !defined(__XTPGRIDRECORDITEMPREVIEW_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPGridColumn
Represents a grid column item with its properties and operations.
Definition XTPGridColumn.h:107
CXTPGridRecordItem
Class for working with single list cell.
Definition XTPGridRecordItem.h:600
CXTPGridRecordItem::GetCaption
virtual CString GetCaption()
Gets the text caption of the item.
CXTPGridRecordItem::IsPreviewItem
virtual BOOL IsPreviewItem() const
Determines if the record item is a preview item.
Definition XTPGridRecordItem.h:1689
CXTPGridRecordItemPreview
This represents a preview cell and inherits basic functionality from the CXTPGridRecordItem class.
Definition XTPGridRecordItemPreview.h:44
CXTPGridRecordItemPreview::m_strPreviewText
CString m_strPreviewText
Preview content.
Definition XTPGridRecordItemPreview.h:167
CXTPGridRecordItemPreview::DoPropExchange
virtual void DoPropExchange(CXTPPropExchange *pPX)
Call this member function to store/load a grid record item using the specified data object.
CXTPGridRecordItemPreview::GetPreviewText
virtual CString GetPreviewText()
Gets the preview text of the item.
Definition XTPGridRecordItemPreview.h:170
CXTPGridRecordItemPreview::OnEditChanged
virtual void OnEditChanged(XTP_GRIDRECORDITEM_ARGS *pItemArgs, LPCTSTR szText)
This method is called when the value of the in-place edit control is changed.
CXTPGridRecordItemPreview::CXTPGridRecordItemPreview
CXTPGridRecordItemPreview(LPCTSTR szPreviewText=_T(""))
Creates a new preview record item.
CXTPGridRecordItemPreview::GetPreviewHeight
virtual int GetPreviewHeight(CDC *pDC, CXTPGridRow *pRow, int nWidth)
Retrieves the height of the preview area.
CXTPGridRecordItemPreview::GetItemMetrics
virtual void GetItemMetrics(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pItemMetrics)
Fills an XTP_GRIDRECORDITEM_METRICS structure.
CXTPGridRecordItemPreview::SetPreviewText
void SetPreviewText(LPCTSTR strPreviewText)
Set the preview text for the item.
CXTPGridRecordItemPreview::GetCaption
CString GetCaption(CXTPGridColumn *pColumn)
Gets the caption of the item.
CXTPGridRecordItemPreview::GetCaptionRect
virtual void GetCaptionRect(XTP_GRIDRECORDITEM_ARGS *pDrawArgs, CRect &rcItem)
Retrieves the caption text of the bounding rectangle.
CXTPGridRecordItemPreview::OnBeginEdit
virtual void OnBeginEdit(XTP_GRIDRECORDITEM_ARGS *pItemArgs)
This method is called when the user begins to edit an item.
CXTPGridRecordItemPreview::SetCaption
virtual void SetCaption(LPCTSTR strCaption)
Sets the caption for the item.
CXTPGridRecordItemPreview::IsPreviewItem
BOOL IsPreviewItem() const
Determines if the item is a preview item.
Definition XTPGridRecordItemPreview.h:175
CXTPGridRecordItemPreview::OnDrawCaption
virtual void OnDrawCaption(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics)
Should be overridden by descendants for drawing itself.
CXTPGridRow
CXTPGridRow class represents a row of the Grid control window.
Definition XTPGridRow.h:71
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72
XTP_GRIDRECORDITEM_ARGS
Basic set of parameters transferred to item handlers.
Definition XTPGridRecordItem.h:69
XTP_GRIDRECORDITEM_DRAWARGS
A set of parameters transferred to the Draw item handler.
Definition XTPGridRecordItem.h:125
XTP_GRIDRECORDITEM_METRICS
Record item drawing metrics.
Definition XTPGridRecordItem.h:356


Toolkit Pro: Member List

CXTPChartRotatedTextPainterBase Member List

This is the complete list of members for CXTPChartRotatedTextPainterBase, including all inherited members.

CalculateBounds() | CXTPChartRotatedTextPainterBase | virtual
CalculateLeftTopPoint()=0 | CXTPChartRotatedTextPainterBase | pure virtual
CalculatePoints(XTPChartTextRotation rotation, CRect rect, float angle, float points[4][2]) | CXTPChartRotatedTextPainterBase |
CalculateRotation()=0 | CXTPChartRotatedTextPainterBase | pure virtual
CreateDeviceCommand(CXTPChartDeviceContext *pDC, const CXTPChartColor &color) | CXTPChartRotatedTextPainterBase | virtual
CXTPChartRotatedTextPainterBase(CXTPChartDeviceContext *pDC, const CXTPChartString &text, CXTPChartTextElement *pTextProvider, CPoint ptBase=CPoint(0, 0)) | CXTPChartRotatedTextPainterBase | protected
CXTPChartTextPainterBase(CXTPChartDeviceContext *pDC, const CXTPChartString &text, CXTPChartTextElement *pTextProvider) | CXTPChartTextPainterBase | protected
GetInitialTextRect() | CXTPChartRotatedTextPainterBase |
GetRoundedBounds() | CXTPChartTextPainterBase |
m_fAngle | CXTPChartRotatedTextPainterBase | protected
m_nHeight | CXTPChartTextPainterBase | protected
m_nWidth | CXTPChartTextPainterBase | protected
m_ptBasePoint | CXTPChartRotatedTextPainterBase | protected
m_pTextProvider | CXTPChartTextPainterBase | protected
m_rcBounds | CXTPChartTextPainterBase | protected
m_rcRoundedBounds | CXTPChartTextPainterBase | protected
m_strText | CXTPChartTextPainterBase | protected
m_szTextSize | CXTPChartTextPainterBase | protected
SetBasePoint(CPoint pt) | CXTPChartRotatedTextPainterBase |
~CXTPChartTextPainterBase() | CXTPChartTextPainterBase | virtual


Toolkit Pro: Member List

CXTPCustomizeSheet Member List

This is the complete list of members for CXTPCustomizeSheet, including all inherited members.

AddButton(UINT nIDCaption, UINT nID) | CXTPPropertySheet | virtual
AddPage(CXTPPropertyPage *pPage, int nIndex=-1) | CXTPCustomizeSheet |
CXTPPropertySheet::AddPage(CXTPPropertyPage *pPage) | CXTPPropertySheet |
AutoLoadPlacement(LPCTSTR pszSection) | CXTPPropertySheet |
ContextMenu(CPoint point) | CXTPCustomizeSheet |
Create(CWnd *pParentWnd=NULL, DWORD dwStyle=(DWORD) -1, DWORD dwExStyle=0) | CXTPPropertySheet |
CreateButtons() | CXTPPropertySheet | protectedvirtual
CreatePage(CXTPPropertyPage *pPage) | CXTPPropertySheet | protectedvirtual
CXTPCustomizeSheet(CXTPCommandBars *pCommandBars, UINT iSelectPage=0) | CXTPCustomizeSheet |
CXTPDialogBase() | CXTPDialogBase< CDialog > | inline
CXTPDialogBase(UINT nIDTemplate, CWnd *pParentWnd=NULL) | CXTPDialogBase< CDialog > | inline
CXTPDialogBase(LPCTSTR lpszTemplateName, CWnd *pParentWnd=NULL) | CXTPDialogBase< CDialog > | inline
CXTPDialogEx() | CXTPDialogEx | inline
CXTPDialogEx(UINT nIDTemplate, CWnd *pParentWnd=NULL) | CXTPDialogEx | inline
CXTPDialogEx(LPCTSTR lpszTemplateName, CWnd *pParentWnd=NULL) | CXTPDialogEx | inline
CXTPPropertySheet() | CXTPPropertySheet |
CXTPPropertySheet(UINT nIDCaption, CWnd *pParentWnd=NULL, UINT iSelectPage=0) | CXTPPropertySheet |
CXTPPropertySheet(LPCTSTR pszCaption, CWnd *pParentWnd=NULL, UINT iSelectPage=0) | CXTPPropertySheet |
DoModal() | CXTPCustomizeSheet |
GetActiveIndex() const | CXTPPropertySheet |
GetActivePage() const | CXTPPropertySheet |
GetCommandBars() const | CXTPCustomizeSheet |
GetCommandsPage() const | CXTPCustomizeSheet |
GetContextMenu() const | CXTPCustomizeSheet |
GetCustomIcons() const | CXTPCustomizeSheet |
GetDragControl() const | CXTPCustomizeSheet |
GetNavigator() const | CXTPPropertySheet |
GetPage(int nPage) const | CXTPPropertySheet |
GetPageBorderStyle() const | CXTPPropertySheet |
GetPageCount() const | CXTPPropertySheet |
GetPageIndex(CXTPPropertyPage *pPage) const | CXTPPropertySheet |
GetPageRect() const | CXTPPropertySheet |
GetTheme() | CXTPPropertySheet |
GetToolbarsPage() const | CXTPCustomizeSheet |
InsertPage(int nIndex, CXTPPropertyPage *pPage) | CXTPPropertySheet |
LoadPlacement(LPCTSTR pszSection) | CXTPPropertySheet |
m_arrButtons | CXTPPropertySheet | protected
m_arrPages | CXTPPropertySheet | protected
m_bAllowApply | CXTPPropertySheet | protected
m_bModeless | CXTPPropertySheet | protected
m_bResizable | CXTPPropertySheet | protected
m_lpDlgTemplate | CXTPPropertySheet | protected
m_nPageBorderStyle | CXTPPropertySheet | protected
m_pActivePage | CXTPPropertySheet | protected
m_pCommandBars | CXTPCustomizeSheet | protected
m_pContextMenu | CXTPCustomizeSheet | protected
m_pCustomIcons | CXTPCustomizeSheet | protected
m_pNavigator | CXTPPropertySheet | protected
m_pPageCommands | CXTPCustomizeSheet | protected
m_pPageToolBars | CXTPCustomizeSheet | protected
m_psh | CXTPPropertySheet |
m_pWndParent | CXTPCustomizeSheet | protected
m_rcMaxPage | CXTPPropertySheet | protected
m_rcMinPage | CXTPPropertySheet | protected
m_rcPage | CXTPPropertySheet | protected
m_scSizeIcon | CXTPPropertySheet | protected
m_strCaption | CXTPPropertySheet | protected
m_szButton | CXTPPropertySheet | protected
m_szWindow | CXTPPropertySheet | protected
m_xtpFontNormal | CXTPPropertySheet | protected
MessageBox(LPCTSTR lpszText, UINT nType=MB_OK) | CXTPCustomizeSheet |
RemoveButtons() | CXTPPropertySheet |
RemovePage(int nPage) | CXTPPropertySheet |
RemovePage(CXTPPropertyPage *pPage) | CXTPPropertySheet |
SavePlacement(LPCTSTR pszSection) | CXTPPropertySheet |
SetActivePage(int nPage) | CXTPPropertySheet | virtual
SetActivePage(CXTPPropertyPage *pPage) | CXTPPropertySheet | virtual
SetNavigator(CXTPPropertyPageNavigator *pNavigator) | CXTPPropertySheet |
SetPageBorderStyle(XTPPropertyPageBorder nBorder) | CXTPPropertySheet |
SetPageSize(CSize szPage) | CXTPPropertySheet |
SetPageSizeMax(CSize szPage) | CXTPPropertySheet |
SetPageSizeMin(CSize szPage) | CXTPPropertySheet |
SetResizable(BOOL bResizable=TRUE) | CXTPPropertySheet |
SetTheme(XTPControlTheme theme) | CXTPPropertySheet |
SetTitle(LPCTSTR lpszText) | CXTPPropertySheet |
UpdatePages() | CXTPPropertySheet |
~CXTPCustomizeSheet() | CXTPCustomizeSheet | virtual
~CXTPPropertySheet() | CXTPPropertySheet |


Toolkit Pro: Member List

XTP_NM_GRIDPREVIEWKEYDOWN Member List

This is the complete list of members for XTP_NM_GRIDPREVIEWKEYDOWN, including all inherited members.

bCancel | XTP_NM_GRIDPREVIEWKEYDOWN
hdr | XTP_NM_GRIDPREVIEWKEYDOWN
nChar | XTP_NM_GRIDPREVIEWKEYDOWN
nFlags | XTP_NM_GRIDPREVIEWKEYDOWN
nRepCnt | XTP_NM_GRIDPREVIEWKEYDOWN


Toolkit Pro: XTPTabPaintManagerTheme.h Source File

  • Source
  • TabManager
XTPTabPaintManagerTheme.h
Go to the documentation of this file.
1
23#if !defined(__XTPTABPAINTMANAGERTHEME_H__)
24# define __XTPTABPAINTMANAGERTHEME_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPTabPaintManagerColorSet;
34class CXTPTabManager;
35class CXTPTabManagerItem;
36class CXTPTabPaintManager;
37
55class _XTP_EXT_CLASS CXTPTabPaintManagerTheme
56{
57public:
62 CXTPTabPaintManagerTheme();
63
68 virtual ~CXTPTabPaintManagerTheme();
69
70public:
79 virtual void RefreshMetrics();
80
90 CXTPTabPaintManagerColorSet* GetColorSet() const;
91
103 virtual CRect GetHeaderRect(CRect rcControl, CXTPTabManager* pTabManager);
104
113 virtual CRect GetHeaderClipBox(CDC* pDC, CXTPTabManager* pTabManager);
114
125 int GetHeaderHeight(CXTPTabManager* pTabManager);
126
138 virtual CRect GetClientRect(CRect rcControl, CXTPTabManager* pTabManager);
139
174 virtual CRect GetHeaderMargin();
175
207 virtual CRect GetClientMargin();
208
227 virtual int GetButtonLength(CDC* pDC, CXTPTabManagerItem* pItem);
228
249 virtual int GetButtonHeight(const CXTPTabManager* pTabManager);
250
261 virtual CRect GetButtonDrawRect(const CXTPTabManagerItem* pItem);
262
263public:
278 virtual void DrawTabControl(CXTPTabManager* pTabManager, CDC* pDC, CRect rcControl);
279
299 virtual CRect FillTabControl(CXTPTabManager* pTabManager, CDC* pDC, CRect rcControl);
300
318 virtual void RepositionTabControl(CXTPTabManager* pTabManager, CDC* pDC, CRect rcClient);
319
340 virtual void AdjustClientRect(CXTPTabManager* pTabManager, CRect& rcClient);
341
357 virtual void DrawSingleButton(CDC* pDC, CXTPTabManagerItem* pItem);
358
381 virtual void DrawWorkspacePart(CDC* pDC, LPRECT lpRect, XTPTabWorkspacePart workspacePart);
382
391 virtual int GetSupportedColorSets()
392 {
393 return xtpTabColorAll;
394 }
395
404 virtual XTPTabColorStyle GetDefaultColorSet()
405 {
406 return xtpTabColorDefault;
407 }
408
409public:
423 COLORREF FillButton(CDC* pDC, CXTPTabManagerItem* pItem, LPPOINT pts, int nCount,
424 XTPTabPosition tabPosition, BOOL bAbsolute = FALSE);
425
435 virtual void DrawText(CDC* pDC, CXTPTabManager* pManager, const CString& str, LPRECT lpRect,
436 UINT nFormat);
437
439 static void AFX_CDECL DrawPolyLine(CDC* pDC, COLORREF clr, LPPOINT pts, int nCount);
440 static void AFX_CDECL DrawSingleLineBorder(CDC* pDC, CRect rc, XTPTabPosition position,
441 COLORREF clrTopLeft, COLORREF clrBottomRight);
442 static void AFX_CDECL InflateRectEx(CRect& rc, CRect rcInflate, XTPTabPosition position);
443 static void AFX_CDECL DeflateRectEx(CRect& rc, CRect rcDeflate, XTPTabPosition position);
446public:
447 CRect m_rcHeaderMargin;
452 int m_nRowMargin; // Margin between rows.
453
454protected:
455 int m_nButtonHeight;
456 CXTPTabPaintManager* m_pPaintManager;
457 BOOL m_bButtonsReverseZOrder;
459 friend class CXTPTabPaintManager;
460};
461
462# define CXTPTabPaintManagerAppearanceSet CXTPTabPaintManagerTheme // Old class name.
463
464# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
466#endif // !defined(__XTPTABPAINTMANAGERTHEME_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPTabPosition
XTPTabPosition
XTPTabPosition is an enumeration used to set the position of tabs.
Definition XTPTabManagerDefines.h:200
XTPTabColorStyle
XTPTabColorStyle
XTPTabColorStyle is an enumeration used to set the color style of tabs.
Definition XTPTabManagerDefines.h:139
xtpTabColorDefault
@ xtpTabColorDefault
Tabs will use the default color for the currently set Appearance.
Definition XTPTabManagerDefines.h:140
xtpTabColorAll
@ xtpTabColorAll
A mask for all tab colors.
Definition XTPTabManagerDefines.h:178
XTPTabWorkspacePart
XTPTabWorkspacePart
XTPTabWorkspacePart is an enumeration used to indicate which part of the MDI TabWorkspace must be red...
Definition XTPTabManagerDefines.h:284
CXTPTabManager
CXTPTabManager is the base class for docking pane tabs, tab control tabs, and MDI client tabs.
Definition XTPTabManager.h:87
CXTPTabManagerItem
CXTPTabManagerItem is the base class for the tabs that appear in the command bars tab workspace,...
Definition XTPTabManagerItem.h:44
CXTPTabPaintManagerColorSet
CXTPTabPaintManagerColorSet represents the colors for all of the components of the tab manager (e....
Definition XTPTabPaintManagerColorSet.h:50
CXTPTabPaintManager
CXTPTabPaintManager is used to store the color and appearance information of the tabs in the tab mana...
Definition XTPTabPaintManager.h:48
CXTPTabPaintManagerTheme
CXTPTabPaintManagerTheme is a class that represents the appearance of all components of the tab manag...
Definition XTPTabPaintManagerTheme.h:56
CXTPTabPaintManagerTheme::GetDefaultColorSet
virtual XTPTabColorStyle GetDefaultColorSet()
Gets the default value of the color set for this theme.
Definition XTPTabPaintManagerTheme.h:404
CXTPTabPaintManagerTheme::FillButton
COLORREF FillButton(CDC *pDC, CXTPTabManagerItem *pItem, LPPOINT pts, int nCount, XTPTabPosition tabPosition, BOOL bAbsolute=FALSE)
Draws a tab button within a specified polygon.
CXTPTabPaintManagerTheme::m_rcHeaderMargin
CRect m_rcHeaderMargin
CRect struct containing the left, top, right, and bottom.
Definition XTPTabPaintManagerTheme.h:447
CXTPTabPaintManagerTheme::GetClientRect
virtual CRect GetClientRect(CRect rcControl, CXTPTabManager *pTabManager)
Gets the bounding rectangle of the tab client area.
CXTPTabPaintManagerTheme::m_nButtonHeight
int m_nButtonHeight
Current tab button height (without margins).
Definition XTPTabPaintManagerTheme.h:455
CXTPTabPaintManagerTheme::GetClientMargin
virtual CRect GetClientMargin()
Gets the top, left, right, and bottom margins of the tab client area.
CXTPTabPaintManagerTheme::GetButtonDrawRect
virtual CRect GetButtonDrawRect(const CXTPTabManagerItem *pItem)
Retrieves the bounding rectangle of a specified drawing item.
CXTPTabPaintManagerTheme::DrawTabControl
virtual void DrawTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl)
Draws the tab control.
CXTPTabPaintManagerTheme::GetHeaderClipBox
virtual CRect GetHeaderClipBox(CDC *pDC, CXTPTabManager *pTabManager)
Gets the clip box of the tab header area.
CXTPTabPaintManagerTheme::GetHeaderMargin
virtual CRect GetHeaderMargin()
Gets the top, left, right, and bottom margins of the tab header.
CXTPTabPaintManagerTheme::FillTabControl
virtual CRect FillTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl)
Fills both the tab header and the tab client area and then draws the tab client frame.
CXTPTabPaintManagerTheme::m_bButtonsReverseZOrder
BOOL m_bButtonsReverseZOrder
Draw buttons in right to left order.
Definition XTPTabPaintManagerTheme.h:457
CXTPTabPaintManagerTheme::GetSupportedColorSets
virtual int GetSupportedColorSets()
Gets the supported color sets for this theme.
Definition XTPTabPaintManagerTheme.h:391
CXTPTabPaintManagerTheme::DrawText
virtual void DrawText(CDC *pDC, CXTPTabManager *pManager, const CString &str, LPRECT lpRect, UINT nFormat)
Draws the text of a specified item.
CXTPTabPaintManagerTheme::GetButtonLength
virtual int GetButtonLength(CDC *pDC, CXTPTabManagerItem *pItem)
Retrieves the total length of a specified tab button including the left and right button margins.
CXTPTabPaintManagerTheme::GetButtonHeight
virtual int GetButtonHeight(const CXTPTabManager *pTabManager)
Retrieves the total height of the tab buttons within a specified tab manager including the top and bo...
CXTPTabPaintManagerTheme::GetColorSet
CXTPTabPaintManagerColorSet * GetColorSet() const
Gets the color set.
CXTPTabPaintManagerTheme::~CXTPTabPaintManagerTheme
virtual ~CXTPTabPaintManagerTheme()
Destroys a CXTPTabPaintManagerTheme object, handles cleanup and deallocation.
CXTPTabPaintManagerTheme::DrawWorkspacePart
virtual void DrawWorkspacePart(CDC *pDC, LPRECT lpRect, XTPTabWorkspacePart workspacePart)
Draws a specified TabMDIClient TabWorkspace part.
CXTPTabPaintManagerTheme::DrawSingleButton
virtual void DrawSingleButton(CDC *pDC, CXTPTabManagerItem *pItem)
Draws a single tab button in the tab client header area.
CXTPTabPaintManagerTheme::m_nRowMargin
int m_nRowMargin
margins of the tab header.
Definition XTPTabPaintManagerTheme.h:452
CXTPTabPaintManagerTheme::GetHeaderHeight
int GetHeaderHeight(CXTPTabManager *pTabManager)
Gets the height of the tab header area.
CXTPTabPaintManagerTheme::RefreshMetrics
virtual void RefreshMetrics()
Refreshes the appearance metrics.
CXTPTabPaintManagerTheme::CXTPTabPaintManagerTheme
CXTPTabPaintManagerTheme()
Constructs a CXTPTabPaintManagerTheme object.
CXTPTabPaintManagerTheme::GetHeaderRect
virtual CRect GetHeaderRect(CRect rcControl, CXTPTabManager *pTabManager)
Gets the bounding rectangle of the tab header area.
CXTPTabPaintManagerTheme::AdjustClientRect
virtual void AdjustClientRect(CXTPTabManager *pTabManager, CRect &rcClient)
Adjusts the tab client rectangle.
CXTPTabPaintManagerTheme::m_pPaintManager
CXTPTabPaintManager * m_pPaintManager
Self paint manager pointer.
Definition XTPTabPaintManagerTheme.h:456
CXTPTabPaintManagerTheme::RepositionTabControl
virtual void RepositionTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcClient)
Moves the tab buttons of the tab control to their correct positions.


Toolkit Pro: Member List

CXTPCaptionThemeOfficeXP Member List

This is the complete list of members for CXTPCaptionThemeOfficeXP, including all inherited members.

CXTPCaptionTheme() | CXTPCaptionTheme |
CXTPCaptionThemeOfficeXP() | CXTPCaptionThemeOfficeXP |
CXTPCmdTarget() | CXTPCmdTarget |
CXTPControlTheme() | CXTPControlTheme |
DrawCaptionBack(CDC *pDC, CXTPCaption *pCaption, CRect &rcItem) | CXTPCaptionThemeOfficeXP | protectedvirtual
DrawCaptionIcon(CDC *pDC, CXTPCaption *pCaption, CRect &rcItem) | CXTPCaptionTheme | virtual
DrawCaptionText(CDC *pDC, CXTPCaption *pCaption) | CXTPCaptionTheme | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetThemeStyle() const | CXTPControlTheme |
m_clrEdgeLight | CXTPCaptionTheme |
m_clrEdgeShadow | CXTPCaptionTheme |
m_nTheme | CXTPControlTheme | protected
RefreshMetrics(CXTPCaption *pCaption) | CXTPCaptionTheme | virtual
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static


Toolkit Pro: Member List

XTP_CALENDAR_RECURRENCE_OPTIONS Member List

This is the complete list of members for XTP_CALENDAR_RECURRENCE_OPTIONS, including all inherited members.

GetData(long &rnData1, long &rnData2, long &rnData3, long &rnData4) const | XTP_CALENDAR_RECURRENCE_OPTIONS | inline
m_Daily | XTP_CALENDAR_RECURRENCE_OPTIONS |
m_Monthly | XTP_CALENDAR_RECURRENCE_OPTIONS |
m_MonthNth | XTP_CALENDAR_RECURRENCE_OPTIONS |
m_nRecurrenceType | XTP_CALENDAR_RECURRENCE_OPTIONS |
m_Weekly | XTP_CALENDAR_RECURRENCE_OPTIONS |
m_Yearly | XTP_CALENDAR_RECURRENCE_OPTIONS |
m_YearNth | XTP_CALENDAR_RECURRENCE_OPTIONS |
operator=(const XTP_CALENDAR_RECURRENCE_OPTIONS &rSrc) | XTP_CALENDAR_RECURRENCE_OPTIONS | inline
SetData(long nData1, long nData2, long nData3, long nData4) | XTP_CALENDAR_RECURRENCE_OPTIONS | inline
XTP_CALENDAR_RECURRENCE_OPTIONS() | XTP_CALENDAR_RECURRENCE_OPTIONS | inline


Toolkit Pro: XTPChartRadarAreaSeriesStyle.h Source File

  • Source
  • Chart
  • Styles
  • Radar
XTPChartRadarAreaSeriesStyle.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTRADARAREASERIESSTYLE_H__)
24# define __XTPCHARTRADARAREASERIESSTYLE_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartSeriesView;
34class CXTPChartBorder;
35class CXTPChartFillStyle;
36
47class _XTP_EXT_CLASS CXTPChartRadarAreaSeriesStyle : public CXTPChartRadarPointSeriesStyle
48{
50 DECLARE_SERIAL(CXTPChartRadarAreaSeriesStyle)
52public:
57 CXTPChartRadarAreaSeriesStyle();
58
63 virtual ~CXTPChartRadarAreaSeriesStyle();
64
65public:
66 void DoPropExchange(CXTPPropExchange* pPX);
67
68public:
77 CXTPChartFillStyle* GetFillStyle() const;
78
79 CXTPChartBorder* GetBorder() const;
80
81public:
93 int GetTransparency() const;
94
105 void SetTransparency(int nTransparency);
106
107protected:
118 virtual CXTPChartSeriesView* CreateView(CXTPChartSeries* pSeries,
119 CXTPChartDiagramView* pDiagramView);
120
121# ifdef _XTP_ACTIVEX
122public:
124 DECLARE_DISPATCH_MAP()
125 DECLARE_INTERFACE_MAP()
126 DECLARE_OLETYPELIB_EX(CXTPChartRadarAreaSeriesStyle);
127 DECLARE_OLECREATE_EX(CXTPChartRadarAreaSeriesStyle)
128
129 LPDISPATCH OleGetFillStyle();
130 LPDISPATCH OleGetBorder();
131
133# endif
134
135protected:
136 int m_nTransparency;
137 CXTPChartBorder* m_pBorder;
139 CXTPChartFillStyle* m_pFillStyle;
140};
141
142AFX_INLINE int CXTPChartRadarAreaSeriesStyle::GetTransparency() const
143{
144 return m_nTransparency;
145}
146AFX_INLINE void CXTPChartRadarAreaSeriesStyle::SetTransparency(int nTransparency)
147{
148 m_nTransparency = nTransparency;
149 OnChartChanged();
150}
151AFX_INLINE CXTPChartFillStyle* CXTPChartRadarAreaSeriesStyle::GetFillStyle() const
152{
153 return m_pFillStyle;
154}
155AFX_INLINE CXTPChartBorder* CXTPChartRadarAreaSeriesStyle::GetBorder() const
156{
157 return m_pBorder;
158}
160# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
161#endif //#if !defined(__XTPCHARTRADARAREASERIESSTYLE_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartBorder
This class abstracts the border of a chart, it is a kind of chart element.
Definition XTPChartBorder.h:42
CXTPChartDiagramView
This class represents the view of a chart diagram, which is a kind of CXTPChartElementView.
Definition XTPChartDiagramView.h:49
CXTPChartElement::OnChartChanged
virtual void OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic propertie...
CXTPChartFillStyle
This class abstracts a fill style used to fill the background of various chart elements.
Definition XTPChartFillStyle.h:43
CXTPChartRadarAreaSeriesStyle
This class represents a line series style, which is a kind of CXTPChartSeriesStyle.
Definition XTPChartRadarAreaSeriesStyle.h:48
CXTPChartRadarAreaSeriesStyle::DoPropExchange
void DoPropExchange(CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
CXTPChartRadarAreaSeriesStyle::m_nTransparency
int m_nTransparency
The transparency values range from 0 to 255.
Definition XTPChartRadarAreaSeriesStyle.h:136
CXTPChartRadarAreaSeriesStyle::SetTransparency
void SetTransparency(int nTransparency)
Call this function to set the transparency of the filled area with respect to the background.
Definition XTPChartRadarAreaSeriesStyle.h:146
CXTPChartRadarAreaSeriesStyle::GetFillStyle
CXTPChartFillStyle * GetFillStyle() const
Call this function to get the background fill style.
Definition XTPChartRadarAreaSeriesStyle.h:151
CXTPChartRadarAreaSeriesStyle::CreateView
virtual CXTPChartSeriesView * CreateView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Call this function to create a view of the point series.
CXTPChartRadarAreaSeriesStyle::m_pBorder
CXTPChartBorder * m_pBorder
The chart border object pointer.
Definition XTPChartRadarAreaSeriesStyle.h:137
CXTPChartRadarAreaSeriesStyle::GetTransparency
int GetTransparency() const
Call this function to get the transparency of the filled area with respect to the background.
Definition XTPChartRadarAreaSeriesStyle.h:142
CXTPChartRadarAreaSeriesStyle::~CXTPChartRadarAreaSeriesStyle
virtual ~CXTPChartRadarAreaSeriesStyle()
Destroys a CXTPChartRadarAreaSeriesStyle object, handles cleanup.
CXTPChartRadarAreaSeriesStyle::m_pFillStyle
CXTPChartFillStyle * m_pFillStyle
The chart background fill style.
Definition XTPChartRadarAreaSeriesStyle.h:139
CXTPChartRadarAreaSeriesStyle::CXTPChartRadarAreaSeriesStyle
CXTPChartRadarAreaSeriesStyle()
Constructs a CXTPChartRadarAreaSeriesStyle object.
CXTPChartRadarPointSeriesStyle
This class represents a line series style, which is a kind of CXTPChartSeriesStyle.
Definition XTPChartRadarPointSeriesStyle.h:47
CXTPChartSeries
This class represents a series in the chart, which is a kind of CXTPChartElement.
Definition XTPChartSeries.h:50
CXTPChartSeriesStyle::SetTransparency
virtual void SetTransparency(int nTransparency)
Call this function to sets the transparency of the chart if it is supported by the chart type.
Definition XTPChartSeriesStyle.h:405
CXTPChartSeriesStyle::GetTransparency
virtual int GetTransparency() const
Call this function to gets the transparency of the chart if it is supported by the chart type.
Definition XTPChartSeriesStyle.h:400
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72


Toolkit Pro: XTPFrameThemeModernUI.h Source File

  • Source
  • CommandBars
  • Frame
XTPFrameThemeModernUI.h
Go to the documentation of this file.
1
23#if !defined(__XTPFRAMETHEMEMODERNUI_H__)
24# define __XTPFRAMETHEMEMODERNUI_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPRibbonBar;
34class CXTPPaintManager;
35class CXTPCommandBarsFrameHook;
36class CXTPColorSetCaptionButton;
37
38class _XTP_EXT_CLASS CXTPModernUIFrameBorder : public CXTPMarkupThemePart
39{
40public:
45 void SetBorderColor(COLORREF clrBorder, COLORREF clrBackground);
46};
47
48class _XTP_EXT_CLASS CXTPModernUIFrameCaptionButton : public CXTPMarkupThemePart
49{
50public:
55 void SetColors(CXTPColorSetCaptionButton* pColorSet);
56
61 void SetBackgroundColor(COLORREF clrBackground);
62
67 void SetOutlineColor(COLORREF clrOutline);
68
73 void SetStrokeColor(COLORREF clrStroke);
74
79 void SetFillColor(COLORREF clrFill);
80};
81
82class _XTP_EXT_CLASS CXTPFrameColorSet
83{
84public:
85 COLORREF m_clrFrameCaptionActive;
86 COLORREF m_clrFrameCaptionInactive;
87};
88
89class _XTP_EXT_CLASS CXTPFrameThemeModernUI : public CXTPRibbonMarkupFrameTheme
90{
91 DECLARE_DYNAMIC(CXTPFrameThemeModernUI);
92
93public:
94 CXTPFrameThemeModernUI(CXTPPaintManager* pPaintManager);
95
96 virtual ~CXTPFrameThemeModernUI();
97
98public:
99 virtual HRGN CalcFrameRegion(CXTPCommandBarsFrameHook* pFrameHook, CSize sz) const;
100
101 virtual CRect CalcFrameBorder(const CXTPCommandBarsFrameHook* pFrameHook) const;
102
103 virtual void DrawFrame(CDC* pDC, CXTPCommandBarsFrameHook* pFrameHook);
104
114 virtual void DrawCaptionText(CDC* pDC, CRect rcCaptionText, CWnd* pSite, BOOL bActive);
115
126 virtual void DrawCaptionText(CDC* pDC, CRect rcCaptionText, CWnd* pSite, BOOL bActive,
127 CXTPRibbonBar* pRibbonBar);
128
140 virtual void DrawFrameCaptionButton(CDC* pDC, CRect rc, int nId, BOOL bSelected, BOOL bPressed,
141 BOOL bActive);
142
155 virtual void DrawFrameCaptionButton(CDC* pDC, CRect rc, int nId, BOOL bSelected, BOOL bPressed,
156 BOOL bActive, CXTPRibbonBar* pRibbonBar);
157
165 virtual void LoadParts(HZIP hZip, CXTPMarkupContext* pMarkupContext);
166
173 virtual void LoadParts(BOOL bReload = FALSE);
174
175protected:
180 virtual void RefreshMetrics();
181
187 virtual LPCTSTR GetStyleResourceName() const = 0;
188
189 virtual CXTPMarkupThemePart* GetFrameBorder(int nId, BOOL bActive);
190
191protected:
193 _XTP_DEPRECATED_IN_FAVOR(CXTPRibbonMarkupFrameTheme::m_bMarkupPartsLoaded)
194 BOOL m_bLoaded;
197 using CXTPRibbonMarkupFrameTheme::m_bMarkupPartsLoaded;
198
199 CXTPPaintManagerColor m_clrFrameBorderActive;
200 CXTPPaintManagerColor m_clrFrameBorderInactive;
201
202 CXTPModernUIFrameBorder* m_pBorderLeft;
203 CXTPModernUIFrameBorder* m_pBorderTop;
204 CXTPModernUIFrameBorder* m_pBorderRight;
205 CXTPModernUIFrameBorder* m_pBorderBottom;
206
207 CXTPColorSetCaptionButton m_csFrameCaptionButtonInactive;
208 CXTPColorSetCaptionButton m_csFrameCaptionButtonActive;
209 CXTPColorSetCaptionButton m_csFrameCaptionButtonHot;
210 CXTPColorSetCaptionButton m_csFrameCaptionButtonPressed;
211
212 CXTPModernUIFrameCaptionButton* m_pButtonMinimize;
213 CXTPModernUIFrameCaptionButton* m_pButtonMaximize;
214 CXTPModernUIFrameCaptionButton* m_pButtonRestore;
215 CXTPModernUIFrameCaptionButton* m_pButtonClose;
216};
218# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
219#endif // !defined(__XTPFRAMETHEMEMODERNUI_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPColorSetCaptionButton
Default theme caption button color set.
Definition XTPTheme.h:40
CXTPCommandBarsFrameHook
CXTPCommandBarsFrameHook is a CXTPHookManagerHookAble derived class.
Definition XTPFrameHook.h:56
CXTPMarkupContext
CXTPMarkupContext is a standalone class used to provide common settings for Markup objects.
Definition XTPMarkupContext.h:128
CXTPMarkupThemePart
The CXTPMarkupThemePart class is used to create a theme part object used for rendering.
Definition XTPMarkupTheme.h:42
CXTPPaintManagerColor
The CXTPPaintManagerColor class is used to manage COLORREF values for determining default and applica...
Definition XTPColorManager.h:117
CXTPPaintManager
Paint manager of the command bars.
Definition XTPPaintManager.h:199
CXTPRibbonBar
CXTPRibbonBar is a CXTPMenuBar derived class.
Definition XTPRibbonBar.h:69
CXTPRibbonMarkupFrameTheme
The CXTPRibbonMarkupFrameTheme class is used to enable a system style theme for Command Bars.
Definition XTPRibbonMarkupFrameTheme.h:43
CXTPRibbonMarkupFrameTheme::m_bMarkupPartsLoaded
BOOL m_bMarkupPartsLoaded
TRUE if markup parts have been loaded.
Definition XTPRibbonMarkupFrameTheme.h:129


Toolkit Pro: Member List

CXTPChartDiagram2D Member List

This is the complete list of members for CXTPChartDiagram2D, including all inherited members.

CalculateSeriesLayout(CXTPChartDeviceContext *pDC, CXTPChartDiagramView *pView) | CXTPChartDiagram | virtual
CreateView(CXTPChartDeviceContext *pDC, CXTPChartElementView *pParent) | CXTPChartDiagram2D | virtual
CXTPChartDiagram() | CXTPChartDiagram | protected
CXTPChartDiagram2D() | CXTPChartDiagram2D |
CXTPChartElement() | CXTPChartElement |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartPanel() | CXTPChartPanel |
DoPropExchange(CXTPPropExchange *pPX) | CXTPChartDiagram2D | virtual
GetAppearance() const | CXTPChartDiagram2D |
GetAxisX() const | CXTPChartDiagram2D |
GetAxisY() const | CXTPChartDiagram2D |
GetContent() const | CXTPChartElement |
GetOwner() const | CXTPChartElement |
GetPane() const | CXTPChartDiagram2D |
GetSecondaryAxisX() const | CXTPChartDiagram2D |
GetSecondaryAxisY() const | CXTPChartDiagram2D |
GetSeries() const | CXTPChartDiagram |
GetTitles() const | CXTPChartPanel |
Is3D() const | CXTPChartObject |
m_arrSeries | CXTPChartDiagram | protected
m_pPane | CXTPChartDiagram2D | protected
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartElement | virtual
OnSeriesAdded(CXTPChartSeries *pSeries) | CXTPChartDiagram | protectedvirtual
OnSeriesRemoved(CXTPChartSeries *pSeries) | CXTPChartDiagram | protected
Release() | CXTPChartDiagram | protectedvirtual
SetPane(CXTPChartDiagram2DPane *pPane) | CXTPChartDiagram2D |
UpdateLayout(CXTPChartDeviceContext *pDC, CXTPChartDiagramView *pView, CRect rcBounds) | CXTPChartDiagram2D | protected
~CXTPChartDiagram2D() | CXTPChartDiagram2D | virtual
~CXTPChartElement() | CXTPChartElement | virtual
~CXTPChartPanel() | CXTPChartPanel | virtual


Toolkit Pro: Member List

CXTPDockingPaneContextAlphaWnd Member List

This is the complete list of members for CXTPDockingPaneContextAlphaWnd, including all inherited members.

CXTPDockingPaneContextAlphaWnd() | CXTPDockingPaneContextAlphaWnd |
~CXTPDockingPaneContextAlphaWnd() | CXTPDockingPaneContextAlphaWnd | virtual


Toolkit Pro: XTPTabColorSetWinNative.h Source File

  • Source
  • TabManager
  • ColorSets
XTPTabColorSetWinNative.h
Go to the documentation of this file.
1
23#if !defined(__XTPTABCOLORSETWINNATIVE_H__)
24# define __XTPTABCOLORSETWINNATIVE_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
48class _XTP_EXT_CLASS CColorSetWinNative : public CXTPTabColorSetDefault
49{
50public:
51 CColorSetWinNative();
52 virtual ~CColorSetWinNative();
53
61 virtual void RefreshMetrics();
62
81 virtual COLORREF FillPropertyButton(CDC* pDC, CRect rcItem, CXTPTabManagerItem* pItem);
82
101 virtual COLORREF FillClient(CDC* pDC, CRect rc, CXTPTabManager* pTabManager);
102
111 virtual void SelectClipRgn(CDC* pDC, CRect rcClient, CXTPTabManager* pTabManager);
112
130 virtual void FillNavigateButton(CDC* pDC, CXTPTabManagerNavigateButton* pButton, CRect& rc);
131
148 virtual void FillStateButton(CDC* pDC, CRect rcItem, CXTPTabManagerItem* pItem);
149
169 virtual BOOL IsAppThemed() const;
170
171private:
172 typedef void(AFX_CDECL* LPFNDRAWROTATEDBITS)(int cx, int cy, UINT* pSrcBits, UINT* pDestBits);
173
175public:
176 void DrawRotatedButton(CDC* pDC, CRect rcItem, CXTPTabManagerItem* pItem, BOOL bSwap,
177 LPFNDRAWROTATEDBITS pfnRotatedProc);
178 static void AFX_CDECL DrawRotatedBitsBottom(int cx, int cy, UINT* pSrcBits, UINT* pDestBits);
179 static void AFX_CDECL DrawRotatedBitsRight(int cx, int cy, UINT* pSrcBits, UINT* pDestBits);
180 static void AFX_CDECL DrawRotatedBitsLeft(int cx, int cy, UINT* pSrcBits, UINT* pDestBits);
181 static void AFX_CDECL DrawRotatedBitsInvertRight(int cx, int cy, UINT* pSrcBits,
182 UINT* pDestBits);
185protected:
186 CXTPWinThemeWrapper* m_themeTabButton;
188 CXTPWinThemeWrapper* m_themeToolbar;
190};
191
193// obsolete, for backward compatibility only.
194class _XTP_EXT_CLASS CColorSetWinXP : public CColorSetWinNative
195{
196};
199# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
201#endif // !defined(__XTPTABCOLORSETWINNATIVE_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CColorSetWinNative
CColorSetWinNative implements a Windows XP tab color set.
Definition XTPTabColorSetWinNative.h:49
CColorSetWinNative::m_themeTabButton
CXTPWinThemeWrapper * m_themeTabButton
Internally used helper to draw property page buttons using Windows XP color set.
Definition XTPTabColorSetWinNative.h:186
CColorSetWinNative::m_themeToolbar
CXTPWinThemeWrapper * m_themeToolbar
Internally used helper to draw state buttons using Windows XP color set.
Definition XTPTabColorSetWinNative.h:188
CColorSetWinNative::FillClient
virtual COLORREF FillClient(CDC *pDC, CRect rc, CXTPTabManager *pTabManager)
Fills the tab client area of a specified tab manager.
CColorSetWinNative::IsAppThemed
virtual BOOL IsAppThemed() const
Determines if Windows XP themes are enabled and if a Windows XP theme is currently used.
CColorSetWinNative::FillStateButton
virtual void FillStateButton(CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem)
Fills a specified tab button when XTPTabAppearanceStyle is xtpTabAppearanceStateButtons.
CColorSetWinNative::SelectClipRgn
virtual void SelectClipRgn(CDC *pDC, CRect rcClient, CXTPTabManager *pTabManager)
Sets a clipping region for the specified tab client area.
CColorSetWinNative::FillNavigateButton
virtual void FillNavigateButton(CDC *pDC, CXTPTabManagerNavigateButton *pButton, CRect &rc)
Fills a specified tab navigation button.
CColorSetWinNative::RefreshMetrics
virtual void RefreshMetrics()
Refreshes the visual metrics of the tabs.
CColorSetWinNative::FillPropertyButton
virtual COLORREF FillPropertyButton(CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem)
Fills a specified tab button.
CXTPTabColorSetDefault
CXTPTabColorSetDefault implements a default tab color set.
Definition XTPTabColorSetDefault.h:44
CXTPTabManager
CXTPTabManager is the base class for docking pane tabs, tab control tabs, and MDI client tabs.
Definition XTPTabManager.h:87
CXTPTabManagerItem
CXTPTabManagerItem is the base class for the tabs that appear in the command bars tab workspace,...
Definition XTPTabManagerItem.h:44
CXTPTabManagerNavigateButton
CXTPTabManagerNavigateButton is a class used to represent a tab navigation button.
Definition XTPTabManagerNavigateButton.h:74
CXTPWinThemeWrapper
The CXTPWinThemeWrapper class wraps the UxTheme.dll visual theme API.
Definition XTPWinThemeWrapper.h:188


Toolkit Pro: XTPPasswordPeek.h Source File

  • Source
  • Controls
  • Edit
XTPPasswordPeek.h
Go to the documentation of this file.
1
23#if !defined(__XTPPASSWORDPEEK_H__)
24# define __XTPPASSWORDPEEK_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
37class _XTP_EXT_CLASS CXTPPasswordPeek : public CXTPEdit
38{
40 DECLARE_DYNAMIC(CXTPPasswordPeek)
42public:
47 CXTPPasswordPeek();
48
53 virtual ~CXTPPasswordPeek();
54
61 CXTPImageManager* GetImageManager();
62
68 void SetImageManager(CXTPImageManager* pImageManager);
69
77 void PeekButtonEnable(BOOL bEnable = TRUE);
78
85 BOOL IsPeekButtonEnabled();
86
91 virtual void InitIcons();
92
101 virtual void OnDrawButton(CDC* pDC, CRect rect, BOOL bIsButtonPressed, BOOL bIsButtonHot);
102
107 virtual void OnChangeLayout();
108
109protected:
110 enum PasswordPeekMode
111 {
112 PasswordPeekModeEnabled,
113 PasswordPeekModeDisabled,
114 };
115
116 int m_nButtonWidth;
117 BOOL m_bIsButtonPressed;
118 BOOL m_bIsButtonHighlighted;
119 BOOL m_bIsButtonCaptured;
120 CRect m_rectBtn;
121 CSize m_sizeImage;
122 PasswordPeekMode m_Mode;
123 CXTPImageManager* m_pImageManager;
124
125 afx_msg void OnNcCalcSize(BOOL bCalcValidRects, NCCALCSIZE_PARAMS FAR* lpncsp);
126 afx_msg void OnNcPaint();
127 afx_msg LRESULT OnNcHitTest(CPoint point);
128 afx_msg void OnNcMouseMove(UINT nHitTest, CPoint point);
129 afx_msg void OnLButtonDown(UINT nFlags, CPoint point);
130 afx_msg void OnLButtonUp(UINT nFlags, CPoint point);
131 afx_msg void OnRButtonDown(UINT nFlags, CPoint point);
132 afx_msg void OnRButtonUp(UINT nFlags, CPoint point);
133 afx_msg void OnMouseMove(UINT nFlags, CPoint point);
134 afx_msg void OnCancelMode();
135
136 DECLARE_MESSAGE_MAP()
137};
139AFX_INLINE CXTPImageManager* CXTPPasswordPeek::GetImageManager()
140{
141 return m_pImageManager;
142}
143
144AFX_INLINE void CXTPPasswordPeek::SetImageManager(CXTPImageManager* pImageManager)
145{
146 m_pImageManager = pImageManager;
147}
149# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
151#endif // #if !defined(__XTPPASSWORDPEEK_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPEdit
CXTPEdit is a CEdit derived class.
Definition XTPEdit.h:129
CXTPImageManager
CXTPImageManager is a standalone class.
Definition XTPImageManager.h:1898
CXTPPasswordPeek
CXTPPasswordPeek is a CXTPEdit derived class.
Definition XTPPasswordPeek.h:38
CXTPPasswordPeek::~CXTPPasswordPeek
virtual ~CXTPPasswordPeek()
Destroys a CXTPPasswordPeek object, handles cleanup and deallocation.
CXTPPasswordPeek::CXTPPasswordPeek
CXTPPasswordPeek()
Constructs a CXTPPasswordPeek object.
CXTPPasswordPeek::IsPeekButtonEnabled
BOOL IsPeekButtonEnabled()
Call this member to get the state of the peek button.
CXTPPasswordPeek::OnChangeLayout
virtual void OnChangeLayout()
This method is used to configure peek button layout.
CXTPPasswordPeek::GetImageManager
CXTPImageManager * GetImageManager()
Call this method to retrieve the image manager.
CXTPPasswordPeek::OnDrawButton
virtual void OnDrawButton(CDC *pDC, CRect rect, BOOL bIsButtonPressed, BOOL bIsButtonHot)
This method is used to draw the peek button.
CXTPPasswordPeek::PeekButtonEnable
void PeekButtonEnable(BOOL bEnable=TRUE)
Call this member to enable or disable peek button.
CXTPPasswordPeek::InitIcons
virtual void InitIcons()
This member function is used to icons initialization.
CXTPPasswordPeek::SetImageManager
void SetImageManager(CXTPImageManager *pImageManager)
Call this member to set the specified image manager.


Toolkit Pro: XTPSyntaxEditLexColorFileReader.h Source File

  • Source
  • SyntaxEdit
XTPSyntaxEditLexColorFileReader.h
Go to the documentation of this file.
1
23#if !defined(__XTPSYNTAXEDITLEXCOLORFILEREADER_H__)
24# define __XTPSYNTAXEDITLEXCOLORFILEREADER_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPSyntaxEditColorTheme;
34class CXTPNotifyConnection;
35class CXTPNotifyConnectionMT;
36struct XTP_EDIT_SCHEMAFILEINFO;
37class CXTPSyntaxEditSchemaFileInfoList;
38
43enum XTPSyntaxEditCfgFlags
44{
45 xtpEditCfgFileAdd = 0x0001,
46 xtpEditCfgFileRemove = 0x0002,
47};
48
54class _XTP_EXT_CLASS CXTPSyntaxEditColorInfo
55{
56public:
63 CXTPSyntaxEditColorInfo(CXTPSyntaxEditColorTheme* pTheme);
71 CXTPSyntaxEditColorInfo(const CString& strClassName, CXTPSyntaxEditColorTheme* pTheme);
72
78 virtual ~CXTPSyntaxEditColorInfo();
79
86 void AddParam(const CString& strName, const CString& strValue);
87
99 const CString GetParam(const CString& strName, BOOL bDynamic = TRUE);
100
112 DWORD GetHexParam(const CString& strName, BOOL bDynamic = TRUE);
113
120 POSITION GetFirstParamNamePosition();
121
129 const CString GetNextParamName(POSITION& pos);
130
137 const CString GetClassName() const;
138
139private:
140 CString m_strClassName;
141 CMapStringToString m_mapParams;
142 CXTPSyntaxEditColorTheme* m_pTheme;
144};
145
150class _XTP_EXT_CLASS CXTPSyntaxEditColorInfoArray
151 : public CArray<CXTPSyntaxEditColorInfo*, CXTPSyntaxEditColorInfo*>
152{
153 typedef CArray<CXTPSyntaxEditColorInfo*, CXTPSyntaxEditColorInfo*> TBase;
154
155public:
160 CXTPSyntaxEditColorInfoArray(){};
161
166 virtual ~CXTPSyntaxEditColorInfoArray()
167 {
168 RemoveAll();
169 };
170
175 void RemoveAll()
176 {
177 for (int i = 0; i < GetSize(); i++)
178 {
179 if (GetAt(i))
180 {
181 delete GetAt(i);
182 }
183 }
184 TBase::RemoveAll();
185 }
186};
187
188class CXTPSyntaxEditColorThemesManager;
189class CXTPSyntaxEditFileChangesMonitor;
190class CXTPSyntaxEditPropertiesTheme;
191
202class _XTP_EXT_CLASS CXTPSyntaxEditColorTheme
203{
204 friend class CXTPSyntaxEditPropertiesTheme;
205
212 typedef CMap<CString, LPCTSTR, CXTPSyntaxEditColorInfo*, CXTPSyntaxEditColorInfo*>
213 CXTPSyntaxEditMapLexColorInfo;
214
215public:
221 CXTPSyntaxEditColorTheme(CXTPSyntaxEditColorThemesManager* pThemesManager);
222
228 virtual ~CXTPSyntaxEditColorTheme();
229
236 virtual void Load(const CString& csFileName);
237
243 virtual void LoadFromString(CStringArray& arPassedString);
244
251 const CString GetParentThemeName();
252
259 CXTPSyntaxEditColorTheme* GetParentTheme();
260
275 CXTPSyntaxEditColorInfo* GetColorInfo(const CString& strLexClass,
276 const CString& strThemeFilename, BOOL bDynamic = TRUE);
277
284 CString GetFileName();
285
296 BOOL WriteCfgFile(CString strParentThemeName,
297 CXTPSyntaxEditColorInfoArray* pColorInfoArray_new);
298
299protected:
304 void Cleanup();
305
315 CXTPSyntaxEditColorInfo* ParseSection(const CString& csSection);
316
327 CXTPSyntaxEditColorInfo* ParseSectionFromString(const CString& csSection,
328 CStringArray& arPassedString);
329
330private:
331 CStringList m_arSections;
332 CString m_csFileName;
333 CXTPSyntaxEditMapLexColorInfo m_mapLexColorInfo;
335 CXTPSyntaxEditColorThemesManager* m_pThemesManager;
337};
338
339AFX_INLINE CString CXTPSyntaxEditColorTheme::GetFileName()
340{
341 return m_csFileName;
342}
343
349class _XTP_EXT_CLASS CXTPSyntaxEditColorThemesManager
350{
351 typedef CMap<CString, LPCTSTR, CXTPSyntaxEditColorTheme*, CXTPSyntaxEditColorTheme*>
352 CXTPSyntaxEditMapThemes;
353
354public:
359 CXTPSyntaxEditColorThemesManager();
365 virtual ~CXTPSyntaxEditColorThemesManager();
366
373 void LoadTheme(const CString& strThemeName, const CString& strThemeFilename);
374
381 void LoadThemeFromString(const CString& strThemeName, CStringArray& arPassedString);
382
389 void AddThemeInfo(const CString& strThemeName, const CString& strThemeFilename);
390
400 CXTPSyntaxEditColorTheme* GetTheme(const CString& strThemeName);
401
408 CStringArray& GetThemes();
409
423 CString ReloadFile(const CString& csFileName, int nCfgFlags = 0);
424
429 void RemoveAll();
430
431private:
432 CXTPSyntaxEditMapThemes m_mapThemes;
433 CStringArray m_arThemeNames;
434 CMapStringToString m_mapFileToTheme;
435};
436
437typedef XTPSyntaxEditLexAnalyser::CXTPSyntaxEditLexTextSchema CXTPSyntaxEditTextSchema;
438typedef CXTPSmartPtrInternalT<XTPSyntaxEditLexAnalyser::CXTPSyntaxEditLexTextSchema>
439 CXTPSyntaxEditLexTextSchemaPtr;
440typedef CXTPSyntaxEditLexTextSchemaPtr CXTPSyntaxEditTextSchemaPtr;
441
447class _XTP_EXT_CLASS CXTPSyntaxEditTextSchemesManager
448{
449 typedef CMap<CString, LPCTSTR, CXTPSyntaxEditTextSchemaPtr, CXTPSyntaxEditTextSchemaPtr&>
450 CXTPSyntaxEditMapSchemes;
451
452public:
457 CXTPSyntaxEditTextSchemesManager();
458
464 virtual ~CXTPSyntaxEditTextSchemesManager();
465
471 void AddTextSchemeInfo(XTP_EDIT_SCHEMAFILEINFO& info);
472
479 void LoadTextScheme(XTP_EDIT_SCHEMAFILEINFO& info);
480
488 void LoadTextStringScheme(XTP_EDIT_SCHEMAFILEINFO& info, CString* p_sSyntaxScheme);
489
499 CXTPSyntaxEditTextSchemaPtr GetSchema(const CString& strSchemeName);
500
508 CString GetSchemaName(const CString& csFileName) const;
509
517 CString GetSchemaFileName(const CString& strSchemeName) const;
518
525 CStringArray& GetSchemes();
526
533 CXTPSyntaxEditSchemaFileInfoList* GetSchemaList() const;
534
544 CXTPSyntaxEditTextSchemaPtr FindSchema(const CString& strFileExt) const;
545
553 void SetTheme(CXTPSyntaxEditColorTheme* pTheme);
554
565 BOOL ReloadFile(const CString& csFileName, int nCfgFlags = 0);
566
571 void RemoveAll();
572
573private:
574 CXTPSyntaxEditMapSchemes m_mapSchemes;
575 CXTPSyntaxEditSchemaFileInfoList* m_plistSchemes;
576 CStringArray m_arSchemeNames;
577 CCriticalSection m_csReadFile;
578};
579
580AFX_INLINE CStringArray& CXTPSyntaxEditTextSchemesManager::GetSchemes()
581{
582 return m_arSchemeNames;
583}
584
585AFX_INLINE CXTPSyntaxEditSchemaFileInfoList* CXTPSyntaxEditTextSchemesManager::GetSchemaList() const
586{
587 return m_plistSchemes;
588}
589
600class _XTP_EXT_CLASS CXTPSyntaxEditConfigurationManager : public CXTPCmdTarget
601{
602public:
607 enum XTPSyntaxEditCfgObjects
608 {
609 xtpEditCfgObjSchMan = 0x0001,
610 xtpEditCfgObjThemeMan = 0x0002,
611 xtpEditCfgObjMainConfig = 0x0004,
612 };
613
618 CXTPSyntaxEditConfigurationManager();
619
625 virtual ~CXTPSyntaxEditConfigurationManager();
626
634 void ReloadConfig(const CString& strConfigFilePath);
635
640 void ReloadConfig();
641
649 void ReloadConfigAsync(int nAsyncThreadPriority = THREAD_PRIORITY_NORMAL);
650
659 CString GetConfigFile() const;
660
673 void ReloadFile(CString csFileName, DWORD dwOwnerFlags, int nCfgFlags = 0);
674
681 CXTPSyntaxEditColorThemesManager& GetThemeManager();
682
689 CXTPSyntaxEditTextSchemesManager& GetTextSchemesManager();
690
697 void SetTheme(const CString& strThemeName, CXTPSyntaxEditTextSchema* pActiveSch = NULL);
698
703 void Close();
710 CString GetCurrentTheme() const;
711
718 CXTPNotifyConnection* GetConnection() const;
719
726 void SetSyntaxAndColorScheme(CString* pSyntaxScheme, CString* pColorScheme)
727 {
728 p_sSyntaxScheme = pSyntaxScheme;
729 p_sColorScheme = pColorScheme;
730 }
731 BOOL m_bUseMonitor;
734 BOOL m_bConfigFileMode;
737 CString m_sIniSet;
738 CString* p_sSyntaxScheme;
739 CString* p_sColorScheme;
741private:
742 static UINT AFX_CDECL ReloadConfigAsync_Proc(LPVOID pThis);
743
744 CString m_strMainIniFilename;
746 CXTPSyntaxEditFileChangesMonitor* m_pFolderMonitor;
748 CXTPSyntaxEditColorThemesManager m_ColorThemeManager;
749 CXTPSyntaxEditTextSchemesManager m_TextSchemesManager;
751 CString m_strCurrentThemeName;
753 CXTPNotifyConnectionMT* m_pConnectMT;
754 CCriticalSection m_DataLockerCS;
756 HANDLE m_hReloadThread;
757 CEvent* m_pBreakReloadEvent;
758};
759
760AFX_INLINE const CString CXTPSyntaxEditColorInfo::GetClassName() const
761{
762 return m_strClassName;
763}
764
765AFX_INLINE CXTPSyntaxEditColorThemesManager& CXTPSyntaxEditConfigurationManager::GetThemeManager()
766{
767 return m_ColorThemeManager;
768}
769
770AFX_INLINE CXTPSyntaxEditTextSchemesManager&
771 CXTPSyntaxEditConfigurationManager::GetTextSchemesManager()
772{
773 return m_TextSchemesManager;
774}
775
776AFX_INLINE CString CXTPSyntaxEditConfigurationManager::GetCurrentTheme() const
777{
778 return m_strCurrentThemeName;
779}
780
781# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
783#endif // !defined(__XTPSYNTAXEDITLEXCOLORFILEREADER_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPSyntaxEditTextSchema
XTPSyntaxEditLexAnalyser::CXTPSyntaxEditLexTextSchema CXTPSyntaxEditTextSchema
namespace XTPSyntaxEditLexAnalyser
Definition XTPSyntaxEditBufferManager.h:41
XTPSyntaxEditCfgFlags
XTPSyntaxEditCfgFlags
This enumeration describes allowable configuration managers flags.
Definition XTPSyntaxEditLexColorFileReader.h:44
xtpEditCfgFileAdd
@ xtpEditCfgFileAdd
File should be added.
Definition XTPSyntaxEditLexColorFileReader.h:45
xtpEditCfgFileRemove
@ xtpEditCfgFileRemove
File should be removed.
Definition XTPSyntaxEditLexColorFileReader.h:46
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPNotifyConnection
This class is used as implementation of Connection interface in a XTPNotification mechanism.
Definition XTPNotifyConnection.h:88
CXTPNotifyConnectionMT
This class is used as thread-safety implementation of Connection interface in a XTPNotification mecha...
Definition XTPNotifyConnection.h:303
CXTPSmartPtrInternalT
Definition XTPSmartPtrInternalT.h:72
CXTPSyntaxEditColorInfoArray
This collection class stores the color info objects.
Definition XTPSyntaxEditLexColorFileReader.h:152
CXTPSyntaxEditColorInfoArray::CXTPSyntaxEditColorInfoArray
CXTPSyntaxEditColorInfoArray()
Constructor, creates and initializes the object.
Definition XTPSyntaxEditLexColorFileReader.h:160
CXTPSyntaxEditColorInfoArray::~CXTPSyntaxEditColorInfoArray
virtual ~CXTPSyntaxEditColorInfoArray()
Destructor, do the cleaups and destroys the object.
Definition XTPSyntaxEditLexColorFileReader.h:166
CXTPSyntaxEditColorInfoArray::RemoveAll
void RemoveAll()
Removes all of the color info objects.
Definition XTPSyntaxEditLexColorFileReader.h:175
CXTPSyntaxEditColorInfo
This storage class is designed to contain information from the color settings file section.
Definition XTPSyntaxEditLexColorFileReader.h:55
CXTPSyntaxEditColorInfo::~CXTPSyntaxEditColorInfo
virtual ~CXTPSyntaxEditColorInfo()
Destroys a CXTPSyntaxEditColorTheme() object, handles cleanup and de-allocation.
CXTPSyntaxEditColorInfo::CXTPSyntaxEditColorInfo
CXTPSyntaxEditColorInfo(const CString &strClassName, CXTPSyntaxEditColorTheme *pTheme)
Object constructor.
CXTPSyntaxEditColorInfo::GetHexParam
DWORD GetHexParam(const CString &strName, BOOL bDynamic=TRUE)
Retrieves the hexadecimal value of a parameter with a specified name.
CXTPSyntaxEditColorInfo::GetParam
const CString GetParam(const CString &strName, BOOL bDynamic=TRUE)
Retrieves the value of a parameter with a specified name.
CXTPSyntaxEditColorInfo::AddParam
void AddParam(const CString &strName, const CString &strValue)
Adds a parameter.
CXTPSyntaxEditColorInfo::GetFirstParamNamePosition
POSITION GetFirstParamNamePosition()
Gets the first parameter name position.
CXTPSyntaxEditColorInfo::GetClassName
const CString GetClassName() const
Gets the lex class name.
Definition XTPSyntaxEditLexColorFileReader.h:760
CXTPSyntaxEditColorInfo::CXTPSyntaxEditColorInfo
CXTPSyntaxEditColorInfo(CXTPSyntaxEditColorTheme *pTheme)
Object constructor.
CXTPSyntaxEditColorInfo::GetNextParamName
const CString GetNextParamName(POSITION &pos)
Gets the next parameter name.
CXTPSyntaxEditColorTheme
This class provides the functionality to read configuration information from configuration files with...
Definition XTPSyntaxEditLexColorFileReader.h:203
CXTPSyntaxEditColorTheme::GetParentTheme
CXTPSyntaxEditColorTheme * GetParentTheme()
Gets the parent schema.
CXTPSyntaxEditColorTheme::LoadFromString
virtual void LoadFromString(CStringArray &arPassedString)
Loads a color scheme.
CXTPSyntaxEditColorTheme::Load
virtual void Load(const CString &csFileName)
Parses the associated color schema file and fills internal color information structures.
CXTPSyntaxEditColorTheme::ParseSectionFromString
CXTPSyntaxEditColorInfo * ParseSectionFromString(const CString &csSection, CStringArray &arPassedString)
Parses a single section of the configuration file and creates a CXTPSyntaxEditColorInfo object from i...
CXTPSyntaxEditColorTheme::GetColorInfo
CXTPSyntaxEditColorInfo * GetColorInfo(const CString &strLexClass, const CString &strThemeFilename, BOOL bDynamic=TRUE)
Gets the color information.
CXTPSyntaxEditColorTheme::GetFileName
CString GetFileName()
Gets the configuration file name.
Definition XTPSyntaxEditLexColorFileReader.h:339
CXTPSyntaxEditColorTheme::GetParentThemeName
const CString GetParentThemeName()
Gets the name of the parent schema.
CXTPSyntaxEditColorTheme::CXTPSyntaxEditColorTheme
CXTPSyntaxEditColorTheme(CXTPSyntaxEditColorThemesManager *pThemesManager)
Default object constructor.
CXTPSyntaxEditColorTheme::Cleanup
void Cleanup()
Cleans up the collection.
CXTPSyntaxEditColorTheme::~CXTPSyntaxEditColorTheme
virtual ~CXTPSyntaxEditColorTheme()
Destroys a CXTPSyntaxEditColorTheme() object, handles cleanup and de-allocation.
CXTPSyntaxEditColorTheme::ParseSection
CXTPSyntaxEditColorInfo * ParseSection(const CString &csSection)
Parses a single section of the configuration file and creates a CXTPSyntaxEditColorInfo object from i...
CXTPSyntaxEditColorTheme::WriteCfgFile
BOOL WriteCfgFile(CString strParentThemeName, CXTPSyntaxEditColorInfoArray *pColorInfoArray_new)
Saves colors to the configuration file.
CXTPSyntaxEditColorThemesManager
This class provides the functionality to store the set of all color themes that would be written from...
Definition XTPSyntaxEditLexColorFileReader.h:350
CXTPSyntaxEditColorThemesManager::~CXTPSyntaxEditColorThemesManager
virtual ~CXTPSyntaxEditColorThemesManager()
Destroys a CXTPSyntaxEditColorThemesManager() object, handles cleanup and de-allocation.
CXTPSyntaxEditColorThemesManager::GetTheme
CXTPSyntaxEditColorTheme * GetTheme(const CString &strThemeName)
Gets the color theme with a specified name.
CXTPSyntaxEditColorThemesManager::GetThemes
CStringArray & GetThemes()
Gets all theme names.
CXTPSyntaxEditColorThemesManager::LoadTheme
void LoadTheme(const CString &strThemeName, const CString &strThemeFilename)
Loads a theme.
CXTPSyntaxEditColorThemesManager::ReloadFile
CString ReloadFile(const CString &csFileName, int nCfgFlags=0)
Reloads configuration settings from a specified configuration file.
CXTPSyntaxEditColorThemesManager::RemoveAll
void RemoveAll()
Removes all loaded data.
CXTPSyntaxEditColorThemesManager::AddThemeInfo
void AddThemeInfo(const CString &strThemeName, const CString &strThemeFilename)
Adds a new entity to the "theme name - configuration file" map.
CXTPSyntaxEditColorThemesManager::LoadThemeFromString
void LoadThemeFromString(const CString &strThemeName, CStringArray &arPassedString)
Loads a theme.
CXTPSyntaxEditColorThemesManager::CXTPSyntaxEditColorThemesManager
CXTPSyntaxEditColorThemesManager()
Default object constructor.
CXTPSyntaxEditConfigurationManager
This class manages all configuration parameters of the control.
Definition XTPSyntaxEditLexColorFileReader.h:601
CXTPSyntaxEditConfigurationManager::CXTPSyntaxEditConfigurationManager
CXTPSyntaxEditConfigurationManager()
Default object constructor.
CXTPSyntaxEditConfigurationManager::GetConfigFile
CString GetConfigFile() const
Gets the name of the main configuration file.
CXTPSyntaxEditConfigurationManager::GetConnection
CXTPNotifyConnection * GetConnection() const
Gets the notification connection.
CXTPSyntaxEditConfigurationManager::ReloadConfigAsync
void ReloadConfigAsync(int nAsyncThreadPriority=THREAD_PRIORITY_NORMAL)
Asynchronously reloads configuration settings from the stored main configuration file.
CXTPSyntaxEditConfigurationManager::ReloadFile
void ReloadFile(CString csFileName, DWORD dwOwnerFlags, int nCfgFlags=0)
Reloads configuration settings from a specified configuration file.
CXTPSyntaxEditConfigurationManager::ReloadConfig
void ReloadConfig()
Reloads configuration settings from the stored main configuration file.
CXTPSyntaxEditConfigurationManager::m_bConfigFileMode
BOOL m_bConfigFileMode
TRUE if the control reads Config file with links to detailed setting (Syntax and Color schemes),...
Definition XTPSyntaxEditLexColorFileReader.h:734
CXTPSyntaxEditConfigurationManager::m_sIniSet
CString m_sIniSet
The ini file settings.
Definition XTPSyntaxEditLexColorFileReader.h:737
CXTPSyntaxEditConfigurationManager::Close
void Close()
Closes the configuration monitor session.
CXTPSyntaxEditConfigurationManager::p_sColorScheme
CString * p_sColorScheme
Pointer to the color scheme.
Definition XTPSyntaxEditLexColorFileReader.h:739
CXTPSyntaxEditConfigurationManager::GetTextSchemesManager
CXTPSyntaxEditTextSchemesManager & GetTextSchemesManager()
Gets the text scheme manager.
Definition XTPSyntaxEditLexColorFileReader.h:771
CXTPSyntaxEditConfigurationManager::m_bUseMonitor
BOOL m_bUseMonitor
TRUE if the control uses a special thread to synchronize syntax rules with files with Syntax and Colo...
Definition XTPSyntaxEditLexColorFileReader.h:731
CXTPSyntaxEditConfigurationManager::~CXTPSyntaxEditConfigurationManager
virtual ~CXTPSyntaxEditConfigurationManager()
Destroys a CXTPSyntaxEditConfigurationManager() object, handles cleanup and de-allocation.
CXTPSyntaxEditConfigurationManager::GetCurrentTheme
CString GetCurrentTheme() const
Gets the current theme name.
Definition XTPSyntaxEditLexColorFileReader.h:776
CXTPSyntaxEditConfigurationManager::ReloadConfig
void ReloadConfig(const CString &strConfigFilePath)
Reloads settings from a specified file.
CXTPSyntaxEditConfigurationManager::GetThemeManager
CXTPSyntaxEditColorThemesManager & GetThemeManager()
Gets the color theme manager.
Definition XTPSyntaxEditLexColorFileReader.h:765
CXTPSyntaxEditConfigurationManager::SetSyntaxAndColorScheme
void SetSyntaxAndColorScheme(CString *pSyntaxScheme, CString *pColorScheme)
Sets the syntax and color scheme.
Definition XTPSyntaxEditLexColorFileReader.h:726
CXTPSyntaxEditConfigurationManager::XTPSyntaxEditCfgObjects
XTPSyntaxEditCfgObjects
Configuration manager sub-objects.
Definition XTPSyntaxEditLexColorFileReader.h:608
CXTPSyntaxEditConfigurationManager::SetTheme
void SetTheme(const CString &strThemeName, CXTPSyntaxEditTextSchema *pActiveSch=NULL)
Sets the current theme name.
CXTPSyntaxEditConfigurationManager::p_sSyntaxScheme
CString * p_sSyntaxScheme
Pointer to the syntax scheme.
Definition XTPSyntaxEditLexColorFileReader.h:738
CXTPSyntaxEditFileChangesMonitor
this class monitors files changes
Definition XTPSyntaxEditLexCfgFileReader.h:408
CXTPSyntaxEditTextSchemesManager
This class provides the functionality to store the set of all text schemes that would be written from...
Definition XTPSyntaxEditLexColorFileReader.h:448
CXTPSyntaxEditTextSchemesManager::GetSchema
CXTPSyntaxEditTextSchemaPtr GetSchema(const CString &strSchemeName)
Gets a schema by its name.
CXTPSyntaxEditTextSchemesManager::LoadTextStringScheme
void LoadTextStringScheme(XTP_EDIT_SCHEMAFILEINFO &info, CString *p_sSyntaxScheme)
Implements common logic on creating new text scheme object and loading it string - used for non-file ...
CXTPSyntaxEditTextSchemesManager::GetSchemaName
CString GetSchemaName(const CString &csFileName) const
Gets a schema name by its file name.
CXTPSyntaxEditTextSchemesManager::GetSchemaFileName
CString GetSchemaFileName(const CString &strSchemeName) const
Gets a file name by its schema name.
CXTPSyntaxEditTextSchemesManager::AddTextSchemeInfo
void AddTextSchemeInfo(XTP_EDIT_SCHEMAFILEINFO &info)
Adds text scheme information.
CXTPSyntaxEditTextSchemesManager::FindSchema
CXTPSyntaxEditTextSchemaPtr FindSchema(const CString &strFileExt) const
Finds a schema by its file extension.
CXTPSyntaxEditTextSchemesManager::~CXTPSyntaxEditTextSchemesManager
virtual ~CXTPSyntaxEditTextSchemesManager()
Destroys a CXTPSyntaxEditTextSchemesManager() object, handles cleanup and de-allocation.
CXTPSyntaxEditTextSchemesManager::RemoveAll
void RemoveAll()
Removes all loaded data.
CXTPSyntaxEditTextSchemesManager::LoadTextScheme
void LoadTextScheme(XTP_EDIT_SCHEMAFILEINFO &info)
Implements common logic on creating new text scheme object and loading it from file or resources.
CXTPSyntaxEditTextSchemesManager::ReloadFile
BOOL ReloadFile(const CString &csFileName, int nCfgFlags=0)
Reloads configuration settings from a specified configuration file.
CXTPSyntaxEditTextSchemesManager::GetSchemes
CStringArray & GetSchemes()
Gets all scheme names.
Definition XTPSyntaxEditLexColorFileReader.h:580
CXTPSyntaxEditTextSchemesManager::GetSchemaList
CXTPSyntaxEditSchemaFileInfoList * GetSchemaList() const
Gets the schema list.
Definition XTPSyntaxEditLexColorFileReader.h:585
CXTPSyntaxEditTextSchemesManager::SetTheme
void SetTheme(CXTPSyntaxEditColorTheme *pTheme)
Sets the theme for all text schemes.
CXTPSyntaxEditTextSchemesManager::CXTPSyntaxEditTextSchemesManager
CXTPSyntaxEditTextSchemesManager()
Default object constructor.


Toolkit Pro: XTPUtil.h Source File

  • Source
  • Controls
  • Util
XTPUtil.h
Go to the documentation of this file.
1
23#if !defined(__XTPUTIL_H__)
24# define __XTPUTIL_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPIconHandle
39{
40public:
45 CXTPIconHandle();
46
52 CXTPIconHandle(HICON hIcon);
53
58 virtual ~CXTPIconHandle();
59
60public:
68 operator HICON() const;
69
78 CXTPIconHandle& operator=(HICON hIcon);
79
86 CSize GetExtent() const;
87
95 static CSize AFX_CDECL GetExtent(HICON hIcon);
96
106 HICON ScaleToFit(CSize desiredExtent) const;
107
118 static HICON AFX_CDECL ScaleToFit(HICON hIcon, CSize desiredExtent);
119
120protected:
121 HICON m_hIcon;
122};
124AFX_INLINE CXTPIconHandle::operator HICON() const
125{
126 return m_hIcon;
127}
134class _XTP_EXT_CLASS CXTPSplitPath
135{
136public:
144 CXTPSplitPath(LPCTSTR lpszPathBuffer = NULL);
145
150 virtual ~CXTPSplitPath();
151
152public:
159 void SplitPath(LPCTSTR lpszPathBuffer);
160
168 CString GetDrive() const;
169
178 CString GetDir() const;
179
187 CString GetFName() const;
188
196 CString GetExt() const;
197
204 CString GetFullPath() const;
205
213 CString GetFullName() const;
214
215protected:
216 TCHAR m_szDrive[_MAX_DRIVE];
217 TCHAR m_szDir[_MAX_DIR];
219 TCHAR m_szFName[_MAX_FNAME];
220 TCHAR m_szExt[_MAX_EXT];
221};
222
224
225# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
227#endif // !defined(__XTPUTIL_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPIconHandle
CXTPIconHandle is a standalone helper class.
Definition XTPUtil.h:39
CXTPIconHandle::ScaleToFit
HICON ScaleToFit(CSize desiredExtent) const
This member function scales an icon to fit into a rectangle.
CXTPIconHandle::CXTPIconHandle
CXTPIconHandle(HICON hIcon)
Constructs a CXTPIconHandle object.
CXTPIconHandle::ScaleToFit
static HICON AFX_CDECL ScaleToFit(HICON hIcon, CSize desiredExtent)
This member function scales an icon to fit into a rectangle.
CXTPIconHandle::GetExtent
CSize GetExtent() const
This member function gets the extent of an icon.
CXTPIconHandle::m_hIcon
HICON m_hIcon
Handle to a dynamically created icon.
Definition XTPUtil.h:121
CXTPIconHandle::GetExtent
static CSize AFX_CDECL GetExtent(HICON hIcon)
This member function gets the extent of an icon.
CXTPIconHandle::operator=
CXTPIconHandle & operator=(HICON hIcon)
This operator is used to initialize the icon associated with the CXTPIconHandle object.
CXTPIconHandle::~CXTPIconHandle
virtual ~CXTPIconHandle()
Destroys a CXTPIconHandle object, handles cleanup and deallocation.
CXTPIconHandle::CXTPIconHandle
CXTPIconHandle()
Constructs a CXTPIconHandle object.
CXTPSplitPath
CXTPSplitPath conveniently wraps the _splitpath API for easier access to path components such as file...
Definition XTPUtil.h:135
CXTPSplitPath::~CXTPSplitPath
virtual ~CXTPSplitPath()
Destroys a CXTPSplitPath object, handles cleanup and deallocation.
CXTPSplitPath::CXTPSplitPath
CXTPSplitPath(LPCTSTR lpszPathBuffer=NULL)
Constructs a CXTPSplitPath object and breaks a path into its four components.
CXTPSplitPath::GetDir
CString GetDir() const
Call GetDir() to retrieve the directory path, including trailing slash.
CXTPSplitPath::GetDrive
CString GetDrive() const
Call GetDrive() to retrieve the drive letter, followed by a colon (:) for the path split.
CXTPSplitPath::GetFullName
CString GetFullName() const
Call GetFullName() to retrieve the filename plus the filename extension only for the path that was sp...
CXTPSplitPath::GetFullPath
CString GetFullPath() const
Call GetFullPath() to retrieve the full path that was split.
CXTPSplitPath::GetExt
CString GetExt() const
Call GetExt() to retrieve the filename extension, including the leading period (.)
CXTPSplitPath::GetFName
CString GetFName() const
Call GetFName() to retrieve the base filename without the filename extension.
CXTPSplitPath::SplitPath
void SplitPath(LPCTSTR lpszPathBuffer)
Call SplitPath to break a path into its four components.


Toolkit Pro: Member List

CXTPComboBoxThemeOffice2000 Member List

This is the complete list of members for CXTPComboBoxThemeOffice2000, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPComboBoxTheme() | CXTPComboBoxTheme |
CXTPComboBoxThemeOffice2000() | CXTPComboBoxThemeOffice2000 |
CXTPControlTheme() | CXTPControlTheme |
DrawBackground(CDC *pDC, CXTPComboBox *pComboBox) | CXTPComboBoxThemeOffice2000 | virtual
DrawButton(CDC *pDC, CXTPComboBox *pComboBox, CRect rcBtn) | CXTPComboBoxThemeOffice2000 | virtual
DrawButtonTriangle(CDC *pDC, CXTPComboBox *pComboBox, CRect rcBtn) | CXTPComboBoxTheme | virtual
DrawComboBox(CDC *pDC, CXTPComboBox *pComboBox) | CXTPComboBoxTheme | virtual
DrawFrame(HDC hdc, LPRECT lprc, int nSize, HBRUSH hBrush) | CXTPComboBoxTheme | virtual
FillSolidRect(HDC hdc, int x, int y, int cx, int cy, HBRUSH hBrush) | CXTPComboBoxTheme | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetBackColor() const | CXTPComboBoxTheme |
GetBackgroundBrush() const | CXTPComboBoxTheme |
GetTextColor() const | CXTPComboBoxTheme |
GetThemeStyle() const | CXTPControlTheme |
m_clrBackDisabled | CXTPComboBoxTheme |
m_clrBackground | CXTPComboBoxTheme |
m_clrBackHighlight | CXTPComboBoxTheme |
m_clrBorderDisabled | CXTPComboBoxTheme |
m_clrBorderHot | CXTPComboBoxTheme |
m_clrBorderNormal | CXTPComboBoxTheme |
m_clrButtonArrowHot | CXTPComboBoxTheme |
m_clrButtonArrowNormal | CXTPComboBoxTheme |
m_clrButtonArrowPressed | CXTPComboBoxTheme |
m_clrButtonHot | CXTPComboBoxTheme |
m_clrButtonNormal | CXTPComboBoxTheme |
m_clrButtonPressed | CXTPComboBoxTheme |
m_clrText | CXTPComboBoxTheme |
m_clrTextDisabled | CXTPComboBoxTheme |
m_clrTextHighlight | CXTPComboBoxTheme |
m_grcButton | CXTPComboBoxTheme |
m_grcButtonHilite | CXTPComboBoxTheme |
m_grcButtonPushed | CXTPComboBoxTheme |
m_nTheme | CXTPControlTheme | protected
m_nThumbWidth | CXTPComboBoxTheme | protected
m_themeComboBox | CXTPComboBoxTheme | protected
m_xtpBrushBackground | CXTPComboBoxTheme | protected
RefreshMetrics(CXTPComboBox *pComboBox) | CXTPComboBoxThemeOffice2000 | virtual
ResetBackColor() | CXTPComboBoxTheme |
ResetTextColor() | CXTPComboBoxTheme |
SetBackColor(COLORREF clrBackground) | CXTPComboBoxTheme |
SetTextColor(COLORREF clrText) | CXTPComboBoxTheme |
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static
UpdateBackgroundBrush() | CXTPComboBoxTheme | protected
~CXTPComboBoxTheme() | CXTPComboBoxTheme | virtual
~CXTPComboBoxThemeOffice2000() | CXTPComboBoxThemeOffice2000 | virtual


Toolkit Pro: Member List

CXTPTrackThemeNativeWindows10 Member List

This is the complete list of members for CXTPTrackThemeNativeWindows10, including all inherited members.

CalcColumnHeight(CDC *pDC, CXTPGridColumn *pColumn, int nTotalWidth=0) | CXTPGridPaintManager | protectedvirtual
CalculateRowHeight(CDC *pDC, const CString &strText, int nMaxWidth, BOOL bWordBreak=TRUE) | CXTPGridPaintManager | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPGridPaintManager() | CXTPGridPaintManager |
CXTPTrackPaintManager() | CXTPTrackPaintManager |
CXTPTrackThemeNativeWindows10() | CXTPTrackThemeNativeWindows10 |
CXTPTrackThemeOffice2013() | CXTPTrackThemeOffice2013 |
DrawBitmap(CDC *pDC, CXTPGridControl *pControl, CRect rcColumn, int iImage) | CXTPGridPaintManager | virtual
DrawCollapsedBitmap(CDC *pDC, const CXTPGridRow *pRow, CRect &rcBitmap) | CXTPGridPaintManager | virtual
DrawColumn(CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn, BOOL bDrawExternal=FALSE, int nShadowWidth=0) | CXTPGridPaintManager | virtual
DrawColumnBackground(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, BOOL &bColumnPressed, BOOL &bDraggingFromHeader, CXTPGridHeader *pHeader=NULL) | CXTPTrackThemeOffice2013 | virtual
DrawColumnFooter(CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn) | CXTPGridPaintManager | virtual
DrawColumnFooterDivider(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn) | CXTPGridPaintManager | virtual
DrawColumnIcon(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, CRect rcIcon, int iIcon) | CXTPGridPaintManager | virtual
DrawColumnText(CDC *pDC, CRect rcText, CString strCaption, int nHeaderAlignment, BOOL bIsHeader, BOOL bColumnPressed) | CXTPTrackThemeOffice2013 | virtual
DrawConnector(CDC *pDC, CPoint ptFrom, CPoint ptTo) | CXTPGridPaintManager |
DrawFocusedRow(CDC *pDC, CRect rcRow) | CXTPTrackThemeOffice2013 | virtual
DrawFreezeColsDivider(CDC *pDC, const CRect &rc, CXTPGridControl *pControl, CXTPGridRow *pRow=NULL) | CXTPGridPaintManager | virtual
DrawGlyph(CDC *pDC, CRect rcColumn, int iImage) | CXTPGridPaintManager | virtual
DrawGrid(CDC *pDC, XTPGridOrientation orientation, CRect rcGrid) | CXTPGridPaintManager | virtual
DrawGridPattern(CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush) | CXTPGridPaintManager | protectedvirtual
DrawGridPattern(CDC *pDC, CXTPBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush) | CXTPGridPaintManager | protectedvirtual
DrawGridPattern(CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr) | CXTPGridPaintManager | protectedvirtual
DrawGroupRow(CDC *pDC, CXTPGridGroupRow *pRow, CRect rcRow, XTP_GRIDRECORDITEM_METRICS *pMetrics) | CXTPTrackThemeOffice2013 | virtual
DrawHorizontalLine(CDC *pDC, int xPos, int yPos, int cx, COLORREF clr) | CXTPGridPaintManager |
DrawInplaceButton(CDC *pDC, CXTPGridInplaceButton *pButton) | CXTPGridPaintManager | virtual
DrawInplaceButtonFrame(CDC *pDC, CXTPGridInplaceButton *pButton) | CXTPGridPaintManager | protectedvirtual
DrawInplaceButtonIcon(CDC *pDC, CXTPGridInplaceButton *pButton) | CXTPGridPaintManager | protectedvirtual
DrawInplaceComboButton(CDC *pDC, CRect *pRc) | CXTPGridPaintManager | virtual
DrawInplaceExpandButton(CDC *pDC, CRect *pRc) | CXTPGridPaintManager | virtual
DrawInplaceSpinButton(CDC *pDC, CRect *pRc) | CXTPGridPaintManager | virtual
DrawItemBitmap(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CRect &rcItem, int nImage) | CXTPGridPaintManager | virtual
DrawItemCaption(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics) | CXTPGridPaintManager | virtual
DrawItemControl(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CXTPGridRecordItemControl *pControl, CRect &rcItem) | CXTPGridPaintManager | virtual
DrawLink(int *pnCurrDrawPos, XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CXTPGridHyperlink *pHyperlink, CString strText, CRect rcLink, int nFlag, BOOL bTrim=FALSE) | CXTPGridPaintManager | protectedvirtual
DrawMarkers(CDC *pDC) | CXTPTrackPaintManager | virtual
DrawMultiLineText(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, BOOL bWordBreak=TRUE) | CXTPGridPaintManager | protectedvirtual
DrawNoGroupByText(CDC *pDC, CRect rcItem) | CXTPGridPaintManager | virtual
DrawRowNumber(CDC *pDC, CRect rcNumber, CXTPGridRow *pRow) | CXTPGridPaintManager | virtual
DrawSectionDivider(CDC *pDC, const CRect &rc, XTPGridSectionDividerPosition dividerPosition, XTPGridSectionDividerStyle dividerStyle, CXTPPaintManagerColor dividerColor) | CXTPGridPaintManager |
DrawShellIcon(CDC *pDC, CRect rcColumn, int iImage) | CXTPGridPaintManager | virtual
DrawSingleLineText(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nStartPos, int nEndPos, int nActualWidth) | CXTPGridPaintManager | protectedvirtual
DrawString(int *pnCurrDrawPos, CDC *pDC, const CString &strDraw, CRect rcDraw, UINT nFormat) | CXTPGridPaintManager | protectedvirtual
DrawTextLine(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nFlag, int &nCharCounter, int &nHyperlinkCounter) | CXTPGridPaintManager | protectedvirtual
DrawTimeLine(CDC *pDC) | CXTPTrackPaintManager | virtual
DrawTrackHeader(CDC *pDC) | CXTPTrackPaintManager | virtual
DrawTreeStructure(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CRect rcItem, CSize sizeGlyph) | CXTPGridPaintManager | virtual
DrawTriangle(CDC *pDC, CRect rcTriangle, BOOL bToDown, BOOL bDraggingFromHeader, int nShadowWidth, BOOL bColumnPressed) | CXTPTrackThemeOffice2013 | virtual
DrawVerticalLine(CDC *pDC, int xPos, int yPos, int cy, COLORREF clr) | CXTPGridPaintManager |
DrawVerticalTimeLineMarker(CDC *pDC, int xPos, CXTPGridControl *pControl, COLORREF color=RGB(0, 255, 0)) | CXTPGridPaintManager | virtual
EnablePreviewMode(BOOL bIsPreviewMode) | CXTPGridPaintManager |
FillFooter(CDC *pDC, CRect rcFooter) | CXTPGridPaintManager | virtual
FillGroupByControl(CDC *pDC, CRect &rcGroupBy) | CXTPGridPaintManager | virtual
FillGroupRowMetrics(CXTPGridGroupRow *pRow, XTP_GRIDRECORDITEM_METRICS *pMetrics, BOOL bPrinting) | CXTPTrackThemeOffice2013 | virtual
FillHeaderControl(CDC *pDC, CRect rcHeader) | CXTPGridPaintManager | virtual
FillIndent(CDC *pDC, CRect rcRow) | CXTPGridPaintManager | virtual
FillItemShade(CDC *pDC, CRect rcItem) | CXTPGridPaintManager | virtual
FillRow(CDC *pDC, CXTPGridRow *pRow, CRect rcRow) | CXTPGridPaintManager | virtual
FindRowAdjacentToMerged(const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, BOOL bUpward) | CXTPGridPaintManager |
FindRowAdjacentToMergedEx(const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, int &nAdjRowIndex, BOOL bUpward) | CXTPGridPaintManager |
FormatTime(int nPosition) | CXTPTrackPaintManager | virtual
FormatTimeLineTick(int nPosition, COLORREF &clrTick, int &nTickLength) | CXTPTrackPaintManager | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetColumnOffice2007CustomThemeBaseColor() const | CXTPGridPaintManager |
GetColumnStyle() const | CXTPGridPaintManager |
GetControlBackColor(CXTPGridControl *pControl) | CXTPGridPaintManager | virtual
GetFooterHeight(CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0) | CXTPGridPaintManager | virtual
GetFreezeColsDividerStyle() const | CXTPGridPaintManager |
GetGlyphs() const | CXTPGridPaintManager |
GetHeaderHeight() | CXTPGridPaintManager | virtual
GetHeaderHeight(CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0) | CXTPGridPaintManager | virtual
GetItemHeight(XTP_GRIDRECORDITEM_DRAWARGS &drawArgs, int nWidth) | CXTPGridPaintManager |
GetMaxPreviewLines() | CXTPGridPaintManager |
GetPreviewItemHeight(CDC *pDC, CXTPGridRow *pRow, int nWidth, int nHeight) | CXTPGridPaintManager | virtual
GetPreviewLinesCount(CDC *pDC, CRect &rcText, const CString &strText) | CXTPGridPaintManager |
GetRowHeight(CDC *pDC, CXTPGridRow *pRow) | CXTPTrackThemeOffice2013 | virtual
CXTPTrackPaintManager::GetRowHeight(CDC *pDC, CXTPGridRow *pRow, int nTotalWidth) | CXTPGridPaintManager | virtual
GetRowHeightEx(CDC *pDC, CXTPGridRow *pRow, int nTotalWidth, const BOOL firstLevel=TRUE) | CXTPGridPaintManager |
GetSectionDividerHeight(XTPGridFixedRowsDividerStyle dividerStyle) | CXTPGridPaintManager |
GetTextFont() | CXTPGridPaintManager |
IsColumHotTrackingEnabled() const | CXTPGridPaintManager | virtual
IsColumnPlusMinusSign() const | CXTPGridPaintManager |
IsColumnWidthWYSIWYG() const | CXTPGridPaintManager |
IsDrawGridForEmptySpace() const | CXTPGridPaintManager |
IsFixedInplaceButtonHeight() const | CXTPGridPaintManager |
IsFixedRowHeight() const | CXTPGridPaintManager |
IsGridVisible(BOOL bVertical) const | CXTPGridPaintManager |
IsGridVisible(XTPGridOrientation orientation) const | CXTPGridPaintManager |
IsLastColumnWidthWYSIWYG() const | CXTPGridPaintManager |
IsPreviewMode() const | CXTPGridPaintManager |
IsPrintGroupRowIcon() const | CXTPGridPaintManager |
IsShowWYSIWYGMarkers() const | CXTPGridPaintManager |
IsUseDropMarker() const | CXTPGridPaintManager |
LoadGlyphs() | CXTPTrackThemeOffice2013 | virtual
m_arStartCol | CXTPGridPaintManager |
m_bAllowMergeCells | CXTPGridPaintManager |
m_bBaseTreeIndent | CXTPGridPaintManager |
m_bCleanTooltip | CXTPGridPaintManager |
m_bColumnPlusMinusSign | CXTPGridPaintManager | protected
m_bColumnWidthWYSIWYG | CXTPGridPaintManager | protected
m_bCompactText | CXTPGridPaintManager |
m_bDrawGridForEmptySpace | CXTPGridPaintManager | protected
m_bFixedInplaceButtonHeight | CXTPGridPaintManager | protected
m_bFixedRowHeight | CXTPGridPaintManager | protected
m_bForceDynamicMarkupForCell | CXTPGridPaintManager |
m_bForceShowDropMarker | CXTPGridPaintManager |
m_bForceShowTooltip | CXTPGridPaintManager |
m_bGrayIfDisable | CXTPGridPaintManager |
m_bGroupRowTextBold | CXTPGridPaintManager |
m_bHideSelection | CXTPGridPaintManager |
m_bHotTracking | CXTPGridPaintManager |
m_bInvertColumnOnClick | CXTPGridPaintManager |
m_bIsPreviewMode | CXTPGridPaintManager | protected
m_bLastColumnWidthWYSIWYG | CXTPGridPaintManager | protected
m_bMakeUpper | CXTPGridPaintManager |
m_bMoveScrollbarOnFixedColumnsIndent | CXTPGridPaintManager |
m_bPrintGroupRowIcon | CXTPGridPaintManager | protected
m_bPrintPageRectangle | CXTPGridPaintManager |
m_bPrintSortTriangle | CXTPGridPaintManager |
m_bPrintVirtualPageNumber | CXTPGridPaintManager |
m_bPrintWatermark | CXTPGridPaintManager |
m_bRecOrRowNum | CXTPGridPaintManager |
m_bRevertAlignment | CXTPGridPaintManager |
m_bShadeGroupHeadings | CXTPGridPaintManager |
m_bShadeSortColumn | CXTPGridPaintManager |
m_bShowLockIcon | CXTPGridPaintManager |
m_bShowNonActiveInPlaceButton | CXTPGridPaintManager |
m_bShowWYSIWYGMarkers | CXTPGridPaintManager | protected
m_bSortTriangleOffsetFromRight | CXTPGridPaintManager |
m_bThemedInplaceButtons | CXTPGridPaintManager |
m_bUseAlternativeBackground | CXTPGridPaintManager |
m_bUseDropMarker | CXTPGridPaintManager |
m_bUseEditTextAlignment | CXTPGridPaintManager |
m_bUseGroupRowSelectionState | CXTPGridPaintManager |
m_bUseShellIcon | CXTPGridPaintManager |
m_clrAlternativeBackground | CXTPGridPaintManager |
m_clrBoldText | CXTPGridPaintManager |
m_clrBoldTextHighlight | CXTPGridPaintManager |
m_clrBtnFace | CXTPGridPaintManager |
m_clrBtnFacePressed | CXTPGridPaintManager |
m_clrBtnText | CXTPGridPaintManager |
m_clrCaptionText | CXTPGridPaintManager |
m_clrCaptionTextPressed | CXTPGridPaintManager |
m_clrColumnOffice2007CustomTheme | CXTPGridPaintManager |
m_clrConnector | CXTPGridPaintManager |
m_clrControlBack | CXTPGridPaintManager |
m_clrControlDark | CXTPGridPaintManager |
m_clrControlLightLight | CXTPGridPaintManager |
m_clrDisableBitmapDarkest | CXTPGridPaintManager |
m_clrDisableBitmapLightest | CXTPGridPaintManager |
m_clrFormulaSubSum | CXTPGridPaintManager |
m_clrFormulaSum | CXTPGridPaintManager |
m_clrFreezeColsDivider | CXTPGridPaintManager |
m_clrGlyph | CXTPTrackThemeOffice2013 |
m_clrGlyphHighlight | CXTPTrackThemeOffice2013 |
m_clrGradientColumnSeparator | CXTPGridPaintManager |
m_clrGradientColumnShadow | CXTPGridPaintManager |
m_clrGroupBoxBack | CXTPGridPaintManager |
m_clrGroupRowText | CXTPGridPaintManager |
m_clrGroupShadeBack | CXTPGridPaintManager |
m_clrGroupShadeBorder | CXTPGridPaintManager |
m_clrGroupShadeText | CXTPGridPaintManager |
m_clrHeaderControl | CXTPGridPaintManager |
m_clrHighlight | CXTPGridPaintManager |
m_clrHighlightText | CXTPGridPaintManager |
m_clrHotDivider | CXTPGridPaintManager |
m_clrIndentControl | CXTPGridPaintManager |
m_clrItemShade | CXTPGridPaintManager |
m_clrMarker | CXTPTrackPaintManager |
m_clrMarkerBack | CXTPTrackPaintManager |
m_clrMarkerBorder | CXTPTrackPaintManager |
m_clrPreviewText | CXTPGridPaintManager |
m_clrScrollBarBorderDark | CXTPTrackPaintManager |
m_clrScrollBarBorderLight | CXTPTrackPaintManager |
m_clrScrollBarDark | CXTPTrackPaintManager |
m_clrScrollBarLight | CXTPTrackPaintManager |
m_clrSelectedArea | CXTPTrackPaintManager |
m_clrSelectedBorder | CXTPTrackThemeOffice2013 |
m_clrSelectedRow | CXTPGridPaintManager |
m_clrSelectedRowText | CXTPGridPaintManager |
m_clrTimeHeaderBorder | CXTPTrackPaintManager |
m_clrTimeHeaderDark | CXTPTrackPaintManager |
m_clrTimeHeaderDarkDark | CXTPTrackPaintManager |
m_clrTimeHeaderDivider | CXTPTrackPaintManager |
m_clrTimeLinePosition | CXTPTrackPaintManager |
m_clrTimeLineTick | CXTPTrackPaintManager |
m_clrTimeSliderBackground | CXTPTrackPaintManager |
m_clrTrackHeader | CXTPTrackPaintManager |
m_clrTrackMarkerBorder | CXTPTrackPaintManager |
m_clrTrackMarkerText | CXTPTrackPaintManager |
m_clrTrackMarkerTextBack | CXTPTrackPaintManager |
m_clrTrackMarkerTextBorder | CXTPTrackPaintManager |
m_clrTrackTimeArea | CXTPTrackPaintManager |
m_clrWindowText | CXTPGridPaintManager |
m_clrWorkArea | CXTPTrackPaintManager |
m_clrWorkAreaScrollBarBorder | CXTPTrackPaintManager |
m_clrWorkAreaScrollBarDark | CXTPTrackPaintManager |
m_clrWorkAreaScrollBarLight | CXTPTrackPaintManager |
m_columnStyle | CXTPGridPaintManager | protected
m_crlNoGroupByText | CXTPGridPaintManager |
m_grcGradientColumn | CXTPGridPaintManager |
m_grcGradientColumnHot | CXTPGridPaintManager |
m_grcGradientColumnPushed | CXTPGridPaintManager |
m_iRecOrRowStart | CXTPGridPaintManager |
m_nBaseParentRecordIndent | CXTPGridPaintManager |
m_nFixedColumnsIndent | CXTPGridPaintManager |
m_nFooterHeight | CXTPGridPaintManager | protected
m_nFreezeColsDividerStyle | CXTPGridPaintManager | protected
m_nGridLineStylePreviousH | CXTPGridPaintManager | protected
m_nGridLineStylePreviousV | CXTPGridPaintManager | protected
m_nGroupGridLineHeight | CXTPGridPaintManager | protected
m_nGroupGridLineStyle | CXTPGridPaintManager | protected
m_nHeaderHeight | CXTPGridPaintManager | protected
m_nMaxPreviewLines | CXTPGridPaintManager | protected
m_nResizingWidth | CXTPGridPaintManager | protected
m_nRowHeight | CXTPGridPaintManager | protected
m_nRowHeightDefault | CXTPGridPaintManager |
m_nTextIndentForGroupRowsWithNoIcon | CXTPGridPaintManager |
m_nTreeColumnLineLength | CXTPGridPaintManager |
m_nTreeIndent | CXTPGridPaintManager |
m_nTreeStructureStyle | CXTPGridPaintManager |
m_nTreeTextIndent | CXTPGridPaintManager |
m_nTreeTextIndentGroupRow | CXTPGridPaintManager |
m_nTreeTextIndentRowChildren | CXTPGridPaintManager |
m_nTreeTextIndentRowParent | CXTPGridPaintManager |
m_pControl | CXTPGridPaintManager | protected
m_pGlyphs | CXTPGridPaintManager | protected
m_pHyperlinkHoverStyle | CXTPGridPaintManager |
m_pHyperlinkStyle | CXTPGridPaintManager |
m_pMarkupUIElement_NoGroupBy | CXTPGridPaintManager | protected
m_PrintPageWidth | CXTPGridPaintManager |
m_rcPreviewIndent | CXTPGridPaintManager |
m_RecordNumberWidth | CXTPGridPaintManager |
m_strCollapse | CXTPGridPaintManager |
m_strDecreasing | CXTPGridPaintManager |
m_strExpand | CXTPGridPaintManager |
m_strIncreasing | CXTPGridPaintManager |
m_strMarkupUIElement_NoGroupBy | CXTPGridPaintManager | protected
m_strNoFieldsAvailable | CXTPGridPaintManager |
m_strNoGroupBy | CXTPGridPaintManager |
m_strNoItems | CXTPGridPaintManager |
m_strSortBy | CXTPGridPaintManager |
m_szGlyph | CXTPGridPaintManager | protected
m_themeButton | CXTPGridPaintManager | protected
m_themeCombo | CXTPGridPaintManager | protected
m_themeHeader | CXTPGridPaintManager | protected
m_themeSpin | CXTPGridPaintManager | protected
m_treeStructureStyle | CXTPGridPaintManager |
m_xtpBrushGroupGridLineStyle | CXTPGridPaintManager | protected
m_xtpBrushHorizontalGrid | CXTPGridPaintManager | protected
m_xtpBrushTreeStructure | CXTPGridPaintManager | protected
m_xtpBrushVeriticalGrid | CXTPGridPaintManager | protected
m_xtpFontBoldText | CXTPGridPaintManager |
m_xtpFontCaption | CXTPGridPaintManager |
m_xtpFontPreview | CXTPGridPaintManager |
m_xtpFontText | CXTPGridPaintManager |
OnDrawAction(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs) | CXTPGridPaintManager | virtual
RecalcTotalHightOfMergedRows(CXTPGridColumns *pColumns, CDC *pDC, CXTPGridRow *pRow, int nRowHeight, int nTotalWidth) | CXTPGridPaintManager |
RefreshMetrics() | CXTPTrackThemeNativeWindows10 | virtual
SetCaptionFont(LOGFONT &lf) | CXTPGridPaintManager |
SetColumnOffice2007CustomThemeBaseColor(COLORREF clrBaseColor) | CXTPGridPaintManager |
SetColumnPlusMinusSign(BOOL bDraw) | CXTPGridPaintManager |
SetColumnWidthWYSIWYG(BOOL bColumnWidthWYSIWYG) | CXTPGridPaintManager |
SetDrawGridForEmptySpace(BOOL bDrawGrid) | CXTPGridPaintManager |
SetFixedRowHeight(BOOL bFixedRowHeight) | CXTPGridPaintManager |
SetFreezeColsDividerStyle(int nStyle) | CXTPGridPaintManager |
SetGridControl(CXTPGridControl *pControl) | CXTPGridPaintManager | virtual
SetHeaderHeight(int nHeight) | CXTPGridPaintManager | virtual
SetInplaceButtonHeight(BOOL bFixedInplaceButtonHeight) | CXTPGridPaintManager |
SetLastColumnWidthWYSIWYG(BOOL bColumnWidthWYSIWYG) | CXTPGridPaintManager |
SetMaxPreviewLines(int nMaxLines) | CXTPGridPaintManager |
SetPreviewIndent(int nLeft, int nTop, int nRight, int nBottom) | CXTPGridPaintManager |
SetPrintGroupRowIcon(BOOL bDraw) | CXTPGridPaintManager |
SetTextFont(LOGFONT &lf) | CXTPGridPaintManager |
ShowWYSIWYGMarkers(BOOL bSet) | CXTPGridPaintManager |
~CXTPGridPaintManager() | CXTPGridPaintManager | virtual
~CXTPTrackPaintManager() | CXTPTrackPaintManager |


Toolkit Pro: Member List

CXTPCalendarEventRecurrenceDlg Member List

This is the complete list of members for CXTPCalendarEventRecurrenceDlg, including all inherited members.

CXTPCalendarEventRecurrenceDlg(CXTPCalendarEvent *pMasterEvent, CWnd *pParent=NULL, UINT nIDTemplate=CXTPCalendarEventRecurrenceDlg::IDD) | CXTPCalendarEventRecurrenceDlg |
InitDayOfWeekCBs(CComboBox &wndCB) | CXTPCalendarEventRecurrenceDlg | protectedvirtual
InitDurationCB() | CXTPCalendarEventRecurrenceDlg | protectedvirtual
InitMonthCBs(CComboBox &wndCB) | CXTPCalendarEventRecurrenceDlg | protectedvirtual
InitStartEndCB() | CXTPCalendarEventRecurrenceDlg | protectedvirtual
InitWhichDayCBs(CComboBox &wndCB) | CXTPCalendarEventRecurrenceDlg | protectedvirtual
m_bDisableRemove | CXTPCalendarEventRecurrenceDlg |
m_bFriday | CXTPCalendarEventRecurrenceDlg | protected
m_bMonday | CXTPCalendarEventRecurrenceDlg | protected
m_bSaturday | CXTPCalendarEventRecurrenceDlg | protected
m_bSunday | CXTPCalendarEventRecurrenceDlg | protected
m_bThursday | CXTPCalendarEventRecurrenceDlg | protected
m_bTuesday | CXTPCalendarEventRecurrenceDlg | protected
m_bWednesday | CXTPCalendarEventRecurrenceDlg | protected
m_dtEnd | CXTPCalendarEventRecurrenceDlg | protected
m_dtEndDate | CXTPCalendarEventRecurrenceDlg | protected
m_dtStart | CXTPCalendarEventRecurrenceDlg | protected
m_dtStartDate | CXTPCalendarEventRecurrenceDlg | protected
m_MonthDate | CXTPCalendarEventRecurrenceDlg | protected
m_nDayInterval | CXTPCalendarEventRecurrenceDlg | protected
m_nDayOfMonth | CXTPCalendarEventRecurrenceDlg | protected
m_nMonthInterval | CXTPCalendarEventRecurrenceDlg | protected
m_nMonthInterval2 | CXTPCalendarEventRecurrenceDlg | protected
m_nOccurNum | CXTPCalendarEventRecurrenceDlg | protected
m_nWeeklyInterval | CXTPCalendarEventRecurrenceDlg | protected
m_ptrMasterEvent | CXTPCalendarEventRecurrenceDlg | protected
m_ptrPattern | CXTPCalendarEventRecurrenceDlg | protected
m_wndCbDuration | CXTPCalendarEventRecurrenceDlg | protected
m_wndCbEnd | CXTPCalendarEventRecurrenceDlg | protected
m_wndCbMonthDay | CXTPCalendarEventRecurrenceDlg | protected
m_wndCbMonthWhich | CXTPCalendarEventRecurrenceDlg | protected
m_wndCbStart | CXTPCalendarEventRecurrenceDlg | protected
m_wndCbYearDay | CXTPCalendarEventRecurrenceDlg | protected
m_wndCbYearWhich | CXTPCalendarEventRecurrenceDlg | protected
m_wndComboYearMonth2 | CXTPCalendarEventRecurrenceDlg | protected
m_wndYearMonth | CXTPCalendarEventRecurrenceDlg | protected
MsgBox_WrongValue(CWnd *pWnd) | CXTPCalendarEventRecurrenceDlg | protectedvirtual
MsgBox_WrongValueRange(UINT nCtrlID, int nMin, int nMax) | CXTPCalendarEventRecurrenceDlg | protectedvirtual
nWorkWeekMask | CXTPCalendarEventRecurrenceDlg |
~CXTPCalendarEventRecurrenceDlg() | CXTPCalendarEventRecurrenceDlg | virtual


Toolkit Pro: Member List

CXTPCalendarViewT< _TViewDay > Member List

This is the complete list of members for CXTPCalendarViewT< _TViewDay >, including all inherited members.

_CalculateEventTimeFormat() | CXTPCalendarView | protectedvirtual
_CanSubjectEditor(UINT idEditCmd) const | CXTPCalendarView | protectedvirtual
_CopySelectedEvents(DWORD dwCopyFlags=0) | CXTPCalendarView | protectedvirtual
_GetDayHeaderFormat(int nLevel) const | CXTPCalendarView | protectedvirtual
_GetMaxWidth(CDC *pDC, CString strFormat) const | CXTPCalendarView | protectedvirtual
_GetMaxWidthFormat(CDC *pDC, CString strFormat, BOOL bMonth) const | CXTPCalendarView | protectedvirtual
_GetSubjectEditorWnd() const | CXTPCalendarView | protectedvirtual
_GetViewDay(const COleDateTime &dtDay) const | CXTPCalendarView | virtual
_IsDragModeCopyMove(int eDragMode) const | CXTPCalendarView | protected
_ReadDefaultHeaderFormats() | CXTPCalendarView | protectedvirtual
_ReadEventsFromClipboard(COleDataObject *pData, DWORD *pdwCopyFlags=NULL) | CXTPCalendarView | protectedvirtual
_RemoveYearPart(CString &strFormat) | CXTPCalendarView | protectedvirtual
_Undo(CXTPCalendarEvent *pEvent=NULL) | CXTPCalendarView | protectedvirtual
AddToDiscreteSelection(UINT id) | CXTPCalendarView |
AdjustLayout(CDC *pDC, const CRect &rcView, BOOL bCallPostAdjustLayout=TRUE) | CXTPCalendarView | virtual
AdjustLayout2(CDC *pDC, const CRect &rcView, BOOL bCallPostAdjustLayout=TRUE) | CXTPCalendarView | virtual
CalculateHeaderFormat(CDC *pDC, int nWidth, CFont *pTextFont) | CXTPCalendarView | virtual
CancelDraggingEvent() | CXTPCalendarView | virtual
CanCopy() const | CXTPCalendarView | virtual
CanCut() const | CXTPCalendarView | virtual
CanPaste() const | CXTPCalendarView | virtual
CanRedo() const | CXTPCalendarView | virtual
CanUndo() const | CXTPCalendarView | virtual
ClearDiscreteSelection() | CXTPCalendarView |
CommitDraggingEvent() | CXTPCalendarView | virtual
Copy() | CXTPCalendarView | virtual
Cut() | CXTPCalendarView | virtual
CXTPCalendarView(CXTPCalendarControl *pCalendarControl) | CXTPCalendarView |
CXTPCalendarViewT(CXTPCalendarControl *pCalendarControl, XTPCalendarViewType nViewType) | CXTPCalendarViewT< _TViewDay > | inline
CXTPCalendarWMHandler() | CXTPCalendarWMHandler |
CXTPCmdTarget() | CXTPCmdTarget |
Draw(CDC *pDC) | CXTPCalendarView | inlinevirtual
Draw2(CDC *pDC) | CXTPCalendarView | inlinevirtual
EmptyUndoBuffer() | CXTPCalendarView | virtual
EnableHScroll(BOOL bEnable=TRUE) | CXTPCalendarView | virtual
EnableVScroll(BOOL bEnable=TRUE) | CXTPCalendarView | virtual
EndEditSubject(XTPCalendarEndEditSubjectAction eAction, BOOL bUpdateControl=TRUE) | CXTPCalendarView | virtual
FindEventToEditByTAB(COleDateTime dtMinStart, BOOL bReverse, CXTPCalendarEvent *pAfterEvent=NULL) | CXTPCalendarView | virtual
FindLastSelectedDay() const | CXTPCalendarView |
FindViewEvent(CXTPCalendarEvent *pEvent, COleDateTime dtDay) const | CXTPCalendarView | virtual
FormatEventTime(COleDateTime dtTime) const | CXTPCalendarView | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCalendarControl() const | CXTPCalendarView |
GetCalendarOptions() const | CXTPCalendarView |
GetChildHandlerAt(int nIndex) const | CXTPCalendarView | virtual
GetChildHandlersCount() const | CXTPCalendarView | virtual
GetDayHeaderFormat() const | CXTPCalendarView | virtual
GetDiscreteSelectionCount() const | CXTPCalendarView |
GetDiscreteSelectionValue(UINT id) const | CXTPCalendarView |
GetDraggingEventNew() const | CXTPCalendarView | virtual
GetDraggingEventOrig() const | CXTPCalendarView | virtual
GetDraggingMode() const | CXTPCalendarView | virtual
GetEventDurationMin() const | CXTPCalendarView | protectedvirtual
GetItemTextEventTimeMax() const | CXTPCalendarView | virtual
GetLastSelectedDate() const | CXTPCalendarView |
GetLastSelectedViewEvent() const | CXTPCalendarView |
GetNextTimeEditByTAB() const | CXTPCalendarView | virtual
GetPaintManager() const | CXTPCalendarView | virtual
GetResources() const | CXTPCalendarView | virtual
GetRowHeight() const | CXTPCalendarView | virtual
GetScrollBarInfoH(SCROLLINFO *pSI, int *pnScrollStep=NULL) const | CXTPCalendarView | inlinevirtual
GetScrollBarInfoV(SCROLLINFO *pSI) const | CXTPCalendarView | inlinevirtual
GetSelectedEvents() const | CXTPCalendarView | virtual
GetSelectedViewEvents() const | CXTPCalendarView | virtual
GetSelection(COleDateTime *pBegin=NULL, COleDateTime *pEnd=NULL, BOOL *pbAllDayEvent=NULL, int *pnGroupIndex=NULL, COleDateTimeSpan *pspSelectionResolution=NULL) const | CXTPCalendarView | virtual
GetShowToolTipTimeOut() const | CXTPCalendarView | virtual
GetStartEditSubjectTimeOut() const | CXTPCalendarView | virtual
GetSubjectEditorRect() const | CXTPCalendarView | virtual
GetTheme() const | CXTPCalendarView | virtual
GetTooltipRect(const CPoint &ptHit, const XTP_CALENDAR_HITTESTINFO &hitInfo) const | CXTPCalendarView | virtual
GetViewDay(int nIndex) const | CXTPCalendarViewT< _TViewDay > | inlinevirtual
GetViewDay_(int nIndex) const | CXTPCalendarView | virtual
GetViewDayCount() const | CXTPCalendarView | virtual
GetViewDayDate(int nIndex) const =0 | CXTPCalendarView | pure virtual
GetViewRect() const | CXTPCalendarView |
GetViewType() const | CXTPCalendarViewT< _TViewDay > | inlinevirtual
HasSelectedViewEvent() const | CXTPCalendarView | virtual
HitTest(CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const | CXTPCalendarView | virtual
HitTestEx(CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const | CXTPCalendarView | virtual
IsEditingSubject() const | CXTPCalendarView | virtual
IsEditOperationDisabledNotify(XTPCalendarEditOperation eOperation, CXTPCalendarViewEvent *pEventView) const | CXTPCalendarView | protected
IsHScrollEnabled() const | CXTPCalendarView | virtual
IsInDiscreteSelection(UINT id) const | CXTPCalendarView |
IsSingleEventSelected() const | CXTPCalendarView |
IsTodayVisible() const | CXTPCalendarView | virtual
IsVScrollEnabled() const | CXTPCalendarView | virtual
KillTimer(UINT uTimerID) | CXTPCalendarView | protectedvirtual
m_arDays | CXTPCalendarView | mutableprotected
m_bResetUndoBuffer | CXTPCalendarView | protected
m_bScrollH_Disabled | CXTPCalendarView | protected
m_bScrollV_Disabled | CXTPCalendarView | protected
m_bStartedClickInside | CXTPCalendarView | protected
m_cntSelChanged | CXTPCalendarView | protected
m_eDraggingMode | CXTPCalendarView | protected
m_eUndoMode | CXTPCalendarView | protected
m_EventTimeFormat | CXTPCalendarView | protected
m_LastHitInfo | CXTPCalendarView | protected
m_Layout | CXTPCalendarView | protected
m_nKeyStateTimerID | CXTPCalendarView | protected
m_nTimerID_ShowToolTip | CXTPCalendarView | protected
m_nTimerID_StartEditSubject | CXTPCalendarView | protected
m_pControl | CXTPCalendarView | protected
m_pLastEvent | CXTPCalendarView | protected
m_pPrevUndoBuffer | CXTPCalendarView | protected
m_pResources | CXTPCalendarView | protected
m_pSelectedEvents | CXTPCalendarView | protected
m_ptrDraggingEventNew | CXTPCalendarView | protected
m_ptrDraggingEventOrig | CXTPCalendarView | protected
m_ptrEditingViewEvent | CXTPCalendarView | protected
m_ptStartDragging | CXTPCalendarView | protected
m_pUndoBuffer | CXTPCalendarView | protected
m_rcTooltip | CXTPCalendarView | protected
m_rcView | CXTPCalendarView | protected
m_selectedBlock | CXTPCalendarView | protected
m_spDraggingStartOffset | CXTPCalendarView | protected
m_strDayHeaderFormatDefaultLong | CXTPCalendarView | protected
m_strDayHeaderFormatDefaultMiddle | CXTPCalendarView | protected
m_strDayHeaderFormatDefaultShort | CXTPCalendarView | protected
m_strDayHeaderFormatDefaultShortest | CXTPCalendarView | protected
m_strDayHeaderFormatLong | CXTPCalendarView | protected
m_strDayHeaderFormatMiddle | CXTPCalendarView | protected
m_strDayHeaderFormatShort | CXTPCalendarView | protected
m_strDayHeaderFormatShortest | CXTPCalendarView | protected
m_strHeaderFormat | CXTPCalendarView | protected
OnActivateView(BOOL bActivate, CXTPCalendarView *pActivateView, CXTPCalendarView *pInactiveView) | CXTPCalendarView | protectedvirtual
OnBeforeDestroy() | CXTPCalendarView | protectedvirtual
OnBeforeEditOperationNotify(XTPCalendarEditOperation eOperation, CXTPCalendarViewEvent *pEventView) | CXTPCalendarView | protected
OnBeforeEditOperationNotify(XTPCalendarEditOperation eOperation, CXTPCalendarViewEvents *pEventViews) | CXTPCalendarView | protected
OnBeforePasteNotify(CXTPCalendarEvent *pEvent, BOOL bPasteWillChangeExistingEvent) | CXTPCalendarView | protected
OnChar(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarView | virtual
OnDragging(CPoint point, XTP_CALENDAR_HITTESTINFO *pHitTest) | CXTPCalendarView | virtual
OnDraw(CDC *pDC) | CXTPCalendarView | virtual
OnEndDragging(CPoint point, XTP_CALENDAR_HITTESTINFO *pHitInfo) | CXTPCalendarView | virtual
OnEventChanged_InDataProvider(XTP_NOTIFY_CODE nfCode, CXTPCalendarEvent *pEvent) | CXTPCalendarView | protectedvirtual
OnInPlaceCreateEvent(LPCTSTR pcszInitialSubject) | CXTPCalendarView | protected
OnKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarView | virtual
OnKeyUp(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnLButtonDblClk(UINT nFlags, CPoint point) | CXTPCalendarView | virtual
OnLButtonDown(UINT nFlags, CPoint point) | CXTPCalendarView | virtual
OnLButtonUp(UINT nFlags, CPoint point) | CXTPCalendarView | virtual
OnMouseMove(UINT nFlags, CPoint point) | CXTPCalendarView | virtual
OnPostAdjustLayout() | CXTPCalendarWMHandler | virtual
OnScrollEnd(int nBar) | CXTPCalendarView | inlinevirtual
OnStartDragging(CPoint point, XTP_CALENDAR_HITTESTINFO *pHitTest) | CXTPCalendarView | virtual
OnSysKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarView | virtual
OnTimer(UINT_PTR uTimerID) | CXTPCalendarView | protectedvirtual
OnUpdateEditingSubject(CString strNewSubject) | CXTPCalendarView | virtual
OnWndMsg(UINT message, WPARAM wParam, LPARAM lParam, LRESULT *pResult) | CXTPCalendarWMHandler | virtual
Paste() | CXTPCalendarView | virtual
Populate() | CXTPCalendarView | virtual
ProcessDaySelection(XTP_CALENDAR_HITTESTINFO *pInfo, UINT nFlags) | CXTPCalendarView | virtual
ProcessEventSelection(XTP_CALENDAR_HITTESTINFO *pInfo, UINT nFlags) | CXTPCalendarView | virtual
Redo() | CXTPCalendarView | virtual
RedrawControl() | CXTPCalendarView | virtual
ResetCustomTimeFormat() | CXTPCalendarView |
ResetSelection() | CXTPCalendarView |
RetrieveDayEvents(CXTPCalendarResource *pRC, COleDateTime dtDay) | CXTPCalendarView | virtual
ScrollH(int nPos, int nPos_raw) | CXTPCalendarView | inlinevirtual
ScrollV(int nPos, int nPos_raw) | CXTPCalendarView | inlinevirtual
SelectDay(CXTPCalendarViewDay *pDay, int nGroupIndex=0) | CXTPCalendarView | virtual
SelectDay(COleDateTime dtSelDay, int nGroupIndex=0) | CXTPCalendarView | virtual
SelectDays(COleDateTime dtNewSel) | CXTPCalendarView | virtual
SelectEvent(CXTPCalendarEvent *pEvent, BOOL bSelect=TRUE) | CXTPCalendarView | virtual
SelectionContains(COleDateTime date, int nGroupIndex=-1, BOOL *pbAllDaySelection=NULL) | CXTPCalendarView |
SelectViewEvent(CXTPCalendarViewEvent *pViewEvent, BOOL bSelect=TRUE) | CXTPCalendarView |
SendNotification(XTP_NOTIFY_CODE EventCode, WPARAM wParam=0, LPARAM lParam=0) | CXTPCalendarView | protectedvirtual
SetCustomTimeFormat(const CString &strFormat) | CXTPCalendarView |
SetDayHeaderFormat(LPCTSTR sFmt) | CXTPCalendarView | virtual
SetDayHeaderFormatLong(LPCTSTR pcszCustomFormat) | CXTPCalendarView | virtual
SetDayHeaderFormatMiddle(LPCTSTR pcszCustomFormat) | CXTPCalendarView | virtual
SetDayHeaderFormatShort(LPCTSTR pcszCustomFormat) | CXTPCalendarView | virtual
SetDayHeaderFormatShortest(LPCTSTR pcszCustomFormat) | CXTPCalendarView | virtual
SetDraggingEvent(CXTPCalendarEvent *pEventOrig) | CXTPCalendarView | virtual
SetResources(CXTPCalendarResources *pResources) | CXTPCalendarView | virtual
SetSelection(const COleDateTime &dtBegin, const COleDateTime &dtEnd, BOOL bAllDayEvent=FALSE, int nGroupIndex=0) | CXTPCalendarView |
SetTimer(UINT uTimeOut_ms) | CXTPCalendarView | protectedvirtual
ShowDay(const COleDateTime &date, BOOL bSelect=TRUE)=0 | CXTPCalendarView | pure virtual
ShowToolTip(BOOL bShow=TRUE) | CXTPCalendarView | virtual
StartEditNewEventInplace(LPCTSTR pcszInitialSubject) | CXTPCalendarView | virtual
StartEditSubject(CXTPCalendarViewEvent *pViewEvent) | CXTPCalendarView | virtual
Undo() | CXTPCalendarView | virtual
UnselectAllEvents() | CXTPCalendarView | virtual
UpdateNextTimeEditByTAB(COleDateTime dtNext, BOOL bReverse, BOOL bReset=FALSE) | CXTPCalendarView | virtual
~CXTPCalendarView() | CXTPCalendarView | virtual
~CXTPCalendarViewT() | CXTPCalendarViewT< _TViewDay > | inlinevirtual


Toolkit Pro: Member List

  • CXTPTabPaintManagerColorSet
  • COLORSET_TAB_PROPERTYPAGE2003
CXTPTabPaintManagerColorSet::COLORSET_TAB_PROPERTYPAGE2003 Member List

This is the complete list of members for CXTPTabPaintManagerColorSet::COLORSET_TAB_PROPERTYPAGE2003, including all inherited members.

clrBorderLeftHighlight | CXTPTabPaintManagerColorSet::COLORSET_TAB_PROPERTYPAGE2003
clrBorderTopHighlight | CXTPTabPaintManagerColorSet::COLORSET_TAB_PROPERTYPAGE2003
clrDarkShadow | CXTPTabPaintManagerColorSet::COLORSET_TAB_PROPERTYPAGE2003
clrFrameBorder | CXTPTabPaintManagerColorSet::COLORSET_TAB_PROPERTYPAGE2003


Toolkit Pro: XTPControlTheme.h Source File

  • Source
  • Controls
  • Util
XTPControlTheme.h
Go to the documentation of this file.
1
23#if !defined(__XTPCONTROLSTHEME_H__)
24# define __XTPCONTROLSTHEME_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPResourceImages;
34
42enum XTPControlTheme
43{
44 xtpControlThemeDefault,
45 xtpControlThemeFlat,
46 xtpControlThemeUltraFlat,
47 xtpControlThemeOffice2000,
48 xtpControlThemeOfficeXP,
49 xtpControlThemeOffice2003,
50 xtpControlThemeNativeWinXP,
51 xtpControlThemeResource,
52 xtpControlThemeVisualStudio2005,
53 xtpControlThemeVisualStudio2008,
54 xtpControlThemeVisualStudio2010,
55 xtpControlThemeCustom,
56 xtpControlThemeOffice2013,
57 xtpControlThemeOffice2016 = xtpControlThemeOffice2013,
58 xtpControlThemeVisualStudio2012,
59 xtpControlThemeVisualStudio2012Light,
60 xtpControlThemeVisualStudio2012Dark,
61 xtpControlThemeVisualStudio2015,
62 xtpControlThemeNativeWindows10,
63 xtpControlThemeVisualStudio2017,
64 xtpControlThemeVisualStudio2019,
65 xtpControlThemeVisualStudio2022,
66 xtpControlThemeNativeWindows11,
67};
68
77enum XTPControlDrawState
78{
79 xtpControlDrawStateNormal = 0x0000,
80 xtpControlDrawStateDisabled = 0x0001,
81 xtpControlDrawStateHotLight = 0x0002,
82 xtpControlDrawStateHotButton = 0x0004,
84 xtpControlDrawStateSelected = 0x0008,
85 xtpControlDrawStatePushed = 0x0010,
87 xtpControlDrawStateFocus = 0x0020,
88};
89
94class _XTP_EXT_CLASS CXTPControlTheme : public CXTPCmdTarget
95{
96public:
101 CXTPControlTheme();
102
109 XTPControlTheme GetThemeStyle() const;
110
135 static void AFX_CDECL SetTheme(HWND hWnd, XTPControlTheme nTheme);
136
137protected:
138 XTPControlTheme m_nTheme;
139};
140
142
143//{{AFX_INSERT_LOCATION}}
144// Microsoft Visual C++ will insert additional declarations immediately before the previous line.
145
146# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
148#endif // !defined(__XTPCONTROLSTHEME_H__)
XTPControlTheme
XTPControlTheme
Enumeration used to determine the active theme style.
Definition XTPControlTheme.h:43
xtpControlThemeVisualStudio2012Dark
@ xtpControlThemeVisualStudio2012Dark
VS 2012 Dark style theme.
Definition XTPControlTheme.h:60
xtpControlThemeResource
@ xtpControlThemeResource
Office 2007/Office 2010/Windows7 external resource .DLL.
Definition XTPControlTheme.h:51
xtpControlThemeOffice2000
@ xtpControlThemeOffice2000
Office 2000 style theme.
Definition XTPControlTheme.h:47
xtpControlThemeVisualStudio2015
@ xtpControlThemeVisualStudio2015
VS 2015 style theme.
Definition XTPControlTheme.h:61
xtpControlThemeOffice2016
@ xtpControlThemeOffice2016
Office 2016 control theme.
Definition XTPControlTheme.h:57
xtpControlThemeVisualStudio2022
@ xtpControlThemeVisualStudio2022
VS 2022 style theme.
Definition XTPControlTheme.h:65
xtpControlThemeVisualStudio2010
@ xtpControlThemeVisualStudio2010
Visual Studio 2010 style theme.
Definition XTPControlTheme.h:54
xtpControlThemeOffice2003
@ xtpControlThemeOffice2003
Office 2003 style theme.
Definition XTPControlTheme.h:49
xtpControlThemeVisualStudio2012Light
@ xtpControlThemeVisualStudio2012Light
VS 2012 Light style theme.
Definition XTPControlTheme.h:59
xtpControlThemeFlat
@ xtpControlThemeFlat
Flat appearance style.
Definition XTPControlTheme.h:45
xtpControlThemeOfficeXP
@ xtpControlThemeOfficeXP
Office XP style theme.
Definition XTPControlTheme.h:48
xtpControlThemeCustom
@ xtpControlThemeCustom
User defined custom theme.
Definition XTPControlTheme.h:55
xtpControlThemeVisualStudio2019
@ xtpControlThemeVisualStudio2019
VS 2019 style theme.
Definition XTPControlTheme.h:64
xtpControlThemeVisualStudio2008
@ xtpControlThemeVisualStudio2008
Visual Studio 2008 style theme.
Definition XTPControlTheme.h:53
xtpControlThemeNativeWindows10
@ xtpControlThemeNativeWindows10
Native Windows 10 theme support.
Definition XTPControlTheme.h:62
xtpControlThemeNativeWindows11
@ xtpControlThemeNativeWindows11
Native Windows 11 theme support.
Definition XTPControlTheme.h:66
xtpControlThemeDefault
@ xtpControlThemeDefault
Default Windows classic theme.
Definition XTPControlTheme.h:44
xtpControlThemeOffice2013
@ xtpControlThemeOffice2013
Office 2013 control theme.
Definition XTPControlTheme.h:56
xtpControlThemeUltraFlat
@ xtpControlThemeUltraFlat
Ultra flat appearance style.
Definition XTPControlTheme.h:46
xtpControlThemeVisualStudio2012
@ xtpControlThemeVisualStudio2012
VS 2012 style theme.
Definition XTPControlTheme.h:58
xtpControlThemeNativeWinXP
@ xtpControlThemeNativeWinXP
Windows XP and later native theme support.
Definition XTPControlTheme.h:50
xtpControlThemeVisualStudio2005
@ xtpControlThemeVisualStudio2005
Visual Studio 2005 style theme.
Definition XTPControlTheme.h:52
xtpControlThemeVisualStudio2017
@ xtpControlThemeVisualStudio2017
VS 2017 style theme.
Definition XTPControlTheme.h:63
XTPControlDrawState
XTPControlDrawState
Enumeration used to determine the display state for a themed window.
Definition XTPControlTheme.h:78
xtpControlDrawStatePushed
@ xtpControlDrawStatePushed
The window has an item selected and the left mouse button is pressed.
Definition XTPControlTheme.h:85
xtpControlDrawStateHotLight
@ xtpControlDrawStateHotLight
The window has the mouse cursor hovering.
Definition XTPControlTheme.h:81
xtpControlDrawStateNormal
@ xtpControlDrawStateNormal
The window should be drawn normal.
Definition XTPControlTheme.h:79
xtpControlDrawStateSelected
@ xtpControlDrawStateSelected
The window has an item selected.
Definition XTPControlTheme.h:84
xtpControlDrawStateHotButton
@ xtpControlDrawStateHotButton
The window has the mouse cursor hovering over a drop button.
Definition XTPControlTheme.h:82
xtpControlDrawStateFocus
@ xtpControlDrawStateFocus
The window has keyboard focus.
Definition XTPControlTheme.h:87
xtpControlDrawStateDisabled
@ xtpControlDrawStateDisabled
The window should be drawn disabled.
Definition XTPControlTheme.h:80
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPControlTheme
CXTPControlTheme can be used as a base class for user defined themes.
Definition XTPControlTheme.h:95
CXTPControlTheme::GetThemeStyle
XTPControlTheme GetThemeStyle() const
Call this member function to get the style for the theme.
CXTPControlTheme::SetTheme
static void AFX_CDECL SetTheme(HWND hWnd, XTPControlTheme nTheme)
Static member posts the specified message to all immediate children of the specified HWND object.
CXTPControlTheme::CXTPControlTheme
CXTPControlTheme()
Constructs a new CXTPControlTheme object and handles initialization.
CXTPControlTheme::m_nTheme
XTPControlTheme m_nTheme
Currently selected theme style index.
Definition XTPControlTheme.h:138
CXTPResourceImages
Implements resource image collection and its operations.
Definition XTPResourceImage.h:257


Toolkit Pro: XTPCalendarControl.h Source File

  • Source
  • Calendar
XTPCalendarControl.h
Go to the documentation of this file.
1
22#if !defined(_XTPCALENDARCONTROL_H__)
23# define _XTPCALENDARCONTROL_H__
24
25# if _MSC_VER > 1000
26# pragma once
27# endif // _MSC_VER > 1000
28
29# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
30
31class CXTPCalendarView;
32class CXTPCalendarPaintManager;
33class CXTPCalendarData;
34class CXTPCalendarDayView;
35class CXTPCalendarWeekView;
36class CXTPCalendarMonthView;
37class CXTPCalendarTimeLineView;
38class CXTPCalendarOptions;
39class CXTPNotifyConnection;
40class CXTPNotifySink;
41class CXTPCalendarRemindersManager;
42class CXTPCalendarResources;
43class CXTPCalendarResourcesNf;
44class CXTPCalendarTheme;
45
46class CXTPMarkupContext;
47class CXTPMarkupUIElement;
48class CXTPCalendarTip;
49
50typedef DWORD_PTR XTP_CONNECTION_ID;
51
125class _XTP_EXT_CLASS CXTPCalendarControl : public CWnd
126{
127 friend class CXTPCalendarView;
128 friend class CXTPCalendarViewDay;
129 friend class CXTPCalendarViewGroup;
130 friend class CXTPCalendarViewEvent;
131 friend class CCalendarControlCtrl;
132 friend class CXTPCalendarControlView;
133 friend class CXTPCalendarResource;
134 friend class CXTPCalendarThemePart;
135
136public:
164 CXTPCalendarControl();
165
171 virtual ~CXTPCalendarControl();
172
184 virtual BOOL Create(DWORD dwStyle, const RECT& rect, CWnd* pParentWnd, UINT nID);
185
195 virtual void Populate();
196
197 // Operations
198public:
205 virtual XTPCalendarTheme GetPaintTheme() const;
206
213 virtual void SetPaintTheme(XTPCalendarTheme ePaintTheme);
214
222 virtual void SetPaintTheme(CXTPCalendarPaintManager* pPaintManager, CXTPCalendarTheme* pTheme);
223
231 XTPCalendarThemeVersion GetThemeVersion() const;
232
234 // drawing related
235
247 CXTPCalendarPaintManager* GetPaintManager() const;
248
270 CXTPCalendarTheme* GetTheme() const;
271
294 void SetTheme(CXTPCalendarTheme* pTheme);
295
297 // resources related
298
311 CXTPCalendarResources* GetResources() const;
312
326 void SetResources(CXTPCalendarResources* pResources,
327 CXTPCalendarData* pOptionsDataProvider = NULL);
328
330 // data provider related
331
347 void SetDataProvider(LPCTSTR lpszConnectionString);
366 void SetDataProvider(CXTPCalendarData* pDataProvider,
367 BOOL bCloseDataProviderWhenDestroy = TRUE);
384 void SetDataProvider(XTPCalendarDataProvider eDataProvider,
385 LPCTSTR lpszConnectionString = NULL);
386
394 CXTPCalendarData* GetDataProvider() const;
395
397 // view related
398
415 virtual CXTPCalendarView* GetActiveView() const;
416
432 CXTPCalendarDayView* GetDayView() const;
433
449 CXTPCalendarWeekView* GetWeekView() const;
450
466 CXTPCalendarMonthView* GetMonthView() const;
467
484 CXTPCalendarTimeLineView* GetTimeLineView() const;
485
500 virtual void SwitchActiveView(XTPCalendarViewType eView);
501
502 // Implementation
503public:
505 // drawing related
506
513 void SetLayoutRTL(BOOL bRightToLeft);
514
521 BOOL IsLayoutRTL() const;
522
534 int GetTimeLineScale() const;
535
553 virtual void RedrawControl(BOOL bForce = FALSE);
554
564 virtual void AdjustLayout();
565
578 virtual void AdjustLayout(CDC* pDC, const CRect& rcView);
579
594 virtual void AdjustScrollBar(int nSBType = -1);
595
600 void OnCalendarTimeline();
601
602private:
603 // Always updates the screen on exit block
604 void BeginUpdate();
605 void EndUpdate();
606
607 // Update the screen on exit block only when something has changed
608 void LockUpdate();
609 void UnlockUpdate();
610
611 // Adjusts layout on exit block
612 void BeginAdjust(BOOL bWithScrollBar = FALSE);
613 void EndAdjust(BOOL bWithScrollBar = FALSE);
614
615public:
617 // managing calendar settings
618
628 int GetWorkWeekMask() const;
629
639 void SetWorkWeekMask(const int nMask);
640
651 int GetFirstDayOfWeek() const;
652
659 int GetFirstWeekOfYearDays() const;
660
672 void SetFirstDayOfWeek(const int nFirstDayOfWeek);
673
680 void SetFirstWeekOfYearDays(const int nFirstWeekOfYearDays);
681
692 void GetWorkDayStartTime(COleDateTime& dtTime) const;
693
706 void GetWorkDayStartTime(int& nHour, int& nMin, int& nSec) const;
707
718 void GetWorkDayEndTime(COleDateTime& dtTime) const;
719
732 void GetWorkDayEndTime(int& nHour, int& nMin, int& nSec) const;
733
740 void SetLongDayHeaderFormat(LPCTSTR pcszCustomFormat);
741
748 void SetSmallDayHeaderFormat(LPCTSTR pcszCustomFormat);
749
760 void SetWorkDayStartTime(const COleDateTime& dtTime);
761
774 void SetWorkDayStartTime(int nHour, int nMin, int nSec);
775
786 void SetWorkDayEndTime(const COleDateTime& dtTime);
787
800 void SetWorkDayEndTime(int nHour, int nMin, int nSec);
801
813 void AddCustomTimeIntervalForReminder(int nMin, LPCTSTR szCustomMeaning = NULL,
814 BOOL bIgnoreDefaultValues = FALSE);
815
824 BOOL DayView_IsAutoResetBusyFlag() const;
825
836 void DayView_SetAutoResetBusyFlag(BOOL bAutoResetBusyFlag = TRUE);
837
847 BOOL MonthView_IsCompressWeekendDays() const;
848
859 void MonthView_SetCompressWeekendDays(BOOL bCompress = TRUE);
860
870 BOOL MonthView_IsShowEndDate() const;
871
882 void MonthView_SetShowEndDate(BOOL bShowEnd = TRUE);
883
893 BOOL MonthView_IsShowTimeAsClocks() const;
894
905 void MonthView_SetShowTimeAsClocks(BOOL bShowClocks = TRUE);
906
916 BOOL WeekView_IsShowEndDate() const;
917
928 void WeekView_SetShowEndDate(BOOL bShowEnd);
929
939 BOOL WeekView_IsShowTimeAsClocks() const;
940
951 void WeekView_SetShowTimeAsClocks(BOOL bShowClocks);
952
966 void SetPaintManager(CXTPCalendarPaintManager* pPaintManager);
967
976 virtual BOOL UpdateMouseCursor();
977
978 //---- Time Management functions ----------------------------------------
979
990 virtual BOOL IsToday(const COleDateTime& dtDate) const;
991
1000 COleDateTime GetTodayDate() const;
1001
1010 void SetTodayDateOverride(const COleDateTime& dtTodayOverride);
1011
1020 COleDateTime GetTodayDateOverride() const;
1021
1028 void ResetTodayDateOverride();
1029
1030public:
1031 // for compatibility with previous versions
1032 // use xtp_wm_UserAction for the feature
1033 //
1050 virtual void QueueDayViewSwitch(DATE dtDate);
1051
1060 virtual BOOL RegisterWindowClass(HINSTANCE hInstance = NULL);
1061
1062protected:
1072 virtual void OnDraw(CDC* pDC);
1073
1088 virtual void SetActiveView(CXTPCalendarView* pView);
1089
1098 virtual UINT SetTimer(UINT uTimeOut_ms);
1099
1105 virtual void OnBeforeDestroy();
1106
1121 virtual void AdjustScrollBarEx(int nSBType);
1122
1138 virtual void _SetDataProvider(CXTPCalendarData* pDataProvider,
1139 BOOL bCloseDataProviderWhenDestroy = TRUE);
1140
1141public:
1155 CXTPNotifyConnection* GetConnection() const;
1156
1178 virtual void SendNotification(XTP_NOTIFY_CODE EventCode, WPARAM wParam, LPARAM lParam);
1179
1201 virtual void SendNotificationAlways(XTP_NOTIFY_CODE EventCode, WPARAM wParam, LPARAM lParam);
1202
1213 virtual void EnableSendNotifications(BOOL bEnable = TRUE);
1214
1227 virtual CXTPCalendarRemindersManager* GetRemindersManager() const;
1228
1229public:
1242 virtual void OnEditCommand(UINT uCommandID);
1243
1253 afx_msg virtual void OnUndo();
1254
1264 afx_msg virtual void OnCut();
1265
1275 afx_msg virtual void OnCopy();
1276
1286 afx_msg virtual void OnPaste();
1287
1300 afx_msg virtual void OnUpdateCmdUI(CCmdUI* pCmdUI);
1301
1314 afx_msg virtual void OnUpdateUndo(CCmdUI* pCmdUI);
1315
1328 afx_msg virtual void OnUpdateCut(CCmdUI* pCmdUI);
1329
1342 afx_msg virtual void OnUpdateCopy(CCmdUI* pCmdUI);
1343
1356 afx_msg virtual void OnUpdatePaste(CCmdUI* pCmdUI);
1357
1370 afx_msg virtual BOOL OnWndMsg(UINT message, WPARAM wParam, LPARAM lParam, LRESULT* pResult);
1371
1395 virtual BOOL OnWndMsg_Children(UINT message, WPARAM wParam, LPARAM lParam, LRESULT* pResult);
1396
1409 virtual BOOL DoDeleteEvent(CXTPCalendarViewEvent* pViewEvent);
1410
1422 virtual BOOL DoDeleteSelectedEvents(CXTPCalendarViewEvent* pViewEvent);
1423
1442 CXTPCalendarOptions* GetCalendarOptions() const;
1443
1454 BOOL SelectEventById(DWORD dEventID, BOOL bSelect = TRUE);
1455
1468 BOOL SelectViewEventByIdAndGroup(int nScheduleID, DWORD dEventID, BOOL bSelect = TRUE);
1469
1480 virtual void SetBorders(int nLeft, int nTop, int nRight, int nBottom);
1481
1487 virtual void UpdateBorders();
1488
1489protected:
1490 CRect m_Borders;
1492 DECLARE_MESSAGE_MAP()
1493
1494 //## Generated message map functions
1495 //{{AFX_MSG(CXTPCalendarControl)
1496 afx_msg void OnNcPaint();
1497 afx_msg void OnNcCalcSize(BOOL bCalcValidRects, NCCALCSIZE_PARAMS* lpncsp);
1498 afx_msg void OnPaint();
1499 afx_msg LRESULT OnPrintClient(WPARAM wParam, LPARAM /*lParam*/);
1500 afx_msg BOOL OnEraseBkgnd(CDC* pDC);
1501 afx_msg void OnSize(UINT nType, int cx, int cy);
1502 afx_msg void OnLButtonDown(UINT nFlags, CPoint point);
1503 afx_msg void OnLButtonDblClk(UINT nFlags, CPoint point);
1504 afx_msg void OnLButtonUp(UINT nFlags, CPoint point);
1505 afx_msg void OnContextMenu(CWnd* pWnd, CPoint pos);
1506 afx_msg void OnMouseMove(UINT nFlags, CPoint point);
1507 afx_msg BOOL OnMouseWheel(UINT nFlags, short zDelta, CPoint pt);
1508 afx_msg void OnMouseLeave();
1509 afx_msg void OnChar(UINT nChar, UINT nRepCnt, UINT nFlags);
1510 afx_msg void OnKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags);
1511 afx_msg void OnSysKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags);
1512 afx_msg void OnCaptureChanged(CWnd* pWnd);
1513 afx_msg void OnVScroll(UINT nSBCode, UINT nPos, CScrollBar* pScrollBar);
1514 afx_msg void OnHScroll(UINT nSBCode, UINT nPos, CScrollBar* pScrollBar);
1515 afx_msg BOOL OnSetCursor(CWnd* pWnd, UINT nHitTest, UINT message);
1516 afx_msg void OnTimer(UINT_PTR uTimerID);
1517 afx_msg void OnDestroy();
1518 afx_msg UINT OnGetDlgCode();
1519
1520 afx_msg void OnSysColorChange();
1521 afx_msg void OnTimeChange();
1522 afx_msg LRESULT OnTimeZoneChanged(WPARAM wParam, LPARAM lParam);
1523
1524 afx_msg LRESULT OnSwitchView(WPARAM nDate, LPARAM); // for compatibility with previous versions
1525 afx_msg LRESULT OnUserAction(WPARAM dwParam1, LPARAM dwParam2);
1526 afx_msg void OnSetFocus(CWnd* pOldWnd);
1527 afx_msg void OnKillFocus(CWnd* pNewWnd);
1528 afx_msg void OnRButtonDown(UINT nFlags, CPoint point);
1529 afx_msg void OnRButtonUp(UINT nFlags, CPoint point);
1530 afx_msg void OnEnable(BOOL bEnable);
1531
1532 //}}AFX_MSG
1533
1534 CXTPNotifySink* m_pSink;
1535
1536 virtual void OnEvent_FromDataProvider(XTP_NOTIFY_CODE Event, WPARAM wParam, LPARAM lParam);
1537 virtual void OnEvent_Reminders(XTP_NOTIFY_CODE Event, WPARAM wParam, LPARAM lParam);
1538
1539 virtual void OnFinalRelease();
1540 virtual CScrollBar* GetScrollBarCtrl(int nBar) const;
1541 virtual void PreSubclassWindow();
1542
1543 virtual void _InitCalendarView();
1544
1569 virtual void OnOptionsChanged(int nOptionRelation);
1570
1571protected:
1572 virtual void AdviseToDataProvider();
1573 virtual void _AdviseToReminders_StartMonitoring();
1574
1575public:
1585 virtual void ShowToolTip(const CString& strText, const CRect rcToolTip, CFont* pFont,
1586 BOOL bAdvanced = FALSE);
1587
1594 virtual void HideToolTip();
1595
1604 virtual BOOL IsToolTipVisible() const;
1605
1615 BOOL IsToolTipsEnabled() const;
1616
1627 void EnableToolTips(BOOL bEnable = TRUE);
1628
1638 BOOL IsRemindersEnabled() const;
1639
1650 void EnableReminders(BOOL bEnable = TRUE);
1651
1669 virtual DWORD GetAskItemTextFlags() const;
1670
1683 BOOL IsMarkupEnabled() const;
1684
1697 void EnableMarkup(BOOL bEnableMarkup = TRUE);
1698
1705 CXTPMarkupContext* GetMarkupContext() const;
1706
1711 void RefreshCaptionBar();
1712
1713private:
1714 BOOL Create(LPCTSTR lpszClassName, LPCTSTR lpszWindowName, DWORD dwStyle, const RECT& rect,
1715 CWnd* pParentWnd, UINT nID, CCreateContext* pContext = NULL);
1716
1717public:
1728 class _XTP_EXT_CLASS CUpdateContext
1729 {
1730 public:
1746 CUpdateContext(CXTPCalendarControl* pControl,
1747 int nOptions = xtpCalendarUpdateLayout | xtpCalendarUpdateRedraw)
1748 : m_pControl(pControl)
1749 {
1755 _ASSERTE(!((nOptions & xtpCalendarUpdateRedraw)
1756 && (nOptions & xtpCalendarUpdateRedrawIfNeed)));
1757
1758 m_nOptions = nOptions;
1759
1760 if (!m_pControl)
1761 {
1762 _ASSERTE(FALSE);
1763 return;
1764 }
1765
1766 if (m_nOptions & (xtpCalendarUpdateLayout | xtpCalendarUpdateScrollBar))
1767 m_pControl->BeginAdjust(nOptions & xtpCalendarUpdateScrollBar);
1768
1769 if (m_nOptions & xtpCalendarUpdateRedraw)
1770 m_pControl->BeginUpdate();
1771
1772 if (m_nOptions & xtpCalendarUpdateRedrawIfNeed)
1773 m_pControl->LockUpdate();
1774 }
1775
1783 ~CUpdateContext()
1784 {
1785 if (!m_pControl)
1786 {
1787 return;
1788 }
1789
1790 if (m_nOptions & (xtpCalendarUpdateLayout | xtpCalendarUpdateScrollBar))
1791 m_pControl->EndAdjust(m_nOptions & xtpCalendarUpdateScrollBar);
1792
1793 if (m_nOptions & xtpCalendarUpdateRedraw)
1794 m_pControl->EndUpdate();
1795
1796 if (m_nOptions & xtpCalendarUpdateRedrawIfNeed)
1797 m_pControl->UnlockUpdate();
1798 }
1799
1800 private:
1801 CXTPCalendarControl* m_pControl;
1802 int m_nOptions;
1803 };
1804
1810 class _XTP_EXT_CLASS CViewChangedContext
1811 {
1812 public:
1822 CViewChangedContext(CXTPCalendarView* pView, int eType = xtpCalendarViewChangedSend);
1823
1833 CViewChangedContext(CXTPCalendarControl* pControl, int eType = xtpCalendarViewChangedSend);
1834
1840 virtual ~CViewChangedContext();
1841
1842 private:
1843 void Init(CXTPCalendarControl* pControl, int eType);
1844
1845 CXTPCalendarControl* m_pControl;
1846 int m_eType;
1847 };
1848
1849 friend class CUpdateContext;
1850 friend class CViewChangedContext;
1851
1852protected:
1858 class CViewChanged_ContextData
1859 {
1860 public:
1865 CViewChanged_ContextData();
1866
1867 int m_nLockCount;
1868 BOOL m_bRequest;
1869 };
1870
1871 CViewChanged_ContextData m_cntViewChanged;
1873 int m_nRowsPerWheel;
1875 CString m_strUndoUIText;
1876 CString m_strRedoUIText;
1877 BOOL m_bUpdateWhenEventChangedNotify;
1879 CXTPCalendarRemindersManager* m_pRemindersManager;
1880 CXTPMarkupContext* m_pMarkupContext;
1882private:
1883 BOOL m_bChanged;
1884
1885 int m_nLockUpdateCount;
1886
1887 int m_nLockAdjustCount;
1888 BOOL m_bAdjustScrollBar;
1889
1890 CXTPCalendarView* m_pActiveView;
1891
1892 CXTPCalendarDayView* m_pDayView;
1893 CXTPCalendarMonthView* m_pMonthView;
1894 CXTPCalendarWeekView* m_pWeekView;
1895 CXTPCalendarTimeLineView* m_pTimeLineView;
1896
1897 CXTPCalendarResourcesNf* m_pResourcesNf;
1899 CXTPCalendarTheme* m_pTheme;
1900 CXTPCalendarPaintManager* m_pPaintManager;
1901 CXTPNotifyConnection* m_pConnection;
1902
1903 CXTPCalendarOptions* m_pOptions;
1905 CBitmap m_bmpCache;
1907 CXTPCalendarTip* m_pWndTip;
1908
1909 UINT m_uNextTimerID;
1910
1911 BOOL m_bEnableToolTips;
1912 BOOL m_bEnableSendNotifications;
1913 UINT m_uPopulateRequest_TimerID;
1914 UINT m_uRedrawRequest_TimerID;
1915
1916 XTP_CONNECTION_ID m_cnidOnReminders;
1917 COleDateTimeSpan m_spRemindersUpdatePeriod;
1918
1919 LCID m_lcidActiveLocale;
1920 int m_nFirstWeekOfYearDays;
1922 COleDateTime m_dtTodayOverride;
1923
1924public:
1931 BOOL IsReadonlyMode() const;
1932
1933 XTPCalendarMouseMode m_mouseMode;
1934 BOOL m_bDeleteOnFinalRelease;
1935 BOOL m_bDisableRedraw;
1937 BOOL m_bTimelineMode;
1938 XTPCalendarViewType m_eViewType;
1939 int m_nTimelineScale;
1940 int m_nCaptionHeight;
1941 BOOL m_bPreventAutoAllDayMode;
1942 BOOL m_bMultiColorScheduleMode;
1943 BOOL m_bMultiColumnWeekMode;
1944 BOOL m_bHideCaptionBar;
1945 BOOL m_bReadOnlyMode;
1946 BOOL m_bFullDateMode;
1948 BOOL m_bTooltipUnderMouse;
1951 BOOL m_bShowLinks;
1952 BOOL m_bHideLinkContainer;
1953 BOOL m_bPromptToDeleteRecurrentEvent;
1955 BOOL m_bDeleteOcurrenceEventIfNoPrompt;
1958 CString m_OwnerUser;
1959 CString m_sCustomFormat4Tooltip;
1963 CString m_sCustomTitle;
1964 BOOL m_bForcePagination;
1965 BOOL m_bShowTooltipForNotFocused;
1966 BOOL m_bShowTooltipForAllDayEvents;
1967 BOOL m_bSwitchToDayViewIfPickedSingleDay;
1970 BOOL m_bMultipleSchedulesMode;
1972 BOOL m_bMultipleSchedulesNoSelfLinks;
1976 CMap<int, int, CString, CString&> m_mapCustomReminderValues;
1977 BOOL m_bIgnoreDefaultReminderValues;
1978
1992 static CXTPCalendarData* AFX_CDECL CreateDataProvider(LPCTSTR lpszConnectionString);
1993
2008 static CXTPCalendarData* AFX_CDECL CreateDataProvider(XTPCalendarDataProvider eDataProvider);
2009
2028 static XTPCalendarDataProvider AFX_CDECL DataProviderTypeFromConStr(
2029 LPCTSTR lpszConnectionString,
2030 XTPCalendarDataProvider eDPDefault = xtpCalendarDataProviderUnknown);
2031
2048 static CString AFX_CDECL DataSourceFromConStr(LPCTSTR lpszConnectionString);
2049};
2050
2052
2053AFX_INLINE BOOL CXTPCalendarControl::Create(LPCTSTR lpszClassName, LPCTSTR lpszWindowName,
2054 DWORD dwStyle, const RECT& rect, CWnd* pParentWnd,
2055 UINT nID, CCreateContext* pContext)
2056{
2057 return CWnd::Create(lpszClassName, lpszWindowName, dwStyle, rect, pParentWnd, nID, pContext);
2058}
2059AFX_INLINE CXTPCalendarPaintManager* CXTPCalendarControl::GetPaintManager() const
2060{
2061 _ASSERTE(this);
2062 return this ? m_pPaintManager : NULL;
2063}
2064AFX_INLINE CXTPCalendarTheme* CXTPCalendarControl::GetTheme() const
2065{
2066 _ASSERTE(this);
2067 return this ? m_pTheme : NULL;
2068}
2069AFX_INLINE CXTPNotifyConnection* CXTPCalendarControl::GetConnection() const
2070{
2071 _ASSERTE(this);
2072 return this ? m_pConnection : NULL;
2073}
2074AFX_INLINE CXTPCalendarRemindersManager* CXTPCalendarControl::GetRemindersManager() const
2075{
2076 _ASSERTE(this);
2077 return this ? m_pRemindersManager : NULL;
2078}
2079AFX_INLINE BOOL CXTPCalendarControl::IsToolTipsEnabled() const
2080{
2081 return m_bEnableToolTips;
2082}
2083AFX_INLINE void CXTPCalendarControl::EnableToolTips(BOOL bEnable)
2084{
2085 if (!bEnable && IsToolTipVisible())
2086 {
2087 HideToolTip();
2088 }
2089 m_bEnableToolTips = bEnable;
2090}
2091AFX_INLINE void CXTPCalendarControl::EnableSendNotifications(BOOL bEnable)
2092{
2093 m_bEnableSendNotifications = bEnable;
2094}
2095AFX_INLINE BOOL CXTPCalendarControl::IsMarkupEnabled() const
2096{
2097 return m_pMarkupContext != NULL;
2098}
2099AFX_INLINE CXTPMarkupContext* CXTPCalendarControl::GetMarkupContext() const
2100{
2101 return m_pMarkupContext;
2102}
2103AFX_INLINE CXTPCalendarView* CXTPCalendarControl::GetActiveView() const
2104{
2105 return m_pActiveView;
2106}
2107AFX_INLINE CXTPCalendarDayView* CXTPCalendarControl::GetDayView() const
2108{
2109 return m_pDayView;
2110}
2111AFX_INLINE CXTPCalendarWeekView* CXTPCalendarControl::GetWeekView() const
2112{
2113 return m_pWeekView;
2114}
2115AFX_INLINE CXTPCalendarMonthView* CXTPCalendarControl::GetMonthView() const
2116{
2117 return m_pMonthView;
2118}
2119AFX_INLINE CXTPCalendarTimeLineView* CXTPCalendarControl::GetTimeLineView() const
2120{
2121 return m_pTimeLineView;
2122}
2123AFX_INLINE CXTPCalendarOptions* CXTPCalendarControl::GetCalendarOptions() const
2124{
2125 return m_pOptions;
2126}
2127
2128# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
2129#endif // !defined(_XTPCALENDARCONTROL_H__)
XTPCalendarDataProvider
XTPCalendarDataProvider
Enumeration used to determine the calendar data provider in use.
Definition XTPCalendarDefines.h:337
xtpCalendarDataProviderUnknown
@ xtpCalendarDataProviderUnknown
Unknown data provider.
Definition XTPCalendarDefines.h:338
XTPCalendarViewType
XTPCalendarViewType
Enumeration used to determine the calendar view type in use.
Definition XTPCalendarDefines.h:361
XTPCalendarThemeVersion
XTPCalendarThemeVersion
Paint theme versions used by calendar.
Definition XTPCalendarDefines.h:87
XTPCalendarTheme
XTPCalendarTheme
Paint themes used by calendar.
Definition XTPCalendarDefines.h:62
xtpCalendarViewChangedSend
@ xtpCalendarViewChangedSend
Set send request for XTP_NC_CALENDARVIEWWASCHANGED notification and lock sending.
Definition XTPCalendarDefines.h:430
xtpCalendarUpdateRedrawIfNeed
@ xtpCalendarUpdateRedrawIfNeed
Redraw control's picture if needed.
Definition XTPCalendarDefines.h:419
xtpCalendarUpdateRedraw
@ xtpCalendarUpdateRedraw
Redraw control picture.
Definition XTPCalendarDefines.h:416
xtpCalendarUpdateLayout
@ xtpCalendarUpdateLayout
Adjust positions of control's elements.
Definition XTPCalendarDefines.h:412
xtpCalendarUpdateScrollBar
@ xtpCalendarUpdateScrollBar
Recalculate control's scrollbar positions.
Definition XTPCalendarDefines.h:414
XTPCalendarMouseMode
XTPCalendarMouseMode
Enumeration of operational mouse modes.
Definition XTPCalendarDefines.h:382
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCalendarControl::CUpdateContext
Class CUpdateContext updates context and redraws control parts depending on input parameters.
Definition XTPCalendarControl.h:1729
CXTPCalendarControl::CUpdateContext::~CUpdateContext
~CUpdateContext()
Destroys a CUpdateContext object and calls all the required Calendar Control adjusting and redrawing ...
Definition XTPCalendarControl.h:1783
CXTPCalendarControl::CUpdateContext::CUpdateContext
CUpdateContext(CXTPCalendarControl *pControl, int nOptions=xtpCalendarUpdateLayout|xtpCalendarUpdateRedraw)
Constructs a CUpdateContext object.
Definition XTPCalendarControl.h:1746
CXTPCalendarControl::CViewChanged_ContextData
Class CViewChanged_ContextData is used as locker context for CViewChangedContext.
Definition XTPCalendarControl.h:1859
CXTPCalendarControl::CViewChanged_ContextData::m_nLockCount
int m_nLockCount
View change notification lock counter.
Definition XTPCalendarControl.h:1867
CXTPCalendarControl::CViewChanged_ContextData::CViewChanged_ContextData
CViewChanged_ContextData()
Default object constructor.
CXTPCalendarControl::CViewChanged_ContextData::m_bRequest
BOOL m_bRequest
View change send notification request.
Definition XTPCalendarControl.h:1868
CXTPCalendarControl::CViewChangedContext
Class CViewChangedContext used to avoid multiple sending of XTP_NC_CALENDARVIEWWASCHANGED notificatio...
Definition XTPCalendarControl.h:1811
CXTPCalendarControl::CViewChangedContext::~CViewChangedContext
virtual ~CViewChangedContext()
Destroys a CViewChangedContext object and send notification if this is last locker object.
CXTPCalendarControl::CViewChangedContext::CViewChangedContext
CViewChangedContext(CXTPCalendarView *pView, int eType=xtpCalendarViewChangedSend)
Constructs a CViewChangedContext object.
CXTPCalendarControl::CViewChangedContext::CViewChangedContext
CViewChangedContext(CXTPCalendarControl *pControl, int eType=xtpCalendarViewChangedSend)
Constructs a CViewChangedContext object.
CXTPCalendarControl
Class CXTPCalendarControl implements the calendar's view interface.
Definition XTPCalendarControl.h:126
CXTPCalendarControl::SetDataProvider
void SetDataProvider(CXTPCalendarData *pDataProvider, BOOL bCloseDataProviderWhenDestroy=TRUE)
This member function sets the custom data provider for the control.
CXTPCalendarControl::m_bMultipleSchedulesNoSelfLinks
BOOL m_bMultipleSchedulesNoSelfLinks
flag to use MutilpleSchedulesModel (one event - many view events case - allow to eliminate selflinks)
Definition XTPCalendarControl.h:1972
CXTPCalendarControl::ResetTodayDateOverride
void ResetTodayDateOverride()
This member function resets override for "today" date to the current date.
CXTPCalendarControl::m_bTooltipUnderMouse
BOOL m_bTooltipUnderMouse
2-way tooltip positioning - TRUE - under mouse cursor, FALSE - on the top of mouse cursor
Definition XTPCalendarControl.h:1948
CXTPCalendarControl::GetTodayDateOverride
COleDateTime GetTodayDateOverride() const
This member function returns override for "today" date is it was set with SetTodayDateOverride() call...
CXTPCalendarControl::GetTimeLineView
CXTPCalendarTimeLineView * GetTimeLineView() const
This member function obtains a pointer to the TimeLine calendar view.
Definition XTPCalendarControl.h:2119
CXTPCalendarControl::SetWorkDayStartTime
void SetWorkDayStartTime(const COleDateTime &dtTime)
This member function sets the begin time for the working day.
CXTPCalendarControl::OnUpdateCut
virtual afx_msg void OnUpdateCut(CCmdUI *pCmdUI)
This member function is used to update the user interface object represented by pCmdUI for the "Cut" ...
CXTPCalendarControl::IsToday
virtual BOOL IsToday(const COleDateTime &dtDate) const
This member function is used to determine if the provided date is "today" The today date may be overr...
CXTPCalendarControl::SetResources
void SetResources(CXTPCalendarResources *pResources, CXTPCalendarData *pOptionsDataProvider=NULL)
This member function sets the new Resources collection for the control.
CXTPCalendarControl::GetFirstWeekOfYearDays
int GetFirstWeekOfYearDays() const
This member function gets the first week of year days.
CXTPCalendarControl::SetBorders
virtual void SetBorders(int nLeft, int nTop, int nRight, int nBottom)
This member function is used to adjust the object's layout depending on the provided bounding rectang...
CXTPCalendarControl::m_bSwitchToDayViewIfPickedSingleDay
BOOL m_bSwitchToDayViewIfPickedSingleDay
flag to switch to DatView on DatePicker one day selection (if TRUE) or keep previous view (FALSE)
Definition XTPCalendarControl.h:1967
CXTPCalendarControl::GetResources
CXTPCalendarResources * GetResources() const
Obtain a pointer to collection of Calendar Resources.
CXTPCalendarControl::MonthView_IsShowTimeAsClocks
BOOL MonthView_IsShowTimeAsClocks() const
Call this method to determine if the time is shown as a graphical clock for events in the month view.
CXTPCalendarControl::m_sCustomFormat4Tooltip
CString m_sCustomFormat4Tooltip
Free-styled tooltip tag-based way to fill tooltip string used tags <BODY>,<LOC>,<SUBJ>,...
Definition XTPCalendarControl.h:1959
CXTPCalendarControl::SetDataProvider
void SetDataProvider(LPCTSTR lpszConnectionString)
This member function sets the custom data provider for the control.
CXTPCalendarControl::CreateDataProvider
static CXTPCalendarData *AFX_CDECL CreateDataProvider(LPCTSTR lpszConnectionString)
Call this method to create a data provider from a specified Calendar connection string.
CXTPCalendarControl::GetTheme
CXTPCalendarTheme * GetTheme() const
This member function obtains a pointer to the associated theme object.
Definition XTPCalendarControl.h:2064
CXTPCalendarControl::HideToolTip
virtual void HideToolTip()
This member function is used to hide the ToolTip rectangle.
CXTPCalendarControl::SwitchActiveView
virtual void SwitchActiveView(XTPCalendarViewType eView)
This member function sets a predefined calendar view for the control.
CXTPCalendarControl::SetPaintManager
void SetPaintManager(CXTPCalendarPaintManager *pPaintManager)
This member function sets the new control drawing PaintManager.
CXTPCalendarControl::SetWorkDayEndTime
void SetWorkDayEndTime(int nHour, int nMin, int nSec)
This member function sets an end time for the working day.
CXTPCalendarControl::m_nTimelineScale
int m_nTimelineScale
current timeline scale type
Definition XTPCalendarControl.h:1939
CXTPCalendarControl::GetRemindersManager
virtual CXTPCalendarRemindersManager * GetRemindersManager() const
Obtain an associated Reminders Manager object.
Definition XTPCalendarControl.h:2074
CXTPCalendarControl::SetSmallDayHeaderFormat
void SetSmallDayHeaderFormat(LPCTSTR pcszCustomFormat)
Sets format for Cell's Day Header in Month View.
CXTPCalendarControl::IsToolTipVisible
virtual BOOL IsToolTipVisible() const
This member function is the ToolTip rectangle visible on the screen.
CXTPCalendarControl::DataSourceFromConStr
static CString AFX_CDECL DataSourceFromConStr(LPCTSTR lpszConnectionString)
Call this method to retrieve a data source connection string from a regular Calendar connection strin...
CXTPCalendarControl::SetWorkDayEndTime
void SetWorkDayEndTime(const COleDateTime &dtTime)
This member function sets an end time for the working day.
CXTPCalendarControl::SendNotification
virtual void SendNotification(XTP_NOTIFY_CODE EventCode, WPARAM wParam, LPARAM lParam)
This member function sends a notification to all control's event subscribers.
CXTPCalendarControl::SetDataProvider
void SetDataProvider(XTPCalendarDataProvider eDataProvider, LPCTSTR lpszConnectionString=NULL)
This member function sets the custom data provider for the control.
CXTPCalendarControl::SetTodayDateOverride
void SetTodayDateOverride(const COleDateTime &dtTodayOverride)
This member function is used to override the "today" date.
CXTPCalendarControl::m_strUndoUIText
CString m_strUndoUIText
Text label for the Undo UI command.
Definition XTPCalendarControl.h:1875
CXTPCalendarControl::UpdateBorders
virtual void UpdateBorders()
This member function is used to adjust the object's layout depending on the provided bounding rectang...
CXTPCalendarControl::GetWorkWeekMask
int GetWorkWeekMask() const
This member function gets the bitwise mask of the work week.
CXTPCalendarControl::SetPaintTheme
virtual void SetPaintTheme(CXTPCalendarPaintManager *pPaintManager, CXTPCalendarTheme *pTheme)
This member function is used to set current paint theme.
CXTPCalendarControl::IsLayoutRTL
BOOL IsLayoutRTL() const
Call this member to determine if right-to-left mode is active.
CXTPCalendarControl::DataProviderTypeFromConStr
static XTPCalendarDataProvider AFX_CDECL DataProviderTypeFromConStr(LPCTSTR lpszConnectionString, XTPCalendarDataProvider eDPDefault=xtpCalendarDataProviderUnknown)
Call this method to retrieve a type of the data provider from its connection string.
CXTPCalendarControl::SetWorkDayStartTime
void SetWorkDayStartTime(int nHour, int nMin, int nSec)
This member function sets the begin time for the working day.
CXTPCalendarControl::Populate
virtual void Populate()
This member function populates the active control view with events data.
CXTPCalendarControl::WeekView_SetShowTimeAsClocks
void WeekView_SetShowTimeAsClocks(BOOL bShowClocks)
Call this method to specify if the events start and end time is shown as a graphical clock in week vi...
CXTPCalendarControl::AdjustLayout
virtual void AdjustLayout()
This member function adjusts the main control parts depending on the current control's size.
CXTPCalendarControl::IsToolTipsEnabled
BOOL IsToolTipsEnabled() const
This member function returns TRUE if the ToolTips enabled, FALSE otherwise.
Definition XTPCalendarControl.h:2079
CXTPCalendarControl::MonthView_IsShowEndDate
BOOL MonthView_IsShowEndDate() const
Call this method to determine whether the end date is shown for events in the month view.
CXTPCalendarControl::OnUpdatePaste
virtual afx_msg void OnUpdatePaste(CCmdUI *pCmdUI)
This member function is used to update the user interface object represented by pCmdUI for the "Paste...
CXTPCalendarControl::CreateDataProvider
static CXTPCalendarData *AFX_CDECL CreateDataProvider(XTPCalendarDataProvider eDataProvider)
Call this method to create a data provider of the specified type.
CXTPCalendarControl::m_bPromptToDeleteRecurrentEvent
BOOL m_bPromptToDeleteRecurrentEvent
flag to use Ocurrence or Master case selector (default = TRUE)
Definition XTPCalendarControl.h:1953
CXTPCalendarControl::m_bShowTooltipForNotFocused
BOOL m_bShowTooltipForNotFocused
flag to Show Tooltip For Not Focused Control
Definition XTPCalendarControl.h:1965
CXTPCalendarControl::SetTheme
void SetTheme(CXTPCalendarTheme *pTheme)
This member function sets (or disables) the new control drawing theme.
CXTPCalendarControl::m_bUpdateWhenEventChangedNotify
BOOL m_bUpdateWhenEventChangedNotify
Whether to update control when notification comes about an event change.
Definition XTPCalendarControl.h:1877
CXTPCalendarControl::OnCut
virtual afx_msg void OnCut()
This member function is used to process the "Cut" command.
CXTPCalendarControl::GetTimeLineScale
int GetTimeLineScale() const
Call this member to get current TimeLine mode.
CXTPCalendarControl::CXTPCalendarControl
CXTPCalendarControl()
This member function constructs a CXTPCalendarControl object.
CXTPCalendarControl::WeekView_SetShowEndDate
void WeekView_SetShowEndDate(BOOL bShowEnd)
Call this method to specify if the end date is shown in week view.
CXTPCalendarControl::GetActiveView
virtual CXTPCalendarView * GetActiveView() const
This member function obtains a pointer to the current calendar view.
Definition XTPCalendarControl.h:2103
CXTPCalendarControl::RegisterWindowClass
virtual BOOL RegisterWindowClass(HINSTANCE hInstance=NULL)
Registers the window class if it has not already been registered.
CXTPCalendarControl::Create
virtual BOOL Create(DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID)
This member function handles control window creation.
CXTPCalendarControl::GetCalendarOptions
CXTPCalendarOptions * GetCalendarOptions() const
Call this member function to get direct access to calendar options data.
Definition XTPCalendarControl.h:2123
CXTPCalendarControl::SetPaintTheme
virtual void SetPaintTheme(XTPCalendarTheme ePaintTheme)
This member function is used to set current paint theme.
CXTPCalendarControl::m_nRowsPerWheel
int m_nRowsPerWheel
Amount of rows to scroll when using the mouse wheel.
Definition XTPCalendarControl.h:1873
CXTPCalendarControl::OnWndMsg
virtual afx_msg BOOL OnWndMsg(UINT message, WPARAM wParam, LPARAM lParam, LRESULT *pResult)
This member function is called by WindowProc, or is called during message reflection.
CXTPCalendarControl::SetFirstDayOfWeek
void SetFirstDayOfWeek(const int nFirstDayOfWeek)
This member function sets the first day of the week.
CXTPCalendarControl::OnPaste
virtual afx_msg void OnPaste()
This member function is used to process the "Paste" command.
CXTPCalendarControl::OnUndo
virtual afx_msg void OnUndo()
This member function is used to process the "Undo" command.
CXTPCalendarControl::GetDataProvider
CXTPCalendarData * GetDataProvider() const
Returns common data provider if it was previously set.
CXTPCalendarControl::SetActiveView
virtual void SetActiveView(CXTPCalendarView *pView)
This member function sets the custom calendar view for the control.
CXTPCalendarControl::m_nCaptionHeight
int m_nCaptionHeight
height param - can be used for custom layout adjustment
Definition XTPCalendarControl.h:1940
CXTPCalendarControl::m_bShowLinks
BOOL m_bShowLinks
flag to show or hide 'virtual' view events
Definition XTPCalendarControl.h:1951
CXTPCalendarControl::SetLongDayHeaderFormat
void SetLongDayHeaderFormat(LPCTSTR pcszCustomFormat)
Sets format for Cell's Day Header in Month View.
CXTPCalendarControl::OnCalendarTimeline
void OnCalendarTimeline()
This member function switch calendar to timeline mode.
CXTPCalendarControl::m_bPreventAutoAllDayMode
BOOL m_bPreventAutoAllDayMode
Flag to prevent dragging event into AllDay zone.
Definition XTPCalendarControl.h:1941
CXTPCalendarControl::GetThemeVersion
XTPCalendarThemeVersion GetThemeVersion() const
This member function is used to obtain the current theme ID.
CXTPCalendarControl::MonthView_SetShowTimeAsClocks
void MonthView_SetShowTimeAsClocks(BOOL bShowClocks=TRUE)
Call this method to specify if the events start and end time is shown as a graphical clock in the mon...
CXTPCalendarControl::GetMarkupContext
CXTPMarkupContext * GetMarkupContext() const
Retrieves a pointer to the markup context.
Definition XTPCalendarControl.h:2099
CXTPCalendarControl::_SetDataProvider
virtual void _SetDataProvider(CXTPCalendarData *pDataProvider, BOOL bCloseDataProviderWhenDestroy=TRUE)
This member function internally sets the custom data provider for the control.
CXTPCalendarControl::GetDayView
CXTPCalendarDayView * GetDayView() const
This member function obtains a pointer to the Day calendar view.
Definition XTPCalendarControl.h:2107
CXTPCalendarControl::EnableSendNotifications
virtual void EnableSendNotifications(BOOL bEnable=TRUE)
This member function enables or disables sending a notification to all control's event subscribers.
Definition XTPCalendarControl.h:2091
CXTPCalendarControl::m_bDeleteOnFinalRelease
BOOL m_bDeleteOnFinalRelease
If TRUE - Delete self OnFinalRelease() call.
Definition XTPCalendarControl.h:1934
CXTPCalendarControl::SelectEventById
BOOL SelectEventById(DWORD dEventID, BOOL bSelect=TRUE)
This member function attempts to select an event through a passed event ID.
CXTPCalendarControl::m_bShowTooltipForAllDayEvents
BOOL m_bShowTooltipForAllDayEvents
flag to Show Tooltip For All Day Events
Definition XTPCalendarControl.h:1966
CXTPCalendarControl::m_pMarkupContext
CXTPMarkupContext * m_pMarkupContext
The markup context.
Definition XTPCalendarControl.h:1880
CXTPCalendarControl::GetFirstDayOfWeek
int GetFirstDayOfWeek() const
This member function gets the first day of the week.
CXTPCalendarControl::OnUpdateCopy
virtual afx_msg void OnUpdateCopy(CCmdUI *pCmdUI)
This member function is used to update the user interface object represented by pCmdUI for the "Copy"...
CXTPCalendarControl::m_bMultiColorScheduleMode
BOOL m_bMultiColorScheduleMode
Flag to show Schedules titles in different colors.
Definition XTPCalendarControl.h:1942
CXTPCalendarControl::GetWorkDayStartTime
void GetWorkDayStartTime(COleDateTime &dtTime) const
This member function gets the begin time of the working day.
CXTPCalendarControl::DayView_IsAutoResetBusyFlag
BOOL DayView_IsAutoResetBusyFlag() const
Call this method to determine if the AutoResetBusyFlag is set.
CXTPCalendarControl::QueueDayViewSwitch
virtual void QueueDayViewSwitch(DATE dtDate)
This member function queues the calendar view while changing to the day view for the specified day.
CXTPCalendarControl::UpdateMouseCursor
virtual BOOL UpdateMouseCursor()
This member function updates the mouse cursor in relation with the control's state.
CXTPCalendarControl::m_bForcePagination
BOOL m_bForcePagination
flag to Force Pagination during PrintPreview
Definition XTPCalendarControl.h:1964
CXTPCalendarControl::GetWorkDayEndTime
void GetWorkDayEndTime(int &nHour, int &nMin, int &nSec) const
This member function gets the end time of the working day.
CXTPCalendarControl::m_bHideCaptionBar
BOOL m_bHideCaptionBar
Flag to Hide Caption Bar when TimeLine mode used.
Definition XTPCalendarControl.h:1944
CXTPCalendarControl::m_bTimelineMode
BOOL m_bTimelineMode
flag to separate timeline (if TRUE) and other calendar modes
Definition XTPCalendarControl.h:1937
CXTPCalendarControl::~CXTPCalendarControl
virtual ~CXTPCalendarControl()
This member function destroys a CXTPCalendarControl object and handles cleanup and deallocation.
CXTPCalendarControl::OnUpdateCmdUI
virtual afx_msg void OnUpdateCmdUI(CCmdUI *pCmdUI)
This member function is used to update the user interface object represented by pCmdUI.
CXTPCalendarControl::MonthView_SetCompressWeekendDays
void MonthView_SetCompressWeekendDays(BOOL bCompress=TRUE)
Call this method to specify whether weekend days are drawn compressed in the month view.
CXTPCalendarControl::GetPaintManager
CXTPCalendarPaintManager * GetPaintManager() const
This member function obtains a pointer to the associated paint manager.
Definition XTPCalendarControl.h:2059
CXTPCalendarControl::GetWorkDayEndTime
void GetWorkDayEndTime(COleDateTime &dtTime) const
This member function gets the end time of the working day.
CXTPCalendarControl::EnableToolTips
void EnableToolTips(BOOL bEnable=TRUE)
This member function is used to enable or disable ToolTips for the control.
Definition XTPCalendarControl.h:2083
CXTPCalendarControl::SelectViewEventByIdAndGroup
BOOL SelectViewEventByIdAndGroup(int nScheduleID, DWORD dEventID, BOOL bSelect=TRUE)
This member function is making attempt to select view event by passed Schedule ID and event ID.
CXTPCalendarControl::AdjustLayout
virtual void AdjustLayout(CDC *pDC, const CRect &rcView)
This member function adjusts the main control parts depending on the current control's size.
CXTPCalendarControl::GetWeekView
CXTPCalendarWeekView * GetWeekView() const
This member function obtains a pointer to the Week calendar view.
Definition XTPCalendarControl.h:2111
CXTPCalendarControl::OnDraw
virtual void OnDraw(CDC *pDC)
This member function performs all of the drawing logic of the calendar control window.
CXTPCalendarControl::m_bFullDateMode
BOOL m_bFullDateMode
Useful for Multi-schedules case flag to use DayHeader special format.
Definition XTPCalendarControl.h:1946
CXTPCalendarControl::MonthView_IsCompressWeekendDays
BOOL MonthView_IsCompressWeekendDays() const
Call this method to determine whether weekend days are drawn compressed in month view or not.
CXTPCalendarControl::DoDeleteEvent
virtual BOOL DoDeleteEvent(CXTPCalendarViewEvent *pViewEvent)
This member function deletes a specified event from the calendar.
CXTPCalendarControl::SetTimer
virtual UINT SetTimer(UINT uTimeOut_ms)
This member function creates a timer event.
CXTPCalendarControl::m_bDeleteOcurrenceEventIfNoPrompt
BOOL m_bDeleteOcurrenceEventIfNoPrompt
True to delete Ocurrence event, False - delete Master (default = TRUE)
Definition XTPCalendarControl.h:1955
CXTPCalendarControl::m_strRedoUIText
CString m_strRedoUIText
Text label for the Redo UI command.
Definition XTPCalendarControl.h:1876
CXTPCalendarControl::IsMarkupEnabled
BOOL IsMarkupEnabled() const
This member function returns TRUE if Markup functionality is enabled for this Calendar control and FA...
Definition XTPCalendarControl.h:2095
CXTPCalendarControl::DoDeleteSelectedEvents
virtual BOOL DoDeleteSelectedEvents(CXTPCalendarViewEvent *pViewEvent)
This member function deletes selected events from the calendar.
CXTPCalendarControl::RedrawControl
virtual void RedrawControl(BOOL bForce=FALSE)
This member function initiates the Calendar control's redrawing.
CXTPCalendarControl::AdjustScrollBarEx
virtual void AdjustScrollBarEx(int nSBType)
This member function adjusts the scroll bar to reflect the current control's state.
CXTPCalendarControl::SetLayoutRTL
void SetLayoutRTL(BOOL bRightToLeft)
Call this member to set right-to-left mode.
CXTPCalendarControl::m_OwnerUser
CString m_OwnerUser
string as current user name place holder
Definition XTPCalendarControl.h:1958
CXTPCalendarControl::OnWndMsg_Children
virtual BOOL OnWndMsg_Children(UINT message, WPARAM wParam, LPARAM lParam, LRESULT *pResult)
This member function is used to catch messages before child windows (like Subject editor).
CXTPCalendarControl::m_Borders
CRect m_Borders
Store options to draw border lines;.
Definition XTPCalendarControl.h:1490
CXTPCalendarControl::GetWorkDayStartTime
void GetWorkDayStartTime(int &nHour, int &nMin, int &nSec) const
This member function gets the begin time of the working day.
CXTPCalendarControl::m_bHideLinkContainer
BOOL m_bHideLinkContainer
flag to hide or show 'virtual' view events container column
Definition XTPCalendarControl.h:1952
CXTPCalendarControl::DayView_SetAutoResetBusyFlag
void DayView_SetAutoResetBusyFlag(BOOL bAutoResetBusyFlag=TRUE)
Call this method to set the AutoResetBusyFlag.
CXTPCalendarControl::SendNotificationAlways
virtual void SendNotificationAlways(XTP_NOTIFY_CODE EventCode, WPARAM wParam, LPARAM lParam)
This member function sends a notification to all control's event subscribers.
CXTPCalendarControl::OnEditCommand
virtual void OnEditCommand(UINT uCommandID)
This member function is used to process the command with the specified ID.
CXTPCalendarControl::GetPaintTheme
virtual XTPCalendarTheme GetPaintTheme() const
This member function is used to obtain current paint theme.
CXTPCalendarControl::AddCustomTimeIntervalForReminder
void AddCustomTimeIntervalForReminder(int nMin, LPCTSTR szCustomMeaning=NULL, BOOL bIgnoreDefaultValues=FALSE)
This member function adds a custom time interval for an event to choose in the event properties dialo...
CXTPCalendarControl::OnUpdateUndo
virtual afx_msg void OnUpdateUndo(CCmdUI *pCmdUI)
This member function is used to update the user interface object represented by pCmdUI for the "Undo"...
CXTPCalendarControl::m_cntViewChanged
CViewChanged_ContextData m_cntViewChanged
Locker context for CViewChangedContext.
Definition XTPCalendarControl.h:1871
CXTPCalendarControl::SetWorkWeekMask
void SetWorkWeekMask(const int nMask)
This member function sets the bitwise mask for the work week.
CXTPCalendarControl::OnBeforeDestroy
virtual void OnBeforeDestroy()
This member function is called by the framework before the view is destroyed.
CXTPCalendarControl::m_bMultiColumnWeekMode
BOOL m_bMultiColumnWeekMode
Flag to select Outlook2007 and Outlook2003 behavior.
Definition XTPCalendarControl.h:1943
CXTPCalendarControl::IsReadonlyMode
BOOL IsReadonlyMode() const
This member function is used to get the state of Read-only mode.
CXTPCalendarControl::MonthView_SetShowEndDate
void MonthView_SetShowEndDate(BOOL bShowEnd=TRUE)
Call this method to specify whether the end date is shown in the month view.
CXTPCalendarControl::GetMonthView
CXTPCalendarMonthView * GetMonthView() const
This member function obtains a pointer to the Month calendar view.
Definition XTPCalendarControl.h:2115
CXTPCalendarControl::m_sCustomTitle
CString m_sCustomTitle
used for unique title - e.g.
Definition XTPCalendarControl.h:1963
CXTPCalendarControl::AdjustScrollBar
virtual void AdjustScrollBar(int nSBType=-1)
This member function adjusts the scroll bar to reflect the current control's state.
CXTPCalendarControl::m_bReadOnlyMode
BOOL m_bReadOnlyMode
View- and Print-only mode to use Calendar.
Definition XTPCalendarControl.h:1945
CXTPCalendarControl::GetConnection
CXTPNotifyConnection * GetConnection() const
Obtain a pointer to the notification connection object.
Definition XTPCalendarControl.h:2069
CXTPCalendarControl::m_bDisableRedraw
BOOL m_bDisableRedraw
If TRUE - control window is not redraw, it is draw last window content (draw cached bitmap).
Definition XTPCalendarControl.h:1935
CXTPCalendarControl::WeekView_IsShowTimeAsClocks
BOOL WeekView_IsShowTimeAsClocks() const
Call this method to determine if the time is shown as a graphical clock for events in the week view.
CXTPCalendarControl::m_bMultipleSchedulesMode
BOOL m_bMultipleSchedulesMode
flag to use MutilpleSchedulesModel (one event - many view events case)
Definition XTPCalendarControl.h:1970
CXTPCalendarControl::m_pRemindersManager
CXTPCalendarRemindersManager * m_pRemindersManager
Stores reminders manager object.
Definition XTPCalendarControl.h:1879
CXTPCalendarControl::OnCopy
virtual afx_msg void OnCopy()
This member function is used to process the "Copy" command.
CXTPCalendarControl::m_mapCustomReminderValues
CMap< int, int, CString, CString & > m_mapCustomReminderValues
custom time intervals for reminder
Definition XTPCalendarControl.h:1976
CXTPCalendarControl::SetFirstWeekOfYearDays
void SetFirstWeekOfYearDays(const int nFirstWeekOfYearDays)
Call this member function to set the first week of year days.
CXTPCalendarControl::GetTodayDate
COleDateTime GetTodayDate() const
This member function is used to determine the "today" date The today date may be overriden with SetTo...
CXTPCalendarControl::m_mouseMode
XTPCalendarMouseMode m_mouseMode
Current mouse operation mode.
Definition XTPCalendarControl.h:1933
CXTPCalendarControl::WeekView_IsShowEndDate
BOOL WeekView_IsShowEndDate() const
Call this method to determine if the end date is shown for events in the week view.
CXTPCalendarControl::m_eViewType
XTPCalendarViewType m_eViewType
current view type
Definition XTPCalendarControl.h:1938
CXTPCalendarControlView
The CXTPCalendarControlView class provides an implementation of the Calendar control as a view class.
Definition XTPCalendarControlView.h:283
CXTPCalendarData
This class defines an abstract representation of the Calendar control data with all necessary methods...
Definition XTPCalendarData.h:97
CXTPCalendarDayView
This class implements a specific view portion of the Calendar control - called Day view.
Definition XTPCalendarDayView.h:62
CXTPCalendarMonthView
This class implements a specific view portion of the Calendar control - called Month view.
Definition XTPCalendarMonthView.h:74
CXTPCalendarOptions
Structure contains all calendar options.
Definition XTPCalendarOptions.h:77
CXTPCalendarPaintManager
Utility class, handles most of the drawing activities.
Definition XTPCalendarPaintManager.h:150
CXTPCalendarRemindersManager
This class is used to monitor and manage calendar events reminders.
Definition XTPCalendarRemindersManager.h:355
CXTPCalendarResource
Class CXTPCalendarResource represents a calendar for some subject like a person, a shared resource,...
Definition XTPCalendarResource.h:339
CXTPCalendarResources
This class represents a simple array collection of CXTPCalendarResource objects.
Definition XTPCalendarResource.h:555
CXTPCalendarResourcesNf
This class implements CXTPCalendarResource functionality with the addition of a notifications mechani...
Definition XTPCalendarResource.h:635
CXTPCalendarTimeLineView
This class implements a specific view portion of the Calendar control - called Timeline view.
Definition XTPCalendarTimeLineView.h:76
CXTPCalendarTip
The CXTPCalendarTip class emulates the functionality of a "tool tip" control.
Definition XTPCalendarTip.h:51
CXTPCalendarViewDay
This class represents the day view portion of the CalendarView.
Definition XTPCalendarViewDay.h:555
CXTPCalendarViewEvent
This class represents an event view portion of the CalendarViewGroup.
Definition XTPCalendarViewEvent.h:106
CXTPCalendarViewGroup
Regular schema:
Definition XTPCalendarViewDay.h:54
CXTPCalendarView
This class represents the view portion of the Calendar control.
Definition XTPCalendarView.h:360
CXTPCalendarWeekView
This class implements a specific view portion of the Calendar control - called Week view.
Definition XTPCalendarWeekView.h:54
CXTPMarkupContext
CXTPMarkupContext is a standalone class used to provide common settings for Markup objects.
Definition XTPMarkupContext.h:128
CXTPMarkupUIElement
Base class for XML Markup core level implementations.
Definition XTPMarkupUIElement.h:43
CXTPNotifyConnection
This class is used as implementation of Connection interface in a XTPNotification mechanism.
Definition XTPNotifyConnection.h:88


Toolkit Pro: Member List

CXTPFlowGraphPaintManager Member List

This is the complete list of members for CXTPFlowGraphPaintManager, including all inherited members.

Cleanup() | CXTPFlowGraphPaintManager | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPFlowGraphPaintManager() | CXTPFlowGraphPaintManager |
DrawConnection(CXTPFlowGraphDrawContext *pDC, CXTPFlowGraphConnection *pConnection) | CXTPFlowGraphPaintManager | virtual
DrawControlBackground(CXTPFlowGraphDrawContext *pDC, CXTPFlowGraphControl *pControl, BOOL bPrintToFile=FALSE, const CRect &drawRect=CRect(0, 0, 0, 0)) | CXTPFlowGraphPaintManager | virtual
DrawNodeGroup(CXTPFlowGraphDrawContext *pDC, CXTPFlowGraphNodeGroup *pNodeGroup) | CXTPFlowGraphPaintManager | virtual
DrawTransparentRectangle(CXTPFlowGraphDrawContext *pDC, CRect rect, COLORREF clrColor) | CXTPFlowGraphPaintManager |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCaptionRect(CXTPFlowGraphElement *pNode) | CXTPFlowGraphPaintManager | virtual
GetDarkColor(COLORREF clrBackground) | CXTPFlowGraphPaintManager | static
GetNodeBoundingRectangle(CXTPFlowGraphNode *pNode) | CXTPFlowGraphPaintManager | virtual
HitTestConnectionArea(const CXTPFlowGraphConnectionPoint *pPoint, CPoint point) | CXTPFlowGraphPaintManager | virtual
m_bAlwaysDrawConnectionPoints | CXTPFlowGraphPaintManager |
m_bChangeNodeColorWhenSelected | CXTPFlowGraphPaintManager |
m_bRecalcConnectionLayoutWhenNeeded | CXTPFlowGraphPaintManager |
m_bShowGrid | CXTPFlowGraphPaintManager |
m_bShowNodeGroupsAlways | CXTPFlowGraphPaintManager |
m_clrBackground | CXTPFlowGraphPaintManager |
m_clrConnection | CXTPFlowGraphPaintManager |
m_clrGridColor | CXTPFlowGraphPaintManager |
m_clrNodeBackground | CXTPFlowGraphPaintManager |
m_clrSelection | CXTPFlowGraphPaintManager |
m_clrSelectionInactive | CXTPFlowGraphPaintManager |
m_clrTextColor | CXTPFlowGraphPaintManager |
m_clrTextColorSelected | CXTPFlowGraphPaintManager |
m_dMinZoomLevelBackground | CXTPFlowGraphPaintManager |
m_dMinZoomLevelConnectionPoints | CXTPFlowGraphPaintManager |
m_dMinZoomLevelConnections | CXTPFlowGraphPaintManager |
m_dMinZoomLevelGDIQuality | CXTPFlowGraphPaintManager |
m_lfCaption | CXTPFlowGraphPaintManager |
m_lfText | CXTPFlowGraphPaintManager |
m_nConnectorType | CXTPFlowGraphPaintManager |
m_nEllipseSize | CXTPFlowGraphPaintManager |
m_nNodeFrameSize | CXTPFlowGraphPaintManager |
m_nPointTextMargin | CXTPFlowGraphPaintManager |
RecalcConnectionLayout(CXTPFlowGraphDrawContext *pDC, CXTPFlowGraphConnection *pConnection) | CXTPFlowGraphPaintManager | virtual
RefreshMetrics() | CXTPFlowGraphPaintManager | virtual
~CXTPFlowGraphPaintManager() | CXTPFlowGraphPaintManager | virtual


Toolkit Pro: Member List

CXTPTabExBase Member List

This is the complete list of members for CXTPTabExBase, including all inherited members.

ActivateView(CWnd *pTabView) | CXTPTabExBase | virtual
AddControl(LPCTSTR lpszLabel, CWnd *pWnd, int iIndex=-1, int iIconIndex=-1, LPARAM lParam=0) | CXTPTabExBase | virtual
AddToolTip(UINT nIDTab, LPCTSTR lpszText) | CXTPTabExBase | virtual
AddView(LPCTSTR lpszLabel, CView *pView, int iIndex=-1, int iIconIndex=-1, LPARAM lParam=0) | CXTPTabExBase | virtual
AddView(LPCTSTR lpszLabel, CRuntimeClass *pViewClass, CDocument *pDoc=NULL, CCreateContext *pContext=NULL, int iIndex=-1, int iIconIndex=-1, LPARAM lParam=0) | CXTPTabExBase | virtual
CalculateTabWidth(CDC *pDC, CString &sLabel, bool bHasIcon) | CXTPTabExBase | protected
Condense() | CXTPTabExBase | protected
CreateTabView(CRuntimeClass *pViewClass, CDocument *pDocument, CCreateContext *pContext) | CXTPTabExBase | protectedvirtual
CXTPTabBase() | CXTPTabBase |
CXTPTabExBase() | CXTPTabExBase |
Defer(HDWP &hDWP, CWnd *pView) | CXTPTabExBase | virtual
DeleteView(int nView, BOOL bDestroyWnd=TRUE) | CXTPTabExBase | virtual
DeleteView(CWnd *pView, BOOL bDestroyWnd=TRUE) | CXTPTabExBase | virtual
DeleteView(CRuntimeClass *pViewClass, BOOL bDestroyWnd=TRUE) | CXTPTabExBase | virtual
EnableRedraw(BOOL bRedraw) | CXTPTabExBase |
EnableToolTipsEx(BOOL bEnable) | CXTPTabExBase | virtual
GetActiveView() | CXTPTabExBase | virtual
GetAutoCondense() | CXTPTabExBase |
GetButtons() | CXTPTabBase |
GetChildRect(CRect &rcChild) const | CXTPTabBase | virtual
GetLastKnownChildView() | CXTPTabExBase |
GetMenuID() | CXTPTabExBase | virtual
GetTabCtrlImpl() | CXTPTabBase |
GetTabFromPoint(CPoint point) | CXTPTabExBase | virtual
GetTheme() | CXTPTabBase |
GetTips() | CXTPTabExBase | virtual
GetView(int nView) | CXTPTabExBase | virtual
GetView(CRuntimeClass *pViewClass) | CXTPTabExBase | virtual
GetViewName(int nView) | CXTPTabExBase | virtual
GetViewName(CRuntimeClass *pViewClass) | CXTPTabExBase | virtual
ImplAttach(CTabCtrl *pTabCtrl) | CXTPTabBase | protected
Init() | CXTPTabExBase | protectedvirtual
InitializeFont() | CXTPTabExBase | virtual
IsChildView(CWnd *pView) | CXTPTabExBase | virtual
m_bAutoCondensing | CXTPTabBase |
m_bBoldFont | CXTPTabBase |
m_bInitialUpdate | CXTPTabExBase | protected
m_bSubclassed | CXTPTabBase | protected
m_bXPBorder | CXTPTabBase |
m_nPos | CXTPTabExBase | protected
m_pLastActiveView | CXTPTabExBase | protected
m_pNavBtns | CXTPTabBase | protected
m_popupMenuID | CXTPTabExBase | protected
m_pParentFrame | CXTPTabExBase | protected
m_pParentWnd | CXTPTabExBase | protected
m_pTabCtrl | CXTPTabBase | protected
m_pTheme | CXTPTabBase | protected
m_tcbItems | CXTPTabExBase |
ModifyTabStyle(DWORD dwRemove, DWORD dwAdd, UINT nFlags=0) | CXTPTabExBase | virtual
NextView() | CXTPTabExBase |
OnAddPadding(CString &strLabelText) | CXTPTabBase | protectedvirtual
OnSelChange() | CXTPTabExBase | protectedvirtual
OnSelChanging() | CXTPTabExBase | protectedvirtual
OnThemeChanged() | CXTPTabExBase | protectedvirtual
PrevView() | CXTPTabExBase |
RecalcLayout() | CXTPTabExBase | virtual
RefreshMetrics() | CXTPTabBase | protectedvirtual
RemoveAllTabs(BOOL bDestroyWnd=TRUE) | CXTPTabExBase | virtual
RemoveListItem(POSITION pos, BOOL bDestroyWnd=TRUE) | CXTPTabExBase | virtual
ResetToolTips() | CXTPTabExBase | virtual
ResizeTabView(CWnd *pView) | CXTPTabExBase | virtual
SendInitialUpdate(BOOL bInitialUpdate) | CXTPTabExBase | virtual
SetActiveView(int nActiveTab) | CXTPTabExBase | virtual
SetActiveView(CWnd *pTabView) | CXTPTabExBase | virtual
SetActiveView(CRuntimeClass *pViewClass) | CXTPTabExBase | virtual
SetAutoCondense(BOOL bEnable) | CXTPTabExBase |
SetMenuID(UINT popupMenuID, int nPos=0) | CXTPTabExBase | virtual
SetTabText(int nTab, LPCTSTR lpszLabel) | CXTPTabExBase |
SetTabText(CWnd *pView, LPCTSTR lpszLabel) | CXTPTabExBase |
SetTabText(CRuntimeClass *pViewClass, LPCTSTR lpszLabel) | CXTPTabExBase |
SetTheme(XTPControlTheme eTheme) | CXTPTabBase |
SetTips(CToolTipCtrl *pWndTip) | CXTPTabExBase | virtual
ShowNavButtons(DWORD dwFlags) | CXTPTabBase |
UpdateTabLabel(int nTab, CXTPTcbItem *pMember, LPCTSTR lpszLabel) | CXTPTabExBase | protected
UpdateToolTip(int nIDTab, LPCTSTR lpszText) | CXTPTabExBase | virtual
UpdateToolTip(CRuntimeClass *pViewClass, LPCTSTR lpszText) | CXTPTabExBase | virtual
~CXTPTabBase() | CXTPTabBase | virtual
~CXTPTabExBase() | CXTPTabExBase | virtual


Toolkit Pro: XTPFlowGraphPages.h Source File

  • Source
  • FlowGraph
XTPFlowGraphPages.h
Go to the documentation of this file.
1
23#if !defined(__XTPFLOWGRAPHPAGES_H__)
24# define __XTPFLOWGRAPHPAGES_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPFlowGraphControl;
34class CXTPFlowGraphPage;
35
46class _XTP_EXT_CLASS CXTPFlowGraphPages : public CXTPCmdTarget
47{
48protected:
54 CXTPFlowGraphPages(CXTPFlowGraphControl* pControl);
60 virtual ~CXTPFlowGraphPages();
61
62public:
70 CXTPFlowGraphPage* AddPage(CXTPFlowGraphPage* pPage);
71
76 void RemoveAll();
77
84 int GetCount() const;
93 CXTPFlowGraphPage* GetAt(int nIndex) const;
94
100 void Remove(CXTPFlowGraphPage* pPage);
106 void RemoveAt(int nIndex);
107
115 CXTPFlowGraphPage* FindPage(int nId) const;
116
117public:
127 void DoPropExchange(CXTPPropExchange* pPX);
128
129protected:
130 CArray<CXTPFlowGraphPage*, CXTPFlowGraphPage*> m_arrPages;
132 CXTPFlowGraphControl* m_pControl;
134 friend class CXTPFlowGraphControl;
135
136# ifdef _XTP_ACTIVEX
139 DECLARE_DISPATCH_MAP()
140 DECLARE_INTERFACE_MAP()
141
142 DECLARE_OLETYPELIB_EX(CXTPFlowGraphPages)
143 DECLARE_ENUM_VARIANT(CXTPFlowGraphPages)
144
145 afx_msg int OleGetItemCount();
146 afx_msg LPDISPATCH OleGetItem(int nIndex);
147 afx_msg LPDISPATCH OleAddPage();
148 afx_msg LPDISPATCH OleFindPage(int nId);
149
151# endif
152};
153
154AFX_INLINE int CXTPFlowGraphPages::GetCount() const
155{
156 return (int)m_arrPages.GetSize();
157}
158AFX_INLINE CXTPFlowGraphPage* CXTPFlowGraphPages::GetAt(int nIndex) const
159{
160 return nIndex >= 0 && nIndex < m_arrPages.GetSize() ? m_arrPages[nIndex] : NULL;
161}
163# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
164#endif //#if !defined(__XTPFLOWGRAPHPAGES_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPFlowGraphControl
Flow Graph Control.
Definition XTPFlowGraphControl.h:173
CXTPFlowGraphPage
Represents a page in the flow graph.
Definition XTPFlowGraphPage.h:54
CXTPFlowGraphPages
Represents a collection of pages in the flow graph.
Definition XTPFlowGraphPages.h:47
CXTPFlowGraphPages::GetCount
int GetCount() const
Retrieves the total number of pages in the flow graph.
Definition XTPFlowGraphPages.h:154
CXTPFlowGraphPages::FindPage
CXTPFlowGraphPage * FindPage(int nId) const
Finds and retrieves the specified page.
CXTPFlowGraphPages::CXTPFlowGraphPages
CXTPFlowGraphPages(CXTPFlowGraphControl *pControl)
Constructs a CXTPFlowGraphPages object.
CXTPFlowGraphPages::DoPropExchange
void DoPropExchange(CXTPPropExchange *pPX)
Call this member function to store/load a collection of pages using the specified data object.
CXTPFlowGraphPages::m_arrPages
CArray< CXTPFlowGraphPage *, CXTPFlowGraphPage * > m_arrPages
Collection of pages in the flow graph control.
Definition XTPFlowGraphPages.h:130
CXTPFlowGraphPages::m_pControl
CXTPFlowGraphControl * m_pControl
Pointer to the parent flow graph control.
Definition XTPFlowGraphPages.h:132
CXTPFlowGraphPages::GetAt
CXTPFlowGraphPage * GetAt(int nIndex) const
Gets a page at the specified index from the FlowGraph's collection of pages.
Definition XTPFlowGraphPages.h:158
CXTPFlowGraphPages::Remove
void Remove(CXTPFlowGraphPage *pPage)
Removes a page from the FlowGraph.
CXTPFlowGraphPages::~CXTPFlowGraphPages
virtual ~CXTPFlowGraphPages()
Destroys a CXTPFlowGraphPages object, handles cleanup and deallocation.
CXTPFlowGraphPages::RemoveAll
void RemoveAll()
Removes all pages from the flow graph.
CXTPFlowGraphPages::AddPage
CXTPFlowGraphPage * AddPage(CXTPFlowGraphPage *pPage)
Adds a page to the flow graph.
CXTPFlowGraphPages::RemoveAt
void RemoveAt(int nIndex)
Removes the specified page from the FlowGraph.
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72


Toolkit Pro: XTPDockingPaneColorSet2015.h Source File

  • Source
  • DockingPane
  • ColorSets
XTPDockingPaneColorSet2015.h
Go to the documentation of this file.
1
23#if !defined(__XTPDOCKINGPANECOLORSET2015_H__)
24# define __XTPDOCKINGPANECOLORSET2015_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPDockingPaneColorSet2015 : public CXTPDockingPaneColorSet
39{
40public:
47 virtual void RefreshMetrics(CString strSection);
48};
49
50# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
52#endif // !defined(__XTPDOCKINGPANECOLORSET2015_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPDockingPaneColorSet2015
Helper class used to initialize default colors for a theme from an .INI resource.
Definition XTPDockingPaneColorSet2015.h:39
CXTPDockingPaneColorSet2015::RefreshMetrics
virtual void RefreshMetrics(CString strSection)
This member function is used to initialize default colors for a theme from an .INI resource.
CXTPDockingPaneColorSet
Helper class used to initialize default colors for a theme from an .INI resource.
Definition XTPDockingPaneColorSet.h:39


Toolkit Pro: Member List

XTPPROGRESSDRAWSTRUCT Member List

This is the complete list of members for XTPPROGRESSDRAWSTRUCT, including all inherited members.

bFlatStyle | XTPPROGRESSDRAWSTRUCT
bMarquee | XTPPROGRESSDRAWSTRUCT
bSmooth | XTPPROGRESSDRAWSTRUCT
bVertical | XTPPROGRESSDRAWSTRUCT
bVista | XTPPROGRESSDRAWSTRUCT
nPos | XTPPROGRESSDRAWSTRUCT
pDC | XTPPROGRESSDRAWSTRUCT
pFont | XTPPROGRESSDRAWSTRUCT
pWndCtrl | XTPPROGRESSDRAWSTRUCT
range | XTPPROGRESSDRAWSTRUCT
rcClient | XTPPROGRESSDRAWSTRUCT
strText | XTPPROGRESSDRAWSTRUCT


Toolkit Pro: XTPGridDataManager.h Source File

  • Source
  • GridControl
XTPGridDataManager.h
Go to the documentation of this file.
1
23#if !defined(__XTPGRIDDATAMANAGER_H__)
24# define __XTPGRIDDATAMANAGER_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPGridRecord;
34class CXTPGridRecords;
35class CXTPGridRecordItemVariant;
36class CXTPGridDataManager;
37class CXTPGridControl;
38class CXTPGridRecordItem;
39
40# define XTP_GRIDDATAMANAGER_MAX_LAST_COM_ERRORS 3
41
57struct XTP_GRIDDATAMANAGER_COM_ERROR
58{
59 HRESULT hResult;
60 CString strMessage;
61 CString strSource;
67 XTP_GRIDDATAMANAGER_COM_ERROR()
68 {
69 hResult = S_OK;
70 strMessage.Empty();
71 strSource.Empty();
72 }
73
81 const XTP_GRIDDATAMANAGER_COM_ERROR& operator=(const XTP_GRIDDATAMANAGER_COM_ERROR& errorSrc)
82 {
83 this->hResult = errorSrc.hResult;
84 this->strMessage = errorSrc.strMessage;
85 this->strSource = errorSrc.strSource;
86
87 return *this;
88 }
89};
90
91class _XTP_EXT_CLASS CRstEvent : public XTPGRIDADODB::RecordsetEventsVt
92{
93private:
94 ULONG m_cRef;
95 CXTPGridDataManager* m_pDataManager;
96
97public:
98 CRstEvent(CXTPGridDataManager* pDataManager);
99 virtual ~CRstEvent();
100
101 STDMETHODIMP QueryInterface(REFIID riid, void** ppv);
102 STDMETHODIMP_(ULONG) AddRef(void);
103 STDMETHODIMP_(ULONG) Release(void);
104
105 virtual HRESULT __stdcall raw_WillChangeField(long cFields, VARIANT Fields,
106 enum XTPGRIDADODB::EventStatusEnum* adStatus,
107 struct XTPGRIDADODB::_Recordset* pRecordset);
108 virtual HRESULT __stdcall raw_FieldChangeComplete(long cFields, VARIANT Fields,
109 struct XTPGRIDADODB::Error* pError,
110 enum XTPGRIDADODB::EventStatusEnum* adStatus,
111 struct XTPGRIDADODB::_Recordset* pRecordset);
112 virtual HRESULT __stdcall raw_WillChangeRecord(enum XTPGRIDADODB::EventReasonEnum adReason,
113 long cRecords,
114 enum XTPGRIDADODB::EventStatusEnum* adStatus,
115 struct XTPGRIDADODB::_Recordset* pRecordset);
116 virtual HRESULT __stdcall raw_RecordChangeComplete(enum XTPGRIDADODB::EventReasonEnum adReason,
117 long cRecords,
118 struct XTPGRIDADODB::Error* pError,
119 enum XTPGRIDADODB::EventStatusEnum* adStatus,
120 struct XTPGRIDADODB::_Recordset* pRecordset);
121 virtual HRESULT __stdcall raw_WillChangeRecordset(enum XTPGRIDADODB::EventReasonEnum adReason,
122 enum XTPGRIDADODB::EventStatusEnum* adStatus,
123 struct XTPGRIDADODB::_Recordset* pRecordset);
124 virtual HRESULT __stdcall raw_RecordsetChangeComplete(
125 enum XTPGRIDADODB::EventReasonEnum adReason, struct XTPGRIDADODB::Error* pError,
126 enum XTPGRIDADODB::EventStatusEnum* adStatus, struct XTPGRIDADODB::_Recordset* pRecordset);
127 virtual HRESULT __stdcall raw_WillMove(enum XTPGRIDADODB::EventReasonEnum adReason,
128 enum XTPGRIDADODB::EventStatusEnum* adStatus,
129 struct XTPGRIDADODB::_Recordset* pRecordset);
130 virtual HRESULT __stdcall raw_MoveComplete(enum XTPGRIDADODB::EventReasonEnum adReason,
131 struct XTPGRIDADODB::Error* pError,
132 enum XTPGRIDADODB::EventStatusEnum* adStatus,
133 struct XTPGRIDADODB::_Recordset* pRecordset);
134 virtual HRESULT __stdcall raw_EndOfRecordset(VARIANT_BOOL* fMoreData,
135 enum XTPGRIDADODB::EventStatusEnum* adStatus,
136 struct XTPGRIDADODB::_Recordset* pRecordset);
137 virtual HRESULT __stdcall raw_FetchProgress(long Progress, long MaxProgress,
138 enum XTPGRIDADODB::EventStatusEnum* adStatus,
139 struct XTPGRIDADODB::_Recordset* pRecordset);
140 virtual HRESULT __stdcall raw_FetchComplete(struct XTPGRIDADODB::Error* pError,
141 enum XTPGRIDADODB::EventStatusEnum* adStatus,
142 struct XTPGRIDADODB::_Recordset* pRecordset);
143
144protected:
145 CArray<XTPGRIDADODB::EventReasonEnum, XTPGRIDADODB::EventReasonEnum&> m_adReasonStack;
146};
147
152class _XTP_EXT_CLASS CXTPGridDataManager : public CXTPCmdTarget
153{
154 DECLARE_DYNAMIC(CXTPGridDataManager);
155
157 friend class CXTPGridControl;
158 friend class CRstEvent;
159 void AFX_CDECL TRACE_ComError(_com_error& e);
160 void AFX_CDECL TRACE_ProviderError(XTPGRIDADODB::_Connection* pConnDB);
163public:
169 CXTPGridDataManager(CXTPGridControl* pGridControl);
170
175 virtual ~CXTPGridDataManager();
176
183 virtual void SetDataSource(XTPGRIDADODB::_RecordsetPtr pDataSource);
184
191 virtual XTPGRIDADODB::_RecordsetPtr GetDataSource() const;
192
199 virtual BOOL DataBind();
200
207 virtual HRESULT CreateColumns();
208
217 virtual HRESULT UpdateGridRecords(XTPGRIDADODB::_RecordsetPtr pRecordset);
218
228 virtual HRESULT AddGridRecords(XTPGRIDADODB::_RecordsetPtr pRecordset, BOOL bAddNow);
229
238 virtual HRESULT PrepareDeleteGridRecords(XTPGRIDADODB::_RecordsetPtr pRecordset);
239
244 virtual void ClearDeleteGridRecords();
245
252 virtual HRESULT DeleteGridRecords();
253
262 virtual HRESULT DeleteGridRecords(XTPGRIDADODB::_RecordsetPtr pRecordset);
263
272 virtual HRESULT UpdateField(CXTPGridRecordItemVariant* pItem);
273
283 virtual HRESULT UpdateRecord(CXTPGridRecord* pRecord, CXTPGridRecordItem* pItemChanged = NULL);
284
295 virtual HRESULT AddRecord(CXTPGridRecord* pRecord, BOOL bAddToGrid);
296
305 virtual HRESULT CreateEmptyRecord(CXTPGridRecord** ppRecord);
306
315 virtual HRESULT DeleteRecord(CXTPGridRecord* pRecord);
316
323 virtual XTP_GRIDDATAMANAGER_COM_ERROR GetLastComError();
324
325protected:
330 void RemoveDataSource();
335 void ClearGridControl();
336
337protected:
338 CXTPGridControl* m_pGridControl;
339 XTPGRIDADODB::_ConnectionPtr m_pConnection;
340 XTPGRIDADODB::_RecordsetPtr m_pDataSource;
341 CRstEvent* m_pRstEvent;
342 DWORD m_dwRstEvent;
343 CXTPGridRecords* m_pDeleteRecords;
344 BOOL m_bLocalUpdate;
345 CArray<XTP_GRIDDATAMANAGER_COM_ERROR*, XTP_GRIDDATAMANAGER_COM_ERROR*> m_LastComError;
346
347public:
348# ifdef _XTP_ACTIVEX
350 DECLARE_DISPATCH_MAP()
351 DECLARE_INTERFACE_MAP()
352
353 DECLARE_OLETYPELIB_EX(CXTPGridDataManager);
354
355public:
356 static CXTPGridDataManager* AFX_CDECL FromDispatch(LPDISPATCH pDisp);
357 LPDISPATCH OleGetDataSource();
358 void OleSetDataSource(LPDISPATCH lpDispatch);
359 BOOL OleUpdateField(LPDISPATCH lpDispatch);
360 BOOL OleUpdateRecord(LPDISPATCH lpDispatch);
361 BOOL OleUpdateRecordItem(LPDISPATCH lpDispatch);
362 BOOL OleAddRecord(LPDISPATCH lpDispatch, BOOL bAddToGrid);
363 BOOL OleDeleteRecord(LPDISPATCH lpDispatch);
364 LPDISPATCH OleCreateEmptyRecord();
365
367# endif /*_XTP_ACTIVEX*/
368
369// CXTPGridDataManager diagnostics
370# ifdef _DEBUG
371 virtual void AssertValid() const;
372 virtual void Dump(CDumpContext& dc) const;
373 friend _XTP_EXT_CLASS CDumpContext& AFXAPI operator<<(CDumpContext& dc,
374 const CXTPGridDataManager& obj);
375# endif
376
377}; // class _XTP_EXT_CLASS CXTPGridDataManager
378
379AFX_INLINE XTPGRIDADODB::_RecordsetPtr CXTPGridDataManager::GetDataSource() const
380{
381 return m_pDataSource;
382}
383
384# ifdef _DEBUG
385_XTP_EXT_CLASS CDumpContext& AFXAPI operator<<(CDumpContext& dc, const CXTPGridDataManager& obj);
386# endif
388# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
389#endif //#if !defined(__XTPGRIDDATAMANAGER_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPGridControl
The CXTPGridControl class provides an implementation of the Grid control.
Definition XTPGridControl.h:479
CXTPGridDataManager
Represents a grid data manager.
Definition XTPGridDataManager.h:153
CXTPGridDataManager::~CXTPGridDataManager
virtual ~CXTPGridDataManager()
Destroys a CXTPGridDataManager object, handles cleanup and deallocation.
CXTPGridDataManager::DeleteGridRecords
virtual HRESULT DeleteGridRecords(XTPGRIDADODB::_RecordsetPtr pRecordset)
Deletes the grid records.
CXTPGridDataManager::DeleteGridRecords
virtual HRESULT DeleteGridRecords()
Deletes the grid records.
CXTPGridDataManager::CreateColumns
virtual HRESULT CreateColumns()
Creates the columns based on the fields.
CXTPGridDataManager::AddGridRecords
virtual HRESULT AddGridRecords(XTPGRIDADODB::_RecordsetPtr pRecordset, BOOL bAddNow)
Adds a record to the Grid control.
CXTPGridDataManager::m_dwRstEvent
DWORD m_dwRstEvent
The record set event.
Definition XTPGridDataManager.h:342
CXTPGridDataManager::PrepareDeleteGridRecords
virtual HRESULT PrepareDeleteGridRecords(XTPGRIDADODB::_RecordsetPtr pRecordset)
Performs preperation for the deletion of grid records.
CXTPGridDataManager::ClearGridControl
void ClearGridControl()
Clears the Grid control.
CXTPGridDataManager::m_pGridControl
CXTPGridControl * m_pGridControl
Pointer to the Grid control.
Definition XTPGridDataManager.h:338
CXTPGridDataManager::DataBind
virtual BOOL DataBind()
Binds the data (i.e.
CXTPGridDataManager::RemoveDataSource
void RemoveDataSource()
Removes the data source.
CXTPGridDataManager::ClearDeleteGridRecords
virtual void ClearDeleteGridRecords()
Clears deleted records.
CXTPGridDataManager::UpdateRecord
virtual HRESULT UpdateRecord(CXTPGridRecord *pRecord, CXTPGridRecordItem *pItemChanged=NULL)
Updates a grid record.
CXTPGridDataManager::m_bLocalUpdate
BOOL m_bLocalUpdate
Tells whether the update is local only.
Definition XTPGridDataManager.h:344
CXTPGridDataManager::m_pRstEvent
CRstEvent * m_pRstEvent
Pointer to the record set event object.
Definition XTPGridDataManager.h:341
CXTPGridDataManager::m_pConnection
XTPGRIDADODB::_ConnectionPtr m_pConnection
The custom ADODB connection point.
Definition XTPGridDataManager.h:339
CXTPGridDataManager::GetDataSource
virtual XTPGRIDADODB::_RecordsetPtr GetDataSource() const
Gets the data source.
Definition XTPGridDataManager.h:379
CXTPGridDataManager::CXTPGridDataManager
CXTPGridDataManager(CXTPGridControl *pGridControl)
Constructs a CXTPGridDataManager object.
CXTPGridDataManager::GetLastComError
virtual XTP_GRIDDATAMANAGER_COM_ERROR GetLastComError()
Gets the last COM error.
CXTPGridDataManager::m_pDeleteRecords
CXTPGridRecords * m_pDeleteRecords
The delete records.
Definition XTPGridDataManager.h:343
CXTPGridDataManager::m_pDataSource
XTPGRIDADODB::_RecordsetPtr m_pDataSource
The data source.
Definition XTPGridDataManager.h:340
CXTPGridDataManager::CreateEmptyRecord
virtual HRESULT CreateEmptyRecord(CXTPGridRecord **ppRecord)
Creates an empty record.
CXTPGridDataManager::AddRecord
virtual HRESULT AddRecord(CXTPGridRecord *pRecord, BOOL bAddToGrid)
Adds a record.
CXTPGridDataManager::UpdateGridRecords
virtual HRESULT UpdateGridRecords(XTPGRIDADODB::_RecordsetPtr pRecordset)
Updates the grid records.
CXTPGridDataManager::DeleteRecord
virtual HRESULT DeleteRecord(CXTPGridRecord *pRecord)
Deletes a record.
CXTPGridDataManager::UpdateField
virtual HRESULT UpdateField(CXTPGridRecordItemVariant *pItem)
Updates a field.
CXTPGridDataManager::SetDataSource
virtual void SetDataSource(XTPGRIDADODB::_RecordsetPtr pDataSource)
Sets the data source.
CXTPGridRecord
CXTPGridRecord represents a collection of CXTPGridRecordItem objects or objects of classes that are c...
Definition XTPGridRecord.h:59
CXTPGridRecordItem
Class for working with single list cell.
Definition XTPGridRecordItem.h:600
CXTPGridRecordItemVariant
Represents a variant item and inherits basic functionality from the CXTPGridRecordItem class.
Definition XTPGridRecordItemVariant.h:44
CXTPGridRecords
This class represents a grid records collection.
Definition XTPGridRecords.h:71
XTP_GRIDDATAMANAGER_COM_ERROR
Basic set of parameters transferred to item handlers.
Definition XTPGridDataManager.h:58
XTP_GRIDDATAMANAGER_COM_ERROR::XTP_GRIDDATAMANAGER_COM_ERROR
XTP_GRIDDATAMANAGER_COM_ERROR()
Performs default error object construction.
Definition XTPGridDataManager.h:67
XTP_GRIDDATAMANAGER_COM_ERROR::hResult
HRESULT hResult
The HRESULT error value.
Definition XTPGridDataManager.h:59
XTP_GRIDDATAMANAGER_COM_ERROR::strMessage
CString strMessage
The error message.
Definition XTPGridDataManager.h:60
XTP_GRIDDATAMANAGER_COM_ERROR::operator=
const XTP_GRIDDATAMANAGER_COM_ERROR & operator=(const XTP_GRIDDATAMANAGER_COM_ERROR &errorSrc)
Overloaded assignment operator.
Definition XTPGridDataManager.h:81
XTP_GRIDDATAMANAGER_COM_ERROR::strSource
CString strSource
The error source.
Definition XTPGridDataManager.h:61


Toolkit Pro: Member List

IXTPApplicationEvents Member List

This is the complete list of members for IXTPApplicationEvents, including all inherited members.

OnAfterApplicationShutdown(CXTPApplication *pApplication) | IXTPApplicationEvents | inlinevirtual
OnAmbientPropertyChanged(CXTPApplication *pApplication, XTPApplicationAmbientProperty nProperty) | IXTPApplicationEvents | inlinevirtual
OnApplicationShutdown(CXTPApplication *pApplication) | IXTPApplicationEvents | inlinevirtual
OnBeforeApplicationShutdown(CXTPApplication *pApplication) | IXTPApplicationEvents | inlinevirtual
~IXTPApplicationEvents() | IXTPApplicationEvents | inlinevirtual


Toolkit Pro: Member List

CXTPDockingPaneOffice2007Theme Member List

This is the complete list of members for CXTPDockingPaneOffice2007Theme, including all inherited members.

AdjustCaptionRect(const CXTPDockingPaneSidePanel *pPane, CRect &rc) | CXTPDockingPanePaintManager | virtual
AdjustCaptionRect(const CXTPDockingPaneTabbedContainer *pPane, CRect &rc) | CXTPDockingPanePaintManager | virtual
AdjustClientRect(CXTPDockingPaneSidePanel *pPane, CRect &rect) | CXTPDockingPanePaintManager | virtual
AdjustClientRect(CXTPDockingPaneTabbedContainer *pPane, CRect &rect, BOOL bApply) | CXTPDockingPanePaintManager | virtual
ClipAndAddEllipsisIfNeeded(CDC *pDC, CString &strTitle, int nCaptionWidth) const | CXTPDockingPanePaintManager | protected
CXTPCmdTarget() | CXTPCmdTarget |
CXTPDockingPaneDefaultTheme() | CXTPDockingPaneDefaultTheme |
CXTPDockingPaneGripperedTheme() | CXTPDockingPaneGripperedTheme |
CXTPDockingPaneOffice2003Theme() | CXTPDockingPaneOffice2003Theme |
CXTPDockingPaneOffice2007Theme() | CXTPDockingPaneOffice2007Theme |
CXTPDockingPanePaintManager() | CXTPDockingPanePaintManager | protected
CXTPDockingPaneVisualStudio2003Theme() | CXTPDockingPaneVisualStudio2003Theme |
DrawAutoHidePanel(CDC *pDC, CRect rc, XTPDockingPaneDirection direction) | CXTPDockingPanePaintManager | virtual
DrawCaption(CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc) | CXTPDockingPaneOffice2007Theme | virtual
DrawCaptionButton(CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton) | CXTPDockingPanePaintManager | virtual
DrawCaptionButtonEntry(CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton, CSize szOffset) | CXTPDockingPanePaintManager | protectedvirtual
DrawCaptionButtonEntry(CDC *pDC, CXTPDockingPaneCaptionButton *pButton, CPoint pt, COLORREF clrButton) | CXTPDockingPanePaintManager | protectedvirtual
DrawCaptionButtons(CDC *pDC, CXTPDockingPaneCaptionButtons *pButtons, CRect &rcCaption, COLORREF clr, int nButtonSize, int nButtonGap, BOOL bVertical=FALSE) | CXTPDockingPanePaintManager | virtual
DrawCaptionPart(CDC *pDC, CXTPDockingPaneBase *pPane, CRect rcCaption, const CString &strTitle, BOOL bActive, BOOL bVertical) | CXTPDockingPaneOffice2003Theme | protectedvirtual
DrawCaptionText(CDC *pDC, const CString &strTitle, CRect rc, BOOL bVertical, BOOL bCalcWidth=FALSE) | CXTPDockingPanePaintManager |
DrawFloatingFrame(CDC *pDC, CXTPDockingPaneMiniWnd *pPane, CRect rc) | CXTPDockingPaneOffice2003Theme | virtual
DrawPane(CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc) | CXTPDockingPanePaintManager | virtual
DrawSidePanel(CDC *pDC, CXTPDockingPaneSidePanel *pPane, CRect rc) | CXTPDockingPaneOffice2003Theme | virtual
DrawSplitter(CDC *pDC, CXTPDockingPaneSplitterWnd *pSplitter) | CXTPDockingPanePaintManager | virtual
FillCaptionPart(CDC *pDC, CXTPDockingPaneBase *pPane, CRect rcCaption, BOOL bActive, BOOL bVertical) | CXTPDockingPaneVisualStudio2003Theme | protectedvirtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCaptionButtonStyle() const | CXTPDockingPanePaintManager |
GetCaptionGripperRect(const CXTPDockingPaneTabbedContainer *pPane) | CXTPDockingPaneOffice2003Theme | virtual
GetCaptionHeight() const | CXTPDockingPanePaintManager |
GetCaptionRect(const CXTPDockingPaneTabbedContainer *pPane, CRect &rc) | CXTPDockingPanePaintManager | virtual
GetCurrentSystemTheme() const | CXTPDockingPanePaintManager |
GetCustomTitleBrush(BOOL bActive, BOOL bVertical) const | CXTPDockingPanePaintManager |
GetPaneCaptionRect(const CXTPDockingPaneSidePanel *pPane) | CXTPDockingPaneOffice2003Theme | virtual
GetPanelPaintManager() const | CXTPDockingPanePaintManager |
GetSplitterStyle() const | CXTPDockingPanePaintManager |
GetTabPaintManager() const | CXTPDockingPanePaintManager |
GetTabsHeight() const | CXTPDockingPanePaintManager |
GetXtremeColor(UINT nIndex) | CXTPDockingPanePaintManager |
Line(CDC *pDC, int x0, int y0, int x1, int y1, int nPen) | CXTPDockingPanePaintManager |
Line(CDC *pDC, int x0, int y0, int x1, int y1) | CXTPDockingPanePaintManager |
m_arrColor | CXTPDockingPanePaintManager | protected
m_bDestroyCustomTitleBrushes | CXTPDockingPanePaintManager | protected
m_bDrawCaptionIcon | CXTPDockingPanePaintManager |
m_bDrawGripper | CXTPDockingPaneOffice2003Theme |
m_bDrawSingleTab | CXTPDockingPanePaintManager |
m_bGradientCaption | CXTPDockingPaneVisualStudio2003Theme | protected
m_bHighlightActiveCaption | CXTPDockingPanePaintManager |
m_bLunaTheme | CXTPDockingPanePaintManager | protected
m_bRoundedCaption | CXTPDockingPaneOffice2003Theme | protected
m_bShowCaption | CXTPDockingPanePaintManager |
m_bUseBoldCaptionFont | CXTPDockingPanePaintManager |
m_bUseOfficeFont | CXTPDockingPanePaintManager | protected
m_bUseStandardFont | CXTPDockingPanePaintManager | protected
m_clrActiveCaption | CXTPDockingPanePaintManager |
m_clrActiveCaptionText | CXTPDockingPanePaintManager |
m_clrBackground | CXTPDockingPanePaintManager |
m_clrDisabledCaptionText | CXTPDockingPanePaintManager |
m_clrNormalCaption | CXTPDockingPanePaintManager |
m_clrNormalCaptionText | CXTPDockingPanePaintManager |
m_clrSplitter | CXTPDockingPanePaintManager |
m_clrSplitterGradient | CXTPDockingPanePaintManager |
m_clrSplitterGripper | CXTPDockingPanePaintManager |
m_dwSplitterStyle | CXTPDockingPanePaintManager | protected
m_hbrActiveTitleHorz | CXTPDockingPanePaintManager | protected
m_hbrActiveTitleVert | CXTPDockingPanePaintManager | protected
m_hbrInactiveTitleHorz | CXTPDockingPanePaintManager | protected
m_hbrInactiveTitleVert | CXTPDockingPanePaintManager | protected
m_nCaptionButtonStyle | CXTPDockingPanePaintManager | protected
m_nCaptionFontGap | CXTPDockingPanePaintManager | protected
m_nSplitterIndent | CXTPDockingPanePaintManager |
m_nSplitterSize | CXTPDockingPanePaintManager |
m_nTabsHeight | CXTPDockingPanePaintManager | protected
m_nTitleHeight | CXTPDockingPanePaintManager | protected
m_pPanelPaintManager | CXTPDockingPanePaintManager | protected
m_pTabPaintManager | CXTPDockingPanePaintManager | protected
m_rcCaptionMargin | CXTPDockingPanePaintManager | protected
m_strOfficeFont | CXTPDockingPanePaintManager | protected
m_systemTheme | CXTPDockingPanePaintManager | protected
m_themeButton | CXTPDockingPanePaintManager | protected
m_themeCurrent | CXTPDockingPanePaintManager | protected
m_themeExplorer | CXTPDockingPanePaintManager | protected
m_themeRebar | CXTPDockingPanePaintManager | protected
m_themeToolbar | CXTPDockingPanePaintManager | protected
m_themeWindow | CXTPDockingPanePaintManager | protected
m_xtpFontTitle | CXTPDockingPanePaintManager | protected
m_xtpFontTitleVertical | CXTPDockingPanePaintManager | protected
Pixel(CDC *pDC, int xPos, int yPos, int nPen) | CXTPDockingPanePaintManager |
Rectangle(CDC *pDC, CRect rc, int nPenEntry, int nPenBorder) | CXTPDockingPanePaintManager |
RefreshMetrics() | CXTPDockingPaneOffice2007Theme | virtual
SetCaptionButtonStyle(XTPDockingPaneCaptionButtonStyle nStyle) | CXTPDockingPanePaintManager |
SetCaptionFontIndirect(LOGFONT *pLogFont, BOOL bUseStandardFont=FALSE) | CXTPDockingPanePaintManager |
SetColors(int cElements, CONST INT *lpaElements, CONST COLORREF *lpaRgbValues) | CXTPDockingPanePaintManager |
SetCustomTitleBrushes(HBRUSH hbrActiveTitleHorz, HBRUSH hbrInactiveTitleHorz=NULL, HBRUSH hbrActiveTitleVert=NULL, HBRUSH hbrInactiveTitleVert=NULL, BOOL bDestroyOnCleanup=FALSE) | CXTPDockingPanePaintManager |
SetLunaTheme(XTPCurrentSystemTheme systemTheme) | CXTPDockingPanePaintManager |
SetPanelPaintManager(CXTPTabPaintManager *pManager) | CXTPDockingPanePaintManager |
SetSplitterStyle(DWORD dwStyle) | CXTPDockingPanePaintManager |
SetTabPaintManager(CXTPTabPaintManager *pManager) | CXTPDockingPanePaintManager |
UseOfficeFont(BOOL bUseOfficeFont) | CXTPDockingPanePaintManager |
~CXTPDockingPaneOffice2003Theme() | CXTPDockingPaneOffice2003Theme | virtual
~CXTPDockingPanePaintManager() | CXTPDockingPanePaintManager | protectedvirtual


Toolkit Pro: Member List

CXTPExcelTabCtrlThemeVisualStudio2015 Member List

This is the complete list of members for CXTPExcelTabCtrlThemeVisualStudio2015, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPControlTheme() | CXTPControlTheme |
CXTPExcelTabCtrlTheme() | CXTPExcelTabCtrlTheme |
CXTPExcelTabCtrlThemeOffice2013() | CXTPExcelTabCtrlThemeOffice2013 |
CXTPExcelTabCtrlThemeVisualStudio2015() | CXTPExcelTabCtrlThemeVisualStudio2015 |
DrawButton(CDC *pDC, CXTPExcelTabCtrl *pTabCtrl, const CXTPExcelTabCtrlButtonState &state) | CXTPExcelTabCtrlThemeOffice2013 | virtual
DrawButtonBack(CDC *pDC, CRect &rect, const CXTPExcelTabCtrlButtonState &state) | CXTPExcelTabCtrlThemeOffice2013 | virtual
DrawGripper(CDC *pDC, CRect rect) | CXTPExcelTabCtrlThemeOffice2013 | virtual
DrawTab(CDC *pDC, CXTPExcelTabCtrl *pTabCtrl, const CPoint &pt, bool bSelected, CXTPTcbItem *pTcbItem) | CXTPExcelTabCtrlThemeOffice2013 | virtual
FillBackground(CDC *pDC, CRect &rect, BOOL bBottom) | CXTPExcelTabCtrlThemeOffice2013 | virtual
FillTabsBackground(CDC *pDC, int cx, int cy) | CXTPExcelTabCtrlThemeOffice2013 | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetSelTabBackColor(CXTPTcbItem *pTcbItem) const | CXTPExcelTabCtrlTheme | virtual
GetSelTabTextColor(CXTPTcbItem *pTcbItem) const | CXTPExcelTabCtrlTheme | virtual
GetTabBackColor(CXTPTcbItem *pTcbItem) const | CXTPExcelTabCtrlTheme | virtual
GetTabTextColor(CXTPTcbItem *pTcbItem) const | CXTPExcelTabCtrlTheme | virtual
GetThemeStyle() const | CXTPControlTheme |
m_clr3DFace | CXTPExcelTabCtrlTheme |
m_clr3DFaceHilite | CXTPExcelTabCtrlTheme |
m_clr3DFacePushed | CXTPExcelTabCtrlTheme |
m_clr3DHilight | CXTPExcelTabCtrlTheme |
m_clr3DShadow | CXTPExcelTabCtrlTheme |
m_clrBorder3DHilite | CXTPExcelTabCtrlTheme |
m_clrBorder3DShadow | CXTPExcelTabCtrlTheme |
m_clrBtnText | CXTPExcelTabCtrlTheme |
m_clrBtnTextGray | CXTPExcelTabCtrlTheme |
m_clrBtnTextHilite | CXTPExcelTabCtrlTheme |
m_clrBtnTextPushed | CXTPExcelTabCtrlTheme |
m_clrWindow | CXTPExcelTabCtrlTheme |
m_clrWindowText | CXTPExcelTabCtrlTheme |
m_nTheme | CXTPControlTheme | protected
RefreshMetrics(CXTPExcelTabCtrl *pTab) | CXTPExcelTabCtrlThemeOffice2013 | virtual
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static
~CXTPExcelTabCtrlTheme() | CXTPExcelTabCtrlTheme |


Toolkit Pro: Member List

CXTPImageManagerResource Member List

This is the complete list of members for CXTPImageManagerResource, including all inherited members.

Add(const CXTPImageManagerIconHandle &hHandle) | CXTPImageManagerResource |
Clear(XTP_IMAGERESOURCE_INFO *pRInfo) | CXTPImageManagerResource |
CreateIcon(CXTPImageManagerIconHandle &hHandle, XTP_IMAGERESOURCE_INFO *pRInfo) | CXTPImageManagerResource |
CXTPImageManagerResource(CXTPImageManager *pImageManager, CSize szIcon) | CXTPImageManagerResource |
Draw(CDC *pDC, XTP_IMAGERESOURCE_INFO *pRInfo, CPoint pt, CSize szIcon, BOOL bDrawComposited) | CXTPImageManagerResource |
GetExtent() const | CXTPImageManagerResource |
m_arrAlloc | CXTPImageManagerResource | protected
m_arrIcons | CXTPImageManagerResource | protected
m_cs | CXTPImageManagerResource | protected
m_dc | CXTPImageManagerResource | protected
m_hbmpImage | CXTPImageManagerResource | protected
m_hbmpMask | CXTPImageManagerResource | protected
m_nAllocWidth | CXTPImageManagerResource | protected
m_pBits | CXTPImageManagerResource | protected
m_pImageManager | CXTPImageManagerResource | protected
m_szIcon | CXTPImageManagerResource | protected
~CXTPImageManagerResource() | CXTPImageManagerResource |


Toolkit Pro: Member List

CXTPChartLineSeriesStyle Member List

This is the complete list of members for CXTPChartLineSeriesStyle, including all inherited members.

ApplyTo(CXTPChartDeviceCommand *pCommand) | CXTPChartSeriesStyle | virtual
CorrectAxisSideMargins(CXTPChartAxis *pAxis, double nMinValue, double nMaxValue, double &nCorrection) | CXTPChartSeriesStyle | virtual
CreateDiagram() | CXTPChartDiagram2DSeriesStyle | virtual
CreateView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView) | CXTPChartLineSeriesStyle | protectedvirtual
CXTPChartDiagram2DSeriesStyle() | CXTPChartDiagram2DSeriesStyle |
CXTPChartElement() | CXTPChartElement |
CXTPChartLineSeriesStyle() | CXTPChartLineSeriesStyle |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartPointSeriesStyle() | CXTPChartPointSeriesStyle |
CXTPChartSeriesStyle() | CXTPChartSeriesStyle |
DoPropExchange(CXTPPropExchange *pPX) | CXTPChartLineSeriesStyle | protectedvirtual
Enable3dEdgeSmoothing(BOOL bEnable=TRUE) | CXTPChartSeriesStyle | virtual
Get3dRotation() const | CXTPChartSeriesStyle | virtual
GetAppearance() const | CXTPChartElement |
GetColor() const | CXTPChartSeriesStyle | virtual
GetContent() const | CXTPChartElement |
GetErrorBar() const | CXTPChartSeriesStyle | virtual
GetLabel() const | CXTPChartSeriesStyle | virtual
GetLineStyle() const | CXTPChartLineSeriesStyle |
GetMarker() const | CXTPChartPointSeriesStyle |
GetOwner() const | CXTPChartElement |
GetSeriesPointValueIndex() const | CXTPChartSeriesStyle | virtual
GetStyleAppearance() const | CXTPChartSeriesStyle | virtual
GetTransparency() const | CXTPChartSeriesStyle | virtual
Is3D() const | CXTPChartObject |
Is3dEdgeSmoothingEnabled() const | CXTPChartSeriesStyle | virtual
IsColorEach() const | CXTPChartSeriesStyle | virtual
IsStyleDiagram(CXTPChartDiagram *pDiagram) const | CXTPChartDiagram2DSeriesStyle | virtual
m_bColorEach | CXTPChartSeriesStyle | protected
m_bSmooth3dEdges | CXTPChartSeriesStyle | protected
m_clrColor | CXTPChartSeriesStyle | protected
m_nAxisIndexX | CXTPChartDiagram2DSeriesStyle | protected
m_nAxisIndexY | CXTPChartDiagram2DSeriesStyle | protected
m_nTransparency | CXTPChartSeriesStyle | protected
m_pErrorBar | CXTPChartSeriesStyle | protected
m_pLabel | CXTPChartSeriesStyle | protected
m_pLineStyle | CXTPChartLineSeriesStyle | protected
m_Rotation3d | CXTPChartSeriesStyle | protected
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartElement | virtual
Release() | CXTPChartElement | virtual
Set3dRotation(const CXTPChart3dRotation &rotation) | CXTPChartSeriesStyle | virtual
Set3dRotation(double dYaw, double dPitch, double dRoll) | CXTPChartSeriesStyle | virtual
SetColor(CXTPChartColor clr) | CXTPChartSeriesStyle | virtual
SetColorEach(BOOL bColorEach) | CXTPChartSeriesStyle | virtual
SetErrorBar(CXTPChartErrorBar *pErrorBar) | CXTPChartSeriesStyle | virtual
SetLabel(CXTPChartSeriesLabel *pLabel) | CXTPChartSeriesStyle | virtual
SetTransparency(int nTransparency) | CXTPChartSeriesStyle | virtual
~CXTPChartDiagram2DSeriesStyle() | CXTPChartDiagram2DSeriesStyle | virtual
~CXTPChartElement() | CXTPChartElement | virtual
~CXTPChartLineSeriesStyle() | CXTPChartLineSeriesStyle | virtual
~CXTPChartPointSeriesStyle() | CXTPChartPointSeriesStyle | virtual
~CXTPChartSeriesStyle() | CXTPChartSeriesStyle | virtual


Toolkit Pro: Member List

  • CXTPCalendarView
  • CSelectionChanged_ContextData
CXTPCalendarView::CSelectionChanged_ContextData Member List

This is the complete list of members for CXTPCalendarView::CSelectionChanged_ContextData, including all inherited members.

CSelectionChanged_ContextData() | CXTPCalendarView::CSelectionChanged_ContextData
m_bRequest_Day | CXTPCalendarView::CSelectionChanged_ContextData
m_bRequest_Event | CXTPCalendarView::CSelectionChanged_ContextData
m_nLockCount | CXTPCalendarView::CSelectionChanged_ContextData
m_nLockCount_Day | CXTPCalendarView::CSelectionChanged_ContextData
m_nLockCount_Event | CXTPCalendarView::CSelectionChanged_ContextData


Toolkit Pro: Member List

CXTPChartCandleStickSeriesView Member List

This is the complete list of members for CXTPChartCandleStickSeriesView, including all inherited members.

AddChildView(CXTPChartElementView *pChildView) | CXTPChartElementView |
CreateDeviceCommand(CXTPChartDeviceContext *pDC) | CXTPChartElementView | virtual
CreateLegendDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcBounds) | CXTPChartCandleStickSeriesView | protectedvirtual
CreateSeriesPointView(CXTPChartDeviceContext *pDC, CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView) | CXTPChartCandleStickSeriesView | protected
CXTPChartCandleStickSeriesView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView) | CXTPChartCandleStickSeriesView |
CXTPChartElementView(CXTPChartElementView *pParentView) | CXTPChartElementView |
CXTPChartElementView(CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartElementView |
CXTPChartElementView(CXTPChartContainer *pContainer) | CXTPChartElementView |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
GetAt(int nIndex) const | CXTPChartElementView |
GetBounds() const | CXTPChartElementView |
GetBounds(BOOL bIncludingChildren) const | CXTPChartElementView |
GetChildren() | CXTPChartElementView |
GetCount() const | CXTPChartElementView |
GetParentView() const | CXTPChartElementView |
Is3D() const | CXTPChartObject |
m_arrChildren | CXTPChartElementView | protected
m_pContainer | CXTPChartElementView | protected
m_pParentView | CXTPChartElementView | protected
m_rcBounds | CXTPChartElementView | protected
~CXTPChartElementView() | CXTPChartElementView | protectedvirtual
~CXTPChartLegendItemView() | CXTPChartLegendItemView | inlinevirtual


Toolkit Pro: XTPStatusBarThemeResource.h Source File

  • Source
  • CommandBars
  • StatusBar
XTPStatusBarThemeResource.h
Go to the documentation of this file.
1
23#if !defined(__XTPSTATUSBARTHEMERESOURCE_H__)
24# define __XTPSTATUSBARTHEMERESOURCE_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPResourceTheme;
34
35class _XTP_EXT_CLASS CXTPStatusBarThemeResource : public CXTPStatusBarPaintManager
36{
37public:
38 CXTPStatusBarThemeResource(CXTPResourceTheme* pTheme);
39
46 virtual void FillStatusBar(CDC* pDC, CXTPStatusBar* pBar);
47
56 virtual void DrawStatusBarPaneBorder(CDC* pDC, CRect rc, CXTPStatusBarPane* pPane,
57 BOOL bGripperPane);
58
65 virtual void DrawStatusBarGripper(CDC* pDC, CRect rcClient);
66
71 virtual void RefreshMetrics();
72
73protected:
74 CXTPResourceTheme* m_pTheme;
75};
76
78# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
79#endif // !defined(__XTPSTATUSBARTHEMERESOURCE_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPResourceTheme
The CXTPResourceTheme class is used to enable a resource style theme for Command Bars.
Definition XTPCommandBarsResourceTheme.h:46
CXTPStatusBar
CXTPStatusBar is a CControlBar derived class.
Definition XTPStatusBar.h:52
CXTPStatusBarPane
CXTPStatusBarPane is a CXTPCmdTarget derived class.
Definition XTPStatusBarPane.h:39


Toolkit Pro: Member List

CXTPMarkupToggleButton Member List

This is the complete list of members for CXTPMarkupToggleButton, including all inherited members.

ApplyRenderTransform(CXTPMarkupDrawingContext *pContext) | CXTPMarkupUIElement | protectedvirtual
Arrange(CRect rcFinalRect) | CXTPMarkupUIElement |
ArrangeCore(CRect rcFinalRect) | CXTPMarkupUIElement | protectedvirtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPMarkupButtonBase() | CXTPMarkupButtonBase | protected
CXTPMarkupContentControl() | CXTPMarkupContentControl | protected
CXTPMarkupFrameworkElement() | CXTPMarkupFrameworkElement | protected
CXTPMarkupUIElement() | CXTPMarkupUIElement | protected
CXTPMarkupVisual() | CXTPMarkupVisual |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAbsoluteVisualOffset() const | CXTPMarkupVisual | protected
GetActualSize() const | CXTPMarkupFrameworkElement |
GetBackground() const | CXTPMarkupControl |
GetBoundRect() const | CXTPMarkupVisual |
GetChecked() const | CXTPMarkupToggleButton |
GetClipToBounds() const | CXTPMarkupFrameworkElement |
GetContent() const | CXTPMarkupContentControl |
GetDesiredSize() const | CXTPMarkupUIElement |
GetFinalRect() const | CXTPMarkupUIElement |
GetForeground() const | CXTPMarkupControl |
GetHeight() const | CXTPMarkupFrameworkElement |
GetHorizontalAlignment() const | CXTPMarkupFrameworkElement |
GetLayoutClip(CRect &rc) const | CXTPMarkupUIElement | protectedvirtual
GetLogicalChild(int nIndex) const | CXTPMarkupVisual | virtual
GetLogicalChildrenCount() const | CXTPMarkupVisual | virtual
GetMargin() const | CXTPMarkupFrameworkElement |
GetMaxHeight() const | CXTPMarkupFrameworkElement |
GetMaxWidth() const | CXTPMarkupFrameworkElement |
GetMinHeight() const | CXTPMarkupFrameworkElement |
GetMinWidth() const | CXTPMarkupFrameworkElement |
GetOpacity() const | CXTPMarkupUIElement | protectedvirtual
GetPadding() const | CXTPMarkupControl |
GetRenderSize() const | CXTPMarkupVisual |
GetRenderTransform() const | CXTPMarkupUIElement | protected
GetStyle() const | CXTPMarkupFrameworkElement |
GetTag() const | CXTPMarkupFrameworkElement |
GetUpdateRect() const | CXTPMarkupVisual |
GetVerticalAlignment() const | CXTPMarkupFrameworkElement |
GetVisibility() const | CXTPMarkupUIElement |
GetVisualChild(int nIndex) const | CXTPMarkupVisual | virtual
GetVisualChildrenCount() const | CXTPMarkupVisual | virtual
GetVisualOffset() const | CXTPMarkupVisual |
GetVisualParent() const | CXTPMarkupVisual |
GetWidth() const | CXTPMarkupFrameworkElement |
InputHitTest(CPoint point) const | CXTPMarkupVisual |
InputHitTestOverride(CPoint point) const | CXTPMarkupVisual | protectedvirtual
InvalidateArrange() | CXTPMarkupUIElement | virtual
InvalidateMeasure() | CXTPMarkupUIElement | virtual
InvalidateMeasureOverride(CXTPMarkupDrawingContext *pDC) | CXTPMarkupUIElement | protectedvirtual
InvalidateVisual() | CXTPMarkupUIElement | virtual
IsEnabled() const | CXTPMarkupUIElement |
IsFocusable() const | CXTPMarkupUIElement |
IsPressed() const | CXTPMarkupButtonBase |
IsThreeState() const | CXTPMarkupToggleButton |
IsVisible() const | CXTPMarkupUIElement | virtual
m_bArrangeDirty | CXTPMarkupUIElement | protected
m_bArrangeInProgress | CXTPMarkupUIElement | protected
m_bMeasureDirty | CXTPMarkupUIElement | protected
m_bMeasureInProgress | CXTPMarkupUIElement | protected
m_bNeverArranged | CXTPMarkupUIElement | protected
m_bNeverMeasured | CXTPMarkupUIElement | protected
m_pClipToBoundsProperty | CXTPMarkupUIElement | static
m_pFocusableProperty | CXTPMarkupUIElement | static
m_pIsEnabledProperty | CXTPMarkupUIElement | static
m_pOpacityProperty | CXTPMarkupUIElement | static
m_pRenderTransformOriginProperty | CXTPMarkupUIElement | static
m_pRenderTransformProperty | CXTPMarkupUIElement | static
m_ptVisualOffset | CXTPMarkupVisual | protected
m_pVisibilityProperty | CXTPMarkupUIElement | static
m_rcBoundRect | CXTPMarkupVisual | protected
m_rcFinalRect | CXTPMarkupUIElement | protected
m_rcPrevUpdateRect | CXTPMarkupVisual | protected
m_rcUpdateRect | CXTPMarkupVisual | protected
m_szDesiredSize | CXTPMarkupUIElement | protected
m_szPreviousAvailableSize | CXTPMarkupUIElement | protected
m_szRenderSize | CXTPMarkupVisual | protected
Measure(CXTPMarkupDrawingContext *pDC, CSize szAvailableSize) | CXTPMarkupUIElement |
MeasureCore(CXTPMarkupDrawingContext *pDC, CSize szAvailableSize) | CXTPMarkupUIElement | protectedvirtual
OnChecked(CXTPMarkupRoutedEventArgs *e) | CXTPMarkupToggleButton | protectedvirtual
OnClick() | CXTPMarkupToggleButton | protectedvirtual
OnIndeterminate(CXTPMarkupRoutedEventArgs *e) | CXTPMarkupToggleButton | protectedvirtual
OnRender(CXTPMarkupDrawingContext *drawingContext) | CXTPMarkupVisual | protectedvirtual
OnRenderFocusVisual(CXTPMarkupDrawingContext *drawingContext) | CXTPMarkupVisual | protectedvirtual
OnToggle() | CXTPMarkupToggleButton | protectedvirtual
OnUnchecked(CXTPMarkupRoutedEventArgs *e) | CXTPMarkupToggleButton | protectedvirtual
PtInRectTransform(const RECT &rect, const POINT &point) const | CXTPMarkupVisual | protected
Render(CXTPMarkupDrawingContext *drawingContext) | CXTPMarkupVisual |
RenderClipped(CXTPMarkupDrawingContext *drawingContext) | CXTPMarkupVisual | protectedvirtual
RestoreRenderTransform(CXTPMarkupDrawingContext *pContext, TransformationMatrices &matrices) | CXTPMarkupUIElement | protectedvirtual
SetBackground(CXTPMarkupBrush *pBrush) | CXTPMarkupControl |
SetChecked(BOOL bChecked) | CXTPMarkupToggleButton |
SetClipToBounds(BOOL bClipToBounds) | CXTPMarkupFrameworkElement |
SetContent(CXTPMarkupUIElement *pContent) | CXTPMarkupContentControl |
SetForeground(CXTPMarkupBrush *pBrush) | CXTPMarkupControl |
SetHeight(int nHeight) | CXTPMarkupFrameworkElement |
SetHorizontalAlignment(XTPMarkupHorizontalAlignment alignment) | CXTPMarkupFrameworkElement |
SetMargin(int nLeft, int nTop, int nRight, int nBottom) | CXTPMarkupFrameworkElement |
SetMargin(int nMargin) | CXTPMarkupFrameworkElement |
SetMaxHeight(int nHeight) | CXTPMarkupFrameworkElement |
SetMaxWidth(int nWidth) | CXTPMarkupFrameworkElement |
SetMinHeight(int nHeight) | CXTPMarkupFrameworkElement |
SetMinWidth(int nWidth) | CXTPMarkupFrameworkElement |
SetPadding(int nLeft, int nTop, int nRight, int nBottom) | CXTPMarkupControl |
SetPadding(int nPadding) | CXTPMarkupControl |
SetTag(CXTPMarkupObject *pTag) | CXTPMarkupFrameworkElement |
SetThreeState(BOOL bThreeState) | CXTPMarkupToggleButton |
SetVerticalAlignment(XTPMarkupVerticalAlignment alignment) | CXTPMarkupFrameworkElement |
SetVisibility(XTPMarkupVisibility visibility) | CXTPMarkupUIElement |
SetWidth(int nWidth) | CXTPMarkupFrameworkElement |
~CXTPMarkupButtonBase() | CXTPMarkupButtonBase | protected
~CXTPMarkupContentControl() | CXTPMarkupContentControl | protectedvirtual
~CXTPMarkupFrameworkElement() | CXTPMarkupFrameworkElement | protectedvirtual
~CXTPMarkupUIElement() | CXTPMarkupUIElement | protectedvirtual
~CXTPMarkupVisual() | CXTPMarkupVisual | virtual


Toolkit Pro: Member List

CXTPRibbonQuickAccessControls Member List

This is the complete list of members for CXTPRibbonQuickAccessControls, including all inherited members.

Add(CXTPControl *pControl, int nId, LPCTSTR lpszParameter=NULL, int nBefore=-1, BOOL bTemporary=FALSE) | CXTPControls |
Add(XTPControlType controlType, int nId, LPCTSTR lpszParameter=NULL, int nBefore=-1, BOOL bTemporary=FALSE) | CXTPControls |
Add(CXTPControl *pControl) | CXTPControls |
AddClone(CXTPControl *pClone, int nBefore=-1, BOOL bRecursive=FALSE) | CXTPControls |
AddMenuItem(CMenu *pMenu, int nIndex) | CXTPControls |
CalcDynamicSize(CDC *pDC, int nLength, DWORD dwMode, const CRect &rcBorder, int nWidth=0) | CXTPControls |
CalcPopupSize(CDC *pDC, int nLength, int nWidth, const CRect &rcBorder) | CXTPControls |
ClearOriginalControls() | CXTPControls |
CommandToIndex(int nIDFind) const | CXTPControls |
Compare(const CXTPControls *pControls) | CXTPControls |
Copy(CXTPControls *pControls, BOOL bRecursive=FALSE) | CXTPControls | virtual
CreateOriginalControls() | CXTPControls |
CXTPCmdTarget() | CXTPCmdTarget |
CXTPControls() | CXTPControls |
CXTPRibbonQuickAccessControls() | CXTPRibbonQuickAccessControls |
DoPropExchange(CXTPPropExchange *pPX) | CXTPControls | virtual
Duplicate(BOOL bRecursive=FALSE) | CXTPControls |
FindControl(int nId) const | CXTPControls |
FindControl(XTPControlType type, int nId, BOOL bVisible, BOOL bRecursive) const | CXTPControls |
FindDuplicate(CXTPControl *pControl) | CXTPRibbonQuickAccessControls |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAt(int nIndex) const | CXTPControls |
GetCommandBars() const | CXTPControls |
GetCount() const | CXTPControls |
GetFirst() const | CXTPControls |
GetNext(CXTPControl *&pControl) const | CXTPControls |
GetNext(long nIndex, int nDirection=+1, BOOL bKeyboard=TRUE, BOOL bSkipTemporary=FALSE, BOOL bSkipCollapsed=TRUE) const | CXTPControls |
GetOriginalControls() const | CXTPControls |
GetParent() const | CXTPControls |
GetVisibleAt(int nIndex, BOOL bIgnoreWraps=FALSE) const | CXTPControls |
GetVisibleCount(BOOL bIgnoreWrap=FALSE) const | CXTPControls |
HitTest(CPoint point) const | CXTPControls |
IndexOf(CXTPControl *pControl) const | CXTPRibbonQuickAccessControls |
InsertAt(CXTPControl *pControl, int nBefore) | CXTPControls |
IsChanged() const | CXTPControls |
IsOriginalControls() const | CXTPControls |
LoadMenu(CMenu *pMenu) | CXTPControls |
m_arrControls | CXTPControls | protected
m_bOriginalControls | CXTPControls | protected
m_pCommandBars | CXTPControls | protected
m_pOriginalControls | CXTPControls | protected
m_pParent | CXTPControls | protected
MoveBefore(CXTPControl *pControl, int nBefore) | CXTPControls |
OnControlAdded(CXTPControl *pControl) | CXTPRibbonQuickAccessControls | protectedvirtual
OnControlRemoved(CXTPControl *pControl) | CXTPRibbonQuickAccessControls | protectedvirtual
OnControlRemoving(CXTPControl *pControl) | CXTPControls | protectedvirtual
Remove(CXTPControl *pControl) | CXTPRibbonQuickAccessControls | virtual
CXTPControls::Remove(int nIndex) | CXTPControls |
RemoveAll() | CXTPControls |
Reset() | CXTPRibbonQuickAccessControls |
SetCommandBars(CXTPCommandBars *pCommandBars) | CXTPControls |
SetControlType(CXTPControl *pControl, XTPControlType type) | CXTPControls |
SetControlType(int nIndex, XTPControlType type) | CXTPControls |
SetOriginalControls(CXTPOriginalControls *pControls) | CXTPControls |
SetParent(CXTPCommandBar *pParent) | CXTPControls |
ShouldSerializeControl(CXTPControl *pControl) | CXTPControls | virtual
Sort() | CXTPControls |
~CXTPControls() | CXTPControls | virtual
~CXTPRibbonQuickAccessControls() | CXTPRibbonQuickAccessControls | virtual


Toolkit Pro: XTPTaskPanelVisualStudio2017Theme.h Source File

  • Source
  • TaskPanel
  • Themes
XTPTaskPanelVisualStudio2017Theme.h
Go to the documentation of this file.
1
23#if !defined(__XTPTASKPANELVISUALSTUDIO2017THEME_H__)
24# define __XTPTASKPANELVISUALSTUDIO2017THEME_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
39class _XTP_EXT_CLASS CXTPTaskPanelVisualStudio2017Theme : public CXTPTaskPanelVisualStudio2012Theme
40{
41protected:
42 void Triangle(CDC* pDC, POINT* pPoints, COLORREF clr, BOOL bFilled);
43
44public:
49 CXTPTaskPanelVisualStudio2017Theme();
50
56 virtual ~CXTPTaskPanelVisualStudio2017Theme();
57
62 virtual void RefreshMetrics();
63};
65# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
66#endif // __XTPTASKPANELVISUALSTUDIO2017THEME_H__
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPTaskPanelVisualStudio2012Theme
CXTPTaskPanelVisualStudio2012Theme represents a VS.NET 2012 style theme.
Definition XTPTaskPanelVisualStudio2012Theme.h:40
CXTPTaskPanelVisualStudio2017Theme
CXTPTaskPanelVisualStudio2017Theme represents a Visutal Studio 2017 style theme.
Definition XTPTaskPanelVisualStudio2017Theme.h:40
CXTPTaskPanelVisualStudio2017Theme::CXTPTaskPanelVisualStudio2017Theme
CXTPTaskPanelVisualStudio2017Theme()
Constructs a CXTPTaskPanelVisualStudio2017Theme object.
CXTPTaskPanelVisualStudio2017Theme::~CXTPTaskPanelVisualStudio2017Theme
virtual ~CXTPTaskPanelVisualStudio2017Theme()
Destroys a CXTPTaskPanelVisualStudio2017Theme object, handles cleanup and deallocation.
CXTPTaskPanelVisualStudio2017Theme::RefreshMetrics
virtual void RefreshMetrics()
Refreshes the visual metrics of the task panel.


Toolkit Pro: Member List

CXTPTrackUndoSetMarkerPositionCommand Member List

This is the complete list of members for CXTPTrackUndoSetMarkerPositionCommand, including all inherited members.

CXTPTrackUndoCommand(int nID) | CXTPTrackUndoCommand | protected
CXTPTrackUndoSetMarkerPositionCommand(CXTPTrackMarker *pMarker, int nOldPosition) | CXTPTrackUndoSetMarkerPositionCommand |
GetID() const | CXTPTrackUndoCommand |
m_nID | CXTPTrackUndoCommand | protected
m_nOldPosition | CXTPTrackUndoSetMarkerPositionCommand | protected
m_pMarker | CXTPTrackUndoSetMarkerPositionCommand | protected
Undo() | CXTPTrackUndoSetMarkerPositionCommand | protectedvirtual
~CXTPTrackUndoCommand() | CXTPTrackUndoCommand | protectedvirtual
~CXTPTrackUndoSetMarkerPositionCommand() | CXTPTrackUndoSetMarkerPositionCommand | virtual


Toolkit Pro: XTPTextPreview.h Source File

  • Source
  • Controls
  • Preview
  • Providers
  • Text
XTPTextPreview.h
Go to the documentation of this file.
1
24#if !defined(__XTPTEXTPREVIEW_H__)
25# define __XTPTEXTPREVIEW_H__
26
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPTextPreviewProvider;
34
35class _XTP_EXT_CLASS CXTPTextPreview : public IXTPPreview
36{
37public:
38 CXTPTextPreview();
39 ~CXTPTextPreview();
40
41private:
42 virtual BOOL IsReady() const;
43 virtual BOOL IsAvailable() const;
44 virtual BOOL HasOwnNavigator() const;
45 virtual UINT GetNumberOfPages() const;
46 virtual SIZE GetPreferredPageSize() const;
47 virtual void GoToPage(UINT page);
48 virtual void Draw(HDC dc, SIZE clientSize, RECT updateRect);
49 virtual BOOL OnHostWndMsg(LPMSG msg, LRESULT* result);
50 virtual BOOL SupportsCompositedParent() const;
51 virtual void Activate();
52
53 BOOL CreateRichEditCtrl(HWND parent);
54 BOOL LoadFile(LPCTSTR pFilePath);
55 BOOL LoadFile(IStream& stream);
56
57 static DWORD CALLBACK StreamInFile(DWORD_PTR dwCookie, LPBYTE pbBuff, LONG cb, LONG* pcb);
58
59private:
60 friend class CXTPTextPreviewProvider;
61 BOOL m_bLoadFinished;
62 BOOL m_bLoadSuccess;
63 BOOL m_bCreated;
64 CRichEditCtrl m_RichEdit;
65 CFile m_inFile;
66 IStream* m_pStream;
67 ULARGE_INTEGER m_ulSize;
68};
69
70# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
71#endif // #if !defined(__XTPTEXTPREVIEW_H__)
72
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPTextPreviewProvider
Provides a preview handler for the text file type (TXT).
Definition XTPTextPreviewProvider.h:42
IXTPPreview
The base interface for a preview handler implementation.
Definition XTPPreviewAbstract.h:40
IXTPPreview::GetNumberOfPages
virtual UINT GetNumberOfPages() const =0
Retrieves the number of pages available for the common page navigator.
IXTPPreview::Draw
virtual void Draw(HDC dc, SIZE clientSize, RECT updateRect)=0
This method is called every time the preview has to draw itself into the available client area.
IXTPPreview::GoToPage
virtual void GoToPage(UINT page)=0
If pages are supported by the preview, then it should cause navigation to the specified page number.
IXTPPreview::OnHostWndMsg
virtual BOOL OnHostWndMsg(LPMSG msg, LRESULT *result)=0
Handles a window message sent to the host preview control.
IXTPPreview::GetPreferredPageSize
virtual SIZE GetPreferredPageSize() const =0
Obtains the preferred page size in pixels if that is required by the preview.
IXTPPreview::SupportsCompositedParent
virtual BOOL SupportsCompositedParent() const =0
Determines if the preview implementation is compatible with composited top level windows (i....
IXTPPreview::IsAvailable
virtual BOOL IsAvailable() const =0
Determines if the preview is available (i.e.
IXTPPreview::IsReady
virtual BOOL IsReady() const =0
Returns TRUE if the handler has attempted and finished loading the preview regardless of the actual l...
IXTPPreview::HasOwnNavigator
virtual BOOL HasOwnNavigator() const =0
Determines if the handler implements its own page navigator.
IXTPPreview::Activate
virtual void Activate()=0
Activate preview.


Toolkit Pro: Member List

CXTPColorSelectorCtrlThemeOfficeXP Member List

This is the complete list of members for CXTPColorSelectorCtrlThemeOfficeXP, including all inherited members.

CalcSize(CXTPColorSelectorCtrl *pOwner) | CXTPColorSelectorCtrlTheme | virtual
CreateAutoButton(CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked) | CXTPColorSelectorCtrlTheme | virtual
CreateColorButtons(CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked) | CXTPColorSelectorCtrlTheme | virtual
CreateExtendedButtons(CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked) | CXTPColorSelectorCtrlTheme | virtual
CreateMoreButton(CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked) | CXTPColorSelectorCtrlTheme | virtual
CreateRecentColorButtons(CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked) | CXTPColorSelectorCtrlTheme | virtual
CreateThemeButtons(CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked) | CXTPColorSelectorCtrlTheme | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPColorSelectorCtrlTheme() | CXTPColorSelectorCtrlTheme |
CXTPColorSelectorCtrlThemeOfficeXP() | CXTPColorSelectorCtrlThemeOfficeXP |
CXTPControlTheme() | CXTPControlTheme |
DrawColorCell(CDC *pDC, CXTPColorSelectorCtrl *pOwner, CXTPColorSelectorCtrl::COLOR_CELL *pColorCell, BOOL bHighlight, BOOL bPressed) | CXTPColorSelectorCtrlTheme | virtual
DrawColorSelector(CDC *pDC, CXTPColorSelectorCtrl *pOwner) | CXTPColorSelectorCtrlTheme | virtual
FillBackground(CDC *pDC, CXTPColorSelectorCtrl *pOwner, const CRect &rect) | CXTPColorSelectorCtrlTheme | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetButtonSize() const | CXTPColorSelectorCtrlTheme | virtual
GetThemeStyle() const | CXTPControlTheme |
m_bThinBorder | CXTPColorSelectorCtrlTheme |
m_crBack | CXTPColorSelectorCtrlTheme |
m_crBackChecked | CXTPColorSelectorCtrlTheme |
m_crBackHilight | CXTPColorSelectorCtrlTheme |
m_crBackPressed | CXTPColorSelectorCtrlTheme |
m_crBorder | CXTPColorSelectorCtrlTheme |
m_crBorderHilight | CXTPColorSelectorCtrlTheme |
m_crBorderPressed | CXTPColorSelectorCtrlTheme |
m_crPopupBorder | CXTPColorSelectorCtrlTheme |
m_crText | CXTPColorSelectorCtrlTheme |
m_crTextPressed | CXTPColorSelectorCtrlTheme |
m_nAutoButton | CXTPColorSelectorCtrlTheme |
m_nCaption | CXTPColorSelectorCtrlTheme |
m_nMargin | CXTPColorSelectorCtrlTheme |
m_nTheme | CXTPControlTheme | protected
m_rcRecentText | CXTPColorSelectorCtrlTheme |
m_rcStandardText | CXTPColorSelectorCtrlTheme |
m_rcThemeText | CXTPColorSelectorCtrlTheme |
m_sizeButton | CXTPColorSelectorCtrlTheme |
RefreshMetrics(CXTPColorSelectorCtrl *pOwner) | CXTPColorSelectorCtrlThemeOfficeXP | virtual
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static


Toolkit Pro: Member List

CXTPColorPageCustom Member List

This is the complete list of members for CXTPColorPageCustom, including all inherited members.

CXTPColorPageCustom(CXTPColorDialog *pParentSheet=NULL) | CXTPColorPageCustom |
m_pParentSheet | CXTPColorPageCustom | protected
RGBtoHSL(COLORREF color, int *xtFocusLumination, int *sat, int *hue) | CXTPColorPageCustom |
~CXTPColorPageCustom() | CXTPColorPageCustom | virtual


Toolkit Pro: XTPCustomizePageToolbars.h Source File

  • Source
  • CommandBars
  • Customize
XTPCustomizePageToolbars.h
Go to the documentation of this file.
1
23#if !defined(__XTPCUSTOMIZETOOLBARSPAGE_H__) && defined(_XTP_INCLUDE_CONTROLS)
24# define __XTPCUSTOMIZETOOLBARSPAGE_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPCustomizeSheet;
34class CXTPWinThemeWrapper;
35
37class _XTP_EXT_CLASS CXTPCustomizeToolbarsPageCheckListBox : public CCheckListBox
38{
39public:
40 CXTPCustomizeToolbarsPageCheckListBox();
41 ~CXTPCustomizeToolbarsPageCheckListBox();
42
43protected:
44 BOOL OnChildNotify(UINT message, WPARAM wParam, LPARAM lParam, LRESULT* pResult);
45 void PreDrawItem(LPDRAWITEMSTRUCT lpDrawItemStruct);
46 void DrawItem(LPDRAWITEMSTRUCT lpDrawItemStruct);
47 void PreSubclassWindow();
48 LRESULT OnSetFont(WPARAM, LPARAM);
49
50 DECLARE_MESSAGE_MAP()
51
52protected:
53 CXTPWinThemeWrapper* m_themeHelper;
54 CSize m_sizeCheck;
55};
63class _XTP_EXT_CLASS CXTPCustomizeToolbarsPage : public CXTPPropertyPage
64{
66 DECLARE_DYNCREATE(CXTPCustomizeToolbarsPage)
69public:
77 CXTPCustomizeToolbarsPage(CXTPCustomizeSheet* pSheet = NULL);
78
84 ~CXTPCustomizeToolbarsPage();
85
86public:
93 void AllowNewToolbars(BOOL bEnable);
94
95protected:
97 DECLARE_MESSAGE_MAP()
98
99 //{{AFX_VIRTUAL(CXTPCustomizeToolbarsPage)
100 virtual void DoDataExchange(CDataExchange* pDX);
101 BOOL OnInitDialog();
102 //}}AFX_VIRTUAL
103
104 //{{AFX_MSG(CXTPCustomizeToolbarsPage)
105 afx_msg void OnSelectionChanged();
106 afx_msg void OnChkChange();
107 afx_msg void OnNewToolbar();
108 afx_msg void OnRenameToolbar();
109 afx_msg void OnDeleteToolbar();
110 afx_msg void OnResetToolbar();
111 afx_msg HBRUSH OnCtlColor(CDC* pDC, CWnd* pWnd, UINT nCtlColor);
112 //}}AFX_MSG
115private:
116 void RefreshToolbarsList();
117
118public:
119 enum
120 {
121 IDD = XTP_IDD_PAGE_TOOLBARS
122 };
123
124 CXTPCustomizeSheet* m_pSheet;
125# ifdef _XTP_INCLUDE_CONTROLS
126 COLORREF m_clrText;
127 CXTPButton m_btnReset;
128 CXTPButton m_btnRename;
129 CXTPButton m_btnDelete;
130 CXTPButton m_btnNew;
131 CXTPCheckListBox m_checkList;
132# else
133 CButton m_btnReset;
134 CButton m_btnRename;
135 CButton m_btnDelete;
136 CButton m_btnNew;
137 CXTPCustomizeToolbarsPageCheckListBox m_checkList;
138# endif
139
140protected:
141 BOOL m_bAllowNewToolbars;
143};
144
145AFX_INLINE void CXTPCustomizeToolbarsPage::AllowNewToolbars(BOOL bEnable)
146{
147 m_bAllowNewToolbars = bEnable;
148}
150# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
151#endif // !defined(__XTPCUSTOMIZETOOLBARSPAGE_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPButton
Push Button control.
Definition XTPButton.h:109
CXTPCheckListBox
The CXTPCheckListBox class is a CXTPListBox derived class.
Definition XTPCheckListBox.h:62
CXTPCustomizeSheet
CXTPCustomizeSheet is a CPropertySheet derived class.
Definition XTPCustomizeSheet.h:47
CXTPCustomizeToolbarsPage
CXTPCustomizeToolbarsPage is a CPropertyPage derived class.
Definition XTPCustomizePageToolbars.h:64
CXTPCustomizeToolbarsPage::AllowNewToolbars
void AllowNewToolbars(BOOL bEnable)
Displays or hides the new toolbar button.
Definition XTPCustomizePageToolbars.h:145
CXTPCustomizeToolbarsPage::~CXTPCustomizeToolbarsPage
~CXTPCustomizeToolbarsPage()
Destroys a CXTPCustomizeToolbarsPage object, handles cleanup and deallocation.
CXTPCustomizeToolbarsPage::m_bAllowNewToolbars
BOOL m_bAllowNewToolbars
TRUE to allow display the add new toolbar button, FALSE to hide it.
Definition XTPCustomizePageToolbars.h:141
CXTPCustomizeToolbarsPage::m_checkList
CXTPCustomizeToolbarsPageCheckListBox m_checkList
Toolbars list box.
Definition XTPCustomizePageToolbars.h:137
CXTPCustomizeToolbarsPage::m_btnDelete
CButton m_btnDelete
Delete button.
Definition XTPCustomizePageToolbars.h:135
CXTPCustomizeToolbarsPage::m_pSheet
CXTPCustomizeSheet * m_pSheet
Parent property sheet.
Definition XTPCustomizePageToolbars.h:124
CXTPCustomizeToolbarsPage::CXTPCustomizeToolbarsPage
CXTPCustomizeToolbarsPage(CXTPCustomizeSheet *pSheet=NULL)
Constructs a CXTPCustomizeToolbarsPage object.
CXTPCustomizeToolbarsPage::m_btnNew
CButton m_btnNew
New button.
Definition XTPCustomizePageToolbars.h:136
CXTPCustomizeToolbarsPage::m_btnRename
CButton m_btnRename
Rename button.
Definition XTPCustomizePageToolbars.h:134
CXTPCustomizeToolbarsPage::m_btnReset
CButton m_btnReset
Reset button.
Definition XTPCustomizePageToolbars.h:133
CXTPPropertyPage
CXTPPropertyPage is a CPropertyPage derived class.
Definition XTPPropertyPage.h:43
CXTPWinThemeWrapper
The CXTPWinThemeWrapper class wraps the UxTheme.dll visual theme API.
Definition XTPWinThemeWrapper.h:188


Toolkit Pro: Member List

CXTPChart2dDrawingObjectFactory Member List

This is the complete list of members for CXTPChart2dDrawingObjectFactory, including all inherited members.

Instance() CXTPSingleton< CXTPChart2dDrawingObjectFactory > inlinestatic


Toolkit Pro: XTPTabClientWnd.h Source File

  • Source
  • CommandBars
XTPTabClientWnd.h
Go to the documentation of this file.
1
23#if !defined(__TABCLIENTWNDEX_H__) && defined(_XTP_INCLUDE_TABMANAGER)
24# define __TABCLIENTWNDEX_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPMarkupContext;
34class CXTPTearOffFrame;
35class CXTPTabClientContext;
36# ifndef _XTP_COMMANDBARS_ACTIVEX
37# ifdef _XTP_INCLUDE_DOCKINGPANE
38class CXTPDockingPaneManager;
39class CXTPDockingPaneTabbedContainer;
40# endif
41# endif
42
97const UINT WM_XTP_PRETRANSLATEMOUSEMSG = (WM_XTP_COMMANDBARS_BASE + 20);
98
127const UINT WM_XTP_GETWINDOWTEXT = (WM_XTP_COMMANDBARS_BASE + 21);
128
157const UINT WM_XTP_GETWINDOWTOOLTIP = (WM_XTP_COMMANDBARS_BASE + 23);
158
183const UINT WM_XTP_NEWTABITEM = (WM_XTP_COMMANDBARS_BASE + 24);
184
212const UINT WM_XTP_TABTODOCKPANE = (WM_XTP_COMMANDBARS_BASE + 26);
213
279const UINT WM_XTP_PRETRANSLATEMOUSEMSG_EX = (WM_XTP_COMMANDBARS_BASE + 28);
280
290const UINT WM_XTP_SETACTIVEWORKSPACE = (WM_XTP_COMMANDBARS_BASE + 29);
291
302enum XTPWorkspaceButtons
303{
304 xtpWorkspaceHideArrows = 1,
305 xtpWorkspaceHideClose = 2,
306 xtpWorkspaceHideAll = 3,
307 xtpWorkspaceShowActiveFiles = 4,
308 xtpWorkspaceHideArrowsAlways = 1 + 8,
309 xtpWorkspaceShowCloseTab = 16,
310 xtpWorkspaceShowCloseSelectedTab = 32,
311};
312
323enum XTPWorkspaceNewTabPosition
324{
325 xtpWorkspaceNewTabRightMost,
326 xtpWorkspaceNewTabLeftMost,
327 xtpWorkspaceNewTabNextToActive
328};
329
338enum XTPWorkspaceActivateTab
339{
340 xtpWorkspaceActivateNextToClosed,
341 xtpWorkspaceActivateTopmost
342};
343
345class CXTPTabPaintManager;
346class CXTPCommandBars;
347class CXTPMDIFrameWnd;
348class CXTPToolTipContext;
351# define XTP_TABCLIENT_ACTION_CANCEL 0
352# define XTP_TABCLIENT_ACTION_POPUP 1
353# define XTP_TABCLIENT_ACTION_ATTACH_CENTER 2
354# define XTP_TABCLIENT_ACTION_ATTACH_LEFT 3
355# define XTP_TABCLIENT_ACTION_ATTACH_RIGHT 4
356# define XTP_TABCLIENT_ACTION_ATTACH_TOP 5
357# define XTP_TABCLIENT_ACTION_ATTACH_BOTTOM 6
358# define XTP_TABCLIENT_ACTION_DETACH 7
359# define XTP_TABCLIENT_ACTION_ATTACH_TEAR_OFF_CENTER 8
360# define XTP_TABCLIENT_ACTION_ATTACH_TEAR_OFF_LEFT 9
361# define XTP_TABCLIENT_ACTION_ATTACH_TEAR_OFF_RIGHT 10
362# define XTP_TABCLIENT_ACTION_ATTACH_TEAR_OFF_TOP 11
363# define XTP_TABCLIENT_ACTION_ATTACH_TEAR_OFF_BOTTOM 12
364# define XTP_TABCLIENT_NO_ACTION 14
365# ifndef _XTP_COMMANDBARS_ACTIVEX
366# ifdef _XTP_INCLUDE_DOCKINGPANE
367# define XTP_TABCLIENT_ACTION_DOCK_CENTER 15
368# define XTP_TABCLIENT_ACTION_DOCK_LEFT 16
369# define XTP_TABCLIENT_ACTION_DOCK_RIGHT 17
370# define XTP_TABCLIENT_ACTION_DOCK_TOP 18
371# define XTP_TABCLIENT_ACTION_DOCK_BOTTOM 19
372# endif
373# endif
374
380class _XTP_EXT_CLASS CXTPTabClientWnd
381 : public CWnd
382 , public CXTPTabManagerAtom
383{
385 DECLARE_DYNAMIC(CXTPTabClientWnd)
386
387 class CTabClientDropTarget;
388 class CNavigateButtonActiveFiles;
391public:
392 class CWorkspace;
393 class CSingleWorkspace;
394
395public:
400 CXTPTabClientWnd();
401
406 virtual ~CXTPTabClientWnd();
407
408public:
417 BOOL Attach(CXTPMDIFrameWnd* pParentFrame, BOOL bEnableGroups = FALSE);
418
428 BOOL Attach(CXTPCommandBars* pCommandBars, CMDIFrameWnd* pParentFrame, BOOL bEnableGroups);
429
436 BOOL Detach();
437
444 BOOL IsAttached() const;
445
452 CMDIFrameWnd* GetParentFrame() const;
453
461 BOOL IsLayoutRTL() const;
462
469 void SetLayoutRTL(BOOL bRightToLeft);
470
483 void SetNewTabPosition(XTPWorkspaceNewTabPosition tabPosition);
484
497 void SetAfterCloseActiveTab(XTPWorkspaceActivateTab activeTab);
498
507 XTPWorkspaceNewTabPosition GetNewTabPositon() const;
508
513 void SaveState();
514
519 void LoadState();
520
526 virtual void UpdateContents();
527
534 virtual CWorkspace* CreateWorkspace();
535
549 void SetFlags(DWORD dwButtons);
550
560 DWORD GetFlags() const;
561
573 void EnableToolTips(XTPTabToolTipBehaviour behaviour = xtpTabToolTipAlways);
574
581 CXTPTabPaintManager* GetPaintManager() const;
582
588 void SetPaintManager(CXTPTabPaintManager* pPaintManager);
589
601 void SetAutoTheme(BOOL bAutoTheme = FALSE);
602
611 BOOL GetAutoTheme() const;
612
621 CXTPTabManagerItem* FindItem(const HWND hWnd) const;
622
632 CXTPTabManagerItem* HitTest(CPoint pt) const;
633
646 int GetWorkspaceCount() const;
647
661 CWorkspace* GetWorkspace(int nIndex) const;
662
674 BOOL IsWorkspaceCommandEnabled(UINT nID, CXTPTabManagerItem** ppItem = NULL);
675
680 void CreateNewVerticalGroup();
681
686 void CreateNewHorizontalGroup();
687
692 void MoveToPreviousGroup();
693
698 void MoveToNextGroup();
699
705 void Refresh(BOOL bRecalcLayout = TRUE);
706
714 void WorkspaceToScreen(LPPOINT lpPoint) const;
715
723 void ScreenToWorkspace(LPPOINT lpPoint) const;
724
730 void ShowWorkspace(BOOL bShow);
731
737 void SetTabWorkspace(CWorkspace* pWorkspace);
738
745 BOOL IsAllowReorder() const;
746
753 void SetAllowReorder(BOOL bAllowReorder);
754
761 virtual void OnFillBackground(CDC* pDC, CRect rc);
762
769 virtual void OnDraw(CDC* pDC, CRect rc);
770
777 CXTPToolTipContext* GetToolTipContext() const;
778
789 void UseSplitterTracker(BOOL bSplitterTracker);
790
799 BOOL IsSplitterTrackerUsed() const;
800
807 virtual CXTPCommandBars* GetCommandBars() const;
808
814 void SetCommandBars(CXTPCommandBars* pCommandBars);
815
822 void MDITile(BOOL bHorizontal);
823
835 CXTPTabManagerItem* GetItem(int nIndex) const;
836
843 int GetItemCount() const;
844
849 virtual void Reposition();
850
858 void EnableMarkup(BOOL bEnableMarkup);
859
866 void ShowNewWindowTab(BOOL bShowNewWindowTab = TRUE, int nCommand = ID_FILE_NEW);
867
875 int FindIndex(CXTPTabManager* pWorkspace) const;
876
877 //{{AFX_CODEJOCK_PRIVATE
878 _XTP_DEPRECATED_IN_FAVOR4(CreateNewVerticalGroup, CreateNewHorizontalGroup, MoveToPreviousGroup,
879 MoveToNextGroup)
880 void OnWorkspaceCommand(UINT nID);
881 //}}AFX_CODEJOCK_PRIVATE
882
883protected:
891 virtual void CheckCommandBarsTheme();
892
899 virtual CWnd* MDIGetActive();
900
907 virtual void MDIActivate(CWnd* pWnd);
908
917 virtual CString GetItemText(const CWnd* pChildWnd) const;
918
928 virtual COLORREF GetItemColor(const CXTPTabManagerItem* pItem) const;
929
937 virtual HICON GetItemIcon(const CXTPTabManagerItem* pItem) const;
938
946 virtual CString GetItemTooltip(const CXTPTabManagerItem* pItem) const;
947
955 virtual CWorkspace* AddWorkspace(int nIndex = -1);
956
965 virtual CXTPTabManagerItem* AddItem(CWnd* pChildWnd);
966
972 void SetActiveWorkspace(CWorkspace* pWorkspace);
973
979 void ContextMenu(CPoint pt);
980
989 virtual void UpdateFlags(CWorkspace* pWorkspace);
990
997 CXTPTabManagerItem* GetSelectedItem() const;
998
999protected:
1001 void OnWorkspaceCommandImpl(UINT nID);
1002 void DoWorkspaceCommand(CXTPTabManagerItem* pItem, CWorkspace* pFocusWorkspace, int nAction,
1003 CPoint pt = CPoint(), CXTPTabClientWnd* pTargetTab = NULL
1004# ifndef _XTP_COMMANDBARS_ACTIVEX
1005 ,
1006# ifdef _XTP_INCLUDE_DOCKINGPANE
1007 CXTPDockingPaneTabbedContainer* pTargetPane = NULL
1008# else
1009 LPVOID pReserved = NULL
1010# endif
1011# endif
1012 );
1013 void TrackSplitter(int nWorkspace, CPoint point);
1014 void RepositionWorkspaces(CRect rc, CRect rcAvail, CWorkspace* pWorkspaceFirst,
1015 CWorkspace* pWorkspaceSecond);
1016 void NormalizeWorkspaceSize();
1017 void ActivateNextItem(CXTPTabManagerItem* pItem);
1018 void ActivateNextTopmostItem(CXTPTabManagerItem* pItem);
1019 virtual BOOL OnBeforeItemClick(CXTPTabManagerItem* pItem);
1022protected:
1024 DECLARE_MESSAGE_MAP()
1025
1026 //{{AFX_VIRTUAL(CXTPTabClientWnd)
1027 virtual void CalcWindowRect(LPRECT lpClientRect, UINT nAdjustType);
1028 virtual BOOL PreTranslateMessage(MSG* pMsg);
1029 virtual INT_PTR OnToolHitTest(CPoint point, TOOLINFO* pTI) const;
1030 virtual LRESULT WindowProc(UINT message, WPARAM wParam, LPARAM lParam);
1031 //}}AFX_VIRTUAL
1032
1033 //{{AFX_MSG(CXTPTabClientWnd)
1034
1035 afx_msg void OnSetFocus(CWnd* pOldWnd);
1036 afx_msg void OnKillFocus(CWnd* pNewWnd);
1037
1038 afx_msg LRESULT OnMDIActivate(WPARAM wParam, LPARAM lParam);
1039 afx_msg LRESULT OnMDICreate(WPARAM wParam, LPARAM lParam);
1040 afx_msg LRESULT OnMDIDestroy(WPARAM wParam, LPARAM lParam);
1041 afx_msg LRESULT OnMDINext(WPARAM wParam, LPARAM lParam);
1042
1043 afx_msg void OnSize(UINT nType, int cx, int cy);
1044 afx_msg void OnPaint();
1045 afx_msg BOOL OnEraseBkgnd(CDC*);
1046 afx_msg LRESULT OnPrintClient(WPARAM wParam, LPARAM lParam);
1047 afx_msg void OnNcPaint();
1048 afx_msg void OnNcCalcSize(BOOL bCalcValidRects, NCCALCSIZE_PARAMS FAR* lpncsp);
1049
1050 afx_msg void OnRButtonDown(UINT nFlags, CPoint point);
1051 afx_msg void OnLButtonDblClk(UINT nFlags, CPoint point);
1052 afx_msg void OnMouseLeave();
1053 afx_msg void OnLButtonDown(UINT nFlags, CPoint point);
1054 afx_msg void OnMouseMove(UINT nFlags, CPoint point);
1055 afx_msg void OnSysColorChange();
1056 afx_msg BOOL OnSetCursor(CWnd* pWnd, UINT nHitTest, UINT message);
1057 afx_msg void OnUpdateWorkspaceCommand(CCmdUI* pCmdUI);
1058 afx_msg BOOL OnNcActivate(BOOL bActive);
1059
1060public:
1061 afx_msg void OnIdleUpdateCmdUI();
1062 //}}AFX_MSG
1065public:
1066 BOOL m_bDelayLock;
1067 BOOL m_bLockUpdate;
1068 BOOL m_bForceToRecalc;
1069 BOOL m_bLockReposition;
1071protected:
1072 CArray<CWorkspace*, CWorkspace*> m_arrWorkspace;
1073 CWorkspace* m_pTabWorkspace;
1074 BOOL m_bUserWorkspace;
1076 CMDIFrameWnd* m_pParentFrame;
1077 BOOL m_bRefreshed;
1079 CXTPTabPaintManager* m_pPaintManager;
1080 XTPPaintTheme m_themeCommandBars;
1083 BOOL m_bAutoTheme;
1085 CWorkspace* m_pActiveWorkspace;
1086 BOOL m_bHorizSplitting;
1088 HCURSOR m_hCursorHoriz;
1089 HCURSOR m_hCursorVert;
1090 HCURSOR m_hCursorNew;
1091 HCURSOR m_hCursorDelete;
1093 BOOL m_bThemedBackColor;
1097 BOOL m_bEnableGroups;
1099 DWORD m_dwFlags;
1100 BOOL m_bAllowReorder;
1101 BOOL m_bShowWorkspace;
1103 BOOL m_bUpdateContents;
1104 CXTPToolTipContext* m_pToolTipContext;
1105 BOOL m_bUseSplitterTracker;
1109 int m_nSplitterSize;
1110 XTPWorkspaceNewTabPosition m_newTabPosition;
1111 XTPWorkspaceActivateTab m_afterCloseTabPosition;
1114 BOOL m_bAutoUpdateTabCaption;
1117 CXTPMarkupContext* m_pMarkupContext;
1118 BOOL m_bShowNewWindowTab;
1119 int m_nNewWindowTabCommand;
1120
1121 CXTPCommandBars* m_pCommandBars;
1122
1123public:
1124 void EnableTearOff();
1125 BOOL IsTearOffEnabled() const;
1126 BOOL IsGroupingEnabled() const;
1127
1128# ifndef _XTP_COMMANDBARS_ACTIVEX
1129# ifdef _XTP_INCLUDE_DOCKINGPANE
1130public:
1131 void SetDockingPaneManager(CXTPDockingPaneManager* pPaneManager);
1132 CXTPDockingPaneManager* GetDockingPaneManager();
1133
1134protected:
1135 CXTPDockingPaneManager* m_paneManager;
1136 CXTPDockingPaneTabbedContainer* FindTargetDockPane(POINT pt);
1137# else
1139 // Required for padding
1140 LPVOID m_paneManager;
1142# endif
1143# endif
1144
1145private:
1146 BOOL m_bEnableTearOff;
1147 CPtrList m_lstNextTab;
1148 CPtrList m_lstPrevTab;
1149 CXTPTabClientWnd* GetTabClientHead();
1150 CXTPTabClientWnd* FindTargetTabClient(POINT pt);
1151# ifdef _XTP_COMMANDBARS_ACTIVEX
1152 static CMDIFrameWnd* pTabClientParentFrame;
1153# endif
1154 static BOOL CALLBACK EnumWindowsProc(HWND hwnd, LPARAM lParam);
1155 void FindTargetTabClients(CXTPTabClientWnd* pTabClient,
1156 CArray<CXTPTabClientWnd*, CXTPTabClientWnd*>* collection, POINT pt);
1157
1158 void EnumTabClients(CXTPTabClientWnd* pTabClient,
1159 CArray<CXTPTabClientWnd*, CXTPTabClientWnd*>* collection);
1160 void ChangeMDIChildFrame(CWnd* pTarget);
1161 void CloseTearOffFrame(CXTPTabClientWnd* pTarget);
1162 void ChangeItemWorkspace(CXTPTabClientWnd* pTarget, int nOldWorkspace, int nSticker);
1163
1164 CXTPTabClientContext* m_pTabClientContext;
1165
1166public:
1167 void SetShowTabClientContextStickers(BOOL value);
1168 void SetAlphaTabClientContext(BOOL value);
1169 void SetShowContentsWhileDragging(BOOL value);
1170 void EnableFloatingFrameTheme(BOOL value);
1171
1172 BOOL GetAlphaTabClientContext() const;
1173 BOOL GetShowTabClientContextStickers() const;
1174 BOOL GetShowContentsWhileDragging() const;
1175 BOOL IsFloatingFrameThemeEnabled() const;
1176
1177 void SetForegroundTearOffFrames();
1178 void CloseAllTearOffFrames();
1179 void GetTabClients(CArray<CXTPTabClientWnd*, CXTPTabClientWnd*>& collection);
1180 HWND GetLastSelecedItem();
1181
1182protected:
1184 CRect m_rcGroup;
1185 CTabClientDropTarget* m_pDropTarget;
1186 CWorkspace* m_pFocusWorkspace;
1187 int m_nFocusedAction;
1188 BOOL m_bIgnoreFlickersOnActivate;
1189 BOOL m_bRightToLeft;
1190 UINT m_nMsgUpdateSkinState;
1191 UINT m_nMsgQuerySkinState;
1192 CString m_strIniFileName;
1193 BOOL NeedsRefresh(XTPPaintTheme theme);
1196# ifdef _XTP_COMMANDBARS_ACTIVEX
1199 DECLARE_DISPATCH_MAP()
1200 DECLARE_INTERFACE_MAP()
1201 XTP_DECLARE_CMDTARGETPROVIDER_INTERFACE()
1202
1203 DECLARE_OLETYPELIB_EX(CXTPTabClientWnd);
1204 DECLARE_CONNECTION_EX(CXTPTabClientWnd)
1205
1206 DECLARE_ENUM_VARIANT(CXTPTabClientWnd)
1207
1208 afx_msg LPDISPATCH OleGetItem(int nItem);
1209 afx_msg LPDISPATCH OleGetSelected();
1210 afx_msg long OleGetItemCount();
1211 afx_msg LPDISPATCH OleHitTest(OLE_XPOS_PIXELS x, OLE_YPOS_PIXELS y);
1212 afx_msg void OleRefresh();
1213 afx_msg BOOL OleIsWorkspaceCommandEnabled(long nID);
1214 afx_msg void OleSetEnableMarkup(BOOL bEnableMarkup);
1215 afx_msg BOOL OleGetEnableMarkup();
1216 afx_msg LPDISPATCH OleGetToolTipContext();
1217 afx_msg void OleSetHorizGroupSplitting(BOOL bHorizSplitting);
1218 afx_msg BOOL OleGetHorizGroupSplitting();
1219 afx_msg long OlegGetGroupCount();
1220 afx_msg double OleGetGroupSplitter(int nGroup);
1221 afx_msg void OleSetGroupSplitter(int nGroup, double dSplitterPos);
1222 afx_msg OLE_HANDLE OleGetHwnd();
1223
1224 afx_msg LPDISPATCH OleFindItem(OLE_HANDLE hWnd);
1225 afx_msg int OleFindGroup(LPDISPATCH Item);
1226 afx_msg void OleCreateGroup(LPDISPATCH Item, BOOL Horiz);
1227 afx_msg void OleMoveToGroup(LPDISPATCH Item, int nGroup);
1228
1229 void FireRClick(LPDISPATCH lpDispatch)
1230 {
1231 FireEvent(1, EVENT_PARAM(VTS_DISPATCH), lpDispatch);
1232 }
1233 void FireNewItem(LPDISPATCH lpDispatch)
1234 {
1235 FireEvent(2, EVENT_PARAM(VTS_DISPATCH), lpDispatch);
1236 }
1237 void FireSelectedChanged(LPDISPATCH Item)
1238 {
1239 FireEvent(3, EVENT_PARAM(VTS_DISPATCH), Item);
1240 }
1241 void FireBeforeItemClick(LPDISPATCH Item)
1242 {
1243 FireEvent(4, EVENT_PARAM(VTS_DISPATCH), Item);
1244 }
1245
1246 enum
1247 {
1248 dispidFlags = 1L,
1249 };
1250
1251 LPDISPATCH OleGetPaintManager();
1252 void OleEnableGroups();
1253
1255# endif
1256
1257 friend class CWorkspace;
1258 friend class CSingleWorkspace;
1259 friend class CTabClientDropTarget;
1260 friend class CNavigateButtonActiveFiles;
1261 friend class CXTPControlTabWorkspace;
1262 friend class CXTPTearOffFrame;
1263 friend class CXTPTabClientSticker;
1264 friend class CXTPDockPaneContextSticker;
1265 friend class CXTPTabClientContext;
1266 friend class CXTPTabClientDraggingContents;
1267# ifndef _XTP_COMMANDBARS_ACTIVEX
1268# ifdef _XTP_INCLUDE_DOCKINGPANE
1269 friend class CXTPDockingPaneContext;
1270# endif
1271# endif
1272};
1273
1275
1276AFX_INLINE BOOL CXTPTabClientWnd::IsAttached() const
1277{
1278 return (m_pParentFrame != NULL ? TRUE : FALSE);
1279}
1280
1281AFX_INLINE CMDIFrameWnd* CXTPTabClientWnd::GetParentFrame() const
1282{
1283 return m_pParentFrame;
1284}
1285
1286AFX_INLINE DWORD CXTPTabClientWnd::GetFlags() const
1287{
1288 return m_dwFlags;
1289}
1290
1291AFX_INLINE CXTPToolTipContext* CXTPTabClientWnd::GetToolTipContext() const
1292{
1293 return m_pToolTipContext;
1294}
1295
1296AFX_INLINE void CXTPTabClientWnd::UseSplitterTracker(BOOL bSplitterTracker)
1297{
1298 m_bUseSplitterTracker = bSplitterTracker;
1299}
1300
1301AFX_INLINE BOOL CXTPTabClientWnd::IsSplitterTrackerUsed() const
1302{
1303 return m_bUseSplitterTracker;
1304}
1305
1306AFX_INLINE void CXTPTabClientWnd::SetNewTabPosition(XTPWorkspaceNewTabPosition tabPosition)
1307{
1308 m_newTabPosition = tabPosition;
1309}
1310
1311AFX_INLINE XTPWorkspaceNewTabPosition CXTPTabClientWnd::GetNewTabPositon() const
1312{
1313 return m_newTabPosition;
1314}
1315
1316AFX_INLINE void CXTPTabClientWnd::SetAfterCloseActiveTab(XTPWorkspaceActivateTab activeTab)
1317{
1318 m_afterCloseTabPosition = activeTab;
1319}
1320
1321AFX_INLINE void CXTPTabClientWnd::EnableTearOff()
1322{
1323 m_bEnableTearOff = TRUE;
1324}
1325
1326AFX_INLINE BOOL CXTPTabClientWnd::IsTearOffEnabled() const
1327{
1328 return m_bEnableTearOff;
1329}
1330
1331AFX_INLINE BOOL CXTPTabClientWnd::IsGroupingEnabled() const
1332{
1333 return m_bEnableGroups;
1334}
1335
1336AFX_INLINE void CXTPTabClientWnd::OnWorkspaceCommand(UINT nID)
1337{
1338 OnWorkspaceCommandImpl(nID);
1339}
1340
1341# ifndef _XTP_COMMANDBARS_ACTIVEX
1342# ifdef _XTP_INCLUDE_DOCKINGPANE
1343AFX_INLINE void CXTPTabClientWnd::SetDockingPaneManager(CXTPDockingPaneManager* pPaneManager)
1344{
1345 m_paneManager = pPaneManager;
1346}
1347AFX_INLINE CXTPDockingPaneManager* CXTPTabClientWnd::GetDockingPaneManager()
1348{
1349 return m_paneManager;
1350}
1351
1352# endif
1353# endif
1354
1355# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
1357#endif // #if !defined(__XTPTABCLIENTWNDEX_H__)
XTPPaintTheme
XTPPaintTheme
Paint themes used by command bars.
Definition XTPCommandBarsDefines.h:233
WM_XTP_COMMANDBARS_BASE
const UINT WM_XTP_COMMANDBARS_BASE
Base message for CommandBars.
Definition XTPCommandBarsDefines.h:442
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTP_DECLARE_CMDTARGETPROVIDER_INTERFACE
#define XTP_DECLARE_CMDTARGETPROVIDER_INTERFACE()
When deriving from CXTPCmdTarget is not possible this macro can be used in addition to standard DECLA...
Definition XTPFramework.h:89
WM_XTP_GETWINDOWTOOLTIP
const UINT WM_XTP_GETWINDOWTOOLTIP
The WM_XTP_GETWINDOWTOOLTIP message is sent to the MDI child window to retrieve tooltips for CXTPTabC...
Definition XTPTabClientWnd.h:157
WM_XTP_NEWTABITEM
const UINT WM_XTP_NEWTABITEM
The WM_XTP_NEWTABITEM message is sent to the owner window when a new tab is created.
Definition XTPTabClientWnd.h:183
WM_XTP_SETACTIVEWORKSPACE
const UINT WM_XTP_SETACTIVEWORKSPACE
The WM_XTP_SETACTIVEWORKSPACE message is sent to the owner window when workspace changed.
Definition XTPTabClientWnd.h:290
XTPWorkspaceActivateTab
XTPWorkspaceActivateTab
XTPWorkspaceActivateTab enumerator.
Definition XTPTabClientWnd.h:339
xtpWorkspaceActivateTopmost
@ xtpWorkspaceActivateTopmost
Activate the left-most tab.
Definition XTPTabClientWnd.h:341
xtpWorkspaceActivateNextToClosed
@ xtpWorkspaceActivateNextToClosed
Activate tab next to the closed tab.
Definition XTPTabClientWnd.h:340
WM_XTP_PRETRANSLATEMOUSEMSG
const UINT WM_XTP_PRETRANSLATEMOUSEMSG
The WM_XTP_PRETRANSLATEMOUSEMSG message is sent to the owner window to pre-translate mouse messages.
Definition XTPTabClientWnd.h:97
WM_XTP_GETWINDOWTEXT
const UINT WM_XTP_GETWINDOWTEXT
The WM_XTP_GETWINDOWTEXT message is sent to the MDI child window to retrieve the text that will be us...
Definition XTPTabClientWnd.h:127
WM_XTP_PRETRANSLATEMOUSEMSG_EX
const UINT WM_XTP_PRETRANSLATEMOUSEMSG_EX
The WM_XTP_PRETRANSLATEMOUSEMSG_EX message is sent to the main window from TearOffFrame to pre-transl...
Definition XTPTabClientWnd.h:279
WM_XTP_TABTODOCKPANE
const UINT WM_XTP_TABTODOCKPANE
The WM_XTP_TABTODOCKPANE message is sent to the owner window when a tab is being docked to Docking Pa...
Definition XTPTabClientWnd.h:212
XTPWorkspaceNewTabPosition
XTPWorkspaceNewTabPosition
XTPWorkspaceNewTabPosition enumerator.
Definition XTPTabClientWnd.h:324
xtpWorkspaceNewTabRightMost
@ xtpWorkspaceNewTabRightMost
New tab will be created after all tabs.
Definition XTPTabClientWnd.h:325
xtpWorkspaceNewTabNextToActive
@ xtpWorkspaceNewTabNextToActive
New tab will be created after active tab.
Definition XTPTabClientWnd.h:327
xtpWorkspaceNewTabLeftMost
@ xtpWorkspaceNewTabLeftMost
New tab will be created before all tabs.
Definition XTPTabClientWnd.h:326
XTPWorkspaceButtons
XTPWorkspaceButtons
Workspace buttons enumerator.
Definition XTPTabClientWnd.h:303
xtpWorkspaceHideClose
@ xtpWorkspaceHideClose
To hide close button.
Definition XTPTabClientWnd.h:305
xtpWorkspaceHideAll
@ xtpWorkspaceHideAll
To hide arrow and close buttons.
Definition XTPTabClientWnd.h:306
xtpWorkspaceShowCloseSelectedTab
@ xtpWorkspaceShowCloseSelectedTab
To show close button for selected tabs.
Definition XTPTabClientWnd.h:310
xtpWorkspaceHideArrowsAlways
@ xtpWorkspaceHideArrowsAlways
To hide arrow buttons always
Definition XTPTabClientWnd.h:308
xtpWorkspaceHideArrows
@ xtpWorkspaceHideArrows
To hide arrow buttons.
Definition XTPTabClientWnd.h:304
xtpWorkspaceShowActiveFiles
@ xtpWorkspaceShowActiveFiles
To show active file button.
Definition XTPTabClientWnd.h:307
xtpWorkspaceShowCloseTab
@ xtpWorkspaceShowCloseTab
To show close button for all tabs.
Definition XTPTabClientWnd.h:309
XTPTabToolTipBehaviour
XTPTabToolTipBehaviour
XTPTabToolTipBehaviour is an enumeration used to set the tooltip behaviour for tabs.
Definition XTPTabManagerDefines.h:240
xtpTabToolTipAlways
@ xtpTabToolTipAlways
Always show tooltips for tabs.
Definition XTPTabManagerDefines.h:242
CXTPCommandBars
CXTPCommandBars is a standalone class.
Definition XTPCommandBars.h:165
CXTPControlTabWorkspace
TabWorkspace control.
Definition XTPControlTabWorkspace.h:40
CXTPDockingPaneContext
CXTPDockingPaneContext is a standalone class.
Definition XTPDockingPaneContext.h:185
CXTPDockingPaneManager
CXTPDockingPaneManager is a CWnd derived class.
Definition XTPDockingPaneManager.h:58
CXTPDockingPaneTabbedContainer
CXTPDockingPaneTabbedContainer is a multiple inheritance class derived from CWnd and CXTPDockingPaneB...
Definition XTPDockingPaneTabbedContainer.h:47
CXTPMDIFrameWnd
CXTPMDIFrameWnd is a CXTPFrameWndBase derived class.
Definition XTPFrameWnd.h:292
CXTPMarkupContext
CXTPMarkupContext is a standalone class used to provide common settings for Markup objects.
Definition XTPMarkupContext.h:128
CXTPTabClientContext
CXTPTabClientContext is a standalone class.
Definition XTPTabClientContext.h:68
CXTPTabClientDraggingContents
Managers tab client dragging contents.
Definition XTPTabClientDraggingContents.h:38
CXTPTabClientSticker
A tab client sticker control.
Definition XTPTabClientSticker.h:139
CXTPTabClientWnd
CXTPTabClientWnd is a CWnd derived class.
Definition XTPTabClientWnd.h:383
CXTPTabClientWnd::MDITile
void MDITile(BOOL bHorizontal)
Call this member to tile child windows in the workspace (only if EnableGroups is enabled).
CXTPTabClientWnd::GetItemCount
int GetItemCount() const
Returns the number of items.
CXTPTabClientWnd::SetAllowReorder
void SetAllowReorder(BOOL bAllowReorder)
Call this member function to allow or disallow reordering.
CXTPTabClientWnd::MoveToPreviousGroup
void MoveToPreviousGroup()
Moves an item to the previous group.
CXTPTabClientWnd::GetWorkspaceCount
int GetWorkspaceCount() const
Call this member to retrieve the current number of workspaces.
CXTPTabClientWnd::AddItem
virtual CXTPTabManagerItem * AddItem(CWnd *pChildWnd)
This member function adds a new tab item for the specified window.
CXTPTabClientWnd::m_bUseSplitterTracker
BOOL m_bUseSplitterTracker
If TRUE, splitter trackers are used.
Definition XTPTabClientWnd.h:1105
CXTPTabClientWnd::SetTabWorkspace
void SetTabWorkspace(CWorkspace *pWorkspace)
Call this method to set the custom workspace control.
CXTPTabClientWnd::UpdateContents
virtual void UpdateContents()
Scan through all MDIChild windows and update the corresponding tab items if any changes happened (e....
CXTPTabClientWnd::EnableMarkup
void EnableMarkup(BOOL bEnableMarkup)
This member function is used to enable/disable Markup functionality for the control.
CXTPTabClientWnd::UpdateFlags
virtual void UpdateFlags(CWorkspace *pWorkspace)
This member function is called to update the status of the TabWorkspace navigation buttons.
CXTPTabClientWnd::SetActiveWorkspace
void SetActiveWorkspace(CWorkspace *pWorkspace)
This member function sets a workspace active.
CXTPTabClientWnd::GetItem
CXTPTabManagerItem * GetItem(int nIndex) const
Returns an item by its index.
CXTPTabClientWnd::ShowNewWindowTab
void ShowNewWindowTab(BOOL bShowNewWindowTab=TRUE, int nCommand=ID_FILE_NEW)
Call this method to add an Explorer 7 style new window tab button.
CXTPTabClientWnd::IsSplitterTrackerUsed
BOOL IsSplitterTrackerUsed() const
Call this member to determine if the splitter tracker is used.
Definition XTPTabClientWnd.h:1301
CXTPTabClientWnd::SetAutoTheme
void SetAutoTheme(BOOL bAutoTheme=FALSE)
Call this member to specify whether auto themes are used for the TabWorkspace.
CXTPTabClientWnd::GetItemIcon
virtual HICON GetItemIcon(const CXTPTabManagerItem *pItem) const
This member function retrieves the icon of a specific tab.
CXTPTabClientWnd::GetPaintManager
CXTPTabPaintManager * GetPaintManager() const
Call this method to retrieve the paint manager.
CXTPTabClientWnd::SetPaintManager
void SetPaintManager(CXTPTabPaintManager *pPaintManager)
Call this member to set the specified paint manager.
CXTPTabClientWnd::m_dwFlags
DWORD m_dwFlags
Specifies which tab navigation buttons are displayed.
Definition XTPTabClientWnd.h:1099
CXTPTabClientWnd::m_newTabPosition
XTPWorkspaceNewTabPosition m_newTabPosition
New tab position.
Definition XTPTabClientWnd.h:1110
CXTPTabClientWnd::IsLayoutRTL
BOOL IsLayoutRTL() const
Determines if right-to-left (RTL) mode is set.
CXTPTabClientWnd::EnableToolTips
void EnableToolTips(XTPTabToolTipBehaviour behaviour=xtpTabToolTipAlways)
Call this member function to enable/disable tooltips show.
CXTPTabClientWnd::Attach
BOOL Attach(CXTPMDIFrameWnd *pParentFrame, BOOL bEnableGroups=FALSE)
Attaches the tabbed workspace.
CXTPTabClientWnd::OnDraw
virtual void OnDraw(CDC *pDC, CRect rc)
This member is called when the client is drawn.
CXTPTabClientWnd::CheckCommandBarsTheme
virtual void CheckCommandBarsTheme()
If m_bAutoTheme is FALSE, then it checks to see if the theme set for the TabWorkspace is different fr...
CXTPTabClientWnd::GetItemColor
virtual COLORREF GetItemColor(const CXTPTabManagerItem *pItem) const
This member function returns the RGB value for the referenced item text, or (COLORREF)-1 if the color...
CXTPTabClientWnd::IsWorkspaceCommandEnabled
BOOL IsWorkspaceCommandEnabled(UINT nID, CXTPTabManagerItem **ppItem=NULL)
Returns the workspace command mode.
CXTPTabClientWnd::~CXTPTabClientWnd
virtual ~CXTPTabClientWnd()
Destroys a CXTPTabClientWnd object, handles cleanup and deallocation.
CXTPTabClientWnd::SetFlags
void SetFlags(DWORD dwButtons)
Call this member to set the flags of the tab workspace.
CXTPTabClientWnd::Detach
BOOL Detach()
Detaches the tabbed workspace.
CXTPTabClientWnd::FindItem
CXTPTabManagerItem * FindItem(const HWND hWnd) const
Call this member to find the item that corresponds to the specified window.
CXTPTabClientWnd::IsAttached
BOOL IsAttached() const
Determines if a tab workspace is attached.
Definition XTPTabClientWnd.h:1276
CXTPTabClientWnd::WorkspaceToScreen
void WorkspaceToScreen(LPPOINT lpPoint) const
Converts the workspace coordinates of a given point on the display to screen coordinates.
CXTPTabClientWnd::SaveState
void SaveState()
Saves Position state.
CXTPTabClientWnd::GetItemTooltip
virtual CString GetItemTooltip(const CXTPTabManagerItem *pItem) const
Returns the tooltip associated with the specified item.
CXTPTabClientWnd::Refresh
void Refresh(BOOL bRecalcLayout=TRUE)
Call this method to refresh all the items.
CXTPTabClientWnd::CreateNewVerticalGroup
void CreateNewVerticalGroup()
Creates a new vertical group.
CXTPTabClientWnd::FindIndex
int FindIndex(CXTPTabManager *pWorkspace) const
Call this member to find the specified index.
CXTPTabClientWnd::m_pToolTipContext
CXTPToolTipContext * m_pToolTipContext
Tooltip Context.
Definition XTPTabClientWnd.h:1104
CXTPTabClientWnd::CreateWorkspace
virtual CWorkspace * CreateWorkspace()
This method is called to create a new CWorkspace class.
CXTPTabClientWnd::CXTPTabClientWnd
CXTPTabClientWnd()
Constructs a CXTPTabClientWnd object.
CXTPTabClientWnd::CreateNewHorizontalGroup
void CreateNewHorizontalGroup()
Creates a new horizontal group.
CXTPTabClientWnd::m_afterCloseTabPosition
XTPWorkspaceActivateTab m_afterCloseTabPosition
Tab to make active after the currently active tab is closed.
Definition XTPTabClientWnd.h:1111
CXTPTabClientWnd::HitTest
CXTPTabManagerItem * HitTest(CPoint pt) const
Call this function to determine which tab, if any, is at the specified screen position.
CXTPTabClientWnd::Reposition
virtual void Reposition()
Call this method to reposition items.
CXTPTabClientWnd::MDIGetActive
virtual CWnd * MDIGetActive()
Retrieves the current active MDI child window.
CXTPTabClientWnd::OnFillBackground
virtual void OnFillBackground(CDC *pDC, CRect rc)
This member is called when the background is filled.
CXTPTabClientWnd::GetWorkspace
CWorkspace * GetWorkspace(int nIndex) const
Call this member to return the workspace at the specified index.
CXTPTabClientWnd::GetItemText
virtual CString GetItemText(const CWnd *pChildWnd) const
This member function retrieves the text of a specific tab.
CXTPTabClientWnd::LoadState
void LoadState()
Loads previous docking state.
CXTPTabClientWnd::GetSelectedItem
CXTPTabManagerItem * GetSelectedItem() const
Returns the selected item in the control.
CXTPTabClientWnd::MDIActivate
virtual void MDIActivate(CWnd *pWnd)
Call this member function to activate an MDI child window independently of the MDI frame window.
CXTPTabClientWnd::SetAfterCloseActiveTab
void SetAfterCloseActiveTab(XTPWorkspaceActivateTab activeTab)
Call this member to set where new tab must appear.
Definition XTPTabClientWnd.h:1316
CXTPTabClientWnd::SetLayoutRTL
void SetLayoutRTL(BOOL bRightToLeft)
Specifies if right-to-left (RTL) mode should be set.
CXTPTabClientWnd::ScreenToWorkspace
void ScreenToWorkspace(LPPOINT lpPoint) const
Converts the screen coordinates of a given point or rectangle on the display to client coordinates.
CXTPTabClientWnd::UseSplitterTracker
void UseSplitterTracker(BOOL bSplitterTracker)
Call this member to use trackers.
Definition XTPTabClientWnd.h:1296
CXTPTabClientWnd::AddWorkspace
virtual CWorkspace * AddWorkspace(int nIndex=-1)
Call this member function to add a workspace.
CXTPTabClientWnd::GetParentFrame
CMDIFrameWnd * GetParentFrame() const
Retrieves the parent frame of the control.
Definition XTPTabClientWnd.h:1281
CXTPTabClientWnd::SetNewTabPosition
void SetNewTabPosition(XTPWorkspaceNewTabPosition tabPosition)
Call this member to set where new tab must appear.
Definition XTPTabClientWnd.h:1306
CXTPTabClientWnd::GetToolTipContext
CXTPToolTipContext * GetToolTipContext() const
Call this method to get a pointer to the tooltip context.
Definition XTPTabClientWnd.h:1291
CXTPTabClientWnd::Attach
BOOL Attach(CXTPCommandBars *pCommandBars, CMDIFrameWnd *pParentFrame, BOOL bEnableGroups)
Attaches the tabbed workspace.
CXTPTabClientWnd::m_pParentFrame
CMDIFrameWnd * m_pParentFrame
Pointer to the corresponding parent MDIFrame window.
Definition XTPTabClientWnd.h:1076
CXTPTabClientWnd::SetCommandBars
void SetCommandBars(CXTPCommandBars *pCommandBars)
Sets the command bars object.
CXTPTabClientWnd::m_bEnableGroups
BOOL m_bEnableGroups
TRUE if TabWorkspace groups are enabled.
Definition XTPTabClientWnd.h:1097
CXTPTabClientWnd::GetFlags
DWORD GetFlags() const
Call this member to determine which tab navigation buttons are currently displayed in the tab workspa...
Definition XTPTabClientWnd.h:1286
CXTPTabClientWnd::GetNewTabPositon
XTPWorkspaceNewTabPosition GetNewTabPositon() const
This method is called to determine where the new tab must appear.
Definition XTPTabClientWnd.h:1311
CXTPTabClientWnd::IsAllowReorder
BOOL IsAllowReorder() const
Returns the current reordering allowance.
CXTPTabClientWnd::ContextMenu
void ContextMenu(CPoint pt)
This method shows the context menu for toolbars.
CXTPTabClientWnd::ShowWorkspace
void ShowWorkspace(BOOL bShow)
Call this member function to show/hide the workspace.
CXTPTabClientWnd::MoveToNextGroup
void MoveToNextGroup()
Moves an item to the next group.
CXTPTabClientWnd::GetCommandBars
virtual CXTPCommandBars * GetCommandBars() const
Gets the command bars object.
CXTPTabClientWnd::GetAutoTheme
BOOL GetAutoTheme() const
Call this member to determine if auto themes are used to theme the TabWorkspace.
CXTPTabManagerAtom
CXTPTabManagerAtom is a class that has only one purpose; to catch the event when a property of the Pa...
Definition XTPTabManagerAtom.h:49
CXTPTabManager
CXTPTabManager is the base class for docking pane tabs, tab control tabs, and MDI client tabs.
Definition XTPTabManager.h:87
CXTPTabManagerItem
CXTPTabManagerItem is the base class for the tabs that appear in the command bars tab workspace,...
Definition XTPTabManagerItem.h:44
CXTPTabPaintManager
CXTPTabPaintManager is used to store the color and appearance information of the tabs in the tab mana...
Definition XTPTabPaintManager.h:48
CXTPTearOffFrame
The class represents a floating torn off frame.
Definition XTPTearOffFrame.h:86
CXTPToolTipContext
CXTPToolTipContext is a CXTPCmdTarget derived class.
Definition XTPToolTipContext.h:291


Toolkit Pro: Member List

CXTPChartNumericalScaleTypeMap Member List

This is the complete list of members for CXTPChartNumericalScaleTypeMap, including all inherited members.

Create(CXTPChartAxis *pAxis) | CXTPChartScaleTypeMap | static
CXTPChartElement() | CXTPChartElement |
CXTPChartNumericalScaleTypeMap(CXTPChartAxis *pAxis) | CXTPChartNumericalScaleTypeMap |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartScaleTypeMap(CXTPChartAxis *pAxis) | CXTPChartScaleTypeMap |
DoPropExchange(CXTPPropExchange *pPX) | CXTPChartElement | virtual
GetAppearance() const | CXTPChartElement |
GetAxis() const | CXTPChartScaleTypeMap |
GetContent() const | CXTPChartElement |
GetOwner() const | CXTPChartElement |
InternalToValue(CXTPChartNumberFormat *pFromat, double dValue) const | CXTPChartNumericalScaleTypeMap | virtual
Is3D() const | CXTPChartObject |
m_dMaxValue | CXTPChartNumericalScaleTypeMap | protected
m_dMinValue | CXTPChartNumericalScaleTypeMap | protected
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartElement | virtual
Release() | CXTPChartElement | virtual
UpdateSeries(CXTPChartAxisView *pAxisView) | CXTPChartScaleTypeMap | virtual
UpdateSeries(CXTPChartSeries *pSeries) | CXTPChartScaleTypeMap | virtual
UpdateSeriesPointArgument(CXTPChartSeriesPoint *pPoint) | CXTPChartNumericalScaleTypeMap | protectedvirtual
ValueToInternal(const CXTPChartString &strValue) const | CXTPChartNumericalScaleTypeMap | virtual
~CXTPChartElement() | CXTPChartElement | virtual
~CXTPChartScaleTypeMap() | CXTPChartScaleTypeMap | virtual


Toolkit Pro: Member List

CXTPCalendarTimeLineViewGroup Member List

This is the complete list of members for CXTPCalendarTimeLineViewGroup, including all inherited members.

AddResource(CXTPCalendarResource *pResource, BOOL bWithAddRef) | CXTPCalendarViewGroup | virtual
AdjustLayout(CDC *pDC, const CRect &rcGroup) | CXTPCalendarTimeLineViewGroup | virtual
AdjustLayout2(CDC *pDC, const CRect &rcGroup) | CXTPCalendarViewGroup | virtual
CXTPCalendarTimeLineViewGroup(CXTPCalendarTimeLineView *pView, CXTPCalendarTimeLineViewGroup *pParentGroup=NULL) | CXTPCalendarTimeLineViewGroup |
CXTPCalendarViewGroup(CXTPCalendarViewDay *pViewDay) | CXTPCalendarViewGroup |
CXTPCalendarWMHandler() | CXTPCalendarWMHandler |
CXTPCmdTarget() | CXTPCmdTarget |
Draw(CDC *pDC, int nOffset) | CXTPCalendarTimeLineViewGroup | virtual
Draw(CDC *pDC) | CXTPCalendarTimeLineViewGroup | virtual
ExchangeEventPlace(CXTPCalendarViewEvent *pViewEvent, int nNewPlace) | CXTPCalendarViewGroup | virtual
FillHitTestEx(XTP_CALENDAR_HITTESTINFO *pHitTest) const | CXTPCalendarTimeLineViewGroup | inlinevirtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCalendarControl() const | CXTPCalendarTimeLineViewGroup | virtual
GetCaption() const | CXTPCalendarViewGroup | virtual
GetChildHandlerAt(int nIndex) const | CXTPCalendarViewGroup | virtual
GetChildHandlersCount() const | CXTPCalendarViewGroup | virtual
GetDataProvider() const | CXTPCalendarViewGroup | virtual
GetGroupHeight() | CXTPCalendarTimeLineViewGroup |
GetGroupIndex() const | CXTPCalendarViewGroup | virtual
GetHeaderRect() const | CXTPCalendarViewGroup | inlinevirtual
GetRect() const | CXTPCalendarViewGroup | inlinevirtual
GetResources() const | CXTPCalendarViewGroup | virtual
GetScheduleID() const | CXTPCalendarViewGroup | virtual
GetTooltipRect(const CPoint &ptHit, const XTP_CALENDAR_HITTESTINFO &hitInfo) const | CXTPCalendarViewGroup | virtual
GetView() const | CXTPCalendarTimeLineViewGroup | inline
GetViewDay_() const | CXTPCalendarTimeLineViewGroup | inlinevirtual
GetViewEvent(int nIndex) const | CXTPCalendarTimeLineViewGroup | inlinevirtual
GetViewEvent_(int nIndex) const | CXTPCalendarViewGroup |
GetViewEventByEvent_(CXTPCalendarEvent *pEvent) const | CXTPCalendarViewGroup | virtual
GetViewEventByPlace_(int nEventPlace) const | CXTPCalendarViewGroup | virtual
GetViewEventsCount() const | CXTPCalendarViewGroup |
HitTest(CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const | CXTPCalendarTimeLineViewGroup | inlinevirtual
HitTestEx(CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const | CXTPCalendarViewGroup | virtual
KillTimer(UINT uTimerID) | CXTPCalendarViewGroup | protectedvirtual
m_arEvents | CXTPCalendarViewGroup | protected
m_Layout | CXTPCalendarViewGroup | protected
m_pChildren | CXTPCalendarTimeLineViewGroup | protected
m_pParentGroup | CXTPCalendarTimeLineViewGroup | protected
m_pResources | CXTPCalendarViewGroup | protected
m_pViewDay | CXTPCalendarViewGroup | protected
OnBeforeDestroy() | CXTPCalendarWMHandler | virtual
OnChar(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnKeyUp(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnLButtonDblClk(UINT nFlags, CPoint point) | CXTPCalendarWMHandler | virtual
OnLButtonDown(UINT nFlags, CPoint point) | CXTPCalendarWMHandler | virtual
OnLButtonUp(UINT nFlags, CPoint point) | CXTPCalendarWMHandler | virtual
OnMouseMove(UINT nFlags, CPoint point) | CXTPCalendarWMHandler | virtual
OnPostAdjustLayout() | CXTPCalendarWMHandler | virtual
OnPrePopulate(CXTPCalendarEvents *pEvents) | CXTPCalendarViewGroup | protectedvirtual
OnSysKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnTimer(UINT_PTR uTimerID) | CXTPCalendarWMHandler | virtual
OnWndMsg(UINT message, WPARAM wParam, LPARAM lParam, LRESULT *pResult) | CXTPCalendarWMHandler | virtual
Populate(COleDateTime dtDayDate) | CXTPCalendarTimeLineViewGroup | inlinevirtual
Populate(CXTPCalendarEvents *pEvents) | CXTPCalendarTimeLineViewGroup | virtual
SetResources(CXTPCalendarResources *pResources) | CXTPCalendarViewGroup | virtual
SetTimer(UINT uTimeOut_ms) | CXTPCalendarViewGroup | protectedvirtual
TBase typedef | CXTPCalendarTimeLineViewGroup |
TViewEventsCollection typedef | CXTPCalendarTimeLineViewGroup | protected
~CXTPCalendarTimeLineViewGroup() | CXTPCalendarTimeLineViewGroup | virtual
~CXTPCalendarViewGroup() | CXTPCalendarViewGroup | virtual


Toolkit Pro: Member List

CXTPChartSplineAreaSeriesStyle Member List

This is the complete list of members for CXTPChartSplineAreaSeriesStyle, including all inherited members.

ApplyTo(CXTPChartDeviceCommand *pCommand) | CXTPChartSeriesStyle | virtual
CorrectAxisSideMargins(CXTPChartAxis *pAxis, double nMinValue, double nMaxValue, double &nCorrection) | CXTPChartSeriesStyle | virtual
CreateDiagram() | CXTPChartDiagram2DSeriesStyle | virtual
CreateView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView) | CXTPChartSplineAreaSeriesStyle | protectedvirtual
CXTPChartAreaSeriesStyle() | CXTPChartAreaSeriesStyle |
CXTPChartDiagram2DSeriesStyle() | CXTPChartDiagram2DSeriesStyle |
CXTPChartElement() | CXTPChartElement |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartPointSeriesStyle() | CXTPChartPointSeriesStyle |
CXTPChartSeriesStyle() | CXTPChartSeriesStyle |
CXTPChartSplineAreaSeriesStyle() | CXTPChartSplineAreaSeriesStyle |
DoPropExchange(CXTPPropExchange *pPX) | CXTPChartAreaSeriesStyle | virtual
Enable3dEdgeSmoothing(BOOL bEnable=TRUE) | CXTPChartSeriesStyle | virtual
Get3dRotation() const | CXTPChartSeriesStyle | virtual
GetAppearance() const | CXTPChartElement |
GetColor() const | CXTPChartSeriesStyle | virtual
GetContent() const | CXTPChartElement |
GetErrorBar() const | CXTPChartSeriesStyle | virtual
GetFillAcrossXAxis() const | CXTPChartAreaSeriesStyle |
GetFillStyle() const | CXTPChartAreaSeriesStyle |
GetLabel() const | CXTPChartSeriesStyle | virtual
GetMarker() const | CXTPChartPointSeriesStyle |
GetOwner() const | CXTPChartElement |
GetSeriesPointValueIndex() const | CXTPChartSeriesStyle | virtual
GetStyleAppearance() const | CXTPChartSeriesStyle | virtual
GetTransparency() const | CXTPChartAreaSeriesStyle | virtual
Is3D() const | CXTPChartObject |
Is3dEdgeSmoothingEnabled() const | CXTPChartSeriesStyle | virtual
IsColorEach() const | CXTPChartSeriesStyle | virtual
IsStyleDiagram(CXTPChartDiagram *pDiagram) const | CXTPChartDiagram2DSeriesStyle | virtual
m_bColorEach | CXTPChartSeriesStyle | protected
m_bSmooth3dEdges | CXTPChartSeriesStyle | protected
m_clrColor | CXTPChartSeriesStyle | protected
m_nAxisIndexX | CXTPChartDiagram2DSeriesStyle | protected
m_nAxisIndexY | CXTPChartDiagram2DSeriesStyle | protected
m_nFillAcrossXAxis | CXTPChartAreaSeriesStyle | protected
m_nTransparency | CXTPChartAreaSeriesStyle | protected
m_pBorder | CXTPChartAreaSeriesStyle | protected
m_pErrorBar | CXTPChartSeriesStyle | protected
m_pFillStyle | CXTPChartAreaSeriesStyle | protected
m_pLabel | CXTPChartSeriesStyle | protected
m_Rotation3d | CXTPChartSeriesStyle | protected
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartElement | virtual
Release() | CXTPChartElement | virtual
Set3dRotation(const CXTPChart3dRotation &rotation) | CXTPChartSeriesStyle | virtual
Set3dRotation(double dYaw, double dPitch, double dRoll) | CXTPChartSeriesStyle | virtual
SetColor(CXTPChartColor clr) | CXTPChartSeriesStyle | virtual
SetColorEach(BOOL bColorEach) | CXTPChartSeriesStyle | virtual
SetErrorBar(CXTPChartErrorBar *pErrorBar) | CXTPChartSeriesStyle | virtual
SetFillAcrossXAxis(BOOL nFillAcrossXAxis) | CXTPChartAreaSeriesStyle |
SetLabel(CXTPChartSeriesLabel *pLabel) | CXTPChartSeriesStyle | virtual
SetTransparency(int nTransparency) | CXTPChartAreaSeriesStyle | virtual
~CXTPChartAreaSeriesStyle() | CXTPChartAreaSeriesStyle | virtual
~CXTPChartDiagram2DSeriesStyle() | CXTPChartDiagram2DSeriesStyle | virtual
~CXTPChartElement() | CXTPChartElement | virtual
~CXTPChartPointSeriesStyle() | CXTPChartPointSeriesStyle | virtual
~CXTPChartSeriesStyle() | CXTPChartSeriesStyle | virtual
~CXTPChartSplineAreaSeriesStyle() | CXTPChartSplineAreaSeriesStyle | virtual


Toolkit Pro: XTPDockingPaneThemeWinExplorer.h Source File

  • Source
  • DockingPane
  • Themes
XTPDockingPaneThemeWinExplorer.h
Go to the documentation of this file.
1
23#if !defined(__XTPDOCKINGPANETHEMEWINEXPLORER_H__)
24# define __XTPDOCKINGPANETHEMEWINEXPLORER_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
40class _XTP_EXT_CLASS CXTPDockingPaneWinExplorerTheme : public CXTPDockingPaneGripperedTheme
41{
42public:
47 CXTPDockingPaneWinExplorerTheme();
48
49public:
54 void RefreshMetrics();
55
56protected:
67 virtual void DrawCaptionPart(CDC* pDC, CXTPDockingPaneBase* pPane, CRect rcCaption,
68 const CString& strTitle, BOOL bActive, BOOL bVertical);
69};
70
71# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
73#endif // !defined(__XTPDOCKINGPANETHEMEWINEXPLORER_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPDockingPaneBase
CXTPDockingPaneBase is a standalone class.
Definition XTPDockingPaneBase.h:69
CXTPDockingPaneGripperedTheme
CXTPDockingPaneGripperedTheme is a CXTPDockingPaneDefaultTheme derived class that represents a grippe...
Definition XTPDockingPaneThemeGrippered.h:41
CXTPDockingPaneWinExplorerTheme
CXTPDockingPaneWinExplorerTheme is a CXTPDockingPaneDefaultTheme derived class that represents an Exp...
Definition XTPDockingPaneThemeWinExplorer.h:41
CXTPDockingPaneWinExplorerTheme::CXTPDockingPaneWinExplorerTheme
CXTPDockingPaneWinExplorerTheme()
Constructs a CXTPDockingPaneWinExplorerTheme object.
CXTPDockingPaneWinExplorerTheme::RefreshMetrics
void RefreshMetrics()
This method is called to refresh the visual metrics of the pane.
CXTPDockingPaneWinExplorerTheme::DrawCaptionPart
virtual void DrawCaptionPart(CDC *pDC, CXTPDockingPaneBase *pPane, CRect rcCaption, const CString &strTitle, BOOL bActive, BOOL bVertical)
Draws the common part of a tabbed and floating caption.


Toolkit Pro: Member List

XTP_NM_GRIDITEMCONTROL Member List

This is the complete list of members for XTP_NM_GRIDITEMCONTROL, including all inherited members.

hdr | XTP_NM_GRIDRECORDITEM
nHyperlink | XTP_NM_GRIDRECORDITEM
pColumn | XTP_NM_GRIDRECORDITEM
pItem | XTP_NM_GRIDRECORDITEM
pItemControl | XTP_NM_GRIDITEMCONTROL
pRow | XTP_NM_GRIDRECORDITEM
pt | XTP_NM_GRIDRECORDITEM


Toolkit Pro: Member List

CXTPChartBoundedCircleDeviceCommand Member List

This is the complete list of members for CXTPChartBoundedCircleDeviceCommand, including all inherited members.

AddChildCommand(CXTPChartDeviceCommand *pCommand) | CXTPChartDeviceCommand |
AfterExecute(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
ApplySeriesStyle(CXTPChartSeriesStyle *pStyle) | CXTPChartDeviceCommand | virtual
BeforeExecute(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
BindView(CXTPChartElementView *pView) | CXTPChartDeviceCommand |
Commit() | CXTPChartDeviceCommand |
CXTPChartBoundedCircleDeviceCommand(const CXTPChartPointF &center, double radius, const CXTPChartColor &color, int thickness) | CXTPChartBoundedCircleDeviceCommand | protected
CXTPChartDeviceCommand() | CXTPChartDeviceCommand |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPObservable() | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | protected
Execute(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
ExecuteOverride(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
GetBoundView() const | CXTPChartDeviceCommand |
GetChildCommand(int nIndex) const | CXTPChartDeviceCommand |
GetChildCommandCount() const | CXTPChartDeviceCommand |
GetCurrentDC() const | CXTPChartDeviceCommand |
GetPassNumber() const | CXTPChartDeviceCommand |
HitTest(CPoint point, CXTPChartElement *pParent) const | CXTPChartDeviceCommand | virtual
Is3D() const | CXTPChartObject |
IsCommitted() const | CXTPChartDeviceCommand |
IsEnabled() const | CXTPChartDeviceCommand | virtual
m_arrChildren | CXTPChartDeviceCommand | protected
m_center | CXTPChartBoundedCircleDeviceCommand | protected
m_color | CXTPChartBoundedCircleDeviceCommand | protected
m_radius | CXTPChartBoundedCircleDeviceCommand | protected
m_thickness | CXTPChartBoundedCircleDeviceCommand | protected
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Prepare(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
PrepareOverride(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
SetEnabled(BOOL bEnabled=TRUE) | CXTPChartDeviceCommand |
Subscribe(CXTPChartDeviceCommandEvents *pObserver, CXTPSubscriptionList< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > *pSubcriptionList=NULL) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > |
Unsubscribe(CXTPChartDeviceCommandEvents *pObserver) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > |
~CXTPChartDeviceCommand() | CXTPChartDeviceCommand | virtual
~CXTPObservable() | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | protected


Toolkit Pro: Member List

CXTPFontEnum Member List

This is the complete list of members for CXTPFontEnum, including all inherited members.

AddFont(const LOGFONT *pLF, DWORD dwType) | CXTPFontEnum | protected
CXTPFontEnum() | CXTPFontEnum | protected
DoesFontExist(CString &strFaceName) | CXTPFontEnum |
EnumFontFamExProc(ENUMLOGFONTEX *pelf, NEWTEXTMETRICEX *lpntm, DWORD dwFontType, LPARAM lParam) | CXTPFontEnum | protectedstatic
Get() | CXTPFontEnum | static
GetFontList() | CXTPFontEnum |
GetLogFont(const CString &strFaceName) | CXTPFontEnum |
GetMaxWidth() | CXTPFontEnum |
GetMaxWidth(LPCTSTR lpString) | CXTPFontEnum |
Init(CDC *pDC=NULL, BYTE nCharSet=DEFAULT_CHARSET) | CXTPFontEnum |
m_listFonts | CXTPFontEnum | protected
~CXTPFontEnum() | CXTPFontEnum | virtual


Toolkit Pro: XTPComboBoxThemeOffice2013.h Source File

  • Source
  • Controls
  • Combo
  • Themes
XTPComboBoxThemeOffice2013.h
Go to the documentation of this file.
1
23#if !defined(__XTPCOMBOBOXTHEMEOFFICE2013_H__)
24# define __XTPCOMBOBOXTHEMEOFFICE2013_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPComboBoxThemeOffice2013 : public CXTPComboBoxThemeVisualStudio
39{
40public:
45 CXTPComboBoxThemeOffice2013();
46
51 virtual ~CXTPComboBoxThemeOffice2013();
52
59 virtual void RefreshMetrics(CXTPComboBox* pComboBox);
60
69 virtual void DrawButton(CDC* pDC, CXTPComboBox* pComboBox, CRect rcBtn);
70
79 virtual void DrawButtonTriangle(CDC* pDC, CXTPComboBox* pComboBox, CRect rcBtn);
80
87 virtual void DrawBackground(CDC* pDC, CXTPComboBox* pComboBox);
88
89protected:
90 CXTPPaintManagerColor m_clrButtonDisabled;
91 CXTPPaintManagerColor m_clrButtonArrowDisabled;
92};
93
94# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
96#endif // __XTPCOMBOBOXTHEMEOFFICE2013_H__
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPComboBox
The CXTPComboBox class provides the functionality of a themed Windows combobox.
Definition XTPComboBox.h:42
CXTPComboBoxThemeOffice2013
Used as the paint manager for a combobox control to render an Office 2013 appearance.
Definition XTPComboBoxThemeOffice2013.h:39
CXTPComboBoxThemeOffice2013::RefreshMetrics
virtual void RefreshMetrics(CXTPComboBox *pComboBox)
This member function is called by the theme manager to refresh the visual styles used by each compone...
CXTPComboBoxThemeOffice2013::CXTPComboBoxThemeOffice2013
CXTPComboBoxThemeOffice2013()
Default constructor.
CXTPComboBoxThemeOffice2013::m_clrButtonArrowDisabled
CXTPPaintManagerColor m_clrButtonArrowDisabled
Drop down arrow disabled color.
Definition XTPComboBoxThemeOffice2013.h:91
CXTPComboBoxThemeOffice2013::~CXTPComboBoxThemeOffice2013
virtual ~CXTPComboBoxThemeOffice2013()
Destructor handles cleanup and deallocation.
CXTPComboBoxThemeOffice2013::m_clrButtonDisabled
CXTPPaintManagerColor m_clrButtonDisabled
Drop down button disabled color.
Definition XTPComboBoxThemeOffice2013.h:90
CXTPComboBoxThemeOffice2013::DrawButton
virtual void DrawButton(CDC *pDC, CXTPComboBox *pComboBox, CRect rcBtn)
Called by the paint manager to draw the button portion of the combobox control.
CXTPComboBoxThemeOffice2013::DrawButtonTriangle
virtual void DrawButtonTriangle(CDC *pDC, CXTPComboBox *pComboBox, CRect rcBtn)
Called by the paint manager to draw the drop down arrow for the combobox drop button.
CXTPComboBoxThemeOffice2013::DrawBackground
virtual void DrawBackground(CDC *pDC, CXTPComboBox *pComboBox)
This member function is called to draw the combobox background.
CXTPComboBoxThemeVisualStudio
Used as the paint manager for a combobox control to render a Visual Studio appearance.
Definition XTPComboBoxThemeVisualStudio.h:39
CXTPPaintManagerColor
The CXTPPaintManagerColor class is used to manage COLORREF values for determining default and applica...
Definition XTPColorManager.h:117


Toolkit Pro: XTPScrollBarThemeFlat.h Source File

  • Source
  • Common
  • ScrollBar
  • Themes
XTPScrollBarThemeFlat.h
Go to the documentation of this file.
1
23#if !defined(__XTPSCROLLBARTHEMEFLAT_H__)
24# define __XTPSCROLLBARTHEMEFLAT_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPScrollBarThemeFlat : public CXTPScrollBarThemeWindowsUx
39{
40protected:
45 virtual void RefreshMetrics();
46
54 virtual void DrawButtons(CDC* pDC, CXTPScrollBase* pScroll, XTPScrollMetricsV* pMetrics);
55
63 virtual void DrawArrows(CDC* pDC, CXTPScrollBase* pScroll, XTPScrollMetricsV* pMetrics);
64
72 virtual void DrawTracker(CDC* pDC, CXTPScrollBase* pScroll, XTPScrollMetricsV* pMetrics);
73
81 virtual void DrawThumbButton(CDC* pDC, CXTPScrollBase* pScroll, XTPScrollMetricsV* pMetrics);
82
90 virtual void DrawButtons(CDC* pDC, CXTPScrollBase* pScroll, XTPScrollMetricsH* pMetrics);
91
99 virtual void DrawArrows(CDC* pDC, CXTPScrollBase* pScroll, XTPScrollMetricsH* pMetrics);
100
108 virtual void DrawTracker(CDC* pDC, CXTPScrollBase* pScroll, XTPScrollMetricsH* pMetrics);
109
117 virtual void DrawThumbButton(CDC* pDC, CXTPScrollBase* pScroll, XTPScrollMetricsH* pMetrics);
118
125 virtual void DrawGripper(CDC* pDC, CXTPScrollBase* pScroll);
126};
127
128# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
130#endif /*__XTPSCROLLBARTHEMEFLAT_H__*/
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPScrollBarThemeFlat
Scrollbar paint manager used to draw flat scrollbars.
Definition XTPScrollBarThemeFlat.h:39
CXTPScrollBarThemeFlat::DrawButtons
virtual void DrawButtons(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar buttons only.
CXTPScrollBarThemeFlat::DrawArrows
virtual void DrawArrows(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar button arrows only.
CXTPScrollBarThemeFlat::DrawTracker
virtual void DrawTracker(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar trackers only.
CXTPScrollBarThemeFlat::DrawGripper
virtual void DrawGripper(CDC *pDC, CXTPScrollBase *pScroll)
Draws scrollbar gripper only.
CXTPScrollBarThemeFlat::DrawButtons
virtual void DrawButtons(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws vertical scrollbar buttons only.
CXTPScrollBarThemeFlat::DrawTracker
virtual void DrawTracker(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws vertical scrollbar trackers only.
CXTPScrollBarThemeFlat::DrawArrows
virtual void DrawArrows(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws vertical scrollbar button arrows only.
CXTPScrollBarThemeFlat::DrawThumbButton
virtual void DrawThumbButton(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar thumb button only.
CXTPScrollBarThemeFlat::RefreshMetrics
virtual void RefreshMetrics()
Recalculates scrollbar metrics.
CXTPScrollBarThemeFlat::DrawThumbButton
virtual void DrawThumbButton(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws vertical scrollbar thumb button only.
CXTPScrollBarThemeWindowsUx
Scrollbar paint manager used to draw scrollbars that use current Windows theme.
Definition XTPScrollBarThemeWindowsUx.h:39
CXTPScrollBase
CXTPScrollBase is the base class for all scrollable objects.
Definition XTPScrollBase.h:222


Toolkit Pro: Member List

CXTPCommandBarsNativeWindows10Theme Member List

This is the complete list of members for CXTPCommandBarsNativeWindows10Theme, including all inherited members.

AdjustExcludeRect(CRect &rc, CXTPControl *pControl, BOOL bVertical) | CXTPCommandBarsOfficeXPTheme | virtual
Animate(CDC *pDestDC, CDC *pSrcDC, CRect rc, XTPAnimationType animationType) | CXTPPaintManager | virtual
AnimateExpanding(CXTPCommandBar *pCommandBar, CDC *pDestDC, CDC *pSrcDC, BOOL bExpandDown) | CXTPPaintManager | virtual
BaseTheme() | CXTPCommandBarsOffice2013Theme | virtual
CreateTheme(XTPPaintTheme paintTheme) | CXTPPaintManager | static
CXTPCmdTarget() | CXTPCmdTarget |
CXTPCommandBarsModernUITheme() | CXTPCommandBarsModernUITheme |
CXTPCommandBarsNativeWindows10Theme() | CXTPCommandBarsNativeWindows10Theme |
CXTPCommandBarsOffice2013Theme() | CXTPCommandBarsOffice2013Theme |
CXTPCommandBarsOfficeXPTheme() | CXTPCommandBarsOfficeXPTheme |
CXTPObservable() | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | protected
CXTPPaintManager() | CXTPPaintManager | protected
Draw3dRect(CDC *pDC, LPCRECT rc, int nTopLeft, int nBottomRight) | CXTPPaintManager |
Draw3dRect(CDC *pDC, LPCRECT rc, int frameThickness, COLORREF clrPen, COLORREF clrBrush) | CXTPPaintManager |
CXTPPaintManager::DrawCheckMark(CDC *pDC, CRect rcCheck, COLORREF clr=0) | CXTPPaintManager | inline
DrawCheckRect(CDC *pDC, CRect rc, COLORREF clrFore, COLORREF clrBack) | CXTPCommandBarsNativeWindows10Theme | protectedvirtual
DrawComboExpandMark(CDC *pDC, CRect rc, COLORREF clr) | CXTPPaintManager | virtual
DrawCommandBarGripper(CDC *pDC, CXTPCommandBar *pBar, BOOL bDraw=TRUE) | CXTPCommandBarsNativeWindows10Theme | protectedvirtual
DrawCommandBarGroupSeparator(CDC *pDC, CXTPCommandBar *pBar, CXTPControl *pLeftControl, CXTPControl *pRightControl, BOOL bDraw) | CXTPCommandBarsOffice2013Theme | virtual
DrawCommandBarSeparator(CDC *pDC, CXTPCommandBar *pBar, CXTPControl *pControl, BOOL bDraw=TRUE) | CXTPCommandBarsOffice2013Theme | protectedvirtual
DrawControl(CDC *pDC, CXTPControl *pButton, BOOL bDraw=TRUE) | CXTPPaintManager |
DrawControlCheckBoxMark(CDC *pDC, CXTPControl *pButton, CRect rc, BOOL bDraw) | CXTPCommandBarsOffice2013Theme | protectedvirtual
DrawControlCheckBoxMark(CDC *pDC, CRect rc, BOOL bDraw, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled) | CXTPCommandBarsOffice2013Theme | protectedvirtual
DrawControlComboBox(CDC *pDC, CXTPControlComboBox *pComboBox, BOOL bDraw) | CXTPCommandBarsNativeWindows10Theme | protectedvirtual
DrawControlEdit(CDC *pDC, CXTPControlEdit *pEdit, BOOL bDraw) | CXTPCommandBarsOffice2013Theme | virtual
DrawControlEntry(CDC *pDC, CXTPControl *pButton) | CXTPPaintManager | virtual
DrawControlMDIButton(CDC *pDC, CXTPControlButton *pButton) | CXTPCommandBarsOffice2013Theme | protectedvirtual
DrawControlPopupParent(CDC *pDC, CXTPControl *pButton, BOOL bDraw) | CXTPCommandBarsOfficeXPTheme | protectedvirtual
DrawControlRadioButtonMark(CDC *pDC, CRect rc, BOOL bDraw, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled) | CXTPCommandBarsOffice2013Theme | protectedvirtual
DrawControlText(CDC *pDC, CXTPControl *pControl, CRect rcText, BOOL bDraw, BOOL bVert, BOOL bCentered, BOOL bTriangled) | CXTPPaintManager |
DrawControlToolBarParent(CDC *pDC, CXTPControl *pButton, BOOL bDraw) | CXTPPaintManager | virtual
DrawDialogBarGripper(CDC *pDC, CXTPDialogBar *pBar, BOOL bDraw) | CXTPCommandBarsOfficeXPTheme | virtual
DrawDropDownGlyph(CDC *pDC, CXTPControl *pControl, CPoint pt, BOOL bSelected, BOOL bPopuped, BOOL bEnabled, BOOL bVert) | CXTPCommandBarsOffice2013Theme | protectedvirtual
DrawExpandGlyph(CDC *pDC, CXTPControl *pButton, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clr) | CXTPCommandBarsOffice2013Theme | protectedvirtual
DrawExpandGlyph(CDC *pDC, CXTPControl *pButton, COLORREF clr, BOOL bVertical) | CXTPCommandBarsOffice2013Theme | protectedvirtual
DrawFrameBorder(CDC *pDC, CRect rc, int nBorderThickness, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition) | CXTPCommandBarsOffice2013Theme | protected
DrawGalleryItemBack(CDC *pDC, CRect rcItem, BOOL bEnabled, BOOL bSelected, BOOL bPressed, BOOL bChecked, XTPBarType barType) | CXTPCommandBarsNativeWindows10Theme | protectedvirtual
DrawHiddenGlyph(CDC *pDC, CXTPControl *pButton, COLORREF clr, BOOL bVertical) | CXTPCommandBarsOffice2013Theme | protectedvirtual
DrawImage(CDC *pDC, CPoint pt, CSize sz, CXTPImageManagerIcon *pImage, BOOL bSelected, BOOL bPressed, BOOL bEnabled=TRUE, BOOL bChecked=FALSE, BOOL bPopuped=FALSE, BOOL bToolBarImage=TRUE) | CXTPCommandBarsOfficeXPTheme | protectedvirtual
DrawListBoxControl(CDC *pDC, CXTPControl *pButton, CRect rc, BOOL bSelected, BOOL bDraw, CXTPCommandBars *pCommandBars=0) | CXTPCommandBarsOfficeXPTheme | virtual
DrawPopupBarCheckMark(CDC *pDC, CRect rcCheck, BOOL bEnabled, COLORREF clr) | CXTPPaintManager | virtual
DrawPopupBarGripper(CDC *pDC, int xPos, int yPos, int cx, int cy, BOOL bExpanded=FALSE) | CXTPCommandBarsOffice2013Theme | protectedvirtual
DrawPopupBarRadioMark(CDC *pDC, CRect rcCheck, BOOL bEnabled, COLORREF clr) | CXTPPaintManager | virtual
DrawPopupResizeGripper(CDC *pDC, CRect rcGripper, int nFlags) | CXTPCommandBarsOfficeXPTheme | virtual
DrawRectangle(CDC *pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition) | CXTPCommandBarsNativeWindows10Theme | protectedvirtual
DrawRectangle(CDC *pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition, int nID) | CXTPCommandBarsNativeWindows10Theme | protectedvirtual
DrawRectangle(CDC *pDC, CXTPControl *pButton) | CXTPCommandBarsNativeWindows10Theme | protectedvirtual
DrawSpecialControl(CDC *pDC, XTPSpecialControl controlType, CXTPControl *pButton, CXTPCommandBar *pBar, BOOL bDraw, LPVOID lpParam) | CXTPPaintManager | virtual
DrawSplitButtonFrame(CDC *pDC, CXTPControl *pButton, CRect rc) | CXTPCommandBarsNativeWindows10Theme | protectedvirtual
DrawTearOffGripper(CDC *pDC, CRect rcGripper, BOOL bSelected, BOOL bDraw) | CXTPCommandBarsOfficeXPTheme | virtual
FillCommandBarEntry(CDC *pDC, CXTPCommandBar *pBar) | CXTPCommandBarsOffice2013Theme | virtual
FillDockBar(CDC *pDC, CXTPDockBar *pBar) | CXTPCommandBarsOffice2013Theme | virtual
FillIntersectRect(CDC *pDC, CXTPPopupBar *pPopupBar, COLORREF clr) | CXTPCommandBarsOfficeXPTheme | protected
FillWorkspace(CDC *pDC, CRect rc, CRect rcExclude) | CXTPCommandBarsOffice2013Theme | virtual
FontExists(LPCTSTR lpszFaceName) | CXTPPaintManager | static
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCommandBarBorders(CXTPCommandBar *pBar) | CXTPPaintManager | virtual
GetCommandBarFont(CXTPCommandBar *pCommandBar) | CXTPPaintManager | virtual
GetControlBackColor(CXTPControl *pButton) | CXTPCommandBarsOffice2013Theme | protectedvirtual
GetControlEditBackColor(CXTPControl *pControl) | CXTPCommandBarsOffice2013Theme | virtual
GetControlFont(CXTPControl *pControl) | CXTPPaintManager | virtual
GetControlHeight() const | CXTPPaintManager |
GetControlTextColor(CXTPControl *pButton) | CXTPCommandBarsNativeWindows10Theme | protectedvirtual
GetControlTextOrientation(CXTPControl *pControl) | CXTPPaintManager | virtual
GetCurrentSystemTheme() | CXTPPaintManager |
GetCurrentTheme() | CXTPPaintManager | inline
GetDefaultCommandBarSize(CXTPCommandBar *pBar) | CXTPPaintManager | virtual
GetFramePaintManager() | CXTPCommandBarsModernUITheme | virtual
GetGalleryPaintManager() const | CXTPPaintManager | virtual
GetGlobalPaintManager() | CXTPPaintManager | static
GetIconFont() | CXTPPaintManager |
GetIconsInfo() | CXTPPaintManager |
GetInstanceAddRef() | CXTPPaintManager | static
GetMarkupContext() | CXTPCommandBarsModernUITheme | virtual
GetMessageBarPaintManager() | CXTPPaintManager | virtual
GetPopupBarGripperWidth(CXTPCommandBar *pBar) | CXTPPaintManager | virtual
GetProgressPaintManager() const | CXTPPaintManager | virtual
GetRectangleTextColor(BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition) | CXTPCommandBarsOffice2013Theme | protectedvirtual
GetRegularBoldFont() | CXTPPaintManager |
GetRegularFont() | CXTPPaintManager |
GetRibbonPaintManager() | CXTPCommandBarsModernUITheme | virtual
GetScrollBarPaintManager() const | CXTPPaintManager | virtual
GetShadowManager() const | CXTPPaintManager |
GetShadowOptions() const | CXTPPaintManager |
GetSliderPaintManager() const | CXTPPaintManager | virtual
GetSmCaptionFont() | CXTPPaintManager |
GetSplitButtonCommandRect(CXTPControl *pButton) | CXTPPaintManager | virtual
GetStateColor() const | CXTPCommandBarsNativeWindows10Theme | virtual
GetStatusBarPaintManager() | CXTPPaintManager | virtual
GetXtremeColor(UINT nIndex) | CXTPPaintManager |
GradientFill(CDC *pDC, LPRECT lpRect, COLORREF crFrom, COLORREF crTo, BOOL bHorz, LPCRECT lpRectClip=NULL) | CXTPPaintManager |
HorizontalLine(CDC *pDC, int x0, int y0, int x1, COLORREF clrPen) | CXTPPaintManager |
IsUseSystemAccentColorEnabled() const | CXTPPaintManager |
Line(CDC *pDC, CPoint p0, CPoint p1) | CXTPPaintManager |
Line(CDC *pDC, int x0, int y0, int x1, int y1, const int nPen) | CXTPPaintManager |
Line(CDC *pDC, int x0, int y0, int x1, int y1, COLORREF clrPen) | CXTPPaintManager |
m_arrColor | CXTPPaintManager | protected
m_bAutoResizeIcons | CXTPPaintManager |
m_bClearTypeTextQuality | CXTPPaintManager |
m_bEmbossedDisabledText | CXTPPaintManager | protected
m_bEnableAnimation | CXTPPaintManager |
m_bFlatMenuBar | CXTPPaintManager |
m_bFlatToolBar | CXTPPaintManager |
m_bIntersect | CXTPCommandBarsOffice2013Theme | protected
m_bOffice2007Padding | CXTPPaintManager |
m_bOffsetPopupLabelText | CXTPPaintManager |
m_bSelectImageInPopupBar | CXTPPaintManager |
m_bShowKeyboardCues | CXTPPaintManager | protected
m_bShowShadow | CXTPPaintManager |
m_bThemedCheckBox | CXTPPaintManager |
m_bThemedStatusBar | CXTPPaintManager |
m_bThickCheckMark | CXTPPaintManager |
m_bUseOfficeFont | CXTPPaintManager |
m_bUseStandardFont | CXTPPaintManager | protected
m_bWrapCaptionBelowText | CXTPPaintManager |
m_clr3DShadow | CXTPCommandBarsOffice2013Theme | protected
m_clrBack | CXTPCommandBarsOffice2013Theme | protected
m_clrBtnFace | CXTPCommandBarsOffice2013Theme | protected
m_clrCaptionButtonFill | CXTPCommandBarsOffice2013Theme | protected
m_clrDisabledIcon | CXTPPaintManager |
m_clrFloatingGripper | CXTPPaintManager |
m_clrFloatingGripperText | CXTPPaintManager |
m_clrGlyph | CXTPCommandBarsOffice2013Theme | protected
m_clrGlyphDisabled | CXTPCommandBarsOffice2013Theme | protected
m_clrGlyphHighlight | CXTPCommandBarsOffice2013Theme | protected
m_clrGlyphPushed | CXTPCommandBarsOffice2013Theme | protected
m_clrHighlight | CXTPCommandBarsOffice2013Theme | protected
m_clrMessageBarText | CXTPCommandBarsOffice2013Theme | protected
m_clrWorkspace | CXTPCommandBarsOffice2013Theme | protected
m_csCheckBox | CXTPCommandBarsOffice2013Theme | protected
m_csCheckMark | CXTPCommandBarsOffice2013Theme | protected
m_csComboBox | CXTPCommandBarsOffice2013Theme | protected
m_csMenu | CXTPCommandBarsOffice2013Theme | protected
m_csMenuTitleBar | CXTPCommandBarsOffice2013Theme | protected
m_csRibbon | CXTPCommandBarsOffice2013Theme | protected
m_csToolbar | CXTPCommandBarsOffice2013Theme | protected
m_fontIcon | CXTPPaintManager |
m_fontIconBold | CXTPPaintManager |
m_fontSmCaption | CXTPPaintManager |
m_fontToolTip | CXTPPaintManager |
m_iconsInfo | CXTPPaintManager | protected
m_nAnimationSteps | CXTPPaintManager | protected
m_nAnimationTime | CXTPPaintManager | protected
m_nEditHeight | CXTPPaintManager | protected
m_nFontHeight | CXTPPaintManager | protected
m_nPopupBarTextPadding | CXTPPaintManager |
m_nSplitButtonDropDownHeight | CXTPPaintManager |
m_nSplitButtonDropDownWidth | CXTPPaintManager |
m_nSplitButtonPopupWidth | CXTPPaintManager |
m_nStatusBarMinHeight | CXTPPaintManager |
m_nTextHeight | CXTPPaintManager |
m_pfnSetLayeredWindowAttributes | CXTPPaintManager |
m_pFramePaintManager | CXTPPaintManager |
m_pGalleryPaintManager | CXTPPaintManager |
m_pImages | CXTPCommandBarsModernUITheme | protected
m_pMarkupContext | CXTPCommandBarsModernUITheme | protected
m_pProgressPaintManager | CXTPPaintManager |
m_pRibbonPaintManager | CXTPPaintManager |
m_pScrollBarPaintManager | CXTPPaintManager |
m_pShadowManager | CXTPPaintManager | protected
m_pSliderPaintManager | CXTPPaintManager |
m_pStatusBarPaintManager | CXTPPaintManager |
m_rcMessageBarMargin | CXTPPaintManager |
m_rcStatusBarBorder | CXTPPaintManager |
m_strOfficeFont | CXTPPaintManager |
m_systemTheme | CXTPPaintManager | protected
m_themeButton | CXTPPaintManager | protected
m_themeCurrent | CXTPPaintManager | protected
m_themeStatusBar | CXTPPaintManager | protected
m_xtpFontRegular | CXTPPaintManager | protected
m_xtpFontRegularBold | CXTPPaintManager | protected
m_xtpFontVert | CXTPPaintManager | protected
m_xtpFontVertBold | CXTPPaintManager | protected
Notify(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *)) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
Notify(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1), A1 arg1) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
Notify(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
Notify(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamic(void(T::*method)(O *)) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1), A1 arg1) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *)) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1), A1 arg1) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyReversed(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *)) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyReversed(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1), A1 arg1) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyReversed(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyReversed(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
Pixel(CDC *pDC, int xPos, int yPos, int nPen) | CXTPPaintManager |
Rectangle(CDC *pDC, LPCRECT rc, int nPen, const int nBrush) | CXTPPaintManager |
Rectangle(CDC *pDC, LPCRECT rc, COLORREF clrPen, COLORREF clrBrush) | CXTPPaintManager |
RefreshMetrics() | CXTPCommandBarsOffice2013Theme | protectedvirtual
RefreshStandardColors() | CXTPCommandBarsOffice2013Theme | protectedvirtual
ReleaseInstance() | CXTPPaintManager | static
RequiresResourceImages() | CXTPCommandBarsOffice2013Theme | virtual
RoundRect(CDC *pDC, LPCRECT rc, COLORREF clrPen, COLORREF clrBrush) | CXTPPaintManager |
SetAnimationDelay(int nAnimationSteps, int nAnimationTime) | CXTPPaintManager |
SetColors(int cElements, CONST INT *lpaElements, CONST COLORREF *lpaRgbValues) | CXTPPaintManager |
SetCommandBarRegion(CXTPCommandBar *pCommandBar) | CXTPPaintManager | virtual
SetCommandBarsFontIndirect(LOGFONT *pLogFont, BOOL bUseStandardFont=FALSE) | CXTPPaintManager |
SetCustomTheme(CXTPPaintManager *pTheme) | CXTPPaintManager | static
SetGlobalPaintManager(CXTPPaintManager *pPaintManager) | CXTPPaintManager | static
SetImageHandle(HMODULE hResource, LPCTSTR lpszIniFileName) | CXTPPaintManager | virtual
SetLunaTheme(XTPCurrentSystemTheme systemTheme) | CXTPPaintManager |
SetStateColor(COLORREF clrState=COLORREF_NULL) | CXTPCommandBarsNativeWindows10Theme | virtual
SetTheme(XTPPaintTheme paintTheme) | CXTPPaintManager | static
StripMnemonics(CString &strClear) | CXTPPaintManager | static
Subscribe(IXTPPaintManagerEvents *pObserver, CXTPSubscriptionList< CXTPPaintManager, IXTPPaintManagerEvents > *pSubcriptionList=NULL) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > |
Triangle(CDC *pDC, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clr) | CXTPPaintManager | static
Unsubscribe(IXTPPaintManagerEvents *pObserver) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > |
UpdateColors() | CXTPPaintManager | virtual
UpdateFonts() | CXTPPaintManager | virtual
UpdateRTLCaption(CString &strCaption) | CXTPPaintManager | virtual
UseOfficeFont(bool bUseOfficeFont) | CXTPPaintManager |
VerticalLine(CDC *pDC, int x0, int y0, int y1, COLORREF clrPen) | CXTPPaintManager |
~CXTPCommandBarsModernUITheme() | CXTPCommandBarsModernUITheme | virtual
~CXTPCommandBarsNativeWindows10Theme() | CXTPCommandBarsNativeWindows10Theme | virtual
~CXTPCommandBarsOffice2013Theme() | CXTPCommandBarsOffice2013Theme | virtual
~CXTPObservable() | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | protected
~CXTPPaintManager() | CXTPPaintManager | protectedvirtual


Toolkit Pro: XTPChart3dFunnelDiagram.h Source File

  • Source
  • Chart
  • Styles
  • Funnel
  • 3D
XTPChart3dFunnelDiagram.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHART3DFUNNELDIAGRAM_H__)
24# define __XTPCHART3DFUNNELDIAGRAM_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartDeviceContext;
34class CXTPChartElementView;
35class CXTPChartDiagramView;
36
42class _XTP_EXT_CLASS CXTPChart3dFunnelDiagram : public CXTPChart3dFunnelDiagramBase
43{
44 DECLARE_SERIAL(CXTPChart3dFunnelDiagram);
45
46public:
51 CXTPChart3dFunnelDiagram();
52
53public:
64 virtual CXTPChartDiagramView* CreateView(CXTPChartDeviceContext* pDC,
65 CXTPChartElementView* pParent);
66
67# ifdef _XTP_ACTIVEX
68public:
70 DECLARE_DISPATCH_MAP()
71 DECLARE_INTERFACE_MAP()
72 DECLARE_OLETYPELIB_EX(CXTPChart3dFunnelDiagram);
73 DECLARE_OLECREATE_EX(CXTPChart3dFunnelDiagram)
75# endif
76};
78# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
79#endif //#if !defined(__XTPCHART3DFUNNELDIAGRAM_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChart3dFunnelDiagram
This class abstracts the funnel diagram.
Definition XTPChart3dFunnelDiagram.h:43
CXTPChart3dFunnelDiagram::CXTPChart3dFunnelDiagram
CXTPChart3dFunnelDiagram()
Constructs a CXTPChart3dFunnelDiagram object.
CXTPChart3dFunnelDiagram::CreateView
virtual CXTPChartDiagramView * CreateView(CXTPChartDeviceContext *pDC, CXTPChartElementView *pParent)
Call this function to create the view of the funnel diagram.
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartDiagramView
This class represents the view of a chart diagram, which is a kind of CXTPChartElementView.
Definition XTPChartDiagramView.h:49
CXTPChartElementView
This class represents the view of a chart element.
Definition XTPChartElementView.h:47
CXTPChartFunnelDiagramBase
This class abstracts the funnel diagram.
Definition XTPChartFunnelDiagramBase.h:62


Toolkit Pro: XTPMarkupUniformGrid.h Source File

  • Source
  • Markup
  • Controls
XTPMarkupUniformGrid.h
Go to the documentation of this file.
1
23#if !defined(__XTPMARKUPUNIFORMGRID_H__)
24# define __XTPMARKUPUNIFORMGRID_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPMarkupDependencyProperty;
34class CXTPMarkupDrawingContext;
35
41class _XTP_EXT_CLASS CXTPMarkupUniformGrid : public CXTPMarkupPanel
42{
44 DECLARE_MARKUPCLASS(CXTPMarkupUniformGrid)
46protected:
51 CXTPMarkupUniformGrid();
52
57 virtual ~CXTPMarkupUniformGrid();
58
59public:
65 void SetColumns(int nColumns);
66
73 int GetColumns() const;
74
80 void SetRows(int nRows);
81
88 int GetRows() const;
89
95 void SetFirstColumn(int nFirstColumn);
96
103 int GetFirstColumn() const;
104
105protected:
107 // Implementation
108 virtual CSize MeasureOverride(CXTPMarkupDrawingContext* pDC, CSize szAvailableSize);
109 virtual CSize ArrangeOverride(CSize szFinalSize);
110
111private:
112 void UpdateComputedValues();
113
114private:
115 int m_nColumns;
116 int m_nRows;
117 int m_nFirstColumn;
118
119public:
120 static CXTPMarkupDependencyProperty* m_pFirstColumnProperty;
121 static CXTPMarkupDependencyProperty* m_pColumnsProperty;
122 static CXTPMarkupDependencyProperty* m_pRowsProperty;
126public:
127 DECLARE_DISPATCH_MAP()
128# ifdef _XTP_ACTIVEX
129 DECLARE_INTERFACE_MAP()
130 DECLARE_OLETYPELIB_EX(CXTPMarkupUniformGrid);
131# endif
132
133 afx_msg long OleGetColumns();
134 afx_msg long OleGetRows();
135 afx_msg long OleGetFirstColumn();
136 afx_msg void OleSetColumns(long);
137 afx_msg void OleSetRows(long);
138 afx_msg void OleSetFirstColumn(long);
140};
141
142# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
144#endif // !defined(__XTPMARKUPUNIFORMGRID_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPMarkupPanel
CXTPMarkupPanel is a CXTPMarkupFrameworkElement derived class.
Definition XTPMarkupPanel.h:48
CXTPMarkupUniformGrid
CXTPMarkupUniformGrid is a CXTPMarkupPanel derived class.
Definition XTPMarkupUniformGrid.h:42
CXTPMarkupUniformGrid::CXTPMarkupUniformGrid
CXTPMarkupUniformGrid()
Constructs a CXTPMarkupUniformGrid object.
CXTPMarkupUniformGrid::SetFirstColumn
void SetFirstColumn(int nFirstColumn)
Sets the position for the first column of the first row of the grid.
CXTPMarkupUniformGrid::SetColumns
void SetColumns(int nColumns)
Sets the number of columns in the grid.
CXTPMarkupUniformGrid::~CXTPMarkupUniformGrid
virtual ~CXTPMarkupUniformGrid()
Destroys a CXTPMarkupUniformGrid object, handles cleanup and deallocation.
CXTPMarkupUniformGrid::SetRows
void SetRows(int nRows)
Sets the number of rows in the grid.
CXTPMarkupUniformGrid::GetRows
int GetRows() const
Gets the number of rows in the grid.
CXTPMarkupUniformGrid::GetFirstColumn
int GetFirstColumn() const
Gets the position of the first column of the first row of the grid.
CXTPMarkupUniformGrid::GetColumns
int GetColumns() const
Gets the number of columns in the grid.


Toolkit Pro: Member List

CXTPChartSeriesStyle Member List

This is the complete list of members for CXTPChartSeriesStyle, including all inherited members.

ApplyTo(CXTPChartDeviceCommand *pCommand) | CXTPChartSeriesStyle | virtual
CorrectAxisSideMargins(CXTPChartAxis *pAxis, double nMinValue, double nMaxValue, double &nCorrection) | CXTPChartSeriesStyle | virtual
CreateDiagram() | CXTPChartSeriesStyle | virtual
CreateView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)=0 | CXTPChartSeriesStyle | pure virtual
CXTPChartElement() | CXTPChartElement |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartSeriesStyle() | CXTPChartSeriesStyle |
DoPropExchange(CXTPPropExchange *pPX) | CXTPChartSeriesStyle | virtual
Enable3dEdgeSmoothing(BOOL bEnable=TRUE) | CXTPChartSeriesStyle | virtual
Get3dRotation() const | CXTPChartSeriesStyle | virtual
GetAppearance() const | CXTPChartElement |
GetColor() const | CXTPChartSeriesStyle | virtual
GetContent() const | CXTPChartElement |
GetErrorBar() const | CXTPChartSeriesStyle | virtual
GetLabel() const | CXTPChartSeriesStyle | virtual
GetOwner() const | CXTPChartElement |
GetSeriesPointValueIndex() const | CXTPChartSeriesStyle | virtual
GetStyleAppearance() const | CXTPChartSeriesStyle | virtual
GetTransparency() const | CXTPChartSeriesStyle | virtual
Is3D() const | CXTPChartObject |
Is3dEdgeSmoothingEnabled() const | CXTPChartSeriesStyle | virtual
IsColorEach() const | CXTPChartSeriesStyle | virtual
IsStyleDiagram(CXTPChartDiagram *pDiagram) const | CXTPChartSeriesStyle | virtual
m_bColorEach | CXTPChartSeriesStyle | protected
m_bSmooth3dEdges | CXTPChartSeriesStyle | protected
m_clrColor | CXTPChartSeriesStyle | protected
m_nTransparency | CXTPChartSeriesStyle | protected
m_pErrorBar | CXTPChartSeriesStyle | protected
m_pLabel | CXTPChartSeriesStyle | protected
m_Rotation3d | CXTPChartSeriesStyle | protected
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartElement | virtual
Release() | CXTPChartElement | virtual
Set3dRotation(const CXTPChart3dRotation &rotation) | CXTPChartSeriesStyle | virtual
Set3dRotation(double dYaw, double dPitch, double dRoll) | CXTPChartSeriesStyle | virtual
SetColor(CXTPChartColor clr) | CXTPChartSeriesStyle | virtual
SetColorEach(BOOL bColorEach) | CXTPChartSeriesStyle | virtual
SetErrorBar(CXTPChartErrorBar *pErrorBar) | CXTPChartSeriesStyle | virtual
SetLabel(CXTPChartSeriesLabel *pLabel) | CXTPChartSeriesStyle | virtual
SetTransparency(int nTransparency) | CXTPChartSeriesStyle | virtual
~CXTPChartElement() | CXTPChartElement | virtual
~CXTPChartSeriesStyle() | CXTPChartSeriesStyle | virtual


Toolkit Pro: Member List

CXTPSingletonBase< Derived, Parent > Member List

This is the complete list of members for CXTPSingletonBase< Derived, Parent >, including all inherited members.

CXTPSingletonBase() | CXTPSingletonBase< Derived, Parent > | inlineprotected
Instance() | CXTPSingleton< Derived > | inlinestatic


Toolkit Pro: XTPResizeFormView.h Source File

  • Source
  • Controls
  • Resize
XTPResizeFormView.h
Go to the documentation of this file.
1
23#if !defined(__XTPRESIZEFORMVIEW_H__)
24# define __XTPRESIZEFORMVIEW_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
39class _XTP_EXT_CLASS CXTPResizeFormView
40 : public CFormView
41 , public CXTPResize
42{
44 DECLARE_DYNCREATE(CXTPResizeFormView)
46public:
65 CXTPResizeFormView(const UINT nID = 0, const UINT nFlags = 0);
66
67protected:
74 virtual void AdjustResizeRect(CSize& rcWindow);
75
76protected:
78 DECLARE_MESSAGE_MAP()
79
80 //{{AFX_VIRTUAL(CXTPResizeFormView)
81 virtual LRESULT WindowProc(UINT message, WPARAM wParam, LPARAM lParam);
82 virtual BOOL OnInitDialog();
83 //}}AFX_VIRTUAL
84
85 //{{AFX_MSG(CXTPResizeFormView)
86 afx_msg void OnSize(UINT nType, int cx, int cy);
87 afx_msg void OnGetMinMaxInfo(MINMAXINFO* lpMMI);
88 afx_msg void OnDestroy();
89 //}}AFX_MSG
91};
92
93# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
95#endif // !defined(__XTPRESIZEFORMVIEW_H__)
XTPDisableNoisyWarnings.h
CXTPResizeFormView
CXTPResizeFormView is a multiple inheritance class derived from CFormView and CXTPResize.
Definition XTPResizeFormView.h:42
CXTPResizeFormView::AdjustResizeRect
virtual void AdjustResizeRect(CSize &rcWindow)
This method called in the Size method to adjust a window rectangle to fit real client size.
CXTPResizeFormView::CXTPResizeFormView
CXTPResizeFormView(const UINT nID=0, const UINT nFlags=0)
Constructs a CXTPResizeFormView object.
CXTPResize
CXTPResize is a base class.
Definition XTPResize.h:145


Toolkit Pro: Member List

CXTPPropertyGridVisualStudio2015Theme Member List

This is the complete list of members for CXTPPropertyGridVisualStudio2015Theme, including all inherited members.

AdjustItemCaptionRect(CXTPPropertyGridItem *pItem, CRect &rcCaption) | CXTPPropertyGridPaintManager | virtual
AdjustItemValueRect(CXTPPropertyGridItem *pItem, CRect &rcValue) | CXTPPropertyGridPaintManager | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPPropertyGridPaintManager(CXTPPropertyGrid *pGrid) | CXTPPropertyGridPaintManager |
CXTPPropertyGridVisualStudio2010Theme(CXTPPropertyGrid *pGrid) | CXTPPropertyGridVisualStudio2010Theme |
CXTPPropertyGridVisualStudio2015Theme(CXTPPropertyGrid *pGrid) | CXTPPropertyGridVisualStudio2015Theme |
DrawCategoryCaptionBackground(CDC *pDC, CXTPPropertyGridItem *pItem, CRect rc) | CXTPPropertyGridPaintManager | virtual
DrawCheckBox(CDC *pDC, CXTPPropertyGridItemBool *pButton) | CXTPPropertyGridPaintManager | virtual
DrawCheckMark(CDC *pDC, CRect rc, BOOL bEnabled, BOOL bChecked) | CXTPPropertyGridPaintManager | virtual
DrawExpandButton(CDC &dc, CXTPPropertyGridItem *pItem, CRect rcCaption) | CXTPPropertyGridVisualStudio2015Theme | virtual
DrawInplaceButtons(CDC *pDC, PDRAWITEMSTRUCT lpDrawItemStruct, CXTPPropertyGridItem *pItem, CRect rcValue) | CXTPPropertyGridPaintManager | virtual
DrawInplaceListItem(CDC *pDC, CXTPPropertyGridItemConstraint *pConstraint, CRect rc, BOOL bSelected) | CXTPPropertyGridPaintManager | virtual
DrawItem(PDRAWITEMSTRUCT lpDrawItemStruct) | CXTPPropertyGridPaintManager | virtual
DrawItemCaption(CDC *pDC, CXTPPropertyGridItem *pItem, CRect rcCaption) | CXTPPropertyGridPaintManager | virtual
DrawItemValue(CDC *pDC, CXTPPropertyGridItem *pItem, CRect rcValue) | CXTPPropertyGridPaintManager | virtual
DrawPropertyGridBorder(CDC *pDC, RECT &rcBorder, XTPPropertyGridWindow nWindow) | CXTPPropertyGridPaintManager | virtual
DrawRadioMark(CDC *pDC, CRect rc, BOOL bEnabled, BOOL bChecked) | CXTPPropertyGridPaintManager | virtual
FillInplaceButton(CDC *pDC, CXTPPropertyGridInplaceButton *pButton) | CXTPPropertyGridPaintManager | virtual
FillPropertyGrid(CDC *pDC) | CXTPPropertyGridPaintManager | virtual
FillPropertyGridView(CDC *pDC) | CXTPPropertyGridPaintManager | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetItemBackColor(CXTPPropertyGridItem *pItem, BOOL bValuePart) | CXTPPropertyGridPaintManager | virtual
GetItemFont(CXTPPropertyGridItem *pItem, BOOL bValuePart) | CXTPPropertyGridPaintManager | virtual
GetItemMetrics() const | CXTPPropertyGridPaintManager |
GetItemsBorderHeight() const | CXTPPropertyGridPaintManager | virtual
GetItemTextColor(CXTPPropertyGridItem *pItem, BOOL bValuePart) | CXTPPropertyGridPaintManager | virtual
GetScrollBarTheme() const | CXTPPropertyGridVisualStudio2015Theme | virtual
GetSplitterRect(CRect rc, BOOL bIsHelp) | CXTPPropertyGridPaintManager |
HitTestVerbs(CDC *pDC, CRect rcVerbs, CPoint pt) | CXTPPropertyGridPaintManager |
m_bThinSplitter | CXTPPropertyGridPaintManager | protected
m_bTransparent | CXTPPropertyGridPaintManager |
m_buttonsStyle | CXTPPropertyGridPaintManager |
m_clrCategorySeparator | CXTPPropertyGridPaintManager |
m_clrFace | CXTPPropertyGridPaintManager |
m_clrHighlight | CXTPPropertyGridPaintManager |
m_clrHighlightText | CXTPPropertyGridPaintManager |
m_clrNonHighlightBack | CXTPPropertyGridPaintManager |
m_clrNonHighlightText | CXTPPropertyGridPaintManager |
m_clrShadow | CXTPPropertyGridPaintManager |
m_clrSplitter | CXTPPropertyGridPaintManager |
m_nHelpHeight | CXTPPropertyGridPaintManager | protected
m_nItemsBorderHeight | CXTPPropertyGridPaintManager | protected
m_nSplitterHeight | CXTPPropertyGridPaintManager | protected
m_nVerbsHeight | CXTPPropertyGridPaintManager | protected
m_pGrid | CXTPPropertyGridPaintManager | protected
m_pMetrics | CXTPPropertyGridPaintManager | protected
m_themeButton | CXTPPropertyGridPaintManager |
m_themeCombo | CXTPPropertyGridPaintManager |
m_themeTree | CXTPPropertyGridPaintManager |
MeasureItem(LPMEASUREITEMSTRUCT lpMeasureItemStruct) | CXTPPropertyGridPaintManager | virtual
OnNcCalcSize(RECT &rc) | CXTPPropertyGridPaintManager | virtual
RefreshMetrics() | CXTPPropertyGridVisualStudio2015Theme | virtual
SetItemsBorderHeight(int nHeight) | CXTPPropertyGridPaintManager | virtual
SetThinSplitter(BOOL bThinSplitter) | CXTPPropertyGridPaintManager | virtual
~CXTPPropertyGridPaintManager() | CXTPPropertyGridPaintManager | virtual
~CXTPPropertyGridVisualStudio2010Theme() | CXTPPropertyGridVisualStudio2010Theme |


Toolkit Pro: Member List

CXTPChart3dPie Member List

This is the complete list of members for CXTPChart3dPie, including all inherited members.

CalculateCenter(const CXTPChartPointF &basePoint) const | CXTPChartPieBase |
CreateBoundedPieDeviceCommand(const CXTPChartColor &color, int nThickness, const CXTPChartPointF &basePoint) | CXTPChart3dPie | virtual
CreatePieDeviceCommand(const CXTPChartColor &color, const CXTPChartColor &color2, const CXTPChartPointF &basePoint) | CXTPChart3dPie | virtual
CXTPChart3dPie(double dStartAngle, double dFinishAngle, const CXTPChartEllipse &ellipse, int nDepthPercent, int nHolePercent, BOOL bStartGap=FALSE, BOOL bEndGap=FALSE) | CXTPChart3dPie |
CXTPChartPieBase(double dStartAngle, double dFinishAngle, const CXTPChartEllipse &ellipse, int nDepthPercent, int nHolePercent) | CXTPChartPieBase | protected
GetBounds() const | CXTPChartPieBase |
GetCenterPoint() const | CXTPChartPieBase |
GetFinishPoint() const | CXTPChartPieBase |
GetHalfAngle() const | CXTPChartPieBase |
GetHolePercent() const | CXTPChartPieBase |
GetStartAngle() const | CXTPChartPieBase |
GetStartPoint() const | CXTPChartPieBase |
m_anchorBounds | CXTPChartPieBase | protected
m_depth | CXTPChartPieBase | protected
m_dStartAngle | CXTPChartPieBase | protected
m_dSweepAngle | CXTPChartPieBase | protected
m_ellipse | CXTPChartPieBase | protected
m_nHolePercent | CXTPChartPieBase | protected
UpdateBounds() | CXTPChartPieBase | protected
~CXTPChartPieBase() | CXTPChartPieBase | virtual


Toolkit Pro: XTPGridAllocators.h Source File

  • Source
  • GridControl
XTPGridAllocators.h
Go to the documentation of this file.
1
23#if !defined(__XTPGRIDALLOCATORS_H__)
24# define __XTPGRIDALLOCATORS_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
35XTP_DECLARE_HEAP_ALLOCATOR_(CXTPGridDataAllocator, _XTP_EXT_CLASS)
36XTP_DECLARE_HEAP_ALLOCATOR_(CXTPGridRowAllocator, _XTP_EXT_CLASS)
37
38// to allocate in the app default heap
39
40XTP_DECLARE_HEAP_ALLOCATOR_(CXTPGridAllocatorDefault, _XTP_EXT_CLASS)
41
42XTP_DECLARE_BATCH_ALLOC_OBJ_DATA_(CXTPGridRow_BatchData, _XTP_EXT_CLASS);
43XTP_DECLARE_BATCH_ALLOC_OBJ_DATA_(CXTPGridGroupRow_BatchData, _XTP_EXT_CLASS);
44
47# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
48#endif //#if !defined(__XTPGRIDALLOCATORS_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h


Toolkit Pro: Member List

CXTPButtonThemeFlat Member List

This is the complete list of members for CXTPButtonThemeFlat, including all inherited members.

CXTPButtonTheme() | CXTPButtonTheme |
CXTPButtonThemeFlat() | CXTPButtonThemeFlat |
CXTPCmdTarget() | CXTPCmdTarget |
CXTPControlTheme() | CXTPControlTheme |
DrawButton(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
DrawButtonBackground(CDC *pDC, CXTPButton *pButton) | CXTPButtonThemeFlat | virtual
DrawButtonText(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme |
DrawButtonVisualStyleBackground(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
DrawCheckBoxMark(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
DrawFocusRect(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
DrawGroupBox(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
DrawPushButtonDropDown(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
DrawPushButtonIcon(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
DrawPushButtonText(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
DrawRadioButtonMark(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetTextColor(CXTPButton *pButton) | CXTPButtonTheme | virtual
GetThemeStyle() const | CXTPControlTheme |
m_crBack | CXTPButtonTheme |
m_crBorder3DHilite | CXTPButtonTheme |
m_crBorder3DShadow | CXTPButtonTheme |
m_crBorderHilite | CXTPButtonTheme |
m_crBorderShadow | CXTPButtonTheme |
m_crText | CXTPButtonTheme |
m_crTextCheck | CXTPButtonTheme |
m_crTextDisabled | CXTPButtonTheme |
m_nTheme | CXTPControlTheme | protected
RefreshMetrics(CXTPButton *pButton) | CXTPButtonTheme | virtual
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static
~CXTPButtonTheme() | CXTPButtonTheme | virtual


Toolkit Pro: Member List

CXTPExcelTabCtrlThemeVisualStudio2019 Member List

This is the complete list of members for CXTPExcelTabCtrlThemeVisualStudio2019, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPControlTheme() | CXTPControlTheme |
CXTPExcelTabCtrlTheme() | CXTPExcelTabCtrlTheme |
CXTPExcelTabCtrlThemeOffice2013() | CXTPExcelTabCtrlThemeOffice2013 |
CXTPExcelTabCtrlThemeVisualStudio2019() | CXTPExcelTabCtrlThemeVisualStudio2019 |
DrawButton(CDC *pDC, CXTPExcelTabCtrl *pTabCtrl, const CXTPExcelTabCtrlButtonState &state) | CXTPExcelTabCtrlThemeOffice2013 | virtual
DrawButtonBack(CDC *pDC, CRect &rect, const CXTPExcelTabCtrlButtonState &state) | CXTPExcelTabCtrlThemeOffice2013 | virtual
DrawGripper(CDC *pDC, CRect rect) | CXTPExcelTabCtrlThemeOffice2013 | virtual
DrawTab(CDC *pDC, CXTPExcelTabCtrl *pTabCtrl, const CPoint &pt, bool bSelected, CXTPTcbItem *pTcbItem) | CXTPExcelTabCtrlThemeOffice2013 | virtual
FillBackground(CDC *pDC, CRect &rect, BOOL bBottom) | CXTPExcelTabCtrlThemeOffice2013 | virtual
FillTabsBackground(CDC *pDC, int cx, int cy) | CXTPExcelTabCtrlThemeOffice2013 | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetSelTabBackColor(CXTPTcbItem *pTcbItem) const | CXTPExcelTabCtrlTheme | virtual
GetSelTabTextColor(CXTPTcbItem *pTcbItem) const | CXTPExcelTabCtrlTheme | virtual
GetTabBackColor(CXTPTcbItem *pTcbItem) const | CXTPExcelTabCtrlTheme | virtual
GetTabTextColor(CXTPTcbItem *pTcbItem) const | CXTPExcelTabCtrlTheme | virtual
GetThemeStyle() const | CXTPControlTheme |
m_clr3DFace | CXTPExcelTabCtrlTheme |
m_clr3DFaceHilite | CXTPExcelTabCtrlTheme |
m_clr3DFacePushed | CXTPExcelTabCtrlTheme |
m_clr3DHilight | CXTPExcelTabCtrlTheme |
m_clr3DShadow | CXTPExcelTabCtrlTheme |
m_clrBorder3DHilite | CXTPExcelTabCtrlTheme |
m_clrBorder3DShadow | CXTPExcelTabCtrlTheme |
m_clrBtnText | CXTPExcelTabCtrlTheme |
m_clrBtnTextGray | CXTPExcelTabCtrlTheme |
m_clrBtnTextHilite | CXTPExcelTabCtrlTheme |
m_clrBtnTextPushed | CXTPExcelTabCtrlTheme |
m_clrWindow | CXTPExcelTabCtrlTheme |
m_clrWindowText | CXTPExcelTabCtrlTheme |
m_nTheme | CXTPControlTheme | protected
RefreshMetrics(CXTPExcelTabCtrl *pTab) | CXTPExcelTabCtrlThemeOffice2013 | virtual
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static
~CXTPExcelTabCtrlTheme() | CXTPExcelTabCtrlTheme |


Toolkit Pro: Member List

CXTPGridSection Member List

This is the complete list of members for CXTPGridSection, including all inherited members.

_DoCollapse(CXTPGridRow *pRow) | CXTPGridSection | virtual
_DoExpand(int nIndex, CXTPGridRow *pRow, BOOL bUpdateSelection) | CXTPGridSection | virtual
_DoExpand(int nIndex, CXTPGridRow *pRow) | CXTPGridSection | virtual
AddRecord(CXTPGridRecord *pRecord) | CXTPGridSection | virtual
AllowAccess(BOOL bAllowAccess) | CXTPGridSection |
AllowEdit(BOOL bAllowEdit) | CXTPGridSection |
AllowFilter(BOOL bAllowFilter) | CXTPGridSection |
AllowGroup(BOOL bAllowGroup) | CXTPGridSection |
AllowSort(BOOL bAllowSort) | CXTPGridSection |
BuildTree(CXTPGridRows *pTree, CXTPGridRow *pParentRow, CXTPGridRecords *pRecords) | CXTPGridSection | protected
CollapseAll() | CXTPGridSection | protected
CXTPCmdTarget() | CXTPCmdTarget |
CXTPGridSection(CXTPGridControl *pControl, XTPGridRowType rowType) | CXTPGridSection |
Draw(CDC *pDC) | CXTPGridSection | virtual
ExpandAll(BOOL bRecursive) | CXTPGridSection | protected
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetBorder() const | CXTPGridSection |
GetDividerColor() const | CXTPGridSection |
GetDividerPosition() const | CXTPGridSection |
GetDividerRect() const | CXTPGridSection |
GetDividerStyle() const | CXTPGridSection |
GetFocusedRow() const | CXTPGridSection | protected
GetHeight() const | CXTPGridSection |
GetHeightMode() const | CXTPGridSection |
GetIndex() const | CXTPGridSection |
GetPopulatedRecordsCount() const | CXTPGridSection |
GetRecords() const | CXTPGridSection |
GetRect() const | CXTPGridSection |
GetRows() const | CXTPGridSection |
GetRowType() const | CXTPGridSection |
GetScrollIndexV() | CXTPGridSection | protectedvirtual
GetScrollOffsetV() const | CXTPGridSection | protectedvirtual
GetSelectedRows() const | CXTPGridSection | protected
IsAllowAccess() const | CXTPGridSection |
IsAllowEdit() const | CXTPGridSection |
IsAllowFilter() const | CXTPGridSection |
IsAllowGroup() const | CXTPGridSection |
IsAllowSort() const | CXTPGridSection |
IsSelectionEnabled() const | CXTPGridSection |
IsVirtualMode() const | CXTPGridSection | virtual
IsVisible() const | CXTPGridSection |
m_bAllowAccess | CXTPGridSection | protected
m_bAllowEdit | CXTPGridSection | protected
m_bAllowFilter | CXTPGridSection | protected
m_bAllowGroup | CXTPGridSection | protected
m_bAllowSort | CXTPGridSection | protected
m_bSelectionEnable | CXTPGridSection | protected
m_bVisible | CXTPGridSection | protected
m_clrDivider | CXTPGridSection | protected
m_dividerPosition | CXTPGridSection | protected
m_dividerStyle | CXTPGridSection | protected
m_heightMode | CXTPGridSection | protected
m_nHeight | CXTPGridSection | protected
m_nPopulatedRecordsCount | CXTPGridSection | protected
m_nScrollIndexV | CXTPGridSection | protected
m_nScrollOffsetV | CXTPGridSection | protected
m_pBorder | CXTPGridSection | protected
m_pControl | CXTPGridSection | protected
m_pMarkupContext | CXTPGridSection | protected
m_pRecords | CXTPGridSection | protected
m_pRows | CXTPGridSection | protected
m_pTree | CXTPGridSection | protected
m_rcDivider | CXTPGridSection | protected
m_rcSection | CXTPGridSection | protected
m_UaSorted | CXTPGridSection | protected
Populate(BOOL bUpdate) | CXTPGridSection | virtual
RefreshIndexes() | CXTPGridSection | virtual
RefreshIndexes(int nIndexStart) | CXTPGridSection | virtual
ResetContent() | CXTPGridSection | virtual
ReSortRows() | CXTPGridSection | virtual
SelectionEnable(BOOL bEnable) | CXTPGridSection |
SetDividerColor(CXTPPaintManagerColor clrDivider) | CXTPGridSection |
SetDividerPosition(XTPGridSectionDividerPosition dividerPosition) | CXTPGridSection |
SetDividerStyle(XTPGridSectionDividerStyle dividerStyle) | CXTPGridSection |
SetHeight(int nHeight) | CXTPGridSection |
SetHeightMode(XTPGridSectionHeightMode heightMode) | CXTPGridSection |
SetMarkupContext(CXTPMarkupContext *pMarkupContext) | CXTPGridSection |
SetScrollIndexV(int nIndex) | CXTPGridSection | protectedvirtual
SetScrollOffsetV(int nScrollOffsetV) | CXTPGridSection | protectedvirtual
SetVisible(BOOL bVisible=TRUE) | CXTPGridSection |
SortRows(CXTPGridRows *pRows) | CXTPGridSection | protectedvirtual
SortTree(CXTPGridRows *pTree) | CXTPGridSection | protectedvirtual
~CXTPGridSection() | CXTPGridSection | virtual


Toolkit Pro: XTPSliderPaintManager.h Source File

  • Source
  • CommandBars
  • Slider
XTPSliderPaintManager.h
Go to the documentation of this file.
1
23#if !defined(__XTPSLIDERPAINTMANAGER_H__)
24# define __XTPSLIDERPAINTMANAGER_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPPaintManager;
34
39class _XTP_EXT_CLASS CXTPSliderPaintManager : public CXTPScrollBarPaintManager
40{
41 DECLARE_DYNAMIC(CXTPSliderPaintManager);
42
43public:
49 CXTPSliderPaintManager(CXTPPaintManager* pPaintManager);
50
51public:
58 virtual void DrawScrollBar(CDC* pDC, CXTPScrollBase* pScrollBar);
59
64 virtual void RefreshMetrics();
65
66public:
67 CXTPPaintManager* m_pPaintManager;
68};
69
71# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
72#endif // !defined(__XTPSLIDERPAINTMANAGER_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPPaintManager
Paint manager of the command bars.
Definition XTPPaintManager.h:199
CXTPScrollBarPaintManager
CXTPScrollBarPaintManager is standalone class used to draw CXTPCommandBarScrollBarCtrl object.
Definition XTPScrollBarPaintManager.h:40
CXTPScrollBase
CXTPScrollBase is the base class for all scrollable objects.
Definition XTPScrollBase.h:222
CXTPSliderPaintManager
Paint manager for the slider control.
Definition XTPSliderPaintManager.h:40
CXTPSliderPaintManager::CXTPSliderPaintManager
CXTPSliderPaintManager(CXTPPaintManager *pPaintManager)
Constructs a CXTPSliderPaintManager object.
CXTPSliderPaintManager::DrawScrollBar
virtual void DrawScrollBar(CDC *pDC, CXTPScrollBase *pScrollBar)
This method is called to draw the scrollbar of the slider.
CXTPSliderPaintManager::RefreshMetrics
virtual void RefreshMetrics()
Recalculates gallery metrics.


Toolkit Pro: Member List

CXTPShortcutBarNativeWinXPTheme Member List

This is the complete list of members for CXTPShortcutBarNativeWinXPTheme, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPShortcutBarNativeWinXPTheme() | CXTPShortcutBarNativeWinXPTheme |
CXTPShortcutBarOffice2003Theme() | CXTPShortcutBarOffice2003Theme |
CXTPShortcutBarPaintManager() | CXTPShortcutBarPaintManager |
DrawExpandButton(CDC *pDC, CRect rc) | CXTPShortcutBarPaintManager | virtual
DrawGripper(CDC *pDC, CXTPShortcutBar *pShortcutBar, BOOL bDraw) | CXTPShortcutBarOffice2003Theme | virtual
DrawImage(CDC *pDC, CPoint pt, CSize sz, CXTPImageManagerIcon *pImage, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled) | CXTPShortcutBarOffice2003Theme | virtual
DrawNavigationItem(CDC *pDC, CXTPShortcutBarItem *pItem) | CXTPShortcutBarPaintManager | virtual
DrawPaneCaption(CDC *pDC, CXTPShortcutBarPane *pPane, BOOL bDraw) | CXTPShortcutBarOffice2003Theme | virtual
DrawPaneItemCaption(CDC *pDC, CXTPShortcutBarPaneItem *pItem, BOOL bDraw) | CXTPShortcutBarOffice2003Theme | virtual
DrawShortcutBarFrame(CDC *pDC, CXTPShortcutBar *pShortcutBar) | CXTPShortcutBarOffice2003Theme | virtual
DrawShortcutItem(CDC *pDC, CXTPShortcutBarItem *pItem) | CXTPShortcutBarPaintManager | virtual
FillNavigationItemEntry(CDC *pDC, CXTPShortcutBarItem *pItem) | CXTPShortcutBarOffice2003Theme | virtual
FillShortcutBar(CDC *pDC, CXTPShortcutBar *pShortcutBar) | CXTPShortcutBarNativeWinXPTheme | virtual
FillShortcutItemEntry(CDC *pDC, CXTPShortcutBarItem *pItem) | CXTPShortcutBarNativeWinXPTheme | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
IsShortcutItemTruncated(CDC *pDC, CXTPShortcutBarItem *pItem) | CXTPShortcutBarPaintManager |
Line(CDC *pDC, int x0, int y0, int x1, int y1, int nPen) | CXTPShortcutBarPaintManager |
m_bBoldItemCaptionFont | CXTPShortcutBarPaintManager |
m_bClearTypeTextQuality | CXTPShortcutBarPaintManager |
m_bNavigationButton | CXTPShortcutBarPaintManager |
m_bShowTopLeftCaptionShadow | CXTPShortcutBarOffice2003Theme |
m_bUseStandardFont | CXTPShortcutBarPaintManager |
m_clrCaptionText | CXTPShortcutBarOffice2003Theme |
m_clrDisabledText | CXTPShortcutBarPaintManager |
m_clrHotText | CXTPShortcutBarPaintManager |
m_clrItemCaptionShadow | CXTPShortcutBarOffice2003Theme |
m_clrItemCaptionText | CXTPShortcutBarOffice2003Theme |
m_clrItemCaptionTop | CXTPShortcutBarOffice2003Theme |
m_clrNormalText | CXTPShortcutBarPaintManager |
m_clrPushedText | CXTPShortcutBarPaintManager |
m_clrSelectedText | CXTPShortcutBarPaintManager |
m_clrShortcutItemShadow | CXTPShortcutBarPaintManager |
m_grcCaption | CXTPShortcutBarOffice2003Theme |
m_grcHot | CXTPShortcutBarPaintManager |
m_grcItemCaption | CXTPShortcutBarOffice2003Theme |
m_grcItemHotCaption | CXTPShortcutBarOffice2003Theme |
m_grcPushed | CXTPShortcutBarPaintManager |
m_grcSelected | CXTPShortcutBarPaintManager |
m_grcShortcutBarGripper | CXTPShortcutBarPaintManager |
m_grcShortcutItem | CXTPShortcutBarPaintManager |
m_nExpandedIconWidth | CXTPShortcutBarPaintManager |
m_nNormalIconWidth | CXTPShortcutBarPaintManager |
m_nPaneItemHeight | CXTPShortcutBarPaintManager |
m_pExpandIcon | CXTPShortcutBarPaintManager |
m_rcCaptionPadding | CXTPShortcutBarPaintManager |
m_rcItemCaptionPadding | CXTPShortcutBarPaintManager |
m_strOfficeFont | CXTPShortcutBarPaintManager |
m_xtpFontPaneCaption | CXTPShortcutBarPaintManager |
m_xtpFontPaneItemCaption | CXTPShortcutBarPaintManager |
m_xtpFontText | CXTPShortcutBarPaintManager |
m_xtpFontVerticalText | CXTPShortcutBarPaintManager |
Rectangle(CDC *pDC, CRect rc, int nPen, int nBrush) | CXTPShortcutBarPaintManager |
RefreshMetrics() | CXTPShortcutBarNativeWinXPTheme | virtual
~CXTPShortcutBarNativeWinXPTheme() | CXTPShortcutBarNativeWinXPTheme |
~CXTPShortcutBarPaintManager() | CXTPShortcutBarPaintManager | virtual


Toolkit Pro: Member List

XTP_EDIT_ROWSBLOCK Member List

This is the complete list of members for XTP_EDIT_ROWSBLOCK, including all inherited members.

lcEnd | XTP_EDIT_ROWSBLOCK
lcStart | XTP_EDIT_ROWSBLOCK
strCollapsedText | XTP_EDIT_ROWSBLOCK


Toolkit Pro: XTPEditThemeResource.h Source File

  • Source
  • Controls
  • Edit
  • Themes
XTPEditThemeResource.h
Go to the documentation of this file.
1
23#if !defined(__XTPEDITTHEMERESOURCE_H__)
24# define __XTPEDITTHEMERESOURCE_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
37class _XTP_EXT_CLASS CXTPEditThemeResource : public CXTPEditThemeOfficeXP
38{
39public:
44 CXTPEditThemeResource();
45
50 virtual ~CXTPEditThemeResource();
51
58 virtual void RefreshMetrics(CXTPEdit* pEdit);
59
71 virtual BOOL AdjustBuddyRect(CWnd* pBuddy, CRect& rcUpDown, int nAlignment);
72
84 virtual void DrawBuddyBorders(CWnd* pBuddy, CDC* pDC, CRect rc, int nAlignment,
85 CXTPEdit* pEdit);
86
87# if _MSC_VER > 1200
88 using CXTPEditThemeDefault::DrawBuddyBorders;
89# endif
90};
91
92# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
94#endif // __XTPEDITTHEMERESOURCE_H__
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPEdit
CXTPEdit is a CEdit derived class.
Definition XTPEdit.h:129
CXTPEditThemeDefault::DrawBuddyBorders
virtual void DrawBuddyBorders(CWnd *pBuddy, CDC *pDC, CRect rc, int nAlignment, CXTPEdit *pEdit)
Called by the framework to draw the borders for the associated buddy window.
CXTPEditThemeOfficeXP
CXTPEditThemeOfficeXP is a class used to perform theme drawing tasks.
Definition XTPEditThemeOfficeXP.h:38
CXTPEditThemeResource
CXTPEditThemeResource is a class used to perform theme drawing tasks.
Definition XTPEditThemeResource.h:38
CXTPEditThemeResource::AdjustBuddyRect
virtual BOOL AdjustBuddyRect(CWnd *pBuddy, CRect &rcUpDown, int nAlignment)
Called by the framework to adjust the size of the area to draw the buddy control borders on.
CXTPEditThemeResource::DrawBuddyBorders
virtual void DrawBuddyBorders(CWnd *pBuddy, CDC *pDC, CRect rc, int nAlignment, CXTPEdit *pEdit)
Called by the framework to draw the borders for the associated buddy window.
CXTPEditThemeResource::~CXTPEditThemeResource
virtual ~CXTPEditThemeResource()
Destructor, handles cleanup and deallocation.
CXTPEditThemeResource::CXTPEditThemeResource
CXTPEditThemeResource()
Constructs a CXTPEditThemeResource object.
CXTPEditThemeResource::RefreshMetrics
virtual void RefreshMetrics(CXTPEdit *pEdit)
This member function is called by the theme manager to refresh the visual styles used by each compone...


Toolkit Pro: XTPTaskPanelItems.h Source File

  • Source
  • TaskPanel
XTPTaskPanelItems.h
Go to the documentation of this file.
1
23#if !defined(__XTPTASKPANELITEMS_H__)
24# define __XTPTASKPANELITEMS_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPTaskPanelGroup;
34class CXTPTaskPanelItem;
35class CXTPTaskPanel;
36class CXTPPropExchange;
37
43class _XTP_EXT_CLASS CXTPTaskPanelItems : public CXTPCmdTarget
44{
46 DECLARE_DYNCREATE(CXTPTaskPanelItems)
48public:
54 CXTPTaskPanelItems(CXTPTaskPanel* pPanel = NULL);
55
60 virtual ~CXTPTaskPanelItems();
61
62public:
71 CXTPTaskPanelItem* Add(CXTPTaskPanelItem* pItem, UINT nID);
72
83 CXTPTaskPanelItem* Add(CXTPTaskPanelItem* pItem, UINT nID, LPCTSTR lpCaption,
84 LPCTSTR lpTooltip = NULL);
85
96 CXTPTaskPanelItem* InsertAt(int nIndex, CXTPTaskPanelItem* pItem);
97
105 CXTPTaskPanelItem* GetAt(int nIndex) const;
106
115 void Clear(BOOL bReposition = TRUE);
116
125 CXTPTaskPanelItem* Find(UINT nID) const;
126
132 void Remove(CXTPTaskPanelItem* pItem);
133
139 void RemoveAt(int nIndex);
140
148 int GetIndex(const CXTPTaskPanelItem* pItem) const;
149
156 int GetCount() const;
157
164 CCmdTarget* GetOwner() const;
165
176 void Move(CXTPTaskPanelItem* pItem, int nIndex);
177
183 void DoPropExchange(CXTPPropExchange* pPX);
184
191 virtual CRuntimeClass* GetDefaultItemClass() const;
192
205 int GetNextVisibleIndex(int nIndex, int nDirection) const;
206
215 CXTPTaskPanelItem* GetFirstVisibleItem() const;
216
225 CXTPTaskPanelItem* GetLastVisibleItem() const;
226
227protected:
228 CXTPTaskPanel* m_pPanel;
229 CArray<CXTPTaskPanelItem*, CXTPTaskPanelItem*> m_arrItems;
230 CCmdTarget* m_pOwner;
232# ifdef _XTP_ACTIVEX
235 afx_msg long OleGetItemCount();
236 afx_msg LPDISPATCH OleItem(long nIndex);
237
238 afx_msg void OleClear();
239 afx_msg void OleRemove(long nIndex);
240 afx_msg LPDISPATCH OleFind(long nID);
241 afx_msg void OleMove(LPDISPATCH lpItem, long nIndex);
242 afx_msg LPDISPATCH OleGetItem(long nIndex);
243
244 DECLARE_ENUM_VARIANT(CXTPTaskPanelItems)
245
246 DECLARE_OLETYPELIB_EX(CXTPTaskPanelItems)
247
248 enum
249 {
250 dispidCount = 1L,
251 dispidRemove = 2L,
252 dispidClear = 3L,
253 dispidAdd = 4L,
254 dispidFind = 5L,
255 };
256
257 DECLARE_DISPATCH_MAP()
258 DECLARE_INTERFACE_MAP()
259
261# endif
262 friend class CXTPTaskPanel;
263 friend class CXTPTaskPanelGroup;
264};
265
270class _XTP_EXT_CLASS CXTPTaskPanelGroupItems : public CXTPTaskPanelItems
271{
272public:
278 CXTPTaskPanelGroupItems(CXTPTaskPanel* pPanel);
279
286 virtual CRuntimeClass* GetDefaultItemClass() const;
287
288# ifdef _XTP_ACTIVEX
291 DECLARE_DISPATCH_MAP()
292 DECLARE_INTERFACE_MAP()
293
294 DECLARE_OLETYPELIB_EX(CXTPTaskPanelGroupItems)
295
296 afx_msg LPDISPATCH OleAdd(long nID, LPCTSTR lpCaption, long nType,
297 const VARIANT& varImageIndex);
298 afx_msg LPDISPATCH OleInsert(long nIndex, long nID, LPCTSTR lpCaption, long nType,
299 const VARIANT& varImageIndex);
300
302# endif
303};
304
309class _XTP_EXT_CLASS CXTPTaskPanelGroups : public CXTPTaskPanelItems
310{
311public:
317 CXTPTaskPanelGroups(CXTPTaskPanel* pPanel);
318
325 virtual CRuntimeClass* GetDefaultItemClass() const;
326
327# ifdef _XTP_ACTIVEX
330 DECLARE_DISPATCH_MAP()
331 DECLARE_INTERFACE_MAP()
332
333 DECLARE_OLETYPELIB_EX(CXTPTaskPanelGroups)
334
335 afx_msg LPDISPATCH OleAdd(long nID, LPCTSTR lpCaption);
337# endif
338};
339
340AFX_INLINE int CXTPTaskPanelItems::GetCount() const
341{
342 return (int)m_arrItems.GetSize();
343}
344AFX_INLINE CXTPTaskPanelItem* CXTPTaskPanelItems::GetAt(int nIndex) const
345{
346 return nIndex >= 0 && nIndex < m_arrItems.GetSize() ? m_arrItems.GetAt(nIndex) : NULL;
347}
348AFX_INLINE CCmdTarget* CXTPTaskPanelItems::GetOwner() const
349{
350 return m_pOwner;
351}
352
353# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
355#endif // !defined(__XTPTASKPANELITEMS_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72
CXTPTaskPanelGroup
CXTPTaskPanelGroup is used in a Task Panel control to represent a group.
Definition XTPTaskPanelGroup.h:45
CXTPTaskPanelGroupItems
CXTPTaskPanelGroupItems represents a collection of items in a group.
Definition XTPTaskPanelItems.h:271
CXTPTaskPanelGroupItems::GetDefaultItemClass
virtual CRuntimeClass * GetDefaultItemClass() const
Gets the default runtime class of items in this collection.
CXTPTaskPanelGroupItems::CXTPTaskPanelGroupItems
CXTPTaskPanelGroupItems(CXTPTaskPanel *pPanel)
Constructs CXTPTaskPanelGroupItems object.
CXTPTaskPanelGroups
CXTPTaskPanelGroups represents a collection of groups in a Task Panel control.
Definition XTPTaskPanelItems.h:310
CXTPTaskPanelGroups::GetDefaultItemClass
virtual CRuntimeClass * GetDefaultItemClass() const
Gets the default runtime class of items in this collection.
CXTPTaskPanelGroups::CXTPTaskPanelGroups
CXTPTaskPanelGroups(CXTPTaskPanel *pPanel)
Constructs a CXTPTaskPanelGroups object.
CXTPTaskPanel
CXTPTaskPanel is used to implement an Explorer and Office-like Task Panel control.
Definition XTPTaskPanel.h:107
CXTPTaskPanelItem
CXTPTaskPanelItem is used in a Task Panel control to represent a single item.
Definition XTPTaskPanelItem.h:49
CXTPTaskPanelItems
CXTPTaskPanelItems is used in a Task Panel control to represent a collection of items.
Definition XTPTaskPanelItems.h:44
CXTPTaskPanelItems::GetCount
int GetCount() const
Gets the number of items in this collection.
Definition XTPTaskPanelItems.h:340
CXTPTaskPanelItems::GetDefaultItemClass
virtual CRuntimeClass * GetDefaultItemClass() const
Gets the default runtime class of items in this collection.
CXTPTaskPanelItems::GetFirstVisibleItem
CXTPTaskPanelItem * GetFirstVisibleItem() const
Gets the first visible item in this collection.
CXTPTaskPanelItems::DoPropExchange
void DoPropExchange(CXTPPropExchange *pPX)
Reads/writes this object from or/an archive.
CXTPTaskPanelItems::Clear
void Clear(BOOL bReposition=TRUE)
Removes all items from this collection.
CXTPTaskPanelItems::m_arrItems
CArray< CXTPTaskPanelItem *, CXTPTaskPanelItem * > m_arrItems
Array of items.
Definition XTPTaskPanelItems.h:229
CXTPTaskPanelItems::GetIndex
int GetIndex(const CXTPTaskPanelItem *pItem) const
Retrieves the index of a specified item in this collection.
CXTPTaskPanelItems::Find
CXTPTaskPanelItem * Find(UINT nID) const
Retrieves the item with a specified identifier.
CXTPTaskPanelItems::CXTPTaskPanelItems
CXTPTaskPanelItems(CXTPTaskPanel *pPanel=NULL)
Constructs a CXTPTaskPanelItems object.
CXTPTaskPanelItems::~CXTPTaskPanelItems
virtual ~CXTPTaskPanelItems()
Destroys a CXTPTaskPanelItems object, handles cleanup and deallocation.
CXTPTaskPanelItems::Remove
void Remove(CXTPTaskPanelItem *pItem)
Removes a specified item from this collection.
CXTPTaskPanelItems::Add
CXTPTaskPanelItem * Add(CXTPTaskPanelItem *pItem, UINT nID)
Adds an item to this collection.
CXTPTaskPanelItems::GetLastVisibleItem
CXTPTaskPanelItem * GetLastVisibleItem() const
Gets the last visible item in this collection.
CXTPTaskPanelItems::m_pOwner
CCmdTarget * m_pOwner
Owner of items.
Definition XTPTaskPanelItems.h:230
CXTPTaskPanelItems::m_pPanel
CXTPTaskPanel * m_pPanel
Parent Task Panel control.
Definition XTPTaskPanelItems.h:228
CXTPTaskPanelItems::GetOwner
CCmdTarget * GetOwner() const
Gets the owner.
Definition XTPTaskPanelItems.h:348
CXTPTaskPanelItems::InsertAt
CXTPTaskPanelItem * InsertAt(int nIndex, CXTPTaskPanelItem *pItem)
Inserts an item at a specified index in this collection.
CXTPTaskPanelItems::GetAt
CXTPTaskPanelItem * GetAt(int nIndex) const
Retrieves the item at a specified index in this collection.
Definition XTPTaskPanelItems.h:344
CXTPTaskPanelItems::Move
void Move(CXTPTaskPanelItem *pItem, int nIndex)
Moved a specified item to a specified index in this collection.
CXTPTaskPanelItems::GetNextVisibleIndex
int GetNextVisibleIndex(int nIndex, int nDirection) const
Retrieves the index of the next/previous visible item in this collection from a specified index.
CXTPTaskPanelItems::RemoveAt
void RemoveAt(int nIndex)
Removes the item at a specified index from this collection.
CXTPTaskPanelItems::Add
CXTPTaskPanelItem * Add(CXTPTaskPanelItem *pItem, UINT nID, LPCTSTR lpCaption, LPCTSTR lpTooltip=NULL)
Adds an item to this collection.


Toolkit Pro: Member List

CXTPCustomizeOptionsPage Member List

This is the complete list of members for CXTPCustomizeOptionsPage, including all inherited members.

AddComboString(UINT nIDResource) | CXTPCustomizeOptionsPage | protected
AdjustResizeRect(CSize &rcWindow) | CXTPResize | protectedvirtual
AutoLoadPlacement(LPCTSTR pszSection) | CXTPResize |
CResizeItemArray typedef | CXTPResize | protected
CXTPCustomizeOptionsPage(CXTPCustomizeSheet *pSheet) | CXTPCustomizeOptionsPage |
CXTPPropertyPage() | CXTPPropertyPage |
CXTPPropertyPage(UINT nIDTemplate, UINT nIDCaption=0) | CXTPPropertyPage |
CXTPPropertyPage(LPCTSTR lpszTemplateName, UINT nIDCaption=0) | CXTPPropertyPage |
CXTPResize(CWnd *pWnd, const UINT nFlags=0) | CXTPResize |
Defer(HDWP &hdwp, CXTPResizeItem *pItem, int dx, int dy) | CXTPResize | protectedvirtual
GetCaption() const | CXTPPropertyPage |
GetCommandBars() const | CXTPCustomizeOptionsPage |
GetMinMaxInfo(MINMAXINFO *pMMI) | CXTPResize | protected
HasFlag(XTPResize eFlag) | CXTPResize | protected
IDD enum value | CXTPCustomizeOptionsPage |
Init() | CXTPResize | protectedvirtual
LoadPlacement(LPCTSTR pszSection) | CXTPResize |
m_arrItems | CXTPResize | protected
m_bModified | CXTPPropertyPage | protected
m_btnAlwaysShowFullMenus | CXTPCustomizeOptionsPage |
m_btnLargeIcons | CXTPCustomizeOptionsPage |
m_btnResetData | CXTPCustomizeOptionsPage |
m_btnShowFullAfterDelay | CXTPCustomizeOptionsPage |
m_btnToolBarAccelTips | CXTPCustomizeOptionsPage |
m_btnToolBarScreenTips | CXTPCustomizeOptionsPage |
m_comboAnimationType | CXTPCustomizeOptionsPage |
m_dwData | CXTPPropertyPage |
m_nAnimationType | CXTPCustomizeOptionsPage |
m_nFlagsXX | CXTPResize | protected
m_pSheet | CXTPCustomizeOptionsPage | protected
m_pWnd | CXTPResize | protected
m_scSizeIcon | CXTPResize | protected
m_strSection | CXTPResize | protected
m_szInitWindow | CXTPResize | protected
m_szMax | CXTPResize | protected
m_szMin | CXTPResize | protected
m_szWindow | CXTPResize | protected
m_wndOtherGroup | CXTPCustomizeOptionsPage |
m_wndPersonalizedGroup | CXTPCustomizeOptionsPage |
Offset(CPoint ptOffset) | CXTPResize | protected
RemoveAllControls() | CXTPResize | protected
RemoveResize(UINT nID) | CXTPResize | protected
Reset() | CXTPResize | protected
SavePlacement(LPCTSTR pszSection) | CXTPResize |
SetCaption(LPCTSTR lpszCaption) | CXTPPropertyPage |
SetFlag(XTPResize eFlag) | CXTPResize | protected
SetMaxSize(CSize &sz) | CXTPResize |
SetMinSize(CSize &sz) | CXTPResize |
SetResize(UINT nID, XTP_RESIZE left, XTP_RESIZE top, XTP_RESIZE right, XTP_RESIZE bottom) | CXTPResize |
SetResize(UINT nID, const XTP_RESIZERECT &rrcSizing) | CXTPResize |
SetResize(UINT nID, HWND hWnd, const XTP_RESIZERECT &rrcSizing) | CXTPResize |
SetResize(UINT nID, HWND hWnd, const XTP_RESIZEPOINT &rpTopLeft, const XTP_RESIZEPOINT &rpBottomRight) | CXTPResize |
SetResize(UINT nID, const XTP_RESIZEPOINT &rpTopLeft, const XTP_RESIZEPOINT &rpBottomRight) | CXTPResize |
SetResize(CWnd *pWnd, const CXTPResizeRect &rrcSizing, CRect rcWindow) | CXTPResize | protected
Size() | CXTPResize | protectedvirtual
UpdateControlRect(CWnd *pWnd) | CXTPResize | protected
UpdatePage(void) | CXTPPropertyPage | virtual
~CXTPCustomizeOptionsPage() | CXTPCustomizeOptionsPage |
~CXTPPropertyPage() | CXTPPropertyPage |
~CXTPResize() | CXTPResize | virtual


Toolkit Pro: Member List

CXTPFlowGraphElement Member List

This is the complete list of members for CXTPFlowGraphElement, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPFlowGraphElement() | CXTPFlowGraphElement |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCaption() const =0 | CXTPFlowGraphElement | pure virtual
GetControl() const =0 | CXTPFlowGraphElement | pure virtual
GetPage() const =0 | CXTPFlowGraphElement | pure virtual
IsSelected() const | CXTPFlowGraphElement |
m_bDirty | CXTPFlowGraphElement |
m_bSelected | CXTPFlowGraphElement | protected
OnGraphChanged() | CXTPFlowGraphElement |
OnRemoved() | CXTPFlowGraphElement | virtual
SetCaption(LPCTSTR lpszCaption)=0 | CXTPFlowGraphElement | pure virtual
~CXTPFlowGraphElement() | CXTPFlowGraphElement | virtual


Toolkit Pro: Member List

CXTPArcBall Member List

This is the complete list of members for CXTPArcBall, including all inherited members.

CXTPArcBall() | CXTPArcBall
GetRotationQuaternion(double &xQuat, double &yQuat, double &zQuat, double &wQuat) | CXTPArcBall
HasBounds() const | CXTPArcBall
SetBegin(double x, double y) | CXTPArcBall
SetBounds(double dWidth, double dHeight) | CXTPArcBall
SetEnd(double x, double y) | CXTPArcBall


Toolkit Pro: XTPChartFunnelSeriesView.h Source File

  • Source
  • Chart
  • Styles
  • Funnel
XTPChartFunnelSeriesView.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTFUNNELSERIESVIEW_H__)
24# define __XTPCHARTFUNNELSERIESVIEW_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Chart/Styles/Funnel/Base/XTPChartFunnelSeriesViewBase.h"
32# include "Chart/Styles/Funnel/2D/XTPChart2dFunnelSeriesView.h"
33
34// CXTPChart2dFunnelSeriesView alias is necessary for naming consistency.
35typedef CXTPChartFunnelSeriesView CXTPChart2dFunnelSeriesView;
37#endif //#if !defined(__XTPCHARTFUNNELSERIESVIEW_H__)
XTPChart2dFunnelSeriesView.h
XTPChartFunnelSeriesViewBase.h
CXTPChartFunnelSeriesView
This class abstracts the view of a funnel series.
Definition XTPChart2dFunnelSeriesView.h:49


Toolkit Pro: Member List

CXTPChartStackedSplineAreaSeriesView Member List

This is the complete list of members for CXTPChartStackedSplineAreaSeriesView, including all inherited members.

AddChildView(CXTPChartElementView *pChildView) | CXTPChartElementView |
CreateDeviceCommand(CXTPChartDeviceContext *pDC) | CXTPChartStackedSplineAreaSeriesView | protectedvirtual
CreateLegendDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcBounds) | CXTPChartAreaSeriesView | protectedvirtual
CreateSeriesPointView(CXTPChartDeviceContext *pDC, CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView) | CXTPChartStackedAreaSeriesView | protected
CXTPChartAreaSeriesView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView) | CXTPChartAreaSeriesView |
CXTPChartElementView(CXTPChartElementView *pParentView) | CXTPChartElementView |
CXTPChartElementView(CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartElementView |
CXTPChartElementView(CXTPChartContainer *pContainer) | CXTPChartElementView |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartStackedAreaSeriesView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView) | CXTPChartStackedAreaSeriesView |
CXTPChartStackedSplineAreaSeriesView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView) | CXTPChartStackedSplineAreaSeriesView |
GetActualColor() const | CXTPChartAreaSeriesView | protected
GetActualColor2() const | CXTPChartAreaSeriesView | protected
GetAt(int nIndex) const | CXTPChartElementView |
GetBorderActualColor() const | CXTPChartAreaSeriesView | protected
GetBounds() const | CXTPChartElementView |
GetBounds(BOOL bIncludingChildren) const | CXTPChartElementView |
GetChildren() | CXTPChartElementView |
GetCount() const | CXTPChartElementView |
GetParentView() const | CXTPChartElementView |
Is3D() const | CXTPChartObject |
m_arrChildren | CXTPChartElementView | protected
m_pContainer | CXTPChartElementView | protected
m_pParentView | CXTPChartElementView | protected
m_rcBounds | CXTPChartElementView | protected
~CXTPChartElementView() | CXTPChartElementView | protectedvirtual
~CXTPChartLegendItemView() | CXTPChartLegendItemView | inlinevirtual


Toolkit Pro: XTPButtonThemeUltraFlat.h Source File

  • Source
  • Controls
  • Button
  • Themes
XTPButtonThemeUltraFlat.h
Go to the documentation of this file.
1
23#if !defined(__XTPBUTTONTHEMEULTRAFLAT_H__)
24# define __XTPBUTTONTHEMEULTRAFLAT_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPButtonThemeUltraFlat : public CXTPButtonTheme
39{
40public:
45 CXTPButtonThemeUltraFlat();
46
53 virtual void RefreshMetrics(CXTPButton* pButton);
54
61 virtual void DrawButtonBackground(CDC* pDC, CXTPButton* pButton);
62
69 virtual void DrawGroupBox(CDC* pDC, CXTPButton* pButton);
70
78 virtual void DrawCheckBoxMark(CDC* pDC, CXTPButton* pButton);
79
87 virtual void DrawRadioButtonMark(CDC* pDC, CXTPButton* pButton);
88
89 CXTPPaintManagerColor m_crBackHilite;
90 CXTPPaintManagerColor m_crBackPushed;
91 CXTPPaintManagerColor m_crBackChecked;
92 CXTPPaintManagerColor m_crBorderPushed;
93 CXTPPaintManagerColor m_crTextPushed;
94 CXTPPaintManagerColor m_crTextHilite;
95 CXTPPaintManagerColor m_crCheckMark;
97 BOOL m_bHiglightButtons;
98};
99
100# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
102#endif //#if !defined(__XTPBUTTONTHEMEULTRAFLAT_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPButton
Push Button control.
Definition XTPButton.h:109
CXTPButtonTheme
CXTPButtonTheme is a class used to perform Button Theme drawing tasks.
Definition XTPButtonTheme.h:51
CXTPButtonThemeUltraFlat
CXTPButtonThemeUltraFlat is a class used to perform Ultra Flat Theme drawing tasks.
Definition XTPButtonThemeUltraFlat.h:39
CXTPButtonThemeUltraFlat::DrawGroupBox
virtual void DrawGroupBox(CDC *pDC, CXTPButton *pButton)
This member function is called to draw the group box for the button.
CXTPButtonThemeUltraFlat::DrawCheckBoxMark
virtual void DrawCheckBoxMark(CDC *pDC, CXTPButton *pButton)
This member function is called to draw the check box mark for the button control.
CXTPButtonThemeUltraFlat::m_crBackChecked
CXTPPaintManagerColor m_crBackChecked
RGB value for when the control is checked.
Definition XTPButtonThemeUltraFlat.h:91
CXTPButtonThemeUltraFlat::DrawButtonBackground
virtual void DrawButtonBackground(CDC *pDC, CXTPButton *pButton)
This member function is called to draw the background for the button.
CXTPButtonThemeUltraFlat::m_crCheckMark
CXTPPaintManagerColor m_crCheckMark
RGB value for check mark color.
Definition XTPButtonThemeUltraFlat.h:95
CXTPButtonThemeUltraFlat::CXTPButtonThemeUltraFlat
CXTPButtonThemeUltraFlat()
Constructs a CXTPButtonThemeUltraFlat object.
CXTPButtonThemeUltraFlat::m_crBorderPushed
CXTPPaintManagerColor m_crBorderPushed
RGB value for border pushed color.
Definition XTPButtonThemeUltraFlat.h:92
CXTPButtonThemeUltraFlat::m_crBackHilite
CXTPPaintManagerColor m_crBackHilite
RGB value for highlighted background color.
Definition XTPButtonThemeUltraFlat.h:89
CXTPButtonThemeUltraFlat::m_crTextPushed
CXTPPaintManagerColor m_crTextPushed
RGB value for pushed text color.
Definition XTPButtonThemeUltraFlat.h:93
CXTPButtonThemeUltraFlat::m_crBackPushed
CXTPPaintManagerColor m_crBackPushed
RGB value for pushed background color.
Definition XTPButtonThemeUltraFlat.h:90
CXTPButtonThemeUltraFlat::DrawRadioButtonMark
virtual void DrawRadioButtonMark(CDC *pDC, CXTPButton *pButton)
This member function is called to draw the radio mark for the button control.
CXTPButtonThemeUltraFlat::m_crTextHilite
CXTPPaintManagerColor m_crTextHilite
RGB value for highlighted text color.
Definition XTPButtonThemeUltraFlat.h:94
CXTPButtonThemeUltraFlat::RefreshMetrics
virtual void RefreshMetrics(CXTPButton *pButton)
This member function is called by the theme manager to refresh the visual styles used by each compone...
CXTPPaintManagerColor
The CXTPPaintManagerColor class is used to manage COLORREF values for determining default and applica...
Definition XTPColorManager.h:117


Toolkit Pro: Member List

CXTPSystemVersion Member List

This is the complete list of members for CXTPSystemVersion, including all inherited members.

GetComCtlVersion() const | CXTPSystemVersion |
GetMaxCharSize() const | CXTPSystemVersion |
GetOSVersionInfo() const | CXTPSystemVersion |
GetVersion(BYTE dwConditionMask, DWORD dwMajorVersion, DWORD dwMinorVersion, DWORD dwPlatformId) const | CXTPSystemVersion |
IsClearTypeTextQualitySupported() const | CXTPSystemVersion |
IsLayoutRTLSupported() const | CXTPSystemVersion |
IsWin10OrGreater() const | CXTPSystemVersion |
IsWin11OrGreater() const | CXTPSystemVersion |
IsWin2K() const | CXTPSystemVersion |
IsWin2KOrGreater() const | CXTPSystemVersion |
IsWin31() const | CXTPSystemVersion |
IsWin31OrGreater() const | CXTPSystemVersion |
IsWin7OrGreater() const | CXTPSystemVersion |
IsWin81OrGreater() const | CXTPSystemVersion |
IsWin8OrGreater() const | CXTPSystemVersion |
IsWin95() const | CXTPSystemVersion |
IsWin95OrGreater() const | CXTPSystemVersion |
IsWin98() const | CXTPSystemVersion |
IsWin98OrGreater() const | CXTPSystemVersion |
IsWin9x() const | CXTPSystemVersion |
IsWinME() const | CXTPSystemVersion |
IsWinMEOrGreater() const | CXTPSystemVersion |
IsWinNT4() const | CXTPSystemVersion |
IsWinNT4OrGreater() const | CXTPSystemVersion |
IsWinVistaOrGreater() const | CXTPSystemVersion |
IsWinXP() const | CXTPSystemVersion |
IsWinXPOrGreater() const | CXTPSystemVersion |
VerifyVersion(BYTE dwConditionMask, DWORD dwMajorVersion, DWORD dwMinorVersion, DWORD dwPlatformId) const | CXTPSystemVersion |
VerifyWinVer(BYTE dwConditionMask, DWORD dwMajorVersion, DWORD dwMinorVersion, DWORD dwPlatformId) const | CXTPSystemVersion |
XTPSystemVersion() | CXTPSystemVersion | friend


Toolkit Pro: Member List

CXTPCommandBarKeyboardTip Member List

This is the complete list of members for CXTPCommandBarKeyboardTip, including all inherited members.

CXTPCommandBarKeyboardTip(CXTPCommandBars *pCommandBars, CCmdTarget *pOwner, LPCTSTR lpszCaption, CPoint pt, DWORD dwAlign, BOOL bEnabled) | CXTPCommandBarKeyboardTip
m_bEnabled | CXTPCommandBarKeyboardTip
m_bExplicit | CXTPCommandBarKeyboardTip
m_bVisible | CXTPCommandBarKeyboardTip
m_dwAlign | CXTPCommandBarKeyboardTip
m_pCommandBars | CXTPCommandBarKeyboardTip
m_pOwner | CXTPCommandBarKeyboardTip
m_pt | CXTPCommandBarKeyboardTip
m_strCaption | CXTPCommandBarKeyboardTip
m_strPrefix | CXTPCommandBarKeyboardTip
m_strTip | CXTPCommandBarKeyboardTip


Toolkit Pro: Member List

CXTPTabThemeOffice2000 Member List

This is the complete list of members for CXTPTabThemeOffice2000, including all inherited members.

AdjustClientRect(CXTPTabManager *pTabManager, CRect &rcClient) | CXTPTabPaintManagerTheme | virtual
CXTPTabPaintManagerTheme() | CXTPTabPaintManagerTheme |
CXTPTabThemeOffice2000() | CXTPTabThemeOffice2000 | inline
DrawSingleButton(CDC *pDC, CXTPTabManagerItem *pItem) | CXTPTabThemeOffice2000 | virtual
DrawTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl) | CXTPTabPaintManagerTheme | virtual
DrawText(CDC *pDC, CXTPTabManager *pManager, const CString &str, LPRECT lpRect, UINT nFormat) | CXTPTabPaintManagerTheme | virtual
DrawWorkspacePart(CDC *pDC, LPRECT lpRect, XTPTabWorkspacePart workspacePart) | CXTPTabPaintManagerTheme | virtual
FillButton(CDC *pDC, CXTPTabManagerItem *pItem, LPPOINT pts, int nCount, XTPTabPosition tabPosition, BOOL bAbsolute=FALSE) | CXTPTabPaintManagerTheme |
FillTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl) | CXTPTabThemeOffice2000 | virtual
GetButtonDrawRect(const CXTPTabManagerItem *pItem) | CXTPTabThemeOffice2000 | virtual
GetButtonHeight(const CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetButtonLength(CDC *pDC, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerTheme | virtual
GetClientMargin() | CXTPTabThemeOffice2000 | virtual
GetClientRect(CRect rcControl, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetColorSet() const | CXTPTabPaintManagerTheme |
GetDefaultColorSet() | CXTPTabThemeOffice2000 | inlinevirtual
GetHeaderClipBox(CDC *pDC, CXTPTabManager *pTabManager) | CXTPTabThemeOffice2000 | virtual
GetHeaderHeight(CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme |
GetHeaderMargin() | CXTPTabPaintManagerTheme | virtual
GetHeaderRect(CRect rcControl, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetSupportedColorSets() | CXTPTabPaintManagerTheme | inlinevirtual
m_bButtonsReverseZOrder | CXTPTabPaintManagerTheme | protected
m_nButtonHeight | CXTPTabPaintManagerTheme | protected
m_nRowMargin | CXTPTabPaintManagerTheme |
m_pPaintManager | CXTPTabPaintManagerTheme | protected
m_rcHeaderMargin | CXTPTabPaintManagerTheme |
RefreshMetrics() | CXTPTabThemeOffice2000 | virtual
RepositionTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcClient) | CXTPTabPaintManagerTheme | virtual
~CXTPTabPaintManagerTheme() | CXTPTabPaintManagerTheme | virtual


Toolkit Pro: XTPComboBoxThemeVisualStudio2017.h Source File

  • Source
  • Controls
  • Combo
  • Themes
XTPComboBoxThemeVisualStudio2017.h
Go to the documentation of this file.
1
23#if !defined(__XTPCOMBOBOXTHEMEVISUALSTUDIO2017_H__)
24# define __XTPCOMBOBOXTHEMEVISUALSTUDIO2017_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPComboBoxThemeVisualStudio2017 : public CXTPComboBoxThemeOffice2013
39{
40public:
45 CXTPComboBoxThemeVisualStudio2017();
46
51 virtual ~CXTPComboBoxThemeVisualStudio2017();
52
59 virtual void RefreshMetrics(CXTPComboBox* pComboBox);
60
69 virtual void DrawButton(CDC* pDC, CXTPComboBox* pComboBox, CRect rcBtn);
70};
71
72# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
74#endif // __XTPCOMBOBOXTHEMEVISUALSTUDIO2017_H__
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPComboBox
The CXTPComboBox class provides the functionality of a themed Windows combobox.
Definition XTPComboBox.h:42
CXTPComboBoxThemeOffice2013
Used as the paint manager for a combobox control to render an Office 2013 appearance.
Definition XTPComboBoxThemeOffice2013.h:39
CXTPComboBoxThemeVisualStudio2017
Used as the paint manager for a combobox control to render a Visual Studio 2017 appearance.
Definition XTPComboBoxThemeVisualStudio2017.h:39
CXTPComboBoxThemeVisualStudio2017::CXTPComboBoxThemeVisualStudio2017
CXTPComboBoxThemeVisualStudio2017()
Default constructor.
CXTPComboBoxThemeVisualStudio2017::RefreshMetrics
virtual void RefreshMetrics(CXTPComboBox *pComboBox)
This member function is called by the theme manager to refresh the visual styles used by each compone...
CXTPComboBoxThemeVisualStudio2017::DrawButton
virtual void DrawButton(CDC *pDC, CXTPComboBox *pComboBox, CRect rcBtn)
Called by the paint manager to draw the button portion of the combobox control.
CXTPComboBoxThemeVisualStudio2017::~CXTPComboBoxThemeVisualStudio2017
virtual ~CXTPComboBoxThemeVisualStudio2017()
Destructor handles cleanup and deallocation.


Toolkit Pro: Member List

CXTPChartStackedAreaSeriesView Member List

This is the complete list of members for CXTPChartStackedAreaSeriesView, including all inherited members.

AddChildView(CXTPChartElementView *pChildView) | CXTPChartElementView |
CreateDeviceCommand(CXTPChartDeviceContext *pDC) | CXTPChartStackedAreaSeriesView | protectedvirtual
CreateLegendDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcBounds) | CXTPChartAreaSeriesView | protectedvirtual
CreateSeriesPointView(CXTPChartDeviceContext *pDC, CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView) | CXTPChartStackedAreaSeriesView | protected
CXTPChartAreaSeriesView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView) | CXTPChartAreaSeriesView |
CXTPChartElementView(CXTPChartElementView *pParentView) | CXTPChartElementView |
CXTPChartElementView(CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartElementView |
CXTPChartElementView(CXTPChartContainer *pContainer) | CXTPChartElementView |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartStackedAreaSeriesView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView) | CXTPChartStackedAreaSeriesView |
GetActualColor() const | CXTPChartAreaSeriesView | protected
GetActualColor2() const | CXTPChartAreaSeriesView | protected
GetAt(int nIndex) const | CXTPChartElementView |
GetBorderActualColor() const | CXTPChartAreaSeriesView | protected
GetBounds() const | CXTPChartElementView |
GetBounds(BOOL bIncludingChildren) const | CXTPChartElementView |
GetChildren() | CXTPChartElementView |
GetCount() const | CXTPChartElementView |
GetParentView() const | CXTPChartElementView |
Is3D() const | CXTPChartObject |
m_arrChildren | CXTPChartElementView | protected
m_pContainer | CXTPChartElementView | protected
m_pParentView | CXTPChartElementView | protected
m_rcBounds | CXTPChartElementView | protected
~CXTPChartElementView() | CXTPChartElementView | protectedvirtual
~CXTPChartLegendItemView() | CXTPChartLegendItemView | inlinevirtual


Toolkit Pro: Member List

IXTPPreviewProvider Member List

This is the complete list of members for IXTPPreviewProvider, including all inherited members.

BindHost(IXTPPreviewHost &host)=0 | IXTPPreviewProvider | pure virtual
CreatePreview(LPCTSTR pFilePath, HWND hwndParent)=0 | IXTPPreviewProvider | pure virtual
CreatePreview(IStream &stream, LPCTSTR pImpliedFileName, HWND hwndParent)=0 | IXTPPreviewProvider | pure virtual
GetDefaultFileAssociations() const =0 | IXTPPreviewProvider | pure virtual
~IXTPPreviewProvider() | IXTPPreviewProvider | inlinevirtual


Toolkit Pro: XTPComboBoxTheme.h Source File

  • Source
  • Controls
  • Combo
XTPComboBoxTheme.h
Go to the documentation of this file.
1
23#if !defined(__XTPCOMBOBOXTHEME_H__)
24# define __XTPCOMBOBOXTHEME_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPWinThemeWrapper;
34class CXTPComboBox;
35
41class _XTP_EXT_CLASS CXTPComboBoxTheme : public CXTPControlTheme
42{
43public:
48 CXTPComboBoxTheme();
49
54 virtual ~CXTPComboBoxTheme();
55
68 virtual void FillSolidRect(HDC hdc, int x, int y, int cx, int cy, HBRUSH hBrush);
69
81 virtual void DrawFrame(HDC hdc, LPRECT lprc, int nSize, HBRUSH hBrush);
82
90 virtual BOOL DrawComboBox(CDC* pDC, CXTPComboBox* pComboBox);
91
98 virtual void DrawBackground(CDC* pDC, CXTPComboBox* pComboBox);
99
108 virtual void DrawButton(CDC* pDC, CXTPComboBox* pComboBox, CRect rcBtn);
109
118 virtual void DrawButtonTriangle(CDC* pDC, CXTPComboBox* pComboBox, CRect rcBtn);
119
126 virtual void RefreshMetrics(CXTPComboBox* pComboBox);
127
138 COLORREF GetBackColor() const;
139
152 COLORREF SetBackColor(COLORREF clrBackground);
153
161 void ResetBackColor();
162
173 COLORREF GetTextColor() const;
174
187 COLORREF SetTextColor(COLORREF clrText);
188
196 void ResetTextColor();
197
206 const CBrush& GetBackgroundBrush() const;
207
208protected:
214 void UpdateBackgroundBrush();
215
216 int m_nThumbWidth;
217 CXTPBrush m_xtpBrushBackground;
218 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CBrush, m_brBackground, m_xtpBrushBackground,
219 GetBackgroundBrushHandle);
220 CXTPWinThemeWrapper* m_themeComboBox;
222public:
223 CXTPPaintManagerColor m_clrBorderDisabled;
225 CXTPPaintManagerColor m_clrBorderHot;
226 CXTPPaintManagerColor m_clrBorderNormal;
227 CXTPPaintManagerColor m_clrButtonPressed;
229 CXTPPaintManagerColor m_clrButtonHot;
231 CXTPPaintManagerColor m_clrButtonNormal;
232 CXTPPaintManagerColor m_clrButtonArrowPressed;
234 CXTPPaintManagerColor m_clrButtonArrowHot;
236 CXTPPaintManagerColor m_clrButtonArrowNormal;
238 CXTPPaintManagerColor m_clrBackground;
239 CXTPPaintManagerColor m_clrBackDisabled;
241 CXTPPaintManagerColor m_clrBackHighlight;
243 CXTPPaintManagerColor m_clrText;
244 CXTPPaintManagerColor m_clrTextDisabled;
246 CXTPPaintManagerColor m_clrTextHighlight;
248 CXTPPaintManagerColorGradient m_grcButton;
250 CXTPPaintManagerColorGradient m_grcButtonHilite;
252 CXTPPaintManagerColorGradient m_grcButtonPushed;
255private:
256 friend class CXTPComboBox;
257};
258
260
261AFX_INLINE COLORREF CXTPComboBoxTheme::GetBackColor() const
262{
263 return m_clrBackground;
264}
265AFX_INLINE COLORREF CXTPComboBoxTheme::SetBackColor(COLORREF clrBackground)
266{
267 COLORREF clrOldBackground = m_clrBackground;
268 m_clrBackground.SetCustomValue(clrBackground);
269 return clrOldBackground;
270}
271AFX_INLINE void CXTPComboBoxTheme::ResetBackColor()
272{
273 m_clrBackground.SetDefaultValue();
274}
275AFX_INLINE COLORREF CXTPComboBoxTheme::GetTextColor() const
276{
277 return m_clrText;
278}
279AFX_INLINE COLORREF CXTPComboBoxTheme::SetTextColor(COLORREF clrText)
280{
281 COLORREF clrOldText = m_clrText;
282 m_clrText.SetCustomValue(clrText);
283 return clrOldText;
284}
285AFX_INLINE void CXTPComboBoxTheme::ResetTextColor()
286{
287 m_clrText.SetDefaultValue();
288}
289AFX_INLINE const CBrush& CXTPComboBoxTheme::GetBackgroundBrush() const
290{
291 return m_xtpBrushBackground;
292}
294# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
296#endif // __XTPCOMBOBOXTHEME_H__
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPBrush
Provides a convenient object oriented interface for HBRUSH GDI object and uses GDI handle caching.
Definition XTPGdiObjects.h:653
CXTPComboBox
The CXTPComboBox class provides the functionality of a themed Windows combobox.
Definition XTPComboBox.h:42
CXTPComboBoxTheme
CXTPComboBoxTheme is a class used to perform ComboBox Theme drawing tasks.
Definition XTPComboBoxTheme.h:42
CXTPComboBoxTheme::m_clrBackHighlight
CXTPPaintManagerColor m_clrBackHighlight
RGB color value representing highlight background color.
Definition XTPComboBoxTheme.h:241
CXTPComboBoxTheme::m_themeComboBox
CXTPWinThemeWrapper * m_themeComboBox
Windows API wrapper used to draw windows theme.
Definition XTPComboBoxTheme.h:220
CXTPComboBoxTheme::m_clrTextDisabled
CXTPPaintManagerColor m_clrTextDisabled
RGB color value representing disabled text color.
Definition XTPComboBoxTheme.h:244
CXTPComboBoxTheme::m_clrTextHighlight
CXTPPaintManagerColor m_clrTextHighlight
RGB color value representing highlight text color.
Definition XTPComboBoxTheme.h:246
CXTPComboBoxTheme::m_grcButton
CXTPPaintManagerColorGradient m_grcButton
RGB value used to draw the button gradient color.
Definition XTPComboBoxTheme.h:248
CXTPComboBoxTheme::m_grcButtonHilite
CXTPPaintManagerColorGradient m_grcButtonHilite
RGB value used to draw the button highlighted gradient color.
Definition XTPComboBoxTheme.h:250
CXTPComboBoxTheme::DrawFrame
virtual void DrawFrame(HDC hdc, LPRECT lprc, int nSize, HBRUSH hBrush)
Called by the combobox to draw a frame rectangle using the brush specified by hBrush.
CXTPComboBoxTheme::FillSolidRect
virtual void FillSolidRect(HDC hdc, int x, int y, int cx, int cy, HBRUSH hBrush)
Called by the combobox to fill a rectangle using the brush specifed by hBrush.
CXTPComboBoxTheme::m_clrButtonArrowPressed
CXTPPaintManagerColor m_clrButtonArrowPressed
RGB value used to draw the pressed button arrow color.
Definition XTPComboBoxTheme.h:232
CXTPComboBoxTheme::GetBackgroundBrush
const CBrush & GetBackgroundBrush() const
Call this member function to retrieve a reference to a CBrush object used to draw the combobox backgr...
CXTPComboBoxTheme::m_clrBackDisabled
CXTPPaintManagerColor m_clrBackDisabled
RGB color value representing disabled background color.
Definition XTPComboBoxTheme.h:239
CXTPComboBoxTheme::m_clrButtonNormal
CXTPPaintManagerColor m_clrButtonNormal
RGB value used to draw the normal button color.
Definition XTPComboBoxTheme.h:231
CXTPComboBoxTheme::UpdateBackgroundBrush
void UpdateBackgroundBrush()
Called by the framework to update the color value used by the combobox background brush.
CXTPComboBoxTheme::m_clrBackground
CXTPPaintManagerColor m_clrBackground
RGB color value representing background color.
Definition XTPComboBoxTheme.h:238
CXTPComboBoxTheme::m_clrBorderDisabled
CXTPPaintManagerColor m_clrBorderDisabled
RGB value used to draw the disabled border color.
Definition XTPComboBoxTheme.h:223
CXTPComboBoxTheme::RefreshMetrics
virtual void RefreshMetrics(CXTPComboBox *pComboBox)
This member function is called by the theme manager to refresh the visual styles used by each compone...
CXTPComboBoxTheme::m_clrBorderNormal
CXTPPaintManagerColor m_clrBorderNormal
RGB value used to draw the normal border color.
Definition XTPComboBoxTheme.h:226
CXTPComboBoxTheme::m_clrText
CXTPPaintManagerColor m_clrText
RGB color value representing text color.
Definition XTPComboBoxTheme.h:243
CXTPComboBoxTheme::m_nThumbWidth
int m_nThumbWidth
Size in pixels of the drop button width.
Definition XTPComboBoxTheme.h:216
CXTPComboBoxTheme::GetTextColor
COLORREF GetTextColor() const
Call this member function to retrieve the text color of the CXTPComboBox control.
CXTPComboBoxTheme::m_clrBorderHot
CXTPPaintManagerColor m_clrBorderHot
RGB value used to draw the hilighted border color.
Definition XTPComboBoxTheme.h:225
CXTPComboBoxTheme::SetTextColor
COLORREF SetTextColor(COLORREF clrText)
Call this member function to set the text color for the CXTPComboBox control.
CXTPComboBoxTheme::~CXTPComboBoxTheme
virtual ~CXTPComboBoxTheme()
Destructor handles cleanup and deallocation.
CXTPComboBoxTheme::m_clrButtonArrowHot
CXTPPaintManagerColor m_clrButtonArrowHot
RGB value used to draw the highlighted button arrow color.
Definition XTPComboBoxTheme.h:234
CXTPComboBoxTheme::GetBackColor
COLORREF GetBackColor() const
Call this member function to retrieve the background color of the CXTPComboBox control.
CXTPComboBoxTheme::m_clrButtonHot
CXTPPaintManagerColor m_clrButtonHot
RGB value used to draw the highlighted button color.
Definition XTPComboBoxTheme.h:229
CXTPComboBoxTheme::m_grcButtonPushed
CXTPPaintManagerColorGradient m_grcButtonPushed
RGB value used to draw the button pushed gradient color.
Definition XTPComboBoxTheme.h:252
CXTPComboBoxTheme::m_xtpBrushBackground
CXTPBrush m_xtpBrushBackground
Brush used by the combobox to fill the background color.
Definition XTPComboBoxTheme.h:217
CXTPComboBoxTheme::ResetTextColor
void ResetTextColor()
Call this member function to reset the text color for the CXTPComboBox control.
CXTPComboBoxTheme::DrawButton
virtual void DrawButton(CDC *pDC, CXTPComboBox *pComboBox, CRect rcBtn)
Called by the paint manager to draw the button portion of the combobox control.
CXTPComboBoxTheme::DrawButtonTriangle
virtual void DrawButtonTriangle(CDC *pDC, CXTPComboBox *pComboBox, CRect rcBtn)
Called by the paint manager to draw the drop down arrow for the combobox drop button.
CXTPComboBoxTheme::DrawBackground
virtual void DrawBackground(CDC *pDC, CXTPComboBox *pComboBox)
This member function is called to draw the combobox background.
CXTPComboBoxTheme::SetBackColor
COLORREF SetBackColor(COLORREF clrBackground)
Call this member function to set the background color for the CXTPComboBox control.
CXTPComboBoxTheme::CXTPComboBoxTheme
CXTPComboBoxTheme()
Default constructor.
CXTPComboBoxTheme::DrawComboBox
virtual BOOL DrawComboBox(CDC *pDC, CXTPComboBox *pComboBox)
Called by the framework to draw the combobox control.
CXTPComboBoxTheme::ResetBackColor
void ResetBackColor()
Call this member function to reset the background color for the CXTPComboBox control.
CXTPComboBoxTheme::m_clrButtonPressed
CXTPPaintManagerColor m_clrButtonPressed
RGB value used to draw the pressed button color.
Definition XTPComboBoxTheme.h:227
CXTPComboBoxTheme::m_clrButtonArrowNormal
CXTPPaintManagerColor m_clrButtonArrowNormal
RGB value used to draw the normal button arrow color.
Definition XTPComboBoxTheme.h:236
CXTPControlTheme
CXTPControlTheme can be used as a base class for user defined themes.
Definition XTPControlTheme.h:95
CXTPPaintManagerColorGradient
The CXTPPaintManagerColorGradient class is used to manage COLORREF values for determining light and d...
Definition XTPColorManager.h:301
CXTPPaintManagerColor
The CXTPPaintManagerColor class is used to manage COLORREF values for determining default and applica...
Definition XTPColorManager.h:117
CXTPPaintManagerColor::SetDefaultValue
void SetDefaultValue()
This member function will remove the application defined color (if any) that was defined for the CXTP...
CXTPPaintManagerColor::SetCustomValue
void SetCustomValue(COLORREF clr)
This member function will sets the application defined color for the CXTPPaintManagerColor class.
CXTPWinThemeWrapper
The CXTPWinThemeWrapper class wraps the UxTheme.dll visual theme API.
Definition XTPWinThemeWrapper.h:188


Toolkit Pro: XTPChart3dFunnelDiagramView.h Source File

  • Source
  • Chart
  • Styles
  • Funnel
  • 3D
XTPChart3dFunnelDiagramView.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHART3DFUNNELDIAGRAMVIEW_H__)
24# define __XTPCHART3DFUNNELDIAGRAMVIEW_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartDiagram;
34class CXTPChartElementView;
35
47class _XTP_EXT_CLASS CXTPChart3dFunnelDiagramView : public CXTPChart3dDiagramView
48{
49 DECLARE_DYNAMIC(CXTPChart3dFunnelDiagramView);
50
51public:
59 CXTPChart3dFunnelDiagramView(CXTPChartDiagram* pDiagram, CXTPChartElementView* pParent);
60};
62# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
63#endif //#if !defined(__XTPCHART3DFUNNELDIAGRAMVIEW_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChart3dDiagramView
This class represents the view of a chart diagram, which is a kind of CXTPChartElementView.
Definition XTPChartDiagramView.h:180
CXTPChart3dFunnelDiagramView
This class abstracts the view of a funnel diagram.
Definition XTPChart3dFunnelDiagramView.h:48
CXTPChart3dFunnelDiagramView::CXTPChart3dFunnelDiagramView
CXTPChart3dFunnelDiagramView(CXTPChartDiagram *pDiagram, CXTPChartElementView *pParent)
Constructs a CXTPChart3dFunnelDiagramView object.
CXTPChartDiagram
This class represents a chart diagram, which is a kind of CXTPChartElement.
Definition XTPChartDiagram.h:48
CXTPChartElementView
This class represents the view of a chart element.
Definition XTPChartElementView.h:47


Toolkit Pro: Member List

CXTPRibbonControlSystemPopupBarListItem Member List

This is the complete list of members for CXTPRibbonControlSystemPopupBarListItem, including all inherited members.

AssignDocTemplate(UINT nIDResource) | CXTPControl |
ClickToolBarButton(CRect rcActiveRect=CRect(0, 0, 0, 0)) | CXTPControl | protected
Compare(CXTPControl *pOther) | CXTPControl | virtual
Copy(CXTPControl *pControl, BOOL bRecursive=FALSE) | CXTPControlButton | protectedvirtual
CustomizeStartDrag(CPoint point) | CXTPControl | protectedvirtual
CustomizeStartResize(CPoint point) | CXTPControl | protectedvirtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPControl() | CXTPControl | protected
CXTPControlButton() | CXTPControlButton |
CXTPRibbonControlSystemPopupBarListItem() | CXTPRibbonControlSystemPopupBarListItem |
DelayLayoutParent() | CXTPControl |
DelayRedrawParent() | CXTPControl |
DoCustomDragOver(CXTPCommandBar *pCommandBar, CPoint point, DROPEFFECT &dropEffect) | CXTPControl | protectedvirtual
DoPropExchange(CXTPPropExchange *pPX) | CXTPControlButton | virtual
Draw(CDC *pDC) | CXTPRibbonControlSystemPopupBarListItem | virtual
ExcludeDocTemplate(UINT nIDResource) | CXTPControl |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
FromUI(CCmdUI *pCmdUI) | CXTPControl | static
GenerateCommandBarList(DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam) | CXTPControl | protectedvirtual
GetAction() const | CXTPControl |
GetBeginGroup() const | CXTPControl |
GetButtonSize() const | CXTPControl | virtual
GetCaption() const | CXTPControl | virtual
GetCategory() const | CXTPControl |
GetChecked() const | CXTPControl |
GetCloseSubMenuOnClick() const | CXTPControl |
GetCommandBar() const | CXTPControl | virtual
GetControls() const | CXTPControl |
GetCustomizeMinHeight() const | CXTPControl | protectedvirtual
GetCustomizeMinWidth() const | CXTPControl | protectedvirtual
GetCustomShortcutText() const | CXTPControl |
GetDescription() const | CXTPControl | virtual
GetEnabled() const | CXTPControl |
GetExecuteOnPressInterval() const | CXTPControl |
GetExpanded() const | CXTPControl |
GetFlags() const | CXTPControl |
GetHeight() const | CXTPControl |
GetHelpId() const | CXTPControl |
GetHideFlags() const | CXTPControl |
GetIconId() const | CXTPControl |
GetIconSize() const | CXTPControl | virtual
GetID() const | CXTPControl |
GetImage(int nWidth=16) const | CXTPControl | virtual
GetImageManager() const | CXTPControl |
GetIndex() const | CXTPControl |
GetKeyboardTip() const | CXTPControl |
GetPaintManager() const | CXTPControl |
GetParameter() const | CXTPControl |
GetParent() const | CXTPControl |
GetPopuped() const | CXTPControl | virtual
GetPressed() const | CXTPControl | virtual
GetRect() const | CXTPControl |
GetRibbonGroup() const | CXTPControl |
GetRowRect() const | CXTPControl |
GetSelected() const | CXTPControl | virtual
GetShortcutText() const | CXTPControl |
GetSize(CDC *pDC) | CXTPRibbonControlSystemPopupBarListItem | virtual
GetStyle() const | CXTPControl |
GetStyleEx() const | CXTPControlButton |
GetTag() const | CXTPControl |
GetTooltip() const | CXTPControl | virtual
GetType() const | CXTPControl |
GetWidth() const | CXTPControl |
GetWrap() const | CXTPControl |
HasDwmCompositedRect() const | CXTPControl |
IsCaptionVisible() const | CXTPControl | virtual
IsCursorOver() const | CXTPControl |
IsCustomizeMode() const | CXTPControl | protected
IsCustomizeMovable() const | CXTPControl | virtual
IsCustomizeResizeAllow() const | CXTPControl | protectedvirtual
IsFocusable() const | CXTPControl | protectedvirtual
IsFocused() const | CXTPControl | virtual
IsItemDefault() const | CXTPControl |
IsLayoutChanged() | CXTPControl | protected
IsLayoutRTL() const | CXTPControl | protected
IsOnQuickAccess() const | CXTPControl |
IsTemporary() const | CXTPControl |
IsTransparent() const | CXTPControl | inlinevirtual
IsVisible(DWORD dwSkipFlags=0) const | CXTPControl | virtual
m_bAlignShortcut | CXTPRibbonControlSystemPopupBarListItem | protected
m_bBeginGroup | CXTPControl | protected
m_bChecked | CXTPControl | protected
m_bCloseSubMenuOnClick | CXTPControl | protected
m_bDefaultItem | CXTPControl | protected
m_bEnabled | CXTPControl | protected
m_bExpanded | CXTPControl | protected
m_bLayoutRTL | CXTPControl | protected
m_bOnQuickAccess | CXTPControl | protected
m_bPressed | CXTPControl | protected
m_bSelected | CXTPControl | protected
m_bTemporary | CXTPControl | protected
m_buttonCustomStyle | CXTPControl | protected
m_buttonRibbonStyle | CXTPControl | protected
m_buttonStyle | CXTPControl | protected
m_buttonStyleEx | CXTPControlButton | protected
m_bWrap | CXTPControl | protected
m_controlType | CXTPControl | protected
m_dwFlags | CXTPControl | protected
m_dwHideFlags | CXTPControl | protected
m_mapDocTemplatesAssigned | CXTPControl | protected
m_mapDocTemplatesExcluded | CXTPControl | protected
m_nCustomIconId | CXTPControl | protected
m_nExecuteOnPressInterval | CXTPControl | protected
m_nHeight | CXTPControl | protected
m_nHelpId | CXTPControl | protected
m_nIconId | CXTPControl | protected
m_nId | CXTPControl | protected
m_nIndex | CXTPControl | protected
m_nTag | CXTPControl | protected
m_nWidth | CXTPControl | protected
m_pAction | CXTPControl | protected
m_pControls | CXTPControl | protected
m_pParent | CXTPControl | protected
m_pRibbonGroup | CXTPControl | protected
m_rcControl | CXTPControl | protected
m_rcRow | CXTPControl | protected
m_strCaption | CXTPControl | protected
m_strCategory | CXTPControl | protected
m_strCustomCaption | CXTPControl | protected
m_strDescriptionText | CXTPControl | protected
m_strKeyboardTip | CXTPControl | protected
m_strParameter | CXTPControl | protected
m_strShortcutText | CXTPControl | protected
m_strShortcutTextAuto | CXTPControl | protected
m_strTooltipText | CXTPControl | protected
m_szIcon | CXTPControl | protected
NotifySite(UINT code) | CXTPControl |
NotifySite(UINT code, NMXTPCONTROL *pNM) | CXTPControl |
NotifySite(CWnd *pSite, UINT code, NMXTPCONTROL *pNM) | CXTPControl |
OnActionChanged(int nProperty) | CXTPControl | protectedvirtual
OnActionChanging(int nProperty) | CXTPControl | protectedvirtual
OnCalcDynamicSize(DWORD dwMode) | CXTPControl | virtual
OnCaptionChanged() | CXTPControl | protectedvirtual
OnClick(BOOL bKeyboard=FALSE, CPoint pt=CPoint(0, 0)) | CXTPControlButton | protectedvirtual
OnCustomizeDragOver(CXTPControl *pDataObject, CPoint point, DROPEFFECT &dropEffect) | CXTPControl | protectedvirtual
OnCustomizeMouseMove(CPoint point) | CXTPControl | protected
OnEnabledChanged() | CXTPControl | virtual
OnExecute() | CXTPControl | virtual
OnHookKeyDown(UINT nChar, LPARAM lParam) | CXTPControl | protectedvirtual
OnHookMouseWheel(UINT nFlags, short zDelta, CPoint point) | CXTPControl | protectedvirtual
OnIdleUpdate() | CXTPControl | protectedvirtual
OnLButtonDblClk(CPoint point) | CXTPControl | protectedvirtual
OnLButtonDown(CPoint point) | CXTPControl | protectedvirtual
OnLButtonUp(CPoint point) | CXTPControlButton | protectedvirtual
OnMouseHover() | CXTPControl | protectedvirtual
OnMouseMove(CPoint point) | CXTPControl | protectedvirtual
OnRButtonDown(CPoint point) | CXTPControl | protectedvirtual
OnRButtonUp(CPoint point) | CXTPControl | protectedvirtual
OnRemoved() | CXTPControl | protectedvirtual
OnSetPopup(BOOL bPopup) | CXTPControl | protectedvirtual
OnSetSelected(int bSelected) | CXTPControl | protectedvirtual
OnThemeChanged() | CXTPControl | virtual
OnToolHitTest(CPoint point, TOOLINFO *pTI) const | CXTPControl | protectedvirtual
OnUnderlineActivate() | CXTPControl | virtual
RedrawParent(BOOL bAnimate=TRUE) | CXTPControl |
Reset() | CXTPControl |
RestoreCommandBarList(CXTPCommandBarList *pCommandBarList) | CXTPControl | protectedvirtual
ScreenToClient(CPoint *point) | CXTPControl | protected
SetAction(CXTPControlAction *pAction) | CXTPControl | virtual
SetBeginGroup(BOOL bBeginGroup) | CXTPControl | virtual
SetCaption(LPCTSTR lpszCaption) | CXTPControl |
SetCaption(UINT nIDCaption) | CXTPControl |
SetCategory(LPCTSTR lpszCategory) | CXTPControl |
SetChecked(BOOL bChecked) | CXTPControl | virtual
SetCloseSubMenuOnClick(BOOL bCloseOnClick) | CXTPControl |
SetCustomIcon(HICON hIcon) | CXTPControl |
SetCustomShortcutText(LPCTSTR lpszCustomShortcutText) | CXTPControl |
SetDescription(LPCTSTR lpszDescription) | CXTPControl |
SetEnabled(BOOL bEnabled) | CXTPControl | virtual
SetExecuteOnPressInterval(int nExecuteOnPressInterval) | CXTPControl |
SetExpanded(BOOL bExpanded) | CXTPControl | protected
SetFlags(DWORD dwFlags) | CXTPControl |
SetFocused(BOOL bFocused) | CXTPControl | virtual
SetHeight(int nHeight) | CXTPControl | virtual
SetHelpId(int nId) | CXTPControl |
SetHideFlag(XTPControlHideFlags dwFlag, BOOL bSet) | CXTPControl |
SetHideFlags(DWORD dwFlags) | CXTPControl | virtual
SetHideWrap(BOOL bHide) | CXTPControl |
SetIconId(int nId) | CXTPControl |
SetIconSize(CSize szIcon) | CXTPControl |
SetID(int nId) | CXTPControl |
SetIndex(int nIndex) | CXTPControl | inlineprotected
SetItemDefault(BOOL bDefault) | CXTPControl |
SetKeyboardTip(LPCTSTR lpszKeyboardTip) | CXTPControl |
SetOnQuickAccess(BOOL bOnQuicAccess=FALSE) | CXTPControl |
SetParameter(LPCTSTR lpszParameter) | CXTPControl |
SetParent(CXTPCommandBar *pParent) | CXTPControl | inlineprotectedvirtual
SetPressed(BOOL bPressed) | CXTPControl |
SetPrompt(LPCTSTR lpszPrompt) | CXTPControl |
SetRect(CRect rcControl) | CXTPControl | virtual
SetRowRect(CRect rcRow) | CXTPControl |
SetShortcutText(LPCTSTR lpszShortcutText) | CXTPControl |
SetStyle(XTPButtonStyle buttonStyle) | CXTPControl |
SetStyleEx(XTPButtonStyle buttonStyle) | CXTPControlButton |
SetTag(DWORD_PTR dwTag) | CXTPControl |
SetTooltip(LPCTSTR lpszTooltip) | CXTPControl |
SetVisible(BOOL bVisible) | CXTPControl |
SetWidth(int nWidth) | CXTPControl | virtual
SetWrap(BOOL bWrap) | CXTPControl |
~CXTPControl() | CXTPControl | protectedvirtual
~CXTPControlButton() | CXTPControlButton | virtual


Toolkit Pro: XTPGridInplaceControls.h Source File

  • Source
  • GridControl
XTPGridInplaceControls.h
Go to the documentation of this file.
1
23#if !defined(__XTPGRIDINPLACECONTROLS_H__)
24# define __XTPGRIDINPLACECONTROLS_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPGridRecord;
34class CXTPGridControl;
35class CXTPGridRecordItem;
36class CXTPGridRecordItemConstraints;
37class CXTPGridRecordItemConstraint;
38
53class _XTP_EXT_CLASS CXTPGridInplaceControl : public XTP_GRIDRECORDITEM_ARGS
54{
55public:
60 CXTPGridInplaceControl();
61
67 virtual ~CXTPGridInplaceControl();
68
69protected:
77 virtual void SetItemArgs(XTP_GRIDRECORDITEM_ARGS* pItemArgs);
78};
79
85class _XTP_EXT_CLASS CXTPGridInplaceEdit
86 : public CXTPMaskEditT<CEdit>
87 , public CXTPGridInplaceControl
88{
90 DECLARE_DYNAMIC(CXTPGridInplaceEdit)
92public:
97 CXTPGridInplaceEdit();
98
104 virtual ~CXTPGridInplaceEdit();
105
106public:
111 void HideWindow();
112
119 CXTPGridRecordItem* GetItem() const;
120
127 void Create(XTP_GRIDRECORDITEM_ARGS* pItemArgs);
128
134 void SetWindowText(LPCTSTR lpszString);
135
136protected:
142 void SetFont(CFont* pFont);
143
144protected:
146 DECLARE_MESSAGE_MAP()
147
148 //{{AFX_VIRTUAL(CXTPGridInplaceControl)
149 virtual BOOL PreTranslateMessage(MSG* pMsg);
150 //}}AFX_VIRTUAL
151
152 //{{AFX_MSG(CXTPGridInplaceControl)
153 afx_msg int OnMouseActivate(CWnd* pDesktopWnd, UINT nHitTest, UINT message);
154 afx_msg void OnEnKillfocus();
155 afx_msg void OnSetFocus(CWnd* pWnd);
156 afx_msg void OnEnChange();
157 afx_msg UINT OnGetDlgCode();
158 afx_msg void OnKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags);
159 afx_msg void OnChar(UINT nChar, UINT nRepCnt, UINT nFlags);
160 afx_msg void OnLButtonDblClk(UINT nFlags, CPoint point);
161 afx_msg void OnSysKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags);
162 afx_msg HBRUSH CtlColor(CDC* pDC, UINT /*nCtlColor*/);
163 //}}AFX_MSG
166private:
167 BOOL Create(LPCTSTR lpszClassName, LPCTSTR lpszWindowName, DWORD dwStyle, const RECT& rect,
168 CWnd* pParentWnd, UINT nID, CCreateContext* pContext = NULL);
169 BOOL Create(DWORD dwStyle, const RECT& rect, CWnd* pParentWnd, UINT nID);
170
171protected:
172 CString m_strValue;
173 CString m_strText_prev;
175 CXTPFont m_xtpFontEdit;
176 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CFont, m_fntEdit, m_xtpFontEdit, GetEditFontHandle);
177
178 CXTPGridRecordItemConstraint* m_pSelectedConstraint;
179 COLORREF m_clrText;
180 COLORREF m_clrBack;
181 CXTPBrush m_xtpBrushBack;
182 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CBrush, m_brBack, m_xtpBrushBack, GetBackBrushHandle);
183 BOOL m_bSetWindowText;
185 // private:
186
187 friend class CXTPGridRecordItem;
188};
189
190AFX_INLINE CXTPGridRecordItem* CXTPGridInplaceEdit::GetItem() const
191{
192 return pItem;
193}
194
195AFX_INLINE BOOL CXTPGridInplaceEdit::Create(LPCTSTR lpszClassName, LPCTSTR lpszWindowName,
196 DWORD dwStyle, const RECT& rect, CWnd* pParentWnd,
197 UINT nID, CCreateContext* pContext)
198{
199 return CWnd::Create(lpszClassName, lpszWindowName, dwStyle, rect, pParentWnd, nID, pContext);
200}
201
202AFX_INLINE BOOL CXTPGridInplaceEdit::Create(DWORD dwStyle, const RECT& rect, CWnd* pParentWnd,
203 UINT nID)
204{
205 return CEdit::Create(dwStyle, rect, pParentWnd, nID);
206}
207
208const UINT XTP_ID_GRID_EXPANDBUTTON = 100;
209const UINT XTP_ID_GRID_COMBOBUTTON = 101;
210const UINT XTP_ID_GRID_SPINBUTTON = 102;
217class _XTP_EXT_CLASS CXTPGridInplaceButton
218 : public CStatic
219 , public CXTPGridInplaceControl
220{
221public:
236 CXTPGridInplaceButton(UINT nID);
237
245 void Create(XTP_GRIDRECORDITEM_ARGS* pItemArgs, CRect& rcButtons);
246
253 int GetID() const;
254
261 BOOL IsPressed() const;
262
269 int GetState() const;
270
277 CXTPGridRecordItem* GetItem() const;
278
285 int GetWidth() const;
286
294 BOOL IsInsideCellButton() const;
295
303 void SetInsideCellButton(BOOL bInsideCell);
304
312 void SetIconIndex(int nIconIndex);
313
322 int GetIconIndex() const;
323
332 int GetSpinButtonMin() const;
333
342 int GetSpinButtonMax() const;
343
352 int GetSpinButtonStep() const;
353
361 void SetSpinButtonMin(int nValue);
362
370 void SetSpinButtonMax(int nValue);
371
379 void SetSpinButtonStep(int nValue);
380
385 void Activate();
386
393 int GetDropListItemNumber() const;
394
400 void SetDropListItemNumber(int nNumber);
401
402protected:
404 DECLARE_MESSAGE_MAP()
405
406 //{{AFX_VIRTUAL(CXTPGridInplaceButton)
407 virtual void OnFinalRelease();
408 //{{AFX_VIRTUAL
409
410 //{{AFX_MSG(CXTPGridInplaceButton)
411 afx_msg void OnPaint();
412 afx_msg void OnLButtonDown(UINT, CPoint point);
413 afx_msg void OnLButtonUp(UINT nFlags, CPoint point);
414 afx_msg void OnLButtonDblClk(UINT, CPoint point);
415 afx_msg void OnMouseMove(UINT nFlags, CPoint point);
416 afx_msg void OnCaptureChanged(CWnd* pWnd);
417 afx_msg void OnTimer(UINT_PTR nIDEvent);
418 //}}AFX_MSG
421# ifdef _XTP_ACTIVEX
423 DECLARE_DISPATCH_MAP()
424 DECLARE_INTERFACE_MAP()
425 XTP_DECLARE_CMDTARGETPROVIDER_INTERFACE()
426
427 DECLARE_OLETYPELIB_EX(CXTPGridInplaceButton);
428 LPDISPATCH OleGetRow();
429 LPDISPATCH OleGetColumn();
430 LPDISPATCH OleGetItem();
431
432 void OleGetRect(long* pnLeft, long* pnTop, long* pnRight, long* pnBottom);
433
435# endif
436
437private:
438 BOOL Create(LPCTSTR lpszClassName, LPCTSTR lpszWindowName, DWORD dwStyle, const RECT& rect,
439 CWnd* pParentWnd, UINT nID, CCreateContext* pContext = NULL);
440 BOOL Create(LPCTSTR lpszText, DWORD dwStyle, const RECT& rect, CWnd* pParentWnd,
441 UINT nID = 0xffff);
442
443protected:
444 int m_nID;
445 int m_nWidth;
446 int m_nFixedHeight;
447 BOOL m_bInsideCell;
448 int m_nIconIndex;
450 BOOL m_bPressed;
451 BOOL m_bOver;
452 int m_nState;
454 int m_nSpinMin;
455 int m_nSpinMax;
456 int m_nSpinStep;
458 UINT_PTR m_unSpinTimerCnt;
459 UINT_PTR m_unSpinTimerId;
460 int m_nSpinIncrement;
462private:
463 int m_Items2Show;
467 friend class CXTPGridRecordItem;
468};
469
470AFX_INLINE int CXTPGridInplaceButton::GetDropListItemNumber() const
471{
472 return m_Items2Show;
473}
474
475AFX_INLINE void CXTPGridInplaceButton::SetDropListItemNumber(int nNumber)
476{
477 _ASSERTE(0 <= nNumber);
478 m_Items2Show = nNumber;
479}
480
481AFX_INLINE int CXTPGridInplaceButton::GetID() const
482{
483 return m_nID;
484}
485AFX_INLINE BOOL CXTPGridInplaceButton::IsPressed() const
486{
487 return m_bPressed && m_bOver;
488}
489AFX_INLINE int CXTPGridInplaceButton::GetState() const
490{
491 return m_bOver ? m_nState : 0;
492}
493AFX_INLINE BOOL CXTPGridInplaceButton::Create(LPCTSTR lpszClassName, LPCTSTR lpszWindowName,
494 DWORD dwStyle, const RECT& rect, CWnd* pParentWnd,
495 UINT nID, CCreateContext* pContext)
496{
497 return CWnd::Create(lpszClassName, lpszWindowName, dwStyle, rect, pParentWnd, nID, pContext);
498}
499AFX_INLINE BOOL CXTPGridInplaceButton::Create(LPCTSTR lpszText, DWORD dwStyle, const RECT& rect,
500 CWnd* pParentWnd, UINT nID)
501{
502 return CStatic::Create(lpszText, dwStyle, rect, pParentWnd, nID);
503}
504AFX_INLINE CXTPGridRecordItem* CXTPGridInplaceButton::GetItem() const
505{
506 return pItem;
507}
508AFX_INLINE void CXTPGridInplaceButton::SetIconIndex(int nIconIndex)
509{
510 m_nIconIndex = nIconIndex;
511}
512AFX_INLINE int CXTPGridInplaceButton::GetIconIndex() const
513{
514 return m_nIconIndex;
515}
516
524class _XTP_EXT_CLASS CXTPGridInplaceList
525 : public CListBox
526 , public CXTPGridInplaceControl
527{
528public:
533 CXTPGridInplaceList();
534
535public:
544 void Create(XTP_GRIDRECORDITEM_ARGS* pItemArgs, CXTPGridRecordItemConstraints* pConstraints);
545
550 void Cancel();
551
556 void Apply();
557
564 int GetDropListItemNumber() const;
565
571 void SetDropListItemNumber(int nNumber);
572
573protected:
575 DECLARE_MESSAGE_MAP()
576
577 //{{AFX_VIRTUAL(CXTPGridInplaceList)
578 virtual BOOL PreTranslateMessage(MSG* pMsg);
579 void PostNcDestroy();
580 //}}AFX_VIRTUAL
581
582 //{{AFX_MSG(CXTPGridInplaceList)
583 afx_msg int OnMouseActivate(CWnd* pDesktopWnd, UINT nHitTest, UINT message);
584 afx_msg UINT OnGetDlgCode();
585 afx_msg void OnKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags);
586 afx_msg void OnChar(UINT nChar, UINT nRepCnt, UINT nFlags);
587 afx_msg void OnSysKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags);
588 afx_msg void OnKillFocus(CWnd* pNewWnd);
589 afx_msg void OnLButtonUp(UINT, CPoint point);
590 afx_msg void OnNcPaint();
591 //}}AFX_MSG
601 virtual void SetItemArgs(XTP_GRIDRECORDITEM_ARGS* pItemArgs);
602
608 virtual void OnSelectionChanged(int nLBIndex);
609
610private:
611 CString m_strHotSearchContext;
612 DWORD m_dwLastKeyDownTime;
613 BOOL m_bApply;
614 int m_Items2Show;
616 BOOL Create(LPCTSTR lpszClassName, LPCTSTR lpszWindowName, DWORD dwStyle, const RECT& rect,
617 CWnd* pParentWnd, UINT nID, CCreateContext* pContext = NULL);
618 BOOL Create(DWORD dwStyle, const RECT& rect, CWnd* pParentWnd, UINT nID);
619};
620
621AFX_INLINE int CXTPGridInplaceList::GetDropListItemNumber() const
622{
623 return m_Items2Show;
624}
625
626AFX_INLINE void CXTPGridInplaceList::SetDropListItemNumber(int nNumber)
627{
628 _ASSERTE(0 <= nNumber);
629 m_Items2Show = nNumber;
630}
631
633
634AFX_INLINE BOOL CXTPGridInplaceList::Create(LPCTSTR lpszClassName, LPCTSTR lpszWindowName,
635 DWORD dwStyle, const RECT& rect, CWnd* pParentWnd,
636 UINT nID, CCreateContext* pContext)
637{
638 return CWnd::Create(lpszClassName, lpszWindowName, dwStyle, rect, pParentWnd, nID, pContext);
639}
640AFX_INLINE BOOL CXTPGridInplaceList::Create(DWORD dwStyle, const RECT& rect, CWnd* pParentWnd,
641 UINT nID)
642{
643 return CListBox::Create(dwStyle, rect, pParentWnd, nID);
644}
645AFX_INLINE int CXTPGridInplaceButton::GetWidth() const
646{
647 return m_nWidth;
648}
649AFX_INLINE BOOL CXTPGridInplaceButton::IsInsideCellButton() const
650{
651 return m_bInsideCell;
652}
653AFX_INLINE void CXTPGridInplaceButton::SetInsideCellButton(BOOL bInsideCell)
654{
655 m_bInsideCell = bInsideCell;
656}
657AFX_INLINE int CXTPGridInplaceButton::GetSpinButtonMin() const
658{
659 return m_nSpinMin;
660}
661AFX_INLINE int CXTPGridInplaceButton::GetSpinButtonMax() const
662{
663 return m_nSpinMax;
664}
665AFX_INLINE int CXTPGridInplaceButton::GetSpinButtonStep() const
666{
667 return m_nSpinStep;
668}
669AFX_INLINE void CXTPGridInplaceButton::SetSpinButtonMin(int nValue)
670{
671 m_nSpinMin = nValue;
672}
673AFX_INLINE void CXTPGridInplaceButton::SetSpinButtonMax(int nValue)
674{
675 m_nSpinMax = nValue;
676}
677AFX_INLINE void CXTPGridInplaceButton::SetSpinButtonStep(int nValue)
678{
679 m_nSpinStep = nValue;
680}
682# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
683#endif // #if !defined(__XTPGRIDINPLACECONTROLS_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTP_DECLARE_CMDTARGETPROVIDER_INTERFACE
#define XTP_DECLARE_CMDTARGETPROVIDER_INTERFACE()
When deriving from CXTPCmdTarget is not possible this macro can be used in addition to standard DECLA...
Definition XTPFramework.h:89
XTP_ID_GRID_SPINBUTTON
const UINT XTP_ID_GRID_SPINBUTTON
Definition XTPGridInplaceControls.h:210
XTP_ID_GRID_COMBOBUTTON
const UINT XTP_ID_GRID_COMBOBUTTON
Definition XTPGridInplaceControls.h:209
XTP_ID_GRID_EXPANDBUTTON
const UINT XTP_ID_GRID_EXPANDBUTTON
Definition XTPGridInplaceControls.h:208
CXTPBrush
Provides a convenient object oriented interface for HBRUSH GDI object and uses GDI handle caching.
Definition XTPGdiObjects.h:653
CXTPFont
Provides a convenient object oriented interface for HFONT GDI object and uses GDI handle caching.
Definition XTPGdiObjects.h:414
CXTPGridControl
The CXTPGridControl class provides an implementation of the Grid control.
Definition XTPGridControl.h:479
CXTPGridInplaceButton
CXTPGridInplaceButton is a CXTPGridInplaceControl derived class that represents a combo button and ex...
Definition XTPGridInplaceControls.h:220
CXTPGridInplaceButton::SetSpinButtonStep
void SetSpinButtonStep(int nValue)
Sets spin button properties.
Definition XTPGridInplaceControls.h:677
CXTPGridInplaceButton::GetDropListItemNumber
int GetDropListItemNumber() const
Gets the number of items to show in the dropdown list.
Definition XTPGridInplaceControls.h:470
CXTPGridInplaceButton::SetSpinButtonMin
void SetSpinButtonMin(int nValue)
Sets spin button properties.
Definition XTPGridInplaceControls.h:669
CXTPGridInplaceButton::GetWidth
int GetWidth() const
Gets the width of the button.
Definition XTPGridInplaceControls.h:645
CXTPGridInplaceButton::IsPressed
BOOL IsPressed() const
Determines if the user pressed the button.
Definition XTPGridInplaceControls.h:485
CXTPGridInplaceButton::m_bInsideCell
BOOL m_bInsideCell
Store button place: inside the cell rect, or outside.
Definition XTPGridInplaceControls.h:447
CXTPGridInplaceButton::GetID
int GetID() const
Gets the identifier of the button.
Definition XTPGridInplaceControls.h:481
CXTPGridInplaceButton::m_nSpinIncrement
int m_nSpinIncrement
Spin button only: increment value.
Definition XTPGridInplaceControls.h:460
CXTPGridInplaceButton::GetSpinButtonMin
int GetSpinButtonMin() const
Gets spin button properties.
Definition XTPGridInplaceControls.h:657
CXTPGridInplaceButton::m_bOver
BOOL m_bOver
TRUE if the mouse cursor is over the button.
Definition XTPGridInplaceControls.h:451
CXTPGridInplaceButton::SetDropListItemNumber
void SetDropListItemNumber(int nNumber)
Sets the number of items to show in the dropdown list.
Definition XTPGridInplaceControls.h:475
CXTPGridInplaceButton::Create
void Create(XTP_GRIDRECORDITEM_ARGS *pItemArgs, CRect &rcButtons)
Creates an in-place button control.
CXTPGridInplaceButton::GetItem
CXTPGridRecordItem * GetItem() const
Gets a child Grid control item.
Definition XTPGridInplaceControls.h:504
CXTPGridInplaceButton::GetState
int GetState() const
Gets the state of the button.
Definition XTPGridInplaceControls.h:489
CXTPGridInplaceButton::m_nState
int m_nState
Button state.
Definition XTPGridInplaceControls.h:452
CXTPGridInplaceButton::GetIconIndex
int GetIconIndex() const
Gets the icon index of the button.
Definition XTPGridInplaceControls.h:512
CXTPGridInplaceButton::m_nWidth
int m_nWidth
Width of the button.
Definition XTPGridInplaceControls.h:445
CXTPGridInplaceButton::GetSpinButtonMax
int GetSpinButtonMax() const
Gets spin button properties.
Definition XTPGridInplaceControls.h:661
CXTPGridInplaceButton::IsInsideCellButton
BOOL IsInsideCellButton() const
Determines if the button is placed inside or outside (near the right cell side) the cell rect.
Definition XTPGridInplaceControls.h:649
CXTPGridInplaceButton::SetInsideCellButton
void SetInsideCellButton(BOOL bInsideCell)
Specifies if the button should be placed inside or outside (near the right cell side) the cell rect.
Definition XTPGridInplaceControls.h:653
CXTPGridInplaceButton::m_nSpinMin
int m_nSpinMin
Spin button only: minimum value.
Definition XTPGridInplaceControls.h:454
CXTPGridInplaceButton::m_nFixedHeight
int m_nFixedHeight
Height of the button.
Definition XTPGridInplaceControls.h:446
CXTPGridInplaceButton::SetSpinButtonMax
void SetSpinButtonMax(int nValue)
Sets spin button properties.
Definition XTPGridInplaceControls.h:673
CXTPGridInplaceButton::m_unSpinTimerCnt
UINT_PTR m_unSpinTimerCnt
Spin button only: timer counter.
Definition XTPGridInplaceControls.h:458
CXTPGridInplaceButton::GetSpinButtonStep
int GetSpinButtonStep() const
Gets spin button properties.
Definition XTPGridInplaceControls.h:665
CXTPGridInplaceButton::SetIconIndex
void SetIconIndex(int nIconIndex)
Sets the icon index for the button.
Definition XTPGridInplaceControls.h:508
CXTPGridInplaceButton::m_nIconIndex
int m_nIconIndex
Icon index.
Definition XTPGridInplaceControls.h:448
CXTPGridInplaceButton::m_nSpinStep
int m_nSpinStep
Spin button only: step value.
Definition XTPGridInplaceControls.h:456
CXTPGridInplaceButton::CXTPGridInplaceButton
CXTPGridInplaceButton(UINT nID)
Constructs a CXTPGridInplaceButton object.
CXTPGridInplaceButton::m_bPressed
BOOL m_bPressed
TRUE if the button is pressed.
Definition XTPGridInplaceControls.h:450
CXTPGridInplaceButton::m_nSpinMax
int m_nSpinMax
Spin button only: maximum value.
Definition XTPGridInplaceControls.h:455
CXTPGridInplaceButton::m_unSpinTimerId
UINT_PTR m_unSpinTimerId
Spin button only: timer identifier.
Definition XTPGridInplaceControls.h:459
CXTPGridInplaceButton::Activate
void Activate()
Call this function to activate the button.
CXTPGridInplaceButton::m_nID
int m_nID
Identifier of the button.
Definition XTPGridInplaceControls.h:444
CXTPGridInplaceControl
CXTPGridInplaceControl is the base class for all in-place controls of the Grid control item.
Definition XTPGridInplaceControls.h:54
CXTPGridInplaceControl::SetItemArgs
virtual void SetItemArgs(XTP_GRIDRECORDITEM_ARGS *pItemArgs)
This method is called internally to fill the item arguments of an in-place control.
CXTPGridInplaceControl::CXTPGridInplaceControl
CXTPGridInplaceControl()
Constructs a CXTPGridInplaceControl object.
CXTPGridInplaceControl::~CXTPGridInplaceControl
virtual ~CXTPGridInplaceControl()
Destroys a CXTPGridInplaceControl object, handles cleanup and deallocation.
CXTPGridInplaceEdit
CXTPGridInplaceEdit is a CXTPGridInplaceControl derived class that represents an edit control to allo...
Definition XTPGridInplaceControls.h:88
CXTPGridInplaceEdit::SetWindowText
void SetWindowText(LPCTSTR lpszString)
Sets edit text.
CXTPGridInplaceEdit::SetFont
void SetFont(CFont *pFont)
Sets the font of the in-place edit control.
CXTPGridInplaceEdit::~CXTPGridInplaceEdit
virtual ~CXTPGridInplaceEdit()
Destroys a CXTPGridInplaceEdit object, handles cleanup and deallocation.
CXTPGridInplaceEdit::HideWindow
void HideWindow()
Hides the in-place edit control.
CXTPGridInplaceEdit::Create
void Create(XTP_GRIDRECORDITEM_ARGS *pItemArgs)
Creates an in-place edit control.
CXTPGridInplaceEdit::CXTPGridInplaceEdit
CXTPGridInplaceEdit()
Constructs a CXTPGridInplaceEdit object.
CXTPGridInplaceList
CXTPGridInplaceList is a CXTPGridInplaceControl derived class that represents a list box with item co...
Definition XTPGridInplaceControls.h:527
CXTPGridInplaceList::SetDropListItemNumber
void SetDropListItemNumber(int nNumber)
Sets the number of items to show in the dropdown list.
Definition XTPGridInplaceControls.h:626
CXTPGridInplaceList::Create
void Create(XTP_GRIDRECORDITEM_ARGS *pItemArgs, CXTPGridRecordItemConstraints *pConstraints)
Creates an in-place list control.
CXTPGridInplaceList::CXTPGridInplaceList
CXTPGridInplaceList()
Constructs a CXTPGridInplaceList object.
CXTPGridInplaceList::Apply
void Apply()
Saves the selected value of the list box.
CXTPGridInplaceList::Cancel
void Cancel()
Cancels the user selection.
CXTPGridRecord
CXTPGridRecord represents a collection of CXTPGridRecordItem objects or objects of classes that are c...
Definition XTPGridRecord.h:59
CXTPGridRecordItemConstraint
CXTPGridRecordItemConstraint is a CXTPCmdTarget derived class.
Definition XTPGridRecordItemConstraint.h:39
CXTPGridRecordItemConstraints
CXTPGridRecordItemConstraints is a CXTPCmdTarget derived class.
Definition XTPGridRecordItemConstraint.h:85
CXTPGridRecordItem
Class for working with single list cell.
Definition XTPGridRecordItem.h:600
CXTPMaskEditT
CXTPMaskEditT is a template class.
Definition XTPMaskEditT.h:45
XTP_GRIDRECORDITEM_ARGS
Basic set of parameters transferred to item handlers.
Definition XTPGridRecordItem.h:69
XTP_GRIDRECORDITEM_ARGS::pItem
CXTPGridRecordItem * pItem
Pointer to the associated item.
Definition XTPGridRecordItem.h:100


Toolkit Pro: XTPControlScrollBar.h Source File

  • Source
  • CommandBars
XTPControlScrollBar.h
Go to the documentation of this file.
1
23#if !defined(__XTPCONTROLSCROLLBAR_H__)
24# define __XTPCONTROLSCROLLBAR_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPControlScrollBar;
34
40class _XTP_EXT_CLASS CXTPControlScrollBar
41 : public CXTPControl
42 , public CXTPScrollBase
43{
45 DECLARE_XTP_CONTROL(CXTPControlScrollBar)
47public:
52 CXTPControlScrollBar();
53
58 virtual ~CXTPControlScrollBar();
59
60public:
68 void SetPos(int nPos);
69
78 int GetPos() const;
79
88 void SetRange(int nMin, int nMax);
89
90protected:
97 virtual void OnScroll(UINT nSBCode, UINT nPos);
98
99protected:
101 CSize GetSize(CDC* pDC);
102 BOOL HasFocus() const;
103 void Draw(CDC* pDC);
104 void OnCalcDynamicSize(DWORD dwMode);
105 void OnClick(BOOL bKeyboard = FALSE, CPoint pt = CPoint(0, 0));
106 virtual int GetCustomizeMinWidth() const;
107 virtual BOOL IsCustomizeResizeAllow() const;
108 void Copy(CXTPControl* pControl, BOOL bRecursive = FALSE);
109 void DoPropExchange(CXTPPropExchange* pPX);
110 void OnMouseMove(CPoint point);
113protected:
115 virtual CRect GetScrollBarRect();
116 virtual void GetScrollInfo(SCROLLINFO* psi);
117 virtual void DoScroll(int cmd, int pos);
118 virtual void RedrawScrollBar();
119 virtual CXTPScrollBarPaintManager* GetScrollBarPaintManager() const;
120 virtual BOOL IsScrollBarEnabled() const;
121 virtual CWnd* GetParentWindow() const;
124protected:
125 int m_nMin;
126 int m_nMax;
127 int m_nPos;
128 int m_nPage;
130 BOOL m_bInScroll;
131
132# ifdef _XTP_COMMANDBARS_ACTIVEX
135 DECLARE_DISPATCH_MAP()
136 DECLARE_INTERFACE_MAP()
137
138 DECLARE_OLETYPELIB_EX(CXTPControlSlider);
139 void OleRangeChanged();
141# endif
142
143 friend class CXTPControlScrollBarCtrl;
144};
146AFX_INLINE BOOL CXTPControlScrollBar::IsCustomizeResizeAllow() const
147{
148 return TRUE;
149}
150AFX_INLINE int CXTPControlScrollBar::GetCustomizeMinWidth() const
151{
152 return 20;
153}
156# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
157#endif // !defined(__XTPCONTROLSCROLLBAR_H__)
DECLARE_XTP_CONTROL
#define DECLARE_XTP_CONTROL(class_name)
This macro generates the C++ header code necessary for a CXTPControl-derived class that can be serial...
Definition XTPCommandBarsDefines.h:1169
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPControl
CXTPControl is a CXTPCmdTarget derived class.
Definition XTPControl.h:841
CXTPControl::IsCustomizeResizeAllow
virtual BOOL IsCustomizeResizeAllow() const
This member checks if the user can resize the control.
CXTPControl::DoPropExchange
virtual void DoPropExchange(CXTPPropExchange *pPX)
Either reads this object from or writes this object to an archive.
CXTPControl::OnCalcDynamicSize
virtual void OnCalcDynamicSize(DWORD dwMode)
This method is called before recalculating the parent command bar size to calculate the dimensions of...
Definition XTPControl.h:2759
CXTPControl::Draw
virtual void Draw(CDC *pDC)
This method is called to draw the control.
CXTPControl::OnClick
virtual void OnClick(BOOL bKeyboard=FALSE, CPoint pt=CPoint(0, 0))
This method is called when the user clicks the control.
Definition XTPControl.h:2678
CXTPControl::OnMouseMove
virtual void OnMouseMove(CPoint point)
This member is called when the mouse cursor moves.
Definition XTPControl.h:2745
CXTPControl::GetCustomizeMinWidth
virtual int GetCustomizeMinWidth() const
Retrieves the available minimum width of control.
Definition XTPControl.h:2702
CXTPControl::GetSize
virtual CSize GetSize(CDC *pDC)
This method is called to determine the size of the control.
CXTPControl::Copy
virtual void Copy(CXTPControl *pControl, BOOL bRecursive=FALSE)
This method is called to copy the control.
CXTPControlScrollBar
CXTPControlScrollBar is a CXTPControl derived class.
Definition XTPControlScrollBar.h:43
CXTPControlScrollBar::SetPos
void SetPos(int nPos)
Call this member function to set the current position of the scrollbar.
CXTPControlScrollBar::CXTPControlScrollBar
CXTPControlScrollBar()
Constructs a CXTPControlScrollBar object.
CXTPControlScrollBar::OnScroll
virtual void OnScroll(UINT nSBCode, UINT nPos)
This method is called when the position of the scrollbar is changed.
CXTPControlScrollBar::m_nMin
int m_nMin
Lower range.
Definition XTPControlScrollBar.h:125
CXTPControlScrollBar::m_nPage
int m_nPage
Current page of the scrollbar.
Definition XTPControlScrollBar.h:128
CXTPControlScrollBar::m_nPos
int m_nPos
Current position of scrollbar.
Definition XTPControlScrollBar.h:127
CXTPControlScrollBar::m_nMax
int m_nMax
Upper range.
Definition XTPControlScrollBar.h:126
CXTPControlScrollBar::GetPos
int GetPos() const
Call this member function to get the current position of the scrollbar.
CXTPControlScrollBar::SetRange
void SetRange(int nMin, int nMax)
Sets the upper and lower limits of the scrollbar control's range.
CXTPControlScrollBar::~CXTPControlScrollBar
virtual ~CXTPControlScrollBar()
Destroys a CXTPControlScrollBar object, handles cleanup and deallocation.
CXTPControlSlider
CXTPControlSlider is a CXTPControl derived class.
Definition XTPControlSlider.h:71
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72
CXTPScrollBarPaintManager
CXTPScrollBarPaintManager is standalone class used to draw CXTPCommandBarScrollBarCtrl object.
Definition XTPScrollBarPaintManager.h:40
CXTPScrollBase
CXTPScrollBase is the base class for all scrollable objects.
Definition XTPScrollBase.h:222
CXTPScrollBase::GetScrollBarPaintManager
virtual CXTPScrollBarPaintManager * GetScrollBarPaintManager() const =0
Obtains a pointer to the associated scrollbar paint manager.
CXTPScrollBase::GetParentWindow
virtual CWnd * GetParentWindow() const =0
Retrieves parent window of scrollbar.
CXTPScrollBase::GetScrollInfo
virtual void GetScrollInfo(SCROLLINFO *psi)=0
The GetScrollInfo function retrieves the parameters of a scroll bar, including the minimum and maximu...
CXTPScrollBase::GetScrollBarRect
virtual CRect GetScrollBarRect()=0
Obtains the rectangle occupied by the scrollbar in client coordinates.
CXTPScrollBase::IsScrollBarEnabled
virtual BOOL IsScrollBarEnabled() const =0
Determines if the scrollbar is enabled.
CXTPScrollBase::RedrawScrollBar
virtual void RedrawScrollBar()=0
Forces the scrollbar to redraw itself.


Toolkit Pro: XTPChartDeviceContext.h Source File

  • Source
  • Chart
  • Drawing
XTPChartDeviceContext.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTDEVICECONTEXT_H__)
24# define __XTPCHARTDEVICECONTEXT_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartContainer;
34class CXTPChartDeviceCommand;
35class CXTPMarkupUIElement;
36class CXTPChartFont;
37class CXTPChartDrawingObjectFactory;
38class CXTPOpenGLTriangleRenderList;
39
47class _XTP_EXT_CLASS CXTPChartDeviceContext : public CXTPCmdTarget
48{
49 DECLARE_DYNAMIC(CXTPChartDeviceContext);
50
51protected:
64 CXTPChartDeviceContext(CXTPChartContainer* pContainer, HDC hDC, BOOL bIs3D,
65 CXTPChartDrawingObjectFactory* pDrawingObjectFactory);
66
67public:
72 virtual ~CXTPChartDeviceContext() = 0;
73
80 virtual BOOL Initialize();
81
88 virtual void Execute(CXTPChartDeviceCommand* pCommand);
89
96 BOOL Is3D() const;
97
104 HDC GetHDC() const;
105
112 CXTPChartContainer* GetContainer() const;
113
121 CXTPChartDrawingObjectFactory* GetDrawingObjectFactory() const;
122
132 virtual CXTPChartSizeF MeasureString(const CXTPChartString* pText, CXTPChartFont* pFont) = 0;
133
144 virtual CXTPChartSizeF MeasureMarkupElement(CXTPMarkupUIElement* pMarkupUIElement,
145 CXTPChartFont* pFont) = 0;
146
147protected:
148 const BOOL m_bIs3D;
149 HDC m_hDC;
150 CXTPChartContainer* m_pContainer;
151 CXTPChartDrawingObjectFactory* m_pDrawingObjectFactory;
152};
153
154AFX_INLINE BOOL CXTPChartDeviceContext::Is3D() const
155{
156 return m_bIs3D;
157}
158
159AFX_INLINE HDC CXTPChartDeviceContext::GetHDC() const
160{
161 return m_hDC;
162}
163
164AFX_INLINE CXTPChartContainer* CXTPChartDeviceContext::GetContainer() const
165{
166 return m_pContainer;
167}
168
169AFX_INLINE CXTPChartDrawingObjectFactory* CXTPChartDeviceContext::GetDrawingObjectFactory() const
170{
171 return m_pDrawingObjectFactory;
172}
174# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
175#endif //#if !defined(__XTPCHARTDEVICECONTEXT_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartContainer
This class represents the chart container.
Definition XTPChartElement.h:232
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartDeviceContext::MeasureMarkupElement
virtual CXTPChartSizeF MeasureMarkupElement(CXTPMarkupUIElement *pMarkupUIElement, CXTPChartFont *pFont)=0
Measures the markup element size provided with the font set as the default font for the associated ma...
CXTPChartDeviceContext::GetDrawingObjectFactory
CXTPChartDrawingObjectFactory * GetDrawingObjectFactory() const
Provides access to the drawing object factory used by the device context implementation.
Definition XTPChartDeviceContext.h:169
CXTPChartDeviceContext::~CXTPChartDeviceContext
virtual ~CXTPChartDeviceContext()=0
Destroys a CXTPChartDeviceContext object, handles cleanup.
CXTPChartDeviceContext::CXTPChartDeviceContext
CXTPChartDeviceContext(CXTPChartContainer *pContainer, HDC hDC, BOOL bIs3D, CXTPChartDrawingObjectFactory *pDrawingObjectFactory)
Constructs a CXTPChartDeviceContext object.
CXTPChartDeviceContext::Execute
virtual void Execute(CXTPChartDeviceCommand *pCommand)
Call this function to trigger the drawing.
CXTPChartDeviceContext::Initialize
virtual BOOL Initialize()
Initializes devices context.
CXTPChartDeviceContext::m_pDrawingObjectFactory
CXTPChartDrawingObjectFactory * m_pDrawingObjectFactory
Drawing object factory pointer.
Definition XTPChartDeviceContext.h:151
CXTPChartDeviceContext::m_pContainer
CXTPChartContainer * m_pContainer
Parent container pointer.
Definition XTPChartDeviceContext.h:150
CXTPChartDeviceContext::GetContainer
CXTPChartContainer * GetContainer() const
Provides access to the parent container object.
Definition XTPChartDeviceContext.h:164
CXTPChartDeviceContext::MeasureString
virtual CXTPChartSizeF MeasureString(const CXTPChartString *pText, CXTPChartFont *pFont)=0
Call this function to get the measurements of texts rendered in a device context using a specific fon...
CXTPChartDeviceContext::m_bIs3D
const BOOL m_bIs3D
TRUE identifies device context used for 3D rendering.
Definition XTPChartDeviceContext.h:148
CXTPChartDeviceContext::Is3D
BOOL Is3D() const
Determines if the derived device context is a 3D device context.
Definition XTPChartDeviceContext.h:154
CXTPChartDeviceContext::GetHDC
HDC GetHDC() const
Call this function to get the windows device context.
Definition XTPChartDeviceContext.h:159
CXTPChartDeviceContext::m_hDC
HDC m_hDC
The windows device context.
Definition XTPChartDeviceContext.h:149
CXTPChartDrawingObjectFactory
Provides a set of factory methods for creating drawing device commands and a base class interface for...
Definition XTPChartDrawingObjectFactory.h:55
CXTPChartFont
This class abstracts a font entity.
Definition XTPChartTypes.h:540
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPMarkupUIElement
Base class for XML Markup core level implementations.
Definition XTPMarkupUIElement.h:43
CXTPSizeT
This class incapsulates size data.
Definition XTPSize.h:40


Toolkit Pro: Member List

CXTPRibbonPaintManager Member List

This is the complete list of members for CXTPRibbonPaintManager, including all inherited members.

CreateTabPaintManager() | CXTPRibbonPaintManager | protectedvirtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPRibbonPaintManager(CXTPPaintManager *pPaintManager) | CXTPRibbonPaintManager |
DrawControlGroupOption(CDC *pDC, CXTPControl *pControlGroupOption, BOOL bDraw)=0 | CXTPRibbonPaintManager | pure virtual
DrawControlGroupPopup(CDC *pDC, CXTPControlPopup *pControlGroupPopup, BOOL bDraw)=0 | CXTPRibbonPaintManager | pure virtual
DrawDwmCaptionText(CDC *pDC, CRect rcCaptionText, CString strText, CWnd *pSite, BOOL bActive) | CXTPRibbonPaintManager | protected
DrawGroup(CDC *pDC, CXTPRibbonGroup *pGroup)=0 | CXTPRibbonPaintManager | pure virtual
DrawQuickAccessControl(CDC *pDC, CXTPRibbonBar *pRibbon, CXTPControl *pControl) | CXTPRibbonPaintManager | virtual
DrawRibbonApplicationIcon(CDC *pDC, CXTPRibbonBar *pRibbonBar, CRect rc, HICON hIcon) | CXTPRibbonPaintManager | protected
DrawRibbonFrameCaption(CDC *pDC, CXTPRibbonBar *pRibbonBar, BOOL bActive)=0 | CXTPRibbonPaintManager | pure virtual
DrawRibbonFrameCaptionBar(CDC *pDC, CXTPRibbonBar *pRibbonBar, BOOL bActive)=0 | CXTPRibbonPaintManager | pure virtual
DrawRibbonFrameContextHeaders(CDC *pDC, CXTPRibbonBar *pRibbonBar, CXTPRibbonTabContextHeaders *pContextHeaders)=0 | CXTPRibbonPaintManager | pure virtual
DrawRibbonFramePart(CDC *pDC, CXTPRibbonBar *pRibbonBar) | CXTPRibbonPaintManager | virtual
DrawRibbonFrameSystemButton(CDC *pDC, CXTPRibbonControlSystemButton *pControl, CRect rc)=0 | CXTPRibbonPaintManager | pure virtual
DrawRibbonGroupControlEntry(CDC *pDC, CXTPControl *pButton)=0 | CXTPRibbonPaintManager | pure virtual
DrawRibbonGroupPopupToolBar(CDC *pDC, CXTPRibbonGroup *pRibbonGroup) | CXTPRibbonPaintManager | virtual
DrawRibbonQuickAccessButton(CDC *pDC, CXTPControlPopup *pControl)=0 | CXTPRibbonPaintManager | pure virtual
DrawRibbonQuickAccessMoreButton(CDC *pDC, CXTPControlPopup *pControl)=0 | CXTPRibbonPaintManager | pure virtual
DrawRibbonScrollButton(CDC *pDC, CXTPControl *pControl, BOOL bScrollLeft)=0 | CXTPRibbonPaintManager | pure virtual
DrawRibbonTab(CDC *pDC, CXTPRibbonTab *pItem)=0 | CXTPRibbonPaintManager | pure virtual
DrawSystemPopupBarButton(CDC *pDC, CXTPControl *pButton)=0 | CXTPRibbonPaintManager | pure virtual
FillGroupPopupToolBar(CDC *pDC, CXTPRibbonGroup *pGroup, CXTPCommandBar *pCommandBar)=0 | CXTPRibbonPaintManager | pure virtual
FillGroupRect(CDC *pDC, CXTPRibbonTab *pActiveTab, CRect rcGroups)=0 | CXTPRibbonPaintManager | pure virtual
FillMorePopupToolBarEntry(CDC *pDC, CXTPCommandBar *pBar)=0 | CXTPRibbonPaintManager | pure virtual
FillRibbonBar(CDC *pDC, CXTPRibbonBar *pRibbonBar)=0 | CXTPRibbonPaintManager | pure virtual
FillRibbonTabControl(CDC *pDC, CXTPRibbonBar *pRibbonBar, CRect rcControl)=0 | CXTPRibbonPaintManager | pure virtual
FillSystemPopupBarEntry(CDC *pDC, CXTPPopupBar *pBar)=0 | CXTPRibbonPaintManager | pure virtual
FillTabPopupToolBar(CDC *pDC, CXTPPopupToolBar *pPopupToolBar) | CXTPRibbonPaintManager | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetControlGroupOptionSize() const =0 | CXTPRibbonPaintManager | pure virtual
GetEditHeight() const | CXTPRibbonPaintManager |
GetFontHeight() const | CXTPRibbonPaintManager |
GetFramePaintManager() const | CXTPRibbonPaintManager |
GetGroupCaptionHeight() const | CXTPRibbonPaintManager |
GetImages() const | CXTPRibbonPaintManager |
GetRibbonCaptionHeight(const CXTPRibbonBar *pRibbonBar) const =0 | CXTPRibbonPaintManager | pure virtual
GetTabPaintManager() const | CXTPRibbonPaintManager |
LoadImage(LPCTSTR lpszFileName) | CXTPRibbonPaintManager |
m_bFlatFrame | CXTPRibbonPaintManager |
m_bHotTrackingGroups | CXTPRibbonPaintManager |
m_clrFileButtonText | CXTPRibbonPaintManager | protected
m_clrMinimizedFrameEdgeHighLight | CXTPRibbonPaintManager | protected
m_clrMinimizedFrameEdgeShadow | CXTPRibbonPaintManager | protected
m_clrRecentFileListEdgeHighLight | CXTPRibbonPaintManager |
m_clrRecentFileListEdgeShadow | CXTPRibbonPaintManager |
m_clrRibbonBorder | CXTPRibbonPaintManager | protected
m_clrRibbonFace | CXTPRibbonPaintManager | protected
m_clrRibbonGroupCaptionText | CXTPRibbonPaintManager | protected
m_clrRibbonInactiveFace | CXTPRibbonPaintManager | protected
m_fontGroupCaption | CXTPRibbonPaintManager |
m_nGroupCaptionHeight | CXTPRibbonPaintManager |
m_nGroupSpacing | CXTPRibbonPaintManager |
m_nTabsHeight | CXTPRibbonPaintManager |
m_pPaintManager | CXTPRibbonPaintManager | protected
m_pTabPaintManager | CXTPRibbonPaintManager | protected
m_rcFileButtonMargin | CXTPRibbonPaintManager | protected
RefreshMetrics() | CXTPRibbonPaintManager | virtual
SetFontHeight(int nFontHeight) | CXTPRibbonPaintManager |
~CXTPRibbonPaintManager() | CXTPRibbonPaintManager | virtual


Toolkit Pro: Member List

CXTPChartPalette Member List

This is the complete list of members for CXTPChartPalette, including all inherited members.

CXTPChartElement() | CXTPChartElement |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartPalette(CXTPChartElement *pOwner) | CXTPChartPalette |
DoPropExchange(CXTPPropExchange *pPX) | CXTPChartPalette | virtual
GetAppearance() const | CXTPChartElement |
GetColor(int nIndex) const | CXTPChartPalette |
GetColor2(int nIndex) const | CXTPChartPalette |
GetContent() const | CXTPChartElement |
GetCount() const | CXTPChartPalette |
GetEntries() | CXTPChartPalette |
GetOwner() const | CXTPChartElement |
Is3D() const | CXTPChartObject |
m_arrEntries | CXTPChartPalette | protected
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartElement | virtual
Release() | CXTPChartElement | virtual
~CXTPChartElement() | CXTPChartElement | virtual
~CXTPChartPalette() | CXTPChartPalette | virtual


Toolkit Pro: Member List

CXTPCalendarPageSetupDialog Member List

This is the complete list of members for CXTPCalendarPageSetupDialog, including all inherited members.

CXTPCalendarPageSetupDialog(CXTPCalendarControlViewPrintOptions *pOptions, DWORD dwFlags=PSD_MARGINS|PSD_INWININIINTLMEASURE, CWnd *pParentWnd=NULL) | CXTPCalendarPageSetupDialog |
FormatFontName(const LOGFONT &lfFont) | CXTPCalendarPageSetupDialog | protected
m_ctrl3SmallCal | CXTPCalendarPageSetupDialog | protected
m_ctrlBlackWhitePrinting | CXTPCalendarPageSetupDialog | protected
m_ctrlDateHeaderFont | CXTPCalendarPageSetupDialog | protected
m_ctrlDateHeaderFontButton | CXTPCalendarPageSetupDialog | protected
m_ctrlDateHeaderFontLabel | CXTPCalendarPageSetupDialog | protected
m_ctrlFooterFormat | CXTPCalendarPageSetupDialog | protected
m_ctrlFooterFormatBtn | CXTPCalendarPageSetupDialog | protected
m_ctrlHeaderFormat | CXTPCalendarPageSetupDialog | protected
m_ctrlHeaderFormatBtn | CXTPCalendarPageSetupDialog | protected
m_ctrlMonthViewPrintFrom | CXTPCalendarPageSetupDialog | protected
m_ctrlMonthViewPrintRange | CXTPCalendarPageSetupDialog | protected
m_ctrlMonthViewPrintTo | CXTPCalendarPageSetupDialog | protected
m_ctrlPrintDateHeader | CXTPCalendarPageSetupDialog | protected
m_ctrlPrintFromCmb | CXTPCalendarPageSetupDialog | protected
m_ctrlPrintFromTo | CXTPCalendarPageSetupDialog | protected
m_ctrlPrintToCmb | CXTPCalendarPageSetupDialog | protected
m_lfDateHeader | CXTPCalendarPageSetupDialog | protected
m_pOptions | CXTPCalendarPageSetupDialog | protected
OnBnClickedDateHeaderFont() | CXTPCalendarPageSetupDialog | protected
OnBnClickedPrintDateHeader() | CXTPCalendarPageSetupDialog | protected
OnInitDialog() | CXTPCalendarPageSetupDialog | protectedvirtual
OnOK() | CXTPCalendarPageSetupDialog | protectedvirtual
~CXTPCalendarPageSetupDialog() | CXTPCalendarPageSetupDialog | virtual


Toolkit Pro: Member List

CXTPCalendarDatabaseDataProvider Member List

This is the complete list of members for CXTPCalendarDatabaseDataProvider, including all inherited members.

AddEvent(CXTPCalendarEvent *pEvent) | CXTPCalendarData | virtual
AddEventCategory(UINT uID, CString strName, COLORREF crBorder, COLORREF crBkBase) | CXTPCalendarData | virtual
AddEventLabel(int nID, CString strName, COLORREF crLabel) | CXTPCalendarData | virtual
AddEvents(CXTPCalendarEvents *pEvents) | CXTPCalendarData | virtual
ChangeEvent(CXTPCalendarEvent *pNewEvent) | CXTPCalendarData | virtual
ClearCache() | CXTPCalendarData | virtual
ClearEventCategoryList() | CXTPCalendarData | virtual
ClearEventLabelList() | CXTPCalendarData | virtual
Close() | CXTPCalendarDatabaseDataProvider | virtual
Create() | CXTPCalendarDatabaseDataProvider | virtual
CreateDataProvider(LPCTSTR lpszConnectionString) | CXTPCalendarData | static
CreateDataProvider(XTPCalendarDataProvider eDataProvider) | CXTPCalendarData | static
CreateNewEvent(DWORD dwEventID=XTP_CALENDAR_UNKNOWN_EVENT_ID) | CXTPCalendarData | virtual
CreateNewRecurrencePattern(DWORD dwPatternID=XTP_CALENDAR_UNKNOWN_RECURRENCE_PATTERN_ID) | CXTPCalendarData | virtual
CXTPCalendarData() | CXTPCalendarData |
CXTPCalendarDatabaseDataProvider() | CXTPCalendarDatabaseDataProvider |
CXTPCmdTarget() | CXTPCmdTarget |
DataProviderTypeFromConStr(LPCTSTR lpszConnectionString, XTPCalendarDataProvider eDPDefault=xtpCalendarDataProviderUnknown) | CXTPCalendarData | static
DataSourceFromConStr(LPCTSTR lpszConnectionString) | CXTPCalendarData | static
DeleteEvent(CXTPCalendarEvent *pEvent) | CXTPCalendarData | virtual
DoCreate_Event(CXTPCalendarEvent *pEvent, DWORD &rdwNewEventID) | CXTPCalendarDatabaseDataProvider | protectedvirtual
DoCreate_RPattern(CXTPCalendarRecurrencePattern *pPattern, DWORD &rdwNewPatternID) | CXTPCalendarDatabaseDataProvider | protectedvirtual
DoDelete_Event(CXTPCalendarEvent *pEvent) | CXTPCalendarDatabaseDataProvider | protectedvirtual
DoDelete_RPattern(CXTPCalendarRecurrencePattern *pPattern) | CXTPCalendarDatabaseDataProvider | protectedvirtual
DoGetAllEvents_raw() | CXTPCalendarDatabaseDataProvider | protectedvirtual
DoGetUpcomingEvents(COleDateTime dtFrom, COleDateTimeSpan spPeriod) | CXTPCalendarDatabaseDataProvider | protectedvirtual
DoRead_Event(DWORD dwEventID) | CXTPCalendarDatabaseDataProvider | protectedvirtual
DoRead_RPattern(DWORD dwPatternID) | CXTPCalendarDatabaseDataProvider | protectedvirtual
DoRemoveAllEvents() | CXTPCalendarDatabaseDataProvider | protectedvirtual
DoRetrieveDayEvents(COleDateTime dtDay) | CXTPCalendarDatabaseDataProvider | protectedvirtual
DoUpdate_Event(CXTPCalendarEvent *pEvent) | CXTPCalendarDatabaseDataProvider | protectedvirtual
DoUpdate_RPattern(CXTPCalendarRecurrencePattern *pPattern) | CXTPCalendarDatabaseDataProvider | protectedvirtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAllEvents_raw() | CXTPCalendarData | virtual
GetCacheMode() const | CXTPCalendarData | virtual
GetConnection() const | CXTPCalendarData | virtual
GetConnectionString() const | CXTPCalendarData | virtual
GetCustomProperties() const | CXTPCalendarData | virtual
GetDataSource() | CXTPCalendarData | virtual
GetEvent(DWORD dwEventID) | CXTPCalendarData | virtual
GetEventCategories() const | CXTPCalendarData | virtual
GetLabelList() const | CXTPCalendarData | virtual
GetNextFreeTempID() | CXTPCalendarData | protectedstatic
GetRecurrencePattern(DWORD dwPatternID) | CXTPCalendarData | virtual
GetSchedules() const | CXTPCalendarData | virtual
GetType() const | CXTPCalendarData | virtual
GetUpcomingEvents(COleDateTime dtFrom=(DATE) 0, COleDateTimeSpan spPeriod=(DATE) 0) | CXTPCalendarData | virtual
IsOpen() const | CXTPCalendarData | virtual
m_bDisableNotificationsSending | CXTPCalendarData | protected
m_bOpened | CXTPCalendarData | protected
m_pCalendarOptions | CXTPCalendarData | protected
m_pConnection | CXTPCalendarData | protected
m_pCustomProperties | CXTPCalendarData | protected
m_pEventCategories | CXTPCalendarData | protected
m_pLabelList | CXTPCalendarData | protected
m_pSchedules | CXTPCalendarData | protected
m_strConnectionString | CXTPCalendarData | protected
m_typeProvider | CXTPCalendarData | protected
ms_dwNextFreeTempID | CXTPCalendarData | protectedstatic
OnTimeZoneChanged() | CXTPCalendarData | inlineprotectedvirtual
Open() | CXTPCalendarDatabaseDataProvider | virtual
OpenEx(LPDISPATCH pdispADOConnection) | CXTPCalendarDatabaseDataProvider | virtual
RemoveAllEvents() | CXTPCalendarData | virtual
RestoreEventCategoryList() | CXTPCalendarData | virtual
RestoreEventLabelList() | CXTPCalendarData | virtual
RetrieveDayEvents(COleDateTime dtDay) | CXTPCalendarData | virtual
Save() | CXTPCalendarDatabaseDataProvider | virtual
SendNotification(XTP_NOTIFY_CODE EventCode, WPARAM wParam, LPARAM lParam) | CXTPCalendarData | protectedvirtual
SetCacheMode(int eCacheMode, CXTPCalendarData *pCacheDataProvider=NULL) | CXTPCalendarData | virtual
SetConnectionString(LPCTSTR lpszConnectionString) | CXTPCalendarData | virtual
SetLabelList(CXTPCalendarEventLabels *pLabelList) | CXTPCalendarData | virtual
UpdateEventCategories(COLORREF *pClrBkBase, COLORREF *pClrBorder, int nCount) | CXTPCalendarData |
UpdateEventLabels(COLORREF *clrEventColors, UINT uCount) | CXTPCalendarData | virtual
~CXTPCalendarData() | CXTPCalendarData | virtual
~CXTPCalendarDatabaseDataProvider() | CXTPCalendarDatabaseDataProvider | virtual


Toolkit Pro: Member List

CXTPMarkupColumnDefinition Member List

This is the complete list of members for CXTPMarkupColumnDefinition, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPMarkupColumnDefinition() | CXTPMarkupColumnDefinition |
CXTPMarkupDefinitionBase(BOOL bIsColumnDefinition=FALSE) | CXTPMarkupDefinitionBase | protected
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetUserMaxSize() const | CXTPMarkupDefinitionBase |
GetUserMinSize() const | CXTPMarkupDefinitionBase |
GetUserSize() const | CXTPMarkupDefinitionBase |
SetMaxWidth(int nWidth) | CXTPMarkupColumnDefinition |
SetMinWidth(int nWidth) | CXTPMarkupColumnDefinition |
SetWidth(int nWidth) | CXTPMarkupColumnDefinition |
SetWidth(CXTPMarkupGridLength *pLength) | CXTPMarkupColumnDefinition |


Toolkit Pro: XTPComboBoxThemeVisualStudio2012.h Source File

  • Source
  • Controls
  • Combo
  • Themes
XTPComboBoxThemeVisualStudio2012.h
Go to the documentation of this file.
1
23#ifndef XTPComboBoxThemeVisualStudio2012_h__
24# define XTPComboBoxThemeVisualStudio2012_h__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPComboBoxThemeVisualStudio2012 : public CXTPComboBoxThemeVisualStudio
39{
40public:
46 CXTPComboBoxThemeVisualStudio2012(BOOL bLight);
47
52 virtual ~CXTPComboBoxThemeVisualStudio2012();
53
60 virtual void RefreshMetrics(CXTPComboBox* pComboBox);
61
70 virtual void DrawButton(CDC* pDC, CXTPComboBox* pComboBox, CRect rcBtn);
71
72 BOOL m_bLight;
73};
74
75# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
77#endif // XTPComboBoxThemeVisualStudio2012_h__
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPComboBox
The CXTPComboBox class provides the functionality of a themed Windows combobox.
Definition XTPComboBox.h:42
CXTPComboBoxThemeVisualStudio2012
Used as the paint manager for a combobox control to render a Visual Studio 2012 appearance.
Definition XTPComboBoxThemeVisualStudio2012.h:39
CXTPComboBoxThemeVisualStudio2012::CXTPComboBoxThemeVisualStudio2012
CXTPComboBoxThemeVisualStudio2012(BOOL bLight)
Default constructor.
CXTPComboBoxThemeVisualStudio2012::RefreshMetrics
virtual void RefreshMetrics(CXTPComboBox *pComboBox)
This member function is called by the theme manager to refresh the visual styles used by each compone...
CXTPComboBoxThemeVisualStudio2012::DrawButton
virtual void DrawButton(CDC *pDC, CXTPComboBox *pComboBox, CRect rcBtn)
Called by the paint manager to draw the button portion of the combobox control.
CXTPComboBoxThemeVisualStudio2012::~CXTPComboBoxThemeVisualStudio2012
virtual ~CXTPComboBoxThemeVisualStudio2012()
Destructor handles cleanup and deallocation.
CXTPComboBoxThemeVisualStudio
Used as the paint manager for a combobox control to render a Visual Studio appearance.
Definition XTPComboBoxThemeVisualStudio.h:39


Toolkit Pro: Member List

CXTPCalendarTimeLineViewPart Member List

This is the complete list of members for CXTPCalendarTimeLineViewPart, including all inherited members.

CalcEventSize(CDC *pDC, CXTPCalendarTimeLineViewEvent *pEventView) | CXTPCalendarTimeLineViewPart | inlinevirtual
CXTPCalendarTimeLineViewPart(CXTPCalendarViewPart *pParentPart=NULL) | CXTPCalendarTimeLineViewPart | inline
CXTPCalendarViewPart(CXTPCalendarViewPart *pParentPart=NULL) | CXTPCalendarViewPart |
CXTPCmdTarget() | CXTPCmdTarget |
Draw(CDC *pDC, const CRect &rcRect, CXTPCalendarTimeLineView *pView) | CXTPCalendarTimeLineViewPart | inlinevirtual
DrawEvent(CDC *pDC, const CRect &rcEvents, CXTPCalendarTimeLineViewEvent *pEventView) | CXTPCalendarTimeLineViewPart | inlinevirtual
DrawLine_CenterLR(CDC *pDC, const CString &str, LPRECT lpRect, UINT nFormat) | CXTPCalendarViewPart |
DrawLineEx(CDC *pDC, const CString &str, LPRECT lpRect, UINT nFormatNormal, UINT nFormatSmall) | CXTPCalendarViewPart |
DrawText(CDC *pDC, const CString &str, LPRECT lpRect, UINT nFormat, COLORREF clrText=COLORREF_NULL, CFont *pFont=NULL) | CXTPCalendarViewPart |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetBackgroundColor() | CXTPCalendarViewPart | virtual
GetTextColor() | CXTPCalendarViewPart | virtual
GetTextExtent(CDC *pDC, const CString &str) | CXTPCalendarViewPart |
GetTextFont() | CXTPCalendarViewPart | virtual
m_clrBackground | CXTPCalendarViewPart |
m_clrTextColor | CXTPCalendarViewPart |
m_fntText | CXTPCalendarViewPart |
m_pPaintManager | CXTPCalendarViewPart |
m_pParentPart | CXTPCalendarViewPart |
RefreshMetrics() | CXTPCalendarViewPart | virtual
SetBackgroundColor(COLORREF clr) | CXTPCalendarViewPart |
SetTextColor(COLORREF clr) | CXTPCalendarViewPart |
SetTextFont(LOGFONT *pLogFont) | CXTPCalendarViewPart |
~CXTPCalendarViewPart() | CXTPCalendarViewPart | virtual


Toolkit Pro: XTPFrameShadowManager.h Source File

  • Source
  • Common
  • FrameShadow
XTPFrameShadowManager.h
Go to the documentation of this file.
1
23#if !defined(__XTPFRAMESHADOWMANAGER_H__)
24# define __XTPFRAMESHADOWMANAGER_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPFrameShadow;
34class CXTPSimpleCriticalSection;
35class CXTPFrameShadowManager;
36
40enum XTPFrameShadowManagerFlags
41{
47 xtpFrameShadowsDisabled = 1,
48
52 xtpFrameShadowsInvisible = 2,
53
57 xtpFrameShadowsNotResizeable = 4,
58
67 xtpFrameShadowsDisabledInTSS = 8,
68
73 xtpFrameShadowsInvisibleInTSS = 0x10
74};
75
79struct IXTPFrameShadowManagerEvents
80{
84 virtual ~IXTPFrameShadowManagerEvents()
85 {
86 }
87
94 virtual void OnFrameShadowEnabled(CXTPFrameShadowManager* pManager, HWND hwndOwner,
95 CXTPFrameShadow* pShadow)
96 {
97 UNREFERENCED_PARAMETER(pManager);
98 UNREFERENCED_PARAMETER(hwndOwner);
99 UNREFERENCED_PARAMETER(pShadow);
100 }
101
108 virtual void OnFrameShadowDisabled(CXTPFrameShadowManager* pManager, HWND hwndOwner,
109 CXTPFrameShadow* pShadow)
110 {
111 UNREFERENCED_PARAMETER(pManager);
112 UNREFERENCED_PARAMETER(hwndOwner);
113 UNREFERENCED_PARAMETER(pShadow);
114 }
115
123 virtual void OnFlagsChanged(CXTPFrameShadowManager* pManager, int nOldEffectiveFlags,
124 int nNewEffectiveFlags)
125 {
126 UNREFERENCED_PARAMETER(pManager);
127 UNREFERENCED_PARAMETER(nOldEffectiveFlags);
128 UNREFERENCED_PARAMETER(nNewEffectiveFlags);
129 }
130};
131
138_XTP_EXT_CLASS CXTPFrameShadowManager* AFX_CDECL XTPFrameShadowManager();
139
144class _XTP_EXT_CLASS CXTPFrameShadowManager
145 : public CXTPCmdTarget
146 , public CXTPObservable<CXTPFrameShadowManager, IXTPFrameShadowManagerEvents>
147{
148 friend class CXTPSingleton<CXTPFrameShadowManager>;
149
150 class CFrameShadowHook;
151 friend class CFrameShadowHook;
152
153 class CWtsEventListener;
154 friend class CWtsEventListener;
155
156 class CFrameShadowHooks;
157 friend class CFrameShadowHooks;
158
159 CXTPFrameShadowManager();
160
161public:
163 ~CXTPFrameShadowManager();
172 BOOL IsShadowSupported() const;
173
181 int GetFlags() const;
182
189 void SetFlags(int nFlags);
190
207 CXTPFrameShadow* EnableShadow(CWnd* pWnd, COLORREF crColor = (COLORREF)-1, UINT nOuterSize = 0,
208 UINT nInnerSize = 0, CPoint ptOffset = CPoint(0, 0),
209 BYTE bTransparency = 0);
210
227 CXTPFrameShadow* EnableShadow(HWND hWnd, COLORREF crColor = (COLORREF)-1, UINT nOuterSize = 0,
228 UINT nInnerSize = 0, CPoint ptOffset = CPoint(0, 0),
229 BYTE bTransparency = 0);
230
238 void DisableShadow(HWND hWnd);
239
247 void DisableShadow(CWnd* pWnd);
248
258 BOOL IsShadowEnabled(CWnd* pWnd) const;
259
269 CXTPFrameShadow* GetShadow(HWND hWnd) const;
270
280 CXTPFrameShadow* GetShadow(CWnd* pWnd) const;
281
291 POSITION GetFirstShadowPosition() const;
292
304 CXTPFrameShadow* GetNextShadow(POSITION& pos) const;
305
313 void FreezeUpdates(BOOL bFreeze = TRUE);
314
324 UINT GetDefaultOuterSize() const;
325
334 void SetDefaultOuterSize(UINT nSize);
335
345 void SetGlobalOuterSize(UINT nSize);
346
356 UINT GetDefaultInnerSize() const;
357
366 void SetDefaultInnerSize(UINT nSize);
367
377 void SetGlobalInnerSize(UINT nSize);
378
388 CPoint GetDefaultOffset() const;
389
398 void SetDefaultOffset(CPoint ptOffset);
399
409 void SetGlobalOffset(CPoint ptOffset);
410
420 COLORREF GetDefaultColor() const;
421
430 void SetDefaultColor(COLORREF crColor);
431
441 void SetGlobalColor(COLORREF crColor);
442
452 BYTE GetDefaultTransparency() const;
453
463 void SetDefaultTransparency(BYTE bTransparency);
464
475 void SetGlobalTransparency(BYTE bTransparency);
476
491 UINT GetDefaultBlendingOptions(OUT OPTIONAL float* pFactors,
492 OUT OPTIONAL float* pPositions) const;
493
505 void SetDefaultBlendingOptions(UINT nCount, const float* pFactors, const float* pPositions);
506
519 void SetGlobalBlendingOptions(UINT nCount, const float* pFactors, const float* pPositions);
520
533 BOOL GetDefaultClipOwner() const;
534
547 void SetDefaultClipOwner(BOOL bClipOwner);
548
561 void SetGlobalClipOwner(BOOL bClipOwner);
562
563protected:
564 virtual void OnFinalRelease();
565
566private:
567 void SetShadowThreadMessageHook(CXTPFrameShadow* pShadow, BOOL bSet = TRUE);
568 void OnHookMessage(UINT nHook, HWND hWnd, UINT nCode, WPARAM& wParam, LPARAM& lParam,
569 LRESULT& lResult);
570 void UpdateAllShadows(BOOL bRedraw = FALSE);
571 void SetInTerminalServiceSession(BOOL bInTSS, BOOL bUpdate = FALSE);
572 void UpdateTerminalSessionFlags();
573
574# ifdef _XTP_ACTIVEX
577 DECLARE_DISPATCH_MAP()
578 DECLARE_INTERFACE_MAP()
579
580 DECLARE_OLETYPELIB_EX(CXTPFrameShadowManager);
581
582 afx_msg long OleGetFlags();
583 afx_msg void OleSetFlags(long flags);
584 afx_msg long OleGetDefaultOuterSize();
585 afx_msg void OleSetDefaultOuterSize(long size);
586 afx_msg long OleGetDefaultInnerSize();
587 afx_msg void OleSetDefaultInnerSize(long size);
588 afx_msg OLE_XSIZE_PIXELS OleGetDefaultOffsetX();
589 afx_msg void OleSetDefaultOffsetX(OLE_XSIZE_PIXELS offset);
590 afx_msg OLE_YSIZE_PIXELS OleGetDefaultOffsetY();
591 afx_msg void OleSetDefaultOffsetY(OLE_YSIZE_PIXELS offset);
592 afx_msg OLE_COLOR OleGetDefaultColor();
593 afx_msg void OleSetDefaultColor(OLE_COLOR color);
594 afx_msg short OleGetDefaultTransparency();
595 afx_msg void OleSetDefaultTransparency(short val);
596 afx_msg BOOL OleGetDefaultClipOwner();
597 afx_msg void OleSetDefaultClipOwner(BOOL bClip);
598 afx_msg VARIANT OleGetDefaultBlendingFactors();
599 afx_msg VARIANT OleGetDefaultBlendingPositions();
600 afx_msg void OleDisableShadow(OLE_HANDLE hWnd);
601 afx_msg BOOL OleIsShadowEnabled(OLE_HANDLE hWnd);
602 afx_msg void OleFreezeUpdates(VARIANT_BOOL bFreeze);
603 afx_msg void OleSetGlobalOuterSize(long size);
604 afx_msg void OleSetGlobalInnerSize(long size);
605 afx_msg void OleSetGlobalOffset(OLE_XSIZE_PIXELS offsetX, OLE_YSIZE_PIXELS offsetY);
606 afx_msg void OleSetGlobalColor(OLE_COLOR color);
607 afx_msg void OleSetDefaultBlendingOptions(const VARIANT& factors, const VARIANT& positions);
608 afx_msg void OleSetGlobalBlendingOptions(const VARIANT& factors, const VARIANT& positions);
609 afx_msg void OleSetGlobalTransparency(short val);
610 afx_msg void OleSetGlobalClipOwner(BOOL bClip);
611 afx_msg LPDISPATCH OleEnableShadow(OLE_HANDLE hWnd, OLE_HANDLE color, long outerSize,
612 long innerSize, OLE_XSIZE_PIXELS offsetX = 0,
613 OLE_YSIZE_PIXELS offsetY = 0, short transparancy = 0);
614 afx_msg LPDISPATCH OleGetShadow(OLE_HANDLE hWnd);
615 afx_msg LPDISPATCH OleGetFrameShadows();
617# endif
618
619private:
620 int m_nFlags, m_nEffectiveFlags;
621 BOOL m_bInTerminalServiceSession;
622 CWtsEventListener* m_pWtsEventListener;
623
624 CMap<HWND, HWND&, CXTPFrameShadow*, CXTPFrameShadow*&> m_mapWnd;
625 UINT m_nDefaultOuterSize;
626 UINT m_nDefaultInnerSize;
627 CPoint m_ptDefaultOffset;
628 COLORREF m_crDefaultColor;
629 BYTE m_bDefaultTransparency;
630 BOOL m_bDefaultClipOwner;
631 CXTPSimpleCriticalSection* m_pGuard;
632 BOOL m_bInUpdateAllShadows;
633
634 struct DefaultBlendingOptions
635 {
636 CArray<float, const float&> Factors;
637 CArray<float, const float&> Positions;
638 } m_DefaultBlendingOptions;
639
640 CMap<DWORD, DWORD&, CFrameShadowHooks*, CFrameShadowHooks*&> m_mapHooks;
641};
642
643# ifdef _XTP_ACTIVEX
647// CFrameShadows command target
648
649class CFrameShadows : public CXTPCmdTarget
650{
651 DECLARE_DYNCREATE(CFrameShadows)
652
653 CFrameShadows(); // protected constructor used by dynamic creation
654
655 // Attributes
656public:
657 // Operations
658public:
659 // Overrides
660 // ClassWizard generated virtual function overrides
661 //{{AFX_VIRTUAL(CFrameShadows)
662public:
663 virtual void OnFinalRelease();
664 //}}AFX_VIRTUAL
665
666 // Implementation
667protected:
668 virtual ~CFrameShadows();
669
670 // Generated message map functions
671 //{{AFX_MSG(CFrameShadows)
672 // NOTE - the ClassWizard will add and remove member functions here.
673 //}}AFX_MSG
674
675 DECLARE_MESSAGE_MAP()
676
677 // Generated OLE dispatch map functions
678 //{{AFX_DISPATCH(CFrameShadows)
679 DECLARE_ENUM_VARIANTLIST(CFrameShadows)
680 //}}AFX_DISPATCH
681 DECLARE_DISPATCH_MAP()
682 DECLARE_INTERFACE_MAP()
683 DECLARE_OLETYPELIB_EX(CFrameShadows);
684};
685
687# endif
689AFX_INLINE int CXTPFrameShadowManager::GetFlags() const
690{
691 return m_nEffectiveFlags;
692}
693
694AFX_INLINE BOOL CXTPFrameShadowManager::IsShadowEnabled(CWnd* pWnd) const
695{
696 return NULL != GetShadow(pWnd);
697}
698
699AFX_INLINE UINT CXTPFrameShadowManager::GetDefaultOuterSize() const
700{
701 return m_nDefaultOuterSize;
702}
703
704AFX_INLINE void CXTPFrameShadowManager::SetDefaultOuterSize(UINT nSize)
705{
706 m_nDefaultOuterSize = nSize;
707}
708
709AFX_INLINE UINT CXTPFrameShadowManager::GetDefaultInnerSize() const
710{
711 return m_nDefaultInnerSize;
712}
713
714AFX_INLINE void CXTPFrameShadowManager::SetDefaultInnerSize(UINT nSize)
715{
716 m_nDefaultInnerSize = nSize;
717}
718
719AFX_INLINE CPoint CXTPFrameShadowManager::GetDefaultOffset() const
720{
721 return m_ptDefaultOffset;
722}
723
724AFX_INLINE void CXTPFrameShadowManager::SetDefaultOffset(CPoint ptOffset)
725{
726 m_ptDefaultOffset = ptOffset;
727}
728
729AFX_INLINE COLORREF CXTPFrameShadowManager::GetDefaultColor() const
730{
731 return m_crDefaultColor;
732}
733
734AFX_INLINE void CXTPFrameShadowManager::SetDefaultColor(COLORREF crColor)
735{
736 m_crDefaultColor = crColor;
737}
738
739AFX_INLINE BYTE CXTPFrameShadowManager::GetDefaultTransparency() const
740{
741 return m_bDefaultTransparency;
742}
743
744AFX_INLINE void CXTPFrameShadowManager::SetDefaultTransparency(BYTE bTransparency)
745{
746 m_bDefaultTransparency = bTransparency;
747}
748
749AFX_INLINE BOOL CXTPFrameShadowManager::GetDefaultClipOwner() const
750{
751 return m_bDefaultClipOwner;
752}
753
754AFX_INLINE void CXTPFrameShadowManager::SetDefaultClipOwner(BOOL bClipOwner)
755{
756 m_bDefaultClipOwner = bClipOwner;
757}
759# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
761#endif // !defined(__XTPFRAMESHADOWMANAGER_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPFrameShadowManagerFlags
XTPFrameShadowManagerFlags
Global Frame Shadow Manager flags.
Definition XTPFrameShadowManager.h:41
xtpFrameShadowsDisabledInTSS
@ xtpFrameShadowsDisabledInTSS
Frame shadows are automatically disabled for Terminal Services sessions, e.g.
Definition XTPFrameShadowManager.h:67
xtpFrameShadowsInvisible
@ xtpFrameShadowsInvisible
Frame shadows are not visible but remain resizeable.
Definition XTPFrameShadowManager.h:52
xtpFrameShadowsInvisibleInTSS
@ xtpFrameShadowsInvisibleInTSS
Frame shadows are automatically invisible for Terminal Services sessions, e.g.
Definition XTPFrameShadowManager.h:73
xtpFrameShadowsDisabled
@ xtpFrameShadowsDisabled
Frame shadows disabled.
Definition XTPFrameShadowManager.h:47
xtpFrameShadowsNotResizeable
@ xtpFrameShadowsNotResizeable
Frame shadows cannot be used for resizing the owner windows.
Definition XTPFrameShadowManager.h:57
XTPFrameShadowManager
_XTP_EXT_CLASS CXTPFrameShadowManager *AFX_CDECL XTPFrameShadowManager()
Provides access to the global frame shdow manager instance.
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPFrameShadow
The class represents frame shadow object.
Definition XTPFrameShadow.h:47
CXTPFrameShadowManager
Provides frame shadow management functionality.
Definition XTPFrameShadowManager.h:147
CXTPFrameShadowManager::SetDefaultTransparency
void SetDefaultTransparency(BYTE bTransparency)
Sets a value of default transparency used for all shadows to be created if a default value is used in...
CXTPFrameShadowManager::SetDefaultOffset
void SetDefaultOffset(CPoint ptOffset)
Sets a value of default shadow offset used for all shadows to be created if a default value is used i...
CXTPFrameShadowManager::GetDefaultOffset
CPoint GetDefaultOffset() const
Obtains a value of default shadow offset used for all shadows to be created if a default value is use...
CXTPFrameShadowManager::GetDefaultBlendingOptions
UINT GetDefaultBlendingOptions(OUT OPTIONAL float *pFactors, OUT OPTIONAL float *pPositions) const
Obtains default blending options used for all shadows to be created if a default value is used in Ena...
CXTPFrameShadowManager::IsShadowEnabled
BOOL IsShadowEnabled(CWnd *pWnd) const
Determines if a shadow is enabled for the window specified.
CXTPFrameShadowManager::EnableShadow
CXTPFrameShadow * EnableShadow(HWND hWnd, COLORREF crColor=(COLORREF) -1, UINT nOuterSize=0, UINT nInnerSize=0, CPoint ptOffset=CPoint(0, 0), BYTE bTransparency=0)
Enables frame shadow for a window specified.
CXTPFrameShadowManager::SetGlobalInnerSize
void SetGlobalInnerSize(UINT nSize)
Sets a value of default inner size used for all shadows to be created if a default value is used in E...
CXTPFrameShadowManager::GetDefaultInnerSize
UINT GetDefaultInnerSize() const
Obtains a value of default inner size used for all shadows to be created if a default value is used i...
CXTPFrameShadowManager::SetGlobalClipOwner
void SetGlobalClipOwner(BOOL bClipOwner)
Sets owner clipping for all shadows.
CXTPFrameShadowManager::DisableShadow
void DisableShadow(HWND hWnd)
Disable a previsously enabled frame shadow for a window specified.
CXTPFrameShadowManager::GetFirstShadowPosition
POSITION GetFirstShadowPosition() const
Obtains the position of the first shadow in the list of all enabled shadows.
CXTPFrameShadowManager::GetNextShadow
CXTPFrameShadow * GetNextShadow(POSITION &pos) const
Obtains frame shadow pointer in the position specified and moves the position cursor to the next enab...
CXTPFrameShadowManager::FreezeUpdates
void FreezeUpdates(BOOL bFreeze=TRUE)
Freezes/unfreezes updates on changing shadow settings, as a result shadow blinking is reduced.
CXTPFrameShadowManager::SetGlobalTransparency
void SetGlobalTransparency(BYTE bTransparency)
Sets a value of default trasparency used for all shadows to be created if a default value is used in ...
CXTPFrameShadowManager::SetFlags
void SetFlags(int nFlags)
Sets global frame shadow flags.
CXTPFrameShadowManager::GetDefaultColor
COLORREF GetDefaultColor() const
Obtains a value of default color used for all shadows to be created if a default value is used in Ena...
CXTPFrameShadowManager::SetDefaultClipOwner
void SetDefaultClipOwner(BOOL bClipOwner)
Sets default owner clipping for new shadows.
CXTPFrameShadowManager::GetDefaultOuterSize
UINT GetDefaultOuterSize() const
Obtains a value of default outer size used for all shadows to be created if a default value is used i...
CXTPFrameShadowManager::SetDefaultColor
void SetDefaultColor(COLORREF crColor)
Sets a value of default color used for all shadows to be created if a default value is used in Enable...
CXTPFrameShadowManager::SetDefaultOuterSize
void SetDefaultOuterSize(UINT nSize)
Sets a value of default outer size used for all shadows to be created if a default value is used in E...
CXTPFrameShadowManager::SetGlobalOuterSize
void SetGlobalOuterSize(UINT nSize)
Sets a value of default outer size used for all shadows to be created if a default value is used in E...
CXTPFrameShadowManager::SetGlobalColor
void SetGlobalColor(COLORREF crColor)
Sets a value of default color used for all shadows to be created if a default value is used in Enable...
CXTPFrameShadowManager::SetDefaultBlendingOptions
void SetDefaultBlendingOptions(UINT nCount, const float *pFactors, const float *pPositions)
Sets default blending options used for all shadows to be created if a default value is used in Enable...
CXTPFrameShadowManager::IsShadowSupported
BOOL IsShadowSupported() const
Determines if frame shadows are supported by the platform.
CXTPFrameShadowManager::SetDefaultInnerSize
void SetDefaultInnerSize(UINT nSize)
Sets a value of default inner size used for all shadows to be created if a default value is used in E...
CXTPFrameShadowManager::GetFlags
int GetFlags() const
Obtains global frame shadow flags.
CXTPFrameShadowManager::GetDefaultTransparency
BYTE GetDefaultTransparency() const
Obtains a value of default transparency used for all shadows to be created if a default value is used...
CXTPFrameShadowManager::SetGlobalBlendingOptions
void SetGlobalBlendingOptions(UINT nCount, const float *pFactors, const float *pPositions)
Sets default blending options used for all shadows to be created if a default value is used in Enable...
CXTPFrameShadowManager::GetShadow
CXTPFrameShadow * GetShadow(HWND hWnd) const
Obtains shadow object pointer for a window specified.
CXTPFrameShadowManager::EnableShadow
CXTPFrameShadow * EnableShadow(CWnd *pWnd, COLORREF crColor=(COLORREF) -1, UINT nOuterSize=0, UINT nInnerSize=0, CPoint ptOffset=CPoint(0, 0), BYTE bTransparency=0)
Enables frame shadow for a window specified.
CXTPFrameShadowManager::SetGlobalOffset
void SetGlobalOffset(CPoint ptOffset)
Sets a value of default shadow offset used for all shadows to be created if a default value is used i...
CXTPFrameShadowManager::GetDefaultClipOwner
BOOL GetDefaultClipOwner() const
Obtains default owner clipping for new shadows.
CXTPFrameShadowManager::GetShadow
CXTPFrameShadow * GetShadow(CWnd *pWnd) const
Obtains shadow object pointer for a window specified.
CXTPFrameShadowManager::DisableShadow
void DisableShadow(CWnd *pWnd)
Disable a previsously enabled frame shadow for a window specified.
CXTPObservable
Provides a basic implementation of the Observable design pattern.
Definition XTPSystemHelpers.h:2138
CXTPSimpleCriticalSection
Implements simple and lightweight synchronization critical section primitive.
Definition XTPSynchro.h:112
CXTPSingleton
Implements Singleton design pattern.
Definition XTPSingleton.h:215
IXTPFrameShadowManagerEvents
An interface for Frame Shadow Manager event listener.
Definition XTPFrameShadowManager.h:80
IXTPFrameShadowManagerEvents::OnFrameShadowDisabled
virtual void OnFrameShadowDisabled(CXTPFrameShadowManager *pManager, HWND hwndOwner, CXTPFrameShadow *pShadow)
Invoked right before a shadow is disabled for a window.
Definition XTPFrameShadowManager.h:108
IXTPFrameShadowManagerEvents::OnFrameShadowEnabled
virtual void OnFrameShadowEnabled(CXTPFrameShadowManager *pManager, HWND hwndOwner, CXTPFrameShadow *pShadow)
Invoked right after a shadow is enabled for a window.
Definition XTPFrameShadowManager.h:94
IXTPFrameShadowManagerEvents::~IXTPFrameShadowManagerEvents
virtual ~IXTPFrameShadowManagerEvents()
Handles object destruction.
Definition XTPFrameShadowManager.h:84
IXTPFrameShadowManagerEvents::OnFlagsChanged
virtual void OnFlagsChanged(CXTPFrameShadowManager *pManager, int nOldEffectiveFlags, int nNewEffectiveFlags)
Invoked when flags are changed.
Definition XTPFrameShadowManager.h:123


Toolkit Pro: Member List

CXTPShellListCtrlEx Member List

This is the complete list of members for CXTPShellListCtrlEx, including all inherited members.

AssociateTree(CWnd *pWnd) | CXTPShellListCtrl | virtual
BrowseToFolder(LPCTSTR lpszPath) | CXTPShellListCtrlEx |
CXTPShellListCtrl() | CXTPShellListCtrl |
CXTPShellListCtrlEx() | CXTPShellListCtrlEx |
m_bInitControl | CXTPShellListCtrl | protected
m_pSyncWnd | CXTPShellListCtrlEx | protected
m_pTreeCtrl | CXTPShellListCtrl | protected
m_strItemPath | CXTPShellListCtrlEx | protected
SetSyncWnd(CWnd *pSyncWnd) | CXTPShellListCtrlEx |
~CXTPShellListCtrl() | CXTPShellListCtrl | virtual
~CXTPShellListCtrlEx() | CXTPShellListCtrlEx | virtual


Toolkit Pro: Member List

CXTPSyntaxEditAutoCompleteWnd Member List

This is the complete list of members for CXTPSyntaxEditAutoCompleteWnd, including all inherited members.

Create(CWnd *pParentWnd) | CXTPSyntaxEditAutoCompleteWnd | virtual
CXTPSyntaxEditAutoCompleteWnd() | CXTPSyntaxEditAutoCompleteWnd |
GetDelimiters() | CXTPSyntaxEditAutoCompleteWnd |
GetImageManager() const | CXTPSyntaxEditAutoCompleteWnd |
GetWndWidth() const | CXTPSyntaxEditAutoCompleteWnd |
Hide() | CXTPSyntaxEditAutoCompleteWnd | virtual
HitTest(CPoint ptTest) const | CXTPSyntaxEditAutoCompleteWnd | protected
IsActive() const | CXTPSyntaxEditAutoCompleteWnd |
IsCloseTag(CString strToTest) | CXTPSyntaxEditAutoCompleteWnd |
IsOpenTag(CString strToTest) | CXTPSyntaxEditAutoCompleteWnd |
m_arrACData | CXTPSyntaxEditAutoCompleteWnd | protected
m_arrACDataFiltered | CXTPSyntaxEditAutoCompleteWnd | protected
m_arrGrid | CXTPSyntaxEditAutoCompleteWnd | protected
m_bActive | CXTPSyntaxEditAutoCompleteWnd | protected
m_bFilteredMode | CXTPSyntaxEditAutoCompleteWnd | protected
m_bFixedBottom | CXTPSyntaxEditAutoCompleteWnd | protected
m_bHighLight | CXTPSyntaxEditAutoCompleteWnd | protected
m_clrHighLight | CXTPSyntaxEditAutoCompleteWnd | protected
m_clrHighLightText | CXTPSyntaxEditAutoCompleteWnd | protected
m_clrWindow | CXTPSyntaxEditAutoCompleteWnd | protected
m_clrWindowText | CXTPSyntaxEditAutoCompleteWnd | protected
m_nBordersHeight | CXTPSyntaxEditAutoCompleteWnd | protected
m_nEndReplacePos | CXTPSyntaxEditAutoCompleteWnd | protected
m_nFirstDisplayedStr | CXTPSyntaxEditAutoCompleteWnd | protected
m_nHighLightLine | CXTPSyntaxEditAutoCompleteWnd | protected
m_nLineHeight | CXTPSyntaxEditAutoCompleteWnd | protected
m_nLines | CXTPSyntaxEditAutoCompleteWnd | protected
m_nStartReplacePos | CXTPSyntaxEditAutoCompleteWnd | protected
m_nWndHeight | CXTPSyntaxEditAutoCompleteWnd | protected
m_nWndWidth | CXTPSyntaxEditAutoCompleteWnd | protected
m_pImageManager | CXTPSyntaxEditAutoCompleteWnd | protected
m_pParentWnd | CXTPSyntaxEditAutoCompleteWnd | protected
m_strCloseTags | CXTPSyntaxEditAutoCompleteWnd | protected
m_strDelims | CXTPSyntaxEditAutoCompleteWnd | protected
m_strOpenTags | CXTPSyntaxEditAutoCompleteWnd | protected
m_strSearch | CXTPSyntaxEditAutoCompleteWnd | protected
m_strTmpCloseTag | CXTPSyntaxEditAutoCompleteWnd | protected
m_strTmpOpenTag | CXTPSyntaxEditAutoCompleteWnd | protected
m_xtpFontBasic | CXTPSyntaxEditAutoCompleteWnd | protected
RefreshMetrics() | CXTPSyntaxEditAutoCompleteWnd | virtual
RegisterWindowClass(HINSTANCE hInstance=NULL) | CXTPSyntaxEditAutoCompleteWnd | virtual
SetCloseTags(CString strCloseTags) | CXTPSyntaxEditAutoCompleteWnd | virtual
SetDelimiters(CString strDelims) | CXTPSyntaxEditAutoCompleteWnd |
SetList(CXTPSyntaxEditACDataArray &parrData) | CXTPSyntaxEditAutoCompleteWnd | virtual
SetOpenTags(CString strOpenTags) | CXTPSyntaxEditAutoCompleteWnd | virtual
SetWndWidth(int nWidth) | CXTPSyntaxEditAutoCompleteWnd |
Show(CPoint pt, CString strSearch=_T("")) | CXTPSyntaxEditAutoCompleteWnd | virtual
~CXTPSyntaxEditAutoCompleteWnd() | CXTPSyntaxEditAutoCompleteWnd | virtual


Toolkit Pro: Member List

CXTPChartHighLowSeriesPointView Member List

This is the complete list of members for CXTPChartHighLowSeriesPointView, including all inherited members.

AddChildView(CXTPChartElementView *pChildView) | CXTPChartElementView |
CreateDeviceCommand(CXTPChartDeviceContext *pDC) | CXTPChartHighLowSeriesPointView | virtual
CreateLegendDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcBounds) | CXTPChartSeriesPointView | virtual
CXTPChartElementView(CXTPChartElementView *pParentView) | CXTPChartElementView |
CXTPChartElementView(CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartElementView |
CXTPChartElementView(CXTPChartContainer *pContainer) | CXTPChartElementView |
CXTPChartHighLowSeriesPointView(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView) | CXTPChartHighLowSeriesPointView |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartSeriesPointView(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView) | CXTPChartSeriesPointView |
CXTPChartSeriesPointView(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartSeriesPointView |
GetAt(int nIndex) const | CXTPChartElementView |
GetBounds() const | CXTPChartElementView |
GetBounds(BOOL bIncludingChildren) const | CXTPChartElementView |
GetChildren() | CXTPChartElementView |
GetColor() const | CXTPChartSeriesPointView |
GetColor2() const | CXTPChartSeriesPointView |
GetCount() const | CXTPChartElementView |
GetInternalValue() const | CXTPChartSeriesPointView |
GetLegendName() const | CXTPChartSeriesPointView | virtual
GetParentView() const | CXTPChartElementView |
GetPoint() const | CXTPChartSeriesPointView |
GetScreenPoint(int nIndex) | CXTPChartHighLowSeriesPointView |
GetSeriesView() const | CXTPChartSeriesPointView |
Is3D() const | CXTPChartObject |
m_arrChildren | CXTPChartElementView | protected
m_dInternalValue | CXTPChartSeriesPointView |
m_pContainer | CXTPChartElementView | protected
m_pParentView | CXTPChartElementView | protected
m_pPoint | CXTPChartSeriesPointView | protected
m_rcBounds | CXTPChartElementView | protected
UpdateMinMaxRange(double &nMinValue, double &nMaxValue) const | CXTPChartSeriesPointView | virtual
~CXTPChartElementView() | CXTPChartElementView | protectedvirtual
~CXTPChartLegendItemView() | CXTPChartLegendItemView | inlinevirtual


Toolkit Pro: Member List

CXTPControlCustom Member List

This is the complete list of members for CXTPControlCustom, including all inherited members.

AssignDocTemplate(UINT nIDResource) | CXTPControl |
ClickToolBarButton(CRect rcActiveRect=CRect(0, 0, 0, 0)) | CXTPControl | protected
Compare(CXTPControl *pOther) | CXTPControl | virtual
Copy(CXTPControl *pControl, BOOL bRecursive=FALSE) | CXTPControlCustom | protectedvirtual
CreateControlCustom(CWnd *pWndChild) | CXTPControlCustom | static
CustomizeStartDrag(CPoint point) | CXTPControl | protectedvirtual
CustomizeStartResize(CPoint point) | CXTPControl | protectedvirtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPControl() | CXTPControl | protected
CXTPControlButton() | CXTPControlButton |
CXTPControlCustom() | CXTPControlCustom |
CXTPHookManagerHookAble() | CXTPHookManagerHookAble |
DelayLayoutParent() | CXTPControl |
DelayRedrawParent() | CXTPControl |
DoCustomDragOver(CXTPCommandBar *pCommandBar, CPoint point, DROPEFFECT &dropEffect) | CXTPControlCustom | protectedvirtual
DoPropExchange(CXTPPropExchange *pPX) | CXTPControlCustom | protectedvirtual
Draw(CDC *pDC) | CXTPControlCustom | protectedvirtual
ExcludeDocTemplate(UINT nIDResource) | CXTPControl |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
FromUI(CCmdUI *pCmdUI) | CXTPControl | static
GenerateCommandBarList(DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam) | CXTPControl | protectedvirtual
GetAction() const | CXTPControl |
GetBeginGroup() const | CXTPControl |
GetButtonSize() const | CXTPControl | virtual
GetCaption() const | CXTPControl | virtual
GetCategory() const | CXTPControl |
GetChecked() const | CXTPControl |
GetCloseSubMenuOnClick() const | CXTPControl |
GetCommandBar() const | CXTPControl | virtual
GetControl() | CXTPControlCustom |
GetControls() const | CXTPControl |
GetCustomizeMinHeight() const | CXTPControl | protectedvirtual
GetCustomizeMinWidth() const | CXTPControl | protectedvirtual
GetCustomShortcutText() const | CXTPControl |
GetDescription() const | CXTPControl | virtual
GetEnabled() const | CXTPControl |
GetExecuteOnPressInterval() const | CXTPControl |
GetExpanded() const | CXTPControl |
GetFlags() const | CXTPControl |
GetHeight() const | CXTPControl |
GetHelpId() const | CXTPControl |
GetHideFlags() const | CXTPControl |
GetIconId() const | CXTPControl |
GetIconSize() const | CXTPControl | virtual
GetID() const | CXTPControl |
GetImage(int nWidth=16) const | CXTPControl | virtual
GetImageManager() const | CXTPControl |
GetIndex() const | CXTPControl |
GetKeyboardTip() const | CXTPControl |
GetPaintManager() const | CXTPControl |
GetParameter() const | CXTPControl |
GetParent() const | CXTPControl |
GetPopuped() const | CXTPControl | virtual
GetPressed() const | CXTPControl | virtual
GetRect() const | CXTPControl |
GetRibbonGroup() const | CXTPControl |
GetRowRect() const | CXTPControl |
GetSelected() const | CXTPControl | virtual
GetShortcutText() const | CXTPControl |
GetSize(CDC *pDC) | CXTPControlCustom | protectedvirtual
GetStyle() const | CXTPControl |
GetStyleEx() const | CXTPControlButton |
GetTag() const | CXTPControl |
GetTooltip() const | CXTPControl | virtual
GetType() const | CXTPControl |
GetWidth() const | CXTPControl |
GetWrap() const | CXTPControl |
HasDwmCompositedRect() const | CXTPControl |
IsCaptionVisible() const | CXTPControl | virtual
IsCursorOver() const | CXTPControl |
IsCustomizeMode() const | CXTPControl | protected
IsCustomizeMovable() const | CXTPControl | virtual
IsCustomizeResizeAllow() const | CXTPControl | protectedvirtual
IsFocusable() const | CXTPControl | protectedvirtual
IsFocused() const | CXTPControl | virtual
IsItemDefault() const | CXTPControl |
IsLayoutChanged() | CXTPControl | protected
IsLayoutRTL() const | CXTPControl | protected
IsOnQuickAccess() const | CXTPControl |
IsTemporary() const | CXTPControl |
IsTransparent() const | CXTPControl | inlinevirtual
IsVisible(DWORD dwSkipFlags=0) const | CXTPControl | virtual
m_bAutoDestroy | CXTPHookManagerHookAble |
m_bBeginGroup | CXTPControl | protected
m_bChecked | CXTPControl | protected
m_bCloseSubMenuOnClick | CXTPControl | protected
m_bControlVisible | CXTPControlCustom | protected
m_bDefaultItem | CXTPControl | protected
m_bEnabled | CXTPControl | protected
m_bExpanded | CXTPControl | protected
m_bLayoutRTL | CXTPControl | protected
m_bOnQuickAccess | CXTPControl | protected
m_bPressed | CXTPControl | protected
m_bSelected | CXTPControl | protected
m_bTemporary | CXTPControl | protected
m_buttonCustomStyle | CXTPControl | protected
m_buttonRibbonStyle | CXTPControl | protected
m_buttonStyle | CXTPControl | protected
m_buttonStyleEx | CXTPControlButton | protected
m_bWrap | CXTPControl | protected
m_controlType | CXTPControl | protected
m_dwFlags | CXTPControl | protected
m_dwHideFlags | CXTPControl | protected
m_hwndControl | CXTPControlCustom | protected
m_mapDocTemplatesAssigned | CXTPControl | protected
m_mapDocTemplatesExcluded | CXTPControl | protected
m_nControlID | CXTPControlCustom | protected
m_nCustomIconId | CXTPControl | protected
m_nExecuteOnPressInterval | CXTPControl | protected
m_nHeight | CXTPControl | protected
m_nHelpId | CXTPControl | protected
m_nIconId | CXTPControl | protected
m_nId | CXTPControl | protected
m_nIndex | CXTPControl | protected
m_nTag | CXTPControl | protected
m_nWidth | CXTPControl | protected
m_pAction | CXTPControl | protected
m_pControls | CXTPControl | protected
m_pParent | CXTPControl | protected
m_pRibbonGroup | CXTPControl | protected
m_rcBorders | CXTPControlCustom | protected
m_rcControl | CXTPControl | protected
m_rcRow | CXTPControl | protected
m_strCaption | CXTPControl | protected
m_strCategory | CXTPControl | protected
m_strCustomCaption | CXTPControl | protected
m_strDescriptionText | CXTPControl | protected
m_strKeyboardTip | CXTPControl | protected
m_strParameter | CXTPControl | protected
m_strShortcutText | CXTPControl | protected
m_strShortcutTextAuto | CXTPControl | protected
m_strTooltipText | CXTPControl | protected
m_szControl | CXTPControlCustom | protected
m_szIcon | CXTPControl | protected
m_verticalOptions | CXTPControlCustom | protected
NotifySite(UINT code) | CXTPControl |
NotifySite(UINT code, NMXTPCONTROL *pNM) | CXTPControl |
NotifySite(CWnd *pSite, UINT code, NMXTPCONTROL *pNM) | CXTPControl |
OnActionChanged(int nProperty) | CXTPControlCustom | protectedvirtual
OnActionChanging(int nProperty) | CXTPControl | protectedvirtual
OnCalcDynamicSize(DWORD dwMode) | CXTPControlCustom | protectedvirtual
OnCaptionChanged() | CXTPControl | protectedvirtual
OnClick(BOOL bKeyboard=FALSE, CPoint pt=CPoint(0, 0)) | CXTPControlCustom | protectedvirtual
OnCustomizeDragOver(CXTPControl *pDataObject, CPoint point, DROPEFFECT &dropEffect) | CXTPControl | protectedvirtual
OnCustomizeMouseMove(CPoint point) | CXTPControl | protected
OnEnabledChanged() | CXTPControlCustom | virtual
OnExecute() | CXTPControl | virtual
OnHookAttached(HWND hWnd) | CXTPHookManagerHookAble | virtual
OnHookDetached() | CXTPHookManagerHookAble | virtual
OnHookKeyDown(UINT nChar, LPARAM lParam) | CXTPControl | protectedvirtual
OnHookMessage(HWND hWnd, UINT nMessage, WPARAM &wParam, LPARAM &lParam, LRESULT &lResult) | CXTPControlCustom | protectedvirtual
OnHookMouseWheel(UINT nFlags, short zDelta, CPoint point) | CXTPControl | protectedvirtual
OnIdleUpdate() | CXTPControl | protectedvirtual
OnLButtonDblClk(CPoint point) | CXTPControl | protectedvirtual
OnLButtonDown(CPoint point) | CXTPControl | protectedvirtual
OnLButtonUp(CPoint point) | CXTPControlButton | protectedvirtual
OnMouseHover() | CXTPControl | protectedvirtual
OnMouseMove(CPoint point) | CXTPControl | protectedvirtual
OnPostHookMessage(HWND hWnd, UINT nMessage, WPARAM &wParam, LPARAM &lParam, LRESULT &lResult) | CXTPHookManagerHookAble | virtual
OnRButtonDown(CPoint point) | CXTPControl | protectedvirtual
OnRButtonUp(CPoint point) | CXTPControl | protectedvirtual
OnRemoved() | CXTPControlCustom | protectedvirtual
OnSetPopup(BOOL bPopup) | CXTPControl | protectedvirtual
OnSetSelected(int bSelected) | CXTPControl | protectedvirtual
OnThemeChanged() | CXTPControl | virtual
OnToolHitTest(CPoint point, TOOLINFO *pTI) const | CXTPControl | protectedvirtual
OnUnderlineActivate() | CXTPControl | virtual
RedrawParent(BOOL bAnimate=TRUE) | CXTPControl |
Reset() | CXTPControl |
RestoreCommandBarList(CXTPCommandBarList *pCommandBarList) | CXTPControl | protectedvirtual
ScreenToClient(CPoint *point) | CXTPControl | protected
SetAction(CXTPControlAction *pAction) | CXTPControl | virtual
SetBeginGroup(BOOL bBeginGroup) | CXTPControl | virtual
SetBorders(int cxRight, int cxTop, int cxLeft, int cxBottom) | CXTPControlCustom |
SetCaption(LPCTSTR lpszCaption) | CXTPControl |
SetCaption(UINT nIDCaption) | CXTPControl |
SetCategory(LPCTSTR lpszCategory) | CXTPControl |
SetChecked(BOOL bChecked) | CXTPControl | virtual
SetCloseSubMenuOnClick(BOOL bCloseOnClick) | CXTPControl |
SetControl(CWnd *pWnd) | CXTPControlCustom |
SetCustomIcon(HICON hIcon) | CXTPControl |
SetCustomShortcutText(LPCTSTR lpszCustomShortcutText) | CXTPControl |
SetDescription(LPCTSTR lpszDescription) | CXTPControl |
SetEnabled(BOOL bEnabled) | CXTPControl | virtual
SetExecuteOnPressInterval(int nExecuteOnPressInterval) | CXTPControl |
SetExpanded(BOOL bExpanded) | CXTPControl | protected
SetFlags(DWORD dwFlags) | CXTPControl |
SetFocused(BOOL bFocused) | CXTPControl | virtual
SetHeight(int nHeight) | CXTPControl | virtual
SetHelpId(int nId) | CXTPControl |
SetHideFlag(XTPControlHideFlags dwFlag, BOOL bSet) | CXTPControl |
SetHideFlags(DWORD dwFlags) | CXTPControlCustom | protectedvirtual
SetHideWrap(BOOL bHide) | CXTPControl |
SetIconId(int nId) | CXTPControl |
SetIconSize(CSize szIcon) | CXTPControl |
SetID(int nId) | CXTPControl |
SetIndex(int nIndex) | CXTPControl | inlineprotected
SetItemDefault(BOOL bDefault) | CXTPControl |
SetKeyboardTip(LPCTSTR lpszKeyboardTip) | CXTPControl |
SetOnQuickAccess(BOOL bOnQuicAccess=FALSE) | CXTPControl |
SetParameter(LPCTSTR lpszParameter) | CXTPControl |
SetParent(CXTPCommandBar *pParent) | CXTPControl | inlineprotectedvirtual
SetPressed(BOOL bPressed) | CXTPControl |
SetPrompt(LPCTSTR lpszPrompt) | CXTPControl |
SetRect(CRect rcControl) | CXTPControlCustom | protectedvirtual
SetRowRect(CRect rcRow) | CXTPControl |
SetShortcutText(LPCTSTR lpszShortcutText) | CXTPControl |
SetSize(CSize szControl) | CXTPControlCustom |
SetStyle(XTPButtonStyle buttonStyle) | CXTPControl |
SetStyleEx(XTPButtonStyle buttonStyle) | CXTPControlButton |
SetTag(DWORD_PTR dwTag) | CXTPControl |
SetTooltip(LPCTSTR lpszTooltip) | CXTPControl |
SetVerticalPositionOption(XTPControlCustomVerticalOptions options) | CXTPControlCustom |
SetVisible(BOOL bVisible) | CXTPControl |
SetWidth(int nWidth) | CXTPControl | virtual
SetWrap(BOOL bWrap) | CXTPControl |
~CXTPControl() | CXTPControl | protectedvirtual
~CXTPControlButton() | CXTPControlButton | virtual
~CXTPControlCustom() | CXTPControlCustom |
~CXTPHookManagerHookAble() | CXTPHookManagerHookAble | virtual


Toolkit Pro: XTPTaskPanelListViewOffice2003Theme.h Source File

  • Source
  • TaskPanel
  • Themes
XTPTaskPanelListViewOffice2003Theme.h
Go to the documentation of this file.
1
23#ifndef XTPTaskPanelListViewOffice2003Theme_h__
24# define XTPTaskPanelListViewOffice2003Theme_h__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
39class _XTP_EXT_CLASS CXTPTaskPanelListViewOffice2003Theme
40 : public CXTPTaskPanelListViewOfficeXPTheme
41{
42public:
47 CXTPTaskPanelListViewOffice2003Theme();
48
53 void RefreshMetrics();
54
55 CXTPPaintManagerColorGradient m_grcHot;
57 CXTPPaintManagerColorGradient m_grcPushed;
73 CRect DrawGroupCaptionBackground(CDC* pDC, CXTPTaskPanelGroup* pGroup, CRect rc);
74};
76# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
77#endif // XTPTaskPanelListViewOffice2003Theme_h__
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPPaintManagerColorGradient
The CXTPPaintManagerColorGradient class is used to manage COLORREF values for determining light and d...
Definition XTPColorManager.h:301
CXTPTaskPanelGroup
CXTPTaskPanelGroup is used in a Task Panel control to represent a group.
Definition XTPTaskPanelGroup.h:45
CXTPTaskPanelListViewOffice2003Theme
CXTPTaskPanelListViewOffice2003Theme represents a List View Office 2003 style theme.
Definition XTPTaskPanelListViewOffice2003Theme.h:41
CXTPTaskPanelListViewOffice2003Theme::m_grcHot
CXTPPaintManagerColorGradient m_grcHot
Color gradient used to colorize "hot" items for this theme.
Definition XTPTaskPanelListViewOffice2003Theme.h:55
CXTPTaskPanelListViewOffice2003Theme::m_grcPushed
CXTPPaintManagerColorGradient m_grcPushed
Color gradient used to colorize "pushed" items for this theme.
Definition XTPTaskPanelListViewOffice2003Theme.h:57
CXTPTaskPanelListViewOffice2003Theme::CXTPTaskPanelListViewOffice2003Theme
CXTPTaskPanelListViewOffice2003Theme()
Constructs a CXTPTaskPanelListViewOffice2003Theme object.
CXTPTaskPanelListViewOffice2003Theme::DrawGroupCaptionBackground
CRect DrawGroupCaptionBackground(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Draws the background of a group caption.
CXTPTaskPanelListViewOffice2003Theme::RefreshMetrics
void RefreshMetrics()
Refreshes the visual metrics of the task panel.
CXTPTaskPanelListViewOfficeXPTheme
CXTPTaskPanelListViewOfficeXPTheme represents a List View Office XP style theme.
Definition XTPTaskPanelListViewOfficeXPTheme.h:40


Toolkit Pro: Member List

CXTPChart2dDiagram Member List

This is the complete list of members for CXTPChart2dDiagram, including all inherited members.

CalculateSeriesLayout(CXTPChartDeviceContext *pDC, CXTPChartDiagramView *pView) | CXTPChartDiagram | virtual
CreateView(CXTPChartDeviceContext *pDC, CXTPChartElementView *pParent) | CXTPChartDiagram | virtual
CXTPChart2dDiagram() | CXTPChart2dDiagram | protected
CXTPChartDiagram() | CXTPChartDiagram | protected
CXTPChartElement() | CXTPChartElement |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartPanel() | CXTPChartPanel |
DoPropExchange(CXTPPropExchange *pPX) | CXTPChartDiagram | virtual
GetAppearance() const | CXTPChartElement |
GetContent() const | CXTPChartElement |
GetOwner() const | CXTPChartElement |
GetSeries() const | CXTPChartDiagram |
GetTitles() const | CXTPChartPanel |
Is3D() const | CXTPChartObject |
m_arrSeries | CXTPChartDiagram | protected
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartElement | virtual
OnSeriesAdded(CXTPChartSeries *pSeries) | CXTPChartDiagram | protectedvirtual
OnSeriesRemoved(CXTPChartSeries *pSeries) | CXTPChartDiagram | protected
Release() | CXTPChartDiagram | protectedvirtual
~CXTPChartElement() | CXTPChartElement | virtual
~CXTPChartPanel() | CXTPChartPanel | virtual


Toolkit Pro: XTPDockingPaneColorSetNativeWindows11.h Source File

  • Source
  • DockingPane
  • ColorSets
XTPDockingPaneColorSetNativeWindows11.h
Go to the documentation of this file.
1
23#if !defined(__XTPDOCKINGPANECOLORSETNATIVEWINDOWS11_H__)
24# define __XTPDOCKINGPANECOLORSETNATIVEWINDOWS11_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPDockingPaneColorSetNativeWindows11 : public CXTPDockingPaneColorSet
39{
40public:
47 virtual void RefreshMetrics(CString strSection);
48};
49
50# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
52#endif // !defined(__XTPDOCKINGPANECOLORSETNATIVEWINDOWS11_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPDockingPaneColorSet
Helper class used to initialize default colors for a theme from an .INI resource.
Definition XTPDockingPaneColorSet.h:39
CXTPDockingPaneColorSetNativeWindows11
Helper class used to initialize default colors for a theme from an .INI resource.
Definition XTPDockingPaneColorSetNativeWindows11.h:39
CXTPDockingPaneColorSetNativeWindows11::RefreshMetrics
virtual void RefreshMetrics(CString strSection)
This member function is used to initialize default colors for a theme from an .INI resource.


Toolkit Pro: XTPDockingPaneThemeOffice2007.h Source File

  • Source
  • DockingPane
  • Themes
XTPDockingPaneThemeOffice2007.h
Go to the documentation of this file.
1
23#if !defined(__XTPDOCKINGPANETHEMEOFFICE2007_H__)
24# define __XTPDOCKINGPANETHEMEOFFICE2007_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
40class _XTP_EXT_CLASS CXTPDockingPaneOffice2007Theme : public CXTPDockingPaneOffice2003Theme
41{
42public:
47 CXTPDockingPaneOffice2007Theme();
48
49public:
54 void RefreshMetrics();
55
63 void DrawCaption(CDC* pDC, CXTPDockingPaneTabbedContainer* pPane, CRect rc);
64};
65
66# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
68#endif // !defined(__XTPDOCKINGPANETHEMEOFFICE2007_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPDockingPaneOffice2003Theme
CXTPDockingPaneOffice2003Theme is a CXTPDockingPaneVisualStudio2003Theme derived class that represent...
Definition XTPDockingPaneThemeOffice2003.h:41
CXTPDockingPaneOffice2007Theme
CXTPDockingPaneOffice2007Theme is a CXTPDockingPaneOffice2003Theme derived class that represents an O...
Definition XTPDockingPaneThemeOffice2007.h:41
CXTPDockingPaneOffice2007Theme::CXTPDockingPaneOffice2007Theme
CXTPDockingPaneOffice2007Theme()
Constructs a CXTPDockingPaneOffice2007Theme object.
CXTPDockingPaneOffice2007Theme::RefreshMetrics
void RefreshMetrics()
This method is called to refresh the visual metrics of the pane.
CXTPDockingPaneOffice2007Theme::DrawCaption
void DrawCaption(CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc)
Override this member function to draw a caption.
CXTPDockingPaneTabbedContainer
CXTPDockingPaneTabbedContainer is a multiple inheritance class derived from CWnd and CXTPDockingPaneB...
Definition XTPDockingPaneTabbedContainer.h:47


Toolkit Pro: Member List

CXTPCalendarViewGroupT< _TViewDay, _TViewEvent, _TPThis > Member List

This is the complete list of members for CXTPCalendarViewGroupT< _TViewDay, _TViewEvent, _TPThis >, including all inherited members.

AddResource(CXTPCalendarResource *pResource, BOOL bWithAddRef) | CXTPCalendarViewGroup | virtual
AdjustLayout(CDC *pDC, const CRect &rcGroup) | CXTPCalendarViewGroup | virtual
AdjustLayout2(CDC *pDC, const CRect &rcGroup) | CXTPCalendarViewGroup | virtual
CXTPCalendarViewGroup(CXTPCalendarViewDay *pViewDay) | CXTPCalendarViewGroup |
CXTPCalendarViewGroupT(_TViewDay *pViewDay) | CXTPCalendarViewGroupT< _TViewDay, _TViewEvent, _TPThis > | inline
CXTPCalendarWMHandler() | CXTPCalendarWMHandler |
CXTPCmdTarget() | CXTPCmdTarget |
Draw(CDC *pDC) | CXTPCalendarViewGroup | virtual
ExchangeEventPlace(CXTPCalendarViewEvent *pViewEvent, int nNewPlace) | CXTPCalendarViewGroup | virtual
FillHitTestEx(XTP_CALENDAR_HITTESTINFO *pHitTest) const =0 | CXTPCalendarViewGroupT< _TViewDay, _TViewEvent, _TPThis > | pure virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCalendarControl() const | CXTPCalendarViewGroup | virtual
GetCaption() const | CXTPCalendarViewGroup | virtual
GetChildHandlerAt(int nIndex) const | CXTPCalendarViewGroup | virtual
GetChildHandlersCount() const | CXTPCalendarViewGroup | virtual
GetDataProvider() const | CXTPCalendarViewGroup | virtual
GetGroupIndex() const | CXTPCalendarViewGroup | virtual
GetHeaderRect() const | CXTPCalendarViewGroup | inlinevirtual
GetPThis()=0 | CXTPCalendarViewGroupT< _TViewDay, _TViewEvent, _TPThis > | protectedpure virtual
GetRect() const | CXTPCalendarViewGroup | inlinevirtual
GetResources() const | CXTPCalendarViewGroup | virtual
GetScheduleID() const | CXTPCalendarViewGroup | virtual
GetTooltipRect(const CPoint &ptHit, const XTP_CALENDAR_HITTESTINFO &hitInfo) const | CXTPCalendarViewGroup | virtual
GetViewDay() const | CXTPCalendarViewGroupT< _TViewDay, _TViewEvent, _TPThis > | inline
GetViewDay_() const | CXTPCalendarViewGroup |
GetViewEvent(int nIndex) const | CXTPCalendarViewGroupT< _TViewDay, _TViewEvent, _TPThis > | inlinevirtual
GetViewEvent_(int nIndex) const | CXTPCalendarViewGroup |
GetViewEventByEvent_(CXTPCalendarEvent *pEvent) const | CXTPCalendarViewGroup | virtual
GetViewEventByPlace_(int nEventPlace) const | CXTPCalendarViewGroup | virtual
GetViewEventsCount() const | CXTPCalendarViewGroup |
HitTest(CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const | CXTPCalendarViewGroup | virtual
HitTestEx(CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const | CXTPCalendarViewGroup | virtual
KillTimer(UINT uTimerID) | CXTPCalendarViewGroup | protectedvirtual
m_arEvents | CXTPCalendarViewGroup | protected
m_Layout | CXTPCalendarViewGroup | protected
m_pResources | CXTPCalendarViewGroup | protected
m_pViewDay | CXTPCalendarViewGroup | protected
OnBeforeDestroy() | CXTPCalendarWMHandler | virtual
OnChar(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnKeyUp(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnLButtonDblClk(UINT nFlags, CPoint point) | CXTPCalendarWMHandler | virtual
OnLButtonDown(UINT nFlags, CPoint point) | CXTPCalendarWMHandler | virtual
OnLButtonUp(UINT nFlags, CPoint point) | CXTPCalendarWMHandler | virtual
OnMouseMove(UINT nFlags, CPoint point) | CXTPCalendarWMHandler | virtual
OnPostAdjustLayout() | CXTPCalendarWMHandler | virtual
OnPrePopulate(CXTPCalendarEvents *pEvents) | CXTPCalendarViewGroup | protectedvirtual
OnSysKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnTimer(UINT_PTR uTimerID) | CXTPCalendarWMHandler | virtual
OnWndMsg(UINT message, WPARAM wParam, LPARAM lParam, LRESULT *pResult) | CXTPCalendarWMHandler | virtual
Populate(COleDateTime dtDayDate) | CXTPCalendarViewGroup | virtual
SetResources(CXTPCalendarResources *pResources) | CXTPCalendarViewGroup | virtual
SetTimer(UINT uTimeOut_ms) | CXTPCalendarViewGroup | protectedvirtual
TViewDay typedef | CXTPCalendarViewGroupT< _TViewDay, _TViewEvent, _TPThis > |
~CXTPCalendarViewGroup() | CXTPCalendarViewGroup | virtual
~CXTPCalendarViewGroupT() | CXTPCalendarViewGroupT< _TViewDay, _TViewEvent, _TPThis > | inlinevirtual


Toolkit Pro: Member List

CXTPSizeIcon Member List

This is the complete list of members for CXTPSizeIcon, including all inherited members.

CXTPSizeIcon() | CXTPSizeIcon |
m_hCursor | CXTPSizeIcon | protected
~CXTPSizeIcon() | CXTPSizeIcon | virtual


Toolkit Pro: XTPDockingPanePanelThemeNativeWindows10.h Source File

  • Source
  • DockingPane
  • TabThemes
XTPDockingPanePanelThemeNativeWindows10.h
Go to the documentation of this file.
1
23#if !defined(__XTPDOCKINGPANEPANELTHEMENATIVEWINDOWS10_H__)
24# define __XTPDOCKINGPANEPANELTHEMENATIVEWINDOWS10_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPDockingPanePanelThemeNativeWindows10 : public CXTPDockingPanePanelTheme2012
39{
40public:
45 CXTPDockingPanePanelThemeNativeWindows10();
46};
47
48# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
50#endif // !defined(__XTPDOCKINGPANEPANELTHEMENATIVEWINDOWS10_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPDockingPanePanelTheme2012
Helper class used to initialize default colors for a theme from an .INI resource and handle drawing r...
Definition XTPDockingPanePanelTheme2012.h:39
CXTPDockingPanePanelThemeNativeWindows10
Helper class used to initialize default colors for a theme from an .INI resource and handle drawing r...
Definition XTPDockingPanePanelThemeNativeWindows10.h:39
CXTPDockingPanePanelThemeNativeWindows10::CXTPDockingPanePanelThemeNativeWindows10
CXTPDockingPanePanelThemeNativeWindows10()
Default class constructor.


Toolkit Pro: Member List

CXTPControlProgress Member List

This is the complete list of members for CXTPControlProgress, including all inherited members.

AssignDocTemplate(UINT nIDResource) | CXTPControl |
ClickToolBarButton(CRect rcActiveRect=CRect(0, 0, 0, 0)) | CXTPControl | protected
Compare(CXTPControl *pOther) | CXTPControl | virtual
Copy(CXTPControl *pControl, BOOL bRecursive=FALSE) | CXTPControlProgress | protectedvirtual
CustomizeStartDrag(CPoint point) | CXTPControl | protectedvirtual
CustomizeStartResize(CPoint point) | CXTPControl | protectedvirtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPControl() | CXTPControl | protected
CXTPControlProgress() | CXTPControlProgress |
CXTPProgressBase() | CXTPProgressBase |
DelayLayoutParent() | CXTPControl |
DelayRedrawParent() | CXTPControl |
DoCustomDragOver(CXTPCommandBar *pCommandBar, CPoint point, DROPEFFECT &dropEffect) | CXTPControl | protectedvirtual
DoPropExchange(CXTPPropExchange *pPX) | CXTPControlProgress | protectedvirtual
Draw(CDC *pDC) | CXTPControlProgress | protectedvirtual
ExcludeDocTemplate(UINT nIDResource) | CXTPControl |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
FromUI(CCmdUI *pCmdUI) | CXTPControl | static
GenerateCommandBarList(DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam) | CXTPControl | protectedvirtual
GetAction() const | CXTPControl |
GetBeginGroup() const | CXTPControl |
GetButtonSize() const | CXTPControl | virtual
GetCaption() const | CXTPControl | virtual
GetCategory() const | CXTPControl |
GetChecked() const | CXTPControl |
GetCloseSubMenuOnClick() const | CXTPControl |
GetCommandBar() const | CXTPControl | virtual
GetControls() const | CXTPControl |
GetCustomizeMinHeight() const | CXTPControl | protectedvirtual
GetCustomizeMinWidth() const | CXTPControl | protectedvirtual
GetCustomShortcutText() const | CXTPControl |
GetDescription() const | CXTPControl | virtual
GetEnabled() const | CXTPControl |
GetExecuteOnPressInterval() const | CXTPControl |
GetExpanded() const | CXTPControl |
GetFlags() const | CXTPControl |
GetHeight() const | CXTPControl |
GetHelpId() const | CXTPControl |
GetHideFlags() const | CXTPControl |
GetIconId() const | CXTPControl |
GetIconSize() const | CXTPControl | virtual
GetID() const | CXTPControl |
GetImage(int nWidth=16) const | CXTPControl | virtual
GetImageManager() const | CXTPControl |
GetIndex() const | CXTPControl |
GetKeyboardTip() const | CXTPControl |
GetPaintManager() const | CXTPControl |
GetParameter() const | CXTPControl |
GetParent() const | CXTPControl |
GetPopuped() const | CXTPControl | virtual
GetPos() const | CXTPProgressBase |
GetPressed() const | CXTPControl | virtual
GetProgressPaintManager() const | CXTPControlProgress | protectedvirtual
GetProgressRect() | CXTPControlProgress | protectedvirtual
GetRange(int &nLower, int &nUpper) const | CXTPProgressBase |
GetRect() const | CXTPControl |
GetRibbonGroup() const | CXTPControl |
GetRowRect() const | CXTPControl |
GetSelected() const | CXTPControl | virtual
GetShortcutText() const | CXTPControl |
GetSize(CDC *pDC) | CXTPControlProgress | protectedvirtual
GetStyle() const | CXTPControl |
GetTag() const | CXTPControl |
GetTooltip() const | CXTPControl | virtual
GetType() const | CXTPControl |
GetWidth() const | CXTPControl |
GetWrap() const | CXTPControl |
HasDwmCompositedRect() const | CXTPControl |
IsCaptionVisible() const | CXTPControl | virtual
IsCursorOver() const | CXTPControl |
IsCustomizeMode() const | CXTPControl | protected
IsCustomizeMovable() const | CXTPControl | virtual
IsCustomizeResizeAllow() const | CXTPControl | protectedvirtual
IsFocusable() const | CXTPControl | protectedvirtual
IsFocused() const | CXTPControl | virtual
IsItemDefault() const | CXTPControl |
IsLayoutChanged() | CXTPControl | protected
IsLayoutRTL() const | CXTPControl | protected
IsOnQuickAccess() const | CXTPControl |
IsTemporary() const | CXTPControl |
IsTransparent() const | CXTPControl | inlinevirtual
IsVisible(DWORD dwSkipFlags=0) const | CXTPControl | virtual
m_bBeginGroup | CXTPControl | protected
m_bChecked | CXTPControl | protected
m_bCloseSubMenuOnClick | CXTPControl | protected
m_bDefaultItem | CXTPControl | protected
m_bEnabled | CXTPControl | protected
m_bExpanded | CXTPControl | protected
m_bLayoutRTL | CXTPControl | protected
m_bOnQuickAccess | CXTPControl | protected
m_bPressed | CXTPControl | protected
m_bSelected | CXTPControl | protected
m_bTemporary | CXTPControl | protected
m_buttonCustomStyle | CXTPControl | protected
m_buttonRibbonStyle | CXTPControl | protected
m_buttonStyle | CXTPControl | protected
m_bWrap | CXTPControl | protected
m_controlType | CXTPControl | protected
m_dwFlags | CXTPControl | protected
m_dwHideFlags | CXTPControl | protected
m_mapDocTemplatesAssigned | CXTPControl | protected
m_mapDocTemplatesExcluded | CXTPControl | protected
m_nCustomIconId | CXTPControl | protected
m_nExecuteOnPressInterval | CXTPControl | protected
m_nHeight | CXTPControl | protected
m_nHelpId | CXTPControl | protected
m_nIconId | CXTPControl | protected
m_nId | CXTPControl | protected
m_nIndex | CXTPControl | protected
m_nMax | CXTPProgressBase | protected
m_nMin | CXTPProgressBase | protected
m_nPos | CXTPProgressBase | protected
m_nTag | CXTPControl | protected
m_nWidth | CXTPControl | protected
m_pAction | CXTPControl | protected
m_pControls | CXTPControl | protected
m_pParent | CXTPControl | protected
m_pRibbonGroup | CXTPControl | protected
m_rcControl | CXTPControl | protected
m_rcRow | CXTPControl | protected
m_strCaption | CXTPControl | protected
m_strCategory | CXTPControl | protected
m_strCustomCaption | CXTPControl | protected
m_strDescriptionText | CXTPControl | protected
m_strKeyboardTip | CXTPControl | protected
m_strParameter | CXTPControl | protected
m_strShortcutText | CXTPControl | protected
m_strShortcutTextAuto | CXTPControl | protected
m_strTooltipText | CXTPControl | protected
m_szIcon | CXTPControl | protected
NotifySite(UINT code) | CXTPControl |
NotifySite(UINT code, NMXTPCONTROL *pNM) | CXTPControl |
NotifySite(CWnd *pSite, UINT code, NMXTPCONTROL *pNM) | CXTPControl |
OnActionChanged(int nProperty) | CXTPControl | protectedvirtual
OnActionChanging(int nProperty) | CXTPControl | protectedvirtual
OnCalcDynamicSize(DWORD dwMode) | CXTPControl | virtual
OnCaptionChanged() | CXTPControl | protectedvirtual
OnClick(BOOL bKeyboard=FALSE, CPoint pt=CPoint(0, 0)) | CXTPControlProgress | protectedvirtual
OnCustomizeDragOver(CXTPControl *pDataObject, CPoint point, DROPEFFECT &dropEffect) | CXTPControl | protectedvirtual
OnCustomizeMouseMove(CPoint point) | CXTPControl | protected
OnEnabledChanged() | CXTPControl | virtual
OnExecute() | CXTPControl | virtual
OnHookKeyDown(UINT nChar, LPARAM lParam) | CXTPControl | protectedvirtual
OnHookMouseWheel(UINT nFlags, short zDelta, CPoint point) | CXTPControl | protectedvirtual
OnIdleUpdate() | CXTPControl | protectedvirtual
OnLButtonDblClk(CPoint point) | CXTPControl | protectedvirtual
OnLButtonDown(CPoint point) | CXTPControl | protectedvirtual
OnLButtonUp(CPoint point) | CXTPControl | protectedvirtual
OnMouseHover() | CXTPControl | protectedvirtual
OnMouseMove(CPoint point) | CXTPControl | protectedvirtual
OnRButtonDown(CPoint point) | CXTPControl | protectedvirtual
OnRButtonUp(CPoint point) | CXTPControl | protectedvirtual
OnRemoved() | CXTPControl | protectedvirtual
OnSetPopup(BOOL bPopup) | CXTPControl | protectedvirtual
OnSetSelected(int bSelected) | CXTPControl | protectedvirtual
OnThemeChanged() | CXTPControl | virtual
OnToolHitTest(CPoint point, TOOLINFO *pTI) const | CXTPControl | protectedvirtual
OnUnderlineActivate() | CXTPControl | virtual
RedrawParent(BOOL bAnimate=TRUE) | CXTPControl |
RedrawProgress() | CXTPControlProgress | protectedvirtual
Reset() | CXTPControl |
RestoreCommandBarList(CXTPCommandBarList *pCommandBarList) | CXTPControl | protectedvirtual
ScreenToClient(CPoint *point) | CXTPControl | protected
SetAction(CXTPControlAction *pAction) | CXTPControl | virtual
SetBeginGroup(BOOL bBeginGroup) | CXTPControl | virtual
SetCaption(LPCTSTR lpszCaption) | CXTPControl |
SetCaption(UINT nIDCaption) | CXTPControl |
SetCategory(LPCTSTR lpszCategory) | CXTPControl |
SetChecked(BOOL bChecked) | CXTPControl | virtual
SetCloseSubMenuOnClick(BOOL bCloseOnClick) | CXTPControl |
SetCustomIcon(HICON hIcon) | CXTPControl |
SetCustomShortcutText(LPCTSTR lpszCustomShortcutText) | CXTPControl |
SetDescription(LPCTSTR lpszDescription) | CXTPControl |
SetEnabled(BOOL bEnabled) | CXTPControl | virtual
SetExecuteOnPressInterval(int nExecuteOnPressInterval) | CXTPControl |
SetExpanded(BOOL bExpanded) | CXTPControl | protected
SetFlags(DWORD dwFlags) | CXTPControl |
SetFocused(BOOL bFocused) | CXTPControl | virtual
SetHeight(int nHeight) | CXTPControl | virtual
SetHelpId(int nId) | CXTPControl |
SetHideFlag(XTPControlHideFlags dwFlag, BOOL bSet) | CXTPControl |
SetHideFlags(DWORD dwFlags) | CXTPControl | virtual
SetHideWrap(BOOL bHide) | CXTPControl |
SetIconId(int nId) | CXTPControl |
SetIconSize(CSize szIcon) | CXTPControl |
SetID(int nId) | CXTPControl |
SetIndex(int nIndex) | CXTPControl | inlineprotected
SetItemDefault(BOOL bDefault) | CXTPControl |
SetKeyboardTip(LPCTSTR lpszKeyboardTip) | CXTPControl |
SetOnQuickAccess(BOOL bOnQuicAccess=FALSE) | CXTPControl |
SetParameter(LPCTSTR lpszParameter) | CXTPControl |
SetParent(CXTPCommandBar *pParent) | CXTPControl | inlineprotectedvirtual
SetPos(int nPos) | CXTPProgressBase |
SetPressed(BOOL bPressed) | CXTPControl |
SetPrompt(LPCTSTR lpszPrompt) | CXTPControl |
SetRange(int nLower, int nUpper) | CXTPProgressBase |
SetRect(CRect rcControl) | CXTPControl | virtual
SetRowRect(CRect rcRow) | CXTPControl |
SetShortcutText(LPCTSTR lpszShortcutText) | CXTPControl |
SetStyle(XTPButtonStyle buttonStyle) | CXTPControl |
SetTag(DWORD_PTR dwTag) | CXTPControl |
SetTooltip(LPCTSTR lpszTooltip) | CXTPControl |
SetVisible(BOOL bVisible) | CXTPControl |
SetWidth(int nWidth) | CXTPControl | virtual
SetWrap(BOOL bWrap) | CXTPControl |
~CXTPControl() | CXTPControl | protectedvirtual
~CXTPProgressBase() | CXTPProgressBase | virtual


Toolkit Pro: Member List

CXTPSyntaxEditUndoRedoManager Member List

This is the complete list of members for CXTPSyntaxEditUndoRedoManager, including all inherited members.

AddCommand(CXTPSyntaxEditCommand *pCommand) | CXTPSyntaxEditUndoRedoManager |
CanRedo() const | CXTPSyntaxEditUndoRedoManager |
CanUndo() const | CXTPSyntaxEditUndoRedoManager |
ChainLastCommand() | CXTPSyntaxEditUndoRedoManager |
Clear() | CXTPSyntaxEditUndoRedoManager |
CXTPSyntaxEditUndoRedoManager() | CXTPSyntaxEditUndoRedoManager |
DoRedo(XTP_EDIT_LINECOL &lcFrom, XTP_EDIT_LINECOL &lcTo, CXTPSyntaxEditCtrl *pEditCtrl) | CXTPSyntaxEditUndoRedoManager |
DoUndo(XTP_EDIT_LINECOL &lcFrom, XTP_EDIT_LINECOL &lcTo, CXTPSyntaxEditCtrl *pEditCtrl) | CXTPSyntaxEditUndoRedoManager |
GetDataSize() const | CXTPSyntaxEditUndoRedoManager | virtual
GetRedoTextList() | CXTPSyntaxEditUndoRedoManager |
GetUndoTextList() | CXTPSyntaxEditUndoRedoManager |
IsModified() const | CXTPSyntaxEditUndoRedoManager |
LimitDataSize(int nNewCommandData, int nDataSizeLimit) | CXTPSyntaxEditUndoRedoManager | virtual
m_bGroupInsertMode | CXTPSyntaxEditUndoRedoManager | protected
m_CommandList | CXTPSyntaxEditUndoRedoManager | protected
m_nDataSizeLimit | CXTPSyntaxEditUndoRedoManager | protected
m_posFirstUndo | CXTPSyntaxEditUndoRedoManager | protected
m_posSavedMark | CXTPSyntaxEditUndoRedoManager | protected
MarkSaved() | CXTPSyntaxEditUndoRedoManager |
SetGroupInsertMode(BOOL bInsertInGroup=TRUE) | CXTPSyntaxEditUndoRedoManager |
SetLastCommandText(LPCTSTR szText) | CXTPSyntaxEditUndoRedoManager |
SetLastCommandText(UINT nTextId) | CXTPSyntaxEditUndoRedoManager |
~CXTPSyntaxEditUndoRedoManager() | CXTPSyntaxEditUndoRedoManager | virtual


Toolkit Pro: Member List

CXTPExcelTabCtrlThemeOffice2013 Member List

This is the complete list of members for CXTPExcelTabCtrlThemeOffice2013, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPControlTheme() | CXTPControlTheme |
CXTPExcelTabCtrlTheme() | CXTPExcelTabCtrlTheme |
CXTPExcelTabCtrlThemeOffice2013() | CXTPExcelTabCtrlThemeOffice2013 |
DrawButton(CDC *pDC, CXTPExcelTabCtrl *pTabCtrl, const CXTPExcelTabCtrlButtonState &state) | CXTPExcelTabCtrlThemeOffice2013 | virtual
DrawButtonBack(CDC *pDC, CRect &rect, const CXTPExcelTabCtrlButtonState &state) | CXTPExcelTabCtrlThemeOffice2013 | virtual
DrawGripper(CDC *pDC, CRect rect) | CXTPExcelTabCtrlThemeOffice2013 | virtual
DrawTab(CDC *pDC, CXTPExcelTabCtrl *pTabCtrl, const CPoint &pt, bool bSelected, CXTPTcbItem *pTcbItem) | CXTPExcelTabCtrlThemeOffice2013 | virtual
FillBackground(CDC *pDC, CRect &rect, BOOL bBottom) | CXTPExcelTabCtrlThemeOffice2013 | virtual
FillTabsBackground(CDC *pDC, int cx, int cy) | CXTPExcelTabCtrlThemeOffice2013 | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetSelTabBackColor(CXTPTcbItem *pTcbItem) const | CXTPExcelTabCtrlTheme | virtual
GetSelTabTextColor(CXTPTcbItem *pTcbItem) const | CXTPExcelTabCtrlTheme | virtual
GetTabBackColor(CXTPTcbItem *pTcbItem) const | CXTPExcelTabCtrlTheme | virtual
GetTabTextColor(CXTPTcbItem *pTcbItem) const | CXTPExcelTabCtrlTheme | virtual
GetThemeStyle() const | CXTPControlTheme |
m_clr3DFace | CXTPExcelTabCtrlTheme |
m_clr3DFaceHilite | CXTPExcelTabCtrlTheme |
m_clr3DFacePushed | CXTPExcelTabCtrlTheme |
m_clr3DHilight | CXTPExcelTabCtrlTheme |
m_clr3DShadow | CXTPExcelTabCtrlTheme |
m_clrBorder3DHilite | CXTPExcelTabCtrlTheme |
m_clrBorder3DShadow | CXTPExcelTabCtrlTheme |
m_clrBtnText | CXTPExcelTabCtrlTheme |
m_clrBtnTextGray | CXTPExcelTabCtrlTheme |
m_clrBtnTextHilite | CXTPExcelTabCtrlTheme |
m_clrBtnTextPushed | CXTPExcelTabCtrlTheme |
m_clrWindow | CXTPExcelTabCtrlTheme |
m_clrWindowText | CXTPExcelTabCtrlTheme |
m_nTheme | CXTPControlTheme | protected
RefreshMetrics(CXTPExcelTabCtrl *pTab) | CXTPExcelTabCtrlThemeOffice2013 | virtual
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static
~CXTPExcelTabCtrlTheme() | CXTPExcelTabCtrlTheme |


Toolkit Pro: Member List

CXTPChartBoundedTextDeviceCommand Member List

This is the complete list of members for CXTPChartBoundedTextDeviceCommand, including all inherited members.

AddChildCommand(CXTPChartDeviceCommand *pCommand) | CXTPChartDeviceCommand |
AfterExecute(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
ApplySeriesStyle(CXTPChartSeriesStyle *pStyle) | CXTPChartDeviceCommand | virtual
BeforeExecute(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
BindView(CXTPChartElementView *pView) | CXTPChartDeviceCommand |
Commit() | CXTPChartDeviceCommand |
CXTPChartBoundedTextDeviceCommand(const CXTPChartString &strText, CXTPChartFont *pFont, const CXTPChartColor &color, const CXTPChartRectF &rectangle) | CXTPChartBoundedTextDeviceCommand |
CXTPChartDeviceCommand() | CXTPChartDeviceCommand |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartTextDeviceCommand(const CXTPChartString &strText, CXTPChartFont *pFont, const CXTPChartColor &color) | CXTPChartTextDeviceCommand | protected
CXTPObservable() | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | protected
Execute(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
ExecuteInternal(CXTPChartDeviceContext *pDC) | CXTPChartTextDeviceCommand | protectedvirtual
ExecuteOverride(CXTPChartDeviceContext *pDC) | CXTPChartTextDeviceCommand | protectedvirtual
GetBoundView() const | CXTPChartDeviceCommand |
GetChildCommand(int nIndex) const | CXTPChartDeviceCommand |
GetChildCommandCount() const | CXTPChartDeviceCommand |
GetCurrentDC() const | CXTPChartDeviceCommand |
GetPassNumber() const | CXTPChartDeviceCommand |
HitTest(CPoint point, CXTPChartElement *pParent) const | CXTPChartBoundedTextDeviceCommand | virtual
Is3D() const | CXTPChartObject |
IsCommitted() const | CXTPChartDeviceCommand |
IsEnabled() const | CXTPChartDeviceCommand | virtual
m_arrChildren | CXTPChartDeviceCommand | protected
m_color | CXTPChartTextDeviceCommand | protected
m_pFont | CXTPChartTextDeviceCommand | protected
m_rect | CXTPChartBoundedTextDeviceCommand | protected
m_strText | CXTPChartTextDeviceCommand | protected
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Prepare(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
PrepareOverride(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
SetEnabled(BOOL bEnabled=TRUE) | CXTPChartDeviceCommand |
Subscribe(CXTPChartDeviceCommandEvents *pObserver, CXTPSubscriptionList< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > *pSubcriptionList=NULL) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > |
Unsubscribe(CXTPChartDeviceCommandEvents *pObserver) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > |
~CXTPChartDeviceCommand() | CXTPChartDeviceCommand | virtual
~CXTPObservable() | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | protected


Toolkit Pro: Member List

CXTPSyntaxEditCommand Member List

This is the complete list of members for CXTPSyntaxEditCommand, including all inherited members.

CXTPSyntaxEditCommand() | CXTPSyntaxEditCommand | protected
Execute(XTP_EDIT_LINECOL &lcFrom, XTP_EDIT_LINECOL &lcTo, CXTPSyntaxEditCtrl *pEditCtrl)=0 | CXTPSyntaxEditCommand | pure virtual
GetCommandText() const | CXTPSyntaxEditCommand | virtual
GetDataSize() const | CXTPSyntaxEditCommand | virtual
m_strCommandText | CXTPSyntaxEditCommand | protected
SetCommandText(LPCTSTR szText) | CXTPSyntaxEditCommand | virtual
SetPositionInternally(CXTPSyntaxEditCtrl *pEditCtrl, const XTP_EDIT_LINECOL &lcPos) | CXTPSyntaxEditCommand | protectedstatic
UnExecute(XTP_EDIT_LINECOL &lcFrom, XTP_EDIT_LINECOL &lcTo, CXTPSyntaxEditCtrl *pEditCtrl)=0 | CXTPSyntaxEditCommand | pure virtual
~CXTPSyntaxEditCommand() | CXTPSyntaxEditCommand | virtual


Toolkit Pro: Member List

CXTPTrackThemeVisualStudio2012Dark Member List

This is the complete list of members for CXTPTrackThemeVisualStudio2012Dark, including all inherited members.

CalcColumnHeight(CDC *pDC, CXTPGridColumn *pColumn, int nTotalWidth=0) | CXTPGridPaintManager | protectedvirtual
CalculateRowHeight(CDC *pDC, const CString &strText, int nMaxWidth, BOOL bWordBreak=TRUE) | CXTPGridPaintManager | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPGridPaintManager() | CXTPGridPaintManager |
CXTPTrackPaintManager() | CXTPTrackPaintManager |
CXTPTrackThemeOffice2013() | CXTPTrackThemeOffice2013 |
CXTPTrackThemeVisualStudio2012Dark() | CXTPTrackThemeVisualStudio2012Dark |
DrawBitmap(CDC *pDC, CXTPGridControl *pControl, CRect rcColumn, int iImage) | CXTPGridPaintManager | virtual
DrawCollapsedBitmap(CDC *pDC, const CXTPGridRow *pRow, CRect &rcBitmap) | CXTPGridPaintManager | virtual
DrawColumn(CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn, BOOL bDrawExternal=FALSE, int nShadowWidth=0) | CXTPGridPaintManager | virtual
DrawColumnBackground(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, BOOL &bColumnPressed, BOOL &bDraggingFromHeader, CXTPGridHeader *pHeader=NULL) | CXTPTrackThemeOffice2013 | virtual
DrawColumnFooter(CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn) | CXTPGridPaintManager | virtual
DrawColumnFooterDivider(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn) | CXTPGridPaintManager | virtual
DrawColumnIcon(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, CRect rcIcon, int iIcon) | CXTPGridPaintManager | virtual
DrawColumnText(CDC *pDC, CRect rcText, CString strCaption, int nHeaderAlignment, BOOL bIsHeader, BOOL bColumnPressed) | CXTPTrackThemeOffice2013 | virtual
DrawConnector(CDC *pDC, CPoint ptFrom, CPoint ptTo) | CXTPGridPaintManager |
DrawFocusedRow(CDC *pDC, CRect rcRow) | CXTPTrackThemeOffice2013 | virtual
DrawFreezeColsDivider(CDC *pDC, const CRect &rc, CXTPGridControl *pControl, CXTPGridRow *pRow=NULL) | CXTPGridPaintManager | virtual
DrawGlyph(CDC *pDC, CRect rcColumn, int iImage) | CXTPGridPaintManager | virtual
DrawGrid(CDC *pDC, XTPGridOrientation orientation, CRect rcGrid) | CXTPGridPaintManager | virtual
DrawGridPattern(CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush) | CXTPGridPaintManager | protectedvirtual
DrawGridPattern(CDC *pDC, CXTPBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush) | CXTPGridPaintManager | protectedvirtual
DrawGridPattern(CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr) | CXTPGridPaintManager | protectedvirtual
DrawGroupRow(CDC *pDC, CXTPGridGroupRow *pRow, CRect rcRow, XTP_GRIDRECORDITEM_METRICS *pMetrics) | CXTPTrackThemeOffice2013 | virtual
DrawHorizontalLine(CDC *pDC, int xPos, int yPos, int cx, COLORREF clr) | CXTPGridPaintManager |
DrawInplaceButton(CDC *pDC, CXTPGridInplaceButton *pButton) | CXTPGridPaintManager | virtual
DrawInplaceButtonFrame(CDC *pDC, CXTPGridInplaceButton *pButton) | CXTPGridPaintManager | protectedvirtual
DrawInplaceButtonIcon(CDC *pDC, CXTPGridInplaceButton *pButton) | CXTPGridPaintManager | protectedvirtual
DrawInplaceComboButton(CDC *pDC, CRect *pRc) | CXTPGridPaintManager | virtual
DrawInplaceExpandButton(CDC *pDC, CRect *pRc) | CXTPGridPaintManager | virtual
DrawInplaceSpinButton(CDC *pDC, CRect *pRc) | CXTPGridPaintManager | virtual
DrawItemBitmap(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CRect &rcItem, int nImage) | CXTPGridPaintManager | virtual
DrawItemCaption(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics) | CXTPGridPaintManager | virtual
DrawItemControl(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CXTPGridRecordItemControl *pControl, CRect &rcItem) | CXTPGridPaintManager | virtual
DrawLink(int *pnCurrDrawPos, XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CXTPGridHyperlink *pHyperlink, CString strText, CRect rcLink, int nFlag, BOOL bTrim=FALSE) | CXTPGridPaintManager | protectedvirtual
DrawMarkers(CDC *pDC) | CXTPTrackPaintManager | virtual
DrawMultiLineText(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, BOOL bWordBreak=TRUE) | CXTPGridPaintManager | protectedvirtual
DrawNoGroupByText(CDC *pDC, CRect rcItem) | CXTPGridPaintManager | virtual
DrawRowNumber(CDC *pDC, CRect rcNumber, CXTPGridRow *pRow) | CXTPGridPaintManager | virtual
DrawSectionDivider(CDC *pDC, const CRect &rc, XTPGridSectionDividerPosition dividerPosition, XTPGridSectionDividerStyle dividerStyle, CXTPPaintManagerColor dividerColor) | CXTPGridPaintManager |
DrawShellIcon(CDC *pDC, CRect rcColumn, int iImage) | CXTPGridPaintManager | virtual
DrawSingleLineText(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nStartPos, int nEndPos, int nActualWidth) | CXTPGridPaintManager | protectedvirtual
DrawString(int *pnCurrDrawPos, CDC *pDC, const CString &strDraw, CRect rcDraw, UINT nFormat) | CXTPGridPaintManager | protectedvirtual
DrawTextLine(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nFlag, int &nCharCounter, int &nHyperlinkCounter) | CXTPGridPaintManager | protectedvirtual
DrawTimeLine(CDC *pDC) | CXTPTrackPaintManager | virtual
DrawTrackHeader(CDC *pDC) | CXTPTrackPaintManager | virtual
DrawTreeStructure(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CRect rcItem, CSize sizeGlyph) | CXTPGridPaintManager | virtual
DrawTriangle(CDC *pDC, CRect rcTriangle, BOOL bToDown, BOOL bDraggingFromHeader, int nShadowWidth, BOOL bColumnPressed) | CXTPTrackThemeOffice2013 | virtual
DrawVerticalLine(CDC *pDC, int xPos, int yPos, int cy, COLORREF clr) | CXTPGridPaintManager |
DrawVerticalTimeLineMarker(CDC *pDC, int xPos, CXTPGridControl *pControl, COLORREF color=RGB(0, 255, 0)) | CXTPGridPaintManager | virtual
EnablePreviewMode(BOOL bIsPreviewMode) | CXTPGridPaintManager |
FillFooter(CDC *pDC, CRect rcFooter) | CXTPGridPaintManager | virtual
FillGroupByControl(CDC *pDC, CRect &rcGroupBy) | CXTPGridPaintManager | virtual
FillGroupRowMetrics(CXTPGridGroupRow *pRow, XTP_GRIDRECORDITEM_METRICS *pMetrics, BOOL bPrinting) | CXTPTrackThemeOffice2013 | virtual
FillHeaderControl(CDC *pDC, CRect rcHeader) | CXTPGridPaintManager | virtual
FillIndent(CDC *pDC, CRect rcRow) | CXTPGridPaintManager | virtual
FillItemShade(CDC *pDC, CRect rcItem) | CXTPGridPaintManager | virtual
FillRow(CDC *pDC, CXTPGridRow *pRow, CRect rcRow) | CXTPGridPaintManager | virtual
FindRowAdjacentToMerged(const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, BOOL bUpward) | CXTPGridPaintManager |
FindRowAdjacentToMergedEx(const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, int &nAdjRowIndex, BOOL bUpward) | CXTPGridPaintManager |
FormatTime(int nPosition) | CXTPTrackPaintManager | virtual
FormatTimeLineTick(int nPosition, COLORREF &clrTick, int &nTickLength) | CXTPTrackPaintManager | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetColumnOffice2007CustomThemeBaseColor() const | CXTPGridPaintManager |
GetColumnStyle() const | CXTPGridPaintManager |
GetControlBackColor(CXTPGridControl *pControl) | CXTPGridPaintManager | virtual
GetFooterHeight(CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0) | CXTPGridPaintManager | virtual
GetFreezeColsDividerStyle() const | CXTPGridPaintManager |
GetGlyphs() const | CXTPGridPaintManager |
GetHeaderHeight() | CXTPGridPaintManager | virtual
GetHeaderHeight(CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0) | CXTPGridPaintManager | virtual
GetItemHeight(XTP_GRIDRECORDITEM_DRAWARGS &drawArgs, int nWidth) | CXTPGridPaintManager |
GetMaxPreviewLines() | CXTPGridPaintManager |
GetPreviewItemHeight(CDC *pDC, CXTPGridRow *pRow, int nWidth, int nHeight) | CXTPGridPaintManager | virtual
GetPreviewLinesCount(CDC *pDC, CRect &rcText, const CString &strText) | CXTPGridPaintManager |
GetRowHeight(CDC *pDC, CXTPGridRow *pRow) | CXTPTrackThemeOffice2013 | virtual
CXTPTrackPaintManager::GetRowHeight(CDC *pDC, CXTPGridRow *pRow, int nTotalWidth) | CXTPGridPaintManager | virtual
GetRowHeightEx(CDC *pDC, CXTPGridRow *pRow, int nTotalWidth, const BOOL firstLevel=TRUE) | CXTPGridPaintManager |
GetSectionDividerHeight(XTPGridFixedRowsDividerStyle dividerStyle) | CXTPGridPaintManager |
GetTextFont() | CXTPGridPaintManager |
IsColumHotTrackingEnabled() const | CXTPGridPaintManager | virtual
IsColumnPlusMinusSign() const | CXTPGridPaintManager |
IsColumnWidthWYSIWYG() const | CXTPGridPaintManager |
IsDrawGridForEmptySpace() const | CXTPGridPaintManager |
IsFixedInplaceButtonHeight() const | CXTPGridPaintManager |
IsFixedRowHeight() const | CXTPGridPaintManager |
IsGridVisible(BOOL bVertical) const | CXTPGridPaintManager |
IsGridVisible(XTPGridOrientation orientation) const | CXTPGridPaintManager |
IsLastColumnWidthWYSIWYG() const | CXTPGridPaintManager |
IsPreviewMode() const | CXTPGridPaintManager |
IsPrintGroupRowIcon() const | CXTPGridPaintManager |
IsShowWYSIWYGMarkers() const | CXTPGridPaintManager |
IsUseDropMarker() const | CXTPGridPaintManager |
LoadGlyphs() | CXTPTrackThemeVisualStudio2012Dark | virtual
m_arStartCol | CXTPGridPaintManager |
m_bAllowMergeCells | CXTPGridPaintManager |
m_bBaseTreeIndent | CXTPGridPaintManager |
m_bCleanTooltip | CXTPGridPaintManager |
m_bColumnPlusMinusSign | CXTPGridPaintManager | protected
m_bColumnWidthWYSIWYG | CXTPGridPaintManager | protected
m_bCompactText | CXTPGridPaintManager |
m_bDrawGridForEmptySpace | CXTPGridPaintManager | protected
m_bFixedInplaceButtonHeight | CXTPGridPaintManager | protected
m_bFixedRowHeight | CXTPGridPaintManager | protected
m_bForceDynamicMarkupForCell | CXTPGridPaintManager |
m_bForceShowDropMarker | CXTPGridPaintManager |
m_bForceShowTooltip | CXTPGridPaintManager |
m_bGrayIfDisable | CXTPGridPaintManager |
m_bGroupRowTextBold | CXTPGridPaintManager |
m_bHideSelection | CXTPGridPaintManager |
m_bHotTracking | CXTPGridPaintManager |
m_bInvertColumnOnClick | CXTPGridPaintManager |
m_bIsPreviewMode | CXTPGridPaintManager | protected
m_bLastColumnWidthWYSIWYG | CXTPGridPaintManager | protected
m_bMakeUpper | CXTPGridPaintManager |
m_bMoveScrollbarOnFixedColumnsIndent | CXTPGridPaintManager |
m_bPrintGroupRowIcon | CXTPGridPaintManager | protected
m_bPrintPageRectangle | CXTPGridPaintManager |
m_bPrintSortTriangle | CXTPGridPaintManager |
m_bPrintVirtualPageNumber | CXTPGridPaintManager |
m_bPrintWatermark | CXTPGridPaintManager |
m_bRecOrRowNum | CXTPGridPaintManager |
m_bRevertAlignment | CXTPGridPaintManager |
m_bShadeGroupHeadings | CXTPGridPaintManager |
m_bShadeSortColumn | CXTPGridPaintManager |
m_bShowLockIcon | CXTPGridPaintManager |
m_bShowNonActiveInPlaceButton | CXTPGridPaintManager |
m_bShowWYSIWYGMarkers | CXTPGridPaintManager | protected
m_bSortTriangleOffsetFromRight | CXTPGridPaintManager |
m_bThemedInplaceButtons | CXTPGridPaintManager |
m_bUseAlternativeBackground | CXTPGridPaintManager |
m_bUseDropMarker | CXTPGridPaintManager |
m_bUseEditTextAlignment | CXTPGridPaintManager |
m_bUseGroupRowSelectionState | CXTPGridPaintManager |
m_bUseShellIcon | CXTPGridPaintManager |
m_clrAlternativeBackground | CXTPGridPaintManager |
m_clrBoldText | CXTPGridPaintManager |
m_clrBoldTextHighlight | CXTPGridPaintManager |
m_clrBtnFace | CXTPGridPaintManager |
m_clrBtnFacePressed | CXTPGridPaintManager |
m_clrBtnText | CXTPGridPaintManager |
m_clrCaptionText | CXTPGridPaintManager |
m_clrCaptionTextPressed | CXTPGridPaintManager |
m_clrColumnOffice2007CustomTheme | CXTPGridPaintManager |
m_clrConnector | CXTPGridPaintManager |
m_clrControlBack | CXTPGridPaintManager |
m_clrControlDark | CXTPGridPaintManager |
m_clrControlLightLight | CXTPGridPaintManager |
m_clrDisableBitmapDarkest | CXTPGridPaintManager |
m_clrDisableBitmapLightest | CXTPGridPaintManager |
m_clrFormulaSubSum | CXTPGridPaintManager |
m_clrFormulaSum | CXTPGridPaintManager |
m_clrFreezeColsDivider | CXTPGridPaintManager |
m_clrGlyph | CXTPTrackThemeOffice2013 |
m_clrGlyphHighlight | CXTPTrackThemeOffice2013 |
m_clrGradientColumnSeparator | CXTPGridPaintManager |
m_clrGradientColumnShadow | CXTPGridPaintManager |
m_clrGroupBoxBack | CXTPGridPaintManager |
m_clrGroupRowText | CXTPGridPaintManager |
m_clrGroupShadeBack | CXTPGridPaintManager |
m_clrGroupShadeBorder | CXTPGridPaintManager |
m_clrGroupShadeText | CXTPGridPaintManager |
m_clrHeaderControl | CXTPGridPaintManager |
m_clrHighlight | CXTPGridPaintManager |
m_clrHighlightText | CXTPGridPaintManager |
m_clrHotDivider | CXTPGridPaintManager |
m_clrIndentControl | CXTPGridPaintManager |
m_clrItemShade | CXTPGridPaintManager |
m_clrMarker | CXTPTrackPaintManager |
m_clrMarkerBack | CXTPTrackPaintManager |
m_clrMarkerBorder | CXTPTrackPaintManager |
m_clrPreviewText | CXTPGridPaintManager |
m_clrScrollBarBorderDark | CXTPTrackPaintManager |
m_clrScrollBarBorderLight | CXTPTrackPaintManager |
m_clrScrollBarDark | CXTPTrackPaintManager |
m_clrScrollBarLight | CXTPTrackPaintManager |
m_clrSelectedArea | CXTPTrackPaintManager |
m_clrSelectedBorder | CXTPTrackThemeOffice2013 |
m_clrSelectedRow | CXTPGridPaintManager |
m_clrSelectedRowText | CXTPGridPaintManager |
m_clrTimeHeaderBorder | CXTPTrackPaintManager |
m_clrTimeHeaderDark | CXTPTrackPaintManager |
m_clrTimeHeaderDarkDark | CXTPTrackPaintManager |
m_clrTimeHeaderDivider | CXTPTrackPaintManager |
m_clrTimeLinePosition | CXTPTrackPaintManager |
m_clrTimeLineTick | CXTPTrackPaintManager |
m_clrTimeSliderBackground | CXTPTrackPaintManager |
m_clrTrackHeader | CXTPTrackPaintManager |
m_clrTrackMarkerBorder | CXTPTrackPaintManager |
m_clrTrackMarkerText | CXTPTrackPaintManager |
m_clrTrackMarkerTextBack | CXTPTrackPaintManager |
m_clrTrackMarkerTextBorder | CXTPTrackPaintManager |
m_clrTrackTimeArea | CXTPTrackPaintManager |
m_clrWindowText | CXTPGridPaintManager |
m_clrWorkArea | CXTPTrackPaintManager |
m_clrWorkAreaScrollBarBorder | CXTPTrackPaintManager |
m_clrWorkAreaScrollBarDark | CXTPTrackPaintManager |
m_clrWorkAreaScrollBarLight | CXTPTrackPaintManager |
m_columnStyle | CXTPGridPaintManager | protected
m_crlNoGroupByText | CXTPGridPaintManager |
m_grcGradientColumn | CXTPGridPaintManager |
m_grcGradientColumnHot | CXTPGridPaintManager |
m_grcGradientColumnPushed | CXTPGridPaintManager |
m_iRecOrRowStart | CXTPGridPaintManager |
m_nBaseParentRecordIndent | CXTPGridPaintManager |
m_nFixedColumnsIndent | CXTPGridPaintManager |
m_nFooterHeight | CXTPGridPaintManager | protected
m_nFreezeColsDividerStyle | CXTPGridPaintManager | protected
m_nGridLineStylePreviousH | CXTPGridPaintManager | protected
m_nGridLineStylePreviousV | CXTPGridPaintManager | protected
m_nGroupGridLineHeight | CXTPGridPaintManager | protected
m_nGroupGridLineStyle | CXTPGridPaintManager | protected
m_nHeaderHeight | CXTPGridPaintManager | protected
m_nMaxPreviewLines | CXTPGridPaintManager | protected
m_nResizingWidth | CXTPGridPaintManager | protected
m_nRowHeight | CXTPGridPaintManager | protected
m_nRowHeightDefault | CXTPGridPaintManager |
m_nTextIndentForGroupRowsWithNoIcon | CXTPGridPaintManager |
m_nTreeColumnLineLength | CXTPGridPaintManager |
m_nTreeIndent | CXTPGridPaintManager |
m_nTreeStructureStyle | CXTPGridPaintManager |
m_nTreeTextIndent | CXTPGridPaintManager |
m_nTreeTextIndentGroupRow | CXTPGridPaintManager |
m_nTreeTextIndentRowChildren | CXTPGridPaintManager |
m_nTreeTextIndentRowParent | CXTPGridPaintManager |
m_pControl | CXTPGridPaintManager | protected
m_pGlyphs | CXTPGridPaintManager | protected
m_pHyperlinkHoverStyle | CXTPGridPaintManager |
m_pHyperlinkStyle | CXTPGridPaintManager |
m_pMarkupUIElement_NoGroupBy | CXTPGridPaintManager | protected
m_PrintPageWidth | CXTPGridPaintManager |
m_rcPreviewIndent | CXTPGridPaintManager |
m_RecordNumberWidth | CXTPGridPaintManager |
m_strCollapse | CXTPGridPaintManager |
m_strDecreasing | CXTPGridPaintManager |
m_strExpand | CXTPGridPaintManager |
m_strIncreasing | CXTPGridPaintManager |
m_strMarkupUIElement_NoGroupBy | CXTPGridPaintManager | protected
m_strNoFieldsAvailable | CXTPGridPaintManager |
m_strNoGroupBy | CXTPGridPaintManager |
m_strNoItems | CXTPGridPaintManager |
m_strSortBy | CXTPGridPaintManager |
m_szGlyph | CXTPGridPaintManager | protected
m_themeButton | CXTPGridPaintManager | protected
m_themeCombo | CXTPGridPaintManager | protected
m_themeHeader | CXTPGridPaintManager | protected
m_themeSpin | CXTPGridPaintManager | protected
m_treeStructureStyle | CXTPGridPaintManager |
m_xtpBrushGroupGridLineStyle | CXTPGridPaintManager | protected
m_xtpBrushHorizontalGrid | CXTPGridPaintManager | protected
m_xtpBrushTreeStructure | CXTPGridPaintManager | protected
m_xtpBrushVeriticalGrid | CXTPGridPaintManager | protected
m_xtpFontBoldText | CXTPGridPaintManager |
m_xtpFontCaption | CXTPGridPaintManager |
m_xtpFontPreview | CXTPGridPaintManager |
m_xtpFontText | CXTPGridPaintManager |
OnDrawAction(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs) | CXTPGridPaintManager | virtual
RecalcTotalHightOfMergedRows(CXTPGridColumns *pColumns, CDC *pDC, CXTPGridRow *pRow, int nRowHeight, int nTotalWidth) | CXTPGridPaintManager |
RefreshMetrics() | CXTPTrackThemeVisualStudio2012Dark | virtual
SetCaptionFont(LOGFONT &lf) | CXTPGridPaintManager |
SetColumnOffice2007CustomThemeBaseColor(COLORREF clrBaseColor) | CXTPGridPaintManager |
SetColumnPlusMinusSign(BOOL bDraw) | CXTPGridPaintManager |
SetColumnWidthWYSIWYG(BOOL bColumnWidthWYSIWYG) | CXTPGridPaintManager |
SetDrawGridForEmptySpace(BOOL bDrawGrid) | CXTPGridPaintManager |
SetFixedRowHeight(BOOL bFixedRowHeight) | CXTPGridPaintManager |
SetFreezeColsDividerStyle(int nStyle) | CXTPGridPaintManager |
SetGridControl(CXTPGridControl *pControl) | CXTPGridPaintManager | virtual
SetHeaderHeight(int nHeight) | CXTPGridPaintManager | virtual
SetInplaceButtonHeight(BOOL bFixedInplaceButtonHeight) | CXTPGridPaintManager |
SetLastColumnWidthWYSIWYG(BOOL bColumnWidthWYSIWYG) | CXTPGridPaintManager |
SetMaxPreviewLines(int nMaxLines) | CXTPGridPaintManager |
SetPreviewIndent(int nLeft, int nTop, int nRight, int nBottom) | CXTPGridPaintManager |
SetPrintGroupRowIcon(BOOL bDraw) | CXTPGridPaintManager |
SetTextFont(LOGFONT &lf) | CXTPGridPaintManager |
ShowWYSIWYGMarkers(BOOL bSet) | CXTPGridPaintManager |
~CXTPGridPaintManager() | CXTPGridPaintManager | virtual
~CXTPTrackPaintManager() | CXTPTrackPaintManager |


Toolkit Pro: Member List

CXTPDockingPaneVisualStudio2008Theme Member List

This is the complete list of members for CXTPDockingPaneVisualStudio2008Theme, including all inherited members.

AdjustCaptionRect(const CXTPDockingPaneSidePanel *pPane, CRect &rc) | CXTPDockingPanePaintManager | virtual
AdjustCaptionRect(const CXTPDockingPaneTabbedContainer *pPane, CRect &rc) | CXTPDockingPanePaintManager | virtual
AdjustClientRect(CXTPDockingPaneSidePanel *pPane, CRect &rect) | CXTPDockingPanePaintManager | virtual
AdjustClientRect(CXTPDockingPaneTabbedContainer *pPane, CRect &rect, BOOL bApply) | CXTPDockingPanePaintManager | virtual
ClipAndAddEllipsisIfNeeded(CDC *pDC, CString &strTitle, int nCaptionWidth) const | CXTPDockingPanePaintManager | protected
CXTPCmdTarget() | CXTPCmdTarget |
CXTPDockingPaneDefaultTheme() | CXTPDockingPaneDefaultTheme |
CXTPDockingPaneGripperedTheme() | CXTPDockingPaneGripperedTheme |
CXTPDockingPanePaintManager() | CXTPDockingPanePaintManager | protected
CXTPDockingPaneVisualStudio2003Theme() | CXTPDockingPaneVisualStudio2003Theme |
CXTPDockingPaneVisualStudio2005Beta1Theme() | CXTPDockingPaneVisualStudio2005Beta1Theme |
CXTPDockingPaneVisualStudio2005Beta2Theme() | CXTPDockingPaneVisualStudio2005Beta2Theme |
CXTPDockingPaneVisualStudio2005Theme() | CXTPDockingPaneVisualStudio2005Theme |
CXTPDockingPaneVisualStudio2008Theme() | CXTPDockingPaneVisualStudio2008Theme |
DrawAutoHidePanel(CDC *pDC, CRect rc, XTPDockingPaneDirection direction) | CXTPDockingPanePaintManager | virtual
DrawCaption(CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc) | CXTPDockingPaneGripperedTheme | virtual
DrawCaptionButton(CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton) | CXTPDockingPanePaintManager | virtual
DrawCaptionButtonEntry(CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton, CSize szOffset) | CXTPDockingPanePaintManager | protectedvirtual
DrawCaptionButtonEntry(CDC *pDC, CXTPDockingPaneCaptionButton *pButton, CPoint pt, COLORREF clrButton) | CXTPDockingPanePaintManager | protectedvirtual
DrawCaptionButtons(CDC *pDC, CXTPDockingPaneCaptionButtons *pButtons, CRect &rcCaption, COLORREF clr, int nButtonSize, int nButtonGap, BOOL bVertical=FALSE) | CXTPDockingPanePaintManager | virtual
DrawCaptionPart(CDC *pDC, CXTPDockingPaneBase *pPane, CRect rcCaption, const CString &strTitle, BOOL bActive, BOOL bVertical) | CXTPDockingPaneVisualStudio2003Theme | protectedvirtual
DrawCaptionText(CDC *pDC, const CString &strTitle, CRect rc, BOOL bVertical, BOOL bCalcWidth=FALSE) | CXTPDockingPanePaintManager |
DrawFloatingFrame(CDC *pDC, CXTPDockingPaneMiniWnd *pPane, CRect rc) | CXTPDockingPaneGripperedTheme | virtual
DrawPane(CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc) | CXTPDockingPanePaintManager | virtual
DrawSidePanel(CDC *pDC, CXTPDockingPaneSidePanel *pPane, CRect rc) | CXTPDockingPaneDefaultTheme | virtual
DrawSplitter(CDC *pDC, CXTPDockingPaneSplitterWnd *pSplitter) | CXTPDockingPanePaintManager | virtual
FillCaptionPart(CDC *pDC, CXTPDockingPaneBase *pPane, CRect rcCaption, BOOL bActive, BOOL bVertical) | CXTPDockingPaneVisualStudio2005Beta2Theme | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCaptionButtonStyle() const | CXTPDockingPanePaintManager |
GetCaptionGripperRect(const CXTPDockingPaneTabbedContainer *pPane) | CXTPDockingPanePaintManager | virtual
GetCaptionHeight() const | CXTPDockingPanePaintManager |
GetCaptionRect(const CXTPDockingPaneTabbedContainer *pPane, CRect &rc) | CXTPDockingPanePaintManager | virtual
GetCurrentSystemTheme() const | CXTPDockingPanePaintManager |
GetCustomTitleBrush(BOOL bActive, BOOL bVertical) const | CXTPDockingPanePaintManager |
GetPaneCaptionRect(const CXTPDockingPaneSidePanel *pPane) | CXTPDockingPanePaintManager | virtual
GetPanelPaintManager() const | CXTPDockingPanePaintManager |
GetSplitterStyle() const | CXTPDockingPanePaintManager |
GetTabPaintManager() const | CXTPDockingPanePaintManager |
GetTabsHeight() const | CXTPDockingPanePaintManager |
GetXtremeColor(UINT nIndex) | CXTPDockingPanePaintManager |
Line(CDC *pDC, int x0, int y0, int x1, int y1, int nPen) | CXTPDockingPanePaintManager |
Line(CDC *pDC, int x0, int y0, int x1, int y1) | CXTPDockingPanePaintManager |
m_arrColor | CXTPDockingPanePaintManager | protected
m_bDestroyCustomTitleBrushes | CXTPDockingPanePaintManager | protected
m_bDrawCaptionIcon | CXTPDockingPanePaintManager |
m_bDrawSingleTab | CXTPDockingPanePaintManager |
m_bGradientCaption | CXTPDockingPaneVisualStudio2003Theme | protected
m_bHighlightActiveCaption | CXTPDockingPanePaintManager |
m_bLunaTheme | CXTPDockingPanePaintManager | protected
m_bShowCaption | CXTPDockingPanePaintManager |
m_bUseBoldCaptionFont | CXTPDockingPanePaintManager |
m_bUseOfficeFont | CXTPDockingPanePaintManager | protected
m_bUseStandardFont | CXTPDockingPanePaintManager | protected
m_clrActiveCaption | CXTPDockingPanePaintManager |
m_clrActiveCaptionText | CXTPDockingPanePaintManager |
m_clrBackground | CXTPDockingPanePaintManager |
m_clrCaptionBorder | CXTPDockingPaneVisualStudio2005Beta2Theme | protected
m_clrDisabledCaptionText | CXTPDockingPanePaintManager |
m_clrNormalCaption | CXTPDockingPanePaintManager |
m_clrNormalCaptionText | CXTPDockingPanePaintManager |
m_clrSplitter | CXTPDockingPanePaintManager |
m_clrSplitterGradient | CXTPDockingPanePaintManager |
m_clrSplitterGripper | CXTPDockingPanePaintManager |
m_dwSplitterStyle | CXTPDockingPanePaintManager | protected
m_hbrActiveTitleHorz | CXTPDockingPanePaintManager | protected
m_hbrActiveTitleVert | CXTPDockingPanePaintManager | protected
m_hbrInactiveTitleHorz | CXTPDockingPanePaintManager | protected
m_hbrInactiveTitleVert | CXTPDockingPanePaintManager | protected
m_nCaptionButtonStyle | CXTPDockingPanePaintManager | protected
m_nCaptionFontGap | CXTPDockingPanePaintManager | protected
m_nSplitterIndent | CXTPDockingPanePaintManager |
m_nSplitterSize | CXTPDockingPanePaintManager |
m_nTabsHeight | CXTPDockingPanePaintManager | protected
m_nTitleHeight | CXTPDockingPanePaintManager | protected
m_pPanelPaintManager | CXTPDockingPanePaintManager | protected
m_pTabPaintManager | CXTPDockingPanePaintManager | protected
m_rcCaptionMargin | CXTPDockingPanePaintManager | protected
m_strOfficeFont | CXTPDockingPanePaintManager | protected
m_systemTheme | CXTPDockingPanePaintManager | protected
m_themeButton | CXTPDockingPanePaintManager | protected
m_themeCurrent | CXTPDockingPanePaintManager | protected
m_themeExplorer | CXTPDockingPanePaintManager | protected
m_themeRebar | CXTPDockingPanePaintManager | protected
m_themeToolbar | CXTPDockingPanePaintManager | protected
m_themeWindow | CXTPDockingPanePaintManager | protected
m_xtpFontTitle | CXTPDockingPanePaintManager | protected
m_xtpFontTitleVertical | CXTPDockingPanePaintManager | protected
Pixel(CDC *pDC, int xPos, int yPos, int nPen) | CXTPDockingPanePaintManager |
Rectangle(CDC *pDC, CRect rc, int nPenEntry, int nPenBorder) | CXTPDockingPanePaintManager |
RefreshMetrics() | CXTPDockingPaneVisualStudio2008Theme | virtual
SetCaptionButtonStyle(XTPDockingPaneCaptionButtonStyle nStyle) | CXTPDockingPanePaintManager |
SetCaptionFontIndirect(LOGFONT *pLogFont, BOOL bUseStandardFont=FALSE) | CXTPDockingPanePaintManager |
SetColors(int cElements, CONST INT *lpaElements, CONST COLORREF *lpaRgbValues) | CXTPDockingPanePaintManager |
SetCustomTitleBrushes(HBRUSH hbrActiveTitleHorz, HBRUSH hbrInactiveTitleHorz=NULL, HBRUSH hbrActiveTitleVert=NULL, HBRUSH hbrInactiveTitleVert=NULL, BOOL bDestroyOnCleanup=FALSE) | CXTPDockingPanePaintManager |
SetLunaTheme(XTPCurrentSystemTheme systemTheme) | CXTPDockingPanePaintManager |
SetPanelPaintManager(CXTPTabPaintManager *pManager) | CXTPDockingPanePaintManager |
SetSplitterStyle(DWORD dwStyle) | CXTPDockingPanePaintManager |
SetTabPaintManager(CXTPTabPaintManager *pManager) | CXTPDockingPanePaintManager |
UseOfficeFont(BOOL bUseOfficeFont) | CXTPDockingPanePaintManager |
~CXTPDockingPanePaintManager() | CXTPDockingPanePaintManager | protectedvirtual


Toolkit Pro: Member List

  • XTP_CALENDAR_RECURRENCE_OPTIONS
  • PATTERN_MONTHLY
XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_MONTHLY Member List

This is the complete list of members for XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_MONTHLY, including all inherited members.

nDayOfMonth | XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_MONTHLY
nIntervalMonths | XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_MONTHLY


Toolkit Pro: XTPMarkupGdiPlusSkewTransform.h Source File

  • Source
  • Markup
  • Transform
XTPMarkupGdiPlusSkewTransform.h
Go to the documentation of this file.
1
23#if !defined(__XTPMARKUPGDIPLUSSKEWTRANSFORM_H__)
24# define __XTPMARKUPGDIPLUSSKEWTRANSFORM_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPGdiPlus;
34
39class _XTP_EXT_CLASS CXTPMarkupGdiPlusSkewTransform
40 : public CXTPMarkupGdiPlusTransformObject<CXTPMarkupSkewTransform>
41{
43 DECLARE_MARKUPCLASS(CXTPMarkupGdiPlusSkewTransform);
53 virtual BOOL TransformMatrix(const CXTPGdiPlus* pReserved, GpMatrix* pMatrix);
54};
55
56# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
58#endif // !defined(__XTPMARKUPGDIPLUSSKEWTRANSFORM_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPMarkupGdiPlusSkewTransform
GDI+ SkewTransform implementation.
Definition XTPMarkupGdiPlusSkewTransform.h:41
CXTPMarkupGdiPlusTransformObject
Base class for all GDI+ markup transformation objects.
Definition XTPMarkupGdiPlusTransformObject.h:91
CXTPMarkupGdiPlusTransformObjectImpl::TransformMatrix
virtual BOOL TransformMatrix(const CXTPGdiPlus *pReserved, GpMatrix *pMatrix)=0
An abstract method that performs a native GDI+ matrix transformation.


Toolkit Pro: XTPXamlPreviewProvider.h Source File

  • Source
  • Controls
  • Preview
  • Providers
  • XAML
XTPXamlPreviewProvider.h
Go to the documentation of this file.
1
23#if !defined(__XTPXAMLPREVIEWPROVIDER_H__)
24# define __XTPXAMLPREVIEWPROVIDER_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
41class _XTP_EXT_CLASS CXTPXamlPreviewProvider : public CXTPPreviewProviderBase
42{
43private:
44 virtual LPCTSTR GetDefaultFileAssociations() const;
45 virtual IXTPPreview* CreatePreview(LPCTSTR pFilePath, HWND hwndParent);
46 virtual IXTPPreview* CreatePreview(IStream& stream, LPCTSTR pImpliedFileName, HWND hwndParent);
47};
48
49# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
51#endif // #if !defined(__XTPXAMLPREVIEWPROVIDER_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPPreviewProviderBase
Base class for a preview provider which implements common behavior to be exposed by a preview provide...
Definition XTPPreviewAbstract.h:251
CXTPXamlPreviewProvider
Provides a preview handler for XAML files that uses Markup components for rendering file contents.
Definition XTPXamlPreviewProvider.h:42
IXTPPreview
The base interface for a preview handler implementation.
Definition XTPPreviewAbstract.h:40
IXTPPreviewProvider::GetDefaultFileAssociations
virtual LPCTSTR GetDefaultFileAssociations() const =0
Obtains the list of file extensions supported by the associated preview implementation.
IXTPPreviewProvider::CreatePreview
virtual IXTPPreview * CreatePreview(LPCTSTR pFilePath, HWND hwndParent)=0
Creates a preview object for the specified file.


Toolkit Pro: Member List

CXTPPropExchangeXMLNode Member List

This is the complete list of members for CXTPPropExchangeXMLNode, including all inherited members.

Clone(BOOL bRecursive) | CXTPPropExchangeXMLNode |
CreateSection(LPCTSTR pszSection) | CXTPPropExchangeXMLNode |
CXTPCmdTarget() | CXTPCmdTarget |
CXTPPropExchange() | CXTPPropExchange |
CXTPPropExchangeXMLNode(BOOL bLoading, CXTPDOMNodePtr xmlParentNode, LPCTSTR lpszSection) | CXTPPropExchangeXMLNode |
EmptySection() | CXTPPropExchangeXMLNode | virtual
ExchangeBlobProp(LPCTSTR pszPropName, BYTE *&pData, DWORD &nBytes) | CXTPPropExchange | virtual
ExchangeLocale() | CXTPPropExchange |
ExchangeObjectInstance(CObject *&pObject, CRuntimeClass *pObjectRuntime) | CXTPPropExchange | virtual
ExchangeProp(LPCTSTR pszPropName, VARTYPE vtProp, void *pvProp, const void *pvDefault=NULL) | CXTPPropExchangeXMLNode | virtual
ExchangeRuntimeClass(LPCTSTR pszPropName, CRuntimeClass *&pClass, CRuntimeClass *pDefaultClass) | CXTPPropExchange | virtual
ExchangeSchema() | CXTPPropExchange |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetArchive(LPCTSTR pszPropName) | CXTPPropExchange | virtual
GetEncodedXML(BOOL bFormatted=FALSE) | CXTPPropExchangeXMLNode |
GetEntryNode(LPCTSTR lpszEntry, BOOL bCreate) | CXTPPropExchangeXMLNode | protected
GetEnumerator(LPCTSTR lpszSection) | CXTPPropExchangeXMLNode | virtual
GetProfileNode(LPCTSTR lpszSection) | CXTPPropExchangeXMLNode | protected
GetSchema() const | CXTPPropExchange |
GetSection(LPCTSTR lpszSection) | CXTPPropExchangeXMLNode | virtual
GetSectionName() | CXTPPropExchangeXMLNode |
GetSectionNode() const | CXTPPropExchangeXMLNode | inline
GetXML(BOOL bFormatted=FALSE) | CXTPPropExchangeXMLNode |
InitSection(CXTPPropExchange *pRootSection) | CXTPPropExchange | protected
IsAllowBlobValues() const | CXTPPropExchange | virtual
IsAllowDefaultValues() const | CXTPPropExchange | virtual
IsLoading() const | CXTPPropExchange |
IsPropertyExists(LPCTSTR pszPropName) | CXTPPropExchangeXMLNode |
IsRootSection() const | CXTPPropExchange |
IsSectionExists(LPCTSTR lpszSection) | CXTPPropExchangeXMLNode |
IsStoring() const | CXTPPropExchange |
IsXMLSupported() | CXTPPropExchangeXMLNode | static
LoadFromEncodedString(LPCSTR lpszState) | CXTPPropExchangeXMLNode |
LoadFromEncodedString(LPCWSTR lpszState) | CXTPPropExchangeXMLNode |
LoadFromFile(LPCTSTR lpszFileName) | CXTPPropExchangeXMLNode |
LoadFromResource(HINSTANCE hInstance, LPCTSTR lpszResourceName, LPCTSTR lpszResourceType) | CXTPPropExchangeXMLNode |
LoadFromString(LPCSTR lpszState) | CXTPPropExchangeXMLNode |
LoadFromString(LPCWSTR lpszState) | CXTPPropExchangeXMLNode |
LoadFromString(BSTR bstrState) | CXTPPropExchangeXMLNode |
m_bChildSection | CXTPPropExchange | protected
m_bCompactMode | CXTPPropExchangeXMLNode | protected
m_bEmptySection | CXTPPropExchange | protected
m_bInitialized | CXTPPropExchange | protected
m_bLoading | CXTPPropExchange | protected
m_bUseDefaultOnLoad | CXTPPropExchange | protected
m_bUseDefaultOnSave | CXTPPropExchange | protected
m_dwData | CXTPPropExchange |
m_lcidDateTime | CXTPPropExchange | static
m_nSchema | CXTPPropExchange | protected
m_pOwner | CXTPPropExchange |
m_strEncoding | CXTPPropExchangeXMLNode | protected
m_strSectionName | CXTPPropExchangeXMLNode | protected
m_xmlDocPtr | CXTPPropExchangeXMLNode | protected
m_xmlParentNode | CXTPPropExchangeXMLNode | protected
m_xmlSectionNode | CXTPPropExchangeXMLNode | protected
OnBeforeExchange() | CXTPPropExchangeXMLNode | virtual
PutSection(CXTPPropExchangeXMLNode *pNode) | CXTPPropExchangeXMLNode |
Read(LPCTSTR pszPropName, void *lpBuf, UINT nCount) | CXTPPropExchange | virtual
ReadCount() | CXTPPropExchange | virtual
ReleaseArchive(LPCTSTR pszPropName, CArchive *pArchive) | CXTPPropExchange | virtual
SaveToFile(LPCTSTR lpszFileName, BOOL bFormatted=TRUE) | CXTPPropExchangeXMLNode |
SetCompactMode(BOOL bCompactMode) | CXTPPropExchangeXMLNode |
SetEncoding(LPCTSTR lpszEncoding) | CXTPPropExchangeXMLNode |
SetLoading(BOOL bLoading) | CXTPPropExchangeXMLNode |
SetSchema(UINT nSchemaVersion) | CXTPPropExchange |
UseDefaultOnLoad(BOOL bUseDefaultOnLoad=TRUE) | CXTPPropExchange |
UseDefaultOnSave(BOOL bUseDefaultOnSave=TRUE) | CXTPPropExchange |
Write(LPCTSTR pszPropName, const void *lpBuf, UINT nCount) | CXTPPropExchange | virtual
WriteCount(DWORD dwCount) | CXTPPropExchange | virtual
~CXTPPropExchange() | CXTPPropExchange | virtual


Toolkit Pro: Member List

CXTPChart3dPyramidDiagramView Member List

This is the complete list of members for CXTPChart3dPyramidDiagramView, including all inherited members.

AddChildView(CXTPChartElementView *pChildView) | CXTPChartElementView |
CalculateView(CXTPChartDeviceContext *pDC, CRect rcBounds) | CXTPChartDiagramView | virtual
CreateDeviceCommand(CXTPChartDeviceContext *pDC) | CXTPChart3dDiagramView | virtual
CreateView(CXTPChartDeviceContext *pDC) | CXTPChartDiagramView | virtual
CXTPChart3dDiagramView(CXTPChartDiagram *pDiagram, CXTPChartElementView *pParentView) | CXTPChart3dDiagramView |
CXTPChart3dPyramidDiagramView(CXTPChartDiagram *pDiagram, CXTPChartElementView *pParent) | CXTPChart3dPyramidDiagramView |
CXTPChartDiagramView(CXTPChartDiagram *pDiagram, CXTPChartElementView *pParentView) | CXTPChartDiagramView |
CXTPChartElementView(CXTPChartElementView *pParentView) | CXTPChartElementView |
CXTPChartElementView(CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartElementView |
CXTPChartElementView(CXTPChartContainer *pContainer) | CXTPChartElementView |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
GetAt(int nIndex) const | CXTPChartElementView |
GetBounds() const | CXTPChartDiagramView |
CXTPChartElementView::GetBounds(BOOL bIncludingChildren) const | CXTPChartElementView |
GetChildren() | CXTPChartElementView |
GetCount() const | CXTPChartElementView |
GetDiagram() const | CXTPChartDiagramView |
GetLabelsView() const | CXTPChartDiagramView |
GetParentView() const | CXTPChartElementView |
GetSeriesView() const | CXTPChartDiagramView |
Is3D() const | CXTPChartObject |
m_arrChildren | CXTPChartElementView | protected
m_pContainer | CXTPChartElementView | protected
m_pDiagram | CXTPChartDiagramView | protected
m_pLabelsView | CXTPChartDiagramView | protected
m_pParentView | CXTPChartElementView | protected
m_pSeriesView | CXTPChartDiagramView | protected
m_pTitlesView | CXTPChartDiagramView | protected
m_rcBounds | CXTPChartDiagramView | protected
OnMouseWheel(UINT nFlags, short zDelta, CPoint pt) | CXTPChartDiagramView | virtual
UpdateRange(CXTPChartDeviceContext *pDC) | CXTPChartDiagramView | virtual
~CXTPChartElementView() | CXTPChartElementView | protectedvirtual


Toolkit Pro: Member List

CXTPCaption Member List

This is the complete list of members for CXTPCaption, including all inherited members.

Create(CWnd *pParentWnd, LPCTSTR lpszWindowName, DWORD dwExStyle=CPWS_EX_RAISED_EDGE, DWORD dwStyle=WS_VISIBLE|SS_CENTER|SS_CENTERIMAGE, const CRect &rect=CRect(0, 0, 0, 0), UINT nID=0xffff) | CXTPCaption | virtual
CXTPCaption() | CXTPCaption |
DrawCaptionBack(CDC *pDC, CRect &rcItem) | CXTPCaption | protectedvirtual
DrawCaptionIcon(CDC *pDC, CRect &rcItem) | CXTPCaption | protectedvirtual
DrawCaptionText(CDC *pDC) | CXTPCaption | protectedvirtual
GetButtonRect() const | CXTPCaption | protectedvirtual
GetCaptionButton() | CXTPCaption |
GetCaptionStyle() const | CXTPCaption |
GetCaptionText() | CXTPCaption |
GetTextRect() const | CXTPCaption | virtual
GetTheme() | CXTPCaption |
HasCloseButton() const | CXTPCaption |
IsAppCaption() const | CXTPCaption | inline
KillChildWindow() | CXTPCaption | virtual
m_bAppCaption | CXTPCaption | protected
m_bSubclassed | CXTPCaption | protected
m_btnCaption | CXTPCaption | protected
m_bUserColors | CXTPCaption | protected
m_clrBorder | CXTPCaption |
m_clrFace | CXTPCaption |
m_clrText | CXTPCaption |
m_dwExStyle | CXTPCaption | protected
m_hIcon | CXTPCaption | protected
m_nBorder | CXTPCaption |
m_nOffset | CXTPCaption | protected
m_pChildWnd | CXTPCaption | protected
m_pParentView | CXTPCaption | protected
m_pPopupWnd | CXTPCaption | protected
m_pSplitterWnd | CXTPCaption | protected
m_pTheme | CXTPCaption | protected
m_rcChild | CXTPCaption | protected
m_rcParent | CXTPCaption | protected
m_rcSplitter | CXTPCaption | protected
m_sizeIcon | CXTPCaption | protected
m_strCaption | CXTPCaption | protected
ModifyCaptionStyle(int nBorderSize, CFont *pFont=NULL, LPCTSTR lpszWindText=NULL, HICON hIcon=NULL) | CXTPCaption | virtual
RefreshButton() | CXTPCaption |
RefreshMetrics() | CXTPCaption | protectedvirtual
SetAppCaption(bool bAppCaption) | CXTPCaption | inline
SetCaptionColors(COLORREF clrBorder, COLORREF clrFace, COLORREF clrText) | CXTPCaption | virtual
SetChildWindow(CWnd *pChild, CWnd *pNotifyWnd) | CXTPCaption | virtual
SetOffice2003Colors(bool b2003Colors=true) | CXTPCaption |
SetTheme(XTPControlTheme eTheme) | CXTPCaption |
SetTheme(CXTPCaptionTheme *pTheme) | CXTPCaption |
ShowPopupWindow() | CXTPCaption | virtual
UpdateCaption(LPCTSTR lpszWindowText, HICON hIcon) | CXTPCaption | virtual
UpdateCaptionText(CDC *pDC) | CXTPCaption | protectedvirtual
~CXTPCaption() | CXTPCaption | virtual


Toolkit Pro: Member List

CXTPPropertyGridItemEnum Member List

This is the complete list of members for CXTPPropertyGridItemEnum, including all inherited members.

AddChildItem(CXTPPropertyGridItem *pItem) | CXTPPropertyGridItem |
AddComboButton() | CXTPPropertyGridItem |
AddExpandButton() | CXTPPropertyGridItem |
AddSliderControl() | CXTPPropertyGridItem |
AddSpinButton() | CXTPPropertyGridItem |
BindToEnum(int *pBindEnum) | CXTPPropertyGridItemEnum | virtual
BindToString(CString *pBindString) | CXTPPropertyGridItem |
Collapse() | CXTPPropertyGridItem |
CXTPCmdTarget() | CXTPCmdTarget |
CXTPPropertyGridItem(LPCTSTR lpszCaption, LPCTSTR strValue=NULL, CString *pBindString=NULL) | CXTPPropertyGridItem |
CXTPPropertyGridItem(UINT nID, LPCTSTR strValue=NULL, CString *pBindString=NULL) | CXTPPropertyGridItem |
CXTPPropertyGridItemEnum(LPCTSTR strCaption, int nValue=0, int *pBindEnum=NULL) | CXTPPropertyGridItemEnum |
CXTPPropertyGridItemEnum(UINT nID, int nValue=0, int *pBindEnum=NULL) | CXTPPropertyGridItemEnum |
EnsureVisible() | CXTPPropertyGridItem |
Expand() | CXTPPropertyGridItem |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCaption() const | CXTPPropertyGridItem |
GetCaptionMetrics() const | CXTPPropertyGridItem |
GetChilds() const | CXTPPropertyGridItem |
GetConstraintEdit() const | CXTPPropertyGridItem |
GetConstraints() const | CXTPPropertyGridItem |
GetDefaultValue() const | CXTPPropertyGridItem |
GetDescription() const | CXTPPropertyGridItem |
GetDropDownItemCount() const | CXTPPropertyGridItem |
GetEditStyle() const | CXTPPropertyGridItem | virtual
GetEnum() const | CXTPPropertyGridItemEnum | virtual
GetFlags() const | CXTPPropertyGridItem |
GetGrid() const | CXTPPropertyGridItem |
GetHeight() const | CXTPPropertyGridItem |
GetID() const | CXTPPropertyGridItem |
GetIndent() const | CXTPPropertyGridItem |
GetIndex() const | CXTPPropertyGridItem |
GetInplaceButtons() const | CXTPPropertyGridItem |
GetInplaceControls() const | CXTPPropertyGridItem |
GetInPlacedEditValue() | CXTPPropertyGridItem | inlineprotectedvirtual
GetInplaceEdit() | CXTPPropertyGridItem | virtual
GetInplaceList() | CXTPPropertyGridItem | protectedvirtual
GetItemData() const | CXTPPropertyGridItem |
GetItemRect() const | CXTPPropertyGridItem |
GetMarkupCaption() const | CXTPPropertyGridItem |
GetMarkupDescription() const | CXTPPropertyGridItem |
GetMarkupTemplate() const | CXTPPropertyGridItem | virtual
GetMarkupValue() const | CXTPPropertyGridItem |
GetMaskedText() const | CXTPPropertyGridItem |
GetMetrics(BOOL bValueMetrics, BOOL bCreate=TRUE) const | CXTPPropertyGridItem |
GetMultiLinesCount() const | CXTPPropertyGridItem |
GetParentItem() const | CXTPPropertyGridItem |
GetReadOnly() const | CXTPPropertyGridItem | virtual
GetTooltip() const | CXTPPropertyGridItem |
GetValue() const | CXTPPropertyGridItem |
GetValueMetrics() const | CXTPPropertyGridItem |
GetValueRect() | CXTPPropertyGridItem | virtual
GetViewValue() | CXTPPropertyGridItem | virtual
HasChilds() const | CXTPPropertyGridItem |
HasParent(CXTPPropertyGridItem *pParent) | CXTPPropertyGridItem |
HasVisibleChilds() const | CXTPPropertyGridItem |
InsertChildItem(int nIndex, CXTPPropertyGridItem *pItem) | CXTPPropertyGridItem |
IsAllowEdit() const | CXTPPropertyGridItem | virtual
IsCategory() const | CXTPPropertyGridItem |
IsExpandable() const | CXTPPropertyGridItem |
IsExpanded() const | CXTPPropertyGridItem |
IsHidden() const | CXTPPropertyGridItem |
IsInplaceButtonVisible(CXTPPropertyGridInplaceButton *pButton) const | CXTPPropertyGridItem | virtual
IsMultiLine() const | CXTPPropertyGridItem |
IsSelected() const | CXTPPropertyGridItem |
IsValueChanged() const | CXTPPropertyGridItem | virtual
IsVisible() const | CXTPPropertyGridItem |
m_bAutoComplete | CXTPPropertyGridItem | protected
m_bCategory | CXTPPropertyGridItem | protected
m_bConstraintEdit | CXTPPropertyGridItem | protected
m_bExpandable | CXTPPropertyGridItem | protected
m_bExpanded | CXTPPropertyGridItem | protected
m_bHidden | CXTPPropertyGridItem | protected
m_bPassword | CXTPPropertyGridItem | protected
m_bReadOnly | CXTPPropertyGridItem | protected
m_bUseMask | CXTPPropertyGridItem | protected
m_bVisible | CXTPPropertyGridItem | protected
m_chPrompt | CXTPPropertyGridItem | protected
m_dwData | CXTPPropertyGridItem | protected
m_dwEditStyle | CXTPPropertyGridItem | protected
m_nDropDownItemCount | CXTPPropertyGridItem | protected
m_nFlags | CXTPPropertyGridItem | protected
m_nHeight | CXTPPropertyGridItem | protected
m_nID | CXTPPropertyGridItem | protected
m_nIndent | CXTPPropertyGridItem | protected
m_nIndex | CXTPPropertyGridItem | protected
m_nLinesCount | CXTPPropertyGridItem | protected
m_nValue | CXTPPropertyGridItemEnum | protected
m_pBindEnum | CXTPPropertyGridItemEnum | protected
m_pBindString | CXTPPropertyGridItem | protected
m_pCaptionMetrics | CXTPPropertyGridItem | mutableprotected
m_pChilds | CXTPPropertyGridItem | protected
m_pConstraints | CXTPPropertyGridItem | protected
m_pGrid | CXTPPropertyGridItem | protected
m_pInplaceButtons | CXTPPropertyGridItem | protected
m_pInplaceControls | CXTPPropertyGridItem | protected
m_pMarkupCaption | CXTPPropertyGridItem | protected
m_pMarkupDescription | CXTPPropertyGridItem | protected
m_pMarkupValue | CXTPPropertyGridItem | protected
m_pParent | CXTPPropertyGridItem | protected
m_pValueMetrics | CXTPPropertyGridItem | mutableprotected
m_strCaption | CXTPPropertyGridItem | protected
m_strDefaultValue | CXTPPropertyGridItem | protected
m_strDescription | CXTPPropertyGridItem | protected
m_strFormat | CXTPPropertyGridItem | protected
m_strLiteral | CXTPPropertyGridItem | protected
m_strMarkupTemplate | CXTPPropertyGridItem | protected
m_strMask | CXTPPropertyGridItem | protected
m_strTooltip | CXTPPropertyGridItem | protected
m_strValue | CXTPPropertyGridItem | protected
MeasureItem(LPMEASUREITEMSTRUCT lpMeasureItemStruct) | CXTPPropertyGridItem | virtual
Move(CXTPPropertyGridItem *pParent, int nIndex=-1) | CXTPPropertyGridItem |
NotifyValueChanged() | CXTPPropertyGridItem | protected
OnAddChildItem() | CXTPPropertyGridItem | protectedvirtual
OnAfterEdit(CString &strValue) | CXTPPropertyGridItem | virtual
OnBeforeInsert() | CXTPPropertyGridItemEnum | protectedvirtual
OnCancelEdit() | CXTPPropertyGridItem | virtual
OnCaptionChanged() | CXTPPropertyGridItem | protectedvirtual
OnChar(UINT nChar) | CXTPPropertyGridItem | protectedvirtual
OnConstraintsChanged() | CXTPPropertyGridItemEnum | protectedvirtual
OnDeselect() | CXTPPropertyGridItem | protectedvirtual
OnDrawItemConstraint(CDC *pDC, CXTPPropertyGridItemConstraint *pConstraint, CRect rc, BOOL bSelected) | CXTPPropertyGridItem | virtual
OnDrawItemValue(CDC &dc, CRect rcValue) | CXTPPropertyGridItem | virtual
OnIndexChanged() | CXTPPropertyGridItem | protectedvirtual
OnInpaceControlFocus(BOOL bForward) | CXTPPropertyGridItem | protectedvirtual
OnInplaceButtonDown(CXTPPropertyGridInplaceButton *pButton) | CXTPPropertyGridItem | protectedvirtual
OnKeyDown(UINT nChar) | CXTPPropertyGridItem | protectedvirtual
OnLButtonDblClk(UINT nFlags, CPoint point) | CXTPPropertyGridItem | protectedvirtual
OnLButtonDown(UINT nFlags, CPoint point) | CXTPPropertyGridItem | protectedvirtual
OnLButtonUp(UINT nFlags, CPoint point) | CXTPPropertyGridItem | protectedvirtual
OnMarkupChanged() | CXTPPropertyGridItem | virtual
OnMergeItemConstraint(CDC *pDC, CXTPPropertyGridItemConstraint *pConstraint) | CXTPPropertyGridItem | virtual
OnRButtonDown(UINT nFlags, CPoint point) | CXTPPropertyGridItem | protectedvirtual
OnRequestEdit() | CXTPPropertyGridItem | virtual
OnSelect() | CXTPPropertyGridItem | protectedvirtual
OnValidateEdit() | CXTPPropertyGridItem | virtual
OnValueChanged(CString strValue) | CXTPPropertyGridItem | virtual
PtInValueRect(CPoint point) | CXTPPropertyGridItem | protected
RedrawItem() | CXTPPropertyGridItem |
Remove() | CXTPPropertyGridItem |
ResetValue() | CXTPPropertyGridItem | virtual
Select() | CXTPPropertyGridItem |
SelectNextConstraint() | CXTPPropertyGridItem | protected
SetAutoComplete(BOOL bAutoComplete=TRUE) | CXTPPropertyGridItem |
SetCaption(LPCTSTR lpszCaption) | CXTPPropertyGridItem |
SetConstraintEdit(BOOL bConstraintEdit=TRUE) | CXTPPropertyGridItem |
SetDefaultValue(LPCTSTR lpszDefaultValue) | CXTPPropertyGridItem |
SetDescription(LPCTSTR lpszDescription) | CXTPPropertyGridItem |
SetDropDownItemCount(int nDropDownItemCount) | CXTPPropertyGridItem |
SetEditStyle(DWORD dwEditStyle) | CXTPPropertyGridItem |
SetEditText(const CString &str) | CXTPPropertyGridItem | protectedvirtual
SetEnum(int nValue) | CXTPPropertyGridItemEnum | virtual
SetEnum(CXTPPropertyGridItemConstraint *pConstraint) | CXTPPropertyGridItemEnum | virtual
SetExpandable(BOOL bExpandable) | CXTPPropertyGridItem |
SetFlags(UINT nFlags) | CXTPPropertyGridItem |
SetFocusToInplaceControl() | CXTPPropertyGridItem | virtual
SetHeight(int nHeight) | CXTPPropertyGridItem |
SetHidden(BOOL bHidden) | CXTPPropertyGridItem |
SetID(UINT nID) | CXTPPropertyGridItem |
SetItemData(DWORD_PTR dwData) | CXTPPropertyGridItem |
SetMarkupTemplate(LPCTSTR lpstrMarkupTemplate) | CXTPPropertyGridItem |
SetMask(LPCTSTR strMask, LPCTSTR strLiteral, TCHAR chPrompt=_T('_')) | CXTPPropertyGridItem |
SetMaskedText(LPCTSTR lpszMaskedText) | CXTPPropertyGridItem |
SetMultiLinesCount(int nLinesCount) | CXTPPropertyGridItem |
SetPasswordMask(TCHAR chMask=_T(' *')) | CXTPPropertyGridItem |
SetPrompt(LPCTSTR lpszPrompt) | CXTPPropertyGridItem |
SetReadOnly(BOOL bReadOnly=TRUE) | CXTPPropertyGridItem | virtual
SetTooltip(LPCTSTR lpstrTooltip) | CXTPPropertyGridItem |
SetValue(CString strValue) | CXTPPropertyGridItemEnum | protectedvirtual
SetVisible(BOOL bVisible) | CXTPPropertyGridItem | protectedvirtual
~CXTPPropertyGridItem() | CXTPPropertyGridItem | virtual
~CXTPPropertyGridItemEnum() | CXTPPropertyGridItemEnum | virtual


Toolkit Pro: XTPDisableNoisyWarnings.h Source File

  • Source
  • Common
  • Base
  • Diagnostic
XTPDisableNoisyWarnings.h
Go to the documentation of this file.
1
24#define XTP_INTERNAL_WARNING_CONTROL
25#define XTP_DISABLE_ADVANCED_WARNINGS
26#include "Common/Base/Diagnostic/XTPEnableAdvancedWarnings.h"
27
XTPEnableAdvancedWarnings.h


Toolkit Pro: XTPChartContent.h Source File

  • Source
  • Chart
XTPChartContent.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTCONTENT_H__)
24# define __XTPCHARTCONTENT_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartDeviceContext;
34class CXTPChartDiagram;
35class CXTPChartTitleCollection;
36class CXTPChartElementView;
37class CXTPChartSeriesCollection;
38class CXTPChartLegend;
39class CXTPChartPanelCollection;
40class CXTPChartSeries;
41class CXTPChartAppearance;
42class CXTPChartLegendView;
43class CXTPPropExchange;
44class CXTPMarkupContext;
45class CXTPChartContentView;
46class CXTPChartDiagramView;
47class CXTPChartBorder;
48class CXTPChartDeviceCommand;
53enum XTPChartPanelDirection
54{
55 xtpChartPanelVertical,
56 xtpChartPanelHorizontal
57};
58
65class _XTP_EXT_CLASS CXTPChartContent : public CXTPChartElement
66{
68 DECLARE_DYNAMIC(CXTPChartContent)
70public:
75 CXTPChartContent();
76
81 virtual ~CXTPChartContent();
82
83public:
91 CXTPChartTitleCollection* GetTitles() const;
92
100 CXTPChartSeriesCollection* GetSeries() const;
101
109 CXTPChartLegend* GetLegend() const;
110
119 CXTPChartDiagram* GetPrimaryDiagram() const;
120
128 CXTPChartPanelCollection* GetPanels() const;
129
137 CXTPChartAppearance* GetAppearance() const;
138
146 CXTPChartBorder* GetBorder() const;
147
148public:
156 void DrawContent(CXTPChartDeviceContext* pDC, CRect rcBounds);
157
168 CXTPChartDeviceCommand* CreateDeviceComand(CXTPChartDeviceContext* pDC, CRect rcBounds);
169
182 CXTPChartDeviceContext* CreateDeviceContext(CXTPChartContainer* pContainer, HDC hDC,
183 CRect rcBounds, BOOL bWindowDC);
184
185public:
193 CXTPChartColor GetBackgroundColor() const;
194
201 void SetBackgroundColor(const CXTPChartColor& clr);
202
214 CXTPChartColor GetActualBackgroundColor() const;
215
223 CXTPChartColor GetActualBorderColor() const;
224
232 virtual void OnChartChanged(XTPChartUpdateOptions updateOptions = xtpChartUpdateView);
233
234public:
246 virtual void DoPropExchange(CXTPPropExchange* pPX);
247
248protected:
257 virtual CXTPChartContentView* CreateView(CXTPChartDeviceContext* pDC, CRect rcBounds);
258
263 void UpdateDiagram();
264
272 virtual void OnSeriesStyleChanged(CXTPChartSeries* pSeries);
273
274public:
285 int GetPanelDistance() const;
286
293 void SetPanelDistance(int nDistance);
294
304 XTPChartPanelDirection GetPanelDirection() const;
305
314 void SetPanelDirection(XTPChartPanelDirection nDirection);
315
316public:
323 void EnableMarkup(BOOL bEnable = TRUE);
324
332 CXTPMarkupContext* GetMarkupContext() const;
333
334protected:
335 void AddContainer(CXTPChartContainer* pContainer);
336 void RemoveContainer(CXTPChartContainer* pContainer);
337 BOOL HasVisible3dSeries() const;
338
339# ifdef _XTP_ACTIVEX
340public:
342 DECLARE_DISPATCH_MAP()
343 DECLARE_INTERFACE_MAP()
344
345 DECLARE_OLETYPELIB_EX(CXTPChartContent);
346 DECLARE_OLECREATE_EX(CXTPChartContent)
347
348 afx_msg LPDISPATCH OleGetSeries();
349 afx_msg LPDISPATCH OleGetDiagrams();
350 afx_msg LPDISPATCH OleGetTitles();
351 afx_msg LPDISPATCH OleGetAppearance();
352 afx_msg LPDISPATCH OleGetLegend();
353 afx_msg LPDISPATCH OleGetBorder();
354
355 afx_msg BOOL OleGetEnableMarkup();
356 afx_msg void OleSetEnableMarkup(BOOL bEnabled);
357 afx_msg void OleDoPropExchange(LPDISPATCH lpPropExchage);
358 afx_msg OLE_COLOR OleGetBackgroundColor();
359 afx_msg void OleSetBackgroundColor(OLE_COLOR clr);
360
361 COleControl* GetOleControl();
362
364# endif
365
366protected:
367 CXTPChartPanelCollection* m_pPanels;
368 CXTPChartTitleCollection* m_pTitles;
369 CXTPChartSeriesCollection* m_pSeries;
370 CXTPChartLegend* m_pLegend;
372 CXTPChartAppearance* m_pAppearance;
374 CXTPChartBorder* m_pBorder;
376 CXTPChartColor m_clrBackground;
378 CArray<CXTPChartContainer*, CXTPChartContainer*> m_arrContainers; // The chart containers*/
379
380 CXTPMarkupContext* m_pMarkupContext;
382 int m_nPanelDistance;
383 XTPChartPanelDirection m_nPanelDirection;
385 friend class CXTPChartSeriesCollection;
386 friend class CXTPChartSeries;
387 friend class CXTPChartControl;
388};
389
390AFX_INLINE CXTPChartTitleCollection* CXTPChartContent::GetTitles() const
391{
392 return m_pTitles;
393}
394
395AFX_INLINE CXTPChartSeriesCollection* CXTPChartContent::GetSeries() const
396{
397 return m_pSeries;
398}
399AFX_INLINE CXTPChartLegend* CXTPChartContent::GetLegend() const
400{
401 return m_pLegend;
402}
403AFX_INLINE CXTPChartPanelCollection* CXTPChartContent::GetPanels() const
404{
405 return m_pPanels;
406}
407AFX_INLINE CXTPChartAppearance* CXTPChartContent::GetAppearance() const
408{
409 return m_pAppearance;
410}
411AFX_INLINE CXTPMarkupContext* CXTPChartContent::GetMarkupContext() const
412{
413 return m_pMarkupContext;
414}
415AFX_INLINE int CXTPChartContent::GetPanelDistance() const
416{
417 return m_nPanelDistance;
418}
419AFX_INLINE void CXTPChartContent::SetPanelDistance(int nDistance)
420{
421 m_nPanelDistance = nDistance;
422 OnChartChanged();
423}
424AFX_INLINE XTPChartPanelDirection CXTPChartContent::GetPanelDirection() const
425{
426 return m_nPanelDirection;
427}
428AFX_INLINE void CXTPChartContent::SetPanelDirection(XTPChartPanelDirection nDirection)
429{
430 m_nPanelDirection = nDirection;
431 OnChartChanged();
432}
433AFX_INLINE void CXTPChartContent::SetBackgroundColor(const CXTPChartColor& clr)
434{
435 m_clrBackground = clr;
436 OnChartChanged();
437}
438AFX_INLINE CXTPChartBorder* CXTPChartContent::GetBorder() const
439{
440 return m_pBorder;
441}
443# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
444#endif //#if !defined(__XTPCHARTCONTENT_H__)
XTPChartPanelDirection
XTPChartPanelDirection
Specified chart panel direction.
Definition XTPChartContent.h:54
xtpChartPanelVertical
@ xtpChartPanelVertical
Specifies vertical chart panel direction.
Definition XTPChartContent.h:55
xtpChartPanelHorizontal
@ xtpChartPanelHorizontal
Specifies horizontal chart panel direction.
Definition XTPChartContent.h:56
XTPChartUpdateOptions
XTPChartUpdateOptions
Specifies chart update options.
Definition XTPChartElement.h:45
xtpChartUpdateView
@ xtpChartUpdateView
Recreate View.
Definition XTPChartElement.h:46
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartAppearance
This class represents the appearance of the chart.
Definition XTPChartAppearance.h:629
CXTPChartBorder
This class abstracts the border of a chart, it is a kind of chart element.
Definition XTPChartBorder.h:42
CXTPChartColor
This class abstracts a color entity.
Definition XTPChartTypes.h:51
CXTPChartContainer
This class represents the chart container.
Definition XTPChartElement.h:232
CXTPChartContent
This class represents chart content, which is a kind of CXTPChartElement.
Definition XTPChartContent.h:66
CXTPChartContent::DrawContent
void DrawContent(CXTPChartDeviceContext *pDC, CRect rcBounds)
Call this function to draw the chart content.
CXTPChartContent::m_pPanels
CXTPChartPanelCollection * m_pPanels
The panel collection.
Definition XTPChartContent.h:367
CXTPChartContent::DoPropExchange
virtual void DoPropExchange(CXTPPropExchange *pPX)
Call this member function to Store/Load the properties of content using the specified data object.
CXTPChartContent::CreateView
virtual CXTPChartContentView * CreateView(CXTPChartDeviceContext *pDC, CRect rcBounds)
Call this function to calculate the view of the chart content.
CXTPChartContent::~CXTPChartContent
virtual ~CXTPChartContent()
Destroys a CXTPChartContent object, handles cleanup.
CXTPChartContent::SetBackgroundColor
void SetBackgroundColor(const CXTPChartColor &clr)
Call this function to set the background color of the chart content.
Definition XTPChartContent.h:433
CXTPChartContent::m_pAppearance
CXTPChartAppearance * m_pAppearance
The chart appearance object.
Definition XTPChartContent.h:372
CXTPChartContent::GetPanelDirection
XTPChartPanelDirection GetPanelDirection() const
Call this function to get the layout direction of panels either top-to-bottom or left-to-right.
Definition XTPChartContent.h:424
CXTPChartContent::GetPrimaryDiagram
CXTPChartDiagram * GetPrimaryDiagram() const
Call this function to get the primary diagram of the chart.
CXTPChartContent::GetAppearance
CXTPChartAppearance * GetAppearance() const
Call this function to get the appearance of the chart.
Definition XTPChartContent.h:407
CXTPChartContent::EnableMarkup
void EnableMarkup(BOOL bEnable=TRUE)
Call this method to enable markup for tab captions.
CXTPChartContent::m_pTitles
CXTPChartTitleCollection * m_pTitles
The title collection.
Definition XTPChartContent.h:368
CXTPChartContent::SetPanelDirection
void SetPanelDirection(XTPChartPanelDirection nDirection)
Call this function to set the layout direction of panels either top-to-bottom or left-to-right.
Definition XTPChartContent.h:428
CXTPChartContent::m_nPanelDirection
XTPChartPanelDirection m_nPanelDirection
Panel direction.
Definition XTPChartContent.h:383
CXTPChartContent::GetPanelDistance
int GetPanelDistance() const
Call this function to get the distance between 2 panels.
Definition XTPChartContent.h:415
CXTPChartContent::CreateDeviceContext
CXTPChartDeviceContext * CreateDeviceContext(CXTPChartContainer *pContainer, HDC hDC, CRect rcBounds, BOOL bWindowDC)
Call this function to create the device context for the drawing.
CXTPChartContent::SetPanelDistance
void SetPanelDistance(int nDistance)
Call this function to set the distance between 2 panels.
Definition XTPChartContent.h:419
CXTPChartContent::m_pBorder
CXTPChartBorder * m_pBorder
The chart border.
Definition XTPChartContent.h:374
CXTPChartContent::m_pLegend
CXTPChartLegend * m_pLegend
The legend object.
Definition XTPChartContent.h:370
CXTPChartContent::GetMarkupContext
CXTPMarkupContext * GetMarkupContext() const
Retrieves a pointer to the markup context.
Definition XTPChartContent.h:411
CXTPChartContent::CreateDeviceComand
CXTPChartDeviceCommand * CreateDeviceComand(CXTPChartDeviceContext *pDC, CRect rcBounds)
Call this function to create the device command tree.
CXTPChartContent::GetActualBackgroundColor
CXTPChartColor GetActualBackgroundColor() const
Call this function to get the appearance background color of the chart content.
CXTPChartContent::m_pMarkupContext
CXTPMarkupContext * m_pMarkupContext
Markup context.
Definition XTPChartContent.h:380
CXTPChartContent::GetSeries
CXTPChartSeriesCollection * GetSeries() const
Call this function to get the series collection object.
Definition XTPChartContent.h:395
CXTPChartContent::GetBorder
CXTPChartBorder * GetBorder() const
Call this function to get the border of the chart.
Definition XTPChartContent.h:438
CXTPChartContent::GetTitles
CXTPChartTitleCollection * GetTitles() const
Call this function to get the title collection object.
Definition XTPChartContent.h:390
CXTPChartContent::GetPanels
CXTPChartPanelCollection * GetPanels() const
Call this function to get the panels of the chart.
Definition XTPChartContent.h:403
CXTPChartContent::CXTPChartContent
CXTPChartContent()
Constructs a CXTPChartContent object.
CXTPChartContent::UpdateDiagram
void UpdateDiagram()
Call this function to update the color of the points from the palette.
CXTPChartContent::m_nPanelDistance
int m_nPanelDistance
Panel distance.
Definition XTPChartContent.h:382
CXTPChartContent::OnSeriesStyleChanged
virtual void OnSeriesStyleChanged(CXTPChartSeries *pSeries)
Call this function to update the chart content whenever there is a change in the series style.
CXTPChartContent::OnChartChanged
virtual void OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this function whenever a change occurs in the chart content.
CXTPChartContent::GetBackgroundColor
CXTPChartColor GetBackgroundColor() const
Call this function to get the background color of the chart content.
CXTPChartContent::m_pSeries
CXTPChartSeriesCollection * m_pSeries
The series collection.
Definition XTPChartContent.h:369
CXTPChartContent::m_clrBackground
CXTPChartColor m_clrBackground
The chart background color.
Definition XTPChartContent.h:376
CXTPChartContent::GetActualBorderColor
CXTPChartColor GetActualBorderColor() const
Call this function to get the appearance border color.
CXTPChartContent::GetLegend
CXTPChartLegend * GetLegend() const
Call this function to get the chart legend object.
Definition XTPChartContent.h:399
CXTPChartContentView
This class represents the view of the chart content, which is a kind of CXTPChartElementView.
Definition XTPChartContentView.h:56
CXTPChartControl
CXTPChartControl is a CWnd derived class.
Definition XTPChartControl.h:52
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartDiagram
This class represents a chart diagram, which is a kind of CXTPChartElement.
Definition XTPChartDiagram.h:48
CXTPChartDiagramView
This class represents the view of a chart diagram, which is a kind of CXTPChartElementView.
Definition XTPChartDiagramView.h:49
CXTPChartElement
This class abstracts a chart element, this class acts as a base class for all chart elements.
Definition XTPChartElement.h:131
CXTPChartElement::GetAppearance
CXTPChartAppearance * GetAppearance() const
Call this function to get the the appearance of the chart.
CXTPChartElementView
This class represents the view of a chart element.
Definition XTPChartElementView.h:47
CXTPChartLegend
This class represents a chart legend as a kind of chart element.
Definition XTPChartLegend.h:88
CXTPChartLegendView
This class abstracts the view of a legend and its child items in a bounding rectangle context.
Definition XTPChartLegendView.h:49
CXTPChartPanelCollection
This class abstracts a chart panel collection.
Definition XTPChartPanel.h:99
CXTPChartSeriesCollection
This class represents the collection of series in the chart, which is a kind of CXTPChartElement.
Definition XTPChartSeries.h:339
CXTPChartSeries
This class represents a series in the chart, which is a kind of CXTPChartElement.
Definition XTPChartSeries.h:50
CXTPChartTitleCollection
CXTPChartTitleCollection represents a collection of chart titles.
Definition XTPChartTitle.h:339
CXTPMarkupContext
CXTPMarkupContext is a standalone class used to provide common settings for Markup objects.
Definition XTPMarkupContext.h:128
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72


Toolkit Pro: Member List

CXTPTimeEdit Member List

This is the complete list of members for CXTPTimeEdit, including all inherited members.

AdjustBuddyRect(CWnd *pBuddy, CRect &rcUpDown, int nAlignment) | CXTPEdit |
CanOverType() const | CXTPMaskEditT< CEdit > | inline
CanPaste() | CXTPEdit | virtual
CanUseMask() const | CXTPMaskEditT< CEdit > | inline
CheckChar(TCHAR &nChar, int nPos) | CXTPMaskEditT< CEdit > | inlinevirtual
ConvertUnicodeAlpha(TCHAR nChar, BOOL bUpperCase) const | CXTPMaskEditT< CEdit > | inline
CopyToClipboard(const CString &strText) | CXTPMaskEditT< CEdit > | inline
CXTPDateEdit() | CXTPDateEdit |
CXTPEdit() | CXTPEdit |
CXTPMaskEdit() | CXTPMaskEdit |
CXTPMaskEditT() | CXTPMaskEditT< CEdit > | inline
CXTPTimeEdit() | CXTPTimeEdit |
DeleteCharAt(int iPos) | CXTPMaskEditT< CEdit > | inline
DrawBuddyBorders(CWnd *pBuddy, CDC *pDC, CRect rc, int nAlignment) | CXTPEdit |
FormatOleDateTime(CString &strData, COleDateTime dt) | CXTPTimeEdit | virtual
GetClientBrush(CDC *pDC) | CXTPEdit | protected
GetDateTime() | CXTPDateEdit | virtual
GetFlatStyle() const | CXTPEdit |
GetHours() const | CXTPTimeEdit |
GetMaskedText(int nStartPos=0, int nEndPos=-1) const | CXTPMaskEditT< CEdit > | inline
GetMins() const | CXTPTimeEdit |
GetPromptChar() const | CXTPMaskEditT< CEdit > | inline
GetPromptString(int nLength) const | CXTPMaskEditT< CEdit > | inline
GetTheme() | CXTPEdit |
GetThemeID() | CXTPEdit |
GetUseVisualStyle() const | CXTPEdit |
GetWindowDateTime() | CXTPDateEdit | virtual
HasSelection() const | CXTPEdit |
Initialize(CWnd *pParentWnd) | CXTPMaskEdit | virtual
InsertCharAt(int iPos, TCHAR nChar) | CXTPMaskEditT< CEdit > | inline
IsFlatStyle() const | CXTPEdit |
IsFocused() const | CXTPEdit |
IsHighlighted() const | CXTPEdit |
IsModified() const | CXTPMaskEditT< CEdit > | inline
IsPatternValid() | CXTPEdit |
m_bFocused | CXTPEdit | protected
m_bHighlighted | CXTPEdit | protected
m_bMilitary | CXTPTimeEdit | protected
m_bModified | CXTPMaskEditT< CEdit > | protected
m_bOverType | CXTPMaskEditT< CEdit > | protected
m_bPreSubclassInit | CXTPEdit | protected
m_bRedo | CXTPMaskEditT< CEdit > | protected
m_bShowBorder | CXTPEdit | protected
m_bUpdateUndo | CXTPMaskEditT< CEdit > | protected
m_bUseMask | CXTPMaskEditT< CEdit > | protected
m_chPrompt | CXTPMaskEditT< CEdit > | protected
m_iHours | CXTPTimeEdit | protected
m_iMins | CXTPTimeEdit | protected
m_nEndChar | CXTPMaskEditT< CEdit > | protected
m_nStartChar | CXTPMaskEditT< CEdit > | protected
m_pRegExp | CXTPEdit | protected
m_pTheme | CXTPEdit | protected
m_strDefault | CXTPMaskEditT< CEdit > | protected
m_strLiteral | CXTPMaskEditT< CEdit > | protected
m_strMask | CXTPMaskEditT< CEdit > | protected
m_strRedoBuffer | CXTPMaskEditT< CEdit > | protected
m_strUndoBuffer | CXTPMaskEditT< CEdit > | protected
m_strWindowText | CXTPMaskEditT< CEdit > | protected
MaskClear() | CXTPMaskEditT< CEdit > | inline
MaskCopy() | CXTPMaskEditT< CEdit > | inline
MaskCut() | CXTPMaskEditT< CEdit > | inline
MaskDeleteSel() | CXTPMaskEditT< CEdit > | inline
MaskPaste() | CXTPMaskEditT< CEdit > | inline
MaskReplaceSel(LPCTSTR lpszNewText) | CXTPMaskEditT< CEdit > | inline
MaskSelectAll() | CXTPMaskEditT< CEdit > | inline
MaskUndo() | CXTPMaskEditT< CEdit > | inline
OnCommand(WPARAM wParam, LPARAM lParam) | CXTPMaskEditT< CEdit > | inlineprotectedvirtual
PosInRange(int iPos) const | CXTPMaskEditT< CEdit > | inline
PreTranslateMessage(MSG *pMsg) | CXTPMaskEditT< CEdit > | inlinevirtual
ProcessMask(TCHAR &nChar, int nEndPos) | CXTPTimeEdit | virtual
ReadOleDateTime(LPCTSTR lpszData) | CXTPDateEdit | virtual
RedrawEdit() | CXTPEdit | protected
RedrawFocusedFrame() | CXTPEdit | protected
RefreshMetrics() | CXTPEdit | virtual
SetDateTime(COleDateTime &dt) | CXTPDateEdit | virtual
SetDateTime(LPCTSTR strDate) | CXTPDateEdit | virtual
SetEditMask(LPCTSTR lpszMask, LPCTSTR lpszLiteral, LPCTSTR lpszDefault=NULL) | CXTPEdit | virtual
SetFlatStyle(BOOL bFlatStyle=TRUE) | CXTPEdit |
SetHours(int nHours) | CXTPTimeEdit | virtual
SetMaskedText(LPCTSTR lpszMaskedText, int iPos=0, BOOL bUpdateWindow=TRUE) | CXTPMaskEditT< CEdit > | inline
SetMilitary(BOOL bMilitary=TRUE) | CXTPTimeEdit |
SetMins(int nMins) | CXTPTimeEdit | virtual
SetOverType(BOOL bOverType) | CXTPMaskEditT< CEdit > | inline
SetPattern(LPCTSTR lpszPattern) | CXTPEdit |
SetPromptChar(TCHAR ch, BOOL bAutoReplace=TRUE) | CXTPMaskEditT< CEdit > | inline
SetTheme(XTPControlTheme nTheme) | CXTPEdit | virtual
SetTime(int nHours, int nMins) | CXTPTimeEdit | virtual
SetUseMask(BOOL bUseMask) | CXTPMaskEditT< CEdit > | inline
SetUseVisualStyle(BOOL bUseVisualStyle=TRUE) | CXTPEdit |
ShowBorder() const | CXTPEdit |
ShowThemedBorder(BOOL bShowThemedBorder) | CXTPEdit |
~CXTPEdit() | CXTPEdit | virtual


Toolkit Pro: XTPRibbonThemeOffice2013.h Source File

  • Source
  • Ribbon
  • Themes
XTPRibbonThemeOffice2013.h
Go to the documentation of this file.
1
23#if !defined(__XTPRIBBONTHEMEOFFICE2013_H__)
24# define __XTPRIBBONTHEMEOFFICE2013_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
37struct XTPRIBBON_HEADER_COLOR
38{
39 COLORREF clrEdge;
40 COLORREF clrBack;
41 COLORREF clrText;
42};
43
49class _XTP_EXT_CLASS CXTPRibbonOffice2013Theme : public CXTPRibbonMarkupTheme
50{
52 DECLARE_DYNAMIC(CXTPRibbonOffice2013Theme)
54public:
60 CXTPRibbonOffice2013Theme(CXTPPaintManager* pPaintManager);
61
66 virtual ~CXTPRibbonOffice2013Theme();
67
77 virtual void RefreshMetrics();
78
86 virtual int GetRibbonCaptionHeight(const CXTPRibbonBar* pRibbonBar) const;
87
95 virtual void DrawQuickAccessControl(CDC* pDC, CXTPRibbonBar* pRibbon, CXTPControl* pControl);
96
103 virtual void DrawRibbonTab(CDC* pDC, CXTPRibbonTab* pItem);
104
112 virtual void DrawRibbonFrameContextHeaders(CDC* pDC, CXTPRibbonBar* pRibbonBar,
113 CXTPRibbonTabContextHeaders* pContextHeaders);
114
121 virtual void FillRibbonBar(CDC* pDC, CXTPRibbonBar* pRibbonBar);
122
131 virtual void DrawRibbonFrameCaptionBar(CDC* pDC, CXTPRibbonBar* pRibbonBar, BOOL bActive);
132
140 virtual void DrawRibbonFrameCaption(CDC* pDC, CXTPRibbonBar* pRibbonBar, BOOL bActive);
141
168 virtual void SetBackImage(int nImage);
169
177 virtual void DrawRibbonFrameSystemButton(CDC* pDC, CXTPRibbonControlSystemButton* pControl,
178 CRect rc);
179
180protected:
191 virtual CString GetBackImageName();
192
199 virtual void DrawBackImage(CDC* pDC, CXTPRibbonBar* pRibbonBar);
200
206 virtual void LoadParts(BOOL bReload = FALSE);
207
212 class CThemeStaticExtension : public CXTPMarkupStaticExtension
213 {
214 public:
219 CThemeStaticExtension();
220 };
221
222 XTPRIBBON_HEADER_COLOR m_clrHeader[24];
227 COLORREF m_clrRibbonInactiveFaceState; // Color of the ribbon when the application is inactive.
228 COLORREF m_clrTabBackInactiveState;
230 COLORREF m_clrTabBackackstageLeft;
235 COLORREF m_clrTabBackackstageRight; // Color of right part of the ribbon tab when new backstage
239 COLORREF m_clrRibbonTabDelimeter; // Tab delimiter color when item is shrinked.
240
241private:
242 int m_nBackImage;
243 int m_nCaptionHeight;
244 CString m_strThemeName;
245};
246
247# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
249#endif // !defined(__XTPRIBBONTHEMEOFFICE2013_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPControl
CXTPControl is a CXTPCmdTarget derived class.
Definition XTPControl.h:841
CXTPMarkupStaticExtension
A base class for a markup static extension composite object.
Definition XTPMarkupStaticExtension.h:41
CXTPPaintManager
Paint manager of the command bars.
Definition XTPPaintManager.h:199
CXTPRibbonBar
CXTPRibbonBar is a CXTPMenuBar derived class.
Definition XTPRibbonBar.h:69
CXTPRibbonControlSystemButton
CXTPRibbonControlSystemButton is a CXTPControlPopup derived class used as a system button for a Ribbo...
Definition XTPRibbonSystemButton.h:39
CXTPRibbonMarkupTheme
CXTPRibbonMarkupTheme class.
Definition XTPRibbonMarkupTheme.h:147
CXTPRibbonOffice2013Theme::CThemeStaticExtension
Helper class used to define variables to be used by XAML Markup code.
Definition XTPRibbonThemeOffice2013.h:213
CXTPRibbonOffice2013Theme::CThemeStaticExtension::CThemeStaticExtension
CThemeStaticExtension()
Default constructor, initializes CXTPMarkupStaticExtension variables.
CXTPRibbonOffice2013Theme
CXTPRibbonOffice2013Theme is a CXTPRibbonMarkupTheme derived class used to represent an Office 2013 r...
Definition XTPRibbonThemeOffice2013.h:50
CXTPRibbonOffice2013Theme::DrawQuickAccessControl
virtual void DrawQuickAccessControl(CDC *pDC, CXTPRibbonBar *pRibbon, CXTPControl *pControl)
Draws the specified control which is a part of the Quick Access panel.
CXTPRibbonOffice2013Theme::DrawRibbonFrameSystemButton
virtual void DrawRibbonFrameSystemButton(CDC *pDC, CXTPRibbonControlSystemButton *pControl, CRect rc)
Draws the top-left system button.
CXTPRibbonOffice2013Theme::FillRibbonBar
virtual void FillRibbonBar(CDC *pDC, CXTPRibbonBar *pRibbonBar)
This method is called to fill the background of a ribbon bar control.
CXTPRibbonOffice2013Theme::~CXTPRibbonOffice2013Theme
virtual ~CXTPRibbonOffice2013Theme()
Destroys a CXTPRibbonOffice2013Theme object, handles cleanup and deallocation.
CXTPRibbonOffice2013Theme::m_clrRibbonInactiveFaceState
COLORREF m_clrRibbonInactiveFaceState
context tabs.
Definition XTPRibbonThemeOffice2013.h:227
CXTPRibbonOffice2013Theme::DrawRibbonTab
virtual void DrawRibbonTab(CDC *pDC, CXTPRibbonTab *pItem)
This method is called to draw a single tab of the ribbon bar.
CXTPRibbonOffice2013Theme::m_clrTabBackackstageRight
COLORREF m_clrTabBackackstageRight
pop-up.
Definition XTPRibbonThemeOffice2013.h:235
CXTPRibbonOffice2013Theme::m_clrRibbonTabDelimeter
COLORREF m_clrRibbonTabDelimeter
is pop-up.
Definition XTPRibbonThemeOffice2013.h:239
CXTPRibbonOffice2013Theme::DrawRibbonFrameCaption
virtual void DrawRibbonFrameCaption(CDC *pDC, CXTPRibbonBar *pRibbonBar, BOOL bActive)
This method is called to draw the Ribbon caption.
CXTPRibbonOffice2013Theme::SetBackImage
virtual void SetBackImage(int nImage)
This member function will set the background image for the Office ribbon bar.
CXTPRibbonOffice2013Theme::DrawBackImage
virtual void DrawBackImage(CDC *pDC, CXTPRibbonBar *pRibbonBar)
Used by the theme to draw the background image for the ribbon bar.
CXTPRibbonOffice2013Theme::LoadParts
virtual void LoadParts(BOOL bReload=FALSE)
Loads markup parts.
CXTPRibbonOffice2013Theme::CXTPRibbonOffice2013Theme
CXTPRibbonOffice2013Theme(CXTPPaintManager *pPaintManager)
Constructs a CXTPRibbonOffice2013Theme object.
CXTPRibbonOffice2013Theme::RefreshMetrics
virtual void RefreshMetrics()
This method is called to refresh the visual metrics of the manager.
CXTPRibbonOffice2013Theme::GetBackImageName
virtual CString GetBackImageName()
This member function is used to get the name of the background image located in the Office 2013 resou...
CXTPRibbonOffice2013Theme::DrawRibbonFrameContextHeaders
virtual void DrawRibbonFrameContextHeaders(CDC *pDC, CXTPRibbonBar *pRibbonBar, CXTPRibbonTabContextHeaders *pContextHeaders)
This method is called to draw ribbon context headers.
CXTPRibbonOffice2013Theme::m_clrTabBackackstageLeft
COLORREF m_clrTabBackackstageLeft
Color of left part of the ribbon tab when new backstage is.
Definition XTPRibbonThemeOffice2013.h:230
CXTPRibbonOffice2013Theme::DrawRibbonFrameCaptionBar
virtual void DrawRibbonFrameCaptionBar(CDC *pDC, CXTPRibbonBar *pRibbonBar, BOOL bActive)
This method is called to draw the ribbon caption if EnableFrameTheme was not called.
CXTPRibbonOffice2013Theme::GetRibbonCaptionHeight
virtual int GetRibbonCaptionHeight(const CXTPRibbonBar *pRibbonBar) const
Calculates the ribbon caption height.
CXTPRibbonOffice2013Theme::m_clrTabBackInactiveState
COLORREF m_clrTabBackInactiveState
Color of the ribbon tab when the application is inactive.
Definition XTPRibbonThemeOffice2013.h:228
CXTPRibbonTab
Represents a tab in the Ribbon Bar.
Definition XTPRibbonTab.h:116
XTPRIBBON_HEADER_COLOR
Struct used to define context tab colors for the ribbon control.
Definition XTPRibbonThemeOffice2013.h:38
XTPRIBBON_HEADER_COLOR::clrEdge
COLORREF clrEdge
An RGB value representing context tab border color.
Definition XTPRibbonThemeOffice2013.h:39
XTPRIBBON_HEADER_COLOR::clrBack
COLORREF clrBack
An RGB value representing context tab background color.
Definition XTPRibbonThemeOffice2013.h:40
XTPRIBBON_HEADER_COLOR::clrText
COLORREF clrText
An RGB value representing context tab text color.
Definition XTPRibbonThemeOffice2013.h:41


Toolkit Pro: Member List

XTP_TPNENDLABELEDIT Member List

This is the complete list of members for XTP_TPNENDLABELEDIT, including all inherited members.

pItem | XTP_TPNENDLABELEDIT
strNewString | XTP_TPNENDLABELEDIT


Toolkit Pro: XTPGridSubListControl.h Source File

  • Source
  • GridControl
XTPGridSubListControl.h
Go to the documentation of this file.
1
23#if !defined(__XTPGRIDSUBLISTCONTROL_H__)
24# define __XTPGRIDSUBLISTCONTROL_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPGridHeaderDragWnd;
34class CXTPGridControl;
35class CXTPGridColumn;
59class _XTP_EXT_CLASS CXTPGridSubListControl : public CListBox
60{
62 DECLARE_DYNAMIC(CXTPGridSubListControl)
64public:
87 CXTPGridSubListControl();
88
94 ~CXTPGridSubListControl();
95
96public:
110 BOOL SetGridCtrl(CXTPGridControl* pGridCtrl);
111
113 _XTP_DEPRECATED_IN_FAVOR(SetGridCtrl)
114 BOOL SetReportCtrl(CXTPGridControl* pGridCtrl);
125 CXTPGridControl* GetGridCtrl();
126
128 _XTP_DEPRECATED_IN_FAVOR(GetGridCtrl)
129 CXTPGridControl* GetReportCtrl();
132public:
146 BOOL UpdateList();
147
155 virtual BOOL Include(int iSubItem);
156
164 virtual BOOL Disable(int iSubItem);
165
171 void SortAscending(BOOL bSort);
172
180 CString GetItemCaption(int nIndex);
181
189 CXTPGridColumn* GetItemColumn(int nIndex);
190
191protected:
199 int FindItemData(int nItemData);
200
216 BOOL BeginDrag(int nItem);
217
238 UINT Dragging(CPoint pt);
239
249 void CancelDrag();
250
262 void Dropped(CPoint pt);
263
264protected:
266 DECLARE_MESSAGE_MAP()
267
268 void ParentNotify_SelChangd();
269 //{{AFX_VIRTUAL(CXTPGridSubListControl)
270public:
271 virtual void DrawItem(LPDRAWITEMSTRUCT lpDrawItemStruct);
272
273protected:
274 virtual void PreSubclassWindow();
275 virtual void MeasureItem(LPMEASUREITEMSTRUCT)
276 {
277 }
278 //}}AFX_VIRTUAL
279
280 //{{AFX_MSG(CXTPGridSubListControl)
281 afx_msg BOOL OnEraseBkgnd(CDC* pDC);
282 afx_msg void OnLButtonDown(UINT nFlags, CPoint point);
283 afx_msg void OnPaint();
284 afx_msg LRESULT OnPrintClient(WPARAM wParam, LPARAM lParam);
285 //}}AFX_MSG
288protected:
289 CXTPGridControl* m_pGridCtrl;
291 CXTPGridHeaderDragWnd* m_pDragWnd;
292 CRect m_rcDragWnd;
293 CRect m_rcDropTarget1;
294 CRect m_rcDropTarget2;
296 int m_nDropIndex;
297 BOOL m_bSortAscending;
298};
300AFX_INLINE BOOL CXTPGridSubListControl::SetReportCtrl(CXTPGridControl* pGridCtrl)
301{
302 return SetGridCtrl(pGridCtrl);
303}
304
305AFX_INLINE CXTPGridControl* CXTPGridSubListControl::GetReportCtrl()
306{
307 return GetGridCtrl();
308}
309
310# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
311#endif //#if !defined(__XTPGRIDSUBLISTCONTROL_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPGridColumn
Represents a grid column item with its properties and operations.
Definition XTPGridColumn.h:107
CXTPGridControl
The CXTPGridControl class provides an implementation of the Grid control.
Definition XTPGridControl.h:479
CXTPGridHeaderDragWnd
CXTPGridHeaderDragWnd is a CWnd derived class.
Definition XTPGridDragDrop.h:43
CXTPGridSubListControl
Field chooser list box control.
Definition XTPGridSubListControl.h:60
CXTPGridSubListControl::GetGridCtrl
CXTPGridControl * GetGridCtrl()
Gets the associated Grid control.
CXTPGridSubListControl::Disable
virtual BOOL Disable(int iSubItem)
Not used currently.
CXTPGridSubListControl::SortAscending
void SortAscending(BOOL bSort)
Specifies if the list should be sorted in ascending order.
CXTPGridSubListControl::m_pDragWnd
CXTPGridHeaderDragWnd * m_pDragWnd
Pointer to the associated dragging window.
Definition XTPGridSubListControl.h:291
CXTPGridSubListControl::FindItemData
int FindItemData(int nItemData)
Retrieves the index of an item by its data.
CXTPGridSubListControl::SetGridCtrl
BOOL SetGridCtrl(CXTPGridControl *pGridCtrl)
Sets the associated Grid control.
CXTPGridSubListControl::Dragging
UINT Dragging(CPoint pt)
Called by the framework when an item is being dragged within the CDragListBox object.
CXTPGridSubListControl::m_nDropIndex
int m_nDropIndex
Drop item index.
Definition XTPGridSubListControl.h:296
CXTPGridSubListControl::CancelDrag
void CancelDrag()
Called by the framework when a drag operation has been canceled.
CXTPGridSubListControl::GetItemColumn
CXTPGridColumn * GetItemColumn(int nIndex)
Retrieves the column object of an item by its index.
CXTPGridSubListControl::CXTPGridSubListControl
CXTPGridSubListControl()
Constructs a CXTPGridSubListControl object.
CXTPGridSubListControl::Dropped
void Dropped(CPoint pt)
Called by the framework when an item is dropped within a CDragListBox object.
CXTPGridSubListControl::m_rcDropTarget1
CRect m_rcDropTarget1
First drop target - the list window itself.
Definition XTPGridSubListControl.h:293
CXTPGridSubListControl::GetItemCaption
CString GetItemCaption(int nIndex)
Retrieves the caption of an item by its index.
CXTPGridSubListControl::m_rcDragWnd
CRect m_rcDragWnd
Coordinates of the associated dragging window.
Definition XTPGridSubListControl.h:292
CXTPGridSubListControl::BeginDrag
BOOL BeginDrag(int nItem)
Called by the framework when a drag operation starts.
CXTPGridSubListControl::Include
virtual BOOL Include(int iSubItem)
Not used currently.
CXTPGridSubListControl::UpdateList
BOOL UpdateList()
Updates columns list data in the field chooser.
CXTPGridSubListControl::m_pGridCtrl
CXTPGridControl * m_pGridCtrl
Pointer to the parent Grid control.
Definition XTPGridSubListControl.h:289
CXTPGridSubListControl::m_bSortAscending
BOOL m_bSortAscending
TRUE to sort items ascending in the list.
Definition XTPGridSubListControl.h:297
CXTPGridSubListControl::m_rcDropTarget2
CRect m_rcDropTarget2
Second drop target - the grid header.
Definition XTPGridSubListControl.h:294
CXTPGridSubListControl::~CXTPGridSubListControl
~CXTPGridSubListControl()
Destroys a CXTPGridSubListControl object, handles cleanup and deallocation.


Toolkit Pro: XTPSkinObjectMenu.h Source File

  • Source
  • SkinFramework
XTPSkinObjectMenu.h
Go to the documentation of this file.
1
23#if !defined(__XTPSKINOBJECTMENU_H__)
24# define __XTPSKINOBJECTMENU_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPSkinPopupMenu;
34class CXTPSkinManagerSchema;
35class CXTPSkinPopupMenuState;
36
37class _XTP_EXT_CLASS CXTPSkinPopupMenuItem
38{
39public:
40 CXTPSkinPopupMenuItem(CXTPSkinPopupMenu* pPopupParent, int nItem);
41
42public:
43 HMENU GetPopupMenu() const;
44 DWORD GetState() const;
45 CRect GetScreenPos() const;
46 BOOL IsSeparator() const;
47 BOOL IsOwnerDraw() const;
48 UINT GetID() const;
49 BOOL IsEnabled() const;
50 BOOL IsChecked() const;
51 UINT GetType() const;
52 BOOL IsDefault() const;
53
54 BOOL IsMenuBreak() const;
55
56 CString GetText() const;
57 DWORD_PTR GetItemData() const;
58
59 void GetMenuItemInfo(UINT fMask, LPMENUITEMINFO lpMII) const;
60
61 HBITMAP GetItemBitmap() const;
62
63 BOOL IsMDISysButton() const;
64
65public:
66 CRect m_rcItem;
67 int m_nItem;
68 HMENU m_hMenu;
69
70 CXTPSkinPopupMenu* m_pPopupParent;
71 CXTPSkinPopupMenu* m_pPopupChild;
72};
73
74class _XTP_EXT_CLASS CXTPSkinPopupMenu : public CWnd
75{
76public:
77 CXTPSkinPopupMenu();
78 ~CXTPSkinPopupMenu();
79
80public:
81 CString GetMenuString(int nIndex);
82 int GetCount();
83 CXTPSkinPopupMenuItem* GetItem(int nIndex) const;
84
85 void RebuildItems();
86
87 void RemoveAll();
88
89 CSize RecalcLayout();
90 void PositionSysMenu();
91
92 using CWnd::Create;
93
94 BOOL Create(HWND hwndParent);
95 BOOL IsMenuThemed();
96
97 BOOL IsSysMenuBar() const
98 {
99 return m_bMenuBar && m_bSysMenu;
100 }
101 void OnFinalRelease();
102
103 void OnScrollUp();
104 void OnScrollDown();
105 void EnsureVisible(int nItem);
106
107protected:
108 void RecalcItemsSize(CDC* pDC);
109 int RecalcItemsHeight(int nScreenArea);
110
111 int GetColumnCount() const;
112
113 BOOL IsMultiColumn() const
114 {
115 return GetColumnCount() > 1;
116 }
117
118 void Scroll(int nOffsetY);
119 void ScrollUp();
120 void ScrollDown();
121
122 void ShowScrollUp(BOOL bShow);
123 void ShowScrollDown(BOOL bShow);
124
125protected:
126 DECLARE_MESSAGE_MAP();
127 //{{AFX_MSG(CXTPPopupBar)
128 afx_msg void OnPaint();
129 //}}AFX_MSG
130
131public:
132 CXTPSkinPopupMenu* LookUp(HMENU hMenu);
133
134 HMENU m_hMenu;
135
136 CArray<CXTPSkinPopupMenuItem*, CXTPSkinPopupMenuItem*> m_arrItems;
137 int m_nSelected;
138 int m_nDropped;
139 BOOL m_bMenuBar;
140 BOOL m_bSysMenu;
141 BOOL m_bToggle;
142 BOOL m_bDropNextPopup;
143 BOOL m_bAboutToHide;
144 BOOL m_bSendUninit;
145 BOOL m_bDroppedLeft;
146
147 HWND m_hWndNotify;
148
149 int m_nMaxWidthColumn;
150 int m_nGripperWidth;
151 int m_nHeight;
152
153 CXTPSkinPopupMenuState* m_pState;
154
155 UINT_PTR m_nHideTimer;
156 UINT_PTR m_nShowTimer;
157
158 CXTPSkinPopupMenu* m_pNextPopup;
159 CXTPSkinPopupMenu* m_pPrevPopup;
160
161 CRect m_rcBorder;
162 XTP_SCROLLINFO m_scrollInfo;
163};
164
165class _XTP_EXT_CLASS CXTPSkinPopupMenuState
166{
167public:
168 enum MenuFocus
169 {
170 focusMouse,
171 focusKeyboard
172 };
173
174public:
175 CXTPSkinPopupMenuState(HWND hWndNotify);
176
177public:
178 BOOL HandleMenuMessage(LPMSG lpMsg);
179 BOOL StartMenu(MenuFocus nFocus);
180 void InitMenu(CXTPSkinPopupMenu* pPopupMenu);
181 void RunLoop(LPARAM lParam);
182
183 int ItemHitTest(CPoint point, CXTPSkinPopupMenu* pPopupMenu);
184 CXTPSkinPopupMenu* FindMenu(CPoint point, CXTPSkinPopupMenu* pPopupMenu, int* pnItem);
185
186 void EndState();
187
188 BOOL TrackPopupMenu(HMENU hMenu, UINT dwFlags, int x, int y, HWND hWnd, CONST RECT* prcRect);
189
190public:
191 void OnButtonDown(CXTPSkinPopupMenu* pMenu, int nItem, BOOL bClick);
192 void OnButtonDblClick(CXTPSkinPopupMenu* pPopupMenu, int nItem);
193 void OnButtonUp(CXTPSkinPopupMenu* pMenu, int nItem);
194 void OnMouseMove(CPoint point);
195 void OnKeyDown(CXTPSkinPopupMenu* pMenu, WPARAM nKey);
196 void OnChar(CXTPSkinPopupMenu* pPopupMenu, WPARAM nKey);
197
198 int FindChar(CXTPSkinPopupMenu* pPopupMenu, WPARAM nKey, int nStart);
199
200 CXTPSkinPopupMenuItem* SelectItem(CXTPSkinPopupMenu* pPopupMenu, int nItem);
201 void SendMenuSelect(CXTPSkinPopupMenu* pPopupMenu);
202 HWND OpenHierarchy(CXTPSkinPopupMenu* pPopupMenu);
203 void CloseHierarchy(CXTPSkinPopupMenu* pPopupMenu);
204 BOOL HideNextHierarchy(CXTPSkinPopupMenu* pPopupMenu);
205 BOOL SetTimerToCloseHierarchy(CXTPSkinPopupMenu* pPopupMenu);
206 BOOL SetTimerToOpenHierarchy(CXTPSkinPopupMenu* pPopupMenu);
207 void RedrawPopup(CXTPSkinPopupMenu* pPopupMenu);
208
209 CXTPSkinPopupMenu* GetNextPopup(CXTPSkinPopupMenu* pPopupMenu) const;
210 CXTPSkinPopupMenu* GetActivePopup() const;
211
212 BOOL ContinueLoop() const;
213 void Dismiss();
214 void Notify(UINT nMessage, UINT nCommand, LPARAM lParam);
215 void DismissNotify(CXTPSkinPopupMenu* pPopupMenu, int nItem);
216 void DismissNotify(HMENU hMenu, int nItem);
217 void EndMenuLoop();
218
219 CXTPSkinPopupMenu* FindPopup(HWND hWnd) const;
220 BOOL RemoveMessage(UINT nMessage);
221
222 int FindNextItem(CXTPSkinPopupMenu* pPopupMenu, int nItem, BOOL bForward, UINT nFlags) const;
223 void FilterMenuKey(LPARAM lParam);
224
225 BOOL SwitchToAlternateMenu();
226 void AdjustMonitorRect(CXTPSkinPopupMenu* pPopupMenu, CPoint& pt, CSize sz, UINT dwFlags,
227 LPCRECT prcExclude);
228 CPoint PositionHierarchy(CXTPSkinPopupMenu* pSubMenu, CXTPSkinPopupMenu* pPopupMenu,
229 CRect rcItem, CSize size);
230
231 static void AFX_CDECL WindowToScreen(HWND hWnd, CRect& rcItem);
232 void PlayEventSound(UINT nID);
233 int GetMenuFlags(HMENU hMenu);
234
235public:
236public:
237 MenuFocus m_nFocus;
238 BOOL m_bButtonDown;
239 BOOL m_bInsideMenuLoop;
240 BOOL m_bDismiss;
241 HWND m_hWndCapture;
242 HWND m_hWndCaptureOld;
244 CXTPSkinPopupMenu* m_pRootPopup;
245 CXTPSkinPopupMenu* m_pAlternatePopup;
246 BOOL m_bNofyByPos;
247 CPoint m_ptMouseLast;
248 BOOL m_bMenuStarted;
249
250 int m_nLastCommand;
251 BOOL m_bFirstClick;
252
253 DWORD m_dwMenuShowDelay;
254 CXTPSkinManagerSchema* m_pSchema;
255
256 struct TrackPopupMenuFlags
257 {
258 TrackPopupMenuFlags()
259 : bRightButton(FALSE)
260 , bNoNotify(FALSE)
261 , bReturnCmd(FALSE)
262 {
263 }
264
265 BOOL bRightButton;
266 BOOL bNoNotify;
267 BOOL bReturnCmd;
268 };
269
270 TrackPopupMenuFlags m_flags;
271};
272
273class _XTP_EXT_CLASS CXTPSkinObjectApplicationFrame : public CXTPSkinObjectFrame
274{
276 DECLARE_DYNCREATE(CXTPSkinObjectApplicationFrame)
278public:
279 CXTPSkinObjectApplicationFrame();
280 virtual ~CXTPSkinObjectApplicationFrame();
281
282 CXTPSkinPopupMenu* LookUp(HMENU hMenu);
283
284protected:
285 void DrawFrame(CDC* pDC);
286 BOOL FrameHasMenuBar();
287 void DrawFrameMenuBar(CDC* pDC);
288 void RedrawMenuBar();
289 void UpdateMenuBar();
290
291protected:
292 int HitTestMenuItem(CPoint point);
293
294 void RebuildMenuItems();
295
296 CXTPSkinPopupMenuState* StartMenuState(UINT nID, LPARAM lParam);
297
298public:
299 static BOOL AFX_CDECL TrackPopupMenu(HMENU hMenu, UINT uFlags, int x, int y, HWND hWnd,
300 CONST RECT* prcRect);
301
302protected:
303 DECLARE_MESSAGE_MAP();
304
305 afx_msg void OnNcCalcSize(BOOL bCalcValidRects, NCCALCSIZE_PARAMS FAR* lpncsp);
306 afx_msg LRESULT HandleNcHitTest(CPoint point);
307 afx_msg BOOL HandleMouseMove(CPoint point);
308 afx_msg void OnContextMenu(CWnd* pWnd, CPoint pos);
309
310 BOOL HandleSysCommand(UINT nID, LPARAM lParam);
311
312protected:
313 CRect m_rcMenuBar;
314 CXTPSkinPopupMenu* m_pPopupMenu;
315};
316
317# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
319#endif // !defined(__XTPSKINOBJECTMENU_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPSkinManagerSchema
CXTPSkinManagerSchema is a standalone class used to read a visual styles schema file.
Definition XTPSkinManagerSchema.h:164
CXTPSkinObjectFrame
CXTPSkinObjectFrame is a CXTPSkinObject derived class.
Definition XTPSkinObjectFrame.h:75


Toolkit Pro: Member List

XTP_NM_FLOWGRAPH_NODECHANGED Member List

This is the complete list of members for XTP_NM_FLOWGRAPH_NODECHANGED, including all inherited members.

hdr | XTP_NM_FLOWGRAPH_NODECHANGED
pNode | XTP_NM_FLOWGRAPH_NODECHANGED


Toolkit Pro: XTPCalendarResourcesManager.h Source File

  • Source
  • Calendar
XTPCalendarResourcesManager.h
Go to the documentation of this file.
1
22#if !defined(_XTPCALENDAR_RESOURCES_MANAGER_H_)
23# define _XTPCALENDAR_RESOURCES_MANAGER_H_
24
25# if _MSC_VER > 1000
26# pragma once
27# endif // _MSC_VER > 1000
28
29# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
30
31class CXTPCalendarResourcesManager;
32class CCalendarResourcesDlg;
33class CXTPCalendarResource;
35 XTP_DEFINE_SMART_PTR_INTERNAL(CXTPCalendarResource)
42class _XTP_EXT_CLASS CXTPCalendarResourceDescription : public CXTPCmdTarget
43{
45 DECLARE_DYNAMIC(CXTPCalendarResourceDescription)
47public:
52 CXTPCalendarResourceDescription();
53
54 BOOL m_bEnabled;
55 BOOL m_bGenerateName;
58 CXTPCalendarResourcePtr m_ptrResource;
60protected:
61# ifdef _XTP_ACTIVEX
62
63 DECLARE_DISPATCH_MAP()
64 DECLARE_INTERFACE_MAP()
65
66 DECLARE_OLETYPELIB_EX(CXTPCalendarResourceDescription)
67
68 LPDISPATCH OleGetResource();
69 void OleSetResource(LPDISPATCH pDispResource);
70
71# endif
72};
73
79class _XTP_EXT_CLASS CXTPCalendarResourcesManager : public CXTPCmdTarget
80{
82 DECLARE_DYNCREATE(CXTPCalendarResourcesManager)
84public:
89 CXTPCalendarResourcesManager();
90
95 virtual ~CXTPCalendarResourcesManager();
96
101 enum XTPEnumCalendarDataProviderFlags
102 {
103 xtpCalendarDPFUnknown = 0,
104 xtpCalendarDPF_CreateIfNotExists = 0x001,
106 xtpCalendarDPF_SaveOnDestroy = 0x010,
108 xtpCalendarDPF_CloseOnDestroy = 0x020,
110 };
111
128 BOOL AddDataProvider(LPCTSTR pcszConnectionString,
129 int eDPFlags = xtpCalendarDPF_CreateIfNotExists);
130
147 BOOL SetDataProvider(int nIndex, LPCTSTR pcszConnectionString,
148 int eDPFlags = xtpCalendarDPF_CreateIfNotExists);
149
161 int GetDataProvidersCount() const;
162
176 CXTPCalendarData* GetDataProvider(int nIndex) const;
177
189 void RemoveDataProvider(int nIndex);
190
203 CXTPCalendarData* GetDataProvider(LPCTSTR pcszConnectionString, int* pnIndex = NULL) const;
204
216 CString GetDataProvider_ConnStr(int nIndex) const;
217
232 BOOL AddResource(LPCTSTR pcszName, BOOL bEnabled);
233
245 int GetResourcesCount() const;
246
260 CXTPCalendarResourceDescription* GetResource(int nIndex) const;
261
273 void RemoveResource(int nIndex);
274
287 void MoveResource(int nIndex, int nNewIndex);
288
299 void DoExchangeCfg(CXTPPropExchange* pPX);
300
313 BOOL SaveCfg(LPCTSTR pcszFile);
314
327 BOOL LoadCfg(LPCTSTR pcszFile);
328
337 void ApplyToCalendar(CXTPCalendarControl* pCalendar);
338
348 void RemoveAll();
349
350protected:
351 CXTPCalendarPtrCollectionT<CXTPCalendarData> m_arDataProviders;
353 CXTPCalendarPtrCollectionT<CXTPCalendarResourceDescription> m_arResources;
368 void _Save(CXTPPropExchange* pPX);
369
382 void _Load(CXTPPropExchange* pPX);
383
396 void _SaveCloseDPifNeed(CXTPCalendarData* pData);
397
398protected:
399# ifdef _XTP_ACTIVEX
400
401 DECLARE_DISPATCH_MAP()
402 DECLARE_INTERFACE_MAP()
403
404 DECLARE_OLETYPELIB_EX(CXTPCalendarResourcesManager)
405 DECLARE_OLECREATE_EX(CXTPCalendarResourcesManager)
406
407 LPDISPATCH OleGetDataProvider(long nIndex);
408 LPDISPATCH OleGetDataProvider2(LPCTSTR pcszConnectionString);
409 long OleGetDataProviderIndex(LPCTSTR pcszConnectionString);
410 BSTR OleGetDataProviderConnStr(long nIndex);
411
412 LPDISPATCH OleGetResource(long nIndex);
413
414 void OleDoExchangeCfg(LPDISPATCH pDispPropExchange);
415 void OleApplyToCalendar(LPDISPATCH pDispCalendar);
416
417# endif
418};
419
420# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
421#endif // !defined(_XTPCALENDAR_RESOURCES_MANAGER_H_)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTP_DEFINE_SMART_PTR_INTERNAL
#define XTP_DEFINE_SMART_PTR_INTERNAL(ClassName)
Define smart pointer for the specified class as ClassNamePtr.
Definition XTPSmartPtrInternalT.h:47
CXTPCalendarControl
Class CXTPCalendarControl implements the calendar's view interface.
Definition XTPCalendarControl.h:126
CXTPCalendarData
This class defines an abstract representation of the Calendar control data with all necessary methods...
Definition XTPCalendarData.h:97
CXTPCalendarPtrCollectionT
This class represents a simple array collection of objects.
Definition XTPCalendarPtrCollectionT.h:48
CXTPCalendarResourceDescription
This class is a wrapper for CXTPCalendarResource class.
Definition XTPCalendarResourcesManager.h:43
CXTPCalendarResourceDescription::m_ptrResource
CXTPCalendarResourcePtr m_ptrResource
A smart pointer to the resource object.
Definition XTPCalendarResourcesManager.h:58
CXTPCalendarResourceDescription::CXTPCalendarResourceDescription
CXTPCalendarResourceDescription()
Default object constructor.
CXTPCalendarResourceDescription::m_bGenerateName
BOOL m_bGenerateName
This flag indicates that resource name should be generated from the schedule(s) name(s).
Definition XTPCalendarResourcesManager.h:55
CXTPCalendarResourceDescription::m_bEnabled
BOOL m_bEnabled
This flag indicates is resource enabled.
Definition XTPCalendarResourcesManager.h:54
CXTPCalendarResource
Class CXTPCalendarResource represents a calendar for some subject like a person, a shared resource,...
Definition XTPCalendarResource.h:339
CXTPCalendarResourcesManager
This class is used as a helper to manage calendar resources (and schedules) data configurations.
Definition XTPCalendarResourcesManager.h:80
CXTPCalendarResourcesManager::~CXTPCalendarResourcesManager
virtual ~CXTPCalendarResourcesManager()
Default object destructor.
CXTPCalendarResourcesManager::LoadCfg
BOOL LoadCfg(LPCTSTR pcszFile)
This method loads data providers and resources configuration from a specified file.
CXTPCalendarResourcesManager::AddDataProvider
BOOL AddDataProvider(LPCTSTR pcszConnectionString, int eDPFlags=xtpCalendarDPF_CreateIfNotExists)
Adds a new data provider to the data providers collection using a specified Calendar connection strin...
CXTPCalendarResourcesManager::XTPEnumCalendarDataProviderFlags
XTPEnumCalendarDataProviderFlags
This enum specifies data provider flags.
Definition XTPCalendarResourcesManager.h:102
CXTPCalendarResourcesManager::RemoveDataProvider
void RemoveDataProvider(int nIndex)
Remove data provider at specified index.
CXTPCalendarResourcesManager::GetResourcesCount
int GetResourcesCount() const
Retrieve the calendar data resources count for the collection.
CXTPCalendarResourcesManager::GetDataProvider
CXTPCalendarData * GetDataProvider(LPCTSTR pcszConnectionString, int *pnIndex=NULL) const
Call this method to find a data provider by a connection string.
CXTPCalendarResourcesManager::MoveResource
void MoveResource(int nIndex, int nNewIndex)
Move resource to a new position in the collection.
CXTPCalendarResourcesManager::_Load
void _Load(CXTPPropExchange *pPX)
This method loads data providers and resources configuration from storage.
CXTPCalendarResourcesManager::m_arDataProviders
CXTPCalendarPtrCollectionT< CXTPCalendarData > m_arDataProviders
Data providers collection.
Definition XTPCalendarResourcesManager.h:351
CXTPCalendarResourcesManager::m_arResources
CXTPCalendarPtrCollectionT< CXTPCalendarResourceDescription > m_arResources
Resources collection.
Definition XTPCalendarResourcesManager.h:353
CXTPCalendarResourcesManager::GetDataProvider
CXTPCalendarData * GetDataProvider(int nIndex) const
Retrieve data provider at specified index.
CXTPCalendarResourcesManager::GetDataProvider_ConnStr
CString GetDataProvider_ConnStr(int nIndex) const
Retrieve a text Calendar connection string for data provider at specified index.
CXTPCalendarResourcesManager::CXTPCalendarResourcesManager
CXTPCalendarResourcesManager()
Default object constructor.
CXTPCalendarResourcesManager::SetDataProvider
BOOL SetDataProvider(int nIndex, LPCTSTR pcszConnectionString, int eDPFlags=xtpCalendarDPF_CreateIfNotExists)
Set a new data provider to data providers collection using specified Calendar connection string.
CXTPCalendarResourcesManager::SaveCfg
BOOL SaveCfg(LPCTSTR pcszFile)
This method writes data providers and resources configuration to a specified file.
CXTPCalendarResourcesManager::RemoveAll
void RemoveAll()
Remove all resources and all data providers.
CXTPCalendarResourcesManager::GetDataProvidersCount
int GetDataProvidersCount() const
Retrieve data providers count in the collection.
CXTPCalendarResourcesManager::RemoveResource
void RemoveResource(int nIndex)
Remove resource at specified index.
CXTPCalendarResourcesManager::GetResource
CXTPCalendarResourceDescription * GetResource(int nIndex) const
Retrieve resource at specified index.
CXTPCalendarResourcesManager::_SaveCloseDPifNeed
void _SaveCloseDPifNeed(CXTPCalendarData *pData)
This method is called to Save and Close data provider if these actions were specified in AddDataProvi...
CXTPCalendarResourcesManager::DoExchangeCfg
void DoExchangeCfg(CXTPPropExchange *pPX)
This method reads data providers and resources configuration from or writes data providers and resour...
CXTPCalendarResourcesManager::AddResource
BOOL AddResource(LPCTSTR pcszName, BOOL bEnabled)
Adds a new data resource to the calendar resources collection.
CXTPCalendarResourcesManager::ApplyToCalendar
void ApplyToCalendar(CXTPCalendarControl *pCalendar)
Set the active configuration (enabled resources) to calendar control.
CXTPCalendarResourcesManager::_Save
void _Save(CXTPPropExchange *pPX)
This method saves data providers and resources configuration to storage.
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72


Toolkit Pro: Member List

CXTPMarkupControl Member List

This is the complete list of members for CXTPMarkupControl, including all inherited members.

ApplyRenderTransform(CXTPMarkupDrawingContext *pContext) | CXTPMarkupUIElement | protectedvirtual
Arrange(CRect rcFinalRect) | CXTPMarkupUIElement |
ArrangeCore(CRect rcFinalRect) | CXTPMarkupUIElement | protectedvirtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPMarkupFrameworkElement() | CXTPMarkupFrameworkElement | protected
CXTPMarkupUIElement() | CXTPMarkupUIElement | protected
CXTPMarkupVisual() | CXTPMarkupVisual |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAbsoluteVisualOffset() const | CXTPMarkupVisual | protected
GetActualSize() const | CXTPMarkupFrameworkElement |
GetBackground() const | CXTPMarkupControl |
GetBoundRect() const | CXTPMarkupVisual |
GetClipToBounds() const | CXTPMarkupFrameworkElement |
GetDesiredSize() const | CXTPMarkupUIElement |
GetFinalRect() const | CXTPMarkupUIElement |
GetForeground() const | CXTPMarkupControl |
GetHeight() const | CXTPMarkupFrameworkElement |
GetHorizontalAlignment() const | CXTPMarkupFrameworkElement |
GetLayoutClip(CRect &rc) const | CXTPMarkupUIElement | protectedvirtual
GetLogicalChild(int nIndex) const | CXTPMarkupVisual | virtual
GetLogicalChildrenCount() const | CXTPMarkupVisual | virtual
GetMargin() const | CXTPMarkupFrameworkElement |
GetMaxHeight() const | CXTPMarkupFrameworkElement |
GetMaxWidth() const | CXTPMarkupFrameworkElement |
GetMinHeight() const | CXTPMarkupFrameworkElement |
GetMinWidth() const | CXTPMarkupFrameworkElement |
GetOpacity() const | CXTPMarkupUIElement | protectedvirtual
GetPadding() const | CXTPMarkupControl |
GetRenderSize() const | CXTPMarkupVisual |
GetRenderTransform() const | CXTPMarkupUIElement | protected
GetStyle() const | CXTPMarkupFrameworkElement |
GetTag() const | CXTPMarkupFrameworkElement |
GetUpdateRect() const | CXTPMarkupVisual |
GetVerticalAlignment() const | CXTPMarkupFrameworkElement |
GetVisibility() const | CXTPMarkupUIElement |
GetVisualChild(int nIndex) const | CXTPMarkupVisual | virtual
GetVisualChildrenCount() const | CXTPMarkupVisual | virtual
GetVisualOffset() const | CXTPMarkupVisual |
GetVisualParent() const | CXTPMarkupVisual |
GetWidth() const | CXTPMarkupFrameworkElement |
InputHitTest(CPoint point) const | CXTPMarkupVisual |
InputHitTestOverride(CPoint point) const | CXTPMarkupVisual | protectedvirtual
InvalidateArrange() | CXTPMarkupUIElement | virtual
InvalidateMeasure() | CXTPMarkupUIElement | virtual
InvalidateMeasureOverride(CXTPMarkupDrawingContext *pDC) | CXTPMarkupUIElement | protectedvirtual
InvalidateVisual() | CXTPMarkupUIElement | virtual
IsEnabled() const | CXTPMarkupUIElement |
IsFocusable() const | CXTPMarkupUIElement |
IsVisible() const | CXTPMarkupUIElement | virtual
m_bArrangeDirty | CXTPMarkupUIElement | protected
m_bArrangeInProgress | CXTPMarkupUIElement | protected
m_bMeasureDirty | CXTPMarkupUIElement | protected
m_bMeasureInProgress | CXTPMarkupUIElement | protected
m_bNeverArranged | CXTPMarkupUIElement | protected
m_bNeverMeasured | CXTPMarkupUIElement | protected
m_pClipToBoundsProperty | CXTPMarkupUIElement | static
m_pFocusableProperty | CXTPMarkupUIElement | static
m_pIsEnabledProperty | CXTPMarkupUIElement | static
m_pOpacityProperty | CXTPMarkupUIElement | static
m_pRenderTransformOriginProperty | CXTPMarkupUIElement | static
m_pRenderTransformProperty | CXTPMarkupUIElement | static
m_ptVisualOffset | CXTPMarkupVisual | protected
m_pVisibilityProperty | CXTPMarkupUIElement | static
m_rcBoundRect | CXTPMarkupVisual | protected
m_rcFinalRect | CXTPMarkupUIElement | protected
m_rcPrevUpdateRect | CXTPMarkupVisual | protected
m_rcUpdateRect | CXTPMarkupVisual | protected
m_szDesiredSize | CXTPMarkupUIElement | protected
m_szPreviousAvailableSize | CXTPMarkupUIElement | protected
m_szRenderSize | CXTPMarkupVisual | protected
Measure(CXTPMarkupDrawingContext *pDC, CSize szAvailableSize) | CXTPMarkupUIElement |
MeasureCore(CXTPMarkupDrawingContext *pDC, CSize szAvailableSize) | CXTPMarkupUIElement | protectedvirtual
OnRender(CXTPMarkupDrawingContext *drawingContext) | CXTPMarkupVisual | protectedvirtual
OnRenderFocusVisual(CXTPMarkupDrawingContext *drawingContext) | CXTPMarkupVisual | protectedvirtual
PtInRectTransform(const RECT &rect, const POINT &point) const | CXTPMarkupVisual | protected
Render(CXTPMarkupDrawingContext *drawingContext) | CXTPMarkupVisual |
RenderClipped(CXTPMarkupDrawingContext *drawingContext) | CXTPMarkupVisual | protectedvirtual
RestoreRenderTransform(CXTPMarkupDrawingContext *pContext, TransformationMatrices &matrices) | CXTPMarkupUIElement | protectedvirtual
SetBackground(CXTPMarkupBrush *pBrush) | CXTPMarkupControl |
SetClipToBounds(BOOL bClipToBounds) | CXTPMarkupFrameworkElement |
SetForeground(CXTPMarkupBrush *pBrush) | CXTPMarkupControl |
SetHeight(int nHeight) | CXTPMarkupFrameworkElement |
SetHorizontalAlignment(XTPMarkupHorizontalAlignment alignment) | CXTPMarkupFrameworkElement |
SetMargin(int nLeft, int nTop, int nRight, int nBottom) | CXTPMarkupFrameworkElement |
SetMargin(int nMargin) | CXTPMarkupFrameworkElement |
SetMaxHeight(int nHeight) | CXTPMarkupFrameworkElement |
SetMaxWidth(int nWidth) | CXTPMarkupFrameworkElement |
SetMinHeight(int nHeight) | CXTPMarkupFrameworkElement |
SetMinWidth(int nWidth) | CXTPMarkupFrameworkElement |
SetPadding(int nLeft, int nTop, int nRight, int nBottom) | CXTPMarkupControl |
SetPadding(int nPadding) | CXTPMarkupControl |
SetTag(CXTPMarkupObject *pTag) | CXTPMarkupFrameworkElement |
SetVerticalAlignment(XTPMarkupVerticalAlignment alignment) | CXTPMarkupFrameworkElement |
SetVisibility(XTPMarkupVisibility visibility) | CXTPMarkupUIElement |
SetWidth(int nWidth) | CXTPMarkupFrameworkElement |
~CXTPMarkupFrameworkElement() | CXTPMarkupFrameworkElement | protectedvirtual
~CXTPMarkupUIElement() | CXTPMarkupUIElement | protectedvirtual
~CXTPMarkupVisual() | CXTPMarkupVisual | virtual


Toolkit Pro: Member List

CXTPTabThemeOffice2013 Member List

This is the complete list of members for CXTPTabThemeOffice2013, including all inherited members.

AdjustClientRect(CXTPTabManager *pTabManager, CRect &rcClient) | CXTPTabPaintManagerTheme | virtual
CXTPTabPaintManagerTheme() | CXTPTabPaintManagerTheme |
CXTPTabThemeFlat() | CXTPTabThemeFlat | inline
CXTPTabThemeOffice2013() | CXTPTabThemeOffice2013 |
DrawSingleButton(CDC *pDC, CXTPTabManagerItem *pItem) | CXTPTabThemeVisualStudio2012 | virtual
DrawTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl) | CXTPTabPaintManagerTheme | virtual
DrawText(CDC *pDC, CXTPTabManager *pManager, const CString &str, LPRECT lpRect, UINT nFormat) | CXTPTabPaintManagerTheme | virtual
DrawWorkspacePart(CDC *pDC, LPRECT lpRect, XTPTabWorkspacePart workspacePart) | CXTPTabThemeVisualStudio2012 | virtual
FillButton(CDC *pDC, CXTPTabManagerItem *pItem, LPPOINT pts, int nCount, XTPTabPosition tabPosition, BOOL bAbsolute=FALSE) | CXTPTabPaintManagerTheme |
FillTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl) | CXTPTabThemeFlat | virtual
GetButtonDrawRect(const CXTPTabManagerItem *pItem) | CXTPTabPaintManagerTheme | virtual
GetButtonHeight(const CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetButtonLength(CDC *pDC, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerTheme | virtual
GetClientMargin() | CXTPTabPaintManagerTheme | virtual
GetClientRect(CRect rcControl, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetColorSet() const | CXTPTabPaintManagerTheme |
GetDefaultColorSet() | CXTPTabThemeOffice2013 | inlinevirtual
GetHeaderClipBox(CDC *pDC, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetHeaderHeight(CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme |
GetHeaderMargin() | CXTPTabPaintManagerTheme | virtual
GetHeaderRect(CRect rcControl, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetSupportedColorSets() | CXTPTabPaintManagerTheme | inlinevirtual
m_bButtonsReverseZOrder | CXTPTabPaintManagerTheme | protected
m_nButtonHeight | CXTPTabPaintManagerTheme | protected
m_nRowMargin | CXTPTabPaintManagerTheme |
m_pPaintManager | CXTPTabPaintManagerTheme | protected
m_rcHeaderMargin | CXTPTabPaintManagerTheme |
RefreshMetrics() | CXTPTabThemeOffice2013 | virtual
RepositionTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcClient) | CXTPTabPaintManagerTheme | virtual
~CXTPTabPaintManagerTheme() | CXTPTabPaintManagerTheme | virtual


Toolkit Pro: Member List

CXTPChart3dLineDeviceCommand Member List

This is the complete list of members for CXTPChart3dLineDeviceCommand, including all inherited members.

AddChildCommand(CXTPChartDeviceCommand *pCommand) | CXTPChartDeviceCommand |
AfterExecute(CXTPChartDeviceContext *pDC) | CXTPChart3dLineDeviceCommand | protectedvirtual
ApplySeriesStyle(CXTPChartSeriesStyle *pStyle) | CXTPChartDeviceCommand | virtual
BeforeExecute(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
BindView(CXTPChartElementView *pView) | CXTPChartDeviceCommand |
Commit() | CXTPChartDeviceCommand |
CXTPChart3dLineDeviceCommand(const CXTPPoint3d &p1, const CXTPPoint3d &p2, const CXTPChartColor &color, int thickness) | CXTPChart3dLineDeviceCommand | protected
CXTPChartDeviceCommand() | CXTPChartDeviceCommand |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPObservable() | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | protected
Execute(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
ExecuteOverride(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
GetBoundView() const | CXTPChartDeviceCommand |
GetChildCommand(int nIndex) const | CXTPChartDeviceCommand |
GetChildCommandCount() const | CXTPChartDeviceCommand |
GetCurrentDC() const | CXTPChartDeviceCommand |
GetPassNumber() const | CXTPChartDeviceCommand |
HitTest(CPoint point, CXTPChartElement *pParent) const | CXTPChart3dLineDeviceCommand | protectedvirtual
Is3D() const | CXTPChartObject |
IsCommitted() const | CXTPChartDeviceCommand |
IsEnabled() const | CXTPChartDeviceCommand | virtual
m_arrChildren | CXTPChartDeviceCommand | protected
m_color | CXTPChart3dLineDeviceCommand | protected
m_nThickness | CXTPChart3dLineDeviceCommand | protected
m_p1 | CXTPChart3dLineDeviceCommand | protected
m_p2 | CXTPChart3dLineDeviceCommand | protected
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Prepare(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
PrepareOverride(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
SetEnabled(BOOL bEnabled=TRUE) | CXTPChartDeviceCommand |
Subscribe(CXTPChartDeviceCommandEvents *pObserver, CXTPSubscriptionList< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > *pSubcriptionList=NULL) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > |
Unsubscribe(CXTPChartDeviceCommandEvents *pObserver) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > |
~CXTPChartDeviceCommand() | CXTPChartDeviceCommand | virtual
~CXTPObservable() | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | protected


Toolkit Pro: Member List

CXTPSyntaxEditBatchCommand Member List

This is the complete list of members for CXTPSyntaxEditBatchCommand, including all inherited members.

AddCommand(CXTPSyntaxEditCommand *pCommand) | CXTPSyntaxEditBatchCommand |
Clear() | CXTPSyntaxEditBatchCommand | protected
CXTPSyntaxEditCommand() | CXTPSyntaxEditCommand | protected
Execute(XTP_EDIT_LINECOL &lcFrom, XTP_EDIT_LINECOL &lcTo, CXTPSyntaxEditCtrl *pEditCtrl) | CXTPSyntaxEditBatchCommand | virtual
GetCommandsCount() | CXTPSyntaxEditBatchCommand |
GetCommandText() const | CXTPSyntaxEditCommand | virtual
GetDataSize() const | CXTPSyntaxEditBatchCommand | virtual
m_CommandList | CXTPSyntaxEditBatchCommand | protected
m_strCommandText | CXTPSyntaxEditCommand | protected
SetCommandText(LPCTSTR szText) | CXTPSyntaxEditCommand | virtual
SetPositionInternally(CXTPSyntaxEditCtrl *pEditCtrl, const XTP_EDIT_LINECOL &lcPos) | CXTPSyntaxEditCommand | protectedstatic
UnExecute(XTP_EDIT_LINECOL &lcFrom, XTP_EDIT_LINECOL &lcTo, CXTPSyntaxEditCtrl *pEditCtrl) | CXTPSyntaxEditBatchCommand | virtual
~CXTPSyntaxEditBatchCommand() | CXTPSyntaxEditBatchCommand |
~CXTPSyntaxEditCommand() | CXTPSyntaxEditCommand | virtual


Toolkit Pro: XTPGridSection.h Source File

  • Source
  • GridControl
XTPGridSection.h
Go to the documentation of this file.
1
23#if !defined(__XTPGRIDSECTION_H__)
24# define __XTPGRIDSECTION_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPGridControl;
34class CXTPGridRecords;
35class CXTPGridRecord;
36class CXTPGridRows;
37class CXTPGridRow;
38class CXTPGridSelectedRows;
39class CXTPGridBorder;
40
45enum XTPGridSectionHeightMode
46{
47 xtpGridSectionHeightModeFixed,
48 xtpGridSectionHeightModeRelative,
49 xtpGridSectionHeightModeAuto,
50 xtpGridSectionHeightModeExpand,
52 xtpGridSectionHeightModeAutoExpand,
53 xtpGridSectionHeightModeAutoShrink,
54};
55
60class _XTP_EXT_CLASS CXTPGridSection : public CXTPCmdTarget
61{
62public:
69 CXTPGridSection(CXTPGridControl* pControl, XTPGridRowType rowType);
70
75 virtual ~CXTPGridSection();
76
77public:
84 CXTPGridBorder* GetBorder() const;
85
94 void AllowAccess(BOOL bAllowAccess);
95
105 BOOL IsAllowAccess() const;
106
120 void AllowEdit(BOOL bAllowEdit);
121
131 BOOL IsAllowEdit() const;
132
141 void AllowGroup(BOOL bAllowGroup);
142
151 BOOL IsAllowGroup() const;
152
161 void AllowSort(BOOL bAllowSort);
162
171 BOOL IsAllowSort() const;
172
181 void AllowFilter(BOOL bAllowFilter);
182
191 BOOL IsAllowFilter() const;
192
201 void SelectionEnable(BOOL bEnable);
202
211 BOOL IsSelectionEnabled() const;
212
220 void SetVisible(BOOL bVisible = TRUE);
221
230 BOOL IsVisible() const;
231
241 XTPGridSectionHeightMode GetHeightMode() const;
242
251 void SetHeightMode(XTPGridSectionHeightMode heightMode);
252
261 int GetHeight() const;
262
270 void SetHeight(int nHeight);
271
281 XTPGridSectionDividerPosition GetDividerPosition() const;
282
291 void SetDividerPosition(XTPGridSectionDividerPosition dividerPosition);
292
302 XTPGridSectionDividerStyle GetDividerStyle() const;
303
312 void SetDividerStyle(XTPGridSectionDividerStyle dividerStyle);
313
322 CXTPPaintManagerColor GetDividerColor() const;
323
331 void SetDividerColor(CXTPPaintManagerColor clrDivider);
332
339 CRect GetRect() const;
340
347 CRect GetDividerRect() const;
348
361 CXTPGridRecords* GetRecords() const;
362
379 CXTPGridRows* GetRows() const;
380
388 XTPGridRowType GetRowType() const;
389
412 virtual CXTPGridRecord* AddRecord(CXTPGridRecord* pRecord);
413
414 virtual void AddRecordEx(CXTPGridRecord* pRecord, CXTPGridRecord* pParentRecord = NULL,
415 int nRowChildIndex = -1, int nRecordChildIndex = -1);
416
417 virtual void UpdateRecord(CXTPGridRecord* pRecord, BOOL bUpdateChildren);
418
419 virtual BOOL RemoveRecordEx(CXTPGridRecord* pRecord, BOOL bAdjustLayout = TRUE,
420 BOOL bRemoveFromParent = TRUE);
421
422 virtual BOOL RemoveRowEx(CXTPGridRow* pRow, BOOL bAdjustLayout);
423
428 virtual void ResetContent();
429
435 virtual void Populate(BOOL bUpdate);
436
441 virtual void ReSortRows();
442
447 virtual void RefreshIndexes();
448
454 virtual void RefreshIndexes(int nIndexStart);
455
467 virtual int _DoExpand(int nIndex, CXTPGridRow* pRow, BOOL bUpdateSelection);
468
477 virtual int _DoExpand(int nIndex, CXTPGridRow* pRow);
478
485 virtual int _DoCollapse(CXTPGridRow* pRow);
486
492 virtual void Draw(CDC* pDC);
493
501 virtual BOOL IsVirtualMode() const;
502
503 virtual int InsertRow(int nIndex, CXTPGridRow* pRow);
504
505 virtual int GetPageRowCount(CDC* pDC) const;
506
507 virtual int GetTotalHeight(CDC* pDC) const;
508
509 virtual int GetRowsHeight(CDC* pDC) const;
510
511 virtual BOOL GetRowAt(CDC* pDC, int nWidth, int nOffset, int& nIndex, int& nTop);
512
513 virtual int GetRowOffset(CDC* pDC, int nWidth, int nIndex);
514
515 virtual BOOL EnsureVisible(CDC* pDC, CXTPGridRow* pRow);
516
522 void SetMarkupContext(CXTPMarkupContext* pMarkupContext);
523
530 int GetPopulatedRecordsCount() const;
531
538 int GetIndex() const;
539
540protected:
541 BOOL EnsureVisibleSmooth(CDC* pDC, CXTPGridRow* pRow);
542 int EnsureVisibleCalc(CDC* pDC, CXTPGridRow* pRow);
543 BOOL EnsureVisibleBlock(CDC* pDC, CXTPGridRow* pRow);
544 BOOL EnsureVisibleIcon(CDC* pDC, CXTPGridRow* pRow);
545
555 void BuildTree(CXTPGridRows* pTree, CXTPGridRow* pParentRow, CXTPGridRecords* pRecords);
556
562 virtual void SortTree(CXTPGridRows* pTree);
563
569 virtual void SortRows(CXTPGridRows* pRows);
570
582 CXTPGridSelectedRows* GetSelectedRows() const;
583
590 CXTPGridRow* GetFocusedRow() const;
591
598 virtual int GetScrollIndexV();
599
605 virtual void SetScrollIndexV(int nIndex);
606
613 virtual int GetScrollOffsetV() const;
614
620 virtual void SetScrollOffsetV(int nScrollOffsetV);
621
622 XTPGridScrollMode GetScrollModeV() const;
623 XTPGridScrollMode GetScrollModeH() const;
624
634 void CollapseAll();
635
647 void ExpandAll(BOOL bRecursive);
648
649protected:
650 void OnDeletedRefreshIndexes();
651
652protected:
653 CXTPMarkupContext* m_pMarkupContext;
654 CXTPGridBorder* m_pBorder;
656 CXTPGridControl* m_pControl;
657 CXTPGridRecords* m_pRecords;
658 CXTPGridRows* m_pRows;
659 CXTPGridRows* m_pTree;
661 int m_nPopulatedRecordsCount;
664 // Divider
666
667 CRect m_rcSection;
668 CRect m_rcDivider;
669 CXTPPaintManagerColor m_clrDivider;
670 XTPGridSectionDividerPosition m_dividerPosition;
671 XTPGridSectionDividerStyle m_dividerStyle;
673 XTPGridSectionHeightMode m_heightMode;
674 int m_nHeight;
676 BOOL m_bAllowAccess;
677 BOOL m_bAllowEdit;
678 BOOL m_bAllowGroup;
679 BOOL m_bAllowSort;
680 BOOL m_bAllowFilter;
681 BOOL m_bSelectionEnable;
682 BOOL m_bVisible;
685 // Scrolling
687 int m_nScrollIndexV;
693 int m_nScrollOffsetV;
695 XTPGridRowType m_rowType;
696
697 CUIntArray m_UaSorted;
699private:
700# ifdef _XTP_ACTIVEX
701 DECLARE_OLETYPELIB_EX(CXTPGridSection);
702 DECLARE_DISPATCH_MAP()
703 DECLARE_INTERFACE_MAP()
704
705# endif // _XTP_ACTIVEX
706
708 friend class CXTPGridControl;
709 friend class CXTPGridSections;
710 friend class CXTPGridGroupRow;
712};
713
714AFX_INLINE void CXTPGridSection::AllowAccess(BOOL bAllowAccess)
715{
716 m_bAllowAccess = bAllowAccess;
717}
718
719AFX_INLINE BOOL CXTPGridSection::IsAllowAccess() const
720{
721 return m_bAllowAccess;
722}
723
724AFX_INLINE void CXTPGridSection::AllowEdit(BOOL bAllowEdit)
725{
726 m_bAllowEdit = bAllowEdit;
727}
728
729AFX_INLINE BOOL CXTPGridSection::IsAllowEdit() const
730{
731 return m_bAllowEdit;
732}
733
734AFX_INLINE void CXTPGridSection::AllowGroup(BOOL bAllowGroup)
735{
736 m_bAllowGroup = bAllowGroup;
737}
738
739AFX_INLINE BOOL CXTPGridSection::IsAllowGroup() const
740{
741 return m_bAllowGroup;
742}
743
744AFX_INLINE void CXTPGridSection::AllowSort(BOOL bAllowSort)
745{
746 m_bAllowSort = bAllowSort;
747}
748
749AFX_INLINE BOOL CXTPGridSection::IsAllowSort() const
750{
751 return m_bAllowSort;
752}
753
754AFX_INLINE void CXTPGridSection::AllowFilter(BOOL bAllowFilter)
755{
756 m_bAllowFilter = bAllowFilter;
757}
758
759AFX_INLINE BOOL CXTPGridSection::IsAllowFilter() const
760{
761 return m_bAllowFilter;
762}
763
764AFX_INLINE void CXTPGridSection::SelectionEnable(BOOL bEnable)
765{
766 m_bSelectionEnable = bEnable;
767}
768
769AFX_INLINE BOOL CXTPGridSection::IsSelectionEnabled() const
770{
771 return m_bSelectionEnable;
772}
773
774AFX_INLINE void CXTPGridSection::SetVisible(BOOL bVisible)
775{
776 m_bVisible = bVisible;
777}
778
779AFX_INLINE BOOL CXTPGridSection::IsVisible() const
780{
781 return m_bVisible;
782}
783
784AFX_INLINE CXTPGridRecords* CXTPGridSection::GetRecords() const
785{
786 return m_pRecords;
787}
788
789AFX_INLINE CXTPGridRows* CXTPGridSection::GetRows() const
790{
791 return m_pRows;
792}
793
794AFX_INLINE XTPGridSectionHeightMode CXTPGridSection::GetHeightMode() const
795{
796 return m_heightMode;
797}
798
799AFX_INLINE void CXTPGridSection::SetHeightMode(XTPGridSectionHeightMode heightMode)
800{
801 m_heightMode = heightMode;
802}
803
804AFX_INLINE int CXTPGridSection::GetHeight() const
805{
806 return m_nHeight;
807}
808
809AFX_INLINE void CXTPGridSection::SetHeight(int nHeight)
810{
811 m_nHeight = nHeight;
812}
813
814AFX_INLINE XTPGridSectionDividerPosition CXTPGridSection::GetDividerPosition() const
815{
816 return m_dividerPosition;
817}
818
819AFX_INLINE void CXTPGridSection::SetDividerPosition(XTPGridSectionDividerPosition dividerPosition)
820{
821 m_dividerPosition = dividerPosition;
822}
823
824AFX_INLINE XTPGridSectionDividerStyle CXTPGridSection::GetDividerStyle() const
825{
826 return m_dividerStyle;
827}
828
829AFX_INLINE void CXTPGridSection::SetDividerStyle(XTPGridSectionDividerStyle dividerStyle)
830{
831 m_dividerStyle = dividerStyle;
832}
833
834AFX_INLINE CXTPPaintManagerColor CXTPGridSection::GetDividerColor() const
835{
836 return m_clrDivider;
837}
838
839AFX_INLINE void CXTPGridSection::SetDividerColor(CXTPPaintManagerColor clrDivider)
840{
841 m_clrDivider = clrDivider;
842}
843
844AFX_INLINE CRect CXTPGridSection::GetRect() const
845{
846 return m_rcSection;
847}
848
849AFX_INLINE CRect CXTPGridSection::GetDividerRect() const
850{
851 return m_rcDivider;
852}
853
854AFX_INLINE int CXTPGridSection::GetPopulatedRecordsCount() const
855{
856 return m_nPopulatedRecordsCount;
857}
858
859AFX_INLINE XTPGridScrollMode CXTPGridSection::GetScrollModeH() const
860{
861 XTPGridScrollMode scrollMode = xtpGridScrollModeNone;
862
863 if (NULL != m_pControl)
864 {
865 scrollMode = m_pControl->GetScrollMode(xtpGridOrientationHorizontal);
866 }
867
868 return scrollMode;
869}
870
871AFX_INLINE XTPGridScrollMode CXTPGridSection::GetScrollModeV() const
872{
873 XTPGridScrollMode scrollMode = xtpGridScrollModeNone;
874
875 if (NULL != m_pControl)
876 {
877 scrollMode = m_pControl->GetScrollMode(xtpGridOrientationVertical);
878 }
879
880 return scrollMode;
881}
883# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
884#endif //#if !defined(__XTPGRIDSECTION_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPGridScrollMode
XTPGridScrollMode
Enumeration of scroll modes.
Definition XTPGridControl.h:320
xtpGridScrollModeNone
@ xtpGridScrollModeNone
No scrolling.
Definition XTPGridControl.h:321
xtpGridOrientationHorizontal
@ xtpGridOrientationHorizontal
Specifies horizontal grid orientation.
Definition XTPGridDefines.h:109
xtpGridOrientationVertical
@ xtpGridOrientationVertical
Specifies vertical grid orientation.
Definition XTPGridDefines.h:110
XTPGridRowType
XTPGridRowType
This enum defines body, header, and footer rows.
Definition XTPGridDefines.h:94
XTPGridSectionDividerPosition
XTPGridSectionDividerPosition
Section divider position.
Definition XTPGridDefines.h:258
XTPGridSectionDividerStyle
XTPGridSectionDividerStyle
Represent the header/footer rows divider style.
Definition XTPGridDefines.h:227
XTPGridSectionHeightMode
XTPGridSectionHeightMode
Section height algorithm.
Definition XTPGridSection.h:46
xtpGridSectionHeightModeAutoExpand
@ xtpGridSectionHeightModeAutoExpand
Minimum auto size.
Definition XTPGridSection.h:52
xtpGridSectionHeightModeAuto
@ xtpGridSectionHeightModeAuto
Equal to 'auto' in HTML.
Definition XTPGridSection.h:49
xtpGridSectionHeightModeRelative
@ xtpGridSectionHeightModeRelative
Equal to '' in HTML.
Definition XTPGridSection.h:48
xtpGridSectionHeightModeExpand
@ xtpGridSectionHeightModeExpand
Equal to '*' in HTML.
Definition XTPGridSection.h:50
xtpGridSectionHeightModeFixed
@ xtpGridSectionHeightModeFixed
Equal to 'px' in HTML.
Definition XTPGridSection.h:47
xtpGridSectionHeightModeAutoShrink
@ xtpGridSectionHeightModeAutoShrink
Maximum auto size.
Definition XTPGridSection.h:53
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPGridControl
The CXTPGridControl class provides an implementation of the Grid control.
Definition XTPGridControl.h:479
CXTPGridControl::GetScrollMode
XTPGridScrollMode GetScrollMode(XTPGridOrientation orientation) const
Gets the scroll mode.
CXTPGridGroupRow
This class represents a 'group row' of the Grid control view.
Definition XTPGridGroupRow.h:49
CXTPGridRecord
CXTPGridRecord represents a collection of CXTPGridRecordItem objects or objects of classes that are c...
Definition XTPGridRecord.h:59
CXTPGridRecords
This class represents a grid records collection.
Definition XTPGridRecords.h:71
CXTPGridRow
CXTPGridRow class represents a row of the Grid control window.
Definition XTPGridRow.h:71
CXTPGridRows
This class represents a rows collection class.
Definition XTPGridRows.h:108
CXTPGridSection
Represents a grid section.
Definition XTPGridSection.h:61
CXTPGridSection::Populate
virtual void Populate(BOOL bUpdate)
Populates the section with rows.
CXTPGridSection::m_bAllowSort
BOOL m_bAllowSort
TRUE if rows can be sorted.
Definition XTPGridSection.h:679
CXTPGridSection::m_pBorder
CXTPGridBorder * m_pBorder
Border.
Definition XTPGridSection.h:654
CXTPGridSection::m_bSelectionEnable
BOOL m_bSelectionEnable
TRUE if selection enabled.
Definition XTPGridSection.h:681
CXTPGridSection::AddRecord
virtual CXTPGridRecord * AddRecord(CXTPGridRecord *pRecord)
Adds a record to the records collection.
CXTPGridSection::m_pRecords
CXTPGridRecords * m_pRecords
Records container.
Definition XTPGridSection.h:657
CXTPGridSection::IsSelectionEnabled
BOOL IsSelectionEnabled() const
Determines if rows selection is enabled/disabled.
Definition XTPGridSection.h:769
CXTPGridSection::BuildTree
void BuildTree(CXTPGridRows *pTree, CXTPGridRow *pParentRow, CXTPGridRecords *pRecords)
Builds a rows tree based on the provided data record.
CXTPGridSection::GetBorder
CXTPGridBorder * GetBorder() const
Gets the border of this grid section.
CXTPGridSection::GetRows
CXTPGridRows * GetRows() const
Gets the collection of grid rows.
Definition XTPGridSection.h:789
CXTPGridSection::IsAllowSort
BOOL IsAllowSort() const
Determines if row sorting is enabled/disabled.
Definition XTPGridSection.h:749
CXTPGridSection::IsAllowAccess
BOOL IsAllowAccess() const
Determines if the user is allowed to move the selection to rows.
Definition XTPGridSection.h:719
CXTPGridSection::m_bAllowAccess
BOOL m_bAllowAccess
TRUE if rows can be selected.
Definition XTPGridSection.h:676
CXTPGridSection::m_dividerPosition
XTPGridSectionDividerPosition m_dividerPosition
Divider position.
Definition XTPGridSection.h:670
CXTPGridSection::SetMarkupContext
void SetMarkupContext(CXTPMarkupContext *pMarkupContext)
Sets the markup context.
CXTPGridSection::GetDividerRect
CRect GetDividerRect() const
Gets the divider rectangle of this section.
Definition XTPGridSection.h:849
CXTPGridSection::GetPopulatedRecordsCount
int GetPopulatedRecordsCount() const
Gets the number of records after using m_strFilterText.
Definition XTPGridSection.h:854
CXTPGridSection::SetScrollIndexV
virtual void SetScrollIndexV(int nIndex)
Sets the current topmost row.
CXTPGridSection::m_rcSection
CRect m_rcSection
The area occupied by the section.
Definition XTPGridSection.h:667
CXTPGridSection::~CXTPGridSection
virtual ~CXTPGridSection()
Destructs a grid section.
CXTPGridSection::RefreshIndexes
virtual void RefreshIndexes(int nIndexStart)
Recalculates the indexes for all rows.
CXTPGridSection::AllowFilter
void AllowFilter(BOOL bAllowFilter)
Enables/disables row filtering.
Definition XTPGridSection.h:754
CXTPGridSection::m_UaSorted
CUIntArray m_UaSorted
Sorted array.
Definition XTPGridSection.h:697
CXTPGridSection::SetHeight
void SetHeight(int nHeight)
Sets the suggested height.
Definition XTPGridSection.h:809
CXTPGridSection::GetDividerStyle
XTPGridSectionDividerStyle GetDividerStyle() const
Gets the divider style for this section.
Definition XTPGridSection.h:824
CXTPGridSection::m_nPopulatedRecordsCount
int m_nPopulatedRecordsCount
Number of records after using m_strFilterText.
Definition XTPGridSection.h:661
CXTPGridSection::ReSortRows
virtual void ReSortRows()
Re-sorts the rows for this section.
CXTPGridSection::GetRowType
XTPGridRowType GetRowType() const
Gets the type of the selected rows (i.e.
CXTPGridSection::m_rcDivider
CRect m_rcDivider
Divider rectangle.
Definition XTPGridSection.h:668
CXTPGridSection::CXTPGridSection
CXTPGridSection(CXTPGridControl *pControl, XTPGridRowType rowType)
Constructs a grid section.
CXTPGridSection::GetFocusedRow
CXTPGridRow * GetFocusedRow() const
Gets the currently focused row in the Grid control's view.
CXTPGridSection::m_heightMode
XTPGridSectionHeightMode m_heightMode
Height mode algorithm.
Definition XTPGridSection.h:673
CXTPGridSection::IsVisible
BOOL IsVisible() const
Gets the visible state of the section.
Definition XTPGridSection.h:779
CXTPGridSection::SortTree
virtual void SortTree(CXTPGridRows *pTree)
Sorts a rows tree collection according to the sort order for columns.
CXTPGridSection::GetSelectedRows
CXTPGridSelectedRows * GetSelectedRows() const
Gets the collection of selected rows.
CXTPGridSection::_DoCollapse
virtual int _DoCollapse(CXTPGridRow *pRow)
Collapses all children of the specified row.
CXTPGridSection::Draw
virtual void Draw(CDC *pDC)
Draws this section on a specified device context.
CXTPGridSection::m_pTree
CXTPGridRows * m_pTree
Tree rows container.
Definition XTPGridSection.h:659
CXTPGridSection::m_dividerStyle
XTPGridSectionDividerStyle m_dividerStyle
Divider style.
Definition XTPGridSection.h:671
CXTPGridSection::m_bAllowGroup
BOOL m_bAllowGroup
TRUE if rows can be grouped.
Definition XTPGridSection.h:678
CXTPGridSection::m_pRows
CXTPGridRows * m_pRows
Rows container.
Definition XTPGridSection.h:658
CXTPGridSection::GetRecords
CXTPGridRecords * GetRecords() const
Gets the collection of data records.
Definition XTPGridSection.h:784
CXTPGridSection::m_pControl
CXTPGridControl * m_pControl
Parent control.
Definition XTPGridSection.h:656
CXTPGridSection::m_pMarkupContext
CXTPMarkupContext * m_pMarkupContext
Markup context.
Definition XTPGridSection.h:653
CXTPGridSection::IsAllowFilter
BOOL IsAllowFilter() const
Determines if row filtering is enabled/disabled.
Definition XTPGridSection.h:759
CXTPGridSection::GetDividerColor
CXTPPaintManagerColor GetDividerColor() const
Gets the divider color for this section.
Definition XTPGridSection.h:834
CXTPGridSection::GetHeight
int GetHeight() const
Gets the suggested height.
Definition XTPGridSection.h:804
CXTPGridSection::GetHeightMode
XTPGridSectionHeightMode GetHeightMode() const
Gets the current height mode.
Definition XTPGridSection.h:794
CXTPGridSection::SetScrollOffsetV
virtual void SetScrollOffsetV(int nScrollOffsetV)
Sets the vertical scroll offset.
CXTPGridSection::SelectionEnable
void SelectionEnable(BOOL bEnable)
Enables/disables rows selection.
Definition XTPGridSection.h:764
CXTPGridSection::_DoExpand
virtual int _DoExpand(int nIndex, CXTPGridRow *pRow)
Expands all children of a specified row.
CXTPGridSection::SortRows
virtual void SortRows(CXTPGridRows *pRows)
Sorts a rows collection according to the sort order for columns.
CXTPGridSection::CollapseAll
void CollapseAll()
Collapses all rows.
CXTPGridSection::AllowAccess
void AllowAccess(BOOL bAllowAccess)
Specifies if the user is allowed to move the selection to rows.
Definition XTPGridSection.h:714
CXTPGridSection::IsVirtualMode
virtual BOOL IsVirtualMode() const
Determines if virtual mode is enabled/disabled for this section.
CXTPGridSection::m_bVisible
BOOL m_bVisible
TRUE if section is visible.
Definition XTPGridSection.h:682
CXTPGridSection::AllowEdit
void AllowEdit(BOOL bAllowEdit)
Specifies if the text in all CXTPGridRecordItem(s) can be edited.
Definition XTPGridSection.h:724
CXTPGridSection::ResetContent
virtual void ResetContent()
Deletes all rows and records from the section.
CXTPGridSection::IsAllowEdit
BOOL IsAllowEdit() const
Determines if the text in all CXTPGridRecordItem(s) can be edited.
Definition XTPGridSection.h:729
CXTPGridSection::m_clrDivider
CXTPPaintManagerColor m_clrDivider
Divider color.
Definition XTPGridSection.h:669
CXTPGridSection::_DoExpand
virtual int _DoExpand(int nIndex, CXTPGridRow *pRow, BOOL bUpdateSelection)
Expands all children of a specified row.
CXTPGridSection::GetScrollIndexV
virtual int GetScrollIndexV()
Gets the current topmost row.
CXTPGridSection::SetDividerPosition
void SetDividerPosition(XTPGridSectionDividerPosition dividerPosition)
Sets the divider position for this section.
Definition XTPGridSection.h:819
CXTPGridSection::m_nScrollOffsetV
int m_nScrollOffsetV
Vertical scroll offset.
Definition XTPGridSection.h:693
CXTPGridSection::GetScrollOffsetV
virtual int GetScrollOffsetV() const
Gets the vertical scroll offset.
CXTPGridSection::AllowSort
void AllowSort(BOOL bAllowSort)
Enables/disables row sorting.
Definition XTPGridSection.h:744
CXTPGridSection::GetDividerPosition
XTPGridSectionDividerPosition GetDividerPosition() const
Gets the divider position for this section.
Definition XTPGridSection.h:814
CXTPGridSection::IsAllowGroup
BOOL IsAllowGroup() const
Determines if row grouping is enabled/disabled.
Definition XTPGridSection.h:739
CXTPGridSection::ExpandAll
void ExpandAll(BOOL bRecursive)
Expands all rows.
CXTPGridSection::GetRect
CRect GetRect() const
Gets the rectangle of this section.
Definition XTPGridSection.h:844
CXTPGridSection::AllowGroup
void AllowGroup(BOOL bAllowGroup)
Enables/disables row grouping.
Definition XTPGridSection.h:734
CXTPGridSection::SetDividerColor
void SetDividerColor(CXTPPaintManagerColor clrDivider)
Sets the divider color for this section.
Definition XTPGridSection.h:839
CXTPGridSection::GetIndex
int GetIndex() const
Gets the index of this section.
CXTPGridSection::RefreshIndexes
virtual void RefreshIndexes()
Recalculates the indexes for all rows.
CXTPGridSection::m_bAllowEdit
BOOL m_bAllowEdit
TRUE if rows can be edited.
Definition XTPGridSection.h:677
CXTPGridSection::SetHeightMode
void SetHeightMode(XTPGridSectionHeightMode heightMode)
Sets the current height mode.
Definition XTPGridSection.h:799
CXTPGridSection::m_bAllowFilter
BOOL m_bAllowFilter
TRUE if rows can be filtered.
Definition XTPGridSection.h:680
CXTPGridSection::SetVisible
void SetVisible(BOOL bVisible=TRUE)
Sets the visible state of the section.
Definition XTPGridSection.h:774
CXTPGridSection::m_nHeight
int m_nHeight
Suggested height (Fixed/Relative).
Definition XTPGridSection.h:674
CXTPGridSection::SetDividerStyle
void SetDividerStyle(XTPGridSectionDividerStyle dividerStyle)
Sets the divider style for this section.
Definition XTPGridSection.h:829
CXTPGridSection::m_nScrollIndexV
int m_nScrollIndexV
Current top row in the visible area.
Definition XTPGridSection.h:687
CXTPGridSections
Collection of sections.
Definition XTPGridSections.h:53
CXTPGridSelectedRows
Encapsulates a collection of CXTPGridRow pointers that represent the selected rows in a Grid control.
Definition XTPGridSelectedRows.h:73
CXTPMarkupContext
CXTPMarkupContext is a standalone class used to provide common settings for Markup objects.
Definition XTPMarkupContext.h:128
CXTPPaintManagerColor
The CXTPPaintManagerColor class is used to manage COLORREF values for determining default and applica...
Definition XTPColorManager.h:117


Toolkit Pro: XTPShortcutBar.h Source File

  • Source
  • ShortcutBar
XTPShortcutBar.h
Go to the documentation of this file.
1
23#if !defined(__XTPSHORTCUTBAR_H__)
24# define __XTPSHORTCUTBAR_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPShortcutBarAnimation;
34class CXTPShortcutBarPopup;
35class CXTPImageManagerIcon;
36
53const UINT XTP_SBN_SELECTION_CHANGING = 1;
54
68const UINT XTP_SBN_SELECTION_CHANGED = 3;
69
83const UINT XTP_SBN_RCLICK = 2;
84
98const UINT XTP_SBN_MINIMIZEBUTTONCLICKED = 4;
99
169const UINT XTPWM_SHORTCUTBAR_NOTIFY = (WM_USER + 9190 + 1);
170
171class CXTPShortcutBar;
172class CXTPImageManager;
173class CXTPToolTipContext;
174
180class _XTP_EXT_CLASS CXTPShortcutBarItem : public CXTPCmdTarget
181{
182 DECLARE_DYNAMIC(CXTPShortcutBarItem);
183
184protected:
192 CXTPShortcutBarItem(CXTPShortcutBar* pShortcutBar, int nID, CWnd* pWnd);
193
194public:
200 void SetID(int nID);
201
208 int GetID() const;
209
215 void SetIconId(int nId);
216
223 int GetIconId() const;
224
230 void SetCaption(LPCTSTR strCaption);
231
238 CString GetCaption() const;
239
245 void SetVisible(BOOL bVisible);
246
253 BOOL IsVisible() const;
254
262 void SetTooltip(LPCTSTR strTooltip);
263
270 CString GetTooltip() const;
271
278 BOOL IsExpanded() const;
279
286 BOOL IsItemExpandButton() const;
287
294 CXTPShortcutBar* GetShortcutBar() const;
295
302 CRect GetItemRect() const;
303
309 void SetItemData(DWORD_PTR dwData);
310
317 DWORD_PTR GetItemData() const;
318
331 CXTPImageManagerIcon* GetImage(int nWidth) const;
332
343 BOOL IsHidden() const;
344
354 BOOL IsSelected() const;
355
364 void SetSelected(BOOL bSelected);
365
375 CWnd* GetClientWindow() const;
376
385 void SetClientWindow(CWnd* pWnd);
386
393 BOOL IsEnabled() const;
394
400 void SetEnabled(BOOL bEnabled);
401
402protected:
403 CString m_strCaption;
404 CString m_strTooltip;
405 int m_nID;
406 CRect m_rcItem;
407 BOOL m_bVisible;
408 BOOL m_bExpanded;
409 BOOL m_bHidden;
410 HWND m_hwndChild;
411 BOOL m_bExpandButton;
412 BOOL m_bNavigateButton;
413 DWORD_PTR m_dwData;
414 CXTPShortcutBar* m_pShortcutBar;
415 BOOL m_bSelected;
416 int m_nIconId;
417 BOOL m_bEnabled;
419private:
420# ifdef _XTP_ACTIVEX
423 DECLARE_DISPATCH_MAP()
424 DECLARE_INTERFACE_MAP()
425
426 DECLARE_OLETYPELIB_EX(CXTPShortcutBarItem)
427public:
428 enum
429 {
430 dispidCaption = 1L,
431 dispidTooltip = 2L,
432 dispidId = 3L,
433 dispidIconIndex = 4L,
434 dispidVisible = 5L,
435 dispidIconHandle = 6L,
436 };
437 afx_msg BSTR OleGetCaption();
438 afx_msg BSTR OleGetTooltip();
439
440 DECLARE_PROPERTY(IconHandle, int);
441 DECLARE_PROPERTY(Handle, OLE_HANDLE);
442
443 static CXTPShortcutBarItem* AFX_CDECL FromDispatch(LPDISPATCH pDisp);
444
446# endif /*_XTP_ACTIVEX*/
447 friend class CXTPShortcutBar;
448};
449
455class _XTP_EXT_CLASS CXTPShortcutBar : public CWnd
456{
461 typedef CArray<CXTPShortcutBarItem*, CXTPShortcutBarItem*> CShortcutArray;
462
463public:
468 CXTPShortcutBar();
469
474 virtual ~CXTPShortcutBar();
475
476public:
487 BOOL Create(DWORD dwStyle, const RECT& rect, CWnd* pParentWnd, UINT nID);
488
496 BOOL RegisterWindowClass(HINSTANCE hInstance = NULL);
497
498public:
506 void LoadState(LPCTSTR lpszProfileName);
507
515 void SaveState(LPCTSTR lpszProfileName);
516
517public:
526 CXTPShortcutBarItem* AddItem(UINT nID, CWnd* pWnd = NULL);
527
535 CXTPShortcutBarItem* FindItem(int nID) const;
536
542 void SelectItem(CXTPShortcutBarItem* pItem);
543
549 void ShowExpandButton(BOOL bShow);
550
557 BOOL IsExpandButtonVisible() const;
558
564 void RemoveItem(int nID);
565
570 void RemoveAllItems();
571
579 CXTPShortcutBarItem* GetItem(int nIndex) const;
580
589 CXTPShortcutBarItem* HitTest(CPoint pt) const;
590
598 void SetMinimumClientHeight(int nMinHeight);
599
606 CRect GetGripperRect() const;
607
614 CSize GetItemSize() const;
615
621 void SetItemSize(CSize szItem);
622
631 int GetExpandedLinesCount() const;
632
641 int GetExpandedLinesHeight() const;
642
650 void SetExpandedLinesCount(int nCount);
651
659 void SetExpandedLinesHeight(int nHeight);
660
669 void AllowGripperResize(BOOL bAllowResize);
670
677 CXTPShortcutBarItem* GetHotItem() const;
678
685 CXTPShortcutBarItem* GetSelectedItem() const;
686
700 void SetSingleSelection(BOOL bSingleSelection = TRUE);
701
711 BOOL IsSingleSelection() const;
712
721 void ShowActiveItemOnTop(BOOL bActiveItemOnTop);
722
731 BOOL IsShowActiveItemOnTop() const;
732
741 void AllowFreeResize(BOOL bAllowFreeResize);
742
752 BOOL IsAllowFreeResize() const;
753
759 void AllowCollapse(BOOL bAllowCollapse);
760
766 void ShowGripper(BOOL bShowGripper);
767
774 CXTPShortcutBarItem* GetPressedItem() const;
775
782 BOOL IsClientPaneVisible() const;
783
789 void SetClientPaneVisible(BOOL bVisible);
790
808 void SetImageManager(CXTPImageManager* pImageManager);
809
821 CXTPImageManager* GetImageManager() const;
822
829 int GetItemCount() const;
830
836 void SetLayoutRTL(BOOL bRightToLeft);
837
844 CRect GetClientPaneRect() const;
845
846public:
861 void SetTheme(XTPShortcutBarPaintTheme paintTheme);
862
870 void SetCustomTheme(CXTPShortcutBarPaintManager* pPaintManager);
871
878 CXTPShortcutBarPaintManager* GetPaintManager() const;
879
889 XTPShortcutBarPaintTheme GetCurrentTheme() const;
890
897 void RedrawControl(LPCRECT lpRect = NULL, BOOL bAnimate = FALSE);
898
905 CXTPToolTipContext* GetToolTipContext() const;
906
913 int GetVisibleItemsCount() const;
914
921 int GetCollapsedItemsCount() const;
922
927 virtual void Reposition();
928
936 virtual void OnDraw(CDC* pDC, CRect rcClipBox);
937
943 void EnableAnimation(BOOL bEnable = TRUE);
944
953 BOOL IsShortcutBarMinimized() const;
954
964 void AllowMinimize(BOOL bAllowMinimize = TRUE, int nMinimizedWidth = 0);
965
972 void ShowMinimizeButton(BOOL bShowMinimizeButton);
973
981 BOOL IsMinimizeButtonVisible() const;
982
990 BOOL IsAllowMinimize() const;
991
992 CXTPShortcutBarItem* GetNavigationPaneItem() const;
993
994 virtual void OnMinimizeButtonClicked();
995
996protected:
1001 virtual void OnRepositionDone();
1002
1008 virtual void OnExpandButtonDown(CXTPShortcutBarItem* pExpandButton);
1009
1015 void OnNavigateButtonDown(CXTPShortcutBarItem* pNavigateButton);
1016
1022 void SetHotItem(CXTPShortcutBarItem* pItem);
1023
1024protected:
1026 DECLARE_MESSAGE_MAP()
1027
1028 //{{AFX_VIRTUAL(CXTPShortcutBar)
1029 BOOL OnWndMsg(UINT message, WPARAM wParam, LPARAM lParam, LRESULT* pResult);
1030 INT_PTR OnToolHitTest(CPoint point, TOOLINFO* pTI) const;
1031 void PreSubclassWindow();
1032 BOOL PreCreateWindow(CREATESTRUCT& cs);
1033 //}}AFX_VIRTUAL
1034
1035 //{{AFX_MSG(CXTPShortcutBar)
1036 afx_msg void OnPaint();
1037 afx_msg LRESULT OnPrintClient(WPARAM wParam, LPARAM /*lParam*/);
1038 afx_msg BOOL OnEraseBkgnd(CDC* pDC);
1039 afx_msg void OnSize(UINT nType, int cx, int cy);
1040 afx_msg int OnCreate(LPCREATESTRUCT lpCreateStruct);
1041 afx_msg void OnDestroy();
1042 afx_msg void OnTimer(UINT_PTR nIDEvent);
1043 afx_msg void OnNcPaint();
1044 afx_msg void OnNcCalcSize(BOOL /*bCalcValidRects*/, NCCALCSIZE_PARAMS* /*lpncsp*/);
1045 afx_msg BOOL OnSetCursor(CWnd* pWnd, UINT nHitTest, UINT message);
1046 afx_msg void OnMouseMove(UINT nFlags, CPoint point);
1047 afx_msg void OnLButtonDown(UINT nFlags, CPoint point);
1048 afx_msg void OnLButtonUp(UINT nFlags, CPoint point);
1049 afx_msg void OnCaptureChanged(CWnd* pWnd);
1050 afx_msg void OnMouseLeave();
1051 afx_msg void OnSysColorChange();
1052 afx_msg void OnRButtonDown(UINT nFlags, CPoint point);
1053 afx_msg void OnRButtonUp(UINT nFlags, CPoint point);
1054 afx_msg LRESULT OnExpandPopupExecute(WPARAM wparam, LPARAM lParam);
1055 afx_msg void OnShowMoreButtons();
1056 afx_msg void OnShowFewerButtons();
1057 afx_msg void OnUpdateShowMoreButtons(CCmdUI* pCmdUI);
1058 afx_msg void OnUpdateShowFewerButtons(CCmdUI* pCmdUI);
1059 afx_msg void OnSetFocus(CWnd* pWnd);
1060 //}}AFX_MSG
1063private:
1064 BOOL Create(LPCTSTR lpszClassName, LPCTSTR lpszWindowName, DWORD dwStyle, const RECT& rect,
1065 CWnd* pParentWnd, UINT nID, CCreateContext* pContext = NULL);
1066 CXTPShortcutBarItem* CreateNavigationItem();
1067 CXTPShortcutBarItem* CreateConfigureButton();
1068
1069protected:
1070 CXTPShortcutBarPaintManager* m_pPaintManager;
1071 CXTPImageManager* m_pImageManager;
1072 int m_nExpandedLines;
1073 int m_nDesiredExpandedLinesHeight;
1074 int m_nMinClientHeight;
1075 BOOL m_bAllowResize;
1076 XTPShortcutBarPaintTheme m_paintTheme;
1077 CShortcutArray m_arrItems;
1078 CSize m_szItem;
1079 CRect m_rcClient;
1080 CRect m_rcGripper;
1081 HWND m_hwndClient;
1082 HCURSOR m_hSizeCursor;
1083 BOOL m_bTrackingSize;
1084 BOOL m_bShowActiveItemOnTop;
1085 BOOL m_bAllowFreeResize;
1086 BOOL m_bAllowCollapse;
1087 BOOL m_bShowGripper;
1089 CXTPShortcutBarItem* m_pHotItem;
1090 CXTPShortcutBarItem* m_pSelectedItem;
1091 CXTPShortcutBarItem* m_pPressedItem;
1093 CXTPShortcutBarPopup* m_pActivePopup;
1094
1095 CXTPShortcutBarItem* m_pNavigationPaneItem;
1096
1097 BOOL m_bClientPaneVisible;
1098 HCURSOR m_hHandCursor;
1100 BOOL m_bSingleSelection;
1101 CXTPToolTipContext* m_pToolTipContext;
1102 BOOL m_bPreSubclassWindow;
1103 CXTPShortcutBarAnimation* m_pAnimation;
1105 int m_bAllowMinimize;
1106 int m_nMinimizedWidth;
1107 BOOL m_bMinimized;
1108 BOOL m_bShowMinimizeButton;
1109
1110 friend class CXTPShortcutBarItem;
1111 friend class CShortcutBarCtrl;
1112};
1113
1115
1116AFX_INLINE CString CXTPShortcutBarItem::GetCaption() const
1117{
1118 return m_strCaption;
1119}
1120AFX_INLINE CString CXTPShortcutBarItem::GetTooltip() const
1121{
1122 return m_strTooltip;
1123}
1124AFX_INLINE BOOL CXTPShortcutBarItem::IsItemExpandButton() const
1125{
1126 return m_bExpandButton;
1127}
1128AFX_INLINE BOOL CXTPShortcutBarItem::IsExpanded() const
1129{
1130 return m_bExpanded;
1131}
1132AFX_INLINE CXTPShortcutBar* CXTPShortcutBarItem::GetShortcutBar() const
1133{
1134 return m_pShortcutBar;
1135}
1136AFX_INLINE CRect CXTPShortcutBarItem::GetItemRect() const
1137{
1138 return m_rcItem;
1139}
1140AFX_INLINE void CXTPShortcutBarItem::SetItemData(DWORD_PTR dwData)
1141{
1142 m_dwData = dwData;
1143}
1144AFX_INLINE DWORD_PTR CXTPShortcutBarItem::GetItemData() const
1145{
1146 return m_dwData;
1147}
1148AFX_INLINE CWnd* CXTPShortcutBarItem::GetClientWindow() const
1149{
1150 return CWnd::FromHandle(m_hwndChild);
1151}
1152
1153AFX_INLINE CXTPShortcutBarItem* CXTPShortcutBar::GetHotItem() const
1154{
1155 return m_pHotItem;
1156}
1157AFX_INLINE CXTPShortcutBarItem* CXTPShortcutBar::GetSelectedItem() const
1158{
1159 return m_pSelectedItem;
1160}
1161AFX_INLINE CXTPShortcutBarItem* CXTPShortcutBar::GetPressedItem() const
1162{
1163 return m_pPressedItem;
1164}
1165AFX_INLINE CRect CXTPShortcutBar::GetGripperRect() const
1166{
1167 return m_rcGripper;
1168}
1169AFX_INLINE CSize CXTPShortcutBar::GetItemSize() const
1170{
1171 return m_szItem;
1172}
1173AFX_INLINE void CXTPShortcutBar::SetItemSize(CSize szItem)
1174{
1175 m_szItem = szItem;
1176}
1177AFX_INLINE int CXTPShortcutBar::GetExpandedLinesCount() const
1178{
1179 return m_nExpandedLines;
1180}
1181AFX_INLINE BOOL CXTPShortcutBar::IsClientPaneVisible() const
1182{
1183 return m_bClientPaneVisible;
1184}
1185AFX_INLINE void CXTPShortcutBar::SetClientPaneVisible(BOOL bVisible)
1186{
1187 m_bClientPaneVisible = bVisible;
1188 Reposition();
1189}
1190AFX_INLINE CXTPShortcutBarPaintManager* CXTPShortcutBar::GetPaintManager() const
1191{
1192 return m_pPaintManager;
1193}
1194AFX_INLINE void CXTPShortcutBar::SetMinimumClientHeight(int nMinHeight)
1195{
1196 m_nMinClientHeight = nMinHeight;
1197}
1198AFX_INLINE XTPShortcutBarPaintTheme CXTPShortcutBar::GetCurrentTheme() const
1199{
1200 return m_paintTheme;
1201}
1202AFX_INLINE BOOL CXTPShortcutBar::Create(LPCTSTR lpszClassName, LPCTSTR lpszWindowName,
1203 DWORD dwStyle, const RECT& rect, CWnd* pParentWnd, UINT nID,
1204 CCreateContext* pContext)
1205{
1206 return CWnd::Create(lpszClassName, lpszWindowName, dwStyle, rect, pParentWnd, nID, pContext);
1207}
1208AFX_INLINE void CXTPShortcutBar::AllowGripperResize(BOOL bAllowResize)
1209{
1210 m_bAllowResize = bAllowResize;
1211}
1212AFX_INLINE void CXTPShortcutBar::SetSingleSelection(BOOL bSingleSelection)
1213{
1214 m_bSingleSelection = bSingleSelection;
1215 Reposition();
1216}
1217AFX_INLINE BOOL CXTPShortcutBar::IsSingleSelection() const
1218{
1219 return m_bSingleSelection;
1220}
1221AFX_INLINE void CXTPShortcutBar::ShowActiveItemOnTop(BOOL bActiveItemOnTop)
1222{
1223 m_bShowActiveItemOnTop = bActiveItemOnTop;
1224 Reposition();
1225}
1226AFX_INLINE BOOL CXTPShortcutBar::IsShowActiveItemOnTop() const
1227{
1228 return m_bShowActiveItemOnTop;
1229}
1230AFX_INLINE void CXTPShortcutBar::AllowFreeResize(BOOL bAllowFreeResize)
1231{
1232 m_bAllowFreeResize = bAllowFreeResize;
1233 Reposition();
1234}
1235AFX_INLINE BOOL CXTPShortcutBar::IsAllowFreeResize() const
1236{
1237 return m_bAllowFreeResize;
1238}
1239AFX_INLINE void CXTPShortcutBar::AllowCollapse(BOOL bAllowCollapse)
1240{
1241 m_bAllowCollapse = bAllowCollapse;
1242 Reposition();
1243}
1244AFX_INLINE void CXTPShortcutBar::ShowGripper(BOOL bShowGripper)
1245{
1246 m_bShowGripper = bShowGripper;
1247 Reposition();
1248}
1249AFX_INLINE int CXTPShortcutBar::GetExpandedLinesHeight() const
1250{
1251 return m_nDesiredExpandedLinesHeight;
1252}
1253AFX_INLINE CRect CXTPShortcutBar::GetClientPaneRect() const
1254{
1255 return m_rcClient;
1256}
1257AFX_INLINE void CXTPShortcutBar::ShowMinimizeButton(BOOL bShowMinimizeButton)
1258{
1259 m_bShowMinimizeButton = bShowMinimizeButton;
1260 Reposition();
1261}
1262AFX_INLINE BOOL CXTPShortcutBar::IsAllowMinimize() const
1263{
1264 return m_bAllowMinimize;
1265}
1266AFX_INLINE CXTPShortcutBarItem* CXTPShortcutBar::GetNavigationPaneItem() const
1267{
1268 return m_pNavigationPaneItem;
1269}
1270AFX_INLINE BOOL CXTPShortcutBar::IsMinimizeButtonVisible() const
1271{
1272 return m_bShowMinimizeButton;
1273}
1274
1275# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
1277#endif // !defined(__XTPSHORTCUTBAR_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTP_SBN_MINIMIZEBUTTONCLICKED
const UINT XTP_SBN_MINIMIZEBUTTONCLICKED
XTP_SBN_MINIMIZEBUTTONCLICKED is used to indicate that the user has pressed the minimize button insid...
Definition XTPShortcutBar.h:98
XTP_SBN_SELECTION_CHANGING
const UINT XTP_SBN_SELECTION_CHANGING
XTP_SBN_SELECTION_CHANGED is used to indicate that the selection has changed in the shortcut bar.
Definition XTPShortcutBar.h:53
XTPWM_SHORTCUTBAR_NOTIFY
const UINT XTPWM_SHORTCUTBAR_NOTIFY
The XTPWM_SHORTCUTBAR_NOTIFY message is sent to the CXTPShortcutBar owner window whenever an action o...
Definition XTPShortcutBar.h:169
XTP_SBN_SELECTION_CHANGED
const UINT XTP_SBN_SELECTION_CHANGED
XTP_SBN_SELECTION_CHANGING is used to indicate that the value for the selection is currently changing...
Definition XTPShortcutBar.h:68
XTP_SBN_RCLICK
const UINT XTP_SBN_RCLICK
XTP_SBN_RCLICK is used to indicate that the user has pressed the right mouse button on a shortcut bar...
Definition XTPShortcutBar.h:83
XTPShortcutBarPaintTheme
XTPShortcutBarPaintTheme
XTPShortcutBarPaintTheme is an enumeration used by CXTPShortcutBar to set the theme of the control.
Definition XTPShortcutBarPaintManager.h:49
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPImageManager
CXTPImageManager is a standalone class.
Definition XTPImageManager.h:1898
CXTPImageManagerIcon
Icons holder class.
Definition XTPImageManager.h:622
CXTPShortcutBar
CXTPShortcutBar is a CWnd derived class used to implement an Outlook 2003 shortcut bar control style.
Definition XTPShortcutBar.h:456
CXTPShortcutBar::GetToolTipContext
CXTPToolTipContext * GetToolTipContext() const
Gets the tooltip context.
CXTPShortcutBar::GetCollapsedItemsCount
int GetCollapsedItemsCount() const
Gets the number of collapsed items.
CXTPShortcutBar::AllowGripperResize
void AllowGripperResize(BOOL bAllowResize)
Allows/disallows resizing the client area.
Definition XTPShortcutBar.h:1208
CXTPShortcutBar::GetItemCount
int GetItemCount() const
Gets the number of items in the shortcut bar control.
CXTPShortcutBar::IsAllowFreeResize
BOOL IsAllowFreeResize() const
Determines if resizing the gripper by pixel is allowed/disallowed.
Definition XTPShortcutBar.h:1235
CXTPShortcutBar::ShowExpandButton
void ShowExpandButton(BOOL bShow)
Shows/hides the expand button.
CXTPShortcutBar::GetCurrentTheme
XTPShortcutBarPaintTheme GetCurrentTheme() const
Gets the theme of the shortcut bar control.
Definition XTPShortcutBar.h:1198
CXTPShortcutBar::RegisterWindowClass
BOOL RegisterWindowClass(HINSTANCE hInstance=NULL)
Registers the window class if it has not already been registered.
CXTPShortcutBar::GetExpandedLinesCount
int GetExpandedLinesCount() const
Gets the number of visible lines in the shortcut bar control.
Definition XTPShortcutBar.h:1177
CXTPShortcutBar::OnDraw
virtual void OnDraw(CDC *pDC, CRect rcClipBox)
This method is called by the framework to draw the shortcut bar control using the specified device co...
CXTPShortcutBar::~CXTPShortcutBar
virtual ~CXTPShortcutBar()
Destroys a CXTPShortcutBar object, handles cleanup and deallocation.
CXTPShortcutBar::AddItem
CXTPShortcutBarItem * AddItem(UINT nID, CWnd *pWnd=NULL)
Adds a specified item.
CXTPShortcutBar::RemoveItem
void RemoveItem(int nID)
Removes the item with a specified identifier.
CXTPShortcutBar::OnNavigateButtonDown
void OnNavigateButtonDown(CXTPShortcutBarItem *pNavigateButton)
This method is called when the navigate button is pressed.
CXTPShortcutBar::IsShowActiveItemOnTop
BOOL IsShowActiveItemOnTop() const
Determines if the active item is shown on top of controls.
Definition XTPShortcutBar.h:1226
CXTPShortcutBar::AllowFreeResize
void AllowFreeResize(BOOL bAllowFreeResize)
Allows/disallows resizing the gripper by pixel.
Definition XTPShortcutBar.h:1230
CXTPShortcutBar::LoadState
void LoadState(LPCTSTR lpszProfileName)
Retrieves state information from the registry or .INI file.
CXTPShortcutBar::HitTest
CXTPShortcutBarItem * HitTest(CPoint pt) const
Determines which item, if any, is located at a specified point.
CXTPShortcutBar::IsMinimizeButtonVisible
BOOL IsMinimizeButtonVisible() const
Determines if the minimize button contained in the caption of the pane is shown/hidden.
Definition XTPShortcutBar.h:1270
CXTPShortcutBar::IsAllowMinimize
BOOL IsAllowMinimize() const
Determines if minimizing the shortcut bar control is allowed/disallowed.
Definition XTPShortcutBar.h:1262
CXTPShortcutBar::GetHotItem
CXTPShortcutBarItem * GetHotItem() const
Gets the hot item in the shortcut bar control.
Definition XTPShortcutBar.h:1153
CXTPShortcutBar::RedrawControl
void RedrawControl(LPCRECT lpRect=NULL, BOOL bAnimate=FALSE)
Redraws the shortcut bar control.
CXTPShortcutBar::ShowGripper
void ShowGripper(BOOL bShowGripper)
Shows/hides the gripper.
Definition XTPShortcutBar.h:1244
CXTPShortcutBar::GetPressedItem
CXTPShortcutBarItem * GetPressedItem() const
Gets the pressed item in the shortcut bar control.
Definition XTPShortcutBar.h:1161
CXTPShortcutBar::OnExpandButtonDown
virtual void OnExpandButtonDown(CXTPShortcutBarItem *pExpandButton)
This method is called when the expand button is pressed.
CXTPShortcutBar::SaveState
void SaveState(LPCTSTR lpszProfileName)
Saves state information to the registry or .INI file.
CXTPShortcutBar::SetExpandedLinesCount
void SetExpandedLinesCount(int nCount)
Sets the number of visible lines in the shortcut bar control.
CXTPShortcutBar::GetExpandedLinesHeight
int GetExpandedLinesHeight() const
Gets the height of visible lines in the shortcut bar control.
Definition XTPShortcutBar.h:1249
CXTPShortcutBar::RemoveAllItems
void RemoveAllItems()
Removes all items.
CXTPShortcutBar::SetTheme
void SetTheme(XTPShortcutBarPaintTheme paintTheme)
Sets the theme for the shortcut bar control.
CXTPShortcutBar::GetGripperRect
CRect GetGripperRect() const
Gets the bounding rectangle of the gripper.
Definition XTPShortcutBar.h:1165
CXTPShortcutBar::IsSingleSelection
BOOL IsSingleSelection() const
Determines if single selection is enabled/disabled.
Definition XTPShortcutBar.h:1217
CXTPShortcutBar::AllowMinimize
void AllowMinimize(BOOL bAllowMinimize=TRUE, int nMinimizedWidth=0)
Allows/disallows minimizing the shortcut bar control.
CXTPShortcutBar::SetCustomTheme
void SetCustomTheme(CXTPShortcutBarPaintManager *pPaintManager)
Sets a custom theme for the shortcut bar control.
CXTPShortcutBar::SetItemSize
void SetItemSize(CSize szItem)
Sets the size for items.
Definition XTPShortcutBar.h:1173
CXTPShortcutBar::SetExpandedLinesHeight
void SetExpandedLinesHeight(int nHeight)
Sets the height for visible lines in the shortcut bar control.
CXTPShortcutBar::ShowActiveItemOnTop
void ShowActiveItemOnTop(BOOL bActiveItemOnTop)
Specifies if the active item should be shown on top of controls.
Definition XTPShortcutBar.h:1221
CXTPShortcutBar::CXTPShortcutBar
CXTPShortcutBar()
Constructs a CXTPShortcutBar object.
CXTPShortcutBar::ShowMinimizeButton
void ShowMinimizeButton(BOOL bShowMinimizeButton)
Shows/hides the minimize button contained in the caption of the pane.
Definition XTPShortcutBar.h:1257
CXTPShortcutBar::GetSelectedItem
CXTPShortcutBarItem * GetSelectedItem() const
Gets the selected item in the shortcut bar control.
Definition XTPShortcutBar.h:1157
CXTPShortcutBar::Reposition
virtual void Reposition()
Repositions items.
CXTPShortcutBar::IsClientPaneVisible
BOOL IsClientPaneVisible() const
Determines if the client pane is shown/hidden.
Definition XTPShortcutBar.h:1181
CXTPShortcutBar::FindItem
CXTPShortcutBarItem * FindItem(int nID) const
Retrieves the item with a specified identifier.
CXTPShortcutBar::IsShortcutBarMinimized
BOOL IsShortcutBarMinimized() const
Determines if the shortcut bar control is minimized.
CXTPShortcutBar::GetImageManager
CXTPImageManager * GetImageManager() const
Gets the image manager of the shortcut bar control.
CXTPShortcutBar::GetItemSize
CSize GetItemSize() const
Gets the size of items.
Definition XTPShortcutBar.h:1169
CXTPShortcutBar::GetClientPaneRect
CRect GetClientPaneRect() const
Gets the bounding rectangle of the shortcut bar client.
Definition XTPShortcutBar.h:1253
CXTPShortcutBar::SetLayoutRTL
void SetLayoutRTL(BOOL bRightToLeft)
Sets right-to-left (RTL) mode.
CXTPShortcutBar::IsExpandButtonVisible
BOOL IsExpandButtonVisible() const
Determines if the expand button is shown/hidden.
CXTPShortcutBar::GetPaintManager
CXTPShortcutBarPaintManager * GetPaintManager() const
Gets the paint manager.
Definition XTPShortcutBar.h:1190
CXTPShortcutBar::OnRepositionDone
virtual void OnRepositionDone()
This method is called when reposition is done.
CXTPShortcutBar::Create
BOOL Create(DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID)
Creates the CXTPShortcutBar control.
CXTPShortcutBar::AllowCollapse
void AllowCollapse(BOOL bAllowCollapse)
Call this method to allow collapse items.
Definition XTPShortcutBar.h:1239
CXTPShortcutBar::SetSingleSelection
void SetSingleSelection(BOOL bSingleSelection=TRUE)
Enables/disables single selection.
Definition XTPShortcutBar.h:1212
CXTPShortcutBar::SetMinimumClientHeight
void SetMinimumClientHeight(int nMinHeight)
Sets the minimum height for the client area.
Definition XTPShortcutBar.h:1194
CXTPShortcutBar::SetClientPaneVisible
void SetClientPaneVisible(BOOL bVisible)
Shows/hides the client pane.
Definition XTPShortcutBar.h:1185
CXTPShortcutBar::SetHotItem
void SetHotItem(CXTPShortcutBarItem *pItem)
Sets the hot item.
CXTPShortcutBar::GetVisibleItemsCount
int GetVisibleItemsCount() const
Gets the number of visible items.
CXTPShortcutBar::SetImageManager
void SetImageManager(CXTPImageManager *pImageManager)
Sets the image manager for the shortcut bar control.
CXTPShortcutBar::GetItem
CXTPShortcutBarItem * GetItem(int nIndex) const
Retrieves the item at a specified index.
CXTPShortcutBar::SelectItem
void SelectItem(CXTPShortcutBarItem *pItem)
Selects a specified item.
CXTPShortcutBar::EnableAnimation
void EnableAnimation(BOOL bEnable=TRUE)
Enables/disables animation for the shortcut bar control.
CXTPShortcutBarItem
CXTPShortcutBarItem is a base class that represents an item for a shortcut bar control.
Definition XTPShortcutBar.h:181
CXTPShortcutBarItem::SetTooltip
void SetTooltip(LPCTSTR strTooltip)
Sets the tooltip text for the item.
CXTPShortcutBarItem::SetClientWindow
void SetClientWindow(CWnd *pWnd)
Sets the child window for the item.
CXTPShortcutBarItem::IsVisible
BOOL IsVisible() const
Determines the visible state of the item.
CXTPShortcutBarItem::m_pShortcutBar
CXTPShortcutBar * m_pShortcutBar
Parent CXTPShortcutBar class.
Definition XTPShortcutBar.h:414
CXTPShortcutBarItem::GetImage
CXTPImageManagerIcon * GetImage(int nWidth) const
Retrieves the image of the item.
CXTPShortcutBarItem::m_strTooltip
CString m_strTooltip
Tooltip of the item.
Definition XTPShortcutBar.h:404
CXTPShortcutBarItem::IsSelected
BOOL IsSelected() const
Gets the selected state of the item.
CXTPShortcutBarItem::CXTPShortcutBarItem
CXTPShortcutBarItem(CXTPShortcutBar *pShortcutBar, int nID, CWnd *pWnd)
Constructs a CXTPShortcutBarItem object.
CXTPShortcutBarItem::SetIconId
void SetIconId(int nId)
Sets the identifier for the icon.
CXTPShortcutBarItem::SetCaption
void SetCaption(LPCTSTR strCaption)
Sets the caption for the item.
CXTPShortcutBarItem::m_bExpandButton
BOOL m_bExpandButton
TRUE if the item is an expand button.
Definition XTPShortcutBar.h:411
CXTPShortcutBarItem::SetID
void SetID(int nID)
Sets the identifier for the item.
CXTPShortcutBarItem::GetIconId
int GetIconId() const
Gets the identifier of the icon.
CXTPShortcutBarItem::m_bExpanded
BOOL m_bExpanded
TRUE if the item is expanded.
Definition XTPShortcutBar.h:408
CXTPShortcutBarItem::m_bSelected
BOOL m_bSelected
TRUE if the item is selected.
Definition XTPShortcutBar.h:415
CXTPShortcutBarItem::GetItemData
DWORD_PTR GetItemData() const
Gets the application-supplied, 32-bit value associated with the item.
Definition XTPShortcutBar.h:1144
CXTPShortcutBarItem::IsExpanded
BOOL IsExpanded() const
Gets the expanded state of the item.
Definition XTPShortcutBar.h:1128
CXTPShortcutBarItem::SetVisible
void SetVisible(BOOL bVisible)
Specifies the visible state of the item.
CXTPShortcutBarItem::SetItemData
void SetItemData(DWORD_PTR dwData)
Sets the 32-bit value associated with the item.
Definition XTPShortcutBar.h:1140
CXTPShortcutBarItem::SetEnabled
void SetEnabled(BOOL bEnabled)
Sets the enabled state for the item.
CXTPShortcutBarItem::m_hwndChild
HWND m_hwndChild
Child window associated with the item.
Definition XTPShortcutBar.h:410
CXTPShortcutBarItem::m_rcItem
CRect m_rcItem
Bounding rectangle of the item.
Definition XTPShortcutBar.h:406
CXTPShortcutBarItem::m_nIconId
int m_nIconId
Identifier of the item's image.
Definition XTPShortcutBar.h:416
CXTPShortcutBarItem::m_bHidden
BOOL m_bHidden
TRUE if the item is hidden.
Definition XTPShortcutBar.h:409
CXTPShortcutBarItem::GetID
int GetID() const
Gets the identifier of the item.
CXTPShortcutBarItem::GetItemRect
CRect GetItemRect() const
Gets the bounding rectangle of the item.
Definition XTPShortcutBar.h:1136
CXTPShortcutBarItem::SetSelected
void SetSelected(BOOL bSelected)
Sets the selected state for the item.
CXTPShortcutBarItem::m_bVisible
BOOL m_bVisible
TRUE if the item is visible.
Definition XTPShortcutBar.h:407
CXTPShortcutBarItem::m_dwData
DWORD_PTR m_dwData
The 32-bit value associated with the item.
Definition XTPShortcutBar.h:413
CXTPShortcutBarItem::IsHidden
BOOL IsHidden() const
Gets the hidden state of the item.
CXTPShortcutBarItem::GetShortcutBar
CXTPShortcutBar * GetShortcutBar() const
Gets the parent shortcut bar.
Definition XTPShortcutBar.h:1132
CXTPShortcutBarItem::GetTooltip
CString GetTooltip() const
Gets the tooltip text of the item.
Definition XTPShortcutBar.h:1120
CXTPShortcutBarItem::m_bNavigateButton
BOOL m_bNavigateButton
TRUE if the item is a navigate button.
Definition XTPShortcutBar.h:412
CXTPShortcutBarItem::GetClientWindow
CWnd * GetClientWindow() const
Gets the child window of the item.
Definition XTPShortcutBar.h:1148
CXTPShortcutBarItem::IsItemExpandButton
BOOL IsItemExpandButton() const
Determines if the item is an expand button.
Definition XTPShortcutBar.h:1124
CXTPShortcutBarItem::m_nID
int m_nID
Item's identifier.
Definition XTPShortcutBar.h:405
CXTPShortcutBarItem::IsEnabled
BOOL IsEnabled() const
Gets the enabled state of the item.
CXTPShortcutBarItem::m_bEnabled
BOOL m_bEnabled
TRUE if the item is enabled.
Definition XTPShortcutBar.h:417
CXTPShortcutBarItem::m_strCaption
CString m_strCaption
Caption of the item.
Definition XTPShortcutBar.h:403
CXTPShortcutBarPaintManager
CXTPShortcutBarPaintManager is a standalone class used as a paint manager for a shortcut bar control.
Definition XTPShortcutBarPaintManager.h:79
CXTPToolTipContext
CXTPToolTipContext is a CXTPCmdTarget derived class.
Definition XTPToolTipContext.h:291


Toolkit Pro: Member List

CXTPFlowGraphUndoCommand Member List

This is the complete list of members for CXTPFlowGraphUndoCommand, including all inherited members.

CXTPFlowGraphUndoCommand(int nID) | CXTPFlowGraphUndoCommand | protected
GetID() const | CXTPFlowGraphUndoCommand |
m_nID | CXTPFlowGraphUndoCommand | protected
Undo() | CXTPFlowGraphUndoCommand | protectedvirtual
~CXTPFlowGraphUndoCommand() | CXTPFlowGraphUndoCommand | protectedvirtual


Toolkit Pro: XTPChartStepLineSeriesStyle.h Source File

  • Source
  • Chart
  • Styles
  • Line
XTPChartStepLineSeriesStyle.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTSTEPLINESERIESSTYLE_H__)
24# define __XTPCHARTSTEPLINESERIESSTYLE_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartSeriesView;
34class CXTPChartStepLineStyle;
35
46class _XTP_EXT_CLASS CXTPChartStepLineSeriesStyle : public CXTPChartLineSeriesStyle
47{
49 DECLARE_SERIAL(CXTPChartStepLineSeriesStyle)
51public:
56 CXTPChartStepLineSeriesStyle();
57
62 virtual ~CXTPChartStepLineSeriesStyle();
63
64public:
72 BOOL GetInvertedStep() const;
73
80 void SetInvertedStep(BOOL bInvertedStep);
81
82protected:
93 virtual CXTPChartSeriesView* CreateView(CXTPChartSeries* pSeries,
94 CXTPChartDiagramView* pDiagramView);
95
102 void DoPropExchange(CXTPPropExchange* pPX);
103
104# ifdef _XTP_ACTIVEX
105public:
107 DECLARE_DISPATCH_MAP()
108 DECLARE_INTERFACE_MAP()
109 DECLARE_OLETYPELIB_EX(CXTPChartStepLineSeriesStyle);
110 DECLARE_OLECREATE_EX(CXTPChartStepLineSeriesStyle)
111 LPDISPATCH OleGetStepLineStyle();
113# endif
114
115protected:
116 BOOL m_bInvertedStep;
117};
118
124class _XTP_EXT_CLASS CXTPChartStepLineSeriesView : public CXTPChartDiagram2DSeriesView
125{
126public:
134 CXTPChartStepLineSeriesView(CXTPChartSeries* pSeries, CXTPChartDiagramView* pDiagramView);
135
136protected:
148 CXTPChartSeriesPointView* CreateSeriesPointView(CXTPChartDeviceContext* pDC,
149 CXTPChartSeriesPoint* pPoint,
150 CXTPChartElementView* pParentView);
151
164 virtual CXTPChartDeviceCommand* CreateDeviceCommand(CXTPChartDeviceContext* pDC);
165
176 virtual CXTPChartDeviceCommand* CreateLegendDeviceCommand(CXTPChartDeviceContext* pDC,
177 CRect rcBounds);
178};
179
185class _XTP_EXT_CLASS CXTPChartStepLineSeriesPointView : public CXTPChartPointSeriesPointView
186{
187public:
195 CXTPChartStepLineSeriesPointView(CXTPChartSeriesPoint* pPoint,
196 CXTPChartElementView* pParentView);
197
198public:
209 virtual CXTPChartDeviceCommand* CreateLegendDeviceCommand(CXTPChartDeviceContext* pDC,
210 CRect rcBounds);
211};
212
213AFX_INLINE BOOL CXTPChartStepLineSeriesStyle::GetInvertedStep() const
214{
215 return m_bInvertedStep;
216}
217AFX_INLINE void CXTPChartStepLineSeriesStyle::SetInvertedStep(BOOL bInvertedStep)
218{
219 m_bInvertedStep = bInvertedStep;
220 OnChartChanged();
221}
223# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
224#endif //#if !defined(__XTPCHARTSTEPLINESERIESSTYLE_H__)
pPoint
const CPoint * pPoint
return 0 or xtpCalendarHitTestDayExpandButton
Definition XTPCalendarThemeOffice2007.h:150
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartDiagramView
This class represents the view of a chart diagram, which is a kind of CXTPChartElementView.
Definition XTPChartDiagramView.h:49
CXTPChartElement::OnChartChanged
virtual void OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic propertie...
CXTPChartElementView
This class represents the view of a chart element.
Definition XTPChartElementView.h:47
CXTPChartLineSeriesStyle
This class represents a line series style, which is a kind of CXTPChartPointSeriesStyle.
Definition XTPChartLineSeriesStyle.h:47
CXTPChartPointSeriesPointView
This class represents the view of a point series point, which is a kind of CXTPChartSeriesPointView.
Definition XTPChartPointSeriesView.h:90
CXTPChartSeries
This class represents a series in the chart, which is a kind of CXTPChartElement.
Definition XTPChartSeries.h:50
CXTPChartSeriesPoint
CXTPChartSeriesPoint is a kind of CXTPChartElement.
Definition XTPChartSeriesPoint.h:43
CXTPChartSeriesPointView
Represents chart series point view.
Definition XTPChartSeriesPointView.h:48
CXTPChartStepLineSeriesPointView
This class represents the view of a step line series point, which is a kind of CXTPChartSeriesPointVi...
Definition XTPChartStepLineSeriesStyle.h:186
CXTPChartStepLineSeriesPointView::CreateLegendDeviceCommand
virtual CXTPChartDeviceCommand * CreateLegendDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcBounds)
This function creates a label view drawing command object.
CXTPChartStepLineSeriesPointView::CXTPChartStepLineSeriesPointView
CXTPChartStepLineSeriesPointView(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Constructs a point view object.
CXTPChartStepLineSeriesStyle
This class represents a StepLine series style, which is a kind of CXTPChartLineSeriesStyle.
Definition XTPChartStepLineSeriesStyle.h:47
CXTPChartStepLineSeriesStyle::DoPropExchange
void DoPropExchange(CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
CXTPChartStepLineSeriesStyle::~CXTPChartStepLineSeriesStyle
virtual ~CXTPChartStepLineSeriesStyle()
Destroys a CXTPChartStepLineSeriesStyle object, handles cleanup.
CXTPChartStepLineSeriesStyle::CreateView
virtual CXTPChartSeriesView * CreateView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Call this function to create view of the StepLine series.
CXTPChartStepLineSeriesStyle::GetInvertedStep
BOOL GetInvertedStep() const
Gets inverted step flag.
Definition XTPChartStepLineSeriesStyle.h:213
CXTPChartStepLineSeriesStyle::SetInvertedStep
void SetInvertedStep(BOOL bInvertedStep)
Sets inverted step flag.
Definition XTPChartStepLineSeriesStyle.h:217
CXTPChartStepLineSeriesStyle::CXTPChartStepLineSeriesStyle
CXTPChartStepLineSeriesStyle()
Constructs a CXTPChartStepLineSeriesStyle object.
CXTPChartStepLineSeriesView
This class represents the view of a StepLine series, which is a kind of CXTPChartSeriesView.
Definition XTPChartStepLineSeriesStyle.h:125
CXTPChartStepLineSeriesView::CreateDeviceCommand
virtual CXTPChartDeviceCommand * CreateDeviceCommand(CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
CXTPChartStepLineSeriesView::CreateLegendDeviceCommand
virtual CXTPChartDeviceCommand * CreateLegendDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcBounds)
This function creates a label view drawing command object.
CXTPChartStepLineSeriesView::CreateSeriesPointView
CXTPChartSeriesPointView * CreateSeriesPointView(CXTPChartDeviceContext *pDC, CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Call this function to create a view of the StepLine series point.
CXTPChartStepLineSeriesView::CXTPChartStepLineSeriesView
CXTPChartStepLineSeriesView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Constructs a CXTPChartStepLineSeriesView object.
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72


Toolkit Pro: Member List

CXTPCalendarPtrCollectionT< _TObject > Member List

This is the complete list of members for CXTPCalendarPtrCollectionT< _TObject >, including all inherited members.

Add(_TObject *pNewElement) | CXTPCalendarPtrCollectionT< _TObject > | virtual
Add(_TObject *pNewElement, BOOL bWithAddRef) | CXTPCalendarPtrCollectionT< _TObject > | virtual
Append(const CXTPCalendarPtrCollectionT< _TObject > *pElementsArray) | CXTPCalendarPtrCollectionT< _TObject > | virtual
CXTPCalendarPtrCollectionT() | CXTPCalendarPtrCollectionT< _TObject > |
CXTPCmdTarget() | CXTPCmdTarget |
Find(const _TObject *pElement) const | CXTPCalendarPtrCollectionT< _TObject > | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAt(int nIndex) const | CXTPCalendarPtrCollectionT< _TObject > | virtual
GetAt(int nIndex, BOOL bWithAddRef) const | CXTPCalendarPtrCollectionT< _TObject > | virtual
GetCount() const | CXTPCalendarPtrCollectionT< _TObject > | virtual
InsertAt(int nIndex, _TObject *pElement) | CXTPCalendarPtrCollectionT< _TObject > | virtual
m_arElements | CXTPCalendarPtrCollectionT< _TObject > | protected
Remove(_TObject *pElement) | CXTPCalendarPtrCollectionT< _TObject > | virtual
RemoveAll() | CXTPCalendarPtrCollectionT< _TObject > | virtual
RemoveAt(int nIndex) | CXTPCalendarPtrCollectionT< _TObject > | virtual
SetAt(int nIndex, _TObject *pElement) | CXTPCalendarPtrCollectionT< _TObject > | virtual
SetSize(int nNewSize) | CXTPCalendarPtrCollectionT< _TObject > | virtual
TObjectPtr typedef | CXTPCalendarPtrCollectionT< _TObject > | protected
~CXTPCalendarPtrCollectionT() | CXTPCalendarPtrCollectionT< _TObject > | virtual


Toolkit Pro: XTPMarkupAmbientColorsStaticExtension.h Source File

  • Source
  • Markup
  • Extensions
XTPMarkupAmbientColorsStaticExtension.h
Go to the documentation of this file.
1
23#if !defined(__XTPMARKUPAMBIENTCOLORSSTATICEXTENSION_H__)
24# define __XTPMARKUPAMBIENTCOLORSSTATICEXTENSION_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
35class CXTPPaintManager;
36enum XTPPaintManagerAccentColor;
37
38class _XTP_EXT_CLASS CXTPMarkupAmbientColor
39 : public CXTPMarkupColor
40 , private IXTPApplicationEvents
41{
42public:
43 explicit CXTPMarkupAmbientColor(XTPApplicationAmbientProperty nProperty);
44 ~CXTPMarkupAmbientColor();
45
46private:
47 virtual void OnAmbientPropertyChanged(CXTPApplication* pApplication,
48 XTPApplicationAmbientProperty nProperty);
49
50 XTPApplicationAmbientProperty m_nProperty;
51};
52
53class _XTP_EXT_CLASS CXTPMarkupAmbientColorBrush
54 : public CXTPMarkupSolidColorBrush
55 , private IXTPApplicationEvents
56{
57public:
58 explicit CXTPMarkupAmbientColorBrush(XTPApplicationAmbientProperty nProperty);
59 ~CXTPMarkupAmbientColorBrush();
60
61private:
62 virtual void OnAmbientPropertyChanged(CXTPApplication* pApplication,
63 XTPApplicationAmbientProperty nProperty);
64 XTPApplicationAmbientProperty m_nProperty;
65};
66
67class _XTP_EXT_CLASS CXTPMarkupAmbientColorsStaticExtensionProperty
68 : public CXTPMarkupStaticExtensionProperty
69{
70public:
71 CXTPMarkupAmbientColorsStaticExtensionProperty(LPCWSTR lpzName,
72 XTPApplicationAmbientProperty nProperty);
73 static CXTPMarkupColor* AFX_CDECL GetAmbientColor(XTPApplicationAmbientProperty nProperty);
74};
75
76class _XTP_EXT_CLASS CXTPMarkupAmbientColorsBrushStaticExtensionProperty
77 : public CXTPMarkupStaticExtensionProperty
78{
79public:
80 CXTPMarkupAmbientColorsBrushStaticExtensionProperty(LPCWSTR lpzName,
81 XTPApplicationAmbientProperty nProperty);
82
83 static CXTPMarkupBrush* AFX_CDECL GetAmbientColorsBrush(XTPApplicationAmbientProperty nProperty);
84};
85
86class _XTP_EXT_CLASS CXTPMarkupAmbientColorsStaticExtension : public CXTPMarkupStaticExtension
87{
88public:
89 CXTPMarkupAmbientColorsStaticExtension();
90};
91
92struct IXTPPaintManagerCustomAccentColorProvider
93{
94 virtual ~IXTPPaintManagerCustomAccentColorProvider()
95 {
96 }
97
98 virtual COLORREF GetCustomAccentColor(XTPPaintManagerAccentColor nColor) = 0;
99};
100
101class _XTP_EXT_CLASS CXTPMarkupPaintManagerBaseThemeBrushStaticExtensionProperty
102 : public CXTPMarkupStaticExtensionProperty
103 , private IXTPApplicationEvents
104{
105public:
106 CXTPMarkupPaintManagerBaseThemeBrushStaticExtensionProperty(
107 LPCWSTR lpzName, XTPPaintManagerAccentColor nColor,
108 IXTPPaintManagerCustomAccentColorProvider& customColorProvider);
109 ~CXTPMarkupPaintManagerBaseThemeBrushStaticExtensionProperty();
110
111private:
112 virtual void OnAmbientPropertyChanged(CXTPApplication* pApplication,
113 XTPApplicationAmbientProperty nProperty);
114 virtual void OnPrepareValue();
115
116 void UpdateColorValue();
117
118 BOOL m_bValueUpdated;
119 XTPPaintManagerAccentColor m_nColor;
120 IXTPPaintManagerCustomAccentColorProvider& m_customColorProvider;
121};
122
125# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
127#endif // !defined(__XTPMARKUPAMBIENTCOLORSSTATICEXTENSION_H__)
XTPApplicationAmbientProperty
XTPApplicationAmbientProperty
Global ambient property identifiers.
Definition XTPApplication.h:46
XTPPaintManagerAccentColor
XTPPaintManagerAccentColor
Defines a set of accent related colors.
Definition XTPColorManager.h:900
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPApplication
Defines a global XTP application object interface.
Definition XTPApplication.h:151
CXTPMarkupStaticExtension
A base class for a markup static extension composite object.
Definition XTPMarkupStaticExtension.h:41
CXTPMarkupStaticExtensionProperty
A convenience base class for all static extension properties.
Definition XTPMarkupStaticExtension.h:171
CXTPPaintManager
Paint manager of the command bars.
Definition XTPPaintManager.h:199
IXTPApplicationEvents
Defines a callback interface for XTP application event sink.
Definition XTPApplication.h:82
IXTPApplicationEvents::OnAmbientPropertyChanged
virtual void OnAmbientPropertyChanged(CXTPApplication *pApplication, XTPApplicationAmbientProperty nProperty)
Called by framework when an ambient property is changed.
Definition XTPApplication.h:130


Toolkit Pro: Member List

CXTPPropertyGridVerbs Member List

This is the complete list of members for CXTPPropertyGridVerbs, including all inherited members.

Add(LPCTSTR lpszCaption, UINT nID) | CXTPPropertyGridVerbs |
CXTPCmdTarget() | CXTPCmdTarget |
CXTPPropertyGridVerbs() | CXTPPropertyGridVerbs |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAt(int nIndex) const | CXTPPropertyGridVerbs |
GetCount() const | CXTPPropertyGridVerbs |
IsEmpty() const | CXTPPropertyGridVerbs |
m_arrVerbs | CXTPPropertyGridVerbs | protected
m_pGrid | CXTPPropertyGridVerbs | protected
RemoveAll() | CXTPPropertyGridVerbs |
~CXTPPropertyGridVerbs() | CXTPPropertyGridVerbs |


Toolkit Pro: Member List

XTP_CALENDAR_DAYVIEWCELL_PARAMS Member List

This is the complete list of members for XTP_CALENDAR_DAYVIEWCELL_PARAMS, including all inherited members.

bSelected | XTP_CALENDAR_DAYVIEWCELL_PARAMS
clrBackgroundColor | XTP_CALENDAR_DAYVIEWCELL_PARAMS
dtBeginTime | XTP_CALENDAR_DAYVIEWCELL_PARAMS
nIndex | XTP_CALENDAR_DAYVIEWCELL_PARAMS


Toolkit Pro: XTPSliderThemeOffice2007System.h Source File

  • Source
  • CommandBars
  • Slider
XTPSliderThemeOffice2007System.h
Go to the documentation of this file.
1
23#if !defined(__XTPSLIDERTHEMEOFFICE2007SYSTEM_H__)
24# define __XTPSLIDERTHEMEOFFICE2007SYSTEM_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class _XTP_EXT_CLASS CXTPSliderThemeOffice2007System : public CXTPSliderPaintManager
34{
35public:
36 CXTPSliderThemeOffice2007System(CXTPPaintManager* pPaintManager);
37
38public:
39 virtual void RefreshMetrics();
40 virtual void DrawScrollBar(CDC* pDC, CXTPScrollBase* pScrollBar);
41};
42
44# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
45#endif // !defined(__XTPSLIDERTHEMEOFFICE2007SYSTEM_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPPaintManager
Paint manager of the command bars.
Definition XTPPaintManager.h:199
CXTPScrollBase
CXTPScrollBase is the base class for all scrollable objects.
Definition XTPScrollBase.h:222
CXTPSliderPaintManager
Paint manager for the slider control.
Definition XTPSliderPaintManager.h:40
CXTPSliderPaintManager::DrawScrollBar
virtual void DrawScrollBar(CDC *pDC, CXTPScrollBase *pScrollBar)
This method is called to draw the scrollbar of the slider.
CXTPSliderPaintManager::RefreshMetrics
virtual void RefreshMetrics()
Recalculates gallery metrics.


Toolkit Pro: Member List

CColorSetVisualStudio2005 Member List

This is the complete list of members for CColorSetVisualStudio2005, including all inherited members.

CColorSetVisualStudio2005() | CColorSetVisualStudio2005 |
CXTPTabPaintManagerColorSet() | CXTPTabPaintManagerColorSet |
FillClient(CDC *pDC, CRect rc, CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
FillHeader(CDC *pDC, CRect rc, CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
FillNavigateButton(CDC *pDC, CXTPTabManagerNavigateButton *pButton, CRect &rc) | CXTPTabColorSetOffice2003 | virtual
FillPropertyButton(CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem) | CColorSetVisualStudio2005 | virtual
FillStateButton(CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerColorSet | virtual
GetClientColor(CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
GetItemColor(CXTPTabManagerItem *pItem) | CXTPTabPaintManagerColorSet | virtual
GradientFill(CDC *pDC, CRect rc, COLORREF clrLight, COLORREF clrDark, XTPTabPosition position) | CXTPTabPaintManagerColorSet |
IsAppThemed() const | CXTPTabPaintManagerColorSet | virtual
m_bGradientButton | CColorSetVisualStudio2005 | protected
m_bLunaTheme | CXTPTabColorSetOffice2003 | protected
m_clrActiveFilesBack | CXTPTabPaintManagerColorSet |
m_clrActiveFilesBackHighlighted | CXTPTabPaintManagerColorSet |
m_clrActiveFilesBackPressed | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyph | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyphHighlighted | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyphPressed | CXTPTabPaintManagerColorSet |
m_clrAutoHideFace | CXTPTabPaintManagerColorSet |
m_clrBorderHighlight | CXTPTabPaintManagerColorSet |
m_clrButtonBorder | CXTPTabPaintManagerColorSet |
m_clrButtonBorderHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonBorderHot | CXTPTabPaintManagerColorSet |
m_clrButtonBorderKeyTips | CXTPTabPaintManagerColorSet |
m_clrButtonBorderTabContext1 | CXTPTabPaintManagerColorSet |
m_clrButtonBorderTabContext2 | CXTPTabPaintManagerColorSet |
m_clrButtonHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonHighlightedClose | CXTPTabPaintManagerColorSet |
m_clrButtonNormal | CXTPTabPaintManagerColorSet |
m_clrButtonPressed | CXTPTabPaintManagerColorSet |
m_clrButtonSelected | CXTPTabPaintManagerColorSet |
m_clrButtonSelectedHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonSelectedPressed | CXTPTabPaintManagerColorSet |
m_clrControlFace | CXTPTabPaintManagerColorSet |
m_clrFrameBorder | CXTPTabPaintManagerColorSet |
m_clrHeaderFace | CXTPTabPaintManagerColorSet |
m_clrNavigateButtonBorder | CXTPTabColorSetOffice2003 | protected
m_clrPaneFace | CXTPTabPaintManagerColorSet |
m_clrTabClientBack | CXTPTabPaintManagerColorSet |
m_clrTabClientBorder | CXTPTabPaintManagerColorSet |
m_clrTextDisabled | CXTPTabPaintManagerColorSet |
m_clrTextHighlight | CXTPTabPaintManagerColorSet |
m_clrTextHighlightClose | CXTPTabPaintManagerColorSet |
m_clrTextNormal | CXTPTabPaintManagerColorSet |
m_clrTextPressed | CXTPTabPaintManagerColorSet |
m_clrTextSelected | CXTPTabPaintManagerColorSet |
m_clrTextSelectedHighlighted | CXTPTabPaintManagerColorSet |
m_clrTextSelectedPressed | CXTPTabPaintManagerColorSet |
m_csExcelNormal | CXTPTabPaintManagerColorSet |
m_csExcelSelected | CXTPTabPaintManagerColorSet |
m_csPropertyPage | CXTPTabPaintManagerColorSet |
m_csPropertyPage2003 | CXTPTabPaintManagerColorSet |
m_csStateButton | CXTPTabPaintManagerColorSet |
m_pPaintManager | CXTPTabPaintManagerColorSet | protected
Rectangle(CDC *pDC, CRect rc, int nPen, int nBrush) | CXTPTabColorSetOffice2003 |
RefreshMetrics() | CColorSetVisualStudio2005 | virtual
SelectClipRgn(CDC *pDC, CRect rcClient, CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
SetTextColor(CDC *pDC, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerColorSet | virtual
~CXTPTabPaintManagerColorSet() | CXTPTabPaintManagerColorSet | virtual


Toolkit Pro: Member List

CXTPChart3dRotateDeviceCommand Member List

This is the complete list of members for CXTPChart3dRotateDeviceCommand, including all inherited members.

AddChildCommand(CXTPChartDeviceCommand *pCommand) | CXTPChartDeviceCommand |
AfterExecute(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
ApplySeriesStyle(CXTPChartSeriesStyle *pStyle) | CXTPChartDeviceCommand | virtual
BeforeExecute(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
BindView(CXTPChartElementView *pView) | CXTPChartDeviceCommand |
Commit() | CXTPChartDeviceCommand |
CXTPChart3dDeviceCommand(XTPChart3dAntialiasingPolicy nAntialiasingPolicy) | CXTPChart3dDeviceCommand | protected
CXTPChart3dRotateDeviceCommand(const CXTPChart3dRotation &rotation) | CXTPChart3dRotateDeviceCommand |
CXTPChartDeviceCommand() | CXTPChartDeviceCommand |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPObservable() | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | protected
Execute(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
ExecuteOverride(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
GetBoundView() const | CXTPChartDeviceCommand |
GetChildCommand(int nIndex) const | CXTPChartDeviceCommand |
GetChildCommandCount() const | CXTPChartDeviceCommand |
GetCurrentDC() const | CXTPChartDeviceCommand |
GetPassNumber() const | CXTPChartDeviceCommand |
HitTest(CPoint point, CXTPChartElement *pParent) const | CXTPChart3dRotateDeviceCommand | virtual
Is3D() const | CXTPChartObject |
IsCommitted() const | CXTPChartDeviceCommand |
IsEnabled() const | CXTPChart3dDeviceCommand | virtual
m_arrChildren | CXTPChartDeviceCommand | protected
m_rotation | CXTPChart3dRotateDeviceCommand | protected
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Prepare(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
PrepareOverride(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
SetEnabled(BOOL bEnabled=TRUE) | CXTPChartDeviceCommand |
Subscribe(CXTPChartDeviceCommandEvents *pObserver, CXTPSubscriptionList< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > *pSubcriptionList=NULL) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > |
Unsubscribe(CXTPChartDeviceCommandEvents *pObserver) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > |
~CXTPChartDeviceCommand() | CXTPChartDeviceCommand | virtual
~CXTPObservable() | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | protected


Toolkit Pro: Member List

CXTPChartPieBase Member List

This is the complete list of members for CXTPChartPieBase, including all inherited members.

CalculateCenter(const CXTPChartPointF &basePoint) const | CXTPChartPieBase |
CreateBoundedPieDeviceCommand(const CXTPChartColor &color, int nThickness, const CXTPChartPointF &basePoint)=0 | CXTPChartPieBase | pure virtual
CreatePieDeviceCommand(const CXTPChartColor &color, const CXTPChartColor &color2, const CXTPChartPointF &basePoint)=0 | CXTPChartPieBase | pure virtual
CXTPChartPieBase(double dStartAngle, double dFinishAngle, const CXTPChartEllipse &ellipse, int nDepthPercent, int nHolePercent) | CXTPChartPieBase | protected
GetBounds() const | CXTPChartPieBase |
GetCenterPoint() const | CXTPChartPieBase |
GetFinishPoint() const | CXTPChartPieBase |
GetHalfAngle() const | CXTPChartPieBase |
GetHolePercent() const | CXTPChartPieBase |
GetStartAngle() const | CXTPChartPieBase |
GetStartPoint() const | CXTPChartPieBase |
m_anchorBounds | CXTPChartPieBase | protected
m_depth | CXTPChartPieBase | protected
m_dStartAngle | CXTPChartPieBase | protected
m_dSweepAngle | CXTPChartPieBase | protected
m_ellipse | CXTPChartPieBase | protected
m_nHolePercent | CXTPChartPieBase | protected
UpdateBounds() | CXTPChartPieBase | protected
~CXTPChartPieBase() | CXTPChartPieBase | virtual


Toolkit Pro: Member List

CXTPMarkupImage Member List

This is the complete list of members for CXTPMarkupImage, including all inherited members.

ApplyRenderTransform(CXTPMarkupDrawingContext *pContext) | CXTPMarkupUIElement | protectedvirtual
Arrange(CRect rcFinalRect) | CXTPMarkupUIElement |
ArrangeCore(CRect rcFinalRect) | CXTPMarkupUIElement | protectedvirtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPMarkupFrameworkElement() | CXTPMarkupFrameworkElement | protected
CXTPMarkupImage() | CXTPMarkupImage | protected
CXTPMarkupUIElement() | CXTPMarkupUIElement | protected
CXTPMarkupVisual() | CXTPMarkupVisual |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAbsoluteVisualOffset() const | CXTPMarkupVisual | protected
GetActualSize() const | CXTPMarkupFrameworkElement |
GetBoundRect() const | CXTPMarkupVisual |
GetClipToBounds() const | CXTPMarkupFrameworkElement |
GetDesiredSize() const | CXTPMarkupUIElement |
GetFinalRect() const | CXTPMarkupUIElement |
GetHeight() const | CXTPMarkupFrameworkElement |
GetHorizontalAlignment() const | CXTPMarkupFrameworkElement |
GetLayoutClip(CRect &rc) const | CXTPMarkupUIElement | protectedvirtual
GetLogicalChild(int nIndex) const | CXTPMarkupVisual | virtual
GetLogicalChildrenCount() const | CXTPMarkupVisual | virtual
GetMargin() const | CXTPMarkupFrameworkElement |
IXTPMarkupDeviceDependentImageSite::GetMarkupContext()=0 | IXTPMarkupDeviceDependentImageSite | privatepure virtual
GetMaxHeight() const | CXTPMarkupFrameworkElement |
GetMaxWidth() const | CXTPMarkupFrameworkElement |
GetMinHeight() const | CXTPMarkupFrameworkElement |
GetMinWidth() const | CXTPMarkupFrameworkElement |
GetOpacity() const | CXTPMarkupUIElement | protectedvirtual
GetOriginalSize() const | CXTPMarkupImage |
GetRenderSize() const | CXTPMarkupVisual |
GetRenderTransform() const | CXTPMarkupUIElement | protected
GetSource() | CXTPMarkupImage |
GetStretch() const | CXTPMarkupImage |
GetStyle() const | CXTPMarkupFrameworkElement |
GetTag() const | CXTPMarkupFrameworkElement |
GetUpdateRect() const | CXTPMarkupVisual |
GetVerticalAlignment() const | CXTPMarkupFrameworkElement |
GetVisibility() const | CXTPMarkupUIElement |
GetVisualChild(int nIndex) const | CXTPMarkupVisual | virtual
GetVisualChildrenCount() const | CXTPMarkupVisual | virtual
GetVisualOffset() const | CXTPMarkupVisual |
GetVisualParent() const | CXTPMarkupVisual |
GetWidth() const | CXTPMarkupFrameworkElement |
InputHitTest(CPoint point) const | CXTPMarkupVisual |
InputHitTestOverride(CPoint point) const | CXTPMarkupVisual | protectedvirtual
InvalidateArrange() | CXTPMarkupUIElement | virtual
InvalidateMeasure() | CXTPMarkupUIElement | virtual
InvalidateMeasureOverride(CXTPMarkupDrawingContext *pDC) | CXTPMarkupUIElement | protectedvirtual
InvalidateVisual() | CXTPMarkupUIElement | virtual
IsEnabled() const | CXTPMarkupUIElement |
IsFocusable() const | CXTPMarkupUIElement |
IsVisible() const | CXTPMarkupUIElement | virtual
m_bArrangeDirty | CXTPMarkupUIElement | protected
m_bArrangeInProgress | CXTPMarkupUIElement | protected
m_bMeasureDirty | CXTPMarkupUIElement | protected
m_bMeasureInProgress | CXTPMarkupUIElement | protected
m_bNeverArranged | CXTPMarkupUIElement | protected
m_bNeverMeasured | CXTPMarkupUIElement | protected
m_pClipToBoundsProperty | CXTPMarkupUIElement | static
m_pFocusableProperty | CXTPMarkupUIElement | static
m_pIsEnabledProperty | CXTPMarkupUIElement | static
m_pOpacityProperty | CXTPMarkupUIElement | static
m_pRenderTransformOriginProperty | CXTPMarkupUIElement | static
m_pRenderTransformProperty | CXTPMarkupUIElement | static
m_ptVisualOffset | CXTPMarkupVisual | protected
m_pVisibilityProperty | CXTPMarkupUIElement | static
m_rcBoundRect | CXTPMarkupVisual | protected
m_rcFinalRect | CXTPMarkupUIElement | protected
m_rcPrevUpdateRect | CXTPMarkupVisual | protected
m_rcUpdateRect | CXTPMarkupVisual | protected
m_szDesiredSize | CXTPMarkupUIElement | protected
m_szPreviousAvailableSize | CXTPMarkupUIElement | protected
m_szRenderSize | CXTPMarkupVisual | protected
Measure(CXTPMarkupDrawingContext *pDC, CSize szAvailableSize) | CXTPMarkupUIElement |
MeasureCore(CXTPMarkupDrawingContext *pDC, CSize szAvailableSize) | CXTPMarkupUIElement | protectedvirtual
OnRender(CXTPMarkupDrawingContext *drawingContext) | CXTPMarkupVisual | protectedvirtual
OnRenderFocusVisual(CXTPMarkupDrawingContext *drawingContext) | CXTPMarkupVisual | protectedvirtual
PtInRectTransform(const RECT &rect, const POINT &point) const | CXTPMarkupVisual | protected
Render(CXTPMarkupDrawingContext *drawingContext) | CXTPMarkupVisual |
RenderClipped(CXTPMarkupDrawingContext *drawingContext) | CXTPMarkupVisual | protectedvirtual
RestoreRenderTransform(CXTPMarkupDrawingContext *pContext, TransformationMatrices &matrices) | CXTPMarkupUIElement | protectedvirtual
SetClipToBounds(BOOL bClipToBounds) | CXTPMarkupFrameworkElement |
SetHeight(int nHeight) | CXTPMarkupFrameworkElement |
SetHorizontalAlignment(XTPMarkupHorizontalAlignment alignment) | CXTPMarkupFrameworkElement |
SetMargin(int nLeft, int nTop, int nRight, int nBottom) | CXTPMarkupFrameworkElement |
SetMargin(int nMargin) | CXTPMarkupFrameworkElement |
SetMaxHeight(int nHeight) | CXTPMarkupFrameworkElement |
SetMaxWidth(int nWidth) | CXTPMarkupFrameworkElement |
SetMinHeight(int nHeight) | CXTPMarkupFrameworkElement |
SetMinWidth(int nWidth) | CXTPMarkupFrameworkElement |
SetSource(LPCTSTR lpszSource) | CXTPMarkupImage |
SetStretch(XTPMarkupStretch stretch) | CXTPMarkupImage |
SetTag(CXTPMarkupObject *pTag) | CXTPMarkupFrameworkElement |
SetVerticalAlignment(XTPMarkupVerticalAlignment alignment) | CXTPMarkupFrameworkElement |
SetVisibility(XTPMarkupVisibility visibility) | CXTPMarkupUIElement |
SetWidth(int nWidth) | CXTPMarkupFrameworkElement |
~CXTPMarkupFrameworkElement() | CXTPMarkupFrameworkElement | protectedvirtual
~CXTPMarkupImage() | CXTPMarkupImage | protectedvirtual
~CXTPMarkupUIElement() | CXTPMarkupUIElement | protectedvirtual
~CXTPMarkupVisual() | CXTPMarkupVisual | virtual


Toolkit Pro: Member List

CXTPChartCandleStickSeriesStyle Member List

This is the complete list of members for CXTPChartCandleStickSeriesStyle, including all inherited members.

ApplyTo(CXTPChartDeviceCommand *pCommand) | CXTPChartSeriesStyle | virtual
CorrectAxisSideMargins(CXTPChartAxis *pAxis, double nMinValue, double nMaxValue, double &nCorrection) | CXTPChartSeriesStyle | virtual
CreateDiagram() | CXTPChartDiagram2DSeriesStyle | virtual
CreateView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView) | CXTPChartCandleStickSeriesStyle | protectedvirtual
CXTPChartCandleStickSeriesStyle() | CXTPChartCandleStickSeriesStyle |
CXTPChartDiagram2DSeriesStyle() | CXTPChartDiagram2DSeriesStyle |
CXTPChartElement() | CXTPChartElement |
CXTPChartHighLowSeriesStyle() | CXTPChartHighLowSeriesStyle |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartSeriesStyle() | CXTPChartSeriesStyle |
DoPropExchange(CXTPPropExchange *pPX) | CXTPChartDiagram2DSeriesStyle | virtual
Enable3dEdgeSmoothing(BOOL bEnable=TRUE) | CXTPChartSeriesStyle | virtual
Get3dRotation() const | CXTPChartSeriesStyle | virtual
GetAppearance() const | CXTPChartElement |
GetColor() const | CXTPChartSeriesStyle | virtual
GetContent() const | CXTPChartElement |
GetCustomDownColor() const | CXTPChartHighLowSeriesStyle |
GetCustomUpColor() const | CXTPChartHighLowSeriesStyle |
GetDownColor() const | CXTPChartHighLowSeriesStyle |
GetErrorBar() const | CXTPChartSeriesStyle | virtual
GetLabel() const | CXTPChartSeriesStyle | virtual
GetLineThickness() const | CXTPChartHighLowSeriesStyle |
GetOwner() const | CXTPChartElement |
GetSeriesPointValueIndex() const | CXTPChartSeriesStyle | virtual
GetStyleAppearance() const | CXTPChartSeriesStyle | virtual
GetTransparency() const | CXTPChartSeriesStyle | virtual
GetUpColor() const | CXTPChartHighLowSeriesStyle |
Is3D() const | CXTPChartObject |
Is3dEdgeSmoothingEnabled() const | CXTPChartSeriesStyle | virtual
IsColorEach() const | CXTPChartSeriesStyle | virtual
IsStyleDiagram(CXTPChartDiagram *pDiagram) const | CXTPChartDiagram2DSeriesStyle | virtual
m_bColorEach | CXTPChartSeriesStyle | protected
m_bSmooth3dEdges | CXTPChartSeriesStyle | protected
m_clrColor | CXTPChartSeriesStyle | protected
m_clrDownColor | CXTPChartHighLowSeriesStyle | protected
m_clrUpColor | CXTPChartHighLowSeriesStyle | protected
m_nAxisIndexX | CXTPChartDiagram2DSeriesStyle | protected
m_nAxisIndexY | CXTPChartDiagram2DSeriesStyle | protected
m_nLineThickness | CXTPChartHighLowSeriesStyle | protected
m_nTransparency | CXTPChartSeriesStyle | protected
m_pErrorBar | CXTPChartSeriesStyle | protected
m_pLabel | CXTPChartSeriesStyle | protected
m_Rotation3d | CXTPChartSeriesStyle | protected
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartElement | virtual
Release() | CXTPChartElement | virtual
Set3dRotation(const CXTPChart3dRotation &rotation) | CXTPChartSeriesStyle | virtual
Set3dRotation(double dYaw, double dPitch, double dRoll) | CXTPChartSeriesStyle | virtual
SetColor(CXTPChartColor clr) | CXTPChartSeriesStyle | virtual
SetColorEach(BOOL bColorEach) | CXTPChartSeriesStyle | virtual
SetErrorBar(CXTPChartErrorBar *pErrorBar) | CXTPChartSeriesStyle | virtual
SetLabel(CXTPChartSeriesLabel *pLabel) | CXTPChartSeriesStyle | virtual
SetLineThickness(int nLineThickness) | CXTPChartHighLowSeriesStyle |
SetTransparency(int nTransparency) | CXTPChartSeriesStyle | virtual
~CXTPChartCandleStickSeriesStyle() | CXTPChartCandleStickSeriesStyle | virtual
~CXTPChartDiagram2DSeriesStyle() | CXTPChartDiagram2DSeriesStyle | virtual
~CXTPChartElement() | CXTPChartElement | virtual
~CXTPChartHighLowSeriesStyle() | CXTPChartHighLowSeriesStyle | virtual
~CXTPChartSeriesStyle() | CXTPChartSeriesStyle | virtual


Toolkit Pro: Member List

CXTPFlowGraphPageHistoryItem Member List

This is the complete list of members for CXTPFlowGraphPageHistoryItem, including all inherited members.

pFrom | CXTPFlowGraphPageHistoryItem
pTo | CXTPFlowGraphPageHistoryItem


Toolkit Pro: Member List

CXTPComboBoxThemeVisualStudio2017 Member List

This is the complete list of members for CXTPComboBoxThemeVisualStudio2017, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPComboBoxTheme() | CXTPComboBoxTheme |
CXTPComboBoxThemeOffice2003() | CXTPComboBoxThemeOffice2003 |
CXTPComboBoxThemeOffice2013() | CXTPComboBoxThemeOffice2013 |
CXTPComboBoxThemeVisualStudio() | CXTPComboBoxThemeVisualStudio |
CXTPComboBoxThemeVisualStudio2017() | CXTPComboBoxThemeVisualStudio2017 |
CXTPControlTheme() | CXTPControlTheme |
DrawBackground(CDC *pDC, CXTPComboBox *pComboBox) | CXTPComboBoxThemeOffice2013 | virtual
DrawButton(CDC *pDC, CXTPComboBox *pComboBox, CRect rcBtn) | CXTPComboBoxThemeVisualStudio2017 | virtual
DrawButtonTriangle(CDC *pDC, CXTPComboBox *pComboBox, CRect rcBtn) | CXTPComboBoxThemeOffice2013 | virtual
DrawComboBox(CDC *pDC, CXTPComboBox *pComboBox) | CXTPComboBoxTheme | virtual
DrawFrame(HDC hdc, LPRECT lprc, int nSize, HBRUSH hBrush) | CXTPComboBoxTheme | virtual
FillSolidRect(HDC hdc, int x, int y, int cx, int cy, HBRUSH hBrush) | CXTPComboBoxTheme | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetBackColor() const | CXTPComboBoxTheme |
GetBackgroundBrush() const | CXTPComboBoxTheme |
GetTextColor() const | CXTPComboBoxTheme |
GetThemeStyle() const | CXTPControlTheme |
m_clrBackDisabled | CXTPComboBoxTheme |
m_clrBackground | CXTPComboBoxTheme |
m_clrBackHighlight | CXTPComboBoxTheme |
m_clrBorderDisabled | CXTPComboBoxTheme |
m_clrBorderHot | CXTPComboBoxTheme |
m_clrBorderNormal | CXTPComboBoxTheme |
m_clrButtonArrowDisabled | CXTPComboBoxThemeOffice2013 | protected
m_clrButtonArrowHot | CXTPComboBoxTheme |
m_clrButtonArrowNormal | CXTPComboBoxTheme |
m_clrButtonArrowPressed | CXTPComboBoxTheme |
m_clrButtonDisabled | CXTPComboBoxThemeOffice2013 | protected
m_clrButtonHot | CXTPComboBoxTheme |
m_clrButtonNormal | CXTPComboBoxTheme |
m_clrButtonPressed | CXTPComboBoxTheme |
m_clrText | CXTPComboBoxTheme |
m_clrTextDisabled | CXTPComboBoxTheme |
m_clrTextHighlight | CXTPComboBoxTheme |
m_grcButton | CXTPComboBoxTheme |
m_grcButtonHilite | CXTPComboBoxTheme |
m_grcButtonPushed | CXTPComboBoxTheme |
m_nTheme | CXTPControlTheme | protected
m_nThumbWidth | CXTPComboBoxTheme | protected
m_themeComboBox | CXTPComboBoxTheme | protected
m_xtpBrushBackground | CXTPComboBoxTheme | protected
RefreshMetrics(CXTPComboBox *pComboBox) | CXTPComboBoxThemeVisualStudio2017 | virtual
ResetBackColor() | CXTPComboBoxTheme |
ResetTextColor() | CXTPComboBoxTheme |
SetBackColor(COLORREF clrBackground) | CXTPComboBoxTheme |
SetTextColor(COLORREF clrText) | CXTPComboBoxTheme |
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static
UpdateBackgroundBrush() | CXTPComboBoxTheme | protected
~CXTPComboBoxTheme() | CXTPComboBoxTheme | virtual
~CXTPComboBoxThemeOffice2003() | CXTPComboBoxThemeOffice2003 | virtual
~CXTPComboBoxThemeOffice2013() | CXTPComboBoxThemeOffice2013 | virtual
~CXTPComboBoxThemeVisualStudio() | CXTPComboBoxThemeVisualStudio | virtual
~CXTPComboBoxThemeVisualStudio2017() | CXTPComboBoxThemeVisualStudio2017 | virtual


Toolkit Pro: Member List

CXTPEditThemeOfficeXP Member List

This is the complete list of members for CXTPEditThemeOfficeXP, including all inherited members.

AdjustBuddyRect(CWnd *pBuddy, CRect &rcUpDown, int nAlignment) | CXTPEditThemeOfficeXP | virtual
CtlColor(CDC *pDC, UINT nCtlColor, CXTPEdit *pEdit) | CXTPEditThemeDefault | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPControlTheme() | CXTPControlTheme |
CXTPEditTheme() | CXTPEditTheme |
CXTPEditThemeDefault() | CXTPEditThemeDefault |
CXTPEditThemeOffice2000() | CXTPEditThemeOffice2000 |
CXTPEditThemeOfficeXP() | CXTPEditThemeOfficeXP |
DrawBuddyBorders(CWnd *pBuddy, CDC *pDC, CRect rc, int nAlignment, CXTPEdit *pEdit) | CXTPEditThemeOfficeXP | virtual
CXTPEditThemeOffice2000::DrawBuddyBorders(CDC *pDC, CRect rc, int nAlignment, CXTPEdit *pEdit) | CXTPEditThemeOffice2000 | virtual
DrawFrame(CDC *pDC, CRect rc, int nSize, CBrush *pBrush) | CXTPEditTheme | virtual
DrawNcBorders(CDC *pDC, CRect rcWnd, CXTPEdit *pEdit) | CXTPEditThemeOfficeXP | virtual
DrawNcBordersDefault(CDC *pDC, CRect rcWnd, CXTPEdit *pEdit) | CXTPEditThemeDefault | protectedvirtual
DrawNcScrollBack(CDC *pDC, CRect rcWnd, CXTPEdit *pEdit) | CXTPEditThemeDefault | virtual
FillRect(CDC *pDC, int x, int y, int cx, int cy, CBrush *pBrush) | CXTPEditTheme | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetClientBrush(CDC *pDC, CXTPEdit *pEdit) | CXTPEditTheme | virtual
GetThemeID() const | CXTPEditTheme |
GetThemeStyle() const | CXTPControlTheme |
IsFlatStyle() const | CXTPEditTheme |
m_bFlatStyle | CXTPEditTheme | protected
m_bUseWinTheme | CXTPEditTheme | protected
m_clrBack | CXTPEditTheme |
m_clrBackNonClient | CXTPEditTheme |
m_clrBorder | CXTPEditTheme |
m_clrBorderDisabled | CXTPEditThemeOfficeXP | protected
m_clrBorderHilite | CXTPEditThemeOfficeXP | protected
m_clrText | CXTPEditTheme |
m_clrTextReadOnly | CXTPEditTheme |
m_nTheme | CXTPEditTheme | protected
m_winTheme | CXTPEditTheme | protected
m_xtpBrushBack | CXTPEditTheme |
RedrawFocusedFrame() const | CXTPEditThemeOfficeXP | virtual
RefreshMetrics(CXTPEdit *pEdit) | CXTPEditThemeOfficeXP | virtual
SetFlatStyle(BOOL bFlatStyle) | CXTPEditTheme |
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static
UseWinTheme(BOOL bUseWinTheme) | CXTPEditTheme |
~CXTPEditTheme() | CXTPEditTheme | virtual
~CXTPEditThemeDefault() | CXTPEditThemeDefault | virtual
~CXTPEditThemeOffice2000() | CXTPEditThemeOffice2000 | virtual
~CXTPEditThemeOfficeXP() | CXTPEditThemeOfficeXP | virtual


Toolkit Pro: Member List

CXTPScrollBarPaintManager Member List

This is the complete list of members for CXTPScrollBarPaintManager, including all inherited members.

CalcHScroll(CXTPScrollBase *pScroll, XTPScrollMetricsH *pHScroll) | CXTPScrollBarPaintManager | protectedstatic
CalcVScroll(CXTPScrollBase *pScroll, XTPScrollMetricsV *pVScroll) | CXTPScrollBarPaintManager | protectedstatic
CXTPScrollBarPaintManager() | CXTPScrollBarPaintManager |
DrawArrowGlyph(CDC *pDC, CRect rcArrow, XTPArrowGlyph glyph, BOOL bEnabled, COLORREF clrText=COLORREF_NULL) | CXTPScrollBarPaintManager | protected
DrawArrows(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics) | CXTPScrollBarPaintManager | protectedvirtual
DrawArrows(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics) | CXTPScrollBarPaintManager | protectedvirtual
DrawBackground(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics) | CXTPScrollBarPaintManager | protectedvirtual
DrawBackground(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics) | CXTPScrollBarPaintManager | protectedvirtual
DrawButtons(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics) | CXTPScrollBarPaintManager | protectedvirtual
DrawButtons(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics) | CXTPScrollBarPaintManager | protectedvirtual
DrawGripper(CDC *pDC, CXTPScrollBase *pScroll) | CXTPScrollBarPaintManager | protectedvirtual
DrawScrollBar(CDC *pDC, CXTPScrollBase *pScrollBar) | CXTPScrollBarPaintManager | virtual
DrawThumbButton(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics) | CXTPScrollBarPaintManager | protectedvirtual
DrawThumbButton(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics) | CXTPScrollBarPaintManager | protectedvirtual
DrawTracker(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics) | CXTPScrollBarPaintManager | protectedvirtual
DrawTracker(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics) | CXTPScrollBarPaintManager | protectedvirtual
m_crBack | CXTPScrollBarPaintManager |
m_crBackHilite | CXTPScrollBarPaintManager |
m_crBackPushed | CXTPScrollBarPaintManager |
m_crBorder | CXTPScrollBarPaintManager |
m_crBorderHilite | CXTPScrollBarPaintManager |
m_cThumb | CXTPScrollBarPaintManager |
m_cxHScroll | CXTPScrollBarPaintManager |
m_cxVScroll | CXTPScrollBarPaintManager |
m_cyHScroll | CXTPScrollBarPaintManager |
m_cyVScroll | CXTPScrollBarPaintManager |
RefreshMetrics() | CXTPScrollBarPaintManager | virtual


Toolkit Pro: Member List

CXTPComboBoxThemeVisualStudio2012 Member List

This is the complete list of members for CXTPComboBoxThemeVisualStudio2012, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPComboBoxTheme() | CXTPComboBoxTheme |
CXTPComboBoxThemeOffice2003() | CXTPComboBoxThemeOffice2003 |
CXTPComboBoxThemeVisualStudio() | CXTPComboBoxThemeVisualStudio |
CXTPComboBoxThemeVisualStudio2012(BOOL bLight) | CXTPComboBoxThemeVisualStudio2012 |
CXTPControlTheme() | CXTPControlTheme |
DrawBackground(CDC *pDC, CXTPComboBox *pComboBox) | CXTPComboBoxThemeOffice2003 | virtual
DrawButton(CDC *pDC, CXTPComboBox *pComboBox, CRect rcBtn) | CXTPComboBoxThemeVisualStudio2012 | virtual
DrawButtonTriangle(CDC *pDC, CXTPComboBox *pComboBox, CRect rcBtn) | CXTPComboBoxTheme | virtual
DrawComboBox(CDC *pDC, CXTPComboBox *pComboBox) | CXTPComboBoxTheme | virtual
DrawFrame(HDC hdc, LPRECT lprc, int nSize, HBRUSH hBrush) | CXTPComboBoxTheme | virtual
FillSolidRect(HDC hdc, int x, int y, int cx, int cy, HBRUSH hBrush) | CXTPComboBoxTheme | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetBackColor() const | CXTPComboBoxTheme |
GetBackgroundBrush() const | CXTPComboBoxTheme |
GetTextColor() const | CXTPComboBoxTheme |
GetThemeStyle() const | CXTPControlTheme |
m_clrBackDisabled | CXTPComboBoxTheme |
m_clrBackground | CXTPComboBoxTheme |
m_clrBackHighlight | CXTPComboBoxTheme |
m_clrBorderDisabled | CXTPComboBoxTheme |
m_clrBorderHot | CXTPComboBoxTheme |
m_clrBorderNormal | CXTPComboBoxTheme |
m_clrButtonArrowHot | CXTPComboBoxTheme |
m_clrButtonArrowNormal | CXTPComboBoxTheme |
m_clrButtonArrowPressed | CXTPComboBoxTheme |
m_clrButtonHot | CXTPComboBoxTheme |
m_clrButtonNormal | CXTPComboBoxTheme |
m_clrButtonPressed | CXTPComboBoxTheme |
m_clrText | CXTPComboBoxTheme |
m_clrTextDisabled | CXTPComboBoxTheme |
m_clrTextHighlight | CXTPComboBoxTheme |
m_grcButton | CXTPComboBoxTheme |
m_grcButtonHilite | CXTPComboBoxTheme |
m_grcButtonPushed | CXTPComboBoxTheme |
m_nTheme | CXTPControlTheme | protected
m_nThumbWidth | CXTPComboBoxTheme | protected
m_themeComboBox | CXTPComboBoxTheme | protected
m_xtpBrushBackground | CXTPComboBoxTheme | protected
RefreshMetrics(CXTPComboBox *pComboBox) | CXTPComboBoxThemeVisualStudio2012 | virtual
ResetBackColor() | CXTPComboBoxTheme |
ResetTextColor() | CXTPComboBoxTheme |
SetBackColor(COLORREF clrBackground) | CXTPComboBoxTheme |
SetTextColor(COLORREF clrText) | CXTPComboBoxTheme |
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static
UpdateBackgroundBrush() | CXTPComboBoxTheme | protected
~CXTPComboBoxTheme() | CXTPComboBoxTheme | virtual
~CXTPComboBoxThemeOffice2003() | CXTPComboBoxThemeOffice2003 | virtual
~CXTPComboBoxThemeVisualStudio() | CXTPComboBoxThemeVisualStudio | virtual
~CXTPComboBoxThemeVisualStudio2012() | CXTPComboBoxThemeVisualStudio2012 | virtual


Toolkit Pro: XTPRibbonBackstageMenuSeparator.h Source File

  • Source
  • Ribbon
  • Backstage
XTPRibbonBackstageMenuSeparator.h
Go to the documentation of this file.
1
23#if !defined(__XTPRIBBONBACKSTAGESPACE_H__)
24# define __XTPRIBBONBACKSTAGESPACE_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class _XTP_EXT_CLASS CXTPRibbonBackstageMenuSeparator : public CXTPControl
34{
36 DECLARE_XTP_CONTROL(CXTPRibbonBackstageMenuSeparator)
38protected:
39 CXTPRibbonBackstageMenuSeparator();
40
41protected:
42# ifdef _XTP_COMMANDBARS_ACTIVEX
45 DECLARE_DISPATCH_MAP()
46 DECLARE_INTERFACE_MAP()
47 DECLARE_OLETYPELIB_EX(CXTPRibbonBackstageMenuSeparator);
48
50# endif
51 friend class CXTPRibbonBackstageView;
52};
53
54# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
56#endif // !defined(__XTPRIBBONBACKSTAGESPACE_H__)
DECLARE_XTP_CONTROL
#define DECLARE_XTP_CONTROL(class_name)
This macro generates the C++ header code necessary for a CXTPControl-derived class that can be serial...
Definition XTPCommandBarsDefines.h:1169
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPControl
CXTPControl is a CXTPCmdTarget derived class.
Definition XTPControl.h:841
CXTPRibbonBackstageView
CXTPRibbonBackstageView is a CDialog derived class used for a Backstage parent frame.
Definition XTPRibbonBackstageView.h:87


Toolkit Pro: XTPDockingPaneThemeVisualStudio2019.h Source File

  • Source
  • DockingPane
  • Themes
XTPDockingPaneThemeVisualStudio2019.h
Go to the documentation of this file.
1
23#if !defined(__XTPDOCKINGPANETHEMEVISUALSTUDIO2019_H__)
24# define __XTPDOCKINGPANETHEMEVISUALSTUDIO2019_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPDockingPaneVisualStudio2019Theme
39 : public CXTPDockingPaneVisualStudio2012Theme
40{
41public:
46 CXTPDockingPaneVisualStudio2019Theme();
47
53 virtual ~CXTPDockingPaneVisualStudio2019Theme();
54
60 virtual void RefreshMetrics();
61
68 virtual void DrawSplitter(CDC* pDC, CXTPDockingPaneSplitterWnd* pSplitter);
69
79 virtual void DrawAutoHidePanel(CDC* pDC, CRect rc, XTPDockingPaneDirection direction);
80
81protected:
91 virtual void DrawTitleBar(CDC* pDC, CXTPDockingPaneBase* pPane, CRect rc, BOOL bVertical);
92
93 COLORREF m_clrCaptionBorder;
94};
95
96# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
98#endif // !defined(__XTPDOCKINGPANETHEMEVISUALSTUDIO2019_H__)
XTPDisableNoisyWarnings.h
XTPDockingPaneDirection
XTPDockingPaneDirection
Docking direction enumeration.
Definition XTPDockingPaneDefines.h:51
XTPEnableNoisyWarnings.h
CXTPDockingPaneBase
CXTPDockingPaneBase is a standalone class.
Definition XTPDockingPaneBase.h:69
CXTPDockingPaneSplitterWnd
CXTPDockingPaneSplitterWnd is a CWnd derived class.
Definition XTPDockingPaneSplitterContainer.h:42
CXTPDockingPaneVisualStudio2012Theme
CXTPDockingPaneVisualStudio2012Theme is used to define drawing routines specific to a Visual Studio 2...
Definition XTPDockingPaneThemeVisualStudio2012.h:41
CXTPDockingPaneVisualStudio2019Theme
CXTPDockingPaneVisualStudio2019Theme is used to define drawing routines specific to a Visual Studio 2...
Definition XTPDockingPaneThemeVisualStudio2019.h:40
CXTPDockingPaneVisualStudio2019Theme::CXTPDockingPaneVisualStudio2019Theme
CXTPDockingPaneVisualStudio2019Theme()
Constructs a CXTPDockingPaneVisualStudio2019Theme object.
CXTPDockingPaneVisualStudio2019Theme::~CXTPDockingPaneVisualStudio2019Theme
virtual ~CXTPDockingPaneVisualStudio2019Theme()
Destroys a CXTPDockingPaneVisualStudio2019Theme object, handles cleanup and deallocation.
CXTPDockingPaneVisualStudio2019Theme::DrawTitleBar
virtual void DrawTitleBar(CDC *pDC, CXTPDockingPaneBase *pPane, CRect rc, BOOL bVertical)
This member function is called to draw a title bar for the docking pane.
CXTPDockingPaneVisualStudio2019Theme::DrawSplitter
virtual void DrawSplitter(CDC *pDC, CXTPDockingPaneSplitterWnd *pSplitter)
Override this method to draw a splitter.
CXTPDockingPaneVisualStudio2019Theme::DrawAutoHidePanel
virtual void DrawAutoHidePanel(CDC *pDC, CRect rc, XTPDockingPaneDirection direction)
This method is called by the framework to draw the docking pane auto-hide panel background and splitt...
CXTPDockingPaneVisualStudio2019Theme::RefreshMetrics
virtual void RefreshMetrics()
This member function is used to initialize default colors for a theme from an .INI resource.
CXTPDockingPaneVisualStudio2019Theme::m_clrCaptionBorder
COLORREF m_clrCaptionBorder
Caption border color.
Definition XTPDockingPaneThemeVisualStudio2019.h:93


Toolkit Pro: Member List

CXTPControlGalleryNativeWindows11Theme Member List

This is the complete list of members for CXTPControlGalleryNativeWindows11Theme, including all inherited members.

CXTPControlGalleryNativeWindows11Theme(CXTPPaintManager *pPaintManager) | CXTPControlGalleryNativeWindows11Theme |
CXTPControlGalleryOffice2013Theme(CXTPPaintManager *pPaintManager) | CXTPControlGalleryOffice2013Theme |
CXTPControlGalleryPaintManager(CXTPPaintManager *pPaintManager) | CXTPControlGalleryPaintManager |
DrawLabel(CDC *pDC, CXTPControlGalleryItem *pLabel, CRect rc) | CXTPControlGalleryPaintManager | virtual
DrawPopupScrollBar(CDC *pDC, CXTPControlGallery *pGallery) | CXTPControlGalleryOffice2013Theme | virtual
FillControl(CDC *pDC, CXTPControlGallery *pGallery, CRect rc) | CXTPControlGalleryOffice2013Theme | protectedvirtual
m_cxPopup | CXTPControlGalleryPaintManager |
m_cyPopupDown | CXTPControlGalleryPaintManager |
m_cyPopupUp | CXTPControlGalleryPaintManager |
RefreshMetrics() | CXTPControlGalleryOffice2013Theme | virtual


Toolkit Pro: XTPDockingPaneKeyboardHook.h Source File

  • Source
  • DockingPane
XTPDockingPaneKeyboardHook.h
Go to the documentation of this file.
1
23#if !defined(__XTPDOCKINGPANEKEYBOARDHOOK_H__)
24# define __XTPDOCKINGPANEKEYBOARDHOOK_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPDockingPane;
34class CXTPDockingPaneManager;
35
41class _XTP_EXT_CLASS CXTPDockingPaneWindowSelect : public CMiniFrameWnd
42{
44 DECLARE_DYNCREATE(CXTPDockingPaneWindowSelect)
46public:
51 enum ItemType
52 {
53 itemPane,
54 itemMDIFrame,
55 itemSDIFrame
56 };
57
62 struct CItem
63 {
64 CRect rc;
66 union {
67 CXTPDockingPane* pPane;
68 HWND hWndFrame;
69 };
70
71 int nIndex;
72 int nColumn;
73 int nRow;
74 ItemType type;
75 };
76
81 struct CColumn
82 {
83 int nFirst;
84 int nLast;
85 };
86
87protected:
92 CXTPDockingPaneWindowSelect();
93
94public:
99 virtual ~CXTPDockingPaneWindowSelect();
100
101public:
111 CItem* HitTest(CPoint pt) const;
112
118 void Select(CItem* pItem);
119
125 void Select(int nItem);
126
127public:
135 virtual CString GetItemCaption(CItem* pItem) const;
136
144 virtual CString GetItemDescription(CItem* pItem) const;
145
153 virtual CString GetItemPath(CItem* pItem) const;
154
155public:
162 virtual BOOL Reposition();
163
164protected:
166 DECLARE_MESSAGE_MAP()
167
168 //{{AFX_VIRTUAL(CXTPDockingPaneWindowSelect)
169protected:
170 virtual void PostNcDestroy();
171 //}}AFX_VIRTUAL
172
173 //{{AFX_MSG(CXTPDockingPaneWindowSelect)
174public:
175 afx_msg void OnKillFocus(CWnd* pNewWnd);
176 afx_msg void OnCaptureChanged(CWnd* pWnd);
177 afx_msg void OnPaint();
178 afx_msg void OnKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags);
179 afx_msg void OnSysKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags);
180 afx_msg void OnKeyUp(UINT nChar, UINT nRepCnt, UINT nFlags);
181 afx_msg void OnLButtonDown(UINT nFlags, CPoint point);
182 afx_msg void OnLButtonUp(UINT nFlags, CPoint point);
183 afx_msg void OnMouseMove(UINT nFlags, CPoint point);
184 afx_msg void OnChar(UINT nChar, UINT nRepCnt, UINT nFlags);
185 //}}AFX_MSG
188private:
189 int CalcItemHeight(CDC* pDC);
190 BOOL DoModal();
191 HWND GetMDIClient() const;
192 void FillItems(HWND hWndClient, int& nItemHeight, int& nItemWidth, int& x, int& y, int& nRow,
193 int& nColumn, int& nTotalRow, int& nFirstColumn);
194
195private:
196 CXTPDockingPaneManager* m_pManager;
197 CArray<CItem*, CItem*> m_arrItems;
198 CArray<CColumn, CColumn&> m_arrColumns;
199 CItem* m_pSelected;
200 HCURSOR m_hHandCursor;
201 HCURSOR m_hArrowCursor;
202 int m_nFirstFile;
203 int m_nPaneCount;
205 CString m_strActiveTools;
206 CString m_strActiveFiles;
208 CXTPFont m_fnt;
209 CXTPFont m_fntBold;
210 BOOL m_bActivatePanes;
212 friend class CXTPDockingPaneKeyboardHook;
213};
214
217class _XTP_EXT_CLASS CXTPDockingPaneKeyboardHook : public CNoTrackObject
218{
219public:
220 CXTPDockingPaneKeyboardHook();
221 ~CXTPDockingPaneKeyboardHook();
222
223public:
224 void SetupKeyboardHook(CXTPDockingPaneManager* pManager, BOOL bSetup);
225 CXTPDockingPaneManager* FindFocusedManager();
226
227 static CXTPDockingPaneKeyboardHook* AFX_CDECL GetThreadState();
228
229protected:
230 static LRESULT CALLBACK KeyboardProc(int code, WPARAM wParam, LPARAM lParam);
231
232 CXTPDockingPaneManager* Lookup(HWND hSite) const;
233
234protected:
235 HHOOK m_hHookKeyboard;
237 static CThreadLocal<CXTPDockingPaneKeyboardHook> _xtpKeyboardThreadState;
240 CMap<HWND, HWND, CXTPDockingPaneManager*, CXTPDockingPaneManager*> m_mapSites;
241# ifdef _AFXDLL
242 AFX_MODULE_STATE* m_pModuleState;
243# endif
244
245 CXTPDockingPaneWindowSelect* m_pWindowSelect;
246};
247
248AFX_INLINE CXTPDockingPaneKeyboardHook* AFX_CDECL CXTPDockingPaneKeyboardHook::GetThreadState()
249{
250 return _xtpKeyboardThreadState.GetData();
251}
252
255# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
256#endif //#if !defined(__XTPDOCKINGPANEKEYBOARDHOOK_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPDockingPane
CXTPDockingPane is a CXTPDockingPaneBase derived class.
Definition XTPDockingPane.h:44
CXTPDockingPaneManager
CXTPDockingPaneManager is a CWnd derived class.
Definition XTPDockingPaneManager.h:58
CXTPDockingPaneWindowSelect
CXTPDockingPaneWindowSelect is a CMiniFrameWnd derived class used to show a window selector for Ctrl+...
Definition XTPDockingPaneKeyboardHook.h:42
CXTPDockingPaneWindowSelect::CXTPDockingPaneWindowSelect
CXTPDockingPaneWindowSelect()
Constructs a CXTPDockingPaneWindowSelect object.
CXTPDockingPaneWindowSelect::GetItemDescription
virtual CString GetItemDescription(CItem *pItem) const
This method is called to retrieve an item's description.
CXTPDockingPaneWindowSelect::ItemType
ItemType
Item type enumeration.
Definition XTPDockingPaneKeyboardHook.h:52
CXTPDockingPaneWindowSelect::itemMDIFrame
@ itemMDIFrame
Item is a handle of a MDI child.
Definition XTPDockingPaneKeyboardHook.h:54
CXTPDockingPaneWindowSelect::itemPane
@ itemPane
Item is a docking pane.
Definition XTPDockingPaneKeyboardHook.h:53
CXTPDockingPaneWindowSelect::HitTest
CItem * HitTest(CPoint pt) const
Call this method to determine which item, if any, is at the specified position.
CXTPDockingPaneWindowSelect::GetItemPath
virtual CString GetItemPath(CItem *pItem) const
This method is called to retrieve an item's path string.
CXTPDockingPaneWindowSelect::Select
void Select(int nItem)
Call this method to select an item by its index.
CXTPDockingPaneWindowSelect::~CXTPDockingPaneWindowSelect
virtual ~CXTPDockingPaneWindowSelect()
Destroys a CXTPDockingPaneMiniWnd object, handles cleanup and deallocation.
CXTPDockingPaneWindowSelect::Reposition
virtual BOOL Reposition()
This method is called to update the position of all items inside the dialog.
CXTPDockingPaneWindowSelect::GetItemCaption
virtual CString GetItemCaption(CItem *pItem) const
This method is called to retrieve an item's caption.
CXTPDockingPaneWindowSelect::Select
void Select(CItem *pItem)
Call this method to select a specified item.
CXTPFont
Provides a convenient object oriented interface for HFONT GDI object and uses GDI handle caching.
Definition XTPGdiObjects.h:414
CXTPDockingPaneWindowSelect::CColumn
Column description.
Definition XTPDockingPaneKeyboardHook.h:82
CXTPDockingPaneWindowSelect::CItem
Item description.
Definition XTPDockingPaneKeyboardHook.h:63
CXTPDockingPaneWindowSelect::CItem::nRow
int nRow
Row of the item.
Definition XTPDockingPaneKeyboardHook.h:73
CXTPDockingPaneWindowSelect::CItem::nIndex
int nIndex
Index of the item.
Definition XTPDockingPaneKeyboardHook.h:71
CXTPDockingPaneWindowSelect::CItem::nColumn
int nColumn
Column of the index.
Definition XTPDockingPaneKeyboardHook.h:72
CXTPDockingPaneWindowSelect::CItem::type
ItemType type
Item type.
Definition XTPDockingPaneKeyboardHook.h:74
CXTPDockingPaneWindowSelect::CItem::rc
CRect rc
Item bounding rectangle.
Definition XTPDockingPaneKeyboardHook.h:64


Toolkit Pro: XTPChartRadarSplineAreaSeriesStyle.h Source File

  • Source
  • Chart
  • Styles
  • Radar
XTPChartRadarSplineAreaSeriesStyle.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTRADARSPLINEAREASERIESSTYLE_H__)
24# define __XTPCHARTRADARSPLINEAREASERIESSTYLE_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartSeriesView;
34class CXTPChartBorder;
35class CXTPChartFillStyle;
36
47class _XTP_EXT_CLASS CXTPChartRadarSplineAreaSeriesStyle : public CXTPChartRadarAreaSeriesStyle
48{
50 DECLARE_SERIAL(CXTPChartRadarSplineAreaSeriesStyle)
52public:
57 CXTPChartRadarSplineAreaSeriesStyle();
58
63 virtual ~CXTPChartRadarSplineAreaSeriesStyle();
64
65protected:
80 virtual CXTPChartSeriesView* CreateView(CXTPChartSeries* pSeries,
81 CXTPChartDiagramView* pDiagramView);
82
83# ifdef _XTP_ACTIVEX
84public:
86 DECLARE_DISPATCH_MAP()
87 DECLARE_INTERFACE_MAP()
88 DECLARE_OLETYPELIB_EX(CXTPChartRadarSplineAreaSeriesStyle);
89 DECLARE_OLECREATE_EX(CXTPChartRadarSplineAreaSeriesStyle)
91# endif
92
93protected:
94};
95
106class _XTP_EXT_CLASS CXTPChartRadarSplineAreaSeriesView : public CXTPChartRadarAreaSeriesView
107{
108public:
116 CXTPChartRadarSplineAreaSeriesView(CXTPChartSeries* pSeries,
117 CXTPChartDiagramView* pDiagramView);
118
119protected:
134 CXTPChartSeriesPointView* CreateSeriesPointView(CXTPChartDeviceContext* pDC,
135 CXTPChartSeriesPoint* pPoint,
136 CXTPChartElementView* pParentView);
137
150 virtual CXTPChartDeviceCommand* CreateDeviceCommand(CXTPChartDeviceContext* pDC);
151};
153# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
154#endif //#if !defined(__XTPCHARTRADARSPLINEAREASERIESSTYLE_H__)
pPoint
const CPoint * pPoint
return 0 or xtpCalendarHitTestDayExpandButton
Definition XTPCalendarThemeOffice2007.h:150
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartBorder
This class abstracts the border of a chart, it is a kind of chart element.
Definition XTPChartBorder.h:42
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartDiagramView
This class represents the view of a chart diagram, which is a kind of CXTPChartElementView.
Definition XTPChartDiagramView.h:49
CXTPChartElementView
This class represents the view of a chart element.
Definition XTPChartElementView.h:47
CXTPChartFillStyle
This class abstracts a fill style used to fill the background of various chart elements.
Definition XTPChartFillStyle.h:43
CXTPChartRadarAreaSeriesStyle
This class represents a line series style, which is a kind of CXTPChartSeriesStyle.
Definition XTPChartRadarAreaSeriesStyle.h:48
CXTPChartRadarAreaSeriesView
This class represents the view of a point series, which is a kind of CXTPChartSeriesView.
Definition XTPChartRadarAreaSeriesView.h:42
CXTPChartRadarSplineAreaSeriesStyle
This class represents a spline area series style, which is a kind of CXTPChartRadarAreaSeriesStyle.
Definition XTPChartRadarSplineAreaSeriesStyle.h:48
CXTPChartRadarSplineAreaSeriesStyle::CreateView
virtual CXTPChartSeriesView * CreateView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Use this function to create a spline area series view object.
CXTPChartRadarSplineAreaSeriesStyle::~CXTPChartRadarSplineAreaSeriesStyle
virtual ~CXTPChartRadarSplineAreaSeriesStyle()
Destroys a CXTPChartRadarSplineAreaSeriesStyle object, handles cleanup.
CXTPChartRadarSplineAreaSeriesStyle::CXTPChartRadarSplineAreaSeriesStyle
CXTPChartRadarSplineAreaSeriesStyle()
Constructs a CXTPChartRadarSplineAreaSeriesStyle object.
CXTPChartRadarSplineAreaSeriesView
CXTPChartRadarSplineAreaSeriesView is a kind of CXTPChartSeriesView.
Definition XTPChartRadarSplineAreaSeriesStyle.h:107
CXTPChartRadarSplineAreaSeriesView::CXTPChartRadarSplineAreaSeriesView
CXTPChartRadarSplineAreaSeriesView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Constructs a CXTPChartRadarSplineAreaSeriesView object.
CXTPChartRadarSplineAreaSeriesView::CreateDeviceCommand
virtual CXTPChartDeviceCommand * CreateDeviceCommand(CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
CXTPChartRadarSplineAreaSeriesView::CreateSeriesPointView
CXTPChartSeriesPointView * CreateSeriesPointView(CXTPChartDeviceContext *pDC, CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Call this function to create a spline area series point view object.
CXTPChartSeries
This class represents a series in the chart, which is a kind of CXTPChartElement.
Definition XTPChartSeries.h:50
CXTPChartSeriesPoint
CXTPChartSeriesPoint is a kind of CXTPChartElement.
Definition XTPChartSeriesPoint.h:43
CXTPChartSeriesPointView
Represents chart series point view.
Definition XTPChartSeriesPointView.h:48


Toolkit Pro: Member List

CXTPCalendarReminderForOccurrenceArray Member List

This is the complete list of members for CXTPCalendarReminderForOccurrenceArray, including all inherited members.

ClearProperties(CXTPCalendarCustomProperties *pProps) | CXTPCalendarReminderForOccurrenceArray | static
CXTPCalendarReminderForOccurrenceArray() | CXTPCalendarReminderForOccurrenceArray |
Find(CXTPCalendarEvent *pOccEvent) const | CXTPCalendarReminderForOccurrenceArray |
Find(DATE dtOccStartTime, DATE dtOccEndTime) const | CXTPCalendarReminderForOccurrenceArray |
Load(CXTPCalendarCustomProperties *pProps) | CXTPCalendarReminderForOccurrenceArray |
Save(CXTPCalendarCustomProperties *pProps, CXTPCalendarRecurrencePattern *pPattern) | CXTPCalendarReminderForOccurrenceArray |
UpdateOccIfNeed(CXTPCalendarEvent *pOccEvent, CXTPCalendarRecurrencePattern *pPattern) | CXTPCalendarReminderForOccurrenceArray |
UpdateOccIfNeedEx(CXTPCalendarEvent *pOccEvent, const CXTPCalendarReminderForOccurrence *pOccRmdData, CXTPCalendarRecurrencePattern *pPattern) | CXTPCalendarReminderForOccurrenceArray | static
~CXTPCalendarReminderForOccurrenceArray() | CXTPCalendarReminderForOccurrenceArray | virtual


Toolkit Pro: XTPSyntaxEditUndoManager.h Source File

  • Source
  • SyntaxEdit
XTPSyntaxEditUndoManager.h
Go to the documentation of this file.
1
23#if !defined(__XTPSYNTAXEDITUNDOMANAGER_H__)
24# define __XTPSYNTAXEDITUNDOMANAGER_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPSyntaxEditBufferManager;
34class CXTPSyntaxEditCtrl;
35
47class _XTP_EXT_CLASS CXTPSyntaxEditCommand : public CObject
48{
50 DECLARE_DYNAMIC(CXTPSyntaxEditCommand)
52public:
58 virtual ~CXTPSyntaxEditCommand();
59
73 virtual int Execute(XTP_EDIT_LINECOL& lcFrom, XTP_EDIT_LINECOL& lcTo,
74 CXTPSyntaxEditCtrl* pEditCtrl) = 0;
75
89 virtual int UnExecute(XTP_EDIT_LINECOL& lcFrom, XTP_EDIT_LINECOL& lcTo,
90 CXTPSyntaxEditCtrl* pEditCtrl) = 0;
91
107 virtual LPCTSTR GetCommandText() const;
108
123 virtual void SetCommandText(LPCTSTR szText);
124
131 virtual int GetDataSize() const;
132
133protected:
139 CXTPSyntaxEditCommand();
140
150 static void AFX_CDECL SetPositionInternally(CXTPSyntaxEditCtrl* pEditCtrl,
151 const XTP_EDIT_LINECOL& lcPos);
152
153 CString m_strCommandText;
154};
155
156AFX_INLINE void CXTPSyntaxEditCommand::SetCommandText(LPCTSTR szText)
157{
158 m_strCommandText = szText;
159}
160AFX_INLINE LPCTSTR CXTPSyntaxEditCommand::GetCommandText() const
161{
162 return m_strCommandText;
163}
164AFX_INLINE int CXTPSyntaxEditCommand::GetDataSize() const
165{
166 return 0;
167}
176class _XTP_EXT_CLASS CXTPSyntaxEditBatchCommand : public CXTPSyntaxEditCommand
177{
179 DECLARE_DYNAMIC(CXTPSyntaxEditBatchCommand)
181public:
182 CXTPSyntaxEditBatchCommand();
183
190 ~CXTPSyntaxEditBatchCommand();
191
205 virtual int Execute(XTP_EDIT_LINECOL& lcFrom, XTP_EDIT_LINECOL& lcTo,
206 CXTPSyntaxEditCtrl* pEditCtrl);
207
221 virtual int UnExecute(XTP_EDIT_LINECOL& lcFrom, XTP_EDIT_LINECOL& lcTo,
222 CXTPSyntaxEditCtrl* pEditCtrl);
223
234 POSITION AddCommand(CXTPSyntaxEditCommand* pCommand);
235
244 int GetCommandsCount();
245
252 virtual int GetDataSize() const;
253
254protected:
259 void Clear();
260
261 CPtrList m_CommandList;
262};
263
273class _XTP_EXT_CLASS CXTPSyntaxEditBufferCommand : public CXTPSyntaxEditCommand
274{
276 DECLARE_DYNAMIC(CXTPSyntaxEditBufferCommand)
278public:
284 virtual ~CXTPSyntaxEditBufferCommand();
285
286protected:
296 CXTPSyntaxEditBufferCommand(CXTPSyntaxEditBufferManager* pMgr, LPCTSTR szText,
297 const XTP_EDIT_LINECOL& lcFrom, const XTP_EDIT_LINECOL& lcTo);
298
299 CXTPSyntaxEditBufferManager* m_pBufferMgr;
314 class CXTPSyntaxEditBufferKeepOverwriteSettings
315 {
316 public:
322 CXTPSyntaxEditBufferKeepOverwriteSettings(CXTPSyntaxEditBufferManager* pBufferMgr);
323
328 virtual ~CXTPSyntaxEditBufferKeepOverwriteSettings();
329
330 private:
331 CXTPSyntaxEditBufferManager* m_pBufMgr;
332 BOOL m_bOldSettings;
333 };
334
349 int DoInsertText(XTP_EDIT_LINECOL& lcFrom, XTP_EDIT_LINECOL& lcTo,
350 CXTPSyntaxEditCtrl* pEditCtrl);
351
366 int DoDeleteText(XTP_EDIT_LINECOL& lcFrom, XTP_EDIT_LINECOL& lcTo,
367 CXTPSyntaxEditCtrl* pEditCtrl);
368
375 virtual int GetDataSize() const;
376
377protected:
378 CString m_strText;
379 XTP_EDIT_LINECOL m_lcFrom;
380 XTP_EDIT_LINECOL m_lcTo;
381};
382
391class _XTP_EXT_CLASS CXTPSyntaxEditInsertStringCommand : public CXTPSyntaxEditBufferCommand
392{
394 DECLARE_DYNAMIC(CXTPSyntaxEditInsertStringCommand)
396public:
406 CXTPSyntaxEditInsertStringCommand(CXTPSyntaxEditBufferManager* pMgr, LPCTSTR szText,
407 const XTP_EDIT_LINECOL& lcFrom, const XTP_EDIT_LINECOL& lcTo);
408
414 virtual ~CXTPSyntaxEditInsertStringCommand();
415
428 virtual int Execute(XTP_EDIT_LINECOL& lcFrom, XTP_EDIT_LINECOL& lcTo,
429 CXTPSyntaxEditCtrl* pEditCtrl);
430
443 virtual int UnExecute(XTP_EDIT_LINECOL& lcFrom, XTP_EDIT_LINECOL& lcTo,
444 CXTPSyntaxEditCtrl* pEditCtrl);
445};
446
455class _XTP_EXT_CLASS CXTPSyntaxEditDeleteStringCommand : public CXTPSyntaxEditBufferCommand
456{
458 DECLARE_DYNAMIC(CXTPSyntaxEditDeleteStringCommand)
460public:
470 CXTPSyntaxEditDeleteStringCommand(CXTPSyntaxEditBufferManager* pMgr, LPCTSTR szText,
471 const XTP_EDIT_LINECOL& lcFrom, const XTP_EDIT_LINECOL& lcTo);
472
478 virtual ~CXTPSyntaxEditDeleteStringCommand();
479
492 virtual int Execute(XTP_EDIT_LINECOL& lcFrom, XTP_EDIT_LINECOL& lcTo,
493 CXTPSyntaxEditCtrl* pEditCtrl);
494
507 virtual int UnExecute(XTP_EDIT_LINECOL& lcFrom, XTP_EDIT_LINECOL& lcTo,
508 CXTPSyntaxEditCtrl* pEditCtrl);
509};
510
519class _XTP_EXT_CLASS CXTPSyntaxEditReplaceStringCommand : public CXTPSyntaxEditBufferCommand
520{
522 DECLARE_DYNAMIC(CXTPSyntaxEditReplaceStringCommand)
524public:
534 CXTPSyntaxEditReplaceStringCommand(CXTPSyntaxEditBufferManager* pMgr, LPCTSTR szText,
535 LPCTSTR szReplacedText, const XTP_EDIT_LINECOL& lcFrom,
536 const XTP_EDIT_LINECOL& lcTo);
537
543 virtual ~CXTPSyntaxEditReplaceStringCommand();
544
557 virtual int Execute(XTP_EDIT_LINECOL& lcFrom, XTP_EDIT_LINECOL& lcTo,
558 CXTPSyntaxEditCtrl* pEditCtrl);
559
572 virtual int UnExecute(XTP_EDIT_LINECOL& lcFrom, XTP_EDIT_LINECOL& lcTo,
573 CXTPSyntaxEditCtrl* pEditCtrl);
574
581 virtual int GetDataSize() const;
582
583protected:
584 CString m_strReplacedText;
597 int DoReplaceText(LPCTSTR szText, XTP_EDIT_LINECOL& lcFrom, XTP_EDIT_LINECOL& lcTo,
598 CXTPSyntaxEditCtrl* pEditCtrl);
599};
600
645class _XTP_EXT_CLASS CXTPSyntaxEditUndoRedoManager
646{
647public:
652 CXTPSyntaxEditUndoRedoManager();
653
659 virtual ~CXTPSyntaxEditUndoRedoManager();
660
674 int DoUndo(XTP_EDIT_LINECOL& lcFrom, XTP_EDIT_LINECOL& lcTo, CXTPSyntaxEditCtrl* pEditCtrl);
675
689 int DoRedo(XTP_EDIT_LINECOL& lcFrom, XTP_EDIT_LINECOL& lcTo, CXTPSyntaxEditCtrl* pEditCtrl);
690
697 void AddCommand(CXTPSyntaxEditCommand* pCommand);
698
703 void Clear();
704
713 BOOL CanUndo() const;
714
723 BOOL CanRedo() const;
724
733 void MarkSaved();
734
745 BOOL IsModified() const;
746
760 void SetGroupInsertMode(BOOL bInsertInGroup = TRUE);
761
769 void ChainLastCommand();
770
778 void SetLastCommandText(LPCTSTR szText);
779
787 void SetLastCommandText(UINT nTextId);
788
797 const CStringList& GetUndoTextList();
798
807 const CStringList& GetRedoTextList();
808
815 virtual int GetDataSize() const;
816
824 virtual void LimitDataSize(int nNewCommandData, int nDataSizeLimit);
825
826private:
831 void RemoveTail();
832
833protected:
834 CPtrList m_CommandList;
835 POSITION m_posFirstUndo;
836 POSITION m_posSavedMark;
838 BOOL m_bGroupInsertMode;
839 int m_nDataSizeLimit;
841private:
842 CStringList m_lstUndoText;
843 CStringList m_lstRedoText;
844};
845
846# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
848#endif // !defined(__XTPSYNTAXEDITUNDOMANAGER_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPSyntaxEditBatchCommand
This class represents a pack of commands in one.
Definition XTPSyntaxEditUndoManager.h:177
CXTPSyntaxEditBatchCommand::GetCommandsCount
int GetCommandsCount()
Gets the number of individual command items inside the batch command buffer.
CXTPSyntaxEditBatchCommand::m_CommandList
CPtrList m_CommandList
Commands buffer storage.
Definition XTPSyntaxEditUndoManager.h:261
CXTPSyntaxEditBatchCommand::GetDataSize
virtual int GetDataSize() const
Gets the undo command data size (in bytes).
CXTPSyntaxEditBatchCommand::Execute
virtual int Execute(XTP_EDIT_LINECOL &lcFrom, XTP_EDIT_LINECOL &lcTo, CXTPSyntaxEditCtrl *pEditCtrl)
Executes the batch command by successively executing all stored commands.
CXTPSyntaxEditBatchCommand::UnExecute
virtual int UnExecute(XTP_EDIT_LINECOL &lcFrom, XTP_EDIT_LINECOL &lcTo, CXTPSyntaxEditCtrl *pEditCtrl)
Unexecutes the batch command by successively undoing all stored commands.
CXTPSyntaxEditBatchCommand::~CXTPSyntaxEditBatchCommand
~CXTPSyntaxEditBatchCommand()
A default command destructor.
CXTPSyntaxEditBatchCommand::Clear
void Clear()
Clears the batch command buffer and deletes all commands.
CXTPSyntaxEditBatchCommand::AddCommand
POSITION AddCommand(CXTPSyntaxEditCommand *pCommand)
Adds a command to the batch command buffer.
CXTPSyntaxEditBufferCommand::CXTPSyntaxEditBufferKeepOverwriteSettings
Keeps the buffer overwrite flag for the specified buffer manager from class construction until destru...
Definition XTPSyntaxEditUndoManager.h:315
CXTPSyntaxEditBufferCommand::CXTPSyntaxEditBufferKeepOverwriteSettings::~CXTPSyntaxEditBufferKeepOverwriteSettings
virtual ~CXTPSyntaxEditBufferKeepOverwriteSettings()
Destroys the object and restores buffer overwrite settings.
CXTPSyntaxEditBufferCommand::CXTPSyntaxEditBufferKeepOverwriteSettings::CXTPSyntaxEditBufferKeepOverwriteSettings
CXTPSyntaxEditBufferKeepOverwriteSettings(CXTPSyntaxEditBufferManager *pBufferMgr)
Creates the object and stores buffer overwrite settings.
CXTPSyntaxEditBufferCommand
The base class for all edit commands related to CXTPSyntaxEditBufferManager.
Definition XTPSyntaxEditUndoManager.h:274
CXTPSyntaxEditBufferCommand::m_strText
CString m_strText
Changed text.
Definition XTPSyntaxEditUndoManager.h:378
CXTPSyntaxEditBufferCommand::GetDataSize
virtual int GetDataSize() const
Gets the undo command data size (in bytes).
CXTPSyntaxEditBufferCommand::m_pBufferMgr
CXTPSyntaxEditBufferManager * m_pBufferMgr
Pointer to the associated text buffer.
Definition XTPSyntaxEditUndoManager.h:299
CXTPSyntaxEditBufferCommand::CXTPSyntaxEditBufferCommand
CXTPSyntaxEditBufferCommand(CXTPSyntaxEditBufferManager *pMgr, LPCTSTR szText, const XTP_EDIT_LINECOL &lcFrom, const XTP_EDIT_LINECOL &lcTo)
Creates the buffer command object, initializes its members.
CXTPSyntaxEditBufferCommand::DoDeleteText
int DoDeleteText(XTP_EDIT_LINECOL &lcFrom, XTP_EDIT_LINECOL &lcTo, CXTPSyntaxEditCtrl *pEditCtrl)
Deletes the text at the stored positions and returns the start and final affected text positions.
CXTPSyntaxEditBufferCommand::DoInsertText
int DoInsertText(XTP_EDIT_LINECOL &lcFrom, XTP_EDIT_LINECOL &lcTo, CXTPSyntaxEditCtrl *pEditCtrl)
Inserts the stored text at the stored positions and returns the start and final affected text positio...
CXTPSyntaxEditBufferCommand::~CXTPSyntaxEditBufferCommand
virtual ~CXTPSyntaxEditBufferCommand()
A default command destructor.
CXTPSyntaxEditBufferCommand::m_lcFrom
XTP_EDIT_LINECOL m_lcFrom
Start edit position.
Definition XTPSyntaxEditUndoManager.h:379
CXTPSyntaxEditBufferCommand::m_lcTo
XTP_EDIT_LINECOL m_lcTo
End edit position.
Definition XTPSyntaxEditUndoManager.h:380
CXTPSyntaxEditBufferManager
This class is the main class for buffer management.
Definition XTPSyntaxEditBufferManager.h:59
CXTPSyntaxEditCommand
This class represents an abstract Edit Control command interface.
Definition XTPSyntaxEditUndoManager.h:48
CXTPSyntaxEditCommand::~CXTPSyntaxEditCommand
virtual ~CXTPSyntaxEditCommand()
A default command destructor.
CXTPSyntaxEditCommand::SetCommandText
virtual void SetCommandText(LPCTSTR szText)
Sets command text.
Definition XTPSyntaxEditUndoManager.h:156
CXTPSyntaxEditCommand::CXTPSyntaxEditCommand
CXTPSyntaxEditCommand()
Protected constructor because this class could not be instantiated itself, only by its descendants.
CXTPSyntaxEditCommand::m_strCommandText
CString m_strCommandText
Text description of the command.
Definition XTPSyntaxEditUndoManager.h:153
CXTPSyntaxEditCommand::Execute
virtual int Execute(XTP_EDIT_LINECOL &lcFrom, XTP_EDIT_LINECOL &lcTo, CXTPSyntaxEditCtrl *pEditCtrl)=0
This is an interface function for operation execution.
CXTPSyntaxEditCommand::SetPositionInternally
static void AFX_CDECL SetPositionInternally(CXTPSyntaxEditCtrl *pEditCtrl, const XTP_EDIT_LINECOL &lcPos)
Sets the line and column position for the specified control using internal fast methods.
CXTPSyntaxEditCommand::GetDataSize
virtual int GetDataSize() const
Gets the undo command data size (in bytes).
Definition XTPSyntaxEditUndoManager.h:164
CXTPSyntaxEditCommand::UnExecute
virtual int UnExecute(XTP_EDIT_LINECOL &lcFrom, XTP_EDIT_LINECOL &lcTo, CXTPSyntaxEditCtrl *pEditCtrl)=0
This is an interface function for operation undoing.
CXTPSyntaxEditCommand::GetCommandText
virtual LPCTSTR GetCommandText() const
Gets command text.
Definition XTPSyntaxEditUndoManager.h:160
CXTPSyntaxEditCtrl
This class is the main CWnd-based editor class.
Definition XTPSyntaxEditCtrl.h:114
CXTPSyntaxEditDeleteStringCommand
This class represents the delete string command.
Definition XTPSyntaxEditUndoManager.h:456
CXTPSyntaxEditDeleteStringCommand::Execute
virtual int Execute(XTP_EDIT_LINECOL &lcFrom, XTP_EDIT_LINECOL &lcTo, CXTPSyntaxEditCtrl *pEditCtrl)
Executes the delete string command.
CXTPSyntaxEditDeleteStringCommand::CXTPSyntaxEditDeleteStringCommand
CXTPSyntaxEditDeleteStringCommand(CXTPSyntaxEditBufferManager *pMgr, LPCTSTR szText, const XTP_EDIT_LINECOL &lcFrom, const XTP_EDIT_LINECOL &lcTo)
Creates the delete string command object, initializes its members.
CXTPSyntaxEditDeleteStringCommand::UnExecute
virtual int UnExecute(XTP_EDIT_LINECOL &lcFrom, XTP_EDIT_LINECOL &lcTo, CXTPSyntaxEditCtrl *pEditCtrl)
Unexecutes the delete string command (i.e.
CXTPSyntaxEditDeleteStringCommand::~CXTPSyntaxEditDeleteStringCommand
virtual ~CXTPSyntaxEditDeleteStringCommand()
A default command destructor.
CXTPSyntaxEditInsertStringCommand
This class represents the insert string command.
Definition XTPSyntaxEditUndoManager.h:392
CXTPSyntaxEditInsertStringCommand::Execute
virtual int Execute(XTP_EDIT_LINECOL &lcFrom, XTP_EDIT_LINECOL &lcTo, CXTPSyntaxEditCtrl *pEditCtrl)
Executes the insert string command.
CXTPSyntaxEditInsertStringCommand::~CXTPSyntaxEditInsertStringCommand
virtual ~CXTPSyntaxEditInsertStringCommand()
A default command destructor.
CXTPSyntaxEditInsertStringCommand::CXTPSyntaxEditInsertStringCommand
CXTPSyntaxEditInsertStringCommand(CXTPSyntaxEditBufferManager *pMgr, LPCTSTR szText, const XTP_EDIT_LINECOL &lcFrom, const XTP_EDIT_LINECOL &lcTo)
Creates the insert string command object, initializes its members.
CXTPSyntaxEditInsertStringCommand::UnExecute
virtual int UnExecute(XTP_EDIT_LINECOL &lcFrom, XTP_EDIT_LINECOL &lcTo, CXTPSyntaxEditCtrl *pEditCtrl)
Unexecutes the insert string command (i.e.
CXTPSyntaxEditReplaceStringCommand
This class represents the replace string command.
Definition XTPSyntaxEditUndoManager.h:520
CXTPSyntaxEditReplaceStringCommand::CXTPSyntaxEditReplaceStringCommand
CXTPSyntaxEditReplaceStringCommand(CXTPSyntaxEditBufferManager *pMgr, LPCTSTR szText, LPCTSTR szReplacedText, const XTP_EDIT_LINECOL &lcFrom, const XTP_EDIT_LINECOL &lcTo)
Creates the replace string command object, initializes its members.
CXTPSyntaxEditReplaceStringCommand::GetDataSize
virtual int GetDataSize() const
Gets the undo command data size (in bytes).
CXTPSyntaxEditReplaceStringCommand::m_strReplacedText
CString m_strReplacedText
Buffer which holds the replaced text.
Definition XTPSyntaxEditUndoManager.h:584
CXTPSyntaxEditReplaceStringCommand::Execute
virtual int Execute(XTP_EDIT_LINECOL &lcFrom, XTP_EDIT_LINECOL &lcTo, CXTPSyntaxEditCtrl *pEditCtrl)
Executes the delete string command.
CXTPSyntaxEditReplaceStringCommand::~CXTPSyntaxEditReplaceStringCommand
virtual ~CXTPSyntaxEditReplaceStringCommand()
A default command destructor.
CXTPSyntaxEditReplaceStringCommand::UnExecute
virtual int UnExecute(XTP_EDIT_LINECOL &lcFrom, XTP_EDIT_LINECOL &lcTo, CXTPSyntaxEditCtrl *pEditCtrl)
Unexecutes the delete string command (i.e.
CXTPSyntaxEditReplaceStringCommand::DoReplaceText
int DoReplaceText(LPCTSTR szText, XTP_EDIT_LINECOL &lcFrom, XTP_EDIT_LINECOL &lcTo, CXTPSyntaxEditCtrl *pEditCtrl)
Performs the replace text operation.
CXTPSyntaxEditUndoRedoManager
This class maintains the list of undo/redo commands.
Definition XTPSyntaxEditUndoManager.h:646
CXTPSyntaxEditUndoRedoManager::CXTPSyntaxEditUndoRedoManager
CXTPSyntaxEditUndoRedoManager()
Creates the undo/redo manager object, initializes its members.
CXTPSyntaxEditUndoRedoManager::m_CommandList
CPtrList m_CommandList
Commands buffer.
Definition XTPSyntaxEditUndoManager.h:834
CXTPSyntaxEditUndoRedoManager::GetUndoTextList
const CStringList & GetUndoTextList()
Gets the list of text for undo operations.
CXTPSyntaxEditUndoRedoManager::GetDataSize
virtual int GetDataSize() const
Gets the undo buffer data size (in bytes).
CXTPSyntaxEditUndoRedoManager::DoUndo
int DoUndo(XTP_EDIT_LINECOL &lcFrom, XTP_EDIT_LINECOL &lcTo, CXTPSyntaxEditCtrl *pEditCtrl)
Performs a single undo operation (unexecutes the latest command).
CXTPSyntaxEditUndoRedoManager::DoRedo
int DoRedo(XTP_EDIT_LINECOL &lcFrom, XTP_EDIT_LINECOL &lcTo, CXTPSyntaxEditCtrl *pEditCtrl)
Performs a single redo operation (executes the next command).
CXTPSyntaxEditUndoRedoManager::CanUndo
BOOL CanUndo() const
Determines if it is possible to perform the undo action.
CXTPSyntaxEditUndoRedoManager::m_nDataSizeLimit
int m_nDataSizeLimit
Memory limit for undo data.
Definition XTPSyntaxEditUndoManager.h:839
CXTPSyntaxEditUndoRedoManager::~CXTPSyntaxEditUndoRedoManager
virtual ~CXTPSyntaxEditUndoRedoManager()
Destroys the undo/redo manager object, handles its cleanup and de-allocation.
CXTPSyntaxEditUndoRedoManager::AddCommand
void AddCommand(CXTPSyntaxEditCommand *pCommand)
Adds a command to the undo buffer.
CXTPSyntaxEditUndoRedoManager::IsModified
BOOL IsModified() const
Determines if the document was modified by any command from the buffer since the document was last sa...
CXTPSyntaxEditUndoRedoManager::m_posSavedMark
POSITION m_posSavedMark
Last saved command position in the buffer.
Definition XTPSyntaxEditUndoManager.h:836
CXTPSyntaxEditUndoRedoManager::ChainLastCommand
void ChainLastCommand()
Merges the latest undo command into a batch command with the previous undo command.
CXTPSyntaxEditUndoRedoManager::MarkSaved
void MarkSaved()
Marks the current command buffer position as last saved.
CXTPSyntaxEditUndoRedoManager::m_bGroupInsertMode
BOOL m_bGroupInsertMode
TRUE if group insert mode is on, FALSE otherwise.
Definition XTPSyntaxEditUndoManager.h:838
CXTPSyntaxEditUndoRedoManager::Clear
void Clear()
Clears the undo manager buffer and deletes all commands.
CXTPSyntaxEditUndoRedoManager::GetRedoTextList
const CStringList & GetRedoTextList()
Gets the list of text for redo operations.
CXTPSyntaxEditUndoRedoManager::CanRedo
BOOL CanRedo() const
Determines if it is possible to perform the redo action.
CXTPSyntaxEditUndoRedoManager::m_posFirstUndo
POSITION m_posFirstUndo
Actual command position in the buffer.
Definition XTPSyntaxEditUndoManager.h:835
CXTPSyntaxEditUndoRedoManager::SetGroupInsertMode
void SetGroupInsertMode(BOOL bInsertInGroup=TRUE)
Enables/disables group insert mode.
CXTPSyntaxEditUndoRedoManager::SetLastCommandText
void SetLastCommandText(UINT nTextId)
Sets the text for the last undo command in the stack.
CXTPSyntaxEditUndoRedoManager::LimitDataSize
virtual void LimitDataSize(int nNewCommandData, int nDataSizeLimit)
Checks the undo buffer data size and removes old stored commands to clear memory if the data size lim...
CXTPSyntaxEditUndoRedoManager::SetLastCommandText
void SetLastCommandText(LPCTSTR szText)
Sets the text for the last undo command in the stack.
XTP_EDIT_LINECOL
The XTP_EDIT_LINECOL structure represents the coordinates of text items on the displaying context in ...
Definition XTPSyntaxEditStruct.h:54


Toolkit Pro: XTPColorDialog.h Source File

  • Source
  • Controls
  • Dialog
XTPColorDialog.h
Go to the documentation of this file.
1
23#if !defined(__XTPCOLORDIALOG_H__)
24# define __XTPCOLORDIALOG_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
40class _XTP_EXT_CLASS CXTPEyeDropper : public CWnd
41{
42public:
47 CXTPEyeDropper();
48
53 virtual ~CXTPEyeDropper();
55 //{{AFX_VIRTUAL(CXTPEyeDropper)
56protected:
57 virtual void PreSubclassWindow();
58 virtual BOOL PreCreateWindow(CREATESTRUCT& cs);
59 //}}AFX_VIRTUAL
61public:
73 virtual BOOL Create(DWORD dwStyle, const RECT& rect, CWnd* pParentWnd, UINT nID);
74
82 void SetClipboard(BOOL bSetClipboard);
83
92 void ShowPreview(BOOL bShowPreview);
93
95 virtual BOOL Create(LPCTSTR lpszClassName, LPCTSTR lpszWindowName, DWORD dwStyle,
96 const RECT& rect, CWnd* pParentWnd, UINT nID,
97 CCreateContext* pContext = NULL);
100protected:
101 int m_nPadding;
102 CSize m_icoSize;
103 BOOL m_bPreInit;
104 BOOL m_bSetClipboard;
105 BOOL m_bShowPreview;
106 HICON m_hIcon;
107 HCURSOR m_hCurEyeDropper;
108 HCURSOR m_hCurPrevious;
109 COLORREF m_color;
118 virtual BOOL Init();
119
125 virtual void DrawDropper(CDC* pDC);
126
132 virtual void DrawColor(CDC* pDC);
133
143 BOOL SetClipboardText(LPCTSTR lpszClipText);
144
152 CRect GetColorRect();
153
161 CRect GetDropperRect();
163 //{{AFX_MSG(CXTPEyeDropper)
164 afx_msg int OnCreate(LPCREATESTRUCT lpCreateStruct);
165 afx_msg void OnPaint();
166 afx_msg BOOL OnEraseBkgnd(CDC* pDC);
167 afx_msg void OnMouseMove(UINT nFlags, CPoint point);
168 afx_msg BOOL OnSetCursor(CWnd* pWnd, UINT nHitTest, UINT message);
169 afx_msg void OnLButtonDown(UINT nFlags, CPoint point);
170 afx_msg void OnLButtonUp(UINT nFlags, CPoint point);
171 //}}AFX_MSG
172
173 DECLARE_MESSAGE_MAP()
175};
176
183class _XTP_EXT_CLASS CXTPColorDialog : public CPropertySheet
184{
186 DECLARE_DYNAMIC(CXTPColorDialog)
188public:
208 CXTPColorDialog(COLORREF clrNew, COLORREF clrCurrent, DWORD dwFlags = 0L,
209 CWnd* pWndParent = NULL);
210
215 virtual ~CXTPColorDialog();
216
217public:
230 void SetNewColor(COLORREF clr, BOOL bNotify = TRUE);
231
238 void SetCurrentColor(COLORREF clr);
239
248 COLORREF GetCurrentColor();
249
258 COLORREF GetColor();
259
268 BOOL CopyToClipboard(const CString& strText);
269
278 static CString AFX_CDECL RGBtoHex(COLORREF clr);
279
290 virtual void CalculateRects();
291
292protected:
294 DECLARE_MESSAGE_MAP()
295
296 //{{AFX_VIRTUAL(CXTPColorDialog)
297 virtual BOOL OnInitDialog();
298 void AddPage(CPropertyPage* pPage);
299 //}}AFX_VIRTUAL
300
301 //{{AFX_MSG(CXTPColorDialog)
302 afx_msg void OnPaint();
303 afx_msg int OnCreate(LPCREATESTRUCT lpCreateStruct);
304 afx_msg LRESULT OnEyeDropperMoving(WPARAM wParam, LPARAM lParam);
305 afx_msg LRESULT OnEyeDropperSelect(WPARAM wParam, LPARAM lParam);
306 afx_msg void OnLButtonDown(UINT nFlags, CPoint point);
307 //}}AFX_MSG
310protected:
311 DWORD m_dwStyle;
312 CEdit m_wndHexEdit;
313 CXTPEyeDropper m_wndEyeDropper;
314 CRect m_rcNew;
315 CRect m_rcCurrent;
316 COLORREF m_clrNew;
317 COLORREF m_clrCurrent;
320private:
321 int m_nTextHeight;
322 int m_nGapSize;
323};
324
326
327AFX_INLINE COLORREF CXTPColorDialog::GetCurrentColor()
328{
329 return m_clrCurrent;
330}
331AFX_INLINE COLORREF CXTPColorDialog::GetColor()
332{
333 return m_clrNew;
334}
335
336AFX_INLINE void CXTPEyeDropper::SetClipboard(BOOL bSetClipboard)
337{
338 m_bSetClipboard = bSetClipboard;
339}
340AFX_INLINE void CXTPEyeDropper::ShowPreview(BOOL bShowPreview)
341{
342 m_bShowPreview = bShowPreview;
343}
345# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
347#endif // !defined(__XTPCOLORDIALOG_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPColorDialog
CXTPColorDialog is a CPropertySheet derived class.
Definition XTPColorDialog.h:184
CXTPColorDialog::~CXTPColorDialog
virtual ~CXTPColorDialog()
Destroys a CXTPColorDialog object, handles cleanup and deallocation.
CXTPColorDialog::CXTPColorDialog
CXTPColorDialog(COLORREF clrNew, COLORREF clrCurrent, DWORD dwFlags=0L, CWnd *pWndParent=NULL)
Constructs a CXTPColorDialog object.
CXTPColorDialog::GetCurrentColor
COLORREF GetCurrentColor()
Call this member function to retrieve the RGB information for the current color.
CXTPColorDialog::GetColor
COLORREF GetColor()
Call this member function to retrieve the RGB information for the color that the user selected.
CXTPColorDialog::SetNewColor
void SetNewColor(COLORREF clr, BOOL bNotify=TRUE)
Sets the active color for the dialog.
CXTPColorDialog::CalculateRects
virtual void CalculateRects()
Calculates the size of the dialog's tab control.
CXTPColorDialog::SetCurrentColor
void SetCurrentColor(COLORREF clr)
Call this function to set the new color selection to the color value specified in 'clr'.
CXTPColorDialog::RGBtoHex
static CString AFX_CDECL RGBtoHex(COLORREF clr)
This member function returns a CString object that represents the HEX conversion for the specified RG...
CXTPColorDialog::CopyToClipboard
BOOL CopyToClipboard(const CString &strText)
Call this member function to copy the string specified by 'strText' to the Windows clipboard.
CXTPEyeDropper
Creates an eye dropper control that can be used to select any color that is displayed anywhere on the...
Definition XTPColorDialog.h:41
CXTPEyeDropper::m_hCurEyeDropper
HCURSOR m_hCurEyeDropper
Handle to the eye dropper cursor.
Definition XTPColorDialog.h:107
CXTPEyeDropper::~CXTPEyeDropper
virtual ~CXTPEyeDropper()
Destroys a CXTPEyeDropper object, handles cleanup and deallocation.
CXTPEyeDropper::DrawColor
virtual void DrawColor(CDC *pDC)
Used by the eye dropper control to draw the color preview box.
CXTPEyeDropper::m_icoSize
CSize m_icoSize
Size of the preview icon.
Definition XTPColorDialog.h:102
CXTPEyeDropper::m_hCurPrevious
HCURSOR m_hCurPrevious
Handle to the previous cursor.
Definition XTPColorDialog.h:108
CXTPEyeDropper::Create
virtual BOOL Create(DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID)
Call this member function to create an eye dropper control.
CXTPEyeDropper::Init
virtual BOOL Init()
This member function is called by the CXTPEyeDropper class to perform initialization when the window ...
CXTPEyeDropper::m_hIcon
HICON m_hIcon
Handle to the eye dropper icon.
Definition XTPColorDialog.h:106
CXTPEyeDropper::ShowPreview
void ShowPreview(BOOL bShowPreview)
Call this member function to enable/disable the display for the color preview window.
CXTPEyeDropper::m_bSetClipboard
BOOL m_bSetClipboard
TRUE to set the selected RGB color on the clipboard.
Definition XTPColorDialog.h:104
CXTPEyeDropper::CXTPEyeDropper
CXTPEyeDropper()
Constructs a CXTPEyeDropper object.
CXTPEyeDropper::SetClipboardText
BOOL SetClipboardText(LPCTSTR lpszClipText)
Used by the eye dropper control to place RGB color values as text on the Windows clipboard.
CXTPEyeDropper::m_bPreInit
BOOL m_bPreInit
TRUE when initializing from PreSubclassWindow.
Definition XTPColorDialog.h:103
CXTPEyeDropper::m_nPadding
int m_nPadding
Size of the gap between the eye dropper and preview display.
Definition XTPColorDialog.h:101
CXTPEyeDropper::m_bShowPreview
BOOL m_bShowPreview
TRUE to show color preview.
Definition XTPColorDialog.h:105
CXTPEyeDropper::GetDropperRect
CRect GetDropperRect()
Used by the eye dropper control to determine the rectangle for drawing the eye dropper box.
CXTPEyeDropper::DrawDropper
virtual void DrawDropper(CDC *pDC)
Used by the eye dropper control to draw the eye dropper box.
CXTPEyeDropper::SetClipboard
void SetClipboard(BOOL bSetClipboard)
Call this member function to enable/disable setting the RGB color value as text on the Windows clipbo...
CXTPEyeDropper::m_color
COLORREF m_color
Selected RGB color value.
Definition XTPColorDialog.h:109
CXTPEyeDropper::GetColorRect
CRect GetColorRect()
Used by the eye dropper control to determine the rectangle for drawing the color preview box.


Toolkit Pro: Member List

CXTPClientRect Member List

This is the complete list of members for CXTPClientRect, including all inherited members.

CXTPClientRect(HWND hWnd) | CXTPClientRect
CXTPClientRect(const CWnd *pWnd) | CXTPClientRect


Toolkit Pro: XTPSyntaxEditFindReplaceDlg.h Source File

  • Source
  • SyntaxEdit
XTPSyntaxEditFindReplaceDlg.h
Go to the documentation of this file.
1
23#if !defined(__XTPSYNTAXEDITFINDREPLACEDLG_H__)
24# define __XTPSYNTAXEDITFINDREPLACEDLG_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPSyntaxEditView;
34
40class _XTP_EXT_CLASS CXTPSyntaxEditFindReplaceDlg : public CDialog
41{
43 DECLARE_DYNAMIC(CXTPSyntaxEditFindReplaceDlg)
45public:
51 CXTPSyntaxEditFindReplaceDlg(CWnd* pParentWnd = NULL);
52
53 int m_nSearchDirection;
54 BOOL m_bMatchWholeWord;
55 BOOL m_bMatchCase;
56 CString m_csFindText;
57 CString m_csReplaceText;
58 int m_nSearchHistoryCountMax;
61 enum
62 {
63 IDD = XTP_IDD_EDIT_SEARCH_REPLACE
64 };
65
66 CButton m_btnFindNext;
67 CButton m_btnRadioUp;
68 CButton m_btnRadioDown;
69 CButton m_btnReplace;
70 CButton m_btnReplaceAll;
71 CComboBox m_wndFindCombo;
72 CComboBox m_wndReplaceCombo;
88 BOOL ShowDialog(CXTPSyntaxEditCtrl* pEditCtrl, BOOL bReplaceDlg = FALSE);
89
98 CXTPSyntaxEditCtrl* GetEdirControl() const;
99
109 BOOL IsReplaceDialog() const;
110
121 int GetSearchHistoryCountMax() const;
122
132 void SetSearchHistoryCountMax(int nMaxCount);
133
134protected:
141 void UpdateHistoryCombo(const CString& csText, CStringArray& arHistory);
149 void UpdateHistoryCombo(const CString& csText, CStringArray& arHistory, CComboBox& wndCombo);
156 void UpdateHistoryCombo(const CString& csText, CComboBox& wndCombo);
157
166 void InitHistoryCombo(CStringArray& arHistory, CComboBox& wndCombo);
167
177 BOOL LoadHistory();
178
188 BOOL SaveHistory();
189
195 void EnableControls();
196
198protected:
199 virtual void DoDataExchange(CDataExchange* pDX);
200 virtual BOOL OnInitDialog();
201 virtual void OnCancel();
202 virtual void OnFinalRelease();
203
204 afx_msg void OnEditChangeComboFind();
205 afx_msg void OnSelendOkComboFind();
206 afx_msg void OnChkMatchWholeWord();
207 afx_msg void OnChkMatchCase();
208 afx_msg void OnRadioUp();
209 afx_msg void OnRadioDown();
210 afx_msg void OnBtnFindNext();
211 afx_msg void OnBtnReplace();
212 afx_msg void OnBtnReplaceAll();
213 afx_msg void OnEditChangeComboReplace();
214 afx_msg void OnSelendOkComboReplace();
215
216 DECLARE_MESSAGE_MAP()
219protected:
220 BOOL m_bReplaceDlg;
221 CPoint m_ptWndPos;
222 CXTPSyntaxEditCtrl* m_pEditCtrl;
223};
224
226AFX_INLINE CXTPSyntaxEditCtrl* CXTPSyntaxEditFindReplaceDlg::GetEdirControl() const
227{
228 return m_pEditCtrl;
229}
230AFX_INLINE BOOL CXTPSyntaxEditFindReplaceDlg::IsReplaceDialog() const
231{
232 return m_bReplaceDlg;
233}
234AFX_INLINE int CXTPSyntaxEditFindReplaceDlg::GetSearchHistoryCountMax() const
235{
236 return m_nSearchHistoryCountMax;
237}
238AFX_INLINE void CXTPSyntaxEditFindReplaceDlg::SetSearchHistoryCountMax(int nMaxCount)
239{
240 m_nSearchHistoryCountMax = nMaxCount;
241}
242
243# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
245#endif // !defined(__XTPSYNTAXEDITFINDREPLACEDLG_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPSyntaxEditCtrl
This class is the main CWnd-based editor class.
Definition XTPSyntaxEditCtrl.h:114
CXTPSyntaxEditFindReplaceDlg
This class implements the "Find and Replace" and "Find" dialogs for a SyntaxEdit control.
Definition XTPSyntaxEditFindReplaceDlg.h:41
CXTPSyntaxEditFindReplaceDlg::EnableControls
void EnableControls()
Updates the control state (i.e.
CXTPSyntaxEditFindReplaceDlg::CXTPSyntaxEditFindReplaceDlg
CXTPSyntaxEditFindReplaceDlg(CWnd *pParentWnd=NULL)
Default object constructor.
CXTPSyntaxEditFindReplaceDlg::ShowDialog
BOOL ShowDialog(CXTPSyntaxEditCtrl *pEditCtrl, BOOL bReplaceDlg=FALSE)
Shows either a "Find and Replace" or "Find" dialog.
CXTPSyntaxEditFindReplaceDlg::UpdateHistoryCombo
void UpdateHistoryCombo(const CString &csText, CStringArray &arHistory)
Moves or adds a string to the top of history items (i.e.
CXTPSyntaxEditFindReplaceDlg::m_bMatchCase
BOOL m_bMatchCase
Match Case option.
Definition XTPSyntaxEditFindReplaceDlg.h:55
CXTPSyntaxEditFindReplaceDlg::m_nSearchHistoryCountMax
int m_nSearchHistoryCountMax
Maximum number of search strings.
Definition XTPSyntaxEditFindReplaceDlg.h:58
CXTPSyntaxEditFindReplaceDlg::UpdateHistoryCombo
void UpdateHistoryCombo(const CString &csText, CStringArray &arHistory, CComboBox &wndCombo)
Moves or adds a string to the top of history items (i.e.
CXTPSyntaxEditFindReplaceDlg::LoadHistory
BOOL LoadHistory()
Loads from application profile history for find and replace comboboxes and state for other dialog con...
CXTPSyntaxEditFindReplaceDlg::InitHistoryCombo
void InitHistoryCombo(CStringArray &arHistory, CComboBox &wndCombo)
Initializes a combobox from an array of strings.
CXTPSyntaxEditFindReplaceDlg::UpdateHistoryCombo
void UpdateHistoryCombo(const CString &csText, CComboBox &wndCombo)
Moves or adds a string to the top of history items (i.e.
CXTPSyntaxEditFindReplaceDlg::m_nSearchDirection
int m_nSearchDirection
Search Direction: 0-up, 1-down.
Definition XTPSyntaxEditFindReplaceDlg.h:53
CXTPSyntaxEditFindReplaceDlg::SaveHistory
BOOL SaveHistory()
Saves to application profile history for find and replace comboboxes and state for other dialog contr...
CXTPSyntaxEditFindReplaceDlg::m_bMatchWholeWord
BOOL m_bMatchWholeWord
Match Whole Words option.
Definition XTPSyntaxEditFindReplaceDlg.h:54
CXTPSyntaxEditFindReplaceDlg::GetSearchHistoryCountMax
int GetSearchHistoryCountMax() const
Gets the maximum allowed number of search strings for find and replace comboboxes.
Definition XTPSyntaxEditFindReplaceDlg.h:234
CXTPSyntaxEditFindReplaceDlg::IsReplaceDialog
BOOL IsReplaceDialog() const
Determines the type of dialog that was created.
Definition XTPSyntaxEditFindReplaceDlg.h:230
CXTPSyntaxEditFindReplaceDlg::m_csFindText
CString m_csFindText
Text to find.
Definition XTPSyntaxEditFindReplaceDlg.h:56
CXTPSyntaxEditFindReplaceDlg::m_csReplaceText
CString m_csReplaceText
Text to replace.
Definition XTPSyntaxEditFindReplaceDlg.h:57
CXTPSyntaxEditFindReplaceDlg::SetSearchHistoryCountMax
void SetSearchHistoryCountMax(int nMaxCount)
Sets the maximum allowed number of search strings for find and replace comboboxes.
Definition XTPSyntaxEditFindReplaceDlg.h:238
CXTPSyntaxEditView
This class represents a View portion of the Edit Control.
Definition XTPSyntaxEditView.h:89


Toolkit Pro: XTPEditThemeOffice2003.h Source File

  • Source
  • Controls
  • Edit
  • Themes
XTPEditThemeOffice2003.h
Go to the documentation of this file.
1
23#if !defined(__XTPEDITTHEMEOFFICE2003_H__)
24# define __XTPEDITTHEMEOFFICE2003_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
37class _XTP_EXT_CLASS CXTPEditThemeOffice2003 : public CXTPEditThemeOfficeXP
38{
39public:
44 CXTPEditThemeOffice2003();
45
50 virtual ~CXTPEditThemeOffice2003();
51
58 virtual void RefreshMetrics(CXTPEdit* pEdit);
59};
60
61# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
63#endif // __XTPEDITTHEMEOFFICE2003_H__
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPEdit
CXTPEdit is a CEdit derived class.
Definition XTPEdit.h:129
CXTPEditThemeOffice2003
CXTPEditThemeOffice2003 is a class used to perform theme drawing tasks.
Definition XTPEditThemeOffice2003.h:38
CXTPEditThemeOffice2003::CXTPEditThemeOffice2003
CXTPEditThemeOffice2003()
Constructs a CXTPEditThemeOffice2003 object.
CXTPEditThemeOffice2003::~CXTPEditThemeOffice2003
virtual ~CXTPEditThemeOffice2003()
Destructor, handles cleanup and deallocation.
CXTPEditThemeOffice2003::RefreshMetrics
virtual void RefreshMetrics(CXTPEdit *pEdit)
This member function is called by the theme manager to refresh the visual styles used by each compone...
CXTPEditThemeOfficeXP
CXTPEditThemeOfficeXP is a class used to perform theme drawing tasks.
Definition XTPEditThemeOfficeXP.h:38


Toolkit Pro: XTPImageList.h Source File

  • Source
  • Common
XTPImageList.h
Go to the documentation of this file.
1
23#if !defined(__XTPIMAGELIST_H__)
24# define __XTPIMAGELIST_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPImageList : public CObject
39{
40 DECLARE_DYNAMIC(CXTPImageList);
41
42public:
44 typedef CXTPGdiObjectPtrProxy<CImageList, CXTPImageList> XTPImageListPtrProxy;
47private:
48 CImageList* m_imageList;
49 int m_imageCx;
50
69 BOOL Create(CBitmap* bitmap, int cx, int nGrow, COLORREF crMask);
70
84 BOOL Resize(CBitmap* src, CBitmap* dst);
85
86public:
91 CXTPImageList();
92
97 virtual ~CXTPImageList();
98
115 BOOL Create(int cx, int cy, UINT nFlags, int nInitial, int nGrow);
116
132 BOOL Create(UINT nBitmapID, int cx, int nGrow, COLORREF crMask);
133
149 BOOL Create(LPCTSTR lpszBitmapID, int cx, int nGrow, COLORREF crMask);
150
165 BOOL Create(CXTPImageList& imagelist1, int nImage1, CXTPImageList& imagelist2, int nImage2,
166 int dx, int dy);
167
175 BOOL Create(CXTPImageList* pImageList);
176
184 operator HIMAGELIST() const;
185
192 HIMAGELIST GetSafeHandle() const;
193
201 BOOL Attach(HIMAGELIST hImageList);
202
209 HIMAGELIST Detach();
210
217 int GetImageCount() const;
218
227 COLORREF SetBkColor(COLORREF cr);
228
235 COLORREF GetBkColor() const;
236
247 BOOL GetImageInfo(int nImage, IMAGEINFO* pImageInfo) const;
248
255 BOOL DeleteImageList();
256
264 BOOL SetImageCount(UINT uNewCount);
265
276 int Add(CBitmap* pbmImage, CBitmap* pbmMask);
277
289 int Add(CBitmap* pbmImage, COLORREF crMask);
290
298 int Add(HICON hIcon);
299
307 BOOL Remove(int nImage);
308
319 BOOL Replace(int nImage, CBitmap* pbmImage, CBitmap* pbmMask);
320
329 int Replace(int nImage, HICON hIcon);
330
339 HICON ExtractIcon(int nImage);
340
353 BOOL Draw(CDC* pDC, int nImage, POINT pt, UINT nStyle);
354
364 BOOL SetOverlayImage(int nImage, int nOverlay);
365
379 BOOL Copy(int iDst, int iSrc, UINT uFlags = ILCF_MOVE);
380
396 BOOL Copy(int iDst, CXTPImageList* pSrc, int iSrc, UINT uFlags = ILCF_MOVE);
397
406 BOOL DrawIndirect(IMAGELISTDRAWPARAMS* pimldp);
407
415 BOOL Read(CArchive* pArchive);
416
424 BOOL Write(CArchive* pArchive);
425
435 BOOL BeginDrag(int nImage, CPoint ptHotSpot);
436
446 BOOL SetDragCursorImage(int nDrag, CPoint ptHotSpot);
447
449# if defined(_DEBUG) || defined(_AFXDLL)
450 virtual void Dump(CDumpContext& dc) const;
451 virtual void AssertValid() const;
452# endif
461 CImageList* GetNativeGdiObject();
462
469 const CImageList* GetNativeGdiObject() const;
470
479 operator CImageList&();
480
489 operator const CImageList&() const;
490
492 XTPImageListPtrProxy operator&();
493 const XTPImageListPtrProxy operator&() const;
495};
497AFX_INLINE CImageList* CXTPImageList::GetNativeGdiObject()
498{
499 return m_imageList;
500}
501
502AFX_INLINE const CImageList* CXTPImageList::GetNativeGdiObject() const
503{
504 return const_cast< CXTPImageList*>(this)->GetNativeGdiObject();
505}
506
507AFX_INLINE CXTPImageList::operator CImageList&()
508{
509 return *GetNativeGdiObject();
510}
511
512AFX_INLINE CXTPImageList::operator const CImageList&() const
513{
514 return *GetNativeGdiObject();
515}
516
517AFX_INLINE CXTPImageList::XTPImageListPtrProxy CXTPImageList::operator&()
518{
519 return XTPImageListPtrProxy(this);
520}
521
522AFX_INLINE const CXTPImageList::XTPImageListPtrProxy CXTPImageList::operator&() const
523{
524 return XTPImageListPtrProxy(const_cast< CXTPImageList*>(this));
525}
527# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
529#endif // !defined(__XTPIMAGELIST_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPImageList
CXTPImageList extends CImageList with add additional functionality for images resizing that depends o...
Definition XTPImageList.h:39
CXTPImageList::GetNativeGdiObject
const CImageList * GetNativeGdiObject() const
Obtains a pointer to the encapsulated CImageList object.
CXTPImageList::SetDragCursorImage
BOOL SetDragCursorImage(int nDrag, CPoint ptHotSpot)
Creates a new drag image by combining the given image (typically a mouse cursor image) with the curre...
CXTPImageList::Create
BOOL Create(CXTPImageList &imagelist1, int nImage1, CXTPImageList &imagelist2, int nImage2, int dx, int dy)
Initializes an image list and attaches it to a CXTPImageList object.
CXTPImageList::Create
BOOL Create(LPCTSTR lpszBitmapID, int cx, int nGrow, COLORREF crMask)
Initializes an image list and attaches it to a CXTPImageList object.
CXTPImageList::Copy
BOOL Copy(int iDst, int iSrc, UINT uFlags=ILCF_MOVE)
This member function implements the behavior of the Win32 function ImageList_Copy,...
CXTPImageList::Replace
int Replace(int nImage, HICON hIcon)
Call this function to replace an image in an image list with a new image.
CXTPImageList::Add
int Add(HICON hIcon)
Call this function to add one or more images or an icon to an image list.
CXTPImageList::CXTPImageList
CXTPImageList()
Constructs a CXTPImageList object.
CXTPImageList::Add
int Add(CBitmap *pbmImage, COLORREF crMask)
Call this function to add one or more images or an icon to an image list.
CXTPImageList::Copy
BOOL Copy(int iDst, CXTPImageList *pSrc, int iSrc, UINT uFlags=ILCF_MOVE)
This member function implements the behavior of the Win32 function ImageList_Copy,...
CXTPImageList::BeginDrag
BOOL BeginDrag(int nImage, CPoint ptHotSpot)
Call this function to begin dragging an image.
CXTPImageList::SetOverlayImage
BOOL SetOverlayImage(int nImage, int nOverlay)
Call this function to add the zero-based index of an image to the list of images to be used as overla...
CXTPImageList::Add
int Add(CBitmap *pbmImage, CBitmap *pbmMask)
Call this function to add one or more images or an icon to an image list.
CXTPImageList::SetImageCount
BOOL SetImageCount(UINT uNewCount)
Call this member function to reset the number of images in a CXTPImageList object.
CXTPImageList::GetNativeGdiObject
CImageList * GetNativeGdiObject()
Obtains a pointer to the encapsulated CImageList object.
CXTPImageList::Detach
HIMAGELIST Detach()
Call this function to detach an image list object from a CXTPImageList object.
CXTPImageList::Draw
BOOL Draw(CDC *pDC, int nImage, POINT pt, UINT nStyle)
Call this function to draw the image that is being dragged during a drag-and-drop operation.
CXTPImageList::Write
BOOL Write(CArchive *pArchive)
Call this function to write an image list object to an archive.
CXTPImageList::Read
BOOL Read(CArchive *pArchive)
Call this function to read an image list from an archive.
CXTPImageList::Create
BOOL Create(CXTPImageList *pImageList)
Initializes an image list and attaches it to a CXTPImageList object.
CXTPImageList::GetBkColor
COLORREF GetBkColor() const
Call this function to retrieve the current background color for an image list.
CXTPImageList::DeleteImageList
BOOL DeleteImageList()
Call this function to delete an image list.
CXTPImageList::Create
BOOL Create(UINT nBitmapID, int cx, int nGrow, COLORREF crMask)
Initializes an image list and attaches it to a CXTPImageList object.
CXTPImageList::Create
BOOL Create(int cx, int cy, UINT nFlags, int nInitial, int nGrow)
Initializes an image list and attaches it to a CXTPImageList object.
CXTPImageList::DrawIndirect
BOOL DrawIndirect(IMAGELISTDRAWPARAMS *pimldp)
Call this member function to draw an image from an image list.
CXTPImageList::ExtractIcon
HICON ExtractIcon(int nImage)
Call this function to create an icon based on an image and its related mask in an image list.
CXTPImageList::SetBkColor
COLORREF SetBkColor(COLORREF cr)
Call this function to set the background color for an image list.
CXTPImageList::Attach
BOOL Attach(HIMAGELIST hImageList)
Attaches an image list to a CXTPImageList object.
CXTPImageList::Remove
BOOL Remove(int nImage)
Call this function to remove an image from an image list object.
CXTPImageList::~CXTPImageList
virtual ~CXTPImageList()
Destroys a CXTPImageList object, handles cleanup and deallocation.
CXTPImageList::GetSafeHandle
HIMAGELIST GetSafeHandle() const
Call this function to retrieve the m_hImageList data member.
CXTPImageList::GetImageInfo
BOOL GetImageInfo(int nImage, IMAGEINFO *pImageInfo) const
Call this function to retrieve information about an image.
CXTPImageList::Replace
BOOL Replace(int nImage, CBitmap *pbmImage, CBitmap *pbmMask)
Call this function to replace an image in an image list with a new image.
CXTPImageList::GetImageCount
int GetImageCount() const
Call this function to retrieve the number of images in an image list.


Toolkit Pro: Member List

CXTPDockingPaneColorSet2015 Member List

This is the complete list of members for CXTPDockingPaneColorSet2015, including all inherited members.

GetButtonColorSet(CXTPDockingPaneCaptionButton *pButton) | CXTPDockingPaneColorSet | virtual
m_clrBackground | CXTPDockingPaneColorSet |
m_clrBorder | CXTPDockingPaneColorSet |
m_clrCaption | CXTPDockingPaneColorSet |
m_clrGripper | CXTPDockingPaneColorSet |
m_clrSplitter | CXTPDockingPaneColorSet |
m_clrText | CXTPDockingPaneColorSet |
m_csCaptionButtonHot | CXTPDockingPaneColorSet | protected
m_csCaptionButtonNormal | CXTPDockingPaneColorSet | protected
m_csCaptionButtonPressed | CXTPDockingPaneColorSet | protected
RefreshMetrics(CString strSection) | CXTPDockingPaneColorSet2015 | virtual
~CXTPDockingPaneColorSet() | CXTPDockingPaneColorSet | virtual


Toolkit Pro: Member List

CXTPGroupLine Member List

This is the complete list of members for CXTPGroupLine, including all inherited members.

CXTPGroupLine() CXTPGroupLine


Toolkit Pro: Member List

CXTPStatusBarThemeNativeWindows11 Member List

This is the complete list of members for CXTPStatusBarThemeNativeWindows11, including all inherited members.

CXTPStatusBarThemeNativeWindows11(CXTPPaintManager *pPaintManager) | CXTPStatusBarThemeNativeWindows11 |
CXTPStatusBarThemeOffice2013(CXTPPaintManager *pPaintManager) | CXTPStatusBarThemeOffice2013 |
DrawStatusBarButtonFace(CDC *pDC, CRect rcItem, CXTPStatusBarPane *pPane) | CXTPStatusBarThemeOffice2013 | virtual
DrawStatusBarGripper(CDC *pDC, CRect rcClient) | CXTPStatusBarThemeNativeWindows11 | virtual
DrawStatusBarPaneBorder(CDC *pDC, CRect rc, CXTPStatusBarPane *pPane, BOOL bGripperPane) | CXTPStatusBarThemeOffice2013 | virtual
DrawStatusBarPaneEntry(CDC *pDC, CRect rcItem, CXTPStatusBarPane *pPane) | CXTPStatusBarThemeOffice2013 | virtual
DrawStatusBarPaneSeparator(CDC *pDC, CRect rc, CXTPStatusBarPane *pPane) | CXTPStatusBarThemeOffice2013 | virtual
DrawStatusBarSwitchPane(CDC *pDC, CRect rcItem, CXTPStatusBarSwitchPane *pPane) | CXTPStatusBarThemeOffice2013 | virtual
FillStatusBar(CDC *pDC, CXTPStatusBar *pBar) | CXTPStatusBarThemeOffice2013 | virtual
GetStateColor() const | CXTPStatusBarThemeNativeWindows11 | virtual
GetTextColor(CXTPStatusBarPane *pPane) | CXTPStatusBarThemeOffice2013 | virtual
m_clrButtonBack | CXTPStatusBarThemeOffice2013 | protected
m_clrButtonBackChecked | CXTPStatusBarThemeOffice2013 | protected
m_clrButtonBackHighlight | CXTPStatusBarThemeOffice2013 | protected
m_clrButtonBackPushed | CXTPStatusBarThemeOffice2013 | protected
m_clrButtonTextChecked | CXTPStatusBarThemeOffice2013 | protected
m_clrButtonTextHighlight | CXTPStatusBarThemeOffice2013 | protected
m_clrButtonTextPushed | CXTPStatusBarThemeOffice2013 | protected
RefreshMetrics() | CXTPStatusBarThemeNativeWindows11 | virtual
SetStateColor(COLORREF clrState) | CXTPStatusBarThemeNativeWindows11 | virtual


Toolkit Pro: Member List

CXTPShortcutBar Member List

This is the complete list of members for CXTPShortcutBar, including all inherited members.

AddItem(UINT nID, CWnd *pWnd=NULL) | CXTPShortcutBar |
AllowCollapse(BOOL bAllowCollapse) | CXTPShortcutBar |
AllowFreeResize(BOOL bAllowFreeResize) | CXTPShortcutBar |
AllowGripperResize(BOOL bAllowResize) | CXTPShortcutBar |
AllowMinimize(BOOL bAllowMinimize=TRUE, int nMinimizedWidth=0) | CXTPShortcutBar |
Create(DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID) | CXTPShortcutBar |
CXTPShortcutBar() | CXTPShortcutBar |
EnableAnimation(BOOL bEnable=TRUE) | CXTPShortcutBar |
FindItem(int nID) const | CXTPShortcutBar |
GetClientPaneRect() const | CXTPShortcutBar |
GetCollapsedItemsCount() const | CXTPShortcutBar |
GetCurrentTheme() const | CXTPShortcutBar |
GetExpandedLinesCount() const | CXTPShortcutBar |
GetExpandedLinesHeight() const | CXTPShortcutBar |
GetGripperRect() const | CXTPShortcutBar |
GetHotItem() const | CXTPShortcutBar |
GetImageManager() const | CXTPShortcutBar |
GetItem(int nIndex) const | CXTPShortcutBar |
GetItemCount() const | CXTPShortcutBar |
GetItemSize() const | CXTPShortcutBar |
GetPaintManager() const | CXTPShortcutBar |
GetPressedItem() const | CXTPShortcutBar |
GetSelectedItem() const | CXTPShortcutBar |
GetToolTipContext() const | CXTPShortcutBar |
GetVisibleItemsCount() const | CXTPShortcutBar |
HitTest(CPoint pt) const | CXTPShortcutBar |
IsAllowFreeResize() const | CXTPShortcutBar |
IsAllowMinimize() const | CXTPShortcutBar |
IsClientPaneVisible() const | CXTPShortcutBar |
IsExpandButtonVisible() const | CXTPShortcutBar |
IsMinimizeButtonVisible() const | CXTPShortcutBar |
IsShortcutBarMinimized() const | CXTPShortcutBar |
IsShowActiveItemOnTop() const | CXTPShortcutBar |
IsSingleSelection() const | CXTPShortcutBar |
LoadState(LPCTSTR lpszProfileName) | CXTPShortcutBar |
m_arrItems | CXTPShortcutBar | protected
m_bAllowCollapse | CXTPShortcutBar | protected
m_bAllowFreeResize | CXTPShortcutBar | protected
m_bAllowResize | CXTPShortcutBar | protected
m_bClientPaneVisible | CXTPShortcutBar | protected
m_bPreSubclassWindow | CXTPShortcutBar | protected
m_bShowActiveItemOnTop | CXTPShortcutBar | protected
m_bShowGripper | CXTPShortcutBar | protected
m_bSingleSelection | CXTPShortcutBar | protected
m_bTrackingSize | CXTPShortcutBar | protected
m_hHandCursor | CXTPShortcutBar | protected
m_hSizeCursor | CXTPShortcutBar | protected
m_hwndClient | CXTPShortcutBar | protected
m_nDesiredExpandedLinesHeight | CXTPShortcutBar | protected
m_nExpandedLines | CXTPShortcutBar | protected
m_nMinClientHeight | CXTPShortcutBar | protected
m_paintTheme | CXTPShortcutBar | protected
m_pAnimation | CXTPShortcutBar | protected
m_pHotItem | CXTPShortcutBar | protected
m_pImageManager | CXTPShortcutBar | protected
m_pPaintManager | CXTPShortcutBar | protected
m_pPressedItem | CXTPShortcutBar | protected
m_pSelectedItem | CXTPShortcutBar | protected
m_pToolTipContext | CXTPShortcutBar | protected
m_rcClient | CXTPShortcutBar | protected
m_rcGripper | CXTPShortcutBar | protected
m_szItem | CXTPShortcutBar | protected
OnDraw(CDC *pDC, CRect rcClipBox) | CXTPShortcutBar | virtual
OnExpandButtonDown(CXTPShortcutBarItem *pExpandButton) | CXTPShortcutBar | protectedvirtual
OnNavigateButtonDown(CXTPShortcutBarItem *pNavigateButton) | CXTPShortcutBar | protected
OnRepositionDone() | CXTPShortcutBar | protectedvirtual
RedrawControl(LPCRECT lpRect=NULL, BOOL bAnimate=FALSE) | CXTPShortcutBar |
RegisterWindowClass(HINSTANCE hInstance=NULL) | CXTPShortcutBar |
RemoveAllItems() | CXTPShortcutBar |
RemoveItem(int nID) | CXTPShortcutBar |
Reposition() | CXTPShortcutBar | virtual
SaveState(LPCTSTR lpszProfileName) | CXTPShortcutBar |
SelectItem(CXTPShortcutBarItem *pItem) | CXTPShortcutBar |
SetClientPaneVisible(BOOL bVisible) | CXTPShortcutBar |
SetCustomTheme(CXTPShortcutBarPaintManager *pPaintManager) | CXTPShortcutBar |
SetExpandedLinesCount(int nCount) | CXTPShortcutBar |
SetExpandedLinesHeight(int nHeight) | CXTPShortcutBar |
SetHotItem(CXTPShortcutBarItem *pItem) | CXTPShortcutBar | protected
SetImageManager(CXTPImageManager *pImageManager) | CXTPShortcutBar |
SetItemSize(CSize szItem) | CXTPShortcutBar |
SetLayoutRTL(BOOL bRightToLeft) | CXTPShortcutBar |
SetMinimumClientHeight(int nMinHeight) | CXTPShortcutBar |
SetSingleSelection(BOOL bSingleSelection=TRUE) | CXTPShortcutBar |
SetTheme(XTPShortcutBarPaintTheme paintTheme) | CXTPShortcutBar |
ShowActiveItemOnTop(BOOL bActiveItemOnTop) | CXTPShortcutBar |
ShowExpandButton(BOOL bShow) | CXTPShortcutBar |
ShowGripper(BOOL bShowGripper) | CXTPShortcutBar |
ShowMinimizeButton(BOOL bShowMinimizeButton) | CXTPShortcutBar |
~CXTPShortcutBar() | CXTPShortcutBar | virtual


Toolkit Pro: XTPRibbonTabTheme.h Source File

  • Source
  • Ribbon
XTPRibbonTabTheme.h
Go to the documentation of this file.
1
23#if !defined(__XTPRIBBONTABTHEME_H__)
24# define __XTPRIBBONTABTHEME_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPRibbonPaintManager;
34class CXTPTabManager;
35
36class _XTP_EXT_CLASS CXTPRibbonTabTheme : public CAppearanceSetPropertyPageFlat
37{
38public:
39 CXTPRibbonTabTheme(CXTPRibbonPaintManager* pRibbonTheme)
40 : m_pRibbonTheme(pRibbonTheme)
41 {
42 m_rcHeaderMargin.SetRect(0, 1, 0, 0);
43 }
44
45protected:
46 void DrawTabControl(CXTPTabManager* pTabManager, CDC* pDC, CRect rcControl);
47
48 void DrawSingleButton(CDC* pDC, CXTPTabManagerItem* pItem);
49 void DrawText(CDC* pDC, CXTPTabManager* pManager, const CString& str, LPRECT lpRect,
50 UINT nFormat);
51
52 int GetButtonHeight(const CXTPTabManager* pTabManager);
53
54protected:
55 CXTPRibbonPaintManager* m_pRibbonTheme;
56};
57
58# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
60#endif // !defined(__XTPRIBBONTABTHEME_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CAppearanceSetPropertyPageFlat
CAppearanceSetPropertyPageFlat implements an Office 2000 Flat tab appearance.
Definition XTPTabThemePropertyPageFlat.h:49
CAppearanceSetPropertyPageFlat::DrawSingleButton
virtual void DrawSingleButton(CDC *pDC, CXTPTabManagerItem *pItem)
Draws a single tab button in the tab client header area.
CXTPRibbonPaintManager
Standalone class used by CXTPRibbonBar as a paint manager.
Definition XTPRibbonPaintManager.h:51
CXTPTabManager
CXTPTabManager is the base class for docking pane tabs, tab control tabs, and MDI client tabs.
Definition XTPTabManager.h:87
CXTPTabManagerItem
CXTPTabManagerItem is the base class for the tabs that appear in the command bars tab workspace,...
Definition XTPTabManagerItem.h:44
CXTPTabPaintManagerTheme::DrawTabControl
virtual void DrawTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl)
Draws the tab control.
CXTPTabPaintManagerTheme::DrawText
virtual void DrawText(CDC *pDC, CXTPTabManager *pManager, const CString &str, LPRECT lpRect, UINT nFormat)
Draws the text of a specified item.
CXTPTabPaintManagerTheme::GetButtonHeight
virtual int GetButtonHeight(const CXTPTabManager *pTabManager)
Retrieves the total height of the tab buttons within a specified tab manager including the top and bo...


Toolkit Pro: XTPCalendarCaptionBarVisualStudio2015Theme.h Source File

  • Source
  • Calendar
  • CaptionBar
  • Themes
XTPCalendarCaptionBarVisualStudio2015Theme.h
Go to the documentation of this file.
1
22#if !defined(__XTPCALENDARCAPTIONBARVISUALSTUDIO2015THEME_H__)
23# define __XTPCALENDARCAPTIONBARVISUALSTUDIO2015THEME_H__
24
25# if _MSC_VER > 1000
26# pragma once
27# endif // _MSC_VER > 1000
28
29# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
30
36class _XTP_EXT_CLASS CXTPCalendarCaptionBarVisualStudio2015Theme
37 : public CXTPCalendarCaptionBarOffice2013Theme
38{
39public:
48 CXTPCalendarCaptionBarVisualStudio2015Theme(CXTPCalendarCaptionBarTheme* pTheme = NULL);
49
56 virtual ~CXTPCalendarCaptionBarVisualStudio2015Theme();
57};
58
59# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
60#endif // !defined(__XTPCALENDARCAPTIONBARVISUALSTUDIO2015THEME_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCalendarCaptionBarOffice2013Theme
CXTPCalendarCaptionBarOffice2013Theme is a CXTPCalendarCaptionBarOffice2003Theme derived class that r...
Definition XTPCalendarCaptionBarOffice2013Theme.h:38
CXTPCalendarCaptionBarTheme
This class CalendarCaptionBar control drawing, user interaction logic and interaction logic with atta...
Definition XTPCalendarCaptionBarTheme.h:48
CXTPCalendarCaptionBarVisualStudio2015Theme
CXTPCalendarCaptionBarVisualStudio2015Theme is a CXTPCalendarCaptionBarOffice2013Theme derived class ...
Definition XTPCalendarCaptionBarVisualStudio2015Theme.h:38
CXTPCalendarCaptionBarVisualStudio2015Theme::CXTPCalendarCaptionBarVisualStudio2015Theme
CXTPCalendarCaptionBarVisualStudio2015Theme(CXTPCalendarCaptionBarTheme *pTheme=NULL)
Default paint manager constructor.
CXTPCalendarCaptionBarVisualStudio2015Theme::~CXTPCalendarCaptionBarVisualStudio2015Theme
virtual ~CXTPCalendarCaptionBarVisualStudio2015Theme()
Default paint manager destructor.


Toolkit Pro: Member List

CXTPButtonThemeOffice2013 Member List

This is the complete list of members for CXTPButtonThemeOffice2013, including all inherited members.

CXTPButtonTheme() | CXTPButtonTheme |
CXTPButtonThemeUltraFlat() | CXTPButtonThemeUltraFlat |
CXTPCmdTarget() | CXTPCmdTarget |
CXTPControlTheme() | CXTPControlTheme |
DrawButton(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
DrawButtonBackground(CDC *pDC, CXTPButton *pButton) | CXTPButtonThemeOffice2013 | virtual
DrawButtonText(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme |
DrawButtonVisualStyleBackground(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
DrawCheckBoxMark(CDC *pDC, CXTPButton *pButton) | CXTPButtonThemeOffice2013 | virtual
DrawFocusRect(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
DrawGroupBox(CDC *pDC, CXTPButton *pButton) | CXTPButtonThemeOffice2013 | virtual
DrawPushButtonDropDown(CDC *pDC, CXTPButton *pButton) | CXTPButtonThemeOffice2013 | virtual
DrawPushButtonIcon(CDC *pDC, CXTPButton *pButton) | CXTPButtonThemeOffice2013 | virtual
DrawPushButtonText(CDC *pDC, CXTPButton *pButton) | CXTPButtonThemeOffice2013 | virtual
DrawRadioButtonMark(CDC *pDC, CXTPButton *pButton) | CXTPButtonThemeOffice2013 | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetTextColor(CXTPButton *pButton) | CXTPButtonThemeOffice2013 | virtual
GetThemeStyle() const | CXTPControlTheme |
m_crBack | CXTPButtonTheme |
m_crBackChecked | CXTPButtonThemeUltraFlat |
m_crBackDisabled | CXTPButtonThemeOffice2013 | protected
m_crBackHilite | CXTPButtonThemeUltraFlat |
m_crBackPushed | CXTPButtonThemeUltraFlat |
m_crBorder | CXTPButtonThemeOffice2013 | protected
m_crBorder3DHilite | CXTPButtonTheme |
m_crBorder3DShadow | CXTPButtonTheme |
m_crBorderDefault | CXTPButtonThemeOffice2013 | protected
m_crBorderDisabled | CXTPButtonThemeOffice2013 | protected
m_crBorderHilite | CXTPButtonTheme |
m_crBorderPushed | CXTPButtonThemeUltraFlat |
m_crBorderShadow | CXTPButtonTheme |
m_crCheckMark | CXTPButtonThemeUltraFlat |
m_crMark | CXTPButtonThemeOffice2013 | protected
m_crMarkDisabled | CXTPButtonThemeOffice2013 | protected
m_crMarkHilite | CXTPButtonThemeOffice2013 | protected
m_crMarkPushed | CXTPButtonThemeOffice2013 | protected
m_crText | CXTPButtonTheme |
m_crTextCheck | CXTPButtonTheme |
m_crTextDisabled | CXTPButtonTheme |
m_crTextHilite | CXTPButtonThemeUltraFlat |
m_crTextPushed | CXTPButtonThemeUltraFlat |
m_nTheme | CXTPControlTheme | protected
RefreshMetrics(CXTPButton *pButton) | CXTPButtonThemeOffice2013 | virtual
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static
~CXTPButtonTheme() | CXTPButtonTheme | virtual


Toolkit Pro: Member List

CXTPDockingPaneOffice2007WordTheme Member List

This is the complete list of members for CXTPDockingPaneOffice2007WordTheme, including all inherited members.

AdjustCaptionRect(const CXTPDockingPaneSidePanel *pPane, CRect &rc) | CXTPDockingPanePaintManager | virtual
AdjustCaptionRect(const CXTPDockingPaneTabbedContainer *pPane, CRect &rc) | CXTPDockingPanePaintManager | virtual
AdjustClientRect(CXTPDockingPaneTabbedContainer *pPane, CRect &rect, BOOL bApply) | CXTPDockingPaneOffice2007WordTheme | virtual
CXTPDockingPaneOffice2003Theme::AdjustClientRect(CXTPDockingPaneSidePanel *pPane, CRect &rect) | CXTPDockingPanePaintManager | virtual
ClipAndAddEllipsisIfNeeded(CDC *pDC, CString &strTitle, int nCaptionWidth) const | CXTPDockingPanePaintManager | protected
CXTPCmdTarget() | CXTPCmdTarget |
CXTPDockingPaneDefaultTheme() | CXTPDockingPaneDefaultTheme |
CXTPDockingPaneGripperedTheme() | CXTPDockingPaneGripperedTheme |
CXTPDockingPaneOffice2003Theme() | CXTPDockingPaneOffice2003Theme |
CXTPDockingPaneOffice2007WordTheme() | CXTPDockingPaneOffice2007WordTheme |
CXTPDockingPanePaintManager() | CXTPDockingPanePaintManager | protected
CXTPDockingPaneVisualStudio2003Theme() | CXTPDockingPaneVisualStudio2003Theme |
DrawAutoHidePanel(CDC *pDC, CRect rc, XTPDockingPaneDirection direction) | CXTPDockingPanePaintManager | virtual
DrawCaption(CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc) | CXTPDockingPaneOffice2007WordTheme | virtual
DrawCaptionButton(CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton) | CXTPDockingPanePaintManager | virtual
DrawCaptionButtonEntry(CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton, CSize szOffset) | CXTPDockingPanePaintManager | protectedvirtual
DrawCaptionButtonEntry(CDC *pDC, CXTPDockingPaneCaptionButton *pButton, CPoint pt, COLORREF clrButton) | CXTPDockingPanePaintManager | protectedvirtual
DrawCaptionButtons(CDC *pDC, CXTPDockingPaneCaptionButtons *pButtons, CRect &rcCaption, COLORREF clr, int nButtonSize, int nButtonGap, BOOL bVertical=FALSE) | CXTPDockingPanePaintManager | virtual
DrawCaptionPart(CDC *pDC, CXTPDockingPaneBase *pPane, CRect rcCaption, const CString &strTitle, BOOL bActive, BOOL bVertical) | CXTPDockingPaneOffice2007WordTheme | virtual
DrawCaptionText(CDC *pDC, const CString &strTitle, CRect rc, BOOL bVertical, BOOL bCalcWidth=FALSE) | CXTPDockingPanePaintManager |
DrawFloatingFrame(CDC *pDC, CXTPDockingPaneMiniWnd *pPane, CRect rc) | CXTPDockingPaneOffice2003Theme | virtual
DrawPane(CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc) | CXTPDockingPaneOffice2007WordTheme | virtual
DrawSidePanel(CDC *pDC, CXTPDockingPaneSidePanel *pPane, CRect rc) | CXTPDockingPaneOffice2003Theme | virtual
DrawSplitter(CDC *pDC, CXTPDockingPaneSplitterWnd *pSplitter) | CXTPDockingPanePaintManager | virtual
FillCaptionPart(CDC *pDC, CXTPDockingPaneBase *pPane, CRect rcCaption, BOOL bActive, BOOL bVertical) | CXTPDockingPaneVisualStudio2003Theme | protectedvirtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCaptionButtonStyle() const | CXTPDockingPanePaintManager |
GetCaptionGripperRect(const CXTPDockingPaneTabbedContainer *pPane) | CXTPDockingPaneOffice2003Theme | virtual
GetCaptionHeight() const | CXTPDockingPanePaintManager |
GetCaptionRect(const CXTPDockingPaneTabbedContainer *pPane, CRect &rc) | CXTPDockingPanePaintManager | virtual
GetCurrentSystemTheme() const | CXTPDockingPanePaintManager |
GetCustomTitleBrush(BOOL bActive, BOOL bVertical) const | CXTPDockingPanePaintManager |
GetPaneCaptionRect(const CXTPDockingPaneSidePanel *pPane) | CXTPDockingPaneOffice2003Theme | virtual
GetPanelPaintManager() const | CXTPDockingPanePaintManager |
GetSplitterStyle() const | CXTPDockingPanePaintManager |
GetTabPaintManager() const | CXTPDockingPanePaintManager |
GetTabsHeight() const | CXTPDockingPanePaintManager |
GetXtremeColor(UINT nIndex) | CXTPDockingPanePaintManager |
Line(CDC *pDC, int x0, int y0, int x1, int y1, int nPen) | CXTPDockingPanePaintManager |
Line(CDC *pDC, int x0, int y0, int x1, int y1) | CXTPDockingPanePaintManager |
m_arrColor | CXTPDockingPanePaintManager | protected
m_bDestroyCustomTitleBrushes | CXTPDockingPanePaintManager | protected
m_bDrawCaptionIcon | CXTPDockingPanePaintManager |
m_bDrawGripper | CXTPDockingPaneOffice2003Theme |
m_bDrawSingleTab | CXTPDockingPanePaintManager |
m_bGradientCaption | CXTPDockingPaneVisualStudio2003Theme | protected
m_bHighlightActiveCaption | CXTPDockingPanePaintManager |
m_bLunaTheme | CXTPDockingPanePaintManager | protected
m_bRoundedCaption | CXTPDockingPaneOffice2003Theme | protected
m_bShowCaption | CXTPDockingPanePaintManager |
m_bUseBoldCaptionFont | CXTPDockingPanePaintManager |
m_bUseOfficeFont | CXTPDockingPanePaintManager | protected
m_bUseStandardFont | CXTPDockingPanePaintManager | protected
m_clrActiveCaption | CXTPDockingPanePaintManager |
m_clrActiveCaptionText | CXTPDockingPanePaintManager |
m_clrBackground | CXTPDockingPanePaintManager |
m_clrDisabledCaptionText | CXTPDockingPanePaintManager |
m_clrNormalCaption | CXTPDockingPanePaintManager |
m_clrNormalCaptionText | CXTPDockingPanePaintManager |
m_clrSplitter | CXTPDockingPanePaintManager |
m_clrSplitterGradient | CXTPDockingPanePaintManager |
m_clrSplitterGripper | CXTPDockingPanePaintManager |
m_dwSplitterStyle | CXTPDockingPanePaintManager | protected
m_hbrActiveTitleHorz | CXTPDockingPanePaintManager | protected
m_hbrActiveTitleVert | CXTPDockingPanePaintManager | protected
m_hbrInactiveTitleHorz | CXTPDockingPanePaintManager | protected
m_hbrInactiveTitleVert | CXTPDockingPanePaintManager | protected
m_nCaptionButtonStyle | CXTPDockingPanePaintManager | protected
m_nCaptionFontGap | CXTPDockingPanePaintManager | protected
m_nSplitterIndent | CXTPDockingPanePaintManager |
m_nSplitterSize | CXTPDockingPanePaintManager |
m_nTabsHeight | CXTPDockingPanePaintManager | protected
m_nTitleHeight | CXTPDockingPanePaintManager | protected
m_pPanelPaintManager | CXTPDockingPanePaintManager | protected
m_pTabPaintManager | CXTPDockingPanePaintManager | protected
m_rcCaptionMargin | CXTPDockingPanePaintManager | protected
m_strOfficeFont | CXTPDockingPanePaintManager | protected
m_systemTheme | CXTPDockingPanePaintManager | protected
m_themeButton | CXTPDockingPanePaintManager | protected
m_themeCurrent | CXTPDockingPanePaintManager | protected
m_themeExplorer | CXTPDockingPanePaintManager | protected
m_themeRebar | CXTPDockingPanePaintManager | protected
m_themeToolbar | CXTPDockingPanePaintManager | protected
m_themeWindow | CXTPDockingPanePaintManager | protected
m_xtpFontTitle | CXTPDockingPanePaintManager | protected
m_xtpFontTitleVertical | CXTPDockingPanePaintManager | protected
PaneHasBorders(CXTPDockingPaneTabbedContainer *pPane) const | CXTPDockingPaneOffice2007WordTheme |
Pixel(CDC *pDC, int xPos, int yPos, int nPen) | CXTPDockingPanePaintManager |
Rectangle(CDC *pDC, CRect rc, int nPenEntry, int nPenBorder) | CXTPDockingPanePaintManager |
RefreshMetrics() | CXTPDockingPaneOffice2007WordTheme | virtual
SetCaptionButtonStyle(XTPDockingPaneCaptionButtonStyle nStyle) | CXTPDockingPanePaintManager |
SetCaptionFontIndirect(LOGFONT *pLogFont, BOOL bUseStandardFont=FALSE) | CXTPDockingPanePaintManager |
SetColors(int cElements, CONST INT *lpaElements, CONST COLORREF *lpaRgbValues) | CXTPDockingPanePaintManager |
SetCustomTitleBrushes(HBRUSH hbrActiveTitleHorz, HBRUSH hbrInactiveTitleHorz=NULL, HBRUSH hbrActiveTitleVert=NULL, HBRUSH hbrInactiveTitleVert=NULL, BOOL bDestroyOnCleanup=FALSE) | CXTPDockingPanePaintManager |
SetLunaTheme(XTPCurrentSystemTheme systemTheme) | CXTPDockingPanePaintManager |
SetPanelPaintManager(CXTPTabPaintManager *pManager) | CXTPDockingPanePaintManager |
SetSplitterStyle(DWORD dwStyle) | CXTPDockingPanePaintManager |
SetTabPaintManager(CXTPTabPaintManager *pManager) | CXTPDockingPanePaintManager |
UseOfficeFont(BOOL bUseOfficeFont) | CXTPDockingPanePaintManager |
~CXTPDockingPaneOffice2003Theme() | CXTPDockingPaneOffice2003Theme | virtual
~CXTPDockingPanePaintManager() | CXTPDockingPanePaintManager | protectedvirtual


Toolkit Pro: Member List

CXTPTcbItem Member List

This is the complete list of members for CXTPTcbItem, including all inherited members.

crTabBack | CXTPTcbItem
crTabSelBack | CXTPTcbItem
crTabSelText | CXTPTcbItem
crTabText | CXTPTcbItem
CXTPTcbItem() | CXTPTcbItem
dwExStyle | CXTPTcbItem
dwStyle | CXTPTcbItem
pWnd | CXTPTcbItem
szCondensedLabel | CXTPTcbItem
szTabLabel | CXTPTcbItem
szToolTipLabel | CXTPTcbItem
uiToolTipId | CXTPTcbItem


Toolkit Pro: Member List

CXTPPropertyGridInplaceSlider Member List

This is the complete list of members for CXTPPropertyGridInplaceSlider, including all inherited members.

CXTPPropertyGridInplaceControl(CXTPPropertyGridItem *pItem) | CXTPPropertyGridInplaceControl |
CXTPPropertyGridInplaceSlider(CXTPPropertyGridItem *pItem) | CXTPPropertyGridInplaceSlider |
GetMax() const | CXTPPropertyGridInplaceSlider |
GetMin() const | CXTPPropertyGridInplaceSlider |
GetSliderCtrl() const | CXTPPropertyGridInplaceSlider |
m_nMax | CXTPPropertyGridInplaceSlider | protected
m_nMin | CXTPPropertyGridInplaceSlider | protected
m_nValue | CXTPPropertyGridInplaceSlider | protected
m_nWidth | CXTPPropertyGridInplaceControl | protected
m_pItem | CXTPPropertyGridInplaceControl | protected
OnAdjustValueRect(CRect &rcValue) | CXTPPropertyGridInplaceSlider | virtual
OnCreateWindow(CRect &rcValue) | CXTPPropertyGridInplaceSlider | virtual
OnDestroyWindow() | CXTPPropertyGridInplaceControl | virtual
OnEditMouseWheel(CEdit *pEdit, short zDelta) | CXTPPropertyGridInplaceSlider | virtual
OnScroll(UINT nSBCode, UINT nPos) | CXTPPropertyGridInplaceSlider | protectedvirtual
OnValueChanged() | CXTPPropertyGridInplaceSlider | virtual
SetMax(int nMax) | CXTPPropertyGridInplaceSlider |
SetMin(int nMin) | CXTPPropertyGridInplaceSlider |


Toolkit Pro: XTPDockingPaneTabColorSet2022.h Source File

  • Source
  • DockingPane
  • TabColorSets
XTPDockingPaneTabColorSet2022.h
Go to the documentation of this file.
1
23#if !defined(__XTPDOCKINGPANETABCOLORSET2022_H__)
24# define __XTPDOCKINGPANETABCOLORSET2022_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPDockingPaneTabColorSet2022 : public CXTPDockingPaneTabColorSet2012
39{
40public:
45 CXTPDockingPaneTabColorSet2022();
46
61 virtual void FillHeader(CDC* pDC, CRect rc, CXTPTabManager* pTabManager);
62};
63
64# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
66#endif // !defined(__XTPDOCKINGPANETABCOLORSET2022_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPDockingPaneTabColorSet2012
Helper class used to initialize default colors for a theme from an .INI resource and handle drawing r...
Definition XTPDockingPaneTabColorSet2012.h:39
CXTPDockingPaneTabColorSet2022
Helper class used to initialize default colors for a theme from an .INI resource and handle drawing r...
Definition XTPDockingPaneTabColorSet2022.h:39
CXTPDockingPaneTabColorSet2022::FillHeader
virtual void FillHeader(CDC *pDC, CRect rc, CXTPTabManager *pTabManager)
This member is called to fill the header of the TabClient of the tab manager.
CXTPDockingPaneTabColorSet2022::CXTPDockingPaneTabColorSet2022
CXTPDockingPaneTabColorSet2022()
Default class constructor.
CXTPTabManager
CXTPTabManager is the base class for docking pane tabs, tab control tabs, and MDI client tabs.
Definition XTPTabManager.h:87


Toolkit Pro: XTPSkinObjectButton.h Source File

  • Source
  • SkinFramework
XTPSkinObjectButton.h
Go to the documentation of this file.
1
23#if !defined(_XTPSKINOBJECTBUTTON_H__)
24# define _XTPSKINOBJECTBUTTON_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPSkinObjectButton : public CXTPSkinObjectFrame
39{
41 DECLARE_DYNCREATE(CXTPSkinObjectButton)
43public:
48 CXTPSkinObjectButton();
49
54 virtual ~CXTPSkinObjectButton();
55
56protected:
58 BOOL OnHookMessage(UINT nMessage, WPARAM& wParam, LPARAM& lParam, LRESULT& lResult);
59 void OnSkinChanged(BOOL bPrevState, BOOL bNewState);
60 BOOL OnHookDefWindowProc(UINT nMessage, WPARAM& wParam, LPARAM& lParam, LRESULT& lResult);
61 BOOL IsDefWindowProcAvail(int nMessage) const;
62
63protected:
64 virtual void OnDraw(CDC* pDC, CRect rc);
65 BOOL IsPushButton();
66 DWORD GetAlignment();
67 void CalcRect(CDC* pDC, LPRECT lprc, int code);
68 void ButtonDrawCheck(CDC* pDC);
69 CSize GetGlyphSize(BOOL bCheckBox);
70 void DrawButtonText(CDC* pDC, int nPart, int nState);
71
72 BYTE GetButtonStyle();
73 void OnDraw(CDC* pDC);
74
75protected:
76 DECLARE_MESSAGE_MAP()
77 //{{AFX_VIRTUAL(CXTPSkinObjectButton)
78 //}}AFX_VIRTUAL
79
80 //{{AFX_MSG(CXTPSkinObjectButton)
81 afx_msg BOOL OnEraseBkgnd(CDC* pDC);
82 afx_msg void OnMouseMove(UINT nFlags, CPoint point);
83 afx_msg int OnCreate(LPCREATESTRUCT lpCreateStruct);
84 afx_msg void OnSetFocus(CWnd* pOldWnd);
85 afx_msg void OnKillFocus(CWnd* pNewWnd);
86 afx_msg void OnPaint();
87 afx_msg LRESULT OnSetState(WPARAM wParam, LPARAM lParam);
88 afx_msg LRESULT OnSetText(WPARAM wParam, LPARAM lParam);
89 afx_msg void OnMouseLeave();
90 afx_msg void OnInvalidate();
91 afx_msg void OnDefaultAndInvalidate();
92 afx_msg LRESULT OnUpdateUIState(WPARAM wParam, LPARAM lParam);
93 afx_msg LRESULT OnPrintClient(WPARAM wParam, LPARAM lParam);
94 //}}AFX_MSG
97public:
98 BYTE m_bStyle;
100protected:
101 BOOL m_bHot;
102 BOOL m_bPushed;
103};
104
105# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
107#endif // !defined(_XTPSKINOBJECTBUTTON_H__)
XTPDisableNoisyWarnings.h
CXTPSkinObjectButton
CXTPSkinObjectButton is a CXTPSkinObjectFrame derived class.
Definition XTPSkinObjectButton.h:39
CXTPSkinObjectButton::~CXTPSkinObjectButton
virtual ~CXTPSkinObjectButton()
Destroys a CXTPSkinObjectButton object, handles cleanup and deallocation.
CXTPSkinObjectButton::CXTPSkinObjectButton
CXTPSkinObjectButton()
Constructs a CXTPSkinObjectButton object.
CXTPSkinObjectFrame
CXTPSkinObjectFrame is a CXTPSkinObject derived class.
Definition XTPSkinObjectFrame.h:75
CXTPSkinObjectFrame::OnSkinChanged
virtual void OnSkinChanged(BOOL bPrevState, BOOL bNewState)
This method is called when the skin is changed.


Toolkit Pro: Member List

CXTPCalendarTLV_TimeScaleParams_WorkWeek Member List

This is the complete list of members for CXTPCalendarTLV_TimeScaleParams_WorkWeek, including all inherited members.

CalcScaleIntervalBegin(COleDateTime dtStart) | CXTPCalendarTLV_TimeScaleParams | virtual
CXTPCalendarTLV_TimeScaleParams(int nTimeScaleParamsID, CXTPCalendarTimeLineViewTimeScale *pTimeScale) | CXTPCalendarTLV_TimeScaleParams |
CXTPCalendarTLV_TimeScaleParams_WorkWeek(CXTPCalendarTimeLineViewTimeScale *pTimeScale) | CXTPCalendarTLV_TimeScaleParams_WorkWeek |
CXTPCmdTarget() | CXTPCmdTarget |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetParentTimeScale() const | CXTPCalendarTLV_TimeScaleParams |
GetPart() const | CXTPCalendarTLV_TimeScaleParams_WorkWeek | virtual
GetScaleInterval() const | CXTPCalendarTLV_TimeScaleParams | virtual
GetScaleIntervalWidth_px() const | CXTPCalendarTLV_TimeScaleParams | virtual
GetTimeLineViewScale() const | CXTPCalendarTLV_TimeScaleParams | virtual
GetTimePerPixel() const | CXTPCalendarTLV_TimeScaleParams | virtual
GetTimeScaleParamsID() const | CXTPCalendarTLV_TimeScaleParams | virtual
m_nScaleIntervalWidth_px | CXTPCalendarTLV_TimeScaleParams | protected
m_scaleInterval | CXTPCalendarTLV_TimeScaleParams | protected
SetScaleInterval(int eType, int nValue) | CXTPCalendarTLV_TimeScaleParams | protected
~CXTPCalendarTLV_TimeScaleParams() | CXTPCalendarTLV_TimeScaleParams | virtual
~CXTPCalendarTLV_TimeScaleParams_WorkWeek() | CXTPCalendarTLV_TimeScaleParams_WorkWeek | virtual


Toolkit Pro: Member List

CXTPDatePickerThemeVisualStudio2017 Member List

This is the complete list of members for CXTPDatePickerThemeVisualStudio2017, including all inherited members.

CalcDayOfWeekRect(CDC *pDC) | CXTPDatePickerPaintManager | virtual
CalcDayRect(CDC *pDC) | CXTPDatePickerPaintManager | virtual
CalcMonthHeaderRect(CDC *pDC) | CXTPDatePickerPaintManager | virtual
CalcMonthRect(CDC *pDC) | CXTPDatePickerPaintManager | virtual
CalcWeekNumbersRect(CDC *pDC) | CXTPDatePickerPaintManager | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPDatePickerPaintManager() | CXTPDatePickerPaintManager |
CXTPDatePickerThemeOffice2013() | CXTPDatePickerThemeOffice2013 |
CXTPDatePickerThemeVisualStudio2017() | CXTPDatePickerThemeVisualStudio2017 |
DrawBackground(CDC *pDC, CRect rcClient) | CXTPDatePickerThemeOffice2013 | virtual
DrawBorder(CDC *pDC, const CXTPDatePickerControl *pControl, CRect &rcClient, BOOL bDraw) | CXTPDatePickerThemeOffice2013 | virtual
DrawButton(CDC *pDC, const CRect &rcButton, const CString &strButton, BOOL bIsDown, BOOL bIsHighLight) | CXTPDatePickerThemeOffice2013 | virtual
DrawDay(CDC *pDC, CXTPDatePickerItemDay *pDay) | CXTPDatePickerThemeOffice2013 | virtual
DrawDaysOfWeek(CDC *pDC, CXTPDatePickerItemMonth *pMonth) | CXTPDatePickerThemeOffice2013 | virtual
DrawMonthHeader(CDC *pDC, CXTPDatePickerItemMonth *pMonth) | CXTPDatePickerPaintManager | virtual
DrawScrollTriangle(CDC *pDC, CRect rcSpot, BOOL bLeftDirection, COLORREF clrColor=0, BOOL bYears=FALSE) | CXTPDatePickerPaintManager | virtual
DrawWeekNumbers(CDC *pDC, CXTPDatePickerItemMonth *pMonth) | CXTPDatePickerThemeOffice2013 | virtual
EnableTheme(BOOL bEnableTheme) | CXTPDatePickerPaintManager | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetButtonFont() | CXTPDatePickerPaintManager |
GetControlBackColor() | CXTPDatePickerPaintManager | virtual
GetCursorBack() | CXTPDatePickerPaintManager | virtual
GetDayBackColor() | CXTPDatePickerPaintManager | virtual
GetDaysOfWeekBackColor() | CXTPDatePickerPaintManager | virtual
GetDaysOfWeekTextColor() | CXTPDatePickerPaintManager | virtual
GetDaysOfWeekTextFont() | CXTPDatePickerPaintManager |
GetDayTextColor() | CXTPDatePickerPaintManager | virtual
GetDayTextFont() | CXTPDatePickerPaintManager | virtual
GetDayTextFontBold() | CXTPDatePickerPaintManager | virtual
GetHeaderTextFont() | CXTPDatePickerPaintManager |
GetHighlightTodayBackColor() | CXTPDatePickerThemeOffice2013 | virtual
GetHighlightTodayBorderColor() | CXTPDatePickerThemeOffice2013 | virtual
GetHighlightTodayColor() | CXTPDatePickerPaintManager | virtual
GetHighlightTodayTextColor() | CXTPDatePickerThemeOffice2013 | virtual
GetListControlBackColor() | CXTPDatePickerPaintManager | virtual
GetListControlTextColor() | CXTPDatePickerPaintManager | virtual
GetListControlTextFont() | CXTPDatePickerPaintManager |
GetMonthHeaderBackColor() | CXTPDatePickerPaintManager | virtual
GetMonthHeaderTextColor() | CXTPDatePickerPaintManager | virtual
GetNonMonthDayBackColor() | CXTPDatePickerPaintManager | virtual
GetNonMonthDayTextColor() | CXTPDatePickerPaintManager | virtual
GetNonMonthDayTextFont() | CXTPDatePickerPaintManager |
GetPaintTheme() const | CXTPDatePickerPaintManager | protected
GetSelectedDayBackColor() | CXTPDatePickerPaintManager | virtual
GetSelectedDayTextColor() | CXTPDatePickerPaintManager | virtual
GetWeekNumbersBackColor() | CXTPDatePickerPaintManager | virtual
GetWeekNumbersTextColor() | CXTPDatePickerPaintManager | virtual
GetWeekNumbersTextFont() | CXTPDatePickerPaintManager |
m_bEnableTheme | CXTPDatePickerPaintManager | protected
m_clr3DFace | CXTPDatePickerPaintManager | protected
m_clr3DLight | CXTPDatePickerPaintManager | protected
m_clr3DShadow | CXTPDatePickerPaintManager | protected
m_clr3DText | CXTPDatePickerPaintManager | protected
m_clrBackground | CXTPDatePickerThemeOffice2013 | protected
m_clrButtonFace | CXTPDatePickerPaintManager |
m_clrButtonText | CXTPDatePickerPaintManager |
m_clrControlBack | CXTPDatePickerPaintManager |
m_clrDayBack | CXTPDatePickerPaintManager |
m_clrDaysOfWeekBack | CXTPDatePickerPaintManager |
m_clrDaysOfWeekText | CXTPDatePickerPaintManager |
m_clrDayText | CXTPDatePickerPaintManager |
m_clrHighlightToday | CXTPDatePickerPaintManager |
m_clrListControlBack | CXTPDatePickerPaintManager |
m_clrListControlText | CXTPDatePickerPaintManager |
m_clrMonthBorder | CXTPDatePickerPaintManager |
m_clrMonthHeaderBack | CXTPDatePickerPaintManager |
m_clrMonthHeaderButton | CXTPDatePickerPaintManager |
m_clrMonthHeaderText | CXTPDatePickerPaintManager |
m_clrNonMonthDayBack | CXTPDatePickerPaintManager |
m_clrNonMonthDayText | CXTPDatePickerPaintManager |
m_clrSelectedDayBack | CXTPDatePickerPaintManager |
m_clrSelectedDayText | CXTPDatePickerPaintManager |
m_clrStaticBorder | CXTPDatePickerPaintManager | protected
m_clrWeekNumbersBack | CXTPDatePickerPaintManager |
m_clrWeekNumbersText | CXTPDatePickerPaintManager |
m_hCursorBack | CXTPDatePickerPaintManager | protected
m_nPaintTheme | CXTPDatePickerPaintManager | protected
m_szDayMargin | CXTPDatePickerPaintManager |
m_themeButton | CXTPDatePickerPaintManager | protected
m_xtpFontButton | CXTPDatePickerPaintManager | protected
m_xtpFontDay | CXTPDatePickerPaintManager | protected
m_xtpFontDayBold | CXTPDatePickerPaintManager | protected
m_xtpFontDaysOfWeek | CXTPDatePickerPaintManager | protected
m_xtpFontHeader | CXTPDatePickerPaintManager | protected
m_xtpFontListControl | CXTPDatePickerPaintManager | protected
m_xtpFontNonMonthDay | CXTPDatePickerPaintManager | protected
m_xtpFontWeekNumbers | CXTPDatePickerPaintManager | protected
RefreshMetrics() | CXTPDatePickerThemeOffice2013 | virtual
SetButtonFont(CFont *fontButton) | CXTPDatePickerPaintManager |
SetButtonFontIndirect(LOGFONT *lFont) | CXTPDatePickerPaintManager |
SetFontIndirect(LOGFONT *lFont) | CXTPDatePickerPaintManager |
Triangle(CDC *pDC, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clrColor=0) | CXTPDatePickerPaintManager | protectedvirtual
~CXTPDatePickerPaintManager() | CXTPDatePickerPaintManager | virtual
~CXTPDatePickerThemeOffice2013() | CXTPDatePickerThemeOffice2013 | virtual
~CXTPDatePickerThemeVisualStudio2017() | CXTPDatePickerThemeVisualStudio2017 | virtual


Toolkit Pro: XTPChartFunnelSeriesPointView.h Source File

  • Source
  • Chart
  • Styles
  • Funnel
XTPChartFunnelSeriesPointView.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTFUNNELSERIESPOINTVIEW_H__)
24# define __XTPCHARTFUNNELSERIESPOINTVIEW_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Chart/Styles/Funnel/Base/XTPChartFunnelSeriesPointViewBase.h"
32# include "Chart/Styles/Funnel/2D/XTPChart2dFunnelSeriesPointView.h"
33
34// CXTPChart2dFunnelSeriesPointView alias is necessary for naming consistency.
35typedef CXTPChartFunnelSeriesPointView CXTPChart2dFunnelSeriesPointView;
37#endif //#if !defined(__XTPCHARTFUNNELSERIESPOINTVIEW_H__)
XTPChart2dFunnelSeriesPointView.h
XTPChartFunnelSeriesPointViewBase.h
CXTPChartFunnelSeriesPointView
This class abstracts the view of a funnel series point.
Definition XTPChart2dFunnelSeriesPointView.h:49


Toolkit Pro: Member List

CXTPDockingPane Member List

This is the complete list of members for CXTPDockingPane, including all inherited members.

Attach(CWnd *pWnd) | CXTPDockingPane |
AttachView(CWnd *pParentWnd, CRuntimeClass *pViewClass, CDocument *pDocument=NULL, CCreateContext *pContext=NULL) | CXTPDockingPane |
Clone(CXTPDockingPaneLayout *pLayout, CXTPPaneToPaneMap *pMap, DWORD dwIgnoredOptions=0) | CXTPDockingPaneBase | protectedvirtual
Close() | CXTPDockingPane |
ContainPane(CXTPDockingPaneBase *pPane) const | CXTPDockingPaneBase | virtual
Copy(CXTPDockingPane *pPane) | CXTPDockingPane | protectedvirtual
CreateContainer() | CXTPDockingPaneBase | protectedvirtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPDockingPane(CXTPDockingPaneLayout *pLayout) | CXTPDockingPane | protected
CXTPDockingPaneBase(XTPDockingPaneType type, CXTPDockingPaneLayout *pLayout) | CXTPDockingPaneBase | protected
DeletePane() | CXTPDockingPane | protectedvirtual
Detach() | CXTPDockingPane |
DoPropExchange(CXTPPropExchange *pPX) | CXTPDockingPane | protectedvirtual
FindCaptionButton(int nID) const | CXTPDockingPaneBase |
FindPane(XTPDockingPaneType type, CXTPDockingPaneBaseList *pList) const | CXTPDockingPaneBase | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCaptionButtons() const | CXTPDockingPaneBase |
GetChild() const | CXTPDockingPane |
GetContainer() const | CXTPDockingPaneBase |
GetDockingPaneManager() const | CXTPDockingPaneBase |
GetDockingSite() const | CXTPDockingPane | virtual
GetEnabled() const | CXTPDockingPane |
GetIcon(int nWidth=16) const | CXTPDockingPane | virtual
GetIconID() const | CXTPDockingPane |
GetID() const | CXTPDockingPane |
GetItemColor() const | CXTPDockingPane | virtual
GetMinMaxInfo(LPMINMAXINFO pMinMaxInfo) const | CXTPDockingPane | virtual
GetOptions() const | CXTPDockingPane |
GetPaintManager() const | CXTPDockingPaneBase |
GetPaneData() const | CXTPDockingPane |
GetPaneHwnd() const | CXTPDockingPaneBase | virtual
GetPaneWindowRect() const | CXTPDockingPaneBase |
GetParentFrame() const | CXTPDockingPane |
GetTabCaption() const | CXTPDockingPane | virtual
GetTitle() const | CXTPDockingPane | virtual
GetTitleToolTip() const | CXTPDockingPane | virtual
GetType() const | CXTPDockingPaneBase |
Hide() | CXTPDockingPane |
InvalidatePane(BOOL bSelectionChanged) | CXTPDockingPaneBase | virtual
IsActive() const | CXTPDockingPaneBase | virtual
IsCaptionButtonVisible(CXTPDockingPaneCaptionButton *pButton) | CXTPDockingPaneBase | protectedvirtual
IsCaptionVertical() const | CXTPDockingPaneBase | virtual
IsClosed() const | CXTPDockingPane |
IsEmpty() const | CXTPDockingPaneBase | virtual
IsFloating() const | CXTPDockingPane |
IsFocus() const | CXTPDockingPane |
IsHidden() const | CXTPDockingPane | virtual
IsSelected() const | CXTPDockingPane |
IsSidePanel() const | CXTPDockingPane |
IsTabsVisible() const | CXTPDockingPane |
IsValid() const | CXTPDockingPane |
m_bEnabled | CXTPDockingPane | protected
m_clrItemTab | CXTPDockingPane | protected
m_dwData | CXTPDockingPane | protected
m_dwOptions | CXTPDockingPane | protected
m_hwndChild | CXTPDockingPane | protected
m_nIconID | CXTPDockingPane | protected
m_nID | CXTPDockingPane | protected
m_nIDHelp | CXTPDockingPane | protected
m_pCaptionButtons | CXTPDockingPaneBase | protected
m_pDockingSite | CXTPDockingPaneBase | protected
m_pLayout | CXTPDockingPaneBase | protected
m_pParentContainer | CXTPDockingPaneBase | protected
m_ptMaxTrackSize | CXTPDockingPane | protected
m_ptMinTrackSize | CXTPDockingPane | protected
m_rcWindow | CXTPDockingPaneBase | protected
m_strTabCaption | CXTPDockingPane | protected
m_strTitle | CXTPDockingPane | protected
m_strTitleToolTip | CXTPDockingPane | protected
m_szDocking | CXTPDockingPaneBase | protected
m_type | CXTPDockingPaneBase | protected
OnCaptionButtonRectChanged(CXTPDockingPaneCaptionButton *pButton) | CXTPDockingPaneBase | protectedvirtual
OnChildContainerChanged(CXTPDockingPaneBase *pContainer) | CXTPDockingPaneBase | protectedvirtual
OnFocusChanged() | CXTPDockingPaneBase | protectedvirtual
OnParentContainerChanged(CXTPDockingPaneBase *pContainer) | CXTPDockingPaneBase | protectedvirtual
OnSizeParent(CWnd *pParent, CRect rect, LPVOID lParam) | CXTPDockingPane | protectedvirtual
RedrawPane() | CXTPDockingPaneBase | virtual
RemovePane(CXTPDockingPaneBase *pPane) | CXTPDockingPaneBase | protectedvirtual
Select() | CXTPDockingPane |
SetDockingSite(CWnd *pFrame) | CXTPDockingPaneBase | protectedvirtual
SetEnabled(XTPDockingPaneEnableOptions nState) | CXTPDockingPane |
SetFocus() | CXTPDockingPane | virtual
SetHelpID(int nIDR) | CXTPDockingPane |
SetIconID(UINT nID) | CXTPDockingPane |
SetID(int nID) | CXTPDockingPane | protected
SetItemColor(COLORREF clr) | CXTPDockingPane |
SetMaxTrackSize(CSize sz) | CXTPDockingPane |
SetMinTrackSize(CSize sz) | CXTPDockingPane |
SetOptions(DWORD dwOptions) | CXTPDockingPane |
SetPaneData(DWORD_PTR dwData) | CXTPDockingPane |
SetParentContainer(CXTPDockingPaneBase *pContainer) | CXTPDockingPane | protectedvirtual
SetTabCaption(LPCTSTR lpszTabCaption) | CXTPDockingPane |
SetTitle(LPCTSTR lpszTitle) | CXTPDockingPane |
SetTitleToolTip(LPCTSTR lpszTitleToolTip) | CXTPDockingPane |
SetWindowRect(CRect rc) | CXTPDockingPane | protected
ShowWindow(BOOL bShow) | CXTPDockingPane | protected
~CXTPDockingPane() | CXTPDockingPane | protectedvirtual
~CXTPDockingPaneBase() | CXTPDockingPaneBase | protectedvirtual


Toolkit Pro: Member List

CXTPPropertyGridInplaceControls Member List

This is the complete list of members for CXTPPropertyGridInplaceControls, including all inherited members.

Add(CXTPPropertyGridInplaceControl *pWindow) | CXTPPropertyGridInplaceControls |
CXTPPropertyGridInplaceControls() | CXTPPropertyGridInplaceControls |
GetAt(int nIndex) | CXTPPropertyGridInplaceControls |
GetCount() const | CXTPPropertyGridInplaceControls |
m_arrControls | CXTPPropertyGridInplaceControls | protected
RemoveAll() | CXTPPropertyGridInplaceControls |
~CXTPPropertyGridInplaceControls() | CXTPPropertyGridInplaceControls |


Toolkit Pro: XTPChartTextDeviceCommand.h Source File

  • Source
  • Chart
  • Drawing
XTPChartTextDeviceCommand.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTTEXTDEVICECOMMAND_H__)
24# define __XTPCHARTTEXTDEVICECOMMAND_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPMarkupUIElement;
34
40class _XTP_EXT_CLASS CXTPChartTextDeviceCommand : public CXTPChartDeviceCommand
41{
42protected:
51 CXTPChartTextDeviceCommand(const CXTPChartString& strText, CXTPChartFont* pFont,
52 const CXTPChartColor& color);
53
62 virtual void ExecuteOverride(CXTPChartDeviceContext* pDC);
63
71 virtual void ExecuteInternal(CXTPChartDeviceContext* pDC);
72
73protected:
74 CXTPChartString m_strText;
75 CXTPChartFont* m_pFont;
76 CXTPChartColor m_color;
77};
78
84class _XTP_EXT_CLASS CXTPChartTextAntialiasingDeviceCommand : public CXTPChartDeviceCommand
85{
86public:
94 CXTPChartTextAntialiasingDeviceCommand(BOOL bAntialias = TRUE);
95
96protected:
97 BOOL m_bAntiAlias;
98 int m_nOldTextRenderingHint;
99};
100
106class _XTP_EXT_CLASS CXTPChartBoundedTextDeviceCommand : public CXTPChartTextDeviceCommand
107{
108public:
118 CXTPChartBoundedTextDeviceCommand(const CXTPChartString& strText, CXTPChartFont* pFont,
119 const CXTPChartColor& color, const CXTPChartRectF& rectangle);
120
131 virtual CXTPChartElement* HitTest(CPoint point, CXTPChartElement* pParent) const;
132
133protected:
134 CXTPChartRectF m_rect;
135};
136
141class _XTP_EXT_CLASS CXTPChartMarkupElementDeviceCommand : public CXTPChartDeviceCommand
142{
143public:
153 CXTPChartMarkupElementDeviceCommand(CXTPMarkupUIElement* pMarkupUIElement, CXTPChartFont* pFont,
154 const CXTPChartColor& color,
155 const CXTPChartRectF& rectangle);
156
161 ~CXTPChartMarkupElementDeviceCommand();
162
173 CXTPChartElement* HitTest(CPoint point, CXTPChartElement* pParent) const;
174
175protected:
176 CXTPChartRectF m_rect;
177 CXTPMarkupUIElement* m_pMarkupUIElement;
178 CXTPChartColor m_color;
179 CXTPChartFont* m_pFont;
180};
182# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
183#endif //#if !defined(__XTPCHARTTEXTDEVICECOMMAND_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartBoundedTextDeviceCommand
This class represents a bounded text device command, which is a kind of CXTPChartDeviceCommand.
Definition XTPChartTextDeviceCommand.h:107
CXTPChartBoundedTextDeviceCommand::CXTPChartBoundedTextDeviceCommand
CXTPChartBoundedTextDeviceCommand(const CXTPChartString &strText, CXTPChartFont *pFont, const CXTPChartColor &color, const CXTPChartRectF &rectangle)
Constructs a CXTPChartBoundedTextDeviceCommand object.
CXTPChartBoundedTextDeviceCommand::m_rect
CXTPChartRectF m_rect
The bounding rectangle of the text.
Definition XTPChartTextDeviceCommand.h:134
CXTPChartBoundedTextDeviceCommand::HitTest
virtual CXTPChartElement * HitTest(CPoint point, CXTPChartElement *pParent) const
Performs recursive hit testing of the element at the specified point.
CXTPChartColor
This class abstracts a color entity.
Definition XTPChartTypes.h:51
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartElement
This class abstracts a chart element, this class acts as a base class for all chart elements.
Definition XTPChartElement.h:131
CXTPChartFont
This class abstracts a font entity.
Definition XTPChartTypes.h:540
CXTPChartMarkupElementDeviceCommand
Implements 2D markup element drawing device command.
Definition XTPChartTextDeviceCommand.h:142
CXTPChartMarkupElementDeviceCommand::m_pFont
CXTPChartFont * m_pFont
The default font of the text.
Definition XTPChartTextDeviceCommand.h:179
CXTPChartMarkupElementDeviceCommand::HitTest
CXTPChartElement * HitTest(CPoint point, CXTPChartElement *pParent) const
Performs recursive hit testing of the element at the specified point.
CXTPChartMarkupElementDeviceCommand::CXTPChartMarkupElementDeviceCommand
CXTPChartMarkupElementDeviceCommand(CXTPMarkupUIElement *pMarkupUIElement, CXTPChartFont *pFont, const CXTPChartColor &color, const CXTPChartRectF &rectangle)
Constructs a CXTPChartMarkupElementDeviceCommand object.
CXTPChartMarkupElementDeviceCommand::m_color
CXTPChartColor m_color
The default color of the text.
Definition XTPChartTextDeviceCommand.h:178
CXTPChartMarkupElementDeviceCommand::m_rect
CXTPChartRectF m_rect
The bounding rectangle of the text.
Definition XTPChartTextDeviceCommand.h:176
CXTPChartMarkupElementDeviceCommand::m_pMarkupUIElement
CXTPMarkupUIElement * m_pMarkupUIElement
Markup element to draw.
Definition XTPChartTextDeviceCommand.h:177
CXTPChartMarkupElementDeviceCommand::~CXTPChartMarkupElementDeviceCommand
~CXTPChartMarkupElementDeviceCommand()
HAndles object deallocation.
CXTPChartTextAntialiasingDeviceCommand
This class represents a text device command, which is a kind of CXTPChartDeviceCommand.
Definition XTPChartTextDeviceCommand.h:85
CXTPChartTextAntialiasingDeviceCommand::CXTPChartTextAntialiasingDeviceCommand
CXTPChartTextAntialiasingDeviceCommand(BOOL bAntialias=TRUE)
Constructs a CXTPChartTextAntialiasingDeviceCommand object.
CXTPChartTextAntialiasingDeviceCommand::m_bAntiAlias
BOOL m_bAntiAlias
TRUE if antialiasing is enabled, FALSE if antialiasing is not used.
Definition XTPChartTextDeviceCommand.h:97
CXTPChartTextDeviceCommand
This class represents a text device command, which is a kind of CXTPChartDeviceCommand.
Definition XTPChartTextDeviceCommand.h:41
CXTPChartTextDeviceCommand::m_pFont
CXTPChartFont * m_pFont
The font used to render the text.
Definition XTPChartTextDeviceCommand.h:75
CXTPChartTextDeviceCommand::CXTPChartTextDeviceCommand
CXTPChartTextDeviceCommand(const CXTPChartString &strText, CXTPChartFont *pFont, const CXTPChartColor &color)
Constructs a CXTPChartTextDeviceCommand object.
CXTPChartTextDeviceCommand::ExecuteInternal
virtual void ExecuteInternal(CXTPChartDeviceContext *pDC)
This function does the actual drawing of the chart element to which this device command is associated...
CXTPChartTextDeviceCommand::m_strText
CXTPChartString m_strText
The string to be rendered.
Definition XTPChartTextDeviceCommand.h:74
CXTPChartTextDeviceCommand::m_color
CXTPChartColor m_color
The color of the text.
Definition XTPChartTextDeviceCommand.h:76
CXTPChartTextDeviceCommand::ExecuteOverride
virtual void ExecuteOverride(CXTPChartDeviceContext *pDC)
This is a virtual function override of base class CXTPChartDeviceContext.
CXTPMarkupUIElement
Base class for XML Markup core level implementations.
Definition XTPMarkupUIElement.h:43
CXTPRectT< float >


Toolkit Pro: XTPListBoxThemeNativeWindows11.h Source File

  • Source
  • Controls
  • ListBox
  • Themes
XTPListBoxThemeNativeWindows11.h
Go to the documentation of this file.
1
23#if !defined(__XTPLISTBOXTHEMENATIVEWINDOWS11_H__)
24# define __XTPLISTBOXTHEMENATIVEWINDOWS11_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPListBoxThemeNativeWindows11 : public CXTPListBoxThemeOffice2013
39{
40public:
45 CXTPListBoxThemeNativeWindows11();
46};
47
48# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
50#endif // !defined(__XTPLISTBOXTHEMENATIVEWINDOWS11_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPListBoxThemeNativeWindows11
CXTPListBoxThemeNativeWindows11 is used by CXTPListBox to draw a Native Windows 10 style list box.
Definition XTPListBoxThemeNativeWindows11.h:39
CXTPListBoxThemeNativeWindows11::CXTPListBoxThemeNativeWindows11
CXTPListBoxThemeNativeWindows11()
Default constructor.
CXTPListBoxThemeOffice2013
CXTPListBoxThemeOffice2013 is used by CXTPListBox to draw an Office 2013 style list box.
Definition XTPListBoxThemeOffice2013.h:39


Toolkit Pro: Member List

CXTPChartDateTimeScaleTypeMap Member List

This is the complete list of members for CXTPChartDateTimeScaleTypeMap, including all inherited members.

Create(CXTPChartAxis *pAxis) | CXTPChartScaleTypeMap | static
CXTPChartElement() | CXTPChartElement |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartScaleTypeMap(CXTPChartAxis *pAxis) | CXTPChartScaleTypeMap |
DoPropExchange(CXTPPropExchange *pPX) | CXTPChartElement | virtual
GetAppearance() const | CXTPChartElement |
GetAxis() const | CXTPChartScaleTypeMap |
GetContent() const | CXTPChartElement |
GetOwner() const | CXTPChartElement |
InternalToValue(CXTPChartNumberFormat *pFromat, double dValue) const | CXTPChartDateTimeScaleTypeMap | virtual
Is3D() const | CXTPChartObject |
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartElement | virtual
Release() | CXTPChartElement | virtual
UpdateSeries(CXTPChartAxisView *pAxisView) | CXTPChartScaleTypeMap | virtual
UpdateSeries(CXTPChartSeries *pSeries) | CXTPChartScaleTypeMap | virtual
UpdateSeriesPointArgument(CXTPChartSeriesPoint *pPoint) | CXTPChartDateTimeScaleTypeMap | protectedvirtual
ValueToInternal(const CXTPChartString &strValue) const | CXTPChartDateTimeScaleTypeMap | virtual
~CXTPChartElement() | CXTPChartElement | virtual
~CXTPChartScaleTypeMap() | CXTPChartScaleTypeMap | virtual


Toolkit Pro: XTPPopupBar.h Source File

  • Source
  • CommandBars
XTPPopupBar.h
Go to the documentation of this file.
1
23#if !defined(__XTPPOPUPBAR_H__)
24# define __XTPPOPUPBAR_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPControlPopup;
34class CXTPCommandBars;
35
41class _XTP_EXT_CLASS CXTPPopupBar : public CXTPCommandBar
42{
44 DECLARE_XTP_COMMANDBAR(CXTPPopupBar)
47private:
48 class CControlExpandButton;
49
50protected:
55 CXTPPopupBar();
56
61 virtual ~CXTPPopupBar();
62
63public:
71 static CXTPPopupBar* AFX_CDECL CreatePopupBar(CXTPCommandBars* pCommandBars);
72
73public:
81 void SetTearOffPopup(LPCTSTR lpszCaption, UINT nID, int nWidth = 400);
82
92 BOOL IsTearOffPopup(CString& strCaption, UINT& nID, int& nWidth);
93
101 virtual BOOL IsVisible() const;
102
112 BOOL Popup(int xPos, int yPos, LPCRECT rcExclude);
113
122 BOOL Popup(CXTPControlPopup* pControlPopup, BOOL bSelectFirst = FALSE);
123
130 CXTPControlPopup* GetControlPopup() const;
131
136 void ExpandBar();
137
144 BOOL DestroyWindow();
145
151 void SetPopupToolBar(BOOL bToolBarType);
152
163 void SetDefaultItem(UINT uItem, BOOL fByPos = FALSE);
164
178 UINT GetDefaultItem(UINT gmdiFlags, BOOL fByPos = FALSE);
179
186 BOOL IsDoubleGripper() const;
187
193 void SetDoubleGripper(BOOL bDoubleGripper = TRUE);
194
203 virtual BOOL IsPopupBar() const;
204
213 BOOL IsContextMenu() const;
214
219 void PumpMessage();
220
230 virtual CSize CalcDynamicLayout(int nLength, DWORD dwMode);
231
238 virtual BOOL Create();
239
248 virtual CRect CalculatePopupRect(CPoint ptPopup, CSize sz);
249
257 void SetPopupFlags(DWORD dwPopupFlags);
258
270 virtual BOOL SetTrackingMode(int bMode, BOOL bSelectFirst = TRUE, BOOL bKeyboard = FALSE);
271
272protected:
277 virtual void DelayRedraw()
278 {
279 Redraw();
280 }
281
290 virtual BOOL SetSelected(int nSelected, BOOL bKeyboard = FALSE);
291
297 void UpdateLocation(CSize sz);
298
303 virtual void UpdateFlags();
304
309 void UpdateExpandingState();
310
317 virtual void DrawCommandBar(CDC* pDC, CRect rcClipBox);
318
323 virtual void OnControlsChanged();
324
329 virtual void OnRecalcLayout();
330
337 CXTPCommandBar* GetParentCommandBar() const;
338
344 virtual void DoPropExchange(CXTPPropExchange* pPX);
345
352 virtual void Copy(CXTPCommandBar* pCommandBar, BOOL bRecursive = FALSE);
353
362 virtual BOOL OnHookKeyDown(UINT nChar, LPARAM lParam);
363
370 virtual void AdjustExcludeRect(CRect& rc, BOOL bVertical);
371
372public:
378 void SetBorders(CRect rcBorders);
379
384 void DisableShadow();
385
392 BOOL IsResizable() const;
393
400 virtual CRect GetBorders();
401
402protected:
404 DECLARE_MESSAGE_MAP()
405
406 //{{AFX_MSG(CXTPPopupBar)
407 afx_msg void OnMouseMove(UINT nFlags, CPoint point);
408 afx_msg int OnMouseActivate(CWnd* pDesktopWnd, UINT nHitTest, UINT message);
409 BOOL OnNcActivate(BOOL bActive);
410 afx_msg void OnTimer(UINT_PTR nIDEvent);
411 afx_msg void OnLButtonDown(UINT nFlags, CPoint point);
412 afx_msg BOOL OnSetCursor(CWnd* pWnd, UINT nHitTest, UINT message);
413 afx_msg BOOL OnNcCreate(LPCREATESTRUCT lpCreateStruct);
414 LRESULT OnFloatStatus(WPARAM wParam, LPARAM);
415 //}}AFX_MSG
418protected:
423 virtual void Animate();
424
425private:
426 void AdjustScrolling(LPSIZE lpSize, BOOL bDown = FALSE, BOOL bInvalidate = FALSE);
427 void TrackTearOff();
428 void TrackResize();
429 void RecalcSizeLayout();
430 void SwitchTearOffTracking(BOOL bShow, CPoint point);
431 void _MakeSameWidth(int nStart, int nLast, int nWidth);
432 BOOL _MouseInResizeGripper(const POINT& pt);
433
434 XTPAnimationType GetAnimationType() const;
435
436public:
437 static double m_dMaxWidthDivisor;
439protected:
440 CXTPControlPopup* m_pControlPopup;
441 CPoint m_ptPopup;
442 CRect m_rcExclude;
443 DWORD m_popupFlags;
444 BOOL m_bDynamicLayout;
445 BOOL m_bCollapsed;
446 BOOL m_bExpanded;
447 BOOL m_bExpanding;
449 BOOL m_bTearOffPopup;
450 CRect m_rcTearOffGripper;
451 CRect m_rcResizeGripper;
452 BOOL m_bResizable;
454 BOOL m_bTearOffSelected;
455 UINT_PTR m_nTearOffTimer;
456 BOOL m_bTearOffTracking;
457 CSize m_szTearOffBar;
458 CXTPToolBar* m_pTearOffBar;
459 CString m_strTearOffCaption;
460 UINT m_nTearOffID;
461 int m_nTearOffWidth;
462 BOOL m_bShowShadow;
463 CRect m_rcBorders;
464 BOOL m_bDoubleGripper;
465 BOOL m_bContextMenu;
467 int m_nMaxHeight;
469private:
470 XTP_SCROLLINFO m_scrollInfo;
471
472# ifdef _XTP_COMMANDBARS_ACTIVEX
473 DECLARE_DISPATCH_MAP()
474# endif
475
476private:
477 BOOL Create(LPCTSTR lpszClassName, LPCTSTR lpszWindowName, DWORD dwStyle, const RECT& rect,
478 CWnd* pParentWnd, UINT nID, CCreateContext* pContext = NULL);
479
480 friend class CControlExpandButton;
481 friend class CXTPControlPopup;
482 friend class CXTPCommandBars;
483 friend class CXTPCommandBar;
484 friend class CXTPCommandBarsContextMenus;
485};
486
491class _XTP_EXT_CLASS CXTPPopupToolBar : public CXTPPopupBar
492{
493 DECLARE_XTP_COMMANDBAR(CXTPPopupToolBar)
494
495
499 CXTPPopupToolBar();
500
501public:
509 static CXTPPopupToolBar* AFX_CDECL CreatePopupToolBar(CXTPCommandBars* pCommandBars);
510
511protected:
521 CSize CalcDynamicLayout(int nLength, DWORD dwMode);
522};
523
525
526AFX_INLINE void CXTPPopupBar::DisableShadow()
527{
528 m_bShowShadow = FALSE;
529}
530AFX_INLINE void CXTPPopupBar::SetBorders(CRect rcBorders)
531{
532 m_rcBorders = rcBorders;
533}
534AFX_INLINE BOOL CXTPPopupBar::Create(LPCTSTR lpszClassName, LPCTSTR lpszWindowName, DWORD dwStyle,
535 const RECT& rect, CWnd* pParentWnd, UINT nID,
536 CCreateContext* pContext)
537{
538 return CWnd::Create(lpszClassName, lpszWindowName, dwStyle, rect, pParentWnd, nID, pContext);
539}
540AFX_INLINE BOOL CXTPPopupBar::IsDoubleGripper() const
541{
542 return m_bDoubleGripper;
543}
544AFX_INLINE void CXTPPopupBar::SetDoubleGripper(BOOL bDoubleGripper /*= TRUE*/)
545{
546 m_bDoubleGripper = bDoubleGripper;
547}
548AFX_INLINE CXTPControlPopup* CXTPPopupBar::GetControlPopup() const
549{
550 return m_pControlPopup;
551}
552AFX_INLINE BOOL CXTPPopupBar::IsPopupBar() const
553{
554 return TRUE;
555}
556AFX_INLINE BOOL CXTPPopupBar::IsContextMenu() const
557{
558 return m_bContextMenu;
559}
560AFX_INLINE BOOL CXTPPopupBar::IsResizable() const
561{
562 return m_bResizable;
563}
564AFX_INLINE void CXTPPopupBar::SetPopupFlags(DWORD dwPopupFlags)
565{
566 m_popupFlags = dwPopupFlags;
567}
569# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
570#endif // #if !defined(__XTPPOPUPBAR_H__)
XTPAnimationType
XTPAnimationType
Enumerated type used to determine the animation effect of pop-up bars.
Definition XTPCommandBarsDefines.h:373
DECLARE_XTP_COMMANDBAR
#define DECLARE_XTP_COMMANDBAR(class_name)
This macro generates the C++ header code necessary for a CXTPCommandBar-derived class that can be ser...
Definition XTPCommandBarsDefines.h:1234
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCommandBar
CXTPCommandBar is a CWnd derived class.
Definition XTPCommandBar.h:66
CXTPCommandBar::IsResizable
virtual BOOL IsResizable() const
Specifies whether the pop-up gallery can be resized by the user.
Definition XTPCommandBar.h:1484
CXTPCommandBar::Redraw
virtual void Redraw(LPCRECT lpRect=0, BOOL bAnimate=TRUE)
The framework calls this member function to redraw the command bar.
CXTPCommandBar::IsPopupBar
virtual BOOL IsPopupBar() const
Call this member function to determine if the command bar is a CXTPPopupBar.
Definition XTPCommandBar.h:1467
CXTPCommandBarsContextMenus
CXTPCommandBarsContextMenus is CXTPCommandBarList derived class which represents a collection of cont...
Definition XTPCommandBarsContextMenus.h:39
CXTPCommandBars
CXTPCommandBars is a standalone class.
Definition XTPCommandBars.h:165
CXTPControlPopup
CXTPControlPopup is a CXTPControl derived class.
Definition XTPControlPopup.h:42
CXTPPopupBar
CXTPPopupBar is a CXTPCommandBar derived class.
Definition XTPPopupBar.h:42
CXTPPopupBar::DoPropExchange
virtual void DoPropExchange(CXTPPropExchange *pPX)
Either reads this object from or writes this object to an archive.
CXTPPopupBar::CalculatePopupRect
virtual CRect CalculatePopupRect(CPoint ptPopup, CSize sz)
This method is called to calculate the destination rectangle of the pop-up bar.
CXTPPopupBar::DrawCommandBar
virtual void DrawCommandBar(CDC *pDC, CRect rcClipBox)
This method is called to draw the command bar in the given context.
CXTPPopupBar::m_bContextMenu
BOOL m_bContextMenu
TRUE if pop-up bar is context menu.
Definition XTPPopupBar.h:465
CXTPPopupBar::SetTearOffPopup
void SetTearOffPopup(LPCTSTR lpszCaption, UINT nID, int nWidth=400)
This method adds the tear-off state to the pop-up bar.
CXTPPopupBar::IsVisible
virtual BOOL IsVisible() const
Call this member to determine if the pop-up menu is visible/displayed.
CXTPPopupBar::CXTPPopupBar
CXTPPopupBar()
Constructs a CXTPPopupBar object.
CXTPPopupBar::GetControlPopup
CXTPControlPopup * GetControlPopup() const
Call this member to retrieve the control's pop-up.
Definition XTPPopupBar.h:548
CXTPPopupBar::Popup
BOOL Popup(int xPos, int yPos, LPCRECT rcExclude)
This method opens the pop-up bar.
CXTPPopupBar::m_pControlPopup
CXTPControlPopup * m_pControlPopup
Control that pop-up'ed the bar.
Definition XTPPopupBar.h:440
CXTPPopupBar::OnRecalcLayout
virtual void OnRecalcLayout()
This method is called to recalculate the command bar layout.
CXTPPopupBar::SetSelected
virtual BOOL SetSelected(int nSelected, BOOL bKeyboard=FALSE)
Call this member to select the specified control.
CXTPPopupBar::UpdateFlags
virtual void UpdateFlags()
Update flags.
CXTPPopupBar::SetPopupToolBar
void SetPopupToolBar(BOOL bToolBarType)
Call this method to make the pop-up bar look like a pop-up toolbar.
CXTPPopupBar::CreatePopupBar
static CXTPPopupBar *AFX_CDECL CreatePopupBar(CXTPCommandBars *pCommandBars)
Creates a pop-up bar object.
CXTPPopupBar::~CXTPPopupBar
virtual ~CXTPPopupBar()
Destroys a CXTPPopupBar object, handles cleanup and deallocation.
CXTPPopupBar::IsResizable
BOOL IsResizable() const
Determines if the control can be resized by the user.
Definition XTPPopupBar.h:560
CXTPPopupBar::SetTrackingMode
virtual BOOL SetTrackingMode(int bMode, BOOL bSelectFirst=TRUE, BOOL bKeyboard=FALSE)
Call this member to change the tracking state.
CXTPPopupBar::m_bDoubleGripper
BOOL m_bDoubleGripper
TRUE if pop-up is state pop-up type.
Definition XTPPopupBar.h:464
CXTPPopupBar::OnControlsChanged
virtual void OnControlsChanged()
This method is called when the controls array is changed.
CXTPPopupBar::OnHookKeyDown
virtual BOOL OnHookKeyDown(UINT nChar, LPARAM lParam)
The framework calls this member function when a non-system key is pressed.
CXTPPopupBar::GetParentCommandBar
CXTPCommandBar * GetParentCommandBar() const
Call this member to retrieve the parent command bar.
CXTPPopupBar::DisableShadow
void DisableShadow()
Disables shadow use.
Definition XTPPopupBar.h:526
CXTPPopupBar::SetPopupFlags
void SetPopupFlags(DWORD dwPopupFlags)
Call this method to set the pop-up direction.
Definition XTPPopupBar.h:564
CXTPPopupBar::SetBorders
void SetBorders(CRect rcBorders)
Sets the toolbar's borders.
Definition XTPPopupBar.h:530
CXTPPopupBar::IsContextMenu
BOOL IsContextMenu() const
Determines if the pop-up bar is a context menu.
Definition XTPPopupBar.h:556
CXTPPopupBar::IsPopupBar
virtual BOOL IsPopupBar() const
Call this member function to determine if the command bar is a CXTPPopupBar.
Definition XTPPopupBar.h:552
CXTPPopupBar::IsTearOffPopup
BOOL IsTearOffPopup(CString &strCaption, UINT &nID, int &nWidth)
Determines if the pop-up bar has the tear-off state.
CXTPPopupBar::ExpandBar
void ExpandBar()
This method expands the bar.
CXTPPopupBar::m_bShowShadow
BOOL m_bShowShadow
TRUE to show the shadow.
Definition XTPPopupBar.h:462
CXTPPopupBar::m_bResizable
BOOL m_bResizable
TRUE to allow resize.
Definition XTPPopupBar.h:452
CXTPPopupBar::SetDefaultItem
void SetDefaultItem(UINT uItem, BOOL fByPos=FALSE)
Sets the default menu item for the specified pop-up bar.
CXTPPopupBar::AdjustExcludeRect
virtual void AdjustExcludeRect(CRect &rc, BOOL bVertical)
Updates rectangle to set the position where the child pop-up bar becomes visible.
CXTPPopupBar::UpdateLocation
void UpdateLocation(CSize sz)
This method sets the pop-up bar's position.
CXTPPopupBar::SetDoubleGripper
void SetDoubleGripper(BOOL bDoubleGripper=TRUE)
Call this member to set a double gripper for the pop-up bar.
Definition XTPPopupBar.h:544
CXTPPopupBar::IsDoubleGripper
BOOL IsDoubleGripper() const
Call this method to determine if the pop-up bar has a double gripper.
Definition XTPPopupBar.h:540
CXTPPopupBar::GetDefaultItem
UINT GetDefaultItem(UINT gmdiFlags, BOOL fByPos=FALSE)
Determines the default menu item on the specified pop-up bar.
CXTPPopupBar::PumpMessage
void PumpMessage()
Translates all messages in the message queue.
CXTPPopupBar::m_popupFlags
DWORD m_popupFlags
Flags of the bar.
Definition XTPPopupBar.h:443
CXTPPopupBar::Create
virtual BOOL Create()
Creates the pop-up bar.
CXTPPopupBar::Copy
virtual void Copy(CXTPCommandBar *pCommandBar, BOOL bRecursive=FALSE)
Call this method make a copy of the command bar.
CXTPPopupBar::UpdateExpandingState
void UpdateExpandingState()
Update expanding state.
CXTPPopupBar::CalcDynamicLayout
virtual CSize CalcDynamicLayout(int nLength, DWORD dwMode)
This method is called to get the size of the command bar.
CXTPPopupBar::m_rcBorders
CRect m_rcBorders
Borders of the bar.
Definition XTPPopupBar.h:463
CXTPPopupBar::DestroyWindow
BOOL DestroyWindow()
Call this member to destroy the window.
CXTPPopupBar::Popup
BOOL Popup(CXTPControlPopup *pControlPopup, BOOL bSelectFirst=FALSE)
This method opens the pop-up bar.
CXTPPopupBar::DelayRedraw
virtual void DelayRedraw()
Redraw the pop-up bar.
Definition XTPPopupBar.h:277
CXTPPopupBar::GetBorders
virtual CRect GetBorders()
Call this method to get the border margins of the command bar.
CXTPPopupToolBar
CXTPPopupToolBar is a CXTPPopupBar derived class.
Definition XTPPopupBar.h:492
CXTPPopupToolBar::CreatePopupToolBar
static CXTPPopupToolBar *AFX_CDECL CreatePopupToolBar(CXTPCommandBars *pCommandBars)
Creates a pop-up toolbar object.
CXTPPopupToolBar::CalcDynamicLayout
CSize CalcDynamicLayout(int nLength, DWORD dwMode)
This method is called to get the size of the command bar.
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72
CXTPToolBar
CXTPToolBar is a CXTPCommandBar derived class.
Definition XTPToolBar.h:42


Toolkit Pro: Member List

CXTPChartRadarAxisXViewTick Member List

This is the complete list of members for CXTPChartRadarAxisXViewTick, including all inherited members.

m_dValue | CXTPChartRadarAxisXViewTick
m_strLabel | CXTPChartRadarAxisXViewTick
m_szBounds | CXTPChartRadarAxisXViewTick
m_szLabel | CXTPChartRadarAxisXViewTick


Toolkit Pro: Member List

CXTPComboBoxThemeOffice2013 Member List

This is the complete list of members for CXTPComboBoxThemeOffice2013, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPComboBoxTheme() | CXTPComboBoxTheme |
CXTPComboBoxThemeOffice2003() | CXTPComboBoxThemeOffice2003 |
CXTPComboBoxThemeOffice2013() | CXTPComboBoxThemeOffice2013 |
CXTPComboBoxThemeVisualStudio() | CXTPComboBoxThemeVisualStudio |
CXTPControlTheme() | CXTPControlTheme |
DrawBackground(CDC *pDC, CXTPComboBox *pComboBox) | CXTPComboBoxThemeOffice2013 | virtual
DrawButton(CDC *pDC, CXTPComboBox *pComboBox, CRect rcBtn) | CXTPComboBoxThemeOffice2013 | virtual
DrawButtonTriangle(CDC *pDC, CXTPComboBox *pComboBox, CRect rcBtn) | CXTPComboBoxThemeOffice2013 | virtual
DrawComboBox(CDC *pDC, CXTPComboBox *pComboBox) | CXTPComboBoxTheme | virtual
DrawFrame(HDC hdc, LPRECT lprc, int nSize, HBRUSH hBrush) | CXTPComboBoxTheme | virtual
FillSolidRect(HDC hdc, int x, int y, int cx, int cy, HBRUSH hBrush) | CXTPComboBoxTheme | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetBackColor() const | CXTPComboBoxTheme |
GetBackgroundBrush() const | CXTPComboBoxTheme |
GetTextColor() const | CXTPComboBoxTheme |
GetThemeStyle() const | CXTPControlTheme |
m_clrBackDisabled | CXTPComboBoxTheme |
m_clrBackground | CXTPComboBoxTheme |
m_clrBackHighlight | CXTPComboBoxTheme |
m_clrBorderDisabled | CXTPComboBoxTheme |
m_clrBorderHot | CXTPComboBoxTheme |
m_clrBorderNormal | CXTPComboBoxTheme |
m_clrButtonArrowDisabled | CXTPComboBoxThemeOffice2013 | protected
m_clrButtonArrowHot | CXTPComboBoxTheme |
m_clrButtonArrowNormal | CXTPComboBoxTheme |
m_clrButtonArrowPressed | CXTPComboBoxTheme |
m_clrButtonDisabled | CXTPComboBoxThemeOffice2013 | protected
m_clrButtonHot | CXTPComboBoxTheme |
m_clrButtonNormal | CXTPComboBoxTheme |
m_clrButtonPressed | CXTPComboBoxTheme |
m_clrText | CXTPComboBoxTheme |
m_clrTextDisabled | CXTPComboBoxTheme |
m_clrTextHighlight | CXTPComboBoxTheme |
m_grcButton | CXTPComboBoxTheme |
m_grcButtonHilite | CXTPComboBoxTheme |
m_grcButtonPushed | CXTPComboBoxTheme |
m_nTheme | CXTPControlTheme | protected
m_nThumbWidth | CXTPComboBoxTheme | protected
m_themeComboBox | CXTPComboBoxTheme | protected
m_xtpBrushBackground | CXTPComboBoxTheme | protected
RefreshMetrics(CXTPComboBox *pComboBox) | CXTPComboBoxThemeOffice2013 | virtual
ResetBackColor() | CXTPComboBoxTheme |
ResetTextColor() | CXTPComboBoxTheme |
SetBackColor(COLORREF clrBackground) | CXTPComboBoxTheme |
SetTextColor(COLORREF clrText) | CXTPComboBoxTheme |
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static
UpdateBackgroundBrush() | CXTPComboBoxTheme | protected
~CXTPComboBoxTheme() | CXTPComboBoxTheme | virtual
~CXTPComboBoxThemeOffice2003() | CXTPComboBoxThemeOffice2003 | virtual
~CXTPComboBoxThemeOffice2013() | CXTPComboBoxThemeOffice2013 | virtual
~CXTPComboBoxThemeVisualStudio() | CXTPComboBoxThemeVisualStudio | virtual


Toolkit Pro: XTPChartTitle.h Source File

  • Source
  • Chart
XTPChartTitle.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTTITLE_H__)
24# define __XTPCHARTTITLE_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartDeviceContext;
34class CXTPChartDeviceCommand;
35class CXTPChartFont;
36class CXTPChartElementView;
37class CXTPChartContent;
38class CXTPPropExchange;
43enum XTPChartDocking
44{
45 xtpChartDockTop,
46 xtpChartDockBottom,
47 xtpChartDockLeft,
48 xtpChartDockRight
49};
50
55class _XTP_EXT_CLASS CXTPChartTitle : public CXTPChartTextElement
56{
58 DECLARE_DYNAMIC(CXTPChartTitle)
60public:
65 CXTPChartTitle();
66
71 virtual ~CXTPChartTitle();
72
73public:
81 void SetVisible(BOOL bVisible);
82
90 BOOL IsVisible() const;
91
101 void SetText(LPCTSTR lpszTitle);
102
113 CXTPChartString GetText() const;
114
125 void SetTextColor(const CXTPChartColor& clrTextColor);
126
138 CXTPChartColor GetTextColor() const;
139
150 CXTPChartColor GetActualTextColor() const;
151
161 void SetFont(CXTPChartFont* pFont);
162
173 CXTPChartFont* GetFont() const;
174
185 void SetDocking(XTPChartDocking nDocking);
186
198 XTPChartDocking GetDocking() const;
199
209 void SetIndent(int nIndent);
210
221 int GetIndent() const;
222
233 void SetAlignment(XTPChartStringAlignment nAlignment);
234
247 XTPChartStringAlignment GetAlignment() const;
248
257 void SetAntialiasing(BOOL bAntialiasing);
258
267 BOOL GetAntialiasing() const;
268
269public:
277 int GetTextAngle() const;
278
279public:
291 void DoPropExchange(CXTPPropExchange* pPX);
292
293public:
296 virtual CXTPChartElementView* CreateView(CXTPChartDeviceContext* pDC,
297 CXTPChartElementView* pParentView);
298 CPoint CalcOrigin(CRect bounds, CRect startBounds, CRect rect);
299 XTPChartNearTextPosition GetNearTextPosition();
302# ifdef _XTP_ACTIVEX
303public:
305 DECLARE_DISPATCH_MAP()
306 DECLARE_INTERFACE_MAP()
307 DECLARE_OLETYPELIB_EX(CXTPChartTitle);
308
309 BSTR OleGetText();
310 void OleSetText(LPCTSTR lpszText);
311 LPDISPATCH OleGetFont();
312
313 OLE_COLOR OleGetTextColor();
314 void OleSetTextColor(OLE_COLOR clr);
315
318# endif
319
320protected:
321 friend class CXTPChartTitleCollection;
322
323 CXTPChartString m_strText;
324 CXTPChartColor m_clrTextColor;
325 BOOL m_bVisible;
326 CXTPChartFont* m_pFont;
327 BOOL m_bAntialiasing;
328 XTPChartDocking m_nDocking;
329 int m_nIndent;
330 int m_nInnerIndent;
331 XTPChartStringAlignment m_nAlignment;
332};
333
338class _XTP_EXT_CLASS CXTPChartTitleCollection : public CXTPChartElementCollection
339{
340public:
347 CXTPChartTitleCollection(CXTPChartElement* pOwner);
348
353 virtual ~CXTPChartTitleCollection();
354
355public:
363 CXTPChartTitle* Add(CXTPChartTitle* pTitle);
364
372 CXTPChartTitle* GetAt(int nIndex) const;
373
374public:
386 virtual void DoPropExchange(CXTPPropExchange* pPX);
387
388public:
390 void CreateView(CXTPChartDeviceContext* pDC, CXTPChartElementView* pParentView);
391 void CalculateView(CXTPChartDeviceContext* pDC, CRect& rcChart,
392 CXTPChartElementView* pParentView);
395# ifdef _XTP_ACTIVEX
396public:
398 DECLARE_DISPATCH_MAP()
399 DECLARE_INTERFACE_MAP()
400
401 DECLARE_OLETYPELIB_EX(CXTPChartTitleCollection);
402
403 afx_msg long OleGetItemCount();
404 afx_msg LPDISPATCH OleGetItem(long nIndex);
405 DECLARE_ENUM_VARIANT(CXTPChartTitleCollection)
406
407 afx_msg LPDISPATCH OleAdd(LPCTSTR lpszTitle);
408
410# endif
411
412protected:
413 friend class CXTPChartContent;
414};
415
416AFX_INLINE CXTPChartTitle* CXTPChartTitleCollection::GetAt(int nIndex) const
417{
418 return nIndex >= 0 && nIndex < m_arrElements.GetSize()
419 ? (CXTPChartTitle*)m_arrElements.GetAt(nIndex)
420 : NULL;
421}
422
423AFX_INLINE CXTPChartString CXTPChartTitle::GetText() const
424{
425 return m_strText;
426}
427AFX_INLINE CXTPChartFont* CXTPChartTitle::GetFont() const
428{
429 return m_pFont;
430}
431AFX_INLINE XTPChartDocking CXTPChartTitle::GetDocking() const
432{
433 return m_nDocking;
434}
435AFX_INLINE int CXTPChartTitle::GetIndent() const
436{
437 return m_nIndent;
438}
439AFX_INLINE XTPChartStringAlignment CXTPChartTitle::GetAlignment() const
440{
441 return m_nAlignment;
442}
443
444AFX_INLINE void CXTPChartTitle::SetAntialiasing(BOOL bAntialiasing)
445{
446 m_bAntialiasing = bAntialiasing;
447 OnChartChanged();
448}
449AFX_INLINE BOOL CXTPChartTitle::GetAntialiasing() const
450{
451 return m_bAntialiasing;
452}
453AFX_INLINE BOOL CXTPChartTitle::IsVisible() const
454{
455 return m_bVisible;
456}
457AFX_INLINE void CXTPChartTitle::SetVisible(BOOL bVisible)
458{
459 m_bVisible = bVisible;
460 OnChartChanged();
461}
463# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
464#endif //#if !defined(__XTPCHARTTITLE_H__)
XTPChartDocking
XTPChartDocking
Specifies chart docking direction.
Definition XTPChartTitle.h:44
xtpChartDockTop
@ xtpChartDockTop
Specifies top docking direction.
Definition XTPChartTitle.h:45
xtpChartDockRight
@ xtpChartDockRight
Specifies right docking direction.
Definition XTPChartTitle.h:48
xtpChartDockBottom
@ xtpChartDockBottom
Specifies bottom docking direction.
Definition XTPChartTitle.h:46
xtpChartDockLeft
@ xtpChartDockLeft
Specifies left docking direction.
Definition XTPChartTitle.h:47
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartColor
This class abstracts a color entity.
Definition XTPChartTypes.h:51
CXTPChartContent
This class represents chart content, which is a kind of CXTPChartElement.
Definition XTPChartContent.h:66
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartElementCollection
This class abstracts a chart collection.
Definition XTPChartElement.h:358
CXTPChartElementCollection::m_arrElements
CArray< CXTPChartElement *, CXTPChartElement * > m_arrElements
Array of CXTPChartElement pointer.
Definition XTPChartElement.h:450
CXTPChartElement
This class abstracts a chart element, this class acts as a base class for all chart elements.
Definition XTPChartElement.h:131
CXTPChartElement::OnChartChanged
virtual void OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic propertie...
CXTPChartElementView
This class represents the view of a chart element.
Definition XTPChartElementView.h:47
CXTPChartFont
This class abstracts a font entity.
Definition XTPChartTypes.h:540
CXTPChartTextElement
This class abstracts a chart text element.
Definition XTPChartElement.h:323
CXTPChartTextElement::GetFont
virtual CXTPChartFont * GetFont() const =0
Call this function to get the font of the text element.
CXTPChartTextElement::GetAntialiasing
virtual BOOL GetAntialiasing() const =0
Call this function to check if anti-aliasing is ON or OFF.
CXTPChartTitleCollection
CXTPChartTitleCollection represents a collection of chart titles.
Definition XTPChartTitle.h:339
CXTPChartTitleCollection::DoPropExchange
virtual void DoPropExchange(CXTPPropExchange *pPX)
Call this member function to Store/Load the properties of a title object using the specified data obj...
CXTPChartTitleCollection::Add
CXTPChartTitle * Add(CXTPChartTitle *pTitle)
Call this method to add a new title.
CXTPChartTitleCollection::~CXTPChartTitleCollection
virtual ~CXTPChartTitleCollection()
Destroys a CXTPChartTitleCollection object, handles cleanup.
CXTPChartTitleCollection::GetAt
CXTPChartTitle * GetAt(int nIndex) const
Call this method to get a title by its index.
Definition XTPChartTitle.h:416
CXTPChartTitleCollection::CXTPChartTitleCollection
CXTPChartTitleCollection(CXTPChartElement *pOwner)
Constructs a CXTPChartTitleCollection object.
CXTPChartTitle
This class represents a chart title.
Definition XTPChartTitle.h:56
CXTPChartTitle::SetAlignment
void SetAlignment(XTPChartStringAlignment nAlignment)
Call this method to set the text alignment of the title.
CXTPChartTitle::m_pFont
CXTPChartFont * m_pFont
Font of the title.
Definition XTPChartTitle.h:326
CXTPChartTitle::DoPropExchange
void DoPropExchange(CXTPPropExchange *pPX)
Call this member function to Store/Load the properties of a title object using the specified data obj...
CXTPChartTitle::GetActualTextColor
CXTPChartColor GetActualTextColor() const
Call this method to get the actual text color of the title.
CXTPChartTitle::SetIndent
void SetIndent(int nIndent)
Call this method to set the indent between 2 titles.
CXTPChartTitle::~CXTPChartTitle
virtual ~CXTPChartTitle()
Destroys a CXTPChartTitle object, handles cleanup.
CXTPChartTitle::GetTextColor
CXTPChartColor GetTextColor() const
Call this method to get the custom text color of the title.
CXTPChartTitle::SetVisible
void SetVisible(BOOL bVisible)
Call this function to set the visibility of the title.
Definition XTPChartTitle.h:457
CXTPChartTitle::m_strText
CXTPChartString m_strText
Text of the title.
Definition XTPChartTitle.h:323
CXTPChartTitle::GetAlignment
XTPChartStringAlignment GetAlignment() const
Call this method to get the text alignment of the title.
Definition XTPChartTitle.h:439
CXTPChartTitle::GetFont
CXTPChartFont * GetFont() const
Call this method to get the font for the title.
Definition XTPChartTitle.h:427
CXTPChartTitle::SetTextColor
void SetTextColor(const CXTPChartColor &clrTextColor)
Call this method to set the custom text color of the title.
CXTPChartTitle::SetFont
void SetFont(CXTPChartFont *pFont)
Call this method to set the font of the title.
CXTPChartTitle::m_nAlignment
XTPChartStringAlignment m_nAlignment
Text alignment.
Definition XTPChartTitle.h:331
CXTPChartTitle::IsVisible
BOOL IsVisible() const
Call this function to check if the title is visible.
Definition XTPChartTitle.h:453
CXTPChartTitle::GetText
CXTPChartString GetText() const
Call this function to get the text of the title.
Definition XTPChartTitle.h:423
CXTPChartTitle::m_nIndent
int m_nIndent
Indent between 2 titles.
Definition XTPChartTitle.h:329
CXTPChartTitle::SetAntialiasing
void SetAntialiasing(BOOL bAntialiasing)
Call this function to set anti-aliasing ON or OFF.
Definition XTPChartTitle.h:444
CXTPChartTitle::SetText
void SetText(LPCTSTR lpszTitle)
Call this function to set the text of the title.
CXTPChartTitle::m_nDocking
XTPChartDocking m_nDocking
Current docking position of the title.
Definition XTPChartTitle.h:328
CXTPChartTitle::SetDocking
void SetDocking(XTPChartDocking nDocking)
Call this method to set the docking position of the title.
CXTPChartTitle::m_bVisible
BOOL m_bVisible
TRUE if title is visible.
Definition XTPChartTitle.h:325
CXTPChartTitle::GetTextAngle
int GetTextAngle() const
This method calculates text angle according to the current docking position.
CXTPChartTitle::m_nInnerIndent
int m_nInnerIndent
Inner indent.
Definition XTPChartTitle.h:330
CXTPChartTitle::m_clrTextColor
CXTPChartColor m_clrTextColor
Text color.
Definition XTPChartTitle.h:324
CXTPChartTitle::GetDocking
XTPChartDocking GetDocking() const
Call this method to get the docking position of the title.
Definition XTPChartTitle.h:431
CXTPChartTitle::m_bAntialiasing
BOOL m_bAntialiasing
Antialiasing flag.
Definition XTPChartTitle.h:327
CXTPChartTitle::CXTPChartTitle
CXTPChartTitle()
Constructs a CXTPChartTitle object.
CXTPChartTitle::GetIndent
int GetIndent() const
Call this method to get the indent between 2 titles.
Definition XTPChartTitle.h:435
CXTPChartTitle::GetAntialiasing
BOOL GetAntialiasing() const
Call this function to check if anti-aliasing is ON or OFF.
Definition XTPChartTitle.h:449
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72


Toolkit Pro: XTPDockingPaneThemeVisualStudio2008.h Source File

  • Source
  • DockingPane
  • Themes
XTPDockingPaneThemeVisualStudio2008.h
Go to the documentation of this file.
1
23#if !defined(__XTPDOCKINGPANETHEMEVISUALSTUDIO2008_H__)
24# define __XTPDOCKINGPANETHEMEVISUALSTUDIO2008_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
41class _XTP_EXT_CLASS CXTPDockingPaneVisualStudio2008Theme
42 : public CXTPDockingPaneVisualStudio2005Theme
43{
44public:
49 CXTPDockingPaneVisualStudio2008Theme();
50
55 virtual void RefreshMetrics();
56
57protected:
58};
59
60# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
62#endif // !defined(__XTPDOCKINGPANETHEMEVISUALSTUDIO2008_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPDockingPaneVisualStudio2005Theme
CXTPDockingPaneVisualStudio2005Theme is a CXTPDockingPaneVisualStudio2005Beta2Theme derived class tha...
Definition XTPDockingPaneThemeVisualStudio2005.h:43
CXTPDockingPaneVisualStudio2008Theme
CXTPDockingPaneVisualStudio2008Theme is a CXTPDockingPaneVisualStudio2005Theme derived class that rep...
Definition XTPDockingPaneThemeVisualStudio2008.h:43
CXTPDockingPaneVisualStudio2008Theme::CXTPDockingPaneVisualStudio2008Theme
CXTPDockingPaneVisualStudio2008Theme()
Constructs a CXTPDockingPaneVisualStudio2008Theme object.
CXTPDockingPaneVisualStudio2008Theme::RefreshMetrics
virtual void RefreshMetrics()
This method is called to refresh the visual metrics of manager.


Toolkit Pro: Member List

CXTPTabToolBar Member List

This is the complete list of members for CXTPTabToolBar, including all inherited members.

AddItem(int nItem, CXTPTabManagerItem *pItem=NULL) | CXTPTabManager | protected
CalcDockingLayout(int nLength, DWORD dwMode, int nWidth) | CXTPTabToolBar | protectedvirtual
CalcDynamicLayout(int nLength, DWORD dwMode) | CXTPTabToolBar | protectedvirtual
Copy(CXTPCommandBar *pCommandBar, BOOL bRecursive=FALSE) | CXTPToolBar | protectedvirtual
Create(CWnd *pParentWnd, BOOL bFloat) | CXTPToolBar | protectedvirtual
CreateKeyboardTips() | CXTPCommandBar | virtual
CreateToolBar(DWORD dwStyle, CWnd *pParentWnd, UINT nID=AFX_IDW_TOOLBAR) | CXTPToolBar |
CXTPCommandBar() | CXTPCommandBar | protected
CXTPHookManagerHookAble() | CXTPHookManagerHookAble |
CXTPTabManager() | CXTPTabManager |
CXTPTabToolBar() | CXTPTabToolBar |
CXTPToolBar() | CXTPToolBar |
DelayLayout() | CXTPCommandBar |
DelayRedraw() | CXTPCommandBar | virtual
DeleteAllItems() | CXTPTabManager |
DeleteItem(int nItem) | CXTPTabManager |
DoPropExchange(CXTPPropExchange *pPX) | CXTPToolBar | protectedvirtual
DoUpdateCustomizeMenuControl(CXTPControl *pControl, CCmdTarget *pTarget) | CXTPToolBar | static
DrawCommandBar(CDC *pDC, CRect rcClipBox) | CXTPTabToolBar | protectedvirtual
DrawIcon(CDC *pDC, CPoint pt, CXTPTabManagerItem *pItem, BOOL bDraw, CSize &szIcon) const | CXTPTabToolBar | protectedvirtual
DrawParentBackground(CDC *pDC, CRect rc) | CXTPTabManager | virtual
EnableAnimation(BOOL bEnable=TRUE) | CXTPCommandBar |
EnableCustomization(BOOL bEnable=TRUE) | CXTPCommandBar |
EnableDocking(DWORD dwFlags=xtpFlagAlignAny|xtpFlagFloating|xtpFlagHideWrap) | CXTPToolBar |
EnableDoubleBuffer(BOOL bEnable=TRUE) | CXTPCommandBar |
EnableMarkup(BOOL bEnable=TRUE) | CXTPTabManager |
EnableTabThemeTexture(HWND hWnd, BOOL bEnable=TRUE) | CXTPTabManager |
CXTPToolBar::EnsureVisible(CXTPControl *pControl) | CXTPCommandBar | virtual
CXTPTabManager::EnsureVisible(CXTPTabManagerItem *pItem) | CXTPTabManager |
FillCommandBarEntry(CDC *pDC) | CXTPCommandBar | virtual
FindAccel(TCHAR chAccel) const | CXTPCommandBar |
FindAccelEx(UINT chAccel, BOOL &bSelectOnly) const | CXTPCommandBar |
FindNavigateButton(UINT nID) const | CXTPTabManager |
FindNextFocusable(int nIndex, int nDirection) const | CXTPTabManager |
GenerateCommandBarList(DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam) | CXTPCommandBar | protectedvirtual
GetActiveDocTemplate() const | CXTPCommandBar | protected
GetAppearance() const | CXTPTabManager |
GetAppearanceSet() const | CXTPTabManager |
GetBarID() const | CXTPCommandBar |
GetBarInfo(CToolBarInfo *pInfo) | CXTPToolBar |
GetBorders() | CXTPTabToolBar | protectedvirtual
GetButtonSize() const | CXTPCommandBar | virtual
GetClientRect() const | CXTPTabManager |
GetColor() const | CXTPTabManager |
GetColorSet() const | CXTPTabManager |
GetCommandBarData() const | CXTPCommandBar |
GetCommandBars() const | CXTPCommandBar |
GetControl(int nIndex) const | CXTPCommandBar |
GetControlCount() const | CXTPCommandBar |
GetControlRect() const | CXTPTabManager |
GetControls() const | CXTPCommandBar |
GetCurSel() const | CXTPTabManager |
GetDefaultButtonStyle() const | CXTPCommandBar |
GetDockBar() const | CXTPToolBar |
GetFlags() const | CXTPCommandBar |
GetFrameSite() const | CXTPCommandBar |
GetHeaderOffset() const | CXTPTabManager |
GetHeaderRect() const | CXTPTabManager |
GetIconSize() const | CXTPCommandBar | virtual
GetImageManager() const | CXTPCommandBar |
GetItem(int nIndex) const | CXTPTabManager |
GetItemCaption(const CXTPTabManagerItem *pItem) const | CXTPTabManager | virtual
GetItemColor(const CXTPTabManagerItem *pItem) const | CXTPTabManager | virtual
GetItemCount() const | CXTPTabManager |
GetItemIcon(const CXTPTabManagerItem *pItem) const | CXTPTabManager | virtual
GetItemMetrics(CSize *szNormal, CSize *szMin=NULL, CSize *szMax=NULL) const | CXTPTabManager | virtual
GetItemsLength() const | CXTPTabManager | virtual
GetItemTooltip(const CXTPTabManagerItem *pItem) const | CXTPTabManager | virtual
GetLargeIconSize(BOOL bAutoSize) const | CXTPCommandBar |
GetLayout() const | CXTPTabManager |
GetMarkupContext() const | CXTPTabManager | virtual
GetNavigateButton(int nIndex) const | CXTPTabManager |
GetNavigateButtonCount() const | CXTPTabManager |
GetNavigateButtons() | CXTPTabManager |
GetOwnerSite() const | CXTPCommandBar |
GetPaintManager() const | CXTPTabToolBar | virtual
GetParentCommandBar() const | CXTPCommandBar | virtual
CXTPToolBar::GetPosition() const | CXTPCommandBar |
CXTPTabManager::GetPosition() const | CXTPTabManager | virtual
GetRectLength(CRect rc) const | CXTPTabManager |
GetRootParent() const | CXTPCommandBar |
GetRowCount() const | CXTPTabManager |
GetSelected() const | CXTPCommandBar |
GetSelectedItem() const | CXTPTabManager |
GetShowGripper() const | CXTPCommandBar |
GetSite() const | CXTPCommandBar |
GetTextOrientation() const | CXTPCommandBar |
GetTitle() const | CXTPCommandBar |
GetTrackFocus() const | CXTPCommandBar |
GetType() const | CXTPCommandBar |
GetWidth() const | CXTPCommandBar |
HeaderHasFocus() const | CXTPTabManager | protectedvirtual
HideKeyboardTips() | CXTPCommandBar |
HitTest(CPoint point) const | CXTPTabManager |
HitTestNavigateButton(CPoint point, BOOL bHeaderOnly, int *pnIndex=NULL) const | CXTPTabManager |
InsertCategory(int nItem, LPCTSTR lpszItem, UINT *pItems, int nCount, BOOL bLoadIcons=TRUE) | CXTPTabToolBar |
InsertCategory(int nItem, LPCTSTR lpszItem, UINT nIDResource, BOOL bLoadIcons=TRUE) | CXTPTabToolBar |
InvalidateParents() | CXTPCommandBar |
IsActive() const | CXTPTabManager |
IsAllowReorder() const | CXTPTabManager | virtual
IsAnimationEnabled() const | CXTPCommandBar |
IsBuiltIn() const | CXTPToolBar |
IsCloseable() const | CXTPToolBar |
IsContextMenuPresent() const | CXTPToolBar |
IsCustomizable() const | CXTPCommandBar | virtual
IsCustomizeDialogPresent() const | CXTPToolBar |
IsCustomizeMode() const | CXTPCommandBar |
IsDialogBar() const | CXTPCommandBar | virtual
IsDrawStaticFrame() const | CXTPTabManager | virtual
IsHelpMode() const | CXTPCommandBar | protected
IsHorizontalPosition() const | CXTPTabManager |
IsKeyboardCuesVisible() const | CXTPCommandBar | virtual
IsKeyboardTipsVisible() const | CXTPCommandBar |
IsLayoutRTL() const | CXTPCommandBar |
IsMenuTitleBar() const | CXTPCommandBar | virtual
IsMouseLocked() const | CXTPTabManager | protectedvirtual
IsNavigateButtonAutomaticVisible(CXTPTabManagerNavigateButton *pButton) | CXTPTabManager | protectedvirtual
IsNavigateButtonVisible(CXTPTabManagerNavigateButton *pButton) | CXTPTabManager | protectedvirtual
IsPopupBar() const | CXTPCommandBar | virtual
IsResizable() const | CXTPCommandBar | virtual
IsRibbonBar() const | CXTPCommandBar | virtual
IsTemporary() const | CXTPToolBar |
IsTextBelowIcons() const | CXTPCommandBar |
IsTrackingMode() const | CXTPCommandBar |
IsVisible() const | CXTPToolBar | inlinevirtual
IsWindowVisible() const | CXTPToolBar |
LoadMenu(CMenu *pMenu, BOOL bRemoveControls=TRUE) | CXTPCommandBar | virtual
LoadToolBar(UINT nIDResource, BOOL bLoadIcons=TRUE) | CXTPToolBar | virtual
LockMouseMove(CXTPControl *pControl) | CXTPCommandBar |
LockRedraw() | CXTPCommandBar |
m_arrItems | CXTPTabManager | protected
m_arrNavigateButtons | CXTPTabManager | protected
m_bActive | CXTPTabManager | protected
m_bAllowReorder | CXTPTabManager | protected
m_bAnimatePopup | CXTPCommandBar | protected
m_barPosition | CXTPCommandBar | protected
m_barType | CXTPCommandBar | protected
m_bAutoDestroy | CXTPHookManagerHookAble |
m_bBuiltIn | CXTPToolBar | protected
m_bCloseable | CXTPCommandBar | protected
m_bCloseItemButton | CXTPTabManager | protected
m_bComboBar | CXTPCommandBar |
m_bContextMenuPresent | CXTPToolBar | protected
m_bCustomizable | CXTPCommandBar | protected
m_bCustomizeDialogPresent | CXTPCommandBar | protected
m_bExecOnRButton | CXTPCommandBar | protected
m_bGrabFocus | CXTPCommandBar | protected
m_bIgnoreUpdateHandler | CXTPCommandBar | protected
m_bInRecalcLayout | CXTPToolBar | protected
m_bKeyboardSelect | CXTPCommandBar | protected
m_bMultiLine | CXTPCommandBar | protected
m_bPreviewMode | CXTPToolBar | protected
m_bPreviewVisible | CXTPToolBar | protected
m_bRecursePopup | CXTPCommandBar | protected
m_bShowExpandButton | CXTPToolBar | protected
m_bTearOff | CXTPToolBar | protected
m_bTemporary | CXTPToolBar | protected
m_bTextBelow | CXTPCommandBar | protected
m_bTracking | CXTPCommandBar | protected
m_bTrackOnHover | CXTPCommandBar |
m_buttonStyle | CXTPCommandBar | protected
m_bVerticalMarker | CXTPCommandBar | protected
m_bVisible | CXTPToolBar | protected
m_dwData | CXTPCommandBar | protected
m_dwFlags | CXTPCommandBar | protected
m_dwStyle | CXTPCommandBar | protected
m_hwndFocus | CXTPCommandBar | protected
m_nBarID | CXTPCommandBar | protected
m_nHeaderOffset | CXTPTabManager | protected
m_nIdleFlags | CXTPCommandBar | protected
m_nLockRedraw | CXTPCommandBar | protected
m_nMinWidth | CXTPTabToolBar | protected
m_nMRUWidth | CXTPCommandBar | protected
m_nPopuped | CXTPCommandBar | protected
m_nScrollDelta | CXTPTabManager | protected
m_nSelected | CXTPCommandBar | protected
m_nStateFlags | CXTPCommandBar |
m_nTextOrientation | CXTPCommandBar | protected
m_pAnimation | CXTPCommandBar | protected
m_pCommandBars | CXTPCommandBar | protected
m_pControls | CXTPCommandBar | protected
m_pDockBar | CXTPToolBar | protected
m_pDockContext | CXTPToolBar | protected
m_pHighlighted | CXTPTabManager | protected
m_pHighlightedNavigateButton | CXTPTabManager | protected
m_pImageManager | CXTPCommandBar | protected
m_pMarkupContext | CXTPTabManager | protected
m_pOwner | CXTPCommandBar | protected
m_pPaintManager | CXTPCommandBar | protected
m_pPressed | CXTPTabManager | protected
m_pReturnCmd | CXTPCommandBar | protected
m_pRowIndexer | CXTPTabManager | protected
m_pSelected | CXTPTabManager | protected
m_pSite | CXTPCommandBar | protected
m_pTabPaintManager | CXTPTabToolBar | protected
m_pToolTipContext | CXTPCommandBar | protected
m_rcControl | CXTPTabManager | protected
m_rcHeaderRect | CXTPTabManager | protected
m_rcMarker | CXTPCommandBar | protected
m_rcTabControl | CXTPTabToolBar | protected
m_strTitle | CXTPCommandBar | protected
m_szButtons | CXTPCommandBar | protected
m_szButtonSpacing | CXTPCommandBar | protected
m_szIcons | CXTPCommandBar | protected
MergeToolBar(CXTPCommandBar *pCommandBar, BOOL bSilent) | CXTPToolBar | protectedvirtual
MergeToolBar(CXTPCommandBar *pCommandBar, BOOL bSilent, int nDefaultConfirmationChoice) | CXTPToolBar | protectedvirtual
ModifyBarStyle(DWORD dwRemove, DWORD dwAdd) | CXTPToolBar |
MoveItem(CXTPTabManagerItem *pItem, int nIndex) | CXTPTabManager |
OnBeforeItemClick(CXTPTabManagerItem *pItem) | CXTPTabToolBar | protectedvirtual
OnControlsChanged() | CXTPCommandBar | protectedvirtual
OnControlSelected(BOOL bSelected, CXTPControl *pControl) | CXTPCommandBar | virtual
OnCustomizeDragEnter(CXTPControl *pDataObject, CPoint point) | CXTPCommandBar | virtual
OnCustomizeDragLeave() | CXTPCommandBar | virtual
OnCustomizeDragOver(CXTPControl *pDataObject, CPoint point) | CXTPCommandBar | virtual
OnCustomizeDrop(CXTPControl *pDataObject, DROPEFFECT &dropEffect, CPoint ptDrop, CPoint ptDrag) | CXTPTabToolBar | protectedvirtual
OnHookAttached(HWND hWnd) | CXTPHookManagerHookAble | virtual
OnHookDetached() | CXTPHookManagerHookAble | virtual
OnHookKeyDown(UINT nChar, LPARAM lParam) | CXTPToolBar | virtual
OnHookMessage(HWND hWnd, UINT nMessage, WPARAM &wParam, LPARAM &lParam, LRESULT &lResult) | CXTPCommandBar | virtual
OnItemClick(CXTPTabManagerItem *pItem) | CXTPTabManager | protectedvirtual
OnItemHandleChanged(CXTPTabManagerItem *pItem, HWND hwndOld, HWND hwndNew) | CXTPTabManager | protectedvirtual
OnItemOrderChanged(CXTPTabManagerItem *pItem, int nOldIndex, int nNewIndex) | CXTPTabManager | protectedvirtual
OnItemsChanged() | CXTPTabManager | virtual
OnKeyboardTip(CXTPCommandBarKeyboardTip *pTip) | CXTPCommandBar | virtual
OnKeyboardTipChar(UINT chAccel) | CXTPCommandBar |
OnMouseHitTest(CPoint pt) | CXTPCommandBar | protectedvirtual
OnNavigateButtonClick(CXTPTabManagerNavigateButton *pButton) | CXTPTabManager | protectedvirtual
OnNavigateButtonClick(UINT nID) | CXTPTabManager | protectedvirtual
OnPaintManagerChanged() | CXTPToolBar | protectedvirtual
OnPostHookMessage(HWND hWnd, UINT nMessage, WPARAM &wParam, LPARAM &lParam, LRESULT &lResult) | CXTPHookManagerHookAble | virtual
OnPropertyChanged() | CXTPTabManagerAtom | inlinevirtual
OnRecalcLayout() | CXTPToolBar | virtual
OnRemoved() | CXTPCommandBar | protectedvirtual
OnScrollHeader(BOOL bRight) | CXTPTabManager | virtual
OnSetPreviewMode(BOOL bPreview) | CXTPToolBar |
OnSwitchItem(CXTPTabManagerItem *pItem1, CXTPTabManagerItem *pItem2) | CXTPTabManager | protectedvirtual
OnTrackEnter() | CXTPCommandBar | virtual
OnTrackLost() | CXTPCommandBar | virtual
PerformClick(HWND hWnd, CPoint pt, BOOL bNoItemClick=FALSE) | CXTPTabManager |
PerformKeyDown(HWND hWnd, UINT nChar) | CXTPTabManager | virtual
PerformMouseMove(HWND hWnd, CPoint pt) | CXTPTabManager |
PerformToolHitTest(HWND hWnd, CPoint point, TOOLINFO *pTI) const | CXTPTabManager | virtual
Popup(CXTPControlPopup *pControlPopup, BOOL bSelectFirst=FALSE) | CXTPCommandBar | virtual
ProcessSpecialKey(XTPSpecialKey key) | CXTPCommandBar | protectedvirtual
Redraw(LPCRECT lpRect=0, BOOL bAnimate=TRUE) | CXTPCommandBar | virtual
RedrawControl(LPCRECT lpRect, BOOL bAnimate) | CXTPTabToolBar | protectedvirtual
ReOrder(HWND hWnd, CPoint pt, CXTPTabManagerItem *pItem) | CXTPTabManager | protectedvirtual
Reposition() | CXTPTabToolBar | protectedvirtual
Reset(BOOL bShowWarningMessage) | CXTPTabToolBar | protectedvirtual
RestoreCommandBarList(CXTPCommandBarList *pCommandBarList) | CXTPCommandBar | protectedvirtual
s_nExpandDelay | CXTPCommandBar | static
s_nExpandHoverDelay | CXTPCommandBar | static
s_nHoverDelay | CXTPCommandBar | static
SetActive(BOOL bActive) | CXTPTabManager |
SetAllowReorder(BOOL bAllowReorder) | CXTPTabManager | virtual
SetAppearance(XTPTabAppearanceStyle tabAppearance) | CXTPTabManager |
SetAppearanceSet(CXTPTabPaintManagerTheme *pAppearanceSet) | CXTPTabManager |
SetBarID(UINT nID) | CXTPCommandBar |
SetBarInfo(CToolBarInfo *pInfo) | CXTPToolBar |
SetButtons(UINT *pButtons, int nCount) | CXTPCommandBar |
SetButtonSize(CSize size) | CXTPCommandBar |
SetCloseable(BOOL bCloseable) | CXTPToolBar |
SetColor(XTPTabColorStyle tabColor) | CXTPTabManager |
SetColorSet(CXTPTabPaintManagerColorSet *pColorSet) | CXTPTabManager |
SetCommandBarData(DWORD_PTR dwData) | CXTPCommandBar |
SetCommandBars(CXTPCommandBars *pCommandBars) | CXTPCommandBar |
SetContextMenuPresent(BOOL bPresent) | CXTPToolBar |
SetControls(CXTPControls *pControls) | CXTPCommandBar |
SetCurSel(int nIndex) | CXTPTabManager |
SetCustomizeDialogPresent(BOOL bPresent) | CXTPToolBar |
SetDefaultButtonStyle(XTPButtonStyle buttonStyle) | CXTPCommandBar |
SetFlags(DWORD dwFlagsAdd, DWORD dwFlagsRemove=0) | CXTPCommandBar |
SetFocusedItem(CXTPTabManagerItem *pItem) | CXTPTabManager | virtual
SetGrabFocus(BOOL bGrabFocus) | CXTPCommandBar |
SetHeaderOffset(int nOffset) | CXTPTabManager |
SetIconSize(CSize size) | CXTPCommandBar |
SetImageManager(CXTPImageManager *pImageManager) | CXTPCommandBar |
SetItemMetrics(CSize szNormal, CSize szMin=CSize(0, 0), CSize szMax=CSize(0, 0)) | CXTPTabManager |
SetLayoutStyle(XTPTabLayoutStyle tabLayout) | CXTPTabManager |
SetMinimumWidth(int nMinWidth) | CXTPTabToolBar |
CXTPToolBar::SetPaintManager(CXTPPaintManager *pPaintManager) | CXTPCommandBar |
CXTPTabManager::SetPaintManager(CXTPTabPaintManager *pPaintManager) | CXTPTabManager | virtual
SetPopuped(int nPopuped, BOOL bKeyboard=FALSE) | CXTPCommandBar |
CXTPToolBar::SetPosition(XTPBarPosition barPosition) | CXTPToolBar | virtual
CXTPTabManager::SetPosition(XTPTabPosition tabPosition) | CXTPTabManager |
SetSelected(int nSelected, BOOL bKeyboard=FALSE) | CXTPCommandBar | virtual
SetSelectedItem(CXTPTabManagerItem *pItem) | CXTPTabToolBar | protectedvirtual
SetShowGripper(BOOL bShow) | CXTPCommandBar |
SetStatusText(const CString &strDescription) | CXTPCommandBar |
SetTemporary(BOOL bTemporary) | CXTPToolBar |
SetTextOrientation(XTPBarTextOrientation nTextOrientation) | CXTPCommandBar |
SetTitle(LPCTSTR lpszTitle) | CXTPCommandBar |
SetTrackFocus(HWND hwnd) | CXTPCommandBar |
SetTrackingMode(int bMode, BOOL bSelectFirst=TRUE, BOOL bKeyboard=FALSE) | CXTPCommandBar | virtual
SetVisible(BOOL bVisible) | CXTPToolBar | virtual
SetWidth(int nWidth) | CXTPCommandBar |
ShouldSerializeBar() | CXTPToolBar | protectedvirtual
ShowCloseItemButton(XTPTabNavigateButtonFlags bCloseItemButton=xtpTabNavigateButtonAlways) | CXTPTabManager |
ShowExpandButton(BOOL bShowExpandButton) | CXTPToolBar |
ShowIcons(BOOL bShowIcons) | CXTPTabManager |
ShowTextBelowIcons(BOOL bTextBelow=TRUE) | CXTPCommandBar |
TrackClick(HWND hWnd, CPoint pt, CXTPTabManagerItem *pItem) | CXTPTabManager | protected
UnlockMouseMove() | CXTPCommandBar |
UnlockRedraw() | CXTPCommandBar |
UpdateShortcuts() | CXTPCommandBar | protectedvirtual
UpdateTabs(CXTPTabManagerItem *pItem=NULL) | CXTPTabToolBar |
~CXTPCommandBar() | CXTPCommandBar | protectedvirtual
~CXTPHookManagerHookAble() | CXTPHookManagerHookAble | virtual
~CXTPTabManager() | CXTPTabManager | virtual
~CXTPTabManagerAtom() | CXTPTabManagerAtom | inlineprotectedvirtual
~CXTPTabToolBar() | CXTPTabToolBar | virtual
~CXTPToolBar() | CXTPToolBar |


Toolkit Pro: Member List

CXTPCalendarEventCategories Member List

This is the complete list of members for CXTPCalendarEventCategories, including all inherited members.

Add(CXTPCalendarEventCategory *pNewElement) | CXTPCalendarPtrCollectionT< CXTPCalendarEventCategory > | virtual
Add(CXTPCalendarEventCategory *pNewElement, BOOL bWithAddRef) | CXTPCalendarPtrCollectionT< CXTPCalendarEventCategory > | virtual
Append(const CXTPCalendarPtrCollectionT< CXTPCalendarEventCategory > *pElementsArray) | CXTPCalendarPtrCollectionT< CXTPCalendarEventCategory > | virtual
CXTPCalendarEventCategories() | CXTPCalendarEventCategories |
CXTPCalendarPtrCollectionT() | CXTPCalendarPtrCollectionT< CXTPCalendarEventCategory > |
CXTPCmdTarget() | CXTPCmdTarget |
Find(UINT nID) const | CXTPCalendarEventCategories | virtual
CXTPCalendarPtrCollectionT< CXTPCalendarEventCategory >::Find(const CXTPCalendarEventCategory *pElement) const | CXTPCalendarPtrCollectionT< CXTPCalendarEventCategory > | virtual
FindIndex(UINT nID) const | CXTPCalendarEventCategories | protectedvirtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAt(int nIndex) const | CXTPCalendarPtrCollectionT< CXTPCalendarEventCategory > | virtual
GetAt(int nIndex, BOOL bWithAddRef) const | CXTPCalendarPtrCollectionT< CXTPCalendarEventCategory > | virtual
GetCount() const | CXTPCalendarPtrCollectionT< CXTPCalendarEventCategory > | virtual
InitDefaultValues() | CXTPCalendarEventCategories | virtual
InsertAt(int nIndex, CXTPCalendarEventCategory *pElement) | CXTPCalendarPtrCollectionT< CXTPCalendarEventCategory > | virtual
m_arElements | CXTPCalendarPtrCollectionT< CXTPCalendarEventCategory > | protected
m_bDefaultValues | CXTPCalendarEventCategories | protected
Remove(CXTPCalendarEventCategory *pElement) | CXTPCalendarPtrCollectionT< CXTPCalendarEventCategory > | virtual
RemoveAll() | CXTPCalendarPtrCollectionT< CXTPCalendarEventCategory > | virtual
RemoveAt(int nIndex) | CXTPCalendarPtrCollectionT< CXTPCalendarEventCategory > | virtual
SetAt(int nIndex, CXTPCalendarEventCategory *pElement) | CXTPCalendarPtrCollectionT< CXTPCalendarEventCategory > | virtual
SetDefaultValues(BOOL bDefault) | CXTPCalendarEventCategories |
SetSize(int nNewSize) | CXTPCalendarPtrCollectionT< CXTPCalendarEventCategory > | virtual
TObjectPtr typedef | CXTPCalendarPtrCollectionT< CXTPCalendarEventCategory > | protected
UpdateDefaultValues(COLORREF *pClrBkBase, COLORREF *pClrBorder, int nCount) | CXTPCalendarEventCategories |
~CXTPCalendarEventCategories() | CXTPCalendarEventCategories | virtual
~CXTPCalendarPtrCollectionT() | CXTPCalendarPtrCollectionT< CXTPCalendarEventCategory > | virtual


Toolkit Pro: XTPButtonThemeNativeWindows10.h Source File

  • Source
  • Controls
  • Button
  • Themes
XTPButtonThemeNativeWindows10.h
Go to the documentation of this file.
1
23#if !defined(__XTPBUTTONTHEMENATIVEWINDOWS10_H__)
24# define __XTPBUTTONTHEMENATIVEWINDOWS10_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPButtonThemeNativeWindows10 : public CXTPButtonThemeOffice2013
39{
40public:
45 CXTPButtonThemeNativeWindows10();
46
53 virtual void RefreshMetrics(CXTPButton* pButton);
54};
55
56# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
58#endif //#if !defined(__XTPBUTTONTHEMENATIVEWINDOWS10_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPButton
Push Button control.
Definition XTPButton.h:109
CXTPButtonThemeNativeWindows10
CXTPButtonThemeNativeWindows10 is a class used to perform Visual Studio 2015 theme drawing tasks.
Definition XTPButtonThemeNativeWindows10.h:39
CXTPButtonThemeNativeWindows10::CXTPButtonThemeNativeWindows10
CXTPButtonThemeNativeWindows10()
Constructs a CXTPButtonThemeNativeWindows10 object.
CXTPButtonThemeNativeWindows10::RefreshMetrics
virtual void RefreshMetrics(CXTPButton *pButton)
This member function is called by the theme manager to refresh the visual styles used by each compone...
CXTPButtonThemeOffice2013
CXTPButtonThemeOffice2013 is a class used to perform Office 2013 theme drawing tasks.
Definition XTPButtonThemeOffice2013.h:39


Toolkit Pro: Member List

CXTPTagCloudCtrl Member List

This is the complete list of members for CXTPTagCloudCtrl, including all inherited members.

AddTag(XTP_TAGCLOUDTAG *pTag) | CXTPTagCloudCtrl |
CalcRowLayout(const CRect &rcClient, const CXTPTagCloudTagArray &arrRow) | CXTPTagCloudCtrl | protectedvirtual
Create(DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID) | CXTPTagCloudCtrl | virtual
CXTPTagCloudCtrl() | CXTPTagCloudCtrl |
EnableFocusRect(BOOL bFocusRect) | CXTPTagCloudCtrl |
EnableTooltip(BOOL bTipEnabled) | CXTPTagCloudCtrl |
GetBackColor() const | CXTPTagCloudCtrl |
GetBorderColor() const | CXTPTagCloudCtrl |
GetCurSel() | CXTPTagCloudCtrl |
GetMargin() const | CXTPTagCloudCtrl |
GetPadding() const | CXTPTagCloudCtrl |
GetSortOrder() const | CXTPTagCloudCtrl |
GetTagArray() | CXTPTagCloudCtrl | protectedvirtual
HitTest(const CPoint &point) | CXTPTagCloudCtrl |
IsFillHorz() const | CXTPTagCloudCtrl |
IsFocusEnabled() const | CXTPTagCloudCtrl |
IsTipEnabled() const | CXTPTagCloudCtrl |
m_arrTags | CXTPTagCloudCtrl | protected
m_arrTagsSorted | CXTPTagCloudCtrl | protected
m_bActive | CXTPTagCloudCtrl | protected
m_bAsc | CXTPTagCloudCtrl | protected
m_bFocusRect | CXTPTagCloudCtrl | protected
m_bHorz | CXTPTagCloudCtrl | protected
m_bTipEnabled | CXTPTagCloudCtrl | protected
m_clrBack | CXTPTagCloudCtrl | protected
m_clrBorder | CXTPTagCloudCtrl | protected
m_hCursor | CXTPTagCloudCtrl | protected
m_nMargin | CXTPTagCloudCtrl | protected
m_nPadding | CXTPTagCloudCtrl | protected
m_nSortOrder | CXTPTagCloudCtrl | protected
m_pCurSel | CXTPTagCloudCtrl | protected
m_pHover | CXTPTagCloudCtrl | protected
m_themeWrapper | CXTPTagCloudCtrl | protected
m_wndToolTip | CXTPTagCloudCtrl | protected
OnDraw(CDC *pDC, const CRect &rcClient) | CXTPTagCloudCtrl | protectedvirtual
OnNotify(XTP_TAGCLOUDTAG *pTag, UINT nEventCode) | CXTPTagCloudCtrl | protectedvirtual
PointInRect() | CXTPTagCloudCtrl | protectedvirtual
RecalcLayout() | CXTPTagCloudCtrl | virtual
RegisterWindowClass(HINSTANCE hInstance=NULL) | CXTPTagCloudCtrl | protectedvirtual
RemoveAll() | CXTPTagCloudCtrl |
RemoveAllInternal() | CXTPTagCloudCtrl | protected
RemoveTag(XTP_TAGCLOUDTAG *pTag) | CXTPTagCloudCtrl |
RestoreDefaults() | CXTPTagCloudCtrl |
SetActive(BOOL bActive) | CXTPTagCloudCtrl | protectedvirtual
SetBackColor(CXTPPaintManagerColorGradient clrBack, BOOL bHorz=FALSE) | CXTPTagCloudCtrl |
SetBorderColor(CXTPPaintManagerColor clrBorder) | CXTPTagCloudCtrl |
SetCurSel(XTP_TAGCLOUDTAG *pCurSel) | CXTPTagCloudCtrl |
SetMargin(int nMargin) | CXTPTagCloudCtrl |
SetPadding(int nPadding) | CXTPTagCloudCtrl |
SetSortOrder(XTPTagCloudSort nSortOrder, BOOL bAsc) | CXTPTagCloudCtrl |
~CXTPTagCloudCtrl() | CXTPTagCloudCtrl | virtual


Toolkit Pro: Member List

CXTPSplitterWndThemeVisualStudio2015 Member List

This is the complete list of members for CXTPSplitterWndThemeVisualStudio2015, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPControlTheme() | CXTPControlTheme |
CXTPSplitterWndTheme() | CXTPSplitterWndTheme |
CXTPSplitterWndThemeOffice2013() | CXTPSplitterWndThemeOffice2013 |
CXTPSplitterWndThemeOfficeXP() | CXTPSplitterWndThemeOfficeXP |
CXTPSplitterWndThemeVisualStudio2015() | CXTPSplitterWndThemeVisualStudio2015 |
DrawSplitter(CDC *pDC, CXTPSplitterWnd *pSplitter, int nType, const CRect &rectArg) | CXTPSplitterWndTheme | virtual
EnableTabColors(BOOL bEnable=TRUE) | CXTPSplitterWndTheme |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetThemeStyle() const | CXTPControlTheme |
GetTrackBrush() | CXTPSplitterWndThemeOfficeXP | virtual
m_bTabColors | CXTPSplitterWndTheme |
m_crBack | CXTPSplitterWndTheme |
m_crBoxBack | CXTPSplitterWndTheme |
m_crInnerBorder | CXTPSplitterWndTheme |
m_crInnerBoxBorder | CXTPSplitterWndTheme |
m_crOuterBorder | CXTPSplitterWndTheme |
m_crOuterBoxBorder | CXTPSplitterWndTheme |
m_nTheme | CXTPControlTheme | protected
RefreshMetrics() | CXTPSplitterWndThemeOffice2013 | virtual
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static


Toolkit Pro: Member List

CXTPTaskPanelPaintManager Member List

This is the complete list of members for CXTPTaskPanelPaintManager, including all inherited members.

BlendColor(COLORREF clrFrom, COLORREF clrTo, int nAlpha) | CXTPTaskPanelPaintManager | protected
CreateGripperBitmaps() | CXTPTaskPanelPaintManager | protected
CreateGripperIcon(HICON &hIcon, UINT nIDResource, COLORREF clrGripperBack) | CXTPTaskPanelPaintManager | protected
CXTPTaskPanelPaintManager() | CXTPTaskPanelPaintManager |
DrawCaptionGripper(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelPaintManager | protectedvirtual
DrawCaptionGripperBitmap(CDC *pDC, CXTPTaskPanelGroup *pGroup, BOOL bExpanded, BOOL bHot, CRect rc) | CXTPTaskPanelPaintManager | protected
DrawCaptionGripperSigns(CDC *pDC, CPoint pt, COLORREF clr, BOOL bExpanded) | CXTPTaskPanelPaintManager | protected
DrawDragArrow(CDC *pDC, CXTPTaskPanelItem *pItem, CRect rc, BOOL bAfter=FALSE) | CXTPTaskPanelPaintManager | protectedvirtual
DrawFocusRect(CDC *pDC, CRect rc) | CXTPTaskPanelPaintManager | protectedvirtual
DrawGroupCaption(CDC *pDC, CXTPTaskPanelGroup *pGroup, BOOL bDraw) | CXTPTaskPanelPaintManager | virtual
DrawGroupClient(CDC *pDC, CXTPTaskPanelGroup *pGroup) | CXTPTaskPanelPaintManager | virtual
DrawGroupClientFace(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelPaintManager | protectedvirtual
DrawGroupClientItems(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelPaintManager | protectedvirtual
DrawGroupItem(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw) | CXTPTaskPanelPaintManager | virtual
DrawGroupItemFrame(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc) | CXTPTaskPanelPaintManager | virtual
DrawGroupItemImage(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw) | CXTPTaskPanelPaintManager | protected
DrawGroupItemImageWithText(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw) | CXTPTaskPanelPaintManager | protected
DrawGroupItemImageWithTextBelow(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw) | CXTPTaskPanelPaintManager | protected
DrawItemCaption(CDC *pDC, CXTPTaskPanelItem *pItem, CRect rcText, UINT nFormat) | CXTPTaskPanelPaintManager | protectedvirtual
DrawItemImage(CDC *pDC, CXTPTaskPanelItem *pItem, CPoint ptIcon, CXTPImageManagerIcon *pImage, CSize szIcon) | CXTPTaskPanelPaintManager | protectedvirtual
DrawScrollButton(CDC *pDC, CXTPTaskPanelScrollButton *pScrollButton) | CXTPTaskPanelPaintManager | virtual
FillGroupClientFace(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelPaintManager | virtual
FillTaskPanel(CDC *pDC, CXTPTaskPanel *pTaskPanel) | CXTPTaskPanelPaintManager | virtual
FreeBitmaps() | CXTPTaskPanelPaintManager | protected
GetCaptionGripperWidth(CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelPaintManager | protectedvirtual
GetControlMargins(const CXTPTaskPanel *pPanel) | CXTPTaskPanelPaintManager | virtual
GetGroupColors(BOOL bSpecial) | CXTPTaskPanelPaintManager |
GetGroupColors(CXTPTaskPanelGroup *pGroup) | CXTPTaskPanelPaintManager | virtual
GetGroupInnerMargins(const CXTPTaskPanelGroup *pGroup) | CXTPTaskPanelPaintManager | virtual
GetGroupOuterMargins(const CXTPTaskPanelGroup *pGroup) | CXTPTaskPanelPaintManager | virtual
GetGroupSpacing(const CXTPTaskPanel *pPanel) | CXTPTaskPanelPaintManager | virtual
GetHighlightOffset(CXTPTaskPanelGroupItem *pItem) | CXTPTaskPanelPaintManager | protectedvirtual
GetItemFont(CXTPTaskPanelItem *pItem) | CXTPTaskPanelPaintManager | virtual
GetItemIconPadding(const CXTPTaskPanelItem *pItem) | CXTPTaskPanelPaintManager | virtual
GetItemInnerMargins(const CXTPTaskPanelGroupItem *pItem) | CXTPTaskPanelPaintManager | virtual
GetItemOuterMargins(const CXTPTaskPanelGroupItem *pItem) | CXTPTaskPanelPaintManager | virtual
m_bBoldCaption | CXTPTaskPanelPaintManager |
m_bCaptionScrollButton | CXTPTaskPanelPaintManager |
m_bEmbossedDisabledText | CXTPTaskPanelPaintManager |
m_bEmulateEplorerTheme | CXTPTaskPanelPaintManager |
m_bInvertDragRect | CXTPTaskPanelPaintManager |
m_bLeftRoundedCorner | CXTPTaskPanelPaintManager | protected
m_bmpGrippers | CXTPTaskPanelPaintManager | protected
m_bOfficeBorder | CXTPTaskPanelPaintManager | protected
m_bOfficeHighlight | CXTPTaskPanelPaintManager |
m_bRightRoundedCorner | CXTPTaskPanelPaintManager | protected
m_bUseBitmapGrippers | CXTPTaskPanelPaintManager | protected
m_bUseStandardCaptionFont | CXTPTaskPanelPaintManager | protected
m_bUseStandardItemsFont | CXTPTaskPanelPaintManager | protected
m_clrBackground | CXTPTaskPanelPaintManager | protected
m_clrHighlightBorder | CXTPTaskPanelPaintManager | protected
m_clrHighlightHot | CXTPTaskPanelPaintManager | protected
m_clrHighlightPressed | CXTPTaskPanelPaintManager | protected
m_clrHighlightSelected | CXTPTaskPanelPaintManager | protected
m_eGripper | CXTPTaskPanelPaintManager |
m_groupNormal | CXTPTaskPanelPaintManager | protected
m_groupSpecial | CXTPTaskPanelPaintManager | protected
m_hGripperNormal | CXTPTaskPanelPaintManager | protected
m_hGripperSpecial | CXTPTaskPanelPaintManager | protected
m_nCaptionHeight | CXTPTaskPanelPaintManager | protected
m_nCaptionTextFormat | CXTPTaskPanelPaintManager | protected
m_nGroupSpacing | CXTPTaskPanelPaintManager |
m_nItemTextFormat | CXTPTaskPanelPaintManager | protected
m_rcControlMargins | CXTPTaskPanelPaintManager |
m_rcGroupIconPadding | CXTPTaskPanelPaintManager |
m_rcGroupInnerMargins | CXTPTaskPanelPaintManager |
m_rcGroupOuterMargins | CXTPTaskPanelPaintManager |
m_rcImageLayoutIconPadding | CXTPTaskPanelPaintManager |
m_rcItemIconPadding | CXTPTaskPanelPaintManager |
m_rcItemInnerMargins | CXTPTaskPanelPaintManager |
m_rcItemOuterMargins | CXTPTaskPanelPaintManager |
m_xtpFontCaption | CXTPTaskPanelPaintManager | protected
m_xtpFontIcon | CXTPTaskPanelPaintManager | protected
m_xtpFontIconBold | CXTPTaskPanelPaintManager | protected
m_xtpFontIconHot | CXTPTaskPanelPaintManager | protected
m_xtpFontIconHotBold | CXTPTaskPanelPaintManager | protected
Rectangle(CDC *pDC, CRect rc, COLORREF clrPen, COLORREF clrBrush) | CXTPTaskPanelPaintManager | protected
rectDefault | CXTPTaskPanelPaintManager | static
RefreshMetrics() | CXTPTaskPanelPaintManager | virtual
SetCaptionFontIndirect(LOGFONT *pLogFont, BOOL bUseStandardCaptionFont=FALSE) | CXTPTaskPanelPaintManager |
SetItemsFontIndirect(LOGFONT *pLogFont, BOOL bUseStandardItemsFont=FALSE) | CXTPTaskPanelPaintManager |
SetTextFormat(int nTextFormat, BOOL bCaption=FALSE) | CXTPTaskPanelPaintManager |
~CXTPTaskPanelPaintManager() | CXTPTaskPanelPaintManager | virtual


Toolkit Pro: Member List

CXTPChartRadarAreaSeriesView Member List

This is the complete list of members for CXTPChartRadarAreaSeriesView, including all inherited members.

AddChildView(CXTPChartElementView *pChildView) | CXTPChartElementView |
CreateDeviceCommand(CXTPChartDeviceContext *pDC) | CXTPChartRadarAreaSeriesView | protectedvirtual
CreateLegendDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcBounds) | CXTPChartRadarAreaSeriesView | virtual
CreateSeriesPointView(CXTPChartDeviceContext *pDC, CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView) | CXTPChartRadarAreaSeriesView | protected
CXTPChartElementView(CXTPChartElementView *pParentView) | CXTPChartElementView |
CXTPChartElementView(CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartElementView |
CXTPChartElementView(CXTPChartContainer *pContainer) | CXTPChartElementView |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartRadarAreaSeriesView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView) | CXTPChartRadarAreaSeriesView |
GetActualColor() const | CXTPChartRadarAreaSeriesView |
GetActualColor2() const | CXTPChartRadarAreaSeriesView |
GetAt(int nIndex) const | CXTPChartElementView |
GetBorderActualColor() const | CXTPChartRadarAreaSeriesView |
GetBounds() const | CXTPChartElementView |
GetBounds(BOOL bIncludingChildren) const | CXTPChartElementView |
GetChildren() | CXTPChartElementView |
GetCount() const | CXTPChartElementView |
GetParentView() const | CXTPChartElementView |
Is3D() const | CXTPChartObject |
m_arrChildren | CXTPChartElementView | protected
m_pContainer | CXTPChartElementView | protected
m_pParentView | CXTPChartElementView | protected
m_rcBounds | CXTPChartElementView | protected
~CXTPChartElementView() | CXTPChartElementView | protectedvirtual
~CXTPChartLegendItemView() | CXTPChartLegendItemView | inlinevirtual


Toolkit Pro: Member List

CXTPStatusBarSliderPane Member List

This is the complete list of members for CXTPStatusBarSliderPane, including all inherited members.

BestFit() | CXTPStatusBarPane |
CXTPCmdTarget() | CXTPCmdTarget |
CXTPScrollBase() | CXTPScrollBase |
CXTPStatusBarPane() | CXTPStatusBarPane |
CXTPStatusBarScrollBarPane() | CXTPStatusBarScrollBarPane |
CXTPStatusBarSliderPane() | CXTPStatusBarSliderPane |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetBackgroundColor() const | CXTPStatusBarPane |
GetBeginGroup() const | CXTPStatusBarPane |
GetBestFit() | CXTPStatusBarPane |
GetCaption() const | CXTPStatusBarPane |
GetCltColor(CDC *pDC) const | CXTPScrollBase |
GetCustomizationVisible() const | CXTPStatusBarPane |
GetIconIndex() const | CXTPStatusBarPane |
GetID() const | CXTPStatusBarPane |
GetImage() const | CXTPStatusBarPane | virtual
GetIndex() const | CXTPStatusBarPane |
GetMargins() const | CXTPStatusBarPane |
GetMarkupUIElement() const | CXTPStatusBarPane |
GetPadding() const | CXTPStatusBarPane |
GetParentWindow() const =0 | CXTPScrollBase | pure virtual
GetPos() const | CXTPStatusBarScrollBarPane |
GetRect() const | CXTPStatusBarPane |
GetScrollBarPaintManager() const | CXTPStatusBarSliderPane | protectedvirtual
GetScrollBarPartRect(int nPart) const | CXTPScrollBase |
GetScrollBarPosInfo() | CXTPScrollBase |
GetScrollBarRect()=0 | CXTPScrollBase | pure virtual
GetScrollBarStyle() const | CXTPScrollBase |
GetScrollBarTrackInfo() const | CXTPScrollBase |
GetScrollInfo(SCROLLINFO *psi)=0 | CXTPScrollBase | pure virtual
GetStatusBar() const | CXTPStatusBarPane |
GetStyle() const | CXTPStatusBarPane |
GetText() const | CXTPStatusBarPane |
GetTextAlignment() const | CXTPStatusBarPane |
GetTextColor() const | CXTPStatusBarPane |
GetTextFont() | CXTPStatusBarPane | virtual
GetTextGrayColor() const | CXTPStatusBarPane |
GetTicks() const | CXTPScrollBase |
GetTooltip() const | CXTPStatusBarPane |
GetValue() const | CXTPStatusBarPane |
GetWidth() | CXTPStatusBarPane | virtual
HasBorders() const | CXTPStatusBarPane |
HitTestScrollBar(POINT pt) const | CXTPScrollBase |
IsButton() const | CXTPStatusBarPane |
IsChecked() const | CXTPStatusBarPane |
IsDark() const | CXTPStatusBarPane |
IsEnabled() const | CXTPStatusBarPane |
IsHighlighted() const | CXTPStatusBarPane |
IsPressed() const | CXTPStatusBarPane |
IsScrollBarEnabled() const =0 | CXTPScrollBase | pure virtual
IsSlider() const | CXTPScrollBase |
IsVisible() const | CXTPStatusBarPane |
m_bAnimation | CXTPScrollBase | protected
m_bAutoDeleteWnd | CXTPStatusBarPane | protected
m_bBeginGroup | CXTPStatusBarPane | protected
m_bButton | CXTPStatusBarPane | protected
m_bCustomizable | CXTPStatusBarPane | protected
m_bIsDark | CXTPStatusBarPane | protected
m_bPressed | CXTPStatusBarPane | protected
m_clrBackground | CXTPStatusBarPane | protected
m_clrText | CXTPStatusBarPane | protected
m_clrTextGray | CXTPStatusBarPane | protected
m_cxText | CXTPStatusBarPane | protected
m_dwHideFlags | CXTPStatusBarPane | protected
m_hWndPane | CXTPStatusBarPane | protected
m_nAlignment | CXTPStatusBarPane | protected
m_nBestFit | CXTPStatusBarPane | protected
m_nIconIndex | CXTPStatusBarPane | protected
m_nID | CXTPStatusBarPane | protected
m_nIndex | CXTPStatusBarPane | protected
m_nMax | CXTPStatusBarScrollBarPane | protected
m_nMin | CXTPStatusBarScrollBarPane | protected
m_nPage | CXTPStatusBarScrollBarPane | protected
m_nStyle | CXTPStatusBarPane | protected
m_nTimerElapse | CXTPScrollBase | protected
m_nValue | CXTPStatusBarScrollBarPane | protected
m_pMarkupUIElement | CXTPStatusBarPane | protected
m_pSBTrack | CXTPScrollBase | protected
m_pStatusBar | CXTPStatusBarPane | protected
m_pTicks | CXTPScrollBase | protected
m_rcMargins | CXTPStatusBarPane | protected
m_rcPadding | CXTPStatusBarPane | protected
m_rcPane | CXTPStatusBarPane | protected
m_scrollBarStyle | CXTPScrollBase | protected
m_spi | CXTPScrollBase | protected
m_strCaption | CXTPStatusBarPane | protected
m_strText | CXTPStatusBarPane | protected
m_strToolTip | CXTPStatusBarPane | protected
m_strToolTipPart | CXTPStatusBarScrollBarPane | protected
m_strValue | CXTPStatusBarPane | protected
m_xtpFontText | CXTPStatusBarPane | protected
OnDraw(CDC *pDC, CRect rcItem) | CXTPStatusBarPane | protectedvirtual
OnLButtonDown(CPoint point) | CXTPStatusBarPane | protectedvirtual
OnMouseMove(CPoint point) | CXTPStatusBarPane | protectedvirtual
OnToolHitTest(CPoint point, TOOLINFO *pTI) const | CXTPStatusBarPane | protectedvirtual
PerformTrackInit(HWND hWnd, CPoint point, XTP_SCROLLBAR_POSINFO *pSBInfo, BOOL bDirect) | CXTPScrollBase |
Redraw() const | CXTPStatusBarPane |
RedrawScrollBar()=0 | CXTPScrollBase | pure virtual
Remove() | CXTPStatusBarPane |
SetBackgroundColor(COLORREF clrBackground) | CXTPStatusBarPane |
SetBeginGroup(BOOL bBeginGroup=TRUE) | CXTPStatusBarPane |
SetButton(BOOL bButton=TRUE) | CXTPStatusBarPane |
SetCaption(LPCTSTR lpszCaption) | CXTPStatusBarPane |
SetChecked(BOOL bChecked) | CXTPStatusBarPane |
SetCustomizationVisible(BOOL bVisible) | CXTPStatusBarPane |
SetDark(BOOL bDark=TRUE) | CXTPStatusBarPane |
SetEnabled(BOOL bEnabled) | CXTPStatusBarPane |
SetIconIndex(int nIconIndex) | CXTPStatusBarPane |
SetMargins(int nLeft, int nTop, int nRight, int nBottom) | CXTPStatusBarPane |
SetPadding(int nLeft, int nTop, int nRight, int nBottom) | CXTPStatusBarPane |
SetPos(int nValue) | CXTPStatusBarScrollBarPane |
SetRange(int nMin, int nMax) | CXTPStatusBarScrollBarPane |
SetScrollBarStyle(XTPScrollBarStyle scrollStyle) | CXTPScrollBase |
SetStyle(UINT nStyle) | CXTPStatusBarPane |
SetText(LPCTSTR lpszText) | CXTPStatusBarPane |
SetTextAlignment(int nAlign) | CXTPStatusBarPane |
SetTextColor(COLORREF clrText) | CXTPStatusBarPane |
SetTextFont(CFont *pFntText) | CXTPStatusBarPane |
SetTextFont(PLOGFONT pLogfText) | CXTPStatusBarPane |
SetTextGrayColor(COLORREF clrText) | CXTPStatusBarPane |
SetTicks(double *pTicks, int nCount) | CXTPStatusBarSliderPane |
SetTooltip(LPCTSTR lpszTooltip) | CXTPStatusBarPane |
SetTooltipPart(int nPart, LPCTSTR lpszTooltip) | CXTPStatusBarScrollBarPane |
SetValue(LPCTSTR lpszValue) | CXTPStatusBarPane |
SetVisible(BOOL bVisible, BOOL bRecalcLayout=TRUE) | CXTPStatusBarPane |
SetWidth(int nWidth) | CXTPStatusBarPane |
ShowBorders(BOOL bShowBorders) | CXTPStatusBarPane |
~CXTPScrollBase() | CXTPScrollBase | virtual
~CXTPStatusBarPane() | CXTPStatusBarPane | virtual
~CXTPStatusBarScrollBarPane() | CXTPStatusBarScrollBarPane | virtual
~CXTPStatusBarSliderPane() | CXTPStatusBarSliderPane |


Toolkit Pro: Member List

CXTPTrackUndoSetBlockPositionCommand Member List

This is the complete list of members for CXTPTrackUndoSetBlockPositionCommand, including all inherited members.

CXTPTrackUndoCommand(int nID) | CXTPTrackUndoCommand | protected
CXTPTrackUndoSetBlockPositionCommand(CXTPTrackBlock *pBlock, int nOldPosition, int nOldLength) | CXTPTrackUndoSetBlockPositionCommand |
GetID() const | CXTPTrackUndoCommand |
m_nID | CXTPTrackUndoCommand | protected
m_nOldLength | CXTPTrackUndoSetBlockPositionCommand | protected
m_nOldPosition | CXTPTrackUndoSetBlockPositionCommand | protected
m_pBlock | CXTPTrackUndoSetBlockPositionCommand | protected
Undo() | CXTPTrackUndoSetBlockPositionCommand | protectedvirtual
~CXTPTrackUndoCommand() | CXTPTrackUndoCommand | protectedvirtual
~CXTPTrackUndoSetBlockPositionCommand() | CXTPTrackUndoSetBlockPositionCommand | virtual


Toolkit Pro: Member List

CXTPCommonPicturePreviewProvider Member List

This is the complete list of members for CXTPCommonPicturePreviewProvider, including all inherited members.

BindHost(IXTPPreviewHost &host) | CXTPPreviewProviderBase | protectedvirtual
CXTPPreviewProviderBase() | CXTPPreviewProviderBase | protected
GetHost() const | CXTPPreviewProviderBase | protected
~IXTPPreviewProvider() | IXTPPreviewProvider | inlinevirtual


Toolkit Pro: Member List

CXTPFlowGraphUndoAddConnectionCommand Member List

This is the complete list of members for CXTPFlowGraphUndoAddConnectionCommand, including all inherited members.

CXTPFlowGraphUndoAddConnectionCommand(CXTPFlowGraphConnection *pConnection) | CXTPFlowGraphUndoAddConnectionCommand |
CXTPFlowGraphUndoCommand(int nID) | CXTPFlowGraphUndoCommand | protected
GetID() const | CXTPFlowGraphUndoCommand |
m_nID | CXTPFlowGraphUndoCommand | protected
m_pConnection | CXTPFlowGraphUndoAddConnectionCommand | protected
Undo() | CXTPFlowGraphUndoAddConnectionCommand | protectedvirtual
~CXTPFlowGraphUndoAddConnectionCommand() | CXTPFlowGraphUndoAddConnectionCommand | virtual
~CXTPFlowGraphUndoCommand() | CXTPFlowGraphUndoCommand | protectedvirtual


Toolkit Pro: Member List

CXTPShortcutListBoxThemeOffice2003 Member List

This is the complete list of members for CXTPShortcutListBoxThemeOffice2003, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPControlTheme() | CXTPControlTheme |
CXTPShortcutListBoxTheme() | CXTPShortcutListBoxTheme |
CXTPShortcutListBoxThemeOffice2003() | CXTPShortcutListBoxThemeOffice2003 |
CXTPShortcutListBoxThemeOfficeXP() | CXTPShortcutListBoxThemeOfficeXP |
DrawImage(CDC *pDC, CRect &rcIcon, CXTPImageManagerIcon *pImage, BOOL bEnabled, BOOL bSelected, BOOL bPressed) | CXTPShortcutListBoxThemeOffice2003 | protectedvirtual
DrawItem(CXTPShortcutListBox *pMenuListBox, LPDRAWITEMSTRUCT lpDIS) | CXTPShortcutListBoxTheme | virtual
DrawText(CDC *pDC, CRect &rcText, CXTPShortcutListBox::CONTENT_ITEM *pCI) | CXTPShortcutListBoxThemeOfficeXP | protectedvirtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetBackColor() | CXTPShortcutListBoxTheme |
GetTextColor() | CXTPShortcutListBoxTheme |
GetThemeStyle() const | CXTPControlTheme |
m_crgBack | CXTPShortcutListBoxTheme |
m_crgItemBackHot | CXTPShortcutListBoxTheme |
m_crgItemBackPressed | CXTPShortcutListBoxTheme |
m_crgItemBorder | CXTPShortcutListBoxTheme |
m_crItemText | CXTPShortcutListBoxTheme |
m_crItemTextDisabled | CXTPShortcutListBoxTheme |
m_cxIcon | CXTPShortcutListBoxTheme |
m_cyEdge | CXTPShortcutListBoxTheme |
m_cyIcon | CXTPShortcutListBoxTheme |
m_nTheme | CXTPControlTheme | protected
RefreshMetrics(CXTPShortcutListBox *pList) | CXTPShortcutListBoxThemeOffice2003 | virtual
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static
~CXTPShortcutListBoxTheme() | CXTPShortcutListBoxTheme | virtual


Toolkit Pro: Member List

CXTPTabThemeNativeWindows11 Member List

This is the complete list of members for CXTPTabThemeNativeWindows11, including all inherited members.

AdjustClientRect(CXTPTabManager *pTabManager, CRect &rcClient) | CXTPTabPaintManagerTheme | virtual
CXTPTabPaintManagerTheme() | CXTPTabPaintManagerTheme |
CXTPTabThemeFlat() | CXTPTabThemeFlat | inline
CXTPTabThemeNativeWindows11() | CXTPTabThemeNativeWindows11 |
CXTPTabThemeOffice2013() | CXTPTabThemeOffice2013 |
DrawSingleButton(CDC *pDC, CXTPTabManagerItem *pItem) | CXTPTabThemeVisualStudio2012 | virtual
DrawTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl) | CXTPTabPaintManagerTheme | virtual
DrawText(CDC *pDC, CXTPTabManager *pManager, const CString &str, LPRECT lpRect, UINT nFormat) | CXTPTabPaintManagerTheme | virtual
DrawWorkspacePart(CDC *pDC, LPRECT lpRect, XTPTabWorkspacePart workspacePart) | CXTPTabThemeVisualStudio2012 | virtual
FillButton(CDC *pDC, CXTPTabManagerItem *pItem, LPPOINT pts, int nCount, XTPTabPosition tabPosition, BOOL bAbsolute=FALSE) | CXTPTabPaintManagerTheme |
FillTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl) | CXTPTabThemeFlat | virtual
GetButtonDrawRect(const CXTPTabManagerItem *pItem) | CXTPTabPaintManagerTheme | virtual
GetButtonHeight(const CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetButtonLength(CDC *pDC, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerTheme | virtual
GetClientMargin() | CXTPTabPaintManagerTheme | virtual
GetClientRect(CRect rcControl, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetColorSet() const | CXTPTabPaintManagerTheme |
GetDefaultColorSet() | CXTPTabThemeNativeWindows11 | inlinevirtual
GetHeaderClipBox(CDC *pDC, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetHeaderHeight(CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme |
GetHeaderMargin() | CXTPTabPaintManagerTheme | virtual
GetHeaderRect(CRect rcControl, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetSupportedColorSets() | CXTPTabPaintManagerTheme | inlinevirtual
m_bButtonsReverseZOrder | CXTPTabPaintManagerTheme | protected
m_nButtonHeight | CXTPTabPaintManagerTheme | protected
m_nRowMargin | CXTPTabPaintManagerTheme |
m_pPaintManager | CXTPTabPaintManagerTheme | protected
m_rcHeaderMargin | CXTPTabPaintManagerTheme |
RefreshMetrics() | CXTPTabThemeNativeWindows11 | virtual
RepositionTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcClient) | CXTPTabPaintManagerTheme | virtual
~CXTPTabPaintManagerTheme() | CXTPTabPaintManagerTheme | virtual


Toolkit Pro: Member List

CXTPProgressPaintManager Member List

This is the complete list of members for CXTPProgressPaintManager, including all inherited members.

CXTPProgressPaintManager(CXTPPaintManager *pPaintManager) | CXTPProgressPaintManager |
DrawProgress(CDC *pDC, CXTPProgressBase *pProgressBar) | CXTPProgressPaintManager | virtual
GetPaintManager() const | CXTPProgressPaintManager |
m_cyProgress | CXTPProgressPaintManager |
m_pPaintManager | CXTPProgressPaintManager | protected
RefreshMetrics() | CXTPProgressPaintManager | virtual
~CXTPProgressPaintManager() | CXTPProgressPaintManager | virtual


Toolkit Pro: XTPChartRectangleDeviceCommand.h Source File

  • Source
  • Chart
  • Drawing
XTPChartRectangleDeviceCommand.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTRECTANGLEDEVICECOMMAND_H__)
24# define __XTPCHARTRECTANGLEDEVICECOMMAND_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
37class _XTP_EXT_CLASS CXTPChartRectangleDeviceCommand : public CXTPChartDeviceCommand
38{
39protected:
46 CXTPChartRectangleDeviceCommand(const CXTPChartRectF& rect);
47
58 CXTPChartElement* HitTest(CPoint point, CXTPChartElement* pParent) const;
59
60protected:
61 CXTPChartRectF m_rect;
62};
64# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
65#endif //#if !defined(__XTPCHARTRECTANGLEDEVICECOMMAND_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPChartElement
This class abstracts a chart element, this class acts as a base class for all chart elements.
Definition XTPChartElement.h:131
CXTPChartRectangleDeviceCommand
Base class implementation for 2D chart rectangle device command.
Definition XTPChartRectangleDeviceCommand.h:38
CXTPChartRectangleDeviceCommand::HitTest
CXTPChartElement * HitTest(CPoint point, CXTPChartElement *pParent) const
Performs recursive hit testing of the element at the specified point.
CXTPChartRectangleDeviceCommand::m_rect
CXTPChartRectF m_rect
The bounds of the rectangle.
Definition XTPChartRectangleDeviceCommand.h:61
CXTPChartRectangleDeviceCommand::CXTPChartRectangleDeviceCommand
CXTPChartRectangleDeviceCommand(const CXTPChartRectF &rect)
Constructs a CXTPChartRectangleDeviceCommand object.
CXTPRectT< float >


Toolkit Pro: XTPTrackThemeOffice2003Luna.h Source File

  • Source
  • GridControl
  • TrackControl
  • Themes
XTPTrackThemeOffice2003Luna.h
Go to the documentation of this file.
1
23#if !defined(__XTPTRACKTHEMEOffice2003Luna_H__)
24# define __XTPTRACKTHEMEOffice2003Luna_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPTrackThemeOffice2003Luna : public CXTPTrackPaintManager
39{
40public:
45 CXTPTrackThemeOffice2003Luna();
46
52 virtual void RefreshMetrics();
53
60 virtual void FillFooter(CDC* pDC, CRect rcFooter);
61
73 virtual BOOL IsColumHotTrackingEnabled() const;
74
86 virtual void DrawColumnBackground(CDC* pDC, CXTPGridColumn* pColumn, CRect rcColumn,
87 BOOL& bColumnPressed, BOOL& bDraggingFromHeader,
88 CXTPGridHeader* pHeader = NULL);
89
97 virtual void DrawColumnFooterDivider(CDC* pDC, CXTPGridColumn* pColumn, CRect rcColumn);
98
111 void DrawSectionDivider(CDC* pDC, const CRect& rc,
112 XTPGridSectionDividerPosition dividerPosition,
113 XTPGridSectionDividerStyle dividerStyle,
114 CXTPPaintManagerColor dividerColor);
115};
117# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
118#endif //#if !defined(__XTPTRACKTHEMEOffice2003Luna_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPGridSectionDividerPosition
XTPGridSectionDividerPosition
Section divider position.
Definition XTPGridDefines.h:258
XTPGridSectionDividerStyle
XTPGridSectionDividerStyle
Represent the header/footer rows divider style.
Definition XTPGridDefines.h:227
CXTPGridColumn
Represents a grid column item with its properties and operations.
Definition XTPGridColumn.h:107
CXTPGridHeader
A grid header is a part of the grid window positioned above columns of text or numbers.
Definition XTPGridHeader.h:173
CXTPPaintManagerColor
The CXTPPaintManagerColor class is used to manage COLORREF values for determining default and applica...
Definition XTPColorManager.h:117
CXTPTrackPaintManager
This class represents a track control paint manager.
Definition XTPTrackPaintManager.h:41
CXTPTrackThemeOffice2003Luna
CXTPTrackThemeOffice2003Luna is a CXTPTrackPaintManager derived class that represents an Office 2003 ...
Definition XTPTrackThemeOffice2003Luna.h:39
CXTPTrackThemeOffice2003Luna::DrawSectionDivider
void DrawSectionDivider(CDC *pDC, const CRect &rc, XTPGridSectionDividerPosition dividerPosition, XTPGridSectionDividerStyle dividerStyle, CXTPPaintManagerColor dividerColor)
Draws the divider between grid sections (e.g.
CXTPTrackThemeOffice2003Luna::DrawColumnBackground
virtual void DrawColumnBackground(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, BOOL &bColumnPressed, BOOL &bDraggingFromHeader, CXTPGridHeader *pHeader=NULL)
This method is called to draw the background of a column using the current column style.
CXTPTrackThemeOffice2003Luna::IsColumHotTrackingEnabled
virtual BOOL IsColumHotTrackingEnabled() const
Determines if hot tracking is enabled for the current column style.
CXTPTrackThemeOffice2003Luna::FillFooter
virtual void FillFooter(CDC *pDC, CRect rcFooter)
Fills the column footer control area by its background.
CXTPTrackThemeOffice2003Luna::DrawColumnFooterDivider
virtual void DrawColumnFooterDivider(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn)
Draws the column footer divider.
CXTPTrackThemeOffice2003Luna::CXTPTrackThemeOffice2003Luna
CXTPTrackThemeOffice2003Luna()
Default paint manager constructor, handles properties initialization.
CXTPTrackThemeOffice2003Luna::RefreshMetrics
virtual void RefreshMetrics()
This method is called to refresh the visual metrics of the track control.


Toolkit Pro: Member List

NMXTPTABCHANGE Member List

This is the complete list of members for NMXTPTABCHANGE, including all inherited members.

hdr | NMXTPCONTROL
pControl | NMXTPCONTROL
pTab | NMXTPTABCHANGE


Toolkit Pro: XTPChartBarSeriesStyle.h Source File

  • Source
  • Chart
  • Styles
  • Bar
XTPChartBarSeriesStyle.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTBARSERIESSTYLE_H__)
24# define __XTPCHARTBARSERIESSTYLE_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartSeriesView;
34
46class _XTP_EXT_CLASS CXTPChartBarSeriesStyle : public CXTPChartDiagram2DSeriesStyle
47{
49 DECLARE_SERIAL(CXTPChartBarSeriesStyle)
51public:
56 CXTPChartBarSeriesStyle();
57
62 virtual ~CXTPChartBarSeriesStyle();
63
64public:
65 void DoPropExchange(CXTPPropExchange* pPX);
66
67public:
75 double GetBarWidth() const;
76
83 void SetBarWidth(double dWidth);
84
85 CXTPChartFillStyle* GetFillStyle() const;
86
87 CXTPChartBorder* GetBorder() const;
88
89 BOOL IsSideBySide() const;
90 void SetSideBySide(BOOL bSideBySide);
91
92 int GetBarDistanceFixed() const;
93 void SetBarDistanceFixed(int nBarDistanceFixed);
94
95protected:
109 virtual CXTPChartSeriesView* CreateView(CXTPChartSeries* pSeries,
110 CXTPChartDiagramView* pDiagramView);
111
123 virtual void CorrectAxisSideMargins(CXTPChartAxis* pAxis, double nMinValue, double nMaxValue,
124 double& nCorrection);
125
126protected:
127 double m_dBarWidth; // The width of the bar.
128
129 CXTPChartFillStyle* m_pFillStyle;
130 CXTPChartBorder* m_pBorder;
131 BOOL m_bSideBySide;
132 int m_nBarDistanceFixed;
133
134# ifdef _XTP_ACTIVEX
135public:
137 DECLARE_DISPATCH_MAP()
138 DECLARE_INTERFACE_MAP()
139 DECLARE_OLETYPELIB_EX(CXTPChartBarSeriesStyle);
140 DECLARE_OLECREATE_EX(CXTPChartBarSeriesStyle)
141
142 LPDISPATCH OleGetFillStyle();
143 LPDISPATCH OleGetBorder();
145# endif
146};
147
148AFX_INLINE double CXTPChartBarSeriesStyle::GetBarWidth() const
149{
150 return m_dBarWidth;
151}
152
153AFX_INLINE void CXTPChartBarSeriesStyle::SetBarWidth(double dWidth)
154{
155 m_dBarWidth = dWidth;
156 OnChartChanged();
157}
158AFX_INLINE CXTPChartFillStyle* CXTPChartBarSeriesStyle::GetFillStyle() const
159{
160 return m_pFillStyle;
161}
162AFX_INLINE CXTPChartBorder* CXTPChartBarSeriesStyle::GetBorder() const
163{
164 return m_pBorder;
165}
166AFX_INLINE void CXTPChartBarSeriesStyle::SetSideBySide(BOOL bSideBySide)
167{
168 m_bSideBySide = bSideBySide;
169 OnChartChanged();
170}
171AFX_INLINE BOOL CXTPChartBarSeriesStyle::IsSideBySide() const
172{
173 return m_bSideBySide;
174}
175AFX_INLINE int CXTPChartBarSeriesStyle::GetBarDistanceFixed() const
176{
177 return m_nBarDistanceFixed;
178}
179AFX_INLINE void CXTPChartBarSeriesStyle::SetBarDistanceFixed(int nBarDistanceFixed)
180{
181 m_nBarDistanceFixed = nBarDistanceFixed;
182 OnChartChanged();
183}
185# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
186#endif //#if !defined(__XTPCHARTBARSERIESSTYLE_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartAxis
This abstract base class represents a chart axis as a kind of chart element.
Definition XTPChartAxis.h:86
CXTPChartBarSeriesStyle
This class represents a bar series style for the chart, which is a kind of CXTPChartSeriesStyle.
Definition XTPChartBarSeriesStyle.h:47
CXTPChartBarSeriesStyle::DoPropExchange
void DoPropExchange(CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
CXTPChartBarSeriesStyle::CXTPChartBarSeriesStyle
CXTPChartBarSeriesStyle()
Constructs a CXTPChartBarSeriesStyle object.
CXTPChartBarSeriesStyle::GetBarWidth
double GetBarWidth() const
Call this function to get the width of the bar.
Definition XTPChartBarSeriesStyle.h:148
CXTPChartBarSeriesStyle::CreateView
virtual CXTPChartSeriesView * CreateView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Call this function to create the view of the bar series.
CXTPChartBarSeriesStyle::CorrectAxisSideMargins
virtual void CorrectAxisSideMargins(CXTPChartAxis *pAxis, double nMinValue, double nMaxValue, double &nCorrection)
Call this function to correct the axis side margins.
CXTPChartBarSeriesStyle::~CXTPChartBarSeriesStyle
virtual ~CXTPChartBarSeriesStyle()
Destroys a CXTPChartBarSeriesStyle object, handles cleanup.
CXTPChartBarSeriesStyle::SetBarWidth
void SetBarWidth(double dWidth)
Call this function to set the width of the bar.
Definition XTPChartBarSeriesStyle.h:153
CXTPChartBorder
This class abstracts the border of a chart, it is a kind of chart element.
Definition XTPChartBorder.h:42
CXTPChartDiagram2DSeriesStyle
This class represents a line series style, which is a kind of CXTPChartSeriesStyle.
Definition XTPChartDiagram2DSeriesStyle.h:47
CXTPChartDiagramView
This class represents the view of a chart diagram, which is a kind of CXTPChartElementView.
Definition XTPChartDiagramView.h:49
CXTPChartElement::OnChartChanged
virtual void OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic propertie...
CXTPChartFillStyle
This class abstracts a fill style used to fill the background of various chart elements.
Definition XTPChartFillStyle.h:43
CXTPChartSeries
This class represents a series in the chart, which is a kind of CXTPChartElement.
Definition XTPChartSeries.h:50
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72


Toolkit Pro: Member List

CXTPCalendarTimeLineView Member List

This is the complete list of members for CXTPCalendarTimeLineView, including all inherited members.

_CalculateEventTimeFormat() | CXTPCalendarView | protectedvirtual
_CanSubjectEditor(UINT idEditCmd) const | CXTPCalendarView | protectedvirtual
_CopySelectedEvents(DWORD dwCopyFlags=0) | CXTPCalendarView | protectedvirtual
_GetDayHeaderFormat(int nLevel) const | CXTPCalendarView | protectedvirtual
_GetEvents(COleDateTime dtStartDay, COleDateTime dtEndDay) | CXTPCalendarTimeLineView | protectedvirtual
_GetMaxWidth(CDC *pDC, CString strFormat) const | CXTPCalendarView | protectedvirtual
_GetMaxWidthFormat(CDC *pDC, CString strFormat, BOOL bMonth) const | CXTPCalendarView | protectedvirtual
_GetSubjectEditorWnd() const | CXTPCalendarView | protectedvirtual
_GetViewDay(const COleDateTime &dtDay) const | CXTPCalendarView | virtual
_IsDragModeCopyMove(int eDragMode) const | CXTPCalendarView | protected
_ReadDefaultHeaderFormats() | CXTPCalendarView | protectedvirtual
_ReadEventsFromClipboard(COleDataObject *pData, DWORD *pdwCopyFlags=NULL) | CXTPCalendarView | protectedvirtual
_RemoveYearPart(CString &strFormat) | CXTPCalendarView | protectedvirtual
_Undo(CXTPCalendarEvent *pEvent=NULL) | CXTPCalendarView | protectedvirtual
AddToDiscreteSelection(UINT id) | CXTPCalendarView |
AdjustLayout(CDC *pDC, const CRect &rcView, BOOL bCallPostAdjustLayout=TRUE) | CXTPCalendarTimeLineView | virtual
AdjustLayout2(CDC *pDC, const CRect &rcView, BOOL bCallPostAdjustLayout=TRUE) | CXTPCalendarView | virtual
CalculateHeaderFormat(CDC *pDC, int nWidth, CFont *pTextFont) | CXTPCalendarView | virtual
CancelDraggingEvent() | CXTPCalendarView | virtual
CanCopy() const | CXTPCalendarView | virtual
CanCut() const | CXTPCalendarView | virtual
CanPaste() const | CXTPCalendarView | virtual
CanRedo() const | CXTPCalendarView | virtual
CanUndo() const | CXTPCalendarView | virtual
ClearDiscreteSelection() | CXTPCalendarView |
CommitDraggingEvent() | CXTPCalendarView | virtual
Copy() | CXTPCalendarView | virtual
Cut() | CXTPCalendarView | virtual
CXTPCalendarTimeLineView(CXTPCalendarControl *pCalendarControl) | CXTPCalendarTimeLineView |
CXTPCalendarView(CXTPCalendarControl *pCalendarControl) | CXTPCalendarView |
CXTPCalendarWMHandler() | CXTPCalendarWMHandler |
CXTPCmdTarget() | CXTPCmdTarget |
Draw(CDC *pDC) | CXTPCalendarTimeLineView | virtual
Draw2(CDC *pDC) | CXTPCalendarTimeLineView | virtual
EmptyUndoBuffer() | CXTPCalendarView | virtual
EnableHScroll(BOOL bEnable=TRUE) | CXTPCalendarView | virtual
EnableVScroll(BOOL bEnable=TRUE) | CXTPCalendarView | virtual
EndEditSubject(XTPCalendarEndEditSubjectAction eAction, BOOL bUpdateControl=TRUE) | CXTPCalendarView | virtual
FindEventToEditByTAB(COleDateTime dtMinStart, BOOL bReverse, CXTPCalendarEvent *pAfterEvent=NULL) | CXTPCalendarView | virtual
FindLastSelectedDay() const | CXTPCalendarView |
FindViewEvent(CXTPCalendarEvent *pEvent, COleDateTime dtDay) const | CXTPCalendarView | virtual
FormatEventTime(COleDateTime dtTime) const | CXTPCalendarView | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCalendarControl() const | CXTPCalendarView |
GetCalendarOptions() const | CXTPCalendarView |
GetChildHandlerAt(int nIndex) const | CXTPCalendarView | virtual
GetChildHandlersCount() const | CXTPCalendarView | virtual
GetDayHeaderFormat() const | CXTPCalendarView | virtual
GetDiscreteSelectionCount() const | CXTPCalendarView |
GetDiscreteSelectionValue(UINT id) const | CXTPCalendarView |
GetDraggingEventNew() const | CXTPCalendarView | virtual
GetDraggingEventOrig() const | CXTPCalendarView | virtual
GetDraggingMode() const | CXTPCalendarView | virtual
GetEventDurationMin() const | CXTPCalendarView | protectedvirtual
GetItemTextEventTimeMax() const | CXTPCalendarView | virtual
GetLastSelectedDate() const | CXTPCalendarView |
GetLastSelectedViewEvent() const | CXTPCalendarView |
GetNextTimeEditByTAB() const | CXTPCalendarView | virtual
GetPaintManager() const | CXTPCalendarView | virtual
GetResources() const | CXTPCalendarView | virtual
GetRowHeight() const | CXTPCalendarView | virtual
GetScrollBarInfoH(SCROLLINFO *pSI, int *pnScrollStep=NULL) const | CXTPCalendarTimeLineView | virtual
GetScrollBarInfoV(SCROLLINFO *pSI) const | CXTPCalendarTimeLineView | virtual
GetSelectedEvents() const | CXTPCalendarView | virtual
GetSelectedViewEvents() const | CXTPCalendarView | virtual
GetSelection(COleDateTime *pBegin=NULL, COleDateTime *pEnd=NULL, BOOL *pbAllDayEvent=NULL, int *pnGroupIndex=NULL, COleDateTimeSpan *pspSelectionResolution=NULL) const | CXTPCalendarView | virtual
GetShowToolTipTimeOut() const | CXTPCalendarView | virtual
GetStartEditSubjectTimeOut() const | CXTPCalendarView | virtual
GetStartViewDate() const | CXTPCalendarTimeLineView | virtual
GetSubjectEditorRect() const | CXTPCalendarView | virtual
GetTheme() const | CXTPCalendarView | virtual
GetTimeScale() const | CXTPCalendarTimeLineView |
GetTimeScaleID() const | CXTPCalendarTimeLineView | virtual
GetTooltipRect(const CPoint &ptHit, const XTP_CALENDAR_HITTESTINFO &hitInfo) const | CXTPCalendarTimeLineView | protectedvirtual
GetViewDay_(int nIndex) const | CXTPCalendarView | virtual
GetViewDayCount() const | CXTPCalendarView | virtual
GetViewDayDate(int nIndex) const | CXTPCalendarTimeLineView | virtual
GetViewRect() const | CXTPCalendarView |
GetViewType() const | CXTPCalendarTimeLineView | virtual
HasSelectedViewEvent() const | CXTPCalendarView | virtual
HitTest(CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const | CXTPCalendarTimeLineView | virtual
HitTestEx(CPoint pt, XTP_CALENDAR_HITTESTINFO_TIMELINE_VIEW *pHitTest) const | CXTPCalendarTimeLineView | virtual
HitTestEx(CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const | CXTPCalendarTimeLineView | virtual
IsEditingSubject() const | CXTPCalendarView | virtual
IsEditOperationDisabledNotify(XTPCalendarEditOperation eOperation, CXTPCalendarViewEvent *pEventView) const | CXTPCalendarView | protected
IsHScrollEnabled() const | CXTPCalendarView | virtual
IsInDiscreteSelection(UINT id) const | CXTPCalendarView |
IsSingleEventSelected() const | CXTPCalendarView |
IsTodayVisible() const | CXTPCalendarView | virtual
IsVScrollEnabled() const | CXTPCalendarView | virtual
KillTimer(UINT uTimerID) | CXTPCalendarView | protectedvirtual
m_arDays | CXTPCalendarView | mutableprotected
m_bResetUndoBuffer | CXTPCalendarView | protected
m_bScrollH_Disabled | CXTPCalendarView | protected
m_bScrollV_Disabled | CXTPCalendarView | protected
m_bStartedClickInside | CXTPCalendarView | protected
m_bTimeLineSeparateGroup | CXTPCalendarTimeLineView |
m_clrBackground | CXTPCalendarTimeLineView |
m_clrEventBar | CXTPCalendarTimeLineView |
m_clrEventBarLine | CXTPCalendarTimeLineView |
m_clrEventBorderLine | CXTPCalendarTimeLineView |
m_clrSelectedBackground | CXTPCalendarTimeLineView |
m_clrSelectedText | CXTPCalendarTimeLineView |
m_clrText | CXTPCalendarTimeLineView |
m_clrTimeScaleBackground | CXTPCalendarTimeLineView |
m_clrTimeScaleBorder | CXTPCalendarTimeLineView |
m_clrTimeScaleHighlight | CXTPCalendarTimeLineView |
m_clrTimeScaleText | CXTPCalendarTimeLineView |
m_clrWeekendBackground | CXTPCalendarTimeLineView |
m_cntSelChanged | CXTPCalendarView | protected
m_eDraggingMode | CXTPCalendarView | protected
m_eUndoMode | CXTPCalendarView | protected
m_EventTimeFormat | CXTPCalendarView | protected
m_LastHitInfo | CXTPCalendarView | protected
m_Layout | CXTPCalendarView | protected
m_nHScrollPos | CXTPCalendarTimeLineView | protected
m_nKeyStateTimerID | CXTPCalendarView | protected
m_nTimelineMaxPixelsForEvent | CXTPCalendarTimeLineView |
m_nTimelineMaxPixelsForEvent_ScaleDay | CXTPCalendarTimeLineView |
m_nTimelineMaxPixelsForEvent_ScaleWeek | CXTPCalendarTimeLineView |
m_nTimerID_ShowToolTip | CXTPCalendarView | protected
m_nTimerID_StartEditSubject | CXTPCalendarView | protected
m_nVScrollPos | CXTPCalendarTimeLineView | protected
m_pControl | CXTPCalendarView | protected
m_pGroups | CXTPCalendarTimeLineView |
m_pLastEvent | CXTPCalendarView | protected
m_pPrevUndoBuffer | CXTPCalendarView | protected
m_pResources | CXTPCalendarView | protected
m_pSelectedEvents | CXTPCalendarView | protected
m_pTimeScale | CXTPCalendarTimeLineView | protected
m_ptrDraggingEventNew | CXTPCalendarView | protected
m_ptrDraggingEventOrig | CXTPCalendarView | protected
m_ptrEditingViewEvent | CXTPCalendarView | protected
m_ptStartDragging | CXTPCalendarView | protected
m_pUndoBuffer | CXTPCalendarView | protected
m_rcTooltip | CXTPCalendarView | protected
m_rcView | CXTPCalendarView | protected
m_selectedBlock | CXTPCalendarView | protected
m_spDraggingStartOffset | CXTPCalendarView | protected
m_strDayHeaderFormatDefaultLong | CXTPCalendarView | protected
m_strDayHeaderFormatDefaultMiddle | CXTPCalendarView | protected
m_strDayHeaderFormatDefaultShort | CXTPCalendarView | protected
m_strDayHeaderFormatDefaultShortest | CXTPCalendarView | protected
m_strDayHeaderFormatLong | CXTPCalendarView | protected
m_strDayHeaderFormatMiddle | CXTPCalendarView | protected
m_strDayHeaderFormatShort | CXTPCalendarView | protected
m_strDayHeaderFormatShortest | CXTPCalendarView | protected
m_strHeaderFormat | CXTPCalendarView | protected
OnActivateView(BOOL bActivate, CXTPCalendarView *pActivateView, CXTPCalendarView *pInactiveView) | CXTPCalendarView | protectedvirtual
OnBeforeDestroy() | CXTPCalendarTimeLineView | protectedvirtual
OnBeforeEditOperationNotify(XTPCalendarEditOperation eOperation, CXTPCalendarViewEvent *pEventView) | CXTPCalendarView | protected
OnBeforeEditOperationNotify(XTPCalendarEditOperation eOperation, CXTPCalendarViewEvents *pEventViews) | CXTPCalendarView | protected
OnBeforePasteNotify(CXTPCalendarEvent *pEvent, BOOL bPasteWillChangeExistingEvent) | CXTPCalendarView | protected
OnChar(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarView | virtual
OnDragging(CPoint point, XTP_CALENDAR_HITTESTINFO *pHitTest) | CXTPCalendarView | virtual
OnDraw(CDC *pDC) | CXTPCalendarView | virtual
OnEndDragging(CPoint point, XTP_CALENDAR_HITTESTINFO *pHitInfo) | CXTPCalendarView | virtual
OnEventChanged_InDataProvider(XTP_NOTIFY_CODE nfCode, CXTPCalendarEvent *pEvent) | CXTPCalendarView | protectedvirtual
OnInPlaceCreateEvent(LPCTSTR pcszInitialSubject) | CXTPCalendarView | protected
OnKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarView | virtual
OnKeyUp(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnLButtonDblClk(UINT nFlags, CPoint point) | CXTPCalendarView | virtual
OnLButtonDown(UINT nFlags, CPoint point) | CXTPCalendarView | virtual
OnLButtonUp(UINT nFlags, CPoint point) | CXTPCalendarView | virtual
OnMouseMove(UINT nFlags, CPoint point) | CXTPCalendarView | virtual
OnPostAdjustLayout() | CXTPCalendarWMHandler | virtual
OnScrollEnd(int nBar) | CXTPCalendarTimeLineView | protectedvirtual
OnStartDragging(CPoint point, XTP_CALENDAR_HITTESTINFO *pHitTest) | CXTPCalendarView | virtual
OnSysKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarView | virtual
OnTimer(UINT_PTR uTimerID) | CXTPCalendarView | protectedvirtual
OnUpdateEditingSubject(CString strNewSubject) | CXTPCalendarView | virtual
OnWndMsg(UINT message, WPARAM wParam, LPARAM lParam, LRESULT *pResult) | CXTPCalendarWMHandler | virtual
Paste() | CXTPCalendarView | virtual
Populate() | CXTPCalendarTimeLineView | virtual
ProcessDaySelection(XTP_CALENDAR_HITTESTINFO *pInfo, UINT nFlags) | CXTPCalendarView | virtual
ProcessEventSelection(XTP_CALENDAR_HITTESTINFO *pInfo, UINT nFlags) | CXTPCalendarView | virtual
Redo() | CXTPCalendarView | virtual
RedrawControl() | CXTPCalendarView | virtual
RefreshMetrics() | CXTPCalendarTimeLineView | protectedvirtual
ResetCustomTimeFormat() | CXTPCalendarView |
ResetSelection() | CXTPCalendarView |
RetrieveDayEvents(CXTPCalendarResource *pRC, COleDateTime dtDay) | CXTPCalendarView | virtual
ScrollH(int nPos, int nPos_raw) | CXTPCalendarTimeLineView | virtual
ScrollV(int nPos, int nPos_raw) | CXTPCalendarTimeLineView | virtual
SelectDay(CXTPCalendarViewDay *pDay, int nGroupIndex=0) | CXTPCalendarView | virtual
SelectDay(COleDateTime dtSelDay, int nGroupIndex=0) | CXTPCalendarView | virtual
SelectDays(COleDateTime dtNewSel) | CXTPCalendarView | virtual
SelectEvent(CXTPCalendarEvent *pEvent, BOOL bSelect=TRUE) | CXTPCalendarView | virtual
SelectionContains(COleDateTime date, int nGroupIndex=-1, BOOL *pbAllDaySelection=NULL) | CXTPCalendarView |
SelectViewEvent(CXTPCalendarViewEvent *pViewEvent, BOOL bSelect=TRUE) | CXTPCalendarView |
SendNotification(XTP_NOTIFY_CODE EventCode, WPARAM wParam=0, LPARAM lParam=0) | CXTPCalendarView | protectedvirtual
SetCustomTimeFormat(const CString &strFormat) | CXTPCalendarView |
SetDayHeaderFormat(LPCTSTR sFmt) | CXTPCalendarView | virtual
SetDayHeaderFormatLong(LPCTSTR pcszCustomFormat) | CXTPCalendarView | virtual
SetDayHeaderFormatMiddle(LPCTSTR pcszCustomFormat) | CXTPCalendarView | virtual
SetDayHeaderFormatShort(LPCTSTR pcszCustomFormat) | CXTPCalendarView | virtual
SetDayHeaderFormatShortest(LPCTSTR pcszCustomFormat) | CXTPCalendarView | virtual
SetDraggingEvent(CXTPCalendarEvent *pEventOrig) | CXTPCalendarView | virtual
SetResources(CXTPCalendarResources *pResources) | CXTPCalendarView | virtual
SetSelection(const COleDateTime &dtBegin, const COleDateTime &dtEnd, BOOL bAllDayEvent=FALSE, int nGroupIndex=0) | CXTPCalendarView |
SetStartViewDate(COleDateTime dt) | CXTPCalendarTimeLineView | virtual
SetTimer(UINT uTimeOut_ms) | CXTPCalendarView | protectedvirtual
SetTimeScaleID(int eTimeScaleParamsID) | CXTPCalendarTimeLineView | virtual
ShowCalendarPopup(COleDateTime dt, CPoint point) | CXTPCalendarTimeLineView |
ShowDay(const COleDateTime &date, BOOL bSelect=TRUE) | CXTPCalendarTimeLineView | inlinevirtual
ShowToolTip(BOOL bShow=TRUE) | CXTPCalendarView | virtual
StartEditNewEventInplace(LPCTSTR pcszInitialSubject) | CXTPCalendarView | virtual
StartEditSubject(CXTPCalendarViewEvent *pViewEvent) | CXTPCalendarView | virtual
TBase typedef | CXTPCalendarTimeLineView |
Undo() | CXTPCalendarView | virtual
UnselectAllEvents() | CXTPCalendarView | virtual
UpdateNextTimeEditByTAB(COleDateTime dtNext, BOOL bReverse, BOOL bReset=FALSE) | CXTPCalendarView | virtual
~CXTPCalendarTimeLineView() | CXTPCalendarTimeLineView | virtual
~CXTPCalendarView() | CXTPCalendarView | virtual


Toolkit Pro: Member List

CXTPChartFunnelSeriesStyleBase Member List

This is the complete list of members for CXTPChartFunnelSeriesStyleBase, including all inherited members.

ApplyTo(CXTPChartDeviceCommand *pCommand) | CXTPChartSeriesStyle | virtual
CorrectAxisSideMargins(CXTPChartAxis *pAxis, double nMinValue, double nMaxValue, double &nCorrection) | CXTPChartSeriesStyle | virtual
CreateDiagram()=0 | CXTPChartFunnelSeriesStyleBase | protectedpure virtual
CreateView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)=0 | CXTPChartFunnelSeriesStyleBase | protectedpure virtual
CXTPChartElement() | CXTPChartElement |
CXTPChartFunnelSeriesStyleBase() | CXTPChartFunnelSeriesStyleBase |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartSeriesStyle() | CXTPChartSeriesStyle |
DoPropExchange(CXTPPropExchange *pPX) | CXTPChartFunnelSeriesStyleBase | virtual
Enable3dEdgeSmoothing(BOOL bEnable=TRUE) | CXTPChartSeriesStyle | virtual
Get3dRotation() const | CXTPChartSeriesStyle | virtual
GetAppearance() const | CXTPChartElement |
GetBorder() const | CXTPChartFunnelSeriesStyleBase |
GetColor() const | CXTPChartSeriesStyle | virtual
GetContent() const | CXTPChartElement |
GetErrorBar() const | CXTPChartSeriesStyle | virtual
GetFillStyle() const | CXTPChartFunnelSeriesStyleBase |
GetHeightToWidthRatio() const | CXTPChartFunnelSeriesStyleBase |
GetLabel() const | CXTPChartSeriesStyle | virtual
GetOwner() const | CXTPChartElement |
GetPointDistance() const | CXTPChartFunnelSeriesStyleBase |
GetSeriesPointValueIndex() const | CXTPChartSeriesStyle | virtual
GetStyleAppearance() const | CXTPChartSeriesStyle | virtual
GetTransparency() const | CXTPChartSeriesStyle | virtual
Is3D() const | CXTPChartObject |
Is3dEdgeSmoothingEnabled() const | CXTPChartSeriesStyle | virtual
IsColorEach() const | CXTPChartSeriesStyle | virtual
IsEqualHeight() const | CXTPChartFunnelSeriesStyleBase |
IsStyleDiagram(CXTPChartDiagram *pDiagram) const | CXTPChartFunnelSeriesStyleBase | protectedvirtual
m_bColorEach | CXTPChartSeriesStyle | protected
m_bSmooth3dEdges | CXTPChartSeriesStyle | protected
m_clrColor | CXTPChartSeriesStyle | protected
m_nTransparency | CXTPChartSeriesStyle | protected
m_pErrorBar | CXTPChartSeriesStyle | protected
m_pLabel | CXTPChartSeriesStyle | protected
m_Rotation3d | CXTPChartSeriesStyle | protected
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartElement | virtual
Release() | CXTPChartElement | virtual
Set3dRotation(const CXTPChart3dRotation &rotation) | CXTPChartSeriesStyle | virtual
Set3dRotation(double dYaw, double dPitch, double dRoll) | CXTPChartSeriesStyle | virtual
SetColor(CXTPChartColor clr) | CXTPChartSeriesStyle | virtual
SetColorEach(BOOL bColorEach) | CXTPChartSeriesStyle | virtual
SetEqualHeight(BOOL bEqualHeight) | CXTPChartFunnelSeriesStyleBase |
SetErrorBar(CXTPChartErrorBar *pErrorBar) | CXTPChartSeriesStyle | virtual
SetHeightToWidthRatio(double dRatio) | CXTPChartFunnelSeriesStyleBase |
SetLabel(CXTPChartSeriesLabel *pLabel) | CXTPChartSeriesStyle | virtual
SetPointDistance(int nPointDistance) | CXTPChartFunnelSeriesStyleBase |
SetTransparency(int nTransparency) | CXTPChartSeriesStyle | virtual
~CXTPChartElement() | CXTPChartElement | virtual
~CXTPChartFunnelSeriesStyleBase() | CXTPChartFunnelSeriesStyleBase | virtual
~CXTPChartSeriesStyle() | CXTPChartSeriesStyle | virtual


Toolkit Pro: Member List

CXTPGridInplaceButton Member List

This is the complete list of members for CXTPGridInplaceButton, including all inherited members.

Activate() | CXTPGridInplaceButton |
Create(XTP_GRIDRECORDITEM_ARGS *pItemArgs, CRect &rcButtons) | CXTPGridInplaceButton |
CXTPGridInplaceButton(UINT nID) | CXTPGridInplaceButton |
CXTPGridInplaceControl() | CXTPGridInplaceControl |
GetDropListItemNumber() const | CXTPGridInplaceButton |
GetIconIndex() const | CXTPGridInplaceButton |
GetID() const | CXTPGridInplaceButton |
GetItem() const | CXTPGridInplaceButton |
GetSpinButtonMax() const | CXTPGridInplaceButton |
GetSpinButtonMin() const | CXTPGridInplaceButton |
GetSpinButtonStep() const | CXTPGridInplaceButton |
GetState() const | CXTPGridInplaceButton |
GetWidth() const | CXTPGridInplaceButton |
IsInsideCellButton() const | CXTPGridInplaceButton |
IsPressed() const | CXTPGridInplaceButton |
m_bInsideCell | CXTPGridInplaceButton | protected
m_bOver | CXTPGridInplaceButton | protected
m_bPressed | CXTPGridInplaceButton | protected
m_nFixedHeight | CXTPGridInplaceButton | protected
m_nIconIndex | CXTPGridInplaceButton | protected
m_nID | CXTPGridInplaceButton | protected
m_nSpinIncrement | CXTPGridInplaceButton | protected
m_nSpinMax | CXTPGridInplaceButton | protected
m_nSpinMin | CXTPGridInplaceButton | protected
m_nSpinStep | CXTPGridInplaceButton | protected
m_nState | CXTPGridInplaceButton | protected
m_nWidth | CXTPGridInplaceButton | protected
m_unSpinTimerCnt | CXTPGridInplaceButton | protected
m_unSpinTimerId | CXTPGridInplaceButton | protected
pColumn | XTP_GRIDRECORDITEM_ARGS |
pControl | XTP_GRIDRECORDITEM_ARGS |
pItem | XTP_GRIDRECORDITEM_ARGS |
pRow | XTP_GRIDRECORDITEM_ARGS |
rcItem | XTP_GRIDRECORDITEM_ARGS |
SetDropListItemNumber(int nNumber) | CXTPGridInplaceButton |
SetIconIndex(int nIconIndex) | CXTPGridInplaceButton |
SetInsideCellButton(BOOL bInsideCell) | CXTPGridInplaceButton |
SetItemArgs(XTP_GRIDRECORDITEM_ARGS *pItemArgs) | CXTPGridInplaceControl | protectedvirtual
SetSpinButtonMax(int nValue) | CXTPGridInplaceButton |
SetSpinButtonMin(int nValue) | CXTPGridInplaceButton |
SetSpinButtonStep(int nValue) | CXTPGridInplaceButton |
~CXTPGridInplaceControl() | CXTPGridInplaceControl | virtual


Toolkit Pro: Member List

CXTPCalendarMonthViewEvent Member List

This is the complete list of members for CXTPCalendarMonthViewEvent, including all inherited members.

_MoveRectY(int nYbasePrev, int nYbaseNew, CRect &rRC) | CXTPCalendarViewEvent | static
AddMultiDayEvent_Slave(CXTPCalendarViewEvent *pSlaveView, int nMasterEventPlace) | CXTPCalendarViewEvent | virtual
AdjustLayout(CDC *pDC, const CRect &rcEventMax, int nEventPlaceNumber) | CXTPCalendarMonthViewEvent | virtual
AdjustLayout2(CDC *pDC, const CRect &rcEventMax, int nEventPlaceNumber) | CXTPCalendarMonthViewEvent | virtual
AdjustMultidayEvent(CRect rcEventMax, int nEventPlaceNumber) | CXTPCalendarViewEvent | protectedvirtual
AdjustSubjectEditor() | CXTPCalendarViewEvent | virtual
CalcIconsRect(CRect rc) | CXTPCalendarViewEvent | virtual
ChangeEventPlace(int nNewPlace) | CXTPCalendarViewEvent | virtual
CXTPCalendarMonthViewEvent(CXTPCalendarEvent *pEvent, CXTPCalendarMonthViewGroup *pViewGroup) | CXTPCalendarMonthViewEvent |
CXTPCalendarViewEvent(CXTPCalendarEvent *pEvent, CXTPCalendarViewGroup *pViewGroup) | CXTPCalendarViewEvent |
CXTPCalendarViewEventT(CXTPCalendarEvent *pEvent, CXTPCalendarMonthViewGroup *pViewGroup) | CXTPCalendarViewEventT< CXTPCalendarMonthViewGroup > | inline
CXTPCalendarWMHandler() | CXTPCalendarWMHandler |
CXTPCmdTarget() | CXTPCmdTarget |
Draw(CDC *pDC) | CXTPCalendarMonthViewEvent | virtual
EndEditSubject() | CXTPCalendarViewEvent | virtual
FormatEventTime(COleDateTime dtTime) const | CXTPCalendarViewEvent | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCalendarControl() const | CXTPCalendarViewEvent | virtual
GetChildHandlerAt(int nIndex) const | CXTPCalendarWMHandler | virtual
GetChildHandlersCount() const | CXTPCalendarWMHandler | virtual
GetEditingSubjectFromEditor() const | CXTPCalendarViewEvent | virtual
GetEndTimeRect() const | CXTPCalendarViewEvent | virtual
GetEvent() const | CXTPCalendarViewEvent | virtual
GetEventPlaceNumber() const | CXTPCalendarViewEvent | virtual
GetEventRect() const | CXTPCalendarViewEvent |
GetEventTimelinePlaceNumber() const | CXTPCalendarViewEvent | virtual
GetFirstClockRect() const | CXTPCalendarViewEvent | virtual
GetItemText(DWORD dwItemFlag, LPCTSTR pcszDefaultText=NULL) const | CXTPCalendarViewEvent | virtual
GetItemTextBody() const | CXTPCalendarViewEvent | virtual
GetItemTextEndTime() const | CXTPCalendarViewEvent | virtual
GetItemTextLocation() const | CXTPCalendarViewEvent | virtual
GetItemTextStartTime() const | CXTPCalendarViewEvent | virtual
GetItemTextSubject() const | CXTPCalendarViewEvent | virtual
GetLastClockRect() const | CXTPCalendarViewEvent | virtual
GetMarkupText() const | CXTPCalendarViewEvent | virtual
GetMarkupUIElement() | CXTPCalendarViewEvent | virtual
GetMeetingGlyphRect() const | CXTPCalendarViewEvent | virtual
GetMultiDayEventFlags() const | CXTPCalendarViewEvent | virtual
GetPrivateGlyphRect() const | CXTPCalendarViewEvent | virtual
GetRecurrenceGlyphRect() const | CXTPCalendarViewEvent | virtual
GetReminderGlyphRect() const | CXTPCalendarViewEvent | virtual
GetShowToolTipTimeOut() const | CXTPCalendarViewEvent | virtual
GetStartTimeRect() const | CXTPCalendarViewEvent | virtual
GetSubjectEditor() const | CXTPCalendarViewEvent | virtual
GetSubjectEditorFont() const | CXTPCalendarMonthViewEvent | protectedvirtual
GetSubjectEditorRect() const | CXTPCalendarViewEvent | virtual
GetSubjectEditorStyles() const | CXTPCalendarViewEvent | virtual
GetTextRect() const | CXTPCalendarViewEvent | virtual
GetToolText() | CXTPCalendarViewEvent | protectedvirtual
GetViewEventRect() const | CXTPCalendarViewEvent | virtual
GetViewEventRectMax() const | CXTPCalendarViewEvent | virtual
GetViewGroup() const | CXTPCalendarViewEventT< CXTPCalendarMonthViewGroup > | inline
GetViewGroup_() const | CXTPCalendarViewEventT< CXTPCalendarMonthViewGroup > | inlinevirtual
HideToolTip() | CXTPCalendarViewEvent | virtual
HitTest(CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const | CXTPCalendarViewEvent | virtual
HitTestEx(CPoint point, XTP_CALENDAR_HITTESTINFO *pInfo) const | CXTPCalendarMonthViewEvent | virtual
IsEditingSubject() const | CXTPCalendarViewEvent | virtual
IsMultidayEvent() const | CXTPCalendarViewEvent | virtual
IsMultyDayTextAlign() const | CXTPCalendarViewEvent | virtual
IsSelected() const | CXTPCalendarViewEvent | virtual
IsShowEndTime() const | CXTPCalendarMonthViewEvent |
IsShowingToolTip() | CXTPCalendarViewEvent | virtual
IsTextOutOfBorders() const | CXTPCalendarViewEvent | virtual
IsTimeAsClock() const | CXTPCalendarMonthViewEvent |
IsVisible() const | CXTPCalendarMonthViewEvent | virtual
KillTimer(UINT uTimerID) | CXTPCalendarViewEvent | virtual
m_bMultyDayTextAlign | CXTPCalendarViewEvent | protected
m_bSelected | CXTPCalendarViewEvent | protected
m_bTextOutOfBorders | CXTPCalendarViewEvent | protected
m_nEventPlaceNumber | CXTPCalendarViewEvent | protected
m_nEventTimelinePlaceNumber | CXTPCalendarViewEvent | protected
m_nMultiDayEventFlags | CXTPCalendarViewEvent |
m_nTimerID_ShowToolTip | CXTPCalendarViewEvent | protected
m_pMasterView | CXTPCalendarViewEvent | protected
m_pSubjectEditor | CXTPCalendarViewEvent | protected
m_ptrEvent | CXTPCalendarViewEvent | protected
m_pUIElement | CXTPCalendarViewEvent |
m_rcEndTime | CXTPCalendarViewEvent |
m_rcEvent | CXTPCalendarViewEvent |
m_rcEventMax | CXTPCalendarViewEvent |
m_rcFirstClock | CXTPCalendarViewEvent |
m_rcLastClock | CXTPCalendarViewEvent |
m_rcMeetingGlyph | CXTPCalendarViewEvent |
m_rcPrivateGlyph | CXTPCalendarViewEvent |
m_rcRecurrenceGlyph | CXTPCalendarViewEvent |
m_rcReminderGlyph | CXTPCalendarViewEvent |
m_rcStartTime | CXTPCalendarViewEvent |
m_rcSubjectEditor | CXTPCalendarViewEvent |
m_rcText | CXTPCalendarViewEvent |
m_rcToolTip | CXTPCalendarViewEvent |
m_strUIElementText | CXTPCalendarViewEvent |
m_szText | CXTPCalendarViewEvent |
OnBeforeDestroy() | CXTPCalendarViewEvent | virtual
OnChar(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnKeyUp(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnLButtonDblClk(UINT nFlags, CPoint point) | CXTPCalendarViewEvent | virtual
OnLButtonDown(UINT nFlags, CPoint point) | CXTPCalendarViewEvent | virtual
OnLButtonUp(UINT nFlags, CPoint point) | CXTPCalendarViewEvent | virtual
OnMouseMove(UINT nFlags, CPoint point) | CXTPCalendarViewEvent | virtual
OnPostAdjustLayout() | CXTPCalendarMonthViewEvent | virtual
OnSysKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnTimer(UINT_PTR uTimerID) | CXTPCalendarViewEvent | virtual
OnWndMsg(UINT message, WPARAM wParam, LPARAM lParam, LRESULT *pResult) | CXTPCalendarViewEvent | virtual
SetMultiDayEvent_MasterSlave(BOOL bMaster, CXTPCalendarViewEvent *pMasterView) | CXTPCalendarViewEvent | virtual
SetSelected(BOOL bSet=TRUE) | CXTPCalendarViewEvent | virtual
SetTextOutOfBorders(BOOL bOutOfBorders) | CXTPCalendarViewEvent | virtual
SetTimer(UINT uTimeOut_ms) | CXTPCalendarViewEvent | virtual
ShowToolTip() | CXTPCalendarViewEvent | virtual
StartEditSubject() | CXTPCalendarViewEvent | virtual
TBase typedef | CXTPCalendarMonthViewEvent |
~CXTPCalendarMonthViewEvent() | CXTPCalendarMonthViewEvent | virtual
~CXTPCalendarViewEvent() | CXTPCalendarViewEvent | virtual
~CXTPCalendarViewEventT() | CXTPCalendarViewEventT< CXTPCalendarMonthViewGroup > | inlinevirtual


Toolkit Pro: Member List

CXTPDockingPanePanelTheme2015 Member List

This is the complete list of members for CXTPDockingPanePanelTheme2015, including all inherited members.

AdjustClientRect(CXTPTabManager *pTabManager, CRect &rcClient) | CXTPTabPaintManagerTheme | virtual
CXTPDockingPanePanelTheme2012() | CXTPDockingPanePanelTheme2012 |
CXTPDockingPanePanelTheme2015() | CXTPDockingPanePanelTheme2015 |
CXTPTabPaintManagerTheme() | CXTPTabPaintManagerTheme |
CXTPTabThemeFlat() | CXTPTabThemeFlat | inline
DrawSingleButton(CDC *pDC, CXTPTabManagerItem *pItem) | CXTPDockingPanePanelTheme2012 | virtual
DrawTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl) | CXTPTabPaintManagerTheme | virtual
DrawText(CDC *pDC, CXTPTabManager *pManager, const CString &str, LPRECT lpRect, UINT nFormat) | CXTPTabPaintManagerTheme | virtual
DrawWorkspacePart(CDC *pDC, LPRECT lpRect, XTPTabWorkspacePart workspacePart) | CXTPTabPaintManagerTheme | virtual
FillButton(CDC *pDC, CXTPTabManagerItem *pItem, LPPOINT pts, int nCount, XTPTabPosition tabPosition, BOOL bAbsolute=FALSE) | CXTPTabPaintManagerTheme |
FillTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl) | CXTPTabThemeFlat | virtual
GetButtonDrawRect(const CXTPTabManagerItem *pItem) | CXTPTabPaintManagerTheme | virtual
GetButtonHeight(const CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetButtonLength(CDC *pDC, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerTheme | virtual
GetClientMargin() | CXTPTabPaintManagerTheme | virtual
GetClientRect(CRect rcControl, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetColorSet() const | CXTPTabPaintManagerTheme |
GetDefaultColorSet() | CXTPTabThemeFlat | inlinevirtual
GetHeaderClipBox(CDC *pDC, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetHeaderHeight(CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme |
GetHeaderMargin() | CXTPTabPaintManagerTheme | virtual
GetHeaderRect(CRect rcControl, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetSupportedColorSets() | CXTPTabPaintManagerTheme | inlinevirtual
m_bButtonsReverseZOrder | CXTPTabPaintManagerTheme | protected
m_nButtonHeight | CXTPTabPaintManagerTheme | protected
m_nGripperWidth | CXTPDockingPanePanelTheme2012 | protected
m_nRowMargin | CXTPTabPaintManagerTheme |
m_pPaintManager | CXTPTabPaintManagerTheme | protected
m_rcHeaderMargin | CXTPTabPaintManagerTheme |
RefreshMetrics() | CXTPDockingPanePanelTheme2012 | virtual
RepositionTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcClient) | CXTPTabPaintManagerTheme | virtual
~CXTPTabPaintManagerTheme() | CXTPTabPaintManagerTheme | virtual


Toolkit Pro: XTPCoreTreePaintManager.h Source File

  • Source
  • Controls
  • CoreTree
XTPCoreTreePaintManager.h
Go to the documentation of this file.
1
23#if !defined(__XTPCORETREEPAINTMANAGER_H__)
24# define __XTPCORETREEPAINTMANAGER_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPCoreTreeControl;
34class CXTPCoreTreeItem;
35class CXTPWinThemeWrapper;
36
37class _XTP_EXT_CLASS CXTPCoreTreePaintManager
38{
39public:
40 CXTPCoreTreePaintManager();
41 virtual ~CXTPCoreTreePaintManager();
42
43public:
44 virtual void RefreshMetrics();
45
46public:
47 virtual void FillTreeControl(CDC* pDC, CXTPCoreTreeControl* pTreeControl);
48
49 virtual void DrawItem(CDC* pDC, CXTPCoreTreeItem* pItem);
50
51 virtual int GetChildrenIndent(CXTPCoreTreeItem* pItem);
52
53 virtual int GetItemHeight() const;
54
55 virtual void SetFontIndirect(LOGFONT* pLogFont);
56
57 virtual void DrawDropRect(CDC* pDC, CXTPCoreTreeItem* pItem);
58
59 BOOL IsAppThemed() const;
60
61protected:
62 virtual void DrawButton(CDC* pDC, CXTPCoreTreeItem* pItem, CRect rcItem);
63 virtual void DrawCheckbox(CDC* pDC, CXTPCoreTreeItem* pItem, CRect rcItem);
64
65public:
66 BOOL m_bShowButtons;
67
68 void EnableTheme(BOOL bEnable);
69
70protected:
71 BOOL m_bEnableTheme;
72
73 COLORREF m_clrBackground;
74
75 COLORREF m_clrText;
76
77 COLORREF m_clrLabelText;
78 COLORREF m_clrLabelBackground;
79
80 COLORREF m_clrSelectedText;
81 COLORREF m_clrSelectedBackground;
82
83 COLORREF m_clrDisabledText;
84
85 CXTPWinThemeWrapper* m_themeButton;
86 CXTPWinThemeWrapper* m_themeTree;
87
88 int m_nItemHeight;
89
90 CXTPFont m_xtpFontItem;
91 CXTPFont m_xtpFontLabel;
92
93 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CFont, m_fntItem, m_xtpFontItem, GetItemFontHandle);
94 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CFont, m_fntLabel, m_xtpFontLabel, GetLabelFontHandle);
95};
97AFX_INLINE int CXTPCoreTreePaintManager::GetItemHeight() const
98{
99 return m_nItemHeight;
100}
102# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
104#endif // !defined(__XTPCORETREEPAINTMANAGER_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPFont
Provides a convenient object oriented interface for HFONT GDI object and uses GDI handle caching.
Definition XTPGdiObjects.h:414
CXTPWinThemeWrapper
The CXTPWinThemeWrapper class wraps the UxTheme.dll visual theme API.
Definition XTPWinThemeWrapper.h:188


Toolkit Pro: Member List

CXTPColorSelectorCtrlThemeNativeWindows11 Member List

This is the complete list of members for CXTPColorSelectorCtrlThemeNativeWindows11, including all inherited members.

CalcSize(CXTPColorSelectorCtrl *pOwner) | CXTPColorSelectorCtrlThemeOffice2013 | virtual
CreateAutoButton(CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked) | CXTPColorSelectorCtrlThemeOffice2013 | virtual
CreateColorButtons(CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked) | CXTPColorSelectorCtrlTheme | virtual
CreateExtendedButtons(CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked) | CXTPColorSelectorCtrlThemeOffice2013 | virtual
CreateMoreButton(CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked) | CXTPColorSelectorCtrlThemeOffice2013 | virtual
CreateRecentColorButtons(CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked) | CXTPColorSelectorCtrlThemeOffice2013 | virtual
CreateThemeButtons(CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked) | CXTPColorSelectorCtrlThemeOffice2013 | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPColorSelectorCtrlTheme() | CXTPColorSelectorCtrlTheme |
CXTPColorSelectorCtrlThemeNativeWindows11() | CXTPColorSelectorCtrlThemeNativeWindows11 |
CXTPColorSelectorCtrlThemeOffice2013() | CXTPColorSelectorCtrlThemeOffice2013 |
CXTPColorSelectorCtrlThemeVisualStudio2015() | CXTPColorSelectorCtrlThemeVisualStudio2015 |
CXTPControlTheme() | CXTPControlTheme |
DrawBorder(CDC *pDC, CRect rcItem, CRect rcBorder, COLORREF crBorder) | CXTPColorSelectorCtrlThemeOffice2013 | virtual
DrawColor(CDC *pDC, CXTPColorSelectorCtrl *pOwner, CXTPColorSelectorCtrl::COLOR_CELL *pColorCell, CRect rcItem, BOOL bChecked, BOOL bHighlight, BOOL bPressed) | CXTPColorSelectorCtrlThemeOffice2013 | virtual
DrawColorCell(CDC *pDC, CXTPColorSelectorCtrl *pOwner, CXTPColorSelectorCtrl::COLOR_CELL *pColorCell, BOOL bHighlight, BOOL bPressed) | CXTPColorSelectorCtrlThemeVisualStudio2015 | virtual
DrawColorSelector(CDC *pDC, CXTPColorSelectorCtrl *pOwner) | CXTPColorSelectorCtrlThemeOffice2013 | virtual
FillBackground(CDC *pDC, CXTPColorSelectorCtrl *pOwner, const CRect &rect) | CXTPColorSelectorCtrlTheme | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetButtonSize() const | CXTPColorSelectorCtrlTheme | virtual
GetThemeStyle() const | CXTPControlTheme |
m_bThinBorder | CXTPColorSelectorCtrlTheme |
m_crBack | CXTPColorSelectorCtrlTheme |
m_crBackChecked | CXTPColorSelectorCtrlTheme |
m_crBackHilight | CXTPColorSelectorCtrlTheme |
m_crBackPressed | CXTPColorSelectorCtrlTheme |
m_crBorder | CXTPColorSelectorCtrlTheme |
m_crBorderHilight | CXTPColorSelectorCtrlTheme |
m_crBorderInside | CXTPColorSelectorCtrlThemeOffice2013 | protected
m_crBorderPressed | CXTPColorSelectorCtrlTheme |
m_crPopupBorder | CXTPColorSelectorCtrlTheme |
m_crText | CXTPColorSelectorCtrlTheme |
m_crTextPressed | CXTPColorSelectorCtrlTheme |
m_crTitleBack | CXTPColorSelectorCtrlThemeOffice2013 | protected
m_crTitleText | CXTPColorSelectorCtrlThemeOffice2013 | protected
m_nAutoButton | CXTPColorSelectorCtrlTheme |
m_nCaption | CXTPColorSelectorCtrlTheme |
m_nMargin | CXTPColorSelectorCtrlTheme |
m_nTheme | CXTPControlTheme | protected
m_rcRecentText | CXTPColorSelectorCtrlTheme |
m_rcStandardText | CXTPColorSelectorCtrlTheme |
m_rcThemeText | CXTPColorSelectorCtrlTheme |
m_sizeButton | CXTPColorSelectorCtrlTheme |
RefreshMetrics(CXTPColorSelectorCtrl *pOwner) | CXTPColorSelectorCtrlThemeVisualStudio2015 | virtual
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static


Toolkit Pro: XTPScrollBarThemeVisualStudio2022.h Source File

  • Source
  • Common
  • ScrollBar
  • Themes
XTPScrollBarThemeVisualStudio2022.h
Go to the documentation of this file.
1
23#if !defined(__XTPSCROLLBARTHEMEVISUALSTUDIO2022_H__)
24# define __XTPSCROLLBARTHEMEVISUALSTUDIO2022_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPScrollBarThemeVisualStudio2022 : public CXTPScrollBarThemeVisualStudio2012
39{
40protected:
41 virtual void DrawScrollBar(CDC* pDC, CXTPScrollBase* pScrollBar);
42};
43
44# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
46#endif // !defined(__XTPSCROLLBARTHEMEVISUALSTUDIO2022_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPScrollBarThemeVisualStudio2012
Scrollbar paint manager used to draw Visual Studio 2012 like scrollbars.
Definition XTPScrollBarThemeVisualStudio2012.h:39
CXTPScrollBarThemeVisualStudio2022
Scrollbar paint manager used to draw Visual Studio 2022 like scrollbars.
Definition XTPScrollBarThemeVisualStudio2022.h:39
CXTPScrollBarThemeVisualStudio2022::DrawScrollBar
virtual void DrawScrollBar(CDC *pDC, CXTPScrollBase *pScrollBar)
This method is called to draw all scrollbar parts.
CXTPScrollBase
CXTPScrollBase is the base class for all scrollable objects.
Definition XTPScrollBase.h:222


Toolkit Pro: XTPShellExplorerProvider.h Source File

  • Source
  • Controls
  • WebBrowser
  • Providers
XTPShellExplorerProvider.h
Go to the documentation of this file.
1
22#if !defined(__XTPSHELLEXPLORERPROVIDER_H__)
23
25# define __XTPSHELLEXPLORERPROVIDER_H__
28# if _MSC_VER >= 1000
29# pragma once
30# endif // _MSC_VER > 1000
31
32# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
33# pragma warning(push)
34// C4616: #pragma warning : warning number '5204' out of range, must be between '4001' and '4999'
35// C5204: '...': class has virtual functions, but its trivial destructor is not virtual; instances
36// of objects derived from this class may not be destructed correctly
37# pragma warning(disable : 4616 5204)
38
40struct IXTPWebBrowserHost;
41class CXTPShellBrowserSite;
49class _XTP_EXT_CLASS CXTPShellExplorerProvider : public CXTPWebBrowserProvider
50{
52 DECLARE_DYNAMIC(CXTPShellExplorerProvider)
55 friend class CXTPShellBrowserSite;
56
57public:
62 enum ScrollBarStyle
63 {
64 xtpScrollBarStandard,
65 xtpScrollBarFlat,
66 xtpScrollBarNone
67 };
68
74 CXTPShellExplorerProvider(IXTPWebBrowserHost& host);
75
80 ~CXTPShellExplorerProvider();
81
89 BOOL GetRegisterAsDropTarget() const;
90
97 void SetRegisterAsDropTarget(BOOL bRegisterAsDropTarget = TRUE);
98
105 BOOL GetContextMenuEnabled() const;
106
112 void SetContextMenuEnabled(BOOL bContextMenuEnabled = TRUE);
113
120 ScrollBarStyle GetScrollBarStyle() const;
121
127 void SetScrollBarStyle(ScrollBarStyle nScrollBarStyle);
128
135 BOOL GetScriptErrorsSuppressed() const;
136
142 void SetScriptErrorsSuppressed(BOOL bScriptErrorsSuppressed = TRUE);
143
150 BOOL GetStaticText() const;
151
157 void SetStaticText(BOOL bStaticText = TRUE);
158
185 HRESULT Navigate2(VARIANT* pvtURL, VARIANT* pvtFlags = NULL, VARIANT* pvtTargetFrameName = NULL,
186 VARIANT* pvtPostData = NULL, VARIANT* pvtHeaders = NULL);
187
197 virtual HRESULT ExecuteScript(LPCWSTR pText, CComVariant* pvtResult = NULL);
198
199private:
201 virtual HRESULT Initialize();
202 virtual HRESULT Navigate(LPCTSTR pUrl);
203 virtual HRESULT LoadHtml(LPCTSTR pHtml);
204 virtual HRESULT WaitUntilReady();
205 virtual void ReleaseBrowser();
206 virtual BOOL OnHostWndMsg(UINT message, WPARAM wParam, LPARAM lParam, LRESULT* pResult);
207 virtual void OnCreateBrowser(IUnknown* pObject);
208 virtual CXTPWebBrowserControlSite* CreateControlSite(COleControlContainer* pCtrlContainer);
209 virtual BOOL PreTranslateMessage(MSG* pMsg);
210
211 BOOL OnSize(UINT nType, int cx, int cy);
212 BOOL OnDestroy();
213 BOOL OnSetFocus(CWnd* pOldWnd);
214 int OnMouseActivate(CWnd* pDesktopWnd, UINT nHitTest, UINT message);
215
216 afx_msg void OnStatusTextChange(LPCTSTR lpszText);
217 afx_msg void OnProgressChange(long nProgress, long nProgressMax);
218 afx_msg void OnCommandStateChange(long nCommand, BOOL bEnable);
219 afx_msg void OnDownloadBegin();
220 afx_msg void OnDownloadComplete();
221 afx_msg void OnTitleChange(LPCTSTR lpszText);
222 afx_msg void OnPropertyChange(LPCTSTR lpszProperty);
223 afx_msg void OnNewWindow2(LPDISPATCH* ppDisp, BOOL* Cancel);
224 afx_msg void OnQuit();
225 afx_msg void OnVisible(BOOL bVisible);
226 afx_msg void OnToolBar(BOOL bToolBar);
227 afx_msg void OnMenuBar(BOOL bMenuBar);
228 afx_msg void OnStatusBar(BOOL bStatusBar);
229 afx_msg void OnFullScreen(BOOL bFullScreen);
230 afx_msg void OnTheaterMode(BOOL bTheaterMode);
231 afx_msg void OnNavigateComplete2(LPDISPATCH pDisp, VARIANT* URL);
232 afx_msg void OnBeforeNavigate2(LPDISPATCH pDisp, VARIANT* URL, VARIANT* Flags,
233 VARIANT* TargetFrameName, VARIANT* PostData, VARIANT* Headers,
234 BOOL* Cancel);
235 afx_msg void OnDocumentComplete(LPDISPATCH pDisp, VARIANT* URL);
236
237 afx_msg void OnNavigateError(LPDISPATCH pDisp, VARIANT* URL, VARIANT* TargetFrameName,
238 VARIANT* StatusCode, BOOL* Cancel);
239
240 afx_msg void OnWindowSetResizable(BOOL Resizable);
241 afx_msg void OnWindowSetLeft(long Left);
242 afx_msg void OnWindowSetTop(long Top);
243 afx_msg void OnWindowSetWidth(long Width);
244 afx_msg void OnWindowSetHeight(long Height);
245 afx_msg void OnWindowClosing(BOOL IsChildWindow, BOOL FAR* Cancel);
246 afx_msg void OnSetSecureLockIcon(long SecureLockIcon);
247
248 DECLARE_INTERFACE_MAP();
249
250private:
251 BEGIN_INTERFACE_PART(WebBrowserEvents2, DWebBrowserEvents2)
252 virtual HRESULT STDMETHODCALLTYPE GetTypeInfoCount(
253 /* [out] */ UINT* pctinfo);
254
255 virtual HRESULT STDMETHODCALLTYPE GetTypeInfo(
256 /* [in] */ UINT iTInfo,
257 /* [in] */ LCID lcid,
258 /* [out] */ ITypeInfo** ppTInfo);
259
260 virtual HRESULT STDMETHODCALLTYPE GetIDsOfNames(
261 /* [in] */ REFIID riid,
262 /* [size_is][in] */ LPOLESTR* rgszNames,
263 /* [range][in] */ UINT cNames,
264 /* [in] */ LCID lcid,
265 /* [size_is][out] */ DISPID* rgDispId);
266
267 virtual /* [local] */ HRESULT STDMETHODCALLTYPE Invoke(
268 /* [annotation][in] */
269 DISPID dispIdMember,
270 /* [annotation][in] */
271 REFIID riid,
272 /* [annotation][in] */
273 LCID lcid,
274 /* [annotation][in] */
275 WORD wFlags,
276 /* [annotation][out][in] */
277 DISPPARAMS* pDispParams,
278 /* [annotation][out] */
279 VARIANT* pVarResult,
280 /* [annotation][out] */
281 EXCEPINFO* pExcepInfo,
282 /* [annotation][out] */
283 UINT* puArgErr);
284 END_INTERFACE_PART(WebBrowserEvents2)
285
286private:
287 CXTPShellExplorerProvider(const CXTPShellExplorerProvider&);
288 CXTPShellExplorerProvider& operator=(const CXTPShellExplorerProvider&);
289
290 CWnd* m_pBrowser;
291 IWebBrowser2* m_pBrowserApp;
292 CXTPShellBrowserSite* m_pSite;
293 COccManager* m_pOccManager;
294 IConnectionPoint* m_pCpEvents;
295 DWORD m_dwCpEventsCookie;
296
297 BOOL m_bRegisterAsDropTarget;
298 BOOL m_bContextMenuEnabled;
299 ScrollBarStyle m_nScrollBarStyle;
300 BOOL m_bScriptErrorsSuppressed;
301 BOOL m_bStaticText;
303};
305AFX_INLINE BOOL CXTPShellExplorerProvider::GetRegisterAsDropTarget() const
306{
307 return m_bRegisterAsDropTarget;
308}
309
310AFX_INLINE void
311 CXTPShellExplorerProvider::SetContextMenuEnabled(BOOL bContextMenuEnabled /*= TRUE*/)
312{
313 m_bContextMenuEnabled = bContextMenuEnabled;
314}
315
316AFX_INLINE BOOL CXTPShellExplorerProvider::GetContextMenuEnabled() const
317{
318 return m_bContextMenuEnabled;
319}
320
321AFX_INLINE void CXTPShellExplorerProvider::SetScrollBarStyle(ScrollBarStyle nScrollBarStyle)
322{
323 m_nScrollBarStyle = nScrollBarStyle;
324}
325
326AFX_INLINE CXTPShellExplorerProvider::ScrollBarStyle
327 CXTPShellExplorerProvider::GetScrollBarStyle() const
328{
329 return m_nScrollBarStyle;
330}
331
332AFX_INLINE void
333 CXTPShellExplorerProvider::SetScriptErrorsSuppressed(BOOL bScriptErrorsSuppressed /*= TRUE*/)
334{
335 m_bScriptErrorsSuppressed = bScriptErrorsSuppressed;
336}
337
338AFX_INLINE BOOL CXTPShellExplorerProvider::GetScriptErrorsSuppressed() const
339{
340 return m_bScriptErrorsSuppressed;
341}
342
343AFX_INLINE void CXTPShellExplorerProvider::SetStaticText(BOOL bStaticText /*= TRUE*/)
344{
345 m_bStaticText = bStaticText;
346}
347
348AFX_INLINE BOOL CXTPShellExplorerProvider::GetStaticText() const
349{
350 return m_bStaticText;
351}
352
353# pragma warning(pop)
354# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
355
356#endif
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPShellExplorerProvider
Implements ShellExplorer WebBrowser provider and gives access to ShellExplorer specific functionality...
Definition XTPShellExplorerProvider.h:50
CXTPShellExplorerProvider::ExecuteScript
virtual HRESULT ExecuteScript(LPCWSTR pText, CComVariant *pvtResult=NULL)
Executes a JavaScript code.
CXTPShellExplorerProvider::GetScriptErrorsSuppressed
BOOL GetScriptErrorsSuppressed() const
Gets a flag that suppresses script errors on a loaded web page.
CXTPShellExplorerProvider::GetRegisterAsDropTarget
BOOL GetRegisterAsDropTarget() const
Gets a flag value that enables registration of the WebBrowser control as drop target.
CXTPShellExplorerProvider::CXTPShellExplorerProvider
CXTPShellExplorerProvider(IXTPWebBrowserHost &host)
Constructs provider object.
CXTPShellExplorerProvider::SetScrollBarStyle
void SetScrollBarStyle(ScrollBarStyle nScrollBarStyle)
Sets WebBrowser control scrollbar style.
CXTPShellExplorerProvider::SetContextMenuEnabled
void SetContextMenuEnabled(BOOL bContextMenuEnabled=TRUE)
Sets a flag value that enables WebBrowser control context menu.
CXTPShellExplorerProvider::ScrollBarStyle
ScrollBarStyle
Defines ShellExplorer scrollbar styles.
Definition XTPShellExplorerProvider.h:63
CXTPShellExplorerProvider::xtpScrollBarFlat
@ xtpScrollBarFlat
Flat scrollbars.
Definition XTPShellExplorerProvider.h:65
CXTPShellExplorerProvider::xtpScrollBarStandard
@ xtpScrollBarStandard
Normal scrollbars.
Definition XTPShellExplorerProvider.h:64
CXTPShellExplorerProvider::Navigate2
HRESULT Navigate2(VARIANT *pvtURL, VARIANT *pvtFlags=NULL, VARIANT *pvtTargetFrameName=NULL, VARIANT *pvtPostData=NULL, VARIANT *pvtHeaders=NULL)
Navigates to the specified URL and provides additional parameters for the browser to use and customiz...
CXTPShellExplorerProvider::~CXTPShellExplorerProvider
~CXTPShellExplorerProvider()
Handles provider destruction.
CXTPShellExplorerProvider::SetStaticText
void SetStaticText(BOOL bStaticText=TRUE)
Sets a flag that enables selection of the text in the form.
CXTPShellExplorerProvider::SetRegisterAsDropTarget
void SetRegisterAsDropTarget(BOOL bRegisterAsDropTarget=TRUE)
Sets a flag value that enables registration of the WebBrowser control as drop target.
CXTPShellExplorerProvider::SetScriptErrorsSuppressed
void SetScriptErrorsSuppressed(BOOL bScriptErrorsSuppressed=TRUE)
Sets a flag that suppresses script errors on a loaded web page.
CXTPShellExplorerProvider::GetContextMenuEnabled
BOOL GetContextMenuEnabled() const
Gets a flag value that enables WebBrowser control context menu.
CXTPShellExplorerProvider::GetStaticText
BOOL GetStaticText() const
Gets a flag that enables selection of the text in the form.
CXTPShellExplorerProvider::GetScrollBarStyle
ScrollBarStyle GetScrollBarStyle() const
Gets WebBrowser control scrollbar style.
CXTPWebBrowserProvider
Implements the base class for a WebBrowser provider.
Definition XTPWebBrowserProvider.h:56


Toolkit Pro: Member List

CXTPSyntaxEditColorTheme Member List

This is the complete list of members for CXTPSyntaxEditColorTheme, including all inherited members.

Cleanup() | CXTPSyntaxEditColorTheme | protected
CXTPSyntaxEditColorTheme(CXTPSyntaxEditColorThemesManager *pThemesManager) | CXTPSyntaxEditColorTheme |
GetColorInfo(const CString &strLexClass, const CString &strThemeFilename, BOOL bDynamic=TRUE) | CXTPSyntaxEditColorTheme |
GetFileName() | CXTPSyntaxEditColorTheme |
GetParentTheme() | CXTPSyntaxEditColorTheme |
GetParentThemeName() | CXTPSyntaxEditColorTheme |
Load(const CString &csFileName) | CXTPSyntaxEditColorTheme | virtual
LoadFromString(CStringArray &arPassedString) | CXTPSyntaxEditColorTheme | virtual
ParseSection(const CString &csSection) | CXTPSyntaxEditColorTheme | protected
ParseSectionFromString(const CString &csSection, CStringArray &arPassedString) | CXTPSyntaxEditColorTheme | protected
WriteCfgFile(CString strParentThemeName, CXTPSyntaxEditColorInfoArray *pColorInfoArray_new) | CXTPSyntaxEditColorTheme |
~CXTPSyntaxEditColorTheme() | CXTPSyntaxEditColorTheme | virtual


Toolkit Pro: XTPMarkupTextElement.h Source File

  • Source
  • Markup
  • Text
XTPMarkupTextElement.h
Go to the documentation of this file.
1
23#if !defined(__XTPMARKUPTEXTELEMENT_H__)
24# define __XTPMARKUPTEXTELEMENT_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPMarkupObject;
34class CXTPMarkupBrush;
35class CXTPMarkupDependencyProperty;
36
37class _XTP_EXT_CLASS CXTPMarkupTextElement : public CXTPMarkupFrameworkContentElement
38{
40 DECLARE_MARKUPCLASS(CXTPMarkupTextElement)
42protected:
43 CXTPMarkupTextElement();
44 virtual ~CXTPMarkupTextElement();
45
46public:
47 void SetBackground(CXTPMarkupBrush* pBrush);
48 void SetBackground(COLORREF clr);
49 static void AFX_CDECL SetBackground(CXTPMarkupObject* pObject, CXTPMarkupBrush* pBrush);
50 CXTPMarkupBrush* GetBackground() const;
51
52 void SetForeground(CXTPMarkupBrush* pBrush);
53 void SetForeground(COLORREF clr);
54 static void AFX_CDECL SetForeground(CXTPMarkupObject* pObject, CXTPMarkupBrush* pBrush);
55 CXTPMarkupBrush* GetForeground() const;
56
57 void SetFontSize(int nFontSize);
58 int GetFontSize() const;
59
60 void SetFontWeight(int nFontWeight);
61 int GetFontWeight() const;
62
63 void SetFontFamily(LPCWSTR lpszFontFamily);
64 LPCWSTR GetFontFamily() const;
65
66 void SetFontStyle(int nFontStyle);
67 int GetFontStyle() const;
68
69 void SetTextDecorations(int nTextDecorations);
70 int GetTextDecorations() const;
71
73public:
74 DECLARE_DISPATCH_MAP()
75# ifdef _XTP_ACTIVEX
76 DECLARE_INTERFACE_MAP()
77 DECLARE_OLETYPELIB_EX(CXTPMarkupTextElement);
78# endif
79
80 afx_msg long OleGetTextDecorations();
81 afx_msg void OleSetTextDecorations(long nValue);
82 afx_msg long OleGetFontSize();
83 afx_msg void OleSetFontSize(long nValue);
84 afx_msg long OleGetFontWeight();
85 afx_msg void OleSetFontWeight(long nValue);
86 afx_msg BSTR OleGetFontFamily();
87 afx_msg void OleSetFontFamily(LPCTSTR lpszValue);
88 afx_msg long OleGetFontStyle();
89 afx_msg void OleSetFontStyle(long nValue);
90 afx_msg LPDISPATCH OleGetBackground();
91 afx_msg void OleSetBackground(LPDISPATCH lpBackground);
92 afx_msg LPDISPATCH OleGetForeground();
93 afx_msg void OleSetForeground(LPDISPATCH lpBackground);
94 afx_msg VARIANT OleGetTag();
95 afx_msg void OleSetTag(const VARIANT& va);
96
99public:
100 static CXTPMarkupDependencyProperty* m_pBackgroundProperty;
101 static CXTPMarkupDependencyProperty* m_pForegroundProperty;
102
103 static CXTPMarkupDependencyProperty* m_pFontSizeProperty;
104 static CXTPMarkupDependencyProperty* m_pFontWeightProperty;
105 static CXTPMarkupDependencyProperty* m_pFontFamilyProperty;
106 static CXTPMarkupDependencyProperty* m_pFontStyleProperty;
107 static CXTPMarkupDependencyProperty* m_pTextDecorationsProperty;
108 static CXTPMarkupDependencyProperty* m_pFontQualityProperty;
109 static CXTPMarkupDependencyProperty* m_pFontCharsetProperty;
110};
111
112# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
114#endif // !defined(__XTPMARKUPTEXTELEMENT_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h


Toolkit Pro: XTPChartPyramidSeriesPointViewBase.h Source File

  • Source
  • Chart
  • Styles
  • Pyramid
  • Base
XTPChartPyramidSeriesPointViewBase.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTPYRAMIDSERIESPOINTVIEWBASE_H__)
24# define __XTPCHARTPYRAMIDSERIESPOINTVIEWBASE_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartSeriesPoint;
34class CXTPChartElementView;
35class CXTPChartDeviceCommand;
36class CXTPChartDeviceContext;
37class CXTPChartPyramidSeriesViewBase;
38class CXTPChartPyramidSeriesView;
39class CXTPChart3dPyramidSeriesPointView;
40
45class _XTP_EXT_CLASS CXTPChartPyramidSeriesPointViewBase : public CXTPChartSeriesPointView
46{
47 DECLARE_DYNAMIC(CXTPChartPyramidSeriesPointViewBase);
48
49public:
57 CXTPChartPyramidSeriesPointViewBase(CXTPChartSeriesPoint* pPoint,
58 CXTPChartElementView* pParentView);
59
68 CXTPChartPyramidSeriesPointViewBase(CXTPChartSeriesPoint* pPoint,
69 CXTPChartElementView* pParentView, BOOL bAddToParent);
70
75 virtual ~CXTPChartPyramidSeriesPointViewBase();
76
86 virtual void CalculateLayout(int nIndex, int nCount, double dFrom, double dTo) = 0;
87
95 CXTPChartColor GetBorderActualColor() const;
96
97protected:
110 virtual CXTPChartDeviceCommand* CreateDeviceCommand(CXTPChartDeviceContext* pDC) = 0;
111
122 virtual CXTPChartDeviceCommand* CreateLegendDeviceCommand(CXTPChartDeviceContext* pDC,
123 CRect rcBounds);
124
125protected:
126 double m_dValue;
128 friend class CXTPChartPyramidSeriesViewBase;
129 friend class CXTPChartPyramidSeriesView;
130 friend class CXTPChart3dPyramidSeriesView;
131 friend class CXTPChart3dPyramidSeriesPointView;
132};
134# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
135#endif //#if !defined(__XTPCHARTPYRAMIDSERIESPOINTVIEWBASE_H__)
pPoint
const CPoint * pPoint
return 0 or xtpCalendarHitTestDayExpandButton
Definition XTPCalendarThemeOffice2007.h:150
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChart3dPyramidSeriesPointView
This class abstracts the view of a pyramid series point.
Definition XTPChart3dPyramidSeriesPointView.h:47
CXTPChart3dPyramidSeriesView
This class abstracts the view of a pyramid series.
Definition XTPChart3dPyramidSeriesView.h:45
CXTPChartColor
This class abstracts a color entity.
Definition XTPChartTypes.h:51
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartElementView
This class represents the view of a chart element.
Definition XTPChartElementView.h:47
CXTPChartPyramidSeriesPointViewBase
This class abstracts the view of a pyramid series point.
Definition XTPChartPyramidSeriesPointViewBase.h:46
CXTPChartPyramidSeriesPointViewBase::GetBorderActualColor
CXTPChartColor GetBorderActualColor() const
Use this function to obtain the color value of the pyramid border.
CXTPChartPyramidSeriesPointViewBase::CXTPChartPyramidSeriesPointViewBase
CXTPChartPyramidSeriesPointViewBase(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView, BOOL bAddToParent)
Constructs a CXTPChartPyramidSeriesPointViewBase object.
CXTPChartPyramidSeriesPointViewBase::CreateDeviceCommand
virtual CXTPChartDeviceCommand * CreateDeviceCommand(CXTPChartDeviceContext *pDC)=0
This function creates a CXTPChartDeviceCommand object.
CXTPChartPyramidSeriesPointViewBase::CalculateLayout
virtual void CalculateLayout(int nIndex, int nCount, double dFrom, double dTo)=0
Use this function to calculate the layout of the pyramid series point.
CXTPChartPyramidSeriesPointViewBase::CreateLegendDeviceCommand
virtual CXTPChartDeviceCommand * CreateLegendDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcBounds)
This function creates a label view drawing command object.
CXTPChartPyramidSeriesPointViewBase::CXTPChartPyramidSeriesPointViewBase
CXTPChartPyramidSeriesPointViewBase(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Constructs a CXTPChartPyramidSeriesPointViewBase object.
CXTPChartPyramidSeriesPointViewBase::~CXTPChartPyramidSeriesPointViewBase
virtual ~CXTPChartPyramidSeriesPointViewBase()
Destroys a CXTPChartPyramidSeriesPointViewBase object, handles cleanup.
CXTPChartPyramidSeriesPointViewBase::m_dValue
double m_dValue
The value of the point.
Definition XTPChartPyramidSeriesPointViewBase.h:126
CXTPChartPyramidSeriesViewBase
This class abstracts the view of a pyramid series.
Definition XTPChartPyramidSeriesViewBase.h:47
CXTPChartPyramidSeriesView
This class abstracts the view of a pyramid series.
Definition XTPChart2dPyramidSeriesView.h:53
CXTPChartSeriesPoint
CXTPChartSeriesPoint is a kind of CXTPChartElement.
Definition XTPChartSeriesPoint.h:43
CXTPChartSeriesPointView
Represents chart series point view.
Definition XTPChartSeriesPointView.h:48


Toolkit Pro: XTPSkinObjectStatusBar.h Source File

  • Source
  • SkinFramework
XTPSkinObjectStatusBar.h
Go to the documentation of this file.
1
23#if !defined(__XTPSKINOBJECTSTATUSBAR_H__)
24# define __XTPSKINOBJECTSTATUSBAR_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPSkinObjectStatusBar : public CXTPSkinObjectFrame
39{
41 DECLARE_DYNCREATE(CXTPSkinObjectStatusBar)
43public:
48 CXTPSkinObjectStatusBar();
49
54 virtual ~CXTPSkinObjectStatusBar();
55
56protected:
58 void RefreshMetrics();
59
60protected:
61 DECLARE_MESSAGE_MAP()
62
63 //{{AFX_VIRTUAL(CXTPSkinObjectStatusBar)
64 //}}AFX_VIRTUAL
65
66 //{{AFX_MSG(CXTPSkinObjectStatusBar)
67 int OnCreate(LPCREATESTRUCT lpCreateStruct);
68 //}}AFX_MSG
69
71};
72
73# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
75#endif // !defined(__XTPSKINOBJECTSTATUSBAR_H__)
XTPDisableNoisyWarnings.h
CXTPSkinObjectFrame
CXTPSkinObjectFrame is a CXTPSkinObject derived class.
Definition XTPSkinObjectFrame.h:75
CXTPSkinObjectFrame::RefreshMetrics
virtual void RefreshMetrics()
This method is called when visual metrics are changed.
CXTPSkinObjectStatusBar
CXTPSkinObjectStatusBar is a CXTPSkinObjectFrame derived class.
Definition XTPSkinObjectStatusBar.h:39
CXTPSkinObjectStatusBar::CXTPSkinObjectStatusBar
CXTPSkinObjectStatusBar()
Constructs a CXTPSkinObjectStatusBar object.
CXTPSkinObjectStatusBar::~CXTPSkinObjectStatusBar
virtual ~CXTPSkinObjectStatusBar()
Destroys a CXTPSkinObjectStatusBar object, handles cleanup and deallocation.


Toolkit Pro: Member List

CXTPTaskPanelExplorerThemePlain Member List

This is the complete list of members for CXTPTaskPanelExplorerThemePlain, including all inherited members.

BlendColor(COLORREF clrFrom, COLORREF clrTo, int nAlpha) | CXTPTaskPanelPaintManager | protected
CreateGripperBitmaps() | CXTPTaskPanelPaintManager | protected
CreateGripperIcon(HICON &hIcon, UINT nIDResource, COLORREF clrGripperBack) | CXTPTaskPanelPaintManager | protected
CXTPTaskPanelExplorerThemePlain() | CXTPTaskPanelExplorerThemePlain |
CXTPTaskPanelPaintManager() | CXTPTaskPanelPaintManager |
CXTPTaskPanelPaintManagerPlain() | CXTPTaskPanelPaintManagerPlain |
DrawCaptionGripper(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelExplorerThemePlain | virtual
DrawCaptionGripperBitmap(CDC *pDC, CXTPTaskPanelGroup *pGroup, BOOL bExpanded, BOOL bHot, CRect rc) | CXTPTaskPanelPaintManager | protected
DrawCaptionGripperSigns(CDC *pDC, CPoint pt, COLORREF clr, BOOL bExpanded) | CXTPTaskPanelPaintManager | protected
DrawDragArrow(CDC *pDC, CXTPTaskPanelItem *pItem, CRect rc, BOOL bAfter=FALSE) | CXTPTaskPanelPaintManager | protectedvirtual
DrawFocusRect(CDC *pDC, CRect rc) | CXTPTaskPanelPaintManager | protectedvirtual
DrawGroupCaption(CDC *pDC, CXTPTaskPanelGroup *pGroup, BOOL bDraw) | CXTPTaskPanelPaintManagerPlain | virtual
DrawGroupClient(CDC *pDC, CXTPTaskPanelGroup *pGroup) | CXTPTaskPanelPaintManager | virtual
DrawGroupClientFace(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelPaintManagerPlain | virtual
DrawGroupClientItems(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelPaintManager | protectedvirtual
DrawGroupItem(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw) | CXTPTaskPanelPaintManager | virtual
DrawGroupItemFrame(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc) | CXTPTaskPanelPaintManager | virtual
DrawGroupItemImage(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw) | CXTPTaskPanelPaintManager | protected
DrawGroupItemImageWithText(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw) | CXTPTaskPanelPaintManager | protected
DrawGroupItemImageWithTextBelow(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw) | CXTPTaskPanelPaintManager | protected
DrawItemCaption(CDC *pDC, CXTPTaskPanelItem *pItem, CRect rcText, UINT nFormat) | CXTPTaskPanelPaintManager | protectedvirtual
DrawItemImage(CDC *pDC, CXTPTaskPanelItem *pItem, CPoint ptIcon, CXTPImageManagerIcon *pImage, CSize szIcon) | CXTPTaskPanelPaintManager | protectedvirtual
DrawScrollButton(CDC *pDC, CXTPTaskPanelScrollButton *pScrollButton) | CXTPTaskPanelPaintManager | virtual
FillGroupClientFace(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelPaintManagerPlain | virtual
FillTaskPanel(CDC *pDC, CXTPTaskPanel *pTaskPanel) | CXTPTaskPanelPaintManagerPlain | virtual
FreeBitmaps() | CXTPTaskPanelPaintManager | protected
GetCaptionGripperWidth(CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelPaintManager | protectedvirtual
GetControlMargins(const CXTPTaskPanel *pPanel) | CXTPTaskPanelPaintManager | virtual
GetGroupColors(BOOL bSpecial) | CXTPTaskPanelPaintManager |
GetGroupColors(CXTPTaskPanelGroup *pGroup) | CXTPTaskPanelPaintManager | virtual
GetGroupInnerMargins(const CXTPTaskPanelGroup *pGroup) | CXTPTaskPanelPaintManager | virtual
GetGroupOuterMargins(const CXTPTaskPanelGroup *pGroup) | CXTPTaskPanelPaintManager | virtual
GetGroupSpacing(const CXTPTaskPanel *pPanel) | CXTPTaskPanelPaintManager | virtual
GetHighlightOffset(CXTPTaskPanelGroupItem *pItem) | CXTPTaskPanelPaintManager | protectedvirtual
GetItemFont(CXTPTaskPanelItem *pItem) | CXTPTaskPanelPaintManager | virtual
GetItemIconPadding(const CXTPTaskPanelItem *pItem) | CXTPTaskPanelPaintManager | virtual
GetItemInnerMargins(const CXTPTaskPanelGroupItem *pItem) | CXTPTaskPanelPaintManager | virtual
GetItemOuterMargins(const CXTPTaskPanelGroupItem *pItem) | CXTPTaskPanelPaintManager | virtual
m_bBoldCaption | CXTPTaskPanelPaintManager |
m_bCaptionScrollButton | CXTPTaskPanelPaintManager |
m_bEmbossedDisabledText | CXTPTaskPanelPaintManager |
m_bEmulateEplorerTheme | CXTPTaskPanelPaintManager |
m_bExplorerTheme | CXTPTaskPanelExplorerThemePlain |
m_bInvertDragRect | CXTPTaskPanelPaintManager |
m_bLeftRoundedCorner | CXTPTaskPanelPaintManager | protected
m_bmpGrippers | CXTPTaskPanelPaintManager | protected
m_bOfficeBorder | CXTPTaskPanelPaintManager | protected
m_bOfficeCaption | CXTPTaskPanelPaintManagerPlain | protected
m_bOfficeHighlight | CXTPTaskPanelPaintManager |
m_bRightRoundedCorner | CXTPTaskPanelPaintManager | protected
m_bRoundedFrame | CXTPTaskPanelPaintManagerPlain | protected
m_bUseBitmapGrippers | CXTPTaskPanelPaintManager | protected
m_bUseStandardCaptionFont | CXTPTaskPanelPaintManager | protected
m_bUseStandardItemsFont | CXTPTaskPanelPaintManager | protected
m_clrBackground | CXTPTaskPanelPaintManager | protected
m_clrHighlightBorder | CXTPTaskPanelPaintManager | protected
m_clrHighlightHot | CXTPTaskPanelPaintManager | protected
m_clrHighlightPressed | CXTPTaskPanelPaintManager | protected
m_clrHighlightSelected | CXTPTaskPanelPaintManager | protected
m_eGripper | CXTPTaskPanelPaintManager |
m_groupNormal | CXTPTaskPanelPaintManager | protected
m_groupSpecial | CXTPTaskPanelPaintManager | protected
m_hGripperNormal | CXTPTaskPanelPaintManager | protected
m_hGripperSpecial | CXTPTaskPanelPaintManager | protected
m_nCaptionHeight | CXTPTaskPanelPaintManager | protected
m_nCaptionTextFormat | CXTPTaskPanelPaintManager | protected
m_nGroupSpacing | CXTPTaskPanelPaintManager |
m_nItemTextFormat | CXTPTaskPanelPaintManager | protected
m_rcControlMargins | CXTPTaskPanelPaintManager |
m_rcGroupIconPadding | CXTPTaskPanelPaintManager |
m_rcGroupInnerMargins | CXTPTaskPanelPaintManager |
m_rcGroupOuterMargins | CXTPTaskPanelPaintManager |
m_rcImageLayoutIconPadding | CXTPTaskPanelPaintManager |
m_rcItemIconPadding | CXTPTaskPanelPaintManager |
m_rcItemInnerMargins | CXTPTaskPanelPaintManager |
m_rcItemOuterMargins | CXTPTaskPanelPaintManager |
m_xtpFontCaption | CXTPTaskPanelPaintManager | protected
m_xtpFontIcon | CXTPTaskPanelPaintManager | protected
m_xtpFontIconBold | CXTPTaskPanelPaintManager | protected
m_xtpFontIconHot | CXTPTaskPanelPaintManager | protected
m_xtpFontIconHotBold | CXTPTaskPanelPaintManager | protected
Rectangle(CDC *pDC, CRect rc, COLORREF clrPen, COLORREF clrBrush) | CXTPTaskPanelPaintManager | protected
rectDefault | CXTPTaskPanelPaintManager | static
RefreshMetrics() | CXTPTaskPanelExplorerThemePlain | virtual
SetCaptionFontIndirect(LOGFONT *pLogFont, BOOL bUseStandardCaptionFont=FALSE) | CXTPTaskPanelPaintManager |
SetItemsFontIndirect(LOGFONT *pLogFont, BOOL bUseStandardItemsFont=FALSE) | CXTPTaskPanelPaintManager |
SetTextFormat(int nTextFormat, BOOL bCaption=FALSE) | CXTPTaskPanelPaintManager |
~CXTPTaskPanelPaintManager() | CXTPTaskPanelPaintManager | virtual


Toolkit Pro: Member List

CXTPColorLum Member List

This is the complete list of members for CXTPColorLum, including all inherited members.

CXTPColorBase() | CXTPColorBase |
CXTPColorLum() | CXTPColorLum |
DrawLuminanceBar(CDC *pDC) | CXTPColorLum |
DrawSliderArrow(CDC *pDC) | CXTPColorLum |
focusColorWheel enum value | CXTPColorBase |
FocusedControl enum name | CXTPColorBase |
focusLumination enum value | CXTPColorBase |
focusNone enum value | CXTPColorBase |
GetLumBarRect(CRect &rect) | CXTPColorLum |
HLStoRGB(double h, double l, double s) | CXTPColorBase | static
Init() | CXTPColorBase | protectedvirtual
m_bPreSubclassInit | CXTPColorBase | protected
m_eHasFocus | CXTPColorBase | protectedstatic
m_nHue | CXTPColorBase |
m_nLum | CXTPColorBase |
m_nSat | CXTPColorBase |
m_ptMousePos | CXTPColorBase |
RGBtoHSL(COLORREF color, double *h, double *s, double *l) | CXTPColorBase | static
SetColor(double nHue, double nSat) | CXTPColorLum | virtual
SetLuminance(double l) | CXTPColorLum |
UpdateCursorPos(CPoint point) | CXTPColorLum | virtual
~CXTPColorBase() | CXTPColorBase | virtual
~CXTPColorLum() | CXTPColorLum | virtual


Toolkit Pro: XTPChartDiagram2DView.h Source File

  • Source
  • Chart
  • Diagram
  • Diagram2D
XTPChartDiagram2DView.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTDIAGRAM2DVIEW_H__)
24# define __XTPCHARTDIAGRAM2DVIEW_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartAxis;
34class CXTPChartDiagram2DPane;
35class CXTPChartDiagram2DPaneView;
36class CXTPChartDiagram2DAppearance;
37class CXTPChartAxisView;
38
44class _XTP_EXT_CLASS CXTPChartDiagram2DView : public CXTPChartDiagramView
45{
46public:
54 CXTPChartDiagram2DView(CXTPChartDiagram* pDiagram, CXTPChartElementView* pParent);
55
62 CXTPChartDiagram2DPaneView* GetPaneView() const;
63
70 void CreateView(CXTPChartDeviceContext* pDC);
71
80 void CalculateView(CXTPChartDeviceContext* pDC, CRect rcBounds);
81
82 void UpdateRange(CXTPChartDeviceContext* pDC);
83
94 void AddAxisView(CXTPChartDeviceContext* pDC, CXTPChartElementView* pParentView,
95 CXTPChartAxis* pAxis);
96
97 virtual CXTPChartDeviceCommand* CreateDeviceCommand(CXTPChartDeviceContext* pDC);
98
107 CXTPChartAxisView* GetAxisView(CXTPChartAxis* pAxis) const;
108
109 virtual void OnMouseWheel(UINT nFlags, short zDelta, CPoint pt);
110 virtual void OnLButtonDown(UINT nFlags, CPoint point);
111 virtual BOOL OnSetCursor(CPoint point);
112
113public:
114 void CheckLabelBounds(const CXTPChartRectF& rcBounds);
115
116public:
117 CXTPChartElementView* m_pAxisViews;
118 CXTPChartDiagram2DPaneView* m_pPaneView;
120 CRect m_rcLabelPadding;
121};
122
123AFX_INLINE CXTPChartDiagram2DPaneView* CXTPChartDiagram2DView::GetPaneView() const
124{
125 return m_pPaneView;
126}
128# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
129#endif //#if !defined(__XTPCHARTDIAGRAM2DVIEW_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartAxis
This abstract base class represents a chart axis as a kind of chart element.
Definition XTPChartAxis.h:86
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartDiagram2DAppearance
This class represents the appearance of diagram in 2D.
Definition XTPChartAppearance.h:292
CXTPChartDiagram2DView
This class represents the view of a chart 2D diagram, which is a kind of CXTPChartDiagramView.
Definition XTPChartDiagram2DView.h:45
CXTPChartDiagram2DView::GetPaneView
CXTPChartDiagram2DPaneView * GetPaneView() const
Call this function to get the diagram pane view object to which this CXTPChartDiagram2DView object is...
Definition XTPChartDiagram2DView.h:123
CXTPChartDiagram2DView::AddAxisView
void AddAxisView(CXTPChartDeviceContext *pDC, CXTPChartElementView *pParentView, CXTPChartAxis *pAxis)
Use this function to add an axis view to the diagram view.
CXTPChartDiagram2DView::GetAxisView
CXTPChartAxisView * GetAxisView(CXTPChartAxis *pAxis) const
Call this function to get the view for an axis object.
CXTPChartDiagram2DView::CreateDeviceCommand
virtual CXTPChartDeviceCommand * CreateDeviceCommand(CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
CXTPChartDiagram2DView::CXTPChartDiagram2DView
CXTPChartDiagram2DView(CXTPChartDiagram *pDiagram, CXTPChartElementView *pParent)
Constructs a CXTPChartDiagram2DView object.
CXTPChartDiagram2DView::CalculateView
void CalculateView(CXTPChartDeviceContext *pDC, CRect rcBounds)
Call this function to calculate the layout based on a rectangular boundary.
CXTPChartDiagram2DView::UpdateRange
void UpdateRange(CXTPChartDeviceContext *pDC)
Updates chart range.
CXTPChartDiagram2DView::m_pAxisViews
CXTPChartElementView * m_pAxisViews
The axis view.
Definition XTPChartDiagram2DView.h:117
CXTPChartDiagram2DView::m_pPaneView
CXTPChartDiagram2DPaneView * m_pPaneView
The pane view.
Definition XTPChartDiagram2DView.h:118
CXTPChartDiagram2DView::CreateView
void CreateView(CXTPChartDeviceContext *pDC)
Call this function to create the view of the 2D diagram.
CXTPChartDiagram2DView::OnMouseWheel
virtual void OnMouseWheel(UINT nFlags, short zDelta, CPoint pt)
Handles mouse wheel event.
CXTPChartDiagram
This class represents a chart diagram, which is a kind of CXTPChartElement.
Definition XTPChartDiagram.h:48
CXTPChartDiagramView
This class represents the view of a chart diagram, which is a kind of CXTPChartElementView.
Definition XTPChartDiagramView.h:49
CXTPChartElementView
This class represents the view of a chart element.
Definition XTPChartElementView.h:47
CXTPRectT< float >


Toolkit Pro: Member List

CXTPMenuBar Member List

This is the complete list of members for CXTPMenuBar, including all inherited members.

AddMDIMenu(UINT nIDResource) | CXTPMenuBar |
CalcDockingLayout(int nLength, DWORD dwMode, int nWidth=0) | CXTPToolBar | virtual
CalcDynamicLayout(int nLength, DWORD dwMode) | CXTPToolBar | virtual
Copy(CXTPCommandBar *pCommandBar, BOOL bRecursive=FALSE) | CXTPMenuBar | protectedvirtual
Create(CWnd *pParentWnd, BOOL bFloat) | CXTPToolBar | protectedvirtual
CreateKeyboardTips() | CXTPCommandBar | virtual
CreateToolBar(DWORD dwStyle, CWnd *pParentWnd, UINT nID=AFX_IDW_TOOLBAR) | CXTPToolBar |
CXTPCommandBar() | CXTPCommandBar | protected
CXTPHookManagerHookAble() | CXTPHookManagerHookAble |
CXTPMenuBar() | CXTPMenuBar |
CXTPToolBar() | CXTPToolBar |
DelayLayout() | CXTPCommandBar |
DelayRedraw() | CXTPCommandBar | virtual
DoPropExchange(CXTPPropExchange *pPX) | CXTPMenuBar | protectedvirtual
DoUpdateCustomizeMenuControl(CXTPControl *pControl, CCmdTarget *pTarget) | CXTPToolBar | static
DrawCommandBar(CDC *pDC, CRect rcClipBox) | CXTPCommandBar | virtual
EnableAnimation(BOOL bEnable=TRUE) | CXTPCommandBar |
EnableCustomization(BOOL bEnable=TRUE) | CXTPCommandBar |
EnableDocking(DWORD dwFlags=xtpFlagAlignAny|xtpFlagFloating|xtpFlagHideWrap) | CXTPToolBar |
EnableDoubleBuffer(BOOL bEnable=TRUE) | CXTPCommandBar |
EnsureVisible(CXTPControl *pControl) | CXTPCommandBar | virtual
FillCommandBarEntry(CDC *pDC) | CXTPCommandBar | virtual
FindAccel(TCHAR chAccel) const | CXTPCommandBar |
FindAccelEx(UINT chAccel, BOOL &bSelectOnly) const | CXTPCommandBar |
FreeMDIMenus() | CXTPMenuBar |
GenerateCommandBarList(DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam) | CXTPMenuBar | protectedvirtual
GetActiveDocTemplate() const | CXTPCommandBar | protected
GetActiveMdiChildWnd(BOOL *bMaximized=NULL) | CXTPMenuBar | protected
GetBarID() const | CXTPCommandBar |
GetBarInfo(CToolBarInfo *pInfo) | CXTPToolBar |
GetBorders() | CXTPToolBar | protectedvirtual
GetButtonSize() const | CXTPCommandBar | virtual
GetCommandBarData() const | CXTPCommandBar |
GetCommandBars() const | CXTPCommandBar |
GetControl(int nIndex) const | CXTPCommandBar |
GetControlCount() const | CXTPCommandBar |
GetControls() const | CXTPCommandBar |
GetCurrentMenuResource() const | CXTPMenuBar |
GetDefaultButtonStyle() const | CXTPCommandBar |
GetDefaultMenuResource() const | CXTPMenuBar |
GetDockBar() const | CXTPToolBar |
GetFlags() const | CXTPCommandBar |
GetFrameSite() const | CXTPCommandBar |
GetIconSize() const | CXTPCommandBar | virtual
GetImageManager() const | CXTPCommandBar |
GetLargeIconSize(BOOL bAutoSize) const | CXTPCommandBar |
GetMDIMenus() const | CXTPMenuBar |
GetOwnerSite() const | CXTPCommandBar |
GetPaintManager() const | CXTPCommandBar |
GetParentCommandBar() const | CXTPCommandBar | virtual
GetPosition() const | CXTPCommandBar |
GetRootParent() const | CXTPCommandBar |
GetSelected() const | CXTPCommandBar |
GetShowGripper() const | CXTPCommandBar |
GetSite() const | CXTPCommandBar |
GetTextOrientation() const | CXTPCommandBar |
GetTitle() const | CXTPCommandBar |
GetTrackFocus() const | CXTPCommandBar |
GetType() const | CXTPCommandBar |
GetWidth() const | CXTPCommandBar |
HideKeyboardTips() | CXTPCommandBar |
InvalidateParents() | CXTPCommandBar |
IsAnimationEnabled() const | CXTPCommandBar |
IsBuiltIn() const | CXTPToolBar |
IsCloseable() const | CXTPToolBar |
IsContextMenuPresent() const | CXTPToolBar |
IsCustomizable() const | CXTPCommandBar | virtual
IsCustomizeDialogPresent() const | CXTPToolBar |
IsCustomizeMode() const | CXTPCommandBar |
IsDialogBar() const | CXTPCommandBar | virtual
IsHelpMode() const | CXTPCommandBar | protected
IsKeyboardCuesVisible() const | CXTPCommandBar | virtual
IsKeyboardTipsVisible() const | CXTPCommandBar |
IsLayoutRTL() const | CXTPCommandBar |
IsMenuTitleBar() const | CXTPCommandBar | virtual
IsPopupBar() const | CXTPCommandBar | virtual
IsResizable() const | CXTPCommandBar | virtual
IsRibbonBar() const | CXTPCommandBar | virtual
IsTemporary() const | CXTPToolBar |
IsTextBelowIcons() const | CXTPCommandBar |
IsTrackingMode() const | CXTPCommandBar |
IsVisible() const | CXTPToolBar | inlinevirtual
IsWindowVisible() const | CXTPToolBar |
LoadMenu(CMenu *pMenu, BOOL bRemoveControls=TRUE) | CXTPCommandBar | virtual
LoadMenuBar(UINT nIDResource) | CXTPMenuBar | virtual
LoadToolBar(UINT nIDResource, BOOL bLoadIcons=TRUE) | CXTPToolBar | virtual
LockMouseMove(CXTPControl *pControl) | CXTPCommandBar |
LockRedraw() | CXTPCommandBar |
m_bAnimatePopup | CXTPCommandBar | protected
m_barPosition | CXTPCommandBar | protected
m_barType | CXTPCommandBar | protected
m_bAutoDestroy | CXTPHookManagerHookAble |
m_bBuiltIn | CXTPToolBar | protected
m_bCloseable | CXTPCommandBar | protected
m_bComboBar | CXTPCommandBar |
m_bContextMenuPresent | CXTPToolBar | protected
m_bCustomizable | CXTPCommandBar | protected
m_bCustomizeDialogPresent | CXTPCommandBar | protected
m_bExecOnRButton | CXTPCommandBar | protected
m_bGrabFocus | CXTPCommandBar | protected
m_bIgnoreUpdateHandler | CXTPCommandBar | protected
m_bInRecalcLayout | CXTPToolBar | protected
m_bKeyboardSelect | CXTPCommandBar | protected
m_bMdiApp | CXTPMenuBar | protected
m_bMultiLine | CXTPCommandBar | protected
m_bPreviewMode | CXTPToolBar | protected
m_bPreviewVisible | CXTPToolBar | protected
m_bRecursePopup | CXTPCommandBar | protected
m_bShowExpandButton | CXTPToolBar | protected
m_bTearOff | CXTPToolBar | protected
m_bTemporary | CXTPToolBar | protected
m_bTextBelow | CXTPCommandBar | protected
m_bTracking | CXTPCommandBar | protected
m_bTrackOnHover | CXTPCommandBar |
m_buttonStyle | CXTPCommandBar | protected
m_bVerticalMarker | CXTPCommandBar | protected
m_bVisible | CXTPToolBar | protected
m_dwData | CXTPCommandBar | protected
m_dwFlags | CXTPCommandBar | protected
m_dwStyle | CXTPCommandBar | protected
m_hMenuDefault | CXTPMenuBar | protected
m_hWndActiveChild | CXTPMenuBar | protected
m_hwndFocus | CXTPCommandBar | protected
m_nBarID | CXTPCommandBar | protected
m_nIdleFlags | CXTPCommandBar | protected
m_nIDResource | CXTPMenuBar | protected
m_nIDResourceCurrent | CXTPMenuBar | protected
m_nLockRedraw | CXTPCommandBar | protected
m_nMRUWidth | CXTPCommandBar | protected
m_nPopuped | CXTPCommandBar | protected
m_nSelected | CXTPCommandBar | protected
m_nStateFlags | CXTPCommandBar |
m_nTextOrientation | CXTPCommandBar | protected
m_pAnimation | CXTPCommandBar | protected
m_pCommandBars | CXTPCommandBar | protected
m_pControls | CXTPCommandBar | protected
m_pDockBar | CXTPToolBar | protected
m_pDockContext | CXTPToolBar | protected
m_pImageManager | CXTPCommandBar | protected
m_pMDIMenus | CXTPMenuBar | protected
m_pOwner | CXTPCommandBar | protected
m_pPaintManager | CXTPCommandBar | protected
m_pReturnCmd | CXTPCommandBar | protected
m_pSite | CXTPCommandBar | protected
m_pToolTipContext | CXTPCommandBar | protected
m_rcMarker | CXTPCommandBar | protected
m_strTitle | CXTPCommandBar | protected
m_szButtons | CXTPCommandBar | protected
m_szButtonSpacing | CXTPCommandBar | protected
m_szIcons | CXTPCommandBar | protected
MergeToolBar(CXTPCommandBar *pCommandBar, BOOL bSilent) | CXTPToolBar | protectedvirtual
MergeToolBar(CXTPCommandBar *pCommandBar, BOOL bSilent, int nDefaultConfirmationChoice) | CXTPToolBar | protectedvirtual
ModifyBarStyle(DWORD dwRemove, DWORD dwAdd) | CXTPToolBar |
OnControlsChanged() | CXTPCommandBar | protectedvirtual
OnControlSelected(BOOL bSelected, CXTPControl *pControl) | CXTPCommandBar | virtual
OnCustomizeDragEnter(CXTPControl *pDataObject, CPoint point) | CXTPCommandBar | virtual
OnCustomizeDragLeave() | CXTPCommandBar | virtual
OnCustomizeDragOver(CXTPControl *pDataObject, CPoint point) | CXTPCommandBar | virtual
OnCustomizeDrop(CXTPControl *pDataObject, DROPEFFECT &dropEffect, CPoint ptDrop, CPoint ptDrag) | CXTPCommandBar | virtual
OnHookAttached(HWND hWnd) | CXTPHookManagerHookAble | virtual
OnHookDetached() | CXTPHookManagerHookAble | virtual
OnHookKeyDown(UINT nChar, LPARAM lParam) | CXTPToolBar | virtual
OnHookMessage(HWND hWnd, UINT nMessage, WPARAM &wParam, LPARAM &lParam, LRESULT &lResult) | CXTPMenuBar | protectedvirtual
OnKeyboardTip(CXTPCommandBarKeyboardTip *pTip) | CXTPCommandBar | virtual
OnKeyboardTipChar(UINT chAccel) | CXTPCommandBar |
OnMouseHitTest(CPoint pt) | CXTPCommandBar | protectedvirtual
OnPaintManagerChanged() | CXTPToolBar | protectedvirtual
OnPostHookMessage(HWND hWnd, UINT nMessage, WPARAM &wParam, LPARAM &lParam, LRESULT &lResult) | CXTPHookManagerHookAble | virtual
OnRecalcLayout() | CXTPToolBar | virtual
OnRemoved() | CXTPCommandBar | protectedvirtual
OnSetPreviewMode(BOOL bPreview) | CXTPToolBar |
OnTrackEnter() | CXTPCommandBar | virtual
OnTrackLost() | CXTPCommandBar | virtual
Popup(CXTPControlPopup *pControlPopup, BOOL bSelectFirst=FALSE) | CXTPCommandBar | virtual
ProcessSpecialKey(XTPSpecialKey key) | CXTPCommandBar | protectedvirtual
Redraw(LPCRECT lpRect=0, BOOL bAnimate=TRUE) | CXTPCommandBar | virtual
RefreshMenu() | CXTPMenuBar |
RefreshSysButtons() | CXTPMenuBar | protectedvirtual
Reset(BOOL bShowWarningMessage) | CXTPMenuBar | virtual
RestoreCommandBarList(CXTPCommandBarList *pCommandBarList) | CXTPMenuBar | protectedvirtual
s_nExpandDelay | CXTPCommandBar | static
s_nExpandHoverDelay | CXTPCommandBar | static
s_nHoverDelay | CXTPCommandBar | static
SetBarID(UINT nID) | CXTPCommandBar |
SetBarInfo(CToolBarInfo *pInfo) | CXTPToolBar |
SetButtons(UINT *pButtons, int nCount) | CXTPCommandBar |
SetButtonSize(CSize size) | CXTPCommandBar |
SetCloseable(BOOL bCloseable) | CXTPToolBar |
SetCommandBarData(DWORD_PTR dwData) | CXTPCommandBar |
SetCommandBars(CXTPCommandBars *pCommandBars) | CXTPCommandBar |
SetContextMenuPresent(BOOL bPresent) | CXTPToolBar |
SetControls(CXTPControls *pControls) | CXTPCommandBar |
SetCustomizeDialogPresent(BOOL bPresent) | CXTPToolBar |
SetDefaultButtonStyle(XTPButtonStyle buttonStyle) | CXTPCommandBar |
SetFlags(DWORD dwFlagsAdd, DWORD dwFlagsRemove=0) | CXTPCommandBar |
SetGrabFocus(BOOL bGrabFocus) | CXTPCommandBar |
SetIconSize(CSize size) | CXTPCommandBar |
SetImageManager(CXTPImageManager *pImageManager) | CXTPCommandBar |
SetPaintManager(CXTPPaintManager *pPaintManager) | CXTPCommandBar |
SetPopuped(int nPopuped, BOOL bKeyboard=FALSE) | CXTPCommandBar |
SetPosition(XTPBarPosition barPosition) | CXTPToolBar | virtual
SetSelected(int nSelected, BOOL bKeyboard=FALSE) | CXTPCommandBar | virtual
SetShowGripper(BOOL bShow) | CXTPCommandBar |
SetStatusText(const CString &strDescription) | CXTPCommandBar |
SetTemporary(BOOL bTemporary) | CXTPToolBar |
SetTextOrientation(XTPBarTextOrientation nTextOrientation) | CXTPCommandBar |
SetTitle(LPCTSTR lpszTitle) | CXTPCommandBar |
SetTrackFocus(HWND hwnd) | CXTPCommandBar |
SetTrackingMode(int bMode, BOOL bSelectFirst=TRUE, BOOL bKeyboard=FALSE) | CXTPCommandBar | virtual
SetupHook() | CXTPMenuBar | protected
SetupMenu() | CXTPMenuBar | protected
SetVisible(BOOL bVisible) | CXTPToolBar | virtual
SetWidth(int nWidth) | CXTPCommandBar |
ShouldSerializeBar() | CXTPMenuBar | protectedvirtual
ShowExpandButton(BOOL bShowExpandButton) | CXTPToolBar |
ShowTextBelowIcons(BOOL bTextBelow=TRUE) | CXTPCommandBar |
SwitchActiveMenu() | CXTPMenuBar |
SwitchMDIMenu(UINT nIDMenu, CMenu *pMenu=NULL) | CXTPMenuBar | virtual
SwitchMDIMenu(HMENU hMenu) | CXTPMenuBar | protected
SyncActiveMdiChild() | CXTPMenuBar | protected
UnlockMouseMove() | CXTPCommandBar |
UnlockRedraw() | CXTPCommandBar |
UpdateShortcuts() | CXTPCommandBar | protectedvirtual
~CXTPCommandBar() | CXTPCommandBar | protectedvirtual
~CXTPHookManagerHookAble() | CXTPHookManagerHookAble | virtual
~CXTPMenuBar() | CXTPMenuBar |
~CXTPToolBar() | CXTPToolBar |


Toolkit Pro: Member List

CXTPRibbonThemeResource Member List

This is the complete list of members for CXTPRibbonThemeResource, including all inherited members.

CreateTabPaintManager() | CXTPRibbonPaintManager | protectedvirtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPRibbonPaintManager(CXTPPaintManager *pPaintManager) | CXTPRibbonPaintManager |
CXTPRibbonThemeResource(CXTPPaintManager *pPaintManager) | CXTPRibbonThemeResource |
DrawControlGroupOption(CDC *pDC, CXTPControl *pControlGroupOption, BOOL bDraw) | CXTPRibbonThemeResource | virtual
DrawControlGroupPopup(CDC *pDC, CXTPControlPopup *pControlGroupPopup, BOOL bDraw) | CXTPRibbonThemeResource | virtual
DrawDwmCaptionText(CDC *pDC, CRect rcCaptionText, CString strText, CWnd *pSite, BOOL bActive) | CXTPRibbonPaintManager | protected
DrawGroup(CDC *pDC, CXTPRibbonGroup *pGroup) | CXTPRibbonThemeResource | virtual
DrawQuickAccessControl(CDC *pDC, CXTPRibbonBar *pRibbon, CXTPControl *pControl) | CXTPRibbonPaintManager | virtual
DrawRibbonApplicationIcon(CDC *pDC, CXTPRibbonBar *pRibbonBar, CRect rc, HICON hIcon) | CXTPRibbonPaintManager | protected
DrawRibbonFrameCaption(CDC *pDC, CXTPRibbonBar *pRibbonBar, BOOL bActive) | CXTPRibbonThemeResource | virtual
DrawRibbonFrameCaptionBar(CDC *pDC, CXTPRibbonBar *pRibbonBar, BOOL bActive) | CXTPRibbonThemeResource | virtual
DrawRibbonFrameContextHeaders(CDC *pDC, CXTPRibbonBar *pRibbonBar, CXTPRibbonTabContextHeaders *pContextHeaders) | CXTPRibbonThemeResource | virtual
DrawRibbonFramePart(CDC *pDC, CXTPRibbonBar *pRibbonBar) | CXTPRibbonPaintManager | virtual
DrawRibbonFrameSystemButton(CDC *pDC, CXTPRibbonControlSystemButton *pControl, CRect rc) | CXTPRibbonThemeResource | virtual
DrawRibbonGroupControlEntry(CDC *pDC, CXTPControl *pButton) | CXTPRibbonThemeResource | virtual
DrawRibbonGroupPopupToolBar(CDC *pDC, CXTPRibbonGroup *pRibbonGroup) | CXTPRibbonPaintManager | virtual
DrawRibbonQuickAccessButton(CDC *pDC, CXTPControlPopup *pControl) | CXTPRibbonThemeResource | virtual
DrawRibbonQuickAccessControls(CDC *pDC, CXTPRibbonBar *pRibbonBar) | CXTPRibbonThemeResource | virtual
DrawRibbonQuickAccessMoreButton(CDC *pDC, CXTPControlPopup *pControl) | CXTPRibbonThemeResource | virtual
DrawRibbonScrollButton(CDC *pDC, CXTPControl *pControl, BOOL bScrollLeft) | CXTPRibbonThemeResource | virtual
DrawRibbonTab(CDC *pDC, CXTPRibbonTab *pItem) | CXTPRibbonThemeResource | virtual
DrawSystemPopupBarButton(CDC *pDC, CXTPControl *pButton) | CXTPRibbonThemeResource | virtual
FillGroupPopupToolBar(CDC *pDC, CXTPRibbonGroup *pGroup, CXTPCommandBar *pCommandBar) | CXTPRibbonThemeResource | virtual
FillGroupRect(CDC *pDC, CXTPRibbonTab *pActiveTab, CRect rcGroups) | CXTPRibbonThemeResource | virtual
FillMorePopupToolBarEntry(CDC *pDC, CXTPCommandBar *pBar) | CXTPRibbonThemeResource | virtual
FillRibbonBar(CDC *pDC, CXTPRibbonBar *pRibbonBar) | CXTPRibbonThemeResource | virtual
FillRibbonTabControl(CDC *pDC, CXTPRibbonBar *pRibbonBar, CRect rcControl) | CXTPRibbonThemeResource | virtual
FillSystemPopupBarEntry(CDC *pDC, CXTPPopupBar *pBar) | CXTPRibbonThemeResource | virtual
FillTabPopupToolBar(CDC *pDC, CXTPPopupToolBar *pPopupToolBar) | CXTPRibbonPaintManager | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetControlGroupOptionSize() const | CXTPRibbonThemeResource | virtual
GetEditHeight() const | CXTPRibbonPaintManager |
GetFontHeight() const | CXTPRibbonPaintManager |
GetFramePaintManager() const | CXTPRibbonPaintManager |
GetGroupCaptionHeight() const | CXTPRibbonPaintManager |
GetImages() const | CXTPRibbonPaintManager |
GetRibbonCaptionHeight(const CXTPRibbonBar *pRibbonBar) const | CXTPRibbonThemeResource | virtual
GetTabPaintManager() const | CXTPRibbonPaintManager |
LoadImage(LPCTSTR lpszFileName) | CXTPRibbonPaintManager |
m_bFlatFrame | CXTPRibbonPaintManager |
m_bHotTrackingGroups | CXTPRibbonPaintManager |
m_clrFileButtonText | CXTPRibbonPaintManager | protected
m_clrMinimizedFrameEdgeHighLight | CXTPRibbonPaintManager | protected
m_clrMinimizedFrameEdgeShadow | CXTPRibbonPaintManager | protected
m_clrRecentFileListEdgeHighLight | CXTPRibbonPaintManager |
m_clrRecentFileListEdgeShadow | CXTPRibbonPaintManager |
m_clrRibbonBorder | CXTPRibbonPaintManager | protected
m_clrRibbonFace | CXTPRibbonPaintManager | protected
m_clrRibbonGroupCaptionText | CXTPRibbonPaintManager | protected
m_clrRibbonInactiveFace | CXTPRibbonPaintManager | protected
m_fontGroupCaption | CXTPRibbonPaintManager |
m_nGroupCaptionHeight | CXTPRibbonPaintManager |
m_nGroupSpacing | CXTPRibbonPaintManager |
m_nTabsHeight | CXTPRibbonPaintManager |
m_pPaintManager | CXTPRibbonPaintManager | protected
m_pTabPaintManager | CXTPRibbonPaintManager | protected
m_rcFileButtonMargin | CXTPRibbonPaintManager | protected
RefreshMetrics() | CXTPRibbonThemeResource | virtual
SetFontHeight(int nFontHeight) | CXTPRibbonPaintManager |
~CXTPRibbonPaintManager() | CXTPRibbonPaintManager | virtual
~CXTPRibbonThemeResource() | CXTPRibbonThemeResource | virtual


Toolkit Pro: Member List

CXTPPropertyGridItemMultilineString Member List

This is the complete list of members for CXTPPropertyGridItemMultilineString, including all inherited members.

AddChildItem(CXTPPropertyGridItem *pItem) | CXTPPropertyGridItem |
AddComboButton() | CXTPPropertyGridItem |
AddExpandButton() | CXTPPropertyGridItem |
AddSliderControl() | CXTPPropertyGridItem |
AddSpinButton() | CXTPPropertyGridItem |
BindToString(CString *pBindString) | CXTPPropertyGridItem |
Collapse() | CXTPPropertyGridItem |
CXTPCmdTarget() | CXTPCmdTarget |
CXTPPropertyGridItem(LPCTSTR lpszCaption, LPCTSTR strValue=NULL, CString *pBindString=NULL) | CXTPPropertyGridItem |
CXTPPropertyGridItem(UINT nID, LPCTSTR strValue=NULL, CString *pBindString=NULL) | CXTPPropertyGridItem |
CXTPPropertyGridItemMultilineString(LPCTSTR lpszCaption, LPCTSTR strValue=NULL, CString *pBindString=NULL) | CXTPPropertyGridItemMultilineString |
CXTPPropertyGridItemMultilineString(UINT nID, LPCTSTR strValue=NULL, CString *pBindString=NULL) | CXTPPropertyGridItemMultilineString |
EnsureVisible() | CXTPPropertyGridItem |
Expand() | CXTPPropertyGridItem |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCaption() const | CXTPPropertyGridItem |
GetCaptionMetrics() const | CXTPPropertyGridItem |
GetChilds() const | CXTPPropertyGridItem |
GetConstraintEdit() const | CXTPPropertyGridItem |
GetConstraints() const | CXTPPropertyGridItem |
GetDefaultValue() const | CXTPPropertyGridItem |
GetDescription() const | CXTPPropertyGridItem |
GetDropDownItemCount() const | CXTPPropertyGridItem |
GetEditStyle() const | CXTPPropertyGridItem | virtual
GetFlags() const | CXTPPropertyGridItem |
GetGrid() const | CXTPPropertyGridItem |
GetHeight() const | CXTPPropertyGridItem |
GetID() const | CXTPPropertyGridItem |
GetIndent() const | CXTPPropertyGridItem |
GetIndex() const | CXTPPropertyGridItem |
GetInplaceButtons() const | CXTPPropertyGridItem |
GetInplaceControls() const | CXTPPropertyGridItem |
GetInPlacedEditValue() | CXTPPropertyGridItem | inlineprotectedvirtual
GetInplaceEdit() | CXTPPropertyGridItem | virtual
GetInplaceList() | CXTPPropertyGridItem | protectedvirtual
GetItemData() const | CXTPPropertyGridItem |
GetItemRect() const | CXTPPropertyGridItem |
GetMarkupCaption() const | CXTPPropertyGridItem |
GetMarkupDescription() const | CXTPPropertyGridItem |
GetMarkupTemplate() const | CXTPPropertyGridItem | virtual
GetMarkupValue() const | CXTPPropertyGridItem |
GetMaskedText() const | CXTPPropertyGridItem |
GetMetrics(BOOL bValueMetrics, BOOL bCreate=TRUE) const | CXTPPropertyGridItem |
GetMultiLinesCount() const | CXTPPropertyGridItem |
GetParentItem() const | CXTPPropertyGridItem |
GetReadOnly() const | CXTPPropertyGridItem | virtual
GetTooltip() const | CXTPPropertyGridItem |
GetValue() const | CXTPPropertyGridItem |
GetValueMetrics() const | CXTPPropertyGridItem |
GetValueRect() | CXTPPropertyGridItem | virtual
GetViewValue() | CXTPPropertyGridItem | virtual
HasChilds() const | CXTPPropertyGridItem |
HasParent(CXTPPropertyGridItem *pParent) | CXTPPropertyGridItem |
HasVisibleChilds() const | CXTPPropertyGridItem |
InsertChildItem(int nIndex, CXTPPropertyGridItem *pItem) | CXTPPropertyGridItem |
IsAllowEdit() const | CXTPPropertyGridItem | virtual
IsCategory() const | CXTPPropertyGridItem |
IsExpandable() const | CXTPPropertyGridItem |
IsExpanded() const | CXTPPropertyGridItem |
IsHidden() const | CXTPPropertyGridItem |
IsInplaceButtonVisible(CXTPPropertyGridInplaceButton *pButton) const | CXTPPropertyGridItem | virtual
IsMultiLine() const | CXTPPropertyGridItem |
IsSelected() const | CXTPPropertyGridItem |
IsValueChanged() const | CXTPPropertyGridItem | virtual
IsVisible() const | CXTPPropertyGridItem |
m_bAutoComplete | CXTPPropertyGridItem | protected
m_bCategory | CXTPPropertyGridItem | protected
m_bConstraintEdit | CXTPPropertyGridItem | protected
m_bExpandable | CXTPPropertyGridItem | protected
m_bExpanded | CXTPPropertyGridItem | protected
m_bHidden | CXTPPropertyGridItem | protected
m_bPassword | CXTPPropertyGridItem | protected
m_bReadOnly | CXTPPropertyGridItem | protected
m_bUseMask | CXTPPropertyGridItem | protected
m_bVisible | CXTPPropertyGridItem | protected
m_chPrompt | CXTPPropertyGridItem | protected
m_dwData | CXTPPropertyGridItem | protected
m_dwEditStyle | CXTPPropertyGridItem | protected
m_nDropDownItemCount | CXTPPropertyGridItem | protected
m_nFlags | CXTPPropertyGridItem | protected
m_nHeight | CXTPPropertyGridItem | protected
m_nID | CXTPPropertyGridItem | protected
m_nIndent | CXTPPropertyGridItem | protected
m_nIndex | CXTPPropertyGridItem | protected
m_nLinesCount | CXTPPropertyGridItem | protected
m_pBindString | CXTPPropertyGridItem | protected
m_pCaptionMetrics | CXTPPropertyGridItem | mutableprotected
m_pChilds | CXTPPropertyGridItem | protected
m_pConstraints | CXTPPropertyGridItem | protected
m_pGrid | CXTPPropertyGridItem | protected
m_pInplaceButtons | CXTPPropertyGridItem | protected
m_pInplaceControls | CXTPPropertyGridItem | protected
m_pMarkupCaption | CXTPPropertyGridItem | protected
m_pMarkupDescription | CXTPPropertyGridItem | protected
m_pMarkupValue | CXTPPropertyGridItem | protected
m_pParent | CXTPPropertyGridItem | protected
m_pValueMetrics | CXTPPropertyGridItem | mutableprotected
m_strCaption | CXTPPropertyGridItem | protected
m_strDefaultValue | CXTPPropertyGridItem | protected
m_strDescription | CXTPPropertyGridItem | protected
m_strFormat | CXTPPropertyGridItem | protected
m_strLiteral | CXTPPropertyGridItem | protected
m_strMarkupTemplate | CXTPPropertyGridItem | protected
m_strMask | CXTPPropertyGridItem | protected
m_strTooltip | CXTPPropertyGridItem | protected
m_strValue | CXTPPropertyGridItem | protected
MeasureItem(LPMEASUREITEMSTRUCT lpMeasureItemStruct) | CXTPPropertyGridItem | virtual
Move(CXTPPropertyGridItem *pParent, int nIndex=-1) | CXTPPropertyGridItem |
NotifyValueChanged() | CXTPPropertyGridItem | protected
OnAddChildItem() | CXTPPropertyGridItem | protectedvirtual
OnAfterEdit(CString &strValue) | CXTPPropertyGridItem | virtual
OnBeforeInsert() | CXTPPropertyGridItem | protectedvirtual
OnCancelEdit() | CXTPPropertyGridItem | virtual
OnCaptionChanged() | CXTPPropertyGridItem | protectedvirtual
OnChar(UINT nChar) | CXTPPropertyGridItem | protectedvirtual
OnConstraintsChanged() | CXTPPropertyGridItem | protectedvirtual
OnDeselect() | CXTPPropertyGridItem | protectedvirtual
OnDrawItemConstraint(CDC *pDC, CXTPPropertyGridItemConstraint *pConstraint, CRect rc, BOOL bSelected) | CXTPPropertyGridItem | virtual
OnDrawItemValue(CDC &dc, CRect rcValue) | CXTPPropertyGridItem | virtual
OnIndexChanged() | CXTPPropertyGridItem | protectedvirtual
OnInpaceControlFocus(BOOL bForward) | CXTPPropertyGridItem | protectedvirtual
OnInplaceButtonDown(CXTPPropertyGridInplaceButton *pButton) | CXTPPropertyGridItemMultilineString | protectedvirtual
OnKeyDown(UINT nChar) | CXTPPropertyGridItem | protectedvirtual
OnLButtonDblClk(UINT nFlags, CPoint point) | CXTPPropertyGridItem | protectedvirtual
OnLButtonDown(UINT nFlags, CPoint point) | CXTPPropertyGridItem | protectedvirtual
OnLButtonUp(UINT nFlags, CPoint point) | CXTPPropertyGridItem | protectedvirtual
OnMarkupChanged() | CXTPPropertyGridItem | virtual
OnMergeItemConstraint(CDC *pDC, CXTPPropertyGridItemConstraint *pConstraint) | CXTPPropertyGridItem | virtual
OnRButtonDown(UINT nFlags, CPoint point) | CXTPPropertyGridItem | protectedvirtual
OnRequestEdit() | CXTPPropertyGridItem | virtual
OnSelect() | CXTPPropertyGridItem | protectedvirtual
OnValidateEdit() | CXTPPropertyGridItem | virtual
OnValueChanged(CString strValue) | CXTPPropertyGridItem | virtual
PtInValueRect(CPoint point) | CXTPPropertyGridItem | protected
RedrawItem() | CXTPPropertyGridItem |
Remove() | CXTPPropertyGridItem |
ResetValue() | CXTPPropertyGridItem | virtual
Select() | CXTPPropertyGridItem |
SelectNextConstraint() | CXTPPropertyGridItem | protected
SetAutoComplete(BOOL bAutoComplete=TRUE) | CXTPPropertyGridItem |
SetCaption(LPCTSTR lpszCaption) | CXTPPropertyGridItem |
SetConstraintEdit(BOOL bConstraintEdit=TRUE) | CXTPPropertyGridItem |
SetDefaultValue(LPCTSTR lpszDefaultValue) | CXTPPropertyGridItem |
SetDescription(LPCTSTR lpszDescription) | CXTPPropertyGridItem |
SetDropDownItemCount(int nDropDownItemCount) | CXTPPropertyGridItem |
SetEditStyle(DWORD dwEditStyle) | CXTPPropertyGridItem |
SetEditText(const CString &str) | CXTPPropertyGridItem | protectedvirtual
SetExpandable(BOOL bExpandable) | CXTPPropertyGridItem |
SetFlags(UINT nFlags) | CXTPPropertyGridItem |
SetFocusToInplaceControl() | CXTPPropertyGridItem | virtual
SetHeight(int nHeight) | CXTPPropertyGridItem |
SetHidden(BOOL bHidden) | CXTPPropertyGridItem |
SetID(UINT nID) | CXTPPropertyGridItem |
SetItemData(DWORD_PTR dwData) | CXTPPropertyGridItem |
SetMarkupTemplate(LPCTSTR lpstrMarkupTemplate) | CXTPPropertyGridItem |
SetMask(LPCTSTR strMask, LPCTSTR strLiteral, TCHAR chPrompt=_T('_')) | CXTPPropertyGridItem |
SetMaskedText(LPCTSTR lpszMaskedText) | CXTPPropertyGridItem |
SetMultiLinesCount(int nLinesCount) | CXTPPropertyGridItem |
SetPasswordMask(TCHAR chMask=_T(' *')) | CXTPPropertyGridItem |
SetPrompt(LPCTSTR lpszPrompt) | CXTPPropertyGridItem |
SetReadOnly(BOOL bReadOnly=TRUE) | CXTPPropertyGridItem | virtual
SetTooltip(LPCTSTR lpstrTooltip) | CXTPPropertyGridItem |
SetValue(CString strValue) | CXTPPropertyGridItem | virtual
SetVisible(BOOL bVisible) | CXTPPropertyGridItem | protectedvirtual
~CXTPPropertyGridItem() | CXTPPropertyGridItem | virtual


Toolkit Pro: XTPChartRadarDiagramSeriesStyle.h Source File

  • Source
  • Chart
  • Diagram
  • RadarDiagram
XTPChartRadarDiagramSeriesStyle.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTRADARDIAGRAMSERIESSTYLE_H__)
24# define __XTPCHARTRADARDIAGRAMSERIESSTYLE_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartSeriesView;
34class CXTPChartMarker;
35
46class _XTP_EXT_CLASS CXTPChartRadarDiagramSeriesStyle : public CXTPChartSeriesStyle
47{
49 DECLARE_DYNAMIC(CXTPChartRadarDiagramSeriesStyle)
51public:
56 CXTPChartRadarDiagramSeriesStyle();
57
62 virtual ~CXTPChartRadarDiagramSeriesStyle();
63
64public:
65 void DoPropExchange(CXTPPropExchange* pPX);
66
67public:
75 virtual CXTPChartDiagram* CreateDiagram();
76
87 virtual BOOL IsStyleDiagram(CXTPChartDiagram* pDiagram) const;
88};
90# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
91#endif //#if !defined(__XTPCHARTRADARDIAGRAMSERIESSTYLE_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartDiagram
This class represents a chart diagram, which is a kind of CXTPChartElement.
Definition XTPChartDiagram.h:48
CXTPChartMarker
This class abstracts a marker used in marking the points in a point series style chart.
Definition XTPChartMarker.h:64
CXTPChartRadarDiagramSeriesStyle
This class represents a base radar series style, which is a kind of CXTPChartSeriesStyle.
Definition XTPChartRadarDiagramSeriesStyle.h:47
CXTPChartRadarDiagramSeriesStyle::DoPropExchange
void DoPropExchange(CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
CXTPChartRadarDiagramSeriesStyle::IsStyleDiagram
virtual BOOL IsStyleDiagram(CXTPChartDiagram *pDiagram) const
Call this function to check whether the chart diagram object passed is a kind of 2D diagram (CXTPChar...
CXTPChartRadarDiagramSeriesStyle::CreateDiagram
virtual CXTPChartDiagram * CreateDiagram()
Call this function to create the diagram for this series.
CXTPChartRadarDiagramSeriesStyle::CXTPChartRadarDiagramSeriesStyle
CXTPChartRadarDiagramSeriesStyle()
Constructs a CXTPChartRadarDiagramSeriesStyle object.
CXTPChartRadarDiagramSeriesStyle::~CXTPChartRadarDiagramSeriesStyle
virtual ~CXTPChartRadarDiagramSeriesStyle()
Destroys a CXTPChartRadarDiagramSeriesStyle object, handles cleanup.
CXTPChartSeriesStyle
CXTPChartSeriesStyle is a CXTPChartElement derived class.
Definition XTPChartSeriesStyle.h:49
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72


Toolkit Pro: Member List

CXTPShellTreeView Member List

This is the complete list of members for CXTPShellTreeView, including all inherited members.

CXTPShellTreeView() | CXTPShellTreeView |
SelectionChanged(HTREEITEM hItem, CString strFolderPath) | CXTPShellTreeView | protectedvirtual
~CXTPShellTreeView() | CXTPShellTreeView | virtual


Toolkit Pro: Member List

CXTPDockingPaneTabColorSet2019 Member List

This is the complete list of members for CXTPDockingPaneTabColorSet2019, including all inherited members.

CXTPDockingPaneTabColorSet2012() | CXTPDockingPaneTabColorSet2012 |
CXTPDockingPaneTabColorSet2019() | CXTPDockingPaneTabColorSet2019 |
CXTPTabPaintManagerColorSet() | CXTPTabPaintManagerColorSet |
FillClient(CDC *pDC, CRect rc, CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
FillHeader(CDC *pDC, CRect rc, CXTPTabManager *pTabManager) | CXTPDockingPaneTabColorSet2019 | virtual
FillNavigateButton(CDC *pDC, CXTPTabManagerNavigateButton *pButton, CRect &rc) | CXTPDockingPaneTabColorSet2012 | virtual
FillPropertyButton(CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerColorSet | virtual
FillStateButton(CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerColorSet | virtual
GetClientColor(CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
GetItemColor(CXTPTabManagerItem *pItem) | CXTPDockingPaneTabColorSet2012 | virtual
GradientFill(CDC *pDC, CRect rc, COLORREF clrLight, COLORREF clrDark, XTPTabPosition position) | CXTPTabPaintManagerColorSet |
IsAppThemed() const | CXTPTabPaintManagerColorSet | virtual
m_clrActiveFilesBack | CXTPTabPaintManagerColorSet |
m_clrActiveFilesBackHighlighted | CXTPTabPaintManagerColorSet |
m_clrActiveFilesBackPressed | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyph | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyphHighlighted | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyphPressed | CXTPTabPaintManagerColorSet |
m_clrAutoHideFace | CXTPTabPaintManagerColorSet |
m_clrBorderHighlight | CXTPTabPaintManagerColorSet |
m_clrButtonBorder | CXTPTabPaintManagerColorSet |
m_clrButtonBorderHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonBorderHot | CXTPTabPaintManagerColorSet |
m_clrButtonBorderKeyTips | CXTPTabPaintManagerColorSet |
m_clrButtonBorderTabContext1 | CXTPTabPaintManagerColorSet |
m_clrButtonBorderTabContext2 | CXTPTabPaintManagerColorSet |
m_clrButtonHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonHighlightedClose | CXTPTabPaintManagerColorSet |
m_clrButtonNormal | CXTPTabPaintManagerColorSet |
m_clrButtonPressed | CXTPTabPaintManagerColorSet |
m_clrButtonSelected | CXTPTabPaintManagerColorSet |
m_clrButtonSelectedHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonSelectedPressed | CXTPTabPaintManagerColorSet |
m_clrControlFace | CXTPTabPaintManagerColorSet |
m_clrFrameBorder | CXTPTabPaintManagerColorSet |
m_clrHeaderFace | CXTPTabPaintManagerColorSet |
m_clrPaneFace | CXTPTabPaintManagerColorSet |
m_clrTabClientBack | CXTPTabPaintManagerColorSet |
m_clrTabClientBorder | CXTPTabPaintManagerColorSet |
m_clrTextDisabled | CXTPTabPaintManagerColorSet |
m_clrTextHighlight | CXTPTabPaintManagerColorSet |
m_clrTextHighlightClose | CXTPTabPaintManagerColorSet |
m_clrTextNormal | CXTPTabPaintManagerColorSet |
m_clrTextPressed | CXTPTabPaintManagerColorSet |
m_clrTextSelected | CXTPTabPaintManagerColorSet |
m_clrTextSelectedHighlighted | CXTPTabPaintManagerColorSet |
m_clrTextSelectedPressed | CXTPTabPaintManagerColorSet |
m_csExcelNormal | CXTPTabPaintManagerColorSet |
m_csExcelSelected | CXTPTabPaintManagerColorSet |
m_csPropertyPage | CXTPTabPaintManagerColorSet |
m_csPropertyPage2003 | CXTPTabPaintManagerColorSet |
m_csStateButton | CXTPTabPaintManagerColorSet |
m_pPaintManager | CXTPTabPaintManagerColorSet | protected
RefreshMetrics() | CXTPDockingPaneTabColorSet2012 | virtual
SelectClipRgn(CDC *pDC, CRect rcClient, CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
SetTextColor(CDC *pDC, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerColorSet | virtual
~CXTPTabPaintManagerColorSet() | CXTPTabPaintManagerColorSet | virtual


Toolkit Pro: Member List

CXTPControlButtonColor Member List

This is the complete list of members for CXTPControlButtonColor, including all inherited members.

AssignDocTemplate(UINT nIDResource) | CXTPControl |
ClickToolBarButton(CRect rcActiveRect=CRect(0, 0, 0, 0)) | CXTPControl | protected
Compare(CXTPControl *pOther) | CXTPControl | virtual
Copy(CXTPControl *pControl, BOOL bRecursive=FALSE) | CXTPControlButtonColor | protectedvirtual
CustomizeStartDrag(CPoint point) | CXTPControl | protectedvirtual
CustomizeStartResize(CPoint point) | CXTPControl | protectedvirtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPControl() | CXTPControl | protected
CXTPControlButton() | CXTPControlButton |
CXTPControlButtonColor() | CXTPControlButtonColor |
DelayLayoutParent() | CXTPControl |
DelayRedrawParent() | CXTPControl |
DoCustomDragOver(CXTPCommandBar *pCommandBar, CPoint point, DROPEFFECT &dropEffect) | CXTPControl | protectedvirtual
DoPropExchange(CXTPPropExchange *pPX) | CXTPControlButtonColor | protectedvirtual
Draw(CDC *pDC) | CXTPControlButtonColor | protectedvirtual
ExcludeDocTemplate(UINT nIDResource) | CXTPControl |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
FromUI(CCmdUI *pCmdUI) | CXTPControl | static
GenerateCommandBarList(DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam) | CXTPControl | protectedvirtual
GetAction() const | CXTPControl |
GetBeginGroup() const | CXTPControl |
GetButtonSize() const | CXTPControl | virtual
GetCaption() const | CXTPControl | virtual
GetCategory() const | CXTPControl |
GetChecked() const | CXTPControl |
GetCloseSubMenuOnClick() const | CXTPControl |
GetColor() const | CXTPControlButtonColor |
GetCommandBar() const | CXTPControl | virtual
GetControls() const | CXTPControl |
GetCustomizeMinHeight() const | CXTPControl | protectedvirtual
GetCustomizeMinWidth() const | CXTPControl | protectedvirtual
GetCustomShortcutText() const | CXTPControl |
GetDescription() const | CXTPControl | virtual
GetEnabled() const | CXTPControl |
GetExecuteOnPressInterval() const | CXTPControl |
GetExpanded() const | CXTPControl |
GetFlags() const | CXTPControl |
GetHeight() const | CXTPControl |
GetHelpId() const | CXTPControl |
GetHideFlags() const | CXTPControl |
GetIconId() const | CXTPControl |
GetIconSize() const | CXTPControl | virtual
GetID() const | CXTPControl |
GetImage(int nWidth=16) const | CXTPControl | virtual
GetImageManager() const | CXTPControl |
GetIndex() const | CXTPControl |
GetKeyboardTip() const | CXTPControl |
GetPaintManager() const | CXTPControl |
GetParameter() const | CXTPControl |
GetParent() const | CXTPControl |
GetPopuped() const | CXTPControl | virtual
GetPressed() const | CXTPControl | virtual
GetRect() const | CXTPControl |
GetRibbonGroup() const | CXTPControl |
GetRowRect() const | CXTPControl |
GetSelected() const | CXTPControl | virtual
GetShortcutText() const | CXTPControl |
GetSize(CDC *pDC) | CXTPControlButtonColor | protectedvirtual
GetStyle() const | CXTPControl |
GetStyleEx() const | CXTPControlButton |
GetTag() const | CXTPControl |
GetTooltip() const | CXTPControl | virtual
GetType() const | CXTPControl |
GetWidth() const | CXTPControl |
GetWrap() const | CXTPControl |
HasDwmCompositedRect() const | CXTPControl |
IsCaptionVisible() const | CXTPControl | virtual
IsCursorOver() const | CXTPControl |
IsCustomizeMode() const | CXTPControl | protected
IsCustomizeMovable() const | CXTPControl | virtual
IsCustomizeResizeAllow() const | CXTPControl | protectedvirtual
IsFocusable() const | CXTPControl | protectedvirtual
IsFocused() const | CXTPControl | virtual
IsItemDefault() const | CXTPControl |
IsLayoutChanged() | CXTPControl | protected
IsLayoutRTL() const | CXTPControl | protected
IsOnQuickAccess() const | CXTPControl |
IsTemporary() const | CXTPControl |
IsTransparent() const | CXTPControl | inlinevirtual
IsVisible(DWORD dwSkipFlags=0) const | CXTPControl | virtual
m_bBeginGroup | CXTPControl | protected
m_bChecked | CXTPControl | protected
m_bCloseSubMenuOnClick | CXTPControl | protected
m_bDefaultItem | CXTPControl | protected
m_bEnabled | CXTPControl | protected
m_bExpanded | CXTPControl | protected
m_bLayoutRTL | CXTPControl | protected
m_bOnQuickAccess | CXTPControl | protected
m_bPressed | CXTPControl | protected
m_bSelected | CXTPControl | protected
m_bTemporary | CXTPControl | protected
m_buttonCustomStyle | CXTPControl | protected
m_buttonRibbonStyle | CXTPControl | protected
m_buttonStyle | CXTPControl | protected
m_buttonStyleEx | CXTPControlButton | protected
m_bWrap | CXTPControl | protected
m_clr | CXTPControlButtonColor | protected
m_controlType | CXTPControl | protected
m_dwFlags | CXTPControl | protected
m_dwHideFlags | CXTPControl | protected
m_mapDocTemplatesAssigned | CXTPControl | protected
m_mapDocTemplatesExcluded | CXTPControl | protected
m_nCustomIconId | CXTPControl | protected
m_nExecuteOnPressInterval | CXTPControl | protected
m_nHeight | CXTPControl | protected
m_nHelpId | CXTPControl | protected
m_nIconId | CXTPControl | protected
m_nId | CXTPControl | protected
m_nIndex | CXTPControl | protected
m_nTag | CXTPControl | protected
m_nWidth | CXTPControl | protected
m_pAction | CXTPControl | protected
m_pControls | CXTPControl | protected
m_pParent | CXTPControl | protected
m_pRibbonGroup | CXTPControl | protected
m_rcControl | CXTPControl | protected
m_rcRow | CXTPControl | protected
m_strCaption | CXTPControl | protected
m_strCategory | CXTPControl | protected
m_strCustomCaption | CXTPControl | protected
m_strDescriptionText | CXTPControl | protected
m_strKeyboardTip | CXTPControl | protected
m_strParameter | CXTPControl | protected
m_strShortcutText | CXTPControl | protected
m_strShortcutTextAuto | CXTPControl | protected
m_strTooltipText | CXTPControl | protected
m_szIcon | CXTPControl | protected
NotifySite(UINT code) | CXTPControl |
NotifySite(UINT code, NMXTPCONTROL *pNM) | CXTPControl |
NotifySite(CWnd *pSite, UINT code, NMXTPCONTROL *pNM) | CXTPControl |
OnActionChanged(int nProperty) | CXTPControl | protectedvirtual
OnActionChanging(int nProperty) | CXTPControl | protectedvirtual
OnCalcDynamicSize(DWORD dwMode) | CXTPControl | virtual
OnCaptionChanged() | CXTPControl | protectedvirtual
OnClick(BOOL bKeyboard=FALSE, CPoint pt=CPoint(0, 0)) | CXTPControlButton | protectedvirtual
OnCustomizeDragOver(CXTPControl *pDataObject, CPoint point, DROPEFFECT &dropEffect) | CXTPControl | protectedvirtual
OnCustomizeMouseMove(CPoint point) | CXTPControl | protected
OnEnabledChanged() | CXTPControl | virtual
OnExecute() | CXTPControl | virtual
OnHookKeyDown(UINT nChar, LPARAM lParam) | CXTPControl | protectedvirtual
OnHookMouseWheel(UINT nFlags, short zDelta, CPoint point) | CXTPControl | protectedvirtual
OnIdleUpdate() | CXTPControl | protectedvirtual
OnLButtonDblClk(CPoint point) | CXTPControl | protectedvirtual
OnLButtonDown(CPoint point) | CXTPControl | protectedvirtual
OnLButtonUp(CPoint point) | CXTPControlButton | protectedvirtual
OnMouseHover() | CXTPControl | protectedvirtual
OnMouseMove(CPoint point) | CXTPControl | protectedvirtual
OnRButtonDown(CPoint point) | CXTPControl | protectedvirtual
OnRButtonUp(CPoint point) | CXTPControl | protectedvirtual
OnRemoved() | CXTPControl | protectedvirtual
OnSetPopup(BOOL bPopup) | CXTPControl | protectedvirtual
OnSetSelected(int bSelected) | CXTPControl | protectedvirtual
OnThemeChanged() | CXTPControl | virtual
OnToolHitTest(CPoint point, TOOLINFO *pTI) const | CXTPControl | protectedvirtual
OnUnderlineActivate() | CXTPControl | virtual
RedrawParent(BOOL bAnimate=TRUE) | CXTPControl |
Reset() | CXTPControl |
RestoreCommandBarList(CXTPCommandBarList *pCommandBarList) | CXTPControl | protectedvirtual
ScreenToClient(CPoint *point) | CXTPControl | protected
SetAction(CXTPControlAction *pAction) | CXTPControl | virtual
SetBeginGroup(BOOL bBeginGroup) | CXTPControl | virtual
SetCaption(LPCTSTR lpszCaption) | CXTPControl |
SetCaption(UINT nIDCaption) | CXTPControl |
SetCategory(LPCTSTR lpszCategory) | CXTPControl |
SetChecked(BOOL bChecked) | CXTPControl | virtual
SetCloseSubMenuOnClick(BOOL bCloseOnClick) | CXTPControl |
SetColor(COLORREF clr) | CXTPControlButtonColor |
SetCustomIcon(HICON hIcon) | CXTPControl |
SetCustomShortcutText(LPCTSTR lpszCustomShortcutText) | CXTPControl |
SetDescription(LPCTSTR lpszDescription) | CXTPControl |
SetEnabled(BOOL bEnabled) | CXTPControl | virtual
SetExecuteOnPressInterval(int nExecuteOnPressInterval) | CXTPControl |
SetExpanded(BOOL bExpanded) | CXTPControl | protected
SetFlags(DWORD dwFlags) | CXTPControl |
SetFocused(BOOL bFocused) | CXTPControl | virtual
SetHeight(int nHeight) | CXTPControl | virtual
SetHelpId(int nId) | CXTPControl |
SetHideFlag(XTPControlHideFlags dwFlag, BOOL bSet) | CXTPControl |
SetHideFlags(DWORD dwFlags) | CXTPControl | virtual
SetHideWrap(BOOL bHide) | CXTPControl |
SetIconId(int nId) | CXTPControl |
SetIconSize(CSize szIcon) | CXTPControl |
SetID(int nId) | CXTPControl |
SetIndex(int nIndex) | CXTPControl | inlineprotected
SetItemDefault(BOOL bDefault) | CXTPControl |
SetKeyboardTip(LPCTSTR lpszKeyboardTip) | CXTPControl |
SetOnQuickAccess(BOOL bOnQuicAccess=FALSE) | CXTPControl |
SetParameter(LPCTSTR lpszParameter) | CXTPControl |
SetParent(CXTPCommandBar *pParent) | CXTPControl | inlineprotectedvirtual
SetPressed(BOOL bPressed) | CXTPControl |
SetPrompt(LPCTSTR lpszPrompt) | CXTPControl |
SetRect(CRect rcControl) | CXTPControl | virtual
SetRowRect(CRect rcRow) | CXTPControl |
SetShortcutText(LPCTSTR lpszShortcutText) | CXTPControl |
SetStyle(XTPButtonStyle buttonStyle) | CXTPControl |
SetStyleEx(XTPButtonStyle buttonStyle) | CXTPControlButton |
SetTag(DWORD_PTR dwTag) | CXTPControl |
SetTooltip(LPCTSTR lpszTooltip) | CXTPControl |
SetVisible(BOOL bVisible) | CXTPControl |
SetWidth(int nWidth) | CXTPControl | virtual
SetWrap(BOOL bWrap) | CXTPControl |
~CXTPControl() | CXTPControl | protectedvirtual
~CXTPControlButton() | CXTPControlButton | virtual


Toolkit Pro: Member List

CXTPTrackThemeVisualStudio2017 Member List

This is the complete list of members for CXTPTrackThemeVisualStudio2017, including all inherited members.

CalcColumnHeight(CDC *pDC, CXTPGridColumn *pColumn, int nTotalWidth=0) | CXTPGridPaintManager | protectedvirtual
CalculateRowHeight(CDC *pDC, const CString &strText, int nMaxWidth, BOOL bWordBreak=TRUE) | CXTPGridPaintManager | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPGridPaintManager() | CXTPGridPaintManager |
CXTPTrackPaintManager() | CXTPTrackPaintManager |
CXTPTrackThemeOffice2013() | CXTPTrackThemeOffice2013 |
CXTPTrackThemeVisualStudio2017() | CXTPTrackThemeVisualStudio2017 |
DrawBitmap(CDC *pDC, CXTPGridControl *pControl, CRect rcColumn, int iImage) | CXTPGridPaintManager | virtual
DrawCollapsedBitmap(CDC *pDC, const CXTPGridRow *pRow, CRect &rcBitmap) | CXTPGridPaintManager | virtual
DrawColumn(CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn, BOOL bDrawExternal=FALSE, int nShadowWidth=0) | CXTPGridPaintManager | virtual
DrawColumnBackground(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, BOOL &bColumnPressed, BOOL &bDraggingFromHeader, CXTPGridHeader *pHeader=NULL) | CXTPTrackThemeOffice2013 | virtual
DrawColumnFooter(CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn) | CXTPGridPaintManager | virtual
DrawColumnFooterDivider(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn) | CXTPGridPaintManager | virtual
DrawColumnIcon(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, CRect rcIcon, int iIcon) | CXTPGridPaintManager | virtual
DrawColumnText(CDC *pDC, CRect rcText, CString strCaption, int nHeaderAlignment, BOOL bIsHeader, BOOL bColumnPressed) | CXTPTrackThemeOffice2013 | virtual
DrawConnector(CDC *pDC, CPoint ptFrom, CPoint ptTo) | CXTPGridPaintManager |
DrawFocusedRow(CDC *pDC, CRect rcRow) | CXTPTrackThemeOffice2013 | virtual
DrawFreezeColsDivider(CDC *pDC, const CRect &rc, CXTPGridControl *pControl, CXTPGridRow *pRow=NULL) | CXTPGridPaintManager | virtual
DrawGlyph(CDC *pDC, CRect rcColumn, int iImage) | CXTPGridPaintManager | virtual
DrawGrid(CDC *pDC, XTPGridOrientation orientation, CRect rcGrid) | CXTPGridPaintManager | virtual
DrawGridPattern(CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush) | CXTPGridPaintManager | protectedvirtual
DrawGridPattern(CDC *pDC, CXTPBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush) | CXTPGridPaintManager | protectedvirtual
DrawGridPattern(CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr) | CXTPGridPaintManager | protectedvirtual
DrawGroupRow(CDC *pDC, CXTPGridGroupRow *pRow, CRect rcRow, XTP_GRIDRECORDITEM_METRICS *pMetrics) | CXTPTrackThemeOffice2013 | virtual
DrawHorizontalLine(CDC *pDC, int xPos, int yPos, int cx, COLORREF clr) | CXTPGridPaintManager |
DrawInplaceButton(CDC *pDC, CXTPGridInplaceButton *pButton) | CXTPGridPaintManager | virtual
DrawInplaceButtonFrame(CDC *pDC, CXTPGridInplaceButton *pButton) | CXTPGridPaintManager | protectedvirtual
DrawInplaceButtonIcon(CDC *pDC, CXTPGridInplaceButton *pButton) | CXTPGridPaintManager | protectedvirtual
DrawInplaceComboButton(CDC *pDC, CRect *pRc) | CXTPGridPaintManager | virtual
DrawInplaceExpandButton(CDC *pDC, CRect *pRc) | CXTPGridPaintManager | virtual
DrawInplaceSpinButton(CDC *pDC, CRect *pRc) | CXTPGridPaintManager | virtual
DrawItemBitmap(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CRect &rcItem, int nImage) | CXTPGridPaintManager | virtual
DrawItemCaption(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics) | CXTPGridPaintManager | virtual
DrawItemControl(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CXTPGridRecordItemControl *pControl, CRect &rcItem) | CXTPGridPaintManager | virtual
DrawLink(int *pnCurrDrawPos, XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CXTPGridHyperlink *pHyperlink, CString strText, CRect rcLink, int nFlag, BOOL bTrim=FALSE) | CXTPGridPaintManager | protectedvirtual
DrawMarkers(CDC *pDC) | CXTPTrackPaintManager | virtual
DrawMultiLineText(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, BOOL bWordBreak=TRUE) | CXTPGridPaintManager | protectedvirtual
DrawNoGroupByText(CDC *pDC, CRect rcItem) | CXTPGridPaintManager | virtual
DrawRowNumber(CDC *pDC, CRect rcNumber, CXTPGridRow *pRow) | CXTPGridPaintManager | virtual
DrawSectionDivider(CDC *pDC, const CRect &rc, XTPGridSectionDividerPosition dividerPosition, XTPGridSectionDividerStyle dividerStyle, CXTPPaintManagerColor dividerColor) | CXTPGridPaintManager |
DrawShellIcon(CDC *pDC, CRect rcColumn, int iImage) | CXTPGridPaintManager | virtual
DrawSingleLineText(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nStartPos, int nEndPos, int nActualWidth) | CXTPGridPaintManager | protectedvirtual
DrawString(int *pnCurrDrawPos, CDC *pDC, const CString &strDraw, CRect rcDraw, UINT nFormat) | CXTPGridPaintManager | protectedvirtual
DrawTextLine(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nFlag, int &nCharCounter, int &nHyperlinkCounter) | CXTPGridPaintManager | protectedvirtual
DrawTimeLine(CDC *pDC) | CXTPTrackPaintManager | virtual
DrawTrackHeader(CDC *pDC) | CXTPTrackPaintManager | virtual
DrawTreeStructure(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CRect rcItem, CSize sizeGlyph) | CXTPGridPaintManager | virtual
DrawTriangle(CDC *pDC, CRect rcTriangle, BOOL bToDown, BOOL bDraggingFromHeader, int nShadowWidth, BOOL bColumnPressed) | CXTPTrackThemeOffice2013 | virtual
DrawVerticalLine(CDC *pDC, int xPos, int yPos, int cy, COLORREF clr) | CXTPGridPaintManager |
DrawVerticalTimeLineMarker(CDC *pDC, int xPos, CXTPGridControl *pControl, COLORREF color=RGB(0, 255, 0)) | CXTPGridPaintManager | virtual
EnablePreviewMode(BOOL bIsPreviewMode) | CXTPGridPaintManager |
FillFooter(CDC *pDC, CRect rcFooter) | CXTPGridPaintManager | virtual
FillGroupByControl(CDC *pDC, CRect &rcGroupBy) | CXTPGridPaintManager | virtual
FillGroupRowMetrics(CXTPGridGroupRow *pRow, XTP_GRIDRECORDITEM_METRICS *pMetrics, BOOL bPrinting) | CXTPTrackThemeOffice2013 | virtual
FillHeaderControl(CDC *pDC, CRect rcHeader) | CXTPGridPaintManager | virtual
FillIndent(CDC *pDC, CRect rcRow) | CXTPGridPaintManager | virtual
FillItemShade(CDC *pDC, CRect rcItem) | CXTPGridPaintManager | virtual
FillRow(CDC *pDC, CXTPGridRow *pRow, CRect rcRow) | CXTPGridPaintManager | virtual
FindRowAdjacentToMerged(const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, BOOL bUpward) | CXTPGridPaintManager |
FindRowAdjacentToMergedEx(const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, int &nAdjRowIndex, BOOL bUpward) | CXTPGridPaintManager |
FormatTime(int nPosition) | CXTPTrackPaintManager | virtual
FormatTimeLineTick(int nPosition, COLORREF &clrTick, int &nTickLength) | CXTPTrackPaintManager | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetColumnOffice2007CustomThemeBaseColor() const | CXTPGridPaintManager |
GetColumnStyle() const | CXTPGridPaintManager |
GetControlBackColor(CXTPGridControl *pControl) | CXTPGridPaintManager | virtual
GetFooterHeight(CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0) | CXTPGridPaintManager | virtual
GetFreezeColsDividerStyle() const | CXTPGridPaintManager |
GetGlyphs() const | CXTPGridPaintManager |
GetHeaderHeight() | CXTPGridPaintManager | virtual
GetHeaderHeight(CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0) | CXTPGridPaintManager | virtual
GetItemHeight(XTP_GRIDRECORDITEM_DRAWARGS &drawArgs, int nWidth) | CXTPGridPaintManager |
GetMaxPreviewLines() | CXTPGridPaintManager |
GetPreviewItemHeight(CDC *pDC, CXTPGridRow *pRow, int nWidth, int nHeight) | CXTPGridPaintManager | virtual
GetPreviewLinesCount(CDC *pDC, CRect &rcText, const CString &strText) | CXTPGridPaintManager |
GetRowHeight(CDC *pDC, CXTPGridRow *pRow) | CXTPTrackThemeOffice2013 | virtual
CXTPTrackPaintManager::GetRowHeight(CDC *pDC, CXTPGridRow *pRow, int nTotalWidth) | CXTPGridPaintManager | virtual
GetRowHeightEx(CDC *pDC, CXTPGridRow *pRow, int nTotalWidth, const BOOL firstLevel=TRUE) | CXTPGridPaintManager |
GetSectionDividerHeight(XTPGridFixedRowsDividerStyle dividerStyle) | CXTPGridPaintManager |
GetTextFont() | CXTPGridPaintManager |
IsColumHotTrackingEnabled() const | CXTPGridPaintManager | virtual
IsColumnPlusMinusSign() const | CXTPGridPaintManager |
IsColumnWidthWYSIWYG() const | CXTPGridPaintManager |
IsDrawGridForEmptySpace() const | CXTPGridPaintManager |
IsFixedInplaceButtonHeight() const | CXTPGridPaintManager |
IsFixedRowHeight() const | CXTPGridPaintManager |
IsGridVisible(BOOL bVertical) const | CXTPGridPaintManager |
IsGridVisible(XTPGridOrientation orientation) const | CXTPGridPaintManager |
IsLastColumnWidthWYSIWYG() const | CXTPGridPaintManager |
IsPreviewMode() const | CXTPGridPaintManager |
IsPrintGroupRowIcon() const | CXTPGridPaintManager |
IsShowWYSIWYGMarkers() const | CXTPGridPaintManager |
IsUseDropMarker() const | CXTPGridPaintManager |
LoadGlyphs() | CXTPTrackThemeOffice2013 | virtual
m_arStartCol | CXTPGridPaintManager |
m_bAllowMergeCells | CXTPGridPaintManager |
m_bBaseTreeIndent | CXTPGridPaintManager |
m_bCleanTooltip | CXTPGridPaintManager |
m_bColumnPlusMinusSign | CXTPGridPaintManager | protected
m_bColumnWidthWYSIWYG | CXTPGridPaintManager | protected
m_bCompactText | CXTPGridPaintManager |
m_bDrawGridForEmptySpace | CXTPGridPaintManager | protected
m_bFixedInplaceButtonHeight | CXTPGridPaintManager | protected
m_bFixedRowHeight | CXTPGridPaintManager | protected
m_bForceDynamicMarkupForCell | CXTPGridPaintManager |
m_bForceShowDropMarker | CXTPGridPaintManager |
m_bForceShowTooltip | CXTPGridPaintManager |
m_bGrayIfDisable | CXTPGridPaintManager |
m_bGroupRowTextBold | CXTPGridPaintManager |
m_bHideSelection | CXTPGridPaintManager |
m_bHotTracking | CXTPGridPaintManager |
m_bInvertColumnOnClick | CXTPGridPaintManager |
m_bIsPreviewMode | CXTPGridPaintManager | protected
m_bLastColumnWidthWYSIWYG | CXTPGridPaintManager | protected
m_bMakeUpper | CXTPGridPaintManager |
m_bMoveScrollbarOnFixedColumnsIndent | CXTPGridPaintManager |
m_bPrintGroupRowIcon | CXTPGridPaintManager | protected
m_bPrintPageRectangle | CXTPGridPaintManager |
m_bPrintSortTriangle | CXTPGridPaintManager |
m_bPrintVirtualPageNumber | CXTPGridPaintManager |
m_bPrintWatermark | CXTPGridPaintManager |
m_bRecOrRowNum | CXTPGridPaintManager |
m_bRevertAlignment | CXTPGridPaintManager |
m_bShadeGroupHeadings | CXTPGridPaintManager |
m_bShadeSortColumn | CXTPGridPaintManager |
m_bShowLockIcon | CXTPGridPaintManager |
m_bShowNonActiveInPlaceButton | CXTPGridPaintManager |
m_bShowWYSIWYGMarkers | CXTPGridPaintManager | protected
m_bSortTriangleOffsetFromRight | CXTPGridPaintManager |
m_bThemedInplaceButtons | CXTPGridPaintManager |
m_bUseAlternativeBackground | CXTPGridPaintManager |
m_bUseDropMarker | CXTPGridPaintManager |
m_bUseEditTextAlignment | CXTPGridPaintManager |
m_bUseGroupRowSelectionState | CXTPGridPaintManager |
m_bUseShellIcon | CXTPGridPaintManager |
m_clrAlternativeBackground | CXTPGridPaintManager |
m_clrBoldText | CXTPGridPaintManager |
m_clrBoldTextHighlight | CXTPGridPaintManager |
m_clrBtnFace | CXTPGridPaintManager |
m_clrBtnFacePressed | CXTPGridPaintManager |
m_clrBtnText | CXTPGridPaintManager |
m_clrCaptionText | CXTPGridPaintManager |
m_clrCaptionTextPressed | CXTPGridPaintManager |
m_clrColumnOffice2007CustomTheme | CXTPGridPaintManager |
m_clrConnector | CXTPGridPaintManager |
m_clrControlBack | CXTPGridPaintManager |
m_clrControlDark | CXTPGridPaintManager |
m_clrControlLightLight | CXTPGridPaintManager |
m_clrDisableBitmapDarkest | CXTPGridPaintManager |
m_clrDisableBitmapLightest | CXTPGridPaintManager |
m_clrFormulaSubSum | CXTPGridPaintManager |
m_clrFormulaSum | CXTPGridPaintManager |
m_clrFreezeColsDivider | CXTPGridPaintManager |
m_clrGlyph | CXTPTrackThemeOffice2013 |
m_clrGlyphHighlight | CXTPTrackThemeOffice2013 |
m_clrGradientColumnSeparator | CXTPGridPaintManager |
m_clrGradientColumnShadow | CXTPGridPaintManager |
m_clrGroupBoxBack | CXTPGridPaintManager |
m_clrGroupRowText | CXTPGridPaintManager |
m_clrGroupShadeBack | CXTPGridPaintManager |
m_clrGroupShadeBorder | CXTPGridPaintManager |
m_clrGroupShadeText | CXTPGridPaintManager |
m_clrHeaderControl | CXTPGridPaintManager |
m_clrHighlight | CXTPGridPaintManager |
m_clrHighlightText | CXTPGridPaintManager |
m_clrHotDivider | CXTPGridPaintManager |
m_clrIndentControl | CXTPGridPaintManager |
m_clrItemShade | CXTPGridPaintManager |
m_clrMarker | CXTPTrackPaintManager |
m_clrMarkerBack | CXTPTrackPaintManager |
m_clrMarkerBorder | CXTPTrackPaintManager |
m_clrPreviewText | CXTPGridPaintManager |
m_clrScrollBarBorderDark | CXTPTrackPaintManager |
m_clrScrollBarBorderLight | CXTPTrackPaintManager |
m_clrScrollBarDark | CXTPTrackPaintManager |
m_clrScrollBarLight | CXTPTrackPaintManager |
m_clrSelectedArea | CXTPTrackPaintManager |
m_clrSelectedBorder | CXTPTrackThemeOffice2013 |
m_clrSelectedRow | CXTPGridPaintManager |
m_clrSelectedRowText | CXTPGridPaintManager |
m_clrTimeHeaderBorder | CXTPTrackPaintManager |
m_clrTimeHeaderDark | CXTPTrackPaintManager |
m_clrTimeHeaderDarkDark | CXTPTrackPaintManager |
m_clrTimeHeaderDivider | CXTPTrackPaintManager |
m_clrTimeLinePosition | CXTPTrackPaintManager |
m_clrTimeLineTick | CXTPTrackPaintManager |
m_clrTimeSliderBackground | CXTPTrackPaintManager |
m_clrTrackHeader | CXTPTrackPaintManager |
m_clrTrackMarkerBorder | CXTPTrackPaintManager |
m_clrTrackMarkerText | CXTPTrackPaintManager |
m_clrTrackMarkerTextBack | CXTPTrackPaintManager |
m_clrTrackMarkerTextBorder | CXTPTrackPaintManager |
m_clrTrackTimeArea | CXTPTrackPaintManager |
m_clrWindowText | CXTPGridPaintManager |
m_clrWorkArea | CXTPTrackPaintManager |
m_clrWorkAreaScrollBarBorder | CXTPTrackPaintManager |
m_clrWorkAreaScrollBarDark | CXTPTrackPaintManager |
m_clrWorkAreaScrollBarLight | CXTPTrackPaintManager |
m_columnStyle | CXTPGridPaintManager | protected
m_crlNoGroupByText | CXTPGridPaintManager |
m_grcGradientColumn | CXTPGridPaintManager |
m_grcGradientColumnHot | CXTPGridPaintManager |
m_grcGradientColumnPushed | CXTPGridPaintManager |
m_iRecOrRowStart | CXTPGridPaintManager |
m_nBaseParentRecordIndent | CXTPGridPaintManager |
m_nFixedColumnsIndent | CXTPGridPaintManager |
m_nFooterHeight | CXTPGridPaintManager | protected
m_nFreezeColsDividerStyle | CXTPGridPaintManager | protected
m_nGridLineStylePreviousH | CXTPGridPaintManager | protected
m_nGridLineStylePreviousV | CXTPGridPaintManager | protected
m_nGroupGridLineHeight | CXTPGridPaintManager | protected
m_nGroupGridLineStyle | CXTPGridPaintManager | protected
m_nHeaderHeight | CXTPGridPaintManager | protected
m_nMaxPreviewLines | CXTPGridPaintManager | protected
m_nResizingWidth | CXTPGridPaintManager | protected
m_nRowHeight | CXTPGridPaintManager | protected
m_nRowHeightDefault | CXTPGridPaintManager |
m_nTextIndentForGroupRowsWithNoIcon | CXTPGridPaintManager |
m_nTreeColumnLineLength | CXTPGridPaintManager |
m_nTreeIndent | CXTPGridPaintManager |
m_nTreeStructureStyle | CXTPGridPaintManager |
m_nTreeTextIndent | CXTPGridPaintManager |
m_nTreeTextIndentGroupRow | CXTPGridPaintManager |
m_nTreeTextIndentRowChildren | CXTPGridPaintManager |
m_nTreeTextIndentRowParent | CXTPGridPaintManager |
m_pControl | CXTPGridPaintManager | protected
m_pGlyphs | CXTPGridPaintManager | protected
m_pHyperlinkHoverStyle | CXTPGridPaintManager |
m_pHyperlinkStyle | CXTPGridPaintManager |
m_pMarkupUIElement_NoGroupBy | CXTPGridPaintManager | protected
m_PrintPageWidth | CXTPGridPaintManager |
m_rcPreviewIndent | CXTPGridPaintManager |
m_RecordNumberWidth | CXTPGridPaintManager |
m_strCollapse | CXTPGridPaintManager |
m_strDecreasing | CXTPGridPaintManager |
m_strExpand | CXTPGridPaintManager |
m_strIncreasing | CXTPGridPaintManager |
m_strMarkupUIElement_NoGroupBy | CXTPGridPaintManager | protected
m_strNoFieldsAvailable | CXTPGridPaintManager |
m_strNoGroupBy | CXTPGridPaintManager |
m_strNoItems | CXTPGridPaintManager |
m_strSortBy | CXTPGridPaintManager |
m_szGlyph | CXTPGridPaintManager | protected
m_themeButton | CXTPGridPaintManager | protected
m_themeCombo | CXTPGridPaintManager | protected
m_themeHeader | CXTPGridPaintManager | protected
m_themeSpin | CXTPGridPaintManager | protected
m_treeStructureStyle | CXTPGridPaintManager |
m_xtpBrushGroupGridLineStyle | CXTPGridPaintManager | protected
m_xtpBrushHorizontalGrid | CXTPGridPaintManager | protected
m_xtpBrushTreeStructure | CXTPGridPaintManager | protected
m_xtpBrushVeriticalGrid | CXTPGridPaintManager | protected
m_xtpFontBoldText | CXTPGridPaintManager |
m_xtpFontCaption | CXTPGridPaintManager |
m_xtpFontPreview | CXTPGridPaintManager |
m_xtpFontText | CXTPGridPaintManager |
OnDrawAction(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs) | CXTPGridPaintManager | virtual
RecalcTotalHightOfMergedRows(CXTPGridColumns *pColumns, CDC *pDC, CXTPGridRow *pRow, int nRowHeight, int nTotalWidth) | CXTPGridPaintManager |
RefreshMetrics() | CXTPTrackThemeVisualStudio2017 | virtual
SetCaptionFont(LOGFONT &lf) | CXTPGridPaintManager |
SetColumnOffice2007CustomThemeBaseColor(COLORREF clrBaseColor) | CXTPGridPaintManager |
SetColumnPlusMinusSign(BOOL bDraw) | CXTPGridPaintManager |
SetColumnWidthWYSIWYG(BOOL bColumnWidthWYSIWYG) | CXTPGridPaintManager |
SetDrawGridForEmptySpace(BOOL bDrawGrid) | CXTPGridPaintManager |
SetFixedRowHeight(BOOL bFixedRowHeight) | CXTPGridPaintManager |
SetFreezeColsDividerStyle(int nStyle) | CXTPGridPaintManager |
SetGridControl(CXTPGridControl *pControl) | CXTPGridPaintManager | virtual
SetHeaderHeight(int nHeight) | CXTPGridPaintManager | virtual
SetInplaceButtonHeight(BOOL bFixedInplaceButtonHeight) | CXTPGridPaintManager |
SetLastColumnWidthWYSIWYG(BOOL bColumnWidthWYSIWYG) | CXTPGridPaintManager |
SetMaxPreviewLines(int nMaxLines) | CXTPGridPaintManager |
SetPreviewIndent(int nLeft, int nTop, int nRight, int nBottom) | CXTPGridPaintManager |
SetPrintGroupRowIcon(BOOL bDraw) | CXTPGridPaintManager |
SetTextFont(LOGFONT &lf) | CXTPGridPaintManager |
ShowWYSIWYGMarkers(BOOL bSet) | CXTPGridPaintManager |
~CXTPGridPaintManager() | CXTPGridPaintManager | virtual
~CXTPTrackPaintManager() | CXTPTrackPaintManager |


Toolkit Pro: Member List

CXTPCalendarThemeRectValue Member List

This is the complete list of members for CXTPCalendarThemeRectValue, including all inherited members.

CopySettings(const CXTPCalendarThemeCustomizableXValueT< CRect, CRect > &refSrc) | CXTPCalendarThemeCustomizableXValueT< CRect, CRect > | inline
CXTPCalendarThemeCustomizableXValueT() | CXTPCalendarThemeCustomizableXValueT< CRect, CRect > | inline
CXTPCalendarThemeRectValue() | CXTPCalendarThemeRectValue |
DoDestroy(CRect &refValue) | CXTPCalendarThemeCustomizableXValueT< CRect, CRect > | inlinevirtual
DoPropExchange(CXTPPropExchange *pPX, LPCTSTR pcszPropName) | CXTPCalendarThemeRectValue | virtual
DoPX_Value(CXTPPropExchange *pPX, LPCTSTR pcszPropName, CRect &rXValue, BOOL bStandard) | CXTPCalendarThemeRectValue | protected
GetStandardValue() const | CXTPCalendarThemeCustomizableXValueT< CRect, CRect > | inlinevirtual
GetValue() const | CXTPCalendarThemeCustomizableXValueT< CRect, CRect > | inlinevirtual
GetValueX() const | CXTPCalendarThemeCustomizableXValueT< CRect, CRect > | inlinevirtual
IsCustomValue() const | CXTPCalendarThemeCustomizableXValueT< CRect, CRect > | inlinevirtual
IsDefaultValue() const | CXTPCalendarThemeCustomizableXValueT< CRect, CRect > | inlinevirtual
IsStandardValue() const | CXTPCalendarThemeCustomizableXValueT< CRect, CRect > | inlinevirtual
m_bAutoDestroy_Custom | CXTPCalendarThemeCustomizableXValueT< CRect, CRect > | protected
m_bAutoDestroy_Standard | CXTPCalendarThemeCustomizableXValueT< CRect, CRect > | protected
m_bIsCustomSet | CXTPCalendarThemeCustomizableXValueT< CRect, CRect > | protected
m_bIsStandardSet | CXTPCalendarThemeCustomizableXValueT< CRect, CRect > | protected
m_ValueCustom | CXTPCalendarThemeCustomizableXValueT< CRect, CRect > | protected
m_ValueStandard | CXTPCalendarThemeCustomizableXValueT< CRect, CRect > | protected
operator CRect() const | CXTPCalendarThemeCustomizableXValueT< CRect, CRect > | inline
operator=(const CRect &rcValue) | CXTPCalendarThemeRectValue |
CXTPCalendarThemeCustomizableXValueT< CRect, CRect >::operator=(CRect refValue) | CXTPCalendarThemeCustomizableXValueT< CRect, CRect > | inline
Serialize(CArchive &ar) | CXTPCalendarThemeCustomizableXValueT< CRect, CRect > | inlinevirtual
SetCustomValue(CRect refValue, BOOL bAutoDestroy) | CXTPCalendarThemeCustomizableXValueT< CRect, CRect > | inlinevirtual
SetCustomValue(CRect refValue) | CXTPCalendarThemeCustomizableXValueT< CRect, CRect > | inlinevirtual
SetDefaultValue() | CXTPCalendarThemeCustomizableXValueT< CRect, CRect > | inlinevirtual
SetStandardValue(CRect refValue, BOOL bAutoDestroy) | CXTPCalendarThemeCustomizableXValueT< CRect, CRect > | inlinevirtual
SetStandardValue(CRect refValue) | CXTPCalendarThemeCustomizableXValueT< CRect, CRect > | inlinevirtual
~CXTPCalendarThemeCustomizableXValueT() | CXTPCalendarThemeCustomizableXValueT< CRect, CRect > | inlinevirtual


Toolkit Pro: Member List

CXTPChartPie Member List

This is the complete list of members for CXTPChartPie, including all inherited members.

CalculateCenter(const CXTPChartPointF &basePoint) const | CXTPChartPieBase |
CreateBoundedPieDeviceCommand(const CXTPChartColor &color, int nThickness, const CXTPChartPointF &basePoint) | CXTPChartPie | virtual
CreatePieDeviceCommand(const CXTPChartColor &color, const CXTPChartColor &color2, const CXTPChartPointF &basePoint) | CXTPChartPie | virtual
CXTPChartPie(double dStartAngle, double dFinishAngle, const CXTPChartEllipse &ellipse, int nDepthPercent, int nHolePercent) | CXTPChartPie |
CXTPChartPieBase(double dStartAngle, double dFinishAngle, const CXTPChartEllipse &ellipse, int nDepthPercent, int nHolePercent) | CXTPChartPieBase | protected
GetBounds() const | CXTPChartPieBase |
GetCenterPoint() const | CXTPChartPieBase |
GetFinishPoint() const | CXTPChartPieBase |
GetHalfAngle() const | CXTPChartPieBase |
GetHolePercent() const | CXTPChartPieBase |
GetStartAngle() const | CXTPChartPieBase |
GetStartPoint() const | CXTPChartPieBase |
m_anchorBounds | CXTPChartPieBase | protected
m_depth | CXTPChartPieBase | protected
m_dStartAngle | CXTPChartPieBase | protected
m_dSweepAngle | CXTPChartPieBase | protected
m_ellipse | CXTPChartPieBase | protected
m_nHolePercent | CXTPChartPieBase | protected
UpdateBounds() | CXTPChartPieBase | protected
~CXTPChartPieBase() | CXTPChartPieBase | virtual


Toolkit Pro: XTPRegistryManager.h Source File

  • Source
  • Controls
  • Util
XTPRegistryManager.h
Go to the documentation of this file.
1
23#if !defined(__XTPREGISTRYMANAGER_H__)
24# define __XTPREGISTRYMANAGER_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
41class _XTP_EXT_CLASS CXTPRegistryManager
42{
43private:
44 class CHKey;
45
46public:
53 CXTPRegistryManager(HKEY hKeyBase = HKEY_CURRENT_USER);
54
59 virtual ~CXTPRegistryManager();
60
61public:
72 void SetRegistryKey(LPCTSTR lpszRegistryKey, LPCTSTR lpszProfileName);
73
74protected:
75 HKEY m_hKeyBase;
76 CString m_strRegistryKey;
78 CString m_strProfileName;
80 static CString m_strINIFileName;
82public:
90 static void AFX_CDECL SetINIFileName(LPCTSTR strINIFileName);
91
99 static CString& AFX_CDECL GetINIFileName();
100
120 BOOL WriteProfileInt(LPCTSTR lpszSection, LPCTSTR lpszEntry, int nValue);
121
142 BOOL WriteProfileBinary(LPCTSTR lpszSection, LPCTSTR lpszEntry, LPBYTE pData, UINT nBytes);
143
163 BOOL WriteProfileString(LPCTSTR lpszSection, LPCTSTR lpszEntry, LPCTSTR lpszValue);
164
184 BOOL WriteProfilePoint(LPCTSTR lpszSection, LPCTSTR lpszEntry, CPoint* pValue);
185
205 BOOL WriteProfileRect(LPCTSTR lpszSection, LPCTSTR lpszEntry, CRect* pValue);
206
226 BOOL WriteProfileSize(LPCTSTR lpszSection, LPCTSTR lpszEntry, CSize* pValue);
227
247 BOOL WriteProfileDouble(LPCTSTR lpszSection, LPCTSTR lpszEntry, double* pValue);
248
271 BOOL WriteProfileDword(LPCTSTR lpszSection, LPCTSTR lpszEntry, DWORD* pValue);
272
295 BOOL WriteProfileColor(LPCTSTR lpszSection, LPCTSTR lpszEntry, COLORREF* pValue);
296
320 UINT GetProfileInt(LPCTSTR lpszSection, LPCTSTR lpszEntry, int nDefault);
321
362 BOOL GetProfileBinary(LPCTSTR lpszSection, LPCTSTR lpszEntry, BYTE** ppData, UINT* pBytes);
363
383 CString GetProfileString(LPCTSTR lpszSection, LPCTSTR lpszEntry, LPCTSTR lpszDefault);
384
399 BOOL GetProfilePoint(LPCTSTR lpszSection, LPCTSTR lpszEntry, CPoint* ptResult);
400
415 BOOL GetProfileRect(LPCTSTR lpszSection, LPCTSTR lpszEntry, CRect* rcResult);
416
431 BOOL GetProfileSize(LPCTSTR lpszSection, LPCTSTR lpszEntry, CSize* rcResult);
432
447 BOOL GetProfileDouble(LPCTSTR lpszSection, LPCTSTR lpszEntry, double* rcResult);
448
466 BOOL GetProfileDword(LPCTSTR lpszSection, LPCTSTR lpszEntry, DWORD* rcResult);
467
485 BOOL GetProfileColor(LPCTSTR lpszSection, LPCTSTR lpszEntry, COLORREF* rcResult);
486
551 int EnumValues(LPCTSTR lpszSection, CMap<CString, LPCTSTR, DWORD, DWORD&>* mapItems,
552 CStringArray* arrayNames);
553
569 int EnumKeys(LPCTSTR lpszSection, CStringArray& arrayKeys);
570
581 bool DeleteKey(LPCTSTR lpszSection, LPCTSTR lpszKey);
582
593 bool DeleteValue(LPCTSTR lpszSection, LPCTSTR lpszKey);
594
604 LONG GetErrorCode() const;
605
614 CString GetErrorMessage() const;
615
616protected:
625 virtual HKEY GetAppRegistryKey(REGSAM samDesired = KEY_WRITE | KEY_READ);
626
637 virtual HKEY GetSectionKey(LPCTSTR lpszSection, REGSAM samDesired = KEY_WRITE | KEY_READ);
638
639private:
640 BOOL GetProfileInfo();
641 LONG RecurseDeleteKey(HKEY hKey, LPCTSTR lpszKey);
642 HKEY GetFullPathKey(LPCTSTR lpszSection) const;
643 HKEY RecurseOpenKey(LPCTSTR lpszSection, REGSAM samDesired);
644
645 LONG m_lResult;
646};
647
649
650AFX_INLINE void CXTPRegistryManager::SetINIFileName(LPCTSTR strINIFileName)
651{
652 m_strINIFileName = strINIFileName;
653}
654AFX_INLINE CString& CXTPRegistryManager::GetINIFileName()
655{
656 return m_strINIFileName;
657}
658AFX_INLINE LONG CXTPRegistryManager::GetErrorCode() const
659{
660 return m_lResult;
661}
663# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
664 #endif // __XTPREGISTRYMANAGER_H__
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPRegistryManager
CXTPRegistryManager is a standalone registry management class.
Definition XTPRegistryManager.h:42
CXTPRegistryManager::GetAppRegistryKey
virtual HKEY GetAppRegistryKey(REGSAM samDesired=KEY_WRITE|KEY_READ)
Called to get a handle to the CWinApp's registry key.
CXTPRegistryManager::WriteProfileRect
BOOL WriteProfileRect(LPCTSTR lpszSection, LPCTSTR lpszEntry, CRect *pValue)
Call this member function to write the specified CRect value into the specified section of the applic...
CXTPRegistryManager::GetProfileRect
BOOL GetProfileRect(LPCTSTR lpszSection, LPCTSTR lpszEntry, CRect *rcResult)
Call this member function to retrieve the value of a CRect from an entry within a specified section o...
CXTPRegistryManager::DeleteValue
bool DeleteValue(LPCTSTR lpszSection, LPCTSTR lpszKey)
Call this function to delete a registry value.
CXTPRegistryManager::SetINIFileName
static void AFX_CDECL SetINIFileName(LPCTSTR strINIFileName)
This member function will set the .INI file name for the registry manager to use instead of the syste...
CXTPRegistryManager::EnumValues
int EnumValues(LPCTSTR lpszSection, CMap< CString, LPCTSTR, DWORD, DWORD & > *mapItems, CStringArray *arrayNames)
Call this function to fill a CMap (CString to DWORD) with the names and value types under a specific ...
CXTPRegistryManager::GetProfileBinary
BOOL GetProfileBinary(LPCTSTR lpszSection, LPCTSTR lpszEntry, BYTE **ppData, UINT *pBytes)
Call this member function to retrieve the binary value from an entry within a specified section of th...
CXTPRegistryManager::WriteProfileInt
BOOL WriteProfileInt(LPCTSTR lpszSection, LPCTSTR lpszEntry, int nValue)
Call this member function to write the specified int value into the specified section of the applicat...
CXTPRegistryManager::WriteProfileColor
BOOL WriteProfileColor(LPCTSTR lpszSection, LPCTSTR lpszEntry, COLORREF *pValue)
Call this member function to write the specified COLORREF value into the specified section of the app...
CXTPRegistryManager::WriteProfileDouble
BOOL WriteProfileDouble(LPCTSTR lpszSection, LPCTSTR lpszEntry, double *pValue)
Call this member function to write the specified double/float value into the specified section of the...
CXTPRegistryManager::m_hKeyBase
HKEY m_hKeyBase
Handle to the registry key to use.
Definition XTPRegistryManager.h:75
CXTPRegistryManager::GetErrorMessage
CString GetErrorMessage() const
Call this member function to retrieve the description text for the last error (if any) that occurred ...
CXTPRegistryManager::WriteProfileBinary
BOOL WriteProfileBinary(LPCTSTR lpszSection, LPCTSTR lpszEntry, LPBYTE pData, UINT nBytes)
Call this member function to write the specified binary value into the specified section of the appli...
CXTPRegistryManager::GetErrorCode
LONG GetErrorCode() const
Call this member function to retrieve that last error (if any) that was returned by Windows when acce...
CXTPRegistryManager::m_strRegistryKey
CString m_strRegistryKey
Used to determine the full registry key for storing application profile settings.
Definition XTPRegistryManager.h:76
CXTPRegistryManager::GetProfileDword
BOOL GetProfileDword(LPCTSTR lpszSection, LPCTSTR lpszEntry, DWORD *rcResult)
Call this member function to retrieve the value of a DWORD from an entry within a specified section o...
CXTPRegistryManager::GetSectionKey
virtual HKEY GetSectionKey(LPCTSTR lpszSection, REGSAM samDesired=KEY_WRITE|KEY_READ)
Called to get a handle to the specified section from the application's registry key.
CXTPRegistryManager::GetProfileString
CString GetProfileString(LPCTSTR lpszSection, LPCTSTR lpszEntry, LPCTSTR lpszDefault)
Call this member function to retrieve the string associated with an entry within the specified sectio...
CXTPRegistryManager::m_strProfileName
CString m_strProfileName
The application's .INI filename.
Definition XTPRegistryManager.h:78
CXTPRegistryManager::GetProfileColor
BOOL GetProfileColor(LPCTSTR lpszSection, LPCTSTR lpszEntry, COLORREF *rcResult)
Call this member function to retrieve the value of a COLORREF from an entry within a specified sectio...
CXTPRegistryManager::WriteProfileString
BOOL WriteProfileString(LPCTSTR lpszSection, LPCTSTR lpszEntry, LPCTSTR lpszValue)
Call this member function to write the specified string value into the specified section of the appli...
CXTPRegistryManager::GetProfilePoint
BOOL GetProfilePoint(LPCTSTR lpszSection, LPCTSTR lpszEntry, CPoint *ptResult)
Call this member function to retrieve the value of a CPoint from an entry within a specified section ...
CXTPRegistryManager::WriteProfileSize
BOOL WriteProfileSize(LPCTSTR lpszSection, LPCTSTR lpszEntry, CSize *pValue)
Call this member function to write the specified CSize value into the specified section of the applic...
CXTPRegistryManager::~CXTPRegistryManager
virtual ~CXTPRegistryManager()
Destroys a CXTPRegistryManager object, handles cleanup and deallocation.
CXTPRegistryManager::m_strINIFileName
static CString m_strINIFileName
Name of an .INI file for registry settings.
Definition XTPRegistryManager.h:80
CXTPRegistryManager::SetRegistryKey
void SetRegistryKey(LPCTSTR lpszRegistryKey, LPCTSTR lpszProfileName)
This member function will set a registry key.
CXTPRegistryManager::WriteProfilePoint
BOOL WriteProfilePoint(LPCTSTR lpszSection, LPCTSTR lpszEntry, CPoint *pValue)
Call this member function to write the specified CPoint value into the specified section of the appli...
CXTPRegistryManager::GetProfileSize
BOOL GetProfileSize(LPCTSTR lpszSection, LPCTSTR lpszEntry, CSize *rcResult)
Call this member function to retrieve the value of a CSize from an entry within a specified section o...
CXTPRegistryManager::WriteProfileDword
BOOL WriteProfileDword(LPCTSTR lpszSection, LPCTSTR lpszEntry, DWORD *pValue)
Call this member function to write the specified DWORD value into the specified section of the applic...
CXTPRegistryManager::GetProfileDouble
BOOL GetProfileDouble(LPCTSTR lpszSection, LPCTSTR lpszEntry, double *rcResult)
Call this member function to retrieve the value of a double from an entry within a specified section ...
CXTPRegistryManager::CXTPRegistryManager
CXTPRegistryManager(HKEY hKeyBase=HKEY_CURRENT_USER)
Constructs a CXTPRegistryManager object.
CXTPRegistryManager::EnumKeys
int EnumKeys(LPCTSTR lpszSection, CStringArray &arrayKeys)
Call this function to fill a CStringArray with the names of keys below the key specified.
CXTPRegistryManager::DeleteKey
bool DeleteKey(LPCTSTR lpszSection, LPCTSTR lpszKey)
Call this function to delete a registry key and all of its contents.
CXTPRegistryManager::GetProfileInt
UINT GetProfileInt(LPCTSTR lpszSection, LPCTSTR lpszEntry, int nDefault)
Call this member function to retrieve the value of an integer from an entry within a specified sectio...
CXTPRegistryManager::GetINIFileName
static CString &AFX_CDECL GetINIFileName()
This member function will return the file name of the .INI file used by the registry manager.


Toolkit Pro: Member List

CXTPTaskDialogLinkCtrl Member List

This is the complete list of members for CXTPTaskDialogLinkCtrl, including all inherited members.

Create(const CRect &rect, CString &strBuffer, CFont *pFont, CWnd *pParentWnd) | CXTPTaskDialogLinkCtrl | virtual
CXTPTaskDialogLinkCtrl() | CXTPTaskDialogLinkCtrl |
ExtractLinks(CString &strBuffer) | CXTPTaskDialogLinkCtrl |
FocusItem(int iFocusItem) | CXTPTaskDialogLinkCtrl |
GetBackColor() const | CXTPTaskDialogLinkCtrl |
GetFocusedLink() const | CXTPTaskDialogLinkCtrl |
GetLinkPos(CString strBuffer, int iPos=0) | CXTPTaskDialogLinkCtrl |
GetTextColor() const | CXTPTaskDialogLinkCtrl |
GetTextLinkColor() const | CXTPTaskDialogLinkCtrl |
HitTest(CPoint pt) const | CXTPTaskDialogLinkCtrl |
m_arrLinks | CXTPTaskDialogLinkCtrl | protected
m_crBack | CXTPTaskDialogLinkCtrl | protected
m_crText | CXTPTaskDialogLinkCtrl | protected
m_crTextLink | CXTPTaskDialogLinkCtrl | protected
m_hcurHand | CXTPTaskDialogLinkCtrl | protected
m_nFocused | CXTPTaskDialogLinkCtrl | protected
m_strBuffer | CXTPTaskDialogLinkCtrl | protected
m_xtpFontUL | CXTPTaskDialogLinkCtrl | protected
SetBackColor(COLORREF crBack) | CXTPTaskDialogLinkCtrl |
SetTextColor(COLORREF crText) | CXTPTaskDialogLinkCtrl |
SetTextLinkColor(COLORREF crTextLink) | CXTPTaskDialogLinkCtrl |
~CXTPTaskDialogLinkCtrl() | CXTPTaskDialogLinkCtrl | virtual


Toolkit Pro: XTPFlowGraphElement.h Source File

  • Source
  • FlowGraph
XTPFlowGraphElement.h
Go to the documentation of this file.
1
23#if !defined(__XTPFLOWGRAPHELEMENT_H__)
24# define __XTPFLOWGRAPHELEMENT_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPFlowGraphControl;
34class CXTPFlowGraphPage;
35
45class _XTP_EXT_CLASS CXTPFlowGraphElement : public CXTPCmdTarget
46{
47 DECLARE_DYNAMIC(CXTPFlowGraphElement);
48
49public:
54 CXTPFlowGraphElement();
60 virtual ~CXTPFlowGraphElement();
61
62public:
69 virtual CXTPFlowGraphControl* GetControl() const = 0;
78 virtual CXTPFlowGraphPage* GetPage() const = 0;
85 BOOL IsSelected() const;
86
95 void OnGraphChanged();
96
101 virtual void OnRemoved();
102
108 virtual void SetCaption(LPCTSTR lpszCaption) = 0;
115 virtual CString GetCaption() const = 0;
116
117public:
118 BOOL m_bDirty;
120protected:
121 BOOL m_bSelected;
123 friend class CXTPFlowGraphSelectedElements;
124
125# ifdef _XTP_ACTIVEX
128 DECLARE_DISPATCH_MAP()
129 DECLARE_INTERFACE_MAP()
130
131 DECLARE_OLETYPELIB_EX(CXTPFlowGraphElement)
132
134# endif
135};
137# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
138#endif //#if !defined(__XTPFLOWGRAPHELEMENT_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPFlowGraphControl
Flow Graph Control.
Definition XTPFlowGraphControl.h:173
CXTPFlowGraphElement
Base class for all elements in the flow graph.
Definition XTPFlowGraphElement.h:46
CXTPFlowGraphElement::OnGraphChanged
void OnGraphChanged()
This method is called when the flow graph layout is changed.
CXTPFlowGraphElement::IsSelected
BOOL IsSelected() const
Determines if the element is currently selected.
CXTPFlowGraphElement::SetCaption
virtual void SetCaption(LPCTSTR lpszCaption)=0
Sets the caption to be displayed for this element.
CXTPFlowGraphElement::OnRemoved
virtual void OnRemoved()
This method is called when the element is removed.
CXTPFlowGraphElement::GetCaption
virtual CString GetCaption() const =0
Gets the caption displayed for this element.
CXTPFlowGraphElement::GetPage
virtual CXTPFlowGraphPage * GetPage() const =0
Retrieves a reference to the flow graph page that this element is displayed on.
CXTPFlowGraphElement::m_bSelected
BOOL m_bSelected
Specifies whether the element is selected.
Definition XTPFlowGraphElement.h:121
CXTPFlowGraphElement::m_bDirty
BOOL m_bDirty
Internally used to tell the flow graph that the element has changed.
Definition XTPFlowGraphElement.h:118
CXTPFlowGraphElement::~CXTPFlowGraphElement
virtual ~CXTPFlowGraphElement()
Destroys a CXTPFlowGraphElement object, handles cleanup and deallocation.
CXTPFlowGraphElement::GetControl
virtual CXTPFlowGraphControl * GetControl() const =0
Gets a reference to the parent FlowGraph control.
CXTPFlowGraphElement::CXTPFlowGraphElement
CXTPFlowGraphElement()
Constructs a CXTPFlowGraphElement object.
CXTPFlowGraphPage
Represents a page in the flow graph.
Definition XTPFlowGraphPage.h:54
CXTPFlowGraphSelectedElements
Collection of selected elements in the flow graph.
Definition XTPFlowGraphSelectedElements.h:46


Toolkit Pro: Member List

CXTPSyntaxEditBufferCommand Member List

This is the complete list of members for CXTPSyntaxEditBufferCommand, including all inherited members.

CXTPSyntaxEditBufferCommand(CXTPSyntaxEditBufferManager *pMgr, LPCTSTR szText, const XTP_EDIT_LINECOL &lcFrom, const XTP_EDIT_LINECOL &lcTo) | CXTPSyntaxEditBufferCommand | protected
CXTPSyntaxEditCommand() | CXTPSyntaxEditCommand | protected
DoDeleteText(XTP_EDIT_LINECOL &lcFrom, XTP_EDIT_LINECOL &lcTo, CXTPSyntaxEditCtrl *pEditCtrl) | CXTPSyntaxEditBufferCommand | protected
DoInsertText(XTP_EDIT_LINECOL &lcFrom, XTP_EDIT_LINECOL &lcTo, CXTPSyntaxEditCtrl *pEditCtrl) | CXTPSyntaxEditBufferCommand | protected
Execute(XTP_EDIT_LINECOL &lcFrom, XTP_EDIT_LINECOL &lcTo, CXTPSyntaxEditCtrl *pEditCtrl)=0 | CXTPSyntaxEditCommand | pure virtual
GetCommandText() const | CXTPSyntaxEditCommand | virtual
GetDataSize() const | CXTPSyntaxEditBufferCommand | protectedvirtual
m_lcFrom | CXTPSyntaxEditBufferCommand | protected
m_lcTo | CXTPSyntaxEditBufferCommand | protected
m_pBufferMgr | CXTPSyntaxEditBufferCommand | protected
m_strCommandText | CXTPSyntaxEditCommand | protected
m_strText | CXTPSyntaxEditBufferCommand | protected
SetCommandText(LPCTSTR szText) | CXTPSyntaxEditCommand | virtual
SetPositionInternally(CXTPSyntaxEditCtrl *pEditCtrl, const XTP_EDIT_LINECOL &lcPos) | CXTPSyntaxEditCommand | protectedstatic
UnExecute(XTP_EDIT_LINECOL &lcFrom, XTP_EDIT_LINECOL &lcTo, CXTPSyntaxEditCtrl *pEditCtrl)=0 | CXTPSyntaxEditCommand | pure virtual
~CXTPSyntaxEditBufferCommand() | CXTPSyntaxEditBufferCommand | virtual
~CXTPSyntaxEditCommand() | CXTPSyntaxEditCommand | virtual


Toolkit Pro: Member List

CXTPMarkupGdiPlusTransformObjectImpl Member List

This is the complete list of members for CXTPMarkupGdiPlusTransformObjectImpl, including all inherited members.

ApplyTransform(const CXTPMarkupTransformationMatrix *pMatrix) | CXTPMarkupGdiPlusTransformObjectImpl | protected
CXTPMarkupGdiPlusTransformObjectImpl() | CXTPMarkupGdiPlusTransformObjectImpl | protected
TransformMatrix(const CXTPGdiPlus *pReserved, GpMatrix *pMatrix)=0 | CXTPMarkupGdiPlusTransformObjectImpl | protectedpure virtual
~CXTPMarkupGdiPlusTransformObjectImpl() | CXTPMarkupGdiPlusTransformObjectImpl | inlinevirtual


Toolkit Pro: XTPSkinManagerSchemaCodes.h Source File

  • Source
  • SkinFramework
XTPSkinManagerSchemaCodes.h
Go to the documentation of this file.
1
23#if !defined(__XTPSKINMANAGERSCHEMACODES_H__)
24# define __XTPSKINMANAGERSCHEMACODES_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33/*
34
35The previous method of getting macro values from the header file
36was smart and concise. Though hardly readable and not working for VS2012
37(with __VSSYM32_H__ defined)
38
39The issue is that SF code is using 'Tmschema.h' definitions, that came with WinXP
40New theme api is defined in 'vssym32.h' which is not supported at the moment.
41
42New approach is straightforward and portable, but verbose and not optimized.
43
44Can be optimized in favor of speed using binary search.
45
46*/
47
48struct TMS_SCHEMA_ENTRY
49{
50 LPCTSTR str;
51 int n;
52};
53
54static const struct TMS_SCHEMA_ENTRY gSchemaClassAndPartsCodes[] = {
55 // clang-format off
56
57 // CJ
58 { _T("Globals"), 1 },
59 { _T("Documentation"), 2 },
60 { _T("SysMetrics"), 3 },
61 { _T("ListBox"), 4 },
62 { _T("Dialog"), 5 },
63
64 // Tmsschema.h
65 { _T("WINDOW"), 6 },
66 { _T("WINDOW_CAPTION"), 1 },
67 { _T("WINDOW_SMALLCAPTION"), 2 },
68 { _T("WINDOW_MINCAPTION"), 3 },
69 { _T("WINDOW_SMALLMINCAPTION"), 4 },
70 { _T("WINDOW_MAXCAPTION"), 5 },
71 { _T("WINDOW_SMALLMAXCAPTION"), 6 },
72 { _T("WINDOW_FRAMELEFT"), 7 },
73 { _T("WINDOW_FRAMERIGHT"), 8 },
74 { _T("WINDOW_FRAMEBOTTOM"), 9 },
75 { _T("WINDOW_SMALLFRAMELEFT"), 10 },
76 { _T("WINDOW_SMALLFRAMERIGHT"), 11 },
77 { _T("WINDOW_SMALLFRAMEBOTTOM"), 12 },
78 //---- window frame buttons ----
79 { _T("WINDOW_SYSBUTTON"), 13 },
80 { _T("WINDOW_MDISYSBUTTON"), 14 },
81 { _T("WINDOW_MINBUTTON"), 15 },
82 { _T("WINDOW_MDIMINBUTTON"), 16 },
83 { _T("WINDOW_MAXBUTTON"), 17 },
84 { _T("WINDOW_CLOSEBUTTON"), 18 },
85 { _T("WINDOW_SMALLCLOSEBUTTON"), 19 },
86 { _T("WINDOW_MDICLOSEBUTTON"), 20 },
87 { _T("WINDOW_RESTOREBUTTON"), 21 },
88 { _T("WINDOW_MDIRESTOREBUTTON"), 22 },
89 { _T("WINDOW_HELPBUTTON"), 23 },
90 { _T("WINDOW_MDIHELPBUTTON"), 24 },
91 //---- scrollbars
92 { _T("WINDOW_HORZSCROLL"), 25 },
93 { _T("WINDOW_HORZTHUMB"), 26 },
94 { _T("WINDOW_VERTSCROLL"), 27 },
95 { _T("WINDOW_VERTTHUMB"), 28 },
96 //---- dialog ----
97 { _T("WINDOW_DIALOG"), 29 },
98 //---- hit-test templates ---
99 { _T("WINDOW_CAPTIONSIZINGTEMPLATE"), 30 },
100 { _T("WINDOW_SMALLCAPTIONSIZINGTEMPLATE"), 31 },
101 { _T("WINDOW_FRAMELEFTSIZINGTEMPLATE"), 32 },
102 { _T("WINDOW_SMALLFRAMELEFTSIZINGTEMPLATE"), 33 },
103 { _T("WINDOW_FRAMERIGHTSIZINGTEMPLATE"), 34 },
104 { _T("WINDOW_SMALLFRAMERIGHTSIZINGTEMPLATE"), 35 },
105 { _T("WINDOW_FRAMEBOTTOMSIZINGTEMPLATE"), 36 },
106 { _T("WINDOW_SMALLFRAMEBOTTOMSIZINGTEMPLATE"), 37 },
107
108 { _T("BUTTON"), 7 },
109 { _T("BUTTON_PUSHBUTTON"), 1 },
110 { _T("BUTTON_RADIOBUTTON"), 2 },
111 { _T("BUTTON_CHECKBOX"), 3 },
112 { _T("BUTTON_GROUPBOX"), 4 },
113 { _T("BUTTON_USERBUTTON"), 5 },
114
115 { _T("REBAR"), 8 },
116 { _T("REBAR_GRIPPER"), 1 },
117 { _T("REBAR_GRIPPERVERT"), 2 },
118 { _T("REBAR_BAND"), 3 },
119 { _T("REBAR_CHEVRON"), 4 },
120 { _T("REBAR_CHEVRONVERT"), 5 },
121
122 { _T("TOOLBAR"), 9 },
123 { _T("TOOLBAR_BUTTON"), 1 },
124 { _T("TOOLBAR_DROPDOWNBUTTON"), 2 },
125 { _T("TOOLBAR_SPLITBUTTON"), 3 },
126 { _T("TOOLBAR_SPLITBUTTONDROPDOWN"), 4 },
127 { _T("TOOLBAR_SEPARATOR"), 5 },
128 { _T("TOOLBAR_SEPARATORVERT"), 6 },
129
130 { _T("STATUS"), 10 },
131 { _T("STATUS_PANE"), 1 },
132 { _T("STATUS_GRIPPERPANE"), 2 },
133 { _T("STATUS_GRIPPER"), 3 },
134
135 { _T("MENU"), 11 },
136 { _T("MENU_MENUITEM"), 1 },
137 { _T("MENU_MENUDROPDOWN"), 2 },
138 { _T("MENU_MENUBARITEM"), 3 },
139 { _T("MENU_MENUBARDROPDOWN"), 4 },
140 { _T("MENU_CHEVRON"), 5 },
141 { _T("MENU_SEPARATOR"), 6 },
142 { _T("MENU_BARBACKGROUND"), 7 },
143 { _T("MENU_BARITEM"), 8 },
144 { _T("MENU_POPUPBACKGROUND"), 9 },
145 { _T("MENU_POPUPBORDERS"), 10 },
146 { _T("MENU_POPUPCHECK"), 11 },
147 { _T("MENU_POPUPCHECKBACKGROUND"), 12 },
148 { _T("MENU_POPUPGUTTER"), 13 },
149 { _T("MENU_POPUPITEM"), 14 },
150 { _T("MENU_POPUPSEPARATOR"), 15 },
151 { _T("MENU_POPUPSUBMENU"), 16 },
152 { _T("MENU_SYSTEMCLOSE"), 17 },
153 { _T("MENU_SYSTEMMAXIMIZE"), 18 },
154 { _T("MENU_SYSTEMMINIMIZE"), 19 },
155 { _T("MENU_SYSTEMRESTORE"), 20 },
156
157 { _T("LISTVIEW"), 12 },
158 { _T("LISTVIEW_LISTITEM"), 1 },
159 { _T("LISTVIEW_LISTGROUP"), 2 },
160 { _T("LISTVIEW_LISTDETAIL"), 3 },
161 { _T("LISTVIEW_LISTSORTEDDETAIL"), 4 },
162 { _T("LISTVIEW_EMPTYTEXT"), 5 },
163
164 { _T("HEADER"), 13 },
165 { _T("HEADER_HEADERITEM"), 1 },
166 { _T("HEADER_HEADERITEMLEFT"), 2 },
167 { _T("HEADER_HEADERITEMRIGHT"), 3 },
168 { _T("HEADER_HEADERSORTARROW"), 4 },
169
170 { _T("PROGRESS"), 14 },
171 { _T("PROGRESS_BAR"), 1 },
172 { _T("PROGRESS_BARVERT"), 2 },
173 { _T("PROGRESS_CHUNK"), 3 },
174 { _T("PROGRESS_CHUNKVERT"), 4 },
175 { _T("PROGRESS_FILL"), 5 },
176 { _T("PROGRESS_FILLVERT"), 6 },
177 { _T("PROGRESS_PULSEOVERLAY"), 7 },
178 { _T("PROGRESS_MOVEOVERLAY"), 8 },
179 { _T("PROGRESS_PULSEOVERLAYVERT"), 9 },
180 { _T("PROGRESS_MOVEOVERLAYVERT"), 10 },
181 { _T("PROGRESS_TRANSPARENTBAR"), 11 },
182 { _T("PROGRESS_TRANSPARENTBARVERT"), 12 },
183
184 { _T("TAB"), 15 },
185 { _T("TAB_TABITEM"), 1 },
186 { _T("TAB_TABITEMLEFTEDGE"), 2 },
187 { _T("TAB_TABITEMRIGHTEDGE"), 3 },
188 { _T("TAB_TABITEMBOTHEDGE"), 4 },
189 { _T("TAB_TOPTABITEM"), 5 },
190 { _T("TAB_TOPTABITEMLEFTEDGE"), 6 },
191 { _T("TAB_TOPTABITEMRIGHTEDGE"), 7 },
192 { _T("TAB_TOPTABITEMBOTHEDGE"), 8 },
193 { _T("TAB_PANE"), 9 },
194 { _T("TAB_BODY"), 10 },
195
196 { _T("TRACKBAR"), 16 },
197 { _T("TRACKBAR_TRACK"), 1 },
198 { _T("TRACKBAR_TRACKVERT"), 2 },
199 { _T("TRACKBAR_THUMB"), 3 },
200 { _T("TRACKBAR_THUMBBOTTOM"), 4 },
201 { _T("TRACKBAR_THUMBTOP"), 5 },
202 { _T("TRACKBAR_THUMBVERT"), 6 },
203 { _T("TRACKBAR_THUMBLEFT"), 7 },
204 { _T("TRACKBAR_THUMBRIGHT"), 8 },
205 { _T("TRACKBAR_TICS"), 9 },
206 { _T("TRACKBAR_TICSVERT"), 10 },
207
208 { _T("TOOLTIP"), 17 },
209 { _T("TOOLTIP_STANDARD"), 1 },
210 { _T("TOOLTIP_STANDARDTITLE"), 2 },
211 { _T("TOOLTIP_BALLOON"), 3 },
212 { _T("TOOLTIP_BALLOONTITLE"), 4 },
213 { _T("TOOLTIP_CLOSE"), 5 },
214
215 { _T("TREEVIEW"), 18 },
216 { _T("TREEVIEW_TREEITEM"), 1 },
217 { _T("TREEVIEW_GLYPH"), 2 },
218 { _T("TREEVIEW_BRANCH"), 3 },
219 { _T("TREEVIEW_HOTGLYPH"), 4 },
220
221 { _T("SPIN"), 19 },
222 { _T("SPIN_UP"), 1 },
223 { _T("SPIN_DOWN"), 2 },
224 { _T("SPIN_UPHORZ"), 3 },
225 { _T("SPIN_DOWNHORZ"), 4 },
226
227 { _T("PAGE"), 20 },
228 { _T("PAGE_UP"), 1 },
229 { _T("PAGE_DOWN"), 2 },
230 { _T("PAGE_UPHORZ"), 3 },
231 { _T("PAGE_DOWNHORZ"), 4 },
232
233 { _T("SCROLLBAR"), 21 },
234 { _T("SCROLLBAR_ARROWBTN"), 1 },
235 { _T("SCROLLBAR_THUMBBTNHORZ"), 2 },
236 { _T("SCROLLBAR_THUMBBTNVERT"), 3 },
237 { _T("SCROLLBAR_LOWERTRACKHORZ"), 4 },
238 { _T("SCROLLBAR_UPPERTRACKHORZ"), 5 },
239 { _T("SCROLLBAR_LOWERTRACKVERT"), 6 },
240 { _T("SCROLLBAR_UPPERTRACKVERT"), 7 },
241 { _T("SCROLLBAR_GRIPPERHORZ"), 8 },
242 { _T("SCROLLBAR_GRIPPERVERT"), 9 },
243 { _T("SCROLLBAR_SIZEBOX"), 10 },
244
245 { _T("EDIT"), 22 },
246 { _T("EDIT_EDITTEXT"), 1 },
247 { _T("EDIT_CARET"), 2 },
248
249 { _T("COMBOBOX"), 23 },
250 { _T("COMBOBOX_DROPDOWNBUTTON"), 1 },
251
252 { _T("CLOCK"), 24 },
253 { _T("CLOCK_TIME"), 1 },
254
255 { _T("TRAYNOTIFY"), 25 },
256 { _T("TRAYNOTIFY_BACKGROUND"), 1 },
257 { _T("TRAYNOTIFY_ANIMBACKGROUND"), 2 },
258
259 { _T("TASKBAR"), 26 },
260 { _T("TASKBAR_BACKGROUNDBOTTOM"), 1 },
261 { _T("TASKBAR_BACKGROUNDRIGHT"), 2 },
262 { _T("TASKBAR_BACKGROUNDTOP"), 3 },
263 { _T("TASKBAR_BACKGROUNDLEFT"), 4 },
264 { _T("TASKBAR_SIZINGBARBOTTOM"), 5 },
265 { _T("TASKBAR_SIZINGBARRIGHT"), 6 },
266 { _T("TASKBAR_SIZINGBARTOP"), 7 },
267 { _T("TASKBAR_SIZINGBARLEFT"), 8 },
268
269 { _T("TASKBAND"), 27 },
270 { _T("TASKBAND_GROUPCOUNT"), 1 },
271 { _T("TASKBAND_FLASHBUTTON"), 2 },
272 { _T("TASKBAND_FLASHBUTTONGROUPMENU"), 3 },
273
274 { _T("STARTPANEL"), 28 },
275 { _T("STARTPANEL_USERPANE"), 1 },
276 { _T("STARTPANEL_MOREPROGRAMS"), 2 },
277 { _T("STARTPANEL_MOREPROGRAMSARROW"), 3 },
278 { _T("STARTPANEL_PROGLIST"), 4 },
279 { _T("STARTPANEL_PROGLISTSEPARATOR"), 5 },
280 { _T("STARTPANEL_PLACESLIST"), 6 },
281 { _T("STARTPANEL_PLACESLISTSEPARATOR"), 7 },
282 { _T("STARTPANEL_LOGOFF"), 8 },
283 { _T("STARTPANEL_LOGOFFBUTTONS"), 9 },
284 { _T("STARTPANEL_USERPICTURE"), 10 },
285 { _T("STARTPANEL_PREVIEW"), 11 },
286
287 { _T("EXPLORERBAR"), 29 },
288 { _T("EXPLORERBAR_HEADERBACKGROUND"), 1 },
289 { _T("EXPLORERBAR_HEADERCLOSE"), 2 },
290 { _T("EXPLORERBAR_HEADERPIN"), 3 },
291 { _T("EXPLORERBAR_IEBARMENU"), 4 },
292 { _T("EXPLORERBAR_NORMALGROUPBACKGROUND"), 5 },
293 { _T("EXPLORERBAR_NORMALGROUPCOLLAPSE"), 6 },
294 { _T("EXPLORERBAR_NORMALGROUPEXPAND"), 7 },
295 { _T("EXPLORERBAR_NORMALGROUPHEAD"), 8 },
296 { _T("EXPLORERBAR_SPECIALGROUPBACKGROUND"), 9 },
297 { _T("EXPLORERBAR_SPECIALGROUPCOLLAPSE"), 10 },
298 { _T("EXPLORERBAR_SPECIALGROUPEXPAND"), 11 },
299 { _T("EXPLORERBAR_SPECIALGROUPHEAD"), 12 },
300
301 { _T("MENUBAND"), 30 },
302 { _T("MENUBAND_NEWAPPBUTTON"), 1 },
303 { _T("MENUBAND_SEPERATOR"), 2 },
304
305 { NULL, 0 }
306
307 // clang-format on
308};
309
310static const struct TMS_SCHEMA_ENTRY gSchemaEnumCodes[] = {
311 // clang-format off
312
313 { _T("BGTYPE_IMAGEFILE"), 0 },
314 { _T("BGTYPE_BORDERFILL"), 1 },
315 { _T("BGTYPE_NONE"), 2 },
316
317 { _T("IMAGELAYOUT_VERTICAL"), 0 },
318 { _T("IMAGELAYOUT_HORIZONTAL"), 1 },
319
320 { _T("BORDERTYPE_RECT"), 0 },
321 { _T("BORDERTYPE_ROUNDRECT"), 1 },
322 { _T("BORDERTYPE_ELLIPSE"), 2 },
323
324 { _T("FILLTYPE_SOLID"), 0 },
325 { _T("FILLTYPE_VERTGRADIENT"), 1 },
326 { _T("FILLTYPE_HORZGRADIENT"), 2 },
327 { _T("FILLTYPE_RADIALGRADIENT"), 3 },
328 { _T("FILLTYPE_TILEIMAGE"), 4 },
329
330 { _T("SIZINGTYPE_TRUESIZE"), 0 },
331 { _T("SIZINGTYPE_STRETCH"), 1 },
332 { _T("SIZINGTYPE_TILE"), 2 },
333
334 { _T("HALIGN_LEFT"), 0 },
335 { _T("HALIGN_CENTER"), 1 },
336 { _T("HALIGN_RIGHT"), 2 },
337
338 { _T("CONTENTALIGNMENT_LEFT"), 0 },
339 { _T("CONTENTALIGNMENT_CENTER"), 1 },
340 { _T("CONTENTALIGNMENT_RIGHT"), 2 },
341
342 { _T("VALIGN_TOP"), 0 },
343 { _T("VALIGN_CENTER"), 1 },
344 { _T("VALIGN_BOTTOM"), 2 },
345
346 { _T("OFFSETTYPE_TOPLEFT"), 0 },
347 { _T("OFFSETTYPE_TOPRIGHT"), 1 },
348 { _T("OFFSETTYPE_TOPMIDDLE"), 2 },
349 { _T("OFFSETTYPE_BOTTOMLEFT"), 3 },
350 { _T("OFFSETTYPE_BOTTOMRIGHT"), 4 },
351 { _T("OFFSETTYPE_BOTTOMMIDDLE"), 5 },
352 { _T("OFFSETTYPE_MIDDLELEFT"), 6 },
353 { _T("OFFSETTYPE_MIDDLERIGHT"), 7 },
354 { _T("OFFSETTYPE_LEFTOFCAPTION"), 8 },
355 { _T("OFFSETTYPE_RIGHTOFCAPTION"), 9 },
356 { _T("OFFSETTYPE_LEFTOFLASTBUTTON"), 10 },
357 { _T("OFFSETTYPE_RIGHTOFLASTBUTTON"), 11 },
358 { _T("OFFSETTYPE_ABOVELASTBUTTON"), 12 },
359 { _T("OFFSETTYPE_BELOWLASTBUTTON"), 13 },
360
361 { _T("ICONEFFECT_NONE"), 0 },
362 { _T("ICONEFFECT_GLOW"), 1 },
363 { _T("ICONEFFECT_SHADOW"), 2 },
364 { _T("ICONEFFECT_PULSE"), 3 },
365 { _T("ICONEFFECT_ALPHA"), 4 },
366
367 { _T("TEXTSHADOWTYPE_NONE"), 0 },
368 { _T("TEXTSHADOWTYPE_SINGLE"), 1 },
369 { _T("TEXTSHADOWTYPE_CONTINUOUS"), 2 },
370
371 { _T("GLYPHTYPE_NONE"), 0 },
372 { _T("GLYPHTYPE_IMAGEGLYPH"), 1 },
373 { _T("GLYPHTYPE_FONTGLYPH"), 2 },
374
375 { _T("IMAGESELECTTYPE_NONE"), 0 },
376 { _T("IMAGESELECTTYPE_SIZE"), 1 },
377 { _T("IMAGESELECTTYPE_DPI"), 2 },
378
379 { _T("TRUESIZESCALINGTYPE_NONE"), 0 },
380 { _T("TRUESIZESCALINGTYPE_SIZE"), 1 },
381 { _T("TRUESIZESCALINGTYPE_DPI"), 2 },
382
383 { _T("GLYPHFONTSIZINGTYPE_NONE"), 0 },
384 { _T("GLYPHFONTSIZINGTYPE_SIZE"), 1 },
385 { _T("GLYPHFONTSIZINGTYPE_DPI"), 2 },
386
387 { NULL, 0 }
388
389 // clang-format on
390};
391
392static const struct TMS_SCHEMA_ENTRY gSchemaStateCodes[] = {
393 // clang-format off
394
395 { _T("FRAME_ACTIVE"), 1 },
396 { _T("FRAME_INACTIVE"), 2 },
397
398 { _T("CAPTION_ACTIVE"), 1 },
399 { _T("CAPTION_INACTIVE"), 2 },
400 { _T("CAPTION_DISABLED"), 3 },
401
402 { _T("MAXCAPTION_ACTIVE"), 1 },
403 { _T("MAXCAPTION_INACTIVE"), 2 },
404 { _T("MAXCAPTION_DISABLED"), 3 },
405
406 { _T("MINCAPTION_ACTIVE"), 1 },
407 { _T("MINCAPTION_INACTIVE"), 2 },
408 { _T("MINCAPTION_DISABLED"), 3 },
409
410 { _T("HORZSCROLL_NORMAL"), 1 },
411 { _T("HORZSCROLL_HOT"), 2 },
412 { _T("HORZSCROLL_PUSHED"), 3 },
413 { _T("HORZSCROLL_DISABLED"), 4 },
414
415 { _T("HORZTHUMB_NORMAL"), 1 },
416 { _T("HORZTHUMB_HOT"), 2 },
417 { _T("HORZTHUMB_PUSHED"), 3 },
418 { _T("HORZTHUMB_DISABLED"), 4 },
419
420 { _T("VERTSCROLL_NORMAL"), 1 },
421 { _T("VERTSCROLL_HOT"), 2 },
422 { _T("VERTSCROLL_PUSHED"), 3 },
423 { _T("VERTSCROLL_DISABLED"), 4 },
424
425 { _T("VERTTHUMB_NORMAL"), 1 },
426 { _T("VERTTHUMB_HOT"), 2 },
427 { _T("VERTTHUMB_PUSHED"), 3 },
428 { _T("VERTTHUMB_DISABLED"), 4 },
429
430 { _T("SYSBUTTON_NORMAL"), 1 },
431 { _T("SYSBUTTON_HOT"), 2 },
432 { _T("SYSBUTTON_PUSHED"), 3 },
433 { _T("SYSBUTTON_DISABLED"), 4 },
434
435 { _T("MINBUTTON_NORMAL"), 1 },
436 { _T("MINBUTTON_HOT"), 2 },
437 { _T("MINBUTTON_PUSHED"), 3 },
438 { _T("MINBUTTON_DISABLED"), 4 },
439
440 { _T("MAXBUTTON_NORMAL"), 1 },
441 { _T("MAXBUTTON_HOT"), 2 },
442 { _T("MAXBUTTON_PUSHED"), 3 },
443 { _T("MAXBUTTON_DISABLED"), 4 },
444
445 { _T("RESTOREBUTTON_NORMAL"), 1 },
446 { _T("RESTOREBUTTON_HOT"), 2 },
447 { _T("RESTOREBUTTON_PUSHED"), 3 },
448 { _T("RESTOREBUTTON_DISABLED"), 4 },
449
450 { _T("HELPBUTTON_NORMAL"), 1 },
451 { _T("HELPBUTTON_HOT"), 2 },
452 { _T("HELPBUTTON_PUSHED"), 3 },
453 { _T("HELPBUTTON_DISABLED"), 4 },
454
455 { _T("CLOSEBUTTON_NORMAL"), 1 },
456 { _T("CLOSEBUTTON_HOT"), 2 },
457 { _T("CLOSEBUTTON_PUSHED"), 3 },
458 { _T("CLOSEBUTTON_DISABLED"), 4 },
459
460 { _T("PUSHBUTTON_NORMAL"), 1 },
461 { _T("PUSHBUTTON_HOT"), 2 },
462 { _T("PUSHBUTTON_PRESSED"), 3 },
463 { _T("PUSHBUTTON_DISABLED"), 4 },
464 { _T("PUSHBUTTON_DEFAULTED"), 5 },
465
466 { _T("RADIOBUTTON_UNCHECKEDNORMAL"), 1 },
467 { _T("RADIOBUTTON_UNCHECKEDHOT"), 2 },
468 { _T("RADIOBUTTON_UNCHECKEDPRESSED"), 3 },
469 { _T("RADIOBUTTON_UNCHECKEDDISABLED"), 4 },
470 { _T("RADIOBUTTON_CHECKEDNORMAL"), 5 },
471 { _T("RADIOBUTTON_CHECKEDHOT"), 6 },
472 { _T("RADIOBUTTON_CHECKEDPRESSED"), 7 },
473 { _T("RADIOBUTTON_CHECKEDDISABLED"), 8 },
474
475 { _T("CHECKBOX_UNCHECKEDNORMAL"), 1 },
476 { _T("CHECKBOX_UNCHECKEDHOT"), 2 },
477 { _T("CHECKBOX_UNCHECKEDPRESSED"), 3 },
478 { _T("CHECKBOX_UNCHECKEDDISABLED"), 4 },
479 { _T("CHECKBOX_CHECKEDNORMAL"), 5 },
480 { _T("CHECKBOX_CHECKEDHOT"), 6 },
481 { _T("CHECKBOX_CHECKEDPRESSED"), 7 },
482 { _T("CHECKBOX_CHECKEDDISABLED"), 8 },
483 { _T("CHECKBOX_MIXEDNORMAL"), 9 },
484 { _T("CHECKBOX_MIXEDHOT"), 10 },
485 { _T("CHECKBOX_MIXEDPRESSED"), 11 },
486 { _T("CHECKBOX_MIXEDDISABLED"), 12 },
487
488 { _T("GROUPBOX_NORMAL"), 1 },
489 { _T("GROUPBOX_DISABLED"), 2 },
490
491 //---------------------------------------------------------------------------------------
492 // "Rebar" Parts & States
493 //---------------------------------------------------------------------------------------
494
495 { _T("CHEVRON_NORMAL"), 1 },
496 { _T("CHEVRON_HOT"), 2 },
497 { _T("CHEVRON_PRESSED"), 3 },
498
499 //---------------------------------------------------------------------------------------
500 // "Toolbar" Parts & States
501 //---------------------------------------------------------------------------------------
502
503 { _T("TOOLBAR_NORMAL"), 1 },
504 { _T("TOOLBAR_HOT"), 2 },
505 { _T("TOOLBAR_PRESSED"), 3 },
506 { _T("TOOLBAR_DISABLED"), 4 },
507 { _T("TOOLBAR_CHECKED"), 5 },
508 { _T("TOOLBAR_HOTCHECKED"), 6 },
509
510 //---------------------------------------------------------------------------------------
511 // "Menu" Parts & States
512 //---------------------------------------------------------------------------------------
513
514 { _T("MENU_NORMAL"), 1 },
515 { _T("MENU_SELECTED"), 2 },
516 { _T("MENU_DEMOTED"), 3 },
517
518 { _T("BARBACKGROUND_ACTIVE"), 1 },
519 { _T("BARBACKGROUND_INACTIVE"), 2 },
520
521 { _T("POPUPCHECK_CHECKMARKNORMAL"), 1 },
522 { _T("POPUPCHECK_CHECKMARKDISABLED"), 2 },
523 { _T("POPUPCHECK_BULLETNORMAL"), 3 },
524 { _T("POPUPCHECK_BULLETDISABLED"), 4 },
525
526 { _T("POPUPCHECKBACKGROUND_DISABLED"), 1 },
527 { _T("POPUPCHECKBACKGROUND_NORMAL"), 2 },
528 { _T("POPUPCHECKBACKGROUND_BITMAP"), 3 },
529
530 { _T("POPUPITEM_NORMAL"), 1 },
531 { _T("POPUPITEM_HOT"), 2 },
532 { _T("POPUPITEM_DISABLED"), 3 },
533 { _T("POPUPITEM_DISABLEDHOT"), 4 },
534
535 { _T("POPUPSUBMENU_NORMAL"), 1 },
536 { _T("POPUPSUBMENU_DISABLED"), 2 },
537
538 //---------------------------------------------------------------------------------------
539 // "ListView" Parts & States
540 //---------------------------------------------------------------------------------------
541
542 { _T("LISTITEM_NORMAL"), 1 },
543 { _T("LISTITEM_HOT"), 2 },
544 { _T("LISTITEM_SELECTED"), 3 },
545 { _T("LISTITEM_DISABLED"), 4 },
546 { _T("LISTITEM_SELECTEDNOTFOCUS"), 5 },
547
548 //---------------------------------------------------------------------------------------
549 // "Header" Parts & States
550 //---------------------------------------------------------------------------------------
551
552 { _T("HEADERITEM_NORMAL"), 1 },
553 { _T("HEADERITEM_HOT"), 2 },
554 { _T("HEADERITEM_PRESSED"), 3 },
555
556 { _T("HEADERITEMLEFT_NORMAL"), 1 },
557 { _T("HEADERITEMLEFT_HOT"), 2 },
558 { _T("HEADERITEMLEFT_PRESSED"), 3 },
559
560 { _T("HEADERITEMRIGHT_NORMAL"), 1 },
561 { _T("HEADERITEMRIGHT_HOT"), 2 },
562 { _T("HEADERITEMRIGHT_PRESSED"), 3 },
563
564 { _T("HEADERSORTARROW_SORTEDUP"), 1 },
565 { _T("HEADERSORTARROW_SORTEDDOWN"), 2 },
566
567 //---------------------------------------------------------------------------------------
568 // "Tab" Parts & States
569 //---------------------------------------------------------------------------------------
570
571 { _T("TABITEM_NORMAL"), 1 },
572 { _T("TABITEM_HOT"), 2 },
573 { _T("TABITEM_SELECTED"), 3 },
574 { _T("TABITEM_DISABLED"), 4 },
575 { _T("TABITEM_FOCUSED"), 5 },
576
577 { _T("TABITEMLEFTEDGE_NORMAL"), 1 },
578 { _T("TABITEMLEFTEDGE_HOT"), 2 },
579 { _T("TABITEMLEFTEDGE_SELECTED"), 3 },
580 { _T("TABITEMLEFTEDGE_DISABLED"), 4 },
581 { _T("TABITEMLEFTEDGE_FOCUSED"), 5 },
582
583 { _T("TABITEMRIGHTEDGE_NORMAL"), 1 },
584 { _T("TABITEMRIGHTEDGE_HOT"), 2 },
585 { _T("TABITEMRIGHTEDGE_SELECTED"), 3 },
586 { _T("TABITEMRIGHTEDGE_DISABLED"), 4 },
587 { _T("TABITEMRIGHTEDGE_FOCUSED"), 5 },
588
589 { _T("TABITEMBOTHEDGES_NORMAL"), 1 },
590 { _T("TABITEMBOTHEDGES_HOT"), 2 },
591 { _T("TABITEMBOTHEDGES_SELECTED"), 3 },
592 { _T("TABITEMBOTHEDGES_DISABLED"), 4 },
593 { _T("TABITEMBOTHEDGES_FOCUSED"), 5 },
594
595 { _T("TOPTABITEM_NORMAL"), 1 },
596 { _T("TOPTABITEM_HOT"), 2 },
597 { _T("TOPTABITEM_SELECTED"), 3 },
598 { _T("TOPTABITEM_DISABLED"), 4 },
599 { _T("TOPTABITEM_FOCUSED"), 5 },
600
601 { _T("TOPTABITEMLEFTEDGE_NORMAL"), 1 },
602 { _T("TOPTABITEMLEFTEDGE_HOT"), 2 },
603 { _T("TOPTABITEMLEFTEDGE_SELECTED"), 3 },
604 { _T("TOPTABITEMLEFTEDGE_DISABLED"), 4 },
605 { _T("TOPTABITEMLEFTEDGE_FOCUSED"), 5 },
606
607 { _T("TOPTABITEMRIGHTEDGE_NORMAL"), 1 },
608 { _T("TOPTABITEMRIGHTEDGE_HOT"), 2 },
609 { _T("TOPTABITEMRIGHTEDGE_SELECTED"), 3 },
610 { _T("TOPTABITEMRIGHTEDGE_DISABLED"), 4 },
611 { _T("TOPTABITEMRIGHTEDGE_FOCUSED"), 5 },
612
613 { _T("TOPTABITEMBOTHEDGES_NORMAL"), 1 },
614 { _T("TOPTABITEMBOTHEDGES_HOT"), 2 },
615 { _T("TOPTABITEMBOTHEDGES_SELECTED"), 3 },
616 { _T("TOPTABITEMBOTHEDGES_DISABLED"), 4 },
617 { _T("TOPTABITEMBOTHEDGES_FOCUSED"), 5 },
618
619 //---------------------------------------------------------------------------------------
620 // "Trackbar" Parts & States
621 //---------------------------------------------------------------------------------------
622
623 { _T("TRACKBAR_NORMAL"), 1 },
624
625 { _T("TRACK_NORMAL"), 1 },
626
627 { _T("TRACKVERT_NORMAL"), 1 },
628
629 { _T("THUMB_NORMAL"), 1 },
630 { _T("THUMB_HOT"), 2 },
631 { _T("THUMB_PRESSED"), 3 },
632 { _T("THUMB_FOCUSED"), 4 },
633 { _T("THUMB_DISABLED"), 5 },
634
635 { _T("THUMBBOTTOM_NORMAL"), 1 },
636 { _T("THUMBBOTTOM_HOT"), 2 },
637 { _T("THUMBBOTTOM_PRESSED"), 3 },
638 { _T("THUMBBOTTOM_FOCUSED"), 4 },
639 { _T("THUMBBOTTOM_DISABLED"), 5 },
640
641 { _T("THUMBTOP_NORMAL"), 1 },
642 { _T("THUMBTOP_HOT"), 2 },
643 { _T("THUMBTOP_PRESSED"), 3 },
644 { _T("THUMBTOP_FOCUSED"), 4 },
645 { _T("THUMBTOP_DISABLED"), 5 },
646
647 { _T("THUMBVERT_NORMAL"), 1 },
648 { _T("THUMBVERT_HOT"), 2 },
649 { _T("THUMBVERT_PRESSED"), 3 },
650 { _T("THUMBVERT_FOCUSED"), 4 },
651 { _T("THUMBVERT_DISABLED"), 5 },
652
653 { _T("THUMBLEFT_NORMAL"), 1 },
654 { _T("THUMBLEFT_HOT"), 2 },
655 { _T("THUMBLEFT_PRESSED"), 3 },
656 { _T("THUMBLEFT_FOCUSED"), 4 },
657 { _T("THUMBLEFT_DISABLED"), 5 },
658
659 { _T("THUMBRIGHT_NORMAL"), 1 },
660 { _T("THUMBRIGHT_HOT"), 2 },
661 { _T("THUMBRIGHT_PRESSED"), 3 },
662 { _T("THUMBRIGHT_FOCUSED"), 4 },
663 { _T("THUMBRIGHT_DISABLED"), 5 },
664
665 { _T("TICS_NORMAL"), 1 },
666
667 { _T("TICSVERT_NORMAL"), 1 },
668
669 //---------------------------------------------------------------------------------------
670 // "Tooltips" Parts & States
671 //---------------------------------------------------------------------------------------
672
673 { _T("CLOSE_NORMAL"), 1 },
674 { _T("CLOSE_HOT"), 2 },
675 { _T("CLOSE_PRESSED"), 3 },
676
677 { _T("STANDARD_NORMAL"), 1 },
678 { _T("STANDARD_LINK"), 2 },
679
680 { _T("BALLOON_NORMAL"), 1 },
681 { _T("BALLOON_LINK"), 2 },
682
683 //---------------------------------------------------------------------------------------
684 // "TreeView" Parts & States
685 //---------------------------------------------------------------------------------------
686
687 { _T("TREEITEM_NORMAL"), 1 },
688 { _T("TREEITEM_HOT"), 2 },
689 { _T("TREEITEM_SELECTED"), 3 },
690 { _T("TREEITEM_DISABLED"), 4 },
691 { _T("TREEITEM_SELECTEDNOTFOCUS"), 5 },
692 { _T("TREEITEM_HOTSELECTED"), 6 },
693
694 { _T("GLYPH_CLOSED"), 1 },
695 { _T("GLYPH_OPENED"), 2 },
696
697 { _T("HGLYPH_CLOSED"), 1 },
698 { _T("HGLYPH_OPENED"), 2 },
699
700 //---------------------------------------------------------------------------------------
701 // "Spin" Parts & States
702 //---------------------------------------------------------------------------------------
703
704 { _T("UP_NORMAL"), 1 },
705 { _T("UP_HOT"), 2 },
706 { _T("UP_PRESSED"), 3 },
707 { _T("UP_DISABLED"), 4 },
708
709 { _T("DOWN_NORMAL"), 1 },
710 { _T("DOWN_HOT"), 2 },
711 { _T("DOWN_PRESSED"), 3 },
712 { _T("DOWN_DISABLED"), 4 },
713
714 { _T("UPHORZ_NORMAL"), 1 },
715 { _T("UPHORZ_HOT"), 2 },
716 { _T("UPHORZ_PRESSED"), 3 },
717 { _T("UPHORZ_DISABLED"), 4 },
718
719 { _T("DOWNHORZ_NORMAL"), 1 },
720 { _T("DOWNHORZ_HOT"), 2 },
721 { _T("DOWNHORZ_PRESSED"), 3 },
722 { _T("DOWNHORZ_DISABLED"), 4 },
723
724 //---------------------------------------------------------------------------------------
725 // "Scrollbar" Parts & States
726 //---------------------------------------------------------------------------------------
727
728 { _T("ARROWBTN_UPNORMAL"), 1 },
729 { _T("ARROWBTN_UPHOT"), 2 },
730 { _T("ARROWBTN_UPPRESSED"), 3 },
731 { _T("ARROWBTN_UPDISABLED"), 4 },
732 { _T("ARROWBTN_DOWNNORMAL"), 5 },
733 { _T("ARROWBTN_DOWNHOT"), 6 },
734 { _T("ARROWBTN_DOWNPRESSED"), 7 },
735 { _T("ARROWBTN_DOWNDISABLED"), 8 },
736 { _T("ARROWBTN_LEFTNORMAL"), 9 },
737 { _T("ARROWBTN_LEFTHOT"), 10 },
738 { _T("ARROWBTN_LEFTPRESSED"), 11 },
739 { _T("ARROWBTN_LEFTDISABLED"), 12 },
740 { _T("ARROWBTN_RIGHTNORMAL"), 13 },
741 { _T("ARROWBTN_RIGHTHOT"), 14 },
742 { _T("ARROWBTN_RIGHTPRESSED"), 15 },
743 { _T("ARROWBTN_RIGHTDISABLED"), 16 },
744
745 { _T("SCROLLBAR_NORMAL"), 1 },
746 { _T("SCROLLBAR_HOT"), 2 },
747 { _T("SCROLLBAR_PRESSED"), 3 },
748 { _T("SCROLLBAR_DISABLED"), 4 },
749 { _T("SCROLLBAR_ACTIVE"), 5 },
750
751 { _T("SIZEBOX_RIGHTALIGN"), 1 },
752 { _T("SIZEBOX_LEFTALIGN"), 2 },
753
754 //---------------------------------------------------------------------------------------
755 // "Edit" Parts & States
756 //---------------------------------------------------------------------------------------
757
758 { _T("EDITTEXT_NORMAL"), 1 },
759 { _T("EDITTEXT_HOT"), 2 },
760 { _T("EDITTEXT_SELECTED"), 3 },
761 { _T("EDITTEXT_DISABLED"), 4 },
762 { _T("EDITTEXT_FOCUSED"), 5 },
763 { _T("EDITTEXT_READONLY"), 6 },
764 { _T("EDITTEXT_ASSIST"), 7 },
765
766 //---------------------------------------------------------------------------------------
767 // "ComboBox" Parts & States
768 //---------------------------------------------------------------------------------------
769
770 { _T("COMBOBOX_NORMAL"), 1 },
771 { _T("COMBOBOX_HOT"), 2 },
772 { _T("COMBOBOX_PRESSED"), 3 },
773 { _T("COMBOBOX_DISABLED"), 4 },
774
775 //---------------------------------------------------------------------------------------
776 // "Taskbar Clock" Parts & States
777 //---------------------------------------------------------------------------------------
778
779 { _T("CLOCK_NORMAL"), 1 },
780
781 //---------------------------------------------------------------------------------------
782 // "StartPanel" Parts & States
783 //---------------------------------------------------------------------------------------
784
785 { _T("MOREPROGRAMSARROW_NORMAL"), 1 },
786 { _T("MOREPROGRAMSARROW_HOT"), 2 },
787 { _T("MOREPROGRAMSARROW_PRESSED"), 3 },
788
789 { _T("LOGOFFBUTTONS_NORMAL"), 1 },
790 { _T("LOGOFFBUTTONS_HOT"), 2 },
791 { _T("LOGOFFBUTTONS_PRESSED"), 3 },
792
793 //---------------------------------------------------------------------------------------
794 // "ExplorerBar" Parts & States
795 //---------------------------------------------------------------------------------------
796
797 { _T("HEADERCLOSE_NORMAL"), 1 },
798 { _T("HEADERCLOSE_HOT"), 2 },
799 { _T("HEADERCLOSE_PRESSED"), 3 },
800
801 { _T("HEADERPIN_NORMAL"), 1 },
802 { _T("HEADERPIN_HOT"), 2 },
803 { _T("HEADERPIN_PRESSED"), 3 },
804 { _T("HEADERPIN_SELECTEDNORMAL"), 4 },
805 { _T("HEADERPIN_SELECTEDHOT"), 5 },
806 { _T("HEADERPIN_SELECTEDPRESSED"), 6 },
807
808 { _T("IEBARMENU_NORMAL"), 1 },
809 { _T("IEBARMENU_HOT"), 2 },
810 { _T("IEBARMENU_PRESSED"), 3 },
811
812 { _T("NORMALGROUPCOLLAPSE_NORMAL"), 1 },
813 { _T("NORMALGROUPCOLLAPSE_HOT"), 2 },
814 { _T("NORMALGROUPCOLLAPSE_PRESSED"), 3 },
815
816 { _T("NORMALGROUPEXPAND_NORMAL"), 1 },
817 { _T("NORMALGROUPEXPAND_HOT"), 2 },
818 { _T("NORMALGROUPEXPAND_PRESSED"), 3 },
819
820 { _T("SPECIALGROUPCOLLAPSE_NORMAL"), 1 },
821 { _T("SPECIALGROUPCOLLAPSE_HOT"), 2 },
822 { _T("SPECIALGROUPCOLLAPSE_PRESSED"), 3 },
823
824 { _T("SPECIALGROUPEXPAND_NORMAL"), 1 },
825 { _T("SPECIALGROUPEXPAND_HOT"), 2 },
826 { _T("SPECIALGROUPEXPAND_PRESSED"), 3 },
827
828 //---------------------------------------------------------------------------------------
829 // "TaskBand" Parts & States
830 //---------------------------------------------------------------------------------------
831
832 { _T("MENUBAND_NORMAL"), 1 },
833 { _T("MENUBAND_HOT"), 2 },
834 { _T("MENUBAND_PRESSED"), 3 },
835 { _T("MENUBAND_DISABLED"), 4 },
836 { _T("MENUBAND_CHECKED"), 5 },
837 { _T("MENUBAND_HOTCHECKED"), 6 },
838
839 { 0, 0 }
840
841 // clang-format on
842};
843
845// Property Codes. The actual number goes without the last digit.
846// The last digit is a value from XTPSkinManagerProperty
848
849# define PROPERTY_N(n, t) ((n)*10 + (t))
850
851# ifdef TM_PROP
852# undef TM_PROP
853# endif
854
855# ifdef UNICODE
856# define TM_PROP(val, prefix, name, primval) \
857 { L"P_" L#name, PROPERTY_N(val, XTP_SKINPROPERTY_##primval) },
858# else
859# define TM_PROP(val, prefix, name, primval) \
860 { "P_" #name, PROPERTY_N(val, XTP_SKINPROPERTY_##primval) },
861# endif
862
863static const struct TMS_SCHEMA_ENTRY gSchemaPropertyCodes[] = {
864 // clang-format off
865
866 // here goes blind copy from 'Tmschema.h'
867
868 //---- primitive types ----
869 TM_PROP(201, TMT, STRING, STRING)
870 TM_PROP(202, TMT, INT, INT)
871 TM_PROP(203, TMT, BOOL, BOOL)
872 TM_PROP(204, TMT, COLOR, COLOR)
873 TM_PROP(205, TMT, MARGINS, MARGINS)
874 TM_PROP(206, TMT, FILENAME, FILENAME)
875 TM_PROP(207, TMT, SIZE, SIZE)
876 TM_PROP(208, TMT, POSITION, POSITION)
877 TM_PROP(209, TMT, RECT, RECT)
878 TM_PROP(210, TMT, FONT, FONT)
879 TM_PROP(211, TMT, INTLIST, INTLIST)
880
881 //---- special misc. properties ----
882 TM_PROP(401, TMT, COLORSCHEMES, STRING)
883 TM_PROP(402, TMT, SIZES, STRING)
884 TM_PROP(403, TMT, CHARSET, INT)
885
886 //---- [documentation] properties ----
887
888 TM_PROP(601, TMT, DISPLAYNAME, STRING)
889 TM_PROP(602, TMT, TOOLTIP, STRING)
890 TM_PROP(603, TMT, COMPANY, STRING)
891 TM_PROP(604, TMT, AUTHOR, STRING)
892 TM_PROP(605, TMT, COPYRIGHT, STRING)
893 TM_PROP(606, TMT, URL, STRING)
894 TM_PROP(607, TMT, VERSION, STRING)
895 TM_PROP(608, TMT, DESCRIPTION, STRING)
896
897 //---- theme metrics: fonts ----
898
899 TM_PROP(801, TMT, CAPTIONFONT, FONT)
900 TM_PROP(802, TMT, SMALLCAPTIONFONT, FONT)
901 TM_PROP(803, TMT, MENUFONT, FONT)
902 TM_PROP(804, TMT, STATUSFONT, FONT)
903 TM_PROP(805, TMT, MSGBOXFONT, FONT)
904 TM_PROP(806, TMT, ICONTITLEFONT, FONT)
905
906 //---- theme metrics: bools ----
907
908 TM_PROP(1001, TMT, FLATMENUS, BOOL)
909
910 //---- theme metrics: sizes ----
911
912 TM_PROP(1201, TMT, SIZINGBORDERWIDTH, SIZE)
913 TM_PROP(1202, TMT, SCROLLBARWIDTH, SIZE)
914 TM_PROP(1203, TMT, SCROLLBARHEIGHT, SIZE)
915 TM_PROP(1204, TMT, CAPTIONBARWIDTH, SIZE)
916 TM_PROP(1205, TMT, CAPTIONBARHEIGHT, SIZE)
917 TM_PROP(1206, TMT, SMCAPTIONBARWIDTH, SIZE)
918 TM_PROP(1207, TMT, SMCAPTIONBARHEIGHT, SIZE)
919 TM_PROP(1208, TMT, MENUBARWIDTH, SIZE)
920 TM_PROP(1209, TMT, MENUBARHEIGHT, SIZE)
921
922 //---- theme metrics: ints ----
923
924 TM_PROP(1301, TMT, MINCOLORDEPTH, INT)
925
926 //---- theme metrics: strings ----
927
928 TM_PROP(1401, TMT, CSSNAME, STRING)
929 TM_PROP(1402, TMT, XMLNAME, STRING)
930
931 //---- theme metrics: colors ----
932
933 TM_PROP(1601, TMT, SCROLLBAR, COLOR)
934 TM_PROP(1602, TMT, BACKGROUND, COLOR)
935 TM_PROP(1603, TMT, ACTIVECAPTION, COLOR)
936 TM_PROP(1604, TMT, INACTIVECAPTION, COLOR)
937 TM_PROP(1605, TMT, MENU, COLOR)
938 TM_PROP(1606, TMT, WINDOW, COLOR)
939 TM_PROP(1607, TMT, WINDOWFRAME, COLOR)
940 TM_PROP(1608, TMT, MENUTEXT, COLOR)
941 TM_PROP(1609, TMT, WINDOWTEXT, COLOR)
942 TM_PROP(1610, TMT, CAPTIONTEXT, COLOR)
943 TM_PROP(1611, TMT, ACTIVEBORDER, COLOR)
944 TM_PROP(1612, TMT, INACTIVEBORDER, COLOR)
945 TM_PROP(1613, TMT, APPWORKSPACE, COLOR)
946 TM_PROP(1614, TMT, HIGHLIGHT, COLOR)
947 TM_PROP(1615, TMT, HIGHLIGHTTEXT, COLOR)
948 TM_PROP(1616, TMT, BTNFACE, COLOR)
949 TM_PROP(1617, TMT, BTNSHADOW, COLOR)
950 TM_PROP(1618, TMT, GRAYTEXT, COLOR)
951 TM_PROP(1619, TMT, BTNTEXT, COLOR)
952 TM_PROP(1620, TMT, INACTIVECAPTIONTEXT, COLOR)
953 TM_PROP(1621, TMT, BTNHIGHLIGHT, COLOR)
954 TM_PROP(1622, TMT, DKSHADOW3D, COLOR)
955 TM_PROP(1623, TMT, LIGHT3D, COLOR)
956 TM_PROP(1624, TMT, INFOTEXT, COLOR)
957 TM_PROP(1625, TMT, INFOBK, COLOR)
958 TM_PROP(1626, TMT, BUTTONALTERNATEFACE, COLOR)
959 TM_PROP(1627, TMT, HOTTRACKING, COLOR)
960 TM_PROP(1628, TMT, GRADIENTACTIVECAPTION, COLOR)
961 TM_PROP(1629, TMT, GRADIENTINACTIVECAPTION, COLOR)
962 TM_PROP(1630, TMT, MENUHILIGHT, COLOR)
963 TM_PROP(1631, TMT, MENUBAR, COLOR)
964
965 //---- hue substitutions ----
966 TM_PROP(1801, TMT, FROMHUE1, INT)
967 TM_PROP(1802, TMT, FROMHUE2, INT)
968 TM_PROP(1803, TMT, FROMHUE3, INT)
969 TM_PROP(1804, TMT, FROMHUE4, INT)
970 TM_PROP(1805, TMT, FROMHUE5, INT)
971 TM_PROP(1806, TMT, TOHUE1, INT)
972 TM_PROP(1807, TMT, TOHUE2, INT)
973 TM_PROP(1808, TMT, TOHUE3, INT)
974 TM_PROP(1809, TMT, TOHUE4, INT)
975 TM_PROP(1810, TMT, TOHUE5, INT)
976
977 //---- color substitutions ----
978 TM_PROP(2001, TMT, FROMCOLOR1, COLOR)
979 TM_PROP(2002, TMT, FROMCOLOR2, COLOR)
980 TM_PROP(2003, TMT, FROMCOLOR3, COLOR)
981 TM_PROP(2004, TMT, FROMCOLOR4, COLOR)
982 TM_PROP(2005, TMT, FROMCOLOR5, COLOR)
983 TM_PROP(2006, TMT, TOCOLOR1, COLOR)
984 TM_PROP(2007, TMT, TOCOLOR2, COLOR)
985 TM_PROP(2008, TMT, TOCOLOR3, COLOR)
986 TM_PROP(2009, TMT, TOCOLOR4, COLOR)
987 TM_PROP(2010, TMT, TOCOLOR5, COLOR)
988
989 //---- rendering BOOL properties ----
990 TM_PROP(2201, TMT, TRANSPARENT, BOOL) // image has transparent areas (see TransparentColor)
991 TM_PROP(2202, TMT, AUTOSIZE, BOOL) // if TRUE, nonclient caption width varies with text extent
992 TM_PROP(2203, TMT, BORDERONLY, BOOL) // only draw the border area of the image
993 TM_PROP(2204, TMT, COMPOSITED, BOOL) // control will handle the composite drawing
994 TM_PROP(2205, TMT, BGFILL, BOOL) // if TRUE, TRUESIZE images should be drawn on bg fill
995 TM_PROP(2206, TMT, GLYPHTRANSPARENT, BOOL) // glyph has transparent areas (see GlyphTransparentColor)
996 TM_PROP(2207, TMT, GLYPHONLY, BOOL) // only draw glyph (not background)
997 TM_PROP(2208, TMT, ALWAYSSHOWSIZINGBAR, BOOL)
998 TM_PROP(2209, TMT, MIRRORIMAGE, BOOL) // default=TRUE means image gets mirrored in RTL (Mirror) windows
999 TM_PROP(2210, TMT, UNIFORMSIZING, BOOL) // if TRUE, height & width must be uniformly sized
1000 TM_PROP(2211, TMT, INTEGRALSIZING, BOOL) // for TRUESIZE and Border sizing; if TRUE, factor must be integer
1001 TM_PROP(2212, TMT, SOURCEGROW, BOOL) // if TRUE, will scale up src image when needed
1002 TM_PROP(2213, TMT, SOURCESHRINK, BOOL) // if TRUE, will scale down src image when needed
1003
1004 //---- rendering INT properties ----
1005 TM_PROP(2401, TMT, IMAGECOUNT, INT) // the number of state images in an imagefile
1006 TM_PROP(2402, TMT, ALPHALEVEL, INT) // (0-255) alpha value for an icon (DrawThemeIcon part)
1007 TM_PROP(2403, TMT, BORDERSIZE, INT) // the size of the border line for bgtype=BorderFill
1008 TM_PROP(2404, TMT, ROUNDCORNERWIDTH, INT) // (0-100) % of roundness for rounded rects
1009 TM_PROP(2405, TMT, ROUNDCORNERHEIGHT, INT) // (0-100) % of roundness for rounded rects
1010 TM_PROP(2406, TMT, GRADIENTRATIO1, INT) // (0-255) - amt of gradient color 1 to use (all must total=255)
1011 TM_PROP(2407, TMT, GRADIENTRATIO2, INT) // (0-255) - amt of gradient color 2 to use (all must total=255)
1012 TM_PROP(2408, TMT, GRADIENTRATIO3, INT) // (0-255) - amt of gradient color 3 to use (all must total = 255)
1013 TM_PROP(2409, TMT, GRADIENTRATIO4, INT) // (0-255) - amt of gradient color 4 to use (all must total=255)
1014 TM_PROP(2410, TMT, GRADIENTRATIO5, INT) // (0-255) - amt of gradient color 5 to use (all must total=255)
1015 TM_PROP(2411, TMT, PROGRESSCHUNKSIZE, INT) // size of progress control chunks
1016 TM_PROP(2412, TMT, PROGRESSSPACESIZE, INT) // size of progress control spaces
1017 TM_PROP(2413, TMT, SATURATION, INT) // (0-255) amt of saturation for DrawThemeIcon() part
1018 TM_PROP(2414, TMT, TEXTBORDERSIZE, INT) // size of border around text chars
1019 TM_PROP(2415, TMT, ALPHATHRESHOLD, INT) // (0-255) the min. alpha value of a pixel that is solid
1020 TM_PROP(2416, TMT, WIDTH, SIZE) // custom window prop: size of part (min. window)
1021 TM_PROP(2417, TMT, HEIGHT, SIZE) // custom window prop: size of part (min. window)
1022 TM_PROP(2418, TMT, GLYPHINDEX, INT) // for font-based glyphs, the char index into the font
1023 TM_PROP(2419, TMT, TRUESIZESTRETCHMARK, INT) // stretch TrueSize image when target exceeds source by this percent
1024 TM_PROP(2420, TMT, MINDPI1, INT) // min DPI ImageFile1 was designed for
1025 TM_PROP(2421, TMT, MINDPI2, INT) // min DPI ImageFile1 was designed for
1026 TM_PROP(2422, TMT, MINDPI3, INT) // min DPI ImageFile1 was designed for
1027 TM_PROP(2423, TMT, MINDPI4, INT) // min DPI ImageFile1 was designed for
1028 TM_PROP(2424, TMT, MINDPI5, INT) // min DPI ImageFile1 was designed for
1029
1030 //---- rendering FONT properties ----
1031 TM_PROP(2601, TMT, GLYPHFONT, FONT) // the font that the glyph is drawn with
1032
1033 //---- rendering INTLIST properties ----
1034 // start with 2801
1035 // (from smallest to largest)
1036 //---- rendering FILENAME properties ----
1037 TM_PROP(3001, TMT, IMAGEFILE, FILENAME) // the filename of the image (or basename, for mult. images)
1038 TM_PROP(3002, TMT, IMAGEFILE1, FILENAME) // multiresolution image file
1039 TM_PROP(3003, TMT, IMAGEFILE2, FILENAME) // multiresolution image file
1040 TM_PROP(3004, TMT, IMAGEFILE3, FILENAME) // multiresolution image file
1041 TM_PROP(3005, TMT, IMAGEFILE4, FILENAME) // multiresolution image file
1042 TM_PROP(3006, TMT, IMAGEFILE5, FILENAME) // multiresolution image file
1043 TM_PROP(3007, TMT, STOCKIMAGEFILE, FILENAME) // These are the only images that you can call GetThemeBitmap on
1044 TM_PROP(3008, TMT, GLYPHIMAGEFILE, FILENAME) // the filename for the glyph image
1045
1046 //---- rendering STRING properties ----
1047 TM_PROP(3201, TMT, TEXT, STRING)
1048
1049 //---- rendering POSITION (x and y values) properties ----
1050 TM_PROP(3401, TMT, OFFSET, POSITION) // for window part layout
1051 TM_PROP(3402, TMT, TEXTSHADOWOFFSET, POSITION) // where char shadows are drawn, relative to orig. chars
1052 TM_PROP(3403, TMT, MINSIZE, POSITION) // min dest rect than ImageFile was designed for
1053 TM_PROP(3404, TMT, MINSIZE1, POSITION) // min dest rect than ImageFile1 was designed for
1054 TM_PROP(3405, TMT, MINSIZE2, POSITION) // min dest rect than ImageFile2 was designed for
1055 TM_PROP(3406, TMT, MINSIZE3, POSITION) // min dest rect than ImageFile3 was designed for
1056 TM_PROP(3407, TMT, MINSIZE4, POSITION) // min dest rect than ImageFile4 was designed for
1057 TM_PROP(3408, TMT, MINSIZE5, POSITION) // min dest rect than ImageFile5 was designed for
1058 TM_PROP(3409, TMT, NORMALSIZE, POSITION) // size of dest rect that exactly source
1059
1060 //---- rendering MARGIN properties ----
1061 TM_PROP(3601, TMT, SIZINGMARGINS, MARGINS) // margins used for 9-grid sizing
1062 TM_PROP(3602, TMT, CONTENTMARGINS, MARGINS) // margins that define where content can be placed
1063 TM_PROP(3603, TMT, CAPTIONMARGINS, MARGINS) // margins that define where caption text can be placed
1064
1065 //---- rendering COLOR properties ----
1066 TM_PROP(3801, TMT, BORDERCOLOR, COLOR) // color of borders for BorderFill
1067 TM_PROP(3802, TMT, FILLCOLOR, COLOR) // color of bg fill
1068 TM_PROP(3803, TMT, TEXTCOLOR, COLOR) // color text is drawn in
1069 TM_PROP(3804, TMT, EDGELIGHTCOLOR, COLOR) // edge color
1070 TM_PROP(3805, TMT, EDGEHIGHLIGHTCOLOR, COLOR) // edge color
1071 TM_PROP(3806, TMT, EDGESHADOWCOLOR, COLOR) // edge color
1072 TM_PROP(3807, TMT, EDGEDKSHADOWCOLOR, COLOR) // edge color
1073 TM_PROP(3808, TMT, EDGEFILLCOLOR, COLOR) // edge color
1074 TM_PROP(3809, TMT, TRANSPARENTCOLOR, COLOR) // color of pixels that are treated as transparent (not drawn)
1075 TM_PROP(3810, TMT, GRADIENTCOLOR1, COLOR) // first color in gradient
1076 TM_PROP(3811, TMT, GRADIENTCOLOR2, COLOR) // second color in gradient
1077 TM_PROP(3812, TMT, GRADIENTCOLOR3, COLOR) // third color in gradient
1078 TM_PROP(3813, TMT, GRADIENTCOLOR4, COLOR) // forth color in gradient
1079 TM_PROP(3814, TMT, GRADIENTCOLOR5, COLOR) // fifth color in gradient
1080 TM_PROP(3815, TMT, SHADOWCOLOR, COLOR) // color of text shadow
1081 TM_PROP(3816, TMT, GLOWCOLOR, COLOR) // color of glow produced by DrawThemeIcon
1082 TM_PROP(3817, TMT, TEXTBORDERCOLOR, COLOR) // color of text border
1083 TM_PROP(3818, TMT, TEXTSHADOWCOLOR, COLOR) // color of text shadow
1084 TM_PROP(3819, TMT, GLYPHTEXTCOLOR, COLOR) // color that font-based glyph is drawn with
1085 TM_PROP(3820, TMT, GLYPHTRANSPARENTCOLOR, COLOR) // color of transparent pixels in GlyphImageFile
1086 TM_PROP(3821, TMT, FILLCOLORHINT, COLOR) // hint about fill color used (for custom controls)
1087 TM_PROP(3822, TMT, BORDERCOLORHINT, COLOR) // hint about border color used (for custom controls)
1088 TM_PROP(3823, TMT, ACCENTCOLORHINT, COLOR) // hint about accent color used (for custom controls)
1089
1090 //---- rendering enum properties (must be declared in TM_ENUM section above) ----
1091 TM_PROP(4001, TMT, BGTYPE, ENUM) // basic drawing type for each part
1092 TM_PROP(4002, TMT, BORDERTYPE, ENUM) // type of border for BorderFill parts
1093 TM_PROP(4003, TMT, FILLTYPE, ENUM) // fill shape for BorderFill parts
1094 TM_PROP(4004, TMT, SIZINGTYPE, ENUM) // how to size ImageFile parts
1095 TM_PROP(4005, TMT, HALIGN, ENUM) // horizontal alignment for TRUESIZE parts & glyphs
1096 TM_PROP(4006, TMT, CONTENTALIGNMENT, ENUM) // custom window prop: how text is aligned in caption
1097 TM_PROP(4007, TMT, VALIGN, ENUM) // horizontal alignment for TRUESIZE parts & glyphs
1098 TM_PROP(4008, TMT, OFFSETTYPE, ENUM) // how window part should be placed
1099 TM_PROP(4009, TMT, ICONEFFECT, ENUM) // type of effect to use with DrawThemeIcon
1100 TM_PROP(4010, TMT, TEXTSHADOWTYPE, ENUM) // type of shadow to draw with text
1101 TM_PROP(4011, TMT, IMAGELAYOUT, ENUM) // how multiple images are arranged (horz. or vert.)
1102 TM_PROP(4012, TMT, GLYPHTYPE, ENUM) // controls type of glyph in imagefile objects
1103 TM_PROP(4013, TMT, IMAGESELECTTYPE, ENUM) // controls when to select from IMAGEFILE1...IMAGEFILE5
1104 TM_PROP(4014, TMT, GLYPHFONTSIZINGTYPE, ENUM) // controls when to select a bigger/small glyph font size
1105 TM_PROP(4015, TMT, TRUESIZESCALINGTYPE, ENUM) // controls how TrueSize image is scaled
1106
1107 //---- custom properties (used only by controls/shell) ----
1108 TM_PROP(5001, TMT, USERPICTURE, BOOL) TM_PROP(5002, TMT, DEFAULTPANESIZE, RECT)
1109 TM_PROP(5003, TMT, BLENDCOLOR, COLOR)
1110
1111 { 0 },
1112 { 0 }
1113
1114 // clang-format on
1115};
1116
1117// restore old value of TM_PROP
1118# undef TM_PROP
1119
1120# pragma warning(disable : 4996)
1121
1122class CXTPSkinManagerSchemaCodeManager : public CXTPSingleton<CXTPSkinManagerSchemaCodeManager>
1123{
1124 friend CXTPSingleton<CXTPSkinManagerSchemaCodeManager>;
1125
1126 CMap<CString, LPCTSTR, int, int> m_cache;
1127 CMap<CString, LPCTSTR, int, int> m_cacheIgnored;
1128
1129 CXTPSkinManagerSchemaCodeManager()
1130 {
1131 CacheSchemaCodes(gSchemaClassAndPartsCodes);
1132 CacheSchemaCodes(gSchemaEnumCodes);
1133 CacheSchemaCodes(gSchemaStateCodes);
1134 CacheSchemaCodes(gSchemaPropertyCodes);
1135 }
1136
1137 void CacheSchemaCodes(const struct TMS_SCHEMA_ENTRY* arSchemaArray)
1138 {
1139 int k = 0;
1140 int nValue = -1;
1141 LPCTSTR name = arSchemaArray[k].str;
1142
1143 while (name)
1144 {
1145 _ASSERTE(!m_cache.Lookup(name, nValue)); // keys should be unique
1146 UNUSED(nValue);
1147
1148 m_cache[arSchemaArray[k].str] = arSchemaArray[k].n;
1149 name = arSchemaArray[++k].str;
1150 }
1151 }
1152
1153 static void AFX_CDECL CacheIgnored(TCHAR* szHashName)
1154 {
1155 _ASSERTE(szHashName);
1156 int nValue = -1;
1157 if (Instance().m_cacheIgnored.GetCount() < 500
1158 && !Instance().m_cacheIgnored.Lookup(szHashName, nValue))
1159 {
1160 Instance().m_cacheIgnored[szHashName] = -1;
1161 }
1162 }
1163
1164public:
1165 static int AFX_CDECL MapKey(const TMS_SCHEMA_ENTRY* pArray, LPCTSTR key, LPCTSTR prefix = NULL)
1166 {
1167 _ASSERTE(NULL != pArray);
1168 _ASSERTE(NULL != key);
1169
1170 int nValue = -1;
1171
1172 TCHAR szHashName[255];
1173
1174 if (prefix)
1175 {
1176 _tcscpy(szHashName, prefix);
1177 _tcscat(szHashName, key);
1178 }
1179 else
1180 {
1181 _tcscpy(szHashName, key);
1182 }
1183
1184 ::EnterCriticalSection(&GetInstanceAccess());
1185
1186 if (!Instance().m_cacheIgnored.Lookup(szHashName, nValue)
1187 && !Instance().m_cache.Lookup(szHashName, nValue))
1188 {
1189 int i = 0;
1190 LPCTSTR name = pArray[i].str;
1191 while (name)
1192 {
1193 if (_tcsicmp(name, szHashName) == 0)
1194 {
1195 Instance().m_cache[szHashName] = pArray[i].n;
1196 nValue = pArray[i].n;
1197 break;
1198 }
1199
1200 name = pArray[++i].str;
1201 }
1202
1203 if (nValue == -1)
1204 CacheIgnored(szHashName);
1205 }
1206
1207 ::LeaveCriticalSection(&GetInstanceAccess());
1208
1209 return nValue;
1210 }
1211
1212 static int AFX_CDECL MapKey2(const TMS_SCHEMA_ENTRY* pArray, LPCTSTR key, LPCTSTR key2)
1213 {
1214 _ASSERTE(NULL != key);
1215 _ASSERTE(NULL != key2);
1216
1217 TCHAR szContencanated[255];
1218 _tcscpy(szContencanated, key);
1219 _tcscat(szContencanated, _T("_"));
1220 _tcscat(szContencanated, key2);
1221
1222 return MapKey(pArray, szContencanated);
1223 }
1224};
1225
1226# pragma warning(default : 4996)
1227
1228# define GET_CLASS_CODE(cls) \
1229 CXTPSkinManagerSchemaCodeManager::MapKey(gSchemaClassAndPartsCodes, cls)
1230# define GET_ENUM_CODE(prop, val) \
1231 CXTPSkinManagerSchemaCodeManager::MapKey2(gSchemaEnumCodes, prop, val)
1232# define GET_CLASSPART_CODE(cls, part) \
1233 CXTPSkinManagerSchemaCodeManager::MapKey2(gSchemaClassAndPartsCodes, cls, part)
1234# define GET_STATE_CODE(part, state) \
1235 CXTPSkinManagerSchemaCodeManager::MapKey2(gSchemaStateCodes, part, state)
1236# define GET_PROPERTY_CODE(prop) \
1237 CXTPSkinManagerSchemaCodeManager::MapKey(gSchemaPropertyCodes, prop, _T("P_"))
1238
1239# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
1241#endif // __XTPSKINMANAGERSCHEMACODES_H__
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPSingleton
Implements Singleton design pattern.
Definition XTPSingleton.h:215
CXTPSingleton< CXTPSkinManagerSchemaCodeManager >::Instance
static CXTPSkinManagerSchemaCodeManager &AFX_CDECL Instance()
Definition XTPSingleton.h:224


Toolkit Pro: Member List

CXTPGridColumnOrder Member List

This is the complete list of members for CXTPGridColumnOrder, including all inherited members.

Add(CXTPGridColumn *pColumn) | CXTPGridColumnOrder |
Add(CXTPGridColumn *pColumn, BOOL bSortIncreasing) | CXTPGridColumnOrder |
Clear() | CXTPGridColumnOrder |
CXTPCmdTarget() | CXTPCmdTarget |
CXTPGridColumnOrder(CXTPGridColumns *pColumns) | CXTPGridColumnOrder |
DoPropExchange(CXTPPropExchange *pPX) | CXTPGridColumnOrder | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAt(int nIndex) | CXTPGridColumnOrder |
GetCount() const | CXTPGridColumnOrder |
IndexOf(const CXTPGridColumn *pColumn) | CXTPGridColumnOrder |
InsertAt(int nIndex, CXTPGridColumn *pColumn) | CXTPGridColumnOrder |
m_arrColumns | CXTPGridColumnOrder | protected
m_pColumns | CXTPGridColumnOrder | protected
Remove(CXTPGridColumn *pColumn) | CXTPGridColumnOrder |
RemoveAt(int nIndex) | CXTPGridColumnOrder |


Toolkit Pro: XTPFrameThemeNativeWindows11.h Source File

  • Source
  • CommandBars
  • Frame
XTPFrameThemeNativeWindows11.h
Go to the documentation of this file.
1
23#if !defined(__XTPFRAMETHEMENATIVEWINDOWS11_H__)
24# define __XTPFRAMETHEMENATIVEWINDOWS11_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPPaintManager;
34class CXTPCommandBarsFrameHook;
35class CXTPRibbonBar;
36
37class _XTP_EXT_CLASS CXTPFrameThemeNativeWindows11
38 : public CXTPFrameThemeOffice2013
39 , public IXTPApplicationEvents
40 , private IXTPPaintManagerCustomAccentColorProvider
41{
42public:
43 CXTPFrameThemeNativeWindows11(CXTPPaintManager* pPaintManager);
44
45 virtual ~CXTPFrameThemeNativeWindows11();
46
47public:
52 virtual void RefreshMetrics();
53
65 virtual void DrawFrameCaptionButton(CDC* pDC, CRect rc, int nId, BOOL bSelected, BOOL bPressed,
66 BOOL bActive);
67
80 virtual void DrawFrameCaptionButton(CDC* pDC, CRect rc, int nId, BOOL bSelected, BOOL bPressed,
81 BOOL bActive, CXTPRibbonBar* pRibbonBar);
82
91 virtual void SetStateColor(COLORREF clrState);
92
101 virtual COLORREF GetStateColor() const;
102
103 virtual CXTPFrameShadow* CreateShadow(CWnd* pFrame);
104
105 virtual void OnShadowedFrameActiveStateChanged(BOOL bActive, CWnd* pFrame,
106 CXTPFrameShadow* pShadow);
107
115 virtual void LoadParts(HZIP hZip, CXTPMarkupContext* pMarkupContext);
116
123 virtual void LoadParts(BOOL bReload = FALSE);
124
125 virtual CRect CalcFrameBorder(const CXTPCommandBarsFrameHook* pFrameHook) const;
126
127protected:
128 virtual HRGN CalcFrameRegion(CXTPCommandBarsFrameHook* pFrameHook, CSize sz) const;
129
137 virtual void DrawFrame(CDC* pDC, CXTPCommandBarsFrameHook* pFrameHook);
138
146 virtual void DrawFrameBorder(CDC* pDC, CXTPCommandBarsFrameHook* pFrameHook);
147
151 virtual COLORREF GetFrameCaptionAccentTextColor(BOOL bActive) const;
152
153private:
154 void DrawCaptionBarRegion(CDC* pDC, CRect rcCaptionBar, CRgn& rgnCaptionBar, CWnd* pSite,
155 BOOL bActive);
156 virtual void OnAmbientPropertyChanged(CXTPApplication* pApplication,
157 XTPApplicationAmbientProperty nProperty);
158
159 void UpdateSystemAccentDependentColors();
160
161private:
162 // IXTPPaintManagerCustomAccentColorProvider overrides
163
164 virtual COLORREF GetCustomAccentColor(XTPPaintManagerAccentColor nColor);
165
166protected:
167 COLORREF m_clrShadowColorActive;
168 COLORREF m_clrShadowColorInactive;
169 COLORREF m_clrFrameCaptionBorderActive;
170 COLORREF m_clrFrameCaptionBorderInactive;
171
172 CXTPModernUIFrameCaptionButton* m_pButtonRestoreActive;
173 CXTPModernUIFrameCaptionButton* m_pButtonRestoreInactive;
174 CXTPModernUIFrameCaptionButton* m_pButtonRestorePressed;
175 CXTPModernUIFrameCaptionButton* m_pButtonRestoreHot;
176
177 CXTPColorSetCaptionButton m_csFrameSytemAccentCloseButtonActive;
178 CXTPColorSetCaptionButton m_csFrameSytemAccentCloseButtonHot;
179 CXTPColorSetCaptionButton m_csFrameSytemAccentCloseButtonPressed;
180 CXTPColorSetCaptionButton m_csFrameSytemAccentCaptionButtonActive;
181 CXTPColorSetCaptionButton m_csFrameSytemAccentCaptionButtonHot;
182 CXTPColorSetCaptionButton m_csFrameSytemAccentCaptionButtonPressed;
183 COLORREF m_clrFrameCaptionAccentTextActive;
184
185 CSize m_szWindowCorner;
186};
188# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
189#endif // !defined(__XTPFRAMETHEMENATIVEWINDOWS11_H__)
XTPApplicationAmbientProperty
XTPApplicationAmbientProperty
Global ambient property identifiers.
Definition XTPApplication.h:46
XTPPaintManagerAccentColor
XTPPaintManagerAccentColor
Defines a set of accent related colors.
Definition XTPColorManager.h:900
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPApplication
Defines a global XTP application object interface.
Definition XTPApplication.h:151
CXTPColorSetCaptionButton
Default theme caption button color set.
Definition XTPTheme.h:40
CXTPCommandBarsFrameHook
CXTPCommandBarsFrameHook is a CXTPHookManagerHookAble derived class.
Definition XTPFrameHook.h:56
CXTPFramePaintManager::OnShadowedFrameActiveStateChanged
virtual void OnShadowedFrameActiveStateChanged(BOOL bActive, CWnd *pFrame, CXTPFrameShadow *pShadow)
An implementation can override this method in order to change frame appearance when a window gets act...
CXTPFramePaintManager::GetFrameCaptionAccentTextColor
virtual COLORREF GetFrameCaptionAccentTextColor(BOOL bActive) const
Obtains frame caption accent color.
CXTPFrameShadow
The class represents frame shadow object.
Definition XTPFrameShadow.h:47
CXTPMarkupContext
CXTPMarkupContext is a standalone class used to provide common settings for Markup objects.
Definition XTPMarkupContext.h:128
CXTPPaintManager
Paint manager of the command bars.
Definition XTPPaintManager.h:199
CXTPRibbonBar
CXTPRibbonBar is a CXTPMenuBar derived class.
Definition XTPRibbonBar.h:69
CXTPRibbonMarkupFrameTheme::DrawFrameBorder
virtual void DrawFrameBorder(CDC *pDC, CXTPCommandBarsFrameHook *pFrameHook)
This method is called to draw the frame border.
IXTPApplicationEvents
Defines a callback interface for XTP application event sink.
Definition XTPApplication.h:82
IXTPApplicationEvents::OnAmbientPropertyChanged
virtual void OnAmbientPropertyChanged(CXTPApplication *pApplication, XTPApplicationAmbientProperty nProperty)
Called by framework when an ambient property is changed.
Definition XTPApplication.h:130


Toolkit Pro: Member List

  • CXTPTabPaintManagerColorSet
  • COLORSET_TAB_EXCEL
CXTPTabPaintManagerColorSet::COLORSET_TAB_EXCEL Member List

This is the complete list of members for CXTPTabPaintManagerColorSet::COLORSET_TAB_EXCEL, including all inherited members.

clrLeftInnerBorder | CXTPTabPaintManagerColorSet::COLORSET_TAB_EXCEL
clrLeftOuterBorder | CXTPTabPaintManagerColorSet::COLORSET_TAB_EXCEL
clrRightInnerBorder | CXTPTabPaintManagerColorSet::COLORSET_TAB_EXCEL
clrRightOuterBorder | CXTPTabPaintManagerColorSet::COLORSET_TAB_EXCEL
clrTopInnerBorder | CXTPTabPaintManagerColorSet::COLORSET_TAB_EXCEL
clrTopOuterBorder | CXTPTabPaintManagerColorSet::COLORSET_TAB_EXCEL


Toolkit Pro: Member List

XTP_URI_DEFAULTS Member List

This is the complete list of members for XTP_URI_DEFAULTS, including all inherited members.

lpType XTP_URI_DEFAULTS


Toolkit Pro: XTPFlowGraphNodes.h Source File

  • Source
  • FlowGraph
XTPFlowGraphNodes.h
Go to the documentation of this file.
1
23#if !defined(__XTPFLOWGRAPHNODES_H__)
24# define __XTPFLOWGRAPHNODES_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPFlowGraphPage;
34class CXTPFlowGraphNode;
35class CXTPFlowGraphNodeCustom;
36
47class _XTP_EXT_CLASS CXTPFlowGraphNodes : public CXTPCmdTarget
48{
49protected:
55 CXTPFlowGraphNodes(CXTPFlowGraphPage* pPage);
61 virtual ~CXTPFlowGraphNodes();
62
63public:
68 void RemoveAll();
76 CXTPFlowGraphNode* AddNode(CXTPFlowGraphNode* pNode);
77
84 CXTPFlowGraphNodeCustom* AddCustomNode(CXTPFlowGraphNodeCustom* pNode = NULL);
85 CXTPFlowGraphNodeCustom* AddResourceNode(UINT uResShapeID);
86
92 void Remove(CXTPFlowGraphNode* pNode);
98 void RemoveAt(int nIndex);
99
108 CXTPFlowGraphNode* FindNode(int nId) const;
109
116 int GetCount() const;
124 CXTPFlowGraphNode* GetAt(int nIndex) const;
125
131 void MoveToFront(CXTPFlowGraphNode* pNode);
132
133public:
143 void DoPropExchange(CXTPPropExchange* pPX);
144
145protected:
146 CXTPFlowGraphPage* m_pPage;
149 CArray<CXTPFlowGraphNode*, CXTPFlowGraphNode*> m_arrNodes;
151 friend class CXTPFlowGraphPage;
152
153# ifdef _XTP_ACTIVEX
156 DECLARE_DISPATCH_MAP()
157 DECLARE_INTERFACE_MAP()
158
159 DECLARE_OLETYPELIB_EX(CXTPFlowGraphNodes)
160 DECLARE_ENUM_VARIANT(CXTPFlowGraphNodes)
161
162 afx_msg int OleGetItemCount();
163 afx_msg LPDISPATCH OleGetItem(int nIndex);
164 afx_msg LPDISPATCH OleAddNode();
165 afx_msg LPDISPATCH OleAddCustomNode();
166 afx_msg LPDISPATCH OleAddResourceNode(int nResShapeID);
167 afx_msg LPDISPATCH OleFindNode(int nId);
168
170# endif
171};
172
173AFX_INLINE int CXTPFlowGraphNodes::GetCount() const
174{
175 return (int)m_arrNodes.GetSize();
176}
177AFX_INLINE CXTPFlowGraphNode* CXTPFlowGraphNodes::GetAt(int nIndex) const
178{
179 return nIndex >= 0 && nIndex < m_arrNodes.GetSize() ? m_arrNodes[nIndex] : NULL;
180}
182# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
183#endif //#if !defined(__XTPFLOWGRAPHNODES_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPFlowGraphNodeCustom
Represents a Node object defined by custom XAML markup.
Definition XTPFlowGraphNodeCustom.h:94
CXTPFlowGraphNode
Represents a Node object.
Definition XTPFlowGraphNode.h:116
CXTPFlowGraphNode::GetSize
CSize GetSize() const
Gets the size of the Node.
CXTPFlowGraphNodes
Represents a collection of Nodes in a page or group.
Definition XTPFlowGraphNodes.h:48
CXTPFlowGraphNodes::GetCount
int GetCount() const
Retrieves the total number of Nodes in the page or group.
Definition XTPFlowGraphNodes.h:173
CXTPFlowGraphNodes::CXTPFlowGraphNodes
CXTPFlowGraphNodes(CXTPFlowGraphPage *pPage)
Constructs a CXTPFlowGraphPage object.
CXTPFlowGraphNodes::DoPropExchange
void DoPropExchange(CXTPPropExchange *pPX)
Call this member function to store/load a collection of Nodes using the specified data object.
CXTPFlowGraphNodes::m_arrNodes
CArray< CXTPFlowGraphNode *, CXTPFlowGraphNode * > m_arrNodes
Collection of nodes.
Definition XTPFlowGraphNodes.h:149
CXTPFlowGraphNodes::~CXTPFlowGraphNodes
virtual ~CXTPFlowGraphNodes()
Destroys a CXTPFlowGraphNodes object, handles cleanup and deallocation.
CXTPFlowGraphNodes::m_pPage
CXTPFlowGraphPage * m_pPage
Pointer to the page this collection of nodes is displayed on.
Definition XTPFlowGraphNodes.h:146
CXTPFlowGraphNodes::RemoveAll
void RemoveAll()
Removes all Nodes from the page or group.
CXTPFlowGraphNodes::AddCustomNode
CXTPFlowGraphNodeCustom * AddCustomNode(CXTPFlowGraphNodeCustom *pNode=NULL)
Adds a custom node.
CXTPFlowGraphNodes::FindNode
CXTPFlowGraphNode * FindNode(int nId) const
Finds and retrieves the specified Node.
CXTPFlowGraphNodes::Remove
void Remove(CXTPFlowGraphNode *pNode)
Removes the specified Node.
CXTPFlowGraphNodes::GetAt
CXTPFlowGraphNode * GetAt(int nIndex) const
Gets the Node at the specified index.
Definition XTPFlowGraphNodes.h:177
CXTPFlowGraphNodes::AddNode
CXTPFlowGraphNode * AddNode(CXTPFlowGraphNode *pNode)
Adds a node to a page or group.
CXTPFlowGraphNodes::RemoveAt
void RemoveAt(int nIndex)
Removes the specified Node from the page or group.
CXTPFlowGraphNodes::MoveToFront
void MoveToFront(CXTPFlowGraphNode *pNode)
Moves the specified Node to the front.
CXTPFlowGraphPage
Represents a page in the flow graph.
Definition XTPFlowGraphPage.h:54
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72


Toolkit Pro: XTPDockingPaneThemeOffice2003Visio.h Source File

  • Source
  • DockingPane
  • Themes
XTPDockingPaneThemeOffice2003Visio.h
Go to the documentation of this file.
1
23#if !defined(__XTPDOCKINGPANETHEMEOFFICE2003VISIO_H__)
24# define __XTPDOCKINGPANETHEMEOFFICE2003VISIO_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
41class _XTP_EXT_CLASS CXTPDockingPaneOffice2003VisioTheme
42 : public CXTPDockingPaneOffice2002VisioTheme
43{
44public:
49 CXTPDockingPaneOffice2003VisioTheme();
50};
51
52# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
54#endif // !defined(__XTPDOCKINGPANETHEMEOFFICE2003VISIO_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPDockingPaneOffice2002VisioTheme
CXTPDockingPaneOffice2002VisioTheme is a CXTPDockingPaneVisualStudio2003Theme derived class that repr...
Definition XTPDockingPaneThemeOffice2002Visio.h:43
CXTPDockingPaneOffice2003VisioTheme
CXTPDockingPaneOffice2003VisioTheme is a CXTPDockingPaneOffice2002VisioTheme derived class that repre...
Definition XTPDockingPaneThemeOffice2003Visio.h:43
CXTPDockingPaneOffice2003VisioTheme::CXTPDockingPaneOffice2003VisioTheme
CXTPDockingPaneOffice2003VisioTheme()
Constructs a CXTPDockingPaneOffice2003VisioTheme object.


Toolkit Pro: Member List

CXTPMarkupRowDefinition Member List

This is the complete list of members for CXTPMarkupRowDefinition, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPMarkupDefinitionBase(BOOL bIsColumnDefinition=FALSE) | CXTPMarkupDefinitionBase | protected
CXTPMarkupRowDefinition() | CXTPMarkupRowDefinition |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetUserMaxSize() const | CXTPMarkupDefinitionBase |
GetUserMinSize() const | CXTPMarkupDefinitionBase |
GetUserSize() const | CXTPMarkupDefinitionBase |
SetHeight(int nHeight) | CXTPMarkupRowDefinition |
SetHeight(CXTPMarkupGridLength *pLength) | CXTPMarkupRowDefinition |
SetMaxHeight(int nHeight) | CXTPMarkupRowDefinition |
SetMinHeight(int nHeight) | CXTPMarkupRowDefinition |


Toolkit Pro: XTPChart3dPyramidSeriesPointView.h Source File

  • Source
  • Chart
  • Styles
  • Pyramid
  • 3D
XTPChart3dPyramidSeriesPointView.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHART3DPYPAMIDSERIESPOINTVIEW_H__)
24# define __XTPCHART3DPYRAMIDSERIESPOINTVIEW_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
44class _XTP_EXT_CLASS CXTPChart3dPyramidSeriesPointView
45 : public CXTPChartPyramidSeriesPointViewBase
46 , private CXTPChart3dPyramidDeviceCommandEvents
47{
48 DECLARE_DYNAMIC(CXTPChart3dPyramidSeriesPointView);
49
50public:
58 CXTPChart3dPyramidSeriesPointView(CXTPChartSeriesPoint* pPoint,
59 CXTPChartElementView* pParentView);
60
65 virtual ~CXTPChart3dPyramidSeriesPointView();
66
67public:
77 virtual void CalculateLayout(int nIndex, int nCount, double dFrom, double dTo);
78
89 const CXTPPoint3d& GetCenterShapeConnectorPoint() const;
90
101 const CXTPPoint3d& GetOuterCenterConnectorPoint() const;
102
103protected:
116 virtual CXTPChartDeviceCommand* CreateDeviceCommand(CXTPChartDeviceContext* pDC);
117
128 virtual CXTPChartDeviceCommand* CreateLegendDeviceCommand(CXTPChartDeviceContext* pDC,
129 CRect rcBounds);
130
131protected:
139 virtual void OnUpdateBounds(CXTPChartDeviceCommand* pCommand, CRect rcBounds);
140
149 virtual void OnSetConnectorPoints(CXTPChartDeviceCommand* pCommand, CXTPPoint3d ptShapeCenter,
150 CXTPPoint3d ptOuterCenter);
151
152private:
153 CXTPChartPyramidSeriesPointViewBase* m_p2dSeriesPointView;
155 CXTPPoint3d m_ptShapeCenter;
156 CXTPPoint3d m_ptOuterCenter;
157 CXTPSubscriptionList<CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents>*
158 m_pCommandSubscriptionList;
159
160 double m_dWidth;
161 double m_dHeight;
162 double m_dFrom;
163 double m_dTo;
164};
165
166AFX_INLINE const CXTPPoint3d& CXTPChart3dPyramidSeriesPointView::GetCenterShapeConnectorPoint() const
167{
168 return m_ptShapeCenter;
169}
170
171AFX_INLINE const CXTPPoint3d& CXTPChart3dPyramidSeriesPointView::GetOuterCenterConnectorPoint() const
172{
173 return m_ptOuterCenter;
174}
176# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
177#endif //#if !defined(__XTPCHART3DPYRAMIDSERIESPOINTVIEW_H__)
pPoint
const CPoint * pPoint
return 0 or xtpCalendarHitTestDayExpandButton
Definition XTPCalendarThemeOffice2007.h:150
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChart3dPyramidDeviceCommandEvents
Defines interface for 3D chart pyramid device command event sink.
Definition XTPChart3dPyramidDeviceCommandEvents.h:42
CXTPChart3dPyramidSeriesPointView
This class abstracts the view of a pyramid series point.
Definition XTPChart3dPyramidSeriesPointView.h:47
CXTPChart3dPyramidSeriesPointView::CXTPChart3dPyramidSeriesPointView
CXTPChart3dPyramidSeriesPointView(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Constructs a CXTPChart3dPyramidSeriesPointView object.
CXTPChart3dPyramidSeriesPointView::GetOuterCenterConnectorPoint
const CXTPPoint3d & GetOuterCenterConnectorPoint() const
Obtains the outer shape center connector point.
Definition XTPChart3dPyramidSeriesPointView.h:171
CXTPChart3dPyramidSeriesPointView::OnSetConnectorPoints
virtual void OnSetConnectorPoints(CXTPChartDeviceCommand *pCommand, CXTPPoint3d ptShapeCenter, CXTPPoint3d ptOuterCenter)
Gets called when pyramid connector points are computed.
CXTPChart3dPyramidSeriesPointView::GetCenterShapeConnectorPoint
const CXTPPoint3d & GetCenterShapeConnectorPoint() const
Obtains the shape center connector point.
Definition XTPChart3dPyramidSeriesPointView.h:166
CXTPChart3dPyramidSeriesPointView::CreateDeviceCommand
virtual CXTPChartDeviceCommand * CreateDeviceCommand(CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
CXTPChart3dPyramidSeriesPointView::CreateLegendDeviceCommand
virtual CXTPChartDeviceCommand * CreateLegendDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcBounds)
This function creates a label view drawing command object.
CXTPChart3dPyramidSeriesPointView::OnUpdateBounds
virtual void OnUpdateBounds(CXTPChartDeviceCommand *pCommand, CRect rcBounds)
Notifies about updated boundaries of the command result.
CXTPChart3dPyramidSeriesPointView::CalculateLayout
virtual void CalculateLayout(int nIndex, int nCount, double dFrom, double dTo)
Use this function to calculate the layout of the pyramid series point.
CXTPChart3dPyramidSeriesPointView::~CXTPChart3dPyramidSeriesPointView
virtual ~CXTPChart3dPyramidSeriesPointView()
Handles view destruction.
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartElementView
This class represents the view of a chart element.
Definition XTPChartElementView.h:47
CXTPChartPyramidSeriesPointViewBase
This class abstracts the view of a pyramid series point.
Definition XTPChartPyramidSeriesPointViewBase.h:46
CXTPChartSeriesPoint
CXTPChartSeriesPoint is a kind of CXTPChartElement.
Definition XTPChartSeriesPoint.h:43
CXTPPoint3T< double >
CXTPSubscriptionList
Holds a list of observable objects to which an oberser is subscribed.
Definition XTPSystemHelpers.h:2090


Toolkit Pro: Member List

CXTPCalendarTimeLineViewGroups Member List

This is the complete list of members for CXTPCalendarTimeLineViewGroups, including all inherited members.

Add(CXTPCalendarTimeLineViewGroup *pNewElement) | CXTPCalendarPtrCollectionT< CXTPCalendarTimeLineViewGroup > | virtual
Add(CXTPCalendarTimeLineViewGroup *pNewElement, BOOL bWithAddRef) | CXTPCalendarPtrCollectionT< CXTPCalendarTimeLineViewGroup > | virtual
Append(const CXTPCalendarPtrCollectionT< CXTPCalendarTimeLineViewGroup > *pElementsArray) | CXTPCalendarPtrCollectionT< CXTPCalendarTimeLineViewGroup > | virtual
CXTPCalendarPtrCollectionT() | CXTPCalendarPtrCollectionT< CXTPCalendarTimeLineViewGroup > |
CXTPCmdTarget() | CXTPCmdTarget |
Find(const CXTPCalendarTimeLineViewGroup *pElement) const | CXTPCalendarPtrCollectionT< CXTPCalendarTimeLineViewGroup > | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAt(int nIndex) const | CXTPCalendarPtrCollectionT< CXTPCalendarTimeLineViewGroup > | virtual
GetAt(int nIndex, BOOL bWithAddRef) const | CXTPCalendarPtrCollectionT< CXTPCalendarTimeLineViewGroup > | virtual
GetCount() const | CXTPCalendarPtrCollectionT< CXTPCalendarTimeLineViewGroup > | virtual
InsertAt(int nIndex, CXTPCalendarTimeLineViewGroup *pElement) | CXTPCalendarPtrCollectionT< CXTPCalendarTimeLineViewGroup > | virtual
m_arElements | CXTPCalendarPtrCollectionT< CXTPCalendarTimeLineViewGroup > | protected
Remove(CXTPCalendarTimeLineViewGroup *pElement) | CXTPCalendarPtrCollectionT< CXTPCalendarTimeLineViewGroup > | virtual
RemoveAll() | CXTPCalendarPtrCollectionT< CXTPCalendarTimeLineViewGroup > | virtual
RemoveAt(int nIndex) | CXTPCalendarPtrCollectionT< CXTPCalendarTimeLineViewGroup > | virtual
SetAt(int nIndex, CXTPCalendarTimeLineViewGroup *pElement) | CXTPCalendarPtrCollectionT< CXTPCalendarTimeLineViewGroup > | virtual
SetSize(int nNewSize) | CXTPCalendarPtrCollectionT< CXTPCalendarTimeLineViewGroup > | virtual
TObjectPtr typedef | CXTPCalendarPtrCollectionT< CXTPCalendarTimeLineViewGroup > | protected
~CXTPCalendarPtrCollectionT() | CXTPCalendarPtrCollectionT< CXTPCalendarTimeLineViewGroup > | virtual


Toolkit Pro: XTPSyntaxEditLexClass.h Source File

  • Source
  • SyntaxEdit
XTPSyntaxEditLexClass.h
Go to the documentation of this file.
1
23#if !defined(__XTPSYNTAXEDITLEXCLASS_H__)
24# define __XTPSYNTAXEDITLEXCLASS_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33// #pragma warning(disable: 4097 4786)
34
42namespace XTPSyntaxEditLexAnalyser
44{
45struct XTP_EDIT_LEXPROPINFO;
46
55class _XTP_EXT_CLASS CXTPSyntaxEditLexVariable
56{
57public:
62 CXTPSyntaxEditLexVariable();
63
68 virtual ~CXTPSyntaxEditLexVariable();
69
81 enum XTPSyntaxEditLexVarID
82 {
83 xtpEditVarID_Unknown = 0,
84 xtpEditVarID_alpha = 1,
85 xtpEditVarID_digit = 2,
86 xtpEditVarID_HexDigit = 3,
87 xtpEditVarID_specs = 4,
88 xtpEditVarID_EOL = 5,
90 };
91
102 enum XTPSyntaxEditLexVarFlags
103 {
104 xtpEditVarfNot = 0x001,
106 };
107
108 int m_nVarID;
109 CString m_strVar;
110 int m_nVarFlags;
124 const CXTPSyntaxEditLexVariable& operator=(const CXTPSyntaxEditLexVariable& rSrc);
125
140 virtual BOOL SetVariable(LPCTSTR pcszVarName);
141
154 BOOL operator==(const CXTPSyntaxEditLexVariable& rSrc) const;
155
172 static int AFX_CDECL GetVarID(LPCTSTR pcszVarName);
173
184 static BOOL AFX_CDECL GetVariableData(int nVarID, CStringArray& rarVarData);
185
186protected:
198 static void AFX_CDECL InitStandartVarsIfNeed();
199
200 static CMapStringToPtr s_mapVar2ID;
201 static BOOL s_bVarMapInitialized;
203};
204
209enum XTPSyntaxEditLexVariantType
210{
211 xtpEditLVT_Unknown = 0,
212 xtpEditLVT_className = 0x0001,
214 xtpEditLVT_classPtr = 0x0002,
215 xtpEditLVT_LVArrayPtr = 0x0004,
216 xtpEditLVT_valInt = 0x0100,
217 xtpEditLVT_valStr = 0x0200,
218 xtpEditLVT_valVar = 0x0400,
219};
220
229class _XTP_EXT_CLASS CXTPSyntaxEditLexVariant : public CXTPCmdTarget
230{
231public:
242 CXTPSyntaxEditLexVariant();
255 CXTPSyntaxEditLexVariant(const CXTPSyntaxEditLexVariant& rSrc);
271 CXTPSyntaxEditLexVariant(CXTPSyntaxEditLexClass* pClass);
288 CXTPSyntaxEditLexVariant(CXTPSyntaxEditLexVariantPtrArray* pLVArray);
289
303 CXTPSyntaxEditLexVariant(const CXTPSyntaxEditLexVariable& rSrcVar);
322 CXTPSyntaxEditLexVariant(LPCTSTR pcszStr, int eType = xtpEditLVT_valStr);
323
337 CXTPSyntaxEditLexVariant(const CStringArray* pArStrVals);
338
352 CXTPSyntaxEditLexVariant(int nValue);
353
358 virtual ~CXTPSyntaxEditLexVariant();
359
360 int m_nObjType;
362 CXTPSyntaxEditLexClassPtr m_ptrClass;
364 CXTPSyntaxEditLexVariantPtrArray* m_ptrLVArrayPtr;
367 int m_nValue;
368 CStringArray m_arStrVals;
371 CXTPSyntaxEditLexVariable m_Variable;
384 const CXTPSyntaxEditLexVariant& operator=(const CXTPSyntaxEditLexVariant& rSrc);
385
398 const CXTPSyntaxEditLexVariant& operator=(int nVal);
399
413 const CXTPSyntaxEditLexVariant& operator=(const CXTPSyntaxEditLexVariable& rSrcVar);
414
427 BOOL operator==(const CXTPSyntaxEditLexVariant& rSrc) const;
428
444 virtual BOOL SetVariable(LPCTSTR pcszVarName);
445
458 virtual BOOL IsStrType() const;
459
473 virtual LPCTSTR GetStr() const;
474
486 virtual CXTPSyntaxEditLexVariant* Clone() const;
487
488# ifdef _DEBUG
496 void Dump(CDumpContext& dc) const;
497# endif
498};
499
507class _XTP_EXT_CLASS CXTPSyntaxEditLexOnScreenParseCnt
508{
509public:
514 CXTPSyntaxEditLexOnScreenParseCnt();
515
520 virtual ~CXTPSyntaxEditLexOnScreenParseCnt();
521
522 int m_nRowStart;
523 int m_nRowEnd;
524 CXTPSyntaxEditLexTextBlockPtr m_ptrTBLast;
525};
526
533enum XTPSyntaxEditLexClass_OptParent
534{
535 xtpEditOptParent_Unknown = 0,
536 xtpEditOptParent_Default = -1,
537 xtpEditOptParent_file = 1,
538 xtpEditOptParent_direct = 2,
540 xtpEditOptParent_dyn = 3,
542};
543
550enum XTPSyntaxEditLexClass_OptChildren
551{
552 xtpEditOptChildren_Unknown = 0,
553 xtpEditOptChildren_No = 1,
554 xtpEditOptChildren_Any =
555 2,
556 xtpEditOptChildren_List = 3,
558};
559
564static const TCHAR XTPLEX_ATTR_TXTPREFIX[] = _T("txt:");
566static const TCHAR XTPLEX_ATTR_COLORPREFIX[] = _T("txt:color");
568static const TCHAR XTPLEX_ATTR_TXT_COLORFG[] = _T("txt:colorFG");
569static const TCHAR XTPLEX_ATTR_TXT_COLORBK[] = _T("txt:colorBK");
570static const TCHAR XTPLEX_ATTR_TXT_COLORSELFG[] = _T("txt:colorSelFG");
571static const TCHAR XTPLEX_ATTR_TXT_COLORSELBK[] = _T("txt:colorSelBK");
573static const TCHAR XTPLEX_ATTR_TXT_BOLD[] = _T("txt:Bold");
574static const TCHAR XTPLEX_ATTR_TXT_ITALIC[] = _T("txt:Italic");
575static const TCHAR XTPLEX_ATTR_TXT_UNDERLINE[] = _T("txt:Underline");
577static const TCHAR XTPLEX_ATTR_CASESENSITIVE[] = _T("CaseSensitive");
579static const TCHAR XTPLEX_ATTR_COLLAPSABLE[] = _T("Collapsable");
581static const TCHAR XTPLEX_ATTR_COLLAPSEDTEXT[] = _T("CollapsedText");
583static const TCHAR XTPLEX_ATTR_PARSEONSCREEN[] = _T("ParseOnScreen");
585static const TCHAR XTPLEX_ATTR_RESTARTRUNLOOP[] =
586 _T("RestartRunLoop");
588static const TCHAR XTPLEX_ATTR_ENDCLASSPARENT[] =
589 _T("End:Class:Parent");
590static const TCHAR XTPLEX_ATTR_RECURRENCEDEPTH[] = _T("RecurrenceDepth");
592static const TCHAR XTPLEX_ATTR_DISPLAYNAME[] = _T("DisplayName");
595// Global attributes
596static const TCHAR XTPLEX_ATTRG_FIRSTPARSEINSEPARATETHREAD[] =
597 _T("global:FirstParseInSeparateThread");
598static const TCHAR XTPLEX_ATTRG_EDITREPARCEINSEPARATETHREAD[] =
599 _T("global:EditReparceInSeparateThread");
600static const TCHAR XTPLEX_ATTRG_CONFIGCHANGEDREPARCEINSEPARATETHREAD[] =
601 _T("global:ConfigChangedReparceInSeparateThread");
602static const TCHAR XTPLEX_ATTRG_EDITREPARCETIMEOUT_MS[] =
603 _T("global:EditReparceTimeout_ms");
605static const TCHAR XTPLEX_ATTRG_MAXBACKPARSEOFFSET[] =
606 _T("global:MaxBackParseOffset");
608static const TCHAR XTPLEX_ATTRG_ONSCREENSCHCACHELIFETIME_SEC[] =
609 _T("global:OnScreenSchCacheLifeTime_sec");
612static const TCHAR XTPLEX_ATTRG_PARSERTHREADIDLELIFETIME_SEC[] =
613 _T("global:ParserThreadIdleLifeTime_sec");
617// internal attributes
618static const TCHAR XTPLEX_ATTRCLASSID[] = _T("ClassID");
628class _XTP_EXT_CLASS CXTPSyntaxEditLexClass
629 : public CXTPCmdTarget
630 , protected CXTPSyntaxEditLexObj_SpecCollT<
631 CXTPSyntaxEditLexObj_Previous, CXTPSyntaxEditLexObj_Start, CXTPSyntaxEditLexObj_End,
632 CXTPSyntaxEditLexObj_Token, CXTPSyntaxEditLexObj_Skip, CXTPSyntaxEditLexObj_ActiveTags>
633{
634public:
642 typedef CXTPSyntaxEditLexObj_SpecCollT<
643 CXTPSyntaxEditLexObj_Previous, CXTPSyntaxEditLexObj_Start, CXTPSyntaxEditLexObj_End,
644 CXTPSyntaxEditLexObj_Token, CXTPSyntaxEditLexObj_Skip, CXTPSyntaxEditLexObj_ActiveTags>
645 TBase;
646
651 CXTPSyntaxEditLexClass();
652
657 virtual ~CXTPSyntaxEditLexClass();
658
661protected:
662 XTP_EDIT_LEX_CLASS_OBJ_MEMBER(0, m_previous);
664 XTP_EDIT_LEX_CLASS_OBJ_MEMBER(1, m_start);
665 XTP_EDIT_LEX_CLASS_OBJ_MEMBER(2, m_end);
666 XTP_EDIT_LEX_CLASS_OBJ_MEMBER(3, m_token);
667 XTP_EDIT_LEX_CLASS_OBJ_MEMBER(4, m_skip);
669 // internal objects
670 XTP_EDIT_LEX_CLASS_OBJ_MEMBER(5, m_ActiveTags);
676 int m_nActiv_EndTags_Offset;
679 friend class CXTPSyntaxEditLexClass_file;
680 friend class CXTPSyntaxEditLexClassSchema;
681 friend class CXTPSyntaxEditLexTextSchema;
682 friend class CXTPSyntaxEditLexParser;
683
684public:
698 virtual CXTPSyntaxEditLexVariantPtr PropV(LPCTSTR pcszPropName);
699
711 virtual CString GetClassName() const;
712
724 virtual BOOL IsCaseSensitive();
725
737 virtual int IsCollapsable();
738
749 virtual void GetTextAttributes(XTP_EDIT_TEXTBLOCK& rTB);
750
762 virtual void Close();
763
775 static void AFX_CDECL CloseClasses(CXTPSyntaxEditLexClassPtrArray* pArClasses);
776
795 virtual CXTPSyntaxEditLexVariantPtr GetAttribute(LPCTSTR strName, BOOL bDyn) const;
796
816 virtual BOOL GetAttribute_BOOL(LPCTSTR strName, BOOL bDyn, BOOL bDefault = FALSE) const;
817
837 virtual int GetAttribute_int(LPCTSTR strName, BOOL bDyn, int nDefault = 0) const;
838
839protected:
851 virtual void SetAttribute(CString strName, const CXTPSyntaxEditLexVariant& rVal);
852
864 virtual CXTPSyntaxEditLexClassPtrArray* GetChildren();
865
877 virtual CXTPSyntaxEditLexClassPtrArray* GetChildrenDyn();
878
890 virtual CXTPSyntaxEditLexClassPtrArray* GetChildrenSelfRef();
891
898 virtual CXTPSyntaxEditLexObj_ActiveTags* GetActiveTags();
899
910 virtual int RunParse(CTextIter* pTxtIter, CXTPSyntaxEditLexTextSchema* pTxtSch,
911 CXTPSyntaxEditLexTextBlockPtr& rPtrTxtBlock,
912 CXTPSyntaxEditLexOnScreenParseCnt* pOnScreenRunCnt = NULL);
913# ifdef _DEBUG
920 void DumpOffset(CDumpContext& dc, LPCTSTR pcszOffset);
921# endif
922
923protected:
925 virtual BOOL SetProp_ProcessSpecials(const XTP_EDIT_LEXPROPINFO* pPropDesc, BOOL& rbProcessed);
926
927 virtual BOOL SetProp_ProcessSpecObjects(const XTP_EDIT_LEXPROPINFO* pPropDesc,
928 BOOL& rbProcessed);
929
930 virtual BOOL SetProp_ProcessAttributes(const XTP_EDIT_LEXPROPINFO* pPropDesc,
931 BOOL& rbProcessed);
932
933 virtual BOOL ParseValues(const XTP_EDIT_LEXPROPINFO* pPropDesc,
934 CXTPSyntaxEditLexVariantPtrArray* pLVArray);
935
936 virtual BOOL IsQuoted(CString strValue, CString* pstrUnQuotedVal = NULL);
937 virtual BOOL IsVar(CString strValue, CString* pstrVarVal = NULL);
938
939 virtual void SortTags();
940
941 virtual BOOL Run_Previous(CTextIter* pTxtIter, CXTPSyntaxEditLexTextSchema* pTxtSch,
942 CXTPSyntaxEditLexTextBlockPtr& rPtrTxtBlock,
943 CXTPSyntaxEditLexOnScreenParseCnt* pOnScreenRunCnt = NULL);
944
945 virtual int Run_Start(CTextIter* pTxtIter, CXTPSyntaxEditLexTextSchema* pTxtSch,
946 CXTPSyntaxEditLexTextBlockPtr& rPtrTxtBlock,
947 CXTPSyntaxEditLexOnScreenParseCnt* pOnScreenRunCnt = NULL);
948
949 virtual int Run_Skip(CTextIter* pTxtIter, CXTPSyntaxEditLexTextSchema* pTxtSch,
950 CXTPSyntaxEditLexTextBlockPtr& rPtrTxtBlock);
951
952 virtual int Run_End(CTextIter* pTxtIter, CXTPSyntaxEditLexTextSchema* pTxtSch,
953 CXTPSyntaxEditLexTextBlockPtr& rPtrTxtBlock,
954 CXTPSyntaxEditLexOnScreenParseCnt* pOnScreenRunCnt = NULL);
955
956 virtual int Run_Token(CTextIter* pTxtIter, CXTPSyntaxEditLexTextSchema* pTxtSch,
957 CXTPSyntaxEditLexTextBlockPtr& rPtrTxtBlock);
958
959 virtual BOOL Run_TokenSeparators(CString strToken, CTextIter* pTxtIter,
960 CXTPSyntaxEditLexTextSchema* pTxtSch, CString& rstrSeparator1,
961 CString& rstrSeparator2);
962
963 virtual BOOL Run_Tags(CTextIter* pIter, CXTPSyntaxEditLexTextSchema* pTxtSch,
964 CXTPSyntaxEditLexVariantPtrArray* pLVTags, CString& rstrTagVal,
965 BOOL bParseDirection_Back = FALSE);
966
967 static BOOL AFX_CDECL Run_Tags1(CTextIter* pIter, CXTPSyntaxEditLexVariantPtrArray* pLVTags,
968 CString& rstrTagVal, BOOL bCaseSensitive,
969 BOOL bParseDirection_Back = FALSE);
970
971 static BOOL AFX_CDECL Run_Tags2(CTextIter* pIter, CXTPSyntaxEditLexVariant* pVTags,
972 CString& rstrTagVal, BOOL bCaseSensitive,
973 BOOL bParseDirection_Back = FALSE);
974
975 virtual BOOL Run_PrevClass(CXTPSyntaxEditLexTextBlock** ppPrevTB,
976 CXTPSyntaxEditLexTextSchema* pTxtSch,
977 CXTPSyntaxEditLexVariantPtrArray* pLVPrevClasses, int nDepth,
978 XTP_EDIT_LINECOL* pMinPrevPos = NULL,
979 CXTPSyntaxEditLexTextBlock* pPrevForParentBlockOnly = NULL,
980 CXTPSyntaxEditLexOnScreenParseCnt* pOnScreenRunCnt = NULL);
981
982 static BOOL AFX_CDECL StrCmp(LPCTSTR pcszStr1, LPCTSTR pcszStr2, int nLen, BOOL bCaseSensitive);
983
984 static BOOL AFX_CDECL StrCmpEQ(LPCTSTR pcszStr1, LPCTSTR pcszStr2, int nLen,
985 BOOL bCaseSensitive, BOOL bParseDirection_Back = FALSE);
986
987 static BOOL AFX_CDECL StrVarCmpEQ(LPCTSTR pcszStr, const CXTPSyntaxEditLexVariable& lexVar,
988 CString& rstrValue, BOOL bParseDirection_Back = FALSE);
989
990 virtual BOOL SetProp(const XTP_EDIT_LEXPROPINFO* pPropDesc);
991
992 virtual BOOL AddChild(CXTPSyntaxEditLexClass* pChild, BOOL bDyn);
993
994 const CXTPSyntaxEditLexClass& operator=(const CXTPSyntaxEditLexClass& rSrc);
995 virtual void CopyFrom(const CXTPSyntaxEditLexClass* pSrc);
996
997 virtual CXTPSyntaxEditLexClass* Clone(CXTPSyntaxEditLexClassSchema* pOwnerSch = NULL);
998
999 virtual void CopyAttributes(const CXTPSyntaxEditLexClass* pSrcAttrClass,
1000 LPCTSTR pcszAttrPrefix = NULL);
1001 virtual void RemoveAttributes(LPCTSTR pcszAttrPrefix = NULL);
1002
1003 virtual void GetParentOpt(int& rnOpt, CStringArray& rArData) const;
1004 virtual void GetChildrenOpt(int& rnOpt, CStringArray& rArData) const;
1005
1006 virtual CXTPSyntaxEditLexVariantPtrArray* BuildActiveTags(int& rnStartCount);
1007
1008 virtual CXTPSyntaxEditLexClass* FindParent(LPCTSTR pcszClassName);
1009
1020 virtual BOOL IsRestartRunLoop();
1021
1022 virtual BOOL IsEndClassParent_this();
1024protected:
1026 class CXTPSyntaxEditParent
1027 {
1028 public:
1029 XTPSyntaxEditLexClass_OptParent eOpt;
1030 CXTPSyntaxEditLexClassPtr ptrDirect;
1031 CStringArray arClassNames;
1032
1033 void Clear()
1034 {
1035 eOpt = xtpEditOptParent_Unknown;
1036 ptrDirect = NULL;
1037 arClassNames.RemoveAll();
1038 }
1039 };
1040
1041 class CXTPSyntaxEditChildren
1042 {
1043 public:
1044 XTPSyntaxEditLexClass_OptChildren eOpt;
1045 CStringArray arClassNames;
1046
1047 void Clear()
1048 {
1049 eOpt = xtpEditOptChildren_Any;
1050 arClassNames.RemoveAll();
1051 }
1052 };
1053
1054 CString m_strClassName;
1055
1056 CXTPSyntaxEditParent m_Parent;
1057 CXTPSyntaxEditChildren m_Children;
1060protected:
1062 CXTPSyntaxEditLexClassPtrArray m_arChildrenClasses;
1063 CXTPSyntaxEditLexClassPtrArray m_arDynChildrenClasses;
1064 CXTPSyntaxEditLexClassPtrArray m_arChildrenSelfRefClasses;
1065
1066 CMap<CString, LPCTSTR, CXTPSyntaxEditLexVariantPtr, CXTPSyntaxEditLexVariantPtr&>
1067 m_mapAttributes;
1070private:
1071 // Cached attributes
1072 virtual void ClearAttributesCache();
1073
1074 int m_bCaseSensitive_Cached;
1075 int m_nCollapsable_Cached;
1076 int m_bRestartRunLoop_Cached;
1077 int m_bEndClassParent_this_Cached;
1078
1079 XTP_EDIT_TEXTBLOCK m_txtAttr_cached;
1080 BOOL m_bTxtAttr_cached;
1081};
1082
1084class _XTP_EXT_CLASS CXTPSyntaxEditLexClass_file : public CXTPSyntaxEditLexClass
1085{
1086public:
1087 CXTPSyntaxEditLexClass_file();
1088 virtual ~CXTPSyntaxEditLexClass_file();
1089
1090 virtual CXTPSyntaxEditLexVariantPtr PropV(LPCTSTR propName);
1091
1092protected:
1093 virtual int RunParse(CTextIter* pTxtIter, CXTPSyntaxEditLexTextSchema* pTxtSch,
1094 CXTPSyntaxEditLexTextBlockPtr& rPtrTxtBlock,
1095 CXTPSyntaxEditLexOnScreenParseCnt* pOnScreenRunCnt = NULL);
1096
1097 virtual CXTPSyntaxEditLexClass* Clone(CXTPSyntaxEditLexClassSchema* pOwnerSch = NULL);
1098
1099 BOOL InternalInitExts(BOOL bReInit = FALSE);
1100 BOOL TestExt(LPCTSTR pcszExt) const;
1101
1102protected:
1103 BOOL m_bExtInitialized;
1104 CStringArray m_arExt;
1105};
1109
1110AFX_INLINE int CXTPSyntaxEditLexClass::StrCmp(LPCTSTR pcszStr1, LPCTSTR pcszStr2, int nLen,
1111 BOOL bCaseSensitive)
1112{
1113 if (bCaseSensitive)
1114 {
1115 return _tcsncmp(pcszStr1, pcszStr2, XTPToSizeTChecked(nLen));
1116 }
1117 return _tcsnicmp(pcszStr1, pcszStr2, XTPToSizeTChecked(nLen));
1118}
1120AFX_INLINE CString CXTPSyntaxEditLexClass::GetClassName() const
1121{
1122 return m_strClassName;
1123}
1124
1125AFX_INLINE CXTPSyntaxEditLexObj_ActiveTags* CXTPSyntaxEditLexClass::GetActiveTags()
1126{
1127 return &m_ActiveTags;
1128}
1129
1130AFX_INLINE int CXTPSyntaxEditLexClass::GetAttribute_int(LPCTSTR strName, BOOL bDyn,
1131 int nDefault) const
1132{
1133 CXTPSyntaxEditLexVariantPtr ptrAttrVal = GetAttribute(strName, bDyn);
1134 _ASSERTE(!ptrAttrVal || !!ptrAttrVal && ptrAttrVal->m_nObjType == xtpEditLVT_valInt);
1135
1136 if (!!ptrAttrVal && ptrAttrVal->m_nObjType == xtpEditLVT_valInt)
1137 {
1138 return ptrAttrVal->m_nValue;
1139 }
1140 return nDefault;
1141}
1142
1143AFX_INLINE BOOL CXTPSyntaxEditLexClass::GetAttribute_BOOL(LPCTSTR strName, BOOL bDyn,
1144 BOOL bDefault) const
1145{
1146 int nVal = GetAttribute_int(strName, bDyn, -1);
1147
1148 _ASSERTE(nVal == -1 || nVal == 0 || nVal == 1);
1149
1150 return (nVal == -1) ? bDefault : (nVal != 0);
1151}
1153AFX_INLINE BOOL CXTPSyntaxEditLexClass::IsRestartRunLoop()
1154{
1155 if (m_bRestartRunLoop_Cached < 0)
1156 {
1157 m_bRestartRunLoop_Cached = GetAttribute_BOOL(XTPLEX_ATTR_RESTARTRUNLOOP, FALSE, TRUE);
1158 }
1159 return m_bRestartRunLoop_Cached;
1160}
1162} // namespace XTPSyntaxEditLexAnalyser
1163
1164# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
1166#endif // !defined(__XTPSYNTAXEDITLEXCLASS_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPLEX_ATTRG_ONSCREENSCHCACHELIFETIME_SEC
static const TCHAR XTPLEX_ATTRG_ONSCREENSCHCACHELIFETIME_SEC[]
default= 180 sec; -1 and 0 means infinite; time out for on screen parsed pieces of text.
Definition XTPSyntaxEditLexClass.h:608
XTPLEX_ATTR_TXT_UNDERLINE
static const TCHAR XTPLEX_ATTR_TXT_UNDERLINE[]
Text font Underline flag.
Definition XTPSyntaxEditLexClass.h:575
XTPLEX_ATTR_ENDCLASSPARENT
static const TCHAR XTPLEX_ATTR_ENDCLASSPARENT[]
if set to 'this' the end block must have this class as parent.
Definition XTPSyntaxEditLexClass.h:588
XTPSyntaxEditLexClass_OptParent
XTPSyntaxEditLexClass_OptParent
Enumerates parent class relation for the Lex Class object.
Definition XTPSyntaxEditLexClass.h:534
xtpEditOptParent_file
@ xtpEditOptParent_file
Lex Class is the top in classes hierarchy: level file.
Definition XTPSyntaxEditLexClass.h:537
xtpEditOptParent_Default
@ xtpEditOptParent_Default
Use default relation value.
Definition XTPSyntaxEditLexClass.h:536
xtpEditOptParent_direct
@ xtpEditOptParent_direct
Lex Class can be child of specified parent class only directly.
Definition XTPSyntaxEditLexClass.h:538
xtpEditOptParent_dyn
@ xtpEditOptParent_dyn
Lex Class can be child of specified parent class dynamically.
Definition XTPSyntaxEditLexClass.h:540
xtpEditOptParent_Unknown
@ xtpEditOptParent_Unknown
Undefined value.
Definition XTPSyntaxEditLexClass.h:535
XTPLEX_ATTR_CASESENSITIVE
static const TCHAR XTPLEX_ATTR_CASESENSITIVE[]
Lex Class CaseSensitive flag.
Definition XTPSyntaxEditLexClass.h:577
XTPLEX_ATTR_COLLAPSABLE
static const TCHAR XTPLEX_ATTR_COLLAPSABLE[]
Lex Class Collapsable flag.
Definition XTPSyntaxEditLexClass.h:579
XTPLEX_ATTRG_CONFIGCHANGEDREPARCEINSEPARATETHREAD
static const TCHAR XTPLEX_ATTRG_CONFIGCHANGEDREPARCEINSEPARATETHREAD[]
{0,1} default=1
Definition XTPSyntaxEditLexClass.h:600
XTPLEX_ATTRG_EDITREPARCETIMEOUT_MS
static const TCHAR XTPLEX_ATTRG_EDITREPARCETIMEOUT_MS[]
time out for start reparse after last key was pressed.
Definition XTPSyntaxEditLexClass.h:602
XTPLEX_ATTR_TXTPREFIX
static const TCHAR XTPLEX_ATTR_TXTPREFIX[]
Class schema (public) attributes.
Definition XTPSyntaxEditLexClass.h:564
XTPLEX_ATTR_TXT_COLORSELFG
static const TCHAR XTPLEX_ATTR_TXT_COLORSELFG[]
Selected text color.
Definition XTPSyntaxEditLexClass.h:570
XTPLEX_ATTRG_FIRSTPARSEINSEPARATETHREAD
static const TCHAR XTPLEX_ATTRG_FIRSTPARSEINSEPARATETHREAD[]
{0,1} default=1
Definition XTPSyntaxEditLexClass.h:596
XTPLEX_ATTR_TXT_BOLD
static const TCHAR XTPLEX_ATTR_TXT_BOLD[]
Text font Bold flag.
Definition XTPSyntaxEditLexClass.h:573
XTPSyntaxEditLexVariantType
XTPSyntaxEditLexVariantType
Enumerates types of values which supported by CXTPSyntaxEditLexVariant class.
Definition XTPSyntaxEditLexClass.h:210
xtpEditLVT_classPtr
@ xtpEditLVT_classPtr
designates value of lex class Pointer type
Definition XTPSyntaxEditLexClass.h:214
xtpEditLVT_Unknown
@ xtpEditLVT_Unknown
designates unknown type of value
Definition XTPSyntaxEditLexClass.h:211
xtpEditLVT_className
@ xtpEditLVT_className
designates value of lex class name (or class names array) type
Definition XTPSyntaxEditLexClass.h:212
xtpEditLVT_valInt
@ xtpEditLVT_valInt
designates value of integer type
Definition XTPSyntaxEditLexClass.h:216
xtpEditLVT_valStr
@ xtpEditLVT_valStr
designates value of character string (or string array) type
Definition XTPSyntaxEditLexClass.h:217
xtpEditLVT_valVar
@ xtpEditLVT_valVar
designates value of lex variable
Definition XTPSyntaxEditLexClass.h:218
xtpEditLVT_LVArrayPtr
@ xtpEditLVT_LVArrayPtr
designates value of LexVariants array Pointer type
Definition XTPSyntaxEditLexClass.h:215
XTPLEX_ATTR_TXT_ITALIC
static const TCHAR XTPLEX_ATTR_TXT_ITALIC[]
Text font Italic flag.
Definition XTPSyntaxEditLexClass.h:574
XTPLEX_ATTR_RECURRENCEDEPTH
static const TCHAR XTPLEX_ATTR_RECURRENCEDEPTH[]
define depth of the recurrence blocks.
Definition XTPSyntaxEditLexClass.h:590
XTPLEX_ATTRG_EDITREPARCEINSEPARATETHREAD
static const TCHAR XTPLEX_ATTRG_EDITREPARCEINSEPARATETHREAD[]
{0,1} default=1
Definition XTPSyntaxEditLexClass.h:598
XTPLEX_ATTR_TXT_COLORBK
static const TCHAR XTPLEX_ATTR_TXT_COLORBK[]
Text back ground color.
Definition XTPSyntaxEditLexClass.h:569
XTPLEX_ATTRCLASSID
static const TCHAR XTPLEX_ATTRCLASSID[]
Lex Class ID, unique for the classes tree.
Definition XTPSyntaxEditLexClass.h:618
XTPLEX_ATTR_COLLAPSEDTEXT
static const TCHAR XTPLEX_ATTR_COLLAPSEDTEXT[]
Collapsed Lex Class mark text.
Definition XTPSyntaxEditLexClass.h:581
XTPSyntaxEditLexClass_OptChildren
XTPSyntaxEditLexClass_OptChildren
Enumerates children classes relation for the Lex Class object.
Definition XTPSyntaxEditLexClass.h:551
xtpEditOptChildren_List
@ xtpEditOptChildren_List
Lex Class can have only children from list and specified by their 'parent' property.
Definition XTPSyntaxEditLexClass.h:556
xtpEditOptChildren_Unknown
@ xtpEditOptChildren_Unknown
Undefined value.
Definition XTPSyntaxEditLexClass.h:552
xtpEditOptChildren_Any
@ xtpEditOptChildren_Any
Lex Class have children specified by their 'parent' property
Definition XTPSyntaxEditLexClass.h:554
xtpEditOptChildren_No
@ xtpEditOptChildren_No
Lex Class cannot have children.
Definition XTPSyntaxEditLexClass.h:553
XTPLEX_ATTR_RESTARTRUNLOOP
static const TCHAR XTPLEX_ATTR_RESTARTRUNLOOP[]
if set to 1 - run children loop will be restarted from the beginning when class ended,...
Definition XTPSyntaxEditLexClass.h:585
XTPLEX_ATTR_TXT_COLORFG
static const TCHAR XTPLEX_ATTR_TXT_COLORFG[]
Text color.
Definition XTPSyntaxEditLexClass.h:568
XTPLEX_ATTR_DISPLAYNAME
static const TCHAR XTPLEX_ATTR_DISPLAYNAME[]
Friendly name to display in options dialog.
Definition XTPSyntaxEditLexClass.h:592
XTPLEX_ATTR_PARSEONSCREEN
static const TCHAR XTPLEX_ATTR_PARSEONSCREEN[]
Parse Lex Class only for screen drawing.
Definition XTPSyntaxEditLexClass.h:583
XTPLEX_ATTRG_PARSERTHREADIDLELIFETIME_SEC
static const TCHAR XTPLEX_ATTRG_PARSERTHREADIDLELIFETIME_SEC[]
default=60 sec; -1 and 0 means infinite; time out for existing of parser thread when parser idle (no ...
Definition XTPSyntaxEditLexClass.h:612
XTPLEX_ATTR_COLORPREFIX
static const TCHAR XTPLEX_ATTR_COLORPREFIX[]
Prefix of properties which value is color.
Definition XTPSyntaxEditLexClass.h:566
XTPLEX_ATTRG_MAXBACKPARSEOFFSET
static const TCHAR XTPLEX_ATTRG_MAXBACKPARSEOFFSET[]
maximum back buffer size.
Definition XTPSyntaxEditLexClass.h:605
XTPLEX_ATTR_TXT_COLORSELBK
static const TCHAR XTPLEX_ATTR_TXT_COLORSELBK[]
Selected text back ground color.
Definition XTPSyntaxEditLexClass.h:571
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPInternalCollectionT
Definition XTPSmartPtrInternalT.h:387
CXTPSmartPtrInternalT< CXTPSyntaxEditLexClass >
CXTPSyntaxEditLexClass
CXTPSyntaxEditLexClass class is used to represent lexical block of text definition and to parse text.
Definition XTPSyntaxEditLexClass.h:633
CXTPSyntaxEditLexClass::CloseClasses
static void AFX_CDECL CloseClasses(CXTPSyntaxEditLexClassPtrArray *pArClasses)
Close specified Lex Classes.
CXTPSyntaxEditLexClass::IsCaseSensitive
virtual BOOL IsCaseSensitive()
Is Lex Class case sensitive.
CXTPSyntaxEditLexClass::RunParse
virtual int RunParse(CTextIter *pTxtIter, CXTPSyntaxEditLexTextSchema *pTxtSch, CXTPSyntaxEditLexTextBlockPtr &rPtrTxtBlock, CXTPSyntaxEditLexOnScreenParseCnt *pOnScreenRunCnt=NULL)
This function does the parsing.
CXTPSyntaxEditLexClass::TBase
CXTPSyntaxEditLexObj_SpecCollT< CXTPSyntaxEditLexObj_Previous, CXTPSyntaxEditLexObj_Start, CXTPSyntaxEditLexObj_End, CXTPSyntaxEditLexObj_Token, CXTPSyntaxEditLexObj_Skip, CXTPSyntaxEditLexObj_ActiveTags > TBase
CXTPSyntaxEditLexClass::TBase is the base collection type for CXTPSyntaxEditLexClass.
Definition XTPSyntaxEditLexClass.h:645
CXTPSyntaxEditLexClass::GetChildrenDyn
virtual CXTPSyntaxEditLexClassPtrArray * GetChildrenDyn()
Get specified children for the Lex Class.
CXTPSyntaxEditLexClass::GetAttribute_int
virtual int GetAttribute_int(LPCTSTR strName, BOOL bDyn, int nDefault=0) const
Get Lex Class attribute by attribute name.
Definition XTPSyntaxEditLexClass.h:1130
CXTPSyntaxEditLexClass::CXTPSyntaxEditLexClass
CXTPSyntaxEditLexClass()
Default object constructor.
CXTPSyntaxEditLexClass::GetTextAttributes
virtual void GetTextAttributes(XTP_EDIT_TEXTBLOCK &rTB)
Is Lex Class Collapsable.
CXTPSyntaxEditLexClass::GetActiveTags
virtual CXTPSyntaxEditLexObj_ActiveTags * GetActiveTags()
Get active tags for the Lex Class.
Definition XTPSyntaxEditLexClass.h:1125
CXTPSyntaxEditLexClass::IsCollapsable
virtual int IsCollapsable()
Is Lex Class Collapsable.
CXTPSyntaxEditLexClass::~CXTPSyntaxEditLexClass
virtual ~CXTPSyntaxEditLexClass()
Default object destructor.
CXTPSyntaxEditLexClass::PropV
virtual CXTPSyntaxEditLexVariantPtr PropV(LPCTSTR pcszPropName)
Get object property by property name.
CXTPSyntaxEditLexClass::GetAttribute_BOOL
virtual BOOL GetAttribute_BOOL(LPCTSTR strName, BOOL bDyn, BOOL bDefault=FALSE) const
Get Lex Class attribute by attribute name.
Definition XTPSyntaxEditLexClass.h:1143
CXTPSyntaxEditLexClass::GetAttribute
virtual CXTPSyntaxEditLexVariantPtr GetAttribute(LPCTSTR strName, BOOL bDyn) const
Get Lex Class attribute by attribute name.
CXTPSyntaxEditLexClass::SetAttribute
virtual void SetAttribute(CString strName, const CXTPSyntaxEditLexVariant &rVal)
Sets Lex Class attribute.
CXTPSyntaxEditLexClass::m_nActiv_EndTags_Offset
int m_nActiv_EndTags_Offset
First index of end active tags set in the Active Tags collection (m_ActiveTags member).
Definition XTPSyntaxEditLexClass.h:676
CXTPSyntaxEditLexClass::Close
virtual void Close()
Close Lex Class.
CXTPSyntaxEditLexClass::GetChildren
virtual CXTPSyntaxEditLexClassPtrArray * GetChildren()
Get specified children for the Lex Class.
CXTPSyntaxEditLexClass::GetChildrenSelfRef
virtual CXTPSyntaxEditLexClassPtrArray * GetChildrenSelfRef()
Get specified children for the Lex Class.
CXTPSyntaxEditLexClass::GetClassName
virtual CString GetClassName() const
Get Lex Class name.
Definition XTPSyntaxEditLexClass.h:1120
CXTPSyntaxEditLexOnScreenParseCnt
CXTPSyntaxEditLexOnScreenParseCnt provides context data storage for OnScreen iterated parsing process...
Definition XTPSyntaxEditLexClass.h:508
CXTPSyntaxEditLexOnScreenParseCnt::~CXTPSyntaxEditLexOnScreenParseCnt
virtual ~CXTPSyntaxEditLexOnScreenParseCnt()
Default object destructor.
CXTPSyntaxEditLexOnScreenParseCnt::m_ptrTBLast
CXTPSyntaxEditLexTextBlockPtr m_ptrTBLast
Latest found text block.
Definition XTPSyntaxEditLexClass.h:524
CXTPSyntaxEditLexOnScreenParseCnt::CXTPSyntaxEditLexOnScreenParseCnt
CXTPSyntaxEditLexOnScreenParseCnt()
Default object constructor.
CXTPSyntaxEditLexOnScreenParseCnt::m_nRowStart
int m_nRowStart
Start row for parse.
Definition XTPSyntaxEditLexClass.h:522
CXTPSyntaxEditLexOnScreenParseCnt::m_nRowEnd
int m_nRowEnd
End row for parse.
Definition XTPSyntaxEditLexClass.h:523
CXTPSyntaxEditLexParser
This class used to 'run' lex schema parsing in a separate thread.
Definition XTPSyntaxEditLexParser.h:861
CXTPSyntaxEditLexTextBlock
The CXTPSyntaxEditLexTextBlock class represents a block of text which corresponds to a lex class in a...
Definition XTPSyntaxEditLexParser.h:266
CXTPSyntaxEditLexTextSchema
The CXTPSyntaxEditLexTextSchema class is used to store data which is necessary to parse a text and pa...
Definition XTPSyntaxEditLexParser.h:428
CXTPSyntaxEditLexVariable
XTPSyntaxEditLexAnalyser namespace is used group text parser classes, separate them from others and t...
Definition XTPSyntaxEditLexClass.h:56
CXTPSyntaxEditLexVariable::SetVariable
virtual BOOL SetVariable(LPCTSTR pcszVarName)
Set object members using string lex variable representation.
CXTPSyntaxEditLexVariable::GetVarID
static int AFX_CDECL GetVarID(LPCTSTR pcszVarName)
Determine standard lex variable ID using string lex variable representation.
CXTPSyntaxEditLexVariable::m_nVarFlags
int m_nVarFlags
Additional lex variable properties (flags).
Definition XTPSyntaxEditLexClass.h:110
CXTPSyntaxEditLexVariable::XTPSyntaxEditLexVarID
XTPSyntaxEditLexVarID
XTPSyntaxEditLexVarID type defines the constants used to identify standard lexical variables: @alpha,...
Definition XTPSyntaxEditLexClass.h:82
CXTPSyntaxEditLexVariable::XTPSyntaxEditLexVarFlags
XTPSyntaxEditLexVarFlags
XTPSyntaxEditLexVarFlags type defines the constants used to specify additional lex variable propertie...
Definition XTPSyntaxEditLexClass.h:103
CXTPSyntaxEditLexVariable::GetVariableData
static BOOL AFX_CDECL GetVariableData(int nVarID, CStringArray &rarVarData)
This method is used to get lex variable chars.
CXTPSyntaxEditLexVariable::~CXTPSyntaxEditLexVariable
virtual ~CXTPSyntaxEditLexVariable()
Default object destructor.
CXTPSyntaxEditLexVariable::CXTPSyntaxEditLexVariable
CXTPSyntaxEditLexVariable()
Default object constructor.
CXTPSyntaxEditLexVariable::InitStandartVarsIfNeed
static void AFX_CDECL InitStandartVarsIfNeed()
Initialize internal Lex variable name to ID map.
CXTPSyntaxEditLexVariable::operator==
BOOL operator==(const CXTPSyntaxEditLexVariable &rSrc) const
Equal-to operator.
CXTPSyntaxEditLexVariable::m_nVarID
int m_nVarID
Lex variable identifier.
Definition XTPSyntaxEditLexClass.h:108
CXTPSyntaxEditLexVariable::s_bVarMapInitialized
static BOOL s_bVarMapInitialized
Is initialized state of the lex variable name to ID map.
Definition XTPSyntaxEditLexClass.h:201
CXTPSyntaxEditLexVariable::s_mapVar2ID
static CMapStringToPtr s_mapVar2ID
Lex variable name to ID map.
Definition XTPSyntaxEditLexClass.h:200
CXTPSyntaxEditLexVariable::m_strVar
CString m_strVar
Lex variable.
Definition XTPSyntaxEditLexClass.h:109
CXTPSyntaxEditLexVariable::operator=
const CXTPSyntaxEditLexVariable & operator=(const CXTPSyntaxEditLexVariable &rSrc)
Copy operator.
CXTPSyntaxEditLexVariant
CXTPSyntaxEditLexVariant provides functionality to manipulate Lexical Analyzer's related variant type...
Definition XTPSyntaxEditLexClass.h:230
CXTPSyntaxEditLexVariant::SetVariable
virtual BOOL SetVariable(LPCTSTR pcszVarName)
Set object members using string lex variable representation.
CXTPSyntaxEditLexVariant::m_ptrLVArrayPtr
CXTPSyntaxEditLexVariantPtrArray * m_ptrLVArrayPtr
Value storage for type xtpEditLVT_LVArrayPtr
Definition XTPSyntaxEditLexClass.h:364
CXTPSyntaxEditLexVariant::CXTPSyntaxEditLexVariant
CXTPSyntaxEditLexVariant(CXTPSyntaxEditLexVariantPtrArray *pLVArray)
Object constructor.
CXTPSyntaxEditLexVariant::m_nValue
int m_nValue
Value storage for type xtpEditLVT_valInt
Definition XTPSyntaxEditLexClass.h:367
CXTPSyntaxEditLexVariant::GetStr
virtual LPCTSTR GetStr() const
Get string for the string type variant object.
CXTPSyntaxEditLexVariant::CXTPSyntaxEditLexVariant
CXTPSyntaxEditLexVariant(const CStringArray *pArStrVals)
Object constructor.
CXTPSyntaxEditLexVariant::CXTPSyntaxEditLexVariant
CXTPSyntaxEditLexVariant()
Object constructor.
CXTPSyntaxEditLexVariant::CXTPSyntaxEditLexVariant
CXTPSyntaxEditLexVariant(CXTPSyntaxEditLexClass *pClass)
Object constructor.
CXTPSyntaxEditLexVariant::~CXTPSyntaxEditLexVariant
virtual ~CXTPSyntaxEditLexVariant()
Default object destructor.
CXTPSyntaxEditLexVariant::operator=
const CXTPSyntaxEditLexVariant & operator=(int nVal)
Copy operator.
CXTPSyntaxEditLexVariant::CXTPSyntaxEditLexVariant
CXTPSyntaxEditLexVariant(const CXTPSyntaxEditLexVariable &rSrcVar)
Object constructor.
CXTPSyntaxEditLexVariant::CXTPSyntaxEditLexVariant
CXTPSyntaxEditLexVariant(int nValue)
Object constructor.
CXTPSyntaxEditLexVariant::operator=
const CXTPSyntaxEditLexVariant & operator=(const CXTPSyntaxEditLexVariant &rSrc)
Copy operator.
CXTPSyntaxEditLexVariant::IsStrType
virtual BOOL IsStrType() const
Is variant object contains string(s).
CXTPSyntaxEditLexVariant::operator=
const CXTPSyntaxEditLexVariant & operator=(const CXTPSyntaxEditLexVariable &rSrcVar)
Copy operator.
CXTPSyntaxEditLexVariant::m_nObjType
int m_nObjType
Object type value from XTPSyntaxEditLexVariantType.
Definition XTPSyntaxEditLexClass.h:360
CXTPSyntaxEditLexVariant::operator==
BOOL operator==(const CXTPSyntaxEditLexVariant &rSrc) const
Equal-to operator.
CXTPSyntaxEditLexVariant::CXTPSyntaxEditLexVariant
CXTPSyntaxEditLexVariant(LPCTSTR pcszStr, int eType=xtpEditLVT_valStr)
Object constructor.
CXTPSyntaxEditLexVariant::m_Variable
CXTPSyntaxEditLexVariable m_Variable
Value storage for type xtpEditLVT_valVar
Definition XTPSyntaxEditLexClass.h:371
CXTPSyntaxEditLexVariant::m_ptrClass
CXTPSyntaxEditLexClassPtr m_ptrClass
Value storage for type xtpEditLVT_classPtr
Definition XTPSyntaxEditLexClass.h:362
CXTPSyntaxEditLexVariant::Clone
virtual CXTPSyntaxEditLexVariant * Clone() const
Clone variant object.
CXTPSyntaxEditLexVariant::CXTPSyntaxEditLexVariant
CXTPSyntaxEditLexVariant(const CXTPSyntaxEditLexVariant &rSrc)
Object constructor.
CXTPSyntaxEditLexVariant::m_arStrVals
CStringArray m_arStrVals
Value storage for types xtpEditLVT_className , xtpEditLVT_valStr
Definition XTPSyntaxEditLexClass.h:368
XTP_EDIT_LINECOL
The XTP_EDIT_LINECOL structure represents the coordinates of text items on the displaying context in ...
Definition XTPSyntaxEditStruct.h:54
XTP_EDIT_TEXTBLOCK
Summary The XTP_EDIT_TEXTBLOCK structure stores the text blocks after parsing.
Definition XTPSyntaxEditStruct.h:286


Toolkit Pro: Member List

CXTPCommandBarsOffice2003Theme Member List

This is the complete list of members for CXTPCommandBarsOffice2003Theme, including all inherited members.

AdjustExcludeRect(CRect &rc, CXTPControl *pControl, BOOL bVertical) | CXTPCommandBarsOfficeXPTheme | virtual
Animate(CDC *pDestDC, CDC *pSrcDC, CRect rc, XTPAnimationType animationType) | CXTPPaintManager | virtual
AnimateExpanding(CXTPCommandBar *pCommandBar, CDC *pDestDC, CDC *pSrcDC, BOOL bExpandDown) | CXTPPaintManager | virtual
BaseTheme() | CXTPCommandBarsOffice2003Theme | inlineprotectedvirtual
CreateGradientCircle() | CXTPCommandBarsOffice2003Theme | protected
CreateTheme(XTPPaintTheme paintTheme) | CXTPPaintManager | static
CXTPCmdTarget() | CXTPCmdTarget |
CXTPCommandBarsOffice2003Theme() | CXTPCommandBarsOffice2003Theme |
CXTPCommandBarsOfficeXPTheme() | CXTPCommandBarsOfficeXPTheme |
CXTPObservable() | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | protected
CXTPPaintManager() | CXTPPaintManager | protected
Draw3dRect(CDC *pDC, LPCRECT rc, int nTopLeft, int nBottomRight) | CXTPPaintManager |
Draw3dRect(CDC *pDC, LPCRECT rc, int frameThickness, COLORREF clrPen, COLORREF clrBrush) | CXTPPaintManager |
CXTPPaintManager::DrawCheckMark(CDC *pDC, CRect rcCheck, COLORREF clr=0) | CXTPPaintManager | inline
DrawComboExpandMark(CDC *pDC, CRect rc, COLORREF clr) | CXTPPaintManager | virtual
DrawCommandBarGripper(CDC *pDC, CXTPCommandBar *pBar, BOOL bDraw=TRUE) | CXTPCommandBarsOffice2003Theme | protectedvirtual
DrawCommandBarGroupSeparator(CDC *pDC, CXTPCommandBar *pBar, CXTPControl *pLeftControl, CXTPControl *pRightControl, BOOL bDraw=TRUE) | CXTPPaintManager | virtual
DrawCommandBarSeparator(CDC *pDC, CXTPCommandBar *pBar, CXTPControl *pControl, BOOL bDraw=TRUE) | CXTPCommandBarsOffice2003Theme | protectedvirtual
DrawControl(CDC *pDC, CXTPControl *pButton, BOOL bDraw=TRUE) | CXTPPaintManager |
DrawControlCheckBoxMark(CDC *pDC, CRect rc, BOOL bDraw, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled) | CXTPCommandBarsOfficeXPTheme | protectedvirtual
DrawControlCheckBoxMark(CDC *pDC, CXTPControl *pButton, CRect rc, BOOL bDraw) | CXTPCommandBarsOfficeXPTheme | protectedvirtual
DrawControlComboBox(CDC *pDC, CXTPControlComboBox *pComboBox, BOOL bDraw) | CXTPCommandBarsOfficeXPTheme | protectedvirtual
DrawControlEdit(CDC *pDC, CXTPControlEdit *pEdit, BOOL bDraw) | CXTPCommandBarsOfficeXPTheme | protectedvirtual
DrawControlEntry(CDC *pDC, CXTPControl *pButton) | CXTPPaintManager | virtual
DrawControlMDIButton(CDC *pDC, CXTPControlButton *pButton) | CXTPPaintManager | virtual
DrawControlPopupParent(CDC *pDC, CXTPControl *pButton, BOOL bDraw) | CXTPCommandBarsOfficeXPTheme | protectedvirtual
DrawControlRadioButtonMark(CDC *pDC, CRect rc, BOOL bDraw, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled) | CXTPCommandBarsOfficeXPTheme | protectedvirtual
DrawControlText(CDC *pDC, CXTPControl *pControl, CRect rcText, BOOL bDraw, BOOL bVert, BOOL bCentered, BOOL bTriangled) | CXTPPaintManager |
DrawControlToolBarParent(CDC *pDC, CXTPControl *pButton, BOOL bDraw) | CXTPPaintManager | virtual
DrawDialogBarGripper(CDC *pDC, CXTPDialogBar *pBar, BOOL bDraw) | CXTPCommandBarsOffice2003Theme | protectedvirtual
DrawDropDownGlyph(CDC *pDC, CXTPControl *pControl, CPoint pt, BOOL bSelected, BOOL bPopuped, BOOL bEnabled, BOOL bVert) | CXTPPaintManager | virtual
DrawExpandGlyph(CDC *pDC, CXTPControl *pButton, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clr) | CXTPPaintManager | virtual
DrawExpandGlyph(CDC *pDC, CXTPControl *pButton, COLORREF clr, BOOL bVertical) | CXTPPaintManager | virtual
DrawGalleryItemBack(CDC *pDC, CRect rcItem, BOOL bEnabled, BOOL bSelected, BOOL bPressed, BOOL bChecked, XTPBarType barType) | CXTPPaintManager | virtual
DrawHiddenGlyph(CDC *pDC, CXTPControl *pButton, COLORREF clr, BOOL bVertical) | CXTPPaintManager | virtual
DrawImage(CDC *pDC, CPoint pt, CSize sz, CXTPImageManagerIcon *pImage, BOOL bSelected, BOOL bPressed, BOOL bEnabled=TRUE, BOOL bChecked=FALSE, BOOL bPopuped=FALSE, BOOL bToolBarImage=TRUE) | CXTPCommandBarsOfficeXPTheme | protectedvirtual
DrawListBoxControl(CDC *pDC, CXTPControl *pButton, CRect rc, BOOL bSelected, BOOL bDraw, CXTPCommandBars *pCommandBars=0) | CXTPCommandBarsOfficeXPTheme | virtual
DrawPopupBarCheckMark(CDC *pDC, CRect rcCheck, BOOL bEnabled, COLORREF clr) | CXTPPaintManager | virtual
DrawPopupBarGripper(CDC *pDC, int xPos, int yPos, int cx, int cy, BOOL bExpanded=FALSE) | CXTPCommandBarsOffice2003Theme | protectedvirtual
DrawPopupBarRadioMark(CDC *pDC, CRect rcCheck, BOOL bEnabled, COLORREF clr) | CXTPPaintManager | virtual
DrawPopupResizeGripper(CDC *pDC, CRect rcGripper, int nFlags) | CXTPCommandBarsOfficeXPTheme | virtual
DrawRectangle(CDC *pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition) | CXTPCommandBarsOffice2003Theme | protectedvirtual
DrawRectangle(CDC *pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition, int nID) | CXTPCommandBarsOffice2003Theme | protectedvirtual
DrawRectangle(CDC *pDC, CXTPControl *pButton) | CXTPCommandBarsOffice2003Theme | protectedvirtual
DrawSpecialControl(CDC *pDC, XTPSpecialControl controlType, CXTPControl *pButton, CXTPCommandBar *pBar, BOOL bDraw, LPVOID lpParam) | CXTPCommandBarsOffice2003Theme | protectedvirtual
DrawSplitButtonFrame(CDC *pDC, CXTPControl *pButton, CRect rc) | CXTPCommandBarsOfficeXPTheme | protectedvirtual
DrawTearOffGripper(CDC *pDC, CRect rcGripper, BOOL bSelected, BOOL bDraw) | CXTPCommandBarsOffice2003Theme | protectedvirtual
ExcludeCorners(CDC *pDC, CRect rc) | CXTPCommandBarsOffice2003Theme |
FillCommandBarEntry(CDC *pDC, CXTPCommandBar *pBar) | CXTPCommandBarsOffice2003Theme | protectedvirtual
FillDockBar(CDC *pDC, CXTPDockBar *pBar) | CXTPCommandBarsOffice2003Theme | protectedvirtual
FillIntersectRect(CDC *pDC, CXTPPopupBar *pPopupBar, COLORREF clr) | CXTPCommandBarsOfficeXPTheme | protected
FillWorkspace(CDC *pDC, CRect rc, CRect rcExclude) | CXTPPaintManager | virtual
FontExists(LPCTSTR lpszFaceName) | CXTPPaintManager | static
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCommandBarBorders(CXTPCommandBar *pBar) | CXTPCommandBarsOffice2003Theme | protectedvirtual
GetCommandBarFont(CXTPCommandBar *pCommandBar) | CXTPPaintManager | virtual
GetControlBackColor(CXTPControl *pButton) | CXTPPaintManager | virtual
GetControlEditBackColor(CXTPControl *pControl) | CXTPPaintManager | virtual
GetControlFont(CXTPControl *pControl) | CXTPPaintManager | virtual
GetControlHeight() const | CXTPPaintManager |
GetControlTextColor(CXTPControl *pButton) | CXTPPaintManager | virtual
GetControlTextOrientation(CXTPControl *pControl) | CXTPPaintManager | virtual
GetCurrentSystemTheme() | CXTPPaintManager |
GetCurrentTheme() | CXTPPaintManager | inline
GetDefaultCommandBarSize(CXTPCommandBar *pBar) | CXTPPaintManager | virtual
GetFramePaintManager() | CXTPPaintManager | virtual
GetGalleryPaintManager() const | CXTPPaintManager | virtual
GetGlobalPaintManager() | CXTPPaintManager | static
GetIconFont() | CXTPPaintManager |
GetIconsInfo() | CXTPPaintManager |
GetInstanceAddRef() | CXTPPaintManager | static
GetMessageBarPaintManager() | CXTPPaintManager | virtual
GetModernBitmap(UINT nIDResource) | CXTPCommandBarsOffice2003Theme | static
GetPopupBarGripperWidth(CXTPCommandBar *pBar) | CXTPPaintManager | virtual
GetProgressPaintManager() const | CXTPPaintManager | virtual
GetRectangleTextColor(BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition) | CXTPCommandBarsOfficeXPTheme | virtual
GetRegularBoldFont() | CXTPPaintManager |
GetRegularFont() | CXTPPaintManager |
GetRibbonPaintManager() | CXTPPaintManager | virtual
GetScrollBarPaintManager() const | CXTPPaintManager | virtual
GetShadowManager() const | CXTPPaintManager |
GetShadowOptions() const | CXTPPaintManager |
GetSliderPaintManager() const | CXTPPaintManager | virtual
GetSmCaptionFont() | CXTPPaintManager |
GetSplitButtonCommandRect(CXTPControl *pButton) | CXTPPaintManager | virtual
GetStatusBarPaintManager() | CXTPPaintManager | virtual
GetXtremeColor(UINT nIndex) | CXTPPaintManager |
GradientFill(CDC *pDC, LPRECT lpRect, COLORREF crFrom, COLORREF crTo, BOOL bHorz, LPCRECT lpRectClip=NULL) | CXTPPaintManager |
HasFloatingBarGradientEntry(CXTPCommandBar *pBar) | CXTPCommandBarsOffice2003Theme | protectedvirtual
HorizontalLine(CDC *pDC, int x0, int y0, int x1, COLORREF clrPen) | CXTPPaintManager |
IsUseSystemAccentColorEnabled() const | CXTPPaintManager |
Line(CDC *pDC, CPoint p0, CPoint p1) | CXTPPaintManager |
Line(CDC *pDC, int x0, int y0, int x1, int y1, const int nPen) | CXTPPaintManager |
Line(CDC *pDC, int x0, int y0, int x1, int y1, COLORREF clrPen) | CXTPPaintManager |
LoadModernToolbarIcons(UINT nIDResource) | CXTPCommandBarsOffice2003Theme | static
LoadModernToolbarIcons(UINT nIDResource, UINT *pCommands, int nCount, CSize szIcon=CSize(16, 15)) | CXTPCommandBarsOffice2003Theme | static
m_arrColor | CXTPPaintManager | protected
m_bAutoResizeIcons | CXTPPaintManager |
m_bClearTypeTextQuality | CXTPPaintManager |
m_bEmbossedDisabledText | CXTPPaintManager | protected
m_bEnableAnimation | CXTPPaintManager |
m_bFlatMenuBar | CXTPPaintManager |
m_bFlatToolBar | CXTPPaintManager |
m_bLunaTheme | CXTPCommandBarsOffice2003Theme |
m_bOffice2007Padding | CXTPPaintManager |
m_bOffsetPopupLabelText | CXTPPaintManager |
m_bPlainSeparators | CXTPCommandBarsOffice2003Theme |
m_bSelectImageInPopupBar | CXTPPaintManager |
m_bShowKeyboardCues | CXTPPaintManager | protected
m_bShowShadow | CXTPPaintManager |
m_bThemedCheckBox | CXTPPaintManager |
m_bThemedStatusBar | CXTPPaintManager |
m_bThickCheckMark | CXTPPaintManager |
m_bUseOfficeFont | CXTPPaintManager |
m_bUseStandardFont | CXTPPaintManager | protected
m_bWrapCaptionBelowText | CXTPPaintManager |
m_clrCommandBar | CXTPCommandBarsOffice2003Theme |
m_clrDisabledIcon | CXTPPaintManager |
m_clrDockBar | CXTPCommandBarsOffice2003Theme |
m_clrFloatingGripper | CXTPPaintManager |
m_clrFloatingGripperText | CXTPPaintManager |
m_clrMenuExpand | CXTPCommandBarsOffice2003Theme |
m_clrMenuExpandedGripper | CXTPCommandBarsOffice2003Theme |
m_clrMenuGripper | CXTPCommandBarsOffice2003Theme |
m_clrMessageBarText | CXTPPaintManager |
m_clrPopupControl | CXTPCommandBarsOffice2003Theme |
m_clrTearOffGripper | CXTPCommandBarsOffice2003Theme |
m_clrToolbarExpand | CXTPCommandBarsOffice2003Theme |
m_clrToolbarShadow | CXTPCommandBarsOffice2003Theme |
m_fontIcon | CXTPPaintManager |
m_fontIconBold | CXTPPaintManager |
m_fontSmCaption | CXTPPaintManager |
m_fontToolTip | CXTPPaintManager |
m_grcLunaChecked | CXTPCommandBarsOffice2003Theme |
m_grcLunaPushed | CXTPCommandBarsOffice2003Theme |
m_grcLunaSelected | CXTPCommandBarsOffice2003Theme |
m_iconsInfo | CXTPPaintManager | protected
m_ilGradientCircle | CXTPCommandBarsOffice2003Theme |
m_nAnimationSteps | CXTPPaintManager | protected
m_nAnimationTime | CXTPPaintManager | protected
m_nEditHeight | CXTPPaintManager | protected
m_nFontHeight | CXTPPaintManager | protected
m_nPopupBarTextPadding | CXTPPaintManager |
m_nSplitButtonDropDownHeight | CXTPPaintManager |
m_nSplitButtonDropDownWidth | CXTPPaintManager |
m_nSplitButtonPopupWidth | CXTPPaintManager |
m_nStatusBarMinHeight | CXTPPaintManager |
m_nTextHeight | CXTPPaintManager |
m_pfnSetLayeredWindowAttributes | CXTPPaintManager |
m_pFramePaintManager | CXTPPaintManager |
m_pGalleryPaintManager | CXTPPaintManager |
m_pProgressPaintManager | CXTPPaintManager |
m_pRibbonPaintManager | CXTPPaintManager |
m_pScrollBarPaintManager | CXTPPaintManager |
m_pShadowManager | CXTPPaintManager | protected
m_pSliderPaintManager | CXTPPaintManager |
m_pStatusBarPaintManager | CXTPPaintManager |
m_rcMessageBarMargin | CXTPPaintManager |
m_rcStatusBarBorder | CXTPPaintManager |
m_strOfficeFont | CXTPPaintManager |
m_systemTheme | CXTPPaintManager | protected
m_themeButton | CXTPPaintManager | protected
m_themeCurrent | CXTPPaintManager | protected
m_themeStatusBar | CXTPPaintManager | protected
m_xtpFontRegular | CXTPPaintManager | protected
m_xtpFontRegularBold | CXTPPaintManager | protected
m_xtpFontVert | CXTPPaintManager | protected
m_xtpFontVertBold | CXTPPaintManager | protected
Notify(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *)) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
Notify(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1), A1 arg1) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
Notify(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
Notify(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamic(void(T::*method)(O *)) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1), A1 arg1) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *)) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1), A1 arg1) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyReversed(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *)) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyReversed(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1), A1 arg1) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyReversed(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyReversed(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
Pixel(CDC *pDC, int xPos, int yPos, int nPen) | CXTPPaintManager |
Rectangle(CDC *pDC, LPCRECT rc, int nPen, const int nBrush) | CXTPPaintManager |
Rectangle(CDC *pDC, LPCRECT rc, COLORREF clrPen, COLORREF clrBrush) | CXTPPaintManager |
RefreshMetrics() | CXTPCommandBarsOffice2003Theme | protectedvirtual
ReleaseInstance() | CXTPPaintManager | static
RequiresResourceImages() | CXTPPaintManager | virtual
RoundRect(CDC *pDC, LPCRECT rc, COLORREF clrPen, COLORREF clrBrush) | CXTPPaintManager |
SetAnimationDelay(int nAnimationSteps, int nAnimationTime) | CXTPPaintManager |
SetColors(int cElements, CONST INT *lpaElements, CONST COLORREF *lpaRgbValues) | CXTPPaintManager |
SetCommandBarRegion(CXTPCommandBar *pCommandBar) | CXTPPaintManager | virtual
SetCommandBarsFontIndirect(LOGFONT *pLogFont, BOOL bUseStandardFont=FALSE) | CXTPPaintManager |
SetCustomTheme(CXTPPaintManager *pTheme) | CXTPPaintManager | static
SetGlobalPaintManager(CXTPPaintManager *pPaintManager) | CXTPPaintManager | static
SetImageHandle(HMODULE hResource, LPCTSTR lpszIniFileName) | CXTPPaintManager | virtual
SetLunaTheme(XTPCurrentSystemTheme systemTheme) | CXTPPaintManager |
SetTheme(XTPPaintTheme paintTheme) | CXTPPaintManager | static
StripMnemonics(CString &strClear) | CXTPPaintManager | static
Subscribe(IXTPPaintManagerEvents *pObserver, CXTPSubscriptionList< CXTPPaintManager, IXTPPaintManagerEvents > *pSubcriptionList=NULL) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > |
Triangle(CDC *pDC, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clr) | CXTPPaintManager | static
Unsubscribe(IXTPPaintManagerEvents *pObserver) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > |
UpdateColors() | CXTPPaintManager | virtual
UpdateFonts() | CXTPPaintManager | virtual
UpdateRTLCaption(CString &strCaption) | CXTPPaintManager | virtual
UseOfficeFont(bool bUseOfficeFont) | CXTPPaintManager |
VerticalLine(CDC *pDC, int x0, int y0, int y1, COLORREF clrPen) | CXTPPaintManager |
~CXTPCommandBarsOffice2003Theme() | CXTPCommandBarsOffice2003Theme | virtual
~CXTPObservable() | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | protected
~CXTPPaintManager() | CXTPPaintManager | protectedvirtual


Toolkit Pro: Member List

CXTPStatusBarThemeVisualStudio2015 Member List

This is the complete list of members for CXTPStatusBarThemeVisualStudio2015, including all inherited members.

CXTPStatusBarThemeOffice2013(CXTPPaintManager *pPaintManager) | CXTPStatusBarThemeOffice2013 |
CXTPStatusBarThemeVisualStudio2015(CXTPPaintManager *pPaintManager) | CXTPStatusBarThemeVisualStudio2015 |
DrawStatusBarButtonFace(CDC *pDC, CRect rcItem, CXTPStatusBarPane *pPane) | CXTPStatusBarThemeOffice2013 | virtual
DrawStatusBarGripper(CDC *pDC, CRect rcClient) | CXTPStatusBarThemeVisualStudio2015 | virtual
DrawStatusBarPaneBorder(CDC *pDC, CRect rc, CXTPStatusBarPane *pPane, BOOL bGripperPane) | CXTPStatusBarThemeOffice2013 | virtual
DrawStatusBarPaneEntry(CDC *pDC, CRect rcItem, CXTPStatusBarPane *pPane) | CXTPStatusBarThemeOffice2013 | virtual
DrawStatusBarPaneSeparator(CDC *pDC, CRect rc, CXTPStatusBarPane *pPane) | CXTPStatusBarThemeOffice2013 | virtual
DrawStatusBarSwitchPane(CDC *pDC, CRect rcItem, CXTPStatusBarSwitchPane *pPane) | CXTPStatusBarThemeOffice2013 | virtual
FillStatusBar(CDC *pDC, CXTPStatusBar *pBar) | CXTPStatusBarThemeOffice2013 | virtual
GetStateColor() const | CXTPStatusBarThemeVisualStudio2015 | virtual
GetTextColor(CXTPStatusBarPane *pPane) | CXTPStatusBarThemeOffice2013 | virtual
m_clrButtonBack | CXTPStatusBarThemeOffice2013 | protected
m_clrButtonBackChecked | CXTPStatusBarThemeOffice2013 | protected
m_clrButtonBackHighlight | CXTPStatusBarThemeOffice2013 | protected
m_clrButtonBackPushed | CXTPStatusBarThemeOffice2013 | protected
m_clrButtonTextChecked | CXTPStatusBarThemeOffice2013 | protected
m_clrButtonTextHighlight | CXTPStatusBarThemeOffice2013 | protected
m_clrButtonTextPushed | CXTPStatusBarThemeOffice2013 | protected
RefreshMetrics() | CXTPStatusBarThemeVisualStudio2015 | virtual
SetStateColor(COLORREF clrState) | CXTPStatusBarThemeVisualStudio2015 | virtual
~CXTPStatusBarThemeVisualStudio2015() | CXTPStatusBarThemeVisualStudio2015 |


Toolkit Pro: Member List

CXTPChartScaleTypeMap Member List

This is the complete list of members for CXTPChartScaleTypeMap, including all inherited members.

Create(CXTPChartAxis *pAxis) | CXTPChartScaleTypeMap | static
CXTPChartElement() | CXTPChartElement |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartScaleTypeMap(CXTPChartAxis *pAxis) | CXTPChartScaleTypeMap |
DoPropExchange(CXTPPropExchange *pPX) | CXTPChartElement | virtual
GetAppearance() const | CXTPChartElement |
GetAxis() const | CXTPChartScaleTypeMap |
GetContent() const | CXTPChartElement |
GetOwner() const | CXTPChartElement |
InternalToValue(CXTPChartNumberFormat *pFromat, double dValue) const =0 | CXTPChartScaleTypeMap | pure virtual
Is3D() const | CXTPChartObject |
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartElement | virtual
Release() | CXTPChartElement | virtual
UpdateSeries(CXTPChartAxisView *pAxisView) | CXTPChartScaleTypeMap | virtual
UpdateSeries(CXTPChartSeries *pSeries) | CXTPChartScaleTypeMap | virtual
UpdateSeriesPointArgument(CXTPChartSeriesPoint *pPoint) | CXTPChartScaleTypeMap | virtual
ValueToInternal(const CXTPChartString &strValue) const =0 | CXTPChartScaleTypeMap | pure virtual
~CXTPChartElement() | CXTPChartElement | virtual
~CXTPChartScaleTypeMap() | CXTPChartScaleTypeMap | virtual


Toolkit Pro: Member List

CXTPPopupThemeOffice2000 Member List

This is the complete list of members for CXTPPopupThemeOffice2000, including all inherited members.

CXTPPopupPaintManager() | CXTPPopupPaintManager |
CXTPPopupThemeOffice2000() | CXTPPopupThemeOffice2000 |
DrawBackground(CDC *pDC, CXTPPopupControl *pControl, CRect rcClient) | CXTPPopupThemeOffice2000 | virtual
DrawButton(CDC *pDC, CXTPPopupItem *pItem) | CXTPPopupPaintManager | virtual
DrawItem(CDC *pDC, CXTPPopupItem *pItem) | CXTPPopupPaintManager |
DrawItemIcon(CDC *pDC, CXTPPopupItem *pItem) | CXTPPopupPaintManager | virtual
m_clrBackground | CXTPPopupPaintManager |
m_clrButtonPressed | CXTPPopupPaintManager |
m_clrButtonPressedBorder | CXTPPopupPaintManager |
m_clrButtonSelected | CXTPPopupPaintManager |
m_clrButtonSelectedBorder | CXTPPopupPaintManager |
m_clrFrame | CXTPPopupPaintManager |
m_clrText | CXTPPopupPaintManager |
m_xtpFontText | CXTPPopupPaintManager |
RefreshMetrics() | CXTPPopupThemeOffice2000 | virtual
SetFont(HFONT hFont) | CXTPPopupPaintManager |
~CXTPPopupPaintManager() | CXTPPopupPaintManager | virtual
~CXTPPopupThemeOffice2000() | CXTPPopupThemeOffice2000 | virtual


Toolkit Pro: XTPShortcutBarOffice2013Theme.h Source File

  • Source
  • ShortcutBar
  • Themes
XTPShortcutBarOffice2013Theme.h
Go to the documentation of this file.
1
23#if !defined(__XTPSHORTCUTBAROFFICE2013THEME_H__)
24# define __XTPSHORTCUTBAROFFICE2013THEME_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPShortcutBarOffice2013Theme : public CXTPShortcutBarResourceTheme
39{
40public:
45 CXTPShortcutBarOffice2013Theme();
46
52 virtual ~CXTPShortcutBarOffice2013Theme();
53
61 virtual void RefreshMetrics();
62
84 virtual int DrawPaneItemCaption(CDC* pDC, CXTPShortcutBarPaneItem* pItem, BOOL bDraw);
85
92 virtual void DrawExpandButton(CDC* pDC, CRect rc);
93
94 virtual void DrawPaneCaptionMinimizeButton(CDC* pDC, CXTPShortcutBarPane* pPane);
95
106 virtual int DrawGripper(CDC* pDC, CXTPShortcutBar* pShortcutBar, BOOL bDraw);
107
114 void FillShortcutItemEntry(CDC* pDC, CXTPShortcutBarItem* pItem);
115
122 virtual void FillNavigationItemEntry(CDC* pDC, CXTPShortcutBarItem* pItem);
123
124 virtual void FillPopupBack(CDC* pDC, CRect rc, CSize szGap);
125
132 virtual void FillShortcutBar(CDC* pDC, CXTPShortcutBar* pShortcutBar);
133
134protected:
135 CXTPPaintManagerColor m_clrBack;
136 CXTPPaintManagerColor m_clrBackHilite;
137 CXTPPaintManagerColor m_clrBackPushed;
138 CXTPPaintManagerColor m_clrBackPushedDark;
139 CXTPPaintManagerColor m_clrBackSelected;
140 CXTPPaintManagerColor m_clrGlyph;
141 CXTPPaintManagerColor m_clrGlyphFill;
142 CXTPPaintManagerColor m_clrGlyphExpanded;
143 CXTPPaintManagerColor m_clrGlyphPushed;
144};
145
146# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
148#endif // !defined(__XTPSHORTCUTBAROFFICE2013THEME_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPPaintManagerColor
The CXTPPaintManagerColor class is used to manage COLORREF values for determining default and applica...
Definition XTPColorManager.h:117
CXTPShortcutBar
CXTPShortcutBar is a CWnd derived class used to implement an Outlook 2003 shortcut bar control style.
Definition XTPShortcutBar.h:456
CXTPShortcutBarItem
CXTPShortcutBarItem is a base class that represents an item for a shortcut bar control.
Definition XTPShortcutBar.h:181
CXTPShortcutBarOffice2013Theme
CXTPShortcutBarOffice2013Theme is a CXTPShortcutBarResourceTheme derived class that represents an Off...
Definition XTPShortcutBarOffice2013Theme.h:39
CXTPShortcutBarOffice2013Theme::m_clrGlyph
CXTPPaintManagerColor m_clrGlyph
Normal glyph color.
Definition XTPShortcutBarOffice2013Theme.h:140
CXTPShortcutBarOffice2013Theme::~CXTPShortcutBarOffice2013Theme
virtual ~CXTPShortcutBarOffice2013Theme()
Destroys a CXTPShortcutBarOffice2013Theme object, handles cleanup and deallocation.
CXTPShortcutBarOffice2013Theme::DrawExpandButton
virtual void DrawExpandButton(CDC *pDC, CRect rc)
Draws the expand button.
CXTPShortcutBarOffice2013Theme::DrawPaneItemCaption
virtual int DrawPaneItemCaption(CDC *pDC, CXTPShortcutBarPaneItem *pItem, BOOL bDraw)
Draws the caption for a specified shortcut bar pane item.
CXTPShortcutBarOffice2013Theme::FillShortcutItemEntry
void FillShortcutItemEntry(CDC *pDC, CXTPShortcutBarItem *pItem)
Fills a specified item for the shortcut bar control.
CXTPShortcutBarOffice2013Theme::FillShortcutBar
virtual void FillShortcutBar(CDC *pDC, CXTPShortcutBar *pShortcutBar)
Fills the client area of the shortcut bar control.
CXTPShortcutBarOffice2013Theme::CXTPShortcutBarOffice2013Theme
CXTPShortcutBarOffice2013Theme()
Constructs a CXTPShortcutBarOffice2013Theme object.
CXTPShortcutBarOffice2013Theme::m_clrGlyphExpanded
CXTPPaintManagerColor m_clrGlyphExpanded
Expanded glyph border color.
Definition XTPShortcutBarOffice2013Theme.h:142
CXTPShortcutBarOffice2013Theme::DrawGripper
virtual int DrawGripper(CDC *pDC, CXTPShortcutBar *pShortcutBar, BOOL bDraw)
Draws the gripper for the shortcut bar control.
CXTPShortcutBarOffice2013Theme::m_clrGlyphPushed
CXTPPaintManagerColor m_clrGlyphPushed
Pushed glyph color.
Definition XTPShortcutBarOffice2013Theme.h:143
CXTPShortcutBarOffice2013Theme::m_clrGlyphFill
CXTPPaintManagerColor m_clrGlyphFill
Expanded glyph fill color.
Definition XTPShortcutBarOffice2013Theme.h:141
CXTPShortcutBarOffice2013Theme::RefreshMetrics
virtual void RefreshMetrics()
Refreshes the visual metrics of the shortcut bar paint manager.
CXTPShortcutBarOffice2013Theme::FillNavigationItemEntry
virtual void FillNavigationItemEntry(CDC *pDC, CXTPShortcutBarItem *pItem)
Fills a specified navigation item for the minimized shortcut bar control.
CXTPShortcutBarPane
CXTPShortcutBarPane is a CWnd derived class used as a client area for a shortcut bar control.
Definition XTPShortcutBarPane.h:158
CXTPShortcutBarPaneItem
CXTPShortcutBarPaneItem is a base class that represents an item for a shortcut bar pane.
Definition XTPShortcutBarPane.h:42
CXTPShortcutBarResourceTheme
CXTPShortcutBarResourceTheme is a CXTPShortcutBarOffice2003Theme derived class that represents the Of...
Definition XTPShortcutBarResourceTheme.h:39


Toolkit Pro: Member List

CXTPScrollBarThemeWindowsUx Member List

This is the complete list of members for CXTPScrollBarThemeWindowsUx, including all inherited members.

CalcHScroll(CXTPScrollBase *pScroll, XTPScrollMetricsH *pHScroll) | CXTPScrollBarPaintManager | protectedstatic
CalcVScroll(CXTPScrollBase *pScroll, XTPScrollMetricsV *pVScroll) | CXTPScrollBarPaintManager | protectedstatic
CXTPScrollBarPaintManager() | CXTPScrollBarPaintManager |
CXTPScrollBarThemeWindowsUx() | CXTPScrollBarThemeWindowsUx |
DrawArrowGlyph(CDC *pDC, CRect rcArrow, XTPArrowGlyph glyph, BOOL bEnabled, COLORREF clrText=COLORREF_NULL) | CXTPScrollBarPaintManager | protected
DrawArrows(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics) | CXTPScrollBarPaintManager | protectedvirtual
DrawArrows(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics) | CXTPScrollBarPaintManager | protectedvirtual
DrawBackground(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics) | CXTPScrollBarPaintManager | protectedvirtual
DrawBackground(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics) | CXTPScrollBarPaintManager | protectedvirtual
DrawButtons(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics) | CXTPScrollBarThemeWindowsUx | protectedvirtual
DrawButtons(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics) | CXTPScrollBarThemeWindowsUx | protectedvirtual
DrawGripper(CDC *pDC, CXTPScrollBase *pScroll) | CXTPScrollBarThemeWindowsUx | protectedvirtual
DrawScrollBar(CDC *pDC, CXTPScrollBase *pScrollBar) | CXTPScrollBarPaintManager | virtual
DrawThumbButton(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics) | CXTPScrollBarThemeWindowsUx | protectedvirtual
DrawThumbButton(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics) | CXTPScrollBarThemeWindowsUx | protectedvirtual
DrawTracker(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics) | CXTPScrollBarThemeWindowsUx | protectedvirtual
DrawTracker(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics) | CXTPScrollBarThemeWindowsUx | protectedvirtual
m_crBack | CXTPScrollBarPaintManager |
m_crBackHilite | CXTPScrollBarPaintManager |
m_crBackPushed | CXTPScrollBarPaintManager |
m_crBorder | CXTPScrollBarPaintManager |
m_crBorderHilite | CXTPScrollBarPaintManager |
m_cThumb | CXTPScrollBarPaintManager |
m_cxHScroll | CXTPScrollBarPaintManager |
m_cxVScroll | CXTPScrollBarPaintManager |
m_cyHScroll | CXTPScrollBarPaintManager |
m_cyVScroll | CXTPScrollBarPaintManager |
RefreshMetrics() | CXTPScrollBarThemeWindowsUx | protectedvirtual
~CXTPScrollBarThemeWindowsUx() | CXTPScrollBarThemeWindowsUx | virtual


Toolkit Pro: XTPMarqueeCtrl.h Source File

  • Source
  • Controls
  • Progress
XTPMarqueeCtrl.h
Go to the documentation of this file.
1
23#if !defined(__XTPMARQUEECTRL_H__)
24# define __XTPMARQUEECTRL_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPWinThemeWrapper;
34class CXTPMarqueeCtrlPaintManager;
35
44class _XTP_EXT_CLASS CXTPMarqueeCtrl : public CProgressCtrl
45{
47 DECLARE_DYNAMIC(CXTPMarqueeCtrl)
49public:
54 CXTPMarqueeCtrl();
55
61 virtual ~CXTPMarqueeCtrl();
62
73 CXTPMarqueeCtrlPaintManager* GetPaintManager() const;
74
87 void SetTheme(CXTPMarqueeCtrlPaintManager* pPaintManager = NULL);
88
104 void SetTheme(XTPControlTheme nTheme);
105
111 void RefreshMetrics();
112
137 void SetMarquee(BOOL bMarqueeMode = TRUE, int nInterval = 50, int nGap = 2, int cx = 12,
138 int* piTrans = NULL);
139
147 BOOL IsSmooth();
148
156 BOOL IsVertical();
157
165 BOOL IsMarquee();
166
175 void SetColors(COLORREF crBack, COLORREF crChunk);
176
177protected:
186 virtual BOOL OnInitControl();
187
195 virtual BOOL UseWinThemes();
196
198 //{{AFX_VIRTUAL(CXTPMarqueeCtrl)
199 virtual void PreSubclassWindow();
200 virtual BOOL PreCreateWindow(CREATESTRUCT& cs);
201 virtual BOOL OnWndMsg(UINT message, WPARAM wParam, LPARAM lParam, LRESULT* pResult);
202 //}}AFX_VIRTUAL
203 //{{AFX_MSG(CXTPMarqueeCtrl)
204 afx_msg int OnCreate(LPCREATESTRUCT lpCreateStruct);
205 afx_msg void OnPaint();
206 afx_msg BOOL OnEraseBkgnd(CDC* pDC);
207 afx_msg void OnTimer(UINT_PTR nIDEvent);
208 //}}AFX_MSG
209 afx_msg LRESULT OnSetTheme(WPARAM wParam, LPARAM lParam);
210 DECLARE_MESSAGE_MAP()
213protected:
214 int m_nGap;
215 int m_nPos;
216 int m_cxChunk;
217 BYTE m_chAlpha[5];
218 BOOL m_bIsSubclassed;
222 CXTPMarqueeCtrlPaintManager* m_pPaintManager; // Pointer to the progress bar paint manager.
223
224 friend class CXTPMarqueeCtrlPaintManager;
225 friend class CXTPMarqueeCtrlThemeResource;
226};
227
229
230AFX_INLINE CXTPMarqueeCtrlPaintManager* CXTPMarqueeCtrl::GetPaintManager() const
231{
232 return m_pPaintManager;
233}
234
235//{{AFX_INSERT_LOCATION}}
236// Microsoft Visual C++ will insert additional declarations immediately before the previous line.
238# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
240#endif // !defined(__XTPMARQUEECTRL_H__)
XTPControlTheme
XTPControlTheme
Enumeration used to determine the active theme style.
Definition XTPControlTheme.h:43
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPMarqueeCtrl
CXTPMarqueeCtrl is a CProgressCtrl derived class.
Definition XTPMarqueeCtrl.h:45
CXTPMarqueeCtrl::IsMarquee
BOOL IsMarquee()
Determines if the PBS_MARQUEE style has been set for the marquee progress bar.
CXTPMarqueeCtrl::IsVertical
BOOL IsVertical()
Determines if the PBS_VERTICAL style has been set for the marquee progress bar.
CXTPMarqueeCtrl::UseWinThemes
virtual BOOL UseWinThemes()
This member function is called to determine if Windows themes are enabled for the calling application...
CXTPMarqueeCtrl::SetTheme
void SetTheme(CXTPMarqueeCtrlPaintManager *pPaintManager=NULL)
This member function sets the new control drawing theme.
CXTPMarqueeCtrl::GetPaintManager
CXTPMarqueeCtrlPaintManager * GetPaintManager() const
This member function obtains a pointer to the associated paint manager object.
CXTPMarqueeCtrl::~CXTPMarqueeCtrl
virtual ~CXTPMarqueeCtrl()
Destroys a CXTPMarqueeCtrl object, handles cleanup and deallocation.
CXTPMarqueeCtrl::CXTPMarqueeCtrl
CXTPMarqueeCtrl()
Constructs a CXTPMarqueeCtrl object.
CXTPMarqueeCtrl::SetTheme
void SetTheme(XTPControlTheme nTheme)
Call this member to switch the visual theme of the control.
CXTPMarqueeCtrl::IsSmooth
BOOL IsSmooth()
Determines if the PBS_SMOOTH style has been set for the marquee progress bar.
CXTPMarqueeCtrl::SetColors
void SetColors(COLORREF crBack, COLORREF crChunk)
This member function sets the background and progress indicator colors for the progress bar.
CXTPMarqueeCtrl::SetMarquee
void SetMarquee(BOOL bMarqueeMode=TRUE, int nInterval=50, int nGap=2, int cx=12, int *piTrans=NULL)
Turns marquee mode on/off for the current progress bar control.
CXTPMarqueeCtrl::RefreshMetrics
void RefreshMetrics()
This member is called to update the color and chunk bitmaps used by the marquee progress control.
CXTPMarqueeCtrl::OnInitControl
virtual BOOL OnInitControl()
This member function is called when the progress bar has been created or subclassed.
CXTPMarqueeCtrlPaintManager
The CXTPMarqueeCtrlPaintManager class is derived from CCmdTarget and is used by the progress bar to p...
Definition XTPMarqueeCtrlPaintManager.h:41
CXTPMarqueeCtrlThemeResource
The CXTPMarqueeCtrlThemeFlat class is derived from CXTPMarqueeCtrlPaintManager and is used by the pro...
Definition XTPMarqueeCtrlPaintManager.h:420
CXTPWinThemeWrapper
The CXTPWinThemeWrapper class wraps the UxTheme.dll visual theme API.
Definition XTPWinThemeWrapper.h:188


Toolkit Pro: XTPCalendarShadowDrawer.h Source File

  • Source
  • Calendar
XTPCalendarShadowDrawer.h
Go to the documentation of this file.
1
22#if !defined(_XTPCALENDARSHADOWDRAWER_H__)
23# define _XTPCALENDARSHADOWDRAWER_H__
24
25# if _MSC_VER > 1000
26# pragma once
27# endif // _MSC_VER > 1000
28
29# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
30
35class _XTP_EXT_CLASS CXTPCalendarShadowDrawer
36{
37public:
45 CXTPCalendarShadowDrawer(CDC* pDC, double dMaxAlpha);
46
51 virtual ~CXTPCalendarShadowDrawer();
52
62 static COLORREF AFX_CDECL AlphaPixel(const COLORREF crPixel, const UINT i);
63
74 static int AFX_CDECL CheckValue(int iValue);
75
76 enum XTPShadowPart
77 {
78 // Regular theme - Office 2003
79 xtpShadowLR = 0,
80 xtpShadowTB = 1,
81 xtpShadowTR = 2,
82 xtpShadowBR = 3,
83 xtpShadowBL = 4,
84 // Office 2007 Theme
85 xtpShadow2007Right = 5,
86 xtpShadow2007Bottom = 6,
87 xtpShadow2007TopRight = 7,
88 xtpShadow2007BottomRight = 8,
89 xtpShadow2007BottomLeft = 9,
90 xtpShadow2007Center = 10
91
92 };
100 void DrawShadowRectPart(const CRect& rcShadow, const XTPShadowPart part);
101
102 // Methods for Office 2003 theme
103
112 void ApplyShadowLR(UINT* pBitmap, const ULONG ulBitmapWidth, const ULONG ulBitmapHeight);
113
122 void ApplyShadowTB(UINT* pBitmap, const ULONG ulBitmapWidth, const ULONG ulBitmapHeight);
123
132 void ApplyShadowTR(UINT* pBitmap, const ULONG ulBitmapWidth, const ULONG ulBitmapHeight);
141 void ApplyShadowBR(UINT* pBitmap, const ULONG ulBitmapWidth, const ULONG ulBitmapHeight);
142
151 void ApplyShadowBL(UINT* pBitmap, const ULONG ulBitmapWidth, const ULONG ulBitmapHeight);
152
153 // methods for Office 2007 theme
154
163 void ApplyShadow2007Right(UINT* pBitmap, const ULONG ulBitmapWidth, const ULONG ulBitmapHeight);
164
173 void ApplyShadow2007Bottom(UINT* pBitmap, const ULONG ulBitmapWidth,
174 const ULONG ulBitmapHeight);
175
184 void ApplyShadow2007TR(UINT* pBitmap, const ULONG ulBitmapWidth, const ULONG ulBitmapHeight);
185
194 void ApplyShadow2007BL(UINT* pBitmap, const ULONG ulBitmapWidth, const ULONG ulBitmapHeight);
195
204 void ApplyShadow2007BR(UINT* pBitmap, const ULONG ulBitmapWidth, const ULONG ulBitmapHeight);
205
214 void ApplyShadow2007Center(UINT* pBitmap, const ULONG ulBitmapWidth,
215 const ULONG ulBitmapHeight);
216
217protected:
218 CDC* m_pDC;
219 double m_dMaxAlpha;
221private:
222};
223
224# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
225#endif // !defined(_XTPCALENDARSHADOWDRAWER_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCalendarShadowDrawer
This is a helper class which handles shadows drawing (for events, etc).
Definition XTPCalendarShadowDrawer.h:36
CXTPCalendarShadowDrawer::m_pDC
CDC * m_pDC
drawing device context
Definition XTPCalendarShadowDrawer.h:218
CXTPCalendarShadowDrawer::~CXTPCalendarShadowDrawer
virtual ~CXTPCalendarShadowDrawer()
Destroy the CXTPCalendarShadowDrawer and does the cleanups.
CXTPCalendarShadowDrawer::ApplyShadow2007BL
void ApplyShadow2007BL(UINT *pBitmap, const ULONG ulBitmapWidth, const ULONG ulBitmapHeight)
Applies shadow to bitmap.
CXTPCalendarShadowDrawer::m_dMaxAlpha
double m_dMaxAlpha
maximal shadow alpha grade
Definition XTPCalendarShadowDrawer.h:219
CXTPCalendarShadowDrawer::ApplyShadowBR
void ApplyShadowBR(UINT *pBitmap, const ULONG ulBitmapWidth, const ULONG ulBitmapHeight)
Applies shadow to bitmap.
CXTPCalendarShadowDrawer::DrawShadowRectPart
void DrawShadowRectPart(const CRect &rcShadow, const XTPShadowPart part)
Generic drawing of the shadow rectangle part.
CXTPCalendarShadowDrawer::AlphaPixel
static COLORREF AFX_CDECL AlphaPixel(const COLORREF crPixel, const UINT i)
Call this function to get the alpha pixel.
CXTPCalendarShadowDrawer::CheckValue
static int AFX_CDECL CheckValue(int iValue)
Call this function to check whether the input is within the limit of 0 and 255.
CXTPCalendarShadowDrawer::ApplyShadow2007TR
void ApplyShadow2007TR(UINT *pBitmap, const ULONG ulBitmapWidth, const ULONG ulBitmapHeight)
Applies shadow to bitmap.
CXTPCalendarShadowDrawer::ApplyShadow2007Center
void ApplyShadow2007Center(UINT *pBitmap, const ULONG ulBitmapWidth, const ULONG ulBitmapHeight)
Applies shadow to bitmap.
CXTPCalendarShadowDrawer::ApplyShadow2007Bottom
void ApplyShadow2007Bottom(UINT *pBitmap, const ULONG ulBitmapWidth, const ULONG ulBitmapHeight)
Applies shadow to bitmap.
CXTPCalendarShadowDrawer::CXTPCalendarShadowDrawer
CXTPCalendarShadowDrawer(CDC *pDC, double dMaxAlpha)
Constructs the object and initializes.
CXTPCalendarShadowDrawer::ApplyShadowBL
void ApplyShadowBL(UINT *pBitmap, const ULONG ulBitmapWidth, const ULONG ulBitmapHeight)
Applies shadow to bitmap.
CXTPCalendarShadowDrawer::ApplyShadowTB
void ApplyShadowTB(UINT *pBitmap, const ULONG ulBitmapWidth, const ULONG ulBitmapHeight)
Applied shadow to bitmap.
CXTPCalendarShadowDrawer::ApplyShadowTR
void ApplyShadowTR(UINT *pBitmap, const ULONG ulBitmapWidth, const ULONG ulBitmapHeight)
Applies shadow to bitmap.
CXTPCalendarShadowDrawer::ApplyShadow2007BR
void ApplyShadow2007BR(UINT *pBitmap, const ULONG ulBitmapWidth, const ULONG ulBitmapHeight)
Applies shadow to bitmap.
CXTPCalendarShadowDrawer::ApplyShadow2007Right
void ApplyShadow2007Right(UINT *pBitmap, const ULONG ulBitmapWidth, const ULONG ulBitmapHeight)
Applies shadow to bitmap.
CXTPCalendarShadowDrawer::ApplyShadowLR
void ApplyShadowLR(UINT *pBitmap, const ULONG ulBitmapWidth, const ULONG ulBitmapHeight)
Applied shadow to bitmap.


Toolkit Pro: Member List

CXTPCalendarDayViewDay Member List

This is the complete list of members for CXTPCalendarDayViewDay, including all inherited members.

AdjustLayout(CDC *pDC, const CRect &rcDay) | CXTPCalendarDayViewDay | virtual
AdjustLayout2(CDC *pDC, const CRect &rcDay) | CXTPCalendarDayViewDay | virtual
ContainsInvisibleEvents() const | CXTPCalendarViewDay | virtual
ContainsInvisibleEventsUpdate() | CXTPCalendarViewDay | virtual
CreateGroup() | CXTPCalendarViewDayT< CXTPCalendarDayView, CXTPCalendarDayViewGroup, XTP_CALENDAR_HITTESTINFO, CXTPCalendarDayViewDay > | inlinevirtual
CXTPCalendarDayViewDay(CXTPCalendarDayView *pDayView, COleDateTime dtDate) | CXTPCalendarDayViewDay |
CXTPCalendarViewDay(const CXTPCalendarView *pView) | CXTPCalendarViewDay |
CXTPCalendarViewDayT(const CXTPCalendarDayView *pView) | CXTPCalendarViewDayT< CXTPCalendarDayView, CXTPCalendarDayViewGroup, XTP_CALENDAR_HITTESTINFO, CXTPCalendarDayViewDay > | inline
CXTPCalendarWMHandler() | CXTPCalendarWMHandler |
CXTPCmdTarget() | CXTPCmdTarget |
Draw(CDC *pDC) | CXTPCalendarDayViewDay | virtual
DrawEvents(CDC *pDC) | CXTPCalendarDayViewDay | virtual
DrawTopmostLayer(CDC *pDC) | CXTPCalendarDayViewDay | virtual
FillHitTestEx(XTP_CALENDAR_HITTESTINFO *pInfo) const | CXTPCalendarDayViewDay | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCalendarControl() const | CXTPCalendarViewDay | virtual
GetCaption() const | CXTPCalendarDayViewDay | virtual
GetChildHandlerAt(int nIndex) const | CXTPCalendarViewDay | inlinevirtual
GetChildHandlersCount() const | CXTPCalendarViewDay | inlinevirtual
GetDayDate() const | CXTPCalendarViewDay | virtual
GetDayIndex() const | CXTPCalendarViewDay | virtual
GetDayRect() const | CXTPCalendarViewDay | virtual
GetExpandSignRect() const | CXTPCalendarViewDay | virtual
GetResources() const | CXTPCalendarViewDay | virtual
GetView() const | CXTPCalendarViewDayT< CXTPCalendarDayView, CXTPCalendarDayViewGroup, XTP_CALENDAR_HITTESTINFO, CXTPCalendarDayViewDay > | inline
GetView_() const | CXTPCalendarViewDay | virtual
GetViewEvent_(int nIndex) const | CXTPCalendarViewDay | virtual
GetViewEventsCount() const | CXTPCalendarViewDay | virtual
GetViewGroup(int nIndex) const | CXTPCalendarViewDayT< CXTPCalendarDayView, CXTPCalendarDayViewGroup, XTP_CALENDAR_HITTESTINFO, CXTPCalendarDayViewDay > | inlinevirtual
GetViewGroup_(int nIndex) const | CXTPCalendarViewDay |
GetViewGroupsCount() const | CXTPCalendarViewDay |
HitTest(CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const | CXTPCalendarViewDay | virtual
HitTestEx(CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const | CXTPCalendarViewDay | virtual
IsExpanded() const | CXTPCalendarViewDay | virtual
IsSelected() const | CXTPCalendarViewDay | virtual
KillTimer(UINT uTimerID) | CXTPCalendarViewDay | virtual
m_arViewGroups | CXTPCalendarViewDay | protected
m_dtDate | CXTPCalendarViewDay | protected
m_Layout | CXTPCalendarViewDay | protected
m_pResources | CXTPCalendarViewDay | protected
m_pView | CXTPCalendarViewDay | protected
OnBeforeDestroy() | CXTPCalendarWMHandler | virtual
OnChar(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnKeyUp(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnLButtonDblClk(UINT nFlags, CPoint point) | CXTPCalendarWMHandler | virtual
OnLButtonDown(UINT nFlags, CPoint point) | CXTPCalendarWMHandler | virtual
OnLButtonUp(UINT nFlags, CPoint point) | CXTPCalendarWMHandler | virtual
OnMouseMove(UINT nFlags, CPoint point) | CXTPCalendarDayViewDay | protectedvirtual
OnPostAdjustLayout() | CXTPCalendarWMHandler | virtual
OnPrePopulateDay() | CXTPCalendarViewDay | protectedvirtual
OnSysKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnTimer(UINT_PTR uTimerID) | CXTPCalendarWMHandler | virtual
OnWndMsg(UINT message, WPARAM wParam, LPARAM lParam, LRESULT *pResult) | CXTPCalendarWMHandler | virtual
Populate(COleDateTime dtDayDate) | CXTPCalendarDayViewDay | virtual
SetDayDate(COleDateTime dtDayDate) | CXTPCalendarViewDay | virtual
SetDayRect(CRect rcDay) | CXTPCalendarViewDay | virtual
SetResources(CXTPCalendarResources *pResources) | CXTPCalendarViewDay | virtual
SetSelected() | CXTPCalendarViewDay | virtual
SetTimer(UINT uTimeOut_ms) | CXTPCalendarViewDay | virtual
TBase typedef | CXTPCalendarDayViewDay |
TView typedef | CXTPCalendarViewDayT< CXTPCalendarDayView, CXTPCalendarDayViewGroup, XTP_CALENDAR_HITTESTINFO, CXTPCalendarDayViewDay > |
UserAction_OnExpandDay(XTPCalendarExpandDayButton eButton) | CXTPCalendarViewDay | virtual
~CXTPCalendarDayViewDay() | CXTPCalendarDayViewDay | virtual
~CXTPCalendarViewDay() | CXTPCalendarViewDay | virtual
~CXTPCalendarViewDayT() | CXTPCalendarViewDayT< CXTPCalendarDayView, CXTPCalendarDayViewGroup, XTP_CALENDAR_HITTESTINFO, CXTPCalendarDayViewDay > | inlinevirtual


Toolkit Pro: XTPSyntaxEditLexClassSubObjT.h Source File

  • Source
  • SyntaxEdit
XTPSyntaxEditLexClassSubObjT.h
Go to the documentation of this file.
1
23#if !defined(__XTPSYNTAXEDITLEXCLASSSUBOBJT_H__)
24# define __XTPSYNTAXEDITLEXCLASSSUBOBJT_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33# pragma warning(disable : 4097)
34
35// #define DBG_AUTOMAT
36
38namespace XTPSyntaxEditLexAnalyser
40{
42class CXTPSyntaxEditLexNULL
43{
44public:
45 LPCTSTR GetName() const
46 {
47 return NULL;
48 };
49
50 BOOL IsEmpty() const
51 {
52 return TRUE;
53 }
54
55 BOOL IfMy(LPCTSTR pcszElementName)
56 {
57 UNREFERENCED_PARAMETER(pcszElementName);
58 return FALSE;
59 }
60
61 BOOL AddIfMy(LPCTSTR pcszElementName, const CXTPSyntaxEditLexVariantPtr& ptr)
62 {
63 UNREFERENCED_PARAMETER(pcszElementName);
64 UNREFERENCED_PARAMETER(ptr);
65 return FALSE;
66 }
67
68 BOOL AppendIfMy(LPCTSTR pcszElementName, const CXTPSyntaxEditLexVariantPtrArray& ptrAr)
69 {
70 UNREFERENCED_PARAMETER(pcszElementName);
71 UNREFERENCED_PARAMETER(ptrAr);
72 return FALSE;
73 }
74
75 CXTPSyntaxEditLexVariantPtrArray* GetIfMy(LPCTSTR pcszElementName)
76 {
77 UNREFERENCED_PARAMETER(pcszElementName);
78 return NULL;
79 }
80
81 void CopyFrom(CXTPSyntaxEditLexNULL& rSrc)
82 {
83 UNREFERENCED_PARAMETER(rSrc);
84 };
85
86 void RemoveAll(){};
87# ifdef _DEBUG
88 void DumpOffset(CDumpContext& dc, LPCTSTR pcszOffset)
89 {
90 dc << pcszOffset;
91 };
92# endif
93};
94
95template<class _TC0 = CXTPSyntaxEditLexNULL, class _TC1 = CXTPSyntaxEditLexNULL,
96 class _TC2 = CXTPSyntaxEditLexNULL, class _TC3 = CXTPSyntaxEditLexNULL,
97 class _TC4 = CXTPSyntaxEditLexNULL, class _TC5 = CXTPSyntaxEditLexNULL,
98 class _TC6 = CXTPSyntaxEditLexNULL, class _TC7 = CXTPSyntaxEditLexNULL,
99 class _TC8 = CXTPSyntaxEditLexNULL, class _TC9 = CXTPSyntaxEditLexNULL>
100
101class CXTPSyntaxEditLexObj_SpecCollT
102{
103public:
104 typedef CXTPSyntaxEditLexObj_SpecCollT<_TC0, _TC1, _TC2, _TC3, _TC4, _TC5, _TC6, _TC7, _TC8,
105 _TC9>
106 Tthis;
107
108 typedef _TC0 _Type0;
109 typedef _TC1 _Type1;
110 typedef _TC2 _Type2;
111 typedef _TC3 _Type3;
112 typedef _TC4 _Type4;
113 typedef _TC5 _Type5;
114 typedef _TC6 _Type6;
115 typedef _TC7 _Type7;
116 typedef _TC8 _Type8;
117 typedef _TC9 _Type9;
118
119 CXTPSyntaxEditLexObj_SpecCollT()
120 {
121 m_bEmpty = TRUE;
122
123 SetSubMembers();
124 };
125
126 virtual ~CXTPSyntaxEditLexObj_SpecCollT(){};
127
128protected:
129 BOOL m_bEmpty;
130
131 _TC0* m_p0;
132 _TC1* m_p1;
133 _TC2* m_p2;
134 _TC3* m_p3;
135 _TC4* m_p4;
136 _TC5* m_p5;
137 _TC6* m_p6;
138 _TC7* m_p7;
139 _TC8* m_p8;
140 _TC9* m_p9;
141
142 virtual void SetSubMember0()
143 {
144 m_p0 = NULL;
145 };
146 virtual void SetSubMember1()
147 {
148 m_p1 = NULL;
149 };
150 virtual void SetSubMember2()
151 {
152 m_p2 = NULL;
153 };
154 virtual void SetSubMember3()
155 {
156 m_p3 = NULL;
157 };
158 virtual void SetSubMember4()
159 {
160 m_p4 = NULL;
161 };
162 virtual void SetSubMember5()
163 {
164 m_p5 = NULL;
165 };
166 virtual void SetSubMember6()
167 {
168 m_p6 = NULL;
169 };
170 virtual void SetSubMember7()
171 {
172 m_p7 = NULL;
173 };
174 virtual void SetSubMember8()
175 {
176 m_p8 = NULL;
177 };
178 virtual void SetSubMember9()
179 {
180 m_p9 = NULL;
181 };
182
183 virtual void SetSubMembers()
184 {
185 SetSubMember0();
186 SetSubMember1();
187 SetSubMember2();
188 SetSubMember3();
189 SetSubMember4();
190 SetSubMember5();
191 SetSubMember6();
192 SetSubMember7();
193 SetSubMember8();
194 SetSubMember9();
195 };
196
197public:
198 BOOL IsEmpty() const
199 {
200 return m_bEmpty;
201 }
202
203 BOOL IfMy(LPCTSTR pcszElementName)
204 {
205 if (m_p0 && m_p0->IfMy(pcszElementName))
206 {
207 }
208 else if (m_p1 && m_p1->IfMy(pcszElementName))
209 {
210 }
211 else if (m_p2 && m_p2->IfMy(pcszElementName))
212 {
213 }
214 else if (m_p3 && m_p3->IfMy(pcszElementName))
215 {
216 }
217 else if (m_p4 && m_p4->IfMy(pcszElementName))
218 {
219 }
220 else if (m_p5 && m_p5->IfMy(pcszElementName))
221 {
222 }
223 else if (m_p6 && m_p6->IfMy(pcszElementName))
224 {
225 }
226 else if (m_p7 && m_p7->IfMy(pcszElementName))
227 {
228 }
229 else if (m_p8 && m_p8->IfMy(pcszElementName))
230 {
231 }
232 else if (m_p9 && m_p9->IfMy(pcszElementName))
233 {
234 }
235 else
236 {
237 return FALSE;
238 }
239 return TRUE;
240 }
241
242 BOOL AddIfMy(LPCTSTR pcszElementName, const CXTPSyntaxEditLexVariantPtr& ptr)
243 {
244 if (m_p0 && m_p0->AddIfMy(pcszElementName, ptr))
245 {
246 }
247 else if (m_p1 && m_p1->AddIfMy(pcszElementName, ptr))
248 {
249 }
250 else if (m_p2 && m_p2->AddIfMy(pcszElementName, ptr))
251 {
252 }
253 else if (m_p3 && m_p3->AddIfMy(pcszElementName, ptr))
254 {
255 }
256 else if (m_p4 && m_p4->AddIfMy(pcszElementName, ptr))
257 {
258 }
259 else if (m_p5 && m_p5->AddIfMy(pcszElementName, ptr))
260 {
261 }
262 else if (m_p6 && m_p6->AddIfMy(pcszElementName, ptr))
263 {
264 }
265 else if (m_p7 && m_p7->AddIfMy(pcszElementName, ptr))
266 {
267 }
268 else if (m_p8 && m_p8->AddIfMy(pcszElementName, ptr))
269 {
270 }
271 else if (m_p9 && m_p9->AddIfMy(pcszElementName, ptr))
272 {
273 }
274 else
275 {
276 return FALSE;
277 }
278 m_bEmpty = FALSE;
279 return TRUE;
280 }
281
282 BOOL AppendIfMy(LPCTSTR pcszElementName, const CXTPSyntaxEditLexVariantPtrArray& ptrAr)
283 {
284 if (m_p0 && m_p0->AppendIfMy(pcszElementName, ptrAr))
285 {
286 }
287 else if (m_p1 && m_p1->AppendIfMy(pcszElementName, ptrAr))
288 {
289 }
290 else if (m_p2 && m_p2->AppendIfMy(pcszElementName, ptrAr))
291 {
292 }
293 else if (m_p3 && m_p3->AppendIfMy(pcszElementName, ptrAr))
294 {
295 }
296 else if (m_p4 && m_p4->AppendIfMy(pcszElementName, ptrAr))
297 {
298 }
299 else if (m_p5 && m_p5->AppendIfMy(pcszElementName, ptrAr))
300 {
301 }
302 else if (m_p6 && m_p6->AppendIfMy(pcszElementName, ptrAr))
303 {
304 }
305 else if (m_p7 && m_p7->AppendIfMy(pcszElementName, ptrAr))
306 {
307 }
308 else if (m_p8 && m_p8->AppendIfMy(pcszElementName, ptrAr))
309 {
310 }
311 else if (m_p9 && m_p9->AppendIfMy(pcszElementName, ptrAr))
312 {
313 }
314 else
315 {
316 return FALSE;
317 }
318 m_bEmpty = FALSE;
319 return TRUE;
320 }
321
322 CXTPSyntaxEditLexVariantPtrArray* GetIfMy(LPCTSTR pcszElementName)
323 {
324 CXTPSyntaxEditLexVariantPtrArray* pData = NULL;
325
326 if (m_p0)
327 {
328 pData = m_p0->GetIfMy(pcszElementName);
329 if (pData)
330 return pData;
331 }
332 if (m_p1)
333 {
334 pData = m_p1->GetIfMy(pcszElementName);
335 if (pData)
336 return pData;
337 }
338 if (m_p2)
339 {
340 pData = m_p2->GetIfMy(pcszElementName);
341 if (pData)
342 return pData;
343 }
344 if (m_p3)
345 {
346 pData = m_p3->GetIfMy(pcszElementName);
347 if (pData)
348 return pData;
349 }
350 if (m_p4)
351 {
352 pData = m_p4->GetIfMy(pcszElementName);
353 if (pData)
354 return pData;
355 }
356 if (m_p5)
357 {
358 pData = m_p5->GetIfMy(pcszElementName);
359 if (pData)
360 return pData;
361 }
362 if (m_p6)
363 {
364 pData = m_p6->GetIfMy(pcszElementName);
365 if (pData)
366 return pData;
367 }
368 if (m_p7)
369 {
370 pData = m_p7->GetIfMy(pcszElementName);
371 if (pData)
372 return pData;
373 }
374 if (m_p8)
375 {
376 pData = m_p8->GetIfMy(pcszElementName);
377 if (pData)
378 return pData;
379 }
380 if (m_p9)
381 {
382 pData = m_p9->GetIfMy(pcszElementName);
383 if (pData)
384 return pData;
385 }
386
387 return NULL;
388 }
389
390 void CopyFrom(const Tthis& rSrc)
391 {
392 RemoveAll();
393
394 // m_p0 ? m_p0->CopyFrom(*rSrc.m_p0):1;
395
396 // just call without accessing to the data (and no virtual)
397 // NULL->CopyFrom(NULL) - is OK
398 m_p0->CopyFrom(*rSrc.m_p0);
399 m_p1->CopyFrom(*rSrc.m_p1);
400 m_p2->CopyFrom(*rSrc.m_p2);
401 m_p3->CopyFrom(*rSrc.m_p3);
402 m_p4->CopyFrom(*rSrc.m_p4);
403 m_p5->CopyFrom(*rSrc.m_p5);
404 m_p6->CopyFrom(*rSrc.m_p6);
405 m_p7->CopyFrom(*rSrc.m_p7);
406 m_p8->CopyFrom(*rSrc.m_p8);
407 m_p9->CopyFrom(*rSrc.m_p9);
408
409 m_bEmpty = m_p0->IsEmpty() && m_p1->IsEmpty() && m_p2->IsEmpty() && m_p3->IsEmpty()
410 && m_p4->IsEmpty() && m_p5->IsEmpty() && m_p6->IsEmpty() && m_p7->IsEmpty()
411 && m_p8->IsEmpty() && m_p9->IsEmpty();
412 }
413
414 void RemoveAll()
415 {
416 m_p0->RemoveAll();
417 m_p1->RemoveAll();
418 m_p2->RemoveAll();
419 m_p3->RemoveAll();
420 m_p4->RemoveAll();
421 m_p5->RemoveAll();
422 m_p6->RemoveAll();
423 m_p7->RemoveAll();
424 m_p8->RemoveAll();
425 m_p9->RemoveAll();
426 m_bEmpty = TRUE;
427 }
428
429# ifdef _DEBUG
430 void DumpOffset(CDumpContext& dc, LPCTSTR pcszOffset)
431 {
432 m_p0->DumpOffset(dc, pcszOffset);
433 m_p1->DumpOffset(dc, pcszOffset);
434 m_p2->DumpOffset(dc, pcszOffset);
435 m_p3->DumpOffset(dc, pcszOffset);
436 m_p4->DumpOffset(dc, pcszOffset);
437 m_p5->DumpOffset(dc, pcszOffset);
438 m_p6->DumpOffset(dc, pcszOffset);
439 m_p7->DumpOffset(dc, pcszOffset);
440 m_p8->DumpOffset(dc, pcszOffset);
441 m_p9->DumpOffset(dc, pcszOffset);
442 }
443# endif
444};
445
447_XTP_EXT_CLASS void AFX_CDECL XTPDumpSyntaxEditLexVariant(CXTPSyntaxEditLexVariant* pVt,
448 CDumpContext& dc);
451template<LPCTSTR (*_FuncName)(void)>
452class CXTPSyntaxEditLexVariantPtrArrayExT : public CXTPSyntaxEditLexVariantPtrArray
453{
454public:
455 CXTPSyntaxEditLexVariantPtrArrayExT(){};
456 virtual ~CXTPSyntaxEditLexVariantPtrArrayExT(){};
457
458 LPCTSTR GetName() const
459 {
460 return _FuncName();
461 }
462
463 BOOL IsEmpty() const
464 {
465 return GetSize() == 0;
466 }
467
468 BOOL IfMy(LPCTSTR pcszElementName)
469 {
470 int nCmpRes = _tcsicmp(GetName(), pcszElementName);
471 return (nCmpRes == 0);
472 }
473
474 BOOL AddIfMy(LPCTSTR pcszElementName, const CXTPSyntaxEditLexVariantPtr& ptr)
475 {
476 if (IfMy(pcszElementName))
477 {
478 Add(ptr);
479 return TRUE;
480 }
481 return FALSE;
482 }
483
484 BOOL AppendIfMy(LPCTSTR pcszElementName, const CXTPSyntaxEditLexVariantPtrArray& ptrAr)
485 {
486 if (IfMy(pcszElementName))
487 {
488 Append(ptrAr);
489 return TRUE;
490 }
491 return FALSE;
492 }
493
494 CXTPSyntaxEditLexVariantPtrArray* GetIfMy(LPCTSTR pcszElementName)
495 {
496 if (IfMy(pcszElementName))
497 {
498 return this;
499 }
500 return NULL;
501 }
502
503 void CopyFrom(const CXTPSyntaxEditLexVariantPtrArray& rSrc)
504 {
505 RemoveAll();
506 Append(rSrc);
507 }
508# ifdef _DEBUG
509 void DumpOffset(CDumpContext& dc, LPCTSTR pcszOffset)
510 {
511 if (IsEmpty())
512 {
513 return;
514 }
515# if _MSC_VER > 1100
516 int nCount = (int)GetSize();
517
518 dc << pcszOffset;
519 dc << GetName() << _T("[") << nCount << _T("]");
520
521 for (int i = 0; i < nCount; i++)
522 {
523 if (i)
524 {
525 dc << _T(", ");
526 }
527
528 CXTPSyntaxEditLexVariantPtr ptrV = GetAt(i);
529 if (ptrV)
530 {
531 XTPDumpSyntaxEditLexVariant(ptrV, dc);
532 }
533 else
534 {
535 dc << _T("?<NULL>");
536 }
537 }
538 dc << _T(" \n");
539# else
540 UNREFERENCED_PARAMETER(dc);
541 UNREFERENCED_PARAMETER(pcszOffset);
542# endif
543 }
544# endif
545};
546
547class CXTPSyntaxEditLexAutomatWordsMap;
548class _XTP_EXT_CLASS LA_CHAR_NODE
549{
550 friend class CXTPSyntaxEditLexAutomatWordsMap;
551 friend class CXTPSyntaxEditLexAutomatMemMan;
552
553public:
554 enum NodeFlags
555 {
556 nfSubWordEnd = 0x0001,
557 };
558 WORD wChar;
559 WORD wFlags;
560 CXTPSyntaxEditLexAutomatWordsMap* pNextMap;
561
562protected:
563 LA_CHAR_NODE* pNextNode;
564
565 void Clear();
566
567public:
568 LA_CHAR_NODE();
569 virtual ~LA_CHAR_NODE();
570
571 const LA_CHAR_NODE& operator=(const LA_CHAR_NODE& rSrc);
572
573 // void Clear();
574};
575typedef LA_CHAR_NODE* PLA_CHAR_NODE;
582class _XTP_EXT_CLASS CXTPSyntaxEditLexAutomatWordsMap : public CXTPCmdTarget
583{
584 friend class CXTPSyntaxEditLexAutomatMemMan;
585
586public:
591 CXTPSyntaxEditLexAutomatWordsMap(UINT uHashTableSize = 17);
592
597 virtual ~CXTPSyntaxEditLexAutomatWordsMap();
598
603 void RemoveAll();
604
611 void AddWord(CString strWord, UINT uHashTableSize);
612
623 BOOL FindWord(BOOL bMinWord, LPCTSTR pcszBuffer, CString& rstrWord, int nBufSize,
624 BOOL bConvertToLowerCase, BOOL bIgnoreCaseDyn) const;
625
631 void InitMap(UINT uHashTableSize);
632
639 UINT GetHashTableSize();
640
649 static UINT AFX_CDECL DivideHTSize(UINT uHashTableSize, UINT uMin = 1);
650
651protected:
653 static UINT AFX_CDECL PrimeAdjustU_50(UINT uNumber);
654
655 BOOL _FindWord(LPCTSTR pcszBuffer, CString& rstrWord, int nBufSize, WORD wEndFlags,
656 BOOL bConvertToLowerCase, BOOL bTryToChangeCaseDyn,
657 BOOL bChangeCase = FALSE) const;
668 WORD _GetChar(LPCTSTR pcszStr, int& rnCharLen) const;
669
677 WORD _ChangeCase(WORD wChar) const;
678
686 WORD _MakeLower(WORD wChar) const;
687
692 void Clear()
693 {
694 RemoveAll();
695 };
696
701 virtual void OnFinalRelease();
702
710 const LA_CHAR_NODE* Lookup(WORD wChar) const;
711
712 const LA_CHAR_NODE* SetAt(const LA_CHAR_NODE& newNode);
713
714 CXTPSyntaxEditLexAutomatWordsMap* pNextFreeObj;
716 PLA_CHAR_NODE* m_pHashTable;
717 UINT m_uHashTableSize;
719private:
720};
721 XTP_DEFINE_SMART_PTR_INTERNAL(CXTPSyntaxEditLexAutomatWordsMap)
722
723
727class _XTP_EXT_CLASS CXTPSyntaxEditLexTagsAutomat
728{
729public:
734 CXTPSyntaxEditLexTagsAutomat();
735
740 virtual ~CXTPSyntaxEditLexTagsAutomat();
741
748 void AddTagsList(CXTPSyntaxEditLexVariantPtrArray* pArTags, BOOL bConvertToLowerCase);
749
756 BOOL IsEmpty();
757
762 void RemoveAll();
763
770 void CopyFrom(const CXTPSyntaxEditLexTagsAutomat& rSrc);
771
782 BOOL FindMinWord(LPCTSTR pcszBuffer, CString& rstrWord, int nBufSize, BOOL bConvertToLowerCase,
783 BOOL bIgnoreCaseDyn);
784
795 BOOL FindMaxWord(LPCTSTR pcszBuffer, CString& rstrWord, int nBufSize, BOOL bConvertToLowerCase,
796 BOOL bIgnoreCaseDyn);
797
798protected:
800 void _AddWords(CXTPSyntaxEditLexAutomatWordsMapPtr& rPtrMap, CStringArray& arTags,
801 BOOL bConvertToLowerCase);
802 UINT _CalcHashTableSize(int nCount);
803
804 BOOL _FindWord(BOOL bMinWord, LPCTSTR pcszBuffer, CString& rstrWord, int nBufSize,
805 BOOL bConvertToLowerCase, BOOL bIgnoreCaseDyn);
806
807public:
808 CXTPSyntaxEditLexAutomatWordsMapPtr m_ptrWordsMap;
809 CXTPSyntaxEditLexAutomatWordsMapPtr m_ptrWordsMap_not;
812private:
813};
815class _XTP_EXT_CLASS CXTPSyntaxEditLexAutomatMemMan : public CXTPCmdTarget
816{
817public:
818 CXTPSyntaxEditLexAutomatMemMan();
819 virtual ~CXTPSyntaxEditLexAutomatMemMan();
820
821 CXTPSyntaxEditLexAutomatWordsMap* NewMap(UINT uHashTableSize);
822 LA_CHAR_NODE* NewNode();
823 PLA_CHAR_NODE* NewHashTable(UINT uSize);
824
825 void FreeObject(CXTPSyntaxEditLexAutomatWordsMap* pObj);
826 void FreeObject(LA_CHAR_NODE* pObj);
827 void FreeObject(PLA_CHAR_NODE* pObj);
828
829 DWORD Lock();
830 DWORD Unlock();
831
832# ifdef _DEBUG
833 void Dump(CDumpContext& dc) const;
834# endif
835 UINT m_uAllocatedMaps;
836 UINT m_uUsedMaps;
837
838 UINT m_uAllocatedNodes;
839 UINT m_uUsedNodes;
840
841 UINT m_uAllocatedTables;
842 UINT m_uUsedTables;
843 UINT m_uAllocatedTablesBytes;
844 UINT m_uUsedTablesBytes;
845 // END DEBUG -----------------------------------
846
847protected:
848 LONG m_lLockCount;
849
850 void FreeAll();
851
852 struct LA_HASH_TABLE
853 {
854 friend class CXTPSyntaxEditLexAutomatMemMan;
855
856 UINT uSize;
857 // protected:
858 LA_HASH_TABLE* pNextFreeObj;
859
860 void Clear()
861 {
862 PLA_CHAR_NODE* pData = GetData();
863 ::ZeroMemory(pData, uSize * sizeof(PLA_CHAR_NODE*));
864 }
865
866 PLA_CHAR_NODE* GetData()
867 {
868 return (PLA_CHAR_NODE*)(((byte*)this) + GetHeaderSizeB());
869 }
870
871 static UINT AFX_CDECL GetHeaderSizeB()
872 {
873 UINT uHeader = sizeof(LA_HASH_TABLE);
874 return uHeader;
875 }
876
877 static UINT AFX_CDECL GetHeaderSize()
878 {
879 UINT uHeader = GetHeaderSizeB();
880 UINT uHeader2 = uHeader / sizeof(PLA_CHAR_NODE);
881 uHeader2 += (uHeader % sizeof(PLA_CHAR_NODE)) ? 1 : 0;
882 return uHeader2;
883 }
884
885 static LA_HASH_TABLE* AFX_CDECL GetHeader(PLA_CHAR_NODE* pData)
886 {
887 return (LA_HASH_TABLE*)(((byte*)pData) - GetHeaderSizeB());
888 }
889 };
890
891 CXTPSyntaxEditLexAutomatWordsMap* m_pFreeMaps;
892 LA_CHAR_NODE* m_pFreeNodes;
893
894 LA_HASH_TABLE* m_pFreeTables;
895
896 CList<CXTPSyntaxEditLexAutomatWordsMap*, CXTPSyntaxEditLexAutomatWordsMap*> m_allocatedMaps;
897 CList<LA_CHAR_NODE*, LA_CHAR_NODE*> m_allocatedNodes;
898 CList<PLA_CHAR_NODE*, PLA_CHAR_NODE*> m_allocatedTables;
899};
900
902template<LPCTSTR (*_FuncName)(void)>
903class CXTPSyntaxEditLexVariantPtrArrayExAutomatT
904 : public CXTPSyntaxEditLexVariantPtrArrayExT<_FuncName>
905{
906public:
907 typedef CXTPSyntaxEditLexVariantPtrArrayExT<_FuncName> TBase;
908 typedef CXTPSyntaxEditLexVariantPtrArrayExAutomatT<_FuncName> Tthis;
909
910 CXTPSyntaxEditLexVariantPtrArrayExAutomatT()
911 {
912# ifdef _DEBUG
913 m_bAutomatWasBuilt = FALSE;
914# endif
915 };
916 virtual ~CXTPSyntaxEditLexVariantPtrArrayExAutomatT(){};
917
918 void BuildAutomat(BOOL bConvertToLowerCase = FALSE)
919 {
920 m_automat.RemoveAll();
921 m_automat.AddTagsList(this, bConvertToLowerCase);
922# ifdef _DEBUG
923 m_bAutomatWasBuilt = TRUE;
924# endif
925 }
926
927 void CopyFrom(const Tthis& rSrc)
928 {
929 TBase::CopyFrom(rSrc);
930 m_automat.CopyFrom(rSrc.m_automat);
931
932# ifdef _DEBUG
933 m_bAutomatWasBuilt = rSrc.m_bAutomatWasBuilt;
934# endif
935 }
936
937 BOOL FindMinWord(LPCTSTR pcszBuffer, CString& rstrWord, int nBufSize,
938 BOOL bConvertToLowerCase = FALSE, BOOL bIgnoreCaseDyn = FALSE)
939 {
940 _ASSERTE(m_bAutomatWasBuilt);
941 return m_automat.FindMinWord(pcszBuffer, rstrWord, nBufSize, bConvertToLowerCase,
942 bIgnoreCaseDyn);
943 }
944
945 BOOL FindMaxWord(LPCTSTR pcszBuffer, CString& rstrWord, int nBufSize,
946 BOOL bConvertToLowerCase = FALSE, BOOL bIgnoreCaseDyn = FALSE)
947 {
948 _ASSERTE(m_bAutomatWasBuilt);
949 return m_automat.FindMaxWord(pcszBuffer, rstrWord, nBufSize, bConvertToLowerCase,
950 bIgnoreCaseDyn);
951 }
952
953protected:
954 CXTPSyntaxEditLexTagsAutomat m_automat;
955# ifdef _DEBUG
956 BOOL m_bAutomatWasBuilt;
957# endif
958};
959} // namespace XTPSyntaxEditLexAnalyser
962
963//#pragma warning(pop)
964
966# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
967
968#endif // !defined(__XTPSYNTAXEDITLEXCLASSSUBOBJT_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTP_DEFINE_SMART_PTR_INTERNAL
#define XTP_DEFINE_SMART_PTR_INTERNAL(ClassName)
Define smart pointer for the specified class as ClassNamePtr.
Definition XTPSmartPtrInternalT.h:47
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPInternalCollectionT
Definition XTPSmartPtrInternalT.h:387
CXTPSmartPtrInternalT
Definition XTPSmartPtrInternalT.h:72
CXTPSyntaxEditLexVariant
CXTPSyntaxEditLexVariant provides functionality to manipulate Lexical Analyzer's related variant type...
Definition XTPSyntaxEditLexClass.h:230


Toolkit Pro: Member List

CXTPFlowGraphImage Member List

This is the complete list of members for CXTPFlowGraphImage, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPFlowGraphImage() | CXTPFlowGraphImage |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetIcon() const | CXTPFlowGraphImage |
GetImage() const | CXTPFlowGraphImage |
GetSize() const | CXTPFlowGraphImage |
ImageChanged() | CXTPFlowGraphImage | protected
LoadFromFile(LPCTSTR lpszFileName) | CXTPFlowGraphImage |
LoadFromResource(HINSTANCE hInstance, UINT nResourceName) | CXTPFlowGraphImage |
LoadFromResource(HINSTANCE hInstance, LPCTSTR lpszResourceName, LPCTSTR lpszResourceType) | CXTPFlowGraphImage |
m_pIcon | CXTPFlowGraphImage | protected
m_pImage | CXTPFlowGraphImage | protected
m_pParent | CXTPFlowGraphImage | protected
m_szImage | CXTPFlowGraphImage | protected
OnRemoved() | CXTPFlowGraphImage | protected
SetBitmap(HBITMAP hBitmap) | CXTPFlowGraphImage |
SetIcon(HICON hIcon) | CXTPFlowGraphImage |
~CXTPFlowGraphImage() | CXTPFlowGraphImage | virtual


Toolkit Pro: XTPHeaderCtrlTheme.h Source File

  • Source
  • Controls
  • Header
XTPHeaderCtrlTheme.h
Go to the documentation of this file.
1
23#if !defined(__XTHEADERCTRLTHEME_H__)
24# define __XTHEADERCTRLTHEME_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPHeaderCtrl;
34class CXTPWinThemeWrapper;
35
50class _XTP_EXT_CLASS CXTPHeaderCtrlTheme : public CXTPControlTheme
51{
52public:
58 CXTPHeaderCtrlTheme();
59
65 virtual ~CXTPHeaderCtrlTheme();
66
67public:
75 CXTPWinThemeWrapper* GetThemeWrapper();
76
87 virtual void DrawHeader(CDC* pDC, CXTPHeaderCtrl* pHeaderCtrl);
88
94 virtual void RefreshMetrics(CXTPHeaderCtrl* pHeader);
95
104 virtual BOOL UseWinXPThemes(CXTPHeaderCtrl* pHeaderCtrl);
105
127 virtual void SetDrawStyle(DWORD dwDrawStyle, CXTPHeaderCtrl* pHeaderCtrl);
128
139 virtual DWORD GetDrawStyle() const;
140
154 virtual BOOL Layout(LPHDLAYOUT lpHDL, CXTPHeaderCtrl* pHeaderCtrl);
155
164 virtual void CleanUp(CXTPHeaderCtrl* pHeaderCtrl);
165
181 virtual BOOL SetBitmap(int iCol, UINT uBitmapID, BOOL bRemove, COLORREF crMask,
182 CXTPHeaderCtrl* pHeaderCtrl);
183
191 BOOL HasSortArrow();
192
193protected:
202 virtual void OnDrawBackground(LPDRAWITEMSTRUCT lpDIS);
203
214 virtual BOOL OnDrawBackgroundWinThemed(LPDRAWITEMSTRUCT lpDIS);
215
224 virtual void OnDrawItemBackground(LPDRAWITEMSTRUCT lpDIS);
225
236 virtual BOOL OnDrawItemBackgroundWinThemed(LPDRAWITEMSTRUCT lpDIS);
237
247 virtual void OnDrawItemSortArrow(LPDRAWITEMSTRUCT lpDIS, BOOL bAscending);
248
258 virtual void OnDrawItemText(LPDRAWITEMSTRUCT lpDIS, CXTPHeaderCtrl* pHeaderCtrl);
259
270 virtual void OnDrawItemBitmap(LPDRAWITEMSTRUCT lpDIS, CRect& rcText,
271 CXTPHeaderCtrl* pHeaderCtrl);
272
281 virtual void DrawSortArrow(CDC* pDC, LPPOINT ptsArrow, BOOL bAscending);
282
283protected:
284 int m_iArrowPadding;
285 DWORD m_dwDrawStyle;
286 BOOL m_bUseWinThemes;
287 CSize m_sizePadding;
288 CSize m_sizeArrow;
289 COLORREF m_crText;
290 COLORREF m_cr3DFace;
291 COLORREF m_cr3DShadow;
292 COLORREF m_cr3DDkShadow;
293 COLORREF m_cr3DHighLight;
294 CXTPWinThemeWrapper* m_themeHeader;
296};
297
299# define CXTPHeaderTheme CXTPHeaderCtrlTheme // deprecated
302AFX_INLINE CXTPWinThemeWrapper* CXTPHeaderCtrlTheme::GetThemeWrapper()
303{
304 return m_themeHeader;
305}
322class _XTP_EXT_CLASS CXTPHeaderCtrlThemeOfficeXP : public CXTPHeaderCtrlTheme
323{
324public:
330 CXTPHeaderCtrlThemeOfficeXP();
331
337 virtual ~CXTPHeaderCtrlThemeOfficeXP();
338
339protected:
348 virtual void OnDrawBackground(LPDRAWITEMSTRUCT lpDIS);
349
358 virtual void OnDrawItemBackground(LPDRAWITEMSTRUCT lpDIS);
359};
360
362# define CXTPHeaderThemeOfficeXP CXTPHeaderCtrlThemeOfficeXP // deprecated
379class _XTP_EXT_CLASS CXTPHeaderCtrlThemeOffice2003 : public CXTPHeaderCtrlTheme
380{
381public:
387 CXTPHeaderCtrlThemeOffice2003();
388
394 virtual ~CXTPHeaderCtrlThemeOffice2003();
395
409 virtual BOOL Layout(LPHDLAYOUT lpHDL, CXTPHeaderCtrl* pHeaderCtrl);
410
411protected:
420 virtual void OnDrawBackground(LPDRAWITEMSTRUCT lpDIS);
421
430 virtual void OnDrawItemBackground(LPDRAWITEMSTRUCT lpDIS);
431
432private:
433 COLORREF MixColor(COLORREF clrLight, COLORREF clrDark, double dFactor);
434};
435
451class _XTP_EXT_CLASS CXTPHeaderCtrlThemeExplorer : public CXTPHeaderCtrlThemeOffice2003
452{
453public:
459 CXTPHeaderCtrlThemeExplorer();
460
466 virtual ~CXTPHeaderCtrlThemeExplorer();
467
481 virtual BOOL Layout(LPHDLAYOUT lpHDL, CXTPHeaderCtrl* pHeaderCtrl);
482
483protected:
494 virtual BOOL OnDrawItemBackgroundWinThemed(LPDRAWITEMSTRUCT lpDIS);
495
504 virtual void DrawSortArrow(CDC* pDC, LPPOINT ptsArrow, BOOL bAscending);
505
514 virtual void OnDrawBackground(LPDRAWITEMSTRUCT lpDIS);
515};
516
532class _XTP_EXT_CLASS CXTPHeaderCtrlThemeResource : public CXTPHeaderCtrlThemeOfficeXP
533{
534public:
540 CXTPHeaderCtrlThemeResource();
541
547 virtual void RefreshMetrics(CXTPHeaderCtrl* pHeader);
548
549protected:
558 virtual void OnDrawBackground(LPDRAWITEMSTRUCT lpDIS);
559
568 virtual void OnDrawItemBackground(LPDRAWITEMSTRUCT lpDIS);
569
578 virtual void DrawSortArrow(CDC* pDC, LPPOINT ptsArrow, BOOL bAscending);
579
589 virtual void OnDrawItemSortArrow(LPDRAWITEMSTRUCT lpDIS, BOOL bAscending);
590
600 virtual void OnDrawItemText(LPDRAWITEMSTRUCT lpDIS, CXTPHeaderCtrl* pHeaderCtrl);
601
602 CXTPPaintManagerColorGradient m_crgBack;
603 CXTPPaintManagerColorGradient m_crgBackPressed;
604};
605
607# define CXTPHeaderThemeExplorer CXTPHeaderCtrlThemeExplorer // deprecated
611# ifndef ODS_HOTLIGHT
612# define ODS_HOTLIGHT 0x0040
613# endif // ODS_HOTLIGHT
616const DWORD HDR_XTP_WINDEF = 0x0001;
617const DWORD HDR_XTP_HOTTRACKING = 0x0002;
618const DWORD HDR_XTP_SORTARROW = 0x0004;
621AFX_INLINE BOOL CXTPHeaderCtrlTheme::HasSortArrow()
622{
623 return ((m_dwDrawStyle & HDR_XTP_SORTARROW) == HDR_XTP_SORTARROW);
624}
625AFX_INLINE COLORREF CXTPHeaderCtrlThemeOffice2003::MixColor(COLORREF clrLight, COLORREF clrDark,
626 double dFactor)
627{
628 return RGB(GetRValue(clrLight) - dFactor * (GetRValue(clrLight) - GetRValue(clrDark)),
629 GetGValue(clrLight) - dFactor * (GetGValue(clrLight) - GetGValue(clrDark)),
630 GetBValue(clrLight) - dFactor * (GetBValue(clrLight) - GetBValue(clrDark)));
631}
634# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
636#endif // !defined(__XTHEADERCTRLTHEME_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
HDR_XTP_SORTARROW
const DWORD HDR_XTP_SORTARROW
Definition XTPHeaderCtrlTheme.h:618
HDR_XTP_HOTTRACKING
const DWORD HDR_XTP_HOTTRACKING
Definition XTPHeaderCtrlTheme.h:617
CXTPControlTheme
CXTPControlTheme can be used as a base class for user defined themes.
Definition XTPControlTheme.h:95
CXTPHeaderCtrl
CXTPHeaderCtrl is a CHeaderCtrl derived class.
Definition XTPHeaderCtrl.h:56
CXTPHeaderCtrlThemeExplorer
CXTPHeaderCtrlThemeExplorer is a CXTPHeaderCtrlThemeOffice2003 derived theme class used to draw an Of...
Definition XTPHeaderCtrlTheme.h:452
CXTPHeaderCtrlThemeExplorer::OnDrawItemBackgroundWinThemed
virtual BOOL OnDrawItemBackgroundWinThemed(LPDRAWITEMSTRUCT lpDIS)
This member function is called by the theme to draw the background using Windows themes for the heade...
CXTPHeaderCtrlThemeExplorer::~CXTPHeaderCtrlThemeExplorer
virtual ~CXTPHeaderCtrlThemeExplorer()
Destroys a CXTPHeaderCtrlThemeExplorer object, handles cleanup and deallocation.
CXTPHeaderCtrlThemeExplorer::CXTPHeaderCtrlThemeExplorer
CXTPHeaderCtrlThemeExplorer()
Constructs a CXTPHeaderCtrlThemeExplorer object using the specified header control.
CXTPHeaderCtrlThemeExplorer::DrawSortArrow
virtual void DrawSortArrow(CDC *pDC, LPPOINT ptsArrow, BOOL bAscending)
This member function is called by CXTPHeaderCtrlTheme::OnDrawItemSortArrow to draw the sort arrow.
CXTPHeaderCtrlThemeExplorer::Layout
virtual BOOL Layout(LPHDLAYOUT lpHDL, CXTPHeaderCtrl *pHeaderCtrl)
Retrieves the size and position of a header control within a given rectangle.
CXTPHeaderCtrlThemeExplorer::OnDrawBackground
virtual void OnDrawBackground(LPDRAWITEMSTRUCT lpDIS)
This member function is called by the theme to draw the header control's background.
CXTPHeaderCtrlTheme
CXTPHeaderCtrlTheme is a theme class used to draw a Windows classic style theme for the header contro...
Definition XTPHeaderCtrlTheme.h:51
CXTPHeaderCtrlTheme::m_cr3DHighLight
COLORREF m_cr3DHighLight
RGB value for border highlight color.
Definition XTPHeaderCtrlTheme.h:293
CXTPHeaderCtrlTheme::RefreshMetrics
virtual void RefreshMetrics(CXTPHeaderCtrl *pHeader)
Call this member whenever the system colors need to be updated.
CXTPHeaderCtrlTheme::SetBitmap
virtual BOOL SetBitmap(int iCol, UINT uBitmapID, BOOL bRemove, COLORREF crMask, CXTPHeaderCtrl *pHeaderCtrl)
Call this member function to set the bitmap image for the specified header item.
CXTPHeaderCtrlTheme::GetThemeWrapper
CXTPWinThemeWrapper * GetThemeWrapper()
Call this member function to return a pointer to the Windows theme API wrapper for this control.
CXTPHeaderCtrlTheme::OnDrawItemBackgroundWinThemed
virtual BOOL OnDrawItemBackgroundWinThemed(LPDRAWITEMSTRUCT lpDIS)
This member function is called by the theme to draw the background using Windows themes for the heade...
CXTPHeaderCtrlTheme::m_themeHeader
CXTPWinThemeWrapper * m_themeHeader
Wraps the Windows XP theme API that is used to display Windows XP themes.
Definition XTPHeaderCtrlTheme.h:294
CXTPHeaderCtrlTheme::OnDrawBackgroundWinThemed
virtual BOOL OnDrawBackgroundWinThemed(LPDRAWITEMSTRUCT lpDIS)
This member function is called by the theme to draw the header control's background using Windows the...
CXTPHeaderCtrlTheme::OnDrawItemBackground
virtual void OnDrawItemBackground(LPDRAWITEMSTRUCT lpDIS)
This member function is called by the theme to draw the background for the header item specified by l...
CXTPHeaderCtrlTheme::DrawHeader
virtual void DrawHeader(CDC *pDC, CXTPHeaderCtrl *pHeaderCtrl)
Call this member function from the header control's WM_PAINT message to perform themed drawing.
CXTPHeaderCtrlTheme::m_cr3DDkShadow
COLORREF m_cr3DDkShadow
RGB value for border dark shadow color.
Definition XTPHeaderCtrlTheme.h:292
CXTPHeaderCtrlTheme::m_crText
COLORREF m_crText
RGB value for text color.
Definition XTPHeaderCtrlTheme.h:289
CXTPHeaderCtrlTheme::~CXTPHeaderCtrlTheme
virtual ~CXTPHeaderCtrlTheme()
Destroys a CXTPHeaderCtrlTheme object, handles cleanup and deallocation.
CXTPHeaderCtrlTheme::OnDrawItemText
virtual void OnDrawItemText(LPDRAWITEMSTRUCT lpDIS, CXTPHeaderCtrl *pHeaderCtrl)
This member function is called to draw the text for the header item specified by lpDIS->itemID.
CXTPHeaderCtrlTheme::HasSortArrow
BOOL HasSortArrow()
Call this member function to determine if the header control displays a sort arrow.
CXTPHeaderCtrlTheme::CleanUp
virtual void CleanUp(CXTPHeaderCtrl *pHeaderCtrl)
Cleans up allocated GDI resources used by the theme.
CXTPHeaderCtrlTheme::OnDrawItemSortArrow
virtual void OnDrawItemSortArrow(LPDRAWITEMSTRUCT lpDIS, BOOL bAscending)
This member function is called by the theme to draw the sort used to display the sort order for a hea...
CXTPHeaderCtrlTheme::GetDrawStyle
virtual DWORD GetDrawStyle() const
Call this member function to return the current drawing style used by the header theme.
CXTPHeaderCtrlTheme::m_iArrowPadding
int m_iArrowPadding
Spacing between text and sort arrow.
Definition XTPHeaderCtrlTheme.h:284
CXTPHeaderCtrlTheme::DrawSortArrow
virtual void DrawSortArrow(CDC *pDC, LPPOINT ptsArrow, BOOL bAscending)
This member function is called by CXTPHeaderCtrlTheme::OnDrawItemSortArrow to draw the sort arrow.
CXTPHeaderCtrlTheme::m_cr3DShadow
COLORREF m_cr3DShadow
RGB value for border shadow color.
Definition XTPHeaderCtrlTheme.h:291
CXTPHeaderCtrlTheme::m_cr3DFace
COLORREF m_cr3DFace
RGB value for header background color.
Definition XTPHeaderCtrlTheme.h:290
CXTPHeaderCtrlTheme::UseWinXPThemes
virtual BOOL UseWinXPThemes(CXTPHeaderCtrl *pHeaderCtrl)
This member function can be called to determine if Windows XP themes can be displayed for the header ...
CXTPHeaderCtrlTheme::m_bUseWinThemes
BOOL m_bUseWinThemes
TRUE to use Windows XP themes when available.
Definition XTPHeaderCtrlTheme.h:286
CXTPHeaderCtrlTheme::Layout
virtual BOOL Layout(LPHDLAYOUT lpHDL, CXTPHeaderCtrl *pHeaderCtrl)
Retrieves the size and position of a header control within a given rectangle.
CXTPHeaderCtrlTheme::OnDrawItemBitmap
virtual void OnDrawItemBitmap(LPDRAWITEMSTRUCT lpDIS, CRect &rcText, CXTPHeaderCtrl *pHeaderCtrl)
This member function is called to draw a bitmap for the header item specified by lpDIS->itemID.
CXTPHeaderCtrlTheme::SetDrawStyle
virtual void SetDrawStyle(DWORD dwDrawStyle, CXTPHeaderCtrl *pHeaderCtrl)
Call this member function to set the desired HDRARROW_XTP_drawing styles for the header theme.
CXTPHeaderCtrlTheme::m_sizePadding
CSize m_sizePadding
Leading and trailing padding for text display.
Definition XTPHeaderCtrlTheme.h:287
CXTPHeaderCtrlTheme::CXTPHeaderCtrlTheme
CXTPHeaderCtrlTheme()
Constructs a CXTPHeaderCtrlTheme object using the specified header control.
CXTPHeaderCtrlTheme::m_sizeArrow
CSize m_sizeArrow
Width and height of sort arrow.
Definition XTPHeaderCtrlTheme.h:288
CXTPHeaderCtrlTheme::OnDrawBackground
virtual void OnDrawBackground(LPDRAWITEMSTRUCT lpDIS)
This member function is called by the theme to draw the header control's background.
CXTPHeaderCtrlTheme::m_dwDrawStyle
DWORD m_dwDrawStyle
Style flags used by theme, see CXTPHeaderCtrlTheme::SetDrawStyle().
Definition XTPHeaderCtrlTheme.h:285
CXTPHeaderCtrlThemeOffice2003
CXTPHeaderCtrlThemeOffice2003 is a CXTPHeaderCtrlTheme derived theme class used to draw an Office 200...
Definition XTPHeaderCtrlTheme.h:380
CXTPHeaderCtrlThemeOffice2003::CXTPHeaderCtrlThemeOffice2003
CXTPHeaderCtrlThemeOffice2003()
Constructs a CXTPHeaderCtrlThemeOffice2003 object using the specified header control.
CXTPHeaderCtrlThemeOffice2003::OnDrawItemBackground
virtual void OnDrawItemBackground(LPDRAWITEMSTRUCT lpDIS)
This member function is called by the theme to draw the background for the header item specified by l...
CXTPHeaderCtrlThemeOffice2003::~CXTPHeaderCtrlThemeOffice2003
virtual ~CXTPHeaderCtrlThemeOffice2003()
Destroys a CXTPHeaderCtrlThemeOffice2003 object, handles cleanup and deallocation.
CXTPHeaderCtrlThemeOffice2003::Layout
virtual BOOL Layout(LPHDLAYOUT lpHDL, CXTPHeaderCtrl *pHeaderCtrl)
Retrieves the size and position of a header control within a given rectangle.
CXTPHeaderCtrlThemeOffice2003::OnDrawBackground
virtual void OnDrawBackground(LPDRAWITEMSTRUCT lpDIS)
This member function is called by the theme to draw the header control's background.
CXTPHeaderCtrlThemeOfficeXP
CXTPHeaderCtrlThemeOfficeXP is a CXTPHeaderCtrlTheme derived theme class used to draw an Office XP st...
Definition XTPHeaderCtrlTheme.h:323
CXTPHeaderCtrlThemeOfficeXP::CXTPHeaderCtrlThemeOfficeXP
CXTPHeaderCtrlThemeOfficeXP()
Constructs a CXTPHeaderCtrlThemeOfficeXP object using the specified header control.
CXTPHeaderCtrlThemeOfficeXP::OnDrawItemBackground
virtual void OnDrawItemBackground(LPDRAWITEMSTRUCT lpDIS)
This member function is called by the theme to draw the background for the header item specified by l...
CXTPHeaderCtrlThemeOfficeXP::~CXTPHeaderCtrlThemeOfficeXP
virtual ~CXTPHeaderCtrlThemeOfficeXP()
Destroys a CXTPHeaderCtrlThemeOfficeXP object, handles cleanup and deallocation.
CXTPHeaderCtrlThemeOfficeXP::OnDrawBackground
virtual void OnDrawBackground(LPDRAWITEMSTRUCT lpDIS)
This member function is called by the theme to draw the header control's background.
CXTPHeaderCtrlThemeResource
CXTPHeaderCtrlThemeResource is a CXTPHeaderCtrlThemeOfficeXP derived theme class used to draw a resou...
Definition XTPHeaderCtrlTheme.h:533
CXTPHeaderCtrlThemeResource::m_crgBackPressed
CXTPPaintManagerColorGradient m_crgBackPressed
Gradient pressed item background color.
Definition XTPHeaderCtrlTheme.h:603
CXTPHeaderCtrlThemeResource::RefreshMetrics
virtual void RefreshMetrics(CXTPHeaderCtrl *pHeader)
Call this member whenever the system colors need to be updated.
CXTPHeaderCtrlThemeResource::OnDrawItemBackground
virtual void OnDrawItemBackground(LPDRAWITEMSTRUCT lpDIS)
This member function is called by the theme to draw the background for the header item specified by l...
CXTPHeaderCtrlThemeResource::OnDrawItemText
virtual void OnDrawItemText(LPDRAWITEMSTRUCT lpDIS, CXTPHeaderCtrl *pHeaderCtrl)
This member function is called to draw the text for the header item specified by lpDIS->itemID.
CXTPHeaderCtrlThemeResource::OnDrawItemSortArrow
virtual void OnDrawItemSortArrow(LPDRAWITEMSTRUCT lpDIS, BOOL bAscending)
This member function is called by the theme to draw the sort used to display the sort order for a hea...
CXTPHeaderCtrlThemeResource::CXTPHeaderCtrlThemeResource
CXTPHeaderCtrlThemeResource()
Constructs a CXTPHeaderCtrlThemeResource object using the specified header control.
CXTPHeaderCtrlThemeResource::DrawSortArrow
virtual void DrawSortArrow(CDC *pDC, LPPOINT ptsArrow, BOOL bAscending)
This member function is called by CXTPHeaderCtrlTheme::OnDrawItemSortArrow to draw the sort arrow.
CXTPHeaderCtrlThemeResource::m_crgBack
CXTPPaintManagerColorGradient m_crgBack
Gradient item background color.
Definition XTPHeaderCtrlTheme.h:602
CXTPHeaderCtrlThemeResource::OnDrawBackground
virtual void OnDrawBackground(LPDRAWITEMSTRUCT lpDIS)
This member function is called by the theme to draw the header control's background.
CXTPPaintManagerColorGradient
The CXTPPaintManagerColorGradient class is used to manage COLORREF values for determining light and d...
Definition XTPColorManager.h:301
CXTPWinThemeWrapper
The CXTPWinThemeWrapper class wraps the UxTheme.dll visual theme API.
Definition XTPWinThemeWrapper.h:188


Toolkit Pro: Member List

CXTPButtonThemeOffice2003 Member List

This is the complete list of members for CXTPButtonThemeOffice2003, including all inherited members.

CXTPButtonTheme() | CXTPButtonTheme |
CXTPButtonThemeOffice2003() | CXTPButtonThemeOffice2003 |
CXTPButtonThemeOfficeXP() | CXTPButtonThemeOfficeXP |
CXTPButtonThemeUltraFlat() | CXTPButtonThemeUltraFlat |
CXTPCmdTarget() | CXTPCmdTarget |
CXTPControlTheme() | CXTPControlTheme |
DrawButton(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
DrawButtonBackground(CDC *pDC, CXTPButton *pButton) | CXTPButtonThemeOffice2003 | virtual
DrawButtonText(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme |
DrawButtonVisualStyleBackground(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
DrawCheckBoxMark(CDC *pDC, CXTPButton *pButton) | CXTPButtonThemeUltraFlat | virtual
DrawFocusRect(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
DrawGroupBox(CDC *pDC, CXTPButton *pButton) | CXTPButtonThemeUltraFlat | virtual
DrawPushButtonDropDown(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
DrawPushButtonIcon(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
DrawPushButtonText(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
DrawRadioButtonMark(CDC *pDC, CXTPButton *pButton) | CXTPButtonThemeUltraFlat | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetTextColor(CXTPButton *pButton) | CXTPButtonTheme | virtual
GetThemeStyle() const | CXTPControlTheme |
m_crBack | CXTPButtonTheme |
m_crBackChecked | CXTPButtonThemeUltraFlat |
m_crBackHilite | CXTPButtonThemeUltraFlat |
m_crBackPushed | CXTPButtonThemeUltraFlat |
m_crBorder3DHilite | CXTPButtonTheme |
m_crBorder3DShadow | CXTPButtonTheme |
m_crBorderHilite | CXTPButtonTheme |
m_crBorderPushed | CXTPButtonThemeUltraFlat |
m_crBorderShadow | CXTPButtonTheme |
m_crCheckMark | CXTPButtonThemeUltraFlat |
m_crText | CXTPButtonTheme |
m_crTextCheck | CXTPButtonTheme |
m_crTextDisabled | CXTPButtonTheme |
m_crTextHilite | CXTPButtonThemeUltraFlat |
m_crTextPushed | CXTPButtonThemeUltraFlat |
m_nTheme | CXTPControlTheme | protected
RefreshMetrics(CXTPButton *pButton) | CXTPButtonThemeOffice2003 | virtual
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static
~CXTPButtonTheme() | CXTPButtonTheme | virtual


Toolkit Pro: Member List

CXTPTrackThemeVisualStudio2022 Member List

This is the complete list of members for CXTPTrackThemeVisualStudio2022, including all inherited members.

CalcColumnHeight(CDC *pDC, CXTPGridColumn *pColumn, int nTotalWidth=0) | CXTPGridPaintManager | protectedvirtual
CalculateRowHeight(CDC *pDC, const CString &strText, int nMaxWidth, BOOL bWordBreak=TRUE) | CXTPGridPaintManager | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPGridPaintManager() | CXTPGridPaintManager |
CXTPTrackPaintManager() | CXTPTrackPaintManager |
CXTPTrackThemeOffice2013() | CXTPTrackThemeOffice2013 |
CXTPTrackThemeVisualStudio2022() | CXTPTrackThemeVisualStudio2022 |
DrawBitmap(CDC *pDC, CXTPGridControl *pControl, CRect rcColumn, int iImage) | CXTPGridPaintManager | virtual
DrawCollapsedBitmap(CDC *pDC, const CXTPGridRow *pRow, CRect &rcBitmap) | CXTPGridPaintManager | virtual
DrawColumn(CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn, BOOL bDrawExternal=FALSE, int nShadowWidth=0) | CXTPGridPaintManager | virtual
DrawColumnBackground(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, BOOL &bColumnPressed, BOOL &bDraggingFromHeader, CXTPGridHeader *pHeader=NULL) | CXTPTrackThemeOffice2013 | virtual
DrawColumnFooter(CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn) | CXTPGridPaintManager | virtual
DrawColumnFooterDivider(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn) | CXTPGridPaintManager | virtual
DrawColumnIcon(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, CRect rcIcon, int iIcon) | CXTPGridPaintManager | virtual
DrawColumnText(CDC *pDC, CRect rcText, CString strCaption, int nHeaderAlignment, BOOL bIsHeader, BOOL bColumnPressed) | CXTPTrackThemeOffice2013 | virtual
DrawConnector(CDC *pDC, CPoint ptFrom, CPoint ptTo) | CXTPGridPaintManager |
DrawFocusedRow(CDC *pDC, CRect rcRow) | CXTPTrackThemeOffice2013 | virtual
DrawFreezeColsDivider(CDC *pDC, const CRect &rc, CXTPGridControl *pControl, CXTPGridRow *pRow=NULL) | CXTPGridPaintManager | virtual
DrawGlyph(CDC *pDC, CRect rcColumn, int iImage) | CXTPGridPaintManager | virtual
DrawGrid(CDC *pDC, XTPGridOrientation orientation, CRect rcGrid) | CXTPGridPaintManager | virtual
DrawGridPattern(CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush) | CXTPGridPaintManager | protectedvirtual
DrawGridPattern(CDC *pDC, CXTPBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush) | CXTPGridPaintManager | protectedvirtual
DrawGridPattern(CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr) | CXTPGridPaintManager | protectedvirtual
DrawGroupRow(CDC *pDC, CXTPGridGroupRow *pRow, CRect rcRow, XTP_GRIDRECORDITEM_METRICS *pMetrics) | CXTPTrackThemeOffice2013 | virtual
DrawHorizontalLine(CDC *pDC, int xPos, int yPos, int cx, COLORREF clr) | CXTPGridPaintManager |
DrawInplaceButton(CDC *pDC, CXTPGridInplaceButton *pButton) | CXTPGridPaintManager | virtual
DrawInplaceButtonFrame(CDC *pDC, CXTPGridInplaceButton *pButton) | CXTPGridPaintManager | protectedvirtual
DrawInplaceButtonIcon(CDC *pDC, CXTPGridInplaceButton *pButton) | CXTPGridPaintManager | protectedvirtual
DrawInplaceComboButton(CDC *pDC, CRect *pRc) | CXTPGridPaintManager | virtual
DrawInplaceExpandButton(CDC *pDC, CRect *pRc) | CXTPGridPaintManager | virtual
DrawInplaceSpinButton(CDC *pDC, CRect *pRc) | CXTPGridPaintManager | virtual
DrawItemBitmap(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CRect &rcItem, int nImage) | CXTPGridPaintManager | virtual
DrawItemCaption(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics) | CXTPGridPaintManager | virtual
DrawItemControl(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CXTPGridRecordItemControl *pControl, CRect &rcItem) | CXTPGridPaintManager | virtual
DrawLink(int *pnCurrDrawPos, XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CXTPGridHyperlink *pHyperlink, CString strText, CRect rcLink, int nFlag, BOOL bTrim=FALSE) | CXTPGridPaintManager | protectedvirtual
DrawMarkers(CDC *pDC) | CXTPTrackPaintManager | virtual
DrawMultiLineText(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, BOOL bWordBreak=TRUE) | CXTPGridPaintManager | protectedvirtual
DrawNoGroupByText(CDC *pDC, CRect rcItem) | CXTPGridPaintManager | virtual
DrawRowNumber(CDC *pDC, CRect rcNumber, CXTPGridRow *pRow) | CXTPGridPaintManager | virtual
DrawSectionDivider(CDC *pDC, const CRect &rc, XTPGridSectionDividerPosition dividerPosition, XTPGridSectionDividerStyle dividerStyle, CXTPPaintManagerColor dividerColor) | CXTPGridPaintManager |
DrawShellIcon(CDC *pDC, CRect rcColumn, int iImage) | CXTPGridPaintManager | virtual
DrawSingleLineText(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nStartPos, int nEndPos, int nActualWidth) | CXTPGridPaintManager | protectedvirtual
DrawString(int *pnCurrDrawPos, CDC *pDC, const CString &strDraw, CRect rcDraw, UINT nFormat) | CXTPGridPaintManager | protectedvirtual
DrawTextLine(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nFlag, int &nCharCounter, int &nHyperlinkCounter) | CXTPGridPaintManager | protectedvirtual
DrawTimeLine(CDC *pDC) | CXTPTrackPaintManager | virtual
DrawTrackHeader(CDC *pDC) | CXTPTrackPaintManager | virtual
DrawTreeStructure(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CRect rcItem, CSize sizeGlyph) | CXTPGridPaintManager | virtual
DrawTriangle(CDC *pDC, CRect rcTriangle, BOOL bToDown, BOOL bDraggingFromHeader, int nShadowWidth, BOOL bColumnPressed) | CXTPTrackThemeOffice2013 | virtual
DrawVerticalLine(CDC *pDC, int xPos, int yPos, int cy, COLORREF clr) | CXTPGridPaintManager |
DrawVerticalTimeLineMarker(CDC *pDC, int xPos, CXTPGridControl *pControl, COLORREF color=RGB(0, 255, 0)) | CXTPGridPaintManager | virtual
EnablePreviewMode(BOOL bIsPreviewMode) | CXTPGridPaintManager |
FillFooter(CDC *pDC, CRect rcFooter) | CXTPGridPaintManager | virtual
FillGroupByControl(CDC *pDC, CRect &rcGroupBy) | CXTPGridPaintManager | virtual
FillGroupRowMetrics(CXTPGridGroupRow *pRow, XTP_GRIDRECORDITEM_METRICS *pMetrics, BOOL bPrinting) | CXTPTrackThemeOffice2013 | virtual
FillHeaderControl(CDC *pDC, CRect rcHeader) | CXTPGridPaintManager | virtual
FillIndent(CDC *pDC, CRect rcRow) | CXTPGridPaintManager | virtual
FillItemShade(CDC *pDC, CRect rcItem) | CXTPGridPaintManager | virtual
FillRow(CDC *pDC, CXTPGridRow *pRow, CRect rcRow) | CXTPGridPaintManager | virtual
FindRowAdjacentToMerged(const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, BOOL bUpward) | CXTPGridPaintManager |
FindRowAdjacentToMergedEx(const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, int &nAdjRowIndex, BOOL bUpward) | CXTPGridPaintManager |
FormatTime(int nPosition) | CXTPTrackPaintManager | virtual
FormatTimeLineTick(int nPosition, COLORREF &clrTick, int &nTickLength) | CXTPTrackPaintManager | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetColumnOffice2007CustomThemeBaseColor() const | CXTPGridPaintManager |
GetColumnStyle() const | CXTPGridPaintManager |
GetControlBackColor(CXTPGridControl *pControl) | CXTPGridPaintManager | virtual
GetFooterHeight(CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0) | CXTPGridPaintManager | virtual
GetFreezeColsDividerStyle() const | CXTPGridPaintManager |
GetGlyphs() const | CXTPGridPaintManager |
GetHeaderHeight() | CXTPGridPaintManager | virtual
GetHeaderHeight(CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0) | CXTPGridPaintManager | virtual
GetItemHeight(XTP_GRIDRECORDITEM_DRAWARGS &drawArgs, int nWidth) | CXTPGridPaintManager |
GetMaxPreviewLines() | CXTPGridPaintManager |
GetPreviewItemHeight(CDC *pDC, CXTPGridRow *pRow, int nWidth, int nHeight) | CXTPGridPaintManager | virtual
GetPreviewLinesCount(CDC *pDC, CRect &rcText, const CString &strText) | CXTPGridPaintManager |
GetRowHeight(CDC *pDC, CXTPGridRow *pRow) | CXTPTrackThemeOffice2013 | virtual
CXTPTrackPaintManager::GetRowHeight(CDC *pDC, CXTPGridRow *pRow, int nTotalWidth) | CXTPGridPaintManager | virtual
GetRowHeightEx(CDC *pDC, CXTPGridRow *pRow, int nTotalWidth, const BOOL firstLevel=TRUE) | CXTPGridPaintManager |
GetSectionDividerHeight(XTPGridFixedRowsDividerStyle dividerStyle) | CXTPGridPaintManager |
GetTextFont() | CXTPGridPaintManager |
IsColumHotTrackingEnabled() const | CXTPGridPaintManager | virtual
IsColumnPlusMinusSign() const | CXTPGridPaintManager |
IsColumnWidthWYSIWYG() const | CXTPGridPaintManager |
IsDrawGridForEmptySpace() const | CXTPGridPaintManager |
IsFixedInplaceButtonHeight() const | CXTPGridPaintManager |
IsFixedRowHeight() const | CXTPGridPaintManager |
IsGridVisible(BOOL bVertical) const | CXTPGridPaintManager |
IsGridVisible(XTPGridOrientation orientation) const | CXTPGridPaintManager |
IsLastColumnWidthWYSIWYG() const | CXTPGridPaintManager |
IsPreviewMode() const | CXTPGridPaintManager |
IsPrintGroupRowIcon() const | CXTPGridPaintManager |
IsShowWYSIWYGMarkers() const | CXTPGridPaintManager |
IsUseDropMarker() const | CXTPGridPaintManager |
LoadGlyphs() | CXTPTrackThemeOffice2013 | virtual
m_arStartCol | CXTPGridPaintManager |
m_bAllowMergeCells | CXTPGridPaintManager |
m_bBaseTreeIndent | CXTPGridPaintManager |
m_bCleanTooltip | CXTPGridPaintManager |
m_bColumnPlusMinusSign | CXTPGridPaintManager | protected
m_bColumnWidthWYSIWYG | CXTPGridPaintManager | protected
m_bCompactText | CXTPGridPaintManager |
m_bDrawGridForEmptySpace | CXTPGridPaintManager | protected
m_bFixedInplaceButtonHeight | CXTPGridPaintManager | protected
m_bFixedRowHeight | CXTPGridPaintManager | protected
m_bForceDynamicMarkupForCell | CXTPGridPaintManager |
m_bForceShowDropMarker | CXTPGridPaintManager |
m_bForceShowTooltip | CXTPGridPaintManager |
m_bGrayIfDisable | CXTPGridPaintManager |
m_bGroupRowTextBold | CXTPGridPaintManager |
m_bHideSelection | CXTPGridPaintManager |
m_bHotTracking | CXTPGridPaintManager |
m_bInvertColumnOnClick | CXTPGridPaintManager |
m_bIsPreviewMode | CXTPGridPaintManager | protected
m_bLastColumnWidthWYSIWYG | CXTPGridPaintManager | protected
m_bMakeUpper | CXTPGridPaintManager |
m_bMoveScrollbarOnFixedColumnsIndent | CXTPGridPaintManager |
m_bPrintGroupRowIcon | CXTPGridPaintManager | protected
m_bPrintPageRectangle | CXTPGridPaintManager |
m_bPrintSortTriangle | CXTPGridPaintManager |
m_bPrintVirtualPageNumber | CXTPGridPaintManager |
m_bPrintWatermark | CXTPGridPaintManager |
m_bRecOrRowNum | CXTPGridPaintManager |
m_bRevertAlignment | CXTPGridPaintManager |
m_bShadeGroupHeadings | CXTPGridPaintManager |
m_bShadeSortColumn | CXTPGridPaintManager |
m_bShowLockIcon | CXTPGridPaintManager |
m_bShowNonActiveInPlaceButton | CXTPGridPaintManager |
m_bShowWYSIWYGMarkers | CXTPGridPaintManager | protected
m_bSortTriangleOffsetFromRight | CXTPGridPaintManager |
m_bThemedInplaceButtons | CXTPGridPaintManager |
m_bUseAlternativeBackground | CXTPGridPaintManager |
m_bUseDropMarker | CXTPGridPaintManager |
m_bUseEditTextAlignment | CXTPGridPaintManager |
m_bUseGroupRowSelectionState | CXTPGridPaintManager |
m_bUseShellIcon | CXTPGridPaintManager |
m_clrAlternativeBackground | CXTPGridPaintManager |
m_clrBoldText | CXTPGridPaintManager |
m_clrBoldTextHighlight | CXTPGridPaintManager |
m_clrBtnFace | CXTPGridPaintManager |
m_clrBtnFacePressed | CXTPGridPaintManager |
m_clrBtnText | CXTPGridPaintManager |
m_clrCaptionText | CXTPGridPaintManager |
m_clrCaptionTextPressed | CXTPGridPaintManager |
m_clrColumnOffice2007CustomTheme | CXTPGridPaintManager |
m_clrConnector | CXTPGridPaintManager |
m_clrControlBack | CXTPGridPaintManager |
m_clrControlDark | CXTPGridPaintManager |
m_clrControlLightLight | CXTPGridPaintManager |
m_clrDisableBitmapDarkest | CXTPGridPaintManager |
m_clrDisableBitmapLightest | CXTPGridPaintManager |
m_clrFormulaSubSum | CXTPGridPaintManager |
m_clrFormulaSum | CXTPGridPaintManager |
m_clrFreezeColsDivider | CXTPGridPaintManager |
m_clrGlyph | CXTPTrackThemeOffice2013 |
m_clrGlyphHighlight | CXTPTrackThemeOffice2013 |
m_clrGradientColumnSeparator | CXTPGridPaintManager |
m_clrGradientColumnShadow | CXTPGridPaintManager |
m_clrGroupBoxBack | CXTPGridPaintManager |
m_clrGroupRowText | CXTPGridPaintManager |
m_clrGroupShadeBack | CXTPGridPaintManager |
m_clrGroupShadeBorder | CXTPGridPaintManager |
m_clrGroupShadeText | CXTPGridPaintManager |
m_clrHeaderControl | CXTPGridPaintManager |
m_clrHighlight | CXTPGridPaintManager |
m_clrHighlightText | CXTPGridPaintManager |
m_clrHotDivider | CXTPGridPaintManager |
m_clrIndentControl | CXTPGridPaintManager |
m_clrItemShade | CXTPGridPaintManager |
m_clrMarker | CXTPTrackPaintManager |
m_clrMarkerBack | CXTPTrackPaintManager |
m_clrMarkerBorder | CXTPTrackPaintManager |
m_clrPreviewText | CXTPGridPaintManager |
m_clrScrollBarBorderDark | CXTPTrackPaintManager |
m_clrScrollBarBorderLight | CXTPTrackPaintManager |
m_clrScrollBarDark | CXTPTrackPaintManager |
m_clrScrollBarLight | CXTPTrackPaintManager |
m_clrSelectedArea | CXTPTrackPaintManager |
m_clrSelectedBorder | CXTPTrackThemeOffice2013 |
m_clrSelectedRow | CXTPGridPaintManager |
m_clrSelectedRowText | CXTPGridPaintManager |
m_clrTimeHeaderBorder | CXTPTrackPaintManager |
m_clrTimeHeaderDark | CXTPTrackPaintManager |
m_clrTimeHeaderDarkDark | CXTPTrackPaintManager |
m_clrTimeHeaderDivider | CXTPTrackPaintManager |
m_clrTimeLinePosition | CXTPTrackPaintManager |
m_clrTimeLineTick | CXTPTrackPaintManager |
m_clrTimeSliderBackground | CXTPTrackPaintManager |
m_clrTrackHeader | CXTPTrackPaintManager |
m_clrTrackMarkerBorder | CXTPTrackPaintManager |
m_clrTrackMarkerText | CXTPTrackPaintManager |
m_clrTrackMarkerTextBack | CXTPTrackPaintManager |
m_clrTrackMarkerTextBorder | CXTPTrackPaintManager |
m_clrTrackTimeArea | CXTPTrackPaintManager |
m_clrWindowText | CXTPGridPaintManager |
m_clrWorkArea | CXTPTrackPaintManager |
m_clrWorkAreaScrollBarBorder | CXTPTrackPaintManager |
m_clrWorkAreaScrollBarDark | CXTPTrackPaintManager |
m_clrWorkAreaScrollBarLight | CXTPTrackPaintManager |
m_columnStyle | CXTPGridPaintManager | protected
m_crlNoGroupByText | CXTPGridPaintManager |
m_grcGradientColumn | CXTPGridPaintManager |
m_grcGradientColumnHot | CXTPGridPaintManager |
m_grcGradientColumnPushed | CXTPGridPaintManager |
m_iRecOrRowStart | CXTPGridPaintManager |
m_nBaseParentRecordIndent | CXTPGridPaintManager |
m_nFixedColumnsIndent | CXTPGridPaintManager |
m_nFooterHeight | CXTPGridPaintManager | protected
m_nFreezeColsDividerStyle | CXTPGridPaintManager | protected
m_nGridLineStylePreviousH | CXTPGridPaintManager | protected
m_nGridLineStylePreviousV | CXTPGridPaintManager | protected
m_nGroupGridLineHeight | CXTPGridPaintManager | protected
m_nGroupGridLineStyle | CXTPGridPaintManager | protected
m_nHeaderHeight | CXTPGridPaintManager | protected
m_nMaxPreviewLines | CXTPGridPaintManager | protected
m_nResizingWidth | CXTPGridPaintManager | protected
m_nRowHeight | CXTPGridPaintManager | protected
m_nRowHeightDefault | CXTPGridPaintManager |
m_nTextIndentForGroupRowsWithNoIcon | CXTPGridPaintManager |
m_nTreeColumnLineLength | CXTPGridPaintManager |
m_nTreeIndent | CXTPGridPaintManager |
m_nTreeStructureStyle | CXTPGridPaintManager |
m_nTreeTextIndent | CXTPGridPaintManager |
m_nTreeTextIndentGroupRow | CXTPGridPaintManager |
m_nTreeTextIndentRowChildren | CXTPGridPaintManager |
m_nTreeTextIndentRowParent | CXTPGridPaintManager |
m_pControl | CXTPGridPaintManager | protected
m_pGlyphs | CXTPGridPaintManager | protected
m_pHyperlinkHoverStyle | CXTPGridPaintManager |
m_pHyperlinkStyle | CXTPGridPaintManager |
m_pMarkupUIElement_NoGroupBy | CXTPGridPaintManager | protected
m_PrintPageWidth | CXTPGridPaintManager |
m_rcPreviewIndent | CXTPGridPaintManager |
m_RecordNumberWidth | CXTPGridPaintManager |
m_strCollapse | CXTPGridPaintManager |
m_strDecreasing | CXTPGridPaintManager |
m_strExpand | CXTPGridPaintManager |
m_strIncreasing | CXTPGridPaintManager |
m_strMarkupUIElement_NoGroupBy | CXTPGridPaintManager | protected
m_strNoFieldsAvailable | CXTPGridPaintManager |
m_strNoGroupBy | CXTPGridPaintManager |
m_strNoItems | CXTPGridPaintManager |
m_strSortBy | CXTPGridPaintManager |
m_szGlyph | CXTPGridPaintManager | protected
m_themeButton | CXTPGridPaintManager | protected
m_themeCombo | CXTPGridPaintManager | protected
m_themeHeader | CXTPGridPaintManager | protected
m_themeSpin | CXTPGridPaintManager | protected
m_treeStructureStyle | CXTPGridPaintManager |
m_xtpBrushGroupGridLineStyle | CXTPGridPaintManager | protected
m_xtpBrushHorizontalGrid | CXTPGridPaintManager | protected
m_xtpBrushTreeStructure | CXTPGridPaintManager | protected
m_xtpBrushVeriticalGrid | CXTPGridPaintManager | protected
m_xtpFontBoldText | CXTPGridPaintManager |
m_xtpFontCaption | CXTPGridPaintManager |
m_xtpFontPreview | CXTPGridPaintManager |
m_xtpFontText | CXTPGridPaintManager |
OnDrawAction(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs) | CXTPGridPaintManager | virtual
RecalcTotalHightOfMergedRows(CXTPGridColumns *pColumns, CDC *pDC, CXTPGridRow *pRow, int nRowHeight, int nTotalWidth) | CXTPGridPaintManager |
RefreshMetrics() | CXTPTrackThemeVisualStudio2022 | virtual
SetCaptionFont(LOGFONT &lf) | CXTPGridPaintManager |
SetColumnOffice2007CustomThemeBaseColor(COLORREF clrBaseColor) | CXTPGridPaintManager |
SetColumnPlusMinusSign(BOOL bDraw) | CXTPGridPaintManager |
SetColumnWidthWYSIWYG(BOOL bColumnWidthWYSIWYG) | CXTPGridPaintManager |
SetDrawGridForEmptySpace(BOOL bDrawGrid) | CXTPGridPaintManager |
SetFixedRowHeight(BOOL bFixedRowHeight) | CXTPGridPaintManager |
SetFreezeColsDividerStyle(int nStyle) | CXTPGridPaintManager |
SetGridControl(CXTPGridControl *pControl) | CXTPGridPaintManager | virtual
SetHeaderHeight(int nHeight) | CXTPGridPaintManager | virtual
SetInplaceButtonHeight(BOOL bFixedInplaceButtonHeight) | CXTPGridPaintManager |
SetLastColumnWidthWYSIWYG(BOOL bColumnWidthWYSIWYG) | CXTPGridPaintManager |
SetMaxPreviewLines(int nMaxLines) | CXTPGridPaintManager |
SetPreviewIndent(int nLeft, int nTop, int nRight, int nBottom) | CXTPGridPaintManager |
SetPrintGroupRowIcon(BOOL bDraw) | CXTPGridPaintManager |
SetTextFont(LOGFONT &lf) | CXTPGridPaintManager |
ShowWYSIWYGMarkers(BOOL bSet) | CXTPGridPaintManager |
~CXTPGridPaintManager() | CXTPGridPaintManager | virtual
~CXTPTrackPaintManager() | CXTPTrackPaintManager |


Toolkit Pro: Member List

CXTPMarkupThemePart Member List

This is the complete list of members for CXTPMarkupThemePart, including all inherited members.

CXTPMarkupThemePart() | CXTPMarkupThemePart |
LoadPart(HZIP hZip, LPCTSTR pszFileName, CXTPMarkupContext *pMarkupContext) | CXTPMarkupThemePart |
m_pMarkupUIElement | CXTPMarkupThemePart | protected
Measure(int cx, int cy) | CXTPMarkupThemePart |
RenderMarkup(CDC *pDC, CRect rc) | CXTPMarkupThemePart |
~CXTPMarkupThemePart() | CXTPMarkupThemePart | virtual


Toolkit Pro: Member List

CXTPTaskPanelListViewOfficeXPTheme Member List

This is the complete list of members for CXTPTaskPanelListViewOfficeXPTheme, including all inherited members.

BlendColor(COLORREF clrFrom, COLORREF clrTo, int nAlpha) | CXTPTaskPanelPaintManager | protected
CreateGripperBitmaps() | CXTPTaskPanelPaintManager | protected
CreateGripperIcon(HICON &hIcon, UINT nIDResource, COLORREF clrGripperBack) | CXTPTaskPanelPaintManager | protected
CXTPTaskPanelListViewOfficeXPTheme() | CXTPTaskPanelListViewOfficeXPTheme |
CXTPTaskPanelListViewTheme() | CXTPTaskPanelListViewTheme |
CXTPTaskPanelPaintManager() | CXTPTaskPanelPaintManager |
CXTPTaskPanelPaintManagerPlain() | CXTPTaskPanelPaintManagerPlain |
CXTPTaskPanelToolboxTheme() | CXTPTaskPanelToolboxTheme |
DrawCaptionGripper(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelPaintManager | protectedvirtual
DrawCaptionGripperBitmap(CDC *pDC, CXTPTaskPanelGroup *pGroup, BOOL bExpanded, BOOL bHot, CRect rc) | CXTPTaskPanelPaintManager | protected
DrawCaptionGripperSigns(CDC *pDC, CPoint pt, COLORREF clr, BOOL bExpanded) | CXTPTaskPanelPaintManager | protected
DrawDragArrow(CDC *pDC, CXTPTaskPanelItem *pItem, CRect rc, BOOL bAfter=FALSE) | CXTPTaskPanelPaintManager | protectedvirtual
DrawFocusRect(CDC *pDC, CRect rc) | CXTPTaskPanelPaintManager | protectedvirtual
DrawGroupCaption(CDC *pDC, CXTPTaskPanelGroup *pGroup, BOOL bDraw) | CXTPTaskPanelToolboxTheme | virtual
DrawGroupCaptionBackground(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelToolboxTheme | protectedvirtual
DrawGroupClient(CDC *pDC, CXTPTaskPanelGroup *pGroup) | CXTPTaskPanelPaintManager | virtual
DrawGroupClientFace(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelPaintManagerPlain | virtual
DrawGroupClientItems(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelPaintManager | protectedvirtual
DrawGroupItem(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw) | CXTPTaskPanelPaintManager | virtual
DrawGroupItemFrame(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc) | CXTPTaskPanelPaintManager | virtual
DrawGroupItemImage(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw) | CXTPTaskPanelPaintManager | protected
DrawGroupItemImageWithText(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw) | CXTPTaskPanelPaintManager | protected
DrawGroupItemImageWithTextBelow(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw) | CXTPTaskPanelPaintManager | protected
DrawItemCaption(CDC *pDC, CXTPTaskPanelItem *pItem, CRect rcText, UINT nFormat) | CXTPTaskPanelPaintManager | protectedvirtual
DrawItemImage(CDC *pDC, CXTPTaskPanelItem *pItem, CPoint ptIcon, CXTPImageManagerIcon *pImage, CSize szIcon) | CXTPTaskPanelPaintManager | protectedvirtual
DrawScrollButton(CDC *pDC, CXTPTaskPanelScrollButton *pScrollButton) | CXTPTaskPanelPaintManager | virtual
FillGroupClientFace(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelPaintManagerPlain | virtual
FillTaskPanel(CDC *pDC, CXTPTaskPanel *pTaskPanel) | CXTPTaskPanelPaintManagerPlain | virtual
FreeBitmaps() | CXTPTaskPanelPaintManager | protected
GetCaptionGripperWidth(CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelPaintManager | protectedvirtual
GetControlMargins(const CXTPTaskPanel *pPanel) | CXTPTaskPanelPaintManager | virtual
GetGroupColors(BOOL bSpecial) | CXTPTaskPanelPaintManager |
GetGroupColors(CXTPTaskPanelGroup *pGroup) | CXTPTaskPanelPaintManager | virtual
GetGroupInnerMargins(const CXTPTaskPanelGroup *pGroup) | CXTPTaskPanelPaintManager | virtual
GetGroupOuterMargins(const CXTPTaskPanelGroup *pGroup) | CXTPTaskPanelPaintManager | virtual
GetGroupSpacing(const CXTPTaskPanel *pPanel) | CXTPTaskPanelPaintManager | virtual
GetHighlightOffset(CXTPTaskPanelGroupItem *pItem) | CXTPTaskPanelPaintManager | protectedvirtual
GetItemFont(CXTPTaskPanelItem *pItem) | CXTPTaskPanelPaintManager | virtual
GetItemIconPadding(const CXTPTaskPanelItem *pItem) | CXTPTaskPanelPaintManager | virtual
GetItemInnerMargins(const CXTPTaskPanelGroupItem *pItem) | CXTPTaskPanelPaintManager | virtual
GetItemOuterMargins(const CXTPTaskPanelGroupItem *pItem) | CXTPTaskPanelPaintManager | virtual
m_bBoldCaption | CXTPTaskPanelPaintManager |
m_bCaptionScrollButton | CXTPTaskPanelPaintManager |
m_bEmbossedDisabledText | CXTPTaskPanelPaintManager |
m_bEmulateEplorerTheme | CXTPTaskPanelPaintManager |
m_bInvertDragRect | CXTPTaskPanelPaintManager |
m_bLeftRoundedCorner | CXTPTaskPanelPaintManager | protected
m_bmpGrippers | CXTPTaskPanelPaintManager | protected
m_bOfficeBorder | CXTPTaskPanelPaintManager | protected
m_bOfficeCaption | CXTPTaskPanelPaintManagerPlain | protected
m_bOfficeHighlight | CXTPTaskPanelPaintManager |
m_bRightRoundedCorner | CXTPTaskPanelPaintManager | protected
m_bRoundedFrame | CXTPTaskPanelPaintManagerPlain | protected
m_bUseBitmapGrippers | CXTPTaskPanelPaintManager | protected
m_bUseStandardCaptionFont | CXTPTaskPanelPaintManager | protected
m_bUseStandardItemsFont | CXTPTaskPanelPaintManager | protected
m_clrBackground | CXTPTaskPanelPaintManager | protected
m_clrHighlightBorder | CXTPTaskPanelPaintManager | protected
m_clrHighlightHot | CXTPTaskPanelPaintManager | protected
m_clrHighlightPressed | CXTPTaskPanelPaintManager | protected
m_clrHighlightSelected | CXTPTaskPanelPaintManager | protected
m_eGripper | CXTPTaskPanelPaintManager |
m_groupNormal | CXTPTaskPanelPaintManager | protected
m_groupSpecial | CXTPTaskPanelPaintManager | protected
m_hGripperNormal | CXTPTaskPanelPaintManager | protected
m_hGripperSpecial | CXTPTaskPanelPaintManager | protected
m_nCaptionHeight | CXTPTaskPanelPaintManager | protected
m_nCaptionTextFormat | CXTPTaskPanelPaintManager | protected
m_nGroupSpacing | CXTPTaskPanelPaintManager |
m_nItemTextFormat | CXTPTaskPanelPaintManager | protected
m_rcControlMargins | CXTPTaskPanelPaintManager |
m_rcGroupIconPadding | CXTPTaskPanelPaintManager |
m_rcGroupInnerMargins | CXTPTaskPanelPaintManager |
m_rcGroupOuterMargins | CXTPTaskPanelPaintManager |
m_rcImageLayoutIconPadding | CXTPTaskPanelPaintManager |
m_rcItemIconPadding | CXTPTaskPanelPaintManager |
m_rcItemInnerMargins | CXTPTaskPanelPaintManager |
m_rcItemOuterMargins | CXTPTaskPanelPaintManager |
m_xtpFontCaption | CXTPTaskPanelPaintManager | protected
m_xtpFontIcon | CXTPTaskPanelPaintManager | protected
m_xtpFontIconBold | CXTPTaskPanelPaintManager | protected
m_xtpFontIconHot | CXTPTaskPanelPaintManager | protected
m_xtpFontIconHotBold | CXTPTaskPanelPaintManager | protected
Rectangle(CDC *pDC, CRect rc, COLORREF clrPen, COLORREF clrBrush) | CXTPTaskPanelPaintManager | protected
rectDefault | CXTPTaskPanelPaintManager | static
RefreshMetrics() | CXTPTaskPanelListViewOfficeXPTheme | virtual
SetCaptionFontIndirect(LOGFONT *pLogFont, BOOL bUseStandardCaptionFont=FALSE) | CXTPTaskPanelPaintManager |
SetItemsFontIndirect(LOGFONT *pLogFont, BOOL bUseStandardItemsFont=FALSE) | CXTPTaskPanelPaintManager |
SetTextFormat(int nTextFormat, BOOL bCaption=FALSE) | CXTPTaskPanelPaintManager |
~CXTPTaskPanelPaintManager() | CXTPTaskPanelPaintManager | virtual


Toolkit Pro: XTPDockingPaneColorSet2013.h Source File

  • Source
  • DockingPane
  • ColorSets
XTPDockingPaneColorSet2013.h
Go to the documentation of this file.
1
23#if !defined(__XTPDOCKINGPANECOLORSET2013_H__)
24# define __XTPDOCKINGPANECOLORSET2013_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPDockingPaneColorSet2013 : public CXTPDockingPaneColorSet
39{
40public:
47 virtual void RefreshMetrics(CString strSection);
48};
49
50# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
52#endif // !defined(__XTPDOCKINGPANECOLORSET2013_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPDockingPaneColorSet2013
Helper class used to initialize default colors for a theme from an .INI resource.
Definition XTPDockingPaneColorSet2013.h:39
CXTPDockingPaneColorSet2013::RefreshMetrics
virtual void RefreshMetrics(CString strSection)
This member function is used to initialize default colors for a theme from an .INI resource.
CXTPDockingPaneColorSet
Helper class used to initialize default colors for a theme from an .INI resource.
Definition XTPDockingPaneColorSet.h:39


Toolkit Pro: XTPDialogBase.h Source File

  • Source
  • Controls
  • Dialog
Controls/Dialog/XTPDialogBase.h
Go to the documentation of this file.
1
23#if !defined(__XTPDIALOGBASEEX_H__)
24# define __XTPDIALOGBASEEX_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
35class CXTPCommandBars;
36class CXTPToolBar;
37class CXTPMenuBar;
38
39template<class TBase>
40class CXTPDialogBaseParentWrapper : public TBase
41{
42public:
43 CXTPDialogBaseParentWrapper()
44 {
45 }
46
47 CXTPDialogBaseParentWrapper(UINT nIDTemplate, CWnd* pParentWnd)
48 : TBase(nIDTemplate, pParentWnd)
49 {
50 }
51
52 CXTPDialogBaseParentWrapper(LPCTSTR lpszTemplateName, CWnd* pParentWnd)
53 : TBase(lpszTemplateName, pParentWnd)
54 {
55 }
56
57# if (_MSC_VER > 1200)
58 CXTPDialogBaseParentWrapper(UINT nIDTemplate, UINT nHtmlResID, CWnd* pParentWnd)
59 : TBase(nIDTemplate, pParentWnd)
60 {
61 _ASSERTE(!"This constructor is added for interface compatibility only and must never be "
62 "called for a non-DHTML dialog");
63
64 UNREFERENCED_PARAMETER(nHtmlResID);
65 }
66
67 CXTPDialogBaseParentWrapper(LPCTSTR lpszTemplateName, LPCTSTR szHtmlResID, CWnd* pParentWnd)
68 : TBase(lpszTemplateName, pParentWnd)
69 {
70 _ASSERTE(!"This constructor is added for interface compatibility only and must never be "
71 "called for a non-DHTML dialog");
72
73 UNREFERENCED_PARAMETER(szHtmlResID);
74 }
75# endif // (_MSC_VER > 1200)
76};
77
78# if (_MSC_VER > 1200)
79template<>
80class CXTPDialogBaseParentWrapper<CDHtmlDialog> : public CDHtmlDialog
81{
82public:
83 CXTPDialogBaseParentWrapper()
84 {
85 }
86
87 CXTPDialogBaseParentWrapper(UINT nIDTemplate, CWnd* pParentWnd)
88 : CDHtmlDialog(nIDTemplate, 0, pParentWnd)
89 {
90 _ASSERTE(!"This constructor is added for interface compatibility only and must never be "
91 "called for a DHTML dialog");
92 }
93
94 CXTPDialogBaseParentWrapper(LPCTSTR lpszTemplateName, CWnd* pParentWnd)
95 : CDHtmlDialog(lpszTemplateName, 0, pParentWnd)
96 {
97 _ASSERTE(!"This constructor is added for interface compatibility only and must never be "
98 "called for a DHTML dialog");
99 }
100
101 CXTPDialogBaseParentWrapper(UINT nIDTemplate, UINT nHtmlResID, CWnd* pParentWnd)
102 : CDHtmlDialog(nIDTemplate, nHtmlResID, pParentWnd)
103 {
104 }
105
106 CXTPDialogBaseParentWrapper(LPCTSTR lpszTemplateName, LPCTSTR szHtmlResID, CWnd* pParentWnd)
107 : CDHtmlDialog(lpszTemplateName, szHtmlResID, pParentWnd)
108 {
109 }
110};
111
112template<>
113class CXTPDialogBaseParentWrapper<CXTPResizeDHtmlDialog> : public CXTPResizeDHtmlDialog
114{
115public:
116 CXTPDialogBaseParentWrapper()
117 {
118 }
119
120 CXTPDialogBaseParentWrapper(UINT nIDTemplate, CWnd* pParentWnd)
121 : CXTPResizeDHtmlDialog(nIDTemplate, 0, pParentWnd)
122 {
123 _ASSERTE(!"This constructor is added for interface compatibility only and must never be "
124 "called for a DHTML dialog");
125 }
126
127 CXTPDialogBaseParentWrapper(LPCTSTR lpszTemplateName, CWnd* pParentWnd)
128 : CXTPResizeDHtmlDialog(lpszTemplateName, 0, pParentWnd)
129 {
130 _ASSERTE(!"This constructor is added for interface compatibility only and must never be "
131 "called for a DHTML dialog");
132 }
133
134 CXTPDialogBaseParentWrapper(UINT nIDTemplate, UINT nHtmlResID, CWnd* pParentWnd)
135 : CXTPResizeDHtmlDialog(nIDTemplate, nHtmlResID, pParentWnd)
136 {
137 }
138
139 CXTPDialogBaseParentWrapper(LPCTSTR lpszTemplateName, LPCTSTR szHtmlResID, CWnd* pParentWnd)
140 : CXTPResizeDHtmlDialog(lpszTemplateName, szHtmlResID, pParentWnd)
141 {
142 }
143};
144
145# endif // (_MSC_VER > 1200)
146
147class _XTP_EXT_CLASS CXTPDialogBaseImpl
148{
149protected:
150 CXTPDialogBaseImpl()
151 {
152# ifdef _XTP_INCLUDE_COMMANDBARS
153 m_pCommandBars = 0;
154# endif
155 }
156
157 virtual ~CXTPDialogBaseImpl();
158
159# ifdef _XTP_INCLUDE_COMMANDBARS
160 virtual BOOL InitCommandBars(CRuntimeClass* pCommandBarsClass = NULL);
161 void DockRightOf(CXTPToolBar* pBarToDock, CXTPToolBar* pBarOnLeft);
162 virtual void SaveCommandBars(LPCTSTR lpszProfileName);
163 virtual void LoadCommandBars(LPCTSTR lpszProfileName, BOOL bSilent = FALSE);
164 virtual BOOL PreTranslateMessage(MSG* pMsg);
165 virtual BOOL OnWndMsg(UINT message, WPARAM wParam, LPARAM lParam, LRESULT* pResult);
166
167 virtual CWnd* GetCommandBarsSite() = 0;
168
169 CXTPCommandBars* GetCommandBars() const
170 {
171 return m_pCommandBars;
172 }
173
174private:
175 CXTPCommandBars* m_pCommandBars;
176# endif
177};
178
186template<class TBase>
187class CXTPDialogBase
188 : public CXTPDialogBaseParentWrapper<TBase>
189 , private CXTPDialogBaseImpl
190{
191 typedef CXTPDialogBaseParentWrapper<TBase> Parent;
192
193public:
198 CXTPDialogBase()
199 {
200 }
201
208 CXTPDialogBase(UINT nIDTemplate, CWnd* pParentWnd = NULL)
209 : CXTPDialogBaseParentWrapper<TBase>(nIDTemplate, pParentWnd)
210 {
211 }
212
220 CXTPDialogBase(LPCTSTR lpszTemplateName, CWnd* pParentWnd = NULL)
221 : CXTPDialogBaseParentWrapper<TBase>(lpszTemplateName, pParentWnd)
222 {
223 }
224
225# if (_MSC_VER > 1200)
233 CXTPDialogBase(UINT nIDTemplate, UINT nHtmlResID, CWnd* pParentWnd = NULL)
234 : CXTPDialogBaseParentWrapper<TBase>(nIDTemplate, nHtmlResID, pParentWnd)
235 {
236 }
237
246 CXTPDialogBase(LPCTSTR lpszTemplateName, LPCTSTR szHtmlResID, CWnd* pParentWnd = NULL)
247 : CXTPDialogBaseParentWrapper<TBase>(lpszTemplateName, szHtmlResID, pParentWnd)
248 {
249 }
250# endif
251
252# ifdef _XTP_INCLUDE_COMMANDBARS
262 virtual BOOL InitCommandBars(CRuntimeClass* pCommandBarsClass = NULL)
263 {
264 return CXTPDialogBaseImpl::InitCommandBars(pCommandBarsClass);
265 }
266
267 using CXTPDialogBaseParentWrapper<TBase>::RepositionBars;
268
276 void DockRightOf(CXTPToolBar* pBarToDock, CXTPToolBar* pBarOnLeft)
277 {
278 CXTPDialogBaseImpl::DockRightOf(pBarToDock, pBarOnLeft);
279 }
280
290 virtual void SaveCommandBars(LPCTSTR lpszProfileName)
291 {
292 CXTPDialogBaseImpl::SaveCommandBars(lpszProfileName);
293 }
294
306 virtual void LoadCommandBars(LPCTSTR lpszProfileName, BOOL bSilent = FALSE)
307 {
308 CXTPDialogBaseImpl::LoadCommandBars(lpszProfileName, bSilent);
309 }
310
317 CXTPCommandBars* GetCommandBars() const
318 {
319 return CXTPDialogBaseImpl::GetCommandBars();
320 }
321
323protected:
324 virtual CWnd* GetCommandBarsSite()
325 {
326 return this;
327 }
328
329 virtual BOOL PreTranslateMessage(MSG* pMsg)
330 {
331 if (CXTPDialogBaseImpl::PreTranslateMessage(pMsg))
332 return TRUE;
333
334 if (TBase::PreTranslateMessage(pMsg))
335 return TRUE;
336
337 return FALSE;
338 }
339
340 virtual BOOL OnWndMsg(UINT message, WPARAM wParam, LPARAM lParam, LRESULT* pResult)
341 {
342 if (CXTPDialogBaseImpl::OnWndMsg(message, wParam, lParam, pResult))
343 return TRUE;
344
345 return TBase::OnWndMsg(message, wParam, lParam, pResult);
346 }
347
349# endif
350};
351
357class _XTP_EXT_CLASS CXTPDialogEx : public CXTPDialogBase<CDialog>
358{
359public:
364 CXTPDialogEx()
365 {
366 }
367
374 CXTPDialogEx(UINT nIDTemplate, CWnd* pParentWnd = NULL)
375 : CXTPDialogBase<CDialog>(nIDTemplate, pParentWnd)
376 {
377 }
378
386 CXTPDialogEx(LPCTSTR lpszTemplateName, CWnd* pParentWnd = NULL)
387 : CXTPDialogBase<CDialog>(lpszTemplateName, pParentWnd)
388 {
389 }
390
392# ifdef _XTP_INCLUDE_COMMANDBARS
393 _XTP_DEPRECATE("Use CXTPCommandBars::SetMenu instead")
394 void SetMenuBar(CXTPMenuBar* pMenuBar);
395# endif
397};
398
399# if (_MSC_VER > 1200)
405class _XTP_EXT_CLASS CXTPDHtmlDialogEx : public CXTPDialogBase<CDHtmlDialog>
406{
407public:
412 CXTPDHtmlDialogEx()
413 {
414 }
415
423 CXTPDHtmlDialogEx(UINT nIDTemplate, UINT nHtmlResID = 0, CWnd* pParentWnd = NULL)
424 : CXTPDialogBase<CDHtmlDialog>(nIDTemplate, nHtmlResID, pParentWnd)
425 {
426 }
427
437 CXTPDHtmlDialogEx(LPCTSTR lpszTemplateName, LPCTSTR szHtmlResID, CWnd* pParentWnd = NULL)
438 : CXTPDialogBase<CDHtmlDialog>(lpszTemplateName, szHtmlResID, pParentWnd)
439 {
440 }
441
443# ifdef _XTP_INCLUDE_COMMANDBARS
444 _XTP_DEPRECATE("Use CXTPCommandBars::SetMenu instead")
445 void SetMenuBar(CXTPMenuBar* pMenuBar);
446# endif
448};
449# endif
450
451# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
453#endif // #if !defined(__XTPDIALOGBASEEX_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCommandBars
CXTPCommandBars is a standalone class.
Definition XTPCommandBars.h:165
CXTPDialogBase
CXTPDialogBase is a TBase derived class.
Definition Controls/Dialog/XTPDialogBase.h:190
CXTPDialogBase::CXTPDialogBase
CXTPDialogBase()
Constructs a CXTPDialog object.
Definition Controls/Dialog/XTPDialogBase.h:198
CXTPDialogBase::CXTPDialogBase
CXTPDialogBase(LPCTSTR lpszTemplateName, CWnd *pParentWnd=NULL)
Constructs a CXTPDialog object.
Definition Controls/Dialog/XTPDialogBase.h:220
CXTPDialogBase::CXTPDialogBase
CXTPDialogBase(UINT nIDTemplate, CWnd *pParentWnd=NULL)
Constructs a CXTPDialog object.
Definition Controls/Dialog/XTPDialogBase.h:208
CXTPDialogEx
CXTPDialogEx is a CXTPDialogBase derived class.
Definition Controls/Dialog/XTPDialogBase.h:358
CXTPDialogEx::CXTPDialogEx
CXTPDialogEx(UINT nIDTemplate, CWnd *pParentWnd=NULL)
Constructs a CXTPDialogEx object.
Definition Controls/Dialog/XTPDialogBase.h:374
CXTPDialogEx::CXTPDialogEx
CXTPDialogEx(LPCTSTR lpszTemplateName, CWnd *pParentWnd=NULL)
Constructs a CXTPDialogEx object.
Definition Controls/Dialog/XTPDialogBase.h:386
CXTPDialogEx::CXTPDialogEx
CXTPDialogEx()
Constructs a CXTPDialogEx object.
Definition Controls/Dialog/XTPDialogBase.h:364
CXTPMenuBar
CXTPMenuBar is a CXTPToolBar derived class.
Definition XTPMenuBar.h:141
CXTPToolBar
CXTPToolBar is a CXTPCommandBar derived class.
Definition XTPToolBar.h:42


Toolkit Pro: XTPCalendarThemePrevNextEventButtons.h Source File

  • Source
  • Calendar
XTPCalendarThemePrevNextEventButtons.h
Go to the documentation of this file.
1
22#if !defined(__XTPCALENDARTHEMEOFFICE2007PREVNEXTEVENTBUTTONS_H__)
23# define __XTPCALENDARTHEMEOFFICE2007PREVNEXTEVENTBUTTONS_H__
24
25# if _MSC_VER > 1000
26# pragma once
27# endif // _MSC_VER > 1000
28
29# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
30
31DECLARE_THEMEPART(CTOPrevNextEventButtons, CXTPCalendarThemePart)
32
33CTOPrevNextEventButtons();
34virtual ~CTOPrevNextEventButtons();
35
36DECLARE_THEMEPART_MEMBER_(0, CTOPrevNextEventButton, PrevEventButton, CXTPCalendarThemePart)
37DECLARE_THEMEPART_MEMBER_(1, CTOPrevNextEventButton, NextEventButton, CXTPCalendarThemePart)
38
39virtual void RefreshMetrics(BOOL bRefreshChildren = TRUE);
40virtual void AdjustLayout(CXTPCalendarView* pObject, CDC* pDC, const CRect& rcRect);
41
42virtual void Draw(CXTPCalendarView* pObject, CDC* pDC);
43virtual void Draw(CCmdTarget* pObject, CDC* pDC);
44
45virtual int HitTest(const CPoint* pPoint = NULL)
46 const; // return 0, xtpCalendarHitTestPrevEventButton or xtpCalendarHitTestNextEventButton
47
48virtual BOOL IsPrevNextButtonsVisible();
49
50virtual BOOL _IsSomeEventVisible();
51COleDateTime GetVisibleDay(BOOL bFirst);
52
53virtual BOOL GetPrevEventDay(COleDateTime* pdtDay = NULL);
54virtual BOOL GetNextEventDay(COleDateTime* pdtDay = NULL);
55
56virtual void OnStatusChanged();
57
58virtual void OnMouseMove(CCmdTarget* pObject, UINT nFlags, CPoint point);
59virtual BOOL OnLButtonDown(CCmdTarget* pObject, UINT nFlags, CPoint point);
60
61// Settings
62 CXTPCalendarThemeBOOLValue m_bHide;
63
64 CXTPCalendarThemeIntValue m_nIdleStepTime_ms;
65 CXTPCalendarThemeIntValue m_nRefreshDaysPerIdleStep;
66 CXTPCalendarThemeBOOLValue m_bUseActiveViewResources;
67
68virtual void SetCacheSize(int nDays);
69
70protected:
71 CXTPCalendarResources* _GetActiveResources();
72
73void _RequestToFindEvents();
74void _StopRequests();
75BOOL _RefreshDay(long ndtDay, BOOL& rbRefreshed, BOOL bRefreshPermanently);
76
77// void _ResetData();
78
79virtual BOOL OnTimer(UINT_PTR uTimerID);
80virtual void OnDetachCalendar();
81
82UINT_PTR m_nRefreshTimerID;
83
84long m_ndtRefreshDatePrev;
85long m_ndtRefreshDateNext;
86
87BOOL m_bScanPrev;
88BOOL m_bScanNext;
89
90long m_ndtMinScanDay;
91long m_ndtMaxScanDay;
92
93CRect m_rcRect;
94
95class CDaysMap : protected CArray<char, char>
96{
97protected:
98 long m_nDaysOffset;
99 int m_nCacheSizeMax_days;
100
101public:
102 CDaysMap();
103
104 long GetMinDay();
105 long GetMaxDay();
106
107 int GetDayState(long nDay);
108 void SetDayState(long nDay,
109 int nState);
110 void SetDaysStateSafe(long nDayStart, long nDayEnd,
111 int nState);
114 void AdjustMiddleDay(long nDay);
115
116 void SetDataSize(int nDays);
117 int GetDataSize();
118
119protected:
120 void _GrowArrayIfNeed(long nDay);
121};
122
123CDaysMap m_mapDaysState;
124
125protected:
126CXTPNotifySink* m_pSink;
127virtual void OnEvent_Calendar(XTP_NOTIFY_CODE Event, WPARAM wParam, LPARAM lParam);
128}
129;
130
131# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
132
133#endif // __XTPCALENDARTHEMEOFFICE2007PREVNEXTEVENTBUTTONS_H__
pPoint
const CPoint * pPoint
return 0 or xtpCalendarHitTestDayExpandButton
Definition XTPCalendarThemeOffice2007.h:150
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCalendarResources
This class represents a simple array collection of CXTPCalendarResource objects.
Definition XTPCalendarResource.h:555
CXTPCalendarThemeBOOLValue
Helper class provides functionality to manage customized BOOL value objects.
Definition XTPCalendarViewPart.h:1123
CXTPCalendarThemeIntValue
Helper class provides functionality to manage customized int value objects.
Definition XTPCalendarViewPart.h:1070
CXTPCalendarView
This class represents the view portion of the Calendar control.
Definition XTPCalendarView.h:360


Toolkit Pro: Member List

CXTPSyntaxEditLexVariant Member List

This is the complete list of members for CXTPSyntaxEditLexVariant, including all inherited members.

Clone() const | CXTPSyntaxEditLexVariant | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPSyntaxEditLexVariant() | CXTPSyntaxEditLexVariant |
CXTPSyntaxEditLexVariant(const CXTPSyntaxEditLexVariant &rSrc) | CXTPSyntaxEditLexVariant |
CXTPSyntaxEditLexVariant(CXTPSyntaxEditLexClass *pClass) | CXTPSyntaxEditLexVariant |
CXTPSyntaxEditLexVariant(CXTPSyntaxEditLexVariantPtrArray *pLVArray) | CXTPSyntaxEditLexVariant |
CXTPSyntaxEditLexVariant(const CXTPSyntaxEditLexVariable &rSrcVar) | CXTPSyntaxEditLexVariant |
CXTPSyntaxEditLexVariant(LPCTSTR pcszStr, int eType=xtpEditLVT_valStr) | CXTPSyntaxEditLexVariant |
CXTPSyntaxEditLexVariant(const CStringArray *pArStrVals) | CXTPSyntaxEditLexVariant |
CXTPSyntaxEditLexVariant(int nValue) | CXTPSyntaxEditLexVariant |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetStr() const | CXTPSyntaxEditLexVariant | virtual
IsStrType() const | CXTPSyntaxEditLexVariant | virtual
m_arStrVals | CXTPSyntaxEditLexVariant |
m_nObjType | CXTPSyntaxEditLexVariant |
m_nValue | CXTPSyntaxEditLexVariant |
m_ptrClass | CXTPSyntaxEditLexVariant |
m_ptrLVArrayPtr | CXTPSyntaxEditLexVariant |
m_Variable | CXTPSyntaxEditLexVariant |
operator=(const CXTPSyntaxEditLexVariant &rSrc) | CXTPSyntaxEditLexVariant |
operator=(int nVal) | CXTPSyntaxEditLexVariant |
operator=(const CXTPSyntaxEditLexVariable &rSrcVar) | CXTPSyntaxEditLexVariant |
operator==(const CXTPSyntaxEditLexVariant &rSrc) const | CXTPSyntaxEditLexVariant |
SetVariable(LPCTSTR pcszVarName) | CXTPSyntaxEditLexVariant | virtual
~CXTPSyntaxEditLexVariant() | CXTPSyntaxEditLexVariant | virtual


Toolkit Pro: Member List

XTP_SCROLLBAR_TRACKINFO Member List

This is the complete list of members for XTP_SCROLLBAR_TRACKINFO, including all inherited members.

bTrackThumb | XTP_SCROLLBAR_TRACKINFO
cmdSB | XTP_SCROLLBAR_TRACKINFO
dpxThumb | XTP_SCROLLBAR_TRACKINFO
fHitOld | XTP_SCROLLBAR_TRACKINFO
hTimerSB | XTP_SCROLLBAR_TRACKINFO
hWndTrack | XTP_SCROLLBAR_TRACKINFO
posNew | XTP_SCROLLBAR_TRACKINFO
posOld | XTP_SCROLLBAR_TRACKINFO
pSBInfo | XTP_SCROLLBAR_TRACKINFO
pxOld | XTP_SCROLLBAR_TRACKINFO
rcTrack | XTP_SCROLLBAR_TRACKINFO


Toolkit Pro: Member List

CXTPProgressThemeVisualStudio2017 Member List

This is the complete list of members for CXTPProgressThemeVisualStudio2017, including all inherited members.

CXTPProgressPaintManager(CXTPPaintManager *pPaintManager) | CXTPProgressPaintManager |
CXTPProgressThemeOffice2013(CXTPPaintManager *pPaintManager) | CXTPProgressThemeOffice2013 |
CXTPProgressThemeVisualStudio2017(CXTPPaintManager *pPaintManager) | CXTPProgressThemeVisualStudio2017 |
DrawProgress(CDC *pDC, CXTPProgressBase *pProgressBar) | CXTPProgressThemeOffice2013 | virtual
GetPaintManager() const | CXTPProgressPaintManager |
m_clrBack | CXTPProgressThemeOffice2013 | protected
m_clrBar | CXTPProgressThemeOffice2013 | protected
m_clrBorder | CXTPProgressThemeOffice2013 | protected
m_cyProgress | CXTPProgressPaintManager |
m_pPaintManager | CXTPProgressPaintManager | protected
RefreshMetrics() | CXTPProgressThemeOffice2013 | virtual
~CXTPProgressPaintManager() | CXTPProgressPaintManager | virtual
~CXTPProgressThemeOffice2013() | CXTPProgressThemeOffice2013 | virtual
~CXTPProgressThemeVisualStudio2017() | CXTPProgressThemeVisualStudio2017 | virtual


Toolkit Pro: XTPGridRecord.h Source File

  • Source
  • GridControl
XTPGridRecord.h
Go to the documentation of this file.
1
23#if !defined(__XTPGRIDRECORD_H__)
24# define __XTPGRIDRECORD_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPGridRecordItem;
34class CXTPGridRecordItemPreview;
35class CXTPGridColumn;
36class CXTPGridRecords;
37class CXTPPropExchange;
38class CXTPMarkupContext;
39
40struct XTP_GRIDRECORDITEM_DRAWARGS;
41struct XTP_GRIDRECORDITEM_METRICS;
42
58class _XTP_EXT_CLASS CXTPGridRecord : public CXTPHeapObjectT<CXTPCmdTarget, CXTPGridDataAllocator>
59{
60 friend class CXTPGridRecords;
61 friend class CXTPGridRow;
62 friend class CXTPGridControl;
63 friend class CXTPGridRecordItem;
64 friend class CXTPGridPaintManager;
66 DECLARE_SERIAL(CXTPGridRecord)
68public:
73 CXTPGridRecord();
74
79 virtual ~CXTPGridRecord();
80
89 int GetItemCount() const;
90
104 CXTPGridRecordItem* GetItem(int nIndex) const;
105
119 CXTPGridRecordItem* GetItem(CXTPGridColumn* pColumn) const;
120
133 CXTPGridRecordItemPreview* GetItemPreview() const;
134
145 void SetPreviewItem(CXTPGridRecordItemPreview* pItemPreview);
146
155 BOOL IsVisible() const;
156
165 void SetVisible(BOOL bVisible);
166
175 BOOL IsLocked() const;
176
188 void SetLocked(BOOL bLocked);
189
198 BOOL IsEditable() const;
199
205 void SetEditable(BOOL bEditable = TRUE);
206
216 CXTPGridRecords* GetChilds();
217
224 CXTPGridRecords* GetRecords() const;
225
234 BOOL HasChildren() const;
235
240 void RemoveAll();
241
250 int IndexOf(const CXTPGridRecordItem* pItem) const;
251
261 virtual void GetItemMetrics(XTP_GRIDRECORDITEM_DRAWARGS* pDrawArgs,
262 XTP_GRIDRECORDITEM_METRICS* pItemMetrics);
263
275 virtual BOOL UpdateRecordField(int row, int index, CString sText);
276
288 BOOL IsExpanded() const;
289
300 virtual void SetExpanded(BOOL bExpanded);
301
302 BOOL IsSelected() const;
303
304 void SetSelected(BOOL bSelected);
305
312 virtual BOOL IsFiltered() const;
313
320 int GetIndex() const;
321
329 CXTPGridRecordItem* AddItem(CXTPGridRecordItem* pItem);
330
337 virtual void DoPropExchange(CXTPPropExchange* pPX);
338
343 void Delete();
344
349 void TreeAddRef();
350
355 void TreeRelease();
356
362 void SetBookmark(VARIANT vtBookmark);
363
370 VARIANT GetBookmark() const;
371
378 CXTPMarkupContext* GetMarkupContext() const;
379
386 CXTPGridRecord* GetParentRecord() const;
387
394 int GetFreeHeight();
395
401 void SetFreeHeight(int nFreeHeight);
402
403protected:
404 void SetGridControl(CXTPGridControl* pGridControl);
405
407 _XTP_DEPRECATED_IN_FAVOR(SetGridControl)
408 void SetReportControl(CXTPGridControl* pGridControl);
411protected:
412 CArray<CXTPGridRecordItem*, CXTPGridRecordItem*> m_arrItems;
415 CXTPGridRecordItemPreview* m_pPreviewItem;
417 CXTPGridControl* m_pControl;
418 CXTPGridRecords* m_pRecords;
419 CXTPGridRecords* m_pChildren;
421 BOOL m_bExpanded;
422 BOOL m_bEditable;
423 BOOL m_bVisible;
424 BOOL m_bLocked;
425 BOOL m_bSelected;
427 int m_nFreeHeight;
428 int m_nIndex;
429 VARIANT m_vtBookmark;
431# ifdef _XTP_ACTIVEX
433 DECLARE_DISPATCH_MAP()
434 DECLARE_INTERFACE_MAP()
435
436 DECLARE_OLETYPELIB_EX(CXTPGridRecord);
437 DECLARE_OLECREATE_EX(CXTPGridRecord);
438
439 int OleGetItemCount();
440 afx_msg LPDISPATCH OleGetItem(long nIndex);
441 afx_msg LPDISPATCH OleAdd(const VARIANT& lpValue);
442 afx_msg LPDISPATCH OleGetChilds();
443 afx_msg LPDISPATCH OleGetParentRecord();
444 afx_msg LPDISPATCH OleGetRecords();
445 afx_msg void OleAddEx(LPDISPATCH lpDisp);
446
447 DECLARE_ENUM_VARIANT(CXTPGridRecord)
448
449 afx_msg BSTR OleGetPreviewText();
450 afx_msg void OleSetPreviewText(LPCTSTR lpszText);
451 afx_msg LPDISPATCH OleGetPreviewItem();
452 afx_msg int OleGetFreeHeight();
453 afx_msg void OleSetFreeHeight(int nFreeHeight);
454
455 enum
456 {
457 dispidCount = 1L,
458 dispidAdd = 2L,
459 dispidFindColumn = 4L,
460 };
461
462 COleVariant m_oleTag;
463
464public:
465 static CXTPGridRecord* AFX_CDECL FromDispatch(LPDISPATCH pDisp);
466
468# endif /*_XTP_ACTIVEX*/
469};
470
471AFX_INLINE int CXTPGridRecord::GetItemCount() const
472{
473 return (int)m_arrItems.GetSize();
474}
475
476AFX_INLINE CXTPGridRecordItem* CXTPGridRecord::GetItem(int nIndex) const
477{
478 return nIndex >= 0 && nIndex < GetItemCount() ? m_arrItems.GetAt(nIndex) : NULL;
479}
480
481AFX_INLINE BOOL CXTPGridRecord::IsVisible() const
482{
483 return m_bVisible;
484}
485
486AFX_INLINE void CXTPGridRecord::SetVisible(BOOL bVisible)
487{
488 m_bVisible = bVisible;
489}
490
491AFX_INLINE BOOL CXTPGridRecord::IsEditable() const
492{
493 return m_bEditable;
494}
495
496AFX_INLINE BOOL CXTPGridRecord::IsExpanded() const
497{
498 return m_bExpanded;
499}
500
501AFX_INLINE BOOL CXTPGridRecord::IsLocked() const
502{
503 return m_bLocked;
504}
505
506AFX_INLINE void CXTPGridRecord::SetLocked(BOOL bLocked)
507{
508 m_bLocked = bLocked;
509}
510
511AFX_INLINE BOOL CXTPGridRecord::IsSelected() const
512{
513 return m_bSelected;
514}
515
516AFX_INLINE void CXTPGridRecord::SetSelected(BOOL bSelected)
517{
518 m_bSelected = bSelected;
519}
520
521AFX_INLINE int CXTPGridRecord::GetFreeHeight()
522{
523 return m_nFreeHeight;
524}
525
526AFX_INLINE void CXTPGridRecord::SetFreeHeight(int nFreeHeight)
527{
528 m_nFreeHeight = nFreeHeight;
529}
530
531AFX_INLINE void CXTPGridRecord::GetItemMetrics(XTP_GRIDRECORDITEM_DRAWARGS* pDrawArgs,
532 XTP_GRIDRECORDITEM_METRICS* pItemMetrics)
533{
534 UNREFERENCED_PARAMETER(pDrawArgs);
535 UNREFERENCED_PARAMETER(pItemMetrics);
536}
537
538AFX_INLINE BOOL CXTPGridRecord::UpdateRecordField(int /*row*/, int /*index*/, CString /*sText*/)
539{
540 return TRUE;
541}
542AFX_INLINE CXTPGridRecords* CXTPGridRecord::GetRecords() const
543{
544 return m_pRecords;
545}
546AFX_INLINE void CXTPGridRecord::SetBookmark(VARIANT vtBookmark)
547{
548 m_vtBookmark = vtBookmark;
549}
550AFX_INLINE VARIANT CXTPGridRecord::GetBookmark() const
551{
552 return m_vtBookmark;
553}
555AFX_INLINE void CXTPGridRecord::SetReportControl(CXTPGridControl* pGridControl)
556{
557 SetGridControl(pGridControl);
558}
559
560# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
561#endif //#if !defined(__XTPGRIDRECORD_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPGridColumn
Represents a grid column item with its properties and operations.
Definition XTPGridColumn.h:107
CXTPGridControl
The CXTPGridControl class provides an implementation of the Grid control.
Definition XTPGridControl.h:479
CXTPGridPaintManager
Utility class that handles most drawing activities.
Definition XTPGridPaintManager.h:76
CXTPGridRecord
CXTPGridRecord represents a collection of CXTPGridRecordItem objects or objects of classes that are c...
Definition XTPGridRecord.h:59
CXTPGridRecord::TreeAddRef
void TreeAddRef()
Increments the reference counter of a record and all of its children.
CXTPGridRecord::SetBookmark
void SetBookmark(VARIANT vtBookmark)
Sets the bookmark for the data source record.
Definition XTPGridRecord.h:546
CXTPGridRecord::DoPropExchange
virtual void DoPropExchange(CXTPPropExchange *pPX)
Call this member function to store/load a grid record with record items using the specified data obje...
CXTPGridRecord::m_pChildren
CXTPGridRecords * m_pChildren
A collection of children records.
Definition XTPGridRecord.h:419
CXTPGridRecord::m_pPreviewItem
CXTPGridRecordItemPreview * m_pPreviewItem
Preview item for record.
Definition XTPGridRecord.h:415
CXTPGridRecord::m_pRecords
CXTPGridRecords * m_pRecords
Parent records collection.
Definition XTPGridRecord.h:418
CXTPGridRecord::m_vtBookmark
VARIANT m_vtBookmark
Bookmark to data source record for data binding.
Definition XTPGridRecord.h:429
CXTPGridRecord::GetItem
CXTPGridRecordItem * GetItem(CXTPGridColumn *pColumn) const
Retrieves a record item by its index/column.
CXTPGridRecord::IsLocked
BOOL IsLocked() const
Gets the locked state of the record.
Definition XTPGridRecord.h:501
CXTPGridRecord::SetVisible
void SetVisible(BOOL bVisible)
Sets the visible state for the record.
Definition XTPGridRecord.h:486
CXTPGridRecord::CXTPGridRecord
CXTPGridRecord()
Constructs a CXTPGridRecord object.
CXTPGridRecord::SetFreeHeight
void SetFreeHeight(int nFreeHeight)
Sets the height for rows in FreeHeight RC mode.
Definition XTPGridRecord.h:526
CXTPGridRecord::m_bExpanded
BOOL m_bExpanded
TRUE if the record is expanded, FALSE otherwise.
Definition XTPGridRecord.h:421
CXTPGridRecord::m_nFreeHeight
int m_nFreeHeight
Height of a visual row in FreeHeight RC mode.
Definition XTPGridRecord.h:427
CXTPGridRecord::SetExpanded
virtual void SetExpanded(BOOL bExpanded)
Sets the expanded state for the record.
CXTPGridRecord::GetItemMetrics
virtual void GetItemMetrics(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pItemMetrics)
Calculates item metrics based on specified draw arguments.
Definition XTPGridRecord.h:531
CXTPGridRecord::m_bSelected
BOOL m_bSelected
TRUE if the record is selected, FALSE otherwise.
Definition XTPGridRecord.h:425
CXTPGridRecord::TreeRelease
void TreeRelease()
Decrements the reference counter of a record and all of its children.
CXTPGridRecord::IsExpanded
BOOL IsExpanded() const
Gets the expanded state of the record.
Definition XTPGridRecord.h:496
CXTPGridRecord::m_nIndex
int m_nIndex
Index of the record within the collection records.
Definition XTPGridRecord.h:428
CXTPGridRecord::m_bLocked
BOOL m_bLocked
TRUE if the record is locked, FALSE otherwise.
Definition XTPGridRecord.h:424
CXTPGridRecord::m_arrItems
CArray< CXTPGridRecordItem *, CXTPGridRecordItem * > m_arrItems
An internal storage for record items.
Definition XTPGridRecord.h:412
CXTPGridRecord::m_bEditable
BOOL m_bEditable
TRUE if the record is editable, FALSE otherwise.
Definition XTPGridRecord.h:422
CXTPGridRecord::GetBookmark
VARIANT GetBookmark() const
Gets the bookmark to the data source record.
Definition XTPGridRecord.h:550
CXTPGridRecord::IsVisible
BOOL IsVisible() const
Gets the visible state of the record.
Definition XTPGridRecord.h:481
CXTPGridRecord::GetChilds
CXTPGridRecords * GetChilds()
Gets the list of child items of the record.
CXTPGridRecord::GetItem
CXTPGridRecordItem * GetItem(int nIndex) const
Retrieves a record item by its index/column.
Definition XTPGridRecord.h:476
CXTPGridRecord::HasChildren
BOOL HasChildren() const
Determines if the record has child records.
CXTPGridRecord::GetRecords
CXTPGridRecords * GetRecords() const
Gets the list of parent items of the record.
Definition XTPGridRecord.h:542
CXTPGridRecord::IsFiltered
virtual BOOL IsFiltered() const
Determines if the record is filtered.
CXTPGridRecord::m_pControl
CXTPGridControl * m_pControl
Pointer to the parent Grid control.
Definition XTPGridRecord.h:417
CXTPGridRecord::GetFreeHeight
int GetFreeHeight()
Gets the height of rows in FreeHeight RC mode.
Definition XTPGridRecord.h:521
CXTPGridRecord::RemoveAll
void RemoveAll()
Removes all items from the record.
CXTPGridRecord::SetEditable
void SetEditable(BOOL bEditable=TRUE)
Sets the editable state for the record.
CXTPGridRecord::SetPreviewItem
void SetPreviewItem(CXTPGridRecordItemPreview *pItemPreview)
Sets the associated preview item for the record.
CXTPGridRecord::~CXTPGridRecord
virtual ~CXTPGridRecord()
Destroys a CXTPGridRecord object, handles cleanup and deallocation.
CXTPGridRecord::IndexOf
int IndexOf(const CXTPGridRecordItem *pItem) const
Gets the index of a specified record item object.
CXTPGridRecord::m_bVisible
BOOL m_bVisible
TRUE if the record is visible, FALSE otherwise.
Definition XTPGridRecord.h:423
CXTPGridRecord::GetItemCount
int GetItemCount() const
Gets the number of items inside the record.
Definition XTPGridRecord.h:471
CXTPGridRecord::GetItemPreview
CXTPGridRecordItemPreview * GetItemPreview() const
Gets the associated preview item of the record.
CXTPGridRecord::Delete
void Delete()
Removes the record.
CXTPGridRecord::IsEditable
BOOL IsEditable() const
Gets the editable state of the record.
Definition XTPGridRecord.h:491
CXTPGridRecord::GetParentRecord
CXTPGridRecord * GetParentRecord() const
Gets the parent record.
CXTPGridRecord::SetLocked
void SetLocked(BOOL bLocked)
Sets the locked state for the record.
Definition XTPGridRecord.h:506
CXTPGridRecord::GetMarkupContext
CXTPMarkupContext * GetMarkupContext() const
Gets the markup context.
CXTPGridRecord::AddItem
CXTPGridRecordItem * AddItem(CXTPGridRecordItem *pItem)
Adds a record item to the internal records item collection.
CXTPGridRecord::GetIndex
int GetIndex() const
Gets the record index in the array.
CXTPGridRecord::UpdateRecordField
virtual BOOL UpdateRecordField(int row, int index, CString sText)
Updates DataSet in VirtualMode without involving _RecordsetPtr.
Definition XTPGridRecord.h:538
CXTPGridRecordItem
Class for working with single list cell.
Definition XTPGridRecordItem.h:600
CXTPGridRecordItemPreview
This represents a preview cell and inherits basic functionality from the CXTPGridRecordItem class.
Definition XTPGridRecordItemPreview.h:44
CXTPGridRecords
This class represents a grid records collection.
Definition XTPGridRecords.h:71
CXTPGridRow
CXTPGridRow class represents a row of the Grid control window.
Definition XTPGridRow.h:71
CXTPHeapObjectT
This template class used as a helper class to override new/delete operators and use custom heap alloc...
Definition XTPCustomHeap.h:335
CXTPMarkupContext
CXTPMarkupContext is a standalone class used to provide common settings for Markup objects.
Definition XTPMarkupContext.h:128
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72
XTP_GRIDRECORDITEM_DRAWARGS
A set of parameters transferred to the Draw item handler.
Definition XTPGridRecordItem.h:125
XTP_GRIDRECORDITEM_METRICS
Record item drawing metrics.
Definition XTPGridRecordItem.h:356


Toolkit Pro: XTPSkinManager.h Source File

  • Source
  • SkinFramework
XTPSkinManager.h
Go to the documentation of this file.
1
23#if !defined(__XTPSKINMANAGER_H__)
24# define __XTPSKINMANAGER_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableAdvancedWarnings.h"
32# include <comdef.h>
33# include "Common/Base/Diagnostic/XTPEnableAdvancedWarnings.h"
34
35# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
36
37class CXTPSkinManagerSchemaProperty;
38class CXTPSkinManagerResourceFile;
39class CXTPSkinManagerColorFilter;
40class CXTPSkinObjectClassMap;
41class CXTPSkinManagerApiHookBase;
42class CXTPSkinManagerModuleListSharedData;
43class CXTPSkinManagerSchemaCodeManager;
44class CXTPColorManager;
45class CXTPDpi;
46typedef HANDLE HTHEME;
47
60enum XTPSkinApplyOptions
61{
62 xtpSkinApplyMetrics = 1,
63 xtpSkinApplyFrame = 2,
64 xtpSkinApplyColors = 4,
65 xtpSkinApplyMenus = 8,
66 xtpSkinApplyDCs = 0x10,
68 xtpSkinApplyCommandBarsFrame = 0x20
69};
70
82enum XTPSkinManagerProperty
83{
84 XTP_SKINPROPERTY_UNKNOWN,
85 XTP_SKINPROPERTY_STRING,
86 XTP_SKINPROPERTY_INT,
87 XTP_SKINPROPERTY_BOOL,
88 XTP_SKINPROPERTY_COLOR,
89 XTP_SKINPROPERTY_RECT,
90 XTP_SKINPROPERTY_FONT,
91 XTP_SKINPROPERTY_INTLIST,
92 XTP_SKINPROPERTY_ENUM,
93 XTP_SKINPROPERTY_POSITION,
94 XTP_SKINPROPERTY_FILENAME = XTP_SKINPROPERTY_STRING,
95 XTP_SKINPROPERTY_MARGINS = XTP_SKINPROPERTY_RECT,
96 XTP_SKINPROPERTY_SIZE = XTP_SKINPROPERTY_INT
97};
98
99class CXTPSkinManager;
100class CXTPSkinManagerSchema;
101class CXTPSkinImages;
102class CXTPSkinObject;
103
109class _XTP_EXT_CLASS CXTPSkinManagerClass : public CXTPSynchronized
110{
111public:
119 CXTPSkinManagerClass(CXTPSkinManagerSchema* pSchema, CString pszClassList, int nClassCode);
120
125 virtual ~CXTPSkinManagerClass();
126
127public:
138 CString GetThemeString(int iPartId, int iStateId, int iPropId, LPCTSTR lpszDefault = NULL);
139
150 CRect GetThemeRect(int iPartId, int iStateId, int iPropId, CRect rcDefault = CRect(0, 0, 0, 0));
151
162 int GetThemeInt(int iPartId, int iStateId, int iPropId, int nDefault = 0);
163
174 CSize GetThemeSize(int iPartId, int iStateId, int iPropId, CSize szDefault = CSize(0));
175
186 BOOL GetThemeBool(int iPartId, int iStateId, int iPropId, BOOL bDefault = FALSE);
187
198 COLORREF GetThemeColor(int iPartId, int iStateId, int iPropId,
199 COLORREF clrDefault = (COLORREF)-1);
200
211 int GetThemeEnumValue(int iPartId, int iStateId, int iPropId, int nDefault = 0);
212
224 BOOL GetThemePartSize(int iPartId, int iStateId, RECT* pRect, int eSize, SIZE* pSize);
225
226public:
239 BOOL DrawThemeBackground(CDC* pDC, int iPartId, int iStateId, const RECT* pRect);
240
254 BOOL DrawThemeText(CDC* pDC, int iPartId, int iStateId, const CString& strText, DWORD dwFormat,
255 const RECT* pRect);
256
263 CXTPSkinImages* GetImages() const;
264
271 int GetClassCode() const;
272
279 CString GetClassName() const;
280
281public:
295 CXTPSkinManagerSchemaProperty* GetProperty(XTPSkinManagerProperty propType, int iPartId,
296 int iStateId, int iPropId);
297
299 _XTP_DEPRECATED
300 HTHEME GetSystemTheme();
301 static CXTPSkinManagerClass* FromHandle(HTHEME hTheme);
302 void BindTheme(HTHEME hTheme);
303 void UnbindTheme(HTHEME hTheme);
306private:
307 void UnbindTheme(HTHEME hTheme, BOOL bFinal);
308 void UnbindAllThemes();
309
310protected:
311 CXTPSkinManagerSchema* m_pSchema;
313 _XTP_DEPRECATED HTHEME m_hSystemTheme;
315 CString m_strClass;
316 UINT m_nClassCode;
317 CXTPSkinImages* m_pImages;
319 CMap<UINT, UINT, CXTPSkinManagerSchemaProperty*, CXTPSkinManagerSchemaProperty*>
320 m_mapCachedProperties;
322private:
323 struct ThemeClassAssoc
324 {
325 ThemeClassAssoc()
326 : nRefs(0)
327 , pClass(NULL)
328 {
329 }
330
331 LONG nRefs;
332 CXTPSkinManagerClass* pClass;
333 };
334
335 static CCriticalSection m_themeClassAccess;
336 static CMap<HTHEME, HTHEME, ThemeClassAssoc*, ThemeClassAssoc*> m_themeClasses;
337};
338
339# define XTP_SKINMETRICS_COLORTABLESIZE 31
340
352struct IXTPSkinManagerWindowFilter
353{
357 virtual ~IXTPSkinManagerWindowFilter()
358 {
359 }
360
370 virtual BOOL FilterWindowClass(LPCSTR lpszClassName) = 0;
371
381 virtual BOOL FilterWindowClass(LPCWSTR lpszClassName) = 0;
382
394 virtual BOOL FilterWindow(HWND hWnd, LPCTSTR lpszClassName, LPCREATESTRUCT lpcs) = 0;
395};
396
402class _XTP_EXT_CLASS CXTPSkinManagerMetrics : public CXTPSynchronized
403{
404public:
410 CXTPSkinManagerMetrics(CXTPSkinManagerSchema* pSchema);
411
416 virtual ~CXTPSkinManagerMetrics();
417
418public:
423 virtual void RefreshMetrics();
424
432 BOOL IsMetricObject(HGDIOBJ hObject) const;
433
438 _XTP_DEPRECATED_IN_FAVOR(IsMetricObject)
439 static BOOL AFX_CDECL IsKnownMetricObject(HGDIOBJ hObject);
446 void DestroyMetrics();
447
455 COLORREF GetColor(int nIndex) const;
456
464 HBRUSH GetBrush(int nIndex) const;
465
474 BOOL CreateTabControlBrush(CBitmap* pBitmap);
475
476public:
477 mutable CXTPCriticalSection m_csAccess;
478 BOOL m_bAllowHandleDestroy;
479
480 CXTPFont m_xtpFontCaption;
481 CXTPFont m_xtpFontMenu;
482 CXTPFont m_xtpFontSmCaption;
484 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CFont, m_fntCaption, m_xtpFontCaption,
485 GetCaptionFontHandle);
486 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CFont, m_fntMenu, m_xtpFontMenu, GetMenuFontHandle);
487 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CFont, m_fntSmCaption, m_xtpFontSmCaption,
488 GetSmCaptionFontHandle);
489
490 CXTPSkinManagerSchema* m_pSchema;
492 CXTPBrush m_xtpBrushDialog;
493 CXTPBrush m_xtpBrushTabControl;
494 CXTPBrush m_xtpBrushWindow;
496 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED_(HBRUSH, HBRUSH, HBRUSH, m_brushDialog, m_xtpBrushDialog,
497 GetDialogBrushHandle);
498 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED_(HBRUSH, HBRUSH, HBRUSH, m_brushTabControl,
499 m_xtpBrushTabControl, GetTabControlBrushHandle);
500 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED_(HBRUSH, HBRUSH, HBRUSH, m_brushWindow, m_xtpBrushWindow,
501 GetWindowBrushHandle);
502
503 COLORREF m_clrEdgeLight;
504 COLORREF m_clrEdgeHighLight;
505 COLORREF m_clrEdgeShadow;
506 COLORREF m_clrEdgeDkShadow;
508 COLORREF m_clrTheme[XTP_SKINMETRICS_COLORTABLESIZE];
510 HBRUSH m_brTheme[XTP_SKINMETRICS_COLORTABLESIZE];
512 int m_nBorderSize;
513 int m_cxBorder;
514 int m_cyBorder;
515 int m_cxEdge;
516 int m_cyEdge;
518 int m_cxHScroll;
519 int m_cyHScroll;
520 int m_cxVScroll;
521 int m_cyVScroll;
523 int m_cyCaption;
524 int m_cySmallCaption;
526 int m_cyOsCaption;
527 int m_cyOsSmallCaption;
528 int m_cxOsVScroll;
530 BOOL m_bRefreshMetrics;
531};
532
538class _XTP_EXT_CLASS CXTPSkinManager
539 : public CXTPSynchronized
540 , IXTPApplicationEvents
541{
542 friend class CXTPSingleton<
543 CXTPSkinManager,
544 CXTPSingletonDependencies<CXTPSingleton<CXTPSkinManagerModuleListSharedData>,
545 CXTPSingleton<CXTPSkinManagerSchemaCodeManager>,
546 CXTPSingleton<CXTPColorManager>, CXTPSingleton<CXTPFontCache>,
547 CXTPSingleton<CXTPDpi>, CXTPSingleton<CXTPBrushCache>,
548 CXTPSingleton<CXTPSoundManager> > >;
549
550private:
551 DECLARE_HANDLE(HWINEVENTHOOK);
552
553 typedef void(CALLBACK* WINEVENTPROC)(HWINEVENTHOOK hWinEventHook, DWORD event, HWND hwnd,
554 LONG idObject, LONG idChild, DWORD idEventThread,
555 DWORD dwmsEventTime);
556 typedef HWINEVENTHOOK(WINAPI* LPFNSETWINEVENTHOOK)(UINT eventMin, UINT eventMax,
557 HMODULE hmodWinEventProc,
558 WINEVENTPROC lpfnWinEventProc,
559 DWORD idProcess, DWORD idThread,
560 UINT dwflags);
561 typedef BOOL(WINAPI* LPFNUNHOOKWINEVENT)(HWINEVENTHOOK hWinEventHook);
562
563 typedef HRESULT(WINAPI* LPSETWINDOWTHEME)(HWND hwnd, LPCWSTR pszSubAppName,
564 LPCWSTR pszSubIdList);
565
566protected:
571 CXTPSkinManager();
572
573public:
578 virtual ~CXTPSkinManager();
579
588 BOOL LoadSkin(LPCTSTR lpszResourcePath, LPCTSTR lpszIniFileName = NULL);
589
598 CXTPSkinManagerSchema* CreateSchema(LPCTSTR lpszResourcePath, LPCTSTR lpszIniFileName = NULL);
599
600public:
609 DWORD GetApplyOptions() const;
610
620 BOOL HasApplyOptions(DWORD dwOptions) const;
621
629 void SetApplyOptions(DWORD dwOptions);
630
639 void ModifyApplyOptions(DWORD dwAdd, DWORD dwRemove);
640
646 void ApplyWindow(HWND hWnd);
647
655 void ApplyWindow(HWND hWnd, BOOL bApplyChildren);
656
665 void SetWindowTheme(HWND hWnd, CXTPSkinManagerSchema* pSchema);
666
674 void SetAutoApplyNewWindows(BOOL bAutoApply);
675
684 BOOL GetAutoApplyNewWindows() const;
685
699 static CXTPSkinManager* AFX_CDECL SetSkinManager(CXTPSkinManager* pSkinManager,
700 BOOL bDelete = TRUE);
701
707# if defined(XTP_SKINFRAMEWORK_USE_DETOURS_API_HOOK) && !defined(_XTP_ACTIVEX)
708 _XTP_DEPRECATE("The method is disabled for compilation with "
709 "XTP_SKINFRAMEWORK_USE_DETOURS_API_HOOK and "
710 "its empty implementation is added for backward compatibility only. In order to "
711 "you the legacy implementation of API hooking re-compile ToolkitPro with "
712 "XTP_SKINFRAMEWORK_USE_LEGACY_API_HOOK macro defined.")
713# endif
714 void ExcludeModule(LPCTSTR lpszModule);
715
724 virtual CXTPSkinManagerClass* GetSkinClass(const CXTPSkinObject* pObject, CString strClassList);
725
733 CXTPSkinObject* Lookup(HWND hWnd);
734
742 CXTPSkinObject* Lookup(HDC hDC);
743
750 CXTPSkinManagerMetrics* GetMetrics() const;
751
758 BOOL IsEnabled() const;
759
764 void Suspend();
765
770 void Resume();
771
778 BOOL IsSuspended() const;
779
786 CXTPSkinManagerSchema* GetSchema() const;
787
796 CXTPSkinManagerResourceFile* GetResourceFile() const;
797
808 void SetResourceFile(CXTPSkinManagerResourceFile* pResourceFile);
809
827 HRESULT EnableThemeDialogTexture(HWND hWnd, DWORD dwFlags);
828
836 COLORREF GetThemeSysColor(int iColorId);
837
847 HRESULT GetThemeSysFont(int iFontId, LOGFONT* plf);
848
857 int GetThemeSysSize(int iSizeId);
858
866 BOOL GetThemeSysBool(int iBoolId);
867
876 void GetCurrentThemeName(CString& strThemeFileName, CString& strColorBuff);
877
885 CXTPSkinManagerClass* FromHandle(HTHEME hTheme);
886
895 BOOL IsComCtlV6() const;
896
907 BOOL IsWin9x() const;
908
913 void RedrawAllControls();
914
922 void EnableCurrentThread();
923
929 void SetAutoApplyNewThreads(BOOL bAutoApply);
930
937 BOOL GetAutoApplyNewThreads() const;
938
946 CXTPSkinObjectClassMap* GetClassMap() const;
947
955 void Remove(HWND hWnd);
956
964 void RemoveAll(BOOL bDetach = TRUE);
965
972 BOOL IsColorFilterExists() const;
973
980 void ApplyColorFilter(COLORREF& clr);
981
987 void AddColorFilter(CXTPSkinManagerColorFilter* pFilter);
988
993 void RemoveColorFilters();
994
1001 virtual void OnSkinChanged(BOOL bPrevState, BOOL bNewState);
1002
1014 BOOL IsPersistentModule(HMODULE hModule);
1015
1024 void SetWindowFilter(IXTPSkinManagerWindowFilter* pFilter);
1025
1027 CXTPSkinManagerApiHookBase* GetApiHook() const;
1030 //-------------------------------------------------------------------------
1031 // Summary:
1032 // Causes a window to use a different set of visual style information than its class
1033 // normally uses.
1034 // Parameters:
1035 // pszSubAppName - Pointer to a string that contains the application name to use in place of
1036 // the calling application's name. If this parameter is NULL, the calling
1037 // application's name is used.
1038 // pszSubIdList - Pointer to a string that contains a semicolon-separated list of CLSID
1039 // names to use in place of the actual list passed by the window's class.
1040 // If this parameter is NULL, the ID list from the calling class is used.
1041 //-------------------------------------------------------------------------
1042 void SetDefaultWindowTheme(LPCWSTR pszSubAppName, LPCWSTR pszSubIdList);
1043
1044 //-------------------------------------------------------------------------
1045 // Summary:
1046 // Causes a window to use a different set of visual style information than its class
1047 // normally uses.
1048 // Parameters:
1049 // hWnd - Handle to the window whose visual style information is to be changed.
1050 // pszSubAppName - Pointer to a string that contains the application name to use in place of
1051 // the calling application's name. If this parameter is NULL, the calling
1052 // application's name is used.
1053 // pszSubIdList - Pointer to a string that contains a semicolon-separated list of CLSID
1054 // names to use in place of the actual list passed by the window's class.
1055 // If this parameter is NULL, the ID list from the calling class is used.
1056 //-------------------------------------------------------------------------
1057 void SetWindowTheme(HWND hWnd, LPCWSTR pszSubAppName, LPCWSTR pszSubIdList);
1058
1059protected:
1070 BOOL ReadSkinData(LPCTSTR lpszResourcePath, LPCTSTR lpszIniFileName);
1071
1078 void FreeSkinData();
1079
1094 virtual CXTPSkinObject* SetHook(HWND hWnd, LPCTSTR lpszClassName, LPCREATESTRUCT lpcs,
1095 BOOL bAuto);
1096
1102 virtual void OnBeforeApplicationShutdown(CXTPApplication* pApplication);
1103
1104public:
1106 BOOL IsWindowClassFilteredOut(LPCSTR lpszClassName);
1107 BOOL IsWindowClassFilteredOut(LPCWSTR lpszClassName);
1108 BOOL IsWindowFilteredOut(HWND hWnd, LPCTSTR lpszClassName, LPCREATESTRUCT lpcs,
1109 BOOL bRecursive);
1110 BOOL IsDCFilteredOut(HDC hDC, BOOL bRecursive);
1111 BOOL IsDCSkinned(HDC hDC);
1114protected:
1116 static BOOL AFX_CDECL IsClassKnownIgnoredClass(LPCTSTR lpszClassName);
1117 static LRESULT CALLBACK HookWndProc(HWND hWnd, UINT message, WPARAM wParam, LPARAM lParam);
1118 static LRESULT CALLBACK CbtFilterHook(int code, WPARAM wParam, LPARAM lParam);
1119 static void CALLBACK WinEventProc(HWINEVENTHOOK hWinEventHook, DWORD event, HWND hWnd,
1120 LONG idObject, LONG idChild, DWORD dwEventThread,
1121 DWORD dwmsEventTime);
1122 static LRESULT CALLBACK DoCallWindowProc(WNDPROC lpPrevWndFunc, HWND hWnd, UINT Msg,
1123 WPARAM wParam, LPARAM lParam);
1124 static BOOL CALLBACK EnumWindowsProcNetBroadcast(HWND hwnd, LPARAM lParam);
1125 static BOOL AFX_CDECL AreAppVisualThemesDisabled();
1126 void Remove(HWND hWnd, BOOL bAuto);
1128private:
1129 enum LookupDCSatus
1130 {
1131 LookupDCOk,
1132 LookupDCNotAssociated,
1133 LookupDCNoWnd
1134 };
1135
1136 CXTPSkinObject* Lookup(HDC hDC, LookupDCSatus* pnStatus);
1137 static HWND GetDCWindow(HDC hDC);
1138
1139protected:
1140 DWORD m_dwComCtrl;
1141 const BOOL m_bAppVisualThemesDisabled;
1142 BOOL m_bWin9x;
1143 BOOL m_bEnabled;
1144 BOOL m_bAutoApplyWindows;
1145 BOOL m_bAutoApplyThreads;
1147 CXTPSkinManagerSchema* m_pSchema;
1148 CXTPSkinManagerResourceFile* m_pResourceFile;
1150 DWORD m_dwApplyOptions;
1152 HWINEVENTHOOK m_hWinEventHook;
1153 CMap<HWND, HWND, CXTPSkinObject*, CXTPSkinObject*> m_mapObjects;
1155 CRITICAL_SECTION m_csObjects;
1157 LPFNSETWINEVENTHOOK m_pSetWinEventHook;
1158 LPFNUNHOOKWINEVENT m_pUnhookWinEvent;
1159 LPSETWINDOWTHEME m_pSetWindowTheme;
1161 CArray<CXTPSkinManagerColorFilter*, CXTPSkinManagerColorFilter*> m_arrFilters;
1165 CXTPSkinObjectClassMap* m_pClassMap;
1167 IXTPSkinManagerWindowFilter* m_pWindowFilter;
1170 mutable CXTPSkinManagerApiHookBase* m_pApiHook; // API hook instance.
1171 static CXTPSkinManager* s_pInstance; // Instance of SkinManager.
1172 CXTPRWCriticalSection m_csPersistentModuleCache; // Synchronization primitive for persistent
1173 // module info cache access.
1174
1175 struct PERSISTENT_IMPORT_INFO
1176 {
1177 HMODULE hModule;
1178 BOOL bPersistent;
1179 };
1180
1181 CArray<PERSISTENT_IMPORT_INFO, PERSISTENT_IMPORT_INFO&>
1182 m_arPersistentModuleCache;
1184public:
1186 AFX_MODULE_STATE* m_pModuleState;
1187
1188# ifdef _XTP_ACTIVEX
1189 static BOOL s_bUserLegacyApiHook;
1190# endif
1194private:
1195 DWORD m_dwRefDisableFrameSkin;
1196 DWORD m_dwPrevOptions;
1197
1198 union SUSPENDED_STATE {
1199 BYTE bits;
1200 struct
1201 {
1202 BYTE bSuspended : 1;
1203 BYTE bAutoApplyWindows : 1;
1204 BYTE bAutoApplyThreads : 1;
1205 BYTE bApplyDCs : 1;
1206 } u;
1207 };
1208
1209 SUSPENDED_STATE m_SuspendedState;
1210
1211public:
1212 BOOL IsSkinApplyCommandBarsFrame();
1213 void DisableSkinFrameOption();
1214 void EnableSkinFrameOption();
1217private:
1218 class CDestructor;
1219 friend _XTP_EXT_CLASS CXTPSkinManager* AFX_CDECL XTPSkinManager();
1220 friend class CXTPSkinObject;
1221 friend class CDestructor;
1222 friend class CXTPSkinManagerApiHookBase;
1223};
1224
1225AFX_INLINE CXTPSkinImages* CXTPSkinManagerClass::GetImages() const
1226{
1227 return m_pImages;
1228}
1229AFX_INLINE int CXTPSkinManagerClass::GetClassCode() const
1230{
1231 return static_cast<int>(m_nClassCode);
1232}
1233AFX_INLINE CString CXTPSkinManagerClass::GetClassName() const
1234{
1235 return m_strClass;
1236}
1237AFX_INLINE BOOL CXTPSkinManager::IsEnabled() const
1238{
1239 return m_bEnabled;
1240}
1241AFX_INLINE BOOL CXTPSkinManager::IsSuspended() const
1242{
1243 return (TRUE == m_SuspendedState.u.bSuspended);
1244}
1245AFX_INLINE CXTPSkinManagerResourceFile* CXTPSkinManager::GetResourceFile() const
1246{
1247 return m_pResourceFile;
1248}
1249AFX_INLINE CXTPSkinManagerSchema* CXTPSkinManager::GetSchema() const
1250{
1251 return m_pSchema;
1252}
1253AFX_INLINE DWORD CXTPSkinManager::GetApplyOptions() const
1254{
1255 return m_dwApplyOptions;
1256}
1257AFX_INLINE BOOL CXTPSkinManager::HasApplyOptions(DWORD dwOptions) const
1258{
1259 return (m_dwApplyOptions & dwOptions) == dwOptions;
1260}
1261AFX_INLINE BOOL CXTPSkinManager::IsComCtlV6() const
1262{
1263 return m_dwComCtrl >= MAKELONG(0, 6);
1264}
1265AFX_INLINE BOOL CXTPSkinManager::IsWin9x() const
1266{
1267 return m_bWin9x;
1268}
1269AFX_INLINE CXTPSkinObjectClassMap* CXTPSkinManager::GetClassMap() const
1270{
1271 return m_pClassMap;
1272}
1273AFX_INLINE BOOL CXTPSkinManager::GetAutoApplyNewWindows() const
1274{
1275 return m_bAutoApplyWindows;
1276}
1277AFX_INLINE BOOL CXTPSkinManager::GetAutoApplyNewThreads() const
1278{
1279 return m_bAutoApplyThreads;
1280}
1281AFX_INLINE void CXTPSkinManager::SetAutoApplyNewWindows(BOOL bAutoApply)
1282{
1283 m_bAutoApplyWindows = bAutoApply;
1284}
1285AFX_INLINE void CXTPSkinManager::SetAutoApplyNewThreads(BOOL bAutoApply)
1286{
1287 m_bAutoApplyThreads = bAutoApply;
1288}
1289AFX_INLINE void CXTPSkinManager::SetWindowFilter(IXTPSkinManagerWindowFilter* pFilter)
1290{
1291 m_pWindowFilter = pFilter;
1292}
1293
1294# ifndef _XTP_ACTIVEX
1296AFX_INLINE CXTPSkinManagerApiHookBase* CXTPSkinManager::GetApiHook() const
1297{
1298 return m_pApiHook;
1299}
1301# endif
1302
1316_XTP_EXT_CLASS CXTPSkinManager* AFX_CDECL XTPSkinManager();
1317
1320_XTP_EXT_CLASS CXTPRWCriticalSection* AFX_CDECL XTPSkinGlobalAccess();
1321
1322# ifdef _AFXDLL
1323
1324class _XTP_EXT_CLASS CXTPSkinScopeModuleStateHolder
1325{
1326 AFX_MODULE_STATE* m_pPrevState;
1327
1328 CXTPSkinScopeModuleStateHolder(const CXTPSkinScopeModuleStateHolder&);
1329 CXTPSkinScopeModuleStateHolder& operator=(const CXTPSkinScopeModuleStateHolder&);
1330
1331public:
1332 CXTPSkinScopeModuleStateHolder(AFX_MODULE_STATE* pNewState)
1333 {
1334 m_pPrevState = AfxSetModuleState(pNewState);
1335 }
1336
1337 ~CXTPSkinScopeModuleStateHolder()
1338 {
1339 AfxSetModuleState(m_pPrevState);
1340 }
1341
1342 operator int()
1343 {
1344 return 0;
1345 }
1346};
1347
1348# endif /*_AFXDLL*/
1349
1350# define XTP_SKINFRAMEWORK_GLOBALLOCK_SHARED_SCOPE() \
1351 XTP_RWCS_LOCK_SHARED_SCOPE(*XTPSkinGlobalAccess())
1352# define XTP_SKINFRAMEWORK_GLOBALLOCK_EXCLUSIVE_SCOPE() \
1353 XTP_RWCS_LOCK_EXCLUSIVE_SCOPE(*XTPSkinGlobalAccess())
1354
1355# define XTP_SKINFRAMEWORK_MANAGE_STATE() \
1356 AFX_MODULE_STATE* $__xtpSkinOrigModuleState = AfxGetModuleState(); \
1357 UNREFERENCED_PARAMETER($__xtpSkinOrigModuleState); \
1358 SAFE_MANAGE_STATE(XTPSkinManager()->m_pModuleState);
1359
1360# ifdef _AFXDLL
1361# define XTP_SKINFRAMEWORK_ORIGINAL_STATE() \
1362 XTP_BLOCKSTATEMENT(CXTPSkinScopeModuleStateHolder, $__xtpSkinScopeModuleStateHolder, \
1363 $__xtpSkinOrigModuleState)
1364# else
1365# define XTP_SKINFRAMEWORK_ORIGINAL_STATE()
1366# endif /*_AFXDLL*/
1367
1368# define XTP_SKINFRAMEWORK_ASSERT_WINDOW_THREAD(hWnd) \
1369 _ASSERTE(::IsWindow(hWnd) ? GetWindowThreadProcessId(hWnd, NULL) == GetCurrentThreadId() \
1370 : TRUE)
1371
1374# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
1376#endif // !defined(__XTPSKINMANAGER_H__)
XTPDisableAdvancedWarnings.h
XTPDisableNoisyWarnings.h
XTPEnableAdvancedWarnings.h
XTPEnableNoisyWarnings.h
XTPSkinApplyOptions
XTPSkinApplyOptions
Applied options of the selected skin.
Definition XTPSkinManager.h:61
xtpSkinApplyMetrics
@ xtpSkinApplyMetrics
TRUE to use skin provided metrics.
Definition XTPSkinManager.h:62
xtpSkinApplyDCs
@ xtpSkinApplyDCs
TRUE to apply skin to device context that have no associated window handles.
Definition XTPSkinManager.h:66
xtpSkinApplyMenus
@ xtpSkinApplyMenus
TRUE to apply skin for pop-up menus.
Definition XTPSkinManager.h:65
xtpSkinApplyFrame
@ xtpSkinApplyFrame
TRUE to apply frame skins.
Definition XTPSkinManager.h:63
xtpSkinApplyColors
@ xtpSkinApplyColors
TRUE to use skin provided colors.
Definition XTPSkinManager.h:64
xtpSkinApplyCommandBarsFrame
@ xtpSkinApplyCommandBarsFrame
TRUE to apply skin frame with CommandBars.
Definition XTPSkinManager.h:68
XTPSkinManagerProperty
XTPSkinManagerProperty
Available properties for the CXTPSkinManagerSchemaProperty class.
Definition XTPSkinManager.h:83
XTP_SKINPROPERTY_POSITION
@ XTP_SKINPROPERTY_POSITION
int property.
Definition XTPSkinManager.h:93
XTP_SKINPROPERTY_BOOL
@ XTP_SKINPROPERTY_BOOL
BOOL property.
Definition XTPSkinManager.h:87
XTP_SKINPROPERTY_FILENAME
@ XTP_SKINPROPERTY_FILENAME
FileName property.
Definition XTPSkinManager.h:94
XTP_SKINPROPERTY_STRING
@ XTP_SKINPROPERTY_STRING
CString property.
Definition XTPSkinManager.h:85
XTP_SKINPROPERTY_UNKNOWN
@ XTP_SKINPROPERTY_UNKNOWN
Not defined.
Definition XTPSkinManager.h:84
XTP_SKINPROPERTY_SIZE
@ XTP_SKINPROPERTY_SIZE
Size property.
Definition XTPSkinManager.h:96
XTP_SKINPROPERTY_COLOR
@ XTP_SKINPROPERTY_COLOR
COLORREF property.
Definition XTPSkinManager.h:88
XTP_SKINPROPERTY_RECT
@ XTP_SKINPROPERTY_RECT
CRect property.
Definition XTPSkinManager.h:89
XTP_SKINPROPERTY_INTLIST
@ XTP_SKINPROPERTY_INTLIST
CIntArray property.
Definition XTPSkinManager.h:91
XTP_SKINPROPERTY_INT
@ XTP_SKINPROPERTY_INT
int property.
Definition XTPSkinManager.h:86
XTP_SKINPROPERTY_FONT
@ XTP_SKINPROPERTY_FONT
LOGFONT property.
Definition XTPSkinManager.h:90
XTP_SKINPROPERTY_MARGINS
@ XTP_SKINPROPERTY_MARGINS
Margins property.
Definition XTPSkinManager.h:95
XTP_SKINPROPERTY_ENUM
@ XTP_SKINPROPERTY_ENUM
enum property.
Definition XTPSkinManager.h:92
XTPSkinManager
_XTP_EXT_CLASS CXTPSkinManager *AFX_CDECL XTPSkinManager()
Call this function to access CXTPSkinManager members.
CXTPApplication
Defines a global XTP application object interface.
Definition XTPApplication.h:151
CXTPBrush
Provides a convenient object oriented interface for HBRUSH GDI object and uses GDI handle caching.
Definition XTPGdiObjects.h:653
CXTPColorManager
CXTPColorManager is a stand alone class.
Definition XTPColorManager.h:486
CXTPCriticalSection
Critical Section Wrapper.
Definition XTPSystemHelpers.h:835
CXTPFont
Provides a convenient object oriented interface for HFONT GDI object and uses GDI handle caching.
Definition XTPGdiObjects.h:414
CXTPRWCriticalSection
Implements recursive read-write lock synchronization pattern.
Definition XTPSynchro.h:195
CXTPSingletonDependencies
Describes the list of up to 10 optional singleton dependencies.
Definition XTPSingleton.h:179
CXTPSingleton
Implements Singleton design pattern.
Definition XTPSingleton.h:215
CXTPSkinImages
CXTPSkinImages represents a cached collection of CXTPSkinImage classes.
Definition XTPSkinImage.h:200
CXTPSkinManagerClass
CXTPSkinManagerClass is a standalone class that represents a single visual class of the skin manager.
Definition XTPSkinManager.h:110
CXTPSkinManagerClass::m_nClassCode
UINT m_nClassCode
Hashed value of the class name.
Definition XTPSkinManager.h:316
CXTPSkinManagerClass::GetProperty
CXTPSkinManagerSchemaProperty * GetProperty(XTPSkinManagerProperty propType, int iPartId, int iStateId, int iPropId)
Gets the property value of a specified part and state.
CXTPSkinManagerClass::m_strClass
CString m_strClass
Class name.
Definition XTPSkinManager.h:315
CXTPSkinManagerClass::m_pImages
CXTPSkinImages * m_pImages
Image collection.
Definition XTPSkinManager.h:317
CXTPSkinManagerClass::GetThemeEnumValue
int GetThemeEnumValue(int iPartId, int iStateId, int iPropId, int nDefault=0)
Gets the value of a specified enum property.
CXTPSkinManagerClass::GetThemeSize
CSize GetThemeSize(int iPartId, int iStateId, int iPropId, CSize szDefault=CSize(0))
Gets the value of a specified size property.
CXTPSkinManagerClass::GetThemeColor
COLORREF GetThemeColor(int iPartId, int iStateId, int iPropId, COLORREF clrDefault=(COLORREF) -1)
Gets the value of a specified color property.
CXTPSkinManagerClass::GetThemeBool
BOOL GetThemeBool(int iPartId, int iStateId, int iPropId, BOOL bDefault=FALSE)
Gets the value of a specified BOOL property.
CXTPSkinManagerClass::DrawThemeBackground
BOOL DrawThemeBackground(CDC *pDC, int iPartId, int iStateId, const RECT *pRect)
Draws the background image defined by the visual style for a specified control part.
CXTPSkinManagerClass::GetThemeRect
CRect GetThemeRect(int iPartId, int iStateId, int iPropId, CRect rcDefault=CRect(0, 0, 0, 0))
Gets the value of a specified RECT property.
CXTPSkinManagerClass::GetThemeInt
int GetThemeInt(int iPartId, int iStateId, int iPropId, int nDefault=0)
Gets the value of a specified int property.
CXTPSkinManagerClass::DrawThemeText
BOOL DrawThemeText(CDC *pDC, int iPartId, int iStateId, const CString &strText, DWORD dwFormat, const RECT *pRect)
Draws text using the color and font defined by the visual style.
CXTPSkinManagerClass::m_mapCachedProperties
CMap< UINT, UINT, CXTPSkinManagerSchemaProperty *, CXTPSkinManagerSchemaProperty * > m_mapCachedProperties
Cached collection of class properties.
Definition XTPSkinManager.h:320
CXTPSkinManagerClass::GetThemeString
CString GetThemeString(int iPartId, int iStateId, int iPropId, LPCTSTR lpszDefault=NULL)
Gets the value of a specified string property.
CXTPSkinManagerClass::GetImages
CXTPSkinImages * GetImages() const
Gets the image collection of the class.
Definition XTPSkinManager.h:1225
CXTPSkinManagerClass::~CXTPSkinManagerClass
virtual ~CXTPSkinManagerClass()
Destroys a CXTPSkinManagerClass object, handles cleanup and deallocation.
CXTPSkinManagerClass::m_pSchema
CXTPSkinManagerSchema * m_pSchema
Parent CXTPSkinManager object.
Definition XTPSkinManager.h:311
CXTPSkinManagerClass::GetThemePartSize
BOOL GetThemePartSize(int iPartId, int iStateId, RECT *pRect, int eSize, SIZE *pSize)
Gets the size of a specified theme part.
CXTPSkinManagerClass::CXTPSkinManagerClass
CXTPSkinManagerClass(CXTPSkinManagerSchema *pSchema, CString pszClassList, int nClassCode)
Constructs a CXTPSkinManagerClass object.
CXTPSkinManagerClass::GetClassName
CString GetClassName() const
Gets the class name.
Definition XTPSkinManager.h:1233
CXTPSkinManagerClass::GetClassCode
int GetClassCode() const
Gets the hash value of the class name.
Definition XTPSkinManager.h:1229
CXTPSkinManagerColorFilter
CXTPSkinManagerColorFilter represents the parent class for all color filters of skin manager.
Definition XTPSkinManagerColorFilter.h:40
CXTPSkinManager
CXTPSkinManager is a standalone class that represents a global object that manages skins.
Definition XTPSkinManager.h:541
CXTPSkinManager::ReadSkinData
BOOL ReadSkinData(LPCTSTR lpszResourcePath, LPCTSTR lpszIniFileName)
Parses a visual styles .ini file.
CXTPSkinManager::GetCurrentThemeName
void GetCurrentThemeName(CString &strThemeFileName, CString &strColorBuff)
Gets the name of the current theme.
CXTPSkinManager::SetWindowFilter
void SetWindowFilter(IXTPSkinManagerWindowFilter *pFilter)
Sets the window filter implementation.
Definition XTPSkinManager.h:1289
CXTPSkinManager::m_hWinEventHook
HWINEVENTHOOK m_hWinEventHook
HWINEVENTHOOK value that identifies event hook instance.
Definition XTPSkinManager.h:1152
CXTPSkinManager::m_pUnhookWinEvent
LPFNUNHOOKWINEVENT m_pUnhookWinEvent
Pointer to UnhookWinEvent API.
Definition XTPSkinManager.h:1158
CXTPSkinManager::CXTPSkinManager
CXTPSkinManager()
Constructs a CXTPSkinManager object.
CXTPSkinManager::m_csObjects
CRITICAL_SECTION m_csObjects
Helper critical section object.
Definition XTPSkinManager.h:1155
CXTPSkinManager::ApplyColorFilter
void ApplyColorFilter(COLORREF &clr)
This method is called internally to transform a specified color using installed color filters.
CXTPSkinManager::m_mapObjects
CMap< HWND, HWND, CXTPSkinObject *, CXTPSkinObject * > m_mapObjects
Collection of CXTPSkinObject classes.
Definition XTPSkinManager.h:1153
CXTPSkinManager::EnableThemeDialogTexture
HRESULT EnableThemeDialogTexture(HWND hWnd, DWORD dwFlags)
Enables/disables dialog background theme.
CXTPSkinManager::FreeSkinData
void FreeSkinData()
Frees skin resources.
CXTPSkinManager::GetMetrics
CXTPSkinManagerMetrics * GetMetrics() const
Gets the skin metrics.
CXTPSkinManager::SetHook
virtual CXTPSkinObject * SetHook(HWND hWnd, LPCTSTR lpszClassName, LPCREATESTRUCT lpcs, BOOL bAuto)
Creates a hook class for a specified window.
CXTPSkinManager::IsEnabled
BOOL IsEnabled() const
Determines if skinning is enabled/disabled.
Definition XTPSkinManager.h:1237
CXTPSkinManager::GetAutoApplyNewThreads
BOOL GetAutoApplyNewThreads() const
Determines if new threads are automatically skinned.
Definition XTPSkinManager.h:1277
CXTPSkinManager::m_dwComCtrl
DWORD m_dwComCtrl
Version of ComCtl.dll.
Definition XTPSkinManager.h:1140
CXTPSkinManager::SetWindowTheme
void SetWindowTheme(HWND hWnd, CXTPSkinManagerSchema *pSchema)
Sets the window theme.
CXTPSkinManager::GetApplyOptions
DWORD GetApplyOptions() const
Determines which parts of the application skin are applied.
Definition XTPSkinManager.h:1253
CXTPSkinManager::m_pClassMap
CXTPSkinObjectClassMap * m_pClassMap
Class map helper.
Definition XTPSkinManager.h:1165
CXTPSkinManager::HasApplyOptions
BOOL HasApplyOptions(DWORD dwOptions) const
Determines which parts of the application skin are applied.
Definition XTPSkinManager.h:1257
CXTPSkinManager::m_bAutoApplyWindows
BOOL m_bAutoApplyWindows
TRUE to auto-skin all new windows.
Definition XTPSkinManager.h:1144
CXTPSkinManager::Lookup
CXTPSkinObject * Lookup(HWND hWnd)
Gets the skin object used to draw a specified window.
CXTPSkinManager::EnableCurrentThread
void EnableCurrentThread()
Enables skin framework for the current thread.
CXTPSkinManager::~CXTPSkinManager
virtual ~CXTPSkinManager()
Destroys a CXTPSkinManager object, handles cleanup and deallocation.
CXTPSkinManager::m_arrFilters
CArray< CXTPSkinManagerColorFilter *, CXTPSkinManagerColorFilter * > m_arrFilters
Array of filters to apply.
Definition XTPSkinManager.h:1161
CXTPSkinManager::m_bAutoApplyThreads
BOOL m_bAutoApplyThreads
TRUE to auto-skin all new threads.
Definition XTPSkinManager.h:1145
CXTPSkinManager::IsWin9x
BOOL IsWin9x() const
Determines if the operating system is of the Windows 9x family and if it is Windows 95 or a later ver...
Definition XTPSkinManager.h:1265
CXTPSkinManager::m_arPersistentModuleCache
CArray< PERSISTENT_IMPORT_INFO, PERSISTENT_IMPORT_INFO & > m_arPersistentModuleCache
Persistent module info cache.
Definition XTPSkinManager.h:1182
CXTPSkinManager::IsColorFilterExists
BOOL IsColorFilterExists() const
Determines if any color filter is installed.
CXTPSkinManager::GetSchema
CXTPSkinManagerSchema * GetSchema() const
Gets the skin schema.
Definition XTPSkinManager.h:1249
CXTPSkinManager::GetThemeSysBool
BOOL GetThemeSysBool(int iBoolId)
Gets the BOOL value of a specified system metric.
CXTPSkinManager::ModifyApplyOptions
void ModifyApplyOptions(DWORD dwAdd, DWORD dwRemove)
Modifies skinning options defined by the XTPSkinApplyOptions enumeration.
CXTPSkinManager::m_pSetWindowTheme
LPSETWINDOWTHEME m_pSetWindowTheme
Pointer to SetWindowTheme API.
Definition XTPSkinManager.h:1159
CXTPSkinManager::GetThemeSysSize
int GetThemeSysSize(int iSizeId)
Gets the size value of a specified system metric.
CXTPSkinManager::GetThemeSysFont
HRESULT GetThemeSysFont(int iFontId, LOGFONT *plf)
Gets the value of a specified system font.
CXTPSkinManager::m_dwApplyOptions
DWORD m_dwApplyOptions
Apply options.
Definition XTPSkinManager.h:1150
CXTPSkinManager::m_pWindowFilter
IXTPSkinManagerWindowFilter * m_pWindowFilter
Custom provided window filter implementation.
Definition XTPSkinManager.h:1167
CXTPSkinManager::Resume
void Resume()
Resumes skinning for all new created windows and threads.
CXTPSkinManager::m_bWin9x
BOOL m_bWin9x
TRUE if OS is Win9x.
Definition XTPSkinManager.h:1142
CXTPSkinManager::LoadSkin
BOOL LoadSkin(LPCTSTR lpszResourcePath, LPCTSTR lpszIniFileName=NULL)
Loads a skin from a cjstyles or msstyles file.
CXTPSkinManager::SetResourceFile
void SetResourceFile(CXTPSkinManagerResourceFile *pResourceFile)
Sets the resource file.
CXTPSkinManager::RemoveColorFilters
void RemoveColorFilters()
Destroys all added color filters.
CXTPSkinManager::IsSuspended
BOOL IsSuspended() const
Determines if skinning is suspended for all new windows and threads.
Definition XTPSkinManager.h:1241
CXTPSkinManager::XTPSkinManager
friend _XTP_EXT_CLASS CXTPSkinManager *AFX_CDECL XTPSkinManager()
Call this function to access CXTPSkinManager members.
CXTPSkinManager::GetClassMap
CXTPSkinObjectClassMap * GetClassMap() const
Gets the class map object whose purpose is to map window classes to skin framework classes.
Definition XTPSkinManager.h:1269
CXTPSkinManager::IsComCtlV6
BOOL IsComCtlV6() const
Determines if ComCtl32.dll is of version 6.0 or above.
Definition XTPSkinManager.h:1261
CXTPSkinManager::m_pResourceFile
CXTPSkinManagerResourceFile * m_pResourceFile
Resource file.
Definition XTPSkinManager.h:1148
CXTPSkinManager::CreateSchema
CXTPSkinManagerSchema * CreateSchema(LPCTSTR lpszResourcePath, LPCTSTR lpszIniFileName=NULL)
Creates a new schema instance from a provided resource.
CXTPSkinManager::Lookup
CXTPSkinObject * Lookup(HDC hDC)
Gets the skin object used to draw a specified window.
CXTPSkinManager::SetAutoApplyNewWindows
void SetAutoApplyNewWindows(BOOL bAutoApply)
Specifies if new windows should be automatically skinned.
Definition XTPSkinManager.h:1281
CXTPSkinManager::RedrawAllControls
void RedrawAllControls()
Redraws all controls with the current skin.
CXTPSkinManager::GetThemeSysColor
COLORREF GetThemeSysColor(int iColorId)
Gets the value of a specified system color.
CXTPSkinManager::Suspend
void Suspend()
Suspends skinning for all new created windows and threads.
CXTPSkinManager::SetAutoApplyNewThreads
void SetAutoApplyNewThreads(BOOL bAutoApply)
Specifies if new threads should be automatically skinned.
Definition XTPSkinManager.h:1285
CXTPSkinManager::AddColorFilter
void AddColorFilter(CXTPSkinManagerColorFilter *pFilter)
Adds a color filter.
CXTPSkinManager::GetResourceFile
CXTPSkinManagerResourceFile * GetResourceFile() const
Gets the resource file.
Definition XTPSkinManager.h:1245
CXTPSkinManager::ApplyWindow
void ApplyWindow(HWND hWnd, BOOL bApplyChildren)
Call this method to manually set the window whose appearance must be skinned.
CXTPSkinManager::ApplyWindow
void ApplyWindow(HWND hWnd)
Call this method to manually set the window whose appearance must be skinned.
CXTPSkinManager::FromHandle
CXTPSkinManagerClass * FromHandle(HTHEME hTheme)
Gets the CXTPSkinManagerClass class from a specified HTHEME handle.
CXTPSkinManager::RemoveAll
void RemoveAll(BOOL bDetach=TRUE)
Removes all hooks.
CXTPSkinManager::OnBeforeApplicationShutdown
virtual void OnBeforeApplicationShutdown(CXTPApplication *pApplication)
This method is called by the framework before an application shuts down.
CXTPSkinManager::SetSkinManager
static CXTPSkinManager *AFX_CDECL SetSkinManager(CXTPSkinManager *pSkinManager, BOOL bDelete=TRUE)
Sets the skin manager.
CXTPSkinManager::IsPersistentModule
BOOL IsPersistentModule(HMODULE hModule)
Determines if a specified module is persistent.
CXTPSkinManager::SetApplyOptions
void SetApplyOptions(DWORD dwOptions)
Specifies which parts of the application skin should be applied.
CXTPSkinManager::GetSkinClass
virtual CXTPSkinManagerClass * GetSkinClass(const CXTPSkinObject *pObject, CString strClassList)
Gets a specified skin class by its name.
CXTPSkinManager::ExcludeModule
void ExcludeModule(LPCTSTR lpszModule)
Excludes a specified .dll file from API hooking.
CXTPSkinManager::m_pSchema
CXTPSkinManagerSchema * m_pSchema
Current schema.
Definition XTPSkinManager.h:1147
CXTPSkinManager::m_pSetWinEventHook
LPFNSETWINEVENTHOOK m_pSetWinEventHook
Pointer to SetWinEventHook API.
Definition XTPSkinManager.h:1157
CXTPSkinManager::m_bEnabled
BOOL m_bEnabled
TRIE if skinning is enabled.
Definition XTPSkinManager.h:1143
CXTPSkinManager::GetAutoApplyNewWindows
BOOL GetAutoApplyNewWindows() const
Determines if new windows are automatically skinned.
Definition XTPSkinManager.h:1273
CXTPSkinManager::OnSkinChanged
virtual void OnSkinChanged(BOOL bPrevState, BOOL bNewState)
This method is called when the skin is changed.
CXTPSkinManager::Remove
void Remove(HWND hWnd)
Removes the hook from a specified window.
CXTPSkinManagerMetrics
CXTPSkinManagerMetrics is a standalone class that represents a collection of metrics of the current s...
Definition XTPSkinManager.h:403
CXTPSkinManagerMetrics::m_cyVScroll
int m_cyVScroll
SM_CYVSCROLL system metric.
Definition XTPSkinManager.h:521
CXTPSkinManagerMetrics::m_cyCaption
int m_cyCaption
Height of captions.
Definition XTPSkinManager.h:523
CXTPSkinManagerMetrics::m_clrEdgeShadow
COLORREF m_clrEdgeShadow
Shadow edge color.
Definition XTPSkinManager.h:505
CXTPSkinManagerMetrics::DestroyMetrics
void DestroyMetrics()
Destroys all GDI objects of metrics.
CXTPSkinManagerMetrics::m_xtpBrushTabControl
CXTPBrush m_xtpBrushTabControl
Tab control brush.
Definition XTPSkinManager.h:493
CXTPSkinManagerMetrics::m_cySmallCaption
int m_cySmallCaption
Height of small captions.
Definition XTPSkinManager.h:524
CXTPSkinManagerMetrics::m_clrEdgeLight
COLORREF m_clrEdgeLight
Light edge color.
Definition XTPSkinManager.h:503
CXTPSkinManagerMetrics::m_cxEdge
int m_cxEdge
SM_CXEDGE system metric.
Definition XTPSkinManager.h:515
CXTPSkinManagerMetrics::IsMetricObject
BOOL IsMetricObject(HGDIOBJ hObject) const
Determines if a specified handle belongs to metrics.
CXTPSkinManagerMetrics::m_nBorderSize
int m_nBorderSize
Border size.
Definition XTPSkinManager.h:512
CXTPSkinManagerMetrics::m_clrEdgeHighLight
COLORREF m_clrEdgeHighLight
HighLight edge color.
Definition XTPSkinManager.h:504
CXTPSkinManagerMetrics::m_cyOsCaption
int m_cyOsCaption
System caption height.
Definition XTPSkinManager.h:526
CXTPSkinManagerMetrics::CXTPSkinManagerMetrics
CXTPSkinManagerMetrics(CXTPSkinManagerSchema *pSchema)
Constructs a CXTPSkinManagerMetrics object.
CXTPSkinManagerMetrics::CreateTabControlBrush
BOOL CreateTabControlBrush(CBitmap *pBitmap)
Creates a tab control brush.
CXTPSkinManagerMetrics::m_clrEdgeDkShadow
COLORREF m_clrEdgeDkShadow
Dark shadow edge color.
Definition XTPSkinManager.h:506
CXTPSkinManagerMetrics::m_xtpFontCaption
CXTPFont m_xtpFontCaption
Caption font.
Definition XTPSkinManager.h:480
CXTPSkinManagerMetrics::m_cxVScroll
int m_cxVScroll
SM_CXVSCROLL system metric.
Definition XTPSkinManager.h:520
CXTPSkinManagerMetrics::GetColor
COLORREF GetColor(int nIndex) const
Retrieves the skinned color of a specified index.
CXTPSkinManagerMetrics::m_xtpFontMenu
CXTPFont m_xtpFontMenu
Menu font.
Definition XTPSkinManager.h:481
CXTPSkinManagerMetrics::m_xtpBrushWindow
CXTPBrush m_xtpBrushWindow
Window brush.
Definition XTPSkinManager.h:494
CXTPSkinManagerMetrics::m_xtpBrushDialog
CXTPBrush m_xtpBrushDialog
Dialog brush.
Definition XTPSkinManager.h:492
CXTPSkinManagerMetrics::GetBrush
HBRUSH GetBrush(int nIndex) const
Retrieves the skinned brush of a specified index.
CXTPSkinManagerMetrics::m_cyEdge
int m_cyEdge
SM_CYEDGE system metric.
Definition XTPSkinManager.h:516
CXTPSkinManagerMetrics::m_cyOsSmallCaption
int m_cyOsSmallCaption
System small caption height.
Definition XTPSkinManager.h:527
CXTPSkinManagerMetrics::m_cxOsVScroll
int m_cxOsVScroll
System SM_CXVSCROLL metric.
Definition XTPSkinManager.h:528
CXTPSkinManagerMetrics::m_cyBorder
int m_cyBorder
SM_CYBORDER system metric.
Definition XTPSkinManager.h:514
CXTPSkinManagerMetrics::m_bRefreshMetrics
BOOL m_bRefreshMetrics
TRUE if refresh metrics is currently executed.
Definition XTPSkinManager.h:530
CXTPSkinManagerMetrics::RefreshMetrics
virtual void RefreshMetrics()
Refreshes visual metrics.
CXTPSkinManagerMetrics::m_cxHScroll
int m_cxHScroll
SM_CXHSCROLL system metric.
Definition XTPSkinManager.h:518
CXTPSkinManagerMetrics::m_pSchema
CXTPSkinManagerSchema * m_pSchema
Parent CXTPSkinManager object.
Definition XTPSkinManager.h:490
CXTPSkinManagerMetrics::m_cxBorder
int m_cxBorder
SM_CXBORDER system metric.
Definition XTPSkinManager.h:513
CXTPSkinManagerMetrics::~CXTPSkinManagerMetrics
virtual ~CXTPSkinManagerMetrics()
Destroys a CXTPSkinManagerMetrics object, handles cleanup and deallocation.
CXTPSkinManagerMetrics::m_xtpFontSmCaption
CXTPFont m_xtpFontSmCaption
Small caption font.
Definition XTPSkinManager.h:482
CXTPSkinManagerMetrics::m_cyHScroll
int m_cyHScroll
SM_CYHSCROLL system metric.
Definition XTPSkinManager.h:519
CXTPSkinManagerResourceFile
CXTPSkinManagerResourceFile is a standalone class that represents a manager of visual style resources...
Definition XTPSkinManagerResource.h:45
CXTPSkinManagerSchema
CXTPSkinManagerSchema is a standalone class used to read a visual styles schema file.
Definition XTPSkinManagerSchema.h:164
CXTPSkinManagerSchemaProperty
CXTPSkinManagerSchemaProperty is a standalone class representing a single property of a visual styles...
Definition XTPSkinManagerSchema.h:50
CXTPSkinObjectClassMap
CXTPSkinObjectClassMap is a standalone class that helps map windows controls to skin framework classe...
Definition XTPSkinObject.h:320
CXTPSkinObject
CXTPSkinObject is a CWnd derived class.
Definition XTPSkinObject.h:80
CXTPSoundManager
CXTPSoundManager is a standalone class.
Definition XTPSystemHelpers.h:1222
CXTPSynchronized
A base class for a synchronized object.
Definition XTPSynchro.h:602
IXTPApplicationEvents
Defines a callback interface for XTP application event sink.
Definition XTPApplication.h:82
IXTPSkinManagerWindowFilter
Implement this interface in order to provide custom configured window filter functionality.
Definition XTPSkinManager.h:353
IXTPSkinManagerWindowFilter::FilterWindowClass
virtual BOOL FilterWindowClass(LPCWSTR lpszClassName)=0
The implementation must make a decision as to whether a window class must be filtered out (not skinne...
IXTPSkinManagerWindowFilter::FilterWindow
virtual BOOL FilterWindow(HWND hWnd, LPCTSTR lpszClassName, LPCREATESTRUCT lpcs)=0
The implementation must make a decision as to whether a window must be filtered out (not skinned) or ...
IXTPSkinManagerWindowFilter::FilterWindowClass
virtual BOOL FilterWindowClass(LPCSTR lpszClassName)=0
The implementation must make a decision as to whether a window class must be filtered out (not skinne...
IXTPSkinManagerWindowFilter::~IXTPSkinManagerWindowFilter
virtual ~IXTPSkinManagerWindowFilter()
Handles object destruction.
Definition XTPSkinManager.h:357


Toolkit Pro: Member List

CXTPDockingPaneTabColorSetVisualStudio2003 Member List

This is the complete list of members for CXTPDockingPaneTabColorSetVisualStudio2003, including all inherited members.

CXTPDockingPaneTabColorSetVisualStudio2003(BOOL bHighlightSelected) | CXTPDockingPaneTabColorSetVisualStudio2003 |
CXTPTabPaintManagerColorSet() | CXTPTabPaintManagerColorSet |
FillClient(CDC *pDC, CRect rc, CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
FillFramePartRect(CDC *pDC, CRect rc, CWnd *pWnd, CWnd *pSite) | CXTPDockingPaneTabColorSetVisualStudio2003 |
FillHeader(CDC *pDC, CRect rc, CXTPTabManager *pTabManager) | CXTPDockingPaneTabColorSetVisualStudio2003 | virtual
FillNavigateButton(CDC *pDC, CXTPTabManagerNavigateButton *pButton, CRect &rc) | CXTPTabColorSetOffice2003 | virtual
FillPropertyButton(CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem) | CXTPDockingPaneTabColorSetVisualStudio2003 | virtual
FillStateButton(CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerColorSet | virtual
GetClientColor(CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
GetItemColor(CXTPTabManagerItem *pItem) | CXTPTabPaintManagerColorSet | virtual
GradientFill(CDC *pDC, CRect rc, COLORREF clrLight, COLORREF clrDark, XTPTabPosition position) | CXTPTabPaintManagerColorSet |
IsAppThemed() const | CXTPTabPaintManagerColorSet | virtual
m_bLunaTheme | CXTPTabColorSetOffice2003 | protected
m_clrActiveFilesBack | CXTPTabPaintManagerColorSet |
m_clrActiveFilesBackHighlighted | CXTPTabPaintManagerColorSet |
m_clrActiveFilesBackPressed | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyph | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyphHighlighted | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyphPressed | CXTPTabPaintManagerColorSet |
m_clrAutoHideFace | CXTPTabPaintManagerColorSet |
m_clrBorderHighlight | CXTPTabPaintManagerColorSet |
m_clrButtonBorder | CXTPTabPaintManagerColorSet |
m_clrButtonBorderHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonBorderHot | CXTPTabPaintManagerColorSet |
m_clrButtonBorderKeyTips | CXTPTabPaintManagerColorSet |
m_clrButtonBorderTabContext1 | CXTPTabPaintManagerColorSet |
m_clrButtonBorderTabContext2 | CXTPTabPaintManagerColorSet |
m_clrButtonHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonHighlightedClose | CXTPTabPaintManagerColorSet |
m_clrButtonNormal | CXTPTabPaintManagerColorSet |
m_clrButtonPressed | CXTPTabPaintManagerColorSet |
m_clrButtonSelected | CXTPTabPaintManagerColorSet |
m_clrButtonSelectedHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonSelectedPressed | CXTPTabPaintManagerColorSet |
m_clrControlFace | CXTPTabPaintManagerColorSet |
m_clrFrameBorder | CXTPTabPaintManagerColorSet |
m_clrHeaderFace | CXTPTabPaintManagerColorSet |
m_clrNavigateButtonBorder | CXTPTabColorSetOffice2003 | protected
m_clrPaneFace | CXTPTabPaintManagerColorSet |
m_clrTabClientBack | CXTPTabPaintManagerColorSet |
m_clrTabClientBorder | CXTPTabPaintManagerColorSet |
m_clrTextDisabled | CXTPTabPaintManagerColorSet |
m_clrTextHighlight | CXTPTabPaintManagerColorSet |
m_clrTextHighlightClose | CXTPTabPaintManagerColorSet |
m_clrTextNormal | CXTPTabPaintManagerColorSet |
m_clrTextPressed | CXTPTabPaintManagerColorSet |
m_clrTextSelected | CXTPTabPaintManagerColorSet |
m_clrTextSelectedHighlighted | CXTPTabPaintManagerColorSet |
m_clrTextSelectedPressed | CXTPTabPaintManagerColorSet |
m_csExcelNormal | CXTPTabPaintManagerColorSet |
m_csExcelSelected | CXTPTabPaintManagerColorSet |
m_csPropertyPage | CXTPTabPaintManagerColorSet |
m_csPropertyPage2003 | CXTPTabPaintManagerColorSet |
m_csStateButton | CXTPTabPaintManagerColorSet |
m_pPaintManager | CXTPTabPaintManagerColorSet | protected
Rectangle(CDC *pDC, CRect rc, int nPen, int nBrush) | CXTPTabColorSetOffice2003 |
RefreshMetrics() | CXTPDockingPaneTabColorSetVisualStudio2003 | virtual
SelectClipRgn(CDC *pDC, CRect rcClient, CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
SetTextColor(CDC *pDC, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerColorSet | virtual
~CXTPTabPaintManagerColorSet() | CXTPTabPaintManagerColorSet | virtual


Toolkit Pro: XTPPropertyGridPaintManager.h Source File

  • Source
  • PropertyGrid
XTPPropertyGridPaintManager.h
Go to the documentation of this file.
1
23#if !defined(_XTPPROPERTYGRIDPAINTMANAGER_H__)
24# define _XTPPROPERTYGRIDPAINTMANAGER_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPPropertyGrid;
34class CXTPPropertyGridInplaceButton;
35class CXTPPropertyGridItem;
36class CXTPPropertyGridItemConstraint;
37class CXTPPropertyGridItemBool;
38class CXTPWinThemeWrapper;
39
40class CXTPButton;
41class CXTPComboBox;
42
43class CXTPPropertyGridPaintManager;
44
49class _XTP_EXT_CLASS CXTPPropertyGridItemMetrics : public CXTPCmdTarget
50{
51public:
57 CXTPPropertyGridItemMetrics(CXTPPropertyGridPaintManager* pPaintManager);
58
63 virtual void SetDefaultValues();
64
65public:
66 CXTPFont m_xtpFontNormal;
67 CXTPFont m_xtpFontBold;
68 CXTPFont m_xtpFontUnderline;
70 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CFont, m_fontNormal, m_xtpFontNormal,
71 GetNormalFontHandle);
72 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CFont, m_fontBold, m_xtpFontBold, GetBoldFontHandle);
73 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CFont, m_fontUnderline, m_xtpFontUnderline,
74 GetUnderlineFontHandle);
75
76 int m_nImage;
78 CXTPPaintManagerColor m_clrHelpBack;
79 CXTPPaintManagerColor m_clrHelpFore;
80 CXTPPaintManagerColor m_clrLine;
81 CXTPPaintManagerColor m_clrFore;
82 CXTPPaintManagerColor m_clrCategoryFore;
83 CXTPPaintManagerColor m_clrBack;
84 CXTPPaintManagerColor m_clrReadOnlyFore;
85 CXTPPaintManagerColor m_clrVerbFace;
87 UINT m_uDrawTextFormat;
88 int m_nMaxLength;
91protected:
92 CXTPPropertyGridPaintManager* m_pPaintManager;
95# ifdef _XTP_ACTIVEX
98public:
99 DECLARE_DISPATCH_MAP()
100 DECLARE_INTERFACE_MAP()
101
102 DECLARE_OLETYPELIB_EX(CXTPPropertyGridItemMetrics)
103
104 afx_msg COLORREF OleGetForeColor();
105 afx_msg void OleSetForeColor(COLORREF clr);
106 afx_msg COLORREF OleGetBackColor();
107 afx_msg void OleSetBackColor(COLORREF clr);
108 afx_msg void OleSetFont(LPFONTDISP pFontDisp);
109 afx_msg LPFONTDISP OleGetFont();
110
112# endif
113};
114
121enum XTPPropertyGridWindow
122{
123 xtpPropertyGridVerbWindow,
124 xtpPropertyGridGridWindow,
125 xtpPropertyGridHelpWindow
126};
127
132class _XTP_EXT_CLASS CXTPPropertyGridPaintManager : public CXTPCmdTarget
133{
134public:
140 CXTPPropertyGridPaintManager(CXTPPropertyGrid* pGrid);
141
147 virtual ~CXTPPropertyGridPaintManager();
148
149public:
158 virtual COLORREF GetItemTextColor(CXTPPropertyGridItem* pItem, BOOL bValuePart);
159
168 virtual COLORREF GetItemBackColor(CXTPPropertyGridItem* pItem, BOOL bValuePart);
169
178 virtual CFont* GetItemFont(CXTPPropertyGridItem* pItem, BOOL bValuePart);
179
180public:
186 virtual void FillPropertyGrid(CDC* pDC);
187
193 virtual void FillPropertyGridView(CDC* pDC);
194
206 virtual void DrawPropertyGridBorder(CDC* pDC, RECT& rcBorder, XTPPropertyGridWindow nWindow);
207
213 virtual void OnNcCalcSize(RECT& rc);
214
221 virtual void DrawItem(PDRAWITEMSTRUCT lpDrawItemStruct);
222
231 virtual void DrawInplaceListItem(CDC* pDC, CXTPPropertyGridItemConstraint* pConstraint,
232 CRect rc, BOOL bSelected);
233
240 virtual void AdjustItemValueRect(CXTPPropertyGridItem* pItem, CRect& rcValue);
241
248 virtual void AdjustItemCaptionRect(CXTPPropertyGridItem* pItem, CRect& rcCaption);
249
256 virtual void MeasureItem(LPMEASUREITEMSTRUCT lpMeasureItemStruct);
257
258 void FillInplaceButtonThemed(CDC* pDC, CXTPPropertyGridInplaceButton* pButton);
259
266 virtual void FillInplaceButton(CDC* pDC, CXTPPropertyGridInplaceButton* pButton);
267
272 virtual void RefreshMetrics();
273
281 virtual XTPScrollBarTheme GetScrollBarTheme() const;
282
294 int HitTestVerbs(CDC* pDC, CRect rcVerbs, CPoint pt);
295
302 CXTPPropertyGridItemMetrics* GetItemMetrics() const;
303
315 CRect GetSplitterRect(CRect rc, BOOL bIsHelp);
316
323 virtual int GetItemsBorderHeight() const;
324
330 virtual void SetItemsBorderHeight(int nHeight);
331
337 virtual void SetThinSplitter(BOOL bThinSplitter);
338
339public:
347 virtual void DrawExpandButton(CDC& dc, CXTPPropertyGridItem* pItem, CRect rcCaption);
348
356 virtual void DrawCategoryCaptionBackground(CDC* pDC, CXTPPropertyGridItem* pItem, CRect rc);
357
365 virtual void DrawItemValue(CDC* pDC, CXTPPropertyGridItem* pItem, CRect rcValue);
366
374 virtual void DrawItemCaption(CDC* pDC, CXTPPropertyGridItem* pItem, CRect rcCaption);
375
386 virtual void DrawInplaceButtons(CDC* pDC, PDRAWITEMSTRUCT lpDrawItemStruct,
387 CXTPPropertyGridItem* pItem, CRect rcValue);
388
396 virtual void DrawCheckBox(CDC* pDC, CXTPPropertyGridItemBool* pButton);
397
406 virtual void DrawCheckMark(CDC* pDC, CRect rc, BOOL bEnabled, BOOL bChecked);
407
417 virtual void DrawRadioMark(CDC* pDC, CRect rc, BOOL bEnabled, BOOL bChecked);
418
419 virtual void DrawSplitter(CDC* pDC, BOOL bIsHelp);
420
422 void DrawInplaceButtons(CDC* pDC, CXTPPropertyGridItem* pItem, CRect rcValue);
425# ifdef _XTP_INCLUDE_CONTROLS
426 void DrawCheckMarkThemed(CDC* pDC, CRect rc, BOOL bEnabled, BOOL bChecked);
427 void DrawRadioMarkThemed(CDC* pDC, CRect rc, BOOL bEnabled, BOOL bChecked);
428 void SetControlsTheme(int eTheme);
429# endif
430
431public:
432 XTPPropertyGridInplaceButtonsStyle m_buttonsStyle;
434 CXTPWinThemeWrapper* m_themeTree;
435 CXTPWinThemeWrapper* m_themeButton;
436 CXTPWinThemeWrapper* m_themeCombo;
437 BOOL m_bTransparent;
439# ifdef _XTP_INCLUDE_CONTROLS
440 CXTPButton* m_pButton;
441 CXTPButton* m_pButtonCheck;
442 CXTPComboBox* m_pCombo;
443 BOOL m_bUseThemedControls;
444# else
445private:
446 CXTPExcludedMemberPadding<CXTPButton*> m_pButton;
447 CXTPExcludedMemberPadding<CXTPButton*> m_pButtonCheck;
448 CXTPExcludedMemberPadding<CXTPComboBox*> m_pCombo;
449 CXTPExcludedMemberPadding<BOOL> m_bUseThemedControls;
450
451public:
452# endif
453
454public:
455 CXTPPaintManagerColor m_clrFace;
456 CXTPPaintManagerColor m_clrShadow;
457 CXTPPaintManagerColor m_clrHighlight;
458 CXTPPaintManagerColor m_clrHighlightText;
459 CXTPPaintManagerColor m_clrNonHighlightBack;
460 CXTPPaintManagerColor m_clrNonHighlightText;
461 CXTPPaintManagerColor m_clrCategorySeparator;
462 CXTPPaintManagerColor m_clrSplitter;
464protected:
465 int m_nItemsBorderHeight;
467 int m_nSplitterHeight;
468 int m_nHelpHeight;
469 int m_nVerbsHeight;
470 BOOL m_bThinSplitter;
471 CXTPPropertyGrid* m_pGrid;
472 CXTPPropertyGridItemMetrics* m_pMetrics;
474 friend class CXTPPropertyGrid;
475
476# ifdef _XTP_ACTIVEX
479 DECLARE_DISPATCH_MAP()
480 DECLARE_INTERFACE_MAP()
481
482 DECLARE_OLETYPELIB_EX(CXTPPropertyGridPaintManager)
483 DECLARE_PROPERTY(HelpBackColor, COLORREF);
484 DECLARE_PROPERTY(HelpForeColor, COLORREF);
485 DECLARE_PROPERTY(ViewBackColor, COLORREF);
486 DECLARE_PROPERTY(ViewForeColor, COLORREF);
487 DECLARE_PROPERTY(LineColor, COLORREF);
488 DECLARE_PROPERTY(ViewCategoryForeColor, COLORREF);
489 DECLARE_PROPERTY(ViewReadOnlyForeColor, COLORREF);
490
491 DECLARE_PROPERTY(BackgroundColor, COLORREF);
492 DECLARE_PROPERTY(ShadowColor, COLORREF);
493 DECLARE_PROPERTY(HighlightBackColor, COLORREF);
494 DECLARE_PROPERTY(HighlightForeColor, COLORREF);
495 DECLARE_PROPERTY(HyperlinkColor, COLORREF);
496 DECLARE_PROPERTY(ItemsBorderHeight, long);
497
499# endif
500};
501
507class _XTP_EXT_CLASS CXTPPropertyGridOffice2003Theme : public CXTPPropertyGridPaintManager
508{
509public:
515 CXTPPropertyGridOffice2003Theme(CXTPPropertyGrid* pGrid);
516
521 virtual void RefreshMetrics();
522
530 virtual XTPScrollBarTheme GetScrollBarTheme() const;
531
532protected:
533 BOOL m_bLunaTheme;
534};
535
541class _XTP_EXT_CLASS CXTPPropertyGridOffice2007Theme : public CXTPPropertyGridOffice2003Theme
542{
543public:
549 CXTPPropertyGridOffice2007Theme(CXTPPropertyGrid* pGrid);
550
555 virtual void RefreshMetrics();
556
557protected:
564 virtual void FillInplaceButton(CDC* pDC, CXTPPropertyGridInplaceButton* pButton);
565
574 virtual void DrawCheckMark(CDC* pDC, CRect rc, BOOL bEnabled, BOOL bChecked);
575
585 virtual void DrawRadioMark(CDC* pDC, CRect rc, BOOL bEnabled, BOOL bChecked);
586
594 void DrawExpandButton(CDC& dc, CXTPPropertyGridItem* pItem, CRect rcCaption);
595
603 virtual XTPScrollBarTheme GetScrollBarTheme() const;
604};
605
611class _XTP_EXT_CLASS CXTPPropertyGridNativeXPTheme : public CXTPPropertyGridPaintManager
612{
613public:
619 CXTPPropertyGridNativeXPTheme(CXTPPropertyGrid* pGrid);
620
625 virtual void RefreshMetrics();
626
634 virtual XTPScrollBarTheme GetScrollBarTheme() const;
635};
636
642class _XTP_EXT_CLASS CXTPPropertyGridOfficeXPTheme : public CXTPPropertyGridPaintManager
643{
644public:
650 CXTPPropertyGridOfficeXPTheme(CXTPPropertyGrid* pGrid);
651
656 void RefreshMetrics();
657
665 virtual XTPScrollBarTheme GetScrollBarTheme() const;
666};
667
673class _XTP_EXT_CLASS CXTPPropertyGridCoolTheme : public CXTPPropertyGridPaintManager
674{
675public:
681 CXTPPropertyGridCoolTheme(CXTPPropertyGrid* pGrid);
682
689 virtual void DrawItem(PDRAWITEMSTRUCT lpDrawItemStruct);
690
695 void RefreshMetrics();
696
704 virtual XTPScrollBarTheme GetScrollBarTheme() const;
705};
706
712class _XTP_EXT_CLASS CXTPPropertyGridSimpleTheme : public CXTPPropertyGridPaintManager
713{
714public:
720 CXTPPropertyGridSimpleTheme(CXTPPropertyGrid* pGrid);
721
728 virtual void DrawItem(PDRAWITEMSTRUCT lpDrawItemStruct);
729
734 void RefreshMetrics();
735
743 virtual XTPScrollBarTheme GetScrollBarTheme() const;
744};
745
751class _XTP_EXT_CLASS CXTPPropertyGridDelphiTheme : public CXTPPropertyGridPaintManager
752{
753public:
759 CXTPPropertyGridDelphiTheme(CXTPPropertyGrid* pGrid);
760
767 virtual void DrawItem(PDRAWITEMSTRUCT lpDrawItemStruct);
768
773 virtual void RefreshMetrics();
774
782 virtual XTPScrollBarTheme GetScrollBarTheme() const;
783};
784
790class _XTP_EXT_CLASS CXTPPropertyGridVisualStudio2005Theme : public CXTPPropertyGridPaintManager
791{
792public:
798 CXTPPropertyGridVisualStudio2005Theme(CXTPPropertyGrid* pGrid);
799
800protected:
808 void DrawCategoryCaptionBackground(CDC* pDC, CXTPPropertyGridItem* pItem, CRect rc);
809
814 void RefreshMetrics();
815
823 void DrawExpandButton(CDC& dc, CXTPPropertyGridItem* pItem, CRect rcCaption);
824
832 virtual XTPScrollBarTheme GetScrollBarTheme() const;
833};
834
840class _XTP_EXT_CLASS CXTPPropertyGridVisualStudio2010Theme : public CXTPPropertyGridPaintManager
841{
842public:
848 CXTPPropertyGridVisualStudio2010Theme(CXTPPropertyGrid* pGrid);
849
855 ~CXTPPropertyGridVisualStudio2010Theme();
856
857public:
865 virtual void DrawExpandButton(CDC& dc, CXTPPropertyGridItem* pItem, CRect rcCaption);
866
871 virtual void RefreshMetrics();
872
880 virtual XTPScrollBarTheme GetScrollBarTheme() const;
881};
882
888class _XTP_EXT_CLASS CXTPPropertyGridVisualStudio2012Theme : public CXTPPropertyGridPaintManager
889{
890public:
897 CXTPPropertyGridVisualStudio2012Theme(CXTPPropertyGrid* pGrid, BOOL bLight);
898
903 virtual void RefreshMetrics();
904
912 virtual void DrawExpandButton(CDC& dc, CXTPPropertyGridItem* pItem, CRect rcCaption);
913
921 virtual XTPScrollBarTheme GetScrollBarTheme() const;
922
923protected:
924 BOOL m_bLight;
925};
926
932class _XTP_EXT_CLASS CXTPPropertyGridOffice2013Theme : public CXTPPropertyGridPaintManager
933{
934public:
940 CXTPPropertyGridOffice2013Theme(CXTPPropertyGrid* pGrid);
941
946 virtual void RefreshMetrics();
947
955 virtual void DrawExpandButton(CDC& dc, CXTPPropertyGridItem* pItem, CRect rcCaption);
956
964 virtual XTPScrollBarTheme GetScrollBarTheme() const;
965
966 CXTPPaintManagerColor m_clrGlyphExpand;
967 CXTPPaintManagerColor m_clrGlyphBorder;
968 CXTPPaintManagerColor m_clrGlyphContract;
969};
970
976class _XTP_EXT_CLASS CXTPPropertyGridVisualStudio2015Theme
977 : public CXTPPropertyGridVisualStudio2010Theme
978{
979public:
985 CXTPPropertyGridVisualStudio2015Theme(CXTPPropertyGrid* pGrid);
986
994 virtual void DrawExpandButton(CDC& dc, CXTPPropertyGridItem* pItem, CRect rcCaption);
995
1000 virtual void RefreshMetrics();
1001
1009 virtual XTPScrollBarTheme GetScrollBarTheme() const;
1010};
1011
1017class _XTP_EXT_CLASS CXTPPropertyGridVisualStudio2017Theme
1018 : public CXTPPropertyGridVisualStudio2010Theme
1019{
1020public:
1026 CXTPPropertyGridVisualStudio2017Theme(CXTPPropertyGrid* pGrid);
1027
1035 virtual void DrawExpandButton(CDC& dc, CXTPPropertyGridItem* pItem, CRect rcCaption);
1036
1041 virtual void RefreshMetrics();
1042
1050 virtual XTPScrollBarTheme GetScrollBarTheme() const;
1051};
1052
1058class _XTP_EXT_CLASS CXTPPropertyGridVisualStudio2019Theme
1059 : public CXTPPropertyGridVisualStudio2010Theme
1060{
1061public:
1067 CXTPPropertyGridVisualStudio2019Theme(CXTPPropertyGrid* pGrid);
1068
1076 virtual void DrawExpandButton(CDC& dc, CXTPPropertyGridItem* pItem, CRect rcCaption);
1077
1082 virtual void RefreshMetrics();
1083
1091 virtual XTPScrollBarTheme GetScrollBarTheme() const;
1092};
1093
1099class _XTP_EXT_CLASS CXTPPropertyGridVisualStudio2022Theme
1100 : public CXTPPropertyGridVisualStudio2010Theme
1101{
1102public:
1108 CXTPPropertyGridVisualStudio2022Theme(CXTPPropertyGrid* pGrid);
1109
1117 virtual void DrawExpandButton(CDC& dc, CXTPPropertyGridItem* pItem, CRect rcCaption);
1118
1123 virtual void RefreshMetrics();
1124
1132 virtual XTPScrollBarTheme GetScrollBarTheme() const;
1133};
1134
1140class _XTP_EXT_CLASS CXTPPropertyGridNativeWindows10Theme
1141 : public CXTPPropertyGridVisualStudio2010Theme
1142{
1143public:
1149 CXTPPropertyGridNativeWindows10Theme(CXTPPropertyGrid* pGrid);
1150
1158 virtual void DrawExpandButton(CDC& dc, CXTPPropertyGridItem* pItem, CRect rcCaption);
1159
1164 virtual void RefreshMetrics();
1165
1173 virtual XTPScrollBarTheme GetScrollBarTheme() const;
1174};
1175
1181class _XTP_EXT_CLASS CXTPPropertyGridNativeWindows11Theme
1182 : public CXTPPropertyGridVisualStudio2010Theme
1183{
1184public:
1190 CXTPPropertyGridNativeWindows11Theme(CXTPPropertyGrid* pGrid);
1191
1199 virtual void DrawExpandButton(CDC& dc, CXTPPropertyGridItem* pItem, CRect rcCaption);
1200
1205 virtual void RefreshMetrics();
1206
1214 virtual XTPScrollBarTheme GetScrollBarTheme() const;
1215};
1216
1217AFX_INLINE CXTPPropertyGridItemMetrics* CXTPPropertyGridPaintManager::GetItemMetrics() const
1218{
1219 return m_pMetrics;
1220}
1221
1222AFX_INLINE void CXTPPropertyGridPaintManager::DrawInplaceButtons(CDC* pDC,
1223 CXTPPropertyGridItem* pItem,
1224 CRect rcValue)
1225{
1226 DrawInplaceButtons(pDC, NULL, pItem, rcValue);
1227}
1228
1229AFX_INLINE int CXTPPropertyGridPaintManager::GetItemsBorderHeight() const
1230{
1231 return m_nItemsBorderHeight;
1232}
1233
1234AFX_INLINE void CXTPPropertyGridPaintManager::SetItemsBorderHeight(int nHeight)
1235{
1236 m_nItemsBorderHeight = nHeight;
1237}
1238
1239AFX_INLINE void CXTPPropertyGridPaintManager::SetThinSplitter(BOOL bThinSplitter)
1240{
1241 m_bThinSplitter = bThinSplitter;
1242}
1243
1245# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
1246#endif // !defined(_XTPPROPERTYGRIDPAINTMANAGER_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPPropertyGridInplaceButtonsStyle
XTPPropertyGridInplaceButtonsStyle
In-place Button Style enumeration.
Definition XTPPropertyGridDefines.h:174
XTPPropertyGridWindow
XTPPropertyGridWindow
Window identifier enumeration.
Definition XTPPropertyGridPaintManager.h:122
xtpPropertyGridVerbWindow
@ xtpPropertyGridVerbWindow
Verb window.
Definition XTPPropertyGridPaintManager.h:123
xtpPropertyGridGridWindow
@ xtpPropertyGridGridWindow
Grid window.
Definition XTPPropertyGridPaintManager.h:124
xtpPropertyGridHelpWindow
@ xtpPropertyGridHelpWindow
Help window.
Definition XTPPropertyGridPaintManager.h:125
XTPScrollBarTheme
XTPScrollBarTheme
Scrollbar theme identifier enum.
Definition XTPScrollBase.h:87
CXTPButton
Push Button control.
Definition XTPButton.h:109
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPComboBox
The CXTPComboBox class provides the functionality of a themed Windows combobox.
Definition XTPComboBox.h:42
CXTPExcludedMemberPadding
The CXTPExcludedMemberPadding type is used for declaring padding members for the members that were ex...
Definition XTPSystemHelpers.h:1855
CXTPFont
Provides a convenient object oriented interface for HFONT GDI object and uses GDI handle caching.
Definition XTPGdiObjects.h:414
CXTPPaintManagerColor
The CXTPPaintManagerColor class is used to manage COLORREF values for determining default and applica...
Definition XTPColorManager.h:117
CXTPPropertyGridCoolTheme
CXTPPropertyGridCoolTheme is a CXTPPropertyGridPaintManager derived class.
Definition XTPPropertyGridPaintManager.h:674
CXTPPropertyGridCoolTheme::CXTPPropertyGridCoolTheme
CXTPPropertyGridCoolTheme(CXTPPropertyGrid *pGrid)
Constructs a CXTPPropertyGridCoolTheme object.
CXTPPropertyGridCoolTheme::GetScrollBarTheme
virtual XTPScrollBarTheme GetScrollBarTheme() const
Gets the scrollbar theme identifier.
CXTPPropertyGridCoolTheme::DrawItem
virtual void DrawItem(PDRAWITEMSTRUCT lpDrawItemStruct)
Draws a single item for the grid.
CXTPPropertyGridCoolTheme::RefreshMetrics
void RefreshMetrics()
Refreshes the visual metrics of the property grid.
CXTPPropertyGridDelphiTheme
CXTPPropertyGridDelphiTheme is a CXTPPropertyGridPaintManager derived class.
Definition XTPPropertyGridPaintManager.h:752
CXTPPropertyGridDelphiTheme::CXTPPropertyGridDelphiTheme
CXTPPropertyGridDelphiTheme(CXTPPropertyGrid *pGrid)
Constructs a CXTPPropertyGridDelphiTheme object.
CXTPPropertyGridDelphiTheme::GetScrollBarTheme
virtual XTPScrollBarTheme GetScrollBarTheme() const
Gets the scrollbar theme identifier.
CXTPPropertyGridDelphiTheme::DrawItem
virtual void DrawItem(PDRAWITEMSTRUCT lpDrawItemStruct)
Draws a single item for the grid.
CXTPPropertyGridDelphiTheme::RefreshMetrics
virtual void RefreshMetrics()
Refreshes the visual metrics of the property grid.
CXTPPropertyGrid
CXTPPropertyGrid is a CWnd derived class.
Definition XTPPropertyGrid.h:402
CXTPPropertyGridInplaceButton
CXTPPropertyGridInplaceButton is a CXTPCmdTarget derived class.
Definition XTPPropertyGridInplaceButton.h:50
CXTPPropertyGridItemBool
CXTPPropertyGridItemBool is a CXTPPropertyGridItem derived class.
Definition XTPPropertyGridItemBool.h:39
CXTPPropertyGridItemConstraint
CXTPPropertyGridItemConstraint is a CXTPCmdTarget derived class.
Definition XTPPropertyGridItem.h:271
CXTPPropertyGridItem
CXTPPropertyGridItem is the base class representing an item of the Property Grid control.
Definition XTPPropertyGridItem.h:523
CXTPPropertyGridItemMetrics
Standalone class used by CXTPPropertyGridPaintManager to store item metrics.
Definition XTPPropertyGridPaintManager.h:50
CXTPPropertyGridItemMetrics::m_pPaintManager
CXTPPropertyGridPaintManager * m_pPaintManager
Pointer to the paint manager used to draw the property grid.
Definition XTPPropertyGridPaintManager.h:92
CXTPPropertyGridItemMetrics::SetDefaultValues
virtual void SetDefaultValues()
Resets all color values to their default values.
CXTPPropertyGridItemMetrics::m_nMaxLength
int m_nMaxLength
Maximum number of characters that can be entered into an editable item (Edit limit).
Definition XTPPropertyGridPaintManager.h:88
CXTPPropertyGridItemMetrics::m_uDrawTextFormat
UINT m_uDrawTextFormat
Text formatting style for the property item.
Definition XTPPropertyGridPaintManager.h:87
CXTPPropertyGridItemMetrics::CXTPPropertyGridItemMetrics
CXTPPropertyGridItemMetrics(CXTPPropertyGridPaintManager *pPaintManager)
Constructs a CXTPPropertyGridItemMetrics object.
CXTPPropertyGridItemMetrics::m_clrReadOnlyFore
CXTPPaintManagerColor m_clrReadOnlyFore
Color of read-only text.
Definition XTPPropertyGridPaintManager.h:84
CXTPPropertyGridItemMetrics::m_nImage
int m_nImage
Image index.
Definition XTPPropertyGridPaintManager.h:76
CXTPPropertyGridItemMetrics::m_xtpFontNormal
CXTPFont m_xtpFontNormal
Normal font.
Definition XTPPropertyGridPaintManager.h:66
CXTPPropertyGridItemMetrics::m_xtpFontBold
CXTPFont m_xtpFontBold
Bold font.
Definition XTPPropertyGridPaintManager.h:67
CXTPPropertyGridItemMetrics::m_clrVerbFace
CXTPPaintManagerColor m_clrVerbFace
Text color of verbs.
Definition XTPPropertyGridPaintManager.h:85
CXTPPropertyGridItemMetrics::m_clrHelpFore
CXTPPaintManagerColor m_clrHelpFore
Color of the description text.
Definition XTPPropertyGridPaintManager.h:79
CXTPPropertyGridItemMetrics::m_clrHelpBack
CXTPPaintManagerColor m_clrHelpBack
Color of the description background.
Definition XTPPropertyGridPaintManager.h:78
CXTPPropertyGridItemMetrics::m_clrCategoryFore
CXTPPaintManagerColor m_clrCategoryFore
Color of the category text.
Definition XTPPropertyGridPaintManager.h:82
CXTPPropertyGridItemMetrics::m_clrLine
CXTPPaintManagerColor m_clrLine
Line color.
Definition XTPPropertyGridPaintManager.h:80
CXTPPropertyGridItemMetrics::m_clrFore
CXTPPaintManagerColor m_clrFore
Color of the item's text.
Definition XTPPropertyGridPaintManager.h:81
CXTPPropertyGridItemMetrics::m_xtpFontUnderline
CXTPFont m_xtpFontUnderline
Underline Font.
Definition XTPPropertyGridPaintManager.h:68
CXTPPropertyGridItemMetrics::m_clrBack
CXTPPaintManagerColor m_clrBack
Background color.
Definition XTPPropertyGridPaintManager.h:83
CXTPPropertyGridNativeWindows10Theme
CXTPPropertyGridNativeWindows10Theme is a CXTPPropertyGridVisualStudio2010Theme derived class.
Definition XTPPropertyGridPaintManager.h:1142
CXTPPropertyGridNativeWindows10Theme::DrawExpandButton
virtual void DrawExpandButton(CDC &dc, CXTPPropertyGridItem *pItem, CRect rcCaption)
Draws an expand button for the grid.
CXTPPropertyGridNativeWindows10Theme::CXTPPropertyGridNativeWindows10Theme
CXTPPropertyGridNativeWindows10Theme(CXTPPropertyGrid *pGrid)
Constructs a CXTPPropertyGridNativeWindows10Theme object.
CXTPPropertyGridNativeWindows10Theme::GetScrollBarTheme
virtual XTPScrollBarTheme GetScrollBarTheme() const
Gets the scrollbar theme identifier.
CXTPPropertyGridNativeWindows10Theme::RefreshMetrics
virtual void RefreshMetrics()
Refreshes the visual metrics of the property grid.
CXTPPropertyGridNativeWindows11Theme
CXTPPropertyGridNativeWindows11Theme is a CXTPPropertyGridVisualStudio2010Theme derived class.
Definition XTPPropertyGridPaintManager.h:1183
CXTPPropertyGridNativeWindows11Theme::DrawExpandButton
virtual void DrawExpandButton(CDC &dc, CXTPPropertyGridItem *pItem, CRect rcCaption)
Draws an expand button for the grid.
CXTPPropertyGridNativeWindows11Theme::GetScrollBarTheme
virtual XTPScrollBarTheme GetScrollBarTheme() const
Gets the scrollbar theme identifier.
CXTPPropertyGridNativeWindows11Theme::CXTPPropertyGridNativeWindows11Theme
CXTPPropertyGridNativeWindows11Theme(CXTPPropertyGrid *pGrid)
Constructs a CXTPPropertyGridNativeWindows11Theme object.
CXTPPropertyGridNativeWindows11Theme::RefreshMetrics
virtual void RefreshMetrics()
Refreshes the visual metrics of the property grid.
CXTPPropertyGridNativeXPTheme
CXTPPropertyGridNativeXPTheme is a CXTPPropertyGridPaintManager derived class.
Definition XTPPropertyGridPaintManager.h:612
CXTPPropertyGridNativeXPTheme::CXTPPropertyGridNativeXPTheme
CXTPPropertyGridNativeXPTheme(CXTPPropertyGrid *pGrid)
Constructs a CXTPPropertyGridNativeXPTheme object.
CXTPPropertyGridNativeXPTheme::GetScrollBarTheme
virtual XTPScrollBarTheme GetScrollBarTheme() const
Gets the scrollbar theme identifier.
CXTPPropertyGridNativeXPTheme::RefreshMetrics
virtual void RefreshMetrics()
Refreshes the visual metrics of the property grid.
CXTPPropertyGridOffice2003Theme
CXTPPropertyGridOffice2003Theme is a CXTPPropertyGridPaintManager derived class.
Definition XTPPropertyGridPaintManager.h:508
CXTPPropertyGridOffice2003Theme::m_bLunaTheme
BOOL m_bLunaTheme
TRUE to use luna colors, FALSE otherwise.
Definition XTPPropertyGridPaintManager.h:533
CXTPPropertyGridOffice2003Theme::GetScrollBarTheme
virtual XTPScrollBarTheme GetScrollBarTheme() const
Gets the scrollbar theme identifier.
CXTPPropertyGridOffice2003Theme::CXTPPropertyGridOffice2003Theme
CXTPPropertyGridOffice2003Theme(CXTPPropertyGrid *pGrid)
Constructs a CXTPPropertyGridOffice2003Theme object.
CXTPPropertyGridOffice2003Theme::RefreshMetrics
virtual void RefreshMetrics()
Refreshes the visual metrics of the property grid.
CXTPPropertyGridOffice2007Theme
CXTPPropertyGridOffice2007Theme is a CXTPPropertyGridOffice2003Theme derived class.
Definition XTPPropertyGridPaintManager.h:542
CXTPPropertyGridOffice2007Theme::CXTPPropertyGridOffice2007Theme
CXTPPropertyGridOffice2007Theme(CXTPPropertyGrid *pGrid)
Constructs a CXTPPropertyGridOffice2003Theme object.
CXTPPropertyGridOffice2007Theme::DrawCheckMark
virtual void DrawCheckMark(CDC *pDC, CRect rc, BOOL bEnabled, BOOL bChecked)
Draws a check mark.
CXTPPropertyGridOffice2007Theme::GetScrollBarTheme
virtual XTPScrollBarTheme GetScrollBarTheme() const
Gets the scrollbar theme identifier.
CXTPPropertyGridOffice2007Theme::DrawExpandButton
void DrawExpandButton(CDC &dc, CXTPPropertyGridItem *pItem, CRect rcCaption)
Draws an expand button for the grid.
CXTPPropertyGridOffice2007Theme::DrawRadioMark
virtual void DrawRadioMark(CDC *pDC, CRect rc, BOOL bEnabled, BOOL bChecked)
Draws a radio button for a CXTPPropertyGridItemOption item with the RadioButton (default) style.
CXTPPropertyGridOffice2007Theme::RefreshMetrics
virtual void RefreshMetrics()
Refreshes the visual metrics of the property grid.
CXTPPropertyGridOffice2007Theme::FillInplaceButton
virtual void FillInplaceButton(CDC *pDC, CXTPPropertyGridInplaceButton *pButton)
Draws an in-place button for the grid.
CXTPPropertyGridOffice2013Theme
CXTPPropertyGridOffice2013Theme is a CXTPPropertyGridPaintManager derived class.
Definition XTPPropertyGridPaintManager.h:933
CXTPPropertyGridOffice2013Theme::CXTPPropertyGridOffice2013Theme
CXTPPropertyGridOffice2013Theme(CXTPPropertyGrid *pGrid)
Constructs a CXTPPropertyGridOffice2013Theme object.
CXTPPropertyGridOffice2013Theme::DrawExpandButton
virtual void DrawExpandButton(CDC &dc, CXTPPropertyGridItem *pItem, CRect rcCaption)
Draws an expand button for the grid.
CXTPPropertyGridOffice2013Theme::m_clrGlyphContract
CXTPPaintManagerColor m_clrGlyphContract
Contract glyph color.
Definition XTPPropertyGridPaintManager.h:968
CXTPPropertyGridOffice2013Theme::m_clrGlyphExpand
CXTPPaintManagerColor m_clrGlyphExpand
Expand glyph color.
Definition XTPPropertyGridPaintManager.h:966
CXTPPropertyGridOffice2013Theme::m_clrGlyphBorder
CXTPPaintManagerColor m_clrGlyphBorder
Expand glyph border color.
Definition XTPPropertyGridPaintManager.h:967
CXTPPropertyGridOffice2013Theme::GetScrollBarTheme
virtual XTPScrollBarTheme GetScrollBarTheme() const
Gets the scrollbar theme identifier.
CXTPPropertyGridOffice2013Theme::RefreshMetrics
virtual void RefreshMetrics()
Refreshes the visual metrics of the property grid.
CXTPPropertyGridOfficeXPTheme
CXTPPropertyGridOfficeXPTheme is a CXTPPropertyGridPaintManager derived class.
Definition XTPPropertyGridPaintManager.h:643
CXTPPropertyGridOfficeXPTheme::CXTPPropertyGridOfficeXPTheme
CXTPPropertyGridOfficeXPTheme(CXTPPropertyGrid *pGrid)
Constructs a CXTPPropertyGridOfficeXPTheme object.
CXTPPropertyGridOfficeXPTheme::GetScrollBarTheme
virtual XTPScrollBarTheme GetScrollBarTheme() const
Gets the scrollbar theme identifier.
CXTPPropertyGridOfficeXPTheme::RefreshMetrics
void RefreshMetrics()
Refreshes the visual metrics of the property grid.
CXTPPropertyGridPaintManager
Standalone class used by CXTPPropertyGrid as the paint manager.
Definition XTPPropertyGridPaintManager.h:133
CXTPPropertyGridPaintManager::DrawExpandButton
virtual void DrawExpandButton(CDC &dc, CXTPPropertyGridItem *pItem, CRect rcCaption)
Draws an expand button for the grid.
CXTPPropertyGridPaintManager::m_clrNonHighlightBack
CXTPPaintManagerColor m_clrNonHighlightBack
Non-highlight background color.
Definition XTPPropertyGridPaintManager.h:459
CXTPPropertyGridPaintManager::DrawInplaceButtons
virtual void DrawInplaceButtons(CDC *pDC, PDRAWITEMSTRUCT lpDrawItemStruct, CXTPPropertyGridItem *pItem, CRect rcValue)
Draws the in-place buttons of a property grid item.
Definition XTPPropertyGridPaintManager.h:1222
CXTPPropertyGridPaintManager::m_bThinSplitter
BOOL m_bThinSplitter
TRUE to draw a single line for the splitter bar.
Definition XTPPropertyGridPaintManager.h:470
CXTPPropertyGridPaintManager::DrawCheckBox
virtual void DrawCheckBox(CDC *pDC, CXTPPropertyGridItemBool *pButton)
Draws a checkbox for a CXTPPropertyGridItemOption item with with the CheckBox style.
CXTPPropertyGridPaintManager::m_clrCategorySeparator
CXTPPaintManagerColor m_clrCategorySeparator
Face color.
Definition XTPPropertyGridPaintManager.h:461
CXTPPropertyGridPaintManager::m_clrNonHighlightText
CXTPPaintManagerColor m_clrNonHighlightText
Non-highlight text color.
Definition XTPPropertyGridPaintManager.h:460
CXTPPropertyGridPaintManager::DrawInplaceListItem
virtual void DrawInplaceListItem(CDC *pDC, CXTPPropertyGridItemConstraint *pConstraint, CRect rc, BOOL bSelected)
Draws a specified constraint in the in-place list.
CXTPPropertyGridPaintManager::DrawItemValue
virtual void DrawItemValue(CDC *pDC, CXTPPropertyGridItem *pItem, CRect rcValue)
Draws the value part of a property grid item.
CXTPPropertyGridPaintManager::AdjustItemValueRect
virtual void AdjustItemValueRect(CXTPPropertyGridItem *pItem, CRect &rcValue)
Adjusts the rectangle of the value part of a specified item.
CXTPPropertyGridPaintManager::DrawCategoryCaptionBackground
virtual void DrawCategoryCaptionBackground(CDC *pDC, CXTPPropertyGridItem *pItem, CRect rc)
Draws the background for the bounding rectangle of a category caption.
CXTPPropertyGridPaintManager::m_clrHighlightText
CXTPPaintManagerColor m_clrHighlightText
Highlight text color.
Definition XTPPropertyGridPaintManager.h:458
CXTPPropertyGridPaintManager::DrawPropertyGridBorder
virtual void DrawPropertyGridBorder(CDC *pDC, RECT &rcBorder, XTPPropertyGridWindow nWindow)
Draws grid borders.
CXTPPropertyGridPaintManager::m_pGrid
CXTPPropertyGrid * m_pGrid
Parent grid class.
Definition XTPPropertyGridPaintManager.h:471
CXTPPropertyGridPaintManager::DrawItemCaption
virtual void DrawItemCaption(CDC *pDC, CXTPPropertyGridItem *pItem, CRect rcCaption)
Draws the caption part of a property grid item.
CXTPPropertyGridPaintManager::SetItemsBorderHeight
virtual void SetItemsBorderHeight(int nHeight)
Sets the height of the horizontal grid line between property grid items.
Definition XTPPropertyGridPaintManager.h:1234
CXTPPropertyGridPaintManager::AdjustItemCaptionRect
virtual void AdjustItemCaptionRect(CXTPPropertyGridItem *pItem, CRect &rcCaption)
Adjusts the rectangle of the caption part of a specified item.
CXTPPropertyGridPaintManager::MeasureItem
virtual void MeasureItem(LPMEASUREITEMSTRUCT lpMeasureItemStruct)
Override this method and fill in a specified MEASUREITEMSTRUCT structure to inform Windows of the lis...
CXTPPropertyGridPaintManager::m_nItemsBorderHeight
int m_nItemsBorderHeight
Height, in pixels, of the horizontal border between property grid items.
Definition XTPPropertyGridPaintManager.h:465
CXTPPropertyGridPaintManager::DrawCheckMark
virtual void DrawCheckMark(CDC *pDC, CRect rc, BOOL bEnabled, BOOL bChecked)
Draws a check mark.
CXTPPropertyGridPaintManager::GetScrollBarTheme
virtual XTPScrollBarTheme GetScrollBarTheme() const
Gets the indentifier of the scrollbar theme.
CXTPPropertyGridPaintManager::HitTestVerbs
int HitTestVerbs(CDC *pDC, CRect rcVerbs, CPoint pt)
Determines the index of the verb within the verbs collection, if any, at a specified point.
CXTPPropertyGridPaintManager::m_nSplitterHeight
int m_nSplitterHeight
Height, in pixels, of the splitter bar.
Definition XTPPropertyGridPaintManager.h:467
CXTPPropertyGridPaintManager::m_clrFace
CXTPPaintManagerColor m_clrFace
Face color.
Definition XTPPropertyGridPaintManager.h:455
CXTPPropertyGridPaintManager::m_nVerbsHeight
int m_nVerbsHeight
Height, in pixels, of the verbs box.
Definition XTPPropertyGridPaintManager.h:469
CXTPPropertyGridPaintManager::DrawItem
virtual void DrawItem(PDRAWITEMSTRUCT lpDrawItemStruct)
Draws a single item of the grid.
CXTPPropertyGridPaintManager::CXTPPropertyGridPaintManager
CXTPPropertyGridPaintManager(CXTPPropertyGrid *pGrid)
Constructs a CXTPPropertyGridPaintManager object.
CXTPPropertyGridPaintManager::GetItemMetrics
CXTPPropertyGridItemMetrics * GetItemMetrics() const
Gets the default item metrics.
Definition XTPPropertyGridPaintManager.h:1217
CXTPPropertyGridPaintManager::m_themeButton
CXTPWinThemeWrapper * m_themeButton
Themes for button controls.
Definition XTPPropertyGridPaintManager.h:435
CXTPPropertyGridPaintManager::OnNcCalcSize
virtual void OnNcCalcSize(RECT &rc)
Adjusts the bounding rectangle of the grid.
CXTPPropertyGridPaintManager::GetItemFont
virtual CFont * GetItemFont(CXTPPropertyGridItem *pItem, BOOL bValuePart)
Retrieves the font of a specified item.
CXTPPropertyGridPaintManager::GetItemsBorderHeight
virtual int GetItemsBorderHeight() const
Gets the height of the horizontal grid line between property grid items.
Definition XTPPropertyGridPaintManager.h:1229
CXTPPropertyGridPaintManager::m_pMetrics
CXTPPropertyGridItemMetrics * m_pMetrics
Default metrics of the item.
Definition XTPPropertyGridPaintManager.h:472
CXTPPropertyGridPaintManager::DrawRadioMark
virtual void DrawRadioMark(CDC *pDC, CRect rc, BOOL bEnabled, BOOL bChecked)
Draws a radio button for a CXTPPropertyGridItemOption item with the RadioButton (default) style.
CXTPPropertyGridPaintManager::m_buttonsStyle
XTPPropertyGridInplaceButtonsStyle m_buttonsStyle
TRUE to use WinXP themes.
Definition XTPPropertyGridPaintManager.h:432
CXTPPropertyGridPaintManager::m_clrShadow
CXTPPaintManagerColor m_clrShadow
Shadow color.
Definition XTPPropertyGridPaintManager.h:456
CXTPPropertyGridPaintManager::GetItemBackColor
virtual COLORREF GetItemBackColor(CXTPPropertyGridItem *pItem, BOOL bValuePart)
Retrieves the back color of a specified item.
CXTPPropertyGridPaintManager::FillPropertyGrid
virtual void FillPropertyGrid(CDC *pDC)
Draws the background of the property grid.
CXTPPropertyGridPaintManager::m_nHelpHeight
int m_nHelpHeight
Height, in pixels, of the description area (help pane).
Definition XTPPropertyGridPaintManager.h:468
CXTPPropertyGridPaintManager::m_clrHighlight
CXTPPaintManagerColor m_clrHighlight
Highlight color.
Definition XTPPropertyGridPaintManager.h:457
CXTPPropertyGridPaintManager::RefreshMetrics
virtual void RefreshMetrics()
Refreshes the visual metrics of the paint manager.
CXTPPropertyGridPaintManager::FillPropertyGridView
virtual void FillPropertyGridView(CDC *pDC)
Draws the background of the view.
CXTPPropertyGridPaintManager::SetThinSplitter
virtual void SetThinSplitter(BOOL bThinSplitter)
Sets draw a bottom single line for the splitter bar.
Definition XTPPropertyGridPaintManager.h:1239
CXTPPropertyGridPaintManager::FillInplaceButton
virtual void FillInplaceButton(CDC *pDC, CXTPPropertyGridInplaceButton *pButton)
Draws an in-place button for the grid.
CXTPPropertyGridPaintManager::GetItemTextColor
virtual COLORREF GetItemTextColor(CXTPPropertyGridItem *pItem, BOOL bValuePart)
Retrieves the text color of a specified item.
CXTPPropertyGridPaintManager::m_bTransparent
BOOL m_bTransparent
TRUE to draw background with parent color.
Definition XTPPropertyGridPaintManager.h:437
CXTPPropertyGridPaintManager::m_themeTree
CXTPWinThemeWrapper * m_themeTree
Themes for tree controls.
Definition XTPPropertyGridPaintManager.h:434
CXTPPropertyGridPaintManager::GetSplitterRect
CRect GetSplitterRect(CRect rc, BOOL bIsHelp)
This method is called by the property grid to retrieve the size of either the help window splitter ba...
CXTPPropertyGridPaintManager::m_clrSplitter
CXTPPaintManagerColor m_clrSplitter
Splitter border color.
Definition XTPPropertyGridPaintManager.h:462
CXTPPropertyGridPaintManager::m_themeCombo
CXTPWinThemeWrapper * m_themeCombo
Themes for combo button.
Definition XTPPropertyGridPaintManager.h:436
CXTPPropertyGridPaintManager::~CXTPPropertyGridPaintManager
virtual ~CXTPPropertyGridPaintManager()
Destroys a CXTPPropertyGridPaintManager object, handles cleanup and deallocation.
CXTPPropertyGridSimpleTheme
CXTPPropertyGridSimpleTheme is a CXTPPropertyGridPaintManager derived class.
Definition XTPPropertyGridPaintManager.h:713
CXTPPropertyGridSimpleTheme::CXTPPropertyGridSimpleTheme
CXTPPropertyGridSimpleTheme(CXTPPropertyGrid *pGrid)
Constructs a CXTPPropertyGridSimpleTheme object.
CXTPPropertyGridSimpleTheme::GetScrollBarTheme
virtual XTPScrollBarTheme GetScrollBarTheme() const
Gets the scrollbar theme identifier.
CXTPPropertyGridSimpleTheme::DrawItem
virtual void DrawItem(PDRAWITEMSTRUCT lpDrawItemStruct)
Draws a single item for the grid.
CXTPPropertyGridSimpleTheme::RefreshMetrics
void RefreshMetrics()
Refreshes the visual metrics of the property grid.
CXTPPropertyGridVisualStudio2005Theme
CXTPPropertyGridVisualStudio2005Theme is a CXTPPropertyGridPaintManager derived class.
Definition XTPPropertyGridPaintManager.h:791
CXTPPropertyGridVisualStudio2005Theme::GetScrollBarTheme
virtual XTPScrollBarTheme GetScrollBarTheme() const
Gets the scrollbar theme identifier.
CXTPPropertyGridVisualStudio2005Theme::CXTPPropertyGridVisualStudio2005Theme
CXTPPropertyGridVisualStudio2005Theme(CXTPPropertyGrid *pGrid)
Constructs a CXTPPropertyGridVisualStudio2005Theme object.
CXTPPropertyGridVisualStudio2005Theme::DrawExpandButton
void DrawExpandButton(CDC &dc, CXTPPropertyGridItem *pItem, CRect rcCaption)
Draws an expand button for the grid.
CXTPPropertyGridVisualStudio2005Theme::RefreshMetrics
void RefreshMetrics()
Refreshes the visual metrics of the property grid.
CXTPPropertyGridVisualStudio2005Theme::DrawCategoryCaptionBackground
void DrawCategoryCaptionBackground(CDC *pDC, CXTPPropertyGridItem *pItem, CRect rc)
Draws the background for the bounding rectangle of a category caption.
CXTPPropertyGridVisualStudio2010Theme
CXTPPropertyGridVisualStudio2010Theme is a CXTPPropertyGridPaintManager derived class.
Definition XTPPropertyGridPaintManager.h:841
CXTPPropertyGridVisualStudio2010Theme::DrawExpandButton
virtual void DrawExpandButton(CDC &dc, CXTPPropertyGridItem *pItem, CRect rcCaption)
Draws an expand button for the grid.
CXTPPropertyGridVisualStudio2010Theme::~CXTPPropertyGridVisualStudio2010Theme
~CXTPPropertyGridVisualStudio2010Theme()
Destroys a CXTPPropertyGridVisualStudio2010Theme object, handles cleanup and deallocation.
CXTPPropertyGridVisualStudio2010Theme::GetScrollBarTheme
virtual XTPScrollBarTheme GetScrollBarTheme() const
Gets the scrollbar theme identifier.
CXTPPropertyGridVisualStudio2010Theme::RefreshMetrics
virtual void RefreshMetrics()
Refreshes the visual metrics of the property grid.
CXTPPropertyGridVisualStudio2010Theme::CXTPPropertyGridVisualStudio2010Theme
CXTPPropertyGridVisualStudio2010Theme(CXTPPropertyGrid *pGrid)
Constructs a CXTPPropertyGridVisualStudio2010Theme object.
CXTPPropertyGridVisualStudio2012Theme
CXTPPropertyGridVisualStudio2012Theme is a CXTPPropertyGridVisualStudio2010Theme derived class.
Definition XTPPropertyGridPaintManager.h:889
CXTPPropertyGridVisualStudio2012Theme::DrawExpandButton
virtual void DrawExpandButton(CDC &dc, CXTPPropertyGridItem *pItem, CRect rcCaption)
Draws an expand button for the grid.
CXTPPropertyGridVisualStudio2012Theme::CXTPPropertyGridVisualStudio2012Theme
CXTPPropertyGridVisualStudio2012Theme(CXTPPropertyGrid *pGrid, BOOL bLight)
Constructs a CXTPPropertyGridVisualStudio2012Theme object.
CXTPPropertyGridVisualStudio2012Theme::GetScrollBarTheme
virtual XTPScrollBarTheme GetScrollBarTheme() const
Gets the scrollbar theme identifier.
CXTPPropertyGridVisualStudio2012Theme::RefreshMetrics
virtual void RefreshMetrics()
Refreshes the visual metrics of the property grid.
CXTPPropertyGridVisualStudio2015Theme
CXTPPropertyGridVisualStudio2015Theme is a CXTPPropertyGridVisualStudio2010Theme derived class.
Definition XTPPropertyGridPaintManager.h:978
CXTPPropertyGridVisualStudio2015Theme::DrawExpandButton
virtual void DrawExpandButton(CDC &dc, CXTPPropertyGridItem *pItem, CRect rcCaption)
Draws an expand button for the grid.
CXTPPropertyGridVisualStudio2015Theme::GetScrollBarTheme
virtual XTPScrollBarTheme GetScrollBarTheme() const
Gets the scrollbar theme identifier.
CXTPPropertyGridVisualStudio2015Theme::CXTPPropertyGridVisualStudio2015Theme
CXTPPropertyGridVisualStudio2015Theme(CXTPPropertyGrid *pGrid)
Constructs a CXTPPropertyGridVisualStudio2015Theme object.
CXTPPropertyGridVisualStudio2015Theme::RefreshMetrics
virtual void RefreshMetrics()
Refreshes the visual metrics of the property grid.
CXTPPropertyGridVisualStudio2017Theme
CXTPPropertyGridVisualStudio2017Theme is a CXTPPropertyGridVisualStudio2010Theme derived class.
Definition XTPPropertyGridPaintManager.h:1019
CXTPPropertyGridVisualStudio2017Theme::DrawExpandButton
virtual void DrawExpandButton(CDC &dc, CXTPPropertyGridItem *pItem, CRect rcCaption)
Draws an expand button for the grid.
CXTPPropertyGridVisualStudio2017Theme::CXTPPropertyGridVisualStudio2017Theme
CXTPPropertyGridVisualStudio2017Theme(CXTPPropertyGrid *pGrid)
Constructs a CXTPPropertyGridVisualStudio2017Theme object.
CXTPPropertyGridVisualStudio2017Theme::GetScrollBarTheme
virtual XTPScrollBarTheme GetScrollBarTheme() const
Gets the scrollbar theme identifier.
CXTPPropertyGridVisualStudio2017Theme::RefreshMetrics
virtual void RefreshMetrics()
Refreshes the visual metrics of the property grid.
CXTPPropertyGridVisualStudio2019Theme
CXTPPropertyGridVisualStudio2019Theme is a CXTPPropertyGridVisualStudio2010Theme derived class.
Definition XTPPropertyGridPaintManager.h:1060
CXTPPropertyGridVisualStudio2019Theme::DrawExpandButton
virtual void DrawExpandButton(CDC &dc, CXTPPropertyGridItem *pItem, CRect rcCaption)
Draws an expand button for the grid.
CXTPPropertyGridVisualStudio2019Theme::GetScrollBarTheme
virtual XTPScrollBarTheme GetScrollBarTheme() const
Gets the scrollbar theme identifier.
CXTPPropertyGridVisualStudio2019Theme::CXTPPropertyGridVisualStudio2019Theme
CXTPPropertyGridVisualStudio2019Theme(CXTPPropertyGrid *pGrid)
Constructs a CXTPPropertyGridVisualStudio2019Theme object.
CXTPPropertyGridVisualStudio2019Theme::RefreshMetrics
virtual void RefreshMetrics()
Refreshes the visual metrics of the property grid.
CXTPPropertyGridVisualStudio2022Theme
CXTPPropertyGridVisualStudio2022Theme is a CXTPPropertyGridVisualStudio2010Theme derived class.
Definition XTPPropertyGridPaintManager.h:1101
CXTPPropertyGridVisualStudio2022Theme::CXTPPropertyGridVisualStudio2022Theme
CXTPPropertyGridVisualStudio2022Theme(CXTPPropertyGrid *pGrid)
Constructs a CXTPPropertyGridVisualStudio2022Theme object.
CXTPPropertyGridVisualStudio2022Theme::DrawExpandButton
virtual void DrawExpandButton(CDC &dc, CXTPPropertyGridItem *pItem, CRect rcCaption)
Draws an expand button for the grid.
CXTPPropertyGridVisualStudio2022Theme::GetScrollBarTheme
virtual XTPScrollBarTheme GetScrollBarTheme() const
Gets the scrollbar theme identifier.
CXTPPropertyGridVisualStudio2022Theme::RefreshMetrics
virtual void RefreshMetrics()
Refreshes the visual metrics of the property grid.
CXTPWinThemeWrapper
The CXTPWinThemeWrapper class wraps the UxTheme.dll visual theme API.
Definition XTPWinThemeWrapper.h:188


Toolkit Pro: Member List

CXTPFlowGraphConnectionPoint Member List

This is the complete list of members for CXTPFlowGraphConnectionPoint, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPFlowGraphConnectionPoint() | CXTPFlowGraphConnectionPoint | protected
CXTPFlowGraphElement() | CXTPFlowGraphElement |
DoPropExchange(CXTPPropExchange *pPX) | CXTPFlowGraphConnectionPoint | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCaption() const | CXTPFlowGraphConnectionPoint | virtual
GetColor() const | CXTPFlowGraphConnectionPoint |
GetConnectionsCount() const | CXTPFlowGraphConnectionPoint |
GetControl() const | CXTPFlowGraphConnectionPoint | virtual
GetID() const | CXTPFlowGraphConnectionPoint |
GetImage() const | CXTPFlowGraphConnectionPoint |
GetImageIndex() const | CXTPFlowGraphConnectionPoint |
GetInputConnectionAt(int nIndex) const | CXTPFlowGraphConnectionPoint |
GetInputConnectionsCount() const | CXTPFlowGraphConnectionPoint |
GetMarkupUIElement() const | CXTPFlowGraphConnectionPoint |
GetMaxConnections() const | CXTPFlowGraphConnectionPoint |
GetName() const | CXTPFlowGraphConnectionPoint |
GetNode() const | CXTPFlowGraphConnectionPoint |
GetOutputConnectionAt(int nIndex) const | CXTPFlowGraphConnectionPoint |
GetOutputConnectionsCount() const | CXTPFlowGraphConnectionPoint |
GetPage() const | CXTPFlowGraphConnectionPoint | virtual
GetRect() const | CXTPFlowGraphConnectionPoint |
GetStyle() const | CXTPFlowGraphConnectionPoint |
GetTooltip() const | CXTPFlowGraphConnectionPoint |
GetType() const | CXTPFlowGraphConnectionPoint |
HitTestConnectionArea(CPoint point) const | CXTPFlowGraphConnectionPoint | virtual
IsLocked() const | CXTPFlowGraphConnectionPoint |
IsSelected() const | CXTPFlowGraphElement |
m_bDirty | CXTPFlowGraphElement |
m_bInputOutPair | CXTPFlowGraphConnectionPoint | protected
m_bLocked | CXTPFlowGraphConnectionPoint | protected
m_bMarkupPoint | CXTPFlowGraphConnectionPoint | protected
m_bSelected | CXTPFlowGraphElement | protected
m_clrPoint | CXTPFlowGraphConnectionPoint | protected
m_nId | CXTPFlowGraphConnectionPoint | protected
m_nImageIndex | CXTPFlowGraphConnectionPoint | protected
m_nMaxConnections | CXTPFlowGraphConnectionPoint | protected
m_nStyle | CXTPFlowGraphConnectionPoint | protected
m_nType | CXTPFlowGraphConnectionPoint | protected
m_pNode | CXTPFlowGraphConnectionPoint | protected
m_strCaption | CXTPFlowGraphConnectionPoint | protected
m_strName | CXTPFlowGraphConnectionPoint | protected
m_strTooltip | CXTPFlowGraphConnectionPoint | protected
OnGraphChanged() | CXTPFlowGraphConnectionPoint |
OnRemoved() | CXTPFlowGraphConnectionPoint | protectedvirtual
SetCaption(LPCTSTR lpszCaption) | CXTPFlowGraphConnectionPoint | virtual
SetColor(COLORREF clr) | CXTPFlowGraphConnectionPoint |
SetID(int nId) | CXTPFlowGraphConnectionPoint |
SetImageIndex(int nImageIndex) | CXTPFlowGraphConnectionPoint |
SetLocked(BOOL bLocked=TRUE) | CXTPFlowGraphConnectionPoint |
SetMaxConnections(int nMaxConnections) | CXTPFlowGraphConnectionPoint |
SetName(LPCTSTR lpszName) | CXTPFlowGraphConnectionPoint |
SetRect(const CRect &rect) | CXTPFlowGraphConnectionPoint |
SetStyle(int nStyle) | CXTPFlowGraphConnectionPoint |
SetTooltip(LPCTSTR lpszTooltip) | CXTPFlowGraphConnectionPoint |
SetType(XTPFlowGraphConnectionPointType type) | CXTPFlowGraphConnectionPoint |
~CXTPFlowGraphConnectionPoint() | CXTPFlowGraphConnectionPoint | virtual
~CXTPFlowGraphElement() | CXTPFlowGraphElement | virtual


Toolkit Pro: Member List

CXTPFontCtrlBase Member List

This is the complete list of members for CXTPFontCtrlBase, including all inherited members.

CreateUIFont(CFont &font) | CXTPFontCtrlBase | static
CXTPFontCtrlBase() | CXTPFontCtrlBase |
GetFontItemHeight() | CXTPFontCtrlBase | static
GetSelFont(CXTPLogFont &lf) | CXTPFontCtrlBase | virtual
GetSelFont(CString &strFaceName) | CXTPFontCtrlBase | virtual
m_csSymbol | CXTPFontCtrlBase | protected
m_dwStyle | CXTPFontCtrlBase | protected
m_pComboBox | CXTPFontCtrlBase | protected
m_pListBox | CXTPFontCtrlBase | protected
OnCompareItem(LPCOMPAREITEMSTRUCT lpCIS) | CXTPFontCtrlBase | protectedvirtual
OnDrawItem(LPDRAWITEMSTRUCT lpDIS) | CXTPFontCtrlBase | protectedvirtual
OnInit(CXTPFontListBox *pListBox) | CXTPFontCtrlBase | protectedvirtual
OnInit(CXTPFontComboBox *pComboBox) | CXTPFontCtrlBase | protectedvirtual
OnMeasureItem(LPMEASUREITEMSTRUCT lpMIS) | CXTPFontCtrlBase | protectedvirtual
SetSelFont(CXTPLogFont &lf) | CXTPFontCtrlBase | virtual
SetSelFont(const CString &strFaceName) | CXTPFontCtrlBase | virtual
~CXTPFontCtrlBase() | CXTPFontCtrlBase | virtual


Toolkit Pro: Member List

XTP_EDIT_COLORVALUES Member List

This is the complete list of members for XTP_EDIT_COLORVALUES, including all inherited members.

crBack | XTP_EDIT_COLORVALUES
crBreakpointBack | XTP_EDIT_COLORVALUES
crBreakpointText | XTP_EDIT_COLORVALUES
crHiliteBack | XTP_EDIT_COLORVALUES
crHiliteText | XTP_EDIT_COLORVALUES
crInactiveHiliteBack | XTP_EDIT_COLORVALUES
crInactiveHiliteText | XTP_EDIT_COLORVALUES
crLineNumberBack | XTP_EDIT_COLORVALUES
crLineNumberText | XTP_EDIT_COLORVALUES
crReadOnlyBack | XTP_EDIT_COLORVALUES
crText | XTP_EDIT_COLORVALUES
GetBackColorEx(CXTPSyntaxEditCtrl *pEditCtrl) | XTP_EDIT_COLORVALUES


Toolkit Pro: XTPCalendarOffice2013Theme.h Source File

  • Source
  • Calendar
  • Themes
XTPCalendarOffice2013Theme.h
Go to the documentation of this file.
1
22#if !defined(__XTPCALENDAROFFICE2013THEME_H__)
23# define __XTPCALENDAROFFICE2013THEME_H__
24
25# if _MSC_VER > 1000
26# pragma once
27# endif // _MSC_VER > 1000
28
29# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
30
36class _XTP_EXT_CLASS CXTPCalendarOffice2013Theme : public CXTPCalendarOffice2000Theme
37{
38public:
47 CXTPCalendarOffice2013Theme();
48
55 virtual ~CXTPCalendarOffice2013Theme();
56
64 virtual void RefreshMetrics();
65
81 virtual void DrawHeader(CDC* pDC, CRect& rcHeader, BOOL bIsSelected, BOOL bIsCurrent,
82 const CXTPPaintManagerColorGradient& grclr, COLORREF clrUnderLineHdr);
83
84 using CXTPCalendarOffice2000Theme::DrawHeader;
85
90 virtual void UpdateEventLabelsDefaultColors();
91
96 virtual void UpdateEventCategoriesDefaultColors();
97
105 virtual void UpdateGlyphs();
106
116 virtual COLORREF GetEventBackColor(CXTPCalendarEvent* pEvent);
117
118 using CXTPCalendarOffice2000Theme::GetEventBackColor;
119
129 virtual COLORREF GetEventEdgeColor(CXTPCalendarEvent* pEvent);
130
131 virtual void DrawCategories(CDC* pDC, CRect& rcEvent, CXTPCalendarEvent* pEvent);
132
133 virtual CXTPCalendarViewEventSubjectEditor* StartEditSubject(CXTPCalendarViewEvent* pViewEvent,
134 CRect& rcEditor);
135 virtual void SetEditFont(CXTPCalendarViewEvent* pViewEvent,
136 CXTPCalendarViewEventSubjectEditor* pEditor);
137 virtual void GetDateFormat(CString& strShort, CString& strLong);
138 virtual void CreateBoldFont(CFont* pFont, CFont* pFontBold);
139 virtual void CreateHeaderFont(CDC* pDC, CFont* pFont, CFont* pFontNew, BOOL bBoldFont);
140 virtual CSize GetTextSize(CDC* pDC, CString strText, CFont* pFont);
141 virtual void FormatLabel(CString& strLabel);
142
143 virtual void DrawMultiDayArrowL(CDC* pDC, int nL, CRect& rcText, COleDateTime& dtDate,
144 CFont& font);
145 virtual void DrawMultiDayArrowR(CDC* pDC, int nR, CRect& rcText, COleDateTime& dtDate,
146 CFont& font);
147 virtual void DrawMultiDayEvent(CDayViewEventPart* pViewPart, CDC* pDC,
148 CXTPCalendarDayViewEvent* pViewEvent, CRect& rcText);
149 virtual void DrawSingleDayEvent(CDayViewEventPart* pViewPart, CDC* pDC,
150 CXTPCalendarDayViewEvent* pViewEvent, CRect& rcText);
151 virtual void DrawExpandSign(CDC* pDC, BOOL bExpandUp, const CRect& rcTSHours);
152
153 virtual void PartRefresh(CControlPart* pViewPart);
154 virtual void PartRefresh(CDayViewEventPart* pViewPart);
155 virtual void PartRefresh(CDayViewTimeScaleCellPart* pViewPart);
156 virtual void PartRefresh(CDayViewTimeScaleHeaderPart* pViewPart);
157 virtual void PartRefresh(CDayViewAllDayEventsPart* pViewPart);
158 virtual void PartRefresh(CDayViewHeaderPart* pViewPart);
159 virtual void PartRefresh(CWeekViewPart* pViewPart);
160 virtual void PartRefresh(CMonthViewHeaderPart* pViewPart);
161 virtual void PartRefresh(CMonthViewEventPart* pViewPart);
162 virtual void PartRefresh(CDayViewWorkCellPart* pViewPart);
163 virtual void PartRefresh(CDayViewNonworkCellPart* pViewPart);
164 virtual void PartRefresh(CMonthViewGridPart* pViewPart);
165 virtual void PartRefresh(CTimeLineViewPart* pViewPart);
166
167 using CXTPCalendarOffice2000Theme::PartRefresh;
168
169 virtual BOOL ShowMultiDayTime(CXTPCalendarViewEvent* pViewEvent,
170 CXTPCalendarViewPart* pViewPart);
171
172 virtual void PartDrawEventSelectedBorder(CDC* pDC, CRect rcBorder, int l, int t, int r, int b);
173 virtual void PartDrawEventBusy(CXTPCalendarViewEvent* pViewEvent,
174 CXTPCalendarViewPart* pViewPart, CDC* pDC, CRect& rcEvent);
175 virtual void PartDrawEventBack(CXTPCalendarViewEvent* pViewEvent,
176 CXTPCalendarViewPart* pViewPart, CDC* pDC, CRect& rcEvent);
177 virtual void PartDrawEventTime(CXTPCalendarViewEvent* pViewEvent,
178 CXTPCalendarViewPart* pViewPart, CDC* pDC, CRect& rcEvent,
179 CRect& rcText, BOOL bTimeAsClock);
180 virtual void PartDrawEventText(CXTPCalendarViewEvent* pViewEvent,
181 CXTPCalendarViewPart* pViewPart, CDC* pDC, CRect& rcEvent,
182 CRect& rcText, int nViewDayIndex);
183
184 virtual void PartDraw(CDayViewEventPart* pViewPart, CDC* pDC,
185 CXTPCalendarDayViewEvent* pViewEvent);
186 virtual void PartDrawHourCell(CDayViewTimeScaleCellPart* pViewPart, CDC* pDC, CRect rc,
187 CString strText, BOOL bFillBackground, BOOL bCurrentTime);
188 virtual void PartDrawBigHourCell(CDayViewTimeScaleCellPart* pViewPart, CDC* pDC, CRect rc,
189 CString strHour, CString strMin, int nRowPerHour,
190 BOOL bFillBackground, BOOL bCurrentTime);
191 virtual void PartDraw(CDayViewTimeScaleHeaderPart* pViewPart, CDC* pDC,
192 CXTPCalendarDayView* /*pView*/, CRect rc, CString strText);
193 virtual void PartDrawNowLine(CDayViewTimeScaleHeaderPart* pViewPart, CDC* pDC,
194 CXTPCalendarDayView* pView, CRect rc, int y, BOOL bDrawBk);
195 virtual void PartDrawNowLine(CDayViewTimeScaleHeaderPart* pViewPart, CDC* pDC,
196 CXTPCalendarDayView* pView, CXTPCalendarDayViewTimeScale* pScale,
197 CRect rc, int y, BOOL bDrawBk);
198 virtual void PartDraw(CDayViewCellPart* pViewPart, CDC* pDC,
199 CXTPCalendarDayViewGroup* pViewGroup, CRect rc,
200 const XTP_CALENDAR_DAYVIEWCELL_PARAMS& cellParams);
201 virtual void PartDraw(CDayViewAllDayEventsPart* pViewPart, CDC* pDC,
202 CXTPCalendarDayViewGroup* pViewGroup, CRect rc, BOOL bSelected);
203 virtual void PartDraw(CDayViewHeaderPart* pViewPart, CDC* pDC, CXTPCalendarDayViewDay* pViewDay,
204 CRect rc, CString strText);
205 virtual void PartDraw(CWeekViewPart* pViewPart, CDC* pDC, CXTPCalendarWeekView* pWeekView);
206 virtual void PartDrawDayHeader(CWeekViewPart* pViewPart, CDC* pDC, CRect rcDay,
207 int nHeaderHeight, CString strHeader, BOOL bIsCurrent,
208 BOOL bIsSelected);
209 virtual void PartDraw(CWeekViewEventPart* pViewPart, CDC* pDC,
210 CXTPCalendarWeekViewEvent* pWeekViewEvent);
211 virtual void PartDrawGrid(CMonthViewGridPart* pViewPart, CDC* pDC,
212 CXTPCalendarMonthView* pMonthView);
213 virtual void PartDraw(CMonthViewHeaderPart* pViewPart, CDC* pDC,
214 CXTPCalendarMonthView* pMonthView, CRect rc, int nCollIndex,
215 CString strText);
216 virtual void PartDrawEvent(CMonthViewEventPart* pViewPart, CDC* pDC,
217 CXTPCalendarMonthViewEvent* pViewEvent);
218 virtual void PartDrawDayDate(CMonthViewEventPart* pViewPart, CDC* pDC, CRect rc, BOOL bToday,
219 BOOL bSelected, BOOL bFirstMonthDay, CString strText);
220 virtual void PartAdjustTimeFont(CDayViewTimeScaleCellPart* pViewPart, CDC* pDC, CRect rcCell);
221
222 using CXTPCalendarOffice2000Theme::PartDraw;
223 using CXTPCalendarOffice2000Theme::PartDrawEvent;
224
225protected:
226 int m_nBusyWidth;
227 int m_nPadding;
228 CString m_strThemeName;
229
230 CXTPFont m_xtpFontBold;
231 CXTPFont m_xtpFontSel;
232
233 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CFont, m_fontBold, m_xtpFontBold, GetBoldFontHandle);
234 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CFont, m_fontSel, m_xtpFontSel, GetSelFontHandle);
235
236 CXTPPaintManagerColor m_clrHeaderText;
237 CXTPPaintManagerColor m_clrHeaderBack;
238 CXTPPaintManagerColor m_clrViewBack;
239 CXTPPaintManagerColor m_clrHeaderTextSelected;
240 CXTPPaintManagerColor m_clrHeaderBackSelected;
241 CXTPPaintManagerColor m_clrEventSelBorder;
242 CXTPPaintManagerColor m_clrEventLabelNone;
243 CXTPPaintManagerColor m_clrEventLabelImportant;
244 CXTPPaintManagerColor m_clrEventLabelBusiness;
245 CXTPPaintManagerColor m_clrEventLabelPersonal;
246 CXTPPaintManagerColor m_clrEventLabelVacation;
247 CXTPPaintManagerColor m_clrEventLabelMustattend;
248 CXTPPaintManagerColor m_clrEventLabelTravelrequired;
249 CXTPPaintManagerColor m_clrEventLabelNeedspreparation;
250 CXTPPaintManagerColor m_clrEventLabelBirthday;
251 CXTPPaintManagerColor m_clrEventLabelAnniversary;
252 CXTPPaintManagerColor m_clrEventLabelPhonecall;
253 CXTPPaintManagerColor m_clrBusyStatusOutOfOfficeBack;
254 CXTPPaintManagerColor m_clrMultiDayArrow;
255 CXTPPaintManagerColor m_clrHourBack;
256 CXTPPaintManagerColor m_clrHourText;
257 CXTPPaintManagerColor m_clrHourNowText;
258 CXTPPaintManagerColor m_clrHourNowBack;
259 CXTPPaintManagerColor m_clrNowLine;
260 CXTPPaintManagerColor m_clrNowLineShadow;
261 CXTPPaintManagerColor m_clrCellBack;
262 CXTPPaintManagerColor m_clrCellText;
263 CXTPPaintManagerColor m_clrNonWorkCellBack;
264 CXTPPaintManagerColor m_clrGridLine;
265 CXTPPaintManagerColor m_clrMonthGridLine;
266 CXTPPaintManagerColor m_clrMultiDayEventFrameColor;
267};
268
269# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
270#endif // !defined(__XTPCALENDAROFFICE2013THEME_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCalendarDayViewDay
This class represents a day view portion of the Calendar Day View.
Definition XTPCalendarDayViewDay.h:726
CXTPCalendarDayViewEvent
This class represents an event view portion of the CalendarDayViewDay.
Definition XTPCalendarDayViewEvent.h:56
CXTPCalendarDayViewGroup
This class represents a single resource view portion of the Calendar Day View.
Definition XTPCalendarDayViewDay.h:53
CXTPCalendarDayView
This class implements a specific view portion of the Calendar control - called Day view.
Definition XTPCalendarDayView.h:62
CXTPCalendarDayViewTimeScale
This class implements a specific view portion of the Calendar Day view - called Time scale.
Definition XTPCalendarDayViewTimeScale.h:75
CXTPCalendarEvent
This class represents the data of a single Event used in the Calendar control.
Definition XTPCalendarEvent.h:77
CXTPCalendarMonthViewEvent
This class represents an event view portion of the CalendarMonthViewDay.
Definition XTPCalendarMonthViewEvent.h:56
CXTPCalendarMonthView
This class implements a specific view portion of the Calendar control - called Month view.
Definition XTPCalendarMonthView.h:74
CXTPCalendarOffice2000Theme
CXTPCalendarOffice2000Theme is a CXTPCalendarPaintManager derived class that represents the Office 20...
Definition XTPCalendarOffice2000Theme.h:37
CXTPCalendarOffice2013Theme
CXTPCalendarOffice2013Theme is a CXTPCalendarOffice2000Theme derived class that represents the Office...
Definition XTPCalendarOffice2013Theme.h:37
CXTPCalendarOffice2013Theme::CXTPCalendarOffice2013Theme
CXTPCalendarOffice2013Theme()
Default paint manager constructor.
CXTPCalendarOffice2013Theme::UpdateGlyphs
virtual void UpdateGlyphs()
Initializes Calendar images.
CXTPCalendarOffice2013Theme::UpdateEventCategoriesDefaultColors
virtual void UpdateEventCategoriesDefaultColors()
This member function is called to update event category default colors.
CXTPCalendarOffice2013Theme::DrawHeader
virtual void DrawHeader(CDC *pDC, CRect &rcHeader, BOOL bIsSelected, BOOL bIsCurrent, const CXTPPaintManagerColorGradient &grclr, COLORREF clrUnderLineHdr)
This member function is used to draw the Header.
CXTPCalendarOffice2013Theme::UpdateEventLabelsDefaultColors
virtual void UpdateEventLabelsDefaultColors()
This member function is called to update event label default colors.
CXTPCalendarOffice2013Theme::~CXTPCalendarOffice2013Theme
virtual ~CXTPCalendarOffice2013Theme()
Default paint manager destructor.
CXTPCalendarOffice2013Theme::GetEventEdgeColor
virtual COLORREF GetEventEdgeColor(CXTPCalendarEvent *pEvent)
Call this member function to get the edge color for the specified event.
CXTPCalendarOffice2013Theme::GetEventBackColor
virtual COLORREF GetEventBackColor(CXTPCalendarEvent *pEvent)
Call this member function to get the background color for the specified event.
CXTPCalendarOffice2013Theme::RefreshMetrics
virtual void RefreshMetrics()
This member function is used to initialize all drawing defaults.
CXTPCalendarPaintManager::GetEventBackColor
virtual COLORREF GetEventBackColor(CXTPCalendarEvent *pEvent, COLORREF crDefault)
Call this member function to get the background color for the specified event.
CXTPCalendarPaintManager::m_clrMultiDayEventFrameColor
COLORREF m_clrMultiDayEventFrameColor
Multi-day event frame color.
Definition XTPCalendarPaintManager.h:595
CXTPCalendarPaintManager::DrawHeader
virtual void DrawHeader(CDC *pDC, CRect &rcHeader, BOOL bIsSelected, BOOL bIsCurrent)
This member function is used to draw the Header.
CXTPCalendarViewEvent
This class represents an event view portion of the CalendarViewGroup.
Definition XTPCalendarViewEvent.h:106
CXTPCalendarViewEventSubjectEditor
This class is used to edit an event subject.
Definition XTPCalendarViewEvent.h:1157
CXTPCalendarViewPart
Helper base class to implement parts for calendar paint manager.
Definition XTPCalendarViewPart.h:1228
CXTPCalendarWeekViewEvent
This class represents an event view portion of the CalendarWeekViewDay.
Definition XTPCalendarWeekViewEvent.h:58
CXTPCalendarWeekView
This class implements a specific view portion of the Calendar control - called Week view.
Definition XTPCalendarWeekView.h:54
CXTPFont
Provides a convenient object oriented interface for HFONT GDI object and uses GDI handle caching.
Definition XTPGdiObjects.h:414
CXTPPaintManagerColorGradient
The CXTPPaintManagerColorGradient class is used to manage COLORREF values for determining light and d...
Definition XTPColorManager.h:301
CXTPPaintManagerColor
The CXTPPaintManagerColor class is used to manage COLORREF values for determining default and applica...
Definition XTPColorManager.h:117
XTP_CALENDAR_DAYVIEWCELL_PARAMS
Set of parameters transferred from calendar items for an XTP_NC_CALENDAR_BEFORE_DRAW_DAYVIEWCELL noti...
Definition XTPCalendarNotifications.h:638


Toolkit Pro: Member List

CXTPSyntaxEditLexParser Member List

This is the complete list of members for CXTPSyntaxEditLexParser, including all inherited members.

Close() | CXTPSyntaxEditLexParser | virtual
CloseParseThread() | CXTPSyntaxEditLexParser | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPSyntaxEditLexParser() | CXTPSyntaxEditLexParser |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetConnection() | CXTPSyntaxEditLexParser | virtual
GetParseThreadPriority() | CXTPSyntaxEditLexParser | virtual
GetSchemaOptions(const CString &strExt) | CXTPSyntaxEditLexParser | virtual
GetTextSchema() | CXTPSyntaxEditLexParser | virtual
GetTokensForAutoCompleate(CXTPSyntaxEditLexTokensDefArray &rArTokens, BOOL bAppend) | CXTPSyntaxEditLexParser | virtual
OnBeforeEditChanged() | CXTPSyntaxEditLexParser | virtual
OnEditChanged(const XTP_EDIT_LINECOL &posFrom, const XTP_EDIT_LINECOL &posTo, int eEditAction, CXTPSyntaxEditBufferManager *pBuffer) | CXTPSyntaxEditLexParser | virtual
SetParseThreadPriority(int nPriority) | CXTPSyntaxEditLexParser | virtual
SetTextSchema(CXTPSyntaxEditLexTextSchema *pTextSchema) | CXTPSyntaxEditLexParser | virtual
StartParseInThread(CXTPSyntaxEditBufferManager *pBuffer, const XTP_EDIT_LINECOL *pLCStart=NULL, const XTP_EDIT_LINECOL *pLCEnd=NULL, int eEditAction=0, BOOL bRunWithoutWait=FALSE) | CXTPSyntaxEditLexParser | virtual
StopParseInThread() | CXTPSyntaxEditLexParser | virtual
~CXTPSyntaxEditLexParser() | CXTPSyntaxEditLexParser | virtual


Toolkit Pro: Member List

CXTPTrackControl Member List

This is the complete list of members for CXTPTrackControl, including all inherited members.

AddColumn(CXTPGridColumn *pColumn) | CXTPGridControl |
AddRecord(CXTPGridRecord *pRecord) | CXTPGridControl | virtual
AddRecordEx(CXTPGridRecord *pRecord, CXTPGridRecord *pParentRecord=NULL, int nRowChildIndex=-1, int nRecordChildIndex=-1) | CXTPGridControl | virtual
AdjustIndentation() | CXTPGridControl | protected
AdjustLayout() | CXTPTrackControl | virtual
AdjustScrollBars() | CXTPGridControl | virtual
AdjustTrackColumnWidth() | CXTPTrackControl |
ApplyFilter(CXTPGridRecord *pRecord, CString strFilterText, BOOL bIncludePreview) | CXTPGridControl | protectedvirtual
AssignIconViewPropNumAndIconNum(int nCol=0, int nIcon=0, BOOL bUseColumnForNum=FALSE, int nWidth=20) | CXTPGridControl |
BeginUpdate() | CXTPGridControl |
CanCopy() | CXTPGridControl | virtual
CanCut() | CXTPGridControl | virtual
CanPaste() | CXTPGridControl | virtual
CollapseAll() | CXTPGridControl |
Copy() | CXTPGridControl | virtual
Create(DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID, CCreateContext *pContext=NULL) | CXTPGridControl |
CreateGroupRow() | CXTPGridControl | protectedvirtual
CreateHeaderFooterRow() | CXTPGridControl | protectedvirtual
CreateIconColumn(BOOL bUseColumnForNum=FALSE, int nWidth=40) | CXTPGridControl |
CreateRow() | CXTPGridControl | protectedvirtual
Cut() | CXTPGridControl | virtual
CXTPGridControl() | CXTPGridControl |
CXTPTrackControl() | CXTPTrackControl |
DoAutoVertScrollIfNeed(CPoint ptClick, CPoint pt) | CXTPGridControl | protectedvirtual
DoPropExchange(CXTPPropExchange *pPX) | CXTPTrackControl | virtual
DrawNoItems(CDC *pDC, const CRect &rcClient) | CXTPGridControl | protectedvirtual
DrawRows(CDC *pDC, CRect &rcClient, int y, CXTPGridRows *pRows, int nTopRow, int nColumnFrom, int nColumnTo, int *pnHeight) | CXTPTrackControl | virtual
DrawWatermark(CDC *pDC, CRect rcWatermark, CRect rcClient) | CXTPGridControl |
EditItem(XTP_GRIDRECORDITEM_ARGS *pItemArgs) | CXTPGridControl |
EditOnClick(BOOL bEditOnClick) | CXTPGridControl |
EditOnDelayClick(BOOL bEditOnDelayClick) | CXTPGridControl |
EditOnDoubleClick(BOOL bEditOnClick) | CXTPGridControl |
EnableDoubleBuffering(BOOL bEnable) | CXTPGridControl |
EnableDragDrop(LPCTSTR lpszClipboardFormat, DWORD dwFlags, DWORD dwDropMarkerFlags=xtpGridDropBetween) | CXTPGridControl |
EnableMarkup(BOOL bEnable=TRUE) | CXTPGridControl |
EnablePreviewMode(BOOL bIsPreviewMode) | CXTPGridControl |
EnableToolTips(BOOL bEnable) | CXTPGridControl |
EndUpdate() | CXTPGridControl |
EnsureFocusedRowVisible(BOOL bEnsureFocusedRowVisible) | CXTPGridControl |
EnsureStartAutoVertScroll() | CXTPGridControl | protectedvirtual
EnsureStopAutoVertScroll() | CXTPGridControl | protectedvirtual
EnsureStopDelayEditTimer() | CXTPGridControl |
EnsureStopLastRqstTimer() | CXTPGridControl |
EnsureVisible(CXTPTrackBlock *pBlock) | CXTPTrackControl |
CXTPGridControl::EnsureVisible(CXTPGridRow *pRow) | CXTPGridControl |
CXTPGridControl::EnsureVisible(CXTPGridColumn *pCheckColumn) | CXTPGridControl |
ExpandAll(BOOL bRecursive=FALSE) | CXTPGridControl |
FocusSubItems(BOOL bFocusSubItems) | CXTPGridControl |
FreeRowBatchExtraData() | CXTPGridControl | static
GetActiveItem() const | CXTPGridControl |
GetAutoVScrollTimerResolution() const | CXTPGridControl |
GetColumns() const | CXTPGridControl |
GetDataManager() | CXTPGridControl |
GetDelayEditTimer() const | CXTPGridControl |
GetDisableReorderColumnsCount() const | CXTPGridControl |
GetDragSensitivityX() const | CXTPGridControl |
GetDragSensitivityY() const | CXTPGridControl |
GetDropMarkerFlags() const | CXTPGridControl |
GetElementRect(XTPGridElementRect nElement) const | CXTPGridControl |
GetFilterText() | CXTPGridControl | virtual
GetFocusedColumn() const | CXTPGridControl |
GetFocusedRecordItem() const | CXTPGridControl |
GetFocusedRow() const | CXTPGridControl |
GetFreezeColumnsCount() const | CXTPGridControl |
GetFreezeColumnsCount(int &nLastIndex) const | CXTPGridControl |
GetFreezeColumnsIndex() const | CXTPGridControl |
GetGridAreaRows(int nStartRow, BOOL bMoveDown) | CXTPGridControl |
GetGridHeader() const | CXTPGridControl |
GetGridStyle(XTPGridOrientation orientation) const | CXTPGridControl |
GetHeaderIndent() const | CXTPGridControl |
GetHScrollStep() const | CXTPGridControl |
GetImageManager() const | CXTPGridControl |
GetIndent(int nLevel) const | CXTPGridControl |
GetInplaceButtons() const | CXTPGridControl |
GetInplaceEdit() const | CXTPGridControl |
GetInplaceList() const | CXTPGridControl |
GetItemMetrics(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pItemMetrics) | CXTPGridControl | protectedvirtual
GetLastRqstEditCol() const | CXTPGridControl |
GetLastRqstEditRow() const | CXTPGridControl |
GetLeftOffset() const | CXTPGridControl |
GetLockUpdateCount() const | CXTPGridControl |
GetMarkers() const | CXTPTrackControl |
GetMarkupContext() const | CXTPGridControl |
GetMouseCursorMode() const | CXTPTrackControl |
GetMouseMode() const | CXTPGridControl |
GetMouseScrollLines() | CXTPGridControl | protectedstatic
GetNavigator() const | CXTPGridControl |
GetNextFocusableColumn(CXTPGridRow *pRow, int nColumnIndex, int nDirection) | CXTPGridControl | virtual
GetNumRowsOnLine(int iTotalWidth) const | CXTPGridControl |
GetPaintManager() const | CXTPGridControl |
GetRecordsTreeFilterMode() const | CXTPGridControl |
GetRowsHeight(CXTPGridRows *pRows, int nTotalWidth, int nMaxHeight=-1) | CXTPGridControl | protectedvirtual
GetRowsPerLine() const | CXTPGridControl |
GetScrollMode(XTPGridOrientation orientation) const | CXTPGridControl |
GetSections() const | CXTPGridControl |
GetSelectedBlocks() const | CXTPTrackControl |
GetSelectedRows() const | CXTPGridControl |
GetSnapMargin() const | CXTPTrackControl |
GetTimelineArea() const | CXTPTrackControl |
GetTimeLineMax() const | CXTPTrackControl |
GetTimeLineMin() const | CXTPTrackControl |
GetTimeLinePosition() const | CXTPTrackControl |
GetToolTipContext() const | CXTPGridControl |
GetTopRowIndex() const | CXTPGridControl |
GetTrackColumn() const | CXTPTrackControl |
GetTrackColumnIndex() const | CXTPTrackControl |
GetTrackOffset() const | CXTPTrackControl |
GetTrackPaintManager() const | CXTPTrackControl |
GetUndoManager() const | CXTPTrackControl |
GetViewPortMax() const | CXTPTrackControl |
GetViewPortMin() const | CXTPTrackControl |
GetWatermarkAlignment() const | CXTPGridControl |
GetWatermarkBitmap() const | CXTPGridControl | virtual
GetWorkAreaMax() const | CXTPTrackControl |
GetWorkAreaMin() const | CXTPTrackControl |
HasFocus() const | CXTPGridControl |
HitTest(CPoint pt, CXTPGridHitTestInfo *pInfo) const | CXTPTrackControl | virtual
CXTPGridControl::HitTest(CPoint pt) const | CXTPGridControl |
InitialSelectionEnable(BOOL bEnable) | CXTPGridControl |
InsertRow(int nIndex, CXTPGridRow *pRow) | CXTPGridControl | protectedvirtual
IsAutoCheckItems() const | CXTPGridControl |
IsCellMergingAllowed() const | CXTPGridControl | virtual
IsChanged() const | CXTPGridControl | protected
IsDoubleBuffering() const | CXTPGridControl |
IsDragMode() const | CXTPGridControl |
IsEditMode() | CXTPGridControl | virtual
IsEditOnClick() const | CXTPGridControl |
IsEditOnDelayClick() const | CXTPGridControl |
IsEditOnDoubleClick() const | CXTPGridControl |
IsEnsureFocusedRowVisible() const | CXTPGridControl |
IsFilterHiddenColumns() const | CXTPGridControl | virtual
IsFocusSubItems() const | CXTPGridControl |
IsFooterRowsPinned() const | CXTPGridControl |
IsFooterRowsPinnedPrinted() const | CXTPGridControl |
IsFooterVisible() const | CXTPGridControl |
IsFullColumnScrolling() const | CXTPGridControl |
IsGroupByVisible() const | CXTPGridControl |
IsGroupRowsBold() const | CXTPGridControl |
IsHeaderVisible() const | CXTPGridControl |
IsIconView() const | CXTPGridControl |
IsInitialSelectionEnabled() const | CXTPGridControl |
IsLayoutRTL() | CXTPGridControl |
IsLockExpand() const | CXTPGridControl |
IsMultipleSelection() const | CXTPGridControl |
IsMultiSelectionMode() const | CXTPGridControl |
IsPreviewAllowEdit() const | CXTPGridControl |
IsPreviewMode() const | CXTPGridControl |
IsRowFocusVisible() const | CXTPGridControl |
IsShadeGroupHeadingsEnabled() const | CXTPGridControl |
IsShowIconWhenEditing() | CXTPGridControl |
IsShowRowNumber() | CXTPGridControl |
IsSkipGroupsFocusEnabled() const | CXTPGridControl |
IsSortRecordChilds() const | CXTPGridControl |
IsVirtualMode() const | CXTPGridControl |
LockExpand(BOOL bLockExpand) | CXTPGridControl |
m_arrDragBlocks | CXTPTrackControl | protected
m_bAdjustLayoutRunning | CXTPGridControl | protected
m_bAllowBlockMove | CXTPTrackControl |
m_bAllowBlockRemove | CXTPTrackControl |
m_bAllowBlockScale | CXTPTrackControl |
m_bAutoCheckItems | CXTPGridControl | protected
m_bBlockSelection | CXTPGridControl | protected
m_bChanged | CXTPGridControl | protected
m_bCreated | CXTPGridControl | protected
m_bDesktopTrackerMode | CXTPGridControl |
m_bDoubleBuffering | CXTPGridControl | protected
m_bDragMode | CXTPGridControl | protected
m_bEditOnClick | CXTPGridControl | protected
m_bEditOnDelayClick | CXTPGridControl | protected
m_bEditOnDoubleClick | CXTPGridControl | protected
m_bEnsureFocusedRowVisible | CXTPGridControl | protected
m_bFastDeselectMode | CXTPGridControl | protected
m_bFilterHiddenColumns | CXTPGridControl | protected
m_bFlexibleDrag | CXTPTrackControl |
m_bFocusSubItems | CXTPGridControl | protected
m_bFooterVisible | CXTPGridControl | protected
m_bForcePagination | CXTPGridControl |
m_bFreeHeightMode | CXTPGridControl |
m_bGroupByEnabled | CXTPGridControl | protected
m_bHeaderVisible | CXTPGridControl | protected
m_bHScrollBarVisible | CXTPGridControl | protected
m_bIconColumnIndexNotValid | CXTPGridControl |
m_bIconView | CXTPGridControl | protected
m_bInitialSelectionEnable | CXTPGridControl | protected
m_bInternalDrag | CXTPGridControl | protected
m_bInternalMove | CXTPGridControl | protected
m_bKeepSelectionAfterSort | CXTPGridControl |
m_bLockExpand | CXTPGridControl | protected
m_bMarkupEnabled | CXTPGridControl |
m_bMovePivot | CXTPGridControl |
m_bmpCache | CXTPGridControl | protected
m_bMultiSelectionMode | CXTPGridControl | protected
m_bmWatermark | CXTPGridControl | protected
m_bNoNeedSortedDragDrop | CXTPGridControl | protected
m_bPinFooterRows | CXTPGridControl | protected
m_bPinFooterRowsPrinted | CXTPGridControl | protected
m_bPrepareDrag | CXTPGridControl | protected
m_bPrevFocusSubItems | CXTPGridControl | protected
m_bPrevFooterRows | CXTPGridControl | protected
m_bPrevFooterShow | CXTPGridControl | protected
m_bPrevHeaderAutoSize | CXTPGridControl | protected
m_bPrevHeaderRows | CXTPGridControl | protected
m_bPrevHeaderShow | CXTPGridControl | protected
m_bPreviewAllowEdit | CXTPGridControl | protected
m_bPrevPreviewMode | CXTPGridControl | protected
m_bRClickDrag | CXTPGridControl |
m_bRelayWndMsg | CXTPGridControl | protected
m_bRowFocusVisible | CXTPGridControl | protected
m_bScaleOnResize | CXTPTrackControl |
m_bSelectionExcludeGroupRows | CXTPGridControl |
m_bShowIconWhenEditing | CXTPGridControl | protected
m_bShowTooltips | CXTPGridControl | protected
m_bShowWorkArea | CXTPTrackControl |
m_bSkipGroupsFocus | CXTPGridControl | protected
m_bSnapToBlocks | CXTPTrackControl |
m_bSnapToMarkers | CXTPTrackControl |
m_bSortedDragDrop | CXTPGridControl |
m_bSortRecordChilds | CXTPGridControl | protected
m_bStrictBestFit | CXTPGridControl |
m_bStrictFiltering | CXTPGridControl |
m_bThemeMetrics | CXTPGridControl |
m_bTrapTabKey | CXTPGridControl |
m_bUnrestrictedDragDrop | CXTPGridControl |
m_bVScrollBarVisible | CXTPGridControl | protected
m_bWasShiftKey | CXTPGridControl |
m_cfGrid | CXTPGridControl | protected
m_dwDragDropFlags | CXTPGridControl | protected
m_dwDropMarkerFlags | CXTPGridControl | protected
m_hbmpWatermark | CXTPGridControl | protected
m_hMoveCursor | CXTPTrackControl |
m_hResizeCursor | CXTPTrackControl |
m_iColumnForNum | CXTPGridControl |
m_iIconHeight | CXTPGridControl |
m_iIconHeightSpacing | CXTPGridControl |
m_iIconNum | CXTPGridControl |
m_iIconPropNum | CXTPGridControl |
m_iIconViewColumn | CXTPGridControl |
m_iIconViewRowsPerLine | CXTPGridControl | protected
m_iIconWidth | CXTPGridControl |
m_iIconWidthSpacing | CXTPGridControl |
m_iLastRqstEditCol | CXTPGridControl | protected
m_iLastRqstEditRow | CXTPGridControl | protected
m_mouseCursorMode | CXTPTrackControl | protected
m_mouseDownState | CXTPGridControl |
m_mouseMode | CXTPGridControl | protected
m_nAutoVScrollTimerResolution | CXTPGridControl | protected
m_nDefaultRowFreeHeight | CXTPGridControl |
m_nDisableReorderColumnsCount | CXTPGridControl | protected
m_nDragSensitivityX | CXTPGridControl | protected
m_nDragSensitivityY | CXTPGridControl | protected
m_nDropPos | CXTPGridControl | protected
m_nEnsureVisibleColumnIdx | CXTPGridControl | protected
m_nEnsureVisibleRowIdx | CXTPGridControl | protected
m_nLockUpdateCount | CXTPGridControl | protected
m_nOldTrackViewPortRange | CXTPTrackControl | protected
m_nOldTrackWidth | CXTPTrackControl | protected
m_nPrevTreeIndent | CXTPGridControl | protected
m_nRecordsTreeFilterMode | CXTPGridControl | protected
m_nRowsPerWheel | CXTPGridControl | protected
m_nScrollOffsetH | CXTPGridControl | protected
m_nScrollStepH | CXTPGridControl | protected
m_nScrollStepV | CXTPGridControl | protected
m_nSnapMargin | CXTPTrackControl |
m_nTimeLineMax | CXTPTrackControl | protected
m_nTimeLineMin | CXTPTrackControl | protected
m_nTimeLinePosition | CXTPTrackControl | protected
m_nTrackColumnIndex | CXTPTrackControl | protected
m_nViewPortMax | CXTPTrackControl | protected
m_nViewPortMin | CXTPTrackControl | protected
m_nWorkAreaMax | CXTPTrackControl | protected
m_nWorkAreaMin | CXTPTrackControl | protected
m_pActiveItem | CXTPGridControl | protected
m_pColumns | CXTPGridControl | protected
m_pDataManager | CXTPGridControl | protected
m_pDropRecords | CXTPGridControl | protected
m_pDropTarget | CXTPGridControl | protected
m_pFocusedColumn | CXTPGridControl | protected
m_pGridHeader | CXTPGridControl | protected
m_pHotExpandButtonRow | CXTPGridControl |
m_pHotHyperlink | CXTPGridControl |
m_pHotRow | CXTPGridControl | protected
m_pImageManager | CXTPGridControl | protected
m_pInplaceButtons | CXTPGridControl | protected
m_pInplaceEdit | CXTPGridControl | protected
m_pInplaceList | CXTPGridControl | protected
m_pMarkers | CXTPTrackControl | protected
m_pMarkupContext | CXTPGridControl | protected
m_pNavigator | CXTPGridControl | protected
m_pPaintManager | CXTPGridControl | protected
m_pPrevGroupsOrder | CXTPGridControl | protected
m_pPrevVisible | CXTPGridControl | protected
m_pRows | CXTPGridControl | protected
m_pRowsCompareFunc | CXTPGridControl | protected
m_pSelectedBlocks | CXTPTrackControl | protected
m_pSelectedRows | CXTPGridControl | protected
m_pSelectedRowsBeforeDrag | CXTPGridControl | protected
m_ptDrag | CXTPGridControl | protected
m_pTip | CXTPGridControl | protected
m_pToolTipContext | CXTPGridControl | protected
m_ptrVirtualEditingRow | CXTPGridControl | protected
m_ptStartDrag | CXTPTrackControl |
m_pUndoManager | CXTPTrackControl | protected
m_rcFooterArea | CXTPGridControl | protected
m_rcGroupByArea | CXTPGridControl | protected
m_rcHeaderArea | CXTPGridControl | protected
m_rcSelectedArea | CXTPTrackControl | protected
m_rcTimelineArea | CXTPTrackControl | protected
m_scrollModeH | CXTPGridControl | protected
m_scrollModeV | CXTPGridControl | protected
m_scrollUpdateMode | CXTPGridControl | protected
m_sCustomTitle | CXTPGridControl |
m_strFilterText | CXTPGridControl | protected
m_strTimeFormat | CXTPTrackControl |
m_themeCurrent | CXTPGridControl | protected
m_uAutoScrollTimerID | CXTPGridControl | protected
m_uiDelayEditMaxTime | CXTPGridControl | protected
m_uiDelayEditTimer | CXTPGridControl | protected
m_uRqstEditTimer | CXTPGridControl | protected
m_WatermarkAlignment | CXTPGridControl | protected
m_WatermarkTransparency | CXTPGridControl | protected
OnBeforeCopyToText(CXTPGridRecord *pRecord, CStringArray &rarStrings) | CXTPGridControl | protectedvirtual
OnBeforePaste(CXTPGridRecord **ppRecord) | CXTPGridControl | protectedvirtual
OnBeforePasteFromText(CStringArray &arStrings, CXTPGridRecord **ppRecord) | CXTPGridControl | protectedvirtual
OnBeginDrag(CPoint point) | CXTPGridControl | protectedvirtual
OnBeginDrag(CPoint point, UINT nFlags) | CXTPGridControl | protectedvirtual
OnConstraintSelecting(CXTPGridRow *pRow, CXTPGridRecordItem *pItem, CXTPGridColumn *pColumn, CXTPGridRecordItemConstraint *pConstraint) | CXTPGridControl | protectedvirtual
OnDragOver(COleDataObject *pDataObject, DWORD dwKeyState, CPoint point, int nState) | CXTPGridControl | protectedvirtual
OnDraw(CDC *pDC) | CXTPGridControl | protectedvirtual
OnDrop(COleDataObject *pDataObject, DROPEFFECT dropEffect, CPoint point) | CXTPGridControl | protectedvirtual
OnFocusChanging(CXTPGridRow *pNewRow, CXTPGridColumn *pNewCol) | CXTPGridControl | protectedvirtual
OnGetColumnDataBestFitWidth(CXTPGridColumn *pColumn) | CXTPGridControl | protectedvirtual
OnGetItemsCaptionMaxWidth(CDC *pDC, CXTPGridRows *pRows, CXTPGridColumn *pColumn, int nStartRow=0, int nRowsCount=-1) | CXTPGridControl | protectedvirtual
OnGetToolTipInfo(CXTPGridRow *pRow, CXTPGridRecordItem *pItem, CString &rstrToolTipText) | CXTPGridControl | protectedvirtual
OnPreviewKeyDown(UINT &rnChar, UINT nRepCnt, UINT nFlags) | CXTPGridControl | protectedvirtual
OnSelectionChanged() | CXTPGridControl | protectedvirtual
Paste() | CXTPGridControl | virtual
PinFooterRows(BOOL bPin=FALSE) | CXTPGridControl |
PinFooterRowsPrinted(BOOL bPin=FALSE) | CXTPGridControl |
Populate() | CXTPTrackControl | virtual
PopulateFooterRows() | CXTPGridControl | virtual
PopulateHeaderRows() | CXTPGridControl | virtual
PositionToTrack(int nPosition) | CXTPTrackControl |
PreviewAllowEdit(BOOL bAllowEdit) | CXTPGridControl |
Recalc(BOOL bAll=FALSE) | CXTPGridControl |
RedrawControl() | CXTPGridControl |
RegisterWindowClass(HINSTANCE hInstance=NULL) | CXTPTrackControl |
RelayToolTipEvent(UINT message) | CXTPGridControl | protectedvirtual
ReleaseItem(int nIndex) | CXTPGridControl |
ReleaseSorted() | CXTPGridControl |
RemoveRecordEx(CXTPGridRecord *pRecord, BOOL bAdjustLayout=TRUE, BOOL bRemoveFromParent=TRUE) | CXTPGridControl | virtual
RemoveRowEx(CXTPGridRow *pRow, BOOL bAdjustLayout=TRUE) | CXTPGridControl | virtual
ResetContent(BOOL bUpdateControl=TRUE) | CXTPGridControl |
ReSortRows() | CXTPGridControl | protectedvirtual
SendMessageToParent(UINT nMessage, CXTPTrackBlock *pBlock=NULL, CXTPTrackMarker *pMarker=NULL) const | CXTPTrackControl |
CXTPGridControl::SendMessageToParent(CXTPGridRow *pRow, CXTPGridRecordItem *pItem, CXTPGridColumn *pColumn, UINT nMessage, CPoint *pPoint, int nHyperlink=-1) const | CXTPGridControl |
SendNotifyMessage(UINT nMessage, NMHDR *pNMHDR=NULL) const | CXTPGridControl |
SerializeState(CArchive &ar) | CXTPGridControl | virtual
SetAutoCheckItems(BOOL bAutoCheck) | CXTPGridControl |
SetAutoVScrollTimerResolution(UINT nNewTimerResolution) | CXTPGridControl |
SetCellFormula(int row, int col, CString sFormula) | CXTPGridControl |
SetCellText(int row, int col, CString sText) | CXTPGridControl |
SetChanged(BOOL bChanged=TRUE) | CXTPGridControl | protected
SetDisableReorderColumnsCount(int nCount) | CXTPGridControl |
SetDragSensitivityX(int nDragSensitivityX) | CXTPGridControl |
SetDragSensitivityY(int nDragSensitivityY) | CXTPGridControl |
SetDropMarkerFlags(DWORD dwDropMarkerFlags) | CXTPGridControl |
SetFastDeselectMode(BOOL bFastDeselect=TRUE) | CXTPGridControl |
SetFilterHiddenColumns(BOOL bFilterHidden) | CXTPGridControl | virtual
SetFilterText(LPCTSTR strFilterText) | CXTPGridControl | virtual
SetFocusedColumn(CXTPGridColumn *pColumn) | CXTPGridControl |
SetFocusedRow(CXTPGridRow *pRow, BOOL bControlKey=FALSE) | CXTPGridControl |
SetFocusedRow(CXTPGridRow *pRow, BOOL bShiftKey, BOOL bControlKey) | CXTPGridControl |
SetFocusedRow(BOOL bEnsureVisible, CXTPGridRow *pRow, BOOL bShiftKey, BOOL bControlKey) | CXTPGridControl |
SetFreezeColumnsCount(int nCount, BOOL bReserved=FALSE) | CXTPGridControl |
SetFullColumnScrolling(BOOL bSet) | CXTPGridControl |
SetGridColor(COLORREF clrGridLine) | CXTPGridControl |
SetGridHeader(CXTPGridHeader *pGridHeader) | CXTPGridControl |
SetGridStyle(XTPGridOrientation orientation, XTPGridGridStyle gridStyle) | CXTPGridControl |
SetGroupRowsBold(BOOL bBold=TRUE) | CXTPGridControl |
SetHScrollStep(int nStep) | CXTPGridControl |
SetIconColumn(CXTPGridColumn *pColumn) | CXTPGridControl |
SetIconView(BOOL bIconView=TRUE) | CXTPGridControl |
SetIconViewToDefaults() | CXTPGridControl |
SetImageList(CImageList *pImageList) | CXTPGridControl |
SetImageManager(CXTPImageManager *pImageManager) | CXTPGridControl |
SetLastRqstEdit(int iRqstEditRow, int iRqstEditCol) | CXTPGridControl |
SetLayoutRTL(BOOL bRightToLeft) | CXTPGridControl |
SetMouseCursorMode(XTPTrackMouseCursorMode enMode) | CXTPTrackControl |
SetMouseMode(XTPGridMouseMode nMode) | CXTPGridControl |
SetMultipleSelection(BOOL bMultipleSelection) | CXTPGridControl |
SetMultiSelectionMode(BOOL bMultiSelectionMode) | CXTPGridControl |
SetNavigator(CXTPGridNavigator *pNavigator) | CXTPGridControl |
CXTPGridControl::SetPaintManager(CXTPGridPaintManager *pPaintManager) | CXTPGridControl |
SetRecordsTreeFilterMode(int nMode) | CXTPGridControl |
SetRowsCompareFunc(XTPGridRowsCompareFunc pCompareFunc) | CXTPGridControl | virtual
SetScrollMode(XTPGridOrientation orientation, XTPGridScrollMode scrollMode) | CXTPGridControl |
SetScrollOffsetH(int nOffset) | CXTPGridControl |
SetScrollOffsetV(int nOffset) | CXTPGridControl |
SetSelectionState(int index, int state) | CXTPGridControl |
SetSortRecordChilds(BOOL bSortRecordChildren) | CXTPGridControl |
SetTimeLinePosition(int nTimeLinePos) | CXTPTrackControl |
SetTimeLineRange(int nTimeScaleMin, int nTimeScaleMax) | CXTPTrackControl |
SetTopRow(int nIndex) | CXTPGridControl |
SetTreeIndent(int nIndent) | CXTPGridControl |
SetViewPort(int nViewPortMin, int nViewPortMax) | CXTPTrackControl |
SetVirtualMode(CXTPGridRecord *pVirtualRecord, int nCount, int nFields=0) | CXTPGridControl |
SetWatermarkAlignment(int nWatermarkAlignment) | CXTPGridControl |
SetWatermarkBitmap(HBITMAP hBitmap, BYTE Transparency) | CXTPGridControl | virtual
SetWatermarkBitmap(LPCTSTR szPath, BYTE Transparency) | CXTPGridControl | virtual
SetWorkArea(int nWorkAreaMin, int nWorkAreaMax) | CXTPTrackControl |
ShadeGroupHeadings(BOOL bEnable=TRUE) | CXTPGridControl |
ShowFooter(BOOL bShow=TRUE) | CXTPGridControl |
ShowGroupBy(BOOL bEnable=TRUE) | CXTPGridControl |
ShowHeader(BOOL bShow=TRUE) | CXTPGridControl |
ShowIconWhenEditing(BOOL bShow) | CXTPGridControl |
ShowRowFocus(BOOL bShow) | CXTPGridControl |
ShowRowNumber(BOOL bSet) | CXTPGridControl |
SkipGroupsFocus(BOOL bSkipFocus) | CXTPGridControl |
SnapPosition(int nPosition) | CXTPTrackControl |
StartDelayEditTimer() | CXTPGridControl |
StartDragBlocks(BOOL bResize) | CXTPTrackControl |
StartDragSelection() | CXTPTrackControl |
StartLastRqstTimer() | CXTPGridControl |
TrackToPosition(int nTrack) const | CXTPTrackControl |
UnselectGroupRows() | CXTPGridControl |
UpdateRecord(CXTPGridRecord *pRecord, BOOL bUpdateChildren) | CXTPGridControl | virtual
UpdateSubList() | CXTPGridControl | protected
UseGridCustomHeap() | CXTPGridControl | static
UseRowBatchAllocation() | CXTPGridControl | static
~CXTPGridControl() | CXTPGridControl | virtual
~CXTPTrackControl() | CXTPTrackControl |


Toolkit Pro: XTPTrackThemeOffice2013.h Source File

  • Source
  • GridControl
  • TrackControl
  • Themes
XTPTrackThemeOffice2013.h
Go to the documentation of this file.
1
23#if !defined(__XTPTRACKTHEMEOffice2013_H__)
24# define __XTPTRACKTHEMEOffice2013_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPTrackThemeOffice2013 : public CXTPTrackPaintManager
39{
40public:
45 CXTPTrackThemeOffice2013();
46
51 virtual void LoadGlyphs();
52
58 virtual void RefreshMetrics();
59
70 virtual void DrawColumnText(CDC* pDC, CRect rcText, CString strCaption, int nHeaderAlignment,
71 BOOL bIsHeader, BOOL bColumnPressed);
72
84 virtual void DrawColumnBackground(CDC* pDC, CXTPGridColumn* pColumn, CRect rcColumn,
85 BOOL& bColumnPressed, BOOL& bDraggingFromHeader,
86 CXTPGridHeader* pHeader = NULL);
87
88 virtual void DrawPlainColumnBackground(CDC* /*pDC*/, CRect /*rcColumn*/);
89
123 virtual void DrawTriangle(CDC* pDC, CRect rcTriangle, BOOL bToDown, BOOL bDraggingFromHeader,
124 int nShadowWidth, BOOL bColumnPressed);
125
126 virtual void DrawColumnInverted(CDC* pDC, CRect rcColumn, BOOL bColumnPressed,
127 BOOL bDraggingFromHeader, int nShadowWidth);
128
129 virtual void DrawWindowFrame(CDC* pDC, CRect rcWindow);
130
139 virtual void FillGroupRowMetrics(CXTPGridGroupRow* pRow, XTP_GRIDRECORDITEM_METRICS* pMetrics,
140 BOOL bPrinting);
141
142 virtual void DrawGroupRowBack(CDC* pDC, CRect rcRow, XTP_GRIDRECORDITEM_METRICS* pMetrics);
143
159 virtual void DrawGroupRow(CDC* pDC, CXTPGridGroupRow* pRow, CRect rcRow,
160 XTP_GRIDRECORDITEM_METRICS* pMetrics);
161
176 virtual void DrawFocusedRow(CDC* pDC, CRect rcRow);
177
190 virtual int GetRowHeight(CDC* pDC, CXTPGridRow* pRow);
191
192 using CXTPTrackPaintManager::GetRowHeight;
193
194 virtual CRect GetGroupRowBmpSize(CRect rcRow, int nBitmapOffset);
195
196 virtual CRect GetGroupRowTextSize(CRect rcBitmap, CRect rcRow, int nBitmapWidth,
197 int nNoIconWidth, int nTextOffset);
198
199 virtual int DrawTrackBlock(CDC* pDC, CRect rc, BOOL bSelected, CXTPTrackBlock* pTrackBlock);
200
201 CXTPPaintManagerColor m_clrGroupText;
202 CXTPPaintManagerColor m_clrGroupTextHilite;
203 CXTPPaintManagerColor m_clrGroupBack;
204 CXTPPaintManagerColor m_clrGroupBackHilite;
205 CXTPPaintManagerColor m_clrGlyph;
206 CXTPPaintManagerColor m_clrGlyphHighlight;
207 CXTPPaintManagerColor m_clrSelectedBorder;
208};
210# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
211#endif //#if !defined(__XTPTRACKTHEMEOffice2013_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPGridColumn
Represents a grid column item with its properties and operations.
Definition XTPGridColumn.h:107
CXTPGridGroupRow
This class represents a 'group row' of the Grid control view.
Definition XTPGridGroupRow.h:49
CXTPGridHeader
A grid header is a part of the grid window positioned above columns of text or numbers.
Definition XTPGridHeader.h:173
CXTPGridPaintManager::GetRowHeight
virtual int GetRowHeight(CDC *pDC, CXTPGridRow *pRow)
Retrieves the default row height for print mode (i.e.
CXTPGridRow
CXTPGridRow class represents a row of the Grid control window.
Definition XTPGridRow.h:71
CXTPPaintManagerColor
The CXTPPaintManagerColor class is used to manage COLORREF values for determining default and applica...
Definition XTPColorManager.h:117
CXTPTrackBlock
This class represents a track control block.
Definition XTPTrackBlock.h:42
CXTPTrackPaintManager
This class represents a track control paint manager.
Definition XTPTrackPaintManager.h:41
CXTPTrackThemeOffice2013
CXTPTrackThemeOffice2013 is a CXTPTrackPaintManager derived class that represents an Office 2013 styl...
Definition XTPTrackThemeOffice2013.h:39
CXTPTrackThemeOffice2013::DrawColumnText
virtual void DrawColumnText(CDC *pDC, CRect rcText, CString strCaption, int nHeaderAlignment, BOOL bIsHeader, BOOL bColumnPressed)
Draws text for the column header.
CXTPTrackThemeOffice2013::m_clrGlyph
CXTPPaintManagerColor m_clrGlyph
Header glyph color.
Definition XTPTrackThemeOffice2013.h:205
CXTPTrackThemeOffice2013::DrawTriangle
virtual void DrawTriangle(CDC *pDC, CRect rcTriangle, BOOL bToDown, BOOL bDraggingFromHeader, int nShadowWidth, BOOL bColumnPressed)
Draws a triangle that shows the sort order of the column.
CXTPTrackThemeOffice2013::FillGroupRowMetrics
virtual void FillGroupRowMetrics(CXTPGridGroupRow *pRow, XTP_GRIDRECORDITEM_METRICS *pMetrics, BOOL bPrinting)
Fills the font and color members of the metrics structure for a specified group row.
CXTPTrackThemeOffice2013::m_clrSelectedBorder
CXTPPaintManagerColor m_clrSelectedBorder
Selected block border.
Definition XTPTrackThemeOffice2013.h:207
CXTPTrackThemeOffice2013::DrawColumnBackground
virtual void DrawColumnBackground(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, BOOL &bColumnPressed, BOOL &bDraggingFromHeader, CXTPGridHeader *pHeader=NULL)
This method is called to draw the background of a column using the current column style.
CXTPTrackThemeOffice2013::m_clrGlyphHighlight
CXTPPaintManagerColor m_clrGlyphHighlight
Header highlighted glyph color.
Definition XTPTrackThemeOffice2013.h:206
CXTPTrackThemeOffice2013::LoadGlyphs
virtual void LoadGlyphs()
Loads the default images used by the track control.
CXTPTrackThemeOffice2013::DrawFocusedRow
virtual void DrawFocusedRow(CDC *pDC, CRect rcRow)
Draws focused rows.
CXTPTrackThemeOffice2013::GetRowHeight
virtual int GetRowHeight(CDC *pDC, CXTPGridRow *pRow)
Retrieves the default row height for print mode (i.e.
CXTPTrackThemeOffice2013::DrawGroupRow
virtual void DrawGroupRow(CDC *pDC, CXTPGridGroupRow *pRow, CRect rcRow, XTP_GRIDRECORDITEM_METRICS *pMetrics)
Draws a group row.
CXTPTrackThemeOffice2013::RefreshMetrics
virtual void RefreshMetrics()
This method is called to refresh the visual metrics of the track control.
CXTPTrackThemeOffice2013::CXTPTrackThemeOffice2013
CXTPTrackThemeOffice2013()
Default paint manager constructor, handles properties initialization.
XTP_GRIDRECORDITEM_METRICS
Record item drawing metrics.
Definition XTPGridRecordItem.h:356


Toolkit Pro: Member List

CXTPStatusBarPane Member List

This is the complete list of members for CXTPStatusBarPane, including all inherited members.

BestFit() | CXTPStatusBarPane |
CXTPCmdTarget() | CXTPCmdTarget |
CXTPStatusBarPane() | CXTPStatusBarPane |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetBackgroundColor() const | CXTPStatusBarPane |
GetBeginGroup() const | CXTPStatusBarPane |
GetBestFit() | CXTPStatusBarPane |
GetCaption() const | CXTPStatusBarPane |
GetCustomizationVisible() const | CXTPStatusBarPane |
GetIconIndex() const | CXTPStatusBarPane |
GetID() const | CXTPStatusBarPane |
GetImage() const | CXTPStatusBarPane | virtual
GetIndex() const | CXTPStatusBarPane |
GetMargins() const | CXTPStatusBarPane |
GetMarkupUIElement() const | CXTPStatusBarPane |
GetPadding() const | CXTPStatusBarPane |
GetRect() const | CXTPStatusBarPane |
GetStatusBar() const | CXTPStatusBarPane |
GetStyle() const | CXTPStatusBarPane |
GetText() const | CXTPStatusBarPane |
GetTextAlignment() const | CXTPStatusBarPane |
GetTextColor() const | CXTPStatusBarPane |
GetTextFont() | CXTPStatusBarPane | virtual
GetTextGrayColor() const | CXTPStatusBarPane |
GetTooltip() const | CXTPStatusBarPane |
GetValue() const | CXTPStatusBarPane |
GetWidth() | CXTPStatusBarPane | virtual
HasBorders() const | CXTPStatusBarPane |
IsButton() const | CXTPStatusBarPane |
IsChecked() const | CXTPStatusBarPane |
IsDark() const | CXTPStatusBarPane |
IsEnabled() const | CXTPStatusBarPane |
IsHighlighted() const | CXTPStatusBarPane |
IsPressed() const | CXTPStatusBarPane |
IsVisible() const | CXTPStatusBarPane |
m_bAutoDeleteWnd | CXTPStatusBarPane | protected
m_bBeginGroup | CXTPStatusBarPane | protected
m_bButton | CXTPStatusBarPane | protected
m_bCustomizable | CXTPStatusBarPane | protected
m_bIsDark | CXTPStatusBarPane | protected
m_bPressed | CXTPStatusBarPane | protected
m_clrBackground | CXTPStatusBarPane | protected
m_clrText | CXTPStatusBarPane | protected
m_clrTextGray | CXTPStatusBarPane | protected
m_cxText | CXTPStatusBarPane | protected
m_dwHideFlags | CXTPStatusBarPane | protected
m_hWndPane | CXTPStatusBarPane | protected
m_nAlignment | CXTPStatusBarPane | protected
m_nBestFit | CXTPStatusBarPane | protected
m_nIconIndex | CXTPStatusBarPane | protected
m_nID | CXTPStatusBarPane | protected
m_nIndex | CXTPStatusBarPane | protected
m_nStyle | CXTPStatusBarPane | protected
m_pMarkupUIElement | CXTPStatusBarPane | protected
m_pStatusBar | CXTPStatusBarPane | protected
m_rcMargins | CXTPStatusBarPane | protected
m_rcPadding | CXTPStatusBarPane | protected
m_rcPane | CXTPStatusBarPane | protected
m_strCaption | CXTPStatusBarPane | protected
m_strText | CXTPStatusBarPane | protected
m_strToolTip | CXTPStatusBarPane | protected
m_strValue | CXTPStatusBarPane | protected
m_xtpFontText | CXTPStatusBarPane | protected
OnDraw(CDC *pDC, CRect rcItem) | CXTPStatusBarPane | protectedvirtual
OnLButtonDown(CPoint point) | CXTPStatusBarPane | protectedvirtual
OnMouseMove(CPoint point) | CXTPStatusBarPane | protectedvirtual
OnToolHitTest(CPoint point, TOOLINFO *pTI) const | CXTPStatusBarPane | protectedvirtual
Redraw() const | CXTPStatusBarPane |
Remove() | CXTPStatusBarPane |
SetBackgroundColor(COLORREF clrBackground) | CXTPStatusBarPane |
SetBeginGroup(BOOL bBeginGroup=TRUE) | CXTPStatusBarPane |
SetButton(BOOL bButton=TRUE) | CXTPStatusBarPane |
SetCaption(LPCTSTR lpszCaption) | CXTPStatusBarPane |
SetChecked(BOOL bChecked) | CXTPStatusBarPane |
SetCustomizationVisible(BOOL bVisible) | CXTPStatusBarPane |
SetDark(BOOL bDark=TRUE) | CXTPStatusBarPane |
SetEnabled(BOOL bEnabled) | CXTPStatusBarPane |
SetIconIndex(int nIconIndex) | CXTPStatusBarPane |
SetMargins(int nLeft, int nTop, int nRight, int nBottom) | CXTPStatusBarPane |
SetPadding(int nLeft, int nTop, int nRight, int nBottom) | CXTPStatusBarPane |
SetStyle(UINT nStyle) | CXTPStatusBarPane |
SetText(LPCTSTR lpszText) | CXTPStatusBarPane |
SetTextAlignment(int nAlign) | CXTPStatusBarPane |
SetTextColor(COLORREF clrText) | CXTPStatusBarPane |
SetTextFont(CFont *pFntText) | CXTPStatusBarPane |
SetTextFont(PLOGFONT pLogfText) | CXTPStatusBarPane |
SetTextGrayColor(COLORREF clrText) | CXTPStatusBarPane |
SetTooltip(LPCTSTR lpszTooltip) | CXTPStatusBarPane |
SetValue(LPCTSTR lpszValue) | CXTPStatusBarPane |
SetVisible(BOOL bVisible, BOOL bRecalcLayout=TRUE) | CXTPStatusBarPane |
SetWidth(int nWidth) | CXTPStatusBarPane |
ShowBorders(BOOL bShowBorders) | CXTPStatusBarPane |
~CXTPStatusBarPane() | CXTPStatusBarPane | virtual


Toolkit Pro: Member List

CXTPTrackThemeVisualStudio2012Light Member List

This is the complete list of members for CXTPTrackThemeVisualStudio2012Light, including all inherited members.

CalcColumnHeight(CDC *pDC, CXTPGridColumn *pColumn, int nTotalWidth=0) | CXTPGridPaintManager | protectedvirtual
CalculateRowHeight(CDC *pDC, const CString &strText, int nMaxWidth, BOOL bWordBreak=TRUE) | CXTPGridPaintManager | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPGridPaintManager() | CXTPGridPaintManager |
CXTPTrackPaintManager() | CXTPTrackPaintManager |
CXTPTrackThemeOffice2013() | CXTPTrackThemeOffice2013 |
CXTPTrackThemeVisualStudio2012Light() | CXTPTrackThemeVisualStudio2012Light |
DrawBitmap(CDC *pDC, CXTPGridControl *pControl, CRect rcColumn, int iImage) | CXTPGridPaintManager | virtual
DrawCollapsedBitmap(CDC *pDC, const CXTPGridRow *pRow, CRect &rcBitmap) | CXTPGridPaintManager | virtual
DrawColumn(CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn, BOOL bDrawExternal=FALSE, int nShadowWidth=0) | CXTPGridPaintManager | virtual
DrawColumnBackground(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, BOOL &bColumnPressed, BOOL &bDraggingFromHeader, CXTPGridHeader *pHeader=NULL) | CXTPTrackThemeOffice2013 | virtual
DrawColumnFooter(CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn) | CXTPGridPaintManager | virtual
DrawColumnFooterDivider(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn) | CXTPGridPaintManager | virtual
DrawColumnIcon(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, CRect rcIcon, int iIcon) | CXTPGridPaintManager | virtual
DrawColumnText(CDC *pDC, CRect rcText, CString strCaption, int nHeaderAlignment, BOOL bIsHeader, BOOL bColumnPressed) | CXTPTrackThemeOffice2013 | virtual
DrawConnector(CDC *pDC, CPoint ptFrom, CPoint ptTo) | CXTPGridPaintManager |
DrawFocusedRow(CDC *pDC, CRect rcRow) | CXTPTrackThemeOffice2013 | virtual
DrawFreezeColsDivider(CDC *pDC, const CRect &rc, CXTPGridControl *pControl, CXTPGridRow *pRow=NULL) | CXTPGridPaintManager | virtual
DrawGlyph(CDC *pDC, CRect rcColumn, int iImage) | CXTPGridPaintManager | virtual
DrawGrid(CDC *pDC, XTPGridOrientation orientation, CRect rcGrid) | CXTPGridPaintManager | virtual
DrawGridPattern(CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush) | CXTPGridPaintManager | protectedvirtual
DrawGridPattern(CDC *pDC, CXTPBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush) | CXTPGridPaintManager | protectedvirtual
DrawGridPattern(CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr) | CXTPGridPaintManager | protectedvirtual
DrawGroupRow(CDC *pDC, CXTPGridGroupRow *pRow, CRect rcRow, XTP_GRIDRECORDITEM_METRICS *pMetrics) | CXTPTrackThemeOffice2013 | virtual
DrawHorizontalLine(CDC *pDC, int xPos, int yPos, int cx, COLORREF clr) | CXTPGridPaintManager |
DrawInplaceButton(CDC *pDC, CXTPGridInplaceButton *pButton) | CXTPGridPaintManager | virtual
DrawInplaceButtonFrame(CDC *pDC, CXTPGridInplaceButton *pButton) | CXTPGridPaintManager | protectedvirtual
DrawInplaceButtonIcon(CDC *pDC, CXTPGridInplaceButton *pButton) | CXTPGridPaintManager | protectedvirtual
DrawInplaceComboButton(CDC *pDC, CRect *pRc) | CXTPGridPaintManager | virtual
DrawInplaceExpandButton(CDC *pDC, CRect *pRc) | CXTPGridPaintManager | virtual
DrawInplaceSpinButton(CDC *pDC, CRect *pRc) | CXTPGridPaintManager | virtual
DrawItemBitmap(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CRect &rcItem, int nImage) | CXTPGridPaintManager | virtual
DrawItemCaption(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics) | CXTPGridPaintManager | virtual
DrawItemControl(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CXTPGridRecordItemControl *pControl, CRect &rcItem) | CXTPGridPaintManager | virtual
DrawLink(int *pnCurrDrawPos, XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CXTPGridHyperlink *pHyperlink, CString strText, CRect rcLink, int nFlag, BOOL bTrim=FALSE) | CXTPGridPaintManager | protectedvirtual
DrawMarkers(CDC *pDC) | CXTPTrackPaintManager | virtual
DrawMultiLineText(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, BOOL bWordBreak=TRUE) | CXTPGridPaintManager | protectedvirtual
DrawNoGroupByText(CDC *pDC, CRect rcItem) | CXTPGridPaintManager | virtual
DrawRowNumber(CDC *pDC, CRect rcNumber, CXTPGridRow *pRow) | CXTPGridPaintManager | virtual
DrawSectionDivider(CDC *pDC, const CRect &rc, XTPGridSectionDividerPosition dividerPosition, XTPGridSectionDividerStyle dividerStyle, CXTPPaintManagerColor dividerColor) | CXTPGridPaintManager |
DrawShellIcon(CDC *pDC, CRect rcColumn, int iImage) | CXTPGridPaintManager | virtual
DrawSingleLineText(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nStartPos, int nEndPos, int nActualWidth) | CXTPGridPaintManager | protectedvirtual
DrawString(int *pnCurrDrawPos, CDC *pDC, const CString &strDraw, CRect rcDraw, UINT nFormat) | CXTPGridPaintManager | protectedvirtual
DrawTextLine(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nFlag, int &nCharCounter, int &nHyperlinkCounter) | CXTPGridPaintManager | protectedvirtual
DrawTimeLine(CDC *pDC) | CXTPTrackPaintManager | virtual
DrawTrackHeader(CDC *pDC) | CXTPTrackPaintManager | virtual
DrawTreeStructure(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CRect rcItem, CSize sizeGlyph) | CXTPGridPaintManager | virtual
DrawTriangle(CDC *pDC, CRect rcTriangle, BOOL bToDown, BOOL bDraggingFromHeader, int nShadowWidth, BOOL bColumnPressed) | CXTPTrackThemeOffice2013 | virtual
DrawVerticalLine(CDC *pDC, int xPos, int yPos, int cy, COLORREF clr) | CXTPGridPaintManager |
DrawVerticalTimeLineMarker(CDC *pDC, int xPos, CXTPGridControl *pControl, COLORREF color=RGB(0, 255, 0)) | CXTPGridPaintManager | virtual
EnablePreviewMode(BOOL bIsPreviewMode) | CXTPGridPaintManager |
FillFooter(CDC *pDC, CRect rcFooter) | CXTPGridPaintManager | virtual
FillGroupByControl(CDC *pDC, CRect &rcGroupBy) | CXTPGridPaintManager | virtual
FillGroupRowMetrics(CXTPGridGroupRow *pRow, XTP_GRIDRECORDITEM_METRICS *pMetrics, BOOL bPrinting) | CXTPTrackThemeOffice2013 | virtual
FillHeaderControl(CDC *pDC, CRect rcHeader) | CXTPGridPaintManager | virtual
FillIndent(CDC *pDC, CRect rcRow) | CXTPGridPaintManager | virtual
FillItemShade(CDC *pDC, CRect rcItem) | CXTPGridPaintManager | virtual
FillRow(CDC *pDC, CXTPGridRow *pRow, CRect rcRow) | CXTPGridPaintManager | virtual
FindRowAdjacentToMerged(const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, BOOL bUpward) | CXTPGridPaintManager |
FindRowAdjacentToMergedEx(const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, int &nAdjRowIndex, BOOL bUpward) | CXTPGridPaintManager |
FormatTime(int nPosition) | CXTPTrackPaintManager | virtual
FormatTimeLineTick(int nPosition, COLORREF &clrTick, int &nTickLength) | CXTPTrackPaintManager | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetColumnOffice2007CustomThemeBaseColor() const | CXTPGridPaintManager |
GetColumnStyle() const | CXTPGridPaintManager |
GetControlBackColor(CXTPGridControl *pControl) | CXTPGridPaintManager | virtual
GetFooterHeight(CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0) | CXTPGridPaintManager | virtual
GetFreezeColsDividerStyle() const | CXTPGridPaintManager |
GetGlyphs() const | CXTPGridPaintManager |
GetHeaderHeight() | CXTPGridPaintManager | virtual
GetHeaderHeight(CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0) | CXTPGridPaintManager | virtual
GetItemHeight(XTP_GRIDRECORDITEM_DRAWARGS &drawArgs, int nWidth) | CXTPGridPaintManager |
GetMaxPreviewLines() | CXTPGridPaintManager |
GetPreviewItemHeight(CDC *pDC, CXTPGridRow *pRow, int nWidth, int nHeight) | CXTPGridPaintManager | virtual
GetPreviewLinesCount(CDC *pDC, CRect &rcText, const CString &strText) | CXTPGridPaintManager |
GetRowHeight(CDC *pDC, CXTPGridRow *pRow) | CXTPTrackThemeOffice2013 | virtual
CXTPTrackPaintManager::GetRowHeight(CDC *pDC, CXTPGridRow *pRow, int nTotalWidth) | CXTPGridPaintManager | virtual
GetRowHeightEx(CDC *pDC, CXTPGridRow *pRow, int nTotalWidth, const BOOL firstLevel=TRUE) | CXTPGridPaintManager |
GetSectionDividerHeight(XTPGridFixedRowsDividerStyle dividerStyle) | CXTPGridPaintManager |
GetTextFont() | CXTPGridPaintManager |
IsColumHotTrackingEnabled() const | CXTPGridPaintManager | virtual
IsColumnPlusMinusSign() const | CXTPGridPaintManager |
IsColumnWidthWYSIWYG() const | CXTPGridPaintManager |
IsDrawGridForEmptySpace() const | CXTPGridPaintManager |
IsFixedInplaceButtonHeight() const | CXTPGridPaintManager |
IsFixedRowHeight() const | CXTPGridPaintManager |
IsGridVisible(BOOL bVertical) const | CXTPGridPaintManager |
IsGridVisible(XTPGridOrientation orientation) const | CXTPGridPaintManager |
IsLastColumnWidthWYSIWYG() const | CXTPGridPaintManager |
IsPreviewMode() const | CXTPGridPaintManager |
IsPrintGroupRowIcon() const | CXTPGridPaintManager |
IsShowWYSIWYGMarkers() const | CXTPGridPaintManager |
IsUseDropMarker() const | CXTPGridPaintManager |
LoadGlyphs() | CXTPTrackThemeVisualStudio2012Light | virtual
m_arStartCol | CXTPGridPaintManager |
m_bAllowMergeCells | CXTPGridPaintManager |
m_bBaseTreeIndent | CXTPGridPaintManager |
m_bCleanTooltip | CXTPGridPaintManager |
m_bColumnPlusMinusSign | CXTPGridPaintManager | protected
m_bColumnWidthWYSIWYG | CXTPGridPaintManager | protected
m_bCompactText | CXTPGridPaintManager |
m_bDrawGridForEmptySpace | CXTPGridPaintManager | protected
m_bFixedInplaceButtonHeight | CXTPGridPaintManager | protected
m_bFixedRowHeight | CXTPGridPaintManager | protected
m_bForceDynamicMarkupForCell | CXTPGridPaintManager |
m_bForceShowDropMarker | CXTPGridPaintManager |
m_bForceShowTooltip | CXTPGridPaintManager |
m_bGrayIfDisable | CXTPGridPaintManager |
m_bGroupRowTextBold | CXTPGridPaintManager |
m_bHideSelection | CXTPGridPaintManager |
m_bHotTracking | CXTPGridPaintManager |
m_bInvertColumnOnClick | CXTPGridPaintManager |
m_bIsPreviewMode | CXTPGridPaintManager | protected
m_bLastColumnWidthWYSIWYG | CXTPGridPaintManager | protected
m_bMakeUpper | CXTPGridPaintManager |
m_bMoveScrollbarOnFixedColumnsIndent | CXTPGridPaintManager |
m_bPrintGroupRowIcon | CXTPGridPaintManager | protected
m_bPrintPageRectangle | CXTPGridPaintManager |
m_bPrintSortTriangle | CXTPGridPaintManager |
m_bPrintVirtualPageNumber | CXTPGridPaintManager |
m_bPrintWatermark | CXTPGridPaintManager |
m_bRecOrRowNum | CXTPGridPaintManager |
m_bRevertAlignment | CXTPGridPaintManager |
m_bShadeGroupHeadings | CXTPGridPaintManager |
m_bShadeSortColumn | CXTPGridPaintManager |
m_bShowLockIcon | CXTPGridPaintManager |
m_bShowNonActiveInPlaceButton | CXTPGridPaintManager |
m_bShowWYSIWYGMarkers | CXTPGridPaintManager | protected
m_bSortTriangleOffsetFromRight | CXTPGridPaintManager |
m_bThemedInplaceButtons | CXTPGridPaintManager |
m_bUseAlternativeBackground | CXTPGridPaintManager |
m_bUseDropMarker | CXTPGridPaintManager |
m_bUseEditTextAlignment | CXTPGridPaintManager |
m_bUseGroupRowSelectionState | CXTPGridPaintManager |
m_bUseShellIcon | CXTPGridPaintManager |
m_clrAlternativeBackground | CXTPGridPaintManager |
m_clrBoldText | CXTPGridPaintManager |
m_clrBoldTextHighlight | CXTPGridPaintManager |
m_clrBtnFace | CXTPGridPaintManager |
m_clrBtnFacePressed | CXTPGridPaintManager |
m_clrBtnText | CXTPGridPaintManager |
m_clrCaptionText | CXTPGridPaintManager |
m_clrCaptionTextPressed | CXTPGridPaintManager |
m_clrColumnOffice2007CustomTheme | CXTPGridPaintManager |
m_clrConnector | CXTPGridPaintManager |
m_clrControlBack | CXTPGridPaintManager |
m_clrControlDark | CXTPGridPaintManager |
m_clrControlLightLight | CXTPGridPaintManager |
m_clrDisableBitmapDarkest | CXTPGridPaintManager |
m_clrDisableBitmapLightest | CXTPGridPaintManager |
m_clrFormulaSubSum | CXTPGridPaintManager |
m_clrFormulaSum | CXTPGridPaintManager |
m_clrFreezeColsDivider | CXTPGridPaintManager |
m_clrGlyph | CXTPTrackThemeOffice2013 |
m_clrGlyphHighlight | CXTPTrackThemeOffice2013 |
m_clrGradientColumnSeparator | CXTPGridPaintManager |
m_clrGradientColumnShadow | CXTPGridPaintManager |
m_clrGroupBoxBack | CXTPGridPaintManager |
m_clrGroupRowText | CXTPGridPaintManager |
m_clrGroupShadeBack | CXTPGridPaintManager |
m_clrGroupShadeBorder | CXTPGridPaintManager |
m_clrGroupShadeText | CXTPGridPaintManager |
m_clrHeaderControl | CXTPGridPaintManager |
m_clrHighlight | CXTPGridPaintManager |
m_clrHighlightText | CXTPGridPaintManager |
m_clrHotDivider | CXTPGridPaintManager |
m_clrIndentControl | CXTPGridPaintManager |
m_clrItemShade | CXTPGridPaintManager |
m_clrMarker | CXTPTrackPaintManager |
m_clrMarkerBack | CXTPTrackPaintManager |
m_clrMarkerBorder | CXTPTrackPaintManager |
m_clrPreviewText | CXTPGridPaintManager |
m_clrScrollBarBorderDark | CXTPTrackPaintManager |
m_clrScrollBarBorderLight | CXTPTrackPaintManager |
m_clrScrollBarDark | CXTPTrackPaintManager |
m_clrScrollBarLight | CXTPTrackPaintManager |
m_clrSelectedArea | CXTPTrackPaintManager |
m_clrSelectedBorder | CXTPTrackThemeOffice2013 |
m_clrSelectedRow | CXTPGridPaintManager |
m_clrSelectedRowText | CXTPGridPaintManager |
m_clrTimeHeaderBorder | CXTPTrackPaintManager |
m_clrTimeHeaderDark | CXTPTrackPaintManager |
m_clrTimeHeaderDarkDark | CXTPTrackPaintManager |
m_clrTimeHeaderDivider | CXTPTrackPaintManager |
m_clrTimeLinePosition | CXTPTrackPaintManager |
m_clrTimeLineTick | CXTPTrackPaintManager |
m_clrTimeSliderBackground | CXTPTrackPaintManager |
m_clrTrackHeader | CXTPTrackPaintManager |
m_clrTrackMarkerBorder | CXTPTrackPaintManager |
m_clrTrackMarkerText | CXTPTrackPaintManager |
m_clrTrackMarkerTextBack | CXTPTrackPaintManager |
m_clrTrackMarkerTextBorder | CXTPTrackPaintManager |
m_clrTrackTimeArea | CXTPTrackPaintManager |
m_clrWindowText | CXTPGridPaintManager |
m_clrWorkArea | CXTPTrackPaintManager |
m_clrWorkAreaScrollBarBorder | CXTPTrackPaintManager |
m_clrWorkAreaScrollBarDark | CXTPTrackPaintManager |
m_clrWorkAreaScrollBarLight | CXTPTrackPaintManager |
m_columnStyle | CXTPGridPaintManager | protected
m_crlNoGroupByText | CXTPGridPaintManager |
m_grcGradientColumn | CXTPGridPaintManager |
m_grcGradientColumnHot | CXTPGridPaintManager |
m_grcGradientColumnPushed | CXTPGridPaintManager |
m_iRecOrRowStart | CXTPGridPaintManager |
m_nBaseParentRecordIndent | CXTPGridPaintManager |
m_nFixedColumnsIndent | CXTPGridPaintManager |
m_nFooterHeight | CXTPGridPaintManager | protected
m_nFreezeColsDividerStyle | CXTPGridPaintManager | protected
m_nGridLineStylePreviousH | CXTPGridPaintManager | protected
m_nGridLineStylePreviousV | CXTPGridPaintManager | protected
m_nGroupGridLineHeight | CXTPGridPaintManager | protected
m_nGroupGridLineStyle | CXTPGridPaintManager | protected
m_nHeaderHeight | CXTPGridPaintManager | protected
m_nMaxPreviewLines | CXTPGridPaintManager | protected
m_nResizingWidth | CXTPGridPaintManager | protected
m_nRowHeight | CXTPGridPaintManager | protected
m_nRowHeightDefault | CXTPGridPaintManager |
m_nTextIndentForGroupRowsWithNoIcon | CXTPGridPaintManager |
m_nTreeColumnLineLength | CXTPGridPaintManager |
m_nTreeIndent | CXTPGridPaintManager |
m_nTreeStructureStyle | CXTPGridPaintManager |
m_nTreeTextIndent | CXTPGridPaintManager |
m_nTreeTextIndentGroupRow | CXTPGridPaintManager |
m_nTreeTextIndentRowChildren | CXTPGridPaintManager |
m_nTreeTextIndentRowParent | CXTPGridPaintManager |
m_pControl | CXTPGridPaintManager | protected
m_pGlyphs | CXTPGridPaintManager | protected
m_pHyperlinkHoverStyle | CXTPGridPaintManager |
m_pHyperlinkStyle | CXTPGridPaintManager |
m_pMarkupUIElement_NoGroupBy | CXTPGridPaintManager | protected
m_PrintPageWidth | CXTPGridPaintManager |
m_rcPreviewIndent | CXTPGridPaintManager |
m_RecordNumberWidth | CXTPGridPaintManager |
m_strCollapse | CXTPGridPaintManager |
m_strDecreasing | CXTPGridPaintManager |
m_strExpand | CXTPGridPaintManager |
m_strIncreasing | CXTPGridPaintManager |
m_strMarkupUIElement_NoGroupBy | CXTPGridPaintManager | protected
m_strNoFieldsAvailable | CXTPGridPaintManager |
m_strNoGroupBy | CXTPGridPaintManager |
m_strNoItems | CXTPGridPaintManager |
m_strSortBy | CXTPGridPaintManager |
m_szGlyph | CXTPGridPaintManager | protected
m_themeButton | CXTPGridPaintManager | protected
m_themeCombo | CXTPGridPaintManager | protected
m_themeHeader | CXTPGridPaintManager | protected
m_themeSpin | CXTPGridPaintManager | protected
m_treeStructureStyle | CXTPGridPaintManager |
m_xtpBrushGroupGridLineStyle | CXTPGridPaintManager | protected
m_xtpBrushHorizontalGrid | CXTPGridPaintManager | protected
m_xtpBrushTreeStructure | CXTPGridPaintManager | protected
m_xtpBrushVeriticalGrid | CXTPGridPaintManager | protected
m_xtpFontBoldText | CXTPGridPaintManager |
m_xtpFontCaption | CXTPGridPaintManager |
m_xtpFontPreview | CXTPGridPaintManager |
m_xtpFontText | CXTPGridPaintManager |
OnDrawAction(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs) | CXTPGridPaintManager | virtual
RecalcTotalHightOfMergedRows(CXTPGridColumns *pColumns, CDC *pDC, CXTPGridRow *pRow, int nRowHeight, int nTotalWidth) | CXTPGridPaintManager |
RefreshMetrics() | CXTPTrackThemeVisualStudio2012Light | virtual
SetCaptionFont(LOGFONT &lf) | CXTPGridPaintManager |
SetColumnOffice2007CustomThemeBaseColor(COLORREF clrBaseColor) | CXTPGridPaintManager |
SetColumnPlusMinusSign(BOOL bDraw) | CXTPGridPaintManager |
SetColumnWidthWYSIWYG(BOOL bColumnWidthWYSIWYG) | CXTPGridPaintManager |
SetDrawGridForEmptySpace(BOOL bDrawGrid) | CXTPGridPaintManager |
SetFixedRowHeight(BOOL bFixedRowHeight) | CXTPGridPaintManager |
SetFreezeColsDividerStyle(int nStyle) | CXTPGridPaintManager |
SetGridControl(CXTPGridControl *pControl) | CXTPGridPaintManager | virtual
SetHeaderHeight(int nHeight) | CXTPGridPaintManager | virtual
SetInplaceButtonHeight(BOOL bFixedInplaceButtonHeight) | CXTPGridPaintManager |
SetLastColumnWidthWYSIWYG(BOOL bColumnWidthWYSIWYG) | CXTPGridPaintManager |
SetMaxPreviewLines(int nMaxLines) | CXTPGridPaintManager |
SetPreviewIndent(int nLeft, int nTop, int nRight, int nBottom) | CXTPGridPaintManager |
SetPrintGroupRowIcon(BOOL bDraw) | CXTPGridPaintManager |
SetTextFont(LOGFONT &lf) | CXTPGridPaintManager |
ShowWYSIWYGMarkers(BOOL bSet) | CXTPGridPaintManager |
~CXTPGridPaintManager() | CXTPGridPaintManager | virtual
~CXTPTrackPaintManager() | CXTPTrackPaintManager |


Toolkit Pro: XTPRibbonMarkupTheme.h Source File

  • Source
  • Ribbon
XTPRibbonMarkupTheme.h
Go to the documentation of this file.
1
23#if !defined(__XTPRIBBONMARKUPTHEME_H__)
24# define __XTPRIBBONMARKUPTHEME_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPMarkupContext;
34class CXTPRibbonTabContextHeader;
39enum XTPRibbonThemePart
40{
41 xtpRibbonFrameCaptionActive,
42 xtpRibbonFrameCaptionInactive,
43 xtpRibbonFrameSystemButtonNormal,
45 xtpRibbonFrameSystemButtonPopuped,
47 xtpRibbonFrameSystemButtonSelected,
49 xtpRibbonGroupControlEntry,
50 xtpRibbonGroupControlEntryLeft,
51 xtpRibbonGroupControlEntryLeftRight,
53 xtpRibbonGroupControlEntryRight,
55 xtpRibbonGroupRect,
56 xtpRibbonGroupRectBlue,
57 xtpRibbonGroupRectCyan,
58 xtpRibbonGroupRectGreen,
59 xtpRibbonGroupRectOrange,
60 xtpRibbonGroupRectPurple,
61 xtpRibbonGroupRectRed,
62 xtpRibbonGroupRectYellow,
63 xtpRibbonScrollButtonLeft,
64 xtpRibbonScrollButtonRight,
65 xtpRibbonTabHighlighted,
66 xtpRibbonTabSelected,
67 xtpRibbonTabSelectedFocused,
68 xtpRibbonTabSelectedHighlighted,
69 xtpRibbonContextTabBlue,
70 xtpRibbonContextTabCyan,
71 xtpRibbonContextTabGreen,
72 xtpRibbonContextTabOrange,
73 xtpRibbonContextTabPurple,
74 xtpRibbonContextTabRed,
75 xtpRibbonContextTabYellow,
76 xtpRibbonTabSelectedBlue,
77 xtpRibbonTabSelectedFocusedBlue,
78 xtpRibbonTabSelectedHighlightedBlue,
80 xtpRibbonTabSelectedCyan,
81 xtpRibbonTabSelectedFocusedCyan,
83 xtpRibbonTabSelectedHighlightedCyan,
85 xtpRibbonTabSelectedGreen,
86 xtpRibbonTabSelectedFocusedGreen,
88 xtpRibbonTabSelectedHighlightedGreen,
90 xtpRibbonTabSelectedOrange,
91 xtpRibbonTabSelectedFocusedOrange,
93 xtpRibbonTabSelectedHighlightedOrange,
95 xtpRibbonTabSelectedPurple,
96 xtpRibbonTabSelectedFocusedPurple,
98 xtpRibbonTabSelectedHighlightedPurple,
100 xtpRibbonTabSelectedRed,
101 xtpRibbonTabSelectedFocusedRed,
102 xtpRibbonTabSelectedHighlightedRed,
104 xtpRibbonTabSelectedYellow,
105 xtpRibbonTabSelectedFocusedYellow,
107 xtpRibbonTabSelectedHighlightedYellow,
109 xtpRibbonFrameCaptionBackstageLeft,
111 xtpRibbonFrameCaptionBackstageRight,
113 xtpRibbonThemePartCount
114};
115
116class _XTP_EXT_CLASS CXTPRibbonMarkupThemePartGroup : public CXTPMarkupThemePart
117{
118public:
119 void SetCaption(LPCTSTR pszCaption);
120
121 void SetTextColor(COLORREF clrText);
122
123 void SetFontSize(int nFontSize);
124
125 void SetFontFamily(LPCTSTR pszFontFamily);
126};
127
128class _XTP_EXT_CLASS CXTPRibbonMarkupThemePartSystemMenu : public CXTPMarkupThemePart
129{
130public:
131 void SetBackgroundColor(COLORREF clrBackground);
132
133 void SetForegroundColor(COLORREF clrForeground);
134
135 void SetCaption(LPCTSTR pszCaption);
136
137 void SetFontSize(int nFontSize);
138
139 void SetFontFamily(LPCTSTR pszFontFamily);
140};
141
146class _XTP_EXT_CLASS CXTPRibbonMarkupTheme : public CXTPRibbonPaintManager
147{
149 DECLARE_DYNAMIC(CXTPRibbonMarkupTheme)
151public:
157 CXTPRibbonMarkupTheme(CXTPPaintManager* pPaintManager);
158
163 virtual ~CXTPRibbonMarkupTheme();
164
165public:
172 void LoadParts(HZIP hZip, CXTPMarkupContext* pMarkupContext = NULL);
173
179 virtual void LoadParts(BOOL bReload = FALSE) = 0;
180
181public:
188 void FillRibbonBar(CDC* pDC, CXTPRibbonBar* pRibbonBar);
189
199 virtual void RefreshMetrics();
200
214 void FillGroupRect(CDC* pDC, CXTPRibbonTab* pActiveTab, CRect rcGroups);
215
227 void DrawGroup(CDC* pDC, CXTPRibbonGroup* pGroup);
228
236 void RenderMarkup(CDC* pDC, CRect rc, LPCTSTR lpszText);
237
245 void RenderMarkup(CDC* pDC, CRect rc, XTPRibbonThemePart part);
246
263 CSize DrawControlGroupOption(CDC* pDC, CXTPControl* pControlGroupOption, BOOL bDraw);
264
271 CSize GetControlGroupOptionSize() const;
272
292 CSize DrawControlGroupPopup(CDC* pDC, CXTPControlPopup* pControlGroupPopup, BOOL bDraw);
293
301 void FillGroupPopupToolBar(CDC* pDC, CXTPRibbonGroup* pGroup, CXTPCommandBar* pCommandBar);
302
311 virtual void DrawRibbonQuickAccessButton(CDC* pDC, CXTPControlPopup* pControl);
312
321 void DrawRibbonQuickAccessMoreButton(CDC* pDC, CXTPControlPopup* pControl);
322
329 void FillMorePopupToolBarEntry(CDC* pDC, CXTPCommandBar* pBar);
330
337 virtual void DrawRibbonTab(CDC* pDC, CXTPRibbonTab* pItem);
338
345 void FillSystemPopupBarEntry(CDC* pDC, CXTPPopupBar* pBar);
346
353 void DrawSystemPopupBarButton(CDC* pDC, CXTPControl* pButton);
354
362 void DrawRibbonScrollButton(CDC* pDC, CXTPControl* pControl, BOOL bScrollLeft);
363
371 void DrawRibbonFrameSystemButton(CDC* pDC, CXTPRibbonControlSystemButton* pControl, CRect rc);
372
382 BOOL DrawRibbonGroupControlEntry(CDC* pDC, CXTPControl* pButton);
383
390 void DrawRibbonGroupPopupToolBar(CDC* pDC, CXTPRibbonGroup* pRibbonGroup);
391
400 virtual void DrawRibbonFrameCaptionBar(CDC* pDC, CXTPRibbonBar* pRibbonBar, BOOL bActive);
401
409 virtual void DrawRibbonFrameCaption(CDC* pDC, CXTPRibbonBar* pRibbonBar, BOOL bActive);
410
417 virtual void DrawRibbonQuickAccessControls(CDC* pDC, CXTPRibbonBar* pRibbonBar);
418
426 virtual void DrawRibbonFrameContextHeaders(CDC* pDC, CXTPRibbonBar* pRibbonBar,
427 CXTPRibbonTabContextHeaders* pContextHeaders);
428
437 virtual void FillRibbonTabControl(CDC* pDC, CXTPRibbonBar* pRibbonBar, CRect rcControl);
438
439protected:
440 virtual CXTPMarkupUIElement* GetTabContextHeader(CXTPRibbonTabContextHeader* pHeader);
441
442protected:
443 COLORREF m_clrControlGroupOption;
444 COLORREF m_clrGroupCaption;
445 COLORREF m_clrQuickAccess;
446 COLORREF m_clrQuickAccessDisabled;
447 COLORREF m_clrQuickAccessBelow;
448 COLORREF m_clrQuickAccessButtonHotBack;
449 COLORREF m_clrQuickAccessButtonPressedBack;
450 COLORREF m_clrBackstageSysButtonBack2013Normal;
452 COLORREF m_clrBackstageSysButtonBack2013Highlighted;
455 CString m_strHighlightedPrefix;
457 CString m_strNormalPrefix;
460 BOOL m_bLoaded;
461
462 CXTPMarkupContext* m_pMarkupContext;
464 CXTPMarkupThemePart m_parts[xtpRibbonThemePartCount];
465
466 CXTPMarkupThemePart m_systemPopupBarEntry;
467 CXTPMarkupThemePart m_systemPopupBarButtonNormal;
468 CXTPMarkupThemePart m_systemPopupBarButtonSelected;
469
470 CXTPRibbonMarkupThemePartSystemMenu* m_pSystemMenuNormal;
471 CXTPRibbonMarkupThemePartSystemMenu* m_pSystemMenuSelected;
472 CXTPRibbonMarkupThemePartSystemMenu* m_pSystemMenuPopuped;
473
474 CXTPRibbonMarkupThemePartGroup* m_pGroupNormal;
475 CXTPRibbonMarkupThemePartGroup* m_pGroupHighlighted;
476
477 CXTPRibbonMarkupThemePartGroup* m_pGroupPopupNormal;
478 CXTPRibbonMarkupThemePartGroup* m_pGroupPopupPopuped;
479 CXTPRibbonMarkupThemePartGroup* m_pGroupPopupSelected;
480
481 CXTPRibbonMarkupThemePartGroup* m_pGroupPopupToolBar;
482
483 CXTPMarkupThemePart* m_pBackstageBackButtonLeft;
484 CXTPMarkupThemePart* m_pBackstageBackButtonRight;
485};
486
487# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
489#endif // !defined(__XTPRIBBONMARKUPTHEME_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPRibbonThemePart
XTPRibbonThemePart
Defines ribbon theme parts.
Definition XTPRibbonMarkupTheme.h:40
xtpRibbonTabSelectedHighlightedBlue
@ xtpRibbonTabSelectedHighlightedBlue
Specifies a selected highlighted blue tab ribbon theme part.
Definition XTPRibbonMarkupTheme.h:78
xtpRibbonGroupRectYellow
@ xtpRibbonGroupRectYellow
Specifies a yellow group rectangle ribbon theme part.
Definition XTPRibbonMarkupTheme.h:62
xtpRibbonTabSelectedRed
@ xtpRibbonTabSelectedRed
Specifies a selected red tab ribbon theme part.
Definition XTPRibbonMarkupTheme.h:100
xtpRibbonGroupControlEntryLeftRight
@ xtpRibbonGroupControlEntryLeftRight
Specifies a group control entry left-right ribbon theme part.
Definition XTPRibbonMarkupTheme.h:51
xtpRibbonFrameCaptionBackstageRight
@ xtpRibbonFrameCaptionBackstageRight
Specifies a frame caption backstage right ribbon theme part.
Definition XTPRibbonMarkupTheme.h:111
xtpRibbonFrameSystemButtonSelected
@ xtpRibbonFrameSystemButtonSelected
Specifies a selected frame system button ribbon theme part.
Definition XTPRibbonMarkupTheme.h:47
xtpRibbonGroupControlEntryRight
@ xtpRibbonGroupControlEntryRight
Specifies a group control entry right ribbon theme part.
Definition XTPRibbonMarkupTheme.h:53
xtpRibbonTabSelectedFocusedYellow
@ xtpRibbonTabSelectedFocusedYellow
Specifies a selected focused yellow tab ribbon theme part.
Definition XTPRibbonMarkupTheme.h:105
xtpRibbonTabSelectedBlue
@ xtpRibbonTabSelectedBlue
Specifies a selected blue tab ribbon theme part.
Definition XTPRibbonMarkupTheme.h:76
xtpRibbonTabSelectedFocused
@ xtpRibbonTabSelectedFocused
Specifies a focused selected tab ribbon theme part.
Definition XTPRibbonMarkupTheme.h:67
xtpRibbonGroupControlEntry
@ xtpRibbonGroupControlEntry
Specifies a group control entry ribbon theme part.
Definition XTPRibbonMarkupTheme.h:49
xtpRibbonTabSelectedHighlightedGreen
@ xtpRibbonTabSelectedHighlightedGreen
Specifies a selected highlighted green tab ribbon theme part.
Definition XTPRibbonMarkupTheme.h:88
xtpRibbonTabSelectedHighlightedRed
@ xtpRibbonTabSelectedHighlightedRed
Specifies a selected highlighted red tab ribbon theme part.
Definition XTPRibbonMarkupTheme.h:102
xtpRibbonGroupRectCyan
@ xtpRibbonGroupRectCyan
Specifies a cyan group rectangle ribbon theme part.
Definition XTPRibbonMarkupTheme.h:57
xtpRibbonGroupRectRed
@ xtpRibbonGroupRectRed
Specifies a red group rectangle ribbon theme part.
Definition XTPRibbonMarkupTheme.h:61
xtpRibbonContextTabOrange
@ xtpRibbonContextTabOrange
Specifies an orange context tab ribbon theme part.
Definition XTPRibbonMarkupTheme.h:72
xtpRibbonGroupRectOrange
@ xtpRibbonGroupRectOrange
Specifies an orange group rectangle ribbon theme part.
Definition XTPRibbonMarkupTheme.h:59
xtpRibbonTabSelectedHighlightedPurple
@ xtpRibbonTabSelectedHighlightedPurple
Specifies a selected highlighted purple tab ribbon theme part.
Definition XTPRibbonMarkupTheme.h:98
xtpRibbonGroupRect
@ xtpRibbonGroupRect
Specifies a group rectangle ribbon theme part.
Definition XTPRibbonMarkupTheme.h:55
xtpRibbonTabSelectedOrange
@ xtpRibbonTabSelectedOrange
Specifies a selected orange tab ribbon theme part.
Definition XTPRibbonMarkupTheme.h:90
xtpRibbonContextTabPurple
@ xtpRibbonContextTabPurple
Specifies a purple context tab ribbon theme part.
Definition XTPRibbonMarkupTheme.h:73
xtpRibbonContextTabGreen
@ xtpRibbonContextTabGreen
Specifies a green context tab ribbon theme part.
Definition XTPRibbonMarkupTheme.h:71
xtpRibbonScrollButtonRight
@ xtpRibbonScrollButtonRight
Specifies a right scroll button ribbon theme part.
Definition XTPRibbonMarkupTheme.h:64
xtpRibbonTabSelectedHighlighted
@ xtpRibbonTabSelectedHighlighted
Specifies a highlighted selected tab ribbon theme part.
Definition XTPRibbonMarkupTheme.h:68
xtpRibbonTabSelectedFocusedRed
@ xtpRibbonTabSelectedFocusedRed
Specifies a selected focused red tab ribbon theme part.
Definition XTPRibbonMarkupTheme.h:101
xtpRibbonTabSelectedFocusedBlue
@ xtpRibbonTabSelectedFocusedBlue
Specifies a selected focuse blue tab ribbon theme part.
Definition XTPRibbonMarkupTheme.h:77
xtpRibbonFrameSystemButtonNormal
@ xtpRibbonFrameSystemButtonNormal
Specifies a normal frame system button ribbon theme part.
Definition XTPRibbonMarkupTheme.h:43
xtpRibbonFrameCaptionActive
@ xtpRibbonFrameCaptionActive
Specifies an active frame caption ribbon theme part.
Definition XTPRibbonMarkupTheme.h:41
xtpRibbonTabSelected
@ xtpRibbonTabSelected
Specifies a selected tab ribbon theme part.
Definition XTPRibbonMarkupTheme.h:66
xtpRibbonScrollButtonLeft
@ xtpRibbonScrollButtonLeft
Specifies a left scroll button ribbon theme part.
Definition XTPRibbonMarkupTheme.h:63
xtpRibbonGroupRectGreen
@ xtpRibbonGroupRectGreen
Specifies a green group rectangle ribbon theme part.
Definition XTPRibbonMarkupTheme.h:58
xtpRibbonGroupRectPurple
@ xtpRibbonGroupRectPurple
Specifies a purple group rectangle ribbon theme part.
Definition XTPRibbonMarkupTheme.h:60
xtpRibbonGroupControlEntryLeft
@ xtpRibbonGroupControlEntryLeft
Specifies a group control entry left ribbon theme part.
Definition XTPRibbonMarkupTheme.h:50
xtpRibbonGroupRectBlue
@ xtpRibbonGroupRectBlue
Specifies a blue group rectangle ribbon theme part.
Definition XTPRibbonMarkupTheme.h:56
xtpRibbonTabSelectedGreen
@ xtpRibbonTabSelectedGreen
Specifies a selected green tab ribbon theme part.
Definition XTPRibbonMarkupTheme.h:85
xtpRibbonFrameCaptionBackstageLeft
@ xtpRibbonFrameCaptionBackstageLeft
Specifies a frame caption backstage left ribbon theme part.
Definition XTPRibbonMarkupTheme.h:109
xtpRibbonTabSelectedPurple
@ xtpRibbonTabSelectedPurple
Specifies a selected purple tab ribbon theme part.
Definition XTPRibbonMarkupTheme.h:95
xtpRibbonContextTabRed
@ xtpRibbonContextTabRed
Specifies a red context tab ribbon theme part.
Definition XTPRibbonMarkupTheme.h:74
xtpRibbonTabSelectedFocusedGreen
@ xtpRibbonTabSelectedFocusedGreen
Specifies a selected focused green tab ribbon theme part.
Definition XTPRibbonMarkupTheme.h:86
xtpRibbonTabSelectedYellow
@ xtpRibbonTabSelectedYellow
Specifies a selected yellow tab ribbon theme part.
Definition XTPRibbonMarkupTheme.h:104
xtpRibbonContextTabCyan
@ xtpRibbonContextTabCyan
Specifies a cyan context tab ribbon theme part.
Definition XTPRibbonMarkupTheme.h:70
xtpRibbonTabSelectedHighlightedYellow
@ xtpRibbonTabSelectedHighlightedYellow
Specifies a selected highlighted yellow tab ribbon theme part.
Definition XTPRibbonMarkupTheme.h:107
xtpRibbonTabSelectedFocusedOrange
@ xtpRibbonTabSelectedFocusedOrange
Specifies a selected focused orange tab ribbon theme part.
Definition XTPRibbonMarkupTheme.h:91
xtpRibbonTabSelectedHighlightedOrange
@ xtpRibbonTabSelectedHighlightedOrange
Specifies a selected highlighted orange tab ribbon theme part.
Definition XTPRibbonMarkupTheme.h:93
xtpRibbonFrameSystemButtonPopuped
@ xtpRibbonFrameSystemButtonPopuped
Specifies a popup frame system button ribbon theme part.
Definition XTPRibbonMarkupTheme.h:45
xtpRibbonContextTabBlue
@ xtpRibbonContextTabBlue
Specifies a blue context tab ribbon theme part.
Definition XTPRibbonMarkupTheme.h:69
xtpRibbonTabHighlighted
@ xtpRibbonTabHighlighted
Specifies a highlighted tab ribbon theme part.
Definition XTPRibbonMarkupTheme.h:65
xtpRibbonTabSelectedFocusedPurple
@ xtpRibbonTabSelectedFocusedPurple
Specifies a selected focused purple tab ribbon theme part.
Definition XTPRibbonMarkupTheme.h:96
xtpRibbonContextTabYellow
@ xtpRibbonContextTabYellow
Specifies a yellow context tab ribbon theme part.
Definition XTPRibbonMarkupTheme.h:75
xtpRibbonFrameCaptionInactive
@ xtpRibbonFrameCaptionInactive
Specifies an inactive frame caption ribbon theme part.
Definition XTPRibbonMarkupTheme.h:42
xtpRibbonTabSelectedCyan
@ xtpRibbonTabSelectedCyan
Specifies a selected cyan tab ribbon theme part.
Definition XTPRibbonMarkupTheme.h:80
xtpRibbonTabSelectedHighlightedCyan
@ xtpRibbonTabSelectedHighlightedCyan
Specifies a selected highlighted cyan tab ribbon theme part.
Definition XTPRibbonMarkupTheme.h:83
xtpRibbonThemePartCount
@ xtpRibbonThemePartCount
The number of theme parts.
Definition XTPRibbonMarkupTheme.h:113
xtpRibbonTabSelectedFocusedCyan
@ xtpRibbonTabSelectedFocusedCyan
Specifies a selected focused cyan tab ribbon theme part.
Definition XTPRibbonMarkupTheme.h:81
CXTPCommandBar
CXTPCommandBar is a CWnd derived class.
Definition XTPCommandBar.h:66
CXTPControl
CXTPControl is a CXTPCmdTarget derived class.
Definition XTPControl.h:841
CXTPControlPopup
CXTPControlPopup is a CXTPControl derived class.
Definition XTPControlPopup.h:42
CXTPMarkupContext
CXTPMarkupContext is a standalone class used to provide common settings for Markup objects.
Definition XTPMarkupContext.h:128
CXTPMarkupThemePart
The CXTPMarkupThemePart class is used to create a theme part object used for rendering.
Definition XTPMarkupTheme.h:42
CXTPMarkupUIElement
Base class for XML Markup core level implementations.
Definition XTPMarkupUIElement.h:43
CXTPPaintManager
Paint manager of the command bars.
Definition XTPPaintManager.h:199
CXTPPopupBar
CXTPPopupBar is a CXTPCommandBar derived class.
Definition XTPPopupBar.h:42
CXTPRibbonBar
CXTPRibbonBar is a CXTPMenuBar derived class.
Definition XTPRibbonBar.h:69
CXTPRibbonControlSystemButton
CXTPRibbonControlSystemButton is a CXTPControlPopup derived class used as a system button for a Ribbo...
Definition XTPRibbonSystemButton.h:39
CXTPRibbonGroup
Represents a single group that is added to a CXTPRibbonTab.
Definition XTPRibbonGroup.h:70
CXTPRibbonMarkupTheme
CXTPRibbonMarkupTheme class.
Definition XTPRibbonMarkupTheme.h:147
CXTPRibbonMarkupTheme::DrawControlGroupPopup
CSize DrawControlGroupPopup(CDC *pDC, CXTPControlPopup *pControlGroupPopup, BOOL bDraw)
Draws the group pop-up button.
CXTPRibbonMarkupTheme::~CXTPRibbonMarkupTheme
virtual ~CXTPRibbonMarkupTheme()
Destroys a CXTPRibbonMarkupTheme object, handles cleanup and deallocation.
CXTPRibbonMarkupTheme::DrawRibbonGroupControlEntry
BOOL DrawRibbonGroupControlEntry(CDC *pDC, CXTPControl *pButton)
This method is called to draw the ribbon group when the group is minimized and only a button is displ...
CXTPRibbonMarkupTheme::DrawRibbonQuickAccessButton
virtual void DrawRibbonQuickAccessButton(CDC *pDC, CXTPControlPopup *pControl)
This method is called to draw the Quick Access customize button.
CXTPRibbonMarkupTheme::FillGroupRect
void FillGroupRect(CDC *pDC, CXTPRibbonTab *pActiveTab, CRect rcGroups)
This method is called to fill the background of a CXTPRibbonGroup.
CXTPRibbonMarkupTheme::FillRibbonTabControl
virtual void FillRibbonTabControl(CDC *pDC, CXTPRibbonBar *pRibbonBar, CRect rcControl)
This member fills in the tab header and tab client area.
CXTPRibbonMarkupTheme::RenderMarkup
void RenderMarkup(CDC *pDC, CRect rc, LPCTSTR lpszText)
Renders a Markup string in the Ribbon.
CXTPRibbonMarkupTheme::FillRibbonBar
void FillRibbonBar(CDC *pDC, CXTPRibbonBar *pRibbonBar)
This method is called to fill the background of a ribbon bar control.
CXTPRibbonMarkupTheme::DrawRibbonScrollButton
void DrawRibbonScrollButton(CDC *pDC, CXTPControl *pControl, BOOL bScrollLeft)
This method is called to draw scroll group buttons.
CXTPRibbonMarkupTheme::RenderMarkup
void RenderMarkup(CDC *pDC, CRect rc, XTPRibbonThemePart part)
Renders a Markup string in the Ribbon.
CXTPRibbonMarkupTheme::FillMorePopupToolBarEntry
void FillMorePopupToolBarEntry(CDC *pDC, CXTPCommandBar *pBar)
This method is called to draw the pop-up bar of the more button.
CXTPRibbonMarkupTheme::DrawGroup
void DrawGroup(CDC *pDC, CXTPRibbonGroup *pGroup)
Draws the specified CXTPRibbonGroup.
CXTPRibbonMarkupTheme::LoadParts
virtual void LoadParts(BOOL bReload=FALSE)=0
Loads markup parts.
CXTPRibbonMarkupTheme::DrawRibbonQuickAccessMoreButton
void DrawRibbonQuickAccessMoreButton(CDC *pDC, CXTPControlPopup *pControl)
This method is called to draw the Quick Access more button.
CXTPRibbonMarkupTheme::DrawRibbonTab
virtual void DrawRibbonTab(CDC *pDC, CXTPRibbonTab *pItem)
This method is called to draw a single tab of the ribbon bar.
CXTPRibbonMarkupTheme::DrawRibbonGroupPopupToolBar
void DrawRibbonGroupPopupToolBar(CDC *pDC, CXTPRibbonGroup *pRibbonGroup)
This method is called to draw the ribbon group pop-up toolbar.
CXTPRibbonMarkupTheme::DrawRibbonFrameCaption
virtual void DrawRibbonFrameCaption(CDC *pDC, CXTPRibbonBar *pRibbonBar, BOOL bActive)
This method is called to draw the Ribbon caption.
CXTPRibbonMarkupTheme::GetControlGroupOptionSize
CSize GetControlGroupOptionSize() const
Calculates the ribbon group option size.
CXTPRibbonMarkupTheme::DrawControlGroupOption
CSize DrawControlGroupOption(CDC *pDC, CXTPControl *pControlGroupOption, BOOL bDraw)
Draws the group option button.
CXTPRibbonMarkupTheme::m_pMarkupContext
CXTPMarkupContext * m_pMarkupContext
Store pointer to a CXTPMarkupContext object.
Definition XTPRibbonMarkupTheme.h:462
CXTPRibbonMarkupTheme::DrawSystemPopupBarButton
void DrawSystemPopupBarButton(CDC *pDC, CXTPControl *pButton)
This method is called to draw a pop-up bar button.
CXTPRibbonMarkupTheme::FillSystemPopupBarEntry
void FillSystemPopupBarEntry(CDC *pDC, CXTPPopupBar *pBar)
This method is called to draw the pop-up bar of the system button.
CXTPRibbonMarkupTheme::LoadParts
void LoadParts(HZIP hZip, CXTPMarkupContext *pMarkupContext=NULL)
Loads markup parts from the specified ZIP source.
CXTPRibbonMarkupTheme::DrawRibbonQuickAccessControls
virtual void DrawRibbonQuickAccessControls(CDC *pDC, CXTPRibbonBar *pRibbonBar)
This method is called to draw ribbon Quick Access controls.
CXTPRibbonMarkupTheme::m_clrBackstageSysButtonBack2013Highlighted
COLORREF m_clrBackstageSysButtonBack2013Highlighted
The color of "back" button in backstage if the button is selected.
Definition XTPRibbonMarkupTheme.h:452
CXTPRibbonMarkupTheme::DrawRibbonFrameSystemButton
void DrawRibbonFrameSystemButton(CDC *pDC, CXTPRibbonControlSystemButton *pControl, CRect rc)
Draws the top-left system button.
CXTPRibbonMarkupTheme::FillGroupPopupToolBar
void FillGroupPopupToolBar(CDC *pDC, CXTPRibbonGroup *pGroup, CXTPCommandBar *pCommandBar)
This method is called to draw the pop-up toolbar of a reduced group.
CXTPRibbonMarkupTheme::CXTPRibbonMarkupTheme
CXTPRibbonMarkupTheme(CXTPPaintManager *pPaintManager)
Constructs a CXTPRibbonMarkupTheme object.
CXTPRibbonMarkupTheme::m_strHighlightedPrefix
CString m_strHighlightedPrefix
The prefix of the file name for the backstage "back" button image used for the selected button.
Definition XTPRibbonMarkupTheme.h:455
CXTPRibbonMarkupTheme::RefreshMetrics
virtual void RefreshMetrics()
This method is called to refresh the visual metrics of the manager.
CXTPRibbonMarkupTheme::m_clrBackstageSysButtonBack2013Normal
COLORREF m_clrBackstageSysButtonBack2013Normal
The color of "back" button in backstage if the button is not selected.
Definition XTPRibbonMarkupTheme.h:450
CXTPRibbonMarkupTheme::DrawRibbonFrameContextHeaders
virtual void DrawRibbonFrameContextHeaders(CDC *pDC, CXTPRibbonBar *pRibbonBar, CXTPRibbonTabContextHeaders *pContextHeaders)
This method is called to draw ribbon context headers.
CXTPRibbonMarkupTheme::m_strNormalPrefix
CString m_strNormalPrefix
The prefix of the file name for the backstage "back" button image used for the not selected button.
Definition XTPRibbonMarkupTheme.h:457
CXTPRibbonMarkupTheme::DrawRibbonFrameCaptionBar
virtual void DrawRibbonFrameCaptionBar(CDC *pDC, CXTPRibbonBar *pRibbonBar, BOOL bActive)
This method is called to draw the ribbon caption if EnableFrameTheme was not called.
CXTPRibbonPaintManager
Standalone class used by CXTPRibbonBar as a paint manager.
Definition XTPRibbonPaintManager.h:51
CXTPRibbonTab
Represents a tab in the Ribbon Bar.
Definition XTPRibbonTab.h:116


Toolkit Pro: XTPMarkupTranslateTransform.h Source File

  • Source
  • Markup
  • Transform
XTPMarkupTranslateTransform.h
Go to the documentation of this file.
1
23#if !defined(__XTPMARKUPTRANSLATETRANSFORM_H__)
24# define __XTPMARKUPTRANSLATETRANSFORM_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPMarkupTransformationMatrix;
34class CXTPMarkupDependencyProperty;
35
40class _XTP_EXT_CLASS CXTPMarkupTranslateTransform : public CXTPMarkupTransform
41{
43 DECLARE_MARKUPCLASS(CXTPMarkupTranslateTransform);
45public:
52 double GetX() const;
53
59 void SetX(double x);
60
67 double GetY() const;
68
74 void SetY(double y);
75
83 virtual CXTPMarkupTransformationMatrix*
84 ApplyTransform(const CXTPMarkupTransformationMatrix* pMatrix);
85
86private:
87 DECLARE_DISPATCH_MAP();
88 afx_msg double OleGetX();
89 afx_msg void OleSetX(double x);
90 afx_msg double OleGetY();
91 afx_msg void OleSetY(double y);
92
93public:
94 static CXTPMarkupDependencyProperty* m_pPropertyX;
95 static CXTPMarkupDependencyProperty* m_pPropertyY;
96};
97
98# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
100#endif // !defined(__XTPMARKUPTRANSLATETRANSFORM_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPMarkupTransform
Base class for all markup transformation objects.
Definition XTPMarkupTransform.h:43
CXTPMarkupTransformationMatrix
An abstract class for device context transformation matrix.
Definition XTPMarkupTransformationMatrix.h:40
CXTPMarkupTranslateTransform
Default TranslateTransform implementation.
Definition XTPMarkupTranslateTransform.h:41
CXTPMarkupTranslateTransform::m_pPropertyX
static CXTPMarkupDependencyProperty * m_pPropertyX
X property.
Definition XTPMarkupTranslateTransform.h:94
CXTPMarkupTranslateTransform::GetY
double GetY() const
Gets the Y value.
CXTPMarkupTranslateTransform::m_pPropertyY
static CXTPMarkupDependencyProperty * m_pPropertyY
Y property.
Definition XTPMarkupTranslateTransform.h:95
CXTPMarkupTranslateTransform::ApplyTransform
virtual CXTPMarkupTransformationMatrix * ApplyTransform(const CXTPMarkupTransformationMatrix *pMatrix)
Does nothing in default implementation.
CXTPMarkupTranslateTransform::GetX
double GetX() const
Gets the X value.
CXTPMarkupTranslateTransform::SetX
void SetX(double x)
Sets the X value.
CXTPMarkupTranslateTransform::SetY
void SetY(double y)
Sets the Y value.


Toolkit Pro: XTPShortcutBarVisualStudio2017Theme.h Source File

  • Source
  • ShortcutBar
  • Themes
XTPShortcutBarVisualStudio2017Theme.h
Go to the documentation of this file.
1
23#if !defined(__XTPSHORTCUTBARVISUALSTUDIO2017THEME_H__)
24# define __XTPSHORTCUTBARVISUALSTUDIO2017THEME_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPShortcutBarVisualStudio2017Theme : public CXTPShortcutBarOffice2013Theme
39{
40public:
45 CXTPShortcutBarVisualStudio2017Theme();
46
52 virtual ~CXTPShortcutBarVisualStudio2017Theme();
53
61 virtual void RefreshMetrics();
62
84 virtual int DrawPaneItemCaption(CDC* pDC, CXTPShortcutBarPaneItem* pItem, BOOL bDraw);
85
86 virtual void DrawPaneCaptionMinimizeButton(CDC* pDC, CXTPShortcutBarPane* pPane);
87
94 virtual void FillShortcutItemEntry(CDC* pDC, CXTPShortcutBarItem* pItem);
95
102 virtual void FillNavigationItemEntry(CDC* pDC, CXTPShortcutBarItem* pItem);
103
104 void DrawHiliteBorder(CDC* pDC, CRect rc);
105
106protected:
107 BOOL m_bHiliteBorders;
108 CXTPPaintManagerColor m_clrBorderHilite;
109 CXTPPaintManagerColor m_clrBackHiliteSelected;
110};
111
112# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
114#endif // !defined(__XTPSHORTCUTBARVISUALSTUDIO2017THEME_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPPaintManagerColor
The CXTPPaintManagerColor class is used to manage COLORREF values for determining default and applica...
Definition XTPColorManager.h:117
CXTPShortcutBarItem
CXTPShortcutBarItem is a base class that represents an item for a shortcut bar control.
Definition XTPShortcutBar.h:181
CXTPShortcutBarOffice2013Theme
CXTPShortcutBarOffice2013Theme is a CXTPShortcutBarResourceTheme derived class that represents an Off...
Definition XTPShortcutBarOffice2013Theme.h:39
CXTPShortcutBarPane
CXTPShortcutBarPane is a CWnd derived class used as a client area for a shortcut bar control.
Definition XTPShortcutBarPane.h:158
CXTPShortcutBarPaneItem
CXTPShortcutBarPaneItem is a base class that represents an item for a shortcut bar pane.
Definition XTPShortcutBarPane.h:42
CXTPShortcutBarVisualStudio2017Theme
CXTPShortcutBarVisualStudio2017Theme is a CXTPShortcutBarOffice2013Theme derived class that represent...
Definition XTPShortcutBarVisualStudio2017Theme.h:39
CXTPShortcutBarVisualStudio2017Theme::DrawPaneItemCaption
virtual int DrawPaneItemCaption(CDC *pDC, CXTPShortcutBarPaneItem *pItem, BOOL bDraw)
Draws the caption for a specified shortcut bar pane item.
CXTPShortcutBarVisualStudio2017Theme::m_bHiliteBorders
BOOL m_bHiliteBorders
TRUE to draw borders around highlighted items.
Definition XTPShortcutBarVisualStudio2017Theme.h:107
CXTPShortcutBarVisualStudio2017Theme::m_clrBackHiliteSelected
CXTPPaintManagerColor m_clrBackHiliteSelected
Selected highlighted background color.
Definition XTPShortcutBarVisualStudio2017Theme.h:109
CXTPShortcutBarVisualStudio2017Theme::FillShortcutItemEntry
virtual void FillShortcutItemEntry(CDC *pDC, CXTPShortcutBarItem *pItem)
Fills a specified item for the shortcut bar control.
CXTPShortcutBarVisualStudio2017Theme::m_clrBorderHilite
CXTPPaintManagerColor m_clrBorderHilite
Highlighted border color.
Definition XTPShortcutBarVisualStudio2017Theme.h:108
CXTPShortcutBarVisualStudio2017Theme::CXTPShortcutBarVisualStudio2017Theme
CXTPShortcutBarVisualStudio2017Theme()
Constructs a CXTPShortcutBarVisualStudio2017Theme object.
CXTPShortcutBarVisualStudio2017Theme::RefreshMetrics
virtual void RefreshMetrics()
Refreshes the visual metrics of the shortcut bar paint manager.
CXTPShortcutBarVisualStudio2017Theme::FillNavigationItemEntry
virtual void FillNavigationItemEntry(CDC *pDC, CXTPShortcutBarItem *pItem)
Fills a specified navigation item for the minimized shortcut bar control.
CXTPShortcutBarVisualStudio2017Theme::~CXTPShortcutBarVisualStudio2017Theme
virtual ~CXTPShortcutBarVisualStudio2017Theme()
Destroys a CXTPShortcutBarVisualStudio2017Theme object, handles cleanup and deallocation.


Toolkit Pro: XTPFlowGraphNodeGroup.h Source File

  • Source
  • FlowGraph
XTPFlowGraphNodeGroup.h
Go to the documentation of this file.
1
23#if !defined(__XTPFLOWGRAPHNODEGROUP_H__)
24# define __XTPFLOWGRAPHNODEGROUP_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPFlowGraphPage;
34class CXTPFlowGraphNodeGroups;
35class CXTPFlowGraphNode;
36
46class _XTP_EXT_CLASS CXTPFlowGraphNodeGroup : public CXTPFlowGraphElement
47{
49 DECLARE_DYNAMIC(CXTPFlowGraphNodeGroup)
51public:
56 CXTPFlowGraphNodeGroup();
62 virtual ~CXTPFlowGraphNodeGroup();
63
64public:
70 void AddNode(CXTPFlowGraphNode* pNode);
76 void RemoveNode(CXTPFlowGraphNode* pNode);
77
82 void RemoveAll();
87 void Remove();
88
95 CXTPFlowGraphControl* GetControl() const;
102 CXTPFlowGraphPage* GetPage() const;
103
110 int GetCount() const;
119 CXTPFlowGraphNode* GetAt(int nIndex) const;
120
127 CRect GetWorkRect() const;
128
134 void SetCaption(LPCTSTR lpszCaption);
144 CString GetCaption() const;
145
146protected:
147 CArray<CXTPFlowGraphNode*, CXTPFlowGraphNode*> m_arrNodes;
149 CXTPFlowGraphNodeGroups* m_pGroups;
151 CRect m_rcWorkRect;
153 friend class CXTPFlowGraphNodeGroups;
154 friend class CXTPFlowGraphPage;
155
156# ifdef _XTP_ACTIVEX
159 DECLARE_DISPATCH_MAP()
160 DECLARE_INTERFACE_MAP()
161
162 DECLARE_OLETYPELIB_EX(CXTPFlowGraphNodeGroup)
163
164 afx_msg void OleSetCaption(LPCTSTR lpszCaption);
165 afx_msg BSTR OleGetCaption();
166
167 afx_msg LPDISPATCH OleGetPage();
168 afx_msg int OleGetItemCount();
169 afx_msg LPDISPATCH OleGetItem(int nIndex);
170
171 afx_msg void OleAddNode(LPDISPATCH Node);
172 afx_msg void OleRemoveNode(LPDISPATCH Node);
173 DECLARE_ENUM_VARIANT(CXTPFlowGraphNodeGroup)
174
176# endif
177};
178
179AFX_INLINE int CXTPFlowGraphNodeGroup::GetCount() const
180{
181 return (int)m_arrNodes.GetSize();
182}
183AFX_INLINE CXTPFlowGraphNode* CXTPFlowGraphNodeGroup::GetAt(int nIndex) const
184{
185 return nIndex >= 0 && nIndex < m_arrNodes.GetSize() ? m_arrNodes[nIndex] : NULL;
186}
187AFX_INLINE CRect CXTPFlowGraphNodeGroup::GetWorkRect() const
188{
189 return m_rcWorkRect;
190}
192# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
193#endif //#if !defined(__XTPFLOWGRAPHNODEGROUP_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPFlowGraphControl
Flow Graph Control.
Definition XTPFlowGraphControl.h:173
CXTPFlowGraphElement
Base class for all elements in the flow graph.
Definition XTPFlowGraphElement.h:46
CXTPFlowGraphNodeGroup
Represents a group of Nodes.
Definition XTPFlowGraphNodeGroup.h:47
CXTPFlowGraphNodeGroup::CXTPFlowGraphNodeGroup
CXTPFlowGraphNodeGroup()
Constructs a CXTPFlowGraphNodeGroup object.
CXTPFlowGraphNodeGroup::GetCount
int GetCount() const
Get the total number of Nodes that are in the group.
Definition XTPFlowGraphNodeGroup.h:179
CXTPFlowGraphNodeGroup::Remove
void Remove()
Removes this group from the flow graph's collection of groups.
CXTPFlowGraphNodeGroup::AddNode
void AddNode(CXTPFlowGraphNode *pNode)
Adds a Node to the Node group.
CXTPFlowGraphNodeGroup::m_pGroups
CXTPFlowGraphNodeGroups * m_pGroups
Pointer to the collection of groups that this belongs to.
Definition XTPFlowGraphNodeGroup.h:149
CXTPFlowGraphNodeGroup::GetCaption
CString GetCaption() const
Gets the common caption for each Node in the group.
CXTPFlowGraphNodeGroup::GetControl
CXTPFlowGraphControl * GetControl() const
Gets a reference to the parent FlowGraph control.
CXTPFlowGraphNodeGroup::m_arrNodes
CArray< CXTPFlowGraphNode *, CXTPFlowGraphNode * > m_arrNodes
Collection of nodes that are in this group.
Definition XTPFlowGraphNodeGroup.h:147
CXTPFlowGraphNodeGroup::RemoveNode
void RemoveNode(CXTPFlowGraphNode *pNode)
Removes a Node from the Node group.
CXTPFlowGraphNodeGroup::GetPage
CXTPFlowGraphPage * GetPage() const
Gets a reference to the page that this group belongs to.
CXTPFlowGraphNodeGroup::SetCaption
void SetCaption(LPCTSTR lpszCaption)
Sets the common caption for each Node in the group.
CXTPFlowGraphNodeGroup::RemoveAll
void RemoveAll()
Removes all nodes from this group.
CXTPFlowGraphNodeGroup::GetWorkRect
CRect GetWorkRect() const
Gets the bounding rectangle for the group.
Definition XTPFlowGraphNodeGroup.h:187
CXTPFlowGraphNodeGroup::m_rcWorkRect
CRect m_rcWorkRect
Rectangle displayed for this group.
Definition XTPFlowGraphNodeGroup.h:151
CXTPFlowGraphNodeGroup::~CXTPFlowGraphNodeGroup
virtual ~CXTPFlowGraphNodeGroup()
Destroys a CXTPFlowGraphNodeGroup object, handles cleanup and deallocation.
CXTPFlowGraphNodeGroup::GetAt
CXTPFlowGraphNode * GetAt(int nIndex) const
Retrieves the Node at the specified index from the group's collection of Nodes.
Definition XTPFlowGraphNodeGroup.h:183
CXTPFlowGraphNodeGroups
Represents a collection of groups in a page.
Definition XTPFlowGraphNodeGroups.h:46
CXTPFlowGraphNode
Represents a Node object.
Definition XTPFlowGraphNode.h:116
CXTPFlowGraphNode::GetSize
CSize GetSize() const
Gets the size of the Node.
CXTPFlowGraphPage
Represents a page in the flow graph.
Definition XTPFlowGraphPage.h:54


Toolkit Pro: XTPButtonThemeVisualStudio2017.h Source File

  • Source
  • Controls
  • Button
  • Themes
XTPButtonThemeVisualStudio2017.h
Go to the documentation of this file.
1
23#if !defined(__XTPBUTTONTHEMEVISUALSTUDIO2017_H__)
24# define __XTPBUTTONTHEMEVISUALSTUDIO2017_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPButtonThemeVisualStudio2017 : public CXTPButtonThemeOffice2013
39{
40public:
45 CXTPButtonThemeVisualStudio2017();
46
53 virtual void RefreshMetrics(CXTPButton* pButton);
54};
55
56# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
58#endif //#if !defined(__XTPBUTTONTHEMEVISUALSTUDIO2017_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPButton
Push Button control.
Definition XTPButton.h:109
CXTPButtonThemeOffice2013
CXTPButtonThemeOffice2013 is a class used to perform Office 2013 theme drawing tasks.
Definition XTPButtonThemeOffice2013.h:39
CXTPButtonThemeVisualStudio2017
CXTPButtonThemeVisualStudio2017 is a class used to perform Visual Studio 2017 theme drawing tasks.
Definition XTPButtonThemeVisualStudio2017.h:39
CXTPButtonThemeVisualStudio2017::CXTPButtonThemeVisualStudio2017
CXTPButtonThemeVisualStudio2017()
Constructs a CXTPButtonThemeVisualStudio2017 object.
CXTPButtonThemeVisualStudio2017::RefreshMetrics
virtual void RefreshMetrics(CXTPButton *pButton)
This member function is called by the theme manager to refresh the visual styles used by each compone...


Toolkit Pro: Member List

CXTPBrowseButton Member List

This is the complete list of members for CXTPBrowseButton, including all inherited members.

Create(CXTPBrowseEdit *pEditWnd, DWORD dwBStyle, UINT nID, UINT nMenu=(UINT) -1, UINT nSubMenuIndx=(UINT) -1) | CXTPBrowseButton | virtual
CXTPBrowseButton() | CXTPBrowseButton |
CXTPButton() | CXTPButton |
DoDropDown() | CXTPButton | protected
DrawImage(CDC *pDC, CRect rc) | CXTPButton | virtual
EnableMarkup(BOOL bEnableMarkup=TRUE) | CXTPButton |
GetBorderGap() const | CXTPButton |
GetBorderStyle() const | CXTPButton |
GetButtonBackColor() | CXTPButton | virtual
GetButtonRect() | CXTPButton | virtual
GetButtonStyle() const | CXTPButton |
GetButtonText() | CXTPButton | virtual
GetButtonTextColor() | CXTPButton | virtual
GetChecked() | CXTPButton | virtual
GetFlatStyle() const | CXTPButton |
GetGlyphSize(BOOL bCheckBox) | CXTPButton |
GetIcon() const | CXTPButton |
GetImageAlignment() const | CXTPButton | virtual
GetImageGap() const | CXTPButton |
GetImageSize() | CXTPButton | virtual
GetMarkupContext() const | CXTPButton |
GetMarkupUIElement() | CXTPButton |
GetPushButtonStyle() const | CXTPButton |
GetShowFocus() const | CXTPButton |
GetTextAlignment() const | CXTPButton | virtual
GetTextImageRelation() const | CXTPButton |
GetTheme() | CXTPButton |
GetTooltip() const | CXTPButton |
GetToolTipContext() const | CXTPButton |
GetUseVisualStyle() const | CXTPButton |
InternalTextChanged() | CXTPButton | virtual
IsDpiImageScalingEnabled() const | CXTPButton | virtual
IsDropDownStyle() const | CXTPButton |
IsHighlighted() | CXTPButton | virtual
IsPushButton() const | CXTPButton |
IsPushed() | CXTPButton | virtual
m_bChecked | CXTPButton |
m_bEnableMarkup | CXTPButton |
m_bFlatStyle | CXTPButton |
m_bHot | CXTPButton |
m_bImageDPIScaling | CXTPButton | protected
m_bPushed | CXTPButton |
m_bShowFocus | CXTPButton |
m_bUseVisualStyle | CXTPButton |
m_dwBStyle | CXTPBrowseButton | protected
m_hWndBuddy | CXTPButton |
m_nBorderGap | CXTPButton |
m_nBorderStyle | CXTPButton |
m_nID | CXTPBrowseButton | protected
m_nImageAlignment | CXTPButton |
m_nImageGap | CXTPButton |
m_nMenu | CXTPBrowseButton | protected
m_nPushButtonStyle | CXTPButton |
m_nSubMenuIndx | CXTPBrowseButton | protected
m_nTextImageRelation | CXTPButton |
m_pEditWnd | CXTPBrowseButton | protected
m_pIcon | CXTPButton |
m_pMarkupContext | CXTPButton | protected
m_pTheme | CXTPButton |
m_pToolTipContext | CXTPButton |
m_pUIElement | CXTPButton | protected
m_strTooltip | CXTPButton |
m_szVectorIcon | CXTPButton |
OnDraw(CDC *pDC) | CXTPButton | protectedvirtual
OnDropDown() | CXTPButton | protectedvirtual
RedrawButton(BOOL bUpdateWindow=FALSE) | CXTPButton |
RefreshMetrics() | CXTPButton | protectedvirtual
SetBitmap(CSize size, UINT nID, BOOL bRedraw=TRUE) | CXTPButton | virtual
SetBorderGap(int nBorderGap) | CXTPButton |
SetBorderStyle(XTPGroupBoxBorderStyle style) | CXTPButton |
SetBrowseStyle(DWORD dwxStyle) | CXTPBrowseButton |
SetBuddy(CWnd *pWndBuddy, BOOL bMoveButton=TRUE) | CXTPButton |
SetChecked(BOOL bChecked) | CXTPButton |
SetDpiImageScaling(BOOL bEnable) | CXTPButton | virtual
SetFlatStyle(BOOL bFlatStyle=TRUE) | CXTPButton |
SetIcon(CSize size, HICON hIcon, HICON hIconHot=NULL, BOOL bRedraw=TRUE) | CXTPButton | virtual
SetIcon(CSize size, UINT nID, UINT nHotID=0, BOOL bRedraw=TRUE) | CXTPButton | virtual
SetIcon(CSize size, LPCTSTR lpszID, LPCTSTR lpszHotID=NULL, BOOL bRedraw=TRUE) | CXTPButton | virtual
SetIcon(CSize size, CXTPImageManagerIcon *pIcon, BOOL bRedraw=TRUE) | CXTPButton |
SetIcon(CSize size, const CXTPImageManagerIconHandle &hIconHandle, const CXTPImageManagerIconHandle &hIconHotHandle, BOOL bRedraw=TRUE) | CXTPButton | virtual
SetImageAlignment(DWORD dwAlignment) | CXTPButton |
SetImageGap(int nImageGap) | CXTPButton |
SetPushButtonStyle(XTPPushButtonStyle nPushButtonStyle) | CXTPButton |
SetShowFocus(BOOL bShowFocus) | CXTPButton |
SetTextAlignment(DWORD dwAlignment) | CXTPButton |
SetTextImageRelation(XTPButtonTextImageRelation relation) | CXTPButton |
SetTheme(XTPControlTheme eTheme) | CXTPButton | virtual
SetTheme(CXTPButtonTheme *pPaintManager) | CXTPButton | virtual
SetTooltip(LPCTSTR lpszTooltip) | CXTPButton |
SetUseVisualStyle(BOOL bUseVisualStyle=TRUE) | CXTPButton |
~CXTPBrowseButton() | CXTPBrowseButton | virtual
~CXTPButton() | CXTPButton | virtual


Toolkit Pro: XTPChartDiagram2D.h Source File

  • Source
  • Chart
  • Diagram
  • Diagram2D
XTPChartDiagram2D.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTDIAGRAM2D_H__)
24# define __XTPCHARTDIAGRAM2D_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartAxis;
34class CXTPChartDiagram2DPane;
35class CXTPChartDiagram2DPaneView;
36class CXTPChartDiagram2DAppearance;
37
38typedef CArray<CXTPChartAxis*, CXTPChartAxis*> CXTPChartAxisArray;
39
40enum
41{
42 xtpChartAxisPrimary = 0,
43 xtpChartAxisSecondary = 1,
44};
45
50class _XTP_EXT_CLASS CXTPChartDiagram2D : public CXTPChartDiagram
51{
53 DECLARE_SERIAL(CXTPChartDiagram2D)
55public:
60 CXTPChartDiagram2D();
61
66 virtual ~CXTPChartDiagram2D();
67
68public:
69 BOOL IsRotated() const;
70 void SetRotated(BOOL bRotated);
71
72 BOOL IsAllowZoom() const;
73 void SetAllowZoom(BOOL bAllowZoom);
74
75 BOOL IsAllowScroll() const;
76 void SetAllowScroll(BOOL bAllowScroll);
77
78public:
79 int GetAxisCountX() const;
80 int GetAxisCountY() const;
81
82 void SetAxisCountX(int nAxisCountNewX);
83 void SetAxisCountY(int nAxisCountNewY);
84
85 CXTPChartAxis* GetAxisX(int nIndex) const;
86 CXTPChartAxis* GetAxisY(int nIndex) const;
87
94 CXTPChartAxis* GetAxisX() const;
101 CXTPChartAxis* GetAxisY() const;
102
110 CXTPChartAxis* GetSecondaryAxisX() const;
111
119 CXTPChartAxis* GetSecondaryAxisY() const;
120
127 CXTPChartDiagram2DPane* GetPane() const;
128
135 void SetPane(CXTPChartDiagram2DPane* pPane);
136
144 CXTPChartDiagram2DAppearance* GetAppearance() const;
145
146public:
156 virtual CXTPChartDiagramView* CreateView(CXTPChartDeviceContext* pDC,
157 CXTPChartElementView* pParent);
158
159public:
160 void DoPropExchange(CXTPPropExchange* pPX);
161
162protected:
172 void UpdateLayout(CXTPChartDeviceContext* pDC, CXTPChartDiagramView* pView, CRect rcBounds);
173
174# ifdef _XTP_ACTIVEX
175public:
177 DECLARE_DISPATCH_MAP()
178 DECLARE_INTERFACE_MAP()
179 DECLARE_OLETYPELIB_EX(CXTPChartDiagram2D);
180 DECLARE_OLECREATE_EX(CXTPChartDiagram2D)
181 LPDISPATCH OleGetAxisX();
182 LPDISPATCH OleGetAxisY();
183 LPDISPATCH OleGetSecondaryAxisX();
184 LPDISPATCH OleGetSecondaryAxisY();
185 LPDISPATCH OleGetAxisXByIndex(int nAxisIndex);
186 LPDISPATCH OleGetAxisYByIndex(int nAxisIndex);
187
188 OLE_COLOR OleGetBackgroundColor();
189 void OleSetBackgroundColor(OLE_COLOR clr);
190 OLE_COLOR OleGetBackgroundColor2();
191 void OleSetBackgroundColor2(OLE_COLOR clr);
192 OLE_COLOR OleGetBorderColor();
193 void OleSetBorderColor(OLE_COLOR clr);
194 LPDISPATCH OleGetBackgroundFillStyle();
195
197# endif
198
199protected:
200 CXTPChartAxisArray m_arrAxesX;
201 CXTPChartAxisArray m_arrAxesY;
202
203 CXTPChartDiagram2DPane* m_pPane;
205 BOOL m_bRotated;
206 BOOL m_bAllowZoom;
207 BOOL m_bAllowScroll;
208
209 friend class CXTPChartDiagram2DView;
210};
211
212AFX_INLINE CXTPChartDiagram2DPane* CXTPChartDiagram2D::GetPane() const
213{
214 return m_pPane;
215}
216
217AFX_INLINE BOOL CXTPChartDiagram2D::IsRotated() const
218{
219 return m_bRotated;
220}
221
222AFX_INLINE void CXTPChartDiagram2D::SetRotated(BOOL bRotated)
223{
224 m_bRotated = bRotated;
225 OnChartChanged();
226}
227
228AFX_INLINE BOOL CXTPChartDiagram2D::IsAllowZoom() const
229{
230 return m_bAllowZoom;
231}
232
233AFX_INLINE void CXTPChartDiagram2D::SetAllowZoom(BOOL bAllowZoom)
234{
235 m_bAllowZoom = bAllowZoom;
236}
237
238AFX_INLINE BOOL CXTPChartDiagram2D::IsAllowScroll() const
239{
240 return m_bAllowScroll;
241}
242
243AFX_INLINE void CXTPChartDiagram2D::SetAllowScroll(BOOL bAllowScroll)
244{
245 m_bAllowScroll = bAllowScroll;
246 OnChartChanged();
247}
249# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
250#endif //#if !defined(__XTPCHARTDIAGRAM2D_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartAxis
This abstract base class represents a chart axis as a kind of chart element.
Definition XTPChartAxis.h:86
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartDiagram2DAppearance
This class represents the appearance of diagram in 2D.
Definition XTPChartAppearance.h:292
CXTPChartDiagram2D
This class represents a chart 2D diagram, which is a kind of CXTPChartDiagram.
Definition XTPChartDiagram2D.h:51
CXTPChartDiagram2D::GetAxisY
CXTPChartAxis * GetAxisY() const
Call this function to get the Y axis associated with the 2D diagram.
CXTPChartDiagram2D::DoPropExchange
void DoPropExchange(CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
CXTPChartDiagram2D::SetPane
void SetPane(CXTPChartDiagram2DPane *pPane)
Sets the pane to which this object is associated with.
CXTPChartDiagram2D::GetAppearance
CXTPChartDiagram2DAppearance * GetAppearance() const
Call this function to get the diagram appearance object associated with this object.
CXTPChartDiagram2D::GetPane
CXTPChartDiagram2DPane * GetPane() const
Gets the pane to which this object is associated with.
Definition XTPChartDiagram2D.h:212
CXTPChartDiagram2D::GetSecondaryAxisX
CXTPChartAxis * GetSecondaryAxisX() const
Call this function to get the secondary X axis associated with the 2D diagram if any.
CXTPChartDiagram2D::GetAxisX
CXTPChartAxis * GetAxisX() const
Call this function to get the X axis associated with the 2D diagram.
CXTPChartDiagram2D::~CXTPChartDiagram2D
virtual ~CXTPChartDiagram2D()
Destroys a CXTPChartDiagram2D object, handles cleanup.
CXTPChartDiagram2D::CreateView
virtual CXTPChartDiagramView * CreateView(CXTPChartDeviceContext *pDC, CXTPChartElementView *pParent)
Call this function to create the view of a 2D diagram object.
CXTPChartDiagram2D::m_pPane
CXTPChartDiagram2DPane * m_pPane
The pointer to diagram pane object.
Definition XTPChartDiagram2D.h:203
CXTPChartDiagram2D::UpdateLayout
void UpdateLayout(CXTPChartDeviceContext *pDC, CXTPChartDiagramView *pView, CRect rcBounds)
Call this function to update the layout if there are some changes in the diagram.
CXTPChartDiagram2D::CXTPChartDiagram2D
CXTPChartDiagram2D()
Constructs a CXTPChartDiagram2D object.
CXTPChartDiagram2D::GetSecondaryAxisY
CXTPChartAxis * GetSecondaryAxisY() const
Call this function to get the secondary Y axis associated with the 2D diagram if any.
CXTPChartDiagram2DView
This class represents the view of a chart 2D diagram, which is a kind of CXTPChartDiagramView.
Definition XTPChartDiagram2DView.h:45
CXTPChartDiagram
This class represents a chart diagram, which is a kind of CXTPChartElement.
Definition XTPChartDiagram.h:48
CXTPChartDiagramView
This class represents the view of a chart diagram, which is a kind of CXTPChartElementView.
Definition XTPChartDiagramView.h:49
CXTPChartElement::OnChartChanged
virtual void OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic propertie...
CXTPChartElementView
This class represents the view of a chart element.
Definition XTPChartElementView.h:47
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72


Toolkit Pro: XTPChartRadarDiagram.h Source File

  • Source
  • Chart
  • Diagram
  • RadarDiagram
XTPChartRadarDiagram.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTRADARDIAGRAM_H__)
24# define __XTPCHARTRADARDIAGRAM_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartAxis;
34class CXTPChartRadarDiagramAppearance;
35class CXTPChartDiagram2DAppearance;
36class CXTPChartFillStyle;
37
42enum XTPChartRadarDiagramStyle
43{
44 xtpChartRadarDiagramCircle,
45 xtpChartRadarDiagramPolygon
46};
47
52class _XTP_EXT_CLASS CXTPChartRadarDiagram : public CXTPChartDiagram
53{
55 DECLARE_SERIAL(CXTPChartRadarDiagram)
57public:
62 CXTPChartRadarDiagram();
63
68 virtual ~CXTPChartRadarDiagram();
69
70public:
77 CXTPChartAxis* GetAxisX() const;
84 CXTPChartAxis* GetAxisY() const;
85
93 CXTPChartDiagram2DAppearance* GetAppearance() const;
94
95 CXTPChartFillStyle* GetFillStyle() const;
96
97 CXTPChartColor GetBorderColor() const;
98
99 CXTPChartColor GetActualBackgroundColor() const;
100 CXTPChartColor GetActualBackgroundColor2() const;
101 CXTPChartColor GetActualBorderColor() const;
102
103 CXTPChartFillStyle* GetActualFillStyle() const;
104
105 CXTPChartColor GetBackgroundColor() const;
106 CXTPChartColor GetBackgroundColor2() const;
107
108 void SetBackgroundColor(const CXTPChartColor& color);
109 void SetBackgroundColor2(const CXTPChartColor& color);
110 void SetBorderColor(const CXTPChartColor& color);
111
112 int GetStartAngle() const;
113 void SetStartAngle(int nAngle);
114
115 void SetStyle(XTPChartRadarDiagramStyle style);
116 XTPChartRadarDiagramStyle GetStyle() const;
117
118public:
128 virtual CXTPChartDiagramView* CreateView(CXTPChartDeviceContext* pDC,
129 CXTPChartElementView* pParent);
130
131public:
132 void DoPropExchange(CXTPPropExchange* pPX);
133
134protected:
144 void UpdateLayout(CXTPChartDeviceContext* pDC, CXTPChartDiagramView* pView, CRect rcBounds);
145
146# ifdef _XTP_ACTIVEX
147public:
149 DECLARE_DISPATCH_MAP()
150 DECLARE_INTERFACE_MAP()
151 DECLARE_OLETYPELIB_EX(CXTPChartRadarDiagram);
152 DECLARE_OLECREATE_EX(CXTPChartRadarDiagram)
153 LPDISPATCH OleGetAxisX();
154 LPDISPATCH OleGetAxisY();
155
156 OLE_COLOR OleGetBackgroundColor();
157 void OleSetBackgroundColor(OLE_COLOR clr);
158 OLE_COLOR OleGetBackgroundColor2();
159 void OleSetBackgroundColor2(OLE_COLOR clr);
160 OLE_COLOR OleGetBorderColor();
161 void OleSetBorderColor(OLE_COLOR clr);
162 LPDISPATCH OleGetBackgroundFillStyle();
163
165# endif
166
167protected:
168 CXTPChartAxis* m_pAxisX;
169 CXTPChartAxis* m_pAxisY;
171 CXTPChartFillStyle* m_pFillStyle;
172 CXTPChartColor m_clrBackgroundColor;
173 CXTPChartColor m_clrBackgroundColor2;
174 CXTPChartColor m_clrBorderColor;
175
176 int m_nStartAngle;
177 XTPChartRadarDiagramStyle m_nStyle;
178
179 friend class CXTPChartRadarDiagramView;
180};
181
182AFX_INLINE CXTPChartAxis* CXTPChartRadarDiagram::GetAxisX() const
183{
184 return m_pAxisX;
185}
186AFX_INLINE CXTPChartAxis* CXTPChartRadarDiagram::GetAxisY() const
187{
188 return m_pAxisY;
189}
190AFX_INLINE CXTPChartFillStyle* CXTPChartRadarDiagram::GetFillStyle() const
191{
192 return m_pFillStyle;
193}
194AFX_INLINE void CXTPChartRadarDiagram::SetBackgroundColor(const CXTPChartColor& color)
195{
196 m_clrBackgroundColor = color;
197 OnChartChanged(xtpChartUpdateRedraw);
198}
199AFX_INLINE void CXTPChartRadarDiagram::SetBackgroundColor2(const CXTPChartColor& color)
200{
201 m_clrBackgroundColor2 = color;
202 OnChartChanged(xtpChartUpdateRedraw);
203}
204AFX_INLINE void CXTPChartRadarDiagram::SetBorderColor(const CXTPChartColor& color)
205{
206 m_clrBorderColor = color;
207 OnChartChanged(xtpChartUpdateRedraw);
208}
209AFX_INLINE int CXTPChartRadarDiagram::GetStartAngle() const
210{
211 return m_nStartAngle;
212}
213AFX_INLINE void CXTPChartRadarDiagram::SetStartAngle(int nAngle)
214{
215 m_nStartAngle = nAngle;
216 OnChartChanged();
217}
218AFX_INLINE void CXTPChartRadarDiagram::SetStyle(XTPChartRadarDiagramStyle style)
219{
220 m_nStyle = style;
221 OnChartChanged();
222}
223AFX_INLINE XTPChartRadarDiagramStyle CXTPChartRadarDiagram::GetStyle() const
224{
225 return m_nStyle;
226}
228# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
229#endif //#if !defined(__XTPCHARTRADARDIAGRAM_H__)
xtpChartUpdateRedraw
@ xtpChartUpdateRedraw
Rebuild Command Tree.
Definition XTPChartElement.h:48
XTPChartRadarDiagramStyle
XTPChartRadarDiagramStyle
Radar diagram style.
Definition XTPChartRadarDiagram.h:43
xtpChartRadarDiagramPolygon
@ xtpChartRadarDiagramPolygon
A polygonal radar diagram style.
Definition XTPChartRadarDiagram.h:45
xtpChartRadarDiagramCircle
@ xtpChartRadarDiagramCircle
A circular radar diagram style.
Definition XTPChartRadarDiagram.h:44
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartAxis
This abstract base class represents a chart axis as a kind of chart element.
Definition XTPChartAxis.h:86
CXTPChartColor
This class abstracts a color entity.
Definition XTPChartTypes.h:51
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartDiagram2DAppearance
This class represents the appearance of diagram in 2D.
Definition XTPChartAppearance.h:292
CXTPChartDiagram
This class represents a chart diagram, which is a kind of CXTPChartElement.
Definition XTPChartDiagram.h:48
CXTPChartDiagramView
This class represents the view of a chart diagram, which is a kind of CXTPChartElementView.
Definition XTPChartDiagramView.h:49
CXTPChartElement::OnChartChanged
virtual void OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic propertie...
CXTPChartElementView
This class represents the view of a chart element.
Definition XTPChartElementView.h:47
CXTPChartFillStyle
This class abstracts a fill style used to fill the background of various chart elements.
Definition XTPChartFillStyle.h:43
CXTPChartRadarDiagram
This class represents a chart 2D diagram, which is a kind of CXTPChartDiagram.
Definition XTPChartRadarDiagram.h:53
CXTPChartRadarDiagram::m_pAxisY
CXTPChartAxis * m_pAxisY
The pointer to Y axis object.
Definition XTPChartRadarDiagram.h:169
CXTPChartRadarDiagram::CXTPChartRadarDiagram
CXTPChartRadarDiagram()
Constructs a CXTPChartRadarDiagram object.
CXTPChartRadarDiagram::GetAxisY
CXTPChartAxis * GetAxisY() const
Call this function to get the Y axis associated with the 2D diagram.
Definition XTPChartRadarDiagram.h:186
CXTPChartRadarDiagram::DoPropExchange
void DoPropExchange(CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
CXTPChartRadarDiagram::GetAppearance
CXTPChartDiagram2DAppearance * GetAppearance() const
Call this function to get the diagram appearance object associated with this object.
CXTPChartRadarDiagram::m_pAxisX
CXTPChartAxis * m_pAxisX
The pointer to X axis object.
Definition XTPChartRadarDiagram.h:168
CXTPChartRadarDiagram::CreateView
virtual CXTPChartDiagramView * CreateView(CXTPChartDeviceContext *pDC, CXTPChartElementView *pParent)
Call this function to create the view of the 2D diagram object.
CXTPChartRadarDiagram::GetAxisX
CXTPChartAxis * GetAxisX() const
Call this function to get the X axis associated with the 2D diagram.
Definition XTPChartRadarDiagram.h:182
CXTPChartRadarDiagram::~CXTPChartRadarDiagram
virtual ~CXTPChartRadarDiagram()
Destroys a CXTPChartRadarDiagram object, handles cleanup.
CXTPChartRadarDiagram::UpdateLayout
void UpdateLayout(CXTPChartDeviceContext *pDC, CXTPChartDiagramView *pView, CRect rcBounds)
Call this function to update the layout if there are some changes in the diagram.
CXTPChartRadarDiagramView
This class represents the view of a chart 2D diagram, which is a kind of CXTPChartDiagramView.
Definition XTPChartRadarDiagramView.h:48
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72


Toolkit Pro: XTPComboBoxThemeVisualStudio.h Source File

  • Source
  • Controls
  • Combo
  • Themes
XTPComboBoxThemeVisualStudio.h
Go to the documentation of this file.
1
23#ifndef XTPComboBoxThemeVisualStudio_h__
24# define XTPComboBoxThemeVisualStudio_h__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPComboBoxThemeVisualStudio : public CXTPComboBoxThemeOffice2003
39{
40public:
45 CXTPComboBoxThemeVisualStudio();
46
51 virtual ~CXTPComboBoxThemeVisualStudio();
52
59 virtual void RefreshMetrics(CXTPComboBox* pComboBox);
60};
61
62# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
64#endif // XTPComboBoxThemeVisualStudio_h__
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPComboBox
The CXTPComboBox class provides the functionality of a themed Windows combobox.
Definition XTPComboBox.h:42
CXTPComboBoxThemeOffice2003
Used as the paint manager for a combobox control to render an Office 2003 appearance.
Definition XTPComboBoxThemeOffice2003.h:39
CXTPComboBoxThemeVisualStudio
Used as the paint manager for a combobox control to render a Visual Studio appearance.
Definition XTPComboBoxThemeVisualStudio.h:39
CXTPComboBoxThemeVisualStudio::RefreshMetrics
virtual void RefreshMetrics(CXTPComboBox *pComboBox)
This member function is called by the theme manager to refresh the visual styles used by each compone...
CXTPComboBoxThemeVisualStudio::CXTPComboBoxThemeVisualStudio
CXTPComboBoxThemeVisualStudio()
Default constructor.
CXTPComboBoxThemeVisualStudio::~CXTPComboBoxThemeVisualStudio
virtual ~CXTPComboBoxThemeVisualStudio()
Destructor handles cleanup and deallocation.


Toolkit Pro: Member List

CXTPCalendarCaptionBarTheme Member List

This is the complete list of members for CXTPCalendarCaptionBarTheme, including all inherited members.

AdjustLayout(CDC *pDC, const CRect &rcRect) | CXTPCalendarCaptionBarTheme | virtual
AttachCalendar(CXTPCalendarControl *pCalendar) | CXTPCalendarCaptionBarTheme | virtual
CalcMinRect(CDC *pDC=NULL, BOOL bExactSize=FALSE) | CXTPCalendarCaptionBarTheme | virtual
CXTPCalendarCaptionBarTheme() | CXTPCalendarCaptionBarTheme |
CXTPCalendarWMHandler() | CXTPCalendarWMHandler |
CXTPCmdTarget() | CXTPCmdTarget |
Draw(CDC *pDC) | CXTPCalendarCaptionBarTheme | virtual
DrawBorders(CDC *pDC, const CRect &rcRect, const CRect &rcBorders) | CXTPCalendarCaptionBarTheme | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCalendarCtrl() const | CXTPCalendarCaptionBarTheme | virtual
GetChildHandlerAt(int nIndex) const | CXTPCalendarCaptionBarTheme | protectedvirtual
GetChildHandlersCount() const | CXTPCalendarCaptionBarTheme | protectedvirtual
GetConnection() | CXTPCalendarCaptionBarTheme |
GetExpandButtonCheck() | CXTPCalendarCaptionBarTheme |
GetOwnerWnd() const | CXTPCalendarCaptionBarTheme |
GetPaintManager() const | CXTPCalendarCaptionBarTheme |
GetPaintTheme() const | CXTPCalendarCaptionBarTheme | virtual
GetRect() | CXTPCalendarCaptionBarTheme | virtual
IsDateLabel() const | CXTPCalendarCaptionBarTheme |
IsExpandButton() const | CXTPCalendarCaptionBarTheme |
IsOneLine() | CXTPCalendarCaptionBarTheme | inline
IsScrollDateButtons() const | CXTPCalendarCaptionBarTheme |
IsSwitchViewButtons() const | CXTPCalendarCaptionBarTheme |
m_bIsDateLabel | CXTPCalendarCaptionBarTheme | protected
m_bIsExpandButton | CXTPCalendarCaptionBarTheme | protected
m_bIsOneLine | CXTPCalendarCaptionBarTheme | protected
m_bIsScrollDateButtons | CXTPCalendarCaptionBarTheme | protected
m_bIsSwitchViewButtons | CXTPCalendarCaptionBarTheme | protected
m_bMulticolumnsEnable | CXTPCalendarCaptionBarTheme |
m_bTimelineEnable | CXTPCalendarCaptionBarTheme |
m_dScale | CXTPCalendarCaptionBarTheme |
m_nCheckHotStateTimerID | CXTPCalendarCaptionBarTheme | protected
m_pButtonViewDay | CXTPCalendarCaptionBarTheme | protected
m_pButtonViewMonth | CXTPCalendarCaptionBarTheme | protected
m_pButtonViewWeek | CXTPCalendarCaptionBarTheme | protected
m_pCalendar | CXTPCalendarCaptionBarTheme | protected
m_pCaptionBar | CXTPCalendarCaptionBarTheme |
m_pDateLabel | CXTPCalendarCaptionBarTheme | protected
m_pExpandButton | CXTPCalendarCaptionBarTheme | protected
m_pScrollNextDate | CXTPCalendarCaptionBarTheme | protected
m_pScrollPrevDate | CXTPCalendarCaptionBarTheme | protected
m_pShowFullWeek | CXTPCalendarCaptionBarTheme | protected
m_pShowMcWeek | CXTPCalendarCaptionBarTheme | protected
m_pShowTimeline | CXTPCalendarCaptionBarTheme | protected
m_pShowWorkWeek | CXTPCalendarCaptionBarTheme | protected
m_rcRect | CXTPCalendarCaptionBarTheme | protected
OnBeforeDestroy() | CXTPCalendarCaptionBarTheme | protectedvirtual
OnChar(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnKeyUp(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnLButtonDblClk(UINT nFlags, CPoint point) | CXTPCalendarWMHandler | virtual
OnLButtonDown(UINT nFlags, CPoint point) | CXTPCalendarWMHandler | virtual
OnLButtonUp(UINT nFlags, CPoint point) | CXTPCalendarWMHandler | virtual
OnMouseMove(UINT nFlags, CPoint point) | CXTPCalendarCaptionBarTheme | protectedvirtual
OnPartClick(int nPartID) | CXTPCalendarCaptionBarTheme | virtual
OnPostAdjustLayout() | CXTPCalendarWMHandler | virtual
OnSysKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnTimer(UINT_PTR uTimerID) | CXTPCalendarCaptionBarTheme | protectedvirtual
OnWndMsg(UINT message, WPARAM wParam, LPARAM lParam, LRESULT *pResult) | CXTPCalendarWMHandler | virtual
Redraw(BOOL bUpdateNow=FALSE) | CXTPCalendarCaptionBarTheme | virtual
RefreshMetrics() | CXTPCalendarCaptionBarTheme | virtual
SetDateLabel(BOOL bVisible) | CXTPCalendarCaptionBarTheme |
SetExpandButton(BOOL bVisible) | CXTPCalendarCaptionBarTheme |
SetExpandButtonCheck(BOOL bCheck) | CXTPCalendarCaptionBarTheme |
SetOneLine(BOOL bSet) | CXTPCalendarCaptionBarTheme | inline
SetOwner(CXTPCalendarCaptionBarControl *pCaptionBar) | CXTPCalendarCaptionBarTheme | virtual
SetPaintTheme(XTPCalendarTheme nTheme) | CXTPCalendarCaptionBarTheme | virtual
SetPaintTheme(CXTPCalendarCaptionBarPaintManager *pPaintManager) | CXTPCalendarCaptionBarTheme | virtual
SetScrollDateButtons(BOOL bVisible) | CXTPCalendarCaptionBarTheme |
SetSwitchViewButtons(BOOL bVisible) | CXTPCalendarCaptionBarTheme |
UpdateControlsState() | CXTPCalendarCaptionBarTheme | virtual
~CXTPCalendarCaptionBarTheme() | CXTPCalendarCaptionBarTheme | virtual


Toolkit Pro: Member List

CXTPToolTipContext Member List

This is the complete list of members for CXTPToolTipContext, including all inherited members.

CancelToolTips() | CXTPToolTipContext |
CreateToolTip(CWnd *pOwner) | CXTPToolTipContext | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPToolTipContext() | CXTPToolTipContext |
EnableDpiBitmapScaling(BOOL bEnable=TRUE) | CXTPToolTipContext |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetControlStyle() const | CXTPToolTipContext |
GetFont() | CXTPToolTipContext |
GetMargin() const | CXTPToolTipContext |
GetMaxTipWidth() const | CXTPToolTipContext |
GetStripEllipsisFromToolTip() const | CXTPToolTipContext |
GetStyle() const | CXTPToolTipContext |
GetTipBkColor() const | CXTPToolTipContext |
GetTipTextColor() const | CXTPToolTipContext |
IsBalloonStyleSupported() const | CXTPToolTipContext |
IsDpiBitmapScalingEnabled() const | CXTPToolTipContext |
IsShowTitleAndDescription() const | CXTPToolTipContext |
m_bImageDPIScaling | CXTPToolTipContext | protected
m_bShowImage | CXTPToolTipContext | protected
m_bShowTitleAndDescription | CXTPToolTipContext | protected
m_bStripEllipsisFromToolTip | CXTPToolTipContext | protected
m_clrTipBkColor | CXTPToolTipContext | protected
m_clrTipTextColor | CXTPToolTipContext | protected
m_dwComCtlVersion | CXTPToolTipContext | protected
m_dwStyle | CXTPToolTipContext | protected
m_lastInfo | CXTPToolTipContext | protected
m_nDelayAutoPop | CXTPToolTipContext | protected
m_nDelayInitial | CXTPToolTipContext | protected
m_nDelayReshow | CXTPToolTipContext | protected
m_nIconTitle | CXTPToolTipContext | protected
m_nImageBase | CXTPToolTipContext | protected
m_nImageSize | CXTPToolTipContext | protected
m_nMaxTipWidth | CXTPToolTipContext | protected
m_pModuleContext | CXTPToolTipContext | protectedstatic
m_pToolTip | CXTPToolTipContext | protected
m_rcMargin | CXTPToolTipContext | protected
m_szVectorIconLarge | CXTPToolTipContext | protected
m_szVectorIconSmall | CXTPToolTipContext | protected
m_toolStyle | CXTPToolTipContext | protected
m_xtpFont | CXTPToolTipContext | protected
m_xtpFontTitle | CXTPToolTipContext | protected
ModifyToolTipStyle(DWORD dwRemove, DWORD dwAdd) | CXTPToolTipContext |
SetDelayTime(DWORD dwDuration, int iTime) | CXTPToolTipContext |
SetFont(CFont *pFont) | CXTPToolTipContext |
SetFontIndirect(LOGFONT *lpLogFont) | CXTPToolTipContext |
SetMargin(LPCRECT lprc) | CXTPToolTipContext |
SetMaxTipWidth(int iWidth) | CXTPToolTipContext |
SetStyle(XTPToolTipStyle toolStyle) | CXTPToolTipContext |
SetTipBkColor(COLORREF clr) | CXTPToolTipContext |
SetTipTextColor(COLORREF clr) | CXTPToolTipContext |
SetToolTipCtrl(CXTPToolTipContextToolTip *pToolTipCtrl) | CXTPToolTipContext |
SetVectorIconSize(CSize szSmall, CSize szLarge) | CXTPToolTipContext |
ShowImage(BOOL bShowImage, int nImageBase=0, int nImageSize=ICON_BIG) | CXTPToolTipContext |
ShowTitleAndDescription(BOOL bShowTitleAndDescription=TRUE, int nIconTitle=TTI_INFO) | CXTPToolTipContext |
StripEllipsisFromToolTip(BOOL bSet) | CXTPToolTipContext |
~CXTPToolTipContext() | CXTPToolTipContext | virtual


Toolkit Pro: XTPCalendarWeekViewEvent.h Source File

  • Source
  • Calendar
XTPCalendarWeekViewEvent.h
Go to the documentation of this file.
1
22#if !defined(__XTPCALENDARWEEKVIEWEVENT_H_)
23# define __XTPCALENDARWEEKVIEWEVENT_H_
24
25# if _MSC_VER > 1000
26# pragma once
27# endif // _MSC_VER > 1000
28
29# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
30
31class CXTPCalendarControl;
32class CXTPCalendarWeekView;
33class CXTPCalendarWeekViewDay;
34class CXTPCalendarWeekViewGroup;
35class CXTPCalendarEvent;
36struct XTP_CALENDAR_HITTESTINFO;
37
56class _XTP_EXT_CLASS CXTPCalendarWeekViewEvent
57 : public CXTPCalendarViewEventT<CXTPCalendarWeekViewGroup>
58{
60 DECLARE_DYNAMIC(CXTPCalendarWeekViewEvent)
62public:
67 typedef CXTPCalendarViewEventT<CXTPCalendarWeekViewGroup> TBase;
68
78 CXTPCalendarWeekViewEvent(CXTPCalendarEvent* pEvent, CXTPCalendarWeekViewGroup* pViewGroup);
79
84 virtual ~CXTPCalendarWeekViewEvent();
85
101 virtual BOOL HitTestEx(CPoint point, XTP_CALENDAR_HITTESTINFO* pInfo) const;
102
117 virtual int CalcIconsRect(CRect rc);
118
133 virtual void AdjustLayout(CDC* pDC, const CRect& rcEventMax, int nEventPlaceNumber);
134
149 virtual void AdjustLayout2(CDC* pDC, const CRect& rcEventMax, int nEventPlaceNumber);
150
163 virtual void Draw(CDC* pDC);
164
171 virtual BOOL IsVisible() const;
172
181 CRect GetViewRect();
182
189 BOOL IsShowEndTime() const;
190
197 BOOL IsTimeAsClock() const;
198
207 virtual void OnPostAdjustLayout();
208
209protected:
216 virtual CFont* GetSubjectEditorFont() const;
217};
219
220AFX_INLINE CRect CXTPCalendarWeekViewEvent::GetViewRect()
221{
222 return m_rcEvent;
223}
224
225# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
226#endif // !defined(__XTPCALENDARWEEKVIEWEVENT_H_)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCalendarControl
Class CXTPCalendarControl implements the calendar's view interface.
Definition XTPCalendarControl.h:126
CXTPCalendarEvent
This class represents the data of a single Event used in the Calendar control.
Definition XTPCalendarEvent.h:77
CXTPCalendarViewEvent::m_rcEvent
CRect m_rcEvent
Event view rectangle.
Definition XTPCalendarViewEvent.h:936
CXTPCalendarViewEventT
This class is used to build the ViewEvent layer of the DayView and ViewEvent hierarchies.
Definition XTPCalendarViewEvent.h:1077
CXTPCalendarWeekViewDay
This class represents a day view portion of the CalendarWeekView.
Definition XTPCalendarWeekViewDay.h:131
CXTPCalendarWeekViewEvent
This class represents an event view portion of the CalendarWeekViewDay.
Definition XTPCalendarWeekViewEvent.h:58
CXTPCalendarWeekViewEvent::IsVisible
virtual BOOL IsVisible() const
Call this member function to determine if the "view visible" flag is set.
CXTPCalendarWeekViewEvent::GetViewRect
CRect GetViewRect()
Call this member function to get the day view rectangle coordinates.
Definition XTPCalendarWeekViewEvent.h:220
CXTPCalendarWeekViewEvent::~CXTPCalendarWeekViewEvent
virtual ~CXTPCalendarWeekViewEvent()
Default class destructor.
CXTPCalendarWeekViewEvent::CalcIconsRect
virtual int CalcIconsRect(CRect rc)
This member function is used to adjust rectangles used to draw event view icons.
CXTPCalendarWeekViewEvent::GetSubjectEditorFont
virtual CFont * GetSubjectEditorFont() const
Call this member function to determine the editor window font.
CXTPCalendarWeekViewEvent::AdjustLayout2
virtual void AdjustLayout2(CDC *pDC, const CRect &rcEventMax, int nEventPlaceNumber)
This member function is used to adjust the view's layout depending on the provided rectangle and also...
CXTPCalendarWeekViewEvent::OnPostAdjustLayout
virtual void OnPostAdjustLayout()
This member function is used to perform additional adjustments.
CXTPCalendarWeekViewEvent::Draw
virtual void Draw(CDC *pDC)
This member function is used to draw the view content using the specified device context.
CXTPCalendarWeekViewEvent::TBase
CXTPCalendarViewEventT< CXTPCalendarWeekViewGroup > TBase
Base class type definition.
Definition XTPCalendarWeekViewEvent.h:67
CXTPCalendarWeekViewEvent::AdjustLayout
virtual void AdjustLayout(CDC *pDC, const CRect &rcEventMax, int nEventPlaceNumber)
This member function is used to adjust the view's layout depending on the provided rectangle and also...
CXTPCalendarWeekViewEvent::IsTimeAsClock
BOOL IsTimeAsClock() const
Call this member function to determine the value of the "show time as clock" flag.
CXTPCalendarWeekViewEvent::HitTestEx
virtual BOOL HitTestEx(CPoint point, XTP_CALENDAR_HITTESTINFO *pInfo) const
This member function is used to fill an XTP_CALENDAR_HITTESTINFO structure.
CXTPCalendarWeekViewEvent::IsShowEndTime
BOOL IsShowEndTime() const
Call this member function to determine the value of the "show end time" flag.
CXTPCalendarWeekViewEvent::CXTPCalendarWeekViewEvent
CXTPCalendarWeekViewEvent(CXTPCalendarEvent *pEvent, CXTPCalendarWeekViewGroup *pViewGroup)
Default object constructor.
CXTPCalendarWeekViewGroup
This class represents a single resource view portion of the Calendar Week View.
Definition XTPCalendarWeekViewDay.h:50
CXTPCalendarWeekView
This class implements a specific view portion of the Calendar control - called Week view.
Definition XTPCalendarWeekView.h:54
XTP_CALENDAR_HITTESTINFO
Basic set of parameters transferred from calendar items to mouse handlers.
Definition XTPCalendarDefines.h:856


Toolkit Pro: XTPWinThemeWrapper.h Source File

  • Source
  • Common
XTPWinThemeWrapper.h
Go to the documentation of this file.
1
23#if !defined(__XTPWINTHEMEWRAPPER_H__)
24# define __XTPWINTHEMEWRAPPER_H__
25
26# if _MSC_VER > 1000
27# pragma once
28# endif // _MSC_VER > 1000
29
30# define XTP_INTERNAL_UXTHEME_INCLUSION
31# include "Uxtheme.h"
32# include "SchemaDef.h"
33# include "Tmschema.h"
34
35# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
36
37BEGIN_TM_CLASS_PARTS(XTP_MENU)
38TM_PART(1, XTP_MP, MENUITEM)
39TM_PART(2, XTP_MP, MENUDROPDOWN)
40TM_PART(3, XTP_MP, MENUBARITEM)
41TM_PART(4, XTP_MP, MENUBARDROPDOWN)
42TM_PART(5, XTP_MP, CHEVRON)
43TM_PART(6, XTP_MP, SEPARATOR)
44TM_PART(7, XTP_MP, BARBACKGROUND)
45TM_PART(8, XTP_MP, BARITEM)
46TM_PART(9, XTP_MP, POPUPBACKGROUND)
47TM_PART(10, XTP_MP, POPUPBORDERS)
48TM_PART(11, XTP_MP, POPUPCHECK)
49TM_PART(12, XTP_MP, POPUPCHECKBACKGROUND)
50TM_PART(13, XTP_MP, POPUPGUTTER)
51TM_PART(14, XTP_MP, POPUPITEM)
52TM_PART(15, XTP_MP, POPUPSEPARATOR)
53TM_PART(16, XTP_MP, POPUPSUBMENU)
54TM_PART(17, XTP_MP, SYSTEMCLOSE)
55TM_PART(18, XTP_MP, SYSTEMMAXIMIZE)
56TM_PART(19, XTP_MP, SYSTEMMINIMIZE)
57TM_PART(20, XTP_MP, SYSTEMRESTORE)
58END_TM_CLASS_PARTS()
59
60typedef HANDLE HPAINTBUFFER;
61
62// BP_BUFFERFORMAT
63enum XTP_UX_BUFFERFORMAT
64{
65 XTP_BPBF_COMPATIBLEBITMAP, // Compatible bitmap
66 XTP_BPBF_DIB, // Device-independent bitmap
67 XTP_BPBF_TOPDOWNDIB, // Top-down device-independent bitmap
68 XTP_BPBF_TOPDOWNMONODIB // Top-down monochrome device-independent bitmap
69};
70
71// BP_PAINTPARAMS
72struct XTP_UX_PAINTPARAMS
73{
74 DWORD cbSize;
75 DWORD dwFlags; // BPPF_ flags
76 const RECT* prcExclude;
77 const BLENDFUNCTION* pBlendFunction;
78};
79
80struct XTP_UX_DTTOPTS
81{
82 DWORD dwSize; // size of the struct
83 DWORD dwFlags; // which options have been specified
84 COLORREF crText; // color to use for text fill
85 COLORREF crBorder; // color to use for text outline
86 COLORREF crShadow; // color to use for text shadow
87 int iTextShadowType; // TST_SINGLE or TST_CONTINUOUS
88 POINT ptShadowOffset; // where shadow is drawn (relative to text)
89 int iBorderSize; // Border radius around text
90 int iFontPropId; // Font property to use for the text instead of TMT_FONT
91 int iColorPropId; // Color property to use for the text instead of TMT_TEXTCOLOR
92 int iStateId; // Alternate state id
93 BOOL fApplyOverlay; // Overlay text on top of any text effect?
94 int iGlowSize; // Glow radius around text
95 VOID* pfnDrawTextCallback; // Callback for DrawText
96 LPARAM lParam; // Parameter for callback
97};
98
99struct _DTBGOPTS;
100typedef _DTBGOPTS* PDTBGOPTS;
101
102# define TYPEDEF_WRAPPER_POINTER(val, type, proc) \
103 const int xtpWrapper##proc = val; \
104 const LPCSTR xtpWrapperProc##proc = #proc; \
105 typedef type(__stdcall* PFN##proc)
106
107TYPEDEF_WRAPPER_POINTER(0, HRESULT, DrawThemeBackground)
108(HTHEME, HDC, int, int, const RECT*, const RECT*);
109TYPEDEF_WRAPPER_POINTER(1, HRESULT, CloseThemeData)(HTHEME);
110TYPEDEF_WRAPPER_POINTER(2, HRESULT, SetWindowTheme)(HWND, LPCWSTR, LPCWSTR);
111TYPEDEF_WRAPPER_POINTER(3, void, SetThemeAppProperties)(DWORD);
112TYPEDEF_WRAPPER_POINTER(4, HTHEME, OpenThemeData)(HWND, LPCWSTR);
113TYPEDEF_WRAPPER_POINTER(5, BOOL, IsThemePartDefined)(HTHEME, int, int);
114TYPEDEF_WRAPPER_POINTER(6, BOOL, IsThemeDialogTextureEnabled)(HWND hWnd);
115TYPEDEF_WRAPPER_POINTER(7, BOOL, IsThemeBackgroundPartiallyTransparent)(HTHEME, int, int);
116TYPEDEF_WRAPPER_POINTER(8, BOOL, IsThemeActive)();
117TYPEDEF_WRAPPER_POINTER(9, BOOL, IsAppThemed)();
118TYPEDEF_WRAPPER_POINTER(10, HRESULT, HitTestThemeBackground)
119(HTHEME, HDC, int, int, DWORD, const RECT*, HRGN, POINT, WORD*);
120TYPEDEF_WRAPPER_POINTER(11, HTHEME, GetWindowTheme)(HWND);
121TYPEDEF_WRAPPER_POINTER(12, HRESULT, GetThemeSysString)(HTHEME, int, LPWSTR, int);
122TYPEDEF_WRAPPER_POINTER(13, HRESULT, GetThemeTextMetrics)(HTHEME, HDC, int, int, TEXTMETRIC*);
123TYPEDEF_WRAPPER_POINTER(14, HRESULT, GetThemeTextExtent)
124(HTHEME, HDC, int, int, LPCWSTR, int, DWORD, const RECT*, RECT*);
125TYPEDEF_WRAPPER_POINTER(15, int, GetThemeSysSize)(HTHEME, int);
126TYPEDEF_WRAPPER_POINTER(16, HRESULT, GetThemeSysInt)(HTHEME, int, int*);
127TYPEDEF_WRAPPER_POINTER(17, HRESULT, GetThemeSysFont)(HTHEME, int, LOGFONT*);
128TYPEDEF_WRAPPER_POINTER(18, HBRUSH, GetThemeSysColorBrush)(HTHEME, int);
129TYPEDEF_WRAPPER_POINTER(19, COLORREF, GetThemeSysColor)(HTHEME, int);
130TYPEDEF_WRAPPER_POINTER(20, BOOL, GetThemeSysBool)(HTHEME, int);
131TYPEDEF_WRAPPER_POINTER(21, HRESULT, GetThemeString)(HTHEME, int, int, int, LPWSTR, int);
132TYPEDEF_WRAPPER_POINTER(22, HRESULT, GetThemeRect)(HTHEME, int, int, int, RECT*);
133TYPEDEF_WRAPPER_POINTER(23, HRESULT, GetThemePropertyOrigin)
134(HTHEME, int, int, int, PROPERTYORIGIN*);
135TYPEDEF_WRAPPER_POINTER(24, HRESULT, GetThemePosition)(HTHEME, int, int, int, POINT*);
136TYPEDEF_WRAPPER_POINTER(25, HRESULT, GetThemePartSize)
137(HTHEME, HDC, int, int, RECT*, THEMESIZE, SIZE*);
138TYPEDEF_WRAPPER_POINTER(26, HRESULT, GetThemeMetric)(HTHEME, HDC, int, int, int, int*);
139TYPEDEF_WRAPPER_POINTER(27, HRESULT, GetThemeMargins)(HTHEME, HDC, int, int, int, RECT*, MARGINS*);
140TYPEDEF_WRAPPER_POINTER(28, HRESULT, GetThemeIntList)(HTHEME, int, int, int, INTLIST*);
141TYPEDEF_WRAPPER_POINTER(29, HRESULT, GetThemeInt)(HTHEME, int, int, int, int*);
142TYPEDEF_WRAPPER_POINTER(30, HRESULT, GetThemeFont)(HTHEME, HDC, int, int, int, LOGFONTW*);
143TYPEDEF_WRAPPER_POINTER(31, HRESULT, GetThemeFilename)(HTHEME, int, int, int, LPWSTR, int);
144TYPEDEF_WRAPPER_POINTER(32, HRESULT, GetThemeEnumValue)(HTHEME, int, int, int, int*);
145TYPEDEF_WRAPPER_POINTER(33, HRESULT, GetThemeDocumentationProperty)(LPCWSTR, LPCWSTR, LPWSTR, int);
146TYPEDEF_WRAPPER_POINTER(34, HRESULT, GetThemeColor)(HTHEME, int, int, int, COLORREF*);
147TYPEDEF_WRAPPER_POINTER(35, HRESULT, GetThemeBool)(HTHEME, int, int, int, BOOL*);
148TYPEDEF_WRAPPER_POINTER(36, HRESULT, GetThemeBackgroundRegion)
149(HTHEME, HDC, int, int, const RECT*, HRGN*);
150TYPEDEF_WRAPPER_POINTER(37, HRESULT, GetThemeBackgroundExtent)
151(HTHEME, HDC, int, int, const RECT*, RECT*);
152TYPEDEF_WRAPPER_POINTER(38, HRESULT, GetThemeBackgroundContentRect)
153(HTHEME, HDC, int, int, const RECT*, RECT*);
154TYPEDEF_WRAPPER_POINTER(39, DWORD, ThemeAppProperties)();
155TYPEDEF_WRAPPER_POINTER(40, HRESULT, GetCurrentThemeName)(LPWSTR, int, LPWSTR, int, LPWSTR, int);
156TYPEDEF_WRAPPER_POINTER(41, HRESULT, EnableTheming)(BOOL);
157TYPEDEF_WRAPPER_POINTER(42, HRESULT, EnableThemeDialogTexture)(HWND, DWORD);
158TYPEDEF_WRAPPER_POINTER(43, HRESULT, DrawThemeText)
159(HTHEME, HDC, int, int, LPCWSTR, int, DWORD, DWORD, const RECT*);
160TYPEDEF_WRAPPER_POINTER(44, HRESULT, DrawThemeParentBackground)(HWND, HDC, RECT*);
161TYPEDEF_WRAPPER_POINTER(45, HRESULT, DrawThemeIcon)
162(HTHEME, HDC, int, int, const RECT*, HIMAGELIST, int);
163TYPEDEF_WRAPPER_POINTER(46, HRESULT, DrawThemeEdge)
164(HTHEME, HDC, int, int, const RECT*, UINT, UINT, RECT*);
165TYPEDEF_WRAPPER_POINTER(47, HRESULT, DrawThemeBackgroundEx)
166(HTHEME, HDC, int, int, const RECT*, const PDTBGOPTS);
167TYPEDEF_WRAPPER_POINTER(48, DWORD, GetThemeAppProperties)();
168
169TYPEDEF_WRAPPER_POINTER(49, HPAINTBUFFER, BeginBufferedPaint)
170(HDC, const RECT*, XTP_UX_BUFFERFORMAT, XTP_UX_PAINTPARAMS*, HDC*);
171TYPEDEF_WRAPPER_POINTER(50, HRESULT, EndBufferedPaint)(HPAINTBUFFER, BOOL);
172TYPEDEF_WRAPPER_POINTER(51, HRESULT, DrawThemeTextEx)
173(HTHEME, HDC, int, int, LPCWSTR, int, DWORD, LPRECT, const XTP_UX_DTTOPTS*);
174
175TYPEDEF_WRAPPER_POINTER(52, HRESULT, BufferedPaintSetAlpha)(HPAINTBUFFER, const RECT*, BYTE);
176
177# define XTP_UXTHEME_HANDLE (HMODULE)0x21FFFF1
178
187class _XTP_EXT_CLASS CXTPWinThemeWrapper
188{
189private:
194 class CSharedData
195 {
196 public:
201 CSharedData();
202
203 public:
204 LPVOID m_ptrWrappers[53];
205 HMODULE m_hThemeDll;
206 DWORD m_dwComCtlVersion;
207 };
208
209public:
215 CXTPWinThemeWrapper(BOOL bUseSkinFramework = TRUE);
216
222 virtual ~CXTPWinThemeWrapper();
223
247 void OpenThemeData(HWND hWnd, LPCWSTR pszClassList);
248
256 void CloseThemeData();
257
271 HRESULT DrawThemeBackground(HDC hDC, int iPartID, int iStateID, const RECT* pRect,
272 const RECT* pClipRect);
273
289 HRESULT DrawThemeText(HDC hDC, int iPartID, int iStateID, LPCWSTR pszText, int iCharCount,
290 DWORD dwTextFlags, DWORD dwTextFlags2, const RECT* pRect);
291
306 HRESULT GetThemeBackgroundContentRect(HDC hDC, int iPartID, int iStateID,
307 const RECT* pBoundingRect, RECT* pContentRect);
308
323 HRESULT GetThemeBackgroundExtent(HDC hDC, int iPartID, int iStateID, const RECT* pContentRect,
324 RECT* pExtentRect);
325
339 HRESULT DrawThemeBackgroundEx(HDC hDC, int iPartID, int iStateID, const RECT* pRect,
340 const PDTBGOPTS pOptions);
341
357 HRESULT DrawThemeEdge(HDC hDC, int iPartID, int iStateID, const RECT* pDestRect, UINT uEdge,
358 UINT uFlags, RECT* pContentRect);
359
373 HRESULT DrawThemeIcon(HDC hDC, int iPartID, int iStateID, const RECT* pRect, HIMAGELIST himl,
374 int iImageIndex);
375
387 HRESULT DrawThemeParentBackground(HWND hWnd, HDC hDC, RECT* pRect);
388
406 HRESULT EnableThemeDialogTexture(HWND hWnd, DWORD dwFlags);
407
419 HRESULT EnableTheming(BOOL bEnable);
420
437 HRESULT GetCurrentThemeName(LPWSTR pszThemeFileName, int dwMaxNameChars, LPWSTR pszColorBuff,
438 int cchMaxColorChars, LPWSTR pszSizeBuff, int cchMaxSizeChars);
439
457 DWORD ThemeAppProperties();
458
473 HRESULT GetThemeBackgroundRegion(HDC hDC, int iPartID, int iStateID, const RECT* pRect,
474 HRGN* pRegion);
475
486 HRESULT GetThemeBool(int iPartID, int iStateID, int iPropID, BOOL* pfVal);
487
498 HRESULT GetThemeColor(int iPartID, int iStateID, int iPropID, COLORREF* pColor);
499
515 HRESULT GetThemeDocumentationProperty(LPCWSTR pszThemeName, LPCWSTR pszPropertyName,
516 LPWSTR pszValueBuff, int cchMaxValChars);
517
528 HRESULT GetThemeEnumValue(int iPartID, int iStateID, int iPropID, int* piVal);
529
541 HRESULT GetThemeFilename(int iPartID, int iStateID, int iPropID, LPWSTR pszThemeFilename,
542 int cchMaxBuffChars);
543
556 HRESULT GetThemeFont(HDC hDC, int iPartID, int iStateID, int iPropID, LOGFONTW* pFont);
557
568 HRESULT GetThemeInt(int iPartID, int iStateID, int iPropID, int* piVal);
569
580 HRESULT GetThemeIntList(int iPartID, int iStateID, int iPropID, INTLIST* pIntList);
581
594 HRESULT GetThemeMargins(HDC hDC, int iPartID, int iStateID, int iPropID, RECT* pRect,
595 MARGINS* pMargins);
596
608 HRESULT GetThemeMetric(HDC hDC, int iPartID, int iStateID, int iPropID, int* piVal);
609
622 HRESULT GetThemePartSize(HDC hDC, int iPartID, int iStateID, RECT* pRect, THEMESIZE eSize,
623 SIZE* pSize);
624
635 HRESULT GetThemePosition(int iPartID, int iStateID, int iPropID, POINT* pPoint);
636
648 HRESULT GetThemePropertyOrigin(int iPartID, int iStateID, int iPropID, PROPERTYORIGIN* pOrigin);
649
660 HRESULT GetThemeRect(int iPartID, int iStateID, int iPropID, RECT* pRect);
661
673 HRESULT GetThemeString(int iPartID, int iStateID, int iPropID, LPWSTR pszBuff,
674 int cchMaxBuffChars);
675
684 BOOL GetThemeSysBool(int iBoolID);
685
693 COLORREF GetThemeSysColor(int iColorID);
694
702 HBRUSH GetThemeSysColorBrush(int iColorID);
703
714 HRESULT GetThemeSysFont(int iFontID, LOGFONT* pLF);
715
727 HRESULT GetThemeSysInt(int iIntID, int* piValue);
728
746 int GetThemeSysSize(int iSizeID);
747
761 HRESULT GetThemeSysString(int iStringID, LPWSTR pszStringBuff, int cchMaxStringChars);
762
778 HRESULT GetThemeTextExtent(HDC hDC, int iPartID, int iStateID, LPCWSTR pszText, int iCharCount,
779 DWORD dwTextFlags, const RECT* pBoundingRect, RECT* pExtentRect);
780
792 HRESULT GetThemeTextMetrics(HDC hDC, int iPartID, int iStateID, TEXTMETRIC* ptm);
793
802 HTHEME GetWindowTheme(HWND hWnd);
803
827 HRESULT HitTestThemeBackground(HDC hDC, int iPartID, int iStateID, DWORD dwOptions,
828 const RECT* pRect, HRGN hRgn, POINT ptTest, WORD* pwHitTestCode);
829
839 BOOL IsAppThemed() const;
840
857 BOOL IsThemeActive() const;
858
870 BOOL IsAppThemeReady() const;
871
883 BOOL IsAppThemeActive() const;
884
904 BOOL IsThemeBackgroundPartiallyTransparent(int iPartID, int iStateID);
905
919 BOOL IsThemeDialogTextureEnabled(HWND hWnd);
920
938 BOOL IsThemePartDefined(int iPartID, int iStateID);
939
945 void SetThemeAppProperties(DWORD dwFlags);
946
972 HRESULT SetWindowTheme(HWND hWnd, LPCWSTR pszSubAppName, LPCWSTR pszSubIdList);
973
981 BOOL ThemeDataOpen() const;
982
988 DWORD GetThemeAppProperties();
989
991 static BOOL m_bDllDetached;
992
993 // for compatibility with older versions.
994 void CloseTheme()
995 {
996 CloseThemeData();
997 }
998 void OpenTheme(HWND hWnd, LPCWSTR pszClassList)
999 {
1000 OpenThemeData(hWnd, pszClassList);
1001 }
1002 void DrawBackground(HDC hdc, int iPartId, int iStateId, const RECT* pRect,
1003 const RECT* pClipRect)
1004 {
1005 DrawThemeBackground(hdc, iPartId, iStateId, pRect, pClipRect);
1006 }
1019 HRESULT BufferedPaintSetAlpha(HPAINTBUFFER hBufferedPaint, const RECT* prc, BYTE alpha);
1020
1040 HPAINTBUFFER BeginBufferedPaint(HDC hdcTarget, const RECT* prcTarget,
1041 XTP_UX_BUFFERFORMAT dwFormat, XTP_UX_PAINTPARAMS* pPaintParams,
1042 HDC* phdc);
1043
1054 void EndBufferedPaint(HPAINTBUFFER hBufferedPaint, BOOL fUpdateTarget);
1055
1071 HRESULT DrawThemeTextEx(HDC hdc, int iPartId, int iStateId, LPCWSTR pszText, int cchText,
1072 DWORD dwTextFlags, LPRECT pRect, const XTP_UX_DTTOPTS* pOptions);
1073
1080 void SetThemeWrapperPtr(int nThemeWrapper, LPVOID lpWrapperPtr);
1081
1082 void CreateSharedData();
1083
1084private:
1085 void ReloadLibrary() const;
1086
1087private:
1088 HTHEME m_hTheme;
1089 BOOL m_bUseSkinFramework;
1090
1091 CSharedData* m_pSharedData;
1092 CSharedData& GetSharedData() const;
1093};
1094
1097struct XTP_DWM_MARGINS
1098{
1099 int cxLeftWidth;
1100 int cxRightWidth;
1101 int cyTopHeight;
1102 int cyBottomHeight;
1103};
1104
1105TYPEDEF_WRAPPER_POINTER(0, HRESULT, DwmDefWindowProc)
1106(HWND hWnd, UINT msg, WPARAM wParam, LPARAM lParam, LRESULT* plResult);
1107TYPEDEF_WRAPPER_POINTER(1, HRESULT, DwmIsCompositionEnabled)(BOOL*);
1108TYPEDEF_WRAPPER_POINTER(2, HRESULT, DwmExtendFrameIntoClientArea)(HWND, const XTP_DWM_MARGINS*);
1109
1114class _XTP_EXT_CLASS CXTPWinDwmWrapper
1115{
1116private:
1121 class CSharedData
1122 {
1123 public:
1128 CSharedData();
1129
1130 public:
1131 LPVOID m_ptrWrappers[3];
1132 HMODULE m_hDwmDll;
1133 };
1134
1135public:
1136 CXTPWinDwmWrapper();
1137 ~CXTPWinDwmWrapper();
1138
1139public:
1140 HRESULT DefWindowProc(HWND hWnd, UINT msg, WPARAM wParam, LPARAM lParam, LRESULT* plResult);
1141 BOOL IsCompositionEnabled();
1142 HRESULT ExtendFrameIntoClientArea(HWND hWnd, int cxLeftWidth, int cyTopHeight, int cxRightWidth,
1143 int cyBottomHeight);
1144
1145public:
1146 void LogicalToPhysicalPoint(HWND hWnd, LPPOINT lpPoint);
1147 void SetProcessDPIAware();
1148
1149private:
1150 CSharedData& GetSharedData() const;
1151};
1152
1156# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
1158#endif // !defined(__XTPWINTHEMEWRAPPER_H__)
pPoint
const CPoint * pPoint
return 0 or xtpCalendarHitTestDayExpandButton
Definition XTPCalendarThemeOffice2007.h:150
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPWinThemeWrapper
The CXTPWinThemeWrapper class wraps the UxTheme.dll visual theme API.
Definition XTPWinThemeWrapper.h:188
CXTPWinThemeWrapper::GetThemeRect
HRESULT GetThemeRect(int iPartID, int iStateID, int iPropID, RECT *pRect)
Get the value for the specified RECT property.
CXTPWinThemeWrapper::IsThemeActive
BOOL IsThemeActive() const
Can be used to test if a system theme is active for the current user session.
CXTPWinThemeWrapper::DrawThemeTextEx
HRESULT DrawThemeTextEx(HDC hdc, int iPartId, int iStateId, LPCWSTR pszText, int cchText, DWORD dwTextFlags, LPRECT pRect, const XTP_UX_DTTOPTS *pOptions)
Draws the text using the theme-specified color and font for the "iPartID" and "iStateID".
CXTPWinThemeWrapper::IsThemeBackgroundPartiallyTransparent
BOOL IsThemeBackgroundPartiallyTransparent(int iPartID, int iStateID)
Returns TRUE if the theme specified background for the part/ state has transparent pieces or alpha-bl...
CXTPWinThemeWrapper::DrawThemeText
HRESULT DrawThemeText(HDC hDC, int iPartID, int iStateID, LPCWSTR pszText, int iCharCount, DWORD dwTextFlags, DWORD dwTextFlags2, const RECT *pRect)
Draws the text using the theme-specified color and font for the "iPartID" and "iStateID".
CXTPWinThemeWrapper::GetThemeFont
HRESULT GetThemeFont(HDC hDC, int iPartID, int iStateID, int iPropID, LOGFONTW *pFont)
Get the value for the specified font property.
CXTPWinThemeWrapper::GetWindowTheme
HTHEME GetWindowTheme(HWND hWnd)
If window is themed, returns its most recent HTHEME from OpenThemeData() - Otherwise,...
CXTPWinThemeWrapper::GetCurrentThemeName
HRESULT GetCurrentThemeName(LPWSTR pszThemeFileName, int dwMaxNameChars, LPWSTR pszColorBuff, int cchMaxColorChars, LPWSTR pszSizeBuff, int cchMaxSizeChars)
Get the name of the current theme in-use.
CXTPWinThemeWrapper::SetWindowTheme
HRESULT SetWindowTheme(HWND hWnd, LPCWSTR pszSubAppName, LPCWSTR pszSubIdList)
Redirects an existing Window to use a different section of the current theme information than its cla...
CXTPWinThemeWrapper::GetThemePropertyOrigin
HRESULT GetThemePropertyOrigin(int iPartID, int iStateID, int iPropID, PROPERTYORIGIN *pOrigin)
Searches for the specified theme property and sets "pOrigin" to indicate where it was found (or not f...
CXTPWinThemeWrapper::GetThemeDocumentationProperty
HRESULT GetThemeDocumentationProperty(LPCWSTR pszThemeName, LPCWSTR pszPropertyName, LPWSTR pszValueBuff, int cchMaxValChars)
Get the value for the specified property name from the [documentation] section of the themes....
CXTPWinThemeWrapper::GetThemeSysInt
HRESULT GetThemeSysInt(int iIntID, int *piValue)
Get the value of specified System int.
CXTPWinThemeWrapper::GetThemeBool
HRESULT GetThemeBool(int iPartID, int iStateID, int iPropID, BOOL *pfVal)
Get the value for the specified BOOL property.
CXTPWinThemeWrapper::IsAppThemed
BOOL IsAppThemed() const
Reports whether the current application's user interface displays using visual styles.
CXTPWinThemeWrapper::EnableThemeDialogTexture
HRESULT EnableThemeDialogTexture(HWND hWnd, DWORD dwFlags)
Enables/disables dialog background theme.
CXTPWinThemeWrapper::ThemeDataOpen
BOOL ThemeDataOpen() const
Call this member function to determine if OpenThemeData() was called to open theme information for a ...
CXTPWinThemeWrapper::GetThemeTextMetrics
HRESULT GetThemeTextMetrics(HDC hDC, int iPartID, int iStateID, TEXTMETRIC *ptm)
Returns info about the theme-specified font for the part/ state passed in.
CXTPWinThemeWrapper::GetThemeSysString
HRESULT GetThemeSysString(int iStringID, LPWSTR pszStringBuff, int cchMaxStringChars)
Get the value of specified System string metric.
CXTPWinThemeWrapper::GetThemeSysFont
HRESULT GetThemeSysFont(int iFontID, LOGFONT *pLF)
Get the LOGFONT for the specified System font.
CXTPWinThemeWrapper::IsAppThemeActive
BOOL IsAppThemeActive() const
Checks whether the current application's user interface displays using visual styles and the theme is...
CXTPWinThemeWrapper::HitTestThemeBackground
HRESULT HitTestThemeBackground(HDC hDC, int iPartID, int iStateID, DWORD dwOptions, const RECT *pRect, HRGN hRgn, POINT ptTest, WORD *pwHitTestCode)
Returns a HitTestCode (a subset of the values returned by WM_NCHITTEST) for the point "ptTest" within...
CXTPWinThemeWrapper::DrawThemeBackgroundEx
HRESULT DrawThemeBackgroundEx(HDC hDC, int iPartID, int iStateID, const RECT *pRect, const PDTBGOPTS pOptions)
Draws the theme-specified border and fill for the "iPartId" and "iStateId".
CXTPWinThemeWrapper::~CXTPWinThemeWrapper
virtual ~CXTPWinThemeWrapper()
Destroys a CXTPWinThemeWrapper object, handles cleanup and deallocation.
CXTPWinThemeWrapper::CXTPWinThemeWrapper
CXTPWinThemeWrapper(BOOL bUseSkinFramework=TRUE)
Constructs a CXTPWinThemeWrapper object.
CXTPWinThemeWrapper::GetThemePartSize
HRESULT GetThemePartSize(HDC hDC, int iPartID, int iStateID, RECT *pRect, THEMESIZE eSize, SIZE *pSize)
Returns the specified size of the theme part.
CXTPWinThemeWrapper::GetThemeBackgroundRegion
HRESULT GetThemeBackgroundRegion(HDC hDC, int iPartID, int iStateID, const RECT *pRect, HRGN *pRegion)
Computes the region for a regular or partially transparent theme-specified background that is bound b...
CXTPWinThemeWrapper::SetThemeAppProperties
void SetThemeAppProperties(DWORD dwFlags)
Sets the flags that control theming within the app.
CXTPWinThemeWrapper::DrawThemeEdge
HRESULT DrawThemeEdge(HDC hDC, int iPartID, int iStateID, const RECT *pDestRect, UINT uEdge, UINT uFlags, RECT *pContentRect)
Similar to the DrawEdge() API, but uses part colors and is high-DPI aware.
CXTPWinThemeWrapper::GetThemeSysBool
BOOL GetThemeSysBool(int iBoolID)
Get the boolean value of specified System metric.
CXTPWinThemeWrapper::GetThemeFilename
HRESULT GetThemeFilename(int iPartID, int iStateID, int iPropID, LPWSTR pszThemeFilename, int cchMaxBuffChars)
Get the value for the specified FILENAME property.
CXTPWinThemeWrapper::DrawThemeBackground
HRESULT DrawThemeBackground(HDC hDC, int iPartID, int iStateID, const RECT *pRect, const RECT *pClipRect)
Draws the theme-specified border and fill for the "iPartId" and "iStateId".
CXTPWinThemeWrapper::GetThemeMetric
HRESULT GetThemeMetric(HDC hDC, int iPartID, int iStateID, int iPropID, int *piVal)
Get the value for the specified metric/size property.
CXTPWinThemeWrapper::GetThemeAppProperties
DWORD GetThemeAppProperties()
CXTPWinThemeWrapper::GetThemeSysColorBrush
HBRUSH GetThemeSysColorBrush(int iColorID)
Get the brush for the specified System color.
CXTPWinThemeWrapper::DrawThemeParentBackground
HRESULT DrawThemeParentBackground(HWND hWnd, HDC hDC, RECT *pRect)
Used by partially-transparent or alpha-blended child controls to draw the part of their parent that t...
CXTPWinThemeWrapper::GetThemeInt
HRESULT GetThemeInt(int iPartID, int iStateID, int iPropID, int *piVal)
Get the value for the specified int property.
CXTPWinThemeWrapper::GetThemeColor
HRESULT GetThemeColor(int iPartID, int iStateID, int iPropID, COLORREF *pColor)
Get the value for the specified COLOR property.
CXTPWinThemeWrapper::DrawThemeIcon
HRESULT DrawThemeIcon(HDC hDC, int iPartID, int iStateID, const RECT *pRect, HIMAGELIST himl, int iImageIndex)
Draws an image within an imagelist based on a (possible) theme-defined effect.
CXTPWinThemeWrapper::GetThemeString
HRESULT GetThemeString(int iPartID, int iStateID, int iPropID, LPWSTR pszBuff, int cchMaxBuffChars)
Get the value for the specified string property.
CXTPWinThemeWrapper::CloseThemeData
void CloseThemeData()
Closes the theme data handle.
CXTPWinThemeWrapper::GetThemeBackgroundContentRect
HRESULT GetThemeBackgroundContentRect(HDC hDC, int iPartID, int iStateID, const RECT *pBoundingRect, RECT *pContentRect)
Gets the size of the content for the theme-defined background.
CXTPWinThemeWrapper::ThemeAppProperties
DWORD ThemeAppProperties()
Retrieves the property flags that control how visual styles are applied in the current application.
CXTPWinThemeWrapper::IsThemePartDefined
BOOL IsThemePartDefined(int iPartID, int iStateID)
Returns TRUE if the theme has defined parameters for the specified "iPartID" and "iStateID".
CXTPWinThemeWrapper::SetThemeWrapperPtr
void SetThemeWrapperPtr(int nThemeWrapper, LPVOID lpWrapperPtr)
This method is used to set user-defined wrappers.
CXTPWinThemeWrapper::GetThemeTextExtent
HRESULT GetThemeTextExtent(HDC hDC, int iPartID, int iStateID, LPCWSTR pszText, int iCharCount, DWORD dwTextFlags, const RECT *pBoundingRect, RECT *pExtentRect)
Calculates the size/location of the specified text when rendered in the Theme Font.
CXTPWinThemeWrapper::GetThemeIntList
HRESULT GetThemeIntList(int iPartID, int iStateID, int iPropID, INTLIST *pIntList)
Get the value for the specified INTLIST struct.
CXTPWinThemeWrapper::EndBufferedPaint
void EndBufferedPaint(HPAINTBUFFER hBufferedPaint, BOOL fUpdateTarget)
Completes a buffered paint operation and frees the associated buffered paint handle.
CXTPWinThemeWrapper::IsAppThemeReady
BOOL IsAppThemeReady() const
Call this member function to determine if the application should display Windows XP themes.
CXTPWinThemeWrapper::BufferedPaintSetAlpha
HRESULT BufferedPaintSetAlpha(HPAINTBUFFER hBufferedPaint, const RECT *prc, BYTE alpha)
Sets the alpha to a specified value in a given rectangle.
CXTPWinThemeWrapper::GetThemeMargins
HRESULT GetThemeMargins(HDC hDC, int iPartID, int iStateID, int iPropID, RECT *pRect, MARGINS *pMargins)
Get the value for the specified MARGINS property.
CXTPWinThemeWrapper::EnableTheming
HRESULT EnableTheming(BOOL bEnable)
Enables or disables theming for the current user in the current and future sessions.
CXTPWinThemeWrapper::IsThemeDialogTextureEnabled
BOOL IsThemeDialogTextureEnabled(HWND hWnd)
Reports whether the dialog supports background texturing.
CXTPWinThemeWrapper::GetThemeBackgroundExtent
HRESULT GetThemeBackgroundExtent(HDC hDC, int iPartID, int iStateID, const RECT *pContentRect, RECT *pExtentRect)
Calculates the size/location of the theme-specified background based on the "pContentRect".
CXTPWinThemeWrapper::GetThemeSysColor
COLORREF GetThemeSysColor(int iColorID)
Get the value of the specified System color.
CXTPWinThemeWrapper::GetThemeSysSize
int GetThemeSysSize(int iSizeID)
Get the value of the specified System size metric.
CXTPWinThemeWrapper::BeginBufferedPaint
HPAINTBUFFER BeginBufferedPaint(HDC hdcTarget, const RECT *prcTarget, XTP_UX_BUFFERFORMAT dwFormat, XTP_UX_PAINTPARAMS *pPaintParams, HDC *phdc)
Begins a buffered paint operation.
CXTPWinThemeWrapper::GetThemePosition
HRESULT GetThemePosition(int iPartID, int iStateID, int iPropID, POINT *pPoint)
Get the value for the specified position property.
CXTPWinThemeWrapper::OpenThemeData
void OpenThemeData(HWND hWnd, LPCWSTR pszClassList)
Open the theme data for the specified HWND and semi-colon separated list of class names.
CXTPWinThemeWrapper::GetThemeEnumValue
HRESULT GetThemeEnumValue(int iPartID, int iStateID, int iPropID, int *piVal)
Get the value for the specified ENUM property.


Toolkit Pro: XTPChartDiagram2DSeriesStyle.h Source File

  • Source
  • Chart
  • Diagram
  • Diagram2D
XTPChartDiagram2DSeriesStyle.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTDIAGRAM2DSERIESSTYLE_H__)
24# define __XTPCHARTDIAGRAM2DSERIESSTYLE_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartSeriesView;
34class CXTPChartMarker;
35
46class _XTP_EXT_CLASS CXTPChartDiagram2DSeriesStyle : public CXTPChartSeriesStyle
47{
49 DECLARE_DYNAMIC(CXTPChartDiagram2DSeriesStyle)
51public:
56 CXTPChartDiagram2DSeriesStyle();
57
62 virtual ~CXTPChartDiagram2DSeriesStyle();
63
64public:
65 void SetSecondaryAxisX(BOOL bSecondaryAxis);
66 BOOL IsSecondaryAxisX() const;
67
68 void SetSecondaryAxisY(BOOL bSecondaryAxis);
69 BOOL IsSecondaryAxisY() const;
70
71 void SetAxisIndexX(int nAxisIndexX);
72 int GetAxisIndexX() const;
73
74 void SetAxisIndexY(int nAxisIndexY);
75 int GetAxisIndexY() const;
76
77public:
78 void DoPropExchange(CXTPPropExchange* pPX);
79
80public:
88 virtual CXTPChartDiagram* CreateDiagram();
89
99 virtual BOOL IsStyleDiagram(CXTPChartDiagram* pDiagram) const;
100
101# ifdef _XTP_ACTIVEX
102public:
104 DECLARE_DISPATCH_MAP()
105 DECLARE_INTERFACE_MAP()
106 DECLARE_OLETYPELIB_EX(CXTPChartDiagram2DSeriesStyle);
107
109# endif
110
111protected:
112 BOOL m_bSecondaryAxisX;
113 BOOL m_bSecondaryAxisY;
114 int m_nAxisIndexX;
115 int m_nAxisIndexY;
116};
117
118AFX_INLINE void CXTPChartDiagram2DSeriesStyle::SetSecondaryAxisX(BOOL bSecondaryAxis)
119{
120 if (m_bSecondaryAxisX != bSecondaryAxis)
121 {
122 m_bSecondaryAxisX = bSecondaryAxis;
123 OnChartChanged();
124 }
125}
126AFX_INLINE BOOL CXTPChartDiagram2DSeriesStyle::IsSecondaryAxisX() const
127{
128 return m_bSecondaryAxisX;
129}
130
131AFX_INLINE void CXTPChartDiagram2DSeriesStyle::SetSecondaryAxisY(BOOL bSecondaryAxis)
132{
133 if (m_bSecondaryAxisY != bSecondaryAxis)
134 {
135 m_bSecondaryAxisY = bSecondaryAxis;
136 OnChartChanged();
137 }
138}
139AFX_INLINE BOOL CXTPChartDiagram2DSeriesStyle::IsSecondaryAxisY() const
140{
141 return m_bSecondaryAxisY;
142}
143
144AFX_INLINE void CXTPChartDiagram2DSeriesStyle::SetAxisIndexX(int nAxisIndexX)
145{
146 if (nAxisIndexX > 0 && nAxisIndexX != m_nAxisIndexX)
147 {
148 m_nAxisIndexX = nAxisIndexX;
149 OnChartChanged();
150 }
151}
152AFX_INLINE int CXTPChartDiagram2DSeriesStyle::GetAxisIndexX() const
153{
154 if (m_bSecondaryAxisX == FALSE)
155 return 0;
156
157 return m_nAxisIndexX;
158}
159
160AFX_INLINE void CXTPChartDiagram2DSeriesStyle::SetAxisIndexY(int nAxisIndexY)
161{
162 if (nAxisIndexY > 0 && nAxisIndexY != m_nAxisIndexY)
163 {
164 m_nAxisIndexY = nAxisIndexY;
165 OnChartChanged();
166 }
167}
168AFX_INLINE int CXTPChartDiagram2DSeriesStyle::GetAxisIndexY() const
169{
170 if (m_bSecondaryAxisY == FALSE)
171 return 0;
172
173 return m_nAxisIndexY;
174}
176# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
177#endif //#if !defined(__XTPCHARTDIAGRAM2DSERIESSTYLE_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartDiagram2DSeriesStyle
This class represents a line series style, which is a kind of CXTPChartSeriesStyle.
Definition XTPChartDiagram2DSeriesStyle.h:47
CXTPChartDiagram2DSeriesStyle::CXTPChartDiagram2DSeriesStyle
CXTPChartDiagram2DSeriesStyle()
Constructs a CXTPChartDiagram2DSeriesStyle object.
CXTPChartDiagram2DSeriesStyle::DoPropExchange
void DoPropExchange(CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
CXTPChartDiagram2DSeriesStyle::~CXTPChartDiagram2DSeriesStyle
virtual ~CXTPChartDiagram2DSeriesStyle()
Destroys a CXTPChartDiagram2DSeriesStyle object, handles cleanup.
CXTPChartDiagram2DSeriesStyle::IsStyleDiagram
virtual BOOL IsStyleDiagram(CXTPChartDiagram *pDiagram) const
Call this function to check whether the chart diagram object passed is a kind of 2D diagram (CXTPChar...
CXTPChartDiagram2DSeriesStyle::CreateDiagram
virtual CXTPChartDiagram * CreateDiagram()
Call this function to create the diagram for this series.
CXTPChartDiagram2DSeriesStyle::m_nAxisIndexY
int m_nAxisIndexY
Holds index of secondary axisY, used when m_bSecondaryAxisY is TRUE.
Definition XTPChartDiagram2DSeriesStyle.h:115
CXTPChartDiagram2DSeriesStyle::m_nAxisIndexX
int m_nAxisIndexX
Holds index of secondary axisX, used when m_bSecondaryAxisX is TRUE.
Definition XTPChartDiagram2DSeriesStyle.h:114
CXTPChartDiagram
This class represents a chart diagram, which is a kind of CXTPChartElement.
Definition XTPChartDiagram.h:48
CXTPChartElement::OnChartChanged
virtual void OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic propertie...
CXTPChartMarker
This class abstracts a marker used in marking the points in a point series style chart.
Definition XTPChartMarker.h:64
CXTPChartSeriesStyle
CXTPChartSeriesStyle is a CXTPChartElement derived class.
Definition XTPChartSeriesStyle.h:49
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72


Toolkit Pro: XTPDockingPaneThemeVisualStudio2005Beta2.h Source File

  • Source
  • DockingPane
  • Themes
XTPDockingPaneThemeVisualStudio2005Beta2.h
Go to the documentation of this file.
1
23#if !defined(__XTPDOCKINGPANETHEMEVISUALSTUDIO2005BETA2_H__)
24# define __XTPDOCKINGPANETHEMEVISUALSTUDIO2005BETA2_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
41class _XTP_EXT_CLASS CXTPDockingPaneVisualStudio2005Beta2Theme
42 : public CXTPDockingPaneVisualStudio2005Beta1Theme
43{
44public:
49 CXTPDockingPaneVisualStudio2005Beta2Theme();
50
55 void RefreshMetrics();
56
67 virtual COLORREF FillCaptionPart(CDC* pDC, CXTPDockingPaneBase* pPane, CRect rcCaption,
68 BOOL bActive, BOOL bVertical);
69
70protected:
71 COLORREF m_clrCaptionBorder;
72};
73
74# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
76#endif // !defined(__XTPDOCKINGPANETHEMEVISUALSTUDIO2005BETA2_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPDockingPaneBase
CXTPDockingPaneBase is a standalone class.
Definition XTPDockingPaneBase.h:69
CXTPDockingPaneVisualStudio2005Beta1Theme
CXTPDockingPaneVisualStudio2005Beta1Theme is CXTPDockingPaneVisualStudio2003Theme derived class that ...
Definition XTPDockingPaneThemeVisualStudio2005Beta1.h:43
CXTPDockingPaneVisualStudio2005Beta2Theme
CXTPDockingPaneVisualStudio2005Beta2Theme is CXTPDockingPaneVisualStudio2005Beta1Theme derived class ...
Definition XTPDockingPaneThemeVisualStudio2005Beta2.h:43
CXTPDockingPaneVisualStudio2005Beta2Theme::CXTPDockingPaneVisualStudio2005Beta2Theme
CXTPDockingPaneVisualStudio2005Beta2Theme()
Constructs a CXTPDockingPaneVisualStudio2005Beta2Theme object.
CXTPDockingPaneVisualStudio2005Beta2Theme::FillCaptionPart
virtual COLORREF FillCaptionPart(CDC *pDC, CXTPDockingPaneBase *pPane, CRect rcCaption, BOOL bActive, BOOL bVertical)
Draws the background of the pane caption.
CXTPDockingPaneVisualStudio2005Beta2Theme::RefreshMetrics
void RefreshMetrics()
This method is called to refresh the visual metrics of the pane.
CXTPDockingPaneVisualStudio2005Beta2Theme::m_clrCaptionBorder
COLORREF m_clrCaptionBorder
Color used to draw the border of the pane caption.
Definition XTPDockingPaneThemeVisualStudio2005Beta2.h:71


Toolkit Pro: Member List

CXTPCalendarThemeCustomizableXValueT< _TValue, _TValueRef > Member List

This is the complete list of members for CXTPCalendarThemeCustomizableXValueT< _TValue, _TValueRef >, including all inherited members.

CopySettings(const CXTPCalendarThemeCustomizableXValueT< _TValue, _TValueRef > &refSrc) | CXTPCalendarThemeCustomizableXValueT< _TValue, _TValueRef > | inline
CXTPCalendarThemeCustomizableXValueT() | CXTPCalendarThemeCustomizableXValueT< _TValue, _TValueRef > | inline
DoDestroy(_TValue &refValue) | CXTPCalendarThemeCustomizableXValueT< _TValue, _TValueRef > | inlinevirtual
DoPropExchange(CXTPPropExchange *pPX, LPCTSTR pcszPropName)=0 | CXTPCalendarThemeCustomizableXValueT< _TValue, _TValueRef > | pure virtual
GetStandardValue() const | CXTPCalendarThemeCustomizableXValueT< _TValue, _TValueRef > | inlinevirtual
GetValue() const | CXTPCalendarThemeCustomizableXValueT< _TValue, _TValueRef > | inlinevirtual
GetValueX() const | CXTPCalendarThemeCustomizableXValueT< _TValue, _TValueRef > | inlinevirtual
IsCustomValue() const | CXTPCalendarThemeCustomizableXValueT< _TValue, _TValueRef > | inlinevirtual
IsDefaultValue() const | CXTPCalendarThemeCustomizableXValueT< _TValue, _TValueRef > | inlinevirtual
IsStandardValue() const | CXTPCalendarThemeCustomizableXValueT< _TValue, _TValueRef > | inlinevirtual
m_bAutoDestroy_Custom | CXTPCalendarThemeCustomizableXValueT< _TValue, _TValueRef > | protected
m_bAutoDestroy_Standard | CXTPCalendarThemeCustomizableXValueT< _TValue, _TValueRef > | protected
m_bIsCustomSet | CXTPCalendarThemeCustomizableXValueT< _TValue, _TValueRef > | protected
m_bIsStandardSet | CXTPCalendarThemeCustomizableXValueT< _TValue, _TValueRef > | protected
m_ValueCustom | CXTPCalendarThemeCustomizableXValueT< _TValue, _TValueRef > | protected
m_ValueStandard | CXTPCalendarThemeCustomizableXValueT< _TValue, _TValueRef > | protected
operator _TValueRef() const | CXTPCalendarThemeCustomizableXValueT< _TValue, _TValueRef > | inline
operator=(_TValueRef refValue) | CXTPCalendarThemeCustomizableXValueT< _TValue, _TValueRef > | inline
Serialize(CArchive &ar) | CXTPCalendarThemeCustomizableXValueT< _TValue, _TValueRef > | inlinevirtual
SetCustomValue(_TValueRef refValue, BOOL bAutoDestroy) | CXTPCalendarThemeCustomizableXValueT< _TValue, _TValueRef > | inlinevirtual
SetCustomValue(_TValueRef refValue) | CXTPCalendarThemeCustomizableXValueT< _TValue, _TValueRef > | inlinevirtual
SetDefaultValue() | CXTPCalendarThemeCustomizableXValueT< _TValue, _TValueRef > | inlinevirtual
SetStandardValue(_TValueRef refValue, BOOL bAutoDestroy) | CXTPCalendarThemeCustomizableXValueT< _TValue, _TValueRef > | inlinevirtual
SetStandardValue(_TValueRef refValue) | CXTPCalendarThemeCustomizableXValueT< _TValue, _TValueRef > | inlinevirtual
~CXTPCalendarThemeCustomizableXValueT() | CXTPCalendarThemeCustomizableXValueT< _TValue, _TValueRef > | inlinevirtual


Toolkit Pro: Member List

CXTPScrollBarThemeFlat Member List

This is the complete list of members for CXTPScrollBarThemeFlat, including all inherited members.

CalcHScroll(CXTPScrollBase *pScroll, XTPScrollMetricsH *pHScroll) | CXTPScrollBarPaintManager | protectedstatic
CalcVScroll(CXTPScrollBase *pScroll, XTPScrollMetricsV *pVScroll) | CXTPScrollBarPaintManager | protectedstatic
CXTPScrollBarPaintManager() | CXTPScrollBarPaintManager |
CXTPScrollBarThemeWindowsUx() | CXTPScrollBarThemeWindowsUx |
DrawArrowGlyph(CDC *pDC, CRect rcArrow, XTPArrowGlyph glyph, BOOL bEnabled, COLORREF clrText=COLORREF_NULL) | CXTPScrollBarPaintManager | protected
DrawArrows(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics) | CXTPScrollBarThemeFlat | protectedvirtual
DrawArrows(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics) | CXTPScrollBarThemeFlat | protectedvirtual
DrawBackground(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics) | CXTPScrollBarPaintManager | protectedvirtual
DrawBackground(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics) | CXTPScrollBarPaintManager | protectedvirtual
DrawButtons(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics) | CXTPScrollBarThemeFlat | protectedvirtual
DrawButtons(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics) | CXTPScrollBarThemeFlat | protectedvirtual
DrawGripper(CDC *pDC, CXTPScrollBase *pScroll) | CXTPScrollBarThemeFlat | protectedvirtual
DrawScrollBar(CDC *pDC, CXTPScrollBase *pScrollBar) | CXTPScrollBarPaintManager | virtual
DrawThumbButton(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics) | CXTPScrollBarThemeFlat | protectedvirtual
DrawThumbButton(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics) | CXTPScrollBarThemeFlat | protectedvirtual
DrawTracker(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics) | CXTPScrollBarThemeFlat | protectedvirtual
DrawTracker(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics) | CXTPScrollBarThemeFlat | protectedvirtual
m_crBack | CXTPScrollBarPaintManager |
m_crBackHilite | CXTPScrollBarPaintManager |
m_crBackPushed | CXTPScrollBarPaintManager |
m_crBorder | CXTPScrollBarPaintManager |
m_crBorderHilite | CXTPScrollBarPaintManager |
m_cThumb | CXTPScrollBarPaintManager |
m_cxHScroll | CXTPScrollBarPaintManager |
m_cxVScroll | CXTPScrollBarPaintManager |
m_cyHScroll | CXTPScrollBarPaintManager |
m_cyVScroll | CXTPScrollBarPaintManager |
RefreshMetrics() | CXTPScrollBarThemeFlat | protectedvirtual
~CXTPScrollBarThemeWindowsUx() | CXTPScrollBarThemeWindowsUx | virtual


Toolkit Pro: Member List

CXTPControlEditCtrl Member List

This is the complete list of members for CXTPControlEditCtrl, including all inherited members.

CreateEdit(DWORD dwStyle, CWnd *pParentWnd) | CXTPCommandBarEditCtrl | virtual
CXTPCommandBarEditCtrl() | CXTPCommandBarEditCtrl |
GetControlEdit() const | CXTPControlEditCtrl |
GetRichEditContext() | CXTPCommandBarEditCtrl | protected
GetWindowTextEx(CString &rString) | CXTPCommandBarEditCtrl |
IsCommandEnabled(UINT nID) | CXTPCommandBarEditCtrl | protected
IsDialogCode(UINT nChar, LPARAM lParam) | CXTPCommandBarEditCtrl |
IsImeMode() const | CXTPCommandBarEditCtrl |
m_bComposited | CXTPCommandBarEditCtrl | protected
m_bIgonoreEditChanged | CXTPCommandBarEditCtrl | protected
m_bImeMode | CXTPCommandBarEditCtrl | protected
m_pControl | CXTPControlEditCtrl | protected
OnCmdMsg(UINT nID, int nCode, void *pExtra, AFX_CMDHANDLERINFO *pHandlerInfo) | CXTPCommandBarEditCtrl | virtual
OnCommand(WPARAM wParam, LPARAM lParam) | CXTPCommandBarEditCtrl | virtual
SetWindowTextEx(LPCTSTR lpszString) | CXTPCommandBarEditCtrl |
ShowContextMenu(CXTPControl *pControl, CPoint point) | CXTPCommandBarEditCtrl | virtual
UpdateCharFormat() | CXTPControlEditCtrl | protected


Toolkit Pro: Member List

CXTPChartSeriesPointCollection Member List

This is the complete list of members for CXTPChartSeriesPointCollection, including all inherited members.

Add(CXTPChartSeriesPoint *pPoint) | CXTPChartSeriesPointCollection |
AddPoints(int nCount) | CXTPChartSeriesPointCollection |
CXTPChartElement() | CXTPChartElement |
CXTPChartElementCollection() | CXTPChartElementCollection |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartSeriesPointCollection() | CXTPChartSeriesPointCollection |
DoPropExchange(CXTPPropExchange *pPX) | CXTPChartSeriesPointCollection | virtual
GetAppearance() const | CXTPChartElement |
GetArithmeticMean(int nValue) const | CXTPChartSeriesPointCollection | virtual
GetAt(int nIndex) const | CXTPChartSeriesPointCollection | virtual
GetContent() const | CXTPChartElement |
GetCount() const | CXTPChartElementCollection | virtual
GetMaximum(int nValue) const | CXTPChartSeriesPointCollection | virtual
GetMinimum(int nValue) const | CXTPChartSeriesPointCollection | virtual
GetMovingAverage(int nValue, int nFrom, int nTo) const | CXTPChartSeriesPointCollection | virtual
GetOwner() const | CXTPChartElement |
GetStandardDeviation(int nValue) const | CXTPChartSeriesPointCollection | virtual
GetVariance(int nValue) const | CXTPChartSeriesPointCollection | virtual
IndexOf(CXTPChartElement *pElement) const | CXTPChartElementCollection |
InsertAt(int nIndex, CXTPChartElement *pElement) | CXTPChartElementCollection |
Is3D() const | CXTPChartObject |
m_arrElements | CXTPChartElementCollection | protected
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartElement | virtual
Release() | CXTPChartElementCollection | virtual
Remove(CXTPChartElement *pElement) | CXTPChartElementCollection | virtual
RemoveAll() | CXTPChartElementCollection | virtual
RemoveAt(int nIndex) | CXTPChartElementCollection | virtual
~CXTPChartElement() | CXTPChartElement | virtual
~CXTPChartElementCollection() | CXTPChartElementCollection |
~CXTPChartSeriesPointCollection() | CXTPChartSeriesPointCollection | virtual


Toolkit Pro: XTPListBoxThemeResource.h Source File

  • Source
  • Controls
  • ListBox
  • Themes
XTPListBoxThemeResource.h
Go to the documentation of this file.
1
23#if !defined(__XTPLISTBOXTHEMERESOURCE_H__)
24# define __XTPLISTBOXTHEMERESOURCE_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPListBoxThemeResource : public CXTPListBoxTheme
39{
40public:
50 virtual void DrawItem(CDC* pDC, CXTPListBox* pListBox, LPDRAWITEMSTRUCT lpDIS);
51
57 virtual void RefreshMetrics();
58};
59
60# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
62#endif // !defined(__XTPLISTBOXTHEMERESOURCE_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPListBox
CXTPListBox is a CListBox derived class.
Definition XTPListBox.h:127
CXTPListBoxTheme
CXTPListBoxTheme is the base class used by CXTPListBox themes to draw the list box control.
Definition XTPListBox.h:61
CXTPListBoxThemeResource
CXTPListBoxThemeResource is used by CXTPListBox to draw a resource style list box.
Definition XTPListBoxThemeResource.h:39
CXTPListBoxThemeResource::DrawItem
virtual void DrawItem(CDC *pDC, CXTPListBox *pListBox, LPDRAWITEMSTRUCT lpDIS)
This method is called to draw the CXTPListBox object.
CXTPListBoxThemeResource::RefreshMetrics
virtual void RefreshMetrics()
Called to update the colors and metrics used to draw the CXTPListBox object.


Toolkit Pro: Member List

CXTPResizePropertySheet Member List

This is the complete list of members for CXTPResizePropertySheet, including all inherited members.

AdjustResizeRect(CSize &rcWindow) | CXTPResize | protectedvirtual
AutoLoadPlacement(LPCTSTR pszSection) | CXTPResize |
CResizeItemArray typedef | CXTPResize | protected
CXTPResize(CWnd *pWnd, const UINT nFlags=0) | CXTPResize |
CXTPResizePropertySheet() | CXTPResizePropertySheet |
CXTPResizePropertySheet(const UINT nCaption, CWnd *pParent=0, const UINT nSelectPage=0, const UINT nFlags=0) | CXTPResizePropertySheet |
CXTPResizePropertySheet(LPCTSTR pszCaption, CWnd *pParent=0, const UINT nSelectPage=0, const UINT nFlags=0) | CXTPResizePropertySheet |
Defer(HDWP &hdwp, CXTPResizeItem *pItem, int dx, int dy) | CXTPResize | protectedvirtual
GetMinMaxInfo(MINMAXINFO *pMMI) | CXTPResize | protected
HasFlag(XTPResize eFlag) | CXTPResize | protected
Init() | CXTPResize | protectedvirtual
IsWizard() | CXTPResizePropertySheet | protected
LoadPlacement(LPCTSTR pszSection) | CXTPResize |
m_arrItems | CXTPResize | protected
m_nFlagsXX | CXTPResize | protected
m_pWnd | CXTPResize | protected
m_scSizeIcon | CXTPResize | protected
m_strSection | CXTPResize | protected
m_szInitWindow | CXTPResize | protected
m_szMax | CXTPResize | protected
m_szMin | CXTPResize | protected
m_szWindow | CXTPResize | protected
m_tabCtrl | CXTPResizePropertySheet |
Offset(CPoint ptOffset) | CXTPResize | protected
RemoveAllControls() | CXTPResize | protected
RemoveResize(UINT nID) | CXTPResize | protected
Reset() | CXTPResize | protected
SavePlacement(LPCTSTR pszSection) | CXTPResize |
SetFlag(XTPResize eFlag) | CXTPResize | protected
SetMaxSize(CSize &sz) | CXTPResize |
SetMinSize(CSize &sz) | CXTPResize |
SetResize(UINT nID, XTP_RESIZE left, XTP_RESIZE top, XTP_RESIZE right, XTP_RESIZE bottom) | CXTPResize |
SetResize(UINT nID, const XTP_RESIZERECT &rrcSizing) | CXTPResize |
SetResize(UINT nID, HWND hWnd, const XTP_RESIZERECT &rrcSizing) | CXTPResize |
SetResize(UINT nID, HWND hWnd, const XTP_RESIZEPOINT &rpTopLeft, const XTP_RESIZEPOINT &rpBottomRight) | CXTPResize |
SetResize(UINT nID, const XTP_RESIZEPOINT &rpTopLeft, const XTP_RESIZEPOINT &rpBottomRight) | CXTPResize |
SetResize(CWnd *pWnd, const CXTPResizeRect &rrcSizing, CRect rcWindow) | CXTPResize | protected
Size() | CXTPResize | protectedvirtual
UpdateControlRect(CWnd *pWnd) | CXTPResize | protected
~CXTPResize() | CXTPResize | virtual


Toolkit Pro: XTPListBoxThemeOfficeXP.h Source File

  • Source
  • Controls
  • ListBox
  • Themes
XTPListBoxThemeOfficeXP.h
Go to the documentation of this file.
1
23#if !defined(__XTPLISTBOXTHEMEOFFICEXP_H__)
24# define __XTPLISTBOXTHEMEOFFICEXP_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPListBoxThemeOfficeXP : public CXTPListBoxTheme
39{
40public:
50 virtual void DrawItem(CDC* pDC, CXTPListBox* pListBox, LPDRAWITEMSTRUCT lpDIS);
51
57 virtual void RefreshMetrics();
58};
59
60# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
62#endif // !defined(__XTPLISTBOXTHEMEOFFICEXP_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPListBox
CXTPListBox is a CListBox derived class.
Definition XTPListBox.h:127
CXTPListBoxTheme
CXTPListBoxTheme is the base class used by CXTPListBox themes to draw the list box control.
Definition XTPListBox.h:61
CXTPListBoxThemeOfficeXP
CXTPListBoxThemeOfficeXP is used by CXTPListBox to draw an Office XP style list box.
Definition XTPListBoxThemeOfficeXP.h:39
CXTPListBoxThemeOfficeXP::DrawItem
virtual void DrawItem(CDC *pDC, CXTPListBox *pListBox, LPDRAWITEMSTRUCT lpDIS)
This method is called to draw the CXTPListBox object.
CXTPListBoxThemeOfficeXP::RefreshMetrics
virtual void RefreshMetrics()
Called to update the colors and metrics used to draw the CXTPListBox object.


Toolkit Pro: XTPTabColorSetOffice2007Access.h Source File

  • Source
  • TabManager
  • ColorSets
XTPTabColorSetOffice2007Access.h
Go to the documentation of this file.
1
23#if !defined(__XTPTABCOLORSETOFFICE2007ACCESS_H__)
24# define __XTPTABCOLORSETOFFICE2007ACCESS_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
37class _XTP_EXT_CLASS CXTPTabColorSetOffice2007Access : public CXTPTabColorSetOffice2007
38{
39public:
47 virtual void RefreshMetrics();
48};
49
51// obsolete, for backward compatibility only.
52class _XTP_EXT_CLASS CColorSetAccess2007 : public CXTPTabColorSetOffice2007Access
53{
54};
57# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
59#endif // !defined(__XTPTABCOLORSETOFFICE2007ACCESSE_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPTabColorSetOffice2007Access
CXTPTabColorSetOffice2007Access implements an Office 2007 Access tab color set.
Definition XTPTabColorSetOffice2007Access.h:38
CXTPTabColorSetOffice2007Access::RefreshMetrics
virtual void RefreshMetrics()
Refreshes the visual metrics of the tabs.
CXTPTabColorSetOffice2007
CXTPTabColorSetOffice2007 implements an Office 2007 tab color set.
Definition XTPTabColorSetOffice2007.h:38


Toolkit Pro: Member List

CXTPListBoxThemeNativeWindows10 Member List

This is the complete list of members for CXTPListBoxThemeNativeWindows10, including all inherited members.

CXTPListBoxThemeNativeWindows10() | CXTPListBoxThemeNativeWindows10 |
CXTPListBoxThemeOffice2013() | CXTPListBoxThemeOffice2013 |
DrawItem(CDC *pDC, CXTPListBox *pListBox, LPDRAWITEMSTRUCT lpDIS) | CXTPListBoxThemeOffice2013 | virtual
DrawItemText(CDC *pDC, CRect rcText, CXTPListBox *pListBox, LPDRAWITEMSTRUCT lpDIS) | CXTPListBoxTheme | virtual
DrawNcBorders(CDC *pDC, CRect rc) | CXTPListBoxThemeOffice2013 | virtual
GetBackColor() | CXTPListBoxThemeOffice2013 | virtual
m_clrBack | CXTPListBoxThemeOffice2013 |
m_clrBorder | CXTPListBoxThemeOffice2013 |
m_clrItemBack | CXTPListBoxThemeOffice2013 |
m_clrItemBackHighlight | CXTPListBoxThemeOffice2013 |
m_clrItemBackSelected | CXTPListBoxThemeOffice2013 |
m_clrItemBorder | CXTPListBoxThemeOffice2013 |
m_clrItemBorderHighlight | CXTPListBoxThemeOffice2013 |
m_clrItemBorderSelected | CXTPListBoxThemeOffice2013 |
m_clrItemText | CXTPListBoxThemeOffice2013 |
m_clrItemTextHighlight | CXTPListBoxThemeOffice2013 |
m_clrItemTextSelected | CXTPListBoxThemeOffice2013 |
RefreshMetrics() | CXTPListBoxThemeOffice2013 | virtual
~CXTPListBoxTheme() | CXTPListBoxTheme | inlinevirtual


Toolkit Pro: XTPFlowGraphImage.h Source File

  • Source
  • FlowGraph
XTPFlowGraphImage.h
Go to the documentation of this file.
1
23#if !defined(__XTPFLOWGRAPHIMAGE_H__)
24# define __XTPFLOWGRAPHIMAGE_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33namespace Gdiplus
34{
35class Image;
36class Bitmap;
37} // namespace Gdiplus
38
39class CXTPImageManager;
40class CXTPImageManagerIcon;
41class CXTPFlowGraphControl;
42
48class _XTP_EXT_CLASS CXTPFlowGraphImage : public CXTPCmdTarget
49{
50public:
55 CXTPFlowGraphImage();
61 virtual ~CXTPFlowGraphImage();
62
63public:
72 void LoadFromResource(HINSTANCE hInstance, UINT nResourceName);
82 void LoadFromResource(HINSTANCE hInstance, LPCTSTR lpszResourceName, LPCTSTR lpszResourceType);
83
89 void LoadFromFile(LPCTSTR lpszFileName);
96 void SetBitmap(HBITMAP hBitmap);
103 void SetIcon(HICON hIcon);
104
111 CSize GetSize() const;
112
119 Gdiplus::Image* GetImage() const;
126 CXTPImageManagerIcon* GetIcon() const;
127
128protected:
134 void OnRemoved();
142 void ImageChanged();
143
144 friend class CXTPFlowGraphImages;
145
146protected:
147 Gdiplus::Bitmap* m_pImage;
148 CXTPImageManagerIcon* m_pIcon;
151 CSize m_szImage;
152 CXTPFlowGraphImages* m_pParent;
155# ifdef _XTP_ACTIVEX
158 DECLARE_DISPATCH_MAP()
159 DECLARE_INTERFACE_MAP()
160 DECLARE_OLETYPELIB_EX(CXTPFlowGraphImage)
161
163# endif
164 friend class CXTPFlowGraphImages;
165
166 UINT m_nCommandId;
167};
168
176class _XTP_EXT_CLASS CXTPFlowGraphImages : public CXTPCmdTarget
177{
178protected:
184 CXTPFlowGraphImages(CXTPFlowGraphControl* pControl);
190 virtual ~CXTPFlowGraphImages();
191
192public:
203 CXTPFlowGraphImage* AddImage(CXTPFlowGraphImage* pPage);
204
209 void RemoveAll();
210
217 int GetCount() const;
226 CXTPFlowGraphImage* GetAt(int nIndex) const;
227
233 void Remove(CXTPFlowGraphImage* pPage);
239 void RemoveAt(int nIndex);
240
248 CXTPImageManager* GetImageManager() const;
249
250protected:
251 CArray<CXTPFlowGraphImage*, CXTPFlowGraphImage*> m_arrImages;
253 CXTPImageManager* m_pImageManager;
256 CXTPFlowGraphControl* m_pControl;
257
258 friend class CXTPFlowGraphControl;
259
260# ifdef _XTP_ACTIVEX
263 DECLARE_DISPATCH_MAP()
264 DECLARE_INTERFACE_MAP()
265
266 DECLARE_OLETYPELIB_EX(CXTPFlowGraphImages)
267 DECLARE_ENUM_VARIANT(CXTPFlowGraphImages)
268
269 afx_msg int OleGetItemCount();
270 afx_msg LPDISPATCH OleGetItem(int nIndex);
271 afx_msg LPDISPATCH OleAddImage();
273# endif
274};
275
276AFX_INLINE int CXTPFlowGraphImages::GetCount() const
277{
278 return (int)m_arrImages.GetSize();
279}
280AFX_INLINE CXTPFlowGraphImage* CXTPFlowGraphImages::GetAt(int nIndex) const
281{
282 return nIndex >= 0 && nIndex < m_arrImages.GetSize() ? m_arrImages[nIndex] : NULL;
283}
284AFX_INLINE CXTPImageManager* CXTPFlowGraphImages::GetImageManager() const
285{
286 return m_pImageManager;
287}
288AFX_INLINE CSize CXTPFlowGraphImage::GetSize() const
289{
290 return m_szImage;
291}
293# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
294#endif //#if !defined(__XTPFLOWGRAPHIMAGE_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPFlowGraphControl
Flow Graph Control.
Definition XTPFlowGraphControl.h:173
CXTPFlowGraphImage
Object used to represent an image displayed in a Node or connection point.
Definition XTPFlowGraphImage.h:49
CXTPFlowGraphImage::m_pImage
Gdiplus::Bitmap * m_pImage
Reference to a Gdiplus::Image for this flow graph image.
Definition XTPFlowGraphImage.h:147
CXTPFlowGraphImage::~CXTPFlowGraphImage
virtual ~CXTPFlowGraphImage()
Destroys a CXTPFlowGraphImage object, handles cleanup and deallocation.
CXTPFlowGraphImage::SetIcon
void SetIcon(HICON hIcon)
Call this method to assign an icon handle to the CXTPFlowGraphImage class.
CXTPFlowGraphImage::m_pIcon
CXTPImageManagerIcon * m_pIcon
Reference to a CXTPImageManagerIcon for this flow graph image.
Definition XTPFlowGraphImage.h:148
CXTPFlowGraphImage::GetSize
CSize GetSize() const
Gets the size of this image.
Definition XTPFlowGraphImage.h:288
CXTPFlowGraphImage::m_szImage
CSize m_szImage
Size of the image.
Definition XTPFlowGraphImage.h:151
CXTPFlowGraphImage::GetImage
Gdiplus::Image * GetImage() const
Gets a reference to a Gdiplus::Image for this flow graph image.
CXTPFlowGraphImage::CXTPFlowGraphImage
CXTPFlowGraphImage()
Constructs a CXTPFlowGraphImage object.
CXTPFlowGraphImage::LoadFromResource
void LoadFromResource(HINSTANCE hInstance, UINT nResourceName)
Loads an image from a resource.
CXTPFlowGraphImage::SetBitmap
void SetBitmap(HBITMAP hBitmap)
Call this method to assign a bitmap handle to the CXTPFlowGraphImage class.
CXTPFlowGraphImage::OnRemoved
void OnRemoved()
This method is called when the image is removed from the flow graph's collection of images.
CXTPFlowGraphImage::LoadFromFile
void LoadFromFile(LPCTSTR lpszFileName)
Loads an image so that it can be used in the flow graph.
CXTPFlowGraphImage::LoadFromResource
void LoadFromResource(HINSTANCE hInstance, LPCTSTR lpszResourceName, LPCTSTR lpszResourceType)
Loads an image from a resource.
CXTPFlowGraphImage::m_pParent
CXTPFlowGraphImages * m_pParent
Reference to the collection of images that this image belongs to.
Definition XTPFlowGraphImage.h:152
CXTPFlowGraphImage::ImageChanged
void ImageChanged()
This method is called whenever the image has been changed.
CXTPFlowGraphImage::GetIcon
CXTPImageManagerIcon * GetIcon() const
Gets a reference to a CXTPImageManagerIcon for this flow graph image.
CXTPFlowGraphImages
Collection of images that can be used in the flow graph.
Definition XTPFlowGraphImage.h:177
CXTPFlowGraphImages::GetCount
int GetCount() const
Retrieves the total number of images added to the flow graph.
Definition XTPFlowGraphImage.h:276
CXTPFlowGraphImages::m_pImageManager
CXTPImageManager * m_pImageManager
Pointer to the image manager associated with the graph.
Definition XTPFlowGraphImage.h:253
CXTPFlowGraphImages::AddImage
CXTPFlowGraphImage * AddImage(CXTPFlowGraphImage *pPage)
Adds an image object that can then be used to load an image file.
CXTPFlowGraphImages::RemoveAll
void RemoveAll()
Removes all images from the flow graph.
CXTPFlowGraphImages::GetAt
CXTPFlowGraphImage * GetAt(int nIndex) const
Retrieves the specified image from the collection of all images added to the flow graph.
Definition XTPFlowGraphImage.h:280
CXTPFlowGraphImages::GetImageManager
CXTPImageManager * GetImageManager() const
Retrieves the image manager associated with the flow graph.
Definition XTPFlowGraphImage.h:284
CXTPFlowGraphImages::~CXTPFlowGraphImages
virtual ~CXTPFlowGraphImages()
Destroys a CXTPFlowGraphImage object, handles cleanup and deallocation.
CXTPFlowGraphImages::CXTPFlowGraphImages
CXTPFlowGraphImages(CXTPFlowGraphControl *pControl)
Constructs a CXTPFlowGraphImages object.
CXTPFlowGraphImages::RemoveAt
void RemoveAt(int nIndex)
Removes the specified images from the collection of images.
CXTPFlowGraphImages::Remove
void Remove(CXTPFlowGraphImage *pPage)
Removes all images from the specified page.
CXTPFlowGraphImages::m_arrImages
CArray< CXTPFlowGraphImage *, CXTPFlowGraphImage * > m_arrImages
List of images for the flow graph.
Definition XTPFlowGraphImage.h:251
CXTPImageManager
CXTPImageManager is a standalone class.
Definition XTPImageManager.h:1898
CXTPImageManagerIcon
Icons holder class.
Definition XTPImageManager.h:622


Toolkit Pro: Member List

CXTPChartPointSeriesLabelView Member List

This is the complete list of members for CXTPChartPointSeriesLabelView, including all inherited members.

AddChildView(CXTPChartElementView *pChildView) | CXTPChartElementView |
CreateDeviceCommand(CXTPChartDeviceContext *pDC) | CXTPChartDiagram2DSeriesLabelView | virtual
CreateDeviceCommand(CXTPChartDeviceContext *pDC, CXTPChartPointF ptCenterPoint) | CXTPChartDiagram2DSeriesLabelView | virtual
CreateDeviceCommand(CXTPChartDeviceContext *pDC, CXTPChartPointF ptCenterPoint, const CXTPChartString &text) | CXTPChartDiagram2DSeriesLabelView | virtual
CreateDeviceCommand(CXTPChartDeviceContext *pDC, const CXTPChartPointF &ptAnchorPoint, double dAnchorAngle, const CXTPChartString &text) | CXTPChartDiagram2DSeriesLabelView | virtual
CXTPChartDiagram2DSeriesLabelView(CXTPChartSeriesLabel *pLabel, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView) | CXTPChartDiagram2DSeriesLabelView |
CXTPChartElementView(CXTPChartElementView *pParentView) | CXTPChartElementView |
CXTPChartElementView(CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartElementView |
CXTPChartElementView(CXTPChartContainer *pContainer) | CXTPChartElementView |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartPointSeriesLabelView(CXTPChartSeriesLabel *pLabel, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView) | CXTPChartPointSeriesLabelView |
GetAnchorPoint() const | CXTPChartPointSeriesLabelView | virtual
GetAt(int nIndex) const | CXTPChartElementView |
GetBounds() const | CXTPChartElementView |
GetBounds(BOOL bIncludingChildren) const | CXTPChartElementView |
GetChildren() | CXTPChartElementView |
GetCount() const | CXTPChartElementView |
GetParentView() const | CXTPChartElementView |
Is3D() const | CXTPChartObject |
m_arrChildren | CXTPChartElementView | protected
m_pContainer | CXTPChartElementView | protected
m_pParentView | CXTPChartElementView | protected
m_rcBounds | CXTPChartElementView | protected
~CXTPChartElementView() | CXTPChartElementView | protectedvirtual


Toolkit Pro: XTPSkinObjectListBox.h Source File

  • Source
  • SkinFramework
XTPSkinObjectListBox.h
Go to the documentation of this file.
1
23#if !defined(__XTPSKINOBJECTLISTBOX_H__)
24# define __XTPSKINOBJECTLISTBOX_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPSkinObjectListBox : public CXTPSkinObjectUser32Control
39{
41 DECLARE_DYNCREATE(CXTPSkinObjectListBox)
43public:
48 CXTPSkinObjectListBox();
49
54 virtual ~CXTPSkinObjectListBox();
55
56protected:
58 // DECLARE_MESSAGE_MAP()
59
60 //{{AFX_VIRTUAL(CXTPSkinObjectListBox)
61 //}}AFX_VIRTUAL
62
63 //{{AFX_MSG(CXTPSkinObjectListBox)
64 //}}AFX_MSG
66};
67
68# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
70#endif // !defined(__XTPSKINOBJECTLISTBOX_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPSkinObjectListBox
CXTPSkinObjectListBox is a CXTPSkinObjectUser32Control derived class.
Definition XTPSkinObjectListBox.h:39
CXTPSkinObjectListBox::~CXTPSkinObjectListBox
virtual ~CXTPSkinObjectListBox()
Destroys a CXTPSkinObjectListBox object, handles cleanup and deallocation.
CXTPSkinObjectListBox::CXTPSkinObjectListBox
CXTPSkinObjectListBox()
Constructs a CXTPSkinObjectListBox object.
CXTPSkinObjectUser32Control
CXTPSkinObjectUser32Control is a CXTPSkinObjectFrame derived class.
Definition XTPSkinObjectFrame.h:400


Toolkit Pro: XTPTabThemeVisualStudio2005.h Source File

  • Source
  • TabManager
  • Themes
XTPTabThemeVisualStudio2005.h
Go to the documentation of this file.
1
23#if !defined(__XTPTABTHEMEVISUALSTUDIO2005_H__)
24# define __XTPTABTHEMEVISUALSTUDIO2005_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
43class _XTP_EXT_CLASS CAppearanceSetVisualStudio2005 : public CAppearanceSetPropertyPage2003
44{
45public:
50 CAppearanceSetVisualStudio2005()
51 {
52 m_bButtonsReverseZOrder = TRUE;
53 }
54
70 virtual void DrawSingleButton(CDC* pDC, CXTPTabManagerItem* pItem);
71
86 virtual CRect GetHeaderMargin()
87 {
88 return CRect(m_rcHeaderMargin.left + m_nButtonHeight / 2, m_rcHeaderMargin.top,
89 m_rcHeaderMargin.right, m_rcHeaderMargin.bottom);
90 }
91
102 virtual CRect GetButtonDrawRect(const CXTPTabManagerItem* pItem);
103};
104
105# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
107#endif // !defined(__XTPTABTHEMEVISUALSTUDIO2005_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CAppearanceSetPropertyPage2003
CAppearanceSetPropertyPage2003 implements an Office 2003 tab appearance.
Definition XTPTabThemePropertyPage2003.h:53
CAppearanceSetVisualStudio2005
CAppearanceSetVisualStudio2005 implements a Visual Studio 2005 tab appearance.
Definition XTPTabThemeVisualStudio2005.h:44
CAppearanceSetVisualStudio2005::GetButtonDrawRect
virtual CRect GetButtonDrawRect(const CXTPTabManagerItem *pItem)
Retrieves the bounding rectangle of a specified drawing item.
CAppearanceSetVisualStudio2005::GetHeaderMargin
virtual CRect GetHeaderMargin()
Gets the top, left, right, and bottom margins of the tab header.
Definition XTPTabThemeVisualStudio2005.h:86
CAppearanceSetVisualStudio2005::CAppearanceSetVisualStudio2005
CAppearanceSetVisualStudio2005()
Constructs a CAppearanceSetVisualStudio2005 object.
Definition XTPTabThemeVisualStudio2005.h:50
CAppearanceSetVisualStudio2005::DrawSingleButton
virtual void DrawSingleButton(CDC *pDC, CXTPTabManagerItem *pItem)
Draws a single tab button in the tab client header area.
CXTPTabManagerItem
CXTPTabManagerItem is the base class for the tabs that appear in the command bars tab workspace,...
Definition XTPTabManagerItem.h:44


Toolkit Pro: Member List

CXTPColorSelectorCtrlThemeVisualStudio2015 Member List

This is the complete list of members for CXTPColorSelectorCtrlThemeVisualStudio2015, including all inherited members.

CalcSize(CXTPColorSelectorCtrl *pOwner) | CXTPColorSelectorCtrlThemeOffice2013 | virtual
CreateAutoButton(CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked) | CXTPColorSelectorCtrlThemeOffice2013 | virtual
CreateColorButtons(CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked) | CXTPColorSelectorCtrlTheme | virtual
CreateExtendedButtons(CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked) | CXTPColorSelectorCtrlThemeOffice2013 | virtual
CreateMoreButton(CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked) | CXTPColorSelectorCtrlThemeOffice2013 | virtual
CreateRecentColorButtons(CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked) | CXTPColorSelectorCtrlThemeOffice2013 | virtual
CreateThemeButtons(CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked) | CXTPColorSelectorCtrlThemeOffice2013 | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPColorSelectorCtrlTheme() | CXTPColorSelectorCtrlTheme |
CXTPColorSelectorCtrlThemeOffice2013() | CXTPColorSelectorCtrlThemeOffice2013 |
CXTPColorSelectorCtrlThemeVisualStudio2015() | CXTPColorSelectorCtrlThemeVisualStudio2015 |
CXTPControlTheme() | CXTPControlTheme |
DrawBorder(CDC *pDC, CRect rcItem, CRect rcBorder, COLORREF crBorder) | CXTPColorSelectorCtrlThemeOffice2013 | virtual
DrawColor(CDC *pDC, CXTPColorSelectorCtrl *pOwner, CXTPColorSelectorCtrl::COLOR_CELL *pColorCell, CRect rcItem, BOOL bChecked, BOOL bHighlight, BOOL bPressed) | CXTPColorSelectorCtrlThemeOffice2013 | virtual
DrawColorCell(CDC *pDC, CXTPColorSelectorCtrl *pOwner, CXTPColorSelectorCtrl::COLOR_CELL *pColorCell, BOOL bHighlight, BOOL bPressed) | CXTPColorSelectorCtrlThemeVisualStudio2015 | virtual
DrawColorSelector(CDC *pDC, CXTPColorSelectorCtrl *pOwner) | CXTPColorSelectorCtrlThemeOffice2013 | virtual
FillBackground(CDC *pDC, CXTPColorSelectorCtrl *pOwner, const CRect &rect) | CXTPColorSelectorCtrlTheme | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetButtonSize() const | CXTPColorSelectorCtrlTheme | virtual
GetThemeStyle() const | CXTPControlTheme |
m_bThinBorder | CXTPColorSelectorCtrlTheme |
m_crBack | CXTPColorSelectorCtrlTheme |
m_crBackChecked | CXTPColorSelectorCtrlTheme |
m_crBackHilight | CXTPColorSelectorCtrlTheme |
m_crBackPressed | CXTPColorSelectorCtrlTheme |
m_crBorder | CXTPColorSelectorCtrlTheme |
m_crBorderHilight | CXTPColorSelectorCtrlTheme |
m_crBorderInside | CXTPColorSelectorCtrlThemeOffice2013 | protected
m_crBorderPressed | CXTPColorSelectorCtrlTheme |
m_crPopupBorder | CXTPColorSelectorCtrlTheme |
m_crText | CXTPColorSelectorCtrlTheme |
m_crTextPressed | CXTPColorSelectorCtrlTheme |
m_crTitleBack | CXTPColorSelectorCtrlThemeOffice2013 | protected
m_crTitleText | CXTPColorSelectorCtrlThemeOffice2013 | protected
m_nAutoButton | CXTPColorSelectorCtrlTheme |
m_nCaption | CXTPColorSelectorCtrlTheme |
m_nMargin | CXTPColorSelectorCtrlTheme |
m_nTheme | CXTPControlTheme | protected
m_rcRecentText | CXTPColorSelectorCtrlTheme |
m_rcStandardText | CXTPColorSelectorCtrlTheme |
m_rcThemeText | CXTPColorSelectorCtrlTheme |
m_sizeButton | CXTPColorSelectorCtrlTheme |
RefreshMetrics(CXTPColorSelectorCtrl *pOwner) | CXTPColorSelectorCtrlThemeVisualStudio2015 | virtual
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static


Toolkit Pro: Member List

CXTPChartPyramidSeriesPointView Member List

This is the complete list of members for CXTPChartPyramidSeriesPointView, including all inherited members.

AddChildView(CXTPChartElementView *pChildView) | CXTPChartElementView |
CalculateLayout(int nIndex, int nCount, double dFrom, double dTo) | CXTPChartPyramidSeriesPointView | virtual
CreateDeviceCommand(CXTPChartDeviceContext *pDC) | CXTPChartPyramidSeriesPointView | protectedvirtual
CreateLegendDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcBounds) | CXTPChartPyramidSeriesPointViewBase | protectedvirtual
CXTPChartElementView(CXTPChartElementView *pParentView) | CXTPChartElementView |
CXTPChartElementView(CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartElementView |
CXTPChartElementView(CXTPChartContainer *pContainer) | CXTPChartElementView |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartPyramidSeriesPointView(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView) | CXTPChartPyramidSeriesPointView |
CXTPChartPyramidSeriesPointView(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartPyramidSeriesPointView |
CXTPChartPyramidSeriesPointViewBase(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView) | CXTPChartPyramidSeriesPointViewBase |
CXTPChartPyramidSeriesPointViewBase(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartPyramidSeriesPointViewBase |
CXTPChartSeriesPointView(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView) | CXTPChartSeriesPointView |
CXTPChartSeriesPointView(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartSeriesPointView |
GetAt(int nIndex) const | CXTPChartElementView |
GetBorderActualColor() const | CXTPChartPyramidSeriesPointViewBase |
GetBounds() const | CXTPChartElementView |
GetBounds(BOOL bIncludingChildren) const | CXTPChartElementView |
GetChildren() | CXTPChartElementView |
GetColor() const | CXTPChartSeriesPointView |
GetColor2() const | CXTPChartSeriesPointView |
GetCount() const | CXTPChartElementView |
GetInternalValue() const | CXTPChartSeriesPointView |
GetLegendName() const | CXTPChartSeriesPointView | virtual
GetParentView() const | CXTPChartElementView |
GetPoint() const | CXTPChartSeriesPointView |
GetSeriesView() const | CXTPChartSeriesPointView |
Is3D() const | CXTPChartObject |
m_arrChildren | CXTPChartElementView | protected
m_dInternalValue | CXTPChartSeriesPointView |
m_dValue | CXTPChartPyramidSeriesPointViewBase | protected
m_pContainer | CXTPChartElementView | protected
m_pParentView | CXTPChartElementView | protected
m_pPoint | CXTPChartSeriesPointView | protected
m_rcBounds | CXTPChartElementView | protected
UpdateMinMaxRange(double &nMinValue, double &nMaxValue) const | CXTPChartSeriesPointView | virtual
~CXTPChartElementView() | CXTPChartElementView | protectedvirtual
~CXTPChartLegendItemView() | CXTPChartLegendItemView | inlinevirtual
~CXTPChartPyramidSeriesPointViewBase() | CXTPChartPyramidSeriesPointViewBase | virtual


Toolkit Pro: Member List

CXTPCalendarResourceDescription Member List

This is the complete list of members for CXTPCalendarResourceDescription, including all inherited members.

CXTPCalendarResourceDescription() | CXTPCalendarResourceDescription |
CXTPCmdTarget() | CXTPCmdTarget |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
m_bEnabled | CXTPCalendarResourceDescription |
m_bGenerateName | CXTPCalendarResourceDescription |
m_ptrResource | CXTPCalendarResourceDescription |


Toolkit Pro: XTPStatusBarPaneSwitch.h Source File

  • Source
  • CommandBars
  • StatusBar
  • Panes
XTPStatusBarPaneSwitch.h
Go to the documentation of this file.
1
23#if !defined(__XTPSTATUSBARPANESWITCH_H__)
24# define __XTPSTATUSBARPANESWITCH_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
39class _XTP_EXT_CLASS CXTPStatusBarSwitchPane : public CXTPStatusBarPane
40{
42 DECLARE_DYNAMIC(CXTPStatusBarSwitchPane)
44public:
49 struct SWITCH
50 {
51 CString strToolTip;
52 UINT nID;
53 int nWidth;
54 BOOL bChecked;
55 BOOL bHighlighted;
56 BOOL bPressed;
57 BOOL bEnabled;
58 };
59
60public:
65 CXTPStatusBarSwitchPane();
66
72 ~CXTPStatusBarSwitchPane();
73
74public:
83 BOOL SetSwitches(const UINT* lpIDArray, int nIDCount);
84
92 SWITCH* AddSwitch(UINT nID);
93
102 SWITCH* AddSwitch(UINT nID, LPCTSTR lpszToolTip);
103
112 SWITCH* GetSwitch(int nIndex) const;
113
122 SWITCH* FindSwitch(UINT nID) const;
123
130 int GetSwitchCount() const;
131
136 void RemoveAll();
137
143 void RemoveSwitch(UINT nID);
144
151 void EnableSwitch(UINT nID, BOOL bEnabled);
152
161 void SetChecked(UINT nID);
162
169 virtual int GetWidth();
170
171public:
181 SWITCH* HitTest(CPoint point, CRect& rcItem) const;
182
183protected:
191 virtual void OnLButtonDown(CPoint point);
192
200 virtual void OnDraw(CDC* pDC, CRect rcItem);
201
207 virtual void OnMouseMove(CPoint point);
208
221 virtual INT_PTR OnToolHitTest(CPoint point, TOOLINFO* pTI) const;
222
223# ifdef _XTP_COMMANDBARS_ACTIVEX
225 DECLARE_DISPATCH_MAP()
226 DECLARE_INTERFACE_MAP()
227 DECLARE_OLETYPELIB_EX(CXTPStatusBarSwitchPane);
228
229 void OleAddSwitch(UINT nID, LPCTSTR lpszToolTip);
230 void OleRemoveSwitch(UINT nID);
231 int OleGetChecked();
232 BSTR OleGetSwitchTooltip(int nID);
233 void OleSetSwitchTooltip(int nID, LPCTSTR lpszTooltip);
235# endif
236
237protected:
238 CArray<SWITCH*, SWITCH*> m_arrSwitches;
239 SWITCH* m_pHighlighted;
240};
241
243# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
244#endif // !defined(__XTPSTATUSBARPANESWITCH_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPStatusBarPane
CXTPStatusBarPane is a CXTPCmdTarget derived class.
Definition XTPStatusBarPane.h:39
CXTPStatusBarSwitchPane
CXTPStatusBarSwitchPane is a CXTPStatusBarPane derived class.
Definition XTPStatusBarPaneSwitch.h:40
CXTPStatusBarSwitchPane::CXTPStatusBarSwitchPane
CXTPStatusBarSwitchPane()
Constructs a CXTPStatusBarSwitchPane object.
CXTPStatusBarSwitchPane::FindSwitch
SWITCH * FindSwitch(UINT nID) const
Retrieves a switch by its index/identifier.
CXTPStatusBarSwitchPane::EnableSwitch
void EnableSwitch(UINT nID, BOOL bEnabled)
Specifies whether the switch pane is enabled.
CXTPStatusBarSwitchPane::HitTest
SWITCH * HitTest(CPoint point, CRect &rcItem) const
Call this method to determine which pane, if any, is at the specified screen position.
CXTPStatusBarSwitchPane::m_pHighlighted
SWITCH * m_pHighlighted
TRUE if the switch is currently highlighted.
Definition XTPStatusBarPaneSwitch.h:239
CXTPStatusBarSwitchPane::GetSwitchCount
int GetSwitchCount() const
Gets the total number of switches in the switch pane.
CXTPStatusBarSwitchPane::GetWidth
virtual int GetWidth()
Gets the width of the switch pane.
CXTPStatusBarSwitchPane::OnToolHitTest
virtual INT_PTR OnToolHitTest(CPoint point, TOOLINFO *pTI) const
The framework calls this member function to determine whether a point is in the bounding rectangle of...
CXTPStatusBarSwitchPane::OnDraw
virtual void OnDraw(CDC *pDC, CRect rcItem)
This method is called to draw a pane switch item.
CXTPStatusBarSwitchPane::m_arrSwitches
CArray< SWITCH *, SWITCH * > m_arrSwitches
Collection of switces in the switch pane.
Definition XTPStatusBarPaneSwitch.h:238
CXTPStatusBarSwitchPane::GetSwitch
SWITCH * GetSwitch(int nIndex) const
Retrieves a switch by its index/identifier.
CXTPStatusBarSwitchPane::RemoveAll
void RemoveAll()
Removes all switches from the switch pane.
CXTPStatusBarSwitchPane::AddSwitch
SWITCH * AddSwitch(UINT nID, LPCTSTR lpszToolTip)
Adds a switch to the Switch Pane.
CXTPStatusBarSwitchPane::SetSwitches
BOOL SetSwitches(const UINT *lpIDArray, int nIDCount)
Call this method to set switches.
CXTPStatusBarSwitchPane::OnMouseMove
virtual void OnMouseMove(CPoint point)
This member is called when the mouse cursor moves.
CXTPStatusBarSwitchPane::OnLButtonDown
virtual void OnLButtonDown(CPoint point)
This member function is used to process left mouse button events.
CXTPStatusBarSwitchPane::~CXTPStatusBarSwitchPane
~CXTPStatusBarSwitchPane()
Destroys a CXTPStatusBarSwitchPane object, handles cleanup and deallocation.
CXTPStatusBarSwitchPane::RemoveSwitch
void RemoveSwitch(UINT nID)
Removes a switch from the switch pane.
CXTPStatusBarSwitchPane::SetChecked
void SetChecked(UINT nID)
Sets the ID of the switch that is currently checked.
CXTPStatusBarSwitchPane::AddSwitch
SWITCH * AddSwitch(UINT nID)
Adds a switch to the Switch Pane.
CXTPStatusBarSwitchPane::SWITCH
Holds status bar pane switch properties.
Definition XTPStatusBarPaneSwitch.h:50
CXTPStatusBarSwitchPane::SWITCH::bChecked
BOOL bChecked
TRUE to "check" the switch.
Definition XTPStatusBarPaneSwitch.h:54
CXTPStatusBarSwitchPane::SWITCH::nWidth
int nWidth
Width of the switch.
Definition XTPStatusBarPaneSwitch.h:53
CXTPStatusBarSwitchPane::SWITCH::bEnabled
BOOL bEnabled
TRUE if enabled.
Definition XTPStatusBarPaneSwitch.h:57
CXTPStatusBarSwitchPane::SWITCH::nID
UINT nID
Id of the switch.
Definition XTPStatusBarPaneSwitch.h:52
CXTPStatusBarSwitchPane::SWITCH::strToolTip
CString strToolTip
Tooltip of the switch.
Definition XTPStatusBarPaneSwitch.h:51
CXTPStatusBarSwitchPane::SWITCH::bPressed
BOOL bPressed
TRUE if the switch is pressed.
Definition XTPStatusBarPaneSwitch.h:56
CXTPStatusBarSwitchPane::SWITCH::bHighlighted
BOOL bHighlighted
TRUE if the switch is highlighted.
Definition XTPStatusBarPaneSwitch.h:55


Toolkit Pro: Member List

CXTPSyntaxEditDrawTextProcessor Member List

This is the complete list of members for CXTPSyntaxEditDrawTextProcessor, including all inherited members.

AlignColIdxToTabs(int nRow, int nCol, BOOL bVirtualSpace=FALSE) | CXTPSyntaxEditDrawTextProcessor |
ColFromXPos(int nRow, int nX, int &rnCol, BOOL bVirtualSpace=FALSE) const | CXTPSyntaxEditDrawTextProcessor |
CXTPSyntaxEditDrawTextProcessor() | CXTPSyntaxEditDrawTextProcessor |
DispPosToStrPos(int nRow, int nDispPos, BOOL bVirtualSpace) const | CXTPSyntaxEditDrawTextProcessor |
DrawRowPart(CDC *pDC, int nRow, LPCTSTR pcszText, int nchCount=-1) | CXTPSyntaxEditDrawTextProcessor |
ExpandChars(LPCTSTR pszChars, CString &strBuffer, int nDispPos=0, BOOL bEnableWhiteSpace=FALSE) | CXTPSyntaxEditDrawTextProcessor |
GetColPosX(int nRow, int nCol, int *pnCharWidth=NULL, BOOL bVirtualSpace=FALSE) const | CXTPSyntaxEditDrawTextProcessor |
GetRowHeight() const | CXTPSyntaxEditDrawTextProcessor |
GetRowsCount(BOOL bWithPartlyVisible) const | CXTPSyntaxEditDrawTextProcessor |
GetRowsMaxWidth() const | CXTPSyntaxEditDrawTextProcessor |
GetRowWidth(int nRow) const | CXTPSyntaxEditDrawTextProcessor |
GetScrollXOffset() const | CXTPSyntaxEditDrawTextProcessor |
GetSpaceWidth() const | CXTPSyntaxEditDrawTextProcessor |
GetTabSize() const | CXTPSyntaxEditDrawTextProcessor |
GetTextMetrics() const | CXTPSyntaxEditDrawTextProcessor |
GetTextRect() const | CXTPSyntaxEditDrawTextProcessor |
HitTest(const CPoint &pt, int &rnRow, int &rnCol, BOOL bVirtualSpace=FALSE) const | CXTPSyntaxEditDrawTextProcessor |
HitTestRow(int nY, int &rnRow) const | CXTPSyntaxEditDrawTextProcessor |
m_bUseOutputDC | CXTPSyntaxEditDrawTextProcessor | protected
m_nDrawingRow | CXTPSyntaxEditDrawTextProcessor | protected
m_nNextRowPosX | CXTPSyntaxEditDrawTextProcessor | protected
m_nPrintingRow | CXTPSyntaxEditDrawTextProcessor | protected
m_nRowHeight | CXTPSyntaxEditDrawTextProcessor | protected
m_nScrollXOffset | CXTPSyntaxEditDrawTextProcessor | protected
m_nSpaceWidth | CXTPSyntaxEditDrawTextProcessor | protected
m_nTabSize | CXTPSyntaxEditDrawTextProcessor | protected
m_ptNextPrintPos | CXTPSyntaxEditDrawTextProcessor | protected
m_rcTextRect | CXTPSyntaxEditDrawTextProcessor | protected
m_tmText | CXTPSyntaxEditDrawTextProcessor | protected
PrintRowPart(CDC *pDC, int nRow, int nPosY, UINT nFlags, LPCTSTR pcszText, int nchCount=-1, int *pnPrintedTextLen=NULL) | CXTPSyntaxEditDrawTextProcessor |
RecalcRowHeight(CDC *pDC, CFont *pFont) | CXTPSyntaxEditDrawTextProcessor |
ResetRowInfo(int nRow) | CXTPSyntaxEditDrawTextProcessor |
SetCaretByPoint(CWnd *pWnd, const CPoint &pt, const CSize &szSize, int &rnRow, int &rnCol, BOOL bVirtualSpace=FALSE) | CXTPSyntaxEditDrawTextProcessor |
SetCaretPos(CWnd *pWnd, const CSize &szSize, int nRow, int &rnCol, BOOL bHideCaret=FALSE, BOOL bVirtualSpace=FALSE) | CXTPSyntaxEditDrawTextProcessor |
SetRowTabPositions(int nRow, LPCTSTR pcszOrigRowText) | CXTPSyntaxEditDrawTextProcessor |
SetScrollXOffset(int nOffsetX) | CXTPSyntaxEditDrawTextProcessor |
SetTabSize(int nTabSize) | CXTPSyntaxEditDrawTextProcessor |
SetTextRect(const CRect &rcRect) | CXTPSyntaxEditDrawTextProcessor |
StrPosToDispPos(int nRow, int nStrPos, BOOL bVirtualSpace=FALSE) const | CXTPSyntaxEditDrawTextProcessor |


Toolkit Pro: XTPListBoxThemeVisualStudio2022.h Source File

  • Source
  • Controls
  • ListBox
  • Themes
XTPListBoxThemeVisualStudio2022.h
Go to the documentation of this file.
1
23#if !defined(__XTPLISTBOXTHEMEVISUALSTUDIO2022_H__)
24# define __XTPLISTBOXTHEMEVISUALSTUDIO2022_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPListBoxThemeVisualStudio2022 : public CXTPListBoxThemeOffice2013
39{
40public:
45 CXTPListBoxThemeVisualStudio2022();
46};
47
48# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
50#endif // !defined(__XTPLISTBOXTHEMEVISUALSTUDIO2022_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPListBoxThemeOffice2013
CXTPListBoxThemeOffice2013 is used by CXTPListBox to draw an Office 2013 style list box.
Definition XTPListBoxThemeOffice2013.h:39
CXTPListBoxThemeVisualStudio2022
CXTPListBoxThemeVisualStudio2022 is used by CXTPListBox to draw a Visual Studio 2022 style list box.
Definition XTPListBoxThemeVisualStudio2022.h:39
CXTPListBoxThemeVisualStudio2022::CXTPListBoxThemeVisualStudio2022
CXTPListBoxThemeVisualStudio2022()
Default constructor.


Toolkit Pro: XTPPreviewCtrl.h Source File

  • Source
  • Controls
  • Preview
XTPPreviewCtrl.h
Go to the documentation of this file.
1
23#if !defined(__XTPPREVIEWCTRL_H__)
24# define __XTPPREVIEWCTRL_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPPreviewHostWindow;
34class CXTPPreviewNavigatorWindow;
35
41class _XTP_EXT_CLASS CXTPPreviewCtrl : public CWnd
42{
44 DECLARE_DYNAMIC(CXTPPreviewCtrl)
46public:
51 CXTPPreviewCtrl();
52
57 virtual ~CXTPPreviewCtrl();
58
66 BOOL RegisterWindowClass(HINSTANCE hInstance = NULL);
67
84 virtual BOOL Create(DWORD dwStyle, const RECT& rect, CWnd* pParentWnd, UINT nID,
85 CCreateContext* pContext = NULL);
86
109 virtual BOOL CreateEx(DWORD dwExStyle, DWORD dwStyle, int x, int y, int nWidth, int nHeight,
110 HWND hWndParent, HMENU nIDorHMenu, LPVOID lpParam = NULL);
111
130 virtual BOOL CreateEx(DWORD dwExStyle, DWORD dwStyle, const RECT& rect, CWnd* pParentWnd,
131 UINT nID, LPVOID lpParam = NULL);
132
133 using CWnd::Create;
134 using CWnd::CreateEx;
135
141 void Preview(LPCTSTR lpFilePath);
142
151 void Preview(IStream* pStream, LPCTSTR lpImpliedFileName);
152
157 void Reset();
158
176 void AddProvider(IXTPPreviewProvider* provider, LPCTSTR associations = NULL);
177
190 void AddDefaultProviders();
191
200 void SetLoadingMessage(LPCTSTR message);
201
210 void SetFailedMessage(LPCTSTR message);
211
221 COLORREF GetBackgroundColor() const;
222
231 void SetBackgroundColor(COLORREF cr);
232
242 COLORREF GetForegroundColor() const;
243
252 void SetForegroundColor(COLORREF cr);
253
264 void EnableAutoPreviewActivate(BOOL bEnable = TRUE);
265
277 BOOL IsAutoPreviewActivateEnabled() const;
278
279protected:
281 DECLARE_MESSAGE_MAP()
282 virtual BOOL PreCreateWindow(CREATESTRUCT& cs);
283 virtual void PreSubclassWindow();
286private:
287 void SetCompositionWnd(HWND hCompositionWnd);
288 BOOL IsExtensionInString(const CString& strAssociation, LPCTSTR lpExt) const;
289 int CalcNavigatorHeight();
290 void CreateHostAndNavigator();
291 void ChangeChildrenPosition(WINDOWPOS* lpwndpos);
292 afx_msg int OnCreate(LPCREATESTRUCT lpCreateStruct);
293 afx_msg void OnDestroy();
294 afx_msg void OnWindowPosChanging(WINDOWPOS* lpwndpos);
295 afx_msg void OnWindowPosChanged(WINDOWPOS* lpwndpos);
296 afx_msg void OnFirst();
297 afx_msg void OnLast();
298 afx_msg void OnPrev();
299 afx_msg void OnNext();
300
301private:
302 CPtrArray m_providers;
303 CStringArray m_additionalAssociations;
304 CString m_strLoadingMessage;
305 CString m_strFailedMessage;
306 BOOL m_bChildrenCreated;
307 BOOL m_bShowNavigator;
308 CXTPPreviewHostWindow* m_pHostWindow;
309 CXTPPreviewNavigatorWindow* m_pNavigatorWindow;
310 CRect m_rPrevPlace;
311 int m_iNavHeight;
312 BOOL m_bSubclassed;
313 HWND m_hCompositionWnd;
314 COLORREF m_crBack;
315 COLORREF m_crFore;
316 BOOL m_bAutoActivate;
317};
319AFX_INLINE void CXTPPreviewCtrl::SetCompositionWnd(HWND hCompositionWnd)
320{
321 m_hCompositionWnd = hCompositionWnd;
322}
323
324AFX_INLINE COLORREF CXTPPreviewCtrl::GetBackgroundColor() const
325{
326 return m_crBack;
327}
328
329AFX_INLINE void CXTPPreviewCtrl::SetBackgroundColor(COLORREF cr)
330{
331 m_crBack = cr;
332}
333
334AFX_INLINE COLORREF CXTPPreviewCtrl::GetForegroundColor() const
335{
336 return m_crFore;
337}
338
339AFX_INLINE void CXTPPreviewCtrl::SetForegroundColor(COLORREF cr)
340{
341 m_crFore = cr;
342}
343
344AFX_INLINE void CXTPPreviewCtrl::EnableAutoPreviewActivate(BOOL bEnable /*= TRUE*/)
345{
346 m_bAutoActivate = bEnable;
347}
348
349AFX_INLINE BOOL CXTPPreviewCtrl::IsAutoPreviewActivateEnabled() const
350{
351 return m_bAutoActivate;
352}
354# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
356#endif // #if !defined(__XTPPREVIEWCTRL_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPPreviewCtrl
Implements the preview control that can display visual preview data provided by the best matching pre...
Definition XTPPreviewCtrl.h:42
CXTPPreviewCtrl::GetForegroundColor
COLORREF GetForegroundColor() const
Provides access to the foreground color value used for text messages in the preview area.
CXTPPreviewCtrl::~CXTPPreviewCtrl
virtual ~CXTPPreviewCtrl()
Handles control destruction.
CXTPPreviewCtrl::RegisterWindowClass
BOOL RegisterWindowClass(HINSTANCE hInstance=NULL)
Registers the window class if it has not already been registered.
CXTPPreviewCtrl::SetFailedMessage
void SetFailedMessage(LPCTSTR message)
Customizes the message displayed when a preview cannot be obtained.
CXTPPreviewCtrl::Reset
void Reset()
Resets the currently loaded preview.
CXTPPreviewCtrl::EnableAutoPreviewActivate
void EnableAutoPreviewActivate(BOOL bEnable=TRUE)
Sets an automatic preview activation on loading.
CXTPPreviewCtrl::IsAutoPreviewActivateEnabled
BOOL IsAutoPreviewActivateEnabled() const
Gets an automatic preview activation on loading.
CXTPPreviewCtrl::CXTPPreviewCtrl
CXTPPreviewCtrl()
Handles control construction.
CXTPPreviewCtrl::CreateEx
virtual BOOL CreateEx(DWORD dwExStyle, DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID, LPVOID lpParam=NULL)
Creates a preview control window object.
CXTPPreviewCtrl::Create
virtual BOOL Create(DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID, CCreateContext *pContext=NULL)
Creates a preview control window object.
CXTPPreviewCtrl::Preview
void Preview(LPCTSTR lpFilePath)
Sets a path to a file to preview.
CXTPPreviewCtrl::Preview
void Preview(IStream *pStream, LPCTSTR lpImpliedFileName)
Sets a path to a file to preview.
CXTPPreviewCtrl::SetForegroundColor
void SetForegroundColor(COLORREF cr)
Sets the foreground color value used for text messages in the preview area.
CXTPPreviewCtrl::SetBackgroundColor
void SetBackgroundColor(COLORREF cr)
Sets the background color value used for filling the preview area.
CXTPPreviewCtrl::AddProvider
void AddProvider(IXTPPreviewProvider *provider, LPCTSTR associations=NULL)
Adds a new preview provider object.
CXTPPreviewCtrl::CreateEx
virtual BOOL CreateEx(DWORD dwExStyle, DWORD dwStyle, int x, int y, int nWidth, int nHeight, HWND hWndParent, HMENU nIDorHMenu, LPVOID lpParam=NULL)
Creates a preview control window object.
CXTPPreviewCtrl::SetLoadingMessage
void SetLoadingMessage(LPCTSTR message)
Customizes the message displayed when a preview is being loaded.
CXTPPreviewCtrl::AddDefaultProviders
void AddDefaultProviders()
Adds all known providers with their default associations in the following order:
CXTPPreviewCtrl::GetBackgroundColor
COLORREF GetBackgroundColor() const
Provides access to the background color value used for filling the preview area.
IXTPPreviewProvider
Interface to be implemented by a preview provider.
Definition XTPPreviewAbstract.h:185


Toolkit Pro: Member List

CXTPCalendarMonthViewDay Member List

This is the complete list of members for CXTPCalendarMonthViewDay, including all inherited members.

AdjustLayout(CDC *pDC, const CRect &rcDay) | CXTPCalendarMonthViewDay | virtual
AdjustLayout2(CDC *pDC, const CRect &rcDay) | CXTPCalendarMonthViewDay | virtual
CalcDayDateRect() const | CXTPCalendarMonthViewDay |
ContainsInvisibleEvents() const | CXTPCalendarViewDay | virtual
ContainsInvisibleEventsUpdate() | CXTPCalendarViewDay | virtual
CreateGroup() | CXTPCalendarViewDayT< CXTPCalendarMonthView, CXTPCalendarMonthViewGroup, XTP_CALENDAR_HITTESTINFO, CXTPCalendarMonthViewDay > | inlinevirtual
CXTPCalendarMonthViewDay(const CXTPCalendarMonthView *pMonthView, int nWeekIndex, int nWeekDayIndex) | CXTPCalendarMonthViewDay |
CXTPCalendarViewDay(const CXTPCalendarView *pView) | CXTPCalendarViewDay |
CXTPCalendarViewDayT(const CXTPCalendarMonthView *pView) | CXTPCalendarViewDayT< CXTPCalendarMonthView, CXTPCalendarMonthViewGroup, XTP_CALENDAR_HITTESTINFO, CXTPCalendarMonthViewDay > | inline
CXTPCalendarWMHandler() | CXTPCalendarWMHandler |
CXTPCmdTarget() | CXTPCmdTarget |
Draw(CDC *pDC) | CXTPCalendarMonthViewDay | virtual
FillHitTestEx(XTP_CALENDAR_HITTESTINFO *pInfo) const | CXTPCalendarMonthViewDay | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCalendarControl() const | CXTPCalendarViewDay | virtual
GetChildHandlerAt(int nIndex) const | CXTPCalendarViewDay | inlinevirtual
GetChildHandlersCount() const | CXTPCalendarViewDay | inlinevirtual
GetDayDate() const | CXTPCalendarViewDay | virtual
GetDayEventsRect() const | CXTPCalendarMonthViewDay |
GetDayIndex() const | CXTPCalendarViewDay | virtual
GetDayRect() const | CXTPCalendarViewDay | virtual
GetExpandSignRect() const | CXTPCalendarViewDay | virtual
GetPThis() | CXTPCalendarMonthViewDay | protectedvirtual
GetResources() const | CXTPCalendarViewDay | virtual
GetView() const | CXTPCalendarViewDayT< CXTPCalendarMonthView, CXTPCalendarMonthViewGroup, XTP_CALENDAR_HITTESTINFO, CXTPCalendarMonthViewDay > | inline
GetView_() const | CXTPCalendarViewDay | virtual
GetViewEvent_(int nIndex) const | CXTPCalendarViewDay | virtual
GetViewEventsCount() const | CXTPCalendarViewDay | virtual
GetViewGroup(int nIndex) const | CXTPCalendarViewDayT< CXTPCalendarMonthView, CXTPCalendarMonthViewGroup, XTP_CALENDAR_HITTESTINFO, CXTPCalendarMonthViewDay > | inlinevirtual
GetViewGroup_(int nIndex) const | CXTPCalendarViewDay |
GetViewGroupsCount() const | CXTPCalendarViewDay |
HitTest(CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const | CXTPCalendarViewDay | virtual
HitTestEx(CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const | CXTPCalendarMonthViewDay | virtual
IsExpanded() const | CXTPCalendarViewDay | virtual
IsSelected() const | CXTPCalendarViewDay | virtual
KillTimer(UINT uTimerID) | CXTPCalendarViewDay | virtual
m_arViewGroups | CXTPCalendarViewDay | protected
m_dtDate | CXTPCalendarViewDay | protected
m_Layout | CXTPCalendarViewDay | protected
m_nWeekDayIndex | CXTPCalendarMonthViewDay | protected
m_nWeekIndex | CXTPCalendarMonthViewDay | protected
m_pResources | CXTPCalendarViewDay | protected
m_pView | CXTPCalendarViewDay | protected
OnBeforeDestroy() | CXTPCalendarWMHandler | virtual
OnChar(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnKeyUp(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnLButtonDblClk(UINT nFlags, CPoint point) | CXTPCalendarWMHandler | virtual
OnLButtonDown(UINT nFlags, CPoint point) | CXTPCalendarMonthViewDay | protectedvirtual
OnLButtonUp(UINT nFlags, CPoint point) | CXTPCalendarWMHandler | virtual
OnMouseMove(UINT nFlags, CPoint point) | CXTPCalendarMonthViewDay | protectedvirtual
OnPostAdjustLayout() | CXTPCalendarWMHandler | virtual
OnPrePopulateDay() | CXTPCalendarViewDay | protectedvirtual
OnSysKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnTimer(UINT_PTR uTimerID) | CXTPCalendarWMHandler | virtual
OnWndMsg(UINT message, WPARAM wParam, LPARAM lParam, LRESULT *pResult) | CXTPCalendarWMHandler | virtual
Populate(COleDateTime dtDayDate) | CXTPCalendarViewDay | virtual
SetDayDate(COleDateTime dtDayDate) | CXTPCalendarViewDay | virtual
SetDayRect(CRect rcDay) | CXTPCalendarViewDay | virtual
SetResources(CXTPCalendarResources *pResources) | CXTPCalendarViewDay | virtual
SetSelected() | CXTPCalendarMonthViewDay | virtual
SetTimer(UINT uTimeOut_ms) | CXTPCalendarViewDay | virtual
TBase typedef | CXTPCalendarMonthViewDay |
TView typedef | CXTPCalendarViewDayT< CXTPCalendarMonthView, CXTPCalendarMonthViewGroup, XTP_CALENDAR_HITTESTINFO, CXTPCalendarMonthViewDay > |
UserAction_OnExpandDay(XTPCalendarExpandDayButton eButton) | CXTPCalendarViewDay | virtual
~CXTPCalendarMonthViewDay() | CXTPCalendarMonthViewDay | virtual
~CXTPCalendarViewDay() | CXTPCalendarViewDay | virtual
~CXTPCalendarViewDayT() | CXTPCalendarViewDayT< CXTPCalendarMonthView, CXTPCalendarMonthViewGroup, XTP_CALENDAR_HITTESTINFO, CXTPCalendarMonthViewDay > | inlinevirtual


Toolkit Pro: XTPHookManager.h Source File

  • Source
  • Common
XTPHookManager.h
Go to the documentation of this file.
1
23#if !defined(__XTPHOOKMANAGER_H__)
24# define __XTPHOOKMANAGER_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPSimpleCriticalSection;
34
41class _XTP_EXT_CLASS CXTPHookManagerHookAble
42{
43public:
48 CXTPHookManagerHookAble();
49
54 virtual ~CXTPHookManagerHookAble();
55
56public:
73 virtual int OnHookMessage(HWND hWnd, UINT nMessage, WPARAM& wParam, LPARAM& lParam,
74 LRESULT& lResult);
75
90 virtual int OnPostHookMessage(HWND hWnd, UINT nMessage, WPARAM& wParam, LPARAM& lParam,
91 LRESULT& lResult);
92
101 virtual void OnHookAttached(HWND hWnd);
102
109 virtual void OnHookDetached();
110
111public:
112 BOOL m_bAutoDestroy;
113};
114
124class _XTP_EXT_CLASS CXTPHookManager
125{
126 friend class CXTPSingleton<CXTPHookManager>;
127
128private:
129 class CHookSink;
130
131protected:
136 CXTPHookManager();
137
138public:
144 ~CXTPHookManager();
145
146public:
154 void SetHook(HWND hWnd, CXTPHookManagerHookAble* pHook);
155
165 BOOL SetHook(int idHook, CXTPHookManagerHookAble* pHook, DWORD dwThreadId = 0);
166
173 void RemoveHook(HWND hWnd, CXTPHookManagerHookAble* pHook);
174
180 void RemoveAll(HWND hWnd);
181
187 void RemoveAll(CXTPHookManagerHookAble* pHook);
188
194 void RemoveAll(int idHook);
195
203 CHookSink* Lookup(HWND hWnd);
204
205public:
211 LRESULT Default();
212
223 LRESULT Default(WPARAM wParam, LPARAM lParam);
224
237 LRESULT Default(HWND hWnd, UINT message, WPARAM wParam, LPARAM lParam);
238
239private:
240 static LRESULT CALLBACK HookWndProc(HWND hWnd, UINT message, WPARAM wParam, LPARAM lParam);
241
242 static LRESULT CALLBACK OnWH_MSGFILTER(int nCode, WPARAM wParam, LPARAM lParam);
243 static LRESULT CALLBACK OnWH_KEYBOARD(int nCode, WPARAM wParam, LPARAM lParam);
244 static LRESULT CALLBACK OnWH_GETMESSAGE(int nCode, WPARAM wParam, LPARAM lParam);
245 static LRESULT CALLBACK OnWH_CALLWNDPROC(int nCode, WPARAM wParam, LPARAM lParam);
246 static LRESULT CALLBACK OnWH_CBT(int nCode, WPARAM wParam, LPARAM lParam);
247 static LRESULT CALLBACK OnWH_MOUSE(int nCode, WPARAM wParam, LPARAM lParam);
248 static LRESULT CALLBACK OnWH_HARDWARE(int nCode, WPARAM wParam, LPARAM lParam);
249 static LRESULT CALLBACK OnWH_DEBUG(int nCode, WPARAM wParam, LPARAM lParam);
250 static LRESULT CALLBACK OnWH_SHELL(int nCode, WPARAM wParam, LPARAM lParam);
251 static LRESULT CALLBACK OnWH_FOREGROUNDIDLE(int nCode, WPARAM wParam, LPARAM lParam);
252 static LRESULT CALLBACK OnWH_CALLWNDPROCRET(int nCode, WPARAM wParam, LPARAM lParam);
253 LRESULT OnWindowsHookProc(int idHook, int nCode, WPARAM wParam, LPARAM lParam);
254
255public:
256 static UINT m_nMsgSinkRemoved;
257
258private:
259 void RemoveAll();
260 void RemoveAll(HWND hWnd, BOOL bLastMessage);
261
262 CXTPSimpleCriticalSection* m_pGuard;
263 CMap<HWND, HWND, LPVOID, LPVOID> m_mapHooks;
264
265 typedef CMap<DWORD, DWORD, CHookSink*, CHookSink*> WindowsHookMap;
266 CArray<WindowsHookMap, WindowsHookMap&> m_WindowsHooks;
267
268 friend _XTP_EXT_CLASS CXTPHookManager* AFX_CDECL XTPHookManager();
269 friend class CHookSink;
270};
271
283_XTP_EXT_CLASS CXTPHookManager* AFX_CDECL XTPHookManager();
284
291enum XTPShadowOptions
292{
293 xtpShadowOfficeAlpha = 1,
294 xtpShadowShowPopupControl = 2
295};
296
302class _XTP_EXT_CLASS CXTPShadowManager : public CXTPCmdTarget
303{
304private:
305 typedef BOOL(WINAPI* LPFNUPDATELAYEREDWINDOW)(HWND hwnd, HDC hdcDst, POINT* pptDst, SIZE* psize,
306 HDC hdcSrc, POINT* pptSrc, COLORREF crKey,
307 BLENDFUNCTION* pblend, DWORD dwFlags);
308
309private:
310 class CShadowWnd;
311 class CShadowList;
312
313public:
318 CXTPShadowManager();
319
320public:
325 ~CXTPShadowManager();
326
327public:
334 BOOL IsAlphaShadow();
335
342 void SetShadow(CRect rcWindow, CWnd* pShadowOwner);
343
351 void SetShadow(CWnd* pShadowOwner, const CRect& rcExclude = CRect(0, 0, 0, 0), int nLevel = 0);
352
358 void RemoveShadow(CWnd* pShadowOwner);
365 void OffsetShadow(CWnd* pShadowOwner, CSize szOffset);
366
374 POSITION GetHeadPosition(CWnd* pShadowOwner) const;
375
384 CWnd* GetNext(POSITION& pos) const;
385
392 int GetShadowOptions() const;
400 void SetShadowOptions(int nOptions);
401
407 void SetShadowColor(COLORREF clrShadow);
408
409public:
410 BOOL m_bUseSystemSaveBitsStyle;
413private:
414 void DestroyShadow(CShadowWnd*);
415 CShadowWnd* CreateShadow(BOOL bHoriz, CRect rc, CRect rcExclude, CWnd* pShadowOwner,
416 BOOL bControlPopup, int nLevel);
417
418private:
419 LPFNUPDATELAYEREDWINDOW m_pfnUpdateLayeredWindow;
420 CShadowList* m_pShadows;
421 BOOL m_bAlphaShadow;
422 int m_nShadowOptions;
423 COLORREF m_clrShadowFactor;
424
425 friend class CShadowWnd;
426};
428AFX_INLINE int CXTPShadowManager::GetShadowOptions() const
429{
430 return m_nShadowOptions;
431}
432AFX_INLINE void CXTPShadowManager::SetShadowOptions(int nOptions)
433{
434 m_nShadowOptions = nOptions;
435}
436AFX_INLINE void CXTPShadowManager::SetShadowColor(COLORREF clrShadow)
437{
438 m_clrShadowFactor = clrShadow;
439}
441# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
443#endif //#if !defined(__XTPHOOKMANAGER_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPHookManager
_XTP_EXT_CLASS CXTPHookManager *AFX_CDECL XTPHookManager()
Call this function to access CXTPHookManager members.
XTPShadowOptions
XTPShadowOptions
Shadow options of selected paint manager.
Definition XTPHookManager.h:292
xtpShadowOfficeAlpha
@ xtpShadowOfficeAlpha
Office alpha shadow.
Definition XTPHookManager.h:293
xtpShadowShowPopupControl
@ xtpShadowShowPopupControl
Draw shadow for popup controls.
Definition XTPHookManager.h:294
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPHookManagerHookAble
HookAble interface.
Definition XTPHookManager.h:42
CXTPHookManagerHookAble::OnHookMessage
virtual int OnHookMessage(HWND hWnd, UINT nMessage, WPARAM &wParam, LPARAM &lParam, LRESULT &lResult)
This member function is called by WindowProc, or is called during message reflection.
CXTPHookManagerHookAble::OnPostHookMessage
virtual int OnPostHookMessage(HWND hWnd, UINT nMessage, WPARAM &wParam, LPARAM &lParam, LRESULT &lResult)
This member function is called after a message has been processed by default window procedure.
CXTPHookManagerHookAble::m_bAutoDestroy
BOOL m_bAutoDestroy
TRUE to automatically delete hook.
Definition XTPHookManager.h:112
CXTPHookManagerHookAble::OnHookDetached
virtual void OnHookDetached()
This member function is called right before a hook is to be detached from the window.
CXTPHookManagerHookAble::CXTPHookManagerHookAble
CXTPHookManagerHookAble()
Constructs a CXTPHookManagerHookAble object.
CXTPHookManagerHookAble::OnHookAttached
virtual void OnHookAttached(HWND hWnd)
This member function is called right after a hook is attached to the window.
CXTPHookManagerHookAble::~CXTPHookManagerHookAble
virtual ~CXTPHookManagerHookAble()
Destroys a CXTPHookManagerHookAble object, handles cleanup and deallocation.
CXTPHookManager
CXTPHookManager is standalone class.
Definition XTPHookManager.h:125
CXTPHookManager::XTPHookManager
friend _XTP_EXT_CLASS CXTPHookManager *AFX_CDECL XTPHookManager()
Call this function to access CXTPHookManager members.
CXTPHookManager::RemoveAll
void RemoveAll(CXTPHookManagerHookAble *pHook)
Removes a hookable object and associated hooks if applicable.
CXTPHookManager::~CXTPHookManager
~CXTPHookManager()
Destroys a CXTPHookManager object, handles cleanup and de- allocation.
CXTPHookManager::Default
LRESULT Default()
Calls the default window procedure.
CXTPHookManager::Lookup
CHookSink * Lookup(HWND hWnd)
Searches collection of Hookable interfaces that receive hooks of specified window.
CXTPHookManager::RemoveAll
void RemoveAll(int idHook)
Removes a local windows hook and all its associated hookable objects.
CXTPHookManager::Default
LRESULT Default(HWND hWnd, UINT message, WPARAM wParam, LPARAM lParam)
Calls the default window procedure.
CXTPHookManager::RemoveAll
void RemoveAll(HWND hWnd)
Removes all hooks associated with a window.
CXTPHookManager::SetHook
BOOL SetHook(int idHook, CXTPHookManagerHookAble *pHook, DWORD dwThreadId=0)
Sets local windows hook.
CXTPHookManager::RemoveHook
void RemoveHook(HWND hWnd, CXTPHookManagerHookAble *pHook)
Removes a hook associated with a window.
CXTPHookManager::CXTPHookManager
CXTPHookManager()
Constructs a CXTPHookManager object.
CXTPHookManager::SetHook
void SetHook(HWND hWnd, CXTPHookManagerHookAble *pHook)
This member function will hook a window so that its messages are intercepted before they are passed o...
CXTPHookManager::Default
LRESULT Default(WPARAM wParam, LPARAM lParam)
Calls the default window procedure.
CXTPShadowManager
CXTPShadowManager is standalone class used to manage CommandBars' shadows.
Definition XTPHookManager.h:303
CXTPShadowManager::OffsetShadow
void OffsetShadow(CWnd *pShadowOwner, CSize szOffset)
Call this method to move shadow to specified offset.
CXTPShadowManager::CXTPShadowManager
CXTPShadowManager()
Constructs a CXTPShadowManager object.
CXTPShadowManager::SetShadow
void SetShadow(CRect rcWindow, CWnd *pShadowOwner)
Sets the command bar shadow.
CXTPShadowManager::GetShadowOptions
int GetShadowOptions() const
Returns combination of XTPShadowOptions flags for shadows.
CXTPShadowManager::IsAlphaShadow
BOOL IsAlphaShadow()
Check the system alpha shadow ability.
CXTPShadowManager::SetShadow
void SetShadow(CWnd *pShadowOwner, const CRect &rcExclude=CRect(0, 0, 0, 0), int nLevel=0)
Sets the command bar shadow.
CXTPShadowManager::~CXTPShadowManager
~CXTPShadowManager()
Destroys a CXTPShadowManager object, handles cleanup and deallocation.
CXTPShadowManager::SetShadowColor
void SetShadowColor(COLORREF clrShadow)
Call this method to set specific color for shadows.
CXTPShadowManager::GetHeadPosition
POSITION GetHeadPosition(CWnd *pShadowOwner) const
This method used to enumerate all shadows of specific parent window.
CXTPShadowManager::SetShadowOptions
void SetShadowOptions(int nOptions)
Call this method to set shadow options.
CXTPShadowManager::m_bUseSystemSaveBitsStyle
BOOL m_bUseSystemSaveBitsStyle
If this flag is set CS_SAVEBITS style will be used for shadow windows.
Definition XTPHookManager.h:410
CXTPShadowManager::GetNext
CWnd * GetNext(POSITION &pos) const
This method used to enumerate all shadows of specific parent window.
CXTPShadowManager::RemoveShadow
void RemoveShadow(CWnd *pShadowOwner)
Removes shadows for the command bar.
CXTPSimpleCriticalSection
Implements simple and lightweight synchronization critical section primitive.
Definition XTPSynchro.h:112
CXTPSingleton
Implements Singleton design pattern.
Definition XTPSingleton.h:215


Toolkit Pro: Member List

CXTPChartRadarDiagramSeriesStyle Member List

This is the complete list of members for CXTPChartRadarDiagramSeriesStyle, including all inherited members.

ApplyTo(CXTPChartDeviceCommand *pCommand) | CXTPChartSeriesStyle | virtual
CorrectAxisSideMargins(CXTPChartAxis *pAxis, double nMinValue, double nMaxValue, double &nCorrection) | CXTPChartSeriesStyle | virtual
CreateDiagram() | CXTPChartRadarDiagramSeriesStyle | virtual
CreateView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)=0 | CXTPChartSeriesStyle | pure virtual
CXTPChartElement() | CXTPChartElement |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartRadarDiagramSeriesStyle() | CXTPChartRadarDiagramSeriesStyle |
CXTPChartSeriesStyle() | CXTPChartSeriesStyle |
DoPropExchange(CXTPPropExchange *pPX) | CXTPChartRadarDiagramSeriesStyle | virtual
Enable3dEdgeSmoothing(BOOL bEnable=TRUE) | CXTPChartSeriesStyle | virtual
Get3dRotation() const | CXTPChartSeriesStyle | virtual
GetAppearance() const | CXTPChartElement |
GetColor() const | CXTPChartSeriesStyle | virtual
GetContent() const | CXTPChartElement |
GetErrorBar() const | CXTPChartSeriesStyle | virtual
GetLabel() const | CXTPChartSeriesStyle | virtual
GetOwner() const | CXTPChartElement |
GetSeriesPointValueIndex() const | CXTPChartSeriesStyle | virtual
GetStyleAppearance() const | CXTPChartSeriesStyle | virtual
GetTransparency() const | CXTPChartSeriesStyle | virtual
Is3D() const | CXTPChartObject |
Is3dEdgeSmoothingEnabled() const | CXTPChartSeriesStyle | virtual
IsColorEach() const | CXTPChartSeriesStyle | virtual
IsStyleDiagram(CXTPChartDiagram *pDiagram) const | CXTPChartRadarDiagramSeriesStyle | virtual
m_bColorEach | CXTPChartSeriesStyle | protected
m_bSmooth3dEdges | CXTPChartSeriesStyle | protected
m_clrColor | CXTPChartSeriesStyle | protected
m_nTransparency | CXTPChartSeriesStyle | protected
m_pErrorBar | CXTPChartSeriesStyle | protected
m_pLabel | CXTPChartSeriesStyle | protected
m_Rotation3d | CXTPChartSeriesStyle | protected
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartElement | virtual
Release() | CXTPChartElement | virtual
Set3dRotation(const CXTPChart3dRotation &rotation) | CXTPChartSeriesStyle | virtual
Set3dRotation(double dYaw, double dPitch, double dRoll) | CXTPChartSeriesStyle | virtual
SetColor(CXTPChartColor clr) | CXTPChartSeriesStyle | virtual
SetColorEach(BOOL bColorEach) | CXTPChartSeriesStyle | virtual
SetErrorBar(CXTPChartErrorBar *pErrorBar) | CXTPChartSeriesStyle | virtual
SetLabel(CXTPChartSeriesLabel *pLabel) | CXTPChartSeriesStyle | virtual
SetTransparency(int nTransparency) | CXTPChartSeriesStyle | virtual
~CXTPChartElement() | CXTPChartElement | virtual
~CXTPChartRadarDiagramSeriesStyle() | CXTPChartRadarDiagramSeriesStyle | virtual
~CXTPChartSeriesStyle() | CXTPChartSeriesStyle | virtual


Toolkit Pro: Member List

CXTPShellTreeCtrl Member List

This is the complete list of members for CXTPShellTreeCtrl, including all inherited members.

AssociateCombo(CWnd *pWnd) | CXTPShellTreeCtrl | virtual
AssociateList(CWnd *pWnd) | CXTPShellTreeCtrl | virtual
CXTPShellTreeCtrl() | CXTPShellTreeCtrl |
EnableAutoInit(BOOL bEnable) | CXTPShellTreeCtrl |
Init() | CXTPShellTreeCtrl | virtual
m_bAutoInit | CXTPShellTreeCtrl | protected
m_pListCtrl | CXTPShellTreeCtrl | protected
SelectionChanged(HTREEITEM hItem, CString strFolderPath) | CXTPShellTreeCtrl | protectedvirtual
~CXTPShellTreeCtrl() | CXTPShellTreeCtrl | virtual


Toolkit Pro: XTPDockingPanePanelTheme2017.h Source File

  • Source
  • DockingPane
  • TabThemes
XTPDockingPanePanelTheme2017.h
Go to the documentation of this file.
1
23#if !defined(__XTPDOCKINGPANEPANELTHEME2017_H__)
24# define __XTPDOCKINGPANEPANELTHEME2017_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPDockingPanePanelTheme2017 : public CXTPDockingPanePanelTheme2012
39{
40public:
45 CXTPDockingPanePanelTheme2017();
46};
47
48# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
50#endif // !defined(__XTPDOCKINGPANEPANELTHEME2017_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPDockingPanePanelTheme2012
Helper class used to initialize default colors for a theme from an .INI resource and handle drawing r...
Definition XTPDockingPanePanelTheme2012.h:39
CXTPDockingPanePanelTheme2017
Helper class used to initialize default colors for a theme from an .INI resource and handle drawing r...
Definition XTPDockingPanePanelTheme2017.h:39
CXTPDockingPanePanelTheme2017::CXTPDockingPanePanelTheme2017
CXTPDockingPanePanelTheme2017()
Default class constructor.


Toolkit Pro: XTPChart3dFunnelSeriesLabelsViewDeviceCommand.h Source File

  • Source
  • Chart
  • Styles
  • Funnel
  • 3D
  • Commands
XTPChart3dFunnelSeriesLabelsViewDeviceCommand.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHART3DFUNNELSERIESLABELSVIEWDEVICECOMMAND_H__)
24# define __XTPCHART3DFUNNELSERIESLABELSVIEWDEVICECOMMAND_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChart3dFunnelSeriesLabelsView;
34class CXTPChart3dFunnelSeriesLabelView;
35class CXTPChart3dFunnelSeriesPointView;
36class CXTPChart3dFunnelSeriesLabelDeviceCommand;
37class CXTPChart3dDeviceContext;
38class CXTPChart3dFunnelSeriesLabel;
39
44class _XTP_EXT_CLASS CXTPChart3dFunnelSeriesLabelDeviceCommand : public CXTPChart3dDeviceCommand
45{
46 DECLARE_DYNAMIC(CXTPChart3dFunnelSeriesLabelDeviceCommand);
47
48public:
55 CXTPChart3dFunnelSeriesLabelDeviceCommand(CXTPChart3dFunnelSeriesLabelView* pSeriesLabelView);
56
57public:
64 virtual void ExecuteOverride(CXTPChartDeviceContext* pDC);
65
73 CXTPChart3dFunnelSeriesLabelView* GetSeriesLabelView() const;
74
85 BOOL IsFailed() const;
86
91 void SetFailed();
92
103 CRect GetLabelRect() const;
104
114 void SetLabelRect(CRect rcLabel);
115
125 BOOL ComputeConnectorVector(CXTPChart3dDeviceContext* pDC);
126
133 void ComputeLabel(CXTPChart3dDeviceContext* pDC);
134
145 double GetConnectorLength() const;
146
156 void SetConnectorLength(double dLength);
157
168 double GetConnectorEndpointVerticalOffset() const;
169
179 void SetConnectorEndpointVerticalOffset(double yOffset);
180
181private:
182 BOOL ComputeConnectorStartPoint(CXTPChart3dDeviceContext* pDC, CXTPPoint3d& ptStart,
183 CPoint& ptProjected) const;
184 CXTPPoint3d ComputeConnectorEndPoint() const;
185 CXTPPoint3d ComputeConnectorVectorEndPoint(const CXTPPoint3d& point) const;
186 void ComputeLabel_Outside(const CSize& szLabel, const CPoint& ptAnchorOrigin,
187 const CPoint& ptAnchor);
188 void ComputeLabel_Center(const CSize& szLabel, const CPoint& ptAnchor);
189
190private:
191 CXTPChart3dFunnelSeriesLabelView* m_pSeriesLabelView;
192 CXTPChart3dFunnelSeriesPointView* m_pPointView;
193 CRect m_rcLabel;
194 BOOL m_bFailed;
195 double m_dConnectorLength;
196 double m_dConnectorEndpointVerticalOffset;
197};
198
199AFX_INLINE BOOL CXTPChart3dFunnelSeriesLabelDeviceCommand::IsFailed() const
200{
201 return m_bFailed;
202}
203
204AFX_INLINE void CXTPChart3dFunnelSeriesLabelDeviceCommand::SetFailed()
205{
206 m_bFailed = TRUE;
207}
208
209AFX_INLINE CXTPChart3dFunnelSeriesLabelView*
210 CXTPChart3dFunnelSeriesLabelDeviceCommand::GetSeriesLabelView() const
211{
212 return m_pSeriesLabelView;
213}
214
215AFX_INLINE CRect CXTPChart3dFunnelSeriesLabelDeviceCommand::GetLabelRect() const
216{
217 return m_rcLabel;
218}
219
220AFX_INLINE void CXTPChart3dFunnelSeriesLabelDeviceCommand::SetLabelRect(CRect rcLabel)
221{
222 m_rcLabel = rcLabel;
223}
224
225AFX_INLINE double CXTPChart3dFunnelSeriesLabelDeviceCommand::GetConnectorLength() const
226{
227 return m_dConnectorLength;
228}
229
230AFX_INLINE void CXTPChart3dFunnelSeriesLabelDeviceCommand::SetConnectorLength(double dLength)
231{
232 m_dConnectorLength = dLength;
233}
234
235AFX_INLINE double
236 CXTPChart3dFunnelSeriesLabelDeviceCommand::GetConnectorEndpointVerticalOffset() const
237{
238 return m_dConnectorEndpointVerticalOffset;
239}
240
241AFX_INLINE void
242 CXTPChart3dFunnelSeriesLabelDeviceCommand::SetConnectorEndpointVerticalOffset(double yOffset)
243{
244 m_dConnectorEndpointVerticalOffset = yOffset;
245}
246
251class _XTP_EXT_CLASS CXTPChart3dFunnelSeriesLabelsViewDeviceCommand
252 : public CXTPChart3dDeviceCommand
253 , private CXTPChartDeviceCommandEvents
254{
255public:
262 CXTPChart3dFunnelSeriesLabelsViewDeviceCommand(
263 CXTPChart3dFunnelSeriesLabelsView* pSeriesLabelsView);
264
265public:
272 virtual void ExecuteOverride(CXTPChartDeviceContext* pDC);
273
274private:
275 CXTPChart3dFunnelSeriesLabel* GetLabel() const;
276 void ComputeLabelConnectorVectors(CXTPChart3dDeviceContext* pDC);
277 void ComputeLabels(CXTPChart3dDeviceContext* pDC);
278 BOOL ResolveLabelOverlaps(CXTPChart3dDeviceContext* pDC);
279 BOOL ResolveLabelOverlaps_ChangeConnectorLength(CXTPChart3dDeviceContext* pDC);
280
281 CXTPChart3dFunnelSeriesLabelDeviceCommand*
282 FindLabelDeviceCommand(CXTPChartDeviceCommand* pCommand) const;
283
284private:
285 virtual void OnAfterExecute(CXTPChartDeviceCommand* pCommand, CXTPChartDeviceContext* pDC);
286
287 struct CommandCallbackData
288 {
289 enum State
290 {
291 None,
292 ComputeVector
293 };
294
295 CommandCallbackData(State state = None);
296 void SwitchTo(State state);
297 State GetState() const;
298
299 BOOL bSuccess;
300 CXTPChart3dDeviceContext* pDC;
301 CXTPChart3dFunnelSeriesLabelDeviceCommand* pLabelCommand;
302
303 private:
304 State state;
305 };
306
307 CommandCallbackData m_CommandCallbackData;
308
309protected:
310 CXTPChart3dFunnelSeriesLabelsView* m_pSeriesLabelsView;
311};
312
313AFX_INLINE void
314 CXTPChart3dFunnelSeriesLabelsViewDeviceCommand::CommandCallbackData::SwitchTo(State newState)
315{
316 *this = CommandCallbackData(newState);
317}
318
319AFX_INLINE CXTPChart3dFunnelSeriesLabelsViewDeviceCommand::CommandCallbackData::State
320 CXTPChart3dFunnelSeriesLabelsViewDeviceCommand::CommandCallbackData::GetState() const
321{
322 return state;
323}
324
325AFX_INLINE CXTPChart3dFunnelSeriesLabelsViewDeviceCommand::CommandCallbackData::CommandCallbackData(
326 State state)
327 : bSuccess(FALSE)
328 , pDC(NULL)
329 , pLabelCommand(NULL)
330 , state(state)
331{
332}
334# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
335#endif //#if !defined(__XTPCHART3DFUNNELSERIESLABELSVIEWDEVICECOMMAND_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChart3dDeviceCommand
Defines a common implementation interface for chart 3D drawing commands.
Definition XTPChartDeviceCommand.h:368
CXTPChart3dDeviceContext
A base implementation of 3D device context.
Definition XTPChart3dDeviceContext.h:48
CXTPChart3dFunnelSeriesLabelDeviceCommand
Implements 3D chart funnel series label device command.
Definition XTPChart3dFunnelSeriesLabelsViewDeviceCommand.h:45
CXTPChart3dFunnelSeriesLabelDeviceCommand::SetConnectorLength
void SetConnectorLength(double dLength)
Sets connector length value.
Definition XTPChart3dFunnelSeriesLabelsViewDeviceCommand.h:230
CXTPChart3dFunnelSeriesLabelDeviceCommand::GetConnectorEndpointVerticalOffset
double GetConnectorEndpointVerticalOffset() const
Determines connector endpoint vertical offset value.
Definition XTPChart3dFunnelSeriesLabelsViewDeviceCommand.h:236
CXTPChart3dFunnelSeriesLabelDeviceCommand::ComputeLabel
void ComputeLabel(CXTPChart3dDeviceContext *pDC)
Computes label.
CXTPChart3dFunnelSeriesLabelDeviceCommand::CXTPChart3dFunnelSeriesLabelDeviceCommand
CXTPChart3dFunnelSeriesLabelDeviceCommand(CXTPChart3dFunnelSeriesLabelView *pSeriesLabelView)
Constructs a CXTPChart3dFunnelSeriesLabelDeviceCommand object.
CXTPChart3dFunnelSeriesLabelDeviceCommand::SetFailed
void SetFailed()
Sets command object to a failed state.
Definition XTPChart3dFunnelSeriesLabelsViewDeviceCommand.h:204
CXTPChart3dFunnelSeriesLabelDeviceCommand::SetConnectorEndpointVerticalOffset
void SetConnectorEndpointVerticalOffset(double yOffset)
Sets connector endpoint vertical offset value.
Definition XTPChart3dFunnelSeriesLabelsViewDeviceCommand.h:242
CXTPChart3dFunnelSeriesLabelDeviceCommand::ComputeConnectorVector
BOOL ComputeConnectorVector(CXTPChart3dDeviceContext *pDC)
Computes connector vector.
CXTPChart3dFunnelSeriesLabelDeviceCommand::ExecuteOverride
virtual void ExecuteOverride(CXTPChartDeviceContext *pDC)
Override this function to write the drawing code for specific objects.
CXTPChart3dFunnelSeriesLabelDeviceCommand::GetLabelRect
CRect GetLabelRect() const
Obtains label rectangle.
Definition XTPChart3dFunnelSeriesLabelsViewDeviceCommand.h:215
CXTPChart3dFunnelSeriesLabelDeviceCommand::GetConnectorLength
double GetConnectorLength() const
Determines connector length value.
Definition XTPChart3dFunnelSeriesLabelsViewDeviceCommand.h:225
CXTPChart3dFunnelSeriesLabelDeviceCommand::IsFailed
BOOL IsFailed() const
Checks whether command object is in a failed state.
Definition XTPChart3dFunnelSeriesLabelsViewDeviceCommand.h:199
CXTPChart3dFunnelSeriesLabelDeviceCommand::GetSeriesLabelView
CXTPChart3dFunnelSeriesLabelView * GetSeriesLabelView() const
Obtains label view object pointer.
Definition XTPChart3dFunnelSeriesLabelsViewDeviceCommand.h:210
CXTPChart3dFunnelSeriesLabelDeviceCommand::SetLabelRect
void SetLabelRect(CRect rcLabel)
Sets label rectangle.
Definition XTPChart3dFunnelSeriesLabelsViewDeviceCommand.h:220
CXTPChart3dFunnelSeriesLabel
CXTPChartFunnelSeriesLabelBase is a kind of CXTPChart3dFunnelSeriesLabel.
Definition XTPChart3dFunnelSeriesLabel.h:45
CXTPChart3dFunnelSeriesLabelView
Represents a series label view object.
Definition XTPChart3dFunnelSeriesLabel.h:77
CXTPChart3dFunnelSeriesLabelsViewDeviceCommand
Represents device command for all funnel series labels view.
Definition XTPChart3dFunnelSeriesLabelsViewDeviceCommand.h:254
CXTPChart3dFunnelSeriesLabelsViewDeviceCommand::m_pSeriesLabelsView
CXTPChart3dFunnelSeriesLabelsView * m_pSeriesLabelsView
View pointer.
Definition XTPChart3dFunnelSeriesLabelsViewDeviceCommand.h:310
CXTPChart3dFunnelSeriesLabelsViewDeviceCommand::CXTPChart3dFunnelSeriesLabelsViewDeviceCommand
CXTPChart3dFunnelSeriesLabelsViewDeviceCommand(CXTPChart3dFunnelSeriesLabelsView *pSeriesLabelsView)
Constructs a command object instance.
CXTPChart3dFunnelSeriesLabelsViewDeviceCommand::ExecuteOverride
virtual void ExecuteOverride(CXTPChartDeviceContext *pDC)
Override this function to write the drawing code for specific objects.
CXTPChart3dFunnelSeriesLabelsView
Represents a view object for all funnel series labels.
Definition XTPChart3dFunnelSeriesLabel.h:386
CXTPChart3dFunnelSeriesPointView
This class abstracts the view of a funnel series point.
Definition XTPChart3dFunnelSeriesPointView.h:47
CXTPChartDeviceCommandEvents
Defines a callback interface for a chart device command event sink.
Definition XTPChartDeviceCommand.h:48
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPPoint3T< double >


Toolkit Pro: Member List

CXTPCalendarDayView Member List

This is the complete list of members for CXTPCalendarDayView, including all inherited members.

_CalculateEventTimeFormat() | CXTPCalendarView | protectedvirtual
_CanSubjectEditor(UINT idEditCmd) const | CXTPCalendarView | protectedvirtual
_CopySelectedEvents(DWORD dwCopyFlags=0) | CXTPCalendarView | protectedvirtual
_EnsureVisibleH(CXTPCalendarViewEvent *pViewEvent) | CXTPCalendarDayView | protected
_EnsureVisibleSelectionH() | CXTPCalendarDayView | protected
_EnsureVisibleV(CXTPCalendarViewEvent *pViewEvent) | CXTPCalendarDayView | protected
_GetDayHeaderFormat(int nLevel) const | CXTPCalendarView | protectedvirtual
_GetMaxWidth(CDC *pDC, CString strFormat) const | CXTPCalendarView | protectedvirtual
_GetMaxWidthFormat(CDC *pDC, CString strFormat, BOOL bMonth) const | CXTPCalendarView | protectedvirtual
_GetScrollRectClient() const | CXTPCalendarDayView | protected
_GetSubjectEditorWnd() const | CXTPCalendarView | protectedvirtual
_GetTimeScaleWith() const | CXTPCalendarDayView | protected
_GetViewDay(const COleDateTime &dtDay) const | CXTPCalendarView | virtual
_IsDragModeCopyMove(int eDragMode) const | CXTPCalendarView | protected
_ReadDefaultHeaderFormats() | CXTPCalendarView | protectedvirtual
_ReadEventsFromClipboard(COleDataObject *pData, DWORD *pdwCopyFlags=NULL) | CXTPCalendarView | protectedvirtual
_RemoveYearPart(CString &strFormat) | CXTPCalendarView | protectedvirtual
_ScrollV(int nIndex, int nPos_raw) | CXTPCalendarDayView | protectedvirtual
_Undo(CXTPCalendarEvent *pEvent=NULL) | CXTPCalendarView | protectedvirtual
AddDay(const COleDateTime &date) | CXTPCalendarDayView | virtual
AddToDiscreteSelection(UINT id) | CXTPCalendarView |
AdjustAdditionalScaleTimeZone() | CXTPCalendarDayView | protectedvirtual
AdjustLayout(CDC *pDC, const CRect &rcView, BOOL bCallPostAdjustLayout=TRUE) | CXTPCalendarDayView | virtual
AdjustLayout2(CDC *pDC, const CRect &rcView, BOOL bCallPostAdjustLayout=TRUE) | CXTPCalendarDayView | virtual
CalculateHeaderFormat(CDC *pDC, int nWidth, CFont *pTextFont) | CXTPCalendarView | virtual
CancelDraggingEvent() | CXTPCalendarView | virtual
CanCopy() const | CXTPCalendarView | virtual
CanCut() const | CXTPCalendarView | virtual
CanPaste() const | CXTPCalendarView | virtual
CanRedo() const | CXTPCalendarView | virtual
CanUndo() const | CXTPCalendarView | virtual
ClearDiscreteSelection() | CXTPCalendarView |
CommitDraggingEvent() | CXTPCalendarView | virtual
Copy() | CXTPCalendarView | virtual
Cut() | CXTPCalendarView | virtual
CXTPCalendarDayView(CXTPCalendarControl *pCalendarControl) | CXTPCalendarDayView |
CXTPCalendarView(CXTPCalendarControl *pCalendarControl) | CXTPCalendarView |
CXTPCalendarViewT(CXTPCalendarControl *pCalendarControl, XTPCalendarViewType nViewType) | CXTPCalendarViewT< CXTPCalendarDayViewDay > | inline
CXTPCalendarWMHandler() | CXTPCalendarWMHandler |
CXTPCmdTarget() | CXTPCmdTarget |
Draw(CDC *pDC) | CXTPCalendarDayView | virtual
Draw2(CDC *pDC) | CXTPCalendarDayView | virtual
EmptyUndoBuffer() | CXTPCalendarView | virtual
EnableHScroll(BOOL bEnable=TRUE) | CXTPCalendarView | virtual
EnableVScroll(BOOL bEnable=TRUE) | CXTPCalendarView | virtual
EndEditSubject(XTPCalendarEndEditSubjectAction eAction, BOOL bUpdateControl=TRUE) | CXTPCalendarView | virtual
EnsureVisible(CXTPCalendarViewEvent *pViewEvent) | CXTPCalendarDayView | virtual
EnsureVisibleH(CXTPCalendarViewEvent *pViewEvent) | CXTPCalendarDayView | virtual
EnsureVisibleH(CXTPCalendarViewGroup *pViewGroup) | CXTPCalendarDayView | virtual
FindEventToEditByTAB(COleDateTime dtMinStart, BOOL bReverse, CXTPCalendarEvent *pAfterEvent=NULL) | CXTPCalendarDayView | protectedvirtual
FindLastSelectedDay() const | CXTPCalendarView |
FindViewEvent(CXTPCalendarEvent *pEvent, COleDateTime dtDay) const | CXTPCalendarView | virtual
FormatEventTime(COleDateTime dtTime) const | CXTPCalendarView | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAdditionalScaleText() const | CXTPCalendarDayView |
GetAdditionalScaleTimeZone() const | CXTPCalendarDayView |
GetAdditionalScaleTimeZoneInfo() const | CXTPCalendarDayView |
GetCalendarControl() const | CXTPCalendarView |
GetCalendarOptions() const | CXTPCalendarView |
GetCellDuration() const | CXTPCalendarDayView |
GetCellNumber(COleDateTime dtTime, BOOL bForEndTime) const | CXTPCalendarDayView |
GetCellNumber(int nHour, int nMin, int nSec, BOOL bForEndTime) const | CXTPCalendarDayView |
GetCellTime(int nCell) const | CXTPCalendarDayView |
GetChildHandlerAt(int nIndex) const | CXTPCalendarView | virtual
GetChildHandlersCount() const | CXTPCalendarView | virtual
GetCurrentTimeZoneInfo() const | CXTPCalendarDayView |
GetDay(COleDateTime dtDay) | CXTPCalendarDayView | virtual
GetDayHeaderFormat() const | CXTPCalendarView | virtual
GetDiscreteSelectionCount() const | CXTPCalendarView |
GetDiscreteSelectionValue(UINT id) const | CXTPCalendarView |
GetDraggingEventNew() const | CXTPCalendarView | virtual
GetDraggingEventOrig() const | CXTPCalendarView | virtual
GetDraggingMode() const | CXTPCalendarView | virtual
GetEventDurationMin() const | CXTPCalendarDayView | protectedvirtual
GetIsCanHScrollGroupsLeft(COleDateTime dtNewSelEnd, BOOL bVKShift) | CXTPCalendarDayView | protected
GetIsCanHScrollGroupsRight(COleDateTime dtNewSelEnd, BOOL bVKShift) | CXTPCalendarDayView | protected
GetItemTextEventTimeMax() const | CXTPCalendarView | virtual
GetLastSelectedDate() const | CXTPCalendarView |
GetLastSelectedViewEvent() const | CXTPCalendarView |
GetMinColumnWidth() const | CXTPCalendarDayView | virtual
GetNeededScrollDirection(CPoint pnt) const | CXTPCalendarDayView | protectedvirtual
GetNextTimeEditByTAB() const | CXTPCalendarDayView | protectedvirtual
GetPaintManager() const | CXTPCalendarView | virtual
GetResources() const | CXTPCalendarView | virtual
GetRowCount() const | CXTPCalendarDayView |
GetRowHeight() const | CXTPCalendarView | virtual
GetScaleInterval() const | CXTPCalendarDayView |
GetScaleMaxTime() const | CXTPCalendarDayView |
GetScaleMinTime() const | CXTPCalendarDayView |
GetScaleText() const | CXTPCalendarDayView |
GetScrollBarInfoH(SCROLLINFO *pSI, int *pnScrollStep=NULL) const | CXTPCalendarDayView | virtual
GetScrollBarInfoV(SCROLLINFO *pSI) const | CXTPCalendarDayView | virtual
GetSelectedEvents() const | CXTPCalendarView | virtual
GetSelectedViewEvents() const | CXTPCalendarView | virtual
GetSelection(COleDateTime *pBegin=NULL, COleDateTime *pEnd=NULL, BOOL *pbAllDayEvent=NULL, int *pnGroupIndex=NULL, COleDateTimeSpan *pspSelectionResolution=NULL) const | CXTPCalendarDayView | virtual
GetShowToolTipTimeOut() const | CXTPCalendarView | virtual
GetStartEditSubjectTimeOut() const | CXTPCalendarView | virtual
GetSubjectEditorRect() const | CXTPCalendarView | virtual
GetTheme() const | CXTPCalendarView | virtual
GetTimeScale(int nNumber=1) const | CXTPCalendarDayView | virtual
GetTooltipRect(const CPoint &ptHit, const XTP_CALENDAR_HITTESTINFO &hitInfo) const | CXTPCalendarView | virtual
GetTopRow() const | CXTPCalendarDayView |
GetViewDay(int nIndex) const | CXTPCalendarViewT< CXTPCalendarDayViewDay > | inlinevirtual
GetViewDay_(int nIndex) const | CXTPCalendarView | virtual
GetViewDayCount() const | CXTPCalendarView | virtual
GetViewDayDate(int nIndex) const | CXTPCalendarDayView | virtual
GetViewRect() const | CXTPCalendarView |
GetViewType() const | CXTPCalendarDayView | virtual
GetVisibleRowCount() const | CXTPCalendarDayView |
HasSelectedViewEvent() const | CXTPCalendarView | virtual
HitTest(CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const | CXTPCalendarView | virtual
HitTestEx(CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const | CXTPCalendarDayView | virtual
HorzEventScroll(BOOL bLeft) | CXTPCalendarDayView | protectedvirtual
IsAdditionalScaleLeftVisible() const | CXTPCalendarDayView |
IsAdditionalScaleRightVisible() const | CXTPCalendarDayView |
IsDrawNowLineOverAppoinment() const | CXTPCalendarDayView |
IsEditingSubject() const | CXTPCalendarView | virtual
IsEditOperationDisabledNotify(XTPCalendarEditOperation eOperation, CXTPCalendarViewEvent *pEventView) const | CXTPCalendarView | protected
IsExpandDown() const | CXTPCalendarDayView |
IsExpandUp() const | CXTPCalendarDayView |
IsGroupHeaderVisible() const | CXTPCalendarDayView | virtual
IsHScrollEnabled() const | CXTPCalendarView | virtual
IsInDiscreteSelection(UINT id) const | CXTPCalendarView |
IsOutOfClientRect(CPoint pnt, XTP_CALENDAR_HITTESTINFO *pHitInfo) | CXTPCalendarDayView | protectedvirtual
IsScaleLeftVisible() const | CXTPCalendarDayView |
IsScaleRightVisible() const | CXTPCalendarDayView |
IsSingleEventSelected() const | CXTPCalendarView |
IsTodayVisible() const | CXTPCalendarView | virtual
IsVScrollEnabled() const | CXTPCalendarView | virtual
KillTimer(UINT uTimerID) | CXTPCalendarView | protectedvirtual
m_arDays | CXTPCalendarView | mutableprotected
m_bDF_mode | CXTPCalendarDayView |
m_bDraftMode | CXTPCalendarDayView |
m_bEcoAllDayMode | CXTPCalendarDayView |
m_bHideLinkContainer | CXTPCalendarDayView |
m_bPreventDragAllDayEventInDayView | CXTPCalendarDayView |
m_bPrintFullScale | CXTPCalendarDayView |
m_bPrintRepeatHeaderFooterMode | CXTPCalendarDayView |
m_bResetUndoBuffer | CXTPCalendarView | protected
m_bScrollH_Disabled | CXTPCalendarView | protected
m_bScrollV_Disabled | CXTPCalendarView | protected
m_bShowAllDayEventsOnly | CXTPCalendarDayView |
m_bShowLinks | CXTPCalendarDayView |
m_bStartedClickInside | CXTPCalendarView | protected
m_bUseNewHitTestCode | CXTPCalendarDayView |
m_cntSelChanged | CXTPCalendarView | protected
m_dtTimeScaleMax | CXTPCalendarDayView |
m_dtTimeScaleMin | CXTPCalendarDayView |
m_eDraggingMode | CXTPCalendarView | protected
m_eUndoMode | CXTPCalendarView | protected
m_EventTimeFormat | CXTPCalendarView | protected
m_LastHitInfo | CXTPCalendarView | protected
m_Layout | CXTPCalendarView | protected
m_LayoutX | CXTPCalendarDayView | protected
m_nCurPage | CXTPCalendarDayView |
m_nDayHeaderPeriod | CXTPCalendarDayView |
m_nDayViewPrintInterval | CXTPCalendarDayView |
m_nKeyStateTimerID | CXTPCalendarView | protected
m_nMinColumnWidth | CXTPCalendarDayView | protected
m_nScrollOffsetX | CXTPCalendarDayView | protected
m_nTimerID_ShowToolTip | CXTPCalendarView | protected
m_nTimerID_StartEditSubject | CXTPCalendarView | protected
m_pControl | CXTPCalendarView | protected
m_pLastEvent | CXTPCalendarView | protected
m_pPrevUndoBuffer | CXTPCalendarView | protected
m_pResources | CXTPCalendarView | protected
m_pSelectedEvents | CXTPCalendarView | protected
m_ptrDraggingEventNew | CXTPCalendarView | protected
m_ptrDraggingEventOrig | CXTPCalendarView | protected
m_ptrEditingViewEvent | CXTPCalendarView | protected
m_ptStartDragging | CXTPCalendarView | protected
m_pUndoBuffer | CXTPCalendarView | protected
m_rcTooltip | CXTPCalendarView | protected
m_rcView | CXTPCalendarView | protected
m_selectedBlock | CXTPCalendarView | protected
m_spDraggingStartOffset | CXTPCalendarView | protected
m_strDayHeaderFormatDefaultLong | CXTPCalendarView | protected
m_strDayHeaderFormatDefaultMiddle | CXTPCalendarView | protected
m_strDayHeaderFormatDefaultShort | CXTPCalendarView | protected
m_strDayHeaderFormatDefaultShortest | CXTPCalendarView | protected
m_strDayHeaderFormatLong | CXTPCalendarView | protected
m_strDayHeaderFormatMiddle | CXTPCalendarView | protected
m_strDayHeaderFormatShort | CXTPCalendarView | protected
m_strDayHeaderFormatShortest | CXTPCalendarView | protected
m_strHeaderFormat | CXTPCalendarView | protected
OnActivateView(BOOL bActivate, CXTPCalendarView *pActivateView, CXTPCalendarView *pInactiveView) | CXTPCalendarDayView | protectedvirtual
OnBeforeDestroy() | CXTPCalendarView | protectedvirtual
OnBeforeEditOperationNotify(XTPCalendarEditOperation eOperation, CXTPCalendarViewEvent *pEventView) | CXTPCalendarView | protected
OnBeforeEditOperationNotify(XTPCalendarEditOperation eOperation, CXTPCalendarViewEvents *pEventViews) | CXTPCalendarView | protected
OnBeforePasteNotify(CXTPCalendarEvent *pEvent, BOOL bPasteWillChangeExistingEvent) | CXTPCalendarView | protected
OnChar(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarView | virtual
OnDragging(CPoint point, XTP_CALENDAR_HITTESTINFO *pHitTest) | CXTPCalendarDayView | protectedvirtual
OnDraw(CDC *pDC) | CXTPCalendarDayView | virtual
OnEndDragging(CPoint point, XTP_CALENDAR_HITTESTINFO *pHitInfo) | CXTPCalendarDayView | protectedvirtual
OnEventChanged_InDataProvider(XTP_NOTIFY_CODE nfCode, CXTPCalendarEvent *pEvent) | CXTPCalendarView | protectedvirtual
OnInPlaceCreateEvent(LPCTSTR pcszInitialSubject) | CXTPCalendarView | protected
OnKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarDayView | virtual
OnKeyUp(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnLButtonDblClk(UINT nFlags, CPoint point) | CXTPCalendarView | virtual
OnLButtonDown(UINT nFlags, CPoint point) | CXTPCalendarDayView | virtual
OnLButtonUp(UINT nFlags, CPoint point) | CXTPCalendarDayView | virtual
OnMouseMove(UINT nFlags, CPoint point) | CXTPCalendarDayView | virtual
OnPostAdjustLayout() | CXTPCalendarWMHandler | virtual
OnScrollEnd(int nBar) | CXTPCalendarView | inlinevirtual
OnStartDragging(CPoint point, XTP_CALENDAR_HITTESTINFO *pHitTest) | CXTPCalendarDayView | protectedvirtual
OnSysKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarView | virtual
OnTimer(UINT_PTR uTimerID) | CXTPCalendarDayView | protectedvirtual
OnUpdateEditingSubject(CString strNewSubject) | CXTPCalendarView | virtual
OnWndMsg(UINT message, WPARAM wParam, LPARAM lParam, LRESULT *pResult) | CXTPCalendarWMHandler | virtual
Paste() | CXTPCalendarView | virtual
Populate() | CXTPCalendarView | virtual
ProcessDaySelection(XTP_CALENDAR_HITTESTINFO *pInfo, UINT nFlags) | CXTPCalendarDayView | protectedvirtual
ProcessEventSelection(XTP_CALENDAR_HITTESTINFO *pInfo, UINT nFlags) | CXTPCalendarView | virtual
Redo() | CXTPCalendarView | virtual
RedrawControl() | CXTPCalendarView | virtual
ResetCustomTimeFormat() | CXTPCalendarView |
ResetSelection() | CXTPCalendarView |
RetrieveDayEvents(CXTPCalendarResource *pRC, COleDateTime dtDay) | CXTPCalendarView | virtual
ScrollDaysToNext(int nScrollDaysCount=1) | CXTPCalendarDayView | virtual
ScrollDaysToPrev(int nScrollDaysCount=1) | CXTPCalendarDayView | virtual
ScrollH(int nPos, int nPos_raw) | CXTPCalendarDayView | virtual
ScrollToColumn(long lColumn) | CXTPCalendarDayView |
ScrollToWorkDayBegin() | CXTPCalendarDayView | virtual
ScrollV(int nPos, int nPos_raw) | CXTPCalendarDayView | virtual
SelectDay(CXTPCalendarViewDay *pDay, int nGroupIndex) | CXTPCalendarDayView | protectedvirtual
SelectDay(CXTPCalendarViewDay *pDay) | CXTPCalendarDayView | protectedvirtual
CXTPCalendarViewT< CXTPCalendarDayViewDay >::SelectDay(COleDateTime dtSelDay, int nGroupIndex=0) | CXTPCalendarView | virtual
SelectDays(COleDateTime dtNewSel) | CXTPCalendarView | virtual
SelectEvent(CXTPCalendarEvent *pEvent, BOOL bSelect=TRUE) | CXTPCalendarView | virtual
SelectionContains(COleDateTime date, int nGroupIndex=-1, BOOL *pbAllDaySelection=NULL) | CXTPCalendarView |
SelectViewEvent(CXTPCalendarViewEvent *pViewEvent, BOOL bSelect=TRUE) | CXTPCalendarView |
SendNotification(XTP_NOTIFY_CODE EventCode, WPARAM wParam=0, LPARAM lParam=0) | CXTPCalendarView | protectedvirtual
SetAdditionalScaleText(LPCTSTR strText) | CXTPCalendarDayView |
SetAdditionalScaleTimeZone(const TIME_ZONE_INFORMATION *pTzInfo) | CXTPCalendarDayView |
SetCustomTimeFormat(const CString &strFormat) | CXTPCalendarView |
SetDayHeaderFormat(LPCTSTR sFmt) | CXTPCalendarView | virtual
SetDayHeaderFormatLong(LPCTSTR pcszCustomFormat) | CXTPCalendarView | virtual
SetDayHeaderFormatMiddle(LPCTSTR pcszCustomFormat) | CXTPCalendarView | virtual
SetDayHeaderFormatShort(LPCTSTR pcszCustomFormat) | CXTPCalendarView | virtual
SetDayHeaderFormatShortest(LPCTSTR pcszCustomFormat) | CXTPCalendarView | virtual
SetDraggingEvent(CXTPCalendarEvent *pEventOrig) | CXTPCalendarView | virtual
SetMinColumnWidth(int nWidth) | CXTPCalendarDayView | virtual
SetMouseOutOfDragArea(BOOL bOutOfArea) | CXTPCalendarDayView | protectedvirtual
SetResources(CXTPCalendarResources *pResources) | CXTPCalendarView | virtual
SetScaleInterval(const COleDateTimeSpan spScaleInterval) | CXTPCalendarDayView |
SetScaleMaxTime(const COleDateTime dtNewScaleMaxTime) | CXTPCalendarDayView |
SetScaleMinTime(const COleDateTime dtNewScaleMinTime) | CXTPCalendarDayView |
SetScaleText(LPCTSTR strText) | CXTPCalendarDayView |
SetSelection(const COleDateTime &dtBegin, const COleDateTime &dtEnd, BOOL bAllDayEvent=FALSE, int nGroupIndex=0) | CXTPCalendarView |
SetTimer(UINT uTimeOut_ms) | CXTPCalendarView | protectedvirtual
ShowAdditionalScale(BOOL bShow=TRUE) | CXTPCalendarDayView |
ShowDay(const COleDateTime &date, BOOL bSelect=TRUE) | CXTPCalendarDayView | virtual
ShowDays(const COleDateTime &dtBegin, const COleDateTime &dtEnd) | CXTPCalendarDayView | virtual
ShowToolTip(BOOL bShow=TRUE) | CXTPCalendarView | virtual
ShowWorkingDays(const COleDateTime &dtDay) | CXTPCalendarDayView | virtual
StartEditNewEventInplace(LPCTSTR pcszInitialSubject) | CXTPCalendarView | virtual
StartEditSubject(CXTPCalendarViewEvent *pViewEvent) | CXTPCalendarView | virtual
StopHorzEventScroll() | CXTPCalendarDayView | protectedvirtual
StopVertEventScroll() | CXTPCalendarDayView | protectedvirtual
TBase typedef | CXTPCalendarDayView |
Undo() | CXTPCalendarView | virtual
UnselectAllEvents() | CXTPCalendarView | virtual
UpdateNextTimeEditByTAB(COleDateTime dtNext, BOOL bReverse, BOOL bReset=FALSE) | CXTPCalendarDayView | protectedvirtual
VertEventScroll(BOOL bUp) | CXTPCalendarDayView | protectedvirtual
~CXTPCalendarDayView() | CXTPCalendarDayView | virtual
~CXTPCalendarView() | CXTPCalendarView | virtual
~CXTPCalendarViewT() | CXTPCalendarViewT< CXTPCalendarDayViewDay > | inlinevirtual


Toolkit Pro: Member List

CXTPChartRadarPointSeriesPointView Member List

This is the complete list of members for CXTPChartRadarPointSeriesPointView, including all inherited members.

AddChildView(CXTPChartElementView *pChildView) | CXTPChartElementView |
CreateDeviceCommand(CXTPChartDeviceContext *pDC) | CXTPChartRadarPointSeriesPointView | virtual
CreateLegendDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcBounds) | CXTPChartRadarPointSeriesPointView | virtual
CXTPChartElementView(CXTPChartElementView *pParentView) | CXTPChartElementView |
CXTPChartElementView(CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartElementView |
CXTPChartElementView(CXTPChartContainer *pContainer) | CXTPChartElementView |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartRadarPointSeriesPointView(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView) | CXTPChartRadarPointSeriesPointView |
CXTPChartSeriesPointView(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView) | CXTPChartSeriesPointView |
CXTPChartSeriesPointView(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartSeriesPointView |
GetAt(int nIndex) const | CXTPChartElementView |
GetBounds() const | CXTPChartElementView |
GetBounds(BOOL bIncludingChildren) const | CXTPChartElementView |
GetChildren() | CXTPChartElementView |
GetColor() const | CXTPChartSeriesPointView |
GetColor2() const | CXTPChartSeriesPointView |
GetCount() const | CXTPChartElementView |
GetInternalValue() const | CXTPChartSeriesPointView |
GetLegendName() const | CXTPChartSeriesPointView | virtual
GetParentView() const | CXTPChartElementView |
GetPoint() const | CXTPChartSeriesPointView |
GetScreenPoint() const | CXTPChartRadarPointSeriesPointView |
GetSeriesView() const | CXTPChartSeriesPointView |
Is3D() const | CXTPChartObject |
m_arrChildren | CXTPChartElementView | protected
m_dInternalValue | CXTPChartSeriesPointView |
m_pContainer | CXTPChartElementView | protected
m_pParentView | CXTPChartElementView | protected
m_pPoint | CXTPChartSeriesPointView | protected
m_rcBounds | CXTPChartElementView | protected
UpdateMinMaxRange(double &nMinValue, double &nMaxValue) const | CXTPChartSeriesPointView | virtual
~CXTPChartElementView() | CXTPChartElementView | protectedvirtual
~CXTPChartLegendItemView() | CXTPChartLegendItemView | inlinevirtual


Toolkit Pro: Member List

CXTPTabCtrlButtons Member List

This is the complete list of members for CXTPTabCtrlButtons, including all inherited members.


Toolkit Pro: Member List

XTP_TAGCLOUDTAG Member List

This is the complete list of members for XTP_TAGCLOUDTAG, including all inherited members.

nScore | XTP_TAGCLOUDTAG |
rcItem | XTP_TAGCLOUDTAG |
strItem | XTP_TAGCLOUDTAG |
XTP_TAGCLOUDTAG(LPCTSTR lpszItem, int nScore) | XTP_TAGCLOUDTAG | inline


Toolkit Pro: Member List

CXTPCalendarMonthViewGroup Member List

This is the complete list of members for CXTPCalendarMonthViewGroup, including all inherited members.

AddResource(CXTPCalendarResource *pResource, BOOL bWithAddRef) | CXTPCalendarViewGroup | virtual
AdjustLayout(CDC *pDC, const CRect &rcGroup) | CXTPCalendarViewGroup | virtual
AdjustLayout2(CDC *pDC, const CRect &rcGroup) | CXTPCalendarViewGroup | virtual
CXTPCalendarMonthViewGroup(CXTPCalendarMonthViewDay *pViewDay) | CXTPCalendarMonthViewGroup |
CXTPCalendarViewGroup(CXTPCalendarViewDay *pViewDay) | CXTPCalendarViewGroup |
CXTPCalendarViewGroupT(CXTPCalendarMonthViewDay *pViewDay) | CXTPCalendarViewGroupT< CXTPCalendarMonthViewDay, CXTPCalendarMonthViewEvent, CXTPCalendarMonthViewGroup > | inline
CXTPCalendarWMHandler() | CXTPCalendarWMHandler |
CXTPCmdTarget() | CXTPCmdTarget |
Draw(CDC *pDC) | CXTPCalendarViewGroup | virtual
ExchangeEventPlace(CXTPCalendarViewEvent *pViewEvent, int nNewPlace) | CXTPCalendarViewGroup | virtual
FillHitTestEx(XTP_CALENDAR_HITTESTINFO *pHitTest) const | CXTPCalendarMonthViewGroup | protectedvirtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCalendarControl() const | CXTPCalendarViewGroup | virtual
GetCaption() const | CXTPCalendarViewGroup | virtual
GetChildHandlerAt(int nIndex) const | CXTPCalendarViewGroup | virtual
GetChildHandlersCount() const | CXTPCalendarViewGroup | virtual
GetDataProvider() const | CXTPCalendarViewGroup | virtual
GetGroupIndex() const | CXTPCalendarViewGroup | virtual
GetHeaderRect() const | CXTPCalendarViewGroup | inlinevirtual
GetPThis() | CXTPCalendarMonthViewGroup | protectedvirtual
GetRect() const | CXTPCalendarViewGroup | inlinevirtual
GetResources() const | CXTPCalendarViewGroup | virtual
GetScheduleID() const | CXTPCalendarViewGroup | virtual
GetTooltipRect(const CPoint &ptHit, const XTP_CALENDAR_HITTESTINFO &hitInfo) const | CXTPCalendarMonthViewGroup | virtual
GetViewDay() const | CXTPCalendarViewGroupT< CXTPCalendarMonthViewDay, CXTPCalendarMonthViewEvent, CXTPCalendarMonthViewGroup > | inline
GetViewDay_() const | CXTPCalendarViewGroup |
GetViewEvent(int nIndex) const | CXTPCalendarViewGroupT< CXTPCalendarMonthViewDay, CXTPCalendarMonthViewEvent, CXTPCalendarMonthViewGroup > | inlinevirtual
GetViewEvent_(int nIndex) const | CXTPCalendarViewGroup |
GetViewEventByEvent_(CXTPCalendarEvent *pEvent) const | CXTPCalendarViewGroup | virtual
GetViewEventByPlace_(int nEventPlace) const | CXTPCalendarViewGroup | virtual
GetViewEventsCount() const | CXTPCalendarViewGroup |
HitTest(CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const | CXTPCalendarViewGroup | virtual
HitTestEx(CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const | CXTPCalendarViewGroup | virtual
KillTimer(UINT uTimerID) | CXTPCalendarViewGroup | protectedvirtual
m_arEvents | CXTPCalendarViewGroup | protected
m_Layout | CXTPCalendarViewGroup | protected
m_pResources | CXTPCalendarViewGroup | protected
m_pViewDay | CXTPCalendarViewGroup | protected
OnBeforeDestroy() | CXTPCalendarWMHandler | virtual
OnChar(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnKeyUp(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnLButtonDblClk(UINT nFlags, CPoint point) | CXTPCalendarWMHandler | virtual
OnLButtonDown(UINT nFlags, CPoint point) | CXTPCalendarWMHandler | virtual
OnLButtonUp(UINT nFlags, CPoint point) | CXTPCalendarWMHandler | virtual
OnMouseMove(UINT nFlags, CPoint point) | CXTPCalendarWMHandler | virtual
OnPostAdjustLayout() | CXTPCalendarWMHandler | virtual
OnPrePopulate(CXTPCalendarEvents *pEvents) | CXTPCalendarViewGroup | protectedvirtual
OnSysKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnTimer(UINT_PTR uTimerID) | CXTPCalendarWMHandler | virtual
OnWndMsg(UINT message, WPARAM wParam, LPARAM lParam, LRESULT *pResult) | CXTPCalendarWMHandler | virtual
Populate(COleDateTime dtDayDate) | CXTPCalendarViewGroup | virtual
SetResources(CXTPCalendarResources *pResources) | CXTPCalendarViewGroup | virtual
SetTimer(UINT uTimeOut_ms) | CXTPCalendarViewGroup | protectedvirtual
TBase typedef | CXTPCalendarMonthViewGroup |
TViewDay typedef | CXTPCalendarViewGroupT< CXTPCalendarMonthViewDay, CXTPCalendarMonthViewEvent, CXTPCalendarMonthViewGroup > |
~CXTPCalendarMonthViewGroup() | CXTPCalendarMonthViewGroup | virtual
~CXTPCalendarViewGroup() | CXTPCalendarViewGroup | virtual
~CXTPCalendarViewGroupT() | CXTPCalendarViewGroupT< CXTPCalendarMonthViewDay, CXTPCalendarMonthViewEvent, CXTPCalendarMonthViewGroup > | inlinevirtual


Toolkit Pro: Member List

CXTPGridRecord Member List

This is the complete list of members for CXTPGridRecord, including all inherited members.

AddItem(CXTPGridRecordItem *pItem) | CXTPGridRecord |
CXTPCmdTarget() | CXTPCmdTarget |
CXTPGridRecord() | CXTPGridRecord |
Delete() | CXTPGridRecord |
DoPropExchange(CXTPPropExchange *pPX) | CXTPGridRecord | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetBookmark() const | CXTPGridRecord |
GetChilds() | CXTPGridRecord |
GetFreeHeight() | CXTPGridRecord |
GetIndex() const | CXTPGridRecord |
GetItem(int nIndex) const | CXTPGridRecord |
GetItem(CXTPGridColumn *pColumn) const | CXTPGridRecord |
GetItemCount() const | CXTPGridRecord |
GetItemMetrics(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pItemMetrics) | CXTPGridRecord | virtual
GetItemPreview() const | CXTPGridRecord |
GetMarkupContext() const | CXTPGridRecord |
GetParentRecord() const | CXTPGridRecord |
GetRecords() const | CXTPGridRecord |
HasChildren() const | CXTPGridRecord |
IndexOf(const CXTPGridRecordItem *pItem) const | CXTPGridRecord |
IsEditable() const | CXTPGridRecord |
IsExpanded() const | CXTPGridRecord |
IsFiltered() const | CXTPGridRecord | virtual
IsLocked() const | CXTPGridRecord |
IsVisible() const | CXTPGridRecord |
m_arrItems | CXTPGridRecord | protected
m_bEditable | CXTPGridRecord | protected
m_bExpanded | CXTPGridRecord | protected
m_bLocked | CXTPGridRecord | protected
m_bSelected | CXTPGridRecord | protected
m_bVisible | CXTPGridRecord | protected
m_nFreeHeight | CXTPGridRecord | protected
m_nIndex | CXTPGridRecord | protected
m_pChildren | CXTPGridRecord | protected
m_pControl | CXTPGridRecord | protected
m_pPreviewItem | CXTPGridRecord | protected
m_pRecords | CXTPGridRecord | protected
m_vtBookmark | CXTPGridRecord | protected
operator delete(void *p) | CXTPHeapObjectT< CXTPCmdTarget, CXTPGridDataAllocator > | inline
operator new(size_t nSize) | CXTPHeapObjectT< CXTPCmdTarget, CXTPGridDataAllocator > | inline
RemoveAll() | CXTPGridRecord |
SetBookmark(VARIANT vtBookmark) | CXTPGridRecord |
SetEditable(BOOL bEditable=TRUE) | CXTPGridRecord |
SetExpanded(BOOL bExpanded) | CXTPGridRecord | virtual
SetFreeHeight(int nFreeHeight) | CXTPGridRecord |
SetLocked(BOOL bLocked) | CXTPGridRecord |
SetPreviewItem(CXTPGridRecordItemPreview *pItemPreview) | CXTPGridRecord |
SetVisible(BOOL bVisible) | CXTPGridRecord |
TreeAddRef() | CXTPGridRecord |
TreeRelease() | CXTPGridRecord |
UpdateRecordField(int row, int index, CString sText) | CXTPGridRecord | virtual
~CXTPGridRecord() | CXTPGridRecord | virtual


Toolkit Pro: Member List

CXTPDockingPaneContextStickerWnd Member List

This is the complete list of members for CXTPDockingPaneContextStickerWnd, including all inherited members.

CXTPDockingPaneContextStickerWnd(CXTPDockingPaneContext *pContext) | CXTPDockingPaneContextStickerWnd |
m_pContext | CXTPDockingPaneContextStickerWnd |
m_selectedSticker | CXTPDockingPaneContextStickerWnd |
m_typeSticker | CXTPDockingPaneContextStickerWnd |
OnDraw(CDC *pDC) | CXTPDockingPaneContextStickerWnd |
~CXTPDockingPaneContextStickerWnd() | CXTPDockingPaneContextStickerWnd | virtual


Toolkit Pro: XTPMarkupTriggerCollection.h Source File

  • Source
  • Markup
XTPMarkupTriggerCollection.h
Go to the documentation of this file.
1
23#if !defined(__XTPMARKUPTRIGGERCOLLECTION_H__)
24# define __XTPMARKUPTRIGGERCOLLECTION_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPMarkupTrigger;
34
35class _XTP_EXT_CLASS CXTPMarkupTriggerCollection : public CXTPMarkupCollection
36{
38 DECLARE_MARKUPCLASS(CXTPMarkupTriggerCollection);
40public:
41 CXTPMarkupTriggerCollection();
42
43public:
44 CXTPMarkupTrigger* GetItem(int nIndex) const;
45
46public:
47};
48
49# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
51#endif // !defined(__XTPMARKUPTRIGGERCOLLECTION_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h


Toolkit Pro: Member List

CXTPControlGalleryVisualStudio2017Theme Member List

This is the complete list of members for CXTPControlGalleryVisualStudio2017Theme, including all inherited members.

CXTPControlGalleryOffice2013Theme(CXTPPaintManager *pPaintManager) | CXTPControlGalleryOffice2013Theme |
CXTPControlGalleryPaintManager(CXTPPaintManager *pPaintManager) | CXTPControlGalleryPaintManager |
CXTPControlGalleryVisualStudio2017Theme(CXTPPaintManager *pPaintManager) | CXTPControlGalleryVisualStudio2017Theme |
DrawLabel(CDC *pDC, CXTPControlGalleryItem *pLabel, CRect rc) | CXTPControlGalleryPaintManager | virtual
DrawPopupScrollBar(CDC *pDC, CXTPControlGallery *pGallery) | CXTPControlGalleryOffice2013Theme | virtual
FillControl(CDC *pDC, CXTPControlGallery *pGallery, CRect rc) | CXTPControlGalleryOffice2013Theme | protectedvirtual
m_cxPopup | CXTPControlGalleryPaintManager |
m_cyPopupDown | CXTPControlGalleryPaintManager |
m_cyPopupUp | CXTPControlGalleryPaintManager |
RefreshMetrics() | CXTPControlGalleryOffice2013Theme | virtual


Toolkit Pro: Member List

CXTPDockingPanePanelTheme2019 Member List

This is the complete list of members for CXTPDockingPanePanelTheme2019, including all inherited members.

AdjustClientRect(CXTPTabManager *pTabManager, CRect &rcClient) | CXTPTabPaintManagerTheme | virtual
CXTPDockingPanePanelTheme2012() | CXTPDockingPanePanelTheme2012 |
CXTPDockingPanePanelTheme2019() | CXTPDockingPanePanelTheme2019 |
CXTPTabPaintManagerTheme() | CXTPTabPaintManagerTheme |
CXTPTabThemeFlat() | CXTPTabThemeFlat | inline
DrawSingleButton(CDC *pDC, CXTPTabManagerItem *pItem) | CXTPDockingPanePanelTheme2012 | virtual
DrawTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl) | CXTPTabPaintManagerTheme | virtual
DrawText(CDC *pDC, CXTPTabManager *pManager, const CString &str, LPRECT lpRect, UINT nFormat) | CXTPTabPaintManagerTheme | virtual
DrawWorkspacePart(CDC *pDC, LPRECT lpRect, XTPTabWorkspacePart workspacePart) | CXTPTabPaintManagerTheme | virtual
FillButton(CDC *pDC, CXTPTabManagerItem *pItem, LPPOINT pts, int nCount, XTPTabPosition tabPosition, BOOL bAbsolute=FALSE) | CXTPTabPaintManagerTheme |
FillTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl) | CXTPTabThemeFlat | virtual
GetButtonDrawRect(const CXTPTabManagerItem *pItem) | CXTPTabPaintManagerTheme | virtual
GetButtonHeight(const CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetButtonLength(CDC *pDC, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerTheme | virtual
GetClientMargin() | CXTPTabPaintManagerTheme | virtual
GetClientRect(CRect rcControl, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetColorSet() const | CXTPTabPaintManagerTheme |
GetDefaultColorSet() | CXTPTabThemeFlat | inlinevirtual
GetHeaderClipBox(CDC *pDC, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetHeaderHeight(CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme |
GetHeaderMargin() | CXTPTabPaintManagerTheme | virtual
GetHeaderRect(CRect rcControl, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetSupportedColorSets() | CXTPTabPaintManagerTheme | inlinevirtual
m_bButtonsReverseZOrder | CXTPTabPaintManagerTheme | protected
m_nButtonHeight | CXTPTabPaintManagerTheme | protected
m_nGripperWidth | CXTPDockingPanePanelTheme2012 | protected
m_nRowMargin | CXTPTabPaintManagerTheme |
m_pPaintManager | CXTPTabPaintManagerTheme | protected
m_rcHeaderMargin | CXTPTabPaintManagerTheme |
RefreshMetrics() | CXTPDockingPanePanelTheme2012 | virtual
RepositionTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcClient) | CXTPTabPaintManagerTheme | virtual
~CXTPTabPaintManagerTheme() | CXTPTabPaintManagerTheme | virtual


Toolkit Pro: XTPMarkupLineBreak.h Source File

  • Source
  • Markup
  • Text
XTPMarkupLineBreak.h
Go to the documentation of this file.
1
23#if !defined(__XTPMARKUPLINEBREAK_H__)
24# define __XTPMARKUPLINEBREAK_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class _XTP_EXT_CLASS CXTPMarkupLineBreak : public CXTPMarkupRun
34{
36 DECLARE_MARKUPCLASS(CXTPMarkupLineBreak);
38protected:
39 CXTPMarkupLineBreak();
40};
41
42# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
44#endif // !defined(__XTPMARKUPLINEBREAK_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h


Toolkit Pro: Member List

CXTPGridRecordItemText Member List

This is the complete list of members for CXTPGridRecordItemText, including all inherited members.

AddHyperlink(CXTPGridHyperlink *pHyperlink) | CXTPGridRecordItem | virtual
Compare(CXTPGridColumn *pColumn, CXTPGridRecordItem *pItem) | CXTPGridRecordItem | virtual
CompareGroupCaption(CXTPGridColumn *pColumn, CXTPGridRecordItem *pItem) | CXTPGridRecordItem | virtual
CompareGroupCaption(CXTPGridColumn *pColumn, CXTPGridGroupRow *pGroupRow) | CXTPGridRecordItem | virtual
CreateBorder() | CXTPGridRecordItem |
CXTPCmdTarget() | CXTPCmdTarget |
CXTPGridRecordItem() | CXTPGridRecordItem |
CXTPGridRecordItemText(LPCTSTR szText=_T("")) | CXTPGridRecordItemText |
DestroyBorder() | CXTPGridRecordItem |
DoPropExchange(CXTPPropExchange *pPX) | CXTPGridRecordItemText | virtual
Draw(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs) | CXTPGridRecordItem | virtual
DrawCheckBox(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CRect &rcItem) | CXTPGridRecordItem | protectedvirtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAlignment() const | CXTPGridRecordItem |
GetBackgroundColor() | CXTPGridRecordItem | virtual
GetBorder() const | CXTPGridRecordItem |
GetCanEditCheckboxItem() const | CXTPGridRecordItem |
GetCaption(CXTPGridColumn *pColumn) | CXTPGridRecordItemText | virtual
GetCaption() | CXTPGridRecordItemText | virtual
GetCaptionRect(XTP_GRIDRECORDITEM_ARGS *pDrawArgs, CRect &rcItem) | CXTPGridRecordItem | virtual
GetCheckedState() const | CXTPGridRecordItem |
GetColumnCaptionPrefix(CXTPGridColumn *pColumn) const | CXTPGridRecordItem |
GetEditOptions(CXTPGridColumn *pColumn) | CXTPGridRecordItem |
GetFont() | CXTPGridRecordItem | virtual
GetFormatString() const | CXTPGridRecordItem | virtual
GetFormula() const | CXTPGridRecordItem | virtual
GetGroupCaption(CXTPGridColumn *pColumn) | CXTPGridRecordItem | virtual
GetGroupCaptionID(CXTPGridColumn *pColumn) | CXTPGridRecordItem | virtual
GetGroupCaptionValue(CXTPGridColumn *pColumn) | CXTPGridRecordItem | virtual
GetGroupPriority() const | CXTPGridRecordItem | virtual
GetHasCheckbox() const | CXTPGridRecordItem | virtual
GetHyperlinkAt(int nHyperlink) const | CXTPGridRecordItem | virtual
GetHyperlinks() | CXTPGridRecordItem | protected
GetHyperlinksCount() const | CXTPGridRecordItem | virtual
GetIconIndex() const | CXTPGridRecordItem | virtual
GetIndex() const | CXTPGridRecordItem |
GetItemControls() | CXTPGridRecordItem |
GetItemData() const | CXTPGridRecordItem | virtual
GetItemMetrics(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pItemMetrics) | CXTPGridRecordItem | virtual
GetMarkupUIElement() const | CXTPGridRecordItem |
GetRecord() const | CXTPGridRecordItem |
GetSelectedConstraintData(XTP_GRIDRECORDITEM_ARGS *pItemArgs) | CXTPGridRecordItem | virtual
GetSortPriority() const | CXTPGridRecordItem | virtual
GetTextColor() | CXTPGridRecordItem | virtual
GetTooltip() const | CXTPGridRecordItem | virtual
GetValue() | CXTPGridRecordItemText |
HasCheckbox(BOOL bHasCheckbox, BOOL bTristate=FALSE) | CXTPGridRecordItem | virtual
HitTest(CPoint ptPoint) | CXTPGridRecordItem |
HitTestHyperlink(CPoint ptClick) | CXTPGridRecordItem | virtual
IsBold() const | CXTPGridRecordItem | virtual
IsChecked() const | CXTPGridRecordItem | virtual
IsChildOfMerge() const | CXTPGridRecordItem |
IsEditable() const | CXTPGridRecordItem | virtual
IsFocusable() const | CXTPGridRecordItem | virtual
IsPreviewItem() const | CXTPGridRecordItem | virtual
m_Alignment | CXTPGridRecordItem | protected
m_bBoldText | CXTPGridRecordItem | protected
m_bCanEditCheckboxItem | CXTPGridRecordItem | protected
m_bEditable | CXTPGridRecordItem | protected
m_bFocusable | CXTPGridRecordItem | protected
m_bHasCheckbox | CXTPGridRecordItem | protected
m_bItemControlUnderMouse | CXTPGridRecordItem | protected
m_bTristateCheckbox | CXTPGridRecordItem | protected
m_checkState | CXTPGridRecordItem | protected
m_clrBackground | CXTPGridRecordItem | protected
m_clrText | CXTPGridRecordItem | protected
m_dwData | CXTPGridRecordItem | protected
m_nGroupPriority | CXTPGridRecordItem | protected
m_nIconIndex | CXTPGridRecordItem | protected
m_nSortPriority | CXTPGridRecordItem | protected
m_pBorder | CXTPGridRecordItem | protected
m_pControl | CXTPGridRecordItem | protected
m_pEditOptions | CXTPGridRecordItem | protected
m_pFocusedItemControl | CXTPGridRecordItem | protected
m_pFontCaption | CXTPGridRecordItem | protected
m_pHyperlinks | CXTPGridRecordItem | protected
m_pItemControlHookWnd | CXTPGridRecordItem | protected
m_pItemControls | CXTPGridRecordItem | protected
m_pMarkupUIElement | CXTPGridRecordItem | protected
m_pRecord | CXTPGridRecordItem | protected
m_rcGlyph | CXTPGridRecordItem | protected
m_strCaption | CXTPGridRecordItem | protected
m_strFormatString | CXTPGridRecordItem | protected
m_strFormula | CXTPGridRecordItem | protected
m_strGroupCaption | CXTPGridRecordItem | protected
m_strText | CXTPGridRecordItemText | protected
m_strTooltip | CXTPGridRecordItem | protected
OnBeginEdit(XTP_GRIDRECORDITEM_ARGS *pItemArgs) | CXTPGridRecordItem | protectedvirtual
OnCancelEdit(CXTPGridControl *pControl, BOOL bApply) | CXTPGridRecordItem | virtual
OnChar(XTP_GRIDRECORDITEM_ARGS *pItemArgs, UINT nChar) | CXTPGridRecordItem | protectedvirtual
OnClick(XTP_GRIDRECORDITEM_CLICKARGS *pClickArgs) | CXTPGridRecordItem | virtual
OnConstraintChanged(XTP_GRIDRECORDITEM_ARGS *pItemArgs, CXTPGridRecordItemConstraint *pConstraint) | CXTPGridRecordItem | virtual
OnDblClick(XTP_GRIDRECORDITEM_CLICKARGS *pClickArgs) | CXTPGridRecordItem | virtual
OnDrawCaption(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics) | CXTPGridRecordItem | virtual
OnDrawControls(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CRect &rcItem) | CXTPGridRecordItem | virtual
OnEditCanceled(XTP_GRIDRECORDITEM_ARGS *pItemArgs) | CXTPGridRecordItem | virtual
OnEditChanged(XTP_GRIDRECORDITEM_ARGS *pItemArgs, LPCTSTR szText) | CXTPGridRecordItemText | virtual
OnEditChanging(XTP_GRIDRECORDITEM_ARGS *pItemArgs, CString &rstrNewText) | CXTPGridRecordItem | virtual
OnInplaceButtonDown(CXTPGridInplaceButton *pButton) | CXTPGridRecordItem | virtual
OnLButtonDown(XTP_GRIDRECORDITEM_CLICKARGS *pClickArgs) | CXTPGridRecordItem | virtual
OnLButtonUp(XTP_GRIDRECORDITEM_CLICKARGS *pClickArgs) | CXTPGridRecordItem | virtual
OnMouseMove(UINT nFlags, CPoint point, CXTPGridControl *pControl=NULL) | CXTPGridRecordItem | virtual
OnRequestEdit(XTP_GRIDRECORDITEM_ARGS *pItemArgs) | CXTPGridRecordItem | protectedvirtual
OnToolHitTest(CPoint point, TOOLINFO *pTI) | CXTPGridRecordItem | virtual
OnValidateEdit(XTP_GRIDRECORDITEM_ARGS *pItemArgs) | CXTPGridRecordItem | virtual
operator delete(void *p) | CXTPHeapObjectT< CXTPCmdTarget, CXTPGridDataAllocator > | inline
operator new(size_t nSize) | CXTPHeapObjectT< CXTPCmdTarget, CXTPGridDataAllocator > | inline
RemoveHyperlinkAt(int nHyperlink) | CXTPGridRecordItem | virtual
ResetMarkupUIElement() | CXTPGridRecordItem | virtual
SetAlignment(int nAlignment) | CXTPGridRecordItem |
SetBackgroundColor(COLORREF clrBackground) | CXTPGridRecordItem | virtual
SetBold(BOOL bBold=TRUE) | CXTPGridRecordItem | virtual
SetCanEditCheckboxItem(BOOL bSet) | CXTPGridRecordItem |
SetCaption(LPCTSTR strCaption) | CXTPGridRecordItem | virtual
SetChecked(BOOL bChecked) | CXTPGridRecordItem | virtual
SetCheckedState(int iState) | CXTPGridRecordItem |
SetEditable(BOOL bEditable=TRUE) | CXTPGridRecordItem | virtual
SetFocusable(BOOL bFocusable) | CXTPGridRecordItem | virtual
SetFont(CFont *pFont) | CXTPGridRecordItem | virtual
SetFormatString(LPCTSTR strFormat) | CXTPGridRecordItem | virtual
SetFormula(LPCTSTR sFormula) | CXTPGridRecordItem | virtual
SetGridControl(CXTPGridControl *pControl) | CXTPGridRecordItem |
SetGroupCaption(LPCTSTR strCaption) | CXTPGridRecordItem | virtual
SetGroupPriority(int nGroupPriority) | CXTPGridRecordItem | virtual
SetIconIndex(int nIconIndex) | CXTPGridRecordItem | virtual
SetItemData(DWORD_PTR dwData) | CXTPGridRecordItem | virtual
SetRecord(CXTPGridRecord *pGridRecord) | CXTPGridRecordItem |
SetSortPriority(int nSortPriority) | CXTPGridRecordItem | virtual
SetTextColor(COLORREF clrText) | CXTPGridRecordItem | virtual
SetTooltip(LPCTSTR lpszTooltip) | CXTPGridRecordItem | virtual
SetValue(LPCTSTR szText) | CXTPGridRecordItemText |
UpdateValue() | CXTPGridRecordItem |
~CXTPGridRecordItem() | CXTPGridRecordItem | virtual


Toolkit Pro: Member List

CXTPControlWindowList Member List

This is the complete list of members for CXTPControlWindowList, including all inherited members.

AssignDocTemplate(UINT nIDResource) | CXTPControl |
ClickToolBarButton(CRect rcActiveRect=CRect(0, 0, 0, 0)) | CXTPControl | protected
Compare(CXTPControl *pOther) | CXTPControl | virtual
ConstructCaption(const CString &lpszTitle, int nIndex) | CXTPControlWindowList | static
Copy(CXTPControl *pControl, BOOL bRecursive=FALSE) | CXTPControlButton | protectedvirtual
CustomizeStartDrag(CPoint point) | CXTPControl | protectedvirtual
CustomizeStartResize(CPoint point) | CXTPControl | protectedvirtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPControl() | CXTPControl | protected
CXTPControlButton() | CXTPControlButton |
DelayLayoutParent() | CXTPControl |
DelayRedrawParent() | CXTPControl |
DoCustomDragOver(CXTPCommandBar *pCommandBar, CPoint point, DROPEFFECT &dropEffect) | CXTPControlWindowList | protectedvirtual
DoPropExchange(CXTPPropExchange *pPX) | CXTPControlButton | virtual
Draw(CDC *pDC) | CXTPControl | virtual
ExcludeDocTemplate(UINT nIDResource) | CXTPControl |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
FromUI(CCmdUI *pCmdUI) | CXTPControl | static
GenerateCommandBarList(DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam) | CXTPControl | protectedvirtual
GetAction() const | CXTPControl |
GetBeginGroup() const | CXTPControl |
GetButtonSize() const | CXTPControl | virtual
GetCaption() const | CXTPControl | virtual
GetCategory() const | CXTPControl |
GetChecked() const | CXTPControl |
GetCloseSubMenuOnClick() const | CXTPControl |
GetCommandBar() const | CXTPControl | virtual
GetControls() const | CXTPControl |
GetCustomizeMinHeight() const | CXTPControl | protectedvirtual
GetCustomizeMinWidth() const | CXTPControl | protectedvirtual
GetCustomShortcutText() const | CXTPControl |
GetDescription() const | CXTPControl | virtual
GetEnabled() const | CXTPControl |
GetExecuteOnPressInterval() const | CXTPControl |
GetExpanded() const | CXTPControl |
GetFlags() const | CXTPControl |
GetHeight() const | CXTPControl |
GetHelpId() const | CXTPControl |
GetHideFlags() const | CXTPControl |
GetIconId() const | CXTPControl |
GetIconSize() const | CXTPControl | virtual
GetID() const | CXTPControl |
GetImage(int nWidth=16) const | CXTPControl | virtual
GetImageManager() const | CXTPControl |
GetIndex() const | CXTPControl |
GetKeyboardTip() const | CXTPControl |
GetPaintManager() const | CXTPControl |
GetParameter() const | CXTPControl |
GetParent() const | CXTPControl |
GetPopuped() const | CXTPControl | virtual
GetPressed() const | CXTPControl | virtual
GetRect() const | CXTPControl |
GetRibbonGroup() const | CXTPControl |
GetRowRect() const | CXTPControl |
GetSelected() const | CXTPControl | virtual
GetShortcutText() const | CXTPControl |
GetSize(CDC *pDC) | CXTPControl | virtual
GetStyle() const | CXTPControl |
GetStyleEx() const | CXTPControlButton |
GetTag() const | CXTPControl |
GetTooltip() const | CXTPControl | virtual
GetType() const | CXTPControl |
GetWidth() const | CXTPControl |
GetWrap() const | CXTPControl |
HasDwmCompositedRect() const | CXTPControl |
IsCaptionVisible() const | CXTPControl | virtual
IsCursorOver() const | CXTPControl |
IsCustomizeMode() const | CXTPControl | protected
IsCustomizeMovable() const | CXTPControl | virtual
IsCustomizeResizeAllow() const | CXTPControl | protectedvirtual
IsFocusable() const | CXTPControl | protectedvirtual
IsFocused() const | CXTPControl | virtual
IsItemDefault() const | CXTPControl |
IsLayoutChanged() | CXTPControl | protected
IsLayoutRTL() const | CXTPControl | protected
IsOnQuickAccess() const | CXTPControl |
IsTemporary() const | CXTPControl |
IsTransparent() const | CXTPControl | inlinevirtual
IsVisible(DWORD dwSkipFlags=0) const | CXTPControl | virtual
m_bBeginGroup | CXTPControl | protected
m_bChecked | CXTPControl | protected
m_bCloseSubMenuOnClick | CXTPControl | protected
m_bDefaultItem | CXTPControl | protected
m_bEnabled | CXTPControl | protected
m_bExpanded | CXTPControl | protected
m_bLayoutRTL | CXTPControl | protected
m_bOnQuickAccess | CXTPControl | protected
m_bPressed | CXTPControl | protected
m_bSelected | CXTPControl | protected
m_bShowRadioButtons | CXTPControlWindowList | static
m_bTemporary | CXTPControl | protected
m_buttonCustomStyle | CXTPControl | protected
m_buttonRibbonStyle | CXTPControl | protected
m_buttonStyle | CXTPControl | protected
m_buttonStyleEx | CXTPControlButton | protected
m_bWrap | CXTPControl | protected
m_controlType | CXTPControl | protected
m_dwFlags | CXTPControl | protected
m_dwHideFlags | CXTPControl | protected
m_mapDocTemplatesAssigned | CXTPControl | protected
m_mapDocTemplatesExcluded | CXTPControl | protected
m_nCustomIconId | CXTPControl | protected
m_nExecuteOnPressInterval | CXTPControl | protected
m_nFistMDIChild | CXTPControlWindowList | static
m_nHeight | CXTPControl | protected
m_nHelpId | CXTPControl | protected
m_nIconId | CXTPControl | protected
m_nId | CXTPControl | protected
m_nIndex | CXTPControl | protected
m_nItemCount | CXTPControlWindowList | static
m_nTag | CXTPControl | protected
m_nWidth | CXTPControl | protected
m_pAction | CXTPControl | protected
m_pControls | CXTPControl | protected
m_pParent | CXTPControl | protected
m_pRibbonGroup | CXTPControl | protected
m_rcControl | CXTPControl | protected
m_rcRow | CXTPControl | protected
m_strCaption | CXTPControl | protected
m_strCategory | CXTPControl | protected
m_strCustomCaption | CXTPControl | protected
m_strDescriptionText | CXTPControl | protected
m_strKeyboardTip | CXTPControl | protected
m_strParameter | CXTPControl | protected
m_strShortcutText | CXTPControl | protected
m_strShortcutTextAuto | CXTPControl | protected
m_strTooltipText | CXTPControl | protected
m_szIcon | CXTPControl | protected
NotifySite(UINT code) | CXTPControl |
NotifySite(UINT code, NMXTPCONTROL *pNM) | CXTPControl |
NotifySite(CWnd *pSite, UINT code, NMXTPCONTROL *pNM) | CXTPControl |
OnActionChanged(int nProperty) | CXTPControl | protectedvirtual
OnActionChanging(int nProperty) | CXTPControl | protectedvirtual
OnCalcDynamicSize(DWORD dwMode) | CXTPControlWindowList | protectedvirtual
OnCaptionChanged() | CXTPControl | protectedvirtual
OnClick(BOOL bKeyboard=FALSE, CPoint pt=CPoint(0, 0)) | CXTPControlButton | protectedvirtual
OnCustomizeDragOver(CXTPControl *pDataObject, CPoint point, DROPEFFECT &dropEffect) | CXTPControl | protectedvirtual
OnCustomizeMouseMove(CPoint point) | CXTPControl | protected
OnEnabledChanged() | CXTPControl | virtual
OnExecute() | CXTPControl | virtual
OnHookKeyDown(UINT nChar, LPARAM lParam) | CXTPControl | protectedvirtual
OnHookMouseWheel(UINT nFlags, short zDelta, CPoint point) | CXTPControl | protectedvirtual
OnIdleUpdate() | CXTPControl | protectedvirtual
OnLButtonDblClk(CPoint point) | CXTPControl | protectedvirtual
OnLButtonDown(CPoint point) | CXTPControl | protectedvirtual
OnLButtonUp(CPoint point) | CXTPControlButton | protectedvirtual
OnMouseHover() | CXTPControl | protectedvirtual
OnMouseMove(CPoint point) | CXTPControl | protectedvirtual
OnRButtonDown(CPoint point) | CXTPControl | protectedvirtual
OnRButtonUp(CPoint point) | CXTPControl | protectedvirtual
OnRemoved() | CXTPControl | protectedvirtual
OnSetPopup(BOOL bPopup) | CXTPControl | protectedvirtual
OnSetSelected(int bSelected) | CXTPControl | protectedvirtual
OnThemeChanged() | CXTPControl | virtual
OnToolHitTest(CPoint point, TOOLINFO *pTI) const | CXTPControl | protectedvirtual
OnUnderlineActivate() | CXTPControl | virtual
RedrawParent(BOOL bAnimate=TRUE) | CXTPControl |
Reset() | CXTPControl |
RestoreCommandBarList(CXTPCommandBarList *pCommandBarList) | CXTPControl | protectedvirtual
ScreenToClient(CPoint *point) | CXTPControl | protected
SetAction(CXTPControlAction *pAction) | CXTPControl | virtual
SetBeginGroup(BOOL bBeginGroup) | CXTPControl | virtual
SetCaption(LPCTSTR lpszCaption) | CXTPControl |
SetCaption(UINT nIDCaption) | CXTPControl |
SetCategory(LPCTSTR lpszCategory) | CXTPControl |
SetChecked(BOOL bChecked) | CXTPControl | virtual
SetCloseSubMenuOnClick(BOOL bCloseOnClick) | CXTPControl |
SetCustomIcon(HICON hIcon) | CXTPControl |
SetCustomShortcutText(LPCTSTR lpszCustomShortcutText) | CXTPControl |
SetDescription(LPCTSTR lpszDescription) | CXTPControl |
SetEnabled(BOOL bEnabled) | CXTPControl | virtual
SetExecuteOnPressInterval(int nExecuteOnPressInterval) | CXTPControl |
SetExpanded(BOOL bExpanded) | CXTPControl | protected
SetFlags(DWORD dwFlags) | CXTPControl |
SetFocused(BOOL bFocused) | CXTPControl | virtual
SetHeight(int nHeight) | CXTPControl | virtual
SetHelpId(int nId) | CXTPControl |
SetHideFlag(XTPControlHideFlags dwFlag, BOOL bSet) | CXTPControl |
SetHideFlags(DWORD dwFlags) | CXTPControl | virtual
SetHideWrap(BOOL bHide) | CXTPControl |
SetIconId(int nId) | CXTPControl |
SetIconSize(CSize szIcon) | CXTPControl |
SetID(int nId) | CXTPControl |
SetIndex(int nIndex) | CXTPControl | inlineprotected
SetItemDefault(BOOL bDefault) | CXTPControl |
SetKeyboardTip(LPCTSTR lpszKeyboardTip) | CXTPControl |
SetOnQuickAccess(BOOL bOnQuicAccess=FALSE) | CXTPControl |
SetParameter(LPCTSTR lpszParameter) | CXTPControl |
SetParent(CXTPCommandBar *pParent) | CXTPControl | inlineprotectedvirtual
SetPressed(BOOL bPressed) | CXTPControl |
SetPrompt(LPCTSTR lpszPrompt) | CXTPControl |
SetRect(CRect rcControl) | CXTPControl | virtual
SetRowRect(CRect rcRow) | CXTPControl |
SetShortcutText(LPCTSTR lpszShortcutText) | CXTPControl |
SetStyle(XTPButtonStyle buttonStyle) | CXTPControl |
SetStyleEx(XTPButtonStyle buttonStyle) | CXTPControlButton |
SetTag(DWORD_PTR dwTag) | CXTPControl |
SetTooltip(LPCTSTR lpszTooltip) | CXTPControl |
SetVisible(BOOL bVisible) | CXTPControl |
SetWidth(int nWidth) | CXTPControl | virtual
SetWrap(BOOL bWrap) | CXTPControl |
~CXTPControl() | CXTPControl | protectedvirtual
~CXTPControlButton() | CXTPControlButton | virtual


Toolkit Pro: Member List

CXTPMarqueeCtrlThemeUltraFlat Member List

This is the complete list of members for CXTPMarqueeCtrlThemeUltraFlat, including all inherited members.

CXTPMarqueeCtrlPaintManager() | CXTPMarqueeCtrlPaintManager |
CXTPMarqueeCtrlThemeFlat() | CXTPMarqueeCtrlThemeFlat |
CXTPMarqueeCtrlThemeUltraFlat() | CXTPMarqueeCtrlThemeUltraFlat |
DeflateRect(CDC *pDC, CRect &rcClient) | CXTPMarqueeCtrlThemeFlat | protectedvirtual
DrawBackground(CXTPMarqueeCtrl *pWndCtrl, CDC *pDC, CRect &rcClient) | CXTPMarqueeCtrlPaintManager | virtual
DrawChunk(CXTPMarqueeCtrl *pWndCtrl, CDC *pDC, CXTPCompatibleDC &dcChunk, int i, int &x, int &y, int cx, int cy) | CXTPMarqueeCtrlPaintManager | protectedvirtual
DrawMarquee(CXTPMarqueeCtrl *pWndCtrl, CDC *pDC, CRect &rcClient) | CXTPMarqueeCtrlThemeFlat | protectedvirtual
GetBackColor() | CXTPMarqueeCtrlPaintManager |
GetBarColor() | CXTPMarqueeCtrlPaintManager |
GetBorderColor() | CXTPMarqueeCtrlPaintManager |
m_bUseWinTheme | CXTPMarqueeCtrlPaintManager | protected
m_clr3DHilite | CXTPMarqueeCtrlPaintManager | protected
m_clr3DShadow | CXTPMarqueeCtrlPaintManager | protected
m_clrBack | CXTPMarqueeCtrlPaintManager | protected
m_clrBar | CXTPMarqueeCtrlPaintManager | protected
m_nTheme | CXTPMarqueeCtrlPaintManager | protected
m_winTheme | CXTPMarqueeCtrlPaintManager | protected
RefreshMetrics() | CXTPMarqueeCtrlThemeUltraFlat | virtual
SetBackColor(COLORREF clrNew) | CXTPMarqueeCtrlPaintManager |
SetBarColor(COLORREF clrNew) | CXTPMarqueeCtrlPaintManager |
SetBorderColor(COLORREF clrNew) | CXTPMarqueeCtrlPaintManager |
UseWinThemes(BOOL bUseWinThemes=TRUE) | CXTPMarqueeCtrlPaintManager |
UsingWinThemes(BOOL bCheckReady=FALSE) | CXTPMarqueeCtrlPaintManager |
~CXTPMarqueeCtrlPaintManager() | CXTPMarqueeCtrlPaintManager | virtual


Toolkit Pro: XTPCalendarMonthView.h Source File

  • Source
  • Calendar
XTPCalendarMonthView.h
Go to the documentation of this file.
1
22#if !defined(_XTPCALENDARMONTHVIEW_H__)
23# define _XTPCALENDARMONTHVIEW_H__
24
25# if _MSC_VER > 1000
26# pragma once
27# endif // _MSC_VER > 1000
28
29# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
30
31class CXTPCalendarMonthView;
32
42# define XTP_CALENDAR_MONTHVIEW_SHOW_WEEKS_MIN 1
43
53# define XTP_CALENDAR_MONTHVIEW_SHOW_WEEKS_MAX 64
54
73class _XTP_EXT_CLASS CXTPCalendarMonthView : public CXTPCalendarViewT<CXTPCalendarMonthViewDay>
74{
75 friend class CXTPCalendarMonthViewDay;
76 friend class CXTPCalendarMonthViewEvent;
78 DECLARE_DYNAMIC(CXTPCalendarMonthView)
80public:
85 typedef CXTPCalendarViewT<CXTPCalendarMonthViewDay> TBase;
86
95 CXTPCalendarMonthView(CXTPCalendarControl* pCalendarControl);
96
104 virtual ~CXTPCalendarMonthView();
105
111 virtual void Populate();
112
130 virtual void AdjustLayout(CDC* pDC, const CRect& rcView, BOOL bCallPostAdjustLayout = TRUE);
131
149 virtual void AdjustLayout2(CDC* pDC, const CRect& rcView, BOOL bCallPostAdjustLayout = TRUE);
150
164 virtual void ShowDay(const COleDateTime& date, BOOL bSelect = TRUE);
165
175 virtual BOOL GetScrollBarInfoV(SCROLLINFO* pSI) const;
176
191 virtual void ScrollV(int nPos, int nPos_raw);
192
207 virtual void Draw(CDC* pDC);
208
223 virtual void Draw2(CDC* pDC);
224
236 virtual int GetEventCaptionFormat() const;
237
245 virtual int GetEventTimeWidth() const;
246
261 virtual void OnMouseMove(UINT nFlags, CPoint point);
262
279 virtual BOOL OnLButtonDown(UINT nFlags, CPoint point);
280
295 virtual void OnKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags);
296
311 virtual CXTPCalendarViewDay* GetViewDay_(int nIndex) const;
312
327 virtual COleDateTime GetViewDayDate(int nIndex) const;
328
349 virtual void GetWeekDayTextIfNeed(CString* pstrText, int nWeekDay);
350
367 CString _FormatDayDate(COleDateTime dtDay, BOOL bLong);
368
369protected:
377 void _CalculateDateFormats(CDC* pDC);
378
395 void _ReadDefaultDateFormats();
396
404 void _SplitDateFormat(const CString& strDateFormat, CStringArray& rarTokens);
405
413 void _CalculateEventCaptionFormat(CDC* pDC);
414
415 CString m_strLongDateFormat;
416 CString m_strSmallDateFormat;
417 int m_nEventCaptionFormat;
419 int m_nEventTimeWidth;
421 XTP_CALENDAR_MONTHVIEW_DAYPOS m_DayPOS_LastSelected;
423 COleDateTime m_dtLightColorDateBase;
425public:
426 void SetMDayViewLightColorBaseDate(const COleDateTime& dtBase);
427 const COleDateTime& GetMDayViewLightColorBaseDate() const;
428
435 void SetLongDayHeaderFormat(LPCTSTR pcszCustomFormat);
436
443 void SetSmallDayHeaderFormat(LPCTSTR pcszCustomFormat);
444
445 BOOL m_bDraftMode;
453 class _XTP_EXT_CLASS CMonthViewGrid
454 {
455 public:
462 CMonthViewGrid(CXTPCalendarMonthView* pView);
463
471 virtual ~CMonthViewGrid();
472
484 COleDateTime GetBeginDate() const;
485
499 void SetBeginDate(COleDateTime dtBeginDate);
500
514 COleDateTime ShiftDateToCell_00(COleDateTime dtDate) const;
515
525 int GetWeeksCount() const;
526
541 void SetWeeksCount(int nWeeks);
542
557 COleDateTime GetDayDate(int nWeekIndex, int nWeekDayIndex) const;
558
580 CRect GetDayRect(int nWeekIndex, int nWeekDayIndex, BOOL bIncludeBorders = FALSE) const;
581
609 CRect GetCelRect(int nWeekIndex, int nColIndex, BOOL bIncludeBorders = FALSE) const;
610
628 int GetWeekDayCol(int nWeekDayIndex) const;
629
647 int GetWeekDayForColIndex(int nColIdx) const;
648
663 int GetColsCount() const;
664
672 int GetColHeaderHeight() const;
673
684 void SetColHeaderHeight(int nHeight);
685
703 void ScrollV(int nPos);
704
716 int GetScrollPos() const;
717
728 void AdjustLayout(CDC* pDC);
729
743 void Draw(CDC* pDC);
744
752 void AdjustFirstDayOfWeek();
753
762 void AdjustGrid(const CRect& rcRect);
763
773 void AdjustDays(CDC* pDC);
774
784 void AdjustEvents(CDC* pDC);
785
801 CXTPCalendarMonthViewDay* GetViewDay(int nWeekIndex, int nWeekDayIndex) const;
802
815 XTP_CALENDAR_MONTHVIEW_DAYPOS GetMaxDayPOS() const;
816
825 int GetFirstDayOfWeek() const;
826
827 protected:
828 COleDateTime m_dtBeginDate;
830 int m_nWeeksCount;
831 int m_nColHeaderHeight;
833 CStringArray m_arColHeaderText;
835 CUIntArray m_arColsLeftX;
836 CUIntArray m_arRowsTopY;
838 int m_nFirstDayOfWeekIndex;
849 void AdjustHeader(CDC* pDC);
850
864 COleDateTime GetMiddleScrollBeginDate() const;
865
866 protected:
867 CXTPCalendarMonthView* m_pView;
868 };
869 friend class CMonthViewGrid;
870
881 CMonthViewGrid* GetGrid() const;
882
883protected:
884 CMonthViewGrid* m_pGrid;
886# ifdef _XTP_ACTIVEX
887
888 DECLARE_DISPATCH_MAP()
889 DECLARE_INTERFACE_MAP()
890
891 DECLARE_OLETYPELIB_EX(CXTPCalendarMonthView);
892
893 long OleGetWeeksCount();
894 void OleSetWeeksCount(long);
895
896 BOOL OleGetDraftMode();
897 void OleSetDraftMode(BOOL bSet);
898
899# endif
900};
901
902//===========================================================================
903// XTP_CALENDAR_MONTHVIEW_DAYPOS
904//-----------------------------
905AFX_INLINE int XTP_CALENDAR_MONTHVIEW_DAYPOS::GetPOS() const
906{
907 int nPOS = nWeekIndex * 7 + nWeekDayIndex;
908 return nPOS;
909}
910AFX_INLINE void XTP_CALENDAR_MONTHVIEW_DAYPOS::SetPOS(int nWidx, int nWDidx)
911{
912 nWeekIndex = nWidx;
913 nWeekDayIndex = nWDidx;
914}
915AFX_INLINE void XTP_CALENDAR_MONTHVIEW_DAYPOS::SetPOS(int nPOS)
916{
917 nWeekIndex = nPOS / 7;
918 nWeekDayIndex = nPOS % 7;
919}
920AFX_INLINE BOOL XTP_CALENDAR_MONTHVIEW_DAYPOS::IsValid() const
921{
922 BOOL bValid = (nWeekIndex >= 0 || nWeekDayIndex >= 0);
923 return bValid;
924}
925AFX_INLINE XTP_CALENDAR_MONTHVIEW_DAYPOS::operator int() const
926{
927 _ASSERTE(IsValid());
928 return GetPOS();
929}
930AFX_INLINE const XTP_CALENDAR_MONTHVIEW_DAYPOS& XTP_CALENDAR_MONTHVIEW_DAYPOS::operator=(int nPOS)
931{
932 SetPOS(nPOS);
933 return *this;
934}
935AFX_INLINE XTP_CALENDAR_MONTHVIEW_DAYPOS& XTP_CALENDAR_MONTHVIEW_DAYPOS::operator++()
936{
937 _ASSERTE(IsValid());
938 SetPOS(GetPOS() + 1);
939 return *this;
940}
941AFX_INLINE XTP_CALENDAR_MONTHVIEW_DAYPOS XTP_CALENDAR_MONTHVIEW_DAYPOS::operator++(int)
942{
943 _ASSERTE(IsValid());
944 XTP_CALENDAR_MONTHVIEW_DAYPOS retPOS = *this;
945 SetPOS(GetPOS() + 1);
946 return retPOS;
947}
948
949//===========================================================================
950AFX_INLINE void CXTPCalendarMonthView::SetMDayViewLightColorBaseDate(const COleDateTime& dtBase)
951{
952 m_dtLightColorDateBase = dtBase;
953}
954
955AFX_INLINE const COleDateTime& CXTPCalendarMonthView::GetMDayViewLightColorBaseDate() const
956{
957 return m_dtLightColorDateBase;
958}
959
960//===========================================================================
961AFX_INLINE int CXTPCalendarMonthView::CMonthViewGrid::GetWeeksCount() const
962{
963 return m_nWeeksCount;
964}
965AFX_INLINE COleDateTime CXTPCalendarMonthView::CMonthViewGrid::GetBeginDate() const
966{
967 return m_dtBeginDate;
968}
969AFX_INLINE XTP_CALENDAR_MONTHVIEW_DAYPOS CXTPCalendarMonthView::CMonthViewGrid::GetMaxDayPOS() const
970{
971 XTP_CALENDAR_MONTHVIEW_DAYPOS maxPOS;
972 maxPOS.SetPOS((int)(GetWeeksCount() * 7 - 1));
973 return maxPOS;
974}
975AFX_INLINE CXTPCalendarMonthView::CMonthViewGrid* CXTPCalendarMonthView::GetGrid() const
976{
977 return m_pGrid;
978}
979AFX_INLINE int CXTPCalendarMonthView::CMonthViewGrid::GetFirstDayOfWeek() const
980{
981 return m_nFirstDayOfWeekIndex;
982}
983AFX_INLINE int CXTPCalendarMonthView::GetEventCaptionFormat() const
984{
985 return m_nEventCaptionFormat;
986}
987AFX_INLINE int CXTPCalendarMonthView::GetEventTimeWidth() const
988{
989 return m_nEventTimeWidth;
990}
991AFX_INLINE void CXTPCalendarMonthView::SetLongDayHeaderFormat(LPCTSTR pcszCustomFormat)
992{
993 m_strLongDateFormat = pcszCustomFormat;
994}
995AFX_INLINE void CXTPCalendarMonthView::SetSmallDayHeaderFormat(LPCTSTR pcszCustomFormat)
996{
997 m_strSmallDateFormat = pcszCustomFormat;
998}
999
1000# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
1001#endif // !defined(_XTPCALENDARMONTHVIEW_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCalendarControl
Class CXTPCalendarControl implements the calendar's view interface.
Definition XTPCalendarControl.h:126
CXTPCalendarMonthView::CMonthViewGrid
Definition XTPCalendarMonthView.h:454
CXTPCalendarMonthView::CMonthViewGrid::AdjustGrid
void AdjustGrid(const CRect &rcRect)
This member function is used to adjust the grid's columns and rows.
CXTPCalendarMonthView::CMonthViewGrid::GetBeginDate
COleDateTime GetBeginDate() const
This member function is used to obtain the date of the first cell (cell [0, 0]) in the grid.
Definition XTPCalendarMonthView.h:965
CXTPCalendarMonthView::CMonthViewGrid::GetDayDate
COleDateTime GetDayDate(int nWeekIndex, int nWeekDayIndex) const
This member function is used to retrieve the specified day date.
CXTPCalendarMonthView::CMonthViewGrid::GetViewDay
CXTPCalendarMonthViewDay * GetViewDay(int nWeekIndex, int nWeekDayIndex) const
This function is used to obtain the view day object that is associated with the given indexes.
CXTPCalendarMonthView::CMonthViewGrid::AdjustEvents
void AdjustEvents(CDC *pDC)
This member function is used to adjust the event views layout.
CXTPCalendarMonthView::CMonthViewGrid::m_nWeeksCount
int m_nWeeksCount
The number of weeks that are displayed.
Definition XTPCalendarMonthView.h:830
CXTPCalendarMonthView::CMonthViewGrid::GetFirstDayOfWeek
int GetFirstDayOfWeek() const
This member function is used to obtain the First Day Of Week index.
Definition XTPCalendarMonthView.h:979
CXTPCalendarMonthView::CMonthViewGrid::m_pView
CXTPCalendarMonthView * m_pView
Pointer to the parent view class.
Definition XTPCalendarMonthView.h:867
CXTPCalendarMonthView::CMonthViewGrid::SetBeginDate
void SetBeginDate(COleDateTime dtBeginDate)
This member function is used to set the start view date.
CXTPCalendarMonthView::CMonthViewGrid::SetWeeksCount
void SetWeeksCount(int nWeeks)
This member function is used to set the number of weeks that are shown in the grid (Month View).
CXTPCalendarMonthView::CMonthViewGrid::CMonthViewGrid
CMonthViewGrid(CXTPCalendarMonthView *pView)
Default class constructor.
CXTPCalendarMonthView::CMonthViewGrid::GetDayRect
CRect GetDayRect(int nWeekIndex, int nWeekDayIndex, BOOL bIncludeBorders=FALSE) const
This member function is used to obtain the bounding rectangle of the day cell.
CXTPCalendarMonthView::CMonthViewGrid::GetWeekDayCol
int GetWeekDayCol(int nWeekDayIndex) const
This member function is used to obtain the column for the specified week day.
CXTPCalendarMonthView::CMonthViewGrid::AdjustDays
void AdjustDays(CDC *pDC)
This member function is used to call AdjustLayout for each day in the days collection with correspond...
CXTPCalendarMonthView::CMonthViewGrid::SetColHeaderHeight
void SetColHeaderHeight(int nHeight)
This member function is used to set the height of the Month View week days columns header.
CXTPCalendarMonthView::CMonthViewGrid::GetMaxDayPOS
XTP_CALENDAR_MONTHVIEW_DAYPOS GetMaxDayPOS() const
This member function is used to obtain the maximum number of available day positions.
Definition XTPCalendarMonthView.h:969
CXTPCalendarMonthView::CMonthViewGrid::GetColHeaderHeight
int GetColHeaderHeight() const
This member function is used to obtain the number of pixels in the height of the Month View week days...
CXTPCalendarMonthView::CMonthViewGrid::m_arRowsTopY
CUIntArray m_arRowsTopY
Array of rows top borders positions.
Definition XTPCalendarMonthView.h:836
CXTPCalendarMonthView::CMonthViewGrid::GetWeekDayForColIndex
int GetWeekDayForColIndex(int nColIdx) const
This member function is used to obtain the week day index for the specified column.
CXTPCalendarMonthView::CMonthViewGrid::GetColsCount
int GetColsCount() const
This member function is used to obtain the number of columns that are displayed in the Month View.
CXTPCalendarMonthView::CMonthViewGrid::m_dtBeginDate
COleDateTime m_dtBeginDate
First Cell (cell [0, 0]) date in the grid.
Definition XTPCalendarMonthView.h:828
CXTPCalendarMonthView::CMonthViewGrid::ScrollV
void ScrollV(int nPos)
This member function is used to scroll the contents of a grid.
CXTPCalendarMonthView::CMonthViewGrid::AdjustFirstDayOfWeek
void AdjustFirstDayOfWeek()
This member function is used to adjust the grid's columns depending on the FirstDayOfWeek calendar co...
CXTPCalendarMonthView::CMonthViewGrid::ShiftDateToCell_00
COleDateTime ShiftDateToCell_00(COleDateTime dtDate) const
This member function is used to shift the specified date to the first cell date in the grid.
CXTPCalendarMonthView::CMonthViewGrid::AdjustLayout
void AdjustLayout(CDC *pDC)
This member function is used to adjust the grid's layout depending on the window's client size and th...
CXTPCalendarMonthView::CMonthViewGrid::m_arColHeaderText
CStringArray m_arColHeaderText
Array of columns (week days) headers names.
Definition XTPCalendarMonthView.h:833
CXTPCalendarMonthView::CMonthViewGrid::m_nFirstDayOfWeekIndex
int m_nFirstDayOfWeekIndex
First Day Of Week index: 1-Sunday, 2-Monday ...
Definition XTPCalendarMonthView.h:838
CXTPCalendarMonthView::CMonthViewGrid::Draw
void Draw(CDC *pDC)
This member function is used to draw the grid content using the specified device context.
CXTPCalendarMonthView::CMonthViewGrid::GetWeeksCount
int GetWeeksCount() const
This member function is used to obtain the weeks (rows) count in the grid.
Definition XTPCalendarMonthView.h:961
CXTPCalendarMonthView::CMonthViewGrid::~CMonthViewGrid
virtual ~CMonthViewGrid()
Default class destructor.
CXTPCalendarMonthView::CMonthViewGrid::GetMiddleScrollBeginDate
COleDateTime GetMiddleScrollBeginDate() const
This member function is used to calculate the date for a middle scrollbar position.
CXTPCalendarMonthView::CMonthViewGrid::GetCelRect
CRect GetCelRect(int nWeekIndex, int nColIndex, BOOL bIncludeBorders=FALSE) const
This member function is used to obtain the bounding rectangle of the full grid cell.
CXTPCalendarMonthView::CMonthViewGrid::GetScrollPos
int GetScrollPos() const
This member function is used to obtain the current scrolling position.
CXTPCalendarMonthView::CMonthViewGrid::m_nColHeaderHeight
int m_nColHeaderHeight
Column header height in pixels.
Definition XTPCalendarMonthView.h:831
CXTPCalendarMonthView::CMonthViewGrid::AdjustHeader
void AdjustHeader(CDC *pDC)
This member function is used to adjust the grid's column header layout.
CXTPCalendarMonthView::CMonthViewGrid::m_arColsLeftX
CUIntArray m_arColsLeftX
Array of columns left borders positions.
Definition XTPCalendarMonthView.h:835
CXTPCalendarMonthViewDay
This class represents a day view portion of the CalendarMonthView.
Definition XTPCalendarMonthViewDay.h:151
CXTPCalendarMonthViewEvent
This class represents an event view portion of the CalendarMonthViewDay.
Definition XTPCalendarMonthViewEvent.h:56
CXTPCalendarMonthView
This class implements a specific view portion of the Calendar control - called Month view.
Definition XTPCalendarMonthView.h:74
CXTPCalendarMonthView::OnLButtonDown
virtual BOOL OnLButtonDown(UINT nFlags, CPoint point)
This member function is used to process left mouse button events.
CXTPCalendarMonthView::Draw2
virtual void Draw2(CDC *pDC)
This member function is used to draw the view content using the specified device context.
CXTPCalendarMonthView::AdjustLayout
virtual void AdjustLayout(CDC *pDC, const CRect &rcView, BOOL bCallPostAdjustLayout=TRUE)
This member function is used to adjust the view's layout depending on the window's client size and th...
CXTPCalendarMonthView::AdjustLayout2
virtual void AdjustLayout2(CDC *pDC, const CRect &rcView, BOOL bCallPostAdjustLayout=TRUE)
This member function is used to adjust the view's layout depending on the window's client size and th...
CXTPCalendarMonthView::m_DayPOS_LastSelected
XTP_CALENDAR_MONTHVIEW_DAYPOS m_DayPOS_LastSelected
Last selected day positions.
Definition XTPCalendarMonthView.h:421
CXTPCalendarMonthView::_CalculateEventCaptionFormat
void _CalculateEventCaptionFormat(CDC *pDC)
This member function is used to calculate the event view's date format based on the current locale.
CXTPCalendarMonthView::SetLongDayHeaderFormat
void SetLongDayHeaderFormat(LPCTSTR pcszCustomFormat)
Sets the format for Cell's Day Header in Month View.
Definition XTPCalendarMonthView.h:991
CXTPCalendarMonthView::_FormatDayDate
CString _FormatDayDate(COleDateTime dtDay, BOOL bLong)
This member function is used to obtain the format string of a day date.
CXTPCalendarMonthView::~CXTPCalendarMonthView
virtual ~CXTPCalendarMonthView()
Default class destructor.
CXTPCalendarMonthView::CXTPCalendarMonthView
CXTPCalendarMonthView(CXTPCalendarControl *pCalendarControl)
Default object constructor.
CXTPCalendarMonthView::Populate
virtual void Populate()
This member function is used to populate the view with data for all items contained in the view.
CXTPCalendarMonthView::m_strSmallDateFormat
CString m_strSmallDateFormat
String of the short date format.
Definition XTPCalendarMonthView.h:416
CXTPCalendarMonthView::ShowDay
virtual void ShowDay(const COleDateTime &date, BOOL bSelect=TRUE)
This member function is used to show the specified day in the calendar view.
CXTPCalendarMonthView::OnKeyDown
virtual void OnKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process keyboard events.
CXTPCalendarMonthView::Draw
virtual void Draw(CDC *pDC)
This member function is used to draw the view content using the specified device context.
CXTPCalendarMonthView::GetWeekDayTextIfNeed
virtual void GetWeekDayTextIfNeed(CString *pstrText, int nWeekDay)
This member function is used to obtain week day header text.
CXTPCalendarMonthView::m_pGrid
CMonthViewGrid * m_pGrid
Pointer to the grid object.
Definition XTPCalendarMonthView.h:884
CXTPCalendarMonthView::m_nEventCaptionFormat
int m_nEventCaptionFormat
Event caption format flags are stored in packed form by bitwise operations.
Definition XTPCalendarMonthView.h:417
CXTPCalendarMonthView::GetViewDayDate
virtual COleDateTime GetViewDayDate(int nIndex) const
Call this member function to obtain the date of a day view by the day's index.
CXTPCalendarMonthView::SetSmallDayHeaderFormat
void SetSmallDayHeaderFormat(LPCTSTR pcszCustomFormat)
Sets the format for Cell's Day Header in Month View.
Definition XTPCalendarMonthView.h:995
CXTPCalendarMonthView::m_dtLightColorDateBase
COleDateTime m_dtLightColorDateBase
Month from this date will be painted with light color in month view.
Definition XTPCalendarMonthView.h:423
CXTPCalendarMonthView::OnMouseMove
virtual void OnMouseMove(UINT nFlags, CPoint point)
This member function is used to processes mouse movement events.
CXTPCalendarMonthView::m_nEventTimeWidth
int m_nEventTimeWidth
width of the area to display the event times.
Definition XTPCalendarMonthView.h:419
CXTPCalendarMonthView::m_strLongDateFormat
CString m_strLongDateFormat
String of the long date format.
Definition XTPCalendarMonthView.h:415
CXTPCalendarMonthView::_ReadDefaultDateFormats
void _ReadDefaultDateFormats()
This member function is used to build day header date format default strings.
CXTPCalendarMonthView::m_bDraftMode
BOOL m_bDraftMode
print mode flag for B/W prinitng without Headers and Footers
Definition XTPCalendarMonthView.h:445
CXTPCalendarMonthView::GetScrollBarInfoV
virtual BOOL GetScrollBarInfoV(SCROLLINFO *pSI) const
This member function is used to retrieve information about the current scroll bar state.
CXTPCalendarMonthView::GetEventTimeWidth
virtual int GetEventTimeWidth() const
This member function is used to obtain the width necessary to display the event's time.
Definition XTPCalendarMonthView.h:987
CXTPCalendarMonthView::GetGrid
CMonthViewGrid * GetGrid() const
This member function is used to obtain the Month View days grid object.
Definition XTPCalendarMonthView.h:975
CXTPCalendarMonthView::GetEventCaptionFormat
virtual int GetEventCaptionFormat() const
This member function is used to obtain the event caption format flags.
Definition XTPCalendarMonthView.h:983
CXTPCalendarMonthView::_CalculateDateFormats
void _CalculateDateFormats(CDC *pDC)
This member function is used to calculate the view's date format based on the current locale.
CXTPCalendarMonthView::ScrollV
virtual void ScrollV(int nPos, int nPos_raw)
This member function is used to scroll the contents of a view.
CXTPCalendarMonthView::TBase
CXTPCalendarViewT< CXTPCalendarMonthViewDay > TBase
Definition XTPCalendarMonthView.h:85
CXTPCalendarMonthView::_SplitDateFormat
void _SplitDateFormat(const CString &strDateFormat, CStringArray &rarTokens)
This member function is used to parse the format string into tokens.
CXTPCalendarMonthView::GetViewDay_
virtual CXTPCalendarViewDay * GetViewDay_(int nIndex) const
This member function is used to obtain the view's day object by the given index.
CXTPCalendarViewDay
This class represents the day view portion of the CalendarView.
Definition XTPCalendarViewDay.h:555
CXTPCalendarViewT
This template class represents a view portion of the Calendar control.
Definition XTPCalendarView.h:2571
XTP_CALENDAR_MONTHVIEW_DAYPOS
Defines a set of data and methods to easily manipulate with day positions in month view.
Definition XTPCalendarDefines.h:714
XTP_CALENDAR_MONTHVIEW_DAYPOS::GetPOS
int GetPOS() const
This member function is used to obtain a sequential integer value.
Definition XTPCalendarMonthView.h:905
XTP_CALENDAR_MONTHVIEW_DAYPOS::nWeekIndex
int nWeekIndex
Week index.
Definition XTPCalendarDefines.h:715
XTP_CALENDAR_MONTHVIEW_DAYPOS::nWeekDayIndex
int nWeekDayIndex
Week day cell index.
Definition XTPCalendarDefines.h:716
XTP_CALENDAR_MONTHVIEW_DAYPOS::operator++
XTP_CALENDAR_MONTHVIEW_DAYPOS & operator++()
This member function is used to pre-increment a sequential position by 1.
Definition XTPCalendarMonthView.h:935
XTP_CALENDAR_MONTHVIEW_DAYPOS::IsValid
BOOL IsValid() const
This member function is used to determine if the WeekIndex and WeekDayIndex values are valid.
Definition XTPCalendarMonthView.h:920
XTP_CALENDAR_MONTHVIEW_DAYPOS::operator=
const XTP_CALENDAR_MONTHVIEW_DAYPOS & operator=(int nPOS)
This member function is used to set a new Sequential integer value.
Definition XTPCalendarMonthView.h:930
XTP_CALENDAR_MONTHVIEW_DAYPOS::SetPOS
void SetPOS(int nWidx, int nWDidx)
This member function is used to set a new week/day index value.
Definition XTPCalendarMonthView.h:910


Toolkit Pro: Member List

CXTPGdiObject Member List

This is the complete list of members for CXTPGdiObject, including all inherited members.

__declspec(property(get=GetSafeHandle)) HGDIOBJ m_hObject | CXTPGdiObject |
CreateStockObject(int nIndex) | CXTPGdiObject |
CXTPGdiObject() | CXTPGdiObject | protected
DeleteObject() | CXTPGdiObject |
GetObject(int nCount, LPVOID lpObject) const | CXTPGdiObject |
GetObjectType() const | CXTPGdiObject |
GetSafeHandle() const | CXTPGdiObject |
IsHandleOwnershipGuaranteed() const | CXTPGdiObject |
operator CGdiObject &() | CXTPGdiObject |
operator const CGdiObject &() const | CXTPGdiObject |
operator HGDIOBJ() const | CXTPGdiObject |
operator!=(const CXTPGdiObject &obj) const | CXTPGdiObject |
operator==(const CXTPGdiObject &obj) const | CXTPGdiObject |
SetHandleOwnershipNotGuaranteed() | CXTPGdiObject |
~CXTPGdiObject()=0 | CXTPGdiObject | pure virtual


Toolkit Pro: XTPChartPieSeriesPointViewBase.h Source File

  • Source
  • Chart
  • Styles
  • Pie
  • Base
XTPChartPieSeriesPointViewBase.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTPIESERIESPOINTVIEWBASE_H__)
24# define __XTPCHARTPIESERIESPOINTVIEWBASE_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartPieBase;
34class CXTPChartSeriesPoint;
35class CXTPChartElementView;
36class CXTPChartDeviceCommand;
37
49class _XTP_EXT_CLASS CXTPChartPieSeriesPointViewBase : public CXTPChartSeriesPointView
50{
51 DECLARE_DYNAMIC(CXTPChartPieSeriesPointViewBase);
52
53protected:
61 CXTPChartPieSeriesPointViewBase(CXTPChartSeriesPoint* pPoint,
62 CXTPChartElementView* pParentView);
71 CXTPChartPieSeriesPointViewBase(CXTPChartSeriesPoint* pPoint, CXTPChartElementView* pParentView,
72 BOOL bAddToParent);
73
74public:
79 virtual ~CXTPChartPieSeriesPointViewBase();
80
81public:
88 virtual void CalculateLayout(double& dAngle) = 0;
89
97 CXTPChartPieBase* GetPie() const;
98
106 CXTPChartPointF GetBasePoint() const;
107
120 virtual CXTPChartDeviceCommand* CreateDeviceCommand(CXTPChartDeviceContext* pDC) = 0;
121
132 virtual CXTPChartDeviceCommand* CreateLegendDeviceCommand(CXTPChartDeviceContext* pDC,
133 CRect rcBounds) = 0;
134
135public:
136 double m_dValue; // The value of the point.
137
138protected:
139 CXTPChartPieBase* m_pPie; // The pie for this point.
140 CXTPChartPointF m_basePoint; // The base point.
141};
142
143AFX_INLINE CXTPChartPieBase* CXTPChartPieSeriesPointViewBase::GetPie() const
144{
145 return m_pPie;
146}
147
148AFX_INLINE CXTPChartPointF CXTPChartPieSeriesPointViewBase::GetBasePoint() const
149{
150 return m_basePoint;
151}
153# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
154#endif //#if !defined(__XTPCHARTPIESERIESPOINTVIEWBASE_H__)
pPoint
const CPoint * pPoint
return 0 or xtpCalendarHitTestDayExpandButton
Definition XTPCalendarThemeOffice2007.h:150
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartElementView
This class represents the view of a chart element.
Definition XTPChartElementView.h:47
CXTPChartPieBase
This class abstracts a pie chart.
Definition XTPChartPie.h:176
CXTPChartPieSeriesPointViewBase
This class abstracts the view of a pie series point.
Definition XTPChartPieSeriesPointViewBase.h:50
CXTPChartPieSeriesPointViewBase::~CXTPChartPieSeriesPointViewBase
virtual ~CXTPChartPieSeriesPointViewBase()
Destroys a CXTPChartPieSeriesPointViewBase object, handle cleanup.
CXTPChartPieSeriesPointViewBase::GetBasePoint
CXTPChartPointF GetBasePoint() const
Use this function to obtain the base point value.
Definition XTPChartPieSeriesPointViewBase.h:148
CXTPChartPieSeriesPointViewBase::CreateDeviceCommand
virtual CXTPChartDeviceCommand * CreateDeviceCommand(CXTPChartDeviceContext *pDC)=0
This function creates a CXTPChartDeviceCommand object.
CXTPChartPieSeriesPointViewBase::CXTPChartPieSeriesPointViewBase
CXTPChartPieSeriesPointViewBase(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Constructs a CXTPChartPieSeriesPointViewBase object.
CXTPChartPieSeriesPointViewBase::CXTPChartPieSeriesPointViewBase
CXTPChartPieSeriesPointViewBase(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView, BOOL bAddToParent)
Constructs a CXTPChartPieSeriesPointViewBase object.
CXTPChartPieSeriesPointViewBase::CreateLegendDeviceCommand
virtual CXTPChartDeviceCommand * CreateLegendDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcBounds)=0
This function creates a label view drawing command object.
CXTPChartPieSeriesPointViewBase::CalculateLayout
virtual void CalculateLayout(double &dAngle)=0
Use this function to calculate the layout of the pie series point.
CXTPChartPieSeriesPointViewBase::GetPie
CXTPChartPieBase * GetPie() const
Use this function to get the pie for the point.
Definition XTPChartPieSeriesPointViewBase.h:143
CXTPChartSeriesPoint
CXTPChartSeriesPoint is a kind of CXTPChartElement.
Definition XTPChartSeriesPoint.h:43
CXTPChartSeriesPointView
Represents chart series point view.
Definition XTPChartSeriesPointView.h:48
CXTPPoint2T< float >


Toolkit Pro: Member List

CXTPFlowGraphConnection Member List

This is the complete list of members for CXTPFlowGraphConnection, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPFlowGraphConnection() | CXTPFlowGraphConnection |
CXTPFlowGraphElement() | CXTPFlowGraphElement |
DoPropExchange(CXTPPropExchange *pPX) | CXTPFlowGraphConnection | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetBoundingRect() | CXTPFlowGraphConnection |
GetCaption() const | CXTPFlowGraphConnection | virtual
GetColor() const | CXTPFlowGraphConnection |
GetControl() const | CXTPFlowGraphConnection | virtual
GetControlPoint() const | CXTPFlowGraphConnection |
GetDashed() const | CXTPFlowGraphConnection |
GetInputNode() const | CXTPFlowGraphConnection |
GetInputPoint() const | CXTPFlowGraphConnection |
GetOutputNode() const | CXTPFlowGraphConnection |
GetOutputPoint() const | CXTPFlowGraphConnection |
GetPage() const | CXTPFlowGraphConnection | virtual
GetStyle() const | CXTPFlowGraphConnection |
GetTooltip() const | CXTPFlowGraphConnection |
GetWidth() const | CXTPFlowGraphConnection |
IsSelected() const | CXTPFlowGraphElement |
m_bDirty | CXTPFlowGraphElement |
m_bSelected | CXTPFlowGraphElement | protected
m_clrConnection | CXTPFlowGraphConnection | protected
m_nInputId | CXTPFlowGraphConnection | protected
m_nOutputId | CXTPFlowGraphConnection | protected
m_nStyle | CXTPFlowGraphConnection | protected
m_pInputPoint | CXTPFlowGraphConnection | protected
m_pNextVisibleConnection | CXTPFlowGraphConnection | protected
m_pOutputPoint | CXTPFlowGraphConnection | protected
m_pPage | CXTPFlowGraphConnection | protected
m_pPath | CXTPFlowGraphConnection | protected
m_ptControlPoint | CXTPFlowGraphConnection | protected
m_ptInputPoint | CXTPFlowGraphConnection | protected
m_ptOutputPoint | CXTPFlowGraphConnection | protected
m_rcBoundingRect | CXTPFlowGraphConnection | protected
m_strCaption | CXTPFlowGraphConnection | protected
m_strTag | CXTPFlowGraphConnection | protected
m_strTooltip | CXTPFlowGraphConnection | protected
OnGraphChanged() | CXTPFlowGraphElement |
OnRemoved() | CXTPFlowGraphConnection | virtual
PtInRect(POINT pt) | CXTPFlowGraphConnection | virtual
RecalcLayout(CXTPFlowGraphDrawContext *pDC) | CXTPFlowGraphConnection | virtual
Remove() | CXTPFlowGraphConnection |
RestoreConnection() | CXTPFlowGraphConnection | protectedvirtual
SetCaption(LPCTSTR lpszCaption) | CXTPFlowGraphConnection | virtual
SetColor(COLORREF clr) | CXTPFlowGraphConnection |
SetControlPoint(CPoint pt) | CXTPFlowGraphConnection |
SetDashed(BOOL bDashed) | CXTPFlowGraphConnection |
SetInputPoint(CXTPFlowGraphConnectionPoint *pPoint) | CXTPFlowGraphConnection | virtual
SetOutputPoint(CXTPFlowGraphConnectionPoint *pPoint) | CXTPFlowGraphConnection | virtual
SetStyle(int nStyle) | CXTPFlowGraphConnection |
SetTooltip(LPCTSTR lpszTooltip) | CXTPFlowGraphConnection |
SetWidth(int nWidth) | CXTPFlowGraphConnection |
~CXTPFlowGraphConnection() | CXTPFlowGraphConnection | virtual
~CXTPFlowGraphElement() | CXTPFlowGraphElement | virtual


Toolkit Pro: XTPPropertyGridToolBar.h Source File

  • Source
  • PropertyGrid
XTPPropertyGridToolBar.h
Go to the documentation of this file.
1
23#if !defined(__XTPPROPERTYGRIDTOOLBAR_H__)
24# define __XTPPROPERTYGRIDTOOLBAR_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPPropertyGridToolBar : public CToolBar
39{
40public:
45 CXTPPropertyGridToolBar();
46
51 ~CXTPPropertyGridToolBar();
52
53protected:
55 DECLARE_MESSAGE_MAP()
56
57 //{{AFX_VIRTUAL(CXTPPropertyGridToolBar)
58 virtual void OnUpdateCmdUI(CFrameWnd* pTarget, BOOL bDisableIfNoHndler);
59 virtual BOOL OnWndMsg(UINT message, WPARAM wParam, LPARAM lParam, LRESULT* pResult);
60 //}}AFX_VIRTUAL
61
62 //{{AFX_MSG(CXTPPropertyGridToolBar)
63 afx_msg BOOL OnEraseBkgnd(CDC*);
64 afx_msg void OnNcCalcSize(BOOL bCalcValidRects, NCCALCSIZE_PARAMS* lpncsp);
65 afx_msg void OnPaint();
66 afx_msg void OnCustomDraw(NMHDR* pNMHDR, LRESULT* pResult);
67 //}}AFX_MSG
69};
70
71# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
73#endif // __XTPPROPERTYGRIDTOOLBAR_H__
XTPDisableNoisyWarnings.h
CXTPPropertyGridToolBar
CXTPPropertyGridToolBar is a CToolBar derived class.
Definition XTPPropertyGridToolBar.h:39
CXTPPropertyGridToolBar::~CXTPPropertyGridToolBar
~CXTPPropertyGridToolBar()
Destroys a CXTPPropertyGridToolBar object, handles cleanup and deallocation.
CXTPPropertyGridToolBar::CXTPPropertyGridToolBar
CXTPPropertyGridToolBar()
Constructs a CXTPPropertyGridToolBar object.


Toolkit Pro: XTPChartDrawingObjectFactory.h Source File

  • Source
  • Chart
  • Drawing
XTPChartDrawingObjectFactory.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTDRAWINGOBJECTFACTORY_H__)
24# define __XTPCHARTDRAWINGOBJECTFACTORY_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
34// CXTPChartDrawingObjectFactory
35
36template<class T>
37class CXTPMatrix;
38
39class CXTPChartDeviceContext;
40class CXTPMarkupUIElement;
41class CXTPChartContainer;
42class CXTPChartElement;
43class CXTPChartDeviceCommand;
44class CXTPChart3dRotation;
45
54class _XTP_EXT_CLASS CXTPChartDrawingObjectFactory
55{
56protected:
57 CXTPChartDrawingObjectFactory();
58
59public:
60 virtual ~CXTPChartDrawingObjectFactory();
61
62 static CXTPChartDeviceContext* AFX_CDECL Create2dDeviceContext(
63 CXTPChartContainer* pContainer, HDC hDC, CXTPChartDeviceContext* p3dDC = NULL);
64 static CXTPChartDeviceContext* AFX_CDECL Create3dDeviceContext(CXTPChartContainer* pContainer,
65 HDC hDC, const RECT& rcBounds);
66
67 static CXTPChartDeviceCommand* AFX_CDECL
68 Create2dHitTestElementCommand(CXTPChartElement* pElement);
69 static CXTPChartDeviceCommand* AFX_CDECL
70 Create2dHitTestElementCommand(CXTPChartElement* pElement, const CRect& rcBounds);
71 static CXTPChartDeviceCommand* AFX_CDECL
72 Create2dHitTestElementCommand(CXTPChartElement* pElement, const CXTPChartRectF& rcBounds);
73 static CXTPChartDeviceCommand* AFX_CDECL Create2dBoundedCircleDeviceCommand(
74 const CXTPChartPointF& center, double radius, const CXTPChartColor& color, int thickness);
75 static CXTPChartDeviceCommand* AFX_CDECL Create2dSolidCircleDeviceCommand(
76 const CXTPChartPointF& center, double radius, const CXTPChartColor& color);
77 static CXTPChartDeviceCommand* AFX_CDECL Create2dHatchCircleDeviceCommand(
78 const CXTPChartPointF& center, double radius, const CXTPChartColor& color,
79 const CXTPChartColor& color2, XTPChartHatchStyle nStyle);
80 static CXTPChartDeviceCommand* AFX_CDECL Create2dGradientCircleDeviceCommand(
81 const CXTPChartPointF& center, double radius, const CXTPChartColor& color,
82 const CXTPChartColor& color2, XTPChartLinearGradientMode nMode);
83 static CXTPChartDeviceCommand* AFX_CDECL Create2dSolidLineDeviceCommand(
84 const CXTPPoint2f& p1, const CXTPPoint2f& p2, const CXTPChartColor& color, int thickness);
85 static CXTPChartDeviceCommand* AFX_CDECL Create3dSolidLineDeviceCommand(
86 const CXTPPoint3d& p1, const CXTPPoint3d& p2, const CXTPChartColor& color, int thickness);
87 static CXTPChartDeviceCommand* AFX_CDECL Create2dDashedLineDeviceCommand(
88 const CXTPPoint2f& p1, const CXTPPoint2f& p2, const CXTPChartColor& color, int thickness,
89 XTPChartDashStyle nDashStyle, const CXTPChartLineDashArray& dashArray);
90 static CXTPChartDeviceCommand* AFX_CDECL Create2dSolidPolylineDeviceCommand(
91 const CXTPChartPoints& p, const CXTPChartColor& color, int thickness);
92 static CXTPChartDeviceCommand* AFX_CDECL Create2dSolidSplineDeviceCommand(
93 const CXTPChartPoints& p, const CXTPChartColor& color, int thickness);
94 static CXTPChartDeviceCommand* AFX_CDECL Create2dDashedSplineDeviceCommand(
95 const CXTPChartPoints& p, const CXTPChartColor& color, int thickness,
96 XTPChartDashStyle nDashStyle, const CXTPChartLineDashArray& dashArray);
97 static CXTPChartDeviceCommand* AFX_CDECL Create2dDashedPolylineDeviceCommand(
98 const CXTPChartPoints& p, const CXTPChartColor& color, int thickness,
99 XTPChartDashStyle nDashStyle, const CXTPChartLineDashArray& dashArray);
100 static CXTPChartDeviceCommand* AFX_CDECL Create2dSolidSplinePolygonDeviceCommand(
101 const CXTPChartPoints& points, const CXTPChartColor& color, BOOL bTwoSides = FALSE);
102 static CXTPChartDeviceCommand* AFX_CDECL Create2dBoundedPolygonDeviceCommand(
103 const CXTPChartPoints& points, const CXTPChartColor& color, int thickness);
104 static CXTPChartDeviceCommand* AFX_CDECL Create2dSolidPolygonDeviceCommand(
105 const CXTPChartPoints& points, const CXTPChartColor& color);
106 static CXTPChartDeviceCommand* AFX_CDECL Create2dHatchPolygonDeviceCommand(
107 const CXTPChartPoints& points, const CXTPChartColor& color, const CXTPChartColor& color2,
108 XTPChartHatchStyle nStyle);
109 static CXTPChartDeviceCommand* AFX_CDECL Create2dGradientPolygonDeviceCommand(
110 const CXTPChartPoints& points, const CXTPChartColor& color, const CXTPChartColor& color2,
111 XTPChartLinearGradientMode nMode);
112 static CXTPChartDeviceCommand* AFX_CDECL
113 Create2dPolygonAntialiasingDeviceCommand(BOOL bAntiAlias = TRUE);
114 static CXTPChartDeviceCommand* AFX_CDECL Create3dShadeModelDeviceCommand(BOOL bAntiAlias = TRUE);
115 static CXTPChartDeviceCommand* AFX_CDECL Create2dInnerBorderDeviceCommand(
116 const CXTPChartRectF& rect, const CXTPChartColor& color, int thickness);
117 static CXTPChartDeviceCommand* AFX_CDECL Create2dBoundedRectangleDeviceCommand(
118 const CXTPChartRectF& rect, const CXTPChartColor& color, int thickness);
119 static CXTPChartDeviceCommand* AFX_CDECL Create2dSolidRectangleDeviceCommand(
120 const CXTPChartRectF& rect, const CXTPChartColor& color);
121 static CXTPChartDeviceCommand* AFX_CDECL Create2dGradientRectangleDeviceCommand(
122 const CXTPChartRectF& rect, const CXTPChartColor& color, const CXTPChartColor& color2,
123 XTPChartLinearGradientMode nMode);
124 static CXTPChartDeviceCommand* AFX_CDECL Create2dHatchRectangleDeviceCommand(
125 const CXTPChartRectF& rect, const CXTPChartColor& color, const CXTPChartColor& color2,
126 XTPChartHatchStyle nStyle);
127 static CXTPChartDeviceCommand* AFX_CDECL
128 Create2dTextAntialiasingDeviceCommand(BOOL bAntialias = TRUE);
129 static CXTPChartDeviceCommand* AFX_CDECL Create2dBoundedTextDeviceCommand(
130 const CXTPChartString& strText, CXTPChartFont* pFont, const CXTPChartColor& color,
131 const CXTPChartRectF& rectangle);
132 static CXTPChartDeviceCommand* AFX_CDECL Create2dMarkupElementDeviceCommand(
133 CXTPMarkupUIElement* pMarkupUIElement, CXTPChartFont* pFont, const CXTPChartColor& color,
134 const CXTPChartRectF& rectangle);
135 static CXTPChartDeviceCommand* AFX_CDECL Create2dSaveStateDeviceCommand();
136 static CXTPChartDeviceCommand* AFX_CDECL Create3dSaveMatrixDeviceCommand();
137 static CXTPChartDeviceCommand* AFX_CDECL
138 Create3dMultiplyMatrixDeviceCommand(const CXTPMatrix<double>& matrix, BOOL bPushMatrix);
139 static CXTPChartDeviceCommand* AFX_CDECL Create3dLoadIdentityDeviceCommand();
140 static CXTPChartDeviceCommand* AFX_CDECL Create2dClipDeviceCommand(CRect rcClip);
141 static CXTPChartDeviceCommand* AFX_CDECL
142 Create2dClipRegionDeviceCommand(const CXTPChartPoints& points);
143 static CXTPChartDeviceCommand* AFX_CDECL Create2dRotateDeviceCommand(float fAngle);
144 static CXTPChartDeviceCommand* AFX_CDECL
145 Create2dRotateDeviceCommand(float fAngle, const CXTPPoint3d& rotateVector);
146 static CXTPChartDeviceCommand* AFX_CDECL
147 Create3dRotateDeviceCommand(const CXTPChart3dRotation& rotation);
148 static CXTPChartDeviceCommand* AFX_CDECL Create2dTranslateDeviceCommand(double dx, double dy);
149 static CXTPChartDeviceCommand* AFX_CDECL Create3dTranslateDeviceCommand(double dx, double dy,
150 double dz);
151 static CXTPChartDeviceCommand* AFX_CDECL Create2dGradientPieDeviceCommand(
152 const CXTPPoint3d& center, double majorSemiAxis, double minorSemiAxis, double startAngle,
153 double sweepAngle, double depth, double holePercent, const CXTPChartRectF& gradientBounds,
154 const CXTPChartColor& color, const CXTPChartColor& color2);
155 static CXTPChartDeviceCommand* AFX_CDECL Create3dGradientPieDeviceCommand(
156 const CXTPPoint3d& center, double radius, double startAngle, double sweepAngle,
157 double depth, double holePercent, const CXTPChartRectF& gradientBounds,
158 const CXTPChartColor& color, const CXTPChartColor& color2, BOOL bStartGap = FALSE,
159 BOOL bEndGap = FALSE);
160 static CXTPChartDeviceCommand* AFX_CDECL Create2dBoundedPieDeviceCommand(
161 const CXTPPoint3d& center, double majorSemiAxis, double minorSemiAxis, double startAngle,
162 double sweepAngle, double depth, int holePercent, const CXTPChartColor& color,
163 int nThickness);
164 static CXTPChartDeviceCommand* AFX_CDECL Create2dFillBackgroundDeviceCommand(
165 const CXTPChartRectF& rect, const CXTPChartColor& color);
166 static CXTPChartDeviceCommand* AFX_CDECL
167 Create3dFillBackgroundDeviceCommand(const CXTPChartColor& color);
168 static CXTPChartDeviceCommand* AFX_CDECL Create3dCameraDeviceCommand(
169 const CXTPPoint3f& ptPosition, const CXTPPoint3f& ptFocal, const CXTPPoint3f& ptUpVector);
170
171public:
172 virtual CXTPChartDeviceContext* CreateDeviceContext(CXTPChartContainer* pContainer, HDC hDC,
173 const RECT& rcBounds) = 0;
174 virtual CXTPChartDeviceCommand*
175 CreatePolygonAntialiasingDeviceCommand(BOOL bAntiAlias = TRUE) = 0;
176 virtual CXTPChartDeviceCommand* CreateGradientPieDeviceCommand(
177 const CXTPPoint3d& center, double majorSemiAxis, double minorSemiAxis, double startAngle,
178 double sweepAngle, double depth, double holePercent, const CXTPChartRectF& gradientBounds,
179 const CXTPChartColor& color, const CXTPChartColor& color2) = 0;
180 virtual CXTPChartDeviceCommand* CreateFillBackgroundDeviceCommand(
181 const CXTPChartRectF& rect, const CXTPChartColor& color) = 0;
182 virtual CXTPChartDeviceCommand* CreateSolidLineDeviceCommand(const CXTPPoint3d& p1,
183 const CXTPPoint3d& p2,
184 const CXTPChartColor& color,
185 int thickness) = 0;
186};
187
195class CXTPChart2dDrawingObjectFactory
196 : public CXTPSingleton<CXTPChart2dDrawingObjectFactory>
197 , public CXTPChartDrawingObjectFactory
198{
199 friend class CXTPSingleton<CXTPChart2dDrawingObjectFactory>;
200
201 CXTPChart2dDrawingObjectFactory();
202
203public:
204 virtual CXTPChartDeviceContext* CreateDeviceContext(CXTPChartContainer* pContainer, HDC hDC,
205 const RECT& rcBounds);
206 virtual CXTPChartDeviceCommand* CreatePolygonAntialiasingDeviceCommand(BOOL bAntiAlias = TRUE);
207 virtual CXTPChartDeviceCommand* CreateGradientPieDeviceCommand(
208 const CXTPPoint3d& center, double majorSemiAxis, double minorSemiAxis, double startAngle,
209 double sweepAngle, double depth, double holePercent, const CXTPChartRectF& gradientBounds,
210 const CXTPChartColor& color, const CXTPChartColor& color2);
211 virtual CXTPChartDeviceCommand* CreateFillBackgroundDeviceCommand(const CXTPChartRectF& rect,
212 const CXTPChartColor& color);
213 virtual CXTPChartDeviceCommand* CreateSolidLineDeviceCommand(const CXTPPoint3d& p1,
214 const CXTPPoint3d& p2,
215 const CXTPChartColor& color,
216 int thickness);
217};
218
226class CXTPChart3dDrawingObjectFactory
227 : public CXTPSingleton<CXTPChart3dDrawingObjectFactory>
228 , public CXTPChartDrawingObjectFactory
229{
230 friend class CXTPSingleton<CXTPChart3dDrawingObjectFactory>;
231
232 CXTPChart3dDrawingObjectFactory();
233
234public:
235 virtual CXTPChartDeviceContext* CreateDeviceContext(CXTPChartContainer* pContainer, HDC hDC,
236 const RECT& rcBounds);
237 virtual CXTPChartDeviceCommand* CreatePolygonAntialiasingDeviceCommand(BOOL bAntiAlias = TRUE);
238 virtual CXTPChartDeviceCommand* CreateGradientPieDeviceCommand(
239 const CXTPPoint3d& center, double majorSemiAxis, double minorSemiAxis, double startAngle,
240 double sweepAngle, double depth, double holePercent, const CXTPChartRectF& gradientBounds,
241 const CXTPChartColor& color, const CXTPChartColor& color2);
242 virtual CXTPChartDeviceCommand* CreateFillBackgroundDeviceCommand(const CXTPChartRectF& rect,
243 const CXTPChartColor& color);
244 virtual CXTPChartDeviceCommand* CreateSolidLineDeviceCommand(const CXTPPoint3d& p1,
245 const CXTPPoint3d& p2,
246 const CXTPChartColor& color,
247 int thickness);
248};
250# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
251#endif //#if !defined(__XTPCHARTDRAWINGOBJECTFACTORY_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChart2dDrawingObjectFactory
Implements a 2D drawing object factory singleton.
Definition XTPChartDrawingObjectFactory.h:198
CXTPChart3dDrawingObjectFactory
Implements a 3D drawing object factory singleton.
Definition XTPChartDrawingObjectFactory.h:229
CXTPChart3dRotation
Represents a 3D rotation primitive for chart objects using Euler angles Yaw, Pitch and Roll in degree...
Definition XTPChartTypes.h:639
CXTPChartColor
This class abstracts a color entity.
Definition XTPChartTypes.h:51
CXTPChartContainer
This class represents the chart container.
Definition XTPChartElement.h:232
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartDrawingObjectFactory
Provides a set of factory methods for creating drawing device commands and a base class interface for...
Definition XTPChartDrawingObjectFactory.h:55
CXTPChartElement
This class abstracts a chart element, this class acts as a base class for all chart elements.
Definition XTPChartElement.h:131
CXTPChartFont
This class abstracts a font entity.
Definition XTPChartTypes.h:540
CXTPMarkupUIElement
Base class for XML Markup core level implementations.
Definition XTPMarkupUIElement.h:43
CXTPMatrix
Represents a matrix object built upon a continuos array of elements and provides basic algorithms for...
Definition XTPMatrix.h:40
CXTPPoint2T< float >
CXTPPoint3T< double >
CXTPRectT< float >
CXTPSingleton
Implements Singleton design pattern.
Definition XTPSingleton.h:215


Toolkit Pro: XTPControlGalleryNativeWindows11Theme.h Source File

  • Source
  • CommandBars
  • Gallery
XTPControlGalleryNativeWindows11Theme.h
Go to the documentation of this file.
1
23#if !defined(__XTPCONTROLGALLERYNATIVEWINDOWS11THEME_H__)
24# define __XTPCONTROLGALLERYNATIVEWINDOWS11THEME_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
40class _XTP_EXT_CLASS CXTPControlGalleryNativeWindows11Theme
41 : public CXTPControlGalleryOffice2013Theme
42{
43public:
49 CXTPControlGalleryNativeWindows11Theme(CXTPPaintManager* pPaintManager);
50};
51
53# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
54#endif // !defined(__XTPCONTROLGALLERYNATIVEWINDOWS11THEME_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPControlGalleryNativeWindows11Theme
The CXTPControlGalleryResourceTheme class is used to enable a Gallery Native Windows 10 style theme f...
Definition XTPControlGalleryNativeWindows11Theme.h:42
CXTPControlGalleryNativeWindows11Theme::CXTPControlGalleryNativeWindows11Theme
CXTPControlGalleryNativeWindows11Theme(CXTPPaintManager *pPaintManager)
Constructs a CXTPControlGalleryNativeWindows11Theme object.
CXTPControlGalleryOffice2013Theme
The CXTPControlGalleryResourceTheme class is used to enable a Gallery Office 2013 style theme for Com...
Definition XTPControlGalleryOffice2013Theme.h:41
CXTPPaintManager
Paint manager of the command bars.
Definition XTPPaintManager.h:199


Toolkit Pro: XTPSyntaxEditLexParser.h Source File

  • Source
  • SyntaxEdit
XTPSyntaxEditLexParser.h
Go to the documentation of this file.
1
23#if !defined(__XTPSYNTAXEDITLEXPARSER_H__)
24# define __XTPSYNTAXEDITLEXPARSER_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPSyntaxEditColorTheme;
34class CXTPNotifySink;
35class CXTPNotifyConnection;
36class CXTPSyntaxEditBufferManager;
37class CXTPNotifyConnectionMT;
38
40
41typedef CList<XTP_EDIT_TEXTBLOCK, XTP_EDIT_TEXTBLOCK> CXTPSyntaxEditTextBlockList;
42typedef CArray<XTP_EDIT_TEXTBLOCK, XTP_EDIT_TEXTBLOCK&> CXTPSyntaxEditTextBlockArray;
46namespace XTPSyntaxEditLexAnalyser
48{
49class CXTPSyntaxEditLexObj_ActiveTags;
50class CXTPSyntaxEditLexClass;
51class CXTPSyntaxEditLexClassInfoArray;
52class CXTPSyntaxEditLexOnScreenParseCnt;
53
60enum XTPSyntaxEditLexParseResult
61{
62 xtpEditLPR_Unknown = 0,
63 xtpEditLPR_StartFound = 0x001,
64 xtpEditLPR_EndFound = 0x002,
65 xtpEditLPR_Iterated = 0x010,
67 xtpEditLPR_TBpop1 = 0x020,
69 xtpEditLPR_Error = 0x100,
71 xtpEditLPR_RunFinished = 0x200,
73 xtpEditLPR_RunBreaked = 0x400,
75 xtpEditLPR_RunRestart = 0x800,
77 // xtpEditLPR_NeedFullReparse = 0x1000, // Cannot reparse only specified piece of text. Full
78 // reparse is necessary.
79};
80
87class _XTP_EXT_CLASS CXTPSyntaxEditTextRegion
88{
89public:
90 XTP_EDIT_LINECOL m_posStart;
91 XTP_EDIT_LINECOL m_posEnd;
97 void Clear();
98
105 void Set(const XTP_EDIT_LINECOL* pLCStart, const XTP_EDIT_LINECOL* pLCEnd);
106};
107
109typedef CArray<CXTPSyntaxEditTextRegion, const CXTPSyntaxEditTextRegion&>
110 CXTPSyntaxEditInvalidZoneArray;
118class _XTP_EXT_CLASS CXTPSyntaxEditLexTokensDef
119{
120public:
125 CXTPSyntaxEditLexTokensDef(){};
131 CXTPSyntaxEditLexTokensDef(const CXTPSyntaxEditLexTokensDef& rSrc);
132
137 virtual ~CXTPSyntaxEditLexTokensDef();
138
146 const CXTPSyntaxEditLexTokensDef& operator=(const CXTPSyntaxEditLexTokensDef& rSrc);
147
148 CStringArray m_arTokens;
149 CStringArray m_arStartSeps;
150 CStringArray m_arEndSeps;
151};
152
154typedef CArray<CXTPSyntaxEditLexTokensDef, const CXTPSyntaxEditLexTokensDef&>
155 CXTPSyntaxEditLexTokensDefArray;
162class _XTP_EXT_CLASS CXTPSyntaxEditLexParserSchemaOptions : public CXTPCmdTarget
163{
164public:
169 CXTPSyntaxEditLexParserSchemaOptions();
170
176 CXTPSyntaxEditLexParserSchemaOptions(const CXTPSyntaxEditLexParserSchemaOptions& rSrc);
177
183 const CXTPSyntaxEditLexParserSchemaOptions&
184 operator=(const CXTPSyntaxEditLexParserSchemaOptions& rSrc);
185
186 // global:
187 BOOL m_bFirstParseInSeparateThread;
188 BOOL m_bEditReparceInSeparateThread;
189 BOOL m_bConfigChangedReparceInSeparateThread;
190 DWORD m_dwMaxBackParseOffset;
192 DWORD m_dwEditReparceTimeout_ms;
194 DWORD m_dwOnScreenSchCacheLifeTime_sec;
196 DWORD m_dwParserThreadIdleLifeTime_ms;
198};
199
201class _XTP_EXT_CLASS CXTPSyntaxEditLexClassSchema : public CXTPCmdTarget
202{
203 friend class CXTPSyntaxEditLexTextSchema;
204
205public:
206 CXTPSyntaxEditLexClassSchema();
207
208 virtual ~CXTPSyntaxEditLexClassSchema();
209
210 virtual void AddPreBuildClass(CXTPSyntaxEditLexClass* pClass);
211
212 virtual BOOL Build();
213
214 virtual BOOL Copy(CXTPSyntaxEditLexClassSchema* pDest);
215
216 virtual void Close();
217
218 virtual void RemoveAll();
219
220 virtual CXTPSyntaxEditLexClassPtrArray* GetClasses(BOOL bShortSch);
221
222 virtual CXTPSyntaxEditLexClassPtrArray* GetPreBuildClasses();
223 virtual CXTPSyntaxEditLexClass* GetPreBuildClass(const CString& strName);
224
225 virtual CXTPSyntaxEditLexClass* GetNewClass(BOOL bForFile);
226
227 virtual CXTPSyntaxEditLexObj_ActiveTags* GetActiveTagsFor(CXTPSyntaxEditLexClass* pTopClass);
228
229protected:
230 virtual BOOL Build_ChildrenFor(BOOL bDynamic, CXTPSyntaxEditLexClass* pCBase,
231 CStringArray& rarAdded, int& rnNextClassID, int nLevel = 0);
232
233 virtual CXTPSyntaxEditLexClassPtrArray* GetChildrenFor(CXTPSyntaxEditLexClass* pClass,
234 BOOL& rbSelfChild);
235 virtual CXTPSyntaxEditLexClassPtrArray* GetDynChildrenFor(CXTPSyntaxEditLexClass* pClass,
236 BOOL& rbSelfChild);
237
238 virtual void GetDynParentsList(CXTPSyntaxEditLexClass* pClass, CStringArray& rarDynParents,
239 CStringArray& rarProcessedClasses);
240
241 virtual int CanBeParentDynForChild(CString strParentName, CXTPSyntaxEditLexClass* pCChild);
242
243 virtual BOOL Build_ShortTree();
244
245 virtual BOOL PostBuild_Step(CXTPSyntaxEditLexClassPtrArray* pArClasses);
246
247 virtual BOOL CopyChildrenFor(BOOL bShort, CXTPSyntaxEditLexClass* pCDest,
248 CXTPSyntaxEditLexClass* pCSrc, int nLevel);
249
250 CXTPSyntaxEditLexClassPtrArray m_arPreBuildClassesList;
251
252 CXTPSyntaxEditLexClassPtrArray m_arClassesTreeShort;
253 CXTPSyntaxEditLexClassPtrArray m_arClassesTreeFull;
254};
265class _XTP_EXT_CLASS CXTPSyntaxEditLexTextBlock : public CXTPCmdTarget
266{
268 friend class CXTPSyntaxEditLexTextSchema;
269 friend class CXTPSyntaxEditLexClass;
270 friend class CXTPSyntaxEditLexClass_file;
272public:
277 CXTPSyntaxEditLexTextBlock();
282 virtual ~CXTPSyntaxEditLexTextBlock();
283
284 CXTPSyntaxEditLexClassPtr m_ptrLexClass;
285 CXTPSyntaxEditLexTextBlockPtr m_ptrParent;
287 CXTPSyntaxEditLexTextBlockPtr m_ptrPrev;
288 CXTPSyntaxEditLexTextBlockPtr m_ptrNext;
290 XTP_EDIT_LINECOL m_PosStartLC;
291 XTP_EDIT_LINECOL m_PosEndLC;
292 BOOL m_bEndByParent;
307 XTP_EDIT_LINECOL GetPosEndLC(BOOL bMaxIfInvalid = TRUE);
308
317 DWORD GetStartTagEndXLC();
318
327 DWORD GetEndTagBeginXLC();
328
337 DWORD GetEndTagEndXLC();
338
347 virtual void Close();
348 // virtual void Close(BOOL bWithPrev = FALSE, BOOL bWithNext = FALSE);
349
360 virtual BOOL IsEqualLexClasses(CXTPSyntaxEditLexTextBlock* pTB2) const;
361
371 virtual BOOL IsInclude(CXTPSyntaxEditLexTextBlock* pTB2) const;
372
381 virtual BOOL IsLookLikeClosed() const;
382
391 virtual int EndChildren(CXTPSyntaxEditLexTextSchema* pTxtSch = NULL, BOOL bEndByParent = TRUE);
392
404 virtual CXTPSyntaxEditLexTextBlock* GetPrevChild(CXTPSyntaxEditLexTextBlock* pChild,
405 BOOL bWithAddRef);
406
407# ifdef _DEBUG
408 virtual void Dump(CDumpContext& dc) const;
409# endif
410
411protected:
412 int m_nStartTagLen;
413 int m_nEndTagXLCLen;
415 CXTPSyntaxEditLexTextBlockPtr m_ptrLastChild;
417};
418
427class _XTP_EXT_CLASS CXTPSyntaxEditLexTextSchema : public CXTPCmdTarget
428{
430 friend class CXTPSyntaxEditLexClass;
431 friend class CXTPSyntaxEditLexClass_file;
432 friend class CXTPSyntaxEditLexTextBlock;
433 friend class CXTPSyntaxEditLexParser;
435public:
441 CXTPSyntaxEditLexTextSchema(LPCTSTR pcszSchName);
442
447 virtual ~CXTPSyntaxEditLexTextSchema();
448
455 virtual CString GetSchName() const;
456
466 virtual void Close();
467
475 static void AFX_CDECL Close(CXTPSyntaxEditLexTextBlock* pFirst);
476
486 virtual void RemoveAll();
487
497 virtual CXTPSyntaxEditLexTextSchema* Clone();
498
505 virtual CXTPNotifyConnection* GetConnection();
506
530 virtual int RunParseUpdate(BOOL bShort, CTextIter* pTxtIter,
531 const XTP_EDIT_LINECOL* pLCStart = NULL,
532 const XTP_EDIT_LINECOL* pLCEnd = NULL,
533 BOOL bSendProgressEvents = FALSE);
534
542 virtual const CXTPSyntaxEditTextRegion& GetUpdatedTextRegion() const;
543
556 virtual BOOL RunParseOnScreen(CTextIter* pTxtIter, int nRowStart, int nRowEnd,
557 CXTPSyntaxEditLexTextBlockPtr& rPtrScreenSchFirstTB);
558
577 virtual void GetRowColors(CTextIter* pTxtIter, int nRow, int nColFrom, int nColTo,
578 const XTP_EDIT_COLORVALUES& clrDefault,
579 CXTPSyntaxEditTextBlockList* rBlocks,
580 CXTPSyntaxEditLexTextBlockPtr* pptrTBStartCache = NULL,
581 CXTPSyntaxEditLexTextBlock* pFirstSchTB = NULL);
582
594 virtual void GetCollapsableBlocksInfo(int nRow, CXTPSyntaxEditRowsBlockArray& rArBlocks,
595 CXTPSyntaxEditLexTextBlockPtr* pptrTBStartCache = NULL);
596
604 virtual void GetTextAttributes(XTP_EDIT_TEXTBLOCK& rTB, CXTPSyntaxEditLexTextBlock* pTextBlock);
605
611 virtual void ApplyTheme(CXTPSyntaxEditColorTheme* pTheme);
612
620 BOOL LoadClassSchema(CXTPSyntaxEditLexClassInfoArray* arClassInfo);
621
632 BOOL IsFileExtSupported(const CString& strExt);
633
644 void BuildIfNeed();
645
657 CXTPSyntaxEditLexClass* GetTopClassForFileExt(const CString& strExt);
658
672 virtual CXTPSyntaxEditLexTextBlock* GetLastParsedBlock(WPARAM dwID = 0);
673
682 CXTPSyntaxEditLexTextBlock* GetBlocks();
683
691 CMutex* GetDataLoker();
692
699 CMutex* GetClassSchLoker();
700
707 CEvent* GetBreakParsingEvent();
708
710 static void AFX_CDECL TraceClrBlocks(CXTPSyntaxEditTextBlockArray& arBlocks);
711 void TraceTxtBlocks(BOOL bFull);
714protected:
719 enum XTPSyntaxEditUpdateTBRes
720 {
721 xtpEditUTBNothing = 0,
722 xtpEditUTBError = 0x0001,
723 xtpEditUTBReparse = 0x0002,
724 xtpEditUTBNearestUpdated = 0x0100,
725 };
726
735 CXTPSyntaxEditLexClassSchema* GetClassSchema();
736
745 virtual void ApplyThemeRecursive(CXTPSyntaxEditColorTheme* pTheme,
746 CXTPSyntaxEditLexClassPtrArray* ptrClasses);
747
759 int UpdateTextBlocks(XTP_EDIT_LINECOL posFrom, XTP_EDIT_LINECOL posTo, int eEditAction);
760
762 virtual int RunChildren(CTextIter* pTxtIter, CXTPSyntaxEditLexTextBlockPtr ptrTxtBlock,
763 CXTPSyntaxEditLexClass* pBase,
764 CXTPSyntaxEditLexOnScreenParseCnt* pOnScreenRunCnt = NULL);
765
766 virtual CXTPSyntaxEditLexTextBlock* GetPrevBlock(BOOL bWithAddRef = TRUE);
767
768 virtual CXTPSyntaxEditLexTextBlock* GetNewBlock();
771private:
772 int UpdateTBNearest(CXTPSyntaxEditLexTextBlock* pNarestTB1, int nLineDiff, int nColDiff,
773 XTP_EDIT_LINECOL posFrom, XTP_EDIT_LINECOL posTo, int eEditAction);
774
775 CXTPSyntaxEditLexTextBlock* FindNearestTextBlock(XTP_EDIT_LINECOL posText);
776
777 virtual BOOL InitScreenSch(CTextIter* pTxtIter, int nRowStart, int nRowEnd,
778 CXTPSyntaxEditLexTextBlockPtr& rPtrScreenSchFirstTB,
779 CXTPSyntaxEditLexTextBlockPtr& rPtrTBParentToRun);
780
781 virtual CXTPSyntaxEditLexTextBlockPtr InitScreenSch_RunTopClass(CTextIter* pTxtIter);
782
783 virtual CXTPSyntaxEditLexTextBlock* CopyShortTBtoFull(CXTPSyntaxEditLexTextBlock* pTB);
784 virtual CXTPSyntaxEditLexClass* FindLexClassByID(CXTPSyntaxEditLexClassPtrArray* pClassesAr,
785 int nClassID);
786
787 virtual int Run_OnScreenTBStack(CTextIter* pTxtIter, CXTPSyntaxEditLexTextBlock* pTBParentToRun,
788 CXTPSyntaxEditLexOnScreenParseCnt* pRunCnt);
789
790 virtual void UpdateLastSchBlock(CXTPSyntaxEditLexTextBlock* pLastTB, BOOL bPermanently = FALSE);
791 virtual CXTPSyntaxEditLexTextBlock* GetLastSchBlock(BOOL bWithAddRef = TRUE);
792
793 virtual UINT SendEvent_OnTextBlockParsed(CXTPSyntaxEditLexTextBlock* pTB);
794
795 virtual int Run_ParseUpdate0(BOOL bShort, CTextIter* pTxtIter, const XTP_EDIT_LINECOL* pLCStart,
796 const XTP_EDIT_LINECOL* pLCEnd, BOOL bSendProgressEvents);
797
798 virtual int Run_ClassesUpdate1(CTextIter* pTxtIter, CXTPSyntaxEditLexTextBlockPtr ptrStartTB,
799 BOOL bStarted);
800
801 virtual int Run_ClassesUpdate2(CTextIter* pTxtIter, CXTPSyntaxEditLexClassPtrArray* pArClasses,
802 CXTPSyntaxEditLexTextBlockPtr ptrParentTB,
803 CXTPSyntaxEditLexOnScreenParseCnt* pOnScreenRunCnt = NULL);
804
805 virtual BOOL IsBlockStartStillHere(CTextIter* pTxtIter, CXTPSyntaxEditLexTextBlock* pTB);
806 virtual void FinishNewChain(BOOL bByBreak, BOOL bEOF);
807 virtual void UpdateNewChainParentsChildren();
808 virtual void EndBlocksByParent(CXTPSyntaxEditLexTextBlock* pTBStart,
809 CXTPSyntaxEditLexTextBlock* pTBEnd);
810
811 virtual void SeekNextEx(CTextIter* pTxtIter, CXTPSyntaxEditLexClass* pRunClass = NULL,
812 CXTPSyntaxEditLexOnScreenParseCnt* pOnScreenRunCnt = NULL,
813 int nChars = 1);
814
815 static void AFX_CDECL AddClrBlock(XTP_EDIT_TEXTBLOCK& rClrB,
816 CXTPSyntaxEditTextBlockArray& arBlocks);
817
818 //==== Run parse update context members ====
819 CXTPSyntaxEditTextRegion m_curInvalidZone;
820
821 CXTPSyntaxEditLexTextBlockPtr m_ptrNewChainTB1;
822 CXTPSyntaxEditLexTextBlockPtr m_ptrNewChainTB2;
823 CXTPSyntaxEditLexTextBlockPtr m_ptrOldChainTBFirst;
824
825 typedef CMap<WPARAM, WPARAM, CXTPSyntaxEditLexTextBlockPtr, CXTPSyntaxEditLexTextBlockPtr&>
826 CXTPSyntaxEditLexID2TBmap;
827
828 CXTPSyntaxEditLexID2TBmap m_mapLastParsedBlocks;
829 CXTPSyntaxEditLexTextBlockPtr m_ptrLastParsedBlock;
830 BOOL m_bSendProgressEvents;
831
832 int m_nNoEndedClassesCount;
833 //==== END Run parse update context members ====
834
835private:
836 // CCriticalSection m_csData;
837 // CCriticalSection m_csClassSch;
838 CMutex m_lockData;
839 CMutex m_lockClassSch;
840
841 CEvent m_evBreakParsing;
842
843 CXTPSyntaxEditLexClassSchema* m_pClassSchema;
844
845 CXTPSyntaxEditLexTextBlockPtr m_ptrFirstBlock;
846 CXTPSyntaxEditLexTextBlockPtr m_ptrLastSchBlock;
847
848 int m_nSeekNext_TagWaitChars;
849
850 CString m_strSchName;
851
852 CXTPNotifyConnectionMT* m_pConnectMT;
853};
854
860class _XTP_EXT_CLASS CXTPSyntaxEditLexParser : public CXTPCmdTarget
861{
862public:
867 CXTPSyntaxEditLexParser();
868
873 virtual ~CXTPSyntaxEditLexParser();
874
882 virtual void Close();
883
890 virtual void CloseParseThread();
891
911 virtual void StartParseInThread(CXTPSyntaxEditBufferManager* pBuffer,
912 const XTP_EDIT_LINECOL* pLCStart = NULL,
913 const XTP_EDIT_LINECOL* pLCEnd = NULL, int eEditAction = 0,
914 BOOL bRunWithoutWait = FALSE);
915
922 virtual void StopParseInThread();
923
930 virtual void OnBeforeEditChanged();
931
943 virtual void OnEditChanged(const XTP_EDIT_LINECOL& posFrom, const XTP_EDIT_LINECOL& posTo,
944 int eEditAction, CXTPSyntaxEditBufferManager* pBuffer);
945
954 virtual CXTPSyntaxEditLexTextSchema* GetTextSchema();
955
963 virtual void SetTextSchema(CXTPSyntaxEditLexTextSchema* pTextSchema);
964
972 virtual const CXTPSyntaxEditLexParserSchemaOptions* GetSchemaOptions(const CString& strExt);
973
982 virtual int GetParseThreadPriority();
983
993 virtual BOOL SetParseThreadPriority(int nPriority);
994
1005 virtual BOOL GetTokensForAutoCompleate(CXTPSyntaxEditLexTokensDefArray& rArTokens,
1006 BOOL bAppend);
1007
1014 virtual CXTPNotifyConnection* GetConnection();
1015
1016protected:
1018 class CXTPSyntaxEditParseThreadParams
1019 {
1020 public:
1021 CXTPSyntaxEditParseThreadParams();
1022
1023 void AddParseZone(const CXTPSyntaxEditTextRegion& rZone);
1024
1025 CMutex lockThreadParams;
1026 CXTPSyntaxEditBufferManager* ptrBuffer;
1027 CXTPSyntaxEditInvalidZoneArray arInvalidZones;
1028 CEvent evParseRun;
1029 CEvent evRunWithoutWait;
1030 CEvent evExitThread;
1031 };
1032
1033 virtual CXTPSyntaxEditParseThreadParams* GetParseInThreadParams();
1037 virtual void SelfCloseParseThread();
1038
1039 static UINT AFX_CDECL ThreadParseProc(LPVOID);
1040
1041 CCriticalSection m_csParserData;
1042 CWinThread* m_pParseThread;
1043 int m_nParseThreadPriority;
1045 CXTPSyntaxEditParseThreadParams m_PThreadParams;
1046
1047 CXTPSyntaxEditLexTextSchema* m_ptrTextSchema;
1048
1049 typedef CMap<CString, LPCTSTR, CXTPSyntaxEditLexParserSchemaOptions*,
1050 CXTPSyntaxEditLexParserSchemaOptions*>
1051 CXTPSyntaxEditLexParserSchemaOptionsMap;
1052
1053 CXTPSyntaxEditLexParserSchemaOptionsMap m_mapSchOptions;
1054 CXTPSyntaxEditLexParserSchemaOptions* m_pSchOptions_default;
1055
1056 CXTPNotifyConnection* m_pConnection;
1057 CXTPNotifySink* m_pSinkMT;
1061 virtual void OnParseEvent_NotificationHandler(XTP_NOTIFY_CODE Event, WPARAM wParam,
1062 LPARAM lParam);
1063
1064 virtual void GetStrsFromLVArray(CXTPSyntaxEditLexVariant* pLVArray,
1065 CStringArray& rArStrs) const;
1066
1067 virtual BOOL ReadSchemaOptions(const CString& strExt, CXTPSyntaxEditLexTextSchema* pTextSchema,
1068 CXTPSyntaxEditLexParserSchemaOptions* pOpt);
1069
1070private:
1071 void RemoveAllOptions();
1072};
1073
1077AFX_INLINE const CXTPSyntaxEditTextRegion& CXTPSyntaxEditLexTextSchema::GetUpdatedTextRegion() const
1078{
1079 return m_curInvalidZone;
1080}
1081
1082AFX_INLINE CMutex* CXTPSyntaxEditLexTextSchema::GetDataLoker()
1083{
1084 return &m_lockData;
1085}
1086
1087AFX_INLINE CMutex* CXTPSyntaxEditLexTextSchema::GetClassSchLoker()
1088{
1089 return &m_lockClassSch;
1090}
1091
1092AFX_INLINE CEvent* CXTPSyntaxEditLexTextSchema::GetBreakParsingEvent()
1093{
1094 return &m_evBreakParsing;
1095}
1096
1097AFX_INLINE XTP_EDIT_LINECOL CXTPSyntaxEditLexTextBlock::GetPosEndLC(BOOL bMaxIfInvalid)
1098{
1099 if (!m_PosEndLC.IsValidData())
1100 {
1101 return bMaxIfInvalid ? XTP_EDIT_LINECOL::MAXPOS : XTP_EDIT_LINECOL::MINPOS;
1102 }
1103 return m_PosEndLC;
1104}
1105
1106AFX_INLINE DWORD CXTPSyntaxEditLexTextBlock::GetStartTagEndXLC()
1107{
1108 return m_PosStartLC.GetXLC() + m_nStartTagLen;
1109}
1110
1111AFX_INLINE DWORD CXTPSyntaxEditLexTextBlock::GetEndTagBeginXLC()
1112{
1113 return m_PosEndLC.GetXLC() - (m_nEndTagXLCLen > 0 ? m_nEndTagXLCLen : 0);
1114}
1115
1116AFX_INLINE DWORD CXTPSyntaxEditLexTextBlock::GetEndTagEndXLC()
1117{
1118 return m_PosEndLC.GetXLC() - (m_nEndTagXLCLen < 0 ? m_nEndTagXLCLen : 0);
1119}
1120} // namespace XTPSyntaxEditLexAnalyser
1121
1123//#pragma warning(pop)
1125
1127# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
1128
1129#endif // !defined(__XTPSYNTAXEDITLEXPARSER_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPSyntaxEditLexParseResult
XTPSyntaxEditLexParseResult
Enumerates flags which indicate the results of parse function calls.
Definition XTPSyntaxEditLexParser.h:61
xtpEditLPR_RunBreaked
@ xtpEditLPR_RunBreaked
Run iterated parse process (or some big part of it) has breaked.
Definition XTPSyntaxEditLexParser.h:73
xtpEditLPR_EndFound
@ xtpEditLPR_EndFound
End text block was found.
Definition XTPSyntaxEditLexParser.h:64
xtpEditLPR_StartFound
@ xtpEditLPR_StartFound
Start text block was found.
Definition XTPSyntaxEditLexParser.h:63
xtpEditLPR_TBpop1
@ xtpEditLPR_TBpop1
Indicates that the new found text block should be inserted before the previous one and as a parent of...
Definition XTPSyntaxEditLexParser.h:67
xtpEditLPR_Error
@ xtpEditLPR_Error
Iterated parse process breaked due to some error.
Definition XTPSyntaxEditLexParser.h:69
xtpEditLPR_RunFinished
@ xtpEditLPR_RunFinished
Run iterated parse process (or some big part of it) has finished.
Definition XTPSyntaxEditLexParser.h:71
xtpEditLPR_RunRestart
@ xtpEditLPR_RunRestart
Restart run children from the beginning.
Definition XTPSyntaxEditLexParser.h:75
xtpEditLPR_Unknown
@ xtpEditLPR_Unknown
Undefined value.
Definition XTPSyntaxEditLexParser.h:62
xtpEditLPR_Iterated
@ xtpEditLPR_Iterated
Indicates that the current text position has already moved to the next char inside a function call.
Definition XTPSyntaxEditLexParser.h:65
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPInternalCollectionT
Definition XTPSmartPtrInternalT.h:387
CXTPNotifyConnection
This class is used as implementation of Connection interface in a XTPNotification mechanism.
Definition XTPNotifyConnection.h:88
CXTPNotifyConnectionMT
This class is used as thread-safety implementation of Connection interface in a XTPNotification mecha...
Definition XTPNotifyConnection.h:303
CXTPSmartPtrInternalT< CXTPSyntaxEditLexClass >
CXTPSyntaxEditBufferManager
This class is the main class for buffer management.
Definition XTPSyntaxEditBufferManager.h:59
CXTPSyntaxEditColorTheme
This class provides the functionality to read configuration information from configuration files with...
Definition XTPSyntaxEditLexColorFileReader.h:203
CXTPSyntaxEditLexClass
CXTPSyntaxEditLexClass class is used to represent lexical block of text definition and to parse text.
Definition XTPSyntaxEditLexClass.h:633
CXTPSyntaxEditLexOnScreenParseCnt
CXTPSyntaxEditLexOnScreenParseCnt provides context data storage for OnScreen iterated parsing process...
Definition XTPSyntaxEditLexClass.h:508
CXTPSyntaxEditLexParser
This class used to 'run' lex schema parsing in a separate thread.
Definition XTPSyntaxEditLexParser.h:861
CXTPSyntaxEditLexParser::StartParseInThread
virtual void StartParseInThread(CXTPSyntaxEditBufferManager *pBuffer, const XTP_EDIT_LINECOL *pLCStart=NULL, const XTP_EDIT_LINECOL *pLCEnd=NULL, int eEditAction=0, BOOL bRunWithoutWait=FALSE)
Starts parsing a specified text range in a separate (working) thread.
CXTPSyntaxEditLexParser::SetTextSchema
virtual void SetTextSchema(CXTPSyntaxEditLexTextSchema *pTextSchema)
Sets the active text schema.
CXTPSyntaxEditLexParser::StopParseInThread
virtual void StopParseInThread()
Stops parsing in thread.
CXTPSyntaxEditLexParser::OnEditChanged
virtual void OnEditChanged(const XTP_EDIT_LINECOL &posFrom, const XTP_EDIT_LINECOL &posTo, int eEditAction, CXTPSyntaxEditBufferManager *pBuffer)
Reparses text after editing.
CXTPSyntaxEditLexParser::GetParseThreadPriority
virtual int GetParseThreadPriority()
Gets the priority of the working thread.
CXTPSyntaxEditLexParser::SetParseThreadPriority
virtual BOOL SetParseThreadPriority(int nPriority)
Sets the priority for the working thread.
CXTPSyntaxEditLexParser::GetTokensForAutoCompleate
virtual BOOL GetTokensForAutoCompleate(CXTPSyntaxEditLexTokensDefArray &rArTokens, BOOL bAppend)
Gets the auto-complete words of the active text schema.
CXTPSyntaxEditLexParser::GetSchemaOptions
virtual const CXTPSyntaxEditLexParserSchemaOptions * GetSchemaOptions(const CString &strExt)
Gets the schema options.
CXTPSyntaxEditLexParser::OnBeforeEditChanged
virtual void OnBeforeEditChanged()
Stops parsing in thread before a call to OnEditChanged.
CXTPSyntaxEditLexParser::~CXTPSyntaxEditLexParser
virtual ~CXTPSyntaxEditLexParser()
Object destructor.
CXTPSyntaxEditLexParser::CloseParseThread
virtual void CloseParseThread()
Stops parsing and destroys the working thread.
CXTPSyntaxEditLexParser::CXTPSyntaxEditLexParser
CXTPSyntaxEditLexParser()
Default object constructor.
CXTPSyntaxEditLexParser::GetTextSchema
virtual CXTPSyntaxEditLexTextSchema * GetTextSchema()
Gets the active text schema.
CXTPSyntaxEditLexParser::Close
virtual void Close()
Stops parsing, destroys the working thread, and unadvises from all events.
CXTPSyntaxEditLexParser::GetConnection
virtual CXTPNotifyConnection * GetConnection()
Gets the notification connection.
CXTPSyntaxEditLexParserSchemaOptions
This class is designed to easily manipulate parser options.
Definition XTPSyntaxEditLexParser.h:163
CXTPSyntaxEditLexParserSchemaOptions::m_bConfigChangedReparceInSeparateThread
BOOL m_bConfigChangedReparceInSeparateThread
{0,1} default=1
Definition XTPSyntaxEditLexParser.h:189
CXTPSyntaxEditLexParserSchemaOptions::m_bFirstParseInSeparateThread
BOOL m_bFirstParseInSeparateThread
{0,1} default=1
Definition XTPSyntaxEditLexParser.h:187
CXTPSyntaxEditLexParserSchemaOptions::m_dwMaxBackParseOffset
DWORD m_dwMaxBackParseOffset
default=100; maximum back buffer size.
Definition XTPSyntaxEditLexParser.h:190
CXTPSyntaxEditLexParserSchemaOptions::operator=
const CXTPSyntaxEditLexParserSchemaOptions & operator=(const CXTPSyntaxEditLexParserSchemaOptions &rSrc)
Overloaded equals operator.
CXTPSyntaxEditLexParserSchemaOptions::m_bEditReparceInSeparateThread
BOOL m_bEditReparceInSeparateThread
{0,1} default=1
Definition XTPSyntaxEditLexParser.h:188
CXTPSyntaxEditLexParserSchemaOptions::m_dwOnScreenSchCacheLifeTime_sec
DWORD m_dwOnScreenSchCacheLifeTime_sec
default=180 sec; time out for on screen parsed pices of text.
Definition XTPSyntaxEditLexParser.h:194
CXTPSyntaxEditLexParserSchemaOptions::CXTPSyntaxEditLexParserSchemaOptions
CXTPSyntaxEditLexParserSchemaOptions()
Default object constructor.
CXTPSyntaxEditLexParserSchemaOptions::m_dwParserThreadIdleLifeTime_ms
DWORD m_dwParserThreadIdleLifeTime_ms
default=60 sec; time out for existing of parser thread when parser idle (no parse requests).
Definition XTPSyntaxEditLexParser.h:196
CXTPSyntaxEditLexParserSchemaOptions::CXTPSyntaxEditLexParserSchemaOptions
CXTPSyntaxEditLexParserSchemaOptions(const CXTPSyntaxEditLexParserSchemaOptions &rSrc)
Object constructor.
CXTPSyntaxEditLexParserSchemaOptions::m_dwEditReparceTimeout_ms
DWORD m_dwEditReparceTimeout_ms
default=500 ms; time out for start reparse after last key was pressed.
Definition XTPSyntaxEditLexParser.h:192
CXTPSyntaxEditLexTextBlock
The CXTPSyntaxEditLexTextBlock class represents a block of text which corresponds to a lex class in a...
Definition XTPSyntaxEditLexParser.h:266
CXTPSyntaxEditLexTextBlock::IsEqualLexClasses
virtual BOOL IsEqualLexClasses(CXTPSyntaxEditLexTextBlock *pTB2) const
Determines if the lex class name of a specified text block is equal to the lex class name of the curr...
CXTPSyntaxEditLexTextBlock::m_ptrLastChild
CXTPSyntaxEditLexTextBlockPtr m_ptrLastChild
For internal use only.
Definition XTPSyntaxEditLexParser.h:415
CXTPSyntaxEditLexTextBlock::GetPosEndLC
XTP_EDIT_LINECOL GetPosEndLC(BOOL bMaxIfInvalid=TRUE)
Gets the text block end position.
CXTPSyntaxEditLexTextBlock::m_ptrNext
CXTPSyntaxEditLexTextBlockPtr m_ptrNext
Pointer to the next block.
Definition XTPSyntaxEditLexParser.h:288
CXTPSyntaxEditLexTextBlock::GetPrevChild
virtual CXTPSyntaxEditLexTextBlock * GetPrevChild(CXTPSyntaxEditLexTextBlock *pChild, BOOL bWithAddRef)
Gets the previous child block from a specified child block.
CXTPSyntaxEditLexTextBlock::GetEndTagBeginXLC
DWORD GetEndTagBeginXLC()
Gets the text block end tag begin position in the text.
CXTPSyntaxEditLexTextBlock::m_PosStartLC
XTP_EDIT_LINECOL m_PosStartLC
Text block start position.
Definition XTPSyntaxEditLexParser.h:290
CXTPSyntaxEditLexTextBlock::m_ptrParent
CXTPSyntaxEditLexTextBlockPtr m_ptrParent
Pointer to the parent block object.
Definition XTPSyntaxEditLexParser.h:285
CXTPSyntaxEditLexTextBlock::m_nEndTagXLCLen
int m_nEndTagXLCLen
End tag length in XLC form.
Definition XTPSyntaxEditLexParser.h:413
CXTPSyntaxEditLexTextBlock::IsInclude
virtual BOOL IsInclude(CXTPSyntaxEditLexTextBlock *pTB2) const
Determines if a specified text block is included within the current text block.
CXTPSyntaxEditLexTextBlock::GetEndTagEndXLC
DWORD GetEndTagEndXLC()
Gets the text block end tag end position in the text.
CXTPSyntaxEditLexTextBlock::m_ptrPrev
CXTPSyntaxEditLexTextBlockPtr m_ptrPrev
Pointer to the previous block.
Definition XTPSyntaxEditLexParser.h:287
CXTPSyntaxEditLexTextBlock::CXTPSyntaxEditLexTextBlock
CXTPSyntaxEditLexTextBlock()
Default object constructor.
CXTPSyntaxEditLexTextBlock::m_PosEndLC
XTP_EDIT_LINECOL m_PosEndLC
Text block start position.
Definition XTPSyntaxEditLexParser.h:291
CXTPSyntaxEditLexTextBlock::~CXTPSyntaxEditLexTextBlock
virtual ~CXTPSyntaxEditLexTextBlock()
Object destructor.
CXTPSyntaxEditLexTextBlock::EndChildren
virtual int EndChildren(CXTPSyntaxEditLexTextSchema *pTxtSch=NULL, BOOL bEndByParent=TRUE)
Sets the end position to not ended children blocks.
CXTPSyntaxEditLexTextBlock::IsLookLikeClosed
virtual BOOL IsLookLikeClosed() const
Determines if the current text block appears to be partly closed or closed.
CXTPSyntaxEditLexTextBlock::m_ptrLexClass
CXTPSyntaxEditLexClassPtr m_ptrLexClass
Pointer to the LexClass object.
Definition XTPSyntaxEditLexParser.h:284
CXTPSyntaxEditLexTextBlock::m_nStartTagLen
int m_nStartTagLen
Start tag length.
Definition XTPSyntaxEditLexParser.h:412
CXTPSyntaxEditLexTextBlock::m_bEndByParent
BOOL m_bEndByParent
Text block ended when the parent block ended.
Definition XTPSyntaxEditLexParser.h:292
CXTPSyntaxEditLexTextBlock::Close
virtual void Close()
Releases references to other objects.
CXTPSyntaxEditLexTextBlock::GetStartTagEndXLC
DWORD GetStartTagEndXLC()
Gets the text block start tag end position in the text.
CXTPSyntaxEditLexTextSchema
The CXTPSyntaxEditLexTextSchema class is used to store data which is necessary to parse a text and pa...
Definition XTPSyntaxEditLexParser.h:428
CXTPSyntaxEditLexTextSchema::GetLastParsedBlock
virtual CXTPSyntaxEditLexTextBlock * GetLastParsedBlock(WPARAM dwID=0)
Retrieves a specified text block by its identifier.
CXTPSyntaxEditLexTextSchema::GetUpdatedTextRegion
virtual const CXTPSyntaxEditTextRegion & GetUpdatedTextRegion() const
Gets the text region for which the schema was updated during the last parse/reparse operation.
CXTPSyntaxEditLexTextSchema::~CXTPSyntaxEditLexTextSchema
virtual ~CXTPSyntaxEditLexTextSchema()
Object destructor.
CXTPSyntaxEditLexTextSchema::BuildIfNeed
void BuildIfNeed()
Builds the schema if necessary, otherwise does nothing.
CXTPSyntaxEditLexTextSchema::Close
static void AFX_CDECL Close(CXTPSyntaxEditLexTextBlock *pFirst)
Destroys the text blocks list.
CXTPSyntaxEditLexTextSchema::ApplyThemeRecursive
virtual void ApplyThemeRecursive(CXTPSyntaxEditColorTheme *pTheme, CXTPSyntaxEditLexClassPtrArray *ptrClasses)
Applies a specified color theme to a specified lex class array.
CXTPSyntaxEditLexTextSchema::CXTPSyntaxEditLexTextSchema
CXTPSyntaxEditLexTextSchema(LPCTSTR pcszSchName)
Default object constructor.
CXTPSyntaxEditLexTextSchema::IsFileExtSupported
BOOL IsFileExtSupported(const CString &strExt)
Determines if this schema supports a specified file extension.
CXTPSyntaxEditLexTextSchema::GetClassSchema
CXTPSyntaxEditLexClassSchema * GetClassSchema()
Gets the class schema of this text schema.
CXTPSyntaxEditLexTextSchema::UpdateTextBlocks
int UpdateTextBlocks(XTP_EDIT_LINECOL posFrom, XTP_EDIT_LINECOL posTo, int eEditAction)
Updates text schema positions after an editing action.
CXTPSyntaxEditLexTextSchema::GetBlocks
CXTPSyntaxEditLexTextBlock * GetBlocks()
Gets the first text schema block.
CXTPSyntaxEditLexTextSchema::GetSchName
virtual CString GetSchName() const
Gets the text schema name.
CXTPSyntaxEditLexTextSchema::RunParseUpdate
virtual int RunParseUpdate(BOOL bShort, CTextIter *pTxtIter, const XTP_EDIT_LINECOL *pLCStart=NULL, const XTP_EDIT_LINECOL *pLCEnd=NULL, BOOL bSendProgressEvents=FALSE)
Runs parse for the text.
CXTPSyntaxEditLexTextSchema::GetTextAttributes
virtual void GetTextAttributes(XTP_EDIT_TEXTBLOCK &rTB, CXTPSyntaxEditLexTextBlock *pTextBlock)
Gets the text attributes from the lex class of a specified text block.
CXTPSyntaxEditLexTextSchema::Clone
virtual CXTPSyntaxEditLexTextSchema * Clone()
Creates a new text schema object and initializes its internal infrastructure from the current schema.
CXTPSyntaxEditLexTextSchema::RemoveAll
virtual void RemoveAll()
Removes all text blocks from the schema.
CXTPSyntaxEditLexTextSchema::ApplyTheme
virtual void ApplyTheme(CXTPSyntaxEditColorTheme *pTheme)
Applies a specified color theme to this text schema.
CXTPSyntaxEditLexTextSchema::Close
virtual void Close()
Destroys all interlocked object references and frees all stored objects.
CXTPSyntaxEditLexTextSchema::RunParseOnScreen
virtual BOOL RunParseOnScreen(CTextIter *pTxtIter, int nRowStart, int nRowEnd, CXTPSyntaxEditLexTextBlockPtr &rPtrScreenSchFirstTB)
Runs parse for the text on screen.
CXTPSyntaxEditLexTextSchema::GetDataLoker
CMutex * GetDataLoker()
Gets the critical section object to lock schema data (i.e.
CXTPSyntaxEditLexTextSchema::LoadClassSchema
BOOL LoadClassSchema(CXTPSyntaxEditLexClassInfoArray *arClassInfo)
Loads a specified class schema.
CXTPSyntaxEditLexTextSchema::GetRowColors
virtual void GetRowColors(CTextIter *pTxtIter, int nRow, int nColFrom, int nColTo, const XTP_EDIT_COLORVALUES &clrDefault, CXTPSyntaxEditTextBlockList *rBlocks, CXTPSyntaxEditLexTextBlockPtr *pptrTBStartCache=NULL, CXTPSyntaxEditLexTextBlock *pFirstSchTB=NULL)
Gets a specified row as a list of blocks with different colors to draw.
CXTPSyntaxEditLexTextSchema::XTPSyntaxEditUpdateTBRes
XTPSyntaxEditUpdateTBRes
This enum describes the set of UpdateTextBlocks return results.
Definition XTPSyntaxEditLexParser.h:720
CXTPSyntaxEditLexTextSchema::GetClassSchLoker
CMutex * GetClassSchLoker()
Gets the critical section object to lock class schema.
CXTPSyntaxEditLexTextSchema::GetCollapsableBlocksInfo
virtual void GetCollapsableBlocksInfo(int nRow, CXTPSyntaxEditRowsBlockArray &rArBlocks, CXTPSyntaxEditLexTextBlockPtr *pptrTBStartCache=NULL)
Gets a specified row as a list of collapsible blocks.
CXTPSyntaxEditLexTextSchema::GetConnection
virtual CXTPNotifyConnection * GetConnection()
Gets the notification connection.
CXTPSyntaxEditLexTextSchema::GetBreakParsingEvent
CEvent * GetBreakParsingEvent()
Gets the event object to break the parsing process.
CXTPSyntaxEditLexTextSchema::GetTopClassForFileExt
CXTPSyntaxEditLexClass * GetTopClassForFileExt(const CString &strExt)
Gets the top lex class for a specified file extension.
CXTPSyntaxEditLexTokensDef
This class stores tokens definition: a list of tokens and corresponding lists of start and end tokens...
Definition XTPSyntaxEditLexParser.h:119
CXTPSyntaxEditLexTokensDef::CXTPSyntaxEditLexTokensDef
CXTPSyntaxEditLexTokensDef(const CXTPSyntaxEditLexTokensDef &rSrc)
Copy object constructor.
CXTPSyntaxEditLexTokensDef::m_arTokens
CStringArray m_arTokens
List of tokens.
Definition XTPSyntaxEditLexParser.h:148
CXTPSyntaxEditLexTokensDef::m_arStartSeps
CStringArray m_arStartSeps
List of start separators.
Definition XTPSyntaxEditLexParser.h:149
CXTPSyntaxEditLexTokensDef::CXTPSyntaxEditLexTokensDef
CXTPSyntaxEditLexTokensDef()
Default object constructor.
Definition XTPSyntaxEditLexParser.h:125
CXTPSyntaxEditLexTokensDef::operator=
const CXTPSyntaxEditLexTokensDef & operator=(const CXTPSyntaxEditLexTokensDef &rSrc)
Assignment operator for class.
CXTPSyntaxEditLexTokensDef::~CXTPSyntaxEditLexTokensDef
virtual ~CXTPSyntaxEditLexTokensDef()
Object destructor.
CXTPSyntaxEditLexTokensDef::m_arEndSeps
CStringArray m_arEndSeps
List of end separators.
Definition XTPSyntaxEditLexParser.h:150
CXTPSyntaxEditLexVariant
CXTPSyntaxEditLexVariant provides functionality to manipulate Lexical Analyzer's related variant type...
Definition XTPSyntaxEditLexClass.h:230
CXTPSyntaxEditTextRegion
This class is designed to store the coordinates of a text region.
Definition XTPSyntaxEditLexParser.h:88
CXTPSyntaxEditTextRegion::m_posEnd
XTP_EDIT_LINECOL m_posEnd
End position in document coordinates.
Definition XTPSyntaxEditLexParser.h:91
CXTPSyntaxEditTextRegion::m_posStart
XTP_EDIT_LINECOL m_posStart
Start position in document coordinates.
Definition XTPSyntaxEditLexParser.h:90
CXTPSyntaxEditTextRegion::Clear
void Clear()
Clears coordinates.
CXTPSyntaxEditTextRegion::Set
void Set(const XTP_EDIT_LINECOL *pLCStart, const XTP_EDIT_LINECOL *pLCEnd)
Sets coordinates.
XTP_EDIT_COLORVALUES
Stores the colors for different phrases.
Definition XTPSyntaxEditStruct.h:197
XTP_EDIT_LINECOL
The XTP_EDIT_LINECOL structure represents the coordinates of text items on the displaying context in ...
Definition XTPSyntaxEditStruct.h:54
XTP_EDIT_LINECOL::MAXPOS
static const XTP_EDIT_LINECOL MAXPOS
Maximum position value.
Definition XTPSyntaxEditStruct.h:58
XTP_EDIT_LINECOL::GetXLC
DWORD GetXLC() const
Gets the coordinates in packed form.
XTP_EDIT_LINECOL::MINPOS
static const XTP_EDIT_LINECOL MINPOS
Minimum position value.
Definition XTPSyntaxEditStruct.h:59
XTP_EDIT_TEXTBLOCK
Summary The XTP_EDIT_TEXTBLOCK structure stores the text blocks after parsing.
Definition XTPSyntaxEditStruct.h:286


Toolkit Pro: Member List

CXTPShortcutBarPaneItem Member List

This is the complete list of members for CXTPShortcutBarPaneItem, including all inherited members.

CXTPShortcutBarPaneItem(LPCTSTR lpszCaption, CWnd *pWnd, int nHeight) | CXTPShortcutBarPaneItem | protected
GetCaption() const | CXTPShortcutBarPaneItem |
GetCaptionRect() const | CXTPShortcutBarPaneItem |
GetHeight() const | CXTPShortcutBarPaneItem |
IsExpandable() const | CXTPShortcutBarPaneItem |
IsExpanded() const | CXTPShortcutBarPaneItem |
IsHighlighted() const | CXTPShortcutBarPaneItem |
m_bExpandable | CXTPShortcutBarPaneItem | protected
m_bExpanded | CXTPShortcutBarPaneItem | protected
m_bShowCaption | CXTPShortcutBarPaneItem | protected
m_nHeight | CXTPShortcutBarPaneItem | protected
m_pPane | CXTPShortcutBarPaneItem | protected
m_pWndClient | CXTPShortcutBarPaneItem | protected
m_rcCaption | CXTPShortcutBarPaneItem | protected
m_rcClient | CXTPShortcutBarPaneItem | protected
m_strCaption | CXTPShortcutBarPaneItem | protected
SetCaption(LPCTSTR lpszCaption) | CXTPShortcutBarPaneItem |
SetExpandable(BOOL bExpandable) | CXTPShortcutBarPaneItem |
SetExpanded(BOOL bExpanded) | CXTPShortcutBarPaneItem |
SetHeight(int nHeight) | CXTPShortcutBarPaneItem |
ShowCaption(BOOL bShowCaption) | CXTPShortcutBarPaneItem |


Toolkit Pro: XTPGridRecordItemIcon.h Source File

  • Source
  • GridControl
  • ItemTypes
XTPGridRecordItemIcon.h
Go to the documentation of this file.
1
23#if !defined(__XTPGRIDRECORDITEMICON_H__)
24# define __XTPGRIDRECORDITEMICON_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class _XTP_EXT_CLASS CXTPGridRecordItemIcon : public CXTPGridRecordItem
34{
36 DECLARE_SERIAL(CXTPGridRecordItemIcon)
38public:
43 CXTPGridRecordItemIcon();
44
53 virtual int Draw(XTP_GRIDRECORDITEM_DRAWARGS* pDrawArgs);
54
63 virtual void OnDrawCaption(XTP_GRIDRECORDITEM_DRAWARGS* pDrawArgs,
64 XTP_GRIDRECORDITEM_METRICS* pMetrics);
65
74 virtual void GetCaptionRect(XTP_GRIDRECORDITEM_ARGS* pDrawArgs, CRect& rcItem);
75
83 void OnEditChanged(XTP_GRIDRECORDITEM_ARGS* pItemArgs, LPCTSTR szText);
84};
85
86# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
88#endif // !defined(__XTPGRIDRECORDITEMICON_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPGridRecordItem
Class for working with single list cell.
Definition XTPGridRecordItem.h:600
CXTPGridRecordItem::OnEditChanged
virtual void OnEditChanged(XTP_GRIDRECORDITEM_ARGS *pItemArgs, LPCTSTR szText)
This method is called when the value of the in-place edit control is changed.
CXTPGridRecordItem::GetCaptionRect
virtual void GetCaptionRect(XTP_GRIDRECORDITEM_ARGS *pDrawArgs, CRect &rcItem)
Retrieves the caption text bounding rectangle.
CXTPGridRecordItem::Draw
virtual int Draw(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs)
Should be overridden by descendants for drawing itself.
CXTPGridRecordItem::OnDrawCaption
virtual void OnDrawCaption(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics)
Should be overridden by descendants for drawing itself.
XTP_GRIDRECORDITEM_ARGS
Basic set of parameters transferred to item handlers.
Definition XTPGridRecordItem.h:69
XTP_GRIDRECORDITEM_DRAWARGS
A set of parameters transferred to the Draw item handler.
Definition XTPGridRecordItem.h:125
XTP_GRIDRECORDITEM_METRICS
Record item drawing metrics.
Definition XTPGridRecordItem.h:356


Toolkit Pro: Member List

CXTPBrowseEdit Member List

This is the complete list of members for CXTPBrowseEdit, including all inherited members.

AdjustBuddyRect(CWnd *pBuddy, CRect &rcUpDown, int nAlignment) | CXTPEdit |
CanOverType() const | CXTPMaskEditT< CEdit > | inline
CanPaste() | CXTPEdit | virtual
CanUseMask() const | CXTPMaskEditT< CEdit > | inline
CheckChar(TCHAR &nChar, int nPos) | CXTPMaskEditT< CEdit > | inlinevirtual
ChooseDirectory() | CXTPBrowseEdit | virtual
ChooseFile() | CXTPBrowseEdit | virtual
ConvertUnicodeAlpha(TCHAR nChar, BOOL bUpperCase) const | CXTPMaskEditT< CEdit > | inline
CopyToClipboard(const CString &strText) | CXTPMaskEditT< CEdit > | inline
CXTPBrowseEdit() | CXTPBrowseEdit |
CXTPEdit() | CXTPEdit |
CXTPMaskEditT() | CXTPMaskEditT< CEdit > | inline
DeleteCharAt(int iPos) | CXTPMaskEditT< CEdit > | inline
DrawBuddyBorders(CWnd *pBuddy, CDC *pDC, CRect rc, int nAlignment) | CXTPEdit |
GetBrowseButton() | CXTPBrowseEdit |
GetClientBrush(CDC *pDC) | CXTPEdit | protected
GetFlatStyle() const | CXTPEdit |
GetMaskedText(int nStartPos=0, int nEndPos=-1) const | CXTPMaskEditT< CEdit > | inline
GetPromptChar() const | CXTPMaskEditT< CEdit > | inline
GetPromptString(int nLength) const | CXTPMaskEditT< CEdit > | inline
GetTheme() | CXTPEdit |
GetThemeID() | CXTPEdit |
GetUseVisualStyle() const | CXTPEdit |
HasSelection() const | CXTPEdit |
Initialize(CWnd *pParentWnd, DWORD dwBStyle, UINT nMenu=0, int nSubMenuIndx=0) | CXTPBrowseEdit | virtual
Initialize(CWnd *pParentWnd) | CXTPBrowseEdit | virtual
InsertCharAt(int iPos, TCHAR nChar) | CXTPMaskEditT< CEdit > | inline
IsBrowsing() | CXTPBrowseEdit |
IsFlatStyle() const | CXTPEdit |
IsFocused() const | CXTPEdit |
IsHighlighted() const | CXTPEdit |
IsModified() const | CXTPMaskEditT< CEdit > | inline
IsPatternValid() | CXTPEdit |
m_bBrowsing | CXTPBrowseEdit | protected
m_bFocused | CXTPEdit | protected
m_bHighlighted | CXTPEdit | protected
m_bModified | CXTPMaskEditT< CEdit > | protected
m_bOpenFileDialog | CXTPBrowseEdit | protected
m_bOverType | CXTPMaskEditT< CEdit > | protected
m_bPreSubclassInit | CXTPEdit | protected
m_bRedo | CXTPMaskEditT< CEdit > | protected
m_bShowBorder | CXTPEdit | protected
m_btnBrowse | CXTPBrowseEdit | protected
m_bUpdateUndo | CXTPMaskEditT< CEdit > | protected
m_bUseMask | CXTPMaskEditT< CEdit > | protected
m_chPrompt | CXTPMaskEditT< CEdit > | protected
m_dwBStyle | CXTPBrowseEdit | protected
m_dwFlags | CXTPBrowseEdit | protected
m_nDefaultGap | CXTPBrowseEdit | static
m_nEndChar | CXTPMaskEditT< CEdit > | protected
m_nGap | CXTPBrowseEdit | protected
m_nMenu | CXTPBrowseEdit | protected
m_nStartChar | CXTPMaskEditT< CEdit > | protected
m_nSubMenuIndx | CXTPBrowseEdit | protected
m_pFileDialog | CXTPBrowseEdit | protected
m_pRegExp | CXTPEdit | protected
m_pTheme | CXTPEdit | protected
m_strDefault | CXTPMaskEditT< CEdit > | protected
m_strDefExt | CXTPBrowseEdit | protected
m_strFileName | CXTPBrowseEdit | protected
m_strFilter | CXTPBrowseEdit | protected
m_strInitialDir | CXTPBrowseEdit | protected
m_strLiteral | CXTPMaskEditT< CEdit > | protected
m_strMask | CXTPMaskEditT< CEdit > | protected
m_strRedoBuffer | CXTPMaskEditT< CEdit > | protected
m_strTitle | CXTPBrowseEdit | protected
m_strUndoBuffer | CXTPMaskEditT< CEdit > | protected
m_strWindowText | CXTPMaskEditT< CEdit > | protected
MaskClear() | CXTPMaskEditT< CEdit > | inline
MaskCopy() | CXTPMaskEditT< CEdit > | inline
MaskCut() | CXTPMaskEditT< CEdit > | inline
MaskDeleteSel() | CXTPMaskEditT< CEdit > | inline
MaskPaste() | CXTPMaskEditT< CEdit > | inline
MaskReplaceSel(LPCTSTR lpszNewText) | CXTPMaskEditT< CEdit > | inline
MaskSelectAll() | CXTPMaskEditT< CEdit > | inline
MaskUndo() | CXTPMaskEditT< CEdit > | inline
OnBrowse() | CXTPBrowseEdit | virtual
OnCommand(WPARAM wParam, LPARAM lParam) | CXTPMaskEditT< CEdit > | inlineprotectedvirtual
PopupMenu() | CXTPBrowseEdit | virtual
PosInRange(int iPos) const | CXTPMaskEditT< CEdit > | inline
PositionBrowseButton() | CXTPBrowseEdit | virtual
PreTranslateMessage(MSG *pMsg) | CXTPMaskEditT< CEdit > | inlinevirtual
ProcessMask(TCHAR &nChar, int nEndPos) | CXTPMaskEditT< CEdit > | inlinevirtual
RedrawEdit() | CXTPEdit | protected
RedrawFocusedFrame() | CXTPEdit | protected
RefreshMetrics() | CXTPEdit | virtual
SetDlgDefExt(LPCTSTR lpszDefExt=NULL) | CXTPBrowseEdit |
SetDlgFileName(LPCTSTR lpszFileName=NULL) | CXTPBrowseEdit |
SetDlgFilter(LPCTSTR lpszFilter=NULL) | CXTPBrowseEdit |
SetDlgInitialDir(LPCTSTR lpszInitialDir) | CXTPBrowseEdit |
SetDlgOpenFile(BOOL bOpenFileDialog=TRUE) | CXTPBrowseEdit | virtual
SetDlgStyle(DWORD dwFlags=OFN_HIDEREADONLY|OFN_OVERWRITEPROMPT) | CXTPBrowseEdit | virtual
SetDlgTitle(LPCTSTR lpszTitle=NULL) | CXTPBrowseEdit |
SetEditMask(LPCTSTR lpszMask, LPCTSTR lpszLiteral, LPCTSTR lpszDefault=NULL) | CXTPEdit | virtual
SetFileDialog(CFileDialog *pFileDialog) | CXTPBrowseEdit | virtual
SetFlatStyle(BOOL bFlatStyle=TRUE) | CXTPEdit |
SetGap(int nGap) | CXTPBrowseEdit |
SetMaskedText(LPCTSTR lpszMaskedText, int iPos=0, BOOL bUpdateWindow=TRUE) | CXTPMaskEditT< CEdit > | inline
SetOverType(BOOL bOverType) | CXTPMaskEditT< CEdit > | inline
SetPattern(LPCTSTR lpszPattern) | CXTPEdit |
SetPromptChar(TCHAR ch, BOOL bAutoReplace=TRUE) | CXTPMaskEditT< CEdit > | inline
SetTheme(XTPControlTheme nTheme) | CXTPEdit | virtual
SetUseMask(BOOL bUseMask) | CXTPMaskEditT< CEdit > | inline
SetUseVisualStyle(BOOL bUseVisualStyle=TRUE) | CXTPEdit |
ShowBorder() const | CXTPEdit |
ShowThemedBorder(BOOL bShowThemedBorder) | CXTPEdit |
~CXTPBrowseEdit() | CXTPBrowseEdit | virtual
~CXTPEdit() | CXTPEdit | virtual


Toolkit Pro: XTPDockingPanePanelColorSet2022.h Source File

  • Source
  • DockingPane
  • TabColorSets
XTPDockingPanePanelColorSet2022.h
Go to the documentation of this file.
1
23#if !defined(__XTPDOCKINGPANEPANELCOLORSET2022_H__)
24# define __XTPDOCKINGPANEPANELCOLORSET2022_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPDockingPanePanelColorSet2022 : public CXTPDockingPanePanelColorSet2012
39{
40public:
45 CXTPDockingPanePanelColorSet2022();
46
52 virtual void RefreshMetrics();
53};
54
55# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
57#endif // !defined(__XTPDOCKINGPANEPANELCOLORSET2022_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPDockingPanePanelColorSet2012
Helper class used to initialize default colors for a theme from an .INI resource and handle drawing r...
Definition XTPDockingPanePanelColorSet2012.h:39
CXTPDockingPanePanelColorSet2022
Helper class used to initialize default colors for a theme from an .INI resource and handle drawing r...
Definition XTPDockingPanePanelColorSet2022.h:39
CXTPDockingPanePanelColorSet2022::CXTPDockingPanePanelColorSet2022
CXTPDockingPanePanelColorSet2022()
Default class constructor.
CXTPDockingPanePanelColorSet2022::RefreshMetrics
virtual void RefreshMetrics()
This member function is used to initialize default colors for a theme from an .INI resource.


Toolkit Pro: Member List

CXTPControlTabWorkspace Member List

This is the complete list of members for CXTPControlTabWorkspace, including all inherited members.

AssignDocTemplate(UINT nIDResource) | CXTPControl |
ClickToolBarButton(CRect rcActiveRect=CRect(0, 0, 0, 0)) | CXTPControl | protected
Compare(CXTPControl *pOther) | CXTPControl | virtual
Copy(CXTPControl *pControl, BOOL bRecursive=FALSE) | CXTPControlButton | protectedvirtual
CustomizeStartDrag(CPoint point) | CXTPControl | protectedvirtual
CustomizeStartResize(CPoint point) | CXTPControl | protectedvirtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPControl() | CXTPControl | protected
CXTPControlButton() | CXTPControlButton |
CXTPControlTabWorkspace() | CXTPControlTabWorkspace |
DelayLayoutParent() | CXTPControl |
DelayRedrawParent() | CXTPControl |
DoCustomDragOver(CXTPCommandBar *pCommandBar, CPoint point, DROPEFFECT &dropEffect) | CXTPControl | protectedvirtual
DoPropExchange(CXTPPropExchange *pPX) | CXTPControlButton | virtual
Draw(CDC *pDC) | CXTPControlTabWorkspace | protectedvirtual
ExcludeDocTemplate(UINT nIDResource) | CXTPControl |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
FromUI(CCmdUI *pCmdUI) | CXTPControl | static
GenerateCommandBarList(DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam) | CXTPControl | protectedvirtual
GetAction() const | CXTPControl |
GetBeginGroup() const | CXTPControl |
GetButtonSize() const | CXTPControl | virtual
GetCaption() const | CXTPControl | virtual
GetCategory() const | CXTPControl |
GetChecked() const | CXTPControl |
GetCloseSubMenuOnClick() const | CXTPControl |
GetCommandBar() const | CXTPControl | virtual
GetControls() const | CXTPControl |
GetCustomizeMinHeight() const | CXTPControl | protectedvirtual
GetCustomizeMinWidth() const | CXTPControl | protectedvirtual
GetCustomShortcutText() const | CXTPControl |
GetDescription() const | CXTPControl | virtual
GetEnabled() const | CXTPControl |
GetExecuteOnPressInterval() const | CXTPControl |
GetExpanded() const | CXTPControl |
GetFlags() const | CXTPControl |
GetHeight() const | CXTPControl |
GetHelpId() const | CXTPControl |
GetHideFlags() const | CXTPControl |
GetIconId() const | CXTPControl |
GetIconSize() const | CXTPControl | virtual
GetID() const | CXTPControl |
GetImage(int nWidth=16) const | CXTPControl | virtual
GetImageManager() const | CXTPControl |
GetIndex() const | CXTPControl |
GetKeyboardTip() const | CXTPControl |
GetPaintManager() const | CXTPControlTabWorkspace |
GetParameter() const | CXTPControl |
GetParent() const | CXTPControl |
GetPopuped() const | CXTPControl | virtual
GetPosition() const | CXTPControlTabWorkspace |
GetPressed() const | CXTPControl | virtual
GetRect() const | CXTPControl |
GetRibbonGroup() const | CXTPControl |
GetRowRect() const | CXTPControl |
GetSelected() const | CXTPControl | virtual
GetShortcutText() const | CXTPControl |
GetSize(CDC *pDC) | CXTPControlTabWorkspace | protectedvirtual
GetStyle() const | CXTPControl |
GetStyleEx() const | CXTPControlButton |
GetTag() const | CXTPControl |
GetTooltip() const | CXTPControl | virtual
GetType() const | CXTPControl |
GetWidth() const | CXTPControl |
GetWindow() const | CXTPControlTabWorkspace | virtual
GetWrap() const | CXTPControl |
HasDwmCompositedRect() const | CXTPControl |
IsCaptionVisible() const | CXTPControl | virtual
IsCursorOver() const | CXTPControl |
IsCustomizeMode() const | CXTPControl | protected
IsCustomizeMovable() const | CXTPControl | virtual
IsCustomizeResizeAllow() const | CXTPControl | protectedvirtual
IsFocusable() const | CXTPControl | protectedvirtual
IsFocused() const | CXTPControl | virtual
IsItemDefault() const | CXTPControl |
IsLayoutChanged() | CXTPControl | protected
IsLayoutRTL() const | CXTPControl | protected
IsOnQuickAccess() const | CXTPControl |
IsTemporary() const | CXTPControl |
IsTransparent() const | CXTPControl | inlinevirtual
IsVisible(DWORD dwSkipFlags=0) const | CXTPControl | virtual
m_bBeginGroup | CXTPControl | protected
m_bChecked | CXTPControl | protected
m_bCloseSubMenuOnClick | CXTPControl | protected
m_bDefaultItem | CXTPControl | protected
m_bEnabled | CXTPControl | protected
m_bExpanded | CXTPControl | protected
m_bForceRecalc | CXTPControlTabWorkspace | protected
m_bLayoutRTL | CXTPControl | protected
m_bOnQuickAccess | CXTPControl | protected
m_bPressed | CXTPControl | protected
m_bSelected | CXTPControl | protected
m_bTemporary | CXTPControl | protected
m_buttonCustomStyle | CXTPControl | protected
m_buttonRibbonStyle | CXTPControl | protected
m_buttonStyle | CXTPControl | protected
m_buttonStyleEx | CXTPControlButton | protected
m_bWrap | CXTPControl | protected
m_controlType | CXTPControl | protected
m_dwFlags | CXTPControl | protected
m_dwHideFlags | CXTPControl | protected
m_mapDocTemplatesAssigned | CXTPControl | protected
m_mapDocTemplatesExcluded | CXTPControl | protected
m_nCustomIconId | CXTPControl | protected
m_nExecuteOnPressInterval | CXTPControl | protected
m_nHeight | CXTPControl | protected
m_nHelpId | CXTPControl | protected
m_nIconId | CXTPControl | protected
m_nId | CXTPControl | protected
m_nIndex | CXTPControl | protected
m_nTag | CXTPControl | protected
m_nWidth | CXTPControl | protected
m_pAction | CXTPControl | protected
m_pControls | CXTPControl | protected
m_pParent | CXTPControl | protected
m_pRibbonGroup | CXTPControl | protected
m_rcControl | CXTPControl | protected
m_rcRow | CXTPControl | protected
m_strCaption | CXTPControl | protected
m_strCategory | CXTPControl | protected
m_strCustomCaption | CXTPControl | protected
m_strDescriptionText | CXTPControl | protected
m_strKeyboardTip | CXTPControl | protected
m_strParameter | CXTPControl | protected
m_strShortcutText | CXTPControl | protected
m_strShortcutTextAuto | CXTPControl | protected
m_strTooltipText | CXTPControl | protected
m_szIcon | CXTPControl | protected
NotifySite(UINT code) | CXTPControl |
NotifySite(UINT code, NMXTPCONTROL *pNM) | CXTPControl |
NotifySite(CWnd *pSite, UINT code, NMXTPCONTROL *pNM) | CXTPControl |
OnActionChanged(int nProperty) | CXTPControl | protectedvirtual
OnActionChanging(int nProperty) | CXTPControl | protectedvirtual
OnCalcDynamicSize(DWORD dwMode) | CXTPControl | virtual
OnCaptionChanged() | CXTPControl | protectedvirtual
OnClick(BOOL bKeyboard=FALSE, CPoint pt=CPoint(0, 0)) | CXTPControlTabWorkspace | protectedvirtual
OnCustomizeDragOver(CXTPControl *pDataObject, CPoint point, DROPEFFECT &dropEffect) | CXTPControl | protectedvirtual
OnCustomizeMouseMove(CPoint point) | CXTPControl | protected
OnEnabledChanged() | CXTPControl | virtual
OnExecute() | CXTPControl | virtual
OnHookKeyDown(UINT nChar, LPARAM lParam) | CXTPControl | protectedvirtual
OnHookMouseWheel(UINT nFlags, short zDelta, CPoint point) | CXTPControl | protectedvirtual
OnIdleUpdate() | CXTPControl | protectedvirtual
OnLButtonDblClk(CPoint point) | CXTPControl | protectedvirtual
OnLButtonDown(CPoint point) | CXTPControl | protectedvirtual
OnLButtonUp(CPoint point) | CXTPControlButton | protectedvirtual
OnMouseHover() | CXTPControl | protectedvirtual
OnMouseMove(CPoint point) | CXTPControlTabWorkspace | protectedvirtual
OnRButtonDown(CPoint point) | CXTPControl | protectedvirtual
OnRButtonUp(CPoint point) | CXTPControl | protectedvirtual
OnRecalcLayout() | CXTPControlTabWorkspace | virtual
OnRemoved() | CXTPControlTabWorkspace | virtual
OnSetPopup(BOOL bPopup) | CXTPControl | protectedvirtual
OnSetSelected(int bSelected) | CXTPControl | protectedvirtual
OnThemeChanged() | CXTPControl | virtual
OnToolHitTest(CPoint point, TOOLINFO *pTI) const | CXTPControlTabWorkspace | protectedvirtual
OnUnderlineActivate() | CXTPControl | virtual
RedrawControl(LPCRECT lpRect, BOOL bAnimate) | CXTPControlTabWorkspace | virtual
RedrawParent(BOOL bAnimate=TRUE) | CXTPControl |
Reset() | CXTPControl |
RestoreCommandBarList(CXTPCommandBarList *pCommandBarList) | CXTPControl | protectedvirtual
ScreenToClient(CPoint *point) | CXTPControl | protected
SetAction(CXTPControlAction *pAction) | CXTPControl | virtual
SetBeginGroup(BOOL bBeginGroup) | CXTPControl | virtual
SetCaption(LPCTSTR lpszCaption) | CXTPControl |
SetCaption(UINT nIDCaption) | CXTPControl |
SetCategory(LPCTSTR lpszCategory) | CXTPControl |
SetChecked(BOOL bChecked) | CXTPControl | virtual
SetCloseSubMenuOnClick(BOOL bCloseOnClick) | CXTPControl |
SetCustomIcon(HICON hIcon) | CXTPControl |
SetCustomShortcutText(LPCTSTR lpszCustomShortcutText) | CXTPControl |
SetDescription(LPCTSTR lpszDescription) | CXTPControl |
SetEnabled(BOOL bEnabled) | CXTPControl | virtual
SetExecuteOnPressInterval(int nExecuteOnPressInterval) | CXTPControl |
SetExpanded(BOOL bExpanded) | CXTPControl | protected
SetFlags(DWORD dwFlags) | CXTPControl |
SetFocused(BOOL bFocused) | CXTPControl | virtual
SetHeight(int nHeight) | CXTPControl | virtual
SetHelpId(int nId) | CXTPControl |
SetHideFlag(XTPControlHideFlags dwFlag, BOOL bSet) | CXTPControl |
SetHideFlags(DWORD dwFlags) | CXTPControl | virtual
SetHideWrap(BOOL bHide) | CXTPControl |
SetIconId(int nId) | CXTPControl |
SetIconSize(CSize szIcon) | CXTPControl |
SetID(int nId) | CXTPControl |
SetIndex(int nIndex) | CXTPControl | inlineprotected
SetItemDefault(BOOL bDefault) | CXTPControl |
SetKeyboardTip(LPCTSTR lpszKeyboardTip) | CXTPControl |
SetOnQuickAccess(BOOL bOnQuicAccess=FALSE) | CXTPControl |
SetParameter(LPCTSTR lpszParameter) | CXTPControl |
SetParent(CXTPCommandBar *pParent) | CXTPControl | inlineprotectedvirtual
SetPressed(BOOL bPressed) | CXTPControl |
SetPrompt(LPCTSTR lpszPrompt) | CXTPControl |
SetRect(CRect rcControl) | CXTPControlTabWorkspace | protectedvirtual
SetRowRect(CRect rcRow) | CXTPControl |
SetShortcutText(LPCTSTR lpszShortcutText) | CXTPControl |
SetStyle(XTPButtonStyle buttonStyle) | CXTPControl |
SetStyleEx(XTPButtonStyle buttonStyle) | CXTPControlButton |
SetTag(DWORD_PTR dwTag) | CXTPControl |
SetTooltip(LPCTSTR lpszTooltip) | CXTPControl |
SetVisible(BOOL bVisible) | CXTPControl |
SetWidth(int nWidth) | CXTPControl | virtual
SetWrap(BOOL bWrap) | CXTPControl |
~CXTPControl() | CXTPControl | protectedvirtual
~CXTPControlButton() | CXTPControlButton | virtual
~CXTPControlTabWorkspace() | CXTPControlTabWorkspace |


Toolkit Pro: Member List

CXTPResourceManagerXML Member List

This is the complete list of members for CXTPResourceManagerXML, including all inherited members.

Close() | CXTPResourceManagerXML | virtual
CreateIconFromResource(HMODULE hModule, LPCTSTR lpszID, CSize iconSize) | CXTPResourceManager | virtual
CXTPResourceManager() | CXTPResourceManager |
CXTPResourceManagerXML(LPCTSTR lpszFileName) | CXTPResourceManagerXML |
CXTPResourceManagerXML(CXTPPropExchangeXMLNode *pResourceRoot) | CXTPResourceManagerXML |
FindResource(HMODULE &hModule, LPCTSTR lpName, LPCTSTR lpType) | CXTPResourceManager |
GetActiveLCID() | CXTPResourceManager |
GetFontCharset() const | CXTPResourceManager |
GetResourceHandle() const | CXTPResourceManager |
GetResourceLanguage(HMODULE hResModule) | CXTPResourceManager | static
GetResourcesLangID() | CXTPResourceManager | virtual
IsIntResource(LPCTSTR lpName, BOOL bTryParse=FALSE) | CXTPResourceManager | static
LoadBitmap(CBitmap *pBitmap, UINT nIDResource) | CXTPResourceManager | virtual
LoadBitmap(CBitmap *pBitmap, LPCTSTR lpszResource) | CXTPResourceManager | virtual
LoadCursor(UINT nIDResource) | CXTPResourceManager | virtual
LoadDialogTemplate(UINT nIDResource) | CXTPResourceManagerXML | virtual
LoadDialogTemplate2(LPCTSTR pszTemplate) | CXTPResourceManager | virtual
LoadHTML(CString *pText, UINT nIDResource) | CXTPResourceManager | virtual
LoadHTML(CString *pText, LPCTSTR pszResource) | CXTPResourceManager | virtual
LoadIcon(LPCTSTR lpszID, CSize iconSize) | CXTPResourceManager | virtual
LoadIcon(int nID, CSize iconSize) | CXTPResourceManager | virtual
LoadMenu(CMenu *lpMenu, UINT nIDResource) | CXTPResourceManagerXML | virtual
LoadString(CString *pString, UINT nIDResource) | CXTPResourceManagerXML | virtual
LoadString(UINT nIDResource, BOOL *pbError=NULL) | CXTPResourceManagerXML | virtual
LoadSVG(CString &svg, UINT nIDResource) | CXTPResourceManager | virtual
LoadToolBar(CToolBar *pToolBar, UINT nIDResource) | CXTPResourceManager | virtual
LoadXAML(CString &xaml, UINT nIDResource) | CXTPResourceManager | virtual
m_bValid | CXTPResourceManager | protected
m_hModXTResource | CXTPResourceManager | protectedstatic
m_hResourceFile | CXTPResourceManager | protected
m_managerInstance | CXTPResourceManager | static
m_pLanguageInfo | CXTPResourceManager | protected
MakeIntResource(LPCTSTR lpName) | CXTPResourceManager | static
OnLoadingFailed() | CXTPResourceManager | protected
SetFontCharset(BYTE nFontCharset) | CXTPResourceManager |
SetResourceFile(const CString &strResourceFile) | CXTPResourceManager |
SetResourceFontCharset(BOOL bResourceCharset=TRUE) | CXTPResourceManager |
SetResourceHandle(HMODULE hModRes) | CXTPResourceManager |
SetResourceManager(CXTPResourceManager *pResourceManager) | CXTPResourceManager |
ShowMessageBox(UINT nIDPrompt, UINT nType=MB_OK) | CXTPResourceManager |
ShowMessageBox(LPCTSTR lpszText, UINT nType=MB_OK) | CXTPResourceManager |
UpdateResourcesLangID() | CXTPResourceManagerXML | protectedvirtual
~CXTPResourceManager() | CXTPResourceManager |
~CXTPResourceManagerXML() | CXTPResourceManagerXML |


Toolkit Pro: XTPRibbonTab.h Source File

  • Source
  • Ribbon
XTPRibbonTab.h
Go to the documentation of this file.
1
23#if !defined(__XTPRIBBONTAB_H__)
24# define __XTPRIBBONTAB_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPRibbonGroups;
34class CXTPRibbonBar;
35class CXTPRibbonGroup;
36class CXTPRibbonTab;
37class CXTPCommandBar;
38class CXTPPropExchange;
39
52enum XTPRibbonTabContextColor
53{
54 xtpRibbonTabContextColorNone,
55 xtpRibbonTabContextColorBlue,
56 xtpRibbonTabContextColorYellow,
57 xtpRibbonTabContextColorGreen,
58 xtpRibbonTabContextColorRed,
59 xtpRibbonTabContextColorPurple,
60 xtpRibbonTabContextColorCyan,
61 xtpRibbonTabContextColorOrange
62};
63
66// Context headers internal classes
67
68class _XTP_EXT_CLASS CXTPRibbonTabContextHeader
69{
70public:
71 CXTPRibbonTabContextHeader(CXTPRibbonTab* pFirstTab);
72
73public:
74 CXTPRibbonTab* m_pFirstTab;
75 CXTPRibbonTab* m_pLastTab;
76 CString m_strCaption;
77 XTPRibbonTabContextColor m_color;
78 CRect m_rcRect;
79};
80
81class _XTP_EXT_CLASS CXTPRibbonTabContextHeaders
82{
83public:
84 CXTPRibbonTabContextHeaders();
85 ~CXTPRibbonTabContextHeaders();
86
87public:
88 void RemoveAll();
89 int GetCount() const;
90 void Add(CXTPRibbonTabContextHeader* pHeader);
91 CXTPRibbonTabContextHeader* GetHeader(int nIndex) const;
92 CXTPRibbonTabContextHeader* HitTest(CPoint pt) const;
93
94protected:
95 CArray<CXTPRibbonTabContextHeader*, CXTPRibbonTabContextHeader*> m_arrHeaders;
96};
115class _XTP_EXT_CLASS CXTPRibbonTab : public CXTPTabManagerItem
116{
118 DECLARE_SERIAL(CXTPRibbonTab)
120public:
125 CXTPRibbonTab();
126
131 virtual ~CXTPRibbonTab();
132
133public:
154 CXTPRibbonGroups* GetGroups() const;
155
165 CXTPRibbonBar* GetRibbonBar() const;
166
173 CXTPCommandBar* GetParent() const;
174
184 virtual CString GetCaption() const;
185
191 virtual void Copy(CXTPRibbonTab* pRibbonTab);
192
205 CXTPRibbonGroup* AddGroup(LPCTSTR lpszCaption);
206
218 CXTPRibbonGroup* AddGroup(int nID);
219
229 CXTPRibbonGroup* FindGroup(int nId) const;
230
240 XTPRibbonTabContextColor GetContextColor() const;
241
250 void SetContextColor(XTPRibbonTabContextColor color);
251
260 CString GetContextCaption() const;
261
269 void SetContextCaption(LPCTSTR lpszContextCaption);
270
279 CString GetCustomizeCaption() const;
280
288 void SetCustomizeCaption(LPCTSTR lpszCustomizeCaption);
289
297 void SetCustomizeCaption(UINT nCustomizeCaption);
298
307 void SetContextTab(XTPRibbonTabContextColor color, int nContextID);
308
317 void SetContextTab(XTPRibbonTabContextColor color, LPCTSTR lpszContextCaption = NULL);
318
329 int GetID() const;
330
338 void SetID(int nId);
339
346 CXTPRibbonTabContextHeader* GetContextHeader() const;
347
355 virtual void SetVisible(BOOL bVisible);
356
362 virtual void DoPropExchange(CXTPPropExchange* pPX);
363
369 void SetKeyboardTip(LPCTSTR lpszKeyboardTip);
370
377 CString GetKeyboardTip() const;
378
379protected:
384 void OnRemoved();
385
400 BOOL OnCmdMsg(UINT nID, int nCode, void* pExtra, AFX_CMDHANDLERINFO* pHandlerInfo);
401
402# ifdef _XTP_COMMANDBARS_ACTIVEX
405 LPDISPATCH OleGetRibbonBar();
406 LPDISPATCH OleGetGroups();
407
408 DECLARE_DISPATCH_MAP()
409 DECLARE_OLETYPELIB_EX(CXTPRibbonTab);
410 DECLARE_INTERFACE_MAP()
411 void OleGetRect(long* pLeft, long* pTop, long* pRight, long* pBottom);
412
414# endif
415
416protected:
417 CXTPRibbonGroups* m_pGroups;
419 CXTPRibbonBar* m_pRibbonBar;
421 CXTPCommandBar* m_pParent;
422 int m_nId;
423 XTPRibbonTabContextColor m_nContextColor;
424 CString m_strContextCaption;
425 CString m_strCustomizeCaption;
427 CXTPRibbonTabContextHeader* m_pContextHeader;
428 CString m_strKeyboardTip;
430 friend class CXTPRibbonBar;
431 friend class CXTPRibbonTabContextHeader;
432 friend class CXTPRibbonTabPopupToolBar;
433 friend class CXTPRibbonControlTab;
434};
435
436AFX_INLINE void CXTPRibbonTab::SetKeyboardTip(LPCTSTR lpszKeyboardTip)
437{
438 m_strKeyboardTip = lpszKeyboardTip;
439}
440AFX_INLINE CString CXTPRibbonTab::GetKeyboardTip() const
441{
442 return m_strKeyboardTip;
443}
444
445AFX_INLINE CXTPRibbonGroups* CXTPRibbonTab::GetGroups() const
446{
447 return m_pGroups;
448}
449AFX_INLINE void CXTPRibbonTab::SetContextTab(XTPRibbonTabContextColor color,
450 LPCTSTR lpszContextCaption)
451{
452 m_nContextColor = color;
453 m_strContextCaption = lpszContextCaption;
454}
455AFX_INLINE int CXTPRibbonTab::GetID() const
456{
457 return m_nId;
458}
459AFX_INLINE void CXTPRibbonTab::SetID(int nID)
460{
461 m_nId = nID;
462}
463AFX_INLINE CString CXTPRibbonTab::GetContextCaption() const
464{
465 return m_strContextCaption;
466}
467AFX_INLINE CString CXTPRibbonTab::GetCustomizeCaption() const
468{
469 return m_strCustomizeCaption.IsEmpty() ? GetCaption() : m_strCustomizeCaption;
470}
471AFX_INLINE void CXTPRibbonTab::SetCustomizeCaption(LPCTSTR lpszCustomizeCaption)
472{
473 m_strCustomizeCaption = lpszCustomizeCaption;
474}
475AFX_INLINE XTPRibbonTabContextColor CXTPRibbonTab::GetContextColor() const
476{
477 return m_nContextColor;
478}
479AFX_INLINE void CXTPRibbonTab::SetContextColor(XTPRibbonTabContextColor color)
480{
481 m_nContextColor = color;
482}
483AFX_INLINE void CXTPRibbonTab::SetContextCaption(LPCTSTR lpszContextCaption)
484{
485 m_strContextCaption = lpszContextCaption;
486}
487AFX_INLINE CXTPRibbonTabContextHeader* CXTPRibbonTab::GetContextHeader() const
488{
489 return m_pContextHeader;
490}
491AFX_INLINE CXTPCommandBar* CXTPRibbonTab::GetParent() const
492{
493 return m_pParent;
494}
495
496# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
498#endif // !defined(__XTPRIBBONTAB_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPRibbonTabContextColor
XTPRibbonTabContextColor
Ribbon tab context color.
Definition XTPRibbonTab.h:53
xtpRibbonTabContextColorNone
@ xtpRibbonTabContextColorNone
Default color.
Definition XTPRibbonTab.h:54
xtpRibbonTabContextColorOrange
@ xtpRibbonTabContextColorOrange
Orange context color.
Definition XTPRibbonTab.h:61
xtpRibbonTabContextColorGreen
@ xtpRibbonTabContextColorGreen
Green context color.
Definition XTPRibbonTab.h:57
xtpRibbonTabContextColorYellow
@ xtpRibbonTabContextColorYellow
Yellow context color.
Definition XTPRibbonTab.h:56
xtpRibbonTabContextColorPurple
@ xtpRibbonTabContextColorPurple
Purple context color.
Definition XTPRibbonTab.h:59
xtpRibbonTabContextColorCyan
@ xtpRibbonTabContextColorCyan
Cyan context color.
Definition XTPRibbonTab.h:60
xtpRibbonTabContextColorRed
@ xtpRibbonTabContextColorRed
Red context color.
Definition XTPRibbonTab.h:58
xtpRibbonTabContextColorBlue
@ xtpRibbonTabContextColorBlue
Blue context color.
Definition XTPRibbonTab.h:55
CXTPCommandBar
CXTPCommandBar is a CWnd derived class.
Definition XTPCommandBar.h:66
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72
CXTPRibbonBar
CXTPRibbonBar is a CXTPMenuBar derived class.
Definition XTPRibbonBar.h:69
CXTPRibbonControlTab
CXTPRibbonControlTab is a CXTPTabManager derived class.
Definition XTPRibbonControlTab.h:56
CXTPRibbonGroup
Represents a single group that is added to a CXTPRibbonTab.
Definition XTPRibbonGroup.h:70
CXTPRibbonGroups
Represents a collection of CXTPRibbonGroup objects.
Definition XTPRibbonGroups.h:51
CXTPRibbonTab
Represents a tab in the Ribbon Bar.
Definition XTPRibbonTab.h:116
CXTPRibbonTab::m_nContextColor
XTPRibbonTabContextColor m_nContextColor
Context color.
Definition XTPRibbonTab.h:423
CXTPRibbonTab::DoPropExchange
virtual void DoPropExchange(CXTPPropExchange *pPX)
Reads/writes this object from/to an archive.
CXTPRibbonTab::GetContextColor
XTPRibbonTabContextColor GetContextColor() const
Gets the tab color.
Definition XTPRibbonTab.h:475
CXTPRibbonTab::m_strContextCaption
CString m_strContextCaption
Context caption.
Definition XTPRibbonTab.h:424
CXTPRibbonTab::GetGroups
CXTPRibbonGroups * GetGroups() const
Gets the collection of CXTPRibbonGroup objects that have been added to the CXTPRibbonTab.
Definition XTPRibbonTab.h:445
CXTPRibbonTab::AddGroup
CXTPRibbonGroup * AddGroup(int nID)
Adds a CXTPRibbonGroup to a CXTPRibbonTab.
CXTPRibbonTab::m_pParent
CXTPCommandBar * m_pParent
This is the ribbon bar that the tab is displayed in.
Definition XTPRibbonTab.h:421
CXTPRibbonTab::GetID
int GetID() const
Gets the tab's ID.
Definition XTPRibbonTab.h:455
CXTPRibbonTab::CXTPRibbonTab
CXTPRibbonTab()
Constructs a CXTPRibbonTab object.
CXTPRibbonTab::m_strCustomizeCaption
CString m_strCustomizeCaption
Caption used by Customize dialog.
Definition XTPRibbonTab.h:425
CXTPRibbonTab::SetCustomizeCaption
void SetCustomizeCaption(UINT nCustomizeCaption)
Sets the customize dialog specific tab text.
CXTPRibbonTab::m_pRibbonBar
CXTPRibbonBar * m_pRibbonBar
The CXTPRibbonBar object the CXTPRibbonTab belongs to.
Definition XTPRibbonTab.h:419
CXTPRibbonTab::GetParent
CXTPCommandBar * GetParent() const
Gets the parent command bar.
Definition XTPRibbonTab.h:491
CXTPRibbonTab::m_pContextHeader
CXTPRibbonTabContextHeader * m_pContextHeader
Context header.
Definition XTPRibbonTab.h:427
CXTPRibbonTab::SetKeyboardTip
void SetKeyboardTip(LPCTSTR lpszKeyboardTip)
Sets the keyboard tip for the control.
Definition XTPRibbonTab.h:436
CXTPRibbonTab::~CXTPRibbonTab
virtual ~CXTPRibbonTab()
Destroys a CXTPRibbonTab object, handles cleanup and deallocation.
CXTPRibbonTab::SetVisible
virtual void SetVisible(BOOL bVisible)
Call this member to show/hide the tab.
CXTPRibbonTab::SetContextCaption
void SetContextCaption(LPCTSTR lpszContextCaption)
Sets the context tab header text.
Definition XTPRibbonTab.h:483
CXTPRibbonTab::SetID
void SetID(int nId)
Sets the tab's ID.
Definition XTPRibbonTab.h:459
CXTPRibbonTab::GetCaption
virtual CString GetCaption() const
Gets the text caption of the tab.
CXTPRibbonTab::GetRibbonBar
CXTPRibbonBar * GetRibbonBar() const
Gets the CXTPRibbonBar object that the CXTPRibbonTab belongs to.
CXTPRibbonTab::SetCustomizeCaption
void SetCustomizeCaption(LPCTSTR lpszCustomizeCaption)
Sets the customize dialog specific tab text.
Definition XTPRibbonTab.h:471
CXTPRibbonTab::m_strKeyboardTip
CString m_strKeyboardTip
Keyboard tip.
Definition XTPRibbonTab.h:428
CXTPRibbonTab::GetContextHeader
CXTPRibbonTabContextHeader * GetContextHeader() const
Gets the CXTPRibbonTabContextHeader associated with the tab.
Definition XTPRibbonTab.h:487
CXTPRibbonTab::OnRemoved
void OnRemoved()
This method is called before removing a tab from the ribbon tabs collection.
CXTPRibbonTab::AddGroup
CXTPRibbonGroup * AddGroup(LPCTSTR lpszCaption)
Adds a CXTPRibbonGroup to a CXTPRibbonTab.
CXTPRibbonTab::GetCustomizeCaption
CString GetCustomizeCaption() const
Gets the customize dialog specific tab text.
Definition XTPRibbonTab.h:467
CXTPRibbonTab::m_pGroups
CXTPRibbonGroups * m_pGroups
Collection of CXTPRibbonGroup objects that have been added to the CXTPRibbonTab.
Definition XTPRibbonTab.h:417
CXTPRibbonTab::FindGroup
CXTPRibbonGroup * FindGroup(int nId) const
Retrieves a group by its identifier.
CXTPRibbonTab::Copy
virtual void Copy(CXTPRibbonTab *pRibbonTab)
Copies the tab.
CXTPRibbonTab::GetContextCaption
CString GetContextCaption() const
Gets the context tab header text.
Definition XTPRibbonTab.h:463
CXTPRibbonTab::OnCmdMsg
BOOL OnCmdMsg(UINT nID, int nCode, void *pExtra, AFX_CMDHANDLERINFO *pHandlerInfo)
Called by the framework to route and dispatch command messages and to handle the update of command us...
CXTPRibbonTab::GetKeyboardTip
CString GetKeyboardTip() const
Gets the keyboard tip of the control.
Definition XTPRibbonTab.h:440
CXTPRibbonTab::SetContextTab
void SetContextTab(XTPRibbonTabContextColor color, int nContextID)
Sets the context tab color and text.
CXTPRibbonTab::SetContextColor
void SetContextColor(XTPRibbonTabContextColor color)
Sets the tab color.
Definition XTPRibbonTab.h:479
CXTPRibbonTab::m_nId
int m_nId
Identifier of the tab.
Definition XTPRibbonTab.h:422
CXTPRibbonTabPopupToolBar
Implements a pop-up when the Ribbon is in minimzed mode.
Definition XTPRibbonPopups.h:113
CXTPTabManagerItem
CXTPTabManagerItem is the base class for the tabs that appear in the command bars tab workspace,...
Definition XTPTabManagerItem.h:44


Toolkit Pro: Member List

CXTPMarkupPanel Member List

This is the complete list of members for CXTPMarkupPanel, including all inherited members.

ApplyRenderTransform(CXTPMarkupDrawingContext *pContext) | CXTPMarkupUIElement | protectedvirtual
Arrange(CRect rcFinalRect) | CXTPMarkupUIElement |
ArrangeCore(CRect rcFinalRect) | CXTPMarkupUIElement | protectedvirtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPMarkupFrameworkElement() | CXTPMarkupFrameworkElement | protected
CXTPMarkupPanel() | CXTPMarkupPanel | protected
CXTPMarkupUIElement() | CXTPMarkupUIElement | protected
CXTPMarkupVisual() | CXTPMarkupVisual |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAbsoluteVisualOffset() const | CXTPMarkupVisual | protected
GetActualSize() const | CXTPMarkupFrameworkElement |
GetBackground() const | CXTPMarkupPanel |
GetBoundRect() const | CXTPMarkupVisual |
GetChildren() const | CXTPMarkupPanel |
GetClipToBounds() const | CXTPMarkupFrameworkElement |
GetDesiredSize() const | CXTPMarkupUIElement |
GetFinalRect() const | CXTPMarkupUIElement |
GetHeight() const | CXTPMarkupFrameworkElement |
GetHorizontalAlignment() const | CXTPMarkupFrameworkElement |
GetLayoutClip(CRect &rc) const | CXTPMarkupUIElement | protectedvirtual
GetLogicalChild(int nIndex) const | CXTPMarkupVisual | virtual
GetLogicalChildrenCount() const | CXTPMarkupVisual | virtual
GetMargin() const | CXTPMarkupFrameworkElement |
GetMaxHeight() const | CXTPMarkupFrameworkElement |
GetMaxWidth() const | CXTPMarkupFrameworkElement |
GetMinHeight() const | CXTPMarkupFrameworkElement |
GetMinWidth() const | CXTPMarkupFrameworkElement |
GetOpacity() const | CXTPMarkupUIElement | protectedvirtual
GetRenderSize() const | CXTPMarkupVisual |
GetRenderTransform() const | CXTPMarkupUIElement | protected
GetStyle() const | CXTPMarkupFrameworkElement |
GetTag() const | CXTPMarkupFrameworkElement |
GetUpdateRect() const | CXTPMarkupVisual |
GetVerticalAlignment() const | CXTPMarkupFrameworkElement |
GetVisibility() const | CXTPMarkupUIElement |
GetVisualChild(int nIndex) const | CXTPMarkupVisual | virtual
GetVisualChildrenCount() const | CXTPMarkupVisual | virtual
GetVisualOffset() const | CXTPMarkupVisual |
GetVisualParent() const | CXTPMarkupVisual |
GetWidth() const | CXTPMarkupFrameworkElement |
InputHitTest(CPoint point) const | CXTPMarkupVisual |
InputHitTestOverride(CPoint point) const | CXTPMarkupVisual | protectedvirtual
InvalidateArrange() | CXTPMarkupUIElement | virtual
InvalidateMeasure() | CXTPMarkupUIElement | virtual
InvalidateMeasureOverride(CXTPMarkupDrawingContext *pDC) | CXTPMarkupUIElement | protectedvirtual
InvalidateVisual() | CXTPMarkupUIElement | virtual
IsEnabled() const | CXTPMarkupUIElement |
IsFocusable() const | CXTPMarkupUIElement |
IsVisible() const | CXTPMarkupUIElement | virtual
m_bArrangeDirty | CXTPMarkupUIElement | protected
m_bArrangeInProgress | CXTPMarkupUIElement | protected
m_bMeasureDirty | CXTPMarkupUIElement | protected
m_bMeasureInProgress | CXTPMarkupUIElement | protected
m_bNeverArranged | CXTPMarkupUIElement | protected
m_bNeverMeasured | CXTPMarkupUIElement | protected
m_pClipToBoundsProperty | CXTPMarkupUIElement | static
m_pFocusableProperty | CXTPMarkupUIElement | static
m_pIsEnabledProperty | CXTPMarkupUIElement | static
m_pOpacityProperty | CXTPMarkupUIElement | static
m_pRenderTransformOriginProperty | CXTPMarkupUIElement | static
m_pRenderTransformProperty | CXTPMarkupUIElement | static
m_ptVisualOffset | CXTPMarkupVisual | protected
m_pVisibilityProperty | CXTPMarkupUIElement | static
m_rcBoundRect | CXTPMarkupVisual | protected
m_rcFinalRect | CXTPMarkupUIElement | protected
m_rcPrevUpdateRect | CXTPMarkupVisual | protected
m_rcUpdateRect | CXTPMarkupVisual | protected
m_szDesiredSize | CXTPMarkupUIElement | protected
m_szPreviousAvailableSize | CXTPMarkupUIElement | protected
m_szRenderSize | CXTPMarkupVisual | protected
Measure(CXTPMarkupDrawingContext *pDC, CSize szAvailableSize) | CXTPMarkupUIElement |
MeasureCore(CXTPMarkupDrawingContext *pDC, CSize szAvailableSize) | CXTPMarkupUIElement | protectedvirtual
OnRender(CXTPMarkupDrawingContext *drawingContext) | CXTPMarkupVisual | protectedvirtual
OnRenderFocusVisual(CXTPMarkupDrawingContext *drawingContext) | CXTPMarkupVisual | protectedvirtual
PtInRectTransform(const RECT &rect, const POINT &point) const | CXTPMarkupVisual | protected
Render(CXTPMarkupDrawingContext *drawingContext) | CXTPMarkupVisual |
RenderClipped(CXTPMarkupDrawingContext *drawingContext) | CXTPMarkupVisual | protectedvirtual
RestoreRenderTransform(CXTPMarkupDrawingContext *pContext, TransformationMatrices &matrices) | CXTPMarkupUIElement | protectedvirtual
SetBackground(CXTPMarkupBrush *pBrush) | CXTPMarkupPanel |
SetClipToBounds(BOOL bClipToBounds) | CXTPMarkupFrameworkElement |
SetHeight(int nHeight) | CXTPMarkupFrameworkElement |
SetHorizontalAlignment(XTPMarkupHorizontalAlignment alignment) | CXTPMarkupFrameworkElement |
SetMargin(int nLeft, int nTop, int nRight, int nBottom) | CXTPMarkupFrameworkElement |
SetMargin(int nMargin) | CXTPMarkupFrameworkElement |
SetMaxHeight(int nHeight) | CXTPMarkupFrameworkElement |
SetMaxWidth(int nWidth) | CXTPMarkupFrameworkElement |
SetMinHeight(int nHeight) | CXTPMarkupFrameworkElement |
SetMinWidth(int nWidth) | CXTPMarkupFrameworkElement |
SetTag(CXTPMarkupObject *pTag) | CXTPMarkupFrameworkElement |
SetVerticalAlignment(XTPMarkupVerticalAlignment alignment) | CXTPMarkupFrameworkElement |
SetVisibility(XTPMarkupVisibility visibility) | CXTPMarkupUIElement |
SetWidth(int nWidth) | CXTPMarkupFrameworkElement |
~CXTPMarkupFrameworkElement() | CXTPMarkupFrameworkElement | protectedvirtual
~CXTPMarkupPanel() | CXTPMarkupPanel | protectedvirtual
~CXTPMarkupUIElement() | CXTPMarkupUIElement | protectedvirtual
~CXTPMarkupVisual() | CXTPMarkupVisual | virtual


Toolkit Pro: Member List

CXTPEditThemeNativeWindows10 Member List

This is the complete list of members for CXTPEditThemeNativeWindows10, including all inherited members.

AdjustBuddyRect(CWnd *pBuddy, CRect &rcUpDown, int nAlignment) | CXTPEditThemeOfficeXP | virtual
CtlColor(CDC *pDC, UINT nCtlColor, CXTPEdit *pEdit) | CXTPEditThemeDefault | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPControlTheme() | CXTPControlTheme |
CXTPEditTheme() | CXTPEditTheme |
CXTPEditThemeDefault() | CXTPEditThemeDefault |
CXTPEditThemeNativeWindows10() | CXTPEditThemeNativeWindows10 |
CXTPEditThemeOffice2000() | CXTPEditThemeOffice2000 |
CXTPEditThemeOffice2013() | CXTPEditThemeOffice2013 |
CXTPEditThemeOfficeXP() | CXTPEditThemeOfficeXP |
DrawBuddyBorders(CWnd *pBuddy, CDC *pDC, CRect rc, int nAlignment, CXTPEdit *pEdit) | CXTPEditThemeOfficeXP | virtual
CXTPEditThemeOffice2000::DrawBuddyBorders(CDC *pDC, CRect rc, int nAlignment, CXTPEdit *pEdit) | CXTPEditThemeOffice2000 | virtual
DrawFrame(CDC *pDC, CRect rc, int nSize, CBrush *pBrush) | CXTPEditTheme | virtual
DrawNcBorders(CDC *pDC, CRect rcWnd, CXTPEdit *pEdit) | CXTPEditThemeOfficeXP | virtual
DrawNcBordersDefault(CDC *pDC, CRect rcWnd, CXTPEdit *pEdit) | CXTPEditThemeDefault | protectedvirtual
DrawNcScrollBack(CDC *pDC, CRect rcWnd, CXTPEdit *pEdit) | CXTPEditThemeDefault | virtual
FillRect(CDC *pDC, int x, int y, int cx, int cy, CBrush *pBrush) | CXTPEditTheme | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetClientBrush(CDC *pDC, CXTPEdit *pEdit) | CXTPEditTheme | virtual
GetThemeID() const | CXTPEditTheme |
GetThemeStyle() const | CXTPControlTheme |
IsFlatStyle() const | CXTPEditTheme |
m_bFlatStyle | CXTPEditTheme | protected
m_bUseWinTheme | CXTPEditTheme | protected
m_clrBack | CXTPEditTheme |
m_clrBackNonClient | CXTPEditTheme |
m_clrBorder | CXTPEditTheme |
m_clrBorderDisabled | CXTPEditThemeOfficeXP | protected
m_clrBorderHilite | CXTPEditThemeOfficeXP | protected
m_clrText | CXTPEditTheme |
m_clrTextReadOnly | CXTPEditTheme |
m_nTheme | CXTPEditTheme | protected
m_winTheme | CXTPEditTheme | protected
m_xtpBrushBack | CXTPEditTheme |
RedrawFocusedFrame() const | CXTPEditThemeOfficeXP | virtual
RefreshMetrics(CXTPEdit *pEdit) | CXTPEditThemeOffice2013 | virtual
SetFlatStyle(BOOL bFlatStyle) | CXTPEditTheme |
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static
UseWinTheme(BOOL bUseWinTheme) | CXTPEditTheme |
~CXTPEditTheme() | CXTPEditTheme | virtual
~CXTPEditThemeDefault() | CXTPEditThemeDefault | virtual
~CXTPEditThemeNativeWindows10() | CXTPEditThemeNativeWindows10 | virtual
~CXTPEditThemeOffice2000() | CXTPEditThemeOffice2000 | virtual
~CXTPEditThemeOffice2013() | CXTPEditThemeOffice2013 | virtual
~CXTPEditThemeOfficeXP() | CXTPEditThemeOfficeXP | virtual


Toolkit Pro: Member List

CXTPChart3dBox Member List

This is the complete list of members for CXTPChart3dBox, including all inherited members.

CXTPChart3dBox() | CXTPChart3dBox
CXTPChart3dBox(const CXTPChart3dBox &rhs) | CXTPChart3dBox
GetCenter(BOOL bAmongstCenterCandidates=FALSE) const | CXTPChart3dBox
GetCenterCandidates() const | CXTPChart3dBox
GetCorners(CXTPPoint3d(&pt)[8]) const | CXTPChart3dBox
GetMaxPoint() const | CXTPChart3dBox
GetMinPoint() const | CXTPChart3dBox
Include(const CXTPPoint3d &pt, BOOL bCenterCandidate=FALSE) | CXTPChart3dBox
Include(double x, double y, double z, BOOL bCenterCandidate=FALSE) | CXTPChart3dBox
Include(const CXTPChart3dBox &box) | CXTPChart3dBox
IsValid() const | CXTPChart3dBox
operator=(const CXTPChart3dBox &rhs) | CXTPChart3dBox
PointList typedef | CXTPChart3dBox


Toolkit Pro: XTPMarkupGdiPlusRotateTransform.h Source File

  • Source
  • Markup
  • Transform
XTPMarkupGdiPlusRotateTransform.h
Go to the documentation of this file.
1
23#if !defined(__XTPMARKUPGDIPLUSROTATETRANSFORM_H__)
24# define __XTPMARKUPGDIPLUSROTATETRANSFORM_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPGdiPlus;
34
39class _XTP_EXT_CLASS CXTPMarkupGdiPlusRotateTransform
40 : public CXTPMarkupGdiPlusTransformObject<CXTPMarkupRotateTransform>
41{
43 DECLARE_MARKUPCLASS(CXTPMarkupGdiPlusRotateTransform);
45public:
50 CXTPMarkupGdiPlusRotateTransform();
51
60 virtual BOOL TransformMatrix(const CXTPGdiPlus* pReserved, GpMatrix* pMatrix);
61};
62
63# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
65#endif // !defined(__XTPMARKUPGDIPLUSROTATETRANSFORM_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPMarkupGdiPlusRotateTransform
GDI+ RotateTransform implementation.
Definition XTPMarkupGdiPlusRotateTransform.h:41
CXTPMarkupGdiPlusRotateTransform::CXTPMarkupGdiPlusRotateTransform
CXTPMarkupGdiPlusRotateTransform()
Constructs a CXTPMarkupGdiPlusRotateTransform object.
CXTPMarkupGdiPlusRotateTransform::TransformMatrix
virtual BOOL TransformMatrix(const CXTPGdiPlus *pReserved, GpMatrix *pMatrix)
Performs GDI+ matrix rotation.
CXTPMarkupGdiPlusTransformObject
Base class for all GDI+ markup transformation objects.
Definition XTPMarkupGdiPlusTransformObject.h:91


Toolkit Pro: Member List

CXTPChartAxisTitle Member List

This is the complete list of members for CXTPChartAxisTitle, including all inherited members.

CXTPChartAxisTitle(CXTPChartAxis *pAxis) | CXTPChartAxisTitle |
CXTPChartElement() | CXTPChartElement |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
DoPropExchange(CXTPPropExchange *pPX) | CXTPChartAxisTitle | virtual
GetActualTextColor() const | CXTPChartAxisTitle |
GetAlignment() const | CXTPChartAxisTitle |
GetAntialiasing() const | CXTPChartAxisTitle | virtual
GetAppearance() const | CXTPChartElement |
GetAxis() const | CXTPChartAxisTitle |
GetContent() const | CXTPChartElement |
GetFont() const | CXTPChartAxisTitle | virtual
GetOwner() const | CXTPChartElement |
GetText() const | CXTPChartAxisTitle |
GetTextColor() const | CXTPChartAxisTitle |
Is3D() const | CXTPChartObject |
IsVisible() const | CXTPChartAxisTitle |
m_bAntialiasing | CXTPChartAxisTitle | protected
m_bVisible | CXTPChartAxisTitle | protected
m_clrTextColor | CXTPChartAxisTitle | protected
m_nAlignment | CXTPChartAxisTitle | protected
m_pFont | CXTPChartAxisTitle | protected
m_strText | CXTPChartAxisTitle | protected
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartElement | virtual
Release() | CXTPChartElement | virtual
SetAlignment(XTPChartStringAlignment nAlignment) | CXTPChartAxisTitle |
SetAntialiasing(BOOL bAntialiasing) | CXTPChartAxisTitle |
SetFont(CXTPChartFont *pFont) | CXTPChartAxisTitle |
SetText(LPCTSTR lpszTitle) | CXTPChartAxisTitle |
SetTextColor(const CXTPChartColor &clrTextColor) | CXTPChartAxisTitle |
SetVisible(BOOL bVisible) | CXTPChartAxisTitle |
~CXTPChartAxisTitle() | CXTPChartAxisTitle | virtual
~CXTPChartElement() | CXTPChartElement | virtual


Toolkit Pro: Member List

  • CXTPControlGallery
  • GALLERYITEM_POSITION
CXTPControlGallery::GALLERYITEM_POSITION Member List

This is the complete list of members for CXTPControlGallery::GALLERYITEM_POSITION, including all inherited members.

bBeginRow | CXTPControlGallery::GALLERYITEM_POSITION
pItem | CXTPControlGallery::GALLERYITEM_POSITION
rcItem | CXTPControlGallery::GALLERYITEM_POSITION


Toolkit Pro: Member List

CAppearanceSetVisio Member List

This is the complete list of members for CAppearanceSetVisio, including all inherited members.

AdjustClientRect(CXTPTabManager *pTabManager, CRect &rcClient) | CAppearanceSetVisio | virtual
CXTPTabPaintManagerTheme() | CXTPTabPaintManagerTheme |
DrawSingleButton(CDC *pDC, CXTPTabManagerItem *pItem) | CAppearanceSetVisio | virtual
DrawTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl) | CAppearanceSetVisio | virtual
DrawText(CDC *pDC, CXTPTabManager *pManager, const CString &str, LPRECT lpRect, UINT nFormat) | CXTPTabPaintManagerTheme | virtual
DrawWorkspacePart(CDC *pDC, LPRECT lpRect, XTPTabWorkspacePart workspacePart) | CXTPTabPaintManagerTheme | virtual
FillButton(CDC *pDC, CXTPTabManagerItem *pItem, LPPOINT pts, int nCount, XTPTabPosition tabPosition, BOOL bAbsolute=FALSE) | CXTPTabPaintManagerTheme |
FillTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl) | CXTPTabPaintManagerTheme | virtual
GetButtonDrawRect(const CXTPTabManagerItem *pItem) | CXTPTabPaintManagerTheme | virtual
GetButtonHeight(const CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetButtonLength(CDC *pDC, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerTheme | virtual
GetClientMargin() | CXTPTabPaintManagerTheme | virtual
GetClientRect(CRect rcControl, CXTPTabManager *pTabManager) | CAppearanceSetVisio | virtual
GetColorSet() const | CXTPTabPaintManagerTheme |
GetDefaultColorSet() | CXTPTabPaintManagerTheme | inlinevirtual
GetHeaderClipBox(CDC *pDC, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetHeaderHeight(CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme |
GetHeaderMargin() | CXTPTabPaintManagerTheme | virtual
GetHeaderRect(CRect rcControl, CXTPTabManager *pTabManager) | CAppearanceSetVisio | virtual
GetSupportedColorSets() | CXTPTabPaintManagerTheme | inlinevirtual
m_bButtonsReverseZOrder | CXTPTabPaintManagerTheme | protected
m_nButtonHeight | CXTPTabPaintManagerTheme | protected
m_nRowMargin | CXTPTabPaintManagerTheme |
m_pPaintManager | CXTPTabPaintManagerTheme | protected
m_rcHeaderMargin | CXTPTabPaintManagerTheme |
RefreshMetrics() | CXTPTabPaintManagerTheme | virtual
RepositionTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcClient) | CAppearanceSetVisio | virtual
~CXTPTabPaintManagerTheme() | CXTPTabPaintManagerTheme | virtual


Toolkit Pro: XTPTabThemePropertyPageFlat.h Source File

  • Source
  • TabManager
  • Themes
XTPTabThemePropertyPageFlat.h
Go to the documentation of this file.
1
23#if !defined(__XTPTABTHEMEPROPERTYPAGEFLAT_H__)
24# define __XTPTABTHEMEPROPERTYPAGEFLAT_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
48class _XTP_EXT_CLASS CAppearanceSetPropertyPageFlat : public CXTPTabThemeFlat
49{
50public:
57 CAppearanceSetPropertyPageFlat()
58 {
59 m_bBlurPoints = TRUE;
60 m_bVisualStudio2005Style = FALSE;
61 m_bDrawNormalTab = TRUE;
62 }
63
81 virtual void DrawSingleButton(CDC* pDC, CXTPTabManagerItem* pItem);
82
91 virtual XTPTabColorStyle GetDefaultColorSet()
92 {
93 return xtpTabColorDefault;
94 }
95
96 void BlurPoint(CDC* pDC, int x, int y, COLORREF clr, int nAlpha);
97 void BlurTab(CDC* pDC, CRect rcTab, COLORREF clrBackground, COLORREF clrBorder,
98 XTPTabPosition tabPosition);
99
100public:
101 BOOL m_bBlurPoints;
102 BOOL m_bVisualStudio2005Style;
103 BOOL m_bDrawNormalTab;
104};
105
106# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
108#endif // !defined(__XTPTABTHEMEPROPERTYPAGEFLAT_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPTabPosition
XTPTabPosition
XTPTabPosition is an enumeration used to set the position of tabs.
Definition XTPTabManagerDefines.h:200
XTPTabColorStyle
XTPTabColorStyle
XTPTabColorStyle is an enumeration used to set the color style of tabs.
Definition XTPTabManagerDefines.h:139
xtpTabColorDefault
@ xtpTabColorDefault
Tabs will use the default color for the currently set Appearance.
Definition XTPTabManagerDefines.h:140
CAppearanceSetPropertyPageFlat
CAppearanceSetPropertyPageFlat implements an Office 2000 Flat tab appearance.
Definition XTPTabThemePropertyPageFlat.h:49
CAppearanceSetPropertyPageFlat::GetDefaultColorSet
virtual XTPTabColorStyle GetDefaultColorSet()
Gets the default value of the color set for this theme.
Definition XTPTabThemePropertyPageFlat.h:91
CAppearanceSetPropertyPageFlat::CAppearanceSetPropertyPageFlat
CAppearanceSetPropertyPageFlat()
Constructs a CAppearanceSetPropertyPageFlat object.
Definition XTPTabThemePropertyPageFlat.h:57
CAppearanceSetPropertyPageFlat::m_bBlurPoints
BOOL m_bBlurPoints
TRUE to smooth corners of flat tabs.
Definition XTPTabThemePropertyPageFlat.h:101
CAppearanceSetPropertyPageFlat::DrawSingleButton
virtual void DrawSingleButton(CDC *pDC, CXTPTabManagerItem *pItem)
Draws a single tab button in the tab client header area.
CAppearanceSetPropertyPageFlat::m_bVisualStudio2005Style
BOOL m_bVisualStudio2005Style
TRUE to draw with Visual Studio 2005 style.
Definition XTPTabThemePropertyPageFlat.h:102
CXTPTabManagerItem
CXTPTabManagerItem is the base class for the tabs that appear in the command bars tab workspace,...
Definition XTPTabManagerItem.h:44
CXTPTabThemeFlat
CXTPTabThemeFlat implements a "Flat" tab appearance.
Definition XTPTabThemeFlat.h:49


Toolkit Pro: Member List

CXTPSkinObjectListBox Member List

This is the complete list of members for CXTPSkinObjectListBox, including all inherited members.

CheckScrollBarsDraw() | CXTPSkinObjectUser32Control | protectedvirtual
CXTPSkinObject() | CXTPSkinObject | protected
CXTPSkinObjectFrame() | CXTPSkinObjectFrame |
CXTPSkinObjectListBox() | CXTPSkinObjectListBox |
CXTPSkinObjectUser32Control() | CXTPSkinObjectUser32Control | protected
GetAccessCriticalSection() const | CXTPSynchronized | inline
GetBorders() const | CXTPSkinObjectFrame |
GetCaptionButtons() | CXTPSkinObjectFrame |
GetClassName() const | CXTPSkinObject |
GetClientBrush(CDC *pDC) | CXTPSkinObjectFrame | virtual
GetColor(int nIndex) const | CXTPSkinObject |
GetMetrics() const | CXTPSkinObject |
GetSkinClass() const | CXTPSkinObject |
GetSkinManager() const | CXTPSkinObject |
IsActive() const | CXTPSkinObjectFrame |
m_arrButtons | CXTPSkinObjectFrame | protected
m_bActive | CXTPSkinObjectFrame | protected
m_bActiveX | CXTPSkinObject | protected
m_bLockFrameDraw | CXTPSkinObjectFrame |
m_bMDIClient | CXTPSkinObjectFrame | protected
m_bRegionChanged | CXTPSkinObjectFrame | protected
m_bWindowsForms | CXTPSkinObject | protected
m_dwDialogTexture | CXTPSkinObjectFrame |
m_dwExStyle | CXTPSkinObjectFrame | protected
m_dwStyle | CXTPSkinObjectFrame | protected
m_pButtonHot | CXTPSkinObjectFrame | protected
m_pButtonPressed | CXTPSkinObjectFrame | protected
m_pManager | CXTPSkinObject | protected
m_pOldWndProc | CXTPSkinObject | protected
m_pSBTrack | CXTPSkinObjectFrame | protected
m_rcBorders | CXTPSkinObjectFrame | protected
m_spi | CXTPSkinObjectFrame | protected
m_strClassName | CXTPSkinObject | protected
m_szFrameRegion | CXTPSkinObjectFrame | protected
OnHookAttached(LPCREATESTRUCT lpcs, BOOL bAuto) | CXTPSkinObjectFrame | protectedvirtual
OnHookDetached(BOOL bAuto) | CXTPSkinObjectFrame | protectedvirtual
OnSkinChanged(BOOL bPrevState, BOOL bNewState) | CXTPSkinObjectFrame | protectedvirtual
RedrawScrollBar(int nBar) | CXTPSkinObjectFrame |
RefreshMetrics() | CXTPSkinObjectFrame | protectedvirtual
~CXTPSkinObject() | CXTPSkinObject | protected
~CXTPSkinObjectFrame() | CXTPSkinObjectFrame | virtual
~CXTPSkinObjectListBox() | CXTPSkinObjectListBox | virtual


Toolkit Pro: XTPTaskPanelShortcutBarOffice2007Theme.h Source File

  • Source
  • TaskPanel
  • Themes
XTPTaskPanelShortcutBarOffice2007Theme.h
Go to the documentation of this file.
1
23#ifndef XTPTaskPanelShortcutBarOffice2007Theme_h__
24# define XTPTaskPanelShortcutBarOffice2007Theme_h__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
39class _XTP_EXT_CLASS CXTPTaskPanelShortcutBarOffice2007Theme
40 : public CXTPTaskPanelShortcutBarOffice2003Theme
41{
42public:
47 CXTPTaskPanelShortcutBarOffice2007Theme();
48
53 void RefreshMetrics();
54
55protected:
65 CRect DrawGroupCaptionBackground(CDC* pDC, CXTPTaskPanelGroup* pGroup, CRect rc);
66
74 void DrawGroupClientFace(CDC* pDC, CXTPTaskPanelGroup* pGroup, CRect rc);
75
85 void FillGroupClientFace(CDC* pDC, CXTPTaskPanelGroup* pGroup, CRect rc);
86
93 void FillTaskPanel(CDC* pDC, CXTPTaskPanel* pTaskPanel);
94
103 void DrawGroupItemFrame(CDC* pDC, CXTPTaskPanelGroupItem* pItem, CRect rc);
104
105protected:
106 COLORREF m_clrShortcutItemShadow;
107 BOOL m_bPlainStyle;
108};
110# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
111#endif // XTPTaskPanelShortcutBarOffice2007Theme_h__
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPTaskPanelGroup
CXTPTaskPanelGroup is used in a Task Panel control to represent a group.
Definition XTPTaskPanelGroup.h:45
CXTPTaskPanelGroupItem
CXTPTaskPanelGroupItem is used in a TaskPanel control to represent a single item of a group.
Definition XTPTaskPanelGroupItem.h:39
CXTPTaskPanel
CXTPTaskPanel is used to implement an Explorer and Office-like Task Panel control.
Definition XTPTaskPanel.h:107
CXTPTaskPanelShortcutBarOffice2003Theme
CXTPTaskPanelShortcutBarOffice2003Theme represents an Office 2003 ShortcutBar style theme.
Definition XTPTaskPanelShortcutBarOffice2003Theme.h:41
CXTPTaskPanelShortcutBarOffice2007Theme
CXTPTaskPanelShortcutBarOffice2007Theme represents an Office 2007 ShortcutBar style theme.
Definition XTPTaskPanelShortcutBarOffice2007Theme.h:41
CXTPTaskPanelShortcutBarOffice2007Theme::m_clrShortcutItemShadow
COLORREF m_clrShortcutItemShadow
Shadow color of items.
Definition XTPTaskPanelShortcutBarOffice2007Theme.h:106
CXTPTaskPanelShortcutBarOffice2007Theme::DrawGroupItemFrame
void DrawGroupItemFrame(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc)
Draws a rectangle around a group item when it is selected, pressed or highlighted.
CXTPTaskPanelShortcutBarOffice2007Theme::FillTaskPanel
void FillTaskPanel(CDC *pDC, CXTPTaskPanel *pTaskPanel)
Fills the background of a specified task panel.
CXTPTaskPanelShortcutBarOffice2007Theme::FillGroupClientFace
void FillGroupClientFace(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Fills the client face of a specified group.
CXTPTaskPanelShortcutBarOffice2007Theme::DrawGroupCaptionBackground
CRect DrawGroupCaptionBackground(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Draws the group caption background of a specified group.
CXTPTaskPanelShortcutBarOffice2007Theme::CXTPTaskPanelShortcutBarOffice2007Theme
CXTPTaskPanelShortcutBarOffice2007Theme()
Constructs a CXTPTaskPanelShortcutBarOffice2003Theme object.
CXTPTaskPanelShortcutBarOffice2007Theme::RefreshMetrics
void RefreshMetrics()
Refreshes the visual metrics of the task panel.
CXTPTaskPanelShortcutBarOffice2007Theme::DrawGroupClientFace
void DrawGroupClientFace(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Draws the client face of a specified group.


Toolkit Pro: Member List

CXTPProgressCtrlThemeUltraFlat Member List

This is the complete list of members for CXTPProgressCtrlThemeUltraFlat, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPProgressCtrlPaintManager() | CXTPProgressCtrlPaintManager |
CXTPProgressCtrlThemeFlat() | CXTPProgressCtrlThemeFlat |
CXTPProgressCtrlThemeUltraFlat() | CXTPProgressCtrlThemeUltraFlat |
DeflateRect(XTPPROGRESSDRAWSTRUCT &ds) | CXTPProgressCtrlThemeFlat | protectedvirtual
Draw(XTPPROGRESSDRAWSTRUCT &ds) | CXTPProgressCtrlPaintManager | virtual
DrawNcBorders(CDC *pDC, CRect rc) | CXTPProgressCtrlPaintManager | virtual
DrawText(XTPPROGRESSDRAWSTRUCT &ds) | CXTPProgressCtrlPaintManager | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetBackColor() | CXTPProgressCtrlPaintManager |
GetBarColor() | CXTPProgressCtrlPaintManager |
GetBorderColor() | CXTPProgressCtrlPaintManager |
GetTextColor() | CXTPProgressCtrlPaintManager |
m_bUseWinTheme | CXTPProgressCtrlPaintManager | protected
m_clrBack | CXTPProgressCtrlPaintManager | protected
m_clrBar | CXTPProgressCtrlPaintManager | protected
m_clrBarText | CXTPProgressCtrlPaintManager | protected
m_clrBorder | CXTPProgressCtrlPaintManager | protected
m_clrText | CXTPProgressCtrlPaintManager | protected
m_nTheme | CXTPProgressCtrlPaintManager | protected
m_winTheme | CXTPProgressCtrlPaintManager | protected
RefreshMetrics() | CXTPProgressCtrlThemeUltraFlat | virtual
SetBackColor(COLORREF clrNew) | CXTPProgressCtrlPaintManager |
SetBarColor(COLORREF clrNew) | CXTPProgressCtrlPaintManager |
SetBorderColor(COLORREF clrNew) | CXTPProgressCtrlPaintManager |
SetTextColor(COLORREF clrNew) | CXTPProgressCtrlPaintManager |
UseWinThemes(BOOL bUseWinThemes=TRUE) | CXTPProgressCtrlPaintManager |
UsingWinThemes(BOOL bCheckReady=FALSE) | CXTPProgressCtrlPaintManager |
~CXTPProgressCtrlPaintManager() | CXTPProgressCtrlPaintManager | virtual


Toolkit Pro: Member List

CXTPChart3dFunnelSeriesLabelsViewDeviceCommand Member List

This is the complete list of members for CXTPChart3dFunnelSeriesLabelsViewDeviceCommand, including all inherited members.

AddChildCommand(CXTPChartDeviceCommand *pCommand) | CXTPChartDeviceCommand |
AfterExecute(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
ApplySeriesStyle(CXTPChartSeriesStyle *pStyle) | CXTPChartDeviceCommand | virtual
BeforeExecute(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
BindView(CXTPChartElementView *pView) | CXTPChartDeviceCommand |
Commit() | CXTPChartDeviceCommand |
CXTPChart3dDeviceCommand(XTPChart3dAntialiasingPolicy nAntialiasingPolicy) | CXTPChart3dDeviceCommand | protected
CXTPChart3dFunnelSeriesLabelsViewDeviceCommand(CXTPChart3dFunnelSeriesLabelsView *pSeriesLabelsView) | CXTPChart3dFunnelSeriesLabelsViewDeviceCommand |
CXTPChartDeviceCommand() | CXTPChartDeviceCommand |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPObservable() | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | protected
Execute(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
ExecuteOverride(CXTPChartDeviceContext *pDC) | CXTPChart3dFunnelSeriesLabelsViewDeviceCommand | virtual
GetBoundView() const | CXTPChartDeviceCommand |
GetChildCommand(int nIndex) const | CXTPChartDeviceCommand |
GetChildCommandCount() const | CXTPChartDeviceCommand |
GetCurrentDC() const | CXTPChartDeviceCommand |
GetPassNumber() const | CXTPChartDeviceCommand |
HitTest(CPoint point, CXTPChartElement *pParent) const | CXTPChartDeviceCommand | virtual
Is3D() const | CXTPChartObject |
IsCommitted() const | CXTPChartDeviceCommand |
IsEnabled() const | CXTPChart3dDeviceCommand | virtual
m_arrChildren | CXTPChartDeviceCommand | protected
m_pSeriesLabelsView | CXTPChart3dFunnelSeriesLabelsViewDeviceCommand | protected
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Prepare(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
PrepareOverride(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
SetEnabled(BOOL bEnabled=TRUE) | CXTPChartDeviceCommand |
Subscribe(CXTPChartDeviceCommandEvents *pObserver, CXTPSubscriptionList< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > *pSubcriptionList=NULL) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > |
Unsubscribe(CXTPChartDeviceCommandEvents *pObserver) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > |
~CXTPChartDeviceCommand() | CXTPChartDeviceCommand | virtual
~CXTPObservable() | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | protected


Toolkit Pro: Member List

CXTPProgressCtrlThemeOffice2003 Member List

This is the complete list of members for CXTPProgressCtrlThemeOffice2003, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPProgressCtrlPaintManager() | CXTPProgressCtrlPaintManager |
CXTPProgressCtrlThemeOffice2000() | CXTPProgressCtrlThemeOffice2000 |
CXTPProgressCtrlThemeOffice2003() | CXTPProgressCtrlThemeOffice2003 |
DeflateRect(XTPPROGRESSDRAWSTRUCT &ds) | CXTPProgressCtrlPaintManager | protectedvirtual
Draw(XTPPROGRESSDRAWSTRUCT &ds) | CXTPProgressCtrlPaintManager | virtual
DrawNcBorders(CDC *pDC, CRect rc) | CXTPProgressCtrlThemeOffice2003 | virtual
DrawText(XTPPROGRESSDRAWSTRUCT &ds) | CXTPProgressCtrlPaintManager | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetBackColor() | CXTPProgressCtrlPaintManager |
GetBarColor() | CXTPProgressCtrlPaintManager |
GetBorderColor() | CXTPProgressCtrlPaintManager |
GetTextColor() | CXTPProgressCtrlPaintManager |
m_bUseWinTheme | CXTPProgressCtrlPaintManager | protected
m_clrBack | CXTPProgressCtrlPaintManager | protected
m_clrBar | CXTPProgressCtrlPaintManager | protected
m_clrBarText | CXTPProgressCtrlPaintManager | protected
m_clrBorder | CXTPProgressCtrlPaintManager | protected
m_clrText | CXTPProgressCtrlPaintManager | protected
m_nTheme | CXTPProgressCtrlPaintManager | protected
m_winTheme | CXTPProgressCtrlPaintManager | protected
RefreshMetrics() | CXTPProgressCtrlThemeOffice2003 | virtual
SetBackColor(COLORREF clrNew) | CXTPProgressCtrlPaintManager |
SetBarColor(COLORREF clrNew) | CXTPProgressCtrlPaintManager |
SetBorderColor(COLORREF clrNew) | CXTPProgressCtrlPaintManager |
SetTextColor(COLORREF clrNew) | CXTPProgressCtrlPaintManager |
UseWinThemes(BOOL bUseWinThemes=TRUE) | CXTPProgressCtrlPaintManager |
UsingWinThemes(BOOL bCheckReady=FALSE) | CXTPProgressCtrlPaintManager |
~CXTPProgressCtrlPaintManager() | CXTPProgressCtrlPaintManager | virtual


Toolkit Pro: XTPMarkupXtpScript.h Source File

  • Source
  • Markup
  • Extensions
XTPMarkupXtpScript.h
Go to the documentation of this file.
1
23#if !defined(__XTPMARKUPXTPSCRIPT_H__)
24# define __XTPMARKUPXTPSCRIPT_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPMarkupDependencyProperty;
34class CXTPMarkupBuilder;
35class CXTPMarkupObject;
36
41class _XTP_EXT_CLASS CXTPMarkupXtpScript : public CXTPMarkupExtension
42{
44 DECLARE_MARKUPCLASS(CXTPMarkupXtpScript);
46public:
54 LPCWSTR GetLanguage() const;
55
62 LPCWSTR GetSource() const;
63
70 LPCWSTR GetRequires() const;
71
72public:
79 virtual void SetContentObject(CXTPMarkupBuilder* pBuilder, CXTPMarkupObject* pContent);
80
81private:
82 virtual void OnLoaded(CXTPMarkupBuilder* pBuilder);
83
84 HRESULT LoadCodeContent(const void* pFileData, UINT cbFileData,
85 CArray<WCHAR, WCHAR>* pData) const;
86
87private:
88 static CXTPMarkupDependencyProperty* m_pPropertyLanguage;
89 static CXTPMarkupDependencyProperty* m_pPropertySource;
90 static CXTPMarkupDependencyProperty* m_pPropertyRequires;
92 CComBSTR m_strCode;
93};
94
95# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
97#endif // !defined(__XTPMARKUPXTPSCRIPT_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPMarkupExtension
Base class for all markup extension objects.
Definition XTPMarkupExtension.h:38
CXTPMarkupXtpScript
Contains a code in the script language chosen.
Definition XTPMarkupXtpScript.h:42
CXTPMarkupXtpScript::GetSource
LPCWSTR GetSource() const
Obtains the referenced script location.
CXTPMarkupXtpScript::GetRequires
LPCWSTR GetRequires() const
Obtains the comma separated list of requirements.
CXTPMarkupXtpScript::SetContentObject
virtual void SetContentObject(CXTPMarkupBuilder *pBuilder, CXTPMarkupObject *pContent)
Sets the script code.
CXTPMarkupXtpScript::GetLanguage
LPCWSTR GetLanguage() const
Obtains the script language name, which is the same as the script language AppID.


Toolkit Pro: Member List

CAppearanceSetPropertyPage2003 Member List

This is the complete list of members for CAppearanceSetPropertyPage2003, including all inherited members.

AdjustClientRect(CXTPTabManager *pTabManager, CRect &rcClient) | CXTPTabPaintManagerTheme | virtual
CAppearanceSetPropertyPage2003() | CAppearanceSetPropertyPage2003 | inline
CXTPTabPaintManagerTheme() | CXTPTabPaintManagerTheme |
DrawSingleButton(CDC *pDC, CXTPTabManagerItem *pItem) | CAppearanceSetPropertyPage2003 | virtual
DrawTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl) | CXTPTabPaintManagerTheme | virtual
DrawText(CDC *pDC, CXTPTabManager *pManager, const CString &str, LPRECT lpRect, UINT nFormat) | CXTPTabPaintManagerTheme | virtual
DrawWorkspacePart(CDC *pDC, LPRECT lpRect, XTPTabWorkspacePart workspacePart) | CXTPTabPaintManagerTheme | virtual
FillButton(CDC *pDC, CXTPTabManagerItem *pItem, LPPOINT pts, int nCount, XTPTabPosition tabPosition, BOOL bAbsolute=FALSE) | CXTPTabPaintManagerTheme |
FillTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl) | CAppearanceSetPropertyPage2003 | virtual
GetButtonDrawRect(const CXTPTabManagerItem *pItem) | CAppearanceSetPropertyPage2003 | virtual
GetButtonHeight(const CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetButtonLength(CDC *pDC, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerTheme | virtual
GetClientMargin() | CXTPTabPaintManagerTheme | virtual
GetClientRect(CRect rcControl, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetColorSet() const | CXTPTabPaintManagerTheme |
GetDefaultColorSet() | CAppearanceSetPropertyPage2003 | inlinevirtual
GetHeaderClipBox(CDC *pDC, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetHeaderHeight(CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme |
GetHeaderMargin() | CAppearanceSetPropertyPage2003 | inlinevirtual
GetHeaderRect(CRect rcControl, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetSupportedColorSets() | CXTPTabPaintManagerTheme | inlinevirtual
m_bButtonsReverseZOrder | CXTPTabPaintManagerTheme | protected
m_bDoubleHighlightedBorder | CAppearanceSetPropertyPage2003 |
m_nButtonHeight | CXTPTabPaintManagerTheme | protected
m_nRowMargin | CXTPTabPaintManagerTheme |
m_pPaintManager | CXTPTabPaintManagerTheme | protected
m_rcHeaderMargin | CXTPTabPaintManagerTheme |
RefreshMetrics() | CAppearanceSetPropertyPage2003 | virtual
RepositionTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcClient) | CXTPTabPaintManagerTheme | virtual
~CXTPTabPaintManagerTheme() | CXTPTabPaintManagerTheme | virtual


Toolkit Pro: Member List

IXTPMarkupClientSite Member List

This is the complete list of members for IXTPMarkupClientSite, including all inherited members.

PrepareCodeChunk(LPCWSTR pCode, const CList< LPCWSTR, LPCWSTR > &requirements) | IXTPMarkupClientSite | inlinevirtual
~IXTPMarkupClientSite() | IXTPMarkupClientSite | inlinevirtual


Toolkit Pro: XTPChartTextPainter.h Source File

  • Source
  • Chart
  • Utils
XTPChartTextPainter.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTROTATEDTEXTPAINTE_H__)
24# define __XTPCHARTROTATEDTEXTPAINTE_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartDeviceContext;
34class CXTPChartDeviceCommand;
35class CXTPChartFont;
36class CXTPMarkupUIElement;
37
42enum XTPChartTextRotation
43{
44 xtpChartTextLeftTop,
45 xtpChartTextCenterTop,
46 xtpChartTextRightTop,
47 xtpChartTextLeftCenter,
48 xtpChartTextCenterCenter,
49 xtpChartTextRightCenter,
50 xtpChartTextLeftBottom,
51 xtpChartTextCenterBottom,
52 xtpChartTextRightBottom
53};
54
55class CXTPChartTextElement;
56
62class _XTP_EXT_CLASS CXTPChartTextPainterBase
63{
64protected:
73 CXTPChartTextPainterBase(CXTPChartDeviceContext* pDC, const CXTPChartString& text,
74 CXTPChartTextElement* pTextProvider);
75
76public:
81 virtual ~CXTPChartTextPainterBase();
82
83public:
90 CRect GetRoundedBounds();
91
92 CXTPChartSizeF GetSize() const;
93
94protected:
105 virtual CXTPChartRectF CalculateBounds() = 0;
106
107protected:
108 CXTPChartString m_strText;
109 CXTPChartSizeF m_szTextSize;
110 CXTPChartTextElement* m_pTextProvider;
111 int m_nHeight;
112 int m_nWidth;
114 CRect m_rcRoundedBounds;
115 CXTPChartRectF m_rcBounds;
116 CXTPMarkupUIElement* m_pMarkupUIElement;
117};
118
124class _XTP_EXT_CLASS CXTPChartTextPainter : public CXTPChartTextPainterBase
125{
126public:
135 CXTPChartTextPainter(CXTPChartDeviceContext* pDC, const CXTPChartString& text,
136 CXTPChartTextElement* pTextProvider);
137
138 void SetLocation(const CXTPChartPointF& location);
139
140public:
153 virtual CXTPChartDeviceCommand* CreateDeviceCommand(CXTPChartDeviceContext* pDC,
154 const CXTPChartColor& color);
155
162 CXTPChartRectF CalculateBounds();
163
164protected:
165 CXTPChartPointF m_ptLocation; // The location of the text.
166};
167
174class _XTP_EXT_CLASS CXTPChartRotatedTextPainterBase : public CXTPChartTextPainterBase
175{
176protected:
186 CXTPChartRotatedTextPainterBase(CXTPChartDeviceContext* pDC, const CXTPChartString& text,
187 CXTPChartTextElement* pTextProvider,
188 CPoint ptBase = CPoint(0, 0));
189
190public:
204 virtual CXTPChartDeviceCommand* CreateDeviceCommand(CXTPChartDeviceContext* pDC,
205 const CXTPChartColor& color);
206
207public:
214 void SetBasePoint(CPoint pt);
215
222 CXTPChartRectF CalculateBounds();
223
230 CRect GetInitialTextRect();
231
242 virtual CPoint CalculateLeftTopPoint() = 0;
243
254 virtual XTPChartTextRotation CalculateRotation() = 0;
255
265 void CalculatePoints(XTPChartTextRotation rotation, CRect rect, float angle,
266 float points[4][2]);
267
268protected:
269 CPoint m_ptBasePoint;
270 float m_fAngle;
271};
272
279class _XTP_EXT_CLASS CXTPChartRotatedTextPainterNearLine : public CXTPChartRotatedTextPainterBase
280{
281public:
293 CXTPChartRotatedTextPainterNearLine(CXTPChartDeviceContext* pDC, const CXTPChartString& text,
294 CXTPChartTextElement* pTextProvider, CPoint ptBase,
295 XTPChartNearTextPosition position, float fAngle);
296
297public:
304 CPoint CalculateLeftTopPoint();
305
312 XTPChartTextRotation CalculateRotation();
313
314protected:
315 XTPChartNearTextPosition m_nNearPosition;
316};
317
318AFX_INLINE CXTPChartSizeF CXTPChartTextPainterBase::GetSize() const
319{
320 return m_szTextSize;
321}
323# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
324#endif //#if !defined(__XTPCHARTROTATEDTEXTPAINTE_H__)
XTPChartTextRotation
XTPChartTextRotation
This enumeration defines the various text rotations used in the XTP chart.
Definition XTPChartTextPainter.h:43
xtpChartTextRightBottom
@ xtpChartTextRightBottom
Right bottom.
Definition XTPChartTextPainter.h:52
xtpChartTextCenterBottom
@ xtpChartTextCenterBottom
Center bottom.
Definition XTPChartTextPainter.h:51
xtpChartTextCenterCenter
@ xtpChartTextCenterCenter
Center center.
Definition XTPChartTextPainter.h:48
xtpChartTextCenterTop
@ xtpChartTextCenterTop
Center top.
Definition XTPChartTextPainter.h:45
xtpChartTextLeftCenter
@ xtpChartTextLeftCenter
Left center.
Definition XTPChartTextPainter.h:47
xtpChartTextRightCenter
@ xtpChartTextRightCenter
Right center.
Definition XTPChartTextPainter.h:49
xtpChartTextLeftBottom
@ xtpChartTextLeftBottom
Left bottom.
Definition XTPChartTextPainter.h:50
xtpChartTextRightTop
@ xtpChartTextRightTop
Right top.
Definition XTPChartTextPainter.h:46
xtpChartTextLeftTop
@ xtpChartTextLeftTop
Left top.
Definition XTPChartTextPainter.h:44
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartColor
This class abstracts a color entity.
Definition XTPChartTypes.h:51
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartFont
This class abstracts a font entity.
Definition XTPChartTypes.h:540
CXTPChartRotatedTextPainterBase
This abstract base class represents a rotated text painter which is used for drawing various rotated ...
Definition XTPChartTextPainter.h:175
CXTPChartRotatedTextPainterBase::GetInitialTextRect
CRect GetInitialTextRect()
Call this function to calculate the bounds of the text.
CXTPChartRotatedTextPainterBase::CalculateRotation
virtual XTPChartTextRotation CalculateRotation()=0
Use this function to calculate the rotation of the text.
CXTPChartRotatedTextPainterBase::CreateDeviceCommand
virtual CXTPChartDeviceCommand * CreateDeviceCommand(CXTPChartDeviceContext *pDC, const CXTPChartColor &color)
This function creates a CXTPChartDeviceCommand object.
CXTPChartRotatedTextPainterBase::CalculateBounds
CXTPChartRectF CalculateBounds()
Call this function to calculate the bounds of the text.
CXTPChartRotatedTextPainterBase::m_fAngle
float m_fAngle
The angle of text rotation.
Definition XTPChartTextPainter.h:270
CXTPChartRotatedTextPainterBase::CalculateLeftTopPoint
virtual CPoint CalculateLeftTopPoint()=0
Call this function to calculate the left top point of the text.
CXTPChartRotatedTextPainterBase::CalculatePoints
void CalculatePoints(XTPChartTextRotation rotation, CRect rect, float angle, float points[4][2])
Computes text rectangle points taking into account text rotation.
CXTPChartRotatedTextPainterBase::CXTPChartRotatedTextPainterBase
CXTPChartRotatedTextPainterBase(CXTPChartDeviceContext *pDC, const CXTPChartString &text, CXTPChartTextElement *pTextProvider, CPoint ptBase=CPoint(0, 0))
Constructs a CXTPChartRotatedTextPainterBase object.
CXTPChartRotatedTextPainterBase::SetBasePoint
void SetBasePoint(CPoint pt)
Set base point of the text.
CXTPChartRotatedTextPainterBase::m_ptBasePoint
CPoint m_ptBasePoint
The base point of the text.
Definition XTPChartTextPainter.h:269
CXTPChartRotatedTextPainterNearLine
This abstract base class renders a rotated text near a line which is used for drawing various rotated...
Definition XTPChartTextPainter.h:280
CXTPChartRotatedTextPainterNearLine::m_nNearPosition
XTPChartNearTextPosition m_nNearPosition
The near text position.
Definition XTPChartTextPainter.h:315
CXTPChartRotatedTextPainterNearLine::CalculateLeftTopPoint
CPoint CalculateLeftTopPoint()
Use this function to calculate the left top point of the text.
CXTPChartRotatedTextPainterNearLine::CXTPChartRotatedTextPainterNearLine
CXTPChartRotatedTextPainterNearLine(CXTPChartDeviceContext *pDC, const CXTPChartString &text, CXTPChartTextElement *pTextProvider, CPoint ptBase, XTPChartNearTextPosition position, float fAngle)
Constructs a CXTPChartRotatedTextPainterNearLine object.
CXTPChartRotatedTextPainterNearLine::CalculateRotation
XTPChartTextRotation CalculateRotation()
Use this function to calculate the rotation of the text.
CXTPChartTextElement
This class abstracts a chart text element.
Definition XTPChartElement.h:323
CXTPChartTextPainterBase
This abstract class represents a text painter which is used for drawing various text elements in the ...
Definition XTPChartTextPainter.h:63
CXTPChartTextPainterBase::m_rcBounds
CXTPChartRectF m_rcBounds
The bounds of the text.
Definition XTPChartTextPainter.h:115
CXTPChartTextPainterBase::CXTPChartTextPainterBase
CXTPChartTextPainterBase(CXTPChartDeviceContext *pDC, const CXTPChartString &text, CXTPChartTextElement *pTextProvider)
Constructs a CXTPChartTextPainterBase object.
CXTPChartTextPainterBase::m_strText
CXTPChartString m_strText
The text to be painted.
Definition XTPChartTextPainter.h:108
CXTPChartTextPainterBase::m_pTextProvider
CXTPChartTextElement * m_pTextProvider
The chart element which owns the text.
Definition XTPChartTextPainter.h:110
CXTPChartTextPainterBase::m_nWidth
int m_nWidth
The width of the text.
Definition XTPChartTextPainter.h:112
CXTPChartTextPainterBase::CalculateBounds
virtual CXTPChartRectF CalculateBounds()=0
Call this function to calculate the bounds of the text.
CXTPChartTextPainterBase::GetRoundedBounds
CRect GetRoundedBounds()
Call this function to get the rounded bounds of the text.
CXTPChartTextPainterBase::~CXTPChartTextPainterBase
virtual ~CXTPChartTextPainterBase()
Destroys a CXTPChartTextPainterBase object, handles cleanup.
CXTPChartTextPainterBase::m_szTextSize
CXTPChartSizeF m_szTextSize
The measurements of the text.
Definition XTPChartTextPainter.h:109
CXTPChartTextPainterBase::m_rcRoundedBounds
CRect m_rcRoundedBounds
The rounded bounds of the text.
Definition XTPChartTextPainter.h:114
CXTPChartTextPainterBase::m_nHeight
int m_nHeight
The height of the text.
Definition XTPChartTextPainter.h:111
CXTPChartTextPainter
This class represents a text painter which is used for drawing various text elements in the chart.
Definition XTPChartTextPainter.h:125
CXTPChartTextPainter::CXTPChartTextPainter
CXTPChartTextPainter(CXTPChartDeviceContext *pDC, const CXTPChartString &text, CXTPChartTextElement *pTextProvider)
Constructs a CXTPChartTextPainterBase object.
CXTPChartTextPainter::CreateDeviceCommand
virtual CXTPChartDeviceCommand * CreateDeviceCommand(CXTPChartDeviceContext *pDC, const CXTPChartColor &color)
This function creates a CXTPChartDeviceCommand object.
CXTPChartTextPainter::CalculateBounds
CXTPChartRectF CalculateBounds()
Call this function to calculate the bounds of the text.
CXTPMarkupUIElement
Base class for XML Markup core level implementations.
Definition XTPMarkupUIElement.h:43
CXTPPoint2T< float >
CXTPRectT< float >
CXTPSizeT
This class incapsulates size data.
Definition XTPSize.h:40


Toolkit Pro: Member List

CXTPFrameWnd Member List

This is the complete list of members for CXTPFrameWnd, including all inherited members.

CXTPCommandBarsSiteBase() | CXTPCommandBarsSiteBase< CFrameWnd > | inline
CXTPFrameWndBase() | CXTPFrameWndBase< CFrameWnd > | inline
DECLARE_DYNCREATE(CXTPFrameWnd) CXTPFrameWnd() | CXTPFrameWnd |
DockRightOf(CXTPToolBar *pBarToDock, CXTPToolBar *pBarOnLeft) | CXTPCommandBarsSiteBase< CFrameWnd > | inline
GetCommandBars() const | CXTPCommandBarsSiteBase< CFrameWnd > | inline
InitCommandBars(CRuntimeClass *pCommandBarsClass=RUNTIME_CLASS(CXTPCommandBars)) | CXTPCommandBarsSiteBase< CFrameWnd > | inlinevirtual
LoadCommandBars(LPCTSTR lpszProfileName, BOOL bSilent=FALSE) | CXTPCommandBarsSiteBase< CFrameWnd > | inlinevirtual
SaveCommandBars(LPCTSTR lpszProfileName) | CXTPCommandBarsSiteBase< CFrameWnd > | inlinevirtual
~CXTPCommandBarsSiteBase() | CXTPCommandBarsSiteBase< CFrameWnd > | inline
~CXTPFrameWndBase() | CXTPFrameWndBase< CFrameWnd > | inline


Toolkit Pro: Member List

CXTPPropertyGridPaintManager Member List

This is the complete list of members for CXTPPropertyGridPaintManager, including all inherited members.

AdjustItemCaptionRect(CXTPPropertyGridItem *pItem, CRect &rcCaption) | CXTPPropertyGridPaintManager | virtual
AdjustItemValueRect(CXTPPropertyGridItem *pItem, CRect &rcValue) | CXTPPropertyGridPaintManager | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPPropertyGridPaintManager(CXTPPropertyGrid *pGrid) | CXTPPropertyGridPaintManager |
DrawCategoryCaptionBackground(CDC *pDC, CXTPPropertyGridItem *pItem, CRect rc) | CXTPPropertyGridPaintManager | virtual
DrawCheckBox(CDC *pDC, CXTPPropertyGridItemBool *pButton) | CXTPPropertyGridPaintManager | virtual
DrawCheckMark(CDC *pDC, CRect rc, BOOL bEnabled, BOOL bChecked) | CXTPPropertyGridPaintManager | virtual
DrawExpandButton(CDC &dc, CXTPPropertyGridItem *pItem, CRect rcCaption) | CXTPPropertyGridPaintManager | virtual
DrawInplaceButtons(CDC *pDC, PDRAWITEMSTRUCT lpDrawItemStruct, CXTPPropertyGridItem *pItem, CRect rcValue) | CXTPPropertyGridPaintManager | virtual
DrawInplaceListItem(CDC *pDC, CXTPPropertyGridItemConstraint *pConstraint, CRect rc, BOOL bSelected) | CXTPPropertyGridPaintManager | virtual
DrawItem(PDRAWITEMSTRUCT lpDrawItemStruct) | CXTPPropertyGridPaintManager | virtual
DrawItemCaption(CDC *pDC, CXTPPropertyGridItem *pItem, CRect rcCaption) | CXTPPropertyGridPaintManager | virtual
DrawItemValue(CDC *pDC, CXTPPropertyGridItem *pItem, CRect rcValue) | CXTPPropertyGridPaintManager | virtual
DrawPropertyGridBorder(CDC *pDC, RECT &rcBorder, XTPPropertyGridWindow nWindow) | CXTPPropertyGridPaintManager | virtual
DrawRadioMark(CDC *pDC, CRect rc, BOOL bEnabled, BOOL bChecked) | CXTPPropertyGridPaintManager | virtual
FillInplaceButton(CDC *pDC, CXTPPropertyGridInplaceButton *pButton) | CXTPPropertyGridPaintManager | virtual
FillPropertyGrid(CDC *pDC) | CXTPPropertyGridPaintManager | virtual
FillPropertyGridView(CDC *pDC) | CXTPPropertyGridPaintManager | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetItemBackColor(CXTPPropertyGridItem *pItem, BOOL bValuePart) | CXTPPropertyGridPaintManager | virtual
GetItemFont(CXTPPropertyGridItem *pItem, BOOL bValuePart) | CXTPPropertyGridPaintManager | virtual
GetItemMetrics() const | CXTPPropertyGridPaintManager |
GetItemsBorderHeight() const | CXTPPropertyGridPaintManager | virtual
GetItemTextColor(CXTPPropertyGridItem *pItem, BOOL bValuePart) | CXTPPropertyGridPaintManager | virtual
GetScrollBarTheme() const | CXTPPropertyGridPaintManager | virtual
GetSplitterRect(CRect rc, BOOL bIsHelp) | CXTPPropertyGridPaintManager |
HitTestVerbs(CDC *pDC, CRect rcVerbs, CPoint pt) | CXTPPropertyGridPaintManager |
m_bThinSplitter | CXTPPropertyGridPaintManager | protected
m_bTransparent | CXTPPropertyGridPaintManager |
m_buttonsStyle | CXTPPropertyGridPaintManager |
m_clrCategorySeparator | CXTPPropertyGridPaintManager |
m_clrFace | CXTPPropertyGridPaintManager |
m_clrHighlight | CXTPPropertyGridPaintManager |
m_clrHighlightText | CXTPPropertyGridPaintManager |
m_clrNonHighlightBack | CXTPPropertyGridPaintManager |
m_clrNonHighlightText | CXTPPropertyGridPaintManager |
m_clrShadow | CXTPPropertyGridPaintManager |
m_clrSplitter | CXTPPropertyGridPaintManager |
m_nHelpHeight | CXTPPropertyGridPaintManager | protected
m_nItemsBorderHeight | CXTPPropertyGridPaintManager | protected
m_nSplitterHeight | CXTPPropertyGridPaintManager | protected
m_nVerbsHeight | CXTPPropertyGridPaintManager | protected
m_pGrid | CXTPPropertyGridPaintManager | protected
m_pMetrics | CXTPPropertyGridPaintManager | protected
m_themeButton | CXTPPropertyGridPaintManager |
m_themeCombo | CXTPPropertyGridPaintManager |
m_themeTree | CXTPPropertyGridPaintManager |
MeasureItem(LPMEASUREITEMSTRUCT lpMeasureItemStruct) | CXTPPropertyGridPaintManager | virtual
OnNcCalcSize(RECT &rc) | CXTPPropertyGridPaintManager | virtual
RefreshMetrics() | CXTPPropertyGridPaintManager | virtual
SetItemsBorderHeight(int nHeight) | CXTPPropertyGridPaintManager | virtual
SetThinSplitter(BOOL bThinSplitter) | CXTPPropertyGridPaintManager | virtual
~CXTPPropertyGridPaintManager() | CXTPPropertyGridPaintManager | virtual


Toolkit Pro: Member List

CXTPCalendarEvents Member List

This is the complete list of members for CXTPCalendarEvents, including all inherited members.

Add(CXTPCalendarEvent *pNewEvent, BOOL bWithAddRef=TRUE) | CXTPCalendarEvents |
Append(CXTPCalendarEvents *pEventsArray) | CXTPCalendarEvents |
CloneEvents() | CXTPCalendarEvents |
CompareEvents_ByID(const CXTPCalendarEvent **ppEv1, const CXTPCalendarEvent **ppEv2) | CXTPCalendarEvents | static
CompareEvents_ForView(const CXTPCalendarEvent **ppEv1, const CXTPCalendarEvent **ppEv2) | CXTPCalendarEvents | static
CompareEvents_ForViewByStart(const CXTPCalendarEvent **ppEv1, const CXTPCalendarEvent **ppEv2) | CXTPCalendarEvents | static
CXTPCalendarEvents() | CXTPCalendarEvents |
CXTPCmdTarget() | CXTPCmdTarget |
Find(CXTPCalendarEvent *pFEvent) const | CXTPCalendarEvents |
Find(DWORD dwEventID) const | CXTPCalendarEvents |
FindEvent(DWORD dwEventID) const | CXTPCalendarEvents |
FindEvent(CXTPCalendarEvent *pFEvent) const | CXTPCalendarEvents |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAt(int nIndex, BOOL bWithAddRef=FALSE) const | CXTPCalendarEvents |
GetCount() const | CXTPCalendarEvents |
InsertAt(int nIndex, CXTPCalendarEvent *pEvent, BOOL bWithAddRef=TRUE) | CXTPCalendarEvents |
m_arEvents | CXTPCalendarEvents | protected
RemoveAll() | CXTPCalendarEvents |
RemoveAt(int nIndex) | CXTPCalendarEvents |
RemoveByID(DWORD dwEventID) | CXTPCalendarEvents |
SetAt(int nIndex, CXTPCalendarEvent *pEvent, BOOL bWithAddRef=TRUE) | CXTPCalendarEvents |
SetSize(int nNewSize, int nGrowBy=-1) | CXTPCalendarEvents |
Sort(T_CompareFunc pCompareFunc) | CXTPCalendarEvents |
T_CompareFunc typedef | CXTPCalendarEvents |
~CXTPCalendarEvents() | CXTPCalendarEvents | virtual


Toolkit Pro: XTPDockingPaneAutoHidePanel.h Source File

  • Source
  • DockingPane
XTPDockingPaneAutoHidePanel.h
Go to the documentation of this file.
1
23#if !defined(__XTPDOCKINGPANEAUTOHIDEPANEL_H__)
24# define __XTPDOCKINGPANEAUTOHIDEPANEL_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPDockingPaneLayout;
34class CXTPDockingPaneAutoHidePanel;
35
42class _XTP_EXT_CLASS CXTPDockingPaneAutoHideWnd : public CMiniFrameWnd
43{
45 DECLARE_DYNAMIC(CXTPDockingPaneAutoHideWnd)
47private:
48 CXTPDockingPaneAutoHideWnd(CXTPDockingPaneAutoHidePanel* pPanel,
49 CXTPDockingPaneTabbedContainer* pPane);
50
51public:
56 CXTPDockingPaneTabbedContainer* GetPane() const;
57
58protected:
60 DECLARE_MESSAGE_MAP()
61
62 //{{AFX_VIRTUAL(CXTPDockingPaneAutoHideWnd)
63 virtual void PostNcDestroy();
64 //}}AFX_VIRTUAL
65
66 //{{AFX_MSG(CXTPDockingPaneAutoHideWnd)
67 afx_msg void OnClose();
68 afx_msg void OnPaint();
69 afx_msg void OnTimer(UINT_PTR nIDEvent);
70 afx_msg void OnLButtonDown(UINT nFlags, CPoint point);
71 afx_msg void OnMouseMove(UINT nFlags, CPoint point);
72 afx_msg BOOL OnEraseBkgnd(CDC* pDC);
73 //}}AFX_MSG
76private:
77 void CloseWindow();
78 CXTPDockingPaneManager* GetDockingPaneManager() const;
79
80 void GetMinMaxInfo(LPMINMAXINFO pMinMaxInfo, BOOL bIncludeSplitter = TRUE) const;
81
82 void RecalcLayout(BOOL bNotify = TRUE);
83 void DoSlideStep();
84 void Reposition(CRect rc, CRect rcClient);
85 BOOL GetAvailableRect(CRect& rcAvail, CRect& rc) const;
86
87public:
88 static double m_dAnimationDelay;
89 static int m_nAnimationInterval;
90 static int m_nAnimationDuration;
91 static DWORD m_nMouseHoverDelay;
92 static UINT m_nInactiveCollapseDelay;
94private:
95 CXTPDockingPaneTabbedContainer* m_pPane;
96 CXTPDockingPaneAutoHidePanel* m_pPanel;
97 XTPDockingPaneDirection m_direction;
98
99 BOOL m_bHoriz;
100 int m_nSlideStep;
101 int m_nStepsCount;
102 BOOL m_bSlideOut;
103 CRect m_rcWindow;
104 int m_nDeactivationCount;
105 BOOL m_bTracking;
106
107private:
108 friend class CXTPDockingPaneAutoHidePanel;
109};
110
117class _XTP_EXT_CLASS CXTPDockingPaneAutoHidePanel
118 : public CWnd
119 , public CXTPDockingPaneBaseContainer
120 , public CXTPTabManager
121{
122private:
123 class CAutoHidePanelTabManager;
124 class CAutoHidePanelTabManagersArray;
125 class CPanelDropTarget;
126
127protected:
134 CXTPDockingPaneAutoHidePanel(CXTPDockingPaneLayout* pLayout);
135
141 ~CXTPDockingPaneAutoHidePanel();
142
143public:
151 XTPDockingPaneDirection GetDirection() const;
152
160 virtual HWND GetPaneHwnd() const;
161
171 CXTPDockingPane* HitTest(CPoint point) const;
172
180 CXTPTabManagerItem* GetPaneTab(CXTPDockingPane* pPane) const;
181
190 virtual CXTPTabPaintManager* GetPaintManager() const;
191
205 virtual BOOL DrawIcon(CDC* pDC, CPoint pt, CXTPTabManagerItem* pItem, BOOL bDraw,
206 CSize& szIcon) const;
207
214 XTPTabPosition GetPosition() const;
215
222 virtual int GetItemsLength() const;
223
224protected:
232 virtual void OnSizeParentEx(CWnd* pParent, CRect& rect, LPVOID lParam);
233
239 virtual void RemovePane(CXTPDockingPaneBase* pPane);
240
246 virtual void OnChildContainerChanged(CXTPDockingPaneBase* pContainer);
247
253 virtual void _InsertPane(CXTPDockingPaneBase* pPane);
254
262 virtual BOOL DoPropExchange(CXTPPropExchange* pPX);
263
271 void CloseActiveWindow(BOOL bDelayed = FALSE);
272
279 void CloseActiveWindows();
280
287 void ShowPane(CXTPDockingPane* pPane, BOOL bSetFocus = TRUE);
288
295 void RefreshManagersArray(CDC* pDC, CRect rcClient);
296
303 int GetPanelHeight() const;
304
310 virtual void Create(CWnd* pParent);
311
317 virtual void InvalidatePane(BOOL bSelectionChanged);
318
319protected:
321 DECLARE_MESSAGE_MAP()
322
323 virtual void RedrawControl(LPCRECT lpRect, BOOL /*bAnimate*/);
324 virtual void Reposition();
325
326 void DeletePane();
327 void OnFinalRelease();
328
329 //{{AFX_MSG(CXTPDockingPaneAutoHidePanel)
330 afx_msg void OnPaint();
331 afx_msg void OnDraw(CDC* pDC);
332 afx_msg LRESULT OnPrintClient(WPARAM wParam, LPARAM /*lParam*/);
333 afx_msg void OnLButtonDown(UINT nFlags, CPoint point);
334 afx_msg void OnRButtonDown(UINT nFlags, CPoint point);
335 afx_msg void OnRButtonUp(UINT /*nFlags*/, CPoint point);
336 afx_msg void OnMouseMove(UINT nFlags, CPoint point);
337 afx_msg LRESULT OnMouseHover(WPARAM, LPARAM lParam);
338 afx_msg void OnMouseLeave();
339 //}}AFX_MSG
342# ifdef _XTP_ACTIVEX
344private:
345 DECLARE_DISPATCH_MAP()
346 DECLARE_OLETYPELIB_EX(CXTPDockingPaneAutoHidePanel);
347 DECLARE_ENUM_VARIANT(CXTPDockingPaneAutoHidePanel);
348 DECLARE_INTERFACE_MAP()
349 XTP_DECLARE_CMDTARGETPROVIDER_INTERFACE()
350
351 LPDISPATCH OleGetDispatch(BOOL /*bAddRef*/);
352 afx_msg LPDISPATCH OleGetItem(int nIndex);
353 afx_msg int OleGetItemCount();
354 afx_msg LPDISPATCH OleGetContainer();
355 afx_msg int OleGetType();
356 afx_msg LPDISPATCH OleGetPane(int nIndex);
357 afx_msg HWND OleGetHwnd();
358 afx_msg BOOL OleIsEmpty();
359 afx_msg int OleGetPosition();
361# endif
362
363private:
364 void Copy(CXTPDockingPaneBase* pClone, CXTPPaneToPaneMap* pMap, DWORD dwIgnoredOptions);
365 BOOL Create(LPCTSTR lpszClassName, LPCTSTR lpszWindowName, DWORD dwStyle, const RECT& rect,
366 CWnd* pParentWnd, UINT nID, CCreateContext* pContext = NULL);
367
368public:
369 static BOOL m_bCloseActiveWindow;
371protected:
372 CXTPDockingPaneAutoHideWnd* m_pActiveWnd;
373 XTPDockingPaneDirection m_direction;
375private:
376 CAutoHidePanelTabManagersArray* m_pTabManagers;
377 CPanelDropTarget* m_pDropTarget;
378 CRect m_rcFrameRect;
379 int m_nItemsLength;
380
381private:
382 friend class CXTPDockingPaneLayout;
383 friend class CXTPDockingPaneAutoHideWnd;
384 friend class CXTPDockingPaneTabbedContainer;
385 friend class CXTPDockingPaneManager;
386 friend class CPanelDropTarget;
387};
388
389AFX_INLINE BOOL CXTPDockingPaneAutoHidePanel::Create(LPCTSTR lpszClassName, LPCTSTR lpszWindowName,
390 DWORD dwStyle, const RECT& rect,
391 CWnd* pParentWnd, UINT nID,
392 CCreateContext* pContext)
393{
394 return CWnd::Create(lpszClassName, lpszWindowName, dwStyle, rect, pParentWnd, nID, pContext);
395}
396AFX_INLINE XTPDockingPaneDirection CXTPDockingPaneAutoHidePanel::GetDirection() const
397{
398 return m_direction;
399}
400AFX_INLINE HWND CXTPDockingPaneAutoHidePanel::GetPaneHwnd() const
401{
402 return CWnd::GetSafeHwnd();
403}
404AFX_INLINE CXTPDockingPaneTabbedContainer* CXTPDockingPaneAutoHideWnd::GetPane() const
405{
406 return m_pPane;
407}
409# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
410#endif // #if !defined(__XTPDOCKINGPANEAUTOHIDEPANEL_H__)
XTPDisableNoisyWarnings.h
XTPDockingPaneDirection
XTPDockingPaneDirection
Docking direction enumeration.
Definition XTPDockingPaneDefines.h:51
CXTPPaneToPaneMap
CMap< CXTPDockingPaneBase *, CXTPDockingPaneBase *, CXTPDockingPaneBase *, CXTPDockingPaneBase * > CXTPPaneToPaneMap
This map is used for mapping CXTPDockingPaneBase objects.
Definition XTPDockingPaneDefines.h:514
XTPEnableNoisyWarnings.h
XTP_DECLARE_CMDTARGETPROVIDER_INTERFACE
#define XTP_DECLARE_CMDTARGETPROVIDER_INTERFACE()
When deriving from CXTPCmdTarget is not possible this macro can be used in addition to standard DECLA...
Definition XTPFramework.h:89
XTPTabPosition
XTPTabPosition
XTPTabPosition is an enumeration used to set the position of tabs.
Definition XTPTabManagerDefines.h:200
CXTPDockingPaneAutoHidePanel
CXTPDockingPaneAutoHidePanel is a multiple inheritance class derived from CWnd and CXTPDockingPaneBas...
Definition XTPDockingPaneAutoHidePanel.h:121
CXTPDockingPaneAutoHidePanel::RemovePane
virtual void RemovePane(CXTPDockingPaneBase *pPane)
Call this member to remove a pane from the collection.
CXTPDockingPaneAutoHidePanel::OnChildContainerChanged
virtual void OnChildContainerChanged(CXTPDockingPaneBase *pContainer)
This member is called when a child pane collection is changed.
CXTPDockingPaneAutoHidePanel::DrawIcon
virtual BOOL DrawIcon(CDC *pDC, CPoint pt, CXTPTabManagerItem *pItem, BOOL bDraw, CSize &szIcon) const
This member is called when the icon of the tab in the tabbed container needs to be drawn (i....
CXTPDockingPaneAutoHidePanel::m_pActiveWnd
CXTPDockingPaneAutoHideWnd * m_pActiveWnd
Active window.
Definition XTPDockingPaneAutoHidePanel.h:372
CXTPDockingPaneAutoHidePanel::DoPropExchange
virtual BOOL DoPropExchange(CXTPPropExchange *pPX)
Call this member function to save/restore the settings of the pane.
CXTPDockingPaneAutoHidePanel::InvalidatePane
virtual void InvalidatePane(BOOL bSelectionChanged)
This member is called when a pane must be redrawn.
CXTPDockingPaneAutoHidePanel::OnSizeParentEx
virtual void OnSizeParentEx(CWnd *pParent, CRect &rect, LPVOID lParam)
This method is called to set the position of the pane.
CXTPDockingPaneAutoHidePanel::RefreshManagersArray
void RefreshManagersArray(CDC *pDC, CRect rcClient)
Call this member to refresh the manager array.
CXTPDockingPaneAutoHidePanel::ShowPane
void ShowPane(CXTPDockingPane *pPane, BOOL bSetFocus=TRUE)
Call this member to show (activate) a pane by its identifier.
CXTPDockingPaneAutoHidePanel::HitTest
CXTPDockingPane * HitTest(CPoint point) const
This member function determines which header item, if any, is at a specified cursor position.
CXTPDockingPaneAutoHidePanel::~CXTPDockingPaneAutoHidePanel
~CXTPDockingPaneAutoHidePanel()
Destroys a CXTPDockingPaneAutoHidePanel object, handles cleanup and deallocation.
CXTPDockingPaneAutoHidePanel::m_direction
XTPDockingPaneDirection m_direction
Location of hidden panel.
Definition XTPDockingPaneAutoHidePanel.h:373
CXTPDockingPaneAutoHidePanel::GetDirection
XTPDockingPaneDirection GetDirection() const
Call this member function to determine the position of the auto-hide panel.
Definition XTPDockingPaneAutoHidePanel.h:396
CXTPDockingPaneAutoHidePanel::GetPanelHeight
int GetPanelHeight() const
Retrieves the height of the panel.
CXTPDockingPaneAutoHidePanel::GetPaneHwnd
virtual HWND GetPaneHwnd() const
Retrieves the window handle for a window.
Definition XTPDockingPaneAutoHidePanel.h:400
CXTPDockingPaneAutoHidePanel::CloseActiveWindow
void CloseActiveWindow(BOOL bDelayed=FALSE)
Call this member to close the active window from a panel.
CXTPDockingPaneAutoHidePanel::GetItemsLength
virtual int GetItemsLength() const
Call this member to get the length of the items in the auto-hide panel.
CXTPDockingPaneAutoHidePanel::GetPaneTab
CXTPTabManagerItem * GetPaneTab(CXTPDockingPane *pPane) const
Call this member to get the tab for a corresponding pane.
CXTPDockingPaneAutoHidePanel::Create
virtual void Create(CWnd *pParent)
Creates an auto-hide panel.
CXTPDockingPaneAutoHidePanel::CXTPDockingPaneAutoHidePanel
CXTPDockingPaneAutoHidePanel(CXTPDockingPaneLayout *pLayout)
Constructs a CXTPDockingPaneAutoHidePanel object.
CXTPDockingPaneAutoHidePanel::_InsertPane
virtual void _InsertPane(CXTPDockingPaneBase *pPane)
Call this member to insert a pane into a collection.
CXTPDockingPaneAutoHidePanel::GetPosition
XTPTabPosition GetPosition() const
Call this member to get the position of the pane's tab in the auto-hide panel.
CXTPDockingPaneAutoHidePanel::m_bCloseActiveWindow
static BOOL m_bCloseActiveWindow
TRUE to allow the auto-hide window to be closed.
Definition XTPDockingPaneAutoHidePanel.h:369
CXTPDockingPaneAutoHidePanel::CloseActiveWindows
void CloseActiveWindows()
Call this member to close active windows from all panels.
CXTPDockingPaneAutoHidePanel::GetPaintManager
virtual CXTPTabPaintManager * GetPaintManager() const
This member is called to access the visual elements of the docking pane tabs (i.e.
CXTPDockingPaneAutoHideWnd
CXTPDockingPaneAutoHideWnd is a CMiniFrameWnd derived class.
Definition XTPDockingPaneAutoHidePanel.h:43
CXTPDockingPaneAutoHideWnd::GetPane
CXTPDockingPaneTabbedContainer * GetPane() const
Definition XTPDockingPaneAutoHidePanel.h:404
CXTPDockingPaneAutoHideWnd::m_dAnimationDelay
static double m_dAnimationDelay
Animation delay.
Definition XTPDockingPaneAutoHidePanel.h:88
CXTPDockingPaneAutoHideWnd::m_nInactiveCollapseDelay
static UINT m_nInactiveCollapseDelay
Delay before collapsing inactive.
Definition XTPDockingPaneAutoHidePanel.h:92
CXTPDockingPaneAutoHideWnd::m_nAnimationInterval
static int m_nAnimationInterval
Delay in ms between animation steps.
Definition XTPDockingPaneAutoHidePanel.h:89
CXTPDockingPaneAutoHideWnd::m_nAnimationDuration
static int m_nAnimationDuration
Duration of sliding animation in ms.
Definition XTPDockingPaneAutoHidePanel.h:90
CXTPDockingPaneAutoHideWnd::m_nMouseHoverDelay
static DWORD m_nMouseHoverDelay
Duration of mouse hover before expanding.
Definition XTPDockingPaneAutoHidePanel.h:91
CXTPDockingPaneBaseContainer
CXTPDockingPaneBaseContainer is a CXTPDockingPaneBase derived class.
Definition XTPDockingPaneBaseContainer.h:39
CXTPDockingPaneBase
CXTPDockingPaneBase is a standalone class.
Definition XTPDockingPaneBase.h:69
CXTPDockingPane
CXTPDockingPane is a CXTPDockingPaneBase derived class.
Definition XTPDockingPane.h:44
CXTPDockingPaneLayout
CXTPDockingPaneLayout is a standalone class.
Definition XTPDockingPaneLayout.h:54
CXTPDockingPaneManager
CXTPDockingPaneManager is a CWnd derived class.
Definition XTPDockingPaneManager.h:58
CXTPDockingPaneTabbedContainer
CXTPDockingPaneTabbedContainer is a multiple inheritance class derived from CWnd and CXTPDockingPaneB...
Definition XTPDockingPaneTabbedContainer.h:47
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72
CXTPTabManager
CXTPTabManager is the base class for docking pane tabs, tab control tabs, and MDI client tabs.
Definition XTPTabManager.h:87
CXTPTabManagerItem
CXTPTabManagerItem is the base class for the tabs that appear in the command bars tab workspace,...
Definition XTPTabManagerItem.h:44
CXTPTabPaintManager
CXTPTabPaintManager is used to store the color and appearance information of the tabs in the tab mana...
Definition XTPTabPaintManager.h:48


Toolkit Pro: XTPSplitterWndTheme.h Source File

  • Source
  • Controls
  • Splitter
XTPSplitterWndTheme.h
Go to the documentation of this file.
1
23#if !defined(__XTPSPLITTERTHEME_H__)
24# define __XTPSPLITTERTHEME_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPSplitterWnd;
34
40class _XTP_EXT_CLASS CXTPSplitterWndTheme : public CXTPControlTheme
41{
42public:
47 CXTPSplitterWndTheme();
48
54 virtual void RefreshMetrics();
55
66 virtual void DrawSplitter(CDC* pDC, CXTPSplitterWnd* pSplitter, int nType,
67 const CRect& rectArg);
68
74 void EnableTabColors(BOOL bEnable = TRUE);
75
83 virtual CBrush* GetTrackBrush();
84
85public:
86 BOOL m_bTabColors;
87 CXTPPaintManagerColorGradient m_crBack;
88 CXTPPaintManagerColorGradient m_crBoxBack;
89 CXTPPaintManagerColorGradient m_crOuterBorder;
90 CXTPPaintManagerColorGradient m_crOuterBoxBorder;
92 CXTPPaintManagerColorGradient m_crInnerBorder;
93 CXTPPaintManagerColorGradient m_crInnerBoxBorder;
95};
96
102class _XTP_EXT_CLASS CXTPSplitterWndThemeOfficeXP : public CXTPSplitterWndTheme
103{
104public:
109 CXTPSplitterWndThemeOfficeXP();
110
116 virtual void RefreshMetrics();
117
125 virtual CBrush* GetTrackBrush();
126};
127
133class _XTP_EXT_CLASS CXTPSplitterWndThemeOffice2003 : public CXTPSplitterWndThemeOfficeXP
134{
135public:
140 CXTPSplitterWndThemeOffice2003();
141
147 virtual void RefreshMetrics();
148
159 virtual void DrawSplitter(CDC* pDC, CXTPSplitterWnd* pSplitter, int nType,
160 const CRect& rectArg);
161};
162
168class _XTP_EXT_CLASS CXTPSplitterWndThemeResource : public CXTPSplitterWndThemeOffice2003
169{
170public:
175 CXTPSplitterWndThemeResource();
176
182 virtual void RefreshMetrics();
183};
184
190class _XTP_EXT_CLASS CXTPSplitterWndThemeVisualStudio2010 : public CXTPSplitterWndThemeOffice2003
191{
192public:
197 CXTPSplitterWndThemeVisualStudio2010();
198
204 virtual void RefreshMetrics();
205
216 virtual void DrawSplitter(CDC* pDC, CXTPSplitterWnd* pSplitter, int nType,
217 const CRect& rectArg);
218};
219
225class _XTP_EXT_CLASS CXTPSplitterWndThemeOffice2013 : public CXTPSplitterWndThemeOfficeXP
226{
227public:
232 CXTPSplitterWndThemeOffice2013();
233
239 virtual void RefreshMetrics();
240};
241
247class _XTP_EXT_CLASS CXTPSplitterWndThemeVisualStudio2015 : public CXTPSplitterWndThemeOffice2013
248{
249public:
254 CXTPSplitterWndThemeVisualStudio2015();
255};
256
262class _XTP_EXT_CLASS CXTPSplitterWndThemeVisualStudio2017 : public CXTPSplitterWndThemeOffice2013
263{
264public:
269 CXTPSplitterWndThemeVisualStudio2017();
270};
271
277class _XTP_EXT_CLASS CXTPSplitterWndThemeVisualStudio2019 : public CXTPSplitterWndThemeOffice2013
278{
279public:
284 CXTPSplitterWndThemeVisualStudio2019();
285};
286
292class _XTP_EXT_CLASS CXTPSplitterWndThemeVisualStudio2022 : public CXTPSplitterWndThemeOffice2013
293{
294public:
299 CXTPSplitterWndThemeVisualStudio2022();
300};
301
303
304# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
306#endif // !defined(__XTPSPLITTERTHEME_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPControlTheme
CXTPControlTheme can be used as a base class for user defined themes.
Definition XTPControlTheme.h:95
CXTPPaintManagerColorGradient
The CXTPPaintManagerColorGradient class is used to manage COLORREF values for determining light and d...
Definition XTPColorManager.h:301
CXTPSplitterWnd
CXTPSplitterWnd is a CSplitterWnd derived class.
Definition XTPSplitterWnd.h:41
CXTPSplitterWndTheme
Class CXTPSplitterWndTheme is derived from CXTPControlTheme.
Definition XTPSplitterWndTheme.h:41
CXTPSplitterWndTheme::m_crOuterBorder
CXTPPaintManagerColorGradient m_crOuterBorder
Splitter window outer border color.
Definition XTPSplitterWndTheme.h:89
CXTPSplitterWndTheme::CXTPSplitterWndTheme
CXTPSplitterWndTheme()
Constructs a CXTPSplitterWndTheme object.
CXTPSplitterWndTheme::m_bTabColors
BOOL m_bTabColors
TRUE to use tab background color from resource.
Definition XTPSplitterWndTheme.h:86
CXTPSplitterWndTheme::m_crInnerBorder
CXTPPaintManagerColorGradient m_crInnerBorder
Splitter window inner border color.
Definition XTPSplitterWndTheme.h:92
CXTPSplitterWndTheme::EnableTabColors
void EnableTabColors(BOOL bEnable=TRUE)
Call this member function to use tab background color from resource.
CXTPSplitterWndTheme::m_crOuterBoxBorder
CXTPPaintManagerColorGradient m_crOuterBoxBorder
Splitter box window outer border color.
Definition XTPSplitterWndTheme.h:90
CXTPSplitterWndTheme::GetTrackBrush
virtual CBrush * GetTrackBrush()
Call this function to retrieve a pointer to the brush used by the split tracker.
CXTPSplitterWndTheme::DrawSplitter
virtual void DrawSplitter(CDC *pDC, CXTPSplitterWnd *pSplitter, int nType, const CRect &rectArg)
Call this member function to draw the splitter window using the specified theme.
CXTPSplitterWndTheme::m_crBack
CXTPPaintManagerColorGradient m_crBack
Splitter window background color.
Definition XTPSplitterWndTheme.h:87
CXTPSplitterWndTheme::m_crInnerBoxBorder
CXTPPaintManagerColorGradient m_crInnerBoxBorder
Splitter box window inner border color.
Definition XTPSplitterWndTheme.h:93
CXTPSplitterWndTheme::RefreshMetrics
virtual void RefreshMetrics()
Call this function to set the splitter windows face and the borders to the system default colors.
CXTPSplitterWndTheme::m_crBoxBack
CXTPPaintManagerColorGradient m_crBoxBack
Splitter box window background color.
Definition XTPSplitterWndTheme.h:88
CXTPSplitterWndThemeOffice2003
Class CXTPSplitterWndThemeOffice2003 is derived from CXTPSplitterWndTheme.
Definition XTPSplitterWndTheme.h:134
CXTPSplitterWndThemeOffice2003::CXTPSplitterWndThemeOffice2003
CXTPSplitterWndThemeOffice2003()
Constructs a CXTPSplitterWndThemeOffice2003 object.
CXTPSplitterWndThemeOffice2003::DrawSplitter
virtual void DrawSplitter(CDC *pDC, CXTPSplitterWnd *pSplitter, int nType, const CRect &rectArg)
Call this member function to draw the splitter window using the specified theme.
CXTPSplitterWndThemeOffice2003::RefreshMetrics
virtual void RefreshMetrics()
Call this function to set the splitter windows face and the borders to the system default colors.
CXTPSplitterWndThemeOffice2013
Class CXTPSplitterWndThemeOffice2013 is derived from CXTPSplitterWndThemeOfficeXP.
Definition XTPSplitterWndTheme.h:226
CXTPSplitterWndThemeOffice2013::CXTPSplitterWndThemeOffice2013
CXTPSplitterWndThemeOffice2013()
Constructs a CXTPSplitterWndThemeOffice2013 object.
CXTPSplitterWndThemeOffice2013::RefreshMetrics
virtual void RefreshMetrics()
Call this function to set the splitter windows face and the borders to the system default colors.
CXTPSplitterWndThemeOfficeXP
Class CXTPSplitterWndThemeOfficeXP is derived from CXTPSplitterWndTheme.
Definition XTPSplitterWndTheme.h:103
CXTPSplitterWndThemeOfficeXP::GetTrackBrush
virtual CBrush * GetTrackBrush()
Call this function to retrieve a pointer to the brush used by the split tracker.
CXTPSplitterWndThemeOfficeXP::CXTPSplitterWndThemeOfficeXP
CXTPSplitterWndThemeOfficeXP()
Constructs a CXTPSplitterWndThemeOfficeXP object.
CXTPSplitterWndThemeOfficeXP::RefreshMetrics
virtual void RefreshMetrics()
Call this function to set the splitter windows face and the borders to the system default colors.
CXTPSplitterWndThemeResource
Class CXTPSplitterWndThemeResource is derived from CXTPSplitterWndTheme.
Definition XTPSplitterWndTheme.h:169
CXTPSplitterWndThemeResource::CXTPSplitterWndThemeResource
CXTPSplitterWndThemeResource()
Constructs a CXTPSplitterWndThemeResource object.
CXTPSplitterWndThemeResource::RefreshMetrics
virtual void RefreshMetrics()
Call this function to set the splitter windows face and the borders to the system default colors.
CXTPSplitterWndThemeVisualStudio2010
Class CXTPSplitterWndThemeVisualStudio2010 is derived from CXTPSplitterWndTheme.
Definition XTPSplitterWndTheme.h:191
CXTPSplitterWndThemeVisualStudio2010::CXTPSplitterWndThemeVisualStudio2010
CXTPSplitterWndThemeVisualStudio2010()
Constructs a CXTPSplitterWndThemeVisualStudio2010 object.
CXTPSplitterWndThemeVisualStudio2010::DrawSplitter
virtual void DrawSplitter(CDC *pDC, CXTPSplitterWnd *pSplitter, int nType, const CRect &rectArg)
Call this member function to draw the splitter window using the specified theme.
CXTPSplitterWndThemeVisualStudio2010::RefreshMetrics
virtual void RefreshMetrics()
Call this function to set the splitter windows face and the borders to the system default colors.
CXTPSplitterWndThemeVisualStudio2015
Class CXTPSplitterWndThemeVisualStudio2015 is derived from CXTPSplitterWndThemeOffice2013.
Definition XTPSplitterWndTheme.h:248
CXTPSplitterWndThemeVisualStudio2015::CXTPSplitterWndThemeVisualStudio2015
CXTPSplitterWndThemeVisualStudio2015()
Constructs a CXTPSplitterWndThemeVisualStudio2015 object.
CXTPSplitterWndThemeVisualStudio2017
Class CXTPSplitterWndThemeVisualStudio2017 is derived from CXTPSplitterWndThemeOffice2013.
Definition XTPSplitterWndTheme.h:263
CXTPSplitterWndThemeVisualStudio2017::CXTPSplitterWndThemeVisualStudio2017
CXTPSplitterWndThemeVisualStudio2017()
Constructs a CXTPSplitterWndThemeVisualStudio2017 object.
CXTPSplitterWndThemeVisualStudio2019
Class CXTPSplitterWndThemeVisualStudio2019 is derived from CXTPSplitterWndThemeOffice2013.
Definition XTPSplitterWndTheme.h:278
CXTPSplitterWndThemeVisualStudio2019::CXTPSplitterWndThemeVisualStudio2019
CXTPSplitterWndThemeVisualStudio2019()
Constructs a CXTPSplitterWndThemeVisualStudio2019 object.
CXTPSplitterWndThemeVisualStudio2022
Class CXTPSplitterWndThemeVisualStudio2022 is derived from CXTPSplitterWndThemeOffice2013.
Definition XTPSplitterWndTheme.h:293
CXTPSplitterWndThemeVisualStudio2022::CXTPSplitterWndThemeVisualStudio2022
CXTPSplitterWndThemeVisualStudio2022()
Constructs a CXTPSplitterWndThemeVisualStudio2022 object.


Toolkit Pro: Member List

CXTPChartRangeBarSeriesLabel Member List

This is the complete list of members for CXTPChartRangeBarSeriesLabel, including all inherited members.

CreateView(CXTPChartDeviceContext *pDC, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView) | CXTPChartRangeBarSeriesLabel | virtual
CXTPChartDiagram2DSeriesLabel() | CXTPChartDiagram2DSeriesLabel |
CXTPChartElement() | CXTPChartElement |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartRangeBarSeriesLabel() | CXTPChartRangeBarSeriesLabel |
CXTPChartSeriesLabel() | CXTPChartSeriesLabel |
DoPropExchange(CXTPPropExchange *pPX) | CXTPChartRangeBarSeriesLabel | virtual
GetAntialiasing() const | CXTPChartSeriesLabel | virtual
GetAppearance() const | CXTPChartElement |
GetBackColor() const | CXTPChartSeriesLabel |
GetContent() const | CXTPChartElement |
GetFont() const | CXTPChartSeriesLabel | virtual
GetFormat() const | CXTPChartSeriesLabel |
GetLineColor() const | CXTPChartSeriesLabel |
GetLineLength() const | CXTPChartSeriesLabel |
GetOwner() const | CXTPChartElement |
GetShowLines() const | CXTPChartSeriesLabel |
GetTextColor() const | CXTPChartSeriesLabel |
GetTransparency() const | CXTPChartSeriesLabel |
Is3D() const | CXTPChartObject |
IsVisible() const | CXTPChartSeriesLabel |
m_bAntialiasing | CXTPChartSeriesLabel | protected
m_bShowLines | CXTPChartSeriesLabel | protected
m_bVisible | CXTPChartSeriesLabel | protected
m_clrBackColor | CXTPChartSeriesLabel | protected
m_clrLineColor | CXTPChartSeriesLabel | protected
m_clrTextColor | CXTPChartSeriesLabel | protected
m_nLineLength | CXTPChartSeriesLabel | protected
m_nTransparency | CXTPChartSeriesLabel | protected
m_pBorder | CXTPChartSeriesLabel | protected
m_pFont | CXTPChartSeriesLabel | protected
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartElement | virtual
Release() | CXTPChartElement | virtual
SetAntialiasing(BOOL bAntialiasing) | CXTPChartSeriesLabel |
SetBackColor(const CXTPChartColor &clrBackColor) | CXTPChartSeriesLabel |
SetFont(CXTPChartFont *pFont) | CXTPChartSeriesLabel |
SetFormat(LPCTSTR lpszFormat) | CXTPChartSeriesLabel |
SetLineColor(const CXTPChartColor &clrBackColor) | CXTPChartSeriesLabel |
SetLineLength(int nLineLength) | CXTPChartSeriesLabel |
SetShowLines(BOOL bShowLines) | CXTPChartSeriesLabel |
SetTextColor(const CXTPChartColor &clrTextColor) | CXTPChartSeriesLabel |
SetTransparency(int nTransparency) | CXTPChartSeriesLabel |
SetVisible(BOOL bVisible) | CXTPChartSeriesLabel |
~CXTPChartDiagram2DSeriesLabel() | CXTPChartDiagram2DSeriesLabel | virtual
~CXTPChartElement() | CXTPChartElement | virtual
~CXTPChartRangeBarSeriesLabel() | CXTPChartRangeBarSeriesLabel | virtual
~CXTPChartSeriesLabel() | CXTPChartSeriesLabel | virtual


Toolkit Pro: Member List

CXTPGridFilterEditControl Member List

This is the complete list of members for CXTPGridFilterEditControl, including all inherited members.

CXTPGridFilterEditControl() | CXTPGridFilterEditControl |
GetGridCtrl() | CXTPGridFilterEditControl |
GetHint() const | CXTPGridFilterEditControl |
GetText() const | CXTPGridFilterEditControl |
m_pGridCtrl | CXTPGridFilterEditControl | protected
m_strHint | CXTPGridFilterEditControl | protected
SetGridCtrl(CXTPGridControl *pGridCtrl) | CXTPGridFilterEditControl |
SetHint(LPCTSTR lpszHint) | CXTPGridFilterEditControl |
SetText(const CString &lpszText) | CXTPGridFilterEditControl |
~CXTPGridFilterEditControl() | CXTPGridFilterEditControl |


Toolkit Pro: Member List

  • XTP_CALENDAR_RECURRENCE_OPTIONS
  • PATTERN_YEARNTH
XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_YEARNTH Member List

This is the complete list of members for XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_YEARNTH, including all inherited members.

nMonthOfYear | XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_YEARNTH
nWhichDay | XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_YEARNTH
nWhichDayMask | XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_YEARNTH


Toolkit Pro: Member List

CXTPShortcutBarNativeWindows11Theme Member List

This is the complete list of members for CXTPShortcutBarNativeWindows11Theme, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPShortcutBarNativeWindows11Theme() | CXTPShortcutBarNativeWindows11Theme |
CXTPShortcutBarOffice2003Theme() | CXTPShortcutBarOffice2003Theme |
CXTPShortcutBarOffice2013Theme() | CXTPShortcutBarOffice2013Theme |
CXTPShortcutBarPaintManager() | CXTPShortcutBarPaintManager |
CXTPShortcutBarResourceTheme() | CXTPShortcutBarResourceTheme |
DrawExpandButton(CDC *pDC, CRect rc) | CXTPShortcutBarOffice2013Theme | virtual
DrawGripper(CDC *pDC, CXTPShortcutBar *pShortcutBar, BOOL bDraw) | CXTPShortcutBarOffice2013Theme | virtual
DrawImage(CDC *pDC, CPoint pt, CSize sz, CXTPImageManagerIcon *pImage, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled) | CXTPShortcutBarOffice2003Theme | virtual
DrawNavigationItem(CDC *pDC, CXTPShortcutBarItem *pItem) | CXTPShortcutBarPaintManager | virtual
DrawPaneCaption(CDC *pDC, CXTPShortcutBarPane *pPane, BOOL bDraw) | CXTPShortcutBarResourceTheme | virtual
DrawPaneItemCaption(CDC *pDC, CXTPShortcutBarPaneItem *pItem, BOOL bDraw) | CXTPShortcutBarNativeWindows11Theme | virtual
DrawShortcutBarFrame(CDC *pDC, CXTPShortcutBar *pShortcutBar) | CXTPShortcutBarOffice2003Theme | virtual
DrawShortcutItem(CDC *pDC, CXTPShortcutBarItem *pItem) | CXTPShortcutBarPaintManager | virtual
FillNavigationItemEntry(CDC *pDC, CXTPShortcutBarItem *pItem) | CXTPShortcutBarNativeWindows11Theme | virtual
FillShortcutBar(CDC *pDC, CXTPShortcutBar *pShortcutBar) | CXTPShortcutBarOffice2013Theme | virtual
FillShortcutItemEntry(CDC *pDC, CXTPShortcutBarItem *pItem) | CXTPShortcutBarNativeWindows11Theme | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
IsShortcutItemTruncated(CDC *pDC, CXTPShortcutBarItem *pItem) | CXTPShortcutBarPaintManager |
Line(CDC *pDC, int x0, int y0, int x1, int y1, int nPen) | CXTPShortcutBarPaintManager |
m_bBoldItemCaptionFont | CXTPShortcutBarPaintManager |
m_bClearTypeTextQuality | CXTPShortcutBarPaintManager |
m_bHiliteBorders | CXTPShortcutBarNativeWindows11Theme | protected
m_bNavigationButton | CXTPShortcutBarPaintManager |
m_bShowTopLeftCaptionShadow | CXTPShortcutBarOffice2003Theme |
m_bUseStandardFont | CXTPShortcutBarPaintManager |
m_clrBackHiliteSelected | CXTPShortcutBarNativeWindows11Theme | protected
m_clrBorderHilite | CXTPShortcutBarNativeWindows11Theme | protected
m_clrCaptionText | CXTPShortcutBarOffice2003Theme |
m_clrDisabledText | CXTPShortcutBarPaintManager |
m_clrGlyph | CXTPShortcutBarOffice2013Theme | protected
m_clrGlyphExpanded | CXTPShortcutBarOffice2013Theme | protected
m_clrGlyphFill | CXTPShortcutBarOffice2013Theme | protected
m_clrGlyphPushed | CXTPShortcutBarOffice2013Theme | protected
m_clrHotText | CXTPShortcutBarPaintManager |
m_clrItemCaptionShadow | CXTPShortcutBarOffice2003Theme |
m_clrItemCaptionText | CXTPShortcutBarOffice2003Theme |
m_clrItemCaptionTop | CXTPShortcutBarOffice2003Theme |
m_clrNormalText | CXTPShortcutBarPaintManager |
m_clrPushedText | CXTPShortcutBarPaintManager |
m_clrSelectedText | CXTPShortcutBarPaintManager |
m_clrShortcutItemShadow | CXTPShortcutBarPaintManager |
m_grcCaption | CXTPShortcutBarOffice2003Theme |
m_grcHot | CXTPShortcutBarPaintManager |
m_grcItemCaption | CXTPShortcutBarOffice2003Theme |
m_grcItemHotCaption | CXTPShortcutBarOffice2003Theme |
m_grcPushed | CXTPShortcutBarPaintManager |
m_grcSelected | CXTPShortcutBarPaintManager |
m_grcShortcutBarGripper | CXTPShortcutBarPaintManager |
m_grcShortcutItem | CXTPShortcutBarPaintManager |
m_nExpandedIconWidth | CXTPShortcutBarPaintManager |
m_nNormalIconWidth | CXTPShortcutBarPaintManager |
m_nPaneItemHeight | CXTPShortcutBarPaintManager |
m_pExpandIcon | CXTPShortcutBarPaintManager |
m_rcCaptionPadding | CXTPShortcutBarPaintManager |
m_rcItemCaptionPadding | CXTPShortcutBarPaintManager |
m_strOfficeFont | CXTPShortcutBarPaintManager |
m_xtpFontPaneCaption | CXTPShortcutBarPaintManager |
m_xtpFontPaneItemCaption | CXTPShortcutBarPaintManager |
m_xtpFontText | CXTPShortcutBarPaintManager |
m_xtpFontVerticalText | CXTPShortcutBarPaintManager |
Rectangle(CDC *pDC, CRect rc, int nPen, int nBrush) | CXTPShortcutBarPaintManager |
RefreshMetrics() | CXTPShortcutBarNativeWindows11Theme | virtual
~CXTPShortcutBarNativeWindows11Theme() | CXTPShortcutBarNativeWindows11Theme | virtual
~CXTPShortcutBarOffice2013Theme() | CXTPShortcutBarOffice2013Theme | virtual
~CXTPShortcutBarPaintManager() | CXTPShortcutBarPaintManager | virtual


Toolkit Pro: Member List

CXTPBrowseDialog Member List

This is the complete list of members for CXTPBrowseDialog, including all inherited members.

BrowseCtrlCallback(HWND hwnd, UINT uMsg, LPARAM lParam, LPARAM lpData) | CXTPBrowseDialog | static
CXTPBrowseDialog(CWnd *pParent=NULL) | CXTPBrowseDialog |
DoModal() | CXTPBrowseDialog |
GetCallback() | CXTPBrowseDialog |
GetData() | CXTPBrowseDialog |
GetDisplayName() | CXTPBrowseDialog |
GetImage() | CXTPBrowseDialog |
GetOptions() | CXTPBrowseDialog |
GetOwner() | CXTPBrowseDialog |
GetPidlRoot() | CXTPBrowseDialog |
GetSelPath() | CXTPBrowseDialog |
GetTitle() | CXTPBrowseDialog |
m_szSelPath | CXTPBrowseDialog | protected
SetCallback(BFFCALLBACK pf) | CXTPBrowseDialog |
SetData(LPARAM lp) | CXTPBrowseDialog |
SetDisplayName(LPCTSTR szDisplayName) | CXTPBrowseDialog |
SetOptions(UINT uf) | CXTPBrowseDialog |
SetOwner(HWND hWnd) | CXTPBrowseDialog |
SetPidlRoot(LPCITEMIDLIST pidl) | CXTPBrowseDialog |
SetSelPath(LPCTSTR szSelPath) | CXTPBrowseDialog |
SetTitle(LPCTSTR szTitle) | CXTPBrowseDialog |
~CXTPBrowseDialog() | CXTPBrowseDialog | virtual


Toolkit Pro: Member List

CXTPSplitterWndThemeResource Member List

This is the complete list of members for CXTPSplitterWndThemeResource, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPControlTheme() | CXTPControlTheme |
CXTPSplitterWndTheme() | CXTPSplitterWndTheme |
CXTPSplitterWndThemeOffice2003() | CXTPSplitterWndThemeOffice2003 |
CXTPSplitterWndThemeOfficeXP() | CXTPSplitterWndThemeOfficeXP |
CXTPSplitterWndThemeResource() | CXTPSplitterWndThemeResource |
DrawSplitter(CDC *pDC, CXTPSplitterWnd *pSplitter, int nType, const CRect &rectArg) | CXTPSplitterWndThemeOffice2003 | virtual
EnableTabColors(BOOL bEnable=TRUE) | CXTPSplitterWndTheme |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetThemeStyle() const | CXTPControlTheme |
GetTrackBrush() | CXTPSplitterWndThemeOfficeXP | virtual
m_bTabColors | CXTPSplitterWndTheme |
m_crBack | CXTPSplitterWndTheme |
m_crBoxBack | CXTPSplitterWndTheme |
m_crInnerBorder | CXTPSplitterWndTheme |
m_crInnerBoxBorder | CXTPSplitterWndTheme |
m_crOuterBorder | CXTPSplitterWndTheme |
m_crOuterBoxBorder | CXTPSplitterWndTheme |
m_nTheme | CXTPControlTheme | protected
RefreshMetrics() | CXTPSplitterWndThemeResource | virtual
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static


Toolkit Pro: Member List

CXTPButtonTheme Member List

This is the complete list of members for CXTPButtonTheme, including all inherited members.

CXTPButtonTheme() | CXTPButtonTheme |
CXTPCmdTarget() | CXTPCmdTarget |
CXTPControlTheme() | CXTPControlTheme |
DrawButton(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
DrawButtonBackground(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
DrawButtonText(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme |
DrawButtonVisualStyleBackground(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
DrawCheckBoxMark(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
DrawFocusRect(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
DrawGroupBox(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
DrawPushButtonDropDown(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
DrawPushButtonIcon(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
DrawPushButtonText(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
DrawRadioButtonMark(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetTextColor(CXTPButton *pButton) | CXTPButtonTheme | virtual
GetThemeStyle() const | CXTPControlTheme |
m_crBack | CXTPButtonTheme |
m_crBorder3DHilite | CXTPButtonTheme |
m_crBorder3DShadow | CXTPButtonTheme |
m_crBorderHilite | CXTPButtonTheme |
m_crBorderShadow | CXTPButtonTheme |
m_crText | CXTPButtonTheme |
m_crTextCheck | CXTPButtonTheme |
m_crTextDisabled | CXTPButtonTheme |
m_nTheme | CXTPControlTheme | protected
RefreshMetrics(CXTPButton *pButton) | CXTPButtonTheme | virtual
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static
~CXTPButtonTheme() | CXTPButtonTheme | virtual


Toolkit Pro: XTPTabThemeVisualStudio2003.h Source File

  • Source
  • TabManager
  • Themes
XTPTabThemeVisualStudio2003.h
Go to the documentation of this file.
1
23#if !defined(__XTPTABTHEMEVISUALSTUDIO2003_H__)
24# define __XTPTABTHEMEVISUALSTUDIO2003_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
50class _XTP_EXT_CLASS CXTPTabThemeVisualStudio2003 : public CXTPTabPaintManagerTheme
51{
52public:
57 CXTPTabThemeVisualStudio2003()
58 {
59 m_rcHeaderMargin.SetRect(4, 2, 4, 0);
60 }
61
77 virtual void DrawSingleButton(CDC* pDC, CXTPTabManagerItem* pItem);
78
98 virtual CRect FillTabControl(CXTPTabManager* pTabManager, CDC* pDC, CRect rcControl);
99
108 virtual XTPTabColorStyle GetDefaultColorSet()
109 {
110 return xtpTabColorVisualStudio2003;
111 }
112};
113
114# define CAppearanceSetVisualStudio CXTPTabThemeVisualStudio2003
115
116# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
118#endif // !defined(__XTPTABTHEMEVISUALSTUDIO2003_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPTabColorStyle
XTPTabColorStyle
XTPTabColorStyle is an enumeration used to set the color style of tabs.
Definition XTPTabManagerDefines.h:139
xtpTabColorVisualStudio2003
@ xtpTabColorVisualStudio2003
Tabs will use the Visual Studio 2003 color style for the currently set Appearance.
Definition XTPTabManagerDefines.h:150
CXTPTabManager
CXTPTabManager is the base class for docking pane tabs, tab control tabs, and MDI client tabs.
Definition XTPTabManager.h:87
CXTPTabManagerItem
CXTPTabManagerItem is the base class for the tabs that appear in the command bars tab workspace,...
Definition XTPTabManagerItem.h:44
CXTPTabPaintManagerTheme
CXTPTabPaintManagerTheme is a class that represents the appearance of all components of the tab manag...
Definition XTPTabPaintManagerTheme.h:56
CXTPTabThemeVisualStudio2003
CXTPTabThemeVisualStudio2003 implements a Visual Studio 2003 tab appearance.
Definition XTPTabThemeVisualStudio2003.h:51
CXTPTabThemeVisualStudio2003::GetDefaultColorSet
virtual XTPTabColorStyle GetDefaultColorSet()
Gets the default value of the color set for this theme.
Definition XTPTabThemeVisualStudio2003.h:108
CXTPTabThemeVisualStudio2003::CXTPTabThemeVisualStudio2003
CXTPTabThemeVisualStudio2003()
Constructs a CXTPTabThemeVisualStudio2003 object.
Definition XTPTabThemeVisualStudio2003.h:57
CXTPTabThemeVisualStudio2003::FillTabControl
virtual CRect FillTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl)
Fills both the tab header and the tab client area and then draws the tab client frame.
CXTPTabThemeVisualStudio2003::DrawSingleButton
virtual void DrawSingleButton(CDC *pDC, CXTPTabManagerItem *pItem)
Draws a single tab button in the tab client header area.


Toolkit Pro: XTPMarkupRadioButton.h Source File

  • Source
  • Markup
  • Controls
XTPMarkupRadioButton.h
Go to the documentation of this file.
1
23#if !defined(__XTPMARKUPRADIOBUTTON_H__)
24# define __XTPMARKUPRADIOBUTTON_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPMarkupRoutedEventArgs;
34class CXTPMarkupDrawingContext;
35
41class _XTP_EXT_CLASS CXTPMarkupRadioButton : public CXTPMarkupToggleButton
42{
44 DECLARE_MARKUPCLASS(CXTPMarkupRadioButton);
46protected:
51 CXTPMarkupRadioButton();
52
57 ~CXTPMarkupRadioButton();
58
59protected:
61 // Implementation
62 void OnRender(CXTPMarkupDrawingContext* pDC);
63 void OnRenderFocusVisual(CXTPMarkupDrawingContext* drawingContext);
64 CSize ArrangeOverride(CSize szFinalSize);
65 CSize MeasureOverride(CXTPMarkupDrawingContext* pDC, CSize szAvailableSize);
66
67protected:
68 void OnToggle();
69 void OnChecked(CXTPMarkupRoutedEventArgs* e);
70
71private:
72 void UpdateRadioButtonGroup();
76public:
77 DECLARE_DISPATCH_MAP()
78# ifdef _XTP_ACTIVEX
79 DECLARE_INTERFACE_MAP()
80 DECLARE_OLETYPELIB_EX(CXTPMarkupRadioButton);
81# endif
82
84};
85
86# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
88#endif // !defined(__XTPMARKUPRADIOBUTTON_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPMarkupRadioButton
CXTPMarkupRadioButton is a CXTPMarkupToggleButton derived class.
Definition XTPMarkupRadioButton.h:42
CXTPMarkupRadioButton::~CXTPMarkupRadioButton
~CXTPMarkupRadioButton()
Destroys a CXTPMarkupRadioButton object, handles cleanup and deallocation.
CXTPMarkupRadioButton::CXTPMarkupRadioButton
CXTPMarkupRadioButton()
Constructs a CXTPMarkupRadioButton object.
CXTPMarkupToggleButton
CXTPMarkupToggleButton is a CXTPMarkupButtonBase derived class.
Definition XTPMarkupToggleButton.h:45
CXTPMarkupToggleButton::OnChecked
virtual void OnChecked(CXTPMarkupRoutedEventArgs *e)
Virtual method called when the user sets the state to checked.
CXTPMarkupToggleButton::OnToggle
virtual void OnToggle()
Virtual method called when the state is toggled by the user.
CXTPMarkupVisual::OnRender
virtual void OnRender(CXTPMarkupDrawingContext *drawingContext)
When overridden in a derived class, participates in rendering operations that are directed by the lay...
Definition XTPMarkupInputElement.h:515
CXTPMarkupVisual::OnRenderFocusVisual
virtual void OnRenderFocusVisual(CXTPMarkupDrawingContext *drawingContext)
This method is called to render the focus rectangle of a focused object.
Definition XTPMarkupInputElement.h:519


Toolkit Pro: Member List

CXTPPopupItem Member List

This is the complete list of members for CXTPPopupItem, including all inherited members.

CalculateHeight() | CXTPPopupItem |
CalculateWidth() | CXTPPopupItem |
CenterIcon() | CXTPPopupItem |
CXTPCmdTarget() | CXTPCmdTarget |
CXTPPopupItem(LPRECT rcItem=NULL, LPCTSTR lpszCaption=NULL, COLORREF clrBack=(COLORREF) -1, COLORREF clrBorder=(COLORREF) -1) | CXTPPopupItem |
Draw(CDC *pDC) | CXTPPopupItem | virtual
FitToContent() | CXTPPopupItem |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetBackgroundColor() const | CXTPPopupItem |
GetBorderColor() const | CXTPPopupItem |
GetCaption() const | CXTPPopupItem |
GetIconIndex() const | CXTPPopupItem |
GetIconOffset() const | CXTPPopupItem |
GetID() const | CXTPPopupItem |
GetImage() const | CXTPPopupItem |
GetMarkupUIElement() const | CXTPPopupItem |
GetPopupControl() const | CXTPPopupItem |
GetRect() const | CXTPPopupItem |
GetRichRender() const | CXTPPopupItem |
GetTextAlignment() const | CXTPPopupItem |
GetTextColor() const | CXTPPopupItem |
GetTextFont() | CXTPPopupItem | virtual
IsBold() const | CXTPPopupItem |
IsButton() const | CXTPPopupItem |
IsHandCursor() const | CXTPPopupItem |
IsHyperLink() const | CXTPPopupItem |
IsPressed() const | CXTPPopupItem |
IsSelected() const | CXTPPopupItem |
IsUnderline() const | CXTPPopupItem |
m_bBold | CXTPPopupItem | protected
m_bButton | CXTPPopupItem | protected
m_bHyperLink | CXTPPopupItem | protected
m_bUnderline | CXTPPopupItem | protected
m_clrBack | CXTPPopupItem | protected
m_clrBorder | CXTPPopupItem | protected
m_clrHotText | CXTPPopupItem | protected
m_clrText | CXTPPopupItem | protected
m_nAlign | CXTPPopupItem | protected
m_nIconIndex | CXTPPopupItem | protected
m_nID | CXTPPopupItem | protected
m_nIndex | CXTPPopupItem | protected
m_pControl | CXTPPopupItem | protected
m_pRichRender | CXTPPopupItem | protected
m_ptOffset | CXTPPopupItem | protected
m_pUIElement | CXTPPopupItem | protected
m_rcItem | CXTPPopupItem | protected
m_strCaption | CXTPPopupItem | protected
m_xtpFontText | CXTPPopupItem | protected
OnItemInserted() | CXTPPopupItem | protectedvirtual
RedrawControl() | CXTPPopupItem | protected
SetBold(BOOL bBold) | CXTPPopupItem |
SetButton(BOOL bButton) | CXTPPopupItem |
SetCaption(LPCTSTR str) | CXTPPopupItem |
SetHandCursor(BOOL bHandCursor) | CXTPPopupItem |
SetHyperLink(BOOL bHyperLink) | CXTPPopupItem |
SetIcon(HICON hIcon, XTPPopupItemIcon itemIcon=xtpPopupItemIconNormal) | CXTPPopupItem |
SetIcon(UINT nIDIcon, XTPPopupItemIcon itemIcon=xtpPopupItemIconNormal) | CXTPPopupItem |
SetIconIndex(int nIconIndex) | CXTPPopupItem |
SetIcons(UINT nIDBitmap, COLORREF clrTransparent, int itemIcon) | CXTPPopupItem |
SetIcons(HBITMAP hBitmap, COLORREF clrTransparent, int itemIcon, BOOL bAlphaBitmap=FALSE) | CXTPPopupItem |
SetID(int nID) | CXTPPopupItem |
SetMarkupText(LPCTSTR str) | CXTPPopupItem |
SetRTFText(LPCTSTR str) | CXTPPopupItem |
SetRTFText(UINT nIDResource) | CXTPPopupItem |
SetTextAlignment(int nAlign) | CXTPPopupItem |
SetTextColor(COLORREF clrText, COLORREF clrHotText=(COLORREF) -1) | CXTPPopupItem |
SetTextFont(CFont *pFntText) | CXTPPopupItem |
SetTextFont(PLOGFONT pLogfText) | CXTPPopupItem |
SetUnderline(BOOL bUnderline) | CXTPPopupItem |
~CXTPPopupItem() | CXTPPopupItem |


Toolkit Pro: Member List

CXTPTabCtrlButton Member List

This is the complete list of members for CXTPTabCtrlButton, including all inherited members.


Toolkit Pro: Member List

CXTPGridRecordItemControlHookWnd Member List

This is the complete list of members for CXTPGridRecordItemControlHookWnd, including all inherited members.

CXTPGridRecordItemControlHookWnd(XTP_GRIDRECORDITEM_CLICKARGS *pClickArgs) | CXTPGridRecordItemControlHookWnd |
m_ClickArgs | CXTPGridRecordItemControlHookWnd | protected
~CXTPGridRecordItemControlHookWnd() | CXTPGridRecordItemControlHookWnd |


Toolkit Pro: Member List

CXTPCommandBarsVisualStudio2022Theme Member List

This is the complete list of members for CXTPCommandBarsVisualStudio2022Theme, including all inherited members.

AdjustExcludeRect(CRect &rc, CXTPControl *pControl, BOOL bVertical) | CXTPCommandBarsOfficeXPTheme | virtual
Animate(CDC *pDestDC, CDC *pSrcDC, CRect rc, XTPAnimationType animationType) | CXTPPaintManager | virtual
AnimateExpanding(CXTPCommandBar *pCommandBar, CDC *pDestDC, CDC *pSrcDC, BOOL bExpandDown) | CXTPPaintManager | virtual
BaseTheme() | CXTPCommandBarsOffice2013Theme | virtual
CreateTheme(XTPPaintTheme paintTheme) | CXTPPaintManager | static
CXTPCmdTarget() | CXTPCmdTarget |
CXTPCommandBarsModernUITheme() | CXTPCommandBarsModernUITheme |
CXTPCommandBarsOffice2013Theme() | CXTPCommandBarsOffice2013Theme |
CXTPCommandBarsOfficeXPTheme() | CXTPCommandBarsOfficeXPTheme |
CXTPCommandBarsVisualStudio2022Theme() | CXTPCommandBarsVisualStudio2022Theme |
CXTPObservable() | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | protected
CXTPPaintManager() | CXTPPaintManager | protected
Draw3dRect(CDC *pDC, LPCRECT rc, int nTopLeft, int nBottomRight) | CXTPPaintManager |
Draw3dRect(CDC *pDC, LPCRECT rc, int frameThickness, COLORREF clrPen, COLORREF clrBrush) | CXTPPaintManager |
CXTPPaintManager::DrawCheckMark(CDC *pDC, CRect rcCheck, COLORREF clr=0) | CXTPPaintManager | inline
DrawCheckRect(CDC *pDC, CRect rc, COLORREF clrFore, COLORREF clrBack) | CXTPCommandBarsVisualStudio2022Theme | protectedvirtual
DrawComboExpandMark(CDC *pDC, CRect rc, COLORREF clr) | CXTPPaintManager | virtual
DrawCommandBarGripper(CDC *pDC, CXTPCommandBar *pBar, BOOL bDraw=TRUE) | CXTPCommandBarsVisualStudio2022Theme | protectedvirtual
DrawCommandBarGroupSeparator(CDC *pDC, CXTPCommandBar *pBar, CXTPControl *pLeftControl, CXTPControl *pRightControl, BOOL bDraw) | CXTPCommandBarsOffice2013Theme | virtual
DrawCommandBarSeparator(CDC *pDC, CXTPCommandBar *pBar, CXTPControl *pControl, BOOL bDraw=TRUE) | CXTPCommandBarsOffice2013Theme | protectedvirtual
DrawControl(CDC *pDC, CXTPControl *pButton, BOOL bDraw=TRUE) | CXTPPaintManager |
DrawControlCheckBoxMark(CDC *pDC, CXTPControl *pButton, CRect rc, BOOL bDraw) | CXTPCommandBarsOffice2013Theme | protectedvirtual
DrawControlCheckBoxMark(CDC *pDC, CRect rc, BOOL bDraw, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled) | CXTPCommandBarsOffice2013Theme | protectedvirtual
DrawControlComboBox(CDC *pDC, CXTPControlComboBox *pComboBox, BOOL bDraw) | CXTPCommandBarsVisualStudio2022Theme | protectedvirtual
DrawControlEdit(CDC *pDC, CXTPControlEdit *pEdit, BOOL bDraw) | CXTPCommandBarsOffice2013Theme | virtual
DrawControlEntry(CDC *pDC, CXTPControl *pButton) | CXTPPaintManager | virtual
DrawControlMDIButton(CDC *pDC, CXTPControlButton *pButton) | CXTPCommandBarsOffice2013Theme | protectedvirtual
DrawControlPopupParent(CDC *pDC, CXTPControl *pButton, BOOL bDraw) | CXTPCommandBarsOfficeXPTheme | protectedvirtual
DrawControlRadioButtonMark(CDC *pDC, CRect rc, BOOL bDraw, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled) | CXTPCommandBarsOffice2013Theme | protectedvirtual
DrawControlText(CDC *pDC, CXTPControl *pControl, CRect rcText, BOOL bDraw, BOOL bVert, BOOL bCentered, BOOL bTriangled) | CXTPPaintManager |
DrawControlToolBarParent(CDC *pDC, CXTPControl *pButton, BOOL bDraw) | CXTPPaintManager | virtual
DrawDialogBarGripper(CDC *pDC, CXTPDialogBar *pBar, BOOL bDraw) | CXTPCommandBarsOfficeXPTheme | virtual
DrawDropDownGlyph(CDC *pDC, CXTPControl *pControl, CPoint pt, BOOL bSelected, BOOL bPopuped, BOOL bEnabled, BOOL bVert) | CXTPCommandBarsOffice2013Theme | protectedvirtual
DrawExpandGlyph(CDC *pDC, CXTPControl *pButton, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clr) | CXTPCommandBarsOffice2013Theme | protectedvirtual
DrawExpandGlyph(CDC *pDC, CXTPControl *pButton, COLORREF clr, BOOL bVertical) | CXTPCommandBarsOffice2013Theme | protectedvirtual
DrawFrameBorder(CDC *pDC, CRect rc, int nBorderThickness, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition) | CXTPCommandBarsOffice2013Theme | protected
DrawGalleryItemBack(CDC *pDC, CRect rcItem, BOOL bEnabled, BOOL bSelected, BOOL bPressed, BOOL bChecked, XTPBarType barType) | CXTPCommandBarsVisualStudio2022Theme | protectedvirtual
DrawHiddenGlyph(CDC *pDC, CXTPControl *pButton, COLORREF clr, BOOL bVertical) | CXTPCommandBarsOffice2013Theme | protectedvirtual
DrawImage(CDC *pDC, CPoint pt, CSize sz, CXTPImageManagerIcon *pImage, BOOL bSelected, BOOL bPressed, BOOL bEnabled=TRUE, BOOL bChecked=FALSE, BOOL bPopuped=FALSE, BOOL bToolBarImage=TRUE) | CXTPCommandBarsOfficeXPTheme | protectedvirtual
DrawListBoxControl(CDC *pDC, CXTPControl *pButton, CRect rc, BOOL bSelected, BOOL bDraw, CXTPCommandBars *pCommandBars=0) | CXTPCommandBarsOfficeXPTheme | virtual
DrawPopupBarCheckMark(CDC *pDC, CRect rcCheck, BOOL bEnabled, COLORREF clr) | CXTPPaintManager | virtual
DrawPopupBarGripper(CDC *pDC, int xPos, int yPos, int cx, int cy, BOOL bExpanded=FALSE) | CXTPCommandBarsOffice2013Theme | protectedvirtual
DrawPopupBarRadioMark(CDC *pDC, CRect rcCheck, BOOL bEnabled, COLORREF clr) | CXTPPaintManager | virtual
DrawPopupResizeGripper(CDC *pDC, CRect rcGripper, int nFlags) | CXTPCommandBarsOfficeXPTheme | virtual
DrawRectangle(CDC *pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition) | CXTPCommandBarsVisualStudio2022Theme | protectedvirtual
DrawRectangle(CDC *pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition, int nID) | CXTPCommandBarsVisualStudio2022Theme | protectedvirtual
DrawRectangle(CDC *pDC, CXTPControl *pButton) | CXTPCommandBarsVisualStudio2022Theme | protectedvirtual
DrawSpecialControl(CDC *pDC, XTPSpecialControl controlType, CXTPControl *pButton, CXTPCommandBar *pBar, BOOL bDraw, LPVOID lpParam) | CXTPPaintManager | virtual
DrawSplitButtonFrame(CDC *pDC, CXTPControl *pButton, CRect rc) | CXTPCommandBarsVisualStudio2022Theme | protectedvirtual
DrawTearOffGripper(CDC *pDC, CRect rcGripper, BOOL bSelected, BOOL bDraw) | CXTPCommandBarsOfficeXPTheme | virtual
FillCommandBarEntry(CDC *pDC, CXTPCommandBar *pBar) | CXTPCommandBarsOffice2013Theme | virtual
FillDockBar(CDC *pDC, CXTPDockBar *pBar) | CXTPCommandBarsOffice2013Theme | virtual
FillIntersectRect(CDC *pDC, CXTPPopupBar *pPopupBar, COLORREF clr) | CXTPCommandBarsOfficeXPTheme | protected
FillWorkspace(CDC *pDC, CRect rc, CRect rcExclude) | CXTPCommandBarsOffice2013Theme | virtual
FontExists(LPCTSTR lpszFaceName) | CXTPPaintManager | static
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCommandBarBorders(CXTPCommandBar *pBar) | CXTPPaintManager | virtual
GetCommandBarFont(CXTPCommandBar *pCommandBar) | CXTPPaintManager | virtual
GetControlBackColor(CXTPControl *pButton) | CXTPCommandBarsOffice2013Theme | protectedvirtual
GetControlEditBackColor(CXTPControl *pControl) | CXTPCommandBarsOffice2013Theme | virtual
GetControlFont(CXTPControl *pControl) | CXTPPaintManager | virtual
GetControlHeight() const | CXTPPaintManager |
GetControlTextColor(CXTPControl *pButton) | CXTPCommandBarsVisualStudio2022Theme | protectedvirtual
GetControlTextOrientation(CXTPControl *pControl) | CXTPPaintManager | virtual
GetCurrentSystemTheme() | CXTPPaintManager |
GetCurrentTheme() | CXTPPaintManager | inline
GetDefaultCommandBarSize(CXTPCommandBar *pBar) | CXTPPaintManager | virtual
GetFramePaintManager() | CXTPCommandBarsModernUITheme | virtual
GetGalleryPaintManager() const | CXTPPaintManager | virtual
GetGlobalPaintManager() | CXTPPaintManager | static
GetIconFont() | CXTPPaintManager |
GetIconsInfo() | CXTPPaintManager |
GetInstanceAddRef() | CXTPPaintManager | static
GetMarkupContext() | CXTPCommandBarsModernUITheme | virtual
GetMessageBarPaintManager() | CXTPPaintManager | virtual
GetPopupBarGripperWidth(CXTPCommandBar *pBar) | CXTPPaintManager | virtual
GetProgressPaintManager() const | CXTPPaintManager | virtual
GetRectangleTextColor(BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition) | CXTPCommandBarsOffice2013Theme | protectedvirtual
GetRegularBoldFont() | CXTPPaintManager |
GetRegularFont() | CXTPPaintManager |
GetRibbonPaintManager() | CXTPCommandBarsModernUITheme | virtual
GetScrollBarPaintManager() const | CXTPPaintManager | virtual
GetShadowManager() const | CXTPPaintManager |
GetShadowOptions() const | CXTPPaintManager |
GetSliderPaintManager() const | CXTPPaintManager | virtual
GetSmCaptionFont() | CXTPPaintManager |
GetSplitButtonCommandRect(CXTPControl *pButton) | CXTPPaintManager | virtual
GetStateColor() const | CXTPCommandBarsVisualStudio2022Theme | virtual
GetStatusBarPaintManager() | CXTPPaintManager | virtual
GetXtremeColor(UINT nIndex) | CXTPPaintManager |
GradientFill(CDC *pDC, LPRECT lpRect, COLORREF crFrom, COLORREF crTo, BOOL bHorz, LPCRECT lpRectClip=NULL) | CXTPPaintManager |
HorizontalLine(CDC *pDC, int x0, int y0, int x1, COLORREF clrPen) | CXTPPaintManager |
IsUseSystemAccentColorEnabled() const | CXTPPaintManager |
Line(CDC *pDC, CPoint p0, CPoint p1) | CXTPPaintManager |
Line(CDC *pDC, int x0, int y0, int x1, int y1, const int nPen) | CXTPPaintManager |
Line(CDC *pDC, int x0, int y0, int x1, int y1, COLORREF clrPen) | CXTPPaintManager |
m_arrColor | CXTPPaintManager | protected
m_bAutoResizeIcons | CXTPPaintManager |
m_bClearTypeTextQuality | CXTPPaintManager |
m_bEmbossedDisabledText | CXTPPaintManager | protected
m_bEnableAnimation | CXTPPaintManager |
m_bFlatMenuBar | CXTPPaintManager |
m_bFlatToolBar | CXTPPaintManager |
m_bIntersect | CXTPCommandBarsOffice2013Theme | protected
m_bOffice2007Padding | CXTPPaintManager |
m_bOffsetPopupLabelText | CXTPPaintManager |
m_bSelectImageInPopupBar | CXTPPaintManager |
m_bShowKeyboardCues | CXTPPaintManager | protected
m_bShowShadow | CXTPPaintManager |
m_bThemedCheckBox | CXTPPaintManager |
m_bThemedStatusBar | CXTPPaintManager |
m_bThickCheckMark | CXTPPaintManager |
m_bUseOfficeFont | CXTPPaintManager |
m_bUseStandardFont | CXTPPaintManager | protected
m_bWrapCaptionBelowText | CXTPPaintManager |
m_clr3DShadow | CXTPCommandBarsOffice2013Theme | protected
m_clrBack | CXTPCommandBarsOffice2013Theme | protected
m_clrBtnFace | CXTPCommandBarsOffice2013Theme | protected
m_clrCaptionButtonFill | CXTPCommandBarsOffice2013Theme | protected
m_clrDisabledIcon | CXTPPaintManager |
m_clrFloatingGripper | CXTPPaintManager |
m_clrFloatingGripperText | CXTPPaintManager |
m_clrGlyph | CXTPCommandBarsOffice2013Theme | protected
m_clrGlyphDisabled | CXTPCommandBarsOffice2013Theme | protected
m_clrGlyphHighlight | CXTPCommandBarsOffice2013Theme | protected
m_clrGlyphPushed | CXTPCommandBarsOffice2013Theme | protected
m_clrHighlight | CXTPCommandBarsOffice2013Theme | protected
m_clrMessageBarText | CXTPCommandBarsOffice2013Theme | protected
m_clrWorkspace | CXTPCommandBarsOffice2013Theme | protected
m_csCheckBox | CXTPCommandBarsOffice2013Theme | protected
m_csCheckMark | CXTPCommandBarsOffice2013Theme | protected
m_csComboBox | CXTPCommandBarsOffice2013Theme | protected
m_csMenu | CXTPCommandBarsOffice2013Theme | protected
m_csMenuTitleBar | CXTPCommandBarsOffice2013Theme | protected
m_csRibbon | CXTPCommandBarsOffice2013Theme | protected
m_csToolbar | CXTPCommandBarsOffice2013Theme | protected
m_fontIcon | CXTPPaintManager |
m_fontIconBold | CXTPPaintManager |
m_fontSmCaption | CXTPPaintManager |
m_fontToolTip | CXTPPaintManager |
m_iconsInfo | CXTPPaintManager | protected
m_nAnimationSteps | CXTPPaintManager | protected
m_nAnimationTime | CXTPPaintManager | protected
m_nEditHeight | CXTPPaintManager | protected
m_nFontHeight | CXTPPaintManager | protected
m_nPopupBarTextPadding | CXTPPaintManager |
m_nSplitButtonDropDownHeight | CXTPPaintManager |
m_nSplitButtonDropDownWidth | CXTPPaintManager |
m_nSplitButtonPopupWidth | CXTPPaintManager |
m_nStatusBarMinHeight | CXTPPaintManager |
m_nTextHeight | CXTPPaintManager |
m_pfnSetLayeredWindowAttributes | CXTPPaintManager |
m_pFramePaintManager | CXTPPaintManager |
m_pGalleryPaintManager | CXTPPaintManager |
m_pImages | CXTPCommandBarsModernUITheme | protected
m_pMarkupContext | CXTPCommandBarsModernUITheme | protected
m_pProgressPaintManager | CXTPPaintManager |
m_pRibbonPaintManager | CXTPPaintManager |
m_pScrollBarPaintManager | CXTPPaintManager |
m_pShadowManager | CXTPPaintManager | protected
m_pSliderPaintManager | CXTPPaintManager |
m_pStatusBarPaintManager | CXTPPaintManager |
m_rcMessageBarMargin | CXTPPaintManager |
m_rcStatusBarBorder | CXTPPaintManager |
m_strOfficeFont | CXTPPaintManager |
m_systemTheme | CXTPPaintManager | protected
m_themeButton | CXTPPaintManager | protected
m_themeCurrent | CXTPPaintManager | protected
m_themeStatusBar | CXTPPaintManager | protected
m_xtpFontRegular | CXTPPaintManager | protected
m_xtpFontRegularBold | CXTPPaintManager | protected
m_xtpFontVert | CXTPPaintManager | protected
m_xtpFontVertBold | CXTPPaintManager | protected
Notify(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *)) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
Notify(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1), A1 arg1) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
Notify(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
Notify(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamic(void(T::*method)(O *)) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1), A1 arg1) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *)) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1), A1 arg1) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyReversed(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *)) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyReversed(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1), A1 arg1) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyReversed(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyReversed(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
Pixel(CDC *pDC, int xPos, int yPos, int nPen) | CXTPPaintManager |
Rectangle(CDC *pDC, LPCRECT rc, int nPen, const int nBrush) | CXTPPaintManager |
Rectangle(CDC *pDC, LPCRECT rc, COLORREF clrPen, COLORREF clrBrush) | CXTPPaintManager |
RefreshMetrics() | CXTPCommandBarsOffice2013Theme | protectedvirtual
RefreshStandardColors() | CXTPCommandBarsOffice2013Theme | protectedvirtual
ReleaseInstance() | CXTPPaintManager | static
RequiresResourceImages() | CXTPCommandBarsOffice2013Theme | virtual
RoundRect(CDC *pDC, LPCRECT rc, COLORREF clrPen, COLORREF clrBrush) | CXTPPaintManager |
SetAnimationDelay(int nAnimationSteps, int nAnimationTime) | CXTPPaintManager |
SetColors(int cElements, CONST INT *lpaElements, CONST COLORREF *lpaRgbValues) | CXTPPaintManager |
SetCommandBarRegion(CXTPCommandBar *pCommandBar) | CXTPPaintManager | virtual
SetCommandBarsFontIndirect(LOGFONT *pLogFont, BOOL bUseStandardFont=FALSE) | CXTPPaintManager |
SetCustomTheme(CXTPPaintManager *pTheme) | CXTPPaintManager | static
SetGlobalPaintManager(CXTPPaintManager *pPaintManager) | CXTPPaintManager | static
SetImageHandle(HMODULE hResource, LPCTSTR lpszIniFileName) | CXTPPaintManager | virtual
SetLunaTheme(XTPCurrentSystemTheme systemTheme) | CXTPPaintManager |
SetStateColor(COLORREF clrState=COLORREF_NULL) | CXTPCommandBarsVisualStudio2022Theme | virtual
SetTheme(XTPPaintTheme paintTheme) | CXTPPaintManager | static
StripMnemonics(CString &strClear) | CXTPPaintManager | static
Subscribe(IXTPPaintManagerEvents *pObserver, CXTPSubscriptionList< CXTPPaintManager, IXTPPaintManagerEvents > *pSubcriptionList=NULL) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > |
Triangle(CDC *pDC, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clr) | CXTPPaintManager | static
Unsubscribe(IXTPPaintManagerEvents *pObserver) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > |
UpdateColors() | CXTPPaintManager | virtual
UpdateFonts() | CXTPPaintManager | virtual
UpdateRTLCaption(CString &strCaption) | CXTPPaintManager | virtual
UseOfficeFont(bool bUseOfficeFont) | CXTPPaintManager |
VerticalLine(CDC *pDC, int x0, int y0, int y1, COLORREF clrPen) | CXTPPaintManager |
~CXTPCommandBarsModernUITheme() | CXTPCommandBarsModernUITheme | virtual
~CXTPCommandBarsOffice2013Theme() | CXTPCommandBarsOffice2013Theme | virtual
~CXTPCommandBarsVisualStudio2022Theme() | CXTPCommandBarsVisualStudio2022Theme | virtual
~CXTPObservable() | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | protected
~CXTPPaintManager() | CXTPPaintManager | protectedvirtual


Toolkit Pro: XTPTabCtrlButtons.h Source File

  • Source
  • Controls
  • Tab
XTPTabCtrlButtons.h
Go to the documentation of this file.
1
23#if !defined(__XTPTABCTRLBUTTONS_H_)
24# define __XTPTABCTRLBUTTONS_H_
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPTabCtrlButtons;
34class CXTPTabBase;
35
36# define XTP_IDC_TAB_CLOSE 106
37
43class _XTP_EXT_CLASS CXTPTabCtrlButton
44{
45public:
46 CXTPTabCtrlButton(DWORD wStyle);
47
48 void Draw(CDC* pDC, COLORREF clrButton);
49 DWORD Click(CXTPTabCtrlButtons* pWnd, CPoint pt, BOOL bRepeat = FALSE);
50 void SetRect(CRect rc);
51 CRect GetRect();
52 BOOL PtInRect(POINT pt) const;
53 void CheckForMouseOver(CWnd* pWnd, CPoint pt);
54 void SetEnable(BOOL bEnable);
55
56 CRect m_Rect;
57 DWORD m_wStyle;
58 CTabCtrl* m_pTabCtrl;
59 CXTPTabCtrlButtons* m_pButtons;
60};
61
63
64AFX_INLINE CXTPTabCtrlButton::CXTPTabCtrlButton(DWORD wStyle)
65{
66 m_wStyle = wStyle;
67 m_pButtons = 0;
68 m_pTabCtrl = 0;
69 m_Rect.SetRectEmpty();
70}
71AFX_INLINE void CXTPTabCtrlButton::SetRect(CRect rc)
72{
73 m_Rect = rc;
74}
75AFX_INLINE CRect CXTPTabCtrlButton::GetRect()
76{
77 return m_Rect;
78}
79AFX_INLINE BOOL CXTPTabCtrlButton::PtInRect(POINT pt) const
80{
81 return m_Rect.PtInRect(pt) != 0;
82}
89class _XTP_EXT_CLASS CXTPTabCtrlButtons : public CWnd
90{
91public:
92 CXTPTabCtrlButtons();
93 ~CXTPTabCtrlButtons();
94
95 BOOL Create(CXTPTabBase* pCtrlBase);
96
97 int GetWidth();
98
99 void ShowButtons(BOOL bShow);
100 BOOL ShowButtons();
101 void Refresh();
102 void SubclassTabButtons(CWnd* pWnd);
103 void SetButtonStyle(DWORD dwFlags);
104 void UnSubclassTabButtons();
105
106 CTabCtrl* GetTabCtrl() const;
107
108private:
109 CRect AdjustRect();
110
111private:
112 CXTPTabCtrlButton m_btnClose;
113 CXTPTabCtrlButton m_btnLeft;
114 CXTPTabCtrlButton m_btnRight;
115
116 DWORD m_dwFlags;
117 CTabCtrl* m_pTabCtrl;
118 CXTPTabBase* m_pTabCtrlBase;
119 BOOL m_bShow;
120
121 HWND m_hwndSubclassed;
122 HWND m_hwndPrimary;
123
124private:
125 afx_msg void OnPaint();
126 afx_msg BOOL OnEraseBkgnd(CDC* pDC);
127 afx_msg void OnLButtonDown(UINT nFlags, CPoint point);
128 afx_msg void OnMouseMove(UINT nFlags, CPoint point);
129 afx_msg void OnMouseLeave();
130 afx_msg void OnWindowPosChanged(WINDOWPOS* lpwndpos);
131
132 BOOL Create(LPCTSTR lpszClassName, LPCTSTR lpszWindowName, DWORD dwStyle, const RECT& rect,
133 CWnd* pParentWnd, UINT nID, CCreateContext* pContext = NULL);
134 DECLARE_MESSAGE_MAP()
135
136 friend class CXTPTabBase;
137 friend class CXTPTabCtrlButton;
138};
140AFX_INLINE CTabCtrl* CXTPTabCtrlButtons::GetTabCtrl() const
141{
142 return m_pTabCtrl;
143}
144
145AFX_INLINE BOOL CXTPTabCtrlButtons::Create(LPCTSTR lpszClassName, LPCTSTR lpszWindowName,
146 DWORD dwStyle, const RECT& rect, CWnd* pParentWnd,
147 UINT nID, CCreateContext* pContext)
148{
149 return CWnd::Create(lpszClassName, lpszWindowName, dwStyle, rect, pParentWnd, nID, pContext);
150}
152# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
154#endif // #if !defined(__XTPTABCTRLBUTTONS_H_)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPTabBase
CXTPTabBase is a standalone base class.
Definition XTPTabBase.h:61
CXTPTabCtrlButton
CXTPTabCtrlButton is a standalone structure class.
Definition XTPTabCtrlButtons.h:44
CXTPTabCtrlButtons
CXTPTabCtrlButtons is a CWnd derived class.
Definition XTPTabCtrlButtons.h:90


Toolkit Pro: XTPChartGdiPieDeviceCommand.h Source File

  • Source
  • Chart
  • Drawing
  • Gdi
XTPChartGdiPieDeviceCommand.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTGDIPIEDEVICECOMMAND_H__)
24# define __XTPCHARTGDIPIEDEVICECOMMAND_H__
25
26# if _MSC_VER >= 1000
27# pragma once
28# endif // _MSC_VER >= 1000
29
30# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
31
32namespace Gdiplus
33{
34class GpPath;
35class GpBrush;
36} // namespace Gdiplus
37
44class _XTP_EXT_CLASS CXTPChartGdiPieDeviceCommand : public CXTPChartPieDeviceCommand
45{
46protected:
59 CXTPChartGdiPieDeviceCommand(const CXTPPoint3d& ptCenter, double dMajorSemiAxis,
60 double dMinorSemiAxis, double dStartAngle, double dSweepAngle,
61 double dDepth, double nHolePercent);
62
63protected:
64 Gdiplus::GpPath* CreatePieGraphicsPath(const CXTPPoint3d& center, double majorSemiaxis,
65 double minorSemiaxis, double holePercent,
66 double startAngle, double sweepAngle) const;
67 void CalculateStartFinishPoints(const CXTPPoint3d& center, double majorSemiaxis,
68 double minorSemiaxis, double startAngle, double sweepAngle,
69 CXTPChartPointF& startPoint,
70 CXTPChartPointF& finishPoint) const;
71
72 virtual CXTPChartElement* HitTest(CPoint point, CXTPChartElement* pParent) const;
73};
74
75class _XTP_EXT_CLASS CXTPChartGdiGradientPieDeviceCommand : public CXTPChartGdiPieDeviceCommand
76{
77public:
78 CXTPChartGdiGradientPieDeviceCommand(const CXTPPoint3d& center, double majorSemiAxis,
79 double minorSemiAxis, double startAngle, double sweepAngle,
80 double depth, double holePercent,
81 const CXTPChartRectF& gradientBounds,
82 const CXTPChartColor& color, const CXTPChartColor& color2);
83
84protected:
85 void ExecuteOverride(CXTPChartDeviceContext* pDC);
86
87 Gdiplus::GpBrush* CreateBrush();
88
89protected:
90 CXTPChartRectF m_rcGradientBounds;
91 CXTPChartColor m_color;
92 CXTPChartColor m_color2;
93};
94
95class _XTP_EXT_CLASS CXTPChartGdiBoundedPieDeviceCommand : public CXTPChartGdiPieDeviceCommand
96{
97public:
98 CXTPChartGdiBoundedPieDeviceCommand(const CXTPPoint3d& center, double majorSemiAxis,
99 double minorSemiAxis, double startAngle, double sweepAngle,
100 double depth, int holePercent, const CXTPChartColor& color,
101 int nThickness);
102
103protected:
104 void ExecuteOverride(CXTPChartDeviceContext* pDC);
105
106protected:
107 CXTPChartColor m_color;
108 int m_nThickness;
109};
110
111# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
112#endif //#if !defined(__XTPCHARTGDIPIEDEVICECOMMAND_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartColor
This class abstracts a color entity.
Definition XTPChartTypes.h:51
CXTPChartDeviceCommand::HitTest
virtual CXTPChartElement * HitTest(CPoint point, CXTPChartElement *pParent) const
Performs recursive hit testing of the element at the specified point.
CXTPChartDeviceCommand::ExecuteOverride
virtual void ExecuteOverride(CXTPChartDeviceContext *pDC)
Override this function to write the drawing code for specific objects.
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartElement
This class abstracts a chart element, this class acts as a base class for all chart elements.
Definition XTPChartElement.h:131
CXTPChartPieDeviceCommand
Base class implementation for 2D pie chart device command.
Definition XTPChartPieDeviceCommand.h:93
CXTPPoint2T< float >
CXTPPoint3T< double >
CXTPRectT< float >


Toolkit Pro: Member List

CXTPChartPieSeriesLabelsViewBase Member List

This is the complete list of members for CXTPChartPieSeriesLabelsViewBase, including all inherited members.

AddChildView(CXTPChartElementView *pChildView) | CXTPChartElementView |
CreateDeviceCommand(CXTPChartDeviceContext *pDC)=0 | CXTPChartPieSeriesLabelsViewBase | pure virtual
CXTPChartElementView(CXTPChartElementView *pParentView) | CXTPChartElementView |
CXTPChartElementView(CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartElementView |
CXTPChartElementView(CXTPChartContainer *pContainer) | CXTPChartElementView |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartPieSeriesLabelsViewBase(CXTPChartElementView *pParentView) | CXTPChartPieSeriesLabelsViewBase | protected
GetAt(int nIndex) const | CXTPChartElementView |
GetBounds() const | CXTPChartElementView |
GetBounds(BOOL bIncludingChildren) const | CXTPChartElementView |
GetChildren() | CXTPChartElementView |
GetCount() const | CXTPChartElementView |
GetParentView() const | CXTPChartElementView |
Is3D() const | CXTPChartObject |
m_arrChildren | CXTPChartElementView | protected
m_pContainer | CXTPChartElementView | protected
m_pParentView | CXTPChartElementView | protected
m_rcBounds | CXTPChartElementView | protected
ResolveOverlapping()=0 | CXTPChartPieSeriesLabelsViewBase | pure virtual
~CXTPChartElementView() | CXTPChartElementView | protectedvirtual


Toolkit Pro: XTPGridThemeOffice2013.h Source File

  • Source
  • GridControl
  • Themes
XTPGridThemeOffice2013.h
Go to the documentation of this file.
1
23#if !defined(__XTPGridThemeOffice2013_H__)
24# define __XTPGridThemeOffice2013_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPGridThemeOffice2013 : public CXTPGridPaintManager
39{
40public:
45 CXTPGridThemeOffice2013();
46
51 virtual void LoadGlyphs();
52
58 virtual void RefreshMetrics();
59
70 virtual void DrawColumnText(CDC* pDC, CRect rcText, CString strCaption, int nHeaderAlignment,
71 BOOL bIsHeader, BOOL bColumnPressed);
72
84 virtual void DrawColumnBackground(CDC* pDC, CXTPGridColumn* pColumn, CRect rcColumn,
85 BOOL& bColumnPressed, BOOL& bDraggingFromHeader,
86 CXTPGridHeader* pHeader = NULL);
87
88 virtual void DrawPlainColumnBackground(CDC* /*pDC*/, CRect /*rcColumn*/);
89
123 virtual void DrawTriangle(CDC* pDC, CRect rcTriangle, BOOL bToDown, BOOL bDraggingFromHeader,
124 int nShadowWidth, BOOL bColumnPressed);
125
135 virtual CSize DrawCollapsedBitmap(CDC* pDC, const CXTPGridRow* pRow, CRect& rcBitmap);
136
137 virtual void DrawColumnInverted(CDC* pDC, CRect rcColumn, BOOL bColumnPressed,
138 BOOL bDraggingFromHeader, int nShadowWidth);
139
140 virtual void DrawWindowFrame(CDC* pDC, CRect rcWindow);
141
150 virtual void FillGroupRowMetrics(CXTPGridGroupRow* pRow, XTP_GRIDRECORDITEM_METRICS* pMetrics,
151 BOOL bPrinting);
152
153 virtual void DrawGroupRowBack(CDC* pDC, CRect rcRow, XTP_GRIDRECORDITEM_METRICS* pMetrics);
154
170 virtual void DrawGroupRow(CDC* pDC, CXTPGridGroupRow* pRow, CRect rcRow,
171 XTP_GRIDRECORDITEM_METRICS* pMetrics);
172
187 virtual void DrawFocusedRow(CDC* pDC, CRect rcRow);
188
201 virtual int GetRowHeight(CDC* pDC, CXTPGridRow* pRow);
202
203 using CXTPGridPaintManager::GetRowHeight;
204
205 virtual CRect GetGroupRowBmpSize(CRect rcRow, int nBitmapOffset);
206
207 virtual CRect GetGroupRowTextSize(CRect rcBitmap, CRect rcRow, int nBitmapWidth,
208 int nNoIconWidth, int nTextOffset);
209
210 CXTPPaintManagerColor m_clrGroupText;
211 CXTPPaintManagerColor m_clrGroupTextHilite;
212 CXTPPaintManagerColor m_clrGroupBack;
213 CXTPPaintManagerColor m_clrGroupBackHilite;
214 CXTPPaintManagerColor m_clrGlyph;
215 CXTPPaintManagerColor m_clrGlyphHighlight;
216 CXTPPaintManagerColor m_clrGlyphExpand;
217 CXTPPaintManagerColor m_clrGlyphBorder;
218 CXTPPaintManagerColor m_clrGlyphContract;
219};
221# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
222#endif //#if !defined(__XTPGridThemeOffice2013_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPGridColumn
Represents a grid column item with its properties and operations.
Definition XTPGridColumn.h:107
CXTPGridGroupRow
This class represents a 'group row' of the Grid control view.
Definition XTPGridGroupRow.h:49
CXTPGridHeader
A grid header is a part of the grid window positioned above columns of text or numbers.
Definition XTPGridHeader.h:173
CXTPGridPaintManager
Utility class that handles most drawing activities.
Definition XTPGridPaintManager.h:76
CXTPGridPaintManager::GetRowHeight
virtual int GetRowHeight(CDC *pDC, CXTPGridRow *pRow)
Retrieves the default row height for print mode (i.e.
CXTPGridRow
CXTPGridRow class represents a row of the Grid control window.
Definition XTPGridRow.h:71
CXTPGridThemeOffice2013
CXTPGridThemeOffice2013 is a CXTPGridPaintManager derived class that represents an Office 2013 style ...
Definition XTPGridThemeOffice2013.h:39
CXTPGridThemeOffice2013::DrawColumnText
virtual void DrawColumnText(CDC *pDC, CRect rcText, CString strCaption, int nHeaderAlignment, BOOL bIsHeader, BOOL bColumnPressed)
Draws text for the column header.
CXTPGridThemeOffice2013::m_clrGlyph
CXTPPaintManagerColor m_clrGlyph
Header glyph color.
Definition XTPGridThemeOffice2013.h:214
CXTPGridThemeOffice2013::DrawTriangle
virtual void DrawTriangle(CDC *pDC, CRect rcTriangle, BOOL bToDown, BOOL bDraggingFromHeader, int nShadowWidth, BOOL bColumnPressed)
Draws a triangle that shows the sort order of the column.
CXTPGridThemeOffice2013::FillGroupRowMetrics
virtual void FillGroupRowMetrics(CXTPGridGroupRow *pRow, XTP_GRIDRECORDITEM_METRICS *pMetrics, BOOL bPrinting)
Fills the font and color members of the metrics structure for a specified group row.
CXTPGridThemeOffice2013::CXTPGridThemeOffice2013
CXTPGridThemeOffice2013()
Default paint manager constructor, handles properties initialization.
CXTPGridThemeOffice2013::m_clrGlyphContract
CXTPPaintManagerColor m_clrGlyphContract
Contract glyph color.
Definition XTPGridThemeOffice2013.h:218
CXTPGridThemeOffice2013::m_clrGlyphExpand
CXTPPaintManagerColor m_clrGlyphExpand
Expand glyph color.
Definition XTPGridThemeOffice2013.h:216
CXTPGridThemeOffice2013::m_clrGlyphBorder
CXTPPaintManagerColor m_clrGlyphBorder
Expand glyph border color.
Definition XTPGridThemeOffice2013.h:217
CXTPGridThemeOffice2013::DrawColumnBackground
virtual void DrawColumnBackground(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, BOOL &bColumnPressed, BOOL &bDraggingFromHeader, CXTPGridHeader *pHeader=NULL)
This method is called to draw the background of a column using the current column style.
CXTPGridThemeOffice2013::m_clrGlyphHighlight
CXTPPaintManagerColor m_clrGlyphHighlight
Header highlighted glyph color.
Definition XTPGridThemeOffice2013.h:215
CXTPGridThemeOffice2013::DrawCollapsedBitmap
virtual CSize DrawCollapsedBitmap(CDC *pDC, const CXTPGridRow *pRow, CRect &rcBitmap)
Draws a collapsed bitmap.
CXTPGridThemeOffice2013::LoadGlyphs
virtual void LoadGlyphs()
Loads the default images used by the Grid control.
CXTPGridThemeOffice2013::DrawFocusedRow
virtual void DrawFocusedRow(CDC *pDC, CRect rcRow)
Draws focused rows.
CXTPGridThemeOffice2013::GetRowHeight
virtual int GetRowHeight(CDC *pDC, CXTPGridRow *pRow)
Retrieves the default row height for print mode (i.e.
CXTPGridThemeOffice2013::DrawGroupRow
virtual void DrawGroupRow(CDC *pDC, CXTPGridGroupRow *pRow, CRect rcRow, XTP_GRIDRECORDITEM_METRICS *pMetrics)
Draws a group row.
CXTPGridThemeOffice2013::RefreshMetrics
virtual void RefreshMetrics()
This method is called to refresh the visual metrics of the Grid control.
CXTPPaintManagerColor
The CXTPPaintManagerColor class is used to manage COLORREF values for determining default and applica...
Definition XTPColorManager.h:117
XTP_GRIDRECORDITEM_METRICS
Record item drawing metrics.
Definition XTPGridRecordItem.h:356


Toolkit Pro: XTPGdiObjects.h Source File

  • Source
  • Common
XTPGdiObjects.h
Go to the documentation of this file.
1
23#if !defined(__XTPGDIOBJECTCACHE_H__)
24# define __XTPGDIOBJECTCACHE_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
41# ifndef XTP_DISABLE_DEPRECATE_GDI_MEMBER
42# define XTP_DEPRECATE_GDI_MEMBER_IN_FAVOR_OF(memberName, inFavorOf) \
43 _XTP_DEPRECATE("The member '" #memberName \
44 "' has been deprecated, using it may lead to undefined behavior. " \
45 "Use '" #inFavorOf \
46 "' instead. You can disable this message by defining " \
47 "XTP_DISABLE_DEPRECATE_GDI_MEMBER globally.")
48# else
49# define XTP_DEPRECATE_GDI_MEMBER_IN_FAVOR_OF(what)
50# endif
51
52# define XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED_(oldClass, oldClassRef, oldClassCRef, \
53 oldMemberName, cachedMemberName, \
54 handleGetterName) \
55 XTP_DEPRECATE_GDI_MEMBER_IN_FAVOR_OF(oldMemberName, cachedMemberName) \
56 AFX_INLINE oldClassRef handleGetterName() \
57 { \
58 return *cachedMemberName.GetNativeGdiObject(); \
59 } \
60 XTP_DEPRECATE_GDI_MEMBER_IN_FAVOR_OF(oldMemberName, cachedMemberName) \
61 AFX_INLINE oldClassCRef handleGetterName() const \
62 { \
63 return *cachedMemberName.GetNativeGdiObject(); \
64 } \
65 __declspec(property(get = handleGetterName)) oldClassRef oldMemberName;
66
67# define XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(oldClass, oldMemberName, cachedMemberName, \
68 handleGetterName) \
69 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED_(oldClass, oldClass&, const oldClass&, \
70 oldMemberName, cachedMemberName, handleGetterName)
71
72template<class GdiObject, class XtpObject>
73class CXTPGdiObjectPtrProxy;
74class CXTPCachedGdiObjectReferenceBase;
75template<class Descriptor, class GdiObject, class XtpCacheClass>
76class CXTPCachedGdiObjectReference;
77class CXTPFont;
78class CXTPGdiObject;
79class CXTPGdiObjectCacheBase;
80
81template<class GdiObject, class XtpObject>
82class CXTPGdiObjectPtrProxy
83{
84public:
85 operator XtpObject*();
86 operator const XtpObject*() const;
87 operator GdiObject*();
88 operator const GdiObject*() const;
89 XtpObject& operator*();
90 const XtpObject& operator*() const;
91
92private:
93 friend class CXTPFont;
94 friend class CXTPBrush;
95 friend class CXTPPen;
96 friend class CXTPImageList;
97 explicit CXTPGdiObjectPtrProxy(XtpObject* object);
98
99 XtpObject* m_pObject;
100};
101
102template<class GdiObject, class XtpObject>
103AFX_INLINE CXTPGdiObjectPtrProxy<GdiObject, XtpObject>::CXTPGdiObjectPtrProxy(XtpObject* pObject)
104 : m_pObject(pObject)
105{
106}
107
108template<class GdiObject, class XtpObject>
109AFX_INLINE CXTPGdiObjectPtrProxy<GdiObject, XtpObject>::operator XtpObject*()
110{
111 return m_pObject;
112}
113
114template<class GdiObject, class XtpObject>
115AFX_INLINE CXTPGdiObjectPtrProxy<GdiObject, XtpObject>::operator const XtpObject*() const
116{
117 return m_pObject;
118}
119
120template<class GdiObject, class XtpObject>
121AFX_INLINE CXTPGdiObjectPtrProxy<GdiObject, XtpObject>::operator GdiObject*()
122{
123 return m_pObject->GetNativeGdiObject();
124}
125
126template<class GdiObject, class XtpObject>
127AFX_INLINE CXTPGdiObjectPtrProxy<GdiObject, XtpObject>::operator const GdiObject*() const
128{
129 return m_pObject->GetNativeGdiObject();
130}
131
132template<class GdiObject, class XtpObject>
133AFX_INLINE XtpObject& CXTPGdiObjectPtrProxy<GdiObject, XtpObject>::operator*()
134{
135 return *m_pObject;
136}
137
138template<class GdiObject, class XtpObject>
139AFX_INLINE const XtpObject& CXTPGdiObjectPtrProxy<GdiObject, XtpObject>::operator*() const
140{
141 return *m_pObject;
142}
143
144struct XTPGDIDESCRIPTOR;
145
169class _XTP_EXT_CLASS CXTPGdiObject : public CObject
170{
171 DECLARE_DYNAMIC(CXTPGdiObject);
172
173protected:
178 CXTPGdiObject();
179
180public:
186 virtual ~CXTPGdiObject() = 0;
187
199 operator HGDIOBJ() const;
200
212 HGDIOBJ GetSafeHandle() const;
213
222 BOOL DeleteObject();
223
224# pragma push_macro("GetObject")
225# undef GetObject
234 int GetObject(int nCount, LPVOID lpObject) const;
235# pragma pop_macro("GetObject")
236
245 UINT GetObjectType() const;
246
259 BOOL CreateStockObject(int nIndex);
260
269 BOOL operator==(const CXTPGdiObject& obj) const;
270
279 BOOL operator!=(const CXTPGdiObject& obj) const;
280
292 operator CGdiObject&();
293
302 operator const CGdiObject&() const;
303
315 __declspec(property(get = GetSafeHandle)) HGDIOBJ m_hObject;
316
329 void SetHandleOwnershipNotGuaranteed();
330
345 BOOL IsHandleOwnershipGuaranteed() const;
346
347protected:
349 CGdiObject* GetGdiObject();
350 const CGdiObject* GetGdiObject() const;
351
352 void SetDummyGdiObject(CGdiObject& gdiObject);
353 void SetCachedObject(CXTPCachedGdiObjectReferenceBase* pCachedObject);
354
355 virtual XTPGDIDESCRIPTOR& AccessDescriptorData() = 0;
356 const XTPGDIDESCRIPTOR& AccessDescriptorData() const;
357
358 void* GetDescriptor() const;
361private:
362 CXTPCachedGdiObjectReferenceBase* m_pCachedObject;
363 CGdiObject* m_pDummyGdiObject;
364 BOOL m_bHandleOwnershipViolated;
365# ifdef _DEBUG
366 HGDIOBJ m_hDummyGdiObject;
367
368 void AssertDummyUnaltered() const;
369# endif
370};
372AFX_INLINE const CGdiObject* CXTPGdiObject::GetGdiObject() const
373{
374 return const_cast< CXTPGdiObject*>(this)->GetGdiObject();
375}
376
377AFX_INLINE CXTPGdiObject::operator CGdiObject&()
378{
379 return *GetGdiObject();
380}
381
382AFX_INLINE CXTPGdiObject::operator const CGdiObject&() const
383{
384 return *GetGdiObject();
385}
386
387AFX_INLINE const XTPGDIDESCRIPTOR& CXTPGdiObject::AccessDescriptorData() const
388{
389 return const_cast< CXTPGdiObject*>(this)->AccessDescriptorData();
390}
413class _XTP_EXT_CLASS CXTPFont : public CXTPGdiObject
414{
415 DECLARE_DYNAMIC(CXTPFont);
416
417public:
419 typedef CXTPGdiObjectPtrProxy<CFont, CXTPFont> XTPFontPtrProxy;
426 CXTPFont();
427
432 ~CXTPFont();
433
447 BOOL CreateFontIndirect(const LOGFONT* lpLogFont);
448
477 BOOL CreateFont(int nHeight, int nWidth, int nEscapement, int nOrientation, int nWeight,
478 BYTE bItalic, BYTE bUnderline, BYTE cStrikeOut, BYTE nCharSet,
479 BYTE nOutPrecision, BYTE nClipPrecision, BYTE nQuality, BYTE nPitchAndFamily,
480 LPCTSTR lpszFacename);
481
498 BOOL CreatePointFont(int nPointSize, LPCTSTR lpszFaceName, CDC* pDC = NULL);
499
515 BOOL CreatePointFontIndirect(const LOGFONT* lpLogFont, CDC* pDC = NULL);
516
525 int GetLogFont(LOGFONT* pLogFont);
526
535 CFont* GetNativeGdiObject();
536
545 const CFont* GetNativeGdiObject() const;
546
558 operator HFONT() const;
559
571 operator CFont&();
572
581 operator const CFont&() const;
582
584 XTPFontPtrProxy operator&();
585 const XTPFontPtrProxy operator&() const;
588private:
589 virtual XTPGDIDESCRIPTOR& AccessDescriptorData();
590
591 CFont m_dummyFont;
592 HGDIOBJ m_hLogFontHandle;
593 LOGFONT m_logFont;
594};
596AFX_INLINE CFont* CXTPFont::GetNativeGdiObject()
597{
598 return static_cast<CFont*>(GetGdiObject());
599}
600
601AFX_INLINE const CFont* CXTPFont::GetNativeGdiObject() const
602{
603 return const_cast< CXTPFont*>(this)->GetNativeGdiObject();
604}
605
606AFX_INLINE CXTPFont::operator HFONT() const
607{
608 return reinterpret_cast<HFONT>(GetSafeHandle());
609}
610
611AFX_INLINE CXTPFont::operator CFont&()
612{
613 return *GetNativeGdiObject();
614}
615
616AFX_INLINE CXTPFont::operator const CFont&() const
617{
618 return *GetNativeGdiObject();
619}
620
621AFX_INLINE CXTPFont::XTPFontPtrProxy CXTPFont::operator&()
622{
623 return XTPFontPtrProxy(this);
624}
625
626AFX_INLINE const CXTPFont::XTPFontPtrProxy CXTPFont::operator&() const
627{
628 return XTPFontPtrProxy(const_cast< CXTPFont*>(this));
629}
652class _XTP_EXT_CLASS CXTPBrush : public CXTPGdiObject
653{
654 DECLARE_DYNAMIC(CXTPBrush);
655
656public:
658 typedef CXTPGdiObjectPtrProxy<CBrush, CXTPBrush> XTPBrushPtrProxy;
665 CXTPBrush();
666
676 CXTPBrush(COLORREF crColor);
677
688 CXTPBrush(int nIndex, COLORREF crColor);
689
699 CXTPBrush(CBitmap* pBitmap);
700
705 ~CXTPBrush();
706
718 BOOL CreateSolidBrush(COLORREF crColor);
719
732 BOOL CreateHatchBrush(int nIndex, COLORREF crColor);
733
747 BOOL CreateBrushIndirect(const LOGBRUSH* lpLogBrush);
748
760 BOOL CreatePatternBrush(CBitmap* pBitmap);
761
777 BOOL CreateDIBPatternBrush(HGLOBAL hPackedDIB, UINT nUsage);
778
795 BOOL CreateDIBPatternBrush(const void* lpPackedDIB, UINT nUsage);
796
808 BOOL CreateSysColorBrush(int nIndex);
809
818 int GetLogBrush(LOGBRUSH* pLogBrush);
819
828 CBrush* GetNativeGdiObject();
829
838 const CBrush* GetNativeGdiObject() const;
839
851 operator HBRUSH() const;
852
864 operator CBrush&();
865
877 operator const CBrush&() const;
878
880 XTPBrushPtrProxy operator&();
881 const XTPBrushPtrProxy operator&() const;
884private:
885 virtual XTPGDIDESCRIPTOR& AccessDescriptorData();
886
887 CBrush m_dummyBrush;
888 HGDIOBJ m_hLogBrushHandle;
889 LOGBRUSH m_logBrush;
890};
892AFX_INLINE CBrush* CXTPBrush::GetNativeGdiObject()
893{
894 return static_cast<CBrush*>(GetGdiObject());
895}
896
897AFX_INLINE const CBrush* CXTPBrush::GetNativeGdiObject() const
898{
899 return const_cast< CXTPBrush*>(this)->GetNativeGdiObject();
900}
901
902AFX_INLINE CXTPBrush::operator HBRUSH() const
903{
904 return reinterpret_cast<HBRUSH>(GetSafeHandle());
905}
906
907AFX_INLINE CXTPBrush::operator CBrush&()
908{
909 return *GetNativeGdiObject();
910}
911
912AFX_INLINE CXTPBrush::operator const CBrush&() const
913{
914 return *GetNativeGdiObject();
915}
916
917AFX_INLINE CXTPBrush::XTPBrushPtrProxy CXTPBrush::operator&()
918{
919 return XTPBrushPtrProxy(this);
920}
921
922AFX_INLINE const CXTPBrush::XTPBrushPtrProxy CXTPBrush::operator&() const
923{
924 return XTPBrushPtrProxy(const_cast< CXTPBrush*>(this));
925}
948class _XTP_EXT_CLASS CXTPPen : public CXTPGdiObject
949{
951 DECLARE_DYNAMIC(CXTPPen);
953public:
955 typedef CXTPGdiObjectPtrProxy<CPen, CXTPPen> XTPPenPtrProxy;
962 CXTPPen();
963
975 CXTPPen(int nPenStyle, int nWidth, COLORREF crColor);
976
991 CXTPPen(int nPenStyle, int nWidth, const LOGBRUSH* pLogBrush, int nStyleCount = 0,
992 const DWORD* lpStyle = NULL);
993
998 ~CXTPPen();
999
1013 BOOL CreatePen(int nPenStyle, int nWidth, COLORREF crColor);
1014
1031 BOOL CreatePen(int nPenStyle, int nWidth, const LOGBRUSH* pLogBrush, int nStyleCount = 0,
1032 const DWORD* lpStyle = NULL);
1033
1046 BOOL CreatePenIndirect(LPLOGPEN lpLogPen);
1047
1056 int GetLogPen(LOGPEN* pLogPen);
1057
1066 int GetExtLogPen(EXTLOGPEN* pLogPen);
1067
1076 CPen* GetNativeGdiObject();
1077
1086 const CPen* GetNativeGdiObject() const;
1087
1099 operator HPEN() const;
1100
1112 operator CPen&();
1113
1125 operator const CPen&() const;
1126
1128 XTPPenPtrProxy operator&();
1129 const XTPPenPtrProxy operator&() const;
1132private:
1133 virtual XTPGDIDESCRIPTOR& AccessDescriptorData();
1134
1135 CPen m_dummyPen;
1136 HGDIOBJ m_hLogPenHandle;
1137 LOGPEN m_logPen;
1138};
1140AFX_INLINE CPen* CXTPPen::GetNativeGdiObject()
1141{
1142 return static_cast<CPen*>(GetGdiObject());
1143}
1144
1145AFX_INLINE const CPen* CXTPPen::GetNativeGdiObject() const
1146{
1147 return const_cast< CXTPPen*>(this)->GetNativeGdiObject();
1148}
1149
1150AFX_INLINE CXTPPen::operator HPEN() const
1151{
1152 return reinterpret_cast<HPEN>(GetSafeHandle());
1153}
1154
1155AFX_INLINE CXTPPen::operator CPen&()
1156{
1157 return *GetNativeGdiObject();
1158}
1159
1160AFX_INLINE CXTPPen::operator const CPen&() const
1161{
1162 return *GetNativeGdiObject();
1163}
1164
1165AFX_INLINE CXTPPen::XTPPenPtrProxy CXTPPen::operator&()
1166{
1167 return XTPPenPtrProxy(this);
1168}
1169
1170AFX_INLINE const CXTPPen::XTPPenPtrProxy CXTPPen::operator&() const
1171{
1172 return XTPPenPtrProxy(const_cast< CXTPPen*>(this));
1173}
1176class CXTPGdiObjectCacheBase
1177 : public CObject
1178 , public CXTPSynchronized
1179{
1180 DECLARE_DYNAMIC(CXTPGdiObjectCacheBase);
1181
1182protected:
1183 CXTPGdiObjectCacheBase()
1184 {
1185 }
1186 virtual ~CXTPGdiObjectCacheBase()
1187 {
1188 }
1189
1190public:
1191 virtual void RemoveFromCache(const void* pDescriptor) = 0;
1192};
1193
1194struct XTPGDIDESCRIPTOR
1195{
1196 XTPGDIDESCRIPTOR()
1197 : pReference(NULL)
1198 , nHandleOwnershipViolatorCount(0)
1199 {
1200 }
1201
1202 CXTPCachedGdiObjectReferenceBase* pReference;
1203 LONG nHandleOwnershipViolatorCount;
1204};
1205
1206struct XTPPENINFO;
1207class CXTPCachedPenReference;
1208
1209template<>
1210UINT AFXAPI HashKey(XTPPENINFO* pPenInfo);
1211template<>
1212BOOL AFXAPI CompareElements(XTPPENINFO* const* pPenInfo1, XTPPENINFO* const* pPenInfo2);
1213
1214class CXTPPenCache : private CXTPGdiObjectCacheBase
1215{
1216 DECLARE_DYNAMIC(CXTPPenCache);
1217
1218 friend class CXTPSingleton<CXTPPenCache>;
1219
1220public:
1221 static XTPGDIDESCRIPTOR& AccessDescriptorData(void* pDescriptor);
1222
1223 CXTPCachedPenReference* CreatePen(int nPenStyle, int nWidth, COLORREF crColor);
1224 CXTPCachedPenReference* CreatePen(int nPenStyle, int nWidth, const LOGBRUSH* pLogBrush,
1225 int nStyleCount = 0, const DWORD* lpStyle = NULL);
1226 CXTPCachedPenReference* CreatePenIndirect(LPLOGPEN lpLogPen);
1227
1228private:
1229 CXTPPenCache();
1230 ~CXTPPenCache();
1231
1232 virtual void RemoveFromCache(const void* pDescriptor);
1233
1234 friend CXTPPenCache* AFX_CDECL XTPPenCache();
1235
1236 // LPVOID used instead of XTPCachedBrushReference* as a workaround for warning C4786.
1237 CMap<XTPPENINFO*, XTPPENINFO*, LPVOID, LPVOID&> m_penCache;
1238};
1239
1240struct XTPLOGBRUSHDESCRIPTOR : XTPGDIDESCRIPTOR
1241{
1242 LOGBRUSH logBrush;
1243};
1244
1245template<>
1246UINT AFXAPI HashKey(const LOGBRUSH& logBrush);
1247template<>
1248BOOL AFXAPI CompareElements(const LOGBRUSH* logBrush1, const LOGBRUSH* logBrush2);
1249
1250class CXTPBrushCache : private CXTPGdiObjectCacheBase
1251{
1252 DECLARE_DYNAMIC(CXTPBrushCache);
1253
1254 friend class CXTPSingleton<CXTPBrushCache>;
1255 friend class CXTPCachedGdiObjectReference<XTPLOGBRUSHDESCRIPTOR, CBrush, CXTPBrushCache>;
1256
1257public:
1258 typedef CXTPCachedGdiObjectReference<XTPLOGBRUSHDESCRIPTOR, CBrush, CXTPBrushCache>
1259 XTPCachedBrushReference;
1260
1261 static XTPGDIDESCRIPTOR& AccessDescriptorData(void* pDescriptor);
1262
1263 XTPCachedBrushReference* CreateSolidBrush(COLORREF crColor);
1264 XTPCachedBrushReference* CreateHatchBrush(int nIndex, COLORREF crColor);
1265 XTPCachedBrushReference* CreateBrushIndirect(const LOGBRUSH* lpLogBrush);
1266 XTPCachedBrushReference* CreatePatternBrush(CBitmap* pBitmap);
1267 XTPCachedBrushReference* CreateDIBPatternBrush(HGLOBAL hPackedDIB, UINT nUsage);
1268 XTPCachedBrushReference* CreateDIBPatternBrush(const void* lpPackedDIB, UINT nUsage);
1269 XTPCachedBrushReference* CreateSysColorBrush(int nIndex);
1270
1271private:
1272 CXTPBrushCache();
1273 ~CXTPBrushCache();
1274
1275 virtual void RemoveFromCache(const void* pDescriptor);
1276
1277 friend CXTPBrushCache* AFX_CDECL XTPBrushCache();
1278
1279 // LPVOID used instead of XTPCachedBrushReference* as a workaround for warning C4786.
1280 CMap<LOGBRUSH, const LOGBRUSH&, LPVOID, LPVOID&> m_brushCache;
1281};
1282
1283struct XTPLOGFONTDESCRIPTOR : XTPGDIDESCRIPTOR
1284{
1285 LOGFONT logFont;
1286};
1287
1288template<>
1289UINT AFXAPI HashKey(const LOGFONT& logFont);
1290template<>
1291BOOL AFXAPI CompareElements(const LOGFONT* logFont1, const LOGFONT* logFont2);
1292
1293class CXTPFontCache : private CXTPGdiObjectCacheBase
1294{
1295 DECLARE_DYNAMIC(CXTPFontCache);
1296
1297 friend class CXTPSingleton<CXTPFontCache>;
1298 friend class CXTPCachedGdiObjectReference<XTPLOGFONTDESCRIPTOR, CFont, CXTPFontCache>;
1299
1300public:
1301 typedef CXTPCachedGdiObjectReference<XTPLOGFONTDESCRIPTOR, CFont, CXTPFontCache>
1302 XTPCachedFontReference;
1303
1304 static XTPGDIDESCRIPTOR& AccessDescriptorData(void* pDescriptor);
1305
1306 XTPCachedFontReference* CreateFontIndirect(const LOGFONT* lpLogFont);
1307 XTPCachedFontReference* CreateFont(int nHeight, int nWidth, int nEscapement, int nOrientation,
1308 int nWeight, BYTE bItalic, BYTE bUnderline, BYTE cStrikeOut,
1309 BYTE nCharSet, BYTE nOutPrecision, BYTE nClipPrecision,
1310 BYTE nQuality, BYTE nPitchAndFamily, LPCTSTR lpszFaceName);
1311 XTPCachedFontReference* CreatePointFont(int nPointSize, LPCTSTR lpszFaceName, CDC* pDC = NULL);
1312 XTPCachedFontReference* CreatePointFontIndirect(const LOGFONT* lpLogFont, CDC* pDC = NULL);
1313
1314private:
1315 CXTPFontCache();
1316 ~CXTPFontCache();
1317
1318 virtual void RemoveFromCache(const void* pDescriptor);
1319
1320 friend CXTPFontCache* AFX_CDECL XTPFontCache();
1321
1322 // LPVOID used instead of XTPCachedFontReference* as a workaround for warning C4786.
1323 CMap<LOGFONT, const LOGFONT&, LPVOID, LPVOID&> m_fontCache;
1324};
1325
1328# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
1330#endif /*__XTPGDIOBJECTCACHE_H__*/
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPBrush
Provides a convenient object oriented interface for HBRUSH GDI object and uses GDI handle caching.
Definition XTPGdiObjects.h:653
CXTPBrush::CreatePatternBrush
BOOL CreatePatternBrush(CBitmap *pBitmap)
Initializes a brush with a pattern specified by a bitmap.
CXTPBrush::GetLogBrush
int GetLogBrush(LOGBRUSH *pLogBrush)
Call this function to retrieve a copy of the LOGBRUSH structure that describes the encapsulated GDI o...
CXTPBrush::CreateSysColorBrush
BOOL CreateSysColorBrush(int nIndex)
Initializes a brush with a system color.
CXTPBrush::CXTPBrush
CXTPBrush(CBitmap *pBitmap)
Initializes a brush with a pattern specified by a bitmap.
CXTPBrush::CreateHatchBrush
BOOL CreateHatchBrush(int nIndex, COLORREF crColor)
Initializes a brush with the specified hatched pattern and color.
CXTPBrush::CreateDIBPatternBrush
BOOL CreateDIBPatternBrush(HGLOBAL hPackedDIB, UINT nUsage)
Initializes a brush with the pattern specified by a device-independent bitmap (DIB).
CXTPBrush::GetNativeGdiObject
CBrush * GetNativeGdiObject()
Obtains a pointer to the encapsulated GDI object as CBrush type.
CXTPBrush::CXTPBrush
CXTPBrush(COLORREF crColor)
Initializes a brush with a specified solid color.
CXTPBrush::GetNativeGdiObject
const CBrush * GetNativeGdiObject() const
Obtains a pointer to the encapsulated GDI object as CBrush type.
CXTPBrush::CreateDIBPatternBrush
BOOL CreateDIBPatternBrush(const void *lpPackedDIB, UINT nUsage)
Initializes a brush with the pattern specified by a device-independent bitmap (DIB).
CXTPBrush::CreateSolidBrush
BOOL CreateSolidBrush(COLORREF crColor)
Initializes a brush with a specified solid color.
CXTPBrush::~CXTPBrush
~CXTPBrush()
Handles CXTPBrush object destruction.
CXTPBrush::CXTPBrush
CXTPBrush()
Constructs an empty CXTPBrush object.
CXTPBrush::CreateBrushIndirect
BOOL CreateBrushIndirect(const LOGBRUSH *lpLogBrush)
Initializes a brush with a style, color, and pattern specified in a LOGBRUSH structure.
CXTPBrush::CXTPBrush
CXTPBrush(int nIndex, COLORREF crColor)
Initializes a brush with the specified hatched pattern and color.
CXTPFont
Provides a convenient object oriented interface for HFONT GDI object and uses GDI handle caching.
Definition XTPGdiObjects.h:414
CXTPFont::CreatePointFont
BOOL CreatePointFont(int nPointSize, LPCTSTR lpszFaceName, CDC *pDC=NULL)
This function provides a simple way to create a font of a specified typeface and point size.
CXTPFont::CreateFont
BOOL CreateFont(int nHeight, int nWidth, int nEscapement, int nOrientation, int nWeight, BYTE bItalic, BYTE bUnderline, BYTE cStrikeOut, BYTE nCharSet, BYTE nOutPrecision, BYTE nClipPrecision, BYTE nQuality, BYTE nPitchAndFamily, LPCTSTR lpszFacename)
Initializes a CFont object with the specified characteristics.
CXTPFont::CreatePointFontIndirect
BOOL CreatePointFontIndirect(const LOGFONT *lpLogFont, CDC *pDC=NULL)
This function is the same as CreateFontIndirect except that the lfHeight member of the LOGFONT is int...
CXTPFont::CreateFontIndirect
BOOL CreateFontIndirect(const LOGFONT *lpLogFont)
Initializes a CFont object with the characteristics given in a LOGFONTstructure.
CXTPFont::GetNativeGdiObject
const CFont * GetNativeGdiObject() const
Obtains a pointer to the encapsulated GDI object as CFont type.
CXTPFont::~CXTPFont
~CXTPFont()
Handles CXTPFont object destruction.
CXTPFont::CXTPFont
CXTPFont()
Constructs empty CXTPFont object.
CXTPFont::GetNativeGdiObject
CFont * GetNativeGdiObject()
Obtains a pointer to the encapsulated GDI object as CFont type.
CXTPFont::GetLogFont
int GetLogFont(LOGFONT *pLogFont)
Call this function to retrieve a copy of the LOGFONT structure that describes the encapsulated GDI ob...
CXTPGdiObject
Implements common functionality for all XTP GDI object.
Definition XTPGdiObjects.h:170
CXTPGdiObject::operator==
BOOL operator==(const CXTPGdiObject &obj) const
Determines if two GDI objects are logically equal.
CXTPGdiObject::__declspec
__declspec(property(get=GetSafeHandle)) HGDIOBJ m_hObject
A read-only encapsulated GDI handle value.
CXTPGdiObject::GetObject
int GetObject(int nCount, LPVOID lpObject) const
Fills a buffer with data that defines a specified object.
CXTPGdiObject::~CXTPGdiObject
virtual ~CXTPGdiObject()=0
Handles CXTPGdiObject destruction.
CXTPGdiObject::IsHandleOwnershipGuaranteed
BOOL IsHandleOwnershipGuaranteed() const
Determines handle ownership guaranteed status.
CXTPGdiObject::DeleteObject
BOOL DeleteObject()
Decrements reference counter for a cached GDI object or delete the cached GDI object once the referen...
CXTPGdiObject::SetHandleOwnershipNotGuaranteed
void SetHandleOwnershipNotGuaranteed()
Sets handle ownership guaranteed status.
CXTPGdiObject::CXTPGdiObject
CXTPGdiObject()
Performs internal CXTPGdiObject construction logic.
CXTPGdiObject::operator!=
BOOL operator!=(const CXTPGdiObject &obj) const
Determines if two GDI objects are logically not equal.
CXTPGdiObject::CreateStockObject
BOOL CreateStockObject(int nIndex)
Retrieves a handle to one of the predefined stock Windows GDI pens, brushes, or fonts,...
CXTPGdiObject::GetSafeHandle
HGDIOBJ GetSafeHandle() const
Returns m_hObject unless this is NULL, in which case NULL is returned.
CXTPGdiObject::GetObjectType
UINT GetObjectType() const
Retrieves the type of the GDI object.
CXTPImageList
CXTPImageList extends CImageList with add additional functionality for images resizing that depends o...
Definition XTPImageList.h:39
CXTPPen
Provides a convenient object oriented interface for HPEN GDI object and uses GDI handle caching.
Definition XTPGdiObjects.h:949
CXTPPen::GetNativeGdiObject
CPen * GetNativeGdiObject()
Obtains a pointer to the encapsulated GDI object as CPen type.
CXTPPen::~CXTPPen
~CXTPPen()
Handles CXTPPen object destruction.
CXTPPen::CXTPPen
CXTPPen(int nPenStyle, int nWidth, const LOGBRUSH *pLogBrush, int nStyleCount=0, const DWORD *lpStyle=NULL)
Constructs a CXTPPen object.
CXTPPen::CreatePen
BOOL CreatePen(int nPenStyle, int nWidth, COLORREF crColor)
Creates a pen with specified parameters.
CXTPPen::CXTPPen
CXTPPen()
Constructs an empty CXTPPen object.
CXTPPen::GetLogPen
int GetLogPen(LOGPEN *pLogPen)
Call this function to retrieve a copy of the LOGPEN structure that describes the encapsulated GDI obj...
CXTPPen::CXTPPen
CXTPPen(int nPenStyle, int nWidth, COLORREF crColor)
Constructs a CXTPPen object.
CXTPPen::CreatePen
BOOL CreatePen(int nPenStyle, int nWidth, const LOGBRUSH *pLogBrush, int nStyleCount=0, const DWORD *lpStyle=NULL)
Creates a pen with specified parameters.
CXTPPen::GetExtLogPen
int GetExtLogPen(EXTLOGPEN *pLogPen)
Call this function to retrieve a copy of the EXTLOGPEN structure that describes the encapsulated GDI ...
CXTPPen::CreatePenIndirect
BOOL CreatePenIndirect(LPLOGPEN lpLogPen)
Creates a pen with specified parameters.
CXTPPen::GetNativeGdiObject
const CPen * GetNativeGdiObject() const
Obtains a pointer to the encapsulated GDI object as CPen type.
CXTPSingleton
Implements Singleton design pattern.
Definition XTPSingleton.h:215
CXTPSynchronized
A base class for a synchronized object.
Definition XTPSynchro.h:602


Toolkit Pro: Member List

CXTPPopupControl Member List

This is the complete list of members for CXTPPopupControl, including all inherited members.

AddItem(CXTPPopupItem *pItem) | CXTPPopupControl |
AllowMove(BOOL bAllowMove) | CXTPPopupControl |
Animate(int nStep) | CXTPPopupControl | protected
Close() | CXTPPopupControl |
Create(CWnd *pParentWnd) | CXTPPopupControl | protectedvirtual
CXTPPopupControl(BOOL bAutoDelete=FALSE) | CXTPPopupControl |
EnableDpiBitmapScaling(BOOL bEnable=TRUE) | CXTPPopupControl |
EnableMarkup(BOOL bEnableMarkup) | CXTPPopupControl |
GetAnimateDelay() const | CXTPPopupControl |
GetBackgroundBitmap() const | CXTPPopupControl |
GetID() const | CXTPPopupControl |
GetImageManager() const | CXTPPopupControl |
GetItem(int nIndex) const | CXTPPopupControl |
GetItemCount() const | CXTPPopupControl |
GetMarkupContext() const | CXTPPopupControl |
GetPaintManager() const | CXTPPopupControl |
GetPopupAnimation() const | CXTPPopupControl |
GetPopupPos() const | CXTPPopupControl |
GetPopupSize() const | CXTPPopupControl |
GetPopupState() const | CXTPPopupControl |
GetShowDelay() const | CXTPPopupControl |
GetSplashScreenMode() const | CXTPPopupControl |
GetTheme() const | CXTPPopupControl |
GetTransparency() const | CXTPPopupControl |
Hide() | CXTPPopupControl |
HitTest(CPoint pt) const | CXTPPopupControl |
IsDpiBitmapScalingEnabled() const | CXTPPopupControl |
IsLayoutRTL() const | CXTPPopupControl |
m_arrItems | CXTPPopupControl | protected
m_bAllowMove | CXTPPopupControl | protected
m_bAutoDelete | CXTPPopupControl | protected
m_bRightToLeft | CXTPPopupControl | protected
m_bSplashScreenMode | CXTPPopupControl | protected
m_hHandCursor | CXTPPopupControl | protected
m_nAnimationInterval | CXTPPopupControl | protected
m_nBackgroundBitmap | CXTPPopupControl | protected
m_nCurrentTransparency | CXTPPopupControl | protected
m_nID | CXTPPopupControl | protected
m_nPopupLocation | CXTPPopupControl | protected
m_nStep | CXTPPopupControl | protected
m_nTransparency | CXTPPopupControl | protected
m_paintTheme | CXTPPopupControl | protected
m_pImageManager | CXTPPopupControl | protected
m_pMarkupContext | CXTPPopupControl | protected
m_popupAnimation | CXTPPopupControl | protected
m_popupState | CXTPPopupControl | protected
m_pPaintManager | CXTPPopupControl | protected
m_pPressed | CXTPPopupControl | protected
m_pSelected | CXTPPopupControl | protected
m_ptPopup | CXTPPopupControl | protected
m_stateCurrent | CXTPPopupControl | protected
m_stateTarget | CXTPPopupControl | protected
m_szPopup | CXTPPopupControl | protected
m_uAnimationDelay | CXTPPopupControl | protected
m_uShowDelay | CXTPPopupControl | protected
Notify(WPARAM wParam, LPARAM lParam) | CXTPPopupControl | protectedvirtual
OnClick(CXTPPopupItem *pItem) | CXTPPopupControl | protectedvirtual
OnCollapsing() | CXTPPopupControl | protectedvirtual
OnExpanding(BOOL bUpdateCurrent) | CXTPPopupControl | protectedvirtual
OnShow() | CXTPPopupControl | protectedvirtual
RedrawControl() | CXTPPopupControl |
RemoveAllItems() | CXTPPopupControl |
RemoveItem(CXTPPopupItem *pItem) | CXTPPopupControl |
RemoveItem(int nIndex) | CXTPPopupControl |
SetAnimateDelay(DWORD dwAnimateDelay) | CXTPPopupControl |
SetAutoDelete(BOOL bAutoDelete) | CXTPPopupControl |
SetBackgroundBitmap(int nBackgroundBitmap) | CXTPPopupControl |
SetDefaultLocation(XTPPopupLocation nPopupLocation) | CXTPPopupControl |
SetImageManager(CXTPImageManager *pImageManager) | CXTPPopupControl |
SetLayeredWindowAttributes(int bAlpha) | CXTPPopupControl | protected
SetLayoutRTL(BOOL bRightToLeft) | CXTPPopupControl |
SetPopupAnimation(XTPPopupAnimation popupAnimation) | CXTPPopupControl |
SetPopupAnimation() | CXTPPopupControl |
SetPopupPos(CPoint ptPopup) | CXTPPopupControl |
SetPopupSize(CSize szPopup) | CXTPPopupControl |
SetPopupState(XTPPopupState popupState) | CXTPPopupControl | protected
SetShowDelay(DWORD dwShowDelay) | CXTPPopupControl |
SetSplashScreenMode(BOOL bSet) | CXTPPopupControl |
SetTheme(XTPPopupPaintTheme theme) | CXTPPopupControl |
SetTheme(CXTPPopupPaintManager *pPaintManager) | CXTPPopupControl |
SetTransparency(BYTE bTransp) | CXTPPopupControl |
Show(CWnd *pParent, int nID=0) | CXTPPopupControl |
ShowModal(CWnd *pParent, int nID=0) | CXTPPopupControl |
TrackMove() | CXTPPopupControl | protected
UpdateState(BOOL bInit=FALSE) | CXTPPopupControl | protected
~CXTPPopupControl() | CXTPPopupControl | virtual


Toolkit Pro: Member List

CXTPChartAxisRange Member List

This is the complete list of members for CXTPChartAxisRange, including all inherited members.

Correct(CXTPChartAxisView *pView) | CXTPChartAxisRange | protected
CXTPChartAxisRange(CXTPChartAxis *pAxis) | CXTPChartAxisRange |
CXTPChartElement() | CXTPChartElement |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
DoPropExchange(CXTPPropExchange *pPX) | CXTPChartAxisRange | virtual
GetAppearance() const | CXTPChartElement |
GetContent() const | CXTPChartElement |
GetMaxValue() const | CXTPChartAxisRange |
GetMinValue() const | CXTPChartAxisRange |
GetOwner() const | CXTPChartElement |
GetShowZeroLevel() const | CXTPChartAxisRange |
GetSideMargins() const | CXTPChartAxisRange |
GetViewMaxValue() const | CXTPChartAxisRange |
GetViewMinValue() const | CXTPChartAxisRange |
Is3D() const | CXTPChartObject |
m_bShowZeroLevel | CXTPChartAxisRange | protected
m_bSideMargins | CXTPChartAxisRange | protected
m_nMaxValue | CXTPChartAxisRange | protected
m_nMinValue | CXTPChartAxisRange | protected
m_pAxis | CXTPChartAxisRange | protected
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartElement | virtual
Release() | CXTPChartElement | virtual
SetAutoRange(BOOL bAutoRange) | CXTPChartAxisRange |
SetMaxValue(double dMaxValue) | CXTPChartAxisRange |
SetMinValue(double dMinValue) | CXTPChartAxisRange |
SetShowZeroLevel(BOOL bShowZeroLevel) | CXTPChartAxisRange |
SetSideMargins(BOOL bSideMargins) | CXTPChartAxisRange |
SetViewAutoRange(BOOL bAutoRange) | CXTPChartAxisRange |
SetViewMaxValue(double dMaxValue) | CXTPChartAxisRange |
SetViewMinValue(double dMinValue) | CXTPChartAxisRange |
UpdateRange(CXTPChartAxisView *pView) | CXTPChartAxisRange |
~CXTPChartAxisRange() | CXTPChartAxisRange | virtual
~CXTPChartElement() | CXTPChartElement | virtual


Toolkit Pro: Member List

CXTPChartLegendView Member List

This is the complete list of members for CXTPChartLegendView, including all inherited members.

AddChildView(CXTPChartElementView *pChildView) | CXTPChartElementView |
AddItem(CXTPChartLegendItemView *pItem, double minimum=0, double maximum=0) | CXTPChartLegendView |
CalcSize(CXTPChartDeviceContext *pDC) | CXTPChartLegendView |
CalculateView(CXTPChartDeviceContext *pDC, CRect &rcChart) | CXTPChartLegendView |
CreateDeviceCommand(CXTPChartDeviceContext *pDC) | CXTPChartLegendView | virtual
CXTPChartElementView(CXTPChartElementView *pParentView) | CXTPChartElementView |
CXTPChartElementView(CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartElementView |
CXTPChartElementView(CXTPChartContainer *pContainer) | CXTPChartElementView |
CXTPChartLegendView(CXTPChartLegend *pLegend, CXTPChartElementView *pParentView) | CXTPChartLegendView |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
GetAt(int nIndex) const | CXTPChartElementView |
GetBounds() const | CXTPChartElementView |
GetBounds(BOOL bIncludingChildren) const | CXTPChartElementView |
GetChildren() | CXTPChartElementView |
GetCount() const | CXTPChartElementView |
GetParentView() const | CXTPChartElementView |
Is3D() const | CXTPChartObject |
m_arrChildren | CXTPChartElementView | protected
m_arrItems | CXTPChartLegendView | protected
m_pContainer | CXTPChartElementView | protected
m_pLegend | CXTPChartLegendView | protected
m_pParentView | CXTPChartElementView | protected
m_rcBounds | CXTPChartLegendView | protected
~CXTPChartElementView() | CXTPChartElementView | protectedvirtual
~CXTPChartLegendView() | CXTPChartLegendView | virtual


Toolkit Pro: Member List

CXTPScrollBarThemeVisualStudio2022 Member List

This is the complete list of members for CXTPScrollBarThemeVisualStudio2022, including all inherited members.

CalcHScroll(CXTPScrollBase *pScroll, XTPScrollMetricsH *pHScroll) | CXTPScrollBarPaintManager | protectedstatic
CalcVScroll(CXTPScrollBase *pScroll, XTPScrollMetricsV *pVScroll) | CXTPScrollBarPaintManager | protectedstatic
CXTPScrollBarPaintManager() | CXTPScrollBarPaintManager |
DrawArrowGlyph(CDC *pDC, CRect rcArrow, XTPArrowGlyph glyph, BOOL bEnabled, COLORREF clrText=COLORREF_NULL) | CXTPScrollBarPaintManager | protected
DrawArrows(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics) | CXTPScrollBarThemeVisualStudio2012 | protectedvirtual
DrawArrows(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics) | CXTPScrollBarThemeVisualStudio2012 | protectedvirtual
DrawBackground(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics) | CXTPScrollBarThemeVisualStudio2012 | protectedvirtual
DrawBackground(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics) | CXTPScrollBarThemeVisualStudio2012 | protectedvirtual
DrawButtons(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics) | CXTPScrollBarThemeVisualStudio2012 | protectedvirtual
DrawButtons(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics) | CXTPScrollBarThemeVisualStudio2012 | protectedvirtual
DrawGripper(CDC *pDC, CXTPScrollBase *pScroll) | CXTPScrollBarThemeVisualStudio2012 | protectedvirtual
DrawScrollBar(CDC *pDC, CXTPScrollBase *pScrollBar) | CXTPScrollBarThemeVisualStudio2022 | protectedvirtual
DrawThumbButton(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics) | CXTPScrollBarThemeVisualStudio2012 | protectedvirtual
DrawThumbButton(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics) | CXTPScrollBarThemeVisualStudio2012 | protectedvirtual
DrawTracker(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics) | CXTPScrollBarPaintManager | protectedvirtual
DrawTracker(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics) | CXTPScrollBarPaintManager | protectedvirtual
m_crBack | CXTPScrollBarPaintManager |
m_crBackHilite | CXTPScrollBarPaintManager |
m_crBackPushed | CXTPScrollBarPaintManager |
m_crBorder | CXTPScrollBarPaintManager |
m_crBorderHilite | CXTPScrollBarPaintManager |
m_cThumb | CXTPScrollBarPaintManager |
m_cxHScroll | CXTPScrollBarPaintManager |
m_cxVScroll | CXTPScrollBarPaintManager |
m_cyHScroll | CXTPScrollBarPaintManager |
m_cyVScroll | CXTPScrollBarPaintManager |
RefreshMetrics() | CXTPScrollBarPaintManager | virtual


Toolkit Pro: Member List

CXTPDockingPaneCaptionButtons Member List

This is the complete list of members for CXTPDockingPaneCaptionButtons, including all inherited members.

CheckForMouseOver(CPoint pt) CXTPDockingPaneCaptionButtons


Toolkit Pro: Member List

CXTPDockingPaneTabColorSetVisualStudio2005 Member List

This is the complete list of members for CXTPDockingPaneTabColorSetVisualStudio2005, including all inherited members.

CXTPDockingPaneTabColorSetVisualStudio2003(BOOL bHighlightSelected) | CXTPDockingPaneTabColorSetVisualStudio2003 |
CXTPDockingPaneTabColorSetVisualStudio2005(BOOL bHighlightSelected) | CXTPDockingPaneTabColorSetVisualStudio2005 |
CXTPTabPaintManagerColorSet() | CXTPTabPaintManagerColorSet |
FillClient(CDC *pDC, CRect rc, CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
FillFramePartRect(CDC *pDC, CRect rc, CWnd *pWnd, CWnd *pSite) | CXTPDockingPaneTabColorSetVisualStudio2003 |
FillHeader(CDC *pDC, CRect rc, CXTPTabManager *pTabManager) | CXTPDockingPaneTabColorSetVisualStudio2003 | virtual
FillNavigateButton(CDC *pDC, CXTPTabManagerNavigateButton *pButton, CRect &rc) | CXTPTabColorSetOffice2003 | virtual
FillPropertyButton(CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem) | CXTPDockingPaneTabColorSetVisualStudio2003 | virtual
FillStateButton(CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerColorSet | virtual
GetClientColor(CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
GetItemColor(CXTPTabManagerItem *pItem) | CXTPTabPaintManagerColorSet | virtual
GradientFill(CDC *pDC, CRect rc, COLORREF clrLight, COLORREF clrDark, XTPTabPosition position) | CXTPTabPaintManagerColorSet |
IsAppThemed() const | CXTPTabPaintManagerColorSet | virtual
m_bLunaTheme | CXTPTabColorSetOffice2003 | protected
m_clrActiveFilesBack | CXTPTabPaintManagerColorSet |
m_clrActiveFilesBackHighlighted | CXTPTabPaintManagerColorSet |
m_clrActiveFilesBackPressed | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyph | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyphHighlighted | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyphPressed | CXTPTabPaintManagerColorSet |
m_clrAutoHideFace | CXTPTabPaintManagerColorSet |
m_clrBorderHighlight | CXTPTabPaintManagerColorSet |
m_clrButtonBorder | CXTPTabPaintManagerColorSet |
m_clrButtonBorderHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonBorderHot | CXTPTabPaintManagerColorSet |
m_clrButtonBorderKeyTips | CXTPTabPaintManagerColorSet |
m_clrButtonBorderTabContext1 | CXTPTabPaintManagerColorSet |
m_clrButtonBorderTabContext2 | CXTPTabPaintManagerColorSet |
m_clrButtonHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonHighlightedClose | CXTPTabPaintManagerColorSet |
m_clrButtonNormal | CXTPTabPaintManagerColorSet |
m_clrButtonPressed | CXTPTabPaintManagerColorSet |
m_clrButtonSelected | CXTPTabPaintManagerColorSet |
m_clrButtonSelectedHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonSelectedPressed | CXTPTabPaintManagerColorSet |
m_clrControlFace | CXTPTabPaintManagerColorSet |
m_clrFrameBorder | CXTPTabPaintManagerColorSet |
m_clrHeaderFace | CXTPTabPaintManagerColorSet |
m_clrNavigateButtonBorder | CXTPTabColorSetOffice2003 | protected
m_clrPaneFace | CXTPTabPaintManagerColorSet |
m_clrTabClientBack | CXTPTabPaintManagerColorSet |
m_clrTabClientBorder | CXTPTabPaintManagerColorSet |
m_clrTextDisabled | CXTPTabPaintManagerColorSet |
m_clrTextHighlight | CXTPTabPaintManagerColorSet |
m_clrTextHighlightClose | CXTPTabPaintManagerColorSet |
m_clrTextNormal | CXTPTabPaintManagerColorSet |
m_clrTextPressed | CXTPTabPaintManagerColorSet |
m_clrTextSelected | CXTPTabPaintManagerColorSet |
m_clrTextSelectedHighlighted | CXTPTabPaintManagerColorSet |
m_clrTextSelectedPressed | CXTPTabPaintManagerColorSet |
m_csExcelNormal | CXTPTabPaintManagerColorSet |
m_csExcelSelected | CXTPTabPaintManagerColorSet |
m_csPropertyPage | CXTPTabPaintManagerColorSet |
m_csPropertyPage2003 | CXTPTabPaintManagerColorSet |
m_csStateButton | CXTPTabPaintManagerColorSet |
m_pPaintManager | CXTPTabPaintManagerColorSet | protected
Rectangle(CDC *pDC, CRect rc, int nPen, int nBrush) | CXTPTabColorSetOffice2003 |
RefreshMetrics() | CXTPDockingPaneTabColorSetVisualStudio2005 | virtual
SelectClipRgn(CDC *pDC, CRect rcClient, CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
SetTextColor(CDC *pDC, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerColorSet | virtual
~CXTPTabPaintManagerColorSet() | CXTPTabPaintManagerColorSet | virtual


Toolkit Pro: Member List

CXTPEditThemeResource Member List

This is the complete list of members for CXTPEditThemeResource, including all inherited members.

AdjustBuddyRect(CWnd *pBuddy, CRect &rcUpDown, int nAlignment) | CXTPEditThemeResource | virtual
CtlColor(CDC *pDC, UINT nCtlColor, CXTPEdit *pEdit) | CXTPEditThemeDefault | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPControlTheme() | CXTPControlTheme |
CXTPEditTheme() | CXTPEditTheme |
CXTPEditThemeDefault() | CXTPEditThemeDefault |
CXTPEditThemeOffice2000() | CXTPEditThemeOffice2000 |
CXTPEditThemeOfficeXP() | CXTPEditThemeOfficeXP |
CXTPEditThemeResource() | CXTPEditThemeResource |
DrawBuddyBorders(CWnd *pBuddy, CDC *pDC, CRect rc, int nAlignment, CXTPEdit *pEdit) | CXTPEditThemeResource | virtual
CXTPEditThemeOffice2000::DrawBuddyBorders(CDC *pDC, CRect rc, int nAlignment, CXTPEdit *pEdit) | CXTPEditThemeOffice2000 | virtual
DrawFrame(CDC *pDC, CRect rc, int nSize, CBrush *pBrush) | CXTPEditTheme | virtual
DrawNcBorders(CDC *pDC, CRect rcWnd, CXTPEdit *pEdit) | CXTPEditThemeOfficeXP | virtual
DrawNcBordersDefault(CDC *pDC, CRect rcWnd, CXTPEdit *pEdit) | CXTPEditThemeDefault | protectedvirtual
DrawNcScrollBack(CDC *pDC, CRect rcWnd, CXTPEdit *pEdit) | CXTPEditThemeDefault | virtual
FillRect(CDC *pDC, int x, int y, int cx, int cy, CBrush *pBrush) | CXTPEditTheme | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetClientBrush(CDC *pDC, CXTPEdit *pEdit) | CXTPEditTheme | virtual
GetThemeID() const | CXTPEditTheme |
GetThemeStyle() const | CXTPControlTheme |
IsFlatStyle() const | CXTPEditTheme |
m_bFlatStyle | CXTPEditTheme | protected
m_bUseWinTheme | CXTPEditTheme | protected
m_clrBack | CXTPEditTheme |
m_clrBackNonClient | CXTPEditTheme |
m_clrBorder | CXTPEditTheme |
m_clrBorderDisabled | CXTPEditThemeOfficeXP | protected
m_clrBorderHilite | CXTPEditThemeOfficeXP | protected
m_clrText | CXTPEditTheme |
m_clrTextReadOnly | CXTPEditTheme |
m_nTheme | CXTPEditTheme | protected
m_winTheme | CXTPEditTheme | protected
m_xtpBrushBack | CXTPEditTheme |
RedrawFocusedFrame() const | CXTPEditThemeOfficeXP | virtual
RefreshMetrics(CXTPEdit *pEdit) | CXTPEditThemeResource | virtual
SetFlatStyle(BOOL bFlatStyle) | CXTPEditTheme |
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static
UseWinTheme(BOOL bUseWinTheme) | CXTPEditTheme |
~CXTPEditTheme() | CXTPEditTheme | virtual
~CXTPEditThemeDefault() | CXTPEditThemeDefault | virtual
~CXTPEditThemeOffice2000() | CXTPEditThemeOffice2000 | virtual
~CXTPEditThemeOfficeXP() | CXTPEditThemeOfficeXP | virtual
~CXTPEditThemeResource() | CXTPEditThemeResource | virtual


Toolkit Pro: XTPTaskPanelVisualStudio2015Theme.h Source File

  • Source
  • TaskPanel
  • Themes
XTPTaskPanelVisualStudio2015Theme.h
Go to the documentation of this file.
1
23#if !defined(__XTPTASKPANELVISUALSTUDIO2015THEME_H__)
24# define __XTPTASKPANELVISUALSTUDIO2015THEME_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
39class _XTP_EXT_CLASS CXTPTaskPanelVisualStudio2015Theme : public CXTPTaskPanelVisualStudio2012Theme
40{
41protected:
42 void Triangle(CDC* pDC, POINT* pPoints, COLORREF clr, BOOL bFilled);
43
44public:
49 CXTPTaskPanelVisualStudio2015Theme();
50
56 virtual ~CXTPTaskPanelVisualStudio2015Theme();
57
62 virtual void RefreshMetrics();
63};
65# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
66#endif // __XTPTASKPANELVISUALSTUDIO2015THEME_H__
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPTaskPanelVisualStudio2012Theme
CXTPTaskPanelVisualStudio2012Theme represents a VS.NET 2012 style theme.
Definition XTPTaskPanelVisualStudio2012Theme.h:40
CXTPTaskPanelVisualStudio2015Theme
CXTPTaskPanelVisualStudio2015Theme represents a Visutal Studio 2015 style theme.
Definition XTPTaskPanelVisualStudio2015Theme.h:40
CXTPTaskPanelVisualStudio2015Theme::~CXTPTaskPanelVisualStudio2015Theme
virtual ~CXTPTaskPanelVisualStudio2015Theme()
Destroys a CXTPTaskPanelVisualStudio2015Theme object, handles cleanup and deallocation.
CXTPTaskPanelVisualStudio2015Theme::CXTPTaskPanelVisualStudio2015Theme
CXTPTaskPanelVisualStudio2015Theme()
Constructs a CXTPTaskPanelVisualStudio2015Theme object.
CXTPTaskPanelVisualStudio2015Theme::RefreshMetrics
virtual void RefreshMetrics()
Refreshes the visual metrics of the task panel.


Toolkit Pro: XTPSyntaxEditColorSampleText.h Source File

  • Source
  • SyntaxEdit
XTPSyntaxEditColorSampleText.h
Go to the documentation of this file.
1
23#if !defined(__XTPSYNTAXEDITPROPERTIESSAMPLETEXT_H__)
24# define __XTPSYNTAXEDITPROPERTIESSAMPLETEXT_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
37class _XTP_EXT_CLASS CXTPSyntaxEditColorSampleText : public CStatic
38{
39public:
44 CXTPSyntaxEditColorSampleText();
45
50 virtual ~CXTPSyntaxEditColorSampleText();
51
52public:
58 void SetTextColor(COLORREF crText);
59
66 COLORREF GetTextColor() const;
67
73 void SetBackColor(COLORREF crBack);
74
81 COLORREF GetBackColor() const;
82
88 void SetBorderColor(COLORREF crBorder);
89
96 COLORREF GetBorderColor() const;
97
102 void Refresh();
103
104 //{{AFX_VIRTUAL(CXTPSyntaxEditColorSampleText)
105 //}}AFX_VIRTUAL
106
107 //{{AFX_MSG(CXTPSyntaxEditColorSampleText)
109 afx_msg void OnNcPaint();
110 afx_msg void OnPaint();
111 afx_msg void OnSysColorChange();
112 afx_msg void OnEnable(BOOL bEnable);
114 //}}AFX_MSG
116 DECLARE_MESSAGE_MAP()
118private:
119 CXTPPaintManagerColor m_crBack;
120 CXTPPaintManagerColor m_crText;
121 CXTPPaintManagerColor m_crBorder;
122};
123
124# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
126#endif // !defined(__XTPSYNTAXEDITPROPERTIESSAMPLETEXT_H__)
XTPDisableNoisyWarnings.h
CXTPPaintManagerColor
The CXTPPaintManagerColor class is used to manage COLORREF values for determining default and applica...
Definition XTPColorManager.h:117
CXTPSyntaxEditColorSampleText
This class, derived from CStatic, is used to display a sample of colored text.
Definition XTPSyntaxEditColorSampleText.h:38
CXTPSyntaxEditColorSampleText::~CXTPSyntaxEditColorSampleText
virtual ~CXTPSyntaxEditColorSampleText()
Default object destructor.
CXTPSyntaxEditColorSampleText::GetBorderColor
COLORREF GetBorderColor() const
Gets the border color.
CXTPSyntaxEditColorSampleText::GetTextColor
COLORREF GetTextColor() const
Gets the text color.
CXTPSyntaxEditColorSampleText::SetBorderColor
void SetBorderColor(COLORREF crBorder)
Sets the border color.
CXTPSyntaxEditColorSampleText::SetBackColor
void SetBackColor(COLORREF crBack)
Sets the background color.
CXTPSyntaxEditColorSampleText::GetBackColor
COLORREF GetBackColor() const
Gets the background color.
CXTPSyntaxEditColorSampleText::CXTPSyntaxEditColorSampleText
CXTPSyntaxEditColorSampleText()
Default object constructor.
CXTPSyntaxEditColorSampleText::Refresh
void Refresh()
Redraws the control.
CXTPSyntaxEditColorSampleText::SetTextColor
void SetTextColor(COLORREF crText)
Sets the text color.


Toolkit Pro: XTPTabThemeOffice2000.h Source File

  • Source
  • TabManager
  • Themes
XTPTabThemeOffice2000.h
Go to the documentation of this file.
1
23#if !defined(__XTPTABTHEMEOFFICE2000_H__)
24# define __XTPTABTHEMEOFFICE2000_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
48class _XTP_EXT_CLASS CXTPTabThemeOffice2000 : public CXTPTabPaintManagerTheme
49{
50public:
55 CXTPTabThemeOffice2000()
56 {
57 m_rcHeaderMargin.SetRect(2, 3, 6, 0);
58 }
59
68 virtual void RefreshMetrics();
69
85 virtual void DrawSingleButton(CDC* pDC, CXTPTabManagerItem* pItem);
86
106 virtual CRect FillTabControl(CXTPTabManager* pTabManager, CDC* pDC, CRect rcControl);
107
116 virtual XTPTabColorStyle GetDefaultColorSet()
117 {
118 return xtpTabColorDefault;
119 }
120
151 virtual CRect GetClientMargin();
152
163 virtual CRect GetButtonDrawRect(const CXTPTabManagerItem* pItem);
164
173 virtual CRect GetHeaderClipBox(CDC* pDC, CXTPTabManager* pTabManager);
174};
175
176class _XTP_EXT_CLASS CXTPTabPaintManager::CAppearanceSetPropertyPage : public CXTPTabThemeOffice2000
177{
178};
179
180# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
182#endif // !defined(__XTPTABTHEMEOFFICE2000_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPTabColorStyle
XTPTabColorStyle
XTPTabColorStyle is an enumeration used to set the color style of tabs.
Definition XTPTabManagerDefines.h:139
xtpTabColorDefault
@ xtpTabColorDefault
Tabs will use the default color for the currently set Appearance.
Definition XTPTabManagerDefines.h:140
CXTPTabManager
CXTPTabManager is the base class for docking pane tabs, tab control tabs, and MDI client tabs.
Definition XTPTabManager.h:87
CXTPTabManagerItem
CXTPTabManagerItem is the base class for the tabs that appear in the command bars tab workspace,...
Definition XTPTabManagerItem.h:44
CXTPTabPaintManager
CXTPTabPaintManager is used to store the color and appearance information of the tabs in the tab mana...
Definition XTPTabPaintManager.h:48
CXTPTabPaintManagerTheme
CXTPTabPaintManagerTheme is a class that represents the appearance of all components of the tab manag...
Definition XTPTabPaintManagerTheme.h:56
CXTPTabThemeOffice2000
CXTPTabThemeOffice2000 implements an Office 2000 tab appearance.
Definition XTPTabThemeOffice2000.h:49
CXTPTabThemeOffice2000::CXTPTabThemeOffice2000
CXTPTabThemeOffice2000()
Constructs a CXTPTabThemeOffice2000 object.
Definition XTPTabThemeOffice2000.h:55
CXTPTabThemeOffice2000::GetDefaultColorSet
virtual XTPTabColorStyle GetDefaultColorSet()
Gets the default value of the color set for this theme.
Definition XTPTabThemeOffice2000.h:116
CXTPTabThemeOffice2000::GetClientMargin
virtual CRect GetClientMargin()
Gets the top, left, right, and bottom margins of the tab client area.
CXTPTabThemeOffice2000::GetButtonDrawRect
virtual CRect GetButtonDrawRect(const CXTPTabManagerItem *pItem)
Retrieves the bounding rectangle of a specified drawing item.
CXTPTabThemeOffice2000::GetHeaderClipBox
virtual CRect GetHeaderClipBox(CDC *pDC, CXTPTabManager *pTabManager)
Gets the clip box of the tab header area.
CXTPTabThemeOffice2000::FillTabControl
virtual CRect FillTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl)
Fills both the tab header and the tab client area and then draws the tab client frame.
CXTPTabThemeOffice2000::DrawSingleButton
virtual void DrawSingleButton(CDC *pDC, CXTPTabManagerItem *pItem)
Draws a single tab button in the tab client header area.
CXTPTabThemeOffice2000::RefreshMetrics
virtual void RefreshMetrics()
Refreshes the appearance metrics.


Toolkit Pro: XTPChartPointSeriesView.h Source File

  • Source
  • Chart
  • Styles
  • Point
XTPChartPointSeriesView.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTPOINTSERIESVIEW_H__)
24# define __XTPCHARTPOINTSERIESVIEW_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartSeriesView;
34class CXTPChartMarker;
35
41class _XTP_EXT_CLASS CXTPChartPointSeriesView : public CXTPChartDiagram2DSeriesView
42{
43public:
51 CXTPChartPointSeriesView(CXTPChartSeries* pSeries, CXTPChartDiagramView* pDiagramView);
52
53protected:
65 CXTPChartSeriesPointView* CreateSeriesPointView(CXTPChartDeviceContext* pDC,
66 CXTPChartSeriesPoint* pPoint,
67 CXTPChartElementView* pParentView);
68
69public:
80 virtual CXTPChartDeviceCommand* CreateLegendDeviceCommand(CXTPChartDeviceContext* pDC,
81 CRect rcBounds);
82};
83
89class _XTP_EXT_CLASS CXTPChartPointSeriesPointView : public CXTPChartSeriesPointView
90{
91public:
99 CXTPChartPointSeriesPointView(CXTPChartSeriesPoint* pPoint, CXTPChartElementView* pParentView);
100
101public:
114 virtual CXTPChartDeviceCommand* CreateDeviceCommand(CXTPChartDeviceContext* pDC);
115
126 virtual CXTPChartDeviceCommand* CreateLegendDeviceCommand(CXTPChartDeviceContext* pDC,
127 CRect rcBounds);
128
136 CXTPChartPointF GetScreenPoint() const;
137};
139# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
140#endif //#if !defined(__XTPCHARTPOINTSERIESVIEW_H__)
pPoint
const CPoint * pPoint
return 0 or xtpCalendarHitTestDayExpandButton
Definition XTPCalendarThemeOffice2007.h:150
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartDiagramView
This class represents the view of a chart diagram, which is a kind of CXTPChartElementView.
Definition XTPChartDiagramView.h:49
CXTPChartElementView
This class represents the view of a chart element.
Definition XTPChartElementView.h:47
CXTPChartMarker
This class abstracts a marker used in marking the points in a point series style chart.
Definition XTPChartMarker.h:64
CXTPChartPointSeriesPointView
This class represents the view of a point series point, which is a kind of CXTPChartSeriesPointView.
Definition XTPChartPointSeriesView.h:90
CXTPChartPointSeriesPointView::CreateDeviceCommand
virtual CXTPChartDeviceCommand * CreateDeviceCommand(CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
CXTPChartPointSeriesPointView::CreateLegendDeviceCommand
virtual CXTPChartDeviceCommand * CreateLegendDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcBounds)
This function creates a label view drawing command object.
CXTPChartPointSeriesPointView::CXTPChartPointSeriesPointView
CXTPChartPointSeriesPointView(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Constructs a CXTPChartPointSeriesPointView object.
CXTPChartPointSeriesPointView::GetScreenPoint
CXTPChartPointF GetScreenPoint() const
Call this function to get the screen point from the series point.
CXTPChartPointSeriesView
This class represents the view of a point series, which is a kind of CXTPChartSeriesView.
Definition XTPChartPointSeriesView.h:42
CXTPChartPointSeriesView::CXTPChartPointSeriesView
CXTPChartPointSeriesView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Constructs a CXTPChartPointSeriesView object.
CXTPChartPointSeriesView::CreateLegendDeviceCommand
virtual CXTPChartDeviceCommand * CreateLegendDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcBounds)
This function creates a label view drawing command object.
CXTPChartPointSeriesView::CreateSeriesPointView
CXTPChartSeriesPointView * CreateSeriesPointView(CXTPChartDeviceContext *pDC, CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Call this function to create a view of the series points.
CXTPChartSeries
This class represents a series in the chart, which is a kind of CXTPChartElement.
Definition XTPChartSeries.h:50
CXTPChartSeriesPoint
CXTPChartSeriesPoint is a kind of CXTPChartElement.
Definition XTPChartSeriesPoint.h:43
CXTPChartSeriesPointView
Represents chart series point view.
Definition XTPChartSeriesPointView.h:48
CXTPPoint2T< float >


Toolkit Pro: Member List

CXTPChartSeriesCollection Member List

This is the complete list of members for CXTPChartSeriesCollection, including all inherited members.

Add(CXTPChartSeries *pSeries) | CXTPChartSeriesCollection |
CXTPChartElement() | CXTPChartElement |
CXTPChartElementCollection() | CXTPChartElementCollection |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartSeriesCollection(CXTPChartContent *pOwner) | CXTPChartSeriesCollection |
DoPropExchange(CXTPPropExchange *pPX) | CXTPChartSeriesCollection | virtual
GetAppearance() const | CXTPChartElement |
GetAt(int nIndex) const | CXTPChartSeriesCollection |
GetContent() const | CXTPChartElement |
GetCount() const | CXTPChartElementCollection | virtual
GetOwner() const | CXTPChartElement |
IndexOf(CXTPChartElement *pElement) const | CXTPChartElementCollection |
InsertAt(int nIndex, CXTPChartElement *pElement) | CXTPChartElementCollection |
Is3D() const | CXTPChartObject |
m_arrElements | CXTPChartElementCollection | protected
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartElement | virtual
Release() | CXTPChartElementCollection | virtual
Remove(CXTPChartElement *pElement) | CXTPChartElementCollection | virtual
RemoveAll() | CXTPChartElementCollection | virtual
RemoveAt(int nIndex) | CXTPChartElementCollection | virtual
~CXTPChartElement() | CXTPChartElement | virtual
~CXTPChartElementCollection() | CXTPChartElementCollection |
~CXTPChartSeriesCollection() | CXTPChartSeriesCollection | virtual


Toolkit Pro: Member List

CXTPSkinObjectScrollBar Member List

This is the complete list of members for CXTPSkinObjectScrollBar, including all inherited members.

CXTPSkinObject() | CXTPSkinObject | protected
CXTPSkinObjectFrame() | CXTPSkinObjectFrame |
CXTPSkinObjectScrollBar() | CXTPSkinObjectScrollBar |
GetAccessCriticalSection() const | CXTPSynchronized | inline
GetBorders() const | CXTPSkinObjectFrame |
GetCaptionButtons() | CXTPSkinObjectFrame |
GetClassName() const | CXTPSkinObject |
GetClientBrush(CDC *pDC) | CXTPSkinObjectFrame | virtual
GetColor(int nIndex) const | CXTPSkinObject |
GetMetrics() const | CXTPSkinObject |
GetSkinClass() const | CXTPSkinObject |
GetSkinManager() const | CXTPSkinObject |
IsActive() const | CXTPSkinObjectFrame |
m_arrButtons | CXTPSkinObjectFrame | protected
m_bActive | CXTPSkinObjectFrame | protected
m_bActiveX | CXTPSkinObject | protected
m_bLockFrameDraw | CXTPSkinObjectFrame |
m_bMDIClient | CXTPSkinObjectFrame | protected
m_bRegionChanged | CXTPSkinObjectFrame | protected
m_bWindowsForms | CXTPSkinObject | protected
m_dwDialogTexture | CXTPSkinObjectFrame |
m_dwExStyle | CXTPSkinObjectFrame | protected
m_dwStyle | CXTPSkinObjectFrame | protected
m_pButtonHot | CXTPSkinObjectFrame | protected
m_pButtonPressed | CXTPSkinObjectFrame | protected
m_pManager | CXTPSkinObject | protected
m_pOldWndProc | CXTPSkinObject | protected
m_pSBTrack | CXTPSkinObjectFrame | protected
m_rcBorders | CXTPSkinObjectFrame | protected
m_spi | CXTPSkinObjectFrame | protected
m_strClassName | CXTPSkinObject | protected
m_szFrameRegion | CXTPSkinObjectFrame | protected
OnHookAttached(LPCREATESTRUCT lpcs, BOOL bAuto) | CXTPSkinObjectFrame | protectedvirtual
OnHookDetached(BOOL bAuto) | CXTPSkinObjectFrame | protectedvirtual
OnSkinChanged(BOOL bPrevState, BOOL bNewState) | CXTPSkinObjectFrame | protectedvirtual
RedrawScrollBar(int nBar) | CXTPSkinObjectFrame |
RefreshMetrics() | CXTPSkinObjectFrame | protectedvirtual
~CXTPSkinObject() | CXTPSkinObject | protected
~CXTPSkinObjectFrame() | CXTPSkinObjectFrame | virtual
~CXTPSkinObjectScrollBar() | CXTPSkinObjectScrollBar | virtual


Toolkit Pro: XTPRibbonControlTab.h Source File

  • Source
  • Ribbon
XTPRibbonControlTab.h
Go to the documentation of this file.
1
23#if !defined(__XTPRIBBONCONTROLTAB_H__)
24# define __XTPRIBBONCONTROLTAB_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPRibbonGroups;
34class CXTPRibbonBar;
35class CXTPRibbonGroup;
36class CXTPRibbonTab;
37
43struct NMXTPTABCHANGE : public NMXTPCONTROL
44{
45 CXTPRibbonTab* pTab;
46};
47
53class _XTP_EXT_CLASS CXTPRibbonControlTab
54 : public CXTPControlPopup
55 , public CXTPTabManager
56{
58 DECLARE_XTP_CONTROL(CXTPRibbonControlTab)
60public:
65 CXTPRibbonControlTab();
66
71 virtual ~CXTPRibbonControlTab();
72
73public:
85 virtual CXTPTabPaintManager* GetPaintManager() const;
86
93 CXTPRibbonBar* GetRibbonBar() const;
94
104 CXTPRibbonTab* FindTab(int nId) const;
105
115 CXTPRibbonTab* GetTab(int nIndex) const;
116
122 void SetSelectedItem(CXTPTabManagerItem* pItem);
123
124protected:
129 void Reposition();
130
138 virtual BOOL HeaderHasFocus() const;
139
145 virtual void SetFocused(BOOL bFocused);
146
153 virtual BOOL IsFocused() const;
154
160 void OnUnderlineActivate();
161
170 virtual BOOL IsFocusable() const;
171
179 BOOL OnSetSelected(int bSelected);
180
189 BOOL OnHookKeyDown(UINT nChar, LPARAM lParam);
190
196 void OnItemClick(CXTPTabManagerItem* pItem);
197
198protected:
214 BOOL DrawIcon(CDC* pDC, CPoint pt, CXTPTabManagerItem* pItem, BOOL bDraw, CSize& szIcon) const;
215
226 void RedrawControl(LPCRECT lpRect, BOOL bAnimate);
227
236 BOOL IsMouseLocked() const;
237
243 void Draw(CDC* pDC);
244
254 void DoPropExchange(CXTPPropExchange* pPX);
255
262 void Copy(CXTPControl* pControl, BOOL bRecursive = FALSE);
263
270 BOOL IsPopupBarTracking() const;
271
272protected:
274 void OnClick(BOOL bKeyboard = FALSE, CPoint pt = CPoint(0, 0));
275 void ShowPopupBar(BOOL bKeyboard);
276 BOOL OnSetPopup(BOOL bPopup);
277 void SetEnabled(BOOL bEnabled);
278 CString GetItemTooltip(const CXTPTabManagerItem* pItem) const;
279 virtual void AdjustExcludeRect(CRect& rc, BOOL bVertical);
282protected:
284 virtual HRESULT GetAccessibleChildCount(long* pcountChildren);
285 virtual HRESULT GetAccessibleChild(VARIANT varChild, IDispatch** ppdispChild);
286 virtual HRESULT GetAccessibleName(VARIANT varChild, BSTR* pszName);
287 virtual HRESULT GetAccessibleRole(VARIANT varChild, VARIANT* pvarRole);
288 virtual HRESULT AccessibleLocation(long* pxLeft, long* pyTop, long* pcxWidth, long* pcyHeight,
289 VARIANT varChild);
290 virtual HRESULT AccessibleHitTest(long xLeft, long yTop, VARIANT* pvarChild);
291 virtual HRESULT GetAccessibleState(VARIANT varChild, VARIANT* pvarState);
292 virtual HRESULT GetAccessibleDefaultAction(VARIANT varChild, BSTR* pszDefaultAction);
293 virtual HRESULT AccessibleDoDefaultAction(VARIANT varChild);
294 virtual HRESULT AccessibleSelect(long flagsSelect, VARIANT varChild);
297protected:
298 BOOL m_bFocused;
300 friend class CXTPRibbonBar;
301};
302
303AFX_INLINE CXTPRibbonBar* CXTPRibbonControlTab::GetRibbonBar() const
304{
305 return (CXTPRibbonBar*)m_pParent;
306}
307
308# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
310#endif // !defined(__XTPRIBBONCONTROLTAB_H__)
DECLARE_XTP_CONTROL
#define DECLARE_XTP_CONTROL(class_name)
This macro generates the C++ header code necessary for a CXTPControl-derived class that can be serial...
Definition XTPCommandBarsDefines.h:1169
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPControl
CXTPControl is a CXTPCmdTarget derived class.
Definition XTPControl.h:841
CXTPControl::m_pParent
CXTPCommandBar * m_pParent
The Parent command bar.
Definition XTPControl.h:2313
CXTPControl::SetEnabled
virtual void SetEnabled(BOOL bEnabled)
Call this member to enable/disable the control.
Definition XTPControl.h:2547
CXTPControlPopup
CXTPControlPopup is a CXTPControl derived class.
Definition XTPControlPopup.h:42
CXTPControlPopup::OnClick
void OnClick(BOOL bKeyboard=FALSE, CPoint pt=CPoint(0, 0))
This method is called when the user clicks the control.
CXTPControlPopup::AdjustExcludeRect
virtual void AdjustExcludeRect(CRect &rc, BOOL bVertical)
Updates rectangle to set the position where the child pop-up bar becomes visible.
CXTPControlPopup::OnSetPopup
virtual BOOL OnSetPopup(BOOL bPopup)
This method is called to pop-up the control.
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72
CXTPRibbonBar
CXTPRibbonBar is a CXTPMenuBar derived class.
Definition XTPRibbonBar.h:69
CXTPRibbonControlTab
CXTPRibbonControlTab is a CXTPTabManager derived class.
Definition XTPRibbonControlTab.h:56
CXTPRibbonControlTab::Copy
void Copy(CXTPControl *pControl, BOOL bRecursive=FALSE)
This method is called to copy the control.
CXTPRibbonControlTab::IsPopupBarTracking
BOOL IsPopupBarTracking() const
Call this member to get the tracking state.
CXTPRibbonControlTab::DoPropExchange
void DoPropExchange(CXTPPropExchange *pPX)
Call this member function to store/load a properties collection using the specified data object.
CXTPRibbonControlTab::GetTab
CXTPRibbonTab * GetTab(int nIndex) const
Call this method to retrieve the tab at a specified position.
CXTPRibbonControlTab::FindTab
CXTPRibbonTab * FindTab(int nId) const
Call this method to find a tab with a specified identifier.
CXTPRibbonControlTab::OnHookKeyDown
BOOL OnHookKeyDown(UINT nChar, LPARAM lParam)
This method is called when a non-system key is pressed.
CXTPRibbonControlTab::m_bFocused
BOOL m_bFocused
TRUE if groups is focused.
Definition XTPRibbonControlTab.h:298
CXTPRibbonControlTab::OnItemClick
void OnItemClick(CXTPTabManagerItem *pItem)
This method is called when an item (tab button) is clicked.
CXTPRibbonControlTab::~CXTPRibbonControlTab
virtual ~CXTPRibbonControlTab()
Destroys a CXTPRibbonControlTab object, handles cleanup and deallocation.
CXTPRibbonControlTab::RedrawControl
void RedrawControl(LPCRECT lpRect, BOOL bAnimate)
Initiates redrawing of the ribbon bar control.
CXTPRibbonControlTab::Reposition
void Reposition()
This method is called to update the position of the tab manager.
CXTPRibbonControlTab::SetSelectedItem
void SetSelectedItem(CXTPTabManagerItem *pItem)
Call this member to select an item in the ribbon bar.
CXTPRibbonControlTab::OnUnderlineActivate
void OnUnderlineActivate()
This method is called when the user actives the control using its underline.
CXTPRibbonControlTab::OnSetSelected
BOOL OnSetSelected(int bSelected)
This method is called when the control becomes selected.
CXTPRibbonControlTab::IsFocusable
virtual BOOL IsFocusable() const
This method is called to check if the control can accept focus.
CXTPRibbonControlTab::Draw
void Draw(CDC *pDC)
This method is called to draw the control.
CXTPRibbonControlTab::SetFocused
virtual void SetFocused(BOOL bFocused)
Call this member to set focus to the control.
CXTPRibbonControlTab::GetPaintManager
virtual CXTPTabPaintManager * GetPaintManager() const
Call this member to get a pointer to the tab paint manager.
CXTPRibbonControlTab::DrawIcon
BOOL DrawIcon(CDC *pDC, CPoint pt, CXTPTabManagerItem *pItem, BOOL bDraw, CSize &szIcon) const
This member is called when the icon of the ribbon tab needs to be drawn.
CXTPRibbonControlTab::GetRibbonBar
CXTPRibbonBar * GetRibbonBar() const
Retrieves the parent CXTPRibbonBar object.
Definition XTPRibbonControlTab.h:303
CXTPRibbonControlTab::IsFocused
virtual BOOL IsFocused() const
Determines if the control has focus.
CXTPRibbonControlTab::IsMouseLocked
BOOL IsMouseLocked() const
Checks to see if the mouse is locked.
CXTPRibbonControlTab::HeaderHasFocus
virtual BOOL HeaderHasFocus() const
The implementation should return TRUE if the header has focus or FALSE otherwise.
CXTPRibbonControlTab::CXTPRibbonControlTab
CXTPRibbonControlTab()
Constructs a CXTPRibbonControlTab object.
CXTPRibbonGroup
Represents a single group that is added to a CXTPRibbonTab.
Definition XTPRibbonGroup.h:70
CXTPRibbonGroups
Represents a collection of CXTPRibbonGroup objects.
Definition XTPRibbonGroups.h:51
CXTPRibbonTab
Represents a tab in the Ribbon Bar.
Definition XTPRibbonTab.h:116
CXTPTabManager
CXTPTabManager is the base class for docking pane tabs, tab control tabs, and MDI client tabs.
Definition XTPTabManager.h:87
CXTPTabManager::GetItemTooltip
virtual CString GetItemTooltip(const CXTPTabManagerItem *pItem) const
Retrieves the tooltip of a specified tab item.
CXTPTabManagerItem
CXTPTabManagerItem is the base class for the tabs that appear in the command bars tab workspace,...
Definition XTPTabManagerItem.h:44
CXTPTabPaintManager
CXTPTabPaintManager is used to store the color and appearance information of the tabs in the tab mana...
Definition XTPTabPaintManager.h:48
NMXTPCONTROL
This structure is passed as a parameter in CBN_XTP_EXECUTE message.
Definition XTPCommandBarsDefines.h:769
NMXTPTABCHANGE
Structure used as a parameter for TCN_SELCHANGING and TCN_SELCHANGE messages when a Ribbon tab is cha...
Definition XTPRibbonControlTab.h:44
NMXTPTABCHANGE::pTab
CXTPRibbonTab * pTab
Ribbon tab to be selected.
Definition XTPRibbonControlTab.h:45


Toolkit Pro: Member List

CXTPRibbonControlSystemPopupBarListCaption Member List

This is the complete list of members for CXTPRibbonControlSystemPopupBarListCaption, including all inherited members.

AssignDocTemplate(UINT nIDResource) | CXTPControl |
ClickToolBarButton(CRect rcActiveRect=CRect(0, 0, 0, 0)) | CXTPControl | protected
Compare(CXTPControl *pOther) | CXTPControl | virtual
Copy(CXTPControl *pControl, BOOL bRecursive=FALSE) | CXTPControl | virtual
CustomizeStartDrag(CPoint point) | CXTPControl | protectedvirtual
CustomizeStartResize(CPoint point) | CXTPControl | protectedvirtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPControl() | CXTPControl | protected
CXTPRibbonControlSystemPopupBarListCaption() | CXTPRibbonControlSystemPopupBarListCaption |
DelayLayoutParent() | CXTPControl |
DelayRedrawParent() | CXTPControl |
DoCustomDragOver(CXTPCommandBar *pCommandBar, CPoint point, DROPEFFECT &dropEffect) | CXTPControl | protectedvirtual
DoPropExchange(CXTPPropExchange *pPX) | CXTPControl | virtual
Draw(CDC *pDC) | CXTPRibbonControlSystemPopupBarListCaption | protectedvirtual
ExcludeDocTemplate(UINT nIDResource) | CXTPControl |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
FromUI(CCmdUI *pCmdUI) | CXTPControl | static
GenerateCommandBarList(DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam) | CXTPControl | protectedvirtual
GetAction() const | CXTPControl |
GetBeginGroup() const | CXTPControl |
GetButtonSize() const | CXTPControl | virtual
GetCaption() const | CXTPControl | virtual
GetCategory() const | CXTPControl |
GetChecked() const | CXTPControl |
GetCloseSubMenuOnClick() const | CXTPControl |
GetCommandBar() const | CXTPControl | virtual
GetControls() const | CXTPControl |
GetCustomizeMinHeight() const | CXTPControl | protectedvirtual
GetCustomizeMinWidth() const | CXTPControl | protectedvirtual
GetCustomShortcutText() const | CXTPControl |
GetDescription() const | CXTPControl | virtual
GetEnabled() const | CXTPControl |
GetExecuteOnPressInterval() const | CXTPControl |
GetExpanded() const | CXTPControl |
GetFlags() const | CXTPControl |
GetHeight() const | CXTPControl |
GetHelpId() const | CXTPControl |
GetHideFlags() const | CXTPControl |
GetIconId() const | CXTPControl |
GetIconSize() const | CXTPControl | virtual
GetID() const | CXTPControl |
GetImage(int nWidth=16) const | CXTPControl | virtual
GetImageManager() const | CXTPControl |
GetIndex() const | CXTPControl |
GetKeyboardTip() const | CXTPControl |
GetPaintManager() const | CXTPControl |
GetParameter() const | CXTPControl |
GetParent() const | CXTPControl |
GetPopuped() const | CXTPControl | virtual
GetPressed() const | CXTPControl | virtual
GetRect() const | CXTPControl |
GetRibbonGroup() const | CXTPControl |
GetRowRect() const | CXTPControl |
GetSelected() const | CXTPControl | virtual
GetShortcutText() const | CXTPControl |
GetSize(CDC *pDC) | CXTPRibbonControlSystemPopupBarListCaption | protectedvirtual
GetStyle() const | CXTPControl |
GetTag() const | CXTPControl |
GetTooltip() const | CXTPControl | virtual
GetType() const | CXTPControl |
GetWidth() const | CXTPControl |
GetWrap() const | CXTPControl |
HasDwmCompositedRect() const | CXTPControl |
IsCaptionVisible() const | CXTPControl | virtual
IsCursorOver() const | CXTPControl |
IsCustomizeMode() const | CXTPControl | protected
IsCustomizeMovable() const | CXTPControl | virtual
IsCustomizeResizeAllow() const | CXTPControl | protectedvirtual
IsFocusable() const | CXTPControl | protectedvirtual
IsFocused() const | CXTPControl | virtual
IsItemDefault() const | CXTPControl |
IsLayoutChanged() | CXTPControl | protected
IsLayoutRTL() const | CXTPControl | protected
IsOnQuickAccess() const | CXTPControl |
IsTemporary() const | CXTPControl |
IsTransparent() const | CXTPControl | inlinevirtual
IsVisible(DWORD dwSkipFlags=0) const | CXTPControl | virtual
m_bBeginGroup | CXTPControl | protected
m_bChecked | CXTPControl | protected
m_bCloseSubMenuOnClick | CXTPControl | protected
m_bDefaultItem | CXTPControl | protected
m_bEnabled | CXTPControl | protected
m_bExpanded | CXTPControl | protected
m_bLayoutRTL | CXTPControl | protected
m_bOnQuickAccess | CXTPControl | protected
m_bPressed | CXTPControl | protected
m_bSelected | CXTPControl | protected
m_bTemporary | CXTPControl | protected
m_buttonCustomStyle | CXTPControl | protected
m_buttonRibbonStyle | CXTPControl | protected
m_buttonStyle | CXTPControl | protected
m_bWrap | CXTPControl | protected
m_controlType | CXTPControl | protected
m_dwFlags | CXTPControl | protected
m_dwHideFlags | CXTPControl | protected
m_mapDocTemplatesAssigned | CXTPControl | protected
m_mapDocTemplatesExcluded | CXTPControl | protected
m_nCustomIconId | CXTPControl | protected
m_nExecuteOnPressInterval | CXTPControl | protected
m_nHeight | CXTPControl | protected
m_nHelpId | CXTPControl | protected
m_nIconId | CXTPControl | protected
m_nId | CXTPControl | protected
m_nIndex | CXTPControl | protected
m_nTag | CXTPControl | protected
m_nWidth | CXTPControl | protected
m_pAction | CXTPControl | protected
m_pControls | CXTPControl | protected
m_pParent | CXTPControl | protected
m_pRibbonGroup | CXTPControl | protected
m_rcControl | CXTPControl | protected
m_rcRow | CXTPControl | protected
m_strCaption | CXTPControl | protected
m_strCategory | CXTPControl | protected
m_strCustomCaption | CXTPControl | protected
m_strDescriptionText | CXTPControl | protected
m_strKeyboardTip | CXTPControl | protected
m_strParameter | CXTPControl | protected
m_strShortcutText | CXTPControl | protected
m_strShortcutTextAuto | CXTPControl | protected
m_strTooltipText | CXTPControl | protected
m_szIcon | CXTPControl | protected
NotifySite(UINT code) | CXTPControl |
NotifySite(UINT code, NMXTPCONTROL *pNM) | CXTPControl |
NotifySite(CWnd *pSite, UINT code, NMXTPCONTROL *pNM) | CXTPControl |
OnActionChanged(int nProperty) | CXTPControl | protectedvirtual
OnActionChanging(int nProperty) | CXTPControl | protectedvirtual
OnCalcDynamicSize(DWORD dwMode) | CXTPControl | virtual
OnCaptionChanged() | CXTPControl | protectedvirtual
OnClick(BOOL bKeyboard=FALSE, CPoint pt=CPoint(0, 0)) | CXTPControl | virtual
OnCustomizeDragOver(CXTPControl *pDataObject, CPoint point, DROPEFFECT &dropEffect) | CXTPControl | protectedvirtual
OnCustomizeMouseMove(CPoint point) | CXTPControl | protected
OnEnabledChanged() | CXTPControl | virtual
OnExecute() | CXTPControl | virtual
OnHookKeyDown(UINT nChar, LPARAM lParam) | CXTPControl | protectedvirtual
OnHookMouseWheel(UINT nFlags, short zDelta, CPoint point) | CXTPControl | protectedvirtual
OnIdleUpdate() | CXTPControl | protectedvirtual
OnLButtonDblClk(CPoint point) | CXTPControl | protectedvirtual
OnLButtonDown(CPoint point) | CXTPControl | protectedvirtual
OnLButtonUp(CPoint point) | CXTPControl | protectedvirtual
OnMouseHover() | CXTPControl | protectedvirtual
OnMouseMove(CPoint point) | CXTPControl | protectedvirtual
OnRButtonDown(CPoint point) | CXTPControl | protectedvirtual
OnRButtonUp(CPoint point) | CXTPControl | protectedvirtual
OnRemoved() | CXTPControl | protectedvirtual
OnSetPopup(BOOL bPopup) | CXTPControl | protectedvirtual
OnSetSelected(int bSelected) | CXTPControl | protectedvirtual
OnThemeChanged() | CXTPControl | virtual
OnToolHitTest(CPoint point, TOOLINFO *pTI) const | CXTPControl | protectedvirtual
OnUnderlineActivate() | CXTPControl | virtual
RedrawParent(BOOL bAnimate=TRUE) | CXTPControl |
Reset() | CXTPControl |
RestoreCommandBarList(CXTPCommandBarList *pCommandBarList) | CXTPControl | protectedvirtual
ScreenToClient(CPoint *point) | CXTPControl | protected
SetAction(CXTPControlAction *pAction) | CXTPControl | virtual
SetBeginGroup(BOOL bBeginGroup) | CXTPControl | virtual
SetCaption(LPCTSTR lpszCaption) | CXTPControl |
SetCaption(UINT nIDCaption) | CXTPControl |
SetCategory(LPCTSTR lpszCategory) | CXTPControl |
SetChecked(BOOL bChecked) | CXTPControl | virtual
SetCloseSubMenuOnClick(BOOL bCloseOnClick) | CXTPControl |
SetCustomIcon(HICON hIcon) | CXTPControl |
SetCustomShortcutText(LPCTSTR lpszCustomShortcutText) | CXTPControl |
SetDescription(LPCTSTR lpszDescription) | CXTPControl |
SetEnabled(BOOL bEnabled) | CXTPControl | virtual
SetExecuteOnPressInterval(int nExecuteOnPressInterval) | CXTPControl |
SetExpanded(BOOL bExpanded) | CXTPControl | protected
SetFlags(DWORD dwFlags) | CXTPControl |
SetFocused(BOOL bFocused) | CXTPControl | virtual
SetHeight(int nHeight) | CXTPControl | virtual
SetHelpId(int nId) | CXTPControl |
SetHideFlag(XTPControlHideFlags dwFlag, BOOL bSet) | CXTPControl |
SetHideFlags(DWORD dwFlags) | CXTPControl | virtual
SetHideWrap(BOOL bHide) | CXTPControl |
SetIconId(int nId) | CXTPControl |
SetIconSize(CSize szIcon) | CXTPControl |
SetID(int nId) | CXTPControl |
SetIndex(int nIndex) | CXTPControl | inlineprotected
SetItemDefault(BOOL bDefault) | CXTPControl |
SetKeyboardTip(LPCTSTR lpszKeyboardTip) | CXTPControl |
SetOnQuickAccess(BOOL bOnQuicAccess=FALSE) | CXTPControl |
SetParameter(LPCTSTR lpszParameter) | CXTPControl |
SetParent(CXTPCommandBar *pParent) | CXTPControl | inlineprotectedvirtual
SetPressed(BOOL bPressed) | CXTPControl |
SetPrompt(LPCTSTR lpszPrompt) | CXTPControl |
SetRect(CRect rcControl) | CXTPControl | virtual
SetRowRect(CRect rcRow) | CXTPControl |
SetShortcutText(LPCTSTR lpszShortcutText) | CXTPControl |
SetStyle(XTPButtonStyle buttonStyle) | CXTPControl |
SetTag(DWORD_PTR dwTag) | CXTPControl |
SetTooltip(LPCTSTR lpszTooltip) | CXTPControl |
SetVisible(BOOL bVisible) | CXTPControl |
SetWidth(int nWidth) | CXTPControl | virtual
SetWrap(BOOL bWrap) | CXTPControl |
~CXTPControl() | CXTPControl | protectedvirtual


Toolkit Pro: Member List

CXTPChartHighLowSeriesStyle Member List

This is the complete list of members for CXTPChartHighLowSeriesStyle, including all inherited members.

ApplyTo(CXTPChartDeviceCommand *pCommand) | CXTPChartSeriesStyle | virtual
CorrectAxisSideMargins(CXTPChartAxis *pAxis, double nMinValue, double nMaxValue, double &nCorrection) | CXTPChartSeriesStyle | virtual
CreateDiagram() | CXTPChartDiagram2DSeriesStyle | virtual
CreateView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView) | CXTPChartHighLowSeriesStyle | protectedvirtual
CXTPChartDiagram2DSeriesStyle() | CXTPChartDiagram2DSeriesStyle |
CXTPChartElement() | CXTPChartElement |
CXTPChartHighLowSeriesStyle() | CXTPChartHighLowSeriesStyle |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartSeriesStyle() | CXTPChartSeriesStyle |
DoPropExchange(CXTPPropExchange *pPX) | CXTPChartDiagram2DSeriesStyle | virtual
Enable3dEdgeSmoothing(BOOL bEnable=TRUE) | CXTPChartSeriesStyle | virtual
Get3dRotation() const | CXTPChartSeriesStyle | virtual
GetAppearance() const | CXTPChartElement |
GetColor() const | CXTPChartSeriesStyle | virtual
GetContent() const | CXTPChartElement |
GetCustomDownColor() const | CXTPChartHighLowSeriesStyle |
GetCustomUpColor() const | CXTPChartHighLowSeriesStyle |
GetDownColor() const | CXTPChartHighLowSeriesStyle |
GetErrorBar() const | CXTPChartSeriesStyle | virtual
GetLabel() const | CXTPChartSeriesStyle | virtual
GetLineThickness() const | CXTPChartHighLowSeriesStyle |
GetOwner() const | CXTPChartElement |
GetSeriesPointValueIndex() const | CXTPChartSeriesStyle | virtual
GetStyleAppearance() const | CXTPChartSeriesStyle | virtual
GetTransparency() const | CXTPChartSeriesStyle | virtual
GetUpColor() const | CXTPChartHighLowSeriesStyle |
Is3D() const | CXTPChartObject |
Is3dEdgeSmoothingEnabled() const | CXTPChartSeriesStyle | virtual
IsColorEach() const | CXTPChartSeriesStyle | virtual
IsStyleDiagram(CXTPChartDiagram *pDiagram) const | CXTPChartDiagram2DSeriesStyle | virtual
m_bColorEach | CXTPChartSeriesStyle | protected
m_bSmooth3dEdges | CXTPChartSeriesStyle | protected
m_clrColor | CXTPChartSeriesStyle | protected
m_clrDownColor | CXTPChartHighLowSeriesStyle | protected
m_clrUpColor | CXTPChartHighLowSeriesStyle | protected
m_nAxisIndexX | CXTPChartDiagram2DSeriesStyle | protected
m_nAxisIndexY | CXTPChartDiagram2DSeriesStyle | protected
m_nLineThickness | CXTPChartHighLowSeriesStyle | protected
m_nTransparency | CXTPChartSeriesStyle | protected
m_pErrorBar | CXTPChartSeriesStyle | protected
m_pLabel | CXTPChartSeriesStyle | protected
m_Rotation3d | CXTPChartSeriesStyle | protected
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartElement | virtual
Release() | CXTPChartElement | virtual
Set3dRotation(const CXTPChart3dRotation &rotation) | CXTPChartSeriesStyle | virtual
Set3dRotation(double dYaw, double dPitch, double dRoll) | CXTPChartSeriesStyle | virtual
SetColor(CXTPChartColor clr) | CXTPChartSeriesStyle | virtual
SetColorEach(BOOL bColorEach) | CXTPChartSeriesStyle | virtual
SetErrorBar(CXTPChartErrorBar *pErrorBar) | CXTPChartSeriesStyle | virtual
SetLabel(CXTPChartSeriesLabel *pLabel) | CXTPChartSeriesStyle | virtual
SetLineThickness(int nLineThickness) | CXTPChartHighLowSeriesStyle |
SetTransparency(int nTransparency) | CXTPChartSeriesStyle | virtual
~CXTPChartDiagram2DSeriesStyle() | CXTPChartDiagram2DSeriesStyle | virtual
~CXTPChartElement() | CXTPChartElement | virtual
~CXTPChartHighLowSeriesStyle() | CXTPChartHighLowSeriesStyle | virtual
~CXTPChartSeriesStyle() | CXTPChartSeriesStyle | virtual


Toolkit Pro: Member List

CXTPCalendarReminders Member List

This is the complete list of members for CXTPCalendarReminders, including all inherited members.

_RemoveDataForMasterEvent(CXTPCalendarEvent *pEvent) | CXTPCalendarReminders | protectedvirtual
Add(CXTPCalendarReminder *pNewElement) | CXTPCalendarPtrCollectionT< CXTPCalendarReminder > | virtual
Add(CXTPCalendarReminder *pNewElement, BOOL bWithAddRef) | CXTPCalendarPtrCollectionT< CXTPCalendarReminder > | virtual
Append(const CXTPCalendarPtrCollectionT< CXTPCalendarReminder > *pElementsArray) | CXTPCalendarPtrCollectionT< CXTPCalendarReminder > | virtual
CXTPCalendarPtrCollectionT() | CXTPCalendarPtrCollectionT< CXTPCalendarReminder > |
CXTPCmdTarget() | CXTPCmdTarget |
Find(const CXTPCalendarReminder *pReminder) const | CXTPCalendarReminders | virtual
Find(CXTPCalendarEvent *pEvent) const | CXTPCalendarReminders | virtual
Find(DWORD dwEventID, CXTPCalendarData *pDP=NULL) const | CXTPCalendarReminders | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAt(int nIndex) const | CXTPCalendarPtrCollectionT< CXTPCalendarReminder > | virtual
GetAt(int nIndex, BOOL bWithAddRef) const | CXTPCalendarPtrCollectionT< CXTPCalendarReminder > | virtual
GetCount() const | CXTPCalendarPtrCollectionT< CXTPCalendarReminder > | virtual
InsertAt(int nIndex, CXTPCalendarReminder *pElement) | CXTPCalendarPtrCollectionT< CXTPCalendarReminder > | virtual
m_arElements | CXTPCalendarPtrCollectionT< CXTPCalendarReminder > | protected
Remove(CXTPCalendarReminder *pElement) | CXTPCalendarPtrCollectionT< CXTPCalendarReminder > | virtual
RemoveAll() | CXTPCalendarPtrCollectionT< CXTPCalendarReminder > | virtual
RemoveAt(int nIndex) | CXTPCalendarPtrCollectionT< CXTPCalendarReminder > | virtual
RemoveDataForEvent(CXTPCalendarEvent *pEvent) | CXTPCalendarReminders | virtual
SetAt(int nIndex, CXTPCalendarReminder *pElement) | CXTPCalendarPtrCollectionT< CXTPCalendarReminder > | virtual
SetSize(int nNewSize) | CXTPCalendarPtrCollectionT< CXTPCalendarReminder > | virtual
Sort() | CXTPCalendarReminders | virtual
TObjectPtr typedef | CXTPCalendarPtrCollectionT< CXTPCalendarReminder > | protected
~CXTPCalendarPtrCollectionT() | CXTPCalendarPtrCollectionT< CXTPCalendarReminder > | virtual


Toolkit Pro: XTPFlowGraphNode.h Source File

  • Source
  • FlowGraph
XTPFlowGraphNode.h
Go to the documentation of this file.
1
23#if !defined(__XTPFLOWGRAPHNODE_H__)
24# define __XTPFLOWGRAPHNODE_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPFlowGraphPage;
34class CXTPFlowGraphDrawContext;
35class CXTPFlowGraphControl;
36class CXTPFlowGraphConnectionPoints;
37class CXTPFlowGraphConnectionPoint;
38class CXTPFlowGraphNodeGroup;
39class CXTPPropExchange;
40class CXTPFlowGraphImage;
41class CXTPFlowGraphSelectionRect;
42
43class CXTPMarkupUIElement;
44class CXTPMarkupObject;
45class CXTPMarkupUIElementCollection;
46class CXTPMarkupVisual;
47class CXTPMarkupTextBlock;
48
49# define XAML_MARKUP_PROPERTY_CPNAME L"CPName"
50# define XAML_MARKUP_PROPERTY_CPTYPE L"CPType"
51# define XAML_MARKUP_PROPERTY_CANSETCOLOR L"CanSetColor"
52# define XAML_MARKUP_PROPERTY_CPOINTS_IN L"ConnectionPointsIn"
53# define XAML_MARKUP_PROPERTY_RESIZABLE L"Resizable"
54
55# define XAML_MARKUP_TAG_ITEMSCOLLECTION L"nodeItemsCollection"
56# define XAML_MARKUP_TAG_CUSTOMCONTROL L"nodeCustomControl"
57# define XAML_MARKUP_TAG_NODECAPTION L"nodeCaption"
58# define XAML_MARKUP_TAG_NODECAPTIONBORDER L"nodeCaptionBorder"
59# define XAML_MARKUP_TAG_NODE_ITEM_CAPTION L"nodeItemCaption"
60# define XAML_MARKUP_TAG_NODE_ITEM_IMAGE L"nodeItemImage"
61# define XAML_MARKUP_TAG_NODEIMAGE L"nodeImage"
62# define XAML_MARKUP_TAG_NODECONTENT L"nodeContent"
63
64# define XAML_MARKUP_CPNAME_PLACEHOLDER _T("%CPNAME%")
65# define XAML_MARKUP_CPCAPTION_PLACEHOLDER _T("%CPCAPTION%")
66
67# define XAML_MARKUP_RESOURCENAME_NODE _T("FLOWGRAPH_XAML_NODE")
68# define XAML_MARKUP_RESOURCENAME_NODE_ITEM _T("FLOWGRAPH_XAML_NODE_ITEM")
69# define XAML_MARKUP_RESOURCENAME_NODE_ITEM_IN _T("FLOWGRAPH_XAML_NODE_ITEM_IN")
70# define XAML_MARKUP_RESOURCENAME_NODE_ITEM_OUT _T("FLOWGRAPH_XAML_NODE_ITEM_OUT")
71# define XAML_MARKUP_RESOURCENAME_NODE_ITEM_INOUT _T("FLOWGRAPH_XAML_NODE_ITEM_INOUT")
72
84enum XTPFlowGraphConnectionPointType
85{
86 xtpFlowGraphPointNone = 0,
87 xtpFlowGraphPointInput = 1,
88 xtpFlowGraphPointOutput = 2,
96 xtpFlowGraphPointInputAndOutput = 3,
97
101 xtpFlowGraphPointBoth = 4
102
103};
104
115class _XTP_EXT_CLASS CXTPFlowGraphNode : public CXTPFlowGraphElement
116{
117 DECLARE_SERIAL(CXTPFlowGraphNode);
118
119public:
124 CXTPFlowGraphNode();
130 virtual ~CXTPFlowGraphNode();
131
132public:
143 void SetCaption(LPCTSTR lpszCaption);
155 CString GetCaption() const;
156
165 void SetTooltip(LPCTSTR lpszTooltip);
175 CString GetTooltip() const;
176
183 virtual void SetColor(COLORREF clr, BYTE bAlpha = 255);
190 COLORREF GetColor() const;
191
198 void SetStyle(int nStyle);
205 int GetStyle() const;
206
215 void SetTag(DWORD_PTR dwTag);
226 DWORD_PTR GetTag() const;
227
233 void SetID(int nId);
240 int GetID() const;
241
248 virtual void SetWindowHandle(HWND hWnd);
256 HWND GetWindowHandle() const;
257
268 virtual void SetWindowSize(CSize sz);
282 CSize GetWindowSize() const;
283
294 void SetImageIndex(int nImageIndex);
302 int GetImageIndex() const;
303
313 void SetLocked(BOOL bLocked = TRUE);
314
325 BOOL IsLocked() const;
326
333 void SetVisible(BOOL bVisible = TRUE);
334
341 BOOL IsVisible() const;
342
343public:
350 void SetLocation(CPoint ptLocation);
358 CPoint GetLocation() const;
359
365 virtual void SetSize(CSize sz);
366
372 void SetSizeCore(CSize sz);
373
380 CSize GetSize() const;
381
388 CSize GetUserSize() const;
389
396 BOOL IsResizable() const;
397
404 CSize GetMinSize() const;
405
411 void SetMinSize(CSize sz);
412
420 CRect GetScreenRect(BOOL bIncludeConnectionPointsEllipses = TRUE) const;
421
422 virtual CRect GetBoundingRectangle(BOOL bIncludeConnectionPointsEllipses = TRUE) const;
423
424public:
431 CXTPFlowGraphPage* GetPage() const;
444 CXTPFlowGraphNodeGroup* GetGroup() const;
451 CXTPFlowGraphImage* GetImage() const;
458 CXTPFlowGraphConnectionPoints* GetConnectionPoints() const;
465 CXTPFlowGraphControl* GetControl() const;
466
467public:
472 void Remove();
473
474public:
483 virtual CXTPFlowGraphConnectionPoint* HitTestConnectionPoint(CPoint point);
484
491 virtual void UpdateWindowPosition();
492
498 virtual void DrawWindowContent(CXTPFlowGraphDrawContext* pDC);
499
505 virtual void Select(BOOL bSelect = TRUE);
506
507public:
515 virtual void DoPropExchange(CXTPPropExchange* pPX);
516
524 void DoCommonPropExchange(CXTPPropExchange* pPX);
525
526public:
535 virtual void RecalLayout();
541 virtual void Draw(CXTPFlowGraphDrawContext* pDC);
542
549 CRect GetSelectionRect() const;
550
556 virtual void DrawSelectionRect(CXTPFlowGraphDrawContext* pDC);
557
564 virtual void DrawConnectionPoints(CXTPFlowGraphDrawContext* pDC);
565
571 virtual void CalcMinSize();
572
573 // Default Markup support:
574
575public:
591 virtual void AddNamedConnectionPoints(
592 LPCTSTR szName, XTPFlowGraphConnectionPointType type = xtpFlowGraphPointNone,
593 LPCTSTR szCaption = NULL);
594
606 CRect GetMarkupVisualElementRect(const CXTPMarkupVisual* pElementVisual) const;
607
619 int GetMarkupTableRowIndex(CXTPFlowGraphConnectionPoint* pPoint,
620 CXTPMarkupUIElementCollection* pChildren);
621
629 int RemoveMarkupTableRow(CXTPFlowGraphConnectionPoint* pPoint);
630
640 CXTPMarkupTextBlock* GetTableRowTextBlock(const CString& strConnectionPointName) const;
641
651 CRect GetTableRowCaptionRect(CXTPFlowGraphConnectionPoint* pPoint) const;
652
657 virtual void SetDefaultMarkup();
658
664 void UpdateMarkupPointCaption(CXTPFlowGraphConnectionPoint* pPoint);
665
671 void UpdateMarkupPointName(CXTPFlowGraphConnectionPoint* pPoint);
672
678 virtual void UpdateMarkupPointColor(CXTPFlowGraphConnectionPoint* pPoint);
679
685 void UpdateMarkupPointImage(CXTPFlowGraphConnectionPoint* pPoint);
686
694 BOOL SetMarkupText(LPCTSTR szMarkupText);
695
703 virtual BOOL IsCustomMarkup() const
704 {
705 return FALSE;
706 }
707
720 virtual void UpdateConnectionPoints(CXTPMarkupObject* pRootElement);
721
729 virtual void UpdateColorRecursive(CXTPMarkupObject* pRootElement, COLORREF clrColor);
730
736 virtual void UpdateCaptionColor();
737
742 virtual void UpdateMarkupImage();
743
751 virtual CXTPMarkupTextBlock* UpdateMarkupCaption();
752
759 CXTPMarkupTextBlock* GetCaptionTextBlock() const;
760
768 CRect GetCaptionRect() const;
769
774 virtual void UpdateMarkupFont();
775
776protected:
781 virtual void OnRemoved();
782
783 static LRESULT CALLBACK ControlWindowProc(HWND hwnd, UINT uMsg, WPARAM wParam,
784 LPARAM lParam); // New window procedure.
785
786 void SetCustomWndProc();
787 void ResetCustomWndProc();
788
789protected:
790 CXTPFlowGraphPage* m_pPage;
792 CXTPFlowGraphNode* m_pNextVisibleNode;
794 CString m_strCaption;
796 CString m_strMarkup;
797
798 CXTPMarkupUIElement* m_pMarkup;
800 CPoint m_ptLocation;
802 CSize m_szUserSize;
803 CSize m_szActualSize;
804 CSize m_szMinSize;
805 CSize m_szUserMinSize;
807 BOOL m_bResizable;
808
809 CString m_strTooltip;
810 COLORREF m_clrNode;
812 BYTE m_bAlpha;
814 int m_nStyle;
816 DWORD_PTR m_dwTag;
817 int m_nId;
819 HWND m_hWnd;
820 WNDPROC m_pOriginalWindowProc;
821 CSize m_szWindow;
825 static CMap<HWND, HWND, CXTPFlowGraphNode*, CXTPFlowGraphNode*>
826 m_WindowToNodeHash;
828 CXTPFlowGraphSelectionRect* m_pSelectionRect;
829
830 int m_nGroupId;
832 int m_nImageIndex;
834 BOOL m_bLocked;
837 BOOL m_bVisible;
840 CXTPFlowGraphConnectionPoints* m_pConnectionPoints;
842 CXTPFlowGraphNodeGroup* m_pGroup;
844 friend class CXTPFlowGraphNodes;
845 friend class CXTPFlowGraphNodeGroup;
846 friend class CXTPFlowGraphPaintManager;
847 friend class CXTPFlowGraphPage;
848 friend class CXTPFlowGraphControl;
849
851private:
852 int m_nArrangeIndex;
853 int m_nArrangeLevel;
854 int m_nArrangeComponent;
859 // Paint Manager Properties:
860
861public:
862 CRect m_rcWindow;
865# ifdef _XTP_ACTIVEX
868 DECLARE_DISPATCH_MAP()
869 DECLARE_INTERFACE_MAP()
870
871 DECLARE_OLETYPELIB_EX(CXTPFlowGraphNode)
872
873 afx_msg void OleSetCaption(LPCTSTR lpszCaption);
874 afx_msg BSTR OleGetCaption();
875 afx_msg void OleSetTooltip(LPCTSTR lpszTooltip);
876 afx_msg BSTR OleGetTooltip();
877 afx_msg void OleSetColor(OLE_COLOR clr);
878 afx_msg OLE_COLOR OleGetColor();
879 afx_msg void OleSetStyle(int nStyle);
880 afx_msg int OleGetStyle();
881 afx_msg LPDISPATCH OleGetConnectionPoints();
882
883 afx_msg int OleGetLeft();
884 afx_msg void OleSetLeft(int nLeft);
885 afx_msg int OleGetTop();
886 afx_msg void OleSetTop(int nTop);
887 afx_msg int OleGetWidth();
888 afx_msg int OleGetHeight();
889
890 afx_msg LPDISPATCH OleGetPage();
891 afx_msg BOOL OleGetSelected();
892 afx_msg void OleSetSelected(BOOL bSelected);
893
894 afx_msg LPDISPATCH OleGetGroup();
895 afx_msg LPDISPATCH OleHitTestConnectionPoint(long x, long y);
896
897 afx_msg void OleAddNamedConnectionPoints(LPCTSTR lpszName, long type);
898 afx_msg void OleAddNamedConnectionPointsWithCaption(LPCTSTR lpszName, long type,
899 LPCTSTR lpszCaption);
900
901 afx_msg void OleSetWindowHandle(HWND hWnd);
902 afx_msg HWND OleGetWindowHandle();
903
904 afx_msg int OleGetWindowWidth();
905 afx_msg void OleSetWindowWidth(int nWidth);
906
907 afx_msg int OleGetWindowHeight();
908 afx_msg void OleSetWindowHeight(int nHeight);
909
910 afx_msg void OleSetWidth(int nWidth);
911 afx_msg void OleSetHeight(int nHeight);
912
914# endif
915};
916
917AFX_INLINE CString CXTPFlowGraphNode::GetCaption() const
918{
919 return m_strCaption;
920}
921AFX_INLINE CPoint CXTPFlowGraphNode::GetLocation() const
922{
923 return m_ptLocation;
924}
925AFX_INLINE CXTPFlowGraphConnectionPoints* CXTPFlowGraphNode::GetConnectionPoints() const
926{
927 return m_pConnectionPoints;
928}
929AFX_INLINE void CXTPFlowGraphNode::SetTooltip(LPCTSTR lpszTooltip)
930{
931 m_strTooltip = lpszTooltip;
932}
933AFX_INLINE CString CXTPFlowGraphNode::GetTooltip() const
934{
935 return m_strTooltip;
936}
937AFX_INLINE COLORREF CXTPFlowGraphNode::GetColor() const
938{
939 return m_clrNode;
940}
941AFX_INLINE void CXTPFlowGraphNode::SetStyle(int nStyle)
942{
943 m_nStyle = nStyle;
944 OnGraphChanged();
945}
946AFX_INLINE int CXTPFlowGraphNode::GetStyle() const
947{
948 return m_nStyle;
949}
950AFX_INLINE CXTPFlowGraphPage* CXTPFlowGraphNode::GetPage() const
951{
952 return m_pPage;
953}
954AFX_INLINE void CXTPFlowGraphNode::SetTag(DWORD_PTR dwTag)
955{
956 m_dwTag = dwTag;
957}
958AFX_INLINE DWORD_PTR CXTPFlowGraphNode::GetTag() const
959{
960 return m_dwTag;
961}
962AFX_INLINE void CXTPFlowGraphNode::SetID(int nId)
963{
964 m_nId = nId;
965}
966AFX_INLINE int CXTPFlowGraphNode::GetID() const
967{
968 return m_nId;
969}
970AFX_INLINE HWND CXTPFlowGraphNode::GetWindowHandle() const
971{
972 return m_hWnd;
973}
974AFX_INLINE CSize CXTPFlowGraphNode::GetWindowSize() const
975{
976 return m_szWindow;
977}
978AFX_INLINE CXTPFlowGraphNodeGroup* CXTPFlowGraphNode::GetGroup() const
979{
980 return m_pGroup;
981}
982AFX_INLINE int CXTPFlowGraphNode::GetImageIndex() const
983{
984 return m_nImageIndex;
985}
986AFX_INLINE void CXTPFlowGraphNode::SetLocked(BOOL bLocked)
987{
988 m_bLocked = bLocked;
989}
990AFX_INLINE BOOL CXTPFlowGraphNode::IsLocked() const
991{
992 return m_bLocked;
993}
994AFX_INLINE BOOL CXTPFlowGraphNode::IsVisible() const
995{
996 return m_bVisible;
997}
998AFX_INLINE BOOL CXTPFlowGraphNode::IsResizable() const
999{
1000 return m_bResizable;
1001}
1003# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
1004#endif //#if !defined(__XTPFLOWGRAPHNODE_H__)
pPoint
const CPoint * pPoint
return 0 or xtpCalendarHitTestDayExpandButton
Definition XTPCalendarThemeOffice2007.h:150
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPFlowGraphConnectionPointType
XTPFlowGraphConnectionPointType
Node connection point types (input/output).
Definition XTPFlowGraphNode.h:85
xtpFlowGraphPointOutput
@ xtpFlowGraphPointOutput
Connection only has an output point.
Definition XTPFlowGraphNode.h:88
xtpFlowGraphPointNone
@ xtpFlowGraphPointNone
Connection has no connection points.
Definition XTPFlowGraphNode.h:86
xtpFlowGraphPointInput
@ xtpFlowGraphPointInput
Connection only has an input point.
Definition XTPFlowGraphNode.h:87
xtpFlowGraphPointInputAndOutput
@ xtpFlowGraphPointInputAndOutput
Connection has both input and output points.
Definition XTPFlowGraphNode.h:96
xtpFlowGraphPointBoth
@ xtpFlowGraphPointBoth
A new connection point type for other shapes.
Definition XTPFlowGraphNode.h:101
CXTPFlowGraphConnectionPoint
Represents a connection point for a node.
Definition XTPFlowGraphConnectionPoint.h:46
CXTPFlowGraphConnectionPoints
Represents a collection of connection points for a Node.
Definition XTPFlowGraphConnectionPoints.h:44
CXTPFlowGraphControl
Flow Graph Control.
Definition XTPFlowGraphControl.h:173
CXTPFlowGraphElement
Base class for all elements in the flow graph.
Definition XTPFlowGraphElement.h:46
CXTPFlowGraphElement::OnGraphChanged
void OnGraphChanged()
This method is called when the flow graph layout is changed.
CXTPFlowGraphElement::GetCaption
virtual CString GetCaption() const =0
Gets the caption displayed for this element.
CXTPFlowGraphElement::GetPage
virtual CXTPFlowGraphPage * GetPage() const =0
Retrieves a reference to the flow graph page that this element is displayed on.
CXTPFlowGraphImage
Object used to represent an image displayed in a Node or connection point.
Definition XTPFlowGraphImage.h:49
CXTPFlowGraphNodeGroup
Represents a group of Nodes.
Definition XTPFlowGraphNodeGroup.h:47
CXTPFlowGraphNode
Represents a Node object.
Definition XTPFlowGraphNode.h:116
CXTPFlowGraphNode::GetConnectionPoints
CXTPFlowGraphConnectionPoints * GetConnectionPoints() const
Gets the connection points collection for this Node.
Definition XTPFlowGraphNode.h:925
CXTPFlowGraphNode::GetSelectionRect
CRect GetSelectionRect() const
Retrieves the Node's selection rectangle (visible only when the Node is selected).
CXTPFlowGraphNode::UpdateMarkupPointName
void UpdateMarkupPointName(CXTPFlowGraphConnectionPoint *pPoint)
Updates the Markup point name (when changed or restored using DoPropExchange).
CXTPFlowGraphNode::DoPropExchange
virtual void DoPropExchange(CXTPPropExchange *pPX)
Call this member function to store/load a Node using the specified data object.
CXTPFlowGraphNode::Remove
void Remove()
Removes this node from the flow graph.
CXTPFlowGraphNode::UpdateCaptionColor
virtual void UpdateCaptionColor()
Updates the foreground color of the CXTPMarkupTextBlock element of the Node's caption.
CXTPFlowGraphNode::m_ptLocation
CPoint m_ptLocation
Point that contains the coordinates of the Node.
Definition XTPFlowGraphNode.h:800
CXTPFlowGraphNode::m_strTooltip
CString m_strTooltip
Tooltip of the item.
Definition XTPFlowGraphNode.h:809
CXTPFlowGraphNode::SetVisible
void SetVisible(BOOL bVisible=TRUE)
Sets the visibility of the Node and its connections.
CXTPFlowGraphNode::GetSize
CSize GetSize() const
Gets the size of the Node.
CXTPFlowGraphNode::GetLocation
CPoint GetLocation() const
Gets the location of the Node.
Definition XTPFlowGraphNode.h:921
CXTPFlowGraphNode::DrawSelectionRect
virtual void DrawSelectionRect(CXTPFlowGraphDrawContext *pDC)
This virtual method is called to draw the Node's selection rectangle.
CXTPFlowGraphNode::GetTableRowTextBlock
CXTPMarkupTextBlock * GetTableRowTextBlock(const CString &strConnectionPointName) const
Retrieves the XAML TextBlock element for a table row of a default Node.
CXTPFlowGraphNode::SetTooltip
void SetTooltip(LPCTSTR lpszTooltip)
Sets the tooltip for this Node.
Definition XTPFlowGraphNode.h:929
CXTPFlowGraphNode::IsLocked
BOOL IsLocked() const
Gets the locked state of the Node.
Definition XTPFlowGraphNode.h:990
CXTPFlowGraphNode::OnRemoved
virtual void OnRemoved()
This method is called when the Node is removed.
CXTPFlowGraphNode::SetStyle
void SetStyle(int nStyle)
Reserved for future use.
Definition XTPFlowGraphNode.h:941
CXTPFlowGraphNode::m_bAlpha
BYTE m_bAlpha
Alpha channel 0-255.
Definition XTPFlowGraphNode.h:812
CXTPFlowGraphNode::SetDefaultMarkup
virtual void SetDefaultMarkup()
Sets the default XAML Markup for a default Node with zero table rows.
CXTPFlowGraphNode::GetID
int GetID() const
Gets the ID used to identify this Node.
Definition XTPFlowGraphNode.h:966
CXTPFlowGraphNode::CalcMinSize
virtual void CalcMinSize()
A virtual method that calculates the minimum size of the Node (used in resizing mechanism).
CXTPFlowGraphNode::SetMarkupText
BOOL SetMarkupText(LPCTSTR szMarkupText)
Sets Markup text for the Node (for a custom Node).
CXTPFlowGraphNode::m_hWnd
HWND m_hWnd
Handle of the window inside the Node.
Definition XTPFlowGraphNode.h:819
CXTPFlowGraphNode::GetControl
CXTPFlowGraphControl * GetControl() const
Gets a reference to the parent FlowGraph control.
CXTPFlowGraphNode::GetCaptionTextBlock
CXTPMarkupTextBlock * GetCaptionTextBlock() const
Get the Node's caption <TextBlock> element.
CXTPFlowGraphNode::DrawWindowContent
virtual void DrawWindowContent(CXTPFlowGraphDrawContext *pDC)
Draws the contents of the Node.
CXTPFlowGraphNode::GetMarkupTableRowIndex
int GetMarkupTableRowIndex(CXTPFlowGraphConnectionPoint *pPoint, CXTPMarkupUIElementCollection *pChildren)
Retrieves the index of a table row in the list (to insert a new one).
CXTPFlowGraphNode::IsResizable
BOOL IsResizable() const
Checks if the Node is resizable.
Definition XTPFlowGraphNode.h:998
CXTPFlowGraphNode::GetMarkupVisualElementRect
CRect GetMarkupVisualElementRect(const CXTPMarkupVisual *pElementVisual) const
An important common method used to get a rectangle of any visual Markup element.
CXTPFlowGraphNode::UpdateWindowPosition
virtual void UpdateWindowPosition()
Updates the window position of the attached external control.
CXTPFlowGraphNode::SetLocked
void SetLocked(BOOL bLocked=TRUE)
Sets the locked state of the Node.
Definition XTPFlowGraphNode.h:986
CXTPFlowGraphNode::m_szUserSize
CSize m_szUserSize
Current size of the Node including user resizing.
Definition XTPFlowGraphNode.h:802
CXTPFlowGraphNode::SetLocation
void SetLocation(CPoint ptLocation)
Sets the location of the Node.
CXTPFlowGraphNode::m_pOriginalWindowProc
WNDPROC m_pOriginalWindowProc
Window procedure pointer.
Definition XTPFlowGraphNode.h:820
CXTPFlowGraphNode::m_bLocked
BOOL m_bLocked
Specifies whether the Node is locked.
Definition XTPFlowGraphNode.h:834
CXTPFlowGraphNode::m_clrNode
COLORREF m_clrNode
Color of the Node.
Definition XTPFlowGraphNode.h:810
CXTPFlowGraphNode::DrawConnectionPoints
virtual void DrawConnectionPoints(CXTPFlowGraphDrawContext *pDC)
A virtual method that draws the Node's connection points (circles) in their placeholders.
CXTPFlowGraphNode::m_pMarkup
CXTPMarkupUIElement * m_pMarkup
Markup that is responsible for drawing this Node.
Definition XTPFlowGraphNode.h:798
CXTPFlowGraphNode::SetID
void SetID(int nId)
Sets the ID used to identify this Node.
Definition XTPFlowGraphNode.h:962
CXTPFlowGraphNode::GetTableRowCaptionRect
CRect GetTableRowCaptionRect(CXTPFlowGraphConnectionPoint *pPoint) const
Retrieves the rectangle of a XAML TextBlock element for a table row of a default Node.
CXTPFlowGraphNode::GetStyle
int GetStyle() const
Reserved for future use.
Definition XTPFlowGraphNode.h:946
CXTPFlowGraphNode::IsVisible
BOOL IsVisible() const
Gets the visibility of the Node and its connections.
Definition XTPFlowGraphNode.h:994
CXTPFlowGraphNode::SetSizeCore
void SetSizeCore(CSize sz)
Sets the size for the Node.
CXTPFlowGraphNode::SetCaption
void SetCaption(LPCTSTR lpszCaption)
Sets the caption that is displayed for this Node.
CXTPFlowGraphNode::CXTPFlowGraphNode
CXTPFlowGraphNode()
Constructs a CXTPFlowGraphNode object.
CXTPFlowGraphNode::m_szUserMinSize
CSize m_szUserMinSize
Manually set minimum size.
Definition XTPFlowGraphNode.h:805
CXTPFlowGraphNode::m_pPage
CXTPFlowGraphPage * m_pPage
Pointer to the page this Node is displayed on.
Definition XTPFlowGraphNode.h:790
CXTPFlowGraphNode::m_dwTag
DWORD_PTR m_dwTag
The 32-bit value associated with the item.
Definition XTPFlowGraphNode.h:816
CXTPFlowGraphNode::GetGroup
CXTPFlowGraphNodeGroup * GetGroup() const
Retrieves the group that this Node is a part of (if any).
Definition XTPFlowGraphNode.h:978
CXTPFlowGraphNode::UpdateMarkupCaption
virtual CXTPMarkupTextBlock * UpdateMarkupCaption()
Updates Node's caption <TextBlock> element with Node's caption text (m_strCaption).
CXTPFlowGraphNode::m_szWindow
CSize m_szWindow
Size of the window of the attached control (if applicable).
Definition XTPFlowGraphNode.h:821
CXTPFlowGraphNode::SetWindowSize
virtual void SetWindowSize(CSize sz)
Sets the size of the window for the external control that is attached to the Node (if applicable).
CXTPFlowGraphNode::SetMinSize
void SetMinSize(CSize sz)
Sets the minimum size for the Node.
CXTPFlowGraphNode::m_WindowToNodeHash
static CMap< HWND, HWND, CXTPFlowGraphNode *, CXTPFlowGraphNode * > m_WindowToNodeHash
Used in the custom window 'ControlWindowProc'.
Definition XTPFlowGraphNode.h:826
CXTPFlowGraphNode::DoCommonPropExchange
void DoCommonPropExchange(CXTPPropExchange *pPX)
Stores/loads Node common properties (for both default and derived Nodes).
CXTPFlowGraphNode::GetImageIndex
int GetImageIndex() const
Gets the ID of the image to display next to the caption text of the Node.
Definition XTPFlowGraphNode.h:982
CXTPFlowGraphNode::GetCaption
CString GetCaption() const
Gets the caption that is displayed for this Node.
Definition XTPFlowGraphNode.h:917
CXTPFlowGraphNode::UpdateMarkupPointCaption
void UpdateMarkupPointCaption(CXTPFlowGraphConnectionPoint *pPoint)
Updates the Markup point caption (when changed or restored using DoPropExchange).
CXTPFlowGraphNode::UpdateMarkupFont
virtual void UpdateMarkupFont()
Updates the default font defined in the paint manager; used in Markup drawing.
CXTPFlowGraphNode::HitTestConnectionPoint
virtual CXTPFlowGraphConnectionPoint * HitTestConnectionPoint(CPoint point)
Determines which connection point, if any, is at a specified point.
CXTPFlowGraphNode::SetTag
void SetTag(DWORD_PTR dwTag)
This method sets the 32-bit value associated with the Node.
Definition XTPFlowGraphNode.h:954
CXTPFlowGraphNode::GetImage
CXTPFlowGraphImage * GetImage() const
Gets the image to display next to the caption text of the Node.
CXTPFlowGraphNode::GetPage
CXTPFlowGraphPage * GetPage() const
Gets a reference to the page that this Node belongs to.
Definition XTPFlowGraphNode.h:950
CXTPFlowGraphNode::IsCustomMarkup
virtual BOOL IsCustomMarkup() const
A virtual function that determines if the Node is a custom Node (a Node with custom XAML markup).
Definition XTPFlowGraphNode.h:703
CXTPFlowGraphNode::RecalLayout
virtual void RecalLayout()
CXTPFlowGraphNode::GetTag
DWORD_PTR GetTag() const
This method retrieves the application-supplied, 32-bit value associated with the Node.
Definition XTPFlowGraphNode.h:958
CXTPFlowGraphNode::m_nImageIndex
int m_nImageIndex
Index of an image to display next to the caption text of the Node.
Definition XTPFlowGraphNode.h:832
CXTPFlowGraphNode::GetWindowHandle
HWND GetWindowHandle() const
Call this member to get the HWND of the object associated with the Node.
Definition XTPFlowGraphNode.h:970
CXTPFlowGraphNode::UpdateConnectionPoints
virtual void UpdateConnectionPoints(CXTPMarkupObject *pRootElement)
A virtual method that finds and updates real connection points in the Markup.
CXTPFlowGraphNode::m_pConnectionPoints
CXTPFlowGraphConnectionPoints * m_pConnectionPoints
Collection of connection points that are displayed for this Node.
Definition XTPFlowGraphNode.h:840
CXTPFlowGraphNode::UpdateColorRecursive
virtual void UpdateColorRecursive(CXTPMarkupObject *pRootElement, COLORREF clrColor)
A recursive method to update/set the color of a Node.
CXTPFlowGraphNode::SetColor
virtual void SetColor(COLORREF clr, BYTE bAlpha=255)
Sets the color for the Node.
CXTPFlowGraphNode::m_bVisible
BOOL m_bVisible
Specifies whether the Node is visible.
Definition XTPFlowGraphNode.h:837
CXTPFlowGraphNode::GetUserSize
CSize GetUserSize() const
Gets the size of the Node (including user resizing).
CXTPFlowGraphNode::Select
virtual void Select(BOOL bSelect=TRUE)
Specifies the selected state of the Node.
CXTPFlowGraphNode::m_nStyle
int m_nStyle
Reserved for future use.
Definition XTPFlowGraphNode.h:814
CXTPFlowGraphNode::m_pGroup
CXTPFlowGraphNodeGroup * m_pGroup
Pointer to the group this Node belongs to (if any).
Definition XTPFlowGraphNode.h:842
CXTPFlowGraphNode::GetMinSize
CSize GetMinSize() const
Gets the minimum size of the Node; calculated in the CalcMinSize method.
CXTPFlowGraphNode::~CXTPFlowGraphNode
virtual ~CXTPFlowGraphNode()
Destroys a CXTPFlowGraphNode object, handles cleanup and deallocation.
CXTPFlowGraphNode::GetCaptionRect
CRect GetCaptionRect() const
Get the Node's caption <TextBlock> rectangle.
CXTPFlowGraphNode::SetWindowHandle
virtual void SetWindowHandle(HWND hWnd)
Call this member to associate an object with the Node.
CXTPFlowGraphNode::GetTooltip
CString GetTooltip() const
Gets the tooltip for this Node.
Definition XTPFlowGraphNode.h:933
CXTPFlowGraphNode::UpdateMarkupImage
virtual void UpdateMarkupImage()
Updates the Node's image.
CXTPFlowGraphNode::Draw
virtual void Draw(CXTPFlowGraphDrawContext *pDC)
This method is called to draw the Node.
CXTPFlowGraphNode::SetSize
virtual void SetSize(CSize sz)
Sets the size for the Node (Node's Markup!).
CXTPFlowGraphNode::m_nGroupId
int m_nGroupId
ID of the group this Node belongs to (if any).
Definition XTPFlowGraphNode.h:830
CXTPFlowGraphNode::GetColor
COLORREF GetColor() const
Gets the color of the node.
Definition XTPFlowGraphNode.h:937
CXTPFlowGraphNode::m_pNextVisibleNode
CXTPFlowGraphNode * m_pNextVisibleNode
Pointer to the next visible node.
Definition XTPFlowGraphNode.h:792
CXTPFlowGraphNode::UpdateMarkupPointImage
void UpdateMarkupPointImage(CXTPFlowGraphConnectionPoint *pPoint)
Updates the markup point image (when changed or restored using DoPropExchange).
CXTPFlowGraphNode::GetScreenRect
CRect GetScreenRect(BOOL bIncludeConnectionPointsEllipses=TRUE) const
Gets the screen coordinates for the Node.
CXTPFlowGraphNode::AddNamedConnectionPoints
virtual void AddNamedConnectionPoints(LPCTSTR szName, XTPFlowGraphConnectionPointType type=xtpFlowGraphPointNone, LPCTSTR szCaption=NULL)
Adds a table row to the Node (of default type), with none, one, or two real connection points.
CXTPFlowGraphNode::m_szActualSize
CSize m_szActualSize
Real size of the Node before the user might have resized it.
Definition XTPFlowGraphNode.h:803
CXTPFlowGraphNode::RemoveMarkupTableRow
int RemoveMarkupTableRow(CXTPFlowGraphConnectionPoint *pPoint)
Removes a table row (with its connection points) from a default Node.
CXTPFlowGraphNode::SetImageIndex
void SetImageIndex(int nImageIndex)
Sets the ID of the image to display next to the caption text of the Node.
CXTPFlowGraphNode::UpdateMarkupPointColor
virtual void UpdateMarkupPointColor(CXTPFlowGraphConnectionPoint *pPoint)
Updates the Markup point color (when changed or restored using DoPropExchange).
CXTPFlowGraphNode::GetWindowSize
CSize GetWindowSize() const
Gets the size of the window for the external control that is attached to the Node (if applicable).
Definition XTPFlowGraphNode.h:974
CXTPFlowGraphNode::m_strCaption
CString m_strCaption
Caption displayed for this node.
Definition XTPFlowGraphNode.h:794
CXTPFlowGraphNode::m_nId
int m_nId
ID of the node.
Definition XTPFlowGraphNode.h:817
CXTPFlowGraphNodes
Represents a collection of Nodes in a page or group.
Definition XTPFlowGraphNodes.h:48
CXTPFlowGraphPage
Represents a page in the flow graph.
Definition XTPFlowGraphPage.h:54
CXTPFlowGraphPaintManager
Handles most of the drawing activities of the flow graph.
Definition XTPFlowGraphPaintManager.h:80
CXTPMarkupTextBlock
CXTPMarkupTextBlock is a CXTPMarkupFrameworkElement derived class.
Definition XTPMarkupTextBlock.h:86
CXTPMarkupUIElementCollection
CXTPMarkupUIElementCollection is a CXTPMarkupCollection derived class.
Definition XTPMarkupUIElementCollection.h:41
CXTPMarkupUIElement
Base class for XML Markup core level implementations.
Definition XTPMarkupUIElement.h:43
CXTPMarkupVisual
Provides rendering support for XML Markup, which includes hit testing, coordinate transformation,...
Definition XTPMarkupInputElement.h:223
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72


Toolkit Pro: Member List

CXTPObservable< Owner, Observer > Member List

This is the complete list of members for CXTPObservable< Owner, Observer >, including all inherited members.

CXTPObservable() | CXTPObservable< Owner, Observer > | protected
Notify(void(Observer::*method)(Owner *)) | CXTPObservable< Owner, Observer > | inline
Notify(void(Observer::*method)(Owner *, A1), A1 arg1) | CXTPObservable< Owner, Observer > | inline
Notify(void(Observer::*method)(Owner *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< Owner, Observer > | inline
Notify(void(Observer::*method)(Owner *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< Owner, Observer > | inline
NotifyDynamic(void(T::*method)(O *)) | CXTPObservable< Owner, Observer > | inline
NotifyDynamic(void(T::*method)(O *, A1), A1 arg1) | CXTPObservable< Owner, Observer > | inline
NotifyDynamic(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< Owner, Observer > | inline
NotifyDynamic(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< Owner, Observer > | inline
NotifyDynamicReversed(void(T::*method)(O *)) | CXTPObservable< Owner, Observer > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1), A1 arg1) | CXTPObservable< Owner, Observer > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< Owner, Observer > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< Owner, Observer > | inline
NotifyReversed(void(Observer::*method)(Owner *)) | CXTPObservable< Owner, Observer > | inline
NotifyReversed(void(Observer::*method)(Owner *, A1), A1 arg1) | CXTPObservable< Owner, Observer > | inline
NotifyReversed(void(Observer::*method)(Owner *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< Owner, Observer > | inline
NotifyReversed(void(Observer::*method)(Owner *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< Owner, Observer > | inline
Subscribe(Observer *pObserver, CXTPSubscriptionList< Owner, Observer > *pSubcriptionList=NULL) | CXTPObservable< Owner, Observer > |
Unsubscribe(Observer *pObserver) | CXTPObservable< Owner, Observer > |
~CXTPObservable() | CXTPObservable< Owner, Observer > | protected


Toolkit Pro: Member List

CXTPGridGroupRow Member List

This is the complete list of members for CXTPGridGroupRow, including all inherited members.

_SetExpanded(BOOL bExpanded, BOOL bRecursive, BOOL bNotify) | CXTPGridRow | virtual
AddChild(CXTPGridRow *pRow) | CXTPGridRow | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPGridGroupRow() | CXTPGridGroupRow |
CXTPGridRow() | CXTPGridRow |
Draw(CDC *pDC, CRect rcRow, CRect rcClip, int nLeftOffset, CXTPGridRecordMergeItems &mergeItems, int nColumnFrom, int nColumnTo) | CXTPGridGroupRow | virtual
EnsureVisible() | CXTPGridRow | virtual
FillMetrics(CXTPGridColumn *pColumn, CXTPGridRecordItem *pItem, XTP_GRIDRECORDITEM_METRICS *pMetrics) | CXTPGridRow | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCaption() const | CXTPGridGroupRow | virtual
GetCaptionValue() const | CXTPGridGroupRow | virtual
GetChilds(BOOL bCreate=TRUE) | CXTPGridRow | virtual
GetControl() const | CXTPGridRow | virtual
GetCurrencyString(double value) | CXTPGridGroupRow | protected
GetFormatString() const | CXTPGridGroupRow | virtual
GetFormula() const | CXTPGridGroupRow | virtual
GetGroupLevel() const | CXTPGridRow | virtual
GetHeight(CDC *pDC, int nWidth) | CXTPGridRow | virtual
GetIndex() const | CXTPGridRow | virtual
GetItemMetrics(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pItemMetrics) | CXTPGridRow | virtual
GetItemRect(CXTPGridRecordItem *pItem) | CXTPGridRow | virtual
GetItemRect(CXTPGridRecordItem *pItem, BOOL bAsMerged) | CXTPGridRow | protected
GetLastChildRow(CXTPGridRows *pChildren) const | CXTPGridRow | protected
GetMergeHeight() const | CXTPGridRow |
GetNextSiblingRow() const | CXTPGridRow | virtual
GetParentRow() const | CXTPGridRow | virtual
GetParentRows() const | CXTPGridRow | virtual
GetRecord() const | CXTPGridRow | virtual
GetRect() const | CXTPGridRow | virtual
GetSection() const | CXTPGridRow |
GetTooltip() const | CXTPGridGroupRow | virtual
GetTreeDepth() const | CXTPGridRow | virtual
GetType() const | CXTPGridRow |
HasChildren() const | CXTPGridRow | virtual
HasMergedItems() const | CXTPGridRow |
HasParent(CXTPGridRow *pRow) | CXTPGridRow | virtual
HitTest(CPoint ptPoint, CRect *pRectItem=NULL, CXTPGridColumn **ppColumn=NULL) const | CXTPGridRow | virtual
InitRow(CXTPGridRow *pRow) | CXTPGridRow | virtual
InitRow(CXTPGridControl *pControl, CXTPGridSection *pSection, CXTPGridRecord *pRecord) | CXTPGridRow | virtual
IsExpanded() const | CXTPGridRow | virtual
IsFocused() const | CXTPGridRow | virtual
IsGroupRow() const | CXTPGridGroupRow | virtual
IsItemsVisible() const | CXTPGridRow | virtual
IsLastTreeRow() const | CXTPGridRow | virtual
IsLockExpand() const | CXTPGridRow | virtual
IsPreviewVisible() const | CXTPGridRow | virtual
IsSelected() const | CXTPGridRow | virtual
IsVisible() const | CXTPGridRow | virtual
LockExpand(BOOL bLockExpand) | CXTPGridRow | virtual
m_bExpanded | CXTPGridRow | protected
m_bHasSelectedChilds | CXTPGridRow | protected
m_bLockExpand | CXTPGridRow | protected
m_bVisible | CXTPGridRow | protected
m_lpCurrencyFmt | CXTPGridGroupRow | protected
m_nChildIndex | CXTPGridRow | protected
m_nFreeHeight | CXTPGridRow | protected
m_nGroupLevel | CXTPGridRow | protected
m_nIndex | CXTPGridRow | protected
m_nMergeHeight | CXTPGridRow | protected
m_nPreviewHeight | CXTPGridRow | protected
m_nRowLevel | CXTPGridRow | protected
m_pChilds | CXTPGridRow | protected
m_pControl | CXTPGridRow | protected
m_pMarkupUIElement | CXTPGridGroupRow |
m_pParentRow | CXTPGridRow | protected
m_pParentRows | CXTPGridRow | protected
m_pRecord | CXTPGridRow | protected
m_pSection | CXTPGridRow | protected
m_rcCollapse | CXTPGridRow | protected
m_rcRow | CXTPGridRow | protected
m_strFormat | CXTPGridGroupRow | protected
m_strFormula | CXTPGridGroupRow | protected
m_strGroupLabel | CXTPGridGroupRow | protected
m_strGroupText | CXTPGridGroupRow | protected
m_vtCaptionValue | CXTPGridGroupRow | protected
OnClick(CPoint ptClicked) | CXTPGridGroupRow | virtual
OnContextMenu(CPoint ptClick) | CXTPGridRow | virtual
OnDblClick(CPoint ptClicked) | CXTPGridGroupRow | virtual
OnLButtonDown(XTP_GRIDRECORDITEM_CLICKARGS *pClickArgs) | CXTPGridRow | virtual
OnLButtonUp(XTP_GRIDRECORDITEM_CLICKARGS *pClickArgs) | CXTPGridRow | virtual
OnMouseMove(UINT nFlags, CPoint point) | CXTPGridRow | virtual
OnToolHitTest(CPoint point, TOOLINFO *pTI) | CXTPGridGroupRow | protectedvirtual
operator delete(void *p) | CXTPHeapObjectT< CXTPGridRowBase, CXTPGridRowAllocator > | inline
operator new(size_t nSize) | CXTPHeapObjectT< CXTPGridRowBase, CXTPGridRowAllocator > | inline
ResetMarkupUIElement() | CXTPGridGroupRow | virtual
SelectChilds() | CXTPGridRow | virtual
SetCaption(LPCTSTR lpszCaption) | CXTPGridGroupRow |
SetCaption(LPCTSTR lpszCaption, COleVariant vtValue) | CXTPGridGroupRow |
SetCollapseRect(CRect rcCollapse) | CXTPGridRow | virtual
SetControl(CXTPGridControl *pControl) | CXTPGridGroupRow | virtual
SetCurrencyFormat(LPCURRENCYFMT fmt) | CXTPGridGroupRow |
SetExpanded(BOOL bExpanded, BOOL bRecursive=FALSE) | CXTPGridRow | virtual
SetFormatString(LPCTSTR strFormat) | CXTPGridGroupRow | virtual
SetFormula(LPCTSTR sFormula) | CXTPGridGroupRow | virtual
SetFullExpanded(BOOL bExpanded) | CXTPGridRow |
SetIndex(int nNewIndex) | CXTPGridRow | protectedvirtual
SetMergeHeight(int nMergeHeight) | CXTPGridRow |
SetSelected(BOOL bSelected) | CXTPGridRow | virtual
SetVisible(BOOL bVisible) | CXTPGridRow | virtual
ShiftTreeIndent(CRect &rcItem, CXTPGridColumn *pColumn) const | CXTPGridRow | virtual
ShowToolTip(CPoint ptTip, CXTPGridTip *pTipWnd) | CXTPGridRow | virtual
UpdateValue() | CXTPGridGroupRow |
~CXTPGridGroupRow() | CXTPGridGroupRow | virtual
~CXTPGridRow() | CXTPGridRow | virtual


Toolkit Pro: Member List

CXTPChartControl Member List

This is the complete list of members for CXTPChartControl, including all inherited members.

BeginFrequentUpdates() | CXTPChartContainer |
CopyToClipboard(CSize szSize) | CXTPChartControl |
CXTPChartContainer() | CXTPChartContainer |
CXTPChartControl() | CXTPChartControl |
EnableToolTips(BOOL bEnable) | CXTPChartControl |
EndFrequentUpdates(XTPChartUpdateOptions updateOptions=xtpChartUpdateRedraw) | CXTPChartContainer |
GetContent() const | CXTPChartControl |
GetControl() | CXTPChartControl | virtual
GetToolTipContext() const | CXTPChartControl |
HitTest(CPoint point) const | CXTPChartControl |
IsBeingFrequentlyUpdated() const | CXTPChartContainer |
m_bmpCache | CXTPChartControl | protected
m_bUpdateWindow | CXTPChartControl | protected
m_dwUpdateOptions | CXTPChartControl | protected
m_pCaptureView | CXTPChartControl | protected
m_pCommand | CXTPChartControl | protected
m_pContent | CXTPChartControl | protected
m_pContentView | CXTPChartControl | protected
m_pDrawThread | CXTPChartControl | protected
m_pToolTipContext | CXTPChartControl | protected
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartControl | virtual
PrintToDC(HDC hDC, CRect rcBounds) | CXTPChartControl |
RegisterWindowClass(HINSTANCE hInstance=NULL) | CXTPChartControl |
SaveAsImage(LPCTSTR lpszFilePath, CSize szBounds) | CXTPChartControl |
SetCapture(CXTPChartElementView *pView) | CXTPChartControl | virtual
SetContent(CXTPChartContent *pContent) | CXTPChartControl |
SetUpdateWindow(BOOL bUpdateWindow) | CXTPChartControl |
~CXTPChartContainer() | CXTPChartContainer | virtual
~CXTPChartControl() | CXTPChartControl | virtual


Toolkit Pro: XTPChartFillStyle.h Source File

  • Source
  • Chart
  • Appearance
XTPChartFillStyle.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTFILLSTYLE_H__)
24# define __XTPCHARTFILLSTYLE_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartElement;
34class CXTPChartDeviceCommand;
35class CXTPPropExchange;
36
42class _XTP_EXT_CLASS CXTPChartFillStyle : public CXTPCmdTarget
43{
44public:
52 CXTPChartFillStyle(CXTPChartElement* pOwner);
53
54public:
59 void Release();
60
61public:
71 void SetFillMode(XTPChartFillMode nFillMode);
72
82 XTPChartFillMode GetFillMode() const;
83
93 void SetGradientAngle(XTPChartGradientAngle nAngle);
94
104 XTPChartGradientAngle GetGradientAngle() const;
105
113 void SetHatchStyle(XTPChartHatchStyle nStyle);
114
122 XTPChartHatchStyle GetHatchStyle() const;
123
124public:
138 virtual CXTPChartDeviceCommand* CreateDeviceCommand(const CXTPChartRectF& bounds,
139 const CXTPChartColor& color,
140 const CXTPChartColor& color2);
141
154 virtual CXTPChartDeviceCommand* CreateDeviceCommand(const CXTPChartPoints& arrPoints,
155 const CXTPChartColor& color,
156 const CXTPChartColor& color2);
157
171 virtual CXTPChartDeviceCommand* CreateCircleDeviceCommand(const CXTPChartPointF& center,
172 double radius,
173 const CXTPChartColor& color,
174 const CXTPChartColor& color2);
175
190 virtual CXTPChartDeviceCommand* CreateSplineDeviceCommand(const CXTPChartPoints& arrPoints,
191 const CXTPChartColor& color,
192 const CXTPChartColor& color2,
193 BOOL bTwoSides = FALSE);
194
206 void DoPropExchange(CXTPPropExchange* pPX);
207
208public:
209 CXTPChartFillStyle* CreateRotatedStyle();
210
211protected:
212# ifdef _XTP_ACTIVEX
213public:
215 DECLARE_DISPATCH_MAP()
216 DECLARE_INTERFACE_MAP()
217 DECLARE_OLETYPELIB_EX(CXTPChartFillStyle);
218
219 int OleGetFillMode();
220 int OleGetHatchStyle();
221 int OleGetGradientAngle();
223# endif
224
225protected:
226 CXTPChartElement* m_pOwner;
227 XTPChartFillMode m_nFillMode;
228 XTPChartGradientAngle m_nGradientAngle;
229 XTPChartHatchStyle m_nHatchStyle;
230};
231
232AFX_INLINE void CXTPChartFillStyle::Release()
233{
234 InternalRelease();
235}
236
237AFX_INLINE XTPChartFillMode CXTPChartFillStyle::GetFillMode() const
238{
239 return m_nFillMode;
240}
241
242AFX_INLINE XTPChartGradientAngle CXTPChartFillStyle::GetGradientAngle() const
243{
244 return m_nGradientAngle;
245}
246
247AFX_INLINE XTPChartHatchStyle CXTPChartFillStyle::GetHatchStyle() const
248{
249 return m_nHatchStyle;
250}
252# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
253#endif //#if !defined(__XTPCHARTFILLSTYLE_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartColor
This class abstracts a color entity.
Definition XTPChartTypes.h:51
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPChartElement
This class abstracts a chart element, this class acts as a base class for all chart elements.
Definition XTPChartElement.h:131
CXTPChartFillStyle
This class abstracts a fill style used to fill the background of various chart elements.
Definition XTPChartFillStyle.h:43
CXTPChartFillStyle::GetHatchStyle
XTPChartHatchStyle GetHatchStyle() const
Call this function to get the hatch style used for filling the background of a particular chart entit...
Definition XTPChartFillStyle.h:247
CXTPChartFillStyle::GetFillMode
XTPChartFillMode GetFillMode() const
Call this function to get a filling mode.
Definition XTPChartFillStyle.h:237
CXTPChartFillStyle::DoPropExchange
void DoPropExchange(CXTPPropExchange *pPX)
Call this member function to Store/Load the properties of fill style object using the specified data ...
CXTPChartFillStyle::m_nFillMode
XTPChartFillMode m_nFillMode
The background fill mode.
Definition XTPChartFillStyle.h:227
CXTPChartFillStyle::SetFillMode
void SetFillMode(XTPChartFillMode nFillMode)
Call this function to set a filling mode.
CXTPChartFillStyle::GetGradientAngle
XTPChartGradientAngle GetGradientAngle() const
Call this function to get the angle for gradient filling.
Definition XTPChartFillStyle.h:242
CXTPChartFillStyle::CreateDeviceCommand
virtual CXTPChartDeviceCommand * CreateDeviceCommand(const CXTPChartRectF &bounds, const CXTPChartColor &color, const CXTPChartColor &color2)
This function creates a CXTPChartDeviceCommand object, this object represents the rendering of an ele...
CXTPChartFillStyle::m_pOwner
CXTPChartElement * m_pOwner
The owner element.
Definition XTPChartFillStyle.h:226
CXTPChartFillStyle::Release
void Release()
Call this function to delete the object.
Definition XTPChartFillStyle.h:232
CXTPChartFillStyle::m_nGradientAngle
XTPChartGradientAngle m_nGradientAngle
The gradient angle.
Definition XTPChartFillStyle.h:228
CXTPChartFillStyle::CreateSplineDeviceCommand
virtual CXTPChartDeviceCommand * CreateSplineDeviceCommand(const CXTPChartPoints &arrPoints, const CXTPChartColor &color, const CXTPChartColor &color2, BOOL bTwoSides=FALSE)
This function creates a CXTPChartDeviceCommand object for rendering, of a spline.
CXTPChartFillStyle::m_nHatchStyle
XTPChartHatchStyle m_nHatchStyle
The hatch style used.
Definition XTPChartFillStyle.h:229
CXTPChartFillStyle::CXTPChartFillStyle
CXTPChartFillStyle(CXTPChartElement *pOwner)
Constructs a CXTPChartFillStyle object.
CXTPChartFillStyle::SetGradientAngle
void SetGradientAngle(XTPChartGradientAngle nAngle)
Call this function to set the angle for gradient filling.
CXTPChartFillStyle::SetHatchStyle
void SetHatchStyle(XTPChartHatchStyle nStyle)
Call this function to set the hatch style used for filling the background of a particular chart entit...
CXTPChartFillStyle::CreateDeviceCommand
virtual CXTPChartDeviceCommand * CreateDeviceCommand(const CXTPChartPoints &arrPoints, const CXTPChartColor &color, const CXTPChartColor &color2)
This function creates a CXTPChartDeviceCommand object, this object represents the rendering of an ele...
CXTPChartFillStyle::CreateCircleDeviceCommand
virtual CXTPChartDeviceCommand * CreateCircleDeviceCommand(const CXTPChartPointF &center, double radius, const CXTPChartColor &color, const CXTPChartColor &color2)
This function creates a CXTPChartDeviceCommand object, this object represents the rendering of an ele...
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPPoint2T< float >
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72
CXTPRectT< float >


Toolkit Pro: XTPMarkupTreeCtrl.h Source File

  • Source
  • Controls
  • Tree
XTPMarkupTreeCtrl.h
Go to the documentation of this file.
1
23#if !defined(__MARKUPTREECTRL_H__) && defined(_XTP_INCLUDE_MARKUP)
24# define __MARKUPTREECTRL_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
37class _XTP_EXT_CLASS CXTPMarkupTreeCtrl
38 : public CXTPTreeCtrl
39 , public CXTPMarkupContext
40{
41public:
46 CXTPMarkupTreeCtrl();
47
52 virtual ~CXTPMarkupTreeCtrl();
53
54public:
61 CXTPMarkupContext* GetMarkupContext();
62
75 HTREEITEM AddItem(LPCTSTR lpszItem, int nImage, int nSelectedImage,
76 HTREEITEM hParent = TVI_ROOT, HTREEITEM hInsertAfter = TVI_LAST);
77
78 //{{AFX_VIRTUAL(CXTPMarkupTreeCtrl)
79 virtual void PreSubclassWindow();
80 virtual BOOL OnWndMsg(UINT message, WPARAM wParam, LPARAM lParam, LRESULT* pResult);
81 using CXTPMarkupContext::OnWndMsg;
82 //}}AFX_VIRTUAL
83
84protected:
90 void DrawMarkupItem(NMTVCUSTOMDRAW* lpLVCD);
91
99 CString GetPlainMarkupItemText(CXTPMarkupUIElement* pUIElement) const;
100
111 CSize GetItemTextExtent(CDC* pDC, LPCTSTR lpszText, int nCount) const;
112
120 HTREEITEM HitTestMarkupItem(CPoint point);
121
123 //{{AFX_MSG(CXTPMarkupTreeCtrl)
124 afx_msg void OnDeleteItem(NMHDR* pNMHDR, LRESULT* pResult);
125 afx_msg void OnGetInfoTip(NMHDR* pNMHDR, LRESULT* pResult);
126 afx_msg void OnGetDispInfo(NMHDR* pNMHDR, LRESULT* pResult);
127 afx_msg void OnCustomDraw(NMHDR* pNMHDR, LRESULT* pResult);
128 afx_msg void OnLButtonDown(UINT nFlags, CPoint point);
129 afx_msg void OnLButtonDblClk(UINT nFlags, CPoint point);
130 afx_msg void OnRButtonDown(UINT nFlags, CPoint point);
131 afx_msg int OnCreate(LPCREATESTRUCT lpCreateStruct);
132 afx_msg void OnPaint();
133 //}}AFX_MSG
134
135 DECLARE_MESSAGE_MAP()
138protected:
139 CXTPToolTipContext::CMarkupToolTip* m_pToolTip;
140
141 mutable CXTPFont m_xtpFontDefaultGui;
142 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CFont, m_fntDefaultGui, m_xtpFontDefaultGui,
143 GetDefaultGuiFontHandle);
144};
146AFX_INLINE CXTPMarkupContext* CXTPMarkupTreeCtrl::GetMarkupContext()
147{
148 return this;
149}
152
153//{{AFX_INSERT_LOCATION}}
154
155# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
157#endif // !defined(__MARKUPTREECTRL_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPFont
Provides a convenient object oriented interface for HFONT GDI object and uses GDI handle caching.
Definition XTPGdiObjects.h:414
CXTPMarkupContext
CXTPMarkupContext is a standalone class used to provide common settings for Markup objects.
Definition XTPMarkupContext.h:128
CXTPMarkupTreeCtrl
Tree control class that allows for adding markup items.
Definition XTPMarkupTreeCtrl.h:40
CXTPMarkupTreeCtrl::AddItem
HTREEITEM AddItem(LPCTSTR lpszItem, int nImage, int nSelectedImage, HTREEITEM hParent=TVI_ROOT, HTREEITEM hInsertAfter=TVI_LAST)
Adds a new markup item.
CXTPMarkupTreeCtrl::CXTPMarkupTreeCtrl
CXTPMarkupTreeCtrl()
Constructs a markup tree control.
CXTPMarkupTreeCtrl::HitTestMarkupItem
HTREEITEM HitTestMarkupItem(CPoint point)
Performs item hit test.
CXTPMarkupTreeCtrl::GetMarkupContext
CXTPMarkupContext * GetMarkupContext()
Obtains the markup context associated with the markup tree.
CXTPMarkupTreeCtrl::GetItemTextExtent
CSize GetItemTextExtent(CDC *pDC, LPCTSTR lpszText, int nCount) const
Obtains item text extent.
CXTPMarkupTreeCtrl::~CXTPMarkupTreeCtrl
virtual ~CXTPMarkupTreeCtrl()
Handles markup tree control deallocation.
CXTPMarkupTreeCtrl::DrawMarkupItem
void DrawMarkupItem(NMTVCUSTOMDRAW *lpLVCD)
Draws a markup item.
CXTPMarkupTreeCtrl::GetPlainMarkupItemText
CString GetPlainMarkupItemText(CXTPMarkupUIElement *pUIElement) const
Obtains plain markup item text, i.e.
CXTPMarkupUIElement
Base class for XML Markup core level implementations.
Definition XTPMarkupUIElement.h:43
CXTPToolTipContext
CXTPToolTipContext is a CXTPCmdTarget derived class.
Definition XTPToolTipContext.h:291
CXTPTreeCtrl
CXTPTreeCtrl is a CTreeCtrl derived class.
Definition XTPTreeCtrlView.h:71


Toolkit Pro: Member List

CXTPShellListBase Member List

This is the complete list of members for CXTPShellListBase, including all inherited members.

_xtGetHeaderCtrl() const | CXTPListBase |
AddColumn(LPCTSTR lpszColHeading, int nWidth=-1, int nFormat=LVCFMT_LEFT) | CXTPListBase | virtual
AutoSaveColumns(LPCTSTR lpszSection=NULL, LPCTSTR lpszEntry=NULL, LPCTSTR lpszDefault=NULL) | CXTPListBase | virtual
AutoSizeColumn(int nCol=-1) | CXTPListBase | virtual
AutoSizeColumn(int nCol, BOOL bUseHeader) | CXTPListBase | virtual
BuildColumns(int nCols, int *nWidth, int *nColString) | CXTPListBase | virtual
BuildColumns(int nCols, int *nWidth, CString *strColString) | CXTPListBase | virtual
BuildDefaultColumns() | CXTPShellListBase | virtual
ComparePidls(LPCITEMIDLIST pidl1, LPCITEMIDLIST pidl2, LPSHELLFOLDER pShellFolder=NULL) | CXTPShellPidl |
ConcatPidls(LPCITEMIDLIST pidl1, LPCITEMIDLIST pidl2) | CXTPShellPidl |
ConcatPidls(LPMALLOC lpMalloc, LPCITEMIDLIST pidl1, LPCITEMIDLIST pidl2) | CXTPShellPidl |
CopyIDList(LPITEMIDLIST pidl) | CXTPShellPidl |
CopyPidlItem(LPITEMIDLIST pidl, UINT nItem) | CXTPShellPidl |
CopyRow(int nFrom, int nTo) | CXTPListBase | virtual
CreatePidl(LPMALLOC lpMalloc, UINT cbSize) | CXTPShellPidl |
CRowColorList typedef | CXTPListBase |
CXTPListBase() | CXTPListBase |
CXTPShellListBase() | CXTPShellListBase |
CXTPShellPidl() | CXTPShellPidl |
DisableColumnSizing(bool bDisable) | CXTPListBase | virtual
DuplicateItem(LPMALLOC lpMalloc, LPITEMIDLIST lpi) | CXTPShellPidl |
EnableContextMenu(BOOL bEnable) | CXTPShellListBase | virtual
EnableUserListColor(bool bEnable) | CXTPListBase |
EnableUserRowColor(bool bEnable) | CXTPListBase |
EnableUserSortColor(bool bEnable) | CXTPListBase |
FreePidl(LPITEMIDLIST pidl) | CXTPShellPidl |
GetAttributes(LPSHELLFOLDER lpsf, LPITEMIDLIST lpi, ULONG uFlags) const | CXTPShellPidl |
GetColumnCount() | CXTPListBase | virtual
GetDoubleClickedItem() | CXTPShellListBase | virtual
GetExtendedStyle() | CXTPListBase | virtual
GetFullyQualPidl(LPSHELLFOLDER lpsf, LPITEMIDLIST lpi) | CXTPShellPidl |
GetItemIcon(LPITEMIDLIST lpi, UINT uFlags) const | CXTPShellPidl |
GetItemPath(int iItem, CString &strItemPath) | CXTPShellListBase | virtual
GetLastITEM(LPITEMIDLIST pidl) | CXTPShellPidl |
GetListBackColor() const | CXTPListBase |
GetListTextColor() const | CXTPListBase |
GetMaximumColSize() | CXTPListBase |
GetMinimumColSize() | CXTPListBase |
GetName(LPSHELLFOLDER lpsf, LPITEMIDLIST lpi, DWORD dwFlags, CString &lpFriendlyName) | CXTPShellPidl |
GetNextPidlItem(LPCITEMIDLIST pidl) | CXTPShellPidl |
GetNormalAndSelectedIcons(LPITEMIDLIST lpifq, LPTV_ITEM lptvitem) | CXTPShellListBase | protectedvirtual
GetPidlCount(LPCITEMIDLIST pidl) | CXTPShellPidl |
GetPidlItemCount(LPCITEMIDLIST pidl) | CXTPShellPidl |
GetSHContextMenu(LPSHELLFOLDER psfFolder, LPCITEMIDLIST *localPidl, int nCount, void **ppCM, int *pcmType) | CXTPShellPidl |
GetSortBackColor() const | CXTPListBase |
GetSortTextColor() const | CXTPListBase |
GetStoredWidth(int nCol) | CXTPListBase | virtual
GetSystemImageList(UINT uFlags) const | CXTPShellPidl |
HitTestEx(CPoint &point, int *col) const | CXTPListBase | virtual
IDLFromPath(LPCTSTR path) | CXTPShellPidl |
ImplAttach(CListCtrl *pListCtrl) | CXTPListBase | protected
Init() | CXTPShellListBase | protectedvirtual
InitListViewItems(XTP_TVITEMDATA *lptvid, LPSHELLFOLDER lpsf) | CXTPShellListBase | protectedvirtual
InitSystemImageLists() | CXTPShellListBase | virtual
InsertCommas(LONGLONG value, TCHAR *szBuffer, UINT nSize) | CXTPShellListBase | virtual
IsItemFiltered(LPCTSTR lpszItemName, ULONG ulItemAttrs) | CXTPShellListBase | protectedvirtual
IsUserListColor() const | CXTPListBase |
IsUserRowColor() const | CXTPListBase |
IsUserSortColor() const | CXTPListBase |
ListViewCompareProc(LPARAM lparam1, LPARAM lparam2, LPARAM lparamSort) | CXTPShellPidl | static
LoadColumnWidths() | CXTPListBase | virtual
Lookup(int iRow) | CXTPListBase | virtual
m_arRowColor | CXTPListBase | protected
m_bAscending | CXTPListBase | protected
m_bAutoFont | CXTPListBase | protected
m_bAutoSave | CXTPListBase | protected
m_bContextMenu | CXTPShellListBase | protected
m_bListColor | CXTPListBase | protected
m_bNoColSizing | CXTPListBase | protected
m_bRowColor | CXTPListBase | protected
m_bShowShellLinkIcons | CXTPShellPidl | protected
m_bSortColor | CXTPListBase | protected
m_crListBack | CXTPListBase | protected
m_crListText | CXTPListBase | protected
m_crSortBack | CXTPListBase | protected
m_crSortText | CXTPListBase | protected
m_csIncludeEXT | CXTPShellListBase | protected
m_lpsfFolder | CXTPShellListBase | protected
m_nMaxColWidth | CXTPListBase | protected
m_nMinColWidth | CXTPListBase | protected
m_nNameColumnWidth | CXTPShellListBase | protected
m_nSortedCol | CXTPListBase | protected
m_pDirThread | CXTPShellListBase | protected
m_pidlINet | CXTPShellListBase | protected
m_pListCtrl | CXTPListBase | protected
m_shSettings | CXTPShellListBase | protected
m_strDefault | CXTPListBase | protected
m_strEntry | CXTPListBase | protected
m_strSection | CXTPListBase | protected
m_uFlags | CXTPShellListBase | protected
m_ulSFGAOFlags | CXTPShellPidl | protected
m_wndHeader | CXTPListBase | protected
MapShellFlagsToItemAttributes(CListCtrl *pListCtrl, int iItem, DWORD dwAttributes) | CXTPShellPidl | protectedvirtual
MapShellFlagsToItemAttributes(CTreeCtrl *pTreeCtrl, HTREEITEM hItem, DWORD dwAttributes) | CXTPShellPidl | protectedvirtual
ModifyExtendedStyle(DWORD dwRemove, DWORD dwAdd) | CXTPListBase | virtual
MoveRow(int nFrom, int nTo) | CXTPListBase | virtual
OnDragDrop(NM_LISTVIEW *pNMListView) | CXTPShellListBase | virtual
OneUpPATH(const CString &path) | CXTPShellPidl |
OneUpPIDL(LPITEMIDLIST pidlPath) | CXTPShellPidl |
OnNotify(WPARAM wParam, LPARAM lParam, LRESULT *pResult) | CXTPListBase | protectedvirtual
OnShowContextMenu(int idCmd, CMINVOKECOMMANDINFO &cmi) | CXTPShellPidl | protectedvirtual
PopulateListView(XTP_TVITEMDATA *lptvid, LPSHELLFOLDER lpsf) | CXTPShellListBase | virtual
RefreshMetrics() | CXTPListBase | protected
RefreshRowColors() | CXTPShellListBase |
RemoveRowColors() | CXTPListBase |
SaveColumnWidths() | CXTPListBase | virtual
SetAttributes(int iItem, DWORD dwAttributes) | CXTPShellListBase | protectedvirtual
SetAutoFont(bool bAutoFont) | CXTPListBase |
SetEnumFlags(UINT uFlags) | CXTPShellListBase | virtual
SetExplorerStyle() | CXTPShellListBase |
SetExtendedStyle(DWORD dwExStyle) | CXTPListBase | virtual
SetIncludeExtensions(LPCTSTR lpszFilters=NULL) | CXTPShellListBase | virtual
SetListBackColor(COLORREF crListBack) | CXTPListBase |
SetListTextColor(COLORREF crListText) | CXTPListBase |
SetMinimumColSize(int nSize) | CXTPListBase |
SetRowColor(ROWCOLOR *lpRowColor, BOOL bRedraw=TRUE) | CXTPListBase |
SetRowColor(int iRow, COLORREF crText, COLORREF crBack, BOOL bRedraw=TRUE) | CXTPListBase |
SetRowColors(COLORREF clrText, COLORREF clrTextBk) | CXTPListBase |
SetSortBackColor(COLORREF crSortBack) | CXTPListBase |
SetSortImage(int nCol, BOOL bAsc) | CXTPListBase | virtual
SetSortTextColor(COLORREF crSortText) | CXTPListBase |
SetStoredWidth(int nCol) | CXTPListBase | virtual
ShellOpenItem(int iItem) | CXTPShellListBase | virtual
ShellOpenItem(XTP_LVITEMDATA *lplvid) | CXTPShellListBase | virtual
ShowContextMenu(HWND hwnd, LPSHELLFOLDER lpsfParent, LPITEMIDLIST lpi, LPPOINT lppt) | CXTPShellPidl |
ShowContextMenu(HWND hwnd, LPSHELLFOLDER lpsfParent, LPCITEMIDLIST *lppi, int nCount, LPPOINT lppt) | CXTPShellPidl |
ShowShellContextMenu(CPoint pos) | CXTPShellListBase | virtual
ShowShellLinkIcons(BOOL bShowLinkIcons=TRUE) | CXTPShellPidl |
SortList(int nCol, bool bAscending) | CXTPShellListBase | virtual
SubclassHeader(bool bBoldFont=false) | CXTPListBase | virtual
TreeViewCompareProc(LPARAM lparam1, LPARAM lparam2, LPARAM lparamSort) | CXTPShellPidl | static
XTPGetHeaderCtrl() const | CXTPListBase |
~CXTPListBase() | CXTPListBase | virtual
~CXTPShellListBase() | CXTPShellListBase | virtual
~CXTPShellPidl() | CXTPShellPidl | virtual


Toolkit Pro: Member List

CXTPChartRangeBarSeriesPointView Member List

This is the complete list of members for CXTPChartRangeBarSeriesPointView, including all inherited members.

AddChildView(CXTPChartElementView *pChildView) | CXTPChartElementView |
CreateDeviceCommand(CXTPChartDeviceContext *pDC) | CXTPChartRangeBarSeriesPointView | virtual
CreateLegendDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcBounds) | CXTPChartBarSeriesPointView | virtual
CXTPChartBarSeriesPointView(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView) | CXTPChartBarSeriesPointView |
CXTPChartElementView(CXTPChartElementView *pParentView) | CXTPChartElementView |
CXTPChartElementView(CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartElementView |
CXTPChartElementView(CXTPChartContainer *pContainer) | CXTPChartElementView |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartRangeBarSeriesPointView(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView) | CXTPChartRangeBarSeriesPointView |
CXTPChartSeriesPointView(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView) | CXTPChartSeriesPointView |
CXTPChartSeriesPointView(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartSeriesPointView |
GetAt(int nIndex) const | CXTPChartElementView |
GetBounds() const | CXTPChartElementView |
GetBounds(BOOL bIncludingChildren) const | CXTPChartElementView |
GetChildren() | CXTPChartElementView |
GetColor() const | CXTPChartSeriesPointView |
GetColor2() const | CXTPChartSeriesPointView |
GetCount() const | CXTPChartElementView |
GetInternalValue() const | CXTPChartSeriesPointView |
GetLegendName() const | CXTPChartSeriesPointView | virtual
GetParentView() const | CXTPChartElementView |
GetPoint() const | CXTPChartSeriesPointView |
GetSeriesView() const | CXTPChartSeriesPointView |
Is3D() const | CXTPChartObject |
m_arrChildren | CXTPChartElementView | protected
m_dInternalValue | CXTPChartSeriesPointView |
m_pContainer | CXTPChartElementView | protected
m_pParentView | CXTPChartElementView | protected
m_pPoint | CXTPChartSeriesPointView | protected
m_rcBounds | CXTPChartElementView | protected
UpdateMinMaxRange(double &nMinValue, double &nMaxValue) const | CXTPChartRangeBarSeriesPointView | virtual
~CXTPChartElementView() | CXTPChartElementView | protectedvirtual
~CXTPChartLegendItemView() | CXTPChartLegendItemView | inlinevirtual


Toolkit Pro: Member List

CXTPShellExplorerProvider Member List

This is the complete list of members for CXTPShellExplorerProvider, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPShellExplorerProvider(IXTPWebBrowserHost &host) | CXTPShellExplorerProvider |
CXTPWebBrowserProvider(IXTPWebBrowserHost &host) | CXTPWebBrowserProvider | protected
ExecuteScript(LPCWSTR pText, CComVariant *pvtResult=NULL) | CXTPShellExplorerProvider | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetBrowserObject() const | CXTPWebBrowserProvider |
GetClientInterface(REFIID riid) const | CXTPWebBrowserProvider |
GetContextMenuEnabled() const | CXTPShellExplorerProvider |
GetRegisterAsDropTarget() const | CXTPShellExplorerProvider |
GetScriptErrorsSuppressed() const | CXTPShellExplorerProvider |
GetScrollBarStyle() const | CXTPShellExplorerProvider |
GetStaticText() const | CXTPShellExplorerProvider |
m_Host | CXTPWebBrowserProvider | protected
Navigate2(VARIANT *pvtURL, VARIANT *pvtFlags=NULL, VARIANT *pvtTargetFrameName=NULL, VARIANT *pvtPostData=NULL, VARIANT *pvtHeaders=NULL) | CXTPShellExplorerProvider |
RemoveClientInterface(REFIID riid) | CXTPWebBrowserProvider |
ScrollBarStyle enum name | CXTPShellExplorerProvider |
SetClientInterface(REFIID riid, IUnknown *pUnk) | CXTPWebBrowserProvider |
SetContextMenuEnabled(BOOL bContextMenuEnabled=TRUE) | CXTPShellExplorerProvider |
SetRegisterAsDropTarget(BOOL bRegisterAsDropTarget=TRUE) | CXTPShellExplorerProvider |
SetScriptErrorsSuppressed(BOOL bScriptErrorsSuppressed=TRUE) | CXTPShellExplorerProvider |
SetScrollBarStyle(ScrollBarStyle nScrollBarStyle) | CXTPShellExplorerProvider |
SetStaticText(BOOL bStaticText=TRUE) | CXTPShellExplorerProvider |
xtpScrollBarFlat enum value | CXTPShellExplorerProvider |
xtpScrollBarNone enum value | CXTPShellExplorerProvider |
xtpScrollBarStandard enum value | CXTPShellExplorerProvider |
~CXTPShellExplorerProvider() | CXTPShellExplorerProvider |
~CXTPWebBrowserProvider() | CXTPWebBrowserProvider | virtual


Toolkit Pro: XTPChartFunnelDiagramView.h Source File

  • Source
  • Chart
  • Styles
  • Funnel
XTPChartFunnelDiagramView.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTFUNNELDIAGRAMVIEW_H__)
24# define __XTPCHARTFUNNELDIAGRAMVIEW_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Chart/Styles/Funnel/2D/XTPChart2dFunnelDiagramView.h"
32
33// CXTPChart2dFunnelDiagramView alias is necessary for naming consistency.
34typedef CXTPChartFunnelDiagramView CXTPChart2dFunnelDiagramView;
36#endif //#if !defined(__XTPCHARTFUNNELDIAGRAMVIEW_H__)
XTPChart2dFunnelDiagramView.h
CXTPChartFunnelDiagramView
This class abstracts the view of a funnel diagram.
Definition XTPChart2dFunnelDiagramView.h:45


Toolkit Pro: XTPScrollBase.h Source File

  • Source
  • Common
  • ScrollBar
XTPScrollBase.h
Go to the documentation of this file.
1
23#if !defined(__XTPSCROLLBASE_H__)
24# define __XTPSCROLLBASE_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPWinThemeWrapper;
34
35# define XTP_HTSCROLLUP 60
36# define XTP_HTSCROLLDOWN \
37 61
39# define XTP_HTSCROLLLEFT \
40 60
42# define XTP_HTSCROLLRIGHT \
43 61
44# define XTP_HTSCROLLUPPAGE \
45 62
46# define XTP_HTSCROLLDOWNPAGE \
47 63
48# define XTP_HTSCROLLTHUMB \
49 64
50# define XTP_HTSCROLLPOPUP \
51 65
53# define IDSYS_SCROLL 23345
54# define IDSYS_ANIMATE 23346
55
62enum XTPScrollBarStyle
63{
64 xtpScrollStyleDefault,
65 xtpScrollStyleStandard,
66 xtpScrollStyleFlat,
67 xtpScrollStyleSystem,
68 xtpScrollStyleOffice,
69 xtpScrollStyleOffice2007Light,
70 xtpScrollStyleOffice2007Dark,
71 xtpScrollStyleSlider,
72 xtpScrollStyleVisualStudio2012Light,
73 xtpScrollStyleVisualStudio2012Dark,
74 xtpScrollStyleVisualStudio2015,
75 xtpScrollStyleNativeWindows10,
76 xtpScrollStyleVisualStudio2017,
77 xtpScrollStyleVisualStudio2019,
78 xtpScrollStyleVisualStudio2022,
79 xtpScrollStyleNativeWindows11,
80};
81
86enum XTPScrollBarTheme
87{
88 xtpScrollBarThemeWindowsClassic,
89 xtpScrollBarThemeWindowsDefault,
90 xtpScrollBarThemeFlat,
91 xtpScrollBarThemeUltraFlat,
92 xtpScrollBarThemeResource,
93 xtpScrollBarThemeOffice2000,
94 xtpScrollBarThemeOfficeXP,
95 xtpScrollBarThemeOffice2003,
96 xtpScrollBarThemeOffice2007Light,
97 xtpScrollBarThemeOffice2007Dark,
98 xtpScrollBarThemeOffice2010,
99 xtpScrollBarThemeOffice2013,
100 xtpScrollBarThemeOffice2016 = xtpScrollBarThemeOffice2013,
101 xtpScrollBarThemeVisualStudio2012Light,
102 xtpScrollBarThemeVisualStudio2012Dark,
103 xtpScrollBarThemeVisualStudio2015,
104 xtpScrollBarThemeVisualStudio2017,
105 xtpScrollBarThemeVisualStudio2019,
106 xtpScrollBarThemeVisualStudio2022,
107 xtpScrollBarThemeNativeWindows10,
108 xtpScrollBarThemeNativeWindows11,
109 xtpScrollBarThemeVisualStudio6 = xtpScrollBarThemeWindowsClassic,
110 xtpScrollBarThemeVisualStudio2002 = xtpScrollBarThemeWindowsDefault,
112 xtpScrollBarThemeVisualStudio2003 = xtpScrollBarThemeWindowsDefault,
114 xtpScrollBarThemeVisualStudio2005 = xtpScrollBarThemeWindowsDefault,
116 xtpScrollBarThemeVisualStudio2008 = xtpScrollBarThemeWindowsDefault,
118 xtpScrollBarThemeVisualStudio2010 = xtpScrollBarThemeWindowsDefault,
120};
121
122class CXTPScrollBarPaintManager;
123
124const UINT XTP_SBN_SCROLL = 0x1007;
125
130struct NMXTPSCROLL
131{
132 NMHDR hdr;
133 CObject* pSender;
134 int nSBCode;
135 int nPos;
136};
137
142struct _XTP_EXT_CLASS XTP_SCROLLBAR_POSINFO
143{
144 int posMin;
145 int posMax;
146 int page;
147 int pos;
149 int pxTop;
150 int pxBottom;
151 int pxLeft;
152 int pxRight;
153 int cpxThumb;
154 int pxUpArrow;
155 int pxDownArrow;
156 int pxStart;
157 int pxThumbBottom;
158 int pxThumbTop;
159 int pxPopup;
160 int cpx;
161 int pxMin;
163 RECT rc;
164 int ht;
165 BOOL fVert;
166 BOOL fSizebox;
167};
168
173struct _XTP_EXT_CLASS XTP_SCROLLBAR_TRACKINFO
174{
175 BOOL fHitOld;
176 RECT rcTrack;
177 UINT cmdSB;
178 UINT_PTR hTimerSB;
179 int dpxThumb;
180 int pxOld;
181 int posOld;
182 int posNew;
183 HWND hWndTrack;
184 BOOL bTrackThumb;
186 XTP_SCROLLBAR_POSINFO* pSBInfo;
187};
188
193struct _XTP_EXT_CLASS XTP_SLIDERTICKS
194{
201 XTP_SLIDERTICKS(double* pTicks, int nCount);
202
207 ~XTP_SLIDERTICKS();
208
209 double* pTicks;
210 int nCount;
211};
212
213_XTP_EXT_CLASS int AFX_CDECL SBPosFromPx(XTP_SCROLLBAR_POSINFO* pSBInfo, int px);
214
215_XTP_EXT_CLASS CRect AFX_CDECL OffsetSourceRect(CRect rc, int nState);
216
221class _XTP_EXT_CLASS CXTPScrollBase
222{
223public:
228 CXTPScrollBase();
229
234 virtual ~CXTPScrollBase();
235
236public:
245 void SetScrollBarStyle(XTPScrollBarStyle scrollStyle);
246
256 XTPScrollBarStyle GetScrollBarStyle() const;
257
258public:
267 XTP_SCROLLBAR_TRACKINFO* GetScrollBarTrackInfo() const;
268
277 XTP_SCROLLBAR_POSINFO* GetScrollBarPosInfo();
278
285 virtual CWnd* GetParentWindow() const = 0;
286
302 int HitTestScrollBar(POINT pt) const;
303
311 CRect GetScrollBarPartRect(int nPart) const;
312
321 void PerformTrackInit(HWND hWnd, CPoint point, XTP_SCROLLBAR_POSINFO* pSBInfo, BOOL bDirect);
322
329 XTP_SLIDERTICKS* GetTicks() const;
330
337 void SetTicks(double* pTicks, int nCount);
338
346 HBRUSH GetCltColor(CDC* pDC) const;
347
348public:
355 BOOL IsSlider() const;
356
363 virtual BOOL IsScrollBarEnabled() const = 0;
364
371 virtual CXTPScrollBarPaintManager* GetScrollBarPaintManager() const = 0;
372
379 virtual CRect GetScrollBarRect() = 0;
380
393 virtual void GetScrollInfo(SCROLLINFO* psi) = 0;
394
399 virtual void RedrawScrollBar() = 0;
400
402 void EndScroll(BOOL fCancel);
403 void MoveThumb(int px);
404 void TrackThumb(UINT message, CPoint pt);
405 void TrackBox(UINT message, CPoint point);
406 void ContScroll();
407 virtual void DoAnimate();
410protected:
412 void SetupScrollInfo();
413 virtual void DoScroll(int cmd, int pos) = 0;
414 virtual void CalcScrollBarInfo(LPRECT lprc, XTP_SCROLLBAR_POSINFO* pSBInfo, SCROLLINFO* pSI);
415 void CalcTrackDragRect(XTP_SCROLLBAR_TRACKINFO* pSBTrack) const;
418 XTP_SCROLLBAR_POSINFO m_spi;
419 XTP_SCROLLBAR_TRACKINFO* m_pSBTrack;
420 XTP_SLIDERTICKS* m_pTicks;
422 XTPScrollBarStyle m_scrollBarStyle;
423 BOOL m_bAnimation;
424 int m_nTimerElapse;
425};
427AFX_INLINE XTP_SCROLLBAR_TRACKINFO* CXTPScrollBase::GetScrollBarTrackInfo() const
428{
429 return m_pSBTrack;
430}
431
432AFX_INLINE XTP_SLIDERTICKS* CXTPScrollBase::GetTicks() const
433{
434 return m_pTicks;
435}
436
437AFX_INLINE XTP_SCROLLBAR_POSINFO* CXTPScrollBase::GetScrollBarPosInfo()
438{
439 return &m_spi;
440}
441
442AFX_INLINE void CXTPScrollBase::SetScrollBarStyle(XTPScrollBarStyle scrollStyle)
443{
444 m_scrollBarStyle = scrollStyle;
445}
446
447AFX_INLINE BOOL CXTPScrollBase::IsSlider() const
448{
449 return (m_scrollBarStyle == xtpScrollStyleSlider);
450}
452# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
454#endif //#if !defined(__XTPSCROLLBASE_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPScrollBarStyle
XTPScrollBarStyle
Scrollbar style.
Definition XTPScrollBase.h:63
xtpScrollStyleVisualStudio2015
@ xtpScrollStyleVisualStudio2015
Visual Studio 2015.
Definition XTPScrollBase.h:74
xtpScrollStyleDefault
@ xtpScrollStyleDefault
Default style.
Definition XTPScrollBase.h:64
xtpScrollStyleVisualStudio2022
@ xtpScrollStyleVisualStudio2022
Visual Studio 2022.
Definition XTPScrollBase.h:78
xtpScrollStyleFlat
@ xtpScrollStyleFlat
Flat scrollbar style.
Definition XTPScrollBase.h:66
xtpScrollStyleVisualStudio2012Light
@ xtpScrollStyleVisualStudio2012Light
Visual Studio 2012 Light.
Definition XTPScrollBase.h:72
xtpScrollStyleOffice
@ xtpScrollStyleOffice
Office scrollbar style.
Definition XTPScrollBase.h:68
xtpScrollStyleOffice2007Dark
@ xtpScrollStyleOffice2007Dark
Office 2007 dark style.
Definition XTPScrollBase.h:70
xtpScrollStyleNativeWindows10
@ xtpScrollStyleNativeWindows10
Native Windows 10.
Definition XTPScrollBase.h:75
xtpScrollStyleSystem
@ xtpScrollStyleSystem
WinXP themed style.
Definition XTPScrollBase.h:67
xtpScrollStyleNativeWindows11
@ xtpScrollStyleNativeWindows11
Native Windows 11.
Definition XTPScrollBase.h:79
xtpScrollStyleVisualStudio2019
@ xtpScrollStyleVisualStudio2019
Visual Studio 2019.
Definition XTPScrollBase.h:77
xtpScrollStyleVisualStudio2017
@ xtpScrollStyleVisualStudio2017
Visual Studio 2017.
Definition XTPScrollBase.h:76
xtpScrollStyleVisualStudio2012Dark
@ xtpScrollStyleVisualStudio2012Dark
Visual Studio 2012 Dark.
Definition XTPScrollBase.h:73
xtpScrollStyleOffice2007Light
@ xtpScrollStyleOffice2007Light
Office 2007 light style.
Definition XTPScrollBase.h:69
xtpScrollStyleStandard
@ xtpScrollStyleStandard
standard window theme
Definition XTPScrollBase.h:65
xtpScrollStyleSlider
@ xtpScrollStyleSlider
Makes the scrollbar look like a slider control.
Definition XTPScrollBase.h:71
XTPScrollBarTheme
XTPScrollBarTheme
Scrollbar theme identifier enum.
Definition XTPScrollBase.h:87
xtpScrollBarThemeVisualStudio2012Light
@ xtpScrollBarThemeVisualStudio2012Light
Visual Studio 2012 light theme.
Definition XTPScrollBase.h:101
xtpScrollBarThemeUltraFlat
@ xtpScrollBarThemeUltraFlat
Ultra flat appearance style theme.
Definition XTPScrollBase.h:91
xtpScrollBarThemeOffice2013
@ xtpScrollBarThemeOffice2013
Office 2013 theme.
Definition XTPScrollBase.h:99
xtpScrollBarThemeOffice2007Dark
@ xtpScrollBarThemeOffice2007Dark
Office 2007 dark theme.
Definition XTPScrollBase.h:97
xtpScrollBarThemeOffice2003
@ xtpScrollBarThemeOffice2003
Office 2003 theme.
Definition XTPScrollBase.h:95
xtpScrollBarThemeVisualStudio2012Dark
@ xtpScrollBarThemeVisualStudio2012Dark
Visual Studio 2012 dark theme.
Definition XTPScrollBase.h:102
xtpScrollBarThemeOffice2010
@ xtpScrollBarThemeOffice2010
Office 2010 theme.
Definition XTPScrollBase.h:98
xtpScrollBarThemeVisualStudio2010
@ xtpScrollBarThemeVisualStudio2010
Visual Studio 2010 theme.
Definition XTPScrollBase.h:118
xtpScrollBarThemeVisualStudio2003
@ xtpScrollBarThemeVisualStudio2003
Visual Studio 2003 theme.
Definition XTPScrollBase.h:112
xtpScrollBarThemeNativeWindows11
@ xtpScrollBarThemeNativeWindows11
Native Windows 11 theme.
Definition XTPScrollBase.h:108
xtpScrollBarThemeVisualStudio2008
@ xtpScrollBarThemeVisualStudio2008
Visual Studio 2008 theme.
Definition XTPScrollBase.h:116
xtpScrollBarThemeFlat
@ xtpScrollBarThemeFlat
Flat appearance style theme.
Definition XTPScrollBase.h:90
xtpScrollBarThemeVisualStudio6
@ xtpScrollBarThemeVisualStudio6
Visual Studio 6 theme.
Definition XTPScrollBase.h:109
xtpScrollBarThemeWindowsDefault
@ xtpScrollBarThemeWindowsDefault
Windows default style theme.
Definition XTPScrollBase.h:89
xtpScrollBarThemeOfficeXP
@ xtpScrollBarThemeOfficeXP
Office XP theme.
Definition XTPScrollBase.h:94
xtpScrollBarThemeVisualStudio2017
@ xtpScrollBarThemeVisualStudio2017
Visual Studio 2017 theme.
Definition XTPScrollBase.h:104
xtpScrollBarThemeOffice2000
@ xtpScrollBarThemeOffice2000
Office 2000 theme.
Definition XTPScrollBase.h:93
xtpScrollBarThemeOffice2016
@ xtpScrollBarThemeOffice2016
Office 2016 theme.
Definition XTPScrollBase.h:100
xtpScrollBarThemeVisualStudio2019
@ xtpScrollBarThemeVisualStudio2019
Visual Studio 2019 theme.
Definition XTPScrollBase.h:105
xtpScrollBarThemeOffice2007Light
@ xtpScrollBarThemeOffice2007Light
Office 2007 light theme.
Definition XTPScrollBase.h:96
xtpScrollBarThemeWindowsClassic
@ xtpScrollBarThemeWindowsClassic
Windows classic style theme.
Definition XTPScrollBase.h:88
xtpScrollBarThemeVisualStudio2022
@ xtpScrollBarThemeVisualStudio2022
Visual Studio 2022 theme.
Definition XTPScrollBase.h:106
xtpScrollBarThemeVisualStudio2015
@ xtpScrollBarThemeVisualStudio2015
Visual Studio 2015 theme.
Definition XTPScrollBase.h:103
xtpScrollBarThemeVisualStudio2005
@ xtpScrollBarThemeVisualStudio2005
Visual Studio 2005 theme.
Definition XTPScrollBase.h:114
xtpScrollBarThemeNativeWindows10
@ xtpScrollBarThemeNativeWindows10
Native Windows 10 theme.
Definition XTPScrollBase.h:107
xtpScrollBarThemeVisualStudio2002
@ xtpScrollBarThemeVisualStudio2002
Visual Studio 2002 theme.
Definition XTPScrollBase.h:110
xtpScrollBarThemeResource
@ xtpScrollBarThemeResource
Resource defined theme.
Definition XTPScrollBase.h:92
CXTPScrollBarPaintManager
CXTPScrollBarPaintManager is standalone class used to draw CXTPCommandBarScrollBarCtrl object.
Definition XTPScrollBarPaintManager.h:40
CXTPScrollBase
CXTPScrollBase is the base class for all scrollable objects.
Definition XTPScrollBase.h:222
CXTPScrollBase::PerformTrackInit
void PerformTrackInit(HWND hWnd, CPoint point, XTP_SCROLLBAR_POSINFO *pSBInfo, BOOL bDirect)
Call this method to start scrollbar tracking.
CXTPScrollBase::SetTicks
void SetTicks(double *pTicks, int nCount)
Call this method to set ticks for the slider.
CXTPScrollBase::SetScrollBarStyle
void SetScrollBarStyle(XTPScrollBarStyle scrollStyle)
Call this method to set the style of the scrollbar.
CXTPScrollBase::GetCltColor
HBRUSH GetCltColor(CDC *pDC) const
Call this method to get the scroll bar control color.
CXTPScrollBase::GetTicks
XTP_SLIDERTICKS * GetTicks() const
Gets the ticks in the slider.
CXTPScrollBase::GetScrollBarPaintManager
virtual CXTPScrollBarPaintManager * GetScrollBarPaintManager() const =0
Obtains a pointer to the associated scrollbar paint manager.
CXTPScrollBase::GetScrollBarTrackInfo
XTP_SCROLLBAR_TRACKINFO * GetScrollBarTrackInfo() const
Call this method to get XTP_SCROLLBAR_TRACKINFO information.
CXTPScrollBase::GetScrollBarStyle
XTPScrollBarStyle GetScrollBarStyle() const
Call this method to get the style of the scrollbar.
CXTPScrollBase::GetParentWindow
virtual CWnd * GetParentWindow() const =0
Retrieves parent window of scrollbar.
CXTPScrollBase::m_nTimerElapse
int m_nTimerElapse
Scroll delay.
Definition XTPScrollBase.h:424
CXTPScrollBase::m_spi
XTP_SCROLLBAR_POSINFO m_spi
ScrollBar position.
Definition XTPScrollBase.h:418
CXTPScrollBase::GetScrollInfo
virtual void GetScrollInfo(SCROLLINFO *psi)=0
The GetScrollInfo function retrieves the parameters of a scroll bar, including the minimum and maximu...
CXTPScrollBase::GetScrollBarPosInfo
XTP_SCROLLBAR_POSINFO * GetScrollBarPosInfo()
Call this method to get XTP_SCROLLBAR_POSINFO information.
CXTPScrollBase::GetScrollBarPartRect
CRect GetScrollBarPartRect(int nPart) const
Gets the bounding rectangle of a specified part of the scrollbar.
CXTPScrollBase::m_scrollBarStyle
XTPScrollBarStyle m_scrollBarStyle
ScrollBar style.
Definition XTPScrollBase.h:422
CXTPScrollBase::m_pTicks
XTP_SLIDERTICKS * m_pTicks
Slider Ticks.
Definition XTPScrollBase.h:420
CXTPScrollBase::m_pSBTrack
XTP_SCROLLBAR_TRACKINFO * m_pSBTrack
ScrollBar tracking.
Definition XTPScrollBase.h:419
CXTPScrollBase::m_bAnimation
BOOL m_bAnimation
TRUE if animation enabled.
Definition XTPScrollBase.h:423
CXTPScrollBase::GetScrollBarRect
virtual CRect GetScrollBarRect()=0
Obtains the rectangle occupied by the scrollbar in client coordinates.
CXTPScrollBase::~CXTPScrollBase
virtual ~CXTPScrollBase()
Destroys a CXTPScrollBase object, handles cleanup and deallocation.
CXTPScrollBase::IsScrollBarEnabled
virtual BOOL IsScrollBarEnabled() const =0
Determines if the scrollbar is enabled.
CXTPScrollBase::CXTPScrollBase
CXTPScrollBase()
Constructs a CXTPScrollBase object.
CXTPScrollBase::IsSlider
BOOL IsSlider() const
Call this member function to determine if the scrollbar is a slider control.
CXTPScrollBase::RedrawScrollBar
virtual void RedrawScrollBar()=0
Forces the scrollbar to redraw itself.
CXTPScrollBase::HitTestScrollBar
int HitTestScrollBar(POINT pt) const
Call this method to check ScrollBar part under pointer.
CXTPWinThemeWrapper
The CXTPWinThemeWrapper class wraps the UxTheme.dll visual theme API.
Definition XTPWinThemeWrapper.h:188
NMXTPSCROLL
The NMXTPSCROLL structure contains information about the scroll bar.
Definition XTPScrollBase.h:131
NMXTPSCROLL::nSBCode
int nSBCode
Scroll bar request codes, such as SB_LINEUP, SB_LINEDOWN, etc.
Definition XTPScrollBase.h:134
NMXTPSCROLL::pSender
CObject * pSender
Pointer to the object that sent the message.
Definition XTPScrollBase.h:133
NMXTPSCROLL::hdr
NMHDR hdr
NMHDR structure that contains additional information about this notification.
Definition XTPScrollBase.h:132
NMXTPSCROLL::nPos
int nPos
Position of the scroll bar thumb.
Definition XTPScrollBase.h:135
XTP_SCROLLBAR_POSINFO
The XTP_SCROLLBAR_POSINFO structure contains scroll bar information.
Definition XTPScrollBase.h:143
XTP_SCROLLBAR_POSINFO::fSizebox
BOOL fSizebox
TRUE if is of size-box type, fVert is ignored.
Definition XTPScrollBase.h:166
XTP_SCROLLBAR_POSINFO::pos
int pos
Position of thumb.
Definition XTPScrollBase.h:147
XTP_SCROLLBAR_POSINFO::rc
RECT rc
Bounding rectangle.
Definition XTPScrollBase.h:163
XTP_SCROLLBAR_POSINFO::pxLeft
int pxLeft
Left bounding rectangle.
Definition XTPScrollBase.h:151
XTP_SCROLLBAR_POSINFO::cpxThumb
int cpxThumb
Size of thumb button.
Definition XTPScrollBase.h:153
XTP_SCROLLBAR_POSINFO::pxStart
int pxStart
Previous position of thumb button.
Definition XTPScrollBase.h:156
XTP_SCROLLBAR_POSINFO::fVert
BOOL fVert
TRUE if vertical.
Definition XTPScrollBase.h:165
XTP_SCROLLBAR_POSINFO::pxDownArrow
int pxDownArrow
Position of Down arrow.
Definition XTPScrollBase.h:155
XTP_SCROLLBAR_POSINFO::cpx
int cpx
position in pixels
Definition XTPScrollBase.h:160
XTP_SCROLLBAR_POSINFO::posMin
int posMin
Minimum position.
Definition XTPScrollBase.h:144
XTP_SCROLLBAR_POSINFO::pxTop
int pxTop
Top bounding rectangle.
Definition XTPScrollBase.h:149
XTP_SCROLLBAR_POSINFO::pxThumbTop
int pxThumbTop
Thumb top bounding rectangle.
Definition XTPScrollBase.h:158
XTP_SCROLLBAR_POSINFO::pxRight
int pxRight
Right bounding rectangle.
Definition XTPScrollBase.h:152
XTP_SCROLLBAR_POSINFO::pxBottom
int pxBottom
Bottom bounding rectangle.
Definition XTPScrollBase.h:150
XTP_SCROLLBAR_POSINFO::pxThumbBottom
int pxThumbBottom
Thumb bottom bounding rectangle.
Definition XTPScrollBase.h:157
XTP_SCROLLBAR_POSINFO::posMax
int posMax
Maximum position.
Definition XTPScrollBase.h:145
XTP_SCROLLBAR_POSINFO::ht
int ht
Hit test.
Definition XTPScrollBase.h:164
XTP_SCROLLBAR_POSINFO::pxUpArrow
int pxUpArrow
Position of Up arrow.
Definition XTPScrollBase.h:154
XTP_SCROLLBAR_POSINFO::pxMin
int pxMin
Minimum position in pixels.
Definition XTPScrollBase.h:161
XTP_SCROLLBAR_POSINFO::page
int page
Page size.
Definition XTPScrollBase.h:146
XTP_SCROLLBAR_POSINFO::pxPopup
int pxPopup
In-place scroll position.
Definition XTPScrollBase.h:159
XTP_SCROLLBAR_TRACKINFO
The XTP_SCROLLBAR_TRACKINFO structure contains tracking information.
Definition XTPScrollBase.h:174
XTP_SCROLLBAR_TRACKINFO::hWndTrack
HWND hWndTrack
Parent tracking window.
Definition XTPScrollBase.h:183
XTP_SCROLLBAR_TRACKINFO::rcTrack
RECT rcTrack
Bounding rectangle of available thumb position.
Definition XTPScrollBase.h:176
XTP_SCROLLBAR_TRACKINFO::hTimerSB
UINT_PTR hTimerSB
Timer identifier.
Definition XTPScrollBase.h:178
XTP_SCROLLBAR_TRACKINFO::pxOld
int pxOld
Previous position in pixels.
Definition XTPScrollBase.h:180
XTP_SCROLLBAR_TRACKINFO::posNew
int posNew
new position
Definition XTPScrollBase.h:182
XTP_SCROLLBAR_TRACKINFO::posOld
int posOld
Previous position.
Definition XTPScrollBase.h:181
XTP_SCROLLBAR_TRACKINFO::fHitOld
BOOL fHitOld
Previous hittest.
Definition XTPScrollBase.h:175
XTP_SCROLLBAR_TRACKINFO::cmdSB
UINT cmdSB
Scroll command.
Definition XTPScrollBase.h:177
XTP_SCROLLBAR_TRACKINFO::pSBInfo
XTP_SCROLLBAR_POSINFO * pSBInfo
SCROLLBARPOSINFO pointer.
Definition XTPScrollBase.h:186
XTP_SCROLLBAR_TRACKINFO::bTrackThumb
BOOL bTrackThumb
TRUE if thumb is tracking.
Definition XTPScrollBase.h:184
XTP_SCROLLBAR_TRACKINFO::dpxThumb
int dpxThumb
Delta of thumb button.
Definition XTPScrollBase.h:179
XTP_SLIDERTICKS
The XTP_SLIDERTICKS structure contains slider ticks.
Definition XTPScrollBase.h:194
XTP_SLIDERTICKS::~XTP_SLIDERTICKS
~XTP_SLIDERTICKS()
Destroys an XTP_SLIDERTICKS object, handles cleanup and deallocation.
XTP_SLIDERTICKS::nCount
int nCount
Count of ticks.
Definition XTPScrollBase.h:210
XTP_SLIDERTICKS::XTP_SLIDERTICKS
XTP_SLIDERTICKS(double *pTicks, int nCount)
Constructs an XTP_SLIDERTICKS object.
XTP_SLIDERTICKS::pTicks
double * pTicks
Ticks array.
Definition XTPScrollBase.h:209


Toolkit Pro: XTPRibbonSystemButton.h Source File

  • Source
  • Ribbon
XTPRibbonSystemButton.h
Go to the documentation of this file.
1
23#if !defined(__XTPRIBBONSYSTEMBUTTON_H__)
24# define __XTPRIBBONSYSTEMBUTTON_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPRibbonControlSystemButton : public CXTPControlPopup
39{
41 DECLARE_XTP_CONTROL(CXTPRibbonControlSystemButton)
43public:
48 CXTPRibbonControlSystemButton();
49
50public:
56 void Draw(CDC* pDC);
57
66 BOOL IsSimpleButton() const;
67
75 virtual CSize GetSize(CDC* pDC);
76
83 virtual CString GetCaption() const;
84
85protected:
93 virtual BOOL OnLButtonDblClk(CPoint point);
94
102 void AdjustExcludeRect(CRect& rc, BOOL bVertical);
103
104# ifdef _XTP_COMMANDBARS_ACTIVEX
107 DECLARE_DISPATCH_MAP()
108 DECLARE_INTERFACE_MAP()
109 DECLARE_OLETYPELIB_EX(CXTPRibbonControlSystemButton);
110
112# endif
113protected:
114 BOOL m_bCloseOnDblClick;
115
116 friend class CXTPRibbonBackstageView;
117 friend class CXTPRibbonBar;
118};
119
125class _XTP_EXT_CLASS CXTPRibbonControlSystemPopupBarButton : public CXTPControlButton
126{
128 DECLARE_XTP_CONTROL(CXTPRibbonControlSystemPopupBarButton)
130public:
135 CXTPRibbonControlSystemPopupBarButton();
136
144 virtual CSize GetSize(CDC* pDC);
145
151 virtual void Draw(CDC* pDC);
152
159 BOOL IsTransparent() const;
160
167 virtual CSize GetButtonSize() const;
168
177 virtual CSize GetIconSize() const;
178
179private:
180 BOOL IsSystemPopupButton() const;
181};
182
188class _XTP_EXT_CLASS CXTPRibbonSystemPopupBar : public CXTPPopupBar
189{
191 DECLARE_XTP_COMMANDBAR(CXTPRibbonSystemPopupBar)
193public:
198 CXTPRibbonSystemPopupBar();
199
200public:
207 virtual CRect GetBorders();
208
216 virtual void FillCommandBarEntry(CDC* pDC);
217
228 virtual CSize CalcDynamicLayout(int nLength, DWORD dwMode);
229
230protected:
232 DECLARE_MESSAGE_MAP()
233
234 afx_msg LRESULT OnNcHitTest(CPoint point);
236};
237
243class _XTP_EXT_CLASS CXTPRibbonSystemPopupBarPage : public CXTPPopupBar
244{
246 DECLARE_XTP_COMMANDBAR(CXTPRibbonSystemPopupBarPage)
248public:
253 CXTPRibbonSystemPopupBarPage();
254
255protected:
266 virtual CSize CalcDynamicLayout(int nLength, DWORD dwMode);
267
274 virtual void AdjustExcludeRect(CRect& rc, BOOL bVertical);
275};
276
282class _XTP_EXT_CLASS CXTPRibbonControlSystemPopupBarListCaption : public CXTPControl
283{
285 DECLARE_XTP_CONTROL(CXTPRibbonControlSystemPopupBarListCaption)
287public:
292 CXTPRibbonControlSystemPopupBarListCaption();
293
294protected:
302 virtual CSize GetSize(CDC* pDC);
303
309 virtual void Draw(CDC* pDC);
310};
311
317class _XTP_EXT_CLASS CXTPRibbonControlSystemPopupBarListItem : public CXTPControlButton
318{
320 DECLARE_XTP_CONTROL(CXTPRibbonControlSystemPopupBarListItem)
322public:
327 CXTPRibbonControlSystemPopupBarListItem();
328
336 virtual CSize GetSize(CDC* pDC);
337
343 virtual void Draw(CDC* pDC);
344
345protected:
346 BOOL m_bAlignShortcut;
347};
348
355class _XTP_EXT_CLASS CXTPRibbonControlSystemPopupBarPinableListItem
356 : public CXTPRibbonControlSystemPopupBarListItem
357{
359 DECLARE_XTP_CONTROL(CXTPRibbonControlSystemPopupBarPinableListItem)
361public:
366 CXTPRibbonControlSystemPopupBarPinableListItem();
367
373 ~CXTPRibbonControlSystemPopupBarPinableListItem();
374
375protected:
381 virtual void Draw(CDC* pDC);
382
388 virtual void OnMouseMove(CPoint point);
389
395 virtual void OnLButtonUp(CPoint point);
396
404 virtual BOOL OnSetSelected(int bSelected);
405
406protected:
407 CXTPImageManager* m_pIcons;
408};
409
416class _XTP_EXT_CLASS CXTPRibbonControlSystemRecentFileList
417 : public CXTPRibbonControlSystemPopupBarListCaption
418{
419 class CControlFileItem;
420 class CControlPinableFileItem;
421
422public:
427 CXTPRibbonControlSystemRecentFileList();
428
429protected:
467 virtual void OnCalcDynamicSize(DWORD dwMode);
468
478 virtual BOOL DoCustomDragOver(CXTPCommandBar* pCommandBar, CPoint point,
479 DROPEFFECT& dropEffect);
480
481protected:
488 virtual CRecentFileList* GetRecentFileList();
489
496 virtual int GetFirstMruID();
497
498private:
499 CString ConstructCaption(const CString& lpszTitle, int nIndex);
500
501private:
502 DECLARE_XTP_CONTROL(CXTPRibbonControlSystemRecentFileList)
503};
504
505# define CXTPPinableRecentFileList CXTPRecentFileList
506
507# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
509#endif // !defined(__XTPRIBBONSYSTEMBUTTON_H__)
DECLARE_XTP_CONTROL
#define DECLARE_XTP_CONTROL(class_name)
This macro generates the C++ header code necessary for a CXTPControl-derived class that can be serial...
Definition XTPCommandBarsDefines.h:1169
DECLARE_XTP_COMMANDBAR
#define DECLARE_XTP_COMMANDBAR(class_name)
This macro generates the C++ header code necessary for a CXTPCommandBar-derived class that can be ser...
Definition XTPCommandBarsDefines.h:1234
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCommandBar
CXTPCommandBar is a CWnd derived class.
Definition XTPCommandBar.h:66
CXTPControlButton
CXTPControlButton is a CXTPControl derived class.
Definition XTPControlButton.h:39
CXTPControl
CXTPControl is a CXTPCmdTarget derived class.
Definition XTPControl.h:841
CXTPControlPopup
CXTPControlPopup is a CXTPControl derived class.
Definition XTPControlPopup.h:42
CXTPImageManager
CXTPImageManager is a standalone class.
Definition XTPImageManager.h:1898
CXTPPopupBar
CXTPPopupBar is a CXTPCommandBar derived class.
Definition XTPPopupBar.h:42
CXTPRibbonBackstageView
CXTPRibbonBackstageView is a CDialog derived class used for a Backstage parent frame.
Definition XTPRibbonBackstageView.h:87
CXTPRibbonBar
CXTPRibbonBar is a CXTPMenuBar derived class.
Definition XTPRibbonBar.h:69
CXTPRibbonControlSystemButton
CXTPRibbonControlSystemButton is a CXTPControlPopup derived class used as a system button for a Ribbo...
Definition XTPRibbonSystemButton.h:39
CXTPRibbonControlSystemButton::IsSimpleButton
BOOL IsSimpleButton() const
This method is called to determine if this system button is a normal button or the Office 2007 style ...
CXTPRibbonControlSystemButton::GetCaption
virtual CString GetCaption() const
Call this member to get the caption of the control.
CXTPRibbonControlSystemButton::OnLButtonDblClk
virtual BOOL OnLButtonDblClk(CPoint point)
This member is called when the user double-clicks the left mouse button.
CXTPRibbonControlSystemButton::CXTPRibbonControlSystemButton
CXTPRibbonControlSystemButton()
Constructs a CXTPRibbonControlSystemButton object.
CXTPRibbonControlSystemButton::Draw
void Draw(CDC *pDC)
This method is called to draw the control.
CXTPRibbonControlSystemButton::GetSize
virtual CSize GetSize(CDC *pDC)
This method is called to determine the size of the control.
CXTPRibbonControlSystemButton::AdjustExcludeRect
void AdjustExcludeRect(CRect &rc, BOOL bVertical)
Updates rectangle to set the position where a child pop-up bar becomes visible.
CXTPRibbonControlSystemPopupBarButton
CXTPRibbonControlSystemPopupBarButton is a CXTPControlButton derived class used in a system pop-up ba...
Definition XTPRibbonSystemButton.h:126
CXTPRibbonControlSystemPopupBarButton::GetButtonSize
virtual CSize GetButtonSize() const
Call this function to get the size of the command bar button.
CXTPRibbonControlSystemPopupBarButton::CXTPRibbonControlSystemPopupBarButton
CXTPRibbonControlSystemPopupBarButton()
Constructs a CXTPRibbonControlSystemPopupBarButton object.
CXTPRibbonControlSystemPopupBarButton::Draw
virtual void Draw(CDC *pDC)
This method is called to draw the control.
CXTPRibbonControlSystemPopupBarButton::IsTransparent
BOOL IsTransparent() const
Determines if the control needs to draw its background.
CXTPRibbonControlSystemPopupBarButton::GetIconSize
virtual CSize GetIconSize() const
Call this member function to get the size of the toolbar icon.
CXTPRibbonControlSystemPopupBarButton::GetSize
virtual CSize GetSize(CDC *pDC)
This method is called to determine the size of the control.
CXTPRibbonControlSystemPopupBarListCaption
CXTPRibbonControlSystemPopupBarListCaption is a CXTPControl derived class used in a Ribbon system pop...
Definition XTPRibbonSystemButton.h:283
CXTPRibbonControlSystemPopupBarListCaption::CXTPRibbonControlSystemPopupBarListCaption
CXTPRibbonControlSystemPopupBarListCaption()
Constructs a CXTPRibbonControlSystemPopupBarListCaption object.
CXTPRibbonControlSystemPopupBarListCaption::Draw
virtual void Draw(CDC *pDC)
This method is called to draw the control.
CXTPRibbonControlSystemPopupBarListCaption::GetSize
virtual CSize GetSize(CDC *pDC)
This method is called to determine the size of the control.
CXTPRibbonControlSystemPopupBarListItem
CXTPRibbonControlSystemPopupBarListItem is a CXTPControlButton derived class used in a Ribbon system ...
Definition XTPRibbonSystemButton.h:318
CXTPRibbonControlSystemPopupBarListItem::m_bAlignShortcut
BOOL m_bAlignShortcut
Alignment of the shortcut in the list.
Definition XTPRibbonSystemButton.h:346
CXTPRibbonControlSystemPopupBarListItem::Draw
virtual void Draw(CDC *pDC)
This method is called to draw the control.
CXTPRibbonControlSystemPopupBarListItem::GetSize
virtual CSize GetSize(CDC *pDC)
This method is called to determine the size of the control.
CXTPRibbonControlSystemPopupBarListItem::CXTPRibbonControlSystemPopupBarListItem
CXTPRibbonControlSystemPopupBarListItem()
Constructs a CXTPRibbonControlSystemPopupBarListItem object.
CXTPRibbonControlSystemPopupBarPinableListItem
CXTPRibbonControlSystemPopupBarPinableListItem is a CXTPRibbonControlSystemPopupBarListItem derived c...
Definition XTPRibbonSystemButton.h:357
CXTPRibbonControlSystemPopupBarPinableListItem::~CXTPRibbonControlSystemPopupBarPinableListItem
~CXTPRibbonControlSystemPopupBarPinableListItem()
Destroys a CXTPRibbonControlSystemPopupBarPinableListItem object, handles cleanup and deallocation.
CXTPRibbonControlSystemPopupBarPinableListItem::Draw
virtual void Draw(CDC *pDC)
This method is called to draw the control.
CXTPRibbonControlSystemPopupBarPinableListItem::CXTPRibbonControlSystemPopupBarPinableListItem
CXTPRibbonControlSystemPopupBarPinableListItem()
Constructs a CXTPRibbonControlSystemPopupBarListItem object.
CXTPRibbonControlSystemPopupBarPinableListItem::OnSetSelected
virtual BOOL OnSetSelected(int bSelected)
This method is called when the MRU item becomes selected.
CXTPRibbonControlSystemPopupBarPinableListItem::OnLButtonUp
virtual void OnLButtonUp(CPoint point)
This member is called when the user releases the left mouse button.
CXTPRibbonControlSystemPopupBarPinableListItem::OnMouseMove
virtual void OnMouseMove(CPoint point)
This member is called when the mouse cursor moves.
CXTPRibbonControlSystemPopupBarPinableListItem::m_pIcons
CXTPImageManager * m_pIcons
Icons used for the MRU item.
Definition XTPRibbonSystemButton.h:407
CXTPRibbonControlSystemRecentFileList
CXTPRibbonControlSystemRecentFileList is a CXTPRibbonControlSystemPopupBarListCaption derived class u...
Definition XTPRibbonSystemButton.h:418
CXTPRibbonControlSystemRecentFileList::GetFirstMruID
virtual int GetFirstMruID()
Retrieves ID_FILE_MRU_FILE1.
CXTPRibbonControlSystemRecentFileList::OnCalcDynamicSize
virtual void OnCalcDynamicSize(DWORD dwMode)
This method is called before recalculating the parent command bar size to calculate the dimensions of...
CXTPRibbonControlSystemRecentFileList::DoCustomDragOver
virtual BOOL DoCustomDragOver(CXTPCommandBar *pCommandBar, CPoint point, DROPEFFECT &dropEffect)
The implementation may implement a custom drag over handling logic in this method.
CXTPRibbonControlSystemRecentFileList::CXTPRibbonControlSystemRecentFileList
CXTPRibbonControlSystemRecentFileList()
Constructs a CXTPRibbonControlSystemRecentFileList object.
CXTPRibbonControlSystemRecentFileList::GetRecentFileList
virtual CRecentFileList * GetRecentFileList()
Retrieves a pointer to the recent file list collection.
CXTPRibbonSystemPopupBar
CXTPRibbonSystemPopupBar is a CXTPPopupBar derived class used as a system pop-up bar for a Ribbon Bar...
Definition XTPRibbonSystemButton.h:189
CXTPRibbonSystemPopupBar::CXTPRibbonSystemPopupBar
CXTPRibbonSystemPopupBar()
Constructs a CXTPRibbonSystemPopupBar object.
CXTPRibbonSystemPopupBar::CalcDynamicLayout
virtual CSize CalcDynamicLayout(int nLength, DWORD dwMode)
This method is called to get the size of the command bar.
CXTPRibbonSystemPopupBar::FillCommandBarEntry
virtual void FillCommandBarEntry(CDC *pDC)
This method is called to draw the background of the command bar.
CXTPRibbonSystemPopupBar::GetBorders
virtual CRect GetBorders()
This method is called to get the border margins of the command bar.
CXTPRibbonSystemPopupBarPage
CXTPRibbonSystemPopupBarPage is a CXTPPopupBar derived class used as a system pop-up bar page of a Ri...
Definition XTPRibbonSystemButton.h:244
CXTPRibbonSystemPopupBarPage::CXTPRibbonSystemPopupBarPage
CXTPRibbonSystemPopupBarPage()
Constructs a CXTPRibbonSystemPopupBarPage object.
CXTPRibbonSystemPopupBarPage::AdjustExcludeRect
virtual void AdjustExcludeRect(CRect &rc, BOOL bVertical)
Updates rectangle to set the position where the pop-up bar becomes visible.
CXTPRibbonSystemPopupBarPage::CalcDynamicLayout
virtual CSize CalcDynamicLayout(int nLength, DWORD dwMode)
This method is called to get the size of the command bar.


Toolkit Pro: Member List

CXTPCalendarViewPart Member List

This is the complete list of members for CXTPCalendarViewPart, including all inherited members.

CXTPCalendarViewPart(CXTPCalendarViewPart *pParentPart=NULL) | CXTPCalendarViewPart |
CXTPCmdTarget() | CXTPCmdTarget |
DrawLine_CenterLR(CDC *pDC, const CString &str, LPRECT lpRect, UINT nFormat) | CXTPCalendarViewPart |
DrawLineEx(CDC *pDC, const CString &str, LPRECT lpRect, UINT nFormatNormal, UINT nFormatSmall) | CXTPCalendarViewPart |
DrawText(CDC *pDC, const CString &str, LPRECT lpRect, UINT nFormat, COLORREF clrText=COLORREF_NULL, CFont *pFont=NULL) | CXTPCalendarViewPart |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetBackgroundColor() | CXTPCalendarViewPart | virtual
GetTextColor() | CXTPCalendarViewPart | virtual
GetTextExtent(CDC *pDC, const CString &str) | CXTPCalendarViewPart |
GetTextFont() | CXTPCalendarViewPart | virtual
m_clrBackground | CXTPCalendarViewPart |
m_clrTextColor | CXTPCalendarViewPart |
m_fntText | CXTPCalendarViewPart |
m_pPaintManager | CXTPCalendarViewPart |
m_pParentPart | CXTPCalendarViewPart |
RefreshMetrics() | CXTPCalendarViewPart | virtual
SetBackgroundColor(COLORREF clr) | CXTPCalendarViewPart |
SetTextColor(COLORREF clr) | CXTPCalendarViewPart |
SetTextFont(LOGFONT *pLogFont) | CXTPCalendarViewPart |
~CXTPCalendarViewPart() | CXTPCalendarViewPart | virtual


Toolkit Pro: XTPStatusBarPaintManager.h Source File

  • Source
  • CommandBars
  • StatusBar
XTPStatusBarPaintManager.h
Go to the documentation of this file.
1
23#if !defined(__XTPSTATUSBARPAINTMANAGER_H__)
24# define __XTPSTATUSBARPAINTMANAGER_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPStatusBarPane;
34class CXTPPaintManager;
35class CXTPStatusBarColorSet;
36class CXTPStatusBarSwitchPane;
37
38class _XTP_EXT_CLASS CXTPStatusBarPaintManager : public CObject
39{
40 DECLARE_DYNAMIC(CXTPStatusBarPaintManager);
41
42public:
48 CXTPStatusBarPaintManager(CXTPPaintManager* pPaintManager);
49
54 virtual ~CXTPStatusBarPaintManager()
55 {
56 }
57
64 virtual void FillStatusBar(CDC* pDC, CXTPStatusBar* pBar);
65
73 virtual void DrawStatusBarPaneEntry(CDC* pDC, CRect rcItem, CXTPStatusBarPane* pPane);
74
82 virtual void DrawStatusBarButtonFace(CDC* pDC, CRect rcItem, CXTPStatusBarPane* pPane);
83
93 virtual int DrawStatusBarSwitchPane(CDC* pDC, CRect rcItem, CXTPStatusBarSwitchPane* pPane);
94
103 virtual void DrawStatusBarPaneBorder(CDC* pDC, CRect rc, CXTPStatusBarPane* pPane,
104 BOOL bGripperPane);
105
113 virtual void DrawStatusBarPaneSeparator(CDC* pDC, CRect rc, CXTPStatusBarPane* pPane);
114
121 virtual void DrawStatusBarGripper(CDC* pDC, CRect rcClient);
122
127 virtual void RefreshMetrics();
128
129 virtual COLORREF GetTextColor(CXTPStatusBarPane* pPane);
130
131public:
132 CXTPPaintManager* m_pPaintManager;
133 CXTPPaintManagerColor m_clrBackground;
134 CXTPPaintManagerColor m_clrText;
135 CXTPPaintManagerColor m_clrTextGray;
136 CXTPPaintManagerColor m_clrGripperLite;
137 CXTPPaintManagerColor m_clrGripperDark;
138};
140# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
141#endif // #if !defined(__XTPSTATUSBARPAINTMANAGER_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPPaintManagerColor
The CXTPPaintManagerColor class is used to manage COLORREF values for determining default and applica...
Definition XTPColorManager.h:117
CXTPPaintManager
Paint manager of the command bars.
Definition XTPPaintManager.h:199
CXTPStatusBar
CXTPStatusBar is a CControlBar derived class.
Definition XTPStatusBar.h:52
CXTPStatusBarPane
CXTPStatusBarPane is a CXTPCmdTarget derived class.
Definition XTPStatusBarPane.h:39
CXTPStatusBarSwitchPane
CXTPStatusBarSwitchPane is a CXTPStatusBarPane derived class.
Definition XTPStatusBarPaneSwitch.h:40


Toolkit Pro: XTPChartBarSeriesView.h Source File

  • Source
  • Chart
  • Styles
  • Bar
XTPChartBarSeriesView.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTBARSERIESVIEW_H__)
24# define __XTPCHARTBARSERIESVIEW_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartSeriesView;
34
40class _XTP_EXT_CLASS CXTPChartBarSeriesView : public CXTPChartDiagram2DSeriesView
41{
42public:
50 CXTPChartBarSeriesView(CXTPChartSeries* pSeries, CXTPChartDiagramView* pDiagramView);
51
52protected:
65 CXTPChartSeriesPointView* CreateSeriesPointView(CXTPChartDeviceContext* pDC,
66 CXTPChartSeriesPoint* pPoint,
67 CXTPChartElementView* pParentView);
68
75 void BeforeUpdateRange(CXTPChartDeviceContext* pDC);
76
87 virtual CXTPChartDeviceCommand* CreateLegendDeviceCommand(CXTPChartDeviceContext* pDC,
88 CRect rcBounds);
89
90protected:
91 int m_nBarCount;
92 int m_nBarIndex;
94 BOOL m_bFirstStack;
95
96 friend class CXTPChartBarSeriesPointView;
97};
98
104class _XTP_EXT_CLASS CXTPChartBarSeriesPointView : public CXTPChartSeriesPointView
105{
106public:
114 CXTPChartBarSeriesPointView(CXTPChartSeriesPoint* pPoint, CXTPChartElementView* pParentView);
115
116public:
117 virtual CXTPChartRectF GetScreenRect() const;
118
119public:
131 virtual CXTPChartDeviceCommand* CreateDeviceCommand(CXTPChartDeviceContext* pDC);
132
143 virtual CXTPChartDeviceCommand* CreateLegendDeviceCommand(CXTPChartDeviceContext* pDC,
144 CRect rcBounds);
145};
147# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
148#endif //#if !defined(__XTPCHARTBARSERIESVIEW_H__)
pPoint
const CPoint * pPoint
return 0 or xtpCalendarHitTestDayExpandButton
Definition XTPCalendarThemeOffice2007.h:150
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartBarSeriesPointView
This class represents the view of a bar series point, which is a kind of CXTPChartPointSeriesPointVie...
Definition XTPChartBarSeriesView.h:105
CXTPChartBarSeriesPointView::CXTPChartBarSeriesPointView
CXTPChartBarSeriesPointView(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Constructs a CXTPChartBarSeriesPointView object.
CXTPChartBarSeriesPointView::CreateDeviceCommand
virtual CXTPChartDeviceCommand * CreateDeviceCommand(CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
CXTPChartBarSeriesPointView::CreateLegendDeviceCommand
virtual CXTPChartDeviceCommand * CreateLegendDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcBounds)
This function creates a label view drawing command object.
CXTPChartBarSeriesView
This class represents the view of a bar series, which is a kind of CXTPChartSeriesView.
Definition XTPChartBarSeriesView.h:41
CXTPChartBarSeriesView::m_nBarIndex
int m_nBarIndex
The index of the bar series.
Definition XTPChartBarSeriesView.h:92
CXTPChartBarSeriesView::m_nBarCount
int m_nBarCount
The bar count in the series.
Definition XTPChartBarSeriesView.h:91
CXTPChartBarSeriesView::CXTPChartBarSeriesView
CXTPChartBarSeriesView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Constructs a CXTPChartBarSeriesView object.
CXTPChartBarSeriesView::CreateLegendDeviceCommand
virtual CXTPChartDeviceCommand * CreateLegendDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcBounds)
This function creates a label view drawing command object.
CXTPChartBarSeriesView::CreateSeriesPointView
CXTPChartSeriesPointView * CreateSeriesPointView(CXTPChartDeviceContext *pDC, CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Call this function to create a view of the bar series point.
CXTPChartBarSeriesView::BeforeUpdateRange
void BeforeUpdateRange(CXTPChartDeviceContext *pDC)
Call this function to calculate the layout of the bar series.
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartDiagramView
This class represents the view of a chart diagram, which is a kind of CXTPChartElementView.
Definition XTPChartDiagramView.h:49
CXTPChartElementView
This class represents the view of a chart element.
Definition XTPChartElementView.h:47
CXTPChartSeries
This class represents a series in the chart, which is a kind of CXTPChartElement.
Definition XTPChartSeries.h:50
CXTPChartSeriesPoint
CXTPChartSeriesPoint is a kind of CXTPChartElement.
Definition XTPChartSeriesPoint.h:43
CXTPChartSeriesPointView
Represents chart series point view.
Definition XTPChartSeriesPointView.h:48
CXTPRectT< float >


Toolkit Pro: Member List

CXTPMarkupUniformGrid Member List

This is the complete list of members for CXTPMarkupUniformGrid, including all inherited members.

ApplyRenderTransform(CXTPMarkupDrawingContext *pContext) | CXTPMarkupUIElement | protectedvirtual
Arrange(CRect rcFinalRect) | CXTPMarkupUIElement |
ArrangeCore(CRect rcFinalRect) | CXTPMarkupUIElement | protectedvirtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPMarkupFrameworkElement() | CXTPMarkupFrameworkElement | protected
CXTPMarkupPanel() | CXTPMarkupPanel | protected
CXTPMarkupUIElement() | CXTPMarkupUIElement | protected
CXTPMarkupUniformGrid() | CXTPMarkupUniformGrid | protected
CXTPMarkupVisual() | CXTPMarkupVisual |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAbsoluteVisualOffset() const | CXTPMarkupVisual | protected
GetActualSize() const | CXTPMarkupFrameworkElement |
GetBackground() const | CXTPMarkupPanel |
GetBoundRect() const | CXTPMarkupVisual |
GetChildren() const | CXTPMarkupPanel |
GetClipToBounds() const | CXTPMarkupFrameworkElement |
GetColumns() const | CXTPMarkupUniformGrid |
GetDesiredSize() const | CXTPMarkupUIElement |
GetFinalRect() const | CXTPMarkupUIElement |
GetFirstColumn() const | CXTPMarkupUniformGrid |
GetHeight() const | CXTPMarkupFrameworkElement |
GetHorizontalAlignment() const | CXTPMarkupFrameworkElement |
GetLayoutClip(CRect &rc) const | CXTPMarkupUIElement | protectedvirtual
GetLogicalChild(int nIndex) const | CXTPMarkupVisual | virtual
GetLogicalChildrenCount() const | CXTPMarkupVisual | virtual
GetMargin() const | CXTPMarkupFrameworkElement |
GetMaxHeight() const | CXTPMarkupFrameworkElement |
GetMaxWidth() const | CXTPMarkupFrameworkElement |
GetMinHeight() const | CXTPMarkupFrameworkElement |
GetMinWidth() const | CXTPMarkupFrameworkElement |
GetOpacity() const | CXTPMarkupUIElement | protectedvirtual
GetRenderSize() const | CXTPMarkupVisual |
GetRenderTransform() const | CXTPMarkupUIElement | protected
GetRows() const | CXTPMarkupUniformGrid |
GetStyle() const | CXTPMarkupFrameworkElement |
GetTag() const | CXTPMarkupFrameworkElement |
GetUpdateRect() const | CXTPMarkupVisual |
GetVerticalAlignment() const | CXTPMarkupFrameworkElement |
GetVisibility() const | CXTPMarkupUIElement |
GetVisualChild(int nIndex) const | CXTPMarkupVisual | virtual
GetVisualChildrenCount() const | CXTPMarkupVisual | virtual
GetVisualOffset() const | CXTPMarkupVisual |
GetVisualParent() const | CXTPMarkupVisual |
GetWidth() const | CXTPMarkupFrameworkElement |
InputHitTest(CPoint point) const | CXTPMarkupVisual |
InputHitTestOverride(CPoint point) const | CXTPMarkupVisual | protectedvirtual
InvalidateArrange() | CXTPMarkupUIElement | virtual
InvalidateMeasure() | CXTPMarkupUIElement | virtual
InvalidateMeasureOverride(CXTPMarkupDrawingContext *pDC) | CXTPMarkupUIElement | protectedvirtual
InvalidateVisual() | CXTPMarkupUIElement | virtual
IsEnabled() const | CXTPMarkupUIElement |
IsFocusable() const | CXTPMarkupUIElement |
IsVisible() const | CXTPMarkupUIElement | virtual
m_bArrangeDirty | CXTPMarkupUIElement | protected
m_bArrangeInProgress | CXTPMarkupUIElement | protected
m_bMeasureDirty | CXTPMarkupUIElement | protected
m_bMeasureInProgress | CXTPMarkupUIElement | protected
m_bNeverArranged | CXTPMarkupUIElement | protected
m_bNeverMeasured | CXTPMarkupUIElement | protected
m_pClipToBoundsProperty | CXTPMarkupUIElement | static
m_pFocusableProperty | CXTPMarkupUIElement | static
m_pIsEnabledProperty | CXTPMarkupUIElement | static
m_pOpacityProperty | CXTPMarkupUIElement | static
m_pRenderTransformOriginProperty | CXTPMarkupUIElement | static
m_pRenderTransformProperty | CXTPMarkupUIElement | static
m_ptVisualOffset | CXTPMarkupVisual | protected
m_pVisibilityProperty | CXTPMarkupUIElement | static
m_rcBoundRect | CXTPMarkupVisual | protected
m_rcFinalRect | CXTPMarkupUIElement | protected
m_rcPrevUpdateRect | CXTPMarkupVisual | protected
m_rcUpdateRect | CXTPMarkupVisual | protected
m_szDesiredSize | CXTPMarkupUIElement | protected
m_szPreviousAvailableSize | CXTPMarkupUIElement | protected
m_szRenderSize | CXTPMarkupVisual | protected
Measure(CXTPMarkupDrawingContext *pDC, CSize szAvailableSize) | CXTPMarkupUIElement |
MeasureCore(CXTPMarkupDrawingContext *pDC, CSize szAvailableSize) | CXTPMarkupUIElement | protectedvirtual
OnRender(CXTPMarkupDrawingContext *drawingContext) | CXTPMarkupVisual | protectedvirtual
OnRenderFocusVisual(CXTPMarkupDrawingContext *drawingContext) | CXTPMarkupVisual | protectedvirtual
PtInRectTransform(const RECT &rect, const POINT &point) const | CXTPMarkupVisual | protected
Render(CXTPMarkupDrawingContext *drawingContext) | CXTPMarkupVisual |
RenderClipped(CXTPMarkupDrawingContext *drawingContext) | CXTPMarkupVisual | protectedvirtual
RestoreRenderTransform(CXTPMarkupDrawingContext *pContext, TransformationMatrices &matrices) | CXTPMarkupUIElement | protectedvirtual
SetBackground(CXTPMarkupBrush *pBrush) | CXTPMarkupPanel |
SetClipToBounds(BOOL bClipToBounds) | CXTPMarkupFrameworkElement |
SetColumns(int nColumns) | CXTPMarkupUniformGrid |
SetFirstColumn(int nFirstColumn) | CXTPMarkupUniformGrid |
SetHeight(int nHeight) | CXTPMarkupFrameworkElement |
SetHorizontalAlignment(XTPMarkupHorizontalAlignment alignment) | CXTPMarkupFrameworkElement |
SetMargin(int nLeft, int nTop, int nRight, int nBottom) | CXTPMarkupFrameworkElement |
SetMargin(int nMargin) | CXTPMarkupFrameworkElement |
SetMaxHeight(int nHeight) | CXTPMarkupFrameworkElement |
SetMaxWidth(int nWidth) | CXTPMarkupFrameworkElement |
SetMinHeight(int nHeight) | CXTPMarkupFrameworkElement |
SetMinWidth(int nWidth) | CXTPMarkupFrameworkElement |
SetRows(int nRows) | CXTPMarkupUniformGrid |
SetTag(CXTPMarkupObject *pTag) | CXTPMarkupFrameworkElement |
SetVerticalAlignment(XTPMarkupVerticalAlignment alignment) | CXTPMarkupFrameworkElement |
SetVisibility(XTPMarkupVisibility visibility) | CXTPMarkupUIElement |
SetWidth(int nWidth) | CXTPMarkupFrameworkElement |
~CXTPMarkupFrameworkElement() | CXTPMarkupFrameworkElement | protectedvirtual
~CXTPMarkupPanel() | CXTPMarkupPanel | protectedvirtual
~CXTPMarkupUIElement() | CXTPMarkupUIElement | protectedvirtual
~CXTPMarkupUniformGrid() | CXTPMarkupUniformGrid | protectedvirtual
~CXTPMarkupVisual() | CXTPMarkupVisual | virtual


Toolkit Pro: XTPMarqueeCtrlPaintManager.h Source File

  • Source
  • Controls
  • Progress
XTPMarqueeCtrlPaintManager.h
Go to the documentation of this file.
1
23#if !defined(__XTPMARQUEECTRLPAINTMANAGER_H__)
24# define __XTPMARQUEECTRLPAINTMANAGER_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPMarqueeCtrl;
34
40class _XTP_EXT_CLASS CXTPMarqueeCtrlPaintManager : public CCmdTarget
41{
43 DECLARE_DYNAMIC(CXTPMarqueeCtrlPaintManager)
45public:
54 CXTPMarqueeCtrlPaintManager();
55
62 virtual ~CXTPMarqueeCtrlPaintManager();
63
71 virtual void RefreshMetrics();
72
81 virtual void DrawBackground(CXTPMarqueeCtrl* pWndCtrl, CDC* pDC, CRect& rcClient);
82
93 virtual void DrawMarquee(CXTPMarqueeCtrl* pWndCtrl, CDC* pDC, CRect& rcClient);
94
103 BOOL UsingWinThemes(BOOL bCheckReady = FALSE);
104
111 void UseWinThemes(BOOL bUseWinThemes = TRUE);
112
120 COLORREF SetBorderColor(COLORREF clrNew);
121
129 COLORREF SetBarColor(COLORREF clrNew);
130
138 COLORREF SetBackColor(COLORREF clrNew);
139
146 COLORREF GetBorderColor();
147
154 COLORREF GetBarColor();
155
162 COLORREF GetBackColor();
163
164protected:
174 virtual void DeflateRect(CDC* pDC, CRect& rcClient);
175
189 virtual void DrawChunk(CXTPMarqueeCtrl* pWndCtrl, CDC* pDC, CXTPCompatibleDC& dcChunk, int i,
190 int& x, int& y, int cx, int cy);
191
192 BOOL m_bUseWinTheme;
193 XTPControlTheme m_nTheme;
194 CXTPWinThemeWrapper m_winTheme;
195 CXTPPaintManagerColor m_clr3DHilite;
196 CXTPPaintManagerColor m_clr3DShadow;
197 CXTPPaintManagerColor m_clrBar;
198 CXTPPaintManagerColor m_clrBack;
199};
201//---------------------------------------------------------------------------
202// Inline functions.
203//---------------------------------------------------------------------------
204
205AFX_INLINE COLORREF CXTPMarqueeCtrlPaintManager::SetBorderColor(COLORREF clrNew)
206{
207 m_clr3DHilite.SetCustomValue(clrNew);
208 m_clr3DShadow.SetCustomValue(clrNew);
209 return m_clr3DShadow;
210}
211AFX_INLINE COLORREF CXTPMarqueeCtrlPaintManager::SetBarColor(COLORREF clrNew)
212{
213 m_clrBar.SetCustomValue(clrNew);
214 return m_clrBar;
215}
216AFX_INLINE COLORREF CXTPMarqueeCtrlPaintManager::SetBackColor(COLORREF clrNew)
217{
218 m_clrBack.SetCustomValue(clrNew);
219 return m_clrBack;
220}
221AFX_INLINE COLORREF CXTPMarqueeCtrlPaintManager::GetBorderColor()
222{
223 return m_clr3DShadow;
224}
225AFX_INLINE COLORREF CXTPMarqueeCtrlPaintManager::GetBarColor()
226{
227 return m_clrBar;
228}
229AFX_INLINE COLORREF CXTPMarqueeCtrlPaintManager::GetBackColor()
230{
231 return m_clrBack;
232}
239class _XTP_EXT_CLASS CXTPMarqueeCtrlThemeFlat : public CXTPMarqueeCtrlPaintManager
240{
242 DECLARE_DYNAMIC(CXTPMarqueeCtrlThemeFlat)
244public:
253 CXTPMarqueeCtrlThemeFlat();
254
262 virtual void RefreshMetrics();
263
264protected:
274 virtual void DeflateRect(CDC* pDC, CRect& rcClient);
275
286 virtual void DrawMarquee(CXTPMarqueeCtrl* pWndCtrl, CDC* pDC, CRect& rcClient);
287};
288
295class _XTP_EXT_CLASS CXTPMarqueeCtrlThemeUltraFlat : public CXTPMarqueeCtrlThemeFlat
296{
298 DECLARE_DYNAMIC(CXTPMarqueeCtrlThemeUltraFlat)
300public:
309 CXTPMarqueeCtrlThemeUltraFlat();
310
318 virtual void RefreshMetrics();
319};
320
326class _XTP_EXT_CLASS CXTPMarqueeCtrlThemeOffice2000 : public CXTPMarqueeCtrlPaintManager
327{
329 DECLARE_DYNAMIC(CXTPMarqueeCtrlThemeOffice2000)
331public:
340 CXTPMarqueeCtrlThemeOffice2000();
341
349 virtual void RefreshMetrics();
350};
351
357class _XTP_EXT_CLASS CXTPMarqueeCtrlThemeOfficeXP : public CXTPMarqueeCtrlThemeOffice2000
358{
360 DECLARE_DYNAMIC(CXTPMarqueeCtrlThemeOfficeXP)
362public:
371 CXTPMarqueeCtrlThemeOfficeXP();
372
380 virtual void RefreshMetrics();
381};
382
388class _XTP_EXT_CLASS CXTPMarqueeCtrlThemeOffice2003 : public CXTPMarqueeCtrlThemeOffice2000
389{
391 DECLARE_DYNAMIC(CXTPMarqueeCtrlThemeOffice2003)
393public:
402 CXTPMarqueeCtrlThemeOffice2003();
403
411 virtual void RefreshMetrics();
412};
413
419class _XTP_EXT_CLASS CXTPMarqueeCtrlThemeResource : public CXTPMarqueeCtrlThemeOffice2000
420{
422 DECLARE_DYNAMIC(CXTPMarqueeCtrlThemeResource)
424public:
433 CXTPMarqueeCtrlThemeResource();
434
443 virtual void DrawBackground(CXTPMarqueeCtrl* pWndCtrl, CDC* pDC, CRect& rcClient);
444
458 virtual void DrawChunk(CXTPMarqueeCtrl* pWndCtrl, CDC* pDC, CXTPCompatibleDC& dcChunk, int i,
459 int& x, int& y, int cx, int cy);
460};
461
467class _XTP_EXT_CLASS CXTPMarqueeCtrlThemeOffice2013 : public CXTPMarqueeCtrlThemeOffice2000
468{
470 DECLARE_DYNAMIC(CXTPMarqueeCtrlThemeOffice2013)
472public:
481 CXTPMarqueeCtrlThemeOffice2013();
482
490 virtual void RefreshMetrics();
491};
492
498class _XTP_EXT_CLASS CXTPMarqueeCtrlThemeVisualStudio2015 : public CXTPMarqueeCtrlThemeOffice2013
499{
501 DECLARE_DYNAMIC(CXTPMarqueeCtrlThemeVisualStudio2015)
503public:
512 CXTPMarqueeCtrlThemeVisualStudio2015();
513};
514
520class _XTP_EXT_CLASS CXTPMarqueeCtrlThemeVisualStudio2017 : public CXTPMarqueeCtrlThemeOffice2013
521{
523 DECLARE_DYNAMIC(CXTPMarqueeCtrlThemeVisualStudio2017)
525public:
534 CXTPMarqueeCtrlThemeVisualStudio2017();
535};
536
542class _XTP_EXT_CLASS CXTPMarqueeCtrlThemeVisualStudio2019 : public CXTPMarqueeCtrlThemeOffice2013
543{
545 DECLARE_DYNAMIC(CXTPMarqueeCtrlThemeVisualStudio2019)
547public:
556 CXTPMarqueeCtrlThemeVisualStudio2019();
557};
558
564class _XTP_EXT_CLASS CXTPMarqueeCtrlThemeVisualStudio2022 : public CXTPMarqueeCtrlThemeOffice2013
565{
567 DECLARE_DYNAMIC(CXTPMarqueeCtrlThemeVisualStudio2022)
569public:
578 CXTPMarqueeCtrlThemeVisualStudio2022();
579};
580
586class _XTP_EXT_CLASS CXTPMarqueeCtrlThemeNativeWinXP : public CXTPMarqueeCtrlPaintManager
587{
589 DECLARE_DYNAMIC(CXTPMarqueeCtrlThemeNativeWinXP)
591public:
600 CXTPMarqueeCtrlThemeNativeWinXP();
601
602protected:
611 virtual void DeflateRect(XTPPROGRESSDRAWSTRUCT& ds);
612
613 using CXTPMarqueeCtrlPaintManager::DeflateRect;
614};
615
621class _XTP_EXT_CLASS CXTPMarqueeCtrlThemeNativeWindows : public CXTPMarqueeCtrlPaintManager
622{
624 DECLARE_DYNAMIC(CXTPMarqueeCtrlThemeNativeWindows)
626public:
635 CXTPMarqueeCtrlThemeNativeWindows();
636
637protected:
647 virtual void DeflateRect(CDC* pDC, CRect& rcClient);
648};
649
650# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
652#endif // #if !defined(__XTPMARQUEECTRLPAINTMANAGER_H__)
XTPControlTheme
XTPControlTheme
Enumeration used to determine the active theme style.
Definition XTPControlTheme.h:43
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPMarqueeCtrl
CXTPMarqueeCtrl is a CProgressCtrl derived class.
Definition XTPMarqueeCtrl.h:45
CXTPMarqueeCtrlPaintManager
The CXTPMarqueeCtrlPaintManager class is derived from CCmdTarget and is used by the progress bar to p...
Definition XTPMarqueeCtrlPaintManager.h:41
CXTPMarqueeCtrlPaintManager::UseWinThemes
void UseWinThemes(BOOL bUseWinThemes=TRUE)
Call this member function to draw the control using the current Windows theme.
CXTPMarqueeCtrlPaintManager::SetBorderColor
COLORREF SetBorderColor(COLORREF clrNew)
This member function sets the border color for the progress bar.
CXTPMarqueeCtrlPaintManager::GetBorderColor
COLORREF GetBorderColor()
This member function gets the border color for the progress bar.
CXTPMarqueeCtrlPaintManager::DeflateRect
virtual void DeflateRect(CDC *pDC, CRect &rcClient)
This member function is called by the progress bar to adjust the bar drawing size; can be overridden ...
CXTPMarqueeCtrlPaintManager::DrawBackground
virtual void DrawBackground(CXTPMarqueeCtrl *pWndCtrl, CDC *pDC, CRect &rcClient)
This member function is called by the progress bar to draw the non-client borders.
CXTPMarqueeCtrlPaintManager::~CXTPMarqueeCtrlPaintManager
virtual ~CXTPMarqueeCtrlPaintManager()
Default paint manager destructor.
CXTPMarqueeCtrlPaintManager::m_clr3DShadow
CXTPPaintManagerColor m_clr3DShadow
An RGB value representing the border color.
Definition XTPMarqueeCtrlPaintManager.h:196
CXTPMarqueeCtrlPaintManager::GetBarColor
COLORREF GetBarColor()
This member function gets the bar color for the progress bar.
CXTPMarqueeCtrlPaintManager::m_nTheme
XTPControlTheme m_nTheme
Theme identifier.
Definition XTPMarqueeCtrlPaintManager.h:193
CXTPMarqueeCtrlPaintManager::m_clrBar
CXTPPaintManagerColor m_clrBar
An RGB value representing the bar color.
Definition XTPMarqueeCtrlPaintManager.h:197
CXTPMarqueeCtrlPaintManager::DrawChunk
virtual void DrawChunk(CXTPMarqueeCtrl *pWndCtrl, CDC *pDC, CXTPCompatibleDC &dcChunk, int i, int &x, int &y, int cx, int cy)
This member function is called by the progress bar to draw a section of the progress indicator.
CXTPMarqueeCtrlPaintManager::m_winTheme
CXTPWinThemeWrapper m_winTheme
Wrapper used when drawing Windows themes.
Definition XTPMarqueeCtrlPaintManager.h:194
CXTPMarqueeCtrlPaintManager::UsingWinThemes
BOOL UsingWinThemes(BOOL bCheckReady=FALSE)
Used by the progress bar to determine if Windows themes should be used to draw the control.
CXTPMarqueeCtrlPaintManager::CXTPMarqueeCtrlPaintManager
CXTPMarqueeCtrlPaintManager()
Default paint manager constructor.
CXTPMarqueeCtrlPaintManager::SetBackColor
COLORREF SetBackColor(COLORREF clrNew)
This member function sets the background color for the progress bar.
CXTPMarqueeCtrlPaintManager::SetBarColor
COLORREF SetBarColor(COLORREF clrNew)
This member function sets the bar color for the progress bar.
CXTPMarqueeCtrlPaintManager::DrawMarquee
virtual void DrawMarquee(CXTPMarqueeCtrl *pWndCtrl, CDC *pDC, CRect &rcClient)
This member function is called by the progress bar to draw the client area of the control.
CXTPMarqueeCtrlPaintManager::RefreshMetrics
virtual void RefreshMetrics()
This member function performs initialization for the Paint Manager.
CXTPMarqueeCtrlPaintManager::GetBackColor
COLORREF GetBackColor()
This member function gets the background color for the progress bar.
CXTPMarqueeCtrlPaintManager::m_bUseWinTheme
BOOL m_bUseWinTheme
TRUE when using Windows themes.
Definition XTPMarqueeCtrlPaintManager.h:192
CXTPMarqueeCtrlPaintManager::m_clr3DHilite
CXTPPaintManagerColor m_clr3DHilite
An RGB value representing the border color.
Definition XTPMarqueeCtrlPaintManager.h:195
CXTPMarqueeCtrlPaintManager::m_clrBack
CXTPPaintManagerColor m_clrBack
An RGB value representing the back color.
Definition XTPMarqueeCtrlPaintManager.h:198
CXTPMarqueeCtrlThemeFlat
The CXTPMarqueeCtrlThemeFlat class is derived from CXTPMarqueeCtrlPaintManager and is used by the pro...
Definition XTPMarqueeCtrlPaintManager.h:240
CXTPMarqueeCtrlThemeFlat::DeflateRect
virtual void DeflateRect(CDC *pDC, CRect &rcClient)
This member function is called by the progress bar to adjust the bar drawing size; can be overridden ...
CXTPMarqueeCtrlThemeFlat::CXTPMarqueeCtrlThemeFlat
CXTPMarqueeCtrlThemeFlat()
Default paint manager constructor.
CXTPMarqueeCtrlThemeFlat::DrawMarquee
virtual void DrawMarquee(CXTPMarqueeCtrl *pWndCtrl, CDC *pDC, CRect &rcClient)
This member function is called by the progress bar to draw the client area of the control.
CXTPMarqueeCtrlThemeFlat::RefreshMetrics
virtual void RefreshMetrics()
This member function performs initialization for the Paint Manager.
CXTPMarqueeCtrlThemeNativeWinXP
The CXTPMarqueeCtrlThemeNativeWinXP class is derived from CXTPMarqueeCtrlPaintManager and is used by ...
Definition XTPMarqueeCtrlPaintManager.h:587
CXTPMarqueeCtrlThemeNativeWinXP::CXTPMarqueeCtrlThemeNativeWinXP
CXTPMarqueeCtrlThemeNativeWinXP()
Default paint manager constructor.
CXTPMarqueeCtrlThemeNativeWinXP::DeflateRect
virtual void DeflateRect(XTPPROGRESSDRAWSTRUCT &ds)
This member function is called by the progress bar to adjust the bar drawing size; can be overridden ...
CXTPMarqueeCtrlThemeNativeWindows
The CXTPMarqueeCtrlThemeNativeWindows class is derived from CXTPMarqueeCtrlPaintManager and is used b...
Definition XTPMarqueeCtrlPaintManager.h:622
CXTPMarqueeCtrlThemeNativeWindows::DeflateRect
virtual void DeflateRect(CDC *pDC, CRect &rcClient)
This member function is called by the progress bar to adjust the bar drawing size; can be overridden ...
CXTPMarqueeCtrlThemeNativeWindows::CXTPMarqueeCtrlThemeNativeWindows
CXTPMarqueeCtrlThemeNativeWindows()
Default paint manager constructor.
CXTPMarqueeCtrlThemeOffice2000
The CXTPMarqueeCtrlThemeFlat class is derived from CXTPMarqueeCtrlPaintManager and is used by the pro...
Definition XTPMarqueeCtrlPaintManager.h:327
CXTPMarqueeCtrlThemeOffice2000::CXTPMarqueeCtrlThemeOffice2000
CXTPMarqueeCtrlThemeOffice2000()
Default paint manager constructor.
CXTPMarqueeCtrlThemeOffice2000::RefreshMetrics
virtual void RefreshMetrics()
This member function performs initialization for the Paint Manager.
CXTPMarqueeCtrlThemeOffice2003
The CXTPMarqueeCtrlThemeFlat class is derived from CXTPMarqueeCtrlPaintManager and is used by the pro...
Definition XTPMarqueeCtrlPaintManager.h:389
CXTPMarqueeCtrlThemeOffice2003::CXTPMarqueeCtrlThemeOffice2003
CXTPMarqueeCtrlThemeOffice2003()
Default paint manager constructor.
CXTPMarqueeCtrlThemeOffice2003::RefreshMetrics
virtual void RefreshMetrics()
This member function performs initialization for the Paint Manager.
CXTPMarqueeCtrlThemeOffice2013
The CXTPMarqueeCtrlThemeFlat class is derived from CXTPMarqueeCtrlPaintManager and is used by the pro...
Definition XTPMarqueeCtrlPaintManager.h:468
CXTPMarqueeCtrlThemeOffice2013::CXTPMarqueeCtrlThemeOffice2013
CXTPMarqueeCtrlThemeOffice2013()
Default paint manager constructor.
CXTPMarqueeCtrlThemeOffice2013::RefreshMetrics
virtual void RefreshMetrics()
This member function performs initialization for the Paint Manager.
CXTPMarqueeCtrlThemeOfficeXP
The CXTPMarqueeCtrlThemeXP class is derived from CXTPMarqueeCtrlThemeFlat and is used by the progress...
Definition XTPMarqueeCtrlPaintManager.h:358
CXTPMarqueeCtrlThemeOfficeXP::CXTPMarqueeCtrlThemeOfficeXP
CXTPMarqueeCtrlThemeOfficeXP()
Default paint manager constructor.
CXTPMarqueeCtrlThemeOfficeXP::RefreshMetrics
virtual void RefreshMetrics()
This member function performs initialization for the Paint Manager.
CXTPMarqueeCtrlThemeResource
The CXTPMarqueeCtrlThemeFlat class is derived from CXTPMarqueeCtrlPaintManager and is used by the pro...
Definition XTPMarqueeCtrlPaintManager.h:420
CXTPMarqueeCtrlThemeResource::CXTPMarqueeCtrlThemeResource
CXTPMarqueeCtrlThemeResource()
Default paint manager constructor.
CXTPMarqueeCtrlThemeResource::DrawBackground
virtual void DrawBackground(CXTPMarqueeCtrl *pWndCtrl, CDC *pDC, CRect &rcClient)
This member function is called by the progress bar to draw the non-client borders.
CXTPMarqueeCtrlThemeResource::DrawChunk
virtual void DrawChunk(CXTPMarqueeCtrl *pWndCtrl, CDC *pDC, CXTPCompatibleDC &dcChunk, int i, int &x, int &y, int cx, int cy)
This member function is called by the progress bar to draw a section of the progress indicator.
CXTPMarqueeCtrlThemeUltraFlat
The CXTPMarqueeCtrlThemeUltraFlat class is derived from CXTPMarqueeCtrlThemeFlat and is used by the p...
Definition XTPMarqueeCtrlPaintManager.h:296
CXTPMarqueeCtrlThemeUltraFlat::CXTPMarqueeCtrlThemeUltraFlat
CXTPMarqueeCtrlThemeUltraFlat()
Default paint manager constructor.
CXTPMarqueeCtrlThemeUltraFlat::RefreshMetrics
virtual void RefreshMetrics()
This member function performs initialization for the Paint Manager.
CXTPMarqueeCtrlThemeVisualStudio2015
The CXTPMarqueeCtrlThemeFlat class is derived from CXTPMarqueeCtrlPaintManager and is used by the pro...
Definition XTPMarqueeCtrlPaintManager.h:499
CXTPMarqueeCtrlThemeVisualStudio2015::CXTPMarqueeCtrlThemeVisualStudio2015
CXTPMarqueeCtrlThemeVisualStudio2015()
Default paint manager constructor.
CXTPMarqueeCtrlThemeVisualStudio2017
The CXTPMarqueeCtrlThemeFlat class is derived from CXTPMarqueeCtrlPaintManager and is used by the pro...
Definition XTPMarqueeCtrlPaintManager.h:521
CXTPMarqueeCtrlThemeVisualStudio2017::CXTPMarqueeCtrlThemeVisualStudio2017
CXTPMarqueeCtrlThemeVisualStudio2017()
Default paint manager constructor.
CXTPMarqueeCtrlThemeVisualStudio2019
The CXTPMarqueeCtrlThemeFlat class is derived from CXTPMarqueeCtrlPaintManager and is used by the pro...
Definition XTPMarqueeCtrlPaintManager.h:543
CXTPMarqueeCtrlThemeVisualStudio2019::CXTPMarqueeCtrlThemeVisualStudio2019
CXTPMarqueeCtrlThemeVisualStudio2019()
Default paint manager constructor.
CXTPMarqueeCtrlThemeVisualStudio2022
The CXTPMarqueeCtrlThemeFlat class is derived from CXTPMarqueeCtrlPaintManager and is used by the pro...
Definition XTPMarqueeCtrlPaintManager.h:565
CXTPMarqueeCtrlThemeVisualStudio2022::CXTPMarqueeCtrlThemeVisualStudio2022
CXTPMarqueeCtrlThemeVisualStudio2022()
Default paint manager constructor.
CXTPPaintManagerColor
The CXTPPaintManagerColor class is used to manage COLORREF values for determining default and applica...
Definition XTPColorManager.h:117
CXTPPaintManagerColor::SetCustomValue
void SetCustomValue(COLORREF clr)
This member function will sets the application defined color for the CXTPPaintManagerColor class.
CXTPWinThemeWrapper
The CXTPWinThemeWrapper class wraps the UxTheme.dll visual theme API.
Definition XTPWinThemeWrapper.h:188
XTPPROGRESSDRAWSTRUCT
Struct used by the progress bar during paint operations.
Definition XTPProgressCtrlPaintManager.h:38


Toolkit Pro: XTPSvgPreviewProvider.h Source File

  • Source
  • Controls
  • Preview
  • Providers
  • Svg
XTPSvgPreviewProvider.h
Go to the documentation of this file.
1
23#if !defined(__XTPSVGPREVIEWPROVIDER_H__)
24# define __XTPSVGPREVIEWPROVIDER_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
41class _XTP_EXT_CLASS CXTPSvgPreviewProvider : public CXTPPreviewProviderBase
42{
43private:
44 virtual LPCTSTR GetDefaultFileAssociations() const;
45 virtual IXTPPreview* CreatePreview(LPCTSTR pFilePath, HWND hwndParent);
46 virtual IXTPPreview* CreatePreview(IStream& stream, LPCTSTR pImpliedFileName, HWND hwndParent);
47};
48
49# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
51#endif // #if !defined(__XTPSVGPREVIEWPROVIDER_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPPreviewProviderBase
Base class for a preview provider which implements common behavior to be exposed by a preview provide...
Definition XTPPreviewAbstract.h:251
CXTPSvgPreviewProvider
Provides a preview handler for XAML files that uses Markup components for rendering file contents.
Definition XTPSvgPreviewProvider.h:42
IXTPPreview
The base interface for a preview handler implementation.
Definition XTPPreviewAbstract.h:40
IXTPPreviewProvider::GetDefaultFileAssociations
virtual LPCTSTR GetDefaultFileAssociations() const =0
Obtains the list of file extensions supported by the associated preview implementation.
IXTPPreviewProvider::CreatePreview
virtual IXTPPreview * CreatePreview(LPCTSTR pFilePath, HWND hwndParent)=0
Creates a preview object for the specified file.


Toolkit Pro: XTPChartRadarDiagramView.h Source File

  • Source
  • Chart
  • Diagram
  • RadarDiagram
XTPChartRadarDiagramView.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTRADARDIAGRAMVIEW_H__)
24# define __XTPCHARTRADARDIAGRAMVIEW_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartAxis;
34class CXTPChartDiagram2DAppearance;
35class CXTPChartRadarAxisView;
36class CXTPChartSeriesView;
37class CXTPChartRadarAxisXView;
38class CXTPChartRadarAxisYView;
39class CXTPChartLineStyle;
40class CXTPChartFillStyle;
41
47class _XTP_EXT_CLASS CXTPChartRadarDiagramView : public CXTPChartDiagramView
48{
49public:
57 CXTPChartRadarDiagramView(CXTPChartDiagram* pDiagram, CXTPChartElementView* pParent);
58
65 void CreateView(CXTPChartDeviceContext* pDC);
66
75 void CalculateView(CXTPChartDeviceContext* pDC, CRect rcBounds);
76
77 void UpdateRange(CXTPChartDeviceContext* pDC);
78
79 virtual CXTPChartDeviceCommand* CreateDeviceCommand(CXTPChartDeviceContext* pDC);
80
89 CXTPChartRadarAxisView* GetAxisView(CXTPChartAxis* pAxis) const;
90
91public:
92 void CheckLabelBounds(const CXTPChartRectF& rcBounds);
93
94 CXTPChartPointF GetScreenPoint(const CXTPChartSeriesView* pView, double x, double y) const;
95
96 CXTPChartRadarAxisXView* GetAxisXView() const;
97 CXTPChartRadarAxisYView* GetAxisYView() const;
98
99protected:
110 CXTPChartRadarAxisView* AddAxisView(CXTPChartDeviceContext* pDC,
111 CXTPChartElementView* pParentView, CXTPChartAxis* pAxis);
112
113public:
114 virtual CXTPChartDeviceCommand* CreatePolygonStripDeviceCommand(
115 CXTPChartDeviceContext* /*pDC*/, double dRadiusFrom, double dRadiusTo,
116 const CXTPChartColor& color1, const CXTPChartColor& color2, CXTPChartFillStyle* pFillStyle);
117
118 virtual CXTPChartDeviceCommand* CreatePolygonLineDeviceCommand(CXTPChartDeviceContext* /*pDC*/,
119 double dRadius,
120 const CXTPChartColor& color,
121 CXTPChartLineStyle* pLineStyle);
122
123protected:
124 CXTPChartElementView* m_pAxisViews;
126 CXTPChartRadarAxisXView* m_pAxisXView;
127 CXTPChartRadarAxisYView* m_pAxisYView;
128
129 CRect m_rcLabelPadding;
130
131 CXTPPoint2i m_ptCenter;
132 int m_nRadius;
133};
134
135AFX_INLINE CXTPChartRadarAxisXView* CXTPChartRadarDiagramView::GetAxisXView() const
136{
137 return m_pAxisXView;
138}
139AFX_INLINE CXTPChartRadarAxisYView* CXTPChartRadarDiagramView::GetAxisYView() const
140{
141 return m_pAxisYView;
142}
144# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
145#endif //#if !defined(__XTPCHARTRADARDIAGRAMVIEW_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartAxis
This abstract base class represents a chart axis as a kind of chart element.
Definition XTPChartAxis.h:86
CXTPChartColor
This class abstracts a color entity.
Definition XTPChartTypes.h:51
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartDiagram2DAppearance
This class represents the appearance of diagram in 2D.
Definition XTPChartAppearance.h:292
CXTPChartDiagram
This class represents a chart diagram, which is a kind of CXTPChartElement.
Definition XTPChartDiagram.h:48
CXTPChartDiagramView
This class represents the view of a chart diagram, which is a kind of CXTPChartElementView.
Definition XTPChartDiagramView.h:49
CXTPChartElementView
This class represents the view of a chart element.
Definition XTPChartElementView.h:47
CXTPChartFillStyle
This class abstracts a fill style used to fill the background of various chart elements.
Definition XTPChartFillStyle.h:43
CXTPChartLineStyle
This class represents a chart line style, which is a kind of CXTPCmdTarget.
Definition XTPChartLineStyle.h:43
CXTPChartRadarAxisView
This class abstracts the view of a chart axis and its child items in a bounding rectangle context.
Definition XTPChartRadarAxisView.h:41
CXTPChartRadarAxisXView
This class abstracts the view of a chart axis and its child items in a bounding rectangle context.
Definition XTPChartRadarAxisXView.h:57
CXTPChartRadarAxisYView
This class abstracts the view of a chart axis and its child items in a bounding rectangle context.
Definition XTPChartRadarAxisYView.h:56
CXTPChartRadarDiagramView
This class represents the view of a chart 2D diagram, which is a kind of CXTPChartDiagramView.
Definition XTPChartRadarDiagramView.h:48
CXTPChartRadarDiagramView::AddAxisView
CXTPChartRadarAxisView * AddAxisView(CXTPChartDeviceContext *pDC, CXTPChartElementView *pParentView, CXTPChartAxis *pAxis)
Use this function to add an axis view to the diagram view boundary.
CXTPChartRadarDiagramView::GetAxisView
CXTPChartRadarAxisView * GetAxisView(CXTPChartAxis *pAxis) const
Call this function to get the view for an axis object.
CXTPChartRadarDiagramView::CreateDeviceCommand
virtual CXTPChartDeviceCommand * CreateDeviceCommand(CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
CXTPChartRadarDiagramView::CalculateView
void CalculateView(CXTPChartDeviceContext *pDC, CRect rcBounds)
Call this function to calculate the layout based on a rectangular boundary.
CXTPChartRadarDiagramView::UpdateRange
void UpdateRange(CXTPChartDeviceContext *pDC)
Updates chart range.
CXTPChartRadarDiagramView::m_pAxisViews
CXTPChartElementView * m_pAxisViews
The axis view.
Definition XTPChartRadarDiagramView.h:124
CXTPChartRadarDiagramView::CreateView
void CreateView(CXTPChartDeviceContext *pDC)
Call this function to create the view of the 2D diagram.
CXTPChartRadarDiagramView::CXTPChartRadarDiagramView
CXTPChartRadarDiagramView(CXTPChartDiagram *pDiagram, CXTPChartElementView *pParent)
Constructs a CXTPChartRadarDiagramView object.
CXTPPoint2T< float >
CXTPRectT< float >


Toolkit Pro: Member List

CXTPResizePoint Member List

This is the complete list of members for CXTPResizePoint, including all inherited members.

CXTPResizePoint() | CXTPResizePoint
CXTPResizePoint(XTP_RESIZE cx, XTP_RESIZE cy) | CXTPResizePoint
x | XTP_RESIZEPOINT
y | XTP_RESIZEPOINT


Toolkit Pro: Member List

CXTPComboBoxThemeVisualStudio Member List

This is the complete list of members for CXTPComboBoxThemeVisualStudio, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPComboBoxTheme() | CXTPComboBoxTheme |
CXTPComboBoxThemeOffice2003() | CXTPComboBoxThemeOffice2003 |
CXTPComboBoxThemeVisualStudio() | CXTPComboBoxThemeVisualStudio |
CXTPControlTheme() | CXTPControlTheme |
DrawBackground(CDC *pDC, CXTPComboBox *pComboBox) | CXTPComboBoxThemeOffice2003 | virtual
DrawButton(CDC *pDC, CXTPComboBox *pComboBox, CRect rcBtn) | CXTPComboBoxThemeOffice2003 | virtual
DrawButtonTriangle(CDC *pDC, CXTPComboBox *pComboBox, CRect rcBtn) | CXTPComboBoxTheme | virtual
DrawComboBox(CDC *pDC, CXTPComboBox *pComboBox) | CXTPComboBoxTheme | virtual
DrawFrame(HDC hdc, LPRECT lprc, int nSize, HBRUSH hBrush) | CXTPComboBoxTheme | virtual
FillSolidRect(HDC hdc, int x, int y, int cx, int cy, HBRUSH hBrush) | CXTPComboBoxTheme | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetBackColor() const | CXTPComboBoxTheme |
GetBackgroundBrush() const | CXTPComboBoxTheme |
GetTextColor() const | CXTPComboBoxTheme |
GetThemeStyle() const | CXTPControlTheme |
m_clrBackDisabled | CXTPComboBoxTheme |
m_clrBackground | CXTPComboBoxTheme |
m_clrBackHighlight | CXTPComboBoxTheme |
m_clrBorderDisabled | CXTPComboBoxTheme |
m_clrBorderHot | CXTPComboBoxTheme |
m_clrBorderNormal | CXTPComboBoxTheme |
m_clrButtonArrowHot | CXTPComboBoxTheme |
m_clrButtonArrowNormal | CXTPComboBoxTheme |
m_clrButtonArrowPressed | CXTPComboBoxTheme |
m_clrButtonHot | CXTPComboBoxTheme |
m_clrButtonNormal | CXTPComboBoxTheme |
m_clrButtonPressed | CXTPComboBoxTheme |
m_clrText | CXTPComboBoxTheme |
m_clrTextDisabled | CXTPComboBoxTheme |
m_clrTextHighlight | CXTPComboBoxTheme |
m_grcButton | CXTPComboBoxTheme |
m_grcButtonHilite | CXTPComboBoxTheme |
m_grcButtonPushed | CXTPComboBoxTheme |
m_nTheme | CXTPControlTheme | protected
m_nThumbWidth | CXTPComboBoxTheme | protected
m_themeComboBox | CXTPComboBoxTheme | protected
m_xtpBrushBackground | CXTPComboBoxTheme | protected
RefreshMetrics(CXTPComboBox *pComboBox) | CXTPComboBoxThemeVisualStudio | virtual
ResetBackColor() | CXTPComboBoxTheme |
ResetTextColor() | CXTPComboBoxTheme |
SetBackColor(COLORREF clrBackground) | CXTPComboBoxTheme |
SetTextColor(COLORREF clrText) | CXTPComboBoxTheme |
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static
UpdateBackgroundBrush() | CXTPComboBoxTheme | protected
~CXTPComboBoxTheme() | CXTPComboBoxTheme | virtual
~CXTPComboBoxThemeOffice2003() | CXTPComboBoxThemeOffice2003 | virtual
~CXTPComboBoxThemeVisualStudio() | CXTPComboBoxThemeVisualStudio | virtual


Toolkit Pro: Member List

CXTPPropertyGridOffice2007Theme Member List

This is the complete list of members for CXTPPropertyGridOffice2007Theme, including all inherited members.

AdjustItemCaptionRect(CXTPPropertyGridItem *pItem, CRect &rcCaption) | CXTPPropertyGridPaintManager | virtual
AdjustItemValueRect(CXTPPropertyGridItem *pItem, CRect &rcValue) | CXTPPropertyGridPaintManager | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPPropertyGridOffice2003Theme(CXTPPropertyGrid *pGrid) | CXTPPropertyGridOffice2003Theme |
CXTPPropertyGridOffice2007Theme(CXTPPropertyGrid *pGrid) | CXTPPropertyGridOffice2007Theme |
CXTPPropertyGridPaintManager(CXTPPropertyGrid *pGrid) | CXTPPropertyGridPaintManager |
DrawCategoryCaptionBackground(CDC *pDC, CXTPPropertyGridItem *pItem, CRect rc) | CXTPPropertyGridPaintManager | virtual
DrawCheckBox(CDC *pDC, CXTPPropertyGridItemBool *pButton) | CXTPPropertyGridPaintManager | virtual
DrawCheckMark(CDC *pDC, CRect rc, BOOL bEnabled, BOOL bChecked) | CXTPPropertyGridOffice2007Theme | protectedvirtual
DrawExpandButton(CDC &dc, CXTPPropertyGridItem *pItem, CRect rcCaption) | CXTPPropertyGridOffice2007Theme | protectedvirtual
DrawInplaceButtons(CDC *pDC, PDRAWITEMSTRUCT lpDrawItemStruct, CXTPPropertyGridItem *pItem, CRect rcValue) | CXTPPropertyGridPaintManager | virtual
DrawInplaceListItem(CDC *pDC, CXTPPropertyGridItemConstraint *pConstraint, CRect rc, BOOL bSelected) | CXTPPropertyGridPaintManager | virtual
DrawItem(PDRAWITEMSTRUCT lpDrawItemStruct) | CXTPPropertyGridPaintManager | virtual
DrawItemCaption(CDC *pDC, CXTPPropertyGridItem *pItem, CRect rcCaption) | CXTPPropertyGridPaintManager | virtual
DrawItemValue(CDC *pDC, CXTPPropertyGridItem *pItem, CRect rcValue) | CXTPPropertyGridPaintManager | virtual
DrawPropertyGridBorder(CDC *pDC, RECT &rcBorder, XTPPropertyGridWindow nWindow) | CXTPPropertyGridPaintManager | virtual
DrawRadioMark(CDC *pDC, CRect rc, BOOL bEnabled, BOOL bChecked) | CXTPPropertyGridOffice2007Theme | protectedvirtual
FillInplaceButton(CDC *pDC, CXTPPropertyGridInplaceButton *pButton) | CXTPPropertyGridOffice2007Theme | protectedvirtual
FillPropertyGrid(CDC *pDC) | CXTPPropertyGridPaintManager | virtual
FillPropertyGridView(CDC *pDC) | CXTPPropertyGridPaintManager | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetItemBackColor(CXTPPropertyGridItem *pItem, BOOL bValuePart) | CXTPPropertyGridPaintManager | virtual
GetItemFont(CXTPPropertyGridItem *pItem, BOOL bValuePart) | CXTPPropertyGridPaintManager | virtual
GetItemMetrics() const | CXTPPropertyGridPaintManager |
GetItemsBorderHeight() const | CXTPPropertyGridPaintManager | virtual
GetItemTextColor(CXTPPropertyGridItem *pItem, BOOL bValuePart) | CXTPPropertyGridPaintManager | virtual
GetScrollBarTheme() const | CXTPPropertyGridOffice2007Theme | protectedvirtual
GetSplitterRect(CRect rc, BOOL bIsHelp) | CXTPPropertyGridPaintManager |
HitTestVerbs(CDC *pDC, CRect rcVerbs, CPoint pt) | CXTPPropertyGridPaintManager |
m_bLunaTheme | CXTPPropertyGridOffice2003Theme | protected
m_bThinSplitter | CXTPPropertyGridPaintManager | protected
m_bTransparent | CXTPPropertyGridPaintManager |
m_buttonsStyle | CXTPPropertyGridPaintManager |
m_clrCategorySeparator | CXTPPropertyGridPaintManager |
m_clrFace | CXTPPropertyGridPaintManager |
m_clrHighlight | CXTPPropertyGridPaintManager |
m_clrHighlightText | CXTPPropertyGridPaintManager |
m_clrNonHighlightBack | CXTPPropertyGridPaintManager |
m_clrNonHighlightText | CXTPPropertyGridPaintManager |
m_clrShadow | CXTPPropertyGridPaintManager |
m_clrSplitter | CXTPPropertyGridPaintManager |
m_nHelpHeight | CXTPPropertyGridPaintManager | protected
m_nItemsBorderHeight | CXTPPropertyGridPaintManager | protected
m_nSplitterHeight | CXTPPropertyGridPaintManager | protected
m_nVerbsHeight | CXTPPropertyGridPaintManager | protected
m_pGrid | CXTPPropertyGridPaintManager | protected
m_pMetrics | CXTPPropertyGridPaintManager | protected
m_themeButton | CXTPPropertyGridPaintManager |
m_themeCombo | CXTPPropertyGridPaintManager |
m_themeTree | CXTPPropertyGridPaintManager |
MeasureItem(LPMEASUREITEMSTRUCT lpMeasureItemStruct) | CXTPPropertyGridPaintManager | virtual
OnNcCalcSize(RECT &rc) | CXTPPropertyGridPaintManager | virtual
RefreshMetrics() | CXTPPropertyGridOffice2007Theme | virtual
SetItemsBorderHeight(int nHeight) | CXTPPropertyGridPaintManager | virtual
SetThinSplitter(BOOL bThinSplitter) | CXTPPropertyGridPaintManager | virtual
~CXTPPropertyGridPaintManager() | CXTPPropertyGridPaintManager | virtual


Toolkit Pro: Member List

  • CXTPSimpleCriticalSection
  • CLock
CXTPSimpleCriticalSection::CLock Member List

This is the complete list of members for CXTPSimpleCriticalSection::CLock, including all inherited members.

CLock(CXTPSimpleCriticalSection &cs) | CXTPSimpleCriticalSection::CLock | inlineexplicit
~CLock() | CXTPSimpleCriticalSection::CLock | inline


Toolkit Pro: Member List

CXTPCommandBarsVisualStudio2015Theme Member List

This is the complete list of members for CXTPCommandBarsVisualStudio2015Theme, including all inherited members.

AdjustExcludeRect(CRect &rc, CXTPControl *pControl, BOOL bVertical) | CXTPCommandBarsOfficeXPTheme | virtual
Animate(CDC *pDestDC, CDC *pSrcDC, CRect rc, XTPAnimationType animationType) | CXTPPaintManager | virtual
AnimateExpanding(CXTPCommandBar *pCommandBar, CDC *pDestDC, CDC *pSrcDC, BOOL bExpandDown) | CXTPPaintManager | virtual
BaseTheme() | CXTPCommandBarsOffice2013Theme | virtual
CreateTheme(XTPPaintTheme paintTheme) | CXTPPaintManager | static
CXTPCmdTarget() | CXTPCmdTarget |
CXTPCommandBarsModernUITheme() | CXTPCommandBarsModernUITheme |
CXTPCommandBarsOffice2013Theme() | CXTPCommandBarsOffice2013Theme |
CXTPCommandBarsOfficeXPTheme() | CXTPCommandBarsOfficeXPTheme |
CXTPCommandBarsVisualStudio2015Theme() | CXTPCommandBarsVisualStudio2015Theme |
CXTPObservable() | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | protected
CXTPPaintManager() | CXTPPaintManager | protected
Draw3dRect(CDC *pDC, LPCRECT rc, int nTopLeft, int nBottomRight) | CXTPPaintManager |
Draw3dRect(CDC *pDC, LPCRECT rc, int frameThickness, COLORREF clrPen, COLORREF clrBrush) | CXTPPaintManager |
CXTPPaintManager::DrawCheckMark(CDC *pDC, CRect rcCheck, COLORREF clr=0) | CXTPPaintManager | inline
DrawCheckRect(CDC *pDC, CRect rc, COLORREF clrFore, COLORREF clrBack) | CXTPCommandBarsVisualStudio2015Theme | protectedvirtual
DrawComboExpandMark(CDC *pDC, CRect rc, COLORREF clr) | CXTPPaintManager | virtual
DrawCommandBarGripper(CDC *pDC, CXTPCommandBar *pBar, BOOL bDraw=TRUE) | CXTPCommandBarsVisualStudio2015Theme | protectedvirtual
DrawCommandBarGroupSeparator(CDC *pDC, CXTPCommandBar *pBar, CXTPControl *pLeftControl, CXTPControl *pRightControl, BOOL bDraw) | CXTPCommandBarsOffice2013Theme | virtual
DrawCommandBarSeparator(CDC *pDC, CXTPCommandBar *pBar, CXTPControl *pControl, BOOL bDraw=TRUE) | CXTPCommandBarsOffice2013Theme | protectedvirtual
DrawControl(CDC *pDC, CXTPControl *pButton, BOOL bDraw=TRUE) | CXTPPaintManager |
DrawControlCheckBoxMark(CDC *pDC, CXTPControl *pButton, CRect rc, BOOL bDraw) | CXTPCommandBarsOffice2013Theme | protectedvirtual
DrawControlCheckBoxMark(CDC *pDC, CRect rc, BOOL bDraw, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled) | CXTPCommandBarsOffice2013Theme | protectedvirtual
DrawControlComboBox(CDC *pDC, CXTPControlComboBox *pComboBox, BOOL bDraw) | CXTPCommandBarsVisualStudio2015Theme | protectedvirtual
DrawControlEdit(CDC *pDC, CXTPControlEdit *pEdit, BOOL bDraw) | CXTPCommandBarsOffice2013Theme | virtual
DrawControlEntry(CDC *pDC, CXTPControl *pButton) | CXTPPaintManager | virtual
DrawControlMDIButton(CDC *pDC, CXTPControlButton *pButton) | CXTPCommandBarsOffice2013Theme | protectedvirtual
DrawControlPopupParent(CDC *pDC, CXTPControl *pButton, BOOL bDraw) | CXTPCommandBarsOfficeXPTheme | protectedvirtual
DrawControlRadioButtonMark(CDC *pDC, CRect rc, BOOL bDraw, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled) | CXTPCommandBarsOffice2013Theme | protectedvirtual
DrawControlText(CDC *pDC, CXTPControl *pControl, CRect rcText, BOOL bDraw, BOOL bVert, BOOL bCentered, BOOL bTriangled) | CXTPPaintManager |
DrawControlToolBarParent(CDC *pDC, CXTPControl *pButton, BOOL bDraw) | CXTPPaintManager | virtual
DrawDialogBarGripper(CDC *pDC, CXTPDialogBar *pBar, BOOL bDraw) | CXTPCommandBarsOfficeXPTheme | virtual
DrawDropDownGlyph(CDC *pDC, CXTPControl *pControl, CPoint pt, BOOL bSelected, BOOL bPopuped, BOOL bEnabled, BOOL bVert) | CXTPCommandBarsOffice2013Theme | protectedvirtual
DrawExpandGlyph(CDC *pDC, CXTPControl *pButton, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clr) | CXTPCommandBarsOffice2013Theme | protectedvirtual
DrawExpandGlyph(CDC *pDC, CXTPControl *pButton, COLORREF clr, BOOL bVertical) | CXTPCommandBarsOffice2013Theme | protectedvirtual
DrawFrameBorder(CDC *pDC, CRect rc, int nBorderThickness, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition) | CXTPCommandBarsOffice2013Theme | protected
DrawGalleryItemBack(CDC *pDC, CRect rcItem, BOOL bEnabled, BOOL bSelected, BOOL bPressed, BOOL bChecked, XTPBarType barType) | CXTPCommandBarsVisualStudio2015Theme | protectedvirtual
DrawHiddenGlyph(CDC *pDC, CXTPControl *pButton, COLORREF clr, BOOL bVertical) | CXTPCommandBarsOffice2013Theme | protectedvirtual
DrawImage(CDC *pDC, CPoint pt, CSize sz, CXTPImageManagerIcon *pImage, BOOL bSelected, BOOL bPressed, BOOL bEnabled=TRUE, BOOL bChecked=FALSE, BOOL bPopuped=FALSE, BOOL bToolBarImage=TRUE) | CXTPCommandBarsOfficeXPTheme | protectedvirtual
DrawListBoxControl(CDC *pDC, CXTPControl *pButton, CRect rc, BOOL bSelected, BOOL bDraw, CXTPCommandBars *pCommandBars=0) | CXTPCommandBarsOfficeXPTheme | virtual
DrawPopupBarCheckMark(CDC *pDC, CRect rcCheck, BOOL bEnabled, COLORREF clr) | CXTPPaintManager | virtual
DrawPopupBarGripper(CDC *pDC, int xPos, int yPos, int cx, int cy, BOOL bExpanded=FALSE) | CXTPCommandBarsOffice2013Theme | protectedvirtual
DrawPopupBarRadioMark(CDC *pDC, CRect rcCheck, BOOL bEnabled, COLORREF clr) | CXTPPaintManager | virtual
DrawPopupResizeGripper(CDC *pDC, CRect rcGripper, int nFlags) | CXTPCommandBarsOfficeXPTheme | virtual
DrawRectangle(CDC *pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition) | CXTPCommandBarsVisualStudio2015Theme | protectedvirtual
DrawRectangle(CDC *pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition, int nID) | CXTPCommandBarsVisualStudio2015Theme | protectedvirtual
DrawRectangle(CDC *pDC, CXTPControl *pButton) | CXTPCommandBarsVisualStudio2015Theme | protectedvirtual
DrawSpecialControl(CDC *pDC, XTPSpecialControl controlType, CXTPControl *pButton, CXTPCommandBar *pBar, BOOL bDraw, LPVOID lpParam) | CXTPPaintManager | virtual
DrawSplitButtonFrame(CDC *pDC, CXTPControl *pButton, CRect rc) | CXTPCommandBarsVisualStudio2015Theme | protectedvirtual
DrawTearOffGripper(CDC *pDC, CRect rcGripper, BOOL bSelected, BOOL bDraw) | CXTPCommandBarsOfficeXPTheme | virtual
FillCommandBarEntry(CDC *pDC, CXTPCommandBar *pBar) | CXTPCommandBarsOffice2013Theme | virtual
FillDockBar(CDC *pDC, CXTPDockBar *pBar) | CXTPCommandBarsOffice2013Theme | virtual
FillIntersectRect(CDC *pDC, CXTPPopupBar *pPopupBar, COLORREF clr) | CXTPCommandBarsOfficeXPTheme | protected
FillWorkspace(CDC *pDC, CRect rc, CRect rcExclude) | CXTPCommandBarsOffice2013Theme | virtual
FontExists(LPCTSTR lpszFaceName) | CXTPPaintManager | static
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCommandBarBorders(CXTPCommandBar *pBar) | CXTPPaintManager | virtual
GetCommandBarFont(CXTPCommandBar *pCommandBar) | CXTPPaintManager | virtual
GetControlBackColor(CXTPControl *pButton) | CXTPCommandBarsOffice2013Theme | protectedvirtual
GetControlEditBackColor(CXTPControl *pControl) | CXTPCommandBarsOffice2013Theme | virtual
GetControlFont(CXTPControl *pControl) | CXTPPaintManager | virtual
GetControlHeight() const | CXTPPaintManager |
GetControlTextColor(CXTPControl *pButton) | CXTPCommandBarsVisualStudio2015Theme | protectedvirtual
GetControlTextOrientation(CXTPControl *pControl) | CXTPPaintManager | virtual
GetCurrentSystemTheme() | CXTPPaintManager |
GetCurrentTheme() | CXTPPaintManager | inline
GetDefaultCommandBarSize(CXTPCommandBar *pBar) | CXTPPaintManager | virtual
GetFramePaintManager() | CXTPCommandBarsModernUITheme | virtual
GetGalleryPaintManager() const | CXTPPaintManager | virtual
GetGlobalPaintManager() | CXTPPaintManager | static
GetIconFont() | CXTPPaintManager |
GetIconsInfo() | CXTPPaintManager |
GetInstanceAddRef() | CXTPPaintManager | static
GetMarkupContext() | CXTPCommandBarsModernUITheme | virtual
GetMessageBarPaintManager() | CXTPPaintManager | virtual
GetPopupBarGripperWidth(CXTPCommandBar *pBar) | CXTPPaintManager | virtual
GetProgressPaintManager() const | CXTPPaintManager | virtual
GetRectangleTextColor(BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition) | CXTPCommandBarsOffice2013Theme | protectedvirtual
GetRegularBoldFont() | CXTPPaintManager |
GetRegularFont() | CXTPPaintManager |
GetRibbonPaintManager() | CXTPCommandBarsModernUITheme | virtual
GetScrollBarPaintManager() const | CXTPPaintManager | virtual
GetShadowManager() const | CXTPPaintManager |
GetShadowOptions() const | CXTPPaintManager |
GetSliderPaintManager() const | CXTPPaintManager | virtual
GetSmCaptionFont() | CXTPPaintManager |
GetSplitButtonCommandRect(CXTPControl *pButton) | CXTPPaintManager | virtual
GetStateColor() const | CXTPCommandBarsVisualStudio2015Theme | virtual
GetStatusBarPaintManager() | CXTPPaintManager | virtual
GetXtremeColor(UINT nIndex) | CXTPPaintManager |
GradientFill(CDC *pDC, LPRECT lpRect, COLORREF crFrom, COLORREF crTo, BOOL bHorz, LPCRECT lpRectClip=NULL) | CXTPPaintManager |
HorizontalLine(CDC *pDC, int x0, int y0, int x1, COLORREF clrPen) | CXTPPaintManager |
IsUseSystemAccentColorEnabled() const | CXTPPaintManager |
Line(CDC *pDC, CPoint p0, CPoint p1) | CXTPPaintManager |
Line(CDC *pDC, int x0, int y0, int x1, int y1, const int nPen) | CXTPPaintManager |
Line(CDC *pDC, int x0, int y0, int x1, int y1, COLORREF clrPen) | CXTPPaintManager |
m_arrColor | CXTPPaintManager | protected
m_bAutoResizeIcons | CXTPPaintManager |
m_bClearTypeTextQuality | CXTPPaintManager |
m_bEmbossedDisabledText | CXTPPaintManager | protected
m_bEnableAnimation | CXTPPaintManager |
m_bFlatMenuBar | CXTPPaintManager |
m_bFlatToolBar | CXTPPaintManager |
m_bIntersect | CXTPCommandBarsOffice2013Theme | protected
m_bOffice2007Padding | CXTPPaintManager |
m_bOffsetPopupLabelText | CXTPPaintManager |
m_bSelectImageInPopupBar | CXTPPaintManager |
m_bShowKeyboardCues | CXTPPaintManager | protected
m_bShowShadow | CXTPPaintManager |
m_bThemedCheckBox | CXTPPaintManager |
m_bThemedStatusBar | CXTPPaintManager |
m_bThickCheckMark | CXTPPaintManager |
m_bUseOfficeFont | CXTPPaintManager |
m_bUseStandardFont | CXTPPaintManager | protected
m_bWrapCaptionBelowText | CXTPPaintManager |
m_clr3DShadow | CXTPCommandBarsOffice2013Theme | protected
m_clrBack | CXTPCommandBarsOffice2013Theme | protected
m_clrBtnFace | CXTPCommandBarsOffice2013Theme | protected
m_clrCaptionButtonFill | CXTPCommandBarsOffice2013Theme | protected
m_clrDisabledIcon | CXTPPaintManager |
m_clrFloatingGripper | CXTPPaintManager |
m_clrFloatingGripperText | CXTPPaintManager |
m_clrGlyph | CXTPCommandBarsOffice2013Theme | protected
m_clrGlyphDisabled | CXTPCommandBarsOffice2013Theme | protected
m_clrGlyphHighlight | CXTPCommandBarsOffice2013Theme | protected
m_clrGlyphPushed | CXTPCommandBarsOffice2013Theme | protected
m_clrHighlight | CXTPCommandBarsOffice2013Theme | protected
m_clrMessageBarText | CXTPCommandBarsOffice2013Theme | protected
m_clrWorkspace | CXTPCommandBarsOffice2013Theme | protected
m_csCheckBox | CXTPCommandBarsOffice2013Theme | protected
m_csCheckMark | CXTPCommandBarsOffice2013Theme | protected
m_csComboBox | CXTPCommandBarsOffice2013Theme | protected
m_csMenu | CXTPCommandBarsOffice2013Theme | protected
m_csMenuTitleBar | CXTPCommandBarsOffice2013Theme | protected
m_csRibbon | CXTPCommandBarsOffice2013Theme | protected
m_csToolbar | CXTPCommandBarsOffice2013Theme | protected
m_fontIcon | CXTPPaintManager |
m_fontIconBold | CXTPPaintManager |
m_fontSmCaption | CXTPPaintManager |
m_fontToolTip | CXTPPaintManager |
m_iconsInfo | CXTPPaintManager | protected
m_nAnimationSteps | CXTPPaintManager | protected
m_nAnimationTime | CXTPPaintManager | protected
m_nEditHeight | CXTPPaintManager | protected
m_nFontHeight | CXTPPaintManager | protected
m_nPopupBarTextPadding | CXTPPaintManager |
m_nSplitButtonDropDownHeight | CXTPPaintManager |
m_nSplitButtonDropDownWidth | CXTPPaintManager |
m_nSplitButtonPopupWidth | CXTPPaintManager |
m_nStatusBarMinHeight | CXTPPaintManager |
m_nTextHeight | CXTPPaintManager |
m_pfnSetLayeredWindowAttributes | CXTPPaintManager |
m_pFramePaintManager | CXTPPaintManager |
m_pGalleryPaintManager | CXTPPaintManager |
m_pImages | CXTPCommandBarsModernUITheme | protected
m_pMarkupContext | CXTPCommandBarsModernUITheme | protected
m_pProgressPaintManager | CXTPPaintManager |
m_pRibbonPaintManager | CXTPPaintManager |
m_pScrollBarPaintManager | CXTPPaintManager |
m_pShadowManager | CXTPPaintManager | protected
m_pSliderPaintManager | CXTPPaintManager |
m_pStatusBarPaintManager | CXTPPaintManager |
m_rcMessageBarMargin | CXTPPaintManager |
m_rcStatusBarBorder | CXTPPaintManager |
m_strOfficeFont | CXTPPaintManager |
m_systemTheme | CXTPPaintManager | protected
m_themeButton | CXTPPaintManager | protected
m_themeCurrent | CXTPPaintManager | protected
m_themeStatusBar | CXTPPaintManager | protected
m_xtpFontRegular | CXTPPaintManager | protected
m_xtpFontRegularBold | CXTPPaintManager | protected
m_xtpFontVert | CXTPPaintManager | protected
m_xtpFontVertBold | CXTPPaintManager | protected
Notify(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *)) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
Notify(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1), A1 arg1) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
Notify(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
Notify(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamic(void(T::*method)(O *)) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1), A1 arg1) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *)) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1), A1 arg1) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyReversed(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *)) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyReversed(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1), A1 arg1) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyReversed(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyReversed(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
Pixel(CDC *pDC, int xPos, int yPos, int nPen) | CXTPPaintManager |
Rectangle(CDC *pDC, LPCRECT rc, int nPen, const int nBrush) | CXTPPaintManager |
Rectangle(CDC *pDC, LPCRECT rc, COLORREF clrPen, COLORREF clrBrush) | CXTPPaintManager |
RefreshMetrics() | CXTPCommandBarsOffice2013Theme | protectedvirtual
RefreshStandardColors() | CXTPCommandBarsOffice2013Theme | protectedvirtual
ReleaseInstance() | CXTPPaintManager | static
RequiresResourceImages() | CXTPCommandBarsOffice2013Theme | virtual
RoundRect(CDC *pDC, LPCRECT rc, COLORREF clrPen, COLORREF clrBrush) | CXTPPaintManager |
SetAnimationDelay(int nAnimationSteps, int nAnimationTime) | CXTPPaintManager |
SetColors(int cElements, CONST INT *lpaElements, CONST COLORREF *lpaRgbValues) | CXTPPaintManager |
SetCommandBarRegion(CXTPCommandBar *pCommandBar) | CXTPPaintManager | virtual
SetCommandBarsFontIndirect(LOGFONT *pLogFont, BOOL bUseStandardFont=FALSE) | CXTPPaintManager |
SetCustomTheme(CXTPPaintManager *pTheme) | CXTPPaintManager | static
SetGlobalPaintManager(CXTPPaintManager *pPaintManager) | CXTPPaintManager | static
SetImageHandle(HMODULE hResource, LPCTSTR lpszIniFileName) | CXTPPaintManager | virtual
SetLunaTheme(XTPCurrentSystemTheme systemTheme) | CXTPPaintManager |
SetStateColor(COLORREF clrState=COLORREF_NULL) | CXTPCommandBarsVisualStudio2015Theme | virtual
SetTheme(XTPPaintTheme paintTheme) | CXTPPaintManager | static
StripMnemonics(CString &strClear) | CXTPPaintManager | static
Subscribe(IXTPPaintManagerEvents *pObserver, CXTPSubscriptionList< CXTPPaintManager, IXTPPaintManagerEvents > *pSubcriptionList=NULL) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > |
Triangle(CDC *pDC, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clr) | CXTPPaintManager | static
Unsubscribe(IXTPPaintManagerEvents *pObserver) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > |
UpdateColors() | CXTPPaintManager | virtual
UpdateFonts() | CXTPPaintManager | virtual
UpdateRTLCaption(CString &strCaption) | CXTPPaintManager | virtual
UseOfficeFont(bool bUseOfficeFont) | CXTPPaintManager |
VerticalLine(CDC *pDC, int x0, int y0, int y1, COLORREF clrPen) | CXTPPaintManager |
~CXTPCommandBarsModernUITheme() | CXTPCommandBarsModernUITheme | virtual
~CXTPCommandBarsOffice2013Theme() | CXTPCommandBarsOffice2013Theme | virtual
~CXTPCommandBarsVisualStudio2015Theme() | CXTPCommandBarsVisualStudio2015Theme | virtual
~CXTPObservable() | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | protected
~CXTPPaintManager() | CXTPPaintManager | protectedvirtual


Toolkit Pro: Member List

CXTPDockingPanePaintManager Member List

This is the complete list of members for CXTPDockingPanePaintManager, including all inherited members.

AdjustCaptionRect(const CXTPDockingPaneSidePanel *pPane, CRect &rc) | CXTPDockingPanePaintManager | virtual
AdjustCaptionRect(const CXTPDockingPaneTabbedContainer *pPane, CRect &rc) | CXTPDockingPanePaintManager | virtual
AdjustClientRect(CXTPDockingPaneSidePanel *pPane, CRect &rect) | CXTPDockingPanePaintManager | virtual
AdjustClientRect(CXTPDockingPaneTabbedContainer *pPane, CRect &rect, BOOL bApply) | CXTPDockingPanePaintManager | virtual
ClipAndAddEllipsisIfNeeded(CDC *pDC, CString &strTitle, int nCaptionWidth) const | CXTPDockingPanePaintManager | protected
CXTPCmdTarget() | CXTPCmdTarget |
CXTPDockingPanePaintManager() | CXTPDockingPanePaintManager | protected
DrawAutoHidePanel(CDC *pDC, CRect rc, XTPDockingPaneDirection direction) | CXTPDockingPanePaintManager | virtual
DrawCaption(CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc)=0 | CXTPDockingPanePaintManager | pure virtual
DrawCaptionButton(CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton) | CXTPDockingPanePaintManager | virtual
DrawCaptionButtonEntry(CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton, CSize szOffset) | CXTPDockingPanePaintManager | protectedvirtual
DrawCaptionButtonEntry(CDC *pDC, CXTPDockingPaneCaptionButton *pButton, CPoint pt, COLORREF clrButton) | CXTPDockingPanePaintManager | protectedvirtual
DrawCaptionButtons(CDC *pDC, CXTPDockingPaneCaptionButtons *pButtons, CRect &rcCaption, COLORREF clr, int nButtonSize, int nButtonGap, BOOL bVertical=FALSE) | CXTPDockingPanePaintManager | virtual
DrawCaptionText(CDC *pDC, const CString &strTitle, CRect rc, BOOL bVertical, BOOL bCalcWidth=FALSE) | CXTPDockingPanePaintManager |
DrawFloatingFrame(CDC *pDC, CXTPDockingPaneMiniWnd *pPane, CRect rc) | CXTPDockingPanePaintManager | virtual
DrawPane(CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc) | CXTPDockingPanePaintManager | virtual
DrawSidePanel(CDC *pDC, CXTPDockingPaneSidePanel *pPane, CRect rc) | CXTPDockingPanePaintManager | virtual
DrawSplitter(CDC *pDC, CXTPDockingPaneSplitterWnd *pSplitter) | CXTPDockingPanePaintManager | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCaptionButtonStyle() const | CXTPDockingPanePaintManager |
GetCaptionGripperRect(const CXTPDockingPaneTabbedContainer *pPane) | CXTPDockingPanePaintManager | virtual
GetCaptionHeight() const | CXTPDockingPanePaintManager |
GetCaptionRect(const CXTPDockingPaneTabbedContainer *pPane, CRect &rc) | CXTPDockingPanePaintManager | virtual
GetCurrentSystemTheme() const | CXTPDockingPanePaintManager |
GetCustomTitleBrush(BOOL bActive, BOOL bVertical) const | CXTPDockingPanePaintManager |
GetPaneCaptionRect(const CXTPDockingPaneSidePanel *pPane) | CXTPDockingPanePaintManager | virtual
GetPanelPaintManager() const | CXTPDockingPanePaintManager |
GetSplitterStyle() const | CXTPDockingPanePaintManager |
GetTabPaintManager() const | CXTPDockingPanePaintManager |
GetTabsHeight() const | CXTPDockingPanePaintManager |
GetXtremeColor(UINT nIndex) | CXTPDockingPanePaintManager |
Line(CDC *pDC, int x0, int y0, int x1, int y1, int nPen) | CXTPDockingPanePaintManager |
Line(CDC *pDC, int x0, int y0, int x1, int y1) | CXTPDockingPanePaintManager |
m_arrColor | CXTPDockingPanePaintManager | protected
m_bDestroyCustomTitleBrushes | CXTPDockingPanePaintManager | protected
m_bDrawCaptionIcon | CXTPDockingPanePaintManager |
m_bDrawSingleTab | CXTPDockingPanePaintManager |
m_bHighlightActiveCaption | CXTPDockingPanePaintManager |
m_bLunaTheme | CXTPDockingPanePaintManager | protected
m_bShowCaption | CXTPDockingPanePaintManager |
m_bUseBoldCaptionFont | CXTPDockingPanePaintManager |
m_bUseOfficeFont | CXTPDockingPanePaintManager | protected
m_bUseStandardFont | CXTPDockingPanePaintManager | protected
m_clrActiveCaption | CXTPDockingPanePaintManager |
m_clrActiveCaptionText | CXTPDockingPanePaintManager |
m_clrBackground | CXTPDockingPanePaintManager |
m_clrDisabledCaptionText | CXTPDockingPanePaintManager |
m_clrNormalCaption | CXTPDockingPanePaintManager |
m_clrNormalCaptionText | CXTPDockingPanePaintManager |
m_clrSplitter | CXTPDockingPanePaintManager |
m_clrSplitterGradient | CXTPDockingPanePaintManager |
m_clrSplitterGripper | CXTPDockingPanePaintManager |
m_dwSplitterStyle | CXTPDockingPanePaintManager | protected
m_hbrActiveTitleHorz | CXTPDockingPanePaintManager | protected
m_hbrActiveTitleVert | CXTPDockingPanePaintManager | protected
m_hbrInactiveTitleHorz | CXTPDockingPanePaintManager | protected
m_hbrInactiveTitleVert | CXTPDockingPanePaintManager | protected
m_nCaptionButtonStyle | CXTPDockingPanePaintManager | protected
m_nCaptionFontGap | CXTPDockingPanePaintManager | protected
m_nSplitterIndent | CXTPDockingPanePaintManager |
m_nSplitterSize | CXTPDockingPanePaintManager |
m_nTabsHeight | CXTPDockingPanePaintManager | protected
m_nTitleHeight | CXTPDockingPanePaintManager | protected
m_pPanelPaintManager | CXTPDockingPanePaintManager | protected
m_pTabPaintManager | CXTPDockingPanePaintManager | protected
m_rcCaptionMargin | CXTPDockingPanePaintManager | protected
m_strOfficeFont | CXTPDockingPanePaintManager | protected
m_systemTheme | CXTPDockingPanePaintManager | protected
m_themeButton | CXTPDockingPanePaintManager | protected
m_themeCurrent | CXTPDockingPanePaintManager | protected
m_themeExplorer | CXTPDockingPanePaintManager | protected
m_themeRebar | CXTPDockingPanePaintManager | protected
m_themeToolbar | CXTPDockingPanePaintManager | protected
m_themeWindow | CXTPDockingPanePaintManager | protected
m_xtpFontTitle | CXTPDockingPanePaintManager | protected
m_xtpFontTitleVertical | CXTPDockingPanePaintManager | protected
Pixel(CDC *pDC, int xPos, int yPos, int nPen) | CXTPDockingPanePaintManager |
Rectangle(CDC *pDC, CRect rc, int nPenEntry, int nPenBorder) | CXTPDockingPanePaintManager |
RefreshMetrics() | CXTPDockingPanePaintManager | virtual
SetCaptionButtonStyle(XTPDockingPaneCaptionButtonStyle nStyle) | CXTPDockingPanePaintManager |
SetCaptionFontIndirect(LOGFONT *pLogFont, BOOL bUseStandardFont=FALSE) | CXTPDockingPanePaintManager |
SetColors(int cElements, CONST INT *lpaElements, CONST COLORREF *lpaRgbValues) | CXTPDockingPanePaintManager |
SetCustomTitleBrushes(HBRUSH hbrActiveTitleHorz, HBRUSH hbrInactiveTitleHorz=NULL, HBRUSH hbrActiveTitleVert=NULL, HBRUSH hbrInactiveTitleVert=NULL, BOOL bDestroyOnCleanup=FALSE) | CXTPDockingPanePaintManager |
SetLunaTheme(XTPCurrentSystemTheme systemTheme) | CXTPDockingPanePaintManager |
SetPanelPaintManager(CXTPTabPaintManager *pManager) | CXTPDockingPanePaintManager |
SetSplitterStyle(DWORD dwStyle) | CXTPDockingPanePaintManager |
SetTabPaintManager(CXTPTabPaintManager *pManager) | CXTPDockingPanePaintManager |
UseOfficeFont(BOOL bUseOfficeFont) | CXTPDockingPanePaintManager |
~CXTPDockingPanePaintManager() | CXTPDockingPanePaintManager | protectedvirtual


Toolkit Pro: Member List

CXTPControlGalleryPaintManager Member List

This is the complete list of members for CXTPControlGalleryPaintManager, including all inherited members.

CXTPControlGalleryPaintManager(CXTPPaintManager *pPaintManager) | CXTPControlGalleryPaintManager |
DrawLabel(CDC *pDC, CXTPControlGalleryItem *pLabel, CRect rc) | CXTPControlGalleryPaintManager | virtual
DrawPopupScrollBar(CDC *pDC, CXTPControlGallery *pGallery) | CXTPControlGalleryPaintManager | virtual
FillControl(CDC *pDC, CXTPControlGallery *pGallery, CRect rc) | CXTPControlGalleryPaintManager | virtual
m_cxPopup | CXTPControlGalleryPaintManager |
m_cyPopupDown | CXTPControlGalleryPaintManager |
m_cyPopupUp | CXTPControlGalleryPaintManager |
RefreshMetrics() | CXTPControlGalleryPaintManager | virtual


Toolkit Pro: Member List

  • CXTPCalendarData
  • EventsMapByID_T
CXTPCalendarData::EventsMapByID_T< _TObject > Member List

This is the complete list of members for CXTPCalendarData::EventsMapByID_T< _TObject >, including all inherited members.

Add(DWORD dwID, _TObject *pObj) | CXTPCalendarData::EventsMapByID_T< _TObject > | inline
EventsMapByID_T(UINT uHashTableSize=XTP_OBJECT_CACHE_HASH_TABLE_SIZE) | CXTPCalendarData::EventsMapByID_T< _TObject > | inline
Get(DWORD dwID) | CXTPCalendarData::EventsMapByID_T< _TObject > | inline
GetCount() | CXTPCalendarData::EventsMapByID_T< _TObject > | inline
GetNextElement(POSITION &rPos, DWORD &rID) | CXTPCalendarData::EventsMapByID_T< _TObject > | inline
GetStartPosition() | CXTPCalendarData::EventsMapByID_T< _TObject > | inline
IsExist(DWORD dwID) | CXTPCalendarData::EventsMapByID_T< _TObject > | inline
m_mapID2Object | CXTPCalendarData::EventsMapByID_T< _TObject > | protected
Remove(DWORD dwID) | CXTPCalendarData::EventsMapByID_T< _TObject > | inline
RemoveAll() | CXTPCalendarData::EventsMapByID_T< _TObject > | inline
TObjPtr typedef | CXTPCalendarData::EventsMapByID_T< _TObject > | protected
~EventsMapByID_T() | CXTPCalendarData::EventsMapByID_T< _TObject > | inlinevirtual


Toolkit Pro: Member List

  • CXTPCheckListBox
  • CCheckListState
CXTPCheckListBox::CCheckListState Member List

This is the complete list of members for CXTPCheckListBox::CCheckListState, including all inherited members.

CCheckListState(BOOL bListBox3D) | CXTPCheckListBox::CCheckListState |
Draw(CDC *pDC, int nCheck, CPoint pt, CSize sz) | CXTPCheckListBox::CCheckListState |
m_sizeCheck | CXTPCheckListBox::CCheckListState |
m_sizeCheckThemed | CXTPCheckListBox::CCheckListState |
~CCheckListState() | CXTPCheckListBox::CCheckListState | virtual


Toolkit Pro: Member List

CXTPMathUtils Member List

This is the complete list of members for CXTPMathUtils, including all inherited members.

Compare(double value1, double value2) | CXTPMathUtils | static
Compare(double value1, double value2, double epsilon) | CXTPMathUtils | static
ComputeTriangleNormal(double x1, double y1, double z1, double x2, double y2, double z2, double x3, double y3, double z4, double &nx, double &ny, double &nz, bool normalize=true, bool ccw=false) | CXTPMathUtils | static
ComputeVectorCrossProduct(double x1, double y1, double z1, double x2, double y2, double z2, double &rx, double &ry, double &rz) | CXTPMathUtils | static
ComputeVectorDotProduct(double x1, double y1, double z1, double x2, double y2, double z2) | CXTPMathUtils | static
ComputeVectorLength(double x, double y, double z) | CXTPMathUtils | static
Degree2Radian(double angleDegree) | CXTPMathUtils | static
GetLinesIntersection(double x11, double y11, double x12, double y12, double x21, double y21, double x22, double y22, double &xi, double &yi) | CXTPMathUtils | static
GetNaN() | CXTPMathUtils | static
GetSegmentLength(double x1, double y1, double x2, double y2) | CXTPMathUtils | static
GetSegmentLength(double x1, double y1, double z1, double x2, double y2, double z2) | CXTPMathUtils | static
HitTestLineSegment(double x1, double y1, double x2, double y2, double xPoint, double yPoint, int nLineThickness) | CXTPMathUtils | static
IsNan(double x) | CXTPMathUtils | static
m_dEPS | CXTPMathUtils | static
m_dPI | CXTPMathUtils | static
NormalizeDegree(double angle) | CXTPMathUtils | static
NormalizeRadian(double angleRadian) | CXTPMathUtils | static
Radian2Degree(double angleRadian) | CXTPMathUtils | static
Round(double dValue) | CXTPMathUtils | static
Sign(double value) | CXTPMathUtils | static


Toolkit Pro: XTPDockingPaneCaptionButton.h Source File

  • Source
  • DockingPane
XTPDockingPaneCaptionButton.h
Go to the documentation of this file.
1
23#if !defined(__XTPDOCKINGPANECAPTIONBUTTON_H__)
24# define __XTPDOCKINGPANECAPTIONBUTTON_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
37class _XTP_EXT_CLASS CXTPDockingPaneCaptionButton
38{
39public:
46 CXTPDockingPaneCaptionButton(int nID, CXTPDockingPaneBase* pPane);
47
53 void SetRect(CRect rc);
54
65 static void AFX_CDECL DrawPinButton(CDC* pDC, CPoint pt, BOOL bPinned,
66 COLORREF clr = COLORREF_NULL);
67
78 static void AFX_CDECL DrawPinButton(CDC* pDC, CRect rc, BOOL bPinned,
79 COLORREF clr = COLORREF_NULL);
80
82 _XTP_DEPRECATED_IN_FAVOR(DrawPinButton)
83 static void AFX_CDECL DrawPinnButton(CDC* pDC, CPoint pt, BOOL bPinned,
84 COLORREF clr = COLORREF_NULL)
85 {
86 DrawPinButton(pDC, pt, bPinned, clr);
87 }
88
89 _XTP_DEPRECATED_IN_FAVOR(DrawPinButton)
90 static void AFX_CDECL DrawPinnButton(CDC* pDC, CRect rc, BOOL bPinned,
91 COLORREF clr = COLORREF_NULL)
92 {
93 DrawPinButton(pDC, rc, bPinned, clr);
94 }
95
109 static void AFX_CDECL DrawMaximizeRestoreButton(CDC* pDC, CPoint pt, BOOL bMaximize,
110 COLORREF clr = COLORREF_NULL);
111
123 static void AFX_CDECL DrawMaximizeRestoreButton(CDC* pDC, CRect rc, BOOL bMaximize,
124 COLORREF clr = COLORREF_NULL);
125
135 static void AFX_CDECL DrawCloseButton(CDC* pDC, CRect rc, COLORREF clr = COLORREF_NULL);
136
146 static void AFX_CDECL DrawMenuButton(CDC* pDC, CRect rc, COLORREF clr = COLORREF_NULL);
147
156 DWORD Click(CWnd* pWnd, CPoint pt, BOOL bClient = TRUE);
157
164 CRect GetRect() const;
165
176 DWORD GetState() const;
177
185 void SetState(DWORD dwState);
186
195 int GetID() const;
196
203 CXTPDockingPaneBase* GetPane() const;
204
212 BOOL PtInRect(POINT pt) const;
213
220 BOOL CheckForMouseOver(CPoint pt);
221
226 void InvalidateRect();
227
234 BOOL IsPressed() const;
235
244 BOOL IsSelected() const;
245
252 BOOL IsVisible() const;
253
260 BOOL IsEnabled() const;
261
262protected:
263 CRect m_rcButton;
264 CXTPDockingPaneBase* m_pPane;
265 int m_nID;
266 BOOL m_bPressed;
267 BOOL m_bSelected;
268 DWORD m_dwState;
270 friend class CXTPDockingPaneTabbedContainer;
271 friend class CXTPDockingPaneMiniWnd;
272
273private:
274 static COLORREF AFX_CDECL NormalizeButtonColor(CDC* pDC, COLORREF clr);
275};
276
277AFX_INLINE CRect CXTPDockingPaneCaptionButton::GetRect() const
278{
279 return m_rcButton;
280}
281
282AFX_INLINE DWORD CXTPDockingPaneCaptionButton::GetState() const
283{
284 return m_dwState;
285}
286
287AFX_INLINE void CXTPDockingPaneCaptionButton::SetState(DWORD dwState)
288{
289 m_dwState = dwState;
290}
291
292AFX_INLINE int CXTPDockingPaneCaptionButton::GetID() const
293{
294 return m_nID;
295}
296
297AFX_INLINE CXTPDockingPaneBase* CXTPDockingPaneCaptionButton::GetPane() const
298{
299 return m_pPane;
300}
301
302AFX_INLINE BOOL CXTPDockingPaneCaptionButton::PtInRect(POINT pt) const
303{
304 return m_rcButton.PtInRect(pt) != 0;
305}
306
307AFX_INLINE BOOL CXTPDockingPaneCaptionButton::IsPressed() const
308{
309 return m_bPressed;
310}
311
312AFX_INLINE BOOL CXTPDockingPaneCaptionButton::IsSelected() const
313{
314 return m_bSelected;
315}
316
317# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
319#endif // !defined(__XTPDOCKINGPANECAPTIONBUTTON_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPDockingPaneBase
CXTPDockingPaneBase is a standalone class.
Definition XTPDockingPaneBase.h:69
CXTPDockingPaneCaptionButton
CXTPDockingPaneCaptionButton is a standalone internal class.
Definition XTPDockingPaneCaptionButton.h:38
CXTPDockingPaneCaptionButton::IsVisible
BOOL IsVisible() const
Call this member to determine if the pin caption button is visible.
CXTPDockingPaneCaptionButton::GetState
DWORD GetState() const
Call this member to determine the state of the pin caption button.
Definition XTPDockingPaneCaptionButton.h:282
CXTPDockingPaneCaptionButton::InvalidateRect
void InvalidateRect()
Call this member to redraw the button.
CXTPDockingPaneCaptionButton::IsPressed
BOOL IsPressed() const
Call this member to determine if the pin caption button is pressed.
Definition XTPDockingPaneCaptionButton.h:307
CXTPDockingPaneCaptionButton::GetID
int GetID() const
Call this member to retrieve the button identifier.
Definition XTPDockingPaneCaptionButton.h:292
CXTPDockingPaneCaptionButton::Click
DWORD Click(CWnd *pWnd, CPoint pt, BOOL bClient=TRUE)
Call this method to click a button.
CXTPDockingPaneCaptionButton::DrawMaximizeRestoreButton
static void AFX_CDECL DrawMaximizeRestoreButton(CDC *pDC, CPoint pt, BOOL bMaximize, COLORREF clr=COLORREF_NULL)
Call this member to draw the Maximize/Restore button.
CXTPDockingPaneCaptionButton::m_bSelected
BOOL m_bSelected
TRUE if the mouse is hovering over the button.
Definition XTPDockingPaneCaptionButton.h:267
CXTPDockingPaneCaptionButton::IsSelected
BOOL IsSelected() const
Call this member to determine if the mouse is hovering over the pin caption button.
Definition XTPDockingPaneCaptionButton.h:312
CXTPDockingPaneCaptionButton::DrawPinButton
static void AFX_CDECL DrawPinButton(CDC *pDC, CRect rc, BOOL bPinned, COLORREF clr=COLORREF_NULL)
Call this member to draw the pin button.
CXTPDockingPaneCaptionButton::m_dwState
DWORD m_dwState
XTPDockingPanePinState of the pin caption button.
Definition XTPDockingPaneCaptionButton.h:268
CXTPDockingPaneCaptionButton::CXTPDockingPaneCaptionButton
CXTPDockingPaneCaptionButton(int nID, CXTPDockingPaneBase *pPane)
Constructs a CXTPDockingPaneCaptionButton object.
CXTPDockingPaneCaptionButton::GetPane
CXTPDockingPaneBase * GetPane() const
Call this member to retrieve the pane that the pin caption button controls.
Definition XTPDockingPaneCaptionButton.h:297
CXTPDockingPaneCaptionButton::DrawMenuButton
static void AFX_CDECL DrawMenuButton(CDC *pDC, CRect rc, COLORREF clr=COLORREF_NULL)
Call this member to draw the Menu button.
CXTPDockingPaneCaptionButton::SetRect
void SetRect(CRect rc)
Call this member to set the button's rectangle.
CXTPDockingPaneCaptionButton::m_pPane
CXTPDockingPaneBase * m_pPane
Parent pane.
Definition XTPDockingPaneCaptionButton.h:264
CXTPDockingPaneCaptionButton::SetState
void SetState(DWORD dwState)
Call this member to set the state for the pin caption button.
Definition XTPDockingPaneCaptionButton.h:287
CXTPDockingPaneCaptionButton::DrawPinButton
static void AFX_CDECL DrawPinButton(CDC *pDC, CPoint pt, BOOL bPinned, COLORREF clr=COLORREF_NULL)
Call this member to draw the pin button.
CXTPDockingPaneCaptionButton::m_rcButton
CRect m_rcButton
Bounding rectangle of the button.
Definition XTPDockingPaneCaptionButton.h:263
CXTPDockingPaneCaptionButton::m_bPressed
BOOL m_bPressed
TRUE if the button is pressed.
Definition XTPDockingPaneCaptionButton.h:266
CXTPDockingPaneCaptionButton::DrawCloseButton
static void AFX_CDECL DrawCloseButton(CDC *pDC, CRect rc, COLORREF clr=COLORREF_NULL)
Call this member to draw the Close button.
CXTPDockingPaneCaptionButton::GetRect
CRect GetRect() const
Call this member to get the bounding rectangle.
Definition XTPDockingPaneCaptionButton.h:277
CXTPDockingPaneCaptionButton::DrawMaximizeRestoreButton
static void AFX_CDECL DrawMaximizeRestoreButton(CDC *pDC, CRect rc, BOOL bMaximize, COLORREF clr=COLORREF_NULL)
Call this member to draw the Maximize/Restore button.
CXTPDockingPaneCaptionButton::PtInRect
BOOL PtInRect(POINT pt) const
Call this member to determine if a specified point belongs to the button.
Definition XTPDockingPaneCaptionButton.h:302
CXTPDockingPaneCaptionButton::m_nID
int m_nID
Identifier of the button.
Definition XTPDockingPaneCaptionButton.h:265
CXTPDockingPaneCaptionButton::CheckForMouseOver
BOOL CheckForMouseOver(CPoint pt)
Call this member to refresh the styles of the button.
CXTPDockingPaneCaptionButton::IsEnabled
BOOL IsEnabled() const
Call this member to determine if the pin caption button is enabled.
CXTPDockingPaneMiniWnd
CXTPDockingPaneMiniWnd is a multiple inheritance class derived from CMiniFrameWnd and CXTPDockingPane...
Definition XTPDockingPaneMiniWnd.h:42
CXTPDockingPaneTabbedContainer
CXTPDockingPaneTabbedContainer is a multiple inheritance class derived from CWnd and CXTPDockingPaneB...
Definition XTPDockingPaneTabbedContainer.h:47


Toolkit Pro: XTPDockingPaneColorSet2017.h Source File

  • Source
  • DockingPane
  • ColorSets
XTPDockingPaneColorSet2017.h
Go to the documentation of this file.
1
23#if !defined(__XTPDOCKINGPANECOLORSET2017_H__)
24# define __XTPDOCKINGPANECOLORSET2017_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPDockingPaneColorSet2017 : public CXTPDockingPaneColorSet
39{
40public:
47 virtual void RefreshMetrics(CString strSection);
48};
49
50# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
52#endif // !defined(__XTPDOCKINGPANECOLORSET2017_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPDockingPaneColorSet2017
Helper class used to initialize default colors for a theme from an .INI resource.
Definition XTPDockingPaneColorSet2017.h:39
CXTPDockingPaneColorSet2017::RefreshMetrics
virtual void RefreshMetrics(CString strSection)
This member function is used to initialize default colors for a theme from an .INI resource.
CXTPDockingPaneColorSet
Helper class used to initialize default colors for a theme from an .INI resource.
Definition XTPDockingPaneColorSet.h:39


Toolkit Pro: Member List

  • CXTPColorHex
  • CRgnCell
CXTPColorHex::CRgnCell Member List

This is the complete list of members for CXTPColorHex::CRgnCell, including all inherited members.

CRgnCell(const CTX_DATA &data, CXTPRectF &rect, COLORREF color, float u, float d) | CXTPColorHex::CRgnCell |
CRgnCell(const CTX_DATA &data, CXTPRectF &rect, COLORREF color, float u, float d, float x, float y, BOOL bLarge=FALSE) | CXTPColorHex::CRgnCell |
DrawCell(CDC *pDC) | CXTPColorHex::CRgnCell | protectedvirtual
DrawSelection(CDC *pDC) | CXTPColorHex::CRgnCell | protectedvirtual
m_color | CXTPColorHex::CRgnCell | protected
m_iCell | CXTPColorHex::CRgnCell | protected
m_pts | CXTPColorHex::CRgnCell | protected
m_rect | CXTPColorHex::CRgnCell | protected


Toolkit Pro: XTPColorPopup.h Source File

  • Source
  • Controls
  • Popup
XTPColorPopup.h
Go to the documentation of this file.
1
23#if !defined(__XTPCOLORPOPUP_H__)
24# define __XTPCOLORPOPUP_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPShadowManager;
34
41class _XTP_EXT_CLASS CXTPColorPopup : public CXTPColorSelectorCtrl
42{
43public:
51 CXTPColorPopup(BOOL bAutoDelete = FALSE, LPARAM callerParam = 0);
52
57 virtual ~CXTPColorPopup();
58
59public:
61 _XTP_DEPRECATED_IN_FAVOR(AddRecentColor)
62 static void AFX_CDECL AddUserColor(COLORREF clrColor)
63 {
64 AddRecentColor(clrColor);
65 }
66
67 _XTP_DEPRECATED_IN_FAVOR(ResetRecentColors)
68 static void AFX_CDECL ResetUserColors()
69 {
70 ResetRecentColors();
71 }
107 virtual BOOL Create(CRect& rect, CWnd* pParentWnd, DWORD dwPopup, COLORREF clrColor,
108 COLORREF clrDefault = CLR_DEFAULT);
109
116 void AddListener(HWND hwndListener);
117
129 void DisplayShadow(BOOL bDisplayShadow = TRUE);
130
131protected:
139 virtual void EndSelection(int nCurSel);
140
141protected:
143 DECLARE_MESSAGE_MAP()
144
145 //{{AFX_VIRTUAL(CXTPColorPopup)
146 virtual void PostNcDestroy();
147 //}}AFX_VIRTUAL
148
149 //{{AFX_MSG(CXTPColorPopup)
150 afx_msg void OnActivate(UINT nState, CWnd* pWndOther, BOOL bMinimized);
151 afx_msg void OnDestroy();
152 afx_msg int OnCreate(LPCREATESTRUCT lpCreateStruct);
153 afx_msg void OnPaint();
154 afx_msg void OnKillFocus(CWnd* pNewWnd);
155 afx_msg void OnLButtonDown(UINT nFlags, CPoint point);
156 afx_msg void OnNcPaint();
157 //}}AFX_MSG
160private:
161 BOOL Create(LPCTSTR lpszClassName, LPCTSTR lpszWindowName, DWORD dwStyle, const RECT& rect,
162 CWnd* pParentWnd, UINT nID, CCreateContext* pContext = NULL);
163
164protected:
165 BOOL m_bAutoDelete;
166 BOOL m_bDisplayShadow;
167 CRect m_rcExclude;
168 BOOL m_bEndSelection;
169 const LPARAM m_callerParam;
174 CXTPShadowManager* m_pShadowManager; // Shadow manager to draw pop-up shadow
175};
176
178
179AFX_INLINE BOOL CXTPColorPopup::Create(LPCTSTR lpszClassName, LPCTSTR lpszWindowName, DWORD dwStyle,
180 const RECT& rect, CWnd* pParentWnd, UINT nID,
181 CCreateContext* pContext)
182{
183 return CWnd::Create(lpszClassName, lpszWindowName, dwStyle, rect, pParentWnd, nID, pContext);
184}
185AFX_INLINE void CXTPColorPopup::DisplayShadow(BOOL bDisplayShadow /* = TRUE*/)
186{
187 m_bDisplayShadow = bDisplayShadow;
188}
190# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
192#endif //#if !defined(__XTPCOLORPOPUP_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPColorPopup
CXTPColorPopup is a CXTPColorSelectorCtrl derived class.
Definition XTPColorPopup.h:42
CXTPColorPopup::CXTPColorPopup
CXTPColorPopup(BOOL bAutoDelete=FALSE, LPARAM callerParam=0)
Constructs a CXTPColorPopup object.
CXTPColorPopup::EndSelection
virtual void EndSelection(int nCurSel)
This member function will finish the selection process for the color box or button in the color pop-u...
CXTPColorPopup::~CXTPColorPopup
virtual ~CXTPColorPopup()
Destroys a CXTPColorPopup object, handles cleanup and deallocation.
CXTPColorPopup::Create
virtual BOOL Create(CRect &rect, CWnd *pParentWnd, DWORD dwPopup, COLORREF clrColor, COLORREF clrDefault=CLR_DEFAULT)
This member function handles the creation of the color pop-up window.
CXTPColorPopup::AddListener
void AddListener(HWND hwndListener)
This member function adds a window that picker notifications are sent to.
CXTPColorPopup::DisplayShadow
void DisplayShadow(BOOL bDisplayShadow=TRUE)
Enables/disables pop-up window shadow.
CXTPColorSelectorCtrl
CXTPColorSelectorCtrl is a CWnd derived class.
Definition XTPColorSelectorCtrl.h:63
CXTPColorSelectorCtrl::AddRecentColor
static void AFX_CDECL AddRecentColor(COLORREF clrRecent)
This member function will add a color to the user-defined color list.
CXTPColorSelectorCtrl::ResetRecentColors
static void AFX_CDECL ResetRecentColors()
Resets the recently used color list.
CXTPShadowManager
CXTPShadowManager is standalone class used to manage CommandBars' shadows.
Definition XTPHookManager.h:303


Toolkit Pro: XTPChartGdiCircleDeviceCommand.h Source File

  • Source
  • Chart
  • Drawing
  • Gdi
XTPChartGdiCircleDeviceCommand.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTGDICIRCLEDEVICECOMMAND_H__)
24# define __XTPCHARTGDICIRCLEDEVICECOMMAND_H__
25
26# if _MSC_VER >= 1000
27# pragma once
28# endif // _MSC_VER >= 1000
29
30# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
31
38class _XTP_EXT_CLASS CXTPChartGdiSolidCircleDeviceCommand : public CXTPChartCircleDeviceCommand
39{
40public:
49 CXTPChartGdiSolidCircleDeviceCommand(const CXTPChartPointF& center, double radius,
50 const CXTPChartColor& color);
51
60 void ExecuteOverride(CXTPChartDeviceContext* pDC);
61
62protected:
63 CXTPChartColor m_color;
64};
65
72class _XTP_EXT_CLASS CXTPChartGdiGradientCircleDeviceCommand : public CXTPChartCircleDeviceCommand
73{
74public:
86 CXTPChartGdiGradientCircleDeviceCommand(const CXTPChartPointF& center, double radius,
87 const CXTPChartColor& color,
88 const CXTPChartColor& color2,
89 XTPChartLinearGradientMode nMode);
90
99 void ExecuteOverride(CXTPChartDeviceContext* pDC);
100
101protected:
102 CXTPChartColor m_color;
103 CXTPChartColor m_color2;
104 XTPChartLinearGradientMode m_nMode;
105};
106
113class _XTP_EXT_CLASS CXTPChartGdiHatchCircleDeviceCommand : public CXTPChartCircleDeviceCommand
114{
115public:
126 CXTPChartGdiHatchCircleDeviceCommand(const CXTPChartPointF& center, double radius,
127 const CXTPChartColor& color, const CXTPChartColor& color2,
128 XTPChartHatchStyle nStyle);
129
138 void ExecuteOverride(CXTPChartDeviceContext* pDC);
139
140protected:
141 CXTPChartColor m_color;
142 CXTPChartColor m_color2;
143 XTPChartHatchStyle m_nStyle;
144};
145
146class _XTP_EXT_CLASS CXTPChartGdiBoundedCircleDeviceCommand
147 : public CXTPChartBoundedCircleDeviceCommand
148{
149public:
159 CXTPChartGdiBoundedCircleDeviceCommand(const CXTPChartPointF& center, double radius,
160 const CXTPChartColor& color, int thickness);
161
170 void ExecuteOverride(CXTPChartDeviceContext* pDC);
171};
172
173# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
174#endif //#if !defined(__XTPCHARTGDICIRCLEDEVICECOMMAND_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartBoundedCircleDeviceCommand
This class represents a bounded circle device command, which is a kind of CXTPChartDeviceCommand.
Definition XTPChartCircleDeviceCommand.h:73
CXTPChartCircleDeviceCommand
This class is the base class for all circle device commands.
Definition XTPChartCircleDeviceCommand.h:38
CXTPChartColor
This class abstracts a color entity.
Definition XTPChartTypes.h:51
CXTPChartDeviceCommand::ExecuteOverride
virtual void ExecuteOverride(CXTPChartDeviceContext *pDC)
Override this function to write the drawing code for specific objects.
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPPoint2T< float >


Toolkit Pro: XTPChartRadarAxisYView.h Source File

  • Source
  • Chart
  • Diagram
  • Axis
XTPChartRadarAxisYView.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTRADARAXISYVIEW_H__)
24# define __XTPCHARTRADARAXISYVIEW_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartRadarAxisYView;
34class CXTPChartAxisRange;
35class CXTPChartAxis;
36class CXTPChartSeriesView;
37
42class _XTP_EXT_CLASS CXTPChartRadarAxisYViewTick
43{
44public:
45 double m_dValue;
46 CXTPChartString m_strLabel;
47 CSize m_szBounds;
48 CXTPChartSizeF m_szLabel;
49};
55class _XTP_EXT_CLASS CXTPChartRadarAxisYView : public CXTPChartRadarAxisView
56{
57public:
65 CXTPChartRadarAxisYView(CXTPChartAxis* pAxis, CXTPChartElementView* pParentView);
66
71 ~CXTPChartRadarAxisYView();
72
73public:
85 virtual CXTPChartDeviceCommand* CreateDeviceCommand(CXTPChartDeviceContext* pDC);
86
98 virtual CXTPChartDeviceCommand* CreateGridLinesDeviceCommand(CXTPChartDeviceContext* pDC);
99
111 virtual CXTPChartDeviceCommand* CreateInterlacedDeviceCommand(CXTPChartDeviceContext* pDC);
112
124 virtual CXTPChartDeviceCommand* CreateTickMarksDeviceCommand(CXTPChartDeviceContext* pDC);
125
137 virtual CXTPChartDeviceCommand* CreateLabelsDeviceCommand(CXTPChartDeviceContext* pDC);
138
150 virtual CXTPChartDeviceCommand* CreateTitleDeviceCommand(CXTPChartDeviceContext* pDC);
151
164 virtual CXTPChartDeviceCommand* CreateConstantLinesDeviceCommand(CXTPChartDeviceContext* pDC,
165 BOOL bBehind);
166
178 virtual CXTPChartDeviceCommand* CreateStripsDeviceCommand(CXTPChartDeviceContext* pDC);
179
190 void CreateView(CXTPChartDeviceContext* pDC);
191
200 void CalcSize(CXTPChartDeviceContext* pDC, CRect rcDiagram);
201
209 void SetBounds(CXTPChartDeviceContext* pDC, CRect rcBounds);
210
218 int GetSize() const;
219
220 double ValueToRadius(double dValue) const;
221
222protected:
230 void CreateTickMarks(CXTPChartDeviceContext* pDC, CRect rcDiagram);
231
232public:
233 CArray<CXTPChartRadarAxisYViewTick, CXTPChartRadarAxisYViewTick&> m_arrTicks;
237 CArray<double, double&> m_arrMinorTicks;
238
239protected:
240 CRect m_rcBounds;
241 CRect m_rcPaneBounds;
242 int m_nSize;
244 CXTPPoint2i m_ptCenter;
245 int m_nRadius;
246};
247
248AFX_INLINE int CXTPChartRadarAxisYView::GetSize() const
249{
250 return m_nSize;
251}
253# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
254#endif //#if !defined(__XTPCHARTRADARAXISYVIEW_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartAxis
This abstract base class represents a chart axis as a kind of chart element.
Definition XTPChartAxis.h:86
CXTPChartAxisRange
This class represents the value range of the axis.
Definition XTPChartAxisRange.h:44
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartElementView
This class represents the view of a chart element.
Definition XTPChartElementView.h:47
CXTPChartRadarAxisView
This class abstracts the view of a chart axis and its child items in a bounding rectangle context.
Definition XTPChartRadarAxisView.h:41
CXTPChartRadarAxisYView
This class abstracts the view of a chart axis and its child items in a bounding rectangle context.
Definition XTPChartRadarAxisYView.h:56
CXTPChartRadarAxisYView::CXTPChartRadarAxisYView
CXTPChartRadarAxisYView(CXTPChartAxis *pAxis, CXTPChartElementView *pParentView)
Constructs a CXTPChartRadarAxisYView object.
CXTPChartRadarAxisYView::SetBounds
void SetBounds(CXTPChartDeviceContext *pDC, CRect rcBounds)
This function sets the bounds for the axis.
CXTPChartRadarAxisYView::CreateStripsDeviceCommand
virtual CXTPChartDeviceCommand * CreateStripsDeviceCommand(CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
CXTPChartRadarAxisYView::m_nSize
int m_nSize
The axis size;.
Definition XTPChartRadarAxisYView.h:242
CXTPChartRadarAxisYView::m_rcPaneBounds
CRect m_rcPaneBounds
The diagram boundary.
Definition XTPChartRadarAxisYView.h:241
CXTPChartRadarAxisYView::CreateTitleDeviceCommand
virtual CXTPChartDeviceCommand * CreateTitleDeviceCommand(CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
CXTPChartRadarAxisYView::~CXTPChartRadarAxisYView
~CXTPChartRadarAxisYView()
Destroys a CXTPChartRadarAxisYView object, handles cleanup and deallocation.
CXTPChartRadarAxisYView::CalcSize
void CalcSize(CXTPChartDeviceContext *pDC, CRect rcDiagram)
This function calculates the size of an axis, including its constituent elements (e....
CXTPChartRadarAxisYView::CreateDeviceCommand
virtual CXTPChartDeviceCommand * CreateDeviceCommand(CXTPChartDeviceContext *pDC)
Override this function to create a CXTPChartDeviceCommand object.
CXTPChartRadarAxisYView::CreateConstantLinesDeviceCommand
virtual CXTPChartDeviceCommand * CreateConstantLinesDeviceCommand(CXTPChartDeviceContext *pDC, BOOL bBehind)
This function creates a CXTPChartDeviceCommand object.
CXTPChartRadarAxisYView::GetSize
int GetSize() const
This function returns the size of the axis.
Definition XTPChartRadarAxisYView.h:248
CXTPChartRadarAxisYView::CreateTickMarks
void CreateTickMarks(CXTPChartDeviceContext *pDC, CRect rcDiagram)
This function creates the axis tick marks.
CXTPChartRadarAxisYView::CreateLabelsDeviceCommand
virtual CXTPChartDeviceCommand * CreateLabelsDeviceCommand(CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
CXTPChartRadarAxisYView::CreateView
void CreateView(CXTPChartDeviceContext *pDC)
Call this function to create a chart axis view.
CXTPChartRadarAxisYView::m_rcBounds
CRect m_rcBounds
The diagram boundary.
Definition XTPChartRadarAxisYView.h:240
CXTPChartRadarAxisYView::CreateGridLinesDeviceCommand
virtual CXTPChartDeviceCommand * CreateGridLinesDeviceCommand(CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
CXTPChartRadarAxisYView::CreateTickMarksDeviceCommand
virtual CXTPChartDeviceCommand * CreateTickMarksDeviceCommand(CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
CXTPChartRadarAxisYView::m_arrTicks
CArray< CXTPChartRadarAxisYViewTick, CXTPChartRadarAxisYViewTick & > m_arrTicks
The collection of tick marks.
Definition XTPChartRadarAxisYView.h:233
CXTPChartRadarAxisYView::CreateInterlacedDeviceCommand
virtual CXTPChartDeviceCommand * CreateInterlacedDeviceCommand(CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
CXTPChartRadarAxisYViewTick
This class represents a tick mark in the axis.
Definition XTPChartRadarAxisYView.h:43
CXTPChartRadarAxisYViewTick::m_strLabel
CXTPChartString m_strLabel
The tick mark label.
Definition XTPChartRadarAxisYView.h:46
CXTPChartRadarAxisYViewTick::m_szLabel
CXTPChartSizeF m_szLabel
The size of the label.
Definition XTPChartRadarAxisYView.h:48
CXTPChartRadarAxisYViewTick::m_szBounds
CSize m_szBounds
The boundary.
Definition XTPChartRadarAxisYView.h:47
CXTPChartRadarAxisYViewTick::m_dValue
double m_dValue
The value of the tick mark.
Definition XTPChartRadarAxisYView.h:45
CXTPPoint2T< int >
CXTPSizeT
This class incapsulates size data.
Definition XTPSize.h:40


Toolkit Pro: XTPStatusBarThemeOffice2003.h Source File

  • Source
  • CommandBars
  • StatusBar
XTPStatusBarThemeOffice2003.h
Go to the documentation of this file.
1
23#if !defined(__XTPSTATUSBARTHEMEOFFICE2003_H__)
24# define __XTPSTATUSBARTHEMEOFFICE2003_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPCommandBarsOffice2003Theme;
34
35class _XTP_EXT_CLASS CXTPStatusBarThemeOffice2003 : public CXTPStatusBarPaintManager
36{
37public:
38 CXTPStatusBarThemeOffice2003(CXTPCommandBarsOffice2003Theme* pTheme);
39
46 virtual void DrawStatusBarGripper(CDC* pDC, CRect rcClient);
47
56 virtual void DrawStatusBarPaneBorder(CDC* pDC, CRect rc, CXTPStatusBarPane* pPane,
57 BOOL bGripperPane);
58
63 virtual void RefreshMetrics();
64
65protected:
66 CXTPCommandBarsOffice2003Theme* m_pTheme;
67};
68
70# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
71#endif // !defined(__XTPSTATUSBARTHEMEOFFICE2003_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCommandBarsOffice2003Theme
The CXTPCommandBarsOffice2003Theme class is used to enable an Office 2003 style theme for Command Bar...
Definition XTPCommandBarsOffice2003Theme.h:41
CXTPStatusBarPane
CXTPStatusBarPane is a CXTPCmdTarget derived class.
Definition XTPStatusBarPane.h:39


Toolkit Pro: Member List

CXTPChartQualitativeScaleTypeMap Member List

This is the complete list of members for CXTPChartQualitativeScaleTypeMap, including all inherited members.

Create(CXTPChartAxis *pAxis) | CXTPChartScaleTypeMap | static
CXTPChartElement() | CXTPChartElement |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartQualitativeScaleTypeMap(CXTPChartAxis *pAxis) | CXTPChartQualitativeScaleTypeMap |
CXTPChartScaleTypeMap(CXTPChartAxis *pAxis) | CXTPChartScaleTypeMap |
DoPropExchange(CXTPPropExchange *pPX) | CXTPChartElement | virtual
GetAppearance() const | CXTPChartElement |
GetAxis() const | CXTPChartScaleTypeMap |
GetContent() const | CXTPChartElement |
GetOwner() const | CXTPChartElement |
InternalToValue(CXTPChartNumberFormat *pFromat, double dValue) const | CXTPChartQualitativeScaleTypeMap | virtual
Is3D() const | CXTPChartObject |
m_dMaxValue | CXTPChartQualitativeScaleTypeMap | protected
m_dMinValue | CXTPChartQualitativeScaleTypeMap | protected
m_pStorage | CXTPChartQualitativeScaleTypeMap | protected
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartElement | virtual
Release() | CXTPChartElement | virtual
UpdateSeries(CXTPChartSeries *pSeries) | CXTPChartQualitativeScaleTypeMap | protectedvirtual
UpdateSeries(CXTPChartAxisView *pAxisView) | CXTPChartQualitativeScaleTypeMap | virtual
UpdateSeriesPointArgument(CXTPChartSeriesPoint *pPoint) | CXTPChartQualitativeScaleTypeMap | protectedvirtual
ValueToInternal(const CXTPChartString &strValue) const | CXTPChartQualitativeScaleTypeMap | virtual
~CXTPChartElement() | CXTPChartElement | virtual
~CXTPChartQualitativeScaleTypeMap() | CXTPChartQualitativeScaleTypeMap | virtual
~CXTPChartScaleTypeMap() | CXTPChartScaleTypeMap | virtual


Toolkit Pro: Member List

CXTPMarqueeCtrlThemeVisualStudio2015 Member List

This is the complete list of members for CXTPMarqueeCtrlThemeVisualStudio2015, including all inherited members.

CXTPMarqueeCtrlPaintManager() | CXTPMarqueeCtrlPaintManager |
CXTPMarqueeCtrlThemeOffice2000() | CXTPMarqueeCtrlThemeOffice2000 |
CXTPMarqueeCtrlThemeOffice2013() | CXTPMarqueeCtrlThemeOffice2013 |
CXTPMarqueeCtrlThemeVisualStudio2015() | CXTPMarqueeCtrlThemeVisualStudio2015 |
DeflateRect(CDC *pDC, CRect &rcClient) | CXTPMarqueeCtrlPaintManager | protectedvirtual
DrawBackground(CXTPMarqueeCtrl *pWndCtrl, CDC *pDC, CRect &rcClient) | CXTPMarqueeCtrlPaintManager | virtual
DrawChunk(CXTPMarqueeCtrl *pWndCtrl, CDC *pDC, CXTPCompatibleDC &dcChunk, int i, int &x, int &y, int cx, int cy) | CXTPMarqueeCtrlPaintManager | protectedvirtual
DrawMarquee(CXTPMarqueeCtrl *pWndCtrl, CDC *pDC, CRect &rcClient) | CXTPMarqueeCtrlPaintManager | virtual
GetBackColor() | CXTPMarqueeCtrlPaintManager |
GetBarColor() | CXTPMarqueeCtrlPaintManager |
GetBorderColor() | CXTPMarqueeCtrlPaintManager |
m_bUseWinTheme | CXTPMarqueeCtrlPaintManager | protected
m_clr3DHilite | CXTPMarqueeCtrlPaintManager | protected
m_clr3DShadow | CXTPMarqueeCtrlPaintManager | protected
m_clrBack | CXTPMarqueeCtrlPaintManager | protected
m_clrBar | CXTPMarqueeCtrlPaintManager | protected
m_nTheme | CXTPMarqueeCtrlPaintManager | protected
m_winTheme | CXTPMarqueeCtrlPaintManager | protected
RefreshMetrics() | CXTPMarqueeCtrlThemeOffice2013 | virtual
SetBackColor(COLORREF clrNew) | CXTPMarqueeCtrlPaintManager |
SetBarColor(COLORREF clrNew) | CXTPMarqueeCtrlPaintManager |
SetBorderColor(COLORREF clrNew) | CXTPMarqueeCtrlPaintManager |
UseWinThemes(BOOL bUseWinThemes=TRUE) | CXTPMarqueeCtrlPaintManager |
UsingWinThemes(BOOL bCheckReady=FALSE) | CXTPMarqueeCtrlPaintManager |
~CXTPMarqueeCtrlPaintManager() | CXTPMarqueeCtrlPaintManager | virtual


Toolkit Pro: XTPMarkupRowDefinitionCollection.h Source File

  • Source
  • Markup
  • Controls
XTPMarkupRowDefinitionCollection.h
Go to the documentation of this file.
1
23#if !defined(__XTPMARKUPROWDEFINITIONCOLLECTION_H__)
24# define __XTPMARKUPROWDEFINITIONCOLLECTION_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPMarkupRowDefinitionCollection : public CXTPMarkupDefinitionCollection
39{
41 DECLARE_MARKUPCLASS(CXTPMarkupRowDefinitionCollection);
43public:
48 CXTPMarkupRowDefinitionCollection();
49};
50
51# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
53#endif // !defined(__XTPMARKUPROWDEFINITIONCOLLECTION_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPMarkupDefinitionCollection
CXTPMarkupDefinitionCollection is the base class for CXTPMarkupDefinitionCollection and CXTPMarkupDef...
Definition XTPMarkupGrid.h:45
CXTPMarkupRowDefinitionCollection
CXTPMarkupRowDefinitionCollection is a CXTPMarkupDefinitionCollection derived class.
Definition XTPMarkupRowDefinitionCollection.h:39
CXTPMarkupRowDefinitionCollection::CXTPMarkupRowDefinitionCollection
CXTPMarkupRowDefinitionCollection()
Constructs a CXTPMarkupRowDefinitionCollection object.


Toolkit Pro: XTPTabColorSetVisualStudio2005.h Source File

  • Source
  • TabManager
  • ColorSets
XTPTabColorSetVisualStudio2005.h
Go to the documentation of this file.
1
23#if !defined(__XTPTABCOLORSETVISUALSTUDIO2005_H__)
24# define __XTPTABCOLORSETVISUALSTUDIO2005_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
47class _XTP_EXT_CLASS CColorSetVisualStudio2005 : public CXTPTabColorSetOffice2003
48{
49public:
54 CColorSetVisualStudio2005();
55
56public:
64 void RefreshMetrics();
65
89 COLORREF FillPropertyButton(CDC* pDC, CRect rcItem, CXTPTabManagerItem* pItem);
90
91protected:
92 BOOL m_bGradientButton;
95};
96
98typedef CColorSetVisualStudio2005 CColorSetWhidbey;
102# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
104#endif // !defined(__XTPTABCOLORSETVISUALSTUDIO2005_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CColorSetVisualStudio2005
CColorSetVisualStudio2005 implements a Visual Studio 2005 tab color set.
Definition XTPTabColorSetVisualStudio2005.h:48
CColorSetVisualStudio2005::CColorSetVisualStudio2005
CColorSetVisualStudio2005()
Constructs a CColorSetVisualStudio2005 object.
CColorSetVisualStudio2005::m_bGradientButton
BOOL m_bGradientButton
TRUE if luna colors are enabled.
Definition XTPTabColorSetVisualStudio2005.h:92
CColorSetVisualStudio2005::FillPropertyButton
COLORREF FillPropertyButton(CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem)
Fills a specified tab button.
CColorSetVisualStudio2005::RefreshMetrics
void RefreshMetrics()
Refreshes the visual metrics of the tabs.
CXTPTabColorSetOffice2003
CXTPTabColorSetOffice2003 implements an Office 2003 tab color set.
Definition XTPTabColorSetOffice2003.h:44
CXTPTabManagerItem
CXTPTabManagerItem is the base class for the tabs that appear in the command bars tab workspace,...
Definition XTPTabManagerItem.h:44


Toolkit Pro: Member List

CXTPChartContent Member List

This is the complete list of members for CXTPChartContent, including all inherited members.

CreateDeviceComand(CXTPChartDeviceContext *pDC, CRect rcBounds) | CXTPChartContent |
CreateDeviceContext(CXTPChartContainer *pContainer, HDC hDC, CRect rcBounds, BOOL bWindowDC) | CXTPChartContent |
CreateView(CXTPChartDeviceContext *pDC, CRect rcBounds) | CXTPChartContent | protectedvirtual
CXTPChartContent() | CXTPChartContent |
CXTPChartElement() | CXTPChartElement |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
DoPropExchange(CXTPPropExchange *pPX) | CXTPChartContent | virtual
DrawContent(CXTPChartDeviceContext *pDC, CRect rcBounds) | CXTPChartContent |
EnableMarkup(BOOL bEnable=TRUE) | CXTPChartContent |
GetActualBackgroundColor() const | CXTPChartContent |
GetActualBorderColor() const | CXTPChartContent |
GetAppearance() const | CXTPChartContent |
GetBackgroundColor() const | CXTPChartContent |
GetBorder() const | CXTPChartContent |
GetContent() const | CXTPChartElement |
GetLegend() const | CXTPChartContent |
GetMarkupContext() const | CXTPChartContent |
GetOwner() const | CXTPChartElement |
GetPanelDirection() const | CXTPChartContent |
GetPanelDistance() const | CXTPChartContent |
GetPanels() const | CXTPChartContent |
GetPrimaryDiagram() const | CXTPChartContent |
GetSeries() const | CXTPChartContent |
GetTitles() const | CXTPChartContent |
Is3D() const | CXTPChartObject |
m_clrBackground | CXTPChartContent | protected
m_nPanelDirection | CXTPChartContent | protected
m_nPanelDistance | CXTPChartContent | protected
m_pAppearance | CXTPChartContent | protected
m_pBorder | CXTPChartContent | protected
m_pLegend | CXTPChartContent | protected
m_pMarkupContext | CXTPChartContent | protected
m_pPanels | CXTPChartContent | protected
m_pSeries | CXTPChartContent | protected
m_pTitles | CXTPChartContent | protected
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartContent | virtual
OnSeriesStyleChanged(CXTPChartSeries *pSeries) | CXTPChartContent | protectedvirtual
Release() | CXTPChartElement | virtual
SetBackgroundColor(const CXTPChartColor &clr) | CXTPChartContent |
SetPanelDirection(XTPChartPanelDirection nDirection) | CXTPChartContent |
SetPanelDistance(int nDistance) | CXTPChartContent |
UpdateDiagram() | CXTPChartContent | protected
~CXTPChartContent() | CXTPChartContent | virtual
~CXTPChartElement() | CXTPChartElement | virtual


Toolkit Pro: Member List

CXTPImageManagerIcon Member List

This is the complete list of members for CXTPImageManagerIcon, including all inherited members.

Copy(CXTPImageManagerIcon *pIcon) | CXTPImageManagerIcon |
CopyAlphaBitmap(HBITMAP hBitmap, LPBYTE *lpBits=NULL) | CXTPImageManagerIcon | static
CreateDisabledIcon(COLORREF clrDisabledLight=(COLORREF) -1, COLORREF clrDisabledDark=(COLORREF) -1) | CXTPImageManagerIcon |
CreateMarkupContext() | CXTPImageManagerIcon |
CXTPCmdTarget() | CXTPCmdTarget |
CXTPImageManagerIcon(UINT nID, int nWidth, int nHeight, CXTPImageManagerIconSet *pIconSet=NULL) | CXTPImageManagerIcon |
CXTPImageManagerIcon(UINT nID, int nWidth, int nHeight, CXTPImageManagerImageList *pImageList) | CXTPImageManagerIcon |
CXTPImageManagerIcon(UINT nID, CXTPImageManagerIconSet *pIconSet=NULL, CSize szRecommendedExtent=CSize(0)) | CXTPImageManagerIcon |
DirectDraw(PVOID pBits, SIZE_T cbSize, CPoint pt, CSize szIcon) | CXTPImageManagerIcon |
DirectDraw(PVOID pBits, SIZE_T cbSize, CPoint pt, XTPImageState imageState, CSize szIcon) | CXTPImageManagerIcon |
DirectDraw(PVOID pBits, SIZE_T cbSize, CPoint pt, CXTPImageManagerVectorImageHandle hIcon, CSize szIcon=0) | CXTPImageManagerIcon |
Draw(CDC *pDC, CPoint pt) | CXTPImageManagerIcon |
Draw(CDC *pDC, CPoint pt, CSize szIcon) | CXTPImageManagerIcon |
Draw(CDC *pDC, CPoint pt, XTPImageState imageState) | CXTPImageManagerIcon |
Draw(CDC *pDC, CPoint pt, XTPImageState imageState, CSize szIcon) | CXTPImageManagerIcon |
Draw(CDC *pDC, CPoint pt, CXTPImageManagerIconHandle &hIcon, CSize szIcon=0, COLORREF clrBK=CLR_NONE, COLORREF clrFG=CLR_NONE, UINT uiFlags=0) | CXTPImageManagerIcon |
Draw(CDC *pDC, CPoint pt, CXTPImageManagerVectorImageHandle hIcon, CSize szIcon=0) | CXTPImageManagerIcon |
DrawAlphaBitmap(CDC *pDC, HBITMAP hBitmap, CPoint ptDest, CSize szDest, CPoint ptSrc=0, CSize szSrc=0) | CXTPImageManagerIcon | static
DrawIconComposited(CDC *pDC, CPoint pt, CSize szIcon, HICON hIcon) | CXTPImageManagerIcon | static
DrawMono(CDC *pDC, CPoint pt, CXTPImageManagerIconHandle &hIcon, CSize szIcon, COLORREF clrBrush) | CXTPImageManagerIcon |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetBitmapBits(CDC &dcSrc, HBITMAP hBitmap, PBITMAPINFO &pbmi, LPVOID &pBits, UINT &nSize) | CXTPImageManagerIcon | static
GetCheckedIcon() | CXTPImageManagerIcon |
GetDisabledIcon(BOOL bCreateIfNotExists=TRUE) | CXTPImageManagerIcon |
GetExtent() const | CXTPImageManagerIcon |
GetExtent(HICON hIcon) | CXTPImageManagerIcon | static
GetFadedIcon() | CXTPImageManagerIcon |
GetHeight() const | CXTPImageManagerIcon |
GetHotIcon() | CXTPImageManagerIcon |
GetIcon() | CXTPImageManagerIcon |
GetIcon(XTPImageState imageState) | CXTPImageManagerIcon |
GetID() const | CXTPImageManagerIcon |
GetImageList() | CXTPImageManagerIcon |
GetImageList() const | CXTPImageManagerIcon |
GetMarkupContext() | CXTPImageManagerIcon |
GetPressedIcon() | CXTPImageManagerIcon |
GetRecommendedExtent() const | CXTPImageManagerIcon |
GetShadowIcon() | CXTPImageManagerIcon |
GetVectorCheckedIcon() const | CXTPImageManagerIcon |
GetVectorDisabledIcon() const | CXTPImageManagerIcon |
GetVectorHotIcon() const | CXTPImageManagerIcon |
GetVectorIcon() const | CXTPImageManagerIcon |
GetVectorIcon(XTPImageState imageState) const | CXTPImageManagerIcon |
GetVectorPressedIcon() const | CXTPImageManagerIcon |
GetWidth() const | CXTPImageManagerIcon |
HasCheckedIcon() const | CXTPImageManagerIcon |
HasDisabledIcon() const | CXTPImageManagerIcon |
HasHotIcon() const | CXTPImageManagerIcon |
HasIcon(XTPImageState imageState) const | CXTPImageManagerIcon |
HasNormalIcon() const | CXTPImageManagerIcon |
HasPressedIcon() const | CXTPImageManagerIcon |
InvertAlphaBitmap(HBITMAP hBitmap) | CXTPImageManagerIcon | static
IsAlpha() const | CXTPImageManagerIcon |
IsAlphaBitmapFile(LPCTSTR pszFileName) | CXTPImageManagerIcon | static
IsAlphaBitmapResource(HMODULE hModule, LPCTSTR lpBitmapName) | CXTPImageManagerIcon | static
IsAlphaIconHandle(HICON hIcon) | CXTPImageManagerIcon | static
IsDirectDrawSupported(XTPImageState imageState=xtpImageNormal) const | CXTPImageManagerIcon |
IsPngBitmapFile(LPCTSTR pszFileName) | CXTPImageManagerIcon | static
IsPngBitmapResource(HMODULE hModule, LPCTSTR lpBitmapName) | CXTPImageManagerIcon | static
IsRasterIcon() const | CXTPImageManagerIcon |
IsScaled() const | CXTPImageManagerIcon |
IsUndefinedIcon() const | CXTPImageManagerIcon |
IsVectorIcon() const | CXTPImageManagerIcon |
LoadAlphaBitmap(UINT nIDResource) | CXTPImageManagerIcon | static
LoadAlphaBitmap(HMODULE hModule, LPCTSTR lpszResource) | CXTPImageManagerIcon | static
LoadAlphaIcon(LPCTSTR pszFileName, int nWidth) | CXTPImageManagerIcon | static
LoadBitmapFromFile(LPCTSTR lpszFileName, BOOL *lbAlphaBitmap=NULL) | CXTPImageManagerIcon | static
LoadBitmapFromResource(LPCTSTR lpszResource, BOOL *lbAlphaBitmap) | CXTPImageManagerIcon | static
LoadBitmapFromResource(HMODULE hModule, LPCTSTR lpszResource, BOOL *lbAlphaBitmap) | CXTPImageManagerIcon | static
m_bDrawComposited | CXTPImageManagerIcon |
PreMultiplyAlphaBitmap(HBITMAP hBitmap, BOOL *pbAlpha=NULL, LPBYTE *lpBits=NULL) | CXTPImageManagerIcon | static
Refresh() | CXTPImageManagerIcon |
ScaleToFit(HICON hIcon, CSize szExtent, int nWidth) | CXTPImageManagerIcon | static
Serialize(CArchive &ar) | CXTPImageManagerIcon |
SerializeIcon(CXTPImageManagerIconHandle &hIcon, CArchive &ar, long nSchema) | CXTPImageManagerIcon |
SerializeIcon(CXTPImageManagerVectorImageHandle &hIcon, CArchive &ar, long nSchema) | CXTPImageManagerIcon |
SetCheckedIcon(const CXTPImageManagerIconHandle &hIcon) | CXTPImageManagerIcon |
SetDisabledIcon(const CXTPImageManagerIconHandle &hIcon) | CXTPImageManagerIcon |
SetHotIcon(const CXTPImageManagerIconHandle &hIcon) | CXTPImageManagerIcon |
SetIcon(const CXTPImageManagerIconHandle &hIcon) | CXTPImageManagerIcon |
SetIcon(const CXTPImageManagerIconHandle &hIcon, XTPImageState imageState) | CXTPImageManagerIcon |
SetIcon(UINT nIDResourceIcon, int nWidth, int nHeight, XTPIconSizeMatching nSizeMatching=xtpIconSizeExact) | CXTPImageManagerIcon |
SetNormalIcon(const CXTPImageManagerIconHandle &hIcon) | CXTPImageManagerIcon |
SetPressedIcon(const CXTPImageManagerIconHandle &hIcon) | CXTPImageManagerIcon |
SetVectorCheckedIcon(CXTPImageManagerVectorImageHandle hIcon) | CXTPImageManagerIcon |
SetVectorDisabledIcon(CXTPImageManagerVectorImageHandle hIcon) | CXTPImageManagerIcon |
SetVectorHotIcon(CXTPImageManagerVectorImageHandle hIcon) | CXTPImageManagerIcon |
SetVectorIcon(CXTPImageManagerVectorImageHandle hIcon) | CXTPImageManagerIcon |
SetVectorIcon(CXTPImageManagerVectorImageHandle hIcon, XTPImageState imageState) | CXTPImageManagerIcon |
SetVectorPressedIcon(CXTPImageManagerVectorImageHandle hIcon) | CXTPImageManagerIcon |
~CXTPImageManagerIcon() | CXTPImageManagerIcon |


Toolkit Pro: XTPMathStats.h Source File

  • Source
  • Common
  • Math
XTPMathStats.h
Go to the documentation of this file.
1
23#if !defined(__XTPMATHSTATS_H__)
24# define __XTPMATHSTATS_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class _XTP_EXT_CLASS CXTPMathArithmeticMean
34{
35public:
36 CXTPMathArithmeticMean()
37 : m_dArithmeticMean(0)
38 , m_dCount(0)
39 {
40 }
41
42 double Add(double dValue);
43
44 operator double() const
45 {
46 return m_dArithmeticMean;
47 }
48
49protected:
50 double m_dArithmeticMean;
51 double m_dCount;
52};
53
54class _XTP_EXT_CLASS CXTPMathVariance
55{
56public:
57 CXTPMathVariance()
58 : m_dVariance(0)
59 , m_dCount(0)
60 {
61 }
62
63 double Add(double dValue, double dArithmeticMean);
64
65 operator double() const;
66
67protected:
68 double m_dVariance;
69 double m_dCount;
70};
71
72class _XTP_EXT_CLASS CXTPMathCovariance
73{
74public:
75 CXTPMathCovariance();
76
77 double Add(double dValueX, double dArithmeticMeanX, double dValueY, double dArithmeticMeanY);
78
79 operator double() const;
80
81protected:
82 double m_dCovariance;
83 double m_dCount;
84};
85
86# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
88#endif //#if !defined(__XTPMATHSTATS_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h


Toolkit Pro: XTPScrollBarThemeNativeWindows10.h Source File

  • Source
  • Common
  • ScrollBar
  • Themes
XTPScrollBarThemeNativeWindows10.h
Go to the documentation of this file.
1
23#if !defined(__XTPSCROLLBARTHEMENATIVEWINDOWS10_H__)
24# define __XTPSCROLLBARTHEMENATIVEWINDOWS10_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPScrollBarThemeNativeWindows10 : public CXTPScrollBarThemeOffice2013
39{
40};
41
42# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
44#endif // !defined(__XTPSCROLLBARTHEMENATIVEWINDOWS10_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPScrollBarThemeNativeWindows10
Scrollbar paint manager used to draw Native Windows 10 like scrollbars.
Definition XTPScrollBarThemeNativeWindows10.h:39
CXTPScrollBarThemeOffice2013
The CXTPScrollBarThemeOffice2013 class is used to enable a Gallery Office 2013 style theme for Comman...
Definition XTPScrollBarThemeOffice2013.h:67


Toolkit Pro: Member List

CXTPSkinObjectListView Member List

This is the complete list of members for CXTPSkinObjectListView, including all inherited members.

CheckScrollBarsDraw() | CXTPSkinObjectComCtl32Control | protectedvirtual
CXTPSkinObject() | CXTPSkinObject | protected
CXTPSkinObjectComCtl32Control() | CXTPSkinObjectComCtl32Control | protected
CXTPSkinObjectFrame() | CXTPSkinObjectFrame |
CXTPSkinObjectListView() | CXTPSkinObjectListView |
CXTPSkinObjectUser32Control() | CXTPSkinObjectUser32Control | protected
GetAccessCriticalSection() const | CXTPSynchronized | inline
GetBorders() const | CXTPSkinObjectFrame |
GetCaptionButtons() | CXTPSkinObjectFrame |
GetClassName() const | CXTPSkinObject |
GetClientBrush(CDC *pDC) | CXTPSkinObjectFrame | virtual
GetColor(int nIndex) const | CXTPSkinObject |
GetMetrics() const | CXTPSkinObject |
GetSkinClass() const | CXTPSkinObject |
GetSkinManager() const | CXTPSkinObject |
IsActive() const | CXTPSkinObjectFrame |
m_arrButtons | CXTPSkinObjectFrame | protected
m_bActive | CXTPSkinObjectFrame | protected
m_bActiveX | CXTPSkinObject | protected
m_bLockFrameDraw | CXTPSkinObjectFrame |
m_bMDIClient | CXTPSkinObjectFrame | protected
m_bRegionChanged | CXTPSkinObjectFrame | protected
m_bWindowsForms | CXTPSkinObject | protected
m_dwDialogTexture | CXTPSkinObjectFrame |
m_dwExStyle | CXTPSkinObjectFrame | protected
m_dwStyle | CXTPSkinObjectFrame | protected
m_pButtonHot | CXTPSkinObjectFrame | protected
m_pButtonPressed | CXTPSkinObjectFrame | protected
m_pManager | CXTPSkinObject | protected
m_pOldWndProc | CXTPSkinObject | protected
m_pSBTrack | CXTPSkinObjectFrame | protected
m_rcBorders | CXTPSkinObjectFrame | protected
m_spi | CXTPSkinObjectFrame | protected
m_strClassName | CXTPSkinObject | protected
m_szFrameRegion | CXTPSkinObjectFrame | protected
OnHookAttached(LPCREATESTRUCT lpcs, BOOL bAuto) | CXTPSkinObjectFrame | protectedvirtual
OnHookDetached(BOOL bAuto) | CXTPSkinObjectFrame | protectedvirtual
OnSkinChanged(BOOL bPrevState, BOOL bNewState) | CXTPSkinObjectFrame | protectedvirtual
RedrawScrollBar(int nBar) | CXTPSkinObjectFrame |
RefreshMetrics() | CXTPSkinObjectFrame | protectedvirtual
~CXTPSkinObject() | CXTPSkinObject | protected
~CXTPSkinObjectFrame() | CXTPSkinObjectFrame | virtual
~CXTPSkinObjectListView() | CXTPSkinObjectListView | virtual


Toolkit Pro: Member List

IXTPPreviewHost Member List

This is the complete list of members for IXTPPreviewHost, including all inherited members.

GetBackgroundColor() const =0 | IXTPPreviewHost | pure virtual
GetForegroundColor() const =0 | IXTPPreviewHost | pure virtual
~IXTPPreviewHost() | IXTPPreviewHost | inlinevirtual


Toolkit Pro: XTPShortcutBarOffice2000Theme.h Source File

  • Source
  • ShortcutBar
  • Themes
XTPShortcutBarOffice2000Theme.h
Go to the documentation of this file.
1
23#if !defined(__XTPSHORTCUTBAROFFICE2000THEME_H__)
24# define __XTPSHORTCUTBAROFFICE2000THEME_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPShortcutBarOffice2000Theme : public CXTPShortcutBarPaintManager
39{
40public:
47 void FillShortcutBar(CDC* pDC, CXTPShortcutBar* pShortcutBar);
48
57 void DrawShortcutBarFrame(CDC* pDC, CXTPShortcutBar* pShortcutBar);
58
65 void FillShortcutItemEntry(CDC* pDC, CXTPShortcutBarItem* pItem);
66
77 int DrawGripper(CDC* pDC, CXTPShortcutBar* pShortcutBar, BOOL bDraw);
78
91 void Rectangle(CDC* pDC, CRect rc, int nPen, int nBrush);
92
103 void Line(CDC* pDC, int x0, int y0, int x1, int y1, int nPen);
104
124 void DrawImage(CDC* pDC, CPoint pt, CSize sz, CXTPImageManagerIcon* pImage, BOOL bSelected,
125 BOOL bPressed, BOOL bChecked, BOOL bEnabled);
126};
127
128# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
130#endif // !defined(__XTPSHORTCUTBAROFFICE2000THEME_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPImageManagerIcon
Icons holder class.
Definition XTPImageManager.h:622
CXTPShortcutBar
CXTPShortcutBar is a CWnd derived class used to implement an Outlook 2003 shortcut bar control style.
Definition XTPShortcutBar.h:456
CXTPShortcutBarItem
CXTPShortcutBarItem is a base class that represents an item for a shortcut bar control.
Definition XTPShortcutBar.h:181
CXTPShortcutBarOffice2000Theme
CXTPShortcutBarOffice2000Theme is a CXTPShortcutBarPaintManager derived class that represents an Offi...
Definition XTPShortcutBarOffice2000Theme.h:39
CXTPShortcutBarOffice2000Theme::FillShortcutItemEntry
void FillShortcutItemEntry(CDC *pDC, CXTPShortcutBarItem *pItem)
Fills a specified item for the shortcut bar control.
CXTPShortcutBarOffice2000Theme::Rectangle
void Rectangle(CDC *pDC, CRect rc, int nPen, int nBrush)
Draws the rectangle to be used to draw the shortcut bar items.
CXTPShortcutBarOffice2000Theme::Line
void Line(CDC *pDC, int x0, int y0, int x1, int y1, int nPen)
Draws the "gripper" lines in the gripper.
CXTPShortcutBarOffice2000Theme::DrawShortcutBarFrame
void DrawShortcutBarFrame(CDC *pDC, CXTPShortcutBar *pShortcutBar)
Draws the frame for the shortcut bar control.
CXTPShortcutBarOffice2000Theme::FillShortcutBar
void FillShortcutBar(CDC *pDC, CXTPShortcutBar *pShortcutBar)
Fills the client area of the shortcut bar control.
CXTPShortcutBarOffice2000Theme::DrawGripper
int DrawGripper(CDC *pDC, CXTPShortcutBar *pShortcutBar, BOOL bDraw)
Draws the gripper for the shortcut bar control.
CXTPShortcutBarOffice2000Theme::DrawImage
void DrawImage(CDC *pDC, CPoint pt, CSize sz, CXTPImageManagerIcon *pImage, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled)
Draws the image of a shortcut bar item.
CXTPShortcutBarPaintManager
CXTPShortcutBarPaintManager is a standalone class used as a paint manager for a shortcut bar control.
Definition XTPShortcutBarPaintManager.h:79


Toolkit Pro: XTPTaskDialogAPI.h Source File

  • Source
  • Controls
  • Dialog
XTPTaskDialogAPI.h
Go to the documentation of this file.
1
23#if !defined(__XTPTASKAPI_H__)
24# define __XTPTASKAPI_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPMarkupUIElement;
34class CXTPMarkupContext;
35
36# define TD_QUESTION_ICON MAKEINTRESOURCEW(-5)
37
39namespace XTPTaskDialogAPI
40{
41# ifndef PBST_NORMAL
42# define PBST_NORMAL 0x0001
43# endif
44
45# ifndef PBST_ERROR
46# define PBST_ERROR 0x0002
47# endif
48
49# ifndef PBST_PAUSED
50# define PBST_PAUSED 0x0003
51# endif
52
53# ifndef TDN_INPUTBOX_CHANGED
54# define TDN_INPUTBOX_CHANGED 200
55# endif
56
57// Check if TaskDialog already included in comctrl.h.
58# ifndef TD_WARNING_ICON
59
60# pragma pack(push, 1)
61
62typedef HRESULT(CALLBACK* PFTASKDIALOGCALLBACK)(HWND hwnd, UINT msg, WPARAM wParam, LPARAM lParam,
63 LONG_PTR lpRefData);
64
65enum _TASKDIALOG_FLAGS
66{
67 TDF_ENABLE_HYPERLINKS = 0x0001,
68 TDF_USE_HICON_MAIN = 0x0002,
69 TDF_USE_HICON_FOOTER = 0x0004,
70 TDF_ALLOW_DIALOG_CANCELLATION = 0x0008,
71 TDF_USE_COMMAND_LINKS = 0x0010,
72 TDF_USE_COMMAND_LINKS_NO_ICON = 0x0020,
73 TDF_EXPAND_FOOTER_AREA = 0x0040,
74 TDF_EXPANDED_BY_DEFAULT = 0x0080,
75 TDF_VERIFICATION_FLAG_CHECKED = 0x0100,
76 TDF_SHOW_PROGRESS_BAR = 0x0200,
77 TDF_SHOW_MARQUEE_PROGRESS_BAR = 0x0400,
78 TDF_CALLBACK_TIMER = 0x0800,
79 TDF_POSITION_RELATIVE_TO_WINDOW = 0x1000,
80 TDF_RTL_LAYOUT = 0x2000,
81 TDF_NO_DEFAULT_RADIO_BUTTON = 0x4000,
82 TDF_CAN_BE_MINIMIZED = 0x8000
83};
84typedef int TASKDIALOG_FLAGS; // Note: _TASKDIALOG_FLAGS is an int
85
86typedef enum _TASKDIALOG_MESSAGES
87{
88 TDM_NAVIGATE_PAGE = WM_USER + 101,
89 TDM_CLICK_BUTTON = WM_USER + 102, // wParam = Button ID
90 TDM_SET_MARQUEE_PROGRESS_BAR = WM_USER + 103, // wParam = 0 (nonMarque) wParam != 0 (Marquee)
91 TDM_SET_PROGRESS_BAR_STATE = WM_USER + 104, // wParam = new progress state
92 TDM_SET_PROGRESS_BAR_RANGE = WM_USER + 105, // lParam = MAKELPARAM(nMinRange, nMaxRange)
93 TDM_SET_PROGRESS_BAR_POS = WM_USER + 106, // wParam = new position
94 TDM_SET_PROGRESS_BAR_MARQUEE = WM_USER
95 + 107, // wParam = 0 (stop marquee), wParam != 0 (start marquee),
96 // lparam = speed (milliseconds between repaints)
97 TDM_SET_ELEMENT_TEXT = WM_USER + 108, // wParam = element (TASKDIALOG_ELEMENTS), lParam = new
98 // element text (LPCWSTR)
99 TDM_CLICK_RADIO_BUTTON = WM_USER + 110, // wParam = Radio Button ID
100 TDM_ENABLE_BUTTON = WM_USER
101 + 111, // lParam = 0 (disable), lParam != 0 (enable), wParam = Button ID
102 TDM_ENABLE_RADIO_BUTTON = WM_USER + 112, // lParam = 0 (disable), lParam != 0 (enable), wParam =
103 // Radio Button ID
104 TDM_CLICK_VERIFICATION = WM_USER + 113, // wParam = 0 (unchecked), 1 (checked), lParam = 1 (set
105 // key focus)
106 TDM_UPDATE_ELEMENT_TEXT = WM_USER + 114, // wParam = element (TASKDIALOG_ELEMENTS), lParam = new
107 // element text (LPCWSTR)
108 TDM_SET_BUTTON_ELEVATION_REQUIRED_STATE = WM_USER + 115, // wParam = Button ID, lParam = 0
109 // (elevation not required), lParam !=
110 // 0 (elevation required)
111 TDM_UPDATE_ICON = WM_USER + 116 // wParam = icon element (TASKDIALOG_ICON_ELEMENTS), lParam =
112 // new icon (hIcon if TDF_USE_HICON_* was set, PCWSTR otherwise)
113} TASKDIALOG_MESSAGES;
114
115typedef enum _TASKDIALOG_NOTIFICATIONS
116{
117 TDN_CREATED = 0,
118 TDN_NAVIGATED = 1,
119 TDN_BUTTON_CLICKED = 2, // wParam = Button ID
120 TDN_HYPERLINK_CLICKED = 3, // lParam = (LPCWSTR)pszHREF
121 TDN_TIMER = 4, // wParam = Milliseconds since dialog created or timer reset
122 TDN_DESTROYED = 5,
123 TDN_RADIO_BUTTON_CLICKED = 6, // wParam = Radio Button ID
124 TDN_DIALOG_CONSTRUCTED = 7,
125 TDN_VERIFICATION_CLICKED = 8, // wParam = 1 if checkbox checked, 0 if not, lParam is unused and
126 // always 0
127 TDN_HELP = 9,
128 TDN_EXPANDO_BUTTON_CLICKED = 10, // wParam = 0 (dialog is now collapsed), wParam != 0 (dialog is
129 // now expanded)
130} TASKDIALOG_NOTIFICATIONS;
131
132typedef struct _TASKDIALOG_BUTTON
133{
134 int nButtonID;
135 PCWSTR pszButtonText;
136} TASKDIALOG_BUTTON;
137
138typedef enum _TASKDIALOG_ELEMENTS
139{
140 TDE_CONTENT,
141 TDE_EXPANDED_INFORMATION,
142 TDE_FOOTER,
143 TDE_MAIN_INSTRUCTION,
144} TASKDIALOG_ELEMENTS;
145
146typedef enum _TASKDIALOG_ICON_ELEMENTS
147{
148 TDIE_ICON_MAIN,
149 TDIE_ICON_FOOTER
150} TASKDIALOG_ICON_ELEMENTS;
151
152# define TD_WARNING_ICON MAKEINTRESOURCEW(-1)
153# define TD_ERROR_ICON MAKEINTRESOURCEW(-2)
154# define TD_INFORMATION_ICON MAKEINTRESOURCEW(-3)
155# define TD_SHIELD_ICON MAKEINTRESOURCEW(-4)
156
157enum _TASKDIALOG_COMMON_BUTTON_FLAGS
158{
159 TDCBF_OK_BUTTON = 0x0001, // selected control return value IDOK
160 TDCBF_YES_BUTTON = 0x0002, // selected control return value IDYES
161 TDCBF_NO_BUTTON = 0x0004, // selected control return value IDNO
162 TDCBF_CANCEL_BUTTON = 0x0008, // selected control return value IDCANCEL
163 TDCBF_RETRY_BUTTON = 0x0010, // selected control return value IDRETRY
164 TDCBF_CLOSE_BUTTON = 0x0020 // selected control return value IDCLOSE
165};
166typedef int TASKDIALOG_COMMON_BUTTON_FLAGS; // Note: _TASKDIALOG_COMMON_BUTTON_FLAGS is an int
167
168typedef struct _TASKDIALOGCONFIG
169{
170 UINT cbSize;
171 HWND hwndParent;
172 HINSTANCE hInstance; // used for MAKEINTRESOURCE() strings
173 TASKDIALOG_FLAGS dwFlags; // TASKDIALOG_FLAGS (TDF_XXX) flags
174 TASKDIALOG_COMMON_BUTTON_FLAGS dwCommonButtons; // TASKDIALOG_COMMON_BUTTON (TDCBF_XXX) flags
175 PCWSTR pszWindowTitle; // string or MAKEINTRESOURCE()
176 union {
177 HICON hMainIcon;
178 PCWSTR pszMainIcon;
179 };
180 PCWSTR pszMainInstruction;
181 PCWSTR pszContent;
182 UINT cButtons;
183 const TASKDIALOG_BUTTON* pButtons;
184 int nDefaultButton;
185 UINT cRadioButtons;
186 const TASKDIALOG_BUTTON* pRadioButtons;
187 int nDefaultRadioButton;
188 PCWSTR pszVerificationText;
189 PCWSTR pszExpandedInformation;
190 PCWSTR pszExpandedControlText;
191 PCWSTR pszCollapsedControlText;
192 union {
193 HICON hFooterIcon;
194 PCWSTR pszFooterIcon;
195 };
196 PCWSTR pszFooter;
197 PFTASKDIALOGCALLBACK pfCallback;
198 LONG_PTR lpCallbackData;
199 UINT cxWidth; // width of the Task Dialog's client area in DLU's. If 0, Task Dialog will
200 // calculate the ideal width.
201} TASKDIALOGCONFIG;
202
203# pragma pack(pop)
204
205# endif
206
207_XTP_EXT_CLASS int AFXAPI XTPLoadStringInst(HINSTANCE hInstance, UINT nID, CString* pString);
208
209_XTP_EXT_CLASS CPoint AFXAPI XTPDlu2Pix(int dluX, int dluY);
210
211_XTP_EXT_CLASS CPoint AFXAPI XTPPix2Dlu(int pixX, int pixY);
212
213_XTP_EXT_CLASS BOOL AFXAPI XTPCalcTextSize(const CString& strText, CSize& pSizeText, CFont& font,
214 BOOL* pbWordWrap = NULL);
215
216_XTP_EXT_CLASS BOOL AFXAPI XTPCalcIdealTextSize(const CString& strText, CSize& pSizeText,
217 CFont& font, int dluMax = 330, int dluGrow = 7);
218_XTP_EXT_CLASS BOOL AFXAPI XTPCalcIdealTextSize(CXTPMarkupContext* pMarkupContext,
219 CXTPMarkupUIElement* pUIElement, CSize& pSizeText,
220 CFont& font, int dluMax = 330, int dluGrow = 7);
221
222_XTP_EXT_CLASS CString AFXAPI XTPExtractSubString(CString strFullString, int iSubString);
223
224_XTP_EXT_CLASS CRect AFXAPI XTPSize2Rect(CSize size);
225} // namespace XTPTaskDialogAPI
226
227using namespace XTPTaskDialogAPI;
228
230
231//{{AFX_INSERT_LOCATION}}
232// Microsoft Visual C++ will insert additional declarations immediately before the previous line.
235# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
237#endif // !defined(__XTPTASKAPI_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPMarkupContext
CXTPMarkupContext is a standalone class used to provide common settings for Markup objects.
Definition XTPMarkupContext.h:128
CXTPMarkupUIElement
Base class for XML Markup core level implementations.
Definition XTPMarkupUIElement.h:43


Toolkit Pro: Member List

CXTPChartPieDiagramBase< BaseDiagram > Member List

This is the complete list of members for CXTPChartPieDiagramBase< BaseDiagram >, including all inherited members.

CalculateSeriesLayout(CXTPChartDeviceContext *pDC, CXTPChartDiagramView *pView) | CXTPChartPieDiagramBase< BaseDiagram > | virtual
CreateView(CXTPChartDeviceContext *pDC, CXTPChartElementView *pParent)=0 | CXTPChartPieDiagramBase< BaseDiagram > | pure virtual
CXTPChartPieDiagramBase() | CXTPChartPieDiagramBase< BaseDiagram > | protected


Toolkit Pro: Member List

CXTPSplitterWndThemeVisualStudio2022 Member List

This is the complete list of members for CXTPSplitterWndThemeVisualStudio2022, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPControlTheme() | CXTPControlTheme |
CXTPSplitterWndTheme() | CXTPSplitterWndTheme |
CXTPSplitterWndThemeOffice2013() | CXTPSplitterWndThemeOffice2013 |
CXTPSplitterWndThemeOfficeXP() | CXTPSplitterWndThemeOfficeXP |
CXTPSplitterWndThemeVisualStudio2022() | CXTPSplitterWndThemeVisualStudio2022 |
DrawSplitter(CDC *pDC, CXTPSplitterWnd *pSplitter, int nType, const CRect &rectArg) | CXTPSplitterWndTheme | virtual
EnableTabColors(BOOL bEnable=TRUE) | CXTPSplitterWndTheme |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetThemeStyle() const | CXTPControlTheme |
GetTrackBrush() | CXTPSplitterWndThemeOfficeXP | virtual
m_bTabColors | CXTPSplitterWndTheme |
m_crBack | CXTPSplitterWndTheme |
m_crBoxBack | CXTPSplitterWndTheme |
m_crInnerBorder | CXTPSplitterWndTheme |
m_crInnerBoxBorder | CXTPSplitterWndTheme |
m_crOuterBorder | CXTPSplitterWndTheme |
m_crOuterBoxBorder | CXTPSplitterWndTheme |
m_nTheme | CXTPControlTheme | protected
RefreshMetrics() | CXTPSplitterWndThemeOffice2013 | virtual
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static


Toolkit Pro: XTPHexEdit.h Source File

  • Source
  • Controls
  • Edit
XTPHexEdit.h
Go to the documentation of this file.
1
23#if !defined(__XTPHEXEDIT_H__)
24# define __XTPHEXEDIT_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000j
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33# ifdef _XTP_ACTIVEX
34# define CXTPHexEditBase CXTPOleControl
35# else
36# define CXTPHexEditBase CEdit
37# endif
38
44class _XTP_EXT_CLASS CXTPHexEdit : public CXTPHexEditBase
45{
47 DECLARE_DYNAMIC(CXTPHexEdit)
49protected:
61 enum EditMode
62 {
63 editNone,
64 editAscii,
65 editHigh,
66 editLow
67 };
68
69public:
74 CXTPHexEdit();
75
80 virtual ~CXTPHexEdit();
81
82public:
93 virtual BOOL Create(DWORD dwStyle, const RECT& rect, CWnd* pParentWnd, UINT nID);
94
108 virtual BOOL Create(LPCTSTR lpszClassName, LPCTSTR lpszWindowName, DWORD dwStyle,
109 const RECT& rect, CWnd* pParentWnd, UINT nID,
110 CCreateContext* pContext = NULL);
111
120 COLORREF GetActualBackColor();
121
130 COLORREF GetActualTextColor();
131
141 COLORREF GetActualHighlightBackColor();
142
152 COLORREF GetActualHighlightTextColor();
153
161 void SetBackColor(COLORREF crBack);
162
171 COLORREF GetBackColor();
172
180 void SetTextColor(COLORREF crText);
181
190 COLORREF GetTextColor();
191
199 void SetDisabledBackColor(COLORREF crDisabledBack);
200
209 COLORREF GetDisabledBackColor();
210
218 void SetDisabledTextColor(COLORREF crDisabledText);
219
228 COLORREF GetDisabledTextColor();
229
237 void SetHighlightTextColor(COLORREF crHighlightText);
238
247 COLORREF GetHighlightTextColor();
248
256 void SetHighlightBackColor(COLORREF crHighlight);
257
266 COLORREF GetHighlightBackColor();
267
275 void SetDisabledHighlightTextColor(COLORREF crDisabledHighlightText);
276
285 COLORREF GetDisabledHighlightTextColor();
286
295 void SetDisabledHighlightBackColor(COLORREF crDisabledHighlight);
296
305 COLORREF GetDisabledHighlightBackColor();
306
312 void RestoreDefaultFont();
313
319 void SetHexFont(CFont* pFont);
320
326 void SetHexFont(LOGFONT* pLogFont);
327
333 void EnableCaret(bool bEnable);
334
342 void EnableScrollBars(bool bVertical, bool bHorizontal);
343
352 DWORD SetAddressBase(DWORD dwBase);
353
362 int GetData(LPBYTE pData, int nBufferLength);
363
373 void SetData(LPBYTE pData, int nLength, int nMaxLength = 0);
374
385 bool SetAllowDeletes(bool bVal = true);
386
396 bool GetAllowDeletes() const;
397
405 CSize GetSel();
406
415 void GetSel(int& nSelStart, int& nSelEnd);
416
423 void SetSel(int nSelStart, int nSelEnd);
424
430 void SetBPR(int nBytePerRow);
431
441 void SetOptions(BOOL bShowAddress, BOOL bShowHex, BOOL bShowAscii, BOOL bAddressIsWide);
442
449 BOOL IsReadOnly() const;
450
455 virtual void OnChange();
456
457protected:
459 DECLARE_MESSAGE_MAP()
460
461 //{{AFX_VIRTUAL(CXTPHexEdit)
462 virtual BOOL PreCreateWindow(CREATESTRUCT& cs);
463 //}}AFX_VIRTUAL
464
465 //{{AFX_MSG(CXTPHexEdit)
466 afx_msg void OnChar(UINT nChar, UINT nRepCnt, UINT nFlags);
467 afx_msg void OnKillFocus(CWnd* pNewWnd);
468 afx_msg void OnPaint();
469 afx_msg LRESULT OnPrintClient(WPARAM wParam, LPARAM /*lParam*/);
470 afx_msg void OnDraw(CDC* pDC);
471 afx_msg void OnSetFocus(CWnd* pOldWnd);
472 afx_msg void OnSize(UINT nType, int cx, int cy);
473 afx_msg void OnVScroll(UINT nSBCode, UINT nPos, CScrollBar* pScrollBar);
474 afx_msg void OnHScroll(UINT nSBCode, UINT nPos, CScrollBar* pScrollBar);
475 afx_msg UINT OnGetDlgCode();
476 afx_msg BOOL OnEraseBkgnd(CDC* pDC);
477 afx_msg void OnLButtonDown(UINT nFlags, CPoint point);
478 afx_msg void OnLButtonDblClk(UINT nFlags, CPoint point);
479 afx_msg void OnMouseMove(UINT nFlags, CPoint point);
480 afx_msg void OnLButtonUp(UINT nFlags, CPoint point);
481 afx_msg void OnKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags);
482 afx_msg void OnContextMenu(CWnd*, CPoint point);
483 afx_msg void OnEditClear();
484 afx_msg void OnEditCopy();
485 afx_msg void OnEditCut();
486 afx_msg void OnEditPaste();
487 afx_msg void OnEditSelectAll();
488 afx_msg void OnEditUndo();
489 afx_msg void OnNcPaint();
490 afx_msg BOOL OnMouseWheel(UINT nFlags, short zDelta, CPoint pt);
491 //}}AFX_MSG
494private:
495 void ScrollIntoView(int pData);
496 void RepositionCaret(int pData);
497 void Move(int x, int y);
498 BOOL IsSelected();
499 void UpdateScrollbars();
500 void CreateEditCaret();
501 void CreateAddressCaret();
502 CPoint CalcPos(int x, int y);
503 void SelInsert(int nSelStart, int nLength);
504 void SelDelete(int nSelStart, int nSelEnd);
505 void NormalizeSel();
506 void RecalcBPR();
507 void DoVScroll(UINT nSBCode, bool bMoveCaret);
508
509public:
510 int m_nLength;
511 int m_nTopIndex;
512 int m_nCurrentAddress;
513 int m_nSelStart;
514 int m_nSelEnd;
515 int m_nBytePerRow;
516 int m_nLinesPerPage;
517 int m_nLineHeight;
518 int m_nNullWidth;
520 int m_nOffHex;
521 int m_nOffAscii;
522 int m_nOffAddress;
523 bool m_bAllowDeletes;
524 BOOL m_bDynamicBPR;
525 BOOL m_bShowAddress;
526 BOOL m_bShowAscii;
527 BOOL m_bShowHex;
528 BOOL m_bAddressIsWide;
529 BOOL m_bUpdate;
531 UINT m_nMaxLength;
532 DWORD m_dwBaseAddress;
533 CPoint m_ptEditPos;
534 LPBYTE m_pData;
535 EditMode m_eEditMode;
537protected:
538 BOOL m_bShowCaret;
539 CSize m_szCaret;
541 CXTPFont m_xtpFontHex;
542 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CFont, m_fontHex, m_xtpFontHex, GetHexFontHandle);
543
544 COLORREF m_crBack;
546 COLORREF m_crText;
547 COLORREF m_crDisabledBack;
549 COLORREF m_crDisabledText;
551 COLORREF m_crHighlightText;
553 COLORREF m_crHighlightBack;
555 COLORREF m_crDisabledHighlightText;
557 COLORREF m_crDisabledHighlightBack;
559};
560
562
563AFX_INLINE UINT CXTPHexEdit::OnGetDlgCode()
564{
565 return DLGC_WANTALLKEYS;
566}
567AFX_INLINE void CXTPHexEdit::SetOptions(BOOL bShowAddress, BOOL bShowHex, BOOL bShowAscii,
568 BOOL bAddressIsWide)
569{
570 m_bShowHex = bShowHex;
571 m_bShowAscii = bShowAscii;
572 m_bShowAddress = bShowAddress;
573 m_bAddressIsWide = bAddressIsWide;
574 m_bUpdate = TRUE;
575 RepositionCaret(m_nCurrentAddress);
576}
577AFX_INLINE void CXTPHexEdit::SetBPR(int nBytePerRow)
578{
579 if (nBytePerRow < 1)
580 nBytePerRow = 1;
581
582 if (nBytePerRow > 256)
583 nBytePerRow = 256;
584
585 if (nBytePerRow != m_nBytePerRow)
586 {
587 m_nBytePerRow = nBytePerRow;
588 m_bUpdate = TRUE;
589 RepositionCaret(m_nCurrentAddress);
590 }
591}
592AFX_INLINE BOOL CXTPHexEdit::IsSelected()
593{
594 return m_nSelStart != 0xffffffff;
595}
596AFX_INLINE CSize CXTPHexEdit::GetSel()
597{
598 return CSize(m_nSelStart, m_nSelEnd);
599}
600AFX_INLINE void CXTPHexEdit::SetBackColor(COLORREF crBack)
601{
602 m_crBack = crBack;
603}
604AFX_INLINE void CXTPHexEdit::SetTextColor(COLORREF crText)
605{
606 m_crText = crText;
607}
608AFX_INLINE void CXTPHexEdit::SetDisabledBackColor(COLORREF crDisabledBack)
609{
610 m_crDisabledBack = crDisabledBack;
611}
612AFX_INLINE void CXTPHexEdit::SetDisabledTextColor(COLORREF crDisabledText)
613{
614 m_crDisabledText = crDisabledText;
615}
616AFX_INLINE void CXTPHexEdit::SetHighlightTextColor(COLORREF crHighlightText)
617{
618 m_crHighlightText = crHighlightText;
619}
620AFX_INLINE void CXTPHexEdit::SetHighlightBackColor(COLORREF crHighlightBack)
621{
622 m_crHighlightBack = crHighlightBack;
623}
624AFX_INLINE void CXTPHexEdit::SetDisabledHighlightTextColor(COLORREF crDisabledHighlightText)
625{
626 m_crDisabledHighlightText = crDisabledHighlightText;
627}
628AFX_INLINE void CXTPHexEdit::SetDisabledHighlightBackColor(COLORREF crDisabledHighlightBack)
629{
630 m_crDisabledHighlightBack = crDisabledHighlightBack;
631}
632AFX_INLINE COLORREF CXTPHexEdit::GetBackColor()
633{
634 return m_crBack;
635}
636AFX_INLINE COLORREF CXTPHexEdit::GetTextColor()
637{
638 return m_crText;
639}
640AFX_INLINE COLORREF CXTPHexEdit::GetDisabledBackColor()
641{
642 return m_crDisabledBack;
643}
644AFX_INLINE COLORREF CXTPHexEdit::GetDisabledTextColor()
645{
646 return m_crDisabledText;
647}
648AFX_INLINE COLORREF CXTPHexEdit::GetHighlightTextColor()
649{
650 return m_crHighlightText;
651}
652AFX_INLINE COLORREF CXTPHexEdit::GetHighlightBackColor()
653{
654 return m_crHighlightBack;
655}
656AFX_INLINE COLORREF CXTPHexEdit::GetDisabledHighlightTextColor()
657{
658 return m_crDisabledHighlightText;
659}
660AFX_INLINE COLORREF CXTPHexEdit::GetDisabledHighlightBackColor()
661{
662 return m_crDisabledHighlightBack;
663}
664AFX_INLINE void CXTPHexEdit::EnableCaret(bool bEnable)
665{
666 m_bShowCaret = bEnable;
667}
668AFX_INLINE bool CXTPHexEdit::SetAllowDeletes(bool bVal)
669{
670 const bool bOldVal = m_bAllowDeletes;
671 m_bAllowDeletes = bVal;
672 return bOldVal;
673}
674AFX_INLINE bool CXTPHexEdit::GetAllowDeletes() const
675{
676 return m_bAllowDeletes;
677}
679# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
681#endif // #if !defined(__XTPHEXEDIT_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPFont
Provides a convenient object oriented interface for HFONT GDI object and uses GDI handle caching.
Definition XTPGdiObjects.h:414
CXTPHexEdit
CXTPHexEdit is a CEdit derived class.
Definition XTPHexEdit.h:45
CXTPHexEdit::RestoreDefaultFont
void RestoreDefaultFont()
This member function sets the font for the hex edit control to the default "Courier New" font.
CXTPHexEdit::SetHexFont
void SetHexFont(LOGFONT *pLogFont)
This member function sets the font used by the hex edit control.
CXTPHexEdit::GetDisabledHighlightBackColor
COLORREF GetDisabledHighlightBackColor()
Call this member function to retrieve the current disabled highlight background color of the hex edit...
CXTPHexEdit::CXTPHexEdit
CXTPHexEdit()
Constructs a CXTPHexEdit object.
CXTPHexEdit::GetSel
CSize GetSel()
Call this member function to get the size of the current selection.
CXTPHexEdit::GetData
int GetData(LPBYTE pData, int nBufferLength)
Call this method to extract the data in the hex edit control.
CXTPHexEdit::GetDisabledBackColor
COLORREF GetDisabledBackColor()
Call this member function to retrieve the current disabled background color of the hex edit control.
CXTPHexEdit::GetActualTextColor
COLORREF GetActualTextColor()
Call this member function to return the current text color of the hex edit control.
CXTPHexEdit::SetDisabledTextColor
void SetDisabledTextColor(COLORREF crDisabledText)
Call this member function to set the disabled text color for the hex edit control.
CXTPHexEdit::GetActualHighlightTextColor
COLORREF GetActualHighlightTextColor()
Call this member function to return the current highlight text color of the hex edit control.
CXTPHexEdit::EnableCaret
void EnableCaret(bool bEnable)
This member function enables/disables a flashing screen caret.
CXTPHexEdit::OnChange
virtual void OnChange()
This method is called when the user changes text.
CXTPHexEdit::SetSel
void SetSel(int nSelStart, int nSelEnd)
Call this member function to set the current selection.
CXTPHexEdit::GetDisabledTextColor
COLORREF GetDisabledTextColor()
Call this member function to retrieve the current disabled text color of the hex edit control.
CXTPHexEdit::SetDisabledBackColor
void SetDisabledBackColor(COLORREF crDisabledBack)
Call this member function to set the disabled background color for the hex edit control.
CXTPHexEdit::GetActualHighlightBackColor
COLORREF GetActualHighlightBackColor()
Call this member function to return the current highlight background color of the hex edit control.
CXTPHexEdit::GetHighlightTextColor
COLORREF GetHighlightTextColor()
Call this member function to retrieve the current highlighted text color of the hex edit control.
CXTPHexEdit::GetActualBackColor
COLORREF GetActualBackColor()
Call this member function to return the current background color of the hex edit control.
CXTPHexEdit::SetDisabledHighlightBackColor
void SetDisabledHighlightBackColor(COLORREF crDisabledHighlight)
Call this member function to set the disabled highlight background color for the hex edit control.
CXTPHexEdit::Create
virtual BOOL Create(DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID)
This method creates the HexEdit control.
CXTPHexEdit::GetAllowDeletes
bool GetAllowDeletes() const
This member function retrieves the current value of the Allow Deletes setting.
CXTPHexEdit::SetHighlightBackColor
void SetHighlightBackColor(COLORREF crHighlight)
Call this member function to set the highlight background color for the hex edit control.
CXTPHexEdit::SetAllowDeletes
bool SetAllowDeletes(bool bVal=true)
Call this method to allow/disallow the deletion of characters within the control.
CXTPHexEdit::SetBackColor
void SetBackColor(COLORREF crBack)
Call this member function to set the background color for the hex edit control.
CXTPHexEdit::SetHighlightTextColor
void SetHighlightTextColor(COLORREF crHighlightText)
Call this member function to set the highlighted text color for the hex edit control.
CXTPHexEdit::GetDisabledHighlightTextColor
COLORREF GetDisabledHighlightTextColor()
Call this member function to retrieve the current disabled highlight text color of the hex edit contr...
CXTPHexEdit::EnableScrollBars
void EnableScrollBars(bool bVertical, bool bHorizontal)
This member function enables/disables a vertical and horizontal scrollbar display.
CXTPHexEdit::SetData
void SetData(LPBYTE pData, int nLength, int nMaxLength=0)
Call this member function to initialize the hex edit control with data specified by 'pData'.
CXTPHexEdit::IsReadOnly
BOOL IsReadOnly() const
Call this member function to determine if the control is in a read-only state.
CXTPHexEdit::SetDisabledHighlightTextColor
void SetDisabledHighlightTextColor(COLORREF crDisabledHighlightText)
Call this member function to set the disabled highlight text color for the hex edit control.
CXTPHexEdit::SetHexFont
void SetHexFont(CFont *pFont)
This member function sets the font used by the hex edit control.
CXTPHexEdit::SetTextColor
void SetTextColor(COLORREF crText)
Call this member function to set the text color for the hex edit control.
CXTPHexEdit::GetHighlightBackColor
COLORREF GetHighlightBackColor()
Call this member function to retrieve the current highlight background color of the hex edit control.
CXTPHexEdit::GetSel
void GetSel(int &nSelStart, int &nSelEnd)
Call this member function to get the size of the current selection.
CXTPHexEdit::SetBPR
void SetBPR(int nBytePerRow)
Call this member function to set the number of bytes per row.
CXTPHexEdit::SetOptions
void SetOptions(BOOL bShowAddress, BOOL bShowHex, BOOL bShowAscii, BOOL bAddressIsWide)
Call this member function to set the display options for the hex edit control.
CXTPHexEdit::EditMode
EditMode
Enumeration used to determine current editing mode.
Definition XTPHexEdit.h:62
CXTPHexEdit::editAscii
@ editAscii
ASCII editing mode.
Definition XTPHexEdit.h:64
CXTPHexEdit::editHigh
@ editHigh
High editing mode.
Definition XTPHexEdit.h:65
CXTPHexEdit::editNone
@ editNone
No editing mode specified.
Definition XTPHexEdit.h:63
CXTPHexEdit::GetBackColor
COLORREF GetBackColor()
Call this member function to retrieve the current background color of the hex edit control.
CXTPHexEdit::~CXTPHexEdit
virtual ~CXTPHexEdit()
Destroys a CXTPHexEdit object, handles cleanup and deallocation.
CXTPHexEdit::GetTextColor
COLORREF GetTextColor()
Call this member function to retrieve the current text color of the hex edit control.
CXTPHexEdit::SetAddressBase
DWORD SetAddressBase(DWORD dwBase)
Call this member function to set the base address for the hex edit control.
CXTPHexEdit::Create
virtual BOOL Create(LPCTSTR lpszClassName, LPCTSTR lpszWindowName, DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID, CCreateContext *pContext=NULL)
This method creates the HexEdit control.


Toolkit Pro: XTPChartAxisRange.h Source File

  • Source
  • Chart
  • Diagram
  • Axis
XTPChartAxisRange.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTAXISRANGE_H__)
24# define __XTPCHARTAXISRANGE_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartAxis;
34class CXTPChartAxisView;
35
43class _XTP_EXT_CLASS CXTPChartAxisRange : public CXTPChartElement
44{
46 DECLARE_DYNAMIC(CXTPChartAxisRange)
48public:
55 CXTPChartAxisRange(CXTPChartAxis* pAxis);
56
61 virtual ~CXTPChartAxisRange();
62
63public:
71 void UpdateRange(CXTPChartAxisView* pView);
72
79 double GetMaxValue() const;
80
87 double GetMinValue() const;
88
95 void SetMaxValue(double dMaxValue);
96
103 void SetMinValue(double dMinValue);
104
111 void SetAutoRange(BOOL bAutoRange);
112
113 BOOL IsAutoRange() const;
114
116 // View
117
124 double GetViewMaxValue() const;
125
132 double GetViewMinValue() const;
133
140 void SetViewMaxValue(double dMaxValue);
141
148 void SetViewMinValue(double dMinValue);
149
156 void SetViewAutoRange(BOOL bAutoRange);
157
158 BOOL IsViewAutoRange() const;
159
160public:
168 void SetSideMargins(BOOL bSideMargins);
169
176 BOOL GetSideMargins() const;
177
185 void SetShowZeroLevel(BOOL bShowZeroLevel);
186
193 BOOL GetShowZeroLevel() const;
194
195public:
196 double GetZoomLimit() const;
197 void SetZoomLimit(double dZoomLimit);
198
199public:
200 void DoPropExchange(CXTPPropExchange* pPX);
201
202protected:
209 void Correct(CXTPChartAxisView* pView);
210
211protected:
212 CXTPChartAxis* m_pAxis;
214 double m_nMinValue;
215 double m_nMaxValue;
216 BOOL m_bSideMargins;
217 BOOL m_bShowZeroLevel;
219 BOOL m_bAutoRange;
220
221 double m_nViewMinValue;
222 double m_nViewMaxValue;
223 BOOL m_bViewAutoRange;
224
225 double m_dZoomLimit;
226
227# ifdef _XTP_ACTIVEX
228public:
230 DECLARE_DISPATCH_MAP()
231 DECLARE_INTERFACE_MAP()
232 DECLARE_OLETYPELIB_EX(CXTPChartAxisRange);
233
234 afx_msg BOOL OleGetShowZeroLevel();
235 afx_msg void OleSetShowZeroLevel(BOOL bSet);
236 afx_msg BOOL OleGetSideMargins();
237 afx_msg void OleSetSideMargins(BOOL bSet);
238
239 afx_msg BOOL OleGetAutoRange();
240 afx_msg void OleSetAutoRange(BOOL bSet);
241 afx_msg double OleGetMinValue();
242 afx_msg void OleSetMinValue(double bSet);
243 afx_msg double OleGetMaxValue();
244 afx_msg void OleSetMaxValue(double bSet);
245
247# endif
248
249 friend class CXTPChartAxis;
250};
251
252AFX_INLINE double CXTPChartAxisRange::GetMaxValue() const
253{
254 return m_nMaxValue;
255}
256AFX_INLINE double CXTPChartAxisRange::GetMinValue() const
257{
258 return m_nMinValue;
259}
260AFX_INLINE BOOL CXTPChartAxisRange::GetSideMargins() const
261{
262 return m_bSideMargins;
263}
264AFX_INLINE BOOL CXTPChartAxisRange::GetShowZeroLevel() const
265{
266 return m_bShowZeroLevel;
267}
268AFX_INLINE BOOL CXTPChartAxisRange::IsAutoRange() const
269{
270 return m_bAutoRange;
271}
272AFX_INLINE double CXTPChartAxisRange::GetViewMaxValue() const
273{
274 return m_nViewMaxValue;
275}
276AFX_INLINE double CXTPChartAxisRange::GetViewMinValue() const
277{
278 return m_nViewMinValue;
279}
280AFX_INLINE BOOL CXTPChartAxisRange::IsViewAutoRange() const
281{
282 return m_bViewAutoRange;
283}
284AFX_INLINE double CXTPChartAxisRange::GetZoomLimit() const
285{
286 return m_dZoomLimit;
287}
288AFX_INLINE void CXTPChartAxisRange::SetZoomLimit(double dZoomLimit)
289{
290 m_dZoomLimit = dZoomLimit;
291}
293# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
294#endif //#if !defined(__XTPCHARTAXISRANGE_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartAxis
This abstract base class represents a chart axis as a kind of chart element.
Definition XTPChartAxis.h:86
CXTPChartAxisRange
This class represents the value range of the axis.
Definition XTPChartAxisRange.h:44
CXTPChartAxisRange::SetShowZeroLevel
void SetShowZeroLevel(BOOL bShowZeroLevel)
Call this function to enable or disable the zero level on the axis.
CXTPChartAxisRange::m_nMaxValue
double m_nMaxValue
The maximum value of the range.
Definition XTPChartAxisRange.h:215
CXTPChartAxisRange::DoPropExchange
void DoPropExchange(CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
CXTPChartAxisRange::SetMinValue
void SetMinValue(double dMinValue)
Call this function to set the minimum value of the axis.
CXTPChartAxisRange::SetMaxValue
void SetMaxValue(double dMaxValue)
Call this function to set the maximum value of the axis.
CXTPChartAxisRange::UpdateRange
void UpdateRange(CXTPChartAxisView *pView)
This function updates the axis, with respect to the series values.
CXTPChartAxisRange::~CXTPChartAxisRange
virtual ~CXTPChartAxisRange()
Destroys a CXTPChartAxisLabel object, handles cleanup.
CXTPChartAxisRange::m_nMinValue
double m_nMinValue
The minimum value of the range.
Definition XTPChartAxisRange.h:214
CXTPChartAxisRange::GetViewMinValue
double GetViewMinValue() const
Call this function to get the minimum value of axis.
Definition XTPChartAxisRange.h:276
CXTPChartAxisRange::GetViewMaxValue
double GetViewMaxValue() const
Call this function to get the maximum value of axis.
Definition XTPChartAxisRange.h:272
CXTPChartAxisRange::SetViewAutoRange
void SetViewAutoRange(BOOL bAutoRange)
Call this function to manually set the min and max values for the range.
CXTPChartAxisRange::GetShowZeroLevel
BOOL GetShowZeroLevel() const
Call this function to check if the zero level is enabled or disabled.
Definition XTPChartAxisRange.h:264
CXTPChartAxisRange::m_pAxis
CXTPChartAxis * m_pAxis
Pointer to chart axis object.
Definition XTPChartAxisRange.h:212
CXTPChartAxisRange::GetMaxValue
double GetMaxValue() const
Call this function to get the maximum value of the axis.
Definition XTPChartAxisRange.h:252
CXTPChartAxisRange::CXTPChartAxisRange
CXTPChartAxisRange(CXTPChartAxis *pAxis)
Constructs a CXTPChartAxisRange object.
CXTPChartAxisRange::m_bShowZeroLevel
BOOL m_bShowZeroLevel
TRUE if the zero level is shown on the axis and FALSE if not.
Definition XTPChartAxisRange.h:217
CXTPChartAxisRange::SetViewMinValue
void SetViewMinValue(double dMinValue)
Call this function to set the minimum value of axis.
CXTPChartAxisRange::GetSideMargins
BOOL GetSideMargins() const
Call this function to check if the side margins are enabled or disabled.
Definition XTPChartAxisRange.h:260
CXTPChartAxisRange::SetViewMaxValue
void SetViewMaxValue(double dMaxValue)
Call this function to set the maximum value of axis.
CXTPChartAxisRange::GetMinValue
double GetMinValue() const
Call this function to get the minimum value of the axis.
Definition XTPChartAxisRange.h:256
CXTPChartAxisRange::SetSideMargins
void SetSideMargins(BOOL bSideMargins)
Call this function to enable or disable the side margins.
CXTPChartAxisRange::SetAutoRange
void SetAutoRange(BOOL bAutoRange)
Call this function to manually set the min and max values for the range.
CXTPChartAxisRange::m_bSideMargins
BOOL m_bSideMargins
TRUE if the side margins are present and FALSE if not.
Definition XTPChartAxisRange.h:216
CXTPChartAxisRange::Correct
void Correct(CXTPChartAxisView *pView)
This function updates range based on the various parameters affecting the axis range (e....
CXTPChartElement
This class abstracts a chart element, this class acts as a base class for all chart elements.
Definition XTPChartElement.h:131
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72


Toolkit Pro: XTPMarkupFrameworkContentElement.h Source File

  • Source
  • Markup
XTPMarkupFrameworkContentElement.h
Go to the documentation of this file.
1
23#if !defined(__XTPMARKUPFRAMEWORKCONTENTELEMENT_H__)
24# define __XTPMARKUPFRAMEWORKCONTENTELEMENT_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPMarkupFrameworkElement;
34
35class _XTP_EXT_CLASS CXTPMarkupFrameworkContentElement : public CXTPMarkupInputElement
36{
38 DECLARE_MARKUPCLASS(CXTPMarkupFrameworkContentElement)
40protected:
41 CXTPMarkupFrameworkContentElement();
42
43public:
44 CXTPMarkupObject* GetTag() const;
45 void SetTag(CXTPMarkupObject* pTag);
46
47public:
48 CXTPMarkupInputElement* InputHitTest(CPoint point) const;
49 CRect GetBoundRect() const;
50 CRect GetUpdateRect() const;
51
52public:
53 CXTPMarkupFrameworkElement* GetParent() const;
54
55protected:
56 virtual void OnPropertyChanged(CXTPMarkupDependencyProperty* pProperty,
57 CXTPMarkupObject* pOldValue, CXTPMarkupObject* pNewValue);
58
59 static void AFX_CDECL OnStylePropertyChanged(CXTPMarkupObject* d,
60 CXTPMarkupPropertyChangedEventArgs* e);
61
62public:
63 static CXTPMarkupDependencyProperty* m_pTagProperty;
64};
65
66# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
68#endif // !defined(__XTPMARKUPFRAMEWORKCONTENTELEMENT_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPMarkupFrameworkElement
This class represents the provided framework-level implementation built on CXTPMarkupUIElement.
Definition XTPMarkupFrameworkElement.h:44


Toolkit Pro: Member List

CXTPChart3dDrawingObjectFactory Member List

This is the complete list of members for CXTPChart3dDrawingObjectFactory, including all inherited members.

Instance() CXTPSingleton< CXTPChart3dDrawingObjectFactory > inlinestatic


Toolkit Pro: XTPMaskEdit.h Source File

  • Source
  • Controls
  • Edit
XTPMaskEdit.h
Go to the documentation of this file.
1
23#if !defined(__XTPMASKEDIT_H__)
24# define __XTPMASKEDIT_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPMaskEdit : public CXTPEdit
39{
41 DECLARE_DYNAMIC(CXTPMaskEdit)
43public:
48 CXTPMaskEdit();
49
60 virtual bool Initialize(CWnd* pParentWnd);
61};
62
68class _XTP_EXT_CLASS CXTPDateEdit : public CXTPMaskEdit
69{
71 DECLARE_DYNAMIC(CXTPDateEdit)
73public:
78 CXTPDateEdit();
79
87 virtual void SetDateTime(COleDateTime& dt);
88
95 virtual void SetDateTime(LPCTSTR strDate);
96
104 virtual COleDateTime GetDateTime();
105
113 virtual CString GetWindowDateTime();
114
123 virtual COleDateTime ReadOleDateTime(LPCTSTR lpszData);
124
134 virtual BOOL ProcessMask(TCHAR& nChar, int nEndPos);
135
143 virtual void FormatOleDateTime(CString& strData, COleDateTime dt);
144};
145
168_XTP_EXT_CLASS void AFXAPI DDX_XTPOleDateTime(CDataExchange* pDX, int nIDC, CXTPDateEdit& rControl,
169 COleDateTime& rDateTime);
170
176class _XTP_EXT_CLASS CXTPTimeEdit : public CXTPDateEdit
177{
179 DECLARE_DYNAMIC(CXTPTimeEdit)
181public:
186 CXTPTimeEdit();
187
188public:
194 virtual void SetHours(int nHours);
195
201 virtual void SetMins(int nMins);
202
210 virtual void SetTime(int nHours, int nMins);
211
219 int GetHours() const;
220
228 int GetMins() const;
229
239 virtual BOOL ProcessMask(TCHAR& nChar, int nEndPos);
240
248 virtual void FormatOleDateTime(CString& strData, COleDateTime dt);
249
255 void SetMilitary(BOOL bMilitary = TRUE);
256
257protected:
258 int m_iHours;
259 int m_iMins;
260 BOOL m_bMilitary;
261};
262
264
265AFX_INLINE int CXTPTimeEdit::GetHours() const
266{
267 return m_iHours;
268}
269AFX_INLINE int CXTPTimeEdit::GetMins() const
270{
271 return m_iMins;
272}
273AFX_INLINE void CXTPTimeEdit::SetMilitary(BOOL bMilitary /*= TRUE*/)
274{
275 m_bMilitary = bMilitary;
276}
278# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
280#endif // #if !defined(__XTPMASKEDIT_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
DDX_XTPOleDateTime
_XTP_EXT_CLASS void AFXAPI DDX_XTPOleDateTime(CDataExchange *pDX, int nIDC, CXTPDateEdit &rControl, COleDateTime &rDateTime)
The DDX_XTPOleDateTime function manages the transfer of integer data between a date edit control,...
CXTPDateEdit
CXTPDateEdit is a CXTPMaskEdit derived class.
Definition XTPMaskEdit.h:69
CXTPDateEdit::SetDateTime
virtual void SetDateTime(COleDateTime &dt)
This member function will set the time based on the text string passed in as 'strDate'.
CXTPDateEdit::SetDateTime
virtual void SetDateTime(LPCTSTR strDate)
This member function will set the time based on the text string passed in as 'strDate'.
CXTPDateEdit::CXTPDateEdit
CXTPDateEdit()
Constructs a CXTPDateEdit object.
CXTPDateEdit::FormatOleDateTime
virtual void FormatOleDateTime(CString &strData, COleDateTime dt)
This member function will read the date passed in as 'dt', and format the 'strData' string as DD/MM/Y...
CXTPDateEdit::ProcessMask
virtual BOOL ProcessMask(TCHAR &nChar, int nEndPos)
This member function is used internally to process the character passed in by 'nChar' whose index is ...
CXTPDateEdit::GetDateTime
virtual COleDateTime GetDateTime()
This member function will retrieve a COleDateTime object that represents the currently displayed date...
CXTPDateEdit::GetWindowDateTime
virtual CString GetWindowDateTime()
This member function will retrieve a CString object that represents the currently displayed date.
CXTPDateEdit::ReadOleDateTime
virtual COleDateTime ReadOleDateTime(LPCTSTR lpszData)
This member function will read the date string passed in as 'lpszData', convert it to a COleDateTime ...
CXTPEdit
CXTPEdit is a CEdit derived class.
Definition XTPEdit.h:129
CXTPMaskEdit
CXTPMaskEdit is a CXTPEdit derived class.
Definition XTPMaskEdit.h:39
CXTPMaskEdit::Initialize
virtual bool Initialize(CWnd *pParentWnd)
Initializes the CXTPMaskEdit control.
CXTPMaskEdit::CXTPMaskEdit
CXTPMaskEdit()
Constructs a CXTPMaskEdit object.
CXTPTimeEdit
CXTPTimeEdit is a CXTPDateEdit derived class.
Definition XTPMaskEdit.h:177
CXTPTimeEdit::SetHours
virtual void SetHours(int nHours)
This member function will update the hours displayed.
CXTPTimeEdit::GetMins
int GetMins() const
This member function will retrieve the minutes displayed for the time edit control.
CXTPTimeEdit::m_bMilitary
BOOL m_bMilitary
true if military time is used.
Definition XTPMaskEdit.h:260
CXTPTimeEdit::CXTPTimeEdit
CXTPTimeEdit()
Constructs a CXTPTimeEdit object.
CXTPTimeEdit::m_iHours
int m_iHours
Represents the hours to display.
Definition XTPMaskEdit.h:258
CXTPTimeEdit::m_iMins
int m_iMins
Represents the minutes to display.
Definition XTPMaskEdit.h:259
CXTPTimeEdit::FormatOleDateTime
virtual void FormatOleDateTime(CString &strData, COleDateTime dt)
This member function will read the time passed in as 'dt', and format the 'strData' string as HH:MM.
CXTPTimeEdit::ProcessMask
virtual BOOL ProcessMask(TCHAR &nChar, int nEndPos)
This member function is used internally to process the character passed in by 'nChar' whose index is ...
CXTPTimeEdit::SetTime
virtual void SetTime(int nHours, int nMins)
This member function will update the hours and minutes that are displayed for the time edit control.
CXTPTimeEdit::GetHours
int GetHours() const
This member function will retrieve the hours displayed for the time edit control.
CXTPTimeEdit::SetMilitary
void SetMilitary(BOOL bMilitary=TRUE)
Sets military time format.
CXTPTimeEdit::SetMins
virtual void SetMins(int nMins)
This member function will update the minutes displayed.


Toolkit Pro: XTPChart3dDeviceContext.h Source File

  • Source
  • Chart
  • Drawing
XTPChart3dDeviceContext.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHART3DDEVICECONTEXT_H__)
24# define __XTPCHART3DDEVICECONTEXT_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartContainer;
34class CXTPChartDeviceCommand;
35class CXTPMarkupUIElement;
36class CXTPChartFont;
37class CXTPChartDrawingObjectFactory;
38class CXTPOpenGLTriangleRenderList;
39
47class _XTP_EXT_CLASS CXTPChart3dDeviceContext : public CXTPChartDeviceContext
48{
49 DECLARE_DYNAMIC(CXTPChart3dDeviceContext);
50
51protected:
61 CXTPChart3dDeviceContext(CXTPChartContainer* pContainer, HDC hDC, CRect rcBounds,
62 CXTPChartDrawingObjectFactory* pDrawingObjectFactory);
63
64public:
69 ~CXTPChart3dDeviceContext();
70
77 virtual void Rotate(const CXTPChart3dRotation& rotation) = 0;
78
94 virtual BOOL Project(const CXTPPoint3d& pt3d, CPoint& pt2d, double* pdWinZ = NULL) = 0;
95
108 virtual BOOL Project(const CXTPChart3dBox& box, CRect& rc) = 0;
109
126 virtual BOOL Unproject(const CPoint& pt2d, CXTPPoint3d& pt3d, double dWinZ = 0) = 0;
127
136 virtual void Transform(CXTPPoint3d& v, const CXTPPoint3d* pTranslation = NULL,
137 const CXTPChart3dRotation* pRotation = NULL) = 0;
138
147 virtual void Transform(CXTPChart3dBox& box, const CXTPPoint3d* pTranslation = NULL,
148 const CXTPChart3dRotation* pRotation = NULL) = 0;
149
160 virtual BOOL DepthTest(CPoint point, double& dWinZ) = 0;
161
168 const CRect& GetBounds() const;
169
179 BOOL IsRenderingAntialiasing() const;
180
190 BOOL IsSkippingAntialiasing() const;
191
200 void OnUpdateCameraState(const CXTPPoint3f& ptPosition, const CXTPPoint3f& ptFocal,
201 const CXTPPoint3f& ptUpVector);
202
210 void SetModelDistanceLimits(float fMinDistance, float fMaxDistance);
211
219 void SetLightPosition(const CXTPPoint3f& position);
220
228 const CXTPPoint3f& GetLightPosition() const;
229
236 void SetLightAmbientColor(const CXTPChartColor& color);
237
244 const CXTPChartColor& GetLightAmbientColor() const;
245
252 void SetLightDiffuseColor(const CXTPChartColor& color);
253
260 const CXTPChartColor& GetLightDiffuseColor() const;
261
268 void SetLightSpecularColor(const CXTPChartColor& color);
269
276 const CXTPChartColor& GetLightSpecularColor() const;
277
284 void SetLightModelAmbientColor(const CXTPChartColor& color);
285
292 const CXTPChartColor& GetLightModelAmbientColor() const;
293
300 void SetMaterialEmissionColor(const CXTPChartColor& color);
301
308 const CXTPChartColor& GetMaterialEmissionColor() const;
309
316 void SetMaterialDiffuseColor(const CXTPChartColor& color);
317
324 const CXTPChartColor& GetMaterialDiffuseColor() const;
325
332 void SetMaterialSpecularColor(const CXTPChartColor& color);
333
340 const CXTPChartColor& GetMaterialSpecularColor() const;
341
348 void SetMaterialShininess(float fShininess);
349
356 float GetMaterialShininess() const;
357
364 BOOL GetAntialiasing() const;
365
372 void SetAntialiasing(BOOL bEnable = TRUE);
373
375 BOOL IsInitialPass() const;
376 CXTPOpenGLTriangleRenderList& GetTriangleRenderList();
379protected:
384 void ResetSavedCameraState();
385
386protected:
387 const CRect m_rcBounds;
388 BOOL m_bRenderingAntialiasing;
389 BOOL m_bSkippingAntialiasing;
391 struct CameraState
392 {
393 CXTPPoint3f ptPosition;
394 CXTPPoint3f ptFocal;
395 CXTPPoint3f ptUpVector;
396 } m_cameraState;
398 float m_fMinModelDistance;
399 float m_fMaxModelDistance;
401 CXTPPoint3f m_ptLightPosition;
403 CXTPChartColor m_clrLightAmbientColor;
404 CXTPChartColor m_clrLightDiffuseColor;
405 CXTPChartColor m_clrLightSpecularColor;
406 CXTPChartColor m_clrLightModelAmbientColor;
407 CXTPChartColor m_clrMaterialEmissionColor;
408 CXTPChartColor m_clrMaterialDiffuseColor;
409 CXTPChartColor m_clrMaterialSpecularColor;
410 float m_fMaterialShininess;
411 BOOL m_bAntialiasing;
412 BOOL m_bInitialPass;
414 CXTPOpenGLTriangleRenderList* m_pTriangles;
415};
416
417AFX_INLINE const CRect& CXTPChart3dDeviceContext::GetBounds() const
418{
419 return m_rcBounds;
420}
421
422AFX_INLINE BOOL CXTPChart3dDeviceContext::IsRenderingAntialiasing() const
423{
424 return m_bRenderingAntialiasing;
425}
426
427AFX_INLINE BOOL CXTPChart3dDeviceContext::IsSkippingAntialiasing() const
428{
429 return m_bSkippingAntialiasing;
430}
431
432AFX_INLINE void CXTPChart3dDeviceContext::SetModelDistanceLimits(float fMinDistance,
433 float fMaxDistance)
434{
435 m_fMinModelDistance = fMinDistance;
436 m_fMaxModelDistance = fMaxDistance;
437}
438
439AFX_INLINE void CXTPChart3dDeviceContext::SetLightPosition(const CXTPPoint3f& position)
440{
441 m_ptLightPosition = position;
442}
443
444AFX_INLINE const CXTPPoint3f& CXTPChart3dDeviceContext::GetLightPosition() const
445{
446 return m_ptLightPosition;
447}
448
449AFX_INLINE void CXTPChart3dDeviceContext::SetLightAmbientColor(const CXTPChartColor& color)
450{
451 m_clrLightAmbientColor = color;
452}
453
454AFX_INLINE const CXTPChartColor& CXTPChart3dDeviceContext::GetLightAmbientColor() const
455{
456 return m_clrLightAmbientColor;
457}
458
459AFX_INLINE void CXTPChart3dDeviceContext::SetLightDiffuseColor(const CXTPChartColor& color)
460{
461 m_clrLightDiffuseColor = color;
462}
463
464AFX_INLINE const CXTPChartColor& CXTPChart3dDeviceContext::GetLightDiffuseColor() const
465{
466 return m_clrLightDiffuseColor;
467}
468
469AFX_INLINE void CXTPChart3dDeviceContext::SetLightSpecularColor(const CXTPChartColor& color)
470{
471 m_clrLightSpecularColor = color;
472}
473
474AFX_INLINE const CXTPChartColor& CXTPChart3dDeviceContext::GetLightSpecularColor() const
475{
476 return m_clrLightSpecularColor;
477}
478
479AFX_INLINE void CXTPChart3dDeviceContext::SetLightModelAmbientColor(const CXTPChartColor& color)
480{
481 m_clrLightModelAmbientColor = color;
482}
483
484AFX_INLINE const CXTPChartColor& CXTPChart3dDeviceContext::GetLightModelAmbientColor() const
485{
486 return m_clrLightModelAmbientColor;
487}
488
489AFX_INLINE void CXTPChart3dDeviceContext::SetMaterialEmissionColor(const CXTPChartColor& color)
490{
491 m_clrMaterialEmissionColor = color;
492}
493
494AFX_INLINE const CXTPChartColor& CXTPChart3dDeviceContext::GetMaterialEmissionColor() const
495{
496 return m_clrMaterialEmissionColor;
497}
498
499AFX_INLINE void CXTPChart3dDeviceContext::SetMaterialDiffuseColor(const CXTPChartColor& color)
500{
501 m_clrMaterialDiffuseColor = color;
502}
503
504AFX_INLINE const CXTPChartColor& CXTPChart3dDeviceContext::GetMaterialDiffuseColor() const
505{
506 return m_clrMaterialDiffuseColor;
507}
508
509AFX_INLINE void CXTPChart3dDeviceContext::SetMaterialSpecularColor(const CXTPChartColor& color)
510{
511 m_clrMaterialSpecularColor = color;
512}
513
514AFX_INLINE const CXTPChartColor& CXTPChart3dDeviceContext::GetMaterialSpecularColor() const
515{
516 return m_clrMaterialSpecularColor;
517}
518
519AFX_INLINE void CXTPChart3dDeviceContext::SetMaterialShininess(float fShininess)
520{
521 m_fMaterialShininess = fShininess;
522}
523
524AFX_INLINE float CXTPChart3dDeviceContext::GetMaterialShininess() const
525{
526 return m_fMaterialShininess;
527}
529AFX_INLINE BOOL CXTPChart3dDeviceContext::IsInitialPass() const
530{
531 return m_bInitialPass;
532}
533
534AFX_INLINE CXTPOpenGLTriangleRenderList& CXTPChart3dDeviceContext::GetTriangleRenderList()
535{
536 return *m_pTriangles;
537}
539AFX_INLINE BOOL CXTPChart3dDeviceContext::GetAntialiasing() const
540{
541 return m_bAntialiasing;
542}
543
544AFX_INLINE void CXTPChart3dDeviceContext::SetAntialiasing(BOOL bAntialiasing)
545{
546 m_bAntialiasing = bAntialiasing;
547}
549# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
550#endif //#if !defined(__XTPCHART3DDEVICECONTEXT_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChart3dBox
Represents a 3D box build around included points and provides useful and fast operations.
Definition XTPChartTypes.h:728
CXTPChart3dDeviceContext
A base implementation of 3D device context.
Definition XTPChart3dDeviceContext.h:48
CXTPChart3dDeviceContext::m_ptLightPosition
CXTPPoint3f m_ptLightPosition
Light position vector, each component is a normalized value in range [0..1].
Definition XTPChart3dDeviceContext.h:401
CXTPChart3dDeviceContext::CXTPChart3dDeviceContext
CXTPChart3dDeviceContext(CXTPChartContainer *pContainer, HDC hDC, CRect rcBounds, CXTPChartDrawingObjectFactory *pDrawingObjectFactory)
Constructs a CXTPChart3dDeviceContext object.
CXTPChart3dDeviceContext::GetLightAmbientColor
const CXTPChartColor & GetLightAmbientColor() const
Sets/obtains light ambient color.
Definition XTPChart3dDeviceContext.h:454
CXTPChart3dDeviceContext::m_bInitialPass
BOOL m_bInitialPass
TRUE if the command tree is executed the very first time.
Definition XTPChart3dDeviceContext.h:412
CXTPChart3dDeviceContext::SetMaterialShininess
void SetMaterialShininess(float fShininess)
Sets/obtains material shininess factor, a value within range [0..1].
Definition XTPChart3dDeviceContext.h:519
CXTPChart3dDeviceContext::GetMaterialSpecularColor
const CXTPChartColor & GetMaterialSpecularColor() const
Sets/obtains material specular color.
Definition XTPChart3dDeviceContext.h:514
CXTPChart3dDeviceContext::SetAntialiasing
void SetAntialiasing(BOOL bEnable=TRUE)
Enables/disables antialiasing if supported.
Definition XTPChart3dDeviceContext.h:544
CXTPChart3dDeviceContext::m_bSkippingAntialiasing
BOOL m_bSkippingAntialiasing
TRUE if skipping anti-aliasing rendering
Definition XTPChart3dDeviceContext.h:389
CXTPChart3dDeviceContext::SetLightAmbientColor
void SetLightAmbientColor(const CXTPChartColor &color)
Sets/obtains light ambient color.
Definition XTPChart3dDeviceContext.h:449
CXTPChart3dDeviceContext::Project
virtual BOOL Project(const CXTPPoint3d &pt3d, CPoint &pt2d, double *pdWinZ=NULL)=0
Projects 3D coordinates to 2D space point coordinates.
CXTPChart3dDeviceContext::GetMaterialEmissionColor
const CXTPChartColor & GetMaterialEmissionColor() const
Sets/obtains material emission color.
Definition XTPChart3dDeviceContext.h:494
CXTPChart3dDeviceContext::GetMaterialDiffuseColor
const CXTPChartColor & GetMaterialDiffuseColor() const
Sets/obtains material diffuse color.
Definition XTPChart3dDeviceContext.h:504
CXTPChart3dDeviceContext::DepthTest
virtual BOOL DepthTest(CPoint point, double &dWinZ)=0
Performs depth dest for 2D point provided.
CXTPChart3dDeviceContext::OnUpdateCameraState
void OnUpdateCameraState(const CXTPPoint3f &ptPosition, const CXTPPoint3f &ptFocal, const CXTPPoint3f &ptUpVector)
Is called when the camera state is updated.
CXTPChart3dDeviceContext::GetLightDiffuseColor
const CXTPChartColor & GetLightDiffuseColor() const
Sets/obtains light diffuse color.
Definition XTPChart3dDeviceContext.h:464
CXTPChart3dDeviceContext::SetLightPosition
void SetLightPosition(const CXTPPoint3f &position)
Sets/obtains light position normalized vector where each component is within range [0....
Definition XTPChart3dDeviceContext.h:439
CXTPChart3dDeviceContext::Transform
virtual void Transform(CXTPPoint3d &v, const CXTPPoint3d *pTranslation=NULL, const CXTPChart3dRotation *pRotation=NULL)=0
Transforms vector or box coordinates.
CXTPChart3dDeviceContext::m_clrMaterialEmissionColor
CXTPChartColor m_clrMaterialEmissionColor
Material emission color.
Definition XTPChart3dDeviceContext.h:407
CXTPChart3dDeviceContext::SetMaterialDiffuseColor
void SetMaterialDiffuseColor(const CXTPChartColor &color)
Sets/obtains material diffuse color.
Definition XTPChart3dDeviceContext.h:499
CXTPChart3dDeviceContext::IsRenderingAntialiasing
BOOL IsRenderingAntialiasing() const
Checks if the device context is currently rendering anti-aliasing.
Definition XTPChart3dDeviceContext.h:422
CXTPChart3dDeviceContext::~CXTPChart3dDeviceContext
~CXTPChart3dDeviceContext()
Destroys a CXTPChartDeviceContext object, handles cleanup.
CXTPChart3dDeviceContext::m_clrLightAmbientColor
CXTPChartColor m_clrLightAmbientColor
Light ambient color.
Definition XTPChart3dDeviceContext.h:403
CXTPChart3dDeviceContext::SetLightDiffuseColor
void SetLightDiffuseColor(const CXTPChartColor &color)
Sets/obtains light diffuse color.
Definition XTPChart3dDeviceContext.h:459
CXTPChart3dDeviceContext::GetMaterialShininess
float GetMaterialShininess() const
Sets/obtains material shininess factor, a value within range [0..1].
Definition XTPChart3dDeviceContext.h:524
CXTPChart3dDeviceContext::Project
virtual BOOL Project(const CXTPChart3dBox &box, CRect &rc)=0
Projects 3D coordinates to 2D space point coordinates.
CXTPChart3dDeviceContext::GetLightPosition
const CXTPPoint3f & GetLightPosition() const
Sets/obtains light position normalized vector where each component is within range [0....
Definition XTPChart3dDeviceContext.h:444
CXTPChart3dDeviceContext::Transform
virtual void Transform(CXTPChart3dBox &box, const CXTPPoint3d *pTranslation=NULL, const CXTPChart3dRotation *pRotation=NULL)=0
Transforms vector or box coordinates.
CXTPChart3dDeviceContext::SetMaterialEmissionColor
void SetMaterialEmissionColor(const CXTPChartColor &color)
Sets/obtains material emission color.
Definition XTPChart3dDeviceContext.h:489
CXTPChart3dDeviceContext::m_clrLightDiffuseColor
CXTPChartColor m_clrLightDiffuseColor
Light diffuse color.
Definition XTPChart3dDeviceContext.h:404
CXTPChart3dDeviceContext::SetModelDistanceLimits
void SetModelDistanceLimits(float fMinDistance, float fMaxDistance)
Sets limits for distance between view point and scene center point.
Definition XTPChart3dDeviceContext.h:432
CXTPChart3dDeviceContext::SetMaterialSpecularColor
void SetMaterialSpecularColor(const CXTPChartColor &color)
Sets/obtains material specular color.
Definition XTPChart3dDeviceContext.h:509
CXTPChart3dDeviceContext::m_fMinModelDistance
float m_fMinModelDistance
Minimal distance allowed to the center of the scene.
Definition XTPChart3dDeviceContext.h:398
CXTPChart3dDeviceContext::GetBounds
const CRect & GetBounds() const
Obtains the device contains boundary rectangle.
Definition XTPChart3dDeviceContext.h:417
CXTPChart3dDeviceContext::m_fMaterialShininess
float m_fMaterialShininess
Material shininess factor in range [0..1].
Definition XTPChart3dDeviceContext.h:410
CXTPChart3dDeviceContext::GetLightModelAmbientColor
const CXTPChartColor & GetLightModelAmbientColor() const
Sets/obtains light model ambient color.
Definition XTPChart3dDeviceContext.h:484
CXTPChart3dDeviceContext::SetLightModelAmbientColor
void SetLightModelAmbientColor(const CXTPChartColor &color)
Sets/obtains light model ambient color.
Definition XTPChart3dDeviceContext.h:479
CXTPChart3dDeviceContext::m_fMaxModelDistance
float m_fMaxModelDistance
Maximum distance allowed to the center of the scene.
Definition XTPChart3dDeviceContext.h:399
CXTPChart3dDeviceContext::m_rcBounds
const CRect m_rcBounds
Device context bounary rectangle.
Definition XTPChart3dDeviceContext.h:387
CXTPChart3dDeviceContext::m_clrLightModelAmbientColor
CXTPChartColor m_clrLightModelAmbientColor
Light model ambient color.
Definition XTPChart3dDeviceContext.h:406
CXTPChart3dDeviceContext::m_clrMaterialSpecularColor
CXTPChartColor m_clrMaterialSpecularColor
Material specular color.
Definition XTPChart3dDeviceContext.h:409
CXTPChart3dDeviceContext::GetLightSpecularColor
const CXTPChartColor & GetLightSpecularColor() const
Sets/obtains light specular color.
Definition XTPChart3dDeviceContext.h:474
CXTPChart3dDeviceContext::SetLightSpecularColor
void SetLightSpecularColor(const CXTPChartColor &color)
Sets/obtains light specular color.
Definition XTPChart3dDeviceContext.h:469
CXTPChart3dDeviceContext::Unproject
virtual BOOL Unproject(const CPoint &pt2d, CXTPPoint3d &pt3d, double dWinZ=0)=0
Projects 2D space point coordinates to 3D space point coordinate on the specified plane.
CXTPChart3dDeviceContext::m_bRenderingAntialiasing
BOOL m_bRenderingAntialiasing
TRUE if currently rendering anti-aliasing.
Definition XTPChart3dDeviceContext.h:388
CXTPChart3dDeviceContext::Rotate
virtual void Rotate(const CXTPChart3dRotation &rotation)=0
Rotates current matrix.
CXTPChart3dDeviceContext::m_clrLightSpecularColor
CXTPChartColor m_clrLightSpecularColor
Light specular color.
Definition XTPChart3dDeviceContext.h:405
CXTPChart3dDeviceContext::ResetSavedCameraState
void ResetSavedCameraState()
Resets saved camera state to default zero values.
CXTPChart3dDeviceContext::m_clrMaterialDiffuseColor
CXTPChartColor m_clrMaterialDiffuseColor
Material diffuse color.
Definition XTPChart3dDeviceContext.h:408
CXTPChart3dDeviceContext::m_bAntialiasing
BOOL m_bAntialiasing
Antialiasing flag
Definition XTPChart3dDeviceContext.h:411
CXTPChart3dDeviceContext::IsSkippingAntialiasing
BOOL IsSkippingAntialiasing() const
Checks if the device context is skipping anti-aliasing rendering.
Definition XTPChart3dDeviceContext.h:427
CXTPChart3dDeviceContext::GetAntialiasing
BOOL GetAntialiasing() const
Enables/disables antialiasing if supported.
Definition XTPChart3dDeviceContext.h:539
CXTPChart3dRotation
Represents a 3D rotation primitive for chart objects using Euler angles Yaw, Pitch and Roll in degree...
Definition XTPChartTypes.h:639
CXTPChartColor
This class abstracts a color entity.
Definition XTPChartTypes.h:51
CXTPChartContainer
This class represents the chart container.
Definition XTPChartElement.h:232
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartDrawingObjectFactory
Provides a set of factory methods for creating drawing device commands and a base class interface for...
Definition XTPChartDrawingObjectFactory.h:55
CXTPChartFont
This class abstracts a font entity.
Definition XTPChartTypes.h:540
CXTPMarkupUIElement
Base class for XML Markup core level implementations.
Definition XTPMarkupUIElement.h:43
CXTPPoint3T< double >


Toolkit Pro: XTPTabThemeStateButtons.h Source File

  • Source
  • TabManager
  • Themes
XTPTabThemeStateButtons.h
Go to the documentation of this file.
1
23#if !defined(__XTPTABTHEMESTATEBUTTONS_H__)
24# define __XTPTABTHEMESTATEBUTTONS_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
50class _XTP_EXT_CLASS CAppearanceSetStateButtons : public CXTPTabPaintManagerTheme
51{
52public:
57 CAppearanceSetStateButtons()
58 {
59 m_rcHeaderMargin.SetRect(2, 2, 4, 2);
60 m_nRowMargin = 0;
61 }
62
78 virtual void DrawSingleButton(CDC* pDC, CXTPTabManagerItem* pItem);
79
99 virtual CRect FillTabControl(CXTPTabManager* pTabManager, CDC* pDC, CRect rcControl);
100
109 virtual XTPTabColorStyle GetDefaultColorSet()
110 {
111 return xtpTabColorVisualStudio2003;
112 }
113};
114
115# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
117#endif // !defined(__XTPTABTHEMESTATEBUTTONS_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPTabColorStyle
XTPTabColorStyle
XTPTabColorStyle is an enumeration used to set the color style of tabs.
Definition XTPTabManagerDefines.h:139
xtpTabColorVisualStudio2003
@ xtpTabColorVisualStudio2003
Tabs will use the Visual Studio 2003 color style for the currently set Appearance.
Definition XTPTabManagerDefines.h:150
CAppearanceSetStateButtons
CAppearanceSetStateButtons implements a "State Button" tab appearance.
Definition XTPTabThemeStateButtons.h:51
CAppearanceSetStateButtons::GetDefaultColorSet
virtual XTPTabColorStyle GetDefaultColorSet()
Gets the default value of the color set for this theme.
Definition XTPTabThemeStateButtons.h:109
CAppearanceSetStateButtons::FillTabControl
virtual CRect FillTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl)
Fills both the tab header and the tab client area and then draws the tab client frame.
CAppearanceSetStateButtons::CAppearanceSetStateButtons
CAppearanceSetStateButtons()
Constructs a CAppearanceSetStateButtons object.
Definition XTPTabThemeStateButtons.h:57
CAppearanceSetStateButtons::DrawSingleButton
virtual void DrawSingleButton(CDC *pDC, CXTPTabManagerItem *pItem)
Draws a single tab button in the tab client header area.
CXTPTabManager
CXTPTabManager is the base class for docking pane tabs, tab control tabs, and MDI client tabs.
Definition XTPTabManager.h:87
CXTPTabManagerItem
CXTPTabManagerItem is the base class for the tabs that appear in the command bars tab workspace,...
Definition XTPTabManagerItem.h:44
CXTPTabPaintManagerTheme
CXTPTabPaintManagerTheme is a class that represents the appearance of all components of the tab manag...
Definition XTPTabPaintManagerTheme.h:56


Toolkit Pro: XTPMarkupDrawingContext.h Source File

  • Source
  • Markup
XTPMarkupDrawingContext.h
Go to the documentation of this file.
1
23#if !defined(__XTPMARKUPDRAWINGCONTEXT_H__)
24# define __XTPMARKUPDRAWINGCONTEXT_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPMarkupDeviceContext;
34class CXTPMarkupPathData;
35class CXTPMarkupDoubleCollection;
36class CXTPMarkupContext;
37class CXTPMarkupBrush;
38class CXTPMarkupThickness;
39class CXTPMarkupTransformationMatrix;
40class CXTPMarkupDeviceDependentImage;
41class CXTPImageManagerIcon;
42struct XTPMarkupFontMetrics;
43
44namespace Gdiplus
45{
46class GpGraphics;
47class Graphics;
48} // namespace Gdiplus
49
50class _XTP_EXT_CLASS CXTPMarkupStrokeStyle
51{
52public:
53 int nStrokeThickness;
54 CXTPMarkupBrush* pStrokeBrush;
55 CXTPMarkupDoubleCollection* pStrokeDashArray;
56 XTPMarkupLineCap nStrokeStartLineCap;
57 XTPMarkupLineCap nStrokeEndLineCap;
58 XTPMarkupLineJoin nStrokeLineJoin;
59};
60
61class _XTP_EXT_CLASS CXTPMarkupBrush : public CXTPMarkupObject
62{
63 DECLARE_MARKUPCLASS(CXTPMarkupBrush);
64
65protected:
66 CXTPMarkupBrush();
67
68public:
69 CXTPMarkupObject* ConvertFrom(CXTPMarkupBuilder* pBuilder, CXTPMarkupObject* pObject) const;
70
71public:
72 virtual COLORREF GetHintColor() const;
73
75public:
76 DECLARE_DISPATCH_MAP()
77# ifdef _XTP_ACTIVEX
78 DECLARE_INTERFACE_MAP()
79 DECLARE_OLETYPELIB_EX(CXTPMarkupBrush);
80# endif
81
83};
84
85class _XTP_EXT_CLASS CXTPMarkupBrushKey : public CXTPMarkupObject
86{
87 DECLARE_MARKUPCLASS(CXTPMarkupBrushKey);
88
89public:
90 CXTPMarkupBrushKey(int nIndex = 0);
91
92public:
93 int m_nIndex;
94};
95
96class _XTP_EXT_CLASS CXTPMarkupSolidColorBrush : public CXTPMarkupBrush
97{
98 DECLARE_MARKUPCLASS(CXTPMarkupSolidColorBrush);
99
100public:
101 CXTPMarkupSolidColorBrush();
102 CXTPMarkupSolidColorBrush(COLORREF clr);
103 CXTPMarkupSolidColorBrush(BYTE bAlpha, COLORREF clr);
104
105public:
106 COLORREF GetHintColor() const;
107 CXTPMarkupColor* GetColor() const;
108
109public:
110 BOOL IsEqual(const CXTPMarkupObject* pObject) const;
111
113public:
114 DECLARE_DISPATCH_MAP()
115# ifdef _XTP_ACTIVEX
116 DECLARE_INTERFACE_MAP()
117 DECLARE_OLETYPELIB_EX(CXTPMarkupSolidColorBrush);
118# endif
119
120 afx_msg COLORREF OleGetColor();
121 afx_msg void OleSetColor(COLORREF clr);
124protected:
125 static CXTPMarkupDependencyProperty* m_pColorProperty;
126};
127
128class _XTP_EXT_CLASS CXTPMarkupGradientStop : public CXTPMarkupObject
129{
130 DECLARE_MARKUPCLASS(CXTPMarkupGradientStop);
131
132public:
133 CXTPMarkupGradientStop();
134 CXTPMarkupGradientStop(COLORREF clr, double dOffset = 0);
135
136public:
137 COLORREF GetColor() const;
138 double GetOffset() const;
139
140protected:
141protected:
142 static CXTPMarkupDependencyProperty* m_pColorProperty;
143 static CXTPMarkupDependencyProperty* m_pOffsetProperty;
144};
145
146class _XTP_EXT_CLASS CXTPMarkupGradientStops : public CXTPMarkupCollection
147{
148 DECLARE_MARKUPCLASS(CXTPMarkupGradientStops);
149
150public:
151 CXTPMarkupGradientStops();
152
153public:
154 CXTPMarkupGradientStop* GetItem(int nIndex) const;
155};
156
157class _XTP_EXT_CLASS CXTPMarkupPoint : public CXTPMarkupObject
158{
160 DECLARE_MARKUPCLASS(CXTPMarkupPoint);
163public:
164 CXTPMarkupPoint();
165 CXTPMarkupPoint(double x, double y);
166
167public:
168 CXTPMarkupPoint& operator=(const CXTPMarkupPoint& srcPoint);
169
170protected:
171 CXTPMarkupObject* ConvertFrom(CXTPMarkupBuilder* pBuilder, CXTPMarkupObject* pObject) const;
172
173public:
174 double x;
175 double y;
176};
177
178class _XTP_EXT_CLASS CXTPMarkupPointCollection : public CXTPMarkupObject
179{
181 DECLARE_MARKUPCLASS(CXTPMarkupPointCollection)
183public:
184 typedef CArray<Gdiplus::GpPointF, Gdiplus::GpPointF&> CPointArray;
185
186public:
187 CXTPMarkupPointCollection();
188 CXTPMarkupPointCollection(CPointArray& arr);
189
190public:
191 CRect GetBounds() const;
192 const CPointArray& GetPoints() const;
193
194 void Stretch(CPointArray& arr, CSize sz);
195
196 static BOOL AFX_CDECL ConvertFromString(CXTPMarkupContext* pCtx, LPCWSTR lpszValue,
197 CPointArray& arr);
198
199protected:
200 CXTPMarkupObject* ConvertFrom(CXTPMarkupBuilder* pBuilder, CXTPMarkupObject* pObject) const;
201 static BOOL AFX_CDECL ConvertFromString(CXTPMarkupBuilder* pBuilder, LPCWSTR lpszValue,
202 CPointArray& arr);
203 static BOOL AFX_CDECL GetNextValue(LPCWSTR& lpszValue, float& dValue);
204
205protected:
206 CPointArray m_arrPoints;
207 CRect m_rcBounds;
208};
209
210enum XTPMarkupBrushMappingMode
211{
212 xtpMarkupBrushMappingModeAbsolute,
213 xtpMarkupBrushMappingModeRelativeToBoundingBox
214};
215
216class _XTP_EXT_CLASS CXTPMarkupGradientBrush : public CXTPMarkupBrush
217{
218public:
219 DECLARE_MARKUPCLASS(CXTPMarkupGradientBrush);
220
221public:
222 CXTPMarkupGradientBrush();
223 ~CXTPMarkupGradientBrush();
224
225public:
226 CXTPMarkupEnum* GetMappingMode() const;
227
228public:
229 static CXTPMarkupDependencyProperty* m_pMappingModeProperty;
230};
231
232class _XTP_EXT_CLASS CXTPMarkupLinearGradientBrush : public CXTPMarkupGradientBrush
233{
234public:
235 DECLARE_MARKUPCLASS(CXTPMarkupLinearGradientBrush);
236
237public:
238 CXTPMarkupLinearGradientBrush();
239 CXTPMarkupLinearGradientBrush(CXTPMarkupGradientStops* pGradientStops);
240 ~CXTPMarkupLinearGradientBrush();
241
242public:
243 CXTPMarkupGradientStops* GetGradientStops() const;
244 void SetStartPoint(double x, double y);
245 void SetEndPoint(double x, double y);
246
247 COLORREF GetHintColor() const;
248
249protected:
250 void SetContentObject(CXTPMarkupBuilder* pBuilder, CXTPMarkupObject* pContent);
251
252public:
253 static CXTPMarkupDependencyProperty* m_pStartPointProperty;
254 static CXTPMarkupDependencyProperty* m_pEndPointProperty;
255 static CXTPMarkupDependencyProperty* m_pGradientStopsProperty;
256};
257
258class _XTP_EXT_CLASS CXTPMarkupFont : public CXTPMarkupObject
259{
260public:
261 CXTPMarkupFont();
262 ~CXTPMarkupFont();
263
264public:
265 CXTPFont m_Font;
266 CXTPMarkupFont* m_pNextChain;
267 CXTPMarkupContext* m_pMarkupContext;
268};
269
270class _XTP_EXT_CLASS CXTPMarkupDrawingContext
271{
272public:
273 CXTPMarkupDrawingContext(CXTPMarkupContext* pMarkupContext, HDC hDC, HDC hAttribDC = 0);
274 CXTPMarkupDrawingContext(CXTPMarkupContext* pMarkupContext);
275 CXTPMarkupDrawingContext(CXTPMarkupContext* pMarkupContext, Gdiplus::GpGraphics* pGpGraphics);
276 CXTPMarkupDrawingContext(CXTPMarkupContext* pMarkupContext, Gdiplus::Graphics* pGraphics);
277 CXTPMarkupDrawingContext(HDC hDC);
278 CXTPMarkupDrawingContext();
279
280public:
281 virtual ~CXTPMarkupDrawingContext();
282
283protected:
284 void Init(CXTPMarkupContext* pMarkupContext);
285
286public:
287 void DrawFrame(CRect rc, CXTPMarkupBrush* pBrush);
288 void FillSolidRect(CRect rc, COLORREF clr);
289
290 void SetFont(CXTPMarkupFont* pFont);
291 void SetTextColor(CXTPMarkupBrush* pBrush);
292
293 double GetOpacity() const;
294 void SetOpacity(double dOpacity) const;
295
296 HDC Detach();
297
298 CXTPMarkupTransformationMatrix* GetTransformationMatrix() const;
299 void SetTransformationMatrix(CXTPMarkupTransformationMatrix* pMatrix);
300
301 void OffsetViewport(const POINT& ptViewortOrg);
302 XTPMarkupSmoothingMode SetSmoothingMode(XTPMarkupSmoothingMode smoothingMode);
303 XTPMarkupSmoothingMode SetSmoothingMode(XTPMarkupSmoothingMode smoothingMode,
304 BOOL bUseTextSmoothing);
305
306 void SetUseTextSmoothing(BOOL bUseTextSmoothing);
307 BOOL GetUseTextSmoothing() const;
308
310 _XTP_DEPRECATED_IN_FAVOR(SetUseTextSmoothing)
311 void SetUseTextSmooting(BOOL bUseTextSmoothing);
312
313 _XTP_DEPRECATED_IN_FAVOR(GetUseTextSmoothing)
314 BOOL GetUseTextSmooting() const;
317 RECT GetClipBox() const;
318 HRGN SaveClipRegion();
319 void RestoreClipRegion(HRGN hrgnClip);
320 void IntersectClipRect(const RECT& rcLayoutClip);
321
322 virtual BOOL IsPrinting() const;
323
324 BOOL GetFontMetrics(CXTPMarkupFont* pFont, XTPMarkupFontMetrics* pMetrics);
325 SIZE GetTextExtent(LPCWSTR lpszText, int nCount) const;
326 void GetTextExtent(LPCWSTR lpszText, int nCount, CXTPSizeF& size) const;
327 virtual void DrawTextLine(LPCWSTR lpszText, UINT nCount, LPCRECT lpRect);
328
329 CXTPMarkupDeviceContext* GetDeviceContext();
330 HDC GetDC();
331 void ReleaseDC(HDC hDC);
332
333public:
334 static void AFX_CDECL Register(BOOL bInit);
335
336public:
337 void Ellipse(CRect rc, CXTPMarkupStrokeStyle* pStrokeStyle, CXTPMarkupBrush* pFillBrush);
338 void DrawRectangle(CRect rc, CXTPMarkupBrush* pBrush, CXTPMarkupThickness* pThickness,
339 double* pCornerRadius = 0);
340 void FillRectangle(CRect rc, CXTPMarkupBrush* pBrush, double* pCornerRadius = 0);
341 void DrawLine(int x1, int y1, int x2, int y2, CXTPMarkupStrokeStyle* pStrokeStyle);
342 void Polyline(const POINT* points, int nCount, CXTPMarkupStrokeStyle* pStrokeStyle);
343 void Polyline(const void* points, int nCount, CXTPMarkupStrokeStyle* pStrokeStyle);
344 void Polygon(const POINT* points, int nCount, CXTPMarkupStrokeStyle* pStrokeStyle,
345 CXTPMarkupBrush* pFillBrush);
346 void Polygon(const void* points, int nCount, CXTPMarkupStrokeStyle* pStrokeStyle,
347 CXTPMarkupBrush* pFillBrush);
348 void DrawPath(CXTPMarkupPathData* pData, CXTPMarkupStrokeStyle* pStrokeStyle,
349 CXTPMarkupBrush* pFillBrush);
350
351 void DrawImage(CXTPImageManagerIcon* pIcon, CRect rc);
352 void DrawImage(CXTPMarkupDeviceDependentImage* pImage, CRect rc);
353
354public:
355 HDWP m_hDWP;
356
357protected:
358 HDC m_hDC;
359 HDC m_hAttribDC;
360
361 CXTPMarkupFont* m_pSelectedFont;
362 HFONT m_hOldFont;
363 CRect m_rcClipBox;
364 BOOL m_bDeleteDC;
365
366 CXTPMarkupDeviceContext* m_pDeviceContext;
367
368 CXTPMarkupContext* m_pMarkupContext;
369 BOOL m_bUseTextSmoothing;
370};
371
372class _XTP_EXT_CLASS CXTPMarkupPrintingContext : public CXTPMarkupDrawingContext
373{
374public:
375 CXTPMarkupPrintingContext(CXTPMarkupContext* pMarkupContext, HDC hDC, HDC hAttribDC);
376 CXTPMarkupPrintingContext(HDC hDC, HDC hAttribDC);
377
378public:
379 virtual BOOL IsPrinting() const;
380
381protected:
382};
383
384AFX_INLINE BOOL CXTPMarkupDrawingContext::IsPrinting() const
385{
386 return FALSE;
387}
388
389AFX_INLINE BOOL CXTPMarkupPrintingContext::IsPrinting() const
390{
391 return TRUE;
392}
393
394AFX_INLINE RECT CXTPMarkupDrawingContext::GetClipBox() const
395{
396 return m_rcClipBox;
397}
398
399AFX_INLINE CXTPMarkupDeviceContext* CXTPMarkupDrawingContext::GetDeviceContext()
400{
401 return m_pDeviceContext;
402}
403
404AFX_INLINE void CXTPMarkupDrawingContext::SetUseTextSmoothing(BOOL bUseTextSmoothing)
405{
406 m_bUseTextSmoothing = bUseTextSmoothing;
407}
408
409AFX_INLINE BOOL CXTPMarkupDrawingContext::GetUseTextSmoothing() const
410{
411 return m_bUseTextSmoothing;
412}
414AFX_INLINE void CXTPMarkupDrawingContext::SetUseTextSmooting(BOOL bUseTextSmoothing)
415{
416 SetUseTextSmoothing(bUseTextSmoothing);
417}
418
419AFX_INLINE BOOL CXTPMarkupDrawingContext::GetUseTextSmooting() const
420{
421 return GetUseTextSmoothing();
422}
424AFX_INLINE CXTPMarkupGradientStops* CXTPMarkupLinearGradientBrush::GetGradientStops() const
425{
426 return MARKUP_STATICCAST(CXTPMarkupGradientStops, GetValue(m_pGradientStopsProperty));
427}
428
429AFX_INLINE CXTPMarkupEnum* CXTPMarkupGradientBrush::GetMappingMode() const
430{
431 return MARKUP_STATICCAST(CXTPMarkupEnum, GetValue(m_pMappingModeProperty));
432}
433
434AFX_INLINE CXTPMarkupGradientStop* CXTPMarkupGradientStops::GetItem(int nIndex) const
435{
436 return nIndex >= 0 && nIndex < m_arrItems.GetSize()
437 ? (CXTPMarkupGradientStop*)m_arrItems[nIndex]
438 : NULL;
439}
440
441# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
443#endif // !defined(__XTPMARKUPDRAWINGCONTEXT_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPMarkupSmoothingMode
XTPMarkupSmoothingMode
Defines markup smoothing mode.
Definition XTPMarkupContext.h:69
CXTPFont
Provides a convenient object oriented interface for HFONT GDI object and uses GDI handle caching.
Definition XTPGdiObjects.h:414
CXTPImageManagerIcon
Icons holder class.
Definition XTPImageManager.h:622
CXTPMarkupContext
CXTPMarkupContext is a standalone class used to provide common settings for Markup objects.
Definition XTPMarkupContext.h:128
CXTPMarkupDeviceDependentImage
Implements an abstract device dependent image.
Definition XTPMarkupDeviceDependentImage.h:73
CXTPMarkupThickness
The CXTPMarkupThickness class describes the thickness of the left, top, right, and bottom sides of a ...
Definition XTPMarkupThickness.h:42
CXTPMarkupTransformationMatrix
An abstract class for device context transformation matrix.
Definition XTPMarkupTransformationMatrix.h:40
CXTPSizeT
This class incapsulates size data.
Definition XTPSize.h:40


Toolkit Pro: Member List

CXTPScrollBarThemeVisualStudio2015 Member List

This is the complete list of members for CXTPScrollBarThemeVisualStudio2015, including all inherited members.

CalcHScroll(CXTPScrollBase *pScroll, XTPScrollMetricsH *pHScroll) | CXTPScrollBarPaintManager | protectedstatic
CalcVScroll(CXTPScrollBase *pScroll, XTPScrollMetricsV *pVScroll) | CXTPScrollBarPaintManager | protectedstatic
CXTPScrollBarPaintManager() | CXTPScrollBarPaintManager |
DrawArrowGlyph(CDC *pDC, CRect rcArrow, XTPArrowGlyph glyph, BOOL bEnabled, COLORREF clrText=COLORREF_NULL) | CXTPScrollBarPaintManager | protected
DrawArrows(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics) | CXTPScrollBarThemeVisualStudio2012 | protectedvirtual
DrawArrows(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics) | CXTPScrollBarThemeVisualStudio2012 | protectedvirtual
DrawBackground(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics) | CXTPScrollBarThemeVisualStudio2012 | protectedvirtual
DrawBackground(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics) | CXTPScrollBarThemeVisualStudio2012 | protectedvirtual
DrawButtons(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics) | CXTPScrollBarThemeVisualStudio2012 | protectedvirtual
DrawButtons(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics) | CXTPScrollBarThemeVisualStudio2012 | protectedvirtual
DrawGripper(CDC *pDC, CXTPScrollBase *pScroll) | CXTPScrollBarThemeVisualStudio2012 | protectedvirtual
DrawScrollBar(CDC *pDC, CXTPScrollBase *pScrollBar) | CXTPScrollBarThemeVisualStudio2015 | protectedvirtual
DrawThumbButton(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics) | CXTPScrollBarThemeVisualStudio2012 | protectedvirtual
DrawThumbButton(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics) | CXTPScrollBarThemeVisualStudio2012 | protectedvirtual
DrawTracker(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics) | CXTPScrollBarPaintManager | protectedvirtual
DrawTracker(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics) | CXTPScrollBarPaintManager | protectedvirtual
m_crBack | CXTPScrollBarPaintManager |
m_crBackHilite | CXTPScrollBarPaintManager |
m_crBackPushed | CXTPScrollBarPaintManager |
m_crBorder | CXTPScrollBarPaintManager |
m_crBorderHilite | CXTPScrollBarPaintManager |
m_cThumb | CXTPScrollBarPaintManager |
m_cxHScroll | CXTPScrollBarPaintManager |
m_cxVScroll | CXTPScrollBarPaintManager |
m_cyHScroll | CXTPScrollBarPaintManager |
m_cyVScroll | CXTPScrollBarPaintManager |
RefreshMetrics() | CXTPScrollBarPaintManager | virtual


Toolkit Pro: Member List

CXTPButtonThemeVisualStudio2022 Member List

This is the complete list of members for CXTPButtonThemeVisualStudio2022, including all inherited members.

CXTPButtonTheme() | CXTPButtonTheme |
CXTPButtonThemeUltraFlat() | CXTPButtonThemeUltraFlat |
CXTPButtonThemeVisualStudio2022() | CXTPButtonThemeVisualStudio2022 |
CXTPCmdTarget() | CXTPCmdTarget |
CXTPControlTheme() | CXTPControlTheme |
DrawButton(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
DrawButtonBackground(CDC *pDC, CXTPButton *pButton) | CXTPButtonThemeOffice2013 | virtual
DrawButtonText(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme |
DrawButtonVisualStyleBackground(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
DrawCheckBoxMark(CDC *pDC, CXTPButton *pButton) | CXTPButtonThemeOffice2013 | virtual
DrawFocusRect(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
DrawGroupBox(CDC *pDC, CXTPButton *pButton) | CXTPButtonThemeOffice2013 | virtual
DrawPushButtonDropDown(CDC *pDC, CXTPButton *pButton) | CXTPButtonThemeOffice2013 | virtual
DrawPushButtonIcon(CDC *pDC, CXTPButton *pButton) | CXTPButtonThemeOffice2013 | virtual
DrawPushButtonText(CDC *pDC, CXTPButton *pButton) | CXTPButtonThemeOffice2013 | virtual
DrawRadioButtonMark(CDC *pDC, CXTPButton *pButton) | CXTPButtonThemeOffice2013 | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetTextColor(CXTPButton *pButton) | CXTPButtonThemeOffice2013 | virtual
GetThemeStyle() const | CXTPControlTheme |
m_crBack | CXTPButtonTheme |
m_crBackChecked | CXTPButtonThemeUltraFlat |
m_crBackDisabled | CXTPButtonThemeOffice2013 | protected
m_crBackHilite | CXTPButtonThemeUltraFlat |
m_crBackPushed | CXTPButtonThemeUltraFlat |
m_crBorder | CXTPButtonThemeOffice2013 | protected
m_crBorder3DHilite | CXTPButtonTheme |
m_crBorder3DShadow | CXTPButtonTheme |
m_crBorderDefault | CXTPButtonThemeOffice2013 | protected
m_crBorderDisabled | CXTPButtonThemeOffice2013 | protected
m_crBorderHilite | CXTPButtonTheme |
m_crBorderPushed | CXTPButtonThemeUltraFlat |
m_crBorderShadow | CXTPButtonTheme |
m_crCheckMark | CXTPButtonThemeUltraFlat |
m_crMark | CXTPButtonThemeOffice2013 | protected
m_crMarkDisabled | CXTPButtonThemeOffice2013 | protected
m_crMarkHilite | CXTPButtonThemeOffice2013 | protected
m_crMarkPushed | CXTPButtonThemeOffice2013 | protected
m_crText | CXTPButtonTheme |
m_crTextCheck | CXTPButtonTheme |
m_crTextDisabled | CXTPButtonTheme |
m_crTextHilite | CXTPButtonThemeUltraFlat |
m_crTextPushed | CXTPButtonThemeUltraFlat |
m_nTheme | CXTPControlTheme | protected
RefreshMetrics(CXTPButton *pButton) | CXTPButtonThemeVisualStudio2022 | virtual
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static
~CXTPButtonTheme() | CXTPButtonTheme | virtual


Toolkit Pro: Member List

CXTPSplitterWnd Member List

This is the complete list of members for CXTPSplitterWnd, including all inherited members.

CreateScrollBarCtrl(DWORD dwStyle, UINT nID) | CXTPScrollBarContainer< CSplitterWnd > | inline
CXTPScrollBarContainer() | CXTPScrollBarContainer< CSplitterWnd > | inlineprotected
CXTPSplitterWnd() | CXTPSplitterWnd |
EnableBorder(BOOL bBorder) | CXTPSplitterWnd |
EnableDotTracker(BOOL bEnable) | CXTPSplitterWnd |
EnableFullDrag(int nFullDrag) | CXTPSplitterWnd |
EnableNoSize(BOOL bEnable) | CXTPSplitterWnd |
EnableScrollBar(int nSBFlags, UINT nArrowFlags=ESB_ENABLE_BOTH) | CXTPScrollBarContainer< CSplitterWnd > | inline
FullDragWindows() const | CXTPSplitterWnd |
GetHiddenColIndex() const | CXTPSplitterWnd |
GetHiddenRowIndex() const | CXTPSplitterWnd |
GetScrollBarCtrl(int nBar) const | CXTPScrollBarContainer< CSplitterWnd > | inlinevirtual
GetTheme() const | CXTPSplitterWnd |
HideColumn(int nColHide) | CXTPSplitterWnd | virtual
HideRow(int nRowHide) | CXTPSplitterWnd | virtual
IsBorderVisible() const | CXTPSplitterWnd |
m_bClipStyles | CXTPSplitterWnd | protected
m_bDotTracker | CXTPSplitterWnd | protected
m_bFullDrag | CXTPSplitterWnd | protected
m_bNoSize | CXTPSplitterWnd | protected
m_bShowBorder | CXTPSplitterWnd | protected
m_bSubclassed | CXTPSplitterWnd | protected
m_nFullDrag | CXTPSplitterWnd | protected
m_nHiddenCol | CXTPSplitterWnd | protected
m_nHiddenRow | CXTPSplitterWnd | protected
m_point | CXTPSplitterWnd | protected
m_pTheme | CXTPSplitterWnd | protected
OptimizeChildrenClipping() | CXTPScrollBarContainer< CSplitterWnd > | inline
PrintClient(CDC *pDC) | CXTPSplitterWnd | protected
RefreshMetrics() | CXTPSplitterWnd | protectedvirtual
RefreshScrollBarMetrics() | CXTPScrollBarContainer< CSplitterWnd > | inline
ReplaceView(int nRow, int nCol, CView *pNewView) | CXTPSplitterWnd | virtual
ReplaceView(int nRow, int nCol, CRuntimeClass *pViewClass) | CXTPSplitterWnd | virtual
SetActivePane(int row, int col, CWnd *pWnd=NULL) | CXTPSplitterWnd | virtual
SetScrollBarClass(CRuntimeClass *pClass=NULL) | CXTPScrollBarContainer< CSplitterWnd > | inline
SetScrollBarTheme(XTPScrollBarTheme theme) | CXTPScrollBarContainer< CSplitterWnd > | inline
SetTheme(XTPControlTheme eTheme) | CXTPSplitterWnd |
SetTheme(CXTPSplitterWndTheme *pTheme) | CXTPSplitterWnd |
ShowColumn() | CXTPSplitterWnd | virtual
ShowRow() | CXTPSplitterWnd | virtual
ShowScrollBar(UINT nBar, BOOL bShow=TRUE) | CXTPScrollBarContainer< CSplitterWnd > | inline
SwitchView(int nRow, int nCol, CView *pNewView) | CXTPSplitterWnd | virtual
~CXTPSplitterWnd() | CXTPSplitterWnd | virtual


Toolkit Pro: Member List

CXTPChartContainer Member List

This is the complete list of members for CXTPChartContainer, including all inherited members.

BeginFrequentUpdates() | CXTPChartContainer |
CXTPChartContainer() | CXTPChartContainer |
EndFrequentUpdates(XTPChartUpdateOptions updateOptions=xtpChartUpdateRedraw) | CXTPChartContainer |
GetControl()=0 | CXTPChartContainer | pure virtual
IsBeingFrequentlyUpdated() const | CXTPChartContainer |
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartContainer | virtual
SetCapture(CXTPChartElementView *pView) | CXTPChartContainer | virtual
~CXTPChartContainer() | CXTPChartContainer | virtual


Toolkit Pro: XTPCalendarMonthViewEvent.h Source File

  • Source
  • Calendar
XTPCalendarMonthViewEvent.h
Go to the documentation of this file.
1
22#if !defined(_XTPCALENDARMONTHVIEWEVENT_H__)
23# define _XTPCALENDARMONTHVIEWEVENT_H__
24
25# if _MSC_VER > 1000
26# pragma once
27# endif // _MSC_VER > 1000
28
29# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
30
31class CXTPCalendarEvent;
32class CXTPCalendarControl;
33class CXTPCalendarMonthViewDay;
34class CXTPCalendarMonthViewGroup;
35struct XTP_CALENDAR_HITTESTINFO;
36
54class _XTP_EXT_CLASS CXTPCalendarMonthViewEvent
55 : public CXTPCalendarViewEventT<CXTPCalendarMonthViewGroup>
56{
57 // friend class CXTPCalendarPaintManager::CMonthViewEventPart;
58 friend class CXTPCalendarMonthViewDay;
60 DECLARE_DYNAMIC(CXTPCalendarMonthViewEvent)
62public:
67 typedef CXTPCalendarViewEventT<CXTPCalendarMonthViewGroup> TBase;
68
78 CXTPCalendarMonthViewEvent(CXTPCalendarEvent* pEvent, CXTPCalendarMonthViewGroup* pViewGroup);
79
84 virtual ~CXTPCalendarMonthViewEvent();
85
98 virtual void Draw(CDC* pDC);
99
116 virtual BOOL HitTestEx(CPoint point, XTP_CALENDAR_HITTESTINFO* pInfo) const;
117
134 virtual void AdjustLayout(CDC* pDC, const CRect& rcEventMax, int nEventPlaceNumber);
135
152 virtual void AdjustLayout2(CDC* pDC, const CRect& rcEventMax, int nEventPlaceNumber);
153
164 virtual BOOL IsVisible() const;
165
177 BOOL IsShowEndTime() const;
178
190 BOOL IsTimeAsClock() const;
191
200 virtual void OnPostAdjustLayout();
201
202protected:
209 virtual CFont* GetSubjectEditorFont() const;
210
211private:
212};
213
214//===========================================================================
215
217
218# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
219#endif // !defined(_XTPCALENDARMONTHVIEWEVENT_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCalendarControl
Class CXTPCalendarControl implements the calendar's view interface.
Definition XTPCalendarControl.h:126
CXTPCalendarEvent
This class represents the data of a single Event used in the Calendar control.
Definition XTPCalendarEvent.h:77
CXTPCalendarMonthViewDay
This class represents a day view portion of the CalendarMonthView.
Definition XTPCalendarMonthViewDay.h:151
CXTPCalendarMonthViewEvent
This class represents an event view portion of the CalendarMonthViewDay.
Definition XTPCalendarMonthViewEvent.h:56
CXTPCalendarMonthViewEvent::IsVisible
virtual BOOL IsVisible() const
This member function is used to obtain the value of the view visible flag.
CXTPCalendarMonthViewEvent::TBase
CXTPCalendarViewEventT< CXTPCalendarMonthViewGroup > TBase
Definition XTPCalendarMonthViewEvent.h:67
CXTPCalendarMonthViewEvent::GetSubjectEditorFont
virtual CFont * GetSubjectEditorFont() const
This member function is used to obtain the editor window font.
CXTPCalendarMonthViewEvent::AdjustLayout2
virtual void AdjustLayout2(CDC *pDC, const CRect &rcEventMax, int nEventPlaceNumber)
This member function is used to adjust the view's layout depending on the provided bounding rectangle...
CXTPCalendarMonthViewEvent::OnPostAdjustLayout
virtual void OnPostAdjustLayout()
This member function is used to perform additional adjustments.
CXTPCalendarMonthViewEvent::CXTPCalendarMonthViewEvent
CXTPCalendarMonthViewEvent(CXTPCalendarEvent *pEvent, CXTPCalendarMonthViewGroup *pViewGroup)
Default object constructor.
CXTPCalendarMonthViewEvent::Draw
virtual void Draw(CDC *pDC)
This member function is used to draw the view content using the specified device context.
CXTPCalendarMonthViewEvent::AdjustLayout
virtual void AdjustLayout(CDC *pDC, const CRect &rcEventMax, int nEventPlaceNumber)
This member function is used to adjust the view's layout depending on the provided bounding rectangle...
CXTPCalendarMonthViewEvent::IsTimeAsClock
BOOL IsTimeAsClock() const
This member function is used to obtain the value of the "show time as clock" flag.
CXTPCalendarMonthViewEvent::HitTestEx
virtual BOOL HitTestEx(CPoint point, XTP_CALENDAR_HITTESTINFO *pInfo) const
This member function is used to fill a XTP_CALENDAR_HITTESTINFO structure.
CXTPCalendarMonthViewEvent::IsShowEndTime
BOOL IsShowEndTime() const
This member function is used to obtain the value of the "show end time" flag.
CXTPCalendarMonthViewEvent::~CXTPCalendarMonthViewEvent
virtual ~CXTPCalendarMonthViewEvent()
Default class destructor.
CXTPCalendarMonthViewGroup
This class represents a single resource view portion of the Calendar Month View.
Definition XTPCalendarMonthViewDay.h:54
CXTPCalendarViewEventT
This class is used to build the ViewEvent layer of the DayView and ViewEvent hierarchies.
Definition XTPCalendarViewEvent.h:1077
XTP_CALENDAR_HITTESTINFO
Basic set of parameters transferred from calendar items to mouse handlers.
Definition XTPCalendarDefines.h:856


Toolkit Pro: XTPCommandBarsNativeWindows11Theme.h Source File

  • Source
  • CommandBars
  • Themes
XTPCommandBarsNativeWindows11Theme.h
Go to the documentation of this file.
1
23#if !defined(__XTPCOMMANDBARSNATIVEWINDOWS11THEME_H__)
24# define __XTPCOMMANDBARSNATIVEWINDOWS11THEME_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
40class _XTP_EXT_CLASS CXTPCommandBarsNativeWindows11Theme : public CXTPCommandBarsOffice2013Theme
41{
43 DECLARE_DYNAMIC(CXTPCommandBarsNativeWindows11Theme)
45public:
50 CXTPCommandBarsNativeWindows11Theme();
51
57 virtual ~CXTPCommandBarsNativeWindows11Theme();
58
65 virtual void FillCommandBarEntry(CDC* pDC, CXTPCommandBar* pBar);
66
73 virtual void FillDockBar(CDC* pDC, CXTPDockBar* pBar);
74
82 virtual void SetStateColor(COLORREF clrState = COLORREF_NULL);
83
90 virtual COLORREF GetStateColor() const;
91
99 virtual CRect GetCommandBarBorders(CXTPCommandBar* pBar);
100
101 virtual BOOL IsPopupRoundedCorners(CPoint& pt);
102
103protected:
108 virtual void RefreshMetrics();
109
117 virtual void DrawSplitButtonFrame(CDC* pDC, CXTPControl* pButton, CRect rc);
118
132 virtual void DrawRectangle(CDC* pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled,
133 BOOL bChecked, BOOL bPopuped, XTPBarType barType,
134 XTPBarPosition barPosition);
135
150 virtual void DrawRectangle(CDC* pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled,
151 BOOL bChecked, BOOL bPopuped, XTPBarType barType,
152 XTPBarPosition barPosition, int nID);
153
162 virtual BOOL DrawRectangle(CDC* pDC, CXTPControl* pButton);
163
170 virtual COLORREF GetControlTextColor(CXTPControl* pButton);
171
183 virtual void DrawGalleryItemBack(CDC* pDC, CRect rcItem, BOOL bEnabled, BOOL bSelected,
184 BOOL bPressed, BOOL bChecked, XTPBarType barType);
185
195 virtual void DrawCheckRect(CDC* pDC, CRect rc, COLORREF clrFore, COLORREF clrBack);
196
206 virtual CSize DrawCommandBarGripper(CDC* pDC, CXTPCommandBar* pBar, BOOL bDraw = TRUE);
207
217 virtual CSize DrawControlComboBox(CDC* pDC, CXTPControlComboBox* pComboBox, BOOL bDraw);
218
219 CXTPPaintManagerColor m_clrActiveBack;
221 CXTPPaintManagerColor m_clrInactiveBack;
223};
224
237_XTP_EXT_CLASS BOOL AFX_CDECL XTPSetNativeWindows11StateColor(CXTPCommandBars* pCommandBars,
238 COLORREF clrState = COLORREF_NULL);
239
241# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
242#endif // !defined(__XTPCOMMANDBARSNATIVEWINDOWS11THEME_H__)
XTPBarType
XTPBarType
Type of the command bar.
Definition XTPCommandBarsDefines.h:77
XTPBarPosition
XTPBarPosition
Position of the command bar.
Definition XTPCommandBarsDefines.h:52
XTPSetNativeWindows11StateColor
_XTP_EXT_CLASS BOOL AFX_CDECL XTPSetNativeWindows11StateColor(CXTPCommandBars *pCommandBars, COLORREF clrState=COLORREF_NULL)
Call XTPSetNativeWindows11StateColor to set the border and status bar colors for this theme to indica...
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCommandBar
CXTPCommandBar is a CWnd derived class.
Definition XTPCommandBar.h:66
CXTPCommandBars
CXTPCommandBars is a standalone class.
Definition XTPCommandBars.h:165
CXTPCommandBarsNativeWindows11Theme
The CXTPCommandBarsNativeWindows11Theme class is used to enable a Native Windows 10 style theme for C...
Definition XTPCommandBarsNativeWindows11Theme.h:41
CXTPCommandBarsNativeWindows11Theme::DrawCheckRect
virtual void DrawCheckRect(CDC *pDC, CRect rc, COLORREF clrFore, COLORREF clrBack)
Helper class called by DrawRectangle to render a checkmark background and border.
CXTPCommandBarsNativeWindows11Theme::DrawCommandBarGripper
virtual CSize DrawCommandBarGripper(CDC *pDC, CXTPCommandBar *pBar, BOOL bDraw=TRUE)
This method is called to draw the command bar's gripper.
CXTPCommandBarsNativeWindows11Theme::GetCommandBarBorders
virtual CRect GetCommandBarBorders(CXTPCommandBar *pBar)
This method is called to retrieve the command bar's borders.
CXTPCommandBarsNativeWindows11Theme::DrawControlComboBox
virtual CSize DrawControlComboBox(CDC *pDC, CXTPControlComboBox *pComboBox, BOOL bDraw)
This method is called to draw the control.
CXTPCommandBarsNativeWindows11Theme::m_clrActiveBack
CXTPPaintManagerColor m_clrActiveBack
CommandBars background color when window is active.
Definition XTPCommandBarsNativeWindows11Theme.h:219
CXTPCommandBarsNativeWindows11Theme::DrawSplitButtonFrame
virtual void DrawSplitButtonFrame(CDC *pDC, CXTPControl *pButton, CRect rc)
This method is called to draw the frame for the SplitButton control.
CXTPCommandBarsNativeWindows11Theme::DrawGalleryItemBack
virtual void DrawGalleryItemBack(CDC *pDC, CRect rcItem, BOOL bEnabled, BOOL bSelected, BOOL bPressed, BOOL bChecked, XTPBarType barType)
This method is called to draw the background for a gallery menu item.
CXTPCommandBarsNativeWindows11Theme::SetStateColor
virtual void SetStateColor(COLORREF clrState=COLORREF_NULL)
Call this member function to set the application state color for the frame border and status bar.
CXTPCommandBarsNativeWindows11Theme::DrawRectangle
virtual BOOL DrawRectangle(CDC *pDC, CXTPControl *pButton)
This method is called to fill the control's face.
CXTPCommandBarsNativeWindows11Theme::~CXTPCommandBarsNativeWindows11Theme
virtual ~CXTPCommandBarsNativeWindows11Theme()
Destroys a CXTPCommandBarsNativeWindows11Theme object, handles cleanup and deallocation.
CXTPCommandBarsNativeWindows11Theme::FillCommandBarEntry
virtual void FillCommandBarEntry(CDC *pDC, CXTPCommandBar *pBar)
This method is called to fill the command bar's face.
CXTPCommandBarsNativeWindows11Theme::GetControlTextColor
virtual COLORREF GetControlTextColor(CXTPControl *pButton)
This method returns the control text color to draw.
CXTPCommandBarsNativeWindows11Theme::CXTPCommandBarsNativeWindows11Theme
CXTPCommandBarsNativeWindows11Theme()
Constructs a CXTPCommandBarsNativeWindows11Theme object.
CXTPCommandBarsNativeWindows11Theme::RefreshMetrics
virtual void RefreshMetrics()
This method is called to refresh the visual metrics of the manager.
CXTPCommandBarsNativeWindows11Theme::GetStateColor
virtual COLORREF GetStateColor() const
Call this member function to gets the application state color for the frame border and status bar.
CXTPCommandBarsNativeWindows11Theme::DrawRectangle
virtual void DrawRectangle(CDC *pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition)
This method is called to fill the control's face.
CXTPCommandBarsNativeWindows11Theme::m_clrInactiveBack
CXTPPaintManagerColor m_clrInactiveBack
CommandBars background color when window is inactive.
Definition XTPCommandBarsNativeWindows11Theme.h:221
CXTPCommandBarsNativeWindows11Theme::DrawRectangle
virtual void DrawRectangle(CDC *pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition, int nID)
This method is called to fill the control's face.
CXTPCommandBarsNativeWindows11Theme::FillDockBar
virtual void FillDockBar(CDC *pDC, CXTPDockBar *pBar)
This method is called to fill a dock bar.
CXTPCommandBarsOffice2013Theme
The CXTPCommandBarsOffice2013Theme class is used to enable an Office 2013 style theme for Command Bar...
Definition XTPCommandBarsOffice2013Theme.h:63
CXTPControlComboBox
CXTPControlComboBox is a CXTPControl derived class.
Definition XTPControlComboBox.h:381
CXTPControl
CXTPControl is a CXTPCmdTarget derived class.
Definition XTPControl.h:841
CXTPDockBar
CXTPDockBar is a CWnd derived class.
Definition XTPDockBar.h:42
CXTPPaintManagerColor
The CXTPPaintManagerColor class is used to manage COLORREF values for determining default and applica...
Definition XTPColorManager.h:117


Toolkit Pro: XTPProgressCtrlPaintManager.h Source File

  • Source
  • Controls
  • Progress
XTPProgressCtrlPaintManager.h
Go to the documentation of this file.
1
23#if !defined(__XTPPROGRESSCTRLPAINTMANAGER_H__)
24# define __XTPPROGRESSCTRLPAINTMANAGER_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
37struct XTPPROGRESSDRAWSTRUCT
38{
39 CDC* pDC;
40 CFont* pFont;
41 CRect rcClient;
42 CString strText;
43 CProgressCtrl* pWndCtrl;
44 PBRANGE range;
45 int nPos;
46 BOOL bVertical;
47 BOOL bVista;
48 BOOL bSmooth;
49 BOOL bMarquee;
50 BOOL bFlatStyle;
51};
52
58class _XTP_EXT_CLASS CXTPProgressCtrlPaintManager : public CXTPCmdTarget
59{
61 DECLARE_DYNAMIC(CXTPProgressCtrlPaintManager)
63public:
72 CXTPProgressCtrlPaintManager();
73
80 virtual ~CXTPProgressCtrlPaintManager();
81
89 virtual void RefreshMetrics();
90
98 COLORREF SetBorderColor(COLORREF clrNew);
99
107 COLORREF SetBarColor(COLORREF clrNew);
108
116 COLORREF SetBackColor(COLORREF clrNew);
117
125 COLORREF SetTextColor(COLORREF clrNew);
126
133 COLORREF GetBorderColor();
134
141 COLORREF GetBarColor();
142
149 COLORREF GetBackColor();
150
157 COLORREF GetTextColor();
158
166 virtual void DrawNcBorders(CDC* pDC, CRect rc);
167
176 virtual void Draw(XTPPROGRESSDRAWSTRUCT& ds);
177
186 virtual void DrawText(XTPPROGRESSDRAWSTRUCT& ds) /* = 0*/;
187
196 BOOL UsingWinThemes(BOOL bCheckReady = FALSE);
197
204 void UseWinThemes(BOOL bUseWinThemes = TRUE);
205
206protected:
215 virtual void DeflateRect(XTPPROGRESSDRAWSTRUCT& ds);
216
217 BOOL m_bUseWinTheme;
218 XTPControlTheme m_nTheme;
219 CXTPWinThemeWrapper m_winTheme;
220 CXTPPaintManagerColor m_clrBorder;
221 CXTPPaintManagerColor m_clrBar;
222 CXTPPaintManagerColor m_clrBack;
223 CXTPPaintManagerColor m_clrText;
224 CXTPPaintManagerColor m_clrBarText;
225};
227//---------------------------------------------------------------------------
228// Inline functions.
229//---------------------------------------------------------------------------
230
231AFX_INLINE COLORREF CXTPProgressCtrlPaintManager::SetBorderColor(COLORREF clrNew)
232{
233 m_clrBorder.SetCustomValue(clrNew);
234 return m_clrBorder;
235}
236AFX_INLINE COLORREF CXTPProgressCtrlPaintManager::SetBarColor(COLORREF clrNew)
237{
238 m_clrBar.SetCustomValue(clrNew);
239 return m_clrBar;
240}
241AFX_INLINE COLORREF CXTPProgressCtrlPaintManager::SetBackColor(COLORREF clrNew)
242{
243 m_clrBack.SetCustomValue(clrNew);
244 return m_clrBack;
245}
246AFX_INLINE COLORREF CXTPProgressCtrlPaintManager::SetTextColor(COLORREF clrNew)
247{
248 m_clrText.SetCustomValue(clrNew);
249 return m_clrText;
250}
251AFX_INLINE COLORREF CXTPProgressCtrlPaintManager::GetBorderColor()
252{
253 return m_clrBorder;
254}
255AFX_INLINE COLORREF CXTPProgressCtrlPaintManager::GetBarColor()
256{
257 return m_clrBar;
258}
259AFX_INLINE COLORREF CXTPProgressCtrlPaintManager::GetBackColor()
260{
261 return m_clrBack;
262}
263AFX_INLINE COLORREF CXTPProgressCtrlPaintManager::GetTextColor()
264{
265 return m_clrText;
266}
273class _XTP_EXT_CLASS CXTPProgressCtrlThemeFlat : public CXTPProgressCtrlPaintManager
274{
276 DECLARE_DYNAMIC(CXTPProgressCtrlThemeFlat)
278public:
287 CXTPProgressCtrlThemeFlat();
288
296 virtual void RefreshMetrics();
297
298protected:
307 virtual void DeflateRect(XTPPROGRESSDRAWSTRUCT& ds);
308};
309
316class _XTP_EXT_CLASS CXTPProgressCtrlThemeUltraFlat : public CXTPProgressCtrlThemeFlat
317{
319 DECLARE_DYNAMIC(CXTPProgressCtrlThemeUltraFlat)
321public:
330 CXTPProgressCtrlThemeUltraFlat();
331
339 virtual void RefreshMetrics();
340};
341
347class _XTP_EXT_CLASS CXTPProgressCtrlThemeOffice2000 : public CXTPProgressCtrlPaintManager
348{
350 DECLARE_DYNAMIC(CXTPProgressCtrlThemeOffice2000)
352public:
361 CXTPProgressCtrlThemeOffice2000();
362
370 virtual void DrawNcBorders(CDC* pDC, CRect rc);
371};
372
378class _XTP_EXT_CLASS CXTPProgressCtrlThemeOfficeXP : public CXTPProgressCtrlThemeOffice2000
379{
381 DECLARE_DYNAMIC(CXTPProgressCtrlThemeOfficeXP)
383public:
392 CXTPProgressCtrlThemeOfficeXP();
393
401 virtual void DrawNcBorders(CDC* pDC, CRect rc);
402};
403
409class _XTP_EXT_CLASS CXTPProgressCtrlThemeOffice2003 : public CXTPProgressCtrlThemeOffice2000
410{
412 DECLARE_DYNAMIC(CXTPProgressCtrlThemeOffice2003)
414public:
423 CXTPProgressCtrlThemeOffice2003();
424
432 virtual void RefreshMetrics();
433
441 virtual void DrawNcBorders(CDC* pDC, CRect rc);
442};
443
449class _XTP_EXT_CLASS CXTPProgressCtrlThemeResource : public CXTPProgressCtrlThemeOffice2000
450{
452 DECLARE_DYNAMIC(CXTPProgressCtrlThemeResource)
454public:
463 CXTPProgressCtrlThemeResource();
464
473 virtual void Draw(XTPPROGRESSDRAWSTRUCT& ds);
474};
475
481class _XTP_EXT_CLASS CXTPProgressCtrlThemeOffice2013 : public CXTPProgressCtrlThemeOffice2000
482{
484 DECLARE_DYNAMIC(CXTPProgressCtrlThemeOffice2013)
486public:
495 CXTPProgressCtrlThemeOffice2013();
496
504 virtual void RefreshMetrics();
505
513 virtual void DrawNcBorders(CDC* pDC, CRect rc);
514
523 virtual void Draw(XTPPROGRESSDRAWSTRUCT& ds);
524};
525
531class _XTP_EXT_CLASS CXTPProgressCtrlThemeVisualStudio2015 : public CXTPProgressCtrlThemeOffice2013
532{
534 DECLARE_DYNAMIC(CXTPProgressCtrlThemeVisualStudio2015)
536public:
545 CXTPProgressCtrlThemeVisualStudio2015();
546
554 virtual void RefreshMetrics();
555};
556
562class _XTP_EXT_CLASS CXTPProgressCtrlThemeNativeWinXP : public CXTPProgressCtrlPaintManager
563{
565 DECLARE_DYNAMIC(CXTPProgressCtrlThemeNativeWinXP)
567public:
576 CXTPProgressCtrlThemeNativeWinXP();
577
578protected:
587 virtual void DeflateRect(XTPPROGRESSDRAWSTRUCT& ds);
588};
589
595class _XTP_EXT_CLASS CXTPProgressCtrlThemeNativeWindows : public CXTPProgressCtrlPaintManager
596{
598 DECLARE_DYNAMIC(CXTPProgressCtrlThemeNativeWindows)
600public:
609 CXTPProgressCtrlThemeNativeWindows();
610
611protected:
620 virtual void DeflateRect(XTPPROGRESSDRAWSTRUCT& ds);
621};
622
629class _XTP_EXT_CLASS CXTPProgressCtrlThemeVisualStudio2017 : public CXTPProgressCtrlThemeOffice2013
630{
632 DECLARE_DYNAMIC(CXTPProgressCtrlThemeVisualStudio2017)
634public:
643 CXTPProgressCtrlThemeVisualStudio2017();
644};
645
652class _XTP_EXT_CLASS CXTPProgressCtrlThemeVisualStudio2019 : public CXTPProgressCtrlThemeOffice2013
653{
655 DECLARE_DYNAMIC(CXTPProgressCtrlThemeVisualStudio2019)
657public:
666 CXTPProgressCtrlThemeVisualStudio2019();
667};
668
675class _XTP_EXT_CLASS CXTPProgressCtrlThemeVisualStudio2022 : public CXTPProgressCtrlThemeOffice2013
676{
678 DECLARE_DYNAMIC(CXTPProgressCtrlThemeVisualStudio2022)
680public:
689 CXTPProgressCtrlThemeVisualStudio2022();
690};
691
692# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
694#endif // #if !defined(__XTPPROGRESSCTRLPAINTMANAGER_H__)
XTPControlTheme
XTPControlTheme
Enumeration used to determine the active theme style.
Definition XTPControlTheme.h:43
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPPaintManagerColor
The CXTPPaintManagerColor class is used to manage COLORREF values for determining default and applica...
Definition XTPColorManager.h:117
CXTPPaintManagerColor::SetCustomValue
void SetCustomValue(COLORREF clr)
This member function will sets the application defined color for the CXTPPaintManagerColor class.
CXTPProgressCtrlPaintManager
The CXTPProgressCtrlPaintManager class is derived from CXTPCmdTarget and is used by the progress bar ...
Definition XTPProgressCtrlPaintManager.h:59
CXTPProgressCtrlPaintManager::DrawNcBorders
virtual void DrawNcBorders(CDC *pDC, CRect rc)
This member function is called by the progress bar to draw the non-client borders.
CXTPProgressCtrlPaintManager::m_clrBarText
CXTPPaintManagerColor m_clrBarText
An RGB value representing the hilite text color.
Definition XTPProgressCtrlPaintManager.h:224
CXTPProgressCtrlPaintManager::UseWinThemes
void UseWinThemes(BOOL bUseWinThemes=TRUE)
Call this member function to draw the control using the current Windows theme.
CXTPProgressCtrlPaintManager::SetBorderColor
COLORREF SetBorderColor(COLORREF clrNew)
This member function sets the border color for the progress bar.
CXTPProgressCtrlPaintManager::GetBorderColor
COLORREF GetBorderColor()
This member function gets the border color for the progress bar.
CXTPProgressCtrlPaintManager::m_clrBorder
CXTPPaintManagerColor m_clrBorder
An RGB value representing the border color.
Definition XTPProgressCtrlPaintManager.h:220
CXTPProgressCtrlPaintManager::m_clrText
CXTPPaintManagerColor m_clrText
An RGB value representing the text color.
Definition XTPProgressCtrlPaintManager.h:223
CXTPProgressCtrlPaintManager::SetTextColor
COLORREF SetTextColor(COLORREF clrNew)
This member function sets the text color for the progress bar.
CXTPProgressCtrlPaintManager::GetBarColor
COLORREF GetBarColor()
This member function gets the bar color for the progress bar.
CXTPProgressCtrlPaintManager::m_nTheme
XTPControlTheme m_nTheme
Theme identifier.
Definition XTPProgressCtrlPaintManager.h:218
CXTPProgressCtrlPaintManager::m_clrBar
CXTPPaintManagerColor m_clrBar
An RGB value representing the bar color.
Definition XTPProgressCtrlPaintManager.h:221
CXTPProgressCtrlPaintManager::~CXTPProgressCtrlPaintManager
virtual ~CXTPProgressCtrlPaintManager()
Default paint manager destructor.
CXTPProgressCtrlPaintManager::Draw
virtual void Draw(XTPPROGRESSDRAWSTRUCT &ds)
This member function is called by the progress bar to draw the client area of the control.
CXTPProgressCtrlPaintManager::m_winTheme
CXTPWinThemeWrapper m_winTheme
Wrapper used when drawing Windows themes.
Definition XTPProgressCtrlPaintManager.h:219
CXTPProgressCtrlPaintManager::UsingWinThemes
BOOL UsingWinThemes(BOOL bCheckReady=FALSE)
Used by the progress bar to determine if Windows themes should be used to draw the control.
CXTPProgressCtrlPaintManager::DrawText
virtual void DrawText(XTPPROGRESSDRAWSTRUCT &ds)
This member function is called by the progress bar to draw the progress text for the control.
CXTPProgressCtrlPaintManager::SetBackColor
COLORREF SetBackColor(COLORREF clrNew)
This member function sets the background color for the progress bar.
CXTPProgressCtrlPaintManager::DeflateRect
virtual void DeflateRect(XTPPROGRESSDRAWSTRUCT &ds)
This member function is called by the progress bar to adjust the bar drawing size; can be overridden ...
CXTPProgressCtrlPaintManager::SetBarColor
COLORREF SetBarColor(COLORREF clrNew)
This member function sets the bar color for the progress bar.
CXTPProgressCtrlPaintManager::RefreshMetrics
virtual void RefreshMetrics()
This member function performs initialization for the Paint Manager.
CXTPProgressCtrlPaintManager::GetBackColor
COLORREF GetBackColor()
This member function gets the background color for the progress bar.
CXTPProgressCtrlPaintManager::m_bUseWinTheme
BOOL m_bUseWinTheme
TRUE when using Windows themes.
Definition XTPProgressCtrlPaintManager.h:217
CXTPProgressCtrlPaintManager::CXTPProgressCtrlPaintManager
CXTPProgressCtrlPaintManager()
Default paint manager constructor.
CXTPProgressCtrlPaintManager::GetTextColor
COLORREF GetTextColor()
This member function gets the text color for the progress bar.
CXTPProgressCtrlPaintManager::m_clrBack
CXTPPaintManagerColor m_clrBack
An RGB value representing the back color.
Definition XTPProgressCtrlPaintManager.h:222
CXTPProgressCtrlThemeFlat
The CXTPProgressCtrlThemeFlat class is derived from CXTPProgressCtrlPaintManager and is used by the p...
Definition XTPProgressCtrlPaintManager.h:274
CXTPProgressCtrlThemeFlat::CXTPProgressCtrlThemeFlat
CXTPProgressCtrlThemeFlat()
Default paint manager constructor.
CXTPProgressCtrlThemeFlat::DeflateRect
virtual void DeflateRect(XTPPROGRESSDRAWSTRUCT &ds)
This member function is called by the progress bar to adjust the bar drawing size; can be overridden ...
CXTPProgressCtrlThemeFlat::RefreshMetrics
virtual void RefreshMetrics()
This member function performs initialization for the Paint Manager.
CXTPProgressCtrlThemeNativeWinXP
The CXTPProgressCtrlThemeNativeWinXP class is derived from CXTPProgressCtrlPaintManager and is used b...
Definition XTPProgressCtrlPaintManager.h:563
CXTPProgressCtrlThemeNativeWinXP::CXTPProgressCtrlThemeNativeWinXP
CXTPProgressCtrlThemeNativeWinXP()
Default paint manager constructor.
CXTPProgressCtrlThemeNativeWinXP::DeflateRect
virtual void DeflateRect(XTPPROGRESSDRAWSTRUCT &ds)
This member function is called by the progress bar to adjust the bar drawing size; can be overridden ...
CXTPProgressCtrlThemeNativeWindows
The CXTPProgressCtrlThemeNativeWindows class is derived from CXTPProgressCtrlPaintManager and is used...
Definition XTPProgressCtrlPaintManager.h:596
CXTPProgressCtrlThemeNativeWindows::CXTPProgressCtrlThemeNativeWindows
CXTPProgressCtrlThemeNativeWindows()
Default paint manager constructor.
CXTPProgressCtrlThemeNativeWindows::DeflateRect
virtual void DeflateRect(XTPPROGRESSDRAWSTRUCT &ds)
This member function is called by the progress bar to adjust the bar drawing size; can be overridden ...
CXTPProgressCtrlThemeOffice2000
The CXTPProgressCtrlThemeFlat class is derived from CXTPProgressCtrlPaintManager and is used by the p...
Definition XTPProgressCtrlPaintManager.h:348
CXTPProgressCtrlThemeOffice2000::DrawNcBorders
virtual void DrawNcBorders(CDC *pDC, CRect rc)
This member function is called by the progress bar to draw the non-client borders.
CXTPProgressCtrlThemeOffice2000::CXTPProgressCtrlThemeOffice2000
CXTPProgressCtrlThemeOffice2000()
Default paint manager constructor.
CXTPProgressCtrlThemeOffice2003
The CXTPProgressCtrlThemeFlat class is derived from CXTPProgressCtrlPaintManager and is used by the p...
Definition XTPProgressCtrlPaintManager.h:410
CXTPProgressCtrlThemeOffice2003::DrawNcBorders
virtual void DrawNcBorders(CDC *pDC, CRect rc)
This member function is called by the progress bar to draw the non-client borders.
CXTPProgressCtrlThemeOffice2003::CXTPProgressCtrlThemeOffice2003
CXTPProgressCtrlThemeOffice2003()
Default paint manager constructor.
CXTPProgressCtrlThemeOffice2003::RefreshMetrics
virtual void RefreshMetrics()
This member function performs initialization for the Paint Manager.
CXTPProgressCtrlThemeOffice2013
The CXTPProgressCtrlThemeFlat class is derived from CXTPProgressCtrlPaintManager and is used by the p...
Definition XTPProgressCtrlPaintManager.h:482
CXTPProgressCtrlThemeOffice2013::DrawNcBorders
virtual void DrawNcBorders(CDC *pDC, CRect rc)
This member function is called by the progress bar to draw the non-client borders.
CXTPProgressCtrlThemeOffice2013::CXTPProgressCtrlThemeOffice2013
CXTPProgressCtrlThemeOffice2013()
Default paint manager constructor.
CXTPProgressCtrlThemeOffice2013::Draw
virtual void Draw(XTPPROGRESSDRAWSTRUCT &ds)
This member function is called by the progress bar to draw the client area of the control.
CXTPProgressCtrlThemeOffice2013::RefreshMetrics
virtual void RefreshMetrics()
This member function performs initialization for the Paint Manager.
CXTPProgressCtrlThemeOfficeXP
The CXTPProgressCtrlThemeXP class is derived from CXTPProgressCtrlThemeFlat and is used by the progre...
Definition XTPProgressCtrlPaintManager.h:379
CXTPProgressCtrlThemeOfficeXP::DrawNcBorders
virtual void DrawNcBorders(CDC *pDC, CRect rc)
This member function is called by the progress bar to draw the non-client borders.
CXTPProgressCtrlThemeOfficeXP::CXTPProgressCtrlThemeOfficeXP
CXTPProgressCtrlThemeOfficeXP()
Default paint manager constructor.
CXTPProgressCtrlThemeResource
The CXTPProgressCtrlThemeFlat class is derived from CXTPProgressCtrlPaintManager and is used by the p...
Definition XTPProgressCtrlPaintManager.h:450
CXTPProgressCtrlThemeResource::CXTPProgressCtrlThemeResource
CXTPProgressCtrlThemeResource()
Default paint manager constructor.
CXTPProgressCtrlThemeResource::Draw
virtual void Draw(XTPPROGRESSDRAWSTRUCT &ds)
This member function is called by the progress bar to draw the client area of the control.
CXTPProgressCtrlThemeUltraFlat
The CXTPProgressCtrlThemeUltraFlat class is derived from CXTPProgressCtrlThemeFlat and is used by the...
Definition XTPProgressCtrlPaintManager.h:317
CXTPProgressCtrlThemeUltraFlat::CXTPProgressCtrlThemeUltraFlat
CXTPProgressCtrlThemeUltraFlat()
Default paint manager constructor.
CXTPProgressCtrlThemeUltraFlat::RefreshMetrics
virtual void RefreshMetrics()
This member function performs initialization for the Paint Manager.
CXTPProgressCtrlThemeVisualStudio2015
The CXTPProgressCtrlThemeFlat class is derived from CXTPProgressCtrlPaintManager and is used by the p...
Definition XTPProgressCtrlPaintManager.h:532
CXTPProgressCtrlThemeVisualStudio2015::CXTPProgressCtrlThemeVisualStudio2015
CXTPProgressCtrlThemeVisualStudio2015()
Default paint manager constructor.
CXTPProgressCtrlThemeVisualStudio2015::RefreshMetrics
virtual void RefreshMetrics()
This member function performs initialization for the Paint Manager.
CXTPProgressCtrlThemeVisualStudio2017
The CXTPProgressCtrlThemeVisualStudio2017 class is derived from CXTPProgressCtrlThemeOffice2013 and i...
Definition XTPProgressCtrlPaintManager.h:630
CXTPProgressCtrlThemeVisualStudio2017::CXTPProgressCtrlThemeVisualStudio2017
CXTPProgressCtrlThemeVisualStudio2017()
Default paint manager constructor.
CXTPProgressCtrlThemeVisualStudio2019
The CXTPProgressCtrlThemeVisualStudio2019 class is derived from CXTPProgressCtrlThemeOffice2013 and i...
Definition XTPProgressCtrlPaintManager.h:653
CXTPProgressCtrlThemeVisualStudio2019::CXTPProgressCtrlThemeVisualStudio2019
CXTPProgressCtrlThemeVisualStudio2019()
Default paint manager constructor.
CXTPProgressCtrlThemeVisualStudio2022
The CXTPProgressCtrlThemeVisualStudio2022 class is derived from CXTPProgressCtrlThemeOffice2013 and i...
Definition XTPProgressCtrlPaintManager.h:676
CXTPProgressCtrlThemeVisualStudio2022::CXTPProgressCtrlThemeVisualStudio2022
CXTPProgressCtrlThemeVisualStudio2022()
Default paint manager constructor.
CXTPWinThemeWrapper
The CXTPWinThemeWrapper class wraps the UxTheme.dll visual theme API.
Definition XTPWinThemeWrapper.h:188
XTPPROGRESSDRAWSTRUCT
Struct used by the progress bar during paint operations.
Definition XTPProgressCtrlPaintManager.h:38
XTPPROGRESSDRAWSTRUCT::pWndCtrl
CProgressCtrl * pWndCtrl
Points to the progress control.
Definition XTPProgressCtrlPaintManager.h:43
XTPPROGRESSDRAWSTRUCT::bVista
BOOL bVista
TRUE if the Windows verison is greater than or equal to Vista.
Definition XTPProgressCtrlPaintManager.h:47
XTPPROGRESSDRAWSTRUCT::pFont
CFont * pFont
Pointer to the progress bar's CFont object.
Definition XTPProgressCtrlPaintManager.h:40
XTPPROGRESSDRAWSTRUCT::rcClient
CRect rcClient
Client area of the progress bar.
Definition XTPProgressCtrlPaintManager.h:41
XTPPROGRESSDRAWSTRUCT::bFlatStyle
BOOL bFlatStyle
TRUE if the progress bar is to be drawn flat (deprecated).
Definition XTPProgressCtrlPaintManager.h:50
XTPPROGRESSDRAWSTRUCT::bSmooth
BOOL bSmooth
TRUE if the progress bar is drawn smooth.
Definition XTPProgressCtrlPaintManager.h:48
XTPPROGRESSDRAWSTRUCT::nPos
int nPos
Position of the progress bar.
Definition XTPProgressCtrlPaintManager.h:45
XTPPROGRESSDRAWSTRUCT::range
PBRANGE range
High and low limits of a progress bar control.
Definition XTPProgressCtrlPaintManager.h:44
XTPPROGRESSDRAWSTRUCT::pDC
CDC * pDC
Pointer to a valid device context.
Definition XTPProgressCtrlPaintManager.h:39
XTPPROGRESSDRAWSTRUCT::bMarquee
BOOL bMarquee
TRUE if this is a Marquee style progress bar.
Definition XTPProgressCtrlPaintManager.h:49
XTPPROGRESSDRAWSTRUCT::strText
CString strText
Window text to be displayed on the progress bar.
Definition XTPProgressCtrlPaintManager.h:42
XTPPROGRESSDRAWSTRUCT::bVertical
BOOL bVertical
TRUE if the progress bar is vertical, otherwise FALSE.
Definition XTPProgressCtrlPaintManager.h:46


Toolkit Pro: XTPScrollBarThemeVisualStudio2019.h Source File

  • Source
  • Common
  • ScrollBar
  • Themes
XTPScrollBarThemeVisualStudio2019.h
Go to the documentation of this file.
1
23#if !defined(__XTPSCROLLBARTHEMEVISUALSTUDIO2019_H__)
24# define __XTPSCROLLBARTHEMEVISUALSTUDIO2019_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPScrollBarThemeVisualStudio2019 : public CXTPScrollBarThemeVisualStudio2012
39{
40protected:
41 virtual void DrawScrollBar(CDC* pDC, CXTPScrollBase* pScrollBar);
42};
43
44# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
46#endif // !defined(__XTPSCROLLBARTHEMEVISUALSTUDIO2019_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPScrollBarThemeVisualStudio2012
Scrollbar paint manager used to draw Visual Studio 2012 like scrollbars.
Definition XTPScrollBarThemeVisualStudio2012.h:39
CXTPScrollBarThemeVisualStudio2019
Scrollbar paint manager used to draw Visual Studio 2019 like scrollbars.
Definition XTPScrollBarThemeVisualStudio2019.h:39
CXTPScrollBarThemeVisualStudio2019::DrawScrollBar
virtual void DrawScrollBar(CDC *pDC, CXTPScrollBase *pScrollBar)
This method is called to draw all scrollbar parts.
CXTPScrollBase
CXTPScrollBase is the base class for all scrollable objects.
Definition XTPScrollBase.h:222


Toolkit Pro: Member List

CXTPDockingPaneVisualStudio2019Theme Member List

This is the complete list of members for CXTPDockingPaneVisualStudio2019Theme, including all inherited members.

AdjustCaptionRect(const CXTPDockingPaneTabbedContainer *pPane, CRect &rc) | CXTPDockingPaneVisualStudio2012Theme | virtual
CXTPDockingPaneDefaultTheme::AdjustCaptionRect(const CXTPDockingPaneSidePanel *pPane, CRect &rc) | CXTPDockingPanePaintManager | virtual
AdjustClientRect(CXTPDockingPaneTabbedContainer *pPane, CRect &rc, BOOL bApply) | CXTPDockingPaneVisualStudio2012Theme | virtual
CXTPDockingPaneDefaultTheme::AdjustClientRect(CXTPDockingPaneSidePanel *pPane, CRect &rect) | CXTPDockingPanePaintManager | virtual
ClipAndAddEllipsisIfNeeded(CDC *pDC, CString &strTitle, int nCaptionWidth) const | CXTPDockingPanePaintManager | protected
CXTPCmdTarget() | CXTPCmdTarget |
CXTPDockingPaneDefaultTheme() | CXTPDockingPaneDefaultTheme |
CXTPDockingPanePaintManager() | CXTPDockingPanePaintManager | protected
CXTPDockingPaneVisualStudio2012Theme() | CXTPDockingPaneVisualStudio2012Theme |
CXTPDockingPaneVisualStudio2019Theme() | CXTPDockingPaneVisualStudio2019Theme |
DeletePaneColorSets() | CXTPDockingPaneVisualStudio2012Theme | protected
DrawAutoHidePanel(CDC *pDC, CRect rc, XTPDockingPaneDirection direction) | CXTPDockingPaneVisualStudio2019Theme | virtual
DrawCaption(CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc) | CXTPDockingPaneVisualStudio2012Theme | virtual
DrawCaptionButton(CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton) | CXTPDockingPaneVisualStudio2012Theme | virtual
DrawCaptionButtonEntry(CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton, CSize szOffset) | CXTPDockingPanePaintManager | protectedvirtual
DrawCaptionButtonEntry(CDC *pDC, CXTPDockingPaneCaptionButton *pButton, CPoint pt, COLORREF clrButton) | CXTPDockingPanePaintManager | protectedvirtual
DrawCaptionButtons(CDC *pDC, CXTPDockingPaneCaptionButtons *pButtons, CRect &rcCaption, COLORREF clr, int nButtonSize, int nButtonGap, BOOL bVertical=FALSE) | CXTPDockingPanePaintManager | virtual
DrawCaptionPart(CDC *pDC, CXTPDockingPaneBase *pPane, CRect rcCaption, const CString &strTitle, BOOL bActive, BOOL bVertical) | CXTPDockingPaneDefaultTheme | protectedvirtual
DrawCaptionText(CDC *pDC, const CString &strTitle, CRect rc, BOOL bVertical, BOOL bCalcWidth=FALSE) | CXTPDockingPanePaintManager |
DrawDottedLine(CDC *pDC, int x, int y, int nSize, COLORREF clr, BOOL bVertical) | CXTPDockingPaneVisualStudio2012Theme | protected
DrawFloatingFrame(CDC *pDC, CXTPDockingPaneMiniWnd *pPane, CRect rc) | CXTPDockingPaneVisualStudio2012Theme | virtual
DrawGripper(CDC *pDC, CRect rcGripper, COLORREF clr, BOOL bVertical) | CXTPDockingPaneVisualStudio2012Theme | protected
DrawPane(CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc) | CXTPDockingPaneVisualStudio2012Theme | virtual
DrawSidePanel(CDC *pDC, CXTPDockingPaneSidePanel *pPane, CRect rc) | CXTPDockingPaneVisualStudio2012Theme | virtual
DrawSplitter(CDC *pDC, CXTPDockingPaneSplitterWnd *pSplitter) | CXTPDockingPaneVisualStudio2019Theme | virtual
DrawTitleBar(CDC *pDC, CXTPDockingPaneBase *pPane, CRect rc, BOOL bVertical) | CXTPDockingPaneVisualStudio2019Theme | protectedvirtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCaptionButtonStyle() const | CXTPDockingPanePaintManager |
GetCaptionGripperRect(const CXTPDockingPaneTabbedContainer *pPane) | CXTPDockingPanePaintManager | virtual
GetCaptionHeight() const | CXTPDockingPanePaintManager |
GetCaptionRect(const CXTPDockingPaneTabbedContainer *pPane, CRect &rc) | CXTPDockingPanePaintManager | virtual
GetColorSet(BOOL bActive) | CXTPDockingPaneVisualStudio2012Theme | protectedvirtual
GetCurrentSystemTheme() const | CXTPDockingPanePaintManager |
GetCustomTitleBrush(BOOL bActive, BOOL bVertical) const | CXTPDockingPanePaintManager |
GetPaneCaptionRect(const CXTPDockingPaneSidePanel *pPane) | CXTPDockingPaneVisualStudio2012Theme | virtual
GetPanelPaintManager() const | CXTPDockingPanePaintManager |
GetSplitterStyle() const | CXTPDockingPanePaintManager |
GetTabPaintManager() const | CXTPDockingPanePaintManager |
GetTabsHeight() const | CXTPDockingPanePaintManager |
GetXtremeColor(UINT nIndex) | CXTPDockingPanePaintManager |
Line(CDC *pDC, int x0, int y0, int x1, int y1, int nPen) | CXTPDockingPanePaintManager |
Line(CDC *pDC, int x0, int y0, int x1, int y1) | CXTPDockingPanePaintManager |
m_arrColor | CXTPDockingPanePaintManager | protected
m_bDestroyCustomTitleBrushes | CXTPDockingPanePaintManager | protected
m_bDrawCaptionIcon | CXTPDockingPanePaintManager |
m_bDrawSingleTab | CXTPDockingPanePaintManager |
m_bHighlightActiveCaption | CXTPDockingPanePaintManager |
m_bLunaTheme | CXTPDockingPanePaintManager | protected
m_bShowCaption | CXTPDockingPanePaintManager |
m_bUseBoldCaptionFont | CXTPDockingPanePaintManager |
m_bUseOfficeFont | CXTPDockingPanePaintManager | protected
m_bUseStandardFont | CXTPDockingPanePaintManager | protected
m_clrActiveCaption | CXTPDockingPanePaintManager |
m_clrActiveCaptionText | CXTPDockingPanePaintManager |
m_clrBackground | CXTPDockingPanePaintManager |
m_clrCaptionBorder | CXTPDockingPaneVisualStudio2019Theme | protected
m_clrDisabledCaptionText | CXTPDockingPanePaintManager |
m_clrNormalCaption | CXTPDockingPanePaintManager |
m_clrNormalCaptionText | CXTPDockingPanePaintManager |
m_clrSplitter | CXTPDockingPanePaintManager |
m_clrSplitterGradient | CXTPDockingPanePaintManager |
m_clrSplitterGripper | CXTPDockingPanePaintManager |
m_dwSplitterStyle | CXTPDockingPanePaintManager | protected
m_hbrActiveTitleHorz | CXTPDockingPanePaintManager | protected
m_hbrActiveTitleVert | CXTPDockingPanePaintManager | protected
m_hbrInactiveTitleHorz | CXTPDockingPanePaintManager | protected
m_hbrInactiveTitleVert | CXTPDockingPanePaintManager | protected
m_nCaptionButtonStyle | CXTPDockingPanePaintManager | protected
m_nCaptionFontGap | CXTPDockingPanePaintManager | protected
m_nFontSize | CXTPDockingPaneVisualStudio2012Theme | protected
m_nSplitterIndent | CXTPDockingPanePaintManager |
m_nSplitterSize | CXTPDockingPanePaintManager |
m_nTabsHeight | CXTPDockingPanePaintManager | protected
m_nTitleHeight | CXTPDockingPanePaintManager | protected
m_pcsActive | CXTPDockingPaneVisualStudio2012Theme | protected
m_pcsInactive | CXTPDockingPaneVisualStudio2012Theme | protected
m_pPanelPaintManager | CXTPDockingPanePaintManager | protected
m_pTabPaintManager | CXTPDockingPanePaintManager | protected
m_rcCaptionMargin | CXTPDockingPanePaintManager | protected
m_strFontFace | CXTPDockingPaneVisualStudio2012Theme | protected
m_strOfficeFont | CXTPDockingPanePaintManager | protected
m_systemTheme | CXTPDockingPanePaintManager | protected
m_themeButton | CXTPDockingPanePaintManager | protected
m_themeCurrent | CXTPDockingPanePaintManager | protected
m_themeExplorer | CXTPDockingPanePaintManager | protected
m_themeRebar | CXTPDockingPanePaintManager | protected
m_themeToolbar | CXTPDockingPanePaintManager | protected
m_themeWindow | CXTPDockingPanePaintManager | protected
m_xtpFontTitle | CXTPDockingPanePaintManager | protected
m_xtpFontTitleVertical | CXTPDockingPanePaintManager | protected
Pixel(CDC *pDC, int xPos, int yPos, int nPen) | CXTPDockingPanePaintManager |
Rectangle(CDC *pDC, CRect rc, int nPenEntry, int nPenBorder) | CXTPDockingPanePaintManager |
RefreshMetrics() | CXTPDockingPaneVisualStudio2019Theme | virtual
SetCaptionButtonStyle(XTPDockingPaneCaptionButtonStyle nStyle) | CXTPDockingPanePaintManager |
SetCaptionFontIndirect(LOGFONT *pLogFont, BOOL bUseStandardFont=FALSE) | CXTPDockingPanePaintManager |
SetColors(int cElements, CONST INT *lpaElements, CONST COLORREF *lpaRgbValues) | CXTPDockingPanePaintManager |
SetCustomTitleBrushes(HBRUSH hbrActiveTitleHorz, HBRUSH hbrInactiveTitleHorz=NULL, HBRUSH hbrActiveTitleVert=NULL, HBRUSH hbrInactiveTitleVert=NULL, BOOL bDestroyOnCleanup=FALSE) | CXTPDockingPanePaintManager |
SetLunaTheme(XTPCurrentSystemTheme systemTheme) | CXTPDockingPanePaintManager |
SetPaneColorSets(CXTPDockingPaneColorSet *pcsActive, CXTPDockingPaneColorSet *pcsInactive) | CXTPDockingPaneVisualStudio2012Theme | protected
SetPanelPaintManager(CXTPTabPaintManager *pManager) | CXTPDockingPanePaintManager |
SetSplitterStyle(DWORD dwStyle) | CXTPDockingPanePaintManager |
SetTabPaintManager(CXTPTabPaintManager *pManager) | CXTPDockingPanePaintManager |
UseOfficeFont(BOOL bUseOfficeFont) | CXTPDockingPanePaintManager |
~CXTPDockingPanePaintManager() | CXTPDockingPanePaintManager | protectedvirtual
~CXTPDockingPaneVisualStudio2012Theme() | CXTPDockingPaneVisualStudio2012Theme | virtual
~CXTPDockingPaneVisualStudio2019Theme() | CXTPDockingPaneVisualStudio2019Theme | virtual


Toolkit Pro: XTPTabThemePropertyPage2007.h Source File

  • Source
  • TabManager
  • Themes
XTPTabThemePropertyPage2007.h
Go to the documentation of this file.
1
23#if !defined(__XTPTABTHEMEPROPERTYPAGE2007_H__)
24# define __XTPTABTHEMEPROPERTYPAGE2007_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
43class _XTP_EXT_CLASS CAppearanceSetPropertyPage2007 : public CXTPTabPaintManagerTheme
44{
45public:
50 CAppearanceSetPropertyPage2007()
51 {
52 m_rcHeaderMargin.SetRect(4, 1, 0, 0);
53 }
54
55protected:
64 virtual void RefreshMetrics();
65
84 virtual void DrawSingleButton(CDC* pDC, CXTPTabManagerItem* pItem);
85
105 virtual CRect FillTabControl(CXTPTabManager* pTabManager, CDC* pDC, CRect rcControl);
106
115 virtual XTPTabColorStyle GetDefaultColorSet()
116 {
117 return xtpTabColorResource;
118 }
119
121protected:
122 typedef void(AFX_CDECL* LPFNDRAWROTATEDBITS)(int cx, int cy, UINT* pSrcBits, UINT* pDestBits);
123 void DrawRotatedButton(CDC* pDC, CRect rcItem, CXTPTabManagerItem* pItem, BOOL bSwap,
124 LPFNDRAWROTATEDBITS pfnRotatedProcBack,
125 LPFNDRAWROTATEDBITS pfnRotatedProc);
126 virtual void DrawButtonBackground(CDC* pDC, CXTPTabManagerItem* pItem, CRect rc);
128};
129
130# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
132#endif // !defined(__XTPTABTHEMEPROPERTYPAGE2007_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPTabColorStyle
XTPTabColorStyle
XTPTabColorStyle is an enumeration used to set the color style of tabs.
Definition XTPTabManagerDefines.h:139
xtpTabColorResource
@ xtpTabColorResource
Tabs will use the Office 2007 color style for the currently set Appearance.
Definition XTPTabManagerDefines.h:146
CAppearanceSetPropertyPage2007
CAppearanceSetPropertyPage2007 implements an Office 2007 tab appearance.
Definition XTPTabThemePropertyPage2007.h:44
CAppearanceSetPropertyPage2007::GetDefaultColorSet
virtual XTPTabColorStyle GetDefaultColorSet()
Gets the default value of the color set for this theme.
Definition XTPTabThemePropertyPage2007.h:115
CAppearanceSetPropertyPage2007::CAppearanceSetPropertyPage2007
CAppearanceSetPropertyPage2007()
Constructs a CAppearanceSetPropertyPage2007 object.
Definition XTPTabThemePropertyPage2007.h:50
CAppearanceSetPropertyPage2007::FillTabControl
virtual CRect FillTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl)
Fills both the tab header and the tab client area and then draws the tab client frame.
CAppearanceSetPropertyPage2007::DrawSingleButton
virtual void DrawSingleButton(CDC *pDC, CXTPTabManagerItem *pItem)
Draws a single tab button in the tab client header area.
CAppearanceSetPropertyPage2007::RefreshMetrics
virtual void RefreshMetrics()
Refreshes the appearance metrics.
CXTPTabManager
CXTPTabManager is the base class for docking pane tabs, tab control tabs, and MDI client tabs.
Definition XTPTabManager.h:87
CXTPTabManagerItem
CXTPTabManagerItem is the base class for the tabs that appear in the command bars tab workspace,...
Definition XTPTabManagerItem.h:44
CXTPTabPaintManagerTheme
CXTPTabPaintManagerTheme is a class that represents the appearance of all components of the tab manag...
Definition XTPTabPaintManagerTheme.h:56


Toolkit Pro: Member List

CXTPChartBarSeriesStyle Member List

This is the complete list of members for CXTPChartBarSeriesStyle, including all inherited members.

ApplyTo(CXTPChartDeviceCommand *pCommand) | CXTPChartSeriesStyle | virtual
CorrectAxisSideMargins(CXTPChartAxis *pAxis, double nMinValue, double nMaxValue, double &nCorrection) | CXTPChartBarSeriesStyle | protectedvirtual
CreateDiagram() | CXTPChartDiagram2DSeriesStyle | virtual
CreateView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView) | CXTPChartBarSeriesStyle | protectedvirtual
CXTPChartBarSeriesStyle() | CXTPChartBarSeriesStyle |
CXTPChartDiagram2DSeriesStyle() | CXTPChartDiagram2DSeriesStyle |
CXTPChartElement() | CXTPChartElement |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartSeriesStyle() | CXTPChartSeriesStyle |
DoPropExchange(CXTPPropExchange *pPX) | CXTPChartBarSeriesStyle | virtual
Enable3dEdgeSmoothing(BOOL bEnable=TRUE) | CXTPChartSeriesStyle | virtual
Get3dRotation() const | CXTPChartSeriesStyle | virtual
GetAppearance() const | CXTPChartElement |
GetBarWidth() const | CXTPChartBarSeriesStyle |
GetColor() const | CXTPChartSeriesStyle | virtual
GetContent() const | CXTPChartElement |
GetErrorBar() const | CXTPChartSeriesStyle | virtual
GetLabel() const | CXTPChartSeriesStyle | virtual
GetOwner() const | CXTPChartElement |
GetSeriesPointValueIndex() const | CXTPChartSeriesStyle | virtual
GetStyleAppearance() const | CXTPChartSeriesStyle | virtual
GetTransparency() const | CXTPChartSeriesStyle | virtual
Is3D() const | CXTPChartObject |
Is3dEdgeSmoothingEnabled() const | CXTPChartSeriesStyle | virtual
IsColorEach() const | CXTPChartSeriesStyle | virtual
IsStyleDiagram(CXTPChartDiagram *pDiagram) const | CXTPChartDiagram2DSeriesStyle | virtual
m_bColorEach | CXTPChartSeriesStyle | protected
m_bSmooth3dEdges | CXTPChartSeriesStyle | protected
m_clrColor | CXTPChartSeriesStyle | protected
m_nAxisIndexX | CXTPChartDiagram2DSeriesStyle | protected
m_nAxisIndexY | CXTPChartDiagram2DSeriesStyle | protected
m_nTransparency | CXTPChartSeriesStyle | protected
m_pErrorBar | CXTPChartSeriesStyle | protected
m_pLabel | CXTPChartSeriesStyle | protected
m_Rotation3d | CXTPChartSeriesStyle | protected
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartElement | virtual
Release() | CXTPChartElement | virtual
Set3dRotation(const CXTPChart3dRotation &rotation) | CXTPChartSeriesStyle | virtual
Set3dRotation(double dYaw, double dPitch, double dRoll) | CXTPChartSeriesStyle | virtual
SetBarWidth(double dWidth) | CXTPChartBarSeriesStyle |
SetColor(CXTPChartColor clr) | CXTPChartSeriesStyle | virtual
SetColorEach(BOOL bColorEach) | CXTPChartSeriesStyle | virtual
SetErrorBar(CXTPChartErrorBar *pErrorBar) | CXTPChartSeriesStyle | virtual
SetLabel(CXTPChartSeriesLabel *pLabel) | CXTPChartSeriesStyle | virtual
SetTransparency(int nTransparency) | CXTPChartSeriesStyle | virtual
~CXTPChartBarSeriesStyle() | CXTPChartBarSeriesStyle | virtual
~CXTPChartDiagram2DSeriesStyle() | CXTPChartDiagram2DSeriesStyle | virtual
~CXTPChartElement() | CXTPChartElement | virtual
~CXTPChartSeriesStyle() | CXTPChartSeriesStyle | virtual


Toolkit Pro: Member List

CXTPCalendarEventColorEdit Member List

This is the complete list of members for CXTPCalendarEventColorEdit, including all inherited members.

CXTPCalendarEventColorEdit(int nIndex) | CXTPCalendarEventColorEdit
GetIndex() const | CXTPCalendarEventColorEdit


Toolkit Pro: Member List

CXTPCalendarTimeLineViewEvent Member List

This is the complete list of members for CXTPCalendarTimeLineViewEvent, including all inherited members.

_MoveRectY(int nYbasePrev, int nYbaseNew, CRect &rRC) | CXTPCalendarViewEvent | static
AddMultiDayEvent_Slave(CXTPCalendarViewEvent *pSlaveView, int nMasterEventPlace) | CXTPCalendarViewEvent | virtual
AdjustLayout(CDC *pDC, const CRect &rcEventMax, int nEventPlaceNumber) | CXTPCalendarTimeLineViewEvent | virtual
AdjustLayout2(CDC *pDC, const CRect &rcEventMax, int nEventPlaceNumber) | CXTPCalendarTimeLineViewEvent | inlinevirtual
AdjustMultidayEvent(CRect rcEventMax, int nEventPlaceNumber) | CXTPCalendarViewEvent | protectedvirtual
AdjustSubjectEditor() | CXTPCalendarViewEvent | virtual
CalcIconsRect(CRect rc) | CXTPCalendarViewEvent | virtual
CalcRect(CDC *pDC) | CXTPCalendarTimeLineViewEvent |
ChangeEventPlace(int nNewPlace) | CXTPCalendarTimeLineViewEvent | virtual
CXTPCalendarTimeLineViewEvent(CXTPCalendarEvent *pEvent, CXTPCalendarTimeLineViewGroup *pGroup) | CXTPCalendarTimeLineViewEvent |
CXTPCalendarViewEvent(CXTPCalendarEvent *pEvent, CXTPCalendarViewGroup *pViewGroup) | CXTPCalendarViewEvent |
CXTPCalendarWMHandler() | CXTPCalendarWMHandler |
CXTPCmdTarget() | CXTPCmdTarget |
Draw(CDC *pDC) | CXTPCalendarTimeLineViewEvent | virtual
EndEditSubject() | CXTPCalendarViewEvent | virtual
FormatEventTime(COleDateTime dtTime) const | CXTPCalendarViewEvent | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCalendarControl() const | CXTPCalendarViewEvent | virtual
GetChildHandlerAt(int nIndex) const | CXTPCalendarWMHandler | virtual
GetChildHandlersCount() const | CXTPCalendarWMHandler | virtual
GetEditingSubjectFromEditor() const | CXTPCalendarViewEvent | virtual
GetEndTimeRect() const | CXTPCalendarViewEvent | virtual
GetEvent() const | CXTPCalendarViewEvent | virtual
GetEventDurationInPixels() const | CXTPCalendarTimeLineViewEvent | virtual
GetEventPlaceNumber() const | CXTPCalendarViewEvent | virtual
GetEventRect() const | CXTPCalendarViewEvent |
GetEventTimelinePlaceNumber() const | CXTPCalendarViewEvent | virtual
GetFirstClockRect() const | CXTPCalendarViewEvent | virtual
GetItemText(DWORD dwItemFlag, LPCTSTR pcszDefaultText=NULL) const | CXTPCalendarViewEvent | virtual
GetItemTextBody() const | CXTPCalendarViewEvent | virtual
GetItemTextEndTime() const | CXTPCalendarViewEvent | virtual
GetItemTextLocation() const | CXTPCalendarViewEvent | virtual
GetItemTextStartTime() const | CXTPCalendarViewEvent | virtual
GetItemTextSubject() const | CXTPCalendarViewEvent | virtual
GetLastClockRect() const | CXTPCalendarViewEvent | virtual
GetLastVisibleRect() const | CXTPCalendarTimeLineViewEvent |
GetMarkupText() const | CXTPCalendarViewEvent | virtual
GetMarkupUIElement() | CXTPCalendarViewEvent | virtual
GetMeetingGlyphRect() const | CXTPCalendarViewEvent | virtual
GetMultiDayEventFlags() const | CXTPCalendarViewEvent | virtual
GetPart() const | CXTPCalendarTimeLineViewEvent | virtual
GetPrivateGlyphRect() const | CXTPCalendarViewEvent | virtual
GetRecurrenceGlyphRect() const | CXTPCalendarViewEvent | virtual
GetReminderGlyphRect() const | CXTPCalendarViewEvent | virtual
GetShowToolTipTimeOut() const | CXTPCalendarViewEvent | virtual
GetStartTimeRect() const | CXTPCalendarViewEvent | virtual
GetSubjectEditor() const | CXTPCalendarViewEvent | virtual
GetSubjectEditorFont() const | CXTPCalendarViewEvent | virtual
GetSubjectEditorRect() const | CXTPCalendarViewEvent | virtual
GetSubjectEditorStyles() const | CXTPCalendarViewEvent | virtual
GetTextRect() const | CXTPCalendarViewEvent | virtual
GetToolText() | CXTPCalendarViewEvent | protectedvirtual
GetView() const | CXTPCalendarTimeLineViewEvent |
GetViewEventRect() const | CXTPCalendarViewEvent | virtual
GetViewEventRectMax() const | CXTPCalendarViewEvent | virtual
GetViewGroup() const | CXTPCalendarTimeLineViewEvent | inline
GetViewGroup_() const | CXTPCalendarTimeLineViewEvent | virtual
HideToolTip() | CXTPCalendarViewEvent | virtual
HitTest(CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const | CXTPCalendarTimeLineViewEvent | inlinevirtual
HitTestEx(CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const | CXTPCalendarTimeLineViewEvent | inlinevirtual
IsEditingSubject() const | CXTPCalendarViewEvent | virtual
IsMultidayEvent() const | CXTPCalendarViewEvent | virtual
IsMultyDayTextAlign() const | CXTPCalendarViewEvent | virtual
IsSelected() const | CXTPCalendarTimeLineViewEvent | virtual
IsShowingToolTip() | CXTPCalendarViewEvent | virtual
IsTextOutOfBorders() const | CXTPCalendarViewEvent | virtual
IsVisible() const | CXTPCalendarTimeLineViewEvent | inlinevirtual
KillTimer(UINT uTimerID) | CXTPCalendarViewEvent | virtual
m_bMultyDayTextAlign | CXTPCalendarViewEvent | protected
m_bSelected | CXTPCalendarViewEvent | protected
m_bTextOutOfBorders | CXTPCalendarViewEvent | protected
m_nEventDurationInPixels | CXTPCalendarTimeLineViewEvent | protected
m_nEventPlaceNumber | CXTPCalendarViewEvent | protected
m_nEventTimelinePlaceNumber | CXTPCalendarViewEvent | protected
m_nMultiDayEventFlags | CXTPCalendarViewEvent |
m_nTimerID_ShowToolTip | CXTPCalendarViewEvent | protected
m_pGroup | CXTPCalendarTimeLineViewEvent | protected
m_pMasterView | CXTPCalendarViewEvent | protected
m_pSubjectEditor | CXTPCalendarViewEvent | protected
m_ptrEvent | CXTPCalendarViewEvent | protected
m_pUIElement | CXTPCalendarViewEvent |
m_rcEndTime | CXTPCalendarViewEvent |
m_rcEvent | CXTPCalendarViewEvent |
m_rcEventMax | CXTPCalendarViewEvent |
m_rcFirstClock | CXTPCalendarViewEvent |
m_rcLastClock | CXTPCalendarViewEvent |
m_rcMeetingGlyph | CXTPCalendarViewEvent |
m_rcPrivateGlyph | CXTPCalendarViewEvent |
m_rcRecurrenceGlyph | CXTPCalendarViewEvent |
m_rcReminderGlyph | CXTPCalendarViewEvent |
m_rcStartTime | CXTPCalendarViewEvent |
m_rcSubjectEditor | CXTPCalendarViewEvent |
m_rcText | CXTPCalendarViewEvent |
m_rcToolTip | CXTPCalendarViewEvent |
m_strUIElementText | CXTPCalendarViewEvent |
m_szText | CXTPCalendarViewEvent |
OnBeforeDestroy() | CXTPCalendarViewEvent | virtual
OnChar(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnKeyUp(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnLButtonDblClk(UINT nFlags, CPoint point) | CXTPCalendarViewEvent | virtual
OnLButtonDown(UINT nFlags, CPoint point) | CXTPCalendarViewEvent | virtual
OnLButtonUp(UINT nFlags, CPoint point) | CXTPCalendarViewEvent | virtual
OnMouseMove(UINT nFlags, CPoint point) | CXTPCalendarViewEvent | virtual
OnPostAdjustLayout() | CXTPCalendarViewEvent | virtual
OnSysKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnTimer(UINT_PTR uTimerID) | CXTPCalendarViewEvent | virtual
OnWndMsg(UINT message, WPARAM wParam, LPARAM lParam, LRESULT *pResult) | CXTPCalendarViewEvent | virtual
SetLastVisibleRect(const CRect &rc) | CXTPCalendarTimeLineViewEvent |
SetMultiDayEvent_MasterSlave(BOOL bMaster, CXTPCalendarViewEvent *pMasterView) | CXTPCalendarViewEvent | virtual
SetSelected(BOOL bSet=TRUE) | CXTPCalendarViewEvent | virtual
SetTextOutOfBorders(BOOL bOutOfBorders) | CXTPCalendarViewEvent | virtual
SetTimer(UINT uTimeOut_ms) | CXTPCalendarViewEvent | virtual
ShowToolTip() | CXTPCalendarViewEvent | virtual
StartEditSubject() | CXTPCalendarViewEvent | virtual
~CXTPCalendarViewEvent() | CXTPCalendarViewEvent | virtual


Toolkit Pro: Member List

CXTPChartPieSeriesLabel Member List

This is the complete list of members for CXTPChartPieSeriesLabel, including all inherited members.

CalculateAnchorPointAndAngles(CXTPChartPieSeriesPointViewBase *pPointView, int borderThickness, double &lineAngle) | CXTPChartPieSeriesLabel |
CreateView(CXTPChartDeviceContext *pDC, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView) | CXTPChartPieSeriesLabel | protectedvirtual
CXTPChartElement() | CXTPChartElement |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartPieSeriesLabel() | CXTPChartPieSeriesLabel |
CXTPChartPieSeriesLabelBase() | CXTPChartPieSeriesLabelBase |
CXTPChartSeriesLabel() | CXTPChartSeriesLabel |
DoPropExchange(CXTPPropExchange *pPX) | CXTPChartPieSeriesLabelBase | virtual
GetAntialiasing() const | CXTPChartSeriesLabel | virtual
GetAppearance() const | CXTPChartElement |
GetBackColor() const | CXTPChartSeriesLabel |
GetContent() const | CXTPChartElement |
GetFont() const | CXTPChartSeriesLabel | virtual
GetFormat() const | CXTPChartSeriesLabel |
GetLineColor() const | CXTPChartSeriesLabel |
GetLineLength() const | CXTPChartSeriesLabel |
GetOwner() const | CXTPChartElement |
GetPosition() const | CXTPChartPieSeriesLabelBase |
GetShowLines() const | CXTPChartSeriesLabel |
GetStyle() const | CXTPChartPieSeriesLabelBase |
GetTextColor() const | CXTPChartSeriesLabel |
GetTransparency() const | CXTPChartSeriesLabel |
Is3D() const | CXTPChartObject |
IsInside() const | CXTPChartPieSeriesLabelBase |
IsVisible() const | CXTPChartSeriesLabel |
m_bAntialiasing | CXTPChartSeriesLabel | protected
m_bShowLines | CXTPChartSeriesLabel | protected
m_bVisible | CXTPChartSeriesLabel | protected
m_clrBackColor | CXTPChartSeriesLabel | protected
m_clrLineColor | CXTPChartSeriesLabel | protected
m_clrTextColor | CXTPChartSeriesLabel | protected
m_nLineLength | CXTPChartSeriesLabel | protected
m_nPosition | CXTPChartPieSeriesLabelBase | protected
m_nTransparency | CXTPChartSeriesLabel | protected
m_pBorder | CXTPChartSeriesLabel | protected
m_pFont | CXTPChartSeriesLabel | protected
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartElement | virtual
Release() | CXTPChartElement | virtual
SetAntialiasing(BOOL bAntialiasing) | CXTPChartSeriesLabel |
SetBackColor(const CXTPChartColor &clrBackColor) | CXTPChartSeriesLabel |
SetFont(CXTPChartFont *pFont) | CXTPChartSeriesLabel |
SetFormat(LPCTSTR lpszFormat) | CXTPChartSeriesLabel |
SetLineColor(const CXTPChartColor &clrBackColor) | CXTPChartSeriesLabel |
SetLineLength(int nLineLength) | CXTPChartSeriesLabel |
SetPosition(XTPChartPieLabelPosition nPosition) | CXTPChartPieSeriesLabelBase |
SetShowLines(BOOL bShowLines) | CXTPChartSeriesLabel |
SetTextColor(const CXTPChartColor &clrTextColor) | CXTPChartSeriesLabel |
SetTransparency(int nTransparency) | CXTPChartSeriesLabel |
SetVisible(BOOL bVisible) | CXTPChartSeriesLabel |
~CXTPChartElement() | CXTPChartElement | virtual
~CXTPChartPieSeriesLabelBase() | CXTPChartPieSeriesLabelBase | virtual
~CXTPChartSeriesLabel() | CXTPChartSeriesLabel | virtual


Toolkit Pro: XTPChartPyramidDiagram.h Source File

  • Source
  • Chart
  • Styles
  • Pyramid
XTPChartPyramidDiagram.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTPYRAMIDDIAGRAM_H__)
24# define __XTPCHARTPYRAMIDDIAGRAM_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Chart/Styles/Pyramid/Base/XTPChartPyramidDiagramBase.h"
32# include "Chart/Styles/Pyramid/2D/XTPChart2dPyramidDiagram.h"
33
35typedef CXTPChartPyramidDiagram CXTPChart2dPyramidDiagram;
37#endif //#if !defined(__XTPCHARTPYRAMIDDIAGRAM_H__)
XTPChart2dPyramidDiagram.h
CXTPChart2dPyramidDiagram
CXTPChartPyramidDiagram CXTPChart2dPyramidDiagram
CXTPChart2dPyramidDiagram alias is necessary for naming consistency.
Definition XTPChartPyramidDiagram.h:35
XTPChartPyramidDiagramBase.h
CXTPChartPyramidDiagram
This class abstracts the pyramid diagram.
Definition XTPChart2dPyramidDiagram.h:43


Toolkit Pro: XTPRibbonThemeResource.h Source File

  • Source
  • Ribbon
  • Themes
XTPRibbonThemeResource.h
Go to the documentation of this file.
1
23#if !defined(__XTPRIBBONTHEMERESOURCE_H__)
24# define __XTPRIBBONTHEMERESOURCE_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPRibbonThemeResource : public CXTPRibbonPaintManager
39{
40public:
46 CXTPRibbonThemeResource(CXTPPaintManager* pPaintManager);
47
52 virtual ~CXTPRibbonThemeResource();
53
63 virtual void RefreshMetrics();
64
65public: // Drawing interface
77 virtual void DrawGroup(CDC* pDC, CXTPRibbonGroup* pGroup);
78
92 virtual void FillGroupRect(CDC* pDC, CXTPRibbonTab* pActiveTab, CRect rcGroups);
93
113 virtual CSize DrawControlGroupPopup(CDC* pDC, CXTPControlPopup* pControlGroupPopup, BOOL bDraw);
114
122 virtual void FillGroupPopupToolBar(CDC* pDC, CXTPRibbonGroup* pGroup,
123 CXTPCommandBar* pCommandBar);
124
131 virtual void FillRibbonBar(CDC* pDC, CXTPRibbonBar* pRibbonBar);
132
149 virtual CSize DrawControlGroupOption(CDC* pDC, CXTPControl* pControlGroupOption, BOOL bDraw);
150
158 virtual void DrawRibbonFrameContextHeaders(CDC* pDC, CXTPRibbonBar* pRibbonBar,
159 CXTPRibbonTabContextHeaders* pContextHeaders);
160
169 virtual void FillRibbonTabControl(CDC* pDC, CXTPRibbonBar* pRibbonBar, CRect rcControl);
170
177 virtual void DrawRibbonTab(CDC* pDC, CXTPRibbonTab* pItem);
178
187 virtual void DrawRibbonFrameCaptionBar(CDC* pDC, CXTPRibbonBar* pRibbonBar, BOOL bActive);
188
196 virtual void DrawRibbonFrameCaption(CDC* pDC, CXTPRibbonBar* pRibbonBar, BOOL bActive);
197
204 virtual void DrawRibbonQuickAccessControls(CDC* pDC, CXTPRibbonBar* pRibbonBar);
205
214 virtual void DrawRibbonQuickAccessButton(CDC* pDC, CXTPControlPopup* pControl);
215
224 virtual void DrawRibbonQuickAccessMoreButton(CDC* pDC, CXTPControlPopup* pControl);
225
233 virtual void DrawRibbonFrameSystemButton(CDC* pDC, CXTPRibbonControlSystemButton* pControl,
234 CRect rc);
235
243 virtual void DrawRibbonScrollButton(CDC* pDC, CXTPControl* pControl, BOOL bScrollLeft);
244
251 virtual void FillMorePopupToolBarEntry(CDC* pDC, CXTPCommandBar* pBar);
252
259 virtual void FillSystemPopupBarEntry(CDC* pDC, CXTPPopupBar* pBar);
260
267 virtual void DrawSystemPopupBarButton(CDC* pDC, CXTPControl* pButton);
268
278 virtual BOOL DrawRibbonGroupControlEntry(CDC* pDC, CXTPControl* pButton);
279
280public:
288 virtual int GetRibbonCaptionHeight(const CXTPRibbonBar* pRibbonBar) const;
289
296 virtual CSize GetControlGroupOptionSize() const;
297
298protected:
299 int m_nFileButtonImageCount;
300};
301
302# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
304#endif // !defined(__XTPRIBBONTHEMERESOURCE_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCommandBar
CXTPCommandBar is a CWnd derived class.
Definition XTPCommandBar.h:66
CXTPControl
CXTPControl is a CXTPCmdTarget derived class.
Definition XTPControl.h:841
CXTPControlPopup
CXTPControlPopup is a CXTPControl derived class.
Definition XTPControlPopup.h:42
CXTPPaintManager
Paint manager of the command bars.
Definition XTPPaintManager.h:199
CXTPPopupBar
CXTPPopupBar is a CXTPCommandBar derived class.
Definition XTPPopupBar.h:42
CXTPRibbonBar
CXTPRibbonBar is a CXTPMenuBar derived class.
Definition XTPRibbonBar.h:69
CXTPRibbonControlSystemButton
CXTPRibbonControlSystemButton is a CXTPControlPopup derived class used as a system button for a Ribbo...
Definition XTPRibbonSystemButton.h:39
CXTPRibbonGroup
Represents a single group that is added to a CXTPRibbonTab.
Definition XTPRibbonGroup.h:70
CXTPRibbonPaintManager
Standalone class used by CXTPRibbonBar as a paint manager.
Definition XTPRibbonPaintManager.h:51
CXTPRibbonTab
Represents a tab in the Ribbon Bar.
Definition XTPRibbonTab.h:116
CXTPRibbonThemeResource
CXTPRibbonThemeResource is a CXTPRibbonPaintManager derived class used to represent a Resource ....
Definition XTPRibbonThemeResource.h:39
CXTPRibbonThemeResource::DrawControlGroupOption
virtual CSize DrawControlGroupOption(CDC *pDC, CXTPControl *pControlGroupOption, BOOL bDraw)
Draws the group option button.
CXTPRibbonThemeResource::FillSystemPopupBarEntry
virtual void FillSystemPopupBarEntry(CDC *pDC, CXTPPopupBar *pBar)
This method is called to draw the pop-up bar of the system button.
CXTPRibbonThemeResource::DrawRibbonQuickAccessButton
virtual void DrawRibbonQuickAccessButton(CDC *pDC, CXTPControlPopup *pControl)
This method is called to draw the Quick Access customize button.
CXTPRibbonThemeResource::DrawRibbonFrameSystemButton
virtual void DrawRibbonFrameSystemButton(CDC *pDC, CXTPRibbonControlSystemButton *pControl, CRect rc)
Draws the top-left system button.
CXTPRibbonThemeResource::FillRibbonTabControl
virtual void FillRibbonTabControl(CDC *pDC, CXTPRibbonBar *pRibbonBar, CRect rcControl)
This member fills in the tab header and tab client area.
CXTPRibbonThemeResource::DrawControlGroupPopup
virtual CSize DrawControlGroupPopup(CDC *pDC, CXTPControlPopup *pControlGroupPopup, BOOL bDraw)
Draws the group pop-up button.
CXTPRibbonThemeResource::DrawGroup
virtual void DrawGroup(CDC *pDC, CXTPRibbonGroup *pGroup)
Draws the specified CXTPRibbonGroup.
CXTPRibbonThemeResource::FillRibbonBar
virtual void FillRibbonBar(CDC *pDC, CXTPRibbonBar *pRibbonBar)
This method is called to fill the background of a ribbon bar control.
CXTPRibbonThemeResource::DrawRibbonGroupControlEntry
virtual BOOL DrawRibbonGroupControlEntry(CDC *pDC, CXTPControl *pButton)
This method is called to draw the ribbon group when the group is minimized and only a button is displ...
CXTPRibbonThemeResource::FillGroupPopupToolBar
virtual void FillGroupPopupToolBar(CDC *pDC, CXTPRibbonGroup *pGroup, CXTPCommandBar *pCommandBar)
This method is called to draw the pop-up toolbar of a reduced group.
CXTPRibbonThemeResource::DrawRibbonScrollButton
virtual void DrawRibbonScrollButton(CDC *pDC, CXTPControl *pControl, BOOL bScrollLeft)
This method is called to draw scroll group buttons.
CXTPRibbonThemeResource::FillGroupRect
virtual void FillGroupRect(CDC *pDC, CXTPRibbonTab *pActiveTab, CRect rcGroups)
This method is called to fill the background of a CXTPRibbonGroup.
CXTPRibbonThemeResource::DrawRibbonTab
virtual void DrawRibbonTab(CDC *pDC, CXTPRibbonTab *pItem)
This method is called to draw a single tab of the ribbon bar.
CXTPRibbonThemeResource::DrawRibbonFrameCaption
virtual void DrawRibbonFrameCaption(CDC *pDC, CXTPRibbonBar *pRibbonBar, BOOL bActive)
This method is called to draw the Ribbon caption.
CXTPRibbonThemeResource::GetControlGroupOptionSize
virtual CSize GetControlGroupOptionSize() const
Calculates the ribbon group option size.
CXTPRibbonThemeResource::FillMorePopupToolBarEntry
virtual void FillMorePopupToolBarEntry(CDC *pDC, CXTPCommandBar *pBar)
This method is called to draw the pop-up bar of the more button.
CXTPRibbonThemeResource::DrawSystemPopupBarButton
virtual void DrawSystemPopupBarButton(CDC *pDC, CXTPControl *pButton)
This method is called to draw a pop-up bar button.
CXTPRibbonThemeResource::DrawRibbonQuickAccessControls
virtual void DrawRibbonQuickAccessControls(CDC *pDC, CXTPRibbonBar *pRibbonBar)
This method is called to draw ribbon Quick Access controls.
CXTPRibbonThemeResource::CXTPRibbonThemeResource
CXTPRibbonThemeResource(CXTPPaintManager *pPaintManager)
Constructs a CXTPRibbonThemeResource object.
CXTPRibbonThemeResource::~CXTPRibbonThemeResource
virtual ~CXTPRibbonThemeResource()
Destroys a CXTPRibbonThemeResource object, handles cleanup and deallocation.
CXTPRibbonThemeResource::RefreshMetrics
virtual void RefreshMetrics()
This method is called to refresh the visual metrics of the manager.
CXTPRibbonThemeResource::DrawRibbonQuickAccessMoreButton
virtual void DrawRibbonQuickAccessMoreButton(CDC *pDC, CXTPControlPopup *pControl)
This method is called to draw the Quick Access more button.
CXTPRibbonThemeResource::DrawRibbonFrameContextHeaders
virtual void DrawRibbonFrameContextHeaders(CDC *pDC, CXTPRibbonBar *pRibbonBar, CXTPRibbonTabContextHeaders *pContextHeaders)
This method is called to draw ribbon context headers.
CXTPRibbonThemeResource::DrawRibbonFrameCaptionBar
virtual void DrawRibbonFrameCaptionBar(CDC *pDC, CXTPRibbonBar *pRibbonBar, BOOL bActive)
This method is called to draw the ribbon caption if EnableFrameTheme was not called.
CXTPRibbonThemeResource::GetRibbonCaptionHeight
virtual int GetRibbonCaptionHeight(const CXTPRibbonBar *pRibbonBar) const
Calculates the ribbon caption height.


Toolkit Pro: XTPTabColorSetNativeWindows11.h Source File

  • Source
  • TabManager
  • ColorSets
XTPTabColorSetNativeWindows11.h
Go to the documentation of this file.
1
23#if !defined(__XTPTABCOLORSETNATIVEWINDOWS11_H__)
24# define __XTPTABCOLORSETNATIVEWINDOWS11_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
37class _XTP_EXT_CLASS CXTPTabColorSetNativeWindows11 : public CXTPTabColorSetVisualStudio2012
38{
39public:
40 CXTPTabColorSetNativeWindows11();
41
49 virtual void RefreshMetrics();
50};
51
52# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
54#endif // !defined(__XTPTABCOLORSETNATIVEWINDOWS11_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPTabColorSetNativeWindows11
CXTPTabColorSetNativeWindows11 implements a Native Windows 10 tab color set.
Definition XTPTabColorSetNativeWindows11.h:38
CXTPTabColorSetNativeWindows11::RefreshMetrics
virtual void RefreshMetrics()
Refreshes the visual metrics of the tabs.
CXTPTabColorSetVisualStudio2012
CXTPTabColorSetVisualStudio2012 implements a Visual Studio 2012 tab color set.
Definition XTPTabColorSetVisualStudio2012.h:38


Toolkit Pro: Member List

CXTPEditThemeFlat Member List

This is the complete list of members for CXTPEditThemeFlat, including all inherited members.

AdjustBuddyRect(CWnd *pBuddy, CRect &rcUpDown, int nAlignment) | CXTPEditThemeOfficeXP | virtual
CtlColor(CDC *pDC, UINT nCtlColor, CXTPEdit *pEdit) | CXTPEditThemeDefault | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPControlTheme() | CXTPControlTheme |
CXTPEditTheme() | CXTPEditTheme |
CXTPEditThemeDefault() | CXTPEditThemeDefault |
CXTPEditThemeFlat() | CXTPEditThemeFlat |
CXTPEditThemeOffice2000() | CXTPEditThemeOffice2000 |
CXTPEditThemeOfficeXP() | CXTPEditThemeOfficeXP |
DrawBuddyBorders(CWnd *pBuddy, CDC *pDC, CRect rc, int nAlignment, CXTPEdit *pEdit) | CXTPEditThemeOfficeXP | virtual
CXTPEditThemeOffice2000::DrawBuddyBorders(CDC *pDC, CRect rc, int nAlignment, CXTPEdit *pEdit) | CXTPEditThemeOffice2000 | virtual
DrawFrame(CDC *pDC, CRect rc, int nSize, CBrush *pBrush) | CXTPEditTheme | virtual
DrawNcBorders(CDC *pDC, CRect rcWnd, CXTPEdit *pEdit) | CXTPEditThemeOfficeXP | virtual
DrawNcBordersDefault(CDC *pDC, CRect rcWnd, CXTPEdit *pEdit) | CXTPEditThemeDefault | protectedvirtual
DrawNcScrollBack(CDC *pDC, CRect rcWnd, CXTPEdit *pEdit) | CXTPEditThemeDefault | virtual
FillRect(CDC *pDC, int x, int y, int cx, int cy, CBrush *pBrush) | CXTPEditTheme | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetClientBrush(CDC *pDC, CXTPEdit *pEdit) | CXTPEditTheme | virtual
GetThemeID() const | CXTPEditTheme |
GetThemeStyle() const | CXTPControlTheme |
IsFlatStyle() const | CXTPEditTheme |
m_bFlatStyle | CXTPEditTheme | protected
m_bUseWinTheme | CXTPEditTheme | protected
m_clrBack | CXTPEditTheme |
m_clrBackNonClient | CXTPEditTheme |
m_clrBorder | CXTPEditTheme |
m_clrBorderDisabled | CXTPEditThemeOfficeXP | protected
m_clrBorderHilite | CXTPEditThemeOfficeXP | protected
m_clrText | CXTPEditTheme |
m_clrTextReadOnly | CXTPEditTheme |
m_nTheme | CXTPEditTheme | protected
m_winTheme | CXTPEditTheme | protected
m_xtpBrushBack | CXTPEditTheme |
RedrawFocusedFrame() const | CXTPEditThemeOfficeXP | virtual
RefreshMetrics(CXTPEdit *pEdit) | CXTPEditThemeFlat | virtual
SetFlatStyle(BOOL bFlatStyle) | CXTPEditTheme |
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static
UseWinTheme(BOOL bUseWinTheme) | CXTPEditTheme |
~CXTPEditTheme() | CXTPEditTheme | virtual
~CXTPEditThemeDefault() | CXTPEditThemeDefault | virtual
~CXTPEditThemeFlat() | CXTPEditThemeFlat | virtual
~CXTPEditThemeOffice2000() | CXTPEditThemeOffice2000 | virtual
~CXTPEditThemeOfficeXP() | CXTPEditThemeOfficeXP | virtual


Toolkit Pro: Member List

CXTPMarkupSystemColorStaticExtension Member List

This is the complete list of members for CXTPMarkupSystemColorStaticExtension, including all inherited members.

CXTPMarkupStaticExtension(LPCWSTR lpzName, BOOL bProperty) | CXTPMarkupStaticExtension | protected
CXTPMarkupStaticExtension(LPCWSTR lpzName) | CXTPMarkupStaticExtension |
CXTPMarkupStaticExtensionProperty(LPCWSTR lpzName, CXTPMarkupObject *pObject=NULL) | CXTPMarkupStaticExtensionProperty |
CXTPMarkupSystemColorStaticExtension(LPCWSTR lpzName, int nColorIndex) | CXTPMarkupSystemColorStaticExtension |
Extend(CXTPMarkupStaticExtension *pExtension, BOOL bReplace=FALSE) | CXTPMarkupStaticExtension |
FindExtension(LPCWSTR lpzName) const | CXTPMarkupStaticExtension |
GetName() const | CXTPMarkupStaticExtension |
GetSystemColor(int nColorIndex) | CXTPMarkupSystemColorStaticExtension | static
GetValue() | CXTPMarkupStaticExtensionProperty |
IsProperty() const | CXTPMarkupStaticExtension |
OnPrepareValue() | CXTPMarkupStaticExtension | inlineprotectedvirtual
Parse(LPCWSTR lpzValue, LPCWSTR &lpzSubValue) | CXTPMarkupStaticExtension | static
ProvideValue() | CXTPMarkupStaticExtensionProperty | virtual
ProvideValue(LPCWSTR lpzValue) | CXTPMarkupStaticExtensionProperty | virtual
SetValue(CXTPMarkupObject *pObject) | CXTPMarkupStaticExtensionProperty |
~CXTPMarkupStaticExtension() | CXTPMarkupStaticExtension | virtual
~CXTPMarkupStaticExtensionProperty() | CXTPMarkupStaticExtensionProperty |


Toolkit Pro: Member List

CXTPTabClientContext Member List

This is the complete list of members for CXTPTabClientContext, including all inherited members.

CXTPTabClientContext() | CXTPTabClientContext |
DisableDraggingContents() | CXTPTabClientContext |
DisableTabContextWindow() | CXTPTabClientContext |
DisableTabFocusRect() | CXTPTabClientContext |
DisableTabSticker() | CXTPTabClientContext |
EnableDraggingContents() | CXTPTabClientContext |
EnableFloatingFrameTheme(BOOL value) | CXTPTabClientContext |
EnableTabContextWindow() | CXTPTabClientContext |
EnableTabFocusRect() | CXTPTabClientContext |
EnableTabSticker() | CXTPTabClientContext |
FindTargetTabClient(POINT pt) const | CXTPTabClientContext |
GetAlphaTabClientContext() const | CXTPTabClientContext |
GetLastSelectedTabClientSticker() const | CXTPTabClientContext |
GetLastTargetTabClient() const | CXTPTabClientContext |
GetLastWorkspace() const | CXTPTabClientContext |
GetShowContentsWhileDragging() const | CXTPTabClientContext |
GetShowTabClientContextStickers() const | CXTPTabClientContext |
GetSticker() const | CXTPTabClientContext |
GetTabClient() const | CXTPTabClientContext |
IsFloatingFrameThemeEnabled() const | CXTPTabClientContext |
SetAlphaTabClientContext(BOOL value) | CXTPTabClientContext |
SetShowContentsWhileDragging(BOOL value) | CXTPTabClientContext |
SetShowTabClientContextStickers(BOOL value) | CXTPTabClientContext |
SetTabClient(CXTPTabClientWnd *pTabClientWnd) | CXTPTabClientContext |
UpdateDraggingContents() | CXTPTabClientContext |
UpdateTabContextWindow() | CXTPTabClientContext |
UpdateTabFocusRect(CRect rcGroup) | CXTPTabClientContext |
UpdateTabSticker() | CXTPTabClientContext |
~CXTPTabClientContext() | CXTPTabClientContext | virtual


Toolkit Pro: Member List

CXTPColorSetStateToolbar Member List

This is the complete list of members for CXTPColorSetStateToolbar, including all inherited members.

clrBack | CXTPColorSetStateButton |
clrBackChecked | CXTPColorSetStateButton |
clrBackCheckedHighlight | CXTPColorSetStateButton |
clrBackDisabled | CXTPColorSetStateButton |
clrBackHighlight | CXTPColorSetStateButton |
clrBackPushed | CXTPColorSetStateButton |
clrBorder | CXTPColorSetStateButton |
clrBorderChecked | CXTPColorSetStateButton |
clrBorderCheckedHighlight | CXTPColorSetStateButton |
clrBorderDisabled | CXTPColorSetStateButton |
clrBorderHighlight | CXTPColorSetStateButton |
clrBorderPushed | CXTPColorSetStateButton |
clrDisabledIcon | CXTPColorSetStateToolbar |
clrEditBorder | CXTPColorSetStateToolbar |
clrGripper | CXTPColorSetStateToolbar |
clrSeparator | CXTPColorSetStateToolbar |
clrText | CXTPColorSetStateButton |
clrTextChecked | CXTPColorSetStateButton |
clrTextCheckedHighlight | CXTPColorSetStateButton |
clrTextDisabled | CXTPColorSetStateButton |
clrTextHighlight | CXTPColorSetStateButton |
clrTextPushed | CXTPColorSetStateButton |
clrToolbarActiveBack | CXTPColorSetStateToolbar |
clrToolbarActiveBorder | CXTPColorSetStateToolbar |
clrToolbarBack | CXTPColorSetStateToolbar |
clrToolbarBorder | CXTPColorSetStateToolbar |
clrToolbarInactiveBack | CXTPColorSetStateToolbar |
clrToolbarInactiveBorder | CXTPColorSetStateToolbar |
CXTPCmdTarget() | CXTPCmdTarget |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
RefreshColors() | CXTPColorSetStateToolbar | virtual


Toolkit Pro: XTPScrollBarThemeWindowsUx.h Source File

  • Source
  • Common
  • ScrollBar
  • Themes
XTPScrollBarThemeWindowsUx.h
Go to the documentation of this file.
1
23#if !defined(__XTPSCROLLBARTHEMEWINDOWSUX_H__)
24# define __XTPSCROLLBARTHEMEWINDOWSUX_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPScrollBarThemeWindowsUx : public CXTPScrollBarThemeWindowsClassic
39{
40public:
45 CXTPScrollBarThemeWindowsUx();
46
51 virtual ~CXTPScrollBarThemeWindowsUx();
52
53protected:
58 virtual void RefreshMetrics();
59
67 virtual void DrawButtons(CDC* pDC, CXTPScrollBase* pScroll, XTPScrollMetricsV* pMetrics);
68
76 virtual void DrawTracker(CDC* pDC, CXTPScrollBase* pScroll, XTPScrollMetricsV* pMetrics);
77
85 virtual void DrawThumbButton(CDC* pDC, CXTPScrollBase* pScroll, XTPScrollMetricsV* pMetrics);
86
94 virtual void DrawButtons(CDC* pDC, CXTPScrollBase* pScroll, XTPScrollMetricsH* pMetrics);
95
103 virtual void DrawTracker(CDC* pDC, CXTPScrollBase* pScroll, XTPScrollMetricsH* pMetrics);
104
112 virtual void DrawThumbButton(CDC* pDC, CXTPScrollBase* pScroll, XTPScrollMetricsH* pMetrics);
113
120 virtual void DrawGripper(CDC* pDC, CXTPScrollBase* pScroll);
121
122private:
123 CXTPWinThemeWrapper* m_themeScrollBar;
124};
125
126# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
128#endif /*__XTPSCROLLBARTHEMEWINDOWSUX_H__*/
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPScrollBarThemeWindowsClassic
Scrollbar paint manager used to draw classic Windows scrollbars.
Definition XTPScrollBarThemeWindowsClassic.h:39
CXTPScrollBarThemeWindowsUx
Scrollbar paint manager used to draw scrollbars that use current Windows theme.
Definition XTPScrollBarThemeWindowsUx.h:39
CXTPScrollBarThemeWindowsUx::DrawButtons
virtual void DrawButtons(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar buttons only.
CXTPScrollBarThemeWindowsUx::DrawTracker
virtual void DrawTracker(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar trackers only.
CXTPScrollBarThemeWindowsUx::DrawGripper
virtual void DrawGripper(CDC *pDC, CXTPScrollBase *pScroll)
Draws scrollbar gripper only.
CXTPScrollBarThemeWindowsUx::DrawButtons
virtual void DrawButtons(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws vertical scrollbar buttons only.
CXTPScrollBarThemeWindowsUx::DrawTracker
virtual void DrawTracker(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws vertical scrollbar trackers only.
CXTPScrollBarThemeWindowsUx::CXTPScrollBarThemeWindowsUx
CXTPScrollBarThemeWindowsUx()
Constructs a CXTPScrollBarThemeWindowsUx object.
CXTPScrollBarThemeWindowsUx::~CXTPScrollBarThemeWindowsUx
virtual ~CXTPScrollBarThemeWindowsUx()
Destroys a CXTPScrollBarThemeWindowsUx object, handles cleanup and deallocation.
CXTPScrollBarThemeWindowsUx::DrawThumbButton
virtual void DrawThumbButton(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar thumb button only.
CXTPScrollBarThemeWindowsUx::RefreshMetrics
virtual void RefreshMetrics()
Recalculates scrollbar metrics.
CXTPScrollBarThemeWindowsUx::DrawThumbButton
virtual void DrawThumbButton(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws vertical scrollbar thumb button only.
CXTPScrollBase
CXTPScrollBase is the base class for all scrollable objects.
Definition XTPScrollBase.h:222
CXTPWinThemeWrapper
The CXTPWinThemeWrapper class wraps the UxTheme.dll visual theme API.
Definition XTPWinThemeWrapper.h:188


Toolkit Pro: Member List

CXTPMsgPreviewProvider Member List

This is the complete list of members for CXTPMsgPreviewProvider, including all inherited members.

BindHost(IXTPPreviewHost &host) | CXTPPreviewProviderBase | protectedvirtual
CXTPPreviewProviderBase() | CXTPPreviewProviderBase | protected
GetHost() const | CXTPPreviewProviderBase | protected
~IXTPPreviewProvider() | IXTPPreviewProvider | inlinevirtual


Toolkit Pro: Member List

CXTPGridThemeNativeWindows10 Member List

This is the complete list of members for CXTPGridThemeNativeWindows10, including all inherited members.

CalcColumnHeight(CDC *pDC, CXTPGridColumn *pColumn, int nTotalWidth=0) | CXTPGridPaintManager | protectedvirtual
CalculateRowHeight(CDC *pDC, const CString &strText, int nMaxWidth, BOOL bWordBreak=TRUE) | CXTPGridPaintManager | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPGridPaintManager() | CXTPGridPaintManager |
CXTPGridThemeNativeWindows10() | CXTPGridThemeNativeWindows10 |
CXTPGridThemeOffice2013() | CXTPGridThemeOffice2013 |
DrawBitmap(CDC *pDC, CXTPGridControl *pControl, CRect rcColumn, int iImage) | CXTPGridPaintManager | virtual
DrawCollapsedBitmap(CDC *pDC, const CXTPGridRow *pRow, CRect &rcBitmap) | CXTPGridThemeOffice2013 | virtual
DrawColumn(CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn, BOOL bDrawExternal=FALSE, int nShadowWidth=0) | CXTPGridPaintManager | virtual
DrawColumnBackground(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, BOOL &bColumnPressed, BOOL &bDraggingFromHeader, CXTPGridHeader *pHeader=NULL) | CXTPGridThemeOffice2013 | virtual
DrawColumnFooter(CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn) | CXTPGridPaintManager | virtual
DrawColumnFooterDivider(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn) | CXTPGridPaintManager | virtual
DrawColumnIcon(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, CRect rcIcon, int iIcon) | CXTPGridPaintManager | virtual
DrawColumnText(CDC *pDC, CRect rcText, CString strCaption, int nHeaderAlignment, BOOL bIsHeader, BOOL bColumnPressed) | CXTPGridThemeOffice2013 | virtual
DrawConnector(CDC *pDC, CPoint ptFrom, CPoint ptTo) | CXTPGridPaintManager |
DrawFocusedRow(CDC *pDC, CRect rcRow) | CXTPGridThemeOffice2013 | virtual
DrawFreezeColsDivider(CDC *pDC, const CRect &rc, CXTPGridControl *pControl, CXTPGridRow *pRow=NULL) | CXTPGridPaintManager | virtual
DrawGlyph(CDC *pDC, CRect rcColumn, int iImage) | CXTPGridPaintManager | virtual
DrawGrid(CDC *pDC, XTPGridOrientation orientation, CRect rcGrid) | CXTPGridPaintManager | virtual
DrawGridPattern(CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush) | CXTPGridPaintManager | protectedvirtual
DrawGridPattern(CDC *pDC, CXTPBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush) | CXTPGridPaintManager | protectedvirtual
DrawGridPattern(CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr) | CXTPGridPaintManager | protectedvirtual
DrawGroupRow(CDC *pDC, CXTPGridGroupRow *pRow, CRect rcRow, XTP_GRIDRECORDITEM_METRICS *pMetrics) | CXTPGridThemeOffice2013 | virtual
DrawHorizontalLine(CDC *pDC, int xPos, int yPos, int cx, COLORREF clr) | CXTPGridPaintManager |
DrawInplaceButton(CDC *pDC, CXTPGridInplaceButton *pButton) | CXTPGridPaintManager | virtual
DrawInplaceButtonFrame(CDC *pDC, CXTPGridInplaceButton *pButton) | CXTPGridPaintManager | protectedvirtual
DrawInplaceButtonIcon(CDC *pDC, CXTPGridInplaceButton *pButton) | CXTPGridPaintManager | protectedvirtual
DrawInplaceComboButton(CDC *pDC, CRect *pRc) | CXTPGridPaintManager | virtual
DrawInplaceExpandButton(CDC *pDC, CRect *pRc) | CXTPGridPaintManager | virtual
DrawInplaceSpinButton(CDC *pDC, CRect *pRc) | CXTPGridPaintManager | virtual
DrawItemBitmap(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CRect &rcItem, int nImage) | CXTPGridPaintManager | virtual
DrawItemCaption(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics) | CXTPGridPaintManager | virtual
DrawItemControl(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CXTPGridRecordItemControl *pControl, CRect &rcItem) | CXTPGridPaintManager | virtual
DrawLink(int *pnCurrDrawPos, XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CXTPGridHyperlink *pHyperlink, CString strText, CRect rcLink, int nFlag, BOOL bTrim=FALSE) | CXTPGridPaintManager | protectedvirtual
DrawMultiLineText(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, BOOL bWordBreak=TRUE) | CXTPGridPaintManager | protectedvirtual
DrawNoGroupByText(CDC *pDC, CRect rcItem) | CXTPGridPaintManager | virtual
DrawRowNumber(CDC *pDC, CRect rcNumber, CXTPGridRow *pRow) | CXTPGridPaintManager | virtual
DrawSectionDivider(CDC *pDC, const CRect &rc, XTPGridSectionDividerPosition dividerPosition, XTPGridSectionDividerStyle dividerStyle, CXTPPaintManagerColor dividerColor) | CXTPGridPaintManager |
DrawShellIcon(CDC *pDC, CRect rcColumn, int iImage) | CXTPGridPaintManager | virtual
DrawSingleLineText(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nStartPos, int nEndPos, int nActualWidth) | CXTPGridPaintManager | protectedvirtual
DrawString(int *pnCurrDrawPos, CDC *pDC, const CString &strDraw, CRect rcDraw, UINT nFormat) | CXTPGridPaintManager | protectedvirtual
DrawTextLine(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nFlag, int &nCharCounter, int &nHyperlinkCounter) | CXTPGridPaintManager | protectedvirtual
DrawTreeStructure(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CRect rcItem, CSize sizeGlyph) | CXTPGridPaintManager | virtual
DrawTriangle(CDC *pDC, CRect rcTriangle, BOOL bToDown, BOOL bDraggingFromHeader, int nShadowWidth, BOOL bColumnPressed) | CXTPGridThemeOffice2013 | virtual
DrawVerticalLine(CDC *pDC, int xPos, int yPos, int cy, COLORREF clr) | CXTPGridPaintManager |
DrawVerticalTimeLineMarker(CDC *pDC, int xPos, CXTPGridControl *pControl, COLORREF color=RGB(0, 255, 0)) | CXTPGridPaintManager | virtual
EnablePreviewMode(BOOL bIsPreviewMode) | CXTPGridPaintManager |
FillFooter(CDC *pDC, CRect rcFooter) | CXTPGridPaintManager | virtual
FillGroupByControl(CDC *pDC, CRect &rcGroupBy) | CXTPGridPaintManager | virtual
FillGroupRowMetrics(CXTPGridGroupRow *pRow, XTP_GRIDRECORDITEM_METRICS *pMetrics, BOOL bPrinting) | CXTPGridThemeOffice2013 | virtual
FillHeaderControl(CDC *pDC, CRect rcHeader) | CXTPGridPaintManager | virtual
FillIndent(CDC *pDC, CRect rcRow) | CXTPGridPaintManager | virtual
FillItemShade(CDC *pDC, CRect rcItem) | CXTPGridPaintManager | virtual
FillRow(CDC *pDC, CXTPGridRow *pRow, CRect rcRow) | CXTPGridPaintManager | virtual
FindRowAdjacentToMerged(const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, BOOL bUpward) | CXTPGridPaintManager |
FindRowAdjacentToMergedEx(const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, int &nAdjRowIndex, BOOL bUpward) | CXTPGridPaintManager |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetColumnOffice2007CustomThemeBaseColor() const | CXTPGridPaintManager |
GetColumnStyle() const | CXTPGridPaintManager |
GetControlBackColor(CXTPGridControl *pControl) | CXTPGridPaintManager | virtual
GetFooterHeight(CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0) | CXTPGridPaintManager | virtual
GetFreezeColsDividerStyle() const | CXTPGridPaintManager |
GetGlyphs() const | CXTPGridPaintManager |
GetHeaderHeight() | CXTPGridPaintManager | virtual
GetHeaderHeight(CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0) | CXTPGridPaintManager | virtual
GetItemHeight(XTP_GRIDRECORDITEM_DRAWARGS &drawArgs, int nWidth) | CXTPGridPaintManager |
GetMaxPreviewLines() | CXTPGridPaintManager |
GetPreviewItemHeight(CDC *pDC, CXTPGridRow *pRow, int nWidth, int nHeight) | CXTPGridPaintManager | virtual
GetPreviewLinesCount(CDC *pDC, CRect &rcText, const CString &strText) | CXTPGridPaintManager |
GetRowHeight(CDC *pDC, CXTPGridRow *pRow) | CXTPGridThemeOffice2013 | virtual
GetRowHeight(CDC *pDC, CXTPGridRow *pRow, int nTotalWidth) | CXTPGridThemeOffice2013 | virtual
GetRowHeightEx(CDC *pDC, CXTPGridRow *pRow, int nTotalWidth, const BOOL firstLevel=TRUE) | CXTPGridPaintManager |
GetSectionDividerHeight(XTPGridFixedRowsDividerStyle dividerStyle) | CXTPGridPaintManager |
GetTextFont() | CXTPGridPaintManager |
IsColumHotTrackingEnabled() const | CXTPGridPaintManager | virtual
IsColumnPlusMinusSign() const | CXTPGridPaintManager |
IsColumnWidthWYSIWYG() const | CXTPGridPaintManager |
IsDrawGridForEmptySpace() const | CXTPGridPaintManager |
IsFixedInplaceButtonHeight() const | CXTPGridPaintManager |
IsFixedRowHeight() const | CXTPGridPaintManager |
IsGridVisible(BOOL bVertical) const | CXTPGridPaintManager |
IsGridVisible(XTPGridOrientation orientation) const | CXTPGridPaintManager |
IsLastColumnWidthWYSIWYG() const | CXTPGridPaintManager |
IsPreviewMode() const | CXTPGridPaintManager |
IsPrintGroupRowIcon() const | CXTPGridPaintManager |
IsShowWYSIWYGMarkers() const | CXTPGridPaintManager |
IsUseDropMarker() const | CXTPGridPaintManager |
LoadGlyphs() | CXTPGridThemeOffice2013 | virtual
m_arStartCol | CXTPGridPaintManager |
m_bAllowMergeCells | CXTPGridPaintManager |
m_bBaseTreeIndent | CXTPGridPaintManager |
m_bCleanTooltip | CXTPGridPaintManager |
m_bColumnPlusMinusSign | CXTPGridPaintManager | protected
m_bColumnWidthWYSIWYG | CXTPGridPaintManager | protected
m_bCompactText | CXTPGridPaintManager |
m_bDrawGridForEmptySpace | CXTPGridPaintManager | protected
m_bFixedInplaceButtonHeight | CXTPGridPaintManager | protected
m_bFixedRowHeight | CXTPGridPaintManager | protected
m_bForceDynamicMarkupForCell | CXTPGridPaintManager |
m_bForceShowDropMarker | CXTPGridPaintManager |
m_bForceShowTooltip | CXTPGridPaintManager |
m_bGrayIfDisable | CXTPGridPaintManager |
m_bGroupRowTextBold | CXTPGridPaintManager |
m_bHideSelection | CXTPGridPaintManager |
m_bHotTracking | CXTPGridPaintManager |
m_bInvertColumnOnClick | CXTPGridPaintManager |
m_bIsPreviewMode | CXTPGridPaintManager | protected
m_bLastColumnWidthWYSIWYG | CXTPGridPaintManager | protected
m_bMakeUpper | CXTPGridPaintManager |
m_bMoveScrollbarOnFixedColumnsIndent | CXTPGridPaintManager |
m_bPrintGroupRowIcon | CXTPGridPaintManager | protected
m_bPrintPageRectangle | CXTPGridPaintManager |
m_bPrintSortTriangle | CXTPGridPaintManager |
m_bPrintVirtualPageNumber | CXTPGridPaintManager |
m_bPrintWatermark | CXTPGridPaintManager |
m_bRecOrRowNum | CXTPGridPaintManager |
m_bRevertAlignment | CXTPGridPaintManager |
m_bShadeGroupHeadings | CXTPGridPaintManager |
m_bShadeSortColumn | CXTPGridPaintManager |
m_bShowLockIcon | CXTPGridPaintManager |
m_bShowNonActiveInPlaceButton | CXTPGridPaintManager |
m_bShowWYSIWYGMarkers | CXTPGridPaintManager | protected
m_bSortTriangleOffsetFromRight | CXTPGridPaintManager |
m_bThemedInplaceButtons | CXTPGridPaintManager |
m_bUseAlternativeBackground | CXTPGridPaintManager |
m_bUseDropMarker | CXTPGridPaintManager |
m_bUseEditTextAlignment | CXTPGridPaintManager |
m_bUseGroupRowSelectionState | CXTPGridPaintManager |
m_bUseShellIcon | CXTPGridPaintManager |
m_clrAlternativeBackground | CXTPGridPaintManager |
m_clrBoldText | CXTPGridPaintManager |
m_clrBoldTextHighlight | CXTPGridPaintManager |
m_clrBtnFace | CXTPGridPaintManager |
m_clrBtnFacePressed | CXTPGridPaintManager |
m_clrBtnText | CXTPGridPaintManager |
m_clrCaptionText | CXTPGridPaintManager |
m_clrCaptionTextPressed | CXTPGridPaintManager |
m_clrColumnOffice2007CustomTheme | CXTPGridPaintManager |
m_clrConnector | CXTPGridPaintManager |
m_clrControlBack | CXTPGridPaintManager |
m_clrControlDark | CXTPGridPaintManager |
m_clrControlLightLight | CXTPGridPaintManager |
m_clrDisableBitmapDarkest | CXTPGridPaintManager |
m_clrDisableBitmapLightest | CXTPGridPaintManager |
m_clrFormulaSubSum | CXTPGridPaintManager |
m_clrFormulaSum | CXTPGridPaintManager |
m_clrFreezeColsDivider | CXTPGridPaintManager |
m_clrGlyph | CXTPGridThemeOffice2013 |
m_clrGlyphBorder | CXTPGridThemeOffice2013 |
m_clrGlyphContract | CXTPGridThemeOffice2013 |
m_clrGlyphExpand | CXTPGridThemeOffice2013 |
m_clrGlyphHighlight | CXTPGridThemeOffice2013 |
m_clrGradientColumnSeparator | CXTPGridPaintManager |
m_clrGradientColumnShadow | CXTPGridPaintManager |
m_clrGroupBoxBack | CXTPGridPaintManager |
m_clrGroupRowText | CXTPGridPaintManager |
m_clrGroupShadeBack | CXTPGridPaintManager |
m_clrGroupShadeBorder | CXTPGridPaintManager |
m_clrGroupShadeText | CXTPGridPaintManager |
m_clrHeaderControl | CXTPGridPaintManager |
m_clrHighlight | CXTPGridPaintManager |
m_clrHighlightText | CXTPGridPaintManager |
m_clrHotDivider | CXTPGridPaintManager |
m_clrIndentControl | CXTPGridPaintManager |
m_clrItemShade | CXTPGridPaintManager |
m_clrPreviewText | CXTPGridPaintManager |
m_clrSelectedRow | CXTPGridPaintManager |
m_clrSelectedRowText | CXTPGridPaintManager |
m_clrWindowText | CXTPGridPaintManager |
m_columnStyle | CXTPGridPaintManager | protected
m_crlNoGroupByText | CXTPGridPaintManager |
m_grcGradientColumn | CXTPGridPaintManager |
m_grcGradientColumnHot | CXTPGridPaintManager |
m_grcGradientColumnPushed | CXTPGridPaintManager |
m_iRecOrRowStart | CXTPGridPaintManager |
m_nBaseParentRecordIndent | CXTPGridPaintManager |
m_nFixedColumnsIndent | CXTPGridPaintManager |
m_nFooterHeight | CXTPGridPaintManager | protected
m_nFreezeColsDividerStyle | CXTPGridPaintManager | protected
m_nGridLineStylePreviousH | CXTPGridPaintManager | protected
m_nGridLineStylePreviousV | CXTPGridPaintManager | protected
m_nGroupGridLineHeight | CXTPGridPaintManager | protected
m_nGroupGridLineStyle | CXTPGridPaintManager | protected
m_nHeaderHeight | CXTPGridPaintManager | protected
m_nMaxPreviewLines | CXTPGridPaintManager | protected
m_nResizingWidth | CXTPGridPaintManager | protected
m_nRowHeight | CXTPGridPaintManager | protected
m_nRowHeightDefault | CXTPGridPaintManager |
m_nTextIndentForGroupRowsWithNoIcon | CXTPGridPaintManager |
m_nTreeColumnLineLength | CXTPGridPaintManager |
m_nTreeIndent | CXTPGridPaintManager |
m_nTreeStructureStyle | CXTPGridPaintManager |
m_nTreeTextIndent | CXTPGridPaintManager |
m_nTreeTextIndentGroupRow | CXTPGridPaintManager |
m_nTreeTextIndentRowChildren | CXTPGridPaintManager |
m_nTreeTextIndentRowParent | CXTPGridPaintManager |
m_pControl | CXTPGridPaintManager | protected
m_pGlyphs | CXTPGridPaintManager | protected
m_pHyperlinkHoverStyle | CXTPGridPaintManager |
m_pHyperlinkStyle | CXTPGridPaintManager |
m_pMarkupUIElement_NoGroupBy | CXTPGridPaintManager | protected
m_PrintPageWidth | CXTPGridPaintManager |
m_rcPreviewIndent | CXTPGridPaintManager |
m_RecordNumberWidth | CXTPGridPaintManager |
m_strCollapse | CXTPGridPaintManager |
m_strDecreasing | CXTPGridPaintManager |
m_strExpand | CXTPGridPaintManager |
m_strIncreasing | CXTPGridPaintManager |
m_strMarkupUIElement_NoGroupBy | CXTPGridPaintManager | protected
m_strNoFieldsAvailable | CXTPGridPaintManager |
m_strNoGroupBy | CXTPGridPaintManager |
m_strNoItems | CXTPGridPaintManager |
m_strSortBy | CXTPGridPaintManager |
m_szGlyph | CXTPGridPaintManager | protected
m_themeButton | CXTPGridPaintManager | protected
m_themeCombo | CXTPGridPaintManager | protected
m_themeHeader | CXTPGridPaintManager | protected
m_themeSpin | CXTPGridPaintManager | protected
m_treeStructureStyle | CXTPGridPaintManager |
m_xtpBrushGroupGridLineStyle | CXTPGridPaintManager | protected
m_xtpBrushHorizontalGrid | CXTPGridPaintManager | protected
m_xtpBrushTreeStructure | CXTPGridPaintManager | protected
m_xtpBrushVeriticalGrid | CXTPGridPaintManager | protected
m_xtpFontBoldText | CXTPGridPaintManager |
m_xtpFontCaption | CXTPGridPaintManager |
m_xtpFontPreview | CXTPGridPaintManager |
m_xtpFontText | CXTPGridPaintManager |
OnDrawAction(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs) | CXTPGridPaintManager | virtual
RecalcTotalHightOfMergedRows(CXTPGridColumns *pColumns, CDC *pDC, CXTPGridRow *pRow, int nRowHeight, int nTotalWidth) | CXTPGridPaintManager |
RefreshMetrics() | CXTPGridThemeNativeWindows10 | virtual
SetCaptionFont(LOGFONT &lf) | CXTPGridPaintManager |
SetColumnOffice2007CustomThemeBaseColor(COLORREF clrBaseColor) | CXTPGridPaintManager |
SetColumnPlusMinusSign(BOOL bDraw) | CXTPGridPaintManager |
SetColumnStyle(XTPGridColumnStyle columnStyle) | CXTPGridPaintManager |
SetColumnWidthWYSIWYG(BOOL bColumnWidthWYSIWYG) | CXTPGridPaintManager |
SetDrawGridForEmptySpace(BOOL bDrawGrid) | CXTPGridPaintManager |
SetFixedRowHeight(BOOL bFixedRowHeight) | CXTPGridPaintManager |
SetFreezeColsDividerStyle(int nStyle) | CXTPGridPaintManager |
SetGridControl(CXTPGridControl *pControl) | CXTPGridPaintManager | virtual
SetHeaderHeight(int nHeight) | CXTPGridPaintManager | virtual
SetInplaceButtonHeight(BOOL bFixedInplaceButtonHeight) | CXTPGridPaintManager |
SetLastColumnWidthWYSIWYG(BOOL bColumnWidthWYSIWYG) | CXTPGridPaintManager |
SetMaxPreviewLines(int nMaxLines) | CXTPGridPaintManager |
SetPreviewIndent(int nLeft, int nTop, int nRight, int nBottom) | CXTPGridPaintManager |
SetPrintGroupRowIcon(BOOL bDraw) | CXTPGridPaintManager |
SetTextFont(LOGFONT &lf) | CXTPGridPaintManager |
ShowWYSIWYGMarkers(BOOL bSet) | CXTPGridPaintManager |
~CXTPGridPaintManager() | CXTPGridPaintManager | virtual


Toolkit Pro: Member List

XTP_COMMANDBARS_ICONSINFO Member List

This is the complete list of members for XTP_COMMANDBARS_ICONSINFO, including all inherited members.

bIconsWithShadow | XTP_COMMANDBARS_ICONSINFO
bOfficeStyleDisabledIcons | XTP_COMMANDBARS_ICONSINFO
bUseDisabledIcons | XTP_COMMANDBARS_ICONSINFO
bUseFadedIcons | XTP_COMMANDBARS_ICONSINFO


Toolkit Pro: Member List

CXTPResizeGroupBox Member List

This is the complete list of members for CXTPResizeGroupBox, including all inherited members.

CXTPButton() | CXTPButton |
CXTPResizeGroupBox() | CXTPResizeGroupBox |
DoDropDown() | CXTPButton | protected
DrawImage(CDC *pDC, CRect rc) | CXTPButton | virtual
EnableMarkup(BOOL bEnableMarkup=TRUE) | CXTPButton |
Exclude(CDC *pDC, CRect &rcClient) | CXTPResizeGroupBox | protectedvirtual
GetBorderGap() const | CXTPButton |
GetBorderStyle() const | CXTPButton |
GetButtonBackColor() | CXTPButton | virtual
GetButtonRect() | CXTPButton | virtual
GetButtonStyle() const | CXTPButton |
GetButtonText() | CXTPButton | virtual
GetButtonTextColor() | CXTPButton | virtual
GetChecked() | CXTPButton | virtual
GetFlatStyle() const | CXTPButton |
GetGlyphSize(BOOL bCheckBox) | CXTPButton |
GetIcon() const | CXTPButton |
GetImageAlignment() const | CXTPButton | virtual
GetImageGap() const | CXTPButton |
GetImageSize() | CXTPButton | virtual
GetMarkupContext() const | CXTPButton |
GetMarkupUIElement() | CXTPButton |
GetPushButtonStyle() const | CXTPButton |
GetShowFocus() const | CXTPButton |
GetTextAlignment() const | CXTPButton | virtual
GetTextImageRelation() const | CXTPButton |
GetTheme() | CXTPButton |
GetTooltip() const | CXTPButton |
GetToolTipContext() const | CXTPButton |
GetUseVisualStyle() const | CXTPButton |
InternalTextChanged() | CXTPButton | virtual
IsDpiImageScalingEnabled() const | CXTPButton | virtual
IsDropDownStyle() const | CXTPButton |
IsHighlighted() | CXTPButton | virtual
IsPushButton() const | CXTPButton |
IsPushed() | CXTPButton | virtual
m_bChecked | CXTPButton |
m_bEnableMarkup | CXTPButton |
m_bFlatStyle | CXTPButton |
m_bHot | CXTPButton |
m_bImageDPIScaling | CXTPButton | protected
m_bPushed | CXTPButton |
m_bShowFocus | CXTPButton |
m_bUseVisualStyle | CXTPButton |
m_hWndBuddy | CXTPButton |
m_nBorderGap | CXTPButton |
m_nBorderStyle | CXTPButton |
m_nImageAlignment | CXTPButton |
m_nImageGap | CXTPButton |
m_nPushButtonStyle | CXTPButton |
m_nTextImageRelation | CXTPButton |
m_pIcon | CXTPButton |
m_pMarkupContext | CXTPButton | protected
m_pTheme | CXTPButton |
m_pToolTipContext | CXTPButton |
m_pUIElement | CXTPButton | protected
m_strTooltip | CXTPButton |
m_szVectorIcon | CXTPButton |
OnDraw(CDC *pDC) | CXTPButton | protectedvirtual
OnDropDown() | CXTPButton | protectedvirtual
RedrawButton(BOOL bUpdateWindow=FALSE) | CXTPButton |
RefreshMetrics() | CXTPButton | protectedvirtual
SetBitmap(CSize size, UINT nID, BOOL bRedraw=TRUE) | CXTPButton | virtual
SetBorderGap(int nBorderGap) | CXTPButton |
SetBorderStyle(XTPGroupBoxBorderStyle style) | CXTPButton |
SetBuddy(CWnd *pWndBuddy, BOOL bMoveButton=TRUE) | CXTPButton |
SetChecked(BOOL bChecked) | CXTPButton |
SetDpiImageScaling(BOOL bEnable) | CXTPButton | virtual
SetFlatStyle(BOOL bFlatStyle=TRUE) | CXTPButton |
SetIcon(CSize size, HICON hIcon, HICON hIconHot=NULL, BOOL bRedraw=TRUE) | CXTPButton | virtual
SetIcon(CSize size, UINT nID, UINT nHotID=0, BOOL bRedraw=TRUE) | CXTPButton | virtual
SetIcon(CSize size, LPCTSTR lpszID, LPCTSTR lpszHotID=NULL, BOOL bRedraw=TRUE) | CXTPButton | virtual
SetIcon(CSize size, CXTPImageManagerIcon *pIcon, BOOL bRedraw=TRUE) | CXTPButton |
SetIcon(CSize size, const CXTPImageManagerIconHandle &hIconHandle, const CXTPImageManagerIconHandle &hIconHotHandle, BOOL bRedraw=TRUE) | CXTPButton | virtual
SetImageAlignment(DWORD dwAlignment) | CXTPButton |
SetImageGap(int nImageGap) | CXTPButton |
SetPushButtonStyle(XTPPushButtonStyle nPushButtonStyle) | CXTPButton |
SetShowFocus(BOOL bShowFocus) | CXTPButton |
SetTextAlignment(DWORD dwAlignment) | CXTPButton |
SetTextImageRelation(XTPButtonTextImageRelation relation) | CXTPButton |
SetTheme(XTPControlTheme eTheme) | CXTPButton | virtual
SetTheme(CXTPButtonTheme *pPaintManager) | CXTPButton | virtual
SetTooltip(LPCTSTR lpszTooltip) | CXTPButton |
SetUseVisualStyle(BOOL bUseVisualStyle=TRUE) | CXTPButton |
~CXTPButton() | CXTPButton | virtual
~CXTPResizeGroupBox() | CXTPResizeGroupBox | virtual


Toolkit Pro: XTPShortcutBarVisualStudio2022Theme.h Source File

  • Source
  • ShortcutBar
  • Themes
XTPShortcutBarVisualStudio2022Theme.h
Go to the documentation of this file.
1
23#if !defined(__XTPSHORTCUTBARVISUALSTUDIO2022THEME_H__)
24# define __XTPSHORTCUTBARVISUALSTUDIO2022THEME_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPShortcutBarVisualStudio2022Theme : public CXTPShortcutBarOffice2013Theme
39{
40public:
45 CXTPShortcutBarVisualStudio2022Theme();
46
52 virtual ~CXTPShortcutBarVisualStudio2022Theme();
53
61 virtual void RefreshMetrics();
62
84 virtual int DrawPaneItemCaption(CDC* pDC, CXTPShortcutBarPaneItem* pItem, BOOL bDraw);
85
86 virtual void DrawPaneCaptionMinimizeButton(CDC* pDC, CXTPShortcutBarPane* pPane);
87
94 virtual void FillShortcutItemEntry(CDC* pDC, CXTPShortcutBarItem* pItem);
95
102 virtual void FillNavigationItemEntry(CDC* pDC, CXTPShortcutBarItem* pItem);
103
104 void DrawHiliteBorder(CDC* pDC, CRect rc);
105
106protected:
107 BOOL m_bHiliteBorders;
108 CXTPPaintManagerColor m_clrBorderHilite;
109 CXTPPaintManagerColor m_clrBackHiliteSelected;
110};
111
112# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
114#endif // !defined(__XTPSHORTCUTBARVISUALSTUDIO2022THEME_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPPaintManagerColor
The CXTPPaintManagerColor class is used to manage COLORREF values for determining default and applica...
Definition XTPColorManager.h:117
CXTPShortcutBarItem
CXTPShortcutBarItem is a base class that represents an item for a shortcut bar control.
Definition XTPShortcutBar.h:181
CXTPShortcutBarOffice2013Theme
CXTPShortcutBarOffice2013Theme is a CXTPShortcutBarResourceTheme derived class that represents an Off...
Definition XTPShortcutBarOffice2013Theme.h:39
CXTPShortcutBarPane
CXTPShortcutBarPane is a CWnd derived class used as a client area for a shortcut bar control.
Definition XTPShortcutBarPane.h:158
CXTPShortcutBarPaneItem
CXTPShortcutBarPaneItem is a base class that represents an item for a shortcut bar pane.
Definition XTPShortcutBarPane.h:42
CXTPShortcutBarVisualStudio2022Theme
CXTPShortcutBarVisualStudio2022Theme is a CXTPShortcutBarOffice2013Theme derived class that represent...
Definition XTPShortcutBarVisualStudio2022Theme.h:39
CXTPShortcutBarVisualStudio2022Theme::DrawPaneItemCaption
virtual int DrawPaneItemCaption(CDC *pDC, CXTPShortcutBarPaneItem *pItem, BOOL bDraw)
Draws the caption for a specified shortcut bar pane item.
CXTPShortcutBarVisualStudio2022Theme::m_bHiliteBorders
BOOL m_bHiliteBorders
TRUE to draw borders around highlighted items.
Definition XTPShortcutBarVisualStudio2022Theme.h:107
CXTPShortcutBarVisualStudio2022Theme::~CXTPShortcutBarVisualStudio2022Theme
virtual ~CXTPShortcutBarVisualStudio2022Theme()
Destroys a CXTPShortcutBarVisualStudio2022Theme object, handles cleanup and deallocation.
CXTPShortcutBarVisualStudio2022Theme::m_clrBackHiliteSelected
CXTPPaintManagerColor m_clrBackHiliteSelected
Selected highlighted background color.
Definition XTPShortcutBarVisualStudio2022Theme.h:109
CXTPShortcutBarVisualStudio2022Theme::FillShortcutItemEntry
virtual void FillShortcutItemEntry(CDC *pDC, CXTPShortcutBarItem *pItem)
Fills a specified item for the shortcut bar control.
CXTPShortcutBarVisualStudio2022Theme::m_clrBorderHilite
CXTPPaintManagerColor m_clrBorderHilite
Highlighted border color.
Definition XTPShortcutBarVisualStudio2022Theme.h:108
CXTPShortcutBarVisualStudio2022Theme::CXTPShortcutBarVisualStudio2022Theme
CXTPShortcutBarVisualStudio2022Theme()
Constructs a CXTPShortcutBarVisualStudio2022Theme object.
CXTPShortcutBarVisualStudio2022Theme::RefreshMetrics
virtual void RefreshMetrics()
Refreshes the visual metrics of the shortcut bar paint manager.
CXTPShortcutBarVisualStudio2022Theme::FillNavigationItemEntry
virtual void FillNavigationItemEntry(CDC *pDC, CXTPShortcutBarItem *pItem)
Fills a specified navigation item for the minimized shortcut bar control.


Toolkit Pro: Member List

CXTPMarkupGdiPlusSkewTransform Member List

This is the complete list of members for CXTPMarkupGdiPlusSkewTransform, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPMarkupGdiPlusTransformObject() | CXTPMarkupGdiPlusTransformObject< CXTPMarkupSkewTransform > | protected
CXTPMarkupGdiPlusTransformObjectImpl() | CXTPMarkupGdiPlusTransformObjectImpl | protected
CXTPMarkupTransform() | CXTPMarkupTransform | protected
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAngleX() const | CXTPMarkupSkewTransform |
GetAngleY() const | CXTPMarkupSkewTransform |
GetCenterX() const | CXTPMarkupSkewTransform |
GetCenterY() const | CXTPMarkupSkewTransform |
m_pPropertyAngleX | CXTPMarkupSkewTransform | static
m_pPropertyAngleY | CXTPMarkupSkewTransform | static
m_pPropertyCenterX | CXTPMarkupSkewTransform | static
m_pPropertyCenterY | CXTPMarkupSkewTransform | static
SetAngleX(double angleX) | CXTPMarkupSkewTransform |
SetAngleY(double angleY) | CXTPMarkupSkewTransform |
SetCenterX(double centerX) | CXTPMarkupSkewTransform |
SetCenterY(double centerY) | CXTPMarkupSkewTransform |
~CXTPMarkupGdiPlusTransformObjectImpl() | CXTPMarkupGdiPlusTransformObjectImpl | inlineprotectedvirtual


Toolkit Pro: XTPFlowGraphUndoManager.h Source File

  • Source
  • FlowGraph
XTPFlowGraphUndoManager.h
Go to the documentation of this file.
1
23#if !defined(__XTPFLOWGRAPHUNDOMANAGER_H__)
24# define __XTPFLOWGRAPHUNDOMANAGER_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33const int XTP_ID_FLOWGRAPHUNDO_GROUP = -1;
34const int XTP_ID_FLOWGRAPHUNDO_ADDNODE = 1003;
35const int XTP_ID_FLOWGRAPHUNDO_DELETENODE = 1004;
36const int XTP_ID_FLOWGRAPHUNDO_SETNODEPOSITION = 1005;
37const int XTP_ID_FLOWGRAPHUNDO_DELETECONNECTION = 1006;
38const int XTP_ID_FLOWGRAPHUNDO_SETCONNECTIONPOSITION = 1007;
40const int XTP_ID_FLOWGRAPHUNDO_ADDCONNECTION = 1008;
41const int XTP_ID_FLOWGRAPHUNDO_SETNODECAPTION = 1009;
42const int XTP_ID_FLOWGRAPHUNDO_SETNODESIZE = 1010;
43const int XTP_ID_FLOWGRAPHUNDO_DELETECONNECTIONPOINT = 1011;
44const int XTP_ID_FLOWGRAPHUNDO_ADDCONNECTIONPOINT = 1012;
50class _XTP_EXT_CLASS CXTPFlowGraphUndoCommand
51{
52protected:
58 CXTPFlowGraphUndoCommand(int nID);
59
65 virtual ~CXTPFlowGraphUndoCommand();
66
67public:
74 int GetID() const;
75
76protected:
84 virtual void Undo();
85
86protected:
87 const int m_nID;
89 friend class CXTPFlowGraphUndoManager;
90 friend class CXTPFlowGraphUndoGroupCommand;
91};
92
97class _XTP_EXT_CLASS CXTPFlowGraphUndoGroupCommand : public CXTPFlowGraphUndoCommand
98{
99protected:
105 CXTPFlowGraphUndoGroupCommand(CXTPFlowGraphUndoManager* pManager);
106
112 virtual ~CXTPFlowGraphUndoGroupCommand();
113
114public:
122 virtual void Undo();
123
131 int GetCount() const;
132
138 void Add(CXTPFlowGraphUndoCommand* pCommand);
139
140protected:
141 CArray<CXTPFlowGraphUndoCommand*, CXTPFlowGraphUndoCommand*> m_arrUndoCommands;
144 CXTPFlowGraphUndoManager* m_pManager;
145 friend class CXTPFlowGraphUndoManager;
146};
147
153class _XTP_EXT_CLASS CXTPFlowGraphUndoDeleteNodeCommand : public CXTPFlowGraphUndoCommand
154{
155public:
161 CXTPFlowGraphUndoDeleteNodeCommand(CXTPFlowGraphNode* pNode);
162
168 virtual ~CXTPFlowGraphUndoDeleteNodeCommand();
169
170protected:
178 virtual void Undo();
179
180protected:
181 CXTPFlowGraphNode* m_pNode;
182 CXTPFlowGraphPage* m_pPage;
183};
184
190class _XTP_EXT_CLASS CXTPFlowGraphUndoDeleteConnectionPointCommand : public CXTPFlowGraphUndoCommand
191{
192public:
198 CXTPFlowGraphUndoDeleteConnectionPointCommand(CXTPFlowGraphConnectionPoint* pConnectionPoint);
199
205 virtual ~CXTPFlowGraphUndoDeleteConnectionPointCommand();
206
207protected:
215 virtual void Undo();
216
217protected:
218 CXTPFlowGraphNode* m_pNode;
219 CXTPFlowGraphConnectionPoint* m_pConnectionPoint;
220 int m_nIndex;
221};
222
228class _XTP_EXT_CLASS CXTPFlowGraphUndoDeleteConnectionCommand : public CXTPFlowGraphUndoCommand
229{
230public:
236 CXTPFlowGraphUndoDeleteConnectionCommand(CXTPFlowGraphConnection* pConnection);
237
243 virtual ~CXTPFlowGraphUndoDeleteConnectionCommand();
244
245protected:
253 virtual void Undo();
254
255protected:
256 CXTPFlowGraphConnection* m_pConnection;
257 CXTPFlowGraphConnectionPoint* m_pInputPoint;
258 CXTPFlowGraphConnectionPoint* m_pOutputPoint;
259 CXTPFlowGraphPage* m_pPage;
260};
261
267class _XTP_EXT_CLASS CXTPFlowGraphUndoAddNodeCommand : public CXTPFlowGraphUndoCommand
268{
269public:
275 CXTPFlowGraphUndoAddNodeCommand(CXTPFlowGraphNode* pNode);
276
282 virtual ~CXTPFlowGraphUndoAddNodeCommand();
283
284protected:
292 virtual void Undo();
293
294protected:
295 CXTPFlowGraphNode* m_pNode;
296};
297
303class _XTP_EXT_CLASS CXTPFlowGraphUndoAddConnectionPointCommand : public CXTPFlowGraphUndoCommand
304{
305public:
311 CXTPFlowGraphUndoAddConnectionPointCommand(CXTPFlowGraphConnectionPoint* pConnectionPoint);
312
318 virtual ~CXTPFlowGraphUndoAddConnectionPointCommand();
319
320protected:
328 virtual void Undo();
329
330protected:
331 CXTPFlowGraphConnectionPoint* m_pConnectionPoint;
332};
333
339class _XTP_EXT_CLASS CXTPFlowGraphUndoAddConnectionCommand : public CXTPFlowGraphUndoCommand
340{
341public:
347 CXTPFlowGraphUndoAddConnectionCommand(CXTPFlowGraphConnection* pConnection);
348
354 virtual ~CXTPFlowGraphUndoAddConnectionCommand();
355
356protected:
364 virtual void Undo();
365
366protected:
367 CXTPFlowGraphConnection* m_pConnection;
368};
369
375class _XTP_EXT_CLASS CXTPFlowGraphUndoSetNodePositionCommand : public CXTPFlowGraphUndoCommand
376{
377public:
384 CXTPFlowGraphUndoSetNodePositionCommand(CXTPFlowGraphNode* pNode, CPoint ptOldPosition);
385
391 virtual ~CXTPFlowGraphUndoSetNodePositionCommand();
392
393protected:
401 virtual void Undo();
402
403protected:
404 CXTPFlowGraphNode* m_pNode;
405 CPoint m_ptOldPosition;
406};
407
413class _XTP_EXT_CLASS CXTPFlowGraphUndoSetNodeSizeCommand : public CXTPFlowGraphUndoCommand
414{
415public:
422 CXTPFlowGraphUndoSetNodeSizeCommand(CXTPFlowGraphNode* pNode, CSize szOldSize);
423
429 virtual ~CXTPFlowGraphUndoSetNodeSizeCommand();
430
431protected:
439 virtual void Undo();
440
441protected:
442 CXTPFlowGraphNode* m_pNode;
443 CPoint m_szOldSize;
444};
445
451class _XTP_EXT_CLASS CXTPFlowGraphUndoSetNodeCaptionCommand : public CXTPFlowGraphUndoCommand
452{
453public:
460 CXTPFlowGraphUndoSetNodeCaptionCommand(CXTPFlowGraphElement* pNode, CString strOldCaption);
461
467 virtual ~CXTPFlowGraphUndoSetNodeCaptionCommand();
468
469protected:
477 virtual void Undo();
478
479protected:
480 CXTPFlowGraphElement* m_pNode;
481 CString m_strOldCaption;
482};
483
489class _XTP_EXT_CLASS CXTPFlowGraphUndoSetConnectionPositionCommand : public CXTPFlowGraphUndoCommand
490{
491public:
498 CXTPFlowGraphUndoSetConnectionPositionCommand(CXTPFlowGraphConnection* pConnection,
499 CPoint ptOldPosition);
500
506 virtual ~CXTPFlowGraphUndoSetConnectionPositionCommand();
507
508protected:
516 virtual void Undo();
517
518protected:
519 CXTPFlowGraphConnection* m_pConnection;
520 CPoint m_ptOldPosition;
521};
522
543class _XTP_EXT_CLASS CXTPFlowGraphUndoManager : public CXTPCmdTarget
544{
545public:
550 CXTPFlowGraphUndoManager();
551
557 virtual ~CXTPFlowGraphUndoManager();
558
559public:
564 virtual void Undo();
565
570 virtual void Redo();
571
579 BOOL CanUndo() const;
580
588 BOOL CanRedo() const;
589
590public:
595 void Clear();
596
603 void AddUndoCommand(CXTPFlowGraphUndoCommand* pCommand);
604
609 virtual void StartGroup();
610
615 virtual void EndGroup();
616
622 void EnableUndoManager(BOOL bEnabled);
623
624protected:
625 CArray<CXTPFlowGraphUndoCommand*, CXTPFlowGraphUndoCommand*> m_arrUndoCommands;
628 CArray<CXTPFlowGraphUndoCommand*, CXTPFlowGraphUndoCommand*> m_arrRedoCommands;
632 CArray<CXTPFlowGraphUndoGroupCommand*, CXTPFlowGraphUndoGroupCommand*>
633 m_arrGroupStack;
635 int m_nUndoContext;
636 BOOL m_bEnabled;
637 CXTPFlowGraphUndoGroupCommand* m_pUndoGroup;
639# ifdef _XTP_ACTIVEX
641 DECLARE_DISPATCH_MAP()
642 DECLARE_INTERFACE_MAP()
643 DECLARE_OLETYPELIB_EX(CXTPFlowGraphUndoManager);
645# endif
646};
647
648AFX_INLINE int CXTPFlowGraphUndoCommand::GetID() const
649{
650 return m_nID;
651}
652AFX_INLINE void CXTPFlowGraphUndoManager::EnableUndoManager(BOOL bEnabled)
653{
654 m_bEnabled = bEnabled;
655}
657# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
658#endif //#if !defined(__XTPFLOWGRAPHUNDOMANAGER_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTP_ID_FLOWGRAPHUNDO_DELETECONNECTIONPOINT
const int XTP_ID_FLOWGRAPHUNDO_DELETECONNECTIONPOINT
The undo delete point command.
Definition XTPFlowGraphUndoManager.h:43
XTP_ID_FLOWGRAPHUNDO_SETNODESIZE
const int XTP_ID_FLOWGRAPHUNDO_SETNODESIZE
The undo set Node size command.
Definition XTPFlowGraphUndoManager.h:42
XTP_ID_FLOWGRAPHUNDO_ADDCONNECTION
const int XTP_ID_FLOWGRAPHUNDO_ADDCONNECTION
The undo add connection command.
Definition XTPFlowGraphUndoManager.h:40
XTP_ID_FLOWGRAPHUNDO_SETNODECAPTION
const int XTP_ID_FLOWGRAPHUNDO_SETNODECAPTION
The undo set Node caption command.
Definition XTPFlowGraphUndoManager.h:41
XTP_ID_FLOWGRAPHUNDO_ADDCONNECTIONPOINT
const int XTP_ID_FLOWGRAPHUNDO_ADDCONNECTIONPOINT
The undo add point command.
Definition XTPFlowGraphUndoManager.h:44
XTP_ID_FLOWGRAPHUNDO_ADDNODE
const int XTP_ID_FLOWGRAPHUNDO_ADDNODE
The undo add Node command.
Definition XTPFlowGraphUndoManager.h:34
XTP_ID_FLOWGRAPHUNDO_SETCONNECTIONPOSITION
const int XTP_ID_FLOWGRAPHUNDO_SETCONNECTIONPOSITION
The undo set connection position command.
Definition XTPFlowGraphUndoManager.h:38
XTP_ID_FLOWGRAPHUNDO_SETNODEPOSITION
const int XTP_ID_FLOWGRAPHUNDO_SETNODEPOSITION
The undo set Node position command.
Definition XTPFlowGraphUndoManager.h:36
XTP_ID_FLOWGRAPHUNDO_DELETECONNECTION
const int XTP_ID_FLOWGRAPHUNDO_DELETECONNECTION
The undo delete connection command.
Definition XTPFlowGraphUndoManager.h:37
XTP_ID_FLOWGRAPHUNDO_DELETENODE
const int XTP_ID_FLOWGRAPHUNDO_DELETENODE
The undo delete Node command.
Definition XTPFlowGraphUndoManager.h:35
XTP_ID_FLOWGRAPHUNDO_GROUP
const int XTP_ID_FLOWGRAPHUNDO_GROUP
The undo group command.
Definition XTPFlowGraphUndoManager.h:33
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPFlowGraphConnection
Represents a connection.
Definition XTPFlowGraphConnection.h:49
CXTPFlowGraphConnectionPoint
Represents a connection point for a node.
Definition XTPFlowGraphConnectionPoint.h:46
CXTPFlowGraphElement
Base class for all elements in the flow graph.
Definition XTPFlowGraphElement.h:46
CXTPFlowGraphNode
Represents a Node object.
Definition XTPFlowGraphNode.h:116
CXTPFlowGraphPage
Represents a page in the flow graph.
Definition XTPFlowGraphPage.h:54
CXTPFlowGraphUndoAddConnectionCommand
This class abstracts the undo add connection command.
Definition XTPFlowGraphUndoManager.h:340
CXTPFlowGraphUndoAddConnectionCommand::CXTPFlowGraphUndoAddConnectionCommand
CXTPFlowGraphUndoAddConnectionCommand(CXTPFlowGraphConnection *pConnection)
Constructs a CXTPFlowGraphUndoAddConnectionCommand object.
CXTPFlowGraphUndoAddConnectionCommand::m_pConnection
CXTPFlowGraphConnection * m_pConnection
Pointer to the FlowGraph connection object.
Definition XTPFlowGraphUndoManager.h:367
CXTPFlowGraphUndoAddConnectionCommand::~CXTPFlowGraphUndoAddConnectionCommand
virtual ~CXTPFlowGraphUndoAddConnectionCommand()
Destroys a CXTPFlowGraphUndoAddConnectionCommand object, handles cleanup and deallocation.
CXTPFlowGraphUndoAddConnectionCommand::Undo
virtual void Undo()
Call this function to do the undo operation.
CXTPFlowGraphUndoAddConnectionPointCommand
This class abstracts the undo add connection point command.
Definition XTPFlowGraphUndoManager.h:304
CXTPFlowGraphUndoAddConnectionPointCommand::CXTPFlowGraphUndoAddConnectionPointCommand
CXTPFlowGraphUndoAddConnectionPointCommand(CXTPFlowGraphConnectionPoint *pConnectionPoint)
Constructs a CXTPFlowGraphUndoAddConnectionPointCommand object.
CXTPFlowGraphUndoAddConnectionPointCommand::~CXTPFlowGraphUndoAddConnectionPointCommand
virtual ~CXTPFlowGraphUndoAddConnectionPointCommand()
Destroys a CXTPFlowGraphUndoAddConnectionPointCommand object, handles cleanup and deallocation.
CXTPFlowGraphUndoAddConnectionPointCommand::Undo
virtual void Undo()
Call this function to do the undo operation.
CXTPFlowGraphUndoAddConnectionPointCommand::m_pConnectionPoint
CXTPFlowGraphConnectionPoint * m_pConnectionPoint
Pointer to the FlowGraph point object.
Definition XTPFlowGraphUndoManager.h:331
CXTPFlowGraphUndoAddNodeCommand
This class abstracts the undo add Node command.
Definition XTPFlowGraphUndoManager.h:268
CXTPFlowGraphUndoAddNodeCommand::~CXTPFlowGraphUndoAddNodeCommand
virtual ~CXTPFlowGraphUndoAddNodeCommand()
Destroys a CXTPFlowGraphUndoAddNodeCommand object, handles cleanup and deallocation.
CXTPFlowGraphUndoAddNodeCommand::CXTPFlowGraphUndoAddNodeCommand
CXTPFlowGraphUndoAddNodeCommand(CXTPFlowGraphNode *pNode)
Constructs a CXTPFlowGraphUndoAddNodeCommand object.
CXTPFlowGraphUndoAddNodeCommand::Undo
virtual void Undo()
Call this function to do the undo operation.
CXTPFlowGraphUndoAddNodeCommand::m_pNode
CXTPFlowGraphNode * m_pNode
Pointer to the FlowGraph Node object.
Definition XTPFlowGraphUndoManager.h:295
CXTPFlowGraphUndoCommand
This class abstracts the undo command.
Definition XTPFlowGraphUndoManager.h:51
CXTPFlowGraphUndoCommand::GetID
int GetID() const
Call this function to get the command ID associated with this object.
Definition XTPFlowGraphUndoManager.h:648
CXTPFlowGraphUndoCommand::~CXTPFlowGraphUndoCommand
virtual ~CXTPFlowGraphUndoCommand()
Destroys a CXTPFlowGraphUndoCommand object, handles cleanup and deallocation.
CXTPFlowGraphUndoCommand::CXTPFlowGraphUndoCommand
CXTPFlowGraphUndoCommand(int nID)
Constructs a CXTPFlowGraphUndoCommand object.
CXTPFlowGraphUndoCommand::Undo
virtual void Undo()
Call this function to do the undo operation.
CXTPFlowGraphUndoCommand::m_nID
const int m_nID
The command ID.
Definition XTPFlowGraphUndoManager.h:87
CXTPFlowGraphUndoDeleteConnectionCommand
This class abstracts the undo delete connection command.
Definition XTPFlowGraphUndoManager.h:229
CXTPFlowGraphUndoDeleteConnectionCommand::m_pConnection
CXTPFlowGraphConnection * m_pConnection
The FlowGraph connection object.
Definition XTPFlowGraphUndoManager.h:256
CXTPFlowGraphUndoDeleteConnectionCommand::m_pPage
CXTPFlowGraphPage * m_pPage
The FlowGraph page object.
Definition XTPFlowGraphUndoManager.h:259
CXTPFlowGraphUndoDeleteConnectionCommand::Undo
virtual void Undo()
Call this function to do the undo operation.
CXTPFlowGraphUndoDeleteConnectionCommand::~CXTPFlowGraphUndoDeleteConnectionCommand
virtual ~CXTPFlowGraphUndoDeleteConnectionCommand()
Destroys a CXTPFlowGraphUndoDeleteConnectionCommand object, handles cleanup and deallocation.
CXTPFlowGraphUndoDeleteConnectionCommand::CXTPFlowGraphUndoDeleteConnectionCommand
CXTPFlowGraphUndoDeleteConnectionCommand(CXTPFlowGraphConnection *pConnection)
Constructs a CXTPFlowGraphUndoDeleteConnectionCommand object.
CXTPFlowGraphUndoDeleteConnectionPointCommand
This class abstracts the undo delete connection point command.
Definition XTPFlowGraphUndoManager.h:191
CXTPFlowGraphUndoDeleteConnectionPointCommand::~CXTPFlowGraphUndoDeleteConnectionPointCommand
virtual ~CXTPFlowGraphUndoDeleteConnectionPointCommand()
Destroys a CXTPFlowGraphUndoDeleteConnectionPointCommand object, handles cleanup and deallocation.
CXTPFlowGraphUndoDeleteConnectionPointCommand::Undo
virtual void Undo()
Call this function to do the undo operation.
CXTPFlowGraphUndoDeleteConnectionPointCommand::m_pConnectionPoint
CXTPFlowGraphConnectionPoint * m_pConnectionPoint
The FlowGraph connection point object.
Definition XTPFlowGraphUndoManager.h:219
CXTPFlowGraphUndoDeleteConnectionPointCommand::CXTPFlowGraphUndoDeleteConnectionPointCommand
CXTPFlowGraphUndoDeleteConnectionPointCommand(CXTPFlowGraphConnectionPoint *pConnectionPoint)
Constructs a CXTPFlowGraphUndoDeleteConnectionPointCommand object.
CXTPFlowGraphUndoDeleteConnectionPointCommand::m_pNode
CXTPFlowGraphNode * m_pNode
The FlowGraph Node object.
Definition XTPFlowGraphUndoManager.h:218
CXTPFlowGraphUndoDeleteNodeCommand
This class abstracts the undo delete Node command.
Definition XTPFlowGraphUndoManager.h:154
CXTPFlowGraphUndoDeleteNodeCommand::CXTPFlowGraphUndoDeleteNodeCommand
CXTPFlowGraphUndoDeleteNodeCommand(CXTPFlowGraphNode *pNode)
Constructs a CXTPFlowGraphUndoDeleteNodeCommand object.
CXTPFlowGraphUndoDeleteNodeCommand::m_pPage
CXTPFlowGraphPage * m_pPage
The FlowGraph page object.
Definition XTPFlowGraphUndoManager.h:182
CXTPFlowGraphUndoDeleteNodeCommand::~CXTPFlowGraphUndoDeleteNodeCommand
virtual ~CXTPFlowGraphUndoDeleteNodeCommand()
Destroys a CXTPFlowGraphUndoDeleteNodeCommand object, handles cleanup and deallocation.
CXTPFlowGraphUndoDeleteNodeCommand::Undo
virtual void Undo()
Call this function to do the undo operation.
CXTPFlowGraphUndoDeleteNodeCommand::m_pNode
CXTPFlowGraphNode * m_pNode
The FlowGraph Node object.
Definition XTPFlowGraphUndoManager.h:181
CXTPFlowGraphUndoGroupCommand
This class abstracts the undo commands in a group.
Definition XTPFlowGraphUndoManager.h:98
CXTPFlowGraphUndoGroupCommand::GetCount
int GetCount() const
Call this function to get the number of command objects in this group.
CXTPFlowGraphUndoGroupCommand::Add
void Add(CXTPFlowGraphUndoCommand *pCommand)
Call this function to add a command to the command group.
CXTPFlowGraphUndoGroupCommand::m_arrUndoCommands
CArray< CXTPFlowGraphUndoCommand *, CXTPFlowGraphUndoCommand * > m_arrUndoCommands
The command collection.
Definition XTPFlowGraphUndoManager.h:141
CXTPFlowGraphUndoGroupCommand::~CXTPFlowGraphUndoGroupCommand
virtual ~CXTPFlowGraphUndoGroupCommand()
Destroys a CXTPFlowGraphUndoGroupCommand object, handles cleanup and deallocation.
CXTPFlowGraphUndoGroupCommand::Undo
virtual void Undo()
Call this function to do the undo operation.
CXTPFlowGraphUndoGroupCommand::m_pManager
CXTPFlowGraphUndoManager * m_pManager
The undo manager.
Definition XTPFlowGraphUndoManager.h:144
CXTPFlowGraphUndoGroupCommand::CXTPFlowGraphUndoGroupCommand
CXTPFlowGraphUndoGroupCommand(CXTPFlowGraphUndoManager *pManager)
Constructs a CXTPFlowGraphUndoGroupCommand object.
CXTPFlowGraphUndoManager
This class abstracts an undo manager.
Definition XTPFlowGraphUndoManager.h:544
CXTPFlowGraphUndoManager::EnableUndoManager
void EnableUndoManager(BOOL bEnabled)
Use this function to enable/disable the undo manager.
Definition XTPFlowGraphUndoManager.h:652
CXTPFlowGraphUndoManager::CanUndo
BOOL CanUndo() const
Call this function to determine if the undo operation is possible in the current context.
CXTPFlowGraphUndoManager::StartGroup
virtual void StartGroup()
Call this function to start an undo group command.
CXTPFlowGraphUndoManager::CXTPFlowGraphUndoManager
CXTPFlowGraphUndoManager()
Constructs a CXTPFlowGraphUndoManager object.
CXTPFlowGraphUndoManager::AddUndoCommand
void AddUndoCommand(CXTPFlowGraphUndoCommand *pCommand)
Use this function to add an undo command to the collection of undo commands.
CXTPFlowGraphUndoManager::m_arrUndoCommands
CArray< CXTPFlowGraphUndoCommand *, CXTPFlowGraphUndoCommand * > m_arrUndoCommands
The undo commands array.
Definition XTPFlowGraphUndoManager.h:625
CXTPFlowGraphUndoManager::Redo
virtual void Redo()
Call this function to do the redo operation.
CXTPFlowGraphUndoManager::Clear
void Clear()
Call this function to clear the list of undo and redo operations.
CXTPFlowGraphUndoManager::Undo
virtual void Undo()
Call this function to do the undo operation.
CXTPFlowGraphUndoManager::m_arrGroupStack
CArray< CXTPFlowGraphUndoGroupCommand *, CXTPFlowGraphUndoGroupCommand * > m_arrGroupStack
The groups stack.
Definition XTPFlowGraphUndoManager.h:633
CXTPFlowGraphUndoManager::m_nUndoContext
int m_nUndoContext
The undo context.
Definition XTPFlowGraphUndoManager.h:635
CXTPFlowGraphUndoManager::CanRedo
BOOL CanRedo() const
Call this function to determine if the redo operation is possible in the current context.
CXTPFlowGraphUndoManager::m_arrRedoCommands
CArray< CXTPFlowGraphUndoCommand *, CXTPFlowGraphUndoCommand * > m_arrRedoCommands
The redo command array.
Definition XTPFlowGraphUndoManager.h:628
CXTPFlowGraphUndoManager::EndGroup
virtual void EndGroup()
Call this function to end an undo group command.
CXTPFlowGraphUndoManager::~CXTPFlowGraphUndoManager
virtual ~CXTPFlowGraphUndoManager()
Destroys a CXTPFlowGraphUndoManager object, handles cleanup and deallocation.
CXTPFlowGraphUndoManager::m_pUndoGroup
CXTPFlowGraphUndoGroupCommand * m_pUndoGroup
The undo group command.
Definition XTPFlowGraphUndoManager.h:637
CXTPFlowGraphUndoManager::m_bEnabled
BOOL m_bEnabled
Specifies whether the undo manager is enabled or disabled.
Definition XTPFlowGraphUndoManager.h:636
CXTPFlowGraphUndoSetConnectionPositionCommand
This class abstracts the undo set connection position command.
Definition XTPFlowGraphUndoManager.h:490
CXTPFlowGraphUndoSetConnectionPositionCommand::CXTPFlowGraphUndoSetConnectionPositionCommand
CXTPFlowGraphUndoSetConnectionPositionCommand(CXTPFlowGraphConnection *pConnection, CPoint ptOldPosition)
Constructs a CXTPFlowGraphUndoSetConnectionPositionCommand object.
CXTPFlowGraphUndoSetConnectionPositionCommand::~CXTPFlowGraphUndoSetConnectionPositionCommand
virtual ~CXTPFlowGraphUndoSetConnectionPositionCommand()
Destroys a CXTPFlowGraphUndoSetConnectionPositionCommand object, handles cleanup and deallocation.
CXTPFlowGraphUndoSetConnectionPositionCommand::m_pConnection
CXTPFlowGraphConnection * m_pConnection
Pointer to the FlowGraph connection object.
Definition XTPFlowGraphUndoManager.h:519
CXTPFlowGraphUndoSetConnectionPositionCommand::m_ptOldPosition
CPoint m_ptOldPosition
Old position of the connection.
Definition XTPFlowGraphUndoManager.h:520
CXTPFlowGraphUndoSetConnectionPositionCommand::Undo
virtual void Undo()
Call this function to do the undo operation.
CXTPFlowGraphUndoSetNodeCaptionCommand
This class abstracts the undo set Node caption command.
Definition XTPFlowGraphUndoManager.h:452
CXTPFlowGraphUndoSetNodeCaptionCommand::m_strOldCaption
CString m_strOldCaption
Old caption of the Node.
Definition XTPFlowGraphUndoManager.h:481
CXTPFlowGraphUndoSetNodeCaptionCommand::CXTPFlowGraphUndoSetNodeCaptionCommand
CXTPFlowGraphUndoSetNodeCaptionCommand(CXTPFlowGraphElement *pNode, CString strOldCaption)
Constructs a CXTPFlowGraphUndoSetNodeCaptionCommand object.
CXTPFlowGraphUndoSetNodeCaptionCommand::~CXTPFlowGraphUndoSetNodeCaptionCommand
virtual ~CXTPFlowGraphUndoSetNodeCaptionCommand()
Destroys a CXTPFlowGraphUndoSetNodeCaptionCommand object, handles cleanup and deallocation.
CXTPFlowGraphUndoSetNodeCaptionCommand::m_pNode
CXTPFlowGraphElement * m_pNode
Pointer to the FlowGraph Node object.
Definition XTPFlowGraphUndoManager.h:480
CXTPFlowGraphUndoSetNodeCaptionCommand::Undo
virtual void Undo()
Call this function to do the undo operation.
CXTPFlowGraphUndoSetNodePositionCommand
This class abstracts the undo set Node position command.
Definition XTPFlowGraphUndoManager.h:376
CXTPFlowGraphUndoSetNodePositionCommand::~CXTPFlowGraphUndoSetNodePositionCommand
virtual ~CXTPFlowGraphUndoSetNodePositionCommand()
Destroys a CXTPFlowGraphUndoSetNodePositionCommand object, handles cleanup and deallocation.
CXTPFlowGraphUndoSetNodePositionCommand::CXTPFlowGraphUndoSetNodePositionCommand
CXTPFlowGraphUndoSetNodePositionCommand(CXTPFlowGraphNode *pNode, CPoint ptOldPosition)
Constructs a CXTPFlowGraphUndoSetNodePositionCommand object.
CXTPFlowGraphUndoSetNodePositionCommand::m_ptOldPosition
CPoint m_ptOldPosition
Old position of the Node.
Definition XTPFlowGraphUndoManager.h:405
CXTPFlowGraphUndoSetNodePositionCommand::Undo
virtual void Undo()
Call this function to do the undo operation.
CXTPFlowGraphUndoSetNodePositionCommand::m_pNode
CXTPFlowGraphNode * m_pNode
Pointer to the FlowGraph Node object.
Definition XTPFlowGraphUndoManager.h:404
CXTPFlowGraphUndoSetNodeSizeCommand
This class abstracts the undo set Node size command.
Definition XTPFlowGraphUndoManager.h:414
CXTPFlowGraphUndoSetNodeSizeCommand::~CXTPFlowGraphUndoSetNodeSizeCommand
virtual ~CXTPFlowGraphUndoSetNodeSizeCommand()
Destroys a CXTPFlowGraphUndoSetNodeSizeCommand object, handles cleanup and deallocation.
CXTPFlowGraphUndoSetNodeSizeCommand::m_szOldSize
CPoint m_szOldSize
Old size of the Node.
Definition XTPFlowGraphUndoManager.h:443
CXTPFlowGraphUndoSetNodeSizeCommand::CXTPFlowGraphUndoSetNodeSizeCommand
CXTPFlowGraphUndoSetNodeSizeCommand(CXTPFlowGraphNode *pNode, CSize szOldSize)
Constructs a CXTPFlowGraphUndoSetNodeSizeCommand object.
CXTPFlowGraphUndoSetNodeSizeCommand::Undo
virtual void Undo()
Call this function to do the undo operation.
CXTPFlowGraphUndoSetNodeSizeCommand::m_pNode
CXTPFlowGraphNode * m_pNode
Pointer to the FlowGraph Node object.
Definition XTPFlowGraphUndoManager.h:442


Toolkit Pro: Member List

CXTPCalendarCaptionBarVisualStudio2019Theme Member List

This is the complete list of members for CXTPCalendarCaptionBarVisualStudio2019Theme, including all inherited members.

CXTPCalendarCaptionBarOffice2000Theme(CXTPCalendarCaptionBarTheme *pTheme=NULL) | CXTPCalendarCaptionBarOffice2000Theme |
CXTPCalendarCaptionBarOffice2003Theme(CXTPCalendarCaptionBarTheme *pTheme=NULL) | CXTPCalendarCaptionBarOffice2003Theme |
CXTPCalendarCaptionBarOffice2013Theme(CXTPCalendarCaptionBarTheme *pTheme=NULL) | CXTPCalendarCaptionBarOffice2013Theme |
CXTPCalendarCaptionBarOfficeXPTheme(CXTPCalendarCaptionBarTheme *pTheme=NULL) | CXTPCalendarCaptionBarOfficeXPTheme |
CXTPCalendarCaptionBarPaintManager(CXTPCalendarCaptionBarTheme *pTheme=NULL) | CXTPCalendarCaptionBarPaintManager |
CXTPCalendarCaptionBarVisualStudio2019Theme(CXTPCalendarCaptionBarTheme *pTheme=NULL) | CXTPCalendarCaptionBarVisualStudio2019Theme |
CXTPCmdTarget() | CXTPCmdTarget |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetPaintTheme() const | CXTPCalendarCaptionBarPaintManager | virtual
m_clrBorders | CXTPCalendarCaptionBarPaintManager | protected
m_clrScrollDateBarBk | CXTPCalendarCaptionBarPaintManager | protected
m_clrScrollTriangleColor | CXTPCalendarCaptionBarPaintManager | protected
m_clrSwitchViewBarBk | CXTPCalendarCaptionBarPaintManager | protected
m_clrTextColor | CXTPCalendarCaptionBarPaintManager | protected
m_fntTextFont | CXTPCalendarCaptionBarPaintManager | protected
m_pTheme | CXTPCalendarCaptionBarPaintManager | protected
RefreshMetrics() | CXTPCalendarCaptionBarOffice2013Theme | virtual
~CXTPCalendarCaptionBarOffice2000Theme() | CXTPCalendarCaptionBarOffice2000Theme | virtual
~CXTPCalendarCaptionBarOffice2003Theme() | CXTPCalendarCaptionBarOffice2003Theme | virtual
~CXTPCalendarCaptionBarOffice2013Theme() | CXTPCalendarCaptionBarOffice2013Theme | virtual
~CXTPCalendarCaptionBarOfficeXPTheme() | CXTPCalendarCaptionBarOfficeXPTheme | virtual
~CXTPCalendarCaptionBarPaintManager() | CXTPCalendarCaptionBarPaintManager | virtual
~CXTPCalendarCaptionBarVisualStudio2019Theme() | CXTPCalendarCaptionBarVisualStudio2019Theme | virtual


Toolkit Pro: XTPTabColorSetVisualStudio2022.h Source File

  • Source
  • TabManager
  • ColorSets
XTPTabColorSetVisualStudio2022.h
Go to the documentation of this file.
1
23#if !defined(__XTPTABCOLORSETVISUALSTUDIO2022_H__)
24# define __XTPTABCOLORSETVISUALSTUDIO2022_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
37class _XTP_EXT_CLASS CXTPTabColorSetVisualStudio2022 : public CXTPTabColorSetVisualStudio2019
38{
39public:
40 CXTPTabColorSetVisualStudio2022();
41
49 virtual void RefreshMetrics();
50};
51
52# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
54#endif // !defined(__XTPTABCOLORSETVISUALSTUDIO2022_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPTabColorSetVisualStudio2019
CXTPTabColorSetVisualStudio2019 implements a Visual Studio 2019 tab color set.
Definition XTPTabColorSetVisualStudio2019.h:38
CXTPTabColorSetVisualStudio2022
CXTPTabColorSetVisualStudio2022 implements a Visual Studio 2022 tab color set.
Definition XTPTabColorSetVisualStudio2022.h:38
CXTPTabColorSetVisualStudio2022::RefreshMetrics
virtual void RefreshMetrics()
Refreshes the visual metrics of the tabs.


Toolkit Pro: Member List

CXTPDockingPanePanelColorSetNativeWindows11 Member List

This is the complete list of members for CXTPDockingPanePanelColorSetNativeWindows11, including all inherited members.

CXTPDockingPanePanelColorSet2012() | CXTPDockingPanePanelColorSet2012 |
CXTPDockingPanePanelColorSetNativeWindows11() | CXTPDockingPanePanelColorSetNativeWindows11 |
CXTPTabPaintManagerColorSet() | CXTPTabPaintManagerColorSet |
FillClient(CDC *pDC, CRect rc, CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
FillHeader(CDC *pDC, CRect rc, CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
FillNavigateButton(CDC *pDC, CXTPTabManagerNavigateButton *pButton, CRect &rc) | CXTPDockingPanePanelColorSet2012 | virtual
FillPropertyButton(CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerColorSet | virtual
FillStateButton(CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerColorSet | virtual
GetClientColor(CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
GetItemColor(CXTPTabManagerItem *pItem) | CXTPDockingPanePanelColorSet2012 | virtual
GradientFill(CDC *pDC, CRect rc, COLORREF clrLight, COLORREF clrDark, XTPTabPosition position) | CXTPTabPaintManagerColorSet |
IsAppThemed() const | CXTPTabPaintManagerColorSet | virtual
m_clrActiveFilesBack | CXTPTabPaintManagerColorSet |
m_clrActiveFilesBackHighlighted | CXTPTabPaintManagerColorSet |
m_clrActiveFilesBackPressed | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyph | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyphHighlighted | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyphPressed | CXTPTabPaintManagerColorSet |
m_clrAutoHideFace | CXTPTabPaintManagerColorSet |
m_clrBorderHighlight | CXTPTabPaintManagerColorSet |
m_clrButtonBorder | CXTPTabPaintManagerColorSet |
m_clrButtonBorderHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonBorderHot | CXTPTabPaintManagerColorSet |
m_clrButtonBorderKeyTips | CXTPTabPaintManagerColorSet |
m_clrButtonBorderTabContext1 | CXTPTabPaintManagerColorSet |
m_clrButtonBorderTabContext2 | CXTPTabPaintManagerColorSet |
m_clrButtonHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonHighlightedClose | CXTPTabPaintManagerColorSet |
m_clrButtonNormal | CXTPTabPaintManagerColorSet |
m_clrButtonPressed | CXTPTabPaintManagerColorSet |
m_clrButtonSelected | CXTPTabPaintManagerColorSet |
m_clrButtonSelectedHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonSelectedPressed | CXTPTabPaintManagerColorSet |
m_clrControlFace | CXTPTabPaintManagerColorSet |
m_clrFrameBorder | CXTPTabPaintManagerColorSet |
m_clrHeaderFace | CXTPTabPaintManagerColorSet |
m_clrPaneFace | CXTPTabPaintManagerColorSet |
m_clrTabClientBack | CXTPTabPaintManagerColorSet |
m_clrTabClientBorder | CXTPTabPaintManagerColorSet |
m_clrTextDisabled | CXTPTabPaintManagerColorSet |
m_clrTextHighlight | CXTPTabPaintManagerColorSet |
m_clrTextHighlightClose | CXTPTabPaintManagerColorSet |
m_clrTextNormal | CXTPTabPaintManagerColorSet |
m_clrTextPressed | CXTPTabPaintManagerColorSet |
m_clrTextSelected | CXTPTabPaintManagerColorSet |
m_clrTextSelectedHighlighted | CXTPTabPaintManagerColorSet |
m_clrTextSelectedPressed | CXTPTabPaintManagerColorSet |
m_csExcelNormal | CXTPTabPaintManagerColorSet |
m_csExcelSelected | CXTPTabPaintManagerColorSet |
m_csPropertyPage | CXTPTabPaintManagerColorSet |
m_csPropertyPage2003 | CXTPTabPaintManagerColorSet |
m_csStateButton | CXTPTabPaintManagerColorSet |
m_pPaintManager | CXTPTabPaintManagerColorSet | protected
RefreshMetrics() | CXTPDockingPanePanelColorSetNativeWindows11 | virtual
SelectClipRgn(CDC *pDC, CRect rcClient, CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
SetTextColor(CDC *pDC, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerColorSet | virtual
~CXTPTabPaintManagerColorSet() | CXTPTabPaintManagerColorSet | virtual


Toolkit Pro: XTPControlComboBoxExt.h Source File

  • Source
  • CommandBars
XTPControlComboBoxExt.h
Go to the documentation of this file.
1
23#if !defined(__XTPCONTROLCOMBOBOXEXT_H__)
24# define __XTPCONTROLCOMBOBOXEXT_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
58const UINT XTP_FN_SETFORMAT = 0x1000;
59
85const UINT XTP_FN_GETFORMAT = 0x1001;
86
96struct NMXTPCHARHDR : public NMXTPCONTROL
97{
103 NMXTPCHARHDR()
104 {
105 cf.cbSize = sizeof(CHARFORMAT);
106 }
109 CHARFORMAT cf;
110};
111
117class _XTP_EXT_CLASS CXTPControlSizeComboBox : public CXTPControlComboBox
118{
120 DECLARE_XTP_CONTROL(CXTPControlSizeComboBox)
122public:
127 CXTPControlSizeComboBox();
128
134 virtual ~CXTPControlSizeComboBox();
135
136public:
142 void SetTwipSize(int nTwips);
143
150 static int AFX_CDECL GetTwipSize(LPCTSTR lpszText);
151
158 static CString AFX_CDECL TwipsToPointString(int nTwips);
159
160protected:
168 virtual BOOL OnSetPopup(BOOL bPopup);
169
176 int GetTwipSize() const;
177
182 virtual void OnExecute();
183
184private:
185 void EnumFontSizes(CDC& dc, LPCTSTR pFontName);
186
187 static BOOL CALLBACK AFX_EXPORT EnumSizeCallBack(LOGFONT FAR* /*lplf*/, LPNEWTEXTMETRIC lpntm,
188 int FontType, LPVOID lpv);
189
190 void InsertSize(int nSize);
191
192private:
193 int m_nLogVert;
194 int m_nTwipsLast;
195};
196
202class _XTP_EXT_CLASS CXTPControlFontComboBoxList : public CXTPControlComboBoxList
203{
205 DECLARE_XTP_COMMANDBAR(CXTPControlFontComboBoxList)
207public:
209 class _XTP_EXT_CLASS CFontDesc
210 {
211 public:
212 CFontDesc(LPCTSTR lpszName, LPCTSTR lpszScript, BYTE nCharSet, BYTE nPitchAndFamily,
213 DWORD dwFlags);
214 CString m_strName;
215 CString m_strScript;
216 BYTE m_nCharSet;
217 BYTE m_nPitchAndFamily;
218 DWORD m_dwFlags;
219 };
220
221 class _XTP_EXT_CLASS CFontDescHolder
222 {
223 public:
224 static BOOL CALLBACK AFX_EXPORT EnumFamScreenCallBack(ENUMLOGFONT* pelf,
225 NEWTEXTMETRICEX* /*lpntm*/,
226 int FontType, LPVOID pThis);
227
228 static BOOL CALLBACK AFX_EXPORT EnumFamScreenCallBackEx(ENUMLOGFONTEX* pelf,
229 NEWTEXTMETRICEX* /*lpntm*/,
230 int FontType, LPVOID pThis);
231
232 void AddFont(ENUMLOGFONT* pelf, DWORD dwType, LPCTSTR lpszScript = NULL);
233
234 void EnumFontFamilies();
235
236 ~CFontDescHolder()
237 {
238 for (int i = 0; i < m_arrayFontDesc.GetSize(); i++)
239 delete m_arrayFontDesc[i];
240 }
241
242 public:
243 CArray<CFontDesc*, CFontDesc*> m_arrayFontDesc;
244 };
247protected:
253 virtual void DoPropExchange(CXTPPropExchange* pPX);
254
261 void Copy(CXTPCommandBar* pCommandBar, BOOL bRecursive = FALSE);
262
267 void CreateListBox();
268
269public:
275 void EnumFontFamiliesEx(BOOL dwStyleListBox = 1);
276
277protected:
278 DWORD m_dwStyleListBox;
280private:
281 friend class CXTPControlFontComboBox;
282};
283
289class _XTP_EXT_CLASS CXTPControlFontComboBox : public CXTPControlComboBox
290{
292 DECLARE_XTP_CONTROL(CXTPControlFontComboBox)
294public:
301 CXTPControlFontComboBox(DWORD dwStyleListBox = 1);
302
307 virtual ~CXTPControlFontComboBox();
308
309public:
316 void SetCharFormat(CHARFORMAT& cf);
317
318protected:
323 virtual void OnExecute();
324};
326# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
327#endif //#if !defined(__XTPCONTROLCOMBOBOXEXT_H__)
DECLARE_XTP_CONTROL
#define DECLARE_XTP_CONTROL(class_name)
This macro generates the C++ header code necessary for a CXTPControl-derived class that can be serial...
Definition XTPCommandBarsDefines.h:1169
DECLARE_XTP_COMMANDBAR
#define DECLARE_XTP_COMMANDBAR(class_name)
This macro generates the C++ header code necessary for a CXTPCommandBar-derived class that can be ser...
Definition XTPCommandBarsDefines.h:1234
XTP_FN_GETFORMAT
const UINT XTP_FN_GETFORMAT
The XTP_FN_GETFORMAT notification sent by CXTPControlFontComboBox to get the current RichEdit selecti...
Definition XTPControlComboBoxExt.h:85
XTP_FN_SETFORMAT
const UINT XTP_FN_SETFORMAT
The XTP_FN_SETFORMAT notification sent by CXTPControlFontComboBox to set the current RichEdit selecti...
Definition XTPControlComboBoxExt.h:58
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCommandBar
CXTPCommandBar is a CWnd derived class.
Definition XTPCommandBar.h:66
CXTPControlComboBox
CXTPControlComboBox is a CXTPControl derived class.
Definition XTPControlComboBox.h:381
CXTPControlComboBoxList
CXTPControlComboBoxList is a CXTPControlComboBoxPopupBar derived class.
Definition XTPControlComboBox.h:137
CXTPControlFontComboBox
CXTPControlFontComboBox is a CXTPControlComboBox derived class.
Definition XTPControlComboBoxExt.h:290
CXTPControlFontComboBox::OnExecute
virtual void OnExecute()
This method is called when the control is executed.
CXTPControlFontComboBox::~CXTPControlFontComboBox
virtual ~CXTPControlFontComboBox()
Destroys a CXTPControl object, handles cleanup and deallocation.
CXTPControlFontComboBox::CXTPControlFontComboBox
CXTPControlFontComboBox(DWORD dwStyleListBox=1)
Constructs a CXTPControlFontComboBox object.
CXTPControlFontComboBox::SetCharFormat
void SetCharFormat(CHARFORMAT &cf)
Call this method to set the current font of the picker.
CXTPControlFontComboBoxList
CXTPControlFontComboBoxList is a CXTPControlComboBoxList derived class.
Definition XTPControlComboBoxExt.h:203
CXTPControlFontComboBoxList::DoPropExchange
virtual void DoPropExchange(CXTPPropExchange *pPX)
Either reads this object from or writes this object to an archive.
CXTPControlFontComboBoxList::EnumFontFamiliesEx
void EnumFontFamiliesEx(BOOL dwStyleListBox=1)
This method is called to add all fonts to the list.
CXTPControlFontComboBoxList::Copy
void Copy(CXTPCommandBar *pCommandBar, BOOL bRecursive=FALSE)
Call this method to make a copy of the command bar.
CXTPControlFontComboBoxList::m_dwStyleListBox
DWORD m_dwStyleListBox
Style of the control.
Definition XTPControlComboBoxExt.h:278
CXTPControlFontComboBoxList::CreateListBox
void CreateListBox()
Creates a list box.
CXTPControlSizeComboBox
CXTPControlSizeComboBox is a CXTPControlComboBox derived class.
Definition XTPControlComboBoxExt.h:118
CXTPControlSizeComboBox::OnExecute
virtual void OnExecute()
This method is called when the control is executed.
CXTPControlSizeComboBox::GetTwipSize
int GetTwipSize() const
Call this method to retrieve the current user selected size.
CXTPControlSizeComboBox::SetTwipSize
void SetTwipSize(int nTwips)
Call this method to set the current size.
CXTPControlSizeComboBox::GetTwipSize
static int AFX_CDECL GetTwipSize(LPCTSTR lpszText)
This method is called to convert string to twip size.
CXTPControlSizeComboBox::OnSetPopup
virtual BOOL OnSetPopup(BOOL bPopup)
This method is called to pop-up the control.
CXTPControlSizeComboBox::~CXTPControlSizeComboBox
virtual ~CXTPControlSizeComboBox()
Destroys a CXTPControlSizeComboBox object, handles cleanup and deallocation.
CXTPControlSizeComboBox::TwipsToPointString
static CString AFX_CDECL TwipsToPointString(int nTwips)
This method is called to convert twips to string.
CXTPControlSizeComboBox::CXTPControlSizeComboBox
CXTPControlSizeComboBox()
Constructs a CXTPControlSizeComboBox object.
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72
NMXTPCHARHDR
Structure used as a parameter for XTP_FN_SETFORMAT and XTP_FN_GETFORMAT messages.
Definition XTPControlComboBoxExt.h:97
NMXTPCHARHDR::cf
CHARFORMAT cf
Character formatting in a rich edit control.
Definition XTPControlComboBoxExt.h:109
NMXTPCONTROL
This structure is passed as a parameter in CBN_XTP_EXECUTE message.
Definition XTPCommandBarsDefines.h:769


Toolkit Pro: XTPResize.h Source File

  • Source
  • Controls
  • Resize
XTPResize.h
Go to the documentation of this file.
1
23#if !defined(__XTPRESIZE_H__)
24# define __XTPRESIZE_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
45enum XTPResize
46{
47 xtpResizeNoSizeIcon = 0x01,
48 xtpResizeNoHorizontal = 0x02,
49 xtpResizeNoVertical = 0x04,
50 xtpResizeNoMinsize = 0x08,
51 xtpResizeNoClipChildren = 0x10,
52 xtpResizeNoTransparentGroup = 0x20
53};
54
55class CXTPResize;
56
62class _XTP_EXT_CLASS CXTPResizeItem
63{
64public:
73 CXTPResizeItem(CWnd* pWnd, const CXTPResizeRect& rrcSizing, CRect& rcWindow, BOOL bAutoDelete);
74
79 virtual ~CXTPResizeItem();
80
81public:
91 virtual bool MakeTransparent(CXTPResize* pXTPResize);
92
93public:
94 BOOL m_bIsGroupBox;
95 BOOL m_bAutoDelete;
96 BOOL m_bInitialSize;
97 CWnd* m_pWnd;
98 CXTPResizeRect m_rrcSizing;
99 CXTPResizeRect m_rrcWindow;
100 CXTPResizeRect m_rrcInitWindow;
101};
102
109class _XTP_EXT_CLASS CXTPSizeIcon : public CScrollBar
110{
111public:
116 CXTPSizeIcon();
117
122 virtual ~CXTPSizeIcon();
123
124protected:
126 DECLARE_MESSAGE_MAP()
127
128 //{{AFX_MSG(CXTPSizeIcon)
129 afx_msg BOOL OnSetCursor(CWnd* pWnd, UINT nHitTest, UINT message);
130 afx_msg void OnSetFocus(CWnd* pOldWnd);
131 //}}AFX_MSG
134protected:
135 HCURSOR m_hCursor;
136};
137
144class _XTP_EXT_CLASS CXTPResize
145{
146public:
166 CXTPResize(CWnd* pWnd, const UINT nFlags = 0);
167
172 virtual ~CXTPResize();
173
174public:
190 void SetResize(UINT nID, XTP_RESIZE left, XTP_RESIZE top, XTP_RESIZE right, XTP_RESIZE bottom);
191
205 void SetResize(UINT nID, const XTP_RESIZERECT& rrcSizing);
206
222 void SetResize(UINT nID, HWND hWnd, const XTP_RESIZERECT& rrcSizing);
223
241 void SetResize(UINT nID, HWND hWnd, const XTP_RESIZEPOINT& rpTopLeft,
242 const XTP_RESIZEPOINT& rpBottomRight);
243
259 void SetResize(UINT nID, const XTP_RESIZEPOINT& rpTopLeft,
260 const XTP_RESIZEPOINT& rpBottomRight);
261
268 void SetMinSize(CSize& sz);
269
275 void SetMaxSize(CSize& sz);
276
285 BOOL SavePlacement(LPCTSTR pszSection);
286
296 BOOL LoadPlacement(LPCTSTR pszSection);
297
309 BOOL AutoLoadPlacement(LPCTSTR pszSection);
310
311protected:
326 void SetResize(CWnd* pWnd, const CXTPResizeRect& rrcSizing, CRect rcWindow);
327
336 BOOL RemoveResize(UINT nID);
337
343 void RemoveAllControls();
344
350 virtual void Init();
351
357 virtual void Size();
358
366 void Reset();
367
374 void Offset(CPoint ptOffset);
375
381 void UpdateControlRect(CWnd* pWnd);
382
397 void GetMinMaxInfo(MINMAXINFO* pMMI);
398
405 virtual void AdjustResizeRect(CSize& rcWindow);
406
407protected: // flags
425 BOOL HasFlag(XTPResize eFlag);
426
442 void SetFlag(XTPResize eFlag);
443
444protected: // helper methods
459 virtual BOOL Defer(HDWP& hdwp, CXTPResizeItem* pItem, int dx, int dy);
460
461protected:
462 typedef CArray<CXTPResizeItem*, CXTPResizeItem*&> CResizeItemArray;
467 UINT m_nFlagsXX;
468 CWnd* m_pWnd;
469 CSize m_szWindow;
470 CSize m_szInitWindow;
471 CSize m_szMin;
472 CSize m_szMax;
473 CString m_strSection;
474 CXTPSizeIcon m_scSizeIcon;
475 CResizeItemArray m_arrItems;
477 friend class CXTPResizeItem;
478};
479
481
482AFX_INLINE void CXTPResize::SetMinSize(CSize& sz)
483{
484 m_szMin = sz;
485}
486AFX_INLINE void CXTPResize::SetMaxSize(CSize& sz)
487{
488 m_szMax = sz;
489}
490AFX_INLINE BOOL CXTPResize::HasFlag(XTPResize eFlag)
491{
492 return (m_nFlagsXX & eFlag) != 0;
493}
494AFX_INLINE void CXTPResize::SetResize(UINT nID, HWND hWnd, const XTP_RESIZEPOINT& rpTopLeft,
495 const XTP_RESIZEPOINT& rpBottomRight)
496{
497 SetResize(nID, hWnd,
498 CXTPResizeRect(rpTopLeft.x, rpTopLeft.y, rpBottomRight.x, rpBottomRight.y));
499}
500
501AFX_INLINE void CXTPResize::SetResize(UINT nID, const XTP_RESIZERECT& rrcSizing)
502{
503 _ASSERTE(0 != nID);
504 SetResize(nID, NULL, rrcSizing);
505}
506
507AFX_INLINE void CXTPResize::SetResize(UINT nID, const XTP_RESIZEPOINT& rpTopLeft,
508 const XTP_RESIZEPOINT& rpBottomRight)
509{
510 _ASSERTE(0 != nID);
511 SetResize(nID, CXTPResizeRect(rpTopLeft.x, rpTopLeft.y, rpBottomRight.x, rpBottomRight.y));
512}
513
514AFX_INLINE void CXTPResize::SetResize(UINT nID, XTP_RESIZE left, XTP_RESIZE top, XTP_RESIZE right,
515 XTP_RESIZE bottom)
516{
517 _ASSERTE(0 != nID);
518 SetResize(nID, CXTPResizeRect(left, top, right, bottom));
519}
521# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
523#endif // !defined(__XTPRESIZE_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPResize
XTPResize
Enumeration used to determine attributes for resizing windows.
Definition XTPResize.h:46
xtpResizeNoHorizontal
@ xtpResizeNoHorizontal
No horizontal resizing.
Definition XTPResize.h:48
xtpResizeNoSizeIcon
@ xtpResizeNoSizeIcon
Do not add size icon.
Definition XTPResize.h:47
xtpResizeNoMinsize
@ xtpResizeNoMinsize
Do not require a minimum size.
Definition XTPResize.h:50
xtpResizeNoClipChildren
@ xtpResizeNoClipChildren
Do not set clip children style.
Definition XTPResize.h:51
xtpResizeNoVertical
@ xtpResizeNoVertical
No vertical resizing.
Definition XTPResize.h:49
xtpResizeNoTransparentGroup
@ xtpResizeNoTransparentGroup
Do not set transparent style for group boxes.
Definition XTPResize.h:52
XTP_RESIZE
float XTP_RESIZE
The XTP_RESIZE data type is defined as a float and is used for storing single-precision floating poin...
Definition XTPResizeRect.h:41
CXTPResize
CXTPResize is a base class.
Definition XTPResize.h:145
CXTPResize::RemoveResize
BOOL RemoveResize(UINT nID)
This member function is called to remove the specified dialog item from the list of items to be resiz...
CXTPResize::HasFlag
BOOL HasFlag(XTPResize eFlag)
This member function is called to determine if the specified flag has been set for the resize manager...
CXTPResize::SetMinSize
void SetMinSize(CSize &sz)
This member function sets the minimum size explicitly.
CXTPResize::SetFlag
void SetFlag(XTPResize eFlag)
This member function is called to set a specific flag for the resize manager.
CXTPResize::SetResize
void SetResize(UINT nID, const XTP_RESIZERECT &rrcSizing)
The SetResize function specifies how much each side of a control will move when the dialog is resized...
CXTPResize::m_pWnd
CWnd * m_pWnd
The associative relation to the window to be resized.
Definition XTPResize.h:468
CXTPResize::LoadPlacement
BOOL LoadPlacement(LPCTSTR pszSection)
This member function loads saved window placement information from the registry.
CXTPResize::m_scSizeIcon
CXTPSizeIcon m_scSizeIcon
Size icon window.
Definition XTPResize.h:474
CXTPResize::Reset
void Reset()
This member function is called when a property sheet in wizard mode has changed pages to alert the re...
CXTPResize::m_szMax
CSize m_szMax
Largest size allowed.
Definition XTPResize.h:472
CXTPResize::Init
virtual void Init()
This member function is called from OnInitDialog or OnInitialUpdate to initialize the resize manager.
CXTPResize::~CXTPResize
virtual ~CXTPResize()
Destroys a CXTPResize object, handles cleanup and deallocation.
CXTPResize::SetResize
void SetResize(UINT nID, XTP_RESIZE left, XTP_RESIZE top, XTP_RESIZE right, XTP_RESIZE bottom)
The SetResize function specifies how much each side of a control will move when the dialog is resized...
CXTPResize::AutoLoadPlacement
BOOL AutoLoadPlacement(LPCTSTR pszSection)
This member function loads saved window placement information from the registry.
CXTPResize::m_szInitWindow
CSize m_szInitWindow
Initial dialog size.
Definition XTPResize.h:470
CXTPResize::RemoveAllControls
void RemoveAllControls()
This member function is called to purge the list that contains the dialog items to be sized.
CXTPResize::m_szWindow
CSize m_szWindow
Last dialog size.
Definition XTPResize.h:469
CXTPResize::GetMinMaxInfo
void GetMinMaxInfo(MINMAXINFO *pMMI)
This member function is called from OnGetMinMaxInfo to get the maximized position or dimensions or th...
CXTPResize::SetMaxSize
void SetMaxSize(CSize &sz)
This member function sets the maximum size.
CXTPResize::Offset
void Offset(CPoint ptOffset)
Called to offset dialog items by the amount specified by ptOffset.
CXTPResize::CXTPResize
CXTPResize(CWnd *pWnd, const UINT nFlags=0)
Constructs a CXTPResize object.
CXTPResize::SetResize
void SetResize(UINT nID, HWND hWnd, const XTP_RESIZEPOINT &rpTopLeft, const XTP_RESIZEPOINT &rpBottomRight)
The SetResize function specifies how much each side of a control will move when the dialog is resized...
CXTPResize::SetResize
void SetResize(UINT nID, const XTP_RESIZEPOINT &rpTopLeft, const XTP_RESIZEPOINT &rpBottomRight)
The SetResize function specifies how much each side of a control will move when the dialog is resized...
CXTPResize::SetResize
void SetResize(UINT nID, HWND hWnd, const XTP_RESIZERECT &rrcSizing)
The SetResize function specifies how much each side of a control will move when the dialog is resized...
CXTPResize::m_arrItems
CResizeItemArray m_arrItems
Array of controls.
Definition XTPResize.h:475
CXTPResize::SavePlacement
BOOL SavePlacement(LPCTSTR pszSection)
This member function saves the window placement to the registry.
CXTPResize::Size
virtual void Size()
This member function is called from OnSize to move and resize the dialog items that are managed.
CXTPResize::SetResize
void SetResize(CWnd *pWnd, const CXTPResizeRect &rrcSizing, CRect rcWindow)
The SetResize function specifies how much each side of a control will move when the dialog is resized...
CXTPResize::m_szMin
CSize m_szMin
Smallest size allowed.
Definition XTPResize.h:471
CXTPResize::AdjustResizeRect
virtual void AdjustResizeRect(CSize &rcWindow)
This method is called in the Size method to adjust a window rectangle to fit real client size.
CXTPResize::m_nFlagsXX
UINT m_nFlagsXX
Flags passed from the constructor.
Definition XTPResize.h:467
CXTPResize::UpdateControlRect
void UpdateControlRect(CWnd *pWnd)
Call this method to reset m_rrcWindow for an item.
CXTPResize::Defer
virtual BOOL Defer(HDWP &hdwp, CXTPResizeItem *pItem, int dx, int dy)
Called by CXTPResize to resize a child window.
CXTPResize::CResizeItemArray
CArray< CXTPResizeItem *, CXTPResizeItem *& > CResizeItemArray
Used by CXTPResize to maintain a list of children that are sizable.
Definition XTPResize.h:462
CXTPResize::m_strSection
CString m_strSection
Section in registry where window placement information is saved.
Definition XTPResize.h:473
CXTPResizeItem
CXTPResizeItem is a standalone helper class.
Definition XTPResize.h:63
CXTPResizeItem::m_bIsGroupBox
BOOL m_bIsGroupBox
TRUE if the window is a group box.
Definition XTPResize.h:94
CXTPResizeItem::m_rrcSizing
CXTPResizeRect m_rrcSizing
Sizing option.
Definition XTPResize.h:98
CXTPResizeItem::m_rrcWindow
CXTPResizeRect m_rrcWindow
Last control size.
Definition XTPResize.h:99
CXTPResizeItem::~CXTPResizeItem
virtual ~CXTPResizeItem()
Destroys a CXTPResizeItem object, handles cleanup and deallocation.
CXTPResizeItem::m_pWnd
CWnd * m_pWnd
A pointer to the window to be sized or moved.
Definition XTPResize.h:97
CXTPResizeItem::m_rrcInitWindow
CXTPResizeRect m_rrcInitWindow
Initial control size.
Definition XTPResize.h:100
CXTPResizeItem::m_bAutoDelete
BOOL m_bAutoDelete
TRUE if the window is to be deleted.
Definition XTPResize.h:95
CXTPResizeItem::MakeTransparent
virtual bool MakeTransparent(CXTPResize *pXTPResize)
Called by CXTPResize to make group box controls window style transparent.
CXTPResizeItem::m_bInitialSize
BOOL m_bInitialSize
Initial size/move has been completed.
Definition XTPResize.h:96
CXTPResizeItem::CXTPResizeItem
CXTPResizeItem(CWnd *pWnd, const CXTPResizeRect &rrcSizing, CRect &rcWindow, BOOL bAutoDelete)
Constructs a CXTPResizeItem object.
CXTPResizeRect
CXTPResizeRect is an XTP_RESIZERECT structure derived class.
Definition XTPResizeRect.h:81
CXTPSizeIcon
The CXTPSizeIcon class is a CStatic derived helper class.
Definition XTPResize.h:110
CXTPSizeIcon::CXTPSizeIcon
CXTPSizeIcon()
Constructs a CXTPSizeIcon object.
CXTPSizeIcon::~CXTPSizeIcon
virtual ~CXTPSizeIcon()
Destroys a CXTPSizeIcon object, handles cleanup and deallocation.
XTP_RESIZEPOINT
The XTP_RESIZEPOINT structure is used by the CXTPResizePoint class for defining single-precision floa...
Definition XTPResizePoint.h:42
XTP_RESIZEPOINT::y
XTP_RESIZE y
Specifies the y-coordinate of a point.
Definition XTPResizePoint.h:44
XTP_RESIZEPOINT::x
XTP_RESIZE x
Specifies the x-coordinate of a point.
Definition XTPResizePoint.h:43
XTP_RESIZERECT
XTP_RESIZERECT structure is used by the CXTPResizeRect class for defining single-precision floating p...
Definition XTPResizeRect.h:64


Toolkit Pro: Member List

CXTPChartPyramidSeriesLabel Member List

This is the complete list of members for CXTPChartPyramidSeriesLabel, including all inherited members.

CreateView(CXTPChartDeviceContext *pDC, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView) | CXTPChartPyramidSeriesLabel | protectedvirtual
CXTPChartElement() | CXTPChartElement |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartPyramidSeriesLabelBase() | CXTPChartPyramidSeriesLabelBase |
CXTPChartSeriesLabel() | CXTPChartSeriesLabel |
DoPropExchange(CXTPPropExchange *pPX) | CXTPChartPyramidSeriesLabelBase | virtual
GetAntialiasing() const | CXTPChartSeriesLabel | virtual
GetAppearance() const | CXTPChartElement |
GetBackColor() const | CXTPChartSeriesLabel |
GetContent() const | CXTPChartElement |
GetFont() const | CXTPChartSeriesLabel | virtual
GetFormat() const | CXTPChartSeriesLabel |
GetLineColor() const | CXTPChartSeriesLabel |
GetLineLength() const | CXTPChartSeriesLabel |
GetOwner() const | CXTPChartElement |
GetPosition() const | CXTPChartPyramidSeriesLabelBase |
GetShowLines() const | CXTPChartSeriesLabel |
GetStyle() const | CXTPChartPyramidSeriesLabelBase |
GetTextColor() const | CXTPChartSeriesLabel |
GetTransparency() const | CXTPChartSeriesLabel |
Is3D() const | CXTPChartObject |
IsInside() const | CXTPChartPyramidSeriesLabelBase |
IsVisible() const | CXTPChartSeriesLabel |
m_bAntialiasing | CXTPChartSeriesLabel | protected
m_bShowLines | CXTPChartSeriesLabel | protected
m_bVisible | CXTPChartSeriesLabel | protected
m_clrBackColor | CXTPChartSeriesLabel | protected
m_clrLineColor | CXTPChartSeriesLabel | protected
m_clrTextColor | CXTPChartSeriesLabel | protected
m_nLineLength | CXTPChartSeriesLabel | protected
m_nPosition | CXTPChartPyramidSeriesLabelBase | protected
m_nTransparency | CXTPChartSeriesLabel | protected
m_pBorder | CXTPChartSeriesLabel | protected
m_pFont | CXTPChartSeriesLabel | protected
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartElement | virtual
Release() | CXTPChartElement | virtual
SetAntialiasing(BOOL bAntialiasing) | CXTPChartSeriesLabel |
SetBackColor(const CXTPChartColor &clrBackColor) | CXTPChartSeriesLabel |
SetFont(CXTPChartFont *pFont) | CXTPChartSeriesLabel |
SetFormat(LPCTSTR lpszFormat) | CXTPChartSeriesLabel |
SetLineColor(const CXTPChartColor &clrBackColor) | CXTPChartSeriesLabel |
SetLineLength(int nLineLength) | CXTPChartSeriesLabel |
SetPosition(XTPChartPyramidLabelPosition nPosition) | CXTPChartPyramidSeriesLabelBase |
SetShowLines(BOOL bShowLines) | CXTPChartSeriesLabel |
SetTextColor(const CXTPChartColor &clrTextColor) | CXTPChartSeriesLabel |
SetTransparency(int nTransparency) | CXTPChartSeriesLabel |
SetVisible(BOOL bVisible) | CXTPChartSeriesLabel |
~CXTPChartElement() | CXTPChartElement | virtual
~CXTPChartPyramidSeriesLabelBase() | CXTPChartPyramidSeriesLabelBase | virtual
~CXTPChartSeriesLabel() | CXTPChartSeriesLabel | virtual


Toolkit Pro: Member List

CXTPChartRadarPointSeriesLabelView Member List

This is the complete list of members for CXTPChartRadarPointSeriesLabelView, including all inherited members.

AddChildView(CXTPChartElementView *pChildView) | CXTPChartElementView |
CreateDeviceCommand(CXTPChartDeviceContext *pDC) | CXTPChartRadarPointSeriesLabelView | virtual
CreateDeviceCommand(CXTPChartDeviceContext *pDC, const CXTPChartPointF &ptAnchorPoint, double dAnchorAngle, const CXTPChartString &text) | CXTPChartRadarPointSeriesLabelView | virtual
CXTPChartElementView(CXTPChartElementView *pParentView) | CXTPChartElementView |
CXTPChartElementView(CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartElementView |
CXTPChartElementView(CXTPChartContainer *pContainer) | CXTPChartElementView |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartRadarPointSeriesLabelView(CXTPChartSeriesLabel *pLabel, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView) | CXTPChartRadarPointSeriesLabelView |
GetAnchorPoint() const | CXTPChartRadarPointSeriesLabelView | virtual
GetAt(int nIndex) const | CXTPChartElementView |
GetBounds() const | CXTPChartElementView |
GetBounds(BOOL bIncludingChildren) const | CXTPChartElementView |
GetChildren() | CXTPChartElementView |
GetCount() const | CXTPChartElementView |
GetParentView() const | CXTPChartElementView |
Is3D() const | CXTPChartObject |
m_arrChildren | CXTPChartElementView | protected
m_pContainer | CXTPChartElementView | protected
m_pParentView | CXTPChartElementView | protected
m_rcBounds | CXTPChartElementView | protected
~CXTPChartElementView() | CXTPChartElementView | protectedvirtual


Toolkit Pro: Member List

CXTPCalendarTLV_TimeScaleParams_Day Member List

This is the complete list of members for CXTPCalendarTLV_TimeScaleParams_Day, including all inherited members.

CalcScaleIntervalBegin(COleDateTime dtStart) | CXTPCalendarTLV_TimeScaleParams | virtual
CXTPCalendarTLV_TimeScaleParams(int nTimeScaleParamsID, CXTPCalendarTimeLineViewTimeScale *pTimeScale) | CXTPCalendarTLV_TimeScaleParams |
CXTPCalendarTLV_TimeScaleParams_Day(CXTPCalendarTimeLineViewTimeScale *pTimeScale) | CXTPCalendarTLV_TimeScaleParams_Day |
CXTPCmdTarget() | CXTPCmdTarget |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetParentTimeScale() const | CXTPCalendarTLV_TimeScaleParams |
GetPart() const | CXTPCalendarTLV_TimeScaleParams_Day | virtual
GetScaleInterval() const | CXTPCalendarTLV_TimeScaleParams | virtual
GetScaleIntervalWidth_px() const | CXTPCalendarTLV_TimeScaleParams | virtual
GetTimeLineViewScale() const | CXTPCalendarTLV_TimeScaleParams | virtual
GetTimePerPixel() const | CXTPCalendarTLV_TimeScaleParams | virtual
GetTimeScaleParamsID() const | CXTPCalendarTLV_TimeScaleParams | virtual
m_nScaleIntervalWidth_px | CXTPCalendarTLV_TimeScaleParams | protected
m_scaleInterval | CXTPCalendarTLV_TimeScaleParams | protected
SetScaleInterval(int eType, int nValue) | CXTPCalendarTLV_TimeScaleParams | protected
~CXTPCalendarTLV_TimeScaleParams() | CXTPCalendarTLV_TimeScaleParams | virtual
~CXTPCalendarTLV_TimeScaleParams_Day() | CXTPCalendarTLV_TimeScaleParams_Day | virtual


Toolkit Pro: Member List

CXTPListCtrl Member List

This is the complete list of members for CXTPListCtrl, including all inherited members.

CXTPListCtrl() | CXTPListCtrl |
~CXTPListCtrl() | CXTPListCtrl | virtual


Toolkit Pro: Member List

CXTPCommandBarsContextMenus Member List

This is the complete list of members for CXTPCommandBarsContextMenus, including all inherited members.

Add(UINT nIDBar) | CXTPCommandBarsContextMenus |
Add(UINT nIDBar, UINT nIDMenuResource, int nSubMenu) | CXTPCommandBarsContextMenus |
Add(CXTPCommandBar *pCommandBar) | CXTPCommandBarsContextMenus | virtual
Add(UINT nIDBar, LPCTSTR lpszTitle, CMenu *pSubMenu) | CXTPCommandBarsContextMenus |
CXTPCmdTarget() | CXTPCmdTarget |
CXTPCommandBarList(CXTPCommandBars *pCommandBars) | CXTPCommandBarList | inline
CXTPCommandBarsContextMenus(CXTPCommandBars *pCommandBars) | CXTPCommandBarsContextMenus |
FindCommandBar(UINT nBarID) const | CXTPCommandBarList |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAt(int nIndex) const | CXTPCommandBarList |
GetCommandBars() const | CXTPCommandBarList | inline
GetCount() const | CXTPCommandBarList |
Lookup(CXTPCommandBar *pCommandBar) const | CXTPCommandBarList |
m_arrBars | CXTPCommandBarList | protected
m_pCommandBars | CXTPCommandBarList | protected
Remove(CXTPCommandBar *pCommandBar) | CXTPCommandBarList |
RemoveAll() | CXTPCommandBarList |
~CXTPCommandBarList() | CXTPCommandBarList | virtual


Toolkit Pro: XTPFrameThemeOffice2007System.h Source File

  • Source
  • CommandBars
  • Frame
XTPFrameThemeOffice2007System.h
Go to the documentation of this file.
1
23#if !defined(__XTPRIBBONOFFICE2007SYSTEMFRAMETHEME_H__)
24# define __XTPRIBBONOFFICE2007SYSTEMFRAMETHEME_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPMarkupThemePart;
34class CXTPRibbonBar;
35
44class _XTP_EXT_CLASS CXTPFrameThemeOffice2007System : public CXTPRibbonMarkupFrameTheme
45{
49public:
56 CXTPFrameThemeOffice2007System(CXTPPaintManager* pPaintManager);
57
63 virtual ~CXTPFrameThemeOffice2007System();
64
65 // Frame border
66public:
67 virtual HRGN CalcFrameRegion(CXTPCommandBarsFrameHook* pFrameHook, CSize sz) const;
68
69 virtual CRect CalcFrameBorder(const CXTPCommandBarsFrameHook* pFrameHook) const;
70
71public:
72 virtual CXTPMarkupThemePart* GetFrameBorder(int nId, BOOL bActive);
73
83 virtual void DrawCaptionBar(CDC* pDC, CRect rcCaptionBar, CWnd* pSite, BOOL bActive);
84
96 void DrawFrameCaptionButton(CDC* pDC, CRect rc, int nId, BOOL bSelected, BOOL bPressed,
97 BOOL bActive);
98
111 virtual void DrawFrameCaptionButton(CDC* pDC, CRect rc, int nId, BOOL bSelected, BOOL bPressed,
112 BOOL bActive, CXTPRibbonBar* pRibbonBar);
113
118 virtual void RefreshMetrics();
119
127 virtual void LoadParts(HZIP hZip, CXTPMarkupContext* pMarkupContext);
128
135 virtual void LoadParts(BOOL bReload = FALSE);
136
137protected:
139 _XTP_DEPRECATED_IN_FAVOR(LoadParts)
140 BOOL LoadResource();
141
142 _XTP_DEPRECATED_IN_FAVOR(CXTPRibbonMarkupFrameTheme::m_bMarkupPartsLoaded)
143 BOOL m_bLoaded;
146 using CXTPRibbonMarkupFrameTheme::m_bMarkupPartsLoaded;
147
148 CXTPMarkupThemePart* m_pCaptionActive;
149 CXTPMarkupThemePart* m_pCaptionInactive;
150 CXTPMarkupThemePart* m_pBorderLeftActive;
151 CXTPMarkupThemePart* m_pBorderLeftInactive;
152 CXTPMarkupThemePart* m_pBorderLeftCaptionActive;
153 CXTPMarkupThemePart* m_pBorderLeftCaptionInactive;
154 CXTPMarkupThemePart* m_pBorderTopActive;
155 CXTPMarkupThemePart* m_pBorderTopInactive;
156 CXTPMarkupThemePart* m_pBorderRightActive;
157 CXTPMarkupThemePart* m_pBorderRightInactive;
158 CXTPMarkupThemePart* m_pBorderRightCaptionActive;
159 CXTPMarkupThemePart* m_pBorderRightCaptionInactive;
160 CXTPMarkupThemePart* m_pBorderBottomActive;
161 CXTPMarkupThemePart* m_pBorderBottomInactive;
162
163 CXTPMarkupThemePart* m_pCaptionButtonSelected;
164 CXTPMarkupThemePart* m_pCaptionButtonPressed;
165
166 CXTPMarkupThemePart* m_pGlyphMinimize9;
167 CXTPMarkupThemePart* m_pGlyphMinimize11;
168 CXTPMarkupThemePart* m_pGlyphMaximize9;
169 CXTPMarkupThemePart* m_pGlyphMaximize11;
170 CXTPMarkupThemePart* m_pGlyphRestore9;
171 CXTPMarkupThemePart* m_pGlyphRestore11;
172 CXTPMarkupThemePart* m_pGlyphClose9;
173 CXTPMarkupThemePart* m_pGlyphClose11;
174
175 CXTPMarkupContext* m_pMarkupContext;
176};
178# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
179#endif // !defined(__XTPRIBBONOFFICE2007SYSTEMFRAMETHEME_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCommandBarsFrameHook
CXTPCommandBarsFrameHook is a CXTPHookManagerHookAble derived class.
Definition XTPFrameHook.h:56
CXTPFrameThemeOffice2007System
The CXTPFrameThemeOffice2007System class is used to enable a system style theme for Command Bars.
Definition XTPFrameThemeOffice2007System.h:45
CXTPFrameThemeOffice2007System::DrawFrameCaptionButton
void DrawFrameCaptionButton(CDC *pDC, CRect rc, int nId, BOOL bSelected, BOOL bPressed, BOOL bActive)
This method is called to draw caption button.
CXTPFrameThemeOffice2007System::LoadParts
virtual void LoadParts(HZIP hZip, CXTPMarkupContext *pMarkupContext)
Loads markup parts from the specified ZIP source.
CXTPFrameThemeOffice2007System::~CXTPFrameThemeOffice2007System
virtual ~CXTPFrameThemeOffice2007System()
Destroys a CXTPFrameThemeOffice2007System object, handles cleanup and deallocation.
CXTPFrameThemeOffice2007System::DrawFrameCaptionButton
virtual void DrawFrameCaptionButton(CDC *pDC, CRect rc, int nId, BOOL bSelected, BOOL bPressed, BOOL bActive, CXTPRibbonBar *pRibbonBar)
This method is called to draw caption button.
CXTPFrameThemeOffice2007System::LoadParts
virtual void LoadParts(BOOL bReload=FALSE)
Loads markup parts.
CXTPFrameThemeOffice2007System::m_pMarkupContext
CXTPMarkupContext * m_pMarkupContext
Store pointer to CXTPMarkupContext object.
Definition XTPFrameThemeOffice2007System.h:175
CXTPFrameThemeOffice2007System::DrawCaptionBar
virtual void DrawCaptionBar(CDC *pDC, CRect rcCaptionBar, CWnd *pSite, BOOL bActive)
This method is called to draw the frame caption bar.
CXTPFrameThemeOffice2007System::CXTPFrameThemeOffice2007System
CXTPFrameThemeOffice2007System(CXTPPaintManager *pPaintManager)
Construction / Destruction.
CXTPFrameThemeOffice2007System::CalcFrameBorder
virtual CRect CalcFrameBorder(const CXTPCommandBarsFrameHook *pFrameHook) const
Calculates the frame border sizes.
CXTPFrameThemeOffice2007System::CalcFrameRegion
virtual HRGN CalcFrameRegion(CXTPCommandBarsFrameHook *pFrameHook, CSize sz) const
This method is called to create the window region.
CXTPFrameThemeOffice2007System::GetFrameBorder
virtual CXTPMarkupThemePart * GetFrameBorder(int nId, BOOL bActive)
This method is called to get the frame border part.
CXTPFrameThemeOffice2007System::RefreshMetrics
virtual void RefreshMetrics()
This method is called to refresh the visual metrics of the manager.
CXTPMarkupContext
CXTPMarkupContext is a standalone class used to provide common settings for Markup objects.
Definition XTPMarkupContext.h:128
CXTPMarkupThemePart
The CXTPMarkupThemePart class is used to create a theme part object used for rendering.
Definition XTPMarkupTheme.h:42
CXTPPaintManager
Paint manager of the command bars.
Definition XTPPaintManager.h:199
CXTPRibbonBar
CXTPRibbonBar is a CXTPMenuBar derived class.
Definition XTPRibbonBar.h:69
CXTPRibbonMarkupFrameTheme
The CXTPRibbonMarkupFrameTheme class is used to enable a system style theme for Command Bars.
Definition XTPRibbonMarkupFrameTheme.h:43
CXTPRibbonMarkupFrameTheme::m_bMarkupPartsLoaded
BOOL m_bMarkupPartsLoaded
TRUE if markup parts have been loaded.
Definition XTPRibbonMarkupFrameTheme.h:129


Toolkit Pro: XTPControlListBox.h Source File

  • Source
  • CommandBars
XTPControlListBox.h
Go to the documentation of this file.
1
23#if !defined(__XTPCONTROLLISTBOX_H__)
24# define __XTPCONTROLLISTBOX_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
60const UINT XTP_LBN_SELCHANGE = 0x1003;
61
89const UINT XTP_LBN_POPUP = 0x1004;
90
92class CXTPControlListBoxCtrl;
100class _XTP_EXT_CLASS CXTPControlListBox : public CXTPControl
101{
102public:
107 CXTPControlListBox();
108
113 virtual ~CXTPControlListBox();
114
115public:
121 void SetWidth(int nWidth);
122
129 void SetLinesMinMax(int nMin, int nMax);
130
137 CListBox* GetListCtrl() const;
138
144 void SetMultiplSel(BOOL bMultiplSel);
145
150 void OnEnabledChanged();
151
152protected:
158 virtual void SetRect(CRect rcControl);
159
167 virtual CSize GetSize(CDC* pDC);
168
174 virtual void SetParent(CXTPCommandBar* pParent);
175
181 virtual void Draw(CDC* pDC);
182
189 virtual BOOL IsFocused() const;
190
200 virtual BOOL OnHookKeyDown(UINT nChar, LPARAM lParam);
201
209 virtual BOOL OnSetSelected(int bSelected);
210
217 virtual void OnClick(BOOL bKeyboard = FALSE, CPoint pt = CPoint(0, 0));
218
269 virtual void OnCalcDynamicSize(DWORD dwMode);
270
277 virtual void Copy(CXTPControl* pControl, BOOL bRecursive = FALSE);
278
284 virtual void DoPropExchange(CXTPPropExchange* pPX);
285
286protected:
287 CXTPControlListBoxCtrl* m_pListBox;
288 int m_nListBoxLinesMin;
289 int m_nListBoxLinesMax;
290 BOOL m_bMultiplSel;
291 BOOL m_bMouseLocked;
294 DECLARE_XTP_CONTROL(CXTPControlListBox)
297 friend class CXTPControlListBoxCtrl;
298};
299
305class _XTP_EXT_CLASS CXTPControlStatic : public CXTPControl
306{
307public:
312 CXTPControlStatic();
313
314public:
320 void SetWidth(int nWidth);
321
322protected:
330 virtual CSize GetSize(CDC* pDC);
331
337 virtual void Draw(CDC* pDC);
338
345 virtual void Copy(CXTPControl* pControl, BOOL bRecursive = FALSE);
346
352 virtual void DoPropExchange(CXTPPropExchange* pPX);
353
354private:
355 DECLARE_XTP_CONTROL(CXTPControlStatic)
356};
357
359# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
360#endif // !defined(__XTPCONTROLLISTBOX_H__)
DECLARE_XTP_CONTROL
#define DECLARE_XTP_CONTROL(class_name)
This macro generates the C++ header code necessary for a CXTPControl-derived class that can be serial...
Definition XTPCommandBarsDefines.h:1169
XTP_LBN_POPUP
const UINT XTP_LBN_POPUP
The XTP_LBN_POPUP is sent to active view when the CXTPControlListBox is about to become visible.
Definition XTPControlListBox.h:89
XTP_LBN_SELCHANGE
const UINT XTP_LBN_SELCHANGE
The XTP_LBN_SELCHANGE is sent to active view when the selection of CXTPControlListBox is changed.
Definition XTPControlListBox.h:60
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCommandBar
CXTPCommandBar is a CWnd derived class.
Definition XTPCommandBar.h:66
CXTPControl
CXTPControl is a CXTPCmdTarget derived class.
Definition XTPControl.h:841
CXTPControlListBox
CXTPControlComboBox is a CXTPControl derived class.
Definition XTPControlListBox.h:101
CXTPControlListBox::DoPropExchange
virtual void DoPropExchange(CXTPPropExchange *pPX)
Either reads ths object from or writes this object to an archive.
CXTPControlListBox::OnEnabledChanged
void OnEnabledChanged()
This method is called when the control's enabled state is changed.
CXTPControlListBox::~CXTPControlListBox
virtual ~CXTPControlListBox()
Destroys a CXTPControlListBox object, handles cleanup and deallocation.
CXTPControlListBox::SetLinesMinMax
void SetLinesMinMax(int nMin, int nMax)
Call this member to set the total minimum and maximum lines.
CXTPControlListBox::m_nListBoxLinesMax
int m_nListBoxLinesMax
Maximum lines.
Definition XTPControlListBox.h:289
CXTPControlListBox::OnClick
virtual void OnClick(BOOL bKeyboard=FALSE, CPoint pt=CPoint(0, 0))
This method is called when the user clicks the control.
CXTPControlListBox::OnCalcDynamicSize
virtual void OnCalcDynamicSize(DWORD dwMode)
This method is called before recalculating the parent command bar size to calculate the dimensions of...
CXTPControlListBox::m_nListBoxLinesMin
int m_nListBoxLinesMin
Minimum lines.
Definition XTPControlListBox.h:288
CXTPControlListBox::m_bMouseLocked
BOOL m_bMouseLocked
TRUE to lock mouse events.
Definition XTPControlListBox.h:291
CXTPControlListBox::Draw
virtual void Draw(CDC *pDC)
This method is called to draw the control.
CXTPControlListBox::OnHookKeyDown
virtual BOOL OnHookKeyDown(UINT nChar, LPARAM lParam)
The framework calls this member function when a non-system key is pressed.
CXTPControlListBox::SetRect
virtual void SetRect(CRect rcControl)
Call this member to set the bounding rectangle of the control.
CXTPControlListBox::m_bMultiplSel
BOOL m_bMultiplSel
Multiple selection style.
Definition XTPControlListBox.h:290
CXTPControlListBox::OnSetSelected
virtual BOOL OnSetSelected(int bSelected)
This method is called when the control becomes selected.
CXTPControlListBox::GetListCtrl
CListBox * GetListCtrl() const
Call this member to retrieve a pointer to the list control.
CXTPControlListBox::CXTPControlListBox
CXTPControlListBox()
Constructs a CXTPControlListBox object.
CXTPControlListBox::GetSize
virtual CSize GetSize(CDC *pDC)
This method is called to determine the size of the control.
CXTPControlListBox::SetMultiplSel
void SetMultiplSel(BOOL bMultiplSel)
Call this member to set the multiple selection style of the control.
CXTPControlListBox::SetWidth
void SetWidth(int nWidth)
Call this member to set the width of the control.
CXTPControlListBox::IsFocused
virtual BOOL IsFocused() const
Call this member to get the focused state of the control.
CXTPControlListBox::SetParent
virtual void SetParent(CXTPCommandBar *pParent)
This method is called to assign a parent command bar object.
CXTPControlListBox::Copy
virtual void Copy(CXTPControl *pControl, BOOL bRecursive=FALSE)
This method is called to copy the control.
CXTPControlListBox::m_pListBox
CXTPControlListBoxCtrl * m_pListBox
List box control.
Definition XTPControlListBox.h:287
CXTPControlStatic
CXTPControlStatic is a CXTPControl derived class.
Definition XTPControlListBox.h:306
CXTPControlStatic::DoPropExchange
virtual void DoPropExchange(CXTPPropExchange *pPX)
Either reads this object from or writes this object to an archive.
CXTPControlStatic::Draw
virtual void Draw(CDC *pDC)
This method is called to draw the control.
CXTPControlStatic::CXTPControlStatic
CXTPControlStatic()
Constructs a CXTPControlStatic object.
CXTPControlStatic::GetSize
virtual CSize GetSize(CDC *pDC)
This method is called to determine the size of the control.
CXTPControlStatic::SetWidth
void SetWidth(int nWidth)
Call this member to set the width of the control.
CXTPControlStatic::Copy
virtual void Copy(CXTPControl *pControl, BOOL bRecursive=FALSE)
This method is called to copy the control.
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72


Toolkit Pro: Member List

CXTPScrollBarThemeNativeWindows11 Member List

This is the complete list of members for CXTPScrollBarThemeNativeWindows11, including all inherited members.

CalcHScroll(CXTPScrollBase *pScroll, XTPScrollMetricsH *pHScroll) | CXTPScrollBarPaintManager | protectedstatic
CalcVScroll(CXTPScrollBase *pScroll, XTPScrollMetricsV *pVScroll) | CXTPScrollBarPaintManager | protectedstatic
CXTPScrollBarPaintManager() | CXTPScrollBarPaintManager |
CXTPScrollBarThemeOffice2013() | CXTPScrollBarThemeOffice2013 |
DrawArrowGlyph(CDC *pDC, CRect rcArrow, XTPArrowGlyph glyph, BOOL bEnabled, COLORREF clrText=COLORREF_NULL) | CXTPScrollBarPaintManager | protected
DrawArrows(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics) | CXTPScrollBarThemeOffice2013 | protectedvirtual
DrawArrows(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics) | CXTPScrollBarThemeOffice2013 | protectedvirtual
DrawBackground(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics) | CXTPScrollBarThemeOffice2013 | protectedvirtual
DrawBackground(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics) | CXTPScrollBarThemeOffice2013 | protectedvirtual
DrawButtons(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics) | CXTPScrollBarThemeOffice2013 | protectedvirtual
DrawButtons(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics) | CXTPScrollBarThemeOffice2013 | protectedvirtual
DrawGripper(CDC *pDC, CXTPScrollBase *pScroll) | CXTPScrollBarThemeOffice2013 | protectedvirtual
DrawScrollBar(CDC *pDC, CXTPScrollBase *pGallery) | CXTPScrollBarThemeOffice2013 | protectedvirtual
DrawThumbButton(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics) | CXTPScrollBarThemeOffice2013 | protectedvirtual
DrawThumbButton(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics) | CXTPScrollBarThemeOffice2013 | protectedvirtual
DrawTracker(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics) | CXTPScrollBarPaintManager | protectedvirtual
DrawTracker(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics) | CXTPScrollBarPaintManager | protectedvirtual
GetScrollBarColors(XTP_SCROLLBARDRAWCOLORS &sbc, int nHitSelected, int nHitPressed, BOOL bEnabled) | CXTPScrollBarThemeOffice2013 | virtual
m_clrCurrent | CXTPScrollBarThemeOffice2013 | protected
m_clrDisabled | CXTPScrollBarThemeOffice2013 | protected
m_clrNormal | CXTPScrollBarThemeOffice2013 | protected
m_clrPressed | CXTPScrollBarThemeOffice2013 | protected
m_clrSelected | CXTPScrollBarThemeOffice2013 | protected
m_crBack | CXTPScrollBarPaintManager |
m_crBackHilite | CXTPScrollBarPaintManager |
m_crBackPushed | CXTPScrollBarPaintManager |
m_crBorder | CXTPScrollBarPaintManager |
m_crBorderHilite | CXTPScrollBarPaintManager |
m_cThumb | CXTPScrollBarPaintManager |
m_cxHScroll | CXTPScrollBarPaintManager |
m_cxVScroll | CXTPScrollBarPaintManager |
m_cyHScroll | CXTPScrollBarPaintManager |
m_cyVScroll | CXTPScrollBarPaintManager |
RefreshMetrics() | CXTPScrollBarThemeOffice2013 | protectedvirtual
~CXTPScrollBarThemeOffice2013() | CXTPScrollBarThemeOffice2013 | virtual


Toolkit Pro: XTPMarkupGrid.h Source File

  • Source
  • Markup
  • Controls
XTPMarkupGrid.h
Go to the documentation of this file.
1
23#if !defined(__XTPMARKUPGRID_H__)
24# define __XTPMARKUPGRID_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPMarkupBuilder;
34class CXTPMarkupUIElement;
35class CXTPMarkupDefinitionBase;
36class CXTPMarkupColumnDefinitionCollection;
37class CXTPMarkupRowDefinitionCollection;
38
44class _XTP_EXT_CLASS CXTPMarkupDefinitionCollection : public CXTPMarkupCollection
45{
47 DECLARE_MARKUPCLASS(CXTPMarkupDefinitionCollection);
49public:
54 CXTPMarkupDefinitionCollection();
55
56public:
64 CXTPMarkupDefinitionBase* GetItem(int nIndex) const;
65
67public:
68 DECLARE_DISPATCH_MAP()
69# ifdef _XTP_ACTIVEX
70 DECLARE_INTERFACE_MAP()
71 DECLARE_OLETYPELIB_EX(CXTPMarkupDefinitionCollection);
72# endif
73 DECLARE_ENUM_VARIANT(CXTPMarkupDefinitionCollection)
74
75 long OleGetItemCount();
76 LPDISPATCH OleGetItem(long nIndex);
77 void OleAdd(LPDISPATCH lpElementDisp);
78 void OleInsert(long Index, LPDISPATCH lpElementDisp);
79
81};
82
88class _XTP_EXT_CLASS CXTPMarkupGrid : public CXTPMarkupPanel
89{
90private:
91 enum LayoutTimeSizeType
92 {
93 sizeTypeNone = 0,
94 sizeTypePixel = 1,
95 sizeTypeAuto = 2,
96 sizeTypeStar = 4
97 };
98
99private:
100 struct CELLCACHE
101 {
102 int nColumnIndex;
103 int nRowIndex;
104 int nColumnSpan;
105 int nRowSpan;
106 int nSizeTypeU;
107 int nSizeTypeV;
108 int nNext;
109
110 public:
111 BOOL IsStarU() const;
112 BOOL IsAutoU() const;
113 BOOL IsStarV() const;
114 BOOL IsAutoV() const;
115 };
116
117 struct SPANKEY
118 {
119 int nCount;
120 int nStart;
121 BOOL bU;
122 int nValue;
123 };
124
125private:
127 DECLARE_MARKUPCLASS(CXTPMarkupGrid)
129protected:
134 CXTPMarkupGrid();
135
140 virtual ~CXTPMarkupGrid();
141
142public:
149 CXTPMarkupColumnDefinitionCollection* GetColumnDefinitions() const;
150
157 CXTPMarkupRowDefinitionCollection* GetRowDefinitions() const;
158
166 static void AFX_CDECL SetColumn(CXTPMarkupUIElement* pElement, int nColumn);
167
175 static int AFX_CDECL GetColumn(CXTPMarkupUIElement* pElement);
176
184 static void AFX_CDECL SetRow(CXTPMarkupUIElement* pElement, int nRow);
185
193 static int AFX_CDECL GetRow(CXTPMarkupUIElement* pElement);
194
202 static void AFX_CDECL SetColumnSpan(CXTPMarkupUIElement* pElement, int nColumnSpan);
203
211 static int AFX_CDECL GetColumnSpan(CXTPMarkupUIElement* pElement);
212
220 static void AFX_CDECL SetRowSpan(CXTPMarkupUIElement* pElement, int nRowSpan);
221
229 static int AFX_CDECL GetRowSpan(CXTPMarkupUIElement* pElement);
230
232 // Implementation
233
234protected:
235 CSize MeasureOverride(CXTPMarkupDrawingContext* pDC, CSize availableSize);
236 CSize ArrangeOverride(CSize arrangeSize);
237 void SetPropertyObject(CXTPMarkupBuilder* pBuilder, CXTPMarkupDependencyProperty* pProperty,
238 CXTPMarkupObject* pValue);
239
240private:
241 void ValidateDefinitionsLayout(CXTPMarkupDefinitionCollection* pDefinitions,
242 BOOL bTreatStarAsAuto);
243 void ValidateCells();
244 void ValidateDefinitions();
245 int GetLengthTypeForRange(CXTPMarkupDefinitionCollection* pDefinitions, int start, int count);
246 void MeasureCellsGroup(CXTPMarkupDrawingContext* pDC, int cellsHead, CSize referenceSize,
247 BOOL ignoreDesiredSizeU, BOOL forceInfinityV);
248 void MeasureCell(CXTPMarkupDrawingContext* pDC, int cell, BOOL forceInfinityV);
249 int GetMeasureSizeForRange(CXTPMarkupDefinitionCollection* pDefinitions, int start, int count);
250 int CalculateDesiredSize(CXTPMarkupDefinitionCollection* pDefinitions);
251 void ResolveStar(CXTPMarkupDefinitionCollection* pDefinitions, double availableSize);
252 int GetFinalSizeForRange(CXTPMarkupDefinitionCollection* pDefinitions, int start, int count);
253 void SetFinalSize(CXTPMarkupDefinitionCollection* pDefinitions, int finalSize);
254 void EnsureMinSizeInDefinitionRange(CXTPMarkupDefinitionCollection* definitions, int start,
255 int count, int requestedSize);
256
257 static int AFX_CDECL DistributionOrderComparer(const void* arg1, const void* arg2);
258 static int AFX_CDECL StarDistributionOrderComparer(const void* arg1, const void* arg2);
259 static int AFX_CDECL SpanMaxDistributionOrderComparer(const void* arg1, const void* arg2);
260 static int AFX_CDECL SpanPreferredDistributionOrderComparer(const void* arg1, const void* arg2);
261
262 static void AFX_CDECL OnCellAttachedPropertyChanged(CXTPMarkupObject* d,
263 CXTPMarkupPropertyChangedEventArgs* e);
264
265protected:
266 CXTPMarkupRowDefinitionCollection* m_pRowDefinitions;
267 CXTPMarkupColumnDefinitionCollection* m_pColumnDefinitions;
268
269public:
270 static CXTPMarkupDependencyProperty* m_pColumnDefinitionsProperty;
271 static CXTPMarkupDependencyProperty* m_pRowDefinitionsProperty;
272 static CXTPMarkupDependencyProperty* m_pRowProperty;
273 static CXTPMarkupDependencyProperty* m_pColumnProperty;
274
275 static CXTPMarkupDependencyProperty* m_pColumnSpanProperty;
276 static CXTPMarkupDependencyProperty* m_pRowSpanProperty;
277
278private:
279 CELLCACHE* m_pCellCachesCollection;
280 int m_nCellGroup[4];
281 BOOL m_bHasStarCellsU;
282 BOOL m_bHasStarCellsV;
283 BOOL m_bHasGroup2CellsInAutoRows;
284
285 CXTPMarkupDefinitionCollection* m_pDefinitionsU;
286 CXTPMarkupDefinitionCollection* m_pDefinitionsV;
287
288 friend struct CELLCACHE;
289 friend class CXTPMarkupDefinitionBase;
290
294public:
295 DECLARE_DISPATCH_MAP()
296# ifdef _XTP_ACTIVEX
297 DECLARE_INTERFACE_MAP()
298 DECLARE_OLETYPELIB_EX(CXTPMarkupGrid);
299# endif
300
301 afx_msg int OleGetRow(LPDISPATCH lpElementDisp);
302 afx_msg void OleSetRow(LPDISPATCH lpElementDisp, int nValue);
303 afx_msg int OleGetRowSpan(LPDISPATCH lpElementDisp);
304 afx_msg void OleSetRowSpan(LPDISPATCH lpElementDisp, int nValue);
305 afx_msg int OleGetColumn(LPDISPATCH lpElementDisp);
306 afx_msg void OleSetColumn(LPDISPATCH lpElementDisp, int nValue);
307 afx_msg int OleGetColumnSpan(LPDISPATCH lpElementDisp);
308 afx_msg void OleSetColumnSpan(LPDISPATCH lpElementDisp, int nValue);
309 afx_msg LPDISPATCH OleGetColumnDefinitions();
310 afx_msg LPDISPATCH OleGetRowDefinitions();
312};
313
314AFX_INLINE CXTPMarkupColumnDefinitionCollection* CXTPMarkupGrid::GetColumnDefinitions() const
315{
316 return m_pColumnDefinitions;
317}
318AFX_INLINE CXTPMarkupRowDefinitionCollection* CXTPMarkupGrid::GetRowDefinitions() const
319{
320 return m_pRowDefinitions;
321}
322AFX_INLINE CXTPMarkupDefinitionBase* CXTPMarkupDefinitionCollection::GetItem(int nIndex) const
323{
324 return nIndex >= 0 && nIndex < m_arrItems.GetSize()
325 ? (CXTPMarkupDefinitionBase*)m_arrItems[nIndex]
326 : NULL;
327}
328
329# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
331#endif // !defined(__XTPMARKUPGRID_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPMarkupColumnDefinitionCollection
CXTPMarkupColumnDefinitionCollection is a CXTPMarkupDefinitionCollection derived class.
Definition XTPMarkupColumnDefinitionCollection.h:39
CXTPMarkupDefinitionBase
CXTPMarkupDefinitionBase is the base class for CXTPMarkupColumnDefinition and CXTPMarkupRowDefinition...
Definition XTPMarkupDefinitionBase.h:45
CXTPMarkupDefinitionCollection
CXTPMarkupDefinitionCollection is the base class for CXTPMarkupDefinitionCollection and CXTPMarkupDef...
Definition XTPMarkupGrid.h:45
CXTPMarkupDefinitionCollection::GetItem
CXTPMarkupDefinitionBase * GetItem(int nIndex) const
Retrieves a CXTPMarkupDefinitionBase object by its index.
Definition XTPMarkupGrid.h:322
CXTPMarkupDefinitionCollection::CXTPMarkupDefinitionCollection
CXTPMarkupDefinitionCollection()
Constructs a CXTPMarkupDefinitionCollection object.
CXTPMarkupGrid
CXTPMarkupGrid is a CXTPMarkupPanel derived class.
Definition XTPMarkupGrid.h:89
CXTPMarkupGrid::GetRowDefinitions
CXTPMarkupRowDefinitionCollection * GetRowDefinitions() const
Retrieves the collection of constraints and definitions for grid rows.
Definition XTPMarkupGrid.h:318
CXTPMarkupGrid::~CXTPMarkupGrid
virtual ~CXTPMarkupGrid()
Destroys a CXTPMarkupGrid object, handles cleanup and deallocation.
CXTPMarkupGrid::GetColumnDefinitions
CXTPMarkupColumnDefinitionCollection * GetColumnDefinitions() const
Retrieves the collection of constraints and definitions for grid columns.
Definition XTPMarkupGrid.h:314
CXTPMarkupGrid::SetRow
static void AFX_CDECL SetRow(CXTPMarkupUIElement *pElement, int nRow)
Sets the row index for a grid child element.
CXTPMarkupGrid::GetRow
static int AFX_CDECL GetRow(CXTPMarkupUIElement *pElement)
Retrieves the row index of a grid child element.
CXTPMarkupGrid::GetRowSpan
static int AFX_CDECL GetRowSpan(CXTPMarkupUIElement *pElement)
Gets the total number of rows that child content spans within a grid.
CXTPMarkupGrid::SetRowSpan
static void AFX_CDECL SetRowSpan(CXTPMarkupUIElement *pElement, int nRowSpan)
Sets the total number of rows that child content spans within a grid.
CXTPMarkupGrid::GetColumn
static int AFX_CDECL GetColumn(CXTPMarkupUIElement *pElement)
Retrieves the column index of a grid child element.
CXTPMarkupGrid::SetColumnSpan
static void AFX_CDECL SetColumnSpan(CXTPMarkupUIElement *pElement, int nColumnSpan)
Sets the total number of columns that child content spans within a grid.
CXTPMarkupGrid::SetColumn
static void AFX_CDECL SetColumn(CXTPMarkupUIElement *pElement, int nColumn)
Sets a column index for a grid child element.
CXTPMarkupGrid::CXTPMarkupGrid
CXTPMarkupGrid()
Constructs a CXTPMarkupGrid object.
CXTPMarkupGrid::GetColumnSpan
static int AFX_CDECL GetColumnSpan(CXTPMarkupUIElement *pElement)
Gets the total number of columns that child content spans within a grid.
CXTPMarkupPanel
CXTPMarkupPanel is a CXTPMarkupFrameworkElement derived class.
Definition XTPMarkupPanel.h:48
CXTPMarkupRowDefinitionCollection
CXTPMarkupRowDefinitionCollection is a CXTPMarkupDefinitionCollection derived class.
Definition XTPMarkupRowDefinitionCollection.h:39
CXTPMarkupUIElement
Base class for XML Markup core level implementations.
Definition XTPMarkupUIElement.h:43


Toolkit Pro: Member List

CXTPChart3dFunnelSeriesLabelView Member List

This is the complete list of members for CXTPChart3dFunnelSeriesLabelView, including all inherited members.

AddChildView(CXTPChartElementView *pChildView) | CXTPChartElementView |
CreateConnectorDeviceCommand(CXTPChartDeviceContext *pDC) | CXTPChart3dFunnelSeriesLabelView | virtual
CreateDeviceCommand(CXTPChartDeviceContext *pDC) | CXTPChart3dFunnelSeriesLabelView | virtual
CreateTranspositionDeviceCommand(CXTPChartDeviceContext *pDC) | CXTPChart3dFunnelSeriesLabelView | virtual
CXTPChart3dFunnelSeriesLabelView(CXTPChartSeriesLabel *pLabel, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView) | CXTPChart3dFunnelSeriesLabelView |
CXTPChartElementView(CXTPChartElementView *pParentView) | CXTPChartElementView |
CXTPChartElementView(CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartElementView |
CXTPChartElementView(CXTPChartContainer *pContainer) | CXTPChartElementView |
CXTPChartFunnelSeriesLabelViewBase(CXTPChartSeriesLabel *pLabel, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView) | CXTPChartFunnelSeriesLabelViewBase | protected
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
GetAt(int nIndex) const | CXTPChartElementView |
GetBounds() const | CXTPChartElementView |
GetBounds(BOOL bIncludingChildren) const | CXTPChartElementView |
GetChildren() | CXTPChartElementView |
GetConnectorBendPoint() const | CXTPChart3dFunnelSeriesLabelView |
GetConnectorEndPoint() const | CXTPChart3dFunnelSeriesLabelView |
GetConnectorStartPoint() const | CXTPChart3dFunnelSeriesLabelView |
GetCount() const | CXTPChartElementView |
GetLabelAnchorOrigin() const | CXTPChart3dFunnelSeriesLabelView |
GetLabelAnchorPoint() const | CXTPChart3dFunnelSeriesLabelView |
GetParentView() const | CXTPChartElementView |
GetPosition() const | CXTPChartFunnelSeriesLabelViewBase |
Is3D() const | CXTPChartObject |
IsConnectorVisible() const | CXTPChart3dFunnelSeriesLabelView |
IsLeftDirected() const | CXTPChart3dFunnelSeriesLabelView |
IsRightDirected() const | CXTPChart3dFunnelSeriesLabelView |
m_arrChildren | CXTPChartElementView | protected
m_bConnectorVisible | CXTPChart3dFunnelSeriesLabelView | protected
m_bLeftDirected | CXTPChart3dFunnelSeriesLabelView | protected
m_p3dPointView | CXTPChart3dFunnelSeriesLabelView | protected
m_pContainer | CXTPChartElementView | protected
m_pParentView | CXTPChartElementView | protected
m_ptBend | CXTPChart3dFunnelSeriesLabelView | protected
m_ptEnd | CXTPChart3dFunnelSeriesLabelView | protected
m_ptLabelAnchor | CXTPChart3dFunnelSeriesLabelView | protected
m_ptLabelAnchorOrigin | CXTPChart3dFunnelSeriesLabelView | protected
m_ptStart | CXTPChart3dFunnelSeriesLabelView | protected
m_rcBounds | CXTPChartElementView | protected
SetConnectorBendPoint(const CXTPPoint3d &point) | CXTPChart3dFunnelSeriesLabelView |
SetConnectorEndPoint(const CXTPPoint3d &point) | CXTPChart3dFunnelSeriesLabelView |
SetConnectorStartPoint(const CXTPPoint3d &point) | CXTPChart3dFunnelSeriesLabelView |
SetConnectorVisible(BOOL bVisible=TRUE) | CXTPChart3dFunnelSeriesLabelView |
SetLabelAnchorOrigin(CPoint ptAnchorOrigin) | CXTPChart3dFunnelSeriesLabelView |
SetLabelAnchorPoint(CPoint ptAnchor) | CXTPChart3dFunnelSeriesLabelView |
SetLeftDirected() | CXTPChart3dFunnelSeriesLabelView |
SetRightDirected() | CXTPChart3dFunnelSeriesLabelView |
~CXTPChart3dFunnelSeriesLabelView() | CXTPChart3dFunnelSeriesLabelView |
~CXTPChartElementView() | CXTPChartElementView | protectedvirtual


Toolkit Pro: Member List

CXTPChartTranslateDeviceCommand Member List

This is the complete list of members for CXTPChartTranslateDeviceCommand, including all inherited members.

AddChildCommand(CXTPChartDeviceCommand *pCommand) | CXTPChartDeviceCommand |
AfterExecute(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
ApplySeriesStyle(CXTPChartSeriesStyle *pStyle) | CXTPChartDeviceCommand | virtual
BeforeExecute(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
BindView(CXTPChartElementView *pView) | CXTPChartDeviceCommand |
Commit() | CXTPChartDeviceCommand |
CXTPChartDeviceCommand() | CXTPChartDeviceCommand |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartTranslateDeviceCommand(double dx, double dy) | CXTPChartTranslateDeviceCommand |
CXTPObservable() | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | protected
Execute(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
ExecuteOverride(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
GetBoundView() const | CXTPChartDeviceCommand |
GetChildCommand(int nIndex) const | CXTPChartDeviceCommand |
GetChildCommandCount() const | CXTPChartDeviceCommand |
GetCurrentDC() const | CXTPChartDeviceCommand |
GetPassNumber() const | CXTPChartDeviceCommand |
HitTest(CPoint point, CXTPChartElement *pParent) const | CXTPChartDeviceCommand | virtual
Is3D() const | CXTPChartObject |
IsCommitted() const | CXTPChartDeviceCommand |
IsEnabled() const | CXTPChartDeviceCommand | virtual
m_arrChildren | CXTPChartDeviceCommand | protected
m_dx | CXTPChartTranslateDeviceCommand | protected
m_dy | CXTPChartTranslateDeviceCommand | protected
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Prepare(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
PrepareOverride(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
SetEnabled(BOOL bEnabled=TRUE) | CXTPChartDeviceCommand |
Subscribe(CXTPChartDeviceCommandEvents *pObserver, CXTPSubscriptionList< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > *pSubcriptionList=NULL) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > |
Unsubscribe(CXTPChartDeviceCommandEvents *pObserver) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > |
~CXTPChartDeviceCommand() | CXTPChartDeviceCommand | virtual
~CXTPObservable() | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | protected


Toolkit Pro: Member List

CXTPChartBubbleSeriesStyle Member List

This is the complete list of members for CXTPChartBubbleSeriesStyle, including all inherited members.

ApplyTo(CXTPChartDeviceCommand *pCommand) | CXTPChartSeriesStyle | virtual
CorrectAxisSideMargins(CXTPChartAxis *pAxis, double nMinValue, double nMaxValue, double &nCorrection) | CXTPChartBubbleSeriesStyle | protectedvirtual
CreateDiagram() | CXTPChartDiagram2DSeriesStyle | virtual
CreateView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView) | CXTPChartBubbleSeriesStyle | protectedvirtual
CXTPChartBubbleSeriesStyle() | CXTPChartBubbleSeriesStyle |
CXTPChartDiagram2DSeriesStyle() | CXTPChartDiagram2DSeriesStyle |
CXTPChartElement() | CXTPChartElement |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartPointSeriesStyle() | CXTPChartPointSeriesStyle |
CXTPChartSeriesStyle() | CXTPChartSeriesStyle |
DoPropExchange(CXTPPropExchange *pPX) | CXTPChartBubbleSeriesStyle | virtual
Enable3dEdgeSmoothing(BOOL bEnable=TRUE) | CXTPChartSeriesStyle | virtual
Get3dRotation() const | CXTPChartSeriesStyle | virtual
GetAppearance() const | CXTPChartElement |
GetColor() const | CXTPChartSeriesStyle | virtual
GetContent() const | CXTPChartElement |
GetErrorBar() const | CXTPChartSeriesStyle | virtual
GetLabel() const | CXTPChartSeriesStyle | virtual
GetMarker() const | CXTPChartPointSeriesStyle |
GetMaxSize() const | CXTPChartBubbleSeriesStyle |
GetMinSize() const | CXTPChartBubbleSeriesStyle |
GetOwner() const | CXTPChartElement |
GetSeriesPointValueIndex() const | CXTPChartBubbleSeriesStyle | virtual
GetStyleAppearance() const | CXTPChartSeriesStyle | virtual
GetTransparency() const | CXTPChartSeriesStyle | virtual
Is3D() const | CXTPChartObject |
Is3dEdgeSmoothingEnabled() const | CXTPChartSeriesStyle | virtual
IsColorEach() const | CXTPChartSeriesStyle | virtual
IsStyleDiagram(CXTPChartDiagram *pDiagram) const | CXTPChartDiagram2DSeriesStyle | virtual
m_bColorEach | CXTPChartSeriesStyle | protected
m_bSmooth3dEdges | CXTPChartSeriesStyle | protected
m_clrColor | CXTPChartSeriesStyle | protected
m_nAxisIndexX | CXTPChartDiagram2DSeriesStyle | protected
m_nAxisIndexY | CXTPChartDiagram2DSeriesStyle | protected
m_nTransparency | CXTPChartSeriesStyle | protected
m_pErrorBar | CXTPChartSeriesStyle | protected
m_pLabel | CXTPChartSeriesStyle | protected
m_Rotation3d | CXTPChartSeriesStyle | protected
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartElement | virtual
Release() | CXTPChartElement | virtual
Set3dRotation(const CXTPChart3dRotation &rotation) | CXTPChartSeriesStyle | virtual
Set3dRotation(double dYaw, double dPitch, double dRoll) | CXTPChartSeriesStyle | virtual
SetColor(CXTPChartColor clr) | CXTPChartSeriesStyle | virtual
SetColorEach(BOOL bColorEach) | CXTPChartSeriesStyle | virtual
SetErrorBar(CXTPChartErrorBar *pErrorBar) | CXTPChartSeriesStyle | virtual
SetLabel(CXTPChartSeriesLabel *pLabel) | CXTPChartSeriesStyle | virtual
SetMaxSize(double dMinSize) | CXTPChartBubbleSeriesStyle |
SetMinSize(double dMinSize) | CXTPChartBubbleSeriesStyle |
SetTransparency(int nTransparency) | CXTPChartSeriesStyle | virtual
~CXTPChartBubbleSeriesStyle() | CXTPChartBubbleSeriesStyle | virtual
~CXTPChartDiagram2DSeriesStyle() | CXTPChartDiagram2DSeriesStyle | virtual
~CXTPChartElement() | CXTPChartElement | virtual
~CXTPChartPointSeriesStyle() | CXTPChartPointSeriesStyle | virtual
~CXTPChartSeriesStyle() | CXTPChartSeriesStyle | virtual


Toolkit Pro: XTPGridNavigator.h Source File

  • Source
  • GridControl
XTPGridNavigator.h
Go to the documentation of this file.
1
23#if !defined(__XTPGRIDNAVIGATOR_H__)
24# define __XTPGRIDNAVIGATOR_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPGridControl;
34class CXTPGridRow;
35class CXTPGridHeader;
36class CXTPGridColumn;
37
44class _XTP_EXT_CLASS CXTPGridNavigator : public CXTPCmdTarget
45{
46 friend class CXTPGridControl;
47
48public:
56 CXTPGridNavigator(CXTPGridControl* pGridControl);
57
62 virtual ~CXTPGridNavigator();
63
68 virtual void BeginEdit();
69
80 virtual void MoveDown(BOOL bShiftKey = FALSE, BOOL bControlKey = FALSE);
81
92 virtual void MoveDownStep(BOOL bShiftKey = FALSE, BOOL bControlKey = FALSE);
93
104 virtual void MoveUp(BOOL bShiftKey = FALSE, BOOL bControlKey = FALSE);
105
116 virtual void MoveUpStep(BOOL bShiftKey = FALSE, BOOL bControlKey = FALSE);
117
129 virtual void MovePageDown(BOOL bShiftKey = FALSE, BOOL bControlKey = FALSE);
130
142 virtual void MovePageUp(BOOL bShiftKey = FALSE, BOOL bControlKey = FALSE);
143
154 void MoveFirstRow(BOOL bShiftKey = FALSE, BOOL bControlKey = FALSE);
155
166 void MoveLastRow(BOOL bShiftKey = FALSE, BOOL bControlKey = FALSE);
167
179 void MoveToRow(int nRowIndex, BOOL bShiftKey = FALSE, BOOL bControlKey = FALSE);
180
187 void MoveFirstColumn();
188
195 void MoveLastColumn();
196
207 void MoveLeft(BOOL bShiftKey = FALSE, BOOL bControlKey = FALSE);
208
219 void MoveRight(BOOL bShiftKey = FALSE, BOOL bControlKey = FALSE);
220
235 void MoveToColumn(int nColumnIndex, BOOL bClearIfNonFocusable = FALSE);
236
245 void SetCurrentFocusInHeadersRows(BOOL bCurrentFocusInHeadersRows);
246
255 void SetCurrentFocusInFootersRows(BOOL bCurrentFocusInFootersRows);
256
266 BOOL GetCurrentFocusInHeadersRows();
267
277 BOOL GetCurrentFocusInFootersRows();
278
279protected:
289 virtual void MoveLeftRight(BOOL bBack, BOOL bShiftKey = FALSE, BOOL bControlKey = FALSE);
290
302 void MoveFirstVisibleRow(XTPGridRowType RowType);
303
315 void MoveLastVisibleRow(XTPGridRowType RowType);
316
326 int CheckDeadEnd(BOOL bMoveDown);
327
328protected:
329 CXTPGridControl* m_pGridControl;
331# ifdef _XTP_ACTIVEX
333 DECLARE_DISPATCH_MAP()
334 DECLARE_INTERFACE_MAP()
335
336 DECLARE_OLETYPELIB_EX(CXTPGridNavigator);
337
338# define DECLARE_OLE_MOVE(Direction) \
339 void OleMove##Direction(const VARIANT& oleSelectBlock, \
340 const VARIANT& oleIgnoreSelection);
341
342 DECLARE_OLE_MOVE(Up)
343 DECLARE_OLE_MOVE(Down)
344 DECLARE_OLE_MOVE(PageUp)
345 DECLARE_OLE_MOVE(PageDown)
346 DECLARE_OLE_MOVE(FirstRow)
347 DECLARE_OLE_MOVE(LastRow)
348 DECLARE_OLE_MOVE(Left)
349 DECLARE_OLE_MOVE(Right)
350
351 void OleMoveToColumn(int nColumnIndex, const VARIANT& oleClearIfNonFocusable);
352 void OleMoveToRow(int nRowIndex, const VARIANT& oleSelectBlock,
353 const VARIANT& oleIgnoreSelection);
354
355 void OleMoveFirstVisibleRow();
356 void OleMoveLastVisibleRow();
357
359# endif
360};
361
368class _XTP_EXT_CLASS CXTPGridIconNavigator : public CXTPGridNavigator
369{
370 friend class CXTPGridControl;
371
372public:
380 CXTPGridIconNavigator(CXTPGridControl* pGridControl);
381
386 virtual ~CXTPGridIconNavigator();
387
388public:
389 virtual void BeginEdit();
390
391 virtual void MoveDown(BOOL bShiftKey = FALSE, BOOL bControlKey = FALSE);
392 virtual void MoveUp(BOOL bShiftKey = FALSE, BOOL bControlKey = FALSE);
393
394 virtual void MoveDownStep(BOOL bShiftKey = FALSE, BOOL bControlKey = FALSE);
395 virtual void MoveUpStep(BOOL bShiftKey = FALSE, BOOL bControlKey = FALSE);
396
397 virtual void MovePageDown(BOOL bShiftKey, BOOL bControlKey);
398 virtual void MovePageUp(BOOL bShiftKey, BOOL bControlKey);
399
400 virtual void MoveLeftRight(BOOL bBack, BOOL bShiftKey = FALSE, BOOL bControlKey = FALSE);
401};
403# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
404#endif //#if !defined(__XTPGRIDNAVIGATOR_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPGridRowType
XTPGridRowType
This enum defines body, header, and footer rows.
Definition XTPGridDefines.h:94
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPGridColumn
Represents a grid column item with its properties and operations.
Definition XTPGridColumn.h:107
CXTPGridControl
The CXTPGridControl class provides an implementation of the Grid control.
Definition XTPGridControl.h:479
CXTPGridHeader
A grid header is a part of the grid window positioned above columns of text or numbers.
Definition XTPGridHeader.h:173
CXTPGridIconNavigator
Utility class, handles Grid control icon navigation.
Definition XTPGridNavigator.h:369
CXTPGridIconNavigator::MovePageUp
virtual void MovePageUp(BOOL bShiftKey, BOOL bControlKey)
Moves the focused row up by one page.
CXTPGridIconNavigator::MoveUp
virtual void MoveUp(BOOL bShiftKey=FALSE, BOOL bControlKey=FALSE)
Moves the focused row up by one.
CXTPGridIconNavigator::BeginEdit
virtual void BeginEdit()
Call this method to begin editing the currently focused item.
CXTPGridIconNavigator::MovePageDown
virtual void MovePageDown(BOOL bShiftKey, BOOL bControlKey)
Moves the focused row down by one page.
CXTPGridIconNavigator::~CXTPGridIconNavigator
virtual ~CXTPGridIconNavigator()
Default navigator destructor, handles member items deallocation.
CXTPGridIconNavigator::CXTPGridIconNavigator
CXTPGridIconNavigator(CXTPGridControl *pGridControl)
Default navigator constructor, handles properties initialization.
CXTPGridIconNavigator::MoveUpStep
virtual void MoveUpStep(BOOL bShiftKey=FALSE, BOOL bControlKey=FALSE)
Moves the focused row up by one.
CXTPGridIconNavigator::MoveDown
virtual void MoveDown(BOOL bShiftKey=FALSE, BOOL bControlKey=FALSE)
Moves the focused row down by one.
CXTPGridIconNavigator::MoveDownStep
virtual void MoveDownStep(BOOL bShiftKey=FALSE, BOOL bControlKey=FALSE)
Moves the focused row down by one.
CXTPGridIconNavigator::MoveLeftRight
virtual void MoveLeftRight(BOOL bBack, BOOL bShiftKey=FALSE, BOOL bControlKey=FALSE)
Moves the focused column left/right.
CXTPGridNavigator
Utility class, handles Grid control item navigation.
Definition XTPGridNavigator.h:45
CXTPGridNavigator::SetCurrentFocusInHeadersRows
void SetCurrentFocusInHeadersRows(BOOL bCurrentFocusInHeadersRows)
Sets the current focus (selected row) to header rows.
CXTPGridNavigator::MovePageDown
virtual void MovePageDown(BOOL bShiftKey=FALSE, BOOL bControlKey=FALSE)
Moves the focused row down by one page.
CXTPGridNavigator::MoveUp
virtual void MoveUp(BOOL bShiftKey=FALSE, BOOL bControlKey=FALSE)
Moves the focused row up by one.
CXTPGridNavigator::MoveLastRow
void MoveLastRow(BOOL bShiftKey=FALSE, BOOL bControlKey=FALSE)
Moves the focused row to the end of the grid view.
CXTPGridNavigator::m_pGridControl
CXTPGridControl * m_pGridControl
Associated Grid control.
Definition XTPGridNavigator.h:329
CXTPGridNavigator::GetCurrentFocusInHeadersRows
BOOL GetCurrentFocusInHeadersRows()
Determines if the current focus (selected row) belongs to header rows.
CXTPGridNavigator::MoveToRow
void MoveToRow(int nRowIndex, BOOL bShiftKey=FALSE, BOOL bControlKey=FALSE)
Moves the focused row to a specified row index.
CXTPGridNavigator::GetCurrentFocusInFootersRows
BOOL GetCurrentFocusInFootersRows()
Determines if the current focus (selected row) belongs to footer rows.
CXTPGridNavigator::BeginEdit
virtual void BeginEdit()
Call this method to begin editing the currently focused item.
CXTPGridNavigator::MoveLeft
void MoveLeft(BOOL bShiftKey=FALSE, BOOL bControlKey=FALSE)
Moves the focused column left by one.
CXTPGridNavigator::MoveToColumn
void MoveToColumn(int nColumnIndex, BOOL bClearIfNonFocusable=FALSE)
Moves the focused column to a specified column index.
CXTPGridNavigator::CheckDeadEnd
int CheckDeadEnd(BOOL bMoveDown)
Checks for a dead end row by moving down/up.
CXTPGridNavigator::~CXTPGridNavigator
virtual ~CXTPGridNavigator()
Default navigator destructor, handles member items deallocation.
CXTPGridNavigator::MovePageUp
virtual void MovePageUp(BOOL bShiftKey=FALSE, BOOL bControlKey=FALSE)
Moves the focused row up by one page.
CXTPGridNavigator::MoveLastColumn
void MoveLastColumn()
Moves the focused column to the end of the currently selected row.
CXTPGridNavigator::CXTPGridNavigator
CXTPGridNavigator(CXTPGridControl *pGridControl)
Default navigator constructor, handles properties initialization.
CXTPGridNavigator::MoveUpStep
virtual void MoveUpStep(BOOL bShiftKey=FALSE, BOOL bControlKey=FALSE)
Moves the focused row up by one.
CXTPGridNavigator::MoveFirstVisibleRow
void MoveFirstVisibleRow(XTPGridRowType RowType)
Moves the focused row to the first visible row of a target section: body, header, or footer.
CXTPGridNavigator::MoveLastVisibleRow
void MoveLastVisibleRow(XTPGridRowType RowType)
Moves the focused row to the last visible row of a target section: body, header, or footer.
CXTPGridNavigator::MoveDown
virtual void MoveDown(BOOL bShiftKey=FALSE, BOOL bControlKey=FALSE)
Moves the focused row down by one.
CXTPGridNavigator::MoveDownStep
virtual void MoveDownStep(BOOL bShiftKey=FALSE, BOOL bControlKey=FALSE)
Moves the focused row down by one.
CXTPGridNavigator::MoveFirstColumn
void MoveFirstColumn()
Moves the focused column to the beginning of the currently selected row.
CXTPGridNavigator::MoveFirstRow
void MoveFirstRow(BOOL bShiftKey=FALSE, BOOL bControlKey=FALSE)
Moves the focused row to the beginning of the grid view.
CXTPGridNavigator::MoveRight
void MoveRight(BOOL bShiftKey=FALSE, BOOL bControlKey=FALSE)
Moves the focused column right by one.
CXTPGridNavigator::SetCurrentFocusInFootersRows
void SetCurrentFocusInFootersRows(BOOL bCurrentFocusInFootersRows)
Sets the current focus (selected row) to footer rows.
CXTPGridNavigator::MoveLeftRight
virtual void MoveLeftRight(BOOL bBack, BOOL bShiftKey=FALSE, BOOL bControlKey=FALSE)
Moves the focused column left/right.
CXTPGridRow
CXTPGridRow class represents a row of the Grid control window.
Definition XTPGridRow.h:71


Toolkit Pro: XTPMarkupTransformationMatrix.h Source File

  • Source
  • Markup
  • Transform
XTPMarkupTransformationMatrix.h
Go to the documentation of this file.
1
23#if !defined(__XTPMARKUPTRANSFORMATIONMATRIX_H__)
24# define __XTPMARKUPTRANSFORMATIONMATRIX_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPMarkupTransformationMatrix;
34
39class _XTP_EXT_CLASS CXTPMarkupTransformationMatrix : public CObject
40{
42 DECLARE_DYNAMIC(CXTPMarkupTransformationMatrix);
44protected:
49 CXTPMarkupTransformationMatrix();
50
51public:
56 virtual ~CXTPMarkupTransformationMatrix();
57
65 virtual CXTPMarkupTransformationMatrix* Clone() const = 0;
66
72 virtual void Offset(const POINT& offset);
73
83 virtual BOOL PtInRect(const RECT& rect, const POINT& absoluteOffset, const POINT& point) const;
84
93 virtual CRect GetBoundRect(const RECT& rect, const POINT& absoluteOffset) const;
94};
95
96AFX_INLINE CXTPMarkupTransformationMatrix::CXTPMarkupTransformationMatrix()
97{
98}
99
100AFX_INLINE CXTPMarkupTransformationMatrix::~CXTPMarkupTransformationMatrix()
101{
102}
103
104# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
106#endif // !defined(__XTPMARKUPTRANSFORMATIONMATRIX_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPMarkupTransformationMatrix
An abstract class for device context transformation matrix.
Definition XTPMarkupTransformationMatrix.h:40
CXTPMarkupTransformationMatrix::~CXTPMarkupTransformationMatrix
virtual ~CXTPMarkupTransformationMatrix()
Destroys a CXTPMarkupTransformationMatrix object, handles cleanup and deallocation.
Definition XTPMarkupTransformationMatrix.h:100
CXTPMarkupTransformationMatrix::CXTPMarkupTransformationMatrix
CXTPMarkupTransformationMatrix()
Constructs a CXTPMarkupTransformationMatrix object.
Definition XTPMarkupTransformationMatrix.h:96
CXTPMarkupTransformationMatrix::GetBoundRect
virtual CRect GetBoundRect(const RECT &rect, const POINT &absoluteOffset) const
Computes the bounding rectangle after transformation.
CXTPMarkupTransformationMatrix::PtInRect
virtual BOOL PtInRect(const RECT &rect, const POINT &absoluteOffset, const POINT &point) const
Checks if a point is inside a rectangle with transformation applied.
CXTPMarkupTransformationMatrix::Clone
virtual CXTPMarkupTransformationMatrix * Clone() const =0
Clones a matrix object.
CXTPMarkupTransformationMatrix::Offset
virtual void Offset(const POINT &offset)
Adds offset to the current matrix.


Toolkit Pro: Member List

CXTPChartDiagram2DAppearance Member List

This is the complete list of members for CXTPChartDiagram2DAppearance, including all inherited members.

ApplyToDeviceContext(CXTPChartDeviceContext *pDC) | CXTPChartElementAppearance | virtual
BackgroundColor | CXTPChartDiagram2DAppearance |
BackgroundColor2 | CXTPChartDiagram2DAppearance |
BackgroundFillStyle | CXTPChartDiagram2DAppearance |
BorderColor | CXTPChartDiagram2DAppearance |
CXTPChartDiagram2DAppearance(CXTPChartElement *pOwner) | CXTPChartDiagram2DAppearance |
CXTPChartElement() | CXTPChartElement |
CXTPChartElementAppearance(CXTPChartElement *pOwner) | CXTPChartElementAppearance |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
DoPropExchange(CXTPPropExchange *pPX) | CXTPChartDiagram2DAppearance | virtual
GetAppearance() const | CXTPChartElement |
GetAxisAppearance() const | CXTPChartDiagram2DAppearance |
GetContent() const | CXTPChartElement |
GetOwner() const | CXTPChartElement |
Is3D() const | CXTPChartObject |
m_pAxisAppearance | CXTPChartDiagram2DAppearance | protected
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartElement | virtual
Release() | CXTPChartElement | virtual
~CXTPChartDiagram2DAppearance() | CXTPChartDiagram2DAppearance | virtual
~CXTPChartElement() | CXTPChartElement | virtual
~CXTPChartElementAppearance() | CXTPChartElementAppearance | virtual


Toolkit Pro: Member List

CXTPFlowGraphPageHistory Member List

This is the complete list of members for CXTPFlowGraphPageHistory, including all inherited members.

AnimatePageTransition(CXTPFlowGraphNode *pNodeFrom, CXTPFlowGraphNode *pNodeTo) | CXTPFlowGraphPageHistory |
CanGoBackward() const | CXTPFlowGraphPageHistory |
CanGoForward() const | CXTPFlowGraphPageHistory |
Clear() | CXTPFlowGraphPageHistory |
CXTPCmdTarget() | CXTPCmdTarget |
CXTPFlowGraphPageHistory(CXTPFlowGraphControl *pControl) | CXTPFlowGraphPageHistory |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GoBackward() | CXTPFlowGraphPageHistory |
GoForward() | CXTPFlowGraphPageHistory |
m_arrPageRedo | CXTPFlowGraphPageHistory | protected
m_arrPageUndo | CXTPFlowGraphPageHistory | protected
m_pControl | CXTPFlowGraphPageHistory | protected
~CXTPFlowGraphPageHistory() | CXTPFlowGraphPageHistory | protectedvirtual


Toolkit Pro: Member List

CXTPHeapStringT< _TAllocator > Member List

This is the complete list of members for CXTPHeapStringT< _TAllocator >, including all inherited members.

_AllocStringData(int nNewStrLen) | CXTPHeapStringT< _TAllocator > | inlineprotectedvirtual
_FreeStringData() | CXTPHeapStringT< _TAllocator > | inlineprotectedvirtual
AllocSysString() const | CXTPHeapString | virtual
CXTPHeapString() | CXTPHeapString |
CXTPHeapString(LPCTSTR pcszString) | CXTPHeapString |
CXTPHeapStringT(LPCTSTR pcszString=_T("")) | CXTPHeapStringT< _TAllocator > | inline
IsEmpty() const | CXTPHeapString | virtual
m_nStrLen | CXTPHeapString | protected
m_pcszString | CXTPHeapString | protected
operator CString() const | CXTPHeapStringT< _TAllocator > | inline
operator LPCTSTR() const | CXTPHeapStringT< _TAllocator > | inline
operator!=(LPCTSTR pcszString) const | CXTPHeapStringT< _TAllocator > | inline
operator=(LPCTSTR pcszString) | CXTPHeapStringT< _TAllocator > | inline
operator==(LPCTSTR pcszString) const | CXTPHeapStringT< _TAllocator > | inline
SetString(LPCTSTR pcszString) | CXTPHeapString | virtual
~CXTPHeapString() | CXTPHeapString | virtual
~CXTPHeapStringT() | CXTPHeapStringT< _TAllocator > | inlinevirtual


Toolkit Pro: Member List

CXTPButtonThemeNativeWindows10 Member List

This is the complete list of members for CXTPButtonThemeNativeWindows10, including all inherited members.

CXTPButtonTheme() | CXTPButtonTheme |
CXTPButtonThemeNativeWindows10() | CXTPButtonThemeNativeWindows10 |
CXTPButtonThemeUltraFlat() | CXTPButtonThemeUltraFlat |
CXTPCmdTarget() | CXTPCmdTarget |
CXTPControlTheme() | CXTPControlTheme |
DrawButton(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
DrawButtonBackground(CDC *pDC, CXTPButton *pButton) | CXTPButtonThemeOffice2013 | virtual
DrawButtonText(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme |
DrawButtonVisualStyleBackground(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
DrawCheckBoxMark(CDC *pDC, CXTPButton *pButton) | CXTPButtonThemeOffice2013 | virtual
DrawFocusRect(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
DrawGroupBox(CDC *pDC, CXTPButton *pButton) | CXTPButtonThemeOffice2013 | virtual
DrawPushButtonDropDown(CDC *pDC, CXTPButton *pButton) | CXTPButtonThemeOffice2013 | virtual
DrawPushButtonIcon(CDC *pDC, CXTPButton *pButton) | CXTPButtonThemeOffice2013 | virtual
DrawPushButtonText(CDC *pDC, CXTPButton *pButton) | CXTPButtonThemeOffice2013 | virtual
DrawRadioButtonMark(CDC *pDC, CXTPButton *pButton) | CXTPButtonThemeOffice2013 | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetTextColor(CXTPButton *pButton) | CXTPButtonThemeOffice2013 | virtual
GetThemeStyle() const | CXTPControlTheme |
m_crBack | CXTPButtonTheme |
m_crBackChecked | CXTPButtonThemeUltraFlat |
m_crBackDisabled | CXTPButtonThemeOffice2013 | protected
m_crBackHilite | CXTPButtonThemeUltraFlat |
m_crBackPushed | CXTPButtonThemeUltraFlat |
m_crBorder | CXTPButtonThemeOffice2013 | protected
m_crBorder3DHilite | CXTPButtonTheme |
m_crBorder3DShadow | CXTPButtonTheme |
m_crBorderDefault | CXTPButtonThemeOffice2013 | protected
m_crBorderDisabled | CXTPButtonThemeOffice2013 | protected
m_crBorderHilite | CXTPButtonTheme |
m_crBorderPushed | CXTPButtonThemeUltraFlat |
m_crBorderShadow | CXTPButtonTheme |
m_crCheckMark | CXTPButtonThemeUltraFlat |
m_crMark | CXTPButtonThemeOffice2013 | protected
m_crMarkDisabled | CXTPButtonThemeOffice2013 | protected
m_crMarkHilite | CXTPButtonThemeOffice2013 | protected
m_crMarkPushed | CXTPButtonThemeOffice2013 | protected
m_crText | CXTPButtonTheme |
m_crTextCheck | CXTPButtonTheme |
m_crTextDisabled | CXTPButtonTheme |
m_crTextHilite | CXTPButtonThemeUltraFlat |
m_crTextPushed | CXTPButtonThemeUltraFlat |
m_nTheme | CXTPControlTheme | protected
RefreshMetrics(CXTPButton *pButton) | CXTPButtonThemeNativeWindows10 | virtual
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static
~CXTPButtonTheme() | CXTPButtonTheme | virtual


Toolkit Pro: XTPMarkupPolyline.h Source File

  • Source
  • Markup
  • Shapes
XTPMarkupPolyline.h
Go to the documentation of this file.
1
23#if !defined(__XTPMARKUPPOLYLINE_H__)
24# define __XTPMARKUPPOLYLINE_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPMarkupPointCollection;
34class CXTPMarkupDependencyProperty;
35class CXTPMarkupDrawingContext;
36
37class _XTP_EXT_CLASS CXTPMarkupPolyline : public CXTPMarkupShape
38{
40 DECLARE_MARKUPCLASS(CXTPMarkupPolyline)
42protected:
43 CXTPMarkupPolyline();
44 virtual ~CXTPMarkupPolyline();
45
46public:
47 void SetPoints(CXTPMarkupPointCollection* pPoints);
48 CXTPMarkupPointCollection* GetPoints() const;
49
50protected:
51 CSize MeasureOverride(CXTPMarkupDrawingContext* pDC, CSize szAvailableSize);
52 void OnRender(CXTPMarkupDrawingContext* pDC);
53
55public:
56 DECLARE_DISPATCH_MAP()
57# ifdef _XTP_ACTIVEX
58 DECLARE_INTERFACE_MAP()
59 DECLARE_OLETYPELIB_EX(CXTPMarkupPolyline);
60# endif
61
64public:
65 static CXTPMarkupDependencyProperty* m_pPointsProperty;
66};
67
68# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
70#endif // !defined(__XTPMARKUPPOLYLINE_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPMarkupVisual::OnRender
virtual void OnRender(CXTPMarkupDrawingContext *drawingContext)
When overridden in a derived class, participates in rendering operations that are directed by the lay...
Definition XTPMarkupInputElement.h:515


Toolkit Pro: Member List

CXTPChartRadarLineSeriesView Member List

This is the complete list of members for CXTPChartRadarLineSeriesView, including all inherited members.

AddChildView(CXTPChartElementView *pChildView) | CXTPChartElementView |
CreateDeviceCommand(CXTPChartDeviceContext *pDC) | CXTPChartRadarLineSeriesView | protectedvirtual
CreateLegendDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcBounds) | CXTPChartRadarLineSeriesView | protectedvirtual
CreateSeriesPointView(CXTPChartDeviceContext *pDC, CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView) | CXTPChartRadarLineSeriesView | protected
CXTPChartElementView(CXTPChartElementView *pParentView) | CXTPChartElementView |
CXTPChartElementView(CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartElementView |
CXTPChartElementView(CXTPChartContainer *pContainer) | CXTPChartElementView |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartRadarLineSeriesView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView) | CXTPChartRadarLineSeriesView |
GetAt(int nIndex) const | CXTPChartElementView |
GetBounds() const | CXTPChartElementView |
GetBounds(BOOL bIncludingChildren) const | CXTPChartElementView |
GetChildren() | CXTPChartElementView |
GetCount() const | CXTPChartElementView |
GetParentView() const | CXTPChartElementView |
Is3D() const | CXTPChartObject |
m_arrChildren | CXTPChartElementView | protected
m_pContainer | CXTPChartElementView | protected
m_pParentView | CXTPChartElementView | protected
m_rcBounds | CXTPChartElementView | protected
~CXTPChartElementView() | CXTPChartElementView | protectedvirtual
~CXTPChartLegendItemView() | CXTPChartLegendItemView | inlinevirtual


Toolkit Pro: XTPFlowGraphPage.h Source File

  • Source
  • FlowGraph
XTPFlowGraphPage.h
Go to the documentation of this file.
1
23#if !defined(__XTPFLOWGRAPHPAGE_H__)
24# define __XTPFLOWGRAPHPAGE_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPFlowGraphControl;
34class CXTPFlowGraphNodes;
35class CXTPFlowGraphNodeGroups;
36class CXTPFlowGraphConnections;
37class CXTPFlowGraphDrawContext;
38class CXTPPropExchange;
39class CXTPFlowGraphNode;
40class CXTPFlowGraphSelectedElements;
41class CXTPFlowGraphConnection;
42
53class _XTP_EXT_CLASS CXTPFlowGraphPage : public CXTPCmdTarget
54{
55 DECLARE_SERIAL(CXTPFlowGraphPage);
56
57public:
62 CXTPFlowGraphPage();
63
64protected:
70 virtual ~CXTPFlowGraphPage();
71
72public:
85 CXTPFlowGraphNodes* GetNodes() const;
86
98 CXTPFlowGraphNodeGroups* GetGroups() const;
99
106 CXTPFlowGraphControl* GetControl() const;
107
115 CXTPFlowGraphConnections* GetConnections() const;
116
117public:
123 void SetID(int nId);
124
131 int GetID() const;
132
138 void SetCaption(LPCTSTR lpszCaption);
139
146 CString GetCaption() const;
147
148public:
157 virtual void OnGraphChanged();
158
166 virtual void Reposition(CXTPFlowGraphDrawContext* pDC, CRect rcPage);
167
173 virtual void OnDraw(CXTPFlowGraphDrawContext* pDC);
174
184 CRect PageToScreen(LPCRECT lpRect) const;
185
198 void ScreenToPage(double& x, double& y) const;
199
214 CPoint ScreenToPage(CPoint point) const;
229 CRect ScreenToPage(LPCRECT lpRect) const;
230
236 virtual void Copy();
237
243 virtual void Paste();
244
254 virtual BOOL CanPaste();
255
262 virtual void Cut();
263
268 void Remove();
269
277 virtual void Arrange();
278
279public:
293 CXTPFlowGraphSelectedElements* GetSelection() const;
294
295public:
302 CRect GetPageRect() const;
303
312 CPoint GetScrollOffset() const;
313
322 void SetScrollOffset(CPoint ptScrollOffset);
323
332 double GetZoomLevel() const;
333
341 void SetZoomLevel(double dZoomLevel);
342
343protected:
348 virtual void OnRemoved();
349
355 void SetVisibleNodesWindowsRegions();
356
357public:
366 virtual void DoPropExchange(CXTPPropExchange* pPX);
367
368private:
370 void SetArrangeLevel(int v, CArray<CDWordArray*, CDWordArray*>& graph);
371 int SetArrangeLocation(int v, int x, int y, int nLevelWidth,
372 CArray<CDWordArray*, CDWordArray*>& graph);
375public:
376 static CLIPFORMAT m_cfNode;
378protected:
379 CXTPFlowGraphControl* m_pControl;
380 CXTPFlowGraphNodes* m_pNodes;
381 CXTPFlowGraphNodeGroups* m_pGroups;
383 CXTPFlowGraphConnections* m_pConnections;
385 CXTPFlowGraphSelectedElements* m_pSelectedElements;
388 CXTPFlowGraphNode* m_pFirstVisibleNode;
389 CXTPFlowGraphConnection* m_pFirstVisibleConnection;
392 CRect m_rcPage;
394 CRect m_rcWorkRect;
397 CPoint m_ptScrollOffset;
399 double m_dZoomLevel;
401 int m_nId;
402 CString m_strCaption;
404 friend class CXTPFlowGraphPages;
405 friend class CXTPFlowGraphControl;
406
407# ifdef _XTP_ACTIVEX
410 DECLARE_DISPATCH_MAP()
411 DECLARE_INTERFACE_MAP()
412
413 DECLARE_OLETYPELIB_EX(CXTPFlowGraphPage)
414
415 afx_msg LPDISPATCH OleGetNodes();
416 afx_msg LPDISPATCH OleGetGroups();
417 afx_msg LPDISPATCH OleGetConnections();
418 afx_msg void OleSetCaption(LPCTSTR lpszCaption);
419 afx_msg BSTR OleGetCaption();
420
421 afx_msg void OleScreenToPage(int* x, int* y);
422 afx_msg void OlePageToScreen(int* x, int* y);
423
424 afx_msg int OleGetScrollOffsetX();
425 afx_msg int OleGetScrollOffsetY();
426 afx_msg void OleSetScrollOffsetX(int x);
427 afx_msg void OleSetScrollOffsetY(int y);
428 afx_msg void OleSetZoomLevel(double dZoomLevel);
429 afx_msg double OleGetZoomLevel();
430 afx_msg LPDISPATCH OleGetSelection();
431
433# endif
434};
435
436AFX_INLINE CXTPFlowGraphSelectedElements* CXTPFlowGraphPage::GetSelection() const
437{
438 return m_pSelectedElements;
439}
440
441AFX_INLINE CXTPFlowGraphNodes* CXTPFlowGraphPage::GetNodes() const
442{
443 return m_pNodes;
444}
445AFX_INLINE CXTPFlowGraphNodeGroups* CXTPFlowGraphPage::GetGroups() const
446{
447 return m_pGroups;
448}
449AFX_INLINE CXTPFlowGraphConnections* CXTPFlowGraphPage::GetConnections() const
450{
451 return m_pConnections;
452}
453AFX_INLINE CXTPFlowGraphControl* CXTPFlowGraphPage::GetControl() const
454{
455 return m_pControl;
456}
457AFX_INLINE CRect CXTPFlowGraphPage::GetPageRect() const
458{
459 return m_rcPage;
460}
461AFX_INLINE CPoint CXTPFlowGraphPage::GetScrollOffset() const
462{
463 return m_ptScrollOffset;
464}
465AFX_INLINE void CXTPFlowGraphPage::SetScrollOffset(CPoint ptScrollOffset)
466{
467 m_ptScrollOffset = ptScrollOffset;
468 OnGraphChanged();
469}
470AFX_INLINE void CXTPFlowGraphPage::SetID(int nId)
471{
472 m_nId = nId;
473}
474AFX_INLINE int CXTPFlowGraphPage::GetID() const
475{
476 return m_nId;
477}
478AFX_INLINE CString CXTPFlowGraphPage::GetCaption() const
479{
480 return m_strCaption;
481}
482AFX_INLINE void CXTPFlowGraphPage::SetCaption(LPCTSTR lpszCaption)
483{
484 m_strCaption = lpszCaption;
485}
486AFX_INLINE double CXTPFlowGraphPage::GetZoomLevel() const
487{
488 return m_dZoomLevel;
489}
490AFX_INLINE void CXTPFlowGraphPage::SetZoomLevel(double dZoomLevel)
491{
492 m_dZoomLevel = dZoomLevel;
493 OnGraphChanged();
494}
496# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
497#endif //#if !defined(__XTPFLOWGRAPHPAGE_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPFlowGraphConnection
Represents a connection.
Definition XTPFlowGraphConnection.h:49
CXTPFlowGraphConnections
Represents a collection of connections for a Node.
Definition XTPFlowGraphConnections.h:41
CXTPFlowGraphControl
Flow Graph Control.
Definition XTPFlowGraphControl.h:173
CXTPFlowGraphNodeGroups
Represents a collection of groups in a page.
Definition XTPFlowGraphNodeGroups.h:46
CXTPFlowGraphNode
Represents a Node object.
Definition XTPFlowGraphNode.h:116
CXTPFlowGraphNodes
Represents a collection of Nodes in a page or group.
Definition XTPFlowGraphNodes.h:48
CXTPFlowGraphPage
Represents a page in the flow graph.
Definition XTPFlowGraphPage.h:54
CXTPFlowGraphPage::Reposition
virtual void Reposition(CXTPFlowGraphDrawContext *pDC, CRect rcPage)
This method is called to move the contents of the page to their correct positions.
CXTPFlowGraphPage::GetPageRect
CRect GetPageRect() const
Gets the bounding rectangle for this page.
Definition XTPFlowGraphPage.h:457
CXTPFlowGraphPage::DoPropExchange
virtual void DoPropExchange(CXTPPropExchange *pPX)
Call this member function to store/load a page using the specified data object.
CXTPFlowGraphPage::Remove
void Remove()
Removes this page from the flow graph.
CXTPFlowGraphPage::m_pNodes
CXTPFlowGraphNodes * m_pNodes
Collection of Nodes that are displayed on this page.
Definition XTPFlowGraphPage.h:380
CXTPFlowGraphPage::GetConnections
CXTPFlowGraphConnections * GetConnections() const
Gets a collection of all connections that have been added to this page.
Definition XTPFlowGraphPage.h:449
CXTPFlowGraphPage::OnRemoved
virtual void OnRemoved()
This method is called when the page is removed.
CXTPFlowGraphPage::CanPaste
virtual BOOL CanPaste()
Specifies whether the flow control can perform a paste operation.
CXTPFlowGraphPage::m_pGroups
CXTPFlowGraphNodeGroups * m_pGroups
Collection of groups that are displayed on this page.
Definition XTPFlowGraphPage.h:381
CXTPFlowGraphPage::GetID
int GetID() const
Gets the ID of this page.
Definition XTPFlowGraphPage.h:474
CXTPFlowGraphPage::ScreenToPage
CRect ScreenToPage(LPCRECT lpRect) const
Converts the screen coordinates of a given point or rectangle on the display to page coordinates.
CXTPFlowGraphPage::OnDraw
virtual void OnDraw(CXTPFlowGraphDrawContext *pDC)
This method is called when the page is drawn.
CXTPFlowGraphPage::m_pSelectedElements
CXTPFlowGraphSelectedElements * m_pSelectedElements
Collection of elements that are used this page.
Definition XTPFlowGraphPage.h:385
CXTPFlowGraphPage::m_pFirstVisibleNode
CXTPFlowGraphNode * m_pFirstVisibleNode
Pointer to the first visible Node in the page.
Definition XTPFlowGraphPage.h:388
CXTPFlowGraphPage::m_dZoomLevel
double m_dZoomLevel
Current zoom level of the page.
Definition XTPFlowGraphPage.h:399
CXTPFlowGraphPage::ScreenToPage
void ScreenToPage(double &x, double &y) const
Converts the given x- and y- screen coordinates to page coordinates.
CXTPFlowGraphPage::SetVisibleNodesWindowsRegions
void SetVisibleNodesWindowsRegions()
Define visible regions of windows inside Nodes (if windows exist inside Nodes).
CXTPFlowGraphPage::m_pControl
CXTPFlowGraphControl * m_pControl
Pointer to the parent flow graph control.
Definition XTPFlowGraphPage.h:379
CXTPFlowGraphPage::m_pFirstVisibleConnection
CXTPFlowGraphConnection * m_pFirstVisibleConnection
Pointer to the first visible connection in the page.
Definition XTPFlowGraphPage.h:389
CXTPFlowGraphPage::ScreenToPage
CPoint ScreenToPage(CPoint point) const
Converts the screen coordinates of a given point or rectangle on the display to page coordinates.
CXTPFlowGraphPage::OnGraphChanged
virtual void OnGraphChanged()
This method is called when the flow graph layout is changed.
CXTPFlowGraphPage::Paste
virtual void Paste()
Call this method to paste the contents of the flow graph's clipboard to the currently active page.
CXTPFlowGraphPage::SetID
void SetID(int nId)
Sets the ID for this page.
Definition XTPFlowGraphPage.h:470
CXTPFlowGraphPage::SetCaption
void SetCaption(LPCTSTR lpszCaption)
Sets the caption for this page.
Definition XTPFlowGraphPage.h:482
CXTPFlowGraphPage::GetControl
CXTPFlowGraphControl * GetControl() const
Gets a reference to the parent FlowGraph control.
Definition XTPFlowGraphPage.h:453
CXTPFlowGraphPage::~CXTPFlowGraphPage
virtual ~CXTPFlowGraphPage()
Destroys a CXTPFlowGraphPage object, handles cleanup and deallocation.
CXTPFlowGraphPage::Arrange
virtual void Arrange()
Auto-arranges the Nodes in this page.
CXTPFlowGraphPage::PageToScreen
CRect PageToScreen(LPCRECT lpRect) const
Converts the page coordinates of a given point or rectangle on the display to screen coordinates.
CXTPFlowGraphPage::Copy
virtual void Copy()
Call this method to copy all the currently selected elements to the flow graph's clipboard.
CXTPFlowGraphPage::SetScrollOffset
void SetScrollOffset(CPoint ptScrollOffset)
Sets the scroll offset (how much the page has been scrolled).
Definition XTPFlowGraphPage.h:465
CXTPFlowGraphPage::GetCaption
CString GetCaption() const
Gets the caption of this page.
Definition XTPFlowGraphPage.h:478
CXTPFlowGraphPage::GetNodes
CXTPFlowGraphNodes * GetNodes() const
Gets a collection of all Nodes that have been added to this page.
Definition XTPFlowGraphPage.h:441
CXTPFlowGraphPage::m_cfNode
static CLIPFORMAT m_cfNode
Clipboard format.
Definition XTPFlowGraphPage.h:376
CXTPFlowGraphPage::CXTPFlowGraphPage
CXTPFlowGraphPage()
Constructs a CXTPFlowGraphPage object.
CXTPFlowGraphPage::m_rcWorkRect
CRect m_rcWorkRect
Rectangle for the currently visible portion of the page (it might be zoomed or scrolled).
Definition XTPFlowGraphPage.h:394
CXTPFlowGraphPage::GetScrollOffset
CPoint GetScrollOffset() const
Retrieves the scroll offset (how much the page has been scrolled).
Definition XTPFlowGraphPage.h:461
CXTPFlowGraphPage::SetZoomLevel
void SetZoomLevel(double dZoomLevel)
Sets the current zoom level of the page.
Definition XTPFlowGraphPage.h:490
CXTPFlowGraphPage::GetSelection
CXTPFlowGraphSelectedElements * GetSelection() const
Gets a reference to the collection of selected elements in the flow graph in this page.
Definition XTPFlowGraphPage.h:436
CXTPFlowGraphPage::GetZoomLevel
double GetZoomLevel() const
Gets the current zoom level of the page.
Definition XTPFlowGraphPage.h:486
CXTPFlowGraphPage::GetGroups
CXTPFlowGraphNodeGroups * GetGroups() const
Gets a collection of all groups that have been added to this page.
Definition XTPFlowGraphPage.h:445
CXTPFlowGraphPage::Cut
virtual void Cut()
Call this method to copy all the currently selected elements to the flow graph's clipboard and then r...
CXTPFlowGraphPage::m_ptScrollOffset
CPoint m_ptScrollOffset
The scroll offset (how much the page has been scrolled).
Definition XTPFlowGraphPage.h:397
CXTPFlowGraphPage::m_rcPage
CRect m_rcPage
Bounding rectangle for this page.
Definition XTPFlowGraphPage.h:392
CXTPFlowGraphPage::m_strCaption
CString m_strCaption
Caption of the page.
Definition XTPFlowGraphPage.h:402
CXTPFlowGraphPage::m_pConnections
CXTPFlowGraphConnections * m_pConnections
Collection of connections that are used in this page.
Definition XTPFlowGraphPage.h:383
CXTPFlowGraphPage::m_nId
int m_nId
ID of the page.
Definition XTPFlowGraphPage.h:401
CXTPFlowGraphPages
Represents a collection of pages in the flow graph.
Definition XTPFlowGraphPages.h:47
CXTPFlowGraphSelectedElements
Collection of selected elements in the flow graph.
Definition XTPFlowGraphSelectedElements.h:46
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72


Toolkit Pro: Member List

CXTPCalendarViewGroup Member List

This is the complete list of members for CXTPCalendarViewGroup, including all inherited members.

AddResource(CXTPCalendarResource *pResource, BOOL bWithAddRef) | CXTPCalendarViewGroup | virtual
AdjustLayout(CDC *pDC, const CRect &rcGroup) | CXTPCalendarViewGroup | virtual
AdjustLayout2(CDC *pDC, const CRect &rcGroup) | CXTPCalendarViewGroup | virtual
CXTPCalendarViewGroup(CXTPCalendarViewDay *pViewDay) | CXTPCalendarViewGroup |
CXTPCalendarWMHandler() | CXTPCalendarWMHandler |
CXTPCmdTarget() | CXTPCmdTarget |
Draw(CDC *pDC) | CXTPCalendarViewGroup | virtual
ExchangeEventPlace(CXTPCalendarViewEvent *pViewEvent, int nNewPlace) | CXTPCalendarViewGroup | virtual
FillHitTestEx(XTP_CALENDAR_HITTESTINFO *pHitTest) const =0 | CXTPCalendarViewGroup | pure virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCalendarControl() const | CXTPCalendarViewGroup | virtual
GetCaption() const | CXTPCalendarViewGroup | virtual
GetChildHandlerAt(int nIndex) const | CXTPCalendarViewGroup | virtual
GetChildHandlersCount() const | CXTPCalendarViewGroup | virtual
GetDataProvider() const | CXTPCalendarViewGroup | virtual
GetGroupIndex() const | CXTPCalendarViewGroup | virtual
GetHeaderRect() const | CXTPCalendarViewGroup | inlinevirtual
GetRect() const | CXTPCalendarViewGroup | inlinevirtual
GetResources() const | CXTPCalendarViewGroup | virtual
GetScheduleID() const | CXTPCalendarViewGroup | virtual
GetTooltipRect(const CPoint &ptHit, const XTP_CALENDAR_HITTESTINFO &hitInfo) const | CXTPCalendarViewGroup | virtual
GetViewDay_() const | CXTPCalendarViewGroup |
GetViewEvent_(int nIndex) const | CXTPCalendarViewGroup |
GetViewEventByEvent_(CXTPCalendarEvent *pEvent) const | CXTPCalendarViewGroup | virtual
GetViewEventByPlace_(int nEventPlace) const | CXTPCalendarViewGroup | virtual
GetViewEventsCount() const | CXTPCalendarViewGroup |
HitTest(CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const | CXTPCalendarViewGroup | virtual
HitTestEx(CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const | CXTPCalendarViewGroup | virtual
KillTimer(UINT uTimerID) | CXTPCalendarViewGroup | protectedvirtual
m_arEvents | CXTPCalendarViewGroup | protected
m_Layout | CXTPCalendarViewGroup | protected
m_pResources | CXTPCalendarViewGroup | protected
m_pViewDay | CXTPCalendarViewGroup | protected
OnBeforeDestroy() | CXTPCalendarWMHandler | virtual
OnChar(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnKeyUp(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnLButtonDblClk(UINT nFlags, CPoint point) | CXTPCalendarWMHandler | virtual
OnLButtonDown(UINT nFlags, CPoint point) | CXTPCalendarWMHandler | virtual
OnLButtonUp(UINT nFlags, CPoint point) | CXTPCalendarWMHandler | virtual
OnMouseMove(UINT nFlags, CPoint point) | CXTPCalendarWMHandler | virtual
OnPostAdjustLayout() | CXTPCalendarWMHandler | virtual
OnPrePopulate(CXTPCalendarEvents *pEvents) | CXTPCalendarViewGroup | protectedvirtual
OnSysKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnTimer(UINT_PTR uTimerID) | CXTPCalendarWMHandler | virtual
OnWndMsg(UINT message, WPARAM wParam, LPARAM lParam, LRESULT *pResult) | CXTPCalendarWMHandler | virtual
Populate(COleDateTime dtDayDate) | CXTPCalendarViewGroup | virtual
SetResources(CXTPCalendarResources *pResources) | CXTPCalendarViewGroup | virtual
SetTimer(UINT uTimeOut_ms) | CXTPCalendarViewGroup | protectedvirtual
~CXTPCalendarViewGroup() | CXTPCalendarViewGroup | virtual


Toolkit Pro: Member List

CXTPChartFunnelSeriesViewBase Member List

This is the complete list of members for CXTPChartFunnelSeriesViewBase, including all inherited members.

AddChildView(CXTPChartElementView *pChildView) | CXTPChartElementView |
CalculateLabelLayout(CXTPChartDeviceContext *pDC) | CXTPChartFunnelSeriesViewBase |
CalculatePointLayout(CXTPChartDeviceContext *pDC, CRect rcBounds) | CXTPChartFunnelSeriesViewBase | virtual
CreateDeviceCommand(CXTPChartDeviceContext *pDC)=0 | CXTPChartFunnelSeriesViewBase | protectedpure virtual
CreateDiagramDomain(CXTPChartDeviceContext *pDC, CRect rcBounds) | CXTPChartFunnelSeriesViewBase | virtual
CreateLegendDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcBounds, CXTPChartColor color1, CXTPChartColor color2, CXTPChartColor clrBorder)=0 | CXTPChartFunnelSeriesViewBase | pure virtual
CreateLegendDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcBounds)=0 | CXTPChartFunnelSeriesViewBase | protectedpure virtual
CreateSeriesPointView(CXTPChartDeviceContext *pDC, CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)=0 | CXTPChartFunnelSeriesViewBase | protectedpure virtual
CXTPChartElementView(CXTPChartElementView *pParentView) | CXTPChartElementView |
CXTPChartElementView(CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartElementView |
CXTPChartElementView(CXTPChartContainer *pContainer) | CXTPChartElementView |
CXTPChartFunnelSeriesViewBase(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView) | CXTPChartFunnelSeriesViewBase |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
GetAt(int nIndex) const | CXTPChartElementView |
GetBounds() const | CXTPChartElementView |
GetBounds(BOOL bIncludingChildren) const | CXTPChartElementView |
GetChildren() | CXTPChartElementView |
GetCount() const | CXTPChartElementView |
GetDomain() const | CXTPChartFunnelSeriesViewBase |
GetInnerBounds() const | CXTPChartFunnelSeriesViewBase | virtual
GetMaxLabelWidth() const | CXTPChartFunnelSeriesViewBase |
GetParentView() const | CXTPChartElementView |
Is3D() const | CXTPChartObject |
m_arrChildren | CXTPChartElementView | protected
m_pContainer | CXTPChartElementView | protected
m_pDomain | CXTPChartFunnelSeriesViewBase | protected
m_pParentView | CXTPChartElementView | protected
m_rcBounds | CXTPChartElementView | protected
~CXTPChartElementView() | CXTPChartElementView | protectedvirtual
~CXTPChartFunnelSeriesViewBase() | CXTPChartFunnelSeriesViewBase | virtual
~CXTPChartLegendItemView() | CXTPChartLegendItemView | inlinevirtual


Toolkit Pro: Member List

CXTPTrackThemeVisualStudio2019 Member List

This is the complete list of members for CXTPTrackThemeVisualStudio2019, including all inherited members.

CalcColumnHeight(CDC *pDC, CXTPGridColumn *pColumn, int nTotalWidth=0) | CXTPGridPaintManager | protectedvirtual
CalculateRowHeight(CDC *pDC, const CString &strText, int nMaxWidth, BOOL bWordBreak=TRUE) | CXTPGridPaintManager | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPGridPaintManager() | CXTPGridPaintManager |
CXTPTrackPaintManager() | CXTPTrackPaintManager |
CXTPTrackThemeOffice2013() | CXTPTrackThemeOffice2013 |
CXTPTrackThemeVisualStudio2019() | CXTPTrackThemeVisualStudio2019 |
DrawBitmap(CDC *pDC, CXTPGridControl *pControl, CRect rcColumn, int iImage) | CXTPGridPaintManager | virtual
DrawCollapsedBitmap(CDC *pDC, const CXTPGridRow *pRow, CRect &rcBitmap) | CXTPGridPaintManager | virtual
DrawColumn(CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn, BOOL bDrawExternal=FALSE, int nShadowWidth=0) | CXTPGridPaintManager | virtual
DrawColumnBackground(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, BOOL &bColumnPressed, BOOL &bDraggingFromHeader, CXTPGridHeader *pHeader=NULL) | CXTPTrackThemeOffice2013 | virtual
DrawColumnFooter(CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn) | CXTPGridPaintManager | virtual
DrawColumnFooterDivider(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn) | CXTPGridPaintManager | virtual
DrawColumnIcon(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, CRect rcIcon, int iIcon) | CXTPGridPaintManager | virtual
DrawColumnText(CDC *pDC, CRect rcText, CString strCaption, int nHeaderAlignment, BOOL bIsHeader, BOOL bColumnPressed) | CXTPTrackThemeOffice2013 | virtual
DrawConnector(CDC *pDC, CPoint ptFrom, CPoint ptTo) | CXTPGridPaintManager |
DrawFocusedRow(CDC *pDC, CRect rcRow) | CXTPTrackThemeOffice2013 | virtual
DrawFreezeColsDivider(CDC *pDC, const CRect &rc, CXTPGridControl *pControl, CXTPGridRow *pRow=NULL) | CXTPGridPaintManager | virtual
DrawGlyph(CDC *pDC, CRect rcColumn, int iImage) | CXTPGridPaintManager | virtual
DrawGrid(CDC *pDC, XTPGridOrientation orientation, CRect rcGrid) | CXTPGridPaintManager | virtual
DrawGridPattern(CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush) | CXTPGridPaintManager | protectedvirtual
DrawGridPattern(CDC *pDC, CXTPBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush) | CXTPGridPaintManager | protectedvirtual
DrawGridPattern(CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr) | CXTPGridPaintManager | protectedvirtual
DrawGroupRow(CDC *pDC, CXTPGridGroupRow *pRow, CRect rcRow, XTP_GRIDRECORDITEM_METRICS *pMetrics) | CXTPTrackThemeOffice2013 | virtual
DrawHorizontalLine(CDC *pDC, int xPos, int yPos, int cx, COLORREF clr) | CXTPGridPaintManager |
DrawInplaceButton(CDC *pDC, CXTPGridInplaceButton *pButton) | CXTPGridPaintManager | virtual
DrawInplaceButtonFrame(CDC *pDC, CXTPGridInplaceButton *pButton) | CXTPGridPaintManager | protectedvirtual
DrawInplaceButtonIcon(CDC *pDC, CXTPGridInplaceButton *pButton) | CXTPGridPaintManager | protectedvirtual
DrawInplaceComboButton(CDC *pDC, CRect *pRc) | CXTPGridPaintManager | virtual
DrawInplaceExpandButton(CDC *pDC, CRect *pRc) | CXTPGridPaintManager | virtual
DrawInplaceSpinButton(CDC *pDC, CRect *pRc) | CXTPGridPaintManager | virtual
DrawItemBitmap(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CRect &rcItem, int nImage) | CXTPGridPaintManager | virtual
DrawItemCaption(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics) | CXTPGridPaintManager | virtual
DrawItemControl(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CXTPGridRecordItemControl *pControl, CRect &rcItem) | CXTPGridPaintManager | virtual
DrawLink(int *pnCurrDrawPos, XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CXTPGridHyperlink *pHyperlink, CString strText, CRect rcLink, int nFlag, BOOL bTrim=FALSE) | CXTPGridPaintManager | protectedvirtual
DrawMarkers(CDC *pDC) | CXTPTrackPaintManager | virtual
DrawMultiLineText(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, BOOL bWordBreak=TRUE) | CXTPGridPaintManager | protectedvirtual
DrawNoGroupByText(CDC *pDC, CRect rcItem) | CXTPGridPaintManager | virtual
DrawRowNumber(CDC *pDC, CRect rcNumber, CXTPGridRow *pRow) | CXTPGridPaintManager | virtual
DrawSectionDivider(CDC *pDC, const CRect &rc, XTPGridSectionDividerPosition dividerPosition, XTPGridSectionDividerStyle dividerStyle, CXTPPaintManagerColor dividerColor) | CXTPGridPaintManager |
DrawShellIcon(CDC *pDC, CRect rcColumn, int iImage) | CXTPGridPaintManager | virtual
DrawSingleLineText(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nStartPos, int nEndPos, int nActualWidth) | CXTPGridPaintManager | protectedvirtual
DrawString(int *pnCurrDrawPos, CDC *pDC, const CString &strDraw, CRect rcDraw, UINT nFormat) | CXTPGridPaintManager | protectedvirtual
DrawTextLine(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nFlag, int &nCharCounter, int &nHyperlinkCounter) | CXTPGridPaintManager | protectedvirtual
DrawTimeLine(CDC *pDC) | CXTPTrackPaintManager | virtual
DrawTrackHeader(CDC *pDC) | CXTPTrackPaintManager | virtual
DrawTreeStructure(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CRect rcItem, CSize sizeGlyph) | CXTPGridPaintManager | virtual
DrawTriangle(CDC *pDC, CRect rcTriangle, BOOL bToDown, BOOL bDraggingFromHeader, int nShadowWidth, BOOL bColumnPressed) | CXTPTrackThemeOffice2013 | virtual
DrawVerticalLine(CDC *pDC, int xPos, int yPos, int cy, COLORREF clr) | CXTPGridPaintManager |
DrawVerticalTimeLineMarker(CDC *pDC, int xPos, CXTPGridControl *pControl, COLORREF color=RGB(0, 255, 0)) | CXTPGridPaintManager | virtual
EnablePreviewMode(BOOL bIsPreviewMode) | CXTPGridPaintManager |
FillFooter(CDC *pDC, CRect rcFooter) | CXTPGridPaintManager | virtual
FillGroupByControl(CDC *pDC, CRect &rcGroupBy) | CXTPGridPaintManager | virtual
FillGroupRowMetrics(CXTPGridGroupRow *pRow, XTP_GRIDRECORDITEM_METRICS *pMetrics, BOOL bPrinting) | CXTPTrackThemeOffice2013 | virtual
FillHeaderControl(CDC *pDC, CRect rcHeader) | CXTPGridPaintManager | virtual
FillIndent(CDC *pDC, CRect rcRow) | CXTPGridPaintManager | virtual
FillItemShade(CDC *pDC, CRect rcItem) | CXTPGridPaintManager | virtual
FillRow(CDC *pDC, CXTPGridRow *pRow, CRect rcRow) | CXTPGridPaintManager | virtual
FindRowAdjacentToMerged(const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, BOOL bUpward) | CXTPGridPaintManager |
FindRowAdjacentToMergedEx(const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, int &nAdjRowIndex, BOOL bUpward) | CXTPGridPaintManager |
FormatTime(int nPosition) | CXTPTrackPaintManager | virtual
FormatTimeLineTick(int nPosition, COLORREF &clrTick, int &nTickLength) | CXTPTrackPaintManager | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetColumnOffice2007CustomThemeBaseColor() const | CXTPGridPaintManager |
GetColumnStyle() const | CXTPGridPaintManager |
GetControlBackColor(CXTPGridControl *pControl) | CXTPGridPaintManager | virtual
GetFooterHeight(CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0) | CXTPGridPaintManager | virtual
GetFreezeColsDividerStyle() const | CXTPGridPaintManager |
GetGlyphs() const | CXTPGridPaintManager |
GetHeaderHeight() | CXTPGridPaintManager | virtual
GetHeaderHeight(CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0) | CXTPGridPaintManager | virtual
GetItemHeight(XTP_GRIDRECORDITEM_DRAWARGS &drawArgs, int nWidth) | CXTPGridPaintManager |
GetMaxPreviewLines() | CXTPGridPaintManager |
GetPreviewItemHeight(CDC *pDC, CXTPGridRow *pRow, int nWidth, int nHeight) | CXTPGridPaintManager | virtual
GetPreviewLinesCount(CDC *pDC, CRect &rcText, const CString &strText) | CXTPGridPaintManager |
GetRowHeight(CDC *pDC, CXTPGridRow *pRow) | CXTPTrackThemeOffice2013 | virtual
CXTPTrackPaintManager::GetRowHeight(CDC *pDC, CXTPGridRow *pRow, int nTotalWidth) | CXTPGridPaintManager | virtual
GetRowHeightEx(CDC *pDC, CXTPGridRow *pRow, int nTotalWidth, const BOOL firstLevel=TRUE) | CXTPGridPaintManager |
GetSectionDividerHeight(XTPGridFixedRowsDividerStyle dividerStyle) | CXTPGridPaintManager |
GetTextFont() | CXTPGridPaintManager |
IsColumHotTrackingEnabled() const | CXTPGridPaintManager | virtual
IsColumnPlusMinusSign() const | CXTPGridPaintManager |
IsColumnWidthWYSIWYG() const | CXTPGridPaintManager |
IsDrawGridForEmptySpace() const | CXTPGridPaintManager |
IsFixedInplaceButtonHeight() const | CXTPGridPaintManager |
IsFixedRowHeight() const | CXTPGridPaintManager |
IsGridVisible(BOOL bVertical) const | CXTPGridPaintManager |
IsGridVisible(XTPGridOrientation orientation) const | CXTPGridPaintManager |
IsLastColumnWidthWYSIWYG() const | CXTPGridPaintManager |
IsPreviewMode() const | CXTPGridPaintManager |
IsPrintGroupRowIcon() const | CXTPGridPaintManager |
IsShowWYSIWYGMarkers() const | CXTPGridPaintManager |
IsUseDropMarker() const | CXTPGridPaintManager |
LoadGlyphs() | CXTPTrackThemeOffice2013 | virtual
m_arStartCol | CXTPGridPaintManager |
m_bAllowMergeCells | CXTPGridPaintManager |
m_bBaseTreeIndent | CXTPGridPaintManager |
m_bCleanTooltip | CXTPGridPaintManager |
m_bColumnPlusMinusSign | CXTPGridPaintManager | protected
m_bColumnWidthWYSIWYG | CXTPGridPaintManager | protected
m_bCompactText | CXTPGridPaintManager |
m_bDrawGridForEmptySpace | CXTPGridPaintManager | protected
m_bFixedInplaceButtonHeight | CXTPGridPaintManager | protected
m_bFixedRowHeight | CXTPGridPaintManager | protected
m_bForceDynamicMarkupForCell | CXTPGridPaintManager |
m_bForceShowDropMarker | CXTPGridPaintManager |
m_bForceShowTooltip | CXTPGridPaintManager |
m_bGrayIfDisable | CXTPGridPaintManager |
m_bGroupRowTextBold | CXTPGridPaintManager |
m_bHideSelection | CXTPGridPaintManager |
m_bHotTracking | CXTPGridPaintManager |
m_bInvertColumnOnClick | CXTPGridPaintManager |
m_bIsPreviewMode | CXTPGridPaintManager | protected
m_bLastColumnWidthWYSIWYG | CXTPGridPaintManager | protected
m_bMakeUpper | CXTPGridPaintManager |
m_bMoveScrollbarOnFixedColumnsIndent | CXTPGridPaintManager |
m_bPrintGroupRowIcon | CXTPGridPaintManager | protected
m_bPrintPageRectangle | CXTPGridPaintManager |
m_bPrintSortTriangle | CXTPGridPaintManager |
m_bPrintVirtualPageNumber | CXTPGridPaintManager |
m_bPrintWatermark | CXTPGridPaintManager |
m_bRecOrRowNum | CXTPGridPaintManager |
m_bRevertAlignment | CXTPGridPaintManager |
m_bShadeGroupHeadings | CXTPGridPaintManager |
m_bShadeSortColumn | CXTPGridPaintManager |
m_bShowLockIcon | CXTPGridPaintManager |
m_bShowNonActiveInPlaceButton | CXTPGridPaintManager |
m_bShowWYSIWYGMarkers | CXTPGridPaintManager | protected
m_bSortTriangleOffsetFromRight | CXTPGridPaintManager |
m_bThemedInplaceButtons | CXTPGridPaintManager |
m_bUseAlternativeBackground | CXTPGridPaintManager |
m_bUseDropMarker | CXTPGridPaintManager |
m_bUseEditTextAlignment | CXTPGridPaintManager |
m_bUseGroupRowSelectionState | CXTPGridPaintManager |
m_bUseShellIcon | CXTPGridPaintManager |
m_clrAlternativeBackground | CXTPGridPaintManager |
m_clrBoldText | CXTPGridPaintManager |
m_clrBoldTextHighlight | CXTPGridPaintManager |
m_clrBtnFace | CXTPGridPaintManager |
m_clrBtnFacePressed | CXTPGridPaintManager |
m_clrBtnText | CXTPGridPaintManager |
m_clrCaptionText | CXTPGridPaintManager |
m_clrCaptionTextPressed | CXTPGridPaintManager |
m_clrColumnOffice2007CustomTheme | CXTPGridPaintManager |
m_clrConnector | CXTPGridPaintManager |
m_clrControlBack | CXTPGridPaintManager |
m_clrControlDark | CXTPGridPaintManager |
m_clrControlLightLight | CXTPGridPaintManager |
m_clrDisableBitmapDarkest | CXTPGridPaintManager |
m_clrDisableBitmapLightest | CXTPGridPaintManager |
m_clrFormulaSubSum | CXTPGridPaintManager |
m_clrFormulaSum | CXTPGridPaintManager |
m_clrFreezeColsDivider | CXTPGridPaintManager |
m_clrGlyph | CXTPTrackThemeOffice2013 |
m_clrGlyphHighlight | CXTPTrackThemeOffice2013 |
m_clrGradientColumnSeparator | CXTPGridPaintManager |
m_clrGradientColumnShadow | CXTPGridPaintManager |
m_clrGroupBoxBack | CXTPGridPaintManager |
m_clrGroupRowText | CXTPGridPaintManager |
m_clrGroupShadeBack | CXTPGridPaintManager |
m_clrGroupShadeBorder | CXTPGridPaintManager |
m_clrGroupShadeText | CXTPGridPaintManager |
m_clrHeaderControl | CXTPGridPaintManager |
m_clrHighlight | CXTPGridPaintManager |
m_clrHighlightText | CXTPGridPaintManager |
m_clrHotDivider | CXTPGridPaintManager |
m_clrIndentControl | CXTPGridPaintManager |
m_clrItemShade | CXTPGridPaintManager |
m_clrMarker | CXTPTrackPaintManager |
m_clrMarkerBack | CXTPTrackPaintManager |
m_clrMarkerBorder | CXTPTrackPaintManager |
m_clrPreviewText | CXTPGridPaintManager |
m_clrScrollBarBorderDark | CXTPTrackPaintManager |
m_clrScrollBarBorderLight | CXTPTrackPaintManager |
m_clrScrollBarDark | CXTPTrackPaintManager |
m_clrScrollBarLight | CXTPTrackPaintManager |
m_clrSelectedArea | CXTPTrackPaintManager |
m_clrSelectedBorder | CXTPTrackThemeOffice2013 |
m_clrSelectedRow | CXTPGridPaintManager |
m_clrSelectedRowText | CXTPGridPaintManager |
m_clrTimeHeaderBorder | CXTPTrackPaintManager |
m_clrTimeHeaderDark | CXTPTrackPaintManager |
m_clrTimeHeaderDarkDark | CXTPTrackPaintManager |
m_clrTimeHeaderDivider | CXTPTrackPaintManager |
m_clrTimeLinePosition | CXTPTrackPaintManager |
m_clrTimeLineTick | CXTPTrackPaintManager |
m_clrTimeSliderBackground | CXTPTrackPaintManager |
m_clrTrackHeader | CXTPTrackPaintManager |
m_clrTrackMarkerBorder | CXTPTrackPaintManager |
m_clrTrackMarkerText | CXTPTrackPaintManager |
m_clrTrackMarkerTextBack | CXTPTrackPaintManager |
m_clrTrackMarkerTextBorder | CXTPTrackPaintManager |
m_clrTrackTimeArea | CXTPTrackPaintManager |
m_clrWindowText | CXTPGridPaintManager |
m_clrWorkArea | CXTPTrackPaintManager |
m_clrWorkAreaScrollBarBorder | CXTPTrackPaintManager |
m_clrWorkAreaScrollBarDark | CXTPTrackPaintManager |
m_clrWorkAreaScrollBarLight | CXTPTrackPaintManager |
m_columnStyle | CXTPGridPaintManager | protected
m_crlNoGroupByText | CXTPGridPaintManager |
m_grcGradientColumn | CXTPGridPaintManager |
m_grcGradientColumnHot | CXTPGridPaintManager |
m_grcGradientColumnPushed | CXTPGridPaintManager |
m_iRecOrRowStart | CXTPGridPaintManager |
m_nBaseParentRecordIndent | CXTPGridPaintManager |
m_nFixedColumnsIndent | CXTPGridPaintManager |
m_nFooterHeight | CXTPGridPaintManager | protected
m_nFreezeColsDividerStyle | CXTPGridPaintManager | protected
m_nGridLineStylePreviousH | CXTPGridPaintManager | protected
m_nGridLineStylePreviousV | CXTPGridPaintManager | protected
m_nGroupGridLineHeight | CXTPGridPaintManager | protected
m_nGroupGridLineStyle | CXTPGridPaintManager | protected
m_nHeaderHeight | CXTPGridPaintManager | protected
m_nMaxPreviewLines | CXTPGridPaintManager | protected
m_nResizingWidth | CXTPGridPaintManager | protected
m_nRowHeight | CXTPGridPaintManager | protected
m_nRowHeightDefault | CXTPGridPaintManager |
m_nTextIndentForGroupRowsWithNoIcon | CXTPGridPaintManager |
m_nTreeColumnLineLength | CXTPGridPaintManager |
m_nTreeIndent | CXTPGridPaintManager |
m_nTreeStructureStyle | CXTPGridPaintManager |
m_nTreeTextIndent | CXTPGridPaintManager |
m_nTreeTextIndentGroupRow | CXTPGridPaintManager |
m_nTreeTextIndentRowChildren | CXTPGridPaintManager |
m_nTreeTextIndentRowParent | CXTPGridPaintManager |
m_pControl | CXTPGridPaintManager | protected
m_pGlyphs | CXTPGridPaintManager | protected
m_pHyperlinkHoverStyle | CXTPGridPaintManager |
m_pHyperlinkStyle | CXTPGridPaintManager |
m_pMarkupUIElement_NoGroupBy | CXTPGridPaintManager | protected
m_PrintPageWidth | CXTPGridPaintManager |
m_rcPreviewIndent | CXTPGridPaintManager |
m_RecordNumberWidth | CXTPGridPaintManager |
m_strCollapse | CXTPGridPaintManager |
m_strDecreasing | CXTPGridPaintManager |
m_strExpand | CXTPGridPaintManager |
m_strIncreasing | CXTPGridPaintManager |
m_strMarkupUIElement_NoGroupBy | CXTPGridPaintManager | protected
m_strNoFieldsAvailable | CXTPGridPaintManager |
m_strNoGroupBy | CXTPGridPaintManager |
m_strNoItems | CXTPGridPaintManager |
m_strSortBy | CXTPGridPaintManager |
m_szGlyph | CXTPGridPaintManager | protected
m_themeButton | CXTPGridPaintManager | protected
m_themeCombo | CXTPGridPaintManager | protected
m_themeHeader | CXTPGridPaintManager | protected
m_themeSpin | CXTPGridPaintManager | protected
m_treeStructureStyle | CXTPGridPaintManager |
m_xtpBrushGroupGridLineStyle | CXTPGridPaintManager | protected
m_xtpBrushHorizontalGrid | CXTPGridPaintManager | protected
m_xtpBrushTreeStructure | CXTPGridPaintManager | protected
m_xtpBrushVeriticalGrid | CXTPGridPaintManager | protected
m_xtpFontBoldText | CXTPGridPaintManager |
m_xtpFontCaption | CXTPGridPaintManager |
m_xtpFontPreview | CXTPGridPaintManager |
m_xtpFontText | CXTPGridPaintManager |
OnDrawAction(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs) | CXTPGridPaintManager | virtual
RecalcTotalHightOfMergedRows(CXTPGridColumns *pColumns, CDC *pDC, CXTPGridRow *pRow, int nRowHeight, int nTotalWidth) | CXTPGridPaintManager |
RefreshMetrics() | CXTPTrackThemeVisualStudio2019 | virtual
SetCaptionFont(LOGFONT &lf) | CXTPGridPaintManager |
SetColumnOffice2007CustomThemeBaseColor(COLORREF clrBaseColor) | CXTPGridPaintManager |
SetColumnPlusMinusSign(BOOL bDraw) | CXTPGridPaintManager |
SetColumnWidthWYSIWYG(BOOL bColumnWidthWYSIWYG) | CXTPGridPaintManager |
SetDrawGridForEmptySpace(BOOL bDrawGrid) | CXTPGridPaintManager |
SetFixedRowHeight(BOOL bFixedRowHeight) | CXTPGridPaintManager |
SetFreezeColsDividerStyle(int nStyle) | CXTPGridPaintManager |
SetGridControl(CXTPGridControl *pControl) | CXTPGridPaintManager | virtual
SetHeaderHeight(int nHeight) | CXTPGridPaintManager | virtual
SetInplaceButtonHeight(BOOL bFixedInplaceButtonHeight) | CXTPGridPaintManager |
SetLastColumnWidthWYSIWYG(BOOL bColumnWidthWYSIWYG) | CXTPGridPaintManager |
SetMaxPreviewLines(int nMaxLines) | CXTPGridPaintManager |
SetPreviewIndent(int nLeft, int nTop, int nRight, int nBottom) | CXTPGridPaintManager |
SetPrintGroupRowIcon(BOOL bDraw) | CXTPGridPaintManager |
SetTextFont(LOGFONT &lf) | CXTPGridPaintManager |
ShowWYSIWYGMarkers(BOOL bSet) | CXTPGridPaintManager |
~CXTPGridPaintManager() | CXTPGridPaintManager | virtual
~CXTPTrackPaintManager() | CXTPTrackPaintManager |


Toolkit Pro: XTPChartPieDiagramBase.h Source File

  • Source
  • Chart
  • Styles
  • Pie
  • Base
XTPChartPieDiagramBase.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTPIEDIAGRAMBASE_H__)
24# define __XTPCHARTPIEDIAGRAMBASE_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartDeviceContext;
34class CXTPChartDiagramView;
35class CXTPChartElementView;
36
39class _XTP_EXT_CLASS CXTPChartPieDiagramBaseImpl
40{
41protected:
42 void CalculateSeriesLayout(CXTPChartDeviceContext* pDC, CXTPChartDiagramView* pView);
43};
44
58template<class BaseDiagram>
59class CXTPChartPieDiagramBase
60 : public BaseDiagram
61 , private CXTPChartPieDiagramBaseImpl
62{
63protected:
68 CXTPChartPieDiagramBase();
69
70public:
81 virtual CXTPChartDiagramView* CreateView(CXTPChartDeviceContext* pDC,
82 CXTPChartElementView* pParent) = 0;
83
91 virtual void CalculateSeriesLayout(CXTPChartDeviceContext* pDC, CXTPChartDiagramView* pView);
92};
93
94template<class BaseDiagram>
95AFX_INLINE CXTPChartPieDiagramBase<BaseDiagram>::CXTPChartPieDiagramBase()
96{
97}
98
99template<class BaseDiagram>
100AFX_INLINE void CXTPChartPieDiagramBase<BaseDiagram>::CalculateSeriesLayout(
101 CXTPChartDeviceContext* pDC, CXTPChartDiagramView* pView)
102{
103 CXTPChartPieDiagramBaseImpl::CalculateSeriesLayout(pDC, pView);
104}
105
106typedef CXTPChartPieDiagramBase<CXTPChart2dDiagram> CXTPChart2dPieDiagramBase;
107typedef CXTPChartPieDiagramBase<CXTPChart3dDiagram> CXTPChart3dPieDiagramBase;
109# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
110#endif //#if !defined(__XTPCHARTPIEDIAGRAMBASE_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartDiagramView
This class represents the view of a chart diagram, which is a kind of CXTPChartElementView.
Definition XTPChartDiagramView.h:49
CXTPChartElementView
This class represents the view of a chart element.
Definition XTPChartElementView.h:47
CXTPChartPieDiagramBase
This class abstracts the pie diagram.
Definition XTPChartPieDiagramBase.h:62
CXTPChartPieDiagramBase::CXTPChartPieDiagramBase
CXTPChartPieDiagramBase()
Constructs a CXTPChart2dPieDiagramBase object.
Definition XTPChartPieDiagramBase.h:95
CXTPChartPieDiagramBase::CreateView
virtual CXTPChartDiagramView * CreateView(CXTPChartDeviceContext *pDC, CXTPChartElementView *pParent)=0
Call this function to create the view of the pie diagram.
CXTPChartPieDiagramBase::CalculateSeriesLayout
virtual void CalculateSeriesLayout(CXTPChartDeviceContext *pDC, CXTPChartDiagramView *pView)
Call this function to calculate the pie series layout.
Definition XTPChartPieDiagramBase.h:100


Toolkit Pro: XTPGraphicBitmapPng.h Source File

  • Source
  • GraphicLibrary
XTPGraphicBitmapPng.h
Go to the documentation of this file.
1
23#if !defined(__XTPGRAPHICBITMAPPNG_H__)
24# define __XTPGRAPHICBITMAPPNG_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPGraphicBitmapPng : public CBitmap
39{
40 struct CCallback;
41
42public:
47 CXTPGraphicBitmapPng();
48
49public:
58 BOOL LoadFromFile(LPCTSTR lpszFileName);
59
69 BOOL LoadFromResource(HMODULE hModule, HRSRC hRes);
70
78 BOOL LoadFromFile(CFile* pFile);
79
86 BOOL IsAlpha() const;
87
88private:
89 HBITMAP ConvertToBitmap(BYTE* pbImage, CSize szImage, int cImgChannels) const;
90
91protected:
92 BOOL m_bAlpha;
93};
95AFX_INLINE BOOL CXTPGraphicBitmapPng::IsAlpha() const
96{
97 return m_bAlpha;
98}
106enum XTPZlibCompressionLevel
107{
108 xtpZLibNoCompression = 0,
109 xtpZLibBestSpeed = 1,
110 xtpZLibBestCompression = 9,
111 xtpZLibDefaultCompression = -1
112};
113
129_XTP_EXT_CLASS int AFX_CDECL ZLibCompress(BYTE* dest, ULONG* destLen, const BYTE* source,
130 ULONG sourceLen,
131 XTPZlibCompressionLevel level = xtpZLibDefaultCompression);
132
140_XTP_EXT_CLASS ULONG AFX_CDECL ZLibCompressBound(ULONG sourceLen);
141
153_XTP_EXT_CLASS int AFX_CDECL ZLibUncompress(BYTE* dest, ULONG* destLen, const BYTE* source,
154 ULONG sourceLen);
155
156# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
158#endif // #if !defined(__XTPGRAPHICBITMAPPNG_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
ZLibCompress
_XTP_EXT_CLASS int AFX_CDECL ZLibCompress(BYTE *dest, ULONG *destLen, const BYTE *source, ULONG sourceLen, XTPZlibCompressionLevel level=xtpZLibDefaultCompression)
Compresses a source buffer into a target buffer using the ZLib library.
ZLibCompressBound
_XTP_EXT_CLASS ULONG AFX_CDECL ZLibCompressBound(ULONG sourceLen)
Used before a ZLibCompress call to allocate the destination buffer.
ZLibUncompress
_XTP_EXT_CLASS int AFX_CDECL ZLibUncompress(BYTE *dest, ULONG *destLen, const BYTE *source, ULONG sourceLen)
Decompresses a source buffer into a target buffer, using the ZLib library.
XTPZlibCompressionLevel
XTPZlibCompressionLevel
Possible ZLib compression levels.
Definition XTPGraphicBitmapPng.h:107
xtpZLibDefaultCompression
@ xtpZLibDefaultCompression
Default compression.
Definition XTPGraphicBitmapPng.h:111
xtpZLibBestCompression
@ xtpZLibBestCompression
Best compression.
Definition XTPGraphicBitmapPng.h:110
xtpZLibNoCompression
@ xtpZLibNoCompression
No compression.
Definition XTPGraphicBitmapPng.h:108
xtpZLibBestSpeed
@ xtpZLibBestSpeed
Best speed.
Definition XTPGraphicBitmapPng.h:109
CXTPGraphicBitmapPng
CXTPGraphicBitmapPng is a CBitmap derived class used to load .PNG files from files and resources.
Definition XTPGraphicBitmapPng.h:39
CXTPGraphicBitmapPng::CXTPGraphicBitmapPng
CXTPGraphicBitmapPng()
Default constructor.
CXTPGraphicBitmapPng::LoadFromFile
BOOL LoadFromFile(LPCTSTR lpszFileName)
Call this method to load a .PNG file.
CXTPGraphicBitmapPng::IsAlpha
BOOL IsAlpha() const
Determines if the loaded .PNG file has alpha layer.
CXTPGraphicBitmapPng::m_bAlpha
BOOL m_bAlpha
TRUE if the .PNG file has alpha layer.
Definition XTPGraphicBitmapPng.h:92
CXTPGraphicBitmapPng::LoadFromFile
BOOL LoadFromFile(CFile *pFile)
Call this method to load a .PNG file.
CXTPGraphicBitmapPng::LoadFromResource
BOOL LoadFromResource(HMODULE hModule, HRSRC hRes)
Call this member function to load a .PNG file from a specified resource.


Toolkit Pro: XTPTabThemeVisualStudio2015.h Source File

  • Source
  • TabManager
  • Themes
XTPTabThemeVisualStudio2015.h
Go to the documentation of this file.
1
23#if !defined(__XTPTABTHEMEVISUALSTUDIO2015_H__)
24# define __XTPTABTHEMEVISUALSTUDIO2015_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
37class _XTP_EXT_CLASS CXTPTabThemeVisualStudio2015 : public CXTPTabThemeVisualStudio2012
38{
39public:
44 CXTPTabThemeVisualStudio2015();
45
54 virtual void RefreshMetrics();
55
64 virtual XTPTabColorStyle GetDefaultColorSet()
65 {
66 return xtpTabColorVisualStudio2015;
67 }
68};
69
70# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
72#endif // __XTPTABTHEMEVISUALSTUDIO2015_H__
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPTabColorStyle
XTPTabColorStyle
XTPTabColorStyle is an enumeration used to set the color style of tabs.
Definition XTPTabManagerDefines.h:139
xtpTabColorVisualStudio2015
@ xtpTabColorVisualStudio2015
Tabs will use the Visual Studio 2015 color style for the currently set Appearance.
Definition XTPTabManagerDefines.h:166
CXTPTabThemeVisualStudio2012
CXTPTabThemeVisualStudio2012 implements a Visual Studio 2012 tab appearance.
Definition XTPTabThemeVisualStudio2012.h:38
CXTPTabThemeVisualStudio2015
CXTPTabThemeVisualStudio2015 implements a Visual Studio 2015 tab appearance.
Definition XTPTabThemeVisualStudio2015.h:38
CXTPTabThemeVisualStudio2015::GetDefaultColorSet
virtual XTPTabColorStyle GetDefaultColorSet()
Gets the default value of the color set for this theme.
Definition XTPTabThemeVisualStudio2015.h:64
CXTPTabThemeVisualStudio2015::CXTPTabThemeVisualStudio2015
CXTPTabThemeVisualStudio2015()
Constructs a CXTPTabThemeVisualStudio2015 object.
CXTPTabThemeVisualStudio2015::RefreshMetrics
virtual void RefreshMetrics()
Refreshes the appearance metrics.


Toolkit Pro: Member List

CXTPTaskPanelShortcutBarOffice2007Theme Member List

This is the complete list of members for CXTPTaskPanelShortcutBarOffice2007Theme, including all inherited members.

BlendColor(COLORREF clrFrom, COLORREF clrTo, int nAlpha) | CXTPTaskPanelPaintManager | protected
CreateGripperBitmaps() | CXTPTaskPanelPaintManager | protected
CreateGripperIcon(HICON &hIcon, UINT nIDResource, COLORREF clrGripperBack) | CXTPTaskPanelPaintManager | protected
CXTPTaskPanelListViewOffice2003Theme() | CXTPTaskPanelListViewOffice2003Theme |
CXTPTaskPanelListViewOfficeXPTheme() | CXTPTaskPanelListViewOfficeXPTheme |
CXTPTaskPanelListViewTheme() | CXTPTaskPanelListViewTheme |
CXTPTaskPanelPaintManager() | CXTPTaskPanelPaintManager |
CXTPTaskPanelPaintManagerPlain() | CXTPTaskPanelPaintManagerPlain |
CXTPTaskPanelShortcutBarOffice2003Theme() | CXTPTaskPanelShortcutBarOffice2003Theme |
CXTPTaskPanelShortcutBarOffice2007Theme() | CXTPTaskPanelShortcutBarOffice2007Theme |
CXTPTaskPanelToolboxTheme() | CXTPTaskPanelToolboxTheme |
DrawCaptionGripper(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelPaintManager | protectedvirtual
DrawCaptionGripperBitmap(CDC *pDC, CXTPTaskPanelGroup *pGroup, BOOL bExpanded, BOOL bHot, CRect rc) | CXTPTaskPanelPaintManager | protected
DrawCaptionGripperSigns(CDC *pDC, CPoint pt, COLORREF clr, BOOL bExpanded) | CXTPTaskPanelPaintManager | protected
DrawDragArrow(CDC *pDC, CXTPTaskPanelItem *pItem, CRect rc, BOOL bAfter=FALSE) | CXTPTaskPanelPaintManager | protectedvirtual
DrawFocusRect(CDC *pDC, CRect rc) | CXTPTaskPanelPaintManager | protectedvirtual
DrawGroupCaption(CDC *pDC, CXTPTaskPanelGroup *pGroup, BOOL bDraw) | CXTPTaskPanelToolboxTheme | virtual
DrawGroupCaptionBackground(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelShortcutBarOffice2007Theme | protectedvirtual
DrawGroupClient(CDC *pDC, CXTPTaskPanelGroup *pGroup) | CXTPTaskPanelPaintManager | virtual
DrawGroupClientFace(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelShortcutBarOffice2007Theme | protectedvirtual
DrawGroupClientItems(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelPaintManager | protectedvirtual
DrawGroupItem(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw) | CXTPTaskPanelPaintManager | virtual
DrawGroupItemFrame(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc) | CXTPTaskPanelShortcutBarOffice2007Theme | protectedvirtual
DrawGroupItemImage(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw) | CXTPTaskPanelPaintManager | protected
DrawGroupItemImageWithText(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw) | CXTPTaskPanelPaintManager | protected
DrawGroupItemImageWithTextBelow(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw) | CXTPTaskPanelPaintManager | protected
DrawItemCaption(CDC *pDC, CXTPTaskPanelItem *pItem, CRect rcText, UINT nFormat) | CXTPTaskPanelPaintManager | protectedvirtual
DrawItemImage(CDC *pDC, CXTPTaskPanelItem *pItem, CPoint ptIcon, CXTPImageManagerIcon *pImage, CSize szIcon) | CXTPTaskPanelPaintManager | protectedvirtual
DrawScrollButton(CDC *pDC, CXTPTaskPanelScrollButton *pScrollButton) | CXTPTaskPanelPaintManager | virtual
FillGroupClientFace(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelShortcutBarOffice2007Theme | protectedvirtual
FillTaskPanel(CDC *pDC, CXTPTaskPanel *pTaskPanel) | CXTPTaskPanelShortcutBarOffice2007Theme | protectedvirtual
FreeBitmaps() | CXTPTaskPanelPaintManager | protected
GetCaptionGripperWidth(CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelPaintManager | protectedvirtual
GetControlMargins(const CXTPTaskPanel *pPanel) | CXTPTaskPanelPaintManager | virtual
GetGroupColors(BOOL bSpecial) | CXTPTaskPanelPaintManager |
GetGroupColors(CXTPTaskPanelGroup *pGroup) | CXTPTaskPanelPaintManager | virtual
GetGroupInnerMargins(const CXTPTaskPanelGroup *pGroup) | CXTPTaskPanelPaintManager | virtual
GetGroupOuterMargins(const CXTPTaskPanelGroup *pGroup) | CXTPTaskPanelPaintManager | virtual
GetGroupSpacing(const CXTPTaskPanel *pPanel) | CXTPTaskPanelPaintManager | virtual
GetHighlightOffset(CXTPTaskPanelGroupItem *pItem) | CXTPTaskPanelPaintManager | protectedvirtual
GetItemFont(CXTPTaskPanelItem *pItem) | CXTPTaskPanelPaintManager | virtual
GetItemIconPadding(const CXTPTaskPanelItem *pItem) | CXTPTaskPanelPaintManager | virtual
GetItemInnerMargins(const CXTPTaskPanelGroupItem *pItem) | CXTPTaskPanelPaintManager | virtual
GetItemOuterMargins(const CXTPTaskPanelGroupItem *pItem) | CXTPTaskPanelPaintManager | virtual
m_bBoldCaption | CXTPTaskPanelPaintManager |
m_bCaptionScrollButton | CXTPTaskPanelPaintManager |
m_bEmbossedDisabledText | CXTPTaskPanelPaintManager |
m_bEmulateEplorerTheme | CXTPTaskPanelPaintManager |
m_bInvertDragRect | CXTPTaskPanelPaintManager |
m_bLeftRoundedCorner | CXTPTaskPanelPaintManager | protected
m_bmpGrippers | CXTPTaskPanelPaintManager | protected
m_bOfficeBorder | CXTPTaskPanelPaintManager | protected
m_bOfficeCaption | CXTPTaskPanelPaintManagerPlain | protected
m_bOfficeHighlight | CXTPTaskPanelPaintManager |
m_bRightRoundedCorner | CXTPTaskPanelPaintManager | protected
m_bRoundedFrame | CXTPTaskPanelPaintManagerPlain | protected
m_bUseBitmapGrippers | CXTPTaskPanelPaintManager | protected
m_bUseStandardCaptionFont | CXTPTaskPanelPaintManager | protected
m_bUseStandardItemsFont | CXTPTaskPanelPaintManager | protected
m_clrBackground | CXTPTaskPanelPaintManager | protected
m_clrHighlightBorder | CXTPTaskPanelPaintManager | protected
m_clrHighlightHot | CXTPTaskPanelPaintManager | protected
m_clrHighlightPressed | CXTPTaskPanelPaintManager | protected
m_clrHighlightSelected | CXTPTaskPanelPaintManager | protected
m_clrShortcutItemShadow | CXTPTaskPanelShortcutBarOffice2007Theme | protected
m_eGripper | CXTPTaskPanelPaintManager |
m_grcHot | CXTPTaskPanelListViewOffice2003Theme |
m_grcPushed | CXTPTaskPanelListViewOffice2003Theme |
m_groupNormal | CXTPTaskPanelPaintManager | protected
m_groupSpecial | CXTPTaskPanelPaintManager | protected
m_hGripperNormal | CXTPTaskPanelPaintManager | protected
m_hGripperSpecial | CXTPTaskPanelPaintManager | protected
m_nCaptionHeight | CXTPTaskPanelPaintManager | protected
m_nCaptionTextFormat | CXTPTaskPanelPaintManager | protected
m_nGroupSpacing | CXTPTaskPanelPaintManager |
m_nItemTextFormat | CXTPTaskPanelPaintManager | protected
m_rcControlMargins | CXTPTaskPanelPaintManager |
m_rcGroupIconPadding | CXTPTaskPanelPaintManager |
m_rcGroupInnerMargins | CXTPTaskPanelPaintManager |
m_rcGroupOuterMargins | CXTPTaskPanelPaintManager |
m_rcImageLayoutIconPadding | CXTPTaskPanelPaintManager |
m_rcItemIconPadding | CXTPTaskPanelPaintManager |
m_rcItemInnerMargins | CXTPTaskPanelPaintManager |
m_rcItemOuterMargins | CXTPTaskPanelPaintManager |
m_xtpFontCaption | CXTPTaskPanelPaintManager | protected
m_xtpFontIcon | CXTPTaskPanelPaintManager | protected
m_xtpFontIconBold | CXTPTaskPanelPaintManager | protected
m_xtpFontIconHot | CXTPTaskPanelPaintManager | protected
m_xtpFontIconHotBold | CXTPTaskPanelPaintManager | protected
Rectangle(CDC *pDC, CRect rc, COLORREF clrPen, COLORREF clrBrush) | CXTPTaskPanelPaintManager | protected
rectDefault | CXTPTaskPanelPaintManager | static
RefreshMetrics() | CXTPTaskPanelShortcutBarOffice2007Theme | virtual
SetCaptionFontIndirect(LOGFONT *pLogFont, BOOL bUseStandardCaptionFont=FALSE) | CXTPTaskPanelPaintManager |
SetItemsFontIndirect(LOGFONT *pLogFont, BOOL bUseStandardItemsFont=FALSE) | CXTPTaskPanelPaintManager |
SetTextFormat(int nTextFormat, BOOL bCaption=FALSE) | CXTPTaskPanelPaintManager |
~CXTPTaskPanelPaintManager() | CXTPTaskPanelPaintManager | virtual


Toolkit Pro: Member List

CXTPControlSelector Member List

This is the complete list of members for CXTPControlSelector, including all inherited members.

AssignDocTemplate(UINT nIDResource) | CXTPControl |
ClickToolBarButton(CRect rcActiveRect=CRect(0, 0, 0, 0)) | CXTPControl | protected
Compare(CXTPControl *pOther) | CXTPControl | virtual
Copy(CXTPControl *pControl, BOOL bRecursive=FALSE) | CXTPControlSelector | protectedvirtual
CustomizeStartDrag(CPoint point) | CXTPControl | protectedvirtual
CustomizeStartResize(CPoint point) | CXTPControl | protectedvirtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPControl() | CXTPControl | protected
CXTPControlSelector() | CXTPControlSelector |
DelayLayoutParent() | CXTPControl |
DelayRedrawParent() | CXTPControl |
DoCustomDragOver(CXTPCommandBar *pCommandBar, CPoint point, DROPEFFECT &dropEffect) | CXTPControl | protectedvirtual
DoPropExchange(CXTPPropExchange *pPX) | CXTPControlSelector | protectedvirtual
Draw(CDC *pDC) | CXTPControlSelector | protectedvirtual
ExcludeDocTemplate(UINT nIDResource) | CXTPControl |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
FromUI(CCmdUI *pCmdUI) | CXTPControl | static
GenerateCommandBarList(DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam) | CXTPControl | protectedvirtual
GetAction() const | CXTPControl |
GetBeginGroup() const | CXTPControl |
GetButtonSize() const | CXTPControl | virtual
GetCaption() const | CXTPControl | virtual
GetCategory() const | CXTPControl |
GetChecked() const | CXTPControl |
GetCloseSubMenuOnClick() const | CXTPControl |
GetCommandBar() const | CXTPControl | virtual
GetControls() const | CXTPControl |
GetCustomizeMinHeight() const | CXTPControl | protectedvirtual
GetCustomizeMinWidth() const | CXTPControl | protectedvirtual
GetCustomShortcutText() const | CXTPControl |
GetDescription() const | CXTPControl | virtual
GetEnabled() const | CXTPControl |
GetExecuteOnPressInterval() const | CXTPControl |
GetExpanded() const | CXTPControl |
GetFlags() const | CXTPControl |
GetHeight() const | CXTPControl |
GetHelpId() const | CXTPControl |
GetHideFlags() const | CXTPControl |
GetIconId() const | CXTPControl |
GetIconSize() const | CXTPControl | virtual
GetID() const | CXTPControl |
GetImage(int nWidth=16) const | CXTPControl | virtual
GetImageManager() const | CXTPControl |
GetIndex() const | CXTPControl |
GetKeyboardTip() const | CXTPControl |
GetPaintManager() const | CXTPControl |
GetParameter() const | CXTPControl |
GetParent() const | CXTPControl |
GetPopuped() const | CXTPControl | virtual
GetPressed() const | CXTPControl | virtual
GetRect() const | CXTPControl |
GetRibbonGroup() const | CXTPControl |
GetRowRect() const | CXTPControl |
GetSelected() const | CXTPControl | virtual
GetShortcutText() const | CXTPControl |
GetSize(CDC *pDC) | CXTPControlSelector | protectedvirtual
GetStyle() const | CXTPControl |
GetTag() const | CXTPControl |
GetTooltip() const | CXTPControl | virtual
GetType() const | CXTPControl |
GetWidth() const | CXTPControl |
GetWrap() const | CXTPControl |
HasDwmCompositedRect() const | CXTPControl |
IsCaptionVisible() const | CXTPControl | virtual
IsCursorOver() const | CXTPControl |
IsCustomizeMode() const | CXTPControl | protected
IsCustomizeMovable() const | CXTPControl | virtual
IsCustomizeResizeAllow() const | CXTPControl | protectedvirtual
IsFocusable() const | CXTPControl | protectedvirtual
IsFocused() const | CXTPControl | virtual
IsItemDefault() const | CXTPControl |
IsLayoutChanged() | CXTPControl | protected
IsLayoutRTL() const | CXTPControl | protected
IsOnQuickAccess() const | CXTPControl |
IsTemporary() const | CXTPControl |
IsTransparent() const | CXTPControl | inlinevirtual
IsVisible(DWORD dwSkipFlags=0) const | CXTPControl | virtual
m_bBeginGroup | CXTPControl | protected
m_bChecked | CXTPControl | protected
m_bCloseSubMenuOnClick | CXTPControl | protected
m_bDefaultItem | CXTPControl | protected
m_bEnabled | CXTPControl | protected
m_bExpanded | CXTPControl | protected
m_bLayoutRTL | CXTPControl | protected
m_bOnQuickAccess | CXTPControl | protected
m_bPressed | CXTPControl | protected
m_bSelected | CXTPControl | protected
m_bTemporary | CXTPControl | protected
m_buttonCustomStyle | CXTPControl | protected
m_buttonRibbonStyle | CXTPControl | protected
m_buttonStyle | CXTPControl | protected
m_bWrap | CXTPControl | protected
m_controlType | CXTPControl | protected
m_dwFlags | CXTPControl | protected
m_dwHideFlags | CXTPControl | protected
m_mapDocTemplatesAssigned | CXTPControl | protected
m_mapDocTemplatesExcluded | CXTPControl | protected
m_nCustomIconId | CXTPControl | protected
m_nExecuteOnPressInterval | CXTPControl | protected
m_nHeight | CXTPControl | protected
m_nHelpId | CXTPControl | protected
m_nIconId | CXTPControl | protected
m_nId | CXTPControl | protected
m_nIndex | CXTPControl | protected
m_nTag | CXTPControl | protected
m_nWidth | CXTPControl | protected
m_pAction | CXTPControl | protected
m_pControls | CXTPControl | protected
m_pParent | CXTPControl | protected
m_pRibbonGroup | CXTPControl | protected
m_rcControl | CXTPControl | protected
m_rcRow | CXTPControl | protected
m_strCaption | CXTPControl | protected
m_strCategory | CXTPControl | protected
m_strCustomCaption | CXTPControl | protected
m_strDescriptionText | CXTPControl | protected
m_strKeyboardTip | CXTPControl | protected
m_strParameter | CXTPControl | protected
m_strShortcutText | CXTPControl | protected
m_strShortcutTextAuto | CXTPControl | protected
m_strTooltipText | CXTPControl | protected
m_szIcon | CXTPControl | protected
m_szItem | CXTPControlSelector |
m_szItemsActive | CXTPControlSelector |
m_szItemsCount | CXTPControlSelector |
m_szItemsMax | CXTPControlSelector |
m_szItemsVisible | CXTPControlSelector |
m_szResult | CXTPControlSelector |
NotifySite(UINT code) | CXTPControl |
NotifySite(UINT code, NMXTPCONTROL *pNM) | CXTPControl |
NotifySite(CWnd *pSite, UINT code, NMXTPCONTROL *pNM) | CXTPControl |
OnActionChanged(int nProperty) | CXTPControl | protectedvirtual
OnActionChanging(int nProperty) | CXTPControl | protectedvirtual
OnCalcDynamicSize(DWORD dwMode) | CXTPControlSelector | protectedvirtual
OnCaptionChanged() | CXTPControl | protectedvirtual
OnClick(BOOL bKeyboard=FALSE, CPoint pt=CPoint(0, 0)) | CXTPControl | virtual
OnCustomizeDragOver(CXTPControl *pDataObject, CPoint point, DROPEFFECT &dropEffect) | CXTPControl | protectedvirtual
OnCustomizeMouseMove(CPoint point) | CXTPControl | protected
OnDrawItem(CDC *pDC, CRect rcItem, COLORREF clrText) | CXTPControlSelector | protectedvirtual
OnEnabledChanged() | CXTPControl | virtual
OnExecute() | CXTPControl | virtual
OnHookKeyDown(UINT nChar, LPARAM lParam) | CXTPControl | protectedvirtual
OnHookMouseWheel(UINT nFlags, short zDelta, CPoint point) | CXTPControl | protectedvirtual
OnIdleUpdate() | CXTPControl | protectedvirtual
OnLButtonDblClk(CPoint point) | CXTPControl | protectedvirtual
OnLButtonDown(CPoint point) | CXTPControl | protectedvirtual
OnLButtonUp(CPoint point) | CXTPControlSelector | protectedvirtual
OnMouseHover() | CXTPControl | protectedvirtual
OnMouseMove(CPoint point) | CXTPControlSelector | protectedvirtual
OnRButtonDown(CPoint point) | CXTPControl | protectedvirtual
OnRButtonUp(CPoint point) | CXTPControl | protectedvirtual
OnRemoved() | CXTPControl | protectedvirtual
OnSetPopup(BOOL bPopup) | CXTPControl | protectedvirtual
OnSetSelected(int bSelected) | CXTPControlSelector | protectedvirtual
OnThemeChanged() | CXTPControl | virtual
OnToolHitTest(CPoint point, TOOLINFO *pTI) const | CXTPControl | protectedvirtual
OnUnderlineActivate() | CXTPControl | virtual
RedrawParent(BOOL bAnimate=TRUE) | CXTPControl |
Reset() | CXTPControl |
RestoreCommandBarList(CXTPCommandBarList *pCommandBarList) | CXTPControl | protectedvirtual
ScreenToClient(CPoint *point) | CXTPControl | protected
SetAction(CXTPControlAction *pAction) | CXTPControl | virtual
SetBeginGroup(BOOL bBeginGroup) | CXTPControl | virtual
SetCaption(LPCTSTR lpszCaption) | CXTPControl |
SetCaption(UINT nIDCaption) | CXTPControl |
SetCategory(LPCTSTR lpszCategory) | CXTPControl |
SetChecked(BOOL bChecked) | CXTPControl | virtual
SetCloseSubMenuOnClick(BOOL bCloseOnClick) | CXTPControl |
SetCustomIcon(HICON hIcon) | CXTPControl |
SetCustomShortcutText(LPCTSTR lpszCustomShortcutText) | CXTPControl |
SetDescription(LPCTSTR lpszDescription) | CXTPControl |
SetEnabled(BOOL bEnabled) | CXTPControl | virtual
SetExecuteOnPressInterval(int nExecuteOnPressInterval) | CXTPControl |
SetExpanded(BOOL bExpanded) | CXTPControl | protected
SetFlags(DWORD dwFlags) | CXTPControl |
SetFocused(BOOL bFocused) | CXTPControl | virtual
SetHeight(int nHeight) | CXTPControl | virtual
SetHelpId(int nId) | CXTPControl |
SetHideFlag(XTPControlHideFlags dwFlag, BOOL bSet) | CXTPControl |
SetHideFlags(DWORD dwFlags) | CXTPControl | virtual
SetHideWrap(BOOL bHide) | CXTPControl |
SetIconId(int nId) | CXTPControl |
SetIconSize(CSize szIcon) | CXTPControl |
SetID(int nId) | CXTPControl |
SetIndex(int nIndex) | CXTPControl | inlineprotected
SetItemDefault(BOOL bDefault) | CXTPControl |
SetItemsActive(CSize szActive, BOOL bNotify=FALSE) | CXTPControlSelector | protected
SetKeyboardTip(LPCTSTR lpszKeyboardTip) | CXTPControl |
SetOnQuickAccess(BOOL bOnQuicAccess=FALSE) | CXTPControl |
SetParameter(LPCTSTR lpszParameter) | CXTPControl |
SetParent(CXTPCommandBar *pParent) | CXTPControl | inlineprotectedvirtual
SetPressed(BOOL bPressed) | CXTPControl |
SetPrompt(LPCTSTR lpszPrompt) | CXTPControl |
SetRect(CRect rcControl) | CXTPControl | virtual
SetRowRect(CRect rcRow) | CXTPControl |
SetShortcutText(LPCTSTR lpszShortcutText) | CXTPControl |
SetStyle(XTPButtonStyle buttonStyle) | CXTPControl |
SetTag(DWORD_PTR dwTag) | CXTPControl |
SetTooltip(LPCTSTR lpszTooltip) | CXTPControl |
SetVisible(BOOL bVisible) | CXTPControl |
SetWidth(int nWidth) | CXTPControl | virtual
SetWrap(BOOL bWrap) | CXTPControl |
~CXTPControl() | CXTPControl | protectedvirtual


Toolkit Pro: Member List

XTP_CALENDAR_GETITEMTEXT_PARAMS Member List

This is the complete list of members for XTP_CALENDAR_GETITEMTEXT_PARAMS, including all inherited members.

nItem | XTP_CALENDAR_GETITEMTEXT_PARAMS
nWeekDay | XTP_CALENDAR_GETITEMTEXT_PARAMS
nWeekNum | XTP_CALENDAR_GETITEMTEXT_PARAMS
pstrText | XTP_CALENDAR_GETITEMTEXT_PARAMS
pViewDay | XTP_CALENDAR_GETITEMTEXT_PARAMS
pViewEvent | XTP_CALENDAR_GETITEMTEXT_PARAMS


Toolkit Pro: XTPDockingPanePanelColorSetNativeWindows10.h Source File

  • Source
  • DockingPane
  • TabColorSets
XTPDockingPanePanelColorSetNativeWindows10.h
Go to the documentation of this file.
1
23#if !defined(__XTPDOCKINGPANEPANELCOLORSETNATIVEWINDOWS10_H__)
24# define __XTPDOCKINGPANEPANELCOLORSETNATIVEWINDOWS10_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPDockingPanePanelColorSetNativeWindows10
39 : public CXTPDockingPanePanelColorSet2012
40{
41public:
46 CXTPDockingPanePanelColorSetNativeWindows10();
47
53 virtual void RefreshMetrics();
54};
55
56# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
58#endif // !defined(__XTPDOCKINGPANEPANELCOLORSETNATIVEWINDOWS10_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPDockingPanePanelColorSet2012
Helper class used to initialize default colors for a theme from an .INI resource and handle drawing r...
Definition XTPDockingPanePanelColorSet2012.h:39
CXTPDockingPanePanelColorSetNativeWindows10
Helper class used to initialize default colors for a theme from an .INI resource and handle drawing r...
Definition XTPDockingPanePanelColorSetNativeWindows10.h:40
CXTPDockingPanePanelColorSetNativeWindows10::CXTPDockingPanePanelColorSetNativeWindows10
CXTPDockingPanePanelColorSetNativeWindows10()
Default class constructor.
CXTPDockingPanePanelColorSetNativeWindows10::RefreshMetrics
virtual void RefreshMetrics()
This member function is used to initialize default colors for a theme from an .INI resource.


Toolkit Pro: XTPControlProgress.h Source File

  • Source
  • CommandBars
XTPControlProgress.h
Go to the documentation of this file.
1
23#if !defined(__XTPCONTOLPROGRESS_H__)
24# define __XTPCONTOLPROGRESS_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPProgressPaintManager;
34
40class _XTP_EXT_CLASS CXTPControlProgress
41 : public CXTPControl
42 , public CXTPProgressBase
43{
45 DECLARE_XTP_CONTROL(CXTPControlProgress)
47public:
52 CXTPControlProgress();
53
54protected:
62 virtual CSize GetSize(CDC* pDC);
63
69 virtual void Draw(CDC* pDC);
70
71protected:
76 virtual void RedrawProgress();
77
84 virtual CXTPProgressPaintManager* GetProgressPaintManager() const;
85
92 virtual CRect GetProgressRect();
93
100 virtual void OnClick(BOOL bKeyboard = FALSE, CPoint pt = CPoint(0, 0));
101
102protected:
109 void Copy(CXTPControl* pControl, BOOL bRecursive = FALSE);
110
116 void DoPropExchange(CXTPPropExchange* pPX);
117
118# ifdef _XTP_COMMANDBARS_ACTIVEX
121 DECLARE_DISPATCH_MAP()
122 DECLARE_INTERFACE_MAP()
123
124 DECLARE_OLETYPELIB_EX(CXTPControlProgress);
125 afx_msg void OleRangeChanged();
126 afx_msg void OleSetPos(int nPos);
127 afx_msg int OleGetPos();
129# endif
130};
132AFX_INLINE int CXTPProgressBase::GetPos() const
133{
134 return m_nPos;
135}
136
137# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
138#endif //#if !defined(__XTPCONTOLPROGRESS_H__)
DECLARE_XTP_CONTROL
#define DECLARE_XTP_CONTROL(class_name)
This macro generates the C++ header code necessary for a CXTPControl-derived class that can be serial...
Definition XTPCommandBarsDefines.h:1169
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPControl
CXTPControl is a CXTPCmdTarget derived class.
Definition XTPControl.h:841
CXTPControlProgress
CXTPControlProgress is a CXTPControl derived class.
Definition XTPControlProgress.h:43
CXTPControlProgress::Copy
void Copy(CXTPControl *pControl, BOOL bRecursive=FALSE)
This method makes a copy of the progress bar.
CXTPControlProgress::DoPropExchange
void DoPropExchange(CXTPPropExchange *pPX)
Either reads this object from or writes this object to an archive.
CXTPControlProgress::GetProgressRect
virtual CRect GetProgressRect()
Call this member to get the bounding rectangle of the control.
CXTPControlProgress::GetProgressPaintManager
virtual CXTPProgressPaintManager * GetProgressPaintManager() const
Call this member to retrieve the paint manager of the progress bar.
CXTPControlProgress::RedrawProgress
virtual void RedrawProgress()
Call this member to redraw the progress bar.
CXTPControlProgress::OnClick
virtual void OnClick(BOOL bKeyboard=FALSE, CPoint pt=CPoint(0, 0))
This method is called when the user clicks the control.
CXTPControlProgress::Draw
virtual void Draw(CDC *pDC)
This method is called to draw the control.
CXTPControlProgress::CXTPControlProgress
CXTPControlProgress()
Constructs a CXTPControlProgress object.
CXTPControlProgress::GetSize
virtual CSize GetSize(CDC *pDC)
This method is called to determine the size of the control.
CXTPProgressBase
CXTPControlProgressBase is base class for all progress objects.
Definition XTPProgressBase.h:40
CXTPProgressBase::m_nPos
int m_nPos
Current position.
Definition XTPProgressBase.h:113
CXTPProgressBase::GetPos
int GetPos() const
Gets the current position of the progress bar, whose return value is always between the values for th...
CXTPProgressPaintManager
CXTPProgressPaintManager object.
Definition XTPProgressPaintManager.h:41
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72


Toolkit Pro: Member List

CXTPDatePickerThemeResource Member List

This is the complete list of members for CXTPDatePickerThemeResource, including all inherited members.

CalcDayOfWeekRect(CDC *pDC) | CXTPDatePickerPaintManager | virtual
CalcDayRect(CDC *pDC) | CXTPDatePickerPaintManager | virtual
CalcMonthHeaderRect(CDC *pDC) | CXTPDatePickerPaintManager | virtual
CalcMonthRect(CDC *pDC) | CXTPDatePickerPaintManager | virtual
CalcWeekNumbersRect(CDC *pDC) | CXTPDatePickerPaintManager | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPDatePickerPaintManager() | CXTPDatePickerPaintManager |
CXTPDatePickerThemeResource() | CXTPDatePickerThemeResource |
DrawBackground(CDC *pDC, CRect rcClient) | CXTPDatePickerPaintManager | virtual
DrawBorder(CDC *pDC, const CXTPDatePickerControl *pControl, CRect &rcClient, BOOL bDraw) | CXTPDatePickerPaintManager | virtual
DrawButton(CDC *pDC, const CRect &rcButton, const CString &strButton, BOOL bIsDown, BOOL bIsHighLight) | CXTPDatePickerThemeResource | virtual
DrawDay(CDC *pDC, CXTPDatePickerItemDay *pDay) | CXTPDatePickerPaintManager | virtual
DrawDaysOfWeek(CDC *pDC, CXTPDatePickerItemMonth *pMonth) | CXTPDatePickerPaintManager | virtual
DrawMonthHeader(CDC *pDC, CXTPDatePickerItemMonth *pMonth) | CXTPDatePickerPaintManager | virtual
DrawScrollTriangle(CDC *pDC, CRect rcSpot, BOOL bLeftDirection, COLORREF clrColor=0, BOOL bYears=FALSE) | CXTPDatePickerPaintManager | virtual
DrawWeekNumbers(CDC *pDC, CXTPDatePickerItemMonth *pMonth) | CXTPDatePickerPaintManager | virtual
EnableTheme(BOOL bEnableTheme) | CXTPDatePickerPaintManager | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetButtonFont() | CXTPDatePickerPaintManager |
GetControlBackColor() | CXTPDatePickerPaintManager | virtual
GetCursorBack() | CXTPDatePickerPaintManager | virtual
GetDayBackColor() | CXTPDatePickerPaintManager | virtual
GetDaysOfWeekBackColor() | CXTPDatePickerPaintManager | virtual
GetDaysOfWeekTextColor() | CXTPDatePickerPaintManager | virtual
GetDaysOfWeekTextFont() | CXTPDatePickerPaintManager |
GetDayTextColor() | CXTPDatePickerPaintManager | virtual
GetDayTextFont() | CXTPDatePickerPaintManager | virtual
GetDayTextFontBold() | CXTPDatePickerPaintManager | virtual
GetHeaderTextFont() | CXTPDatePickerPaintManager |
GetHighlightTodayColor() | CXTPDatePickerPaintManager | virtual
GetListControlBackColor() | CXTPDatePickerPaintManager | virtual
GetListControlTextColor() | CXTPDatePickerPaintManager | virtual
GetListControlTextFont() | CXTPDatePickerPaintManager |
GetMonthHeaderBackColor() | CXTPDatePickerPaintManager | virtual
GetMonthHeaderTextColor() | CXTPDatePickerPaintManager | virtual
GetNonMonthDayBackColor() | CXTPDatePickerPaintManager | virtual
GetNonMonthDayTextColor() | CXTPDatePickerPaintManager | virtual
GetNonMonthDayTextFont() | CXTPDatePickerPaintManager |
GetPaintTheme() const | CXTPDatePickerPaintManager | protected
GetResourceColor(LPCTSTR pcszColorName, COLORREF clrDefault) | CXTPDatePickerThemeResource | protected
GetSelectedDayBackColor() | CXTPDatePickerPaintManager | virtual
GetSelectedDayTextColor() | CXTPDatePickerPaintManager | virtual
GetWeekNumbersBackColor() | CXTPDatePickerPaintManager | virtual
GetWeekNumbersTextColor() | CXTPDatePickerPaintManager | virtual
GetWeekNumbersTextFont() | CXTPDatePickerPaintManager |
m_bEnableTheme | CXTPDatePickerPaintManager | protected
m_clr3DFace | CXTPDatePickerPaintManager | protected
m_clr3DLight | CXTPDatePickerPaintManager | protected
m_clr3DShadow | CXTPDatePickerPaintManager | protected
m_clr3DText | CXTPDatePickerPaintManager | protected
m_clrButtonFace | CXTPDatePickerPaintManager |
m_clrButtonText | CXTPDatePickerPaintManager |
m_clrControlBack | CXTPDatePickerPaintManager |
m_clrDayBack | CXTPDatePickerPaintManager |
m_clrDaysOfWeekBack | CXTPDatePickerPaintManager |
m_clrDaysOfWeekText | CXTPDatePickerPaintManager |
m_clrDayText | CXTPDatePickerPaintManager |
m_clrHighlightToday | CXTPDatePickerPaintManager |
m_clrListControlBack | CXTPDatePickerPaintManager |
m_clrListControlText | CXTPDatePickerPaintManager |
m_clrMonthBorder | CXTPDatePickerPaintManager |
m_clrMonthHeaderBack | CXTPDatePickerPaintManager |
m_clrMonthHeaderButton | CXTPDatePickerPaintManager |
m_clrMonthHeaderText | CXTPDatePickerPaintManager |
m_clrNonMonthDayBack | CXTPDatePickerPaintManager |
m_clrNonMonthDayText | CXTPDatePickerPaintManager |
m_clrSelectedDayBack | CXTPDatePickerPaintManager |
m_clrSelectedDayText | CXTPDatePickerPaintManager |
m_clrStaticBorder | CXTPDatePickerPaintManager | protected
m_clrWeekNumbersBack | CXTPDatePickerPaintManager |
m_clrWeekNumbersText | CXTPDatePickerPaintManager |
m_hCursorBack | CXTPDatePickerPaintManager | protected
m_nPaintTheme | CXTPDatePickerPaintManager | protected
m_szDayMargin | CXTPDatePickerPaintManager |
m_themeButton | CXTPDatePickerPaintManager | protected
m_xtpFontButton | CXTPDatePickerPaintManager | protected
m_xtpFontDay | CXTPDatePickerPaintManager | protected
m_xtpFontDayBold | CXTPDatePickerPaintManager | protected
m_xtpFontDaysOfWeek | CXTPDatePickerPaintManager | protected
m_xtpFontHeader | CXTPDatePickerPaintManager | protected
m_xtpFontListControl | CXTPDatePickerPaintManager | protected
m_xtpFontNonMonthDay | CXTPDatePickerPaintManager | protected
m_xtpFontWeekNumbers | CXTPDatePickerPaintManager | protected
RefreshMetrics() | CXTPDatePickerThemeResource | virtual
SetButtonFont(CFont *fontButton) | CXTPDatePickerPaintManager |
SetButtonFontIndirect(LOGFONT *lFont) | CXTPDatePickerPaintManager |
SetFontIndirect(LOGFONT *lFont) | CXTPDatePickerPaintManager |
Triangle(CDC *pDC, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clrColor=0) | CXTPDatePickerPaintManager | protectedvirtual
~CXTPDatePickerPaintManager() | CXTPDatePickerPaintManager | virtual
~CXTPDatePickerThemeResource() | CXTPDatePickerThemeResource | virtual


Toolkit Pro: XTPMarkupRectangle.h Source File

  • Source
  • Markup
  • Shapes
XTPMarkupRectangle.h
Go to the documentation of this file.
1
23#if !defined(__XTPMARKUPRECTANGLE_H__)
24# define __XTPMARKUPRECTANGLE_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPMarkupDependencyProperty;
34class CXTPMarkupDrawingContext;
35
36class _XTP_EXT_CLASS CXTPMarkupRectangle : public CXTPMarkupShape
37{
39 DECLARE_MARKUPCLASS(CXTPMarkupRectangle)
41protected:
42 CXTPMarkupRectangle();
43 virtual ~CXTPMarkupRectangle();
44
45public:
46 int GetRadiusX() const;
47 int GetRadiusY() const;
48
49 void SetRadiusX(int nRarius);
50 void SetRadiusY(int nRarius);
51
52protected:
53 CSize MeasureOverride(CXTPMarkupDrawingContext* pDC, CSize szAvailableSize);
54 void OnRender(CXTPMarkupDrawingContext* pDC);
55
56public:
57 static CXTPMarkupDependencyProperty* m_pRadiusXProperty;
58 static CXTPMarkupDependencyProperty* m_pRadiusYProperty;
59
61public:
62 DECLARE_DISPATCH_MAP()
63# ifdef _XTP_ACTIVEX
64 DECLARE_INTERFACE_MAP()
65 DECLARE_OLETYPELIB_EX(CXTPMarkupRectangle);
66# endif
67
68 afx_msg int OleGetRadiusX();
69 afx_msg void OleSetRadiusX(int nValue);
70 afx_msg int OleGetRadiusY();
71 afx_msg void OleSetRadiusY(int nValue);
72
74};
75
76# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
78#endif // !defined(__XTPMARKUPRECTANGLE_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPMarkupVisual::OnRender
virtual void OnRender(CXTPMarkupDrawingContext *drawingContext)
When overridden in a derived class, participates in rendering operations that are directed by the lay...
Definition XTPMarkupInputElement.h:515


Toolkit Pro: Member List

CXTPGridThemeOffice2003 Member List

This is the complete list of members for CXTPGridThemeOffice2003, including all inherited members.

CalcColumnHeight(CDC *pDC, CXTPGridColumn *pColumn, int nTotalWidth=0) | CXTPGridPaintManager | protectedvirtual
CalculateRowHeight(CDC *pDC, const CString &strText, int nMaxWidth, BOOL bWordBreak=TRUE) | CXTPGridPaintManager | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPGridPaintManager() | CXTPGridPaintManager |
CXTPGridThemeOffice2003() | CXTPGridThemeOffice2003 |
DrawBitmap(CDC *pDC, CXTPGridControl *pControl, CRect rcColumn, int iImage) | CXTPGridPaintManager | virtual
DrawCollapsedBitmap(CDC *pDC, const CXTPGridRow *pRow, CRect &rcBitmap) | CXTPGridPaintManager | virtual
DrawColumn(CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn, BOOL bDrawExternal=FALSE, int nShadowWidth=0) | CXTPGridThemeOffice2003 | virtual
DrawColumnBackground(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, BOOL &bColumnPressed, BOOL &bDraggingFromHeader, CXTPGridHeader *pHeader=NULL) | CXTPGridThemeOffice2003 | virtual
DrawColumnFooter(CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn) | CXTPGridPaintManager | virtual
DrawColumnFooterDivider(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn) | CXTPGridPaintManager | virtual
DrawColumnIcon(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, CRect rcIcon, int iIcon) | CXTPGridPaintManager | virtual
DrawColumnText(CDC *pDC, CRect rcText, CString strCaption, int nHeaderAlignment, BOOL bIsHeader, BOOL bColumnPressed) | CXTPGridPaintManager | virtual
DrawConnector(CDC *pDC, CPoint ptFrom, CPoint ptTo) | CXTPGridPaintManager |
DrawFocusedRow(CDC *pDC, CRect rcRow) | CXTPGridPaintManager | virtual
DrawFreezeColsDivider(CDC *pDC, const CRect &rc, CXTPGridControl *pControl, CXTPGridRow *pRow=NULL) | CXTPGridPaintManager | virtual
DrawGlyph(CDC *pDC, CRect rcColumn, int iImage) | CXTPGridPaintManager | virtual
DrawGrid(CDC *pDC, XTPGridOrientation orientation, CRect rcGrid) | CXTPGridPaintManager | virtual
DrawGridPattern(CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush) | CXTPGridPaintManager | protectedvirtual
DrawGridPattern(CDC *pDC, CXTPBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush) | CXTPGridPaintManager | protectedvirtual
DrawGridPattern(CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr) | CXTPGridPaintManager | protectedvirtual
DrawGroupRow(CDC *pDC, CXTPGridGroupRow *pRow, CRect rcRow, XTP_GRIDRECORDITEM_METRICS *pMetrics) | CXTPGridPaintManager | virtual
DrawHorizontalLine(CDC *pDC, int xPos, int yPos, int cx, COLORREF clr) | CXTPGridPaintManager |
DrawInplaceButton(CDC *pDC, CXTPGridInplaceButton *pButton) | CXTPGridPaintManager | virtual
DrawInplaceButtonFrame(CDC *pDC, CXTPGridInplaceButton *pButton) | CXTPGridPaintManager | protectedvirtual
DrawInplaceButtonIcon(CDC *pDC, CXTPGridInplaceButton *pButton) | CXTPGridPaintManager | protectedvirtual
DrawInplaceComboButton(CDC *pDC, CRect *pRc) | CXTPGridPaintManager | virtual
DrawInplaceExpandButton(CDC *pDC, CRect *pRc) | CXTPGridPaintManager | virtual
DrawInplaceSpinButton(CDC *pDC, CRect *pRc) | CXTPGridPaintManager | virtual
DrawItemBitmap(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CRect &rcItem, int nImage) | CXTPGridPaintManager | virtual
DrawItemCaption(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics) | CXTPGridPaintManager | virtual
DrawItemControl(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CXTPGridRecordItemControl *pControl, CRect &rcItem) | CXTPGridPaintManager | virtual
DrawLink(int *pnCurrDrawPos, XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CXTPGridHyperlink *pHyperlink, CString strText, CRect rcLink, int nFlag, BOOL bTrim=FALSE) | CXTPGridPaintManager | protectedvirtual
DrawMultiLineText(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, BOOL bWordBreak=TRUE) | CXTPGridPaintManager | protectedvirtual
DrawNoGroupByText(CDC *pDC, CRect rcItem) | CXTPGridPaintManager | virtual
DrawRowNumber(CDC *pDC, CRect rcNumber, CXTPGridRow *pRow) | CXTPGridPaintManager | virtual
DrawSectionDivider(CDC *pDC, const CRect &rc, XTPGridSectionDividerPosition dividerPosition, XTPGridSectionDividerStyle dividerStyle, CXTPPaintManagerColor dividerColor) | CXTPGridThemeOffice2003 |
DrawShellIcon(CDC *pDC, CRect rcColumn, int iImage) | CXTPGridPaintManager | virtual
DrawSingleLineText(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nStartPos, int nEndPos, int nActualWidth) | CXTPGridPaintManager | protectedvirtual
DrawString(int *pnCurrDrawPos, CDC *pDC, const CString &strDraw, CRect rcDraw, UINT nFormat) | CXTPGridPaintManager | protectedvirtual
DrawTextLine(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nFlag, int &nCharCounter, int &nHyperlinkCounter) | CXTPGridPaintManager | protectedvirtual
DrawTreeStructure(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CRect rcItem, CSize sizeGlyph) | CXTPGridPaintManager | virtual
DrawTriangle(CDC *pDC, CRect rcTriangle, BOOL bToDown, BOOL bDraggingFromHeader, int nShadowWidth, BOOL bColumnPressed) | CXTPGridPaintManager | virtual
DrawVerticalLine(CDC *pDC, int xPos, int yPos, int cy, COLORREF clr) | CXTPGridPaintManager |
DrawVerticalTimeLineMarker(CDC *pDC, int xPos, CXTPGridControl *pControl, COLORREF color=RGB(0, 255, 0)) | CXTPGridPaintManager | virtual
EnablePreviewMode(BOOL bIsPreviewMode) | CXTPGridPaintManager |
FillFooter(CDC *pDC, CRect rcFooter) | CXTPGridPaintManager | virtual
FillGroupByControl(CDC *pDC, CRect &rcGroupBy) | CXTPGridPaintManager | virtual
FillGroupRowMetrics(CXTPGridGroupRow *pRow, XTP_GRIDRECORDITEM_METRICS *pMetrics, BOOL bPrinting) | CXTPGridPaintManager | virtual
FillHeaderControl(CDC *pDC, CRect rcHeader) | CXTPGridPaintManager | virtual
FillIndent(CDC *pDC, CRect rcRow) | CXTPGridPaintManager | virtual
FillItemShade(CDC *pDC, CRect rcItem) | CXTPGridPaintManager | virtual
FillRow(CDC *pDC, CXTPGridRow *pRow, CRect rcRow) | CXTPGridPaintManager | virtual
FindRowAdjacentToMerged(const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, BOOL bUpward) | CXTPGridPaintManager |
FindRowAdjacentToMergedEx(const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, int &nAdjRowIndex, BOOL bUpward) | CXTPGridPaintManager |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetColumnOffice2007CustomThemeBaseColor() const | CXTPGridPaintManager |
GetColumnStyle() const | CXTPGridPaintManager |
GetControlBackColor(CXTPGridControl *pControl) | CXTPGridPaintManager | virtual
GetFooterHeight(CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0) | CXTPGridPaintManager | virtual
GetFreezeColsDividerStyle() const | CXTPGridPaintManager |
GetGlyphs() const | CXTPGridPaintManager |
GetHeaderHeight() | CXTPGridPaintManager | virtual
GetHeaderHeight(CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0) | CXTPGridPaintManager | virtual
GetItemHeight(XTP_GRIDRECORDITEM_DRAWARGS &drawArgs, int nWidth) | CXTPGridPaintManager |
GetMaxPreviewLines() | CXTPGridPaintManager |
GetPreviewItemHeight(CDC *pDC, CXTPGridRow *pRow, int nWidth, int nHeight) | CXTPGridPaintManager | virtual
GetPreviewLinesCount(CDC *pDC, CRect &rcText, const CString &strText) | CXTPGridPaintManager |
GetRowHeight(CDC *pDC, CXTPGridRow *pRow) | CXTPGridPaintManager | virtual
GetRowHeight(CDC *pDC, CXTPGridRow *pRow, int nTotalWidth) | CXTPGridPaintManager | virtual
GetRowHeightEx(CDC *pDC, CXTPGridRow *pRow, int nTotalWidth, const BOOL firstLevel=TRUE) | CXTPGridPaintManager |
GetSectionDividerHeight(XTPGridFixedRowsDividerStyle dividerStyle) | CXTPGridPaintManager |
GetTextFont() | CXTPGridPaintManager |
IsColumHotTrackingEnabled() const | CXTPGridPaintManager | virtual
IsColumnPlusMinusSign() const | CXTPGridPaintManager |
IsColumnWidthWYSIWYG() const | CXTPGridPaintManager |
IsDrawGridForEmptySpace() const | CXTPGridPaintManager |
IsFixedInplaceButtonHeight() const | CXTPGridPaintManager |
IsFixedRowHeight() const | CXTPGridPaintManager |
IsGridVisible(BOOL bVertical) const | CXTPGridPaintManager |
IsGridVisible(XTPGridOrientation orientation) const | CXTPGridPaintManager |
IsLastColumnWidthWYSIWYG() const | CXTPGridPaintManager |
IsPreviewMode() const | CXTPGridPaintManager |
IsPrintGroupRowIcon() const | CXTPGridPaintManager |
IsShowWYSIWYGMarkers() const | CXTPGridPaintManager |
IsUseDropMarker() const | CXTPGridPaintManager |
LoadGlyphs() | CXTPGridPaintManager | virtual
m_arStartCol | CXTPGridPaintManager |
m_bAllowMergeCells | CXTPGridPaintManager |
m_bBaseTreeIndent | CXTPGridPaintManager |
m_bCleanTooltip | CXTPGridPaintManager |
m_bColumnPlusMinusSign | CXTPGridPaintManager | protected
m_bColumnWidthWYSIWYG | CXTPGridPaintManager | protected
m_bCompactText | CXTPGridPaintManager |
m_bDrawGridForEmptySpace | CXTPGridPaintManager | protected
m_bFixedInplaceButtonHeight | CXTPGridPaintManager | protected
m_bFixedRowHeight | CXTPGridPaintManager | protected
m_bForceDynamicMarkupForCell | CXTPGridPaintManager |
m_bForceShowDropMarker | CXTPGridPaintManager |
m_bForceShowTooltip | CXTPGridPaintManager |
m_bGrayIfDisable | CXTPGridPaintManager |
m_bGroupRowTextBold | CXTPGridPaintManager |
m_bHideSelection | CXTPGridPaintManager |
m_bHotTracking | CXTPGridPaintManager |
m_bInvertColumnOnClick | CXTPGridPaintManager |
m_bIsPreviewMode | CXTPGridPaintManager | protected
m_bLastColumnWidthWYSIWYG | CXTPGridPaintManager | protected
m_bMakeUpper | CXTPGridPaintManager |
m_bMoveScrollbarOnFixedColumnsIndent | CXTPGridPaintManager |
m_bPrintGroupRowIcon | CXTPGridPaintManager | protected
m_bPrintPageRectangle | CXTPGridPaintManager |
m_bPrintSortTriangle | CXTPGridPaintManager |
m_bPrintVirtualPageNumber | CXTPGridPaintManager |
m_bPrintWatermark | CXTPGridPaintManager |
m_bRecOrRowNum | CXTPGridPaintManager |
m_bRevertAlignment | CXTPGridPaintManager |
m_bShadeGroupHeadings | CXTPGridPaintManager |
m_bShadeSortColumn | CXTPGridPaintManager |
m_bShowLockIcon | CXTPGridPaintManager |
m_bShowNonActiveInPlaceButton | CXTPGridPaintManager |
m_bShowWYSIWYGMarkers | CXTPGridPaintManager | protected
m_bSortTriangleOffsetFromRight | CXTPGridPaintManager |
m_bThemedInplaceButtons | CXTPGridPaintManager |
m_bUseAlternativeBackground | CXTPGridPaintManager |
m_bUseDropMarker | CXTPGridPaintManager |
m_bUseEditTextAlignment | CXTPGridPaintManager |
m_bUseGroupRowSelectionState | CXTPGridPaintManager |
m_bUseShellIcon | CXTPGridPaintManager |
m_clrAlternativeBackground | CXTPGridPaintManager |
m_clrBoldText | CXTPGridPaintManager |
m_clrBoldTextHighlight | CXTPGridPaintManager |
m_clrBtnFace | CXTPGridPaintManager |
m_clrBtnFacePressed | CXTPGridPaintManager |
m_clrBtnText | CXTPGridPaintManager |
m_clrCaptionText | CXTPGridPaintManager |
m_clrCaptionTextPressed | CXTPGridPaintManager |
m_clrColumnOffice2007CustomTheme | CXTPGridPaintManager |
m_clrConnector | CXTPGridPaintManager |
m_clrControlBack | CXTPGridPaintManager |
m_clrControlDark | CXTPGridPaintManager |
m_clrControlLightLight | CXTPGridPaintManager |
m_clrDisableBitmapDarkest | CXTPGridPaintManager |
m_clrDisableBitmapLightest | CXTPGridPaintManager |
m_clrFormulaSubSum | CXTPGridPaintManager |
m_clrFormulaSum | CXTPGridPaintManager |
m_clrFreezeColsDivider | CXTPGridPaintManager |
m_clrGradientColumnSeparator | CXTPGridPaintManager |
m_clrGradientColumnShadow | CXTPGridPaintManager |
m_clrGroupBoxBack | CXTPGridPaintManager |
m_clrGroupRowText | CXTPGridPaintManager |
m_clrGroupShadeBack | CXTPGridPaintManager |
m_clrGroupShadeBorder | CXTPGridPaintManager |
m_clrGroupShadeText | CXTPGridPaintManager |
m_clrHeaderControl | CXTPGridPaintManager |
m_clrHighlight | CXTPGridPaintManager |
m_clrHighlightText | CXTPGridPaintManager |
m_clrHotDivider | CXTPGridPaintManager |
m_clrIndentControl | CXTPGridPaintManager |
m_clrItemShade | CXTPGridPaintManager |
m_clrPreviewText | CXTPGridPaintManager |
m_clrSelectedRow | CXTPGridPaintManager |
m_clrSelectedRowText | CXTPGridPaintManager |
m_clrWindowText | CXTPGridPaintManager |
m_columnStyle | CXTPGridPaintManager | protected
m_crlNoGroupByText | CXTPGridPaintManager |
m_grcGradientColumn | CXTPGridPaintManager |
m_grcGradientColumnHot | CXTPGridPaintManager |
m_grcGradientColumnPushed | CXTPGridPaintManager |
m_iRecOrRowStart | CXTPGridPaintManager |
m_nBaseParentRecordIndent | CXTPGridPaintManager |
m_nFixedColumnsIndent | CXTPGridPaintManager |
m_nFooterHeight | CXTPGridPaintManager | protected
m_nFreezeColsDividerStyle | CXTPGridPaintManager | protected
m_nGridLineStylePreviousH | CXTPGridPaintManager | protected
m_nGridLineStylePreviousV | CXTPGridPaintManager | protected
m_nGroupGridLineHeight | CXTPGridPaintManager | protected
m_nGroupGridLineStyle | CXTPGridPaintManager | protected
m_nHeaderHeight | CXTPGridPaintManager | protected
m_nMaxPreviewLines | CXTPGridPaintManager | protected
m_nResizingWidth | CXTPGridPaintManager | protected
m_nRowHeight | CXTPGridPaintManager | protected
m_nRowHeightDefault | CXTPGridPaintManager |
m_nTextIndentForGroupRowsWithNoIcon | CXTPGridPaintManager |
m_nTreeColumnLineLength | CXTPGridPaintManager |
m_nTreeIndent | CXTPGridPaintManager |
m_nTreeStructureStyle | CXTPGridPaintManager |
m_nTreeTextIndent | CXTPGridPaintManager |
m_nTreeTextIndentGroupRow | CXTPGridPaintManager |
m_nTreeTextIndentRowChildren | CXTPGridPaintManager |
m_nTreeTextIndentRowParent | CXTPGridPaintManager |
m_pControl | CXTPGridPaintManager | protected
m_pGlyphs | CXTPGridPaintManager | protected
m_pHyperlinkHoverStyle | CXTPGridPaintManager |
m_pHyperlinkStyle | CXTPGridPaintManager |
m_pMarkupUIElement_NoGroupBy | CXTPGridPaintManager | protected
m_PrintPageWidth | CXTPGridPaintManager |
m_rcPreviewIndent | CXTPGridPaintManager |
m_RecordNumberWidth | CXTPGridPaintManager |
m_strCollapse | CXTPGridPaintManager |
m_strDecreasing | CXTPGridPaintManager |
m_strExpand | CXTPGridPaintManager |
m_strIncreasing | CXTPGridPaintManager |
m_strMarkupUIElement_NoGroupBy | CXTPGridPaintManager | protected
m_strNoFieldsAvailable | CXTPGridPaintManager |
m_strNoGroupBy | CXTPGridPaintManager |
m_strNoItems | CXTPGridPaintManager |
m_strSortBy | CXTPGridPaintManager |
m_szGlyph | CXTPGridPaintManager | protected
m_themeButton | CXTPGridPaintManager | protected
m_themeCombo | CXTPGridPaintManager | protected
m_themeHeader | CXTPGridPaintManager | protected
m_themeSpin | CXTPGridPaintManager | protected
m_treeStructureStyle | CXTPGridPaintManager |
m_xtpBrushGroupGridLineStyle | CXTPGridPaintManager | protected
m_xtpBrushHorizontalGrid | CXTPGridPaintManager | protected
m_xtpBrushTreeStructure | CXTPGridPaintManager | protected
m_xtpBrushVeriticalGrid | CXTPGridPaintManager | protected
m_xtpFontBoldText | CXTPGridPaintManager |
m_xtpFontCaption | CXTPGridPaintManager |
m_xtpFontPreview | CXTPGridPaintManager |
m_xtpFontText | CXTPGridPaintManager |
OnDrawAction(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs) | CXTPGridPaintManager | virtual
RecalcTotalHightOfMergedRows(CXTPGridColumns *pColumns, CDC *pDC, CXTPGridRow *pRow, int nRowHeight, int nTotalWidth) | CXTPGridPaintManager |
RefreshMetrics() | CXTPGridPaintManager | virtual
SetCaptionFont(LOGFONT &lf) | CXTPGridPaintManager |
SetColumnOffice2007CustomThemeBaseColor(COLORREF clrBaseColor) | CXTPGridPaintManager |
SetColumnPlusMinusSign(BOOL bDraw) | CXTPGridPaintManager |
SetColumnStyle(XTPGridColumnStyle columnStyle) | CXTPGridPaintManager |
SetColumnWidthWYSIWYG(BOOL bColumnWidthWYSIWYG) | CXTPGridPaintManager |
SetDrawGridForEmptySpace(BOOL bDrawGrid) | CXTPGridPaintManager |
SetFixedRowHeight(BOOL bFixedRowHeight) | CXTPGridPaintManager |
SetFreezeColsDividerStyle(int nStyle) | CXTPGridPaintManager |
SetGridControl(CXTPGridControl *pControl) | CXTPGridPaintManager | virtual
SetHeaderHeight(int nHeight) | CXTPGridPaintManager | virtual
SetInplaceButtonHeight(BOOL bFixedInplaceButtonHeight) | CXTPGridPaintManager |
SetLastColumnWidthWYSIWYG(BOOL bColumnWidthWYSIWYG) | CXTPGridPaintManager |
SetMaxPreviewLines(int nMaxLines) | CXTPGridPaintManager |
SetPreviewIndent(int nLeft, int nTop, int nRight, int nBottom) | CXTPGridPaintManager |
SetPrintGroupRowIcon(BOOL bDraw) | CXTPGridPaintManager |
SetTextFont(LOGFONT &lf) | CXTPGridPaintManager |
ShowWYSIWYGMarkers(BOOL bSet) | CXTPGridPaintManager |
~CXTPGridPaintManager() | CXTPGridPaintManager | virtual


Toolkit Pro: Member List

CXTPCalendarControlView Member List

This is the complete list of members for CXTPCalendarControlView, including all inherited members.

_DrawDateHeaderCalendar(BOOL bCalculate, CDC *pDC, COleDateTime dtYearMonth, CRect &rrcHeaderCalendar) | CXTPCalendarControlView | protectedvirtual
_GetDateHeaderMonths(COleDateTime &dtYearMonth1, COleDateTime &dtYearMonth2, CString &strHeader1, CString &strHeader2, CString &strHeaderWeekDay) | CXTPCalendarControlView | protectedvirtual
_HimetricToLP(CDC *pDC, const CRect rcHimetric) | CXTPCalendarControlView | protectedstatic
AdjustCalendarForPrint(CDC *pDC, CRect rcCalendar, CPrintInfo *pInfo) | CXTPCalendarControlView | protectedvirtual
CXTPCalendarControlView() | CXTPCalendarControlView | protected
DrawDateHeader(BOOL bCalculate, CDC *pDC, CRect &rrcHeader) | CXTPCalendarControlView | protectedvirtual
GetCalendarCaptionBarCtrl() | CXTPCalendarControlView | virtual
GetCalendarCtrl() | CXTPCalendarControlView | virtual
GetPrintOptions() const | CXTPCalendarControlView |
IsShowCaptionBar() const | CXTPCalendarControlView | virtual
m_bDF_mode | CXTPCalendarControlView |
m_bPrintDirect | CXTPCalendarControlView |
m_bPrintFineMode | CXTPCalendarControlView |
m_bPrintFullScale | CXTPCalendarControlView |
m_bPrintRepeatHeaderFooterMode | CXTPCalendarControlView |
m_bResizeControlWithView | CXTPCalendarControlView |
m_bShowCaptionBar | CXTPCalendarControlView | protected
m_dtPrintFrom | CXTPCalendarControlView | protected
m_dtPrintTo | CXTPCalendarControlView | protected
m_dtTimeScaleOldMaxTime | CXTPCalendarControlView |
m_dtTimeScaleOldMinTime | CXTPCalendarControlView |
m_pPrintOptions | CXTPCalendarControlView | protected
SetCalendarCtrl(CXTPCalendarControl *pCalendar, BOOL bReleaseWhenDestroy=TRUE) | CXTPCalendarControlView | virtual
SetScrollBarCtrl(CScrollBar *pScrollBar, int nBar=SB_VERT) | CXTPCalendarControlView |
ShowCaptionBar(BOOL bShow) | CXTPCalendarControlView | virtual
~CXTPCalendarControlView() | CXTPCalendarControlView | protectedvirtual


Toolkit Pro: Member List

CXTPChartPolygonDeviceCommand Member List

This is the complete list of members for CXTPChartPolygonDeviceCommand, including all inherited members.

AddChildCommand(CXTPChartDeviceCommand *pCommand) | CXTPChartDeviceCommand |
AfterExecute(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
ApplySeriesStyle(CXTPChartSeriesStyle *pStyle) | CXTPChartDeviceCommand | virtual
BeforeExecute(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
BindView(CXTPChartElementView *pView) | CXTPChartDeviceCommand |
Commit() | CXTPChartDeviceCommand |
CXTPChartDeviceCommand() | CXTPChartDeviceCommand |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartPolygonDeviceCommand(const CXTPChartPoints &points) | CXTPChartPolygonDeviceCommand | protected
CXTPObservable() | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | protected
Execute(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
ExecuteOverride(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
GetBoundView() const | CXTPChartDeviceCommand |
GetChildCommand(int nIndex) const | CXTPChartDeviceCommand |
GetChildCommandCount() const | CXTPChartDeviceCommand |
GetCurrentDC() const | CXTPChartDeviceCommand |
GetPassNumber() const | CXTPChartDeviceCommand |
HitTest(CPoint point, CXTPChartElement *pParent) const | CXTPChartDeviceCommand | virtual
Is3D() const | CXTPChartObject |
IsCommitted() const | CXTPChartDeviceCommand |
IsEnabled() const | CXTPChartDeviceCommand | virtual
m_arrChildren | CXTPChartDeviceCommand | protected
m_bounds | CXTPChartPolygonDeviceCommand | protected
m_points | CXTPChartPolygonDeviceCommand | protected
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Prepare(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
PrepareOverride(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
SetEnabled(BOOL bEnabled=TRUE) | CXTPChartDeviceCommand |
Subscribe(CXTPChartDeviceCommandEvents *pObserver, CXTPSubscriptionList< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > *pSubcriptionList=NULL) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > |
Unsubscribe(CXTPChartDeviceCommandEvents *pObserver) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > |
~CXTPChartDeviceCommand() | CXTPChartDeviceCommand | virtual
~CXTPObservable() | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | protected


Toolkit Pro: Member List

CXTPDockState Member List

This is the complete list of members for CXTPDockState, including all inherited members.

CXTPDockState() | CXTPDockState
DoPropExchange(CXTPPropExchange *pPX) | CXTPDockState
GetVersion() const | CXTPDockState
LoadState(LPCTSTR lpszProfileName) | CXTPDockState
SaveState(LPCTSTR lpszProfileName) | CXTPDockState
ScalePoint(CPoint &pt) | CXTPDockState
ScaleRectPos(CRect &rect) | CXTPDockState
~CXTPDockState() | CXTPDockState


Toolkit Pro: Member List

  • CXTPMouseManager
  • CTrackArray
CXTPMouseManager::CTrackArray Member List

This is the complete list of members for CXTPMouseManager::CTrackArray, including all inherited members.

Find(const CXTPCommandBar *pCommandBar) const CXTPMouseManager::CTrackArray


Toolkit Pro: XTPPopupPaintManager.h Source File

  • Source
  • Controls
  • Popup
XTPPopupPaintManager.h
Go to the documentation of this file.
1
23#if !defined(_XTPPOPUPPAINTMANAGER_H__)
24# define _XTPPOPUPPAINTMANAGER_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPPopupItem;
34class CXTPPopupItemText;
35class CXTPPopupItemIcon;
36class CXTPPopupControl;
37
43class _XTP_EXT_CLASS CXTPPopupPaintManager
44{
45public:
50 CXTPPopupPaintManager();
51
56 virtual ~CXTPPopupPaintManager();
57
58public:
66 virtual void DrawBackground(CDC* pDC, CXTPPopupControl* pControl, CRect rcClient);
67
75 void DrawItem(CDC* pDC, CXTPPopupItem* pItem);
76
83 virtual void DrawButton(CDC* pDC, CXTPPopupItem* pItem);
84
91 virtual void DrawItemIcon(CDC* pDC, CXTPPopupItem* pItem);
92
98 void SetFont(HFONT hFont);
99
104 virtual void RefreshMetrics();
105
106public:
107 CXTPPaintManagerColorGradient m_clrBackground;
108 CXTPPaintManagerColorGradient m_clrFrame;
110 CXTPFont m_xtpFontText;
111 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CFont, m_fntText, m_xtpFontText, GetTextFontHandle);
112
113 COLORREF m_clrText;
115 int m_iButtonBorderInflate;
116
117 COLORREF m_clrButtonSelected;
118 COLORREF m_clrButtonPressed;
119 CXTPPaintManagerColorGradient m_clrButtonSelectedBorder;
121 CXTPPaintManagerColorGradient m_clrButtonPressedBorder;
123};
124
125# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
127#endif // !defined(_XTPPOPUPPAINTMANAGER_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPFont
Provides a convenient object oriented interface for HFONT GDI object and uses GDI handle caching.
Definition XTPGdiObjects.h:414
CXTPPaintManagerColorGradient
The CXTPPaintManagerColorGradient class is used to manage COLORREF values for determining light and d...
Definition XTPColorManager.h:301
CXTPPopupControl
CXTPPopupControl is a class for control of a pop-up window.
Definition XTPPopupControl.h:225
CXTPPopupItem
CXTPPopupItem is a class used to manage a pop-up item object.
Definition XTPPopupItem.h:70
CXTPPopupPaintManager
CXTPPopupPaintManager is a class used to perform specialized drawing tasks.
Definition XTPPopupPaintManager.h:44
CXTPPopupPaintManager::m_clrFrame
CXTPPaintManagerColorGradient m_clrFrame
3D frame color.
Definition XTPPopupPaintManager.h:108
CXTPPopupPaintManager::SetFont
void SetFont(HFONT hFont)
Sets the font for text used in a pop-up control.
CXTPPopupPaintManager::DrawButton
virtual void DrawButton(CDC *pDC, CXTPPopupItem *pItem)
Call this method to draw the rectangle of a button.
CXTPPopupPaintManager::DrawItem
void DrawItem(CDC *pDC, CXTPPopupItem *pItem)
Call this member function to draw the controlled item object of a pop-up window.
CXTPPopupPaintManager::m_clrButtonPressedBorder
CXTPPaintManagerColorGradient m_clrButtonPressedBorder
3D border color of pressed button.
Definition XTPPopupPaintManager.h:121
CXTPPopupPaintManager::~CXTPPopupPaintManager
virtual ~CXTPPopupPaintManager()
Destroys a CXTPPopupPaintManager object.
CXTPPopupPaintManager::CXTPPopupPaintManager
CXTPPopupPaintManager()
Constructs a CXTPPopupPaintManager object.
CXTPPopupPaintManager::m_clrButtonPressed
COLORREF m_clrButtonPressed
Color of pressed button.
Definition XTPPopupPaintManager.h:118
CXTPPopupPaintManager::m_clrButtonSelectedBorder
CXTPPaintManagerColorGradient m_clrButtonSelectedBorder
3D border color of selected button.
Definition XTPPopupPaintManager.h:119
CXTPPopupPaintManager::DrawItemIcon
virtual void DrawItemIcon(CDC *pDC, CXTPPopupItem *pItem)
Call this method to draw the icon of a button.
CXTPPopupPaintManager::DrawBackground
virtual void DrawBackground(CDC *pDC, CXTPPopupControl *pControl, CRect rcClient)
Call this member function to draw the background of a pop-up window.
CXTPPopupPaintManager::m_clrButtonSelected
COLORREF m_clrButtonSelected
Color of selected button.
Definition XTPPopupPaintManager.h:117
CXTPPopupPaintManager::m_clrText
COLORREF m_clrText
Default color of text.
Definition XTPPopupPaintManager.h:113
CXTPPopupPaintManager::RefreshMetrics
virtual void RefreshMetrics()
Call this member function to refresh draw metrics.
CXTPPopupPaintManager::m_clrBackground
CXTPPaintManagerColorGradient m_clrBackground
Gradient background color.
Definition XTPPopupPaintManager.h:107
CXTPPopupPaintManager::m_xtpFontText
CXTPFont m_xtpFontText
Default font of text.
Definition XTPPopupPaintManager.h:110


Toolkit Pro: Member List

CXTPChart3dPyramidSeriesView Member List

This is the complete list of members for CXTPChart3dPyramidSeriesView, including all inherited members.

AddChildView(CXTPChartElementView *pChildView) | CXTPChartElementView |
CalculateLabelLayout(CXTPChartDeviceContext *pDC) | CXTPChartPyramidSeriesViewBase |
CalculatePointLayout(CXTPChartDeviceContext *pDC, CRect rcBounds) | CXTPChart3dPyramidSeriesView | virtual
CreateDeviceCommand(CXTPChartDeviceContext *pDC) | CXTPChart3dPyramidSeriesView | protectedvirtual
CreateDiagramDomain(CXTPChartDeviceContext *pDC, CRect rcBounds) | CXTPChartPyramidSeriesViewBase | virtual
CreateLegendDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcBounds) | CXTPChart3dPyramidSeriesView | protectedvirtual
CreateLegendDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcBounds, CXTPChartColor color1, CXTPChartColor color2, CXTPChartColor clrBorder) | CXTPChart3dPyramidSeriesView | protectedvirtual
CreateSeriesPointView(CXTPChartDeviceContext *pDC, CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView) | CXTPChart3dPyramidSeriesView | protectedvirtual
CXTPChart3dPyramidSeriesView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView) | CXTPChart3dPyramidSeriesView |
CXTPChartElementView(CXTPChartElementView *pParentView) | CXTPChartElementView |
CXTPChartElementView(CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartElementView |
CXTPChartElementView(CXTPChartContainer *pContainer) | CXTPChartElementView |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartPyramidSeriesViewBase(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView) | CXTPChartPyramidSeriesViewBase |
GetAt(int nIndex) const | CXTPChartElementView |
GetBounds() const | CXTPChartElementView |
GetBounds(BOOL bIncludingChildren) const | CXTPChartElementView |
GetChildren() | CXTPChartElementView |
GetCount() const | CXTPChartElementView |
GetDomain() const | CXTPChartPyramidSeriesViewBase |
GetInnerBounds() const | CXTPChartPyramidSeriesViewBase | virtual
GetMaxLabelWidth() const | CXTPChartPyramidSeriesViewBase |
GetParentView() const | CXTPChartElementView |
Is3D() const | CXTPChartObject |
m_arrChildren | CXTPChartElementView | protected
m_pContainer | CXTPChartElementView | protected
m_pDomain | CXTPChartPyramidSeriesViewBase | protected
m_pParentView | CXTPChartElementView | protected
m_rcBounds | CXTPChartElementView | protected
~CXTPChartElementView() | CXTPChartElementView | protectedvirtual
~CXTPChartLegendItemView() | CXTPChartLegendItemView | inlinevirtual
~CXTPChartPyramidSeriesViewBase() | CXTPChartPyramidSeriesViewBase | virtual


Toolkit Pro: Member List

CXTPScrollableListCtrlT< ListBase > Member List

This is the complete list of members for CXTPScrollableListCtrlT< ListBase >, including all inherited members.

Create(LPCTSTR lpszClassName, LPCTSTR lpszWindowName, DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID, CCreateContext *pContext=NULL) | CXTPScrollable< ListBase > | virtual
CreateEx(DWORD dwExStyle, LPCTSTR lpszClassName, LPCTSTR lpszWindowName, DWORD dwStyle, int x, int y, int nWidth, int nHeight, HWND hWndParent, HMENU nIDorHMenu, LPVOID lpParam=NULL) | CXTPScrollable< ListBase > | virtual
CreateEx(DWORD dwExStyle, LPCTSTR lpszClassName, LPCTSTR lpszWindowName, DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID, LPVOID lpParam=NULL) | CXTPScrollable< ListBase > | virtual
CXTPScrollable() | CXTPScrollable< ListBase > |
CXTPScrollableListCtrlT() | CXTPScrollableListCtrlT< ListBase > |
EnableDefaultBorderDrawing(BOOL bEnable=TRUE) | CXTPScrollable< ListBase > |
InitScrollBars() | CXTPScrollable< ListBase > |
SetScrollBarTheme(XTPScrollBarTheme nTheme) | CXTPScrollable< ListBase > |
~IXTPScrollable() | IXTPScrollable | inlinevirtual


Toolkit Pro: Member List

  • CXTPTaskDialogLinkCtrl
  • LINKITEM
CXTPTaskDialogLinkCtrl::LINKITEM Member List

This is the complete list of members for CXTPTaskDialogLinkCtrl::LINKITEM, including all inherited members.

nIndex | CXTPTaskDialogLinkCtrl::LINKITEM
nStart | CXTPTaskDialogLinkCtrl::LINKITEM
strLabel | CXTPTaskDialogLinkCtrl::LINKITEM
strUrl | CXTPTaskDialogLinkCtrl::LINKITEM


Toolkit Pro: Member List

CXTPGridInplaceButtons Member List

This is the complete list of members for CXTPGridInplaceButtons, including all inherited members.

CXTPGridInplaceButtons() CXTPGridInplaceButtons


Toolkit Pro: XTPSyntaxEditLineMarksManager.h Source File

  • Source
  • SyntaxEdit
XTPSyntaxEditLineMarksManager.h
Go to the documentation of this file.
1
23#if !defined(__XTPSYNTAXEDITLINEMARKSMANAGER_H__)
24# define __XTPSYNTAXEDITLINEMARKSMANAGER_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33typedef LPCTSTR XTP_EDIT_LINEMARKTYPE;
34
35// You can define your own line mark types (as string constants)
36// Strings are case sensitive!
37//
38static const XTP_EDIT_LINEMARKTYPE xtpEditLMT_Bookmark = _T("Bookmark");
39static const XTP_EDIT_LINEMARKTYPE xtpEditLMT_Breakpoint = _T("Breakpoint");
40static const XTP_EDIT_LINEMARKTYPE xtpEditLMT_Collapsed = _T("Collapsed");
41
46enum XTPSyntaxEditLineMarksRefreshType
47{
48 xtpEditLMRefresh_Unknown = 0,
49 xtpEditLMRefresh_Insert = 0x01,
50 xtpEditLMRefresh_Delete = 0x02,
52 xtpEditLMRefresh_Delete_only1 = 0x10,
53 xtpEditLMRefresh_Delete_only2 = 0x20,
54 xtpEditLMRefresh_InsertAt0 = 0x40,
55};
56
59class _XTP_EXT_CLASS CXTPSyntaxEditVoidObj : public CXTPCmdTarget
60{
61public:
62 typedef void(AFX_CDECL* TPFDeleter)(void*);
63
64protected:
65 void* m_pPtr;
66 TPFDeleter m_pfDeleter;
67
68public:
77 CXTPSyntaxEditVoidObj(void* pPtr, TPFDeleter pfDeleter = NULL)
78 {
79 m_pPtr = pPtr;
80 m_pfDeleter = pfDeleter;
81 };
82
88 virtual ~CXTPSyntaxEditVoidObj()
89 {
90 if (m_pfDeleter)
91 {
92 m_pfDeleter(m_pPtr);
93 }
94 else
95 {
96 SAFE_DELETE(m_pPtr);
97 }
98 };
99
104 operator void*() const
105 {
106 return m_pPtr;
107 }
108
109 void* GetPtr() const
110 {
111 return m_pPtr;
112 }
113
118 BOOL operator!() const
119 {
120 return !m_pPtr;
121 }
122};
123typedef CXTPSmartPtrInternalT<CXTPSyntaxEditVoidObj> CXTPSyntaxEditVoidObjPtr;
128enum XTPSyntaxEditLMParamType
129{
130 xtpEditLMPT_Unknown = 0,
131 xtpEditLMPT_DWORD = 1,
132 xtpEditLMPT_double = 2,
133 xtpEditLMPT_Ptr = 3,
134};
135
136struct _XTP_EXT_CLASS XTP_EDIT_LMPARAM
137{
138 // Data type
139 XTPSyntaxEditLMParamType m_eType;
140
141 // Data
142 union {
143 DWORD m_dwValue;
144 double m_dblValue;
145 };
146
147protected:
148 CXTPSyntaxEditVoidObjPtr m_Ptr;
149
150public:
151 // END Data
152
153 XTP_EDIT_LMPARAM();
154 virtual ~XTP_EDIT_LMPARAM();
155
156 XTP_EDIT_LMPARAM(const XTP_EDIT_LMPARAM& rSrc);
157
158 XTP_EDIT_LMPARAM(DWORD dwVal);
159 XTP_EDIT_LMPARAM(double dblValue);
160 XTP_EDIT_LMPARAM(void* pPtr);
161
162 const XTP_EDIT_LMPARAM& operator=(const XTP_EDIT_LMPARAM& rSrc);
163
164 const XTP_EDIT_LMPARAM& operator=(DWORD dwValue);
165 const XTP_EDIT_LMPARAM& operator=(double dblValue);
166 const XTP_EDIT_LMPARAM& operator=(void* pPtr);
167
168 operator DWORD() const;
169 operator double() const;
170 operator void*() const;
171
172 void SetPtr(void* pPtr, CXTPSyntaxEditVoidObj::TPFDeleter pfDeleter = NULL);
173
174 void* GetPtr() const;
175
176 BOOL IsValid() const;
177
178 void Clear();
179};
180
181struct _XTP_EXT_CLASS XTP_EDIT_LMDATA
182{
183 int m_nRow;
184 XTP_EDIT_LMPARAM m_Param;
185
186 XTP_EDIT_LMDATA();
187 virtual ~XTP_EDIT_LMDATA();
188
189 XTP_EDIT_LMDATA(const XTP_EDIT_LMDATA& rSrc);
190 const XTP_EDIT_LMDATA& operator=(const XTP_EDIT_LMDATA& rSrc);
191};
192
200class _XTP_EXT_CLASS CXTPSyntaxEditLineMarksManager : public CXTPCmdTarget
201{
203 DECLARE_DYNAMIC(CXTPSyntaxEditLineMarksManager)
206public:
211 CXTPSyntaxEditLineMarksManager();
212
218 virtual ~CXTPSyntaxEditLineMarksManager();
219
235 void AddRemoveLineMark(int nRow, const XTP_EDIT_LINEMARKTYPE lmType,
236 XTP_EDIT_LMPARAM* pParam = NULL);
237
248 void SetLineMark(int nRow, const XTP_EDIT_LINEMARKTYPE lmType, XTP_EDIT_LMPARAM* pParam = NULL);
249
256 void DeleteLineMark(int nRow, const XTP_EDIT_LINEMARKTYPE lmType);
257
268 BOOL HasRowMark(int nRow, const XTP_EDIT_LINEMARKTYPE& lmType,
269 XTP_EDIT_LMPARAM* pParam = NULL) const;
270
281 POSITION FindPrevLineMark(int& nRow, const XTP_EDIT_LINEMARKTYPE lmType) const;
282
293 POSITION FindNextLineMark(int& nRow, const XTP_EDIT_LINEMARKTYPE lmType) const;
294
302 POSITION GetLastLineMark(const XTP_EDIT_LINEMARKTYPE lmType) const;
303
311 POSITION GetFirstLineMark(const XTP_EDIT_LINEMARKTYPE lmType) const;
312
326 XTP_EDIT_LMDATA* GetNextLineMark(POSITION& pos, const XTP_EDIT_LINEMARKTYPE lmType) const;
327
341 XTP_EDIT_LMDATA* GetLineMarkAt(const POSITION pos, const XTP_EDIT_LINEMARKTYPE lmType) const;
342
353 virtual void RefreshLineMarks(int nRowFrom, int nRowTo, int nRefreshType);
354
360 void RemoveAll(const XTP_EDIT_LINEMARKTYPE lmType);
361
369 int GetCount(const XTP_EDIT_LINEMARKTYPE lmType) const;
370
371private:
379 class CLineMarksList : public CXTPCmdTarget
380 {
381 public:
386 virtual ~CLineMarksList();
387
395 void Add(const XTP_EDIT_LMDATA& lmData);
396
402 void Remove(const int nKey);
403
408 void RemoveAll();
409
416 int GetCount() const;
417
425 POSITION FindAt(int nKey) const;
426
436 POSITION FindNext(int nKey) const;
437
447 POSITION FindPrev(int nKey) const;
448
459 void RefreshLineMarks(int nRowFrom, int nRowTo, int nRefreshType);
460
469 XTP_EDIT_LMDATA* GetLineMarkAt(const POSITION pos) const;
470
477 POSITION GetFirstLineMark() const;
478
487 XTP_EDIT_LMDATA* GetNextLineMark(POSITION& pos) const;
488
489 private:
498 int FindIndex(const int nKey) const;
499
509 int FindLowerIndex(const int nKey) const;
510
520 int FindUpperIndex(const int nKey) const;
521
522 private:
523 typedef CArray<XTP_EDIT_LMDATA*, XTP_EDIT_LMDATA*> CXTPSyntaxEditLineMarkPointersArray;
524 CXTPSyntaxEditLineMarkPointersArray m_array;
525 };
526
527public:
528 typedef CXTPSmartPtrInternalT<CLineMarksList> CLineMarksListPtr;
530private:
539 class CLineMarksListsMap
540 {
541 public:
549 CLineMarksListPtr GetList(LPCTSTR szMarkType) const;
550
560 CLineMarksListPtr AddList(LPCTSTR szMarkType);
561
572 void RefreshLineMarks(int nRowFrom, int nRowTo, int nRefreshType);
573
574 private:
575 CMap<CString, LPCTSTR, CLineMarksListPtr, CLineMarksListPtr&> m_map;
578 };
579
580 CLineMarksListsMap m_mapLists;
582protected:
583# ifdef _XTP_ACTIVEX
586 DECLARE_DISPATCH_MAP()
587 DECLARE_INTERFACE_MAP()
588
589 DECLARE_OLETYPELIB_EX(CXTPSyntaxEditLineMarksManager)
590
591 afx_msg void OleAddRemoveLineMark(int nRow, const XTP_EDIT_LINEMARKTYPE lmType);
592 afx_msg void OleSetLineMark(int nRow, const XTP_EDIT_LINEMARKTYPE lmType);
593 afx_msg void OleDeleteLineMark(int nRow, const XTP_EDIT_LINEMARKTYPE lmType);
594 afx_msg BOOL OleHasRowMark(int nRow, const XTP_EDIT_LINEMARKTYPE lmType);
595 afx_msg POSITION OleFindPrevLineMark(int nRow, const XTP_EDIT_LINEMARKTYPE lmType);
596 afx_msg POSITION OleFindNextLineMark(int nRow, const XTP_EDIT_LINEMARKTYPE lmType);
597 afx_msg POSITION OleGetLastLineMark(const XTP_EDIT_LINEMARKTYPE lmType);
598 afx_msg POSITION OleGetFirstLineMark(const XTP_EDIT_LINEMARKTYPE lmType);
599 afx_msg long OleGetLineMarkAt(const POSITION pos, const XTP_EDIT_LINEMARKTYPE lmType);
600 afx_msg void OleRemoveAll(XTP_EDIT_LINEMARKTYPE lmType);
601 afx_msg long OleGetCount(XTP_EDIT_LINEMARKTYPE lmType);
602
604# endif
605};
606
607# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
609#endif // !defined(__XTPSYNTAXEDITLINEMARKSMANAGER_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
SAFE_DELETE
#define SAFE_DELETE(ptr)
Frees dynamically allocated memory.
Definition XTPMacros.h:63
XTPSyntaxEditLineMarksRefreshType
XTPSyntaxEditLineMarksRefreshType
Enumerates types of mark refreshing.
Definition XTPSyntaxEditLineMarksManager.h:47
xtpEditLMRefresh_Delete
@ xtpEditLMRefresh_Delete
Mark deleted.
Definition XTPSyntaxEditLineMarksManager.h:50
xtpEditLMRefresh_Insert
@ xtpEditLMRefresh_Insert
Mark inserted.
Definition XTPSyntaxEditLineMarksManager.h:49
xtpEditLMRefresh_Unknown
@ xtpEditLMRefresh_Unknown
Unknown refresh state.
Definition XTPSyntaxEditLineMarksManager.h:48
xtpEditLMRefresh_InsertAt0
@ xtpEditLMRefresh_InsertAt0
Move mark for first row of inserted text block.
Definition XTPSyntaxEditLineMarksManager.h:54
xtpEditLMRefresh_Delete_only2
@ xtpEditLMRefresh_Delete_only2
Delete mark for last row of deleted text block.
Definition XTPSyntaxEditLineMarksManager.h:53
xtpEditLMRefresh_Delete_only1
@ xtpEditLMRefresh_Delete_only1
Delete mark for first row of deleted text block.
Definition XTPSyntaxEditLineMarksManager.h:52
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPSmartPtrInternalT
Definition XTPSmartPtrInternalT.h:72
CXTPSyntaxEditLineMarksManager
The CXTPSyntaxEditLineMarksManager class provides functionality to manipulate marks on text lines.
Definition XTPSyntaxEditLineMarksManager.h:201
CXTPSyntaxEditLineMarksManager::GetLineMarkAt
XTP_EDIT_LMDATA * GetLineMarkAt(const POSITION pos, const XTP_EDIT_LINEMARKTYPE lmType) const
Gets the identifier of the row with a specified mark type at a specified position.
CXTPSyntaxEditLineMarksManager::HasRowMark
BOOL HasRowMark(int nRow, const XTP_EDIT_LINEMARKTYPE &lmType, XTP_EDIT_LMPARAM *pParam=NULL) const
Determines if a specified row has a specified mark.
CXTPSyntaxEditLineMarksManager::RefreshLineMarks
virtual void RefreshLineMarks(int nRowFrom, int nRowTo, int nRefreshType)
Refreshes the line marks for a specified range of rows.
CXTPSyntaxEditLineMarksManager::FindPrevLineMark
POSITION FindPrevLineMark(int &nRow, const XTP_EDIT_LINEMARKTYPE lmType) const
Gets the position of the row with a specified mark type that precedes a specified row.
CXTPSyntaxEditLineMarksManager::SetLineMark
void SetLineMark(int nRow, const XTP_EDIT_LINEMARKTYPE lmType, XTP_EDIT_LMPARAM *pParam=NULL)
Adds a specified mark to a specified row.
CXTPSyntaxEditLineMarksManager::~CXTPSyntaxEditLineMarksManager
virtual ~CXTPSyntaxEditLineMarksManager()
Destroys a CXTPSyntaxEditLineMarksManager object, handles cleanup and de-allocation.
CXTPSyntaxEditLineMarksManager::DeleteLineMark
void DeleteLineMark(int nRow, const XTP_EDIT_LINEMARKTYPE lmType)
Removes a specified mark from a specified row.
CXTPSyntaxEditLineMarksManager::CLineMarksListPtr
CXTPSmartPtrInternalT< CLineMarksList > CLineMarksListPtr
SmartPointer for the class.
Definition XTPSyntaxEditLineMarksManager.h:528
CXTPSyntaxEditLineMarksManager::GetFirstLineMark
POSITION GetFirstLineMark(const XTP_EDIT_LINEMARKTYPE lmType) const
Gets the position of the first row with a specified mark type.
CXTPSyntaxEditLineMarksManager::CXTPSyntaxEditLineMarksManager
CXTPSyntaxEditLineMarksManager()
Default object constructor.
CXTPSyntaxEditLineMarksManager::GetNextLineMark
XTP_EDIT_LMDATA * GetNextLineMark(POSITION &pos, const XTP_EDIT_LINEMARKTYPE lmType) const
Gets the identifier of the row with a specified mark type that follows a specified position.
CXTPSyntaxEditLineMarksManager::GetCount
int GetCount(const XTP_EDIT_LINEMARKTYPE lmType) const
Gets the number of line marks of a specified type.
CXTPSyntaxEditLineMarksManager::RemoveAll
void RemoveAll(const XTP_EDIT_LINEMARKTYPE lmType)
Removes all line marks of a specified type.
CXTPSyntaxEditLineMarksManager::FindNextLineMark
POSITION FindNextLineMark(int &nRow, const XTP_EDIT_LINEMARKTYPE lmType) const
Gets the position of the row with a specified mark type that follows a specified row.
CXTPSyntaxEditLineMarksManager::GetLastLineMark
POSITION GetLastLineMark(const XTP_EDIT_LINEMARKTYPE lmType) const
Gets the position of the last row with a specified mark type.
CXTPSyntaxEditLineMarksManager::AddRemoveLineMark
void AddRemoveLineMark(int nRow, const XTP_EDIT_LINEMARKTYPE lmType, XTP_EDIT_LMPARAM *pParam=NULL)
Adds/removes a specified mark to/from a specified row.


Toolkit Pro: XTPTaskPanelNativeWindows10Theme.h Source File

  • Source
  • TaskPanel
  • Themes
XTPTaskPanelNativeWindows10Theme.h
Go to the documentation of this file.
1
23#if !defined(__XTPTASKPANELNATIVEWINDOWS10THEME_H__)
24# define __XTPTASKPANELNATIVEWINDOWS10THEME_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
39class _XTP_EXT_CLASS CXTPTaskPanelNativeWindows10Theme : public CXTPTaskPanelVisualStudio2012Theme
40{
41protected:
42 void Triangle(CDC* pDC, POINT* pPoints, COLORREF clr, BOOL bFilled);
43
44public:
49 CXTPTaskPanelNativeWindows10Theme();
50
56 virtual ~CXTPTaskPanelNativeWindows10Theme();
57
62 virtual void RefreshMetrics();
63};
65# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
66#endif // __XTPTASKPANELNATIVEWINDOWS10THEME_H__
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPTaskPanelNativeWindows10Theme
CXTPTaskPanelNativeWindows10Theme represents a Native Windows 10 style theme.
Definition XTPTaskPanelNativeWindows10Theme.h:40
CXTPTaskPanelNativeWindows10Theme::~CXTPTaskPanelNativeWindows10Theme
virtual ~CXTPTaskPanelNativeWindows10Theme()
Destroys a CXTPTaskPanelNativeWindows10Theme object, handles cleanup and deallocation.
CXTPTaskPanelNativeWindows10Theme::CXTPTaskPanelNativeWindows10Theme
CXTPTaskPanelNativeWindows10Theme()
Constructs a CXTPTaskPanelNativeWindows10Theme object.
CXTPTaskPanelNativeWindows10Theme::RefreshMetrics
virtual void RefreshMetrics()
Refreshes the visual metrics of the task panel.
CXTPTaskPanelVisualStudio2012Theme
CXTPTaskPanelVisualStudio2012Theme represents a VS.NET 2012 style theme.
Definition XTPTaskPanelVisualStudio2012Theme.h:40


Toolkit Pro: XTPChartSeriesStyle.h Source File

  • Source
  • Chart
XTPChartSeriesStyle.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTSERIESSTYLE_H__)
24# define __XTPCHARTSERIESSTYLE_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartDiagram;
34class CXTPChartSeriesLabel;
35class CXTPChartSeriesView;
36class CXTPChartSeries;
37class CXTPChartDiagramView;
38class CXTPChartAxis;
39class CXTPChartSeriesStyleAppearance;
40class CXTPChartErrorBar;
41class CXTPChartDeviceCommand;
42
48class _XTP_EXT_CLASS CXTPChartSeriesStyle : public CXTPChartElement
49{
50 DECLARE_DYNAMIC(CXTPChartSeriesStyle);
51
52public:
57 CXTPChartSeriesStyle();
58
63 virtual ~CXTPChartSeriesStyle();
64
65public:
73 virtual CXTPChartSeriesLabel* GetLabel() const;
74
84 virtual CXTPChartSeriesLabel* SetLabel(CXTPChartSeriesLabel* pLabel);
85
93 virtual CXTPChartErrorBar* GetErrorBar() const;
94
104 virtual CXTPChartErrorBar* SetErrorBar(CXTPChartErrorBar* pErrorBar);
105
114 virtual CXTPChartDiagram* CreateDiagram();
115
127 virtual BOOL IsStyleDiagram(CXTPChartDiagram* pDiagram) const;
128
137 virtual CXTPChartColor GetColor() const;
138
146 virtual void SetColor(CXTPChartColor clr);
147
154 virtual void SetColorEach(BOOL bColorEach);
155
162 virtual BOOL IsColorEach() const;
163
174 virtual CXTPChart3dRotation Get3dRotation() const;
175
185 virtual void Set3dRotation(const CXTPChart3dRotation& rotation);
186
198 virtual void Set3dRotation(double dYaw, double dPitch, double dRoll);
199
207 virtual BOOL Is3dEdgeSmoothingEnabled() const;
208
215 virtual void Enable3dEdgeSmoothing(BOOL bEnable = TRUE);
216
225 virtual int GetTransparency() const;
226
235 virtual void SetTransparency(int nTransparency);
236
246 virtual void CorrectAxisSideMargins(CXTPChartAxis* pAxis, double nMinValue, double nMaxValue,
247 double& nCorrection);
248
256 virtual CXTPChartSeriesStyleAppearance* GetStyleAppearance() const;
257
265 virtual void ApplyTo(CXTPChartDeviceCommand* pCommand);
266
276 virtual int GetSeriesPointValueIndex() const;
277
284 virtual void DoPropExchange(CXTPPropExchange* pPX);
285
296 virtual CXTPChartSeriesView* CreateView(CXTPChartSeries* pSeries,
297 CXTPChartDiagramView* pDiagramView) = 0;
298
299# ifdef _XTP_ACTIVEX
300public:
303 DECLARE_DISPATCH_MAP()
304 DECLARE_INTERFACE_MAP()
305 DECLARE_OLETYPELIB_EX(CXTPChartSeriesStyle);
306
307 afx_msg void OleChartChanged();
308 afx_msg LPDISPATCH OleGetLabel();
309 afx_msg LPDISPATCH OleGetErrorBar();
310 afx_msg BOOL OleGetColorEach();
311 afx_msg void OleSetColorEach(BOOL bColorEach);
312 afx_msg OLE_COLOR OleGetColor();
313 afx_msg void OleSetColor(OLE_COLOR clr);
314 afx_msg LPDISPATCH OleGet3dRotation();
315 afx_msg void OleSet3dRotation(LPDISPATCH pRotationDisp);
316
318# endif
319
320protected:
321 friend class CXTPChartSeries;
322
323 CXTPChartSeriesLabel* m_pLabel;
324 CXTPChartErrorBar* m_pErrorBar;
326 CXTPChartColor m_clrColor;
328 BOOL m_bColorEach;
330 int m_nTransparency;
332 CXTPChart3dRotation m_Rotation3d;
333 BOOL m_bSmooth3dEdges;
334};
335
336AFX_INLINE CXTPChartDiagram* CXTPChartSeriesStyle::CreateDiagram()
337{
338 return NULL;
339}
340
341AFX_INLINE CXTPChartSeriesLabel* CXTPChartSeriesStyle::GetLabel() const
342{
343 return m_pLabel;
344}
345
346AFX_INLINE CXTPChartErrorBar* CXTPChartSeriesStyle::GetErrorBar() const
347{
348 return m_pErrorBar;
349}
350
351AFX_INLINE CXTPChartColor CXTPChartSeriesStyle::GetColor() const
352{
353 return m_clrColor;
354}
355
356AFX_INLINE void CXTPChartSeriesStyle::SetColor(CXTPChartColor clr)
357{
358 m_clrColor = clr;
359 OnChartChanged();
360}
361
362AFX_INLINE BOOL CXTPChartSeriesStyle::IsColorEach() const
363{
364 return m_bColorEach;
365}
366
367AFX_INLINE void CXTPChartSeriesStyle::SetColorEach(BOOL bColorEach)
368{
369 m_bColorEach = bColorEach;
370 OnChartChanged();
371}
372
373AFX_INLINE CXTPChart3dRotation CXTPChartSeriesStyle::Get3dRotation() const
374{
375 return m_Rotation3d;
376}
377
378AFX_INLINE void CXTPChartSeriesStyle::Set3dRotation(double dYaw, double dPitch, double dRoll)
379{
380 Set3dRotation(CXTPChart3dRotation(dYaw, dPitch, dRoll));
381}
382
383AFX_INLINE void CXTPChartSeriesStyle::Set3dRotation(const CXTPChart3dRotation& rotation)
384{
385 m_Rotation3d = rotation;
386 OnChartChanged();
387}
388
389AFX_INLINE BOOL CXTPChartSeriesStyle::Is3dEdgeSmoothingEnabled() const
390{
391 return m_bSmooth3dEdges;
392}
393
394AFX_INLINE void CXTPChartSeriesStyle::Enable3dEdgeSmoothing(BOOL bEnable /*= TRUE*/)
395{
396 m_bSmooth3dEdges = bEnable;
397 OnChartChanged();
398}
399
400AFX_INLINE int CXTPChartSeriesStyle::GetTransparency() const
401{
402 return m_nTransparency;
403}
404
405AFX_INLINE void CXTPChartSeriesStyle::SetTransparency(int nTransparency)
406{
407 _ASSERTE("Transparency value must be within range [0..255]" && 0 <= nTransparency
408 && nTransparency <= 255);
409 m_nTransparency = nTransparency;
410 OnChartChanged();
411}
412
413AFX_INLINE int CXTPChartSeriesStyle::GetSeriesPointValueIndex() const
414{
415 return 0;
416}
418# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
419#endif //#if !defined(__XTPCHARTSERIESSTYLE_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChart3dRotation
Represents a 3D rotation primitive for chart objects using Euler angles Yaw, Pitch and Roll in degree...
Definition XTPChartTypes.h:639
CXTPChartAxis
This abstract base class represents a chart axis as a kind of chart element.
Definition XTPChartAxis.h:86
CXTPChartColor
This class abstracts a color entity.
Definition XTPChartTypes.h:51
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPChartDiagram
This class represents a chart diagram, which is a kind of CXTPChartElement.
Definition XTPChartDiagram.h:48
CXTPChartDiagramView
This class represents the view of a chart diagram, which is a kind of CXTPChartElementView.
Definition XTPChartDiagramView.h:49
CXTPChartElement
This class abstracts a chart element, this class acts as a base class for all chart elements.
Definition XTPChartElement.h:131
CXTPChartElement::OnChartChanged
virtual void OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic propertie...
CXTPChartSeries
This class represents a series in the chart, which is a kind of CXTPChartElement.
Definition XTPChartSeries.h:50
CXTPChartSeriesLabel
This class abstracts the label of a series.
Definition XTPChartSeriesLabel.h:49
CXTPChartSeriesStyle
CXTPChartSeriesStyle is a CXTPChartElement derived class.
Definition XTPChartSeriesStyle.h:49
CXTPChartSeriesStyle::DoPropExchange
virtual void DoPropExchange(CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
CXTPChartSeriesStyle::CreateDiagram
virtual CXTPChartDiagram * CreateDiagram()
Implementations can override this method to customize the creation of a diagram object.
Definition XTPChartSeriesStyle.h:336
CXTPChartSeriesStyle::GetStyleAppearance
virtual CXTPChartSeriesStyleAppearance * GetStyleAppearance() const
Obtains associated style appearance pointer.
CXTPChartSeriesStyle::SetLabel
virtual CXTPChartSeriesLabel * SetLabel(CXTPChartSeriesLabel *pLabel)
Call this method to sets the series label object.
CXTPChartSeriesStyle::m_Rotation3d
CXTPChart3dRotation m_Rotation3d
3D rotation
Definition XTPChartSeriesStyle.h:332
CXTPChartSeriesStyle::m_nTransparency
int m_nTransparency
The transparency value in the range 0..255.
Definition XTPChartSeriesStyle.h:330
CXTPChartSeriesStyle::SetColor
virtual void SetColor(CXTPChartColor clr)
Call this method to set the color of the series.
Definition XTPChartSeriesStyle.h:356
CXTPChartSeriesStyle::m_bColorEach
BOOL m_bColorEach
TRUE to color each point.
Definition XTPChartSeriesStyle.h:328
CXTPChartSeriesStyle::GetLabel
virtual CXTPChartSeriesLabel * GetLabel() const
Call this method to gets the series label object.
Definition XTPChartSeriesStyle.h:341
CXTPChartSeriesStyle::m_clrColor
CXTPChartColor m_clrColor
Custom color of series.
Definition XTPChartSeriesStyle.h:326
CXTPChartSeriesStyle::IsStyleDiagram
virtual BOOL IsStyleDiagram(CXTPChartDiagram *pDiagram) const
Implementations should override this method to customize the logic of checking diagram compatibility ...
CXTPChartSeriesStyle::GetSeriesPointValueIndex
virtual int GetSeriesPointValueIndex() const
Obtains the index of a point element for which an internal value can be otained.
Definition XTPChartSeriesStyle.h:413
CXTPChartSeriesStyle::SetTransparency
virtual void SetTransparency(int nTransparency)
Call this function to sets the transparency of the chart if it is supported by the chart type.
Definition XTPChartSeriesStyle.h:405
CXTPChartSeriesStyle::m_pLabel
CXTPChartSeriesLabel * m_pLabel
Label object.
Definition XTPChartSeriesStyle.h:323
CXTPChartSeriesStyle::Set3dRotation
virtual void Set3dRotation(const CXTPChart3dRotation &rotation)
Sets rotation parameters for 3D chart.
Definition XTPChartSeriesStyle.h:383
CXTPChartSeriesStyle::GetColor
virtual CXTPChartColor GetColor() const
Call this method to get the color of the series.
Definition XTPChartSeriesStyle.h:351
CXTPChartSeriesStyle::~CXTPChartSeriesStyle
virtual ~CXTPChartSeriesStyle()
Destroys a CXTPChartSeriesStyle object, handles cleanup.
CXTPChartSeriesStyle::SetErrorBar
virtual CXTPChartErrorBar * SetErrorBar(CXTPChartErrorBar *pErrorBar)
Call this method to sets the error bar object.
CXTPChartSeriesStyle::ApplyTo
virtual void ApplyTo(CXTPChartDeviceCommand *pCommand)
Applies the style to the command provided in case the command needs style specific details for correc...
CXTPChartSeriesStyle::CreateView
virtual CXTPChartSeriesView * CreateView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)=0
This virtual method is called to create a new view associated with the current style.
CXTPChartSeriesStyle::IsColorEach
virtual BOOL IsColorEach() const
This method is called to check if individual color is used for each point of the series.
Definition XTPChartSeriesStyle.h:362
CXTPChartSeriesStyle::Enable3dEdgeSmoothing
virtual void Enable3dEdgeSmoothing(BOOL bEnable=TRUE)
Enables/disables 3D edge smoothing.
Definition XTPChartSeriesStyle.h:394
CXTPChartSeriesStyle::m_bSmooth3dEdges
BOOL m_bSmooth3dEdges
3D edge smoothing
Definition XTPChartSeriesStyle.h:333
CXTPChartSeriesStyle::GetTransparency
virtual int GetTransparency() const
Call this function to gets the transparency of the chart if it is supported by the chart type.
Definition XTPChartSeriesStyle.h:400
CXTPChartSeriesStyle::GetErrorBar
virtual CXTPChartErrorBar * GetErrorBar() const
Call this method to gets the error bar object.
Definition XTPChartSeriesStyle.h:346
CXTPChartSeriesStyle::CXTPChartSeriesStyle
CXTPChartSeriesStyle()
Constructs a CXTPChartSeriesStyle object.
CXTPChartSeriesStyle::Get3dRotation
virtual CXTPChart3dRotation Get3dRotation() const
Obtains rotation parameters for 3D chart.
Definition XTPChartSeriesStyle.h:373
CXTPChartSeriesStyle::CorrectAxisSideMargins
virtual void CorrectAxisSideMargins(CXTPChartAxis *pAxis, double nMinValue, double nMaxValue, double &nCorrection)
Provides default implementation for axis side margins correction.
CXTPChartSeriesStyle::SetColorEach
virtual void SetColorEach(BOOL bColorEach)
Call this method to set individual color for each point of the series.
Definition XTPChartSeriesStyle.h:367
CXTPChartSeriesStyle::m_pErrorBar
CXTPChartErrorBar * m_pErrorBar
Error bar object.
Definition XTPChartSeriesStyle.h:324
CXTPChartSeriesStyle::Is3dEdgeSmoothingEnabled
virtual BOOL Is3dEdgeSmoothingEnabled() const
Enables/disables 3D edge smoothing.
Definition XTPChartSeriesStyle.h:389
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72


Toolkit Pro: Member List

CXTPCalendarTimeZones Member List

This is the complete list of members for CXTPCalendarTimeZones, including all inherited members.

CXTPCalendarTimeZones() | CXTPCalendarTimeZones |
CXTPCmdTarget() | CXTPCmdTarget |
Find(const TIME_ZONE_INFORMATION *pTZI2) const | CXTPCalendarTimeZones |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAt(long nIndex) const | CXTPCalendarTimeZones |
GetCount() const | CXTPCalendarTimeZones |
GetRegBSTR(HKEY hKey, LPCWSTR pcszValueNameW, BSTR &rbstrValue) | CXTPCalendarTimeZones | static
GetRegDWORD(HKEY hKey, LPCTSTR pcszValueName, DWORD &rdwValue) | CXTPCalendarTimeZones | static
GetRegStr(HKEY hKey, LPCTSTR pcszValueName, CString &rstrValue) | CXTPCalendarTimeZones | static
GetRegTZI(HKEY hKey, LPCTSTR pcszValueName, REGISTRY_TIMEZONE_INFORMATION &rRegTZI) | CXTPCalendarTimeZones | static
InitFromRegistry() | CXTPCalendarTimeZones |
m_arTZInfo | CXTPCalendarTimeZones | protected
~CXTPCalendarTimeZones() | CXTPCalendarTimeZones | virtual


Toolkit Pro: Member List

CXTPChartPaletteEntry Member List

This is the complete list of members for CXTPChartPaletteEntry, including all inherited members.


Toolkit Pro: Member List

CXTPMarkupGdiPlusTranslateTransform Member List

This is the complete list of members for CXTPMarkupGdiPlusTranslateTransform, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPMarkupGdiPlusTransformObject() | CXTPMarkupGdiPlusTransformObject< CXTPMarkupTranslateTransform > | protected
CXTPMarkupGdiPlusTransformObjectImpl() | CXTPMarkupGdiPlusTransformObjectImpl | protected
CXTPMarkupTransform() | CXTPMarkupTransform | protected
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetX() const | CXTPMarkupTranslateTransform |
GetY() const | CXTPMarkupTranslateTransform |
m_pPropertyX | CXTPMarkupTranslateTransform | static
m_pPropertyY | CXTPMarkupTranslateTransform | static
SetX(double x) | CXTPMarkupTranslateTransform |
SetY(double y) | CXTPMarkupTranslateTransform |
~CXTPMarkupGdiPlusTransformObjectImpl() | CXTPMarkupGdiPlusTransformObjectImpl | inlineprotectedvirtual


Toolkit Pro: XTPChartBarSeriesLabel.h Source File

  • Source
  • Chart
  • Styles
  • Bar
XTPChartBarSeriesLabel.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTBARSERIESLABEL_H__)
24# define __XTPCHARTBARSERIESLABEL_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartSeriesView;
34
35enum XTPChartBarLabelPosition
36{
37 xtpChartBarLabelTop,
38 xtpChartBarLabelCenter
39};
40
46class _XTP_EXT_CLASS CXTPChartBarSeriesLabel : public CXTPChartDiagram2DSeriesLabel
47{
48 DECLARE_SERIAL(CXTPChartBarSeriesLabel);
49
50public:
55 CXTPChartBarSeriesLabel();
56
61 virtual ~CXTPChartBarSeriesLabel();
62
63public:
64 void SetPosition(XTPChartBarLabelPosition nPosition);
65 XTPChartBarLabelPosition GetPosition() const;
66
67public:
80 virtual CXTPChartElementView* CreateView(CXTPChartDeviceContext* pDC,
81 CXTPChartSeriesPointView* pPointView,
82 CXTPChartElementView* pParentView);
83
84 void DoPropExchange(CXTPPropExchange* pPX);
85
86protected:
87 XTPChartBarLabelPosition m_nPosition;
88
89# ifdef _XTP_ACTIVEX
90public:
92 DECLARE_DISPATCH_MAP()
93 DECLARE_INTERFACE_MAP()
94 DECLARE_OLETYPELIB_EX(CXTPChartBarSeriesLabel);
96# endif
97};
98
104class _XTP_EXT_CLASS CXTPChartBarSeriesLabelView : public CXTPChartDiagram2DSeriesLabelView
105{
106public:
115 CXTPChartBarSeriesLabelView(CXTPChartSeriesLabel* pLabel, CXTPChartSeriesPointView* pPointView,
116 CXTPChartElementView* pParentView);
117
124 virtual CXTPChartPointF GetAnchorPoint() const;
125 virtual double GetAnchorAngle() const;
126
127 using CXTPChartDiagram2DSeriesLabelView::CreateDeviceCommand;
128
129 virtual CXTPChartDeviceCommand* CreateDeviceCommand(CXTPChartDeviceContext* pDC);
130 void CalculateLayout(CXTPChartDeviceContext* pDC);
131};
132
133AFX_INLINE void CXTPChartBarSeriesLabel::SetPosition(XTPChartBarLabelPosition nPosition)
134{
135 m_nPosition = nPosition;
136 OnChartChanged();
137}
138AFX_INLINE XTPChartBarLabelPosition CXTPChartBarSeriesLabel::GetPosition() const
139{
140 return m_nPosition;
141}
143# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
144#endif //#if !defined(__XTPCHARTBARSERIESLABEL_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartBarSeriesLabel
This class abstracts the label of a bar series.
Definition XTPChartBarSeriesLabel.h:47
CXTPChartBarSeriesLabel::DoPropExchange
void DoPropExchange(CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
CXTPChartBarSeriesLabel::~CXTPChartBarSeriesLabel
virtual ~CXTPChartBarSeriesLabel()
Destroys a CXTPChartBarSeriesLabel object, handles cleanup.
CXTPChartBarSeriesLabel::CXTPChartBarSeriesLabel
CXTPChartBarSeriesLabel()
Constructs a CXTPChartBarSeriesLabel object.
CXTPChartBarSeriesLabel::CreateView
virtual CXTPChartElementView * CreateView(CXTPChartDeviceContext *pDC, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView)
This function creates the view of the bar series label.
CXTPChartBarSeriesLabelView
This class abstracts the view of the label of a bar series.
Definition XTPChartBarSeriesLabel.h:105
CXTPChartBarSeriesLabelView::CXTPChartBarSeriesLabelView
CXTPChartBarSeriesLabelView(CXTPChartSeriesLabel *pLabel, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView)
Constructs a CXTPChartBarSeriesLabel object.
CXTPChartBarSeriesLabelView::CreateDeviceCommand
virtual CXTPChartDeviceCommand * CreateDeviceCommand(CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
CXTPChartBarSeriesLabelView::GetAnchorPoint
virtual CXTPChartPointF GetAnchorPoint() const
This function calculates the anchor point of the label stem.
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartDiagram2DSeriesLabel
This class abstracts the label of a point series.
Definition XTPChartDiagram2DSeriesLabel.h:41
CXTPChartDiagram2DSeriesLabelView
This class abstracts the view of the label of a point series.
Definition XTPChartDiagram2DSeriesLabel.h:69
CXTPChartDiagram2DSeriesLabelView::CreateDeviceCommand
virtual CXTPChartDeviceCommand * CreateDeviceCommand(CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
CXTPChartElement::OnChartChanged
virtual void OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic propertie...
CXTPChartElementView
This class represents the view of a chart element.
Definition XTPChartElementView.h:47
CXTPChartSeriesLabel
This class abstracts the label of a series.
Definition XTPChartSeriesLabel.h:49
CXTPChartSeriesPointView
Represents chart series point view.
Definition XTPChartSeriesPointView.h:48
CXTPPoint2T< float >
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72


Toolkit Pro: XTPEditThemeUltraFlat.h Source File

  • Source
  • Controls
  • Edit
  • Themes
XTPEditThemeUltraFlat.h
Go to the documentation of this file.
1
23#if !defined(__XTPEDITTHEMEULTRAFLAT_H__)
24# define __XTPEDITTHEMEULTRAFLAT_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
37class _XTP_EXT_CLASS CXTPEditThemeUltraFlat : public CXTPEditThemeOfficeXP
38{
39public:
44 CXTPEditThemeUltraFlat();
45
50 virtual ~CXTPEditThemeUltraFlat();
51
58 virtual void RefreshMetrics(CXTPEdit* pEdit);
59};
60
61# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
63#endif // __XTPEDITTHEMEULTRAFLAT_H__
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPEdit
CXTPEdit is a CEdit derived class.
Definition XTPEdit.h:129
CXTPEditThemeOfficeXP
CXTPEditThemeOfficeXP is a class used to perform theme drawing tasks.
Definition XTPEditThemeOfficeXP.h:38
CXTPEditThemeUltraFlat
CXTPEditThemeUltraFlat is a class used to perform theme drawing tasks.
Definition XTPEditThemeUltraFlat.h:38
CXTPEditThemeUltraFlat::CXTPEditThemeUltraFlat
CXTPEditThemeUltraFlat()
Constructs a CXTPEditThemeUltraFlat object.
CXTPEditThemeUltraFlat::~CXTPEditThemeUltraFlat
virtual ~CXTPEditThemeUltraFlat()
Destructor, handles cleanup and deallocation.
CXTPEditThemeUltraFlat::RefreshMetrics
virtual void RefreshMetrics(CXTPEdit *pEdit)
This member function is called by the theme manager to refresh the visual styles used by each compone...


Toolkit Pro: Member List

CXTPVisualStudio2005Theme Member List

This is the complete list of members for CXTPVisualStudio2005Theme, including all inherited members.

AdjustExcludeRect(CRect &rc, CXTPControl *pControl, BOOL bVertical) | CXTPCommandBarsOfficeXPTheme | virtual
Animate(CDC *pDestDC, CDC *pSrcDC, CRect rc, XTPAnimationType animationType) | CXTPPaintManager | virtual
AnimateExpanding(CXTPCommandBar *pCommandBar, CDC *pDestDC, CDC *pSrcDC, BOOL bExpandDown) | CXTPPaintManager | virtual
BaseTheme() | CXTPVisualStudio2005Theme | inlinevirtual
CreateGradientCircle() | CXTPCommandBarsOffice2003Theme | protected
CreateTheme(XTPPaintTheme paintTheme) | CXTPPaintManager | static
CXTPCmdTarget() | CXTPCmdTarget |
CXTPCommandBarsOffice2003Theme() | CXTPCommandBarsOffice2003Theme |
CXTPCommandBarsOfficeXPTheme() | CXTPCommandBarsOfficeXPTheme |
CXTPObservable() | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | protected
CXTPPaintManager() | CXTPPaintManager | protected
CXTPVisualStudio2005Theme() | CXTPVisualStudio2005Theme |
Draw3dRect(CDC *pDC, LPCRECT rc, int nTopLeft, int nBottomRight) | CXTPPaintManager |
Draw3dRect(CDC *pDC, LPCRECT rc, int frameThickness, COLORREF clrPen, COLORREF clrBrush) | CXTPPaintManager |
CXTPPaintManager::DrawCheckMark(CDC *pDC, CRect rcCheck, COLORREF clr=0) | CXTPPaintManager | inline
DrawComboExpandMark(CDC *pDC, CRect rc, COLORREF clr) | CXTPPaintManager | virtual
DrawCommandBarGripper(CDC *pDC, CXTPCommandBar *pBar, BOOL bDraw=TRUE) | CXTPCommandBarsOffice2003Theme | protectedvirtual
DrawCommandBarGroupSeparator(CDC *pDC, CXTPCommandBar *pBar, CXTPControl *pLeftControl, CXTPControl *pRightControl, BOOL bDraw=TRUE) | CXTPPaintManager | virtual
DrawCommandBarSeparator(CDC *pDC, CXTPCommandBar *pBar, CXTPControl *pControl, BOOL bDraw=TRUE) | CXTPCommandBarsOffice2003Theme | protectedvirtual
DrawControl(CDC *pDC, CXTPControl *pButton, BOOL bDraw=TRUE) | CXTPPaintManager |
DrawControlCheckBoxMark(CDC *pDC, CRect rc, BOOL bDraw, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled) | CXTPCommandBarsOfficeXPTheme | protectedvirtual
DrawControlCheckBoxMark(CDC *pDC, CXTPControl *pButton, CRect rc, BOOL bDraw) | CXTPCommandBarsOfficeXPTheme | protectedvirtual
DrawControlComboBox(CDC *pDC, CXTPControlComboBox *pComboBox, BOOL bDraw) | CXTPCommandBarsOfficeXPTheme | protectedvirtual
DrawControlEdit(CDC *pDC, CXTPControlEdit *pEdit, BOOL bDraw) | CXTPCommandBarsOfficeXPTheme | protectedvirtual
DrawControlEntry(CDC *pDC, CXTPControl *pButton) | CXTPPaintManager | virtual
DrawControlMDIButton(CDC *pDC, CXTPControlButton *pButton) | CXTPPaintManager | virtual
DrawControlPopupParent(CDC *pDC, CXTPControl *pButton, BOOL bDraw) | CXTPCommandBarsOfficeXPTheme | protectedvirtual
DrawControlRadioButtonMark(CDC *pDC, CRect rc, BOOL bDraw, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled) | CXTPCommandBarsOfficeXPTheme | protectedvirtual
DrawControlText(CDC *pDC, CXTPControl *pControl, CRect rcText, BOOL bDraw, BOOL bVert, BOOL bCentered, BOOL bTriangled) | CXTPPaintManager |
DrawControlToolBarParent(CDC *pDC, CXTPControl *pButton, BOOL bDraw) | CXTPPaintManager | virtual
DrawDialogBarGripper(CDC *pDC, CXTPDialogBar *pBar, BOOL bDraw) | CXTPCommandBarsOffice2003Theme | protectedvirtual
DrawDropDownGlyph(CDC *pDC, CXTPControl *pControl, CPoint pt, BOOL bSelected, BOOL bPopuped, BOOL bEnabled, BOOL bVert) | CXTPPaintManager | virtual
DrawExpandGlyph(CDC *pDC, CXTPControl *pButton, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clr) | CXTPPaintManager | virtual
DrawExpandGlyph(CDC *pDC, CXTPControl *pButton, COLORREF clr, BOOL bVertical) | CXTPPaintManager | virtual
DrawGalleryItemBack(CDC *pDC, CRect rcItem, BOOL bEnabled, BOOL bSelected, BOOL bPressed, BOOL bChecked, XTPBarType barType) | CXTPPaintManager | virtual
DrawHiddenGlyph(CDC *pDC, CXTPControl *pButton, COLORREF clr, BOOL bVertical) | CXTPPaintManager | virtual
DrawImage(CDC *pDC, CPoint pt, CSize sz, CXTPImageManagerIcon *pImage, BOOL bSelected, BOOL bPressed, BOOL bEnabled=TRUE, BOOL bChecked=FALSE, BOOL bPopuped=FALSE, BOOL bToolBarImage=TRUE) | CXTPCommandBarsOfficeXPTheme | protectedvirtual
DrawListBoxControl(CDC *pDC, CXTPControl *pButton, CRect rc, BOOL bSelected, BOOL bDraw, CXTPCommandBars *pCommandBars=0) | CXTPCommandBarsOfficeXPTheme | virtual
DrawPopupBarCheckMark(CDC *pDC, CRect rcCheck, BOOL bEnabled, COLORREF clr) | CXTPPaintManager | virtual
DrawPopupBarGripper(CDC *pDC, int xPos, int yPos, int cx, int cy, BOOL bExpanded=FALSE) | CXTPCommandBarsOffice2003Theme | protectedvirtual
DrawPopupBarRadioMark(CDC *pDC, CRect rcCheck, BOOL bEnabled, COLORREF clr) | CXTPPaintManager | virtual
DrawPopupResizeGripper(CDC *pDC, CRect rcGripper, int nFlags) | CXTPCommandBarsOfficeXPTheme | virtual
DrawRectangle(CDC *pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition) | CXTPCommandBarsOffice2003Theme | protectedvirtual
DrawRectangle(CDC *pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition, int nID) | CXTPCommandBarsOffice2003Theme | protectedvirtual
DrawRectangle(CDC *pDC, CXTPControl *pButton) | CXTPCommandBarsOffice2003Theme | protectedvirtual
DrawSpecialControl(CDC *pDC, XTPSpecialControl controlType, CXTPControl *pButton, CXTPCommandBar *pBar, BOOL bDraw, LPVOID lpParam) | CXTPCommandBarsOffice2003Theme | protectedvirtual
DrawSplitButtonFrame(CDC *pDC, CXTPControl *pButton, CRect rc) | CXTPCommandBarsOfficeXPTheme | protectedvirtual
DrawTearOffGripper(CDC *pDC, CRect rcGripper, BOOL bSelected, BOOL bDraw) | CXTPCommandBarsOffice2003Theme | protectedvirtual
ExcludeCorners(CDC *pDC, CRect rc) | CXTPCommandBarsOffice2003Theme |
FillCommandBarEntry(CDC *pDC, CXTPCommandBar *pBar) | CXTPCommandBarsOffice2003Theme | protectedvirtual
FillDockBar(CDC *pDC, CXTPDockBar *pBar) | CXTPCommandBarsOffice2003Theme | protectedvirtual
FillIntersectRect(CDC *pDC, CXTPPopupBar *pPopupBar, COLORREF clr) | CXTPCommandBarsOfficeXPTheme | protected
FillWorkspace(CDC *pDC, CRect rc, CRect rcExclude) | CXTPPaintManager | virtual
FontExists(LPCTSTR lpszFaceName) | CXTPPaintManager | static
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCommandBarBorders(CXTPCommandBar *pBar) | CXTPCommandBarsOffice2003Theme | protectedvirtual
GetCommandBarFont(CXTPCommandBar *pCommandBar) | CXTPPaintManager | virtual
GetControlBackColor(CXTPControl *pButton) | CXTPPaintManager | virtual
GetControlEditBackColor(CXTPControl *pControl) | CXTPPaintManager | virtual
GetControlFont(CXTPControl *pControl) | CXTPPaintManager | virtual
GetControlHeight() const | CXTPPaintManager |
GetControlTextColor(CXTPControl *pButton) | CXTPPaintManager | virtual
GetControlTextOrientation(CXTPControl *pControl) | CXTPPaintManager | virtual
GetCurrentSystemTheme() | CXTPPaintManager |
GetCurrentTheme() | CXTPPaintManager | inline
GetDefaultCommandBarSize(CXTPCommandBar *pBar) | CXTPPaintManager | virtual
GetFramePaintManager() | CXTPPaintManager | virtual
GetGalleryPaintManager() const | CXTPPaintManager | virtual
GetGlobalPaintManager() | CXTPPaintManager | static
GetIconFont() | CXTPPaintManager |
GetIconsInfo() | CXTPPaintManager |
GetInstanceAddRef() | CXTPPaintManager | static
GetMessageBarPaintManager() | CXTPPaintManager | virtual
GetModernBitmap(UINT nIDResource) | CXTPCommandBarsOffice2003Theme | static
GetPopupBarGripperWidth(CXTPCommandBar *pBar) | CXTPPaintManager | virtual
GetProgressPaintManager() const | CXTPPaintManager | virtual
GetRectangleTextColor(BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition) | CXTPCommandBarsOfficeXPTheme | virtual
GetRegularBoldFont() | CXTPPaintManager |
GetRegularFont() | CXTPPaintManager |
GetRibbonPaintManager() | CXTPPaintManager | virtual
GetScrollBarPaintManager() const | CXTPPaintManager | virtual
GetShadowManager() const | CXTPPaintManager |
GetShadowOptions() const | CXTPPaintManager |
GetSliderPaintManager() const | CXTPPaintManager | virtual
GetSmCaptionFont() | CXTPPaintManager |
GetSplitButtonCommandRect(CXTPControl *pButton) | CXTPPaintManager | virtual
GetStatusBarPaintManager() | CXTPPaintManager | virtual
GetXtremeColor(UINT nIndex) | CXTPPaintManager |
GradientFill(CDC *pDC, LPRECT lpRect, COLORREF crFrom, COLORREF crTo, BOOL bHorz, LPCRECT lpRectClip=NULL) | CXTPPaintManager |
HasFloatingBarGradientEntry(CXTPCommandBar *pBar) | CXTPCommandBarsOffice2003Theme | protectedvirtual
HorizontalLine(CDC *pDC, int x0, int y0, int x1, COLORREF clrPen) | CXTPPaintManager |
IsUseSystemAccentColorEnabled() const | CXTPPaintManager |
Line(CDC *pDC, CPoint p0, CPoint p1) | CXTPPaintManager |
Line(CDC *pDC, int x0, int y0, int x1, int y1, const int nPen) | CXTPPaintManager |
Line(CDC *pDC, int x0, int y0, int x1, int y1, COLORREF clrPen) | CXTPPaintManager |
LoadModernToolbarIcons(UINT nIDResource) | CXTPCommandBarsOffice2003Theme | static
LoadModernToolbarIcons(UINT nIDResource, UINT *pCommands, int nCount, CSize szIcon=CSize(16, 15)) | CXTPCommandBarsOffice2003Theme | static
m_arrColor | CXTPPaintManager | protected
m_bAutoResizeIcons | CXTPPaintManager |
m_bClearTypeTextQuality | CXTPPaintManager |
m_bEmbossedDisabledText | CXTPPaintManager | protected
m_bEnableAnimation | CXTPPaintManager |
m_bFlatMenuBar | CXTPPaintManager |
m_bFlatToolBar | CXTPPaintManager |
m_bLunaTheme | CXTPCommandBarsOffice2003Theme |
m_bOffice2007Padding | CXTPPaintManager |
m_bOffsetPopupLabelText | CXTPPaintManager |
m_bPlainSeparators | CXTPCommandBarsOffice2003Theme |
m_bSelectImageInPopupBar | CXTPPaintManager |
m_bShowKeyboardCues | CXTPPaintManager | protected
m_bShowShadow | CXTPPaintManager |
m_bThemedCheckBox | CXTPPaintManager |
m_bThemedStatusBar | CXTPPaintManager |
m_bThickCheckMark | CXTPPaintManager |
m_bUseOfficeFont | CXTPPaintManager |
m_bUseStandardFont | CXTPPaintManager | protected
m_bWrapCaptionBelowText | CXTPPaintManager |
m_clrCommandBar | CXTPCommandBarsOffice2003Theme |
m_clrDisabledIcon | CXTPPaintManager |
m_clrDockBar | CXTPCommandBarsOffice2003Theme |
m_clrFloatingGripper | CXTPPaintManager |
m_clrFloatingGripperText | CXTPPaintManager |
m_clrMenuExpand | CXTPCommandBarsOffice2003Theme |
m_clrMenuExpandedGripper | CXTPCommandBarsOffice2003Theme |
m_clrMenuGripper | CXTPCommandBarsOffice2003Theme |
m_clrMessageBarText | CXTPPaintManager |
m_clrPopupControl | CXTPCommandBarsOffice2003Theme |
m_clrTearOffGripper | CXTPCommandBarsOffice2003Theme |
m_clrToolbarExpand | CXTPCommandBarsOffice2003Theme |
m_clrToolbarShadow | CXTPCommandBarsOffice2003Theme |
m_fontIcon | CXTPPaintManager |
m_fontIconBold | CXTPPaintManager |
m_fontSmCaption | CXTPPaintManager |
m_fontToolTip | CXTPPaintManager |
m_grcLunaChecked | CXTPCommandBarsOffice2003Theme |
m_grcLunaPushed | CXTPCommandBarsOffice2003Theme |
m_grcLunaSelected | CXTPCommandBarsOffice2003Theme |
m_iconsInfo | CXTPPaintManager | protected
m_ilGradientCircle | CXTPCommandBarsOffice2003Theme |
m_nAnimationSteps | CXTPPaintManager | protected
m_nAnimationTime | CXTPPaintManager | protected
m_nEditHeight | CXTPPaintManager | protected
m_nFontHeight | CXTPPaintManager | protected
m_nPopupBarTextPadding | CXTPPaintManager |
m_nSplitButtonDropDownHeight | CXTPPaintManager |
m_nSplitButtonDropDownWidth | CXTPPaintManager |
m_nSplitButtonPopupWidth | CXTPPaintManager |
m_nStatusBarMinHeight | CXTPPaintManager |
m_nTextHeight | CXTPPaintManager |
m_pfnSetLayeredWindowAttributes | CXTPPaintManager |
m_pFramePaintManager | CXTPPaintManager |
m_pGalleryPaintManager | CXTPPaintManager |
m_pProgressPaintManager | CXTPPaintManager |
m_pRibbonPaintManager | CXTPPaintManager |
m_pScrollBarPaintManager | CXTPPaintManager |
m_pShadowManager | CXTPPaintManager | protected
m_pSliderPaintManager | CXTPPaintManager |
m_pStatusBarPaintManager | CXTPPaintManager |
m_rcMessageBarMargin | CXTPPaintManager |
m_rcStatusBarBorder | CXTPPaintManager |
m_strOfficeFont | CXTPPaintManager |
m_systemTheme | CXTPPaintManager | protected
m_themeButton | CXTPPaintManager | protected
m_themeCurrent | CXTPPaintManager | protected
m_themeStatusBar | CXTPPaintManager | protected
m_xtpFontRegular | CXTPPaintManager | protected
m_xtpFontRegularBold | CXTPPaintManager | protected
m_xtpFontVert | CXTPPaintManager | protected
m_xtpFontVertBold | CXTPPaintManager | protected
Notify(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *)) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
Notify(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1), A1 arg1) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
Notify(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
Notify(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamic(void(T::*method)(O *)) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1), A1 arg1) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *)) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1), A1 arg1) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyReversed(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *)) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyReversed(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1), A1 arg1) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyReversed(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyReversed(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
Pixel(CDC *pDC, int xPos, int yPos, int nPen) | CXTPPaintManager |
Rectangle(CDC *pDC, LPCRECT rc, int nPen, const int nBrush) | CXTPPaintManager |
Rectangle(CDC *pDC, LPCRECT rc, COLORREF clrPen, COLORREF clrBrush) | CXTPPaintManager |
RefreshMetrics() | CXTPVisualStudio2005Theme | virtual
ReleaseInstance() | CXTPPaintManager | static
RequiresResourceImages() | CXTPPaintManager | virtual
RoundRect(CDC *pDC, LPCRECT rc, COLORREF clrPen, COLORREF clrBrush) | CXTPPaintManager |
SetAnimationDelay(int nAnimationSteps, int nAnimationTime) | CXTPPaintManager |
SetColors(int cElements, CONST INT *lpaElements, CONST COLORREF *lpaRgbValues) | CXTPPaintManager |
SetCommandBarRegion(CXTPCommandBar *pCommandBar) | CXTPPaintManager | virtual
SetCommandBarsFontIndirect(LOGFONT *pLogFont, BOOL bUseStandardFont=FALSE) | CXTPPaintManager |
SetCustomTheme(CXTPPaintManager *pTheme) | CXTPPaintManager | static
SetGlobalPaintManager(CXTPPaintManager *pPaintManager) | CXTPPaintManager | static
SetImageHandle(HMODULE hResource, LPCTSTR lpszIniFileName) | CXTPPaintManager | virtual
SetLunaTheme(XTPCurrentSystemTheme systemTheme) | CXTPPaintManager |
SetTheme(XTPPaintTheme paintTheme) | CXTPPaintManager | static
StripMnemonics(CString &strClear) | CXTPPaintManager | static
Subscribe(IXTPPaintManagerEvents *pObserver, CXTPSubscriptionList< CXTPPaintManager, IXTPPaintManagerEvents > *pSubcriptionList=NULL) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > |
Triangle(CDC *pDC, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clr) | CXTPPaintManager | static
Unsubscribe(IXTPPaintManagerEvents *pObserver) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > |
UpdateColors() | CXTPPaintManager | virtual
UpdateFonts() | CXTPPaintManager | virtual
UpdateRTLCaption(CString &strCaption) | CXTPPaintManager | virtual
UseOfficeFont(bool bUseOfficeFont) | CXTPPaintManager |
VerticalLine(CDC *pDC, int x0, int y0, int y1, COLORREF clrPen) | CXTPPaintManager |
~CXTPCommandBarsOffice2003Theme() | CXTPCommandBarsOffice2003Theme | virtual
~CXTPObservable() | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | protected
~CXTPPaintManager() | CXTPPaintManager | protectedvirtual
~CXTPVisualStudio2005Theme() | CXTPVisualStudio2005Theme | virtual


Toolkit Pro: XTPListBoxThemeOffice2013.h Source File

  • Source
  • Controls
  • ListBox
  • Themes
XTPListBoxThemeOffice2013.h
Go to the documentation of this file.
1
23#if !defined(__XTPLISTBOXTHEMEOFFICE2013_H__)
24# define __XTPLISTBOXTHEMEOFFICE2013_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPListBoxThemeOffice2013 : public CXTPListBoxTheme
39{
40public:
45 CXTPListBoxThemeOffice2013();
46
56 virtual void DrawItem(CDC* pDC, CXTPListBox* pListBox, LPDRAWITEMSTRUCT lpDIS);
57
63 virtual void RefreshMetrics();
64
71 virtual COLORREF GetBackColor();
72
81 virtual BOOL DrawNcBorders(CDC* pDC, CRect rc);
82
83public:
84 COLORREF m_clrBack;
85 COLORREF m_clrBorder;
86 COLORREF m_clrItemText;
87 COLORREF m_clrItemTextHighlight;
88 COLORREF m_clrItemTextSelected;
89 COLORREF m_clrItemBack;
90 COLORREF m_clrItemBackHighlight;
91 COLORREF m_clrItemBackSelected;
92 COLORREF m_clrItemBorder;
93 COLORREF m_clrItemBorderHighlight;
94 COLORREF m_clrItemBorderSelected;
95};
96
97# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
99#endif // !defined(__XTPLISTBOXTHEMEOFFICE2013_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPListBox
CXTPListBox is a CListBox derived class.
Definition XTPListBox.h:127
CXTPListBoxTheme
CXTPListBoxTheme is the base class used by CXTPListBox themes to draw the list box control.
Definition XTPListBox.h:61
CXTPListBoxThemeOffice2013
CXTPListBoxThemeOffice2013 is used by CXTPListBox to draw an Office 2013 style list box.
Definition XTPListBoxThemeOffice2013.h:39
CXTPListBoxThemeOffice2013::m_clrBorder
COLORREF m_clrBorder
List-box border color.
Definition XTPListBoxThemeOffice2013.h:85
CXTPListBoxThemeOffice2013::m_clrItemBorder
COLORREF m_clrItemBorder
List-box item normal border color.
Definition XTPListBoxThemeOffice2013.h:92
CXTPListBoxThemeOffice2013::DrawNcBorders
virtual BOOL DrawNcBorders(CDC *pDC, CRect rc)
Call this member function to draw the list control borders.
CXTPListBoxThemeOffice2013::m_clrItemBackSelected
COLORREF m_clrItemBackSelected
List-box item selected background color.
Definition XTPListBoxThemeOffice2013.h:91
CXTPListBoxThemeOffice2013::GetBackColor
virtual COLORREF GetBackColor()
Called to retrieve the background color for the listbox.
CXTPListBoxThemeOffice2013::m_clrItemTextSelected
COLORREF m_clrItemTextSelected
List-box item selected text color.
Definition XTPListBoxThemeOffice2013.h:88
CXTPListBoxThemeOffice2013::m_clrItemText
COLORREF m_clrItemText
List-box item normal text color.
Definition XTPListBoxThemeOffice2013.h:86
CXTPListBoxThemeOffice2013::CXTPListBoxThemeOffice2013
CXTPListBoxThemeOffice2013()
Default constructor.
CXTPListBoxThemeOffice2013::m_clrBack
COLORREF m_clrBack
List-box background color.
Definition XTPListBoxThemeOffice2013.h:84
CXTPListBoxThemeOffice2013::m_clrItemBack
COLORREF m_clrItemBack
List-box item normal background color.
Definition XTPListBoxThemeOffice2013.h:89
CXTPListBoxThemeOffice2013::DrawItem
virtual void DrawItem(CDC *pDC, CXTPListBox *pListBox, LPDRAWITEMSTRUCT lpDIS)
This method is called to draw the CXTPListBox object.
CXTPListBoxThemeOffice2013::m_clrItemBorderHighlight
COLORREF m_clrItemBorderHighlight
List-box item highlighted border color.
Definition XTPListBoxThemeOffice2013.h:93
CXTPListBoxThemeOffice2013::m_clrItemBorderSelected
COLORREF m_clrItemBorderSelected
List-box item selected border color.
Definition XTPListBoxThemeOffice2013.h:94
CXTPListBoxThemeOffice2013::RefreshMetrics
virtual void RefreshMetrics()
Called to update the colors and metrics used to draw the CXTPListBox object.
CXTPListBoxThemeOffice2013::m_clrItemBackHighlight
COLORREF m_clrItemBackHighlight
List-box item highlighted background color.
Definition XTPListBoxThemeOffice2013.h:90
CXTPListBoxThemeOffice2013::m_clrItemTextHighlight
COLORREF m_clrItemTextHighlight
List-box item highlighted text color.
Definition XTPListBoxThemeOffice2013.h:87


Toolkit Pro: Member List

CXTPMarqueeCtrlThemeNativeWindows Member List

This is the complete list of members for CXTPMarqueeCtrlThemeNativeWindows, including all inherited members.

CXTPMarqueeCtrlPaintManager() | CXTPMarqueeCtrlPaintManager |
CXTPMarqueeCtrlThemeNativeWindows() | CXTPMarqueeCtrlThemeNativeWindows |
DeflateRect(CDC *pDC, CRect &rcClient) | CXTPMarqueeCtrlThemeNativeWindows | protectedvirtual
DrawBackground(CXTPMarqueeCtrl *pWndCtrl, CDC *pDC, CRect &rcClient) | CXTPMarqueeCtrlPaintManager | virtual
DrawChunk(CXTPMarqueeCtrl *pWndCtrl, CDC *pDC, CXTPCompatibleDC &dcChunk, int i, int &x, int &y, int cx, int cy) | CXTPMarqueeCtrlPaintManager | protectedvirtual
DrawMarquee(CXTPMarqueeCtrl *pWndCtrl, CDC *pDC, CRect &rcClient) | CXTPMarqueeCtrlPaintManager | virtual
GetBackColor() | CXTPMarqueeCtrlPaintManager |
GetBarColor() | CXTPMarqueeCtrlPaintManager |
GetBorderColor() | CXTPMarqueeCtrlPaintManager |
m_bUseWinTheme | CXTPMarqueeCtrlPaintManager | protected
m_clr3DHilite | CXTPMarqueeCtrlPaintManager | protected
m_clr3DShadow | CXTPMarqueeCtrlPaintManager | protected
m_clrBack | CXTPMarqueeCtrlPaintManager | protected
m_clrBar | CXTPMarqueeCtrlPaintManager | protected
m_nTheme | CXTPMarqueeCtrlPaintManager | protected
m_winTheme | CXTPMarqueeCtrlPaintManager | protected
RefreshMetrics() | CXTPMarqueeCtrlPaintManager | virtual
SetBackColor(COLORREF clrNew) | CXTPMarqueeCtrlPaintManager |
SetBarColor(COLORREF clrNew) | CXTPMarqueeCtrlPaintManager |
SetBorderColor(COLORREF clrNew) | CXTPMarqueeCtrlPaintManager |
UseWinThemes(BOOL bUseWinThemes=TRUE) | CXTPMarqueeCtrlPaintManager |
UsingWinThemes(BOOL bCheckReady=FALSE) | CXTPMarqueeCtrlPaintManager |
~CXTPMarqueeCtrlPaintManager() | CXTPMarqueeCtrlPaintManager | virtual


Toolkit Pro: Member List

CXTPControlComboBoxGalleryPopupBar Member List

This is the complete list of members for CXTPControlComboBoxGalleryPopupBar, including all inherited members.

AdjustExcludeRect(CRect &rc, BOOL bVertical) | CXTPPopupBar | protectedvirtual
Animate() | CXTPPopupBar | protectedvirtual
CalcDynamicLayout(int nLength, DWORD dwMode) | CXTPPopupBar | virtual
CalculatePopupRect(CPoint ptPopup, CSize sz) | CXTPPopupBar | virtual
Copy(CXTPCommandBar *pCommandBar, BOOL bRecursive=FALSE) | CXTPPopupBar | protectedvirtual
Create() | CXTPPopupBar | virtual
CreateComboBoxGalleryPopupBar(CXTPCommandBars *pCommandBars) | CXTPControlComboBoxGalleryPopupBar | static
CreateKeyboardTips() | CXTPCommandBar | virtual
CreatePopupBar(CXTPCommandBars *pCommandBars) | CXTPPopupBar | static
CXTPCommandBar() | CXTPCommandBar | protected
CXTPControlComboBoxGalleryPopupBar() | CXTPControlComboBoxGalleryPopupBar | protected
CXTPControlComboBoxPopupBar() | CXTPControlComboBoxPopupBar |
CXTPHookManagerHookAble() | CXTPHookManagerHookAble |
CXTPPopupBar() | CXTPPopupBar | protected
DelayLayout() | CXTPCommandBar |
DelayRedraw() | CXTPPopupBar | inlineprotectedvirtual
DestroyWindow() | CXTPPopupBar |
DisableShadow() | CXTPPopupBar |
DoPropExchange(CXTPPropExchange *pPX) | CXTPPopupBar | protectedvirtual
DrawCommandBar(CDC *pDC, CRect rcClipBox) | CXTPPopupBar | protectedvirtual
EnableAnimation(BOOL bEnable=TRUE) | CXTPCommandBar |
EnableCustomization(BOOL bEnable=TRUE) | CXTPCommandBar |
EnableDoubleBuffer(BOOL bEnable=TRUE) | CXTPCommandBar |
EnsureVisible(CXTPControl *pControl) | CXTPCommandBar | virtual
ExpandBar() | CXTPPopupBar |
FillCommandBarEntry(CDC *pDC) | CXTPCommandBar | virtual
FindAccel(TCHAR chAccel) const | CXTPCommandBar |
FindAccelEx(UINT chAccel, BOOL &bSelectOnly) const | CXTPCommandBar |
GenerateCommandBarList(DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam) | CXTPCommandBar | protectedvirtual
GetActiveDocTemplate() const | CXTPCommandBar | protected
GetBarID() const | CXTPCommandBar |
GetBorders() | CXTPPopupBar | virtual
GetButtonSize() const | CXTPCommandBar | virtual
GetCommandBarData() const | CXTPCommandBar |
GetCommandBars() const | CXTPCommandBar |
GetControl(int nIndex) const | CXTPCommandBar |
GetControlCount() const | CXTPCommandBar |
GetControlPopup() const | CXTPPopupBar |
GetControls() const | CXTPCommandBar |
GetDefaultButtonStyle() const | CXTPCommandBar |
GetDefaultItem(UINT gmdiFlags, BOOL fByPos=FALSE) | CXTPPopupBar |
GetFlags() const | CXTPCommandBar |
GetFrameSite() const | CXTPCommandBar |
GetIconSize() const | CXTPCommandBar | virtual
GetImageManager() const | CXTPCommandBar |
GetLargeIconSize(BOOL bAutoSize) const | CXTPCommandBar |
GetOwnerSite() const | CXTPCommandBar |
GetPaintManager() const | CXTPCommandBar |
GetParentCommandBar() const | CXTPPopupBar | protectedvirtual
GetPosition() const | CXTPCommandBar |
GetRootParent() const | CXTPCommandBar |
GetSelected() const | CXTPCommandBar |
GetShowGripper() const | CXTPCommandBar |
GetSite() const | CXTPCommandBar |
GetTextOrientation() const | CXTPCommandBar |
GetTitle() const | CXTPCommandBar |
GetTrackFocus() const | CXTPCommandBar |
GetType() const | CXTPCommandBar |
GetWidth() const | CXTPCommandBar |
HideKeyboardTips() | CXTPCommandBar |
InvalidateParents() | CXTPCommandBar |
IsAnimationEnabled() const | CXTPCommandBar |
IsContextMenu() const | CXTPPopupBar |
IsCustomizable() const | CXTPCommandBar | virtual
IsCustomizeDialogPresent() const | CXTPCommandBar |
IsCustomizeMode() const | CXTPCommandBar |
IsDialogBar() const | CXTPCommandBar | virtual
IsDoubleGripper() const | CXTPPopupBar |
IsHelpMode() const | CXTPCommandBar | protected
IsKeyboardCuesVisible() const | CXTPCommandBar | virtual
IsKeyboardTipsVisible() const | CXTPCommandBar |
IsLayoutRTL() const | CXTPCommandBar |
IsMenuTitleBar() const | CXTPCommandBar | virtual
IsPopupBar() const | CXTPPopupBar | virtual
IsResizable() const | CXTPPopupBar | virtual
IsRibbonBar() const | CXTPCommandBar | virtual
IsTearOffPopup(CString &strCaption, UINT &nID, int &nWidth) | CXTPPopupBar |
IsTextBelowIcons() const | CXTPCommandBar |
IsTrackingMode() const | CXTPCommandBar |
IsVisible() const | CXTPPopupBar | virtual
LoadMenu(CMenu *pMenu, BOOL bRemoveControls=TRUE) | CXTPCommandBar | virtual
LoadToolBar(UINT nIDResource, BOOL bLoadIcons=TRUE) | CXTPCommandBar | virtual
LockMouseMove(CXTPControl *pControl) | CXTPCommandBar |
LockRedraw() | CXTPCommandBar |
m_bAnimatePopup | CXTPCommandBar | protected
m_barPosition | CXTPCommandBar | protected
m_barType | CXTPCommandBar | protected
m_bAutoDestroy | CXTPHookManagerHookAble |
m_bCloseable | CXTPCommandBar | protected
m_bCollapsed | CXTPPopupBar | protected
m_bComboBar | CXTPCommandBar |
m_bContextMenu | CXTPPopupBar | protected
m_bCustomizable | CXTPCommandBar | protected
m_bCustomizeDialogPresent | CXTPCommandBar | protected
m_bDoubleGripper | CXTPPopupBar | protected
m_bDynamicLayout | CXTPPopupBar | protected
m_bExecOnRButton | CXTPCommandBar | protected
m_bExpanded | CXTPPopupBar | protected
m_bExpanding | CXTPPopupBar | protected
m_bGrabFocus | CXTPCommandBar | protected
m_bIgnoreUpdateHandler | CXTPCommandBar | protected
m_bKeyboardSelect | CXTPCommandBar | protected
m_bMultiLine | CXTPCommandBar | protected
m_bRecursePopup | CXTPCommandBar | protected
m_bResizable | CXTPPopupBar | protected
m_bShowShadow | CXTPPopupBar | protected
m_bTearOffPopup | CXTPPopupBar | protected
m_bTearOffSelected | CXTPPopupBar | protected
m_bTearOffTracking | CXTPPopupBar | protected
m_bTextBelow | CXTPCommandBar | protected
m_bTracking | CXTPCommandBar | protected
m_bTrackOnHover | CXTPCommandBar |
m_buttonStyle | CXTPCommandBar | protected
m_bVerticalMarker | CXTPCommandBar | protected
m_dMaxWidthDivisor | CXTPPopupBar | static
m_dwData | CXTPCommandBar | protected
m_dwFlags | CXTPCommandBar | protected
m_dwStyle | CXTPCommandBar | protected
m_hwndFocus | CXTPCommandBar | protected
m_nBarID | CXTPCommandBar | protected
m_nIdleFlags | CXTPCommandBar | protected
m_nLockRedraw | CXTPCommandBar | protected
m_nMaxHeight | CXTPPopupBar | protected
m_nMRUWidth | CXTPCommandBar | protected
m_nPopuped | CXTPCommandBar | protected
m_nSelected | CXTPCommandBar | protected
m_nStateFlags | CXTPCommandBar |
m_nTearOffID | CXTPPopupBar | protected
m_nTearOffTimer | CXTPPopupBar | protected
m_nTearOffWidth | CXTPPopupBar | protected
m_nTextOrientation | CXTPCommandBar | protected
m_pAnimation | CXTPCommandBar | protected
m_pCommandBars | CXTPCommandBar | protected
m_pControlPopup | CXTPPopupBar | protected
m_pControls | CXTPCommandBar | protected
m_pImageManager | CXTPCommandBar | protected
m_popupFlags | CXTPPopupBar | protected
m_pOwner | CXTPCommandBar | protected
m_pPaintManager | CXTPCommandBar | protected
m_pReturnCmd | CXTPCommandBar | protected
m_pSite | CXTPCommandBar | protected
m_pTearOffBar | CXTPPopupBar | protected
m_pToolTipContext | CXTPCommandBar | protected
m_ptPopup | CXTPPopupBar | protected
m_rcBorders | CXTPPopupBar | protected
m_rcExclude | CXTPPopupBar | protected
m_rcMarker | CXTPCommandBar | protected
m_rcResizeGripper | CXTPPopupBar | protected
m_rcTearOffGripper | CXTPPopupBar | protected
m_strTearOffCaption | CXTPPopupBar | protected
m_strTitle | CXTPCommandBar | protected
m_szButtons | CXTPCommandBar | protected
m_szButtonSpacing | CXTPCommandBar | protected
m_szIcons | CXTPCommandBar | protected
m_szTearOffBar | CXTPPopupBar | protected
OnControlsChanged() | CXTPPopupBar | protectedvirtual
OnControlSelected(BOOL bSelected, CXTPControl *pControl) | CXTPCommandBar | virtual
OnCustomizeDragEnter(CXTPControl *pDataObject, CPoint point) | CXTPCommandBar | virtual
OnCustomizeDragLeave() | CXTPCommandBar | virtual
OnCustomizeDragOver(CXTPControl *pDataObject, CPoint point) | CXTPCommandBar | virtual
OnCustomizeDrop(CXTPControl *pDataObject, DROPEFFECT &dropEffect, CPoint ptDrop, CPoint ptDrag) | CXTPCommandBar | virtual
OnHookAttached(HWND hWnd) | CXTPHookManagerHookAble | virtual
OnHookDetached() | CXTPHookManagerHookAble | virtual
OnHookKeyDown(UINT nChar, LPARAM lParam) | CXTPPopupBar | protectedvirtual
OnHookMessage(HWND hWnd, UINT nMessage, WPARAM &wParam, LPARAM &lParam, LRESULT &lResult) | CXTPCommandBar | virtual
OnKeyboardTip(CXTPCommandBarKeyboardTip *pTip) | CXTPCommandBar | virtual
OnKeyboardTipChar(UINT chAccel) | CXTPCommandBar |
OnMouseHitTest(CPoint pt) | CXTPCommandBar | protectedvirtual
OnPostHookMessage(HWND hWnd, UINT nMessage, WPARAM &wParam, LPARAM &lParam, LRESULT &lResult) | CXTPHookManagerHookAble | virtual
OnRecalcLayout() | CXTPPopupBar | protectedvirtual
OnRemoved() | CXTPCommandBar | protectedvirtual
OnTrackEnter() | CXTPCommandBar | virtual
OnTrackLost() | CXTPCommandBar | virtual
Popup(int xPos, int yPos, LPCRECT rcExclude) | CXTPPopupBar |
Popup(CXTPControlPopup *pControlPopup, BOOL bSelectFirst=FALSE) | CXTPPopupBar | virtual
ProcessSpecialKey(XTPSpecialKey key) | CXTPCommandBar | protectedvirtual
PumpMessage() | CXTPPopupBar |
Redraw(LPCRECT lpRect=0, BOOL bAnimate=TRUE) | CXTPCommandBar | virtual
RestoreCommandBarList(CXTPCommandBarList *pCommandBarList) | CXTPCommandBar | protectedvirtual
s_nExpandDelay | CXTPCommandBar | static
s_nExpandHoverDelay | CXTPCommandBar | static
s_nHoverDelay | CXTPCommandBar | static
SetBarID(UINT nID) | CXTPCommandBar |
SetBorders(CRect rcBorders) | CXTPPopupBar |
SetButtons(UINT *pButtons, int nCount) | CXTPCommandBar |
SetButtonSize(CSize size) | CXTPCommandBar |
SetCommandBarData(DWORD_PTR dwData) | CXTPCommandBar |
SetCommandBars(CXTPCommandBars *pCommandBars) | CXTPCommandBar |
SetControls(CXTPControls *pControls) | CXTPCommandBar |
SetDefaultButtonStyle(XTPButtonStyle buttonStyle) | CXTPCommandBar |
SetDefaultItem(UINT uItem, BOOL fByPos=FALSE) | CXTPPopupBar |
SetDoubleGripper(BOOL bDoubleGripper=TRUE) | CXTPPopupBar |
SetFlags(DWORD dwFlagsAdd, DWORD dwFlagsRemove=0) | CXTPCommandBar |
SetGrabFocus(BOOL bGrabFocus) | CXTPCommandBar |
SetIconSize(CSize size) | CXTPCommandBar |
SetImageManager(CXTPImageManager *pImageManager) | CXTPCommandBar |
SetPaintManager(CXTPPaintManager *pPaintManager) | CXTPCommandBar |
SetPopuped(int nPopuped, BOOL bKeyboard=FALSE) | CXTPCommandBar |
SetPopupFlags(DWORD dwPopupFlags) | CXTPPopupBar |
SetPopupToolBar(BOOL bToolBarType) | CXTPPopupBar |
SetPosition(XTPBarPosition barPosition) | CXTPCommandBar | virtual
SetSelected(int nSelected, BOOL bKeyboard=FALSE) | CXTPPopupBar | protectedvirtual
SetShowGripper(BOOL bShow) | CXTPCommandBar |
SetStatusText(const CString &strDescription) | CXTPCommandBar |
SetTearOffPopup(LPCTSTR lpszCaption, UINT nID, int nWidth=400) | CXTPPopupBar |
SetTextOrientation(XTPBarTextOrientation nTextOrientation) | CXTPCommandBar |
SetTitle(LPCTSTR lpszTitle) | CXTPCommandBar |
SetTrackFocus(HWND hwnd) | CXTPCommandBar |
SetTrackingMode(int bMode, BOOL bSelectFirst=TRUE, BOOL bKeyboard=FALSE) | CXTPPopupBar | virtual
SetVisible(BOOL bVisible) | CXTPCommandBar | virtual
SetWidth(int nWidth) | CXTPCommandBar |
ShowTextBelowIcons(BOOL bTextBelow=TRUE) | CXTPCommandBar |
UnlockMouseMove() | CXTPCommandBar |
UnlockRedraw() | CXTPCommandBar |
UpdateExpandingState() | CXTPPopupBar | protected
UpdateFlags() | CXTPPopupBar | protectedvirtual
UpdateLocation(CSize sz) | CXTPPopupBar | protected
UpdateShortcuts() | CXTPCommandBar | protectedvirtual
~CXTPCommandBar() | CXTPCommandBar | protectedvirtual
~CXTPHookManagerHookAble() | CXTPHookManagerHookAble | virtual
~CXTPPopupBar() | CXTPPopupBar | protectedvirtual


Toolkit Pro: Member List

CXTPChartTitleCollection Member List

This is the complete list of members for CXTPChartTitleCollection, including all inherited members.

Add(CXTPChartTitle *pTitle) | CXTPChartTitleCollection |
CXTPChartElement() | CXTPChartElement |
CXTPChartElementCollection() | CXTPChartElementCollection |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartTitleCollection(CXTPChartElement *pOwner) | CXTPChartTitleCollection |
DoPropExchange(CXTPPropExchange *pPX) | CXTPChartTitleCollection | virtual
GetAppearance() const | CXTPChartElement |
GetAt(int nIndex) const | CXTPChartTitleCollection |
GetContent() const | CXTPChartElement |
GetCount() const | CXTPChartElementCollection | virtual
GetOwner() const | CXTPChartElement |
IndexOf(CXTPChartElement *pElement) const | CXTPChartElementCollection |
InsertAt(int nIndex, CXTPChartElement *pElement) | CXTPChartElementCollection |
Is3D() const | CXTPChartObject |
m_arrElements | CXTPChartElementCollection | protected
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartElement | virtual
Release() | CXTPChartElementCollection | virtual
Remove(CXTPChartElement *pElement) | CXTPChartElementCollection | virtual
RemoveAll() | CXTPChartElementCollection | virtual
RemoveAt(int nIndex) | CXTPChartElementCollection | virtual
~CXTPChartElement() | CXTPChartElement | virtual
~CXTPChartElementCollection() | CXTPChartElementCollection |
~CXTPChartTitleCollection() | CXTPChartTitleCollection | virtual


Toolkit Pro: Member List

CXTPPropertyGridVisualStudio2010Theme Member List

This is the complete list of members for CXTPPropertyGridVisualStudio2010Theme, including all inherited members.

AdjustItemCaptionRect(CXTPPropertyGridItem *pItem, CRect &rcCaption) | CXTPPropertyGridPaintManager | virtual
AdjustItemValueRect(CXTPPropertyGridItem *pItem, CRect &rcValue) | CXTPPropertyGridPaintManager | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPPropertyGridPaintManager(CXTPPropertyGrid *pGrid) | CXTPPropertyGridPaintManager |
CXTPPropertyGridVisualStudio2010Theme(CXTPPropertyGrid *pGrid) | CXTPPropertyGridVisualStudio2010Theme |
DrawCategoryCaptionBackground(CDC *pDC, CXTPPropertyGridItem *pItem, CRect rc) | CXTPPropertyGridPaintManager | virtual
DrawCheckBox(CDC *pDC, CXTPPropertyGridItemBool *pButton) | CXTPPropertyGridPaintManager | virtual
DrawCheckMark(CDC *pDC, CRect rc, BOOL bEnabled, BOOL bChecked) | CXTPPropertyGridPaintManager | virtual
DrawExpandButton(CDC &dc, CXTPPropertyGridItem *pItem, CRect rcCaption) | CXTPPropertyGridVisualStudio2010Theme | virtual
DrawInplaceButtons(CDC *pDC, PDRAWITEMSTRUCT lpDrawItemStruct, CXTPPropertyGridItem *pItem, CRect rcValue) | CXTPPropertyGridPaintManager | virtual
DrawInplaceListItem(CDC *pDC, CXTPPropertyGridItemConstraint *pConstraint, CRect rc, BOOL bSelected) | CXTPPropertyGridPaintManager | virtual
DrawItem(PDRAWITEMSTRUCT lpDrawItemStruct) | CXTPPropertyGridPaintManager | virtual
DrawItemCaption(CDC *pDC, CXTPPropertyGridItem *pItem, CRect rcCaption) | CXTPPropertyGridPaintManager | virtual
DrawItemValue(CDC *pDC, CXTPPropertyGridItem *pItem, CRect rcValue) | CXTPPropertyGridPaintManager | virtual
DrawPropertyGridBorder(CDC *pDC, RECT &rcBorder, XTPPropertyGridWindow nWindow) | CXTPPropertyGridPaintManager | virtual
DrawRadioMark(CDC *pDC, CRect rc, BOOL bEnabled, BOOL bChecked) | CXTPPropertyGridPaintManager | virtual
FillInplaceButton(CDC *pDC, CXTPPropertyGridInplaceButton *pButton) | CXTPPropertyGridPaintManager | virtual
FillPropertyGrid(CDC *pDC) | CXTPPropertyGridPaintManager | virtual
FillPropertyGridView(CDC *pDC) | CXTPPropertyGridPaintManager | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetItemBackColor(CXTPPropertyGridItem *pItem, BOOL bValuePart) | CXTPPropertyGridPaintManager | virtual
GetItemFont(CXTPPropertyGridItem *pItem, BOOL bValuePart) | CXTPPropertyGridPaintManager | virtual
GetItemMetrics() const | CXTPPropertyGridPaintManager |
GetItemsBorderHeight() const | CXTPPropertyGridPaintManager | virtual
GetItemTextColor(CXTPPropertyGridItem *pItem, BOOL bValuePart) | CXTPPropertyGridPaintManager | virtual
GetScrollBarTheme() const | CXTPPropertyGridVisualStudio2010Theme | virtual
GetSplitterRect(CRect rc, BOOL bIsHelp) | CXTPPropertyGridPaintManager |
HitTestVerbs(CDC *pDC, CRect rcVerbs, CPoint pt) | CXTPPropertyGridPaintManager |
m_bThinSplitter | CXTPPropertyGridPaintManager | protected
m_bTransparent | CXTPPropertyGridPaintManager |
m_buttonsStyle | CXTPPropertyGridPaintManager |
m_clrCategorySeparator | CXTPPropertyGridPaintManager |
m_clrFace | CXTPPropertyGridPaintManager |
m_clrHighlight | CXTPPropertyGridPaintManager |
m_clrHighlightText | CXTPPropertyGridPaintManager |
m_clrNonHighlightBack | CXTPPropertyGridPaintManager |
m_clrNonHighlightText | CXTPPropertyGridPaintManager |
m_clrShadow | CXTPPropertyGridPaintManager |
m_clrSplitter | CXTPPropertyGridPaintManager |
m_nHelpHeight | CXTPPropertyGridPaintManager | protected
m_nItemsBorderHeight | CXTPPropertyGridPaintManager | protected
m_nSplitterHeight | CXTPPropertyGridPaintManager | protected
m_nVerbsHeight | CXTPPropertyGridPaintManager | protected
m_pGrid | CXTPPropertyGridPaintManager | protected
m_pMetrics | CXTPPropertyGridPaintManager | protected
m_themeButton | CXTPPropertyGridPaintManager |
m_themeCombo | CXTPPropertyGridPaintManager |
m_themeTree | CXTPPropertyGridPaintManager |
MeasureItem(LPMEASUREITEMSTRUCT lpMeasureItemStruct) | CXTPPropertyGridPaintManager | virtual
OnNcCalcSize(RECT &rc) | CXTPPropertyGridPaintManager | virtual
RefreshMetrics() | CXTPPropertyGridVisualStudio2010Theme | virtual
SetItemsBorderHeight(int nHeight) | CXTPPropertyGridPaintManager | virtual
SetThinSplitter(BOOL bThinSplitter) | CXTPPropertyGridPaintManager | virtual
~CXTPPropertyGridPaintManager() | CXTPPropertyGridPaintManager | virtual
~CXTPPropertyGridVisualStudio2010Theme() | CXTPPropertyGridVisualStudio2010Theme |


Toolkit Pro: XTPFlowGraphConnectionPoint.h Source File

  • Source
  • FlowGraph
XTPFlowGraphConnectionPoint.h
Go to the documentation of this file.
1
23#if !defined(__XTPFLOWGRAPHCONNECTIONPOINT_H__)
24# define __XTPFLOWGRAPHCONNECTIONPOINT_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPFlowGraphNode;
34class CXTPFlowGraphImage;
35class CXTPMarkupUIElement;
36class CXTPFlowGraphConnection;
37
45class _XTP_EXT_CLASS CXTPFlowGraphConnectionPoint : public CXTPFlowGraphElement
46{
48 DECLARE_SERIAL(CXTPFlowGraphConnectionPoint)
50protected:
55 CXTPFlowGraphConnectionPoint();
56
57public:
63 virtual ~CXTPFlowGraphConnectionPoint();
64
65public:
71 void SetCaption(LPCTSTR lpszCaption);
78 CString GetCaption() const;
79
88 void SetName(LPCTSTR lpszName);
89
99 CString GetName() const;
100
109 void SetTooltip(LPCTSTR lpszTooltip);
119 CString GetTooltip() const;
120
126 void SetColor(COLORREF clr);
133 COLORREF GetColor() const;
134
141 void SetStyle(int nStyle);
148 int GetStyle() const;
149
163 XTPFlowGraphConnectionPointType GetType() const;
176 void SetType(XTPFlowGraphConnectionPointType type);
177
184 CRect GetRect() const;
185
191 void SetRect(const CRect& rect);
192
198 void SetID(int nId);
205 int GetID() const;
206
214 BOOL IsLocked() const;
224 void SetLocked(BOOL bLocked = TRUE);
225
234 int GetMaxConnections() const;
242 void SetMaxConnections(int nMaxConnections);
243
250 int GetConnectionsCount() const;
251
258 int GetInputConnectionsCount() const;
259
267 CXTPFlowGraphConnection* GetInputConnectionAt(int nIndex) const;
268
275 int GetOutputConnectionsCount() const;
276
284 CXTPFlowGraphConnection* GetOutputConnectionAt(int nIndex) const;
285
296 void SetImageIndex(int nImageIndex);
305 int GetImageIndex() const;
306
307public:
315 CXTPMarkupUIElement* GetMarkupUIElement() const;
316
317public:
324 CXTPFlowGraphNode* GetNode() const;
325
332 CXTPFlowGraphPage* GetPage() const;
333
340 CXTPFlowGraphControl* GetControl() const;
341
348 CXTPFlowGraphImage* GetImage() const;
349
358 void OnGraphChanged();
359
360public:
370 virtual void DoPropExchange(CXTPPropExchange* pPX);
371
372public:
381 virtual BOOL HitTestConnectionArea(CPoint point) const;
382
383 void Remove();
384
385protected:
390 virtual void OnRemoved();
391
392protected:
393 CXTPFlowGraphNode* m_pNode;
395 CString m_strCaption;
397 CString m_strName;
399 CString m_strTooltip;
400 COLORREF m_clrPoint;
401 XTPFlowGraphConnectionPointType m_nType;
405 int m_nStyle;
407 int m_nId;
408 BOOL m_bLocked;
411 BOOL m_bMarkupPoint;
413 BOOL m_bInputOutPair;
415 int m_nMaxConnections;
418 int m_nImageIndex;
421 int m_nConnectionPointIndex;
422
423 friend class CXTPFlowGraphConnectionPoints;
424 friend class CXTPFlowGraphPaintManager;
425 friend class CXTPFlowGraphConnection;
426 friend class CXTPFlowGraphPage;
427 friend class CXTPFlowGraphUndoDeleteConnectionPointCommand;
428 friend class CXTPFlowGraphNode;
429 friend class CXTPFlowGraphNodeCustom;
430
431 CArray<CXTPFlowGraphConnection*, CXTPFlowGraphConnection*> m_arrInputConnections;
432 CArray<CXTPFlowGraphConnection*, CXTPFlowGraphConnection*> m_arrOutputConnections;
433
436 // Paint Manager Properties:
437
438public:
439 CRect m_rcPoint;
442# ifdef _XTP_ACTIVEX
445 DECLARE_DISPATCH_MAP()
446 DECLARE_INTERFACE_MAP()
447
448 DECLARE_OLETYPELIB_EX(CXTPFlowGraphConnectionPoint)
449
450 afx_msg void OleSetCaption(LPCTSTR lpszCaption);
451 afx_msg BSTR OleGetCaption();
452
453 afx_msg void OleSetName(LPCTSTR lpszName);
454 afx_msg BSTR OleGetName();
455
456 afx_msg void OleSetTooltip(LPCTSTR lpszTooltip);
457 afx_msg BSTR OleGetTooltip();
458 afx_msg void OleSetColor(OLE_COLOR clr);
459 afx_msg OLE_COLOR OleGetColor();
460 afx_msg void OleSetStyle(int nStyle);
461 afx_msg int OleGetStyle();
462 afx_msg void OleSetType(int nType);
463 afx_msg int OleGetType();
464 afx_msg LPDISPATCH OleGetNode();
465 afx_msg LPDISPATCH OleGetInputConnection(int nIndex);
466 afx_msg LPDISPATCH OleGetOutputConnection(int nIndex);
468# endif
469};
470
471AFX_INLINE CString CXTPFlowGraphConnectionPoint::GetCaption() const
472{
473 return m_strCaption;
474}
475AFX_INLINE CString CXTPFlowGraphConnectionPoint::GetName() const
476{
477 return m_strName;
478}
479AFX_INLINE void CXTPFlowGraphConnectionPoint::SetTooltip(LPCTSTR lpszTooltip)
480{
481 m_strTooltip = lpszTooltip;
482}
483AFX_INLINE CString CXTPFlowGraphConnectionPoint::GetTooltip() const
484{
485 return m_strTooltip;
486}
487AFX_INLINE COLORREF CXTPFlowGraphConnectionPoint::GetColor() const
488{
489 return m_clrPoint;
490}
491AFX_INLINE void CXTPFlowGraphConnectionPoint::SetStyle(int nStyle)
492{
493 m_nStyle = nStyle;
494}
495AFX_INLINE int CXTPFlowGraphConnectionPoint::GetStyle() const
496{
497 return m_nStyle;
498}
499AFX_INLINE CXTPFlowGraphNode* CXTPFlowGraphConnectionPoint::GetNode() const
500{
501 return m_pNode;
502}
503AFX_INLINE XTPFlowGraphConnectionPointType CXTPFlowGraphConnectionPoint::GetType() const
504{
505 return m_nType;
506}
507AFX_INLINE void CXTPFlowGraphConnectionPoint::SetType(XTPFlowGraphConnectionPointType type)
508{
509 m_nType = type;
510}
511AFX_INLINE CRect CXTPFlowGraphConnectionPoint::GetRect() const
512{
513 return m_rcPoint;
514}
515AFX_INLINE void CXTPFlowGraphConnectionPoint::SetRect(const CRect& rect)
516{
517 m_rcPoint = rect;
518}
519AFX_INLINE void CXTPFlowGraphConnectionPoint::SetID(int nId)
520{
521 m_nId = nId;
522}
523AFX_INLINE int CXTPFlowGraphConnectionPoint::GetID() const
524{
525 return m_nId;
526}
527AFX_INLINE BOOL CXTPFlowGraphConnectionPoint::IsLocked() const
528{
529 return m_bLocked;
530}
531AFX_INLINE void CXTPFlowGraphConnectionPoint::SetLocked(BOOL bLocked)
532{
533 m_bLocked = bLocked;
534}
535AFX_INLINE int CXTPFlowGraphConnectionPoint::GetMaxConnections() const
536{
537 return m_nMaxConnections;
538}
539AFX_INLINE void CXTPFlowGraphConnectionPoint::SetMaxConnections(int nMaxConnections)
540{
541 m_nMaxConnections = nMaxConnections;
542}
543AFX_INLINE int CXTPFlowGraphConnectionPoint::GetConnectionsCount() const
544{
545 return (int)m_arrInputConnections.GetSize() + (int)m_arrOutputConnections.GetSize();
546}
547AFX_INLINE int CXTPFlowGraphConnectionPoint::GetImageIndex() const
548{
549 return m_nImageIndex;
550}
551AFX_INLINE int CXTPFlowGraphConnectionPoint::GetInputConnectionsCount() const
552{
553 return (int)m_arrInputConnections.GetSize();
554}
555AFX_INLINE CXTPFlowGraphConnection*
556 CXTPFlowGraphConnectionPoint::GetInputConnectionAt(int nIndex) const
557{
558 return m_arrInputConnections[nIndex];
559}
560AFX_INLINE int CXTPFlowGraphConnectionPoint::GetOutputConnectionsCount() const
561{
562 return (int)m_arrOutputConnections.GetSize();
563}
564AFX_INLINE CXTPFlowGraphConnection*
565 CXTPFlowGraphConnectionPoint::GetOutputConnectionAt(int nIndex) const
566{
567 return m_arrOutputConnections[nIndex];
568}
570# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
571#endif //#if !defined(__XTPFLOWGRAPHCONNECTIONPOINT_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPFlowGraphConnectionPointType
XTPFlowGraphConnectionPointType
Node connection point types (input/output).
Definition XTPFlowGraphNode.h:85
CXTPFlowGraphConnection
Represents a connection.
Definition XTPFlowGraphConnection.h:49
CXTPFlowGraphConnectionPoint
Represents a connection point for a node.
Definition XTPFlowGraphConnectionPoint.h:46
CXTPFlowGraphConnectionPoint::DoPropExchange
virtual void DoPropExchange(CXTPPropExchange *pPX)
Call this member function to store/load a connection point using the specified data object.
CXTPFlowGraphConnectionPoint::m_nType
XTPFlowGraphConnectionPointType m_nType
Type of connection point; specifies whether the FlowGraphConnection will have any connection points (...
Definition XTPFlowGraphConnectionPoint.h:401
CXTPFlowGraphConnectionPoint::m_strName
CString m_strName
Unique name of the connection point.
Definition XTPFlowGraphConnectionPoint.h:397
CXTPFlowGraphConnectionPoint::m_strTooltip
CString m_strTooltip
Tooltip text for the item.
Definition XTPFlowGraphConnectionPoint.h:399
CXTPFlowGraphConnectionPoint::OnGraphChanged
void OnGraphChanged()
This method is called when the flow graph's layout is changed.
CXTPFlowGraphConnectionPoint::SetTooltip
void SetTooltip(LPCTSTR lpszTooltip)
Sets the tooltip for this connection point.
Definition XTPFlowGraphConnectionPoint.h:479
CXTPFlowGraphConnectionPoint::IsLocked
BOOL IsLocked() const
Gets whether the connection's points are locked.
Definition XTPFlowGraphConnectionPoint.h:527
CXTPFlowGraphConnectionPoint::OnRemoved
virtual void OnRemoved()
This method is called when the point is removed.
CXTPFlowGraphConnectionPoint::SetStyle
void SetStyle(int nStyle)
Reserved for future use.
Definition XTPFlowGraphConnectionPoint.h:491
CXTPFlowGraphConnectionPoint::GetMarkupUIElement
CXTPMarkupUIElement * GetMarkupUIElement() const
Call this method to get the markup element that renders the caption of the control.
CXTPFlowGraphConnectionPoint::GetID
int GetID() const
Gets the ID used to identify this connection point.
Definition XTPFlowGraphConnectionPoint.h:523
CXTPFlowGraphConnectionPoint::SetType
void SetType(XTPFlowGraphConnectionPointType type)
Specifies whether the flow graph connection will have any connection points (input/output).
Definition XTPFlowGraphConnectionPoint.h:507
CXTPFlowGraphConnectionPoint::GetControl
CXTPFlowGraphControl * GetControl() const
Gets a reference to the parent FlowGraph control.
CXTPFlowGraphConnectionPoint::GetType
XTPFlowGraphConnectionPointType GetType() const
Gets whether the flow graph connection will have any connection points (input/output).
Definition XTPFlowGraphConnectionPoint.h:503
CXTPFlowGraphConnectionPoint::SetMaxConnections
void SetMaxConnections(int nMaxConnections)
Specifies the maximum number of connections (connection lines) that the connection point can accept.
Definition XTPFlowGraphConnectionPoint.h:539
CXTPFlowGraphConnectionPoint::SetLocked
void SetLocked(BOOL bLocked=TRUE)
Specifies whether the connection's points should be locked.
Definition XTPFlowGraphConnectionPoint.h:531
CXTPFlowGraphConnectionPoint::GetNode
CXTPFlowGraphNode * GetNode() const
Gets a reference to the Node that this connection point belongs to.
Definition XTPFlowGraphConnectionPoint.h:499
CXTPFlowGraphConnectionPoint::~CXTPFlowGraphConnectionPoint
virtual ~CXTPFlowGraphConnectionPoint()
Destroys a CXTPFlowGraphConnectionPoint object, handles cleanup and deallocation.
CXTPFlowGraphConnectionPoint::m_bLocked
BOOL m_bLocked
Specifies if the connection point is locked.
Definition XTPFlowGraphConnectionPoint.h:408
CXTPFlowGraphConnectionPoint::HitTestConnectionArea
virtual BOOL HitTestConnectionArea(CPoint point) const
Determines if the specified point is within the connection area.
CXTPFlowGraphConnectionPoint::GetPage
CXTPFlowGraphPage * GetPage() const
Gets a reference to the page that this connection point belongs to.
CXTPFlowGraphConnectionPoint::SetID
void SetID(int nId)
Sets the ID used to identify this connection point.
Definition XTPFlowGraphConnectionPoint.h:519
CXTPFlowGraphConnectionPoint::GetOutputConnectionsCount
int GetOutputConnectionsCount() const
Gets the number of output connection lines connected to this connection point.
Definition XTPFlowGraphConnectionPoint.h:560
CXTPFlowGraphConnectionPoint::GetStyle
int GetStyle() const
Reserved for future use.
Definition XTPFlowGraphConnectionPoint.h:495
CXTPFlowGraphConnectionPoint::SetCaption
void SetCaption(LPCTSTR lpszCaption)
Sets the caption of the connection point.
CXTPFlowGraphConnectionPoint::m_bInputOutPair
BOOL m_bInputOutPair
for the undo manager.
Definition XTPFlowGraphConnectionPoint.h:413
CXTPFlowGraphConnectionPoint::GetName
CString GetName() const
Gets the name of the connection point.
Definition XTPFlowGraphConnectionPoint.h:475
CXTPFlowGraphConnectionPoint::SetColor
void SetColor(COLORREF clr)
Sets the color for the connection point.
CXTPFlowGraphConnectionPoint::GetImageIndex
int GetImageIndex() const
Gets the ID of the image to display to the left of the connection point's caption.
Definition XTPFlowGraphConnectionPoint.h:547
CXTPFlowGraphConnectionPoint::GetCaption
CString GetCaption() const
Gets the caption of the connection point.
Definition XTPFlowGraphConnectionPoint.h:471
CXTPFlowGraphConnectionPoint::GetImage
CXTPFlowGraphImage * GetImage() const
Gets the image to display to the left of the connection point's caption.
CXTPFlowGraphConnectionPoint::m_bMarkupPoint
BOOL m_bMarkupPoint
Specifies if the connection point is actually an XML-markup point-row.
Definition XTPFlowGraphConnectionPoint.h:411
CXTPFlowGraphConnectionPoint::m_nImageIndex
int m_nImageIndex
ID of the image to display to the left of the connection point's caption.
Definition XTPFlowGraphConnectionPoint.h:418
CXTPFlowGraphConnectionPoint::m_nMaxConnections
int m_nMaxConnections
The maximum number of connections (connection lines) that the connection point can accept.
Definition XTPFlowGraphConnectionPoint.h:415
CXTPFlowGraphConnectionPoint::SetName
void SetName(LPCTSTR lpszName)
Sets the name of the connection point.
CXTPFlowGraphConnectionPoint::GetOutputConnectionAt
CXTPFlowGraphConnection * GetOutputConnectionAt(int nIndex) const
Retrieves the output connection associated with a point by its index.
Definition XTPFlowGraphConnectionPoint.h:565
CXTPFlowGraphConnectionPoint::CXTPFlowGraphConnectionPoint
CXTPFlowGraphConnectionPoint()
Constructs a CXTPFlowGraphConnectionPoint object.
CXTPFlowGraphConnectionPoint::m_nStyle
int m_nStyle
Reserved for future use.
Definition XTPFlowGraphConnectionPoint.h:405
CXTPFlowGraphConnectionPoint::SetRect
void SetRect(const CRect &rect)
Sets the bounding rectangle for this element.
Definition XTPFlowGraphConnectionPoint.h:515
CXTPFlowGraphConnectionPoint::GetInputConnectionsCount
int GetInputConnectionsCount() const
Gets the number of input connection lines connected to this connection point.
Definition XTPFlowGraphConnectionPoint.h:551
CXTPFlowGraphConnectionPoint::GetTooltip
CString GetTooltip() const
Gets the tooltip for this connection point.
Definition XTPFlowGraphConnectionPoint.h:483
CXTPFlowGraphConnectionPoint::GetColor
COLORREF GetColor() const
Gets the color of the connection point.
Definition XTPFlowGraphConnectionPoint.h:487
CXTPFlowGraphConnectionPoint::m_clrPoint
COLORREF m_clrPoint
Color of the connection point.
Definition XTPFlowGraphConnectionPoint.h:400
CXTPFlowGraphConnectionPoint::GetRect
CRect GetRect() const
Gets the bounding rectangle for this element.
Definition XTPFlowGraphConnectionPoint.h:511
CXTPFlowGraphConnectionPoint::GetMaxConnections
int GetMaxConnections() const
Gets the maximum number of connections (connection lines) that the connection point can accept.
Definition XTPFlowGraphConnectionPoint.h:535
CXTPFlowGraphConnectionPoint::GetInputConnectionAt
CXTPFlowGraphConnection * GetInputConnectionAt(int nIndex) const
Retrieves the input connection associated with a point by its index.
Definition XTPFlowGraphConnectionPoint.h:556
CXTPFlowGraphConnectionPoint::SetImageIndex
void SetImageIndex(int nImageIndex)
Sets the ID of the image to display to the left of the connection point's caption.
CXTPFlowGraphConnectionPoint::GetConnectionsCount
int GetConnectionsCount() const
Gets the number of connection lines connected to this connection point.
Definition XTPFlowGraphConnectionPoint.h:543
CXTPFlowGraphConnectionPoint::m_pNode
CXTPFlowGraphNode * m_pNode
Reference to the Node that this connection point belongs to.
Definition XTPFlowGraphConnectionPoint.h:393
CXTPFlowGraphConnectionPoint::m_strCaption
CString m_strCaption
Caption of the connection point.
Definition XTPFlowGraphConnectionPoint.h:395
CXTPFlowGraphConnectionPoint::m_nId
int m_nId
ID of the connection point.
Definition XTPFlowGraphConnectionPoint.h:407
CXTPFlowGraphConnectionPoints
Represents a collection of connection points for a Node.
Definition XTPFlowGraphConnectionPoints.h:44
CXTPFlowGraphControl
Flow Graph Control.
Definition XTPFlowGraphControl.h:173
CXTPFlowGraphElement
Base class for all elements in the flow graph.
Definition XTPFlowGraphElement.h:46
CXTPFlowGraphElement::GetCaption
virtual CString GetCaption() const =0
Gets the caption displayed for this element.
CXTPFlowGraphImage
Object used to represent an image displayed in a Node or connection point.
Definition XTPFlowGraphImage.h:49
CXTPFlowGraphNodeCustom
Represents a Node object defined by custom XAML markup.
Definition XTPFlowGraphNodeCustom.h:94
CXTPFlowGraphNode
Represents a Node object.
Definition XTPFlowGraphNode.h:116
CXTPFlowGraphPage
Represents a page in the flow graph.
Definition XTPFlowGraphPage.h:54
CXTPFlowGraphPaintManager
Handles most of the drawing activities of the flow graph.
Definition XTPFlowGraphPaintManager.h:80
CXTPFlowGraphUndoDeleteConnectionPointCommand
This class abstracts the undo delete connection point command.
Definition XTPFlowGraphUndoManager.h:191
CXTPMarkupUIElement
Base class for XML Markup core level implementations.
Definition XTPMarkupUIElement.h:43
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72


Toolkit Pro: Member List

CXTPPropertyGridItem Member List

This is the complete list of members for CXTPPropertyGridItem, including all inherited members.

AddChildItem(CXTPPropertyGridItem *pItem) | CXTPPropertyGridItem |
AddComboButton() | CXTPPropertyGridItem |
AddExpandButton() | CXTPPropertyGridItem |
AddSliderControl() | CXTPPropertyGridItem |
AddSpinButton() | CXTPPropertyGridItem |
BindToString(CString *pBindString) | CXTPPropertyGridItem |
Collapse() | CXTPPropertyGridItem |
CXTPCmdTarget() | CXTPCmdTarget |
CXTPPropertyGridItem(LPCTSTR lpszCaption, LPCTSTR strValue=NULL, CString *pBindString=NULL) | CXTPPropertyGridItem |
CXTPPropertyGridItem(UINT nID, LPCTSTR strValue=NULL, CString *pBindString=NULL) | CXTPPropertyGridItem |
EnsureVisible() | CXTPPropertyGridItem |
Expand() | CXTPPropertyGridItem |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCaption() const | CXTPPropertyGridItem |
GetCaptionMetrics() const | CXTPPropertyGridItem |
GetChilds() const | CXTPPropertyGridItem |
GetConstraintEdit() const | CXTPPropertyGridItem |
GetConstraints() const | CXTPPropertyGridItem |
GetDefaultValue() const | CXTPPropertyGridItem |
GetDescription() const | CXTPPropertyGridItem |
GetDropDownItemCount() const | CXTPPropertyGridItem |
GetEditStyle() const | CXTPPropertyGridItem | virtual
GetFlags() const | CXTPPropertyGridItem |
GetGrid() const | CXTPPropertyGridItem |
GetHeight() const | CXTPPropertyGridItem |
GetID() const | CXTPPropertyGridItem |
GetIndent() const | CXTPPropertyGridItem |
GetIndex() const | CXTPPropertyGridItem |
GetInplaceButtons() const | CXTPPropertyGridItem |
GetInplaceControls() const | CXTPPropertyGridItem |
GetInPlacedEditValue() | CXTPPropertyGridItem | inlineprotectedvirtual
GetInplaceEdit() | CXTPPropertyGridItem | virtual
GetInplaceList() | CXTPPropertyGridItem | protectedvirtual
GetItemData() const | CXTPPropertyGridItem |
GetItemRect() const | CXTPPropertyGridItem |
GetMarkupCaption() const | CXTPPropertyGridItem |
GetMarkupDescription() const | CXTPPropertyGridItem |
GetMarkupTemplate() const | CXTPPropertyGridItem | virtual
GetMarkupValue() const | CXTPPropertyGridItem |
GetMaskedText() const | CXTPPropertyGridItem |
GetMetrics(BOOL bValueMetrics, BOOL bCreate=TRUE) const | CXTPPropertyGridItem |
GetMultiLinesCount() const | CXTPPropertyGridItem |
GetParentItem() const | CXTPPropertyGridItem |
GetReadOnly() const | CXTPPropertyGridItem | virtual
GetTooltip() const | CXTPPropertyGridItem |
GetValue() const | CXTPPropertyGridItem |
GetValueMetrics() const | CXTPPropertyGridItem |
GetValueRect() | CXTPPropertyGridItem | virtual
GetViewValue() | CXTPPropertyGridItem | virtual
HasChilds() const | CXTPPropertyGridItem |
HasParent(CXTPPropertyGridItem *pParent) | CXTPPropertyGridItem |
HasVisibleChilds() const | CXTPPropertyGridItem |
InsertChildItem(int nIndex, CXTPPropertyGridItem *pItem) | CXTPPropertyGridItem |
IsAllowEdit() const | CXTPPropertyGridItem | virtual
IsCategory() const | CXTPPropertyGridItem |
IsExpandable() const | CXTPPropertyGridItem |
IsExpanded() const | CXTPPropertyGridItem |
IsHidden() const | CXTPPropertyGridItem |
IsInplaceButtonVisible(CXTPPropertyGridInplaceButton *pButton) const | CXTPPropertyGridItem | virtual
IsMultiLine() const | CXTPPropertyGridItem |
IsSelected() const | CXTPPropertyGridItem |
IsValueChanged() const | CXTPPropertyGridItem | virtual
IsVisible() const | CXTPPropertyGridItem |
m_bAutoComplete | CXTPPropertyGridItem | protected
m_bCategory | CXTPPropertyGridItem | protected
m_bConstraintEdit | CXTPPropertyGridItem | protected
m_bExpandable | CXTPPropertyGridItem | protected
m_bExpanded | CXTPPropertyGridItem | protected
m_bHidden | CXTPPropertyGridItem | protected
m_bPassword | CXTPPropertyGridItem | protected
m_bReadOnly | CXTPPropertyGridItem | protected
m_bUseMask | CXTPPropertyGridItem | protected
m_bVisible | CXTPPropertyGridItem | protected
m_chPrompt | CXTPPropertyGridItem | protected
m_dwData | CXTPPropertyGridItem | protected
m_dwEditStyle | CXTPPropertyGridItem | protected
m_nDropDownItemCount | CXTPPropertyGridItem | protected
m_nFlags | CXTPPropertyGridItem | protected
m_nHeight | CXTPPropertyGridItem | protected
m_nID | CXTPPropertyGridItem | protected
m_nIndent | CXTPPropertyGridItem | protected
m_nIndex | CXTPPropertyGridItem | protected
m_nLinesCount | CXTPPropertyGridItem | protected
m_pBindString | CXTPPropertyGridItem | protected
m_pCaptionMetrics | CXTPPropertyGridItem | mutableprotected
m_pChilds | CXTPPropertyGridItem | protected
m_pConstraints | CXTPPropertyGridItem | protected
m_pGrid | CXTPPropertyGridItem | protected
m_pInplaceButtons | CXTPPropertyGridItem | protected
m_pInplaceControls | CXTPPropertyGridItem | protected
m_pMarkupCaption | CXTPPropertyGridItem | protected
m_pMarkupDescription | CXTPPropertyGridItem | protected
m_pMarkupValue | CXTPPropertyGridItem | protected
m_pParent | CXTPPropertyGridItem | protected
m_pValueMetrics | CXTPPropertyGridItem | mutableprotected
m_strCaption | CXTPPropertyGridItem | protected
m_strDefaultValue | CXTPPropertyGridItem | protected
m_strDescription | CXTPPropertyGridItem | protected
m_strFormat | CXTPPropertyGridItem | protected
m_strLiteral | CXTPPropertyGridItem | protected
m_strMarkupTemplate | CXTPPropertyGridItem | protected
m_strMask | CXTPPropertyGridItem | protected
m_strTooltip | CXTPPropertyGridItem | protected
m_strValue | CXTPPropertyGridItem | protected
MeasureItem(LPMEASUREITEMSTRUCT lpMeasureItemStruct) | CXTPPropertyGridItem | virtual
Move(CXTPPropertyGridItem *pParent, int nIndex=-1) | CXTPPropertyGridItem |
NotifyValueChanged() | CXTPPropertyGridItem | protected
OnAddChildItem() | CXTPPropertyGridItem | protectedvirtual
OnAfterEdit(CString &strValue) | CXTPPropertyGridItem | virtual
OnBeforeInsert() | CXTPPropertyGridItem | protectedvirtual
OnCancelEdit() | CXTPPropertyGridItem | virtual
OnCaptionChanged() | CXTPPropertyGridItem | protectedvirtual
OnChar(UINT nChar) | CXTPPropertyGridItem | protectedvirtual
OnConstraintsChanged() | CXTPPropertyGridItem | protectedvirtual
OnDeselect() | CXTPPropertyGridItem | protectedvirtual
OnDrawItemConstraint(CDC *pDC, CXTPPropertyGridItemConstraint *pConstraint, CRect rc, BOOL bSelected) | CXTPPropertyGridItem | virtual
OnDrawItemValue(CDC &dc, CRect rcValue) | CXTPPropertyGridItem | virtual
OnIndexChanged() | CXTPPropertyGridItem | protectedvirtual
OnInpaceControlFocus(BOOL bForward) | CXTPPropertyGridItem | protectedvirtual
OnInplaceButtonDown(CXTPPropertyGridInplaceButton *pButton) | CXTPPropertyGridItem | protectedvirtual
OnKeyDown(UINT nChar) | CXTPPropertyGridItem | protectedvirtual
OnLButtonDblClk(UINT nFlags, CPoint point) | CXTPPropertyGridItem | protectedvirtual
OnLButtonDown(UINT nFlags, CPoint point) | CXTPPropertyGridItem | protectedvirtual
OnLButtonUp(UINT nFlags, CPoint point) | CXTPPropertyGridItem | protectedvirtual
OnMarkupChanged() | CXTPPropertyGridItem | virtual
OnMergeItemConstraint(CDC *pDC, CXTPPropertyGridItemConstraint *pConstraint) | CXTPPropertyGridItem | virtual
OnRButtonDown(UINT nFlags, CPoint point) | CXTPPropertyGridItem | protectedvirtual
OnRequestEdit() | CXTPPropertyGridItem | virtual
OnSelect() | CXTPPropertyGridItem | protectedvirtual
OnValidateEdit() | CXTPPropertyGridItem | virtual
OnValueChanged(CString strValue) | CXTPPropertyGridItem | virtual
PtInValueRect(CPoint point) | CXTPPropertyGridItem | protected
RedrawItem() | CXTPPropertyGridItem |
Remove() | CXTPPropertyGridItem |
ResetValue() | CXTPPropertyGridItem | virtual
Select() | CXTPPropertyGridItem |
SelectNextConstraint() | CXTPPropertyGridItem | protected
SetAutoComplete(BOOL bAutoComplete=TRUE) | CXTPPropertyGridItem |
SetCaption(LPCTSTR lpszCaption) | CXTPPropertyGridItem |
SetConstraintEdit(BOOL bConstraintEdit=TRUE) | CXTPPropertyGridItem |
SetDefaultValue(LPCTSTR lpszDefaultValue) | CXTPPropertyGridItem |
SetDescription(LPCTSTR lpszDescription) | CXTPPropertyGridItem |
SetDropDownItemCount(int nDropDownItemCount) | CXTPPropertyGridItem |
SetEditStyle(DWORD dwEditStyle) | CXTPPropertyGridItem |
SetEditText(const CString &str) | CXTPPropertyGridItem | protectedvirtual
SetExpandable(BOOL bExpandable) | CXTPPropertyGridItem |
SetFlags(UINT nFlags) | CXTPPropertyGridItem |
SetFocusToInplaceControl() | CXTPPropertyGridItem | virtual
SetHeight(int nHeight) | CXTPPropertyGridItem |
SetHidden(BOOL bHidden) | CXTPPropertyGridItem |
SetID(UINT nID) | CXTPPropertyGridItem |
SetItemData(DWORD_PTR dwData) | CXTPPropertyGridItem |
SetMarkupTemplate(LPCTSTR lpstrMarkupTemplate) | CXTPPropertyGridItem |
SetMask(LPCTSTR strMask, LPCTSTR strLiteral, TCHAR chPrompt=_T('_')) | CXTPPropertyGridItem |
SetMaskedText(LPCTSTR lpszMaskedText) | CXTPPropertyGridItem |
SetMultiLinesCount(int nLinesCount) | CXTPPropertyGridItem |
SetPasswordMask(TCHAR chMask=_T(' *')) | CXTPPropertyGridItem |
SetPrompt(LPCTSTR lpszPrompt) | CXTPPropertyGridItem |
SetReadOnly(BOOL bReadOnly=TRUE) | CXTPPropertyGridItem | virtual
SetTooltip(LPCTSTR lpstrTooltip) | CXTPPropertyGridItem |
SetValue(CString strValue) | CXTPPropertyGridItem | virtual
SetVisible(BOOL bVisible) | CXTPPropertyGridItem | protectedvirtual
~CXTPPropertyGridItem() | CXTPPropertyGridItem | virtual


Toolkit Pro: Member List

  • CXTPNotifySinkBase
  • ADVISE_DESCRIPTOR
CXTPNotifySinkBase::ADVISE_DESCRIPTOR Member List

This is the complete list of members for CXTPNotifySinkBase::ADVISE_DESCRIPTOR, including all inherited members.

dwConnectionID | CXTPNotifySinkBase::ADVISE_DESCRIPTOR
dwNotifyCode | CXTPNotifySinkBase::ADVISE_DESCRIPTOR
pConnection | CXTPNotifySinkBase::ADVISE_DESCRIPTOR


Toolkit Pro: Member List

CXTPChartRangeAreaSeriesLabel Member List

This is the complete list of members for CXTPChartRangeAreaSeriesLabel, including all inherited members.

CreateView(CXTPChartDeviceContext *pDC, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView) | CXTPChartRangeAreaSeriesLabel | virtual
CXTPChartDiagram2DSeriesLabel() | CXTPChartDiagram2DSeriesLabel |
CXTPChartElement() | CXTPChartElement |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartPointSeriesLabel() | CXTPChartPointSeriesLabel |
CXTPChartRangeAreaSeriesLabel() | CXTPChartRangeAreaSeriesLabel |
CXTPChartSeriesLabel() | CXTPChartSeriesLabel |
DoPropExchange(CXTPPropExchange *pPX) | CXTPChartRangeAreaSeriesLabel | virtual
GetAngle() const | CXTPChartPointSeriesLabel |
GetAntialiasing() const | CXTPChartSeriesLabel | virtual
GetAppearance() const | CXTPChartElement |
GetBackColor() const | CXTPChartSeriesLabel |
GetContent() const | CXTPChartElement |
GetFont() const | CXTPChartSeriesLabel | virtual
GetFormat() const | CXTPChartSeriesLabel |
GetLineColor() const | CXTPChartSeriesLabel |
GetLineLength() const | CXTPChartSeriesLabel |
GetOwner() const | CXTPChartElement |
GetShowLines() const | CXTPChartSeriesLabel |
GetTextColor() const | CXTPChartSeriesLabel |
GetTransparency() const | CXTPChartSeriesLabel |
Is3D() const | CXTPChartObject |
IsVisible() const | CXTPChartSeriesLabel |
m_bAntialiasing | CXTPChartSeriesLabel | protected
m_bShowLines | CXTPChartSeriesLabel | protected
m_bVisible | CXTPChartSeriesLabel | protected
m_clrBackColor | CXTPChartSeriesLabel | protected
m_clrLineColor | CXTPChartSeriesLabel | protected
m_clrTextColor | CXTPChartSeriesLabel | protected
m_nAngle | CXTPChartPointSeriesLabel | protected
m_nLineLength | CXTPChartSeriesLabel | protected
m_nTransparency | CXTPChartSeriesLabel | protected
m_pBorder | CXTPChartSeriesLabel | protected
m_pFont | CXTPChartSeriesLabel | protected
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartElement | virtual
Release() | CXTPChartElement | virtual
SetAngle(int nAngle) | CXTPChartPointSeriesLabel |
SetAntialiasing(BOOL bAntialiasing) | CXTPChartSeriesLabel |
SetBackColor(const CXTPChartColor &clrBackColor) | CXTPChartSeriesLabel |
SetFont(CXTPChartFont *pFont) | CXTPChartSeriesLabel |
SetFormat(LPCTSTR lpszFormat) | CXTPChartSeriesLabel |
SetLineColor(const CXTPChartColor &clrBackColor) | CXTPChartSeriesLabel |
SetLineLength(int nLineLength) | CXTPChartSeriesLabel |
SetShowLines(BOOL bShowLines) | CXTPChartSeriesLabel |
SetTextColor(const CXTPChartColor &clrTextColor) | CXTPChartSeriesLabel |
SetTransparency(int nTransparency) | CXTPChartSeriesLabel |
SetVisible(BOOL bVisible) | CXTPChartSeriesLabel |
~CXTPChartDiagram2DSeriesLabel() | CXTPChartDiagram2DSeriesLabel | virtual
~CXTPChartElement() | CXTPChartElement | virtual
~CXTPChartPointSeriesLabel() | CXTPChartPointSeriesLabel | virtual
~CXTPChartRangeAreaSeriesLabel() | CXTPChartRangeAreaSeriesLabel | virtual
~CXTPChartSeriesLabel() | CXTPChartSeriesLabel | virtual


Toolkit Pro: Member List

CXTPChartFunnelSeriesLabel Member List

This is the complete list of members for CXTPChartFunnelSeriesLabel, including all inherited members.

CreateView(CXTPChartDeviceContext *pDC, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView) | CXTPChartFunnelSeriesLabel | protectedvirtual
CXTPChartElement() | CXTPChartElement |
CXTPChartFunnelSeriesLabel() | CXTPChartFunnelSeriesLabel |
CXTPChartFunnelSeriesLabelBase() | CXTPChartFunnelSeriesLabelBase |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartSeriesLabel() | CXTPChartSeriesLabel |
DoPropExchange(CXTPPropExchange *pPX) | CXTPChartFunnelSeriesLabelBase | virtual
GetAntialiasing() const | CXTPChartSeriesLabel | virtual
GetAppearance() const | CXTPChartElement |
GetBackColor() const | CXTPChartSeriesLabel |
GetContent() const | CXTPChartElement |
GetFont() const | CXTPChartSeriesLabel | virtual
GetFormat() const | CXTPChartSeriesLabel |
GetLineColor() const | CXTPChartSeriesLabel |
GetLineLength() const | CXTPChartSeriesLabel |
GetOwner() const | CXTPChartElement |
GetPosition() const | CXTPChartFunnelSeriesLabelBase |
GetShowLines() const | CXTPChartSeriesLabel |
GetStyle() const | CXTPChartFunnelSeriesLabel |
GetTextColor() const | CXTPChartSeriesLabel |
GetTransparency() const | CXTPChartSeriesLabel |
Is3D() const | CXTPChartObject |
IsInside() const | CXTPChartFunnelSeriesLabelBase |
IsVisible() const | CXTPChartSeriesLabel |
m_bAntialiasing | CXTPChartSeriesLabel | protected
m_bShowLines | CXTPChartSeriesLabel | protected
m_bVisible | CXTPChartSeriesLabel | protected
m_clrBackColor | CXTPChartSeriesLabel | protected
m_clrLineColor | CXTPChartSeriesLabel | protected
m_clrTextColor | CXTPChartSeriesLabel | protected
m_nLineLength | CXTPChartSeriesLabel | protected
m_nPosition | CXTPChartFunnelSeriesLabelBase | protected
m_nTransparency | CXTPChartSeriesLabel | protected
m_pBorder | CXTPChartSeriesLabel | protected
m_pFont | CXTPChartSeriesLabel | protected
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartElement | virtual
Release() | CXTPChartElement | virtual
SetAntialiasing(BOOL bAntialiasing) | CXTPChartSeriesLabel |
SetBackColor(const CXTPChartColor &clrBackColor) | CXTPChartSeriesLabel |
SetFont(CXTPChartFont *pFont) | CXTPChartSeriesLabel |
SetFormat(LPCTSTR lpszFormat) | CXTPChartSeriesLabel |
SetLineColor(const CXTPChartColor &clrBackColor) | CXTPChartSeriesLabel |
SetLineLength(int nLineLength) | CXTPChartSeriesLabel |
SetPosition(XTPChartFunnelLabelPosition nPosition) | CXTPChartFunnelSeriesLabelBase |
SetShowLines(BOOL bShowLines) | CXTPChartSeriesLabel |
SetTextColor(const CXTPChartColor &clrTextColor) | CXTPChartSeriesLabel |
SetTransparency(int nTransparency) | CXTPChartSeriesLabel |
SetVisible(BOOL bVisible) | CXTPChartSeriesLabel |
~CXTPChartElement() | CXTPChartElement | virtual
~CXTPChartFunnelSeriesLabelBase() | CXTPChartFunnelSeriesLabelBase | virtual
~CXTPChartSeriesLabel() | CXTPChartSeriesLabel | virtual


Toolkit Pro: XTPFlowGraphSelectionRect.h Source File

  • Source
  • FlowGraph
XTPFlowGraphSelectionRect.h
Go to the documentation of this file.
1
23#if !defined(__XTPFLOWGRAPHVISIOSELECTIONRECT_H__)
24# define __XTPFLOWGRAPHVISIOSELECTIONRECT_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPFlowGraphDrawContext;
34
35// constants are in the same order as rectangles appear after GetSizingRects method
36
42enum SelectionRectHitTest
43{
44 SelectionRectHitTestTopLeft = 0,
45 SelectionRectHitTestTopCenter,
46 SelectionRectHitTestTopRight,
47 SelectionRectHitTestMiddleRight,
48 SelectionRectHitTestBottomRight,
49 SelectionRectHitTestBottomCenter,
50 SelectionRectHitTestBottomLeft,
51 SelectionRectHitTestMiddleLeft,
52 SelectionRectHitTestNone
53};
54
55class _XTP_EXT_CLASS CXTPFlowGraphSelectionRect
56{
57protected:
58 static double m_zoomLevel;
59 static int m_iSizeSquareSize;
60
61 static void AFX_CDECL GetSizingRects(const CRect& rc, CRect* rects);
62 static void AFX_CDECL GetSizingRectsEx(const CRect& rc, CRect* rects);
63
64public:
65 CXTPFlowGraphSelectionRect();
66 virtual ~CXTPFlowGraphSelectionRect();
67
68 void Draw(CXTPFlowGraphDrawContext* pDC, const CRect& rc);
69
70 static SelectionRectHitTest AFX_CDECL HitTest(const CRect& rc, const CPoint& point);
71
72 static void AFX_CDECL ResizeRect(CRect& rcRect, CSize szMinSize, CPoint ptOffset,
73 SelectionRectHitTest hitPoint);
74
75 static UINT AFX_CDECL GetCursorBySelectionHitTest(SelectionRectHitTest hitTest);
76
77 static void SetZoomLevel(double zoomLevel);
78};
80# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
81#endif //#if !defined(__XTPFLOWGRAPHVISIOSELECTIONRECT_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
SelectionRectHitTest
SelectionRectHitTest
Defines selection rectangle hit test codes.
Definition XTPFlowGraphSelectionRect.h:43
SelectionRectHitTestMiddleRight
@ SelectionRectHitTestMiddleRight
Specifies middle right rectangle area.
Definition XTPFlowGraphSelectionRect.h:47
SelectionRectHitTestTopRight
@ SelectionRectHitTestTopRight
Specifies top right rectangle area.
Definition XTPFlowGraphSelectionRect.h:46
SelectionRectHitTestBottomRight
@ SelectionRectHitTestBottomRight
Specifies bottom right rectangle area.
Definition XTPFlowGraphSelectionRect.h:48
SelectionRectHitTestNone
@ SelectionRectHitTestNone
No rectangle area is hit.
Definition XTPFlowGraphSelectionRect.h:52
SelectionRectHitTestMiddleLeft
@ SelectionRectHitTestMiddleLeft
Specifies middle left rectangle area.
Definition XTPFlowGraphSelectionRect.h:51
SelectionRectHitTestTopLeft
@ SelectionRectHitTestTopLeft
Specifies top left rectangle area.
Definition XTPFlowGraphSelectionRect.h:44
SelectionRectHitTestTopCenter
@ SelectionRectHitTestTopCenter
Specifies top center rectangle area.
Definition XTPFlowGraphSelectionRect.h:45
SelectionRectHitTestBottomLeft
@ SelectionRectHitTestBottomLeft
Specifies bottom left rectangle area.
Definition XTPFlowGraphSelectionRect.h:50
SelectionRectHitTestBottomCenter
@ SelectionRectHitTestBottomCenter
Specifies bottom center rectangle area.
Definition XTPFlowGraphSelectionRect.h:49


Toolkit Pro: Member List

CXTPDatePickerThemeVisualStudio2015 Member List

This is the complete list of members for CXTPDatePickerThemeVisualStudio2015, including all inherited members.

CalcDayOfWeekRect(CDC *pDC) | CXTPDatePickerPaintManager | virtual
CalcDayRect(CDC *pDC) | CXTPDatePickerPaintManager | virtual
CalcMonthHeaderRect(CDC *pDC) | CXTPDatePickerPaintManager | virtual
CalcMonthRect(CDC *pDC) | CXTPDatePickerPaintManager | virtual
CalcWeekNumbersRect(CDC *pDC) | CXTPDatePickerPaintManager | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPDatePickerPaintManager() | CXTPDatePickerPaintManager |
CXTPDatePickerThemeOffice2013() | CXTPDatePickerThemeOffice2013 |
CXTPDatePickerThemeVisualStudio2015() | CXTPDatePickerThemeVisualStudio2015 |
DrawBackground(CDC *pDC, CRect rcClient) | CXTPDatePickerThemeOffice2013 | virtual
DrawBorder(CDC *pDC, const CXTPDatePickerControl *pControl, CRect &rcClient, BOOL bDraw) | CXTPDatePickerThemeOffice2013 | virtual
DrawButton(CDC *pDC, const CRect &rcButton, const CString &strButton, BOOL bIsDown, BOOL bIsHighLight) | CXTPDatePickerThemeOffice2013 | virtual
DrawDay(CDC *pDC, CXTPDatePickerItemDay *pDay) | CXTPDatePickerThemeOffice2013 | virtual
DrawDaysOfWeek(CDC *pDC, CXTPDatePickerItemMonth *pMonth) | CXTPDatePickerThemeOffice2013 | virtual
DrawMonthHeader(CDC *pDC, CXTPDatePickerItemMonth *pMonth) | CXTPDatePickerPaintManager | virtual
DrawScrollTriangle(CDC *pDC, CRect rcSpot, BOOL bLeftDirection, COLORREF clrColor=0, BOOL bYears=FALSE) | CXTPDatePickerPaintManager | virtual
DrawWeekNumbers(CDC *pDC, CXTPDatePickerItemMonth *pMonth) | CXTPDatePickerThemeOffice2013 | virtual
EnableTheme(BOOL bEnableTheme) | CXTPDatePickerPaintManager | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetButtonFont() | CXTPDatePickerPaintManager |
GetControlBackColor() | CXTPDatePickerPaintManager | virtual
GetCursorBack() | CXTPDatePickerPaintManager | virtual
GetDayBackColor() | CXTPDatePickerPaintManager | virtual
GetDaysOfWeekBackColor() | CXTPDatePickerPaintManager | virtual
GetDaysOfWeekTextColor() | CXTPDatePickerPaintManager | virtual
GetDaysOfWeekTextFont() | CXTPDatePickerPaintManager |
GetDayTextColor() | CXTPDatePickerPaintManager | virtual
GetDayTextFont() | CXTPDatePickerPaintManager | virtual
GetDayTextFontBold() | CXTPDatePickerPaintManager | virtual
GetHeaderTextFont() | CXTPDatePickerPaintManager |
GetHighlightTodayBackColor() | CXTPDatePickerThemeOffice2013 | virtual
GetHighlightTodayBorderColor() | CXTPDatePickerThemeOffice2013 | virtual
GetHighlightTodayColor() | CXTPDatePickerPaintManager | virtual
GetHighlightTodayTextColor() | CXTPDatePickerThemeOffice2013 | virtual
GetListControlBackColor() | CXTPDatePickerPaintManager | virtual
GetListControlTextColor() | CXTPDatePickerPaintManager | virtual
GetListControlTextFont() | CXTPDatePickerPaintManager |
GetMonthHeaderBackColor() | CXTPDatePickerPaintManager | virtual
GetMonthHeaderTextColor() | CXTPDatePickerPaintManager | virtual
GetNonMonthDayBackColor() | CXTPDatePickerPaintManager | virtual
GetNonMonthDayTextColor() | CXTPDatePickerPaintManager | virtual
GetNonMonthDayTextFont() | CXTPDatePickerPaintManager |
GetPaintTheme() const | CXTPDatePickerPaintManager | protected
GetSelectedDayBackColor() | CXTPDatePickerPaintManager | virtual
GetSelectedDayTextColor() | CXTPDatePickerPaintManager | virtual
GetWeekNumbersBackColor() | CXTPDatePickerPaintManager | virtual
GetWeekNumbersTextColor() | CXTPDatePickerPaintManager | virtual
GetWeekNumbersTextFont() | CXTPDatePickerPaintManager |
m_bEnableTheme | CXTPDatePickerPaintManager | protected
m_clr3DFace | CXTPDatePickerPaintManager | protected
m_clr3DLight | CXTPDatePickerPaintManager | protected
m_clr3DShadow | CXTPDatePickerPaintManager | protected
m_clr3DText | CXTPDatePickerPaintManager | protected
m_clrBackground | CXTPDatePickerThemeOffice2013 | protected
m_clrButtonFace | CXTPDatePickerPaintManager |
m_clrButtonText | CXTPDatePickerPaintManager |
m_clrControlBack | CXTPDatePickerPaintManager |
m_clrDayBack | CXTPDatePickerPaintManager |
m_clrDaysOfWeekBack | CXTPDatePickerPaintManager |
m_clrDaysOfWeekText | CXTPDatePickerPaintManager |
m_clrDayText | CXTPDatePickerPaintManager |
m_clrHighlightToday | CXTPDatePickerPaintManager |
m_clrListControlBack | CXTPDatePickerPaintManager |
m_clrListControlText | CXTPDatePickerPaintManager |
m_clrMonthBorder | CXTPDatePickerPaintManager |
m_clrMonthHeaderBack | CXTPDatePickerPaintManager |
m_clrMonthHeaderButton | CXTPDatePickerPaintManager |
m_clrMonthHeaderText | CXTPDatePickerPaintManager |
m_clrNonMonthDayBack | CXTPDatePickerPaintManager |
m_clrNonMonthDayText | CXTPDatePickerPaintManager |
m_clrSelectedDayBack | CXTPDatePickerPaintManager |
m_clrSelectedDayText | CXTPDatePickerPaintManager |
m_clrStaticBorder | CXTPDatePickerPaintManager | protected
m_clrWeekNumbersBack | CXTPDatePickerPaintManager |
m_clrWeekNumbersText | CXTPDatePickerPaintManager |
m_hCursorBack | CXTPDatePickerPaintManager | protected
m_nPaintTheme | CXTPDatePickerPaintManager | protected
m_szDayMargin | CXTPDatePickerPaintManager |
m_themeButton | CXTPDatePickerPaintManager | protected
m_xtpFontButton | CXTPDatePickerPaintManager | protected
m_xtpFontDay | CXTPDatePickerPaintManager | protected
m_xtpFontDayBold | CXTPDatePickerPaintManager | protected
m_xtpFontDaysOfWeek | CXTPDatePickerPaintManager | protected
m_xtpFontHeader | CXTPDatePickerPaintManager | protected
m_xtpFontListControl | CXTPDatePickerPaintManager | protected
m_xtpFontNonMonthDay | CXTPDatePickerPaintManager | protected
m_xtpFontWeekNumbers | CXTPDatePickerPaintManager | protected
RefreshMetrics() | CXTPDatePickerThemeOffice2013 | virtual
SetButtonFont(CFont *fontButton) | CXTPDatePickerPaintManager |
SetButtonFontIndirect(LOGFONT *lFont) | CXTPDatePickerPaintManager |
SetFontIndirect(LOGFONT *lFont) | CXTPDatePickerPaintManager |
Triangle(CDC *pDC, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clrColor=0) | CXTPDatePickerPaintManager | protectedvirtual
~CXTPDatePickerPaintManager() | CXTPDatePickerPaintManager | virtual
~CXTPDatePickerThemeOffice2013() | CXTPDatePickerThemeOffice2013 | virtual
~CXTPDatePickerThemeVisualStudio2015() | CXTPDatePickerThemeVisualStudio2015 | virtual


Toolkit Pro: XTPCalendarOccurSeriesChooseDlg.h Source File

  • Source
  • Calendar
XTPCalendarOccurSeriesChooseDlg.h
Go to the documentation of this file.
1
22#ifndef _XTPCALENDAROCCURSERIESCHOOSEDLG_H__
23#define _XTPCALENDAROCCURSERIESCHOOSEDLG_H__
24
25#if _MSC_VER > 1000
26# pragma once
27#endif // _MSC_VER > 1000
29
30#include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
31
32class CXTPCalendarEvent;
42class _XTP_EXT_CLASS CXTPCalendarOccurSeriesChooseDlg : public CDialog
43{
44public:
45 enum
46 {
47 IDD = XTP_IDD_CALENDAR_DIALOG_OCURR_SERIES
48 };
49
72 CXTPCalendarOccurSeriesChooseDlg(CWnd* pParent, UINT nIDResourceLabels,
73 LPCTSTR lpszResourceIcon = IDI_EXCLAMATION,
74 UINT nIDTemplate = CXTPCalendarOccurSeriesChooseDlg::IDD);
75
80 virtual ~CXTPCalendarOccurSeriesChooseDlg();
81
82public:
93 virtual void SetEvent(CXTPCalendarEvent* pEvent);
94
95 BOOL m_bOccur;
98protected:
99 virtual void DoDataExchange(CDataExchange* pDX); // DDX/DDV support
100 virtual BOOL OnInitDialog();
101 virtual void OnOK();
103 DECLARE_MESSAGE_MAP()
106protected:
107 CStatic m_ctrlMessage;
108 CStatic m_ctrlIcon;
109 CButton m_ctrlOccur;
110 CButton m_ctrlSeries;
112 CString m_strTitle;
113 CString m_strMessage;
114 CString m_strOccur;
115 CString m_strSeries;
117 UINT m_nIDResourceLabels;
118 HICON m_hIcon;
119};
120
121#include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
122#endif // _XTPCALENDAROCCURSERIESCHOOSEDLG_H__
XTPDisableNoisyWarnings.h
CXTPCalendarEvent
This class represents the data of a single Event used in the Calendar control.
Definition XTPCalendarEvent.h:77
CXTPCalendarOccurSeriesChooseDlg
This class implements a dialog to choose between current occurrence and whole recurrence event series...
Definition XTPCalendarOccurSeriesChooseDlg.h:43
CXTPCalendarOccurSeriesChooseDlg::m_bOccur
BOOL m_bOccur
[in/out] Contain default/selected choice.
Definition XTPCalendarOccurSeriesChooseDlg.h:95
CXTPCalendarOccurSeriesChooseDlg::~CXTPCalendarOccurSeriesChooseDlg
virtual ~CXTPCalendarOccurSeriesChooseDlg()
Default class destructor.
CXTPCalendarOccurSeriesChooseDlg::CXTPCalendarOccurSeriesChooseDlg
CXTPCalendarOccurSeriesChooseDlg(CWnd *pParent, UINT nIDResourceLabels, LPCTSTR lpszResourceIcon=IDI_EXCLAMATION, UINT nIDTemplate=CXTPCalendarOccurSeriesChooseDlg::IDD)
Default object constructor.
CXTPCalendarOccurSeriesChooseDlg::SetEvent
virtual void SetEvent(CXTPCalendarEvent *pEvent)
Update dialog information from the specified event.


Toolkit Pro: XTPSyntaxEditCtrl.h Source File

  • Source
  • SyntaxEdit
XTPSyntaxEditCtrl.h
Go to the documentation of this file.
1
23#if !defined(__XTPSYNTAXEDITSYNTAXEDITCTRL_H__)
24# define __XTPSYNTAXEDITSYNTAXEDITCTRL_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
34typedef CMap<int, int, COLORREF, COLORREF> CXTPSyntaxEditRowColorMap;
37// forwards
38class CXTPNotifySink;
39class CXTPSyntaxEditBufferManager;
40class CXTPSyntaxEditConfigurationManager;
41class CXTPSyntaxEditToolTipCtrl;
42class CXTPSyntaxEditAutoCompleteWnd;
43class CXTPSyntaxEditLineMarksManager;
44class CXTPSyntaxEditDrawTextProcessor;
45class CXTPSyntaxEditSelection;
46typedef CList<XTP_EDIT_TEXTBLOCK, XTP_EDIT_TEXTBLOCK> CXTPSyntaxEditTextBlockList;
47typedef LPCTSTR XTP_EDIT_LINEMARKTYPE;
48struct XTP_EDIT_LMPARAM;
49
54class _XTP_EXT_CLASS CXTPSyntaxEditOptions : public CXTPCmdTarget
55{
56public:
57 CXTPSyntaxEditOptions();
58
59protected:
60 BOOL m_bSyntaxColor;
61 BOOL m_bAutoIndent;
62 BOOL m_bSelMargin;
63 BOOL m_bLineNumbers;
64 BOOL m_bWideCaret;
65 BOOL m_bTabWithSpace;
66 BOOL m_bVirtualSpace;
68 BOOL m_bDrawNodes;
69 BOOL m_bEnableWhiteSpace;
70 BOOL m_bReadOnly;
71 BOOL m_bViewOnly;
72 BOOL m_bHideCaret;
73 BOOL m_bEnableEditAccelerators;
77 CXTPSyntaxEditRowColorMap m_mapRowBkColor;
78 CXTPSyntaxEditRowColorMap m_mapRowForeColor;
80 friend class CXTPSyntaxEditCtrl;
81};
82
113class _XTP_EXT_CLASS CXTPSyntaxEditCtrl : public CWnd
114{
115 DECLARE_DYNAMIC(CXTPSyntaxEditCtrl)
116
117 friend class CXTPSyntaxEditAutoCompleteWnd;
118 friend class CXTPSyntaxEditView;
119 friend class CXTPSyntaxEditCommand;
120 friend class CXTPSyntaxEditPaintManager;
121 friend class CXTPSyntaxEditSelection;
122 friend class CSyntaxEditCtrl;
123 friend class CSyntaxEditBaseCtrl;
124
125 class CImmWrapper;
126
127public:
132 CXTPSyntaxEditCtrl();
133
138 virtual ~CXTPSyntaxEditCtrl();
139
140public:
148 BOOL GetLineNumbers() const;
149
159 BOOL SetLineNumbers(BOOL bLineNumbers, BOOL bUpdateReg = FALSE);
160
168 BOOL GetCollapsibleNodes() const;
169
178 void SetCollapsibleNodes(BOOL bDrawNodes, BOOL bUpdateReg = FALSE);
179
186 BOOL UnTabifySelection();
187
194 BOOL TabifySelection();
195
202 BOOL LowercaseSelection();
203
210 BOOL UppercaseSelection();
211
220 CXTPSyntaxEditSelection& GetSelection();
221
230 CXTPSyntaxEditAutoCompleteWnd* GetAutoCompleteWnd() const;
231
240 int GetRowPerPage() const;
241
249 BOOL IsRowVisible(int iRow) const;
250
263 void SetRightButtonDrag(BOOL bRightButtonDrag = TRUE);
264
277 BOOL SetScrollBars(BOOL bHorzSBar, BOOL bVertSBar, BOOL bUpdateReg = FALSE);
278
286 BOOL GetHorzScrollBar() const;
287
295 BOOL GetVertScrollBar() const;
296
311 BOOL SetSelMargin(BOOL bSelMargin, BOOL bUpdateReg = FALSE);
312
322 BOOL GetSelMargin() const;
323
336 BOOL SetSyntaxColor(BOOL bSyntaxColor, BOOL bUpdateReg = FALSE);
337
346 BOOL GetSyntaxColor() const;
347
360 BOOL SetAutoIndent(BOOL bAutoIndent, BOOL bUpdateReg = FALSE);
361
371 BOOL GetAutoIndent() const;
372
384 BOOL SetTabSize(int nTabSize, BOOL bUpdateReg = FALSE);
385
394 int GetTabSize() const;
395
405 BOOL GetTabWithSpace() const;
406
419 BOOL SetTabWithSpace(BOOL bTabWithSpace, BOOL bUpdateReg = FALSE);
420
429 void SetRowColor(int nRow, COLORREF clrFront);
430
440 virtual COLORREF GetRowColor(int nRow) const;
441
450 void SetRowBkColor(int nRow, COLORREF crBack);
451
461 virtual COLORREF GetRowBkColor(int nRow) const;
462
472 BOOL IsEnabledWhiteSpace() const;
473
482 void EnableWhiteSpace(BOOL bShow = TRUE);
483
493 BOOL IsEnabledVirtualSpace() const;
494
505 void EnableVirtualSpace(BOOL bEnable, BOOL bUpdateReg = FALSE);
506
516 BOOL IsRightButtonDrag() const;
517
524 void CancelRightButtonDrag();
525
534 void ShowDefaultContextMenu();
535
542 void HandleDrop(BOOL bCopy);
543
550 void GoToRow(int iRow, BOOL bSelectRow = FALSE);
551
559 BOOL ReplaceSel(LPCTSTR szNewText);
560
571 int ReplaceAll(LPCTSTR szFindText, LPCTSTR szReplaceText, BOOL bMatchWholeWord,
572 BOOL bMatchCase);
573
582 int GetSelectionText(CString& strText);
583
592 void SetDropPos(int iRow, int iCol);
593
600 int GetCurAbsCol() const;
601
613 HGLOBAL GetSelectionBuffer(UINT nFormat);
614
621 void EnableOleDrag(BOOL bEnableDrag = TRUE);
622
630 void ValidateCol(const int nRow, int& nCol, int& nAbsCol);
631
649 BOOL RowColFromPoint(CPoint pt, int* pRow, int* pCol, int* pDispRow = NULL,
650 int* pDispCol = NULL, BOOL bVirtualSpace = -1);
651
658 BOOL DecreaseIndent();
659
666 BOOL IncreaseIndent();
667
675 void DeleteSelectedLines(int iForceDeleteRow);
676
684 void ShowHScrollBar(BOOL bShow = TRUE);
685
691 void CopyOrMoveText(BOOL bCopy);
692
713 BOOL Find(LPCTSTR szText, BOOL bMatchWholeWord, BOOL bMatchCase, BOOL bSearchDown,
714 BOOL bRedraw = TRUE, int nStartRow = -1, int nStartCol = -1);
715
729 BOOL Select(int nRow1, int nDispCol1, int nRow2, int nDispCol2, BOOL bRedraw = TRUE);
730
737 void Unselect();
738
746 const CXTPSyntaxEditCtrl& operator=(const CXTPSyntaxEditCtrl& src);
747
754 void RestoreCursor();
755
762 void SetOverwriteMode(BOOL bOverwriteMode);
763
774 BOOL SetWideCaret(BOOL bWideCaret, BOOL bUpdateReg = FALSE);
775
783 BOOL GetWideCaret() const;
784
791 BOOL IsHideCaret() const;
792
800 void SetHideCaret(BOOL bHide);
801
807 void SelectWord(CPoint point);
808
819 void SetCurCaretPos(int nTextRow, int nDispCol, BOOL bRowColNotify = TRUE,
820 BOOL bEnsureVisible = TRUE);
821
828 CXTPSyntaxEditBufferManager* GetEditBuffer() const;
829
836 CXTPSyntaxEditConfigurationManager* GetLexConfigurationManager() const;
837
844 CXTPSyntaxEditPaintManager* GetPaintManager() const;
845
851 virtual void SetPaintManager(CXTPSyntaxEditPaintManager* pPaintManager);
852
859 CXTPSyntaxEditDrawTextProcessor& GetDrawTextProcessor();
860
871 void InsertString(LPCTSTR szText, int iRow, int iCol, BOOL bDeleteSelection = TRUE);
872
883 void InsertTextBlock(LPCTSTR szText, int iRow, int iCol, BOOL bDeleteSelection = TRUE);
884
893 CString GetConfigFile() const;
894
901 static CString AFX_CDECL GetModulePath();
902
915 BOOL SetConfigFile(LPCTSTR szPath, BOOL bConfigFileMode = TRUE);
916
924 void SetFontIndirect(LPLOGFONT pLogfont, BOOL bUpdateReg = FALSE);
925
938 void SetCurPos(int nTextRow, int nDispCol, BOOL bRemainSelected = FALSE,
939 BOOL bForceVisible = TRUE);
940
947 int GetCurCol() const;
948
955 int GetCurRow() const;
956
963 int GetRowCount() const;
964
969 void SelectAll();
970
979 virtual void Draw(CDC* pDC, const CRect& rcRect);
980
995 virtual int PrintPage(CDC* pDC, const CRect& rcRect, int nFlags = 0);
996
1021 virtual CRect CalcEditRects(CRect* prcBookMarks = NULL, CRect* prcLineNum = NULL,
1022 CRect* prcNodes = NULL, CRect* prcText = NULL,
1023 const CRect* prcClient = NULL) const;
1024
1031 BOOL IsSelectionExist() const;
1032
1037 void Paste();
1038
1043 void Copy();
1044
1050 void Cut();
1051
1060 BOOL CanRedo() const;
1061
1070 BOOL CanUndo() const;
1071
1081 BOOL Redo(int nActionsCount = 1);
1082
1092 BOOL Undo(int nActionsCount = 1);
1093
1100 const CStringList& GetUndoTextList();
1101
1108 const CStringList& GetRedoTextList();
1109
1121 BOOL DeleteChar(int iRow, int iCol, XTPSyntaxEditDeletePos pos);
1122
1137 BOOL DeleteBuffer(int iRowFrom, int iColFrom, int iRowTo, int iColTo, int nFlags = 0);
1138
1145 BOOL DeleteSelection();
1146
1163 CString GetText(int nMaxLen = -1) const;
1164
1182 BOOL GetText(CMemFile& memFile, int nMaxLen = -1) const;
1183
1193 void SetText(LPCTSTR pcszText);
1194
1202 void SetTopRow(int iRow);
1203
1212 int GetTopRow() const;
1213
1219 void RecalcScrollBars();
1220
1257 void RepositionBars(UINT nIDFirst, UINT nIDLast, UINT nIDLeftOver,
1258 UINT nFlag = CWnd::reposDefault, LPRECT lpRectParam = NULL,
1259 LPCRECT lpRectClient = NULL, BOOL bStretch = TRUE);
1260
1279 virtual CScrollBar* GetScrollBarCtrl(int nBar) const;
1280
1293 void EnableScrollBarCtrl(int nBar, BOOL bEnable = TRUE);
1294
1317 void ShowScrollBar(UINT nBar, BOOL bShow = TRUE);
1318
1349 void SetScrollRange(int nBar, int nMinPos, int nMaxPos, BOOL bRedraw = TRUE);
1350
1370 int SetScrollPos(int nBar, int nPos, BOOL bRedraw = TRUE);
1371
1398 BOOL SetScrollInfo(int nBar, LPSCROLLINFO lpScrollInfo, BOOL bRedraw = TRUE);
1399
1412 int GetScrollLimit(int nBar);
1413
1458 BOOL GetScrollInfo(int nBar, LPSCROLLINFO lpScrollInfo, UINT nMask = SIF_ALL);
1459
1510 int ScrollWindowEx(int dx, int dy, LPCRECT lpRectScroll, LPCRECT lpRectClip, CRgn* prgnUpdate,
1511 LPRECT lpRectUpdate, UINT flags);
1512
1535 void ScrollWindow(int xAmount, int yAmount, LPCRECT lpRect = NULL, LPCRECT lpClipRect = NULL);
1536
1552 void GetScrollRange(int nBar, LPINT lpMinPos, LPINT lpMaxPos) const;
1553
1570 int GetScrollPos(int nBar) const;
1571
1578 void Scroll(int xPos, int yPos);
1579
1587 BOOL EnsureVisibleRow(int nTextRow);
1588
1597 BOOL EnsureVisibleCol(int nDispRow, int nDispCol);
1598
1611 BOOL Create(CWnd* pParent, BOOL bHorzScroll, BOOL bVertScroll,
1612 CXTPSyntaxEditBufferManager* pBuffer = NULL, CCreateContext* lpCS = NULL,
1613 UINT nID = 0);
1614
1615 using CWnd::Create;
1616
1627 void AddRemoveBreakPoint(int nRow);
1628
1639 void AddRemoveBookmark(int nRow);
1640
1651 void CollapseExpandBlock(int nRow);
1652
1658 void DeleteBreakpoint(int nRow);
1659
1665 void DeleteBookmark(int nRow);
1666
1671 void PrevBookmark();
1672
1677 void NextBookmark();
1678
1685 BOOL HasBreakpoints() const;
1686
1693 BOOL HasBookmarks() const;
1694
1707 BOOL HasRowMark(int nRow, const XTP_EDIT_LINEMARKTYPE& lmType,
1708 XTP_EDIT_LMPARAM* pParam = NULL) const;
1709
1716 void CollapseAll();
1717
1724 void ExpandAll();
1725
1732 CStringArray& GetThemes();
1733
1739 void ApplyTheme(CString strTheme);
1740
1747 CString GetCurrentTheme() const;
1748
1756 virtual void RefreshColors();
1757
1763 void InvalidateRow(int nRow);
1764
1771 void InvalidateRows(int nRowFrom = -1, int nRowTo = -1);
1772
1782 BOOL IsRowValid(int nDispRow) const;
1783
1791 void SetRowValid(int nDispRow);
1792
1800 BOOL IsActive() const;
1801
1808 virtual void SetActive(BOOL bIsActive);
1809
1816 BOOL IsCreateScrollbarOnParent() const;
1817
1823 void SetCreateScrollbarOnParent(BOOL nSet);
1824
1831 virtual BOOL CanEditDoc() const;
1832
1839 BOOL IsReadOnly() const;
1840
1847 virtual void SetReadOnly(BOOL bReadOnly = TRUE);
1848
1858 BOOL IsViewOnly() const;
1859
1869 void SetViewOnly(BOOL bViewOnly);
1870
1887 BOOL IsEnabledEditAccelerators() const;
1888
1897 void EnableEditAccelerators(BOOL bEnable);
1898
1899 BOOL HasFocus() const;
1900
1902public:
1903 virtual BOOL PreTranslateMessage(MSG* pMsg);
1904 virtual BOOL PreCreateWindow(CREATESTRUCT& cs);
1905 virtual void PreSubclassWindow();
1906 virtual void OnFinalRelease();
1907
1908 virtual BOOL _InitEditControl();
1909 virtual DWORD ProcessCollapsedRowsBeroreDraw(int nTextRow, int& rnSkipRowsCount);
1910 virtual BOOL _IsVirtualSpaceActive() const;
1911 virtual void _EnsureVisible(int nTextRow, int nDispCol);
1912
1913 virtual BOOL SetValueInt(LPCTSTR lpszValue, int nNewValue, int& nRefValue, BOOL bUpdateReg);
1914 virtual BOOL SetValueBool(LPCTSTR lpszValue, BOOL bNewValue, BOOL& bRefValue, BOOL bUpdateReg);
1915
1916 void SetInternalRowBkColor(int nRow, COLORREF crBack);
1917 void SetInternalRowColor(int nRow, COLORREF crText);
1918
1919protected:
1920 afx_msg void OnPaint();
1921 afx_msg BOOL OnSetCursor(CWnd* pWnd, UINT nHitTest, UINT message);
1922 afx_msg void OnHScroll(UINT nSBCode, UINT nPos, CScrollBar* pScrollBar);
1923 afx_msg void OnVScroll(UINT nSBCode, UINT nPos, CScrollBar* pScrollBar);
1924 afx_msg void OnKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags);
1925 afx_msg void OnSysKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags);
1926 afx_msg void OnChar(UINT nChar, UINT nRepCnt, UINT nFlags);
1927 afx_msg void OnLButtonDown(UINT nFlags, CPoint point);
1928 afx_msg void OnLButtonUp(UINT nFlags, CPoint point);
1929 afx_msg void OnMouseMove(UINT nFlags, CPoint point);
1930 afx_msg BOOL OnMouseWheel(UINT nFlags, short zDelta, CPoint pt);
1931 afx_msg int OnCreate(LPCREATESTRUCT lpCreateStruct);
1932 afx_msg void OnDestroy();
1933 afx_msg void OnSize(UINT nType, int cx, int cy);
1934 afx_msg void OnSetFocus(CWnd* pOldWnd);
1935 afx_msg BOOL OnNcActivate(BOOL bActive);
1936 afx_msg int OnMouseActivate(CWnd* pDesktopWnd, UINT nHitTest, UINT message);
1937 afx_msg void OnKeyUp(UINT nChar, UINT nRepCnt, UINT nFlags);
1938 afx_msg void OnLButtonDblClk(UINT nFlags, CPoint point);
1939 afx_msg void OnRButtonDown(UINT nFlags, CPoint point);
1940 afx_msg void OnRButtonUp(UINT nFlags, CPoint point);
1941 afx_msg BOOL OnEraseBkgnd(CDC* pDC);
1942 afx_msg void OnContextMenu(CWnd* pWnd, CPoint point);
1943 afx_msg void OnTimer(UINT_PTR nIDEvent);
1944 afx_msg void OnKillFocus(CWnd* pNewWnd);
1945 afx_msg void OnShowWindow(BOOL bShow, UINT nStatus);
1946 afx_msg void OnActivate(UINT nState, CWnd* pWndOther, BOOL bMinimized);
1947 afx_msg LRESULT OnSetText(WPARAM wParam, LPARAM lParam);
1948 afx_msg LRESULT OnGetText(WPARAM wBufferSize, LPARAM lpBuffer);
1949 afx_msg LRESULT OnGetTextLen(WPARAM wParam, LPARAM lParam);
1950 afx_msg LRESULT OnGetFont(WPARAM wParam, LPARAM lParam);
1951 afx_msg LRESULT OnSetFont(WPARAM wParam, LPARAM lParam);
1952 afx_msg LRESULT OnInputLanguage(WPARAM wParam, LPARAM lParam);
1953 afx_msg void OnDragCopy();
1954 afx_msg void OnDragMove();
1955 afx_msg UINT OnGetDlgCode();
1956
1957 DECLARE_MESSAGE_MAP()
1961 // Methods
1963
1973 void GetLineNodeRect(int nDispRow, CRect& rcNode, CRect* prcNodeFull = NULL) const;
1974
1980 void CalculateEditbarLength(CDC* pDC = NULL);
1981
1987 void _RecalcScrollBars();
1988
1994 void _RecalcHScrollMaxWidth();
1995
2000 void _UpdateIMEStatus();
2001
2009 void FillTabs(CString& rstrTextToIns, int nDispCol);
2010
2025 BOOL CreateInsertText(LPTSTR szText, CString& strTextToIns, int& iNewRow, int& iNewCol,
2026 int& iNewDispCol, int& iEditRowFrom, int& iEditRowTo,
2027 int& iChainActionCount);
2028
2036 void NotifyEditChanged(int iRowFrom, int iRowTo, UINT nActions);
2037
2044 void NotifyCurRowCol(int nRow, int nCol) const;
2045
2053 virtual LRESULT NotifyParent(UINT uCode) const;
2054
2067 virtual LRESULT NotifyMouseEvent(UINT uCode, UINT nFlags, const CPoint& point) const;
2068
2077 virtual BOOL NotifyMarginLBtnClick(int nRow, int nDispRow) const;
2078
2083 virtual void NotifySelInit() const;
2084
2089 void RecalcHorzScrollPos();
2090
2095 void RecalcVertScrollPos();
2096
2103 void FindWord(UINT nFindWhat);
2104
2122 BOOL FindWordEx(UINT nFindWhat, int nTextRow, int nCol, XTP_EDIT_LINECOL& rlcWordStart,
2123 XTP_EDIT_LINECOL& rlcWordEnd, BOOL& rbOverSpace);
2124
2141 BOOL FindWordEx_str(UINT nFindWhat, XTP_EDIT_LINECOL lcPos_str, XTP_EDIT_LINECOL& rlcWordStart,
2142 XTP_EDIT_LINECOL& rlcWordEnd, BOOL& rbOverSpace);
2143
2162 BOOL MatchText(int nRow, LPCTSTR szLineText, LPCTSTR szMatchText, int nStartPos,
2163 BOOL bMatchWholeWord, BOOL bMatchCase, BOOL bSearchForward, BOOL bRedraw = TRUE);
2164
2171 CWnd* GetEffectiveParent() const;
2172
2182 int CalcValidDispCol(LPCTSTR szText, int iCol) const;
2183
2192 int CalcAbsCol(LPCTSTR szText, int nDispCol) const;
2193
2202 int CalcDispCol(LPCTSTR szText, int nActualCol) const;
2203
2204public:
2213 int CalcAbsCol(int nTextRow, int nDispCol) const;
2214
2223 int CalcDispCol(int nTextRow, int nActualCol) const;
2224
2233 CXTPSyntaxEditLineMarksManager* GetLineMarksManager() const;
2234
2244 void SetRowText(int nRow, LPCTSTR pcszText, BOOL bCanUndo);
2245
2255 void InsertRow(int nRow, LPCTSTR pcszText, BOOL bCanUndo);
2256
2265 void RemoveRow(int nRow, BOOL bCanUndo);
2266
2284 virtual void GetRowColors(int nTextRow, int nColFrom, int nColTo,
2285 const XTP_EDIT_COLORVALUES& clrDefault,
2286 CXTPSyntaxEditTextBlockList* rBlocks);
2287
2298 virtual void GetCollapsableBlocksInfo(int nTextRow,
2299 CXTPSyntaxEditRowsBlockArray& rArBlocks) const;
2300
2301public:
2313 CString GetLineText(int nRow, BOOL bAddCRLF = FALSE, int iCRLFStyle = -1) const;
2325 void GetLineText(int nRow, CString& strBuffer, BOOL bAddCRLF = FALSE,
2326 int iCRLFStyle = -1) const;
2327
2328protected:
2340 int ExpandChars(CDC* pDC, LPCTSTR pszChars, int nCurPos, CString& strBufer);
2341
2353 void ProcessCollapsedText(CDC* pDC, XTP_EDIT_COLLAPSEDBLOCK* pCoDrawBlk, CRect& rcCoBlk);
2354
2370 BOOL ProcessCollapsedTextEx(CDC* pDC, XTP_EDIT_COLLAPSEDBLOCK* pCoDrawBlk,
2371 const XTP_EDIT_TEXTBLOCK& txtBlk, CRect& rcCoBlk);
2372
2384 CString GetCollapsedText(XTP_EDIT_COLLAPSEDBLOCK* pCoDrawBlk, int nMaxLinesCount = 150) const;
2385
2397 XTP_EDIT_COLLAPSEDBLOCK* GetBlockFromPt(const CPoint& ptMouse) const;
2398
2408 void ShowCollapsedToolTip(const CPoint& ptMouse);
2409
2421 int ProcessCollapsedBlockDblClick(const CPoint& ptMouse);
2422
2428 void UpdateScrollPos(DWORD dwUpdate = XTP_EDIT_UPDATE_ALL);
2429
2437 void SetDocModified(BOOL bModified = TRUE);
2438
2446 int CalcMaximumWidth(LPCTSTR szText);
2447
2454 CString GetDefaultCfgFilePath();
2455
2462 void OnBeforeEditChanged(int nRow, int nCol);
2463
2473 void OnEditChanged(int nRowFrom, int nColFrom, int nRowTo, int nColTo, int eEditAction);
2474
2484 void OnEditChanged(const XTP_EDIT_LINECOL& LCFrom, const XTP_EDIT_LINECOL& LCTo,
2485 int eEditAction);
2486
2496 void OnParseEvent(XTP_NOTIFY_CODE code, WPARAM wParam, LPARAM lParam);
2497
2509 BOOL NotifyParseEvent(XTP_NOTIFY_CODE code, WPARAM wParam, LPARAM lParam);
2510
2520 void OnLexCfgWasChanged(XTP_NOTIFY_CODE code, WPARAM wParam, LPARAM lParam);
2521
2530 int GetCurrentDocumentRow() const;
2531
2539 void SetCurrentDocumentRow(int nRow);
2540
2547 int GetCurrentVisibleRow();
2548
2558 int GetDocumentRow(int nVisibleRow);
2559
2568 int CalculateDocumentRow(int nStartDocumentRow, int nRowDelta);
2569
2577 int GetVisibleRow(int nDocumentRow);
2578
2589 int CalculateVisibleRow(int nStartDocumentRow, int nDocumentRow);
2590
2602 int CalculateVisibleRow_(int nStartDocumentRow, int nDocumentRow);
2603
2615 int GetVisibleRowsCount(int nMaxDocRow = -1);
2616
2624 int MoveCurrentVisibleRowUp(int nCount);
2625
2633 int MoveCurrentVisibleRowDown(int nCount);
2634
2644 BOOL ShiftCurrentVisibleRowUp(int nCount, BOOL bChangeCaret = FALSE);
2645
2655 BOOL ShiftCurrentVisibleRowDown(int nCount, BOOL bChangeCaret = FALSE);
2656
2666 BOOL GetCollapsedBlockLen(int nStartRow, int& rnLen) const;
2667
2677 BOOL GetRowNodes(int nRow, DWORD& dwType) const;
2678
2683 virtual void SetAutoCompleteList();
2684
2692 virtual void RefreshLineMarks(XTP_EDIT_NMHDR_EDITCHANGED* pEditChanged);
2693
2698 virtual void RedrawLineMarks();
2699
2709 BOOL DoUndoRedo(int nActionsCount, BOOL bUndoRedo);
2710
2719 BOOL DoChangeSelectionCase(BOOL bUpper);
2720
2729 BOOL DoChangeSelectionTabify(BOOL bTabify);
2730
2737 BOOL GetRegValues();
2738
2747 void UpdateRowInfoInternally(int nTextRow);
2748
2760 virtual DWORD GetAutoscrollDirection(int* pnCols = NULL, int* pnRows = NULL);
2761
2769 XTP_EDIT_LINECOL _SubtractSelSizeFromPos(XTP_EDIT_LINECOL lcDispPos);
2770
2777 virtual void DoAutoIndentIfNeed(int nBaseDocRow, int nDispCol_prev);
2778
2790 virtual void _EnableScrollBarNotify(DWORD dwScrollBar, DWORD dwState);
2791
2792 virtual DROPEFFECT OnDragOver(COleDataObject* pDataObject, DWORD dwKeyState, CPoint point);
2793 virtual BOOL OnDrop(COleDataObject* pDataObject, DROPEFFECT dropEffect, CPoint point);
2794
2795private:
2796 void RedrawScrollBar(int nBar);
2797 void InvalidateAll();
2798
2799protected:
2800 CXTPSyntaxEditOptions* m_pOptions;
2802 // Variables
2804
2805 BOOL m_bVertScrollBarEnabled;
2806 BOOL m_bHorzScrollBarEnabled;
2807
2808 CXTPSyntaxEditRowColorMap m_mapInternalRowBkColor;
2809 CXTPSyntaxEditRowColorMap m_mapInternalRowForeColor;
2811 CXTPNotifySink* m_pSink;
2812
2813 BOOL m_bVertScrollBar;
2814 BOOL m_bHorzScrollBar;
2815 BOOL m_bScrolling;
2816 BOOL m_bCaseSensitive;
2817 BOOL m_bEnableOleDrag;
2818 BOOL m_bIsSmartIndent;
2819 BOOL m_bRightButtonDrag;
2820 BOOL m_bIsScrollingEndRow;
2822 BOOL m_bTokensLoaded;
2823 BOOL m_bDroppable;
2824 BOOL m_bDragging;
2825 BOOL m_bIsDragging;
2827 BOOL m_bPageDirty;
2828 BOOL m_bIsActive;
2829 BOOL m_bFocused;
2830 BOOL m_bCreateScrollbarOnParent;
2832 BOOL m_bAllowExpandCollapse;
2833 BOOL m_bActivateOnFocus;
2836 int m_nTopCalculatedRow;
2838 int m_nBottomCalculatedRow;
2840 int m_nEditbarLength;
2841 int m_nMarginLength;
2842 int m_nLineNumLength;
2843 int m_nNodesWidth;
2845 int m_nInsertTabCount;
2847 int m_nInsertSpaceCount;
2849 int m_nAutoIndentCol;
2850 int m_nTopRow;
2851 int m_nCurrentDocumentRow;
2852 int m_nCurrentCol;
2853 int m_nDispCol;
2854 int m_nWheelScroll;
2855 int m_nAverageLineLen;
2856 int m_nCollapsedTextRowsCount;
2858 DWORD m_dwInsertPos;
2859 DWORD m_dwLastRedrawTime;
2861# ifndef _UNICODE
2862 // DBCS Support (specially for IME)
2863 BYTE m_chPrevLeadByte;
2866# endif
2867
2868 CPoint m_ptDropPos;
2869 CPoint m_ptPrevMouse;
2871 CBitmap m_bmpCache;
2873 CXTPSyntaxEditSelection* m_pSelection;
2879 enum XTPScrolDirection
2880 {
2881 xtpLeft = 0x0001,
2882 xtpRight = 0x0010,
2883 xtpTop = 0x0100,
2884 xtpBottom = 0x1000,
2885 };
2886 DWORD m_dwAutoScrollDirection;
2888 CXTPSyntaxEditBufferManager* m_pBuffer;
2889 CXTPSyntaxEditPaintManager* m_pPaintManeger;
2890 CWnd* m_pParentWnd;
2892 CUIntArray m_arCollapsedTextRows;
2894 CXTPSyntaxEditToolTipCtrl* m_pToolTip;
2895 CXTPSyntaxEditAutoCompleteWnd* m_pAutoComplete;
2897 CString m_strDefaultCfgFilePath;
2899 CString m_strSyntaxScheme;
2900 CString m_strColorScheme;
2902 int m_nHScrollMaxWidth;
2903 BOOL m_bWndCreateInProgress;
2913 XTPSyntaxEditLexAnalyser::CXTPSyntaxEditLexTextBlock* GetOnScreenSch(int nForRow);
2914
2920 void ClearOnScreenSchCache(int nRowFrom);
2921
2932 virtual UINT CalcAveDataSize(int nRowStart, int nRowEnd);
2933
2941 BOOL RegisterWindowClass(HINSTANCE hInstance = NULL);
2942
2947 class CTextSearchCache;
2948
2949 CTextSearchCache* m_fcCollapsable;
2950 CTextSearchCache* m_fcRowColors;
2952 class CScreenSearchBlock;
2953 class CScreenSearchCache;
2954
2955 CScreenSearchCache* m_arOnScreenSchCache;
2956 CByteArray m_arValidDispRows;
2962 class CAverageVal
2963 {
2964 public:
2971 CAverageVal(int nDataSize = 100);
2972
2979 void AddValue(UINT uVal);
2980
2989 UINT GetAverageValue(UINT uDefaultIfNoData = 0);
2990
2991 protected:
2992 int m_nDataSize;
2993 int m_nNextIndex;
2994 CUIntArray m_arData;
2995 };
2996
2997 CAverageVal m_aveRedrawScreenTime;
2999 CXTPSyntaxEditDrawTextProcessor* m_pDrawTextProcessor;
3002 CImmWrapper* m_pImmWrapper;
3003 BOOL m_bIMEsupported;
3005 // for direct assignment (without SynaxEditControl files to read!)
3006 CString m_sIniSet;
3009 BOOL m_bConfigFileMode;
3013 CString m_sPassedIniSet;
3016public:
3017 BOOL m_bDisableRedraw;
3020 BOOL m_bUseMonitor;
3029 BOOL IsConfigFileMode()
3030 {
3031 return m_bConfigFileMode;
3032 }
3033
3040 CString GetSyntaxScheme()
3041 {
3042 return m_strSyntaxScheme;
3043 }
3044
3051 CString GetColorScheme()
3052 {
3053 return m_strColorScheme;
3054 }
3055
3056 CString m_sCustomTitle;
3057 // User-defined app title. Can also be used in Print Job as a unique identifier.
3058
3064 void SetPassedIniSet(CString sPassedIniSet)
3065 {
3066 m_sPassedIniSet = sPassedIniSet;
3067 }
3068
3077 void SetSyntaxAndColorScheme(CString sSyntaxScheme, CString sColorScheme, BOOL bScheme = FALSE,
3078 BOOL bColors = FALSE);
3079
3084 void ReloadSyntaxStringMode();
3085
3090 void ReloadSyntaxConfigFileMode();
3091};
3092
3094
3095AFX_INLINE void CXTPSyntaxEditCtrl::InvalidateRow(int nDispRow)
3096{
3097 InvalidateRows(nDispRow, nDispRow);
3098}
3099AFX_INLINE BOOL CXTPSyntaxEditCtrl::GetAutoIndent() const
3100{
3101 return m_pOptions->m_bAutoIndent;
3102}
3103AFX_INLINE BOOL CXTPSyntaxEditCtrl::GetSyntaxColor() const
3104{
3105 return m_pOptions->m_bSyntaxColor;
3106}
3107AFX_INLINE BOOL CXTPSyntaxEditCtrl::GetSelMargin() const
3108{
3109 return m_pOptions->m_bSelMargin;
3110}
3111AFX_INLINE CXTPSyntaxEditBufferManager* CXTPSyntaxEditCtrl::GetEditBuffer() const
3112{
3113 return m_pBuffer;
3114}
3115AFX_INLINE CXTPSyntaxEditPaintManager* CXTPSyntaxEditCtrl::GetPaintManager() const
3116{
3117 return m_pPaintManeger;
3118}
3119AFX_INLINE BOOL CXTPSyntaxEditCtrl::GetHorzScrollBar() const
3120{
3121 return m_bHorzScrollBar;
3122}
3123AFX_INLINE BOOL CXTPSyntaxEditCtrl::GetVertScrollBar() const
3124{
3125 return m_bVertScrollBar;
3126}
3127AFX_INLINE BOOL CXTPSyntaxEditCtrl::IsActive() const
3128{
3129 return m_bIsActive;
3130}
3131AFX_INLINE BOOL CXTPSyntaxEditCtrl::IsCreateScrollbarOnParent() const
3132{
3133 return m_bCreateScrollbarOnParent;
3134}
3135AFX_INLINE void CXTPSyntaxEditCtrl::SetCreateScrollbarOnParent(BOOL bSet)
3136{
3137 m_bCreateScrollbarOnParent = bSet;
3138}
3139AFX_INLINE BOOL CXTPSyntaxEditCtrl::IsEnabledVirtualSpace() const
3140{
3141 return m_pOptions->m_bVirtualSpace;
3142}
3143AFX_INLINE CXTPSyntaxEditAutoCompleteWnd* CXTPSyntaxEditCtrl::GetAutoCompleteWnd() const
3144{
3145 return m_pAutoComplete;
3146}
3147AFX_INLINE BOOL CXTPSyntaxEditCtrl::IsReadOnly() const
3148{
3149 return m_pOptions->m_bReadOnly;
3150}
3151AFX_INLINE BOOL CXTPSyntaxEditCtrl::GetLineNumbers() const
3152{
3153 return m_pOptions->m_bLineNumbers;
3154}
3155AFX_INLINE void CXTPSyntaxEditCtrl::SetReadOnly(BOOL bReadOnly)
3156{
3157 m_pOptions->m_bReadOnly = bReadOnly;
3158 InvalidateAll();
3159}
3160AFX_INLINE BOOL CXTPSyntaxEditCtrl::IsViewOnly() const
3161{
3162 return m_pOptions->m_bViewOnly;
3163}
3164AFX_INLINE void CXTPSyntaxEditCtrl::SetViewOnly(BOOL bViewOnly)
3165{
3166 m_pOptions->m_bViewOnly = bViewOnly;
3167 m_pOptions->m_bReadOnly = bViewOnly;
3168 m_pOptions->m_bHideCaret = bViewOnly;
3169
3170 InvalidateAll();
3171}
3172AFX_INLINE BOOL CXTPSyntaxEditCtrl::HasFocus() const
3173{
3174 return m_bFocused;
3175}
3176AFX_INLINE BOOL CXTPSyntaxEditCtrl::IsHideCaret() const
3177{
3178 return m_pOptions->m_bHideCaret;
3179}
3180AFX_INLINE void CXTPSyntaxEditCtrl::SetHideCaret(BOOL bHide)
3181{
3182 m_pOptions->m_bHideCaret = bHide;
3183 if (m_hWnd)
3184 Invalidate(FALSE);
3185}
3186AFX_INLINE BOOL CXTPSyntaxEditCtrl::GetCollapsibleNodes() const
3187{
3188 return m_pOptions->m_bDrawNodes;
3189}
3190AFX_INLINE BOOL CXTPSyntaxEditCtrl::IsEnabledEditAccelerators() const
3191{
3192 return m_pOptions->m_bEnableEditAccelerators;
3193}
3194AFX_INLINE void CXTPSyntaxEditCtrl::EnableEditAccelerators(BOOL bEnable)
3195{
3196 m_pOptions->m_bEnableEditAccelerators = bEnable;
3197}
3199AFX_INLINE BOOL CXTPSyntaxEditCtrl::_IsVirtualSpaceActive() const
3200{
3201 BOOL bVirtualSpace = IsEnabledVirtualSpace();
3202 return bVirtualSpace;
3203}
3205AFX_INLINE BOOL CXTPSyntaxEditCtrl::IsEnabledWhiteSpace() const
3206{
3207 return m_pOptions->m_bEnableWhiteSpace;
3208}
3209AFX_INLINE BOOL CXTPSyntaxEditCtrl::GetTabWithSpace() const
3210{
3211 return m_pOptions->m_bTabWithSpace;
3212}
3213AFX_INLINE int CXTPSyntaxEditCtrl::GetTopRow() const
3214{
3215 return m_nTopRow;
3216}
3217AFX_INLINE BOOL CXTPSyntaxEditCtrl::IsRightButtonDrag() const
3218{
3219 return m_bRightButtonDrag;
3220}
3221AFX_INLINE void CXTPSyntaxEditCtrl::CancelRightButtonDrag()
3222{
3223 m_bRightButtonDrag = FALSE;
3224}
3225AFX_INLINE void CXTPSyntaxEditCtrl::SetRightButtonDrag(BOOL bRightButtonDrag)
3226{
3227 m_bRightButtonDrag = bRightButtonDrag;
3228}
3229AFX_INLINE int CXTPSyntaxEditCtrl::GetCurCol() const
3230{
3231 return m_nDispCol;
3232}
3233AFX_INLINE int CXTPSyntaxEditCtrl::GetCurAbsCol() const
3234{
3235 return m_nCurrentCol;
3236}
3237
3239
3240// CXTPSyntaxEditStringDlg dialog
3241
3242class _XTP_EXT_CLASS CXTPSyntaxEditStringDlg : public CDialog
3243{
3245 DECLARE_DYNAMIC(CXTPSyntaxEditStringDlg)
3247public:
3248 CXTPSyntaxEditStringDlg(CWnd* pParent = NULL);
3249 virtual ~CXTPSyntaxEditStringDlg();
3250 CString m_Syntax;
3251
3252protected:
3253 virtual void DoDataExchange(CDataExchange* pDX);
3255 DECLARE_MESSAGE_MAP()
3256 virtual void OnOK();
3257
3258public:
3259 virtual INT_PTR DoModal();
3260 virtual BOOL OnInitDialog();
3261
3262 afx_msg void OnSize(UINT nType, int cx, int cy);
3263 afx_msg void OnEditCut();
3264 afx_msg void OnEditCopy();
3265 afx_msg void OnEditClear();
3266 afx_msg void OnEditPaste();
3267 afx_msg void OnEditUndo();
3268 afx_msg void OnEditSelectAll();
3269 CEdit m_edit;
3270};
3271
3272//{{AFX_INSERT_LOCATION}}
3273// Microsoft Visual C++ will insert additional declarations immediately before the previous line.
3274
3275# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
3277#endif // !defined(__XTPSYNTAXEDITSYNTAXEDITCTRL_H__)
XTPDisableNoisyWarnings.h
XTPSyntaxEditDeletePos
XTPSyntaxEditDeletePos
Edit delete position.
Definition XTPSyntaxEditDefines.h:219
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPSyntaxEditAutoCompleteWnd
This class implements the auto-complete window.
Definition XTPSyntaxEditAutoCompleteWnd.h:87
CXTPSyntaxEditBufferManager
This class is the main class for buffer management.
Definition XTPSyntaxEditBufferManager.h:59
CXTPSyntaxEditCommand
This class represents an abstract Edit Control command interface.
Definition XTPSyntaxEditUndoManager.h:48
CXTPSyntaxEditConfigurationManager
This class manages all configuration parameters of the control.
Definition XTPSyntaxEditLexColorFileReader.h:601
CXTPSyntaxEditCtrl::CAverageVal
CXTPSyntaxEditCtrl::CAverageVal.
Definition XTPSyntaxEditCtrl.h:2963
CXTPSyntaxEditCtrl::CAverageVal::CAverageVal
CAverageVal(int nDataSize=100)
Constructs a CAverageVal object.
CXTPSyntaxEditCtrl::CAverageVal::AddValue
void AddValue(UINT uVal)
Adds a value to the data collection.
CXTPSyntaxEditCtrl::CAverageVal::m_nNextIndex
int m_nNextIndex
Next index.
Definition XTPSyntaxEditCtrl.h:2993
CXTPSyntaxEditCtrl::CAverageVal::m_nDataSize
int m_nDataSize
Data size.
Definition XTPSyntaxEditCtrl.h:2992
CXTPSyntaxEditCtrl::CAverageVal::GetAverageValue
UINT GetAverageValue(UINT uDefaultIfNoData=0)
Gets the average value the data in this object.
CXTPSyntaxEditCtrl::CAverageVal::m_arData
CUIntArray m_arData
Data collection.
Definition XTPSyntaxEditCtrl.h:2994
CXTPSyntaxEditCtrl
This class is the main CWnd-based editor class.
Definition XTPSyntaxEditCtrl.h:114
CXTPSyntaxEditCtrl::UppercaseSelection
BOOL UppercaseSelection()
Converts the selected text to uppercase.
CXTPSyntaxEditCtrl::SetHideCaret
void SetHideCaret(BOOL bHide)
Hides/shows the caret.
Definition XTPSyntaxEditCtrl.h:3180
CXTPSyntaxEditCtrl::SetScrollInfo
BOOL SetScrollInfo(int nBar, LPSCROLLINFO lpScrollInfo, BOOL bRedraw=TRUE)
Sets the information that the SCROLLINFO structure maintains about a specified scroll bar.
CXTPSyntaxEditCtrl::SetCurPos
void SetCurPos(int nTextRow, int nDispCol, BOOL bRemainSelected=FALSE, BOOL bForceVisible=TRUE)
Sets the current cursor position to a specified row and column.
CXTPSyntaxEditCtrl::GetTabSize
int GetTabSize() const
Gets the tab size.
CXTPSyntaxEditCtrl::ClearOnScreenSchCache
void ClearOnScreenSchCache(int nRowFrom)
Clears the screen schema cache.
CXTPSyntaxEditCtrl::SelectAll
void SelectAll()
Selects all text.
CXTPSyntaxEditCtrl::GetUndoTextList
const CStringList & GetUndoTextList()
Gets the list of text for undo operations.
CXTPSyntaxEditCtrl::GetText
BOOL GetText(CMemFile &memFile, int nMaxLen=-1) const
Gets the editor text.
CXTPSyntaxEditCtrl::GetPaintManager
CXTPSyntaxEditPaintManager * GetPaintManager() const
Gets the associated paint manager.
Definition XTPSyntaxEditCtrl.h:3115
CXTPSyntaxEditCtrl::EnableOleDrag
void EnableOleDrag(BOOL bEnableDrag=TRUE)
Enables/disables OLE drag drop mode.
CXTPSyntaxEditCtrl::GetText
CString GetText(int nMaxLen=-1) const
Gets the editor text.
CXTPSyntaxEditCtrl::XTPScrolDirection
XTPScrolDirection
This enum defines flags for auto-scroll direction.
Definition XTPSyntaxEditCtrl.h:2880
CXTPSyntaxEditCtrl::m_bCreateScrollbarOnParent
BOOL m_bCreateScrollbarOnParent
TRUE if parent window scroll bars are used, otherwise FALSE.
Definition XTPSyntaxEditCtrl.h:2830
CXTPSyntaxEditCtrl::Copy
void Copy()
Copies the selected text to the clipboard.
CXTPSyntaxEditCtrl::EnableVirtualSpace
void EnableVirtualSpace(BOOL bEnable, BOOL bUpdateReg=FALSE)
Enables/disables virtual space mode.
CXTPSyntaxEditCtrl::HasBreakpoints
BOOL HasBreakpoints() const
Determines if the current document has breakpoints.
CXTPSyntaxEditCtrl::RepositionBars
void RepositionBars(UINT nIDFirst, UINT nIDLast, UINT nIDLeftOver, UINT nFlag=CWnd::reposDefault, LPRECT lpRectParam=NULL, LPCRECT lpRectClient=NULL, BOOL bStretch=TRUE)
Repositions and resizes control bars in the client area of a window.
CXTPSyntaxEditCtrl::HasRowMark
BOOL HasRowMark(int nRow, const XTP_EDIT_LINEMARKTYPE &lmType, XTP_EDIT_LMPARAM *pParam=NULL) const
Determines if a specified row has a specified mark.
CXTPSyntaxEditCtrl::SetRightButtonDrag
void SetRightButtonDrag(BOOL bRightButtonDrag=TRUE)
Sets right mouse button for dragging.
Definition XTPSyntaxEditCtrl.h:3225
CXTPSyntaxEditCtrl::SetTabWithSpace
BOOL SetTabWithSpace(BOOL bTabWithSpace, BOOL bUpdateReg=FALSE)
Enables/disables replacing tabs with spaces.
CXTPSyntaxEditCtrl::AddRemoveBookmark
void AddRemoveBookmark(int nRow)
Adds/removes a bookmark to/from a specified row.
CXTPSyntaxEditCtrl::SetFontIndirect
void SetFontIndirect(LPLOGFONT pLogfont, BOOL bUpdateReg=FALSE)
Sets the font for the edit control.
CXTPSyntaxEditCtrl::RegisterWindowClass
BOOL RegisterWindowClass(HINSTANCE hInstance=NULL)
Registers the window class if it has not already been registered.
CXTPSyntaxEditCtrl::GetConfigFile
CString GetConfigFile() const
Gets the name of the main configuration file.
CXTPSyntaxEditCtrl::GetAutoIndent
BOOL GetAutoIndent() const
Determines if auto-indentation is enabled/disabled.
Definition XTPSyntaxEditCtrl.h:3099
CXTPSyntaxEditCtrl::m_bVertScrollBar
BOOL m_bVertScrollBar
TRUE if vertical scrollbar is enabled.
Definition XTPSyntaxEditCtrl.h:2813
CXTPSyntaxEditCtrl::m_nTopRow
int m_nTopRow
Top row for display.
Definition XTPSyntaxEditCtrl.h:2850
CXTPSyntaxEditCtrl::ReplaceSel
BOOL ReplaceSel(LPCTSTR szNewText)
Replaces the selected text with specified text.
CXTPSyntaxEditCtrl::GetCurrentTheme
CString GetCurrentTheme() const
Gets the current theme name.
CXTPSyntaxEditCtrl::GetCurAbsCol
int GetCurAbsCol() const
Gets the absolute column position.
Definition XTPSyntaxEditCtrl.h:3233
CXTPSyntaxEditCtrl::m_bmpCache
CBitmap m_bmpCache
Current view cached picture.
Definition XTPSyntaxEditCtrl.h:2871
CXTPSyntaxEditCtrl::CanUndo
BOOL CanUndo() const
Determines if it is possible to perform the undo action.
CXTPSyntaxEditCtrl::m_nHScrollMaxWidth
int m_nHScrollMaxWidth
Maximum horizontal scrollbar position.
Definition XTPSyntaxEditCtrl.h:2902
CXTPSyntaxEditCtrl::GetScrollBarCtrl
virtual CScrollBar * GetScrollBarCtrl(int nBar) const
Retrieves a pointer to a specified sibling scroll bar.
CXTPSyntaxEditCtrl::IsEnabledEditAccelerators
BOOL IsEnabledEditAccelerators() const
Determines if editor accelerators are enabled/disabled.
Definition XTPSyntaxEditCtrl.h:3190
CXTPSyntaxEditCtrl::m_bIMEsupported
BOOL m_bIMEsupported
TRUE if IME is supported, FALSE otherwise.
Definition XTPSyntaxEditCtrl.h:3003
CXTPSyntaxEditCtrl::SetCurCaretPos
void SetCurCaretPos(int nTextRow, int nDispCol, BOOL bRowColNotify=TRUE, BOOL bEnsureVisible=TRUE)
Sets the current caret position to a specified row and column.
CXTPSyntaxEditCtrl::Cut
void Cut()
Copies the selected text to the clipboard and deletes the selected text from the document.
CXTPSyntaxEditCtrl::SetScrollRange
void SetScrollRange(int nBar, int nMinPos, int nMaxPos, BOOL bRedraw=TRUE)
Sets the minimum and maximum position values for a specified scroll bar.
CXTPSyntaxEditCtrl::m_bFocused
BOOL m_bFocused
TRUE if focused.
Definition XTPSyntaxEditCtrl.h:2829
CXTPSyntaxEditCtrl::IncreaseIndent
BOOL IncreaseIndent()
Inserts a tab to the front of the selection.
CXTPSyntaxEditCtrl::GetScrollRange
void GetScrollRange(int nBar, LPINT lpMinPos, LPINT lpMaxPos) const
Gets the range of a specified scroll bar.
CXTPSyntaxEditCtrl::SetSyntaxColor
BOOL SetSyntaxColor(BOOL bSyntaxColor, BOOL bUpdateReg=FALSE)
Enables/disables syntax colorization.
CXTPSyntaxEditCtrl::InsertString
void InsertString(LPCTSTR szText, int iRow, int iCol, BOOL bDeleteSelection=TRUE)
Inserts either a string or a vertical text block at a specified row and column.
CXTPSyntaxEditCtrl::GetSelMargin
BOOL GetSelMargin() const
Determines if the gutter is enabled/disabled.
Definition XTPSyntaxEditCtrl.h:3107
CXTPSyntaxEditCtrl::GetLexConfigurationManager
CXTPSyntaxEditConfigurationManager * GetLexConfigurationManager() const
Gets the associated configuration manager.
CXTPSyntaxEditCtrl::CancelRightButtonDrag
void CancelRightButtonDrag()
Disables mouse right button drag.
Definition XTPSyntaxEditCtrl.h:3221
CXTPSyntaxEditCtrl::Create
BOOL Create(CWnd *pParent, BOOL bHorzScroll, BOOL bVertScroll, CXTPSyntaxEditBufferManager *pBuffer=NULL, CCreateContext *lpCS=NULL, UINT nID=0)
Creates the window.
CXTPSyntaxEditCtrl::m_pToolTip
CXTPSyntaxEditToolTipCtrl * m_pToolTip
Tooltip window for collapsed blocks text.
Definition XTPSyntaxEditCtrl.h:2894
CXTPSyntaxEditCtrl::IsCreateScrollbarOnParent
BOOL IsCreateScrollbarOnParent() const
Determines if scroll bars are created in the parent window.
Definition XTPSyntaxEditCtrl.h:3131
CXTPSyntaxEditCtrl::CanEditDoc
virtual BOOL CanEditDoc() const
Determines if the document can be edited.
CXTPSyntaxEditCtrl::IsRowVisible
BOOL IsRowVisible(int iRow) const
Determines if a specified row is visible.
CXTPSyntaxEditCtrl::ReloadSyntaxConfigFileMode
void ReloadSyntaxConfigFileMode()
Reloads the syntax config file mode.
CXTPSyntaxEditCtrl::IsViewOnly
BOOL IsViewOnly() const
Gets if the editor is in view-only mode.
Definition XTPSyntaxEditCtrl.h:3160
CXTPSyntaxEditCtrl::CalcAveDataSize
virtual UINT CalcAveDataSize(int nRowStart, int nRowEnd)
Calculates the average line length between specified starting and ending rows.
CXTPSyntaxEditCtrl::GetTopRow
int GetTopRow() const
Gets the identifier of the top row of the visible window.
Definition XTPSyntaxEditCtrl.h:3213
CXTPSyntaxEditCtrl::CopyOrMoveText
void CopyOrMoveText(BOOL bCopy)
Copies or moves text after dragging.
CXTPSyntaxEditCtrl::SetConfigFile
BOOL SetConfigFile(LPCTSTR szPath, BOOL bConfigFileMode=TRUE)
Sets the the path to the main configuration file.
CXTPSyntaxEditCtrl::SetReadOnly
virtual void SetReadOnly(BOOL bReadOnly=TRUE)
Sets if the editor should be in read-only mode.
Definition XTPSyntaxEditCtrl.h:3155
CXTPSyntaxEditCtrl::SetRowValid
void SetRowValid(int nDispRow)
Validates a specified row.
CXTPSyntaxEditCtrl::SetActive
virtual void SetActive(BOOL bIsActive)
Activates/deactives the edit control.
CXTPSyntaxEditCtrl::m_bConfigFileMode
BOOL m_bConfigFileMode
TRUE if control read Config file with links to detailed setting (Syntax and Color schemes) FALSE if S...
Definition XTPSyntaxEditCtrl.h:3009
CXTPSyntaxEditCtrl::ScrollWindowEx
int ScrollWindowEx(int dx, int dy, LPCRECT lpRectScroll, LPCRECT lpRectClip, CRgn *prgnUpdate, LPRECT lpRectUpdate, UINT flags)
Scrolls the specified client area with additional features.
CXTPSyntaxEditCtrl::m_pParentWnd
CWnd * m_pParentWnd
Pointer to the parent window.
Definition XTPSyntaxEditCtrl.h:2890
CXTPSyntaxEditCtrl::IsConfigFileMode
BOOL IsConfigFileMode()
Gets the config file mode.
Definition XTPSyntaxEditCtrl.h:3029
CXTPSyntaxEditCtrl::GetSelectionBuffer
HGLOBAL GetSelectionBuffer(UINT nFormat)
Gets the handle of the selection buffer in global memory for a specified clipboard format (either CF_...
CXTPSyntaxEditCtrl::SetScrollBars
BOOL SetScrollBars(BOOL bHorzSBar, BOOL bVertSBar, BOOL bUpdateReg=FALSE)
Enables/disables scrollbars.
CXTPSyntaxEditCtrl::SetRowColor
void SetRowColor(int nRow, COLORREF clrFront)
Sets the text color foreground for a specified row in the colors cache.
CXTPSyntaxEditCtrl::GetRowPerPage
int GetRowPerPage() const
Gets the number of rows that can be printed per page when using the current settings.
CXTPSyntaxEditCtrl::SetCollapsibleNodes
void SetCollapsibleNodes(BOOL bDrawNodes, BOOL bUpdateReg=FALSE)
Enables/disables the collapsible nodes area.
CXTPSyntaxEditCtrl::NextBookmark
void NextBookmark()
Moves the current position to the next bookmark.
CXTPSyntaxEditCtrl::Paste
void Paste()
Pastes from the clipboard to the document.
CXTPSyntaxEditCtrl::m_strSyntaxScheme
CString m_strSyntaxScheme
The syntax scheme.
Definition XTPSyntaxEditCtrl.h:2899
CXTPSyntaxEditCtrl::m_arCollapsedTextRows
CUIntArray m_arCollapsedTextRows
The array of rows with beginning of collapsed blocks.
Definition XTPSyntaxEditCtrl.h:2892
CXTPSyntaxEditCtrl::m_pSelection
CXTPSyntaxEditSelection * m_pSelection
Current selection.
Definition XTPSyntaxEditCtrl.h:2873
CXTPSyntaxEditCtrl::SetSelMargin
BOOL SetSelMargin(BOOL bSelMargin, BOOL bUpdateReg=FALSE)
Enables/disables the gutter.
CXTPSyntaxEditCtrl::SetPaintManager
virtual void SetPaintManager(CXTPSyntaxEditPaintManager *pPaintManager)
Sets the associated paint manager.
CXTPSyntaxEditCtrl::IsSelectionExist
BOOL IsSelectionExist() const
Determines if the selection exists.
CXTPSyntaxEditCtrl::SetRowBkColor
void SetRowBkColor(int nRow, COLORREF crBack)
Sets the background color of a specified row in the colors cache.
CXTPSyntaxEditCtrl::GetRowBkColor
virtual COLORREF GetRowBkColor(int nRow) const
Gets the background color of a specified row in the colors cache.
CXTPSyntaxEditCtrl::InvalidateRows
void InvalidateRows(int nRowFrom=-1, int nRowTo=-1)
Invalidates a specified set of rows.
CXTPSyntaxEditCtrl::m_strColorScheme
CString m_strColorScheme
The color scheme.
Definition XTPSyntaxEditCtrl.h:2900
CXTPSyntaxEditCtrl::GetScrollLimit
int GetScrollLimit(int nBar)
Retrieves the scroll limit of a specified scroll bar.
CXTPSyntaxEditCtrl::RestoreCursor
void RestoreCursor()
Restores the cursor.
CXTPSyntaxEditCtrl::DeleteSelectedLines
void DeleteSelectedLines(int iForceDeleteRow)
Either deletes all lines in the selection or a specified line in the case that no selection exists.
CXTPSyntaxEditCtrl::GetWideCaret
BOOL GetWideCaret() const
Determines if thin caret is set for overwrite mode.
CXTPSyntaxEditCtrl::GetCollapsibleNodes
BOOL GetCollapsibleNodes() const
Determines if the collapsible nodes area is enabled/disabled.
Definition XTPSyntaxEditCtrl.h:3186
CXTPSyntaxEditCtrl::CollapseExpandBlock
void CollapseExpandBlock(int nRow)
Expands/collapses the block at a specified row.
CXTPSyntaxEditCtrl::GetHorzScrollBar
BOOL GetHorzScrollBar() const
Determines if the horizontal scrollbar is enabled/disabled.
Definition XTPSyntaxEditCtrl.h:3119
CXTPSyntaxEditCtrl::GetCurCol
int GetCurCol() const
Gets the current column.
Definition XTPSyntaxEditCtrl.h:3229
CXTPSyntaxEditCtrl::m_nDispCol
int m_nDispCol
Current display column.
Definition XTPSyntaxEditCtrl.h:2853
CXTPSyntaxEditCtrl::ReplaceAll
int ReplaceAll(LPCTSTR szFindText, LPCTSTR szReplaceText, BOOL bMatchWholeWord, BOOL bMatchCase)
Replaces all occurrences of szFindText with szReplaceText.
CXTPSyntaxEditCtrl::m_sIniSet
CString m_sIniSet
String with default or passed type of rules, e.g.
Definition XTPSyntaxEditCtrl.h:3006
CXTPSyntaxEditCtrl::GetRowCount
int GetRowCount() const
Gets the number of rows in the current document.
CXTPSyntaxEditCtrl::IsReadOnly
BOOL IsReadOnly() const
Gets if the editor is in read-only mode.
Definition XTPSyntaxEditCtrl.h:3147
CXTPSyntaxEditCtrl::GetThemes
CStringArray & GetThemes()
Gets the array of available theme names.
CXTPSyntaxEditCtrl::EnsureVisibleRow
BOOL EnsureVisibleRow(int nTextRow)
Ensures the visibility of a specified row.
CXTPSyntaxEditCtrl::SetWideCaret
BOOL SetWideCaret(BOOL bWideCaret, BOOL bUpdateReg=FALSE)
Sets the caret for overwrite mode.
CXTPSyntaxEditCtrl::AddRemoveBreakPoint
void AddRemoveBreakPoint(int nRow)
Adds/removes a breakpoint to/from a specified row.
CXTPSyntaxEditCtrl::GetSelectionText
int GetSelectionText(CString &strText)
Gets the selected text.
CXTPSyntaxEditCtrl::GetTabWithSpace
BOOL GetTabWithSpace() const
Determines if replacing tabs with spaces is enabled/disabled.
Definition XTPSyntaxEditCtrl.h:3209
CXTPSyntaxEditCtrl::GoToRow
void GoToRow(int iRow, BOOL bSelectRow=FALSE)
Moves to a specified row.
CXTPSyntaxEditCtrl::m_nCurrentCol
int m_nCurrentCol
Current absolute column.
Definition XTPSyntaxEditCtrl.h:2852
CXTPSyntaxEditCtrl::IsActive
BOOL IsActive() const
Determines if the edit control is actived/deactivated.
Definition XTPSyntaxEditCtrl.h:3127
CXTPSyntaxEditCtrl::m_aveRedrawScreenTime
CAverageVal m_aveRedrawScreenTime
Redraw screen time.
Definition XTPSyntaxEditCtrl.h:2997
CXTPSyntaxEditCtrl::SetDropPos
void SetDropPos(int iRow, int iCol)
Sets the drop position.
CXTPSyntaxEditCtrl::SetViewOnly
void SetViewOnly(BOOL bViewOnly)
Sets if the editor should be in view-only mode.
Definition XTPSyntaxEditCtrl.h:3164
CXTPSyntaxEditCtrl::m_pAutoComplete
CXTPSyntaxEditAutoCompleteWnd * m_pAutoComplete
Auto-complete pop-up window.
Definition XTPSyntaxEditCtrl.h:2895
CXTPSyntaxEditCtrl::GetLineNumbers
BOOL GetLineNumbers() const
Determines if line numbering is enabled/disabled.
Definition XTPSyntaxEditCtrl.h:3151
CXTPSyntaxEditCtrl::CXTPSyntaxEditCtrl
CXTPSyntaxEditCtrl()
Default object constructor.
CXTPSyntaxEditCtrl::PrintPage
virtual int PrintPage(CDC *pDC, const CRect &rcRect, int nFlags=0)
Prints the edit control page.
CXTPSyntaxEditCtrl::ExpandAll
void ExpandAll()
Expands all collapsed nodes.
CXTPSyntaxEditCtrl::GetVertScrollBar
BOOL GetVertScrollBar() const
Determines if the vertical scrollbar is enabled/disabled.
Definition XTPSyntaxEditCtrl.h:3123
CXTPSyntaxEditCtrl::DeleteBreakpoint
void DeleteBreakpoint(int nRow)
Removes the breakpoint from a specified row.
CXTPSyntaxEditCtrl::DeleteBookmark
void DeleteBookmark(int nRow)
Removes the bookmark from a specified row.
CXTPSyntaxEditCtrl::m_pBuffer
CXTPSyntaxEditBufferManager * m_pBuffer
The buffer manager.
Definition XTPSyntaxEditCtrl.h:2888
CXTPSyntaxEditCtrl::SetTabSize
BOOL SetTabSize(int nTabSize, BOOL bUpdateReg=FALSE)
Sets the tab size.
CXTPSyntaxEditCtrl::CalcEditRects
virtual CRect CalcEditRects(CRect *prcBookMarks=NULL, CRect *prcLineNum=NULL, CRect *prcNodes=NULL, CRect *prcText=NULL, const CRect *prcClient=NULL) const
Calculates the rectangles of the edit control regions.
CXTPSyntaxEditCtrl::IsRowValid
BOOL IsRowValid(int nDispRow) const
Determines if a specified row is valid.
CXTPSyntaxEditCtrl::IsRightButtonDrag
BOOL IsRightButtonDrag() const
Determines if mouse right button drag is enabled/disabled.
Definition XTPSyntaxEditCtrl.h:3217
CXTPSyntaxEditCtrl::GetOnScreenSch
XTPSyntaxEditLexAnalyser::CXTPSyntaxEditLexTextBlock * GetOnScreenSch(int nForRow)
Gets the screen schema cache.
CXTPSyntaxEditCtrl::InsertTextBlock
void InsertTextBlock(LPCTSTR szText, int iRow, int iCol, BOOL bDeleteSelection=TRUE)
Inserts either a string or a vertical text block at a specified row and column.
CXTPSyntaxEditCtrl::m_bHorzScrollBar
BOOL m_bHorzScrollBar
TRUE if horizontal scrollbar is enabled.
Definition XTPSyntaxEditCtrl.h:2814
CXTPSyntaxEditCtrl::m_fcRowColors
CTextSearchCache * m_fcRowColors
Row colors cache.
Definition XTPSyntaxEditCtrl.h:2950
CXTPSyntaxEditCtrl::m_ptDropPos
CPoint m_ptDropPos
Drop position.
Definition XTPSyntaxEditCtrl.h:2868
CXTPSyntaxEditCtrl::SetText
void SetText(LPCTSTR pcszText)
Sets the editor text.
CXTPSyntaxEditCtrl::Find
BOOL Find(LPCTSTR szText, BOOL bMatchWholeWord, BOOL bMatchCase, BOOL bSearchDown, BOOL bRedraw=TRUE, int nStartRow=-1, int nStartCol=-1)
Finds specified text.
CXTPSyntaxEditCtrl::m_bWndCreateInProgress
BOOL m_bWndCreateInProgress
Internal flag to indicate that window creation is in progress.
Definition XTPSyntaxEditCtrl.h:2903
CXTPSyntaxEditCtrl::~CXTPSyntaxEditCtrl
virtual ~CXTPSyntaxEditCtrl()
Destroys a CXTPSyntaxEditCtrl object, handles cleanup and de-allocation.
CXTPSyntaxEditCtrl::InvalidateRow
void InvalidateRow(int nRow)
Invalidates a specified row.
Definition XTPSyntaxEditCtrl.h:3095
CXTPSyntaxEditCtrl::GetSyntaxScheme
CString GetSyntaxScheme()
Gets the syntax scheme.
Definition XTPSyntaxEditCtrl.h:3040
CXTPSyntaxEditCtrl::GetAutoCompleteWnd
CXTPSyntaxEditAutoCompleteWnd * GetAutoCompleteWnd() const
Gets the auto-complete pop-up window.
Definition XTPSyntaxEditCtrl.h:3143
CXTPSyntaxEditCtrl::m_bUseMonitor
BOOL m_bUseMonitor
TRUE if control use special thread to synchronize syntax rules with files with Syntax and Color schem...
Definition XTPSyntaxEditCtrl.h:3020
CXTPSyntaxEditCtrl::m_strDefaultCfgFilePath
CString m_strDefaultCfgFilePath
Configuration file full name.
Definition XTPSyntaxEditCtrl.h:2897
CXTPSyntaxEditCtrl::IsEnabledVirtualSpace
BOOL IsEnabledVirtualSpace() const
Determines if virtual space mode is enabled/disabled.
Definition XTPSyntaxEditCtrl.h:3139
CXTPSyntaxEditCtrl::ApplyTheme
void ApplyTheme(CString strTheme)
Applies a theme with a specified name to the editor.
CXTPSyntaxEditCtrl::RefreshColors
virtual void RefreshColors()
Refreshes the colors for the current document.
CXTPSyntaxEditCtrl::Unselect
void Unselect()
Deselects the previously selected rectangle area.
CXTPSyntaxEditCtrl::ShowHScrollBar
void ShowHScrollBar(BOOL bShow=TRUE)
Shows/hides the horizontal scrollbar.
CXTPSyntaxEditCtrl::GetEditBuffer
CXTPSyntaxEditBufferManager * GetEditBuffer() const
Gets the buffer manager of the smart edit control.
Definition XTPSyntaxEditCtrl.h:3111
CXTPSyntaxEditCtrl::CollapseAll
void CollapseAll()
Collapses all expanded collapsible nodes.
CXTPSyntaxEditCtrl::GetSyntaxColor
BOOL GetSyntaxColor() const
Determines if syntax colorization is enabled/disabled.
Definition XTPSyntaxEditCtrl.h:3103
CXTPSyntaxEditCtrl::m_arValidDispRows
CByteArray m_arValidDispRows
Array with indexes of valid displayed rows.
Definition XTPSyntaxEditCtrl.h:2956
CXTPSyntaxEditCtrl::GetModulePath
static CString AFX_CDECL GetModulePath()
Gets the path of the executable file module.
CXTPSyntaxEditCtrl::m_pImmWrapper
CImmWrapper * m_pImmWrapper
Imm wrapper.
Definition XTPSyntaxEditCtrl.h:3002
CXTPSyntaxEditCtrl::DecreaseIndent
BOOL DecreaseIndent()
Deletes a tab from the front of the selection.
CXTPSyntaxEditCtrl::ReloadSyntaxStringMode
void ReloadSyntaxStringMode()
Reloads the syntax string mode.
CXTPSyntaxEditCtrl::EnableWhiteSpace
void EnableWhiteSpace(BOOL bShow=TRUE)
Enables/disables showing white space.
CXTPSyntaxEditCtrl::SetOverwriteMode
void SetOverwriteMode(BOOL bOverwriteMode)
Enables/disables overwrite mode.
CXTPSyntaxEditCtrl::GetScrollInfo
BOOL GetScrollInfo(int nBar, LPSCROLLINFO lpScrollInfo, UINT nMask=SIF_ALL)
Retrieves the information of a specified scroll bar.
CXTPSyntaxEditCtrl::UnTabifySelection
BOOL UnTabifySelection()
Replaces all tabs with blank spaces.
CXTPSyntaxEditCtrl::RowColFromPoint
BOOL RowColFromPoint(CPoint pt, int *pRow, int *pCol, int *pDispRow=NULL, int *pDispCol=NULL, BOOL bVirtualSpace=-1)
Gets the row and column (not validated) at a specified point.
CXTPSyntaxEditCtrl::GetRedoTextList
const CStringList & GetRedoTextList()
Gets the list of text for redo operations.
CXTPSyntaxEditCtrl::GetColorScheme
CString GetColorScheme()
Gets the color scheme.
Definition XTPSyntaxEditCtrl.h:3051
CXTPSyntaxEditCtrl::RecalcScrollBars
void RecalcScrollBars()
Recalculates and sets the scroll bars and other related areas depending on the text size and current ...
CXTPSyntaxEditCtrl::operator=
const CXTPSyntaxEditCtrl & operator=(const CXTPSyntaxEditCtrl &src)
Copies the control settings from a specified control.
CXTPSyntaxEditCtrl::TabifySelection
BOOL TabifySelection()
Replaces all blank spaces with tabs.
CXTPSyntaxEditCtrl::IsEnabledWhiteSpace
BOOL IsEnabledWhiteSpace() const
Determines if showing white space is enabled/disabled.
Definition XTPSyntaxEditCtrl.h:3205
CXTPSyntaxEditCtrl::Scroll
void Scroll(int xPos, int yPos)
Scrolls the window by the specified offsets along the x- and y- axes.
CXTPSyntaxEditCtrl::DeleteSelection
BOOL DeleteSelection()
Deletes the currently selected text.
CXTPSyntaxEditCtrl::GetRowColor
virtual COLORREF GetRowColor(int nRow) const
Gets the text color foreground of a specified row in the colors cache.
CXTPSyntaxEditCtrl::EnableEditAccelerators
void EnableEditAccelerators(BOOL bEnable)
Enables/disables editor accelerators.
Definition XTPSyntaxEditCtrl.h:3194
CXTPSyntaxEditCtrl::m_sPassedIniSet
CString m_sPassedIniSet
String with passed type of rules, e.g.
Definition XTPSyntaxEditCtrl.h:3013
CXTPSyntaxEditCtrl::Undo
BOOL Undo(int nActionsCount=1)
Performs a undo operation.
CXTPSyntaxEditCtrl::GetScrollPos
int GetScrollPos(int nBar) const
Gets the position of a specified scroll box.
CXTPSyntaxEditCtrl::CanRedo
BOOL CanRedo() const
Determines if it is possible to perform the redo action.
CXTPSyntaxEditCtrl::HasBookmarks
BOOL HasBookmarks() const
Determines if the current document has bookmarks.
CXTPSyntaxEditCtrl::IsHideCaret
BOOL IsHideCaret() const
Determines if the caret is hidden/visible.
Definition XTPSyntaxEditCtrl.h:3176
CXTPSyntaxEditCtrl::GetSelection
CXTPSyntaxEditSelection & GetSelection()
Gets the current selection.
CXTPSyntaxEditCtrl::HandleDrop
void HandleDrop(BOOL bCopy)
Handles the drop operation within the same edit buffer.
CXTPSyntaxEditCtrl::m_dwAutoScrollDirection
DWORD m_dwAutoScrollDirection
Active auto-scroll direction.
Definition XTPSyntaxEditCtrl.h:2886
CXTPSyntaxEditCtrl::PrevBookmark
void PrevBookmark()
Moves the current position to the previous bookmark.
CXTPSyntaxEditCtrl::DeleteBuffer
BOOL DeleteBuffer(int iRowFrom, int iColFrom, int iRowTo, int iColTo, int nFlags=0)
Deletes a specified range of text.
CXTPSyntaxEditCtrl::LowercaseSelection
BOOL LowercaseSelection()
Converts the selected text to lowercase.
CXTPSyntaxEditCtrl::DeleteChar
BOOL DeleteChar(int iRow, int iCol, XTPSyntaxEditDeletePos pos)
Deletes the character at a specified location.
CXTPSyntaxEditCtrl::ShowScrollBar
void ShowScrollBar(UINT nBar, BOOL bShow=TRUE)
Shows/hides a specified scroll bar.
CXTPSyntaxEditCtrl::ShowDefaultContextMenu
void ShowDefaultContextMenu()
Displays the default context menu.
CXTPSyntaxEditCtrl::m_fcCollapsable
CTextSearchCache * m_fcCollapsable
Collapsible rows cache.
Definition XTPSyntaxEditCtrl.h:2949
CXTPSyntaxEditCtrl::m_chPrevLeadByte
BYTE m_chPrevLeadByte
For non-UNICODE version, IME sends double byte chars as 2 messages.
Definition XTPSyntaxEditCtrl.h:2863
CXTPSyntaxEditCtrl::Draw
virtual void Draw(CDC *pDC, const CRect &rcRect)
Draws the edit control client area.
CXTPSyntaxEditCtrl::m_bIsActive
BOOL m_bIsActive
TRUE if the application is active.
Definition XTPSyntaxEditCtrl.h:2828
CXTPSyntaxEditCtrl::EnsureVisibleCol
BOOL EnsureVisibleCol(int nDispRow, int nDispCol)
Ensures the visibility of a specified location.
CXTPSyntaxEditCtrl::ScrollWindow
void ScrollWindow(int xAmount, int yAmount, LPCRECT lpRect=NULL, LPCRECT lpClipRect=NULL)
Scrolls the specified client area.
CXTPSyntaxEditCtrl::m_pDrawTextProcessor
CXTPSyntaxEditDrawTextProcessor * m_pDrawTextProcessor
Pointer to the draw text processor.
Definition XTPSyntaxEditCtrl.h:2999
CXTPSyntaxEditCtrl::m_ptPrevMouse
CPoint m_ptPrevMouse
Mouse position of the previous tip showing.
Definition XTPSyntaxEditCtrl.h:2869
CXTPSyntaxEditCtrl::SetAutoIndent
BOOL SetAutoIndent(BOOL bAutoIndent, BOOL bUpdateReg=FALSE)
Enables/disables auto-indentation.
CXTPSyntaxEditCtrl::m_bDisableRedraw
BOOL m_bDisableRedraw
If TRUE - control window is not redraw, it is draw last window content (draw cached bitmap).
Definition XTPSyntaxEditCtrl.h:3017
CXTPSyntaxEditCtrl::m_pPaintManeger
CXTPSyntaxEditPaintManager * m_pPaintManeger
The paint manager.
Definition XTPSyntaxEditCtrl.h:2889
CXTPSyntaxEditCtrl::SetLineNumbers
BOOL SetLineNumbers(BOOL bLineNumbers, BOOL bUpdateReg=FALSE)
Enables/disables line numbering.
CXTPSyntaxEditCtrl::Redo
BOOL Redo(int nActionsCount=1)
Performs a redo operation.
CXTPSyntaxEditCtrl::SetPassedIniSet
void SetPassedIniSet(CString sPassedIniSet)
Sets the passed ini set.
Definition XTPSyntaxEditCtrl.h:3064
CXTPSyntaxEditCtrl::SetTopRow
void SetTopRow(int iRow)
Sets the top row of the visible window.
CXTPSyntaxEditCtrl::SetScrollPos
int SetScrollPos(int nBar, int nPos, BOOL bRedraw=TRUE)
Sets the current position of a specified scroll box and, if requested, redraws the scroll bar to refl...
CXTPSyntaxEditCtrl::SetCreateScrollbarOnParent
void SetCreateScrollbarOnParent(BOOL nSet)
Sets if scroll bars should be created in the parent window.
Definition XTPSyntaxEditCtrl.h:3135
CXTPSyntaxEditCtrl::GetCurRow
int GetCurRow() const
Gets the current row.
CXTPSyntaxEditCtrl::GetDrawTextProcessor
CXTPSyntaxEditDrawTextProcessor & GetDrawTextProcessor()
Gets the draw text processor.
CXTPSyntaxEditCtrl::m_arOnScreenSchCache
CScreenSearchCache * m_arOnScreenSchCache
On-screen schema cache for this control.
Definition XTPSyntaxEditCtrl.h:2955
CXTPSyntaxEditCtrl::EnableScrollBarCtrl
void EnableScrollBarCtrl(int nBar, BOOL bEnable=TRUE)
Enables/disables the scroll bar.
CXTPSyntaxEditCtrl::SetSyntaxAndColorScheme
void SetSyntaxAndColorScheme(CString sSyntaxScheme, CString sColorScheme, BOOL bScheme=FALSE, BOOL bColors=FALSE)
Sets the syntax and color schemes.
CXTPSyntaxEditCtrl::SelectWord
void SelectWord(CPoint point)
Selects the word at a specified point.
CXTPSyntaxEditCtrl::m_bRightButtonDrag
BOOL m_bRightButtonDrag
TRUE if the user is dragging through right button.
Definition XTPSyntaxEditCtrl.h:2819
CXTPSyntaxEditCtrl::ValidateCol
void ValidateCol(const int nRow, int &nCol, int &nAbsCol)
Validates and sets the row column to a valid one.
CXTPSyntaxEditCtrl::Select
BOOL Select(int nRow1, int nDispCol1, int nRow2, int nDispCol2, BOOL bRedraw=TRUE)
Selects the text bounded by a specified rectangle area.
CXTPSyntaxEditDrawTextProcessor
This helper class is used by CXTPSyntaxEditCtrl as the Draw Text Processor.
Definition XTPSyntaxEditDrawTextProcessor.h:104
CXTPSyntaxEditLineMarksManager
The CXTPSyntaxEditLineMarksManager class provides functionality to manipulate marks on text lines.
Definition XTPSyntaxEditLineMarksManager.h:201
CXTPSyntaxEditOptions
Shared Options of SyntaxEdit.
Definition XTPSyntaxEditCtrl.h:55
CXTPSyntaxEditOptions::m_bAutoIndent
BOOL m_bAutoIndent
TRUE if auto-indentation is enabled, FALSE if disabled.
Definition XTPSyntaxEditCtrl.h:61
CXTPSyntaxEditOptions::m_bEnableEditAccelerators
BOOL m_bEnableEditAccelerators
TRUE if the accelerators for the Cut, Copy, Paste, Undo, Redo, and Select All operations are enabled,...
Definition XTPSyntaxEditCtrl.h:73
CXTPSyntaxEditOptions::m_bSyntaxColor
BOOL m_bSyntaxColor
TRUE if syntax colorization is enabled, FALSE if disabled.
Definition XTPSyntaxEditCtrl.h:60
CXTPSyntaxEditOptions::m_bTabWithSpace
BOOL m_bTabWithSpace
TRUE if tabs are replaced with spaces, FALSE otherwise.
Definition XTPSyntaxEditCtrl.h:65
CXTPSyntaxEditOptions::m_bEnableWhiteSpace
BOOL m_bEnableWhiteSpace
TRUE if white space is shown, otherwise FALSE.
Definition XTPSyntaxEditCtrl.h:69
CXTPSyntaxEditOptions::m_bVirtualSpace
BOOL m_bVirtualSpace
TRUE if virtual space is enabled (i.e.
Definition XTPSyntaxEditCtrl.h:66
CXTPSyntaxEditOptions::m_bHideCaret
BOOL m_bHideCaret
TRUE if the caret is hidden, otherwise FALSE.
Definition XTPSyntaxEditCtrl.h:72
CXTPSyntaxEditOptions::m_bLineNumbers
BOOL m_bLineNumbers
TRUE if line numbers are to be printed, FALSE otherwise.
Definition XTPSyntaxEditCtrl.h:63
CXTPSyntaxEditOptions::m_mapRowForeColor
CXTPSyntaxEditRowColorMap m_mapRowForeColor
Map for row colors.
Definition XTPSyntaxEditCtrl.h:78
CXTPSyntaxEditOptions::m_mapRowBkColor
CXTPSyntaxEditRowColorMap m_mapRowBkColor
Map for row back colors.
Definition XTPSyntaxEditCtrl.h:77
CXTPSyntaxEditOptions::m_bDrawNodes
BOOL m_bDrawNodes
TRUE if collapsible nodes signs are printed, otherwise FALSE.
Definition XTPSyntaxEditCtrl.h:68
CXTPSyntaxEditOptions::m_bSelMargin
BOOL m_bSelMargin
TRUE if selection margin is enabled, FALSE if disabled.
Definition XTPSyntaxEditCtrl.h:62
CXTPSyntaxEditOptions::m_bWideCaret
BOOL m_bWideCaret
Stored Overwrite Caret Style: Thin or Thick.
Definition XTPSyntaxEditCtrl.h:64
CXTPSyntaxEditOptions::m_bReadOnly
BOOL m_bReadOnly
TRUE if in read-only mode, otherwise FALSE.
Definition XTPSyntaxEditCtrl.h:70
CXTPSyntaxEditOptions::m_bViewOnly
BOOL m_bViewOnly
TRUE if in view-only mode, otherwise FALSE.
Definition XTPSyntaxEditCtrl.h:71
CXTPSyntaxEditPaintManager
This class is used by CXTPSyntaxEditCtrl as the paint manager.
Definition XTPSyntaxEditPaintManager.h:47
CXTPSyntaxEditSelection
This class is used to represent syntax edit text selection and allows for selection properties to be ...
Definition XTPSyntaxEditSelection.h:48
CXTPSyntaxEditToolTipCtrl
The CXTPSyntaxEditToolTipCtrl class encapsulates the functionality of a "tip control,...
Definition XTPSyntaxEditToolTipCtrl.h:52
CXTPSyntaxEditView
This class represents a View portion of the Edit Control.
Definition XTPSyntaxEditView.h:89
XTP_EDIT_COLLAPSEDBLOCK
Stores collapsed block parameters.
Definition XTPSyntaxEditStruct.h:244
XTP_EDIT_COLORVALUES
Stores the colors for different phrases.
Definition XTPSyntaxEditStruct.h:197
XTP_EDIT_LINECOL
The XTP_EDIT_LINECOL structure represents the coordinates of text items on the displaying context in ...
Definition XTPSyntaxEditStruct.h:54
XTP_EDIT_NMHDR_EDITCHANGED
Structure to notify "Edit changed" event.
Definition XTPSyntaxEditStruct.h:359
XTP_EDIT_TEXTBLOCK
Summary The XTP_EDIT_TEXTBLOCK structure stores the text blocks after parsing.
Definition XTPSyntaxEditStruct.h:286


Toolkit Pro: Member List

CXTPCalendarDayViewEvent Member List

This is the complete list of members for CXTPCalendarDayViewEvent, including all inherited members.

_MoveRectY(int nYbasePrev, int nYbaseNew, CRect &rRC) | CXTPCalendarViewEvent | static
AddMultiDayEvent_Slave(CXTPCalendarViewEvent *pSlaveView, int nMasterEventPlace) | CXTPCalendarViewEvent | virtual
AdjustLayout(CDC *pDC, const CRect &rcEventMax, int nEventPlaceNumber) | CXTPCalendarDayViewEvent | virtual
AdjustLayout2(CDC *pDC, const CRect &rcEventMax, int nEventPlaceNumber) | CXTPCalendarDayViewEvent | virtual
AdjustMultidayEvent(CRect rcEventMax, int nEventPlaceNumber) | CXTPCalendarViewEvent | protectedvirtual
AdjustSubjectEditor() | CXTPCalendarDayViewEvent | virtual
AdjustSubjectEditorEx(BOOL bUpdateView) | CXTPCalendarDayViewEvent | virtual
CalcIconsRect(CRect rc) | CXTPCalendarViewEvent | virtual
ChangeEventPlace(int nNewPlace) | CXTPCalendarDayViewEvent | protectedvirtual
CXTPCalendarDayViewEvent(CXTPCalendarEvent *pEvent, CXTPCalendarDayViewGroup *pViewGroup) | CXTPCalendarDayViewEvent |
CXTPCalendarViewEvent(CXTPCalendarEvent *pEvent, CXTPCalendarViewGroup *pViewGroup) | CXTPCalendarViewEvent |
CXTPCalendarViewEventT(CXTPCalendarEvent *pEvent, CXTPCalendarDayViewGroup *pViewGroup) | CXTPCalendarViewEventT< CXTPCalendarDayViewGroup > | inline
CXTPCalendarWMHandler() | CXTPCalendarWMHandler |
CXTPCmdTarget() | CXTPCmdTarget |
Draw(CDC *pDC) | CXTPCalendarDayViewEvent | virtual
EndEditSubject() | CXTPCalendarViewEvent | virtual
FormatEventTime(COleDateTime dtTime) const | CXTPCalendarViewEvent | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCalendarControl() const | CXTPCalendarViewEvent | virtual
GetChildHandlerAt(int nIndex) const | CXTPCalendarWMHandler | virtual
GetChildHandlersCount() const | CXTPCalendarWMHandler | virtual
GetEditingSubjectFromEditor() const | CXTPCalendarViewEvent | virtual
GetEndTimeRect() const | CXTPCalendarViewEvent | virtual
GetEvent() const | CXTPCalendarViewEvent | virtual
GetEventPlaceCount() const | CXTPCalendarDayViewEvent |
GetEventPlaceNumber() const | CXTPCalendarViewEvent | virtual
GetEventPlacePos() const | CXTPCalendarDayViewEvent |
GetEventRect() const | CXTPCalendarViewEvent |
GetEventsRect() const | CXTPCalendarDayViewEvent |
GetEventTimelinePlaceNumber() const | CXTPCalendarViewEvent | virtual
GetFirstClockRect() const | CXTPCalendarViewEvent | virtual
GetItemText(DWORD dwItemFlag, LPCTSTR pcszDefaultText=NULL) const | CXTPCalendarViewEvent | virtual
GetItemTextBody() const | CXTPCalendarViewEvent | virtual
GetItemTextEndTime() const | CXTPCalendarViewEvent | virtual
GetItemTextLocation() const | CXTPCalendarViewEvent | virtual
GetItemTextStartTime() const | CXTPCalendarViewEvent | virtual
GetItemTextSubject() const | CXTPCalendarViewEvent | virtual
GetLastClockRect() const | CXTPCalendarViewEvent | virtual
GetMarkupText() const | CXTPCalendarViewEvent | virtual
GetMarkupUIElement() | CXTPCalendarViewEvent | virtual
GetMeetingGlyphRect() const | CXTPCalendarViewEvent | virtual
GetMultiDayEventFlags() const | CXTPCalendarViewEvent | virtual
GetPrivateGlyphRect() const | CXTPCalendarViewEvent | virtual
GetRecurrenceGlyphRect() const | CXTPCalendarViewEvent | virtual
GetReminderGlyphRect() const | CXTPCalendarViewEvent | virtual
GetShowToolTipTimeOut() const | CXTPCalendarViewEvent | virtual
GetSlotNumber() const | CXTPCalendarDayViewEvent |
GetStartTimeRect() const | CXTPCalendarViewEvent | virtual
GetSubjectEditor() const | CXTPCalendarViewEvent | virtual
GetSubjectEditorFont() const | CXTPCalendarDayViewEvent | protectedvirtual
GetSubjectEditorRect() const | CXTPCalendarViewEvent | virtual
GetSubjectEditorStyles() const | CXTPCalendarDayViewEvent | protectedvirtual
GetTextRect() const | CXTPCalendarViewEvent | virtual
GetTimeframeRect() const | CXTPCalendarDayViewEvent |
GetToolText() | CXTPCalendarViewEvent | protectedvirtual
GetViewEventRect() const | CXTPCalendarViewEvent | virtual
GetViewEventRectMax() const | CXTPCalendarViewEvent | virtual
GetViewGroup() const | CXTPCalendarViewEventT< CXTPCalendarDayViewGroup > | inline
GetViewGroup_() const | CXTPCalendarViewEventT< CXTPCalendarDayViewGroup > | inlinevirtual
HideToolTip() | CXTPCalendarViewEvent | virtual
HitTest(CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const | CXTPCalendarViewEvent | virtual
HitTestEx(CPoint point, XTP_CALENDAR_HITTESTINFO *pInfo) const | CXTPCalendarDayViewEvent | virtual
IsEditingSubject() const | CXTPCalendarViewEvent | virtual
IsHideEventTime() const | CXTPCalendarDayViewEvent |
IsMultidayEvent() const | CXTPCalendarDayViewEvent | virtual
IsMultyDayTextAlign() const | CXTPCalendarViewEvent | virtual
IsSelected() const | CXTPCalendarViewEvent | virtual
IsShowingToolTip() | CXTPCalendarViewEvent | virtual
IsTextOutOfBorders() const | CXTPCalendarViewEvent | virtual
IsVisible() const | CXTPCalendarDayViewEvent | virtual
IsVisibleEx(BOOL bCheckTop, BOOL bCheckBottom, BOOL bTopAndBottom) const | CXTPCalendarDayViewEvent | virtual
KillTimer(UINT uTimerID) | CXTPCalendarViewEvent | virtual
m_bHideEventTime | CXTPCalendarDayViewEvent |
m_bMultyDayTextAlign | CXTPCalendarViewEvent | protected
m_bSelected | CXTPCalendarViewEvent | protected
m_bShowArrow | CXTPCalendarDayViewEvent |
m_bTextOutOfBorders | CXTPCalendarViewEvent | protected
m_nEventPlaceNumber | CXTPCalendarViewEvent | protected
m_nEventTimelinePlaceNumber | CXTPCalendarViewEvent | protected
m_nMultiDayEventFlags | CXTPCalendarViewEvent |
m_nTimerID_ShowToolTip | CXTPCalendarViewEvent | protected
m_pMasterView | CXTPCalendarViewEvent | protected
m_pSubjectEditor | CXTPCalendarViewEvent | protected
m_ptrEvent | CXTPCalendarViewEvent | protected
m_pUIElement | CXTPCalendarViewEvent |
m_rcEndTime | CXTPCalendarViewEvent |
m_rcEvent | CXTPCalendarViewEvent |
m_rcEventMax | CXTPCalendarViewEvent |
m_rcFirstClock | CXTPCalendarViewEvent |
m_rcLastClock | CXTPCalendarViewEvent |
m_rcMeetingGlyph | CXTPCalendarViewEvent |
m_rcPrivateGlyph | CXTPCalendarViewEvent |
m_rcRecurrenceGlyph | CXTPCalendarViewEvent |
m_rcReminderGlyph | CXTPCalendarViewEvent |
m_rcStartTime | CXTPCalendarViewEvent |
m_rcSubjectEditor | CXTPCalendarViewEvent |
m_rcText | CXTPCalendarViewEvent |
m_rcTimeframe | CXTPCalendarDayViewEvent |
m_rcToolTip | CXTPCalendarViewEvent |
m_strUIElementText | CXTPCalendarViewEvent |
m_szText | CXTPCalendarViewEvent |
OnBeforeDestroy() | CXTPCalendarViewEvent | virtual
OnChar(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnKeyUp(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnLButtonDblClk(UINT nFlags, CPoint point) | CXTPCalendarViewEvent | virtual
OnLButtonDown(UINT nFlags, CPoint point) | CXTPCalendarViewEvent | virtual
OnLButtonUp(UINT nFlags, CPoint point) | CXTPCalendarViewEvent | virtual
OnMouseMove(UINT nFlags, CPoint point) | CXTPCalendarViewEvent | virtual
OnPostAdjustLayout() | CXTPCalendarDayViewEvent | virtual
OnSysKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnTimer(UINT_PTR uTimerID) | CXTPCalendarViewEvent | virtual
OnWndMsg(UINT message, WPARAM wParam, LPARAM lParam, LRESULT *pResult) | CXTPCalendarViewEvent | virtual
SetEventPlaceCount(int nPlaceCount) | CXTPCalendarDayViewEvent |
SetEventPlacePos(int nPlace) | CXTPCalendarDayViewEvent |
SetMultiDayEvent_MasterSlave(BOOL bMaster, CXTPCalendarViewEvent *pMasterView) | CXTPCalendarViewEvent | virtual
SetSelected(BOOL bSet=TRUE) | CXTPCalendarViewEvent | virtual
SetSlotNumber(int nSlotNumber) | CXTPCalendarDayViewEvent |
SetTextOutOfBorders(BOOL bOutOfBorders) | CXTPCalendarViewEvent | virtual
SetTimer(UINT uTimeOut_ms) | CXTPCalendarViewEvent | virtual
ShowToolTip() | CXTPCalendarViewEvent | virtual
StartEditSubject() | CXTPCalendarDayViewEvent | virtual
TBase typedef | CXTPCalendarDayViewEvent |
~CXTPCalendarDayViewEvent() | CXTPCalendarDayViewEvent | virtual
~CXTPCalendarViewEvent() | CXTPCalendarViewEvent | virtual
~CXTPCalendarViewEventT() | CXTPCalendarViewEventT< CXTPCalendarDayViewGroup > | inlinevirtual


Toolkit Pro: Member List

CXTPDatePickerThemeVisualStudio2019 Member List

This is the complete list of members for CXTPDatePickerThemeVisualStudio2019, including all inherited members.

CalcDayOfWeekRect(CDC *pDC) | CXTPDatePickerPaintManager | virtual
CalcDayRect(CDC *pDC) | CXTPDatePickerPaintManager | virtual
CalcMonthHeaderRect(CDC *pDC) | CXTPDatePickerPaintManager | virtual
CalcMonthRect(CDC *pDC) | CXTPDatePickerPaintManager | virtual
CalcWeekNumbersRect(CDC *pDC) | CXTPDatePickerPaintManager | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPDatePickerPaintManager() | CXTPDatePickerPaintManager |
CXTPDatePickerThemeOffice2013() | CXTPDatePickerThemeOffice2013 |
CXTPDatePickerThemeVisualStudio2019() | CXTPDatePickerThemeVisualStudio2019 |
DrawBackground(CDC *pDC, CRect rcClient) | CXTPDatePickerThemeOffice2013 | virtual
DrawBorder(CDC *pDC, const CXTPDatePickerControl *pControl, CRect &rcClient, BOOL bDraw) | CXTPDatePickerThemeOffice2013 | virtual
DrawButton(CDC *pDC, const CRect &rcButton, const CString &strButton, BOOL bIsDown, BOOL bIsHighLight) | CXTPDatePickerThemeOffice2013 | virtual
DrawDay(CDC *pDC, CXTPDatePickerItemDay *pDay) | CXTPDatePickerThemeOffice2013 | virtual
DrawDaysOfWeek(CDC *pDC, CXTPDatePickerItemMonth *pMonth) | CXTPDatePickerThemeOffice2013 | virtual
DrawMonthHeader(CDC *pDC, CXTPDatePickerItemMonth *pMonth) | CXTPDatePickerPaintManager | virtual
DrawScrollTriangle(CDC *pDC, CRect rcSpot, BOOL bLeftDirection, COLORREF clrColor=0, BOOL bYears=FALSE) | CXTPDatePickerPaintManager | virtual
DrawWeekNumbers(CDC *pDC, CXTPDatePickerItemMonth *pMonth) | CXTPDatePickerThemeOffice2013 | virtual
EnableTheme(BOOL bEnableTheme) | CXTPDatePickerPaintManager | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetButtonFont() | CXTPDatePickerPaintManager |
GetControlBackColor() | CXTPDatePickerPaintManager | virtual
GetCursorBack() | CXTPDatePickerPaintManager | virtual
GetDayBackColor() | CXTPDatePickerPaintManager | virtual
GetDaysOfWeekBackColor() | CXTPDatePickerPaintManager | virtual
GetDaysOfWeekTextColor() | CXTPDatePickerPaintManager | virtual
GetDaysOfWeekTextFont() | CXTPDatePickerPaintManager |
GetDayTextColor() | CXTPDatePickerPaintManager | virtual
GetDayTextFont() | CXTPDatePickerPaintManager | virtual
GetDayTextFontBold() | CXTPDatePickerPaintManager | virtual
GetHeaderTextFont() | CXTPDatePickerPaintManager |
GetHighlightTodayBackColor() | CXTPDatePickerThemeOffice2013 | virtual
GetHighlightTodayBorderColor() | CXTPDatePickerThemeOffice2013 | virtual
GetHighlightTodayColor() | CXTPDatePickerPaintManager | virtual
GetHighlightTodayTextColor() | CXTPDatePickerThemeOffice2013 | virtual
GetListControlBackColor() | CXTPDatePickerPaintManager | virtual
GetListControlTextColor() | CXTPDatePickerPaintManager | virtual
GetListControlTextFont() | CXTPDatePickerPaintManager |
GetMonthHeaderBackColor() | CXTPDatePickerPaintManager | virtual
GetMonthHeaderTextColor() | CXTPDatePickerPaintManager | virtual
GetNonMonthDayBackColor() | CXTPDatePickerPaintManager | virtual
GetNonMonthDayTextColor() | CXTPDatePickerPaintManager | virtual
GetNonMonthDayTextFont() | CXTPDatePickerPaintManager |
GetPaintTheme() const | CXTPDatePickerPaintManager | protected
GetSelectedDayBackColor() | CXTPDatePickerPaintManager | virtual
GetSelectedDayTextColor() | CXTPDatePickerPaintManager | virtual
GetWeekNumbersBackColor() | CXTPDatePickerPaintManager | virtual
GetWeekNumbersTextColor() | CXTPDatePickerPaintManager | virtual
GetWeekNumbersTextFont() | CXTPDatePickerPaintManager |
m_bEnableTheme | CXTPDatePickerPaintManager | protected
m_clr3DFace | CXTPDatePickerPaintManager | protected
m_clr3DLight | CXTPDatePickerPaintManager | protected
m_clr3DShadow | CXTPDatePickerPaintManager | protected
m_clr3DText | CXTPDatePickerPaintManager | protected
m_clrBackground | CXTPDatePickerThemeOffice2013 | protected
m_clrButtonFace | CXTPDatePickerPaintManager |
m_clrButtonText | CXTPDatePickerPaintManager |
m_clrControlBack | CXTPDatePickerPaintManager |
m_clrDayBack | CXTPDatePickerPaintManager |
m_clrDaysOfWeekBack | CXTPDatePickerPaintManager |
m_clrDaysOfWeekText | CXTPDatePickerPaintManager |
m_clrDayText | CXTPDatePickerPaintManager |
m_clrHighlightToday | CXTPDatePickerPaintManager |
m_clrListControlBack | CXTPDatePickerPaintManager |
m_clrListControlText | CXTPDatePickerPaintManager |
m_clrMonthBorder | CXTPDatePickerPaintManager |
m_clrMonthHeaderBack | CXTPDatePickerPaintManager |
m_clrMonthHeaderButton | CXTPDatePickerPaintManager |
m_clrMonthHeaderText | CXTPDatePickerPaintManager |
m_clrNonMonthDayBack | CXTPDatePickerPaintManager |
m_clrNonMonthDayText | CXTPDatePickerPaintManager |
m_clrSelectedDayBack | CXTPDatePickerPaintManager |
m_clrSelectedDayText | CXTPDatePickerPaintManager |
m_clrStaticBorder | CXTPDatePickerPaintManager | protected
m_clrWeekNumbersBack | CXTPDatePickerPaintManager |
m_clrWeekNumbersText | CXTPDatePickerPaintManager |
m_hCursorBack | CXTPDatePickerPaintManager | protected
m_nPaintTheme | CXTPDatePickerPaintManager | protected
m_szDayMargin | CXTPDatePickerPaintManager |
m_themeButton | CXTPDatePickerPaintManager | protected
m_xtpFontButton | CXTPDatePickerPaintManager | protected
m_xtpFontDay | CXTPDatePickerPaintManager | protected
m_xtpFontDayBold | CXTPDatePickerPaintManager | protected
m_xtpFontDaysOfWeek | CXTPDatePickerPaintManager | protected
m_xtpFontHeader | CXTPDatePickerPaintManager | protected
m_xtpFontListControl | CXTPDatePickerPaintManager | protected
m_xtpFontNonMonthDay | CXTPDatePickerPaintManager | protected
m_xtpFontWeekNumbers | CXTPDatePickerPaintManager | protected
RefreshMetrics() | CXTPDatePickerThemeOffice2013 | virtual
SetButtonFont(CFont *fontButton) | CXTPDatePickerPaintManager |
SetButtonFontIndirect(LOGFONT *lFont) | CXTPDatePickerPaintManager |
SetFontIndirect(LOGFONT *lFont) | CXTPDatePickerPaintManager |
Triangle(CDC *pDC, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clrColor=0) | CXTPDatePickerPaintManager | protectedvirtual
~CXTPDatePickerPaintManager() | CXTPDatePickerPaintManager | virtual
~CXTPDatePickerThemeOffice2013() | CXTPDatePickerThemeOffice2013 | virtual
~CXTPDatePickerThemeVisualStudio2019() | CXTPDatePickerThemeVisualStudio2019 | virtual


Toolkit Pro: XTPRibbonGroup.h Source File

  • Source
  • Ribbon
XTPRibbonGroup.h
Go to the documentation of this file.
1
23#if !defined(__XTPRIBBONGROUP_H__)
24# define __XTPRIBBONGROUP_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPRibbonGroups;
34class CXTPRibbonBar;
35class CXTPRibbonTab;
36
37class CXTPControl;
38class CXTPControlPopup;
43enum XTPRibbonGroupReductionLevels
44{
45 xtpRibbonGroupReductionDisabled = 1,
46 xtpRibbonGroupFullCaptionDontHide = 2,
48 xtpRibbonGroupReduceCaptionDontHide = 3,
50 xtpRibbonGroupFullReduction = 4,
51};
52
69class _XTP_EXT_CLASS CXTPRibbonGroup : public CXTPCmdTarget
70{
72 DECLARE_SERIAL(CXTPRibbonGroup)
74public:
79 CXTPRibbonGroup();
80
85 virtual ~CXTPRibbonGroup();
86
87public:
99 void SetCaption(LPCTSTR lpszCaption);
100
113 CString GetCaption() const;
114
121 CXTPCommandBar* GetParent() const;
122
133 virtual void SetRect(CRect rc);
134
146 CRect GetRect() const;
147
158 CRect GetCaptionRect() const;
159
169 CXTPRibbonBar* GetRibbonBar() const;
170
180 CXTPRibbonTab* GetParentTab() const;
181
193 BOOL IsHighlighted() const;
194
205 int IndexOf(CXTPControl* pControl) const;
206
207public:
221 int GetCount() const;
222
242 CXTPControl* Add(XTPControlType controlType, int nId, LPCTSTR lpszParameter = NULL,
243 int nBefore = -1, BOOL bTemporary = FALSE);
244
264 CXTPControl* Add(CXTPControl* pControl, int nId, LPCTSTR lpszParameter = NULL, int nBefore = -1,
265 BOOL bTemporary = FALSE);
266
281 CXTPControl* AddClone(CXTPControl* pControl, int nBefore, BOOL bRecursive = FALSE);
282
294 CXTPControl* InsertAt(CXTPControl* pControl, int nBefore = -1);
295
311 CXTPControl* GetAt(int nIndex) const;
312
324 void RemoveAt(int nIndex);
325
333 void Remove(CXTPControl* pControl);
334
341 void RemoveAll();
342
365 BOOL IsReduced() const;
366
382 void SetIconId(int nId);
383
400 int GetIconId() const;
401
414 void ShowOptionButton(BOOL bShowOptionButton = TRUE);
415
424 BOOL IsOptionButtonVisible() const;
425
434 BOOL IsVisible() const;
435
443 void SetVisible(BOOL bVisible);
444
451 int GetIndex() const;
452
458 virtual void Copy(CXTPRibbonGroup* pGroup);
459
469 CXTPControl* SetControlType(CXTPControl* pControl, XTPControlType type);
470
478 CXTPControl* FindControl(int nId) const;
479
490 CXTPControl* FindControl(XTPControlType type, int nId, BOOL bVisible, BOOL bRecursive) const;
491
502 int GetID() const;
503
511 void SetID(int nId);
512
527 BOOL IsControlsGrouping() const;
528
542 void SetControlsGrouping(BOOL bControlsGrouping = TRUE);
543
549 void SetControlsCentering(BOOL bControlsCentering = TRUE);
550
557 BOOL IsControlsCentering() const;
558
565 virtual void Draw(CDC* pDC, CRect rcClipBox);
566
572 virtual void DoPropExchange(CXTPPropExchange* pPX);
573
583 void AllowReduce(int nAllowReduceLevel = 0);
584
594 int GetAllowReduceLevel() const;
595
602 void SetArrangeEditCaption(BOOL bArrangeEditCaption);
603
604public:
618 CXTPControl* GetControlGroupOption() const;
619
636 CXTPControlPopup* GetControlGroupPopup() const;
637
646 BOOL LoadToolBar(UINT nIDResource, BOOL bLoadIcons = TRUE);
647
658 BOOL SetButtons(UINT* pButtons, int nCount);
659
660 CXTPRibbonGroups* GetGroups() const;
661
662protected:
669 virtual void RepositionControls(CDC* pDC);
670
677 virtual void OnGroupAdded();
678
685 virtual void OnGroupRemoved();
686
696 virtual int GetMinimumWidth(CDC* pDC);
697
698protected:
706 virtual void OnBeforeCalcSize(CDC* pDC);
707
714 virtual void OnAfterCalcSize();
715
725 virtual int OnCalcDynamicSize(CDC* pDC);
726
738 virtual BOOL OnReduceSize(int nLevel, int nWidthAvail);
739
747 virtual BOOL OnExtendSize(int nWidthAvail);
748
750protected:
751 virtual void OnAdjustBorders(int nWidth, CRect rcBorders);
752 void CenterColumn(int nFirstItem, int nLastItem, int nGroupHeight);
753 BOOL OnCmdMsg(UINT nID, int nCode, void* pExtra, AFX_CMDHANDLERINFO* pHandlerInfo);
754
755private:
756 int _CalcSpecialDynamicSize(CDC* pDC);
757 int _WrapSpecialDynamicSize(int nWidth, BOOL bIncludeTail);
758 int _GetSizeSpecialDynamicSize();
759 BOOL _FindBestWrapSpecialDynamicSize();
760 void ArrangeEditCaption();
763protected:
764# ifdef _XTP_COMMANDBARS_ACTIVEX
767 afx_msg long OleGetItemCount();
768 afx_msg int OleGetIndex();
769 afx_msg LPDISPATCH OleGetItem(int nIndex);
770
771 afx_msg LPDISPATCH OleAdd(long controlType, int nId, LPCTSTR strCaption,
772 const VARIANT& varBefore, const VARIANT& varTemporary);
773 afx_msg LPDISPATCH OleGetControlGroupPopup();
774 afx_msg LPDISPATCH OleGetControlGroupOption();
775 afx_msg LPDISPATCH OleGetRibbonBar();
776 afx_msg LPDISPATCH OleGetGroups();
777 DECLARE_PROPERTY(Visible, BOOL);
778 afx_msg void OleAddControl(LPDISPATCH Control, const VARIANT& varBefore);
779
780 DECLARE_DISPATCH_MAP()
781 DECLARE_OLETYPELIB_EX(CXTPRibbonGroup);
782 DECLARE_INTERFACE_MAP()
783 DECLARE_ENUM_VARIANT(CXTPRibbonGroup);
784 void OleGetRect(long* pLeft, long* pTop, long* pRight, long* pBottom);
785
787# endif
788
789protected:
790 BOOL m_bControlsCentering;
791 BOOL m_bControlsGrouping;
792 CString m_strCaption;
793 int m_nIndex;
794 CXTPRibbonGroups* m_pGroups;
795 CRect m_rcGroup;
796 CArray<CXTPControl*, CXTPControl*> m_arrControls;
797 CXTPCommandBar* m_pParent;
798 CXTPRibbonBar* m_pRibbonBar;
799 int m_nId;
800 int m_nIconId;
802 CXTPControl* m_pControlGroupOption;
803 CXTPControlPopup* m_pControlGroupPopup;
804 BOOL m_bReduced;
805 BOOL m_bShowOptionButton;
806 BOOL m_bVisible;
807 int m_nAllowReduce;
809 int m_nRowCount;
811 BOOL m_bAutoArrangeEditCaption;
814private:
815 struct LAYOUTINFO;
816 struct CONTROLINFO;
817 LAYOUTINFO* m_pLayoutInfo;
818
819private:
820 friend class CXTPRibbonGroups;
821 friend class CXTPRibbonBar;
822 friend class CControlGroupPopup;
823 friend class CXTPRibbonGroupPopupToolBar;
824 friend class CXTPRibbonGroupControlPopup;
825};
826
829class _XTP_EXT_CLASS CXTPRibbonGroupOption : public CXTPControlButton
830{
831 DECLARE_XTP_CONTROL(CXTPRibbonGroupOption)
832
833public:
834 CXTPRibbonGroupOption();
835 void Draw(CDC* pDC);
836};
837
838class _XTP_EXT_CLASS CXTPRibbonGroupControlPopup : public CXTPControlPopup
839{
840 DECLARE_XTP_CONTROL(CXTPRibbonGroupControlPopup)
841
842public:
843 CXTPRibbonGroupControlPopup(CXTPRibbonGroup* pGroup = 0);
844
845 virtual CSize GetSize(CDC* pDC);
846 void Draw(CDC* pDC);
847 BOOL IsTransparent() const;
848
849 CXTPRibbonBar* GetRibbonBar() const;
850
851 virtual void Copy(CXTPControl* pControl, BOOL bRecursive = FALSE);
852 virtual void GenerateCommandBarList(DWORD& /*nID*/, CXTPCommandBarList* /*pCommandBarList*/,
853 XTP_COMMANDBARS_PROPEXCHANGE_PARAM* /*pParam*/);
854 virtual void OnLButtonUp(CPoint /*point*/);
855 virtual BOOL IsVisible(DWORD dwSkipFlags = 0) const;
856 virtual BOOL OnSetPopup(BOOL bPopup);
857
858protected:
859 CXTPRibbonGroup* m_pPopupGroup;
860};
861
864AFX_INLINE CString CXTPRibbonGroup::GetCaption() const
865{
866 return m_strCaption;
867}
868
869AFX_INLINE CXTPCommandBar* CXTPRibbonGroup::GetParent() const
870{
871 return m_pParent;
872}
873
874AFX_INLINE CRect CXTPRibbonGroup::GetRect() const
875{
876 return m_rcGroup;
877}
878
879AFX_INLINE CXTPRibbonBar* CXTPRibbonGroup::GetRibbonBar() const
880{
881 return (CXTPRibbonBar*)m_pRibbonBar;
882}
883
884AFX_INLINE int CXTPRibbonGroup::GetCount() const
885{
886 return (int)m_arrControls.GetSize();
887}
888
889AFX_INLINE CXTPControl* CXTPRibbonGroup::GetAt(int nIndex) const
890{
891 return nIndex >= 0 && nIndex < GetCount() ? m_arrControls.GetAt(nIndex) : NULL;
892}
893
894AFX_INLINE int CXTPRibbonGroup::GetID() const
895{
896 return m_nId;
897}
898
899AFX_INLINE CXTPControl* CXTPRibbonGroup::GetControlGroupOption() const
900{
901 return m_pControlGroupOption;
902}
903
904AFX_INLINE CXTPControlPopup* CXTPRibbonGroup::GetControlGroupPopup() const
905{
906 return m_pControlGroupPopup;
907}
908
909AFX_INLINE BOOL CXTPRibbonGroup::IsReduced() const
910{
911 return m_bReduced;
912}
913
914AFX_INLINE void CXTPRibbonGroup::SetIconId(int nId)
915{
916 m_nIconId = nId;
917}
918
919AFX_INLINE int CXTPRibbonGroup::GetIconId() const
920{
921 return m_nIconId <= 0 ? m_nId : m_nIconId;
922}
923
924AFX_INLINE void CXTPRibbonGroup::ShowOptionButton(BOOL bShowOptionButton)
925{
926 m_bShowOptionButton = bShowOptionButton;
927}
928
929AFX_INLINE int CXTPRibbonGroup::GetIndex() const
930{
931 return m_nIndex;
932}
933
934AFX_INLINE BOOL CXTPRibbonGroup::IsControlsGrouping() const
935{
936 return m_bControlsGrouping;
937}
938
939AFX_INLINE void CXTPRibbonGroup::SetControlsGrouping(BOOL bControlsGrouping)
940{
941 m_bControlsGrouping = bControlsGrouping;
942}
943
944AFX_INLINE void CXTPRibbonGroup::SetControlsCentering(BOOL bControlsCentering)
945{
946 m_bControlsCentering = bControlsCentering;
947}
948
949AFX_INLINE BOOL CXTPRibbonGroup::IsControlsCentering() const
950{
951 return m_bControlsCentering;
952}
953
954AFX_INLINE void CXTPRibbonGroup::AllowReduce(int nAllowReduce)
955{
956 m_nAllowReduce = nAllowReduce;
957}
958
959AFX_INLINE int CXTPRibbonGroup::GetAllowReduceLevel() const
960{
961 return m_nAllowReduce;
962}
963
964AFX_INLINE void CXTPRibbonGroup::SetArrangeEditCaption(BOOL bArrangeEditCaption)
965{
966 m_bAutoArrangeEditCaption = bArrangeEditCaption;
967}
968
969AFX_INLINE CXTPRibbonGroups* CXTPRibbonGroup::GetGroups() const
970{
971 return m_pGroups;
972}
973
974# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
976#endif // !defined(__XTPRIBBONGROUP_H__)
XTPControlType
XTPControlType
Type of the control.
Definition XTPCommandBarsDefines.h:111
DECLARE_XTP_CONTROL
#define DECLARE_XTP_CONTROL(class_name)
This macro generates the C++ header code necessary for a CXTPControl-derived class that can be serial...
Definition XTPCommandBarsDefines.h:1169
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPRibbonGroupReductionLevels
XTPRibbonGroupReductionLevels
Defines ribbon group reduction levels.
Definition XTPRibbonGroup.h:44
xtpRibbonGroupReduceCaptionDontHide
@ xtpRibbonGroupReduceCaptionDontHide
Hide captions, but do not allow hiding at all when reduced.
Definition XTPRibbonGroup.h:48
xtpRibbonGroupFullCaptionDontHide
@ xtpRibbonGroupFullCaptionDontHide
Do not hide captions and do not allow hiding at all when reduced.
Definition XTPRibbonGroup.h:46
xtpRibbonGroupFullReduction
@ xtpRibbonGroupFullReduction
Hide captions and allow hiding when reduced.
Definition XTPRibbonGroup.h:50
xtpRibbonGroupReductionDisabled
@ xtpRibbonGroupReductionDisabled
Do not reduce.
Definition XTPRibbonGroup.h:45
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPCommandBar
CXTPCommandBar is a CWnd derived class.
Definition XTPCommandBar.h:66
CXTPCommandBarList
CXTPCommandBarList is a CList derived class.
Definition XTPCommandBarList.h:42
CXTPControlButton
CXTPControlButton is a CXTPControl derived class.
Definition XTPControlButton.h:39
CXTPControl
CXTPControl is a CXTPCmdTarget derived class.
Definition XTPControl.h:841
CXTPControlPopup
CXTPControlPopup is a CXTPControl derived class.
Definition XTPControlPopup.h:42
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72
CXTPRibbonBar
CXTPRibbonBar is a CXTPMenuBar derived class.
Definition XTPRibbonBar.h:69
CXTPRibbonGroup
Represents a single group that is added to a CXTPRibbonTab.
Definition XTPRibbonGroup.h:70
CXTPRibbonGroup::GetControlGroupPopup
CXTPControlPopup * GetControlGroupPopup() const
Retrieves the CXTPControlPopup used to display controls that are not currently visible in the group.
Definition XTPRibbonGroup.h:904
CXTPRibbonGroup::GetCount
int GetCount() const
Gets the total number of CXTPControl objects that have been added to the CXTPRibbonGroup.
Definition XTPRibbonGroup.h:884
CXTPRibbonGroup::DoPropExchange
virtual void DoPropExchange(CXTPPropExchange *pPX)
Reads/writes this object from/to an archive.
CXTPRibbonGroup::IsVisible
BOOL IsVisible() const
Determines if the group is visible.
CXTPRibbonGroup::Copy
virtual void Copy(CXTPRibbonGroup *pGroup)
Copies a parameter from one group to another.
CXTPRibbonGroup::m_bReduced
BOOL m_bReduced
TRUE if group was reduced.
Definition XTPRibbonGroup.h:804
CXTPRibbonGroup::IsControlsCentering
BOOL IsControlsCentering() const
Determines if controls are automatically centered in the group.
Definition XTPRibbonGroup.h:949
CXTPRibbonGroup::IsHighlighted
BOOL IsHighlighted() const
Gets whether the group is currently highlighted.
CXTPRibbonGroup::m_arrControls
CArray< CXTPControl *, CXTPControl * > m_arrControls
Collection of group's controls.
Definition XTPRibbonGroup.h:796
CXTPRibbonGroup::GetIndex
int GetIndex() const
Retrieves the group's own index within the parent group collection.
Definition XTPRibbonGroup.h:929
CXTPRibbonGroup::m_pParent
CXTPCommandBar * m_pParent
Parent ribbon bar.
Definition XTPRibbonGroup.h:797
CXTPRibbonGroup::SetButtons
BOOL SetButtons(UINT *pButtons, int nCount)
Sets the controls from the button array.
CXTPRibbonGroup::GetID
int GetID() const
Gets the group's ID.
Definition XTPRibbonGroup.h:894
CXTPRibbonGroup::ShowOptionButton
void ShowOptionButton(BOOL bShowOptionButton=TRUE)
Specifies whether to display an option button in the group's caption.
Definition XTPRibbonGroup.h:924
CXTPRibbonGroup::~CXTPRibbonGroup
virtual ~CXTPRibbonGroup()
Destroys a CXTPRibbonGroup object, handles cleanup and deallocation.
CXTPRibbonGroup::m_pControlGroupOption
CXTPControl * m_pControlGroupOption
Group option control.
Definition XTPRibbonGroup.h:802
CXTPRibbonGroup::m_nAllowReduce
int m_nAllowReduce
Ribbon group reduction level.
Definition XTPRibbonGroup.h:807
CXTPRibbonGroup::IsControlsGrouping
BOOL IsControlsGrouping() const
Determines if controls grouping is used.
Definition XTPRibbonGroup.h:934
CXTPRibbonGroup::AddClone
CXTPControl * AddClone(CXTPControl *pControl, int nBefore, BOOL bRecursive=FALSE)
Adds a CXTPControl to the ribbon group.
CXTPRibbonGroup::OnGroupAdded
virtual void OnGroupAdded()
This method is called when the group is added.
CXTPRibbonGroup::m_bShowOptionButton
BOOL m_bShowOptionButton
TRUE to show option button.
Definition XTPRibbonGroup.h:805
CXTPRibbonGroup::SetArrangeEditCaption
void SetArrangeEditCaption(BOOL bArrangeEditCaption)
Call this method to specify whether the group will automatically align caption/edit parts.
Definition XTPRibbonGroup.h:964
CXTPRibbonGroup::GetMinimumWidth
virtual int GetMinimumWidth(CDC *pDC)
Calculates the minimum width of the ribbon group.
CXTPRibbonGroup::m_pRibbonBar
CXTPRibbonBar * m_pRibbonBar
Parent ribbon bar.
Definition XTPRibbonGroup.h:798
CXTPRibbonGroup::GetParent
CXTPCommandBar * GetParent() const
Call this member to get the parent command bar.
Definition XTPRibbonGroup.h:869
CXTPRibbonGroup::IsReduced
BOOL IsReduced() const
Determines if the CXTPRibbonGroup is currently displayed as a group button.
Definition XTPRibbonGroup.h:909
CXTPRibbonGroup::OnGroupRemoved
virtual void OnGroupRemoved()
This method is called when the group is removed.
CXTPRibbonGroup::m_bAutoArrangeEditCaption
BOOL m_bAutoArrangeEditCaption
Specifies whether the group will automatically align caption/edit parts.
Definition XTPRibbonGroup.h:811
CXTPRibbonGroup::m_nIndex
int m_nIndex
Index of the group.
Definition XTPRibbonGroup.h:793
CXTPRibbonGroup::SetVisible
void SetVisible(BOOL bVisible)
Call this method to show/hide the group.
CXTPRibbonGroup::SetControlsGrouping
void SetControlsGrouping(BOOL bControlsGrouping=TRUE)
Specifies if controls grouping should be used.
Definition XTPRibbonGroup.h:939
CXTPRibbonGroup::CXTPRibbonGroup
CXTPRibbonGroup()
Constructs a CXTPRibbonGroup object.
CXTPRibbonGroup::GetIconId
int GetIconId() const
Call this member to get the group icon's identifier.
Definition XTPRibbonGroup.h:919
CXTPRibbonGroup::Remove
void Remove(CXTPControl *pControl)
Removes a specified item from the group's collection of items.
CXTPRibbonGroup::IsOptionButtonVisible
BOOL IsOptionButtonVisible() const
Determines if the option button is visible.
CXTPRibbonGroup::SetCaption
void SetCaption(LPCTSTR lpszCaption)
Sets the text to display in the group title bar.
CXTPRibbonGroup::SetID
void SetID(int nId)
Sets the group's ID.
CXTPRibbonGroup::GetControlGroupOption
CXTPControl * GetControlGroupOption() const
Retrieves the CXTPControl that represents the group's OptionButton (used to set tooltip and status ba...
Definition XTPRibbonGroup.h:899
CXTPRibbonGroup::FindControl
CXTPControl * FindControl(int nId) const
Call this member to find the specified control.
CXTPRibbonGroup::AllowReduce
void AllowReduce(int nAllowReduceLevel=0)
Sets the ribbon group reduction level.
Definition XTPRibbonGroup.h:954
CXTPRibbonGroup::SetRect
virtual void SetRect(CRect rc)
Sets the bounding rectangle for the group.
CXTPRibbonGroup::GetCaption
CString GetCaption() const
Gets the text displayed in the group title bar.
Definition XTPRibbonGroup.h:864
CXTPRibbonGroup::m_nIconId
int m_nIconId
Icon index of the group.
Definition XTPRibbonGroup.h:800
CXTPRibbonGroup::RemoveAll
void RemoveAll()
Removes all items from the group.
CXTPRibbonGroup::Draw
virtual void Draw(CDC *pDC, CRect rcClipBox)
Draws the group and all of the controls in the group.
CXTPRibbonGroup::SetControlsCentering
void SetControlsCentering(BOOL bControlsCentering=TRUE)
Specifies if controls should be automatically centered in the group.
Definition XTPRibbonGroup.h:944
CXTPRibbonGroup::m_nRowCount
int m_nRowCount
Total rows number of items.
Definition XTPRibbonGroup.h:809
CXTPRibbonGroup::OnReduceSize
virtual BOOL OnReduceSize(int nLevel, int nWidthAvail)
This method is called to reduce the size of the ribbon group.
CXTPRibbonGroup::m_pControlGroupPopup
CXTPControlPopup * m_pControlGroupPopup
Group popup control.
Definition XTPRibbonGroup.h:803
CXTPRibbonGroup::IndexOf
int IndexOf(CXTPControl *pControl) const
Retrieves the index of a specified CXTPControl object in the CXTPRibbonGroup.
CXTPRibbonGroup::m_bVisible
BOOL m_bVisible
TRUE if group is visible.
Definition XTPRibbonGroup.h:806
CXTPRibbonGroup::m_pGroups
CXTPRibbonGroups * m_pGroups
Parent groups collection.
Definition XTPRibbonGroup.h:794
CXTPRibbonGroup::Add
CXTPControl * Add(CXTPControl *pControl, int nId, LPCTSTR lpszParameter=NULL, int nBefore=-1, BOOL bTemporary=FALSE)
Adds a CXTPControl to the ribbon group.
CXTPRibbonGroup::RepositionControls
virtual void RepositionControls(CDC *pDC)
Called automatically to reposition all controls in the group.
CXTPRibbonGroup::GetParentTab
CXTPRibbonTab * GetParentTab() const
Gets the CXTPRibbonTab object that the CXTPRibbonGroup belongs to.
CXTPRibbonGroup::GetAllowReduceLevel
int GetAllowReduceLevel() const
Gets the ribbon group reduction level.
Definition XTPRibbonGroup.h:959
CXTPRibbonGroup::GetAt
CXTPControl * GetAt(int nIndex) const
Gets the CXTPControl object that has been added to the CXTPRibbonGroup at the specified index.
Definition XTPRibbonGroup.h:889
CXTPRibbonGroup::OnExtendSize
virtual BOOL OnExtendSize(int nWidthAvail)
This method is called to extend the size of the ribbon group.
CXTPRibbonGroup::SetIconId
void SetIconId(int nId)
Call this member to set the group icon's identifier.
Definition XTPRibbonGroup.h:914
CXTPRibbonGroup::SetControlType
CXTPControl * SetControlType(CXTPControl *pControl, XTPControlType type)
Call this member to change the type of the control.
CXTPRibbonGroup::OnBeforeCalcSize
virtual void OnBeforeCalcSize(CDC *pDC)
This method is called before the size of the ribbon group is calculated.
CXTPRibbonGroup::m_bControlsCentering
BOOL m_bControlsCentering
TRUE to center controls inside groups.
Definition XTPRibbonGroup.h:790
CXTPRibbonGroup::GetCaptionRect
CRect GetCaptionRect() const
Gets the bounding rectangle of the group caption.
CXTPRibbonGroup::LoadToolBar
BOOL LoadToolBar(UINT nIDResource, BOOL bLoadIcons=TRUE)
Loads the toolbar specified by nIDResource.
CXTPRibbonGroup::Add
CXTPControl * Add(XTPControlType controlType, int nId, LPCTSTR lpszParameter=NULL, int nBefore=-1, BOOL bTemporary=FALSE)
Adds a CXTPControl to the ribbon group.
CXTPRibbonGroup::GetRibbonBar
CXTPRibbonBar * GetRibbonBar() const
Gets the CXTPRibbonBar object that the CXTPRibbonGroup belongs to.
Definition XTPRibbonGroup.h:879
CXTPRibbonGroup::RemoveAt
void RemoveAt(int nIndex)
Removes the item at a specified index from the group's collection of items.
CXTPRibbonGroup::OnAfterCalcSize
virtual void OnAfterCalcSize()
This method is called after the size of the ribbon group is calculated.
CXTPRibbonGroup::InsertAt
CXTPControl * InsertAt(CXTPControl *pControl, int nBefore=-1)
Adds a CXTPControl to the ribbon group.
CXTPRibbonGroup::GetRect
CRect GetRect() const
Gets the bounding rectangle of the group.
Definition XTPRibbonGroup.h:874
CXTPRibbonGroup::m_bControlsGrouping
BOOL m_bControlsGrouping
TRUE to group controls.
Definition XTPRibbonGroup.h:791
CXTPRibbonGroup::m_rcGroup
CRect m_rcGroup
Bounding rectangle of the group.
Definition XTPRibbonGroup.h:795
CXTPRibbonGroup::OnCalcDynamicSize
virtual int OnCalcDynamicSize(CDC *pDC)
This method is called to retrieve the width of the ribbon group.
CXTPRibbonGroup::FindControl
CXTPControl * FindControl(XTPControlType type, int nId, BOOL bVisible, BOOL bRecursive) const
Call this member to find the specified control.
CXTPRibbonGroup::m_strCaption
CString m_strCaption
Caption of the group.
Definition XTPRibbonGroup.h:792
CXTPRibbonGroup::m_nId
int m_nId
Identifier of the group.
Definition XTPRibbonGroup.h:799
CXTPRibbonGroups
Represents a collection of CXTPRibbonGroup objects.
Definition XTPRibbonGroups.h:51
CXTPRibbonTab
Represents a tab in the Ribbon Bar.
Definition XTPRibbonTab.h:116
XTP_COMMANDBARS_PROPEXCHANGE_PARAM
XTP_COMMANDBARS_PROPEXCHANGE_PARAM is a structure used to store the CommandBar's save settings.
Definition XTPCommandBars.h:88


Toolkit Pro: Member List

CXTPCalendarViewEventT< _TViewGroup > Member List

This is the complete list of members for CXTPCalendarViewEventT< _TViewGroup >, including all inherited members.

_MoveRectY(int nYbasePrev, int nYbaseNew, CRect &rRC) | CXTPCalendarViewEvent | static
AddMultiDayEvent_Slave(CXTPCalendarViewEvent *pSlaveView, int nMasterEventPlace) | CXTPCalendarViewEvent | virtual
AdjustLayout(CDC *pDC, const CRect &rcEventMax, int nEventPlaceNumber) | CXTPCalendarViewEvent | virtual
AdjustLayout2(CDC *pDC, const CRect &rcEventMax, int nEventPlaceNumber)=0 | CXTPCalendarViewEvent | pure virtual
AdjustMultidayEvent(CRect rcEventMax, int nEventPlaceNumber) | CXTPCalendarViewEvent | protectedvirtual
AdjustSubjectEditor() | CXTPCalendarViewEvent | virtual
CalcIconsRect(CRect rc) | CXTPCalendarViewEvent | virtual
ChangeEventPlace(int nNewPlace) | CXTPCalendarViewEvent | virtual
CXTPCalendarViewEvent(CXTPCalendarEvent *pEvent, CXTPCalendarViewGroup *pViewGroup) | CXTPCalendarViewEvent |
CXTPCalendarViewEventT(CXTPCalendarEvent *pEvent, _TViewGroup *pViewGroup) | CXTPCalendarViewEventT< _TViewGroup > | inline
CXTPCalendarWMHandler() | CXTPCalendarWMHandler |
CXTPCmdTarget() | CXTPCmdTarget |
Draw(CDC *pDC)=0 | CXTPCalendarViewEvent | pure virtual
EndEditSubject() | CXTPCalendarViewEvent | virtual
FormatEventTime(COleDateTime dtTime) const | CXTPCalendarViewEvent | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCalendarControl() const | CXTPCalendarViewEvent | virtual
GetChildHandlerAt(int nIndex) const | CXTPCalendarWMHandler | virtual
GetChildHandlersCount() const | CXTPCalendarWMHandler | virtual
GetEditingSubjectFromEditor() const | CXTPCalendarViewEvent | virtual
GetEndTimeRect() const | CXTPCalendarViewEvent | virtual
GetEvent() const | CXTPCalendarViewEvent | virtual
GetEventPlaceNumber() const | CXTPCalendarViewEvent | virtual
GetEventRect() const | CXTPCalendarViewEvent |
GetEventTimelinePlaceNumber() const | CXTPCalendarViewEvent | virtual
GetFirstClockRect() const | CXTPCalendarViewEvent | virtual
GetItemText(DWORD dwItemFlag, LPCTSTR pcszDefaultText=NULL) const | CXTPCalendarViewEvent | virtual
GetItemTextBody() const | CXTPCalendarViewEvent | virtual
GetItemTextEndTime() const | CXTPCalendarViewEvent | virtual
GetItemTextLocation() const | CXTPCalendarViewEvent | virtual
GetItemTextStartTime() const | CXTPCalendarViewEvent | virtual
GetItemTextSubject() const | CXTPCalendarViewEvent | virtual
GetLastClockRect() const | CXTPCalendarViewEvent | virtual
GetMarkupText() const | CXTPCalendarViewEvent | virtual
GetMarkupUIElement() | CXTPCalendarViewEvent | virtual
GetMeetingGlyphRect() const | CXTPCalendarViewEvent | virtual
GetMultiDayEventFlags() const | CXTPCalendarViewEvent | virtual
GetPrivateGlyphRect() const | CXTPCalendarViewEvent | virtual
GetRecurrenceGlyphRect() const | CXTPCalendarViewEvent | virtual
GetReminderGlyphRect() const | CXTPCalendarViewEvent | virtual
GetShowToolTipTimeOut() const | CXTPCalendarViewEvent | virtual
GetStartTimeRect() const | CXTPCalendarViewEvent | virtual
GetSubjectEditor() const | CXTPCalendarViewEvent | virtual
GetSubjectEditorFont() const | CXTPCalendarViewEvent | virtual
GetSubjectEditorRect() const | CXTPCalendarViewEvent | virtual
GetSubjectEditorStyles() const | CXTPCalendarViewEvent | virtual
GetTextRect() const | CXTPCalendarViewEvent | virtual
GetToolText() | CXTPCalendarViewEvent | protectedvirtual
GetViewEventRect() const | CXTPCalendarViewEvent | virtual
GetViewEventRectMax() const | CXTPCalendarViewEvent | virtual
GetViewGroup() const | CXTPCalendarViewEventT< _TViewGroup > | inline
GetViewGroup_() const | CXTPCalendarViewEventT< _TViewGroup > | inlinevirtual
HideToolTip() | CXTPCalendarViewEvent | virtual
HitTest(CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const | CXTPCalendarViewEvent | virtual
HitTestEx(CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const =0 | CXTPCalendarViewEvent | pure virtual
IsEditingSubject() const | CXTPCalendarViewEvent | virtual
IsMultidayEvent() const | CXTPCalendarViewEvent | virtual
IsMultyDayTextAlign() const | CXTPCalendarViewEvent | virtual
IsSelected() const | CXTPCalendarViewEvent | virtual
IsShowingToolTip() | CXTPCalendarViewEvent | virtual
IsTextOutOfBorders() const | CXTPCalendarViewEvent | virtual
IsVisible() const =0 | CXTPCalendarViewEvent | pure virtual
KillTimer(UINT uTimerID) | CXTPCalendarViewEvent | virtual
m_bMultyDayTextAlign | CXTPCalendarViewEvent | protected
m_bSelected | CXTPCalendarViewEvent | protected
m_bTextOutOfBorders | CXTPCalendarViewEvent | protected
m_nEventPlaceNumber | CXTPCalendarViewEvent | protected
m_nEventTimelinePlaceNumber | CXTPCalendarViewEvent | protected
m_nMultiDayEventFlags | CXTPCalendarViewEvent |
m_nTimerID_ShowToolTip | CXTPCalendarViewEvent | protected
m_pMasterView | CXTPCalendarViewEvent | protected
m_pSubjectEditor | CXTPCalendarViewEvent | protected
m_ptrEvent | CXTPCalendarViewEvent | protected
m_pUIElement | CXTPCalendarViewEvent |
m_rcEndTime | CXTPCalendarViewEvent |
m_rcEvent | CXTPCalendarViewEvent |
m_rcEventMax | CXTPCalendarViewEvent |
m_rcFirstClock | CXTPCalendarViewEvent |
m_rcLastClock | CXTPCalendarViewEvent |
m_rcMeetingGlyph | CXTPCalendarViewEvent |
m_rcPrivateGlyph | CXTPCalendarViewEvent |
m_rcRecurrenceGlyph | CXTPCalendarViewEvent |
m_rcReminderGlyph | CXTPCalendarViewEvent |
m_rcStartTime | CXTPCalendarViewEvent |
m_rcSubjectEditor | CXTPCalendarViewEvent |
m_rcText | CXTPCalendarViewEvent |
m_rcToolTip | CXTPCalendarViewEvent |
m_strUIElementText | CXTPCalendarViewEvent |
m_szText | CXTPCalendarViewEvent |
OnBeforeDestroy() | CXTPCalendarViewEvent | virtual
OnChar(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnKeyUp(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnLButtonDblClk(UINT nFlags, CPoint point) | CXTPCalendarViewEvent | virtual
OnLButtonDown(UINT nFlags, CPoint point) | CXTPCalendarViewEvent | virtual
OnLButtonUp(UINT nFlags, CPoint point) | CXTPCalendarViewEvent | virtual
OnMouseMove(UINT nFlags, CPoint point) | CXTPCalendarViewEvent | virtual
OnPostAdjustLayout() | CXTPCalendarViewEvent | virtual
OnSysKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnTimer(UINT_PTR uTimerID) | CXTPCalendarViewEvent | virtual
OnWndMsg(UINT message, WPARAM wParam, LPARAM lParam, LRESULT *pResult) | CXTPCalendarViewEvent | virtual
SetMultiDayEvent_MasterSlave(BOOL bMaster, CXTPCalendarViewEvent *pMasterView) | CXTPCalendarViewEvent | virtual
SetSelected(BOOL bSet=TRUE) | CXTPCalendarViewEvent | virtual
SetTextOutOfBorders(BOOL bOutOfBorders) | CXTPCalendarViewEvent | virtual
SetTimer(UINT uTimeOut_ms) | CXTPCalendarViewEvent | virtual
ShowToolTip() | CXTPCalendarViewEvent | virtual
StartEditSubject() | CXTPCalendarViewEvent | virtual
~CXTPCalendarViewEvent() | CXTPCalendarViewEvent | virtual
~CXTPCalendarViewEventT() | CXTPCalendarViewEventT< _TViewGroup > | inlinevirtual


Toolkit Pro: Member List

CXTPDockingPaneVisualStudio2005Beta2Theme Member List

This is the complete list of members for CXTPDockingPaneVisualStudio2005Beta2Theme, including all inherited members.

AdjustCaptionRect(const CXTPDockingPaneSidePanel *pPane, CRect &rc) | CXTPDockingPanePaintManager | virtual
AdjustCaptionRect(const CXTPDockingPaneTabbedContainer *pPane, CRect &rc) | CXTPDockingPanePaintManager | virtual
AdjustClientRect(CXTPDockingPaneSidePanel *pPane, CRect &rect) | CXTPDockingPanePaintManager | virtual
AdjustClientRect(CXTPDockingPaneTabbedContainer *pPane, CRect &rect, BOOL bApply) | CXTPDockingPanePaintManager | virtual
ClipAndAddEllipsisIfNeeded(CDC *pDC, CString &strTitle, int nCaptionWidth) const | CXTPDockingPanePaintManager | protected
CXTPCmdTarget() | CXTPCmdTarget |
CXTPDockingPaneDefaultTheme() | CXTPDockingPaneDefaultTheme |
CXTPDockingPaneGripperedTheme() | CXTPDockingPaneGripperedTheme |
CXTPDockingPanePaintManager() | CXTPDockingPanePaintManager | protected
CXTPDockingPaneVisualStudio2003Theme() | CXTPDockingPaneVisualStudio2003Theme |
CXTPDockingPaneVisualStudio2005Beta1Theme() | CXTPDockingPaneVisualStudio2005Beta1Theme |
CXTPDockingPaneVisualStudio2005Beta2Theme() | CXTPDockingPaneVisualStudio2005Beta2Theme |
DrawAutoHidePanel(CDC *pDC, CRect rc, XTPDockingPaneDirection direction) | CXTPDockingPanePaintManager | virtual
DrawCaption(CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc) | CXTPDockingPaneGripperedTheme | virtual
DrawCaptionButton(CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton) | CXTPDockingPanePaintManager | virtual
DrawCaptionButtonEntry(CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton, CSize szOffset) | CXTPDockingPanePaintManager | protectedvirtual
DrawCaptionButtonEntry(CDC *pDC, CXTPDockingPaneCaptionButton *pButton, CPoint pt, COLORREF clrButton) | CXTPDockingPanePaintManager | protectedvirtual
DrawCaptionButtons(CDC *pDC, CXTPDockingPaneCaptionButtons *pButtons, CRect &rcCaption, COLORREF clr, int nButtonSize, int nButtonGap, BOOL bVertical=FALSE) | CXTPDockingPanePaintManager | virtual
DrawCaptionPart(CDC *pDC, CXTPDockingPaneBase *pPane, CRect rcCaption, const CString &strTitle, BOOL bActive, BOOL bVertical) | CXTPDockingPaneVisualStudio2003Theme | protectedvirtual
DrawCaptionText(CDC *pDC, const CString &strTitle, CRect rc, BOOL bVertical, BOOL bCalcWidth=FALSE) | CXTPDockingPanePaintManager |
DrawFloatingFrame(CDC *pDC, CXTPDockingPaneMiniWnd *pPane, CRect rc) | CXTPDockingPaneGripperedTheme | virtual
DrawPane(CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc) | CXTPDockingPanePaintManager | virtual
DrawSidePanel(CDC *pDC, CXTPDockingPaneSidePanel *pPane, CRect rc) | CXTPDockingPaneDefaultTheme | virtual
DrawSplitter(CDC *pDC, CXTPDockingPaneSplitterWnd *pSplitter) | CXTPDockingPanePaintManager | virtual
FillCaptionPart(CDC *pDC, CXTPDockingPaneBase *pPane, CRect rcCaption, BOOL bActive, BOOL bVertical) | CXTPDockingPaneVisualStudio2005Beta2Theme | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCaptionButtonStyle() const | CXTPDockingPanePaintManager |
GetCaptionGripperRect(const CXTPDockingPaneTabbedContainer *pPane) | CXTPDockingPanePaintManager | virtual
GetCaptionHeight() const | CXTPDockingPanePaintManager |
GetCaptionRect(const CXTPDockingPaneTabbedContainer *pPane, CRect &rc) | CXTPDockingPanePaintManager | virtual
GetCurrentSystemTheme() const | CXTPDockingPanePaintManager |
GetCustomTitleBrush(BOOL bActive, BOOL bVertical) const | CXTPDockingPanePaintManager |
GetPaneCaptionRect(const CXTPDockingPaneSidePanel *pPane) | CXTPDockingPanePaintManager | virtual
GetPanelPaintManager() const | CXTPDockingPanePaintManager |
GetSplitterStyle() const | CXTPDockingPanePaintManager |
GetTabPaintManager() const | CXTPDockingPanePaintManager |
GetTabsHeight() const | CXTPDockingPanePaintManager |
GetXtremeColor(UINT nIndex) | CXTPDockingPanePaintManager |
Line(CDC *pDC, int x0, int y0, int x1, int y1, int nPen) | CXTPDockingPanePaintManager |
Line(CDC *pDC, int x0, int y0, int x1, int y1) | CXTPDockingPanePaintManager |
m_arrColor | CXTPDockingPanePaintManager | protected
m_bDestroyCustomTitleBrushes | CXTPDockingPanePaintManager | protected
m_bDrawCaptionIcon | CXTPDockingPanePaintManager |
m_bDrawSingleTab | CXTPDockingPanePaintManager |
m_bGradientCaption | CXTPDockingPaneVisualStudio2003Theme | protected
m_bHighlightActiveCaption | CXTPDockingPanePaintManager |
m_bLunaTheme | CXTPDockingPanePaintManager | protected
m_bShowCaption | CXTPDockingPanePaintManager |
m_bUseBoldCaptionFont | CXTPDockingPanePaintManager |
m_bUseOfficeFont | CXTPDockingPanePaintManager | protected
m_bUseStandardFont | CXTPDockingPanePaintManager | protected
m_clrActiveCaption | CXTPDockingPanePaintManager |
m_clrActiveCaptionText | CXTPDockingPanePaintManager |
m_clrBackground | CXTPDockingPanePaintManager |
m_clrCaptionBorder | CXTPDockingPaneVisualStudio2005Beta2Theme | protected
m_clrDisabledCaptionText | CXTPDockingPanePaintManager |
m_clrNormalCaption | CXTPDockingPanePaintManager |
m_clrNormalCaptionText | CXTPDockingPanePaintManager |
m_clrSplitter | CXTPDockingPanePaintManager |
m_clrSplitterGradient | CXTPDockingPanePaintManager |
m_clrSplitterGripper | CXTPDockingPanePaintManager |
m_dwSplitterStyle | CXTPDockingPanePaintManager | protected
m_hbrActiveTitleHorz | CXTPDockingPanePaintManager | protected
m_hbrActiveTitleVert | CXTPDockingPanePaintManager | protected
m_hbrInactiveTitleHorz | CXTPDockingPanePaintManager | protected
m_hbrInactiveTitleVert | CXTPDockingPanePaintManager | protected
m_nCaptionButtonStyle | CXTPDockingPanePaintManager | protected
m_nCaptionFontGap | CXTPDockingPanePaintManager | protected
m_nSplitterIndent | CXTPDockingPanePaintManager |
m_nSplitterSize | CXTPDockingPanePaintManager |
m_nTabsHeight | CXTPDockingPanePaintManager | protected
m_nTitleHeight | CXTPDockingPanePaintManager | protected
m_pPanelPaintManager | CXTPDockingPanePaintManager | protected
m_pTabPaintManager | CXTPDockingPanePaintManager | protected
m_rcCaptionMargin | CXTPDockingPanePaintManager | protected
m_strOfficeFont | CXTPDockingPanePaintManager | protected
m_systemTheme | CXTPDockingPanePaintManager | protected
m_themeButton | CXTPDockingPanePaintManager | protected
m_themeCurrent | CXTPDockingPanePaintManager | protected
m_themeExplorer | CXTPDockingPanePaintManager | protected
m_themeRebar | CXTPDockingPanePaintManager | protected
m_themeToolbar | CXTPDockingPanePaintManager | protected
m_themeWindow | CXTPDockingPanePaintManager | protected
m_xtpFontTitle | CXTPDockingPanePaintManager | protected
m_xtpFontTitleVertical | CXTPDockingPanePaintManager | protected
Pixel(CDC *pDC, int xPos, int yPos, int nPen) | CXTPDockingPanePaintManager |
Rectangle(CDC *pDC, CRect rc, int nPenEntry, int nPenBorder) | CXTPDockingPanePaintManager |
RefreshMetrics() | CXTPDockingPaneVisualStudio2005Beta2Theme | virtual
SetCaptionButtonStyle(XTPDockingPaneCaptionButtonStyle nStyle) | CXTPDockingPanePaintManager |
SetCaptionFontIndirect(LOGFONT *pLogFont, BOOL bUseStandardFont=FALSE) | CXTPDockingPanePaintManager |
SetColors(int cElements, CONST INT *lpaElements, CONST COLORREF *lpaRgbValues) | CXTPDockingPanePaintManager |
SetCustomTitleBrushes(HBRUSH hbrActiveTitleHorz, HBRUSH hbrInactiveTitleHorz=NULL, HBRUSH hbrActiveTitleVert=NULL, HBRUSH hbrInactiveTitleVert=NULL, BOOL bDestroyOnCleanup=FALSE) | CXTPDockingPanePaintManager |
SetLunaTheme(XTPCurrentSystemTheme systemTheme) | CXTPDockingPanePaintManager |
SetPanelPaintManager(CXTPTabPaintManager *pManager) | CXTPDockingPanePaintManager |
SetSplitterStyle(DWORD dwStyle) | CXTPDockingPanePaintManager |
SetTabPaintManager(CXTPTabPaintManager *pManager) | CXTPDockingPanePaintManager |
UseOfficeFont(BOOL bUseOfficeFont) | CXTPDockingPanePaintManager |
~CXTPDockingPanePaintManager() | CXTPDockingPanePaintManager | protectedvirtual


Toolkit Pro: Member List

XTP_EVENT_PASTE_OPERATION_PARAMS Member List

This is the complete list of members for XTP_EVENT_PASTE_OPERATION_PARAMS, including all inherited members.

bPasteWillChangeExistingEvent | XTP_EVENT_PASTE_OPERATION_PARAMS
eOperation | XTP_EVENT_EDIT_OPERATION_PARAMS
nRefCounter | XTP_EVENT_EDIT_OPERATION_PARAMS
pEvent | XTP_EVENT_PASTE_OPERATION_PARAMS
pEventViews | XTP_EVENT_EDIT_OPERATION_PARAMS


Toolkit Pro: XTPMarkupButton.h Source File

  • Source
  • Markup
  • Controls
XTPMarkupButton.h
Go to the documentation of this file.
1
23#if !defined(__XTPMARKUPBUTTON_H__)
24# define __XTPMARKUPBUTTON_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPMarkupBrush;
34class CXTPMarkupBuilder;
35class CXTPWinThemeWrapper;
36
42class _XTP_EXT_CLASS CXTPMarkupButton : public CXTPMarkupButtonBase
43{
45 DECLARE_MARKUPCLASS(CXTPMarkupButton);
47protected:
52 CXTPMarkupButton();
53
58 virtual ~CXTPMarkupButton();
59
60protected:
62 // Implementation
63 void OnRender(CXTPMarkupDrawingContext* pDC);
64 void OnRenderFocusVisual(CXTPMarkupDrawingContext* drawingContext);
65 CSize ArrangeOverride(CSize szFinalSize);
66 CSize MeasureOverride(CXTPMarkupDrawingContext* pDC, CSize szAvailableSize);
70public:
71 DECLARE_DISPATCH_MAP()
72# ifdef _XTP_ACTIVEX
73 DECLARE_INTERFACE_MAP()
74 DECLARE_OLETYPELIB_EX(CXTPMarkupButton);
75# endif
76
78};
79
80# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
82#endif // !defined(__XTPMARKUPBUTTON_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPMarkupButtonBase
CXTPMarkupButtonBase is a CXTPMarkupContentControl derived class.
Definition XTPMarkupButtonBase.h:46
CXTPMarkupButton
CXTPMarkupButton is a CXTPMarkupButtonBase derived class.
Definition XTPMarkupButton.h:43
CXTPMarkupButton::CXTPMarkupButton
CXTPMarkupButton()
Constructs a CXTPMarkupButton object.
CXTPMarkupButton::~CXTPMarkupButton
virtual ~CXTPMarkupButton()
Destroys a CXTPMarkupButton object, handles cleanup and deallocation.
CXTPMarkupVisual::OnRender
virtual void OnRender(CXTPMarkupDrawingContext *drawingContext)
When overridden in a derived class, participates in rendering operations that are directed by the lay...
Definition XTPMarkupInputElement.h:515
CXTPMarkupVisual::OnRenderFocusVisual
virtual void OnRenderFocusVisual(CXTPMarkupDrawingContext *drawingContext)
This method is called to render the focus rectangle of a focused object.
Definition XTPMarkupInputElement.h:519
CXTPWinThemeWrapper
The CXTPWinThemeWrapper class wraps the UxTheme.dll visual theme API.
Definition XTPWinThemeWrapper.h:188


Toolkit Pro: XTPChartRadarLineSeriesView.h Source File

  • Source
  • Chart
  • Styles
  • Radar
XTPChartRadarLineSeriesView.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTRADARLINESERIESVIEW_H__)
24# define __XTPCHARTRADARLINESERIESVIEW_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartSeriesView;
34class CXTPChartMarker;
35
41class _XTP_EXT_CLASS CXTPChartRadarLineSeriesView : public CXTPChartRadarDiagramSeriesView
42{
43public:
51 CXTPChartRadarLineSeriesView(CXTPChartSeries* pSeries, CXTPChartDiagramView* pDiagramView);
52
53protected:
65 CXTPChartSeriesPointView* CreateSeriesPointView(CXTPChartDeviceContext* pDC,
66 CXTPChartSeriesPoint* pPoint,
67 CXTPChartElementView* pParentView);
68
81 virtual CXTPChartDeviceCommand* CreateDeviceCommand(CXTPChartDeviceContext* pDC);
82
93 virtual CXTPChartDeviceCommand* CreateLegendDeviceCommand(CXTPChartDeviceContext* pDC,
94 CRect rcBounds);
95};
97# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
98#endif //#if !defined(__XTPCHARTRADARLINESERIESVIEW_H__)
pPoint
const CPoint * pPoint
return 0 or xtpCalendarHitTestDayExpandButton
Definition XTPCalendarThemeOffice2007.h:150
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartDiagramView
This class represents the view of a chart diagram, which is a kind of CXTPChartElementView.
Definition XTPChartDiagramView.h:49
CXTPChartElementView
This class represents the view of a chart element.
Definition XTPChartElementView.h:47
CXTPChartMarker
This class abstracts a marker used in marking the points in a point series style chart.
Definition XTPChartMarker.h:64
CXTPChartRadarLineSeriesView
This class represents the view of a point series, which is a kind of CXTPChartSeriesView.
Definition XTPChartRadarLineSeriesView.h:42
CXTPChartRadarLineSeriesView::CreateDeviceCommand
virtual CXTPChartDeviceCommand * CreateDeviceCommand(CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
CXTPChartRadarLineSeriesView::CreateLegendDeviceCommand
virtual CXTPChartDeviceCommand * CreateLegendDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcBounds)
This function creates a label view drawing command object.
CXTPChartRadarLineSeriesView::CreateSeriesPointView
CXTPChartSeriesPointView * CreateSeriesPointView(CXTPChartDeviceContext *pDC, CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Call this function to create the view of the series points.
CXTPChartRadarLineSeriesView::CXTPChartRadarLineSeriesView
CXTPChartRadarLineSeriesView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Constructs a CXTPChartPointSeriesView object.
CXTPChartSeries
This class represents a series in the chart, which is a kind of CXTPChartElement.
Definition XTPChartSeries.h:50
CXTPChartSeriesPoint
CXTPChartSeriesPoint is a kind of CXTPChartElement.
Definition XTPChartSeriesPoint.h:43
CXTPChartSeriesPointView
Represents chart series point view.
Definition XTPChartSeriesPointView.h:48


Toolkit Pro: XTPMarkupInline.h Source File

  • Source
  • Markup
  • Text
XTPMarkupInline.h
Go to the documentation of this file.
1
23#if !defined(__XTPMARKUPINLINE_H__)
24# define __XTPMARKUPINLINE_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33# define MARKUP_POSITION_EOF (POSITION)(-1)
34# define MARKUP_POSITION_START (POSITION)(0)
35# define MARKUP_POSITION_END (POSITION)(1)
36
37class CXTPMarkupDependencyProperty;
38class CXTPMarkupTextBlock;
39class CXTPMarkupDrawingContext;
40class CXTPMarkupInline;
41struct XTPMarkupFontMetrics;
42
43class _XTP_EXT_CLASS CXTPMarkupInline : public CXTPMarkupTextElement
44{
46 DECLARE_MARKUPCLASS(CXTPMarkupInline)
48protected:
49 CXTPMarkupInline();
50 virtual ~CXTPMarkupInline();
51
52public:
53 virtual CXTPMarkupInline* GetFirstInline() const;
54 CXTPMarkupInline* GetNextInline() const;
55
56public:
57 XTPMarkupBaselineAlignment GetBaselineAlignment() const;
58 void SetBaselineAlignment(XTPMarkupBaselineAlignment nBaselineAlignment);
59
60public:
61 virtual POSITION GetContentStartPosition() const;
62 virtual void GetContentNextPosition(POSITION& pos) const;
63 virtual BOOL IsWordBreakPosition(POSITION pos) const;
64 virtual BOOL IsLineBreakPosition(POSITION pos) const;
65 virtual BOOL IsCaretReturnPosition(POSITION pos) const;
66 virtual BOOL IsWhiteSpacePosition(POSITION pos) const;
67
68 virtual void Arrange(CRect rcFinalRect, POSITION posStart, POSITION posEnd);
69 virtual CSize Measure(CXTPMarkupDrawingContext* pDC, POSITION posStart, POSITION posEnd);
70 virtual void Measure(CXTPMarkupDrawingContext* pDC, POSITION posStart, POSITION posEnd,
71 CXTPSizeF& size);
72 virtual void Render(CXTPMarkupDrawingContext* pDC, CRect rc, POSITION posStart,
73 POSITION posEnd);
74
75 virtual void PrepareMeasure(CXTPMarkupDrawingContext* pDC);
76
77 virtual int GetBaseline() const;
78 virtual const XTPMarkupFontMetrics* GetFontMetrics() const;
79
80 CXTPMarkupTextBlock* GetTextBlock() const;
81
83public:
84 DECLARE_DISPATCH_MAP()
85# ifdef _XTP_ACTIVEX
86 DECLARE_INTERFACE_MAP()
87 DECLARE_OLETYPELIB_EX(CXTPMarkupInline);
88# endif
89
90 afx_msg int OleGetBaselineAlignment();
91 afx_msg void OleSetBaselineAlignment(int nValue);
94protected:
95 int m_nIndex;
96
97public:
98 static CXTPMarkupDependencyProperty* m_pBaselineAlignmentProperty;
99
100private:
101 friend class CXTPMarkupInlineCollection;
102};
103
104# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
106#endif // !defined(__XTPMARKUPINLINE_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPMarkupTextBlock
CXTPMarkupTextBlock is a CXTPMarkupFrameworkElement derived class.
Definition XTPMarkupTextBlock.h:86
CXTPSizeT
This class incapsulates size data.
Definition XTPSize.h:40


Toolkit Pro: Member List

CXTPStatusBarProgressPane Member List

This is the complete list of members for CXTPStatusBarProgressPane, including all inherited members.

BestFit() | CXTPStatusBarPane |
CXTPCmdTarget() | CXTPCmdTarget |
CXTPProgressBase() | CXTPProgressBase |
CXTPStatusBarPane() | CXTPStatusBarPane |
CXTPStatusBarProgressPane() | CXTPStatusBarProgressPane |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetBackgroundColor() const | CXTPStatusBarPane |
GetBeginGroup() const | CXTPStatusBarPane |
GetBestFit() | CXTPStatusBarPane |
GetCaption() const | CXTPStatusBarPane |
GetCustomizationVisible() const | CXTPStatusBarPane |
GetIconIndex() const | CXTPStatusBarPane |
GetID() const | CXTPStatusBarPane |
GetImage() const | CXTPStatusBarPane | virtual
GetIndex() const | CXTPStatusBarPane |
GetMargins() const | CXTPStatusBarPane |
GetMarkupUIElement() const | CXTPStatusBarPane |
GetPadding() const | CXTPStatusBarPane |
GetPos() const | CXTPProgressBase |
GetProgressPaintManager() const | CXTPStatusBarProgressPane | protectedvirtual
GetProgressRect() | CXTPStatusBarProgressPane | protectedvirtual
GetRange(int &nLower, int &nUpper) const | CXTPProgressBase |
GetRect() const | CXTPStatusBarPane |
GetStatusBar() const | CXTPStatusBarPane |
GetStyle() const | CXTPStatusBarPane |
GetText() const | CXTPStatusBarPane |
GetTextAlignment() const | CXTPStatusBarPane |
GetTextColor() const | CXTPStatusBarPane |
GetTextFont() | CXTPStatusBarPane | virtual
GetTextGrayColor() const | CXTPStatusBarPane |
GetTooltip() const | CXTPStatusBarPane |
GetValue() const | CXTPStatusBarPane |
GetWidth() | CXTPStatusBarPane | virtual
HasBorders() const | CXTPStatusBarPane |
IsButton() const | CXTPStatusBarPane |
IsChecked() const | CXTPStatusBarPane |
IsDark() const | CXTPStatusBarPane |
IsEnabled() const | CXTPStatusBarPane |
IsHighlighted() const | CXTPStatusBarPane |
IsPressed() const | CXTPStatusBarPane |
IsVisible() const | CXTPStatusBarPane |
m_bAutoDeleteWnd | CXTPStatusBarPane | protected
m_bBeginGroup | CXTPStatusBarPane | protected
m_bButton | CXTPStatusBarPane | protected
m_bCustomizable | CXTPStatusBarPane | protected
m_bIsDark | CXTPStatusBarPane | protected
m_bPressed | CXTPStatusBarPane | protected
m_clrBackground | CXTPStatusBarPane | protected
m_clrText | CXTPStatusBarPane | protected
m_clrTextGray | CXTPStatusBarPane | protected
m_cxText | CXTPStatusBarPane | protected
m_dwHideFlags | CXTPStatusBarPane | protected
m_hWndPane | CXTPStatusBarPane | protected
m_nAlignment | CXTPStatusBarPane | protected
m_nBestFit | CXTPStatusBarPane | protected
m_nIconIndex | CXTPStatusBarPane | protected
m_nID | CXTPStatusBarPane | protected
m_nIndex | CXTPStatusBarPane | protected
m_nMax | CXTPProgressBase | protected
m_nMin | CXTPProgressBase | protected
m_nPos | CXTPProgressBase | protected
m_nStyle | CXTPStatusBarPane | protected
m_pMarkupUIElement | CXTPStatusBarPane | protected
m_pStatusBar | CXTPStatusBarPane | protected
m_rcMargins | CXTPStatusBarPane | protected
m_rcPadding | CXTPStatusBarPane | protected
m_rcPane | CXTPStatusBarPane | protected
m_strCaption | CXTPStatusBarPane | protected
m_strText | CXTPStatusBarPane | protected
m_strToolTip | CXTPStatusBarPane | protected
m_strValue | CXTPStatusBarPane | protected
m_xtpFontText | CXTPStatusBarPane | protected
OnDraw(CDC *pDC, CRect rcItem) | CXTPStatusBarProgressPane | protectedvirtual
OnLButtonDown(CPoint point) | CXTPStatusBarPane | protectedvirtual
OnMouseMove(CPoint point) | CXTPStatusBarPane | protectedvirtual
OnToolHitTest(CPoint point, TOOLINFO *pTI) const | CXTPStatusBarPane | protectedvirtual
Redraw() const | CXTPStatusBarPane |
RedrawProgress() | CXTPStatusBarProgressPane | protectedvirtual
Remove() | CXTPStatusBarPane |
SetBackgroundColor(COLORREF clrBackground) | CXTPStatusBarPane |
SetBeginGroup(BOOL bBeginGroup=TRUE) | CXTPStatusBarPane |
SetButton(BOOL bButton=TRUE) | CXTPStatusBarPane |
SetCaption(LPCTSTR lpszCaption) | CXTPStatusBarPane |
SetChecked(BOOL bChecked) | CXTPStatusBarPane |
SetCustomizationVisible(BOOL bVisible) | CXTPStatusBarPane |
SetDark(BOOL bDark=TRUE) | CXTPStatusBarPane |
SetEnabled(BOOL bEnabled) | CXTPStatusBarPane |
SetIconIndex(int nIconIndex) | CXTPStatusBarPane |
SetMargins(int nLeft, int nTop, int nRight, int nBottom) | CXTPStatusBarPane |
SetPadding(int nLeft, int nTop, int nRight, int nBottom) | CXTPStatusBarPane |
SetPos(int nPos) | CXTPProgressBase |
SetRange(int nLower, int nUpper) | CXTPProgressBase |
SetStyle(UINT nStyle) | CXTPStatusBarPane |
SetText(LPCTSTR lpszText) | CXTPStatusBarPane |
SetTextAlignment(int nAlign) | CXTPStatusBarPane |
SetTextColor(COLORREF clrText) | CXTPStatusBarPane |
SetTextFont(CFont *pFntText) | CXTPStatusBarPane |
SetTextFont(PLOGFONT pLogfText) | CXTPStatusBarPane |
SetTextGrayColor(COLORREF clrText) | CXTPStatusBarPane |
SetTooltip(LPCTSTR lpszTooltip) | CXTPStatusBarPane |
SetValue(LPCTSTR lpszValue) | CXTPStatusBarPane |
SetVisible(BOOL bVisible, BOOL bRecalcLayout=TRUE) | CXTPStatusBarPane |
SetWidth(int nWidth) | CXTPStatusBarPane |
ShowBorders(BOOL bShowBorders) | CXTPStatusBarPane |
~CXTPProgressBase() | CXTPProgressBase | virtual
~CXTPStatusBarPane() | CXTPStatusBarPane | virtual
~CXTPStatusBarProgressPane() | CXTPStatusBarProgressPane |


Toolkit Pro: Member List

CXTPDockingPaneAutoHidePanel Member List

This is the complete list of members for CXTPDockingPaneAutoHidePanel, including all inherited members.

_InsertPane(CXTPDockingPaneBase *pPane) | CXTPDockingPaneAutoHidePanel | protectedvirtual
AddItem(int nItem, CXTPTabManagerItem *pItem=NULL) | CXTPTabManager | protected
Clone(CXTPDockingPaneLayout *pLayout, CXTPPaneToPaneMap *pMap, DWORD dwIgnoredOptions=0) | CXTPDockingPaneBase | protectedvirtual
CloseActiveWindow(BOOL bDelayed=FALSE) | CXTPDockingPaneAutoHidePanel | protected
CloseActiveWindows() | CXTPDockingPaneAutoHidePanel | protected
ContainPane(CXTPDockingPaneBase *pPane) const | CXTPDockingPaneBaseContainer | virtual
Create(CWnd *pParent) | CXTPDockingPaneAutoHidePanel | protectedvirtual
CreateContainer() | CXTPDockingPaneBase | protectedvirtual
CXTPDockingPaneAutoHidePanel(CXTPDockingPaneLayout *pLayout) | CXTPDockingPaneAutoHidePanel | protected
CXTPDockingPaneBase(XTPDockingPaneType type, CXTPDockingPaneLayout *pLayout) | CXTPDockingPaneBase | protected
CXTPDockingPaneBaseContainer(XTPDockingPaneType type, CXTPDockingPaneLayout *pLayout) | CXTPDockingPaneBaseContainer | protected
CXTPTabManager() | CXTPTabManager |
DeleteAllItems() | CXTPTabManager |
DeleteItem(int nItem) | CXTPTabManager |
DeletePane()=0 | CXTPDockingPaneBase | protectedpure virtual
DoPropExchange(CXTPPropExchange *pPX) | CXTPDockingPaneAutoHidePanel | protectedvirtual
DrawIcon(CDC *pDC, CPoint pt, CXTPTabManagerItem *pItem, BOOL bDraw, CSize &szIcon) const | CXTPDockingPaneAutoHidePanel | virtual
DrawParentBackground(CDC *pDC, CRect rc) | CXTPTabManager | virtual
EnableMarkup(BOOL bEnable=TRUE) | CXTPTabManager |
EnableTabThemeTexture(HWND hWnd, BOOL bEnable=TRUE) | CXTPTabManager |
EnsureVisible(CXTPTabManagerItem *pItem) | CXTPTabManager |
FindCaptionButton(int nID) const | CXTPDockingPaneBase |
FindNavigateButton(UINT nID) const | CXTPTabManager |
FindNextFocusable(int nIndex, int nDirection) const | CXTPTabManager |
FindPane(XTPDockingPaneType type, CXTPDockingPaneBaseList *pList) const | CXTPDockingPaneBaseContainer | virtual
GetAppearance() const | CXTPTabManager |
GetAppearanceSet() const | CXTPTabManager |
GetCaptionButtons() const | CXTPDockingPaneBase |
GetClientRect() const | CXTPTabManager |
GetColor() const | CXTPTabManager |
GetColorSet() const | CXTPTabManager |
GetContainer() const | CXTPDockingPaneBase |
GetControlRect() const | CXTPTabManager |
GetCurSel() const | CXTPTabManager |
GetDirection() const | CXTPDockingPaneAutoHidePanel |
GetDockingPaneManager() const | CXTPDockingPaneBase |
GetDockingSite() const | CXTPDockingPaneBase | virtual
GetFirstPane() const | CXTPDockingPaneBaseContainer |
GetHeaderOffset() const | CXTPTabManager |
GetHeaderRect() const | CXTPTabManager |
GetHeadPosition() const | CXTPDockingPaneBaseContainer |
GetItem(int nIndex) const | CXTPTabManager |
GetItemCaption(const CXTPTabManagerItem *pItem) const | CXTPTabManager | virtual
GetItemColor(const CXTPTabManagerItem *pItem) const | CXTPTabManager | virtual
GetItemCount() const | CXTPTabManager |
GetItemIcon(const CXTPTabManagerItem *pItem) const | CXTPTabManager | virtual
GetItemMetrics(CSize *szNormal, CSize *szMin=NULL, CSize *szMax=NULL) const | CXTPTabManager | virtual
GetItemsLength() const | CXTPDockingPaneAutoHidePanel | virtual
GetItemTooltip(const CXTPTabManagerItem *pItem) const | CXTPTabManager | virtual
GetLastPane() const | CXTPDockingPaneBaseContainer |
GetLayout() const | CXTPTabManager |
GetMarkupContext() const | CXTPTabManager | virtual
GetMinMaxInfo(LPMINMAXINFO pMinMaxInfo) const | CXTPDockingPaneBase | virtual
GetNavigateButton(int nIndex) const | CXTPTabManager |
GetNavigateButtonCount() const | CXTPTabManager |
GetNavigateButtons() | CXTPTabManager |
GetNext(POSITION &pos) const | CXTPDockingPaneBaseContainer |
GetPaintManager() const | CXTPDockingPaneAutoHidePanel | virtual
GetPaneHwnd() const | CXTPDockingPaneAutoHidePanel | virtual
GetPanelHeight() const | CXTPDockingPaneAutoHidePanel | protected
GetPanes() | CXTPDockingPaneBaseContainer |
GetPaneTab(CXTPDockingPane *pPane) const | CXTPDockingPaneAutoHidePanel |
GetPaneWindowRect() const | CXTPDockingPaneBase |
GetPosition() const | CXTPDockingPaneAutoHidePanel | virtual
GetRectLength(CRect rc) const | CXTPTabManager |
GetRowCount() const | CXTPTabManager |
GetSelectedItem() const | CXTPTabManager |
GetTitle() const | CXTPDockingPaneBase | virtual
GetType() const | CXTPDockingPaneBase |
HeaderHasFocus() const | CXTPTabManager | protectedvirtual
HitTest(CPoint point) const | CXTPDockingPaneAutoHidePanel |
HitTestNavigateButton(CPoint point, BOOL bHeaderOnly, int *pnIndex=NULL) const | CXTPTabManager |
InvalidatePane(BOOL bSelectionChanged) | CXTPDockingPaneAutoHidePanel | protectedvirtual
CXTPDockingPaneBaseContainer::IsActive() const | CXTPDockingPaneBase | virtual
CXTPTabManager::IsActive() const | CXTPTabManager |
IsAllowReorder() const | CXTPTabManager | virtual
IsCaptionButtonVisible(CXTPDockingPaneCaptionButton *pButton) | CXTPDockingPaneBase | protectedvirtual
IsCaptionVertical() const | CXTPDockingPaneBase | virtual
IsDrawStaticFrame() const | CXTPTabManager | virtual
IsEmpty() const | CXTPDockingPaneBaseContainer | protectedvirtual
IsHidden() const | CXTPDockingPaneBase | virtual
IsHorizontalPosition() const | CXTPTabManager |
IsMouseLocked() const | CXTPTabManager | protectedvirtual
IsNavigateButtonAutomaticVisible(CXTPTabManagerNavigateButton *pButton) | CXTPTabManager | protectedvirtual
IsNavigateButtonVisible(CXTPTabManagerNavigateButton *pButton) | CXTPTabManager | protectedvirtual
m_arrItems | CXTPTabManager | protected
m_arrNavigateButtons | CXTPTabManager | protected
m_bActive | CXTPTabManager | protected
m_bAllowReorder | CXTPTabManager | protected
m_bCloseActiveWindow | CXTPDockingPaneAutoHidePanel | static
m_bCloseItemButton | CXTPTabManager | protected
m_direction | CXTPDockingPaneAutoHidePanel | protected
m_lstPanes | CXTPDockingPaneBaseContainer | protected
m_nHeaderOffset | CXTPTabManager | protected
m_nScrollDelta | CXTPTabManager | protected
m_pActiveWnd | CXTPDockingPaneAutoHidePanel | protected
m_pCaptionButtons | CXTPDockingPaneBase | protected
m_pDockingSite | CXTPDockingPaneBase | protected
m_pHighlighted | CXTPTabManager | protected
m_pHighlightedNavigateButton | CXTPTabManager | protected
m_pLayout | CXTPDockingPaneBase | protected
m_pMarkupContext | CXTPTabManager | protected
m_pParentContainer | CXTPDockingPaneBase | protected
m_pPressed | CXTPTabManager | protected
m_pRowIndexer | CXTPTabManager | protected
m_pSelected | CXTPTabManager | protected
m_rcControl | CXTPTabManager | protected
m_rcHeaderRect | CXTPTabManager | protected
m_rcWindow | CXTPDockingPaneBase | protected
m_szDocking | CXTPDockingPaneBase | protected
m_type | CXTPDockingPaneBase | protected
MoveItem(CXTPTabManagerItem *pItem, int nIndex) | CXTPTabManager |
OnAction(XTPDockingPaneAction action) | CXTPDockingPaneBaseContainer |
OnBeforeItemClick(CXTPTabManagerItem *pItem) | CXTPTabManager | protectedvirtual
OnCaptionButtonRectChanged(CXTPDockingPaneCaptionButton *pButton) | CXTPDockingPaneBase | protectedvirtual
OnChildContainerChanged(CXTPDockingPaneBase *pContainer) | CXTPDockingPaneAutoHidePanel | protectedvirtual
OnFocusChanged() | CXTPDockingPaneBase | protectedvirtual
OnItemClick(CXTPTabManagerItem *pItem) | CXTPTabManager | protectedvirtual
OnItemHandleChanged(CXTPTabManagerItem *pItem, HWND hwndOld, HWND hwndNew) | CXTPTabManager | protectedvirtual
OnItemOrderChanged(CXTPTabManagerItem *pItem, int nOldIndex, int nNewIndex) | CXTPTabManager | protectedvirtual
OnItemsChanged() | CXTPTabManager | virtual
OnNavigateButtonClick(CXTPTabManagerNavigateButton *pButton) | CXTPTabManager | protectedvirtual
OnNavigateButtonClick(UINT nID) | CXTPTabManager | protectedvirtual
OnParentContainerChanged(CXTPDockingPaneBase *pContainer) | CXTPDockingPaneBase | protectedvirtual
OnPropertyChanged() | CXTPTabManagerAtom | inlinevirtual
OnScrollHeader(BOOL bRight) | CXTPTabManager | virtual
OnSizeParent(CWnd *pParent, CRect rect, LPVOID lParam) | CXTPDockingPaneBase | protectedvirtual
OnSizeParentEx(CWnd *pParent, CRect &rect, LPVOID lParam) | CXTPDockingPaneAutoHidePanel | protectedvirtual
OnSwitchItem(CXTPTabManagerItem *pItem1, CXTPTabManagerItem *pItem2) | CXTPTabManager | protectedvirtual
PerformClick(HWND hWnd, CPoint pt, BOOL bNoItemClick=FALSE) | CXTPTabManager |
PerformKeyDown(HWND hWnd, UINT nChar) | CXTPTabManager | virtual
PerformMouseMove(HWND hWnd, CPoint pt) | CXTPTabManager |
PerformToolHitTest(HWND hWnd, CPoint point, TOOLINFO *pTI) const | CXTPTabManager | virtual
RedrawControl(LPCRECT lpRect, BOOL bAnimate)=0 | CXTPTabManager | pure virtual
RedrawPane() | CXTPDockingPaneBase | virtual
RefreshManagersArray(CDC *pDC, CRect rcClient) | CXTPDockingPaneAutoHidePanel | protected
RemovePane(CXTPDockingPaneBase *pPane) | CXTPDockingPaneAutoHidePanel | protectedvirtual
ReOrder(HWND hWnd, CPoint pt, CXTPTabManagerItem *pItem) | CXTPTabManager | protectedvirtual
Reposition()=0 | CXTPTabManagerAtom | pure virtual
SetActive(BOOL bActive) | CXTPTabManager |
SetAllowReorder(BOOL bAllowReorder) | CXTPTabManager | virtual
SetAppearance(XTPTabAppearanceStyle tabAppearance) | CXTPTabManager |
SetAppearanceSet(CXTPTabPaintManagerTheme *pAppearanceSet) | CXTPTabManager |
SetColor(XTPTabColorStyle tabColor) | CXTPTabManager |
SetColorSet(CXTPTabPaintManagerColorSet *pColorSet) | CXTPTabManager |
SetCurSel(int nIndex) | CXTPTabManager |
SetDockingSite(CWnd *pFrame) | CXTPDockingPaneBase | protectedvirtual
SetFocusedItem(CXTPTabManagerItem *pItem) | CXTPTabManager | virtual
SetHeaderOffset(int nOffset) | CXTPTabManager |
SetItemMetrics(CSize szNormal, CSize szMin=CSize(0, 0), CSize szMax=CSize(0, 0)) | CXTPTabManager |
SetLayoutStyle(XTPTabLayoutStyle tabLayout) | CXTPTabManager |
SetPaintManager(CXTPTabPaintManager *pPaintManager) | CXTPTabManager | virtual
SetParentContainer(CXTPDockingPaneBase *pContainer) | CXTPDockingPaneBase | protectedvirtual
SetPosition(XTPTabPosition tabPosition) | CXTPTabManager |
SetSelectedItem(CXTPTabManagerItem *pItem) | CXTPTabManager | virtual
ShowCloseItemButton(XTPTabNavigateButtonFlags bCloseItemButton=xtpTabNavigateButtonAlways) | CXTPTabManager |
ShowIcons(BOOL bShowIcons) | CXTPTabManager |
ShowPane(CXTPDockingPane *pPane, BOOL bSetFocus=TRUE) | CXTPDockingPaneAutoHidePanel | protected
TrackClick(HWND hWnd, CPoint pt, CXTPTabManagerItem *pItem) | CXTPTabManager | protected
~CXTPDockingPaneAutoHidePanel() | CXTPDockingPaneAutoHidePanel | protected
~CXTPDockingPaneBase() | CXTPDockingPaneBase | protectedvirtual
~CXTPDockingPaneBaseContainer() | CXTPDockingPaneBaseContainer | protectedvirtual
~CXTPTabManager() | CXTPTabManager | virtual
~CXTPTabManagerAtom() | CXTPTabManagerAtom | inlineprotectedvirtual


Toolkit Pro: Member List

CXTPFlowGraphNodeGroups Member List

This is the complete list of members for CXTPFlowGraphNodeGroups, including all inherited members.

AddGroup() | CXTPFlowGraphNodeGroups |
CXTPCmdTarget() | CXTPCmdTarget |
CXTPFlowGraphNodeGroups(CXTPFlowGraphPage *pPage) | CXTPFlowGraphNodeGroups | protected
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAt(int nIndex) const | CXTPFlowGraphNodeGroups |
GetCount() const | CXTPFlowGraphNodeGroups |
GetPage() const | CXTPFlowGraphNodeGroups |
m_arrGroups | CXTPFlowGraphNodeGroups | protected
m_pPage | CXTPFlowGraphNodeGroups | protected
Remove(CXTPFlowGraphNodeGroup *pGroup) | CXTPFlowGraphNodeGroups |
RemoveAll() | CXTPFlowGraphNodeGroups |
~CXTPFlowGraphNodeGroups() | CXTPFlowGraphNodeGroups | protectedvirtual


Toolkit Pro: Member List

CXTPTabThemeVisualStudio2022 Member List

This is the complete list of members for CXTPTabThemeVisualStudio2022, including all inherited members.

AdjustClientRect(CXTPTabManager *pTabManager, CRect &rcClient) | CXTPTabPaintManagerTheme | virtual
CXTPTabPaintManagerTheme() | CXTPTabPaintManagerTheme |
CXTPTabThemeFlat() | CXTPTabThemeFlat | inline
CXTPTabThemeVisualStudio2015() | CXTPTabThemeVisualStudio2015 |
CXTPTabThemeVisualStudio2017() | CXTPTabThemeVisualStudio2017 |
CXTPTabThemeVisualStudio2019() | CXTPTabThemeVisualStudio2019 |
CXTPTabThemeVisualStudio2022() | CXTPTabThemeVisualStudio2022 |
DrawSingleButton(CDC *pDC, CXTPTabManagerItem *pItem) | CXTPTabThemeVisualStudio2012 | virtual
DrawTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl) | CXTPTabPaintManagerTheme | virtual
DrawText(CDC *pDC, CXTPTabManager *pManager, const CString &str, LPRECT lpRect, UINT nFormat) | CXTPTabPaintManagerTheme | virtual
DrawWorkspacePart(CDC *pDC, LPRECT lpRect, XTPTabWorkspacePart workspacePart) | CXTPTabThemeVisualStudio2012 | virtual
FillButton(CDC *pDC, CXTPTabManagerItem *pItem, LPPOINT pts, int nCount, XTPTabPosition tabPosition, BOOL bAbsolute=FALSE) | CXTPTabPaintManagerTheme |
FillTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl) | CXTPTabThemeFlat | virtual
GetButtonDrawRect(const CXTPTabManagerItem *pItem) | CXTPTabPaintManagerTheme | virtual
GetButtonHeight(const CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetButtonLength(CDC *pDC, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerTheme | virtual
GetClientMargin() | CXTPTabPaintManagerTheme | virtual
GetClientRect(CRect rcControl, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetColorSet() const | CXTPTabPaintManagerTheme |
GetDefaultColorSet() | CXTPTabThemeVisualStudio2022 | inlinevirtual
GetHeaderClipBox(CDC *pDC, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetHeaderHeight(CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme |
GetHeaderMargin() | CXTPTabPaintManagerTheme | virtual
GetHeaderRect(CRect rcControl, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetSupportedColorSets() | CXTPTabPaintManagerTheme | inlinevirtual
m_bButtonsReverseZOrder | CXTPTabPaintManagerTheme | protected
m_nButtonHeight | CXTPTabPaintManagerTheme | protected
m_nRowMargin | CXTPTabPaintManagerTheme |
m_pPaintManager | CXTPTabPaintManagerTheme | protected
m_rcHeaderMargin | CXTPTabPaintManagerTheme |
RefreshMetrics() | CXTPTabThemeVisualStudio2022 | virtual
RepositionTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcClient) | CXTPTabPaintManagerTheme | virtual
~CXTPTabPaintManagerTheme() | CXTPTabPaintManagerTheme | virtual


Toolkit Pro: XTPMarkupView.h Source File

  • Source
  • Controls
  • View
XTPMarkupView.h
Go to the documentation of this file.
1
23#if !defined(__XTPMARKUPVIEW_H__)
24# define __XTPMARKUPVIEW_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33# ifdef _XTP_INCLUDE_MARKUP
34
35class CXTPMarkupDrawingContext;
36class CXTPMarkupUIElement;
37class CXTPMarkupContext;
38
39class _XTP_EXT_CLASS CXTPMarkupView
40 : public CView
41 , CXTPMarkupContext
42{
43protected: // create from serialization only
44 CXTPMarkupView();
45 DECLARE_DYNCREATE(CXTPMarkupView)
46
47 // Attributes
48public:
52public:
53 //{{AFX_VIRTUAL(CMarkupPadView)
58public:
59 virtual void OnDraw(CDC* pDC);
60 virtual BOOL PreCreateWindow(CREATESTRUCT& cs);
61
62protected:
63 virtual BOOL OnPreparePrinting(CPrintInfo* pInfo);
64 virtual void OnBeginPrinting(CDC* pDC, CPrintInfo* pInfo);
65 virtual void OnEndPrinting(CDC* pDC, CPrintInfo* pInfo);
66 void OnPrint(CDC* pDC, CPrintInfo* pInfo);
67 //}}AFX_VIRTUAL
68
69 void OnPrepareDC(CDC* pDC, CPrintInfo* pInfo);
70
71 // Implementation
72public:
73 virtual ~CXTPMarkupView();
74# ifdef _DEBUG
75 virtual void AssertValid() const;
76 virtual void Dump(CDumpContext& dc) const;
77# endif
78
79 BOOL OnWndMsg(UINT message, WPARAM wParam, LPARAM lParam, LRESULT* pResult);
80 using CXTPMarkupContext::OnWndMsg;
81 void OnInitialUpdate();
82
83 void DrawMarkup(CXTPMarkupDrawingContext* pDC, CRect rc);
84 void SetMarkupText(LPCTSTR lpszMarkup);
85
86public:
87 CXTPMarkupUIElement* m_pUIElement;
88 BOOL m_bInRender;
89
90 // Generated message map functions
91protected:
92 //{{AFX_MSG(CMarkupPadView)
93 afx_msg BOOL OnEraseBkgnd(CDC* pDC);
94 afx_msg void OnPaint();
95 //}}AFX_MSG
96 DECLARE_MESSAGE_MAP()
97};
98
99# endif
100
101# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
103#endif // !defined(__XTPMARKUPVIEW_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPMarkupContext
CXTPMarkupContext is a standalone class used to provide common settings for Markup objects.
Definition XTPMarkupContext.h:128
CXTPMarkupUIElement
Base class for XML Markup core level implementations.
Definition XTPMarkupUIElement.h:43


Toolkit Pro: Member List

CXTPControlButton Member List

This is the complete list of members for CXTPControlButton, including all inherited members.

AssignDocTemplate(UINT nIDResource) | CXTPControl |
ClickToolBarButton(CRect rcActiveRect=CRect(0, 0, 0, 0)) | CXTPControl | protected
Compare(CXTPControl *pOther) | CXTPControl | virtual
Copy(CXTPControl *pControl, BOOL bRecursive=FALSE) | CXTPControlButton | protectedvirtual
CustomizeStartDrag(CPoint point) | CXTPControl | protectedvirtual
CustomizeStartResize(CPoint point) | CXTPControl | protectedvirtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPControl() | CXTPControl | protected
CXTPControlButton() | CXTPControlButton |
DelayLayoutParent() | CXTPControl |
DelayRedrawParent() | CXTPControl |
DoCustomDragOver(CXTPCommandBar *pCommandBar, CPoint point, DROPEFFECT &dropEffect) | CXTPControl | protectedvirtual
DoPropExchange(CXTPPropExchange *pPX) | CXTPControlButton | virtual
Draw(CDC *pDC) | CXTPControl | virtual
ExcludeDocTemplate(UINT nIDResource) | CXTPControl |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
FromUI(CCmdUI *pCmdUI) | CXTPControl | static
GenerateCommandBarList(DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam) | CXTPControl | protectedvirtual
GetAction() const | CXTPControl |
GetBeginGroup() const | CXTPControl |
GetButtonSize() const | CXTPControl | virtual
GetCaption() const | CXTPControl | virtual
GetCategory() const | CXTPControl |
GetChecked() const | CXTPControl |
GetCloseSubMenuOnClick() const | CXTPControl |
GetCommandBar() const | CXTPControl | virtual
GetControls() const | CXTPControl |
GetCustomizeMinHeight() const | CXTPControl | protectedvirtual
GetCustomizeMinWidth() const | CXTPControl | protectedvirtual
GetCustomShortcutText() const | CXTPControl |
GetDescription() const | CXTPControl | virtual
GetEnabled() const | CXTPControl |
GetExecuteOnPressInterval() const | CXTPControl |
GetExpanded() const | CXTPControl |
GetFlags() const | CXTPControl |
GetHeight() const | CXTPControl |
GetHelpId() const | CXTPControl |
GetHideFlags() const | CXTPControl |
GetIconId() const | CXTPControl |
GetIconSize() const | CXTPControl | virtual
GetID() const | CXTPControl |
GetImage(int nWidth=16) const | CXTPControl | virtual
GetImageManager() const | CXTPControl |
GetIndex() const | CXTPControl |
GetKeyboardTip() const | CXTPControl |
GetPaintManager() const | CXTPControl |
GetParameter() const | CXTPControl |
GetParent() const | CXTPControl |
GetPopuped() const | CXTPControl | virtual
GetPressed() const | CXTPControl | virtual
GetRect() const | CXTPControl |
GetRibbonGroup() const | CXTPControl |
GetRowRect() const | CXTPControl |
GetSelected() const | CXTPControl | virtual
GetShortcutText() const | CXTPControl |
GetSize(CDC *pDC) | CXTPControl | virtual
GetStyle() const | CXTPControl |
GetStyleEx() const | CXTPControlButton |
GetTag() const | CXTPControl |
GetTooltip() const | CXTPControl | virtual
GetType() const | CXTPControl |
GetWidth() const | CXTPControl |
GetWrap() const | CXTPControl |
HasDwmCompositedRect() const | CXTPControl |
IsCaptionVisible() const | CXTPControl | virtual
IsCursorOver() const | CXTPControl |
IsCustomizeMode() const | CXTPControl | protected
IsCustomizeMovable() const | CXTPControl | virtual
IsCustomizeResizeAllow() const | CXTPControl | protectedvirtual
IsFocusable() const | CXTPControl | protectedvirtual
IsFocused() const | CXTPControl | virtual
IsItemDefault() const | CXTPControl |
IsLayoutChanged() | CXTPControl | protected
IsLayoutRTL() const | CXTPControl | protected
IsOnQuickAccess() const | CXTPControl |
IsTemporary() const | CXTPControl |
IsTransparent() const | CXTPControl | inlinevirtual
IsVisible(DWORD dwSkipFlags=0) const | CXTPControl | virtual
m_bBeginGroup | CXTPControl | protected
m_bChecked | CXTPControl | protected
m_bCloseSubMenuOnClick | CXTPControl | protected
m_bDefaultItem | CXTPControl | protected
m_bEnabled | CXTPControl | protected
m_bExpanded | CXTPControl | protected
m_bLayoutRTL | CXTPControl | protected
m_bOnQuickAccess | CXTPControl | protected
m_bPressed | CXTPControl | protected
m_bSelected | CXTPControl | protected
m_bTemporary | CXTPControl | protected
m_buttonCustomStyle | CXTPControl | protected
m_buttonRibbonStyle | CXTPControl | protected
m_buttonStyle | CXTPControl | protected
m_buttonStyleEx | CXTPControlButton | protected
m_bWrap | CXTPControl | protected
m_controlType | CXTPControl | protected
m_dwFlags | CXTPControl | protected
m_dwHideFlags | CXTPControl | protected
m_mapDocTemplatesAssigned | CXTPControl | protected
m_mapDocTemplatesExcluded | CXTPControl | protected
m_nCustomIconId | CXTPControl | protected
m_nExecuteOnPressInterval | CXTPControl | protected
m_nHeight | CXTPControl | protected
m_nHelpId | CXTPControl | protected
m_nIconId | CXTPControl | protected
m_nId | CXTPControl | protected
m_nIndex | CXTPControl | protected
m_nTag | CXTPControl | protected
m_nWidth | CXTPControl | protected
m_pAction | CXTPControl | protected
m_pControls | CXTPControl | protected
m_pParent | CXTPControl | protected
m_pRibbonGroup | CXTPControl | protected
m_rcControl | CXTPControl | protected
m_rcRow | CXTPControl | protected
m_strCaption | CXTPControl | protected
m_strCategory | CXTPControl | protected
m_strCustomCaption | CXTPControl | protected
m_strDescriptionText | CXTPControl | protected
m_strKeyboardTip | CXTPControl | protected
m_strParameter | CXTPControl | protected
m_strShortcutText | CXTPControl | protected
m_strShortcutTextAuto | CXTPControl | protected
m_strTooltipText | CXTPControl | protected
m_szIcon | CXTPControl | protected
NotifySite(UINT code) | CXTPControl |
NotifySite(UINT code, NMXTPCONTROL *pNM) | CXTPControl |
NotifySite(CWnd *pSite, UINT code, NMXTPCONTROL *pNM) | CXTPControl |
OnActionChanged(int nProperty) | CXTPControl | protectedvirtual
OnActionChanging(int nProperty) | CXTPControl | protectedvirtual
OnCalcDynamicSize(DWORD dwMode) | CXTPControl | virtual
OnCaptionChanged() | CXTPControl | protectedvirtual
OnClick(BOOL bKeyboard=FALSE, CPoint pt=CPoint(0, 0)) | CXTPControlButton | protectedvirtual
OnCustomizeDragOver(CXTPControl *pDataObject, CPoint point, DROPEFFECT &dropEffect) | CXTPControl | protectedvirtual
OnCustomizeMouseMove(CPoint point) | CXTPControl | protected
OnEnabledChanged() | CXTPControl | virtual
OnExecute() | CXTPControl | virtual
OnHookKeyDown(UINT nChar, LPARAM lParam) | CXTPControl | protectedvirtual
OnHookMouseWheel(UINT nFlags, short zDelta, CPoint point) | CXTPControl | protectedvirtual
OnIdleUpdate() | CXTPControl | protectedvirtual
OnLButtonDblClk(CPoint point) | CXTPControl | protectedvirtual
OnLButtonDown(CPoint point) | CXTPControl | protectedvirtual
OnLButtonUp(CPoint point) | CXTPControlButton | protectedvirtual
OnMouseHover() | CXTPControl | protectedvirtual
OnMouseMove(CPoint point) | CXTPControl | protectedvirtual
OnRButtonDown(CPoint point) | CXTPControl | protectedvirtual
OnRButtonUp(CPoint point) | CXTPControl | protectedvirtual
OnRemoved() | CXTPControl | protectedvirtual
OnSetPopup(BOOL bPopup) | CXTPControl | protectedvirtual
OnSetSelected(int bSelected) | CXTPControl | protectedvirtual
OnThemeChanged() | CXTPControl | virtual
OnToolHitTest(CPoint point, TOOLINFO *pTI) const | CXTPControl | protectedvirtual
OnUnderlineActivate() | CXTPControl | virtual
RedrawParent(BOOL bAnimate=TRUE) | CXTPControl |
Reset() | CXTPControl |
RestoreCommandBarList(CXTPCommandBarList *pCommandBarList) | CXTPControl | protectedvirtual
ScreenToClient(CPoint *point) | CXTPControl | protected
SetAction(CXTPControlAction *pAction) | CXTPControl | virtual
SetBeginGroup(BOOL bBeginGroup) | CXTPControl | virtual
SetCaption(LPCTSTR lpszCaption) | CXTPControl |
SetCaption(UINT nIDCaption) | CXTPControl |
SetCategory(LPCTSTR lpszCategory) | CXTPControl |
SetChecked(BOOL bChecked) | CXTPControl | virtual
SetCloseSubMenuOnClick(BOOL bCloseOnClick) | CXTPControl |
SetCustomIcon(HICON hIcon) | CXTPControl |
SetCustomShortcutText(LPCTSTR lpszCustomShortcutText) | CXTPControl |
SetDescription(LPCTSTR lpszDescription) | CXTPControl |
SetEnabled(BOOL bEnabled) | CXTPControl | virtual
SetExecuteOnPressInterval(int nExecuteOnPressInterval) | CXTPControl |
SetExpanded(BOOL bExpanded) | CXTPControl | protected
SetFlags(DWORD dwFlags) | CXTPControl |
SetFocused(BOOL bFocused) | CXTPControl | virtual
SetHeight(int nHeight) | CXTPControl | virtual
SetHelpId(int nId) | CXTPControl |
SetHideFlag(XTPControlHideFlags dwFlag, BOOL bSet) | CXTPControl |
SetHideFlags(DWORD dwFlags) | CXTPControl | virtual
SetHideWrap(BOOL bHide) | CXTPControl |
SetIconId(int nId) | CXTPControl |
SetIconSize(CSize szIcon) | CXTPControl |
SetID(int nId) | CXTPControl |
SetIndex(int nIndex) | CXTPControl | inlineprotected
SetItemDefault(BOOL bDefault) | CXTPControl |
SetKeyboardTip(LPCTSTR lpszKeyboardTip) | CXTPControl |
SetOnQuickAccess(BOOL bOnQuicAccess=FALSE) | CXTPControl |
SetParameter(LPCTSTR lpszParameter) | CXTPControl |
SetParent(CXTPCommandBar *pParent) | CXTPControl | inlineprotectedvirtual
SetPressed(BOOL bPressed) | CXTPControl |
SetPrompt(LPCTSTR lpszPrompt) | CXTPControl |
SetRect(CRect rcControl) | CXTPControl | virtual
SetRowRect(CRect rcRow) | CXTPControl |
SetShortcutText(LPCTSTR lpszShortcutText) | CXTPControl |
SetStyle(XTPButtonStyle buttonStyle) | CXTPControl |
SetStyleEx(XTPButtonStyle buttonStyle) | CXTPControlButton |
SetTag(DWORD_PTR dwTag) | CXTPControl |
SetTooltip(LPCTSTR lpszTooltip) | CXTPControl |
SetVisible(BOOL bVisible) | CXTPControl |
SetWidth(int nWidth) | CXTPControl | virtual
SetWrap(BOOL bWrap) | CXTPControl |
~CXTPControl() | CXTPControl | protectedvirtual
~CXTPControlButton() | CXTPControlButton | virtual


Toolkit Pro: XTPResizeGroupBox.h Source File

  • Source
  • Controls
  • Resize
XTPResizeGroupBox.h
Go to the documentation of this file.
1
23#if !defined(__XTPRESIZEGROUPBOX_H__)
24# define __XTPRESIZEGROUPBOX_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
44class _XTP_EXT_CLASS CXTPResizeGroupBox : public CXTPButton
45{
47 DECLARE_DYNAMIC(CXTPResizeGroupBox)
49public:
54 CXTPResizeGroupBox();
55
61 virtual ~CXTPResizeGroupBox();
62
63protected:
71 virtual void Exclude(CDC* pDC, CRect& rcClient);
72
73protected:
75 DECLARE_MESSAGE_MAP()
76
77 //{{AFX_VIRTUAL(CXTPResizeGroupBox)
78 //}}AFX_VIRTUAL
79
80 //{{AFX_MSG(CXTPResizeGroupBox)
81 afx_msg BOOL OnEraseBkgnd(CDC* pDC);
82 afx_msg void OnPaint();
83 //}}AFX_MSG
85};
86
87# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
89#endif // !defined(__XTPRESIZEGROUPBOX_H__)
XTPDisableNoisyWarnings.h
CXTPButton
Push Button control.
Definition XTPButton.h:109
CXTPResizeGroupBox
CXTPResizeGroupBox is a CButton derived class that can be used to display a flicker free group box wh...
Definition XTPResizeGroupBox.h:45
CXTPResizeGroupBox::CXTPResizeGroupBox
CXTPResizeGroupBox()
Constructs a CXTPResizeGroupBox object.
CXTPResizeGroupBox::Exclude
virtual void Exclude(CDC *pDC, CRect &rcClient)
Called during paint operations to exclude the control windows that are grouped by this control.
CXTPResizeGroupBox::~CXTPResizeGroupBox
virtual ~CXTPResizeGroupBox()
Destroys a CXTPResizeGroupBox object, handles cleanup and deallocation.


Toolkit Pro: Member List

CXTPSkinManager Member List

This is the complete list of members for CXTPSkinManager, including all inherited members.

AddColorFilter(CXTPSkinManagerColorFilter *pFilter) | CXTPSkinManager |
ApplyColorFilter(COLORREF &clr) | CXTPSkinManager |
ApplyWindow(HWND hWnd) | CXTPSkinManager |
ApplyWindow(HWND hWnd, BOOL bApplyChildren) | CXTPSkinManager |
CreateSchema(LPCTSTR lpszResourcePath, LPCTSTR lpszIniFileName=NULL) | CXTPSkinManager |
CXTPSkinManager() | CXTPSkinManager | protected
EnableCurrentThread() | CXTPSkinManager |
EnableThemeDialogTexture(HWND hWnd, DWORD dwFlags) | CXTPSkinManager |
ExcludeModule(LPCTSTR lpszModule) | CXTPSkinManager |
FreeSkinData() | CXTPSkinManager | protected
FromHandle(HTHEME hTheme) | CXTPSkinManager |
GetAccessCriticalSection() const | CXTPSynchronized | inline
GetApplyOptions() const | CXTPSkinManager |
GetAutoApplyNewThreads() const | CXTPSkinManager |
GetAutoApplyNewWindows() const | CXTPSkinManager |
GetClassMap() const | CXTPSkinManager |
GetCurrentThemeName(CString &strThemeFileName, CString &strColorBuff) | CXTPSkinManager |
GetMetrics() const | CXTPSkinManager |
GetResourceFile() const | CXTPSkinManager |
GetSchema() const | CXTPSkinManager |
GetSkinClass(const CXTPSkinObject *pObject, CString strClassList) | CXTPSkinManager | virtual
GetThemeSysBool(int iBoolId) | CXTPSkinManager |
GetThemeSysColor(int iColorId) | CXTPSkinManager |
GetThemeSysFont(int iFontId, LOGFONT *plf) | CXTPSkinManager |
GetThemeSysSize(int iSizeId) | CXTPSkinManager |
HasApplyOptions(DWORD dwOptions) const | CXTPSkinManager |
IsColorFilterExists() const | CXTPSkinManager |
IsComCtlV6() const | CXTPSkinManager |
IsEnabled() const | CXTPSkinManager |
IsPersistentModule(HMODULE hModule) | CXTPSkinManager |
IsSuspended() const | CXTPSkinManager |
IsWin9x() const | CXTPSkinManager |
LoadSkin(LPCTSTR lpszResourcePath, LPCTSTR lpszIniFileName=NULL) | CXTPSkinManager |
Lookup(HWND hWnd) | CXTPSkinManager |
Lookup(HDC hDC) | CXTPSkinManager |
m_arPersistentModuleCache | CXTPSkinManager | protected
m_arrFilters | CXTPSkinManager | protected
m_bAutoApplyThreads | CXTPSkinManager | protected
m_bAutoApplyWindows | CXTPSkinManager | protected
m_bEnabled | CXTPSkinManager | protected
m_bWin9x | CXTPSkinManager | protected
m_csObjects | CXTPSkinManager | protected
m_dwApplyOptions | CXTPSkinManager | protected
m_dwComCtrl | CXTPSkinManager | protected
m_hWinEventHook | CXTPSkinManager | protected
m_mapObjects | CXTPSkinManager | protected
m_pClassMap | CXTPSkinManager | protected
m_pResourceFile | CXTPSkinManager | protected
m_pSchema | CXTPSkinManager | protected
m_pSetWindowTheme | CXTPSkinManager | protected
m_pSetWinEventHook | CXTPSkinManager | protected
m_pUnhookWinEvent | CXTPSkinManager | protected
m_pWindowFilter | CXTPSkinManager | protected
ModifyApplyOptions(DWORD dwAdd, DWORD dwRemove) | CXTPSkinManager |
OnBeforeApplicationShutdown(CXTPApplication *pApplication) | CXTPSkinManager | protectedvirtual
OnSkinChanged(BOOL bPrevState, BOOL bNewState) | CXTPSkinManager | virtual
ReadSkinData(LPCTSTR lpszResourcePath, LPCTSTR lpszIniFileName) | CXTPSkinManager | protected
RedrawAllControls() | CXTPSkinManager |
Remove(HWND hWnd) | CXTPSkinManager |
RemoveAll(BOOL bDetach=TRUE) | CXTPSkinManager |
RemoveColorFilters() | CXTPSkinManager |
Resume() | CXTPSkinManager |
SetApplyOptions(DWORD dwOptions) | CXTPSkinManager |
SetAutoApplyNewThreads(BOOL bAutoApply) | CXTPSkinManager |
SetAutoApplyNewWindows(BOOL bAutoApply) | CXTPSkinManager |
SetHook(HWND hWnd, LPCTSTR lpszClassName, LPCREATESTRUCT lpcs, BOOL bAuto) | CXTPSkinManager | protectedvirtual
SetResourceFile(CXTPSkinManagerResourceFile *pResourceFile) | CXTPSkinManager |
SetSkinManager(CXTPSkinManager *pSkinManager, BOOL bDelete=TRUE) | CXTPSkinManager | static
SetWindowFilter(IXTPSkinManagerWindowFilter *pFilter) | CXTPSkinManager |
SetWindowTheme(HWND hWnd, CXTPSkinManagerSchema *pSchema) | CXTPSkinManager |
Suspend() | CXTPSkinManager |
XTPSkinManager() | CXTPSkinManager | friend
~CXTPSkinManager() | CXTPSkinManager | virtual


Toolkit Pro: XTPMarkupColumnDefinitionCollection.h Source File

  • Source
  • Markup
  • Controls
XTPMarkupColumnDefinitionCollection.h
Go to the documentation of this file.
1
23#if !defined(__XTPMARKUPCOLUMNDEFINITIONCOLLECTION_H__)
24# define __XTPMARKUPCOLUMNDEFINITIONCOLLECTION_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPMarkupColumnDefinitionCollection : public CXTPMarkupDefinitionCollection
39{
41 DECLARE_MARKUPCLASS(CXTPMarkupColumnDefinitionCollection);
43public:
48 CXTPMarkupColumnDefinitionCollection();
49};
50
51# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
53#endif // !defined(__XTPMARKUPCOLUMNDEFINITIONCOLLECTION_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPMarkupColumnDefinitionCollection
CXTPMarkupColumnDefinitionCollection is a CXTPMarkupDefinitionCollection derived class.
Definition XTPMarkupColumnDefinitionCollection.h:39
CXTPMarkupColumnDefinitionCollection::CXTPMarkupColumnDefinitionCollection
CXTPMarkupColumnDefinitionCollection()
Constructs a CXTPMarkupColumnDefinitionCollection object.
CXTPMarkupDefinitionCollection
CXTPMarkupDefinitionCollection is the base class for CXTPMarkupDefinitionCollection and CXTPMarkupDef...
Definition XTPMarkupGrid.h:45


Toolkit Pro: Member List

CXTPColorSelectorCtrl Member List

This is the complete list of members for CXTPColorSelectorCtrl, including all inherited members.

AddListener(HWND hwndListener) | CXTPColorSelectorCtrl |
AddRecentColor(COLORREF clrRecent) | CXTPColorSelectorCtrl | static
CalcSize() | CXTPColorSelectorCtrl | protectedvirtual
CColorCellList typedef | CXTPColorSelectorCtrl | protected
CListenerArray typedef | CXTPColorSelectorCtrl | protected
Create(CRect rect, CWnd *pParentWnd, DWORD dwPopup, COLORREF clrColor, COLORREF clrDefault=CLR_DEFAULT) | CXTPColorSelectorCtrl |
CXTPColorSelectorCtrl() | CXTPColorSelectorCtrl |
DrawColorSelector(CDC *pDC) | CXTPColorSelectorCtrl | protected
EndSelection(int nCurSel) | CXTPColorSelectorCtrl | protectedvirtual
GetBorderRect() const | CXTPColorSelectorCtrl |
GetButtonSize() const | CXTPColorSelectorCtrl |
GetCellFromIndex(int iIndex) | CXTPColorSelectorCtrl |
GetColorCellList() | CXTPColorSelectorCtrl |
GetCurColor() const | CXTPColorSelectorCtrl |
GetCurSel(COLOR_CELL *pColorCell) | CXTPColorSelectorCtrl |
GetCurSel() const | CXTPColorSelectorCtrl |
GetCustomTitle() | CXTPColorSelectorCtrl |
GetDefColor() const | CXTPColorSelectorCtrl |
GetExtendedColors() | CXTPColorSelectorCtrl |
GetExtendedCount() const | CXTPColorSelectorCtrl |
GetNumCols() const | CXTPColorSelectorCtrl |
GetPopupStyle() const | CXTPColorSelectorCtrl |
GetPressed() const | CXTPColorSelectorCtrl |
GetRecentColors() | CXTPColorSelectorCtrl | static
GetStandardColors() | CXTPColorSelectorCtrl |
GetStandardTitle() | CXTPColorSelectorCtrl |
GetTheme() | CXTPColorSelectorCtrl |
GetThemeColors() | CXTPColorSelectorCtrl |
GetThemeTip(LPCTSTR lpszColor, LPCTSTR lpszDesc, int nShade) | CXTPColorSelectorCtrl |
GetThemeTitle() | CXTPColorSelectorCtrl |
GetToolTipCtrl() | CXTPColorSelectorCtrl |
HasCaptions() const | CXTPColorSelectorCtrl |
IsColorDlgVisible() | CXTPColorSelectorCtrl |
IsColorStatic(CDC *pDC) const | CXTPColorSelectorCtrl |
LookUpColor(const COLORREF crFind) | CXTPColorSelectorCtrl | protected
m_arCells | CXTPColorSelectorCtrl | protected
m_arRecentColors | CXTPColorSelectorCtrl | static
m_arStandardColors | CXTPColorSelectorCtrl | protected
m_arThemeColors | CXTPColorSelectorCtrl | protected
m_bCaptions | CXTPColorSelectorCtrl | protected
m_clrColor | CXTPColorSelectorCtrl | protected
m_clrDefault | CXTPColorSelectorCtrl | protected
m_dwPopup | CXTPColorSelectorCtrl | protected
m_listeners | CXTPColorSelectorCtrl | protected
m_nCols | CXTPColorSelectorCtrl | protected
m_nCurSel | CXTPColorSelectorCtrl | protected
m_nExtendedColors | CXTPColorSelectorCtrl | protected
m_nPressed | CXTPColorSelectorCtrl | protected
m_pColorDlg | CXTPColorSelectorCtrl | protected
m_pExtendedColors | CXTPColorSelectorCtrl | protected
m_point | CXTPColorSelectorCtrl | protected
m_pParentWnd | CXTPColorSelectorCtrl | protected
m_pTheme | CXTPColorSelectorCtrl | protected
m_rcBorders | CXTPColorSelectorCtrl | protected
m_rcWnd | CXTPColorSelectorCtrl | protected
m_strTitleCustom | CXTPColorSelectorCtrl | protected
m_strTitleRecent | CXTPColorSelectorCtrl | static
m_strTitleStandard | CXTPColorSelectorCtrl | protected
m_strTitleTheme | CXTPColorSelectorCtrl | protected
m_tooltip | CXTPColorSelectorCtrl | protected
ModifyPopupStyle(DWORD dwRemove, DWORD dwAdd) | CXTPColorSelectorCtrl |
OnEndSelection(int nCurSel, LPARAM callerParam) | CXTPColorSelectorCtrl | protectedvirtual
RefreshMetrics() | CXTPColorSelectorCtrl | protectedvirtual
RemoveListener(HWND hwndListener) | CXTPColorSelectorCtrl |
ResetRecentColors() | CXTPColorSelectorCtrl | static
SelectColor(COLORREF clr) | CXTPColorSelectorCtrl |
SelectColorCell(COLOR_CELL *pColorCell) | CXTPColorSelectorCtrl | virtual
SetBorders(int l=0, int t=0, int r=0, int b=0) | CXTPColorSelectorCtrl |
SetColors(XTP_PICK_BUTTON *pColors, int nCount, int nCols=8, LPCTSTR lpszTitle=NULL) | CXTPColorSelectorCtrl |
SetColors(CXTPPickBtnArray &arColors, const XTP_PICK_BUTTON *pColors, const int nCount) | CXTPColorSelectorCtrl | protected
SetCurSel(int nIndex) | CXTPColorSelectorCtrl |
SetRecentColors(const CUIntArray &arRecentColors, LPCTSTR lpszTitle=NULL) | CXTPColorSelectorCtrl | static
SetStandardColors(XTP_PICK_BUTTON *pColors=NULL, int nCount=10, int nCols=10, LPCTSTR lpszTitle=NULL) | CXTPColorSelectorCtrl |
SetStandardColors(CXTPPickBtnArray &arColors, int nCols=10, LPCTSTR lpszTitle=NULL) | CXTPColorSelectorCtrl |
SetTheme(XTPControlTheme eTheme) | CXTPColorSelectorCtrl |
SetTheme(CXTPColorSelectorCtrlTheme *pTheme) | CXTPColorSelectorCtrl |
SetThemeColors(XTP_PICK_BUTTON *pColors=NULL, int nCount=10, LPCTSTR lpszTitle=NULL, UINT *pStringIDs=NULL, int ppShadeMatrix[6][10]=NULL) | CXTPColorSelectorCtrl |
SetThemeColors(XTP_PICK_BUTTON *pColors, int nCount, LPCTSTR lpszTitle, LPCTSTR *ppszStrings, int ppShadeMatrix[6][10]) | CXTPColorSelectorCtrl |
SetThemeColors(CXTPPickBtnArray &arColors, int nCols=10, LPCTSTR lpszTitle=NULL) | CXTPColorSelectorCtrl |
ShowCaptions(BOOL bShow) | CXTPColorSelectorCtrl |
~CXTPColorSelectorCtrl() | CXTPColorSelectorCtrl | virtual


Toolkit Pro: Member List

XTP_EDIT_COLLAPSEDBLOCK Member List

This is the complete list of members for XTP_EDIT_COLLAPSEDBLOCK, including all inherited members.

collBlock | XTP_EDIT_COLLAPSEDBLOCK
rcCollMark | XTP_EDIT_COLLAPSEDBLOCK


Toolkit Pro: Member List

CXTPChart3dPyramidSeriesLabelsViewDeviceCommand Member List

This is the complete list of members for CXTPChart3dPyramidSeriesLabelsViewDeviceCommand, including all inherited members.

AddChildCommand(CXTPChartDeviceCommand *pCommand) | CXTPChartDeviceCommand |
AfterExecute(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
ApplySeriesStyle(CXTPChartSeriesStyle *pStyle) | CXTPChartDeviceCommand | virtual
BeforeExecute(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
BindView(CXTPChartElementView *pView) | CXTPChartDeviceCommand |
Commit() | CXTPChartDeviceCommand |
CXTPChart3dDeviceCommand(XTPChart3dAntialiasingPolicy nAntialiasingPolicy) | CXTPChart3dDeviceCommand | protected
CXTPChart3dPyramidSeriesLabelsViewDeviceCommand(CXTPChart3dPyramidSeriesLabelsView *pSeriesLabelsView) | CXTPChart3dPyramidSeriesLabelsViewDeviceCommand |
CXTPChartDeviceCommand() | CXTPChartDeviceCommand |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPObservable() | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | protected
Execute(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
ExecuteOverride(CXTPChartDeviceContext *pDC) | CXTPChart3dPyramidSeriesLabelsViewDeviceCommand | virtual
GetBoundView() const | CXTPChartDeviceCommand |
GetChildCommand(int nIndex) const | CXTPChartDeviceCommand |
GetChildCommandCount() const | CXTPChartDeviceCommand |
GetCurrentDC() const | CXTPChartDeviceCommand |
GetPassNumber() const | CXTPChartDeviceCommand |
HitTest(CPoint point, CXTPChartElement *pParent) const | CXTPChartDeviceCommand | virtual
Is3D() const | CXTPChartObject |
IsCommitted() const | CXTPChartDeviceCommand |
IsEnabled() const | CXTPChart3dDeviceCommand | virtual
m_arrChildren | CXTPChartDeviceCommand | protected
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Prepare(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
PrepareOverride(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
SetEnabled(BOOL bEnabled=TRUE) | CXTPChartDeviceCommand |
Subscribe(CXTPChartDeviceCommandEvents *pObserver, CXTPSubscriptionList< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > *pSubcriptionList=NULL) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > |
Unsubscribe(CXTPChartDeviceCommandEvents *pObserver) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > |
~CXTPChartDeviceCommand() | CXTPChartDeviceCommand | virtual
~CXTPObservable() | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | protected


Toolkit Pro: Member List

CXTPSyntaxEditPaintManager Member List

This is the complete list of members for CXTPSyntaxEditPaintManager, including all inherited members.

CreateFontIndirect(LPLOGFONT pLogfont, BOOL bUpdateReg=FALSE) | CXTPSyntaxEditPaintManager |
CXTPCmdTarget() | CXTPCmdTarget |
CXTPSyntaxEditPaintManager() | CXTPSyntaxEditPaintManager |
DrawCollapsedTextMarks(CXTPSyntaxEditCtrl *pEditCtrl, CDC *pDC) | CXTPSyntaxEditPaintManager | virtual
DrawLineCalcSel(const XTP_EDIT_TEXTBLOCK &txtBlk, int nSelStartX, int nSelEndX, XTP_EDIT_TEXTBLOCK(&arTxtBlk)[4], BOOL(&bUseBlk)[4]) | CXTPSyntaxEditPaintManager | virtual
DrawLineMark(CXTPSyntaxEditCtrl *pEditCtrl, XTP_EDIT_SENMBOOKMARK *pBookmark) | CXTPSyntaxEditPaintManager | protectedvirtual
DrawLineMarks(CDC *pDC, const CRect &rcRect, int nTextRow, CXTPSyntaxEditCtrl *pEditCtrl) | CXTPSyntaxEditPaintManager | virtual
DrawLineNode(CDC *pDC, const CRect &rcNode, const CRect &rcNodeFull, DWORD dwType, int nTextRow, CXTPSyntaxEditCtrl *pEditCtrl) | CXTPSyntaxEditPaintManager | virtual
DrawLineNodeBackground(CDC *pDC, const CRect &rcNodeFull, DWORD dwType, int nTextRow, CXTPSyntaxEditCtrl *pEditCtrl) | CXTPSyntaxEditPaintManager | virtual
DrawLineNumber(CDC *pDC, const CRect &rcRect, int nTextRow, CXTPSyntaxEditCtrl *pEditCtrl) | CXTPSyntaxEditPaintManager | virtual
DrawLineNumbersBorder(CDC *pDC, const CRect &rcLineNum, const COLORREF clrBorder) | CXTPSyntaxEditPaintManager | protectedvirtual
DrawLineTextEx(CDC *pDC, const CRect &rcTextLine, int nTextRow, int nLine, CXTPSyntaxEditCtrl *pEditCtrl) | CXTPSyntaxEditPaintManager | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetBackColor() const | CXTPSyntaxEditPaintManager |
GetBackColorEx(CXTPSyntaxEditCtrl *pEditCtrl) | CXTPSyntaxEditPaintManager |
GetBookmarks() | CXTPSyntaxEditPaintManager | protectedvirtual
GetBreakpointBackColor() const | CXTPSyntaxEditPaintManager |
GetBreakpointTextColor() const | CXTPSyntaxEditPaintManager |
GetCurArrow() | CXTPSyntaxEditPaintManager |
GetCurCopy() | CXTPSyntaxEditPaintManager |
GetCurIBeam() | CXTPSyntaxEditPaintManager |
GetCurLine() | CXTPSyntaxEditPaintManager |
GetCurMove() | CXTPSyntaxEditPaintManager |
GetCurNO() | CXTPSyntaxEditPaintManager |
GetFont() | CXTPSyntaxEditPaintManager |
GetFontLineNumber() | CXTPSyntaxEditPaintManager |
GetFontText() | CXTPSyntaxEditPaintManager |
GetFontToolTip() | CXTPSyntaxEditPaintManager |
GetHiliteBackColor() const | CXTPSyntaxEditPaintManager |
GetHiliteTextColor() const | CXTPSyntaxEditPaintManager |
GetInactiveHiliteBackColor() const | CXTPSyntaxEditPaintManager |
GetInactiveHiliteTextColor() const | CXTPSyntaxEditPaintManager |
GetLineNumberBackColor() const | CXTPSyntaxEditPaintManager |
GetLineNumberTextColor() const | CXTPSyntaxEditPaintManager |
GetTextColor() const | CXTPSyntaxEditPaintManager |
InitBitmaps() | CXTPSyntaxEditPaintManager | virtual
m_clrValues | CXTPSyntaxEditPaintManager | protected
m_hCurArrow | CXTPSyntaxEditPaintManager | protected
m_hCurCopy | CXTPSyntaxEditPaintManager | protected
m_hCurIBeam | CXTPSyntaxEditPaintManager | protected
m_hCurLine | CXTPSyntaxEditPaintManager | protected
m_hCurMove | CXTPSyntaxEditPaintManager | protected
m_hCurNO | CXTPSyntaxEditPaintManager | protected
m_penGray | CXTPSyntaxEditPaintManager | protected
m_sLineNumberFormat | CXTPSyntaxEditPaintManager |
m_xtpFont | CXTPSyntaxEditPaintManager | protected
m_xtpFontLineNumber | CXTPSyntaxEditPaintManager | protected
m_xtpFontText | CXTPSyntaxEditPaintManager | protected
m_xtpFontToolTip | CXTPSyntaxEditPaintManager | protected
PrintLineTextEx(CDC *pDC, const CRect &rcTextLine, int nTextRow, int nLine, CXTPSyntaxEditCtrl *pEditCtrl, int nFlags=0) | CXTPSyntaxEditPaintManager | virtual
RefreshMetrics() | CXTPSyntaxEditPaintManager | virtual
SetBackColor(COLORREF crBack, BOOL bUpdateReg=FALSE) | CXTPSyntaxEditPaintManager |
SetBreakpointBackColor(COLORREF color, BOOL bUpdateReg=FALSE) | CXTPSyntaxEditPaintManager |
SetBreakpointTextColor(COLORREF color, BOOL bUpdateReg=FALSE) | CXTPSyntaxEditPaintManager |
SetCopyCursor(HCURSOR hCurCopy) | CXTPSyntaxEditPaintManager |
SetFont(LPLOGFONT pLogfont) | CXTPSyntaxEditPaintManager |
SetFontLineNumber(LPLOGFONT pLogfont) | CXTPSyntaxEditPaintManager |
SetFontText(LPLOGFONT pLogfont) | CXTPSyntaxEditPaintManager |
SetFontToolTip(LPLOGFONT pLogfont) | CXTPSyntaxEditPaintManager |
SetHiliteBackColor(COLORREF color, BOOL bUpdateReg=FALSE) | CXTPSyntaxEditPaintManager |
SetHiliteTextColor(COLORREF color, BOOL bUpdateReg=FALSE) | CXTPSyntaxEditPaintManager |
SetInactiveHiliteBackColor(COLORREF color, BOOL bUpdateReg=FALSE) | CXTPSyntaxEditPaintManager |
SetInactiveHiliteTextColor(COLORREF color, BOOL bUpdateReg=FALSE) | CXTPSyntaxEditPaintManager |
SetLineNumberBackColor(COLORREF color, BOOL bUpdateReg=FALSE) | CXTPSyntaxEditPaintManager |
SetLineNumberTextColor(COLORREF color, BOOL bUpdateReg=FALSE) | CXTPSyntaxEditPaintManager |
SetLineSelCursor(HCURSOR hCurLine) | CXTPSyntaxEditPaintManager |
SetMoveCursor(HCURSOR hCurMove) | CXTPSyntaxEditPaintManager |
SetReadOnlyBackColor(COLORREF crBack, BOOL bUpdateReg=FALSE) | CXTPSyntaxEditPaintManager |
SetTextColor(COLORREF crText, BOOL bUpdateReg=FALSE) | CXTPSyntaxEditPaintManager |
UpdateTextFont(CXTPSyntaxEditCtrl *pEditCtrl, const XTP_EDIT_FONTOPTIONS &lf) | CXTPSyntaxEditPaintManager | virtual
~CXTPSyntaxEditPaintManager() | CXTPSyntaxEditPaintManager | virtual


Toolkit Pro: XTPProgressBase.h Source File

  • Source
  • Common
  • Controls
  • Progress
XTPProgressBase.h
Go to the documentation of this file.
1
23#if !defined(__XTPPROGRESSBASE_H__)
24# define __XTPPROGRESSBASE_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPProgressPaintManager;
34
39class _XTP_EXT_CLASS CXTPProgressBase
40{
41public:
46 CXTPProgressBase();
47
52 virtual ~CXTPProgressBase();
53
54public:
61 void SetRange(int nLower, int nUpper);
62
69 void GetRange(int& nLower, int& nUpper) const;
70
78 int GetPos() const;
79
86 void SetPos(int nPos);
87
88public:
94 virtual CRect GetProgressRect() = 0;
95
96protected:
101 virtual void RedrawProgress() = 0;
102
108 virtual CXTPProgressPaintManager* GetProgressPaintManager() const = 0;
109
110protected:
111 int m_nMin;
112 int m_nMax;
113 int m_nPos;
114};
115
116# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
118#endif // !defined(__XTPPROGRESSBASE_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPProgressBase
CXTPControlProgressBase is base class for all progress objects.
Definition XTPProgressBase.h:40
CXTPProgressBase::CXTPProgressBase
CXTPProgressBase()
Constructs a CXTPProgressBase object.
CXTPProgressBase::SetPos
void SetPos(int nPos)
Sets the current position of the progress bar, whose return value is always between the values for th...
CXTPProgressBase::GetProgressPaintManager
virtual CXTPProgressPaintManager * GetProgressPaintManager() const =0
This method is called to retrieve pointer to CXTPProgressPaintManager.
CXTPProgressBase::~CXTPProgressBase
virtual ~CXTPProgressBase()
Destroys a CXTPProgressBase object, handles cleanup and deallocation.
CXTPProgressBase::m_nMin
int m_nMin
Minimum.
Definition XTPProgressBase.h:111
CXTPProgressBase::m_nPos
int m_nPos
Current position.
Definition XTPProgressBase.h:113
CXTPProgressBase::GetRange
void GetRange(int &nLower, int &nUpper) const
Gets the upper and lower limits of the progress bar control's range.
CXTPProgressBase::SetRange
void SetRange(int nLower, int nUpper)
Sets the upper and lower limits of the progress bar control's range.
CXTPProgressBase::RedrawProgress
virtual void RedrawProgress()=0
This method is called to redraw progress bar.
CXTPProgressBase::m_nMax
int m_nMax
Maximum.
Definition XTPProgressBase.h:112
CXTPProgressBase::GetPos
int GetPos() const
Gets the current position of the progress bar, whose return value is always between the values for th...
CXTPProgressBase::GetProgressRect
virtual CRect GetProgressRect()=0
This method is called to get bounding rectangle of progressbar.
CXTPProgressPaintManager
CXTPProgressPaintManager object.
Definition XTPProgressPaintManager.h:41


Toolkit Pro: Member List

CXTPProgressCtrlThemeOfficeXP Member List

This is the complete list of members for CXTPProgressCtrlThemeOfficeXP, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPProgressCtrlPaintManager() | CXTPProgressCtrlPaintManager |
CXTPProgressCtrlThemeOffice2000() | CXTPProgressCtrlThemeOffice2000 |
CXTPProgressCtrlThemeOfficeXP() | CXTPProgressCtrlThemeOfficeXP |
DeflateRect(XTPPROGRESSDRAWSTRUCT &ds) | CXTPProgressCtrlPaintManager | protectedvirtual
Draw(XTPPROGRESSDRAWSTRUCT &ds) | CXTPProgressCtrlPaintManager | virtual
DrawNcBorders(CDC *pDC, CRect rc) | CXTPProgressCtrlThemeOfficeXP | virtual
DrawText(XTPPROGRESSDRAWSTRUCT &ds) | CXTPProgressCtrlPaintManager | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetBackColor() | CXTPProgressCtrlPaintManager |
GetBarColor() | CXTPProgressCtrlPaintManager |
GetBorderColor() | CXTPProgressCtrlPaintManager |
GetTextColor() | CXTPProgressCtrlPaintManager |
m_bUseWinTheme | CXTPProgressCtrlPaintManager | protected
m_clrBack | CXTPProgressCtrlPaintManager | protected
m_clrBar | CXTPProgressCtrlPaintManager | protected
m_clrBarText | CXTPProgressCtrlPaintManager | protected
m_clrBorder | CXTPProgressCtrlPaintManager | protected
m_clrText | CXTPProgressCtrlPaintManager | protected
m_nTheme | CXTPProgressCtrlPaintManager | protected
m_winTheme | CXTPProgressCtrlPaintManager | protected
RefreshMetrics() | CXTPProgressCtrlPaintManager | virtual
SetBackColor(COLORREF clrNew) | CXTPProgressCtrlPaintManager |
SetBarColor(COLORREF clrNew) | CXTPProgressCtrlPaintManager |
SetBorderColor(COLORREF clrNew) | CXTPProgressCtrlPaintManager |
SetTextColor(COLORREF clrNew) | CXTPProgressCtrlPaintManager |
UseWinThemes(BOOL bUseWinThemes=TRUE) | CXTPProgressCtrlPaintManager |
UsingWinThemes(BOOL bCheckReady=FALSE) | CXTPProgressCtrlPaintManager |
~CXTPProgressCtrlPaintManager() | CXTPProgressCtrlPaintManager | virtual


Toolkit Pro: Member List

CXTPWebBrowserProvider Member List

This is the complete list of members for CXTPWebBrowserProvider, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPWebBrowserProvider(IXTPWebBrowserHost &host) | CXTPWebBrowserProvider | protected
ExecuteScript(LPCWSTR pText, CComVariant *pvtResult=NULL)=0 | CXTPWebBrowserProvider | pure virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetBrowserObject() const | CXTPWebBrowserProvider |
GetClientInterface(REFIID riid) const | CXTPWebBrowserProvider |
m_Host | CXTPWebBrowserProvider | protected
RemoveClientInterface(REFIID riid) | CXTPWebBrowserProvider |
SetClientInterface(REFIID riid, IUnknown *pUnk) | CXTPWebBrowserProvider |
~CXTPWebBrowserProvider() | CXTPWebBrowserProvider | virtual


Toolkit Pro: Member List

CXTPMarkupGridLength Member List

This is the complete list of members for CXTPMarkupGridLength, including all inherited members.

ConvertFrom(CXTPMarkupBuilder *pBuilder, CXTPMarkupObject *pObject) const | CXTPMarkupGridLength |
CXTPCmdTarget() | CXTPCmdTarget |
CXTPMarkupGridLength(double nValue=0, GridUnitType type=unitTypePixel) | CXTPMarkupGridLength |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetUnitType() const | CXTPMarkupGridLength |
GetValue() const | CXTPMarkupGridLength |
GridUnitType enum name | CXTPMarkupGridLength |
IsAuto() const | CXTPMarkupGridLength | inline
IsStar() const | CXTPMarkupGridLength | inline
m_nValue | CXTPMarkupGridLength |
m_type | CXTPMarkupGridLength |
unitTypeAuto enum value | CXTPMarkupGridLength |
unitTypePixel enum value | CXTPMarkupGridLength |
unitTypeStar enum value | CXTPMarkupGridLength |


Toolkit Pro: XTPEditThemeVisualStudio2015.h Source File

  • Source
  • Controls
  • Edit
  • Themes
XTPEditThemeVisualStudio2015.h
Go to the documentation of this file.
1
23#if !defined(__XTPEDITTHEMEVISUALSTUDIO2015_H__)
24# define __XTPEDITTHEMEVISUALSTUDIO2015_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
37class _XTP_EXT_CLASS CXTPEditThemeVisualStudio2015 : public CXTPEditThemeOffice2013
38{
39public:
44 CXTPEditThemeVisualStudio2015();
45
50 virtual ~CXTPEditThemeVisualStudio2015();
51};
52
53# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
55#endif // __XTPEDITTHEMEVISUALSTUDIO2015_H__
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPEditThemeOffice2013
CXTPEditThemeOffice2013 is a class used to perform theme drawing tasks.
Definition XTPEditThemeOffice2013.h:38
CXTPEditThemeVisualStudio2015
CXTPEditThemeVisualStudio2015 is a class used to perform theme drawing tasks.
Definition XTPEditThemeVisualStudio2015.h:38
CXTPEditThemeVisualStudio2015::~CXTPEditThemeVisualStudio2015
virtual ~CXTPEditThemeVisualStudio2015()
Destructor, handles cleanup and deallocation.
CXTPEditThemeVisualStudio2015::CXTPEditThemeVisualStudio2015
CXTPEditThemeVisualStudio2015()
Constructs a CXTPEditThemeVisualStudio2015 object.


Toolkit Pro: Member List

XTP_NM_GRIDDRAGDROP Member List

This is the complete list of members for XTP_NM_GRIDDRAGDROP, including all inherited members.

bAbove | XTP_NM_GRIDDRAGDROP
bReturnValue | XTP_NM_GRIDDRAGDROP
dropEffect | XTP_NM_GRIDDRAGDROP
dwKeyState | XTP_NM_GRIDDRAGDROP
hdr | XTP_NM_GRIDDRAGDROP
nState | XTP_NM_GRIDDRAGDROP
nTargetRow | XTP_NM_GRIDDRAGDROP
pDataObject | XTP_NM_GRIDDRAGDROP
pDataSource | XTP_NM_GRIDDRAGDROP
pRecords | XTP_NM_GRIDDRAGDROP
pt | XTP_NM_GRIDDRAGDROP
pTargetRecord | XTP_NM_GRIDDRAGDROP


Toolkit Pro: XTPMarkupPath.h Source File

  • Source
  • Markup
  • Shapes
XTPMarkupPath.h
Go to the documentation of this file.
1
23#if !defined(__XTPMARKUPPATH_H__)
24# define __XTPMARKUPPATH_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPMarkupPathData;
34class CXTPMarkupBuilder;
35class CXTPMarkupObject;
36class CXTPMarkupDrawingContext;
37class CXTPMarkupDependencyProperty;
38
39class _XTP_EXT_CLASS CXTPMarkupPath : public CXTPMarkupShape
40{
42 DECLARE_MARKUPCLASS(CXTPMarkupPath)
44protected:
45 CXTPMarkupPath();
46 virtual ~CXTPMarkupPath();
47
48public:
49 CXTPMarkupPathData* GetData() const;
50
51protected:
52 void SetContentObject(CXTPMarkupBuilder* pBuilder, CXTPMarkupObject* pContent);
53
54protected:
55 virtual CSize MeasureOverride(CXTPMarkupDrawingContext* pDC, CSize szAvailableSize);
56 virtual void OnRender(CXTPMarkupDrawingContext* pDC);
57
59public:
60 DECLARE_DISPATCH_MAP()
61# ifdef _XTP_ACTIVEX
62 DECLARE_INTERFACE_MAP()
63 DECLARE_OLETYPELIB_EX(CXTPMarkupPath);
64# endif
65
68public:
69 static CXTPMarkupDependencyProperty* m_pPropertyData;
70};
71
72# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
74#endif // !defined(__XTPMARKUPPATH_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPMarkupVisual::OnRender
virtual void OnRender(CXTPMarkupDrawingContext *drawingContext)
When overridden in a derived class, participates in rendering operations that are directed by the lay...
Definition XTPMarkupInputElement.h:515


Toolkit Pro: XTPGlobal.h Source File

  • Source
  • Controls
  • Util
XTPGlobal.h
Go to the documentation of this file.
1
23#if !defined(__XTGLOBALS_H__)
24# define __XTGLOBALS_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
40class _XTP_EXT_CLASS CXTPTcbItem
41{
42public:
47 CXTPTcbItem();
48
49 UINT uiToolTipId;
50 CWnd* pWnd;
51 CString szTabLabel;
52 CString szToolTipLabel;
53 CString szCondensedLabel;
54 DWORD dwStyle;
55 DWORD dwExStyle;
56 COLORREF crTabBack;
57 COLORREF crTabText;
58 COLORREF crTabSelBack;
59 COLORREF crTabSelText;
60};
61
68class _XTP_EXT_CLASS CXTPLogFont : public LOGFONT
69{
70public:
75 CXTPLogFont();
76
82 CXTPLogFont(const CXTPLogFont& rhs);
83
89 CXTPLogFont(const LOGFONT& logFont);
90
91public:
99 CXTPLogFont& operator=(const CXTPLogFont& rhs);
100
108 CXTPLogFont& operator=(const LOGFONT& logFont);
109
110public:
111 DWORD dwType;
112};
114AFX_INLINE CXTPLogFont::CXTPLogFont()
115{
116 memset(this, 0, sizeof(*this));
117}
118
119AFX_INLINE CXTPLogFont::CXTPLogFont(const CXTPLogFont& rhs)
120{
121 *this = rhs;
122}
123
124AFX_INLINE CXTPLogFont::CXTPLogFont(const LOGFONT& logFont)
125{
126 *this = logFont;
127}
128
129AFX_INLINE CXTPLogFont& CXTPLogFont::operator=(const CXTPLogFont& rhs)
130{
131 memcpy(this, &rhs, sizeof(*this));
132 return *this;
133}
134
135AFX_INLINE CXTPLogFont& CXTPLogFont::operator=(const LOGFONT& logFont)
136{
137 memcpy(static_cast<LOGFONT*>(this), &logFont, sizeof(logFont));
138 return *this;
139}
141class CXTPAuxData;
142
162_XTP_EXT_CLASS CXTPAuxData& AFXAPI XTPAuxData();
163
171class _XTP_EXT_CLASS CXTPAuxData
172{
173 friend class CXTPSingleton<CXTPAuxData>;
174
175private:
180 CXTPAuxData();
181
182public:
187 virtual ~CXTPAuxData();
188
189public:
196 BOOL LoadSysCursors();
197
210 BOOL LoadSysFonts(LPCTSTR lpszHorzFaceName = NULL, LPCTSTR lpszVertFaceName = NULL);
211
216 void FreeSysFonts();
217
222 void UpdateSysColors();
223
228 void UpdateSysMetrics();
229
237 DWORD GetComCtlVersion();
238
246 BOOL IsComCtlValid() const;
247
253 void InitResources(HINSTANCE hInst);
254
264 void UseOfficeFont(BOOL bOfficeFont);
265
277 BOOL FontExists(LPCTSTR lpszFaceName);
278
296 BOOL CreateSysFont(const CXTPLogFont& lf, CFont& font, long lfWeight = -1,
297 char lfUnderline = -1, long lfOrientation = -1, long lfEscapement = -1);
298
316 BOOL CreateSysFont(const CXTPLogFont& lf, CXTPFont& font, long lfWeight = -1,
317 char lfUnderline = -1, long lfOrientation = -1, long lfEscapement = -1);
318
335 BOOL SetGlobalFont(CFont* pHorzFont, CFont* pVertFont = NULL);
336
352 BOOL SetGlobalFont(LPCTSTR lpszFaceName, LPCTSTR lpszVertFaceName = NULL);
353
367 CString XTPGetVersion(bool bVerNumOnly = false);
368
369private:
371 static int CALLBACK EnumFontFamExProc(ENUMLOGFONTEX* pelf, NEWTEXTMETRICEX*, int, LPVOID pThis);
372 DISABLE_COPY_OPERATOR(CXTPAuxData)
375public:
376 //=======================================================================
377 //## (RGB) System colors used by Xtreme Toolkit
378 //=======================================================================
379
380 COLORREF clr3DFace;
382 COLORREF clr3DShadow;
384 COLORREF clr3DDkShadow;
386 COLORREF clr3DHilight;
388 COLORREF clr3DLight;
390 COLORREF clrBtnText;
391 COLORREF clrGrayText;
392 COLORREF clrHighlight;
393 COLORREF clrHighlightText;
395 COLORREF clrMenu;
396 COLORREF clrMenuText;
397 COLORREF clrWindow;
398 COLORREF clrWindowFrame;
399 COLORREF clrWindowText;
400 COLORREF clrActiveCaption;
401 COLORREF clrInActiveCaption;
402 COLORREF clrGradActiveCapt;
403 COLORREF clrGradInActiveCapt;
405 COLORREF clrActiveCaptText;
406 COLORREF clrInactiveCaptText;
407 COLORREF clrXPBarFace;
408 COLORREF clrXPHighlight;
409 COLORREF clrXPHighlightBorder;
411 COLORREF clrXPHighlightPushed;
413 COLORREF clrXPIconShadow;
414 COLORREF clrXPGrayText;
416 COLORREF clrXPHighlightChecked;
418 COLORREF clrXPHighlightCheckedBorder;
420 COLORREF clrXPGripper;
421 COLORREF clrXPSeparator;
422 COLORREF clrXPDisabled;
423 COLORREF clrXPMenuTextBack;
425 COLORREF clrXPMenuExpanded;
427 COLORREF clrXPMenuBorder;
428 COLORREF clrXPMenuText;
429 COLORREF clrXPHighlightText;
431 COLORREF clrXPBarText;
432 COLORREF clrXPBarTextPushed;
434 COLORREF clrXPTabInactiveBack;
436 COLORREF clrXPTabInactiveText;
439 //=======================================================================
440 //## Cursors used by Xtreme Toolkit
441 //=======================================================================
442
443 HCURSOR hcurDragCopy;
444 HCURSOR hcurDragMove;
445 HCURSOR hcurDragNone;
446 HCURSOR hcurHand;
447 HCURSOR hcurHSplitBar;
448 HCURSOR hcurVSplitBar;
449 HCURSOR hcurMove;
451 //=======================================================================
452 //## System metrics
453 //=======================================================================
454
455 int cxSmIcon;
456 int cySmIcon;
457 int cxSize;
458 int cySize;
459 int cxHThumb;
460 int cyVThumb;
461 int cyMenuItem;
463 //=======================================================================
464 //## Fonts used by Xtreme Toolkit
465 //=======================================================================
466
467 CXTPFont xtpFont;
468 CXTPFont xtpFontBold;
469 CXTPFont xtpFontULine;
470 CXTPFont xtpFontVert;
471 CXTPFont xtpFontVertBold;
472 CXTPFont xtpFontIconTitle;
473 CXTPFont xtpFontIconTitleBold;
474 CXTPFont xtpFontMarlettIcon;
475 CXTPFont xtpFontStatus;
476 CXTPFont xtpFontSmCaption;
478 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CFont, font, xtpFont, GetFontHandle);
479 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CFont, fontBold, xtpFontBold, GetBoldFontHandle);
480 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CFont, fontULine, xtpFontULine, GetULineFontHandle);
481 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CFont, fontVert, xtpFontVert, GetVertFontHandle);
482 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CFont, fontVertBold, xtpFontVertBold,
483 GetVertBoldFontHandle);
484 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CFont, fontIconTitle, xtpFontIconTitle,
485 GetIconTitleFontHandle);
486 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CFont, fontIconTitleBold, xtpFontIconTitleBold,
487 GetIconTitleBoldFontHandle);
488 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CFont, fontMarlettIcon, xtpFontMarlettIcon,
489 GetMarlettIconFontHandle);
490 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CFont, fontStatus, xtpFontStatus, GetStatusFontHandle);
491 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CFont, fontSmCaption, xtpFontSmCaption,
492 GetSmCaptionFontHandle);
493
494 //=======================================================================
495 //## Flags used by Xtreme Toolkit
496 //=======================================================================
497
498 BOOL bWin95;
499 BOOL bWin98;
500 BOOL bWinNT;
501 BOOL bWin2K;
502 BOOL bWinXP;
503 BOOL bUseOfficeFont;
505 BOOL bUseSolidShadows;
507 BOOL bMenuShadows;
509 //=======================================================================
510 //## Miscellaneous settings
511 //=======================================================================
512
513 int iComCtlVersion;
515 friend _XTP_EXT_CLASS CXTPAuxData& AFXAPI XTPAuxData();
516};
517
519
520# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
522#endif // #if !defined(__XTGLOBALS_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPAuxData
_XTP_EXT_CLASS CXTPAuxData &AFXAPI XTPAuxData()
The XTPAuxData function is used for access to the CXTPAuxData class.
CXTPAuxData
CXTPAuxData is a standalone global item data structure class.
Definition XTPGlobal.h:172
CXTPAuxData::hcurHand
HCURSOR hcurHand
Hand cursor handle.
Definition XTPGlobal.h:446
CXTPAuxData::clrXPDisabled
COLORREF clrXPDisabled
An RGB value that represents the XP menu icon disabled color.
Definition XTPGlobal.h:422
CXTPAuxData::clrXPBarTextPushed
COLORREF clrXPBarTextPushed
An RGB value that represents the XP toolbar pushed text color.
Definition XTPGlobal.h:432
CXTPAuxData::hcurDragMove
HCURSOR hcurDragMove
Drag move cursor handle.
Definition XTPGlobal.h:444
CXTPAuxData::XTPAuxData
friend _XTP_EXT_CLASS CXTPAuxData &AFXAPI XTPAuxData()
The XTPAuxData function is used for access to the CXTPAuxData class.
CXTPAuxData::clr3DFace
COLORREF clr3DFace
An RGB value that represents the face color for three dimensional display elements.
Definition XTPGlobal.h:380
CXTPAuxData::cxSmIcon
int cxSmIcon
cx small icon size (width).
Definition XTPGlobal.h:455
CXTPAuxData::GetComCtlVersion
DWORD GetComCtlVersion()
This member function is called to retrieve the version information for the common control ....
CXTPAuxData::clrXPHighlightBorder
COLORREF clrXPHighlightBorder
An RGB value that represents the XP menu item selected border color.
Definition XTPGlobal.h:409
CXTPAuxData::xtpFontVertBold
CXTPFont xtpFontVertBold
Vertical menu bold font.
Definition XTPGlobal.h:471
CXTPAuxData::clrInactiveCaptText
COLORREF clrInactiveCaptText
An RGB value that represents the inactive caption text.
Definition XTPGlobal.h:406
CXTPAuxData::clrGradInActiveCapt
COLORREF clrGradInActiveCapt
An RGB value that represents the gradient inactive title bar.
Definition XTPGlobal.h:403
CXTPAuxData::clrXPMenuTextBack
COLORREF clrXPMenuTextBack
An RGB value that represents the XP menu item text background color.
Definition XTPGlobal.h:423
CXTPAuxData::InitResources
void InitResources(HINSTANCE hInst)
This member function is called by the library to initialize resources.
CXTPAuxData::xtpFontIconTitleBold
CXTPFont xtpFontIconTitleBold
Icon title bold font.
Definition XTPGlobal.h:473
CXTPAuxData::bMenuShadows
BOOL bMenuShadows
TRUE to use shadows under the menus.
Definition XTPGlobal.h:507
CXTPAuxData::UseOfficeFont
void UseOfficeFont(BOOL bOfficeFont)
Enables/disables Tahoma font usage for the library.
CXTPAuxData::clrXPGripper
COLORREF clrXPGripper
An RGB value that represents the XP toolbar gripper color.
Definition XTPGlobal.h:420
CXTPAuxData::UpdateSysMetrics
void UpdateSysMetrics()
This member function updates system metrics used by the library.
CXTPAuxData::clrXPHighlightChecked
COLORREF clrXPHighlightChecked
An RGB value that represents the XP menu item checked color.
Definition XTPGlobal.h:416
CXTPAuxData::cxHThumb
int cxHThumb
Width, in pixels, of the thumb box in a horizontal scrollbar.
Definition XTPGlobal.h:459
CXTPAuxData::clrWindowText
COLORREF clrWindowText
An RGB value that represents the text color in windows.
Definition XTPGlobal.h:399
CXTPAuxData::hcurHSplitBar
HCURSOR hcurHSplitBar
Horizontal Splitter cursor handle.
Definition XTPGlobal.h:447
CXTPAuxData::clrXPHighlightCheckedBorder
COLORREF clrXPHighlightCheckedBorder
An RGB value that represents the XP menu item checked border color.
Definition XTPGlobal.h:418
CXTPAuxData::clrMenuText
COLORREF clrMenuText
An RGB value that represents the text color in menus.
Definition XTPGlobal.h:396
CXTPAuxData::clr3DDkShadow
COLORREF clr3DDkShadow
An RGB value that represents the dark shadow for three dimensional display elements.
Definition XTPGlobal.h:384
CXTPAuxData::~CXTPAuxData
virtual ~CXTPAuxData()
Destroys an CXTPAuxData object, handles cleanup and deallocation.
CXTPAuxData::xtpFontULine
CXTPFont xtpFontULine
Menu underlined font.
Definition XTPGlobal.h:469
CXTPAuxData::clrMenu
COLORREF clrMenu
An RGB value that represents the menu background.
Definition XTPGlobal.h:395
CXTPAuxData::clrBtnText
COLORREF clrBtnText
An RGB value that represents the text color on push buttons.
Definition XTPGlobal.h:390
CXTPAuxData::cySize
int cySize
Height, in pixels, of a button in a window's caption or title bar.
Definition XTPGlobal.h:458
CXTPAuxData::cyMenuItem
int cyMenuItem
Height, in pixels, of single-line menu bar.
Definition XTPGlobal.h:461
CXTPAuxData::hcurDragCopy
HCURSOR hcurDragCopy
Drag copy cursor handle.
Definition XTPGlobal.h:443
CXTPAuxData::clr3DShadow
COLORREF clr3DShadow
An RGB value that represents the shadow color for three dimensional display elements.
Definition XTPGlobal.h:382
CXTPAuxData::clrXPSeparator
COLORREF clrXPSeparator
An RGB value that represents the XP toolbar separator color.
Definition XTPGlobal.h:421
CXTPAuxData::SetGlobalFont
BOOL SetGlobalFont(LPCTSTR lpszFaceName, LPCTSTR lpszVertFaceName=NULL)
Initializes the fonts used by the library.
CXTPAuxData::bWinNT
BOOL bWinNT
TRUE if Windows NT.
Definition XTPGlobal.h:500
CXTPAuxData::hcurVSplitBar
HCURSOR hcurVSplitBar
Vertical Splitter cursor handle.
Definition XTPGlobal.h:448
CXTPAuxData::xtpFontVert
CXTPFont xtpFontVert
Vertical menu font.
Definition XTPGlobal.h:470
CXTPAuxData::hcurMove
HCURSOR hcurMove
4 way move cursor handle.
Definition XTPGlobal.h:449
CXTPAuxData::bWinXP
BOOL bWinXP
TRUE if Windows XP.
Definition XTPGlobal.h:502
CXTPAuxData::xtpFontStatus
CXTPFont xtpFontStatus
Status bar font.
Definition XTPGlobal.h:475
CXTPAuxData::clrWindowFrame
COLORREF clrWindowFrame
An RGB value that represents the window frame.
Definition XTPGlobal.h:398
CXTPAuxData::bUseSolidShadows
BOOL bUseSolidShadows
TRUE to use solid shadows for operating systems that do not supported layered windows.
Definition XTPGlobal.h:505
CXTPAuxData::clrXPBarFace
COLORREF clrXPBarFace
An RGB value that represents the XP toolbar background color.
Definition XTPGlobal.h:407
CXTPAuxData::clrActiveCaptText
COLORREF clrActiveCaptText
An RGB value that represents the active caption text.
Definition XTPGlobal.h:405
CXTPAuxData::bUseOfficeFont
BOOL bUseOfficeFont
TRUE to use the Tahoma font if found, good for Office style applications by default.
Definition XTPGlobal.h:503
CXTPAuxData::xtpFont
CXTPFont xtpFont
Menu font.
Definition XTPGlobal.h:467
CXTPAuxData::clrXPGrayText
COLORREF clrXPGrayText
An RGB value that represents the XP menu item disabled text color.
Definition XTPGlobal.h:414
CXTPAuxData::clrGrayText
COLORREF clrGrayText
An RGB value that represents the grayed (disabled) text.
Definition XTPGlobal.h:391
CXTPAuxData::clrXPBarText
COLORREF clrXPBarText
An RGB value that represents the XP toolbar text color.
Definition XTPGlobal.h:431
CXTPAuxData::clr3DHilight
COLORREF clr3DHilight
An RGB value that represents the highlight color for three dimensional display elements.
Definition XTPGlobal.h:386
CXTPAuxData::CreateSysFont
BOOL CreateSysFont(const CXTPLogFont &lf, CXTPFont &font, long lfWeight=-1, char lfUnderline=-1, long lfOrientation=-1, long lfEscapement=-1)
Initializes the fonts used by the library.
CXTPAuxData::xtpFontSmCaption
CXTPFont xtpFontSmCaption
Small caption font.
Definition XTPGlobal.h:476
CXTPAuxData::bWin98
BOOL bWin98
TRUE if Windows 98.
Definition XTPGlobal.h:499
CXTPAuxData::cyVThumb
int cyVThumb
Height, in pixels, of the thumb box in a vertical scrollbar.
Definition XTPGlobal.h:460
CXTPAuxData::xtpFontBold
CXTPFont xtpFontBold
Menu bold font.
Definition XTPGlobal.h:468
CXTPAuxData::UpdateSysColors
void UpdateSysColors()
This member function updates system colors used by the library.
CXTPAuxData::clrGradActiveCapt
COLORREF clrGradActiveCapt
An RGB value that represents the gradient active title bar.
Definition XTPGlobal.h:402
CXTPAuxData::xtpFontIconTitle
CXTPFont xtpFontIconTitle
Icon title font.
Definition XTPGlobal.h:472
CXTPAuxData::LoadSysFonts
BOOL LoadSysFonts(LPCTSTR lpszHorzFaceName=NULL, LPCTSTR lpszVertFaceName=NULL)
Initializes the fonts used by the library.
CXTPAuxData::clrXPIconShadow
COLORREF clrXPIconShadow
An RGB value that represents the XP menu item icon shadow.
Definition XTPGlobal.h:413
CXTPAuxData::clrXPHighlightPushed
COLORREF clrXPHighlightPushed
An RGB value that represents the XP menu item pushed color.
Definition XTPGlobal.h:411
CXTPAuxData::hcurDragNone
HCURSOR hcurDragNone
Drag none cursor handle.
Definition XTPGlobal.h:445
CXTPAuxData::XTPGetVersion
CString XTPGetVersion(bool bVerNumOnly=false)
Retrieves the library version.
CXTPAuxData::clr3DLight
COLORREF clr3DLight
An RGB value that represents the light color for three dimensional display elements.
Definition XTPGlobal.h:388
CXTPAuxData::clrWindow
COLORREF clrWindow
An RGB value that represents the window background.
Definition XTPGlobal.h:397
CXTPAuxData::clrActiveCaption
COLORREF clrActiveCaption
An RGB value that represents the active window title bar.
Definition XTPGlobal.h:400
CXTPAuxData::iComCtlVersion
int iComCtlVersion
Common control .dll (comctl32.dll) version information.
Definition XTPGlobal.h:513
CXTPAuxData::clrXPMenuBorder
COLORREF clrXPMenuBorder
An RGB value that represents the XP menu border color.
Definition XTPGlobal.h:427
CXTPAuxData::clrXPHighlightText
COLORREF clrXPHighlightText
An RGB value that represents the XP menu item selected text color.
Definition XTPGlobal.h:429
CXTPAuxData::clrXPHighlight
COLORREF clrXPHighlight
An RGB value that represents the XP menu item selected color.
Definition XTPGlobal.h:408
CXTPAuxData::IsComCtlValid
BOOL IsComCtlValid() const
This member function is called to check the current version of the common control ....
CXTPAuxData::clrXPTabInactiveText
COLORREF clrXPTabInactiveText
An RGB value that represents the XP inactive tab text color.
Definition XTPGlobal.h:436
CXTPAuxData::clrInActiveCaption
COLORREF clrInActiveCaption
An RGB value that represents the inactive window title bar.
Definition XTPGlobal.h:401
CXTPAuxData::clrXPMenuText
COLORREF clrXPMenuText
An RGB value that represents the XP menu item text color.
Definition XTPGlobal.h:428
CXTPAuxData::cxSize
int cxSize
Width, in pixels, of a button in a window's caption or title bar.
Definition XTPGlobal.h:457
CXTPAuxData::bWin2K
BOOL bWin2K
TRUE if Windows 2000.
Definition XTPGlobal.h:501
CXTPAuxData::bWin95
BOOL bWin95
TRUE if Windows 95.
Definition XTPGlobal.h:498
CXTPAuxData::clrHighlightText
COLORREF clrHighlightText
An RGB value that represents the text color of item(s) selected in a control.
Definition XTPGlobal.h:393
CXTPAuxData::SetGlobalFont
BOOL SetGlobalFont(CFont *pHorzFont, CFont *pVertFont=NULL)
Initializes the fonts used by the library.
CXTPAuxData::clrXPTabInactiveBack
COLORREF clrXPTabInactiveBack
An RGB value that represents the XP inactive tab background color.
Definition XTPGlobal.h:434
CXTPAuxData::clrHighlight
COLORREF clrHighlight
An RGB value that represents the item(s) selected in a control.
Definition XTPGlobal.h:392
CXTPAuxData::cySmIcon
int cySmIcon
cy small icon size (height).
Definition XTPGlobal.h:456
CXTPAuxData::FreeSysFonts
void FreeSysFonts()
This member function frees font resources.
CXTPAuxData::CreateSysFont
BOOL CreateSysFont(const CXTPLogFont &lf, CFont &font, long lfWeight=-1, char lfUnderline=-1, long lfOrientation=-1, long lfEscapement=-1)
Initializes the fonts used by the library.
CXTPAuxData::xtpFontMarlettIcon
CXTPFont xtpFontMarlettIcon
Marlett icon font.
Definition XTPGlobal.h:474
CXTPAuxData::FontExists
BOOL FontExists(LPCTSTR lpszFaceName)
Determines if a font is installed.
CXTPAuxData::LoadSysCursors
BOOL LoadSysCursors()
Initializes the cursors used by the library.
CXTPAuxData::clrXPMenuExpanded
COLORREF clrXPMenuExpanded
An RGB value that represents the XP hidden menu commands background color.
Definition XTPGlobal.h:425
CXTPFont
Provides a convenient object oriented interface for HFONT GDI object and uses GDI handle caching.
Definition XTPGdiObjects.h:414
CXTPLogFont
CXTPLogFont is a self initializing LOGFONT derived class.
Definition XTPGlobal.h:69
CXTPLogFont::operator=
CXTPLogFont & operator=(const CXTPLogFont &rhs)
Assigns the specified value.
CXTPLogFont::operator=
CXTPLogFont & operator=(const LOGFONT &logFont)
Assigns the specified value.
CXTPLogFont::CXTPLogFont
CXTPLogFont(const LOGFONT &logFont)
Constructs a CXTPLogFont object.
CXTPLogFont::CXTPLogFont
CXTPLogFont()
Constructs a CXTPLogFont object.
CXTPLogFont::CXTPLogFont
CXTPLogFont(const CXTPLogFont &rhs)
Constructs a CXTPLogFont object.
CXTPLogFont::dwType
DWORD dwType
Used to hold the font type, i.e.
Definition XTPGlobal.h:111
CXTPSingleton
Implements Singleton design pattern.
Definition XTPSingleton.h:215
CXTPTcbItem
The CXTPTcbItem class is used to maintain information for a particular tab item in a CXTPExcelTabCtrl...
Definition XTPGlobal.h:41
CXTPTcbItem::uiToolTipId
UINT uiToolTipId
Resource ID for the tooltip.
Definition XTPGlobal.h:49
CXTPTcbItem::crTabText
COLORREF crTabText
Application defined tab text color.
Definition XTPGlobal.h:57
CXTPTcbItem::szToolTipLabel
CString szToolTipLabel
Tooltip text for the tab.
Definition XTPGlobal.h:52
CXTPTcbItem::dwStyle
DWORD dwStyle
Stores the window style when the tab item was created.
Definition XTPGlobal.h:54
CXTPTcbItem::pWnd
CWnd * pWnd
A CWnd pointer to the window associated with a tab.
Definition XTPGlobal.h:50
CXTPTcbItem::CXTPTcbItem
CXTPTcbItem()
Constructs a CXTPTcbItem object.
CXTPTcbItem::dwExStyle
DWORD dwExStyle
Stores the extended window style when the tab item was created.
Definition XTPGlobal.h:55
CXTPTcbItem::crTabBack
COLORREF crTabBack
Application defined tab background color.
Definition XTPGlobal.h:56
CXTPTcbItem::crTabSelBack
COLORREF crTabSelBack
Application defined selected tab background color.
Definition XTPGlobal.h:58
CXTPTcbItem::szCondensedLabel
CString szCondensedLabel
The label actually being displayed for auto-condensing tabs.
Definition XTPGlobal.h:53
CXTPTcbItem::szTabLabel
CString szTabLabel
User specified label for the tab.
Definition XTPGlobal.h:51
CXTPTcbItem::crTabSelText
COLORREF crTabSelText
Application defined selected tab text color.
Definition XTPGlobal.h:59


Toolkit Pro: XTPColorManager.h Source File

  • Source
  • Common
XTPColorManager.h
Go to the documentation of this file.
1
23#if !defined(__XTPCOLORMANAGER_H__)
24# define __XTPCOLORMANAGER_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
44enum XTPCurrentSystemTheme
45{
46 xtpSystemThemeUnknown,
47 xtpSystemThemeBlue,
48 xtpSystemThemeOlive,
49 xtpSystemThemeSilver,
50 xtpSystemThemeRoyale,
51 xtpSystemThemeAero,
52 xtpSystemThemeAuto,
53 xtpSystemThemeDefault
54};
55
57# ifndef COLOR_GRADIENTACTIVECAPTION
58# define COLOR_GRADIENTACTIVECAPTION 27
59# endif
60
61# ifndef COLOR_GRADIENTINACTIVECAPTION
62# define COLOR_GRADIENTINACTIVECAPTION 28
63# endif
64
65# ifndef COLORREF_NULL
66# define COLORREF_NULL ((COLORREF)-1)
67# endif
68
69# ifndef COLORREF_ERROR
70# define COLORREF_ERROR RGB(255, 0, 0)
71# endif
74const int XPCOLOR_BASE = 30;
75const int XPCOLOR_TOOLBAR_FACE = XPCOLOR_BASE;
76const int XPCOLOR_HIGHLIGHT = 31;
77const int XPCOLOR_HIGHLIGHT_BORDER = 32;
78const int XPCOLOR_HIGHLIGHT_PUSHED = 33;
79const int XPCOLOR_ICONSHADDOW = 34;
80const int XPCOLOR_MENUBAR_GRAYTEXT = 35;
81const int XPCOLOR_GRAYTEXT = XPCOLOR_MENUBAR_GRAYTEXT;
82const int XPCOLOR_HIGHLIGHT_CHECKED = 36;
83const int XPCOLOR_HIGHLIGHT_CHECKED_BORDER = 37;
84const int XPCOLOR_TOOLBAR_GRIPPER = 38;
85const int XPCOLOR_SEPARATOR = 39;
86const int XPCOLOR_DISABLED = 40;
87const int XPCOLOR_MENUBAR_FACE = 41;
88const int XPCOLOR_MENUBAR_EXPANDED = 42;
89const int XPCOLOR_MENUBAR_BORDER = 43;
90const int XPCOLOR_MENUBAR_TEXT = 44;
91const int XPCOLOR_HIGHLIGHT_TEXT = 45;
92const int XPCOLOR_CHECKED_TEXT = XPCOLOR_HIGHLIGHT_TEXT;
93const int XPCOLOR_TOOLBAR_TEXT = 46;
94const int XPCOLOR_PUSHED_TEXT = 47;
95const int XPCOLOR_TAB_INACTIVE_BACK = 48;
96const int XPCOLOR_TAB_INACTIVE_TEXT = 49;
97const int XPCOLOR_HIGHLIGHT_PUSHED_BORDER = 50;
98const int XPCOLOR_3DFACE = 51;
99const int XPCOLOR_3DSHADOW = 52;
100const int XPCOLOR_EDITCTRLBORDER = 53;
101const int XPCOLOR_FRAME = 54;
102const int XPCOLOR_SPLITTER_FACE = 55;
103const int XPCOLOR_LABEL = 56;
104const int XPCOLOR_STATICFRAME = 57;
105const int XPCOLOR_HIGHLIGHT_DISABLED_BORDER = 58;
106const int XPCOLOR_SHADOW_FACTOR = 59;
107const int XPCOLOR_TOOLBAR_GRAYTEXT = 60;
108const int XPCOLOR_FLOATBAR_BORDER = 61;
109const int XPCOLOR_LAST = 62;
116class _XTP_EXT_CLASS CXTPPaintManagerColor
117{
118public:
126 CXTPPaintManagerColor();
127
136 CXTPPaintManagerColor(COLORREF clr);
137
141 virtual ~CXTPPaintManagerColor()
142 {
143 }
144
152 BOOL IsDefaultValue() const;
153
162 BOOL IsStandardValue() const;
163
171 BOOL IsCustomValue() const;
172
180 COLORREF GetStandardColor() const;
181
188 void SetCustomValue(COLORREF clr);
189
196 void SetStandardValue(COLORREF clr);
197
203 void SetDefaultValue();
204
212 operator COLORREF() const;
213
223 const CXTPPaintManagerColor& operator=(COLORREF clr);
224
234 const CXTPPaintManagerColor& operator=(const CXTPPaintManagerColor& refclr);
235
241 virtual void Serialize(CArchive& ar);
242
243protected:
244 COLORREF m_clrStandardValue;
245 COLORREF m_clrCustomValue;
246};
247
249AFX_INLINE BOOL CXTPPaintManagerColor::IsDefaultValue() const
250{
251 return (m_clrCustomValue == COLORREF_NULL) && (m_clrStandardValue == COLORREF_NULL);
252}
253AFX_INLINE BOOL CXTPPaintManagerColor::IsStandardValue() const
254{
255 return (m_clrCustomValue == COLORREF_NULL) && (m_clrStandardValue != COLORREF_NULL);
256}
257AFX_INLINE BOOL CXTPPaintManagerColor::IsCustomValue() const
258{
259 return m_clrCustomValue != COLORREF_NULL;
260}
261AFX_INLINE COLORREF CXTPPaintManagerColor::GetStandardColor() const
262{
263 return m_clrStandardValue;
264}
265AFX_INLINE void CXTPPaintManagerColor::SetCustomValue(COLORREF clr)
266{
267 m_clrCustomValue = clr;
268}
269AFX_INLINE void CXTPPaintManagerColor::SetStandardValue(COLORREF clr)
270{
271 m_clrStandardValue = clr;
272}
273AFX_INLINE void CXTPPaintManagerColor::SetDefaultValue()
274{
275 m_clrCustomValue = COLORREF_NULL;
276}
277AFX_INLINE CXTPPaintManagerColor::operator COLORREF() const
278{
279 return (m_clrCustomValue == COLORREF_NULL) ? m_clrStandardValue : m_clrCustomValue;
280}
281AFX_INLINE const CXTPPaintManagerColor& CXTPPaintManagerColor::operator=(COLORREF clr)
282{
283 SetCustomValue(clr);
284 return *this;
285}
286AFX_INLINE const CXTPPaintManagerColor& CXTPPaintManagerColor::
287 operator=(const CXTPPaintManagerColor& clr)
288{
289 m_clrCustomValue = clr.m_clrCustomValue;
290 m_clrStandardValue = clr.m_clrStandardValue;
291 return *this;
292}
300class _XTP_EXT_CLASS CXTPPaintManagerColorGradient
301{
302public:
310 CXTPPaintManagerColorGradient();
311
320 CXTPPaintManagerColorGradient(const COLORREF clr);
321
330 CXTPPaintManagerColorGradient(const CXTPPaintManagerColor clr);
331
341 CXTPPaintManagerColorGradient(COLORREF clrLight, COLORREF clrDark);
342
347 virtual ~CXTPPaintManagerColorGradient()
348 {
349 }
350
357 void SetStandardValue(const COLORREF clr);
358
366 void SetStandardValue(CXTPPaintManagerColorGradient& clrref);
367
376 void SetStandardValue(COLORREF clrLight, COLORREF clrDark, float fGradientFactor = 0.5f);
377
384 void SetCustomValue(const COLORREF clr);
385
393 void SetCustomValue(CXTPPaintManagerColorGradient& clrref);
394
402 void SetCustomValue(COLORREF clrLight, COLORREF clrDark);
403
411 operator COLORREF() const;
412
421 operator CXTPPaintManagerColor&();
422
431 const CXTPPaintManagerColorGradient& operator=(const CXTPPaintManagerColorGradient& refSrc);
432
441 BOOL IsNull() const;
442
448 virtual void Serialize(CArchive& ar);
449
450public:
451 CXTPPaintManagerColor clrLight;
452 CXTPPaintManagerColor clrDark;
453 float fGradientFactor;
454};
455
457AFX_INLINE CXTPPaintManagerColorGradient::operator COLORREF() const
458{
459 return clrDark;
460}
461AFX_INLINE CXTPPaintManagerColorGradient::operator CXTPPaintManagerColor&()
462{
463 return clrDark;
464}
465AFX_INLINE BOOL CXTPPaintManagerColorGradient::IsNull() const
466{
467 return ((clrDark == COLORREF_NULL) && (clrLight == COLORREF_NULL));
468}
469AFX_INLINE const CXTPPaintManagerColorGradient& CXTPPaintManagerColorGradient::
470 operator=(const CXTPPaintManagerColorGradient& refSrc)
471{
472 clrLight = refSrc.clrLight;
473 clrDark = refSrc.clrDark;
474 fGradientFactor = refSrc.fGradientFactor;
475 return *this;
476}
485class _XTP_EXT_CLASS CXTPColorManager : public CXTPCmdTarget
486{
487 friend class CXTPSingleton<CXTPColorManager>;
488
489public:
496 typedef DWORD(__stdcall* PFNGETSYSCOLOR)(int nIndex);
497
498public:
499 void ResetCustomColors();
500
507 void RefreshColors(BOOL bResetCustomColors = TRUE);
508
617 COLORREF GetColor(int nIndex) const;
618
627 COLORREF GetLunaColor(int nIndex) const;
628
639 COLORREF LightColor(COLORREF clrLight, COLORREF clrDark, int nDelta) const;
640
648 void DisableLunaColors(BOOL bDisable = TRUE);
649
656 BOOL IsLunaColorsDisabled() const;
657
667 void SetColor(int nIndex, COLORREF clrValue);
668
679 void SetColors(int cElements, const int* lpaElements, const COLORREF* lpaRgbValues);
680
688 void RefreshLunaColors();
689
705 XTPCurrentSystemTheme GetCurrentSystemTheme() const;
706
720 XTPCurrentSystemTheme GetWinThemeWrapperTheme() const;
721
733 void SetLunaTheme(XTPCurrentSystemTheme systemTheme);
734
740 void SetGetSysColorPtr(PFNGETSYSCOLOR pfnGetSysColor);
741
752 BOOL IsLowResolution(HDC hDC = 0);
753
754public:
755 BOOL LongColor(COLORREF clrMain, COLORREF clrSub, BOOL bCalcLength, float fDistance);
756
757private:
758 CXTPColorManager();
759 void RefreshSysColors();
760 void RefreshXPColors();
761 void RefreshGradientColors();
762 float ColorWidth(int nLength, int nWidth);
763 float ColorDelta(COLORREF clrA, COLORREF clrB);
764 float Length(COLORREF clrA, COLORREF clrB);
765 COLORREF MixColor(COLORREF clrMain, COLORREF clrSub, float fDistance);
766 COLORREF AdjustColor(COLORREF clrMain, COLORREF clrSub, float fDistance);
767 double GetRDelta(COLORREF clr);
768 double GetGDelta(COLORREF clr);
769 double GetBDelta(COLORREF clr);
770 XTPCurrentSystemTheme _GetWinThemeWrapperTheme();
771
772public:
773 CXTPPaintManagerColorGradient grcCaption;
774 CXTPPaintManagerColorGradient grcDockBar;
775 CXTPPaintManagerColorGradient grcShortcutBarGripper;
776 CXTPPaintManagerColorGradient grcToolBar;
777 CXTPPaintManagerColorGradient grcMenu;
778 CXTPPaintManagerColorGradient grcMenuExpanded;
780 CXTPPaintManagerColorGradient grcMenuItemPopup;
782 CXTPPaintManagerColorGradient grcLunaChecked;
783 CXTPPaintManagerColorGradient grcLunaPushed;
784 CXTPPaintManagerColorGradient grcLunaSelected;
786 BOOL m_bEnableLunaBlueForRoyaleTheme;
788 BOOL m_bEnableLunaBlueForAeroTheme;
791private:
792 BOOL m_bDisableLunaColors;
793 COLORREF m_arrStandardColor[XPCOLOR_LAST + 1];
794 COLORREF m_arrCustomColor[XPCOLOR_LAST + 1];
795 COLORREF m_arrLunaColor[XPCOLOR_LAST + 1];
796 PFNGETSYSCOLOR m_pfnGetSysColor;
797 XTPCurrentSystemTheme m_systemTheme;
798 XTPCurrentSystemTheme m_winThemeWrapperTheme;
799
800# ifdef _XTP_ACTIVEX
803 DECLARE_DISPATCH_MAP()
804 DECLARE_INTERFACE_MAP()
805
806 DECLARE_OLETYPELIB_EX(CXTPColorManager);
807
808 void OleSetColor(int nIndex, OLE_COLOR clr);
809 void OleRefreshColors();
810 virtual void OnFinalRelease();
811
813# endif
814};
815
829_XTP_EXT_CLASS CXTPColorManager* AFX_CDECL XTPColorManager();
830
853_XTP_EXT_CLASS COLORREF AFX_CDECL GetXtremeColor(UINT nIndex);
854
882_XTP_EXT_CLASS COLORREF AFX_CDECL GetMSO2003Color(UINT nIndex);
883
893_XTP_EXT_CLASS void AFX_CDECL RefreshXtremeColors(BOOL bResetCustomColors = TRUE);
894
899enum XTPPaintManagerAccentColor
900{
901 xtpPaintManagerAccentColor,
902 xtpPaintManagerNormalBackAccentColor,
903 xtpPaintManagerHighlightBackAccentColor,
905 xtpPaintManagerPressedBackAccentColor,
906 xtpPaintManagerNormalTextAccentColor,
907 xtpPaintManagerHighlightTextAccentColor,
908 xtpPaintManagerPressedTextAccentColor
909};
910
917_XTP_EXT_CLASS COLORREF AFX_CDECL XTPGetAccentColor(XTPPaintManagerAccentColor nColor);
918
927_XTP_EXT_CLASS COLORREF AFX_CDECL XTPGetColorizationColor();
928
929# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
931#endif // !defined(__XTPCOLORMANAGER_H__)
GetXtremeColor
_XTP_EXT_CLASS COLORREF AFX_CDECL GetXtremeColor(UINT nIndex)
Call this member as a convenient way to call XTPColorManager()->GetColor, see CXTPColorManager::GetCo...
XPCOLOR_HIGHLIGHT_DISABLED_BORDER
const int XPCOLOR_HIGHLIGHT_DISABLED_BORDER
Definition XTPColorManager.h:105
XPCOLOR_HIGHLIGHT_BORDER
const int XPCOLOR_HIGHLIGHT_BORDER
Definition XTPColorManager.h:77
RefreshXtremeColors
_XTP_EXT_CLASS void AFX_CDECL RefreshXtremeColors(BOOL bResetCustomColors=TRUE)
This global function will refresh the display element colors defined in the CXTPColorManager class.
XPCOLOR_SPLITTER_FACE
const int XPCOLOR_SPLITTER_FACE
Definition XTPColorManager.h:102
XPCOLOR_BASE
const int XPCOLOR_BASE
Definition XTPColorManager.h:74
XPCOLOR_LABEL
const int XPCOLOR_LABEL
Definition XTPColorManager.h:103
XTPPaintManagerAccentColor
XTPPaintManagerAccentColor
Defines a set of accent related colors.
Definition XTPColorManager.h:900
xtpPaintManagerPressedBackAccentColor
@ xtpPaintManagerPressedBackAccentColor
The background accent color in pressed state.
Definition XTPColorManager.h:905
xtpPaintManagerHighlightTextAccentColor
@ xtpPaintManagerHighlightTextAccentColor
The text accent color in highlighted state.
Definition XTPColorManager.h:907
xtpPaintManagerPressedTextAccentColor
@ xtpPaintManagerPressedTextAccentColor
The text accent color in pressed state.
Definition XTPColorManager.h:908
xtpPaintManagerAccentColor
@ xtpPaintManagerAccentColor
The actual accent color.
Definition XTPColorManager.h:901
xtpPaintManagerNormalTextAccentColor
@ xtpPaintManagerNormalTextAccentColor
The text accent color in normal state.
Definition XTPColorManager.h:906
xtpPaintManagerHighlightBackAccentColor
@ xtpPaintManagerHighlightBackAccentColor
The background accent color in highlighted state.
Definition XTPColorManager.h:903
xtpPaintManagerNormalBackAccentColor
@ xtpPaintManagerNormalBackAccentColor
The background accent color in normal state.
Definition XTPColorManager.h:902
XPCOLOR_SHADOW_FACTOR
const int XPCOLOR_SHADOW_FACTOR
Definition XTPColorManager.h:106
XPCOLOR_LAST
const int XPCOLOR_LAST
Definition XTPColorManager.h:109
XPCOLOR_TOOLBAR_TEXT
const int XPCOLOR_TOOLBAR_TEXT
Definition XTPColorManager.h:93
XPCOLOR_DISABLED
const int XPCOLOR_DISABLED
Definition XTPColorManager.h:86
XPCOLOR_HIGHLIGHT
const int XPCOLOR_HIGHLIGHT
Definition XTPColorManager.h:76
XPCOLOR_3DSHADOW
const int XPCOLOR_3DSHADOW
Definition XTPColorManager.h:99
XTPGetColorizationColor
_XTP_EXT_CLASS COLORREF AFX_CDECL XTPGetColorizationColor()
Retrieves the current color used for Desktop Window Manager (DWM) glass composition.
XTPColorManager
_XTP_EXT_CLASS CXTPColorManager *AFX_CDECL XTPColorManager()
Call this function to access CXTPColorManager members.
XPCOLOR_MENUBAR_BORDER
const int XPCOLOR_MENUBAR_BORDER
Definition XTPColorManager.h:89
XPCOLOR_MENUBAR_GRAYTEXT
const int XPCOLOR_MENUBAR_GRAYTEXT
Definition XTPColorManager.h:80
XPCOLOR_STATICFRAME
const int XPCOLOR_STATICFRAME
Definition XTPColorManager.h:104
XPCOLOR_CHECKED_TEXT
const int XPCOLOR_CHECKED_TEXT
Definition XTPColorManager.h:92
XPCOLOR_TOOLBAR_FACE
const int XPCOLOR_TOOLBAR_FACE
Definition XTPColorManager.h:75
XPCOLOR_PUSHED_TEXT
const int XPCOLOR_PUSHED_TEXT
Definition XTPColorManager.h:94
XPCOLOR_FRAME
const int XPCOLOR_FRAME
Definition XTPColorManager.h:101
XPCOLOR_TOOLBAR_GRIPPER
const int XPCOLOR_TOOLBAR_GRIPPER
Definition XTPColorManager.h:84
XPCOLOR_3DFACE
const int XPCOLOR_3DFACE
Definition XTPColorManager.h:98
XPCOLOR_MENUBAR_FACE
const int XPCOLOR_MENUBAR_FACE
Definition XTPColorManager.h:87
XPCOLOR_TAB_INACTIVE_TEXT
const int XPCOLOR_TAB_INACTIVE_TEXT
Definition XTPColorManager.h:96
XPCOLOR_MENUBAR_EXPANDED
const int XPCOLOR_MENUBAR_EXPANDED
Definition XTPColorManager.h:88
XPCOLOR_MENUBAR_TEXT
const int XPCOLOR_MENUBAR_TEXT
Definition XTPColorManager.h:90
XPCOLOR_TAB_INACTIVE_BACK
const int XPCOLOR_TAB_INACTIVE_BACK
Definition XTPColorManager.h:95
XPCOLOR_TOOLBAR_GRAYTEXT
const int XPCOLOR_TOOLBAR_GRAYTEXT
Definition XTPColorManager.h:107
GetMSO2003Color
_XTP_EXT_CLASS COLORREF AFX_CDECL GetMSO2003Color(UINT nIndex)
Call this function to get the MS Office color represented by nIndex.
XPCOLOR_EDITCTRLBORDER
const int XPCOLOR_EDITCTRLBORDER
Definition XTPColorManager.h:100
XPCOLOR_HIGHLIGHT_CHECKED_BORDER
const int XPCOLOR_HIGHLIGHT_CHECKED_BORDER
Definition XTPColorManager.h:83
XPCOLOR_HIGHLIGHT_TEXT
const int XPCOLOR_HIGHLIGHT_TEXT
Definition XTPColorManager.h:91
XPCOLOR_HIGHLIGHT_PUSHED
const int XPCOLOR_HIGHLIGHT_PUSHED
Definition XTPColorManager.h:78
XTPCurrentSystemTheme
XTPCurrentSystemTheme
Enumeration used to determine the current Windows XP theme in use.
Definition XTPColorManager.h:45
xtpSystemThemeDefault
@ xtpSystemThemeDefault
Default theme (xtpSystemThemeAuto)
Definition XTPColorManager.h:53
xtpSystemThemeAero
@ xtpSystemThemeAero
Aero Vista theme in use.
Definition XTPColorManager.h:51
xtpSystemThemeAuto
@ xtpSystemThemeAuto
Use OS theme.
Definition XTPColorManager.h:52
xtpSystemThemeUnknown
@ xtpSystemThemeUnknown
No known theme in use.
Definition XTPColorManager.h:46
xtpSystemThemeOlive
@ xtpSystemThemeOlive
Luna Olive Windows XP theme in use.
Definition XTPColorManager.h:48
xtpSystemThemeSilver
@ xtpSystemThemeSilver
Luna Silver Windows XP theme in use.
Definition XTPColorManager.h:49
xtpSystemThemeBlue
@ xtpSystemThemeBlue
Luna Blue Windows XP theme in use.
Definition XTPColorManager.h:47
xtpSystemThemeRoyale
@ xtpSystemThemeRoyale
Royale Windows XP theme in use.
Definition XTPColorManager.h:50
XPCOLOR_HIGHLIGHT_CHECKED
const int XPCOLOR_HIGHLIGHT_CHECKED
Definition XTPColorManager.h:82
XPCOLOR_FLOATBAR_BORDER
const int XPCOLOR_FLOATBAR_BORDER
Definition XTPColorManager.h:108
XPCOLOR_ICONSHADDOW
const int XPCOLOR_ICONSHADDOW
Definition XTPColorManager.h:79
XPCOLOR_HIGHLIGHT_PUSHED_BORDER
const int XPCOLOR_HIGHLIGHT_PUSHED_BORDER
Definition XTPColorManager.h:97
XPCOLOR_GRAYTEXT
const int XPCOLOR_GRAYTEXT
Definition XTPColorManager.h:81
XPCOLOR_SEPARATOR
const int XPCOLOR_SEPARATOR
Definition XTPColorManager.h:85
XTPGetAccentColor
_XTP_EXT_CLASS COLORREF AFX_CDECL XTPGetAccentColor(XTPPaintManagerAccentColor nColor)
Calculate the specified accent color value.
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPColorManager
CXTPColorManager is a stand alone class.
Definition XTPColorManager.h:486
CXTPColorManager::IsLowResolution
BOOL IsLowResolution(HDC hDC=0)
Call this member function to determine if the system display is set to low resolution.
CXTPColorManager::grcDockBar
CXTPPaintManagerColorGradient grcDockBar
Office 2003 Dockbar gradient color.
Definition XTPColorManager.h:774
CXTPColorManager::SetColors
void SetColors(int cElements, const int *lpaElements, const COLORREF *lpaRgbValues)
Call this member to set the colors for each element to the color in the specified color array.
CXTPColorManager::GetWinThemeWrapperTheme
XTPCurrentSystemTheme GetWinThemeWrapperTheme() const
Call this member function to determine the current Windows XP theme in use.
CXTPColorManager::GetCurrentSystemTheme
XTPCurrentSystemTheme GetCurrentSystemTheme() const
Call this member function to determine the current Windows XP theme in use.
CXTPColorManager::RefreshLunaColors
void RefreshLunaColors()
Call this member to set the Office 2003 Luna colors for each element to correspond with the current W...
CXTPColorManager::SetColor
void SetColor(int nIndex, COLORREF clrValue)
Call this member to set the color for the specified index.
CXTPColorManager::m_bEnableLunaBlueForRoyaleTheme
BOOL m_bEnableLunaBlueForRoyaleTheme
TRUE if Office2003 blue theme will be used for xtpSystemThemeRoyale.
Definition XTPColorManager.h:786
CXTPColorManager::grcMenu
CXTPPaintManagerColorGradient grcMenu
Office 2003 Menu sidebar gradient color.
Definition XTPColorManager.h:777
CXTPColorManager::m_bEnableLunaBlueForAeroTheme
BOOL m_bEnableLunaBlueForAeroTheme
TRUE if Office2003 blue theme will be used for xtpSystemThemeAero.
Definition XTPColorManager.h:788
CXTPColorManager::grcCaption
CXTPPaintManagerColorGradient grcCaption
Office 2003 Caption gradient color.
Definition XTPColorManager.h:773
CXTPColorManager::SetLunaTheme
void SetLunaTheme(XTPCurrentSystemTheme systemTheme)
Call this method to force system theme.
CXTPColorManager::grcLunaPushed
CXTPPaintManagerColorGradient grcLunaPushed
Office 2003 pushed button gradient color.
Definition XTPColorManager.h:783
CXTPColorManager::LightColor
COLORREF LightColor(COLORREF clrLight, COLORREF clrDark, int nDelta) const
Call this member function to blend the light and dark colors by the amount specified in nDelta.
CXTPColorManager::GetColor
COLORREF GetColor(int nIndex) const
Retrieves the current color of the specified XP display element.
CXTPColorManager::grcLunaChecked
CXTPPaintManagerColorGradient grcLunaChecked
Office 2003 checked button gradient color.
Definition XTPColorManager.h:782
CXTPColorManager::RefreshColors
void RefreshColors(BOOL bResetCustomColors=TRUE)
This function will refresh the display element colors defined in the CXTPColorManager object.
CXTPColorManager::IsLunaColorsDisabled
BOOL IsLunaColorsDisabled() const
Determines if Luna colors for Office 2003 style is disabled.
CXTPColorManager::grcMenuExpanded
CXTPPaintManagerColorGradient grcMenuExpanded
Office 2003 Expanded menu sidebar gradient color.
Definition XTPColorManager.h:778
CXTPColorManager::grcMenuItemPopup
CXTPPaintManagerColorGradient grcMenuItemPopup
Office 2003 Menu item pop-up gradient color.
Definition XTPColorManager.h:780
CXTPColorManager::grcShortcutBarGripper
CXTPPaintManagerColorGradient grcShortcutBarGripper
Office 2003 Shortcut bar gripper.
Definition XTPColorManager.h:775
CXTPColorManager::grcLunaSelected
CXTPPaintManagerColorGradient grcLunaSelected
Office 2003 selected button gradient color.
Definition XTPColorManager.h:784
CXTPColorManager::SetGetSysColorPtr
void SetGetSysColorPtr(PFNGETSYSCOLOR pfnGetSysColor)
This method replace standard GetSysColor to application defined.
CXTPColorManager::GetLunaColor
COLORREF GetLunaColor(int nIndex) const
Call this member function to get the Luna color specified by nIndex.
CXTPColorManager::grcToolBar
CXTPPaintManagerColorGradient grcToolBar
Office 2003 ToolBar gradient color.
Definition XTPColorManager.h:776
CXTPColorManager::DisableLunaColors
void DisableLunaColors(BOOL bDisable=TRUE)
Call this member function to disable the luna (Blue, Olive and Green) colors for Office 2003 theme fo...
CXTPPaintManagerColorGradient
The CXTPPaintManagerColorGradient class is used to manage COLORREF values for determining light and d...
Definition XTPColorManager.h:301
CXTPPaintManagerColorGradient::SetCustomValue
void SetCustomValue(CXTPPaintManagerColorGradient &clrref)
This member function will sets the application defined 4 color gradient values for the CXTPPaintManag...
CXTPPaintManagerColorGradient::IsNull
BOOL IsNull() const
Determines if the CXTPPaintManagerColorGradient object's colors have been initialized.
CXTPPaintManagerColorGradient::SetCustomValue
void SetCustomValue(COLORREF clrLight, COLORREF clrDark)
This member function will sets the application defined 4 color gradient values for the CXTPPaintManag...
CXTPPaintManagerColorGradient::CXTPPaintManagerColorGradient
CXTPPaintManagerColorGradient()
Constructs a CXTPPaintManagerColorGradient object and initializes default dark and light colors equal...
CXTPPaintManagerColorGradient::clrDark
CXTPPaintManagerColor clrDark
Dark color.
Definition XTPColorManager.h:452
CXTPPaintManagerColorGradient::operator=
const CXTPPaintManagerColorGradient & operator=(const CXTPPaintManagerColorGradient &refSrc)
This operator copy all values from the specified source object;.
CXTPPaintManagerColorGradient::CXTPPaintManagerColorGradient
CXTPPaintManagerColorGradient(const CXTPPaintManagerColor clr)
Constructs a CXTPPaintManagerColorGradient object and initializes default dark and light colors equal...
CXTPPaintManagerColorGradient::~CXTPPaintManagerColorGradient
virtual ~CXTPPaintManagerColorGradient()
Handles object destruction.
Definition XTPColorManager.h:347
CXTPPaintManagerColorGradient::clrLight
CXTPPaintManagerColor clrLight
Light color.
Definition XTPColorManager.h:451
CXTPPaintManagerColorGradient::CXTPPaintManagerColorGradient
CXTPPaintManagerColorGradient(COLORREF clrLight, COLORREF clrDark)
Constructs a CXTPPaintManagerColorGradient object and initializes default dark and light colors equal...
CXTPPaintManagerColorGradient::Serialize
virtual void Serialize(CArchive &ar)
This method reads or writes data from or to an archive.
CXTPPaintManagerColorGradient::CXTPPaintManagerColorGradient
CXTPPaintManagerColorGradient(const COLORREF clr)
Constructs a CXTPPaintManagerColorGradient object and initializes default dark and light colors equal...
CXTPPaintManagerColorGradient::fGradientFactor
float fGradientFactor
Gradient divider factor.
Definition XTPColorManager.h:453
CXTPPaintManagerColorGradient::SetCustomValue
void SetCustomValue(const COLORREF clr)
This member function will sets the application defined 4 color gradient values for the CXTPPaintManag...
CXTPPaintManagerColorGradient::SetStandardValue
void SetStandardValue(const COLORREF clr)
This member function sets the value of the default dark and light colors equal to the specified COLOR...
CXTPPaintManagerColorGradient::SetStandardValue
void SetStandardValue(CXTPPaintManagerColorGradient &clrref)
This member function sets the value of the default dark and light colors equal to the specified COLOR...
CXTPPaintManagerColorGradient::SetStandardValue
void SetStandardValue(COLORREF clrLight, COLORREF clrDark, float fGradientFactor=0.5f)
This member function sets the value of the default dark and light colors equal to the specified COLOR...
CXTPPaintManagerColor
The CXTPPaintManagerColor class is used to manage COLORREF values for determining default and applica...
Definition XTPColorManager.h:117
CXTPPaintManagerColor::CXTPPaintManagerColor
CXTPPaintManagerColor()
Constructs a CXTPPaintManagerColor object and initializes default and application defined colors for ...
CXTPPaintManagerColor::IsDefaultValue
BOOL IsDefaultValue() const
This member function determines if application defined colors are used.
CXTPPaintManagerColor::GetStandardColor
COLORREF GetStandardColor() const
This member function will retrieves the default color for the CXTPPaintManagerColor class.
CXTPPaintManagerColor::m_clrCustomValue
COLORREF m_clrCustomValue
Application defined color.
Definition XTPColorManager.h:245
CXTPPaintManagerColor::IsCustomValue
BOOL IsCustomValue() const
This member function determines if the custom color is set and used.
CXTPPaintManagerColor::operator=
const CXTPPaintManagerColor & operator=(COLORREF clr)
This operator assigns a new COLORREF value for the application defined color.
CXTPPaintManagerColor::~CXTPPaintManagerColor
virtual ~CXTPPaintManagerColor()
Handles object destruction.
Definition XTPColorManager.h:141
CXTPPaintManagerColor::SetDefaultValue
void SetDefaultValue()
This member function will remove the application defined color (if any) that was defined for the CXTP...
CXTPPaintManagerColor::m_clrStandardValue
COLORREF m_clrStandardValue
Standard color.
Definition XTPColorManager.h:244
CXTPPaintManagerColor::Serialize
virtual void Serialize(CArchive &ar)
This method reads or writes data from or to an archive.
CXTPPaintManagerColor::SetStandardValue
void SetStandardValue(COLORREF clr)
This member function will sets the default color for the CXTPPaintManagerColor class.
CXTPPaintManagerColor::CXTPPaintManagerColor
CXTPPaintManagerColor(COLORREF clr)
Constructs a CXTPPaintManagerColor object and initializes default and application defined colors for ...
CXTPPaintManagerColor::SetCustomValue
void SetCustomValue(COLORREF clr)
This member function will sets the application defined color for the CXTPPaintManagerColor class.
CXTPPaintManagerColor::operator=
const CXTPPaintManagerColor & operator=(const CXTPPaintManagerColor &refclr)
This operator assigns a new COLORREF value for the application defined color.
CXTPPaintManagerColor::IsStandardValue
BOOL IsStandardValue() const
This member function determines if the standard color is set and used.
CXTPSingleton
Implements Singleton design pattern.
Definition XTPSingleton.h:215


Toolkit Pro: XTPPropertyGridInplaceButton.h Source File

  • Source
  • PropertyGrid
XTPPropertyGridInplaceButton.h
Go to the documentation of this file.
1
23#if !defined(__XTPPROPERTYGRIDINPLACEBUTTON_H__)
24# define __XTPPROPERTYGRIDINPLACEBUTTON_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33// class forwards
34
35class CXTPPropertyGridView;
36class CXTPPropertyGridItem;
37class CXTPImageManagerIcon;
38
39const UINT XTP_ID_PROPERTYGRID_EXPANDBUTTON =
40 100;
41const UINT XTP_ID_PROPERTYGRID_COMBOBUTTON =
42 101;
49class _XTP_EXT_CLASS CXTPPropertyGridInplaceButton : public CXTPCmdTarget
50{
51public:
57 CXTPPropertyGridInplaceButton(UINT nID);
58
64 virtual ~CXTPPropertyGridInplaceButton();
65
74 int GetWidth();
75
83 void SetWidth(int nWidth);
84
93 CString GetCaption() const;
94
102 void SetCaption(LPCTSTR lpszCaption);
103
112 int GetIconIndex() const;
113
121 void SetTooltip(LPCTSTR lpstrTooltip);
122
131 CString GetTooltip() const;
132
143 void SetIconIndex(int nIconIndex);
144
153 virtual CXTPImageManagerIcon* GetImage() const;
154
161 CXTPPropertyGridItem* GetItem() const;
162
172 UINT GetID() const;
173
180 CRect GetRect() const;
181
188 BOOL IsFocused() const;
189
196 BOOL IsHot() const;
197
204 BOOL IsPressed() const;
205
214 int GetIndex() const;
215
222 virtual void OnDraw(CDC* pDC, CRect rc);
223
232 virtual void OnLButtonDown(UINT nFlags, CPoint point);
233
240 virtual void OnKeyDown(UINT nChar);
241
248 CXTPPropertyGridView* GetGrid() const;
249
256 BOOL GetEnabled() const;
257
263 void SetEnabled(BOOL bEnabled);
264
271 BOOL IsHyperlink() const;
272
279 void SetHyperlink(BOOL bHyperlink = TRUE);
280
290 BOOL GetShowAlways() const;
291
300 void SetShowAlways(BOOL bShowAlways);
301
308 int GetAlignment() const;
309
315 void SetAlignment(int nAlignment);
316
324 BOOL GetTabStop() const;
325
326protected:
329 BOOL m_bPressed;
330 int m_nIndex;
331
332 CXTPPropertyGridView* m_pGrid;
333 CXTPPropertyGridItem* m_pItem;
334 UINT m_nID;
335 CRect m_rcButton;
336 int m_nWidth;
337 CString m_strCaption;
338 int m_nIconIndex;
339 BOOL m_bEnabled;
340 CString m_strTooltip;
341 BOOL m_bHyperlink;
342 BOOL m_bShowAlways;
343 BOOL m_bTabStop;
344 int m_nAlignment;
347protected:
348# ifdef _XTP_ACTIVEX
350 DECLARE_DISPATCH_MAP()
351 DECLARE_INTERFACE_MAP()
352
353 DECLARE_OLETYPELIB_EX(CXTPPropertyGridInplaceButton);
354 LPDISPATCH OleGetItem();
355 BSTR OleGetCaption();
356
358# endif
359
360private:
361 friend class CXTPPropertyGridItem;
362 friend class CXTPPropertyGridItems;
363 friend class CXTPPropertyGridInplaceButtons;
364};
365
371class _XTP_EXT_CLASS CXTPPropertyGridInplaceButtons : public CXTPCmdTarget
372{
373public:
379 CXTPPropertyGridInplaceButtons(CXTPPropertyGridItem* pItem);
380
386 ~CXTPPropertyGridInplaceButtons();
387
388public:
393 void AddComboButton();
394
399 void AddExpandButton();
400
411 CXTPPropertyGridInplaceButton* AddButton(CXTPPropertyGridInplaceButton* pButton);
412
413public:
420 int GetCount() const;
421
430 CXTPPropertyGridInplaceButton* GetAt(int nIndex) const;
431
436 void RemoveAll();
437
443 void Remove(CXTPPropertyGridInplaceButton* pButton);
444
450 void Remove(UINT nID);
451
457 void RemoveAt(long nIndex);
458
466 CXTPPropertyGridInplaceButton* HitTest(CPoint point) const;
467
476 CXTPPropertyGridInplaceButton* Find(UINT nID) const;
477
478protected:
487 virtual void OnButtonRemoved(CXTPPropertyGridInplaceButton* pButton);
488
489private:
490 void UpdateIndexes();
491
492private:
493 CArray<CXTPPropertyGridInplaceButton*, CXTPPropertyGridInplaceButton*> m_arrButtons;
494 CXTPPropertyGridItem* m_pItem;
495
497# ifdef _XTP_ACTIVEX
498 DECLARE_DISPATCH_MAP()
499 DECLARE_INTERFACE_MAP()
500
501 DECLARE_OLETYPELIB_EX(CXTPPropertyGridInplaceButtons);
502
503 afx_msg long OleGetItemCount();
504 afx_msg LPDISPATCH OleItem(long nIndex);
505 afx_msg LPDISPATCH OleGetItem(long nIndex);
506 afx_msg void OleClear();
507 afx_msg void OleRemove(long nIndex);
508 afx_msg LPDISPATCH OleAdd(UINT ID);
509 afx_msg LPDISPATCH OleFindButton(long nId);
510
511 DECLARE_ENUM_VARIANT(CXTPPropertyGridInplaceButtons)
512
513# endif
515 friend class CXTPPropertyGridItem;
516};
517
518AFX_INLINE CXTPPropertyGridItem* CXTPPropertyGridInplaceButton::GetItem() const
519{
520 return m_pItem;
521}
522AFX_INLINE UINT CXTPPropertyGridInplaceButton::GetID() const
523{
524 return m_nID;
525}
526AFX_INLINE CRect CXTPPropertyGridInplaceButton::GetRect() const
527{
528 return m_rcButton;
529}
530AFX_INLINE CString CXTPPropertyGridInplaceButton::GetCaption() const
531{
532 return m_strCaption;
533}
534AFX_INLINE int CXTPPropertyGridInplaceButton::GetIconIndex() const
535{
536 return m_nIconIndex;
537}
538AFX_INLINE void CXTPPropertyGridInplaceButton::SetIconIndex(int nIconIndex)
539{
540 m_nIconIndex = nIconIndex;
541}
542AFX_INLINE CXTPPropertyGridView* CXTPPropertyGridInplaceButton::GetGrid() const
543{
544 return m_pGrid;
545}
546AFX_INLINE void CXTPPropertyGridInplaceButton::SetTooltip(LPCTSTR lpstrTooltip)
547{
548 m_strTooltip = lpstrTooltip;
549}
550AFX_INLINE CString CXTPPropertyGridInplaceButton::GetTooltip() const
551{
552 return m_strTooltip;
553}
554
555AFX_INLINE int CXTPPropertyGridInplaceButtons::GetCount() const
556{
557 return (int)m_arrButtons.GetSize();
558}
559AFX_INLINE CXTPPropertyGridInplaceButton* CXTPPropertyGridInplaceButtons::GetAt(int nIndex) const
560{
561 return nIndex >= 0 && nIndex < GetCount() ? m_arrButtons.GetAt(nIndex) : NULL;
562}
563AFX_INLINE void CXTPPropertyGridInplaceButton::SetHyperlink(BOOL bHyperlink)
564{
565 m_bHyperlink = bHyperlink;
566}
567AFX_INLINE BOOL CXTPPropertyGridInplaceButton::IsHyperlink() const
568{
569 return m_bHyperlink;
570}
571AFX_INLINE BOOL CXTPPropertyGridInplaceButton::GetShowAlways() const
572{
573 return m_bShowAlways;
574}
575AFX_INLINE void CXTPPropertyGridInplaceButton::SetShowAlways(BOOL bShowAlways)
576{
577 m_bShowAlways = bShowAlways;
578}
579AFX_INLINE int CXTPPropertyGridInplaceButton::GetAlignment() const
580{
581 return m_nAlignment;
582}
583AFX_INLINE void CXTPPropertyGridInplaceButton::SetAlignment(int nAlignment)
584{
585 m_nAlignment = nAlignment;
586}
587AFX_INLINE BOOL CXTPPropertyGridInplaceButton::GetTabStop() const
588{
589 return m_bTabStop;
590}
592# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
593#endif //#if !defined(__XTPPROPERTYGRIDINPLACEBUTTON_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTP_ID_PROPERTYGRID_COMBOBUTTON
const UINT XTP_ID_PROPERTYGRID_COMBOBUTTON
Definition XTPPropertyGridInplaceButton.h:41
XTP_ID_PROPERTYGRID_EXPANDBUTTON
const UINT XTP_ID_PROPERTYGRID_EXPANDBUTTON
Definition XTPPropertyGridInplaceButton.h:39
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPImageManagerIcon
Icons holder class.
Definition XTPImageManager.h:622
CXTPPropertyGridInplaceButton
CXTPPropertyGridInplaceButton is a CXTPCmdTarget derived class.
Definition XTPPropertyGridInplaceButton.h:50
CXTPPropertyGridInplaceButton::GetShowAlways
BOOL GetShowAlways() const
Determines if the button is always shown.
Definition XTPPropertyGridInplaceButton.h:571
CXTPPropertyGridInplaceButton::GetItem
CXTPPropertyGridItem * GetItem() const
Gets the parent property grid item.
Definition XTPPropertyGridInplaceButton.h:518
CXTPPropertyGridInplaceButton::GetGrid
CXTPPropertyGridView * GetGrid() const
Gets the parent property grid view.
Definition XTPPropertyGridInplaceButton.h:542
CXTPPropertyGridInplaceButton::SetTooltip
void SetTooltip(LPCTSTR lpstrTooltip)
Sets the tooltip text for the item.
Definition XTPPropertyGridInplaceButton.h:546
CXTPPropertyGridInplaceButton::OnDraw
virtual void OnDraw(CDC *pDC, CRect rc)
Draws the button.
CXTPPropertyGridInplaceButton::IsHot
BOOL IsHot() const
Determines if the button is hot (i.e.
CXTPPropertyGridInplaceButton::GetIconIndex
int GetIconIndex() const
Gets the image index of the button.
Definition XTPPropertyGridInplaceButton.h:534
CXTPPropertyGridInplaceButton::GetTabStop
BOOL GetTabStop() const
Specifies if the button is a tab stop (i.e.
Definition XTPPropertyGridInplaceButton.h:587
CXTPPropertyGridInplaceButton::CXTPPropertyGridInplaceButton
CXTPPropertyGridInplaceButton(UINT nID)
Constructs a CXTPPropertyGridInplaceButton object.
CXTPPropertyGridInplaceButton::OnKeyDown
virtual void OnKeyDown(UINT nChar)
This method is called when the user presses a key while the button has focus.
CXTPPropertyGridInplaceButton::SetHyperlink
void SetHyperlink(BOOL bHyperlink=TRUE)
Specifies if the button should act as a hyperlink.
Definition XTPPropertyGridInplaceButton.h:563
CXTPPropertyGridInplaceButton::SetCaption
void SetCaption(LPCTSTR lpszCaption)
Sets the caption text for the button.
CXTPPropertyGridInplaceButton::IsPressed
BOOL IsPressed() const
Determines if the button is pressed.
CXTPPropertyGridInplaceButton::GetWidth
int GetWidth()
Gets the width of the button.
CXTPPropertyGridInplaceButton::SetEnabled
void SetEnabled(BOOL bEnabled)
Enables/disables the button.
CXTPPropertyGridInplaceButton::GetAlignment
int GetAlignment() const
Gets the alignment of the button.
Definition XTPPropertyGridInplaceButton.h:579
CXTPPropertyGridInplaceButton::GetCaption
CString GetCaption() const
Gets the caption text of the button.
Definition XTPPropertyGridInplaceButton.h:530
CXTPPropertyGridInplaceButton::GetID
UINT GetID() const
Gets the identifier of the button.
Definition XTPPropertyGridInplaceButton.h:522
CXTPPropertyGridInplaceButton::SetShowAlways
void SetShowAlways(BOOL bShowAlways)
Specifies if the button should always be shown.
Definition XTPPropertyGridInplaceButton.h:575
CXTPPropertyGridInplaceButton::OnLButtonDown
virtual void OnLButtonDown(UINT nFlags, CPoint point)
This method is called when the user presses the left mouse button on the button.
CXTPPropertyGridInplaceButton::SetIconIndex
void SetIconIndex(int nIconIndex)
Sets the icon index for the button.
Definition XTPPropertyGridInplaceButton.h:538
CXTPPropertyGridInplaceButton::IsHyperlink
BOOL IsHyperlink() const
Determines if the button acts as a hyperlink.
Definition XTPPropertyGridInplaceButton.h:567
CXTPPropertyGridInplaceButton::GetTooltip
CString GetTooltip() const
Gets the tooltip text of the item.
Definition XTPPropertyGridInplaceButton.h:550
CXTPPropertyGridInplaceButton::SetWidth
void SetWidth(int nWidth)
Sets the width for the button.
CXTPPropertyGridInplaceButton::GetRect
CRect GetRect() const
Gets the bounding rectangle of the button.
Definition XTPPropertyGridInplaceButton.h:526
CXTPPropertyGridInplaceButton::GetImage
virtual CXTPImageManagerIcon * GetImage() const
Gets the icon of the button.
CXTPPropertyGridInplaceButton::IsFocused
BOOL IsFocused() const
Determines if the button has focus.
CXTPPropertyGridInplaceButton::GetIndex
int GetIndex() const
Gets the index of this button within the collection of in-place buttons of the parent item.
CXTPPropertyGridInplaceButton::GetEnabled
BOOL GetEnabled() const
Determines if the button is enabled/disabled.
CXTPPropertyGridInplaceButton::SetAlignment
void SetAlignment(int nAlignment)
Sets the alignment for the button.
Definition XTPPropertyGridInplaceButton.h:583
CXTPPropertyGridInplaceButton::~CXTPPropertyGridInplaceButton
virtual ~CXTPPropertyGridInplaceButton()
Destroys a CXTPPropertyGridInplaceButton object, handles cleanup and deallocation.
CXTPPropertyGridInplaceButtons
CXTPPropertyGridInplaceButtons is a CXTPCmdTarget derived class.
Definition XTPPropertyGridInplaceButton.h:372
CXTPPropertyGridInplaceButtons::GetCount
int GetCount() const
Gets the number of buttons in the collection.
Definition XTPPropertyGridInplaceButton.h:555
CXTPPropertyGridInplaceButtons::CXTPPropertyGridInplaceButtons
CXTPPropertyGridInplaceButtons(CXTPPropertyGridItem *pItem)
Constructs a CXTPPropertyGridInplaceButtons object.
CXTPPropertyGridInplaceButtons::Remove
void Remove(CXTPPropertyGridInplaceButton *pButton)
Removes a specified button from the collection.
CXTPPropertyGridInplaceButtons::AddButton
CXTPPropertyGridInplaceButton * AddButton(CXTPPropertyGridInplaceButton *pButton)
Adds a custom button to the collection.
CXTPPropertyGridInplaceButtons::RemoveAt
void RemoveAt(long nIndex)
Removes the button at a specified index within the collection.
CXTPPropertyGridInplaceButtons::HitTest
CXTPPropertyGridInplaceButton * HitTest(CPoint point) const
Determines which button, if any, is at a specified position.
CXTPPropertyGridInplaceButtons::GetAt
CXTPPropertyGridInplaceButton * GetAt(int nIndex) const
Retrieves the button at a specified index within the collection.
Definition XTPPropertyGridInplaceButton.h:559
CXTPPropertyGridInplaceButtons::Remove
void Remove(UINT nID)
Removes the button with a specified identifier from the collection.
CXTPPropertyGridInplaceButtons::AddExpandButton
void AddExpandButton()
Adds a standard expand button to the collection.
CXTPPropertyGridInplaceButtons::AddComboButton
void AddComboButton()
Adds a standard combo button to the collection.
CXTPPropertyGridInplaceButtons::~CXTPPropertyGridInplaceButtons
~CXTPPropertyGridInplaceButtons()
Destroys a CXTPPropertyGridInplaceButtons object, handles cleanup and deallocation.
CXTPPropertyGridInplaceButtons::RemoveAll
void RemoveAll()
Removes all buttons from the collection.
CXTPPropertyGridInplaceButtons::OnButtonRemoved
virtual void OnButtonRemoved(CXTPPropertyGridInplaceButton *pButton)
This method is called when a button is removed.
CXTPPropertyGridInplaceButtons::Find
CXTPPropertyGridInplaceButton * Find(UINT nID) const
Retrieves the button with a specified identifier within the collection.
CXTPPropertyGridItem
CXTPPropertyGridItem is the base class representing an item of the Property Grid control.
Definition XTPPropertyGridItem.h:523
CXTPPropertyGridItems
CXTPPropertyGridItems is a CList derived class.
Definition XTPPropertyGridItem.h:110
CXTPPropertyGridView
CXTPPropertyGridView is a CListBox derived class.
Definition XTPPropertyGridView.h:49


Toolkit Pro: XTPTreeTheme.h Source File

  • Source
  • Controls
  • Tree
XTPTreeTheme.h
Go to the documentation of this file.
1
23#if !defined(__XTPTREETHEME_H__)
24# define __XTPTREETHEME_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPTreeBase;
34
40class _XTP_EXT_CLASS CXTPTreeTheme : public CXTPControlTheme
41{
42public:
47 CXTPTreeTheme();
48
53 virtual ~CXTPTreeTheme();
54
62 virtual void RefreshMetrics(CXTPTreeBase* pTreeBase);
63
70 virtual COLORREF GetTreeBackColor() const;
71
78 virtual COLORREF GetTreeTextColor() const;
79
92 virtual COLORREF GetItemTextColor(UINT uState, bool bTreeHasFocus, DWORD dwStyle,
93 COLORREF crBackDef, CTreeCtrl* pTreeBase) const;
94
107 virtual COLORREF GetItemBackColor(UINT uState, bool bTreeHasFocus, DWORD dwStyle,
108 COLORREF crTextDef, CTreeCtrl* pTreeBase) const;
109
117 BOOL IsDrawFocusRect() const
118 {
119 return m_bDrawFocusRect;
120 }
121
129 virtual BOOL IsThemeDark() const
130 {
131 return m_bDarkTheme;
132 }
133
134protected:
135 COLORREF m_crText;
136 COLORREF m_crTextDisabled;
137 COLORREF m_crTextSelected;
138 COLORREF m_crTextSelectedInactive;
140 COLORREF m_crTextSelectedDisabled;
142 COLORREF m_crBack;
143 COLORREF m_crBackDisabled;
144 COLORREF m_crBackSelected;
145 COLORREF m_crBackSelectedInactive;
147 COLORREF m_crBackSelectedDisabled;
149 BOOL m_bDrawFocusRect;
150 BOOL m_bDarkTheme;
152};
153
159class _XTP_EXT_CLASS CXTPTreeVisualStudio2012Theme : public CXTPTreeTheme
160{
161public:
167 CXTPTreeVisualStudio2012Theme(BOOL bLight = TRUE);
168
176 virtual void RefreshMetrics(CXTPTreeBase* pTreeBase);
177};
178
184class _XTP_EXT_CLASS CXTPTreeOffice2013Theme : public CXTPTreeTheme
185{
186public:
191 CXTPTreeOffice2013Theme();
192
200 virtual void RefreshMetrics(CXTPTreeBase* pTreeBase);
201};
202
208class _XTP_EXT_CLASS CXTPTreeVisualStudio2015Theme : public CXTPTreeOffice2013Theme
209{
210public:
215 CXTPTreeVisualStudio2015Theme();
216};
217
223class _XTP_EXT_CLASS CXTPTreeVisualStudio2017Theme : public CXTPTreeOffice2013Theme
224{
225public:
230 CXTPTreeVisualStudio2017Theme();
231};
232
238class _XTP_EXT_CLASS CXTPTreeVisualStudio2019Theme : public CXTPTreeOffice2013Theme
239{
240public:
245 CXTPTreeVisualStudio2019Theme();
246};
247
253class _XTP_EXT_CLASS CXTPTreeVisualStudio2022Theme : public CXTPTreeOffice2013Theme
254{
255public:
260 CXTPTreeVisualStudio2022Theme();
261};
262
268class _XTP_EXT_CLASS CXTPTreeNativeWindows10Theme : public CXTPTreeOffice2013Theme
269{
270public:
275 CXTPTreeNativeWindows10Theme();
276};
277
283class _XTP_EXT_CLASS CXTPTreeNativeWindows11Theme : public CXTPTreeOffice2013Theme
284{
285public:
290 CXTPTreeNativeWindows11Theme();
291};
292
293# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
295#endif // !defined(__XTPTREETHEME_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPControlTheme
CXTPControlTheme can be used as a base class for user defined themes.
Definition XTPControlTheme.h:95
CXTPTreeBase
CXTPTreeBase is a CTreeView derived class.
Definition XTPTreeBase.h:43
CXTPTreeNativeWindows10Theme
CXTPTreeNativeWindows10Theme is a CXTPTreeTheme derived class used to render a Native Windows 10 styl...
Definition XTPTreeTheme.h:269
CXTPTreeNativeWindows10Theme::CXTPTreeNativeWindows10Theme
CXTPTreeNativeWindows10Theme()
Constructs a CXTPTreeNativeWindows10Theme object.
CXTPTreeNativeWindows11Theme
CXTPTreeNativeWindows11Theme is a CXTPTreeTheme derived class used to render a Native Windows 11 styl...
Definition XTPTreeTheme.h:284
CXTPTreeNativeWindows11Theme::CXTPTreeNativeWindows11Theme
CXTPTreeNativeWindows11Theme()
Constructs a CXTPTreeNativeWindows11Theme object.
CXTPTreeOffice2013Theme
CXTPTreeOffice2013Theme is a CXTPTreeTheme derived class used to render a Office 2013 style tree.
Definition XTPTreeTheme.h:185
CXTPTreeOffice2013Theme::CXTPTreeOffice2013Theme
CXTPTreeOffice2013Theme()
Constructs a CXTPTreeOffice2013Theme object.
CXTPTreeOffice2013Theme::RefreshMetrics
virtual void RefreshMetrics(CXTPTreeBase *pTreeBase)
This member function performs initialization for the tree theme.
CXTPTreeTheme
CXTPTreeTheme is a class used to perform tree control theme drawing tasks.
Definition XTPTreeTheme.h:41
CXTPTreeTheme::GetItemTextColor
virtual COLORREF GetItemTextColor(UINT uState, bool bTreeHasFocus, DWORD dwStyle, COLORREF crBackDef, CTreeCtrl *pTreeBase) const
This member function is used to retrieve the tree text color depending on the tree item state.
CXTPTreeTheme::~CXTPTreeTheme
virtual ~CXTPTreeTheme()
Destroys a CXTPTreeTheme object, handles cleanup and deallocation.
CXTPTreeTheme::m_crBackSelectedDisabled
COLORREF m_crBackSelectedDisabled
Tree item selected disabled background color when TVS_SHOWSELALWAYS is used.
Definition XTPTreeTheme.h:147
CXTPTreeTheme::m_bDrawFocusRect
BOOL m_bDrawFocusRect
TRUE to draw a focus rectangle when a tree item has input focus.
Definition XTPTreeTheme.h:149
CXTPTreeTheme::GetItemBackColor
virtual COLORREF GetItemBackColor(UINT uState, bool bTreeHasFocus, DWORD dwStyle, COLORREF crTextDef, CTreeCtrl *pTreeBase) const
This member function is used to retrieve the tree back color depending on the tree item state.
CXTPTreeTheme::m_crBack
COLORREF m_crBack
Tree item background color.
Definition XTPTreeTheme.h:142
CXTPTreeTheme::GetTreeTextColor
virtual COLORREF GetTreeTextColor() const
This member function is used to retrieve the tree text color.
CXTPTreeTheme::m_crTextDisabled
COLORREF m_crTextDisabled
Tree item disabled text color.
Definition XTPTreeTheme.h:136
CXTPTreeTheme::m_crBackSelected
COLORREF m_crBackSelected
Tree item selected background color.
Definition XTPTreeTheme.h:144
CXTPTreeTheme::m_crText
COLORREF m_crText
Tree item text color.
Definition XTPTreeTheme.h:135
CXTPTreeTheme::m_crBackSelectedInactive
COLORREF m_crBackSelectedInactive
Tree item selected inactive background color when TVS_SHOWSELALWAYS is used.
Definition XTPTreeTheme.h:145
CXTPTreeTheme::CXTPTreeTheme
CXTPTreeTheme()
Constructs a CXTPTreeTheme object.
CXTPTreeTheme::IsDrawFocusRect
BOOL IsDrawFocusRect() const
This member function is used to determine if a focus rectangle should be drawn around tree items that...
Definition XTPTreeTheme.h:117
CXTPTreeTheme::m_bDarkTheme
BOOL m_bDarkTheme
TRUE when using a darker background theme, FALSE when using a lighter background theme.
Definition XTPTreeTheme.h:150
CXTPTreeTheme::GetTreeBackColor
virtual COLORREF GetTreeBackColor() const
This member function is used to retrieve the tree background color.
CXTPTreeTheme::IsThemeDark
virtual BOOL IsThemeDark() const
This member function is used to determine if a dark theme is used.
Definition XTPTreeTheme.h:129
CXTPTreeTheme::RefreshMetrics
virtual void RefreshMetrics(CXTPTreeBase *pTreeBase)
This member function performs initialization for the tree theme.
CXTPTreeTheme::m_crTextSelectedDisabled
COLORREF m_crTextSelectedDisabled
Tree item selected disabled text color when TVS_SHOWSELALWAYS is used.
Definition XTPTreeTheme.h:140
CXTPTreeTheme::m_crTextSelected
COLORREF m_crTextSelected
Tree item selected text color.
Definition XTPTreeTheme.h:137
CXTPTreeTheme::m_crBackDisabled
COLORREF m_crBackDisabled
Tree item disabled background color.
Definition XTPTreeTheme.h:143
CXTPTreeTheme::m_crTextSelectedInactive
COLORREF m_crTextSelectedInactive
Tree item selected inactive text color when TVS_SHOWSELALWAYS is used.
Definition XTPTreeTheme.h:138
CXTPTreeVisualStudio2012Theme
CXTPTreeVisualStudio2012Theme is a CXTPTreeTheme derived class used to render a Visual Studio 2012 st...
Definition XTPTreeTheme.h:160
CXTPTreeVisualStudio2012Theme::CXTPTreeVisualStudio2012Theme
CXTPTreeVisualStudio2012Theme(BOOL bLight=TRUE)
Constructs a CXTPTreeVisualStudio2012Theme object.
CXTPTreeVisualStudio2012Theme::RefreshMetrics
virtual void RefreshMetrics(CXTPTreeBase *pTreeBase)
This member function performs initialization for the tree theme.
CXTPTreeVisualStudio2015Theme
CXTPTreeVisualStudio2015Theme is a CXTPTreeTheme derived class used to render a Visual Studio 2015 st...
Definition XTPTreeTheme.h:209
CXTPTreeVisualStudio2015Theme::CXTPTreeVisualStudio2015Theme
CXTPTreeVisualStudio2015Theme()
Constructs a CXTPTreeVisualStudio2015Theme object.
CXTPTreeVisualStudio2017Theme
CXTPTreeVisualStudio2017Theme is a CXTPTreeTheme derived class used to render a Visual Studio 2017 st...
Definition XTPTreeTheme.h:224
CXTPTreeVisualStudio2017Theme::CXTPTreeVisualStudio2017Theme
CXTPTreeVisualStudio2017Theme()
Constructs a CXTPTreeVisualStudio2017Theme object.
CXTPTreeVisualStudio2019Theme
CXTPTreeVisualStudio2019Theme is a CXTPTreeTheme derived class used to render a Visual Studio 2019 st...
Definition XTPTreeTheme.h:239
CXTPTreeVisualStudio2019Theme::CXTPTreeVisualStudio2019Theme
CXTPTreeVisualStudio2019Theme()
Constructs a CXTPTreeVisualStudio2019Theme object.
CXTPTreeVisualStudio2022Theme
CXTPTreeVisualStudio2022Theme is a CXTPTreeTheme derived class used to render a Visual Studio 2022 st...
Definition XTPTreeTheme.h:254
CXTPTreeVisualStudio2022Theme::CXTPTreeVisualStudio2022Theme
CXTPTreeVisualStudio2022Theme()
Constructs a CXTPTreeVisualStudio2022Theme object.


Toolkit Pro: Member List

CXTPChartPieSeriesView Member List

This is the complete list of members for CXTPChartPieSeriesView, including all inherited members.

AddChildView(CXTPChartElementView *pChildView) | CXTPChartElementView |
CalculateLabelLayout(CXTPChartDeviceContext *pDC) | CXTPChartPieSeriesViewBase | virtual
CalculatePointLayout(CXTPChartDeviceContext *pDC, CRect rcBounds) | CXTPChartPieSeriesView | virtual
CreateDeviceCommand(CXTPChartDeviceContext *pDC) | CXTPChartPieSeriesView | protectedvirtual
CreateDiagramDomain(CXTPChartDeviceContext *pDC, CRect rcBounds) | CXTPChartPieSeriesViewBase | virtual
CreateLegendDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcBounds) | CXTPChartPieSeriesView | protectedvirtual
CreateSeriesPointView(CXTPChartDeviceContext *pDC, CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView) | CXTPChartPieSeriesView | protectedvirtual
CXTPChartElementView(CXTPChartElementView *pParentView) | CXTPChartElementView |
CXTPChartElementView(CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartElementView |
CXTPChartElementView(CXTPChartContainer *pContainer) | CXTPChartElementView |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartPieSeriesView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView) | CXTPChartPieSeriesView |
CXTPChartPieSeriesViewBase(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView) | CXTPChartPieSeriesViewBase | protected
GetAt(int nIndex) const | CXTPChartElementView |
GetBounds() const | CXTPChartElementView |
GetBounds(BOOL bIncludingChildren) const | CXTPChartElementView |
GetChildren() | CXTPChartElementView |
GetCount() const | CXTPChartElementView |
GetDomain() const | CXTPChartPieSeriesViewBase |
GetInnerBounds() const | CXTPChartPieSeriesViewBase |
GetMaxLabelWidth() const | CXTPChartPieSeriesViewBase |
GetParentView() const | CXTPChartElementView |
Is3D() const | CXTPChartObject |
m_arrChildren | CXTPChartElementView | protected
m_pContainer | CXTPChartElementView | protected
m_pParentView | CXTPChartElementView | protected
m_rcBounds | CXTPChartElementView | protected
~CXTPChartElementView() | CXTPChartElementView | protectedvirtual
~CXTPChartLegendItemView() | CXTPChartLegendItemView | inlinevirtual
~CXTPChartPieSeriesViewBase() | CXTPChartPieSeriesViewBase | virtual


Toolkit Pro: XTPSyntaxEditDoc.h Source File

  • Source
  • SyntaxEdit
XTPSyntaxEditDoc.h
Go to the documentation of this file.
1
23#if !defined(__XTPSYNTAXEDITSYNTAXEDITDOC_H__)
24# define __XTPSYNTAXEDITSYNTAXEDITDOC_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPSyntaxEditBufferManager;
34
44class _XTP_EXT_CLASS CXTPSyntaxEditDoc : public CDocument
45{
46protected:
51 CXTPSyntaxEditDoc();
52
58 virtual ~CXTPSyntaxEditDoc();
59
61 DECLARE_DYNCREATE(CXTPSyntaxEditDoc)
64 // Attributes
65public:
66 // Operations
67public:
68 // Overrides
70 //{{AFX_VIRTUAL(CXTPSyntaxEditDoc)
71public:
72 virtual void Serialize(CArchive& ar);
73 virtual void OnChangedViewList();
74 virtual BOOL OnOpenDocument(LPCTSTR lpszPathName);
75 virtual BOOL OnSaveDocument(LPCTSTR lpszPathName);
76 virtual void OnCloseDocument();
77
78protected:
79 virtual BOOL OnNewDocument();
80 //}}AFX_VIRTUAL
83 // Implementation
84public:
91 BOOL ReOpen();
92
100 void SetDataManager(CXTPSyntaxEditBufferManager* pBuffer);
101
110 CXTPSyntaxEditBufferManager* GetDataManager() const;
111
121 void SetConfigFile(LPCTSTR szPath);
122
130 BOOL GetAutoReload() const;
131
142 BOOL SetAutoReload(BOOL bAutoReload, BOOL bUpdateReg = FALSE);
143
157 BOOL CheckFileModified(LPCTSTR lpszPathName);
158
165 BOOL IsReadonly();
166
175 CXTPSyntaxEditView* GetFirstView();
176
177# ifdef _DEBUG
179 virtual void AssertValid() const;
180 virtual void Dump(CDumpContext& dc) const;
182# endif
183
184 // Generated message map functions
185protected:
186 virtual BOOL SaveFileData(LPCTSTR lpszPathName);
187
189 //{{AFX_MSG(CXTPSyntaxEditDoc)
190 // NOTE - the ClassWizard will add and remove member functions here.
191 //}}AFX_MSG
192 DECLARE_MESSAGE_MAP()
195protected:
196 CXTPSyntaxEditBufferManager* m_ptrDataMan;
198 BOOL m_bAutoReload;
200 BOOL m_bOpened;
201 BOOL m_bNewFile;
203 BOOL m_bDocCreated;
204 BOOL m_bReloading;
206 int m_iTopRow;
207 int m_iHScrollPos;
209 WIN32_FIND_DATA m_curFileData;
210};
211
212AFX_INLINE CXTPSyntaxEditBufferManager* CXTPSyntaxEditDoc::GetDataManager() const
213{
214 return m_ptrDataMan;
215}
216AFX_INLINE BOOL CXTPSyntaxEditDoc::GetAutoReload() const
217{
218 return m_bAutoReload;
219}
220
222
223//{{AFX_INSERT_LOCATION}}
224// Microsoft Visual C++ will insert additional declarations immediately before the previous line.
225
226# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
228#endif // !defined(__XTPSYNTAXEDITSYNTAXEDITDOC_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPSyntaxEditBufferManager
This class is the main class for buffer management.
Definition XTPSyntaxEditBufferManager.h:59
CXTPSyntaxEditDoc
This class represents the Document portion of an Edit control.
Definition XTPSyntaxEditDoc.h:45
CXTPSyntaxEditDoc::ReOpen
BOOL ReOpen()
Re-opens an opened file.
CXTPSyntaxEditDoc::GetAutoReload
BOOL GetAutoReload() const
Determines if auto-reload for external files is enabled/disabled.
Definition XTPSyntaxEditDoc.h:216
CXTPSyntaxEditDoc::~CXTPSyntaxEditDoc
virtual ~CXTPSyntaxEditDoc()
Destroys a CXTPSyntaxEditDoc object, handles cleanup and de-allocation.
CXTPSyntaxEditDoc::CXTPSyntaxEditDoc
CXTPSyntaxEditDoc()
Protected object constructor.
CXTPSyntaxEditDoc::SetConfigFile
void SetConfigFile(LPCTSTR szPath)
Sets the the path to the main configuration file.
CXTPSyntaxEditDoc::GetFirstView
CXTPSyntaxEditView * GetFirstView()
Gets a first view for the document object.
CXTPSyntaxEditDoc::SetDataManager
void SetDataManager(CXTPSyntaxEditBufferManager *pBuffer)
Sets the edit buffer manager.
CXTPSyntaxEditDoc::CheckFileModified
BOOL CheckFileModified(LPCTSTR lpszPathName)
Determines if the current file has been externally modified and prompts the user to reload it.
CXTPSyntaxEditDoc::IsReadonly
BOOL IsReadonly()
Determines if the current file is read-only.
CXTPSyntaxEditDoc::SetAutoReload
BOOL SetAutoReload(BOOL bAutoReload, BOOL bUpdateReg=FALSE)
Enables/disables auto-reload for external files.
CXTPSyntaxEditView
This class represents a View portion of the Edit Control.
Definition XTPSyntaxEditView.h:89


Toolkit Pro: Member List

CXTPGridView Member List

This is the complete list of members for CXTPGridView, including all inherited members.

CXTPGridView() | CXTPGridView | protected
GetGridCtrl() const | CXTPGridView | virtual
GetPaintManager() const | CXTPGridView |
GetPrintOptions() const | CXTPGridView |
GetScrollBarCtrl(int nBar) const | CXTPGridView | protected
m_bAllowCut | CXTPGridView |
m_bAllowPaste | CXTPGridView |
m_bmpGrayDC | CXTPGridView | protected
m_bPrintDirect | CXTPGridView |
m_bPrintSelection | CXTPGridView | protected
m_bResizeControlWithView | CXTPGridView |
m_bShowRowNumber | CXTPGridView | protected
m_bSwitchMode | CXTPGridView | protected
m_pGrid | CXTPGridView | protected
m_pPrintOptions | CXTPGridView | protected
m_pScrollBarHor | CXTPGridView | protected
m_pScrollBarVer | CXTPGridView | protected
m_wndGrid | CXTPGridView | protected
PrintFixedRowsDivider(CDC *pDC, const CRect &rc, BOOL bHeaderRows) | CXTPGridView | protected
PrintFooter(CDC *pDC, CRect rcFooter) | CXTPGridView | protectedvirtual
PrintGrid(CDC *pDC, CPrintInfo *pInfo, CRect rcPage, int nRowFrom, int nColumnFrom, int nColumnTo) | CXTPGridView | protectedvirtual
PrintHeader(CDC *pDC, CRect rcHeader) | CXTPGridView | protectedvirtual
PrintPage(CDC *pDC, CPrintInfo *pInfo, CRect rcPage, int nRowFrom, int nColumnFrom, int nColumnTo) | CXTPGridView | protectedvirtual
PrintPageFooter(CDC *pDC, CPrintInfo *pInfo, CRect rcPage, BOOL bOnlyCalculate, int nPageNumber, int nNumberOfPages, int nHorizontalPageNumber, int nNumberOfHorizontalPages) | CXTPGridView | protectedvirtual
PrintPageHeader(CDC *pDC, CPrintInfo *pInfo, CRect rcPage, BOOL bOnlyCalculate, int nPageNumber, int nNumberOfPages, int nHorizontalPageNumber, int nNumberOfHorizontalPages) | CXTPGridView | protectedvirtual
SetGridCtrl(CXTPGridControl *pGrid) | CXTPGridView |
SetScrollBarCtrl(CScrollBar *pScrollBar, BOOL bHor=FALSE) | CXTPGridView | protected
SetSliderCtrl(CSliderCtrl *pSlider) | CXTPGridView | protected
SetTheme(XTPGridPaintTheme paintTheme, BOOL bEnableMetrics=FALSE) | CXTPGridView |
SetupStartCol(CDC *pDC, CPrintInfo *pInfo) | CXTPGridView | protected
UpdateScrollBars() | CXTPGridView |
~CXTPGridView() | CXTPGridView | protectedvirtual


Toolkit Pro: Member List

CXTPTreeBase Member List

This is the complete list of members for CXTPTreeBase, including all inherited members.

CColorFontMap typedef | CXTPTreeBase | protected
CXTPTreeBase() | CXTPTreeBase | protected
DoAction(HTREEITEM hItem, BOOL bLeft, UINT nFlags, CPoint point) | CXTPTreeBase | protectedvirtual
DoBanding(UINT nFlags, CPoint point) | CXTPTreeBase | protectedvirtual
DoPaint(CDC &dc, BOOL bInternal=TRUE) | CXTPTreeBase | protectedvirtual
DoPreSelection(HTREEITEM hItem, BOOL bLeft, UINT nFlags) | CXTPTreeBase | protectedvirtual
DrawDarkThemeExpander(CDC *pDC, COLORREF crBack, CRect rcItem, CRect rcExpander, int nPart, int nState) const | CXTPTreeBase | protected
DrawItem(CDC *pDC, HTREEITEM hItem, const COLORREF crBack) | CXTPTreeBase | protected
EnableDefaultItemDrawing(BOOL bEnable=TRUE) | CXTPTreeBase |
EnableMultiSelect(BOOL bMultiSelect=TRUE) | CXTPTreeBase | virtual
FindItem(LPCTSTR lpszSearch, BOOL bCaseSensitive=FALSE, BOOL bDownDir=TRUE, BOOL bWholeWord=FALSE, HTREEITEM hItem=NULL) | CXTPTreeBase | virtual
FindItemExact(LPCTSTR lpszSearch, BOOL bCaseSensitive=FALSE, BOOL bDownDir=TRUE, HTREEITEM hItem=NULL) | CXTPTreeBase | virtual
FindItemImpl(LPCTSTR lpszSearch, BOOL bCaseSensitive=FALSE, BOOL bDownDir=TRUE, BOOL bWholeWord=FALSE, HTREEITEM hItem=NULL, BOOL bExactlySameStr=FALSE) | CXTPTreeBase | protectedvirtual
FindItemInBranch(LPCTSTR lpszSearch, BOOL bCaseSensitive, BOOL bWholeWord, HTREEITEM htiItem) | CXTPTreeBase | virtual
FocusItem(HTREEITEM hItem) | CXTPTreeBase |
GetFirstSelectedItem() const | CXTPTreeBase | virtual
GetFocusedItem() const | CXTPTreeBase |
GetIconIndent() const | CXTPTreeBase |
GetInsertMarkColor() const | CXTPTreeBase | protected
GetItemBackColor(HTREEITEM hItem) | CXTPTreeBase | virtual
GetItemBackColor(UINT uState, bool bTreeHasFocus, DWORD dwStyle, COLORREF crBack) const | CXTPTreeBase | protectedvirtual
GetItemBold(HTREEITEM hItem) | CXTPTreeBase | virtual
GetItemColor(HTREEITEM hItem) | CXTPTreeBase | virtual
GetItemExpanderRect(HTREEITEM hItem, CDC *pDC, const CRect &rcIcon, const CRect &rcStateIcon) const | CXTPTreeBase | protectedvirtual
GetItemFont(HTREEITEM hItem, LOGFONT *plogfont) | CXTPTreeBase | virtual
GetItemIconRect(HTREEITEM hItem) const | CXTPTreeBase | protectedvirtual
GetItemState(HTREEITEM hItem, UINT nStateMask) const | CXTPTreeBase |
GetItemStateIconRect(HTREEITEM hItem, const CRect &rcIcon) const | CXTPTreeBase | protectedvirtual
GetItemTextColor(UINT uState, bool bTreeHasFocus, DWORD dwStyle, COLORREF crText) const | CXTPTreeBase | protectedvirtual
GetLastItem(HTREEITEM hItem) const | CXTPTreeBase | virtual
GetNextItem(HTREEITEM hItem) const | CXTPTreeBase | virtual
GetNextItem(HTREEITEM hItem, UINT nCode) const | CXTPTreeBase | virtual
GetNextSelectedItem(HTREEITEM hItem) const | CXTPTreeBase | virtual
GetPrevItem(HTREEITEM hItem) const | CXTPTreeBase | virtual
GetPrevSelectedItem(HTREEITEM hItem) const | CXTPTreeBase | virtual
GetSelectedCount() const | CXTPTreeBase | virtual
GetSelectedList(CTypedPtrList< CPtrList, HTREEITEM > &list) const | CXTPTreeBase |
GetTreeBackColor() const | CXTPTreeBase | protectedvirtual
GetTreeTextColor() const | CXTPTreeBase | protectedvirtual
HasEditLabels() const | CXTPTreeBase | protected
Init() | CXTPTreeBase | protectedvirtual
IsDefaultItemDrawingEnabled() const | CXTPTreeBase |
IsExplorerTheme() const | CXTPTreeBase |
IsFindValid(HTREEITEM hti) | CXTPTreeBase | protectedvirtual
IsFullRowSelectionEnabled() | CXTPTreeBase | protectedvirtual
IsMultiSelect() const | CXTPTreeBase |
IsSelected(HTREEITEM hItem) const | CXTPTreeBase | virtual
m_bBandLabel | CXTPTreeBase | protected
m_bDoDefaultItemDrawing | CXTPTreeBase | protected
m_bExplorerTheme | CXTPTreeBase | protected
m_bMultiSelect | CXTPTreeBase | protected
m_hInsertMark | CXTPTreeBase | protected
m_hSelect | CXTPTreeBase | protected
m_htiEdit | CXTPTreeBase | protected
m_htiLast | CXTPTreeBase | protected
m_iconIndent | CXTPTreeBase | protected
m_InsertMarkAfter | CXTPTreeBase | protected
m_InsertMarkColor | CXTPTreeBase | protected
m_mapColorFont | CXTPTreeBase | protected
m_nTheme | CXTPTreeBase | protected
OnButtonDown(BOOL bLeft, UINT nFlags, CPoint point) | CXTPTreeBase | protectedvirtual
SelectAll(BOOL bSelect=TRUE, HTREEITEM htItem=NULL) | CXTPTreeBase | virtual
SelectAllIgnore(BOOL bSelect, HTREEITEM hIgnore) | CXTPTreeBase | protectedvirtual
SelectChildren(HTREEITEM hParent, BOOL bSelect=TRUE, BOOL bRecurse=TRUE) | CXTPTreeBase |
SelectItem(HTREEITEM hItem) | CXTPTreeBase |
SelectItems(HTREEITEM hItemFrom, HTREEITEM hItemTo, BOOL bOnly=TRUE) | CXTPTreeBase | virtual
SendNotify(LPNMHDR pNMHDR) | CXTPTreeBase | protectedvirtual
SetBandingHit(BOOL bLabel) | CXTPTreeBase |
SetExplorerTheme(BOOL bSet) | CXTPTreeBase |
SetIconIndent(int iconIndent) | CXTPTreeBase |
SetInsertMark(HTREEITEM hItem, BOOL fAfter) | CXTPTreeBase | protected
SetInsertMarkColor(COLORREF clrNew) | CXTPTreeBase | protected
SetItemBackColor(HTREEITEM hItem, COLORREF color) | CXTPTreeBase | virtual
SetItemBold(HTREEITEM hItem, BOOL bBold=TRUE) | CXTPTreeBase | virtual
SetItemColor(HTREEITEM hItem, COLORREF color) | CXTPTreeBase | virtual
SetItemFont(HTREEITEM hItem, LOGFONT &logfont) | CXTPTreeBase | virtual
SetItemState(HTREEITEM hItem, UINT nState, UINT nStateMask) | CXTPTreeBase |
UpdateSelectionForRect(LPCRECT pRect, UINT nFlags, CTypedPtrList< CPtrList, HTREEITEM > &list) | CXTPTreeBase | protectedvirtual
~CXTPTreeBase() | CXTPTreeBase | protectedvirtual


Toolkit Pro: Member List

CXTPTrackControlItem Member List

This is the complete list of members for CXTPTrackControlItem, including all inherited members.

Add(CXTPTrackBlock *pBlock) | CXTPTrackControlItem |
AddHyperlink(CXTPGridHyperlink *pHyperlink) | CXTPGridRecordItem | virtual
AdjustBlockPosition(CXTPTrackBlock *pBlock, BOOL bResize=FALSE) | CXTPTrackControlItem |
Compare(CXTPGridColumn *pColumn, CXTPGridRecordItem *pItem) | CXTPGridRecordItem | virtual
CompareGroupCaption(CXTPGridColumn *pColumn, CXTPGridRecordItem *pItem) | CXTPGridRecordItem | virtual
CompareGroupCaption(CXTPGridColumn *pColumn, CXTPGridGroupRow *pGroupRow) | CXTPGridRecordItem | virtual
CreateBorder() | CXTPGridRecordItem |
CXTPCmdTarget() | CXTPCmdTarget |
CXTPGridRecordItem() | CXTPGridRecordItem |
CXTPTrackControlItem() | CXTPTrackControlItem |
DestroyBorder() | CXTPGridRecordItem |
DoPropExchange(CXTPPropExchange *pPX) | CXTPTrackControlItem | virtual
Draw(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs) | CXTPTrackControlItem | virtual
DrawCheckBox(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CRect &rcItem) | CXTPGridRecordItem | protectedvirtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAlignment() const | CXTPGridRecordItem |
GetBackgroundColor() | CXTPGridRecordItem | virtual
GetBlock(int nIndex) const | CXTPTrackControlItem |
GetBlockCount() const | CXTPTrackControlItem |
GetBorder() const | CXTPGridRecordItem |
GetCanEditCheckboxItem() const | CXTPGridRecordItem |
GetCaption(CXTPGridColumn *pColumn) | CXTPTrackControlItem | virtual
GetCaption() | CXTPTrackControlItem | virtual
GetCaptionRect(XTP_GRIDRECORDITEM_ARGS *pDrawArgs, CRect &rcItem) | CXTPGridRecordItem | virtual
GetCheckedState() const | CXTPGridRecordItem |
GetColumnCaptionPrefix(CXTPGridColumn *pColumn) const | CXTPGridRecordItem |
GetEditOptions(CXTPGridColumn *pColumn) | CXTPGridRecordItem |
GetFont() | CXTPGridRecordItem | virtual
GetFormatString() const | CXTPGridRecordItem | virtual
GetFormula() const | CXTPGridRecordItem | virtual
GetGroupCaption(CXTPGridColumn *pColumn) | CXTPGridRecordItem | virtual
GetGroupCaptionID(CXTPGridColumn *pColumn) | CXTPGridRecordItem | virtual
GetGroupCaptionValue(CXTPGridColumn *pColumn) | CXTPGridRecordItem | virtual
GetGroupPriority() const | CXTPGridRecordItem | virtual
GetHasCheckbox() const | CXTPGridRecordItem | virtual
GetHyperlinkAt(int nHyperlink) const | CXTPGridRecordItem | virtual
GetHyperlinks() | CXTPGridRecordItem | protected
GetHyperlinksCount() const | CXTPGridRecordItem | virtual
GetIconIndex() const | CXTPGridRecordItem | virtual
GetIndex() const | CXTPGridRecordItem |
GetItemControls() | CXTPGridRecordItem |
GetItemData() const | CXTPGridRecordItem | virtual
GetItemMetrics(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pItemMetrics) | CXTPGridRecordItem | virtual
GetMarkupUIElement() const | CXTPGridRecordItem |
GetRecord() const | CXTPGridRecordItem |
GetSelectedConstraintData(XTP_GRIDRECORDITEM_ARGS *pItemArgs) | CXTPGridRecordItem | virtual
GetSortPriority() const | CXTPGridRecordItem | virtual
GetTextColor() | CXTPGridRecordItem | virtual
GetTooltip() const | CXTPGridRecordItem | virtual
GetTrackControl() const | CXTPTrackControlItem |
HasCheckbox(BOOL bHasCheckbox, BOOL bTristate=FALSE) | CXTPGridRecordItem | virtual
HighlightWorkArea(CDC *pDC, CRect rcItem) | CXTPTrackControlItem | protectedvirtual
HitTest(CPoint ptPoint) | CXTPTrackControlItem |
HitTestHyperlink(CPoint ptClick) | CXTPGridRecordItem | virtual
IsBold() const | CXTPGridRecordItem | virtual
IsChecked() const | CXTPGridRecordItem | virtual
IsChildOfMerge() const | CXTPGridRecordItem |
IsEditable() const | CXTPGridRecordItem | virtual
IsFocusable() const | CXTPGridRecordItem | virtual
IsLocked() const | CXTPTrackControlItem |
IsPreviewItem() const | CXTPGridRecordItem | virtual
m_Alignment | CXTPGridRecordItem | protected
m_arrBlocks | CXTPTrackControlItem | protected
m_bBoldText | CXTPGridRecordItem | protected
m_bCanEditCheckboxItem | CXTPGridRecordItem | protected
m_bEditable | CXTPGridRecordItem | protected
m_bFocusable | CXTPGridRecordItem | protected
m_bHasCheckbox | CXTPGridRecordItem | protected
m_bItemControlUnderMouse | CXTPGridRecordItem | protected
m_bLocked | CXTPTrackControlItem |
m_bTristateCheckbox | CXTPGridRecordItem | protected
m_checkState | CXTPGridRecordItem | protected
m_clrBackground | CXTPGridRecordItem | protected
m_clrText | CXTPGridRecordItem | protected
m_dwData | CXTPGridRecordItem | protected
m_nGroupPriority | CXTPGridRecordItem | protected
m_nIconIndex | CXTPGridRecordItem | protected
m_nSortPriority | CXTPGridRecordItem | protected
m_pBorder | CXTPGridRecordItem | protected
m_pControl | CXTPGridRecordItem | protected
m_pEditOptions | CXTPGridRecordItem | protected
m_pFocusedItemControl | CXTPGridRecordItem | protected
m_pFontCaption | CXTPGridRecordItem | protected
m_pHyperlinks | CXTPGridRecordItem | protected
m_pItemControlHookWnd | CXTPGridRecordItem | protected
m_pItemControls | CXTPGridRecordItem | protected
m_pMarkupUIElement | CXTPGridRecordItem | protected
m_pRecord | CXTPGridRecordItem | protected
m_rcGlyph | CXTPGridRecordItem | protected
m_strCaption | CXTPGridRecordItem | protected
m_strFormatString | CXTPGridRecordItem | protected
m_strFormula | CXTPGridRecordItem | protected
m_strGroupCaption | CXTPGridRecordItem | protected
m_strTooltip | CXTPGridRecordItem | protected
OnBeginEdit(XTP_GRIDRECORDITEM_ARGS *pItemArgs) | CXTPGridRecordItem | protectedvirtual
OnCancelEdit(CXTPGridControl *pControl, BOOL bApply) | CXTPGridRecordItem | virtual
OnChar(XTP_GRIDRECORDITEM_ARGS *pItemArgs, UINT nChar) | CXTPGridRecordItem | protectedvirtual
OnClick(XTP_GRIDRECORDITEM_CLICKARGS *pClickArgs) | CXTPTrackControlItem | virtual
OnConstraintChanged(XTP_GRIDRECORDITEM_ARGS *pItemArgs, CXTPGridRecordItemConstraint *pConstraint) | CXTPGridRecordItem | virtual
OnDblClick(XTP_GRIDRECORDITEM_CLICKARGS *pClickArgs) | CXTPTrackControlItem | virtual
OnDrawCaption(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics) | CXTPGridRecordItem | virtual
OnDrawControls(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CRect &rcItem) | CXTPGridRecordItem | virtual
OnEditCanceled(XTP_GRIDRECORDITEM_ARGS *pItemArgs) | CXTPGridRecordItem | virtual
OnEditChanged(XTP_GRIDRECORDITEM_ARGS *pItemArgs, LPCTSTR szText) | CXTPGridRecordItem | virtual
OnEditChanging(XTP_GRIDRECORDITEM_ARGS *pItemArgs, CString &rstrNewText) | CXTPGridRecordItem | virtual
OnInplaceButtonDown(CXTPGridInplaceButton *pButton) | CXTPGridRecordItem | virtual
OnLButtonDown(XTP_GRIDRECORDITEM_CLICKARGS *pClickArgs) | CXTPTrackControlItem | virtual
OnLButtonUp(XTP_GRIDRECORDITEM_CLICKARGS *pClickArgs) | CXTPTrackControlItem | virtual
OnMouseMove(UINT nFlags, CPoint point, CXTPGridControl *pControl=NULL) | CXTPTrackControlItem | virtual
OnRequestEdit(XTP_GRIDRECORDITEM_ARGS *pItemArgs) | CXTPGridRecordItem | protectedvirtual
OnToolHitTest(CPoint point, TOOLINFO *pTI) | CXTPTrackControlItem | virtual
OnValidateEdit(XTP_GRIDRECORDITEM_ARGS *pItemArgs) | CXTPGridRecordItem | virtual
operator delete(void *p) | CXTPHeapObjectT< CXTPCmdTarget, CXTPGridDataAllocator > | inline
operator new(size_t nSize) | CXTPHeapObjectT< CXTPCmdTarget, CXTPGridDataAllocator > | inline
RecalcLayout() | CXTPTrackControlItem |
RedrawControl() | CXTPTrackControlItem |
Remove(CXTPTrackBlock *pBlock) | CXTPTrackControlItem |
RemoveAll() | CXTPTrackControlItem |
RemoveAt(int nIndex) | CXTPTrackControlItem |
RemoveHyperlinkAt(int nHyperlink) | CXTPGridRecordItem | virtual
ResetMarkupUIElement() | CXTPGridRecordItem | virtual
SetAlignment(int nAlignment) | CXTPGridRecordItem |
SetBackgroundColor(COLORREF clrBackground) | CXTPGridRecordItem | virtual
SetBold(BOOL bBold=TRUE) | CXTPGridRecordItem | virtual
SetCanEditCheckboxItem(BOOL bSet) | CXTPGridRecordItem |
SetCaption(LPCTSTR strCaption) | CXTPGridRecordItem | virtual
SetChecked(BOOL bChecked) | CXTPGridRecordItem | virtual
SetCheckedState(int iState) | CXTPGridRecordItem |
SetEditable(BOOL bEditable=TRUE) | CXTPGridRecordItem | virtual
SetFocusable(BOOL bFocusable) | CXTPGridRecordItem | virtual
SetFont(CFont *pFont) | CXTPGridRecordItem | virtual
SetFormatString(LPCTSTR strFormat) | CXTPGridRecordItem | virtual
SetFormula(LPCTSTR sFormula) | CXTPGridRecordItem | virtual
SetGridControl(CXTPGridControl *pControl) | CXTPGridRecordItem |
SetGroupCaption(LPCTSTR strCaption) | CXTPGridRecordItem | virtual
SetGroupPriority(int nGroupPriority) | CXTPGridRecordItem | virtual
SetIconIndex(int nIconIndex) | CXTPGridRecordItem | virtual
SetItemData(DWORD_PTR dwData) | CXTPGridRecordItem | virtual
SetLocked(BOOL bLocked=TRUE) | CXTPTrackControlItem |
SetRecord(CXTPGridRecord *pGridRecord) | CXTPGridRecordItem |
SetSortPriority(int nSortPriority) | CXTPGridRecordItem | virtual
SetTextColor(COLORREF clrText) | CXTPGridRecordItem | virtual
SetTooltip(LPCTSTR lpszTooltip) | CXTPGridRecordItem | virtual
UpdateValue() | CXTPGridRecordItem |
~CXTPGridRecordItem() | CXTPGridRecordItem | virtual
~CXTPTrackControlItem() | CXTPTrackControlItem | virtual


Toolkit Pro: XTPChartAxisLabel.h Source File

  • Source
  • Chart
  • Diagram
  • Axis
XTPChartAxisLabel.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTAXISLABEL_H__)
24# define __XTPCHARTAXISLABEL_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartAxis;
34class CXTPChartNumberFormat;
35
44class _XTP_EXT_CLASS CXTPChartAxisLabel : public CXTPChartTextElement
45{
47 DECLARE_DYNAMIC(CXTPChartAxisLabel)
49public:
56 CXTPChartAxisLabel(CXTPChartAxis* pAxis);
57
62 virtual ~CXTPChartAxisLabel();
63
64public:
71 void SetTextColor(const CXTPChartColor& clrTextColor);
72
79 CXTPChartColor GetTextColor() const;
86 CXTPChartColor GetActualTextColor() const;
87
94 void SetFont(CXTPChartFont* pFont);
95
102 CXTPChartFont* GetFont() const;
103
110 int GetAngle() const;
111
118 void SetAngle(int nAgle);
119
128 void SetAntialiasing(BOOL bAntialiasing);
129
137 BOOL GetAntialiasing() const;
138
146 void SetVisible(BOOL bVisible);
147
154 BOOL IsVisible() const;
155
165 CXTPChartNumberFormat* GetFormat() const;
166
175 void SetFormat(LPCTSTR lpszFormat);
176
177public:
185 CXTPChartAxis* GetAxis() const;
186
187public:
188 void DoPropExchange(CXTPPropExchange* pPX);
189
190# ifdef _XTP_ACTIVEX
191public:
193 DECLARE_DISPATCH_MAP()
194 DECLARE_INTERFACE_MAP()
195 DECLARE_OLETYPELIB_EX(CXTPChartAxisLabel);
196
197 afx_msg LPDISPATCH OleGetFont();
198 afx_msg OLE_COLOR OleGetTextColor();
199 afx_msg void OleSetTextColor(OLE_COLOR clr);
200 afx_msg LPDISPATCH OleGetFormat();
201
203# endif
204
205protected:
206 CXTPChartColor m_clrTextColor;
207 CXTPChartFont* m_pFont;
208 BOOL m_bVisible;
209 BOOL m_bAntialiasing;
210 int m_nAngle;
212 CXTPChartNumberFormat* m_pFormat;
213};
214
215AFX_INLINE CXTPChartAxis* CXTPChartAxisLabel::GetAxis() const
216{
217 return (CXTPChartAxis*)m_pOwner;
218}
219
220AFX_INLINE CXTPChartFont* CXTPChartAxisLabel::GetFont() const
221{
222 return m_pFont;
223}
224
225AFX_INLINE int CXTPChartAxisLabel::GetAngle() const
226{
227 return m_nAngle;
228}
229AFX_INLINE void CXTPChartAxisLabel::SetAngle(int nAgle)
230{
231 m_nAngle = nAgle;
232 OnChartChanged();
233}
234AFX_INLINE void CXTPChartAxisLabel::SetAntialiasing(BOOL bAntialiasing)
235{
236 m_bAntialiasing = bAntialiasing;
237 OnChartChanged();
238}
239AFX_INLINE BOOL CXTPChartAxisLabel::GetAntialiasing() const
240{
241 return m_bAntialiasing;
242}
243AFX_INLINE BOOL CXTPChartAxisLabel::IsVisible() const
244{
245 return m_bVisible;
246}
247AFX_INLINE void CXTPChartAxisLabel::SetVisible(BOOL bVisible)
248{
249 m_bVisible = bVisible;
250 OnChartChanged();
251}
252AFX_INLINE CXTPChartNumberFormat* CXTPChartAxisLabel::GetFormat() const
253{
254 return m_pFormat;
255}
257# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
258#endif //#if !defined(__XTPCHARTAXISLABEL_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartAxis
This abstract base class represents a chart axis as a kind of chart element.
Definition XTPChartAxis.h:86
CXTPChartAxisLabel
CXTPChartAxisLabel is a kind of CXTPChartTextElement.
Definition XTPChartAxisLabel.h:45
CXTPChartAxisLabel::m_pFont
CXTPChartFont * m_pFont
The font used to render the text.
Definition XTPChartAxisLabel.h:207
CXTPChartAxisLabel::GetAxis
CXTPChartAxis * GetAxis() const
Use this function to get the pointer to the axis object to which the label is associated.
Definition XTPChartAxisLabel.h:215
CXTPChartAxisLabel::DoPropExchange
void DoPropExchange(CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
CXTPChartAxisLabel::SetFormat
void SetFormat(LPCTSTR lpszFormat)
Obsolete method.
CXTPChartAxisLabel::GetActualTextColor
CXTPChartColor GetActualTextColor() const
Call this function to get the real text color of the axis label.
CXTPChartAxisLabel::GetAngle
int GetAngle() const
Call this function to get the angle of the text label.
Definition XTPChartAxisLabel.h:225
CXTPChartAxisLabel::GetTextColor
CXTPChartColor GetTextColor() const
Call this function to get the apparent text color of the axis label.
CXTPChartAxisLabel::SetVisible
void SetVisible(BOOL bVisible)
Call this function to set the visibility of the text label.
Definition XTPChartAxisLabel.h:247
CXTPChartAxisLabel::GetFont
CXTPChartFont * GetFont() const
Call this function to get the font of the axis label.
Definition XTPChartAxisLabel.h:220
CXTPChartAxisLabel::~CXTPChartAxisLabel
virtual ~CXTPChartAxisLabel()
Destroys a CXTPChartAxisLabel object, handles cleanup.
CXTPChartAxisLabel::SetTextColor
void SetTextColor(const CXTPChartColor &clrTextColor)
Call this function to set the text color of the axis label.
CXTPChartAxisLabel::GetFormat
CXTPChartNumberFormat * GetFormat() const
Call this function to get a pointer to CXTPChartNumberFormat which specifies how to convert a number ...
Definition XTPChartAxisLabel.h:252
CXTPChartAxisLabel::SetFont
void SetFont(CXTPChartFont *pFont)
Call this function to set the font of the axis label text.
CXTPChartAxisLabel::CXTPChartAxisLabel
CXTPChartAxisLabel(CXTPChartAxis *pAxis)
Constructs a CXTPChartAxisLabel object.
CXTPChartAxisLabel::IsVisible
BOOL IsVisible() const
Call this function to check the visibility of the text label.
Definition XTPChartAxisLabel.h:243
CXTPChartAxisLabel::SetAngle
void SetAngle(int nAgle)
Call this function to set the angle of the text label.
Definition XTPChartAxisLabel.h:229
CXTPChartAxisLabel::SetAntialiasing
void SetAntialiasing(BOOL bAntialiasing)
Call this function to set anti-aliasing ON or OFF.
Definition XTPChartAxisLabel.h:234
CXTPChartAxisLabel::m_bVisible
BOOL m_bVisible
TRUE if the label is visible, FALSE if not.
Definition XTPChartAxisLabel.h:208
CXTPChartAxisLabel::m_nAngle
int m_nAngle
The angle of the label.
Definition XTPChartAxisLabel.h:210
CXTPChartAxisLabel::m_clrTextColor
CXTPChartColor m_clrTextColor
The text color.
Definition XTPChartAxisLabel.h:206
CXTPChartAxisLabel::m_bAntialiasing
BOOL m_bAntialiasing
TRUE if antialiasing enabled, FALSE if not.
Definition XTPChartAxisLabel.h:209
CXTPChartAxisLabel::GetAntialiasing
BOOL GetAntialiasing() const
Call this function to check if anti-aliasing is ON or OFF.
Definition XTPChartAxisLabel.h:239
CXTPChartColor
This class abstracts a color entity.
Definition XTPChartTypes.h:51
CXTPChartElement::OnChartChanged
virtual void OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic propertie...
CXTPChartFont
This class abstracts a font entity.
Definition XTPChartTypes.h:540
CXTPChartNumberFormat
This class helper is used to format number to string.
Definition XTPChartNumberFormat.h:72
CXTPChartTextElement
This class abstracts a chart text element.
Definition XTPChartElement.h:323
CXTPChartTextElement::GetFont
virtual CXTPChartFont * GetFont() const =0
Call this function to get the font of the text element.
CXTPChartTextElement::GetAntialiasing
virtual BOOL GetAntialiasing() const =0
Call this function to check if anti-aliasing is ON or OFF.
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72


Toolkit Pro: Member List

CXTPMarkupViewbox Member List

This is the complete list of members for CXTPMarkupViewbox, including all inherited members.

ApplyRenderTransform(CXTPMarkupDrawingContext *pContext) | CXTPMarkupUIElement | protectedvirtual
Arrange(CRect rcFinalRect) | CXTPMarkupUIElement |
ArrangeCore(CRect rcFinalRect) | CXTPMarkupUIElement | protectedvirtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPMarkupDecorator() | CXTPMarkupDecorator | protected
CXTPMarkupFrameworkElement() | CXTPMarkupFrameworkElement | protected
CXTPMarkupUIElement() | CXTPMarkupUIElement | protected
CXTPMarkupViewbox() | CXTPMarkupViewbox | protected
CXTPMarkupVisual() | CXTPMarkupVisual |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAbsoluteVisualOffset() const | CXTPMarkupVisual | protected
GetActualSize() const | CXTPMarkupFrameworkElement |
GetBoundRect() const | CXTPMarkupVisual |
GetChild() const | CXTPMarkupDecorator |
GetClipToBounds() const | CXTPMarkupFrameworkElement |
GetDesiredSize() const | CXTPMarkupUIElement |
GetFinalRect() const | CXTPMarkupUIElement |
GetHeight() const | CXTPMarkupFrameworkElement |
GetHorizontalAlignment() const | CXTPMarkupFrameworkElement |
GetLayoutClip(CRect &rc) const | CXTPMarkupUIElement | protectedvirtual
GetLogicalChild(int nIndex) const | CXTPMarkupVisual | virtual
GetLogicalChildrenCount() const | CXTPMarkupVisual | virtual
GetMargin() const | CXTPMarkupFrameworkElement |
GetMaxHeight() const | CXTPMarkupFrameworkElement |
GetMaxWidth() const | CXTPMarkupFrameworkElement |
GetMinHeight() const | CXTPMarkupFrameworkElement |
GetMinWidth() const | CXTPMarkupFrameworkElement |
GetOpacity() const | CXTPMarkupUIElement | protectedvirtual
GetRenderSize() const | CXTPMarkupVisual |
GetRenderTransform() const | CXTPMarkupUIElement | protected
GetStretch() const | CXTPMarkupViewbox |
GetStyle() const | CXTPMarkupFrameworkElement |
GetTag() const | CXTPMarkupFrameworkElement |
GetUpdateRect() const | CXTPMarkupVisual |
GetVerticalAlignment() const | CXTPMarkupFrameworkElement |
GetVisibility() const | CXTPMarkupUIElement |
GetVisualChild(int nIndex) const | CXTPMarkupVisual | virtual
GetVisualChildrenCount() const | CXTPMarkupVisual | virtual
GetVisualOffset() const | CXTPMarkupVisual |
GetVisualParent() const | CXTPMarkupVisual |
GetWidth() const | CXTPMarkupFrameworkElement |
InputHitTest(CPoint point) const | CXTPMarkupVisual |
InputHitTestOverride(CPoint point) const | CXTPMarkupVisual | protectedvirtual
InvalidateArrange() | CXTPMarkupUIElement | virtual
InvalidateMeasure() | CXTPMarkupUIElement | virtual
InvalidateMeasureOverride(CXTPMarkupDrawingContext *pDC) | CXTPMarkupUIElement | protectedvirtual
InvalidateVisual() | CXTPMarkupUIElement | virtual
IsEnabled() const | CXTPMarkupUIElement |
IsFocusable() const | CXTPMarkupUIElement |
IsVisible() const | CXTPMarkupUIElement | virtual
m_bArrangeDirty | CXTPMarkupUIElement | protected
m_bArrangeInProgress | CXTPMarkupUIElement | protected
m_bMeasureDirty | CXTPMarkupUIElement | protected
m_bMeasureInProgress | CXTPMarkupUIElement | protected
m_bNeverArranged | CXTPMarkupUIElement | protected
m_bNeverMeasured | CXTPMarkupUIElement | protected
m_pClipToBoundsProperty | CXTPMarkupUIElement | static
m_pFocusableProperty | CXTPMarkupUIElement | static
m_pIsEnabledProperty | CXTPMarkupUIElement | static
m_pOpacityProperty | CXTPMarkupUIElement | static
m_pRenderTransformOriginProperty | CXTPMarkupUIElement | static
m_pRenderTransformProperty | CXTPMarkupUIElement | static
m_ptVisualOffset | CXTPMarkupVisual | protected
m_pVisibilityProperty | CXTPMarkupUIElement | static
m_rcBoundRect | CXTPMarkupVisual | protected
m_rcFinalRect | CXTPMarkupUIElement | protected
m_rcPrevUpdateRect | CXTPMarkupVisual | protected
m_rcUpdateRect | CXTPMarkupVisual | protected
m_szDesiredSize | CXTPMarkupUIElement | protected
m_szPreviousAvailableSize | CXTPMarkupUIElement | protected
m_szRenderSize | CXTPMarkupVisual | protected
Measure(CXTPMarkupDrawingContext *pDC, CSize szAvailableSize) | CXTPMarkupUIElement |
MeasureCore(CXTPMarkupDrawingContext *pDC, CSize szAvailableSize) | CXTPMarkupUIElement | protectedvirtual
OnRender(CXTPMarkupDrawingContext *drawingContext) | CXTPMarkupVisual | protectedvirtual
OnRenderFocusVisual(CXTPMarkupDrawingContext *drawingContext) | CXTPMarkupVisual | protectedvirtual
PtInRectTransform(const RECT &rect, const POINT &point) const | CXTPMarkupVisual | protected
Render(CXTPMarkupDrawingContext *drawingContext) | CXTPMarkupVisual |
RenderClipped(CXTPMarkupDrawingContext *drawingContext) | CXTPMarkupVisual | protectedvirtual
RestoreRenderTransform(CXTPMarkupDrawingContext *pContext, TransformationMatrices &matrices) | CXTPMarkupUIElement | protectedvirtual
SetChild(CXTPMarkupUIElement *pChild) | CXTPMarkupDecorator |
SetClipToBounds(BOOL bClipToBounds) | CXTPMarkupFrameworkElement |
SetHeight(int nHeight) | CXTPMarkupFrameworkElement |
SetHorizontalAlignment(XTPMarkupHorizontalAlignment alignment) | CXTPMarkupFrameworkElement |
SetMargin(int nLeft, int nTop, int nRight, int nBottom) | CXTPMarkupFrameworkElement |
SetMargin(int nMargin) | CXTPMarkupFrameworkElement |
SetMaxHeight(int nHeight) | CXTPMarkupFrameworkElement |
SetMaxWidth(int nWidth) | CXTPMarkupFrameworkElement |
SetMinHeight(int nHeight) | CXTPMarkupFrameworkElement |
SetMinWidth(int nWidth) | CXTPMarkupFrameworkElement |
SetStretch(XTPMarkupStretch stretch) | CXTPMarkupViewbox |
SetTag(CXTPMarkupObject *pTag) | CXTPMarkupFrameworkElement |
SetVerticalAlignment(XTPMarkupVerticalAlignment alignment) | CXTPMarkupFrameworkElement |
SetVisibility(XTPMarkupVisibility visibility) | CXTPMarkupUIElement |
SetWidth(int nWidth) | CXTPMarkupFrameworkElement |
~CXTPMarkupDecorator() | CXTPMarkupDecorator | protectedvirtual
~CXTPMarkupFrameworkElement() | CXTPMarkupFrameworkElement | protectedvirtual
~CXTPMarkupUIElement() | CXTPMarkupUIElement | protectedvirtual
~CXTPMarkupViewbox() | CXTPMarkupViewbox | protectedvirtual
~CXTPMarkupVisual() | CXTPMarkupVisual | virtual


Toolkit Pro: XTPMarkupGdiPlusTranslateTransform.h Source File

  • Source
  • Markup
  • Transform
XTPMarkupGdiPlusTranslateTransform.h
Go to the documentation of this file.
1
23#if !defined(__XTPMARKUPGDIPLUSTRANSLATETRANSFORM_H__)
24# define __XTPMARKUPGDIPLUSTRANSLATETRANSFORM_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPGdiPlus;
34
39class _XTP_EXT_CLASS CXTPMarkupGdiPlusTranslateTransform
40 : public CXTPMarkupGdiPlusTransformObject<CXTPMarkupTranslateTransform>
41{
43 DECLARE_MARKUPCLASS(CXTPMarkupGdiPlusTranslateTransform);
53 virtual BOOL TransformMatrix(const CXTPGdiPlus* pReserved, GpMatrix* pMatrix);
54};
55
56# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
58#endif // !defined(__XTPMARKUPGDIPLUSTRANSLATETRANSFORM_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPMarkupGdiPlusTransformObject
Base class for all GDI+ markup transformation objects.
Definition XTPMarkupGdiPlusTransformObject.h:91
CXTPMarkupGdiPlusTransformObjectImpl::TransformMatrix
virtual BOOL TransformMatrix(const CXTPGdiPlus *pReserved, GpMatrix *pMatrix)=0
An abstract method that performs a native GDI+ matrix transformation.
CXTPMarkupGdiPlusTranslateTransform
GDI+ TranslateTransform implementation.
Definition XTPMarkupGdiPlusTranslateTransform.h:41


Toolkit Pro: Member List

CXTPEditThemeVisualStudio2010 Member List

This is the complete list of members for CXTPEditThemeVisualStudio2010, including all inherited members.

AdjustBuddyRect(CWnd *pBuddy, CRect &rcUpDown, int nAlignment) | CXTPEditThemeOfficeXP | virtual
CtlColor(CDC *pDC, UINT nCtlColor, CXTPEdit *pEdit) | CXTPEditThemeDefault | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPControlTheme() | CXTPControlTheme |
CXTPEditTheme() | CXTPEditTheme |
CXTPEditThemeDefault() | CXTPEditThemeDefault |
CXTPEditThemeOffice2000() | CXTPEditThemeOffice2000 |
CXTPEditThemeOfficeXP() | CXTPEditThemeOfficeXP |
CXTPEditThemeVisualStudio2010() | CXTPEditThemeVisualStudio2010 |
DrawBuddyBorders(CWnd *pBuddy, CDC *pDC, CRect rc, int nAlignment, CXTPEdit *pEdit) | CXTPEditThemeOfficeXP | virtual
CXTPEditThemeOffice2000::DrawBuddyBorders(CDC *pDC, CRect rc, int nAlignment, CXTPEdit *pEdit) | CXTPEditThemeOffice2000 | virtual
DrawFrame(CDC *pDC, CRect rc, int nSize, CBrush *pBrush) | CXTPEditTheme | virtual
DrawNcBorders(CDC *pDC, CRect rcWnd, CXTPEdit *pEdit) | CXTPEditThemeOfficeXP | virtual
DrawNcBordersDefault(CDC *pDC, CRect rcWnd, CXTPEdit *pEdit) | CXTPEditThemeDefault | protectedvirtual
DrawNcScrollBack(CDC *pDC, CRect rcWnd, CXTPEdit *pEdit) | CXTPEditThemeDefault | virtual
FillRect(CDC *pDC, int x, int y, int cx, int cy, CBrush *pBrush) | CXTPEditTheme | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetClientBrush(CDC *pDC, CXTPEdit *pEdit) | CXTPEditTheme | virtual
GetThemeID() const | CXTPEditTheme |
GetThemeStyle() const | CXTPControlTheme |
IsFlatStyle() const | CXTPEditTheme |
m_bFlatStyle | CXTPEditTheme | protected
m_bUseWinTheme | CXTPEditTheme | protected
m_clrBack | CXTPEditTheme |
m_clrBackNonClient | CXTPEditTheme |
m_clrBorder | CXTPEditTheme |
m_clrBorderDisabled | CXTPEditThemeOfficeXP | protected
m_clrBorderHilite | CXTPEditThemeOfficeXP | protected
m_clrText | CXTPEditTheme |
m_clrTextReadOnly | CXTPEditTheme |
m_nTheme | CXTPEditTheme | protected
m_winTheme | CXTPEditTheme | protected
m_xtpBrushBack | CXTPEditTheme |
RedrawFocusedFrame() const | CXTPEditThemeOfficeXP | virtual
RefreshMetrics(CXTPEdit *pEdit) | CXTPEditThemeVisualStudio2010 | virtual
SetFlatStyle(BOOL bFlatStyle) | CXTPEditTheme |
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static
UseWinTheme(BOOL bUseWinTheme) | CXTPEditTheme |
~CXTPEditTheme() | CXTPEditTheme | virtual
~CXTPEditThemeDefault() | CXTPEditThemeDefault | virtual
~CXTPEditThemeOffice2000() | CXTPEditThemeOffice2000 | virtual
~CXTPEditThemeOfficeXP() | CXTPEditThemeOfficeXP | virtual
~CXTPEditThemeVisualStudio2010() | CXTPEditThemeVisualStudio2010 | virtual


Toolkit Pro: XTPSkinObjectTab.h Source File

  • Source
  • SkinFramework
XTPSkinObjectTab.h
Go to the documentation of this file.
1
23#if !defined(__XTPSKINOBJECTTAB_H__)
24# define __XTPSKINOBJECTTAB_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPSkinObjectTab : public CXTPSkinObjectFrame
39{
41 DECLARE_DYNCREATE(CXTPSkinObjectTab)
43public:
48 CXTPSkinObjectTab();
49
54 virtual ~CXTPSkinObjectTab();
55
56protected:
59 void FillClient(CDC* pDC, CRect rc);
60 CRect GetHeaderRect();
61 void FillTabFace(CDC* pDC, CRect rcItem, int iItem, int iCount, BOOL bSelected, BOOL bFocused);
62 void DrawTab(CDC* pDC, int iItem);
63 void DrawTabIcon(CDC* pDC, CRect& rcItem, int iItem);
64 void DrawTabText(CDC* pDC, CRect& rcItem, int iItem, int iCount, BOOL bSelected, BOOL bFocused);
65 void OnDraw(CDC* pDC);
66
67protected:
68 //{{AFX_VIRTUAL(CXTPSkinObjectTab)
69 //}}AFX_VIRTUAL
70
71 //{{AFX_MSG(CXTPSkinObjectTab)
72 afx_msg BOOL OnEraseBkgnd(CDC* pDC);
73 afx_msg LRESULT OnPrintClient(WPARAM wParam, LPARAM /*lParam*/);
74 afx_msg void OnPaint();
75 afx_msg void OnMouseLeave();
76 afx_msg void OnMouseMove(UINT nFlags, CPoint point);
77 //}}AFX_MSG
78 DECLARE_MESSAGE_MAP()
79
80protected:
81 int m_nHotItem;
82 BOOL m_bPaint;
84};
85
86# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
88#endif // !defined(__XTPSKINOBJECTTAB_H__)
XTPDisableNoisyWarnings.h
CXTPSkinObjectFrame
CXTPSkinObjectFrame is a CXTPSkinObject derived class.
Definition XTPSkinObjectFrame.h:75
CXTPSkinObjectTab
CXTPSkinObjectTab is a CXTPSkinObjectFrame derived class.
Definition XTPSkinObjectTab.h:39
CXTPSkinObjectTab::CXTPSkinObjectTab
CXTPSkinObjectTab()
Constructs a CXTPSkinObjectTab object.
CXTPSkinObjectTab::~CXTPSkinObjectTab
virtual ~CXTPSkinObjectTab()
Destroys a CXTPSkinObjectTab object, handles cleanup and deallocation.


Toolkit Pro: XTPChartDiagram2DPane.h Source File

  • Source
  • Chart
  • Diagram
  • Diagram2D
XTPChartDiagram2DPane.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTDIAGRAM2DPANE_H__)
24# define __XTPCHARTDIAGRAM2DPANE_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartAxis;
34class CXTPChartDiagram2D;
35class CXTPChartElementView;
36class CXTPChartDeviceContext;
37class CXTPChartDeviceCommand;
38class CXTPChartAxisView;
39class CXTPChartFillStyle;
40class CXTPChartDiagram2DAppearance;
41class CXTPChartAxisView;
42class CXTPChartDiagram2DAxisView;
43class CXTPChartBoundElementView;
44class CXTPChartSeriesView;
45
46namespace Gdiplus
47{
48class Matrix;
49}
50
51class _XTP_EXT_CLASS CXTPChartDiagram2DPane : public CXTPChartElement
52{
53 DECLARE_DYNAMIC(CXTPChartDiagram2DPane);
54
55public:
56 CXTPChartDiagram2DPane(CXTPChartDiagram* pDiagram);
57 virtual ~CXTPChartDiagram2DPane();
58
59public:
60 virtual CXTPChartElementView* CreateView(CXTPChartDeviceContext* pDC,
61 CXTPChartElementView* pParent);
62
63 CXTPChartDiagram2D* GetDiagram() const;
64
65public:
66 CXTPChartColor GetBackgroundColor() const;
67 CXTPChartColor GetBackgroundColor2() const;
68 CXTPChartColor GetBorderColor() const;
69
70 CXTPChartColor GetActualBackgroundColor() const;
71 CXTPChartColor GetActualBackgroundColor2() const;
72 CXTPChartColor GetActualBorderColor() const;
73
74 void SetBackgroundColor(const CXTPChartColor& color);
75 void SetBackgroundColor2(const CXTPChartColor& color);
76 void SetBorderColor(const CXTPChartColor& color);
77
78 CXTPChartFillStyle* GetFillStyle() const;
79
80public:
81 void DoPropExchange(CXTPPropExchange* pPX);
82
83public:
84 CXTPChartDiagram2DAppearance* GetAppearance() const;
85
86 CXTPChartFillStyle* GetActualFillStyle() const;
87
88protected:
89 CXTPChartColor m_clrBackgroundColor;
90 CXTPChartColor m_clrBackgroundColor2;
91 CXTPChartColor m_clrBorderColor;
92 CXTPChartFillStyle* m_pBackgroundFillStyle;
93};
94
95class _XTP_EXT_CLASS CXTPChartDiagram2DPaneView : public CXTPChartElementView
96{
97public:
98 CXTPChartDiagram2DPaneView(CXTPChartDiagram2DPane* pPane, CXTPChartElementView* pParent);
99 ~CXTPChartDiagram2DPaneView();
100
101public:
102 CRect GetBounds() const;
103
104 CXTPChartPointF GetScreenPoint(const CXTPChartSeriesView* pView, double x, double y) const;
105
106 void CalculateView(CRect rcBounds);
107
108public:
109 CXTPChartAxisView* GetAxisView(CXTPChartAxis* pAxis) const;
110
111 CXTPChartElementView* CreateSeriesView();
112
113protected:
114 virtual CXTPChartDeviceCommand* CreateDeviceCommand(CXTPChartDeviceContext* pDC);
115
116 virtual CXTPChartDeviceCommand* CreateGridLinesDeviceCommand(CXTPChartDeviceContext* pDC,
117 CXTPChartDiagram2DAxisView* pAxis);
118 virtual CXTPChartDeviceCommand* CreateInterlacedDeviceCommand(
119 CXTPChartDeviceContext* pDC, CXTPChartDiagram2DAxisView* pAxis);
120 virtual CXTPChartDeviceCommand* CreateConstantLinesDeviceCommand(
121 CXTPChartDeviceContext* pDC, CXTPChartDiagram2DAxisView* pAxis, BOOL bBehind);
122 virtual CXTPChartDeviceCommand* CreateStripsDeviceCommand(CXTPChartDeviceContext* pDC,
123 CXTPChartDiagram2DAxisView* pAxis);
124
125public:
126 virtual void OnLButtonDown(UINT nFlags, CPoint point);
127 virtual void OnMouseMove(UINT nFlags, CPoint point);
128 virtual BOOL OnSetCursor(CPoint point);
129
130public:
131 CXTPChartDiagram2DPane* m_pPane;
132 CXTPChartElementView* m_pSeriesView;
133 CRect m_rcBounds;
134 CPoint m_ptOldPosition;
135};
136
137AFX_INLINE CXTPChartDiagram2D* CXTPChartDiagram2DPane::GetDiagram() const
138{
139 return (CXTPChartDiagram2D*)m_pOwner;
140}
141AFX_INLINE CRect CXTPChartDiagram2DPaneView::GetBounds() const
142{
143 return m_rcBounds;
144}
145AFX_INLINE CXTPChartFillStyle* CXTPChartDiagram2DPane::GetFillStyle() const
146{
147 return m_pBackgroundFillStyle;
148}
149AFX_INLINE void CXTPChartDiagram2DPane::SetBackgroundColor(const CXTPChartColor& color)
150{
151 m_clrBackgroundColor = color;
152 OnChartChanged();
153}
154AFX_INLINE void CXTPChartDiagram2DPane::SetBackgroundColor2(const CXTPChartColor& color)
155{
156 m_clrBackgroundColor2 = color;
157 OnChartChanged();
158}
159AFX_INLINE void CXTPChartDiagram2DPane::SetBorderColor(const CXTPChartColor& color)
160{
161 m_clrBorderColor = color;
162 OnChartChanged();
163}
165# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
166#endif //#if !defined(__XTPCHARTDIAGRAM2DPANE_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartAxis
This abstract base class represents a chart axis as a kind of chart element.
Definition XTPChartAxis.h:86
CXTPChartColor
This class abstracts a color entity.
Definition XTPChartTypes.h:51
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartDiagram2DAppearance
This class represents the appearance of diagram in 2D.
Definition XTPChartAppearance.h:292
CXTPChartDiagram2DAxisView
This class abstracts the view of a chart axis and its child items in a bounding rectangle context.
Definition XTPChartAxisView.h:128
CXTPChartDiagram2D
This class represents a chart 2D diagram, which is a kind of CXTPChartDiagram.
Definition XTPChartDiagram2D.h:51
CXTPChartDiagram
This class represents a chart diagram, which is a kind of CXTPChartElement.
Definition XTPChartDiagram.h:48
CXTPChartElement
This class abstracts a chart element, this class acts as a base class for all chart elements.
Definition XTPChartElement.h:131
CXTPChartElement::DoPropExchange
virtual void DoPropExchange(CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
CXTPChartElement::GetAppearance
CXTPChartAppearance * GetAppearance() const
Call this function to get the the appearance of the chart.
CXTPChartElement::OnChartChanged
virtual void OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic propertie...
CXTPChartElementView
This class represents the view of a chart element.
Definition XTPChartElementView.h:47
CXTPChartFillStyle
This class abstracts a fill style used to fill the background of various chart elements.
Definition XTPChartFillStyle.h:43
CXTPPoint2T< float >
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72


Toolkit Pro: Member List

CXTPChartLegendAppearance Member List

This is the complete list of members for CXTPChartLegendAppearance, including all inherited members.

ApplyToDeviceContext(CXTPChartDeviceContext *pDC) | CXTPChartElementAppearance | virtual
BackgroundColor | CXTPChartLegendAppearance |
BorderColor | CXTPChartLegendAppearance |
CXTPChartElement() | CXTPChartElement |
CXTPChartElementAppearance(CXTPChartElement *pOwner) | CXTPChartElementAppearance |
CXTPChartLegendAppearance(CXTPChartElement *pOwner) | CXTPChartLegendAppearance |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
DoPropExchange(CXTPPropExchange *pPX) | CXTPChartLegendAppearance | virtual
GetAppearance() const | CXTPChartElement |
GetContent() const | CXTPChartElement |
GetOwner() const | CXTPChartElement |
Is3D() const | CXTPChartObject |
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartElement | virtual
Release() | CXTPChartElement | virtual
TextColor | CXTPChartLegendAppearance |
~CXTPChartElement() | CXTPChartElement | virtual
~CXTPChartElementAppearance() | CXTPChartElementAppearance | virtual


Toolkit Pro: Member List

CXTPFramePaintManager Member List

This is the complete list of members for CXTPFramePaintManager, including all inherited members.

CalcFrameBorder(const CXTPCommandBarsFrameHook *pFrameHook) const | CXTPFramePaintManager | virtual
CalcFrameCaption(const CXTPCommandBarsFrameHook *pFrameHook) const | CXTPFramePaintManager | virtual
CalcFrameRegion(CXTPCommandBarsFrameHook *pFrameHook, CSize sz) const =0 | CXTPFramePaintManager | pure virtual
CreateShadow(CWnd *pFrame) | CXTPFramePaintManager | virtual
CXTPFramePaintManager(CXTPPaintManager *pPaintManager) | CXTPFramePaintManager |
DrawCaptionBar(CDC *pDC, CRect rcCaptionBar, CWnd *pSite, BOOL bActive) | CXTPFramePaintManager | virtual
DrawCaptionText(CDC *pDC, CRect rcCaptionText, CWnd *pSite, BOOL bActive) | CXTPFramePaintManager | virtual
DrawCaptionText(CDC *pDC, CRect rcCaptionText, CWnd *pSite, BOOL bActive, CXTPRibbonBar *pRibbonBar) | CXTPFramePaintManager | virtual
DrawFrame(CDC *pDC, CXTPCommandBarsFrameHook *pFrameHook)=0 | CXTPFramePaintManager | pure virtual
DrawFrameCaptionButton(CDC *pDC, CRect rc, int nId, BOOL bSelected, BOOL bPressed, BOOL bActive)=0 | CXTPFramePaintManager | pure virtual
DrawFrameCaptionButton(CDC *pDC, CRect rc, int nId, BOOL bSelected, BOOL bPressed, BOOL bActive, CXTPRibbonBar *pRibbonBar)=0 | CXTPFramePaintManager | pure virtual
GetFrameCaptionAccentTextColor(BOOL bActive) const | CXTPFramePaintManager | virtual
GetFrameCaptionActiveColor() const | CXTPFramePaintManager |
GetFrameCaptionHeight() const | CXTPFramePaintManager | virtual
GetFrameLargeIcon(CWnd *pFrame) | CXTPFramePaintManager |
GetFrameSmallIcon(CWnd *pFrame) | CXTPFramePaintManager |
GetImages() const | CXTPFramePaintManager |
IsUseSystemAccentColorEnabled() const | CXTPFramePaintManager |
LoadImage(LPCTSTR lpszFileName) | CXTPFramePaintManager |
m_bCaptionCenterAligned | CXTPFramePaintManager |
m_bFlatFrame | CXTPFramePaintManager |
m_bFrameStatusBar | CXTPFramePaintManager |
m_clrFrameCaptionActive | CXTPFramePaintManager | protected
m_clrFrameCaptionInactive | CXTPFramePaintManager | protected
m_clrFrameCaptionTextActive | CXTPFramePaintManager | protected
m_clrFrameCaptionTextActiveBSMode | CXTPFramePaintManager | protected
m_clrFrameCaptionTextActiveTitle | CXTPFramePaintManager | protected
m_clrFrameCaptionTextActiveTitleBSMode | CXTPFramePaintManager | protected
m_clrFrameCaptionTextInactive | CXTPFramePaintManager | protected
m_clrFrameCaptionTextInactiveBSMode | CXTPFramePaintManager | protected
m_fntFrameCaption | CXTPFramePaintManager |
m_hIcon | CXTPFramePaintManager | protected
m_nFrameCaptionHeight | CXTPFramePaintManager |
m_pPaintManager | CXTPFramePaintManager |
m_rcIconMargin | CXTPFramePaintManager | protected
m_szIcon | CXTPFramePaintManager | protected
OnShadowedFrameActiveStateChanged(BOOL bActive, CWnd *pFrame, CXTPFrameShadow *pShadow) | CXTPFramePaintManager | virtual
RefreshMetrics() | CXTPFramePaintManager | virtual
SetIcon(HICON hIcon, CSize szIcon) | CXTPFramePaintManager |
~CXTPFramePaintManager() | CXTPFramePaintManager | virtual


Toolkit Pro: Member List

  • CXTPColorHex
  • CRgnCell
  • CTX_DATA
  • HEXAGON_DATA
CXTPColorHex::CRgnCell::CTX_DATA::HEXAGON_DATA Member List

This is the complete list of members for CXTPColorHex::CRgnCell::CTX_DATA::HEXAGON_DATA, including all inherited members.

half | CXTPColorHex::CRgnCell::CTX_DATA::HEXAGON_DATA
height | CXTPColorHex::CRgnCell::CTX_DATA::HEXAGON_DATA
roof | CXTPColorHex::CRgnCell::CTX_DATA::HEXAGON_DATA
side | CXTPColorHex::CRgnCell::CTX_DATA::HEXAGON_DATA
width | CXTPColorHex::CRgnCell::CTX_DATA::HEXAGON_DATA


Toolkit Pro: Member List

CXTPGaugeMeterType Member List

This is the complete list of members for CXTPGaugeMeterType, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPGaugeBaseType() | CXTPGaugeBaseType | protected
DumpTraits(CString &strTraits) const | CXTPGaugeBaseType |
EnableAutomaticUpdate(BOOL bEnable=TRUE) | CXTPGaugeBaseType |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCurrent() const | CXTPGaugeMeterType |
GetCurrent(UINT nDimension) const | CXTPGaugeMeterType |
GetDimensionCount() const | CXTPGaugeMeterType |
GetMax() const | CXTPGaugeMeterType |
GetMax(UINT nDimension) const | CXTPGaugeMeterType |
GetMin() const | CXTPGaugeMeterType |
GetMin(UINT nDimension) const | CXTPGaugeMeterType |
GetTrait(LPCTSTR pJPath, COleVariant &vtValue) const | CXTPGaugeBaseType |
GetTypeName() const | CXTPGaugeMeterType | virtual
InvokeAction(LPCTSTR lpName, const COleVariant &vtArg=COleVariant(), COleVariant *pvtResult=NULL) | CXTPGaugeBaseType |
IsAutomaticUpdateEnabled() const | CXTPGaugeBaseType |
SetCurrent(double dValue) | CXTPGaugeMeterType |
SetCurrent(UINT nDimension, double dValue) | CXTPGaugeMeterType |
SetMax(double dValue) | CXTPGaugeMeterType |
SetMax(UINT nDimension, double dValue) | CXTPGaugeMeterType |
SetMin(double dValue) | CXTPGaugeMeterType |
SetMin(UINT nDimension, double dValue) | CXTPGaugeMeterType |
SetTrait(LPCTSTR pJPath, const COleVariant &vtValue) | CXTPGaugeBaseType |
UnsetCurrent(UINT nDimension) | CXTPGaugeMeterType |
UnsetMax(UINT nDimension) | CXTPGaugeMeterType |
UnsetMin(UINT nDimension) | CXTPGaugeMeterType |
Update() | CXTPGaugeBaseType |
~CXTPGaugeBaseType() | CXTPGaugeBaseType |
~CXTPGaugeMeterType() | CXTPGaugeMeterType |


Toolkit Pro: Member List

CXTPTrackThemeVisualStudio2012Blue Member List

This is the complete list of members for CXTPTrackThemeVisualStudio2012Blue, including all inherited members.

CalcColumnHeight(CDC *pDC, CXTPGridColumn *pColumn, int nTotalWidth=0) | CXTPGridPaintManager | protectedvirtual
CalculateRowHeight(CDC *pDC, const CString &strText, int nMaxWidth, BOOL bWordBreak=TRUE) | CXTPGridPaintManager | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPGridPaintManager() | CXTPGridPaintManager |
CXTPTrackPaintManager() | CXTPTrackPaintManager |
CXTPTrackThemeOffice2013() | CXTPTrackThemeOffice2013 |
CXTPTrackThemeVisualStudio2012Blue() | CXTPTrackThemeVisualStudio2012Blue |
DrawBitmap(CDC *pDC, CXTPGridControl *pControl, CRect rcColumn, int iImage) | CXTPGridPaintManager | virtual
DrawCollapsedBitmap(CDC *pDC, const CXTPGridRow *pRow, CRect &rcBitmap) | CXTPGridPaintManager | virtual
DrawColumn(CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn, BOOL bDrawExternal=FALSE, int nShadowWidth=0) | CXTPGridPaintManager | virtual
DrawColumnBackground(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, BOOL &bColumnPressed, BOOL &bDraggingFromHeader, CXTPGridHeader *pHeader=NULL) | CXTPTrackThemeOffice2013 | virtual
DrawColumnFooter(CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn) | CXTPGridPaintManager | virtual
DrawColumnFooterDivider(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn) | CXTPGridPaintManager | virtual
DrawColumnIcon(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, CRect rcIcon, int iIcon) | CXTPGridPaintManager | virtual
DrawColumnText(CDC *pDC, CRect rcText, CString strCaption, int nHeaderAlignment, BOOL bIsHeader, BOOL bColumnPressed) | CXTPTrackThemeOffice2013 | virtual
DrawConnector(CDC *pDC, CPoint ptFrom, CPoint ptTo) | CXTPGridPaintManager |
DrawFocusedRow(CDC *pDC, CRect rcRow) | CXTPTrackThemeOffice2013 | virtual
DrawFreezeColsDivider(CDC *pDC, const CRect &rc, CXTPGridControl *pControl, CXTPGridRow *pRow=NULL) | CXTPGridPaintManager | virtual
DrawGlyph(CDC *pDC, CRect rcColumn, int iImage) | CXTPGridPaintManager | virtual
DrawGrid(CDC *pDC, XTPGridOrientation orientation, CRect rcGrid) | CXTPGridPaintManager | virtual
DrawGridPattern(CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush) | CXTPGridPaintManager | protectedvirtual
DrawGridPattern(CDC *pDC, CXTPBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush) | CXTPGridPaintManager | protectedvirtual
DrawGridPattern(CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr) | CXTPGridPaintManager | protectedvirtual
DrawGroupRow(CDC *pDC, CXTPGridGroupRow *pRow, CRect rcRow, XTP_GRIDRECORDITEM_METRICS *pMetrics) | CXTPTrackThemeOffice2013 | virtual
DrawHorizontalLine(CDC *pDC, int xPos, int yPos, int cx, COLORREF clr) | CXTPGridPaintManager |
DrawInplaceButton(CDC *pDC, CXTPGridInplaceButton *pButton) | CXTPGridPaintManager | virtual
DrawInplaceButtonFrame(CDC *pDC, CXTPGridInplaceButton *pButton) | CXTPGridPaintManager | protectedvirtual
DrawInplaceButtonIcon(CDC *pDC, CXTPGridInplaceButton *pButton) | CXTPGridPaintManager | protectedvirtual
DrawInplaceComboButton(CDC *pDC, CRect *pRc) | CXTPGridPaintManager | virtual
DrawInplaceExpandButton(CDC *pDC, CRect *pRc) | CXTPGridPaintManager | virtual
DrawInplaceSpinButton(CDC *pDC, CRect *pRc) | CXTPGridPaintManager | virtual
DrawItemBitmap(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CRect &rcItem, int nImage) | CXTPGridPaintManager | virtual
DrawItemCaption(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics) | CXTPGridPaintManager | virtual
DrawItemControl(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CXTPGridRecordItemControl *pControl, CRect &rcItem) | CXTPGridPaintManager | virtual
DrawLink(int *pnCurrDrawPos, XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CXTPGridHyperlink *pHyperlink, CString strText, CRect rcLink, int nFlag, BOOL bTrim=FALSE) | CXTPGridPaintManager | protectedvirtual
DrawMarkers(CDC *pDC) | CXTPTrackPaintManager | virtual
DrawMultiLineText(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, BOOL bWordBreak=TRUE) | CXTPGridPaintManager | protectedvirtual
DrawNoGroupByText(CDC *pDC, CRect rcItem) | CXTPGridPaintManager | virtual
DrawRowNumber(CDC *pDC, CRect rcNumber, CXTPGridRow *pRow) | CXTPGridPaintManager | virtual
DrawSectionDivider(CDC *pDC, const CRect &rc, XTPGridSectionDividerPosition dividerPosition, XTPGridSectionDividerStyle dividerStyle, CXTPPaintManagerColor dividerColor) | CXTPGridPaintManager |
DrawShellIcon(CDC *pDC, CRect rcColumn, int iImage) | CXTPGridPaintManager | virtual
DrawSingleLineText(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nStartPos, int nEndPos, int nActualWidth) | CXTPGridPaintManager | protectedvirtual
DrawString(int *pnCurrDrawPos, CDC *pDC, const CString &strDraw, CRect rcDraw, UINT nFormat) | CXTPGridPaintManager | protectedvirtual
DrawTextLine(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nFlag, int &nCharCounter, int &nHyperlinkCounter) | CXTPGridPaintManager | protectedvirtual
DrawTimeLine(CDC *pDC) | CXTPTrackPaintManager | virtual
DrawTrackHeader(CDC *pDC) | CXTPTrackPaintManager | virtual
DrawTreeStructure(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CRect rcItem, CSize sizeGlyph) | CXTPGridPaintManager | virtual
DrawTriangle(CDC *pDC, CRect rcTriangle, BOOL bToDown, BOOL bDraggingFromHeader, int nShadowWidth, BOOL bColumnPressed) | CXTPTrackThemeOffice2013 | virtual
DrawVerticalLine(CDC *pDC, int xPos, int yPos, int cy, COLORREF clr) | CXTPGridPaintManager |
DrawVerticalTimeLineMarker(CDC *pDC, int xPos, CXTPGridControl *pControl, COLORREF color=RGB(0, 255, 0)) | CXTPGridPaintManager | virtual
EnablePreviewMode(BOOL bIsPreviewMode) | CXTPGridPaintManager |
FillFooter(CDC *pDC, CRect rcFooter) | CXTPGridPaintManager | virtual
FillGroupByControl(CDC *pDC, CRect &rcGroupBy) | CXTPGridPaintManager | virtual
FillGroupRowMetrics(CXTPGridGroupRow *pRow, XTP_GRIDRECORDITEM_METRICS *pMetrics, BOOL bPrinting) | CXTPTrackThemeOffice2013 | virtual
FillHeaderControl(CDC *pDC, CRect rcHeader) | CXTPGridPaintManager | virtual
FillIndent(CDC *pDC, CRect rcRow) | CXTPGridPaintManager | virtual
FillItemShade(CDC *pDC, CRect rcItem) | CXTPGridPaintManager | virtual
FillRow(CDC *pDC, CXTPGridRow *pRow, CRect rcRow) | CXTPGridPaintManager | virtual
FindRowAdjacentToMerged(const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, BOOL bUpward) | CXTPGridPaintManager |
FindRowAdjacentToMergedEx(const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, int &nAdjRowIndex, BOOL bUpward) | CXTPGridPaintManager |
FormatTime(int nPosition) | CXTPTrackPaintManager | virtual
FormatTimeLineTick(int nPosition, COLORREF &clrTick, int &nTickLength) | CXTPTrackPaintManager | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetColumnOffice2007CustomThemeBaseColor() const | CXTPGridPaintManager |
GetColumnStyle() const | CXTPGridPaintManager |
GetControlBackColor(CXTPGridControl *pControl) | CXTPGridPaintManager | virtual
GetFooterHeight(CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0) | CXTPGridPaintManager | virtual
GetFreezeColsDividerStyle() const | CXTPGridPaintManager |
GetGlyphs() const | CXTPGridPaintManager |
GetHeaderHeight() | CXTPGridPaintManager | virtual
GetHeaderHeight(CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0) | CXTPGridPaintManager | virtual
GetItemHeight(XTP_GRIDRECORDITEM_DRAWARGS &drawArgs, int nWidth) | CXTPGridPaintManager |
GetMaxPreviewLines() | CXTPGridPaintManager |
GetPreviewItemHeight(CDC *pDC, CXTPGridRow *pRow, int nWidth, int nHeight) | CXTPGridPaintManager | virtual
GetPreviewLinesCount(CDC *pDC, CRect &rcText, const CString &strText) | CXTPGridPaintManager |
GetRowHeight(CDC *pDC, CXTPGridRow *pRow) | CXTPTrackThemeOffice2013 | virtual
CXTPTrackPaintManager::GetRowHeight(CDC *pDC, CXTPGridRow *pRow, int nTotalWidth) | CXTPGridPaintManager | virtual
GetRowHeightEx(CDC *pDC, CXTPGridRow *pRow, int nTotalWidth, const BOOL firstLevel=TRUE) | CXTPGridPaintManager |
GetSectionDividerHeight(XTPGridFixedRowsDividerStyle dividerStyle) | CXTPGridPaintManager |
GetTextFont() | CXTPGridPaintManager |
IsColumHotTrackingEnabled() const | CXTPGridPaintManager | virtual
IsColumnPlusMinusSign() const | CXTPGridPaintManager |
IsColumnWidthWYSIWYG() const | CXTPGridPaintManager |
IsDrawGridForEmptySpace() const | CXTPGridPaintManager |
IsFixedInplaceButtonHeight() const | CXTPGridPaintManager |
IsFixedRowHeight() const | CXTPGridPaintManager |
IsGridVisible(BOOL bVertical) const | CXTPGridPaintManager |
IsGridVisible(XTPGridOrientation orientation) const | CXTPGridPaintManager |
IsLastColumnWidthWYSIWYG() const | CXTPGridPaintManager |
IsPreviewMode() const | CXTPGridPaintManager |
IsPrintGroupRowIcon() const | CXTPGridPaintManager |
IsShowWYSIWYGMarkers() const | CXTPGridPaintManager |
IsUseDropMarker() const | CXTPGridPaintManager |
LoadGlyphs() | CXTPTrackThemeVisualStudio2012Blue | virtual
m_arStartCol | CXTPGridPaintManager |
m_bAllowMergeCells | CXTPGridPaintManager |
m_bBaseTreeIndent | CXTPGridPaintManager |
m_bCleanTooltip | CXTPGridPaintManager |
m_bColumnPlusMinusSign | CXTPGridPaintManager | protected
m_bColumnWidthWYSIWYG | CXTPGridPaintManager | protected
m_bCompactText | CXTPGridPaintManager |
m_bDrawGridForEmptySpace | CXTPGridPaintManager | protected
m_bFixedInplaceButtonHeight | CXTPGridPaintManager | protected
m_bFixedRowHeight | CXTPGridPaintManager | protected
m_bForceDynamicMarkupForCell | CXTPGridPaintManager |
m_bForceShowDropMarker | CXTPGridPaintManager |
m_bForceShowTooltip | CXTPGridPaintManager |
m_bGrayIfDisable | CXTPGridPaintManager |
m_bGroupRowTextBold | CXTPGridPaintManager |
m_bHideSelection | CXTPGridPaintManager |
m_bHotTracking | CXTPGridPaintManager |
m_bInvertColumnOnClick | CXTPGridPaintManager |
m_bIsPreviewMode | CXTPGridPaintManager | protected
m_bLastColumnWidthWYSIWYG | CXTPGridPaintManager | protected
m_bMakeUpper | CXTPGridPaintManager |
m_bMoveScrollbarOnFixedColumnsIndent | CXTPGridPaintManager |
m_bPrintGroupRowIcon | CXTPGridPaintManager | protected
m_bPrintPageRectangle | CXTPGridPaintManager |
m_bPrintSortTriangle | CXTPGridPaintManager |
m_bPrintVirtualPageNumber | CXTPGridPaintManager |
m_bPrintWatermark | CXTPGridPaintManager |
m_bRecOrRowNum | CXTPGridPaintManager |
m_bRevertAlignment | CXTPGridPaintManager |
m_bShadeGroupHeadings | CXTPGridPaintManager |
m_bShadeSortColumn | CXTPGridPaintManager |
m_bShowLockIcon | CXTPGridPaintManager |
m_bShowNonActiveInPlaceButton | CXTPGridPaintManager |
m_bShowWYSIWYGMarkers | CXTPGridPaintManager | protected
m_bSortTriangleOffsetFromRight | CXTPGridPaintManager |
m_bThemedInplaceButtons | CXTPGridPaintManager |
m_bUseAlternativeBackground | CXTPGridPaintManager |
m_bUseDropMarker | CXTPGridPaintManager |
m_bUseEditTextAlignment | CXTPGridPaintManager |
m_bUseGroupRowSelectionState | CXTPGridPaintManager |
m_bUseShellIcon | CXTPGridPaintManager |
m_clrAlternativeBackground | CXTPGridPaintManager |
m_clrBoldText | CXTPGridPaintManager |
m_clrBoldTextHighlight | CXTPGridPaintManager |
m_clrBtnFace | CXTPGridPaintManager |
m_clrBtnFacePressed | CXTPGridPaintManager |
m_clrBtnText | CXTPGridPaintManager |
m_clrCaptionText | CXTPGridPaintManager |
m_clrCaptionTextPressed | CXTPGridPaintManager |
m_clrColumnOffice2007CustomTheme | CXTPGridPaintManager |
m_clrConnector | CXTPGridPaintManager |
m_clrControlBack | CXTPGridPaintManager |
m_clrControlDark | CXTPGridPaintManager |
m_clrControlLightLight | CXTPGridPaintManager |
m_clrDisableBitmapDarkest | CXTPGridPaintManager |
m_clrDisableBitmapLightest | CXTPGridPaintManager |
m_clrFormulaSubSum | CXTPGridPaintManager |
m_clrFormulaSum | CXTPGridPaintManager |
m_clrFreezeColsDivider | CXTPGridPaintManager |
m_clrGlyph | CXTPTrackThemeOffice2013 |
m_clrGlyphHighlight | CXTPTrackThemeOffice2013 |
m_clrGradientColumnSeparator | CXTPGridPaintManager |
m_clrGradientColumnShadow | CXTPGridPaintManager |
m_clrGroupBoxBack | CXTPGridPaintManager |
m_clrGroupRowText | CXTPGridPaintManager |
m_clrGroupShadeBack | CXTPGridPaintManager |
m_clrGroupShadeBorder | CXTPGridPaintManager |
m_clrGroupShadeText | CXTPGridPaintManager |
m_clrHeaderControl | CXTPGridPaintManager |
m_clrHighlight | CXTPGridPaintManager |
m_clrHighlightText | CXTPGridPaintManager |
m_clrHotDivider | CXTPGridPaintManager |
m_clrIndentControl | CXTPGridPaintManager |
m_clrItemShade | CXTPGridPaintManager |
m_clrMarker | CXTPTrackPaintManager |
m_clrMarkerBack | CXTPTrackPaintManager |
m_clrMarkerBorder | CXTPTrackPaintManager |
m_clrPreviewText | CXTPGridPaintManager |
m_clrScrollBarBorderDark | CXTPTrackPaintManager |
m_clrScrollBarBorderLight | CXTPTrackPaintManager |
m_clrScrollBarDark | CXTPTrackPaintManager |
m_clrScrollBarLight | CXTPTrackPaintManager |
m_clrSelectedArea | CXTPTrackPaintManager |
m_clrSelectedBorder | CXTPTrackThemeOffice2013 |
m_clrSelectedRow | CXTPGridPaintManager |
m_clrSelectedRowText | CXTPGridPaintManager |
m_clrTimeHeaderBorder | CXTPTrackPaintManager |
m_clrTimeHeaderDark | CXTPTrackPaintManager |
m_clrTimeHeaderDarkDark | CXTPTrackPaintManager |
m_clrTimeHeaderDivider | CXTPTrackPaintManager |
m_clrTimeLinePosition | CXTPTrackPaintManager |
m_clrTimeLineTick | CXTPTrackPaintManager |
m_clrTimeSliderBackground | CXTPTrackPaintManager |
m_clrTrackHeader | CXTPTrackPaintManager |
m_clrTrackMarkerBorder | CXTPTrackPaintManager |
m_clrTrackMarkerText | CXTPTrackPaintManager |
m_clrTrackMarkerTextBack | CXTPTrackPaintManager |
m_clrTrackMarkerTextBorder | CXTPTrackPaintManager |
m_clrTrackTimeArea | CXTPTrackPaintManager |
m_clrWindowText | CXTPGridPaintManager |
m_clrWorkArea | CXTPTrackPaintManager |
m_clrWorkAreaScrollBarBorder | CXTPTrackPaintManager |
m_clrWorkAreaScrollBarDark | CXTPTrackPaintManager |
m_clrWorkAreaScrollBarLight | CXTPTrackPaintManager |
m_columnStyle | CXTPGridPaintManager | protected
m_crlNoGroupByText | CXTPGridPaintManager |
m_grcGradientColumn | CXTPGridPaintManager |
m_grcGradientColumnHot | CXTPGridPaintManager |
m_grcGradientColumnPushed | CXTPGridPaintManager |
m_iRecOrRowStart | CXTPGridPaintManager |
m_nBaseParentRecordIndent | CXTPGridPaintManager |
m_nFixedColumnsIndent | CXTPGridPaintManager |
m_nFooterHeight | CXTPGridPaintManager | protected
m_nFreezeColsDividerStyle | CXTPGridPaintManager | protected
m_nGridLineStylePreviousH | CXTPGridPaintManager | protected
m_nGridLineStylePreviousV | CXTPGridPaintManager | protected
m_nGroupGridLineHeight | CXTPGridPaintManager | protected
m_nGroupGridLineStyle | CXTPGridPaintManager | protected
m_nHeaderHeight | CXTPGridPaintManager | protected
m_nMaxPreviewLines | CXTPGridPaintManager | protected
m_nResizingWidth | CXTPGridPaintManager | protected
m_nRowHeight | CXTPGridPaintManager | protected
m_nRowHeightDefault | CXTPGridPaintManager |
m_nTextIndentForGroupRowsWithNoIcon | CXTPGridPaintManager |
m_nTreeColumnLineLength | CXTPGridPaintManager |
m_nTreeIndent | CXTPGridPaintManager |
m_nTreeStructureStyle | CXTPGridPaintManager |
m_nTreeTextIndent | CXTPGridPaintManager |
m_nTreeTextIndentGroupRow | CXTPGridPaintManager |
m_nTreeTextIndentRowChildren | CXTPGridPaintManager |
m_nTreeTextIndentRowParent | CXTPGridPaintManager |
m_pControl | CXTPGridPaintManager | protected
m_pGlyphs | CXTPGridPaintManager | protected
m_pHyperlinkHoverStyle | CXTPGridPaintManager |
m_pHyperlinkStyle | CXTPGridPaintManager |
m_pMarkupUIElement_NoGroupBy | CXTPGridPaintManager | protected
m_PrintPageWidth | CXTPGridPaintManager |
m_rcPreviewIndent | CXTPGridPaintManager |
m_RecordNumberWidth | CXTPGridPaintManager |
m_strCollapse | CXTPGridPaintManager |
m_strDecreasing | CXTPGridPaintManager |
m_strExpand | CXTPGridPaintManager |
m_strIncreasing | CXTPGridPaintManager |
m_strMarkupUIElement_NoGroupBy | CXTPGridPaintManager | protected
m_strNoFieldsAvailable | CXTPGridPaintManager |
m_strNoGroupBy | CXTPGridPaintManager |
m_strNoItems | CXTPGridPaintManager |
m_strSortBy | CXTPGridPaintManager |
m_szGlyph | CXTPGridPaintManager | protected
m_themeButton | CXTPGridPaintManager | protected
m_themeCombo | CXTPGridPaintManager | protected
m_themeHeader | CXTPGridPaintManager | protected
m_themeSpin | CXTPGridPaintManager | protected
m_treeStructureStyle | CXTPGridPaintManager |
m_xtpBrushGroupGridLineStyle | CXTPGridPaintManager | protected
m_xtpBrushHorizontalGrid | CXTPGridPaintManager | protected
m_xtpBrushTreeStructure | CXTPGridPaintManager | protected
m_xtpBrushVeriticalGrid | CXTPGridPaintManager | protected
m_xtpFontBoldText | CXTPGridPaintManager |
m_xtpFontCaption | CXTPGridPaintManager |
m_xtpFontPreview | CXTPGridPaintManager |
m_xtpFontText | CXTPGridPaintManager |
OnDrawAction(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs) | CXTPGridPaintManager | virtual
RecalcTotalHightOfMergedRows(CXTPGridColumns *pColumns, CDC *pDC, CXTPGridRow *pRow, int nRowHeight, int nTotalWidth) | CXTPGridPaintManager |
RefreshMetrics() | CXTPTrackThemeVisualStudio2012Blue | virtual
SetCaptionFont(LOGFONT &lf) | CXTPGridPaintManager |
SetColumnOffice2007CustomThemeBaseColor(COLORREF clrBaseColor) | CXTPGridPaintManager |
SetColumnPlusMinusSign(BOOL bDraw) | CXTPGridPaintManager |
SetColumnWidthWYSIWYG(BOOL bColumnWidthWYSIWYG) | CXTPGridPaintManager |
SetDrawGridForEmptySpace(BOOL bDrawGrid) | CXTPGridPaintManager |
SetFixedRowHeight(BOOL bFixedRowHeight) | CXTPGridPaintManager |
SetFreezeColsDividerStyle(int nStyle) | CXTPGridPaintManager |
SetGridControl(CXTPGridControl *pControl) | CXTPGridPaintManager | virtual
SetHeaderHeight(int nHeight) | CXTPGridPaintManager | virtual
SetInplaceButtonHeight(BOOL bFixedInplaceButtonHeight) | CXTPGridPaintManager |
SetLastColumnWidthWYSIWYG(BOOL bColumnWidthWYSIWYG) | CXTPGridPaintManager |
SetMaxPreviewLines(int nMaxLines) | CXTPGridPaintManager |
SetPreviewIndent(int nLeft, int nTop, int nRight, int nBottom) | CXTPGridPaintManager |
SetPrintGroupRowIcon(BOOL bDraw) | CXTPGridPaintManager |
SetTextFont(LOGFONT &lf) | CXTPGridPaintManager |
ShowWYSIWYGMarkers(BOOL bSet) | CXTPGridPaintManager |
~CXTPGridPaintManager() | CXTPGridPaintManager | virtual
~CXTPTrackPaintManager() | CXTPTrackPaintManager |


Toolkit Pro: Member List

CXTPExcelTabCtrlThemeVisualStudio2017 Member List

This is the complete list of members for CXTPExcelTabCtrlThemeVisualStudio2017, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPControlTheme() | CXTPControlTheme |
CXTPExcelTabCtrlTheme() | CXTPExcelTabCtrlTheme |
CXTPExcelTabCtrlThemeOffice2013() | CXTPExcelTabCtrlThemeOffice2013 |
CXTPExcelTabCtrlThemeVisualStudio2017() | CXTPExcelTabCtrlThemeVisualStudio2017 |
DrawButton(CDC *pDC, CXTPExcelTabCtrl *pTabCtrl, const CXTPExcelTabCtrlButtonState &state) | CXTPExcelTabCtrlThemeOffice2013 | virtual
DrawButtonBack(CDC *pDC, CRect &rect, const CXTPExcelTabCtrlButtonState &state) | CXTPExcelTabCtrlThemeOffice2013 | virtual
DrawGripper(CDC *pDC, CRect rect) | CXTPExcelTabCtrlThemeOffice2013 | virtual
DrawTab(CDC *pDC, CXTPExcelTabCtrl *pTabCtrl, const CPoint &pt, bool bSelected, CXTPTcbItem *pTcbItem) | CXTPExcelTabCtrlThemeOffice2013 | virtual
FillBackground(CDC *pDC, CRect &rect, BOOL bBottom) | CXTPExcelTabCtrlThemeOffice2013 | virtual
FillTabsBackground(CDC *pDC, int cx, int cy) | CXTPExcelTabCtrlThemeOffice2013 | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetSelTabBackColor(CXTPTcbItem *pTcbItem) const | CXTPExcelTabCtrlTheme | virtual
GetSelTabTextColor(CXTPTcbItem *pTcbItem) const | CXTPExcelTabCtrlTheme | virtual
GetTabBackColor(CXTPTcbItem *pTcbItem) const | CXTPExcelTabCtrlTheme | virtual
GetTabTextColor(CXTPTcbItem *pTcbItem) const | CXTPExcelTabCtrlTheme | virtual
GetThemeStyle() const | CXTPControlTheme |
m_clr3DFace | CXTPExcelTabCtrlTheme |
m_clr3DFaceHilite | CXTPExcelTabCtrlTheme |
m_clr3DFacePushed | CXTPExcelTabCtrlTheme |
m_clr3DHilight | CXTPExcelTabCtrlTheme |
m_clr3DShadow | CXTPExcelTabCtrlTheme |
m_clrBorder3DHilite | CXTPExcelTabCtrlTheme |
m_clrBorder3DShadow | CXTPExcelTabCtrlTheme |
m_clrBtnText | CXTPExcelTabCtrlTheme |
m_clrBtnTextGray | CXTPExcelTabCtrlTheme |
m_clrBtnTextHilite | CXTPExcelTabCtrlTheme |
m_clrBtnTextPushed | CXTPExcelTabCtrlTheme |
m_clrWindow | CXTPExcelTabCtrlTheme |
m_clrWindowText | CXTPExcelTabCtrlTheme |
m_nTheme | CXTPControlTheme | protected
RefreshMetrics(CXTPExcelTabCtrl *pTab) | CXTPExcelTabCtrlThemeOffice2013 | virtual
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static
~CXTPExcelTabCtrlTheme() | CXTPExcelTabCtrlTheme |


Toolkit Pro: Member List

CXTPMarkupSkewTransform Member List

This is the complete list of members for CXTPMarkupSkewTransform, including all inherited members.

ApplyTransform(const CXTPMarkupTransformationMatrix *pMatrix) | CXTPMarkupSkewTransform | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPMarkupTransform() | CXTPMarkupTransform | protected
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAngleX() const | CXTPMarkupSkewTransform |
GetAngleY() const | CXTPMarkupSkewTransform |
GetCenterX() const | CXTPMarkupSkewTransform |
GetCenterY() const | CXTPMarkupSkewTransform |
m_pPropertyAngleX | CXTPMarkupSkewTransform | static
m_pPropertyAngleY | CXTPMarkupSkewTransform | static
m_pPropertyCenterX | CXTPMarkupSkewTransform | static
m_pPropertyCenterY | CXTPMarkupSkewTransform | static
SetAngleX(double angleX) | CXTPMarkupSkewTransform |
SetAngleY(double angleY) | CXTPMarkupSkewTransform |
SetCenterX(double centerX) | CXTPMarkupSkewTransform |
SetCenterY(double centerY) | CXTPMarkupSkewTransform |


Toolkit Pro: XTPTrackThemeVisualStudio2017.h Source File

  • Source
  • GridControl
  • TrackControl
  • Themes
XTPTrackThemeVisualStudio2017.h
Go to the documentation of this file.
1
23#if !defined(__XTPTRACKTHEMEVISUALSTUDIO2017_H__)
24# define __XTPTRACKTHEMEVISUALSTUDIO2017_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPTrackThemeVisualStudio2017 : public CXTPTrackThemeOffice2013
39{
40public:
45 CXTPTrackThemeVisualStudio2017();
46
52 virtual void RefreshMetrics();
53};
55# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
56#endif //#if !defined(__XTPTRACKTHEMEVISUALSTUDIO2017_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPTrackThemeOffice2013
CXTPTrackThemeOffice2013 is a CXTPTrackPaintManager derived class that represents an Office 2013 styl...
Definition XTPTrackThemeOffice2013.h:39
CXTPTrackThemeVisualStudio2017
CXTPTrackThemeVisualStudio2017 is a CXTPTrackThemeOffice2013 derived class that represents a Visual S...
Definition XTPTrackThemeVisualStudio2017.h:39
CXTPTrackThemeVisualStudio2017::CXTPTrackThemeVisualStudio2017
CXTPTrackThemeVisualStudio2017()
Default paint manager constructor, handles properties initialization.
CXTPTrackThemeVisualStudio2017::RefreshMetrics
virtual void RefreshMetrics()
This method is called to refresh the visual metrics of the track control.


Toolkit Pro: XTPGridHitTestInfo.h Source File

  • Source
  • GridControl
XTPGridHitTestInfo.h
Go to the documentation of this file.
1
23#if !defined(__XTPGRIDHITTESTINFO_H__)
24# define __XTPGRIDHITTESTINFO_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33// Forward declarations
34
35class CXTPGridColumn;
36class CXTPGridRow;
37class CXTPGridRecordItem;
38class CXTPTrackBlock;
39
40enum XTPGridHitTestInfoCode
41{
42 xtpGridHitTestUnknown = 0,
43 xtpGridHitTestHeader = 1,
44 xtpGridHitTestGroupBox = 2,
45 xtpGridHitTestBodyRows = 3,
46 xtpGridHitTestBlock = 4,
47 xtpGridHitTestHeaderRows = 5,
48 xtpGridHitTestFooterRows = 6
49};
50
51class _XTP_EXT_CLASS CXTPGridHitTestInfo : public CXTPCmdTarget
52{
54 DECLARE_DYNCREATE(CXTPGridHitTestInfo)
56public:
57 CXTPGridHitTestInfo();
58 virtual ~CXTPGridHitTestInfo();
59
60 // Attributes
61
62public:
63 XTPGridHitTestInfoCode m_htCode;
64 CXTPGridColumn* m_pColumn;
65 CXTPGridRow* m_pRow;
66 CXTPGridRecordItem* m_pItem;
67 CXTPTrackBlock* m_pBlock;
68 int m_iTrackPosition;
69
70# ifdef _XTP_ACTIVEX
72public:
73 LPDISPATCH OleGetColumn();
74 LPDISPATCH OleGetRow();
75 LPDISPATCH OleGetItem();
76 LPDISPATCH OleGetBlock();
77 long OleGetTrackPosition();
78 long OleGetHt();
79
80protected:
81 DECLARE_DISPATCH_MAP()
82 DECLARE_INTERFACE_MAP()
83 DECLARE_OLETYPELIB_EX(CXTPGridHitTestInfo);
85# endif
86};
87
88# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
90#endif // !defined(__XTPGRIDHITTESTINFO_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPGridColumn
Represents a grid column item with its properties and operations.
Definition XTPGridColumn.h:107
CXTPGridRecordItem
Class for working with single list cell.
Definition XTPGridRecordItem.h:600
CXTPGridRow
CXTPGridRow class represents a row of the Grid control window.
Definition XTPGridRow.h:71
CXTPTrackBlock
This class represents a track control block.
Definition XTPTrackBlock.h:42


Toolkit Pro: Member List

CXTPGridThemeOffice2013 Member List

This is the complete list of members for CXTPGridThemeOffice2013, including all inherited members.

CalcColumnHeight(CDC *pDC, CXTPGridColumn *pColumn, int nTotalWidth=0) | CXTPGridPaintManager | protectedvirtual
CalculateRowHeight(CDC *pDC, const CString &strText, int nMaxWidth, BOOL bWordBreak=TRUE) | CXTPGridPaintManager | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPGridPaintManager() | CXTPGridPaintManager |
CXTPGridThemeOffice2013() | CXTPGridThemeOffice2013 |
DrawBitmap(CDC *pDC, CXTPGridControl *pControl, CRect rcColumn, int iImage) | CXTPGridPaintManager | virtual
DrawCollapsedBitmap(CDC *pDC, const CXTPGridRow *pRow, CRect &rcBitmap) | CXTPGridThemeOffice2013 | virtual
DrawColumn(CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn, BOOL bDrawExternal=FALSE, int nShadowWidth=0) | CXTPGridPaintManager | virtual
DrawColumnBackground(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, BOOL &bColumnPressed, BOOL &bDraggingFromHeader, CXTPGridHeader *pHeader=NULL) | CXTPGridThemeOffice2013 | virtual
DrawColumnFooter(CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn) | CXTPGridPaintManager | virtual
DrawColumnFooterDivider(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn) | CXTPGridPaintManager | virtual
DrawColumnIcon(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, CRect rcIcon, int iIcon) | CXTPGridPaintManager | virtual
DrawColumnText(CDC *pDC, CRect rcText, CString strCaption, int nHeaderAlignment, BOOL bIsHeader, BOOL bColumnPressed) | CXTPGridThemeOffice2013 | virtual
DrawConnector(CDC *pDC, CPoint ptFrom, CPoint ptTo) | CXTPGridPaintManager |
DrawFocusedRow(CDC *pDC, CRect rcRow) | CXTPGridThemeOffice2013 | virtual
DrawFreezeColsDivider(CDC *pDC, const CRect &rc, CXTPGridControl *pControl, CXTPGridRow *pRow=NULL) | CXTPGridPaintManager | virtual
DrawGlyph(CDC *pDC, CRect rcColumn, int iImage) | CXTPGridPaintManager | virtual
DrawGrid(CDC *pDC, XTPGridOrientation orientation, CRect rcGrid) | CXTPGridPaintManager | virtual
DrawGridPattern(CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush) | CXTPGridPaintManager | protectedvirtual
DrawGridPattern(CDC *pDC, CXTPBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush) | CXTPGridPaintManager | protectedvirtual
DrawGridPattern(CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr) | CXTPGridPaintManager | protectedvirtual
DrawGroupRow(CDC *pDC, CXTPGridGroupRow *pRow, CRect rcRow, XTP_GRIDRECORDITEM_METRICS *pMetrics) | CXTPGridThemeOffice2013 | virtual
DrawHorizontalLine(CDC *pDC, int xPos, int yPos, int cx, COLORREF clr) | CXTPGridPaintManager |
DrawInplaceButton(CDC *pDC, CXTPGridInplaceButton *pButton) | CXTPGridPaintManager | virtual
DrawInplaceButtonFrame(CDC *pDC, CXTPGridInplaceButton *pButton) | CXTPGridPaintManager | protectedvirtual
DrawInplaceButtonIcon(CDC *pDC, CXTPGridInplaceButton *pButton) | CXTPGridPaintManager | protectedvirtual
DrawInplaceComboButton(CDC *pDC, CRect *pRc) | CXTPGridPaintManager | virtual
DrawInplaceExpandButton(CDC *pDC, CRect *pRc) | CXTPGridPaintManager | virtual
DrawInplaceSpinButton(CDC *pDC, CRect *pRc) | CXTPGridPaintManager | virtual
DrawItemBitmap(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CRect &rcItem, int nImage) | CXTPGridPaintManager | virtual
DrawItemCaption(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics) | CXTPGridPaintManager | virtual
DrawItemControl(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CXTPGridRecordItemControl *pControl, CRect &rcItem) | CXTPGridPaintManager | virtual
DrawLink(int *pnCurrDrawPos, XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CXTPGridHyperlink *pHyperlink, CString strText, CRect rcLink, int nFlag, BOOL bTrim=FALSE) | CXTPGridPaintManager | protectedvirtual
DrawMultiLineText(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, BOOL bWordBreak=TRUE) | CXTPGridPaintManager | protectedvirtual
DrawNoGroupByText(CDC *pDC, CRect rcItem) | CXTPGridPaintManager | virtual
DrawRowNumber(CDC *pDC, CRect rcNumber, CXTPGridRow *pRow) | CXTPGridPaintManager | virtual
DrawSectionDivider(CDC *pDC, const CRect &rc, XTPGridSectionDividerPosition dividerPosition, XTPGridSectionDividerStyle dividerStyle, CXTPPaintManagerColor dividerColor) | CXTPGridPaintManager |
DrawShellIcon(CDC *pDC, CRect rcColumn, int iImage) | CXTPGridPaintManager | virtual
DrawSingleLineText(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nStartPos, int nEndPos, int nActualWidth) | CXTPGridPaintManager | protectedvirtual
DrawString(int *pnCurrDrawPos, CDC *pDC, const CString &strDraw, CRect rcDraw, UINT nFormat) | CXTPGridPaintManager | protectedvirtual
DrawTextLine(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nFlag, int &nCharCounter, int &nHyperlinkCounter) | CXTPGridPaintManager | protectedvirtual
DrawTreeStructure(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CRect rcItem, CSize sizeGlyph) | CXTPGridPaintManager | virtual
DrawTriangle(CDC *pDC, CRect rcTriangle, BOOL bToDown, BOOL bDraggingFromHeader, int nShadowWidth, BOOL bColumnPressed) | CXTPGridThemeOffice2013 | virtual
DrawVerticalLine(CDC *pDC, int xPos, int yPos, int cy, COLORREF clr) | CXTPGridPaintManager |
DrawVerticalTimeLineMarker(CDC *pDC, int xPos, CXTPGridControl *pControl, COLORREF color=RGB(0, 255, 0)) | CXTPGridPaintManager | virtual
EnablePreviewMode(BOOL bIsPreviewMode) | CXTPGridPaintManager |
FillFooter(CDC *pDC, CRect rcFooter) | CXTPGridPaintManager | virtual
FillGroupByControl(CDC *pDC, CRect &rcGroupBy) | CXTPGridPaintManager | virtual
FillGroupRowMetrics(CXTPGridGroupRow *pRow, XTP_GRIDRECORDITEM_METRICS *pMetrics, BOOL bPrinting) | CXTPGridThemeOffice2013 | virtual
FillHeaderControl(CDC *pDC, CRect rcHeader) | CXTPGridPaintManager | virtual
FillIndent(CDC *pDC, CRect rcRow) | CXTPGridPaintManager | virtual
FillItemShade(CDC *pDC, CRect rcItem) | CXTPGridPaintManager | virtual
FillRow(CDC *pDC, CXTPGridRow *pRow, CRect rcRow) | CXTPGridPaintManager | virtual
FindRowAdjacentToMerged(const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, BOOL bUpward) | CXTPGridPaintManager |
FindRowAdjacentToMergedEx(const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, int &nAdjRowIndex, BOOL bUpward) | CXTPGridPaintManager |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetColumnOffice2007CustomThemeBaseColor() const | CXTPGridPaintManager |
GetColumnStyle() const | CXTPGridPaintManager |
GetControlBackColor(CXTPGridControl *pControl) | CXTPGridPaintManager | virtual
GetFooterHeight(CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0) | CXTPGridPaintManager | virtual
GetFreezeColsDividerStyle() const | CXTPGridPaintManager |
GetGlyphs() const | CXTPGridPaintManager |
GetHeaderHeight() | CXTPGridPaintManager | virtual
GetHeaderHeight(CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0) | CXTPGridPaintManager | virtual
GetItemHeight(XTP_GRIDRECORDITEM_DRAWARGS &drawArgs, int nWidth) | CXTPGridPaintManager |
GetMaxPreviewLines() | CXTPGridPaintManager |
GetPreviewItemHeight(CDC *pDC, CXTPGridRow *pRow, int nWidth, int nHeight) | CXTPGridPaintManager | virtual
GetPreviewLinesCount(CDC *pDC, CRect &rcText, const CString &strText) | CXTPGridPaintManager |
GetRowHeight(CDC *pDC, CXTPGridRow *pRow) | CXTPGridThemeOffice2013 | virtual
GetRowHeight(CDC *pDC, CXTPGridRow *pRow, int nTotalWidth) | CXTPGridThemeOffice2013 | virtual
GetRowHeightEx(CDC *pDC, CXTPGridRow *pRow, int nTotalWidth, const BOOL firstLevel=TRUE) | CXTPGridPaintManager |
GetSectionDividerHeight(XTPGridFixedRowsDividerStyle dividerStyle) | CXTPGridPaintManager |
GetTextFont() | CXTPGridPaintManager |
IsColumHotTrackingEnabled() const | CXTPGridPaintManager | virtual
IsColumnPlusMinusSign() const | CXTPGridPaintManager |
IsColumnWidthWYSIWYG() const | CXTPGridPaintManager |
IsDrawGridForEmptySpace() const | CXTPGridPaintManager |
IsFixedInplaceButtonHeight() const | CXTPGridPaintManager |
IsFixedRowHeight() const | CXTPGridPaintManager |
IsGridVisible(BOOL bVertical) const | CXTPGridPaintManager |
IsGridVisible(XTPGridOrientation orientation) const | CXTPGridPaintManager |
IsLastColumnWidthWYSIWYG() const | CXTPGridPaintManager |
IsPreviewMode() const | CXTPGridPaintManager |
IsPrintGroupRowIcon() const | CXTPGridPaintManager |
IsShowWYSIWYGMarkers() const | CXTPGridPaintManager |
IsUseDropMarker() const | CXTPGridPaintManager |
LoadGlyphs() | CXTPGridThemeOffice2013 | virtual
m_arStartCol | CXTPGridPaintManager |
m_bAllowMergeCells | CXTPGridPaintManager |
m_bBaseTreeIndent | CXTPGridPaintManager |
m_bCleanTooltip | CXTPGridPaintManager |
m_bColumnPlusMinusSign | CXTPGridPaintManager | protected
m_bColumnWidthWYSIWYG | CXTPGridPaintManager | protected
m_bCompactText | CXTPGridPaintManager |
m_bDrawGridForEmptySpace | CXTPGridPaintManager | protected
m_bFixedInplaceButtonHeight | CXTPGridPaintManager | protected
m_bFixedRowHeight | CXTPGridPaintManager | protected
m_bForceDynamicMarkupForCell | CXTPGridPaintManager |
m_bForceShowDropMarker | CXTPGridPaintManager |
m_bForceShowTooltip | CXTPGridPaintManager |
m_bGrayIfDisable | CXTPGridPaintManager |
m_bGroupRowTextBold | CXTPGridPaintManager |
m_bHideSelection | CXTPGridPaintManager |
m_bHotTracking | CXTPGridPaintManager |
m_bInvertColumnOnClick | CXTPGridPaintManager |
m_bIsPreviewMode | CXTPGridPaintManager | protected
m_bLastColumnWidthWYSIWYG | CXTPGridPaintManager | protected
m_bMakeUpper | CXTPGridPaintManager |
m_bMoveScrollbarOnFixedColumnsIndent | CXTPGridPaintManager |
m_bPrintGroupRowIcon | CXTPGridPaintManager | protected
m_bPrintPageRectangle | CXTPGridPaintManager |
m_bPrintSortTriangle | CXTPGridPaintManager |
m_bPrintVirtualPageNumber | CXTPGridPaintManager |
m_bPrintWatermark | CXTPGridPaintManager |
m_bRecOrRowNum | CXTPGridPaintManager |
m_bRevertAlignment | CXTPGridPaintManager |
m_bShadeGroupHeadings | CXTPGridPaintManager |
m_bShadeSortColumn | CXTPGridPaintManager |
m_bShowLockIcon | CXTPGridPaintManager |
m_bShowNonActiveInPlaceButton | CXTPGridPaintManager |
m_bShowWYSIWYGMarkers | CXTPGridPaintManager | protected
m_bSortTriangleOffsetFromRight | CXTPGridPaintManager |
m_bThemedInplaceButtons | CXTPGridPaintManager |
m_bUseAlternativeBackground | CXTPGridPaintManager |
m_bUseDropMarker | CXTPGridPaintManager |
m_bUseEditTextAlignment | CXTPGridPaintManager |
m_bUseGroupRowSelectionState | CXTPGridPaintManager |
m_bUseShellIcon | CXTPGridPaintManager |
m_clrAlternativeBackground | CXTPGridPaintManager |
m_clrBoldText | CXTPGridPaintManager |
m_clrBoldTextHighlight | CXTPGridPaintManager |
m_clrBtnFace | CXTPGridPaintManager |
m_clrBtnFacePressed | CXTPGridPaintManager |
m_clrBtnText | CXTPGridPaintManager |
m_clrCaptionText | CXTPGridPaintManager |
m_clrCaptionTextPressed | CXTPGridPaintManager |
m_clrColumnOffice2007CustomTheme | CXTPGridPaintManager |
m_clrConnector | CXTPGridPaintManager |
m_clrControlBack | CXTPGridPaintManager |
m_clrControlDark | CXTPGridPaintManager |
m_clrControlLightLight | CXTPGridPaintManager |
m_clrDisableBitmapDarkest | CXTPGridPaintManager |
m_clrDisableBitmapLightest | CXTPGridPaintManager |
m_clrFormulaSubSum | CXTPGridPaintManager |
m_clrFormulaSum | CXTPGridPaintManager |
m_clrFreezeColsDivider | CXTPGridPaintManager |
m_clrGlyph | CXTPGridThemeOffice2013 |
m_clrGlyphBorder | CXTPGridThemeOffice2013 |
m_clrGlyphContract | CXTPGridThemeOffice2013 |
m_clrGlyphExpand | CXTPGridThemeOffice2013 |
m_clrGlyphHighlight | CXTPGridThemeOffice2013 |
m_clrGradientColumnSeparator | CXTPGridPaintManager |
m_clrGradientColumnShadow | CXTPGridPaintManager |
m_clrGroupBoxBack | CXTPGridPaintManager |
m_clrGroupRowText | CXTPGridPaintManager |
m_clrGroupShadeBack | CXTPGridPaintManager |
m_clrGroupShadeBorder | CXTPGridPaintManager |
m_clrGroupShadeText | CXTPGridPaintManager |
m_clrHeaderControl | CXTPGridPaintManager |
m_clrHighlight | CXTPGridPaintManager |
m_clrHighlightText | CXTPGridPaintManager |
m_clrHotDivider | CXTPGridPaintManager |
m_clrIndentControl | CXTPGridPaintManager |
m_clrItemShade | CXTPGridPaintManager |
m_clrPreviewText | CXTPGridPaintManager |
m_clrSelectedRow | CXTPGridPaintManager |
m_clrSelectedRowText | CXTPGridPaintManager |
m_clrWindowText | CXTPGridPaintManager |
m_columnStyle | CXTPGridPaintManager | protected
m_crlNoGroupByText | CXTPGridPaintManager |
m_grcGradientColumn | CXTPGridPaintManager |
m_grcGradientColumnHot | CXTPGridPaintManager |
m_grcGradientColumnPushed | CXTPGridPaintManager |
m_iRecOrRowStart | CXTPGridPaintManager |
m_nBaseParentRecordIndent | CXTPGridPaintManager |
m_nFixedColumnsIndent | CXTPGridPaintManager |
m_nFooterHeight | CXTPGridPaintManager | protected
m_nFreezeColsDividerStyle | CXTPGridPaintManager | protected
m_nGridLineStylePreviousH | CXTPGridPaintManager | protected
m_nGridLineStylePreviousV | CXTPGridPaintManager | protected
m_nGroupGridLineHeight | CXTPGridPaintManager | protected
m_nGroupGridLineStyle | CXTPGridPaintManager | protected
m_nHeaderHeight | CXTPGridPaintManager | protected
m_nMaxPreviewLines | CXTPGridPaintManager | protected
m_nResizingWidth | CXTPGridPaintManager | protected
m_nRowHeight | CXTPGridPaintManager | protected
m_nRowHeightDefault | CXTPGridPaintManager |
m_nTextIndentForGroupRowsWithNoIcon | CXTPGridPaintManager |
m_nTreeColumnLineLength | CXTPGridPaintManager |
m_nTreeIndent | CXTPGridPaintManager |
m_nTreeStructureStyle | CXTPGridPaintManager |
m_nTreeTextIndent | CXTPGridPaintManager |
m_nTreeTextIndentGroupRow | CXTPGridPaintManager |
m_nTreeTextIndentRowChildren | CXTPGridPaintManager |
m_nTreeTextIndentRowParent | CXTPGridPaintManager |
m_pControl | CXTPGridPaintManager | protected
m_pGlyphs | CXTPGridPaintManager | protected
m_pHyperlinkHoverStyle | CXTPGridPaintManager |
m_pHyperlinkStyle | CXTPGridPaintManager |
m_pMarkupUIElement_NoGroupBy | CXTPGridPaintManager | protected
m_PrintPageWidth | CXTPGridPaintManager |
m_rcPreviewIndent | CXTPGridPaintManager |
m_RecordNumberWidth | CXTPGridPaintManager |
m_strCollapse | CXTPGridPaintManager |
m_strDecreasing | CXTPGridPaintManager |
m_strExpand | CXTPGridPaintManager |
m_strIncreasing | CXTPGridPaintManager |
m_strMarkupUIElement_NoGroupBy | CXTPGridPaintManager | protected
m_strNoFieldsAvailable | CXTPGridPaintManager |
m_strNoGroupBy | CXTPGridPaintManager |
m_strNoItems | CXTPGridPaintManager |
m_strSortBy | CXTPGridPaintManager |
m_szGlyph | CXTPGridPaintManager | protected
m_themeButton | CXTPGridPaintManager | protected
m_themeCombo | CXTPGridPaintManager | protected
m_themeHeader | CXTPGridPaintManager | protected
m_themeSpin | CXTPGridPaintManager | protected
m_treeStructureStyle | CXTPGridPaintManager |
m_xtpBrushGroupGridLineStyle | CXTPGridPaintManager | protected
m_xtpBrushHorizontalGrid | CXTPGridPaintManager | protected
m_xtpBrushTreeStructure | CXTPGridPaintManager | protected
m_xtpBrushVeriticalGrid | CXTPGridPaintManager | protected
m_xtpFontBoldText | CXTPGridPaintManager |
m_xtpFontCaption | CXTPGridPaintManager |
m_xtpFontPreview | CXTPGridPaintManager |
m_xtpFontText | CXTPGridPaintManager |
OnDrawAction(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs) | CXTPGridPaintManager | virtual
RecalcTotalHightOfMergedRows(CXTPGridColumns *pColumns, CDC *pDC, CXTPGridRow *pRow, int nRowHeight, int nTotalWidth) | CXTPGridPaintManager |
RefreshMetrics() | CXTPGridThemeOffice2013 | virtual
SetCaptionFont(LOGFONT &lf) | CXTPGridPaintManager |
SetColumnOffice2007CustomThemeBaseColor(COLORREF clrBaseColor) | CXTPGridPaintManager |
SetColumnPlusMinusSign(BOOL bDraw) | CXTPGridPaintManager |
SetColumnStyle(XTPGridColumnStyle columnStyle) | CXTPGridPaintManager |
SetColumnWidthWYSIWYG(BOOL bColumnWidthWYSIWYG) | CXTPGridPaintManager |
SetDrawGridForEmptySpace(BOOL bDrawGrid) | CXTPGridPaintManager |
SetFixedRowHeight(BOOL bFixedRowHeight) | CXTPGridPaintManager |
SetFreezeColsDividerStyle(int nStyle) | CXTPGridPaintManager |
SetGridControl(CXTPGridControl *pControl) | CXTPGridPaintManager | virtual
SetHeaderHeight(int nHeight) | CXTPGridPaintManager | virtual
SetInplaceButtonHeight(BOOL bFixedInplaceButtonHeight) | CXTPGridPaintManager |
SetLastColumnWidthWYSIWYG(BOOL bColumnWidthWYSIWYG) | CXTPGridPaintManager |
SetMaxPreviewLines(int nMaxLines) | CXTPGridPaintManager |
SetPreviewIndent(int nLeft, int nTop, int nRight, int nBottom) | CXTPGridPaintManager |
SetPrintGroupRowIcon(BOOL bDraw) | CXTPGridPaintManager |
SetTextFont(LOGFONT &lf) | CXTPGridPaintManager |
ShowWYSIWYGMarkers(BOOL bSet) | CXTPGridPaintManager |
~CXTPGridPaintManager() | CXTPGridPaintManager | virtual


Toolkit Pro: Member List

CXTPTaskPanelScrollButton Member List

This is the complete list of members for CXTPTaskPanelScrollButton, including all inherited members.

bEnabled | CXTPTaskPanelScrollButton
bHot | CXTPTaskPanelScrollButton
bPressed | CXTPTaskPanelScrollButton
bScrollUp | CXTPTaskPanelScrollButton
CXTPTaskPanelScrollButton(BOOL bScrollUp) | CXTPTaskPanelScrollButton
IsVisible() const | CXTPTaskPanelScrollButton
pGroupCaption | CXTPTaskPanelScrollButton
pGroupScroll | CXTPTaskPanelScrollButton
rcButton | CXTPTaskPanelScrollButton


Toolkit Pro: Member List

XTP_RESIZEPOINT Member List

This is the complete list of members for XTP_RESIZEPOINT, including all inherited members.

x | XTP_RESIZEPOINT
y | XTP_RESIZEPOINT


Toolkit Pro: Member List

CXTPControlEdit Member List

This is the complete list of members for CXTPControlEdit, including all inherited members.

AssignDocTemplate(UINT nIDResource) | CXTPControl |
ClickToolBarButton(CRect rcActiveRect=CRect(0, 0, 0, 0)) | CXTPControl | protected
Compare(CXTPControl *pOther) | CXTPControlEdit | virtual
Copy(CXTPControl *pControl, BOOL bRecursive=FALSE) | CXTPControlEdit | protectedvirtual
CreateEditControl() | CXTPControlEdit | virtual
CustomizeStartDrag(CPoint point) | CXTPControl | protectedvirtual
CustomizeStartResize(CPoint point) | CXTPControl | protectedvirtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPControl() | CXTPControl | protected
CXTPControlEdit() | CXTPControlEdit |
DeflateEditRect(CRect &rcControl) | CXTPControlEdit | protectedvirtual
DelayLayoutParent() | CXTPControl |
DelayRedrawParent() | CXTPControl |
DoCustomDragOver(CXTPCommandBar *pCommandBar, CPoint point, DROPEFFECT &dropEffect) | CXTPControl | protectedvirtual
DoPropExchange(CXTPPropExchange *pPX) | CXTPControlEdit | virtual
Draw(CDC *pDC) | CXTPControl | virtual
DrawEditText(CDC *pDC, CRect rcText) | CXTPControlEdit | virtual
EnableShellAutoComplete(DWORD dwFlags=SHACF_FILESYSTEM|SHACF_URLALL) | CXTPControlEdit |
ExcludeDocTemplate(UINT nIDResource) | CXTPControl |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
FromUI(CCmdUI *pCmdUI) | CXTPControl | static
GenerateCommandBarList(DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam) | CXTPControl | protectedvirtual
GetAction() const | CXTPControl |
GetBeginGroup() const | CXTPControl |
GetButtonSize() const | CXTPControl | virtual
GetCaption() const | CXTPControl | virtual
GetCategory() const | CXTPControl |
GetChecked() const | CXTPControl |
GetCloseSubMenuOnClick() const | CXTPControl |
GetCommandBar() const | CXTPControl | virtual
GetControls() const | CXTPControl |
GetCustomizeMinHeight() const | CXTPControl | protectedvirtual
GetCustomizeMinWidth() const | CXTPControlEdit | protectedvirtual
GetCustomShortcutText() const | CXTPControl |
GetDefaultCharFormat() | CXTPControlEdit | protectedvirtual
GetDescription() const | CXTPControl | virtual
GetEditCtrl() const | CXTPControlEdit |
GetEditHint() const | CXTPControlEdit |
GetEditIconId() const | CXTPControlEdit |
GetEditStyle() const | CXTPControlEdit |
GetEditText() const | CXTPControlEdit |
GetEnabled() const | CXTPControl |
GetExecuteOnPressInterval() const | CXTPControl |
GetExpanded() const | CXTPControl |
GetFlags() const | CXTPControl |
GetHeight() const | CXTPControl |
GetHelpId() const | CXTPControl |
GetHideFlags() const | CXTPControl |
GetIconId() const | CXTPControl |
GetIconSize() const | CXTPControl | virtual
GetID() const | CXTPControl |
GetImage(int nWidth=16) const | CXTPControl | virtual
GetImageManager() const | CXTPControl |
GetIndex() const | CXTPControl |
GetKeyboardTip() const | CXTPControl |
GetLabelWidth() const | CXTPControlEdit |
GetPaintManager() const | CXTPControl |
GetParameter() const | CXTPControl |
GetParent() const | CXTPControl |
GetPopuped() const | CXTPControl | virtual
GetPressed() const | CXTPControl | virtual
GetReadOnly() const | CXTPControlEdit |
GetRect() const | CXTPControl |
GetRibbonGroup() const | CXTPControl |
GetRowRect() const | CXTPControl |
GetSelected() const | CXTPControl | virtual
GetShortcutText() const | CXTPControl |
GetSize(CDC *pDC) | CXTPControl | virtual
GetSpinButtonsRect() const | CXTPControlEdit |
GetStyle() const | CXTPControl |
GetTag() const | CXTPControl |
GetTextLimit() const | CXTPControlEdit |
GetTooltip() const | CXTPControl | virtual
GetType() const | CXTPControl |
GetWidth() const | CXTPControl |
GetWrap() const | CXTPControl |
HasDwmCompositedRect() const | CXTPControl |
HasFocus() const | CXTPControlEdit |
IsBuddyButtonVisible() const | CXTPControlEdit |
IsCaptionVisible() const | CXTPControlEdit | virtual
IsCursorOver() const | CXTPControl |
IsCustomizeMode() const | CXTPControl | protected
IsCustomizeMovable() const | CXTPControl | virtual
IsCustomizeResizeAllow() const | CXTPControlEdit | protectedvirtual
IsFocusable() const | CXTPControlEdit | protectedvirtual
IsFocused() const | CXTPControlEdit | virtual
IsImageVisible() const | CXTPControlEdit |
IsItemDefault() const | CXTPControl |
IsLabeled() const | CXTPControlEdit |
IsLayoutChanged() | CXTPControl | protected
IsLayoutRTL() const | CXTPControl | protected
IsNumericOnly() const | CXTPControlEdit |
IsOnQuickAccess() const | CXTPControl |
IsSpinButtonsVisible() const | CXTPControlEdit |
IsTemporary() const | CXTPControl |
IsTransparent() const | CXTPControl | inlinevirtual
IsVisible(DWORD dwSkipFlags=0) const | CXTPControl | virtual
m_bBeginGroup | CXTPControl | protected
m_bChecked | CXTPControl | protected
m_bCloseSubMenuOnClick | CXTPControl | protected
m_bDefaultItem | CXTPControl | protected
m_bDelayDestroy | CXTPControlEdit | protected
m_bDelayReposition | CXTPControlEdit | protected
m_bEditChanged | CXTPControlEdit | mutableprotected
m_bEnabled | CXTPControl | protected
m_bExpanded | CXTPControl | protected
m_bFocused | CXTPControlEdit | protected
m_bLabel | CXTPControlEdit | protected
m_bLayoutRTL | CXTPControl | protected
m_bNumericOnly | CXTPControlEdit | protected
m_bOnQuickAccess | CXTPControl | protected
m_bPressed | CXTPControl | protected
m_bReadOnly | CXTPControlEdit | protected
m_bSelected | CXTPControl | protected
m_bShowSpinButtons | CXTPControlEdit | protected
m_bTemporary | CXTPControl | protected
m_buttonCustomStyle | CXTPControl | protected
m_buttonRibbonStyle | CXTPControl | protected
m_buttonStyle | CXTPControl | protected
m_bWrap | CXTPControl | protected
m_controlType | CXTPControl | protected
m_dwEditStyle | CXTPControlEdit | protected
m_dwFlags | CXTPControl | protected
m_dwHideFlags | CXTPControl | protected
m_dwShellAutoCompleteFlags | CXTPControlEdit | protected
m_mapDocTemplatesAssigned | CXTPControl | protected
m_mapDocTemplatesExcluded | CXTPControl | protected
m_nCustomIconId | CXTPControl | protected
m_nEditIconId | CXTPControlEdit | protected
m_nExecuteOnPressInterval | CXTPControl | protected
m_nHeight | CXTPControl | protected
m_nHelpId | CXTPControl | protected
m_nIconId | CXTPControl | protected
m_nId | CXTPControl | protected
m_nIndex | CXTPControl | protected
m_nLabelWidth | CXTPControlEdit | protected
m_nTag | CXTPControl | protected
m_nTextLimit | CXTPControlEdit | protected
m_nWidth | CXTPControl | protected
m_pAction | CXTPControl | protected
m_pAutoCompleteWnd | CXTPControlEdit | protected
m_pControls | CXTPControl | protected
m_pEdit | CXTPControlEdit | protected
m_pParent | CXTPControl | protected
m_pRibbonGroup | CXTPControl | protected
m_rcControl | CXTPControl | protected
m_rcRow | CXTPControl | protected
m_strCaption | CXTPControl | protected
m_strCategory | CXTPControl | protected
m_strCustomCaption | CXTPControl | protected
m_strDescriptionText | CXTPControl | protected
m_strEditHint | CXTPControlEdit | protected
m_strEditText | CXTPControlEdit | mutableprotected
m_strKeyboardTip | CXTPControl | protected
m_strLastText | CXTPControlEdit | protected
m_strParameter | CXTPControl | protected
m_strShortcutText | CXTPControl | protected
m_strShortcutTextAuto | CXTPControl | protected
m_strTooltipText | CXTPControl | protected
m_szIcon | CXTPControl | protected
NotifySite(UINT code) | CXTPControl |
NotifySite(UINT code, NMXTPCONTROL *pNM) | CXTPControl |
NotifySite(CWnd *pSite, UINT code, NMXTPCONTROL *pNM) | CXTPControl |
OnActionChanged(int nProperty) | CXTPControlEdit | virtual
OnActionChanging(int nProperty) | CXTPControlEdit | virtual
OnCalcDynamicSize(DWORD dwMode) | CXTPControlEdit | protectedvirtual
OnCaptionChanged() | CXTPControl | protectedvirtual
OnClick(BOOL bKeyboard=FALSE, CPoint pt=CPoint(0, 0)) | CXTPControlEdit | protectedvirtual
OnCustomizeDragOver(CXTPControl *pDataObject, CPoint point, DROPEFFECT &dropEffect) | CXTPControl | protectedvirtual
OnCustomizeMouseMove(CPoint point) | CXTPControl | protected
OnEditChanged() | CXTPControlEdit | protectedvirtual
OnEnabledChanged() | CXTPControlEdit | virtual
OnExecute() | CXTPControl | virtual
OnHookKeyDown(UINT nChar, LPARAM lParam) | CXTPControlEdit | protectedvirtual
OnHookMouseWheel(UINT nFlags, short zDelta, CPoint point) | CXTPControl | protectedvirtual
OnIdleUpdate() | CXTPControl | protectedvirtual
OnKillFocus() | CXTPControlEdit | protectedvirtual
OnLButtonDblClk(CPoint point) | CXTPControl | protectedvirtual
OnLButtonDown(CPoint point) | CXTPControl | protectedvirtual
OnLButtonUp(CPoint point) | CXTPControl | protectedvirtual
OnMouseHover() | CXTPControlEdit | protectedvirtual
OnMouseMove(CPoint point) | CXTPControlEdit | protectedvirtual
OnRButtonDown(CPoint point) | CXTPControl | protectedvirtual
OnRButtonUp(CPoint point) | CXTPControl | protectedvirtual
OnRemoved() | CXTPControlEdit | protectedvirtual
OnSetFocus(CWnd *pOldWnd) | CXTPControlEdit | protectedvirtual
OnSetPopup(BOOL bPopup) | CXTPControl | protectedvirtual
OnSetSelected(int bSelected) | CXTPControlEdit | protectedvirtual
OnThemeChanged() | CXTPControl | virtual
OnToolHitTest(CPoint point, TOOLINFO *pTI) const | CXTPControl | protectedvirtual
OnUnderlineActivate() | CXTPControlEdit | protectedvirtual
RedrawParent(BOOL bAnimate=TRUE) | CXTPControl |
Reset() | CXTPControl |
RestoreCommandBarList(CXTPCommandBarList *pCommandBarList) | CXTPControl | protectedvirtual
ScreenToClient(CPoint *point) | CXTPControl | protected
SetAction(CXTPControlAction *pAction) | CXTPControl | virtual
SetBeginGroup(BOOL bBeginGroup) | CXTPControl | virtual
SetCaption(LPCTSTR lpszCaption) | CXTPControl |
SetCaption(UINT nIDCaption) | CXTPControl |
SetCategory(LPCTSTR lpszCategory) | CXTPControl |
SetChecked(BOOL bChecked) | CXTPControl | virtual
SetCloseSubMenuOnClick(BOOL bCloseOnClick) | CXTPControl |
SetCustomIcon(HICON hIcon) | CXTPControl |
SetCustomShortcutText(LPCTSTR lpszCustomShortcutText) | CXTPControl |
SetDescription(LPCTSTR lpszDescription) | CXTPControl |
SetEditHint(LPCTSTR lpszEditHint) | CXTPControlEdit |
SetEditIconId(int nId) | CXTPControlEdit |
SetEditStyle(DWORD dwStyle) | CXTPControlEdit |
SetEditText(const CString &strText) | CXTPControlEdit |
SetEnabled(BOOL bEnabled) | CXTPControl | virtual
SetExecuteOnPressInterval(int nExecuteOnPressInterval) | CXTPControl |
SetExpanded(BOOL bExpanded) | CXTPControl | protected
SetFlags(DWORD dwFlags) | CXTPControl |
SetFocused(BOOL bFocused) | CXTPControlEdit | virtual
SetHeight(int nHeight) | CXTPControl | virtual
SetHelpId(int nId) | CXTPControl |
SetHideFlag(XTPControlHideFlags dwFlag, BOOL bSet) | CXTPControl |
SetHideFlags(DWORD dwFlags) | CXTPControlEdit | virtual
SetHideWrap(BOOL bHide) | CXTPControl |
SetIconId(int nId) | CXTPControl |
SetIconSize(CSize szIcon) | CXTPControl |
SetID(int nId) | CXTPControl |
SetIndex(int nIndex) | CXTPControl | inlineprotected
SetItemDefault(BOOL bDefault) | CXTPControl |
SetKeyboardTip(LPCTSTR lpszKeyboardTip) | CXTPControl |
SetLabelWidth(int nLabelWidth) | CXTPControlEdit |
SetNumericOnly(BOOL bNumericOnly=TRUE) | CXTPControlEdit |
SetOnQuickAccess(BOOL bOnQuicAccess=FALSE) | CXTPControl |
SetParameter(LPCTSTR lpszParameter) | CXTPControl |
SetParent(CXTPCommandBar *pParent) | CXTPControlEdit | protectedvirtual
SetPressed(BOOL bPressed) | CXTPControl |
SetPrompt(LPCTSTR lpszPrompt) | CXTPControl |
SetReadOnly(BOOL bReadOnly=TRUE) | CXTPControlEdit |
SetRect(CRect rcControl) | CXTPControlEdit | protectedvirtual
SetRowRect(CRect rcRow) | CXTPControl |
SetShortcutText(LPCTSTR lpszShortcutText) | CXTPControl |
SetStyle(XTPButtonStyle buttonStyle) | CXTPControl |
SetTag(DWORD_PTR dwTag) | CXTPControl |
SetTextLimit(int nTextLimit) | CXTPControlEdit |
SetTooltip(LPCTSTR lpszTooltip) | CXTPControl |
SetVisible(BOOL bVisible) | CXTPControl |
SetWidth(int nWidth) | CXTPControl | virtual
SetWrap(BOOL bWrap) | CXTPControl |
ShowBuddyButton(int nButtonId) | CXTPControlEdit |
ShowLabel(BOOL bShow) | CXTPControlEdit |
ShowSpinButtons(BOOL bShow=TRUE) | CXTPControlEdit |
~CXTPControl() | CXTPControl | protectedvirtual
~CXTPControlEdit() | CXTPControlEdit | virtual


Toolkit Pro: Member List

CXTPDeviceCaps Member List

This is the complete list of members for CXTPDeviceCaps, including all inherited members.

CXTPDeviceCaps() | CXTPDeviceCaps
m_nLogPixelsX | CXTPDeviceCaps
m_nLogPixelsY | CXTPDeviceCaps
RefreshMetrics() | CXTPDeviceCaps


Toolkit Pro: Member List

CXTPChartPointSeriesErrorBarView Member List

This is the complete list of members for CXTPChartPointSeriesErrorBarView, including all inherited members.

AddChildView(CXTPChartElementView *pChildView) | CXTPChartElementView |
CXTPChartElementView(CXTPChartElementView *pParentView) | CXTPChartElementView |
CXTPChartElementView(CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartElementView |
CXTPChartElementView(CXTPChartContainer *pContainer) | CXTPChartElementView |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartPointSeriesErrorBarView(CXTPChartErrorBar *pErrorBar, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView) | CXTPChartPointSeriesErrorBarView |
GetAt(int nIndex) const | CXTPChartElementView |
GetBounds() const | CXTPChartElementView |
GetBounds(BOOL bIncludingChildren) const | CXTPChartElementView |
GetChildren() | CXTPChartElementView |
GetCount() const | CXTPChartElementView |
GetParentView() const | CXTPChartElementView |
Is3D() const | CXTPChartObject |
m_arrChildren | CXTPChartElementView | protected
m_pContainer | CXTPChartElementView | protected
m_pParentView | CXTPChartElementView | protected
m_rcBounds | CXTPChartElementView | protected
~CXTPChartElementView() | CXTPChartElementView | protectedvirtual


Toolkit Pro: XTPButtonTheme.h Source File

  • Source
  • Controls
  • Button
XTPButtonTheme.h
Go to the documentation of this file.
1
23#if !defined(__XTPBUTTONTHEME_H__)
24# define __XTPBUTTONTHEME_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPButton;
34class CXTPWinThemeWrapper;
35
36# define CBR_CLIENTRECT 0
37# define CBR_CHECKBOX 1
38# define CBR_RADIOBOX 2
39# define CBR_CHECKTEXT 3
40# define CBR_RADIOTEXT 4
41# define CBR_GROUPTEXT 5
42# define CBR_GROUPFRAME 6
43# define CBR_PUSHBUTTON 7
44
50class _XTP_EXT_CLASS CXTPButtonTheme : public CXTPControlTheme
51{
52public:
57 CXTPButtonTheme();
58
63 virtual ~CXTPButtonTheme();
64
71 virtual void DrawButtonBackground(CDC* pDC, CXTPButton* pButton);
72
79 virtual void DrawFocusRect(CDC* pDC, CXTPButton* pButton);
80
87 virtual void DrawButton(CDC* pDC, CXTPButton* pButton);
88
95 virtual void DrawButtonVisualStyleBackground(CDC* pDC, CXTPButton* pButton);
96
103 virtual void RefreshMetrics(CXTPButton* pButton);
104
111 virtual void DrawPushButtonText(CDC* pDC, CXTPButton* pButton);
112
119 virtual void DrawPushButtonIcon(CDC* pDC, CXTPButton* pButton);
120
127 virtual void DrawPushButtonDropDown(CDC* pDC, CXTPButton* pButton);
128
136 virtual COLORREF GetTextColor(CXTPButton* pButton);
137
144 virtual void DrawCheckBoxMark(CDC* pDC, CXTPButton* pButton);
145
152 virtual void DrawRadioButtonMark(CDC* pDC, CXTPButton* pButton);
153
160 void DrawButtonText(CDC* pDC, CXTPButton* pButton);
161
168 virtual void DrawGroupBox(CDC* pDC, CXTPButton* pButton);
169
170 void CalcRects(CDC* pDC, CXTPButton* pButton, CRect* pButtonText, UINT* pDrawFlags,
171 CRect* pButtonIcon);
172 void CalcRect(CDC* pDC, CXTPButton* pButton, LPRECT lprc, int code);
173 BOOL IsVisualThemeUsed(CXTPButton* pButton);
174 void AlphaEllipse(CDC* pDC, CRect rc, COLORREF clrBorder, COLORREF clrFace);
175
176 void EnableToolbarStyle(BOOL bEnable)
177 {
178 m_bToolbarStyle = bEnable;
179 }
180
181 CXTPPaintManagerColor m_crTextDisabled;
182 CXTPPaintManagerColor m_crBorderHilite;
183 CXTPPaintManagerColor m_crBorderShadow;
184 CXTPPaintManagerColor m_crBorder3DHilite;
185 CXTPPaintManagerColor m_crBorder3DShadow;
186 CXTPPaintManagerColor m_crBack;
187 CXTPPaintManagerColor m_crText;
188 CXTPPaintManagerColor m_crTextCheck;
190 CXTPWinThemeWrapper* m_themeButton;
191
192 BOOL m_bOffsetHiliteText;
193 int m_nBorderWidth;
194 BOOL m_bFlatGlyphs;
195 BOOL m_bToolbarStyle;
196
197 int m_cxBorder;
198 int m_cyBorder;
199 int m_cyEdge;
200 int m_cxEdge;
201};
202
203# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
205#endif // !defined(__XTPBUTTONTHEME_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPButton
Push Button control.
Definition XTPButton.h:109
CXTPButtonTheme
CXTPButtonTheme is a class used to perform Button Theme drawing tasks.
Definition XTPButtonTheme.h:51
CXTPButtonTheme::m_crTextDisabled
CXTPPaintManagerColor m_crTextDisabled
RGB value for disabled text color.
Definition XTPButtonTheme.h:181
CXTPButtonTheme::m_crBorder3DShadow
CXTPPaintManagerColor m_crBorder3DShadow
RGB value for 3D border shadow color.
Definition XTPButtonTheme.h:185
CXTPButtonTheme::GetTextColor
virtual COLORREF GetTextColor(CXTPButton *pButton)
Call this member function to return the color used to draw the button text.
CXTPButtonTheme::DrawGroupBox
virtual void DrawGroupBox(CDC *pDC, CXTPButton *pButton)
This member function draws the group box for the button, if one has been defined.
CXTPButtonTheme::DrawButtonVisualStyleBackground
virtual void DrawButtonVisualStyleBackground(CDC *pDC, CXTPButton *pButton)
This member function is called to draw the styled background for the button.
CXTPButtonTheme::m_crBack
CXTPPaintManagerColor m_crBack
RGB value for background color.
Definition XTPButtonTheme.h:186
CXTPButtonTheme::DrawCheckBoxMark
virtual void DrawCheckBoxMark(CDC *pDC, CXTPButton *pButton)
This member function draws the check box mark for the button, if one has been defined.
CXTPButtonTheme::m_crBorderHilite
CXTPPaintManagerColor m_crBorderHilite
RGB value for border highlight color.
Definition XTPButtonTheme.h:182
CXTPButtonTheme::DrawPushButtonIcon
virtual void DrawPushButtonIcon(CDC *pDC, CXTPButton *pButton)
This member function draws the icon for the button, if one has been defined.
CXTPButtonTheme::DrawButtonBackground
virtual void DrawButtonBackground(CDC *pDC, CXTPButton *pButton)
This member function is called to draw the background for the button.
CXTPButtonTheme::DrawButtonText
void DrawButtonText(CDC *pDC, CXTPButton *pButton)
This member function is called to draw the text for the button.
CXTPButtonTheme::m_crBorderShadow
CXTPPaintManagerColor m_crBorderShadow
RGB value for border shadow color.
Definition XTPButtonTheme.h:183
CXTPButtonTheme::DrawPushButtonDropDown
virtual void DrawPushButtonDropDown(CDC *pDC, CXTPButton *pButton)
This member function draws the dropdown for the button, if one has been defined.
CXTPButtonTheme::DrawButton
virtual void DrawButton(CDC *pDC, CXTPButton *pButton)
This member function is called to the button.
CXTPButtonTheme::DrawFocusRect
virtual void DrawFocusRect(CDC *pDC, CXTPButton *pButton)
This member function is called to draw the focus rectangle for the button.
CXTPButtonTheme::CXTPButtonTheme
CXTPButtonTheme()
Constructs a CXTPButtonTheme object.
CXTPButtonTheme::m_crBorder3DHilite
CXTPPaintManagerColor m_crBorder3DHilite
RGB value for 3D border highlight color.
Definition XTPButtonTheme.h:184
CXTPButtonTheme::~CXTPButtonTheme
virtual ~CXTPButtonTheme()
Destroys a CXTPButtonTheme object, handles cleanup and deallocation.
CXTPButtonTheme::m_crText
CXTPPaintManagerColor m_crText
RGB value for text color.
Definition XTPButtonTheme.h:187
CXTPButtonTheme::DrawPushButtonText
virtual void DrawPushButtonText(CDC *pDC, CXTPButton *pButton)
This member function is called to draw the text for the button.
CXTPButtonTheme::DrawRadioButtonMark
virtual void DrawRadioButtonMark(CDC *pDC, CXTPButton *pButton)
This member function draws the radio button mark for the button, if one has been defined.
CXTPButtonTheme::RefreshMetrics
virtual void RefreshMetrics(CXTPButton *pButton)
This member function is called by the theme manager to refresh the visual styles used by each compone...
CXTPButtonTheme::m_crTextCheck
CXTPPaintManagerColor m_crTextCheck
RGB value for checked text color.
Definition XTPButtonTheme.h:188
CXTPControlTheme
CXTPControlTheme can be used as a base class for user defined themes.
Definition XTPControlTheme.h:95
CXTPPaintManagerColor
The CXTPPaintManagerColor class is used to manage COLORREF values for determining default and applica...
Definition XTPColorManager.h:117
CXTPWinThemeWrapper
The CXTPWinThemeWrapper class wraps the UxTheme.dll visual theme API.
Definition XTPWinThemeWrapper.h:188


Toolkit Pro: XTPEditThemeOffice2000.h Source File

  • Source
  • Controls
  • Edit
  • Themes
XTPEditThemeOffice2000.h
Go to the documentation of this file.
1
23#if !defined(__XTPEDITTHEMEOFFICE2000_H__)
24# define __XTPEDITTHEMEOFFICE2000_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
37class _XTP_EXT_CLASS CXTPEditThemeOffice2000 : public CXTPEditThemeDefault
38{
39public:
44 CXTPEditThemeOffice2000();
45
50 virtual ~CXTPEditThemeOffice2000();
51
58 virtual void RefreshMetrics(CXTPEdit* pEdit);
59
68 virtual void DrawNcBorders(CDC* pDC, CRect rcWnd, CXTPEdit* pEdit);
69
81 virtual void DrawBuddyBorders(CWnd* pBuddy, CDC* pDC, CRect rc, int nAlignment,
82 CXTPEdit* pEdit);
83
84 using CXTPEditThemeDefault::DrawBuddyBorders;
85
94 virtual BOOL RedrawFocusedFrame() const;
95};
96
97# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
99#endif // __XTPEDITTHEMEOFFICE2000_H__
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPEdit
CXTPEdit is a CEdit derived class.
Definition XTPEdit.h:129
CXTPEditThemeDefault
CXTPEditThemeDefault is a class used to perform theme drawing tasks.
Definition XTPEditThemeDefault.h:38
CXTPEditThemeDefault::DrawBuddyBorders
virtual void DrawBuddyBorders(CWnd *pBuddy, CDC *pDC, CRect rc, int nAlignment, CXTPEdit *pEdit)
Called by the framework to draw the borders for the associated buddy window.
CXTPEditThemeOffice2000
CXTPEditThemeOffice2000 is a class used to perform theme drawing tasks.
Definition XTPEditThemeOffice2000.h:38
CXTPEditThemeOffice2000::DrawBuddyBorders
virtual void DrawBuddyBorders(CWnd *pBuddy, CDC *pDC, CRect rc, int nAlignment, CXTPEdit *pEdit)
Called by the framework to draw the borders for the associated buddy window.
CXTPEditThemeOffice2000::RedrawFocusedFrame
virtual BOOL RedrawFocusedFrame() const
Called by the framework to redraw the focus rectangle for the edit control.
CXTPEditThemeOffice2000::~CXTPEditThemeOffice2000
virtual ~CXTPEditThemeOffice2000()
Destructor, handles cleanup and deallocation.
CXTPEditThemeOffice2000::CXTPEditThemeOffice2000
CXTPEditThemeOffice2000()
Constructs a CXTPEditThemeOffice2000 object.
CXTPEditThemeOffice2000::DrawNcBorders
virtual void DrawNcBorders(CDC *pDC, CRect rcWnd, CXTPEdit *pEdit)
This member function is called by the theme manager to draw non-client borders for the edit control.
CXTPEditThemeOffice2000::RefreshMetrics
virtual void RefreshMetrics(CXTPEdit *pEdit)
This member function is called by the theme manager to refresh the visual styles used by each compone...


Toolkit Pro: XTPChart3dPieSeriesLabelsViewDeviceCommand.h Source File

  • Source
  • Chart
  • Styles
  • Pie
  • 3D
  • Commands
XTPChart3dPieSeriesLabelsViewDeviceCommand.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHART3DPIESERIESLABELSVIEWDEVICECOMMAND_H__)
24# define __XTPCHART3DPIESERIESLABELSVIEWDEVICECOMMAND_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChart3dPieSeriesLabelsView;
34class CXTPChart3dPieSeriesLabelView;
35class CXTPChart3dPieSeriesPointView;
36class CXTPChart3dPieSeriesLabelDeviceCommand;
37class CXTPChart3dDeviceContext;
38class CXTPChart3dPieSeriesLabel;
39
44class _XTP_EXT_CLASS CXTPChart3dPieSeriesLabelDeviceCommand : public CXTPChart3dDeviceCommand
45{
46 DECLARE_DYNAMIC(CXTPChart3dPieSeriesLabelDeviceCommand);
47
48public:
55 CXTPChart3dPieSeriesLabelDeviceCommand(CXTPChart3dPieSeriesLabelView* pSeriesLabelView);
56
57public:
59 virtual void ExecuteOverride(CXTPChartDeviceContext* pDC);
69 CXTPChart3dPieSeriesLabelView* GetSeriesLabelView() const;
70
78 BOOL IsBent() const;
79
90 BOOL IsFailed() const;
91
96 void SetFailed();
97
108 CRect GetLabelRect() const;
109
119 void SetLabelRect(CRect rcLabel);
120
130 BOOL ComputeConnectorVector(CXTPChart3dDeviceContext* pDC);
131
142 BOOL ComputeConnectorBend(CXTPChart3dDeviceContext* pDC, CRect rcBoundaries);
143
150 void ComputeLabel(CXTPChart3dDeviceContext* pDC);
151
162 double GetConnectorLengthFactor() const;
163
173 void SetConnectorLengthFactor(double dFactor);
174
185 double GetConnectorEndpointVerticalOffset() const;
186
196 void SetConnectorEndpointVerticalOffset(double yOffset);
197
208 BOOL SetColumnAnchorVerticalPosition(CXTPChart3dDeviceContext* pDC, int y);
209
210private:
211 BOOL ComputeConnectorStartPoint(CXTPChart3dDeviceContext* pDC, CXTPPoint3d& ptStart,
212 CPoint& ptProjected) const;
213 CXTPPoint3d ComputeConnectorBendPoint() const;
214 CXTPPoint3d ComputeConnectorEndPoint() const;
215 CXTPPoint3d ComputeConnectorVectorEndPoint(const CXTPPoint3d& point) const;
216 void ComputeLabel_TwoColumn(const CSize& szLabel, const CPoint& ptAnchor);
217 void ComputeLabel_Outside(const CSize& szLabel, const CPoint& ptAnchorOrigin,
218 const CPoint& ptAnchor);
219 void ComputeLabel_InsideAndRadial(const CSize& szLabel, const CPoint& ptAnchor);
220
221protected:
222 CXTPChart3dPieSeriesLabelView* m_pSeriesLabelView;
223 CXTPChart3dPieSeriesPointView* m_pPointView;
224 CRect m_rcLabel;
225 BOOL m_bFailed;
226 double m_dConnectorLengthFactor;
227 double m_dConnectorEndpointVerticalOffset;
228};
229
230AFX_INLINE BOOL CXTPChart3dPieSeriesLabelDeviceCommand::IsFailed() const
231{
232 return m_bFailed;
233}
234
235AFX_INLINE void CXTPChart3dPieSeriesLabelDeviceCommand::SetFailed()
236{
237 m_bFailed = TRUE;
238}
239
240AFX_INLINE CXTPChart3dPieSeriesLabelView*
241 CXTPChart3dPieSeriesLabelDeviceCommand::GetSeriesLabelView() const
242{
243 return m_pSeriesLabelView;
244}
245
246AFX_INLINE CRect CXTPChart3dPieSeriesLabelDeviceCommand::GetLabelRect() const
247{
248 return m_rcLabel;
249}
250
251AFX_INLINE void CXTPChart3dPieSeriesLabelDeviceCommand::SetLabelRect(CRect rcLabel)
252{
253 m_rcLabel = rcLabel;
254}
255
256AFX_INLINE double CXTPChart3dPieSeriesLabelDeviceCommand::GetConnectorLengthFactor() const
257{
258 return m_dConnectorLengthFactor;
259}
260
261AFX_INLINE void CXTPChart3dPieSeriesLabelDeviceCommand::SetConnectorLengthFactor(double dFactor)
262{
263 m_dConnectorLengthFactor = dFactor;
264}
265
266AFX_INLINE double CXTPChart3dPieSeriesLabelDeviceCommand::GetConnectorEndpointVerticalOffset() const
267{
268 return m_dConnectorEndpointVerticalOffset;
269}
270
271AFX_INLINE void
272 CXTPChart3dPieSeriesLabelDeviceCommand::SetConnectorEndpointVerticalOffset(double yOffset)
273{
274 m_dConnectorEndpointVerticalOffset = yOffset;
275}
276
281class _XTP_EXT_CLASS CXTPChart3dPieSeriesLabelsViewDeviceCommand
282 : public CXTPChart3dDeviceCommand
283 , private CXTPChartDeviceCommandEvents
284{
285public:
292 CXTPChart3dPieSeriesLabelsViewDeviceCommand(CXTPChart3dPieSeriesLabelsView* pSeriesLabelsView);
293
294public:
301 virtual void ExecuteOverride(CXTPChartDeviceContext* pDC);
302
303private:
304 CXTPChart3dPieSeriesLabel* GetLabel() const;
305 void ComputeLabelConnectorVectors(CXTPChart3dDeviceContext* pDC, BOOL& bNeedComputeBends);
306 BOOL ComputeBendBoundaries(CXTPChart3dDeviceContext* pDC, CRect& rcBounaries);
307 void ComputeLabelConnectorBends(CXTPChart3dDeviceContext* pDC, CRect rcBoundaries);
308 void ComputeLabels(CXTPChart3dDeviceContext* pDC);
309 BOOL ResolveLabelOverlaps(CXTPChart3dDeviceContext* pDC, const CRect& rcBoundaries);
310 BOOL ResolveLabelOverlaps_ChangePositionInColumn(CXTPChart3dDeviceContext* pDC,
311 BOOL bLeftDirected, const CRect& rcBoundaries);
312 BOOL ResolveLabelOverlaps_ChangeConnectorLength(CXTPChart3dDeviceContext* pDC);
313
314 CXTPChart3dPieSeriesLabelDeviceCommand*
315 FindLabelDeviceCommand(CXTPChartDeviceCommand* pCommand) const;
316
317private:
318 virtual void OnAfterExecute(CXTPChartDeviceCommand* pCommand, CXTPChartDeviceContext* pDC);
319
320 struct CommandCallbackData
321 {
322 enum State
323 {
324 None,
325 ComputeVector,
326 ComputeBend,
327 ComputeBendConnector,
328 ColumnAnchorVericalPosition
329 };
330
331 CommandCallbackData(State state = None);
332 void SwitchTo(State state);
333 State GetState() const;
334
335 BOOL bSuccess;
336 CXTPChart3dDeviceContext* pDC;
338 CXTPChart3dPieSeriesLabelDeviceCommand* pLabelCommand;
340 const CXTPPoint3d* ptBend;
341 LPRECT prcBoundaries;
342 int nNewYPos;
344 private:
345 State state;
346 };
347
348 CommandCallbackData m_CommandCallbackData;
349
350protected:
351 CXTPChart3dPieSeriesLabelsView* m_pSeriesLabelsView;
352};
353
354AFX_INLINE void
355 CXTPChart3dPieSeriesLabelsViewDeviceCommand::CommandCallbackData::SwitchTo(State newState)
356{
357 *this = CommandCallbackData(newState);
358}
359
360AFX_INLINE CXTPChart3dPieSeriesLabelsViewDeviceCommand::CommandCallbackData::State
361 CXTPChart3dPieSeriesLabelsViewDeviceCommand::CommandCallbackData::GetState() const
362{
363 return state;
364}
365
366AFX_INLINE CXTPChart3dPieSeriesLabelsViewDeviceCommand::CommandCallbackData::CommandCallbackData(
367 State state)
368 : bSuccess(FALSE)
369 , pDC(NULL)
370 , pLabelCommand(NULL)
371 , ptBend(NULL)
372 , prcBoundaries(NULL)
373 , state(state)
374{
375}
377# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
378#endif //#if !defined(__XTPCHART3DPIESERIESLABELSVIEWDEVICECOMMAND_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChart3dDeviceCommand
Defines a common implementation interface for chart 3D drawing commands.
Definition XTPChartDeviceCommand.h:368
CXTPChart3dDeviceContext
A base implementation of 3D device context.
Definition XTPChart3dDeviceContext.h:48
CXTPChart3dPieSeriesLabelDeviceCommand
Implements 3D chart pie series label device command.
Definition XTPChart3dPieSeriesLabelsViewDeviceCommand.h:45
CXTPChart3dPieSeriesLabelDeviceCommand::GetConnectorEndpointVerticalOffset
double GetConnectorEndpointVerticalOffset() const
Determines the connector endpoint vertical offset value.
Definition XTPChart3dPieSeriesLabelsViewDeviceCommand.h:266
CXTPChart3dPieSeriesLabelDeviceCommand::ComputeLabel
void ComputeLabel(CXTPChart3dDeviceContext *pDC)
Computes label.
CXTPChart3dPieSeriesLabelDeviceCommand::GetConnectorLengthFactor
double GetConnectorLengthFactor() const
Determines the connector length factor value.
Definition XTPChart3dPieSeriesLabelsViewDeviceCommand.h:256
CXTPChart3dPieSeriesLabelDeviceCommand::SetColumnAnchorVerticalPosition
BOOL SetColumnAnchorVerticalPosition(CXTPChart3dDeviceContext *pDC, int y)
Sets the column anchor vertical position value.
CXTPChart3dPieSeriesLabelDeviceCommand::SetConnectorLengthFactor
void SetConnectorLengthFactor(double dFactor)
Sets the connector length factor value.
Definition XTPChart3dPieSeriesLabelsViewDeviceCommand.h:261
CXTPChart3dPieSeriesLabelDeviceCommand::ComputeConnectorBend
BOOL ComputeConnectorBend(CXTPChart3dDeviceContext *pDC, CRect rcBoundaries)
Computes the connector bend.
CXTPChart3dPieSeriesLabelDeviceCommand::CXTPChart3dPieSeriesLabelDeviceCommand
CXTPChart3dPieSeriesLabelDeviceCommand(CXTPChart3dPieSeriesLabelView *pSeriesLabelView)
Constructs a CXTPChart3dPieSeriesLabelDeviceCommand object.
CXTPChart3dPieSeriesLabelDeviceCommand::IsBent
BOOL IsBent() const
Returns TRUE if the label connector is bent.
CXTPChart3dPieSeriesLabelDeviceCommand::SetFailed
void SetFailed()
Sets the command object to a failed state.
Definition XTPChart3dPieSeriesLabelsViewDeviceCommand.h:235
CXTPChart3dPieSeriesLabelDeviceCommand::SetConnectorEndpointVerticalOffset
void SetConnectorEndpointVerticalOffset(double yOffset)
Sets the connector endpoint vertical offset value.
Definition XTPChart3dPieSeriesLabelsViewDeviceCommand.h:272
CXTPChart3dPieSeriesLabelDeviceCommand::ComputeConnectorVector
BOOL ComputeConnectorVector(CXTPChart3dDeviceContext *pDC)
Computes the connector vector.
CXTPChart3dPieSeriesLabelDeviceCommand::GetSeriesLabelView
CXTPChart3dPieSeriesLabelView * GetSeriesLabelView() const
Obtains the label view object pointer.
Definition XTPChart3dPieSeriesLabelsViewDeviceCommand.h:241
CXTPChart3dPieSeriesLabelDeviceCommand::GetLabelRect
CRect GetLabelRect() const
Obtains the label rectangle.
Definition XTPChart3dPieSeriesLabelsViewDeviceCommand.h:246
CXTPChart3dPieSeriesLabelDeviceCommand::IsFailed
BOOL IsFailed() const
Checks whether the command object is in a failed state.
Definition XTPChart3dPieSeriesLabelsViewDeviceCommand.h:230
CXTPChart3dPieSeriesLabelDeviceCommand::SetLabelRect
void SetLabelRect(CRect rcLabel)
Sets the label rectangle.
Definition XTPChart3dPieSeriesLabelsViewDeviceCommand.h:251
CXTPChart3dPieSeriesLabel
CXTPChartPieSeriesLabelBase is a kind of CXTPChart3dPieSeriesLabel.
Definition XTPChart3dPieSeriesLabel.h:45
CXTPChart3dPieSeriesLabelView
Represents a series label view object.
Definition XTPChart3dPieSeriesLabel.h:77
CXTPChart3dPieSeriesLabelsViewDeviceCommand
Represents device command for all pie series labels view.
Definition XTPChart3dPieSeriesLabelsViewDeviceCommand.h:284
CXTPChart3dPieSeriesLabelsViewDeviceCommand::m_pSeriesLabelsView
CXTPChart3dPieSeriesLabelsView * m_pSeriesLabelsView
View pointer.
Definition XTPChart3dPieSeriesLabelsViewDeviceCommand.h:351
CXTPChart3dPieSeriesLabelsViewDeviceCommand::CXTPChart3dPieSeriesLabelsViewDeviceCommand
CXTPChart3dPieSeriesLabelsViewDeviceCommand(CXTPChart3dPieSeriesLabelsView *pSeriesLabelsView)
Constructs a command object instance.
CXTPChart3dPieSeriesLabelsViewDeviceCommand::ExecuteOverride
virtual void ExecuteOverride(CXTPChartDeviceContext *pDC)
Override this function to write the drawing code for specific objects.
CXTPChart3dPieSeriesLabelsView
Represents a view object for all pie series labels.
Definition XTPChart3dPieSeriesLabel.h:374
CXTPChart3dPieSeriesPointView
This class abstracts the view of a pie series point.
Definition XTPChart3dPieSeriesPointView.h:49
CXTPChartDeviceCommandEvents
Defines a callback interface for a chart device command event sink.
Definition XTPChartDeviceCommand.h:48
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPChartDeviceCommand::ExecuteOverride
virtual void ExecuteOverride(CXTPChartDeviceContext *pDC)
Override this function to write the drawing code for specific objects.
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPPoint3T< double >


Toolkit Pro: Member List

CXTPMessageBarThemeVisualStudio2015 Member List

This is the complete list of members for CXTPMessageBarThemeVisualStudio2015, including all inherited members.

CXTPMessageBarPaintManager(CXTPPaintManager *pPaintManager) | CXTPMessageBarPaintManager |
CXTPMessageBarThemeOffice2013(CXTPPaintManager *pPaintManager) | CXTPMessageBarThemeOffice2013 |
CXTPMessageBarThemeVisualStudio2015(CXTPPaintManager *pPaintManager) | CXTPMessageBarThemeVisualStudio2015 |
DrawMessageBarButton(CDC *pDC, CXTPMessageBarButton *pButton) | CXTPMessageBarThemeOffice2013 | virtual
FillMessageBar(CDC *pDC, CXTPMessageBar *pBar) | CXTPMessageBarThemeOffice2013 | virtual
GetCloseButtonRect(int x, int y, int cy) | CXTPMessageBarThemeOffice2013 | virtual
GetDefaultButtonSize() const | CXTPMessageBarPaintManager | virtual
GetHeight() const | CXTPMessageBarPaintManager | virtual
GetPadding() const | CXTPMessageBarPaintManager | virtual
m_clrBack | CXTPMessageBarPaintManager | protected
m_clrBorder | CXTPMessageBarPaintManager | protected
m_clrButtonBack | CXTPMessageBarThemeOffice2013 | protected
m_clrButtonBackHilite | CXTPMessageBarThemeOffice2013 | protected
m_clrButtonBackPushed | CXTPMessageBarThemeOffice2013 | protected
m_clrButtonBorder | CXTPMessageBarThemeOffice2013 | protected
m_clrButtonBorderHilite | CXTPMessageBarThemeOffice2013 | protected
m_clrButtonBorderPushed | CXTPMessageBarThemeOffice2013 | protected
m_clrInfoBack | CXTPMessageBarPaintManager | protected
m_clrText | CXTPMessageBarPaintManager | protected
m_clrTextHilite | CXTPMessageBarThemeOffice2013 | protected
m_pPaintManager | CXTPMessageBarPaintManager | protected
RefreshMetrics() | CXTPMessageBarThemeOffice2013 | virtual
~CXTPMessageBarPaintManager() | CXTPMessageBarPaintManager | inlinevirtual


Toolkit Pro: Member List

CXTPControlWorkspaceActions Member List

This is the complete list of members for CXTPControlWorkspaceActions, including all inherited members.

AddCommand(CXTPTabClientWnd *pClient, UINT nID, int &nIndex) | CXTPControlWorkspaceActions | protected
AssignDocTemplate(UINT nIDResource) | CXTPControl |
ClickToolBarButton(CRect rcActiveRect=CRect(0, 0, 0, 0)) | CXTPControl | protected
Compare(CXTPControl *pOther) | CXTPControl | virtual
Copy(CXTPControl *pControl, BOOL bRecursive=FALSE) | CXTPControlButton | protectedvirtual
CustomizeStartDrag(CPoint point) | CXTPControl | protectedvirtual
CustomizeStartResize(CPoint point) | CXTPControl | protectedvirtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPControl() | CXTPControl | protected
CXTPControlButton() | CXTPControlButton |
DelayLayoutParent() | CXTPControl |
DelayRedrawParent() | CXTPControl |
DoCustomDragOver(CXTPCommandBar *pCommandBar, CPoint point, DROPEFFECT &dropEffect) | CXTPControl | protectedvirtual
DoPropExchange(CXTPPropExchange *pPX) | CXTPControlButton | virtual
Draw(CDC *pDC) | CXTPControl | virtual
ExcludeDocTemplate(UINT nIDResource) | CXTPControl |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
FromUI(CCmdUI *pCmdUI) | CXTPControl | static
GenerateCommandBarList(DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam) | CXTPControl | protectedvirtual
GetAction() const | CXTPControl |
GetBeginGroup() const | CXTPControl |
GetButtonSize() const | CXTPControl | virtual
GetCaption() const | CXTPControl | virtual
GetCategory() const | CXTPControl |
GetChecked() const | CXTPControl |
GetCloseSubMenuOnClick() const | CXTPControl |
GetCommandBar() const | CXTPControl | virtual
GetControls() const | CXTPControl |
GetCustomizeMinHeight() const | CXTPControl | protectedvirtual
GetCustomizeMinWidth() const | CXTPControl | protectedvirtual
GetCustomShortcutText() const | CXTPControl |
GetDescription() const | CXTPControl | virtual
GetEnabled() const | CXTPControl |
GetExecuteOnPressInterval() const | CXTPControl |
GetExpanded() const | CXTPControl |
GetFlags() const | CXTPControl |
GetHeight() const | CXTPControl |
GetHelpId() const | CXTPControl |
GetHideFlags() const | CXTPControl |
GetIconId() const | CXTPControl |
GetIconSize() const | CXTPControl | virtual
GetID() const | CXTPControl |
GetImage(int nWidth=16) const | CXTPControl | virtual
GetImageManager() const | CXTPControl |
GetIndex() const | CXTPControl |
GetKeyboardTip() const | CXTPControl |
GetPaintManager() const | CXTPControl |
GetParameter() const | CXTPControl |
GetParent() const | CXTPControl |
GetPopuped() const | CXTPControl | virtual
GetPressed() const | CXTPControl | virtual
GetRect() const | CXTPControl |
GetRibbonGroup() const | CXTPControl |
GetRowRect() const | CXTPControl |
GetSelected() const | CXTPControl | virtual
GetShortcutText() const | CXTPControl |
GetSize(CDC *pDC) | CXTPControl | virtual
GetStyle() const | CXTPControl |
GetStyleEx() const | CXTPControlButton |
GetTag() const | CXTPControl |
GetTooltip() const | CXTPControl | virtual
GetType() const | CXTPControl |
GetWidth() const | CXTPControl |
GetWrap() const | CXTPControl |
HasDwmCompositedRect() const | CXTPControl |
IsCaptionVisible() const | CXTPControl | virtual
IsCursorOver() const | CXTPControl |
IsCustomizeMode() const | CXTPControl | protected
IsCustomizeMovable() const | CXTPControl | virtual
IsCustomizeResizeAllow() const | CXTPControl | protectedvirtual
IsFocusable() const | CXTPControl | protectedvirtual
IsFocused() const | CXTPControl | virtual
IsItemDefault() const | CXTPControl |
IsLayoutChanged() | CXTPControl | protected
IsLayoutRTL() const | CXTPControl | protected
IsOnQuickAccess() const | CXTPControl |
IsTemporary() const | CXTPControl |
IsTransparent() const | CXTPControl | inlinevirtual
IsVisible(DWORD dwSkipFlags=0) const | CXTPControl | virtual
m_bBeginGroup | CXTPControl | protected
m_bChecked | CXTPControl | protected
m_bCloseSubMenuOnClick | CXTPControl | protected
m_bDefaultItem | CXTPControl | protected
m_bEnabled | CXTPControl | protected
m_bExpanded | CXTPControl | protected
m_bLayoutRTL | CXTPControl | protected
m_bOnQuickAccess | CXTPControl | protected
m_bPressed | CXTPControl | protected
m_bSelected | CXTPControl | protected
m_bTemporary | CXTPControl | protected
m_buttonCustomStyle | CXTPControl | protected
m_buttonRibbonStyle | CXTPControl | protected
m_buttonStyle | CXTPControl | protected
m_buttonStyleEx | CXTPControlButton | protected
m_bWrap | CXTPControl | protected
m_controlType | CXTPControl | protected
m_dwFlags | CXTPControl | protected
m_dwHideFlags | CXTPControl | protected
m_mapDocTemplatesAssigned | CXTPControl | protected
m_mapDocTemplatesExcluded | CXTPControl | protected
m_nCustomIconId | CXTPControl | protected
m_nExecuteOnPressInterval | CXTPControl | protected
m_nHeight | CXTPControl | protected
m_nHelpId | CXTPControl | protected
m_nIconId | CXTPControl | protected
m_nId | CXTPControl | protected
m_nIndex | CXTPControl | protected
m_nTag | CXTPControl | protected
m_nWidth | CXTPControl | protected
m_pAction | CXTPControl | protected
m_pControls | CXTPControl | protected
m_pParent | CXTPControl | protected
m_pRibbonGroup | CXTPControl | protected
m_rcControl | CXTPControl | protected
m_rcRow | CXTPControl | protected
m_strCaption | CXTPControl | protected
m_strCategory | CXTPControl | protected
m_strCustomCaption | CXTPControl | protected
m_strDescriptionText | CXTPControl | protected
m_strKeyboardTip | CXTPControl | protected
m_strParameter | CXTPControl | protected
m_strShortcutText | CXTPControl | protected
m_strShortcutTextAuto | CXTPControl | protected
m_strTooltipText | CXTPControl | protected
m_szIcon | CXTPControl | protected
NotifySite(UINT code) | CXTPControl |
NotifySite(UINT code, NMXTPCONTROL *pNM) | CXTPControl |
NotifySite(CWnd *pSite, UINT code, NMXTPCONTROL *pNM) | CXTPControl |
OnActionChanged(int nProperty) | CXTPControl | protectedvirtual
OnActionChanging(int nProperty) | CXTPControl | protectedvirtual
OnCalcDynamicSize(DWORD dwMode) | CXTPControlWorkspaceActions | protectedvirtual
OnCaptionChanged() | CXTPControl | protectedvirtual
OnClick(BOOL bKeyboard=FALSE, CPoint pt=CPoint(0, 0)) | CXTPControlButton | protectedvirtual
OnCustomizeDragOver(CXTPControl *pDataObject, CPoint point, DROPEFFECT &dropEffect) | CXTPControl | protectedvirtual
OnCustomizeMouseMove(CPoint point) | CXTPControl | protected
OnEnabledChanged() | CXTPControl | virtual
OnExecute() | CXTPControl | virtual
OnHookKeyDown(UINT nChar, LPARAM lParam) | CXTPControl | protectedvirtual
OnHookMouseWheel(UINT nFlags, short zDelta, CPoint point) | CXTPControl | protectedvirtual
OnIdleUpdate() | CXTPControl | protectedvirtual
OnLButtonDblClk(CPoint point) | CXTPControl | protectedvirtual
OnLButtonDown(CPoint point) | CXTPControl | protectedvirtual
OnLButtonUp(CPoint point) | CXTPControlButton | protectedvirtual
OnMouseHover() | CXTPControl | protectedvirtual
OnMouseMove(CPoint point) | CXTPControl | protectedvirtual
OnRButtonDown(CPoint point) | CXTPControl | protectedvirtual
OnRButtonUp(CPoint point) | CXTPControl | protectedvirtual
OnRemoved() | CXTPControl | protectedvirtual
OnSetPopup(BOOL bPopup) | CXTPControl | protectedvirtual
OnSetSelected(int bSelected) | CXTPControl | protectedvirtual
OnThemeChanged() | CXTPControl | virtual
OnToolHitTest(CPoint point, TOOLINFO *pTI) const | CXTPControl | protectedvirtual
OnUnderlineActivate() | CXTPControl | virtual
RedrawParent(BOOL bAnimate=TRUE) | CXTPControl |
Reset() | CXTPControl |
RestoreCommandBarList(CXTPCommandBarList *pCommandBarList) | CXTPControl | protectedvirtual
ScreenToClient(CPoint *point) | CXTPControl | protected
SetAction(CXTPControlAction *pAction) | CXTPControl | virtual
SetBeginGroup(BOOL bBeginGroup) | CXTPControl | virtual
SetCaption(LPCTSTR lpszCaption) | CXTPControl |
SetCaption(UINT nIDCaption) | CXTPControl |
SetCategory(LPCTSTR lpszCategory) | CXTPControl |
SetChecked(BOOL bChecked) | CXTPControl | virtual
SetCloseSubMenuOnClick(BOOL bCloseOnClick) | CXTPControl |
SetCustomIcon(HICON hIcon) | CXTPControl |
SetCustomShortcutText(LPCTSTR lpszCustomShortcutText) | CXTPControl |
SetDescription(LPCTSTR lpszDescription) | CXTPControl |
SetEnabled(BOOL bEnabled) | CXTPControl | virtual
SetExecuteOnPressInterval(int nExecuteOnPressInterval) | CXTPControl |
SetExpanded(BOOL bExpanded) | CXTPControl | protected
SetFlags(DWORD dwFlags) | CXTPControl |
SetFocused(BOOL bFocused) | CXTPControl | virtual
SetHeight(int nHeight) | CXTPControl | virtual
SetHelpId(int nId) | CXTPControl |
SetHideFlag(XTPControlHideFlags dwFlag, BOOL bSet) | CXTPControl |
SetHideFlags(DWORD dwFlags) | CXTPControl | virtual
SetHideWrap(BOOL bHide) | CXTPControl |
SetIconId(int nId) | CXTPControl |
SetIconSize(CSize szIcon) | CXTPControl |
SetID(int nId) | CXTPControl |
SetIndex(int nIndex) | CXTPControl | inlineprotected
SetItemDefault(BOOL bDefault) | CXTPControl |
SetKeyboardTip(LPCTSTR lpszKeyboardTip) | CXTPControl |
SetOnQuickAccess(BOOL bOnQuicAccess=FALSE) | CXTPControl |
SetParameter(LPCTSTR lpszParameter) | CXTPControl |
SetParent(CXTPCommandBar *pParent) | CXTPControl | inlineprotectedvirtual
SetPressed(BOOL bPressed) | CXTPControl |
SetPrompt(LPCTSTR lpszPrompt) | CXTPControl |
SetRect(CRect rcControl) | CXTPControl | virtual
SetRowRect(CRect rcRow) | CXTPControl |
SetShortcutText(LPCTSTR lpszShortcutText) | CXTPControl |
SetStyle(XTPButtonStyle buttonStyle) | CXTPControl |
SetStyleEx(XTPButtonStyle buttonStyle) | CXTPControlButton |
SetTag(DWORD_PTR dwTag) | CXTPControl |
SetTooltip(LPCTSTR lpszTooltip) | CXTPControl |
SetVisible(BOOL bVisible) | CXTPControl |
SetWidth(int nWidth) | CXTPControl | virtual
SetWrap(BOOL bWrap) | CXTPControl |
~CXTPControl() | CXTPControl | protectedvirtual
~CXTPControlButton() | CXTPControlButton | virtual


Toolkit Pro: XTPPropertyGrid.h Source File

  • Source
  • PropertyGrid
XTPPropertyGrid.h
Go to the documentation of this file.
1
23#if !defined(__XTPPROPERTYGRID_H__)
24# define __XTPPROPERTYGRID_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
46# ifndef XTP_PROPERTY_GRID_DISABLE_SCROLLBAR_THEMES
47# define XTP_PROPERTY_GRID_DISABLE_SCROLLBAR_THEMES
48# endif
49
50class CXTPToolTipContext;
51class CXTPImageManager;
52class CXTPMarkupContext;
53class CXTPPropertyGridPaintManager;
54
55class CXTPPropertyGridView;
56class CXTPPropertyGridPaintManager;
57class CXTPPropertyGrid;
58
83class _XTP_EXT_CLASS CXTPPropertyGridUpdateContext : public CXTPCmdTarget
84{
85 DECLARE_DYNAMIC(CXTPPropertyGridUpdateContext);
86
87public:
92 CXTPPropertyGridUpdateContext();
93
94public:
105 BOOL IsEmpty() const;
106
107protected:
108 CMap<UINT, UINT, BOOL, BOOL&> m_mapState;
110 UINT m_nSelected;
112 UINT m_nTopIndex;
113 XTPPropertyGridSortOrder m_propertySort;
116# ifdef _XTP_ACTIVEX
119 DECLARE_DISPATCH_MAP()
120 DECLARE_INTERFACE_MAP()
121
122 DECLARE_OLETYPELIB_EX(CXTPPropertyGridUpdateContext)
124# endif
125
126 friend class CXTPPropertyGrid;
127};
128
129class CXTPPropertyGridVerbs;
130
145class _XTP_EXT_CLASS CXTPPropertyGridVerb : public CXTPCmdTarget
146{
147public:
152 CXTPPropertyGridVerb();
153
154public:
161 CString GetCaption() const;
162
169 int GetID() const;
170
177 int GetIndex() const;
178
188 BOOL IsFocused() const;
189
196 void SetPart(CRect rc);
197
206 CRect GetPart() const;
207
216 CPoint GetClickPoint() const;
217
218protected:
219 CString m_strCaption;
220 int m_nID;
221 int m_nIndex;
222 CRect m_rcPart;
223 CPoint m_ptClick;
224 CXTPPropertyGridVerbs* m_pVerbs;
226 friend class CXTPPropertyGridVerbs;
227 friend class CXTPPropertyGrid;
228
229# ifdef _XTP_ACTIVEX
231 DECLARE_DISPATCH_MAP()
232 DECLARE_INTERFACE_MAP()
233
234 DECLARE_OLETYPELIB_EX(CXTPPropertyGridVerb)
236# endif
237};
238
246class _XTP_EXT_CLASS CXTPPropertyGridVerbs : public CXTPCmdTarget
247{
248public:
253 CXTPPropertyGridVerbs();
254
259 ~CXTPPropertyGridVerbs();
260
261public:
269 BOOL IsEmpty() const;
270
275 void RemoveAll();
276
284 CXTPPropertyGridVerb* GetAt(int nIndex) const;
285
292 int GetCount() const;
293
304 void Add(LPCTSTR lpszCaption, UINT nID);
305
306protected:
307 CArray<CXTPPropertyGridVerb*, CXTPPropertyGridVerb*> m_arrVerbs;
309 CXTPPropertyGrid* m_pGrid;
311 friend class CXTPPropertyGrid;
312 friend class CXTPPropertyGridVerb;
313
314# ifdef _XTP_ACTIVEX
317 DECLARE_DISPATCH_MAP()
318 DECLARE_INTERFACE_MAP()
319 DECLARE_ENUM_VARIANT(CXTPPropertyGridVerbs)
320
321 LPDISPATCH OleItem(long nIndex);
322 LPDISPATCH OleGetItem(long nIndex);
323 int OleGetItemCount();
324
325 DECLARE_OLETYPELIB_EX(CXTPPropertyGridVerbs)
327# endif
328};
329
346enum XTPPropertyGridUI
347{
348 xtpPropertyGridUIParentPrev = -2,
350 xtpPropertyGridUIViewPrev = -1,
353 xtpPropertyGridUIView = 0,
355 xtpPropertyGridUIInplaceEdit = 1,
357 xtpPropertyGridUIInplaceControl = 2,
359 xtpPropertyGridUIInplaceButton = 3,
361 xtpPropertyGridUIViewNext = 4,
364 xtpPropertyGridUIVerb = 5,
366 xtpPropertyGridUIParentNext = 6
368};
369
386enum XTPPropertyGridHitCode
387{
388 xtpPropertyGridHitError = -1,
390 xtpPropertyGridHitHelpSplitter = 1,
391 xtpPropertyGridHitVerbsSplitter = 2,
392 xtpPropertyGridHitFirstVerb = 3
393};
394
401class _XTP_EXT_CLASS CXTPPropertyGrid : public CWnd
402{
404 DECLARE_DYNAMIC(CXTPPropertyGrid)
406public:
411 CXTPPropertyGrid();
412
417 virtual ~CXTPPropertyGrid();
418
445 virtual BOOL Create(const RECT& rect, CWnd* pParentWnd, UINT nID, DWORD dwListStyle = 0);
446
447public:
458 CXTPPropertyGridItem* AddCategory(LPCTSTR lpszCaption, CXTPPropertyGridItem* pCategory = NULL);
459
470 CXTPPropertyGridItem* AddCategory(int nID, CXTPPropertyGridItem* pCategory = NULL);
471
483 CXTPPropertyGridItem* InsertCategory(int nIndex, LPCTSTR lpszCaption,
484 CXTPPropertyGridItem* pCategory = NULL);
485
497 CXTPPropertyGridItem* InsertCategory(int nIndex, int nID,
498 CXTPPropertyGridItem* pCategory = NULL);
499
513 void SetPropertySort(XTPPropertyGridSortOrder sort);
514
524 XTPPropertyGridSortOrder GetPropertySort() const;
525
531 void ShowToolBar(BOOL bShow = TRUE);
532
538 void ShowHelp(BOOL bShow = TRUE);
539
545 void ShowView(BOOL bShow = TRUE);
546
552 void EnableToolTips(BOOL bEnable = TRUE);
553
570 void SetCustomColors(COLORREF clrHelpBack, COLORREF clrHelpFore, COLORREF clrViewLine,
571 COLORREF clrViewBack, COLORREF clrViewFore,
572 COLORREF clrCategoryFore = ::GetSysColor(COLOR_GRAYTEXT));
573
578 void SetStandardColors();
579
587 CXTPPropertyGridItem* FindItem(LPCTSTR strCaption) const;
588
596 CXTPPropertyGridItem* FindItem(UINT nID) const;
597
602 void ResetContent();
603
610 BOOL IsHelpVisible() const;
611
618 BOOL IsBarVisible() const;
619
626 int GetHelpHeight() const;
627
634 COLORREF GetHelpBackColor() const;
635
642 COLORREF GetHelpForeColor() const;
643
650 CXTPPropertyGridItems* GetCategories() const;
651
658 CXTPPropertyGridVerbs* GetVerbs() const;
659
666 CXTPPropertyGridView& GetGridView() const;
667
674 CToolBar& GetToolBar();
675
682 CXTPPropertyGridItem* GetSelectedItem() const;
683
691 CXTPPropertyGridItem* GetItem(int nIndex) const;
692
698 void SetHelpHeight(int nHeight);
699
708 void SetViewDivider(double dDivider);
709
717 void SetViewDividerPos(int nDivider, BOOL bLockDivider = FALSE);
718
727 double GetViewDivider() const;
728
734 void SetFont(CFont* pFont);
735
741 void SetTheme(XTPPropertyGridPaintTheme paintTheme);
743 _XTP_DEPRECATE("One of XTPPropertyGridPaintTheme constants must be used. Rename xtpGrid* to "
744 "xtpPropertyGrid* constant being used.")
745 void SetTheme(XTPGridPaintTheme paintTheme);
753 void SetCustomTheme(CXTPPropertyGridPaintManager* pPaintManager);
754
762 XTPPropertyGridPaintTheme GetCurrentTheme() const;
763
768 void Refresh();
769
790 void BeginUpdate(CXTPPropertyGridUpdateContext& context, BOOL bResetContent = TRUE);
791
800 void EndUpdate(CXTPPropertyGridUpdateContext& context);
801
810 BOOL IsVerbsVisible() const;
811
819 CXTPPropertyGridPaintManager* GetPaintManager() const;
820
839 virtual CXTPPropertyGridView* CreateView() const;
840
852 virtual void OnVerbClick(int nIndex, CPoint pt);
853
871 virtual void OnNavigate(XTPPropertyGridUI nUIElement, BOOL bForward,
872 CXTPPropertyGridItem* pItem);
873
887 void NavigateItems(BOOL bTabItems, BOOL bTabCaptions = TRUE);
888
897 void SetShowInplaceButtonsAlways(BOOL bShow);
898
908 BOOL GetShowInplaceButtonsAlways() const;
909
917 void SetVerbsHeight(int nHeight);
918
927 int GetVerbsHeight() const;
928
938 BOOL IsHighlightChangedItems() const;
939
948 void HighlightChangedItems(BOOL bHighlightChanged);
949
962 BOOL IsHighlightChangedButtonItems() const;
963
975 void HighlightChangedButtonItems(BOOL bHighlightChanged);
976
981 void RedrawControl();
982
990 CXTPImageManager* GetImageManager() const;
991
998 void SetImageManager(CXTPImageManager* pImageManager);
999
1007 void SetVariableItemsHeight(BOOL bVariable = TRUE);
1008
1019 void SetInplaceEdit(CXTPPropertyGridInplaceEdit* pInplaceEdit);
1020
1031 void SetInplaceList(CXTPPropertyGridInplaceList* pInplaceList);
1032
1041 virtual LRESULT SendNotifyMessage(WPARAM wParam = 0, LPARAM lParam = 0);
1042
1055 int GetTopIndex() const;
1056
1068 void SetTopIndex(int nIndex);
1069
1080 int GetCount() const;
1081
1089 BOOL RegisterWindowClass(HINSTANCE hInstance = NULL);
1090
1103 void SetVariableSplitterPos(BOOL bVariable);
1104
1118 BOOL GetVariableSplitterPos() const;
1119
1133 void SetVariableHelpHeight(BOOL bVariable);
1134
1149 BOOL GetVariableHelpHeight() const;
1150
1159 void SetBorderStyle(XTPPropertyGridBorderStyle borderStyle);
1160
1170 XTPPropertyGridBorderStyle GetBorderStyle() const;
1171
1178 CXTPToolTipContext* GetToolTipContext() const;
1179
1188 void EnableMultiSelect(BOOL bMultiSelect = TRUE);
1189
1199 int GetSelectedItems(CArray<int, int>* pItems) const;
1200
1201public:
1209 BOOL IsLayoutRTL() const;
1210
1217 void SetLayoutRTL(BOOL bRightToLeft);
1218
1223 void Reposition();
1224
1231 void AllowEdit(BOOL bAllowEdit);
1232
1233public:
1240 void EnableMarkup(BOOL bEnable = TRUE);
1241
1248 CXTPMarkupContext* GetMarkupContext() const;
1249
1250protected:
1256 void OnInvertTracker(CRect rc);
1257
1286 virtual int HitTest(CPoint pt);
1287
1296 virtual void OnSelectionChanged(CXTPPropertyGridItem* pItem);
1297
1304 virtual void OnSortChanged();
1305
1319 virtual void Reposition(int cx, int cy);
1320
1325 virtual void CreateToolbar();
1326
1335 void RefreshToolBarButtons();
1336
1342 void OnVerbsChanged();
1343
1351 BOOL CreateGridView(DWORD dwListStyle);
1352
1359 void RefeshBindings(CXTPPropertyGridItem* pItem = NULL);
1360
1361private:
1362 CWnd* GetNextGridTabItem(BOOL bForward);
1363 void RestoreExpandingState(CXTPPropertyGridItems* pItems,
1364 CXTPPropertyGridUpdateContext& context);
1365 void SaveExpandingState(CXTPPropertyGridItems* pItems, CXTPPropertyGridUpdateContext& context);
1366 void RecreateView();
1367
1368public:
1369 BOOL m_bHideSelection;
1371protected:
1372 BOOL m_bHelpVisible;
1373 BOOL m_bViewVisible;
1374 BOOL m_bEnableTooltips;
1375 BOOL m_bVariableHelpHeight;
1376 BOOL m_bToolBarVisible;
1377 CXTPPropertyGridToolBar m_wndToolbar;
1378 HCURSOR m_hCursorSplit;
1379 HCURSOR m_hCursorHand;
1380 BOOL m_bTabItems;
1381 BOOL m_bTabCaptions;
1383 CXTPPropertyGridVerbs* m_pVerbs;
1385 BOOL m_bVerbsVisible;
1387 XTPPropertyGridPaintTheme m_themeCurrent;
1388 CXTPPropertyGridPaintManager* m_pPaintManager;
1389 int m_nFocusedVerb;
1390 mutable CXTPPropertyGridView* m_pView;
1391 BOOL m_bHighlightChanged;
1392 BOOL m_bHighlightChangedButton;
1393 CXTPImageManager* m_pImageManager;
1394 BOOL m_bVariableItemsHeight;
1395 BOOL m_bPreSubclassWindow;
1397 CXTPPropertyGridInplaceEdit* m_pInplaceEdit;
1398 CXTPPropertyGridInplaceList* m_pInplaceListBox;
1399 BOOL m_bShowInplaceButtonsAlways;
1400 CXTPToolTipContext* m_pToolTipContext;
1401 BOOL m_bMultiSelect;
1402 CXTPMarkupContext* m_pMarkupContext;
1403 BOOL m_bAllowEdit;
1405private:
1406 CRect m_rectTracker;
1407 BOOL m_bVerbActivate;
1408 XTPPropertyGridBorderStyle m_borderStyle;
1409
1410protected:
1412# ifdef _XTP_ACTIVEX
1413 BOOL m_bFocusNext;
1414# endif
1415 //{{AFX_VIRTUAL(CXTPPropertyGrid)
1416protected:
1417 virtual BOOL PreCreateWindow(CREATESTRUCT& cs);
1418 virtual void PreSubclassWindow();
1419 virtual BOOL OnWndMsg(UINT message, WPARAM wParam, LPARAM lParam, LRESULT* pResult);
1420 //}}AFX_VIRTUAL
1421
1422 //{{AFX_MSG(CXTPPropertyGrid)
1423 afx_msg int OnCreate(LPCREATESTRUCT lpCreateStruct);
1424 afx_msg BOOL OnEraseBkgnd(CDC* pDC);
1425 afx_msg void OnPaint();
1426 afx_msg LRESULT OnPrintClient(WPARAM wParam, LPARAM /*lParam*/);
1427 afx_msg void OnSetFocus(CWnd* pOldWnd);
1428 afx_msg void OnKillFocus(CWnd* pNewWnd);
1429 afx_msg void OnSize(UINT nType, int cx, int cy);
1430 afx_msg BOOL OnSetCursor(CWnd* pWnd, UINT nHitTest, UINT message);
1431 afx_msg void OnLButtonDown(UINT nFlags, CPoint point);
1432 afx_msg void OnMouseMove(UINT nFlags, CPoint point);
1433 afx_msg void OnRButtonUp(UINT nFlags, CPoint point);
1434 afx_msg void OnRButtonDown(UINT nFlags, CPoint point);
1435 afx_msg void OnLButtonUp(UINT nFlags, CPoint point);
1436 afx_msg void OnSortAlphabetic();
1437 afx_msg void OnSortCategorized();
1438 afx_msg void OnSysColorChange();
1439 afx_msg void OnKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags);
1440 afx_msg UINT OnGetDlgCode();
1441 //}}AFX_MSG
1442 afx_msg BOOL OnToolTipText(UINT, NMHDR* pNMHDR, LRESULT* pResult);
1443 DECLARE_MESSAGE_MAP()
1444
1445
1447private:
1448 BOOL Create(LPCTSTR lpszClassName, LPCTSTR lpszWindowName, DWORD dwStyle, const RECT& rect,
1449 CWnd* pParentWnd, UINT nID, CCreateContext* pContext = NULL);
1450 void SetLayoutRTL(CWnd* pWnd, BOOL bRTLLayout);
1451
1452 friend class CXTPPropertyGridView;
1453 friend class CPropertyGridCtrl;
1454 friend class CXTPPropertyGridVerb;
1455 friend class CXTPPropertyGridVerbs;
1456 friend class CXTPPropertyGridItem;
1457};
1458
1460AFX_INLINE BOOL CXTPPropertyGridUpdateContext::IsEmpty() const
1461{
1462 return m_mapState.IsEmpty();
1463}
1464
1465AFX_INLINE CString CXTPPropertyGridVerb::GetCaption() const
1466{
1467 return m_strCaption;
1468}
1469AFX_INLINE int CXTPPropertyGridVerb::GetID() const
1470{
1471 return m_nID;
1472}
1473AFX_INLINE int CXTPPropertyGridVerb::GetIndex() const
1474{
1475 return m_nIndex;
1476}
1477AFX_INLINE void CXTPPropertyGridVerb::SetPart(CRect rc)
1478{
1479 m_rcPart = rc;
1480}
1481AFX_INLINE CRect CXTPPropertyGridVerb::GetPart() const
1482{
1483 return m_rcPart;
1484}
1485AFX_INLINE CPoint CXTPPropertyGridVerb::GetClickPoint() const
1486{
1487 return m_ptClick;
1488}
1489AFX_INLINE BOOL CXTPPropertyGridVerb::IsFocused() const
1490{
1491 return (m_nIndex == m_pVerbs->m_pGrid->m_nFocusedVerb)
1492 && (::GetFocus() == m_pVerbs->m_pGrid->GetSafeHwnd());
1493}
1494AFX_INLINE CXTPPropertyGridVerb* CXTPPropertyGridVerbs::GetAt(int nIndex) const
1495{
1496 return m_arrVerbs.GetAt(nIndex);
1497}
1498AFX_INLINE BOOL CXTPPropertyGridVerbs::IsEmpty() const
1499{
1500 return m_arrVerbs.GetSize() == 0;
1501}
1502AFX_INLINE BOOL CXTPPropertyGrid::IsHelpVisible() const
1503{
1504 return m_bHelpVisible;
1505}
1506AFX_INLINE BOOL CXTPPropertyGrid::IsBarVisible() const
1507{
1508 return m_bToolBarVisible;
1509}
1510AFX_INLINE void CXTPPropertyGrid::EnableToolTips(BOOL bEnable)
1511{
1512 m_bEnableTooltips = bEnable;
1513}
1514AFX_INLINE CToolBar& CXTPPropertyGrid::GetToolBar()
1515{
1516 return m_wndToolbar;
1517}
1518AFX_INLINE XTPPropertyGridPaintTheme CXTPPropertyGrid::GetCurrentTheme() const
1519{
1520 return m_themeCurrent;
1521}
1522AFX_INLINE CXTPPropertyGridVerbs* CXTPPropertyGrid::GetVerbs() const
1523{
1524 return m_pVerbs;
1525}
1526AFX_INLINE BOOL CXTPPropertyGrid::IsVerbsVisible() const
1527{
1528 return !m_pVerbs->IsEmpty();
1529}
1530AFX_INLINE CXTPPropertyGridPaintManager* CXTPPropertyGrid::GetPaintManager() const
1531{
1532 return m_pPaintManager;
1533}
1534AFX_INLINE BOOL CXTPPropertyGrid::Create(LPCTSTR lpszClassName, LPCTSTR lpszWindowName,
1535 DWORD dwStyle, const RECT& rect, CWnd* pParentWnd,
1536 UINT nID, CCreateContext* pContext)
1537{
1538 return CWnd::Create(lpszClassName, lpszWindowName, dwStyle, rect, pParentWnd, nID, pContext);
1539}
1540AFX_INLINE void CXTPPropertyGrid::NavigateItems(BOOL bTabItems, BOOL bTabCaptions)
1541{
1542 m_bTabItems = bTabItems;
1543 m_bTabCaptions = bTabCaptions;
1544}
1545AFX_INLINE BOOL CXTPPropertyGrid::IsHighlightChangedItems() const
1546{
1547 return m_bHighlightChanged;
1548}
1549AFX_INLINE void CXTPPropertyGrid::HighlightChangedItems(BOOL bHighlightChanged)
1550{
1551 m_bHighlightChanged = bHighlightChanged;
1552 RedrawControl();
1553}
1554AFX_INLINE BOOL CXTPPropertyGrid::IsHighlightChangedButtonItems() const
1555{
1556 return m_bHighlightChangedButton;
1557}
1558AFX_INLINE void CXTPPropertyGrid::HighlightChangedButtonItems(BOOL bHighlightChanged)
1559{
1560 m_bHighlightChangedButton = bHighlightChanged;
1561 RedrawControl();
1562}
1563AFX_INLINE void CXTPPropertyGrid::SetVariableHelpHeight(BOOL bVariable)
1564{
1565 m_bVariableHelpHeight = bVariable;
1566}
1567AFX_INLINE BOOL CXTPPropertyGrid::GetVariableHelpHeight() const
1568{
1569 return m_bVariableHelpHeight;
1570}
1571AFX_INLINE BOOL CXTPPropertyGrid::GetShowInplaceButtonsAlways() const
1572{
1573 return m_bShowInplaceButtonsAlways;
1574}
1575AFX_INLINE void CXTPPropertyGrid::SetShowInplaceButtonsAlways(BOOL bShow)
1576{
1577 m_bShowInplaceButtonsAlways = bShow;
1578 Reposition();
1579}
1580AFX_INLINE CXTPToolTipContext* CXTPPropertyGrid::GetToolTipContext() const
1581{
1582 return m_pToolTipContext;
1583}
1584AFX_INLINE CXTPMarkupContext* CXTPPropertyGrid::GetMarkupContext() const
1585{
1586 return m_pMarkupContext;
1587}
1588AFX_INLINE void CXTPPropertyGrid::SetTheme(XTPGridPaintTheme paintTheme)
1589{
1590 SetTheme(static_cast< XTPPropertyGridPaintTheme >(paintTheme));
1591}
1593# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
1594#endif // #if !defined(__XTPPROPERTYGRID_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPGridPaintTheme
XTPGridPaintTheme
Visual theme enumeration.
Definition XTPGridDefines.h:299
XTPPropertyGridUI
XTPPropertyGridUI
XTPPropertyGridUI is an enumeration used by CXTPPropertyGrid during navigation of the Property Grid,...
Definition XTPPropertyGrid.h:347
xtpPropertyGridUIInplaceButton
@ xtpPropertyGridUIInplaceButton
Used to indicate that the Tab key is pressed while an in-place button has focus.
Definition XTPPropertyGrid.h:359
xtpPropertyGridUIInplaceControl
@ xtpPropertyGridUIInplaceControl
Used to indicate that the Tab key is pressed while an in-place edit box has focus.
Definition XTPPropertyGrid.h:357
xtpPropertyGridUIViewPrev
@ xtpPropertyGridUIViewPrev
If m_bTabItems is TRUE, used to indicate that focus should be given to the previous item in the grid.
Definition XTPPropertyGrid.h:350
xtpPropertyGridUIViewNext
@ xtpPropertyGridUIViewNext
If m_bTabItems is TRUE, used to indicate that focus should be given to the next item in the grid.
Definition XTPPropertyGrid.h:361
xtpPropertyGridUIParentNext
@ xtpPropertyGridUIParentNext
Used to indicate that focus should be given to the next object in the tab order.
Definition XTPPropertyGrid.h:366
xtpPropertyGridUIParentPrev
@ xtpPropertyGridUIParentPrev
Used to indicate that focus should be given to the previous object in the tab order.
Definition XTPPropertyGrid.h:348
xtpPropertyGridUIVerb
@ xtpPropertyGridUIVerb
Used to indicate that the Tab key is pressed while a verb has focus.
Definition XTPPropertyGrid.h:364
xtpPropertyGridUIView
@ xtpPropertyGridUIView
Used to indicate that focus should be given to the Property Grid.
Definition XTPPropertyGrid.h:353
xtpPropertyGridUIInplaceEdit
@ xtpPropertyGridUIInplaceEdit
Used to indicate that the Tab key is pressed while an in-place edit box has focus.
Definition XTPPropertyGrid.h:355
XTPPropertyGridHitCode
XTPPropertyGridHitCode
XTPPropertyGridHitCode is an enumeration used by CXTPPropertyGrid to determine which part of the prop...
Definition XTPPropertyGrid.h:387
xtpPropertyGridHitVerbsSplitter
@ xtpPropertyGridHitVerbsSplitter
Indicates that the verb splitter was clicked.
Definition XTPPropertyGrid.h:391
xtpPropertyGridHitFirstVerb
@ xtpPropertyGridHitFirstVerb
Indicates that a verb was clicked.
Definition XTPPropertyGrid.h:392
xtpPropertyGridHitHelpSplitter
@ xtpPropertyGridHitHelpSplitter
Indicates that the help splitter was clicked.
Definition XTPPropertyGrid.h:390
xtpPropertyGridHitError
@ xtpPropertyGridHitError
Indicates that neither the help splitter, the verb splitter, or a verb was clicked.
Definition XTPPropertyGrid.h:388
XTPPropertyGridSortOrder
XTPPropertyGridSortOrder
XTPPropertyGridSortOrder is an enumeration used by CXTPPropertyGrid to determine the grouping style.
Definition XTPPropertyGridDefines.h:48
XTPPropertyGridBorderStyle
XTPPropertyGridBorderStyle
Border Style enumeration.
Definition XTPPropertyGridDefines.h:143
XTPPropertyGridPaintTheme
XTPPropertyGridPaintTheme
Visual Theme enumeration.
Definition XTPPropertyGridDefines.h:77
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPImageManager
CXTPImageManager is a standalone class.
Definition XTPImageManager.h:1898
CXTPMarkupContext
CXTPMarkupContext is a standalone class used to provide common settings for Markup objects.
Definition XTPMarkupContext.h:128
CXTPPropertyGrid
CXTPPropertyGrid is a CWnd derived class.
Definition XTPPropertyGrid.h:402
CXTPPropertyGrid::GetCategories
CXTPPropertyGridItems * GetCategories() const
Gets the collection of categories of the property grid.
CXTPPropertyGrid::SetPropertySort
void SetPropertySort(XTPPropertyGridSortOrder sort)
Sets the grouping style for the property grid control.
CXTPPropertyGrid::GetViewDivider
double GetViewDivider() const
Gets the divider position of the grid view.
CXTPPropertyGrid::AddCategory
CXTPPropertyGridItem * AddCategory(LPCTSTR lpszCaption, CXTPPropertyGridItem *pCategory=NULL)
Adds a new category to the property grid control.
CXTPPropertyGrid::GetShowInplaceButtonsAlways
BOOL GetShowInplaceButtonsAlways() const
Determines if in-place buttons are always shown.
Definition XTPPropertyGrid.h:1571
CXTPPropertyGrid::ShowHelp
void ShowHelp(BOOL bShow=TRUE)
Shows/hides the description pane in the property grid window.
CXTPPropertyGrid::GetItem
CXTPPropertyGridItem * GetItem(int nIndex) const
Retrieves the item at a specified index in the list.
CXTPPropertyGrid::SetViewDividerPos
void SetViewDividerPos(int nDivider, BOOL bLockDivider=FALSE)
Sets the divider position for the grid view.
CXTPPropertyGrid::GetToolBar
CToolBar & GetToolBar()
Gets the toolbar of the property grid.
Definition XTPPropertyGrid.h:1514
CXTPPropertyGrid::InsertCategory
CXTPPropertyGridItem * InsertCategory(int nIndex, LPCTSTR lpszCaption, CXTPPropertyGridItem *pCategory=NULL)
Inserts a new category to the property grid control.
CXTPPropertyGrid::GetSelectedItem
CXTPPropertyGridItem * GetSelectedItem() const
Gets the currently selected item.
CXTPPropertyGrid::SetVariableHelpHeight
void SetVariableHelpHeight(BOOL bVariable)
Specifies if the user can resize the help box with the mouse.
Definition XTPPropertyGrid.h:1563
CXTPPropertyGrid::GetVerbs
CXTPPropertyGridVerbs * GetVerbs() const
Gets the collection of verbs displayed in the verb panel.
Definition XTPPropertyGrid.h:1522
CXTPPropertyGrid::GetHelpForeColor
COLORREF GetHelpForeColor() const
Gets the foreground color of the help pane.
CXTPPropertyGrid::FindItem
CXTPPropertyGridItem * FindItem(LPCTSTR strCaption) const
Retrieves an item by its caption/identifier.
CXTPPropertyGrid::SetViewDivider
void SetViewDivider(double dDivider)
Sets the divider position for the grid view.
CXTPPropertyGrid::SetFont
void SetFont(CFont *pFont)
Sets the font of the property grid.
CXTPPropertyGrid::IsHighlightChangedItems
BOOL IsHighlightChangedItems() const
Determines if changed item highlighting is enabled/disabled.
Definition XTPPropertyGrid.h:1545
CXTPPropertyGrid::SetTheme
void SetTheme(XTPPropertyGridPaintTheme paintTheme)
Sets the theme for the property grid.
Definition XTPPropertyGrid.h:1588
CXTPPropertyGrid::GetCurrentTheme
XTPPropertyGridPaintTheme GetCurrentTheme() const
Gets the theme of the property grid.
Definition XTPPropertyGrid.h:1518
CXTPPropertyGrid::GetPropertySort
XTPPropertyGridSortOrder GetPropertySort() const
Gets the grouping style of the property grid control.
CXTPPropertyGrid::IsBarVisible
BOOL IsBarVisible() const
Determines the visible state of the toolbar.
Definition XTPPropertyGrid.h:1506
CXTPPropertyGrid::AddCategory
CXTPPropertyGridItem * AddCategory(int nID, CXTPPropertyGridItem *pCategory=NULL)
Adds a new category to the property grid control.
CXTPPropertyGrid::Create
virtual BOOL Create(const RECT &rect, CWnd *pParentWnd, UINT nID, DWORD dwListStyle=0)
Creates the property grid control.
CXTPPropertyGrid::GetHelpHeight
int GetHelpHeight() const
Gets the height of the help pane when it is visible.
CXTPPropertyGrid::SetCustomColors
void SetCustomColors(COLORREF clrHelpBack, COLORREF clrHelpFore, COLORREF clrViewLine, COLORREF clrViewBack, COLORREF clrViewFore, COLORREF clrCategoryFore=::GetSysColor(COLOR_GRAYTEXT))
Sets the custom colors for the property grid control.
CXTPPropertyGrid::ShowView
void ShowView(BOOL bShow=TRUE)
Shows/hides the view pane.
CXTPPropertyGrid::HighlightChangedItems
void HighlightChangedItems(BOOL bHighlightChanged)
Enables/disables changed item highlighting.
Definition XTPPropertyGrid.h:1549
CXTPPropertyGrid::SetShowInplaceButtonsAlways
void SetShowInplaceButtonsAlways(BOOL bShow)
Specifies if in-place buttons should always be shown.
Definition XTPPropertyGrid.h:1575
CXTPPropertyGrid::GetMarkupContext
CXTPMarkupContext * GetMarkupContext() const
Gets the Markup context.
Definition XTPPropertyGrid.h:1584
CXTPPropertyGrid::SetStandardColors
void SetStandardColors()
Sets the default colors for the property grid control.
CXTPPropertyGrid::ShowToolBar
void ShowToolBar(BOOL bShow=TRUE)
Shows/hides the toolbar control in the property grid window.
CXTPPropertyGrid::InsertCategory
CXTPPropertyGridItem * InsertCategory(int nIndex, int nID, CXTPPropertyGridItem *pCategory=NULL)
Inserts a new category to the property grid control.
CXTPPropertyGrid::EnableToolTips
void EnableToolTips(BOOL bEnable=TRUE)
Enables/disables tooltips under items.
Definition XTPPropertyGrid.h:1510
CXTPPropertyGrid::CXTPPropertyGrid
CXTPPropertyGrid()
Constructs a CXTPPropertyGrid object.
CXTPPropertyGrid::ResetContent
void ResetContent()
Removes all items from the list box of the property grid control.
CXTPPropertyGrid::GetHelpBackColor
COLORREF GetHelpBackColor() const
Gets the background color of the help pane.
CXTPPropertyGrid::IsHighlightChangedButtonItems
BOOL IsHighlightChangedButtonItems() const
Determines if highlighting is enabled/disabled for in-place button text when the item value is change...
Definition XTPPropertyGrid.h:1554
CXTPPropertyGrid::GetToolTipContext
CXTPToolTipContext * GetToolTipContext() const
Gets the tooltip context.
Definition XTPPropertyGrid.h:1580
CXTPPropertyGrid::~CXTPPropertyGrid
virtual ~CXTPPropertyGrid()
Destroys a CXTPPropertyGrid object, handles cleanup and deallocation.
CXTPPropertyGrid::IsVerbsVisible
BOOL IsVerbsVisible() const
Determines the visible state of the verb panel.
Definition XTPPropertyGrid.h:1526
CXTPPropertyGrid::GetGridView
CXTPPropertyGridView & GetGridView() const
Gets the view of the property grid.
CXTPPropertyGrid::IsHelpVisible
BOOL IsHelpVisible() const
Determines the visible state of the help pane.
Definition XTPPropertyGrid.h:1502
CXTPPropertyGrid::SetHelpHeight
void SetHelpHeight(int nHeight)
Sets the height for the help pane when it is visible.
CXTPPropertyGrid::NavigateItems
void NavigateItems(BOOL bTabItems, BOOL bTabCaptions=TRUE)
Enables/disables item navigation by using the Tab key.
Definition XTPPropertyGrid.h:1540
CXTPPropertyGrid::GetPaintManager
CXTPPropertyGridPaintManager * GetPaintManager() const
Gets the paint manager associated with the property grid (i.e.
Definition XTPPropertyGrid.h:1530
CXTPPropertyGrid::FindItem
CXTPPropertyGridItem * FindItem(UINT nID) const
Retrieves an item by its caption/identifier.
CXTPPropertyGrid::GetVariableHelpHeight
BOOL GetVariableHelpHeight() const
Determines if the user can resize the help box with the mouse.
Definition XTPPropertyGrid.h:1567
CXTPPropertyGrid::m_nFocusedVerb
int m_nFocusedVerb
Index of the currently focused verb within the collection of verbs.
Definition XTPPropertyGrid.h:1389
CXTPPropertyGrid::HighlightChangedButtonItems
void HighlightChangedButtonItems(BOOL bHighlightChanged)
Enables/disables highlighting for in-place button text when the item value is changed.
Definition XTPPropertyGrid.h:1558
CXTPPropertyGridInplaceEdit
CXTPPropertyGridInplaceEdit is a CEdit derived class.
Definition XTPPropertyGridInplaceEdit.h:44
CXTPPropertyGridInplaceList
CXTPPropertyGridInplaceList is a CListBox derived class.
Definition XTPPropertyGridInplaceList.h:44
CXTPPropertyGridItem
CXTPPropertyGridItem is the base class representing an item of the Property Grid control.
Definition XTPPropertyGridItem.h:523
CXTPPropertyGridItems
CXTPPropertyGridItems is a CList derived class.
Definition XTPPropertyGridItem.h:110
CXTPPropertyGridPaintManager
Standalone class used by CXTPPropertyGrid as the paint manager.
Definition XTPPropertyGridPaintManager.h:133
CXTPPropertyGridToolBar
CXTPPropertyGridToolBar is a CToolBar derived class.
Definition XTPPropertyGridToolBar.h:39
CXTPPropertyGridUpdateContext
CXTPPropertyGridUpdateContext is a CXTPCmdTarget derived class used to save the state of the property...
Definition XTPPropertyGrid.h:84
CXTPPropertyGridUpdateContext::m_propertySort
XTPPropertyGridSortOrder m_propertySort
Stores the currently used sort method of the grid before CXTPPropertyGrid::BeginUpdate.
Definition XTPPropertyGrid.h:113
CXTPPropertyGridUpdateContext::CXTPPropertyGridUpdateContext
CXTPPropertyGridUpdateContext()
Constructs a CXTPPropertyGridUpdateContext object.
CXTPPropertyGridUpdateContext::m_nTopIndex
UINT m_nTopIndex
Stores the index of the top-most visible item in the property grid.
Definition XTPPropertyGrid.h:112
CXTPPropertyGridUpdateContext::m_nSelected
UINT m_nSelected
Stores the ID of the currently selected item before CXTPPropertyGrid::BeginUpdate.
Definition XTPPropertyGrid.h:110
CXTPPropertyGridUpdateContext::m_mapState
CMap< UINT, UINT, BOOL, BOOL & > m_mapState
Stores the expanded state of each item in the grid before CXTPPropertyGrid::BeginUpdate.
Definition XTPPropertyGrid.h:108
CXTPPropertyGridVerb
CXTPPropertyGridVerb is used to create a verb link similar to what is seen in Visual Studio ....
Definition XTPPropertyGrid.h:146
CXTPPropertyGridVerb::m_pVerbs
CXTPPropertyGridVerbs * m_pVerbs
Collection of verb links.
Definition XTPPropertyGrid.h:224
CXTPPropertyGridVerb::GetIndex
int GetIndex() const
Gets the index of this verb link within the collection of verb links.
Definition XTPPropertyGrid.h:1473
CXTPPropertyGridVerb::GetID
int GetID() const
Gets the ID of this verb link.
Definition XTPPropertyGrid.h:1469
CXTPPropertyGridVerb::GetPart
CRect GetPart() const
This method is used internally by PaintManager and PropertyGrid to get the bounding rectangle of verb...
Definition XTPPropertyGrid.h:1481
CXTPPropertyGridVerb::m_ptClick
CPoint m_ptClick
The last position that the user clicked.
Definition XTPPropertyGrid.h:223
CXTPPropertyGridVerb::m_nIndex
int m_nIndex
Index of this verb link in the collection of verbs.
Definition XTPPropertyGrid.h:221
CXTPPropertyGridVerb::m_rcPart
CRect m_rcPart
Bounding rectangle of the verb.
Definition XTPPropertyGrid.h:222
CXTPPropertyGridVerb::GetCaption
CString GetCaption() const
Gets the text caption of this verb link.
Definition XTPPropertyGrid.h:1465
CXTPPropertyGridVerb::SetPart
void SetPart(CRect rc)
This method is used internally by PaintManager and PropertyGrid to set the bounding rectangle for ver...
Definition XTPPropertyGrid.h:1477
CXTPPropertyGridVerb::CXTPPropertyGridVerb
CXTPPropertyGridVerb()
Constructs a CXTPPropertyGridVerb object.
CXTPPropertyGridVerb::GetClickPoint
CPoint GetClickPoint() const
Gets the last position that the user clicked.
Definition XTPPropertyGrid.h:1485
CXTPPropertyGridVerb::IsFocused
BOOL IsFocused() const
Determines if this verb link is focused.
Definition XTPPropertyGrid.h:1489
CXTPPropertyGridVerb::m_nID
int m_nID
ID assigned to this verb link.
Definition XTPPropertyGrid.h:220
CXTPPropertyGridVerb::m_strCaption
CString m_strCaption
Text caption of this verb link.
Definition XTPPropertyGrid.h:219
CXTPPropertyGridVerbs
A collection of CXTPPropertyGridVerb objects that are displayed in the verb panel.
Definition XTPPropertyGrid.h:247
CXTPPropertyGridVerbs::Add
void Add(LPCTSTR lpszCaption, UINT nID)
Adds a verb link to the verb panel.
CXTPPropertyGridVerbs::GetCount
int GetCount() const
Gets the total number of verbs in the collection of verbs.
CXTPPropertyGridVerbs::m_arrVerbs
CArray< CXTPPropertyGridVerb *, CXTPPropertyGridVerb * > m_arrVerbs
Collection of verb links.
Definition XTPPropertyGrid.h:307
CXTPPropertyGridVerbs::m_pGrid
CXTPPropertyGrid * m_pGrid
Pointer to the property grid that the verbs are drawn on.
Definition XTPPropertyGrid.h:309
CXTPPropertyGridVerbs::GetAt
CXTPPropertyGridVerb * GetAt(int nIndex) const
Retrieves the verb at a specified index within the collection of verbs.
Definition XTPPropertyGrid.h:1494
CXTPPropertyGridVerbs::RemoveAll
void RemoveAll()
Removes all verbs from the collection of verbs.
CXTPPropertyGridVerbs::IsEmpty
BOOL IsEmpty() const
Determines if any verbs have been added to the collection of verbs.
Definition XTPPropertyGrid.h:1498
CXTPPropertyGridVerbs::CXTPPropertyGridVerbs
CXTPPropertyGridVerbs()
Constructs a CXTPPropertyGridVerbs object.
CXTPPropertyGridVerbs::~CXTPPropertyGridVerbs
~CXTPPropertyGridVerbs()
Destroys a CXTPPropertyGridVerbs object, handles cleanup and deallocation.
CXTPPropertyGridView
CXTPPropertyGridView is a CListBox derived class.
Definition XTPPropertyGridView.h:49
CXTPToolTipContext
CXTPToolTipContext is a CXTPCmdTarget derived class.
Definition XTPToolTipContext.h:291


Toolkit Pro: Member List

CXTPVisualStudio2010Theme Member List

This is the complete list of members for CXTPVisualStudio2010Theme, including all inherited members.

AdjustExcludeRect(CRect &rc, CXTPControl *pControl, BOOL bVertical) | CXTPVisualStudio2010Theme | virtual
Animate(CDC *pDestDC, CDC *pSrcDC, CRect rc, XTPAnimationType animationType) | CXTPPaintManager | virtual
AnimateExpanding(CXTPCommandBar *pCommandBar, CDC *pDestDC, CDC *pSrcDC, BOOL bExpandDown) | CXTPPaintManager | virtual
BaseTheme() | CXTPVisualStudio2010Theme | inlinevirtual
CreateGradientCircle() | CXTPCommandBarsOffice2003Theme | protected
CreateTheme(XTPPaintTheme paintTheme) | CXTPPaintManager | static
CXTPCmdTarget() | CXTPCmdTarget |
CXTPCommandBarsOffice2003Theme() | CXTPCommandBarsOffice2003Theme |
CXTPCommandBarsOfficeXPTheme() | CXTPCommandBarsOfficeXPTheme |
CXTPObservable() | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | protected
CXTPPaintManager() | CXTPPaintManager | protected
CXTPVisualStudio2010Theme() | CXTPVisualStudio2010Theme |
Draw3dRect(CDC *pDC, LPCRECT rc, int nTopLeft, int nBottomRight) | CXTPPaintManager |
Draw3dRect(CDC *pDC, LPCRECT rc, int frameThickness, COLORREF clrPen, COLORREF clrBrush) | CXTPPaintManager |
CXTPPaintManager::DrawCheckMark(CDC *pDC, CRect rcCheck, COLORREF clr=0) | CXTPPaintManager | inline
DrawComboExpandMark(CDC *pDC, CRect rc, COLORREF clr) | CXTPPaintManager | virtual
DrawCommandBarGripper(CDC *pDC, CXTPCommandBar *pBar, BOOL bDraw=TRUE) | CXTPCommandBarsOffice2003Theme | protectedvirtual
DrawCommandBarGroupSeparator(CDC *pDC, CXTPCommandBar *pBar, CXTPControl *pLeftControl, CXTPControl *pRightControl, BOOL bDraw=TRUE) | CXTPPaintManager | virtual
DrawCommandBarSeparator(CDC *pDC, CXTPCommandBar *pBar, CXTPControl *pControl, BOOL bDraw) | CXTPVisualStudio2010Theme | virtual
DrawControl(CDC *pDC, CXTPControl *pButton, BOOL bDraw=TRUE) | CXTPPaintManager |
DrawControlCheckBoxMark(CDC *pDC, CRect rc, BOOL bDraw, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled) | CXTPCommandBarsOfficeXPTheme | protectedvirtual
DrawControlCheckBoxMark(CDC *pDC, CXTPControl *pButton, CRect rc, BOOL bDraw) | CXTPCommandBarsOfficeXPTheme | protectedvirtual
DrawControlComboBox(CDC *pDC, CXTPControlComboBox *pComboBox, BOOL bDraw) | CXTPCommandBarsOfficeXPTheme | protectedvirtual
DrawControlEdit(CDC *pDC, CXTPControlEdit *pEdit, BOOL bDraw) | CXTPCommandBarsOfficeXPTheme | protectedvirtual
DrawControlEntry(CDC *pDC, CXTPControl *pButton) | CXTPPaintManager | virtual
DrawControlMDIButton(CDC *pDC, CXTPControlButton *pButton) | CXTPPaintManager | virtual
DrawControlPopupParent(CDC *pDC, CXTPControl *pButton, BOOL bDraw) | CXTPCommandBarsOfficeXPTheme | protectedvirtual
DrawControlRadioButtonMark(CDC *pDC, CRect rc, BOOL bDraw, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled) | CXTPCommandBarsOfficeXPTheme | protectedvirtual
DrawControlText(CDC *pDC, CXTPControl *pControl, CRect rcText, BOOL bDraw, BOOL bVert, BOOL bCentered, BOOL bTriangled) | CXTPPaintManager |
DrawControlToolBarParent(CDC *pDC, CXTPControl *pButton, BOOL bDraw) | CXTPPaintManager | virtual
DrawDialogBarGripper(CDC *pDC, CXTPDialogBar *pBar, BOOL bDraw) | CXTPCommandBarsOffice2003Theme | protectedvirtual
DrawDropDownGlyph(CDC *pDC, CXTPControl *pControl, CPoint pt, BOOL bSelected, BOOL bPopuped, BOOL bEnabled, BOOL bVert) | CXTPPaintManager | virtual
DrawExpandGlyph(CDC *pDC, CXTPControl *pButton, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clr) | CXTPPaintManager | virtual
DrawExpandGlyph(CDC *pDC, CXTPControl *pButton, COLORREF clr, BOOL bVertical) | CXTPPaintManager | virtual
DrawGalleryItemBack(CDC *pDC, CRect rcItem, BOOL bEnabled, BOOL bSelected, BOOL bPressed, BOOL bChecked, XTPBarType barType) | CXTPPaintManager | virtual
DrawHiddenGlyph(CDC *pDC, CXTPControl *pButton, COLORREF clr, BOOL bVertical) | CXTPPaintManager | virtual
DrawImage(CDC *pDC, CPoint pt, CSize sz, CXTPImageManagerIcon *pImage, BOOL bSelected, BOOL bPressed, BOOL bEnabled=TRUE, BOOL bChecked=FALSE, BOOL bPopuped=FALSE, BOOL bToolBarImage=TRUE) | CXTPCommandBarsOfficeXPTheme | protectedvirtual
DrawListBoxControl(CDC *pDC, CXTPControl *pButton, CRect rc, BOOL bSelected, BOOL bDraw, CXTPCommandBars *pCommandBars=0) | CXTPCommandBarsOfficeXPTheme | virtual
DrawPopupBarCheckMark(CDC *pDC, CRect rcCheck, BOOL bEnabled, COLORREF clr) | CXTPPaintManager | virtual
DrawPopupBarGripper(CDC *pDC, int xPos, int yPos, int cx, int cy, BOOL bExpanded) | CXTPVisualStudio2010Theme | virtual
DrawPopupBarRadioMark(CDC *pDC, CRect rcCheck, BOOL bEnabled, COLORREF clr) | CXTPPaintManager | virtual
DrawPopupResizeGripper(CDC *pDC, CRect rcGripper, int nFlags) | CXTPCommandBarsOfficeXPTheme | virtual
DrawRectangle(CDC *pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition) | CXTPVisualStudio2010Theme | virtual
DrawRectangle(CDC *pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition, int nID) | CXTPVisualStudio2010Theme | virtual
DrawRectangle(CDC *pDC, CXTPControl *pButton) | CXTPVisualStudio2010Theme | virtual
DrawSpecialControl(CDC *pDC, XTPSpecialControl controlType, CXTPControl *pButton, CXTPCommandBar *pBar, BOOL bDraw, LPVOID lpParam) | CXTPCommandBarsOffice2003Theme | protectedvirtual
DrawSplitButtonFrame(CDC *pDC, CXTPControl *pButton, CRect rc) | CXTPCommandBarsOfficeXPTheme | protectedvirtual
DrawTearOffGripper(CDC *pDC, CRect rcGripper, BOOL bSelected, BOOL bDraw) | CXTPCommandBarsOffice2003Theme | protectedvirtual
ExcludeCorners(CDC *pDC, CRect rc) | CXTPCommandBarsOffice2003Theme |
FillCommandBarEntry(CDC *pDC, CXTPCommandBar *pBar) | CXTPVisualStudio2010Theme | virtual
FillDockBar(CDC *pDC, CXTPDockBar *pBar) | CXTPCommandBarsOffice2003Theme | protectedvirtual
FillIntersectRect(CDC *pDC, CXTPPopupBar *pPopupBar, COLORREF clr) | CXTPCommandBarsOfficeXPTheme | protected
FillWorkspace(CDC *pDC, CRect rc, CRect rcExclude) | CXTPPaintManager | virtual
FontExists(LPCTSTR lpszFaceName) | CXTPPaintManager | static
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCommandBarBorders(CXTPCommandBar *pBar) | CXTPVisualStudio2010Theme | virtual
GetCommandBarFont(CXTPCommandBar *pCommandBar) | CXTPPaintManager | virtual
GetControlBackColor(CXTPControl *pButton) | CXTPPaintManager | virtual
GetControlEditBackColor(CXTPControl *pControl) | CXTPPaintManager | virtual
GetControlFont(CXTPControl *pControl) | CXTPPaintManager | virtual
GetControlHeight() const | CXTPPaintManager |
GetControlTextColor(CXTPControl *pButton) | CXTPPaintManager | virtual
GetControlTextOrientation(CXTPControl *pControl) | CXTPPaintManager | virtual
GetCurrentSystemTheme() | CXTPPaintManager |
GetCurrentTheme() | CXTPPaintManager | inline
GetDefaultCommandBarSize(CXTPCommandBar *pBar) | CXTPPaintManager | virtual
GetFramePaintManager() | CXTPPaintManager | virtual
GetGalleryPaintManager() const | CXTPPaintManager | virtual
GetGlobalPaintManager() | CXTPPaintManager | static
GetIconFont() | CXTPPaintManager |
GetIconsInfo() | CXTPPaintManager |
GetInstanceAddRef() | CXTPPaintManager | static
GetMessageBarPaintManager() | CXTPPaintManager | virtual
GetModernBitmap(UINT nIDResource) | CXTPCommandBarsOffice2003Theme | static
GetPopupBarGripperWidth(CXTPCommandBar *pBar) | CXTPPaintManager | virtual
GetProgressPaintManager() const | CXTPPaintManager | virtual
GetRectangleTextColor(BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition) | CXTPVisualStudio2010Theme | virtual
GetRegularBoldFont() | CXTPPaintManager |
GetRegularFont() | CXTPPaintManager |
GetRibbonPaintManager() | CXTPPaintManager | virtual
GetScrollBarPaintManager() const | CXTPPaintManager | virtual
GetShadowManager() const | CXTPPaintManager |
GetShadowOptions() const | CXTPPaintManager |
GetSliderPaintManager() const | CXTPPaintManager | virtual
GetSmCaptionFont() | CXTPPaintManager |
GetSplitButtonCommandRect(CXTPControl *pButton) | CXTPPaintManager | virtual
GetStatusBarPaintManager() | CXTPPaintManager | virtual
GetXtremeColor(UINT nIndex) | CXTPPaintManager |
GradientFill(CDC *pDC, LPRECT lpRect, COLORREF crFrom, COLORREF crTo, BOOL bHorz, LPCRECT lpRectClip=NULL) | CXTPPaintManager |
HasFloatingBarGradientEntry(CXTPCommandBar *pBar) | CXTPCommandBarsOffice2003Theme | protectedvirtual
HorizontalLine(CDC *pDC, int x0, int y0, int x1, COLORREF clrPen) | CXTPPaintManager |
IsUseSystemAccentColorEnabled() const | CXTPPaintManager |
Line(CDC *pDC, CPoint p0, CPoint p1) | CXTPPaintManager |
Line(CDC *pDC, int x0, int y0, int x1, int y1, const int nPen) | CXTPPaintManager |
Line(CDC *pDC, int x0, int y0, int x1, int y1, COLORREF clrPen) | CXTPPaintManager |
LoadModernToolbarIcons(UINT nIDResource) | CXTPCommandBarsOffice2003Theme | static
LoadModernToolbarIcons(UINT nIDResource, UINT *pCommands, int nCount, CSize szIcon=CSize(16, 15)) | CXTPCommandBarsOffice2003Theme | static
m_arrColor | CXTPPaintManager | protected
m_bAutoResizeIcons | CXTPPaintManager |
m_bClearTypeTextQuality | CXTPPaintManager |
m_bEmbossedDisabledText | CXTPPaintManager | protected
m_bEnableAnimation | CXTPPaintManager |
m_bFlatMenuBar | CXTPPaintManager |
m_bFlatToolBar | CXTPPaintManager |
m_bLunaTheme | CXTPCommandBarsOffice2003Theme |
m_bOffice2007Padding | CXTPPaintManager |
m_bOffsetPopupLabelText | CXTPPaintManager |
m_bPlainSeparators | CXTPCommandBarsOffice2003Theme |
m_bSelectImageInPopupBar | CXTPPaintManager |
m_bShowKeyboardCues | CXTPPaintManager | protected
m_bShowShadow | CXTPPaintManager |
m_bThemedCheckBox | CXTPPaintManager |
m_bThemedStatusBar | CXTPPaintManager |
m_bThickCheckMark | CXTPPaintManager |
m_bUseOfficeFont | CXTPPaintManager |
m_bUseStandardFont | CXTPPaintManager | protected
m_bWrapCaptionBelowText | CXTPPaintManager |
m_clrCommandBar | CXTPCommandBarsOffice2003Theme |
m_clrDisabledIcon | CXTPPaintManager |
m_clrDockBar | CXTPCommandBarsOffice2003Theme |
m_clrFloatingGripper | CXTPPaintManager |
m_clrFloatingGripperText | CXTPPaintManager |
m_clrMenuExpand | CXTPCommandBarsOffice2003Theme |
m_clrMenuExpandedGripper | CXTPCommandBarsOffice2003Theme |
m_clrMenuGripper | CXTPCommandBarsOffice2003Theme |
m_clrMessageBarText | CXTPPaintManager |
m_clrPopupControl | CXTPCommandBarsOffice2003Theme |
m_clrTearOffGripper | CXTPCommandBarsOffice2003Theme |
m_clrToolbarExpand | CXTPCommandBarsOffice2003Theme |
m_clrToolbarShadow | CXTPCommandBarsOffice2003Theme |
m_fontIcon | CXTPPaintManager |
m_fontIconBold | CXTPPaintManager |
m_fontSmCaption | CXTPPaintManager |
m_fontToolTip | CXTPPaintManager |
m_grcLunaChecked | CXTPCommandBarsOffice2003Theme |
m_grcLunaPushed | CXTPCommandBarsOffice2003Theme |
m_grcLunaSelected | CXTPCommandBarsOffice2003Theme |
m_iconsInfo | CXTPPaintManager | protected
m_ilGradientCircle | CXTPCommandBarsOffice2003Theme |
m_nAnimationSteps | CXTPPaintManager | protected
m_nAnimationTime | CXTPPaintManager | protected
m_nEditHeight | CXTPPaintManager | protected
m_nFontHeight | CXTPPaintManager | protected
m_nPopupBarTextPadding | CXTPPaintManager |
m_nSplitButtonDropDownHeight | CXTPPaintManager |
m_nSplitButtonDropDownWidth | CXTPPaintManager |
m_nSplitButtonPopupWidth | CXTPPaintManager |
m_nStatusBarMinHeight | CXTPPaintManager |
m_nTextHeight | CXTPPaintManager |
m_pfnSetLayeredWindowAttributes | CXTPPaintManager |
m_pFramePaintManager | CXTPPaintManager |
m_pGalleryPaintManager | CXTPPaintManager |
m_pProgressPaintManager | CXTPPaintManager |
m_pRibbonPaintManager | CXTPPaintManager |
m_pScrollBarPaintManager | CXTPPaintManager |
m_pShadowManager | CXTPPaintManager | protected
m_pSliderPaintManager | CXTPPaintManager |
m_pStatusBarPaintManager | CXTPPaintManager |
m_rcMessageBarMargin | CXTPPaintManager |
m_rcStatusBarBorder | CXTPPaintManager |
m_strOfficeFont | CXTPPaintManager |
m_systemTheme | CXTPPaintManager | protected
m_themeButton | CXTPPaintManager | protected
m_themeCurrent | CXTPPaintManager | protected
m_themeStatusBar | CXTPPaintManager | protected
m_xtpFontRegular | CXTPPaintManager | protected
m_xtpFontRegularBold | CXTPPaintManager | protected
m_xtpFontVert | CXTPPaintManager | protected
m_xtpFontVertBold | CXTPPaintManager | protected
Notify(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *)) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
Notify(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1), A1 arg1) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
Notify(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
Notify(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamic(void(T::*method)(O *)) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1), A1 arg1) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *)) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1), A1 arg1) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyReversed(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *)) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyReversed(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1), A1 arg1) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyReversed(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyReversed(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
Pixel(CDC *pDC, int xPos, int yPos, int nPen) | CXTPPaintManager |
Rectangle(CDC *pDC, LPCRECT rc, int nPen, const int nBrush) | CXTPPaintManager |
Rectangle(CDC *pDC, LPCRECT rc, COLORREF clrPen, COLORREF clrBrush) | CXTPPaintManager |
RefreshMetrics() | CXTPVisualStudio2010Theme | virtual
ReleaseInstance() | CXTPPaintManager | static
RequiresResourceImages() | CXTPPaintManager | virtual
RoundRect(CDC *pDC, LPCRECT rc, COLORREF clrPen, COLORREF clrBrush) | CXTPPaintManager |
SetAnimationDelay(int nAnimationSteps, int nAnimationTime) | CXTPPaintManager |
SetColors(int cElements, CONST INT *lpaElements, CONST COLORREF *lpaRgbValues) | CXTPPaintManager |
SetCommandBarRegion(CXTPCommandBar *pCommandBar) | CXTPPaintManager | virtual
SetCommandBarsFontIndirect(LOGFONT *pLogFont, BOOL bUseStandardFont=FALSE) | CXTPPaintManager |
SetCustomTheme(CXTPPaintManager *pTheme) | CXTPPaintManager | static
SetGlobalPaintManager(CXTPPaintManager *pPaintManager) | CXTPPaintManager | static
SetImageHandle(HMODULE hResource, LPCTSTR lpszIniFileName) | CXTPPaintManager | virtual
SetLunaTheme(XTPCurrentSystemTheme systemTheme) | CXTPPaintManager |
SetTheme(XTPPaintTheme paintTheme) | CXTPPaintManager | static
StripMnemonics(CString &strClear) | CXTPPaintManager | static
Subscribe(IXTPPaintManagerEvents *pObserver, CXTPSubscriptionList< CXTPPaintManager, IXTPPaintManagerEvents > *pSubcriptionList=NULL) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > |
Triangle(CDC *pDC, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clr) | CXTPPaintManager | static
Unsubscribe(IXTPPaintManagerEvents *pObserver) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > |
UpdateColors() | CXTPPaintManager | virtual
UpdateFonts() | CXTPPaintManager | virtual
UpdateRTLCaption(CString &strCaption) | CXTPPaintManager | virtual
UseOfficeFont(bool bUseOfficeFont) | CXTPPaintManager |
VerticalLine(CDC *pDC, int x0, int y0, int y1, COLORREF clrPen) | CXTPPaintManager |
~CXTPCommandBarsOffice2003Theme() | CXTPCommandBarsOffice2003Theme | virtual
~CXTPObservable() | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | protected
~CXTPPaintManager() | CXTPPaintManager | protectedvirtual
~CXTPVisualStudio2010Theme() | CXTPVisualStudio2010Theme | virtual


Toolkit Pro: XTPTaskPanelOffice2013Theme.h Source File

  • Source
  • TaskPanel
  • Themes
XTPTaskPanelOffice2013Theme.h
Go to the documentation of this file.
1
23#if !defined(__XTPTASKPANELOFFICE2013THEME_H__)
24# define __XTPTASKPANELOFFICE2013THEME_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
39class _XTP_EXT_CLASS CXTPTaskPanelOffice2013Theme : public CXTPTaskPanelVisualStudio2012Theme
40{
41public:
46 CXTPTaskPanelOffice2013Theme();
47
53 virtual ~CXTPTaskPanelOffice2013Theme();
54
59 virtual void RefreshMetrics();
60
67 virtual void FillTaskPanel(CDC* pDC, CXTPTaskPanel* pTaskPanel);
68};
70# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
71#endif // __XTPTASKPANELOFFICE2013THEME_H__
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPTaskPanel
CXTPTaskPanel is used to implement an Explorer and Office-like Task Panel control.
Definition XTPTaskPanel.h:107
CXTPTaskPanelOffice2013Theme
CXTPTaskPanelOffice2013Theme represents an Office 2013 style theme.
Definition XTPTaskPanelOffice2013Theme.h:40
CXTPTaskPanelOffice2013Theme::FillTaskPanel
virtual void FillTaskPanel(CDC *pDC, CXTPTaskPanel *pTaskPanel)
Fills the background of a specified task panel.
CXTPTaskPanelOffice2013Theme::~CXTPTaskPanelOffice2013Theme
virtual ~CXTPTaskPanelOffice2013Theme()
Destroys a CXTPTaskPanelOffice2013Theme object, handles cleanup and deallocation.
CXTPTaskPanelOffice2013Theme::CXTPTaskPanelOffice2013Theme
CXTPTaskPanelOffice2013Theme()
Constructs a CXTPTaskPanelOffice2013Theme object.
CXTPTaskPanelOffice2013Theme::RefreshMetrics
virtual void RefreshMetrics()
Refreshes the visual metrics of the task panel.
CXTPTaskPanelVisualStudio2012Theme
CXTPTaskPanelVisualStudio2012Theme represents a VS.NET 2012 style theme.
Definition XTPTaskPanelVisualStudio2012Theme.h:40


Toolkit Pro: XTPChartOpenGLBackgroundColorDeviceCommand.h Source File

  • Source
  • Chart
  • Drawing
  • OpenGL
XTPChartOpenGLBackgroundColorDeviceCommand.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTOPENGLBACKGROUNDCOLORDEVICECOMMAND_H__)
24# define __XTPCHARTOPENGLBACKGROUNDCOLORDEVICECOMMAND_H__
25
26# if _MSC_VER >= 1000
27# pragma once
28# endif // _MSC_VER >= 1000
29
30# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
31
32class _XTP_EXT_CLASS CXTPChartOpenGLBackgroundColorDeviceCommand : public CXTPChart3dDeviceCommand
33{
34public:
41 CXTPChartOpenGLBackgroundColorDeviceCommand(const CXTPChartColor& color);
42
43protected:
52 void ExecuteOverride(CXTPChartDeviceContext* pDC);
53
54private:
55 const CXTPChartColor m_color;
56};
57
58# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
59#endif //#if !defined(__XTPCHARTOPENGLBACKGROUNDCOLORDEVICECOMMAND_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChart3dDeviceCommand
Defines a common implementation interface for chart 3D drawing commands.
Definition XTPChartDeviceCommand.h:368
CXTPChartColor
This class abstracts a color entity.
Definition XTPChartTypes.h:51
CXTPChartDeviceCommand::ExecuteOverride
virtual void ExecuteOverride(CXTPChartDeviceContext *pDC)
Override this function to write the drawing code for specific objects.
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48


Toolkit Pro: Member List

CXTPChartBarSeriesLabel Member List

This is the complete list of members for CXTPChartBarSeriesLabel, including all inherited members.

CreateView(CXTPChartDeviceContext *pDC, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView) | CXTPChartBarSeriesLabel | virtual
CXTPChartBarSeriesLabel() | CXTPChartBarSeriesLabel |
CXTPChartDiagram2DSeriesLabel() | CXTPChartDiagram2DSeriesLabel |
CXTPChartElement() | CXTPChartElement |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartSeriesLabel() | CXTPChartSeriesLabel |
DoPropExchange(CXTPPropExchange *pPX) | CXTPChartBarSeriesLabel | virtual
GetAntialiasing() const | CXTPChartSeriesLabel | virtual
GetAppearance() const | CXTPChartElement |
GetBackColor() const | CXTPChartSeriesLabel |
GetContent() const | CXTPChartElement |
GetFont() const | CXTPChartSeriesLabel | virtual
GetFormat() const | CXTPChartSeriesLabel |
GetLineColor() const | CXTPChartSeriesLabel |
GetLineLength() const | CXTPChartSeriesLabel |
GetOwner() const | CXTPChartElement |
GetShowLines() const | CXTPChartSeriesLabel |
GetTextColor() const | CXTPChartSeriesLabel |
GetTransparency() const | CXTPChartSeriesLabel |
Is3D() const | CXTPChartObject |
IsVisible() const | CXTPChartSeriesLabel |
m_bAntialiasing | CXTPChartSeriesLabel | protected
m_bShowLines | CXTPChartSeriesLabel | protected
m_bVisible | CXTPChartSeriesLabel | protected
m_clrBackColor | CXTPChartSeriesLabel | protected
m_clrLineColor | CXTPChartSeriesLabel | protected
m_clrTextColor | CXTPChartSeriesLabel | protected
m_nLineLength | CXTPChartSeriesLabel | protected
m_nTransparency | CXTPChartSeriesLabel | protected
m_pBorder | CXTPChartSeriesLabel | protected
m_pFont | CXTPChartSeriesLabel | protected
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartElement | virtual
Release() | CXTPChartElement | virtual
SetAntialiasing(BOOL bAntialiasing) | CXTPChartSeriesLabel |
SetBackColor(const CXTPChartColor &clrBackColor) | CXTPChartSeriesLabel |
SetFont(CXTPChartFont *pFont) | CXTPChartSeriesLabel |
SetFormat(LPCTSTR lpszFormat) | CXTPChartSeriesLabel |
SetLineColor(const CXTPChartColor &clrBackColor) | CXTPChartSeriesLabel |
SetLineLength(int nLineLength) | CXTPChartSeriesLabel |
SetShowLines(BOOL bShowLines) | CXTPChartSeriesLabel |
SetTextColor(const CXTPChartColor &clrTextColor) | CXTPChartSeriesLabel |
SetTransparency(int nTransparency) | CXTPChartSeriesLabel |
SetVisible(BOOL bVisible) | CXTPChartSeriesLabel |
~CXTPChartBarSeriesLabel() | CXTPChartBarSeriesLabel | virtual
~CXTPChartDiagram2DSeriesLabel() | CXTPChartDiagram2DSeriesLabel | virtual
~CXTPChartElement() | CXTPChartElement | virtual
~CXTPChartSeriesLabel() | CXTPChartSeriesLabel | virtual


Toolkit Pro: Member List

CXTPTabThemeVisualStudio2015 Member List

This is the complete list of members for CXTPTabThemeVisualStudio2015, including all inherited members.

AdjustClientRect(CXTPTabManager *pTabManager, CRect &rcClient) | CXTPTabPaintManagerTheme | virtual
CXTPTabPaintManagerTheme() | CXTPTabPaintManagerTheme |
CXTPTabThemeFlat() | CXTPTabThemeFlat | inline
CXTPTabThemeVisualStudio2015() | CXTPTabThemeVisualStudio2015 |
DrawSingleButton(CDC *pDC, CXTPTabManagerItem *pItem) | CXTPTabThemeVisualStudio2012 | virtual
DrawTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl) | CXTPTabPaintManagerTheme | virtual
DrawText(CDC *pDC, CXTPTabManager *pManager, const CString &str, LPRECT lpRect, UINT nFormat) | CXTPTabPaintManagerTheme | virtual
DrawWorkspacePart(CDC *pDC, LPRECT lpRect, XTPTabWorkspacePart workspacePart) | CXTPTabThemeVisualStudio2012 | virtual
FillButton(CDC *pDC, CXTPTabManagerItem *pItem, LPPOINT pts, int nCount, XTPTabPosition tabPosition, BOOL bAbsolute=FALSE) | CXTPTabPaintManagerTheme |
FillTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl) | CXTPTabThemeFlat | virtual
GetButtonDrawRect(const CXTPTabManagerItem *pItem) | CXTPTabPaintManagerTheme | virtual
GetButtonHeight(const CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetButtonLength(CDC *pDC, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerTheme | virtual
GetClientMargin() | CXTPTabPaintManagerTheme | virtual
GetClientRect(CRect rcControl, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetColorSet() const | CXTPTabPaintManagerTheme |
GetDefaultColorSet() | CXTPTabThemeVisualStudio2015 | inlinevirtual
GetHeaderClipBox(CDC *pDC, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetHeaderHeight(CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme |
GetHeaderMargin() | CXTPTabPaintManagerTheme | virtual
GetHeaderRect(CRect rcControl, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetSupportedColorSets() | CXTPTabPaintManagerTheme | inlinevirtual
m_bButtonsReverseZOrder | CXTPTabPaintManagerTheme | protected
m_nButtonHeight | CXTPTabPaintManagerTheme | protected
m_nRowMargin | CXTPTabPaintManagerTheme |
m_pPaintManager | CXTPTabPaintManagerTheme | protected
m_rcHeaderMargin | CXTPTabPaintManagerTheme |
RefreshMetrics() | CXTPTabThemeVisualStudio2015 | virtual
RepositionTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcClient) | CXTPTabPaintManagerTheme | virtual
~CXTPTabPaintManagerTheme() | CXTPTabPaintManagerTheme | virtual


Toolkit Pro: Member List

CXTPCalendarCustomDataProvider Member List

This is the complete list of members for CXTPCalendarCustomDataProvider, including all inherited members.

AddEvent(CXTPCalendarEvent *pEvent) | CXTPCalendarData | virtual
AddEventCategory(UINT uID, CString strName, COLORREF crBorder, COLORREF crBkBase) | CXTPCalendarData | virtual
AddEventLabel(int nID, CString strName, COLORREF crLabel) | CXTPCalendarData | virtual
AddEvents(CXTPCalendarEvents *pEvents) | CXTPCalendarData | virtual
ChangeEvent(CXTPCalendarEvent *pNewEvent) | CXTPCalendarData | virtual
ClearCache() | CXTPCalendarData | virtual
ClearEventCategoryList() | CXTPCalendarData | virtual
ClearEventLabelList() | CXTPCalendarData | virtual
Close() | CXTPCalendarCustomDataProvider | virtual
Create() | CXTPCalendarData | virtual
CreateDataProvider(LPCTSTR lpszConnectionString) | CXTPCalendarData | static
CreateDataProvider(XTPCalendarDataProvider eDataProvider) | CXTPCalendarData | static
CreateNewEvent(DWORD dwEventID=XTP_CALENDAR_UNKNOWN_EVENT_ID) | CXTPCalendarData | virtual
CreateNewRecurrencePattern(DWORD dwPatternID=XTP_CALENDAR_UNKNOWN_RECURRENCE_PATTERN_ID) | CXTPCalendarData | virtual
CXTPCalendarCustomDataProvider() | CXTPCalendarCustomDataProvider |
CXTPCalendarData() | CXTPCalendarData |
CXTPCmdTarget() | CXTPCmdTarget |
DataProviderTypeFromConStr(LPCTSTR lpszConnectionString, XTPCalendarDataProvider eDPDefault=xtpCalendarDataProviderUnknown) | CXTPCalendarData | static
DataSourceFromConStr(LPCTSTR lpszConnectionString) | CXTPCalendarData | static
DeleteEvent(CXTPCalendarEvent *pEvent) | CXTPCalendarData | virtual
DoCreate_Event(CXTPCalendarEvent *pEvent, DWORD &rdwNewEventID) | CXTPCalendarCustomDataProvider | protectedvirtual
DoCreate_RPattern(CXTPCalendarRecurrencePattern *pPattern, DWORD &rdwNewPatternID) | CXTPCalendarCustomDataProvider | protectedvirtual
DoDelete_Event(CXTPCalendarEvent *pEvent) | CXTPCalendarCustomDataProvider | protectedvirtual
DoDelete_RPattern(CXTPCalendarRecurrencePattern *pPattern) | CXTPCalendarCustomDataProvider | protectedvirtual
DoGetAllEvents_raw() | CXTPCalendarCustomDataProvider | protectedvirtual
DoGetUpcomingEvents(COleDateTime dtFrom, COleDateTimeSpan spPeriod) | CXTPCalendarCustomDataProvider | protectedvirtual
DoRead_Event(DWORD dwEventID) | CXTPCalendarCustomDataProvider | protectedvirtual
DoRead_RPattern(DWORD dwPatternID) | CXTPCalendarCustomDataProvider | protectedvirtual
DoRemoveAllEvents() | CXTPCalendarCustomDataProvider | protectedvirtual
DoRetrieveDayEvents(COleDateTime dtDay) | CXTPCalendarCustomDataProvider | protectedvirtual
DoUpdate_Event(CXTPCalendarEvent *pEvent) | CXTPCalendarCustomDataProvider | protectedvirtual
DoUpdate_RPattern(CXTPCalendarRecurrencePattern *pPattern) | CXTPCalendarCustomDataProvider | protectedvirtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAllEvents_raw() | CXTPCalendarData | virtual
GetCacheMode() const | CXTPCalendarData | virtual
GetConnection() const | CXTPCalendarData | virtual
GetConnectionString() const | CXTPCalendarData | virtual
GetCustomProperties() const | CXTPCalendarData | virtual
GetDataSource() | CXTPCalendarData | virtual
GetEvent(DWORD dwEventID) | CXTPCalendarData | virtual
GetEventCategories() const | CXTPCalendarData | virtual
GetLabelList() const | CXTPCalendarData | virtual
GetNextFreeTempID() | CXTPCalendarData | protectedstatic
GetRecurrencePattern(DWORD dwPatternID) | CXTPCalendarData | virtual
GetSchedules() const | CXTPCalendarData | virtual
GetType() const | CXTPCalendarData | virtual
GetUpcomingEvents(COleDateTime dtFrom=(DATE) 0, COleDateTimeSpan spPeriod=(DATE) 0) | CXTPCalendarData | virtual
IsOpen() const | CXTPCalendarData | virtual
m_bDisableNotificationsSending | CXTPCalendarData | protected
m_bOpened | CXTPCalendarData | protected
m_pCalendarOptions | CXTPCalendarData | protected
m_pConnection | CXTPCalendarData | protected
m_pCustomProperties | CXTPCalendarData | protected
m_pEventCategories | CXTPCalendarData | protected
m_pLabelList | CXTPCalendarData | protected
m_pSchedules | CXTPCalendarData | protected
m_strConnectionString | CXTPCalendarData | protected
m_typeProvider | CXTPCalendarData | protected
ms_dwNextFreeTempID | CXTPCalendarData | protectedstatic
OnTimeZoneChanged() | CXTPCalendarData | inlineprotectedvirtual
Open() | CXTPCalendarData | virtual
RemoveAllEvents() | CXTPCalendarData | virtual
RestoreEventCategoryList() | CXTPCalendarData | virtual
RestoreEventLabelList() | CXTPCalendarData | virtual
RetrieveDayEvents(COleDateTime dtDay) | CXTPCalendarData | virtual
Save() | CXTPCalendarData | virtual
SendNotification(XTP_NOTIFY_CODE EventCode, WPARAM wParam, LPARAM lParam) | CXTPCalendarData | protectedvirtual
SetCacheMode(int eCacheMode, CXTPCalendarData *pCacheDataProvider=NULL) | CXTPCalendarData | virtual
SetConnectionString(LPCTSTR lpszConnectionString) | CXTPCalendarData | virtual
SetLabelList(CXTPCalendarEventLabels *pLabelList) | CXTPCalendarData | virtual
UpdateEventCategories(COLORREF *pClrBkBase, COLORREF *pClrBorder, int nCount) | CXTPCalendarData |
UpdateEventLabels(COLORREF *clrEventColors, UINT uCount) | CXTPCalendarData | virtual
~CXTPCalendarCustomDataProvider() | CXTPCalendarCustomDataProvider | virtual
~CXTPCalendarData() | CXTPCalendarData | virtual


Toolkit Pro: XTPChartPointSeriesLabel.h Source File

  • Source
  • Chart
  • Styles
  • Point
XTPChartPointSeriesLabel.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTPOINTSERIESLABEL_H__)
24# define __XTPCHARTPOINTSERIESLABEL_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartSeriesView;
34
40class _XTP_EXT_CLASS CXTPChartPointSeriesLabel : public CXTPChartDiagram2DSeriesLabel
41{
42 DECLARE_SERIAL(CXTPChartPointSeriesLabel);
43
44public:
49 CXTPChartPointSeriesLabel();
50
55 virtual ~CXTPChartPointSeriesLabel();
56
57public:
64 void SetAngle(int nAngle);
65
73 int GetAngle() const;
74
75public:
76 void DoPropExchange(CXTPPropExchange* pPX);
77
78public:
90 virtual CXTPChartElementView* CreateView(CXTPChartDeviceContext* pDC,
91 CXTPChartSeriesPointView* pPointView,
92 CXTPChartElementView* pParentView);
93
94protected:
95 int m_nAngle;
97# ifdef _XTP_ACTIVEX
98public:
100 DECLARE_DISPATCH_MAP()
101 DECLARE_INTERFACE_MAP()
102 DECLARE_OLETYPELIB_EX(CXTPChartPointSeriesLabel);
104# endif
105};
106
107AFX_INLINE void CXTPChartPointSeriesLabel::SetAngle(int nAngle)
108{
109 m_nAngle = nAngle;
110 OnChartChanged();
111}
112AFX_INLINE int CXTPChartPointSeriesLabel::GetAngle() const
113{
114 return m_nAngle;
115}
117# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
118#endif //#if !defined(__XTPCHARTPOINTSERIESLABEL_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartDiagram2DSeriesLabel
This class abstracts the label of a point series.
Definition XTPChartDiagram2DSeriesLabel.h:41
CXTPChartElement::OnChartChanged
virtual void OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic propertie...
CXTPChartElementView
This class represents the view of a chart element.
Definition XTPChartElementView.h:47
CXTPChartPointSeriesLabel
This class abstracts the label of a point series.
Definition XTPChartPointSeriesLabel.h:41
CXTPChartPointSeriesLabel::SetAngle
void SetAngle(int nAngle)
Call this function to set the angle of the label stem.
Definition XTPChartPointSeriesLabel.h:107
CXTPChartPointSeriesLabel::DoPropExchange
void DoPropExchange(CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
CXTPChartPointSeriesLabel::GetAngle
int GetAngle() const
Call this function to get the angle of the label stem.
Definition XTPChartPointSeriesLabel.h:112
CXTPChartPointSeriesLabel::CXTPChartPointSeriesLabel
CXTPChartPointSeriesLabel()
Constructs a CXTPChartPointSeriesLabel object.
CXTPChartPointSeriesLabel::~CXTPChartPointSeriesLabel
virtual ~CXTPChartPointSeriesLabel()
Destroys a CXTPChartPointSeriesLabel object, handles cleanup.
CXTPChartPointSeriesLabel::m_nAngle
int m_nAngle
The stem angle.
Definition XTPChartPointSeriesLabel.h:95
CXTPChartPointSeriesLabel::CreateView
virtual CXTPChartElementView * CreateView(CXTPChartDeviceContext *pDC, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView)
This function creates the view of the label.
CXTPChartSeriesPointView
Represents chart series point view.
Definition XTPChartSeriesPointView.h:48
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72


Toolkit Pro: XTPTheme.h Source File

  • Source
  • Common
XTPTheme.h
Go to the documentation of this file.
1
23#if !defined(_XTPTHEME_H_)
24# define _XTPTHEME_H_
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPResourceImages;
34
39class _XTP_EXT_CLASS CXTPColorSetCaptionButton
40{
41public:
46 virtual ~CXTPColorSetCaptionButton()
47 {
48 }
49
56 virtual void RefreshMetrics(CString strSectionName);
57
58 CXTPPaintManagerColor m_clrBackground;
59 CXTPPaintManagerColor m_clrOutline;
60 CXTPPaintManagerColor m_clrFill;
61};
62
63# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
65#endif // !defined(_XTPTHEME_H_)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPColorSetCaptionButton
Default theme caption button color set.
Definition XTPTheme.h:40
CXTPColorSetCaptionButton::m_clrBackground
CXTPPaintManagerColor m_clrBackground
Background color.
Definition XTPTheme.h:58
CXTPColorSetCaptionButton::m_clrFill
CXTPPaintManagerColor m_clrFill
Fill color.
Definition XTPTheme.h:60
CXTPColorSetCaptionButton::RefreshMetrics
virtual void RefreshMetrics(CString strSectionName)
Called to update caption button theme colors.
CXTPColorSetCaptionButton::~CXTPColorSetCaptionButton
virtual ~CXTPColorSetCaptionButton()
Handles object destruction.
Definition XTPTheme.h:46
CXTPColorSetCaptionButton::m_clrOutline
CXTPPaintManagerColor m_clrOutline
Outline color.
Definition XTPTheme.h:59
CXTPPaintManagerColor
The CXTPPaintManagerColor class is used to manage COLORREF values for determining default and applica...
Definition XTPColorManager.h:117
CXTPResourceImages
Implements resource image collection and its operations.
Definition XTPResourceImage.h:257


Toolkit Pro: Member List

XTP_COMMANDBARS_CREATEBAR Member List

This is the complete list of members for XTP_COMMANDBARS_CREATEBAR, including all inherited members.

bCustomBar | XTP_COMMANDBARS_CREATEBAR
bExpandBar | XTP_COMMANDBARS_CREATEBAR
bPopup | XTP_COMMANDBARS_CREATEBAR
bTearOffBar | XTP_COMMANDBARS_CREATEBAR
lpcstrCaption | XTP_COMMANDBARS_CREATEBAR
nID | XTP_COMMANDBARS_CREATEBAR
pCommandBar | XTP_COMMANDBARS_CREATEBAR


Toolkit Pro: Member List

CXTPMarkupStaticExtensionStringProperty Member List

This is the complete list of members for CXTPMarkupStaticExtensionStringProperty, including all inherited members.

CXTPMarkupStaticExtension(LPCWSTR lpzName, BOOL bProperty) | CXTPMarkupStaticExtension | protected
CXTPMarkupStaticExtension(LPCWSTR lpzName) | CXTPMarkupStaticExtension |
CXTPMarkupStaticExtensionProperty(LPCWSTR lpzName, CXTPMarkupObject *pObject=NULL) | CXTPMarkupStaticExtensionProperty |
CXTPMarkupStaticExtensionStringProperty(LPCWSTR lpzName, LPCWSTR lpzValue=NULL) | CXTPMarkupStaticExtensionStringProperty |
CXTPMarkupStaticExtensionStringProperty(LPCWSTR lpzName, LPCSTR lpzValue=NULL) | CXTPMarkupStaticExtensionStringProperty |
Extend(CXTPMarkupStaticExtension *pExtension, BOOL bReplace=FALSE) | CXTPMarkupStaticExtension |
FindExtension(LPCWSTR lpzName) const | CXTPMarkupStaticExtension |
GetName() const | CXTPMarkupStaticExtension |
GetRawValue() const | CXTPMarkupStaticExtensionStringProperty |
GetValue() | CXTPMarkupStaticExtensionProperty |
IsProperty() const | CXTPMarkupStaticExtension |
OnPrepareValue() | CXTPMarkupStaticExtension | inlineprotectedvirtual
Parse(LPCWSTR lpzValue, LPCWSTR &lpzSubValue) | CXTPMarkupStaticExtension | static
ProvideValue() | CXTPMarkupStaticExtensionProperty | virtual
ProvideValue(LPCWSTR lpzValue) | CXTPMarkupStaticExtensionProperty | virtual
SetValue(LPCWSTR lpzValue) | CXTPMarkupStaticExtensionStringProperty |
SetValue(LPCSTR lpzValue) | CXTPMarkupStaticExtensionStringProperty |
CXTPMarkupStaticExtensionProperty::SetValue(CXTPMarkupObject *pObject) | CXTPMarkupStaticExtensionProperty |
~CXTPMarkupStaticExtension() | CXTPMarkupStaticExtension | virtual
~CXTPMarkupStaticExtensionProperty() | CXTPMarkupStaticExtensionProperty |


Toolkit Pro: Member List

CXTPTabBase Member List

This is the complete list of members for CXTPTabBase, including all inherited members.

CXTPTabBase() | CXTPTabBase |
GetButtons() | CXTPTabBase |
GetChildRect(CRect &rcChild) const | CXTPTabBase | virtual
GetTabCtrlImpl() | CXTPTabBase |
GetTheme() | CXTPTabBase |
ImplAttach(CTabCtrl *pTabCtrl) | CXTPTabBase | protected
Init() | CXTPTabBase | protectedvirtual
m_bAutoCondensing | CXTPTabBase |
m_bBoldFont | CXTPTabBase |
m_bSubclassed | CXTPTabBase | protected
m_bXPBorder | CXTPTabBase |
m_pNavBtns | CXTPTabBase | protected
m_pTabCtrl | CXTPTabBase | protected
m_pTheme | CXTPTabBase | protected
OnAddPadding(CString &strLabelText) | CXTPTabBase | protectedvirtual
RefreshMetrics() | CXTPTabBase | protectedvirtual
SetTheme(XTPControlTheme eTheme) | CXTPTabBase |
ShowNavButtons(DWORD dwFlags) | CXTPTabBase |
~CXTPTabBase() | CXTPTabBase | virtual


Toolkit Pro: Member List

CXTPChartRadarAxisX Member List

This is the complete list of members for CXTPChartRadarAxisX, including all inherited members.

CalcSideMarginsValue(double nMinValue, double nMaxValue) const | CXTPChartRadarAxisX | virtual
CreateView(CXTPChartDeviceContext *pDC, CXTPChartElementView *pParentView) | CXTPChartRadarAxisX | protectedvirtual
CXTPChartAxis(CXTPChartDiagram *pDiagram) | CXTPChartAxis |
CXTPChartElement() | CXTPChartElement |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartRadarAxisX(CXTPChartRadarDiagram *pDiagram) | CXTPChartRadarAxisX |
DoPropExchange(CXTPPropExchange *pPX) | CXTPChartAxis | virtual
GetActualColor() const | CXTPChartAxis |
GetActualInterlacedColor() const | CXTPChartAxis |
GetActualInterlacedColor2() const | CXTPChartAxis |
GetAlignment() const | CXTPChartAxis |
GetAppearance() const | CXTPChartAxis |
GetColor() const | CXTPChartAxis |
GetConstantLines() const | CXTPChartAxis |
GetContent() const | CXTPChartElement |
GetCustomLabels() const | CXTPChartAxis |
GetDiagram() const | CXTPChartAxis |
GetGridLines() const | CXTPChartAxis |
GetGridSpacing() const | CXTPChartAxis |
GetIndex() const | CXTPChartAxis |
GetInterlacedColor() const | CXTPChartAxis |
GetInterlacedColor2() const | CXTPChartAxis |
GetInterlacedFillStyle() const | CXTPChartAxis |
GetLabel() const | CXTPChartAxis |
GetMinorCount() const | CXTPChartAxis |
GetOwner() const | CXTPChartElement |
GetRange() const | CXTPChartAxis |
GetScaleType() const | CXTPChartAxis |
GetScaleTypeMap() const | CXTPChartAxis |
GetStrips() const | CXTPChartAxis |
GetThickness() const | CXTPChartAxis |
GetTickMarks() const | CXTPChartAxis |
GetTitle() const | CXTPChartAxis |
Is3D() const | CXTPChartObject |
IsDirectionClockwise() const | CXTPChartRadarAxisX |
IsInterlaced() const | CXTPChartAxis |
IsReversed() const | CXTPChartAxis |
IsValuesAxis() const | CXTPChartRadarAxisX | virtual
IsVertical() const | CXTPChartRadarAxisX | virtual
IsVisible() const | CXTPChartAxis |
m_bDirectionClockwise | CXTPChartRadarAxisX | protected
m_bGridSpacingAuto | CXTPChartAxis | protected
m_bInterlaced | CXTPChartAxis | protected
m_bLogarithmic | CXTPChartAxis | protected
m_bReversed | CXTPChartAxis | protected
m_bVisible | CXTPChartAxis | protected
m_clrColor | CXTPChartAxis | protected
m_clrInterlacedColor | CXTPChartAxis | protected
m_clrInterlacedColor2 | CXTPChartAxis | protected
m_dGridSpacing | CXTPChartAxis | protected
m_dLogarithmicBase | CXTPChartAxis | protected
m_nAlignment | CXTPChartAxis | protected
m_nMinorCount | CXTPChartAxis | protected
m_nScaleType | CXTPChartAxis | protected
m_nThickness | CXTPChartAxis | protected
m_pConstantLines | CXTPChartAxis | protected
m_pCustomLabels | CXTPChartAxis | protected
m_pDiagram | CXTPChartAxis | protected
m_pGridLines | CXTPChartAxis | protected
m_pInterlacedFillStyle | CXTPChartAxis | protected
m_pLabel | CXTPChartAxis | protected
m_pRange | CXTPChartAxis | protected
m_pScaleTypeMap | CXTPChartAxis | protected
m_pStrips | CXTPChartAxis | protected
m_pTickMarks | CXTPChartAxis | protected
m_pTitle | CXTPChartAxis | protected
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartElement | virtual
Release() | CXTPChartElement | virtual
SetAlignment(XTPChartAxisAlignment nAlignment) | CXTPChartAxis |
SetColor(const CXTPChartColor &color) | CXTPChartAxis |
SetDateTimeScaleUnit(XTPChartAxisDateTimeScaleUnit unit) | CXTPChartAxis |
SetDirectionClockwise(BOOL bDirectionClockwise) | CXTPChartRadarAxisX |
SetGridSpacing(double dGridSpacing) | CXTPChartAxis |
SetGridSpacingAuto(BOOL bGridSpacingAuto) | CXTPChartAxis |
SetIndex(int nIndex) | CXTPChartAxis |
SetInterlaced(BOOL bInterlaced) | CXTPChartAxis |
SetInterlacedColor(const CXTPChartColor &color) | CXTPChartAxis |
SetInterlacedColor2(const CXTPChartColor &color) | CXTPChartAxis |
SetLogarithmic(BOOL bLogarithmic) | CXTPChartAxis |
SetLogarithmicBase(double dLogarithmicBase) | CXTPChartAxis |
SetMinorCount(int nMinorCount) | CXTPChartAxis |
SetReversed(BOOL bRevered) | CXTPChartAxis |
SetThickness(int nThicknes) | CXTPChartAxis |
SetVisible(BOOL bVisible) | CXTPChartAxis |
UpdateRange(CXTPChartDeviceContext *pDC, CXTPChartAxisView *pView) | CXTPChartAxis |
~CXTPChartAxis() | CXTPChartAxis | virtual
~CXTPChartElement() | CXTPChartElement | virtual


Toolkit Pro: XTPDockingPaneTabColorSet2017.h Source File

  • Source
  • DockingPane
  • TabColorSets
XTPDockingPaneTabColorSet2017.h
Go to the documentation of this file.
1
23#if !defined(__XTPDOCKINGPANETABCOLORSET2017_H__)
24# define __XTPDOCKINGPANETABCOLORSET2017_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPDockingPaneTabColorSet2017 : public CXTPDockingPaneTabColorSet2012
39{
40public:
45 CXTPDockingPaneTabColorSet2017();
46
61 virtual void FillHeader(CDC* pDC, CRect rc, CXTPTabManager* pTabManager);
62};
63
64# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
66#endif // !defined(__XTPDOCKINGPANETABCOLORSET2017_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPDockingPaneTabColorSet2012
Helper class used to initialize default colors for a theme from an .INI resource and handle drawing r...
Definition XTPDockingPaneTabColorSet2012.h:39
CXTPDockingPaneTabColorSet2017
Helper class used to initialize default colors for a theme from an .INI resource and handle drawing r...
Definition XTPDockingPaneTabColorSet2017.h:39
CXTPDockingPaneTabColorSet2017::FillHeader
virtual void FillHeader(CDC *pDC, CRect rc, CXTPTabManager *pTabManager)
This member is called to fill the header of the TabClient of the tab manager.
CXTPDockingPaneTabColorSet2017::CXTPDockingPaneTabColorSet2017
CXTPDockingPaneTabColorSet2017()
Default class constructor.
CXTPTabManager
CXTPTabManager is the base class for docking pane tabs, tab control tabs, and MDI client tabs.
Definition XTPTabManager.h:87


Toolkit Pro: Member List

CXTPShadowManager Member List

This is the complete list of members for CXTPShadowManager, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPShadowManager() | CXTPShadowManager |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetHeadPosition(CWnd *pShadowOwner) const | CXTPShadowManager |
GetNext(POSITION &pos) const | CXTPShadowManager |
GetShadowOptions() const | CXTPShadowManager |
IsAlphaShadow() | CXTPShadowManager |
m_bUseSystemSaveBitsStyle | CXTPShadowManager |
OffsetShadow(CWnd *pShadowOwner, CSize szOffset) | CXTPShadowManager |
RemoveShadow(CWnd *pShadowOwner) | CXTPShadowManager |
SetShadow(CRect rcWindow, CWnd *pShadowOwner) | CXTPShadowManager |
SetShadow(CWnd *pShadowOwner, const CRect &rcExclude=CRect(0, 0, 0, 0), int nLevel=0) | CXTPShadowManager |
SetShadowColor(COLORREF clrShadow) | CXTPShadowManager |
SetShadowOptions(int nOptions) | CXTPShadowManager |
~CXTPShadowManager() | CXTPShadowManager |


Toolkit Pro: Member List

CXTPSimpleEvent Member List

This is the complete list of members for CXTPSimpleEvent, including all inherited members.

CXTPSimpleEvent(BOOL bInitialState) | CXTPSimpleEvent | explicit
IsSignaled() const | CXTPSimpleEvent |
Reset() | CXTPSimpleEvent |
Set() | CXTPSimpleEvent |
Wait() | CXTPSimpleEvent |


Toolkit Pro: XTPDockingPaneColorSet.h Source File

  • Source
  • DockingPane
  • ColorSets
XTPDockingPaneColorSet.h
Go to the documentation of this file.
1
23#if !defined(__XTPDOCKINGPANECOLORSET_H__)
24# define __XTPDOCKINGPANECOLORSET_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPDockingPaneColorSet
39{
40public:
45 virtual ~CXTPDockingPaneColorSet();
46
53 virtual void RefreshMetrics(CString strSection) = 0;
54
65 virtual CXTPColorSetCaptionButton& GetButtonColorSet(CXTPDockingPaneCaptionButton* pButton);
66
67 CXTPPaintManagerColor m_clrBorder;
68 CXTPPaintManagerColor m_clrBackground;
69 CXTPPaintManagerColor m_clrCaption;
70 CXTPPaintManagerColor m_clrText;
71 CXTPPaintManagerColor m_clrGripper;
72 CXTPPaintManagerColor m_clrSplitter;
74protected:
75 CXTPColorSetCaptionButton m_csCaptionButtonHot;
76 CXTPColorSetCaptionButton m_csCaptionButtonNormal;
77 CXTPColorSetCaptionButton m_csCaptionButtonPressed;
78};
79
80# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
82#endif // !defined(__XTPDOCKINGPANECOLORSET_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPColorSetCaptionButton
Default theme caption button color set.
Definition XTPTheme.h:40
CXTPDockingPaneCaptionButton
CXTPDockingPaneCaptionButton is a standalone internal class.
Definition XTPDockingPaneCaptionButton.h:38
CXTPDockingPaneColorSet
Helper class used to initialize default colors for a theme from an .INI resource.
Definition XTPDockingPaneColorSet.h:39
CXTPDockingPaneColorSet::RefreshMetrics
virtual void RefreshMetrics(CString strSection)=0
This member function is used to initialize default colors for a theme from an .INI resource.
CXTPDockingPaneColorSet::m_clrCaption
CXTPPaintManagerColor m_clrCaption
Caption color.
Definition XTPDockingPaneColorSet.h:69
CXTPDockingPaneColorSet::m_clrGripper
CXTPPaintManagerColor m_clrGripper
Gripper color.
Definition XTPDockingPaneColorSet.h:71
CXTPDockingPaneColorSet::m_csCaptionButtonNormal
CXTPColorSetCaptionButton m_csCaptionButtonNormal
Normal state caption button colors.
Definition XTPDockingPaneColorSet.h:76
CXTPDockingPaneColorSet::m_clrBackground
CXTPPaintManagerColor m_clrBackground
Background color.
Definition XTPDockingPaneColorSet.h:68
CXTPDockingPaneColorSet::m_clrBorder
CXTPPaintManagerColor m_clrBorder
Border color.
Definition XTPDockingPaneColorSet.h:67
CXTPDockingPaneColorSet::GetButtonColorSet
virtual CXTPColorSetCaptionButton & GetButtonColorSet(CXTPDockingPaneCaptionButton *pButton)
Call this member function to retrieve the state color set for the caption button specified by pButton...
CXTPDockingPaneColorSet::m_clrText
CXTPPaintManagerColor m_clrText
Text color.
Definition XTPDockingPaneColorSet.h:70
CXTPDockingPaneColorSet::m_csCaptionButtonHot
CXTPColorSetCaptionButton m_csCaptionButtonHot
Selected state caption button colors.
Definition XTPDockingPaneColorSet.h:75
CXTPDockingPaneColorSet::~CXTPDockingPaneColorSet
virtual ~CXTPDockingPaneColorSet()
Handles object destruction.
CXTPDockingPaneColorSet::m_csCaptionButtonPressed
CXTPColorSetCaptionButton m_csCaptionButtonPressed
Pressed state caption button colors.
Definition XTPDockingPaneColorSet.h:77
CXTPDockingPaneColorSet::m_clrSplitter
CXTPPaintManagerColor m_clrSplitter
Splitter color.
Definition XTPDockingPaneColorSet.h:72
CXTPPaintManagerColor
The CXTPPaintManagerColor class is used to manage COLORREF values for determining default and applica...
Definition XTPColorManager.h:117


Toolkit Pro: XTPFlowGraphConnection.h Source File

  • Source
  • FlowGraph
XTPFlowGraphConnection.h
Go to the documentation of this file.
1
23#if !defined(__XTPFLOWGRAPHCONNECTION_H__)
24# define __XTPFLOWGRAPHCONNECTION_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPFlowGraphPage;
34class CXTPFlowGraphConnectionPoint;
35class CXTPFlowGraphDrawContext;
36class CXTPFlowGraphNode;
37
38namespace Gdiplus
39{
40class GraphicsPath;
41}
42
48class _XTP_EXT_CLASS CXTPFlowGraphConnection : public CXTPFlowGraphElement
49{
50 DECLARE_SERIAL(CXTPFlowGraphConnection);
51
52public:
57 CXTPFlowGraphConnection();
63 virtual ~CXTPFlowGraphConnection();
64
65public:
72 virtual void SetInputPoint(CXTPFlowGraphConnectionPoint* pPoint);
81 CXTPFlowGraphConnectionPoint* GetInputPoint() const;
82
89 virtual void SetOutputPoint(CXTPFlowGraphConnectionPoint* pPoint);
98 CXTPFlowGraphConnectionPoint* GetOutputPoint() const;
99
111 void SetControlPoint(CPoint pt);
124 CPoint GetControlPoint() const;
125
131 void SetCaption(LPCTSTR lpszCaption);
141 CString GetCaption() const;
142
151 void SetTooltip(LPCTSTR lpszTooltip);
161 CString GetTooltip() const;
162
163 void SetTag(LPCTSTR lpszTag);
164
165 CString GetTag() const;
166
172 void SetColor(COLORREF clr);
179 COLORREF GetColor() const;
180
190 void SetStyle(int nStyle);
200 int GetStyle() const;
201
207 void SetWidth(int nWidth);
214 int GetWidth() const;
215
221 void SetDashed(BOOL bDashed);
229 BOOL GetDashed() const;
230
231public:
238 CRect GetBoundingRect();
246 virtual BOOL PtInRect(POINT pt);
247
248public:
255 CXTPFlowGraphNode* GetInputNode() const;
262 CXTPFlowGraphNode* GetOutputNode() const;
269 CXTPFlowGraphControl* GetControl() const;
276 CXTPFlowGraphPage* GetPage() const;
277
278public:
285 virtual void RecalcLayout(CXTPFlowGraphDrawContext* pDC);
286
287public:
292 void Remove();
297 virtual void OnRemoved();
298
299 void SetPathReversed(BOOL bReversed);
300
301 BOOL IsPathReversed() const;
302
303public:
313 virtual void DoPropExchange(CXTPPropExchange* pPX);
314
315protected:
321 virtual void RestoreConnection();
322
323 int GetConnectionPointIndex(CXTPFlowGraphConnectionPoint* pPoint) const;
324
325protected:
326 CXTPFlowGraphPage* m_pPage;
327 CXTPFlowGraphConnectionPoint* m_pInputPoint;
329 CXTPFlowGraphConnectionPoint* m_pOutputPoint;
331 CXTPFlowGraphConnection* m_pNextVisibleConnection;
333 CPoint m_ptInputPoint;
335 CPoint m_ptOutputPoint;
337 CPoint m_ptControlPoint;
339 CString m_strCaption;
340 CString m_strTooltip;
341 CString m_strTag;
343 COLORREF m_clrConnection;
344 int m_nStyle;
347 int m_nInputId;
348 int m_nOutputId;
350 int m_nInputPointIndex;
351 int m_nOutputPointIndex;
352
353 int m_nInputPointConnectionIndex;
354 int m_nOutputPointConnectionIndex;
355 int m_nConnectionIndex;
356
357 CRect m_rcBoundingRect;
359 Gdiplus::GraphicsPath* m_pPath;
361 BOOL m_bPathReversed;
362 int m_nWidth;
363 BOOL m_bDashed;
364
365 friend class CXTPFlowGraphPaintManager;
366 friend class CXTPFlowGraphConnections;
367 friend class CXTPFlowGraphControl;
368 friend class CXTPFlowGraphPage;
369
370# ifdef _XTP_ACTIVEX
373 DECLARE_DISPATCH_MAP()
374 DECLARE_INTERFACE_MAP()
375
376 DECLARE_OLETYPELIB_EX(CXTPFlowGraphConnection)
377
378 afx_msg void OleSetCaption(LPCTSTR lpszCaption);
379 afx_msg BSTR OleGetCaption();
380 afx_msg void OleSetTooltip(LPCTSTR lpszTooltip);
381 afx_msg BSTR OleGetTooltip();
382
383 afx_msg void OleSetTag(LPCTSTR lpszTag);
384 afx_msg BSTR OleGetTag();
385
386 afx_msg void OleSetColor(OLE_COLOR clr);
387 afx_msg OLE_COLOR OleGetColor();
388 afx_msg void OleSetStyle(int nStyle);
389 afx_msg int OleGetStyle();
390 afx_msg LPDISPATCH OleGetOutputPoint();
391 afx_msg void OleSetOutputPoint(LPDISPATCH lpDisp);
392 afx_msg LPDISPATCH OleGetInputPoint();
393 afx_msg void OleSetInputPoint(LPDISPATCH lpDisp);
394 afx_msg void OleSetWidth(int nWidth);
395 afx_msg int OleGetWidth();
396 afx_msg void OleSetDashed(BOOL bDashed);
397 afx_msg BOOL OleGetDashed();
398
400# endif
401};
402
403AFX_INLINE CXTPFlowGraphConnectionPoint* CXTPFlowGraphConnection::GetInputPoint() const
404{
405 return m_pInputPoint;
406}
407
408AFX_INLINE CXTPFlowGraphConnectionPoint* CXTPFlowGraphConnection::GetOutputPoint() const
409{
410 return m_pOutputPoint;
411}
412AFX_INLINE CString CXTPFlowGraphConnection::GetCaption() const
413{
414 return m_strCaption;
415}
416AFX_INLINE void CXTPFlowGraphConnection::SetTooltip(LPCTSTR lpszTooltip)
417{
418 m_strTooltip = lpszTooltip;
419}
420AFX_INLINE CString CXTPFlowGraphConnection::GetTooltip() const
421{
422 return m_strTooltip;
423}
424AFX_INLINE void CXTPFlowGraphConnection::SetTag(LPCTSTR lpszTag)
425{
426 m_strTag = lpszTag;
427}
428AFX_INLINE CString CXTPFlowGraphConnection::GetTag() const
429{
430 return m_strTag;
431}
432AFX_INLINE void CXTPFlowGraphConnection::SetColor(COLORREF clr)
433{
434 m_clrConnection = clr;
435}
436AFX_INLINE COLORREF CXTPFlowGraphConnection::GetColor() const
437{
438 return m_clrConnection;
439}
440AFX_INLINE void CXTPFlowGraphConnection::SetStyle(int nStyle)
441{
442 m_nStyle = nStyle;
443 OnGraphChanged();
444}
445AFX_INLINE int CXTPFlowGraphConnection::GetStyle() const
446{
447 return m_nStyle;
448}
449
450AFX_INLINE void CXTPFlowGraphConnection::SetPathReversed(BOOL bReversed)
451{
452 m_bPathReversed = bReversed;
453}
454
455AFX_INLINE BOOL CXTPFlowGraphConnection::IsPathReversed() const
456{
457 return m_bPathReversed;
458}
459
460AFX_INLINE CPoint CXTPFlowGraphConnection::GetControlPoint() const
461{
462 return m_ptControlPoint;
463}
464AFX_INLINE CXTPFlowGraphPage* CXTPFlowGraphConnection::GetPage() const
465{
466 return m_pPage;
467}
468
469AFX_INLINE void CXTPFlowGraphConnection::SetWidth(int nWidth)
470{
471 m_nWidth = nWidth;
472}
473AFX_INLINE int CXTPFlowGraphConnection::GetWidth() const
474{
475 return m_nWidth;
476}
477
478AFX_INLINE void CXTPFlowGraphConnection::SetDashed(BOOL bDashed)
479{
480 m_bDashed = bDashed;
481}
482AFX_INLINE BOOL CXTPFlowGraphConnection::GetDashed() const
483{
484 return m_bDashed;
485}
487# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
488#endif //#if !defined(__XTPFLOWGRAPHCONNECTION_H__)
pPoint
const CPoint * pPoint
return 0 or xtpCalendarHitTestDayExpandButton
Definition XTPCalendarThemeOffice2007.h:150
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPFlowGraphConnection
Represents a connection.
Definition XTPFlowGraphConnection.h:49
CXTPFlowGraphConnection::SetWidth
void SetWidth(int nWidth)
Sets the width for the connector line.
Definition XTPFlowGraphConnection.h:469
CXTPFlowGraphConnection::m_strTag
CString m_strTag
A tag property to define a connection.
Definition XTPFlowGraphConnection.h:341
CXTPFlowGraphConnection::DoPropExchange
virtual void DoPropExchange(CXTPPropExchange *pPX)
Call this member function to store/load a connection using the specified data object.
CXTPFlowGraphConnection::Remove
void Remove()
Remove/delete this connection from its parent node.
CXTPFlowGraphConnection::m_strTooltip
CString m_strTooltip
Tooltip text for the item.
Definition XTPFlowGraphConnection.h:340
CXTPFlowGraphConnection::SetOutputPoint
virtual void SetOutputPoint(CXTPFlowGraphConnectionPoint *pPoint)
Sets the output connection point that this connection line is connected to.
CXTPFlowGraphConnection::m_clrConnection
COLORREF m_clrConnection
Color of the connection.
Definition XTPFlowGraphConnection.h:343
CXTPFlowGraphConnection::RecalcLayout
virtual void RecalcLayout(CXTPFlowGraphDrawContext *pDC)
Call this method to recalculate the size and layout of the connection.
CXTPFlowGraphConnection::SetTooltip
void SetTooltip(LPCTSTR lpszTooltip)
Sets the tooltip for this connection.
Definition XTPFlowGraphConnection.h:416
CXTPFlowGraphConnection::OnRemoved
virtual void OnRemoved()
This method is called when the connection is removed.
CXTPFlowGraphConnection::SetStyle
void SetStyle(int nStyle)
Sets the style for the connector.
Definition XTPFlowGraphConnection.h:440
CXTPFlowGraphConnection::GetWidth
int GetWidth() const
Gets the width of the connector line.
Definition XTPFlowGraphConnection.h:473
CXTPFlowGraphConnection::GetOutputPoint
CXTPFlowGraphConnectionPoint * GetOutputPoint() const
Gets the output connection point that this connection line is connected to.
Definition XTPFlowGraphConnection.h:408
CXTPFlowGraphConnection::GetControl
CXTPFlowGraphControl * GetControl() const
Gets a reference to the parent FlowGraph control.
CXTPFlowGraphConnection::m_pPath
Gdiplus::GraphicsPath * m_pPath
Path to the GDI Plus graphics used to draw the conneciton.
Definition XTPFlowGraphConnection.h:359
CXTPFlowGraphConnection::RestoreConnection
virtual void RestoreConnection()
Used internally to restore the connection when loaded from a resource.
CXTPFlowGraphConnection::~CXTPFlowGraphConnection
virtual ~CXTPFlowGraphConnection()
Destroys a CXTPFlowGraphConnection object, handles cleanup and deallocation.
CXTPFlowGraphConnection::m_ptInputPoint
CPoint m_ptInputPoint
Stores the coordinates of the Input connection point (if any), also is used internally for drag/drop.
Definition XTPFlowGraphConnection.h:333
CXTPFlowGraphConnection::SetDashed
void SetDashed(BOOL bDashed)
Enables/disables dashed style for the connector line.
Definition XTPFlowGraphConnection.h:478
CXTPFlowGraphConnection::GetBoundingRect
CRect GetBoundingRect()
Gets the bounding rectangle for this element.
CXTPFlowGraphConnection::m_ptControlPoint
CPoint m_ptControlPoint
Middle point for the connection.
Definition XTPFlowGraphConnection.h:337
CXTPFlowGraphConnection::m_ptOutputPoint
CPoint m_ptOutputPoint
Stores the coordinates of the Output connection point (if any), also is used internally for drag/drop...
Definition XTPFlowGraphConnection.h:335
CXTPFlowGraphConnection::GetStyle
int GetStyle() const
Gets the style of the connector.
Definition XTPFlowGraphConnection.h:445
CXTPFlowGraphConnection::SetCaption
void SetCaption(LPCTSTR lpszCaption)
Sets the caption for the connection.
CXTPFlowGraphConnection::m_pPage
CXTPFlowGraphPage * m_pPage
The page that this connection belongs to.
Definition XTPFlowGraphConnection.h:326
CXTPFlowGraphConnection::m_nOutputId
int m_nOutputId
Used internally to store the ID of the Output connection point.
Definition XTPFlowGraphConnection.h:348
CXTPFlowGraphConnection::GetOutputNode
CXTPFlowGraphNode * GetOutputNode() const
Gets the output Node that this connection line is connected to.
CXTPFlowGraphConnection::GetInputPoint
CXTPFlowGraphConnectionPoint * GetInputPoint() const
Gets the input connection point that this connection line is connected to.
Definition XTPFlowGraphConnection.h:403
CXTPFlowGraphConnection::m_pInputPoint
CXTPFlowGraphConnectionPoint * m_pInputPoint
The input ConnectionPoint that this connection line is connected to.
Definition XTPFlowGraphConnection.h:327
CXTPFlowGraphConnection::GetCaption
CString GetCaption() const
Gets the caption of the connection.
Definition XTPFlowGraphConnection.h:412
CXTPFlowGraphConnection::GetDashed
BOOL GetDashed() const
Determines if dashed style is enabled/disabled for the connector line.
Definition XTPFlowGraphConnection.h:482
CXTPFlowGraphConnection::m_rcBoundingRect
CRect m_rcBoundingRect
The bounding rectangle for this element.
Definition XTPFlowGraphConnection.h:357
CXTPFlowGraphConnection::GetPage
CXTPFlowGraphPage * GetPage() const
Gets a reference to the page that this connection belongs to.
Definition XTPFlowGraphConnection.h:464
CXTPFlowGraphConnection::m_nInputId
int m_nInputId
Used internally to store the ID of the Input connection point.
Definition XTPFlowGraphConnection.h:347
CXTPFlowGraphConnection::m_pNextVisibleConnection
CXTPFlowGraphConnection * m_pNextVisibleConnection
Reference to the next visible connection.
Definition XTPFlowGraphConnection.h:331
CXTPFlowGraphConnection::CXTPFlowGraphConnection
CXTPFlowGraphConnection()
Constructs a CXTPFlowGraphConnection object.
CXTPFlowGraphConnection::m_pOutputPoint
CXTPFlowGraphConnectionPoint * m_pOutputPoint
The output ConnectionPoint that this connection line is connected to.
Definition XTPFlowGraphConnection.h:329
CXTPFlowGraphConnection::m_nStyle
int m_nStyle
Style of the connection.
Definition XTPFlowGraphConnection.h:344
CXTPFlowGraphConnection::GetInputNode
CXTPFlowGraphNode * GetInputNode() const
Gets the input Node that this connection line is connected to.
CXTPFlowGraphConnection::SetInputPoint
virtual void SetInputPoint(CXTPFlowGraphConnectionPoint *pPoint)
Sets the input connection point that this connection line is connected to.
CXTPFlowGraphConnection::GetTooltip
CString GetTooltip() const
Gets the tooltip of this connection.
Definition XTPFlowGraphConnection.h:420
CXTPFlowGraphConnection::SetControlPoint
void SetControlPoint(CPoint pt)
Sets the middle point of the connection (this is also what happens when a connection is dragged by th...
CXTPFlowGraphConnection::GetColor
COLORREF GetColor() const
Gets the color of the connection line.
Definition XTPFlowGraphConnection.h:436
CXTPFlowGraphConnection::SetColor
void SetColor(COLORREF clr)
Sets the color for the connection line.
Definition XTPFlowGraphConnection.h:432
CXTPFlowGraphConnection::PtInRect
virtual BOOL PtInRect(POINT pt)
Determines if the specified point is within the connection.
CXTPFlowGraphConnection::GetControlPoint
CPoint GetControlPoint() const
Gets the middle point of the connection (this is also what happens when a connection is dragged by th...
Definition XTPFlowGraphConnection.h:460
CXTPFlowGraphConnection::m_strCaption
CString m_strCaption
The caption of the connection.
Definition XTPFlowGraphConnection.h:339
CXTPFlowGraphConnectionPoint
Represents a connection point for a node.
Definition XTPFlowGraphConnectionPoint.h:46
CXTPFlowGraphConnections
Represents a collection of connections for a Node.
Definition XTPFlowGraphConnections.h:41
CXTPFlowGraphControl
Flow Graph Control.
Definition XTPFlowGraphControl.h:173
CXTPFlowGraphElement
Base class for all elements in the flow graph.
Definition XTPFlowGraphElement.h:46
CXTPFlowGraphElement::OnGraphChanged
void OnGraphChanged()
This method is called when the flow graph layout is changed.
CXTPFlowGraphElement::GetCaption
virtual CString GetCaption() const =0
Gets the caption displayed for this element.
CXTPFlowGraphElement::GetPage
virtual CXTPFlowGraphPage * GetPage() const =0
Retrieves a reference to the flow graph page that this element is displayed on.
CXTPFlowGraphNode
Represents a Node object.
Definition XTPFlowGraphNode.h:116
CXTPFlowGraphPage
Represents a page in the flow graph.
Definition XTPFlowGraphPage.h:54
CXTPFlowGraphPaintManager
Handles most of the drawing activities of the flow graph.
Definition XTPFlowGraphPaintManager.h:80
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72


Toolkit Pro: Member List

CXTPCalendarUtils Member List

This is the complete list of members for CXTPCalendarUtils, including all inherited members.

_ResetDate_dbl(double dblDT) | CXTPCalendarUtils | static
_ResetTime_dbl(double dblDT) | CXTPCalendarUtils | static
_RoundDateTime_dbl(double dblDT) | CXTPCalendarUtils | static
CalcDayOfMonth(COleDateTime &rdtDate, int nWhichDay, int nWhichDayMask) | CXTPCalendarUtils | static
FormatTimeDuration(int nMinutes, BOOL bRoundly) | CXTPCalendarUtils | static
GetActiveLCID() | CXTPCalendarUtils | static
GetCurrentTime() | CXTPCalendarUtils | static
GetDateFormat(CONST SYSTEMTIME *lpDate, LPCTSTR lpFormat) | CXTPCalendarUtils | static
GetDateFormat(CONST COleDateTime &dtDate, LPCTSTR lpFormat) | CXTPCalendarUtils | static
GetDayOfWeekCount(int nDayOfWeekMask) | CXTPCalendarUtils | static
GetDayOfWeekIndex(int nDayOfWeekMask) | CXTPCalendarUtils | static
GetDayOfWeekLocaleStringId(int nWeekDay) | CXTPCalendarUtils | static
GetDayOfWeekMask(int nWeekDay) | CXTPCalendarUtils | static
GetDiff_Months(const COleDateTime &dt1, const COleDateTime &dt2) | CXTPCalendarUtils | static
GetDurationMinutes(const COleDateTime &dtStart, const COleDateTime &dtEnd, BOOL bAllDayEvent) | CXTPCalendarUtils | static
GetEventPeriodDays(const COleDateTime &dtStart, const COleDateTime &dtEnd) | CXTPCalendarUtils | static
GetFirstWeekOfYearDays() | CXTPCalendarUtils | static
GetLocaleLong(LCTYPE LCType) | CXTPCalendarUtils | static
GetLocaleString(LCTYPE LCType, int nMaxLength=128) | CXTPCalendarUtils | static
GetMaxHeightFont(CArray< CFont *, CFont * > &arFonts, CDC *pDC, int *pnMaxHeight=NULL) | CXTPCalendarUtils | static
GetMaxMonthDay(COleDateTime dtDate) | CXTPCalendarUtils | static
GetTimeFormat(CONST SYSTEMTIME *lpTime, LPCTSTR lpFormat) | CXTPCalendarUtils | static
GetTimeFormat(CONST COleDateTime &dtTime, LPCTSTR lpFormat) | CXTPCalendarUtils | static
GetTimeFormat(int nHour, int nMinutes, LPCTSTR lpFormat) | CXTPCalendarUtils | static
GetTimeFormatString_HrMin() | CXTPCalendarUtils | static
GetWeekOfYear(COleDateTime dtDate, int nFirstDayOfWeekIndex=1) | CXTPCalendarUtils | static
IsEqual(const COleDateTime &dt1, const COleDateTime &dt2, BOOL bOneSecTimeDiff=FALSE) | CXTPCalendarUtils | static
IsFormatChar(TCHAR t) | CXTPCalendarUtils | static
IsWin9x() | CXTPCalendarUtils | static
IsZeroTime(const COleDateTime &dtDateTime) | CXTPCalendarUtils | static
LoadString(UINT nIDResource) | CXTPCalendarUtils | static
LoadString2(CString &rstrString, UINT nIDResource) | CXTPCalendarUtils | static
MakeDaysOfWeekMask_Mo_(int nEndWDay) | CXTPCalendarUtils | static
Minutes2Span(int nMinutes) | CXTPCalendarUtils | static
OverrideTimeProvider(ITimeProvider *pTimeProvider) | CXTPCalendarUtils | static
ParceTimeDuration_min(LPCTSTR pcszTimeDuration) | CXTPCalendarUtils | static
ParceTimeString_min(LPCTSTR pcszTime_HrMin) | CXTPCalendarUtils | static
RemoveFormatPart(CString strFormat, LPCTSTR lpszRemove) | CXTPCalendarUtils | static
RemoveFormatPart(CString strFormat, TCHAR cRemove) | CXTPCalendarUtils | static
ResetDate(const COleDateTime &dtDateTime) | CXTPCalendarUtils | static
ResetTime(const COleDateTime &dtDateTime) | CXTPCalendarUtils | static
ResetTime(const DATE dtDateTime) | CXTPCalendarUtils | static
ResetTimeProvider() | CXTPCalendarUtils | static
RetriveEventEndDate(const CXTPCalendarEvent *pEvent) | CXTPCalendarUtils | static
RetriveEventEndDate(const COleDateTime &dtStart, const COleDateTime &dtEnd) | CXTPCalendarUtils | static
SetTime_235959(const COleDateTime &dtDateTime) | CXTPCalendarUtils | static
ShiftDate_Month(COleDateTime &refDate, int nMonthCount) | CXTPCalendarUtils | static
ShiftDate_Month(COleDateTime &refDate, int nMonthCount, int nMonthDay) | CXTPCalendarUtils | static
ShiftDate_Year(COleDateTime &refDate, int nYearCount) | CXTPCalendarUtils | static
ShiftDate_Year(COleDateTime &refDate, int nYearCount, int nMonthDay) | CXTPCalendarUtils | static
ShiftDateToWeekBegin(COleDateTime dtDate, int nFirstDayOfWeekIndex=1) | CXTPCalendarUtils | static
StripFormat(CString &strFormat, int nIndex, int nRemove) | CXTPCalendarUtils | static
SystemTimeToTzSpecificLocalTime(const TIME_ZONE_INFORMATION *pTZI, const SYSTEMTIME *pUTime, SYSTEMTIME *pTzTime) | CXTPCalendarUtils | static
TextPrepareSingleline(CString &rstrString) | CXTPCalendarUtils | static
TrackMouseEvent(DWORD dwFlags, HWND hwndTrack, DWORD dwHoverTime=HOVER_DEFAULT) | CXTPCalendarUtils | static
UpdateDate(const COleDateTime &dtTime, const COleDateTime &dtDate) | CXTPCalendarUtils | static
UpdateDate(const COleDateTime &dtTime, int nYear, int nMonth, int nDay) | CXTPCalendarUtils | static
UpdateMonthDay(COleDateTime &refDate, int nMonthDay) | CXTPCalendarUtils | static
UpdateTime(const COleDateTime &dtDate, int nHour, int nMinutes, int nSeconds) | CXTPCalendarUtils | static
UpdateTime(const COleDateTime &dtDate, const COleDateTime &dtTime) | CXTPCalendarUtils | static


Toolkit Pro: Member List

CXTPChartTextPainterBase Member List

This is the complete list of members for CXTPChartTextPainterBase, including all inherited members.

CalculateBounds()=0 | CXTPChartTextPainterBase | protectedpure virtual
CXTPChartTextPainterBase(CXTPChartDeviceContext *pDC, const CXTPChartString &text, CXTPChartTextElement *pTextProvider) | CXTPChartTextPainterBase | protected
GetRoundedBounds() | CXTPChartTextPainterBase |
m_nHeight | CXTPChartTextPainterBase | protected
m_nWidth | CXTPChartTextPainterBase | protected
m_pTextProvider | CXTPChartTextPainterBase | protected
m_rcBounds | CXTPChartTextPainterBase | protected
m_rcRoundedBounds | CXTPChartTextPainterBase | protected
m_strText | CXTPChartTextPainterBase | protected
m_szTextSize | CXTPChartTextPainterBase | protected
~CXTPChartTextPainterBase() | CXTPChartTextPainterBase | virtual


Toolkit Pro: Member List

CXTPCalendarOffice2013Theme Member List

This is the complete list of members for CXTPCalendarOffice2013Theme, including all inherited members.

_GetAtGrow_BusyStatusBrushValue(int eBusyStatus, BOOL bGrow) | CXTPCalendarPaintManager | protected
_Init() | CXTPCalendarPaintManager | virtual
AddViewPart(CXTPCalendarViewPart *pPart) | CXTPCalendarPaintManager | protected
AdjustTimeFont(CDC *pDC, CRect rcCell) | CXTPCalendarPaintManager |
BEGIN_VIEW_PART(ControlPart, XTPCalendarViewPart) virtual void RefreshMetrics() | CXTPCalendarPaintManager |
CalcEventSize(CDC *c, CXTPCalendarTimeLineViewEvent *pViewEvent) | CXTPCalendarPaintManager | virtual
CalcWidth(CDC *pDC, const CString &strHour, const CString &strMin, int nHourHeight, int &nWidth) | CXTPCalendarPaintManager |
CXTPCalendarOffice2000Theme() | CXTPCalendarOffice2000Theme |
CXTPCalendarOffice2013Theme() | CXTPCalendarOffice2013Theme |
CXTPCalendarPaintManager() | CXTPCalendarPaintManager |
CXTPCmdTarget() | CXTPCmdTarget |
DrawBigHourCell(CDC *pDC, CRect rc, CString strHour, CString strMin, int nRowPerHour, BOOL bFillBackground=TRUE, BOOL bCurrentTime=FALSE) | CXTPCalendarPaintManager | virtual
DrawBitmap(CImageList *pImageList, CDC *pDC, CRect rcView, int iIcon, UINT uFlags=0) | CXTPCalendarPaintManager | virtual
DrawBitmap(UINT nIDResource, CDC *pDC, CRect rcBitmap) | CXTPCalendarPaintManager | virtual
DrawBorder(CDC *pDC, CRect rcView, CXTPCalendarWeekViewEvent *pWeekViewEvent) | CXTPCalendarPaintManager | virtual
DrawBusyStatus(CDC *pDC, CRect &rcRect, int eBusyStatus) | CXTPCalendarPaintManager | virtual
DrawBusyStatus(CDC *pDC, CRgn &rgnBusy, int eBusyStatus) | CXTPCalendarPaintManager | virtual
DrawClock(CDC *pDC, COleDateTime dtClockTime, CRect rcView, COLORREF clrBackground, XTPCalendarClockAlignFlags cafAlign) | CXTPCalendarPaintManager | virtual
DrawDayHeader(CDC *pDC, CRect rcDay, int nHeaderHeight, CString strHeader, BOOL bIsCurrent=FALSE, BOOL bIsSelected=FALSE) | CXTPCalendarPaintManager | virtual
DrawEvent(CDC *pDC, const CRect &rcEvents, CXTPCalendarTimeLineViewEvent *pViewEvent) | CXTPCalendarPaintManager | virtual
DrawExpandSigns(CDC *pDC, CXTPCalendarDayView *pView, const CRect &rcTSHours) | CXTPCalendarPaintManager | virtual
DrawGroup(CDC *pDC, const CRect &rcRect, CXTPCalendarTimeLineViewGroup *pGroup) | CXTPCalendarPaintManager | virtual
DrawHeader(CDC *pDC, CRect &rcHeader, BOOL bIsSelected, BOOL bIsCurrent, const CXTPPaintManagerColorGradient &grclr, COLORREF clrUnderLineHdr) | CXTPCalendarOffice2013Theme | virtual
CXTPCalendarOffice2000Theme::DrawHeader(CDC *pDC, CRect &rcHeader, BOOL bIsSelected, BOOL bIsCurrent) | CXTPCalendarPaintManager | virtual
DrawHorizontalLine(CDC *pDC, int xPos, int yPos, int cx) | CXTPCalendarPaintManager | virtual
DrawHourCell(CDC *pDC, CRect rc, CString strText, BOOL bFillBackground=TRUE, BOOL bCurrentTime=FALSE) | CXTPCalendarPaintManager | virtual
DrawIconChar(CDC *pDC, CRect rc, TCHAR ch) | CXTPCalendarPaintManager | virtual
DrawIcons(CDC *pDC, CXTPCalendarViewEvent *pViewEvent) | CXTPCalendarPaintManager | virtual
DrawLine(CDC *pDC, int xPos, int yPos, int cx, int cy) | CXTPCalendarPaintManager | virtual
DrawNowLine(CDC *pDC, CXTPCalendarDayView *pView, CRect rc, int y, BOOL bDrawBk=FALSE) | CXTPCalendarPaintManager | virtual
DrawNowLine(CDC *pDC, CXTPCalendarDayView *pView, CXTPCalendarDayViewTimeScale *pScale, CRect rc, int y, BOOL bDrawBk=FALSE) | CXTPCalendarPaintManager | virtual
DrawShadow(CDC *pDC, const CRect &rcRect) | CXTPCalendarPaintManager | virtual
DrawSubj(CDC *pDC, CXTPCalendarWeekViewEvent *pWeekViewEvent) | CXTPCalendarPaintManager | virtual
DrawTimes(CDC *pDC, CXTPCalendarWeekViewEvent *pWeekViewEvent) | CXTPCalendarPaintManager | virtual
DrawVerticalLine(CDC *pDC, int xPos, int yPos, int cy) | CXTPCalendarPaintManager | virtual
EnableTheme(BOOL bEnableTheme) | CXTPCalendarPaintManager |
END_VIEW_PART(ControlPart) BEGIN_VIEW_PART(DayViewTimeScaleHeaderPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewTimeScaleHeaderPart) BEGIN_VIEW_PART(DayViewTimeScaleCellPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewTimeScaleCellPart) BEGIN_VIEW_PART(DayViewCellPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewCellPart) BEGIN_VIEW_PART(DayViewWorkCellPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewWorkCellPart) BEGIN_VIEW_PART(DayViewNonworkCellPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewNonworkCellPart) BEGIN_VIEW_PART(DayMonthViewHeaderPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayMonthViewHeaderPart) BEGIN_VIEW_PART(DayViewHeaderPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewHeaderPart) BEGIN_VIEW_PART(DayViewGroupHeaderPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewGroupHeaderPart) BEGIN_VIEW_PART(DayViewAllDayEventsPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewAllDayEventsPart) BEGIN_VIEW_PART(DayViewAllDayEventScrollIconsPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewAllDayEventScrollIconsPart) BEGIN_VIEW_PART(DayViewEventPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewEventPart) BEGIN_VIEW_PART(MonthViewGridPart | CXTPCalendarPaintManager |
END_VIEW_PART(MonthViewGridPart) BEGIN_VIEW_PART(MonthViewHeaderPart | CXTPCalendarPaintManager |
END_VIEW_PART(MonthViewHeaderPart) BEGIN_VIEW_PART(MonthViewEventPart | CXTPCalendarPaintManager |
END_VIEW_PART(MonthViewEventPart) BEGIN_VIEW_PART(WeekViewPart | CXTPCalendarPaintManager |
END_VIEW_PART(WeekViewPart) BEGIN_VIEW_PART(WeekViewEventPart | CXTPCalendarPaintManager |
END_VIEW_PART(WeekViewEventPart) BEGIN_VIEW_PART(TimeLineViewTimeScalePart_Day | CXTPCalendarPaintManager |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAskItemTextFlags() const | CXTPCalendarPaintManager |
GetBusyStatusBrush(int nBusyStatus) | CXTPCalendarPaintManager |
GetClockSize() | CXTPCalendarPaintManager | virtual
GetCurrentSystemTheme() | CXTPCalendarPaintManager |
GetEventBackColor(CXTPCalendarEvent *pEvent) | CXTPCalendarOffice2013Theme | virtual
CXTPCalendarOffice2000Theme::GetEventBackColor(CXTPCalendarEvent *pEvent, COLORREF crDefault) | CXTPCalendarPaintManager | virtual
GetEventEdgeColor(CXTPCalendarEvent *pEvent) | CXTPCalendarOffice2013Theme | virtual
GetExpandSignSize() | CXTPCalendarPaintManager | virtual
GetPaintTheme() const | CXTPCalendarPaintManager | virtual
GetParams(CXTPCalendarDayViewGroup *pViewGroup, XTP_CALENDAR_DAYVIEWCELL_PARAMS *rCellParams) | CXTPCalendarPaintManager | virtual
idxExpandSignDown enum value | CXTPCalendarPaintManager | protected
idxExpandSignUp enum value | CXTPCalendarPaintManager | protected
idxMeeting enum value | CXTPCalendarPaintManager | protected
idxPrivate enum value | CXTPCalendarPaintManager | protected
idxRecurrenceException enum value | CXTPCalendarPaintManager | protected
idxRecurrenceOccurrence enum value | CXTPCalendarPaintManager | protected
idxReminder enum value | CXTPCalendarPaintManager | protected
InitBusyStatusDefaultColors() | CXTPCalendarPaintManager | protectedvirtual
IsThemeEnabled() | CXTPCalendarPaintManager |
m_arBusyStatusBrushes | CXTPCalendarPaintManager | protected
m_arStartCol | CXTPCalendarPaintManager |
m_arStartRow | CXTPCalendarPaintManager |
m_bEnableTheme | CXTPCalendarPaintManager | protected
m_bmpElsewherePattern | CXTPCalendarPaintManager | protected
m_bmpTentativePattern | CXTPCalendarPaintManager | protected
m_bShowMinutes | CXTPCalendarPaintManager |
m_clr3DShadow | CXTPCalendarPaintManager |
m_clrBackground | CXTPCalendarPaintManager |
m_clrBackground2 | CXTPCalendarPaintManager |
m_clrBackgroundSlave | CXTPCalendarPaintManager |
m_clrBorders | CXTPCalendarPaintManager |
m_clrButtonFace | CXTPCalendarPaintManager |
m_clrButtonFaceText | CXTPCalendarPaintManager |
m_clrClassicUnderline | CXTPCalendarPaintManager |
m_clrEventBar | CXTPCalendarPaintManager |
m_clrEventBarLine | CXTPCalendarPaintManager |
m_clrEventBorderLine | CXTPCalendarPaintManager |
m_clrHeaderBottomLine | CXTPCalendarPaintManager |
m_clrHighlight | CXTPCalendarPaintManager |
m_clrHour | CXTPCalendarPaintManager |
m_clrSelectedBackground | CXTPCalendarPaintManager |
m_clrSelectedText | CXTPCalendarPaintManager |
m_clrShadow | CXTPCalendarPaintManager |
m_clrText | CXTPCalendarPaintManager |
m_clrTextHighLightColor | CXTPCalendarPaintManager |
m_clrTextNormalColor | CXTPCalendarPaintManager |
m_clrTimeScaleBackground | CXTPCalendarPaintManager |
m_clrTimeScaleHightlite | CXTPCalendarPaintManager |
m_clrTimeScaleText | CXTPCalendarPaintManager |
m_clrUnderLineHdr | CXTPCalendarPaintManager | protected
m_clrWeekendBackground | CXTPCalendarPaintManager |
m_clrWindow | CXTPCalendarPaintManager |
m_clrWindowText | CXTPCalendarPaintManager |
m_CurrSystemTheme | CXTPCalendarPaintManager | protected
m_dwAskItemTextFlags | CXTPCalendarPaintManager | protected
m_fntTimeText | CXTPCalendarPaintManager |
m_grclrClassicSelDay | CXTPCalendarPaintManager |
m_grclrToday | CXTPCalendarPaintManager |
m_lstViewParts | CXTPCalendarPaintManager | protected
m_nHourWidth | CXTPCalendarPaintManager |
m_nMinWidth | CXTPCalendarPaintManager |
m_nPaintTheme | CXTPCalendarPaintManager | protected
m_pControl | CXTPCalendarPaintManager | protected
m_pExpandSigns | CXTPCalendarPaintManager | protected
m_pGlyphs | CXTPCalendarPaintManager | protected
m_pGlyphsFont | CXTPCalendarPaintManager | protected
m_PrintPageWidth | CXTPCalendarPaintManager |
m_szClockRect | CXTPCalendarPaintManager | protected
m_xtpBrushElsewhere | CXTPCalendarPaintManager | protected
m_xtpBrushTentative | CXTPCalendarPaintManager | protected
OnDraw(CDC *pDC, CXTPCalendarDayView *pView, CRect rc, CString strText) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarDayViewGroup *pViewGroup, CRect rc, const XTP_CALENDAR_DAYVIEWCELL_PARAMS &cellParams) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarDayViewDay *pViewDay, CRect rc, CString strText) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarDayViewGroup *pViewGroup, CRect rc, CString strText) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarDayViewGroup *pViewGroup, CRect rc, BOOL bSelected) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarDayViewGroup *pViewGroup, BOOL bDrawUp, BOOL bDrawDown, const CRect &rcIconUp, const CRect &rcIconDown, BOOL bHighlightUp, BOOL bHighlightDown) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarDayViewEvent *pViewEvent) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarMonthView *pMonthView, CRect rc, int nCollIndex, CString strText) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarWeekView *pWeekView) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarWeekViewEvent *pWeekViewEvent) | CXTPCalendarPaintManager | virtual
OnDrawDayDate(CDC *pDC, CRect rc, BOOL bToday, BOOL bSelected, BOOL bFirstMonthDay, CString strText) | CXTPCalendarPaintManager | virtual
OnDrawEvent(CDC *pDC, CXTPCalendarMonthViewEvent *pViewEvent) | CXTPCalendarPaintManager | virtual
OnDrawGrid(CDC *pDC, CXTPCalendarMonthView *pMonthView) | CXTPCalendarPaintManager | virtual
RefreshMetrics() | CXTPCalendarOffice2013Theme | virtual
SetAskItemTextFlags(DWORD dwFlags) | CXTPCalendarPaintManager |
SetBusyStatusBrush(int nBusyStatus, CBrush *pBrush, BOOL bAutodeleteBrush) | CXTPCalendarPaintManager |
SetControl(CXTPCalendarControl *pControl) | CXTPCalendarPaintManager | virtual
SetPaintTheme(XTPCalendarTheme ePaintTheme) | CXTPCalendarPaintManager | virtual
UpdateEventCategoriesDefaultColors() | CXTPCalendarOffice2013Theme | virtual
UpdateEventLabelsDefaultColors() | CXTPCalendarOffice2013Theme | virtual
UpdateGlyphs() | CXTPCalendarOffice2013Theme | virtual
XTPEnumEventGlyphs enum name | CXTPCalendarPaintManager | protected
XTPEnumExpandSigns enum name | CXTPCalendarPaintManager | protected
~CTimeLineViewPart() | CXTPCalendarPaintManager | virtual
~CXTPCalendarOffice2000Theme() | CXTPCalendarOffice2000Theme | virtual
~CXTPCalendarOffice2013Theme() | CXTPCalendarOffice2013Theme | virtual
~CXTPCalendarPaintManager() | CXTPCalendarPaintManager | virtual


Toolkit Pro: Member List

CXTPPropertyGridToolTip Member List

This is the complete list of members for CXTPPropertyGridToolTip, including all inherited members.

Activate(BOOL bActive, CXTPPropertyGridItem *pItem, BOOL bValuePart) | CXTPPropertyGridToolTip |
Create(CXTPPropertyGridView *pParentWnd) | CXTPPropertyGridToolTip |
CXTPPropertyGridToolTip() | CXTPPropertyGridToolTip |
m_pGrid | CXTPPropertyGridToolTip | protected
m_xtpFont | CXTPPropertyGridToolTip | protected


Toolkit Pro: XTPGridThemeVisualStudio2022.h Source File

  • Source
  • GridControl
  • Themes
XTPGridThemeVisualStudio2022.h
Go to the documentation of this file.
1
23#if !defined(__XTPGRIDTHEMEVISUALSTUDIO2022_H__)
24# define __XTPGRIDTHEMEVISUALSTUDIO2022_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPGridThemeVisualStudio2022 : public CXTPGridThemeOffice2013
39{
40public:
45 CXTPGridThemeVisualStudio2022();
46
52 virtual void RefreshMetrics();
53};
55# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
56#endif //#if !defined(__XTPGRIDTHEMEVISUALSTUDIO2022_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPGridThemeOffice2013
CXTPGridThemeOffice2013 is a CXTPGridPaintManager derived class that represents an Office 2013 style ...
Definition XTPGridThemeOffice2013.h:39
CXTPGridThemeVisualStudio2022
CXTPGridThemeVisualStudio2022 is a CXTPGridThemeOffice2013 derived class that represents a Visual Stu...
Definition XTPGridThemeVisualStudio2022.h:39
CXTPGridThemeVisualStudio2022::CXTPGridThemeVisualStudio2022
CXTPGridThemeVisualStudio2022()
Default paint manager constructor, handles properties initialization.
CXTPGridThemeVisualStudio2022::RefreshMetrics
virtual void RefreshMetrics()
This method is called to refresh the visual metrics of the Grid control.


Toolkit Pro: XTPDockingPaneThemeVisualStudio2015.h Source File

  • Source
  • DockingPane
  • Themes
XTPDockingPaneThemeVisualStudio2015.h
Go to the documentation of this file.
1
23#if !defined(__XTPDOCKINGPANETHEMEVISUALSTUDIO2015_H__)
24# define __XTPDOCKINGPANETHEMEVISUALSTUDIO2015_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPDockingPaneVisualStudio2015Theme
39 : public CXTPDockingPaneVisualStudio2012Theme
40{
41public:
46 CXTPDockingPaneVisualStudio2015Theme();
47
53 virtual ~CXTPDockingPaneVisualStudio2015Theme();
54
60 virtual void RefreshMetrics();
61
68 virtual void DrawSplitter(CDC* pDC, CXTPDockingPaneSplitterWnd* pSplitter);
69
79 virtual void DrawAutoHidePanel(CDC* pDC, CRect rc, XTPDockingPaneDirection direction);
80
81protected:
91 virtual void DrawTitleBar(CDC* pDC, CXTPDockingPaneBase* pPane, CRect rc, BOOL bVertical);
92
93 COLORREF m_clrCaptionBorder;
94};
95
96# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
98#endif // !defined(__XTPDOCKINGPANETHEMEVISUALSTUDIO2015_H__)
XTPDisableNoisyWarnings.h
XTPDockingPaneDirection
XTPDockingPaneDirection
Docking direction enumeration.
Definition XTPDockingPaneDefines.h:51
XTPEnableNoisyWarnings.h
CXTPDockingPaneBase
CXTPDockingPaneBase is a standalone class.
Definition XTPDockingPaneBase.h:69
CXTPDockingPaneSplitterWnd
CXTPDockingPaneSplitterWnd is a CWnd derived class.
Definition XTPDockingPaneSplitterContainer.h:42
CXTPDockingPaneVisualStudio2012Theme
CXTPDockingPaneVisualStudio2012Theme is used to define drawing routines specific to a Visual Studio 2...
Definition XTPDockingPaneThemeVisualStudio2012.h:41
CXTPDockingPaneVisualStudio2015Theme
CXTPDockingPaneVisualStudio2015Theme is used to define drawing routines specific to a Visual Studio 2...
Definition XTPDockingPaneThemeVisualStudio2015.h:40
CXTPDockingPaneVisualStudio2015Theme::DrawTitleBar
virtual void DrawTitleBar(CDC *pDC, CXTPDockingPaneBase *pPane, CRect rc, BOOL bVertical)
This member function is called to draw a title bar for the docking pane.
CXTPDockingPaneVisualStudio2015Theme::DrawSplitter
virtual void DrawSplitter(CDC *pDC, CXTPDockingPaneSplitterWnd *pSplitter)
Override this method to draw a splitter.
CXTPDockingPaneVisualStudio2015Theme::DrawAutoHidePanel
virtual void DrawAutoHidePanel(CDC *pDC, CRect rc, XTPDockingPaneDirection direction)
This method is called by the framework to draw the docking pane auto-hide panel background and splitt...
CXTPDockingPaneVisualStudio2015Theme::CXTPDockingPaneVisualStudio2015Theme
CXTPDockingPaneVisualStudio2015Theme()
Constructs a CXTPDockingPaneVisualStudio2015Theme object.
CXTPDockingPaneVisualStudio2015Theme::RefreshMetrics
virtual void RefreshMetrics()
This member function is used to initialize default colors for a theme from an .INI resource.
CXTPDockingPaneVisualStudio2015Theme::m_clrCaptionBorder
COLORREF m_clrCaptionBorder
Caption border color.
Definition XTPDockingPaneThemeVisualStudio2015.h:93
CXTPDockingPaneVisualStudio2015Theme::~CXTPDockingPaneVisualStudio2015Theme
virtual ~CXTPDockingPaneVisualStudio2015Theme()
Destroys a CXTPDockingPaneVisualStudio2015Theme object, handles cleanup and deallocation.


Toolkit Pro: XTPRibbonBackstageViewThemeVisualStudio2022.h Source File

  • Source
  • Ribbon
  • Backstage
XTPRibbonBackstageViewThemeVisualStudio2022.h
Go to the documentation of this file.
1
23#if !defined(__XTPRIBBONBACKSTAGEVIEWTHEMEVISUALSTUDIO2022_H__)
24# define __XTPRIBBONBACKSTAGEVIEWTHEMEVISUALSTUDIO2022_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class _XTP_EXT_CLASS CXTPRibbonBackstageViewThemeVisualStudio2022
34 : public CXTPRibbonBackstageViewThemeOffice2013
35{
36public:
37 CXTPRibbonBackstageViewThemeVisualStudio2022();
38 ~CXTPRibbonBackstageViewThemeVisualStudio2022();
39};
40
41# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
43#endif // !defined(__XTPRIBBONBACKSTAGEVIEWTHEMEVISUALSTUDIO2022_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h


Toolkit Pro: Member List

CXTPGridThemeNativeWindows11 Member List

This is the complete list of members for CXTPGridThemeNativeWindows11, including all inherited members.

CalcColumnHeight(CDC *pDC, CXTPGridColumn *pColumn, int nTotalWidth=0) | CXTPGridPaintManager | protectedvirtual
CalculateRowHeight(CDC *pDC, const CString &strText, int nMaxWidth, BOOL bWordBreak=TRUE) | CXTPGridPaintManager | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPGridPaintManager() | CXTPGridPaintManager |
CXTPGridThemeNativeWindows11() | CXTPGridThemeNativeWindows11 |
CXTPGridThemeOffice2013() | CXTPGridThemeOffice2013 |
DrawBitmap(CDC *pDC, CXTPGridControl *pControl, CRect rcColumn, int iImage) | CXTPGridPaintManager | virtual
DrawCollapsedBitmap(CDC *pDC, const CXTPGridRow *pRow, CRect &rcBitmap) | CXTPGridThemeOffice2013 | virtual
DrawColumn(CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn, BOOL bDrawExternal=FALSE, int nShadowWidth=0) | CXTPGridPaintManager | virtual
DrawColumnBackground(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, BOOL &bColumnPressed, BOOL &bDraggingFromHeader, CXTPGridHeader *pHeader=NULL) | CXTPGridThemeOffice2013 | virtual
DrawColumnFooter(CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn) | CXTPGridPaintManager | virtual
DrawColumnFooterDivider(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn) | CXTPGridPaintManager | virtual
DrawColumnIcon(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, CRect rcIcon, int iIcon) | CXTPGridPaintManager | virtual
DrawColumnText(CDC *pDC, CRect rcText, CString strCaption, int nHeaderAlignment, BOOL bIsHeader, BOOL bColumnPressed) | CXTPGridThemeOffice2013 | virtual
DrawConnector(CDC *pDC, CPoint ptFrom, CPoint ptTo) | CXTPGridPaintManager |
DrawFocusedRow(CDC *pDC, CRect rcRow) | CXTPGridThemeOffice2013 | virtual
DrawFreezeColsDivider(CDC *pDC, const CRect &rc, CXTPGridControl *pControl, CXTPGridRow *pRow=NULL) | CXTPGridPaintManager | virtual
DrawGlyph(CDC *pDC, CRect rcColumn, int iImage) | CXTPGridPaintManager | virtual
DrawGrid(CDC *pDC, XTPGridOrientation orientation, CRect rcGrid) | CXTPGridPaintManager | virtual
DrawGridPattern(CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush) | CXTPGridPaintManager | protectedvirtual
DrawGridPattern(CDC *pDC, CXTPBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush) | CXTPGridPaintManager | protectedvirtual
DrawGridPattern(CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr) | CXTPGridPaintManager | protectedvirtual
DrawGroupRow(CDC *pDC, CXTPGridGroupRow *pRow, CRect rcRow, XTP_GRIDRECORDITEM_METRICS *pMetrics) | CXTPGridThemeOffice2013 | virtual
DrawHorizontalLine(CDC *pDC, int xPos, int yPos, int cx, COLORREF clr) | CXTPGridPaintManager |
DrawInplaceButton(CDC *pDC, CXTPGridInplaceButton *pButton) | CXTPGridPaintManager | virtual
DrawInplaceButtonFrame(CDC *pDC, CXTPGridInplaceButton *pButton) | CXTPGridPaintManager | protectedvirtual
DrawInplaceButtonIcon(CDC *pDC, CXTPGridInplaceButton *pButton) | CXTPGridPaintManager | protectedvirtual
DrawInplaceComboButton(CDC *pDC, CRect *pRc) | CXTPGridPaintManager | virtual
DrawInplaceExpandButton(CDC *pDC, CRect *pRc) | CXTPGridPaintManager | virtual
DrawInplaceSpinButton(CDC *pDC, CRect *pRc) | CXTPGridPaintManager | virtual
DrawItemBitmap(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CRect &rcItem, int nImage) | CXTPGridPaintManager | virtual
DrawItemCaption(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics) | CXTPGridPaintManager | virtual
DrawItemControl(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CXTPGridRecordItemControl *pControl, CRect &rcItem) | CXTPGridPaintManager | virtual
DrawLink(int *pnCurrDrawPos, XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CXTPGridHyperlink *pHyperlink, CString strText, CRect rcLink, int nFlag, BOOL bTrim=FALSE) | CXTPGridPaintManager | protectedvirtual
DrawMultiLineText(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, BOOL bWordBreak=TRUE) | CXTPGridPaintManager | protectedvirtual
DrawNoGroupByText(CDC *pDC, CRect rcItem) | CXTPGridPaintManager | virtual
DrawRowNumber(CDC *pDC, CRect rcNumber, CXTPGridRow *pRow) | CXTPGridPaintManager | virtual
DrawSectionDivider(CDC *pDC, const CRect &rc, XTPGridSectionDividerPosition dividerPosition, XTPGridSectionDividerStyle dividerStyle, CXTPPaintManagerColor dividerColor) | CXTPGridPaintManager |
DrawShellIcon(CDC *pDC, CRect rcColumn, int iImage) | CXTPGridPaintManager | virtual
DrawSingleLineText(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nStartPos, int nEndPos, int nActualWidth) | CXTPGridPaintManager | protectedvirtual
DrawString(int *pnCurrDrawPos, CDC *pDC, const CString &strDraw, CRect rcDraw, UINT nFormat) | CXTPGridPaintManager | protectedvirtual
DrawTextLine(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nFlag, int &nCharCounter, int &nHyperlinkCounter) | CXTPGridPaintManager | protectedvirtual
DrawTreeStructure(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CRect rcItem, CSize sizeGlyph) | CXTPGridPaintManager | virtual
DrawTriangle(CDC *pDC, CRect rcTriangle, BOOL bToDown, BOOL bDraggingFromHeader, int nShadowWidth, BOOL bColumnPressed) | CXTPGridThemeOffice2013 | virtual
DrawVerticalLine(CDC *pDC, int xPos, int yPos, int cy, COLORREF clr) | CXTPGridPaintManager |
DrawVerticalTimeLineMarker(CDC *pDC, int xPos, CXTPGridControl *pControl, COLORREF color=RGB(0, 255, 0)) | CXTPGridPaintManager | virtual
EnablePreviewMode(BOOL bIsPreviewMode) | CXTPGridPaintManager |
FillFooter(CDC *pDC, CRect rcFooter) | CXTPGridPaintManager | virtual
FillGroupByControl(CDC *pDC, CRect &rcGroupBy) | CXTPGridPaintManager | virtual
FillGroupRowMetrics(CXTPGridGroupRow *pRow, XTP_GRIDRECORDITEM_METRICS *pMetrics, BOOL bPrinting) | CXTPGridThemeOffice2013 | virtual
FillHeaderControl(CDC *pDC, CRect rcHeader) | CXTPGridPaintManager | virtual
FillIndent(CDC *pDC, CRect rcRow) | CXTPGridPaintManager | virtual
FillItemShade(CDC *pDC, CRect rcItem) | CXTPGridPaintManager | virtual
FillRow(CDC *pDC, CXTPGridRow *pRow, CRect rcRow) | CXTPGridPaintManager | virtual
FindRowAdjacentToMerged(const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, BOOL bUpward) | CXTPGridPaintManager |
FindRowAdjacentToMergedEx(const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, int &nAdjRowIndex, BOOL bUpward) | CXTPGridPaintManager |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetColumnOffice2007CustomThemeBaseColor() const | CXTPGridPaintManager |
GetColumnStyle() const | CXTPGridPaintManager |
GetControlBackColor(CXTPGridControl *pControl) | CXTPGridPaintManager | virtual
GetFooterHeight(CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0) | CXTPGridPaintManager | virtual
GetFreezeColsDividerStyle() const | CXTPGridPaintManager |
GetGlyphs() const | CXTPGridPaintManager |
GetHeaderHeight() | CXTPGridPaintManager | virtual
GetHeaderHeight(CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0) | CXTPGridPaintManager | virtual
GetItemHeight(XTP_GRIDRECORDITEM_DRAWARGS &drawArgs, int nWidth) | CXTPGridPaintManager |
GetMaxPreviewLines() | CXTPGridPaintManager |
GetPreviewItemHeight(CDC *pDC, CXTPGridRow *pRow, int nWidth, int nHeight) | CXTPGridPaintManager | virtual
GetPreviewLinesCount(CDC *pDC, CRect &rcText, const CString &strText) | CXTPGridPaintManager |
GetRowHeight(CDC *pDC, CXTPGridRow *pRow) | CXTPGridThemeOffice2013 | virtual
GetRowHeight(CDC *pDC, CXTPGridRow *pRow, int nTotalWidth) | CXTPGridThemeOffice2013 | virtual
GetRowHeightEx(CDC *pDC, CXTPGridRow *pRow, int nTotalWidth, const BOOL firstLevel=TRUE) | CXTPGridPaintManager |
GetSectionDividerHeight(XTPGridFixedRowsDividerStyle dividerStyle) | CXTPGridPaintManager |
GetTextFont() | CXTPGridPaintManager |
IsColumHotTrackingEnabled() const | CXTPGridPaintManager | virtual
IsColumnPlusMinusSign() const | CXTPGridPaintManager |
IsColumnWidthWYSIWYG() const | CXTPGridPaintManager |
IsDrawGridForEmptySpace() const | CXTPGridPaintManager |
IsFixedInplaceButtonHeight() const | CXTPGridPaintManager |
IsFixedRowHeight() const | CXTPGridPaintManager |
IsGridVisible(BOOL bVertical) const | CXTPGridPaintManager |
IsGridVisible(XTPGridOrientation orientation) const | CXTPGridPaintManager |
IsLastColumnWidthWYSIWYG() const | CXTPGridPaintManager |
IsPreviewMode() const | CXTPGridPaintManager |
IsPrintGroupRowIcon() const | CXTPGridPaintManager |
IsShowWYSIWYGMarkers() const | CXTPGridPaintManager |
IsUseDropMarker() const | CXTPGridPaintManager |
LoadGlyphs() | CXTPGridThemeOffice2013 | virtual
m_arStartCol | CXTPGridPaintManager |
m_bAllowMergeCells | CXTPGridPaintManager |
m_bBaseTreeIndent | CXTPGridPaintManager |
m_bCleanTooltip | CXTPGridPaintManager |
m_bColumnPlusMinusSign | CXTPGridPaintManager | protected
m_bColumnWidthWYSIWYG | CXTPGridPaintManager | protected
m_bCompactText | CXTPGridPaintManager |
m_bDrawGridForEmptySpace | CXTPGridPaintManager | protected
m_bFixedInplaceButtonHeight | CXTPGridPaintManager | protected
m_bFixedRowHeight | CXTPGridPaintManager | protected
m_bForceDynamicMarkupForCell | CXTPGridPaintManager |
m_bForceShowDropMarker | CXTPGridPaintManager |
m_bForceShowTooltip | CXTPGridPaintManager |
m_bGrayIfDisable | CXTPGridPaintManager |
m_bGroupRowTextBold | CXTPGridPaintManager |
m_bHideSelection | CXTPGridPaintManager |
m_bHotTracking | CXTPGridPaintManager |
m_bInvertColumnOnClick | CXTPGridPaintManager |
m_bIsPreviewMode | CXTPGridPaintManager | protected
m_bLastColumnWidthWYSIWYG | CXTPGridPaintManager | protected
m_bMakeUpper | CXTPGridPaintManager |
m_bMoveScrollbarOnFixedColumnsIndent | CXTPGridPaintManager |
m_bPrintGroupRowIcon | CXTPGridPaintManager | protected
m_bPrintPageRectangle | CXTPGridPaintManager |
m_bPrintSortTriangle | CXTPGridPaintManager |
m_bPrintVirtualPageNumber | CXTPGridPaintManager |
m_bPrintWatermark | CXTPGridPaintManager |
m_bRecOrRowNum | CXTPGridPaintManager |
m_bRevertAlignment | CXTPGridPaintManager |
m_bShadeGroupHeadings | CXTPGridPaintManager |
m_bShadeSortColumn | CXTPGridPaintManager |
m_bShowLockIcon | CXTPGridPaintManager |
m_bShowNonActiveInPlaceButton | CXTPGridPaintManager |
m_bShowWYSIWYGMarkers | CXTPGridPaintManager | protected
m_bSortTriangleOffsetFromRight | CXTPGridPaintManager |
m_bThemedInplaceButtons | CXTPGridPaintManager |
m_bUseAlternativeBackground | CXTPGridPaintManager |
m_bUseDropMarker | CXTPGridPaintManager |
m_bUseEditTextAlignment | CXTPGridPaintManager |
m_bUseGroupRowSelectionState | CXTPGridPaintManager |
m_bUseShellIcon | CXTPGridPaintManager |
m_clrAlternativeBackground | CXTPGridPaintManager |
m_clrBoldText | CXTPGridPaintManager |
m_clrBoldTextHighlight | CXTPGridPaintManager |
m_clrBtnFace | CXTPGridPaintManager |
m_clrBtnFacePressed | CXTPGridPaintManager |
m_clrBtnText | CXTPGridPaintManager |
m_clrCaptionText | CXTPGridPaintManager |
m_clrCaptionTextPressed | CXTPGridPaintManager |
m_clrColumnOffice2007CustomTheme | CXTPGridPaintManager |
m_clrConnector | CXTPGridPaintManager |
m_clrControlBack | CXTPGridPaintManager |
m_clrControlDark | CXTPGridPaintManager |
m_clrControlLightLight | CXTPGridPaintManager |
m_clrDisableBitmapDarkest | CXTPGridPaintManager |
m_clrDisableBitmapLightest | CXTPGridPaintManager |
m_clrFormulaSubSum | CXTPGridPaintManager |
m_clrFormulaSum | CXTPGridPaintManager |
m_clrFreezeColsDivider | CXTPGridPaintManager |
m_clrGlyph | CXTPGridThemeOffice2013 |
m_clrGlyphBorder | CXTPGridThemeOffice2013 |
m_clrGlyphContract | CXTPGridThemeOffice2013 |
m_clrGlyphExpand | CXTPGridThemeOffice2013 |
m_clrGlyphHighlight | CXTPGridThemeOffice2013 |
m_clrGradientColumnSeparator | CXTPGridPaintManager |
m_clrGradientColumnShadow | CXTPGridPaintManager |
m_clrGroupBoxBack | CXTPGridPaintManager |
m_clrGroupRowText | CXTPGridPaintManager |
m_clrGroupShadeBack | CXTPGridPaintManager |
m_clrGroupShadeBorder | CXTPGridPaintManager |
m_clrGroupShadeText | CXTPGridPaintManager |
m_clrHeaderControl | CXTPGridPaintManager |
m_clrHighlight | CXTPGridPaintManager |
m_clrHighlightText | CXTPGridPaintManager |
m_clrHotDivider | CXTPGridPaintManager |
m_clrIndentControl | CXTPGridPaintManager |
m_clrItemShade | CXTPGridPaintManager |
m_clrPreviewText | CXTPGridPaintManager |
m_clrSelectedRow | CXTPGridPaintManager |
m_clrSelectedRowText | CXTPGridPaintManager |
m_clrWindowText | CXTPGridPaintManager |
m_columnStyle | CXTPGridPaintManager | protected
m_crlNoGroupByText | CXTPGridPaintManager |
m_grcGradientColumn | CXTPGridPaintManager |
m_grcGradientColumnHot | CXTPGridPaintManager |
m_grcGradientColumnPushed | CXTPGridPaintManager |
m_iRecOrRowStart | CXTPGridPaintManager |
m_nBaseParentRecordIndent | CXTPGridPaintManager |
m_nFixedColumnsIndent | CXTPGridPaintManager |
m_nFooterHeight | CXTPGridPaintManager | protected
m_nFreezeColsDividerStyle | CXTPGridPaintManager | protected
m_nGridLineStylePreviousH | CXTPGridPaintManager | protected
m_nGridLineStylePreviousV | CXTPGridPaintManager | protected
m_nGroupGridLineHeight | CXTPGridPaintManager | protected
m_nGroupGridLineStyle | CXTPGridPaintManager | protected
m_nHeaderHeight | CXTPGridPaintManager | protected
m_nMaxPreviewLines | CXTPGridPaintManager | protected
m_nResizingWidth | CXTPGridPaintManager | protected
m_nRowHeight | CXTPGridPaintManager | protected
m_nRowHeightDefault | CXTPGridPaintManager |
m_nTextIndentForGroupRowsWithNoIcon | CXTPGridPaintManager |
m_nTreeColumnLineLength | CXTPGridPaintManager |
m_nTreeIndent | CXTPGridPaintManager |
m_nTreeStructureStyle | CXTPGridPaintManager |
m_nTreeTextIndent | CXTPGridPaintManager |
m_nTreeTextIndentGroupRow | CXTPGridPaintManager |
m_nTreeTextIndentRowChildren | CXTPGridPaintManager |
m_nTreeTextIndentRowParent | CXTPGridPaintManager |
m_pControl | CXTPGridPaintManager | protected
m_pGlyphs | CXTPGridPaintManager | protected
m_pHyperlinkHoverStyle | CXTPGridPaintManager |
m_pHyperlinkStyle | CXTPGridPaintManager |
m_pMarkupUIElement_NoGroupBy | CXTPGridPaintManager | protected
m_PrintPageWidth | CXTPGridPaintManager |
m_rcPreviewIndent | CXTPGridPaintManager |
m_RecordNumberWidth | CXTPGridPaintManager |
m_strCollapse | CXTPGridPaintManager |
m_strDecreasing | CXTPGridPaintManager |
m_strExpand | CXTPGridPaintManager |
m_strIncreasing | CXTPGridPaintManager |
m_strMarkupUIElement_NoGroupBy | CXTPGridPaintManager | protected
m_strNoFieldsAvailable | CXTPGridPaintManager |
m_strNoGroupBy | CXTPGridPaintManager |
m_strNoItems | CXTPGridPaintManager |
m_strSortBy | CXTPGridPaintManager |
m_szGlyph | CXTPGridPaintManager | protected
m_themeButton | CXTPGridPaintManager | protected
m_themeCombo | CXTPGridPaintManager | protected
m_themeHeader | CXTPGridPaintManager | protected
m_themeSpin | CXTPGridPaintManager | protected
m_treeStructureStyle | CXTPGridPaintManager |
m_xtpBrushGroupGridLineStyle | CXTPGridPaintManager | protected
m_xtpBrushHorizontalGrid | CXTPGridPaintManager | protected
m_xtpBrushTreeStructure | CXTPGridPaintManager | protected
m_xtpBrushVeriticalGrid | CXTPGridPaintManager | protected
m_xtpFontBoldText | CXTPGridPaintManager |
m_xtpFontCaption | CXTPGridPaintManager |
m_xtpFontPreview | CXTPGridPaintManager |
m_xtpFontText | CXTPGridPaintManager |
OnDrawAction(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs) | CXTPGridPaintManager | virtual
RecalcTotalHightOfMergedRows(CXTPGridColumns *pColumns, CDC *pDC, CXTPGridRow *pRow, int nRowHeight, int nTotalWidth) | CXTPGridPaintManager |
RefreshMetrics() | CXTPGridThemeNativeWindows11 | virtual
SetCaptionFont(LOGFONT &lf) | CXTPGridPaintManager |
SetColumnOffice2007CustomThemeBaseColor(COLORREF clrBaseColor) | CXTPGridPaintManager |
SetColumnPlusMinusSign(BOOL bDraw) | CXTPGridPaintManager |
SetColumnStyle(XTPGridColumnStyle columnStyle) | CXTPGridPaintManager |
SetColumnWidthWYSIWYG(BOOL bColumnWidthWYSIWYG) | CXTPGridPaintManager |
SetDrawGridForEmptySpace(BOOL bDrawGrid) | CXTPGridPaintManager |
SetFixedRowHeight(BOOL bFixedRowHeight) | CXTPGridPaintManager |
SetFreezeColsDividerStyle(int nStyle) | CXTPGridPaintManager |
SetGridControl(CXTPGridControl *pControl) | CXTPGridPaintManager | virtual
SetHeaderHeight(int nHeight) | CXTPGridPaintManager | virtual
SetInplaceButtonHeight(BOOL bFixedInplaceButtonHeight) | CXTPGridPaintManager |
SetLastColumnWidthWYSIWYG(BOOL bColumnWidthWYSIWYG) | CXTPGridPaintManager |
SetMaxPreviewLines(int nMaxLines) | CXTPGridPaintManager |
SetPreviewIndent(int nLeft, int nTop, int nRight, int nBottom) | CXTPGridPaintManager |
SetPrintGroupRowIcon(BOOL bDraw) | CXTPGridPaintManager |
SetTextFont(LOGFONT &lf) | CXTPGridPaintManager |
ShowWYSIWYGMarkers(BOOL bSet) | CXTPGridPaintManager |
~CXTPGridPaintManager() | CXTPGridPaintManager | virtual


Toolkit Pro: XTPChartElementView.h Source File

  • Source
  • Chart
XTPChartElementView.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTELEMENTVIEW_H__)
24# define __XTPCHARTELEMENTVIEW_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartDeviceCommand;
34class CXTPChartDeviceContext;
35class CXTPChartContainer;
36
46class _XTP_EXT_CLASS CXTPChartElementView : public CXTPChartObject
47{
48 DECLARE_DYNAMIC(CXTPChartElementView);
49
50public:
57 CXTPChartElementView(CXTPChartElementView* pParentView);
58
66 CXTPChartElementView(CXTPChartElementView* pParentView, BOOL bAddToParent);
67
74 CXTPChartElementView(CXTPChartContainer* pContainer);
75
76protected:
81 virtual ~CXTPChartElementView();
82
83public:
92 int GetCount() const;
93
101 CXTPChartElementView* GetAt(int nIndex) const;
102
120 virtual CXTPChartDeviceCommand* CreateDeviceCommand(CXTPChartDeviceContext* pDC);
121
129 CXTPChartElementView* GetParentView() const;
130
138 CXTPChartElementView* AddChildView(CXTPChartElementView* pChildView);
139
152 CXTPChartElementView** GetChildren();
153
161 CRect GetBounds() const;
162
173 CRect GetBounds(BOOL bIncludingChildren) const;
174
175public:
177 virtual void OnMouseMove(UINT nFlags, CPoint point);
178 virtual void OnLButtonDown(UINT nFlags, CPoint point);
179 virtual void OnLButtonUp(UINT nFlags, CPoint point);
180 virtual BOOL OnSetCursor(CPoint point);
183public:
184 void Release();
185
186private:
187 void Initialize(CXTPChartElementView* pParentView, BOOL bAddToParent);
188
189protected:
190 CArray<CXTPChartElementView*, CXTPChartElementView*> m_arrChildren;
192 CXTPChartElementView* m_pParentView;
193 CXTPChartContainer* m_pContainer;
194 CRect m_rcBounds;
195};
196
197AFX_INLINE int CXTPChartElementView::GetCount() const
198{
199 return (int)m_arrChildren.GetSize();
200}
201AFX_INLINE CXTPChartElementView* CXTPChartElementView::GetAt(int nIndex) const
202{
203 return nIndex >= 0 && nIndex < m_arrChildren.GetSize() ? m_arrChildren.GetAt(nIndex) : NULL;
204}
205AFX_INLINE CXTPChartElementView* CXTPChartElementView::GetParentView() const
206{
207 return m_pParentView;
208}
209AFX_INLINE CXTPChartElementView** CXTPChartElementView::GetChildren()
210{
211 return m_arrChildren.GetData();
212}
213AFX_INLINE CRect CXTPChartElementView::GetBounds() const
214{
215 return m_rcBounds;
216}
218# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
219#endif //#if !defined(__XTPCHARTELEMENTVIEW_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartContainer
This class represents the chart container.
Definition XTPChartElement.h:232
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartElementView
This class represents the view of a chart element.
Definition XTPChartElementView.h:47
CXTPChartElementView::GetCount
int GetCount() const
Call this function to get the number of child views associated with this view.
Definition XTPChartElementView.h:197
CXTPChartElementView::GetAt
CXTPChartElementView * GetAt(int nIndex) const
Call this function to get a child view at a particular index.
Definition XTPChartElementView.h:201
CXTPChartElementView::GetBounds
CRect GetBounds() const
Obtains viewed object's bound rectangle.
Definition XTPChartElementView.h:213
CXTPChartElementView::GetChildren
CXTPChartElementView ** GetChildren()
Provides access to the collection of children elements owned by the view.
Definition XTPChartElementView.h:209
CXTPChartElementView::m_arrChildren
CArray< CXTPChartElementView *, CXTPChartElementView * > m_arrChildren
The child view collection.
Definition XTPChartElementView.h:190
CXTPChartElementView::CXTPChartElementView
CXTPChartElementView(CXTPChartElementView *pParentView, BOOL bAddToParent)
Constructs a CXTPChartElementView object.
CXTPChartElementView::CreateDeviceCommand
virtual CXTPChartDeviceCommand * CreateDeviceCommand(CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
CXTPChartElementView::m_pContainer
CXTPChartContainer * m_pContainer
The parent container.
Definition XTPChartElementView.h:193
CXTPChartElementView::~CXTPChartElementView
virtual ~CXTPChartElementView()
Destroys a CXTPChartElementView object, handles cleanup.
CXTPChartElementView::m_pParentView
CXTPChartElementView * m_pParentView
The parent view.
Definition XTPChartElementView.h:192
CXTPChartElementView::CXTPChartElementView
CXTPChartElementView(CXTPChartElementView *pParentView)
Constructs a CXTPChartElementView object.
CXTPChartElementView::CXTPChartElementView
CXTPChartElementView(CXTPChartContainer *pContainer)
Constructs a CXTPChartElementView object.
CXTPChartElementView::GetBounds
CRect GetBounds(BOOL bIncludingChildren) const
Obtains viewed object's bound rectangle.
CXTPChartElementView::m_rcBounds
CRect m_rcBounds
Bounding rectangle.
Definition XTPChartElementView.h:194
CXTPChartElementView::GetParentView
CXTPChartElementView * GetParentView() const
Call this function to get the parent view.
Definition XTPChartElementView.h:205
CXTPChartElementView::AddChildView
CXTPChartElementView * AddChildView(CXTPChartElementView *pChildView)
Call this function to add a child view to the current view.
CXTPChartObject
A base class for all chart objects.
Definition XTPChartElement.h:61


Toolkit Pro: XTPChartScatterLineSeriesStyle.h Source File

  • Source
  • Chart
  • Styles
  • Line
XTPChartScatterLineSeriesStyle.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTSCATTERLINESERIESSTYLE_H__)
24# define __XTPCHARTSCATTERLINESERIESSTYLE_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartSeriesView;
34class CXTPChartLineStyle;
35
46class _XTP_EXT_CLASS CXTPChartScatterLineSeriesStyle : public CXTPChartLineSeriesStyle
47{
49 DECLARE_SERIAL(CXTPChartScatterLineSeriesStyle)
51public:
56 CXTPChartScatterLineSeriesStyle();
57
62 virtual ~CXTPChartScatterLineSeriesStyle();
63
64protected:
75 virtual CXTPChartSeriesView* CreateView(CXTPChartSeries* pSeries,
76 CXTPChartDiagramView* pDiagramView);
77
78# ifdef _XTP_ACTIVEX
79public:
81 DECLARE_DISPATCH_MAP()
82 DECLARE_INTERFACE_MAP()
83 DECLARE_OLETYPELIB_EX(CXTPChartScatterLineSeriesStyle);
84 DECLARE_OLECREATE_EX(CXTPChartScatterLineSeriesStyle)
86# endif
87};
89# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
90#endif //#if !defined(__XTPCHARTSCATTERLINESERIESSTYLE_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartDiagramView
This class represents the view of a chart diagram, which is a kind of CXTPChartElementView.
Definition XTPChartDiagramView.h:49
CXTPChartLineSeriesStyle
This class represents a line series style, which is a kind of CXTPChartPointSeriesStyle.
Definition XTPChartLineSeriesStyle.h:47
CXTPChartLineStyle
This class represents a chart line style, which is a kind of CXTPCmdTarget.
Definition XTPChartLineStyle.h:43
CXTPChartScatterLineSeriesStyle
This class represents a line series style, which is a kind of CXTPChartPointSeriesStyle.
Definition XTPChartScatterLineSeriesStyle.h:47
CXTPChartScatterLineSeriesStyle::CXTPChartScatterLineSeriesStyle
CXTPChartScatterLineSeriesStyle()
Constructs a CXTPChartScatterLineSeriesStyle object.
CXTPChartScatterLineSeriesStyle::CreateView
virtual CXTPChartSeriesView * CreateView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Call this function to create a view of the line series.
CXTPChartScatterLineSeriesStyle::~CXTPChartScatterLineSeriesStyle
virtual ~CXTPChartScatterLineSeriesStyle()
Destroys a CXTPChartScatterLineSeriesStyle object, handles cleanup.
CXTPChartSeries
This class represents a series in the chart, which is a kind of CXTPChartElement.
Definition XTPChartSeries.h:50


Toolkit Pro: XTPDockingPaneThemeVisualStudio2005.h Source File

  • Source
  • DockingPane
  • Themes
XTPDockingPaneThemeVisualStudio2005.h
Go to the documentation of this file.
1
23#if !defined(__XTPDOCKINGPANETHEMEVISUALSTUDIO2005_H__)
24# define __XTPDOCKINGPANETHEMEVISUALSTUDIO2005_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
41class _XTP_EXT_CLASS CXTPDockingPaneVisualStudio2005Theme
42 : public CXTPDockingPaneVisualStudio2005Beta2Theme
43{
44public:
49 CXTPDockingPaneVisualStudio2005Theme();
50};
51
52# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
54#endif // !defined(__XTPDOCKINGPANETHEMEVISUALSTUDIO2005_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPDockingPaneVisualStudio2005Beta2Theme
CXTPDockingPaneVisualStudio2005Beta2Theme is CXTPDockingPaneVisualStudio2005Beta1Theme derived class ...
Definition XTPDockingPaneThemeVisualStudio2005Beta2.h:43
CXTPDockingPaneVisualStudio2005Theme
CXTPDockingPaneVisualStudio2005Theme is a CXTPDockingPaneVisualStudio2005Beta2Theme derived class tha...
Definition XTPDockingPaneThemeVisualStudio2005.h:43
CXTPDockingPaneVisualStudio2005Theme::CXTPDockingPaneVisualStudio2005Theme
CXTPDockingPaneVisualStudio2005Theme()
Constructs a CXTPDockingPaneVisualStudio2005Theme object.


Toolkit Pro: Member List

CXTPCommandBarEditCtrl Member List

This is the complete list of members for CXTPCommandBarEditCtrl, including all inherited members.

CreateEdit(DWORD dwStyle, CWnd *pParentWnd) | CXTPCommandBarEditCtrl | virtual
CXTPCommandBarEditCtrl() | CXTPCommandBarEditCtrl |
GetRichEditContext() | CXTPCommandBarEditCtrl | protected
GetWindowTextEx(CString &rString) | CXTPCommandBarEditCtrl |
IsCommandEnabled(UINT nID) | CXTPCommandBarEditCtrl | protected
IsDialogCode(UINT nChar, LPARAM lParam) | CXTPCommandBarEditCtrl |
IsImeMode() const | CXTPCommandBarEditCtrl |
m_bComposited | CXTPCommandBarEditCtrl | protected
m_bIgonoreEditChanged | CXTPCommandBarEditCtrl | protected
m_bImeMode | CXTPCommandBarEditCtrl | protected
OnCmdMsg(UINT nID, int nCode, void *pExtra, AFX_CMDHANDLERINFO *pHandlerInfo) | CXTPCommandBarEditCtrl | virtual
OnCommand(WPARAM wParam, LPARAM lParam) | CXTPCommandBarEditCtrl | virtual
SetWindowTextEx(LPCTSTR lpszString) | CXTPCommandBarEditCtrl |
ShowContextMenu(CXTPControl *pControl, CPoint point) | CXTPCommandBarEditCtrl | virtual


Toolkit Pro: Member List

XTPRIBBON_HEADER_COLOR Member List

This is the complete list of members for XTPRIBBON_HEADER_COLOR, including all inherited members.

clrBack | XTPRIBBON_HEADER_COLOR
clrEdge | XTPRIBBON_HEADER_COLOR
clrText | XTPRIBBON_HEADER_COLOR


Toolkit Pro: XTPChartPieSeriesLabelBase.h Source File

  • Source
  • Chart
  • Styles
  • Pie
  • Base
XTPChartPieSeriesLabelBase.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTPIESERIESLABELBASE_H__)
24# define __XTPCHARTPIESERIESLABELBASE_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartSeriesView;
34class CXTPChartPieSeriesPointViewBase;
35class CXTPChartPieSeriesStyleBase;
36class CXTPChartPieSeriesLabelViewBase;
37
42enum XTPChartPieLabelPosition
43{
44 xtpChartPieLabelOutside,
45 xtpChartPieLabelInside,
46 xtpChartPieLabelRadial,
47 xtpChartPieLabelTwoColumns
48};
49
55class _XTP_EXT_CLASS CXTPChartPieSeriesLabelBase : public CXTPChartSeriesLabel
56{
57 DECLARE_DYNAMIC(CXTPChartPieSeriesLabelBase);
58
59public:
64 CXTPChartPieSeriesLabelBase();
65
70 virtual ~CXTPChartPieSeriesLabelBase();
71
72public:
80 XTPChartPieLabelPosition GetPosition() const;
81
89 void SetPosition(XTPChartPieLabelPosition nPosition);
90
98 CXTPChartPieSeriesStyleBase* GetStyle() const;
99
100public:
101 void DoPropExchange(CXTPPropExchange* pPX);
102
103protected:
115 virtual CXTPChartElementView* CreateView(CXTPChartDeviceContext* pDC,
116 CXTPChartSeriesPointView* pPointView,
117 CXTPChartElementView* pParentView) = 0;
118
119public:
127 BOOL IsInside() const;
128
129protected:
130 XTPChartPieLabelPosition m_nPosition;
132# ifdef _XTP_ACTIVEX
133public:
135 DECLARE_DISPATCH_MAP()
136 DECLARE_INTERFACE_MAP()
137 DECLARE_OLETYPELIB_EX(CXTPChartPieSeriesLabelBase);
139# endif
140};
141
142AFX_INLINE XTPChartPieLabelPosition CXTPChartPieSeriesLabelBase::GetPosition() const
143{
144 return m_nPosition;
145}
146AFX_INLINE void CXTPChartPieSeriesLabelBase::SetPosition(XTPChartPieLabelPosition nPosition)
147{
148 m_nPosition = nPosition;
149 OnChartChanged();
150}
151
156class CXTPChartPieSeriesLabelViewBase : public CXTPChartSeriesLabelView
157{
158 DECLARE_DYNAMIC(CXTPChartPieSeriesLabelViewBase);
159
160protected:
169 CXTPChartPieSeriesLabelViewBase(CXTPChartSeriesLabel* pLabel,
170 CXTPChartSeriesPointView* pPointView,
171 CXTPChartElementView* pParentView);
172
173public:
181 XTPChartPieLabelPosition GetPosition() const;
182
193 virtual CXTPChartDeviceCommand* CreateDeviceCommand(CXTPChartDeviceContext* pDC) = 0;
194
205 virtual CXTPChartDeviceCommand* CreateConnectorDeviceCommand(CXTPChartDeviceContext* pDC) = 0;
206};
207
212class _XTP_EXT_CLASS CXTPChartPieSeriesLabelsViewBase : public CXTPChartElementView
213{
214 DECLARE_DYNAMIC(CXTPChartPieSeriesLabelsViewBase);
215
216protected:
223 CXTPChartPieSeriesLabelsViewBase(CXTPChartElementView* pParentView);
224
225public:
236 virtual CXTPChartDeviceCommand* CreateDeviceCommand(CXTPChartDeviceContext* pDC) = 0;
237
242 virtual void ResolveOverlapping() = 0;
243};
245# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
246#endif //#if !defined(__XTPCHARTPIESERIESLABELBASE_H__)
XTPChartPieLabelPosition
XTPChartPieLabelPosition
This enumeration tells the various positions available for the pie label.
Definition XTPChartPieSeriesLabelBase.h:43
xtpChartPieLabelOutside
@ xtpChartPieLabelOutside
Outside the pie.
Definition XTPChartPieSeriesLabelBase.h:44
xtpChartPieLabelRadial
@ xtpChartPieLabelRadial
Radial label.
Definition XTPChartPieSeriesLabelBase.h:46
xtpChartPieLabelInside
@ xtpChartPieLabelInside
Inside the pie.
Definition XTPChartPieSeriesLabelBase.h:45
xtpChartPieLabelTwoColumns
@ xtpChartPieLabelTwoColumns
2 Columns
Definition XTPChartPieSeriesLabelBase.h:47
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartElement::OnChartChanged
virtual void OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic propertie...
CXTPChartElementView
This class represents the view of a chart element.
Definition XTPChartElementView.h:47
CXTPChartPieSeriesLabelBase
CXTPChartPieSeriesLabelBase is a kind of CXTPChartSeriesLabel.
Definition XTPChartPieSeriesLabelBase.h:56
CXTPChartPieSeriesLabelBase::~CXTPChartPieSeriesLabelBase
virtual ~CXTPChartPieSeriesLabelBase()
Destroys a CXTPChartPieSeriesLabelBase object, handles cleanup.
CXTPChartPieSeriesLabelBase::GetPosition
XTPChartPieLabelPosition GetPosition() const
Call this function to get the label position.
Definition XTPChartPieSeriesLabelBase.h:142
CXTPChartPieSeriesLabelBase::DoPropExchange
void DoPropExchange(CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
CXTPChartPieSeriesLabelBase::m_nPosition
XTPChartPieLabelPosition m_nPosition
The pie label position.
Definition XTPChartPieSeriesLabelBase.h:130
CXTPChartPieSeriesLabelBase::SetPosition
void SetPosition(XTPChartPieLabelPosition nPosition)
Call this function to set the label position.
Definition XTPChartPieSeriesLabelBase.h:146
CXTPChartPieSeriesLabelBase::IsInside
BOOL IsInside() const
Call this function to check whether the label is inside the pie.
CXTPChartPieSeriesLabelBase::GetStyle
CXTPChartPieSeriesStyleBase * GetStyle() const
Call this function to get the basic style of the pie series.
CXTPChartPieSeriesLabelBase::CXTPChartPieSeriesLabelBase
CXTPChartPieSeriesLabelBase()
Constructs a CXTPChartPieSeriesLabelBase object.
CXTPChartPieSeriesLabelBase::CreateView
virtual CXTPChartElementView * CreateView(CXTPChartDeviceContext *pDC, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView)=0
This function creates the view of the pie series.
CXTPChartPieSeriesLabelViewBase
Defines a base class interface for series label view.
Definition XTPChartPieSeriesLabelBase.h:157
CXTPChartPieSeriesLabelViewBase::CreateDeviceCommand
virtual CXTPChartDeviceCommand * CreateDeviceCommand(CXTPChartDeviceContext *pDC)=0
Creates view drawing device command for the device context specified.
CXTPChartPieSeriesLabelViewBase::GetPosition
XTPChartPieLabelPosition GetPosition() const
Obtains label position.
CXTPChartPieSeriesLabelViewBase::CXTPChartPieSeriesLabelViewBase
CXTPChartPieSeriesLabelViewBase(CXTPChartSeriesLabel *pLabel, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView)
Constructs a CXTPChartPieSeriesLabelViewBase object.
CXTPChartPieSeriesLabelViewBase::CreateConnectorDeviceCommand
virtual CXTPChartDeviceCommand * CreateConnectorDeviceCommand(CXTPChartDeviceContext *pDC)=0
Creates connector drawing device command for the device context specified.
CXTPChartPieSeriesLabelsViewBase
Defines a base class interface for series label collection view.
Definition XTPChartPieSeriesLabelBase.h:213
CXTPChartPieSeriesLabelsViewBase::CXTPChartPieSeriesLabelsViewBase
CXTPChartPieSeriesLabelsViewBase(CXTPChartElementView *pParentView)
Constructs a CXTPChartPieSeriesLabelsViewBase object.
CXTPChartPieSeriesLabelsViewBase::CreateDeviceCommand
virtual CXTPChartDeviceCommand * CreateDeviceCommand(CXTPChartDeviceContext *pDC)=0
Creates view drawing device command for the device context specified.
CXTPChartPieSeriesLabelsViewBase::ResolveOverlapping
virtual void ResolveOverlapping()=0
Resolves label overlapping in an implementation specific way.
CXTPChartPieSeriesPointViewBase
This class abstracts the view of a pie series point.
Definition XTPChartPieSeriesPointViewBase.h:50
CXTPChartPieSeriesStyleBase
This class abstracts the basic style of a pie serie.This class is a kind of CXTPChartSeriesStyle.
Definition XTPChartPieSeriesStyleBase.h:48
CXTPChartSeriesLabel
This class abstracts the label of a series.
Definition XTPChartSeriesLabel.h:49
CXTPChartSeriesPointView
Represents chart series point view.
Definition XTPChartSeriesPointView.h:48
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72


Toolkit Pro: XTPMarkupTextBlock.h Source File

  • Source
  • Markup
  • Controls
XTPMarkupTextBlock.h
Go to the documentation of this file.
1
23#if !defined(__XTPMARKUPTEXTBLOCK_H__)
24# define __XTPMARKUPTEXTBLOCK_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPMarkupBrush;
34class CXTPMarkupInlineCollection;
35class CXTPMarkupInline;
36class CXTPMarkupDrawingContext;
37class CXTPMarkupRenderTransform;
38template<class TYPE>
39class CXTPMarkupTypedSimpleStack;
40
50enum XTPMarkupTextTrimming
51{
52 xtpMarkupTextTrimmingNone,
53 xtpMarkupTextTrimmingCharacterEllipsis,
55 xtpMarkupTextTrimmingWordEllipsis,
57};
58
68enum XTPMarkupTextWrapping
69{
70 xtpMarkupTextNoWrap,
71 xtpMarkupTextWrap,
74 xtpMarkupTextWrapWithOverflow
78};
79
85class _XTP_EXT_CLASS CXTPMarkupTextBlock : public CXTPMarkupFrameworkElement
86{
88 DECLARE_MARKUPCLASS(CXTPMarkupTextBlock)
90private:
91 struct CLine;
92 struct CLineIterator;
93 struct CLinePart;
94
95protected:
100 CXTPMarkupTextBlock();
101
106 virtual ~CXTPMarkupTextBlock();
107
108public:
114 void SetText(LPCWSTR lpszText);
115
122 CString GetText() const;
123
132 CXTPMarkupInlineCollection* GetInlines() const;
133
139 void SetBackground(CXTPMarkupBrush* pBrush);
140
147 CXTPMarkupBrush* GetBackground() const;
148
154 void SetForeground(CXTPMarkupBrush* pBrush);
155
162 CXTPMarkupBrush* GetForeground() const;
163
172 void SetTextAlignment(XTPMarkupTextAlignment alignment);
173
183 XTPMarkupTextAlignment GetTextAlignment() const;
184
194 void SetTextWrapping(XTPMarkupTextWrapping nTextWrapping);
195
204 void SetTextWrapping(BOOL bTextWrapping);
205
216 XTPMarkupTextWrapping GetTextWrapping() const;
217
228 void SetTextTrimming(XTPMarkupTextTrimming bTextTrimming);
229
238 XTPMarkupTextTrimming GetTextTrimming() const;
239
250 void SetPadding(int nLeft, int nTop, int nRight, int nBottom);
251
259 void SetPadding(int nPadding);
260
273 CXTPMarkupThickness* GetPadding() const;
274
280 void SetFontSize(int nFontSize);
281
288 int GetFontSize() const;
289
295 void SetFontWeight(int nFontWeight);
296
303 int GetFontWeight() const;
304
310 void SetFontFamily(LPCWSTR lpszFontFamily);
311
318 LPCWSTR GetFontFamily() const;
319
327 void SetFontStyle(int nFontStyle);
328
335 int GetFontStyle() const;
336
345 void SetTextDecorations(int nTextDecorations);
346
353 int GetTextDecorations() const;
354
356 // Internal methods
357
358public:
359 CXTPMarkupInline* GetFirstInline() const;
360
361public:
362 virtual void SetContentObject(CXTPMarkupBuilder* pBuilder, CXTPMarkupObject* pContent);
363 virtual BOOL HasContentObject() const;
364
365protected:
366 virtual CSize MeasureOverride(CXTPMarkupDrawingContext* pDC, CSize szAvailableSize);
367 virtual CSize ArrangeOverride(CSize szFinal);
368 virtual void OnRender(CXTPMarkupDrawingContext* pDC);
369
370 virtual BOOL AllowWhiteSpaceContent() const;
371 virtual void OnPropertyChanged(CXTPMarkupDependencyProperty* pProperty,
372 CXTPMarkupObject* pOldValue, CXTPMarkupObject* pNewValue);
373
374 virtual int GetLogicalChildrenCount() const;
375 virtual CXTPMarkupObject* GetLogicalChild(int nIndex) const;
376
377 CXTPMarkupInputElement* InputHitTestOverride(CPoint point) const;
378
379 void InvalidateMeasureOverride(CXTPMarkupDrawingContext* pDC);
380
383private:
384 void RemoveAllLines();
385
386 void CloseLine(CLineIterator& li, int nWidth);
387 void TrimLine(CLineIterator& li, int nWidth);
388 void PushLinePart(CLineIterator& li, int nWidth);
389
390 void CalculateLines(CXTPMarkupDrawingContext* pDC, int nWidth);
391
392 void RenderTextDecorations(CXTPMarkupDrawingContext* pDC, CLinePart* part);
393 FLOAT GetStackWidth(CLineIterator& li) const;
394
395 void AddEmptyRun(CLineIterator& li);
396
398public:
399 DECLARE_DISPATCH_MAP()
400# ifdef _XTP_ACTIVEX
401 DECLARE_INTERFACE_MAP()
402 DECLARE_OLETYPELIB_EX(CXTPMarkupTextBlock);
403# endif
404
405 afx_msg VARIANT OleGetText();
406 afx_msg void OleSetText(const VARIANT& lpCaption);
407 afx_msg long OleGetTextWrapping();
408 afx_msg void OleSetTextWrapping(long nValue);
409 afx_msg long OleGetTextTrimming();
410 afx_msg void OleSetTextTrimming(long nValue);
411 afx_msg long OleGetTextAlignment();
412 afx_msg void OleSetTextAlignment(long nValue);
413 afx_msg long OleGetTextDecorations();
414 afx_msg void OleSetTextDecorations(long nValue);
415 afx_msg long OleGetFontSize();
416 afx_msg void OleSetFontSize(long nValue);
417 afx_msg long OleGetFontWeight();
418 afx_msg void OleSetFontWeight(long nValue);
419 afx_msg BSTR OleGetFontFamily();
420 afx_msg void OleSetFontFamily(LPCTSTR lpszValue);
421 afx_msg long OleGetFontStyle();
422 afx_msg void OleSetFontStyle(long nValue);
423 afx_msg LPDISPATCH OleGetPadding();
424 afx_msg void OleSetPadding(LPDISPATCH lpPaddingDisp);
425 afx_msg long OleGetFontQuality();
426 afx_msg void OleSetFontQuality(long nValue);
427 afx_msg LPDISPATCH OleGetBackground();
428 afx_msg void OleSetBackground(LPDISPATCH lpBackground);
429 afx_msg LPDISPATCH OleGetForeground();
430 afx_msg void OleSetForeground(LPDISPATCH lpBackground);
431 afx_msg LPDISPATCH OleGetInlines();
434protected:
435 CXTPMarkupInlineCollection* m_pInlines;
437public:
438 static CXTPMarkupDependencyProperty* m_pBackgroundProperty;
439 static CXTPMarkupDependencyProperty* m_pForegroundProperty;
440 static CXTPMarkupDependencyProperty* m_pTextWrappingProperty;
441 static CXTPMarkupDependencyProperty* m_pTextTrimmingProperty;
442 static CXTPMarkupDependencyProperty* m_pTextAlignmentProperty;
443 static CXTPMarkupDependencyProperty* m_pTextDecorationsProperty;
444 static CXTPMarkupDependencyProperty* m_pFontSizeProperty;
445 static CXTPMarkupDependencyProperty* m_pFontWeightProperty;
446 static CXTPMarkupDependencyProperty* m_pFontFamilyProperty;
447 static CXTPMarkupDependencyProperty* m_pFontStyleProperty;
448 static CXTPMarkupDependencyProperty* m_pPaddingProperty;
449 static CXTPMarkupDependencyProperty* m_pTextProperty;
450 static CXTPMarkupDependencyProperty* m_pFontQualityProperty;
451 static CXTPMarkupDependencyProperty* m_pFontCharsetProperty;
452
453private:
454 CXTPMarkupTypedSimpleStack<CLine>* m_pLineList;
455 int m_nLastWidth;
456 CSize m_szBlockSize;
457};
458
459AFX_INLINE CXTPMarkupInlineCollection* CXTPMarkupTextBlock::GetInlines() const
460{
461 return m_pInlines;
462}
464AFX_INLINE int CXTPMarkupTextBlock::GetLogicalChildrenCount() const
465{
466 return m_pInlines != NULL ? 1 : 0;
467}
469# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
471#endif // !defined(__XTPMARKUPTEXTBLOCK_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPMarkupTextWrapping
XTPMarkupTextWrapping
Text wrapping type.
Definition XTPMarkupTextBlock.h:69
xtpMarkupTextNoWrap
@ xtpMarkupTextNoWrap
No line wrapping is performed.
Definition XTPMarkupTextBlock.h:70
xtpMarkupTextWrap
@ xtpMarkupTextWrap
Line-breaking occurs if the line overflows beyond the available block width, even if the standard lin...
Definition XTPMarkupTextBlock.h:71
xtpMarkupTextWrapWithOverflow
@ xtpMarkupTextWrapWithOverflow
Line-breaking occurs if the line overflows beyond the available block width.
Definition XTPMarkupTextBlock.h:74
XTPMarkupTextTrimming
XTPMarkupTextTrimming
Text trimming type.
Definition XTPMarkupTextBlock.h:51
xtpMarkupTextTrimmingNone
@ xtpMarkupTextTrimmingNone
Drawing without trimming.
Definition XTPMarkupTextBlock.h:52
xtpMarkupTextTrimmingWordEllipsis
@ xtpMarkupTextTrimmingWordEllipsis
Replaces last word of the given string with ellipses, if necessary.
Definition XTPMarkupTextBlock.h:55
xtpMarkupTextTrimmingCharacterEllipsis
@ xtpMarkupTextTrimmingCharacterEllipsis
Replaces part of the given string with ellipses, if necessary.
Definition XTPMarkupTextBlock.h:53
CXTPMarkupFrameworkElement
This class represents the provided framework-level implementation built on CXTPMarkupUIElement.
Definition XTPMarkupFrameworkElement.h:44
CXTPMarkupTextBlock
CXTPMarkupTextBlock is a CXTPMarkupFrameworkElement derived class.
Definition XTPMarkupTextBlock.h:86
CXTPMarkupTextBlock::SetTextWrapping
void SetTextWrapping(XTPMarkupTextWrapping nTextWrapping)
Sets the text wrapping type for the bounding rectangle (how text will be wrapped inside the bounding ...
CXTPMarkupTextBlock::SetPadding
void SetPadding(int nLeft, int nTop, int nRight, int nBottom)
Sets a value that indicates the thickness of the padding space between the boundaries of the content ...
CXTPMarkupTextBlock::GetTextTrimming
XTPMarkupTextTrimming GetTextTrimming() const
Gets the current text trimming style (how text is trimmed when content overflows the content area).
CXTPMarkupTextBlock::CXTPMarkupTextBlock
CXTPMarkupTextBlock()
Constructs a CXTPMarkupTextBlock object.
CXTPMarkupTextBlock::GetFontFamily
LPCWSTR GetFontFamily() const
Gets the typeface name of the font.
CXTPMarkupTextBlock::SetTextDecorations
void SetTextDecorations(int nTextDecorations)
Sets the font text decoration for the TextBlock object.
CXTPMarkupTextBlock::GetInlines
CXTPMarkupInlineCollection * GetInlines() const
Gets a pointer to the CXTPMarkupInlineCollection object containing the TextBlock object's inline bloc...
Definition XTPMarkupTextBlock.h:459
CXTPMarkupTextBlock::GetBackground
CXTPMarkupBrush * GetBackground() const
Gets the background brush of the TextBlock object.
CXTPMarkupTextBlock::SetTextWrapping
void SetTextWrapping(BOOL bTextWrapping)
Sets the text wrapping type for the bounding rectangle (how text will be wrapped inside the bounding ...
CXTPMarkupTextBlock::SetFontWeight
void SetFontWeight(int nFontWeight)
Sets the font weight for the TextBlock object.
CXTPMarkupTextBlock::SetFontSize
void SetFontSize(int nFontSize)
Sets the font size for the TextBlock object.
CXTPMarkupTextBlock::SetTextTrimming
void SetTextTrimming(XTPMarkupTextTrimming bTextTrimming)
Sets the text trimming style (how text will be trimmed when content overflows the content area).
CXTPMarkupTextBlock::GetFontWeight
int GetFontWeight() const
Gets the font weight of the TextBlock object.
CXTPMarkupTextBlock::GetTextDecorations
int GetTextDecorations() const
Gets the font text decoration of the TextBlock object.
CXTPMarkupTextBlock::GetPadding
CXTPMarkupThickness * GetPadding() const
Retrieves a value that indicates the thickness of the padding space between the boundaries of the con...
CXTPMarkupTextBlock::SetFontFamily
void SetFontFamily(LPCWSTR lpszFontFamily)
Sets the typeface name for the font.
CXTPMarkupTextBlock::SetText
void SetText(LPCWSTR lpszText)
Sets the text for the TextBlock object.
CXTPMarkupTextBlock::SetTextAlignment
void SetTextAlignment(XTPMarkupTextAlignment alignment)
Sets the text alignment for the TextBlock object.
CXTPMarkupTextBlock::GetText
CString GetText() const
Gets the current text of the TextBlock object.
CXTPMarkupTextBlock::GetForeground
CXTPMarkupBrush * GetForeground() const
Gets the default text brush of the TextBlock object.
CXTPMarkupTextBlock::GetFontStyle
int GetFontStyle() const
Gets the font style of the TextBlock object.
CXTPMarkupTextBlock::GetFontSize
int GetFontSize() const
Gets the font size of the TextBlock object.
CXTPMarkupTextBlock::SetPadding
void SetPadding(int nPadding)
Sets a value that indicates the thickness of the padding space between the boundaries of the content ...
CXTPMarkupTextBlock::m_pInlines
CXTPMarkupInlineCollection * m_pInlines
Inline collection of TextBlock.
Definition XTPMarkupTextBlock.h:435
CXTPMarkupTextBlock::SetFontStyle
void SetFontStyle(int nFontStyle)
Sets the font style for the TextBlock object.
CXTPMarkupTextBlock::GetTextAlignment
XTPMarkupTextAlignment GetTextAlignment() const
Gets the text alignment of the TextBlock object.
CXTPMarkupTextBlock::GetTextWrapping
XTPMarkupTextWrapping GetTextWrapping() const
Gets the text wrapping type of the bounding rectangle (how text is wrapped inside the bounding rectan...
CXTPMarkupTextBlock::SetBackground
void SetBackground(CXTPMarkupBrush *pBrush)
Sets the background brush for the TextBlock object.
CXTPMarkupTextBlock::~CXTPMarkupTextBlock
virtual ~CXTPMarkupTextBlock()
Destroys a CXTPMarkupTextBlock object, handles cleanup and deallocation.
CXTPMarkupTextBlock::SetForeground
void SetForeground(CXTPMarkupBrush *pBrush)
Sets the default text brush for the TextBlock object.
CXTPMarkupThickness
The CXTPMarkupThickness class describes the thickness of the left, top, right, and bottom sides of a ...
Definition XTPMarkupThickness.h:42
CXTPMarkupUIElement::InvalidateMeasureOverride
virtual void InvalidateMeasureOverride(CXTPMarkupDrawingContext *pDC)
Override this method to provide a custom reaction to an InvalidateMeasure call.
CXTPMarkupVisual::GetLogicalChildrenCount
virtual int GetLogicalChildrenCount() const
Retrieves the number of logical child elements of this object.
CXTPMarkupVisual::InputHitTestOverride
virtual CXTPMarkupInputElement * InputHitTestOverride(CPoint point) const
Override this method in the derived class to provide visual hit testing of a child object.
CXTPMarkupVisual::GetLogicalChild
virtual CXTPMarkupObject * GetLogicalChild(int nIndex) const
Retrieves the logical child element located at a specified index within the parent collection.
CXTPMarkupVisual::OnRender
virtual void OnRender(CXTPMarkupDrawingContext *drawingContext)
When overridden in a derived class, participates in rendering operations that are directed by the lay...
Definition XTPMarkupInputElement.h:515


Toolkit Pro: Member List

CXTPSystemPreviewProvider Member List

This is the complete list of members for CXTPSystemPreviewProvider, including all inherited members.

BindHost(IXTPPreviewHost &host) | CXTPPreviewProviderBase | protectedvirtual
CXTPPreviewProviderBase() | CXTPPreviewProviderBase | protected
GetHost() const | CXTPPreviewProviderBase | protected
~IXTPPreviewProvider() | IXTPPreviewProvider | inlinevirtual


Toolkit Pro: XTPControlGalleryVisualStudio2017Theme.h Source File

  • Source
  • CommandBars
  • Gallery
XTPControlGalleryVisualStudio2017Theme.h
Go to the documentation of this file.
1
23#if !defined(__XTPCONTROLGALLERYVISUALSTUDIO2017THEME_H__)
24# define __XTPCONTROLGALLERYVISUALSTUDIO2017THEME_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
40class _XTP_EXT_CLASS CXTPControlGalleryVisualStudio2017Theme
41 : public CXTPControlGalleryOffice2013Theme
42{
43public:
49 CXTPControlGalleryVisualStudio2017Theme(CXTPPaintManager* pPaintManager);
50};
51
53# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
54#endif // !defined(__XTPCONTROLGALLERYVISUALSTUDIO2017THEME_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPControlGalleryOffice2013Theme
The CXTPControlGalleryResourceTheme class is used to enable a Gallery Office 2013 style theme for Com...
Definition XTPControlGalleryOffice2013Theme.h:41
CXTPControlGalleryVisualStudio2017Theme
The CXTPControlGalleryResourceTheme class is used to enable a Gallery Visual Studio 2017 style theme ...
Definition XTPControlGalleryVisualStudio2017Theme.h:42
CXTPControlGalleryVisualStudio2017Theme::CXTPControlGalleryVisualStudio2017Theme
CXTPControlGalleryVisualStudio2017Theme(CXTPPaintManager *pPaintManager)
Constructs a CXTPControlGalleryVisualStudio2017Theme object.
CXTPPaintManager
Paint manager of the command bars.
Definition XTPPaintManager.h:199


Toolkit Pro: Member List

ITimeProvider Member List

This is the complete list of members for ITimeProvider, including all inherited members.


Toolkit Pro: Member List

CXTPChart3dPyramidSeriesLabelView Member List

This is the complete list of members for CXTPChart3dPyramidSeriesLabelView, including all inherited members.

AddChildView(CXTPChartElementView *pChildView) | CXTPChartElementView |
CreateConnectorDeviceCommand(CXTPChartDeviceContext *pDC) | CXTPChart3dPyramidSeriesLabelView | virtual
CreateDeviceCommand(CXTPChartDeviceContext *pDC) | CXTPChart3dPyramidSeriesLabelView | virtual
CreateTranspositionDeviceCommand(CXTPChartDeviceContext *pDC) | CXTPChart3dPyramidSeriesLabelView | virtual
CXTPChart3dPyramidSeriesLabelView(CXTPChartSeriesLabel *pLabel, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView) | CXTPChart3dPyramidSeriesLabelView |
CXTPChartElementView(CXTPChartElementView *pParentView) | CXTPChartElementView |
CXTPChartElementView(CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartElementView |
CXTPChartElementView(CXTPChartContainer *pContainer) | CXTPChartElementView |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartPyramidSeriesLabelViewBase(CXTPChartSeriesLabel *pLabel, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView) | CXTPChartPyramidSeriesLabelViewBase | protected
GetAt(int nIndex) const | CXTPChartElementView |
GetBounds() const | CXTPChartElementView |
GetBounds(BOOL bIncludingChildren) const | CXTPChartElementView |
GetChildren() | CXTPChartElementView |
GetConnectorBendPoint() const | CXTPChart3dPyramidSeriesLabelView |
GetConnectorEndPoint() const | CXTPChart3dPyramidSeriesLabelView |
GetConnectorStartPoint() const | CXTPChart3dPyramidSeriesLabelView |
GetCount() const | CXTPChartElementView |
GetLabelAnchorOrigin() const | CXTPChart3dPyramidSeriesLabelView |
GetLabelAnchorPoint() const | CXTPChart3dPyramidSeriesLabelView |
GetParentView() const | CXTPChartElementView |
GetPosition() const | CXTPChartPyramidSeriesLabelViewBase |
Is3D() const | CXTPChartObject |
IsConnectorVisible() const | CXTPChart3dPyramidSeriesLabelView |
IsLeftDirected() const | CXTPChart3dPyramidSeriesLabelView |
IsRightDirected() const | CXTPChart3dPyramidSeriesLabelView |
m_arrChildren | CXTPChartElementView | protected
m_bConnectorVisible | CXTPChart3dPyramidSeriesLabelView | protected
m_bLeftDirected | CXTPChart3dPyramidSeriesLabelView | protected
m_p3dPointView | CXTPChart3dPyramidSeriesLabelView | protected
m_pContainer | CXTPChartElementView | protected
m_pParentView | CXTPChartElementView | protected
m_ptBend | CXTPChart3dPyramidSeriesLabelView | protected
m_ptEnd | CXTPChart3dPyramidSeriesLabelView | protected
m_ptLabelAnchor | CXTPChart3dPyramidSeriesLabelView | protected
m_ptLabelAnchorOrigin | CXTPChart3dPyramidSeriesLabelView | protected
m_ptStart | CXTPChart3dPyramidSeriesLabelView | protected
m_rcBounds | CXTPChartElementView | protected
SetConnectorBendPoint(const CXTPPoint3d &point) | CXTPChart3dPyramidSeriesLabelView |
SetConnectorEndPoint(const CXTPPoint3d &point) | CXTPChart3dPyramidSeriesLabelView |
SetConnectorStartPoint(const CXTPPoint3d &point) | CXTPChart3dPyramidSeriesLabelView |
SetConnectorVisible(BOOL bVisible=TRUE) | CXTPChart3dPyramidSeriesLabelView |
SetLabelAnchorOrigin(CPoint ptAnchorOrigin) | CXTPChart3dPyramidSeriesLabelView |
SetLabelAnchorPoint(CPoint ptAnchor) | CXTPChart3dPyramidSeriesLabelView |
SetLeftDirected() | CXTPChart3dPyramidSeriesLabelView |
SetRightDirected() | CXTPChart3dPyramidSeriesLabelView |
~CXTPChart3dPyramidSeriesLabelView() | CXTPChart3dPyramidSeriesLabelView |
~CXTPChartElementView() | CXTPChartElementView | protectedvirtual


Toolkit Pro: XTPChartRangeSplineAreaSeriesStyle.h Source File

  • Source
  • Chart
  • Styles
  • Area
XTPChartRangeSplineAreaSeriesStyle.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTRANGESPLINEAREASERIESSTYLE_H__)
24# define __XTPCHARTRANGESPLINEAREASERIESSTYLE_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartSeriesView;
34class CXTPChartBorder;
35class CXTPChartFillStyle;
36
47class _XTP_EXT_CLASS CXTPChartRangeSplineAreaSeriesStyle : public CXTPChartAreaSeriesStyle
48{
50 DECLARE_SERIAL(CXTPChartRangeSplineAreaSeriesStyle)
52public:
57 CXTPChartRangeSplineAreaSeriesStyle();
58
63 virtual ~CXTPChartRangeSplineAreaSeriesStyle();
64
65public:
66protected:
79 virtual CXTPChartSeriesView* CreateView(CXTPChartSeries* pSeries,
80 CXTPChartDiagramView* pDiagramView);
81
82# ifdef _XTP_ACTIVEX
83public:
85 DECLARE_DISPATCH_MAP()
86 DECLARE_INTERFACE_MAP()
87 DECLARE_OLETYPELIB_EX(CXTPChartRangeSplineAreaSeriesStyle);
88 DECLARE_OLECREATE_EX(CXTPChartRangeSplineAreaSeriesStyle)
89
91# endif
92
93protected:
94};
95
106class _XTP_EXT_CLASS CXTPChartRangeSplineAreaSeriesView : public CXTPChartAreaSeriesView
107{
108public:
116 CXTPChartRangeSplineAreaSeriesView(CXTPChartSeries* pSeries,
117 CXTPChartDiagramView* pDiagramView);
118
119protected:
120 CXTPChartSeriesPointView* CreateSeriesPointView(CXTPChartDeviceContext* pDC,
121 CXTPChartSeriesPoint* pPoint,
122 CXTPChartElementView* pParentView);
123
135 virtual CXTPChartDeviceCommand* CreateDeviceCommand(CXTPChartDeviceContext* pDC);
136};
137
143class _XTP_EXT_CLASS CXTPChartRangeSplineAreaSeriesPointView : public CXTPChartPointSeriesPointView
144{
145public:
153 CXTPChartRangeSplineAreaSeriesPointView(CXTPChartSeriesPoint* pPoint,
154 CXTPChartElementView* pParentView);
155
156public:
157 virtual void UpdateMinMaxRange(double& nMinValue, double& nMaxValue) const;
158
159public:
171 virtual CXTPChartDeviceCommand* CreateDeviceCommand(CXTPChartDeviceContext* pDC);
172};
174# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
175#endif //#if !defined(__XTPCHARTRANGESPLINEAREASERIESSTYLE_H__)
pPoint
const CPoint * pPoint
return 0 or xtpCalendarHitTestDayExpandButton
Definition XTPCalendarThemeOffice2007.h:150
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartAreaSeriesStyle
CXTPChartAreaSeriesStyle is a CXTPChartPointSeriesStyle derived class which represents the area serie...
Definition XTPChartAreaSeriesStyle.h:48
CXTPChartAreaSeriesView
CXTPChartAreaSeriesView is a kind of CXTPChartSeriesView.
Definition XTPChartAreaSeriesView.h:48
CXTPChartBorder
This class abstracts the border of a chart, it is a kind of chart element.
Definition XTPChartBorder.h:42
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartDiagramView
This class represents the view of a chart diagram, which is a kind of CXTPChartElementView.
Definition XTPChartDiagramView.h:49
CXTPChartElementView
This class represents the view of a chart element.
Definition XTPChartElementView.h:47
CXTPChartFillStyle
This class abstracts a fill style used to fill the background of various chart elements.
Definition XTPChartFillStyle.h:43
CXTPChartPointSeriesPointView
This class represents the view of a point series point, which is a kind of CXTPChartSeriesPointView.
Definition XTPChartPointSeriesView.h:90
CXTPChartRangeSplineAreaSeriesPointView
This class represents the view of a RangeBar series point, which is a kind of CXTPChartPointSeriesPoi...
Definition XTPChartRangeSplineAreaSeriesStyle.h:144
CXTPChartRangeSplineAreaSeriesPointView::UpdateMinMaxRange
virtual void UpdateMinMaxRange(double &nMinValue, double &nMaxValue) const
Provides a default empty implementation for min/max range update request.
CXTPChartRangeSplineAreaSeriesPointView::CXTPChartRangeSplineAreaSeriesPointView
CXTPChartRangeSplineAreaSeriesPointView(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Constructs a CXTPChartRangeBarSeriesPointView object.
CXTPChartRangeSplineAreaSeriesPointView::CreateDeviceCommand
virtual CXTPChartDeviceCommand * CreateDeviceCommand(CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
CXTPChartRangeSplineAreaSeriesStyle
CXTPChartRangeSplineAreaSeriesStyle is a CXTPChartAreaSeriesStyle derived class which represents the ...
Definition XTPChartRangeSplineAreaSeriesStyle.h:48
CXTPChartRangeSplineAreaSeriesStyle::~CXTPChartRangeSplineAreaSeriesStyle
virtual ~CXTPChartRangeSplineAreaSeriesStyle()
Destroys a CXTPChartRangeSplineAreaSeriesStyle object, handles cleanup.
CXTPChartRangeSplineAreaSeriesStyle::CreateView
virtual CXTPChartSeriesView * CreateView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Use this function to create a chart series view object.
CXTPChartRangeSplineAreaSeriesStyle::CXTPChartRangeSplineAreaSeriesStyle
CXTPChartRangeSplineAreaSeriesStyle()
Constructs a CXTPChartRangeSplineAreaSeriesStyle object.
CXTPChartRangeSplineAreaSeriesView
CXTPChartRangeSplineAreaSeriesView is a kind of CXTPChartAreaSeriesView.
Definition XTPChartRangeSplineAreaSeriesStyle.h:107
CXTPChartRangeSplineAreaSeriesView::CXTPChartRangeSplineAreaSeriesView
CXTPChartRangeSplineAreaSeriesView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Constructs a CXTPChartRangeSplineAreaSeriesView object.
CXTPChartRangeSplineAreaSeriesView::CreateDeviceCommand
virtual CXTPChartDeviceCommand * CreateDeviceCommand(CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
CXTPChartSeries
This class represents a series in the chart, which is a kind of CXTPChartElement.
Definition XTPChartSeries.h:50
CXTPChartSeriesPoint
CXTPChartSeriesPoint is a kind of CXTPChartElement.
Definition XTPChartSeriesPoint.h:43
CXTPChartSeriesPointView
Represents chart series point view.
Definition XTPChartSeriesPointView.h:48


Toolkit Pro: Member List

XTP_EDIT_ACDATA Member List

This is the complete list of members for XTP_EDIT_ACDATA, including all inherited members.

m_nIcon | XTP_EDIT_ACDATA |
m_strText | XTP_EDIT_ACDATA |
XTP_EDIT_ACDATA(int nIcon, CString strText) | XTP_EDIT_ACDATA | inline


Toolkit Pro: Member List

CXTPSkinObject Member List

This is the complete list of members for CXTPSkinObject, including all inherited members.

CXTPSkinObject() | CXTPSkinObject | protected
GetAccessCriticalSection() const | CXTPSynchronized | inline
GetClassName() const | CXTPSkinObject |
GetColor(int nIndex) const | CXTPSkinObject |
GetMetrics() const | CXTPSkinObject |
GetSkinClass() const | CXTPSkinObject |
GetSkinManager() const | CXTPSkinObject |
m_bActiveX | CXTPSkinObject | protected
m_bWindowsForms | CXTPSkinObject | protected
m_pManager | CXTPSkinObject | protected
m_pOldWndProc | CXTPSkinObject | protected
m_strClassName | CXTPSkinObject | protected
OnHookAttached(LPCREATESTRUCT lpcs, BOOL bAuto) | CXTPSkinObject | protectedvirtual
OnHookDetached(BOOL bAuto) | CXTPSkinObject | protectedvirtual
OnSkinChanged(BOOL bPrevState, BOOL bNewState) | CXTPSkinObject | protectedvirtual
RefreshMetrics() | CXTPSkinObject | protectedvirtual
~CXTPSkinObject() | CXTPSkinObject | protected


Toolkit Pro: XTPChart2dFunnelDiagram.h Source File

  • Source
  • Chart
  • Styles
  • Funnel
  • 2D
XTPChart2dFunnelDiagram.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHART2DFUNNELDIAGRAM_H__)
24# define __XTPCHART2DFUNNELDIAGRAM_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
44class _XTP_EXT_CLASS CXTPChartFunnelDiagram : public CXTPChart2dFunnelDiagramBase
45{
47 DECLARE_SERIAL(CXTPChartFunnelDiagram)
49public:
54 CXTPChartFunnelDiagram();
55
56public:
68 virtual CXTPChartDiagramView* CreateView(CXTPChartDeviceContext* pDC,
69 CXTPChartElementView* pParent);
70
71# ifdef _XTP_ACTIVEX
72public:
74 DECLARE_DISPATCH_MAP()
75 DECLARE_INTERFACE_MAP()
76 DECLARE_OLETYPELIB_EX(CXTPChartFunnelDiagram);
77 DECLARE_OLECREATE_EX(CXTPChartFunnelDiagram)
79# endif
80};
82# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
83#endif //#if !defined(__XTPCHART2DFUNNELDIAGRAM_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartDiagramView
This class represents the view of a chart diagram, which is a kind of CXTPChartElementView.
Definition XTPChartDiagramView.h:49
CXTPChartElementView
This class represents the view of a chart element.
Definition XTPChartElementView.h:47
CXTPChartFunnelDiagramBase
This class abstracts the funnel diagram.
Definition XTPChartFunnelDiagramBase.h:62
CXTPChartFunnelDiagram
This class abstracts the funnel diagram.
Definition XTPChart2dFunnelDiagram.h:45
CXTPChartFunnelDiagram::CXTPChartFunnelDiagram
CXTPChartFunnelDiagram()
Constructs a CXTPChartFunnelDiagram object.
CXTPChartFunnelDiagram::CreateView
virtual CXTPChartDiagramView * CreateView(CXTPChartDeviceContext *pDC, CXTPChartElementView *pParent)
Call this function to create the view of the funnel diagram.


Toolkit Pro: XTPChartGdiPolygonDeviceCommand.h Source File

  • Source
  • Chart
  • Drawing
  • Gdi
XTPChartGdiPolygonDeviceCommand.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTGDIPOLYGONDEVICECOMMAND_H__)
24# define __XTPCHARTGDIPOLYGONDEVICECOMMAND_H__
25
26# if _MSC_VER >= 1000
27# pragma once
28# endif // _MSC_VER >= 1000
29
30# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
31
32class _XTP_EXT_CLASS CXTPChartGdiPolygonDeviceCommand : public CXTPChartPolygonDeviceCommand
33{
34protected:
35 CXTPChartGdiPolygonDeviceCommand(const CXTPChartPoints& points);
36
37protected:
38 virtual CXTPChartElement* HitTest(CPoint point, CXTPChartElement* pParent) const;
39};
40
46class _XTP_EXT_CLASS CXTPChartGdiSolidPolygonDeviceCommand : public CXTPChartGdiPolygonDeviceCommand
47{
48public:
56 CXTPChartGdiSolidPolygonDeviceCommand(const CXTPChartPoints& points,
57 const CXTPChartColor& color);
58
64 ~CXTPChartGdiSolidPolygonDeviceCommand();
65
66protected:
75 void ExecuteOverride(CXTPChartDeviceContext* pDC);
76
77protected:
78 CXTPChartColor m_color;
79};
80
81class _XTP_EXT_CLASS CXTPChartGdiSolidSplinePolygonDeviceCommand
82 : public CXTPChartSolidSplinePolygonDeviceCommand
83{
84public:
92 CXTPChartGdiSolidSplinePolygonDeviceCommand(const CXTPChartPoints& points,
93 const CXTPChartColor& color,
94 BOOL bTwoSides = FALSE);
95
101 ~CXTPChartGdiSolidSplinePolygonDeviceCommand();
102
103protected:
112 virtual void ExecuteOverride(CXTPChartDeviceContext* pDC);
113
114 virtual CXTPChartElement* HitTest(CPoint point, CXTPChartElement* pParent) const;
115
116protected:
117 Gdiplus::GpPath* m_pGpPath;
118};
119
126class _XTP_EXT_CLASS CXTPChartGdiGradientPolygonDeviceCommand
127 : public CXTPChartGdiPolygonDeviceCommand
128{
129public:
140 CXTPChartGdiGradientPolygonDeviceCommand(const CXTPChartPoints& points,
141 const CXTPChartColor& color,
142 const CXTPChartColor& color2,
143 XTPChartLinearGradientMode nMode);
144
145protected:
154 virtual void ExecuteOverride(CXTPChartDeviceContext* pDC);
155
156protected:
157 CXTPChartColor m_color;
158 CXTPChartColor m_color2;
159 XTPChartLinearGradientMode m_nMode;
160};
161
168class _XTP_EXT_CLASS CXTPChartGdiHatchPolygonDeviceCommand : public CXTPChartGdiPolygonDeviceCommand
169{
170public:
180 CXTPChartGdiHatchPolygonDeviceCommand(const CXTPChartPoints& points,
181 const CXTPChartColor& color, const CXTPChartColor& color2,
182 XTPChartHatchStyle nStyle);
183
184protected:
193 virtual void ExecuteOverride(CXTPChartDeviceContext* pDC);
194
195protected:
196 CXTPChartColor m_color;
197 CXTPChartColor m_color2;
198 XTPChartHatchStyle m_nStyle;
199};
200
201class _XTP_EXT_CLASS CXTPChartGdiBoundedPolygonDeviceCommand
202 : public CXTPChartBoundedPolygonDeviceCommand
203{
204public:
213 CXTPChartGdiBoundedPolygonDeviceCommand(const CXTPChartPoints& points,
214 const CXTPChartColor& color, int thickness);
215
216protected:
225 virtual void ExecuteOverride(CXTPChartDeviceContext* pDC);
226};
227
228class _XTP_EXT_CLASS CXTPChartGdiPolygonAntialiasingDeviceCommand
229 : public CXTPChartPolygonAntialiasingDeviceCommand
230{
231public:
239 CXTPChartGdiPolygonAntialiasingDeviceCommand(BOOL bAntiAlias = TRUE);
240
246 ~CXTPChartGdiPolygonAntialiasingDeviceCommand();
247
248protected:
256 virtual void BeforeExecute(CXTPChartDeviceContext* pDC);
257
265 virtual void AfterExecute(CXTPChartDeviceContext* pDC);
266
267protected:
268 long m_bOldAntiAlias;
269};
270
271# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
272#endif //#if !defined(__XTPCHARTGDIPOLYGONDEVICECOMMAND_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartBoundedPolygonDeviceCommand
Base class implementation for 2D chart bounded polygon device command.
Definition XTPChartPolygonDeviceCommand.h:79
CXTPChartColor
This class abstracts a color entity.
Definition XTPChartTypes.h:51
CXTPChartDeviceCommand::AfterExecute
virtual void AfterExecute(CXTPChartDeviceContext *pDC)
This method gets called after a command is executed which allows for the customization of command beh...
CXTPChartDeviceCommand::BeforeExecute
virtual void BeforeExecute(CXTPChartDeviceContext *pDC)
This method gets called before a command is executed which allows for the customization of command be...
CXTPChartDeviceCommand::HitTest
virtual CXTPChartElement * HitTest(CPoint point, CXTPChartElement *pParent) const
Performs recursive hit testing of the element at the specified point.
CXTPChartDeviceCommand::ExecuteOverride
virtual void ExecuteOverride(CXTPChartDeviceContext *pDC)
Override this function to write the drawing code for specific objects.
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartElement
This class abstracts a chart element, this class acts as a base class for all chart elements.
Definition XTPChartElement.h:131
CXTPChartPolygonAntialiasingDeviceCommand
Base class implementation for 2D chart antialiased polygon device command.
Definition XTPChartPolygonDeviceCommand.h:103
CXTPChartPolygonDeviceCommand
Base class implementation for 2D chart polygon device command.
Definition XTPChartPolygonDeviceCommand.h:38
CXTPChartSolidSplinePolygonDeviceCommand
Base class implementation for 2D chart solid spline polygon device command.
Definition XTPChartPolygonDeviceCommand.h:58


Toolkit Pro: Member List

CXTPPropertyGridItemCategory Member List

This is the complete list of members for CXTPPropertyGridItemCategory, including all inherited members.

AddChildItem(CXTPPropertyGridItem *pItem) | CXTPPropertyGridItem |
AddComboButton() | CXTPPropertyGridItem |
AddExpandButton() | CXTPPropertyGridItem |
AddSliderControl() | CXTPPropertyGridItem |
AddSpinButton() | CXTPPropertyGridItem |
BindToString(CString *pBindString) | CXTPPropertyGridItem |
Collapse() | CXTPPropertyGridItem |
CXTPCmdTarget() | CXTPCmdTarget |
CXTPPropertyGridItem(LPCTSTR lpszCaption, LPCTSTR strValue=NULL, CString *pBindString=NULL) | CXTPPropertyGridItem |
CXTPPropertyGridItem(UINT nID, LPCTSTR strValue=NULL, CString *pBindString=NULL) | CXTPPropertyGridItem |
CXTPPropertyGridItemCategory(LPCTSTR strCaption) | CXTPPropertyGridItemCategory |
CXTPPropertyGridItemCategory(UINT nID) | CXTPPropertyGridItemCategory |
EnsureVisible() | CXTPPropertyGridItem |
Expand() | CXTPPropertyGridItem |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCaption() const | CXTPPropertyGridItem |
GetCaptionMetrics() const | CXTPPropertyGridItem |
GetChilds() const | CXTPPropertyGridItem |
GetConstraintEdit() const | CXTPPropertyGridItem |
GetConstraints() const | CXTPPropertyGridItem |
GetDefaultValue() const | CXTPPropertyGridItem |
GetDescription() const | CXTPPropertyGridItem |
GetDropDownItemCount() const | CXTPPropertyGridItem |
GetEditStyle() const | CXTPPropertyGridItem | virtual
GetFlags() const | CXTPPropertyGridItem |
GetGrid() const | CXTPPropertyGridItem |
GetHeight() const | CXTPPropertyGridItem |
GetID() const | CXTPPropertyGridItem |
GetIndent() const | CXTPPropertyGridItem |
GetIndex() const | CXTPPropertyGridItem |
GetInplaceButtons() const | CXTPPropertyGridItem |
GetInplaceControls() const | CXTPPropertyGridItem |
GetInPlacedEditValue() | CXTPPropertyGridItem | inlineprotectedvirtual
GetInplaceEdit() | CXTPPropertyGridItem | virtual
GetInplaceList() | CXTPPropertyGridItem | protectedvirtual
GetItemData() const | CXTPPropertyGridItem |
GetItemRect() const | CXTPPropertyGridItem |
GetMarkupCaption() const | CXTPPropertyGridItem |
GetMarkupDescription() const | CXTPPropertyGridItem |
GetMarkupTemplate() const | CXTPPropertyGridItem | virtual
GetMarkupValue() const | CXTPPropertyGridItem |
GetMaskedText() const | CXTPPropertyGridItem |
GetMetrics(BOOL bValueMetrics, BOOL bCreate=TRUE) const | CXTPPropertyGridItem |
GetMultiLinesCount() const | CXTPPropertyGridItem |
GetParentItem() const | CXTPPropertyGridItem |
GetReadOnly() const | CXTPPropertyGridItem | virtual
GetTooltip() const | CXTPPropertyGridItem |
GetValue() const | CXTPPropertyGridItem |
GetValueMetrics() const | CXTPPropertyGridItem |
GetValueRect() | CXTPPropertyGridItem | virtual
GetViewValue() | CXTPPropertyGridItem | virtual
HasChilds() const | CXTPPropertyGridItem |
HasParent(CXTPPropertyGridItem *pParent) | CXTPPropertyGridItem |
HasVisibleChilds() const | CXTPPropertyGridItem |
InsertChildItem(int nIndex, CXTPPropertyGridItem *pItem) | CXTPPropertyGridItem |
IsAllowEdit() const | CXTPPropertyGridItem | virtual
IsCategory() const | CXTPPropertyGridItem |
IsExpandable() const | CXTPPropertyGridItem |
IsExpanded() const | CXTPPropertyGridItem |
IsHidden() const | CXTPPropertyGridItem |
IsInplaceButtonVisible(CXTPPropertyGridInplaceButton *pButton) const | CXTPPropertyGridItem | virtual
IsMultiLine() const | CXTPPropertyGridItem |
IsSelected() const | CXTPPropertyGridItem |
IsValueChanged() const | CXTPPropertyGridItem | virtual
IsVisible() const | CXTPPropertyGridItem |
m_bAutoComplete | CXTPPropertyGridItem | protected
m_bCategory | CXTPPropertyGridItem | protected
m_bConstraintEdit | CXTPPropertyGridItem | protected
m_bExpandable | CXTPPropertyGridItem | protected
m_bExpanded | CXTPPropertyGridItem | protected
m_bHidden | CXTPPropertyGridItem | protected
m_bPassword | CXTPPropertyGridItem | protected
m_bReadOnly | CXTPPropertyGridItem | protected
m_bUseMask | CXTPPropertyGridItem | protected
m_bVisible | CXTPPropertyGridItem | protected
m_chPrompt | CXTPPropertyGridItem | protected
m_dwData | CXTPPropertyGridItem | protected
m_dwEditStyle | CXTPPropertyGridItem | protected
m_nDropDownItemCount | CXTPPropertyGridItem | protected
m_nFlags | CXTPPropertyGridItem | protected
m_nHeight | CXTPPropertyGridItem | protected
m_nID | CXTPPropertyGridItem | protected
m_nIndent | CXTPPropertyGridItem | protected
m_nIndex | CXTPPropertyGridItem | protected
m_nLinesCount | CXTPPropertyGridItem | protected
m_pBindString | CXTPPropertyGridItem | protected
m_pCaptionMetrics | CXTPPropertyGridItem | mutableprotected
m_pChilds | CXTPPropertyGridItem | protected
m_pConstraints | CXTPPropertyGridItem | protected
m_pGrid | CXTPPropertyGridItem | protected
m_pInplaceButtons | CXTPPropertyGridItem | protected
m_pInplaceControls | CXTPPropertyGridItem | protected
m_pMarkupCaption | CXTPPropertyGridItem | protected
m_pMarkupDescription | CXTPPropertyGridItem | protected
m_pMarkupValue | CXTPPropertyGridItem | protected
m_pParent | CXTPPropertyGridItem | protected
m_pValueMetrics | CXTPPropertyGridItem | mutableprotected
m_strCaption | CXTPPropertyGridItem | protected
m_strDefaultValue | CXTPPropertyGridItem | protected
m_strDescription | CXTPPropertyGridItem | protected
m_strFormat | CXTPPropertyGridItem | protected
m_strLiteral | CXTPPropertyGridItem | protected
m_strMarkupTemplate | CXTPPropertyGridItem | protected
m_strMask | CXTPPropertyGridItem | protected
m_strTooltip | CXTPPropertyGridItem | protected
m_strValue | CXTPPropertyGridItem | protected
MeasureItem(LPMEASUREITEMSTRUCT lpMeasureItemStruct) | CXTPPropertyGridItem | virtual
Move(CXTPPropertyGridItem *pParent, int nIndex=-1) | CXTPPropertyGridItem |
NotifyValueChanged() | CXTPPropertyGridItem | protected
OnAddChildItem() | CXTPPropertyGridItem | protectedvirtual
OnAfterEdit(CString &strValue) | CXTPPropertyGridItem | virtual
OnBeforeInsert() | CXTPPropertyGridItem | protectedvirtual
OnCancelEdit() | CXTPPropertyGridItem | virtual
OnCaptionChanged() | CXTPPropertyGridItem | protectedvirtual
OnChar(UINT nChar) | CXTPPropertyGridItem | protectedvirtual
OnConstraintsChanged() | CXTPPropertyGridItem | protectedvirtual
OnDeselect() | CXTPPropertyGridItem | protectedvirtual
OnDrawItemConstraint(CDC *pDC, CXTPPropertyGridItemConstraint *pConstraint, CRect rc, BOOL bSelected) | CXTPPropertyGridItem | virtual
OnDrawItemValue(CDC &dc, CRect rcValue) | CXTPPropertyGridItem | virtual
OnIndexChanged() | CXTPPropertyGridItem | protectedvirtual
OnInpaceControlFocus(BOOL bForward) | CXTPPropertyGridItem | protectedvirtual
OnInplaceButtonDown(CXTPPropertyGridInplaceButton *pButton) | CXTPPropertyGridItem | protectedvirtual
OnKeyDown(UINT nChar) | CXTPPropertyGridItem | protectedvirtual
OnLButtonDblClk(UINT nFlags, CPoint point) | CXTPPropertyGridItem | protectedvirtual
OnLButtonDown(UINT nFlags, CPoint point) | CXTPPropertyGridItem | protectedvirtual
OnLButtonUp(UINT nFlags, CPoint point) | CXTPPropertyGridItem | protectedvirtual
OnMarkupChanged() | CXTPPropertyGridItem | virtual
OnMergeItemConstraint(CDC *pDC, CXTPPropertyGridItemConstraint *pConstraint) | CXTPPropertyGridItem | virtual
OnRButtonDown(UINT nFlags, CPoint point) | CXTPPropertyGridItem | protectedvirtual
OnRequestEdit() | CXTPPropertyGridItem | virtual
OnSelect() | CXTPPropertyGridItem | protectedvirtual
OnValidateEdit() | CXTPPropertyGridItem | virtual
OnValueChanged(CString strValue) | CXTPPropertyGridItem | virtual
PtInValueRect(CPoint point) | CXTPPropertyGridItem | protected
RedrawItem() | CXTPPropertyGridItem |
Remove() | CXTPPropertyGridItem |
ResetValue() | CXTPPropertyGridItem | virtual
Select() | CXTPPropertyGridItem |
SelectNextConstraint() | CXTPPropertyGridItem | protected
SetAutoComplete(BOOL bAutoComplete=TRUE) | CXTPPropertyGridItem |
SetCaption(LPCTSTR lpszCaption) | CXTPPropertyGridItem |
SetConstraintEdit(BOOL bConstraintEdit=TRUE) | CXTPPropertyGridItem |
SetDefaultValue(LPCTSTR lpszDefaultValue) | CXTPPropertyGridItem |
SetDescription(LPCTSTR lpszDescription) | CXTPPropertyGridItem |
SetDropDownItemCount(int nDropDownItemCount) | CXTPPropertyGridItem |
SetEditStyle(DWORD dwEditStyle) | CXTPPropertyGridItem |
SetEditText(const CString &str) | CXTPPropertyGridItem | protectedvirtual
SetExpandable(BOOL bExpandable) | CXTPPropertyGridItem |
SetFlags(UINT nFlags) | CXTPPropertyGridItem |
SetFocusToInplaceControl() | CXTPPropertyGridItem | virtual
SetHeight(int nHeight) | CXTPPropertyGridItem |
SetHidden(BOOL bHidden) | CXTPPropertyGridItem |
SetID(UINT nID) | CXTPPropertyGridItem |
SetItemData(DWORD_PTR dwData) | CXTPPropertyGridItem |
SetMarkupTemplate(LPCTSTR lpstrMarkupTemplate) | CXTPPropertyGridItem |
SetMask(LPCTSTR strMask, LPCTSTR strLiteral, TCHAR chPrompt=_T('_')) | CXTPPropertyGridItem |
SetMaskedText(LPCTSTR lpszMaskedText) | CXTPPropertyGridItem |
SetMultiLinesCount(int nLinesCount) | CXTPPropertyGridItem |
SetPasswordMask(TCHAR chMask=_T(' *')) | CXTPPropertyGridItem |
SetPrompt(LPCTSTR lpszPrompt) | CXTPPropertyGridItem |
SetReadOnly(BOOL bReadOnly=TRUE) | CXTPPropertyGridItem | virtual
SetTooltip(LPCTSTR lpstrTooltip) | CXTPPropertyGridItem |
SetValue(CString strValue) | CXTPPropertyGridItem | virtual
SetVisible(BOOL bVisible) | CXTPPropertyGridItem | protectedvirtual
~CXTPPropertyGridItem() | CXTPPropertyGridItem | virtual


Toolkit Pro: Member List

  • CXTPNotifyConnection
  • CONNECTION_DESCRIPTOR
CXTPNotifyConnection::CONNECTION_DESCRIPTOR Member List

This is the complete list of members for CXTPNotifyConnection::CONNECTION_DESCRIPTOR, including all inherited members.

dwConnectionID | CXTPNotifyConnection::CONNECTION_DESCRIPTOR
dwNotifyCode | CXTPNotifyConnection::CONNECTION_DESCRIPTOR
pSink | CXTPNotifyConnection::CONNECTION_DESCRIPTOR


Toolkit Pro: Member List

CXTPChartStepLineSeriesStyle Member List

This is the complete list of members for CXTPChartStepLineSeriesStyle, including all inherited members.

ApplyTo(CXTPChartDeviceCommand *pCommand) | CXTPChartSeriesStyle | virtual
CorrectAxisSideMargins(CXTPChartAxis *pAxis, double nMinValue, double nMaxValue, double &nCorrection) | CXTPChartSeriesStyle | virtual
CreateDiagram() | CXTPChartDiagram2DSeriesStyle | virtual
CreateView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView) | CXTPChartStepLineSeriesStyle | protectedvirtual
CXTPChartDiagram2DSeriesStyle() | CXTPChartDiagram2DSeriesStyle |
CXTPChartElement() | CXTPChartElement |
CXTPChartLineSeriesStyle() | CXTPChartLineSeriesStyle |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartPointSeriesStyle() | CXTPChartPointSeriesStyle |
CXTPChartSeriesStyle() | CXTPChartSeriesStyle |
CXTPChartStepLineSeriesStyle() | CXTPChartStepLineSeriesStyle |
DoPropExchange(CXTPPropExchange *pPX) | CXTPChartStepLineSeriesStyle | protectedvirtual
Enable3dEdgeSmoothing(BOOL bEnable=TRUE) | CXTPChartSeriesStyle | virtual
Get3dRotation() const | CXTPChartSeriesStyle | virtual
GetAppearance() const | CXTPChartElement |
GetColor() const | CXTPChartSeriesStyle | virtual
GetContent() const | CXTPChartElement |
GetErrorBar() const | CXTPChartSeriesStyle | virtual
GetInvertedStep() const | CXTPChartStepLineSeriesStyle |
GetLabel() const | CXTPChartSeriesStyle | virtual
GetLineStyle() const | CXTPChartLineSeriesStyle |
GetMarker() const | CXTPChartPointSeriesStyle |
GetOwner() const | CXTPChartElement |
GetSeriesPointValueIndex() const | CXTPChartSeriesStyle | virtual
GetStyleAppearance() const | CXTPChartSeriesStyle | virtual
GetTransparency() const | CXTPChartSeriesStyle | virtual
Is3D() const | CXTPChartObject |
Is3dEdgeSmoothingEnabled() const | CXTPChartSeriesStyle | virtual
IsColorEach() const | CXTPChartSeriesStyle | virtual
IsStyleDiagram(CXTPChartDiagram *pDiagram) const | CXTPChartDiagram2DSeriesStyle | virtual
m_bColorEach | CXTPChartSeriesStyle | protected
m_bSmooth3dEdges | CXTPChartSeriesStyle | protected
m_clrColor | CXTPChartSeriesStyle | protected
m_nAxisIndexX | CXTPChartDiagram2DSeriesStyle | protected
m_nAxisIndexY | CXTPChartDiagram2DSeriesStyle | protected
m_nTransparency | CXTPChartSeriesStyle | protected
m_pErrorBar | CXTPChartSeriesStyle | protected
m_pLabel | CXTPChartSeriesStyle | protected
m_pLineStyle | CXTPChartLineSeriesStyle | protected
m_Rotation3d | CXTPChartSeriesStyle | protected
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartElement | virtual
Release() | CXTPChartElement | virtual
Set3dRotation(const CXTPChart3dRotation &rotation) | CXTPChartSeriesStyle | virtual
Set3dRotation(double dYaw, double dPitch, double dRoll) | CXTPChartSeriesStyle | virtual
SetColor(CXTPChartColor clr) | CXTPChartSeriesStyle | virtual
SetColorEach(BOOL bColorEach) | CXTPChartSeriesStyle | virtual
SetErrorBar(CXTPChartErrorBar *pErrorBar) | CXTPChartSeriesStyle | virtual
SetInvertedStep(BOOL bInvertedStep) | CXTPChartStepLineSeriesStyle |
SetLabel(CXTPChartSeriesLabel *pLabel) | CXTPChartSeriesStyle | virtual
SetTransparency(int nTransparency) | CXTPChartSeriesStyle | virtual
~CXTPChartDiagram2DSeriesStyle() | CXTPChartDiagram2DSeriesStyle | virtual
~CXTPChartElement() | CXTPChartElement | virtual
~CXTPChartLineSeriesStyle() | CXTPChartLineSeriesStyle | virtual
~CXTPChartPointSeriesStyle() | CXTPChartPointSeriesStyle | virtual
~CXTPChartSeriesStyle() | CXTPChartSeriesStyle | virtual
~CXTPChartStepLineSeriesStyle() | CXTPChartStepLineSeriesStyle | virtual


Toolkit Pro: XTPTaskPanelNativeWindows11Theme.h Source File

  • Source
  • TaskPanel
  • Themes
XTPTaskPanelNativeWindows11Theme.h
Go to the documentation of this file.
1
23#if !defined(__XTPTASKPANELNATIVEWINDOWS11THEME_H__)
24# define __XTPTASKPANELNATIVEWINDOWS11THEME_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
39class _XTP_EXT_CLASS CXTPTaskPanelNativeWindows11Theme : public CXTPTaskPanelVisualStudio2012Theme
40{
41protected:
42 void Triangle(CDC* pDC, POINT* pPoints, COLORREF clr, BOOL bFilled);
43
44public:
49 CXTPTaskPanelNativeWindows11Theme();
50
56 virtual ~CXTPTaskPanelNativeWindows11Theme();
57
62 virtual void RefreshMetrics();
63};
65# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
66#endif // __XTPTASKPANELNATIVEWINDOWS11THEME_H__
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPTaskPanelNativeWindows11Theme
CXTPTaskPanelNativeWindows11Theme represents a Native Windows 10 style theme.
Definition XTPTaskPanelNativeWindows11Theme.h:40
CXTPTaskPanelNativeWindows11Theme::~CXTPTaskPanelNativeWindows11Theme
virtual ~CXTPTaskPanelNativeWindows11Theme()
Destroys a CXTPTaskPanelNativeWindows11Theme object, handles cleanup and deallocation.
CXTPTaskPanelNativeWindows11Theme::CXTPTaskPanelNativeWindows11Theme
CXTPTaskPanelNativeWindows11Theme()
Constructs a CXTPTaskPanelNativeWindows11Theme object.
CXTPTaskPanelNativeWindows11Theme::RefreshMetrics
virtual void RefreshMetrics()
Refreshes the visual metrics of the task panel.
CXTPTaskPanelVisualStudio2012Theme
CXTPTaskPanelVisualStudio2012Theme represents a VS.NET 2012 style theme.
Definition XTPTaskPanelVisualStudio2012Theme.h:40


Toolkit Pro: Member List

CXTPGridInplaceEdit Member List

This is the complete list of members for CXTPGridInplaceEdit, including all inherited members.

CanOverType() const | CXTPMaskEditT< CEdit > | inline
CanUseMask() const | CXTPMaskEditT< CEdit > | inline
CheckChar(TCHAR &nChar, int nPos) | CXTPMaskEditT< CEdit > | inlinevirtual
ConvertUnicodeAlpha(TCHAR nChar, BOOL bUpperCase) const | CXTPMaskEditT< CEdit > | inline
CopyToClipboard(const CString &strText) | CXTPMaskEditT< CEdit > | inline
Create(XTP_GRIDRECORDITEM_ARGS *pItemArgs) | CXTPGridInplaceEdit |
CXTPGridInplaceControl() | CXTPGridInplaceControl |
CXTPGridInplaceEdit() | CXTPGridInplaceEdit |
CXTPMaskEditT() | CXTPMaskEditT< CEdit > | inline
DeleteCharAt(int iPos) | CXTPMaskEditT< CEdit > | inline
GetItem() const | CXTPGridInplaceEdit |
GetMaskedText(int nStartPos=0, int nEndPos=-1) const | CXTPMaskEditT< CEdit > | inline
GetPromptChar() const | CXTPMaskEditT< CEdit > | inline
GetPromptString(int nLength) const | CXTPMaskEditT< CEdit > | inline
HideWindow() | CXTPGridInplaceEdit |
InsertCharAt(int iPos, TCHAR nChar) | CXTPMaskEditT< CEdit > | inline
IsModified() const | CXTPMaskEditT< CEdit > | inline
m_bModified | CXTPMaskEditT< CEdit > | protected
m_bOverType | CXTPMaskEditT< CEdit > | protected
m_bRedo | CXTPMaskEditT< CEdit > | protected
m_bSetWindowText | CXTPGridInplaceEdit | protected
m_bUpdateUndo | CXTPMaskEditT< CEdit > | protected
m_bUseMask | CXTPMaskEditT< CEdit > | protected
m_chPrompt | CXTPMaskEditT< CEdit > | protected
m_clrBack | CXTPGridInplaceEdit | protected
m_clrText | CXTPGridInplaceEdit | protected
m_nEndChar | CXTPMaskEditT< CEdit > | protected
m_nStartChar | CXTPMaskEditT< CEdit > | protected
m_pSelectedConstraint | CXTPGridInplaceEdit | protected
m_strDefault | CXTPMaskEditT< CEdit > | protected
m_strLiteral | CXTPMaskEditT< CEdit > | protected
m_strMask | CXTPMaskEditT< CEdit > | protected
m_strRedoBuffer | CXTPMaskEditT< CEdit > | protected
m_strText_prev | CXTPGridInplaceEdit | protected
m_strUndoBuffer | CXTPMaskEditT< CEdit > | protected
m_strValue | CXTPGridInplaceEdit | protected
m_strWindowText | CXTPMaskEditT< CEdit > | protected
m_xtpBrushBack | CXTPGridInplaceEdit | protected
m_xtpFontEdit | CXTPGridInplaceEdit | protected
MaskClear() | CXTPMaskEditT< CEdit > | inline
MaskCopy() | CXTPMaskEditT< CEdit > | inline
MaskCut() | CXTPMaskEditT< CEdit > | inline
MaskDeleteSel() | CXTPMaskEditT< CEdit > | inline
MaskPaste() | CXTPMaskEditT< CEdit > | inline
MaskReplaceSel(LPCTSTR lpszNewText) | CXTPMaskEditT< CEdit > | inline
MaskSelectAll() | CXTPMaskEditT< CEdit > | inline
MaskUndo() | CXTPMaskEditT< CEdit > | inline
OnCommand(WPARAM wParam, LPARAM lParam) | CXTPMaskEditT< CEdit > | inlineprotectedvirtual
pColumn | XTP_GRIDRECORDITEM_ARGS |
pControl | XTP_GRIDRECORDITEM_ARGS |
pItem | XTP_GRIDRECORDITEM_ARGS |
PosInRange(int iPos) const | CXTPMaskEditT< CEdit > | inline
PreTranslateMessage(MSG *pMsg) | CXTPMaskEditT< CEdit > | inlinevirtual
ProcessMask(TCHAR &nChar, int nEndPos) | CXTPMaskEditT< CEdit > | inlinevirtual
pRow | XTP_GRIDRECORDITEM_ARGS |
rcItem | XTP_GRIDRECORDITEM_ARGS |
SetEditMask(LPCTSTR lpszMask, LPCTSTR lpszLiteral, LPCTSTR lpszDefault=NULL) | CXTPMaskEditT< CEdit > | inlinevirtual
SetFont(CFont *pFont) | CXTPGridInplaceEdit | protected
SetItemArgs(XTP_GRIDRECORDITEM_ARGS *pItemArgs) | CXTPGridInplaceControl | protectedvirtual
SetMaskedText(LPCTSTR lpszMaskedText, int iPos=0, BOOL bUpdateWindow=TRUE) | CXTPMaskEditT< CEdit > | inline
SetOverType(BOOL bOverType) | CXTPMaskEditT< CEdit > | inline
SetPromptChar(TCHAR ch, BOOL bAutoReplace=TRUE) | CXTPMaskEditT< CEdit > | inline
SetUseMask(BOOL bUseMask) | CXTPMaskEditT< CEdit > | inline
SetWindowText(LPCTSTR lpszString) | CXTPGridInplaceEdit |
~CXTPGridInplaceControl() | CXTPGridInplaceControl | virtual
~CXTPGridInplaceEdit() | CXTPGridInplaceEdit | virtual


Toolkit Pro: Member List

CXTPToolTipContextToolTip Member List

This is the complete list of members for CXTPToolTipContextToolTip, including all inherited members.

CXTPToolTipContextToolTip(CXTPToolTipContext *pContext) | CXTPToolTipContextToolTip |
DrawBackground(CDC *pDC, TOOLITEM *lpToolInfo, CRect rc) | CXTPToolTipContextToolTip | protectedvirtual
DrawEntry(CDC *pDC, TOOLITEM *lpToolInfo, CRect rc) | CXTPToolTipContextToolTip | protectedvirtual
GetToolSize(TOOLITEM *lpToolInfo) | CXTPToolTipContextToolTip | protectedvirtual
m_arrTools | CXTPToolTipContextToolTip | protected
m_bActive | CXTPToolTipContextToolTip | protected
m_dwLastTip | CXTPToolTipContextToolTip | protected
m_hHookMouse | CXTPToolTipContextToolTip | protectedstatic
m_nAutoPopTimer | CXTPToolTipContextToolTip | protected
m_nDelayAutoPop | CXTPToolTipContextToolTip | protected
m_nDelayInitial | CXTPToolTipContextToolTip | protected
m_nDelayReshow | CXTPToolTipContextToolTip | protected
m_nDelayTimer | CXTPToolTipContextToolTip | protected
m_pContext | CXTPToolTipContextToolTip | protected
m_pIcon | CXTPToolTipContextToolTip | protected
m_pWndMonitor | CXTPToolTipContextToolTip | protectedstatic
m_strTitle | CXTPToolTipContextToolTip | protected
m_toolDelay | CXTPToolTipContextToolTip | protected
m_toolDisabled | CXTPToolTipContextToolTip | protected
m_toolVisible | CXTPToolTipContextToolTip | protected
~CXTPToolTipContextToolTip() | CXTPToolTipContextToolTip | virtual


Toolkit Pro: XTPRibbonBackstageSeparator.h Source File

  • Source
  • Ribbon
  • Backstage
XTPRibbonBackstageSeparator.h
Go to the documentation of this file.
1
23#if !defined(__XTPRIBBONBACKATAGESEPARATOR_H__)
24# define __XTPRIBBONBACKATAGESEPARATOR_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33# ifndef CXTPRibbonBackstageSeparatorBase
34# define CXTPRibbonBackstageSeparatorBase CStatic
35# endif
36
37class CXTPMarkupContext;
38class CXTPMarkupUIElement;
39
40class CXTPRibbonBackstageSeparatorPaintManager;
41
42class _XTP_EXT_CLASS CXTPRibbonBackstageSeparator : public CXTPRibbonBackstageSeparatorBase
43{
44 DECLARE_DYNCREATE(CXTPRibbonBackstageSeparator);
45
46public:
47 CXTPRibbonBackstageSeparator();
48 virtual ~CXTPRibbonBackstageSeparator();
49
50public:
51 virtual BOOL SetTheme(XTPControlTheme theme);
52
53 BOOL IsVerticalStyle() const;
54
55 void SetVerticalStyle(BOOL bVerticalStyle);
56
57public:
58 //{{AFX_VIRTUAL(CXTPRibbonBackstageSeparator)
59 virtual void OnDraw(CDC* pDC);
60 //}}AFX_VIRTUAL
61
62protected:
63 DECLARE_MESSAGE_MAP()
64 //{{AFX_MSG(CXTPRibbonBackstageSeparator)
65 afx_msg void OnPaint();
66 afx_msg BOOL OnEraseBkgnd(CDC* pDC);
67 //}}AFX_MSG
68
69protected:
70 CXTPRibbonBackstageSeparatorPaintManager* m_pTheme;
71
72 BOOL m_bVerticalStyle;
73
74 CXTPMarkupContext* m_pMarkupContext;
75 CXTPMarkupUIElement* m_pMarkupUIElement;
76};
77
78AFX_INLINE BOOL CXTPRibbonBackstageSeparator::IsVerticalStyle() const
79{
80 return m_bVerticalStyle;
81}
82
83AFX_INLINE void CXTPRibbonBackstageSeparator::SetVerticalStyle(BOOL bVerticalStyle)
84{
85 m_bVerticalStyle = bVerticalStyle;
86}
87
88# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
90#endif // !defined(__XTPRIBBONBACKATAGESEPARATOR_H__)
XTPControlTheme
XTPControlTheme
Enumeration used to determine the active theme style.
Definition XTPControlTheme.h:43
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPMarkupContext
CXTPMarkupContext is a standalone class used to provide common settings for Markup objects.
Definition XTPMarkupContext.h:128
CXTPMarkupUIElement
Base class for XML Markup core level implementations.
Definition XTPMarkupUIElement.h:43


Toolkit Pro: Member List

CXTPFrameShadow Member List

This is the complete list of members for CXTPFrameShadow, including all inherited members.

Create(COLORREF crColor, UINT nOuterSize, UINT nInnerSize=0, CPoint ptOffset=CPoint(0, 0), BYTE bTransparency=0x80) | CXTPFrameShadow |
CXTPFrameShadow(HWND hOwner) | CXTPFrameShadow | explicit
FreezeUpdates(BOOL bFreeze=TRUE) | CXTPFrameShadow |
GetBlendingOptions(OUT OPTIONAL float *pFactors, OUT OPTIONAL float *pPositions) const | CXTPFrameShadow |
GetClipOwner() const | CXTPFrameShadow |
GetColor() const | CXTPFrameShadow |
GetInnerSize() const | CXTPFrameShadow |
GetOffset() const | CXTPFrameShadow |
GetOuterSize() const | CXTPFrameShadow |
GetOwner() const | CXTPFrameShadow |
GetTransparency() const | CXTPFrameShadow |
Hide() | CXTPFrameShadow |
IsCreated() const | CXTPFrameShadow |
IsShadowSupported() | CXTPFrameShadow | static
OnFlagsChanged(CXTPFrameShadowManager *pManager, int nOldEffectiveFlags, int nNewEffectiveFlags) | CXTPFrameShadow | protectedvirtual
SetBlendingOptions(UINT nCount, const float *pFactors, const float *pPositions) | CXTPFrameShadow |
SetClipOwner(BOOL bClipOwner) | CXTPFrameShadow |
SetColor(COLORREF crColor) | CXTPFrameShadow |
SetInnerSize(UINT nSize) | CXTPFrameShadow |
SetOffset(CPoint ptOffset) | CXTPFrameShadow |
SetOuterSize(UINT nSize) | CXTPFrameShadow |
SetTransparency(BYTE bTransparency) | CXTPFrameShadow |
Show() | CXTPFrameShadow |
UpdatePosition() | CXTPFrameShadow |
~CXTPFrameShadow() | CXTPFrameShadow | virtual


Toolkit Pro: XTPSystemPreviewProvider.h Source File

  • Source
  • Controls
  • Preview
  • Providers
  • System
XTPSystemPreviewProvider.h
Go to the documentation of this file.
1
23#if !defined(__XTPSYSTEMPREVIEWPROVIDER_H__)
24# define __XTPSYSTEMPREVIEWPROVIDER_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
42class _XTP_EXT_CLASS CXTPSystemPreviewProvider : public CXTPPreviewProviderBase
43{
44private:
45 virtual LPCTSTR GetDefaultFileAssociations() const;
46 virtual IXTPPreview* CreatePreview(LPCTSTR pFilePath, HWND hwndParent);
47 virtual IXTPPreview* CreatePreview(IStream& stream, LPCTSTR pImpliedFileName, HWND hwndParent);
48};
49
50# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
52#endif // #if !defined(__XTPSYSTEMPREVIEWPROVIDER_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPPreviewProviderBase
Base class for a preview provider which implements common behavior to be exposed by a preview provide...
Definition XTPPreviewAbstract.h:251
CXTPSystemPreviewProvider
Provides a preview handler that uses supported system means for previewing files.
Definition XTPSystemPreviewProvider.h:43
IXTPPreview
The base interface for a preview handler implementation.
Definition XTPPreviewAbstract.h:40
IXTPPreviewProvider::GetDefaultFileAssociations
virtual LPCTSTR GetDefaultFileAssociations() const =0
Obtains the list of file extensions supported by the associated preview implementation.
IXTPPreviewProvider::CreatePreview
virtual IXTPPreview * CreatePreview(LPCTSTR pFilePath, HWND hwndParent)=0
Creates a preview object for the specified file.


Toolkit Pro: Member List

  • CXTPColorSelectorCtrl
  • COLOR_CELL
CXTPColorSelectorCtrl::COLOR_CELL Member List

This is the complete list of members for CXTPColorSelectorCtrl::COLOR_CELL, including all inherited members.

bChecked | CXTPColorSelectorCtrl::COLOR_CELL
clr | CXTPColorSelectorCtrl::COLOR_CELL
dwStyle | CXTPColorSelectorCtrl::COLOR_CELL
nID | CXTPColorSelectorCtrl::COLOR_CELL
nIndex | CXTPColorSelectorCtrl::COLOR_CELL
rcBorder | CXTPColorSelectorCtrl::COLOR_CELL
rect | CXTPColorSelectorCtrl::COLOR_CELL
szText | CXTPColorSelectorCtrl::COLOR_CELL


Toolkit Pro: XTPMessageBarThemeVisualStudio2019.h Source File

  • Source
  • CommandBars
  • MessageBar
XTPMessageBarThemeVisualStudio2019.h
Go to the documentation of this file.
1
23#if !defined(__XTPMESSAGEBARTHEMEVISUALSTUDIO2019_H__)
24# define __XTPMESSAGEBARTHEMEVISUALSTUDIO2019_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPPaintManager;
34class CXTPMessageBar;
35class CXTPMessageBarButton;
36
42class _XTP_EXT_CLASS CXTPMessageBarThemeVisualStudio2019 : public CXTPMessageBarThemeOffice2013
43{
44public:
50 CXTPMessageBarThemeVisualStudio2019(CXTPPaintManager* pPaintManager);
51};
52
54# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
55#endif // !defined(__XTPMESSAGEBARTHEMEVISUALSTUDIO2019_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPMessageBarButton
CXTPMessageBarButton is a standalone class.
Definition XTPMessageBar.h:48
CXTPMessageBar
CXTPMessageBar is a CControlBar derived class.
Definition XTPMessageBar.h:88
CXTPMessageBarThemeOffice2013
The CXTPMessageBarThemeOffice2013 class is used by the message bar to draw an Office 2013 style messa...
Definition XTPMessageBarThemeOffice2013.h:43
CXTPMessageBarThemeVisualStudio2019
The CXTPMessageBarThemeVisualStudio2019 class is used by the message bar to draw a Visual Studio 2019...
Definition XTPMessageBarThemeVisualStudio2019.h:43
CXTPMessageBarThemeVisualStudio2019::CXTPMessageBarThemeVisualStudio2019
CXTPMessageBarThemeVisualStudio2019(CXTPPaintManager *pPaintManager)
Message bar constructor.
CXTPPaintManager
Paint manager of the command bars.
Definition XTPPaintManager.h:199


Toolkit Pro: XTPSkinObjectMDI.h Source File

  • Source
  • SkinFramework
XTPSkinObjectMDI.h
Go to the documentation of this file.
1
23#if !defined(__XTPSKINOBJECTMDI_H__)
24# define __XTPSKINOBJECTMDI_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
35class _XTP_EXT_CLASS CXTPSkinObjectMDIClient : public CXTPSkinObjectFrame
36{
38 DECLARE_DYNCREATE(CXTPSkinObjectMDIClient)
40public:
41 CXTPSkinObjectMDIClient();
42 virtual ~CXTPSkinObjectMDIClient();
43
44protected:
45 BOOL m_bArrange;
46
47protected:
48 DECLARE_MESSAGE_MAP()
49
50 //{{AFX_VIRTUAL(CXTPSkinObjectMDIClient)
51 BOOL IsDefWindowProcAvail(int /*nMessage*/) const;
52 void OnHookAttached(LPCREATESTRUCT lpcs, BOOL bAuto);
53 void OnHookDetached(BOOL bAuto);
54 //}}AFX_VIRTUAL
55
56 //{{AFX_MSG(CXTPSkinObjectMDIClient)
57 afx_msg void OnHScroll(UINT nSBCode, UINT nPos, CScrollBar* pScrollBar);
58 afx_msg void OnVScroll(UINT nSBCode, UINT nPos, CScrollBar* pScrollBar);
59 afx_msg LRESULT OnCalcScroll(WPARAM, LPARAM);
60 afx_msg BOOL OnNcActivate(BOOL bActive);
61 afx_msg void OnSize(UINT nType, int cx, int cy);
62 afx_msg void OnMDIArrange();
63 //}}AFX_MSG
64
65 CXTPSkinObjectFrame* m_pMDIParent;
66};
69# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
71#endif // !defined(__XTPSKINOBJECTMDI_H__)
XTPDisableNoisyWarnings.h
CXTPSkinObjectFrame
CXTPSkinObjectFrame is a CXTPSkinObject derived class.
Definition XTPSkinObjectFrame.h:75


Toolkit Pro: Member List

CXTPColorSetStateCheckMark Member List

This is the complete list of members for CXTPColorSetStateCheckMark, including all inherited members.

clrBack | CXTPColorSetStateCheckMark |
clrBackDisabled | CXTPColorSetStateCheckMark |
clrBackHighlight | CXTPColorSetStateCheckMark |
clrBackPushed | CXTPColorSetStateCheckMark |
clrCheck | CXTPColorSetStateCheckMark |
clrCheckDisabled | CXTPColorSetStateCheckMark |
clrCheckHighlight | CXTPColorSetStateCheckMark |
clrCheckPushed | CXTPColorSetStateCheckMark |
RefreshColors() | CXTPColorSetStateCheckMark | virtual
~CXTPColorSetStateCheckMark() | CXTPColorSetStateCheckMark | inlinevirtual


Toolkit Pro: XTPGaugeTraits.h Source File

  • Source
  • Gauge
XTPGaugeTraits.h
Go to the documentation of this file.
1
22#if !defined(__XTPGAUGETRAITS_H__)
23# define __XTPGAUGETRAITS_H__
24
25# if _MSC_VER > 1000
26# pragma once
27# endif // _MSC_VER > 1000
28
29# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
30
31class CXTPGaugeBaseType;
32
37class _XTP_EXT_CLASS CXTPGaugeTraits : public CObject
38{
39 friend class CXTPGaugeBaseType;
40
41 DECLARE_DYNAMIC(CXTPGaugeTraits);
42
43public:
48 CXTPGaugeTraits();
49
64 CXTPGaugeTraits(IStream& stream, CString strTraitsArg = CString());
65
80 CXTPGaugeTraits(CString strTraits, CString strTraitsArg = CString());
81
86 ~CXTPGaugeTraits();
87
102 const CString& GetTraits() const;
103
117 void SetTraits(CString strTraits);
118
133 const CString& GetTraitsArgument() const;
134
149 void SetTraitsArgument(CString strTraitsArg);
150
184 COleVariant* GetCustomTrait(CString strJsonPath) const;
185
218 void SetCustomTrait(CString strJsonPath, COleVariant vtValue);
219
229 POSITION EnumCustomTraits() const;
230
247 BOOL GetNextCustomTrait(POSITION& pos, CString& strJsonPath, COleVariant*& pValue) const;
248
258 const CString& GetResourcePath() const;
259
268 void SetResourcePath(CString strPath);
269
270 //-----------------------------------------------------------------------
271 // Summary:
272 // Gets/sets resource module handle and resource namespace to be used by the gauge
273 // implementation to load images and other assets from. Setting a new value will also
274 // invalidate the traits argument value.
275 // Parameters:
276 // hResMod - Resource module handle. NULL handle value will make traits argument an empty
277 // string.
278 // pNamespace - An optional string to be added as a resource name prefix for all requested
279 // gauge resources. The string must contain only alpha-numeric a hyphen and a underscore
280 // symbols.
281 // Returns:
282 // Current resource handle module and resource namespace.
283 // See also:
284 // GetResourcePath, SetResourcePath
285 //-----------------------------------------------------------------------
286
297 HMODULE GetResourceModule() const;
298
309 const CString& GetResourceNamespace() const;
310
325 BOOL SetResourceModule(HMODULE hResMod, LPCTSTR pNamespace = NULL);
326
327private:
328 CString GetCompositeTraitsArgument() const;
329
330private:
331 CString m_strTraits;
332 CString m_strTraitsArg;
333 CString m_strResPathTraits;
334 CMapStringToPtr m_customTraits;
335 CString m_strResPath;
336 CString m_strResNamespace;
337 HMODULE m_hResMod;
338};
339
340AFX_INLINE CXTPGaugeTraits::CXTPGaugeTraits()
341{
342}
343
344AFX_INLINE CXTPGaugeTraits::CXTPGaugeTraits(CString strTraits, CString strTraitsArg /*= CString()*/)
345 : m_strTraits(strTraits)
346 , m_strTraitsArg(strTraitsArg)
347 , m_hResMod(NULL)
348{
349}
350
351AFX_INLINE void CXTPGaugeTraits::SetTraits(CString strTraits)
352{
353 m_strTraits = strTraits;
354}
355
356AFX_INLINE const CString& CXTPGaugeTraits::GetTraits() const
357{
358 return m_strTraits;
359}
360
361AFX_INLINE void CXTPGaugeTraits::SetTraitsArgument(CString strTraitsArg)
362{
363 m_strTraitsArg = strTraitsArg;
364}
365
366AFX_INLINE const CString& CXTPGaugeTraits::GetTraitsArgument() const
367{
368 return m_strTraitsArg;
369}
370
371AFX_INLINE POSITION CXTPGaugeTraits::EnumCustomTraits() const
372{
373 return m_customTraits.GetStartPosition();
374}
375
376AFX_INLINE const CString& CXTPGaugeTraits::GetResourcePath() const
377{
378 return m_strResPath;
379}
380
381AFX_INLINE HMODULE CXTPGaugeTraits::GetResourceModule() const
382{
383 return m_hResMod;
384}
385
386AFX_INLINE const CString& CXTPGaugeTraits::GetResourceNamespace() const
387{
388 return m_strResNamespace;
389}
390
391# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
392
393#endif // !defined(__XTPGAUGETRAITS_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPGaugeBaseType
A base class for all gauge types.
Definition XTPGaugeBaseType.h:44
CXTPGaugeTraits
Defines a set of loaded gauge traits.
Definition XTPGaugeTraits.h:38
CXTPGaugeTraits::CXTPGaugeTraits
CXTPGaugeTraits(IStream &stream, CString strTraitsArg=CString())
Loads a set of gauge traits from the specified source.
CXTPGaugeTraits::SetTraits
void SetTraits(CString strTraits)
Sets gauge traits data.
Definition XTPGaugeTraits.h:351
CXTPGaugeTraits::GetResourcePath
const CString & GetResourcePath() const
Gets the resource path to be used by the gauge implementation to load images and other assets from.
Definition XTPGaugeTraits.h:376
CXTPGaugeTraits::GetTraitsArgument
const CString & GetTraitsArgument() const
Gets gauge traits data argument.
Definition XTPGaugeTraits.h:366
CXTPGaugeTraits::GetCustomTrait
COleVariant * GetCustomTrait(CString strJsonPath) const
Gets a custom value of a gauge trait.
CXTPGaugeTraits::SetResourcePath
void SetResourcePath(CString strPath)
Sets the resource path to be used by the gauge implementation to load images and other assets from.
CXTPGaugeTraits::GetResourceModule
HMODULE GetResourceModule() const
Gets resource module handle to be used by the gauge implementation to load images and other assets fr...
Definition XTPGaugeTraits.h:381
CXTPGaugeTraits::GetNextCustomTrait
BOOL GetNextCustomTrait(POSITION &pos, CString &strJsonPath, COleVariant *&pValue) const
Enumerates specified custom trait paths and values.
CXTPGaugeTraits::EnumCustomTraits
POSITION EnumCustomTraits() const
Start custom traits enumeration.
Definition XTPGaugeTraits.h:371
CXTPGaugeTraits::SetCustomTrait
void SetCustomTrait(CString strJsonPath, COleVariant vtValue)
Sets a custom value of a gauge trait.
CXTPGaugeTraits::GetTraits
const CString & GetTraits() const
Gets gauge traits data.
Definition XTPGaugeTraits.h:356
CXTPGaugeTraits::~CXTPGaugeTraits
~CXTPGaugeTraits()
Handles traits set destruction.
CXTPGaugeTraits::SetTraitsArgument
void SetTraitsArgument(CString strTraitsArg)
Sets gauge traits data argument.
Definition XTPGaugeTraits.h:361
CXTPGaugeTraits::CXTPGaugeTraits
CXTPGaugeTraits()
Initializes an empty set of gauge traits.
Definition XTPGaugeTraits.h:340
CXTPGaugeTraits::SetResourceModule
BOOL SetResourceModule(HMODULE hResMod, LPCTSTR pNamespace=NULL)
Sets resource module handle to be used by the gauge implementation to load images and other assets fr...
CXTPGaugeTraits::GetResourceNamespace
const CString & GetResourceNamespace() const
Gets resource module handle to be used by the gauge implementation to load images and other assets fr...
Definition XTPGaugeTraits.h:386


Toolkit Pro: Member List

CXTPCalendarOfficeXPTheme Member List

This is the complete list of members for CXTPCalendarOfficeXPTheme, including all inherited members.

_GetAtGrow_BusyStatusBrushValue(int eBusyStatus, BOOL bGrow) | CXTPCalendarPaintManager | protected
_Init() | CXTPCalendarPaintManager | virtual
AddViewPart(CXTPCalendarViewPart *pPart) | CXTPCalendarPaintManager | protected
AdjustTimeFont(CDC *pDC, CRect rcCell) | CXTPCalendarPaintManager |
BEGIN_VIEW_PART(ControlPart, XTPCalendarViewPart) virtual void RefreshMetrics() | CXTPCalendarPaintManager |
CalcEventSize(CDC *c, CXTPCalendarTimeLineViewEvent *pViewEvent) | CXTPCalendarPaintManager | virtual
CalcWidth(CDC *pDC, const CString &strHour, const CString &strMin, int nHourHeight, int &nWidth) | CXTPCalendarPaintManager |
CXTPCalendarOffice2000Theme() | CXTPCalendarOffice2000Theme |
CXTPCalendarOfficeXPTheme() | CXTPCalendarOfficeXPTheme |
CXTPCalendarPaintManager() | CXTPCalendarPaintManager |
CXTPCmdTarget() | CXTPCmdTarget |
DrawBigHourCell(CDC *pDC, CRect rc, CString strHour, CString strMin, int nRowPerHour, BOOL bFillBackground=TRUE, BOOL bCurrentTime=FALSE) | CXTPCalendarPaintManager | virtual
DrawBitmap(CImageList *pImageList, CDC *pDC, CRect rcView, int iIcon, UINT uFlags=0) | CXTPCalendarPaintManager | virtual
DrawBitmap(UINT nIDResource, CDC *pDC, CRect rcBitmap) | CXTPCalendarPaintManager | virtual
DrawBorder(CDC *pDC, CRect rcView, CXTPCalendarWeekViewEvent *pWeekViewEvent) | CXTPCalendarPaintManager | virtual
DrawBusyStatus(CDC *pDC, CRect &rcRect, int eBusyStatus) | CXTPCalendarPaintManager | virtual
DrawBusyStatus(CDC *pDC, CRgn &rgnBusy, int eBusyStatus) | CXTPCalendarPaintManager | virtual
DrawClock(CDC *pDC, COleDateTime dtClockTime, CRect rcView, COLORREF clrBackground, XTPCalendarClockAlignFlags cafAlign) | CXTPCalendarPaintManager | virtual
DrawDayHeader(CDC *pDC, CRect rcDay, int nHeaderHeight, CString strHeader, BOOL bIsCurrent=FALSE, BOOL bIsSelected=FALSE) | CXTPCalendarPaintManager | virtual
DrawEvent(CDC *pDC, const CRect &rcEvents, CXTPCalendarTimeLineViewEvent *pViewEvent) | CXTPCalendarPaintManager | virtual
DrawExpandSigns(CDC *pDC, CXTPCalendarDayView *pView, const CRect &rcTSHours) | CXTPCalendarPaintManager | virtual
DrawGroup(CDC *pDC, const CRect &rcRect, CXTPCalendarTimeLineViewGroup *pGroup) | CXTPCalendarPaintManager | virtual
DrawHeader(CDC *pDC, CRect &rcHeader, BOOL bIsSelected, BOOL bIsCurrent) | CXTPCalendarPaintManager | virtual
DrawHeader(CDC *pDC, CRect &rcHeader, BOOL bIsSelected, BOOL bIsCurrent, const CXTPPaintManagerColorGradient &grclr, COLORREF clrUnderLineHdr) | CXTPCalendarPaintManager | virtual
DrawHorizontalLine(CDC *pDC, int xPos, int yPos, int cx) | CXTPCalendarPaintManager | virtual
DrawHourCell(CDC *pDC, CRect rc, CString strText, BOOL bFillBackground=TRUE, BOOL bCurrentTime=FALSE) | CXTPCalendarPaintManager | virtual
DrawIconChar(CDC *pDC, CRect rc, TCHAR ch) | CXTPCalendarPaintManager | virtual
DrawIcons(CDC *pDC, CXTPCalendarViewEvent *pViewEvent) | CXTPCalendarPaintManager | virtual
DrawLine(CDC *pDC, int xPos, int yPos, int cx, int cy) | CXTPCalendarPaintManager | virtual
DrawNowLine(CDC *pDC, CXTPCalendarDayView *pView, CRect rc, int y, BOOL bDrawBk=FALSE) | CXTPCalendarPaintManager | virtual
DrawNowLine(CDC *pDC, CXTPCalendarDayView *pView, CXTPCalendarDayViewTimeScale *pScale, CRect rc, int y, BOOL bDrawBk=FALSE) | CXTPCalendarPaintManager | virtual
DrawShadow(CDC *pDC, const CRect &rcRect) | CXTPCalendarPaintManager | virtual
DrawSubj(CDC *pDC, CXTPCalendarWeekViewEvent *pWeekViewEvent) | CXTPCalendarPaintManager | virtual
DrawTimes(CDC *pDC, CXTPCalendarWeekViewEvent *pWeekViewEvent) | CXTPCalendarPaintManager | virtual
DrawVerticalLine(CDC *pDC, int xPos, int yPos, int cy) | CXTPCalendarPaintManager | virtual
EnableTheme(BOOL bEnableTheme) | CXTPCalendarPaintManager |
END_VIEW_PART(ControlPart) BEGIN_VIEW_PART(DayViewTimeScaleHeaderPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewTimeScaleHeaderPart) BEGIN_VIEW_PART(DayViewTimeScaleCellPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewTimeScaleCellPart) BEGIN_VIEW_PART(DayViewCellPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewCellPart) BEGIN_VIEW_PART(DayViewWorkCellPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewWorkCellPart) BEGIN_VIEW_PART(DayViewNonworkCellPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewNonworkCellPart) BEGIN_VIEW_PART(DayMonthViewHeaderPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayMonthViewHeaderPart) BEGIN_VIEW_PART(DayViewHeaderPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewHeaderPart) BEGIN_VIEW_PART(DayViewGroupHeaderPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewGroupHeaderPart) BEGIN_VIEW_PART(DayViewAllDayEventsPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewAllDayEventsPart) BEGIN_VIEW_PART(DayViewAllDayEventScrollIconsPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewAllDayEventScrollIconsPart) BEGIN_VIEW_PART(DayViewEventPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewEventPart) BEGIN_VIEW_PART(MonthViewGridPart | CXTPCalendarPaintManager |
END_VIEW_PART(MonthViewGridPart) BEGIN_VIEW_PART(MonthViewHeaderPart | CXTPCalendarPaintManager |
END_VIEW_PART(MonthViewHeaderPart) BEGIN_VIEW_PART(MonthViewEventPart | CXTPCalendarPaintManager |
END_VIEW_PART(MonthViewEventPart) BEGIN_VIEW_PART(WeekViewPart | CXTPCalendarPaintManager |
END_VIEW_PART(WeekViewPart) BEGIN_VIEW_PART(WeekViewEventPart | CXTPCalendarPaintManager |
END_VIEW_PART(WeekViewEventPart) BEGIN_VIEW_PART(TimeLineViewTimeScalePart_Day | CXTPCalendarPaintManager |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAskItemTextFlags() const | CXTPCalendarPaintManager |
GetBusyStatusBrush(int nBusyStatus) | CXTPCalendarPaintManager |
GetClockSize() | CXTPCalendarPaintManager | virtual
GetCurrentSystemTheme() | CXTPCalendarPaintManager |
GetEventBackColor(CXTPCalendarEvent *pEvent, COLORREF crDefault) | CXTPCalendarPaintManager | virtual
GetExpandSignSize() | CXTPCalendarPaintManager | virtual
GetPaintTheme() const | CXTPCalendarPaintManager | virtual
GetParams(CXTPCalendarDayViewGroup *pViewGroup, XTP_CALENDAR_DAYVIEWCELL_PARAMS *rCellParams) | CXTPCalendarPaintManager | virtual
idxExpandSignDown enum value | CXTPCalendarPaintManager | protected
idxExpandSignUp enum value | CXTPCalendarPaintManager | protected
idxMeeting enum value | CXTPCalendarPaintManager | protected
idxPrivate enum value | CXTPCalendarPaintManager | protected
idxRecurrenceException enum value | CXTPCalendarPaintManager | protected
idxRecurrenceOccurrence enum value | CXTPCalendarPaintManager | protected
idxReminder enum value | CXTPCalendarPaintManager | protected
InitBusyStatusDefaultColors() | CXTPCalendarPaintManager | protectedvirtual
IsThemeEnabled() | CXTPCalendarPaintManager |
m_arBusyStatusBrushes | CXTPCalendarPaintManager | protected
m_arStartCol | CXTPCalendarPaintManager |
m_arStartRow | CXTPCalendarPaintManager |
m_bEnableTheme | CXTPCalendarPaintManager | protected
m_bmpElsewherePattern | CXTPCalendarPaintManager | protected
m_bmpTentativePattern | CXTPCalendarPaintManager | protected
m_bShowMinutes | CXTPCalendarPaintManager |
m_clr3DShadow | CXTPCalendarPaintManager |
m_clrBackground | CXTPCalendarPaintManager |
m_clrBackground2 | CXTPCalendarPaintManager |
m_clrBackgroundSlave | CXTPCalendarPaintManager |
m_clrBorders | CXTPCalendarPaintManager |
m_clrButtonFace | CXTPCalendarPaintManager |
m_clrButtonFaceText | CXTPCalendarPaintManager |
m_clrClassicUnderline | CXTPCalendarPaintManager |
m_clrEventBar | CXTPCalendarPaintManager |
m_clrEventBarLine | CXTPCalendarPaintManager |
m_clrEventBorderLine | CXTPCalendarPaintManager |
m_clrHeaderBottomLine | CXTPCalendarPaintManager |
m_clrHighlight | CXTPCalendarPaintManager |
m_clrHour | CXTPCalendarPaintManager |
m_clrMultiDayEventFrameColor | CXTPCalendarPaintManager |
m_clrSelectedBackground | CXTPCalendarPaintManager |
m_clrSelectedText | CXTPCalendarPaintManager |
m_clrShadow | CXTPCalendarPaintManager |
m_clrText | CXTPCalendarPaintManager |
m_clrTextHighLightColor | CXTPCalendarPaintManager |
m_clrTextNormalColor | CXTPCalendarPaintManager |
m_clrTimeScaleBackground | CXTPCalendarPaintManager |
m_clrTimeScaleHightlite | CXTPCalendarPaintManager |
m_clrTimeScaleText | CXTPCalendarPaintManager |
m_clrUnderLineHdr | CXTPCalendarPaintManager | protected
m_clrWeekendBackground | CXTPCalendarPaintManager |
m_clrWindow | CXTPCalendarPaintManager |
m_clrWindowText | CXTPCalendarPaintManager |
m_CurrSystemTheme | CXTPCalendarPaintManager | protected
m_dwAskItemTextFlags | CXTPCalendarPaintManager | protected
m_fntTimeText | CXTPCalendarPaintManager |
m_grclrClassicSelDay | CXTPCalendarPaintManager |
m_grclrToday | CXTPCalendarPaintManager |
m_lstViewParts | CXTPCalendarPaintManager | protected
m_nHourWidth | CXTPCalendarPaintManager |
m_nMinWidth | CXTPCalendarPaintManager |
m_nPaintTheme | CXTPCalendarPaintManager | protected
m_pControl | CXTPCalendarPaintManager | protected
m_pExpandSigns | CXTPCalendarPaintManager | protected
m_pGlyphs | CXTPCalendarPaintManager | protected
m_pGlyphsFont | CXTPCalendarPaintManager | protected
m_PrintPageWidth | CXTPCalendarPaintManager |
m_szClockRect | CXTPCalendarPaintManager | protected
m_xtpBrushElsewhere | CXTPCalendarPaintManager | protected
m_xtpBrushTentative | CXTPCalendarPaintManager | protected
OnDraw(CDC *pDC, CXTPCalendarDayView *pView, CRect rc, CString strText) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarDayViewGroup *pViewGroup, CRect rc, const XTP_CALENDAR_DAYVIEWCELL_PARAMS &cellParams) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarDayViewDay *pViewDay, CRect rc, CString strText) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarDayViewGroup *pViewGroup, CRect rc, CString strText) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarDayViewGroup *pViewGroup, CRect rc, BOOL bSelected) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarDayViewGroup *pViewGroup, BOOL bDrawUp, BOOL bDrawDown, const CRect &rcIconUp, const CRect &rcIconDown, BOOL bHighlightUp, BOOL bHighlightDown) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarDayViewEvent *pViewEvent) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarMonthView *pMonthView, CRect rc, int nCollIndex, CString strText) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarWeekView *pWeekView) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarWeekViewEvent *pWeekViewEvent) | CXTPCalendarPaintManager | virtual
OnDrawDayDate(CDC *pDC, CRect rc, BOOL bToday, BOOL bSelected, BOOL bFirstMonthDay, CString strText) | CXTPCalendarPaintManager | virtual
OnDrawEvent(CDC *pDC, CXTPCalendarMonthViewEvent *pViewEvent) | CXTPCalendarPaintManager | virtual
OnDrawGrid(CDC *pDC, CXTPCalendarMonthView *pMonthView) | CXTPCalendarPaintManager | virtual
RefreshMetrics() | CXTPCalendarPaintManager | virtual
RefreshMetrics() | CXTPCalendarPaintManager | virtual
RefreshMetrics() | CXTPCalendarPaintManager | virtual
RefreshMetrics() | CXTPCalendarPaintManager | virtual
RefreshMetrics() | CXTPCalendarPaintManager | virtual
RefreshMetrics() | CXTPCalendarPaintManager | inlinevirtual
RefreshMetrics() | CXTPCalendarPaintManager | virtual
RefreshMetrics() | CXTPCalendarPaintManager | virtual
RefreshMetrics() | CXTPCalendarPaintManager | virtual
RefreshMetrics() | CXTPCalendarPaintManager | virtual
RefreshMetrics() | CXTPCalendarPaintManager | virtual
RefreshMetrics() | CXTPCalendarPaintManager | inlinevirtual
RefreshMetrics() | CXTPCalendarPaintManager | virtual
RefreshMetrics() | CXTPCalendarPaintManager | virtual
SetAskItemTextFlags(DWORD dwFlags) | CXTPCalendarPaintManager |
SetBusyStatusBrush(int nBusyStatus, CBrush *pBrush, BOOL bAutodeleteBrush) | CXTPCalendarPaintManager |
SetControl(CXTPCalendarControl *pControl) | CXTPCalendarPaintManager | virtual
SetPaintTheme(XTPCalendarTheme ePaintTheme) | CXTPCalendarPaintManager | virtual
UpdateEventCategoriesDefaultColors() | CXTPCalendarPaintManager | virtual
UpdateEventLabelsDefaultColors() | CXTPCalendarPaintManager | virtual
UpdateGlyphs() | CXTPCalendarPaintManager | virtual
XTPEnumEventGlyphs enum name | CXTPCalendarPaintManager | protected
XTPEnumExpandSigns enum name | CXTPCalendarPaintManager | protected
~CTimeLineViewPart() | CXTPCalendarPaintManager | virtual
~CXTPCalendarOffice2000Theme() | CXTPCalendarOffice2000Theme | virtual
~CXTPCalendarOfficeXPTheme() | CXTPCalendarOfficeXPTheme | virtual
~CXTPCalendarPaintManager() | CXTPCalendarPaintManager | virtual


Toolkit Pro: XTPCaption.h Source File

  • Source
  • Controls
  • Static
XTPCaption.h
Go to the documentation of this file.
1
23#if !defined(__XTPCAPTION_H__)
24# define __XTPCAPTION_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPCaption;
34class CXTPCaptionPopupWnd;
35class CXTPCaptionTheme;
36
37# define XTP_IDC_BTN_CLOSE 100
38
44class _XTP_EXT_CLASS CXTPCaptionButton : public CXTPButton
45{
46public:
51 CXTPCaptionButton();
52
60 CXTPCaption* GetCaption()
61 {
62 return m_pCaption;
63 }
70 void SetCaption(CXTPCaption* pCaption)
71 {
72 m_pCaption = pCaption;
73 }
74 virtual BOOL SetTheme(XTPControlTheme eTheme);
75
76 using CXTPButton::SetTheme;
77
78protected:
79 CXTPCaption* m_pCaption;
80};
81
82const DWORD CPWS_EX_GROOVE_EDGE = 0x0001;
83const DWORD CPWS_EX_RAISED_EDGE = 0x0002;
84const DWORD CPWS_EX_CLOSEBUTTON = 0x0004;
91class _XTP_EXT_CLASS CXTPCaption : public CStatic
92{
94 DECLARE_DYNAMIC(CXTPCaption)
96public:
101 virtual ~CXTPCaption();
102
107 CXTPCaption();
108
109public:
122 BOOL SetTheme(XTPControlTheme eTheme);
123
130 BOOL SetTheme(CXTPCaptionTheme* pTheme);
131
140 CXTPCaptionTheme* GetTheme();
141
150 bool IsAppCaption() const
151 {
152 return m_bAppCaption;
153 }
161 void SetAppCaption(bool bAppCaption)
162 {
163 m_bAppCaption = bAppCaption;
164 }
165
173 CXTPCaptionButton& GetCaptionButton();
174
183 virtual void SetCaptionColors(COLORREF clrBorder, COLORREF clrFace, COLORREF clrText);
184
191 void SetOffice2003Colors(bool b2003Colors = true);
192
200 DWORD GetCaptionStyle() const;
201
215 virtual void ModifyCaptionStyle(int nBorderSize, CFont* pFont = NULL,
216 LPCTSTR lpszWindText = NULL, HICON hIcon = NULL);
217
227 virtual void SetChildWindow(CWnd* pChild, CWnd* pNotifyWnd);
228
234 virtual void KillChildWindow();
235
243 virtual BOOL ShowPopupWindow();
244
253 virtual void UpdateCaption(LPCTSTR lpszWindowText, HICON hIcon);
254
286 virtual BOOL Create(CWnd* pParentWnd, LPCTSTR lpszWindowName,
287 DWORD dwExStyle = CPWS_EX_RAISED_EDGE,
288 DWORD dwStyle = WS_VISIBLE | SS_CENTER | SS_CENTERIMAGE,
289 const CRect& rect = CRect(0, 0, 0, 0), UINT nID = 0xffff);
290
295 void RefreshButton();
296
303 const CString& GetCaptionText();
304
311 BOOL HasCloseButton() const;
312
321 virtual CRect GetTextRect() const;
322
323protected:
330 virtual void DrawCaptionBack(CDC* pDC, CRect& rcItem);
331
337 virtual void DrawCaptionText(CDC* pDC);
338
345 virtual void DrawCaptionIcon(CDC* pDC, CRect& rcItem);
346
352 virtual void UpdateCaptionText(CDC* pDC);
353
362 virtual CRect GetButtonRect() const;
363
368 virtual void RefreshMetrics();
369
372 //{{AFX_VIRTUAL(CXTPCaption)
373 virtual BOOL OnWndMsg(UINT message, WPARAM wParam, LPARAM lParam, LRESULT* pResult);
374 //}}AFX_VIRTUAL
375
376 //{{AFX_MSG(CXTPCaption)
377 afx_msg void OnPaint();
378 afx_msg LRESULT OnPrintClient(WPARAM wParam, LPARAM /*lParam*/);
379 afx_msg BOOL OnEraseBkgnd(CDC* pDC);
380 afx_msg void OnWindowPosChanged(WINDOWPOS FAR* lpwndpos);
381 afx_msg void OnSysColorChange();
382 afx_msg void OnSize(UINT nType, int cx, int cy);
383 afx_msg void OnCaptButton();
384 afx_msg void OnPushPinButton();
385 afx_msg void OnPushPinCancel();
386 //}}AFX_MSG
387 afx_msg LRESULT OnSetTheme(WPARAM wParam, LPARAM lParam);
388
389 DECLARE_MESSAGE_MAP()
392private:
393 BOOL Create(LPCTSTR lpszClassName, LPCTSTR lpszWindowName, DWORD dwStyle, const RECT& rect,
394 CWnd* pParentWnd, UINT nID, CCreateContext* pContext = NULL);
395 BOOL Create(LPCTSTR lpszText, DWORD dwStyle, const RECT& rect, CWnd* pParentWnd,
396 UINT nID = 0xffff);
397
398public:
399 int m_nBorder;
400 COLORREF m_clrBorder;
401 COLORREF m_clrFace;
402 COLORREF m_clrText;
404protected:
405 int m_nOffset;
406 bool m_bUserColors;
408 bool m_bAppCaption;
409 CWnd* m_pChildWnd;
411 CWnd* m_pParentView;
412 CWnd* m_pSplitterWnd;
414 CSize m_sizeIcon;
415 CRect m_rcChild;
416 CRect m_rcParent;
417 CRect m_rcSplitter;
418 DWORD m_dwExStyle;
419 HICON m_hIcon;
420 CString m_strCaption;
421 CXTPCaptionButton m_btnCaption;
422 CXTPCaptionPopupWnd* m_pPopupWnd;
423 CXTPCaptionTheme* m_pTheme;
424 BOOL m_bSubclassed;
426 friend class CXTPCaptionButton;
427 friend class CXTPCaptionButtonTheme;
428 friend class CXTPCaptionTheme;
429};
430
432
433AFX_INLINE CXTPCaptionButton& CXTPCaption::GetCaptionButton()
434{
435 _ASSERTE(::IsWindow(m_btnCaption.m_hWnd));
436 return m_btnCaption;
437}
438AFX_INLINE DWORD CXTPCaption::GetCaptionStyle() const
439{
440 return m_dwExStyle;
441}
442AFX_INLINE const CString& CXTPCaption::GetCaptionText()
443{
444 return m_strCaption;
445}
446AFX_INLINE BOOL CXTPCaption::HasCloseButton() const
447{
448 return ((m_dwExStyle & CPWS_EX_CLOSEBUTTON) == CPWS_EX_CLOSEBUTTON);
449}
450AFX_INLINE BOOL CXTPCaption::Create(LPCTSTR lpszClassName, LPCTSTR lpszWindowName, DWORD dwStyle,
451 const RECT& rect, CWnd* pParentWnd, UINT nID,
452 CCreateContext* pContext)
453{
454 return CWnd::Create(lpszClassName, lpszWindowName, dwStyle, rect, pParentWnd, nID, pContext);
455}
456AFX_INLINE BOOL CXTPCaption::Create(LPCTSTR lpszText, DWORD dwStyle, const RECT& rect,
457 CWnd* pParentWnd, UINT nID)
458{
459 return CStatic::Create(lpszText, dwStyle, rect, pParentWnd, nID);
460}
461AFX_INLINE CXTPCaptionTheme* CXTPCaption::GetTheme()
462{
463 return m_pTheme;
464}
466# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
468#endif // #if !defined(__XTPCAPTION_H__)
CPWS_EX_GROOVE_EDGE
const DWORD CPWS_EX_GROOVE_EDGE
Definition XTPCaption.h:82
CPWS_EX_RAISED_EDGE
const DWORD CPWS_EX_RAISED_EDGE
Definition XTPCaption.h:83
CPWS_EX_CLOSEBUTTON
const DWORD CPWS_EX_CLOSEBUTTON
Definition XTPCaption.h:84
XTPControlTheme
XTPControlTheme
Enumeration used to determine the active theme style.
Definition XTPControlTheme.h:43
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPButton
Push Button control.
Definition XTPButton.h:109
CXTPButton::SetTheme
virtual BOOL SetTheme(XTPControlTheme eTheme)
Call this member to switch the visual theme of the control.
CXTPButton::m_pTheme
CXTPButtonTheme * m_pTheme
Pointer to the current theme object.
Definition XTPButton.h:758
CXTPCaptionButton
CXTPCaptionButton is a CXTPButton derived class.
Definition XTPCaption.h:45
CXTPCaptionButton::GetCaption
CXTPCaption * GetCaption()
This member function is called to retrieve a pointer to the parent caption.
Definition XTPCaption.h:60
CXTPCaptionButton::SetCaption
void SetCaption(CXTPCaption *pCaption)
This member function is called to set the pointer to the parent caption.
Definition XTPCaption.h:70
CXTPCaptionButton::m_pCaption
CXTPCaption * m_pCaption
A pointer to the parent CXTPCaption.
Definition XTPCaption.h:79
CXTPCaptionButton::SetTheme
virtual BOOL SetTheme(XTPControlTheme eTheme)
Call this member to switch the visual theme of the control.
CXTPCaptionButton::CXTPCaptionButton
CXTPCaptionButton()
Constructs a CXTPCaptionButton object.
CXTPCaptionButtonTheme
CXTPCaptionButtonTheme is derived from CXTPButtonTheme.
Definition XTPCaptionTheme.h:161
CXTPCaption
CXTPCaption is a CStatic derived class.
Definition XTPCaption.h:92
CXTPCaption::HasCloseButton
BOOL HasCloseButton() const
Call this member function to see if the caption contains a close button.
CXTPCaption::KillChildWindow
virtual void KillChildWindow()
This member function is called to destroy the pop-up window and associated children.
CXTPCaption::GetButtonRect
virtual CRect GetButtonRect() const
This member function is called to determine the size and location of the button associated with the c...
CXTPCaption::SetAppCaption
void SetAppCaption(bool bAppCaption)
This member function is called to set the flag that indicates if the caption is the application's pri...
Definition XTPCaption.h:161
CXTPCaption::SetOffice2003Colors
void SetOffice2003Colors(bool b2003Colors=true)
Call this member function to enable Office 2003 visualizations.
CXTPCaption::DrawCaptionBack
virtual void DrawCaptionBack(CDC *pDC, CRect &rcItem)
This member function is called to draw the caption background.
CXTPCaption::IsAppCaption
bool IsAppCaption() const
This member function is called to determine if the caption is configured to be used as the applicatio...
Definition XTPCaption.h:150
CXTPCaption::ShowPopupWindow
virtual BOOL ShowPopupWindow()
This member function is called to display the pop-up window and associated children.
CXTPCaption::GetCaptionStyle
DWORD GetCaptionStyle() const
Call this member function to retrieve the current style settings for the caption.
CXTPCaption::SetTheme
BOOL SetTheme(XTPControlTheme eTheme)
Call this member to switch the visual theme of the control.
CXTPCaption::UpdateCaption
virtual void UpdateCaption(LPCTSTR lpszWindowText, HICON hIcon)
This member function is called to update the text and icon for the caption bar.
CXTPCaption::SetCaptionColors
virtual void SetCaptionColors(COLORREF clrBorder, COLORREF clrFace, COLORREF clrText)
This member function will set the caption bar border, background, and font colors.
CXTPCaption::CXTPCaption
CXTPCaption()
Constructs a CXTPCaption object.
CXTPCaption::GetCaptionButton
CXTPCaptionButton & GetCaptionButton()
Call this member function to get a reference to the caption's close/pop-up button.
CXTPCaption::UpdateCaptionText
virtual void UpdateCaptionText(CDC *pDC)
This member function is called to update the caption text.
CXTPCaption::GetCaptionText
const CString & GetCaptionText()
This member function retrieves the current caption title.
CXTPCaption::GetTextRect
virtual CRect GetTextRect() const
This member function is called to determine the size and location of the text associated with the cap...
CXTPCaption::SetTheme
BOOL SetTheme(CXTPCaptionTheme *pTheme)
Call this member to switch the visual theme of the control.
CXTPCaption::ModifyCaptionStyle
virtual void ModifyCaptionStyle(int nBorderSize, CFont *pFont=NULL, LPCTSTR lpszWindText=NULL, HICON hIcon=NULL)
Modifies the caption title and appearance.
CXTPCaption::Create
virtual BOOL Create(CWnd *pParentWnd, LPCTSTR lpszWindowName, DWORD dwExStyle=CPWS_EX_RAISED_EDGE, DWORD dwStyle=WS_VISIBLE|SS_CENTER|SS_CENTERIMAGE, const CRect &rect=CRect(0, 0, 0, 0), UINT nID=0xffff)
Creates and initializes the child window associated with the CXTPCaption object.
CXTPCaption::SetChildWindow
virtual void SetChildWindow(CWnd *pChild, CWnd *pNotifyWnd)
Call this member function to set the child and notification windows for the caption bar.
CXTPCaption::~CXTPCaption
virtual ~CXTPCaption()
Destroys a CXTPCaption object, handles cleanup and deallocation.
CXTPCaption::RefreshMetrics
virtual void RefreshMetrics()
Call this member function to refresh theme colors and redraw the control.
CXTPCaption::RefreshButton
void RefreshButton()
This member function is called to refresh the caption button style.
CXTPCaption::DrawCaptionIcon
virtual void DrawCaptionIcon(CDC *pDC, CRect &rcItem)
This member function is called to paint the caption icon.
CXTPCaption::DrawCaptionText
virtual void DrawCaptionText(CDC *pDC)
This member function is called to paint the caption text.
CXTPCaption::GetTheme
CXTPCaptionTheme * GetTheme()
Call this member function to get a pointer to the currently selected theme.
CXTPCaptionPopupWnd
CXTPCaptionPopupWnd is a CWnd derived class.
Definition XTPCaptionPopupWnd.h:39
CXTPCaptionTheme
CXTPCaptionTheme is a CXTPControlTheme derived class used to control caption themes.
Definition XTPCaptionTheme.h:42


Toolkit Pro: XTPCommandBarKeyboardTip.h Source File

  • Source
  • CommandBars
XTPCommandBarKeyboardTip.h
Go to the documentation of this file.
1
23#if !defined(__XTPCOMMANDBARKEYBOARDTIP_H__)
24# define __XTPCOMMANDBARKEYBOARDTIP_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPCommandBars;
34
40class _XTP_EXT_CLASS CXTPCommandBarKeyboardTip : public CWnd
41{
42public:
53 CXTPCommandBarKeyboardTip(CXTPCommandBars* pCommandBars, CCmdTarget* pOwner,
54 LPCTSTR lpszCaption, CPoint pt, DWORD dwAlign, BOOL bEnabled);
55
56protected:
58 DECLARE_MESSAGE_MAP()
59
60 afx_msg void OnPaint();
61 afx_msg LRESULT OnNcHitTest(CPoint point);
64public:
65 CString m_strTip;
66 CString m_strCaption;
67 CString m_strPrefix;
68 CCmdTarget* m_pOwner;
69 CPoint m_pt;
70 BOOL m_bEnabled;
71 BOOL m_bVisible;
72 CXTPCommandBars* m_pCommandBars;
73 DWORD m_dwAlign;
74 BOOL m_bExplicit;
76};
77
79# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
80#endif // !defined(__XTPCOMMANDBARKEYBOARDTIP_H__)
XTPDisableNoisyWarnings.h
CXTPCommandBarKeyboardTip
CXTPCommandBarKeyboardTip is a CWnd derived class which represents a keyboard tip single window.
Definition XTPCommandBarKeyboardTip.h:41
CXTPCommandBarKeyboardTip::CXTPCommandBarKeyboardTip
CXTPCommandBarKeyboardTip(CXTPCommandBars *pCommandBars, CCmdTarget *pOwner, LPCTSTR lpszCaption, CPoint pt, DWORD dwAlign, BOOL bEnabled)
Constructs a CXTPCommandBarKeyboardTip object.
CXTPCommandBars
CXTPCommandBars is a standalone class.
Definition XTPCommandBars.h:165


Toolkit Pro: Member List

CXTPChart3dFunnelSeriesLabel Member List

This is the complete list of members for CXTPChart3dFunnelSeriesLabel, including all inherited members.

CreateView(CXTPChartDeviceContext *pDC, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView) | CXTPChart3dFunnelSeriesLabel | protectedvirtual
CXTPChart3dFunnelSeriesLabel() | CXTPChart3dFunnelSeriesLabel |
CXTPChartElement() | CXTPChartElement |
CXTPChartFunnelSeriesLabelBase() | CXTPChartFunnelSeriesLabelBase |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartSeriesLabel() | CXTPChartSeriesLabel |
DoPropExchange(CXTPPropExchange *pPX) | CXTPChartFunnelSeriesLabelBase | virtual
GetAntialiasing() const | CXTPChartSeriesLabel | virtual
GetAppearance() const | CXTPChartElement |
GetBackColor() const | CXTPChartSeriesLabel |
GetContent() const | CXTPChartElement |
GetFont() const | CXTPChartSeriesLabel | virtual
GetFormat() const | CXTPChartSeriesLabel |
GetLineColor() const | CXTPChartSeriesLabel |
GetLineLength() const | CXTPChartSeriesLabel |
GetOwner() const | CXTPChartElement |
GetPosition() const | CXTPChartFunnelSeriesLabelBase |
GetShowLines() const | CXTPChartSeriesLabel |
GetStyle() const | CXTPChartFunnelSeriesLabelBase |
GetTextColor() const | CXTPChartSeriesLabel |
GetTransparency() const | CXTPChartSeriesLabel |
Is3D() const | CXTPChartObject |
IsInside() const | CXTPChartFunnelSeriesLabelBase |
IsVisible() const | CXTPChartSeriesLabel |
m_bAntialiasing | CXTPChartSeriesLabel | protected
m_bShowLines | CXTPChartSeriesLabel | protected
m_bVisible | CXTPChartSeriesLabel | protected
m_clrBackColor | CXTPChartSeriesLabel | protected
m_clrLineColor | CXTPChartSeriesLabel | protected
m_clrTextColor | CXTPChartSeriesLabel | protected
m_nLineLength | CXTPChartSeriesLabel | protected
m_nPosition | CXTPChartFunnelSeriesLabelBase | protected
m_nTransparency | CXTPChartSeriesLabel | protected
m_pBorder | CXTPChartSeriesLabel | protected
m_pFont | CXTPChartSeriesLabel | protected
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartElement | virtual
Release() | CXTPChartElement | virtual
SetAntialiasing(BOOL bAntialiasing) | CXTPChartSeriesLabel |
SetBackColor(const CXTPChartColor &clrBackColor) | CXTPChartSeriesLabel |
SetFont(CXTPChartFont *pFont) | CXTPChartSeriesLabel |
SetFormat(LPCTSTR lpszFormat) | CXTPChartSeriesLabel |
SetLineColor(const CXTPChartColor &clrBackColor) | CXTPChartSeriesLabel |
SetLineLength(int nLineLength) | CXTPChartSeriesLabel |
SetPosition(XTPChartFunnelLabelPosition nPosition) | CXTPChartFunnelSeriesLabelBase |
SetShowLines(BOOL bShowLines) | CXTPChartSeriesLabel |
SetTextColor(const CXTPChartColor &clrTextColor) | CXTPChartSeriesLabel |
SetTransparency(int nTransparency) | CXTPChartSeriesLabel |
SetVisible(BOOL bVisible) | CXTPChartSeriesLabel |
~CXTPChartElement() | CXTPChartElement | virtual
~CXTPChartFunnelSeriesLabelBase() | CXTPChartFunnelSeriesLabelBase | virtual
~CXTPChartSeriesLabel() | CXTPChartSeriesLabel | virtual


Toolkit Pro: Member List

CXTPDockingPaneColorSet Member List

This is the complete list of members for CXTPDockingPaneColorSet, including all inherited members.

GetButtonColorSet(CXTPDockingPaneCaptionButton *pButton) | CXTPDockingPaneColorSet | virtual
m_clrBackground | CXTPDockingPaneColorSet |
m_clrBorder | CXTPDockingPaneColorSet |
m_clrCaption | CXTPDockingPaneColorSet |
m_clrGripper | CXTPDockingPaneColorSet |
m_clrSplitter | CXTPDockingPaneColorSet |
m_clrText | CXTPDockingPaneColorSet |
m_csCaptionButtonHot | CXTPDockingPaneColorSet | protected
m_csCaptionButtonNormal | CXTPDockingPaneColorSet | protected
m_csCaptionButtonPressed | CXTPDockingPaneColorSet | protected
RefreshMetrics(CString strSection)=0 | CXTPDockingPaneColorSet | pure virtual
~CXTPDockingPaneColorSet() | CXTPDockingPaneColorSet | virtual


Toolkit Pro: Member List

CXTPChartSplineSeriesStyle Member List

This is the complete list of members for CXTPChartSplineSeriesStyle, including all inherited members.

ApplyTo(CXTPChartDeviceCommand *pCommand) | CXTPChartSeriesStyle | virtual
CorrectAxisSideMargins(CXTPChartAxis *pAxis, double nMinValue, double nMaxValue, double &nCorrection) | CXTPChartSeriesStyle | virtual
CreateDiagram() | CXTPChartDiagram2DSeriesStyle | virtual
CreateView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView) | CXTPChartSplineSeriesStyle | protectedvirtual
CXTPChartDiagram2DSeriesStyle() | CXTPChartDiagram2DSeriesStyle |
CXTPChartElement() | CXTPChartElement |
CXTPChartLineSeriesStyle() | CXTPChartLineSeriesStyle |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartPointSeriesStyle() | CXTPChartPointSeriesStyle |
CXTPChartSeriesStyle() | CXTPChartSeriesStyle |
CXTPChartSplineSeriesStyle() | CXTPChartSplineSeriesStyle |
DoPropExchange(CXTPPropExchange *pPX) | CXTPChartLineSeriesStyle | protectedvirtual
Enable3dEdgeSmoothing(BOOL bEnable=TRUE) | CXTPChartSeriesStyle | virtual
Get3dRotation() const | CXTPChartSeriesStyle | virtual
GetAppearance() const | CXTPChartElement |
GetColor() const | CXTPChartSeriesStyle | virtual
GetContent() const | CXTPChartElement |
GetErrorBar() const | CXTPChartSeriesStyle | virtual
GetLabel() const | CXTPChartSeriesStyle | virtual
GetLineStyle() const | CXTPChartLineSeriesStyle |
GetMarker() const | CXTPChartPointSeriesStyle |
GetOwner() const | CXTPChartElement |
GetSeriesPointValueIndex() const | CXTPChartSeriesStyle | virtual
GetStyleAppearance() const | CXTPChartSeriesStyle | virtual
GetTransparency() const | CXTPChartSeriesStyle | virtual
Is3D() const | CXTPChartObject |
Is3dEdgeSmoothingEnabled() const | CXTPChartSeriesStyle | virtual
IsColorEach() const | CXTPChartSeriesStyle | virtual
IsStyleDiagram(CXTPChartDiagram *pDiagram) const | CXTPChartDiagram2DSeriesStyle | virtual
m_bColorEach | CXTPChartSeriesStyle | protected
m_bSmooth3dEdges | CXTPChartSeriesStyle | protected
m_clrColor | CXTPChartSeriesStyle | protected
m_nAxisIndexX | CXTPChartDiagram2DSeriesStyle | protected
m_nAxisIndexY | CXTPChartDiagram2DSeriesStyle | protected
m_nTransparency | CXTPChartSeriesStyle | protected
m_pErrorBar | CXTPChartSeriesStyle | protected
m_pLabel | CXTPChartSeriesStyle | protected
m_pLineStyle | CXTPChartLineSeriesStyle | protected
m_Rotation3d | CXTPChartSeriesStyle | protected
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartElement | virtual
Release() | CXTPChartElement | virtual
Set3dRotation(const CXTPChart3dRotation &rotation) | CXTPChartSeriesStyle | virtual
Set3dRotation(double dYaw, double dPitch, double dRoll) | CXTPChartSeriesStyle | virtual
SetColor(CXTPChartColor clr) | CXTPChartSeriesStyle | virtual
SetColorEach(BOOL bColorEach) | CXTPChartSeriesStyle | virtual
SetErrorBar(CXTPChartErrorBar *pErrorBar) | CXTPChartSeriesStyle | virtual
SetLabel(CXTPChartSeriesLabel *pLabel) | CXTPChartSeriesStyle | virtual
SetTransparency(int nTransparency) | CXTPChartSeriesStyle | virtual
~CXTPChartDiagram2DSeriesStyle() | CXTPChartDiagram2DSeriesStyle | virtual
~CXTPChartElement() | CXTPChartElement | virtual
~CXTPChartLineSeriesStyle() | CXTPChartLineSeriesStyle | virtual
~CXTPChartPointSeriesStyle() | CXTPChartPointSeriesStyle | virtual
~CXTPChartSeriesStyle() | CXTPChartSeriesStyle | virtual
~CXTPChartSplineSeriesStyle() | CXTPChartSplineSeriesStyle | virtual


Toolkit Pro: XTPPropertyGridItemOption.h Source File

  • Source
  • PropertyGrid
XTPPropertyGridItemOption.h
Go to the documentation of this file.
1
23#if !defined(__XTPPROPERTYGRIDITEMOPTION_H__)
24# define __XTPPROPERTYGRIDITEMOPTION_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
37class _XTP_EXT_CLASS CXTPPropertyGridItemOption : public CXTPPropertyGridItem
38{
40 DECLARE_DYNAMIC(CXTPPropertyGridItemOption)
42public:
78 CXTPPropertyGridItemOption(LPCTSTR strCaption, int nValue = 0, int* pBindOption = NULL);
79
115 CXTPPropertyGridItemOption(UINT nID, int nValue = 0, int* pBindOption = NULL);
116
121 virtual ~CXTPPropertyGridItemOption();
122
123public:
129 void SetOption(int nValue);
130
154 void BindToOption(int* pBindOption);
155
162 int GetOption() const;
163
171 void SetCheckBoxStyle(BOOL bCheckBoxStyle = TRUE);
172
181 BOOL IsCheckBoxStyle() const;
182
183protected:
197 void OnBeforeInsert();
198
206 void SetValue(CString strValue);
207
214 void MeasureItem(LPMEASUREITEMSTRUCT lpMeasureItemStruct);
215
226 BOOL OnDrawItemValue(CDC& dc, CRect rcValue);
227
236 void OnLButtonDblClk(UINT nFlags, CPoint point);
237
248 BOOL OnLButtonDown(UINT nFlags, CPoint point);
249
259 BOOL OnInpaceControlFocus(BOOL bForward);
260
265 void OnDeselect();
266
273 BOOL OnKeyDown(UINT nChar);
274
280 void ToggleConstraint(int nIndex);
281
282private:
283 void _Init(int nValue);
284
285protected:
286 int m_nValue;
288 int* m_pBindOption;
289 BOOL m_bCheckBoxStyle;
292# ifdef _XTP_ACTIVEX
294 afx_msg void OleSetValue(const VARIANT* varValue);
295 afx_msg const VARIANT OleGetValue();
296
297 DECLARE_DISPATCH_MAP()
298 DECLARE_INTERFACE_MAP()
299
300 DECLARE_OLETYPELIB_EX(CXTPPropertyGridItemBool)
301
302 void BindDispatch();
304# endif
305};
306
307AFX_INLINE int CXTPPropertyGridItemOption::GetOption() const
308{
309 return m_nValue;
310}
311AFX_INLINE void CXTPPropertyGridItemOption::SetCheckBoxStyle(BOOL bCheckBoxStyle /*= TRUE*/)
312{
313 m_bCheckBoxStyle = bCheckBoxStyle;
314}
315AFX_INLINE BOOL CXTPPropertyGridItemOption::IsCheckBoxStyle() const
316{
317 return m_bCheckBoxStyle;
318}
319
321# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
322#endif //#if !defined(__XTPPROPERTYGRIDITEMOPTION_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPPropertyGridItemBool
CXTPPropertyGridItemBool is a CXTPPropertyGridItem derived class.
Definition XTPPropertyGridItemBool.h:39
CXTPPropertyGridItem
CXTPPropertyGridItem is the base class representing an item of the Property Grid control.
Definition XTPPropertyGridItem.h:523
CXTPPropertyGridItemOption
CXTPPropertyGridItemOption is a CXTPPropertyGridItem derived class.
Definition XTPPropertyGridItemOption.h:38
CXTPPropertyGridItemOption::OnLButtonDblClk
void OnLButtonDblClk(UINT nFlags, CPoint point)
This method is called when the user double-clicks the left mouse button on the item.
CXTPPropertyGridItemOption::m_pBindOption
int * m_pBindOption
Pointer to the variable bound to this item.
Definition XTPPropertyGridItemOption.h:288
CXTPPropertyGridItemOption::m_nValue
int m_nValue
Value of the item.
Definition XTPPropertyGridItemOption.h:286
CXTPPropertyGridItemOption::OnKeyDown
BOOL OnKeyDown(UINT nChar)
This method is called when a non-system key is pressed.
CXTPPropertyGridItemOption::CXTPPropertyGridItemOption
CXTPPropertyGridItemOption(LPCTSTR strCaption, int nValue=0, int *pBindOption=NULL)
Constructs a CXTPPropertyGridItemOption object.
CXTPPropertyGridItemOption::SetValue
void SetValue(CString strValue)
Sets the value of the item.
CXTPPropertyGridItemOption::OnLButtonDown
BOOL OnLButtonDown(UINT nFlags, CPoint point)
This method is called when the user presses the left mouse button on the item.
CXTPPropertyGridItemOption::OnDeselect
void OnDeselect()
This method is called when an item is de-selected.
CXTPPropertyGridItemOption::ToggleConstraint
void ToggleConstraint(int nIndex)
Toggles the value of the option button.
CXTPPropertyGridItemOption::~CXTPPropertyGridItemOption
virtual ~CXTPPropertyGridItemOption()
Destroys a CXTPPropertyGridItemOption object.
CXTPPropertyGridItemOption::m_bCheckBoxStyle
BOOL m_bCheckBoxStyle
TRUE if the option button will be displayed as a check box, FALSE if the option button will be displa...
Definition XTPPropertyGridItemOption.h:289
CXTPPropertyGridItemOption::OnDrawItemValue
BOOL OnDrawItemValue(CDC &dc, CRect rcValue)
This method is called when an item is drawn.
CXTPPropertyGridItemOption::OnBeforeInsert
void OnBeforeInsert()
This method is called before the item becomes visible in the property grid.
CXTPPropertyGridItemOption::GetOption
int GetOption() const
Gets the integer value of the item.
Definition XTPPropertyGridItemOption.h:307
CXTPPropertyGridItemOption::BindToOption
void BindToOption(int *pBindOption)
Binds the item to a specified integer value.
CXTPPropertyGridItemOption::SetCheckBoxStyle
void SetCheckBoxStyle(BOOL bCheckBoxStyle=TRUE)
Specifies if the item should be drawn as a checkbox or as an option/radio button.
Definition XTPPropertyGridItemOption.h:311
CXTPPropertyGridItemOption::MeasureItem
void MeasureItem(LPMEASUREITEMSTRUCT lpMeasureItemStruct)
Override this method and fill in a specified MEASUREITEMSTRUCT structure to inform Windows of the lis...
CXTPPropertyGridItemOption::CXTPPropertyGridItemOption
CXTPPropertyGridItemOption(UINT nID, int nValue=0, int *pBindOption=NULL)
Constructs a CXTPPropertyGridItemOption object.
CXTPPropertyGridItemOption::OnInpaceControlFocus
BOOL OnInpaceControlFocus(BOOL bForward)
This method is called by the property grid to set focus to an in-place child window.
CXTPPropertyGridItemOption::SetOption
void SetOption(int nValue)
Sets the integer value of the item.
CXTPPropertyGridItemOption::IsCheckBoxStyle
BOOL IsCheckBoxStyle() const
Determines if the item is drawn as a checkbox or as an option/radio button.
Definition XTPPropertyGridItemOption.h:315


Toolkit Pro: XTPCommandBarList.h Source File

  • Source
  • CommandBars
XTPCommandBarList.h
Go to the documentation of this file.
1
23#if !defined(__XTPCOMMANDBARLIST_H__)
24# define __XTPCOMMANDBARLIST_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPCommandBar;
34class CXTPCommandBars;
35
41class _XTP_EXT_CLASS CXTPCommandBarList : public CXTPCmdTarget
42{
43public:
49 CXTPCommandBarList(CXTPCommandBars* pCommandBars)
50 {
51 m_pCommandBars = pCommandBars;
52 }
53
59 virtual ~CXTPCommandBarList();
60
61public:
69 CXTPCommandBar* FindCommandBar(UINT nBarID) const;
70
79 CXTPCommandBars* GetCommandBars() const
80 {
81 return m_pCommandBars;
82 }
83
93 CXTPCommandBar* GetAt(int nIndex) const;
94
103 int GetCount() const;
104
114 virtual CXTPCommandBar* Add(CXTPCommandBar* pCommandBar);
115
123 BOOL Lookup(CXTPCommandBar* pCommandBar) const;
124
131 void RemoveAll();
132
140 void Remove(CXTPCommandBar* pCommandBar);
141
142protected:
143 CXTPCommandBars* m_pCommandBars;
144 CArray<CXTPCommandBar*, CXTPCommandBar*> m_arrBars;
145};
146
148# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
149#endif // !defined(__XTPCOMMANDBARLIST_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPCommandBar
CXTPCommandBar is a CWnd derived class.
Definition XTPCommandBar.h:66
CXTPCommandBarList
CXTPCommandBarList is a CList derived class.
Definition XTPCommandBarList.h:42
CXTPCommandBarList::FindCommandBar
CXTPCommandBar * FindCommandBar(UINT nBarID) const
Call this method to find the command bar with the specified identifier.
CXTPCommandBarList::GetCount
int GetCount() const
Call this method to get the number of command bars in the list.
CXTPCommandBarList::GetAt
CXTPCommandBar * GetAt(int nIndex) const
Call this method to get the command bar at the specified index in the list.
CXTPCommandBarList::Remove
void Remove(CXTPCommandBar *pCommandBar)
Call this method to remove a specified command bar from the list.
CXTPCommandBarList::Add
virtual CXTPCommandBar * Add(CXTPCommandBar *pCommandBar)
Call this method to add a new command bar to the list.
CXTPCommandBarList::m_arrBars
CArray< CXTPCommandBar *, CXTPCommandBar * > m_arrBars
Array of CommandBars.
Definition XTPCommandBarList.h:144
CXTPCommandBarList::RemoveAll
void RemoveAll()
Call this method to remove all command bars from the list.
CXTPCommandBarList::Lookup
BOOL Lookup(CXTPCommandBar *pCommandBar) const
Call this method to check if a specified command bar is in the list.
CXTPCommandBarList::CXTPCommandBarList
CXTPCommandBarList(CXTPCommandBars *pCommandBars)
Constructs a CXTPCommandBarList object.
Definition XTPCommandBarList.h:49
CXTPCommandBarList::m_pCommandBars
CXTPCommandBars * m_pCommandBars
Parent CXTPCommandBars object.
Definition XTPCommandBarList.h:143
CXTPCommandBarList::~CXTPCommandBarList
virtual ~CXTPCommandBarList()
Destroys a CXTPCommandBarList object, handles cleanup and deallocation.
CXTPCommandBarList::GetCommandBars
CXTPCommandBars * GetCommandBars() const
Call this method to get the CXTPCommandBars parent object attached to the list.
Definition XTPCommandBarList.h:79
CXTPCommandBars
CXTPCommandBars is a standalone class.
Definition XTPCommandBars.h:165


Toolkit Pro: XTPSyntaxEditPaintManager.h Source File

  • Source
  • SyntaxEdit
XTPSyntaxEditPaintManager.h
Go to the documentation of this file.
1
23#if !defined(__XTPSYNTAXEDITPAINTMANAGER_H__)
24# define __XTPSYNTAXEDITPAINTMANAGER_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPSyntaxEditCtrl;
34class CXTPImageManager;
35
37# define XTP_DECLARE_COLOR_PROP(propName) \
38 OLE_COLOR OleGet##propName(); \
39 void OleSet##propName(OLE_COLOR oleColor);
46class _XTP_EXT_CLASS CXTPSyntaxEditPaintManager : public CXTPCmdTarget
47{
49 DECLARE_DYNAMIC(CXTPSyntaxEditPaintManager)
51public:
56 CXTPSyntaxEditPaintManager();
57
63 virtual ~CXTPSyntaxEditPaintManager();
64
70 virtual void InitBitmaps();
71
76 virtual void RefreshMetrics();
77
88 virtual BOOL UpdateTextFont(CXTPSyntaxEditCtrl* pEditCtrl, const XTP_EDIT_FONTOPTIONS& lf);
89
98 virtual void DrawLineNumber(CDC* pDC, const CRect& rcRect, int nTextRow,
99 CXTPSyntaxEditCtrl* pEditCtrl);
100
111 virtual void DrawLineNode(CDC* pDC, const CRect& rcNode, const CRect& rcNodeFull, DWORD dwType,
112 int nTextRow, CXTPSyntaxEditCtrl* pEditCtrl);
113
123 virtual void DrawLineNodeBackground(CDC* pDC, const CRect& rcNodeFull, DWORD dwType,
124 int nTextRow, CXTPSyntaxEditCtrl* pEditCtrl);
125
132 virtual void DrawCollapsedTextMarks(CXTPSyntaxEditCtrl* pEditCtrl, CDC* pDC);
133
142 virtual void DrawLineMarks(CDC* pDC, const CRect& rcRect, int nTextRow,
143 CXTPSyntaxEditCtrl* pEditCtrl);
144
156 virtual int DrawLineTextEx(CDC* pDC, const CRect& rcTextLine, int nTextRow, int nLine,
157 CXTPSyntaxEditCtrl* pEditCtrl);
158
173 virtual int PrintLineTextEx(CDC* pDC, const CRect& rcTextLine, int nTextRow, int nLine,
174 CXTPSyntaxEditCtrl* pEditCtrl, int nFlags = 0);
175
187 virtual void DrawLineCalcSel(const XTP_EDIT_TEXTBLOCK& txtBlk, int nSelStartX, int nSelEndX,
188 XTP_EDIT_TEXTBLOCK (&arTxtBlk)[4], BOOL (&bUseBlk)[4]);
189
190protected:
199 virtual void DrawLineMark(CXTPSyntaxEditCtrl* pEditCtrl, XTP_EDIT_SENMBOOKMARK* pBookmark);
200
208 virtual void DrawLineNumbersBorder(CDC* pDC, const CRect& rcLineNum, const COLORREF clrBorder);
209
210public:
221 HCURSOR SetLineSelCursor(HCURSOR hCurLine);
222
232 HCURSOR SetCopyCursor(HCURSOR hCurCopy);
233
243 HCURSOR SetMoveCursor(HCURSOR hCurMove);
244
253 COLORREF GetTextColor() const;
254
263 COLORREF GetBackColor() const;
264
275 COLORREF GetBackColorEx(CXTPSyntaxEditCtrl* pEditCtrl);
276
285 COLORREF GetHiliteTextColor() const;
286
295 COLORREF GetHiliteBackColor() const;
296
305 COLORREF GetInactiveHiliteTextColor() const;
306
315 COLORREF GetInactiveHiliteBackColor() const;
316
325 COLORREF GetLineNumberTextColor() const;
326
335 COLORREF GetLineNumberBackColor() const;
336
345 COLORREF GetBreakpointTextColor() const;
346
355 COLORREF GetBreakpointBackColor() const;
356
368 BOOL SetTextColor(COLORREF crText, BOOL bUpdateReg = FALSE);
369
381 BOOL SetBackColor(COLORREF crBack, BOOL bUpdateReg = FALSE);
382
394 BOOL SetReadOnlyBackColor(COLORREF crBack, BOOL bUpdateReg = FALSE);
395
407 BOOL SetHiliteTextColor(COLORREF color, BOOL bUpdateReg = FALSE);
408
420 BOOL SetHiliteBackColor(COLORREF color, BOOL bUpdateReg = FALSE);
421
433 BOOL SetInactiveHiliteTextColor(COLORREF color, BOOL bUpdateReg = FALSE);
434
446 BOOL SetInactiveHiliteBackColor(COLORREF color, BOOL bUpdateReg = FALSE);
447
459 BOOL SetLineNumberTextColor(COLORREF color, BOOL bUpdateReg = FALSE);
460
472 BOOL SetLineNumberBackColor(COLORREF color, BOOL bUpdateReg = FALSE);
473
485 BOOL SetBreakpointTextColor(COLORREF color, BOOL bUpdateReg = FALSE);
486
498 BOOL SetBreakpointBackColor(COLORREF color, BOOL bUpdateReg = FALSE);
499
500public:
509 CFont* GetFont();
510
519 CFont* GetFontText();
520
529 CFont* GetFontLineNumber();
530
539 CFont* GetFontToolTip(); // ToolTip font.
540
550 BOOL SetFont(LPLOGFONT pLogfont);
551
561 BOOL SetFontText(LPLOGFONT pLogfont);
562
572 BOOL SetFontLineNumber(LPLOGFONT pLogfont);
573
583 BOOL SetFontToolTip(LPLOGFONT pLogfont);
584
596 BOOL CreateFontIndirect(LPLOGFONT pLogfont, BOOL bUpdateReg = FALSE);
597
606 HCURSOR GetCurLine();
607
616 HCURSOR GetCurMove();
617
626 HCURSOR GetCurCopy();
627
634 HCURSOR GetCurNO();
635
642 HCURSOR GetCurIBeam();
643
650 HCURSOR GetCurArrow();
651
652 CString m_sLineNumberFormat;
656protected:
657 // fonts
658 CXTPFont m_xtpFont;
659 CXTPFont m_xtpFontText;
660 CXTPFont m_xtpFontLineNumber;
661 CXTPFont m_xtpFontToolTip;
663 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CFont, m_font, m_xtpFont, GetFontHandle);
664 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CFont, m_fontText, m_xtpFontText, GetTextFontHandle);
665 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CFont, m_fontLineNumber, m_xtpFontLineNumber,
666 GetLineNumberFontHandle);
667 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CFont, m_fontToolTip, m_xtpFontToolTip,
668 GetToolTipFontHandle);
669
670 // cursors
671 HCURSOR m_hCurLine;
672 HCURSOR m_hCurMove;
673 HCURSOR m_hCurCopy;
674 HCURSOR m_hCurNO;
675 HCURSOR m_hCurIBeam;
676 HCURSOR m_hCurArrow;
678 enum IconType
679 {
680 IconBookmark,
681 IconBookmarkSelected,
682 IconBreakpoint
683 };
684
685 CXTPImageManager* m_pImageManager;
686
687 CPen m_penGray;
689 XTP_EDIT_COLORVALUES m_clrValues;
697 virtual CXTPImageManager* GetBookmarks();
698
699protected:
700# ifdef _XTP_ACTIVEX
703 DECLARE_DISPATCH_MAP()
704 DECLARE_INTERFACE_MAP()
705
706 DECLARE_OLETYPELIB_EX(CXTPSyntaxEditPaintManager)
707
708 XTP_DECLARE_COLOR_PROP(TextColor)
709 XTP_DECLARE_COLOR_PROP(BackColor)
710 XTP_DECLARE_COLOR_PROP(ReadOnlyBackColor)
711 XTP_DECLARE_COLOR_PROP(LineNumberTextColor)
712 XTP_DECLARE_COLOR_PROP(LineNumberBackColor)
713 XTP_DECLARE_COLOR_PROP(SelectedTextColor)
714 XTP_DECLARE_COLOR_PROP(SelectedBackColor)
715 XTP_DECLARE_COLOR_PROP(BreakpontTextColor)
716 XTP_DECLARE_COLOR_PROP(BreakpontBackColor)
717
719# endif
720};
721
723AFX_INLINE COLORREF CXTPSyntaxEditPaintManager::GetTextColor() const
724{
725 return m_clrValues.crText;
726}
727AFX_INLINE COLORREF CXTPSyntaxEditPaintManager::GetBackColor() const
728{
729 return m_clrValues.crBack;
730}
731AFX_INLINE COLORREF CXTPSyntaxEditPaintManager::GetBackColorEx(CXTPSyntaxEditCtrl* pEditCtrl)
732{
733 return m_clrValues.GetBackColorEx(pEditCtrl);
734}
735AFX_INLINE COLORREF CXTPSyntaxEditPaintManager::GetHiliteTextColor() const
736{
737 return m_clrValues.crHiliteText;
738}
739AFX_INLINE COLORREF CXTPSyntaxEditPaintManager::GetHiliteBackColor() const
740{
741 return m_clrValues.crHiliteBack;
742}
743AFX_INLINE COLORREF CXTPSyntaxEditPaintManager::GetInactiveHiliteTextColor() const
744{
745 return m_clrValues.crInactiveHiliteText;
746}
747AFX_INLINE COLORREF CXTPSyntaxEditPaintManager::GetInactiveHiliteBackColor() const
748{
749 return m_clrValues.crInactiveHiliteBack;
750}
751AFX_INLINE COLORREF CXTPSyntaxEditPaintManager::GetLineNumberTextColor() const
752{
753 return m_clrValues.crLineNumberText;
754}
755AFX_INLINE COLORREF CXTPSyntaxEditPaintManager::GetLineNumberBackColor() const
756{
757 return m_clrValues.crLineNumberBack;
758}
759AFX_INLINE COLORREF CXTPSyntaxEditPaintManager::GetBreakpointTextColor() const
760{
761 return m_clrValues.crBreakpointText;
762}
763AFX_INLINE COLORREF CXTPSyntaxEditPaintManager::GetBreakpointBackColor() const
764{
765 return m_clrValues.crBreakpointBack;
766}
767
769
770//{{AFX_INSERT_LOCATION}}
771// Microsoft Visual C++ will insert additional declarations immediately before the previous line.
772
773# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
775#endif // !defined(__XTPSYNTAXEDITPAINTMANAGER_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPFont
Provides a convenient object oriented interface for HFONT GDI object and uses GDI handle caching.
Definition XTPGdiObjects.h:414
CXTPImageManager
CXTPImageManager is a standalone class.
Definition XTPImageManager.h:1898
CXTPSyntaxEditCtrl
This class is the main CWnd-based editor class.
Definition XTPSyntaxEditCtrl.h:114
CXTPSyntaxEditPaintManager
This class is used by CXTPSyntaxEditCtrl as the paint manager.
Definition XTPSyntaxEditPaintManager.h:47
CXTPSyntaxEditPaintManager::CXTPSyntaxEditPaintManager
CXTPSyntaxEditPaintManager()
Default object constructor.
CXTPSyntaxEditPaintManager::GetTextColor
COLORREF GetTextColor() const
Gets the text color.
Definition XTPSyntaxEditPaintManager.h:723
CXTPSyntaxEditPaintManager::DrawCollapsedTextMarks
virtual void DrawCollapsedTextMarks(CXTPSyntaxEditCtrl *pEditCtrl, CDC *pDC)
Draws frames around collapsed text blocks.
CXTPSyntaxEditPaintManager::GetCurLine
HCURSOR GetCurLine()
Gets the cursor to show on the line selection area.
CXTPSyntaxEditPaintManager::m_xtpFont
CXTPFont m_xtpFont
Default font for normal text.
Definition XTPSyntaxEditPaintManager.h:658
CXTPSyntaxEditPaintManager::GetInactiveHiliteBackColor
COLORREF GetInactiveHiliteBackColor() const
Gets the selected background color for when the control does not have focus.
Definition XTPSyntaxEditPaintManager.h:747
CXTPSyntaxEditPaintManager::GetBreakpointBackColor
COLORREF GetBreakpointBackColor() const
Gets the breakpoint background color.
Definition XTPSyntaxEditPaintManager.h:763
CXTPSyntaxEditPaintManager::SetFontText
BOOL SetFontText(LPLOGFONT pLogfont)
Sets the editor text font.
CXTPSyntaxEditPaintManager::DrawLineTextEx
virtual int DrawLineTextEx(CDC *pDC, const CRect &rcTextLine, int nTextRow, int nLine, CXTPSyntaxEditCtrl *pEditCtrl)
Draws row text.
CXTPSyntaxEditPaintManager::~CXTPSyntaxEditPaintManager
virtual ~CXTPSyntaxEditPaintManager()
Destroys a CXTPSyntaxEditPaintManager object, handles cleanup and deallocation.
CXTPSyntaxEditPaintManager::m_penGray
CPen m_penGray
Standard common gray pen.
Definition XTPSyntaxEditPaintManager.h:687
CXTPSyntaxEditPaintManager::m_hCurLine
HCURSOR m_hCurLine
Cursor to show on the line selection area.
Definition XTPSyntaxEditPaintManager.h:671
CXTPSyntaxEditPaintManager::SetFontToolTip
BOOL SetFontToolTip(LPLOGFONT pLogfont)
Sets the tooltip font.
CXTPSyntaxEditPaintManager::GetBookmarks
virtual CXTPImageManager * GetBookmarks()
Gets the bookmarks image manager.
CXTPSyntaxEditPaintManager::GetCurNO
HCURSOR GetCurNO()
Gets the standard NO cursor.
CXTPSyntaxEditPaintManager::SetFontLineNumber
BOOL SetFontLineNumber(LPLOGFONT pLogfont)
Sets the line numbers font.
CXTPSyntaxEditPaintManager::SetLineNumberTextColor
BOOL SetLineNumberTextColor(COLORREF color, BOOL bUpdateReg=FALSE)
Sets the line numbers text color.
CXTPSyntaxEditPaintManager::GetBackColor
COLORREF GetBackColor() const
Gets the background color.
Definition XTPSyntaxEditPaintManager.h:727
CXTPSyntaxEditPaintManager::PrintLineTextEx
virtual int PrintLineTextEx(CDC *pDC, const CRect &rcTextLine, int nTextRow, int nLine, CXTPSyntaxEditCtrl *pEditCtrl, int nFlags=0)
Prints row text.
CXTPSyntaxEditPaintManager::GetFontText
CFont * GetFontText()
Gets the editor text font.
CXTPSyntaxEditPaintManager::SetBreakpointBackColor
BOOL SetBreakpointBackColor(COLORREF color, BOOL bUpdateReg=FALSE)
Sets the breakpoint background color.
CXTPSyntaxEditPaintManager::SetHiliteBackColor
BOOL SetHiliteBackColor(COLORREF color, BOOL bUpdateReg=FALSE)
Sets the selected background color.
CXTPSyntaxEditPaintManager::m_xtpFontLineNumber
CXTPFont m_xtpFontLineNumber
Font for line numbering.
Definition XTPSyntaxEditPaintManager.h:660
CXTPSyntaxEditPaintManager::m_xtpFontToolTip
CXTPFont m_xtpFontToolTip
Font for tooltip text.
Definition XTPSyntaxEditPaintManager.h:661
CXTPSyntaxEditPaintManager::GetCurIBeam
HCURSOR GetCurIBeam()
Gets the standard IBEAM cursor.
CXTPSyntaxEditPaintManager::SetBackColor
BOOL SetBackColor(COLORREF crBack, BOOL bUpdateReg=FALSE)
Sets the background color.
CXTPSyntaxEditPaintManager::GetCurMove
HCURSOR GetCurMove()
Gets the cursor for moving text.
CXTPSyntaxEditPaintManager::SetLineSelCursor
HCURSOR SetLineSelCursor(HCURSOR hCurLine)
Sets the line selection cursor.
CXTPSyntaxEditPaintManager::GetLineNumberBackColor
COLORREF GetLineNumberBackColor() const
Gets the line numbers background color.
Definition XTPSyntaxEditPaintManager.h:755
CXTPSyntaxEditPaintManager::GetCurCopy
HCURSOR GetCurCopy()
Gets the cursor for copying text.
CXTPSyntaxEditPaintManager::GetBackColorEx
COLORREF GetBackColorEx(CXTPSyntaxEditCtrl *pEditCtrl)
Gets the corresponding background color for either the edit or read-only mode of a specified CXTPSynt...
Definition XTPSyntaxEditPaintManager.h:731
CXTPSyntaxEditPaintManager::SetFont
BOOL SetFont(LPLOGFONT pLogfont)
Set the common font.
CXTPSyntaxEditPaintManager::SetInactiveHiliteTextColor
BOOL SetInactiveHiliteTextColor(COLORREF color, BOOL bUpdateReg=FALSE)
Sets the selected text color for when the control does not have focus.
CXTPSyntaxEditPaintManager::GetBreakpointTextColor
COLORREF GetBreakpointTextColor() const
Gets the breakpoint text color.
Definition XTPSyntaxEditPaintManager.h:759
CXTPSyntaxEditPaintManager::m_clrValues
XTP_EDIT_COLORVALUES m_clrValues
Default color.
Definition XTPSyntaxEditPaintManager.h:689
CXTPSyntaxEditPaintManager::UpdateTextFont
virtual BOOL UpdateTextFont(CXTPSyntaxEditCtrl *pEditCtrl, const XTP_EDIT_FONTOPTIONS &lf)
Updates the edit control text font.
CXTPSyntaxEditPaintManager::SetCopyCursor
HCURSOR SetCopyCursor(HCURSOR hCurCopy)
Sets the cursor shape for "copy" cursor.
CXTPSyntaxEditPaintManager::DrawLineMarks
virtual void DrawLineMarks(CDC *pDC, const CRect &rcRect, int nTextRow, CXTPSyntaxEditCtrl *pEditCtrl)
Draws line marks.
CXTPSyntaxEditPaintManager::InitBitmaps
virtual void InitBitmaps()
Initializes default paint manager bitmaps, should be called after creating the control window.
CXTPSyntaxEditPaintManager::DrawLineCalcSel
virtual void DrawLineCalcSel(const XTP_EDIT_TEXTBLOCK &txtBlk, int nSelStartX, int nSelEndX, XTP_EDIT_TEXTBLOCK(&arTxtBlk)[4], BOOL(&bUseBlk)[4])
Draws the editor text line and calculates the selection position.
CXTPSyntaxEditPaintManager::DrawLineMark
virtual void DrawLineMark(CXTPSyntaxEditCtrl *pEditCtrl, XTP_EDIT_SENMBOOKMARK *pBookmark)
Draws a line mark.
CXTPSyntaxEditPaintManager::DrawLineNumbersBorder
virtual void DrawLineNumbersBorder(CDC *pDC, const CRect &rcLineNum, const COLORREF clrBorder)
Draws the line numbers border.
CXTPSyntaxEditPaintManager::SetInactiveHiliteBackColor
BOOL SetInactiveHiliteBackColor(COLORREF color, BOOL bUpdateReg=FALSE)
Sets the selected background color for when the control does not have focus.
CXTPSyntaxEditPaintManager::SetReadOnlyBackColor
BOOL SetReadOnlyBackColor(COLORREF crBack, BOOL bUpdateReg=FALSE)
Sets the background color for read-only mode.
CXTPSyntaxEditPaintManager::GetHiliteTextColor
COLORREF GetHiliteTextColor() const
Gets the selected text color.
Definition XTPSyntaxEditPaintManager.h:735
CXTPSyntaxEditPaintManager::SetBreakpointTextColor
BOOL SetBreakpointTextColor(COLORREF color, BOOL bUpdateReg=FALSE)
Sets the breakpoint text color.
CXTPSyntaxEditPaintManager::m_hCurArrow
HCURSOR m_hCurArrow
Standard ARROW cursor.
Definition XTPSyntaxEditPaintManager.h:676
CXTPSyntaxEditPaintManager::m_hCurNO
HCURSOR m_hCurNO
Standard NO cursor.
Definition XTPSyntaxEditPaintManager.h:674
CXTPSyntaxEditPaintManager::SetTextColor
BOOL SetTextColor(COLORREF crText, BOOL bUpdateReg=FALSE)
Sets the text color.
CXTPSyntaxEditPaintManager::GetLineNumberTextColor
COLORREF GetLineNumberTextColor() const
Gets the line numbers text color.
Definition XTPSyntaxEditPaintManager.h:751
CXTPSyntaxEditPaintManager::m_hCurMove
HCURSOR m_hCurMove
Cursor for moving text.
Definition XTPSyntaxEditPaintManager.h:672
CXTPSyntaxEditPaintManager::m_sLineNumberFormat
CString m_sLineNumberFormat
String to customize Line Number format (e.g.
Definition XTPSyntaxEditPaintManager.h:652
CXTPSyntaxEditPaintManager::GetFont
CFont * GetFont()
Gets the common font.
CXTPSyntaxEditPaintManager::GetInactiveHiliteTextColor
COLORREF GetInactiveHiliteTextColor() const
Gets the selected text color for when the control does not have focus.
Definition XTPSyntaxEditPaintManager.h:743
CXTPSyntaxEditPaintManager::m_hCurIBeam
HCURSOR m_hCurIBeam
Standard IBEAM cursor.
Definition XTPSyntaxEditPaintManager.h:675
CXTPSyntaxEditPaintManager::DrawLineNumber
virtual void DrawLineNumber(CDC *pDC, const CRect &rcRect, int nTextRow, CXTPSyntaxEditCtrl *pEditCtrl)
Draws a line number.
CXTPSyntaxEditPaintManager::GetFontLineNumber
CFont * GetFontLineNumber()
Gets the line numbers font.
CXTPSyntaxEditPaintManager::DrawLineNodeBackground
virtual void DrawLineNodeBackground(CDC *pDC, const CRect &rcNodeFull, DWORD dwType, int nTextRow, CXTPSyntaxEditCtrl *pEditCtrl)
Draws the line node background.
CXTPSyntaxEditPaintManager::GetFontToolTip
CFont * GetFontToolTip()
Gets the tooltip font.
CXTPSyntaxEditPaintManager::RefreshMetrics
virtual void RefreshMetrics()
Refreshes the visual metrics of the manager.
CXTPSyntaxEditPaintManager::GetCurArrow
HCURSOR GetCurArrow()
Gets the standard ARROW cursor.
CXTPSyntaxEditPaintManager::m_hCurCopy
HCURSOR m_hCurCopy
Cursor for copying text.
Definition XTPSyntaxEditPaintManager.h:673
CXTPSyntaxEditPaintManager::CreateFontIndirect
BOOL CreateFontIndirect(LPLOGFONT pLogfont, BOOL bUpdateReg=FALSE)
Sets all editor fonts.
CXTPSyntaxEditPaintManager::GetHiliteBackColor
COLORREF GetHiliteBackColor() const
Gets the selected background color.
Definition XTPSyntaxEditPaintManager.h:739
CXTPSyntaxEditPaintManager::DrawLineNode
virtual void DrawLineNode(CDC *pDC, const CRect &rcNode, const CRect &rcNodeFull, DWORD dwType, int nTextRow, CXTPSyntaxEditCtrl *pEditCtrl)
Draws the line collapsible node icon.
CXTPSyntaxEditPaintManager::SetHiliteTextColor
BOOL SetHiliteTextColor(COLORREF color, BOOL bUpdateReg=FALSE)
Sets the selected text color.
CXTPSyntaxEditPaintManager::SetMoveCursor
HCURSOR SetMoveCursor(HCURSOR hCurMove)
Sets the cursor shape for "move" cursor.
CXTPSyntaxEditPaintManager::SetLineNumberBackColor
BOOL SetLineNumberBackColor(COLORREF color, BOOL bUpdateReg=FALSE)
Sets the line numbers background color.
CXTPSyntaxEditPaintManager::m_xtpFontText
CXTPFont m_xtpFontText
Current text font.
Definition XTPSyntaxEditPaintManager.h:659
XTP_EDIT_COLORVALUES
Stores the colors for different phrases.
Definition XTPSyntaxEditStruct.h:197
XTP_EDIT_COLORVALUES::crBreakpointText
CXTPPaintManagerColor crBreakpointText
Breakpoint Text color.
Definition XTPSyntaxEditStruct.h:207
XTP_EDIT_COLORVALUES::crLineNumberBack
CXTPPaintManagerColor crLineNumberBack
Line numbers text and line color.
Definition XTPSyntaxEditStruct.h:206
XTP_EDIT_COLORVALUES::crBreakpointBack
CXTPPaintManagerColor crBreakpointBack
Breakpoint Back color.
Definition XTPSyntaxEditStruct.h:208
XTP_EDIT_COLORVALUES::crText
CXTPPaintManagerColor crText
Text color.
Definition XTPSyntaxEditStruct.h:198
XTP_EDIT_COLORVALUES::crHiliteBack
CXTPPaintManagerColor crHiliteBack
Text color of selection back.
Definition XTPSyntaxEditStruct.h:202
XTP_EDIT_COLORVALUES::crInactiveHiliteText
CXTPPaintManagerColor crInactiveHiliteText
Inactive text color of selection.
Definition XTPSyntaxEditStruct.h:203
XTP_EDIT_COLORVALUES::crBack
CXTPPaintManagerColor crBack
Back color.
Definition XTPSyntaxEditStruct.h:199
XTP_EDIT_COLORVALUES::crLineNumberText
CXTPPaintManagerColor crLineNumberText
Line numbers text and line color.
Definition XTPSyntaxEditStruct.h:205
XTP_EDIT_COLORVALUES::GetBackColorEx
COLORREF GetBackColorEx(CXTPSyntaxEditCtrl *pEditCtrl)
Gets the corresponding background color for either the edit or read-only mode of a specified CXTPSynt...
XTP_EDIT_COLORVALUES::crInactiveHiliteBack
CXTPPaintManagerColor crInactiveHiliteBack
Inactive text color of selection back.
Definition XTPSyntaxEditStruct.h:204
XTP_EDIT_COLORVALUES::crHiliteText
CXTPPaintManagerColor crHiliteText
Text color of selection.
Definition XTPSyntaxEditStruct.h:201
XTP_EDIT_FONTOPTIONS
The XTP_EDIT_FONTOPTIONS structure is a self-initializing LOGFONT structure that initializes all valu...
Definition XTPSyntaxEditStruct.h:273
XTP_EDIT_SENMBOOKMARK
Bookmark notification structure.
Definition XTPSyntaxEditStruct.h:322
XTP_EDIT_TEXTBLOCK
Summary The XTP_EDIT_TEXTBLOCK structure stores the text blocks after parsing.
Definition XTPSyntaxEditStruct.h:286


Toolkit Pro: Member List

CXTPComInitializer Member List

This is the complete list of members for CXTPComInitializer, including all inherited members.

CXTPComInitializer(int xtpComInit=xtpComInitAppDefault) | CXTPComInitializer
GetInitFlags() const | CXTPComInitializer
GetInitializationStatus() const | CXTPComInitializer
~CXTPComInitializer() | CXTPComInitializer


Toolkit Pro: XTPMarkupGdiImage.h Source File

  • Source
  • Markup
  • DeviceContext
XTPMarkupGdiImage.h
Go to the documentation of this file.
1
23#if !defined(__XTPMARKUPGDIIMAGE_H__)
24# define __XTPMARKUPGDIIMAGE_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPImageManager;
34class CXTPImageManagerIcon;
35
40class _XTP_EXT_CLASS CXTPMarkupGdiImage : public CXTPMarkupDeviceDependentImage
41{
43 DECLARE_DYNAMIC(CXTPMarkupGdiImage);
45public:
51 explicit CXTPMarkupGdiImage(IXTPMarkupDeviceDependentImageSite* pSite);
52
57 virtual ~CXTPMarkupGdiImage();
58
59public:
73 virtual BOOL Load(LPCWSTR lpszSource, int nWidth, int nHeight = 0);
74
81 CXTPImageManagerIcon* GetNativeImage();
82
83private:
84 CXTPImageManager* m_pImageManager;
85 CXTPImageManagerIcon* m_pImage;
86 CXTPMarkupContext* m_pMarkupContext;
87};
88
89AFX_INLINE CXTPImageManagerIcon* CXTPMarkupGdiImage::GetNativeImage()
90{
91 return m_pImage;
92}
94# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
95#endif /*__XTPMARKUPGDIIMAGE_H__*/
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPImageManager
CXTPImageManager is a standalone class.
Definition XTPImageManager.h:1898
CXTPImageManagerIcon
Icons holder class.
Definition XTPImageManager.h:622
CXTPMarkupContext
CXTPMarkupContext is a standalone class used to provide common settings for Markup objects.
Definition XTPMarkupContext.h:128
CXTPMarkupDeviceDependentImage
Implements an abstract device dependent image.
Definition XTPMarkupDeviceDependentImage.h:73
CXTPMarkupGdiImage
Implements an abstract GDI device dependent image.
Definition XTPMarkupGdiImage.h:41
CXTPMarkupGdiImage::GetNativeImage
CXTPImageManagerIcon * GetNativeImage()
Obtains the wrapped image pointer.
Definition XTPMarkupGdiImage.h:89
CXTPMarkupGdiImage::~CXTPMarkupGdiImage
virtual ~CXTPMarkupGdiImage()
Handles device dependent image object deallocation.
CXTPMarkupGdiImage::Load
virtual BOOL Load(LPCWSTR lpszSource, int nWidth, int nHeight=0)
Loads an image from a specified resource.
CXTPMarkupGdiImage::CXTPMarkupGdiImage
CXTPMarkupGdiImage(IXTPMarkupDeviceDependentImageSite *pSite)
Constructs a device dependent image object.
IXTPMarkupDeviceDependentImageSite
Describes an image site interface.
Definition XTPMarkupDeviceDependentImage.h:40


Toolkit Pro: Member List

CXTPFontListBox Member List

This is the complete list of members for CXTPFontListBox, including all inherited members.

CreateUIFont(CFont &font) | CXTPFontCtrlBase | static
CXTPFontCtrlBase() | CXTPFontCtrlBase |
CXTPFontListBox() | CXTPFontListBox |
CXTPListBox() | CXTPListBox |
GetBackColor() | CXTPListBox | virtual
GetFontItemHeight() | CXTPFontCtrlBase | static
GetListStyle() const | CXTPListBox |
GetSelFont(CXTPLogFont &lf) | CXTPFontCtrlBase | virtual
GetSelFont(CString &strFaceName) | CXTPFontCtrlBase | virtual
HasFocus() const | CXTPListBox |
Initialize(bool bAutoFont=true) | CXTPFontListBox | virtual
m_csSymbol | CXTPFontCtrlBase | protected
m_dwStyle | CXTPFontCtrlBase | protected
m_nHotItem | CXTPListBox |
m_nItemHeight | CXTPListBox |
m_nTextPadding | CXTPListBox |
m_pComboBox | CXTPFontCtrlBase | protected
m_pListBox | CXTPFontCtrlBase | protected
m_pTheme | CXTPListBox |
m_theme | CXTPListBox |
OnCompareItem(LPCOMPAREITEMSTRUCT lpCIS) | CXTPFontCtrlBase | protectedvirtual
OnDrawItem(LPDRAWITEMSTRUCT lpDIS) | CXTPFontCtrlBase | protectedvirtual
OnInit(CXTPFontListBox *pListBox) | CXTPFontCtrlBase | protectedvirtual
OnInit(CXTPFontComboBox *pComboBox) | CXTPFontCtrlBase | protectedvirtual
OnMeasureItem(LPMEASUREITEMSTRUCT lpMIS) | CXTPFontCtrlBase | protectedvirtual
RefreshMetrics() | CXTPListBox | virtual
SetListStyle(DWORD dwStyle) | CXTPFontListBox |
CXTPListBox::SetListStyle(XTPListBoxStyle style) | CXTPListBox |
SetSelFont(CXTPLogFont &lf) | CXTPFontCtrlBase | virtual
SetSelFont(const CString &strFaceName) | CXTPFontCtrlBase | virtual
SetTheme(XTPControlTheme nTheme) | CXTPListBox |
TryItemFromPoint(CPoint pt, BOOL &bOutside, int &nIndex) const | CXTPListBox | protected
~CXTPFontCtrlBase() | CXTPFontCtrlBase | virtual
~CXTPFontListBox() | CXTPFontListBox | virtual
~CXTPListBox() | CXTPListBox | virtual


Toolkit Pro: Member List

CXTPChartRadarSplineAreaSeriesView Member List

This is the complete list of members for CXTPChartRadarSplineAreaSeriesView, including all inherited members.

AddChildView(CXTPChartElementView *pChildView) | CXTPChartElementView |
CreateDeviceCommand(CXTPChartDeviceContext *pDC) | CXTPChartRadarSplineAreaSeriesView | protectedvirtual
CreateLegendDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcBounds) | CXTPChartRadarAreaSeriesView | virtual
CreateSeriesPointView(CXTPChartDeviceContext *pDC, CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView) | CXTPChartRadarSplineAreaSeriesView | protected
CXTPChartElementView(CXTPChartElementView *pParentView) | CXTPChartElementView |
CXTPChartElementView(CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartElementView |
CXTPChartElementView(CXTPChartContainer *pContainer) | CXTPChartElementView |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartRadarAreaSeriesView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView) | CXTPChartRadarAreaSeriesView |
CXTPChartRadarSplineAreaSeriesView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView) | CXTPChartRadarSplineAreaSeriesView |
GetActualColor() const | CXTPChartRadarAreaSeriesView |
GetActualColor2() const | CXTPChartRadarAreaSeriesView |
GetAt(int nIndex) const | CXTPChartElementView |
GetBorderActualColor() const | CXTPChartRadarAreaSeriesView |
GetBounds() const | CXTPChartElementView |
GetBounds(BOOL bIncludingChildren) const | CXTPChartElementView |
GetChildren() | CXTPChartElementView |
GetCount() const | CXTPChartElementView |
GetParentView() const | CXTPChartElementView |
Is3D() const | CXTPChartObject |
m_arrChildren | CXTPChartElementView | protected
m_pContainer | CXTPChartElementView | protected
m_pParentView | CXTPChartElementView | protected
m_rcBounds | CXTPChartElementView | protected
~CXTPChartElementView() | CXTPChartElementView | protectedvirtual
~CXTPChartLegendItemView() | CXTPChartLegendItemView | inlinevirtual


Toolkit Pro: Member List

CXTPProgressThemeVisualStudio2019 Member List

This is the complete list of members for CXTPProgressThemeVisualStudio2019, including all inherited members.

CXTPProgressPaintManager(CXTPPaintManager *pPaintManager) | CXTPProgressPaintManager |
CXTPProgressThemeOffice2013(CXTPPaintManager *pPaintManager) | CXTPProgressThemeOffice2013 |
CXTPProgressThemeVisualStudio2019(CXTPPaintManager *pPaintManager) | CXTPProgressThemeVisualStudio2019 |
DrawProgress(CDC *pDC, CXTPProgressBase *pProgressBar) | CXTPProgressThemeOffice2013 | virtual
GetPaintManager() const | CXTPProgressPaintManager |
m_clrBack | CXTPProgressThemeOffice2013 | protected
m_clrBar | CXTPProgressThemeOffice2013 | protected
m_clrBorder | CXTPProgressThemeOffice2013 | protected
m_cyProgress | CXTPProgressPaintManager |
m_pPaintManager | CXTPProgressPaintManager | protected
RefreshMetrics() | CXTPProgressThemeOffice2013 | virtual
~CXTPProgressPaintManager() | CXTPProgressPaintManager | virtual
~CXTPProgressThemeOffice2013() | CXTPProgressThemeOffice2013 | virtual
~CXTPProgressThemeVisualStudio2019() | CXTPProgressThemeVisualStudio2019 | virtual


Toolkit Pro: Member List

CXTPMenuBarMDIMenuInfo Member List

This is the complete list of members for CXTPMenuBarMDIMenuInfo, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPMenuBarMDIMenuInfo(CXTPCommandBars *pCommandBars, UINT nIDResource) | CXTPMenuBarMDIMenuInfo |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
m_bChanged | CXTPMenuBarMDIMenuInfo |
m_hIcon | CXTPMenuBarMDIMenuInfo |
m_nIDResource | CXTPMenuBarMDIMenuInfo |
m_pControls | CXTPMenuBarMDIMenuInfo |
m_strDescription | CXTPMenuBarMDIMenuInfo |
m_strTitle | CXTPMenuBarMDIMenuInfo |
~CXTPMenuBarMDIMenuInfo() | CXTPMenuBarMDIMenuInfo |


Toolkit Pro: Member List

  • CXTPPopupControl
  • POPUPSTATE
CXTPPopupControl::POPUPSTATE Member List

This is the complete list of members for CXTPPopupControl::POPUPSTATE, including all inherited members.

nTransparency | CXTPPopupControl::POPUPSTATE
rcPopup | CXTPPopupControl::POPUPSTATE


Toolkit Pro: Member List

CXTPSkinObjectComboBox Member List

This is the complete list of members for CXTPSkinObjectComboBox, including all inherited members.

CXTPSkinObject() | CXTPSkinObject | protected
CXTPSkinObjectComboBox() | CXTPSkinObjectComboBox |
CXTPSkinObjectFrame() | CXTPSkinObjectFrame |
GetAccessCriticalSection() const | CXTPSynchronized | inline
GetBorders() const | CXTPSkinObjectFrame |
GetCaptionButtons() | CXTPSkinObjectFrame |
GetClassName() const | CXTPSkinObject |
GetClientBrush(CDC *pDC) | CXTPSkinObjectFrame | virtual
GetColor(int nIndex) const | CXTPSkinObject |
GetMetrics() const | CXTPSkinObject |
GetSkinClass() const | CXTPSkinObject |
GetSkinManager() const | CXTPSkinObject |
IsActive() const | CXTPSkinObjectFrame |
m_arrButtons | CXTPSkinObjectFrame | protected
m_bActive | CXTPSkinObjectFrame | protected
m_bActiveX | CXTPSkinObject | protected
m_bLockFrameDraw | CXTPSkinObjectFrame |
m_bMDIClient | CXTPSkinObjectFrame | protected
m_bRegionChanged | CXTPSkinObjectFrame | protected
m_bWindowsForms | CXTPSkinObject | protected
m_dwDialogTexture | CXTPSkinObjectFrame |
m_dwExStyle | CXTPSkinObjectFrame | protected
m_dwStyle | CXTPSkinObjectFrame | protected
m_pButtonHot | CXTPSkinObjectFrame | protected
m_pButtonPressed | CXTPSkinObjectFrame | protected
m_pManager | CXTPSkinObject | protected
m_pOldWndProc | CXTPSkinObject | protected
m_pSBTrack | CXTPSkinObjectFrame | protected
m_rcBorders | CXTPSkinObjectFrame | protected
m_spi | CXTPSkinObjectFrame | protected
m_strClassName | CXTPSkinObject | protected
m_szFrameRegion | CXTPSkinObjectFrame | protected
OnDraw(CDC *pDC) | CXTPSkinObjectComboBox | virtual
OnHookAttached(LPCREATESTRUCT lpcs, BOOL bAuto) | CXTPSkinObjectFrame | protectedvirtual
OnHookDetached(BOOL bAuto) | CXTPSkinObjectFrame | protectedvirtual
OnSkinChanged(BOOL bPrevState, BOOL bNewState) | CXTPSkinObjectFrame | protectedvirtual
RedrawScrollBar(int nBar) | CXTPSkinObjectFrame |
RefreshMetrics() | CXTPSkinObjectFrame | protectedvirtual
~CXTPSkinObject() | CXTPSkinObject | protected
~CXTPSkinObjectComboBox() | CXTPSkinObjectComboBox | virtual
~CXTPSkinObjectFrame() | CXTPSkinObjectFrame | virtual


Toolkit Pro: XTPDockingPaneThemeOffice2007Outlook.h Source File

  • Source
  • DockingPane
  • Themes
XTPDockingPaneThemeOffice2007Outlook.h
Go to the documentation of this file.
1
23#if !defined(__XTPDOCKINGPANETHEMEOFFICE2007OUTLOOK_H__)
24# define __XTPDOCKINGPANETHEMEOFFICE2007OUTLOOK_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
41class _XTP_EXT_CLASS CXTPDockingPaneOffice2007OutlookTheme : public CXTPDockingPaneOffice2007Theme
42{
43public:
48 CXTPDockingPaneOffice2007OutlookTheme();
49
50public:
55 void RefreshMetrics();
56
64 void DrawCaption(CDC* pDC, CXTPDockingPaneTabbedContainer* pPane, CRect rc);
65};
66
67# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
69#endif // !defined(__XTPDOCKINGPANETHEMEOFFICE2007OUTLOOK_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPDockingPaneOffice2007OutlookTheme
CXTPDockingPaneOffice2007OutlookTheme is CXTPDockingPaneOffice2007Theme derived class that represents...
Definition XTPDockingPaneThemeOffice2007Outlook.h:42
CXTPDockingPaneOffice2007OutlookTheme::CXTPDockingPaneOffice2007OutlookTheme
CXTPDockingPaneOffice2007OutlookTheme()
Constructs a CXTPDockingPaneOffice2007OutlookTheme object.
CXTPDockingPaneOffice2007OutlookTheme::RefreshMetrics
void RefreshMetrics()
This method is called to refresh the visual metrics of the pane.
CXTPDockingPaneOffice2007OutlookTheme::DrawCaption
void DrawCaption(CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc)
Override this member function to draw a caption.
CXTPDockingPaneOffice2007Theme
CXTPDockingPaneOffice2007Theme is a CXTPDockingPaneOffice2003Theme derived class that represents an O...
Definition XTPDockingPaneThemeOffice2007.h:41
CXTPDockingPaneTabbedContainer
CXTPDockingPaneTabbedContainer is a multiple inheritance class derived from CWnd and CXTPDockingPaneB...
Definition XTPDockingPaneTabbedContainer.h:47


Toolkit Pro: Member List

CXTPEditListBoxToolBar Member List

This is the complete list of members for CXTPEditListBoxToolBar, including all inherited members.

CXTPEditListBoxToolBar() | CXTPEditListBoxToolBar |
DrawText(CDC *pDC, CRect &rcClient) | CXTPEditListBoxToolBar | virtual
EnableEdit(bool bEnable) | CXTPEditListBoxToolBar |
GetDeleteButton() | CXTPEditListBoxToolBar |
GetDownButton() | CXTPEditListBoxToolBar |
GetNewButton() | CXTPEditListBoxToolBar |
GetTooltipControl() | CXTPEditListBoxToolBar |
GetUpButton() | CXTPEditListBoxToolBar |
Initialize(bool bAutoFont=true) | CXTPEditListBoxToolBar | virtual
m_arButton | CXTPEditListBoxToolBar | protected
m_arClipRect | CXTPEditListBoxToolBar | protected
m_bEnableEdit | CXTPEditListBoxToolBar | protected
m_bShowNewDeleteButtons | CXTPEditListBoxToolBar | protected
m_bShowUpDownButtons | CXTPEditListBoxToolBar | protected
m_theme | CXTPEditListBoxToolBar | protected
m_tooltip | CXTPEditListBoxToolBar | protected
MoveButtons() | CXTPEditListBoxToolBar | virtual
SendCommand(UINT nCmdID) | CXTPEditListBoxToolBar | virtual
SetButtonTheme(XTPControlTheme eTheme) | CXTPEditListBoxToolBar |
SetTheme(XTPControlTheme nTheme) | CXTPEditListBoxToolBar |
~CXTPEditListBoxToolBar() | CXTPEditListBoxToolBar | virtual


Toolkit Pro: Member List

CXTPToolhelpApi Member List

This is the complete list of members for CXTPToolhelpApi, including all inherited members.

CreateSnapshot(DWORD dwFlags, DWORD th32ProcessID) | CXTPToolhelpApi |
GetFirstModule(HANDLE hSnapshot, LPMODULEENTRY32 lpme) | CXTPToolhelpApi |
GetFirstThread(HANDLE hSnapshot, LPTHREADENTRY32 lpte) | CXTPToolhelpApi |
GetNextModule(HANDLE hSnapshot, LPMODULEENTRY32 lpme) | CXTPToolhelpApi |
GetNextThread(HANDLE hSnapshot, LPTHREADENTRY32 lpte) | CXTPToolhelpApi |
Instance() | CXTPToolhelpApi | static
IsInitialized() const | CXTPToolhelpApi |


Toolkit Pro: XTPChart2dPyramidSeriesLabel.h Source File

  • Source
  • Chart
  • Styles
  • Pyramid
  • 2D
XTPChart2dPyramidSeriesLabel.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHART2DPYRAMIDSERIESLABEL_H__)
24# define __XTPCHART2DPYRAMIDSERIESLABEL_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartElementView;
34class CXTPChartDeviceContext;
35class CXTPChartSeriesPointView;
36class CXTPChartElementView;
37
43class _XTP_EXT_CLASS CXTPChartPyramidSeriesLabel : public CXTPChartPyramidSeriesLabelBase
44{
45 DECLARE_SERIAL(CXTPChartPyramidSeriesLabel);
46
47protected:
59 virtual CXTPChartElementView* CreateView(CXTPChartDeviceContext* pDC,
60 CXTPChartSeriesPointView* pPointView,
61 CXTPChartElementView* pParentView);
62
63# ifdef _XTP_ACTIVEX
64public:
66 DECLARE_DISPATCH_MAP()
67 DECLARE_INTERFACE_MAP()
68 DECLARE_OLETYPELIB_EX(CXTPChartPyramidSeriesLabel);
70# endif
71};
72
77class _XTP_EXT_CLASS CXTPChartPyramidSeriesLabelView : public CXTPChartPyramidSeriesLabelViewBase
78{
79 DECLARE_DYNAMIC(CXTPChartPyramidSeriesLabelView);
80
81public:
90 CXTPChartPyramidSeriesLabelView(CXTPChartSeriesLabel* pLabel,
91 CXTPChartSeriesPointView* pPointView,
92 CXTPChartElementView* pParentView);
93
104 virtual CXTPChartDeviceCommand* CreateDeviceCommand(CXTPChartDeviceContext* pDC);
105};
107# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
108#endif //#if !defined(__XTPCHART2DPYRAMIDSERIESLABEL_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartElementView
This class represents the view of a chart element.
Definition XTPChartElementView.h:47
CXTPChartPyramidSeriesLabelBase
This class abstracts the pyramid series label.
Definition XTPChartPyramidSeriesLabelBase.h:55
CXTPChartPyramidSeriesLabel
CXTPChartPyramidSeriesLabel is a kind of CXTPChartSeriesLabel.
Definition XTPChart2dPyramidSeriesLabel.h:44
CXTPChartPyramidSeriesLabel::CreateView
virtual CXTPChartElementView * CreateView(CXTPChartDeviceContext *pDC, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView)
This function creates the view of the pyramid series.
CXTPChartPyramidSeriesLabelViewBase
This class abstracts the view of a pyramid series label.
Definition XTPChartPyramidSeriesLabelBase.h:166
CXTPChartPyramidSeriesLabelView
Defines 2D series label view.
Definition XTPChart2dPyramidSeriesLabel.h:78
CXTPChartPyramidSeriesLabelView::CreateDeviceCommand
virtual CXTPChartDeviceCommand * CreateDeviceCommand(CXTPChartDeviceContext *pDC)
Creates view drawing device command for the device context specified.
CXTPChartPyramidSeriesLabelView::CXTPChartPyramidSeriesLabelView
CXTPChartPyramidSeriesLabelView(CXTPChartSeriesLabel *pLabel, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView)
Constructs a CXTPChartPyramidSeriesLabelView object.
CXTPChartSeriesLabel
This class abstracts the label of a series.
Definition XTPChartSeriesLabel.h:49
CXTPChartSeriesPointView
Represents chart series point view.
Definition XTPChartSeriesPointView.h:48


Toolkit Pro: Member List

CXTPProgressCtrlThemeVisualStudio2022 Member List

This is the complete list of members for CXTPProgressCtrlThemeVisualStudio2022, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPProgressCtrlPaintManager() | CXTPProgressCtrlPaintManager |
CXTPProgressCtrlThemeOffice2000() | CXTPProgressCtrlThemeOffice2000 |
CXTPProgressCtrlThemeOffice2013() | CXTPProgressCtrlThemeOffice2013 |
CXTPProgressCtrlThemeVisualStudio2022() | CXTPProgressCtrlThemeVisualStudio2022 |
DeflateRect(XTPPROGRESSDRAWSTRUCT &ds) | CXTPProgressCtrlPaintManager | protectedvirtual
Draw(XTPPROGRESSDRAWSTRUCT &ds) | CXTPProgressCtrlThemeOffice2013 | virtual
DrawNcBorders(CDC *pDC, CRect rc) | CXTPProgressCtrlThemeOffice2013 | virtual
DrawText(XTPPROGRESSDRAWSTRUCT &ds) | CXTPProgressCtrlPaintManager | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetBackColor() | CXTPProgressCtrlPaintManager |
GetBarColor() | CXTPProgressCtrlPaintManager |
GetBorderColor() | CXTPProgressCtrlPaintManager |
GetTextColor() | CXTPProgressCtrlPaintManager |
m_bUseWinTheme | CXTPProgressCtrlPaintManager | protected
m_clrBack | CXTPProgressCtrlPaintManager | protected
m_clrBar | CXTPProgressCtrlPaintManager | protected
m_clrBarText | CXTPProgressCtrlPaintManager | protected
m_clrBorder | CXTPProgressCtrlPaintManager | protected
m_clrText | CXTPProgressCtrlPaintManager | protected
m_nTheme | CXTPProgressCtrlPaintManager | protected
m_winTheme | CXTPProgressCtrlPaintManager | protected
RefreshMetrics() | CXTPProgressCtrlThemeOffice2013 | virtual
SetBackColor(COLORREF clrNew) | CXTPProgressCtrlPaintManager |
SetBarColor(COLORREF clrNew) | CXTPProgressCtrlPaintManager |
SetBorderColor(COLORREF clrNew) | CXTPProgressCtrlPaintManager |
SetTextColor(COLORREF clrNew) | CXTPProgressCtrlPaintManager |
UseWinThemes(BOOL bUseWinThemes=TRUE) | CXTPProgressCtrlPaintManager |
UsingWinThemes(BOOL bCheckReady=FALSE) | CXTPProgressCtrlPaintManager |
~CXTPProgressCtrlPaintManager() | CXTPProgressCtrlPaintManager | virtual


Toolkit Pro: Member List

CXTPProgressThemeOffice2013 Member List

This is the complete list of members for CXTPProgressThemeOffice2013, including all inherited members.

CXTPProgressPaintManager(CXTPPaintManager *pPaintManager) | CXTPProgressPaintManager |
CXTPProgressThemeOffice2013(CXTPPaintManager *pPaintManager) | CXTPProgressThemeOffice2013 |
DrawProgress(CDC *pDC, CXTPProgressBase *pProgressBar) | CXTPProgressThemeOffice2013 | virtual
GetPaintManager() const | CXTPProgressPaintManager |
m_clrBack | CXTPProgressThemeOffice2013 | protected
m_clrBar | CXTPProgressThemeOffice2013 | protected
m_clrBorder | CXTPProgressThemeOffice2013 | protected
m_cyProgress | CXTPProgressPaintManager |
m_pPaintManager | CXTPProgressPaintManager | protected
RefreshMetrics() | CXTPProgressThemeOffice2013 | virtual
~CXTPProgressPaintManager() | CXTPProgressPaintManager | virtual
~CXTPProgressThemeOffice2013() | CXTPProgressThemeOffice2013 | virtual


Toolkit Pro: XTPDatePickerNotifications.h Source File

  • Source
  • Calendar
  • DatePicker
XTPDatePickerNotifications.h
Go to the documentation of this file.
1
22#if !defined(_XTPDatePickerNotifications_H__)
23# define _XTPDatePickerNotifications_H__
24
25# if _MSC_VER > 1000
26# pragma once
27# endif // _MSC_VER > 1000
28
29# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
30
31//==== CXTPDatePickerControl notification IDs ===============================
32
73static const XTP_NOTIFY_CODE XTP_NC_DATEPICKERBUTTONCLICKED = (WM_XTP_CALENDAR_BASE + 80);
74
106static const XTP_NOTIFY_CODE XTP_NC_DATEPICKERSELECTIONCHANGED = (WM_XTP_CALENDAR_BASE + 81);
107
140static const XTP_NOTIFY_CODE XTP_NC_DATEPICKERBEFOREGOMODAL = (WM_XTP_CALENDAR_BASE + 82);
141
177static const XTP_NOTIFY_CODE XTP_NC_DATEPICKERMOUSEMOVE = (WM_XTP_CALENDAR_BASE + 83);
178
208static const XTP_NOTIFY_CODE XTP_NC_DATEPICKERMONTHCHANGED = (WM_XTP_CALENDAR_BASE + 84);
209
222static const XTP_NOTIFY_CODE XTP_NC_DATEPICKERGETDAYMETRICS = (WM_XTP_CALENDAR_BASE + 85);
224
225# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
226#endif // !defined(_XTPDatePickerNotifications_H__)
WM_XTP_CALENDAR_BASE
const UINT WM_XTP_CALENDAR_BASE
The WM_XTP_CALENDAR_BASE constant is used by Calendar Control to help define private messages for use...
Definition XTPCalendarDefines.h:1069
XTP_NC_DATEPICKERSELECTIONCHANGED
static const XTP_NOTIFY_CODE XTP_NC_DATEPICKERSELECTIONCHANGED
This is a notification ID that is used to indicate that the selection has changed.
Definition XTPDatePickerNotifications.h:106
XTP_NC_DATEPICKERBEFOREGOMODAL
static const XTP_NOTIFY_CODE XTP_NC_DATEPICKERBEFOREGOMODAL
This is a notification ID that indicates that the Date Picker is about to enter modal mode (pop-up wi...
Definition XTPDatePickerNotifications.h:140
XTP_NC_DATEPICKERMONTHCHANGED
static const XTP_NOTIFY_CODE XTP_NC_DATEPICKERMONTHCHANGED
This is a notification ID that is used to indicate that the Date Picker is populated.
Definition XTPDatePickerNotifications.h:208
XTP_NC_DATEPICKERMOUSEMOVE
static const XTP_NOTIFY_CODE XTP_NC_DATEPICKERMOUSEMOVE
This is a notification ID that is used to indicate that the mouse moved under a control.
Definition XTPDatePickerNotifications.h:177
XTP_NC_DATEPICKERGETDAYMETRICS
static const XTP_NOTIFY_CODE XTP_NC_DATEPICKERGETDAYMETRICS
This notification is used to get day item metrics.
Definition XTPDatePickerNotifications.h:222
XTP_NC_DATEPICKERBUTTONCLICKED
static const XTP_NOTIFY_CODE XTP_NC_DATEPICKERBUTTONCLICKED
This is a notification ID that is used to indicate mouse button clicks on a control.
Definition XTPDatePickerNotifications.h:73
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h


Toolkit Pro: Member List

CXTPProgressCtrlThemeFlat Member List

This is the complete list of members for CXTPProgressCtrlThemeFlat, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPProgressCtrlPaintManager() | CXTPProgressCtrlPaintManager |
CXTPProgressCtrlThemeFlat() | CXTPProgressCtrlThemeFlat |
DeflateRect(XTPPROGRESSDRAWSTRUCT &ds) | CXTPProgressCtrlThemeFlat | protectedvirtual
Draw(XTPPROGRESSDRAWSTRUCT &ds) | CXTPProgressCtrlPaintManager | virtual
DrawNcBorders(CDC *pDC, CRect rc) | CXTPProgressCtrlPaintManager | virtual
DrawText(XTPPROGRESSDRAWSTRUCT &ds) | CXTPProgressCtrlPaintManager | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetBackColor() | CXTPProgressCtrlPaintManager |
GetBarColor() | CXTPProgressCtrlPaintManager |
GetBorderColor() | CXTPProgressCtrlPaintManager |
GetTextColor() | CXTPProgressCtrlPaintManager |
m_bUseWinTheme | CXTPProgressCtrlPaintManager | protected
m_clrBack | CXTPProgressCtrlPaintManager | protected
m_clrBar | CXTPProgressCtrlPaintManager | protected
m_clrBarText | CXTPProgressCtrlPaintManager | protected
m_clrBorder | CXTPProgressCtrlPaintManager | protected
m_clrText | CXTPProgressCtrlPaintManager | protected
m_nTheme | CXTPProgressCtrlPaintManager | protected
m_winTheme | CXTPProgressCtrlPaintManager | protected
RefreshMetrics() | CXTPProgressCtrlThemeFlat | virtual
SetBackColor(COLORREF clrNew) | CXTPProgressCtrlPaintManager |
SetBarColor(COLORREF clrNew) | CXTPProgressCtrlPaintManager |
SetBorderColor(COLORREF clrNew) | CXTPProgressCtrlPaintManager |
SetTextColor(COLORREF clrNew) | CXTPProgressCtrlPaintManager |
UseWinThemes(BOOL bUseWinThemes=TRUE) | CXTPProgressCtrlPaintManager |
UsingWinThemes(BOOL bCheckReady=FALSE) | CXTPProgressCtrlPaintManager |
~CXTPProgressCtrlPaintManager() | CXTPProgressCtrlPaintManager | virtual


Toolkit Pro: Member List

CXTPDockingPaneTabPaintManager Member List

This is the complete list of members for CXTPDockingPaneTabPaintManager, including all inherited members.

_GetButtonLength(int nValue, int nMin, int nMax) | CXTPTabPaintManager | protected
AddObserver(CXTPTabManagerAtom *pObserver) | CXTPTabPaintManager |
AdjustClientRect(CXTPTabManager *pTabManager, CRect &rcClient) | CXTPTabPaintManager | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPTabPaintManager(BOOL bPanelManager=FALSE) | CXTPTabPaintManager |
DisableLunaColors(BOOL bDisableLunaColors) | CXTPTabPaintManager |
DrawNavigateButton(CDC *pDC, CXTPTabManagerNavigateButton *pButton, CRect &rc) | CXTPTabPaintManager | virtual
DrawSingleButtonIconAndText(CDC *pDC, CXTPTabManagerItem *pItem, CRect rcItem, BOOL bDraw) | CXTPTabPaintManager | virtual
DrawTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl) | CXTPTabPaintManager | virtual
DrawTabControlEx(CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl) | CXTPTabPaintManager | protected
DrawTextPathEllipsis(CDC *pDC, CXTPTabManager *pManager, const CString &strItem, CRect rcItem, UINT uFormat) | CXTPTabPaintManager | protected
EnableToolTips(XTPTabToolTipBehaviour behaviour=xtpTabToolTipAlways) | CXTPTabPaintManager |
EnsureVisible(CXTPTabManager *pTabManager, CXTPTabManagerItem *pItem) | CXTPTabPaintManager |
FillNavigateButton(CDC *pDC, CXTPTabManagerNavigateButton *pButton, CRect &rc) | CXTPTabPaintManager |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAppearance() const | CXTPTabPaintManager |
GetAppearanceSet() const | CXTPTabPaintManager |
GetBoldFont(BOOL bVertical=FALSE) | CXTPTabPaintManager |
GetColor() const | CXTPTabPaintManager |
GetColorSet() const | CXTPTabPaintManager |
GetFont(BOOL bVertical=FALSE) | CXTPTabPaintManager |
GetLayout() const | CXTPTabPaintManager |
GetOneNoteColor(XTPTabOneNoteColor tabColor) | CXTPTabPaintManager | static
GetPosition() const | CXTPTabPaintManager |
IsLunaColorsDisabled() const | CXTPTabPaintManager |
m_arrObservers | CXTPTabPaintManager | protected
m_bBoldNormal | CXTPTabPaintManager |
m_bBoldSelected | CXTPTabPaintManager |
m_bClearTypeTextQuality | CXTPTabPaintManager |
m_bClipHeader | CXTPTabPaintManager |
m_bDrawFocusRect | CXTPTabPaintManager |
m_bDrawTextEndEllipsis | CXTPTabPaintManager |
m_bDrawTextHidePrefix | CXTPTabPaintManager |
m_bDrawTextNoPrefix | CXTPTabPaintManager |
m_bDrawTextPathEllipsis | CXTPTabPaintManager |
m_bFillBackground | CXTPTabPaintManager |
m_bHotTracking | CXTPTabPaintManager |
m_bInvertGradient | CXTPTabPaintManager |
m_bMultiRowFixedSelection | CXTPTabPaintManager |
m_bMultiRowJustified | CXTPTabPaintManager |
m_bMultiRowTabsOptimization | CXTPTabPaintManager |
m_bOneNoteColors | CXTPTabPaintManager |
m_bPanelManager | CXTPTabPaintManager |
m_bRotateImageOnVerticalDraw | CXTPTabPaintManager |
m_bSelectOnButtonDown | CXTPTabPaintManager |
m_bSelectOnDragOver | CXTPTabPaintManager |
m_bShowIcons | CXTPTabPaintManager |
m_bShowTabs | CXTPTabPaintManager |
m_bStaticFrame | CXTPTabPaintManager |
m_bUseStandardFont | CXTPTabPaintManager | protected
m_bVerticalTextTopToBottom | CXTPTabPaintManager |
m_clientFrame | CXTPTabPaintManager |
m_nButtonExtraLength | CXTPTabPaintManager |
m_nDrawTextFormat | CXTPTabPaintManager |
m_nFixedTabWidth | CXTPTabPaintManager |
m_nMaxTabWidth | CXTPTabPaintManager |
m_nMinTabWidth | CXTPTabPaintManager |
m_nSelectOnDragOverDelay | CXTPTabPaintManager | static
m_pAppearanceSet | CXTPTabPaintManager | protected
m_pColorSet | CXTPTabPaintManager | protected
m_rcButtonMargin | CXTPTabPaintManager |
m_rcButtonTextPadding | CXTPTabPaintManager |
m_rcClientMargin | CXTPTabPaintManager |
m_rcControlMargin | CXTPTabPaintManager |
m_szIcon | CXTPTabPaintManager |
m_szNavigateButton | CXTPTabPaintManager |
m_szTabCloseButton | CXTPTabPaintManager |
m_tabAppearance | CXTPTabPaintManager | protected
m_tabColor | CXTPTabPaintManager | protected
m_tabLayout | CXTPTabPaintManager | protected
m_tabPosition | CXTPTabPaintManager | protected
m_toolBehaviour | CXTPTabPaintManager |
m_xtpFontBold | CXTPTabPaintManager | protected
m_xtpFontNormal | CXTPTabPaintManager | protected
m_xtpFontVerticalBold | CXTPTabPaintManager | protected
m_xtpFontVerticalNormal | CXTPTabPaintManager | protected
OnPropertyChanged() | CXTPTabPaintManager | protectedvirtual
RefreshMetrics() | CXTPTabPaintManager | virtual
RepositionNavigateButtons(CXTPTabManager *pTabManager, CRect rcClient) | CXTPTabPaintManager |
RepositionTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl) | CXTPTabPaintManager | virtual
RepositionTabControlEx(CXTPTabManager *pTabManager, CDC *pDC, CRect rcClient) | CXTPTabPaintManager | protected
RepositionTabControlMultiRow(CXTPTabManager *pTabManager, CDC *pDC, CRect rcClient) | CXTPTabPaintManager | protected
SetAppearance(XTPTabAppearanceStyle tabAppearance) | CXTPDockingPaneTabPaintManager | virtual
SetAppearanceSet(CXTPTabPaintManagerTheme *pAppearanceSet) | CXTPTabPaintManager | virtual
SetColor(XTPTabColorStyle tabColor) | CXTPDockingPaneTabPaintManager | virtual
SetColorSet(CXTPTabPaintManagerColorSet *pColorSet) | CXTPTabPaintManager | virtual
SetFontIndirect(LOGFONT *pLogFont, BOOL bUseStandardFont=FALSE) | CXTPTabPaintManager |
SetLayout(XTPTabLayoutStyle tabLayout) | CXTPTabPaintManager |
SetOneNoteColors(BOOL bOneNoteColors) | CXTPTabPaintManager |
SetPosition(XTPTabPosition tabPosition) | CXTPTabPaintManager |
SizeToFit(CXTPTabManager *pTabManager, int nWidth) | CXTPTabPaintManager | protected
~CXTPTabPaintManager() | CXTPTabPaintManager | virtual


Toolkit Pro: Member List

CXTPThreadLocal< T > Member List

This is the complete list of members for CXTPThreadLocal< T >, including all inherited members.

CreateProc typedef | CXTPThreadLocal< T >
CXTPThreadLocal(CreateProc pfnCreate=DefaultProcs::Create, DestroyProc pfnDestroy=DefaultProcs::Destroy) | CXTPThreadLocal< T >
DestroyProc typedef | CXTPThreadLocal< T >
IsValid() const | CXTPThreadLocal< T >
operator*() | CXTPThreadLocal< T >
operator*() const | CXTPThreadLocal< T >
Reset(BOOL bCurrentThread=FALSE) | CXTPThreadLocal< T >
~CXTPThreadLocal() | CXTPThreadLocal< T >


Toolkit Pro: XTPGridRecordItemDateTime.h Source File

  • Source
  • GridControl
  • ItemTypes
XTPGridRecordItemDateTime.h
Go to the documentation of this file.
1
23#if !defined(__XTPGRIDRECORDITEMDATETIME_H__)
24# define __XTPGRIDRECORDITEMDATETIME_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
43class _XTP_EXT_CLASS CXTPGridRecordItemDateTime : public CXTPGridRecordItem
44{
46 DECLARE_SERIAL(CXTPGridRecordItemDateTime)
48public:
54 CXTPGridRecordItemDateTime(COleDateTime odtValue = (DATE)0);
55
65 virtual CString GetCaption(CXTPGridColumn* pColumn);
66
67 using CXTPGridRecordItem::GetCaption;
68
81 virtual int Compare(CXTPGridColumn* pColumn, CXTPGridRecordItem* pItem);
82
90 virtual COleVariant GetGroupCaptionValue(CXTPGridColumn* pColumn);
91
107 virtual int CompareGroupCaption(CXTPGridColumn* pColumn, CXTPGridGroupRow* pGroupRow);
108
109 using CXTPGridRecordItem::CompareGroupCaption;
110
118 virtual void OnEditChanged(XTP_GRIDRECORDITEM_ARGS* pItemArgs, LPCTSTR szText);
119
126 COleDateTime GetValue();
127
133 void SetValue(COleDateTime odtValue);
134
141 virtual void DoPropExchange(CXTPPropExchange* pPX);
142
143private:
144 static int CompareValues(const COleDateTime& dt1, const COleDateTime& dt2);
145
146protected:
147 COleDateTime m_odtValue;
148};
149
150AFX_INLINE COleDateTime CXTPGridRecordItemDateTime::GetValue()
151{
152 return m_odtValue;
153}
154
155AFX_INLINE void CXTPGridRecordItemDateTime::SetValue(COleDateTime odtValue)
156{
157 m_odtValue = odtValue;
158}
159
160# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
162#endif // !defined(__XTPGRIDRECORDITEMDATETIME_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPGridColumn
Represents a grid column item with its properties and operations.
Definition XTPGridColumn.h:107
CXTPGridGroupRow
This class represents a 'group row' of the Grid control view.
Definition XTPGridGroupRow.h:49
CXTPGridRecordItemDateTime
Represents a time cell and inherits basic functionality from the CXTPGridRecordItem class.
Definition XTPGridRecordItemDateTime.h:44
CXTPGridRecordItemDateTime::DoPropExchange
virtual void DoPropExchange(CXTPPropExchange *pPX)
Call this member function to store/load a grid record item using the specified data object.
CXTPGridRecordItemDateTime::Compare
virtual int Compare(CXTPGridColumn *pColumn, CXTPGridRecordItem *pItem)
Compares the current record item with a provided record item.
CXTPGridRecordItemDateTime::OnEditChanged
virtual void OnEditChanged(XTP_GRIDRECORDITEM_ARGS *pItemArgs, LPCTSTR szText)
This method is called when the value of the in-place edit control is changed.
CXTPGridRecordItemDateTime::m_odtValue
COleDateTime m_odtValue
Cell value.
Definition XTPGridRecordItemDateTime.h:147
CXTPGridRecordItemDateTime::GetValue
COleDateTime GetValue()
Gets the value of the item.
Definition XTPGridRecordItemDateTime.h:150
CXTPGridRecordItemDateTime::SetValue
void SetValue(COleDateTime odtValue)
Sets the value of the item.
Definition XTPGridRecordItemDateTime.h:155
CXTPGridRecordItemDateTime::CXTPGridRecordItemDateTime
CXTPGridRecordItemDateTime(COleDateTime odtValue=(DATE) 0)
Creates a record date/time item.
CXTPGridRecordItemDateTime::GetCaption
virtual CString GetCaption(CXTPGridColumn *pColumn)
Retrieves the text caption of the current item.
CXTPGridRecordItemDateTime::CompareGroupCaption
virtual int CompareGroupCaption(CXTPGridColumn *pColumn, CXTPGridGroupRow *pGroupRow)
Compares the group caption of the current record item with the group caption of a provided group row.
CXTPGridRecordItemDateTime::GetGroupCaptionValue
virtual COleVariant GetGroupCaptionValue(CXTPGridColumn *pColumn)
Retrieves the group caption native value.
CXTPGridRecordItem
Class for working with single list cell.
Definition XTPGridRecordItem.h:600
CXTPGridRecordItem::GetCaption
virtual CString GetCaption()
Gets the text caption of the item.
CXTPGridRecordItem::CompareGroupCaption
virtual int CompareGroupCaption(CXTPGridColumn *pColumn, CXTPGridRecordItem *pItem)
Compares the group caption of the current record item with the group caption of a provided record ite...
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72
XTP_GRIDRECORDITEM_ARGS
Basic set of parameters transferred to item handlers.
Definition XTPGridRecordItem.h:69


Toolkit Pro: Member List

CXTPSyntaxEditLexTextSchema Member List

This is the complete list of members for CXTPSyntaxEditLexTextSchema, including all inherited members.

ApplyTheme(CXTPSyntaxEditColorTheme *pTheme) | CXTPSyntaxEditLexTextSchema | virtual
ApplyThemeRecursive(CXTPSyntaxEditColorTheme *pTheme, CXTPSyntaxEditLexClassPtrArray *ptrClasses) | CXTPSyntaxEditLexTextSchema | protectedvirtual
BuildIfNeed() | CXTPSyntaxEditLexTextSchema |
Clone() | CXTPSyntaxEditLexTextSchema | virtual
Close() | CXTPSyntaxEditLexTextSchema | virtual
Close(CXTPSyntaxEditLexTextBlock *pFirst) | CXTPSyntaxEditLexTextSchema | static
CXTPCmdTarget() | CXTPCmdTarget |
CXTPSyntaxEditLexTextSchema(LPCTSTR pcszSchName) | CXTPSyntaxEditLexTextSchema |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetBlocks() | CXTPSyntaxEditLexTextSchema |
GetBreakParsingEvent() | CXTPSyntaxEditLexTextSchema |
GetClassSchema() | CXTPSyntaxEditLexTextSchema | protected
GetClassSchLoker() | CXTPSyntaxEditLexTextSchema |
GetCollapsableBlocksInfo(int nRow, CXTPSyntaxEditRowsBlockArray &rArBlocks, CXTPSyntaxEditLexTextBlockPtr *pptrTBStartCache=NULL) | CXTPSyntaxEditLexTextSchema | virtual
GetConnection() | CXTPSyntaxEditLexTextSchema | virtual
GetDataLoker() | CXTPSyntaxEditLexTextSchema |
GetLastParsedBlock(WPARAM dwID=0) | CXTPSyntaxEditLexTextSchema | virtual
GetRowColors(CTextIter *pTxtIter, int nRow, int nColFrom, int nColTo, const XTP_EDIT_COLORVALUES &clrDefault, CXTPSyntaxEditTextBlockList *rBlocks, CXTPSyntaxEditLexTextBlockPtr *pptrTBStartCache=NULL, CXTPSyntaxEditLexTextBlock *pFirstSchTB=NULL) | CXTPSyntaxEditLexTextSchema | virtual
GetSchName() const | CXTPSyntaxEditLexTextSchema | virtual
GetTextAttributes(XTP_EDIT_TEXTBLOCK &rTB, CXTPSyntaxEditLexTextBlock *pTextBlock) | CXTPSyntaxEditLexTextSchema | virtual
GetTopClassForFileExt(const CString &strExt) | CXTPSyntaxEditLexTextSchema |
GetUpdatedTextRegion() const | CXTPSyntaxEditLexTextSchema | virtual
IsFileExtSupported(const CString &strExt) | CXTPSyntaxEditLexTextSchema |
LoadClassSchema(CXTPSyntaxEditLexClassInfoArray *arClassInfo) | CXTPSyntaxEditLexTextSchema |
RemoveAll() | CXTPSyntaxEditLexTextSchema | virtual
RunParseOnScreen(CTextIter *pTxtIter, int nRowStart, int nRowEnd, CXTPSyntaxEditLexTextBlockPtr &rPtrScreenSchFirstTB) | CXTPSyntaxEditLexTextSchema | virtual
RunParseUpdate(BOOL bShort, CTextIter *pTxtIter, const XTP_EDIT_LINECOL *pLCStart=NULL, const XTP_EDIT_LINECOL *pLCEnd=NULL, BOOL bSendProgressEvents=FALSE) | CXTPSyntaxEditLexTextSchema | virtual
UpdateTextBlocks(XTP_EDIT_LINECOL posFrom, XTP_EDIT_LINECOL posTo, int eEditAction) | CXTPSyntaxEditLexTextSchema | protected
xtpEditUTBError enum value | CXTPSyntaxEditLexTextSchema | protected
xtpEditUTBNearestUpdated enum value | CXTPSyntaxEditLexTextSchema | protected
xtpEditUTBNothing enum value | CXTPSyntaxEditLexTextSchema | protected
xtpEditUTBReparse enum value | CXTPSyntaxEditLexTextSchema | protected
XTPSyntaxEditUpdateTBRes enum name | CXTPSyntaxEditLexTextSchema | protected
~CXTPSyntaxEditLexTextSchema() | CXTPSyntaxEditLexTextSchema | virtual


Toolkit Pro: XTPSyntaxEditLexCfgFileReader.h Source File

  • Source
  • SyntaxEdit
XTPSyntaxEditLexCfgFileReader.h
Go to the documentation of this file.
1
23#if !defined(__XTPSYNTAXEDITLEXCFGFILEREADER_H__)
24# define __XTPSYNTAXEDITLEXCFGFILEREADER_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPSyntaxEditLexCfgFileReader;
34
36namespace XTPSyntaxEditLexAnalyser
38{
47enum XTPSyntaxEditTokenType
48{
49 xtpEditTokType_Unknown,
50 xtpEditTokType_Delim,
51 xtpEditTokType_Name,
52 xtpEditTokType_Value,
53 xtpEditTokType_Quoted,
54 xtpEditTokType_Comment,
55 xtpEditTokType_EOL,
56 xtpEditTokType_Control
57};
58
65struct _XTP_EXT_CLASS XTP_EDIT_LEXPROPINFO
66{
67 XTP_EDIT_LEXPROPINFO();
68
69 XTP_EDIT_LEXPROPINFO(const XTP_EDIT_LEXPROPINFO& rSrc);
70
71 const XTP_EDIT_LEXPROPINFO& operator=(const XTP_EDIT_LEXPROPINFO& rSrc);
72
73 CStringArray arPropName;
74 CStringArray arPropValue;
75 int nLine;
76 int nOffset;
77 int nPropertyLen;
78};
79
87class _XTP_EXT_CLASS CXTPSyntaxEditLexPropInfoArray
88 : public CArray<XTP_EDIT_LEXPROPINFO, XTP_EDIT_LEXPROPINFO&>
89{
90public:
91 CXTPSyntaxEditLexPropInfoArray();
92
93 CXTPSyntaxEditLexPropInfoArray(const CXTPSyntaxEditLexPropInfoArray& rSrc);
94
95 const CXTPSyntaxEditLexPropInfoArray& operator=(const CXTPSyntaxEditLexPropInfoArray& rSrc);
96};
97
105struct _XTP_EXT_CLASS XTP_EDIT_LEXCLASSINFO
106{
107 XTP_EDIT_LEXCLASSINFO();
108
109 XTP_EDIT_LEXCLASSINFO(const XTP_EDIT_LEXCLASSINFO& rSrc);
110
111 const XTP_EDIT_LEXCLASSINFO& operator=(const XTP_EDIT_LEXCLASSINFO& rSrc);
112
113 CString csClassName;
114 CXTPSyntaxEditLexPropInfoArray arPropertyDesc;
116 int nStartLine;
117 int nEndLine;
118};
119
126class _XTP_EXT_CLASS CXTPSyntaxEditLexClassInfoArray
127 : public CArray<XTP_EDIT_LEXCLASSINFO, XTP_EDIT_LEXCLASSINFO&>
128{
129public:
130 CXTPSyntaxEditLexClassInfoArray();
131
132 CXTPSyntaxEditLexClassInfoArray(const CXTPSyntaxEditLexClassInfoArray& rSrc);
133
134 const CXTPSyntaxEditLexClassInfoArray& operator=(const CXTPSyntaxEditLexClassInfoArray& rSrc);
135
136 BOOL m_bModified;
137};
139} // namespace XTPSyntaxEditLexAnalyser
140
154class _XTP_EXT_CLASS CXTPSyntaxEditLexCfgFileReader
155{
156 friend class CXTPSingleton<CXTPSyntaxEditLexCfgFileReader>;
157
158public:
164 virtual ~CXTPSyntaxEditLexCfgFileReader();
165
177 void ReadSource(const CString& csFileName, BOOL bSaveInfo);
178
187 void ReadSource(UINT nResourceID);
188
199 void ReadStringSource(BOOL bSaveInfo, CString sPassedString, CString* pSyntaxScheme);
200
207 XTPSyntaxEditLexAnalyser::CXTPSyntaxEditLexClassInfoArray& GetLexClassInfoArray();
208
215 CMapStringToPtr& GetLexClassInfoMap()
216 {
217 return m_mapLexClassInfo;
218 }
219
227 void CleanInfoMap(CMapStringToPtr& mapInfo);
228
238 void CopyInfoMap(CMapStringToPtr& mapInfo);
239
248 BOOL WriteCfgFile(const CString& csFileName,
249 XTPSyntaxEditLexAnalyser::CXTPSyntaxEditLexClassInfoArray& arLexClassDesc);
250
258 BOOL WriteCfg2String(XTPSyntaxEditLexAnalyser::CXTPSyntaxEditLexClassInfoArray& arLexClassDesc);
259
269 CString StrToES(CString strSrc, BOOL bQuoted);
270
280 CString ESToStr(CString strSrc, BOOL bQuoted);
281
282private:
286 typedef CMap<void*, void*, bool, bool> CMapPtrToBool;
287# ifdef _DEBUG
291 void ProcessFileException(CFileException* pExc);
292# endif
296 int GetToken();
300 int GetLexToken();
304 int ProcessUnknowToken(TCHAR tchCurrSymbol);
305 int ProcessDelimToken(TCHAR tchCurrSymbol);
306 int ProcessNameToken(TCHAR tchCurrSymbol);
307 int ProcessValueToken(TCHAR tchCurrSymbol);
308 int ProcessQuotedToken(TCHAR tchCurrSymbol);
309 int ProcessCommentToken(TCHAR tchCurrSymbol);
310 int ProcessEOLToken(TCHAR tchCurrSymbol);
311 int ProcessControlToken(TCHAR tchCurrSymbol);
315 void ParseLexClass(XTPSyntaxEditLexAnalyser::XTP_EDIT_LEXCLASSINFO& infoClass);
319 XTPSyntaxEditLexAnalyser::XTP_EDIT_LEXCLASSINFO*
320 FindClassDesc(XTPSyntaxEditLexAnalyser::CXTPSyntaxEditLexClassInfoArray& arInfoClass,
321 const CString& csClassName);
325 XTPSyntaxEditLexAnalyser::XTP_EDIT_LEXPROPINFO* FindPropDesc(
326 XTPSyntaxEditLexAnalyser::XTP_EDIT_LEXCLASSINFO* pInfoClass,
327 XTPSyntaxEditLexAnalyser::XTP_EDIT_LEXPROPINFO* pInfoProp, CMapPtrToBool& mapUsed);
331 void ReadSource2(const CString& csFileName, CStringArray& arBuffer);
335 void WriteString(CFile& file, LPCTSTR pcszString);
339 void WriteStrings(CFile& file, CStringArray& arBuffer, int nFrom, int nTo);
343 void WriteProp(CFile& file, CString& csOffset,
344 const XTPSyntaxEditLexAnalyser::XTP_EDIT_LEXPROPINFO& newInfoProp);
345 void WriteProp(CFile& file, CString& csOffset,
346 const XTPSyntaxEditLexAnalyser::XTP_EDIT_LEXPROPINFO& oldInfoProp,
347 const XTPSyntaxEditLexAnalyser::XTP_EDIT_LEXPROPINFO& newInfoProp,
348 const CStringArray& arBuffer);
352 void Parse(XTPSyntaxEditLexAnalyser::CXTPSyntaxEditLexClassInfoArray& arLexClassDesc);
353
354 CString* p_sSyntaxScheme;
355 CString* p_sColorScheme;
356 void SetSyntaxAndColorScheme(CString* pSyntaxScheme, CString* pColorScheme)
357 {
358 p_sSyntaxScheme = pSyntaxScheme;
359 p_sColorScheme = pColorScheme;
360
361 m_csDataBuffer = *p_sSyntaxScheme;
362 }
363
364private:
365 int m_nCurrLine;
366 int m_nCurrLine_pos;
367 int m_nCurrPos;
368 int m_nEOFPos;
369 int m_nPrevPos;
370 int m_nTokenType;
371 BOOL m_bReadNames;
372 BOOL m_bES;
373 CString m_csDataBuffer;
374 CString m_strToken;
375 CMapStringToPtr m_mapLexClassInfo;
376 XTPSyntaxEditLexAnalyser::CXTPSyntaxEditLexClassInfoArray m_arLexClassInfo;
382 CXTPSyntaxEditLexCfgFileReader();
383 friend CXTPSyntaxEditLexCfgFileReader* AFX_CDECL XTPSyntaxEditLexConfig();
384};
385
392AFX_INLINE CXTPSyntaxEditLexCfgFileReader* AFX_CDECL XTPSyntaxEditLexConfig()
393{
394 return &CXTPSingleton<CXTPSyntaxEditLexCfgFileReader>::Instance();
395}
396
402class CXTPSyntaxEditConfigurationManager;
403
407class _XTP_EXT_CLASS CXTPSyntaxEditFileChangesMonitor
408{
409public:
414 CXTPSyntaxEditFileChangesMonitor();
415
421 virtual ~CXTPSyntaxEditFileChangesMonitor();
422
428 void SetDefaultFolder(const CString& strPath);
429
437 void SetConfigurationManager(CXTPSyntaxEditConfigurationManager* pConfigMgr);
438
453 BOOL AddMonitorFile(CString& strFilename, DWORD dwOwnerFlags);
454
459 void StartMonitoring();
460
465 void StopMonitoring();
466
472 void RefreshFiles();
473
474private:
479 void RemoveAll();
480
481private:
482 CString m_strPath;
483 CWinThread* m_pThread;
484 HANDLE m_evExitThread;
485 static UINT AFX_CDECL ThreadMonitorProc(LPVOID);
486 BOOL m_bES;
487
488 CXTPSyntaxEditConfigurationManager* m_pConfigMgr;
494 class _XTP_EXT_CLASS CFMFileInfo
495 {
496 public:
501 CFMFileInfo();
502
503 CString m_strFileName;
505 BY_HANDLE_FILE_INFORMATION m_sysFileInfo;
506 BOOL m_bExists;
507 DWORD m_dwOwnerFlags;
513 const CFMFileInfo& operator=(const CFMFileInfo& rSrc);
514 };
515
525 BOOL GetFileInfo(LPCTSTR pcszFilePath, BY_HANDLE_FILE_INFORMATION* pInfo);
526
527 CArray<CFMFileInfo, CFMFileInfo&> m_arFiles;
528};
529
530AFX_INLINE void CXTPSyntaxEditFileChangesMonitor::SetConfigurationManager(
531 CXTPSyntaxEditConfigurationManager* pConfigMgr)
532{
533 m_pConfigMgr = pConfigMgr;
534}
535
536# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
538#endif // !defined(__XTPSYNTAXEDITLEXCFGFILEREADER_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPSyntaxEditLexConfig
AFX_INLINE CXTPSyntaxEditLexCfgFileReader *AFX_CDECL XTPSyntaxEditLexConfig()
Gets the CXTPSyntaxEditLexCfgFileReader global object.
Definition XTPSyntaxEditLexCfgFileReader.h:392
CXTPSingleton
Implements Singleton design pattern.
Definition XTPSingleton.h:215
CXTPSingleton::Instance
static T &AFX_CDECL Instance()
Obtains encapsulated singleton instance reference.
Definition XTPSingleton.h:224
CXTPSyntaxEditConfigurationManager
This class manages all configuration parameters of the control.
Definition XTPSyntaxEditLexColorFileReader.h:601
CXTPSyntaxEditFileChangesMonitor
this class monitors files changes
Definition XTPSyntaxEditLexCfgFileReader.h:408
CXTPSyntaxEditFileChangesMonitor::SetDefaultFolder
void SetDefaultFolder(const CString &strPath)
Sets the default monitoring folder.
CXTPSyntaxEditFileChangesMonitor::CXTPSyntaxEditFileChangesMonitor
CXTPSyntaxEditFileChangesMonitor()
Default object constructor.
CXTPSyntaxEditFileChangesMonitor::RefreshFiles
void RefreshFiles()
Refreshes the contents of the folder, update file's status and re-reads changed configuration files.
CXTPSyntaxEditFileChangesMonitor::StopMonitoring
void StopMonitoring()
Stops the thread which is monitoring folder changes.
CXTPSyntaxEditFileChangesMonitor::StartMonitoring
void StartMonitoring()
Starts the thread which will be monitoring folder changes.
CXTPSyntaxEditFileChangesMonitor::~CXTPSyntaxEditFileChangesMonitor
virtual ~CXTPSyntaxEditFileChangesMonitor()
Destroys a CXTPSyntaxEditFileChangesMonitor() object, handles cleanup and de-allocation.
CXTPSyntaxEditFileChangesMonitor::SetConfigurationManager
void SetConfigurationManager(CXTPSyntaxEditConfigurationManager *pConfigMgr)
Sets the associated configuration manager.
Definition XTPSyntaxEditLexCfgFileReader.h:530
CXTPSyntaxEditFileChangesMonitor::AddMonitorFile
BOOL AddMonitorFile(CString &strFilename, DWORD dwOwnerFlags)
Adds a file to be monitored.


Toolkit Pro: XTPChartBorder.h Source File

  • Source
  • Chart
  • Appearance
XTPChartBorder.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTBORDER_H__)
24# define __XTPCHARTBORDER_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartColor;
34class CXTPChartDeviceCommand;
35class CXTPPropExchange;
36
41class _XTP_EXT_CLASS CXTPChartBorder : public CXTPChartElement
42{
43public:
50 CXTPChartBorder(CXTPChartElement* pOwner);
51
56 virtual ~CXTPChartBorder();
57
58public:
65 BOOL IsVisible() const;
66
67 void SetVisible(BOOL bVisible);
68
75 CXTPChartColor GetColor() const;
76 void SetColor(const CXTPChartColor& clr);
77
84 int GetThickness() const;
85
92 void SetThickness(int Thickness);
93
94public:
107 virtual CXTPChartDeviceCommand* CreateDeviceCommand(const CXTPChartRectF& rcBounds,
108 const CXTPChartColor& color);
109
122 virtual CXTPChartDeviceCommand* CreateInnerBorderDeviceCommand(const CXTPChartRectF& rcBounds,
123 const CXTPChartColor& color);
124
136 void DoPropExchange(CXTPPropExchange* pPX);
137
138protected:
139# ifdef _XTP_ACTIVEX
140public:
142 DECLARE_DISPATCH_MAP()
143 DECLARE_INTERFACE_MAP()
144 DECLARE_OLETYPELIB_EX(CXTPChartBorder);
145 void OleSetColor(OLE_COLOR clr);
146 OLE_COLOR OleGetColor();
148# endif
149
150protected:
151 CXTPChartColor m_clrColor;
152 int m_nThickness;
153 BOOL m_bVisible;
154};
155
156AFX_INLINE BOOL CXTPChartBorder::IsVisible() const
157{
158 return m_bVisible;
159}
160AFX_INLINE void CXTPChartBorder::SetVisible(BOOL bVisible)
161{
162 m_bVisible = bVisible;
163 OnChartChanged();
164}
165AFX_INLINE CXTPChartColor CXTPChartBorder::GetColor() const
166{
167 return m_clrColor;
168}
169AFX_INLINE void CXTPChartBorder::SetColor(const CXTPChartColor& clr)
170{
171 m_clrColor = clr;
172 OnChartChanged();
173}
174AFX_INLINE int CXTPChartBorder::GetThickness() const
175{
176 return m_nThickness;
177}
178AFX_INLINE void CXTPChartBorder::SetThickness(int nThickness)
179{
180 m_nThickness = nThickness;
181 OnChartChanged();
182}
184# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
185#endif //#if !defined(__XTPCHARTBORDER_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartBorder
This class abstracts the border of a chart, it is a kind of chart element.
Definition XTPChartBorder.h:42
CXTPChartBorder::DoPropExchange
void DoPropExchange(CXTPPropExchange *pPX)
Call this member function to store/Load the properties of chart boundary object using the specified d...
CXTPChartBorder::SetThickness
void SetThickness(int Thickness)
Call this function to set the thickness of the chart border.
Definition XTPChartBorder.h:178
CXTPChartBorder::CXTPChartBorder
CXTPChartBorder(CXTPChartElement *pOwner)
Constructs a CXTPChartBorder object.
CXTPChartBorder::m_clrColor
CXTPChartColor m_clrColor
The boundary color.
Definition XTPChartBorder.h:151
CXTPChartBorder::GetColor
CXTPChartColor GetColor() const
This function returns the color of the border.
Definition XTPChartBorder.h:165
CXTPChartBorder::~CXTPChartBorder
virtual ~CXTPChartBorder()
Destroys a CXTPChartBorder object, handles cleanup.
CXTPChartBorder::m_nThickness
int m_nThickness
The thickness of the boundary.
Definition XTPChartBorder.h:152
CXTPChartBorder::IsVisible
BOOL IsVisible() const
Call this function to check whether the chart border is visible or not.
Definition XTPChartBorder.h:156
CXTPChartBorder::GetThickness
int GetThickness() const
Call this function to get the thickness of the chart border.
Definition XTPChartBorder.h:174
CXTPChartBorder::CreateDeviceCommand
virtual CXTPChartDeviceCommand * CreateDeviceCommand(const CXTPChartRectF &rcBounds, const CXTPChartColor &color)
This function creates a CXTPChartDeviceCommand object, this object represents the rendering of the bo...
CXTPChartBorder::m_bVisible
BOOL m_bVisible
TRUE if the boundary is visible, FALSE if invisible.
Definition XTPChartBorder.h:153
CXTPChartBorder::CreateInnerBorderDeviceCommand
virtual CXTPChartDeviceCommand * CreateInnerBorderDeviceCommand(const CXTPChartRectF &rcBounds, const CXTPChartColor &color)
This function creates a CXTPChartDeviceCommand object, this object represents the rendering of the bo...
CXTPChartColor
This class abstracts a color entity.
Definition XTPChartTypes.h:51
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPChartElement
This class abstracts a chart element, this class acts as a base class for all chart elements.
Definition XTPChartElement.h:131
CXTPChartElement::OnChartChanged
virtual void OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic propertie...
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72
CXTPRectT< float >


Toolkit Pro: Member List

CXTPFlowGraphNode Member List

This is the complete list of members for CXTPFlowGraphNode, including all inherited members.

AddNamedConnectionPoints(LPCTSTR szName, XTPFlowGraphConnectionPointType type=xtpFlowGraphPointNone, LPCTSTR szCaption=NULL) | CXTPFlowGraphNode | virtual
CalcMinSize() | CXTPFlowGraphNode | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPFlowGraphElement() | CXTPFlowGraphElement |
CXTPFlowGraphNode() | CXTPFlowGraphNode |
DoCommonPropExchange(CXTPPropExchange *pPX) | CXTPFlowGraphNode |
DoPropExchange(CXTPPropExchange *pPX) | CXTPFlowGraphNode | virtual
Draw(CXTPFlowGraphDrawContext *pDC) | CXTPFlowGraphNode | virtual
DrawConnectionPoints(CXTPFlowGraphDrawContext *pDC) | CXTPFlowGraphNode | virtual
DrawSelectionRect(CXTPFlowGraphDrawContext *pDC) | CXTPFlowGraphNode | virtual
DrawWindowContent(CXTPFlowGraphDrawContext *pDC) | CXTPFlowGraphNode | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCaption() const | CXTPFlowGraphNode | virtual
GetCaptionRect() const | CXTPFlowGraphNode |
GetCaptionTextBlock() const | CXTPFlowGraphNode |
GetColor() const | CXTPFlowGraphNode |
GetConnectionPoints() const | CXTPFlowGraphNode |
GetControl() const | CXTPFlowGraphNode | virtual
GetGroup() const | CXTPFlowGraphNode |
GetID() const | CXTPFlowGraphNode |
GetImage() const | CXTPFlowGraphNode |
GetImageIndex() const | CXTPFlowGraphNode |
GetLocation() const | CXTPFlowGraphNode |
GetMarkupTableRowIndex(CXTPFlowGraphConnectionPoint *pPoint, CXTPMarkupUIElementCollection *pChildren) | CXTPFlowGraphNode |
GetMarkupVisualElementRect(const CXTPMarkupVisual *pElementVisual) const | CXTPFlowGraphNode |
GetMinSize() const | CXTPFlowGraphNode |
GetPage() const | CXTPFlowGraphNode | virtual
GetScreenRect(BOOL bIncludeConnectionPointsEllipses=TRUE) const | CXTPFlowGraphNode |
GetSelectionRect() const | CXTPFlowGraphNode |
GetSize() const | CXTPFlowGraphNode |
GetStyle() const | CXTPFlowGraphNode |
GetTableRowCaptionRect(CXTPFlowGraphConnectionPoint *pPoint) const | CXTPFlowGraphNode |
GetTableRowTextBlock(const CString &strConnectionPointName) const | CXTPFlowGraphNode |
GetTag() const | CXTPFlowGraphNode |
GetTooltip() const | CXTPFlowGraphNode |
GetUserSize() const | CXTPFlowGraphNode |
GetWindowHandle() const | CXTPFlowGraphNode |
GetWindowSize() const | CXTPFlowGraphNode |
HitTestConnectionPoint(CPoint point) | CXTPFlowGraphNode | virtual
IsCustomMarkup() const | CXTPFlowGraphNode | inlinevirtual
IsLocked() const | CXTPFlowGraphNode |
IsResizable() const | CXTPFlowGraphNode |
IsSelected() const | CXTPFlowGraphElement |
IsVisible() const | CXTPFlowGraphNode |
m_bAlpha | CXTPFlowGraphNode | protected
m_bDirty | CXTPFlowGraphElement |
m_bLocked | CXTPFlowGraphNode | protected
m_bSelected | CXTPFlowGraphElement | protected
m_bVisible | CXTPFlowGraphNode | protected
m_clrNode | CXTPFlowGraphNode | protected
m_dwTag | CXTPFlowGraphNode | protected
m_hWnd | CXTPFlowGraphNode | protected
m_nGroupId | CXTPFlowGraphNode | protected
m_nId | CXTPFlowGraphNode | protected
m_nImageIndex | CXTPFlowGraphNode | protected
m_nStyle | CXTPFlowGraphNode | protected
m_pConnectionPoints | CXTPFlowGraphNode | protected
m_pGroup | CXTPFlowGraphNode | protected
m_pMarkup | CXTPFlowGraphNode | protected
m_pNextVisibleNode | CXTPFlowGraphNode | protected
m_pOriginalWindowProc | CXTPFlowGraphNode | protected
m_pPage | CXTPFlowGraphNode | protected
m_ptLocation | CXTPFlowGraphNode | protected
m_strCaption | CXTPFlowGraphNode | protected
m_strTooltip | CXTPFlowGraphNode | protected
m_szActualSize | CXTPFlowGraphNode | protected
m_szUserMinSize | CXTPFlowGraphNode | protected
m_szUserSize | CXTPFlowGraphNode | protected
m_szWindow | CXTPFlowGraphNode | protected
m_WindowToNodeHash | CXTPFlowGraphNode | protectedstatic
OnGraphChanged() | CXTPFlowGraphElement |
OnRemoved() | CXTPFlowGraphNode | protectedvirtual
RecalLayout() | CXTPFlowGraphNode | virtual
Remove() | CXTPFlowGraphNode |
RemoveMarkupTableRow(CXTPFlowGraphConnectionPoint *pPoint) | CXTPFlowGraphNode |
Select(BOOL bSelect=TRUE) | CXTPFlowGraphNode | virtual
SetCaption(LPCTSTR lpszCaption) | CXTPFlowGraphNode | virtual
SetColor(COLORREF clr, BYTE bAlpha=255) | CXTPFlowGraphNode | virtual
SetDefaultMarkup() | CXTPFlowGraphNode | virtual
SetID(int nId) | CXTPFlowGraphNode |
SetImageIndex(int nImageIndex) | CXTPFlowGraphNode |
SetLocation(CPoint ptLocation) | CXTPFlowGraphNode |
SetLocked(BOOL bLocked=TRUE) | CXTPFlowGraphNode |
SetMarkupText(LPCTSTR szMarkupText) | CXTPFlowGraphNode |
SetMinSize(CSize sz) | CXTPFlowGraphNode |
SetSize(CSize sz) | CXTPFlowGraphNode | virtual
SetSizeCore(CSize sz) | CXTPFlowGraphNode |
SetStyle(int nStyle) | CXTPFlowGraphNode |
SetTag(DWORD_PTR dwTag) | CXTPFlowGraphNode |
SetTooltip(LPCTSTR lpszTooltip) | CXTPFlowGraphNode |
SetVisible(BOOL bVisible=TRUE) | CXTPFlowGraphNode |
SetWindowHandle(HWND hWnd) | CXTPFlowGraphNode | virtual
SetWindowSize(CSize sz) | CXTPFlowGraphNode | virtual
UpdateCaptionColor() | CXTPFlowGraphNode | virtual
UpdateColorRecursive(CXTPMarkupObject *pRootElement, COLORREF clrColor) | CXTPFlowGraphNode | virtual
UpdateConnectionPoints(CXTPMarkupObject *pRootElement) | CXTPFlowGraphNode | virtual
UpdateMarkupCaption() | CXTPFlowGraphNode | virtual
UpdateMarkupFont() | CXTPFlowGraphNode | virtual
UpdateMarkupImage() | CXTPFlowGraphNode | virtual
UpdateMarkupPointCaption(CXTPFlowGraphConnectionPoint *pPoint) | CXTPFlowGraphNode |
UpdateMarkupPointColor(CXTPFlowGraphConnectionPoint *pPoint) | CXTPFlowGraphNode | virtual
UpdateMarkupPointImage(CXTPFlowGraphConnectionPoint *pPoint) | CXTPFlowGraphNode |
UpdateMarkupPointName(CXTPFlowGraphConnectionPoint *pPoint) | CXTPFlowGraphNode |
UpdateWindowPosition() | CXTPFlowGraphNode | virtual
~CXTPFlowGraphElement() | CXTPFlowGraphElement | virtual
~CXTPFlowGraphNode() | CXTPFlowGraphNode | virtual


Toolkit Pro: Member List

CXTPSyntaxEditTipWnd Member List

This is the complete list of members for CXTPSyntaxEditTipWnd, including all inherited members.

CalcItemRect(int iItem, CRect &rItem) | CXTPSyntaxEditTipWnd | protectedvirtual
Create(CListBox *pListBox) | CXTPSyntaxEditTipWnd | virtual
CXTPSyntaxEditTipWnd() | CXTPSyntaxEditTipWnd |
DrawTip(CDC *pDC, CRect rClient) | CXTPSyntaxEditTipWnd | protectedvirtual
GetBackColor() const | CXTPSyntaxEditTipWnd | virtual
GetTextColor() const | CXTPSyntaxEditTipWnd | virtual
HideTip() | CXTPSyntaxEditTipWnd | virtual
IsOwnerDrawn() | CXTPSyntaxEditTipWnd | virtual
m_iIndex | CXTPSyntaxEditTipWnd | protected
m_pListBox | CXTPSyntaxEditTipWnd | protected
m_ptCursor | CXTPSyntaxEditTipWnd | protected
m_rWindow | CXTPSyntaxEditTipWnd | protected
OwnerDrawTip(CDC *pDC, CRect rClient) | CXTPSyntaxEditTipWnd | protectedvirtual
RegisterWindowClass(HINSTANCE hInstance=NULL) | CXTPSyntaxEditTipWnd | protectedvirtual
ShowTip(int iIndex) | CXTPSyntaxEditTipWnd | virtual
~CXTPSyntaxEditTipWnd() | CXTPSyntaxEditTipWnd | virtual


Toolkit Pro: XTPCalendarNotifications.h Source File

  • Source
  • Calendar
XTPCalendarNotifications.h
Go to the documentation of this file.
1
22#if !defined(_XTPCALENDARNOTIFICATIONS_H__)
23# define _XTPCALENDARNOTIFICATIONS_H__
24
25# if _MSC_VER > 1000
26# pragma once
27# endif // _MSC_VER > 1000
28
29# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
30
31class CXTPCalendarViewEvents;
32class CXTPCalendarDayViewGroup;
33typedef DWORD XTP_NOTIFY_CODE;
34
35//## *** CXTPCalendarData notification IDs ***
36
43static const XTP_NOTIFY_CODE XTP_NC_CALENDAREVENTWASADDED = (WM_XTP_CALENDAR_BASE + 1);
44
51static const XTP_NOTIFY_CODE XTP_NC_CALENDAREVENTWASDELETED = (WM_XTP_CALENDAR_BASE + 2);
52
59static const XTP_NOTIFY_CODE XTP_NC_CALENDAREVENTWASCHANGED = (WM_XTP_CALENDAR_BASE + 3);
60
61//
62// ***
63// These handlers are remain for compatibility with previous versions.
64// In new versions XTP_NC_CALENDAREVENTWASxxx should be used instead.
65// Pattern can be retrieved from lParam = CXTPCalendarEvent*
66// ***
67//
74static const XTP_NOTIFY_CODE XTP_NC_CALENDARPATTERNWASADDED = (WM_XTP_CALENDAR_BASE + 4);
75
82static const XTP_NOTIFY_CODE XTP_NC_CALENDARPATTERNWASDELETED = (WM_XTP_CALENDAR_BASE + 5);
83
90static const XTP_NOTIFY_CODE XTP_NC_CALENDARPATTERNWASCHANGED = (WM_XTP_CALENDAR_BASE + 6);
91
99static const XTP_NOTIFY_CODE XTP_NC_CALENDARVIEWWASCHANGED = (WM_XTP_CALENDAR_BASE + 7);
100
107static const XTP_NOTIFY_CODE XTP_NC_CALENDARCONTEXTMENU = (WM_XTP_CALENDAR_BASE + 8);
108
115static const XTP_NOTIFY_CODE XTP_NC_CALENDARLBUTTONDOWN = (WM_XTP_CALENDAR_BASE + 9);
116
123static const XTP_NOTIFY_CODE XTP_NC_CALENDARLBUTTONDBLCLICK = (WM_XTP_CALENDAR_BASE + 10);
124
131static const XTP_NOTIFY_CODE XTP_NC_CALENDARLBUTTONUP = (WM_XTP_CALENDAR_BASE + 11);
132
139static const XTP_NOTIFY_CODE XTP_NC_CALENDARMOUSEMOVE = (WM_XTP_CALENDAR_BASE + 12);
140
147static const XTP_NOTIFY_CODE XTP_NC_CALENDARKEYDOWN = (WM_XTP_CALENDAR_BASE + 13);
148
155static const XTP_NOTIFY_CODE XTP_NC_CALENDARRBUTTONDOWN = (WM_XTP_CALENDAR_BASE + 14);
156
163static const XTP_NOTIFY_CODE XTP_NC_CALENDARVIEWTIMESCALEWASCHANGED = (WM_XTP_CALENDAR_BASE + 15);
164
175static const XTP_NOTIFY_CODE XTP_NC_CALENDAROPTIONSWASCHANGED = (WM_XTP_CALENDAR_BASE + 16);
176
189static const XTP_NOTIFY_CODE XTP_NC_CALENDARDATAPROVIDERWASCHANGED = (WM_XTP_CALENDAR_BASE + 17);
190
194static const XTP_NOTIFY_CODE XTP_NC_CALENDAR_RESOURCES_WHERE_CHANGED =
195 XTP_NC_CALENDARDATAPROVIDERWASCHANGED;
196
223static const XTP_NOTIFY_CODE XTP_NC_CALENDAR_IS_EVENT_EDIT_OPERATION_DISABLED =
224 (WM_XTP_CALENDAR_BASE + 18);
225
250static const XTP_NOTIFY_CODE XTP_NC_CALENDAR_BEFORE_EVENT_EDIT_OPERATION = (WM_XTP_CALENDAR_BASE
251 + 19);
252
263struct XTP_EVENT_EDIT_OPERATION_PARAMS
264{
265 XTPCalendarEditOperation eOperation;
266 CXTPCalendarViewEvents* pEventViews;
268 int nRefCounter;
269};
270
280struct XTP_EVENT_PASTE_OPERATION_PARAMS : public XTP_EVENT_EDIT_OPERATION_PARAMS
281{
282 CXTPCalendarEvent* pEvent;
283 BOOL bPasteWillChangeExistingEvent;
286};
287
297struct XTP_EVENT_IN_PLACE_CREATE_EVENT_OPERATION_PARAMS : public XTP_EVENT_EDIT_OPERATION_PARAMS
298{
299 LPCTSTR pcszInitialSubject;
301};
302
315struct XTP_EVENT_DRAG_OPERATION_PARAMS : public XTP_EVENT_EDIT_OPERATION_PARAMS
316{
317 CXTPCalendarEvent* pDraggingEventOriginal;
318 CXTPCalendarEvent* pDraggingEvent;
319 CXTPCalendarEvent* pDraggingEventNew;
320};
321
334static const XTP_NOTIFY_CODE XTP_NC_CALENDAR_SELECTION_CHANGED = (WM_XTP_CALENDAR_BASE + 20);
335
342static const XTP_NOTIFY_CODE XTP_NC_CALENDARRBUTTONUP = (WM_XTP_CALENDAR_BASE + 21);
343
352enum XTPCalendarRemindersAction
353{
354 xtpCalendarRemindersMonitoringStarted = 1,
357 xtpCalendarRemindersMonitoringStopped = 2,
359 xtpCalendarRemindersFire = 3,
361 xtpCalendarReminderSnoozed = 4,
363 xtpCalendarReminderDismissed = 5,
365 xtpCalendarReminderDismissedAll = 6
366};
367
375static const XTP_NOTIFY_CODE XTP_NC_CALENDAR_ON_REMINDERS = (WM_XTP_CALENDAR_BASE + 22);
376
381struct XTP_CALENDAR_WPARAM2
382{
383 WPARAM wParam1;
384 WPARAM wParam2;
385};
386
403static const XTP_NOTIFY_CODE XTP_NC_CALENDAR_DoRetrieveDayEvents = (WM_XTP_CALENDAR_BASE + 23);
404
416static const XTP_NOTIFY_CODE XTP_NC_CALENDAR_DoRemoveAllEvents = (WM_XTP_CALENDAR_BASE + 24);
417
433static const XTP_NOTIFY_CODE XTP_NC_CALENDAR_DoRead_Event = (WM_XTP_CALENDAR_BASE + 25);
434
450static const XTP_NOTIFY_CODE XTP_NC_CALENDAR_DoRead_RPattern = (WM_XTP_CALENDAR_BASE + 26);
451
469static const XTP_NOTIFY_CODE XTP_NC_CALENDAR_DoCreate_Event = (WM_XTP_CALENDAR_BASE + 27);
470
485static const XTP_NOTIFY_CODE XTP_NC_CALENDAR_DoUpdate_Event = (WM_XTP_CALENDAR_BASE + 28);
486
501static const XTP_NOTIFY_CODE XTP_NC_CALENDAR_DoDelete_Event = (WM_XTP_CALENDAR_BASE + 29);
502
521static const XTP_NOTIFY_CODE XTP_NC_CALENDAR_DoCreate_RPattern = (WM_XTP_CALENDAR_BASE + 30);
522
538static const XTP_NOTIFY_CODE XTP_NC_CALENDAR_DoUpdate_RPattern = (WM_XTP_CALENDAR_BASE + 31);
539
555static const XTP_NOTIFY_CODE XTP_NC_CALENDAR_DoDelete_RPattern = (WM_XTP_CALENDAR_BASE + 32);
556
572static const XTP_NOTIFY_CODE XTP_NC_CALENDAR_DoGetAllEvents_raw = (WM_XTP_CALENDAR_BASE + 33);
573
593static const XTP_NOTIFY_CODE XTP_NC_CALENDAR_DoGetUpcomingEvents = (WM_XTP_CALENDAR_BASE + 34);
594
606static const XTP_NOTIFY_CODE XTP_NC_CALENDAR_GETGROPVIEWCAPTION = (WM_XTP_CALENDAR_BASE + 35);
607
624static const XTP_NOTIFY_CODE XTP_NC_CALENDAR_PREPOPULATE = (WM_XTP_CALENDAR_BASE + 36);
625
637struct XTP_CALENDAR_DAYVIEWCELL_PARAMS
638{
639 int nIndex;
640 DATE dtBeginTime;
641 BOOL bSelected;
643 COLORREF clrBackgroundColor;
644};
645
658static const XTP_NOTIFY_CODE XTP_NC_CALENDAR_BEFORE_DRAW_DAYVIEWCELL = (WM_XTP_CALENDAR_BASE + 37);
659
671struct XTP_CALENDAR_THEME_DAYVIEWCELL_PARAMS
672{
673 int nIndex;
674 DATE dtBeginTime;
675 BOOL bSelected;
676 BOOL bWorkCell;
678 CXTPCalendarDayViewGroup* pViewGroup;
679};
680
692struct XTP_CALENDAR_THEME_DAYVIEWTIMESCALECELL_PARAMS
693{
694 int nTimeScale;
696 int nIndex;
697 DATE dtBeginTime;
699 int nMinutes;
700};
701
709enum XTPCalendarBeforeDrawThemeObject
710{
711 xtpCalendarBeforeDraw_DayViewTimeScale = 0x00000001,
713 xtpCalendarBeforeDraw_DayViewTimeScaleCaption = 0x00000002,
715 xtpCalendarBeforeDraw_DayViewTimeScaleCell =
716 0x00000004,
717 xtpCalendarBeforeDraw_DayViewDay = 0x00000010,
718 xtpCalendarBeforeDraw_DayViewDayGroup = 0x00000020,
720 xtpCalendarBeforeDraw_DayViewCell = 0x00000040,
722 xtpCalendarBeforeDraw_DayViewEvent = 0x00000080,
723 xtpCalendarBeforeDraw_AllDayViewEvent = 0x00000100,
725 xtpCalendarBeforeDraw_MonthViewDay = 0x00001000,
726 xtpCalendarBeforeDraw_MonthViewEvent = 0x00002000,
728 xtpCalendarBeforeDraw_MonthViewWeekDayHeader =
729 0x00004000,
730 xtpCalendarBeforeDraw_MonthViewWeekHeader = 0x00008000,
732 xtpCalendarBeforeDraw_WeekViewDay = 0x00100000,
733 xtpCalendarBeforeDraw_WeekViewEvent = 0x00200000
735};
736
755static const XTP_NOTIFY_CODE XTP_NC_CALENDAR_BEFORE_DRAW_THEMEOBJECT = (WM_XTP_CALENDAR_BASE + 38);
756
770struct XTP_CALENDAR_GETITEMTEXT_PARAMS
771{
772 int nItem;
774 CString* pstrText;
776 CXTPCalendarViewEvent* pViewEvent;
777 CXTPCalendarViewDay* pViewDay;
779 int nWeekDay;
780 int nWeekNum;
781};
782
801static const XTP_NOTIFY_CODE XTP_NC_CALENDAR_GETITEMTEXT = (WM_XTP_CALENDAR_BASE + 39);
802
810enum XTPCalendarUserAction
811{
812 xtpCalendarUserAction_OnExpandDay = 0x80000000,
814 xtpCalendarUserAction_OnScrollDay = 0x40000000,
816 xtpCalendarUserAction_OnScrollAllDayEvensUp = 0x30000000,
818 xtpCalendarUserAction_OnScrollAllDayEvensDown = 0x20000000
820};
821
829struct XTP_CALENDAR_USERACTION_PARAMS
830{
835 struct EXPANDDAYBUTTONACTION_PARAMS
836 {
837 XTPCalendarExpandDayButton nButton;
839 CXTPCalendarViewDay* pViewDay;
840 };
841
846 struct SCROLLDAYBUTTONACTION_PARAMS
847 {
848 XTPCalendarScrollDayButton nButton;
849 CXTPCalendarDayViewGroup* pViewGroup;
851 };
852
853 XTPCalendarUserAction m_eAction;
855 // reserved for other actions in the feature
856 union {
857 EXPANDDAYBUTTONACTION_PARAMS m_ExpandDayButton;
860 SCROLLDAYBUTTONACTION_PARAMS m_ScrollDayButton;
863 };
864};
865
879static const XTP_NOTIFY_CODE XTP_NC_CALENDAR_USERACTION = (WM_XTP_CALENDAR_BASE + 40);
880
898static const XTP_NOTIFY_CODE XTP_NC_CALENDAR_PREPOPULATE_DAY = (WM_XTP_CALENDAR_BASE + 41);
899
911static const XTP_NOTIFY_CODE XTP_NC_CALENDAR_THEME_CHANGED = (WM_XTP_CALENDAR_BASE + 42);
912
916static const XTP_NOTIFY_CODE XTP_NC_CALENDAR_CAPTIONBARPART_CLICK = (WM_XTP_CALENDAR_BASE + 43);
917
921static const XTP_NOTIFY_CODE XTP_NC_CALENDAR_CAPTIONBARPART_BEFORE_CLICK = (WM_XTP_CALENDAR_BASE
922 + 44);
923
924// Next Free ID: (WM_XTP_CALENDAR_BASE + 45)
926
927# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
928#endif // !defined(_XTPCALENDARNOTIFICATIONS_H__)
XTPCalendarExpandDayButton
XTPCalendarExpandDayButton
This enum defines parameters for xtpCalendarUserAction_OnExpandDay user action.
Definition XTPCalendarDefines.h:1315
XTPCalendarEditOperation
XTPCalendarEditOperation
Enumerates customizable event edit operations.
Definition XTPCalendarDefines.h:1264
XTPCalendarScrollDayButton
XTPCalendarScrollDayButton
This enum defines parameters for xtpCalendarUserAction_OnScrollDay user action.
Definition XTPCalendarDefines.h:1329
WM_XTP_CALENDAR_BASE
const UINT WM_XTP_CALENDAR_BASE
The WM_XTP_CALENDAR_BASE constant is used by Calendar Control to help define private messages for use...
Definition XTPCalendarDefines.h:1069
XTPCalendarUserAction
XTPCalendarUserAction
This enum defines a set of user actions which can be customized.
Definition XTPCalendarNotifications.h:811
xtpCalendarUserAction_OnScrollAllDayEvensUp
@ xtpCalendarUserAction_OnScrollAllDayEvensUp
Scroll All Day button up action.
Definition XTPCalendarNotifications.h:816
xtpCalendarUserAction_OnScrollAllDayEvensDown
@ xtpCalendarUserAction_OnScrollAllDayEvensDown
Scroll All Day button down action.
Definition XTPCalendarNotifications.h:818
xtpCalendarUserAction_OnExpandDay
@ xtpCalendarUserAction_OnExpandDay
Expand Day button was clicked for month or week view.
Definition XTPCalendarNotifications.h:812
xtpCalendarUserAction_OnScrollDay
@ xtpCalendarUserAction_OnScrollDay
Scroll Day button was clicked for day view.
Definition XTPCalendarNotifications.h:814
XTP_NC_CALENDAR_RESOURCES_WHERE_CHANGED
static const XTP_NOTIFY_CODE XTP_NC_CALENDAR_RESOURCES_WHERE_CHANGED
alias of XTP_NC_CALENDARDATAPROVIDERWASCHANGED notification code
Definition XTPCalendarNotifications.h:194
XTP_NC_CALENDAR_IS_EVENT_EDIT_OPERATION_DISABLED
static const XTP_NOTIFY_CODE XTP_NC_CALENDAR_IS_EVENT_EDIT_OPERATION_DISABLED
This notification is sent to determine if the specified editing operation is disabled.
Definition XTPCalendarNotifications.h:223
XTP_NC_CALENDARLBUTTONUP
static const XTP_NOTIFY_CODE XTP_NC_CALENDARLBUTTONUP
On LButtonUp event.
Definition XTPCalendarNotifications.h:131
XTP_NC_CALENDARLBUTTONDOWN
static const XTP_NOTIFY_CODE XTP_NC_CALENDARLBUTTONDOWN
On LButtonDown event.
Definition XTPCalendarNotifications.h:115
XTP_NC_CALENDAR_DoRead_RPattern
static const XTP_NOTIFY_CODE XTP_NC_CALENDAR_DoRead_RPattern
This notification is used as an analog of the overridable method CXTPCalendarData::DoRead_RPattern.
Definition XTPCalendarNotifications.h:450
XTP_NC_CALENDAR_PREPOPULATE_DAY
static const XTP_NOTIFY_CODE XTP_NC_CALENDAR_PREPOPULATE_DAY
This notification is sent when the calendar is populating.
Definition XTPCalendarNotifications.h:898
XTP_NC_CALENDAR_DoRead_Event
static const XTP_NOTIFY_CODE XTP_NC_CALENDAR_DoRead_Event
This notification is used as an analog of the overridable method CXTPCalendarData::DoRead_Event.
Definition XTPCalendarNotifications.h:433
XTP_NC_CALENDARRBUTTONDOWN
static const XTP_NOTIFY_CODE XTP_NC_CALENDARRBUTTONDOWN
On RButtonDown event.
Definition XTPCalendarNotifications.h:155
XTPCalendarBeforeDrawThemeObject
XTPCalendarBeforeDrawThemeObject
This enum defines a set of calendar theme items for which a XTP_NC_CALENDAR_BEFORE_DRAW_THEMEOBJECT n...
Definition XTPCalendarNotifications.h:710
xtpCalendarBeforeDraw_DayViewEvent
@ xtpCalendarBeforeDraw_DayViewEvent
dwParam2 - [in] CXTPCalendarDayViewEvent
Definition XTPCalendarNotifications.h:722
xtpCalendarBeforeDraw_DayViewTimeScale
@ xtpCalendarBeforeDraw_DayViewTimeScale
dwParam2 - [in] nTimeScale = {1 - main, 2 - additional}
Definition XTPCalendarNotifications.h:711
xtpCalendarBeforeDraw_WeekViewDay
@ xtpCalendarBeforeDraw_WeekViewDay
dwParam2 - [in] CXTPCalendarWeekViewDay
Definition XTPCalendarNotifications.h:732
xtpCalendarBeforeDraw_WeekViewEvent
@ xtpCalendarBeforeDraw_WeekViewEvent
dwParam2 - [in] CXTPCalendarWeekViewEvent
Definition XTPCalendarNotifications.h:733
xtpCalendarBeforeDraw_DayViewCell
@ xtpCalendarBeforeDraw_DayViewCell
dwParam2 - [in] XTP_CALENDAR_THEME_DAYVIEWCELL_PARAMS
Definition XTPCalendarNotifications.h:720
xtpCalendarBeforeDraw_DayViewTimeScaleCaption
@ xtpCalendarBeforeDraw_DayViewTimeScaleCaption
dwParam2 - [in] nTimeScale = {1
Definition XTPCalendarNotifications.h:713
xtpCalendarBeforeDraw_MonthViewWeekHeader
@ xtpCalendarBeforeDraw_MonthViewWeekHeader
dwParam2 - [in] WeekIndex={0...N}, -1 for common part;
Definition XTPCalendarNotifications.h:730
xtpCalendarBeforeDraw_DayViewTimeScaleCell
@ xtpCalendarBeforeDraw_DayViewTimeScaleCell
dwParam2 - [in] XTP_CALENDAR_THEME_DAYVIEWTIMESCALECELL_PARAMS
Definition XTPCalendarNotifications.h:715
xtpCalendarBeforeDraw_MonthViewDay
@ xtpCalendarBeforeDraw_MonthViewDay
dwParam2 - [in] CXTPCalendarMonthViewDay
Definition XTPCalendarNotifications.h:725
xtpCalendarBeforeDraw_DayViewDay
@ xtpCalendarBeforeDraw_DayViewDay
dwParam2 - [in] CXTPCalendarDayViewDay
Definition XTPCalendarNotifications.h:717
xtpCalendarBeforeDraw_AllDayViewEvent
@ xtpCalendarBeforeDraw_AllDayViewEvent
dwParam2 - [in] CXTPCalendarDayViewEvent
Definition XTPCalendarNotifications.h:723
xtpCalendarBeforeDraw_DayViewDayGroup
@ xtpCalendarBeforeDraw_DayViewDayGroup
dwParam2 - [in] CXTPCalendarDayViewGroup
Definition XTPCalendarNotifications.h:718
xtpCalendarBeforeDraw_MonthViewWeekDayHeader
@ xtpCalendarBeforeDraw_MonthViewWeekDayHeader
dwParam2 - [in] WeekDay = {1-Sun, 2-Mon, ...}, -1 for common part;
Definition XTPCalendarNotifications.h:728
xtpCalendarBeforeDraw_MonthViewEvent
@ xtpCalendarBeforeDraw_MonthViewEvent
dwParam2 - [in] CXTPCalendarMonthViewEvent
Definition XTPCalendarNotifications.h:726
XTP_NC_CALENDARPATTERNWASCHANGED
static const XTP_NOTIFY_CODE XTP_NC_CALENDARPATTERNWASCHANGED
Recurrence pattern has just been changed in the data provider.
Definition XTPCalendarNotifications.h:90
XTP_NC_CALENDAR_BEFORE_DRAW_DAYVIEWCELL
static const XTP_NOTIFY_CODE XTP_NC_CALENDAR_BEFORE_DRAW_DAYVIEWCELL
This notification is sent for each calendar day view cell before draw.
Definition XTPCalendarNotifications.h:658
XTP_NC_CALENDAR_DoGetUpcomingEvents
static const XTP_NOTIFY_CODE XTP_NC_CALENDAR_DoGetUpcomingEvents
This notification is used as an analog of the overridable method CXTPCalendarData::DoGetUpcomingEvent...
Definition XTPCalendarNotifications.h:593
XTP_NC_CALENDAR_GETGROPVIEWCAPTION
static const XTP_NOTIFY_CODE XTP_NC_CALENDAR_GETGROPVIEWCAPTION
This notification is sent when the selection is changed.
Definition XTPCalendarNotifications.h:606
XTP_NC_CALENDARVIEWWASCHANGED
static const XTP_NOTIFY_CODE XTP_NC_CALENDARVIEWWASCHANGED
Current Calendar Control view type(day, week, ...) or content was changed.
Definition XTPCalendarNotifications.h:99
XTP_NC_CALENDARMOUSEMOVE
static const XTP_NOTIFY_CODE XTP_NC_CALENDARMOUSEMOVE
On MouseMove event.
Definition XTPCalendarNotifications.h:139
XTP_NC_CALENDARLBUTTONDBLCLICK
static const XTP_NOTIFY_CODE XTP_NC_CALENDARLBUTTONDBLCLICK
On LButtonDblClick event.
Definition XTPCalendarNotifications.h:123
XTP_NC_CALENDAR_DoRetrieveDayEvents
static const XTP_NOTIFY_CODE XTP_NC_CALENDAR_DoRetrieveDayEvents
This notification is used as an analog of the overridable method CXTPCalendarData::DoRetrieveDayEvent...
Definition XTPCalendarNotifications.h:403
XTP_NC_CALENDAR_CAPTIONBARPART_CLICK
static const XTP_NOTIFY_CODE XTP_NC_CALENDAR_CAPTIONBARPART_CLICK
This notification is sent on a CaptionBar part click.
Definition XTPCalendarNotifications.h:916
XTP_NC_CALENDAR_DoDelete_Event
static const XTP_NOTIFY_CODE XTP_NC_CALENDAR_DoDelete_Event
This notification is used as an analog of the overridable method CXTPCalendarData::DoDelete_Event.
Definition XTPCalendarNotifications.h:501
XTP_NC_CALENDARPATTERNWASADDED
static const XTP_NOTIFY_CODE XTP_NC_CALENDARPATTERNWASADDED
New recurrence pattern has just been added to the data provider.
Definition XTPCalendarNotifications.h:74
XTP_NC_CALENDARKEYDOWN
static const XTP_NOTIFY_CODE XTP_NC_CALENDARKEYDOWN
On KeyDown event.
Definition XTPCalendarNotifications.h:147
XTP_NC_CALENDAR_DoCreate_Event
static const XTP_NOTIFY_CODE XTP_NC_CALENDAR_DoCreate_Event
This notification is used as an analog of the overridable method CXTPCalendarData::DoCreate_Event.
Definition XTPCalendarNotifications.h:469
XTPCalendarRemindersAction
XTPCalendarRemindersAction
Enumeration of possible Calendar Reminder notification actions.
Definition XTPCalendarNotifications.h:353
xtpCalendarReminderDismissed
@ xtpCalendarReminderDismissed
When 1 pending reminder was dismissed.
Definition XTPCalendarNotifications.h:363
xtpCalendarRemindersMonitoringStarted
@ xtpCalendarRemindersMonitoringStarted
Sends after monitoring has started (end of executing CXTPCalendarRemindersManager::StartMonitoring)
Definition XTPCalendarNotifications.h:354
xtpCalendarReminderSnoozed
@ xtpCalendarReminderSnoozed
When 1 pending reminder was snoozed.
Definition XTPCalendarNotifications.h:361
xtpCalendarRemindersMonitoringStopped
@ xtpCalendarRemindersMonitoringStopped
Sends when monitoring has stopped (CXTPCalendarRemindersManager::StopMonitoring)
Definition XTPCalendarNotifications.h:357
xtpCalendarRemindersFire
@ xtpCalendarRemindersFire
Main notification, when reminder is executed.
Definition XTPCalendarNotifications.h:359
xtpCalendarReminderDismissedAll
@ xtpCalendarReminderDismissedAll
When all pending reminders were dismissed.
Definition XTPCalendarNotifications.h:365
XTP_NC_CALENDAREVENTWASCHANGED
static const XTP_NOTIFY_CODE XTP_NC_CALENDAREVENTWASCHANGED
Event has just been changed in the data provider.
Definition XTPCalendarNotifications.h:59
XTP_NC_CALENDAR_BEFORE_EVENT_EDIT_OPERATION
static const XTP_NOTIFY_CODE XTP_NC_CALENDAR_BEFORE_EVENT_EDIT_OPERATION
This notification is sent to customize or disable a specified editing operation.
Definition XTPCalendarNotifications.h:250
XTP_NC_CALENDARPATTERNWASDELETED
static const XTP_NOTIFY_CODE XTP_NC_CALENDARPATTERNWASDELETED
Recurrence pattern has just been deleted from the data provider.
Definition XTPCalendarNotifications.h:82
XTP_NC_CALENDAR_DoDelete_RPattern
static const XTP_NOTIFY_CODE XTP_NC_CALENDAR_DoDelete_RPattern
This notification is used as an analog of the overridable method CXTPCalendarData::DoDelete_RPattern.
Definition XTPCalendarNotifications.h:555
XTP_NC_CALENDAR_GETITEMTEXT
static const XTP_NOTIFY_CODE XTP_NC_CALENDAR_GETITEMTEXT
This notification is sent for calendar items which define an AskItemTextFlags property.
Definition XTPCalendarNotifications.h:801
XTP_NC_CALENDAR_BEFORE_DRAW_THEMEOBJECT
static const XTP_NOTIFY_CODE XTP_NC_CALENDAR_BEFORE_DRAW_THEMEOBJECT
This notification is sent for calendar theme items before draw.
Definition XTPCalendarNotifications.h:755
XTP_NC_CALENDAR_DoGetAllEvents_raw
static const XTP_NOTIFY_CODE XTP_NC_CALENDAR_DoGetAllEvents_raw
This notification is used as an analog of the overridable method CXTPCalendarData::DoGetAllEvents_raw...
Definition XTPCalendarNotifications.h:572
XTP_NC_CALENDAREVENTWASADDED
static const XTP_NOTIFY_CODE XTP_NC_CALENDAREVENTWASADDED
New event has just been added to the data provider.
Definition XTPCalendarNotifications.h:43
XTP_NC_CALENDAR_USERACTION
static const XTP_NOTIFY_CODE XTP_NC_CALENDAR_USERACTION
This notification is sent when a user action defined in XTPCalendarUserAction enum happens.
Definition XTPCalendarNotifications.h:879
XTP_NC_CALENDAR_DoCreate_RPattern
static const XTP_NOTIFY_CODE XTP_NC_CALENDAR_DoCreate_RPattern
This notification is used as an analog of the overridable method CXTPCalendarData::DoCreate_RPattern.
Definition XTPCalendarNotifications.h:521
XTP_NC_CALENDAR_THEME_CHANGED
static const XTP_NOTIFY_CODE XTP_NC_CALENDAR_THEME_CHANGED
This notification is sent when the calendar paint theme changes.
Definition XTPCalendarNotifications.h:911
XTP_NC_CALENDAROPTIONSWASCHANGED
static const XTP_NOTIFY_CODE XTP_NC_CALENDAROPTIONSWASCHANGED
Calendar Control options was changed.
Definition XTPCalendarNotifications.h:175
XTP_NC_CALENDARCONTEXTMENU
static const XTP_NOTIFY_CODE XTP_NC_CALENDARCONTEXTMENU
A Context Menu should be displayed for the Calendar Control.
Definition XTPCalendarNotifications.h:107
XTP_NC_CALENDAREVENTWASDELETED
static const XTP_NOTIFY_CODE XTP_NC_CALENDAREVENTWASDELETED
Event has just been deleted from the data provider.
Definition XTPCalendarNotifications.h:51
XTP_NC_CALENDAR_DoUpdate_RPattern
static const XTP_NOTIFY_CODE XTP_NC_CALENDAR_DoUpdate_RPattern
This notification is used as an analog of the overridable method CXTPCalendarData::DoUpdate_RPattern.
Definition XTPCalendarNotifications.h:538
XTP_NC_CALENDARVIEWTIMESCALEWASCHANGED
static const XTP_NOTIFY_CODE XTP_NC_CALENDARVIEWTIMESCALEWASCHANGED
Calendar Control Day view time scale was changed.
Definition XTPCalendarNotifications.h:163
XTP_NC_CALENDAR_ON_REMINDERS
static const XTP_NOTIFY_CODE XTP_NC_CALENDAR_ON_REMINDERS
On RButtonUp event.
Definition XTPCalendarNotifications.h:375
XTP_NC_CALENDAR_CAPTIONBARPART_BEFORE_CLICK
static const XTP_NOTIFY_CODE XTP_NC_CALENDAR_CAPTIONBARPART_BEFORE_CLICK
This notification is sent before a CaptionBar part click.
Definition XTPCalendarNotifications.h:921
XTP_NC_CALENDAR_DoUpdate_Event
static const XTP_NOTIFY_CODE XTP_NC_CALENDAR_DoUpdate_Event
This notification is used as an analog of the overridable method CXTPCalendarData::DoUpdate_Event.
Definition XTPCalendarNotifications.h:485
XTP_NC_CALENDAR_DoRemoveAllEvents
static const XTP_NOTIFY_CODE XTP_NC_CALENDAR_DoRemoveAllEvents
This notification is used as an analog of the overridable method CXTPCalendarData::DoRemoveAllEvents.
Definition XTPCalendarNotifications.h:416
XTP_NC_CALENDAR_SELECTION_CHANGED
static const XTP_NOTIFY_CODE XTP_NC_CALENDAR_SELECTION_CHANGED
This notification is sent when the selection is changed.
Definition XTPCalendarNotifications.h:334
XTP_NC_CALENDARRBUTTONUP
static const XTP_NOTIFY_CODE XTP_NC_CALENDARRBUTTONUP
On RButtonUp event.
Definition XTPCalendarNotifications.h:342
XTP_NC_CALENDAR_PREPOPULATE
static const XTP_NOTIFY_CODE XTP_NC_CALENDAR_PREPOPULATE
This notification is sent when calendar is populating.
Definition XTPCalendarNotifications.h:624
XTP_NC_CALENDARDATAPROVIDERWASCHANGED
static const XTP_NOTIFY_CODE XTP_NC_CALENDARDATAPROVIDERWASCHANGED
Calendar Control data provider (resources) was changed.
Definition XTPCalendarNotifications.h:189
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCalendarDayViewGroup
This class represents a single resource view portion of the Calendar Day View.
Definition XTPCalendarDayViewDay.h:53
CXTPCalendarEvent
This class represents the data of a single Event used in the Calendar control.
Definition XTPCalendarEvent.h:77
CXTPCalendarViewDay
This class represents the day view portion of the CalendarView.
Definition XTPCalendarViewDay.h:555
CXTPCalendarViewEvent
This class represents an event view portion of the CalendarViewGroup.
Definition XTPCalendarViewEvent.h:106
CXTPCalendarViewEvents
This class is used as a collection of Event View objects.
Definition XTPCalendarViewEvent.h:1004
XTP_CALENDAR_DAYVIEWCELL_PARAMS
Set of parameters transferred from calendar items for an XTP_NC_CALENDAR_BEFORE_DRAW_DAYVIEWCELL noti...
Definition XTPCalendarNotifications.h:638
XTP_CALENDAR_DAYVIEWCELL_PARAMS::clrBackgroundColor
COLORREF clrBackgroundColor
[in/out] Background cell color.
Definition XTPCalendarNotifications.h:643
XTP_CALENDAR_DAYVIEWCELL_PARAMS::nIndex
int nIndex
[in] Cell index.
Definition XTPCalendarNotifications.h:639
XTP_CALENDAR_DAYVIEWCELL_PARAMS::dtBeginTime
DATE dtBeginTime
[in] Begin cell date and time.
Definition XTPCalendarNotifications.h:640
XTP_CALENDAR_DAYVIEWCELL_PARAMS::bSelected
BOOL bSelected
[in] Is cell selected.
Definition XTPCalendarNotifications.h:641
XTP_CALENDAR_GETITEMTEXT_PARAMS
Set of parameters transferred from calendar items for an XTP_NC_CALENDAR_GETITEMTEXT notification.
Definition XTPCalendarNotifications.h:771
XTP_CALENDAR_GETITEMTEXT_PARAMS::pViewEvent
CXTPCalendarViewEvent * pViewEvent
[in] Pointer to a ViewEvent object or NULL.
Definition XTPCalendarNotifications.h:776
XTP_CALENDAR_GETITEMTEXT_PARAMS::nWeekDay
int nWeekDay
[in] Zero or Week day number as: 1 - Sunday, 2 - Monday, etc, 7 - Saturday.
Definition XTPCalendarNotifications.h:779
XTP_CALENDAR_GETITEMTEXT_PARAMS::nItem
int nItem
[in] One of the values from enums XTPCalendarGetItemText, XTPCalendarGetItemTextEx;
Definition XTPCalendarNotifications.h:772
XTP_CALENDAR_GETITEMTEXT_PARAMS::pstrText
CString * pstrText
[in, out] - Pointer to item text;
Definition XTPCalendarNotifications.h:774
XTP_CALENDAR_GETITEMTEXT_PARAMS::pViewDay
CXTPCalendarViewDay * pViewDay
[in] Pointer to a ViewDay object or NULL.
Definition XTPCalendarNotifications.h:777
XTP_CALENDAR_GETITEMTEXT_PARAMS::nWeekNum
int nWeekNum
[in] Zero or current visible range first week number.
Definition XTPCalendarNotifications.h:780
XTP_CALENDAR_THEME_DAYVIEWCELL_PARAMS
Set of parameters transferred from calendar items for an XTP_NC_CALENDAR_BEFORE_DRAW_THEMEOBJECT noti...
Definition XTPCalendarNotifications.h:672
XTP_CALENDAR_THEME_DAYVIEWCELL_PARAMS::pViewGroup
CXTPCalendarDayViewGroup * pViewGroup
[in] Owner group.
Definition XTPCalendarNotifications.h:678
XTP_CALENDAR_THEME_DAYVIEWCELL_PARAMS::nIndex
int nIndex
[in] Cell index.
Definition XTPCalendarNotifications.h:673
XTP_CALENDAR_THEME_DAYVIEWCELL_PARAMS::dtBeginTime
DATE dtBeginTime
[in] Begin cell date and time.
Definition XTPCalendarNotifications.h:674
XTP_CALENDAR_THEME_DAYVIEWCELL_PARAMS::bWorkCell
BOOL bWorkCell
[in] The cell is work (or non-work).
Definition XTPCalendarNotifications.h:676
XTP_CALENDAR_THEME_DAYVIEWCELL_PARAMS::bSelected
BOOL bSelected
[in] Is cell selected.
Definition XTPCalendarNotifications.h:675
XTP_CALENDAR_THEME_DAYVIEWTIMESCALECELL_PARAMS
Set of parameters transferred from calendar items for an XTP_NC_CALENDAR_BEFORE_DRAW_THEMEOBJECT noti...
Definition XTPCalendarNotifications.h:693
XTP_CALENDAR_THEME_DAYVIEWTIMESCALECELL_PARAMS::nMinutes
int nMinutes
[in] SubCell Minutes value {0, 5, 10, ...} or -1 for cell hour.
Definition XTPCalendarNotifications.h:699
XTP_CALENDAR_THEME_DAYVIEWTIMESCALECELL_PARAMS::nIndex
int nIndex
[in] Cell index.
Definition XTPCalendarNotifications.h:696
XTP_CALENDAR_THEME_DAYVIEWTIMESCALECELL_PARAMS::dtBeginTime
DATE dtBeginTime
[in] Begin cell time.
Definition XTPCalendarNotifications.h:697
XTP_CALENDAR_THEME_DAYVIEWTIMESCALECELL_PARAMS::nTimeScale
int nTimeScale
[in] Time scale number {1 - main, 2 - additional}
Definition XTPCalendarNotifications.h:694
XTP_CALENDAR_USERACTION_PARAMS::EXPANDDAYBUTTONACTION_PARAMS
Defines parameters for xtpCalendarUserAction_OnExpandDay user action.
Definition XTPCalendarNotifications.h:836
XTP_CALENDAR_USERACTION_PARAMS::EXPANDDAYBUTTONACTION_PARAMS::nButton
XTPCalendarExpandDayButton nButton
Defines Month view or Week View expand button.
Definition XTPCalendarNotifications.h:837
XTP_CALENDAR_USERACTION_PARAMS::EXPANDDAYBUTTONACTION_PARAMS::pViewDay
CXTPCalendarViewDay * pViewDay
Pointer to a CXTPCalendarDayViewDay object or NULL.
Definition XTPCalendarNotifications.h:839
XTP_CALENDAR_USERACTION_PARAMS::SCROLLDAYBUTTONACTION_PARAMS
Defines parameters for xtpCalendarUserAction_OnScrollDay user action.
Definition XTPCalendarNotifications.h:847
XTP_CALENDAR_USERACTION_PARAMS::SCROLLDAYBUTTONACTION_PARAMS::pViewGroup
CXTPCalendarDayViewGroup * pViewGroup
Pointer to a CXTPCalendarDayViewGroup object or NULL.
Definition XTPCalendarNotifications.h:849
XTP_CALENDAR_USERACTION_PARAMS::SCROLLDAYBUTTONACTION_PARAMS::nButton
XTPCalendarScrollDayButton nButton
Defines Month view or Week View expand button.
Definition XTPCalendarNotifications.h:848
XTP_CALENDAR_USERACTION_PARAMS
Set of parameters transferred from calendar items for an XTP_NC_CALENDAR_USERACTION notification.
Definition XTPCalendarNotifications.h:830
XTP_CALENDAR_USERACTION_PARAMS::m_eAction
XTPCalendarUserAction m_eAction
A value from XTPCalendarUserAction.
Definition XTPCalendarNotifications.h:853
XTP_CALENDAR_USERACTION_PARAMS::m_ScrollDayButton
SCROLLDAYBUTTONACTION_PARAMS m_ScrollDayButton
Parameters for xtpCalendarUserAction_OnScrollDay user action.
Definition XTPCalendarNotifications.h:860
XTP_CALENDAR_USERACTION_PARAMS::m_ExpandDayButton
EXPANDDAYBUTTONACTION_PARAMS m_ExpandDayButton
Parameters for xtpCalendarUserAction_OnExpandDay user action.
Definition XTPCalendarNotifications.h:857
XTP_CALENDAR_WPARAM2
Doubled custom parameter for notifications.
Definition XTPCalendarNotifications.h:382
XTP_CALENDAR_WPARAM2::wParam1
WPARAM wParam1
First custom parameter
Definition XTPCalendarNotifications.h:383
XTP_CALENDAR_WPARAM2::wParam2
WPARAM wParam2
Second custom parameter.
Definition XTPCalendarNotifications.h:384
XTP_EVENT_DRAG_OPERATION_PARAMS
This structure is used with notifications for custom edit event notifications when eOperation is xtpC...
Definition XTPCalendarNotifications.h:316
XTP_EVENT_DRAG_OPERATION_PARAMS::pDraggingEventOriginal
CXTPCalendarEvent * pDraggingEventOriginal
A pointer to original dragging event.
Definition XTPCalendarNotifications.h:317
XTP_EVENT_DRAG_OPERATION_PARAMS::pDraggingEventNew
CXTPCalendarEvent * pDraggingEventNew
A pointer to event after dragging operation.
Definition XTPCalendarNotifications.h:319
XTP_EVENT_DRAG_OPERATION_PARAMS::pDraggingEvent
CXTPCalendarEvent * pDraggingEvent
A pointer to event before dragging operation.
Definition XTPCalendarNotifications.h:318
XTP_EVENT_EDIT_OPERATION_PARAMS
This structure is used as a generic and base class for custom edit event notifications.
Definition XTPCalendarNotifications.h:264
XTP_EVENT_EDIT_OPERATION_PARAMS::pEventViews
CXTPCalendarViewEvents * pEventViews
Event views array with events set for edit operation.
Definition XTPCalendarNotifications.h:266
XTP_EVENT_EDIT_OPERATION_PARAMS::eOperation
XTPCalendarEditOperation eOperation
Edit operation.
Definition XTPCalendarNotifications.h:265
XTP_EVENT_EDIT_OPERATION_PARAMS::nRefCounter
int nRefCounter
Reserved.
Definition XTPCalendarNotifications.h:268
XTP_EVENT_IN_PLACE_CREATE_EVENT_OPERATION_PARAMS
This structure is used with notifications for custom edit event notifications when eOperation is xtpC...
Definition XTPCalendarNotifications.h:298
XTP_EVENT_IN_PLACE_CREATE_EVENT_OPERATION_PARAMS::pcszInitialSubject
LPCTSTR pcszInitialSubject
A pointer to the string which contains initial subject value for new event (generally initial char).
Definition XTPCalendarNotifications.h:299
XTP_EVENT_PASTE_OPERATION_PARAMS
This structure is used with notifications for custom edit event notifications when eOperation is xtpC...
Definition XTPCalendarNotifications.h:281
XTP_EVENT_PASTE_OPERATION_PARAMS::pEvent
CXTPCalendarEvent * pEvent
A pointer to an event prepared for paste.
Definition XTPCalendarNotifications.h:282
XTP_EVENT_PASTE_OPERATION_PARAMS::bPasteWillChangeExistingEvent
BOOL bPasteWillChangeExistingEvent
If this member is TRUE, the new event will not be added, just existing event will be updated.
Definition XTPCalendarNotifications.h:283


Toolkit Pro: Member List

CXTPChartFunnelSeriesLabelView Member List

This is the complete list of members for CXTPChartFunnelSeriesLabelView, including all inherited members.

AddChildView(CXTPChartElementView *pChildView) | CXTPChartElementView |
CreateDeviceCommand(CXTPChartDeviceContext *pDC) | CXTPChartFunnelSeriesLabelView | virtual
CXTPChartElementView(CXTPChartElementView *pParentView) | CXTPChartElementView |
CXTPChartElementView(CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartElementView |
CXTPChartElementView(CXTPChartContainer *pContainer) | CXTPChartElementView |
CXTPChartFunnelSeriesLabelView(CXTPChartSeriesLabel *pLabel, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView) | CXTPChartFunnelSeriesLabelView |
CXTPChartFunnelSeriesLabelViewBase(CXTPChartSeriesLabel *pLabel, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView) | CXTPChartFunnelSeriesLabelViewBase | protected
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
GetAt(int nIndex) const | CXTPChartElementView |
GetBounds() const | CXTPChartElementView |
GetBounds(BOOL bIncludingChildren) const | CXTPChartElementView |
GetChildren() | CXTPChartElementView |
GetCount() const | CXTPChartElementView |
GetParentView() const | CXTPChartElementView |
GetPosition() const | CXTPChartFunnelSeriesLabelViewBase |
Is3D() const | CXTPChartObject |
m_arrChildren | CXTPChartElementView | protected
m_pContainer | CXTPChartElementView | protected
m_pParentView | CXTPChartElementView | protected
m_rcBounds | CXTPChartElementView | protected
~CXTPChartElementView() | CXTPChartElementView | protectedvirtual


Toolkit Pro: Member List

CXTPComboBox Member List

This is the complete list of members for CXTPComboBox, including all inherited members.

CXTPComboBox() | CXTPComboBox |
EnableAutoCompletion(BOOL bEnable=TRUE) | CXTPComboBox |
EnableMarkup(BOOL bEnableMarkup=TRUE) | CXTPComboBox |
GetBackColor() const | CXTPComboBox |
GetClientBrush(CDC *pDC) | CXTPComboBox |
GetComboBoxRect() const | CXTPComboBox |
GetFlatStyle() const | CXTPComboBox |
GetTextColor() const | CXTPComboBox |
GetTheme() | CXTPComboBox |
GetTheme() const | CXTPComboBox |
GetUseVisualStyle() const | CXTPComboBox |
Initialize(bool bAutoFont=true) | CXTPComboBox | virtual
IsDroppedDown() const | CXTPComboBox |
IsFocused() const | CXTPComboBox |
IsHighlighted() const | CXTPComboBox |
m_bAutoComp | CXTPComboBox | protected
m_bDisableAC | CXTPComboBox | protected
m_bEnableMarkup | CXTPComboBox | protected
m_bFlatStyle | CXTPComboBox | protected
m_bFocused | CXTPComboBox | protected
m_bHighlighted | CXTPComboBox | protected
m_bPreSubclassInit | CXTPComboBox | protected
m_bUseVisualStyle | CXTPComboBox | protected
m_pMarkupContext | CXTPComboBox | protected
m_pTheme | CXTPComboBox | protected
m_pWndEdit | CXTPComboBox | protected
NeedRedraw() | CXTPComboBox | protected
RedrawComboBox(BOOL bUpdateWindow=FALSE) | CXTPComboBox |
RedrawFocusedFrame() | CXTPComboBox | protected
RefreshMetrics() | CXTPComboBox |
SetBackColor(COLORREF crBack) | CXTPComboBox | virtual
SetFlatStyle(BOOL bFlatStyle=TRUE) | CXTPComboBox |
SetHighlighted(BOOL bHot) | CXTPComboBox |
SetTextColor(COLORREF crText) | CXTPComboBox | virtual
SetTheme(XTPControlTheme nTheme) | CXTPComboBox |
SetTheme(CXTPComboBoxTheme *pTheme) | CXTPComboBox | virtual
SetUseVisualStyle(BOOL bUseVisualStyle=TRUE) | CXTPComboBox |
~CXTPComboBox() | CXTPComboBox | virtual


Toolkit Pro: Member List

CXTPDockingPanePanelTheme2012 Member List

This is the complete list of members for CXTPDockingPanePanelTheme2012, including all inherited members.

AdjustClientRect(CXTPTabManager *pTabManager, CRect &rcClient) | CXTPTabPaintManagerTheme | virtual
CXTPDockingPanePanelTheme2012() | CXTPDockingPanePanelTheme2012 |
CXTPTabPaintManagerTheme() | CXTPTabPaintManagerTheme |
CXTPTabThemeFlat() | CXTPTabThemeFlat | inline
DrawSingleButton(CDC *pDC, CXTPTabManagerItem *pItem) | CXTPDockingPanePanelTheme2012 | virtual
DrawTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl) | CXTPTabPaintManagerTheme | virtual
DrawText(CDC *pDC, CXTPTabManager *pManager, const CString &str, LPRECT lpRect, UINT nFormat) | CXTPTabPaintManagerTheme | virtual
DrawWorkspacePart(CDC *pDC, LPRECT lpRect, XTPTabWorkspacePart workspacePart) | CXTPTabPaintManagerTheme | virtual
FillButton(CDC *pDC, CXTPTabManagerItem *pItem, LPPOINT pts, int nCount, XTPTabPosition tabPosition, BOOL bAbsolute=FALSE) | CXTPTabPaintManagerTheme |
FillTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl) | CXTPTabThemeFlat | virtual
GetButtonDrawRect(const CXTPTabManagerItem *pItem) | CXTPTabPaintManagerTheme | virtual
GetButtonHeight(const CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetButtonLength(CDC *pDC, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerTheme | virtual
GetClientMargin() | CXTPTabPaintManagerTheme | virtual
GetClientRect(CRect rcControl, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetColorSet() const | CXTPTabPaintManagerTheme |
GetDefaultColorSet() | CXTPTabThemeFlat | inlinevirtual
GetHeaderClipBox(CDC *pDC, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetHeaderHeight(CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme |
GetHeaderMargin() | CXTPTabPaintManagerTheme | virtual
GetHeaderRect(CRect rcControl, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetSupportedColorSets() | CXTPTabPaintManagerTheme | inlinevirtual
m_bButtonsReverseZOrder | CXTPTabPaintManagerTheme | protected
m_nButtonHeight | CXTPTabPaintManagerTheme | protected
m_nGripperWidth | CXTPDockingPanePanelTheme2012 | protected
m_nRowMargin | CXTPTabPaintManagerTheme |
m_pPaintManager | CXTPTabPaintManagerTheme | protected
m_rcHeaderMargin | CXTPTabPaintManagerTheme |
RefreshMetrics() | CXTPDockingPanePanelTheme2012 | virtual
RepositionTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcClient) | CXTPTabPaintManagerTheme | virtual
~CXTPTabPaintManagerTheme() | CXTPTabPaintManagerTheme | virtual


Toolkit Pro: Member List

CXTPMarkupGdiPlusTransformationMatrix Member List

This is the complete list of members for CXTPMarkupGdiPlusTransformationMatrix, including all inherited members.

Clone() const | CXTPMarkupGdiPlusTransformationMatrix | virtual
CXTPMarkupGdiPlusTransformationMatrix(CXTPGdiPlus *pReserved, GpMatrix *pMatrix) | CXTPMarkupGdiPlusTransformationMatrix |
CXTPMarkupTransformationMatrix() | CXTPMarkupTransformationMatrix | protected
GetBoundRect(const RECT &rect, const POINT &absoluteOffset) const | CXTPMarkupGdiPlusTransformationMatrix | virtual
GetMatrix() | CXTPMarkupGdiPlusTransformationMatrix |
GetMatrix() const | CXTPMarkupGdiPlusTransformationMatrix |
Offset(const POINT &offset) | CXTPMarkupGdiPlusTransformationMatrix | virtual
PtInRect(const RECT &rect, const POINT &absoluteOffset, const POINT &point) const | CXTPMarkupGdiPlusTransformationMatrix | virtual
~CXTPMarkupGdiPlusTransformationMatrix() | CXTPMarkupGdiPlusTransformationMatrix |
~CXTPMarkupTransformationMatrix() | CXTPMarkupTransformationMatrix | virtual


Toolkit Pro: XTPTagCloudCtrl.h Source File

  • Source
  • Controls
  • TagCloud
XTPTagCloudCtrl.h
Go to the documentation of this file.
1
23#if !defined(__XTPTAGCLOUDCTRL_H__)
24# define __XTPTAGCLOUDCTRL_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPTagCloudStyle
39{
40public:
45 CXTPTagCloudStyle();
46
52 CXTPTagCloudStyle(const CXTPTagCloudStyle& style);
53
65 CXTPTagCloudStyle(int nScore, COLORREF clrText, COLORREF clrTextHover, COLORREF clrBorder,
66 LOGFONT& lf);
67
74 void SetFont(LOGFONT& lf);
75
85 CXTPTagCloudStyle& operator=(const CXTPTagCloudStyle& style);
86
94 static void AFX_CDECL Copy(const CXTPTagCloudStyle* pSource, CXTPTagCloudStyle* pDest);
95
96 int m_nScore;
98 CXTPFont m_xtpFont;
99 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CFont, m_font, m_xtpFont, GetFontHandle);
100
101 COLORREF m_clrText;
102 COLORREF m_clrTextHover;
103 COLORREF m_clrBorder;
104};
105
110typedef CArray<CXTPTagCloudStyle*, CXTPTagCloudStyle*> CXTPTagCloudStyleArray;
111
118class _XTP_EXT_CLASS CXTPTagCloudStyleManager : public CXTPCmdTarget
119{
120 CXTPTagCloudStyleManager();
121
122public:
127 ~CXTPTagCloudStyleManager();
128
134 void InitDefaultStyles();
135
149 INT_PTR AddStyle(int nScore, COLORREF clrText, COLORREF clrTextHover, COLORREF clrBorder,
150 LOGFONT& lf);
151
159 INT_PTR AddStyle(CXTPTagCloudStyle* pStyle);
160
169 BOOL RemoveStyle(int nScore);
170
176 void RemoveAll();
177
186 CXTPTagCloudStyle* GetStyle(int nScore);
187
201 BOOL SetColors(int nScore, COLORREF clrText, COLORREF clrTextHover,
202 COLORREF clrBorder = COLORREF_NULL);
203
213 BOOL SetFont(int nScore, LOGFONT& lf);
214
222 CXTPTagCloudStyleArray& GetCloudStyleArray();
223
232 BOOL ScoreExists(int nScore);
233
234protected:
235 CXTPTagCloudStyleArray m_arrStyles;
238private:
239 friend class CXTPSingleton<CXTPTagCloudStyleManager>;
240 friend _XTP_EXT_CLASS CXTPTagCloudStyleManager* AFX_CDECL XTPTabCloudStyleManager();
241# ifdef _XTP_ACTIVEX
244 DECLARE_DISPATCH_MAP()
245 DECLARE_INTERFACE_MAP()
246
247 DECLARE_OLETYPELIB_EX(CXTPTagCloudStyleManager);
248
249 void OleInitDefaultStyles();
250 void OleAdd(LPDISPATCH pStyle);
251 void OleRemove(long Score);
252 void OleRemoveAll();
253 LPDISPATCH OleGet(long Score);
254 void OleSetStyle(LPDISPATCH pStyle);
255 BOOL OleScoreExists(long Score);
256 LPDISPATCH OleCreateStyle();
257 virtual void OnFinalRelease();
258 afx_msg long OleGetItemCount();
259 afx_msg LPDISPATCH OleGetItem(long Index);
260
261 DECLARE_ENUM_VARIANT(CXTPTagCloudStyleManager);
262
264# endif
265};
267AFX_INLINE CXTPTagCloudStyleArray& CXTPTagCloudStyleManager::GetCloudStyleArray()
268{
269 return m_arrStyles;
270}
278_XTP_EXT_CLASS CXTPTagCloudStyleManager* AFX_CDECL XTPTabCloudStyleManager();
279
285struct XTP_TAGCLOUDTAG
286{
293 XTP_TAGCLOUDTAG(LPCTSTR lpszItem, int nScore)
294 : nScore(nScore)
295 , strItem(lpszItem)
296 {
297 }
298
299 int nScore;
300 CString strItem;
301 CXTPEmptyRect rcItem;
302};
303
309enum XTPTagCloudSort
310{
311 xtpTagCloudNone,
312 xtpTagCloudAlpha,
313 xtpTagCloudNumeric,
314};
315
321class _XTP_EXT_CLASS CXTPTagCloudTagArray : public CArray<XTP_TAGCLOUDTAG*, XTP_TAGCLOUDTAG*>
322{
323public:
333 void Sort(XTPTagCloudSort nSort, BOOL bAsc);
334
335private:
336 //-----------------------------------------------------------------------
337 // Private use: CXTPTagCloudCtrl::RemoveAll() instead.
338 //-----------------------------------------------------------------------
339 void RemoveAll();
340 //-----------------------------------------------------------------------
341 // Private use: CXTPTagCloudCtrl::RemoveTag(XTP_TAGCLOUDTAG* pTag) instead.
342 //-----------------------------------------------------------------------
343 void RemoveAt(INT_PTR nIndex, INT_PTR nCount = 1);
344
345 static int AFX_CDECL CompareName(XTP_TAGCLOUDTAG* pTagA, XTP_TAGCLOUDTAG* pTagB, BOOL bAsc);
346 static int AFX_CDECL CompareScore(XTP_TAGCLOUDTAG* pTagA, XTP_TAGCLOUDTAG* pTagB, BOOL bAsc);
347 static int AFX_CDECL CompareNameAsc(LPCVOID a, LPCVOID b);
348 static int AFX_CDECL CompareNameDesc(LPCVOID a, LPCVOID b);
349 static int AFX_CDECL CompareScoreAsc(LPCVOID a, LPCVOID b);
350 static int AFX_CDECL CompareScoreDesc(LPCVOID a, LPCVOID b);
351
352 friend class CXTPTagCloudCtrl;
353};
355AFX_INLINE int AFX_CDECL CXTPTagCloudTagArray::CompareNameAsc(LPCVOID a, LPCVOID b)
356{
357 return CompareName(*(XTP_TAGCLOUDTAG**)a, *(XTP_TAGCLOUDTAG**)b, TRUE);
358}
359AFX_INLINE int AFX_CDECL CXTPTagCloudTagArray::CompareNameDesc(LPCVOID a, LPCVOID b)
360{
361 return CompareName(*(XTP_TAGCLOUDTAG**)a, *(XTP_TAGCLOUDTAG**)b, FALSE);
362}
363AFX_INLINE int AFX_CDECL CXTPTagCloudTagArray::CompareScoreAsc(LPCVOID a, LPCVOID b)
364{
365 return CompareScore(*(XTP_TAGCLOUDTAG**)a, *(XTP_TAGCLOUDTAG**)b, TRUE);
366}
367AFX_INLINE int AFX_CDECL CXTPTagCloudTagArray::CompareScoreDesc(LPCVOID a, LPCVOID b)
368{
369 return CompareScore(*(XTP_TAGCLOUDTAG**)a, *(XTP_TAGCLOUDTAG**)b, FALSE);
370}
379class _XTP_EXT_CLASS CXTPTagCloudCtrl : public CWnd
380{
381public:
386 CXTPTagCloudCtrl();
387
392 virtual ~CXTPTagCloudCtrl();
393
404 virtual BOOL Create(DWORD dwStyle, const RECT& rect, CWnd* pParentWnd, UINT nID);
405
406 using CWnd::Create;
407
413 void AddTag(XTP_TAGCLOUDTAG* pTag);
414
420 void RemoveTag(XTP_TAGCLOUDTAG* pTag);
421
426 void RemoveAll();
427
435 XTP_TAGCLOUDTAG* HitTest(const CPoint& point);
436
442 virtual void RecalcLayout();
443
449 void SetMargin(int nMargin);
450
457 int GetMargin() const;
458
464 void SetPadding(int nPadding);
465
472 int GetPadding() const;
473
479 void EnableTooltip(BOOL bTipEnabled);
480
487 BOOL IsTipEnabled() const;
488
494 void EnableFocusRect(BOOL bFocusRect);
495
503 BOOL IsFocusEnabled() const;
504
514 void SetSortOrder(XTPTagCloudSort nSortOrder, BOOL bAsc);
515
525 XTPTagCloudSort GetSortOrder() const;
526
534 XTP_TAGCLOUDTAG* GetCurSel();
535
542 void SetCurSel(XTP_TAGCLOUDTAG* pCurSel);
543
554 void SetBackColor(CXTPPaintManagerColorGradient clrBack, BOOL bHorz = FALSE);
555
563 CXTPPaintManagerColorGradient GetBackColor() const;
564
570 void SetBorderColor(CXTPPaintManagerColor clrBorder);
571
579 CXTPPaintManagerColor GetBorderColor() const;
580
588 BOOL IsFillHorz() const;
589
594 void RestoreDefaults();
595
596 //{{AFX_VIRTUAL(CXTPTagCloudCtrl)
597public:
598 virtual BOOL PreTranslateMessage(MSG* pMsg);
599 //}}AFX_VIRTUAL
600
601protected:
609 virtual CXTPTagCloudTagArray& GetTagArray();
610
620 virtual BOOL RegisterWindowClass(HINSTANCE hInstance = NULL);
621
629 virtual void OnDraw(CDC* pDC, const CRect& rcClient);
630
643 virtual CSize CalcRowLayout(const CRect& rcClient, const CXTPTagCloudTagArray& arrRow);
644
653 virtual BOOL PointInRect();
654
662 virtual void SetActive(BOOL bActive);
663
675 virtual BOOL OnNotify(XTP_TAGCLOUDTAG* pTag, UINT nEventCode);
676
677 using CWnd::OnNotify;
678
683 void RemoveAllInternal();
684
685 int m_nPadding;
686 int m_nMargin;
687 BOOL m_bActive;
688 BOOL m_bTipEnabled;
689 BOOL m_bFocusRect;
690 BOOL m_bHorz;
692 BOOL m_bAsc;
693 HCURSOR m_hCursor;
694 CToolTipCtrl m_wndToolTip;
695 XTPTagCloudSort m_nSortOrder;
696 XTP_TAGCLOUDTAG* m_pHover;
698 XTP_TAGCLOUDTAG* m_pCurSel;
699 CXTPTagCloudTagArray m_arrTags;
700 CXTPTagCloudTagArray m_arrTagsSorted;
702 CXTPPaintManagerColor m_clrBorder;
703 CXTPPaintManagerColorGradient m_clrBack;
704 CXTPWinThemeWrapper m_themeWrapper;
707 //{{AFX_MSG(CXTPTagCloudCtrl)
708 afx_msg void OnPaint();
709 afx_msg void OnLButtonDown(UINT nFlags, CPoint point);
710 afx_msg void OnSize(UINT nType, int cx, int cy);
711 afx_msg void OnMouseMove(UINT nFlags, CPoint point);
712 afx_msg BOOL OnEraseBkgnd(CDC* pDC);
713 afx_msg BOOL OnSetCursor(CWnd* pWnd, UINT nHitTest, UINT message);
714 afx_msg void OnLButtonDblClk(UINT nFlags, CPoint point);
715 afx_msg void OnRButtonDown(UINT nFlags, CPoint point);
716 afx_msg void OnNcPaint();
717 afx_msg void OnNcCalcSize(BOOL bCalcValidRects, NCCALCSIZE_PARAMS* lpncsp);
718 //}}AFX_MSG
719
721 afx_msg void OnMouseLeave();
722 DECLARE_MESSAGE_MAP()
724};
726AFX_INLINE void CXTPTagCloudCtrl::SetMargin(int nMargin)
727{
728 m_nMargin = nMargin;
729}
730AFX_INLINE int CXTPTagCloudCtrl::GetMargin() const
731{
732 return m_nMargin;
733}
734AFX_INLINE void CXTPTagCloudCtrl::SetPadding(int nPadding)
735{
736 m_nPadding = nPadding;
737}
738AFX_INLINE int CXTPTagCloudCtrl::GetPadding() const
739{
740 return m_nPadding;
741}
742AFX_INLINE BOOL CXTPTagCloudCtrl::IsTipEnabled() const
743{
744 return m_bTipEnabled;
745}
746AFX_INLINE void CXTPTagCloudCtrl::EnableFocusRect(BOOL bFocusRect)
747{
748 m_bFocusRect = bFocusRect;
749 if (GetSafeHwnd())
750 RedrawWindow();
751}
752AFX_INLINE BOOL CXTPTagCloudCtrl::IsFocusEnabled() const
753{
754 return m_bFocusRect;
755}
756AFX_INLINE XTPTagCloudSort CXTPTagCloudCtrl::GetSortOrder() const
757{
758 return m_nSortOrder;
759}
760AFX_INLINE XTP_TAGCLOUDTAG* CXTPTagCloudCtrl::GetCurSel()
761{
762 return m_pCurSel;
763}
764AFX_INLINE void CXTPTagCloudCtrl::SetBackColor(CXTPPaintManagerColorGradient clrBack, BOOL bHorz)
765{
766 m_clrBack = clrBack;
767 m_bHorz = bHorz;
768}
769AFX_INLINE CXTPPaintManagerColorGradient CXTPTagCloudCtrl::GetBackColor() const
770{
771 return m_clrBack;
772}
773AFX_INLINE void CXTPTagCloudCtrl::SetBorderColor(CXTPPaintManagerColor clrBorder)
774{
775 m_clrBorder = clrBorder;
776}
777AFX_INLINE CXTPPaintManagerColor CXTPTagCloudCtrl::GetBorderColor() const
778{
779 return m_clrBorder;
780}
781AFX_INLINE BOOL CXTPTagCloudCtrl::IsFillHorz() const
782{
783 return m_bHorz;
784}
787
788//{{AFX_INSERT_LOCATION}}
789// Microsoft Visual C++ will insert additional declarations immediately before the previous line.
790
791# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
793#endif // !defined(__XTPTAGCLOUDCTRL_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPTabCloudStyleManager
_XTP_EXT_CLASS CXTPTagCloudStyleManager *AFX_CDECL XTPTabCloudStyleManager()
Use the XTPTabCloudStyleManager() function for access to the singleton class CXTPTagCloudStyleManager...
CXTPTagCloudStyleArray
CArray< CXTPTagCloudStyle *, CXTPTagCloudStyle * > CXTPTagCloudStyleArray
CArray based object used for storing CXTPTagCloudStyle structs.
Definition XTPTagCloudCtrl.h:110
XTPTagCloudSort
XTPTagCloudSort
XTPTagCloudSort is an enumeration used by the CXTPTagCloudTagArray class to perform sorting operation...
Definition XTPTagCloudCtrl.h:310
xtpTagCloudNumeric
@ xtpTagCloudNumeric
Sort by tag score.
Definition XTPTagCloudCtrl.h:313
xtpTagCloudAlpha
@ xtpTagCloudAlpha
Sort by tag name.
Definition XTPTagCloudCtrl.h:312
xtpTagCloudNone
@ xtpTagCloudNone
No sorting.
Definition XTPTagCloudCtrl.h:311
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPEmptyRect
CXTPEmptyRect is a helper class used to instantiate an empty CRect object.
Definition XTPDrawHelpers.h:112
CXTPFont
Provides a convenient object oriented interface for HFONT GDI object and uses GDI handle caching.
Definition XTPGdiObjects.h:414
CXTPPaintManagerColorGradient
The CXTPPaintManagerColorGradient class is used to manage COLORREF values for determining light and d...
Definition XTPColorManager.h:301
CXTPPaintManagerColor
The CXTPPaintManagerColor class is used to manage COLORREF values for determining default and applica...
Definition XTPColorManager.h:117
CXTPSingleton
Implements Singleton design pattern.
Definition XTPSingleton.h:215
CXTPTagCloudCtrl
The CXTPTagCloudCtrl class is used to create a tag cloud control representing a visual depiction of g...
Definition XTPTagCloudCtrl.h:380
CXTPTagCloudCtrl::m_nMargin
int m_nMargin
Size, in pixels, of the margin for the client area.
Definition XTPTagCloudCtrl.h:686
CXTPTagCloudCtrl::GetBorderColor
CXTPPaintManagerColor GetBorderColor() const
Retrieves the border color for the tag cloud control.
CXTPTagCloudCtrl::m_bActive
BOOL m_bActive
TRUE if the tag cloud control is active.
Definition XTPTagCloudCtrl.h:687
CXTPTagCloudCtrl::GetBackColor
CXTPPaintManagerColorGradient GetBackColor() const
Retrieves the background color for the tag cloud control.
CXTPTagCloudCtrl::m_hCursor
HCURSOR m_hCursor
Handle to the mouse hover cursor.
Definition XTPTagCloudCtrl.h:693
CXTPTagCloudCtrl::GetCurSel
XTP_TAGCLOUDTAG * GetCurSel()
Retrieves a pointer to the currently selected tag if any.
CXTPTagCloudCtrl::SetMargin
void SetMargin(int nMargin)
Sets the margin for the client area of the tag cloud control.
CXTPTagCloudCtrl::m_arrTags
CXTPTagCloudTagArray m_arrTags
Array of all tags associated with the tag cloud control.
Definition XTPTagCloudCtrl.h:699
CXTPTagCloudCtrl::SetBackColor
void SetBackColor(CXTPPaintManagerColorGradient clrBack, BOOL bHorz=FALSE)
Sets the background color for the tag cloud control.
CXTPTagCloudCtrl::RestoreDefaults
void RestoreDefaults()
Called to restore all default values for the tag cloud control.
CXTPTagCloudCtrl::CXTPTagCloudCtrl
CXTPTagCloudCtrl()
Default constructor.
CXTPTagCloudCtrl::RemoveTag
void RemoveTag(XTP_TAGCLOUDTAG *pTag)
Removes a tag from the tag cloud control.
CXTPTagCloudCtrl::RecalcLayout
virtual void RecalcLayout()
Recalculates the size and position for all tags associated with the tag cloud control.
CXTPTagCloudCtrl::m_bTipEnabled
BOOL m_bTipEnabled
Set to FALSE to disable tooltips.
Definition XTPTagCloudCtrl.h:688
CXTPTagCloudCtrl::SetCurSel
void SetCurSel(XTP_TAGCLOUDTAG *pCurSel)
Sets the current selection for the tag cloud control and sends an event notification to the owner win...
CXTPTagCloudCtrl::EnableTooltip
void EnableTooltip(BOOL bTipEnabled)
Enables/disables tooltips for the tag cloud control.
CXTPTagCloudCtrl::m_pHover
XTP_TAGCLOUDTAG * m_pHover
Pointer to the tag item that the mouse cursor is currently hovering over.
Definition XTPTagCloudCtrl.h:696
CXTPTagCloudCtrl::m_themeWrapper
CXTPWinThemeWrapper m_themeWrapper
Determines if tag cloud control should use Windows themes.
Definition XTPTagCloudCtrl.h:704
CXTPTagCloudCtrl::m_bFocusRect
BOOL m_bFocusRect
Set to FALSE to disable focus rect.
Definition XTPTagCloudCtrl.h:689
CXTPTagCloudCtrl::OnDraw
virtual void OnDraw(CDC *pDC, const CRect &rcClient)
Called by the tag cloud control to draw the client area of the control.
CXTPTagCloudCtrl::m_clrBorder
CXTPPaintManagerColor m_clrBorder
Tag cloud control border color.
Definition XTPTagCloudCtrl.h:702
CXTPTagCloudCtrl::IsFocusEnabled
BOOL IsFocusEnabled() const
Called to determine if tag item focus display is enabled for the tag cloud control.
CXTPTagCloudCtrl::m_pCurSel
XTP_TAGCLOUDTAG * m_pCurSel
Pointer to the tag item that is currently selected.
Definition XTPTagCloudCtrl.h:698
CXTPTagCloudCtrl::IsFillHorz
BOOL IsFillHorz() const
Determines if the background gradient fill style is horizontal or vertical.
CXTPTagCloudCtrl::RemoveAllInternal
void RemoveAllInternal()
Removes all tags from the XTP_TAGCLOUDTAG window.
CXTPTagCloudCtrl::RegisterWindowClass
virtual BOOL RegisterWindowClass(HINSTANCE hInstance=NULL)
Called by the tag cloud control to register the window class used to create the control.
CXTPTagCloudCtrl::Create
virtual BOOL Create(DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID)
Call this member function to create the CXTPTagCloudCtrl window.
CXTPTagCloudCtrl::SetSortOrder
void SetSortOrder(XTPTagCloudSort nSortOrder, BOOL bAsc)
Sets the sort order for all tags associated with the tag cloud control.
CXTPTagCloudCtrl::~CXTPTagCloudCtrl
virtual ~CXTPTagCloudCtrl()
Destructor used to handle cleanup and deallocation.
CXTPTagCloudCtrl::IsTipEnabled
BOOL IsTipEnabled() const
Called to determine if tooltips are enabled for the tab cloud control.
CXTPTagCloudCtrl::AddTag
void AddTag(XTP_TAGCLOUDTAG *pTag)
Adds a new tag to the tag cloud control.
CXTPTagCloudCtrl::m_nSortOrder
XTPTagCloudSort m_nSortOrder
Specifies the sort order for the tag cloud control.
Definition XTPTagCloudCtrl.h:695
CXTPTagCloudCtrl::GetSortOrder
XTPTagCloudSort GetSortOrder() const
Called to determine the sort order for the tag cloud control; can be one of the following values: xtp...
CXTPTagCloudCtrl::m_bHorz
BOOL m_bHorz
TRUE if the background gradient colors should be drawn horizontal, FALSE if vertical.
Definition XTPTagCloudCtrl.h:690
CXTPTagCloudCtrl::RemoveAll
void RemoveAll()
Removes all tags from the XTP_TAGCLOUDTAG window.
CXTPTagCloudCtrl::GetMargin
int GetMargin() const
Retrieves the client area margin for the tag cloud control.
CXTPTagCloudCtrl::OnNotify
virtual BOOL OnNotify(XTP_TAGCLOUDTAG *pTag, UINT nEventCode)
Called by tag cloud control to send notification messages to the owner window when an event specified...
CXTPTagCloudCtrl::SetActive
virtual void SetActive(BOOL bActive)
Called during mouse move events to set the active/inactive state for the tag cloud control.
CXTPTagCloudCtrl::PointInRect
virtual BOOL PointInRect()
Retrieves the cursor position in window coordinates and determines if the cursor is hovering over the...
CXTPTagCloudCtrl::GetTagArray
virtual CXTPTagCloudTagArray & GetTagArray()
Retrieves a reference to the CXTPTagCloudTagArray that contains all of the tags associated with the t...
CXTPTagCloudCtrl::m_arrTagsSorted
CXTPTagCloudTagArray m_arrTagsSorted
Array of sorted tags associated with the tag cloud control.
Definition XTPTagCloudCtrl.h:700
CXTPTagCloudCtrl::m_bAsc
BOOL m_bAsc
TRUE if sorting ascending, FALSE if sorting descending.
Definition XTPTagCloudCtrl.h:692
CXTPTagCloudCtrl::SetBorderColor
void SetBorderColor(CXTPPaintManagerColor clrBorder)
Sets the border color for the tag cloud control.
CXTPTagCloudCtrl::EnableFocusRect
void EnableFocusRect(BOOL bFocusRect)
Enables/disables tag item focus rectangle display.
CXTPTagCloudCtrl::m_clrBack
CXTPPaintManagerColorGradient m_clrBack
Tag cloud control background colors.
Definition XTPTagCloudCtrl.h:703
CXTPTagCloudCtrl::SetPadding
void SetPadding(int nPadding)
Sets the padding for each tag associated with the tag cloud control.
CXTPTagCloudCtrl::HitTest
XTP_TAGCLOUDTAG * HitTest(const CPoint &point)
Retrieves the tag from the cursor position specified by point.
CXTPTagCloudCtrl::m_wndToolTip
CToolTipCtrl m_wndToolTip
Tooltip to be displayed for the control.
Definition XTPTagCloudCtrl.h:694
CXTPTagCloudCtrl::m_nPadding
int m_nPadding
Size, in pixels, of the padding around each tag item.
Definition XTPTagCloudCtrl.h:685
CXTPTagCloudCtrl::CalcRowLayout
virtual CSize CalcRowLayout(const CRect &rcClient, const CXTPTagCloudTagArray &arrRow)
Called by the OnDraw function to calculate the size and position for a tag in the row specified by ar...
CXTPTagCloudCtrl::GetPadding
int GetPadding() const
Retrieves the padding for each tag associated with the tag cloud control.
CXTPTagCloudStyle
CXTPTagCloudStyle is a helper class used by CXTPTagCloudStyleManager to manage styles for the CXTPTag...
Definition XTPTagCloudCtrl.h:39
CXTPTagCloudStyle::m_clrBorder
COLORREF m_clrBorder
An RGB value representing the style border color.
Definition XTPTagCloudCtrl.h:103
CXTPTagCloudStyle::operator=
CXTPTagCloudStyle & operator=(const CXTPTagCloudStyle &style)
Overloaded operator initializes a CXTPTagCloudStyle class using the object specified by style.
CXTPTagCloudStyle::m_xtpFont
CXTPFont m_xtpFont
Font used by the style.
Definition XTPTagCloudCtrl.h:98
CXTPTagCloudStyle::m_clrTextHover
COLORREF m_clrTextHover
An RGB value representing the style text hover color.
Definition XTPTagCloudCtrl.h:102
CXTPTagCloudStyle::CXTPTagCloudStyle
CXTPTagCloudStyle(const CXTPTagCloudStyle &style)
Default constructor.
CXTPTagCloudStyle::CXTPTagCloudStyle
CXTPTagCloudStyle()
Default constructor.
CXTPTagCloudStyle::SetFont
void SetFont(LOGFONT &lf)
Sets the font for the style using the LOGFONT struct specified by lf.
CXTPTagCloudStyle::m_nScore
int m_nScore
Unique identifier used to specify the score or weight of the style.
Definition XTPTagCloudCtrl.h:96
CXTPTagCloudStyle::CXTPTagCloudStyle
CXTPTagCloudStyle(int nScore, COLORREF clrText, COLORREF clrTextHover, COLORREF clrBorder, LOGFONT &lf)
Default constructor.
CXTPTagCloudStyle::m_clrText
COLORREF m_clrText
An RGB value representing the style text color.
Definition XTPTagCloudCtrl.h:101
CXTPTagCloudStyle::Copy
static void AFX_CDECL Copy(const CXTPTagCloudStyle *pSource, CXTPTagCloudStyle *pDest)
Copies the contents from one CXTPTagCloudStyle object to another.
CXTPTagCloudStyleManager
CXTPTagCloudStyleManager is a singleton class used to manage CXTPTagCloudStyle structs that identify ...
Definition XTPTagCloudCtrl.h:119
CXTPTagCloudStyleManager::InitDefaultStyles
void InitDefaultStyles()
Called by the CXTPTagCloudCtrl to initialize a default array of CXTPTagCloudStyle structs representin...
CXTPTagCloudStyleManager::SetColors
BOOL SetColors(int nScore, COLORREF clrText, COLORREF clrTextHover, COLORREF clrBorder=COLORREF_NULL)
Sets the color values for the style specified by nScore.
CXTPTagCloudStyleManager::XTPTabCloudStyleManager
friend _XTP_EXT_CLASS CXTPTagCloudStyleManager *AFX_CDECL XTPTabCloudStyleManager()
Use the XTPTabCloudStyleManager() function for access to the singleton class CXTPTagCloudStyleManager...
CXTPTagCloudStyleManager::~CXTPTagCloudStyleManager
~CXTPTagCloudStyleManager()
Destructor used to handle cleanup and deallocation.
CXTPTagCloudStyleManager::SetFont
BOOL SetFont(int nScore, LOGFONT &lf)
Sets the font for the style specified by nScore.
CXTPTagCloudStyleManager::RemoveAll
void RemoveAll()
Call this member function to remove all tag styles from the style array and free any allocated memory...
CXTPTagCloudStyleManager::m_arrStyles
CXTPTagCloudStyleArray m_arrStyles
Array of CXTPTagCloudStyle structs managed by CXTPTagCloudStyleManager.
Definition XTPTagCloudCtrl.h:235
CXTPTagCloudStyleManager::AddStyle
INT_PTR AddStyle(CXTPTagCloudStyle *pStyle)
Call this member function to add a new style to the style array.
CXTPTagCloudStyleManager::ScoreExists
BOOL ScoreExists(int nScore)
Call this member function to determine if the score specified by nScore already exists in the array.
CXTPTagCloudStyleManager::AddStyle
INT_PTR AddStyle(int nScore, COLORREF clrText, COLORREF clrTextHover, COLORREF clrBorder, LOGFONT &lf)
Call this member function to add a new style to the style array.
CXTPTagCloudStyleManager::RemoveStyle
BOOL RemoveStyle(int nScore)
Call this member function to remove an existing style from the style array.
CXTPTagCloudStyleManager::GetStyle
CXTPTagCloudStyle * GetStyle(int nScore)
Call this member function to retrieve the style associated with the identifier specified by nScore.
CXTPTagCloudStyleManager::GetCloudStyleArray
CXTPTagCloudStyleArray & GetCloudStyleArray()
Call this member function to retrieve a reference to the CXTPTagCloudStyleArray managed by CXTPTagClo...
CXTPTagCloudTagArray
CXTPTagCloudTagArray is a CArray derived class used to manage XTP_TAGCLOUDTAG objects for the CXTPTag...
Definition XTPTagCloudCtrl.h:322
CXTPTagCloudTagArray::Sort
void Sort(XTPTagCloudSort nSort, BOOL bAsc)
Call this member function to sort the tag item array by the style specified by nSort.
CXTPWinThemeWrapper
The CXTPWinThemeWrapper class wraps the UxTheme.dll visual theme API.
Definition XTPWinThemeWrapper.h:188
XTP_TAGCLOUDTAG
Manages the attributes for each tag element such as weight, font, background and foreground color.
Definition XTPTagCloudCtrl.h:286
XTP_TAGCLOUDTAG::strItem
CString strItem
String value representing the tag text.
Definition XTPTagCloudCtrl.h:300
XTP_TAGCLOUDTAG::nScore
int nScore
Style for this tag.
Definition XTPTagCloudCtrl.h:299
XTP_TAGCLOUDTAG::rcItem
CXTPEmptyRect rcItem
Size and location of the tag.
Definition XTPTagCloudCtrl.h:301
XTP_TAGCLOUDTAG::XTP_TAGCLOUDTAG
XTP_TAGCLOUDTAG(LPCTSTR lpszItem, int nScore)
Default constructor initializes members.
Definition XTPTagCloudCtrl.h:293


Toolkit Pro: XTPCalendarMemoryDataProvider.h Source File

  • Source
  • Calendar
XTPCalendarMemoryDataProvider.h
Go to the documentation of this file.
1
22#if !defined(_XTPCALENDARMEMORYDATAPROVIDER_H__)
23# define _XTPCALENDARMEMORYDATAPROVIDER_H__
24
25# if _MSC_VER > 1000
26# pragma once
27# endif // _MSC_VER > 1000
28
29# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
30
32class CXTPCalendarEvent;
33class CXTPCalendarRecurrencePattern;
34
44# define XTP_EVENTS_STORAGE_HASH_TABLE_SIZE 4001
45
72class _XTP_EXT_CLASS CXTPCalendarMemoryDataProvider : public CXTPCalendarData
73{
75 DECLARE_DYNAMIC(CXTPCalendarMemoryDataProvider)
77public:
89 CXTPCalendarMemoryDataProvider();
90
98 virtual ~CXTPCalendarMemoryDataProvider();
99
108 virtual BOOL Open();
109
120 virtual BOOL Create();
121
132 virtual BOOL Save();
133
138 virtual void Close();
139
151 virtual CXTPCalendarEventsPtr RetrieveEvents(COleDateTime dtStartDay, COleDateTime dtEndDay);
152
172 virtual void Serialize(CArchive& ar);
173
193 virtual void DoPropExchange(CXTPPropExchange* pPX);
194
195protected:
214 virtual BOOL _Load(CXTPPropExchange* pPX);
215
232 virtual BOOL _Save(CXTPPropExchange* pPX);
233
248 virtual CXTPCalendarEventsPtr DoRetrieveDayEvents(COleDateTime dtDay);
249
257 virtual void DoRemoveAllEvents();
258
271 virtual CXTPCalendarEventPtr DoRead_Event(DWORD dwEventID);
272
285 virtual CXTPCalendarRecurrencePatternPtr DoRead_RPattern(DWORD dwPatternID);
286
302 virtual BOOL DoCreate_Event(CXTPCalendarEvent* pEvent, DWORD& rdwNewEventID);
303
318 virtual BOOL DoUpdate_Event(CXTPCalendarEvent* pEvent);
319
334 virtual BOOL DoDelete_Event(CXTPCalendarEvent* pEvent);
335
351 virtual BOOL DoCreate_RPattern(CXTPCalendarRecurrencePattern* pPattern, DWORD& rdwNewPatternID);
352
366 virtual BOOL DoUpdate_RPattern(CXTPCalendarRecurrencePattern* pPattern);
367
382 virtual BOOL DoDelete_RPattern(CXTPCalendarRecurrencePattern* pPattern);
383
399 virtual CXTPCalendarEventsPtr DoGetAllEvents_raw();
400
419 virtual CXTPCalendarEventsPtr DoGetUpcomingEvents(COleDateTime dtFrom,
420 COleDateTimeSpan spPeriod);
421
437 virtual BOOL OnTimeZoneChanged()
438 {
439 return TRUE;
440 };
441
442private:
443 typedef CMap<DWORD, DWORD, CXTPCalendarEvent*, CXTPCalendarEvent*> CMapIDtoEvent;
444
445 struct DSTNode
446 {
447 DSTNode();
448 ~DSTNode();
449
450 DSTNode* pLeft;
451 DSTNode* pRight;
452
453 void Mark(CXTPCalendarEvent* pEvent);
454 void Unmark(CXTPCalendarEvent* pEvent);
455 BOOL IsMarked(CXTPCalendarEvent* pEvent);
456
457 void AppendAll(CMapIDtoEvent* pMapEvents);
458
459 private:
460 typedef CMap<CXTPCalendarEvent*, CXTPCalendarEvent*, BOOL, BOOL> EventsMap;
461 EventsMap* m_pMapEvents;
462 };
463
464 struct DST
465 {
466 DST();
467 ~DST();
468
469 void Insert(CXTPCalendarEvent* pEvent);
470 void Remove(CXTPCalendarEvent* pEvent);
471
472 void Clear();
473
474 void SearchForEvents(DWORD dwStart, DWORD dwEnd, CXTPCalendarEvents* pEvents);
475
476 private:
477 DSTNode* pHead;
479 CMapIDtoEvent tmp_mapEvents;
481 private:
482 enum DSTScanType
483 {
484 dstScanMark,
485 dstScanUnmark,
486 dstScanFind
487 };
488
489 void ScanRange(DSTNode* const pNode, const int nDepth, const DWORD dwMinValue,
490 const DWORD dwMaxValue, const DWORD dwStart, const DWORD dwEnd,
491 CXTPCalendarEvent* const pEvent, CMapIDtoEvent* pMapEvents,
492 const DSTScanType eScanType);
494 void MarkRange(CXTPCalendarEvent* pEvent, const DSTScanType eScanType);
495 };
496
497private:
498 BOOL IsProviderXML(BOOL bCheckXMLsupport, BOOL* pbXMLsupportError = NULL);
499 CString GetXMLEncoding();
500
501 DWORD _UniqueID_Event(DWORD dwID);
502 DWORD _UniqueID_Patern(DWORD dwID);
503
504private:
505 EventsMapByID_T<CXTPCalendarEvent> m_EventsStorage;
506 EventsMapByID_T<CXTPCalendarRecurrencePattern> m_mapPatterns;
507
508 DST m_tree;
509
510 //------------------------------------------------------------
511 // CMap<DWORD, DWORD, BOOL, BOOL> m_mapIsDayInCache;
512};
513
514# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
515#endif // !defined(_XTPCALENDARMEMORYDATAPROVIDER_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCalendarData
This class defines an abstract representation of the Calendar control data with all necessary methods...
Definition XTPCalendarData.h:97
CXTPCalendarEvent
This class represents the data of a single Event used in the Calendar control.
Definition XTPCalendarEvent.h:77
CXTPCalendarEvents
This class represents a simple array collection of CXTPCalendarEvent objects.
Definition XTPCalendarEvents.h:55
CXTPCalendarMemoryDataProvider
This class implements an abstract representation of the data used in the XTPCalendarData class.
Definition XTPCalendarMemoryDataProvider.h:73
CXTPCalendarMemoryDataProvider::DoPropExchange
virtual void DoPropExchange(CXTPPropExchange *pPX)
This method reads data from or writes data to storage.
CXTPCalendarMemoryDataProvider::~CXTPCalendarMemoryDataProvider
virtual ~CXTPCalendarMemoryDataProvider()
Default Destructor.
CXTPCalendarMemoryDataProvider::RetrieveEvents
virtual CXTPCalendarEventsPtr RetrieveEvents(COleDateTime dtStartDay, COleDateTime dtEndDay)
Call this member function to get a collection of events for the specified date range.
CXTPCalendarMemoryDataProvider::DoRead_Event
virtual CXTPCalendarEventPtr DoRead_Event(DWORD dwEventID)
Read event from the memory storage.
CXTPCalendarMemoryDataProvider::DoRead_RPattern
virtual CXTPCalendarRecurrencePatternPtr DoRead_RPattern(DWORD dwPatternID)
Read recurrence pattern from the memory storage.
CXTPCalendarMemoryDataProvider::_Save
virtual BOOL _Save(CXTPPropExchange *pPX)
This method writes data to an archive.
CXTPCalendarMemoryDataProvider::CXTPCalendarMemoryDataProvider
CXTPCalendarMemoryDataProvider()
Default constructor.
CXTPCalendarMemoryDataProvider::DoCreate_RPattern
virtual BOOL DoCreate_RPattern(CXTPCalendarRecurrencePattern *pPattern, DWORD &rdwNewPatternID)
Creates a new recurrence pattern in the memory storage.
CXTPCalendarMemoryDataProvider::DoDelete_Event
virtual BOOL DoDelete_Event(CXTPCalendarEvent *pEvent)
Deletes an event from the memory storage.
CXTPCalendarMemoryDataProvider::DoUpdate_RPattern
virtual BOOL DoUpdate_RPattern(CXTPCalendarRecurrencePattern *pPattern)
Updates a recurrence pattern in the memory storage.
CXTPCalendarMemoryDataProvider::DoCreate_Event
virtual BOOL DoCreate_Event(CXTPCalendarEvent *pEvent, DWORD &rdwNewEventID)
Creates a new event in the memory storage.
CXTPCalendarMemoryDataProvider::DoGetUpcomingEvents
virtual CXTPCalendarEventsPtr DoGetUpcomingEvents(COleDateTime dtFrom, COleDateTimeSpan spPeriod)
Retrieves a collection of events expiring in the period from dtFrom during next spPeriod.
CXTPCalendarMemoryDataProvider::DoDelete_RPattern
virtual BOOL DoDelete_RPattern(CXTPCalendarRecurrencePattern *pPattern)
Deletes a recurrence pattern from the memory storage.
CXTPCalendarMemoryDataProvider::DoUpdate_Event
virtual BOOL DoUpdate_Event(CXTPCalendarEvent *pEvent)
Updates event properties in the memory storage.
CXTPCalendarMemoryDataProvider::Serialize
virtual void Serialize(CArchive &ar)
This method reads data from or writes data to an archive.
CXTPCalendarMemoryDataProvider::OnTimeZoneChanged
virtual BOOL OnTimeZoneChanged()
This method is called by the calendar control framework when the Time Zone is Changed.
Definition XTPCalendarMemoryDataProvider.h:437
CXTPCalendarMemoryDataProvider::Save
virtual BOOL Save()
This method saves data to the file.
CXTPCalendarMemoryDataProvider::Close
virtual void Close()
Call this member function to close the connection to a data source.
CXTPCalendarMemoryDataProvider::Create
virtual BOOL Create()
Call this member function to create a file for storing memory data provider data.
CXTPCalendarMemoryDataProvider::DoRemoveAllEvents
virtual void DoRemoveAllEvents()
Removes all events from the memory storage.
CXTPCalendarMemoryDataProvider::_Load
virtual BOOL _Load(CXTPPropExchange *pPX)
This method reads data from an archive.
CXTPCalendarMemoryDataProvider::DoRetrieveDayEvents
virtual CXTPCalendarEventsPtr DoRetrieveDayEvents(COleDateTime dtDay)
Retrieves day events for a specified day from the memory storage.
CXTPCalendarMemoryDataProvider::Open
virtual BOOL Open()
Call this member function to initialize a newly constructed Data object.
CXTPCalendarMemoryDataProvider::DoGetAllEvents_raw
virtual CXTPCalendarEventsPtr DoGetAllEvents_raw()
This method implements getting all events from the memory storage without generating recurrence occur...
CXTPCalendarRecurrencePattern
This class represents a recurrence pattern and stores data to build a schedule for recurrence events.
Definition XTPCalendarRecurrencePattern.h:398
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72


Toolkit Pro: Member List

CXTPChartBarSeriesPointView Member List

This is the complete list of members for CXTPChartBarSeriesPointView, including all inherited members.

AddChildView(CXTPChartElementView *pChildView) | CXTPChartElementView |
CreateDeviceCommand(CXTPChartDeviceContext *pDC) | CXTPChartBarSeriesPointView | virtual
CreateLegendDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcBounds) | CXTPChartBarSeriesPointView | virtual
CXTPChartBarSeriesPointView(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView) | CXTPChartBarSeriesPointView |
CXTPChartElementView(CXTPChartElementView *pParentView) | CXTPChartElementView |
CXTPChartElementView(CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartElementView |
CXTPChartElementView(CXTPChartContainer *pContainer) | CXTPChartElementView |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartSeriesPointView(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView) | CXTPChartSeriesPointView |
CXTPChartSeriesPointView(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartSeriesPointView |
GetAt(int nIndex) const | CXTPChartElementView |
GetBounds() const | CXTPChartElementView |
GetBounds(BOOL bIncludingChildren) const | CXTPChartElementView |
GetChildren() | CXTPChartElementView |
GetColor() const | CXTPChartSeriesPointView |
GetColor2() const | CXTPChartSeriesPointView |
GetCount() const | CXTPChartElementView |
GetInternalValue() const | CXTPChartSeriesPointView |
GetLegendName() const | CXTPChartSeriesPointView | virtual
GetParentView() const | CXTPChartElementView |
GetPoint() const | CXTPChartSeriesPointView |
GetSeriesView() const | CXTPChartSeriesPointView |
Is3D() const | CXTPChartObject |
m_arrChildren | CXTPChartElementView | protected
m_dInternalValue | CXTPChartSeriesPointView |
m_pContainer | CXTPChartElementView | protected
m_pParentView | CXTPChartElementView | protected
m_pPoint | CXTPChartSeriesPointView | protected
m_rcBounds | CXTPChartElementView | protected
UpdateMinMaxRange(double &nMinValue, double &nMaxValue) const | CXTPChartSeriesPointView | virtual
~CXTPChartElementView() | CXTPChartElementView | protectedvirtual
~CXTPChartLegendItemView() | CXTPChartLegendItemView | inlinevirtual


Toolkit Pro: Member List

CXTPChartBoundedPolygonDeviceCommand Member List

This is the complete list of members for CXTPChartBoundedPolygonDeviceCommand, including all inherited members.

AddChildCommand(CXTPChartDeviceCommand *pCommand) | CXTPChartDeviceCommand |
AfterExecute(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
ApplySeriesStyle(CXTPChartSeriesStyle *pStyle) | CXTPChartDeviceCommand | virtual
BeforeExecute(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
BindView(CXTPChartElementView *pView) | CXTPChartDeviceCommand |
Commit() | CXTPChartDeviceCommand |
CXTPChartBoundedPolygonDeviceCommand(const CXTPChartPoints &points, const CXTPChartColor &color, int thickness) | CXTPChartBoundedPolygonDeviceCommand |
CXTPChartDeviceCommand() | CXTPChartDeviceCommand |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPObservable() | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | protected
Execute(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
ExecuteOverride(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
GetBoundView() const | CXTPChartDeviceCommand |
GetChildCommand(int nIndex) const | CXTPChartDeviceCommand |
GetChildCommandCount() const | CXTPChartDeviceCommand |
GetCurrentDC() const | CXTPChartDeviceCommand |
GetPassNumber() const | CXTPChartDeviceCommand |
HitTest(CPoint point, CXTPChartElement *pParent) const | CXTPChartDeviceCommand | virtual
Is3D() const | CXTPChartObject |
IsCommitted() const | CXTPChartDeviceCommand |
IsEnabled() const | CXTPChartDeviceCommand | virtual
m_arrChildren | CXTPChartDeviceCommand | protected
m_color | CXTPChartBoundedPolygonDeviceCommand | protected
m_points | CXTPChartBoundedPolygonDeviceCommand | protected
m_thickness | CXTPChartBoundedPolygonDeviceCommand | protected
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Prepare(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
PrepareOverride(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
SetEnabled(BOOL bEnabled=TRUE) | CXTPChartDeviceCommand |
Subscribe(CXTPChartDeviceCommandEvents *pObserver, CXTPSubscriptionList< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > *pSubcriptionList=NULL) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > |
Unsubscribe(CXTPChartDeviceCommandEvents *pObserver) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > |
~CXTPChartDeviceCommand() | CXTPChartDeviceCommand | virtual
~CXTPObservable() | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | protected


Toolkit Pro: XTPMarkupComboBox.h Source File

  • Source
  • Controls
  • Combo
XTPMarkupComboBox.h
Go to the documentation of this file.
1
23#if !defined(__XTPMARKUPCOMBOBOX_H__) && defined(_XTP_INCLUDE_MARKUP)
24# define __XTPMARKUPCOMBOBOX_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPMarkupUIElement;
34class CXTPMarkupContext;
35
36struct _XTP_EXT_CLASS XTP_MARKUP_COMBOBOXITEM
37{
38public:
39 XTP_MARKUP_COMBOBOXITEM(CXTPMarkupContext* pContext);
40
41 virtual ~XTP_MARKUP_COMBOBOXITEM();
42
43public:
44 void Resolve(LPCTSTR lpszMarkup);
45
46 CString strMarkup;
47 CXTPMarkupUIElement* pItem;
48 CXTPMarkupContext* pContext;
49};
50
51class _XTP_EXT_CLASS CXTPMarkupComboBox
52 : public CXTPComboBox
53 , public CXTPMarkupContext
54{
56 DECLARE_DYNAMIC(CXTPMarkupComboBox)
58public:
63 CXTPMarkupComboBox();
64
69 virtual ~CXTPMarkupComboBox();
70
73 //{{AFX_VIRTUAL(CXTPMarkupComboBox)
74 virtual void DrawItem(LPDRAWITEMSTRUCT lpDrawItemStruct);
75 virtual void MeasureItem(LPMEASUREITEMSTRUCT lpMeasureItemStruct);
76 virtual void DeleteItem(LPDELETEITEMSTRUCT lpDeleteItemStruct);
77 virtual BOOL OnWndMsg(UINT message, WPARAM wParam, LPARAM lParam, LRESULT* pResult);
78 using CXTPMarkupContext::OnWndMsg;
79 //}}AFX_VIRTUAL
80
81public:
82 CXTPMarkupContext* GetMarkupContext()
83 {
84 return this;
85 }
86
87 void Init();
88
89 void AddMarkupString(LPCTSTR lpszMarkup);
90
91 //{{AFX_MSG(CXTPMarkupComboBox)
92 //}}AFX_MSG
93
94 DECLARE_MESSAGE_MAP()
95
96
97};
98
100
101# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
103#endif // !defined(__XTPMARKUPCOMBOBOX_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPComboBox
The CXTPComboBox class provides the functionality of a themed Windows combobox.
Definition XTPComboBox.h:42
CXTPMarkupContext
CXTPMarkupContext is a standalone class used to provide common settings for Markup objects.
Definition XTPMarkupContext.h:128
CXTPMarkupUIElement
Base class for XML Markup core level implementations.
Definition XTPMarkupUIElement.h:43


Toolkit Pro: Member List

CXTPGridControl Member List

This is the complete list of members for CXTPGridControl, including all inherited members.

AddColumn(CXTPGridColumn *pColumn) | CXTPGridControl |
AddRecord(CXTPGridRecord *pRecord) | CXTPGridControl | virtual
AddRecordEx(CXTPGridRecord *pRecord, CXTPGridRecord *pParentRecord=NULL, int nRowChildIndex=-1, int nRecordChildIndex=-1) | CXTPGridControl | virtual
AdjustIndentation() | CXTPGridControl | protected
AdjustLayout() | CXTPGridControl | virtual
AdjustScrollBars() | CXTPGridControl | virtual
ApplyFilter(CXTPGridRecord *pRecord, CString strFilterText, BOOL bIncludePreview) | CXTPGridControl | protectedvirtual
AssignIconViewPropNumAndIconNum(int nCol=0, int nIcon=0, BOOL bUseColumnForNum=FALSE, int nWidth=20) | CXTPGridControl |
BeginUpdate() | CXTPGridControl |
CanCopy() | CXTPGridControl | virtual
CanCut() | CXTPGridControl | virtual
CanPaste() | CXTPGridControl | virtual
CollapseAll() | CXTPGridControl |
Copy() | CXTPGridControl | virtual
Create(DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID, CCreateContext *pContext=NULL) | CXTPGridControl |
CreateGroupRow() | CXTPGridControl | protectedvirtual
CreateHeaderFooterRow() | CXTPGridControl | protectedvirtual
CreateIconColumn(BOOL bUseColumnForNum=FALSE, int nWidth=40) | CXTPGridControl |
CreateRow() | CXTPGridControl | protectedvirtual
Cut() | CXTPGridControl | virtual
CXTPGridControl() | CXTPGridControl |
DoAutoVertScrollIfNeed(CPoint ptClick, CPoint pt) | CXTPGridControl | protectedvirtual
DoPropExchange(CXTPPropExchange *pPX) | CXTPGridControl | virtual
DrawNoItems(CDC *pDC, const CRect &rcClient) | CXTPGridControl | protectedvirtual
DrawRows(CDC *pDC, CRect &rcClient, int y, CXTPGridRows *pRows, int nTopRow, int nColumnFrom, int nColumnTo, int *pnHeight=NULL) | CXTPGridControl | protectedvirtual
DrawWatermark(CDC *pDC, CRect rcWatermark, CRect rcClient) | CXTPGridControl |
EditItem(XTP_GRIDRECORDITEM_ARGS *pItemArgs) | CXTPGridControl |
EditOnClick(BOOL bEditOnClick) | CXTPGridControl |
EditOnDelayClick(BOOL bEditOnDelayClick) | CXTPGridControl |
EditOnDoubleClick(BOOL bEditOnClick) | CXTPGridControl |
EnableDoubleBuffering(BOOL bEnable) | CXTPGridControl |
EnableDragDrop(LPCTSTR lpszClipboardFormat, DWORD dwFlags, DWORD dwDropMarkerFlags=xtpGridDropBetween) | CXTPGridControl |
EnableMarkup(BOOL bEnable=TRUE) | CXTPGridControl |
EnablePreviewMode(BOOL bIsPreviewMode) | CXTPGridControl |
EnableToolTips(BOOL bEnable) | CXTPGridControl |
EndUpdate() | CXTPGridControl |
EnsureFocusedRowVisible(BOOL bEnsureFocusedRowVisible) | CXTPGridControl |
EnsureStartAutoVertScroll() | CXTPGridControl | protectedvirtual
EnsureStopAutoVertScroll() | CXTPGridControl | protectedvirtual
EnsureStopDelayEditTimer() | CXTPGridControl |
EnsureStopLastRqstTimer() | CXTPGridControl |
EnsureVisible(CXTPGridRow *pRow) | CXTPGridControl |
EnsureVisible(CXTPGridColumn *pCheckColumn) | CXTPGridControl |
ExpandAll(BOOL bRecursive=FALSE) | CXTPGridControl |
FocusSubItems(BOOL bFocusSubItems) | CXTPGridControl |
FreeRowBatchExtraData() | CXTPGridControl | static
GetActiveItem() const | CXTPGridControl |
GetAutoVScrollTimerResolution() const | CXTPGridControl |
GetColumns() const | CXTPGridControl |
GetDataManager() | CXTPGridControl |
GetDelayEditTimer() const | CXTPGridControl |
GetDisableReorderColumnsCount() const | CXTPGridControl |
GetDragSensitivityX() const | CXTPGridControl |
GetDragSensitivityY() const | CXTPGridControl |
GetDropMarkerFlags() const | CXTPGridControl |
GetElementRect(XTPGridElementRect nElement) const | CXTPGridControl |
GetFilterText() | CXTPGridControl | virtual
GetFocusedColumn() const | CXTPGridControl |
GetFocusedRecordItem() const | CXTPGridControl |
GetFocusedRow() const | CXTPGridControl |
GetFreezeColumnsCount() const | CXTPGridControl |
GetFreezeColumnsCount(int &nLastIndex) const | CXTPGridControl |
GetFreezeColumnsIndex() const | CXTPGridControl |
GetGridAreaRows(int nStartRow, BOOL bMoveDown) | CXTPGridControl |
GetGridHeader() const | CXTPGridControl |
GetGridStyle(XTPGridOrientation orientation) const | CXTPGridControl |
GetHeaderIndent() const | CXTPGridControl |
GetHScrollStep() const | CXTPGridControl |
GetImageManager() const | CXTPGridControl |
GetIndent(int nLevel) const | CXTPGridControl |
GetInplaceButtons() const | CXTPGridControl |
GetInplaceEdit() const | CXTPGridControl |
GetInplaceList() const | CXTPGridControl |
GetItemMetrics(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pItemMetrics) | CXTPGridControl | protectedvirtual
GetLastRqstEditCol() const | CXTPGridControl |
GetLastRqstEditRow() const | CXTPGridControl |
GetLeftOffset() const | CXTPGridControl |
GetLockUpdateCount() const | CXTPGridControl |
GetMarkupContext() const | CXTPGridControl |
GetMouseMode() const | CXTPGridControl |
GetMouseScrollLines() | CXTPGridControl | protectedstatic
GetNavigator() const | CXTPGridControl |
GetNextFocusableColumn(CXTPGridRow *pRow, int nColumnIndex, int nDirection) | CXTPGridControl | virtual
GetNumRowsOnLine(int iTotalWidth) const | CXTPGridControl |
GetPaintManager() const | CXTPGridControl |
GetRecordsTreeFilterMode() const | CXTPGridControl |
GetRowsHeight(CXTPGridRows *pRows, int nTotalWidth, int nMaxHeight=-1) | CXTPGridControl | protectedvirtual
GetRowsPerLine() const | CXTPGridControl |
GetScrollMode(XTPGridOrientation orientation) const | CXTPGridControl |
GetSections() const | CXTPGridControl |
GetSelectedRows() const | CXTPGridControl |
GetToolTipContext() const | CXTPGridControl |
GetTopRowIndex() const | CXTPGridControl |
GetWatermarkAlignment() const | CXTPGridControl |
GetWatermarkBitmap() const | CXTPGridControl | virtual
HasFocus() const | CXTPGridControl |
HitTest(CPoint pt, CXTPGridHitTestInfo *pInfo) const | CXTPGridControl | virtual
HitTest(CPoint pt) const | CXTPGridControl |
InitialSelectionEnable(BOOL bEnable) | CXTPGridControl |
InsertRow(int nIndex, CXTPGridRow *pRow) | CXTPGridControl | protectedvirtual
IsAutoCheckItems() const | CXTPGridControl |
IsCellMergingAllowed() const | CXTPGridControl | virtual
IsChanged() const | CXTPGridControl | protected
IsDoubleBuffering() const | CXTPGridControl |
IsDragMode() const | CXTPGridControl |
IsEditMode() | CXTPGridControl | virtual
IsEditOnClick() const | CXTPGridControl |
IsEditOnDelayClick() const | CXTPGridControl |
IsEditOnDoubleClick() const | CXTPGridControl |
IsEnsureFocusedRowVisible() const | CXTPGridControl |
IsFilterHiddenColumns() const | CXTPGridControl | virtual
IsFocusSubItems() const | CXTPGridControl |
IsFooterRowsPinned() const | CXTPGridControl |
IsFooterRowsPinnedPrinted() const | CXTPGridControl |
IsFooterVisible() const | CXTPGridControl |
IsFullColumnScrolling() const | CXTPGridControl |
IsGroupByVisible() const | CXTPGridControl |
IsGroupRowsBold() const | CXTPGridControl |
IsHeaderVisible() const | CXTPGridControl |
IsIconView() const | CXTPGridControl |
IsInitialSelectionEnabled() const | CXTPGridControl |
IsLayoutRTL() | CXTPGridControl |
IsLockExpand() const | CXTPGridControl |
IsMultipleSelection() const | CXTPGridControl |
IsMultiSelectionMode() const | CXTPGridControl |
IsPreviewAllowEdit() const | CXTPGridControl |
IsPreviewMode() const | CXTPGridControl |
IsRowFocusVisible() const | CXTPGridControl |
IsShadeGroupHeadingsEnabled() const | CXTPGridControl |
IsShowIconWhenEditing() | CXTPGridControl |
IsShowRowNumber() | CXTPGridControl |
IsSkipGroupsFocusEnabled() const | CXTPGridControl |
IsSortRecordChilds() const | CXTPGridControl |
IsVirtualMode() const | CXTPGridControl |
LockExpand(BOOL bLockExpand) | CXTPGridControl |
m_bAdjustLayoutRunning | CXTPGridControl | protected
m_bAutoCheckItems | CXTPGridControl | protected
m_bBlockSelection | CXTPGridControl | protected
m_bChanged | CXTPGridControl | protected
m_bCreated | CXTPGridControl | protected
m_bDesktopTrackerMode | CXTPGridControl |
m_bDoubleBuffering | CXTPGridControl | protected
m_bDragMode | CXTPGridControl | protected
m_bEditOnClick | CXTPGridControl | protected
m_bEditOnDelayClick | CXTPGridControl | protected
m_bEditOnDoubleClick | CXTPGridControl | protected
m_bEnsureFocusedRowVisible | CXTPGridControl | protected
m_bFastDeselectMode | CXTPGridControl | protected
m_bFilterHiddenColumns | CXTPGridControl | protected
m_bFocusSubItems | CXTPGridControl | protected
m_bFooterVisible | CXTPGridControl | protected
m_bForcePagination | CXTPGridControl |
m_bFreeHeightMode | CXTPGridControl |
m_bGroupByEnabled | CXTPGridControl | protected
m_bHeaderVisible | CXTPGridControl | protected
m_bHScrollBarVisible | CXTPGridControl | protected
m_bIconColumnIndexNotValid | CXTPGridControl |
m_bIconView | CXTPGridControl | protected
m_bInitialSelectionEnable | CXTPGridControl | protected
m_bInternalDrag | CXTPGridControl | protected
m_bInternalMove | CXTPGridControl | protected
m_bKeepSelectionAfterSort | CXTPGridControl |
m_bLockExpand | CXTPGridControl | protected
m_bMarkupEnabled | CXTPGridControl |
m_bMovePivot | CXTPGridControl |
m_bmpCache | CXTPGridControl | protected
m_bMultiSelectionMode | CXTPGridControl | protected
m_bmWatermark | CXTPGridControl | protected
m_bNoNeedSortedDragDrop | CXTPGridControl | protected
m_bPinFooterRows | CXTPGridControl | protected
m_bPinFooterRowsPrinted | CXTPGridControl | protected
m_bPrepareDrag | CXTPGridControl | protected
m_bPrevFocusSubItems | CXTPGridControl | protected
m_bPrevFooterRows | CXTPGridControl | protected
m_bPrevFooterShow | CXTPGridControl | protected
m_bPrevHeaderAutoSize | CXTPGridControl | protected
m_bPrevHeaderRows | CXTPGridControl | protected
m_bPrevHeaderShow | CXTPGridControl | protected
m_bPreviewAllowEdit | CXTPGridControl | protected
m_bPrevPreviewMode | CXTPGridControl | protected
m_bRClickDrag | CXTPGridControl |
m_bRelayWndMsg | CXTPGridControl | protected
m_bRowFocusVisible | CXTPGridControl | protected
m_bSelectionExcludeGroupRows | CXTPGridControl |
m_bShowIconWhenEditing | CXTPGridControl | protected
m_bShowTooltips | CXTPGridControl | protected
m_bSkipGroupsFocus | CXTPGridControl | protected
m_bSortedDragDrop | CXTPGridControl |
m_bSortRecordChilds | CXTPGridControl | protected
m_bStrictBestFit | CXTPGridControl |
m_bStrictFiltering | CXTPGridControl |
m_bThemeMetrics | CXTPGridControl |
m_bTrapTabKey | CXTPGridControl |
m_bUnrestrictedDragDrop | CXTPGridControl |
m_bVScrollBarVisible | CXTPGridControl | protected
m_bWasShiftKey | CXTPGridControl |
m_cfGrid | CXTPGridControl | protected
m_dwDragDropFlags | CXTPGridControl | protected
m_dwDropMarkerFlags | CXTPGridControl | protected
m_hbmpWatermark | CXTPGridControl | protected
m_iColumnForNum | CXTPGridControl |
m_iIconHeight | CXTPGridControl |
m_iIconHeightSpacing | CXTPGridControl |
m_iIconNum | CXTPGridControl |
m_iIconPropNum | CXTPGridControl |
m_iIconViewColumn | CXTPGridControl |
m_iIconViewRowsPerLine | CXTPGridControl | protected
m_iIconWidth | CXTPGridControl |
m_iIconWidthSpacing | CXTPGridControl |
m_iLastRqstEditCol | CXTPGridControl | protected
m_iLastRqstEditRow | CXTPGridControl | protected
m_mouseDownState | CXTPGridControl |
m_mouseMode | CXTPGridControl | protected
m_nAutoVScrollTimerResolution | CXTPGridControl | protected
m_nDefaultRowFreeHeight | CXTPGridControl |
m_nDisableReorderColumnsCount | CXTPGridControl | protected
m_nDragSensitivityX | CXTPGridControl | protected
m_nDragSensitivityY | CXTPGridControl | protected
m_nDropPos | CXTPGridControl | protected
m_nEnsureVisibleColumnIdx | CXTPGridControl | protected
m_nEnsureVisibleRowIdx | CXTPGridControl | protected
m_nLockUpdateCount | CXTPGridControl | protected
m_nPrevTreeIndent | CXTPGridControl | protected
m_nRecordsTreeFilterMode | CXTPGridControl | protected
m_nRowsPerWheel | CXTPGridControl | protected
m_nScrollOffsetH | CXTPGridControl | protected
m_nScrollStepH | CXTPGridControl | protected
m_nScrollStepV | CXTPGridControl | protected
m_pActiveItem | CXTPGridControl | protected
m_pColumns | CXTPGridControl | protected
m_pDataManager | CXTPGridControl | protected
m_pDropRecords | CXTPGridControl | protected
m_pDropTarget | CXTPGridControl | protected
m_pFocusedColumn | CXTPGridControl | protected
m_pGridHeader | CXTPGridControl | protected
m_pHotExpandButtonRow | CXTPGridControl |
m_pHotHyperlink | CXTPGridControl |
m_pHotRow | CXTPGridControl | protected
m_pImageManager | CXTPGridControl | protected
m_pInplaceButtons | CXTPGridControl | protected
m_pInplaceEdit | CXTPGridControl | protected
m_pInplaceList | CXTPGridControl | protected
m_pMarkupContext | CXTPGridControl | protected
m_pNavigator | CXTPGridControl | protected
m_pPaintManager | CXTPGridControl | protected
m_pPrevGroupsOrder | CXTPGridControl | protected
m_pPrevVisible | CXTPGridControl | protected
m_pRows | CXTPGridControl | protected
m_pRowsCompareFunc | CXTPGridControl | protected
m_pSelectedRows | CXTPGridControl | protected
m_pSelectedRowsBeforeDrag | CXTPGridControl | protected
m_ptDrag | CXTPGridControl | protected
m_pTip | CXTPGridControl | protected
m_pToolTipContext | CXTPGridControl | protected
m_ptrVirtualEditingRow | CXTPGridControl | protected
m_rcFooterArea | CXTPGridControl | protected
m_rcGroupByArea | CXTPGridControl | protected
m_rcHeaderArea | CXTPGridControl | protected
m_scrollModeH | CXTPGridControl | protected
m_scrollModeV | CXTPGridControl | protected
m_scrollUpdateMode | CXTPGridControl | protected
m_sCustomTitle | CXTPGridControl |
m_strFilterText | CXTPGridControl | protected
m_themeCurrent | CXTPGridControl | protected
m_uAutoScrollTimerID | CXTPGridControl | protected
m_uiDelayEditMaxTime | CXTPGridControl | protected
m_uiDelayEditTimer | CXTPGridControl | protected
m_uRqstEditTimer | CXTPGridControl | protected
m_WatermarkAlignment | CXTPGridControl | protected
m_WatermarkTransparency | CXTPGridControl | protected
OnBeforeCopyToText(CXTPGridRecord *pRecord, CStringArray &rarStrings) | CXTPGridControl | protectedvirtual
OnBeforePaste(CXTPGridRecord **ppRecord) | CXTPGridControl | protectedvirtual
OnBeforePasteFromText(CStringArray &arStrings, CXTPGridRecord **ppRecord) | CXTPGridControl | protectedvirtual
OnBeginDrag(CPoint point) | CXTPGridControl | protectedvirtual
OnBeginDrag(CPoint point, UINT nFlags) | CXTPGridControl | protectedvirtual
OnConstraintSelecting(CXTPGridRow *pRow, CXTPGridRecordItem *pItem, CXTPGridColumn *pColumn, CXTPGridRecordItemConstraint *pConstraint) | CXTPGridControl | protectedvirtual
OnDragOver(COleDataObject *pDataObject, DWORD dwKeyState, CPoint point, int nState) | CXTPGridControl | protectedvirtual
OnDraw(CDC *pDC) | CXTPGridControl | protectedvirtual
OnDrop(COleDataObject *pDataObject, DROPEFFECT dropEffect, CPoint point) | CXTPGridControl | protectedvirtual
OnFocusChanging(CXTPGridRow *pNewRow, CXTPGridColumn *pNewCol) | CXTPGridControl | protectedvirtual
OnGetColumnDataBestFitWidth(CXTPGridColumn *pColumn) | CXTPGridControl | protectedvirtual
OnGetItemsCaptionMaxWidth(CDC *pDC, CXTPGridRows *pRows, CXTPGridColumn *pColumn, int nStartRow=0, int nRowsCount=-1) | CXTPGridControl | protectedvirtual
OnGetToolTipInfo(CXTPGridRow *pRow, CXTPGridRecordItem *pItem, CString &rstrToolTipText) | CXTPGridControl | protectedvirtual
OnPreviewKeyDown(UINT &rnChar, UINT nRepCnt, UINT nFlags) | CXTPGridControl | protectedvirtual
OnSelectionChanged() | CXTPGridControl | protectedvirtual
Paste() | CXTPGridControl | virtual
PinFooterRows(BOOL bPin=FALSE) | CXTPGridControl |
PinFooterRowsPrinted(BOOL bPin=FALSE) | CXTPGridControl |
Populate() | CXTPGridControl | virtual
PopulateFooterRows() | CXTPGridControl | virtual
PopulateHeaderRows() | CXTPGridControl | virtual
PreviewAllowEdit(BOOL bAllowEdit) | CXTPGridControl |
Recalc(BOOL bAll=FALSE) | CXTPGridControl |
RedrawControl() | CXTPGridControl |
RegisterWindowClass(HINSTANCE hInstance=NULL) | CXTPGridControl |
RelayToolTipEvent(UINT message) | CXTPGridControl | protectedvirtual
ReleaseItem(int nIndex) | CXTPGridControl |
ReleaseSorted() | CXTPGridControl |
RemoveRecordEx(CXTPGridRecord *pRecord, BOOL bAdjustLayout=TRUE, BOOL bRemoveFromParent=TRUE) | CXTPGridControl | virtual
RemoveRowEx(CXTPGridRow *pRow, BOOL bAdjustLayout=TRUE) | CXTPGridControl | virtual
ResetContent(BOOL bUpdateControl=TRUE) | CXTPGridControl |
ReSortRows() | CXTPGridControl | protectedvirtual
SendMessageToParent(CXTPGridRow *pRow, CXTPGridRecordItem *pItem, CXTPGridColumn *pColumn, UINT nMessage, CPoint *pPoint, int nHyperlink=-1) const | CXTPGridControl |
SendNotifyMessage(UINT nMessage, NMHDR *pNMHDR=NULL) const | CXTPGridControl |
SerializeState(CArchive &ar) | CXTPGridControl | virtual
SetAutoCheckItems(BOOL bAutoCheck) | CXTPGridControl |
SetAutoVScrollTimerResolution(UINT nNewTimerResolution) | CXTPGridControl |
SetCellFormula(int row, int col, CString sFormula) | CXTPGridControl |
SetCellText(int row, int col, CString sText) | CXTPGridControl |
SetChanged(BOOL bChanged=TRUE) | CXTPGridControl | protected
SetDisableReorderColumnsCount(int nCount) | CXTPGridControl |
SetDragSensitivityX(int nDragSensitivityX) | CXTPGridControl |
SetDragSensitivityY(int nDragSensitivityY) | CXTPGridControl |
SetDropMarkerFlags(DWORD dwDropMarkerFlags) | CXTPGridControl |
SetFastDeselectMode(BOOL bFastDeselect=TRUE) | CXTPGridControl |
SetFilterHiddenColumns(BOOL bFilterHidden) | CXTPGridControl | virtual
SetFilterText(LPCTSTR strFilterText) | CXTPGridControl | virtual
SetFocusedColumn(CXTPGridColumn *pColumn) | CXTPGridControl |
SetFocusedRow(CXTPGridRow *pRow, BOOL bControlKey=FALSE) | CXTPGridControl |
SetFocusedRow(CXTPGridRow *pRow, BOOL bShiftKey, BOOL bControlKey) | CXTPGridControl |
SetFocusedRow(BOOL bEnsureVisible, CXTPGridRow *pRow, BOOL bShiftKey, BOOL bControlKey) | CXTPGridControl |
SetFreezeColumnsCount(int nCount, BOOL bReserved=FALSE) | CXTPGridControl |
SetFullColumnScrolling(BOOL bSet) | CXTPGridControl |
SetGridColor(COLORREF clrGridLine) | CXTPGridControl |
SetGridHeader(CXTPGridHeader *pGridHeader) | CXTPGridControl |
SetGridStyle(XTPGridOrientation orientation, XTPGridGridStyle gridStyle) | CXTPGridControl |
SetGroupRowsBold(BOOL bBold=TRUE) | CXTPGridControl |
SetHScrollStep(int nStep) | CXTPGridControl |
SetIconColumn(CXTPGridColumn *pColumn) | CXTPGridControl |
SetIconView(BOOL bIconView=TRUE) | CXTPGridControl |
SetIconViewToDefaults() | CXTPGridControl |
SetImageList(CImageList *pImageList) | CXTPGridControl |
SetImageManager(CXTPImageManager *pImageManager) | CXTPGridControl |
SetLastRqstEdit(int iRqstEditRow, int iRqstEditCol) | CXTPGridControl |
SetLayoutRTL(BOOL bRightToLeft) | CXTPGridControl |
SetMouseMode(XTPGridMouseMode nMode) | CXTPGridControl |
SetMultipleSelection(BOOL bMultipleSelection) | CXTPGridControl |
SetMultiSelectionMode(BOOL bMultiSelectionMode) | CXTPGridControl |
SetNavigator(CXTPGridNavigator *pNavigator) | CXTPGridControl |
SetPaintManager(CXTPGridPaintManager *pPaintManager) | CXTPGridControl |
SetRecordsTreeFilterMode(int nMode) | CXTPGridControl |
SetRowsCompareFunc(XTPGridRowsCompareFunc pCompareFunc) | CXTPGridControl | virtual
SetScrollMode(XTPGridOrientation orientation, XTPGridScrollMode scrollMode) | CXTPGridControl |
SetScrollOffsetH(int nOffset) | CXTPGridControl |
SetScrollOffsetV(int nOffset) | CXTPGridControl |
SetSelectionState(int index, int state) | CXTPGridControl |
SetSortRecordChilds(BOOL bSortRecordChildren) | CXTPGridControl |
SetTopRow(int nIndex) | CXTPGridControl |
SetTreeIndent(int nIndent) | CXTPGridControl |
SetVirtualMode(CXTPGridRecord *pVirtualRecord, int nCount, int nFields=0) | CXTPGridControl |
SetWatermarkAlignment(int nWatermarkAlignment) | CXTPGridControl |
SetWatermarkBitmap(HBITMAP hBitmap, BYTE Transparency) | CXTPGridControl | virtual
SetWatermarkBitmap(LPCTSTR szPath, BYTE Transparency) | CXTPGridControl | virtual
ShadeGroupHeadings(BOOL bEnable=TRUE) | CXTPGridControl |
ShowFooter(BOOL bShow=TRUE) | CXTPGridControl |
ShowGroupBy(BOOL bEnable=TRUE) | CXTPGridControl |
ShowHeader(BOOL bShow=TRUE) | CXTPGridControl |
ShowIconWhenEditing(BOOL bShow) | CXTPGridControl |
ShowRowFocus(BOOL bShow) | CXTPGridControl |
ShowRowNumber(BOOL bSet) | CXTPGridControl |
SkipGroupsFocus(BOOL bSkipFocus) | CXTPGridControl |
StartDelayEditTimer() | CXTPGridControl |
StartLastRqstTimer() | CXTPGridControl |
UnselectGroupRows() | CXTPGridControl |
UpdateRecord(CXTPGridRecord *pRecord, BOOL bUpdateChildren) | CXTPGridControl | virtual
UpdateSubList() | CXTPGridControl | protected
UseGridCustomHeap() | CXTPGridControl | static
UseRowBatchAllocation() | CXTPGridControl | static
~CXTPGridControl() | CXTPGridControl | virtual


Toolkit Pro: Member List

CXTPChartRadarAxisY Member List

This is the complete list of members for CXTPChartRadarAxisY, including all inherited members.

CalcSideMarginsValue(double nMinValue, double nMaxValue) const | CXTPChartRadarAxisY | virtual
CreateView(CXTPChartDeviceContext *pDC, CXTPChartElementView *pParentView) | CXTPChartRadarAxisY | protectedvirtual
CXTPChartAxis(CXTPChartDiagram *pDiagram) | CXTPChartAxis |
CXTPChartElement() | CXTPChartElement |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartRadarAxisY(CXTPChartRadarDiagram *pDiagram) | CXTPChartRadarAxisY |
DoPropExchange(CXTPPropExchange *pPX) | CXTPChartAxis | virtual
GetActualColor() const | CXTPChartAxis |
GetActualInterlacedColor() const | CXTPChartAxis |
GetActualInterlacedColor2() const | CXTPChartAxis |
GetAlignment() const | CXTPChartAxis |
GetAppearance() const | CXTPChartAxis |
GetColor() const | CXTPChartAxis |
GetConstantLines() const | CXTPChartAxis |
GetContent() const | CXTPChartElement |
GetCustomLabels() const | CXTPChartAxis |
GetDiagram() const | CXTPChartAxis |
GetGridLines() const | CXTPChartAxis |
GetGridSpacing() const | CXTPChartAxis |
GetIndex() const | CXTPChartAxis |
GetInterlacedColor() const | CXTPChartAxis |
GetInterlacedColor2() const | CXTPChartAxis |
GetInterlacedFillStyle() const | CXTPChartAxis |
GetLabel() const | CXTPChartAxis |
GetMinorCount() const | CXTPChartAxis |
GetOwner() const | CXTPChartElement |
GetRange() const | CXTPChartAxis |
GetScaleType() const | CXTPChartAxis |
GetScaleTypeMap() const | CXTPChartAxis |
GetStrips() const | CXTPChartAxis |
GetThickness() const | CXTPChartAxis |
GetTickMarks() const | CXTPChartAxis |
GetTitle() const | CXTPChartAxis |
Is3D() const | CXTPChartObject |
IsInterlaced() const | CXTPChartAxis |
IsReversed() const | CXTPChartAxis |
IsValuesAxis() const | CXTPChartRadarAxisY | virtual
IsVertical() const | CXTPChartRadarAxisY | virtual
IsVisible() const | CXTPChartAxis |
m_bGridSpacingAuto | CXTPChartAxis | protected
m_bInterlaced | CXTPChartAxis | protected
m_bLogarithmic | CXTPChartAxis | protected
m_bReversed | CXTPChartAxis | protected
m_bVisible | CXTPChartAxis | protected
m_clrColor | CXTPChartAxis | protected
m_clrInterlacedColor | CXTPChartAxis | protected
m_clrInterlacedColor2 | CXTPChartAxis | protected
m_dGridSpacing | CXTPChartAxis | protected
m_dLogarithmicBase | CXTPChartAxis | protected
m_nAlignment | CXTPChartAxis | protected
m_nMinorCount | CXTPChartAxis | protected
m_nScaleType | CXTPChartAxis | protected
m_nThickness | CXTPChartAxis | protected
m_pConstantLines | CXTPChartAxis | protected
m_pCustomLabels | CXTPChartAxis | protected
m_pDiagram | CXTPChartAxis | protected
m_pGridLines | CXTPChartAxis | protected
m_pInterlacedFillStyle | CXTPChartAxis | protected
m_pLabel | CXTPChartAxis | protected
m_pRange | CXTPChartAxis | protected
m_pScaleTypeMap | CXTPChartAxis | protected
m_pStrips | CXTPChartAxis | protected
m_pTickMarks | CXTPChartAxis | protected
m_pTitle | CXTPChartAxis | protected
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartElement | virtual
Release() | CXTPChartElement | virtual
SetAlignment(XTPChartAxisAlignment nAlignment) | CXTPChartAxis |
SetColor(const CXTPChartColor &color) | CXTPChartAxis |
SetDateTimeScaleUnit(XTPChartAxisDateTimeScaleUnit unit) | CXTPChartAxis |
SetGridSpacing(double dGridSpacing) | CXTPChartAxis |
SetGridSpacingAuto(BOOL bGridSpacingAuto) | CXTPChartAxis |
SetIndex(int nIndex) | CXTPChartAxis |
SetInterlaced(BOOL bInterlaced) | CXTPChartAxis |
SetInterlacedColor(const CXTPChartColor &color) | CXTPChartAxis |
SetInterlacedColor2(const CXTPChartColor &color) | CXTPChartAxis |
SetLogarithmic(BOOL bLogarithmic) | CXTPChartAxis |
SetLogarithmicBase(double dLogarithmicBase) | CXTPChartAxis |
SetMinorCount(int nMinorCount) | CXTPChartAxis |
SetReversed(BOOL bRevered) | CXTPChartAxis |
SetThickness(int nThicknes) | CXTPChartAxis |
SetVisible(BOOL bVisible) | CXTPChartAxis |
UpdateRange(CXTPChartDeviceContext *pDC, CXTPChartAxisView *pView) | CXTPChartAxis |
~CXTPChartAxis() | CXTPChartAxis | virtual
~CXTPChartElement() | CXTPChartElement | virtual


Toolkit Pro: XTPChartSeriesPointView.h Source File

  • Source
  • Chart
XTPChartSeriesPointView.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTSERIESPOINTVIEW_H__)
24# define __XTPCHARTSERIESPOINTVIEW_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartSeriesView;
34class CXTPChartSeriesPoint;
35class CXTPChartSeriesStyle;
36class CXTPChartSeries;
37class CXTPChartDiagramView;
38class CXTPChartDiagram;
39class CXTPChartLegendView;
40
45class _XTP_EXT_CLASS CXTPChartSeriesPointView
46 : public CXTPChartElementView
47 , public CXTPChartLegendItemView
48{
49 DECLARE_DYNAMIC(CXTPChartSeriesPointView);
50
51public:
59 CXTPChartSeriesPointView(CXTPChartSeriesPoint* pPoint, CXTPChartElementView* pParentView);
60
69 CXTPChartSeriesPointView(CXTPChartSeriesPoint* pPoint, CXTPChartElementView* pParentView,
70 BOOL bAddToParent);
71
72public:
80 CXTPChartSeriesPoint* GetPoint() const;
81
89 CXTPChartSeriesView* GetSeriesView() const;
90
98 CXTPChartColor GetColor() const;
99
107 CXTPChartColor GetColor2() const;
108
116 double GetInternalValue() const;
117
126 virtual CXTPChartString GetLegendName() const;
127
139 virtual CXTPChartDeviceCommand* CreateLegendDeviceCommand(CXTPChartDeviceContext* pDC,
140 CRect rcBounds);
141
149 virtual void UpdateMinMaxRange(double& nMinValue, double& nMaxValue) const;
150
151private:
152 CXTPChartColor PrepareColor(CXTPChartColor color) const;
153
154public:
155 double m_dInternalValue;
157protected:
158 CXTPChartSeriesPoint* m_pPoint;
160 friend class CXTPChartSeriesView;
161};
162
163AFX_INLINE CXTPChartSeriesPoint* CXTPChartSeriesPointView::GetPoint() const
164{
165 return m_pPoint;
166}
167
168AFX_INLINE double CXTPChartSeriesPointView::GetInternalValue() const
169{
170 return m_dInternalValue;
171}
172
173AFX_INLINE void CXTPChartSeriesPointView::UpdateMinMaxRange(double& /*nMinValue*/,
174 double& /*nMaxValue*/) const
175{
176}
178# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
179#endif //#if !defined(__XTPCHARTSERIESPOINTVIEW_H__)
pPoint
const CPoint * pPoint
return 0 or xtpCalendarHitTestDayExpandButton
Definition XTPCalendarThemeOffice2007.h:150
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartColor
This class abstracts a color entity.
Definition XTPChartTypes.h:51
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartDiagram
This class represents a chart diagram, which is a kind of CXTPChartElement.
Definition XTPChartDiagram.h:48
CXTPChartDiagramView
This class represents the view of a chart diagram, which is a kind of CXTPChartElementView.
Definition XTPChartDiagramView.h:49
CXTPChartElementView
This class represents the view of a chart element.
Definition XTPChartElementView.h:47
CXTPChartLegendItemView
CXTPChartLegendItemView is an abstract base class which represents a chart legend item.
Definition XTPChartLegendItem.h:39
CXTPChartLegendView
This class abstracts the view of a legend and its child items in a bounding rectangle context.
Definition XTPChartLegendView.h:49
CXTPChartSeries
This class represents a series in the chart, which is a kind of CXTPChartElement.
Definition XTPChartSeries.h:50
CXTPChartSeriesPoint
CXTPChartSeriesPoint is a kind of CXTPChartElement.
Definition XTPChartSeriesPoint.h:43
CXTPChartSeriesPointView
Represents chart series point view.
Definition XTPChartSeriesPointView.h:48
CXTPChartSeriesPointView::UpdateMinMaxRange
virtual void UpdateMinMaxRange(double &nMinValue, double &nMaxValue) const
Provides a default empty implementation for min/max range update request.
Definition XTPChartSeriesPointView.h:173
CXTPChartSeriesPointView::m_pPoint
CXTPChartSeriesPoint * m_pPoint
Point model object pointer.
Definition XTPChartSeriesPointView.h:158
CXTPChartSeriesPointView::GetColor
CXTPChartColor GetColor() const
Obtain view color values.
CXTPChartSeriesPointView::m_dInternalValue
double m_dInternalValue
Point internal value.
Definition XTPChartSeriesPointView.h:155
CXTPChartSeriesPointView::GetLegendName
virtual CXTPChartString GetLegendName() const
This function returns the legend name.
CXTPChartSeriesPointView::GetInternalValue
double GetInternalValue() const
Obtains point interval value.
Definition XTPChartSeriesPointView.h:168
CXTPChartSeriesPointView::GetPoint
CXTPChartSeriesPoint * GetPoint() const
Obtains point model object.
Definition XTPChartSeriesPointView.h:163
CXTPChartSeriesPointView::CreateLegendDeviceCommand
virtual CXTPChartDeviceCommand * CreateLegendDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcBounds)
This function creates a CXTPChartDeviceCommand object.
CXTPChartSeriesPointView::CXTPChartSeriesPointView
CXTPChartSeriesPointView(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Constructs the view object.
CXTPChartSeriesPointView::CXTPChartSeriesPointView
CXTPChartSeriesPointView(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView, BOOL bAddToParent)
Constructs the view object.
CXTPChartSeriesPointView::GetSeriesView
CXTPChartSeriesView * GetSeriesView() const
Obtains parent series view.
CXTPChartSeriesPointView::GetColor2
CXTPChartColor GetColor2() const
Obtain view color values.
CXTPChartSeriesStyle
CXTPChartSeriesStyle is a CXTPChartElement derived class.
Definition XTPChartSeriesStyle.h:49


Toolkit Pro: XTPDialogBase.h Source File

  • Source
  • CommandBars
CommandBars/XTPDialogBase.h
Go to the documentation of this file.
1
23#if !defined(__XTPDIALOGBASE_H__)
24# define __XTPDIALOGBASE_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33# ifdef _XTP_INCLUDE_CONTROLS
34# include "Controls/Dialog/XTPDialogBase.h"
35
38typedef CXTPDialogEx CXTPDialog;
39
40# if (_MSC_VER > 1200)
41typedef CXTPDHtmlDialogEx CXTPDHtmlDialog;
42# endif
43
44# endif // _XTP_INCLUDE_CONTROLS
46# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
47#endif // #if !defined(__XTPDIALOGBASE_H__)
XTPDialogBase.h
XTPDisableNoisyWarnings.h
CXTPDialogEx
CXTPDialogEx is a CXTPDialogBase derived class.
Definition Controls/Dialog/XTPDialogBase.h:358


Toolkit Pro: XTPMarkupGdiPlusTransformationMatrix.h Source File

  • Source
  • Markup
  • Transform
XTPMarkupGdiPlusTransformationMatrix.h
Go to the documentation of this file.
1
23#if !defined(__XTPMARKUPGDIPLUSTRANSFORMATIONMATRIX_H__)
24# define __XTPMARKUPGDIPLUSTRANSFORMATIONMATRIX_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPGdiPlus;
34
39class _XTP_EXT_CLASS CXTPMarkupGdiPlusTransformationMatrix : public CXTPMarkupTransformationMatrix
40{
42 DECLARE_DYNAMIC(CXTPMarkupGdiPlusTransformationMatrix);
44public:
52 CXTPMarkupGdiPlusTransformationMatrix(CXTPGdiPlus* pReserved, GpMatrix* pMatrix);
53
58 ~CXTPMarkupGdiPlusTransformationMatrix();
59
61 _XTP_DEPRECATED CXTPGdiPlus* GetGdiPlus();
62 _XTP_DEPRECATED const CXTPGdiPlus* GetGdiPlus() const;
71 GpMatrix* GetMatrix();
72
79 const GpMatrix* GetMatrix() const;
80
81public:
89 virtual CXTPMarkupTransformationMatrix* Clone() const;
90
96 virtual void Offset(const POINT& offset);
97
107 virtual BOOL PtInRect(const RECT& rect, const POINT& absoluteOffset, const POINT& point) const;
108
117 virtual CRect GetBoundRect(const RECT& rect, const POINT& absoluteOffset) const;
118
119private:
120 BOOL TransformRect(const RECT& rect, const POINT& absoluteOffset,
121 PointF (&transformedRectPoints)[4]) const;
122
123private:
124 GpMatrix* m_pMatrix;
125};
127AFX_INLINE CXTPGdiPlus* CXTPMarkupGdiPlusTransformationMatrix::GetGdiPlus()
128{
129 return NULL;
130}
131
132AFX_INLINE const CXTPGdiPlus* CXTPMarkupGdiPlusTransformationMatrix::GetGdiPlus() const
133{
134 return NULL;
135}
137AFX_INLINE GpMatrix* CXTPMarkupGdiPlusTransformationMatrix::GetMatrix()
138{
139 return m_pMatrix;
140}
141
142AFX_INLINE const GpMatrix* CXTPMarkupGdiPlusTransformationMatrix::GetMatrix() const
143{
144 return m_pMatrix;
145}
146
147# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
149#endif // !defined(__XTPMARKUPGDIPLUSTRANSFORMATIONMATRIX_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPMarkupGdiPlusTransformationMatrix
Encapsulates GDI+ transformation matrix access.
Definition XTPMarkupGdiPlusTransformationMatrix.h:40
CXTPMarkupGdiPlusTransformationMatrix::Clone
virtual CXTPMarkupTransformationMatrix * Clone() const
Clones a matrix object.
CXTPMarkupGdiPlusTransformationMatrix::GetBoundRect
virtual CRect GetBoundRect(const RECT &rect, const POINT &absoluteOffset) const
Computes the bounding rectangle after transformation.
CXTPMarkupGdiPlusTransformationMatrix::PtInRect
virtual BOOL PtInRect(const RECT &rect, const POINT &absoluteOffset, const POINT &point) const
Checks if a point is inside a rectangle with transformation applied.
CXTPMarkupGdiPlusTransformationMatrix::Offset
virtual void Offset(const POINT &offset)
Adds offset to the current matrix.
CXTPMarkupGdiPlusTransformationMatrix::~CXTPMarkupGdiPlusTransformationMatrix
~CXTPMarkupGdiPlusTransformationMatrix()
Cleans up resources held.
CXTPMarkupGdiPlusTransformationMatrix::GetMatrix
GpMatrix * GetMatrix()
Provides access to the native GDI+ matrix instance.
Definition XTPMarkupGdiPlusTransformationMatrix.h:137
CXTPMarkupGdiPlusTransformationMatrix::CXTPMarkupGdiPlusTransformationMatrix
CXTPMarkupGdiPlusTransformationMatrix(CXTPGdiPlus *pReserved, GpMatrix *pMatrix)
Constructs a GDI+ markup matrix.
CXTPMarkupTransformationMatrix
An abstract class for device context transformation matrix.
Definition XTPMarkupTransformationMatrix.h:40


Toolkit Pro: Member List

CXTPHeaderCtrlThemeOffice2003 Member List

This is the complete list of members for CXTPHeaderCtrlThemeOffice2003, including all inherited members.

CleanUp(CXTPHeaderCtrl *pHeaderCtrl) | CXTPHeaderCtrlTheme | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPControlTheme() | CXTPControlTheme |
CXTPHeaderCtrlTheme() | CXTPHeaderCtrlTheme |
CXTPHeaderCtrlThemeOffice2003() | CXTPHeaderCtrlThemeOffice2003 |
DrawHeader(CDC *pDC, CXTPHeaderCtrl *pHeaderCtrl) | CXTPHeaderCtrlTheme | virtual
DrawSortArrow(CDC *pDC, LPPOINT ptsArrow, BOOL bAscending) | CXTPHeaderCtrlTheme | protectedvirtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetDrawStyle() const | CXTPHeaderCtrlTheme | virtual
GetThemeStyle() const | CXTPControlTheme |
GetThemeWrapper() | CXTPHeaderCtrlTheme |
HasSortArrow() | CXTPHeaderCtrlTheme |
Layout(LPHDLAYOUT lpHDL, CXTPHeaderCtrl *pHeaderCtrl) | CXTPHeaderCtrlThemeOffice2003 | virtual
m_bUseWinThemes | CXTPHeaderCtrlTheme | protected
m_cr3DDkShadow | CXTPHeaderCtrlTheme | protected
m_cr3DFace | CXTPHeaderCtrlTheme | protected
m_cr3DHighLight | CXTPHeaderCtrlTheme | protected
m_cr3DShadow | CXTPHeaderCtrlTheme | protected
m_crText | CXTPHeaderCtrlTheme | protected
m_dwDrawStyle | CXTPHeaderCtrlTheme | protected
m_iArrowPadding | CXTPHeaderCtrlTheme | protected
m_nTheme | CXTPControlTheme | protected
m_sizeArrow | CXTPHeaderCtrlTheme | protected
m_sizePadding | CXTPHeaderCtrlTheme | protected
m_themeHeader | CXTPHeaderCtrlTheme | protected
OnDrawBackground(LPDRAWITEMSTRUCT lpDIS) | CXTPHeaderCtrlThemeOffice2003 | protectedvirtual
OnDrawBackgroundWinThemed(LPDRAWITEMSTRUCT lpDIS) | CXTPHeaderCtrlTheme | protectedvirtual
OnDrawItemBackground(LPDRAWITEMSTRUCT lpDIS) | CXTPHeaderCtrlThemeOffice2003 | protectedvirtual
OnDrawItemBackgroundWinThemed(LPDRAWITEMSTRUCT lpDIS) | CXTPHeaderCtrlTheme | protectedvirtual
OnDrawItemBitmap(LPDRAWITEMSTRUCT lpDIS, CRect &rcText, CXTPHeaderCtrl *pHeaderCtrl) | CXTPHeaderCtrlTheme | protectedvirtual
OnDrawItemSortArrow(LPDRAWITEMSTRUCT lpDIS, BOOL bAscending) | CXTPHeaderCtrlTheme | protectedvirtual
OnDrawItemText(LPDRAWITEMSTRUCT lpDIS, CXTPHeaderCtrl *pHeaderCtrl) | CXTPHeaderCtrlTheme | protectedvirtual
RefreshMetrics(CXTPHeaderCtrl *pHeader) | CXTPHeaderCtrlTheme | virtual
SetBitmap(int iCol, UINT uBitmapID, BOOL bRemove, COLORREF crMask, CXTPHeaderCtrl *pHeaderCtrl) | CXTPHeaderCtrlTheme | virtual
SetDrawStyle(DWORD dwDrawStyle, CXTPHeaderCtrl *pHeaderCtrl) | CXTPHeaderCtrlTheme | virtual
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static
UseWinXPThemes(CXTPHeaderCtrl *pHeaderCtrl) | CXTPHeaderCtrlTheme | virtual
~CXTPHeaderCtrlTheme() | CXTPHeaderCtrlTheme | virtual
~CXTPHeaderCtrlThemeOffice2003() | CXTPHeaderCtrlThemeOffice2003 | virtual


Toolkit Pro: Member List

CXTPCalendarTip Member List

This is the complete list of members for CXTPCalendarTip, including all inherited members.

Activate(BOOL bActive, BOOL bAdvanced=FALSE) | CXTPCalendarTip |
CalcToolTipRect(BOOL bFull=FALSE) | CXTPCalendarTip |
Create(CWnd *pParentWnd) | CXTPCalendarTip | virtual
CXTPCalendarTip() | CXTPCalendarTip |
GetHoverRect() const | CXTPCalendarTip |
GetTooltipText() const | CXTPCalendarTip |
IsAdvancedMode() const | CXTPCalendarTip |
m_bAdvancedMode | CXTPCalendarTip | protected
m_pFont | CXTPCalendarTip | protected
m_pParentWnd | CXTPCalendarTip | protected
m_pTheme | CXTPCalendarTip | protected
m_rcHover | CXTPCalendarTip | protected
m_strTooltipText | CXTPCalendarTip | protected
SetAdvancedMode(BOOL bMode=TRUE) | CXTPCalendarTip |
SetFont(CFont *pFont) | CXTPCalendarTip |
SetHoverRect(CRect rc) | CXTPCalendarTip |
SetTheme(CXTPCalendarTheme *pTheme) | CXTPCalendarTip |
SetTooltipText(LPCTSTR str) | CXTPCalendarTip |
~CXTPCalendarTip() | CXTPCalendarTip | virtual


Toolkit Pro: Member List

CXTPChartRangeSplineAreaSeriesView Member List

This is the complete list of members for CXTPChartRangeSplineAreaSeriesView, including all inherited members.

AddChildView(CXTPChartElementView *pChildView) | CXTPChartElementView |
CreateDeviceCommand(CXTPChartDeviceContext *pDC) | CXTPChartRangeSplineAreaSeriesView | protectedvirtual
CreateLegendDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcBounds) | CXTPChartAreaSeriesView | protectedvirtual
CXTPChartAreaSeriesView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView) | CXTPChartAreaSeriesView |
CXTPChartElementView(CXTPChartElementView *pParentView) | CXTPChartElementView |
CXTPChartElementView(CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartElementView |
CXTPChartElementView(CXTPChartContainer *pContainer) | CXTPChartElementView |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartRangeSplineAreaSeriesView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView) | CXTPChartRangeSplineAreaSeriesView |
GetActualColor() const | CXTPChartAreaSeriesView | protected
GetActualColor2() const | CXTPChartAreaSeriesView | protected
GetAt(int nIndex) const | CXTPChartElementView |
GetBorderActualColor() const | CXTPChartAreaSeriesView | protected
GetBounds() const | CXTPChartElementView |
GetBounds(BOOL bIncludingChildren) const | CXTPChartElementView |
GetChildren() | CXTPChartElementView |
GetCount() const | CXTPChartElementView |
GetParentView() const | CXTPChartElementView |
Is3D() const | CXTPChartObject |
m_arrChildren | CXTPChartElementView | protected
m_pContainer | CXTPChartElementView | protected
m_pParentView | CXTPChartElementView | protected
m_rcBounds | CXTPChartElementView | protected
~CXTPChartElementView() | CXTPChartElementView | protectedvirtual
~CXTPChartLegendItemView() | CXTPChartLegendItemView | inlinevirtual


Toolkit Pro: Member List

CXTPWindowList Member List

This is the complete list of members for CXTPWindowList, including all inherited members.

AdjustResizeRect(CSize &rcWindow) | CXTPResize | protectedvirtual
AutoLoadPlacement(LPCTSTR pszSection) | CXTPResize |
CResizeItemArray typedef | CXTPResize | protected
CXTPResize(CWnd *pWnd, const UINT nFlags=0) | CXTPResize |
CXTPResizeDialog() | CXTPResizeDialog |
CXTPResizeDialog(const UINT nID, CWnd *pParent=0, const UINT nFlags=0) | CXTPResizeDialog |
CXTPResizeDialog(LPCTSTR lpszTemplateName, CWnd *pParent=0, const UINT nFlags=0) | CXTPResizeDialog |
CXTPWindowList(CMDIFrameWnd *pMDIFrameWnd) | CXTPWindowList |
CXTPWindowList(HWND hWndMDIClient) | CXTPWindowList |
Defer(HDWP &hdwp, CXTPResizeItem *pItem, int dx, int dy) | CXTPResize | protectedvirtual
FillMDIClientWindowList(HWND hWnd) | CXTPWindowList | protected
FillMDIWindowList() | CXTPWindowList | protectedvirtual
GetChildWndText(HWND hWnd) const | CXTPWindowList | protectedvirtual
GetMinMaxInfo(MINMAXINFO *pMMI) | CXTPResize | protected
HasFlag(XTPResize eFlag) | CXTPResize | protected
Init() | CXTPResize | protectedvirtual
InsertMDIChild(HWND hwndMDIChildWnd) | CXTPWindowList | protectedvirtual
LoadPlacement(LPCTSTR pszSection) | CXTPResize |
m_arrItems | CXTPResize | protected
m_hIcon | CXTPWindowList | protected
m_hWndMDIClient | CXTPWindowList | protected
m_lboxWindows | CXTPWindowList | protected
m_nDialogID | CXTPResizeDialog | protected
m_nFlagsXX | CXTPResize | protected
m_pMDIFrameWnd | CXTPWindowList | protected
m_pWnd | CXTPResize | protected
m_scSizeIcon | CXTPResize | protected
m_strSection | CXTPResize | protected
m_szInitWindow | CXTPResize | protected
m_szMax | CXTPResize | protected
m_szMin | CXTPResize | protected
m_szWindow | CXTPResize | protected
Offset(CPoint ptOffset) | CXTPResize | protected
RemoveAllControls() | CXTPResize | protected
RemoveResize(UINT nID) | CXTPResize | protected
Reset() | CXTPResize | protected
RestoreAndMinimize() | CXTPWindowList | protected
SavePlacement(LPCTSTR pszSection) | CXTPResize |
SelectMDIActive() | CXTPWindowList | protectedvirtual
SetEnableButtons() | CXTPWindowList | protectedvirtual
SetFlag(XTPResize eFlag) | CXTPResize | protected
SetMaxSize(CSize &sz) | CXTPResize |
SetMinSize(CSize &sz) | CXTPResize |
SetResize(UINT nID, XTP_RESIZE left, XTP_RESIZE top, XTP_RESIZE right, XTP_RESIZE bottom) | CXTPResize |
SetResize(UINT nID, const XTP_RESIZERECT &rrcSizing) | CXTPResize |
SetResize(UINT nID, HWND hWnd, const XTP_RESIZERECT &rrcSizing) | CXTPResize |
SetResize(UINT nID, HWND hWnd, const XTP_RESIZEPOINT &rpTopLeft, const XTP_RESIZEPOINT &rpBottomRight) | CXTPResize |
SetResize(UINT nID, const XTP_RESIZEPOINT &rpTopLeft, const XTP_RESIZEPOINT &rpBottomRight) | CXTPResize |
SetResize(CWnd *pWnd, const CXTPResizeRect &rrcSizing, CRect rcWindow) | CXTPResize | protected
SetWindowIcon(HICON hIcon) | CXTPWindowList | inline
Size() | CXTPResize | protectedvirtual
UpdateControlRect(CWnd *pWnd) | CXTPResize | protected
~CXTPResize() | CXTPResize | virtual


Toolkit Pro: Member List

CXTPSkinObjectButton Member List

This is the complete list of members for CXTPSkinObjectButton, including all inherited members.

CXTPSkinObject() | CXTPSkinObject | protected
CXTPSkinObjectButton() | CXTPSkinObjectButton |
CXTPSkinObjectFrame() | CXTPSkinObjectFrame |
GetAccessCriticalSection() const | CXTPSynchronized | inline
GetBorders() const | CXTPSkinObjectFrame |
GetCaptionButtons() | CXTPSkinObjectFrame |
GetClassName() const | CXTPSkinObject |
GetClientBrush(CDC *pDC) | CXTPSkinObjectFrame | virtual
GetColor(int nIndex) const | CXTPSkinObject |
GetMetrics() const | CXTPSkinObject |
GetSkinClass() const | CXTPSkinObject |
GetSkinManager() const | CXTPSkinObject |
IsActive() const | CXTPSkinObjectFrame |
m_arrButtons | CXTPSkinObjectFrame | protected
m_bActive | CXTPSkinObjectFrame | protected
m_bActiveX | CXTPSkinObject | protected
m_bHot | CXTPSkinObjectButton | protected
m_bLockFrameDraw | CXTPSkinObjectFrame |
m_bMDIClient | CXTPSkinObjectFrame | protected
m_bPushed | CXTPSkinObjectButton | protected
m_bRegionChanged | CXTPSkinObjectFrame | protected
m_bStyle | CXTPSkinObjectButton |
m_bWindowsForms | CXTPSkinObject | protected
m_dwDialogTexture | CXTPSkinObjectFrame |
m_dwExStyle | CXTPSkinObjectFrame | protected
m_dwStyle | CXTPSkinObjectFrame | protected
m_pButtonHot | CXTPSkinObjectFrame | protected
m_pButtonPressed | CXTPSkinObjectFrame | protected
m_pManager | CXTPSkinObject | protected
m_pOldWndProc | CXTPSkinObject | protected
m_pSBTrack | CXTPSkinObjectFrame | protected
m_rcBorders | CXTPSkinObjectFrame | protected
m_spi | CXTPSkinObjectFrame | protected
m_strClassName | CXTPSkinObject | protected
m_szFrameRegion | CXTPSkinObjectFrame | protected
OnHookAttached(LPCREATESTRUCT lpcs, BOOL bAuto) | CXTPSkinObjectFrame | protectedvirtual
OnHookDetached(BOOL bAuto) | CXTPSkinObjectFrame | protectedvirtual
OnSkinChanged(BOOL bPrevState, BOOL bNewState) | CXTPSkinObjectFrame | protectedvirtual
RedrawScrollBar(int nBar) | CXTPSkinObjectFrame |
RefreshMetrics() | CXTPSkinObjectFrame | protectedvirtual
~CXTPSkinObject() | CXTPSkinObject | protected
~CXTPSkinObjectButton() | CXTPSkinObjectButton | virtual
~CXTPSkinObjectFrame() | CXTPSkinObjectFrame | virtual


Toolkit Pro: XTPMarkupPathData.h Source File

  • Source
  • Markup
  • Shapes
XTPMarkupPathData.h
Go to the documentation of this file.
1
23#if !defined(__XTPMARKUPPATHDATA_H__)
24# define __XTPMARKUPPATHDATA_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPMarkupPathData;
34class CXTPMarkupBuilder;
35class CXTPMarkupObject;
36class CXTPMarkupDependencyProperty;
37
38struct MARKUP_POINTF;
39
40class _XTP_EXT_CLASS CXTPMarkupPathData : public CXTPMarkupObject
41{
42public:
44 DECLARE_MARKUPCLASS(CXTPMarkupPathData)
46public:
47 CXTPMarkupPathData();
48 CXTPMarkupPathData(const MARKUP_POINTF* pPoints, const BYTE* pTypes, int nCount);
49
50 ~CXTPMarkupPathData();
51
52public:
53 MARKUP_POINTF* GetPoints() const;
54 int GetCount() const;
55 BYTE* GetTypes() const;
56
57 CRect GetBounds() const;
58
59 CXTPMarkupPathData* Stretch(CSize sz) const;
60
61protected:
62 void SetContentObject(CXTPMarkupBuilder* pBuilder, CXTPMarkupObject* pContent);
63 CXTPMarkupObject* ConvertFrom(CXTPMarkupBuilder* pBuilder, CXTPMarkupObject* pObject) const;
64 void UpdateBounds();
65
66protected:
67 MARKUP_POINTF* m_pPoints;
68 int m_nCount;
69 BYTE* m_pTypes;
70 CRect m_rcBounds;
71
72public:
73 int m_nFillRule;
74 int m_nPixelOffsetMode;
75
76public:
77 static CXTPMarkupDependencyProperty* m_pPropertyGeometry;
78};
79
80AFX_INLINE MARKUP_POINTF* CXTPMarkupPathData::GetPoints() const
81{
82 return m_pPoints;
83}
84
85AFX_INLINE int CXTPMarkupPathData::GetCount() const
86{
87 return m_nCount;
88}
89
90AFX_INLINE BYTE* CXTPMarkupPathData::GetTypes() const
91{
92 return m_pTypes;
93}
94
95AFX_INLINE CRect CXTPMarkupPathData::GetBounds() const
96{
97 return m_rcBounds;
98}
99
100# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
102#endif // !defined(__XTPMARKUPPATHDATA_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h


Toolkit Pro: Member List

CXTPChart3dPieSeriesPointView Member List

This is the complete list of members for CXTPChart3dPieSeriesPointView, including all inherited members.

AddChildView(CXTPChartElementView *pChildView) | CXTPChartElementView |
CalculateLayout(double &dAngle) | CXTPChart3dPieSeriesPointView | virtual
CreateDeviceCommand(CXTPChartDeviceContext *pDC) | CXTPChart3dPieSeriesPointView | protectedvirtual
CreateLegendDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcBounds) | CXTPChart3dPieSeriesPointView | protectedvirtual
CXTPChart3dPieSeriesPointView(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView) | CXTPChart3dPieSeriesPointView |
CXTPChartElementView(CXTPChartElementView *pParentView) | CXTPChartElementView |
CXTPChartElementView(CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartElementView |
CXTPChartElementView(CXTPChartContainer *pContainer) | CXTPChartElementView |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartPieSeriesPointViewBase(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView) | CXTPChartPieSeriesPointViewBase | protected
CXTPChartPieSeriesPointViewBase(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartPieSeriesPointViewBase | protected
CXTPChartSeriesPointView(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView) | CXTPChartSeriesPointView |
CXTPChartSeriesPointView(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartSeriesPointView |
GetAt(int nIndex) const | CXTPChartElementView |
GetBasePoint() const | CXTPChartPieSeriesPointViewBase |
GetBounds() const | CXTPChartElementView |
GetBounds(BOOL bIncludingChildren) const | CXTPChartElementView |
GetCenterShapeConnectorPoint() const | CXTPChart3dPieSeriesPointView |
GetChildren() | CXTPChartElementView |
GetColor() const | CXTPChartSeriesPointView |
GetColor2() const | CXTPChartSeriesPointView |
GetCount() const | CXTPChartElementView |
GetInternalValue() const | CXTPChartSeriesPointView |
GetLegendName() const | CXTPChartSeriesPointView | virtual
GetOuterCenterConnectorPoint() const | CXTPChart3dPieSeriesPointView |
GetParentView() const | CXTPChartElementView |
GetPie() const | CXTPChartPieSeriesPointViewBase |
GetPoint() const | CXTPChartSeriesPointView |
GetSeriesView() const | CXTPChartSeriesPointView |
Is3D() const | CXTPChartObject |
m_arrChildren | CXTPChartElementView | protected
m_dInternalValue | CXTPChartSeriesPointView |
m_pContainer | CXTPChartElementView | protected
m_pParentView | CXTPChartElementView | protected
m_pPoint | CXTPChartSeriesPointView | protected
m_rcBounds | CXTPChartElementView | protected
OnSetConnectorPoints(CXTPChartDeviceCommand *pCommand, CXTPPoint3d ptShapeCenter, CXTPPoint3d ptOuterCenter) | CXTPChart3dPieSeriesPointView | protectedvirtual
OnUpdateBounds(CXTPChartDeviceCommand *pCommand, CRect rcBounds) | CXTPChart3dPieSeriesPointView | protectedvirtual
UpdateMinMaxRange(double &nMinValue, double &nMaxValue) const | CXTPChartSeriesPointView | virtual
~CXTPChart3dPieSeriesPointView() | CXTPChart3dPieSeriesPointView | virtual
~CXTPChartElementView() | CXTPChartElementView | protectedvirtual
~CXTPChartLegendItemView() | CXTPChartLegendItemView | inlinevirtual
~CXTPChartPieSeriesPointViewBase() | CXTPChartPieSeriesPointViewBase | virtual


Toolkit Pro: XTPChartCandleStickSeriesStyle.h Source File

  • Source
  • Chart
  • Styles
  • Financial
XTPChartCandleStickSeriesStyle.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTCANDLESTICKSERIESSTYLE_H__)
24# define __XTPCHARTCANDLESTICKSERIESSTYLE_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartSeriesView;
34
47class _XTP_EXT_CLASS CXTPChartCandleStickSeriesStyle : public CXTPChartHighLowSeriesStyle
48{
50 DECLARE_SERIAL(CXTPChartCandleStickSeriesStyle)
52public:
57 CXTPChartCandleStickSeriesStyle();
58
63 virtual ~CXTPChartCandleStickSeriesStyle();
64
65protected:
75 virtual CXTPChartSeriesView* CreateView(CXTPChartSeries* pSeries,
76 CXTPChartDiagramView* pDiagramView);
77
78protected:
79# ifdef _XTP_ACTIVEX
80public:
82 DECLARE_DISPATCH_MAP()
83 DECLARE_INTERFACE_MAP()
84 DECLARE_OLETYPELIB_EX(CXTPChartCandleStickSeriesStyle);
85 DECLARE_OLECREATE_EX(CXTPChartCandleStickSeriesStyle)
87# endif
88};
89
102class _XTP_EXT_CLASS CXTPChartCandleStickSeriesView : public CXTPChartDiagram2DSeriesView
103{
104public:
113 CXTPChartCandleStickSeriesView(CXTPChartSeries* pSeries, CXTPChartDiagramView* pDiagramView);
114
115protected:
128 CXTPChartSeriesPointView* CreateSeriesPointView(CXTPChartDeviceContext* pDC,
129 CXTPChartSeriesPoint* pPoint,
130 CXTPChartElementView* pParentView);
131
142 virtual CXTPChartDeviceCommand* CreateLegendDeviceCommand(CXTPChartDeviceContext* pDC,
143 CRect rcBounds);
144};
145
151class _XTP_EXT_CLASS CXTPChartCandleStickSeriesPointView : public CXTPChartSeriesPointView
152{
153public:
161 CXTPChartCandleStickSeriesPointView(CXTPChartSeriesPoint* pPoint,
162 CXTPChartElementView* pParentView);
163
164public:
177 virtual CXTPChartDeviceCommand* CreateDeviceCommand(CXTPChartDeviceContext* pDC);
178
179public:
189 CXTPChartPointF GetScreenPoint(int nIndex);
190};
192# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
193#endif //#if !defined(__XTPCHARTCANDLESTICKSERIESSTYLE_H__)
pPoint
const CPoint * pPoint
return 0 or xtpCalendarHitTestDayExpandButton
Definition XTPCalendarThemeOffice2007.h:150
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartCandleStickSeriesPointView
This class represents the view of a candle stick series point, which is a kind of CXTPChartSeriesPoin...
Definition XTPChartCandleStickSeriesStyle.h:152
CXTPChartCandleStickSeriesPointView::CXTPChartCandleStickSeriesPointView
CXTPChartCandleStickSeriesPointView(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Constructs a CXTPChartCandleStickSeriesPointView object.
CXTPChartCandleStickSeriesPointView::CreateDeviceCommand
virtual CXTPChartDeviceCommand * CreateDeviceCommand(CXTPChartDeviceContext *pDC)
Call this function to create a CXTPChartDeviceCommand object.
CXTPChartCandleStickSeriesPointView::GetScreenPoint
CXTPChartPointF GetScreenPoint(int nIndex)
Call this function to get the screen point from a series index.
CXTPChartCandleStickSeriesStyle
This class represents a candle stick series style, which is a kind of CXTPChartHighLowSeriesStyle.
Definition XTPChartCandleStickSeriesStyle.h:48
CXTPChartCandleStickSeriesStyle::~CXTPChartCandleStickSeriesStyle
virtual ~CXTPChartCandleStickSeriesStyle()
Destroys a CXTPChartBubbleSeriesLabel object, handles cleanup.
CXTPChartCandleStickSeriesStyle::CreateView
virtual CXTPChartSeriesView * CreateView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Call this function to create the view of the candlestick series.
CXTPChartCandleStickSeriesStyle::CXTPChartCandleStickSeriesStyle
CXTPChartCandleStickSeriesStyle()
Constructs a CXTPChartCandleStickSeriesStyle object.
CXTPChartCandleStickSeriesView
This class represents the view of a candle stick series, which is a kind of CXTPChartSeriesView.
Definition XTPChartCandleStickSeriesStyle.h:103
CXTPChartCandleStickSeriesView::CXTPChartCandleStickSeriesView
CXTPChartCandleStickSeriesView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Constructs a CXTPChartCandleStickSeriesView object.
CXTPChartCandleStickSeriesView::CreateLegendDeviceCommand
virtual CXTPChartDeviceCommand * CreateLegendDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcBounds)
This function creates a label view drawing command object.
CXTPChartCandleStickSeriesView::CreateSeriesPointView
CXTPChartSeriesPointView * CreateSeriesPointView(CXTPChartDeviceContext *pDC, CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Call this function to create a new candlestick series point view object.
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartDiagramView
This class represents the view of a chart diagram, which is a kind of CXTPChartElementView.
Definition XTPChartDiagramView.h:49
CXTPChartElementView
This class represents the view of a chart element.
Definition XTPChartElementView.h:47
CXTPChartHighLowSeriesStyle
This class represents the stock series style in the chart.
Definition XTPChartHighLowSeriesStyle.h:45
CXTPChartSeries
This class represents a series in the chart, which is a kind of CXTPChartElement.
Definition XTPChartSeries.h:50
CXTPChartSeriesPoint
CXTPChartSeriesPoint is a kind of CXTPChartElement.
Definition XTPChartSeriesPoint.h:43
CXTPChartSeriesPointView
Represents chart series point view.
Definition XTPChartSeriesPointView.h:48
CXTPPoint2T< float >


Toolkit Pro: Member List

CXTPPropertyGridItemColor Member List

This is the complete list of members for CXTPPropertyGridItemColor, including all inherited members.

AddChildItem(CXTPPropertyGridItem *pItem) | CXTPPropertyGridItem |
AddComboButton() | CXTPPropertyGridItem |
AddExpandButton() | CXTPPropertyGridItem |
AddSliderControl() | CXTPPropertyGridItem |
AddSpinButton() | CXTPPropertyGridItem |
BindToColor(COLORREF *pBindColor) | CXTPPropertyGridItemColor | virtual
BindToString(CString *pBindString) | CXTPPropertyGridItem |
Collapse() | CXTPPropertyGridItem |
CXTPCmdTarget() | CXTPCmdTarget |
CXTPPropertyGridItem(LPCTSTR lpszCaption, LPCTSTR strValue=NULL, CString *pBindString=NULL) | CXTPPropertyGridItem |
CXTPPropertyGridItem(UINT nID, LPCTSTR strValue=NULL, CString *pBindString=NULL) | CXTPPropertyGridItem |
CXTPPropertyGridItemColor(LPCTSTR strCaption, COLORREF clr=0, COLORREF *pBindColor=NULL) | CXTPPropertyGridItemColor |
CXTPPropertyGridItemColor(UINT nID, COLORREF clr=0, COLORREF *pBindColor=NULL) | CXTPPropertyGridItemColor |
EnsureVisible() | CXTPPropertyGridItem |
Expand() | CXTPPropertyGridItem |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCaption() const | CXTPPropertyGridItem |
GetCaptionMetrics() const | CXTPPropertyGridItem |
GetChilds() const | CXTPPropertyGridItem |
GetColor() const | CXTPPropertyGridItemColor | virtual
GetConstraintEdit() const | CXTPPropertyGridItem |
GetConstraints() const | CXTPPropertyGridItem |
GetDefaultValue() const | CXTPPropertyGridItem |
GetDescription() const | CXTPPropertyGridItem |
GetDropDownItemCount() const | CXTPPropertyGridItem |
GetEditorStyle() | CXTPPropertyGridItemColor |
GetEditStyle() const | CXTPPropertyGridItem | virtual
GetFlags() const | CXTPPropertyGridItem |
GetGrid() const | CXTPPropertyGridItem |
GetHeight() const | CXTPPropertyGridItem |
GetID() const | CXTPPropertyGridItem |
GetIndent() const | CXTPPropertyGridItem |
GetIndex() const | CXTPPropertyGridItem |
GetInplaceButtons() const | CXTPPropertyGridItem |
GetInplaceControls() const | CXTPPropertyGridItem |
GetInPlacedEditValue() | CXTPPropertyGridItem | inlineprotectedvirtual
GetInplaceEdit() | CXTPPropertyGridItem | virtual
GetInplaceList() | CXTPPropertyGridItem | protectedvirtual
GetItemData() const | CXTPPropertyGridItem |
GetItemRect() const | CXTPPropertyGridItem |
GetMarkupCaption() const | CXTPPropertyGridItem |
GetMarkupDescription() const | CXTPPropertyGridItem |
GetMarkupTemplate() const | CXTPPropertyGridItem | virtual
GetMarkupValue() const | CXTPPropertyGridItem |
GetMaskedText() const | CXTPPropertyGridItem |
GetMetrics(BOOL bValueMetrics, BOOL bCreate=TRUE) const | CXTPPropertyGridItem |
GetMultiLinesCount() const | CXTPPropertyGridItem |
GetParentItem() const | CXTPPropertyGridItem |
GetReadOnly() const | CXTPPropertyGridItem | virtual
GetTooltip() const | CXTPPropertyGridItem |
GetValue() const | CXTPPropertyGridItem |
GetValueMetrics() const | CXTPPropertyGridItem |
GetValueRect() | CXTPPropertyGridItemColor | protectedvirtual
GetViewValue() | CXTPPropertyGridItem | virtual
HasChilds() const | CXTPPropertyGridItem |
HasParent(CXTPPropertyGridItem *pParent) | CXTPPropertyGridItem |
HasVisibleChilds() const | CXTPPropertyGridItem |
InsertChildItem(int nIndex, CXTPPropertyGridItem *pItem) | CXTPPropertyGridItem |
IsAllowEdit() const | CXTPPropertyGridItem | virtual
IsCategory() const | CXTPPropertyGridItem |
IsExpandable() const | CXTPPropertyGridItem |
IsExpanded() const | CXTPPropertyGridItem |
IsHidden() const | CXTPPropertyGridItem |
IsInplaceButtonVisible(CXTPPropertyGridInplaceButton *pButton) const | CXTPPropertyGridItem | virtual
IsMultiLine() const | CXTPPropertyGridItem |
IsSelected() const | CXTPPropertyGridItem |
IsValueChanged() const | CXTPPropertyGridItem | virtual
IsVisible() const | CXTPPropertyGridItem |
m_bAutoComplete | CXTPPropertyGridItem | protected
m_bCategory | CXTPPropertyGridItem | protected
m_bConstraintEdit | CXTPPropertyGridItem | protected
m_bExpandable | CXTPPropertyGridItem | protected
m_bExpanded | CXTPPropertyGridItem | protected
m_bHidden | CXTPPropertyGridItem | protected
m_bPassword | CXTPPropertyGridItem | protected
m_bReadOnly | CXTPPropertyGridItem | protected
m_bUseMask | CXTPPropertyGridItem | protected
m_bVisible | CXTPPropertyGridItem | protected
m_chPrompt | CXTPPropertyGridItem | protected
m_clrValue | CXTPPropertyGridItemColor | protected
m_colorEditor | CXTPPropertyGridItemColor | protected
m_dwData | CXTPPropertyGridItem | protected
m_dwEditStyle | CXTPPropertyGridItem | protected
m_nDropDownItemCount | CXTPPropertyGridItem | protected
m_nFlags | CXTPPropertyGridItem | protected
m_nHeight | CXTPPropertyGridItem | protected
m_nID | CXTPPropertyGridItem | protected
m_nIndent | CXTPPropertyGridItem | protected
m_nIndex | CXTPPropertyGridItem | protected
m_nLinesCount | CXTPPropertyGridItem | protected
m_pBindColor | CXTPPropertyGridItemColor | protected
m_pBindString | CXTPPropertyGridItem | protected
m_pCaptionMetrics | CXTPPropertyGridItem | mutableprotected
m_pChilds | CXTPPropertyGridItem | protected
m_pConstraints | CXTPPropertyGridItem | protected
m_pGrid | CXTPPropertyGridItem | protected
m_pInplaceButtons | CXTPPropertyGridItem | protected
m_pInplaceControls | CXTPPropertyGridItem | protected
m_pMarkupCaption | CXTPPropertyGridItem | protected
m_pMarkupDescription | CXTPPropertyGridItem | protected
m_pMarkupValue | CXTPPropertyGridItem | protected
m_pParent | CXTPPropertyGridItem | protected
m_pValueMetrics | CXTPPropertyGridItem | mutableprotected
m_strCaption | CXTPPropertyGridItem | protected
m_strDefaultValue | CXTPPropertyGridItem | protected
m_strDescription | CXTPPropertyGridItem | protected
m_strFormat | CXTPPropertyGridItem | protected
m_strLiteral | CXTPPropertyGridItem | protected
m_strMarkupTemplate | CXTPPropertyGridItem | protected
m_strMask | CXTPPropertyGridItem | protected
m_strTooltip | CXTPPropertyGridItem | protected
m_strValue | CXTPPropertyGridItem | protected
MeasureItem(LPMEASUREITEMSTRUCT lpMeasureItemStruct) | CXTPPropertyGridItem | virtual
Move(CXTPPropertyGridItem *pParent, int nIndex=-1) | CXTPPropertyGridItem |
NotifyValueChanged() | CXTPPropertyGridItem | protected
OnAddChildItem() | CXTPPropertyGridItem | protectedvirtual
OnAfterEdit(CString &strValue) | CXTPPropertyGridItem | virtual
OnBeforeInsert() | CXTPPropertyGridItemColor | protectedvirtual
OnCancelEdit() | CXTPPropertyGridItem | virtual
OnCaptionChanged() | CXTPPropertyGridItem | protectedvirtual
OnChar(UINT nChar) | CXTPPropertyGridItem | protectedvirtual
OnConstraintsChanged() | CXTPPropertyGridItem | protectedvirtual
OnDeselect() | CXTPPropertyGridItem | protectedvirtual
OnDrawItemConstraint(CDC *pDC, CXTPPropertyGridItemConstraint *pConstraint, CRect rc, BOOL bSelected) | CXTPPropertyGridItem | virtual
OnDrawItemValue(CDC &dc, CRect rcValue) | CXTPPropertyGridItemColor | protectedvirtual
OnIndexChanged() | CXTPPropertyGridItem | protectedvirtual
OnInpaceControlFocus(BOOL bForward) | CXTPPropertyGridItem | protectedvirtual
OnInplaceButtonDown(CXTPPropertyGridInplaceButton *pButton) | CXTPPropertyGridItemColor | protectedvirtual
OnKeyDown(UINT nChar) | CXTPPropertyGridItem | protectedvirtual
OnLButtonDblClk(UINT nFlags, CPoint point) | CXTPPropertyGridItem | protectedvirtual
OnLButtonDown(UINT nFlags, CPoint point) | CXTPPropertyGridItem | protectedvirtual
OnLButtonUp(UINT nFlags, CPoint point) | CXTPPropertyGridItem | protectedvirtual
OnMarkupChanged() | CXTPPropertyGridItem | virtual
OnMergeItemConstraint(CDC *pDC, CXTPPropertyGridItemConstraint *pConstraint) | CXTPPropertyGridItem | virtual
OnRButtonDown(UINT nFlags, CPoint point) | CXTPPropertyGridItem | protectedvirtual
OnRequestEdit() | CXTPPropertyGridItem | virtual
OnSelect() | CXTPPropertyGridItem | protectedvirtual
OnValidateEdit() | CXTPPropertyGridItem | virtual
OnValueChanged(CString strValue) | CXTPPropertyGridItem | virtual
PtInValueRect(CPoint point) | CXTPPropertyGridItem | protected
RedrawItem() | CXTPPropertyGridItem |
Remove() | CXTPPropertyGridItem |
ResetValue() | CXTPPropertyGridItem | virtual
RGBToString(COLORREF clr) | CXTPPropertyGridItemColor | static
Select() | CXTPPropertyGridItem |
SelectNextConstraint() | CXTPPropertyGridItem | protected
SetAutoComplete(BOOL bAutoComplete=TRUE) | CXTPPropertyGridItem |
SetCaption(LPCTSTR lpszCaption) | CXTPPropertyGridItem |
SetColor(COLORREF clr) | CXTPPropertyGridItemColor | virtual
SetConstraintEdit(BOOL bConstraintEdit=TRUE) | CXTPPropertyGridItem |
SetDefaultValue(LPCTSTR lpszDefaultValue) | CXTPPropertyGridItem |
SetDescription(LPCTSTR lpszDescription) | CXTPPropertyGridItem |
SetDropDownItemCount(int nDropDownItemCount) | CXTPPropertyGridItem |
SetEditorStyle(XTPPropertyGridItemColorEditor editor) | CXTPPropertyGridItemColor |
SetEditStyle(DWORD dwEditStyle) | CXTPPropertyGridItem |
SetEditText(const CString &str) | CXTPPropertyGridItem | protectedvirtual
SetExpandable(BOOL bExpandable) | CXTPPropertyGridItem |
SetFlags(UINT nFlags) | CXTPPropertyGridItem |
SetFocusToInplaceControl() | CXTPPropertyGridItem | virtual
SetHeight(int nHeight) | CXTPPropertyGridItem |
SetHidden(BOOL bHidden) | CXTPPropertyGridItem |
SetID(UINT nID) | CXTPPropertyGridItem |
SetItemData(DWORD_PTR dwData) | CXTPPropertyGridItem |
SetMarkupTemplate(LPCTSTR lpstrMarkupTemplate) | CXTPPropertyGridItem |
SetMask(LPCTSTR strMask, LPCTSTR strLiteral, TCHAR chPrompt=_T('_')) | CXTPPropertyGridItem |
SetMaskedText(LPCTSTR lpszMaskedText) | CXTPPropertyGridItem |
SetMultiLinesCount(int nLinesCount) | CXTPPropertyGridItem |
SetPasswordMask(TCHAR chMask=_T(' *')) | CXTPPropertyGridItem |
SetPrompt(LPCTSTR lpszPrompt) | CXTPPropertyGridItem |
SetReadOnly(BOOL bReadOnly=TRUE) | CXTPPropertyGridItem | virtual
SetTooltip(LPCTSTR lpstrTooltip) | CXTPPropertyGridItem |
SetValue(CString strValue) | CXTPPropertyGridItemColor | protectedvirtual
SetVisible(BOOL bVisible) | CXTPPropertyGridItem | protectedvirtual
StringToRGB(LPCTSTR str) | CXTPPropertyGridItemColor | static
~CXTPPropertyGridItem() | CXTPPropertyGridItem | virtual
~CXTPPropertyGridItemColor() | CXTPPropertyGridItemColor | virtual


Toolkit Pro: Member List

CXTPDateEdit Member List

This is the complete list of members for CXTPDateEdit, including all inherited members.

AdjustBuddyRect(CWnd *pBuddy, CRect &rcUpDown, int nAlignment) | CXTPEdit |
CanOverType() const | CXTPMaskEditT< CEdit > | inline
CanPaste() | CXTPEdit | virtual
CanUseMask() const | CXTPMaskEditT< CEdit > | inline
CheckChar(TCHAR &nChar, int nPos) | CXTPMaskEditT< CEdit > | inlinevirtual
ConvertUnicodeAlpha(TCHAR nChar, BOOL bUpperCase) const | CXTPMaskEditT< CEdit > | inline
CopyToClipboard(const CString &strText) | CXTPMaskEditT< CEdit > | inline
CXTPDateEdit() | CXTPDateEdit |
CXTPEdit() | CXTPEdit |
CXTPMaskEdit() | CXTPMaskEdit |
CXTPMaskEditT() | CXTPMaskEditT< CEdit > | inline
DeleteCharAt(int iPos) | CXTPMaskEditT< CEdit > | inline
DrawBuddyBorders(CWnd *pBuddy, CDC *pDC, CRect rc, int nAlignment) | CXTPEdit |
FormatOleDateTime(CString &strData, COleDateTime dt) | CXTPDateEdit | virtual
GetClientBrush(CDC *pDC) | CXTPEdit | protected
GetDateTime() | CXTPDateEdit | virtual
GetFlatStyle() const | CXTPEdit |
GetMaskedText(int nStartPos=0, int nEndPos=-1) const | CXTPMaskEditT< CEdit > | inline
GetPromptChar() const | CXTPMaskEditT< CEdit > | inline
GetPromptString(int nLength) const | CXTPMaskEditT< CEdit > | inline
GetTheme() | CXTPEdit |
GetThemeID() | CXTPEdit |
GetUseVisualStyle() const | CXTPEdit |
GetWindowDateTime() | CXTPDateEdit | virtual
HasSelection() const | CXTPEdit |
Initialize(CWnd *pParentWnd) | CXTPMaskEdit | virtual
InsertCharAt(int iPos, TCHAR nChar) | CXTPMaskEditT< CEdit > | inline
IsFlatStyle() const | CXTPEdit |
IsFocused() const | CXTPEdit |
IsHighlighted() const | CXTPEdit |
IsModified() const | CXTPMaskEditT< CEdit > | inline
IsPatternValid() | CXTPEdit |
m_bFocused | CXTPEdit | protected
m_bHighlighted | CXTPEdit | protected
m_bModified | CXTPMaskEditT< CEdit > | protected
m_bOverType | CXTPMaskEditT< CEdit > | protected
m_bPreSubclassInit | CXTPEdit | protected
m_bRedo | CXTPMaskEditT< CEdit > | protected
m_bShowBorder | CXTPEdit | protected
m_bUpdateUndo | CXTPMaskEditT< CEdit > | protected
m_bUseMask | CXTPMaskEditT< CEdit > | protected
m_chPrompt | CXTPMaskEditT< CEdit > | protected
m_nEndChar | CXTPMaskEditT< CEdit > | protected
m_nStartChar | CXTPMaskEditT< CEdit > | protected
m_pRegExp | CXTPEdit | protected
m_pTheme | CXTPEdit | protected
m_strDefault | CXTPMaskEditT< CEdit > | protected
m_strLiteral | CXTPMaskEditT< CEdit > | protected
m_strMask | CXTPMaskEditT< CEdit > | protected
m_strRedoBuffer | CXTPMaskEditT< CEdit > | protected
m_strUndoBuffer | CXTPMaskEditT< CEdit > | protected
m_strWindowText | CXTPMaskEditT< CEdit > | protected
MaskClear() | CXTPMaskEditT< CEdit > | inline
MaskCopy() | CXTPMaskEditT< CEdit > | inline
MaskCut() | CXTPMaskEditT< CEdit > | inline
MaskDeleteSel() | CXTPMaskEditT< CEdit > | inline
MaskPaste() | CXTPMaskEditT< CEdit > | inline
MaskReplaceSel(LPCTSTR lpszNewText) | CXTPMaskEditT< CEdit > | inline
MaskSelectAll() | CXTPMaskEditT< CEdit > | inline
MaskUndo() | CXTPMaskEditT< CEdit > | inline
OnCommand(WPARAM wParam, LPARAM lParam) | CXTPMaskEditT< CEdit > | inlineprotectedvirtual
PosInRange(int iPos) const | CXTPMaskEditT< CEdit > | inline
PreTranslateMessage(MSG *pMsg) | CXTPMaskEditT< CEdit > | inlinevirtual
ProcessMask(TCHAR &nChar, int nEndPos) | CXTPDateEdit | virtual
ReadOleDateTime(LPCTSTR lpszData) | CXTPDateEdit | virtual
RedrawEdit() | CXTPEdit | protected
RedrawFocusedFrame() | CXTPEdit | protected
RefreshMetrics() | CXTPEdit | virtual
SetDateTime(COleDateTime &dt) | CXTPDateEdit | virtual
SetDateTime(LPCTSTR strDate) | CXTPDateEdit | virtual
SetEditMask(LPCTSTR lpszMask, LPCTSTR lpszLiteral, LPCTSTR lpszDefault=NULL) | CXTPEdit | virtual
SetFlatStyle(BOOL bFlatStyle=TRUE) | CXTPEdit |
SetMaskedText(LPCTSTR lpszMaskedText, int iPos=0, BOOL bUpdateWindow=TRUE) | CXTPMaskEditT< CEdit > | inline
SetOverType(BOOL bOverType) | CXTPMaskEditT< CEdit > | inline
SetPattern(LPCTSTR lpszPattern) | CXTPEdit |
SetPromptChar(TCHAR ch, BOOL bAutoReplace=TRUE) | CXTPMaskEditT< CEdit > | inline
SetTheme(XTPControlTheme nTheme) | CXTPEdit | virtual
SetUseMask(BOOL bUseMask) | CXTPMaskEditT< CEdit > | inline
SetUseVisualStyle(BOOL bUseVisualStyle=TRUE) | CXTPEdit |
ShowBorder() const | CXTPEdit |
ShowThemedBorder(BOOL bShowThemedBorder) | CXTPEdit |
~CXTPEdit() | CXTPEdit | virtual


Toolkit Pro: Member List

CXTPScrollBarThemeNativeWindows10 Member List

This is the complete list of members for CXTPScrollBarThemeNativeWindows10, including all inherited members.

CalcHScroll(CXTPScrollBase *pScroll, XTPScrollMetricsH *pHScroll) | CXTPScrollBarPaintManager | protectedstatic
CalcVScroll(CXTPScrollBase *pScroll, XTPScrollMetricsV *pVScroll) | CXTPScrollBarPaintManager | protectedstatic
CXTPScrollBarPaintManager() | CXTPScrollBarPaintManager |
CXTPScrollBarThemeOffice2013() | CXTPScrollBarThemeOffice2013 |
DrawArrowGlyph(CDC *pDC, CRect rcArrow, XTPArrowGlyph glyph, BOOL bEnabled, COLORREF clrText=COLORREF_NULL) | CXTPScrollBarPaintManager | protected
DrawArrows(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics) | CXTPScrollBarThemeOffice2013 | protectedvirtual
DrawArrows(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics) | CXTPScrollBarThemeOffice2013 | protectedvirtual
DrawBackground(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics) | CXTPScrollBarThemeOffice2013 | protectedvirtual
DrawBackground(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics) | CXTPScrollBarThemeOffice2013 | protectedvirtual
DrawButtons(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics) | CXTPScrollBarThemeOffice2013 | protectedvirtual
DrawButtons(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics) | CXTPScrollBarThemeOffice2013 | protectedvirtual
DrawGripper(CDC *pDC, CXTPScrollBase *pScroll) | CXTPScrollBarThemeOffice2013 | protectedvirtual
DrawScrollBar(CDC *pDC, CXTPScrollBase *pGallery) | CXTPScrollBarThemeOffice2013 | protectedvirtual
DrawThumbButton(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics) | CXTPScrollBarThemeOffice2013 | protectedvirtual
DrawThumbButton(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics) | CXTPScrollBarThemeOffice2013 | protectedvirtual
DrawTracker(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics) | CXTPScrollBarPaintManager | protectedvirtual
DrawTracker(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics) | CXTPScrollBarPaintManager | protectedvirtual
GetScrollBarColors(XTP_SCROLLBARDRAWCOLORS &sbc, int nHitSelected, int nHitPressed, BOOL bEnabled) | CXTPScrollBarThemeOffice2013 | virtual
m_clrCurrent | CXTPScrollBarThemeOffice2013 | protected
m_clrDisabled | CXTPScrollBarThemeOffice2013 | protected
m_clrNormal | CXTPScrollBarThemeOffice2013 | protected
m_clrPressed | CXTPScrollBarThemeOffice2013 | protected
m_clrSelected | CXTPScrollBarThemeOffice2013 | protected
m_crBack | CXTPScrollBarPaintManager |
m_crBackHilite | CXTPScrollBarPaintManager |
m_crBackPushed | CXTPScrollBarPaintManager |
m_crBorder | CXTPScrollBarPaintManager |
m_crBorderHilite | CXTPScrollBarPaintManager |
m_cThumb | CXTPScrollBarPaintManager |
m_cxHScroll | CXTPScrollBarPaintManager |
m_cxVScroll | CXTPScrollBarPaintManager |
m_cyHScroll | CXTPScrollBarPaintManager |
m_cyVScroll | CXTPScrollBarPaintManager |
RefreshMetrics() | CXTPScrollBarThemeOffice2013 | protectedvirtual
~CXTPScrollBarThemeOffice2013() | CXTPScrollBarThemeOffice2013 | virtual


Toolkit Pro: XTPFrameThemeVisualStudio2019.h Source File

  • Source
  • CommandBars
  • Frame
XTPFrameThemeVisualStudio2019.h
Go to the documentation of this file.
1
23#if !defined(__XTPFRAMETHEMEVISUALSTUDIO2019_H__)
24# define __XTPFRAMETHEMEVISUALSTUDIO2019_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPPaintManager;
34class CXTPCommandBarsFrameHook;
35class CXTPRibbonBar;
36
37class _XTP_EXT_CLASS CXTPFrameThemeVisualStudio2019
38 : public CXTPFrameThemeOffice2013
39 , private IXTPApplicationEvents
40{
41public:
42 CXTPFrameThemeVisualStudio2019(CXTPPaintManager* pPaintManager);
43
44 virtual ~CXTPFrameThemeVisualStudio2019();
45
46public:
51 virtual void RefreshMetrics();
52
64 virtual void DrawFrameCaptionButton(CDC* pDC, CRect rc, int nId, BOOL bSelected, BOOL bPressed,
65 BOOL bActive);
66
79 virtual void DrawFrameCaptionButton(CDC* pDC, CRect rc, int nId, BOOL bSelected, BOOL bPressed,
80 BOOL bActive, CXTPRibbonBar* pRibbonBar);
81
90 virtual void SetStateColor(COLORREF clrState);
91
100 virtual COLORREF GetStateColor() const;
101
102 virtual CRect CalcFrameBorder(const CXTPCommandBarsFrameHook* pFrameHook) const;
103
104 virtual CXTPFrameShadow* CreateShadow(CWnd* pFrame);
105
106 virtual void OnShadowedFrameActiveStateChanged(BOOL bActive, CWnd* pFrame,
107 CXTPFrameShadow* pShadow);
108
109private:
110 virtual void OnAmbientPropertyChanged(CXTPApplication* pApplication,
111 XTPApplicationAmbientProperty nProperty);
112 void UpdateStateColor();
113
114 BOOL m_bAutomaticStateColor;
115
116protected:
117 COLORREF m_clrShadowColorActive;
118 COLORREF m_clrShadowColorInactive;
119};
121# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
122#endif // !defined(__XTPFRAMETHEMEVISUALSTUDIO2019_H__)
XTPApplicationAmbientProperty
XTPApplicationAmbientProperty
Global ambient property identifiers.
Definition XTPApplication.h:46
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPApplication
Defines a global XTP application object interface.
Definition XTPApplication.h:151
CXTPCommandBarsFrameHook
CXTPCommandBarsFrameHook is a CXTPHookManagerHookAble derived class.
Definition XTPFrameHook.h:56
CXTPFramePaintManager::OnShadowedFrameActiveStateChanged
virtual void OnShadowedFrameActiveStateChanged(BOOL bActive, CWnd *pFrame, CXTPFrameShadow *pShadow)
An implementation can override this method in order to change frame appearance when a window gets act...
CXTPFrameShadow
The class represents frame shadow object.
Definition XTPFrameShadow.h:47
CXTPPaintManager
Paint manager of the command bars.
Definition XTPPaintManager.h:199
CXTPRibbonBar
CXTPRibbonBar is a CXTPMenuBar derived class.
Definition XTPRibbonBar.h:69
IXTPApplicationEvents
Defines a callback interface for XTP application event sink.
Definition XTPApplication.h:82
IXTPApplicationEvents::OnAmbientPropertyChanged
virtual void OnAmbientPropertyChanged(CXTPApplication *pApplication, XTPApplicationAmbientProperty nProperty)
Called by framework when an ambient property is changed.
Definition XTPApplication.h:130


Toolkit Pro: XTPEnableAdvancedWarnings.h Source File

  • Source
  • Common
  • Base
  • Diagnostic
XTPEnableAdvancedWarnings.h
Go to the documentation of this file.
1
24// Advanced warning control is required only for compilation with /Wall switch.
25#if defined(_MSC_VER) && (1900 <= _MSC_VER)
26
27# ifndef XTP_BETWEEN_XTPENABLEADVANCEDWARNINGS_H_INCLUSIONS
28
29# define XTP_BETWEEN_XTPENABLEADVANCEDWARNINGS_H_INCLUSIONS
30
31# ifdef XTP_INTERNAL_WARNING_CONTROL
32// clang-format off
33// Controlling only noisy /Wall warnings, those that don't indicate actual bugs:
34// C4615: #pragma warning : unknown user warning type
35// C4616: #pragma warning : warning number 'number' out of range, must be between 'number' and 'number'
36// C4710: 'function': function not inlined
37// C4275: non dll - interface class 'user-defined type' used as base for dll - interface class 'user-defined type'
38// C4820: 'user-defined type' : '3' bytes padding added after data member 'user-defined type'
39// C4625: 'user-defined type' : copy constructor was implicitly defined as deleted
40// C4626: 'user-defined type' : assignment operator was implicitly defined as deleted
41// C5026: 'user-defined type' : move constructor was implicitly defined as deleted
42// C5027: 'user-defined type' : move assignment operator was implicitly defined as deleted
43// C4251: 'identifier' : class 'user-defined type' needs to have dll - interface to be
44// used by clients of class 'user-defined type'
45// C4555: expression has no effect; expected expression with side-effect
46// C4623: 'user-defined type': default constructor was implicitly defined as deleted
47// C4514: 'function' : unreferenced inline function has been removed
48// C4571: Informational: catch (...) semantics changed since Visual C++ 7.1; structured exceptions(SEH) are no longer caught
49// C4371: layout of class may have changed from a previous version of the compiler due to
50// better packing of member 'member'
51// C5039: 'function' : pointer or reference to potentially throwing function passed to extern C
52// function under - EHc. Undefined behavior may occur if this function throws an exception.
53// C4768: __declspec attributes before linkage specification are ignored
54// C5045: Compiler will insert Spectre mitigation for memory load if /Qspectre switch specified
55// C4061: enumerator '...' in switch of enum '...' is not explicitly handled by a case label
56// C4062: enumerator '...' in switch of enum '...' is not handled
57// C4548: expression before comma has no effect; expected expression with side-effect
58// C4986: '...': exception specification does not match previous declaration
59// C2143: syntax error: missing ';' before '...'
60// C4430: missing type specifier - int assumed. Note: C++ does not support default-int
61// C4183: '...': missing return type; assumed to be a member function returning 'int'
62// C4097: typedef-name 'Parent' used as synonym for class-name '...'
63// C4711: function '...' selected for automatic inline expansion
64// C4738: storing 32-bit float result in memory, possible loss of performance
65// C4619: (level 3) #pragma warning: there is no warning number 'number'
66// C4793: '...': function compiled as native: non-clrcall vcall thunks must be compiled as native
67// C5267: definition of implicit copy constructor for '...' is deprecated because it has a user-provided destructor
68// C5246: '...': the initialization of a subobject should be wrapped in braces
69# define XTP_ADVANCED_WARNING_CONTROL(action) \
70 __pragma(warning(action : \
71 4097 4615 4616 4710 4514 4275 4820 4625 4626 5026 5027 4251 4555 4623 \
72 4571 4371 5039 4768 5045 4062 4061 4548 4986 2143 4430 4183 4711 4738 \
73 4619 4503 4793 5267 5246))
74// clang-format on
75# else // XTP_INTERNAL_WARNING_CONTROL
76// clang-format off
77// Controlling /Wall warnings:
78// C4061: (level 4) enumerator 'identifier' in a switch of enum 'enumeration' is not explicitly
79// handled by a case label
80// C4062: (level 3) enumerator 'identifier' in a switch of enum 'enumeration' is not handled
81// C4191: (level 3) 'operator/operation': unsafe conversion from 'type of expression' to 'type required'
82// C4242: (level 4) 'identifier': conversion from 'type1' to 'type2', possible loss of data
83// C4254: (level 4) 'operator': conversion from 'type1' to 'type2', possible loss of data
84// C4255: (level 4) 'function': no function prototype given: converting '()' to '(void)'
85// C4263: (level 4) 'function': member function does not override any base class virtual member function
86// C4264: (level 1) 'virtual_function': no override available for virtual member function from base 'class'; function is hidden
87// C4265: (level 3) 'class': class has virtual functions, but destructor is not virtual
88// C4266: (level 4) 'function': no override available for virtual member function from base 'type'; function is hidden
89// C4287: (level 3) 'operator': unsigned/negative constant mismatch
90// C4289: (level 4) nonstandard extension used : 'var' : loop control variable declared in the for-loop is used outside the for-loop scope
91// C4296: (level 4) 'operator': expression is always false
92// C4302: (level 2) 'conversion': truncation from 'type1' to 'type2'
93// C4350: (level 1) behavior change: 'member1' called instead of 'member2'
94// C4365: (level 4) 'action': conversion from 'type_1' to 'type_2', signed/unsigned mismatch
95// C4412: (level 2) 'function': function signature contains type 'type';
96// C++ objects are unsafe to pass between pure code and mixed or native
97// C4431: (level 4) missing type specifier - int assumed. Note: C no longer supports default-int
98// C4514: (level 4) 'function': unreferenced inline function has been removed
99// C4536: (level 4) 'type name': type-name exceeds meta-data limit of 'limit' characters
100// C4545: (level 1) expression before comma evaluates to a function which is missing an argument list
101// C4546: (level 1) function call before comma missing argument list C4547: (level 1)
102// 'operator': operator before comma has no effect; expected operator with side-effect
103// C4548: (level 1) expression before comma has no effect; expected expression with side-effect
104// C4549: (level 1) 'operator': operator before comma has no effect; did you intend 'operator'?
105// C4555: (level 1) expression has no effect; expected expression with side-effect
106// C4557: (level 3) '__assume' contains effect 'effect'
107// C4571: (level 4) informational: catch(...) semantics changed since Visual C++ 7.1; structured exceptions (SEH) are no longer caught
108// C4619: (level 3) #pragma warning: there is no warning number 'number'
109// C4623: (level 4) 'derived class': default constructor could not be generated because a base class default constructor is inaccessible
110// C4625: (level 4) 'derived class': copy constructor could not be generated because a base class
111// copy constructor is inaccessible
112// C4626: (level 4) 'derived class': assignment operator could not be generated because a base class assignment operator is inaccessible
113// C4628: (level 1) digraphs not supported with -Ze. Character sequence 'digraph' not interpreted as alternate token for 'char'
114// C4640: (level 3) 'instance': construction of local static object is not thread-safe
115// C4641: (level 3) XML document comment has an ambiguous cross reference
116// C4668: (level 4) 'symbol' is not defined as a preprocessor macro, replacing with '0' for 'directives'
117// C4686: (level 3) 'user-defined type': possible change in behavior, change in UDT return calling convention
118// C4692: (level 1) 'function': signature of non-private member contains assembly private native type 'native_type'
119// C4710: (level 4) 'function': function not inlined
120// C4711: (level 1) function 'function' selected for inline expansion
121// C4738: (level 3) storing 32-bit float result in memory, possible loss of performance
122// C4820: (level 4) 'bytes' bytes padding added after construct 'member_name'
123// C4826: (level 2) conversion from 'type1' to 'type2' is sign-extended. This may cause unexpected runtime behavior
124// C4836: (level 1) nonstandard extension used : 'type' : local types or unnamed types cannot be used as template arguments
125// C4837: (level 4) trigraph detected: '??%c' replaced by '%c'
126// C4905: (level 1) wide string literal cast to 'LPSTR'
127// C4906: (level 1) string literal cast to 'LPWSTR'
128// C4917: (level 1) 'declarator': a GUID can only be associated with a class, interface, or namespace
129// C4928: (level 1) illegal copy-initialization; more than one user-defined conversion has been implicitly applied
130// C4931: (level 4) we are assuming the type library was built for number-bit pointers
131// C4946: (level 1) reinterpret_cast used between related classes: 'class1' and 'class2'
132// C4962: 'function': profile-guided optimizations disabled because optimizations caused profile data to become inconsistent
133// C4987: nonstandard extension used: 'throw (...)'
134// C5026: 'user-defined type': move constructor was implicitly defined as deleted
135// C5027: 'user-defined type': move assignment operator was implicitly defined as deleted
136// C4471: 'user-defined type': a forward declaration of an unscoped enumeration must have an underlying type(int assumed)
137// C4201: nonstandard extension used : nameless struct / union
138// C4458: declaration of 'identifier' hides class member
139// C5039: 'function' : pointer or reference to potentially throwing function passed to
140// extern C function under - EHc. Undefined behavior may occur if this function throws an exception.
141// C4768: __declspec attributes before linkage specification are ignored
142// C4986: 'function': exception specification does not match previous declaration
143// C5045: Compiler will insert Spectre mitigation for memory load if /Qspectre switch specified
144// C5204: '...': class has virtual functions, but its trivial destructor is not virtual; instances of objects derived from this class may not be destructed correctly
145// C5220: '...': a non-static data member with a volatile qualified type no longer implies that compiler generated copy/move constructors and copy/move assignment operators are not trivial
146// C5038: data member '...' will be initialized after data member '...'
147// C4131: '...': uses old-style declarator
148// C4371: layout of class may have changed from a previous version of the compiler due to
149// C4097: typedef-name 'Parent' used as synonym for class-name '...'
150// C5246: '...': the initialization of a subobject should be wrapped in braces
151// C4710: '...': function not inlined
152// C4755: Conversion rules for arithmetic operations in the comparison at ... mean that one branch cannot be executed in an inlined function. Cast '...' to '...' (or similar type of ... bytes).
153// C5267: definition of implicit copy constructor for '...' is deprecated because it has a user-provided destructor
154# define XTP_ADVANCED_WARNING_CONTROL(action) \
155 __pragma(warning(action : \
156 4097 4061 4062 4191 4201 4242 4254 4255 4263 4264 4265 4266 4287 4289 \
157 4296 4302 4350 4365 4412 4431 4514 4536 4545 4546 4547 4548 4549 4555 \
158 4557 4571 4619 4623 4625 4626 4628 4640 4641 4668 4686 4692 4710 4711 \
159 4738 4820 4826 4836 4837 4905 4906 4917 4928 4931 4946 4962 4987 5026 \
160 5027 4710 4471 4458 5039 4768 4986 5045 5204 5220 5038 4131 4371 5246 \
161 4710 4355 4755 5267))
162// clang-format on
163# endif
165# ifdef XTP_DISABLE_ADVANCED_WARNINGS
166# define XTP_BETWEEN_XTPENABLEADVANCEDWARNINGS__DISABLE
167# define XTP_WARNING_CONTROL_ACTION disable
168# undef XTP_DISABLE_ADVANCED_WARNINGS
169# else // XTP_DISABLE_ADVANCED_WARNINGS
170# define XTP_BETWEEN_XTPENABLEADVANCEDWARNINGS__ENABLE
171# define XTP_WARNING_CONTROL_ACTION default
172# endif // !XTP_DISABLE_ADVANCED_WARNINGS
173
174# ifdef XTP_INTERNAL_WARNING_CONTROL
175// C5032: detected #pragma warning(push) with no corresponding #pragma warning(pop)
176# pragma warning(disable : 5032)
177
178// Prevent C4435: class1' : Object layout under /vd2 will change due to virtual base 'class2'
179# pragma vtordisp(push, off)
180
181# undef XTP_INTERNAL_WARNING_CONTROL
182# endif
183
184# pragma warning(push)
185
186// C4615: #pragma warning: unknown user warning type
187# pragma warning(disable : 4615)
188
189XTP_ADVANCED_WARNING_CONTROL(XTP_WARNING_CONTROL_ACTION)
190
191// C4615: #pragma warning: unknown user warning type
192# pragma warning(default : 4615)
193
194# undef XTP_ADVANCED_WARNING_CONTROL
195
196# else // XTP_BETWEEN_XTPENABLEADVANCEDWARNINGS_H_INCLUSIONS
197
198# undef XTP_BETWEEN_XTPENABLEADVANCEDWARNINGS_H_INCLUSIONS
199
200# ifdef XTP_BETWEEN_XTPENABLEADVANCEDWARNINGS__DISABLE
201# ifdef XTP_DISABLE_ADVANCED_WARNINGS
202#error XTP_DISABLE_ADVANCED_WARNINGS must not be defined twice. The state of advanced warnings must be restored.
203# endif
204# undef XTP_BETWEEN_XTPENABLEADVANCEDWARNINGS__DISABLE
205# endif
206
207# ifdef XTP_BETWEEN_XTPENABLEADVANCEDWARNINGS__ENABLE
208# ifndef XTP_DISABLE_ADVANCED_WARNINGS
209#error XTP_DISABLE_ADVANCED_WARNINGS must be defined in order to restore the state of advanced warnings.
210# endif
211# undef XTP_BETWEEN_XTPENABLEADVANCEDWARNINGS__ENABLE
212# endif
213
214# ifdef XTP_INTERNAL_WARNING_CONTROL
215# pragma vtordisp(pop)
216# undef XTP_INTERNAL_WARNING_CONTROL
217# endif
218
219# pragma warning(pop)
220
221# endif // !XTP_BETWEEN_XTPENABLEADVANCEDWARNINGS_H_INCLUSIONS
222
223#else // defined(_MSC_VER) && (1900 <= _MSC_VER)
224
225# ifdef XTP_INTERNAL_WARNING_CONTROL
226# undef XTP_INTERNAL_WARNING_CONTROL
227# endif
228
229# ifdef XTP_DISABLE_ADVANCED_WARNINGS
230# undef XTP_DISABLE_ADVANCED_WARNINGS
231# endif
232
233#endif // !(defined(_MSC_VER) && (1900 <= _MSC_VER))
234


Toolkit Pro: Member List

CXTPResizeFormView Member List

This is the complete list of members for CXTPResizeFormView, including all inherited members.

AdjustResizeRect(CSize &rcWindow) | CXTPResizeFormView | protectedvirtual
AutoLoadPlacement(LPCTSTR pszSection) | CXTPResize |
CResizeItemArray typedef | CXTPResize | protected
CXTPResize(CWnd *pWnd, const UINT nFlags=0) | CXTPResize |
CXTPResizeFormView(const UINT nID=0, const UINT nFlags=0) | CXTPResizeFormView |
Defer(HDWP &hdwp, CXTPResizeItem *pItem, int dx, int dy) | CXTPResize | protectedvirtual
GetMinMaxInfo(MINMAXINFO *pMMI) | CXTPResize | protected
HasFlag(XTPResize eFlag) | CXTPResize | protected
Init() | CXTPResize | protectedvirtual
LoadPlacement(LPCTSTR pszSection) | CXTPResize |
m_arrItems | CXTPResize | protected
m_nFlagsXX | CXTPResize | protected
m_pWnd | CXTPResize | protected
m_scSizeIcon | CXTPResize | protected
m_strSection | CXTPResize | protected
m_szInitWindow | CXTPResize | protected
m_szMax | CXTPResize | protected
m_szMin | CXTPResize | protected
m_szWindow | CXTPResize | protected
Offset(CPoint ptOffset) | CXTPResize | protected
RemoveAllControls() | CXTPResize | protected
RemoveResize(UINT nID) | CXTPResize | protected
Reset() | CXTPResize | protected
SavePlacement(LPCTSTR pszSection) | CXTPResize |
SetFlag(XTPResize eFlag) | CXTPResize | protected
SetMaxSize(CSize &sz) | CXTPResize |
SetMinSize(CSize &sz) | CXTPResize |
SetResize(UINT nID, XTP_RESIZE left, XTP_RESIZE top, XTP_RESIZE right, XTP_RESIZE bottom) | CXTPResize |
SetResize(UINT nID, const XTP_RESIZERECT &rrcSizing) | CXTPResize |
SetResize(UINT nID, HWND hWnd, const XTP_RESIZERECT &rrcSizing) | CXTPResize |
SetResize(UINT nID, HWND hWnd, const XTP_RESIZEPOINT &rpTopLeft, const XTP_RESIZEPOINT &rpBottomRight) | CXTPResize |
SetResize(UINT nID, const XTP_RESIZEPOINT &rpTopLeft, const XTP_RESIZEPOINT &rpBottomRight) | CXTPResize |
SetResize(CWnd *pWnd, const CXTPResizeRect &rrcSizing, CRect rcWindow) | CXTPResize | protected
Size() | CXTPResize | protectedvirtual
UpdateControlRect(CWnd *pWnd) | CXTPResize | protected
~CXTPResize() | CXTPResize | virtual


Toolkit Pro: XTPChartGdiTextDeviceCommand.h Source File

  • Source
  • Chart
  • Drawing
  • Gdi
XTPChartGdiTextDeviceCommand.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTGDITEXTDEVICECOMMAND_H__)
24# define __XTPCHARTGDITEXTDEVICECOMMAND_H__
25
26# if _MSC_VER >= 1000
27# pragma once
28# endif // _MSC_VER >= 1000
29
30# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
31
32class CXTPMarkupUIElement;
33
39class _XTP_EXT_CLASS CXTPChartGdiTextAntialiasingDeviceCommand
40 : public CXTPChartTextAntialiasingDeviceCommand
41{
42public:
50 CXTPChartGdiTextAntialiasingDeviceCommand(BOOL bAntialias = TRUE);
51
52protected:
60 void BeforeExecute(CXTPChartDeviceContext* pDC);
61
69 void AfterExecute(CXTPChartDeviceContext* pDC);
70};
71
77class _XTP_EXT_CLASS CXTPChartGdiBoundedTextDeviceCommand : public CXTPChartBoundedTextDeviceCommand
78{
79public:
89 CXTPChartGdiBoundedTextDeviceCommand(const CXTPChartString& strText, CXTPChartFont* pFont,
90 const CXTPChartColor& color,
91 const CXTPChartRectF& rectangle);
92
93protected:
102 virtual void ExecuteInternal(CXTPChartDeviceContext* pDC);
103};
104
105class _XTP_EXT_CLASS CXTPChartGdiMarkupElementDeviceCommand
106 : public CXTPChartMarkupElementDeviceCommand
107{
108public:
118 CXTPChartGdiMarkupElementDeviceCommand(CXTPMarkupUIElement* pMarkupUIElement,
119 CXTPChartFont* pFont, const CXTPChartColor& color,
120 const CXTPChartRectF& rectangle);
121
122public:
123 virtual void ExecuteOverride(CXTPChartDeviceContext* pDC);
124
125 CXTPChartElement* HitTest(CPoint point, CXTPChartElement* pParent) const;
126};
127
128# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
129#endif //#if !defined(__XTPCHARTGDITEXTDEVICECOMMAND_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartBoundedTextDeviceCommand
This class represents a bounded text device command, which is a kind of CXTPChartDeviceCommand.
Definition XTPChartTextDeviceCommand.h:107
CXTPChartColor
This class abstracts a color entity.
Definition XTPChartTypes.h:51
CXTPChartDeviceCommand::AfterExecute
virtual void AfterExecute(CXTPChartDeviceContext *pDC)
This method gets called after a command is executed which allows for the customization of command beh...
CXTPChartDeviceCommand::BeforeExecute
virtual void BeforeExecute(CXTPChartDeviceContext *pDC)
This method gets called before a command is executed which allows for the customization of command be...
CXTPChartDeviceCommand::HitTest
virtual CXTPChartElement * HitTest(CPoint point, CXTPChartElement *pParent) const
Performs recursive hit testing of the element at the specified point.
CXTPChartDeviceCommand::ExecuteOverride
virtual void ExecuteOverride(CXTPChartDeviceContext *pDC)
Override this function to write the drawing code for specific objects.
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartElement
This class abstracts a chart element, this class acts as a base class for all chart elements.
Definition XTPChartElement.h:131
CXTPChartFont
This class abstracts a font entity.
Definition XTPChartTypes.h:540
CXTPChartMarkupElementDeviceCommand
Implements 2D markup element drawing device command.
Definition XTPChartTextDeviceCommand.h:142
CXTPChartTextAntialiasingDeviceCommand
This class represents a text device command, which is a kind of CXTPChartDeviceCommand.
Definition XTPChartTextDeviceCommand.h:85
CXTPMarkupUIElement
Base class for XML Markup core level implementations.
Definition XTPMarkupUIElement.h:43
CXTPRectT< float >


Toolkit Pro: XTPMarkupTypedSimpleStack.h Source File

  • Source
  • Markup
XTPMarkupTypedSimpleStack.h
Go to the documentation of this file.
1
23#if !defined(__XTPMARKUPTYPEDSIMPLESTACK_H__)
24# define __XTPMARKUPTYPEDSIMPLESTACK_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33template<class TYPE>
34class CXTPMarkupTypedSimpleStack
35{
36public:
37 CXTPMarkupTypedSimpleStack()
38 {
39 m_pHead = NULL;
40 m_pTail = NULL;
41 }
42
43 BOOL IsEmpty() const
44 {
45 return m_pHead == NULL;
46 }
47
48 void AddTail(TYPE* pPart)
49 {
50 if (m_pTail != NULL)
51 {
52 m_pTail->m_pNextChain = pPart;
53 }
54 else
55 {
56 m_pTail = m_pHead = pPart;
57 }
58 m_pTail = pPart;
59 }
60
61 void AddHead(TYPE* pPart)
62 {
63 if (m_pHead != NULL)
64 {
65 pPart->m_pNextChain = m_pHead;
66 m_pHead = pPart;
67 }
68 else
69 {
70 m_pTail = m_pHead = pPart;
71 }
72 }
73
74 TYPE* RemoveHead()
75 {
76 if (NULL == m_pHead)
77 return NULL;
78
79 TYPE* pHead = m_pHead;
80
81 if (m_pHead == m_pTail)
82 {
83 m_pHead = m_pTail = NULL;
84 }
85 else
86 {
87 m_pHead = pHead->m_pNextChain;
88 _ASSERTE(NULL != m_pHead);
89 }
90
91 pHead->m_pNextChain = NULL;
92
93 return pHead;
94 }
95
96 TYPE* GetHead() const
97 {
98 return m_pHead;
99 }
100
101 TYPE* GetTail() const
102 {
103 return m_pTail;
104 }
105
106 BOOL Remove(TYPE* p)
107 {
108 _ASSERTE(p != NULL);
109 if (!p)
110 return FALSE;
111
112 if (m_pHead == m_pTail)
113 {
114 if (p != m_pHead)
115 return FALSE;
116
117 p->m_pNextChain = NULL;
118 m_pHead = m_pTail = NULL;
119 return TRUE;
120 }
121
122 if (m_pHead == p)
123 {
124 m_pHead = p->m_pNextChain;
125 p->m_pNextChain = NULL;
126 return TRUE;
127 }
128
129 TYPE* pTest = m_pHead;
130 while (pTest != NULL && pTest->m_pNextChain != p)
131 pTest = pTest->m_pNextChain;
132
133 if (pTest != NULL)
134 {
135 if (m_pTail == p)
136 m_pTail = pTest;
137 pTest->m_pNextChain = p->m_pNextChain;
138 p->m_pNextChain = NULL;
139 return TRUE;
140 }
141 return FALSE;
142 }
143
144protected:
145 TYPE* m_pHead;
146 TYPE* m_pTail;
147};
148
149# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
151#endif // !defined(__XTPMARKUPTYPEDSIMPLESTACK_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h


Toolkit Pro: Member List

XTP_EDIT_NMHDR_DOCMODIFIED Member List

This is the complete list of members for XTP_EDIT_NMHDR_DOCMODIFIED, including all inherited members.

bModified | XTP_EDIT_NMHDR_DOCMODIFIED
nmhdr | XTP_EDIT_NMHDR_DOCMODIFIED


Toolkit Pro: XTPGridControl.h Source File

  • Source
  • GridControl
XTPGridControl.h
Go to the documentation of this file.
1
23#if !defined(__XTPGRIDCONTROL_H__)
24# define __XTPGRIDCONTROL_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPCompatibleDC;
34class CXTPPropExchange;
35class CXTPToolTipContext;
36class CXTPImageManager;
37class CXTPMarkupContext;
38
39struct XTP_GRIDRECORDITEM_DRAWARGS;
40struct XTP_GRIDRECORDITEM_METRICS;
41struct XTP_GRIDRECORDITEM_ARGS;
42struct XTP_NM_GRIDTOOLTIPINFO;
43
44class CXTPGridRecords;
45class CXTPGridRecordItem;
46class CXTPGridColumns;
47class CXTPGridGroups;
48class CXTPGridColumn;
49class CXTPGridRecord;
50class CXTPGridRows;
51class CXTPGridRow;
52class CXTPGridPaintManager;
53class CXTPGridColumnOrder;
54class CXTPGridInplaceEdit;
55class CXTPGridInplaceButtons;
56class CXTPGridInplaceList;
57class CXTPGridNavigator;
58class CXTPGridIconNavigator;
59class CXTPGridRecordItemConstraint;
60class CXTPGridDataManager;
61class CXTPGridHyperlink;
62class CXTPGridRecordItemRange;
63class CXTPGridSelectedRows;
64class CXTPGridBehavior;
65class CXTPGridBehaviorRowMouseButton;
66class CXTPGridTip;
67class CXTPGridSection;
68class CXTPGridSections;
69class CXTPGridBorder;
70class CXTPGridHitTestInfo;
71
106struct XTP_NM_GRIDITEMMETRICS
107{
108 NMHDR hdr;
109 XTP_GRIDRECORDITEM_DRAWARGS* pDrawArgs;
111 XTP_GRIDRECORDITEM_METRICS* pItemMetrics;
113};
114
136struct XTP_NM_GRIDDRAGDROP
137{
138 NMHDR hdr;
139 CXTPGridRecords* pRecords;
140 CXTPGridRecord* pTargetRecord;
141 int nTargetRow;
142 BOOL bAbove;
143 DROPEFFECT dropEffect;
144 CPoint pt;
145 int nState;
146 DWORD dwKeyState;
147 COleDataSource* pDataSource;
148 COleDataObject* pDataObject;
149 BOOL bReturnValue;
150};
151
160struct XTP_NM_GRIDPREVIEWKEYDOWN
161{
162 NMHDR hdr;
164 UINT nChar;
165 UINT nRepCnt;
166 UINT nFlags;
169 BOOL bCancel;
170};
171
185enum XTPGridMouseMode
186{
187 xtpGridMouseNothing,
188 xtpGridMouseOverColumnDivide,
189 xtpGridMousePrepareDragColumn,
190 xtpGridMouseDraggingColumn,
191 xtpGridMouseOverRowDivide,
192};
193
206enum XTPGridDragDrop
207{
208 xtpGridAllowDrop = 1,
209 xtpGridAllowDragCopy = 2,
210 xtpGridAllowDragMove = 4,
211 xtpGridAllowDrag = 6,
212 xtpGridDontDropAsText = 8
213};
214
219enum XTPGridDropMarker
220{
221 xtpGridDropBetween = 1,
222 xtpGridDropSelect = 2,
223};
224
236enum XTPGridWatermarkAlignment
237{
238 xtpGridWatermarkUnknown = 0,
240 xtpGridWatermarkLeft = 0x0001,
242 xtpGridWatermarkCenter = 0x0002,
244 xtpGridWatermarkRight = 0x0004,
246 xtpGridWatermarkHmask = 0x000F,
247 xtpGridWatermarkTop = 0x0010,
248 xtpGridWatermarkVCenter = 0x0020,
249 xtpGridWatermarkBottom = 0x0040,
251 xtpGridWatermarkVmask = 0x00F0,
252 xtpGridWatermarkStretch = 0x0100,
253 xtpGridWatermarkEnlargeOnly = 0x0200,
255 xtpGridWatermarkShrinkOnly = 0x0400,
257 xtpGridWatermarkPreserveRatio = 0x0800,
258};
259
271enum XTPGridElementRect
272{
273 xtpGridElementRectGridArea = 0,
274 xtpGridElementRectGroupByArea,
275 xtpGridElementRectHeaderArea,
276 xtpGridElementRectFooterArea,
277 xtpGridElementRectHeaderRecordsArea,
278 xtpGridElementRectFooterRecordsArea,
279 xtpGridElementRectHeaderRecordsDividerArea,
281 xtpGridElementRectFooterRecordsDividerArea,
283};
284
296enum XTPGridFilterMode
297{
298 xtpGridFilterTreeSimple = 0,
299 xtpGridFilterTreeByParentAndChildren = 1,
301 xtpGridFilterTreeByEndChildrenOnly = 2
303};
304
309enum XTPGridScrollUpdateMode
310{
311 xtpGridScrollUpdateModeImmediate,
312 xtpGridScrollUpdateModeDeferred
313};
314
319enum XTPGridScrollMode
320{
321 xtpGridScrollModeNone = 0,
322 xtpGridScrollModeBlockCount = 1,
323 xtpGridScrollModeBlockSize = 3,
324 xtpGridScrollModeSmooth = 2,
326 // Deprecated
327
328 xtpGridScrollModeBlock = xtpGridScrollModeBlockCount,
330};
331
336struct XTPGridInputState
337{
338 XTPGridInputState()
339 : ptMouse(-1, -1)
340 , bKeyControl(FALSE)
341 , bKeyShift(FALSE)
342 , nRow(-1)
343 , bSelected(FALSE)
344 {
345 // Nothing.
346 }
347
348 CPoint ptMouse;
349 BOOL bKeyControl;
350 BOOL bKeyShift;
351 int nRow;
352 BOOL bSelected;
353};
354
476class _XTP_EXT_CLASS CXTPGridControl
477 : public CWnd
478 , public CXTPAccessible
479{
481 DECLARE_DYNCREATE(CXTPGridControl)
482 DECLARE_INTERFACE_MAP()
483 XTP_DECLARE_CMDTARGETPROVIDER_INTERFACE()
484
485 friend class CXTPGridSubListControl;
486 friend class CXTPGridRow;
487 friend class CXTPGridGroupRow;
488 friend class CXTPGridHeader;
489 friend class CXTPGridNavigator;
490 friend class CXTPGridInplaceEdit;
491 friend class CXTPGridHeaderDragWnd;
492 friend class CXTPGridInplaceList;
493 friend class CXTPGridColumn;
494 friend class CXTPGridView;
495 class CGridDropTarget;
498public:
503 class _XTP_EXT_CLASS CUpdateContext
504 {
505 public:
511 CUpdateContext(CXTPGridControl* pControl)
512 {
513 m_pControl = pControl;
514 pControl->BeginUpdate();
515 }
516
522 ~CUpdateContext()
523 {
524 m_pControl->EndUpdate();
525 }
526
527 protected:
528 CXTPGridControl* m_pControl;
529 };
530
531public:
548 static BOOL AFX_CDECL UseGridCustomHeap();
549
571 static BOOL AFX_CDECL UseRowBatchAllocation();
572
581 static void AFX_CDECL FreeRowBatchExtraData();
582
609 CXTPGridControl();
610
615 virtual ~CXTPGridControl();
616
639 BOOL Create(DWORD dwStyle, const RECT& rect, CWnd* pParentWnd, UINT nID,
640 CCreateContext* pContext = NULL);
641
647 virtual void SerializeState(CArchive& ar);
648
654 virtual void DoPropExchange(CXTPPropExchange* pPX);
655
677 CXTPGridColumn* AddColumn(CXTPGridColumn* pColumn);
678
703 virtual CXTPGridRecord* AddRecord(CXTPGridRecord* pRecord);
704
731 virtual void AddRecordEx(CXTPGridRecord* pRecord, CXTPGridRecord* pParentRecord = NULL,
732 int nRowChildIndex = -1, int nRecordChildIndex = -1);
733
749 virtual BOOL RemoveRecordEx(CXTPGridRecord* pRecord, BOOL bAdjustLayout = TRUE,
750 BOOL bRemoveFromParent = TRUE);
751
766 virtual BOOL RemoveRowEx(CXTPGridRow* pRow, BOOL bAdjustLayout = TRUE);
767
779 virtual void UpdateRecord(CXTPGridRecord* pRecord, BOOL bUpdateChildren);
780
810 void BeginUpdate();
811
817 void ResetContent(BOOL bUpdateControl = TRUE);
818
838 void EndUpdate();
839
846 int GetLockUpdateCount() const;
847
858 void RedrawControl();
859
866 CXTPToolTipContext* GetToolTipContext() const;
867
886 CLIPFORMAT EnableDragDrop(LPCTSTR lpszClipboardFormat, DWORD dwFlags,
887 DWORD dwDropMarkerFlags = xtpGridDropBetween);
888
895 void SetDropMarkerFlags(DWORD dwDropMarkerFlags);
896
903 DWORD GetDropMarkerFlags() const;
904
927 void SetGridStyle(XTPGridOrientation orientation, XTPGridGridStyle gridStyle);
928
930 _XTP_DEPRECATED_IN_FAVOR(SetGridStyle)
931 void SetReportStyle(XTPGridOrientation orientation, XTPGridGridStyle gridStyle);
950 XTPGridGridStyle GetGridStyle(XTPGridOrientation orientation) const;
951
953 _XTP_DEPRECATED_IN_FAVOR(GetGridStyle)
954 XTPGridGridStyle GetReportStyle(XTPGridOrientation orientation) const;
969 COLORREF SetGridColor(COLORREF clrGridLine);
970
972 _XTP_DEPRECATED_IN_FAVOR(SetGridColor)
973 COLORREF SetReportColor(COLORREF clrGridLine);
993 CXTPGridColumns* GetColumns() const;
994
1003 CXTPGridPaintManager* GetPaintManager() const;
1004
1010 void SetPaintManager(CXTPGridPaintManager* pPaintManager);
1011
1020 CXTPGridNavigator* GetNavigator() const;
1021
1035 virtual void Populate();
1036
1048 virtual void PopulateHeaderRows();
1049
1061 virtual void PopulateFooterRows();
1062
1074 void EnsureVisible(CXTPGridRow* pRow);
1075
1087 void EnsureVisible(CXTPGridColumn* pCheckColumn);
1088
1098 virtual BOOL HitTest(CPoint pt, CXTPGridHitTestInfo* pInfo) const;
1099
1108 CXTPGridRow* HitTest(CPoint pt) const;
1109
1121 CXTPGridSelectedRows* GetSelectedRows() const;
1122
1129 CXTPGridRow* GetFocusedRow() const;
1130
1139 BOOL SetFocusedRow(CXTPGridRow* pRow, BOOL bControlKey = FALSE);
1140
1150 BOOL SetFocusedRow(CXTPGridRow* pRow, BOOL bShiftKey, BOOL bControlKey);
1151
1162 BOOL SetFocusedRow(BOOL bEnsureVisible, CXTPGridRow* pRow, BOOL bShiftKey, BOOL bControlKey);
1163
1176 int GetGridAreaRows(int nStartRow, BOOL bMoveDown);
1177
1179 _XTP_DEPRECATED_IN_FAVOR(GetGridAreaRows)
1180 int GetReportAreaRows(int nStartRow, BOOL bMoveDown);
1194 void SetTopRow(int nIndex);
1195
1204 int GetTopRowIndex() const;
1205
1215 void SetScrollOffsetH(int nOffset);
1216
1222 void SetScrollOffsetV(int nOffset);
1223
1229 void SetLayoutRTL(BOOL bRightToLeft);
1230
1237 BOOL IsLayoutRTL();
1238
1250 void EnablePreviewMode(BOOL bIsPreviewMode);
1251
1260 BOOL IsPreviewMode() const;
1261
1273 void ShowGroupBy(BOOL bEnable = TRUE);
1274
1287 BOOL IsGroupByVisible() const;
1288
1297 void ShowHeader(BOOL bShow = TRUE);
1298
1308 BOOL IsHeaderVisible() const;
1309
1318 void ShowFooter(BOOL bShow = TRUE);
1319
1329 BOOL IsFooterVisible() const;
1330
1343 void ShadeGroupHeadings(BOOL bEnable = TRUE);
1344
1358 BOOL IsShadeGroupHeadingsEnabled() const;
1359
1369 void SetGroupRowsBold(BOOL bBold = TRUE);
1370
1381 BOOL IsGroupRowsBold() const;
1382
1389 int GetFreezeColumnsCount() const;
1390
1399 int GetFreezeColumnsCount(int& nLastIndex) const;
1400
1407 int GetFreezeColumnsIndex() const;
1408
1416 void SetFreezeColumnsCount(int nCount, BOOL bReserved = FALSE);
1417
1424 int GetDisableReorderColumnsCount() const;
1425
1431 void SetDisableReorderColumnsCount(int nCount);
1432
1442 BOOL IsFullColumnScrolling() const;
1443
1452 void SetFullColumnScrolling(BOOL bSet);
1453
1459 void ReleaseItem(int nIndex);
1460
1471 void PinFooterRows(BOOL bPin = FALSE);
1472
1482 BOOL IsFooterRowsPinned() const;
1483
1495 void PinFooterRowsPrinted(BOOL bPin = FALSE);
1496
1507 BOOL IsFooterRowsPinnedPrinted() const;
1508
1514 void EnableMarkup(BOOL bEnable = TRUE);
1515
1522 CXTPMarkupContext* GetMarkupContext() const;
1523
1532 CXTPImageManager* GetImageManager() const;
1533
1548 void SetImageManager(CXTPImageManager* pImageManager);
1549
1574 void SetImageList(CImageList* pImageList);
1575
1587 CXTPGridHeader* GetGridHeader() const;
1588
1590 _XTP_DEPRECATED_IN_FAVOR(GetGridHeader)
1591 CXTPGridHeader* GetReportHeader() const;
1604 void SetGridHeader(CXTPGridHeader* pGridHeader);
1605
1607 _XTP_DEPRECATED_IN_FAVOR(SetGridHeader)
1608 void SetReportHeader(CXTPGridHeader* pGridHeader);
1622 int GetIndent(int nLevel) const;
1623
1644 LRESULT SendMessageToParent(CXTPGridRow* pRow, CXTPGridRecordItem* pItem,
1645 CXTPGridColumn* pColumn, UINT nMessage, CPoint* pPoint,
1646 int nHyperlink = -1) const;
1647
1656 LRESULT SendNotifyMessage(UINT nMessage, NMHDR* pNMHDR = NULL) const;
1657
1667 void CollapseAll();
1668
1680 void ExpandAll(BOOL bRecursive = FALSE);
1681
1691 BOOL IsMultipleSelection() const;
1692
1701 void SetMultipleSelection(BOOL bMultipleSelection);
1702
1714 BOOL IsMultiSelectionMode() const;
1715
1726 void SetMultiSelectionMode(BOOL bMultiSelectionMode);
1727
1734 void EnableToolTips(BOOL bEnable);
1735
1747 void SkipGroupsFocus(BOOL bSkipFocus);
1748
1759 BOOL IsSkipGroupsFocusEnabled() const;
1760
1767 int GetHeaderIndent() const;
1768
1773 virtual void AdjustScrollBars();
1774
1779 virtual void AdjustLayout();
1780
1787 CXTPGridColumn* GetFocusedColumn() const;
1788
1796 BOOL SetFocusedColumn(CXTPGridColumn* pColumn);
1797
1805 void SetSelectionState(int index, int state);
1806
1815 void EnsureFocusedRowVisible(BOOL bEnsureFocusedRowVisible);
1816
1823 BOOL IsEnsureFocusedRowVisible() const;
1824
1836 void FocusSubItems(BOOL bFocusSubItems);
1837
1850 BOOL IsFocusSubItems() const;
1851
1865 void EditOnClick(BOOL bEditOnClick);
1866
1881 BOOL IsEditOnClick() const;
1882
1889 void EditOnDelayClick(BOOL bEditOnDelayClick);
1890
1898 BOOL IsEditOnDelayClick() const;
1899
1913 void EditOnDoubleClick(BOOL bEditOnClick);
1914
1929 BOOL IsEditOnDoubleClick() const;
1930
1937 int GetLastRqstEditRow() const;
1938
1945 int GetLastRqstEditCol() const;
1946
1954 void SetLastRqstEdit(int iRqstEditRow, int iRqstEditCol);
1955
1960 void EnsureStopLastRqstTimer();
1961
1966 void StartLastRqstTimer();
1967
1974 UINT_PTR GetDelayEditTimer() const;
1975
1980 void EnsureStopDelayEditTimer();
1981
1986 void StartDelayEditTimer();
1987
1998 void SetAutoCheckItems(BOOL bAutoCheck);
1999
2011 BOOL IsAutoCheckItems() const;
2012
2026 void EditItem(XTP_GRIDRECORDITEM_ARGS* pItemArgs);
2027
2034 CXTPGridInplaceEdit* GetInplaceEdit() const;
2035
2042 CXTPGridInplaceButtons* GetInplaceButtons() const;
2043
2050 CXTPGridInplaceList* GetInplaceList() const;
2051
2058 BOOL HasFocus() const;
2059
2066 CXTPGridRecordItem* GetActiveItem() const;
2067
2074 CXTPGridRecordItem* GetFocusedRecordItem() const;
2075
2082 void SetTreeIndent(int nIndent);
2083
2115 void SetVirtualMode(CXTPGridRecord* pVirtualRecord, int nCount, int nFields = 0);
2116
2125 BOOL IsVirtualMode() const;
2126
2135 virtual CString GetFilterText();
2136
2146 virtual void SetFilterText(LPCTSTR strFilterText);
2147
2159 virtual BOOL IsFilterHiddenColumns() const;
2160
2172 virtual void SetFilterHiddenColumns(BOOL bFilterHidden);
2173
2182 void SetRecordsTreeFilterMode(int nMode);
2183
2193 int GetRecordsTreeFilterMode() const;
2194
2202 BOOL RegisterWindowClass(HINSTANCE hInstance = NULL);
2203
2213 virtual BOOL CanCut();
2214
2224 virtual BOOL CanCopy();
2225
2235 virtual BOOL CanPaste();
2236
2245 virtual void Cut();
2246
2255 virtual void Copy();
2256
2265 virtual void Paste();
2266
2275 virtual BOOL IsEditMode();
2276
2292 virtual void SetRowsCompareFunc(XTPGridRowsCompareFunc pCompareFunc);
2293
2300 BOOL IsSortRecordChilds() const;
2301
2308 void SetSortRecordChilds(BOOL bSortRecordChildren);
2309
2316 int GetHScrollStep() const;
2317
2323 void SetHScrollStep(int nStep);
2324
2331 UINT GetAutoVScrollTimerResolution() const;
2332
2340 void SetAutoVScrollTimerResolution(UINT nNewTimerResolution);
2341
2348 BOOL IsPreviewAllowEdit() const;
2349
2356 void PreviewAllowEdit(BOOL bAllowEdit);
2357
2364 BOOL IsLockExpand() const;
2365
2372 void LockExpand(BOOL bLockExpand);
2373
2381 void Recalc(BOOL bAll = FALSE);
2382
2389 void EnableDoubleBuffering(BOOL bEnable);
2390
2399 BOOL IsDoubleBuffering() const;
2400
2412 BOOL IsInitialSelectionEnabled() const;
2413
2425 void InitialSelectionEnable(BOOL bEnable);
2426
2435 BOOL IsRowFocusVisible() const;
2436
2444 void ShowRowFocus(BOOL bShow);
2445
2455 int GetWatermarkAlignment() const;
2456
2465 void SetWatermarkAlignment(int nWatermarkAlignment);
2466
2474 void DrawWatermark(CDC* pDC, CRect rcWatermark, CRect rcClient);
2475
2486 CRect GetElementRect(XTPGridElementRect nElement) const;
2487
2489 _XTP_DEPRECATED_IN_FAVOR_("GetElementRect with XTPGridElementRect")
2490 CRect GetElementRect(int nElement) const;
2499 CXTPGridDataManager* GetDataManager();
2500
2509 void SetMouseMode(XTPGridMouseMode nMode);
2510
2520 XTPGridMouseMode GetMouseMode() const;
2521
2528 virtual HBITMAP GetWatermarkBitmap() const;
2529
2538 virtual BOOL SetWatermarkBitmap(HBITMAP hBitmap, BYTE Transparency);
2539
2548 virtual BOOL SetWatermarkBitmap(LPCTSTR szPath, BYTE Transparency);
2549
2562 virtual CXTPGridColumn* GetNextFocusableColumn(CXTPGridRow* pRow, int nColumnIndex,
2563 int nDirection);
2564
2565 CXTPGridBehavior* GetBehavior() const;
2566
2572 void ShowIconWhenEditing(BOOL bShow);
2573
2580 BOOL IsShowIconWhenEditing();
2581
2588 void SetFastDeselectMode(BOOL bFastDeselect = TRUE);
2589
2595 void SetIconColumn(CXTPGridColumn* pColumn);
2596
2605 void CreateIconColumn(BOOL bUseColumnForNum = FALSE, int nWidth = 40);
2606
2619 void AssignIconViewPropNumAndIconNum(int nCol = 0, int nIcon = 0, BOOL bUseColumnForNum = FALSE,
2620 int nWidth = 20);
2621
2628 void SetIconView(BOOL bIconView = TRUE);
2629
2636 BOOL IsIconView() const;
2637
2644 int GetRowsPerLine() const;
2645
2653 int GetNumRowsOnLine(int iTotalWidth) const;
2654
2660 void SetNavigator(CXTPGridNavigator* pNavigator);
2661
2667 void ShowRowNumber(BOOL bSet);
2668
2675 BOOL IsShowRowNumber();
2676
2686 BOOL SetCellText(int row, int col, CString sText);
2687
2697 BOOL SetCellFormula(int row, int col, CString sFormula);
2698
2703 void UnselectGroupRows();
2704
2709 void ReleaseSorted();
2710
2717 int GetLeftOffset() const;
2718
2726 BOOL IsDragMode() const;
2727
2736 int GetDragSensitivityX() const;
2737
2747 void SetDragSensitivityX(int nDragSensitivityX);
2748
2757 int GetDragSensitivityY() const;
2758
2768 void SetDragSensitivityY(int nDragSensitivityY);
2769
2777 void SetIconViewToDefaults();
2778
2788 XTPGridScrollMode GetScrollMode(XTPGridOrientation orientation) const;
2789
2798 void SetScrollMode(XTPGridOrientation orientation, XTPGridScrollMode scrollMode);
2799
2806 CXTPGridSections* GetSections() const;
2807
2814 virtual BOOL IsCellMergingAllowed() const;
2815
2816# if XTP_GRID_DEPRECATED()
2817
2830 XTPGridGridStyle GetGridStyle(BOOL bVertical) const;
2831
2833 _XTP_DEPRECATED_IN_FAVOR(GetGridStyle)
2834 XTPGridGridStyle GetReportStyle(BOOL bVertical) const;
2856 void SetGridStyle(BOOL bVertical, XTPGridGridStyle gridStyle);
2857
2859 _XTP_DEPRECATED_IN_FAVOR(SetGridStyle)
2860 void SetReportStyle(BOOL bVertical, XTPGridGridStyle gridStyle);
2875 CXTPGridRecords* GetRecords() const;
2876
2889 CXTPGridRecords* GetHeaderRecords() const;
2890
2903 CXTPGridRecords* GetFooterRecords() const;
2904
2921 CXTPGridRows* GetRows() const;
2922
2936 CXTPGridRows* GetHeaderRows() const;
2937
2951 CXTPGridRows* GetFooterRows() const;
2952
2959 CRect GetGridRectangle() const;
2960
2962 _XTP_DEPRECATED_IN_FAVOR(GetGridRectangle)
2963 CRect GetReportRectangle() const;
2972 CRect GetHeaderRowsRect() const;
2973
2980 CRect GetFooterRowsRect() const;
2981
2990 void HeaderRowsAllowAccess(BOOL bAllowAccess);
2991
3000 void FooterRowsAllowAccess(BOOL bAllowAccess);
3001
3011 BOOL IsHeaderRowsAllowAccess() const;
3012
3022 BOOL IsFooterRowsAllowAccess() const;
3023
3032 BOOL IsSelectionEnabled() const;
3033
3041 void SelectionEnable(BOOL bEnable);
3042
3051 void HeaderRowsEnableSelection(BOOL bEnable);
3052
3062 BOOL IsHeaderRowsSelectionEnabled() const;
3063
3072 void FooterRowsEnableSelection(BOOL bEnable);
3073
3083 BOOL IsFooterRowsSelectionEnabled() const;
3084
3098 void AllowEdit(BOOL bAllowEdit);
3099
3109 BOOL IsAllowEdit() const;
3110
3125 void HeaderRowsAllowEdit(BOOL bAllowEdit);
3126
3137 BOOL IsHeaderRowsAllowEdit() const;
3138
3153 void FooterRowsAllowEdit(BOOL bAllowEdit);
3154
3165 BOOL IsFooterRowsAllowEdit() const;
3166
3168 // Allow Group
3170
3179 void AllowGroup(BOOL bAllowGroup);
3180
3189 BOOL IsAllowGroup() const;
3190
3199 void HeaderRowsAllowGroup(BOOL bAllowGroup);
3200
3209 BOOL IsHeaderRowsAllowGroup() const;
3210
3219 void FooterRowsAllowGroup(BOOL bAllowGroup);
3220
3229 BOOL IsFooterRowsAllowGroup() const;
3230
3232 // Allow Sort
3234
3243 void AllowSort(BOOL bAllowSort);
3244
3253 BOOL IsAllowSort() const;
3254
3263 void HeaderRowsAllowSort(BOOL bAllowSort);
3264
3273 BOOL IsHeaderRowsAllowSort() const;
3274
3283 void FooterRowsAllowSort(BOOL bAllowSort);
3284
3293 BOOL IsFooterRowsAllowSort() const;
3294
3296 // Show Rows
3298
3307 void ShowHeaderRows(BOOL bShow = TRUE);
3308
3317 BOOL IsHeaderRowsVisible() const;
3318
3327 void ShowFooterRows(BOOL bShow = TRUE);
3328
3337 BOOL IsFooterRowsVisible() const;
3338
3361 void SetTheme(XTPGridPaintTheme paintTheme, BOOL bEnableMetrics = FALSE);
3362
3370 XTPGridPaintTheme GetCurrentTheme() const;
3371
3372# endif // XTP_GRID_DEPRECATED()
3373
3374protected:
3375 int GetPageRowCount(CDC* pDC) const;
3376
3377 void AdjustScrollBarH(BOOL bUpdate, UINT nMask); /* Adjusts the horizontal scrollbar. */
3378 void AdjustScrollBarV(BOOL bUpdate, UINT nMask); /* Adjusts the vertical scrollbar. */
3379 void UpdateScrollBarV();
3380
3381 void Paint(CDC* pDC);
3382
3388 virtual void OnDraw(CDC* pDC);
3389
3405 virtual int DrawRows(CDC* pDC, CRect& rcClient, int y, CXTPGridRows* pRows, int nTopRow,
3406 int nColumnFrom, int nColumnTo, int* pnHeight = NULL);
3407
3408 virtual void DrawIconView(CDC* pDC, CRect& rcClient);
3409
3416 virtual void DrawNoItems(CDC* pDC, const CRect& rcClient);
3417
3427 BOOL IsChanged() const;
3428
3437 void SetChanged(BOOL bChanged = TRUE);
3438
3445 virtual void ReSortRows();
3446
3451 void UpdateSubList();
3452
3465 virtual int InsertRow(int nIndex, CXTPGridRow* pRow);
3466
3482 virtual BOOL ApplyFilter(CXTPGridRecord* pRecord, CString strFilterText, BOOL bIncludePreview);
3483
3493 virtual void OnSelectionChanged();
3494
3508 virtual BOOL OnFocusChanging(CXTPGridRow* pNewRow, CXTPGridColumn* pNewCol);
3509
3518 virtual void GetItemMetrics(XTP_GRIDRECORDITEM_DRAWARGS* pDrawArgs,
3519 XTP_GRIDRECORDITEM_METRICS* pItemMetrics);
3520
3528 virtual CXTPGridRow* CreateRow();
3529
3537 virtual CXTPGridGroupRow* CreateGroupRow();
3538
3546 virtual CXTPGridRow* CreateHeaderFooterRow();
3547
3558 virtual void OnBeginDrag(CPoint point);
3559
3571 virtual void OnBeginDrag(CPoint point, UINT nFlags);
3572
3590 virtual BOOL OnBeforeCopyToText(CXTPGridRecord* pRecord, CStringArray& rarStrings);
3591
3615 virtual BOOL OnBeforePasteFromText(CStringArray& arStrings, CXTPGridRecord** ppRecord);
3616
3634 virtual BOOL OnBeforePaste(CXTPGridRecord** ppRecord);
3635
3658 virtual BOOL OnPreviewKeyDown(UINT& rnChar, UINT nRepCnt, UINT nFlags);
3659
3668 virtual int OnGetColumnDataBestFitWidth(CXTPGridColumn* pColumn);
3669
3684 virtual int OnGetItemsCaptionMaxWidth(CDC* pDC, CXTPGridRows* pRows, CXTPGridColumn* pColumn,
3685 int nStartRow = 0, int nRowsCount = -1);
3686
3696 virtual void EnsureStartAutoVertScroll();
3697
3707 virtual void EnsureStopAutoVertScroll();
3708
3721 virtual void DoAutoVertScrollIfNeed(CPoint ptClick, CPoint pt);
3722
3735 virtual int GetRowsHeight(CXTPGridRows* pRows, int nTotalWidth, int nMaxHeight = -1);
3736
3749 virtual BOOL OnConstraintSelecting(CXTPGridRow* pRow, CXTPGridRecordItem* pItem,
3750 CXTPGridColumn* pColumn,
3751 CXTPGridRecordItemConstraint* pConstraint);
3752
3767 virtual const XTP_NM_GRIDTOOLTIPINFO& OnGetToolTipInfo(CXTPGridRow* pRow,
3768 CXTPGridRecordItem* pItem,
3769 CString& rstrToolTipText);
3770
3777 void AdjustIndentation();
3778
3802 virtual DROPEFFECT OnDragOver(COleDataObject* pDataObject, DWORD dwKeyState, CPoint point,
3803 int nState);
3804
3819 virtual BOOL OnDrop(COleDataObject* pDataObject, DROPEFFECT dropEffect, CPoint point);
3820
3827 virtual void RelayToolTipEvent(UINT message);
3828
3835 static UINT AFX_CDECL GetMouseScrollLines();
3836
3838 virtual CString _GetSelectedRowsVisibleColsText();
3839 BOOL _GetSelectedRows(CXTPGridRecords* pRecords,
3840 CXTPInternalCollectionT<CXTPGridRow>* pRows = NULL);
3841
3842 void _SelectChilds(CXTPGridRecords* pRecords);
3843 void _SelectRows(CXTPGridRecords* pRecords);
3844
3845 virtual BOOL _ReadRecordsFromText(LPCTSTR pcszText, CXTPGridRecords& rarRecords);
3846 virtual CXTPGridRecord* _CreateRecodFromText(LPCTSTR pcszRecord);
3847
3848 virtual BOOL _WriteSelectedRowsData(CXTPPropExchange* pPX);
3849 virtual BOOL _ReadRecordsFromData(CXTPPropExchange* pPX, CXTPGridRecords& rarRecords);
3850 BOOL _WriteRecordsData(CXTPPropExchange* pPX, CXTPGridRecords* pRecords);
3851 virtual void DrawDropMarker(CDC* pDC);
3852 virtual void DrawExtDropMarker(CDC* pDC, int y);
3853 virtual BOOL _ApplyFilter(CXTPGridRecord* pRecord, CString strFilterText, BOOL bIncludePreview);
3858 // System accessibility support.
3859
3860 virtual HRESULT GetAccessibleParent(IDispatch** ppdispParent);
3861 virtual HRESULT GetAccessibleChildCount(long* pcountChildren);
3862 virtual HRESULT GetAccessibleChild(VARIANT varChild, IDispatch** ppdispChild);
3863 virtual HRESULT GetAccessibleName(VARIANT varChild, BSTR* pszName);
3864 virtual HRESULT GetAccessibleRole(VARIANT varChild, VARIANT* pvarRole);
3865 virtual HRESULT AccessibleLocation(long* pxLeft, long* pyTop, long* pcxWidth, long* pcyHeight,
3866 VARIANT varChild);
3867 virtual HRESULT AccessibleHitTest(long xLeft, long yTop, VARIANT* pvarChild);
3868 virtual HRESULT GetAccessibleState(VARIANT varChild, VARIANT* pvarState);
3869 virtual CCmdTarget* GetAccessible();
3872 //{{AFX_VIRTUAL(CXTPGridControl)
3873 virtual BOOL Create(LPCTSTR lpszClassName, LPCTSTR lpszWindowName, DWORD dwStyle,
3874 const RECT& rect, CWnd* pParentWnd, UINT nID,
3875 CCreateContext* pContext = NULL);
3876 virtual void PreSubclassWindow();
3877 virtual BOOL PreTranslateMessage(MSG* pMsg);
3878 virtual BOOL OnWndMsg(UINT message, WPARAM wParam, LPARAM lParam, LRESULT* pResult);
3879 virtual INT_PTR OnToolHitTest(CPoint point, TOOLINFO* pTI) const;
3880 virtual CScrollBar* GetScrollBarCtrl(int nBar) const;
3881 //}}AFX_VIRTUAL
3882
3883 //{{AFX_MSG(CXTPGridControl)
3884 afx_msg LRESULT OnPrintClient(WPARAM wParam, LPARAM lParam);
3885
3886 // Window events
3887 afx_msg int OnCreate(LPCREATESTRUCT lpCreateStruct);
3888 afx_msg void OnEnable(BOOL bEnable);
3889 afx_msg BOOL OnEraseBkgnd(CDC* pDC);
3890 afx_msg void OnPaint();
3891 afx_msg void OnSize(UINT nType, int cx, int cy);
3892 afx_msg void OnTimer(UINT_PTR uTimerID);
3893 afx_msg void OnNcPaint();
3894
3895 // Focus
3896 afx_msg void OnSetFocus(CWnd* pOldWnd);
3897 afx_msg void OnKillFocus(CWnd* pNewWnd);
3898
3899 // Scrolling
3900 afx_msg void OnVScroll(UINT nSBCode, UINT nPos, CScrollBar* pScrollBar);
3901 afx_msg void OnHScroll(UINT nSBCode, UINT nPos, CScrollBar* pScrollBar);
3902
3903 // Mouse events
3904 afx_msg void OnLButtonDown(UINT nFlags, CPoint point);
3905 afx_msg void OnLButtonUp(UINT nFlags, CPoint point);
3906 afx_msg void OnLButtonDblClk(UINT nFlags, CPoint point);
3907 afx_msg void OnRButtonDown(UINT nFlags, CPoint point);
3908 afx_msg void OnRButtonUp(UINT nFlags, CPoint point);
3909 afx_msg void OnMouseMove(UINT nFlags, CPoint point);
3910 afx_msg BOOL OnMouseWheel(UINT nFlags, short zDelta, CPoint point);
3911 afx_msg void OnMouseLeave();
3912
3913 // Key events
3914 afx_msg void OnKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags);
3915 afx_msg void OnKeyUp(UINT nChar, UINT nRepCnt, UINT nFlags);
3916 afx_msg void OnSysKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags);
3917 afx_msg void OnSysKeyUp(UINT nChar, UINT nRepCnt, UINT nFlags);
3918 afx_msg void OnChar(UINT nChar, UINT nRepCnt, UINT nFlags);
3919
3920 afx_msg LRESULT OnNcHitTest(CPoint point);
3921 afx_msg void OnContextMenu(CWnd* pWnd, CPoint pos);
3922
3923 afx_msg BOOL OnSetCursor(CWnd* pWnd, UINT nHitTest, UINT message);
3924 afx_msg void OnCaptureChanged(CWnd* pWnd);
3925 afx_msg void OnSysColorChange();
3926 afx_msg UINT OnGetDlgCode();
3927 afx_msg void OnStyleChanged(int nStyleType, LPSTYLESTRUCT lpStyleStruct);
3928 afx_msg LRESULT OnGetObject(WPARAM wParam, LPARAM lParam);
3929
3930# ifdef _XTP_ACTIVEX
3931 // Dispatch and event IDs
3932public:
3933 enum
3934 {
3935 //{{AFX_DISP_ID(CXTPGridControl)
3936 eventidDrawItem = 11L,
3937 eventidMeasureRow = 12L,
3938 eventidDrawPreviewItem = 24L,
3939 eventidMeasurePreviewItem = 33L,
3940 //}}AFX_DISP_ID
3941 };
3942# endif
3943
3944# ifdef _XTP_ACTIVEX
3945
3946public:
3947 void SetCustomDraw(long dwFlags);
3948
3949 // Event maps
3950 //{{AFX_EVENT(CXTPGridControl)
3951 void FireMeasureRow(LPDISPATCH Row, OLE_HANDLE hDC, int nWidth, int* pnHeight)
3952 {
3953 ((COleControl*)GetParent())
3954 ->FireEvent(eventidMeasureRow, EVENT_PARAM(VTS_DISPATCH VTS_HANDLE VTS_I4 VTS_PI4), Row,
3955 hDC, nWidth, pnHeight);
3956 }
3957
3958 void FireMeasureRowV(LPDISPATCH Row, OLE_HANDLE hDC, int nWidth, VARIANT* pHeight)
3959 {
3960 ((COleControl*)GetParent())
3961 ->FireEvent(eventidMeasureRow + 100,
3962 EVENT_PARAM(VTS_DISPATCH VTS_HANDLE VTS_I4 VTS_PVARIANT), Row, hDC, nWidth,
3963 pHeight);
3964 }
3965
3966 void FireDrawItem(LPDISPATCH Row, LPDISPATCH Column, LPDISPATCH Item, OLE_HANDLE hDC, CRect rc,
3967 BOOL* pbDoDefault)
3968 {
3969 ((COleControl*)GetParent())
3970 ->FireEvent(eventidDrawItem,
3971 EVENT_PARAM(VTS_DISPATCH VTS_DISPATCH VTS_DISPATCH VTS_HANDLE VTS_I4 VTS_I4
3972 VTS_I4 VTS_I4 VTS_PBOOL),
3973 Row, Column, Item, hDC, rc.left, rc.top, rc.right, rc.bottom, pbDoDefault);
3974 }
3975
3976 void FireDrawItemV(LPDISPATCH Row, LPDISPATCH Column, LPDISPATCH Item, OLE_HANDLE hDC, CRect rc,
3977 VARIANT* pbDoDefault)
3978 {
3979 ((COleControl*)GetParent())
3980 ->FireEvent(eventidDrawItem + 100,
3981 EVENT_PARAM(VTS_DISPATCH VTS_DISPATCH VTS_DISPATCH VTS_HANDLE VTS_I4 VTS_I4
3982 VTS_I4 VTS_I4 VTS_PVARIANT),
3983 Row, Column, Item, hDC, rc.left, rc.top, rc.right, rc.bottom, pbDoDefault);
3984 }
3985
3986 void FireDrawPreviewItem(LPDISPATCH Row, LPDISPATCH Item, OLE_HANDLE hDC, CRect rc,
3987 BOOL* pbDoDefault)
3988 {
3989 ((COleControl*)GetParent())
3990 ->FireEvent(eventidDrawPreviewItem,
3991 EVENT_PARAM(VTS_DISPATCH VTS_DISPATCH VTS_HANDLE VTS_I4 VTS_I4 VTS_I4 VTS_I4
3992 VTS_PBOOL),
3993 Row, Item, hDC, rc.left, rc.top, rc.right, rc.bottom, pbDoDefault);
3994 }
3995
3996 void FireDrawPreviewItemV(LPDISPATCH Row, LPDISPATCH Item, OLE_HANDLE hDC, CRect rc,
3997 VARIANT* pbDoDefault)
3998 {
3999 ((COleControl*)GetParent())
4000 ->FireEvent(eventidDrawPreviewItem + 100,
4001 EVENT_PARAM(VTS_DISPATCH VTS_DISPATCH VTS_HANDLE VTS_I4 VTS_I4 VTS_I4 VTS_I4
4002 VTS_PVARIANT),
4003 Row, Item, hDC, rc.left, rc.top, rc.right, rc.bottom, pbDoDefault);
4004 }
4005
4006 void FireMeasurePreviewItem(LPDISPATCH Row, OLE_HANDLE hDC, int nWidth, int* pnHeight)
4007 {
4008 ((COleControl*)GetParent())
4009 ->FireEvent(eventidMeasurePreviewItem,
4010 EVENT_PARAM(VTS_DISPATCH VTS_HANDLE VTS_I4 VTS_PI4), Row, hDC, nWidth,
4011 pnHeight);
4012 }
4013
4014 void FireMeasurePreviewItemV(LPDISPATCH Row, OLE_HANDLE hDC, int nWidth, VARIANT* pHeight)
4015 {
4016 ((COleControl*)GetParent())
4017 ->FireEvent(eventidMeasurePreviewItem + 100,
4018 EVENT_PARAM(VTS_DISPATCH VTS_HANDLE VTS_I4 VTS_PVARIANT), Row, hDC, nWidth,
4019 pHeight);
4020 }
4021 //}}AFX_EVENT
4022# endif
4023 //}}AFX_MSG
4025 DECLARE_MESSAGE_MAP()
4027private:
4028 void OnButton(UINT nFlags, CPoint point, CXTPGridBehaviorRowMouseButton* behavior);
4029
4030 int _GetFocusedRowType() const;
4031
4032 int _GetFocusedRowIndex() const;
4033
4034 BOOL _SetFocusedRow(CXTPGridRow* pRow);
4035
4036 BOOL _SetSelectedRow(CXTPGridRow* pRow, int nFocusedRowIndex, BOOL bShiftKey, BOOL bControlKey);
4037
4038 void DrawDefaultGrid(CDC* pDC, CRect rcClient, int nRowHeight, int nLeftOffset);
4039 void RedrawScrollBar(int nBar);
4040
4041 void GetColumnTotalSize(int& nTotalCount, int& nTotalWidth) const;
4042 void GetColumnOutOfViewSize(int& nOutOfViewCount, int& nOutOfViewWidth) const;
4043 void GetColumnScrollSize(int nOutOfViewWidth, int& nScrollCount, int& nScrollWidth) const;
4044 void GetParametersOfHScrollingBlockSize(int& nTotalWidth, int& nScrollPage) const;
4045 void GetParametersOfHScrollingBlockCount(int& nTotalCount, int& nScrollPage) const;
4046
4047 void UpdateScrollBarVisibility(int nBar);
4048
4049public:
4050 BOOL m_bThemeMetrics;
4051 BOOL m_bMovePivot;
4053 BOOL m_bStrictFiltering;
4055 BOOL m_bForcePagination;
4057 BOOL m_bSelectionExcludeGroupRows;
4059 XTPGridInputState m_mouseDownState;
4061 DWORD m_dwLastMouseMessage;
4062
4063 CXTPGridRow* m_pHotExpandButtonRow;
4064 CXTPGridHyperlink* m_pHotHyperlink;
4066protected:
4067 CXTPGridBehavior* m_pBehavior;
4068
4069 BOOL m_bDoubleBuffering;
4070 BOOL m_bChanged;
4071 BOOL m_bInternalMove;
4073 int m_nLockUpdateCount;
4076 CRect m_rcGroupByArea;
4077 CRect m_rcHeaderArea;
4078 CRect m_rcFooterArea;
4080 CXTPGridColumns* m_pColumns;
4082 CXTPGridRows* m_pRows;
4084 CXTPGridHeader* m_pGridHeader;
4086 CXTPGridSections* m_pSections;
4087 CXTPGridSection* m_pSectionHeader;
4088 CXTPGridSection* m_pSectionBody;
4089 CXTPGridSection* m_pSectionFooter;
4090 CXTPGridSection* m_pSectionScroll;
4091
4092 CXTPMarkupContext* m_pMarkupContext;
4093 CXTPGridPaintManager* m_pPaintManager;
4094 CXTPGridNavigator* m_pNavigator;
4096 CXTPGridNavigator* m_pNavigatorGrid;
4097 CXTPGridIconNavigator* m_pNavigatorIcon;
4098
4100 // Scrolling
4102
4103 XTPGridScrollUpdateMode m_scrollUpdateMode;
4104 XTPGridScrollMode m_scrollModeH;
4105 XTPGridScrollMode m_scrollModeV;
4107 int m_nScrollOffsetH;
4109 int m_nScrollStepH;
4110 int m_nScrollStepV;
4112 int m_nDisableReorderColumnsCount;
4115 CXTPGridSelectedRows* m_pSelectedRows;
4117 CXTPGridRow* m_pHotRow;
4119 int m_nRowsPerWheel;
4121 CXTPGridTip* m_pTip;
4122 CBitmap m_bmpCache;
4124 BOOL m_bGroupByEnabled;
4125 BOOL m_bSortRecordChilds;
4127 XTPGridMouseMode m_mouseMode;
4128 BOOL m_bBlockSelection;
4129 BOOL m_bMultiSelectionMode;
4131 BOOL m_bShowTooltips;
4132 BOOL m_bAutoCheckItems;
4135 CXTPImageManager* m_pImageManager;
4136 BOOL m_bSkipGroupsFocus;
4139 BOOL m_bLockExpand;
4140 BOOL m_bEnsureFocusedRowVisible;
4141 BOOL m_bFocusSubItems;
4142 BOOL m_bEditOnClick;
4143 BOOL m_bEditOnDelayClick;
4144 BOOL m_bEditOnDoubleClick;
4146 BOOL m_bPreviewAllowEdit;
4147 BOOL m_bHeaderVisible;
4148 BOOL m_bFooterVisible;
4149 BOOL m_bPinFooterRows;
4150 BOOL m_bPinFooterRowsPrinted;
4152 BOOL m_bInitialSelectionEnable;
4154 BOOL m_bRowFocusVisible;
4156 CXTPGridColumn* m_pFocusedColumn;
4158 CXTPToolTipContext* m_pToolTipContext;
4159 CXTPGridRecordItem* m_pActiveItem;
4160 CXTPGridInplaceEdit* m_pInplaceEdit;
4161 CXTPGridInplaceButtons* m_pInplaceButtons;
4162 CXTPGridInplaceList* m_pInplaceList;
4163 BOOL m_bVScrollBarVisible;
4164 BOOL m_bHScrollBarVisible;
4165 UINT m_nAutoVScrollTimerResolution;
4167 CPoint m_ptDrag;
4168 int m_nDragSensitivityX;
4170 int m_nDragSensitivityY;
4172 BOOL m_bPrepareDrag;
4174 CString m_strFilterText;
4175 BOOL m_bFilterHiddenColumns;
4176 int m_nRecordsTreeFilterMode;
4178 CLIPFORMAT m_cfGrid;
4180 CGridDropTarget* m_pDropTarget;
4181 BOOL m_bDragMode;
4182 BOOL m_bInternalDrag;
4183 DWORD m_dwDragDropFlags;
4184 DWORD m_dwDropMarkerFlags;
4185 CXTPGridSelectedRows* m_pSelectedRowsBeforeDrag;
4187 int m_nDropPos;
4188 CXTPGridRecords* m_pDropRecords;
4190 BOOL m_bAdjustLayoutRunning;
4192 UINT_PTR m_uAutoScrollTimerID;
4195 long m_nOLEDropMode;
4196 BOOL m_nOLEDropAbove;
4199 CXTPGridRow* m_ptrVirtualEditingRow;
4201 XTPGridRowsCompareFunc m_pRowsCompareFunc;
4203 HBITMAP m_hbmpWatermark;
4204 BYTE m_WatermarkTransparency;
4205 BITMAP m_bmWatermark;
4206 XTPGridWatermarkAlignment m_WatermarkAlignment;
4207 int m_nEnsureVisibleRowIdx;
4208 int m_nEnsureVisibleColumnIdx;
4210 CXTPGridDataManager* m_pDataManager;
4212 BOOL m_bShowIconWhenEditing;
4214# ifdef _XTP_ACTIVEX
4215
4216public:
4217 BOOL m_bCustomDrawItem;
4218 BOOL m_bCustomDrawPreviewItem;
4219 BOOL m_bCustomMeasureRow;
4220 BOOL m_bCustomBeforeDrawRow;
4221 BOOL m_bCustomMeasurePreviewItem;
4222
4223# endif
4224
4225private:
4226 XTP_NM_GRIDTOOLTIPINFO* m_pCachedToolTipInfo;
4227
4228public:
4229 int m_iIconWidth;
4230 int m_iIconHeight;
4231 int m_iIconWidthSpacing;
4232 int m_iIconHeightSpacing;
4234 int m_iIconPropNum;
4235 int m_iIconNum;
4237 BOOL m_bMarkupEnabled;
4238 int m_iIconViewColumn;
4239 BOOL m_bIconColumnIndexNotValid;
4242 BOOL m_bStrictBestFit;
4243 BOOL m_bWasShiftKey;
4244 BOOL m_bSortedDragDrop;
4246 BOOL m_bTrapTabKey;
4247 BOOL m_bDesktopTrackerMode;
4248 BOOL m_bUnrestrictedDragDrop;
4250 BOOL m_bFreeHeightMode;
4251 int m_nDefaultRowFreeHeight;
4252 CString m_sCustomTitle;
4253 BOOL m_bRClickDrag;
4254 BOOL m_bKeepSelectionAfterSort;
4256 int m_iColumnForNum;
4258protected:
4259 BOOL m_bCreated;
4260 BOOL m_bIconView;
4264 int m_iColumnForNumPrev;
4265 int m_iIconViewRowsPerLine;
4266 BOOL m_bUseIconColumnForNum;
4267 CXTPGridColumnOrder* m_pPrevVisible;
4268 CXTPGridColumnOrder* m_pPrevGroupsOrder;
4270 BOOL m_bPrevFocusSubItems;
4272 BOOL m_bPrevHeaderAutoSize;
4274 BOOL m_bPrevHeaderRows;
4275 BOOL m_bPrevFooterRows;
4276 int m_nPrevTreeIndent;
4277 BOOL m_bPrevHeaderShow;
4278 BOOL m_bPrevFooterShow;
4279 BOOL m_bPrevPreviewMode;
4281 BOOL m_bNoNeedSortedDragDrop;
4284 UINT_PTR m_uiDelayEditTimer;
4285 UINT m_uiDelayEditMaxTime;
4287 int m_iLastRqstEditRow;
4288 int m_iLastRqstEditCol;
4290 // ICON_VIEW_MODE RELATED <<
4291
4292 UINT_PTR m_uRqstEditTimer;
4293 BOOL m_bFastDeselectMode;
4294 XTPGridPaintTheme m_themeCurrent;
4296 BOOL m_bRelayWndMsg;
4298 friend class CGridControlCtrl;
4299 friend class CGridDropTarget;
4300 friend class CXTPGridPaintManager;
4301 friend class CXTPGridSections;
4302 friend class CXTPGridSection;
4303};
4304
4310class _XTP_EXT_CLASS CXTPGridControlLocale
4311{
4312private:
4313 CXTPGridControlLocale(){};
4314
4315public:
4327 static BOOL AFX_CDECL IsUseResourceFileLocale();
4328
4343 static void AFX_CDECL SetUseResourceFileLocale(BOOL bUseResourceFileLocale);
4344
4356 static LCID AFX_CDECL GetActiveLCID();
4357
4371 static BOOL AFX_CDECL VariantChangeTypeEx(VARIANT& rVarValue, VARTYPE vartype,
4372 BOOL bThrowError = TRUE);
4373
4386 static CString AFX_CDECL FormatDateTime(const COleDateTime& dt, LPCTSTR lpcszFormatString);
4387
4388private:
4389 static CString AFX_CDECL _FormatDateTime(const COleDateTime& dt, LPCTSTR lpcszFormatString,
4390 LCID lcLocaleID);
4391
4392 static void AFX_CDECL _InitMappedSpecs();
4393
4394 static void AFX_CDECL _ProcessMappedSpecs(CString& rstrFormat, const SYSTEMTIME* pST,
4395 LCID lcLocaleID);
4396 static void AFX_CDECL _ProcessDateTimeSpecs(CString& rstrFormat, const SYSTEMTIME* pST,
4397 LCID lcLocaleID);
4398 static void AFX_CDECL __ProcessDate_x(CString& rstrFormat, const SYSTEMTIME* pST,
4399 LCID lcLocaleID);
4400 static void AFX_CDECL __ProcessTime_X(CString& rstrFormat, const SYSTEMTIME* pST,
4401 LCID lcLocaleID);
4402 static void AFX_CDECL _ProcessOtherSpecs(CString& rstrFormat, const COleDateTime& dt);
4403
4404private:
4405 struct XTP_TIMESPEC
4406 {
4407 LPCTSTR pcszSpec;
4408 LPCTSTR pcszFormat;
4409 BOOL bTime;
4410 };
4411
4412 static CArray<XTP_TIMESPEC, XTP_TIMESPEC&> s_arMappedSpecs;
4413
4414 static void AFX_CDECL _AddsMappedSpec(LPCTSTR pcszSpec, LPCTSTR pcszFormat, BOOL bTime);
4415
4416 static BOOL s_bUseResourceFileLocale;
4417};
4418
4420
4421AFX_INLINE CXTPGridPaintManager* CXTPGridControl::GetPaintManager() const
4422{
4423 return m_pPaintManager;
4424}
4425AFX_INLINE CXTPGridNavigator* CXTPGridControl::GetNavigator() const
4426{
4427 return m_pNavigator;
4428}
4429AFX_INLINE CXTPGridSelectedRows* CXTPGridControl::GetSelectedRows() const
4430{
4431 return m_pSelectedRows;
4432}
4433
4434AFX_INLINE CXTPGridColumns* CXTPGridControl::GetColumns() const
4435{
4436 return m_pColumns;
4437}
4438AFX_INLINE XTPGridMouseMode CXTPGridControl::GetMouseMode() const
4439{
4440 return m_mouseMode;
4441}
4442AFX_INLINE BOOL CXTPGridControl::IsChanged() const
4443{
4444 return m_bChanged;
4445}
4446AFX_INLINE void CXTPGridControl::SetChanged(BOOL bChanged)
4447{
4448 m_bChanged = bChanged;
4449}
4450AFX_INLINE void CXTPGridControl::ShowGroupBy(BOOL bEnable)
4451{
4452 // _ASSERTE(!IsVirtualMode());
4453 m_bGroupByEnabled = bEnable;
4454 AdjustLayout();
4455 AdjustScrollBars();
4456 RedrawControl();
4457}
4458AFX_INLINE BOOL CXTPGridControl::IsGroupByVisible() const
4459{
4460 return m_bGroupByEnabled;
4461}
4462AFX_INLINE void CXTPGridControl::ShowHeader(BOOL bShow /*= TRUE*/)
4463{
4464 m_bHeaderVisible = bShow;
4465 AdjustLayout();
4466 AdjustScrollBars();
4467}
4468AFX_INLINE BOOL CXTPGridControl::IsHeaderVisible() const
4469{
4470 return m_bHeaderVisible;
4471}
4472AFX_INLINE void CXTPGridControl::ShowFooter(BOOL bShow /*= TRUE*/)
4473{
4474 m_bFooterVisible = bShow;
4475 AdjustLayout();
4476 AdjustScrollBars();
4477}
4478AFX_INLINE BOOL CXTPGridControl::IsFooterVisible() const
4479{
4480 return m_bFooterVisible;
4481}
4482AFX_INLINE BOOL CXTPGridControl::IsMultipleSelection() const
4483{
4484 return m_bBlockSelection;
4485}
4486AFX_INLINE void CXTPGridControl::SetMultipleSelection(BOOL bSet)
4487{
4488 m_bBlockSelection = bSet;
4489}
4490
4491AFX_INLINE BOOL CXTPGridControl::IsMultiSelectionMode() const
4492{
4493 return m_bMultiSelectionMode;
4494}
4495
4496AFX_INLINE void CXTPGridControl::SetMultiSelectionMode(BOOL bSet)
4497{
4498 m_bMultiSelectionMode = bSet;
4499}
4500
4501AFX_INLINE void CXTPGridControl::EnableToolTips(BOOL bEnable)
4502{
4503 m_bShowTooltips = bEnable;
4504}
4505AFX_INLINE void CXTPGridControl::SkipGroupsFocus(BOOL bSkipFocus)
4506{
4507 m_bSkipGroupsFocus = bSkipFocus;
4508}
4509AFX_INLINE BOOL CXTPGridControl::IsSkipGroupsFocusEnabled() const
4510{
4511 return m_bSkipGroupsFocus;
4512}
4513AFX_INLINE CXTPImageManager* CXTPGridControl::GetImageManager() const
4514{
4515 return m_pImageManager;
4516}
4517AFX_INLINE CXTPGridColumn* CXTPGridControl::GetFocusedColumn() const
4518{
4519 return m_pFocusedColumn;
4520}
4521AFX_INLINE void CXTPGridControl::FocusSubItems(BOOL bFocusSubItems)
4522{
4523 m_bFocusSubItems = bFocusSubItems;
4524 m_pFocusedColumn = NULL;
4525}
4526AFX_INLINE CXTPGridInplaceEdit* CXTPGridControl::GetInplaceEdit() const
4527{
4528 return m_pInplaceEdit;
4529}
4530AFX_INLINE CXTPGridInplaceButtons* CXTPGridControl::GetInplaceButtons() const
4531{
4532 return m_pInplaceButtons;
4533}
4534AFX_INLINE CXTPGridInplaceList* CXTPGridControl::GetInplaceList() const
4535{
4536 return m_pInplaceList;
4537}
4538AFX_INLINE CXTPGridRecordItem* CXTPGridControl::GetActiveItem() const
4539{
4540 return m_pActiveItem;
4541}
4542AFX_INLINE void CXTPGridControl::EnsureFocusedRowVisible(BOOL bEnsureFocusedRowVisible)
4543{
4544 m_bEnsureFocusedRowVisible = bEnsureFocusedRowVisible;
4545}
4546AFX_INLINE BOOL CXTPGridControl::IsEnsureFocusedRowVisible() const
4547{
4548 return m_bEnsureFocusedRowVisible;
4549}
4550
4551AFX_INLINE BOOL CXTPGridControl::IsFocusSubItems() const
4552{
4553 return m_bFocusSubItems;
4554}
4555
4556AFX_INLINE BOOL CXTPGridControl::IsDoubleBuffering() const
4557{
4558 return m_bDoubleBuffering;
4559}
4560
4561AFX_INLINE void CXTPGridControl::EditOnClick(BOOL bEditOnClick)
4562{
4563 if (bEditOnClick)
4564 {
4565 m_bEditOnDelayClick = FALSE;
4566 }
4567 m_bEditOnClick = bEditOnClick;
4568}
4569
4570AFX_INLINE BOOL CXTPGridControl::IsEditOnClick() const
4571{
4572 return m_bEditOnClick;
4573}
4574
4575AFX_INLINE void CXTPGridControl::EditOnDelayClick(BOOL bEditOnDelayClick)
4576{
4577 if (bEditOnDelayClick)
4578 {
4579 m_bEditOnClick = FALSE;
4580 }
4581 m_bEditOnDelayClick = bEditOnDelayClick;
4582}
4583
4584AFX_INLINE BOOL CXTPGridControl::IsEditOnDelayClick() const
4585{
4586 return m_bEditOnDelayClick;
4587}
4588
4589AFX_INLINE void CXTPGridControl::EditOnDoubleClick(BOOL bEditOnClick)
4590{
4591 m_bEditOnDoubleClick = bEditOnClick;
4592}
4593
4594AFX_INLINE BOOL CXTPGridControl::IsEditOnDoubleClick() const
4595{
4596 return m_bEditOnDoubleClick;
4597}
4598
4599AFX_INLINE int CXTPGridControl::GetLastRqstEditRow() const
4600{
4601 return m_iLastRqstEditRow;
4602}
4603
4604AFX_INLINE int CXTPGridControl::GetLastRqstEditCol() const
4605{
4606 return m_iLastRqstEditCol;
4607}
4608
4609// Information for delay editing.
4610AFX_INLINE UINT_PTR CXTPGridControl::GetDelayEditTimer() const
4611{
4612 return m_uiDelayEditTimer;
4613}
4614
4615AFX_INLINE void CXTPGridControl::SetLastRqstEdit(int iLastRqstEditRow, int iLastRqstEditCol)
4616{
4617 m_iLastRqstEditRow = iLastRqstEditRow;
4618 m_iLastRqstEditCol = iLastRqstEditCol;
4619}
4620
4621AFX_INLINE CString CXTPGridControl::GetFilterText()
4622{
4623 return m_strFilterText;
4624}
4625
4626AFX_INLINE void CXTPGridControl::SetFilterText(LPCTSTR strFilterText)
4627{
4628 m_strFilterText = strFilterText;
4629}
4630
4631AFX_INLINE CXTPGridHeader* CXTPGridControl::GetGridHeader() const
4632{
4633 return m_pGridHeader;
4634}
4635
4636AFX_INLINE void CXTPGridControl::SetAutoCheckItems(BOOL bAutoCheck)
4637{
4638 m_bAutoCheckItems = bAutoCheck;
4639}
4640
4641AFX_INLINE BOOL CXTPGridControl::IsAutoCheckItems() const
4642{
4643 return m_bAutoCheckItems;
4644}
4645
4646AFX_INLINE int CXTPGridControl::GetDisableReorderColumnsCount() const
4647{
4648 return m_nDisableReorderColumnsCount;
4649}
4650
4651AFX_INLINE int CXTPGridControl::GetLockUpdateCount() const
4652{
4653 return m_nLockUpdateCount;
4654}
4655
4656AFX_INLINE void CXTPGridControl::SetRowsCompareFunc(XTPGridRowsCompareFunc pCompareFunc)
4657{
4658 m_pRowsCompareFunc = pCompareFunc;
4659}
4660
4661AFX_INLINE int CXTPGridControl::GetHScrollStep() const
4662{
4663 return m_nScrollStepH;
4664}
4665
4666AFX_INLINE void CXTPGridControl::SetHScrollStep(int nStep)
4667{
4668 _ASSERTE(nStep > 0);
4669 m_nScrollStepH = max(1, nStep);
4670}
4671
4672AFX_INLINE UINT CXTPGridControl::GetAutoVScrollTimerResolution() const
4673{
4674 return m_nAutoVScrollTimerResolution;
4675}
4676
4677AFX_INLINE BOOL CXTPGridControl::IsFooterRowsPinned() const
4678{
4679 return m_bPinFooterRows;
4680}
4681
4682AFX_INLINE void CXTPGridControl::PinFooterRowsPrinted(BOOL bPin)
4683{
4684 m_bPinFooterRowsPrinted = bPin;
4685}
4686
4687AFX_INLINE BOOL CXTPGridControl::IsFooterRowsPinnedPrinted() const
4688{
4689 return m_bPinFooterRowsPrinted;
4690}
4691
4692AFX_INLINE BOOL CXTPGridControl::IsPreviewAllowEdit() const
4693{
4694 return m_bPreviewAllowEdit;
4695}
4696
4697AFX_INLINE void CXTPGridControl::PreviewAllowEdit(BOOL bAllowEdit)
4698{
4699 m_bPreviewAllowEdit = bAllowEdit;
4700}
4701
4702AFX_INLINE void CXTPGridControl::SetSortRecordChilds(BOOL bSortRecordChildren)
4703{
4704 m_bSortRecordChilds = bSortRecordChildren;
4705}
4706
4707AFX_INLINE BOOL CXTPGridControl::IsSortRecordChilds() const
4708{
4709 return m_bSortRecordChilds;
4710}
4711
4712AFX_INLINE BOOL CXTPGridControl::IsFilterHiddenColumns() const
4713{
4714 return m_bFilterHiddenColumns;
4715}
4716
4717AFX_INLINE void CXTPGridControl::SetFilterHiddenColumns(BOOL bFilterHidden)
4718{
4719 m_bFilterHiddenColumns = bFilterHidden;
4720}
4721
4722AFX_INLINE int CXTPGridControl::GetRecordsTreeFilterMode() const
4723{
4724 return m_nRecordsTreeFilterMode;
4725}
4726
4727AFX_INLINE void CXTPGridControl::SetRecordsTreeFilterMode(int nMode)
4728{
4729 m_nRecordsTreeFilterMode = nMode;
4730}
4731
4732AFX_INLINE BOOL CXTPGridControl::IsInitialSelectionEnabled() const
4733{
4734 return m_bInitialSelectionEnable;
4735}
4736
4737AFX_INLINE BOOL CXTPGridControl::IsRowFocusVisible() const
4738{
4739 return m_bRowFocusVisible;
4740}
4741
4742AFX_INLINE void CXTPGridControl::ShowRowFocus(BOOL bShow)
4743{
4744 m_bRowFocusVisible = bShow;
4745}
4746
4747AFX_INLINE int CXTPGridControl::GetWatermarkAlignment() const
4748{
4749 return m_WatermarkAlignment;
4750}
4751
4752AFX_INLINE void CXTPGridControl::SetWatermarkAlignment(int nWatermarkAlignment)
4753{
4754 m_WatermarkAlignment = (XTPGridWatermarkAlignment)nWatermarkAlignment;
4755}
4756
4757AFX_INLINE BOOL CXTPGridControl::IsIconView() const
4758{
4759 return m_bIconView;
4760}
4761
4762AFX_INLINE int CXTPGridControl::GetRowsPerLine() const
4763{
4764 return m_iIconViewRowsPerLine;
4765}
4766
4767AFX_INLINE int CXTPGridControl::GetLeftOffset() const
4768{
4769 return m_nScrollOffsetH;
4770}
4771
4772AFX_INLINE void CXTPGridControl::SetDropMarkerFlags(DWORD dwDropMarkerFlags)
4773{
4774 m_dwDropMarkerFlags = dwDropMarkerFlags;
4775}
4776
4777AFX_INLINE DWORD CXTPGridControl::GetDropMarkerFlags() const
4778{
4779 return m_dwDropMarkerFlags;
4780}
4781
4782AFX_INLINE BOOL CXTPGridControl::IsDragMode() const
4783{
4784 return m_bDragMode;
4785}
4786
4787AFX_INLINE int CXTPGridControl::GetDragSensitivityX() const
4788{
4789 return m_nDragSensitivityX;
4790}
4791
4792AFX_INLINE int CXTPGridControl::GetDragSensitivityY() const
4793{
4794 return m_nDragSensitivityY;
4795}
4796
4797AFX_INLINE void CXTPGridControl::SetFastDeselectMode(BOOL bFastDeselect)
4798{
4799 m_bFastDeselectMode = bFastDeselect;
4800}
4801
4802AFX_INLINE CXTPGridBehavior* CXTPGridControl::GetBehavior() const
4803{
4804 return m_pBehavior;
4805}
4806
4807AFX_INLINE void CXTPGridControl::LockExpand(BOOL bLockExpand)
4808{
4809 m_bLockExpand = bLockExpand;
4810}
4811
4812AFX_INLINE BOOL CXTPGridControl::IsLockExpand() const
4813{
4814 return m_bLockExpand;
4815}
4817AFX_INLINE XTPGridPaintTheme CXTPGridControl::GetCurrentTheme() const
4818{
4819 return m_themeCurrent;
4820}
4821
4822AFX_INLINE void CXTPGridControl::SetReportStyle(XTPGridOrientation orientation,
4823 XTPGridGridStyle gridStyle)
4824{
4825 SetGridStyle(orientation, gridStyle);
4826}
4827
4828AFX_INLINE COLORREF CXTPGridControl::SetReportColor(COLORREF clrGridLine)
4829{
4830 return SetGridColor(clrGridLine);
4831}
4832
4833AFX_INLINE void CXTPGridControl::SetReportHeader(CXTPGridHeader* pGridHeader)
4834{
4835 SetGridHeader(pGridHeader);
4836}
4837
4838AFX_INLINE void CXTPGridControl::SetReportStyle(BOOL bVertical, XTPGridGridStyle gridStyle)
4839{
4840 SetGridStyle(bVertical, gridStyle);
4841}
4842
4843AFX_INLINE XTPGridGridStyle CXTPGridControl::GetReportStyle(XTPGridOrientation orientation) const
4844{
4845 return GetGridStyle(orientation);
4846}
4847
4848AFX_INLINE int CXTPGridControl::GetReportAreaRows(int nStartRow, BOOL bMoveDown)
4849{
4850 return GetGridAreaRows(nStartRow, bMoveDown);
4851}
4852
4853AFX_INLINE CXTPGridHeader* CXTPGridControl::GetReportHeader() const
4854{
4855 return GetGridHeader();
4856}
4857
4858AFX_INLINE XTPGridGridStyle CXTPGridControl::GetReportStyle(BOOL bVertical) const
4859{
4860 return GetGridStyle(bVertical);
4861}
4862
4863AFX_INLINE CRect CXTPGridControl::GetReportRectangle() const
4864{
4865 return GetGridRectangle();
4866}
4868class _XTP_EXT_CLASS CXTPPromptDlg : public CDialog
4869{
4871 DECLARE_DYNAMIC(CXTPPromptDlg)
4873public:
4874 CXTPPromptDlg(CWnd* pParent = NULL);
4875 virtual ~CXTPPromptDlg();
4876 virtual void OnOK();
4877 virtual INT_PTR DoModal();
4878 virtual BOOL OnInitDialog();
4879 CString m_sName;
4880};
4881
4882extern UINT XTP_WM_GRID_SETTHEME;
4884# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
4885#endif //#if !defined(__XTPGRIDCONTROL_H__)
pPoint
const CPoint * pPoint
return 0 or xtpCalendarHitTestDayExpandButton
Definition XTPCalendarThemeOffice2007.h:150
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTP_DECLARE_CMDTARGETPROVIDER_INTERFACE
#define XTP_DECLARE_CMDTARGETPROVIDER_INTERFACE()
When deriving from CXTPCmdTarget is not possible this macro can be used in addition to standard DECLA...
Definition XTPFramework.h:89
XTPGridScrollUpdateMode
XTPGridScrollUpdateMode
Enumeration of scroll update modes.
Definition XTPGridControl.h:310
xtpGridScrollUpdateModeDeferred
@ xtpGridScrollUpdateModeDeferred
Updates the scroll position deferred.
Definition XTPGridControl.h:312
xtpGridScrollUpdateModeImmediate
@ xtpGridScrollUpdateModeImmediate
Immediately updates the scroll position.
Definition XTPGridControl.h:311
XTPGridDragDrop
XTPGridDragDrop
Enumeration of drag and drop flags.
Definition XTPGridControl.h:207
xtpGridAllowDragCopy
@ xtpGridAllowDragCopy
Allow copy records from grid.
Definition XTPGridControl.h:209
xtpGridAllowDrag
@ xtpGridAllowDrag
Allow copy and move records from grid.
Definition XTPGridControl.h:211
xtpGridAllowDragMove
@ xtpGridAllowDragMove
Allow move records from grid.
Definition XTPGridControl.h:210
xtpGridDontDropAsText
@ xtpGridDontDropAsText
Do not drag record as plain text.
Definition XTPGridControl.h:212
xtpGridAllowDrop
@ xtpGridAllowDrop
Allow drop records to grid.
Definition XTPGridControl.h:208
XTPGridMouseMode
XTPGridMouseMode
Enumeration of operational mouse modes.
Definition XTPGridControl.h:186
xtpGridMouseNothing
@ xtpGridMouseNothing
User is just watching to the list.
Definition XTPGridControl.h:187
xtpGridMouseOverRowDivide
@ xtpGridMouseOverRowDivide
User watching, but mouse is under row divider.
Definition XTPGridControl.h:191
xtpGridMouseDraggingColumn
@ xtpGridMouseDraggingColumn
User is dragging column header.
Definition XTPGridControl.h:190
xtpGridMousePrepareDragColumn
@ xtpGridMousePrepareDragColumn
User holds mouse button pressed on the column header.
Definition XTPGridControl.h:189
xtpGridMouseOverColumnDivide
@ xtpGridMouseOverColumnDivide
User watching, but mouse is under column divider.
Definition XTPGridControl.h:188
XTPGridWatermarkAlignment
XTPGridWatermarkAlignment
Enumeration of watermark alignment flags.
Definition XTPGridControl.h:237
xtpGridWatermarkHmask
@ xtpGridWatermarkHmask
A mask for horizontal alignment flags.
Definition XTPGridControl.h:246
xtpGridWatermarkStretch
@ xtpGridWatermarkStretch
Stretch watermark to entire Grid control client rect.
Definition XTPGridControl.h:252
xtpGridWatermarkShrinkOnly
@ xtpGridWatermarkShrinkOnly
Watermark can be shrinked only, enlarging is disabled.
Definition XTPGridControl.h:255
xtpGridWatermarkBottom
@ xtpGridWatermarkBottom
Vertical alignment: bottom side of Grid control client rect.
Definition XTPGridControl.h:249
xtpGridWatermarkCenter
@ xtpGridWatermarkCenter
Horizontal alignment: center of Grid control client rect.
Definition XTPGridControl.h:242
xtpGridWatermarkVmask
@ xtpGridWatermarkVmask
A mask for vertical alignment flags.
Definition XTPGridControl.h:251
xtpGridWatermarkLeft
@ xtpGridWatermarkLeft
Horizontal alignment: left side of Grid control client rect.
Definition XTPGridControl.h:240
xtpGridWatermarkTop
@ xtpGridWatermarkTop
Vertical alignment: top side of Grid control client rect.
Definition XTPGridControl.h:247
xtpGridWatermarkVCenter
@ xtpGridWatermarkVCenter
Vertical alignment: center of Grid control client rect.
Definition XTPGridControl.h:248
xtpGridWatermarkEnlargeOnly
@ xtpGridWatermarkEnlargeOnly
Watermark can be enlarged only, shrinking is disabled.
Definition XTPGridControl.h:253
xtpGridWatermarkRight
@ xtpGridWatermarkRight
Horizontal alignment: right side of Grid control client rect.
Definition XTPGridControl.h:244
xtpGridWatermarkPreserveRatio
@ xtpGridWatermarkPreserveRatio
Watermark aspect ratio is preserved.
Definition XTPGridControl.h:257
xtpGridWatermarkUnknown
@ xtpGridWatermarkUnknown
Unknown (empty) value.
Definition XTPGridControl.h:238
XTPGridScrollMode
XTPGridScrollMode
Enumeration of scroll modes.
Definition XTPGridControl.h:320
xtpGridScrollModeBlock
@ xtpGridScrollModeBlock
Deprecated, same as xtpGridScrollModeBlockCount.
Definition XTPGridControl.h:328
xtpGridScrollModeNone
@ xtpGridScrollModeNone
No scrolling.
Definition XTPGridControl.h:321
xtpGridScrollModeBlockCount
@ xtpGridScrollModeBlockCount
Scrolls an entire row or column.
Definition XTPGridControl.h:322
xtpGridScrollModeBlockSize
@ xtpGridScrollModeBlockSize
Scrolls an entire row or column.
Definition XTPGridControl.h:323
xtpGridScrollModeSmooth
@ xtpGridScrollModeSmooth
Smooth scrolling.
Definition XTPGridControl.h:324
XTPGridDropMarker
XTPGridDropMarker
Enumeration describes the drop marker.
Definition XTPGridControl.h:220
xtpGridDropSelect
@ xtpGridDropSelect
Drop the selected rows.
Definition XTPGridControl.h:222
xtpGridDropBetween
@ xtpGridDropBetween
Drop the row between two rows.
Definition XTPGridControl.h:221
XTPGridFilterMode
XTPGridFilterMode
Enumeration of options for the SetRecordsTreeFilterMode method.
Definition XTPGridControl.h:297
xtpGridFilterTreeByParentAndChildren
@ xtpGridFilterTreeByParentAndChildren
Specifies a parent-children tree grid filter mode.
Definition XTPGridControl.h:299
xtpGridFilterTreeSimple
@ xtpGridFilterTreeSimple
Specifies a simple tree grid filter mode.
Definition XTPGridControl.h:298
xtpGridFilterTreeByEndChildrenOnly
@ xtpGridFilterTreeByEndChildrenOnly
Specifies a end children only tree grid filter mode.
Definition XTPGridControl.h:301
XTPGridElementRect
XTPGridElementRect
Enumeration of GetElementRect flags.
Definition XTPGridControl.h:272
xtpGridElementRectHeaderRecordsArea
@ xtpGridElementRectHeaderRecordsArea
The area occupied by the header records.
Definition XTPGridControl.h:277
xtpGridElementRectGridArea
@ xtpGridElementRectGridArea
The area occupied by the records.
Definition XTPGridControl.h:273
xtpGridElementRectHeaderArea
@ xtpGridElementRectHeaderArea
The area occupied by the header.
Definition XTPGridControl.h:275
xtpGridElementRectFooterRecordsDividerArea
@ xtpGridElementRectFooterRecordsDividerArea
The area occupied by the footer records divider.
Definition XTPGridControl.h:281
xtpGridElementRectFooterRecordsArea
@ xtpGridElementRectFooterRecordsArea
The area occupied by the footer records.
Definition XTPGridControl.h:278
xtpGridElementRectFooterArea
@ xtpGridElementRectFooterArea
The area occupied by the footer.
Definition XTPGridControl.h:276
xtpGridElementRectHeaderRecordsDividerArea
@ xtpGridElementRectHeaderRecordsDividerArea
The area occupied by the header records divider.
Definition XTPGridControl.h:279
xtpGridElementRectGroupByArea
@ xtpGridElementRectGroupByArea
The area occupied by Group By item.
Definition XTPGridControl.h:274
XTPGridLineStyle
XTPGridLineStyle
Represents predefined grid line styles.
Definition XTPGridDefines.h:126
XTPGridRowsCompareFunc
int(AFX_CDECL * XTPGridRowsCompareFunc)(const CXTPGridRow **pRow1, const CXTPGridRow **pRow2)
Defines a function pointer for comparing events.
Definition XTPGridDefines.h:1420
XTPGridOrientation
XTPGridOrientation
Enumeration of orientations.
Definition XTPGridDefines.h:108
XTPGridPaintTheme
XTPGridPaintTheme
Visual theme enumeration.
Definition XTPGridDefines.h:299
CXTPGridColumn
Represents a grid column item with its properties and operations.
Definition XTPGridColumn.h:107
CXTPGridColumnOrder
Represents the column order, used for sorting and grouping.
Definition XTPGridColumns.h:384
CXTPGridColumns
This class is a collection of grid column objects.
Definition XTPGridColumns.h:54
CXTPGridControl::CUpdateContext
Internal grid update helper.
Definition XTPGridControl.h:504
CXTPGridControl::CUpdateContext::CUpdateContext
CUpdateContext(CXTPGridControl *pControl)
Constructs a CUpdateContext object.
Definition XTPGridControl.h:511
CXTPGridControl::CUpdateContext::~CUpdateContext
~CUpdateContext()
Destroys a CUpdateContext object, handles cleanup and deallocation.
Definition XTPGridControl.h:522
CXTPGridControl::CUpdateContext::m_pControl
CXTPGridControl * m_pControl
Updated Grid control pointer.
Definition XTPGridControl.h:528
CXTPGridControl
The CXTPGridControl class provides an implementation of the Grid control.
Definition XTPGridControl.h:479
CXTPGridControl::SetScrollOffsetV
void SetScrollOffsetV(int nOffset)
Sets the vertical scroll position.
CXTPGridControl::m_bPrevPreviewMode
BOOL m_bPrevPreviewMode
Tells whether the preview mode is enabled or not previously.
Definition XTPGridControl.h:4279
CXTPGridControl::IsFooterVisible
BOOL IsFooterVisible() const
Gets the visible state of column footers.
Definition XTPGridControl.h:4478
CXTPGridControl::m_nDragSensitivityX
int m_nDragSensitivityX
Horizontal sensitivity of Drag'n'Drop operation (in pixels).
Definition XTPGridControl.h:4168
CXTPGridControl::ApplyFilter
virtual BOOL ApplyFilter(CXTPGridRecord *pRecord, CString strFilterText, BOOL bIncludePreview)
Checks a record for filter text.
CXTPGridControl::GetToolTipContext
CXTPToolTipContext * GetToolTipContext() const
Gets the tooltip context.
CXTPGridControl::OnPreviewKeyDown
virtual BOOL OnPreviewKeyDown(UINT &rnChar, UINT nRepCnt, UINT nFlags)
This method is called before processing the OnKeyDown event.
CXTPGridControl::GetAutoVScrollTimerResolution
UINT GetAutoVScrollTimerResolution() const
Gets the vertical scrolling timer resolution.
Definition XTPGridControl.h:4672
CXTPGridControl::GetGridAreaRows
int GetGridAreaRows(int nStartRow, BOOL bMoveDown)
Calculates the number of visible rows between a specified row and the bottom/top of the current view.
CXTPGridControl::m_bPrevFooterRows
BOOL m_bPrevFooterRows
TRUE if there are previous footer rows, FALSE otherwise.
Definition XTPGridControl.h:4275
CXTPGridControl::StartLastRqstTimer
void StartLastRqstTimer()
Starts the last request timer used for delay edit.
CXTPGridControl::DoPropExchange
virtual void DoPropExchange(CXTPPropExchange *pPX)
Reads/writes configuration to/from the provided data source.
CXTPGridControl::m_bMarkupEnabled
BOOL m_bMarkupEnabled
Flag to check markup settings.
Definition XTPGridControl.h:4237
CXTPGridControl::SetFocusedRow
BOOL SetFocusedRow(CXTPGridRow *pRow, BOOL bShiftKey, BOOL bControlKey)
Sets the currently focused row in the Grid control's view.
CXTPGridControl::DrawNoItems
virtual void DrawNoItems(CDC *pDC, const CRect &rcClient)
Draws the 'NoItems' text in the provided device conext.
CXTPGridControl::IsSkipGroupsFocusEnabled
BOOL IsSkipGroupsFocusEnabled() const
Determines if groups are skipped when navigating the Grid control by using the Up and Down keys.
Definition XTPGridControl.h:4509
CXTPGridControl::AddRecord
virtual CXTPGridRecord * AddRecord(CXTPGridRecord *pRecord)
Adds a specified data record to the records collection.
CXTPGridControl::GetHScrollStep
int GetHScrollStep() const
Gets the horizontal scrolling step.
Definition XTPGridControl.h:4661
CXTPGridControl::m_iLastRqstEditCol
int m_iLastRqstEditCol
The last column which requested a delay edit.
Definition XTPGridControl.h:4288
CXTPGridControl::m_uiDelayEditMaxTime
UINT m_uiDelayEditMaxTime
The delay edit time interval.
Definition XTPGridControl.h:4285
CXTPGridControl::GetLastRqstEditCol
int GetLastRqstEditCol() const
Gets the index of the most recent column that was requested for editing.
Definition XTPGridControl.h:4604
CXTPGridControl::IsFooterRowsPinned
BOOL IsFooterRowsPinned() const
Determines if footer records are pinned to the last body row.
Definition XTPGridControl.h:4677
CXTPGridControl::m_uiDelayEditTimer
UINT_PTR m_uiDelayEditTimer
The delay edit timer.
Definition XTPGridControl.h:4284
CXTPGridControl::OnDragOver
virtual DROPEFFECT OnDragOver(COleDataObject *pDataObject, DWORD dwKeyState, CPoint point, int nState)
This member is called when an item is dragged over the Grid control.
CXTPGridControl::OnConstraintSelecting
virtual BOOL OnConstraintSelecting(CXTPGridRow *pRow, CXTPGridRecordItem *pItem, CXTPGridColumn *pColumn, CXTPGridRecordItemConstraint *pConstraint)
This method is used to notify about changes to the constraint selection.
CXTPGridControl::OnBeforeCopyToText
virtual BOOL OnBeforeCopyToText(CXTPGridRecord *pRecord, CStringArray &rarStrings)
This method is called before a record is copied to the clipboard in text format.
CXTPGridControl::PopulateFooterRows
virtual void PopulateFooterRows()
Performs control's footer rows population, creating a view from the data.
CXTPGridControl::m_pPaintManager
CXTPGridPaintManager * m_pPaintManager
Paint manager.
Definition XTPGridControl.h:4093
CXTPGridControl::m_pSelectedRows
CXTPGridSelectedRows * m_pSelectedRows
Container for the currently selected rows.
Definition XTPGridControl.h:4115
CXTPGridControl::SetTreeIndent
void SetTreeIndent(int nIndent)
Sets the indentation before the text of each child node in a hierarchical tree structure.
CXTPGridControl::GetInplaceEdit
CXTPGridInplaceEdit * GetInplaceEdit() const
Gets the in-place edit control.
Definition XTPGridControl.h:4526
CXTPGridControl::IsShadeGroupHeadingsEnabled
BOOL IsShadeGroupHeadingsEnabled() const
Determines if group items shading is enabled/disabled.
CXTPGridControl::UseGridCustomHeap
static BOOL AFX_CDECL UseGridCustomHeap()
Call this function to use the custom heap feature.
CXTPGridControl::SetFocusedRow
BOOL SetFocusedRow(CXTPGridRow *pRow, BOOL bControlKey=FALSE)
Sets the currently focused row in the Grid control's view.
CXTPGridControl::m_bSortRecordChilds
BOOL m_bSortRecordChilds
TRUE to apply sort order for record children.
Definition XTPGridControl.h:4125
CXTPGridControl::m_bWasShiftKey
BOOL m_bWasShiftKey
Flag set on MouseUp or KeyUp if Shift key was On.
Definition XTPGridControl.h:4243
CXTPGridControl::Create
BOOL Create(DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID, CCreateContext *pContext=NULL)
This method is called to create a Grid control.
CXTPGridControl::m_pInplaceEdit
CXTPGridInplaceEdit * m_pInplaceEdit
In-place edit pointer.
Definition XTPGridControl.h:4160
CXTPGridControl::PreviewAllowEdit
void PreviewAllowEdit(BOOL bAllowEdit)
Enables/disables preview editing.
Definition XTPGridControl.h:4697
CXTPGridControl::IsGroupRowsBold
BOOL IsGroupRowsBold() const
Gets the group rows text style: bold or normal.
CXTPGridControl::m_bIconColumnIndexNotValid
BOOL m_bIconColumnIndexNotValid
Used to indicate icon column is created, but does not yet have a valid index.
Definition XTPGridControl.h:4239
CXTPGridControl::IsFullColumnScrolling
BOOL IsFullColumnScrolling() const
Gets the horizontal scrolling mode.
CXTPGridControl::IsDoubleBuffering
BOOL IsDoubleBuffering() const
Determines if double-buffering is enabled/disabled.
Definition XTPGridControl.h:4556
CXTPGridControl::RelayToolTipEvent
virtual void RelayToolTipEvent(UINT message)
Relays a tooltip event.
CXTPGridControl::RegisterWindowClass
BOOL RegisterWindowClass(HINSTANCE hInstance=NULL)
Registers the window class if it has not already been registered.
CXTPGridControl::EditOnClick
void EditOnClick(BOOL bEditOnClick)
Specifies if a CXTPGridRecordItem should become editable after being single-clicked.
Definition XTPGridControl.h:4561
CXTPGridControl::GetRecordsTreeFilterMode
int GetRecordsTreeFilterMode() const
Gets the filtering mode of the record tree.
Definition XTPGridControl.h:4722
CXTPGridControl::InitialSelectionEnable
void InitialSelectionEnable(BOOL bEnable)
Enables/disables initial selection.
CXTPGridControl::GetDelayEditTimer
UINT_PTR GetDelayEditTimer() const
Gets the ID of the delay edit timer.
Definition XTPGridControl.h:4610
CXTPGridControl::IsIconView
BOOL IsIconView() const
Determines if Icon View mode is active.
Definition XTPGridControl.h:4757
CXTPGridControl::SetHScrollStep
void SetHScrollStep(int nStep)
Sets the horizontal scrolling step.
Definition XTPGridControl.h:4666
CXTPGridControl::IsRowFocusVisible
BOOL IsRowFocusVisible() const
Determines if row focus is shown.
Definition XTPGridControl.h:4737
CXTPGridControl::m_iIconWidthSpacing
int m_iIconWidthSpacing
Icon geometry settings.
Definition XTPGridControl.h:4231
CXTPGridControl::CanPaste
virtual BOOL CanPaste()
Determines if the Paste operation is possible in the current context (i.e.
CXTPGridControl::SetFullColumnScrolling
void SetFullColumnScrolling(BOOL bSet)
Sets the horizontal scrolling mode.
CXTPGridControl::StartDelayEditTimer
void StartDelayEditTimer()
Starts the delay edit timer.
CXTPGridControl::m_pGridHeader
CXTPGridHeader * m_pGridHeader
List header member.
Definition XTPGridControl.h:4084
CXTPGridControl::ShowRowFocus
void ShowRowFocus(BOOL bShow)
Specifies if row focus should be shown.
Definition XTPGridControl.h:4742
CXTPGridControl::m_bMultiSelectionMode
BOOL m_bMultiSelectionMode
TRUE if multi-selection mode is enabled (i.e.
Definition XTPGridControl.h:4129
CXTPGridControl::SendMessageToParent
LRESULT SendMessageToParent(CXTPGridRow *pRow, CXTPGridRecordItem *pItem, CXTPGridColumn *pColumn, UINT nMessage, CPoint *pPoint, int nHyperlink=-1) const
Notifies the parent control about an event that occurred.
CXTPGridControl::m_bTrapTabKey
BOOL m_bTrapTabKey
Flag to set Trap Tab key in m_bEditOnClick && m_bAllowEdit case.
Definition XTPGridControl.h:4246
CXTPGridControl::EnsureStartAutoVertScroll
virtual void EnsureStartAutoVertScroll()
This method is used to start monitoring mouse position for automatic vertical scrolling.
CXTPGridControl::EnableMarkup
void EnableMarkup(BOOL bEnable=TRUE)
Call this method to enable Markup for records.
CXTPGridControl::m_pRowsCompareFunc
XTPGridRowsCompareFunc m_pRowsCompareFunc
Pointer to the rows compare function.
Definition XTPGridControl.h:4201
CXTPGridControl::m_pColumns
CXTPGridColumns * m_pColumns
List columns container.
Definition XTPGridControl.h:4080
CXTPGridControl::m_pActiveItem
CXTPGridRecordItem * m_pActiveItem
Pointer to the currently focused CXTPGridRecordItem.
Definition XTPGridControl.h:4159
CXTPGridControl::SetTopRow
void SetTopRow(int nIndex)
Sets the top row of the Grid control view.
CXTPGridControl::IsGroupByVisible
BOOL IsGroupByVisible() const
Gets the visible state of the Group By area.
Definition XTPGridControl.h:4458
CXTPGridControl::m_WatermarkAlignment
XTPGridWatermarkAlignment m_WatermarkAlignment
Watermark alignment flags.
Definition XTPGridControl.h:4206
CXTPGridControl::OnSelectionChanged
virtual void OnSelectionChanged()
This member function is called after a user selects a row or a column.
CXTPGridControl::SetFocusedRow
BOOL SetFocusedRow(BOOL bEnsureVisible, CXTPGridRow *pRow, BOOL bShiftKey, BOOL bControlKey)
Sets the currently focused row in the Grid control's view.
CXTPGridControl::IsPreviewMode
BOOL IsPreviewMode() const
Determines if preview mode is enabled/disabled for the control.
CXTPGridControl::m_bFreeHeightMode
BOOL m_bFreeHeightMode
Flag to set RC Free Height Mode.
Definition XTPGridControl.h:4250
CXTPGridControl::m_bPinFooterRowsPrinted
BOOL m_bPinFooterRowsPrinted
TRUE if footer rows are printed immediately after the body rows.
Definition XTPGridControl.h:4150
CXTPGridControl::SetFilterText
virtual void SetFilterText(LPCTSTR strFilterText)
Sets the filter text for the control.
Definition XTPGridControl.h:4626
CXTPGridControl::SetChanged
void SetChanged(BOOL bChanged=TRUE)
Specifies if the internal control state was changed since the last drawing.
Definition XTPGridControl.h:4446
CXTPGridControl::EnsureStopLastRqstTimer
void EnsureStopLastRqstTimer()
Stops the last request timer used for delay edit.
CXTPGridControl::m_bHeaderVisible
BOOL m_bHeaderVisible
TRUE if column headers are visible.
Definition XTPGridControl.h:4147
CXTPGridControl::m_bSkipGroupsFocus
BOOL m_bSkipGroupsFocus
TRUE if group rows are skipped when navigating rows with the Up and Down arrow keys.
Definition XTPGridControl.h:4136
CXTPGridControl::IsDragMode
BOOL IsDragMode() const
assessors for m_bDragMode
Definition XTPGridControl.h:4782
CXTPGridControl::SetRecordsTreeFilterMode
void SetRecordsTreeFilterMode(int nMode)
Sets the filtering mode for the record tree.
Definition XTPGridControl.h:4727
CXTPGridControl::SetLastRqstEdit
void SetLastRqstEdit(int iRqstEditRow, int iRqstEditCol)
Sets an arbitrary index for both the most recent row and most recent column that was requested for ed...
Definition XTPGridControl.h:4615
CXTPGridControl::SetScrollOffsetH
void SetScrollOffsetH(int nOffset)
Sets the horizontal scroll position.
CXTPGridControl::ExpandAll
void ExpandAll(BOOL bRecursive=FALSE)
Expands all rows.
CXTPGridControl::IsChanged
BOOL IsChanged() const
Determines if the internal control state was changed since the last drawing.
Definition XTPGridControl.h:4442
CXTPGridControl::GetDropMarkerFlags
DWORD GetDropMarkerFlags() const
Gets the drop marker flags.
Definition XTPGridControl.h:4777
CXTPGridControl::GetFreezeColumnsCount
int GetFreezeColumnsCount() const
Gets the number of frozen columns starting from the left hand side.
CXTPGridControl::m_bPrevHeaderAutoSize
BOOL m_bPrevHeaderAutoSize
TRUE if the previous header is auto-size, FALSE otherwise.
Definition XTPGridControl.h:4272
CXTPGridControl::GetFocusedRecordItem
CXTPGridRecordItem * GetFocusedRecordItem() const
Gets the focused item.
CXTPGridControl::GetColumns
CXTPGridColumns * GetColumns() const
Gets the collection of grid columns.
Definition XTPGridControl.h:4434
CXTPGridControl::ShowHeader
void ShowHeader(BOOL bShow=TRUE)
Sets the visible state of column headers.
Definition XTPGridControl.h:4462
CXTPGridControl::IsEditOnClick
BOOL IsEditOnClick() const
Determines if a CXTPGridRecordItem becomes editable after being single-clicked.
Definition XTPGridControl.h:4570
CXTPGridControl::RedrawControl
void RedrawControl()
Initiates Grid control redrawing.
CXTPGridControl::Populate
virtual void Populate()
Performs control population, creating a view from the data.
CXTPGridControl::m_bDragMode
BOOL m_bDragMode
TRUE if records are currently being dragged.
Definition XTPGridControl.h:4181
CXTPGridControl::m_bInitialSelectionEnable
BOOL m_bInitialSelectionEnable
TRUE if Initial (in Populate() call) selection is enabled.
Definition XTPGridControl.h:4152
CXTPGridControl::m_nLockUpdateCount
int m_nLockUpdateCount
A counter of the update locks.
Definition XTPGridControl.h:4073
CXTPGridControl::AdjustLayout
virtual void AdjustLayout()
Adjusts main control areas depending on current control size.
CXTPGridControl::SetImageList
void SetImageList(CImageList *pImageList)
Sets the image list for the paint manager.
CXTPGridControl::IsMultiSelectionMode
BOOL IsMultiSelectionMode() const
Determines if multi-selection mode is enabled/disabled for the Grid control.
Definition XTPGridControl.h:4491
CXTPGridControl::AddColumn
CXTPGridColumn * AddColumn(CXTPGridColumn *pColumn)
Adds a specified column to the end of the columns array.
CXTPGridControl::IsFooterRowsPinnedPrinted
BOOL IsFooterRowsPinnedPrinted() const
Determines if footer records are pinned to the last body row.
Definition XTPGridControl.h:4687
CXTPGridControl::OnBeginDrag
virtual void OnBeginDrag(CPoint point)
This method is called when the user begins dragging a row.
CXTPGridControl::m_bPreviewAllowEdit
BOOL m_bPreviewAllowEdit
TRUE if the preview of the row can be edited.
Definition XTPGridControl.h:4146
CXTPGridControl::GetFreezeColumnsIndex
int GetFreezeColumnsIndex() const
Gets the index of the rightmost frozen column.
CXTPGridControl::SetDropMarkerFlags
void SetDropMarkerFlags(DWORD dwDropMarkerFlags)
Sets the drop marker flags.
Definition XTPGridControl.h:4772
CXTPGridControl::GetFilterText
virtual CString GetFilterText()
Gets the filter text of the control.
Definition XTPGridControl.h:4621
CXTPGridControl::AdjustScrollBars
virtual void AdjustScrollBars()
Adjusts scrollbars depending on currently visible rows.
CXTPGridControl::GetItemMetrics
virtual void GetItemMetrics(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pItemMetrics)
Calculates metrics for a row.
CXTPGridControl::SetRowsCompareFunc
virtual void SetRowsCompareFunc(XTPGridRowsCompareFunc pCompareFunc)
Sets the compare function used to compare (and sort) rows.
Definition XTPGridControl.h:4656
CXTPGridControl::GetHeaderIndent
int GetHeaderIndent() const
Gets the indentation of the header.
CXTPGridControl::m_iColumnForNum
int m_iColumnForNum
Index of the row number column used.
Definition XTPGridControl.h:4256
CXTPGridControl::m_iIconPropNum
int m_iIconPropNum
Icon view setting.
Definition XTPGridControl.h:4234
CXTPGridControl::m_bRClickDrag
BOOL m_bRClickDrag
TRUE to allow drag on right click.
Definition XTPGridControl.h:4253
CXTPGridControl::ShowFooter
void ShowFooter(BOOL bShow=TRUE)
Sets the visible state of column footers.
Definition XTPGridControl.h:4472
CXTPGridControl::m_bPrevHeaderRows
BOOL m_bPrevHeaderRows
TRUE if there are previous header rows, FALSE otherwise.
Definition XTPGridControl.h:4274
CXTPGridControl::m_iLastRqstEditRow
int m_iLastRqstEditRow
The last row which requested a delay edit.
Definition XTPGridControl.h:4287
CXTPGridControl::ResetContent
void ResetContent(BOOL bUpdateControl=TRUE)
Deletes all rows and records from the Grid control.
CXTPGridControl::CXTPGridControl
CXTPGridControl()
Constructs a CXTPGridControl object.
CXTPGridControl::SkipGroupsFocus
void SkipGroupsFocus(BOOL bSkipFocus)
Specifies if groups are skipped when navigating the Grid control by using the Up and Down keys.
Definition XTPGridControl.h:4505
CXTPGridControl::EnableDoubleBuffering
void EnableDoubleBuffering(BOOL bEnable)
Enables/disables double-buffering.
CXTPGridControl::GetInplaceButtons
CXTPGridInplaceButtons * GetInplaceButtons() const
Gets the collection of in-place buttons of the Grid control.
Definition XTPGridControl.h:4530
CXTPGridControl::LockExpand
void LockExpand(BOOL bLockExpand)
Specifies if the user's ability to collapse/expand rows should be locked.
Definition XTPGridControl.h:4807
CXTPGridControl::GetWatermarkAlignment
int GetWatermarkAlignment() const
Gets the watermark alignment.
Definition XTPGridControl.h:4747
CXTPGridControl::OnBeforePaste
virtual BOOL OnBeforePaste(CXTPGridRecord **ppRecord)
This method is called after creating a new record using binary data from the clipboard,...
CXTPGridControl::RemoveRowEx
virtual BOOL RemoveRowEx(CXTPGridRow *pRow, BOOL bAdjustLayout=TRUE)
Removes a specified row, the record associated with the specified row, and all child rows and records...
CXTPGridControl::UpdateSubList
void UpdateSubList()
Updates the field chooser control with its content.
CXTPGridControl::Paste
virtual void Paste()
Reads records from the clipboard and adds them to the records collection (the binary data format is u...
CXTPGridControl::EnsureFocusedRowVisible
void EnsureFocusedRowVisible(BOOL bEnsureFocusedRowVisible)
Specifies if the visibility of focused rows should be ensured.
Definition XTPGridControl.h:4542
CXTPGridControl::ReSortRows
virtual void ReSortRows()
Re-sorts the rows tree according to the sort order for columns.
CXTPGridControl::m_pFocusedColumn
CXTPGridColumn * m_pFocusedColumn
Pointer to the currently focused CXTPGridColumn.
Definition XTPGridControl.h:4156
CXTPGridControl::GetIndent
int GetIndent(int nLevel) const
Calculates the indentation, in pixels, for a tree view row of a specified depth level.
CXTPGridControl::m_bKeepSelectionAfterSort
BOOL m_bKeepSelectionAfterSort
TRUE to keep the selection after sorting items.
Definition XTPGridControl.h:4254
CXTPGridControl::IsEditOnDoubleClick
BOOL IsEditOnDoubleClick() const
Determines if a CXTPGridRecordItem becomes editable after being double-clicked.
Definition XTPGridControl.h:4594
CXTPGridControl::GetPaintManager
CXTPGridPaintManager * GetPaintManager() const
Gets the paint manager object used to draw the Grid control window.
Definition XTPGridControl.h:4421
CXTPGridControl::GetFocusedRow
CXTPGridRow * GetFocusedRow() const
Gets the currently focused row in the Grid control's view.
CXTPGridControl::InsertRow
virtual int InsertRow(int nIndex, CXTPGridRow *pRow)
Inserts a specified row at a specified index in the rows array.
CXTPGridControl::SendNotifyMessage
LRESULT SendNotifyMessage(UINT nMessage, NMHDR *pNMHDR=NULL) const
Sends a specified message to the window.
CXTPGridControl::SetGridColor
COLORREF SetGridColor(COLORREF clrGridLine)
Sets the grid line color.
CXTPGridControl::SetMultiSelectionMode
void SetMultiSelectionMode(BOOL bMultiSelectionMode)
Enables/disables multi-selection mode for the Grid control.
Definition XTPGridControl.h:4496
CXTPGridControl::OnGetColumnDataBestFitWidth
virtual int OnGetColumnDataBestFitWidth(CXTPGridColumn *pColumn)
This method is used by the Grid control to calculate the best-fit column width.
CXTPGridControl::IsFilterHiddenColumns
virtual BOOL IsFilterHiddenColumns() const
Determines if search filter text is enabled/disabled in hidden columns.
Definition XTPGridControl.h:4712
CXTPGridControl::CreateRow
virtual CXTPGridRow * CreateRow()
Creates a CXTPGridRow object.
CXTPGridControl::m_bIconView
BOOL m_bIconView
TRUE if icon view, FALSE otherwise.
Definition XTPGridControl.h:4260
CXTPGridControl::SetMultipleSelection
void SetMultipleSelection(BOOL bMultipleSelection)
Enables/disables multiple selections for the Grid control.
Definition XTPGridControl.h:4486
CXTPGridControl::m_bPrevFocusSubItems
BOOL m_bPrevFocusSubItems
TRUE if there are previous focused sub-items, FALSE otherwise.
Definition XTPGridControl.h:4270
CXTPGridControl::PinFooterRows
void PinFooterRows(BOOL bPin=FALSE)
Specifies if footer records are pinned to the last body row.
CXTPGridControl::EnsureVisible
void EnsureVisible(CXTPGridColumn *pCheckColumn)
Ensures that a Grid control column is at least partially visible.
CXTPGridControl::m_nPrevTreeIndent
int m_nPrevTreeIndent
Tree indentation.
Definition XTPGridControl.h:4276
CXTPGridControl::IsInitialSelectionEnabled
BOOL IsInitialSelectionEnabled() const
Determines if initial selection is enabled/disabled.
Definition XTPGridControl.h:4732
CXTPGridControl::m_pImageManager
CXTPImageManager * m_pImageManager
Image list for the Grid control.
Definition XTPGridControl.h:4135
CXTPGridControl::EditOnDoubleClick
void EditOnDoubleClick(BOOL bEditOnClick)
Specifies if a CXTPGridRecordItem should become editable after being double-clicked.
Definition XTPGridControl.h:4589
CXTPGridControl::ReleaseItem
void ReleaseItem(int nIndex)
Call this method to remove all items and column in specified position.
CXTPGridControl::IsEnsureFocusedRowVisible
BOOL IsEnsureFocusedRowVisible() const
Determines if the visibility of focused rows is ensured.
Definition XTPGridControl.h:4546
CXTPGridControl::IsLayoutRTL
BOOL IsLayoutRTL()
Determines if right-to-left (RTL) mode was set.
CXTPGridControl::m_bGroupByEnabled
BOOL m_bGroupByEnabled
TRUE if Group By box is enabled.
Definition XTPGridControl.h:4124
CXTPGridControl::IsPreviewAllowEdit
BOOL IsPreviewAllowEdit() const
Determines if preview editing is enabled/disabled.
Definition XTPGridControl.h:4692
CXTPGridControl::BeginUpdate
void BeginUpdate()
Prevents the Grid control from being redrawn until the EndUpdate method is called.
CXTPGridControl::GetFocusedColumn
CXTPGridColumn * GetFocusedColumn() const
Gets the selected column.
Definition XTPGridControl.h:4517
CXTPGridControl::GetInplaceList
CXTPGridInplaceList * GetInplaceList() const
Gets the in-place list of Grid controls.
Definition XTPGridControl.h:4534
CXTPGridControl::m_bPrevFooterShow
BOOL m_bPrevFooterShow
Tells whether the previous footer is visible or not.
Definition XTPGridControl.h:4278
CXTPGridControl::IsHeaderVisible
BOOL IsHeaderVisible() const
Gets the visible state of column headers.
Definition XTPGridControl.h:4468
CXTPGridControl::Copy
virtual void Copy()
Copies the selected record data (in the binary and/or text data formats) to the clipboard.
CXTPGridControl::m_uRqstEditTimer
UINT_PTR m_uRqstEditTimer
The edit timer ID.
Definition XTPGridControl.h:4292
CXTPGridControl::m_bEditOnDoubleClick
BOOL m_bEditOnDoubleClick
TRUE if sub-items become editable on a double-click.
Definition XTPGridControl.h:4144
CXTPGridControl::EndUpdate
void EndUpdate()
Resumes drawing of the Grid control after drawing has been suspended by the BeginUpdate method.
CXTPGridControl::AddRecordEx
virtual void AddRecordEx(CXTPGridRecord *pRecord, CXTPGridRecord *pParentRecord=NULL, int nRowChildIndex=-1, int nRecordChildIndex=-1)
Adds a specified data record to the records collection and associates a row with it.
CXTPGridControl::m_iIconNum
int m_iIconNum
Icon view setting.
Definition XTPGridControl.h:4235
CXTPGridControl::GetRowsPerLine
int GetRowsPerLine() const
Gets the number of rows per line.
Definition XTPGridControl.h:4762
CXTPGridControl::m_pPrevVisible
CXTPGridColumnOrder * m_pPrevVisible
The previous visible column order.
Definition XTPGridControl.h:4267
CXTPGridControl::m_themeCurrent
XTPGridPaintTheme m_themeCurrent
Currently set theme.
Definition XTPGridControl.h:4294
CXTPGridControl::IsEditMode
virtual BOOL IsEditMode()
Determines if the in-place edit control is active (i.e.
CXTPGridControl::GetDisableReorderColumnsCount
int GetDisableReorderColumnsCount() const
Gets the number of columns at the left side where reordering is disabled.
Definition XTPGridControl.h:4646
CXTPGridControl::GetDragSensitivityX
int GetDragSensitivityX() const
Gets the horizontal sensitivity of Drag'n'Drop operations.
Definition XTPGridControl.h:4787
CXTPGridControl::m_iIconHeightSpacing
int m_iIconHeightSpacing
Icon geometry settings.
Definition XTPGridControl.h:4232
CXTPGridControl::DrawRows
virtual int DrawRows(CDC *pDC, CRect &rcClient, int y, CXTPGridRows *pRows, int nTopRow, int nColumnFrom, int nColumnTo, int *pnHeight=NULL)
Draws all rows in the provided device context.
CXTPGridControl::GetLockUpdateCount
int GetLockUpdateCount() const
Definition XTPGridControl.h:4651
CXTPGridControl::m_bStrictBestFit
BOOL m_bStrictBestFit
TRUE to use BestFit only for non-autosize mode.
Definition XTPGridControl.h:4242
CXTPGridControl::GetRowsHeight
virtual int GetRowsHeight(CXTPGridRows *pRows, int nTotalWidth, int nMaxHeight=-1)
Calculates the combined height of all rows within a specified rows collection.
CXTPGridControl::m_nDragSensitivityY
int m_nDragSensitivityY
Vertical sensitivity of Drag'n'Drop operation (in pixels).
Definition XTPGridControl.h:4170
CXTPGridControl::m_bNoNeedSortedDragDrop
BOOL m_bNoNeedSortedDragDrop
Dynamic flag during Sorted DragDrop operation (set during OnDragOver state - used during OnDrop state...
Definition XTPGridControl.h:4281
CXTPGridControl::m_iIconViewColumn
int m_iIconViewColumn
Icon view setting.
Definition XTPGridControl.h:4238
CXTPGridControl::m_nDisableReorderColumnsCount
int m_nDisableReorderColumnsCount
Count of columns at the left side where reordering is disabled.
Definition XTPGridControl.h:4112
CXTPGridControl::IsEditOnDelayClick
BOOL IsEditOnDelayClick() const
Determines if the Delay Click Edit feature is enabled/disabled.
Definition XTPGridControl.h:4584
CXTPGridControl::m_bFastDeselectMode
BOOL m_bFastDeselectMode
Tells whether the fast deselect mode is enabled or not.
Definition XTPGridControl.h:4293
CXTPGridControl::DrawWatermark
void DrawWatermark(CDC *pDC, CRect rcWatermark, CRect rcClient)
Draws a watermark.
CXTPGridControl::PinFooterRowsPrinted
void PinFooterRowsPrinted(BOOL bPin=FALSE)
Specifies if footer records are pinned to the last body row.
Definition XTPGridControl.h:4682
CXTPGridControl::m_bEditOnDelayClick
BOOL m_bEditOnDelayClick
TRUE if sub-items become editable on a delay-click.
Definition XTPGridControl.h:4143
CXTPGridControl::m_iIconHeight
int m_iIconHeight
Icon geometry settings.
Definition XTPGridControl.h:4230
CXTPGridControl::m_mouseMode
XTPGridMouseMode m_mouseMode
Current mouse operation mode.
Definition XTPGridControl.h:4127
CXTPGridControl::EnableDragDrop
CLIPFORMAT EnableDragDrop(LPCTSTR lpszClipboardFormat, DWORD dwFlags, DWORD dwDropMarkerFlags=xtpGridDropBetween)
Call this method to enable built in drag and drop operations.
CXTPGridControl::m_bRelayWndMsg
BOOL m_bRelayWndMsg
Used for relaying window messages.
Definition XTPGridControl.h:4296
CXTPGridControl::OnGetItemsCaptionMaxWidth
virtual int OnGetItemsCaptionMaxWidth(CDC *pDC, CXTPGridRows *pRows, CXTPGridColumn *pColumn, int nStartRow=0, int nRowsCount=-1)
This method is used by the Grid control to calculate the items captions maximum width.
CXTPGridControl::SetAutoCheckItems
void SetAutoCheckItems(BOOL bAutoCheck)
Enables/disables auto-check mode for checkbox items.
Definition XTPGridControl.h:4636
CXTPGridControl::m_nScrollOffsetH
int m_nScrollOffsetH
Horizontal scroll position.
Definition XTPGridControl.h:4107
CXTPGridControl::m_bLockExpand
BOOL m_bLockExpand
TRUE if collapsing/expanding rows is locked.
Definition XTPGridControl.h:4139
CXTPGridControl::IsAutoCheckItems
BOOL IsAutoCheckItems() const
Determines if auto-check mode is enabled/disabled for checkbox items.
Definition XTPGridControl.h:4641
CXTPGridControl::SetFreezeColumnsCount
void SetFreezeColumnsCount(int nCount, BOOL bReserved=FALSE)
Sets the number of frozen columns.
CXTPGridControl::SetWatermarkAlignment
void SetWatermarkAlignment(int nWatermarkAlignment)
Sets the watermark alignment.
Definition XTPGridControl.h:4752
CXTPGridControl::PopulateHeaderRows
virtual void PopulateHeaderRows()
Performs control's header rows population, creating a view from the data.
CXTPGridControl::GetGridStyle
XTPGridGridStyle GetGridStyle(XTPGridOrientation orientation) const
Gets the grid drawing style.
CXTPGridControl::m_bBlockSelection
BOOL m_bBlockSelection
TRUE if multiple selection is enabled.
Definition XTPGridControl.h:4128
CXTPGridControl::GetLeftOffset
int GetLeftOffset() const
Gets the horizontal scroll position.
Definition XTPGridControl.h:4767
CXTPGridControl::m_bDesktopTrackerMode
BOOL m_bDesktopTrackerMode
Flag to set Vista Tracker Mode On or Off.
Definition XTPGridControl.h:4247
CXTPGridControl::SetPaintManager
void SetPaintManager(CXTPGridPaintManager *pPaintManager)
Sets the paint manager object used to draw the Grid control window.
CXTPGridControl::CollapseAll
void CollapseAll()
Collapses all rows.
CXTPGridControl::IsLockExpand
BOOL IsLockExpand() const
Determines if the user's ability to collapse/expand rows is locked.
Definition XTPGridControl.h:4812
CXTPGridControl::GetGridHeader
CXTPGridHeader * GetGridHeader() const
Gets the associated grid header object.
Definition XTPGridControl.h:4631
CXTPGridControl::HitTest
CXTPGridRow * HitTest(CPoint pt) const
Determines which grid row is at a specified point, if any.
CXTPGridControl::CreateGroupRow
virtual CXTPGridGroupRow * CreateGroupRow()
Creates a CXTPGridGroupRow object.
CXTPGridControl::GetNavigator
CXTPGridNavigator * GetNavigator() const
Gets the navigator object used for cell navigation by the Grid control.
Definition XTPGridControl.h:4425
CXTPGridControl::GetLastRqstEditRow
int GetLastRqstEditRow() const
Gets the index of the most recent row that was requested for editing.
Definition XTPGridControl.h:4599
CXTPGridControl::m_pPrevGroupsOrder
CXTPGridColumnOrder * m_pPrevGroupsOrder
The previous group column order.
Definition XTPGridControl.h:4268
CXTPGridControl::m_bEnsureFocusedRowVisible
BOOL m_bEnsureFocusedRowVisible
TRUE if focused rows will be forced visible.
Definition XTPGridControl.h:4140
CXTPGridControl::EnablePreviewMode
void EnablePreviewMode(BOOL bIsPreviewMode)
Enables/disables preview mode for the control.
CXTPGridControl::m_iIconViewRowsPerLine
int m_iIconViewRowsPerLine
The icon view rows per line.
Definition XTPGridControl.h:4265
CXTPGridControl::m_bPinFooterRows
BOOL m_bPinFooterRows
TRUE if footer rows are drawn immediately after the body rows.
Definition XTPGridControl.h:4149
CXTPGridControl::OnDraw
virtual void OnDraw(CDC *pDC)
Performs all drawing logic.
CXTPGridControl::EditOnDelayClick
void EditOnDelayClick(BOOL bEditOnDelayClick)
Enables/disables the Delay Click Edit feature.
Definition XTPGridControl.h:4575
CXTPGridControl::OnDrop
virtual BOOL OnDrop(COleDataObject *pDataObject, DROPEFFECT dropEffect, CPoint point)
This member is called when an item has been dropped into the Grid control.
CXTPGridControl::m_bCreated
BOOL m_bCreated
TRUE if created using the Create() method.
Definition XTPGridControl.h:4259
CXTPGridControl::DoAutoVertScrollIfNeed
virtual void DoAutoVertScrollIfNeed(CPoint ptClick, CPoint pt)
This method is used to monitor mouse position.
CXTPGridControl::OnBeforePasteFromText
virtual BOOL OnBeforePasteFromText(CStringArray &arStrings, CXTPGridRecord **ppRecord)
This method is called before creating a new record using text data from the clipboard.
CXTPGridControl::GetSelectedRows
CXTPGridSelectedRows * GetSelectedRows() const
Gets the collection of selected rows.
Definition XTPGridControl.h:4429
CXTPGridControl::UseRowBatchAllocation
static BOOL AFX_CDECL UseRowBatchAllocation()
Call this function to enable the batch allocation feature for grid rows.
CXTPGridControl::HitTest
virtual BOOL HitTest(CPoint pt, CXTPGridHitTestInfo *pInfo) const
Determines which grid part is at a specified point.
CXTPGridControl::m_bFooterVisible
BOOL m_bFooterVisible
TRUE if column footers are visible.
Definition XTPGridControl.h:4148
CXTPGridControl::GetMouseMode
XTPGridMouseMode GetMouseMode() const
Gets the control mouse mode.
Definition XTPGridControl.h:4438
CXTPGridControl::ShowGroupBy
void ShowGroupBy(BOOL bEnable=TRUE)
Sets the visible state of the Group By area.
Definition XTPGridControl.h:4450
CXTPGridControl::OnGetToolTipInfo
virtual const XTP_NM_GRIDTOOLTIPINFO & OnGetToolTipInfo(CXTPGridRow *pRow, CXTPGridRecordItem *pItem, CString &rstrToolTipText)
This method is called to get the tooltip text for the current record item.
CXTPGridControl::m_bChanged
BOOL m_bChanged
Internal member for storing changed flag.
Definition XTPGridControl.h:4070
CXTPGridControl::SetDisableReorderColumnsCount
void SetDisableReorderColumnsCount(int nCount)
Sets the number of columns at the left side where reordering is disabled.
CXTPGridControl::SetLayoutRTL
void SetLayoutRTL(BOOL bRightToLeft)
Sets right-to-left (RTL) mode.
CXTPGridControl::CanCut
virtual BOOL CanCut()
Determines if the Cut operation is possible in the current context (i.e.
CXTPGridControl::m_dwDropMarkerFlags
DWORD m_dwDropMarkerFlags
The drop marker flags.
Definition XTPGridControl.h:4184
CXTPGridControl::EnableToolTips
void EnableToolTips(BOOL bEnable)
Enables/disables showing tooltips for the Grid control window.
Definition XTPGridControl.h:4501
CXTPGridControl::~CXTPGridControl
virtual ~CXTPGridControl()
Destroys a CXTPGridControl object, handles cleanup and deallocation.
CXTPGridControl::m_bEditOnClick
BOOL m_bEditOnClick
TRUE if sub-items become editable on a single-click.
Definition XTPGridControl.h:4142
CXTPGridControl::CanCopy
virtual BOOL CanCopy()
Determines if the Copy operation is posssible in the current context (i.e.
CXTPGridControl::m_pNavigator
CXTPGridNavigator * m_pNavigator
Navigator.
Definition XTPGridControl.h:4094
CXTPGridControl::CreateHeaderFooterRow
virtual CXTPGridRow * CreateHeaderFooterRow()
Creates a CXTPGridRow object for header/footer rows.
CXTPGridControl::m_bRowFocusVisible
BOOL m_bRowFocusVisible
TRUE if showing focused row rectangle is enabled.
Definition XTPGridControl.h:4154
CXTPGridControl::m_nScrollStepH
int m_nScrollStepH
Horizontal scroll step (in pixels).
Definition XTPGridControl.h:4109
CXTPGridControl::IsMultipleSelection
BOOL IsMultipleSelection() const
Determines if multiple selections is enabled/disabled for the Grid control.
Definition XTPGridControl.h:4482
CXTPGridControl::m_iIconWidth
int m_iIconWidth
Icon geometry settings.
Definition XTPGridControl.h:4229
CXTPGridControl::GetElementRect
CRect GetElementRect(XTPGridElementRect nElement) const
Retrieves a specified grid element rectangle.
CXTPGridControl::FocusSubItems
void FocusSubItems(BOOL bFocusSubItems)
Specifies if each individual record item in a row should receive focus when an item in the row is cli...
Definition XTPGridControl.h:4521
CXTPGridControl::OnFocusChanging
virtual BOOL OnFocusChanging(CXTPGridRow *pNewRow, CXTPGridColumn *pNewCol)
This member function is called before the focus changes.
CXTPGridControl::m_bShowTooltips
BOOL m_bShowTooltips
TRUE if show tooltips is enabled.
Definition XTPGridControl.h:4131
CXTPGridControl::SetFocusedColumn
BOOL SetFocusedColumn(CXTPGridColumn *pColumn)
Sets the selected column.
CXTPGridControl::UpdateRecord
virtual void UpdateRecord(CXTPGridRecord *pRecord, BOOL bUpdateChildren)
Updates a specified record.
CXTPGridControl::IsVirtualMode
BOOL IsVirtualMode() const
Determines if virtual mode is enabled/disabled.
CXTPGridControl::Recalc
void Recalc(BOOL bAll=FALSE)
Recalculates and redraws rows.
CXTPGridControl::SetSortRecordChilds
void SetSortRecordChilds(BOOL bSortRecordChildren)
Specifies if the sort order should be applied to record children.
Definition XTPGridControl.h:4702
CXTPGridControl::RemoveRecordEx
virtual BOOL RemoveRecordEx(CXTPGridRecord *pRecord, BOOL bAdjustLayout=TRUE, BOOL bRemoveFromParent=TRUE)
Removes a specified record, the row associated with the specified record, and all child records and r...
CXTPGridControl::SetGridStyle
void SetGridStyle(XTPGridOrientation orientation, XTPGridGridStyle gridStyle)
Sets the grid drawing style.
CXTPGridControl::IsSortRecordChilds
BOOL IsSortRecordChilds() const
Determines if the sort order is applied to record children.
Definition XTPGridControl.h:4707
CXTPGridControl::GetImageManager
CXTPImageManager * GetImageManager() const
Gets the image manager of the Grid control.
Definition XTPGridControl.h:4513
CXTPGridControl::m_bDoubleBuffering
BOOL m_bDoubleBuffering
Enables double-buffering.
Definition XTPGridControl.h:4069
CXTPGridControl::GetMarkupContext
CXTPMarkupContext * GetMarkupContext() const
Gets the Markup context.
CXTPGridControl::GetMouseScrollLines
static UINT AFX_CDECL GetMouseScrollLines()
Gets the number of rows per mouse scroll.
CXTPGridControl::Cut
virtual void Cut()
Copies the selected record data (in the binary and/or text data formats) to the clipboard and deletes...
CXTPGridControl::m_sCustomTitle
CString m_sCustomTitle
Used for a unique title (e.g.
Definition XTPGridControl.h:4252
CXTPGridControl::m_pInplaceButtons
CXTPGridInplaceButtons * m_pInplaceButtons
In-place buttons pointer.
Definition XTPGridControl.h:4161
CXTPGridControl::m_bFocusSubItems
BOOL m_bFocusSubItems
TRUE if sub-items can receive focus.
Definition XTPGridControl.h:4141
CXTPGridControl::SetAutoVScrollTimerResolution
void SetAutoVScrollTimerResolution(UINT nNewTimerResolution)
Sets the vertical scrolling timer resolution.
CXTPGridControl::ShadeGroupHeadings
void ShadeGroupHeadings(BOOL bEnable=TRUE)
Enables/disables group items shading.
CXTPGridControl::EnsureStopAutoVertScroll
virtual void EnsureStopAutoVertScroll()
This method is used to stop monitoring mouse position for automatic vertical scrolling.
CXTPGridControl::SerializeState
virtual void SerializeState(CArchive &ar)
(Re)Stores control configuration to/from the provided archive stream.
CXTPGridControl::SetSelectionState
void SetSelectionState(int index, int state)
Sets the selection state of a row.
CXTPGridControl::SetGroupRowsBold
void SetGroupRowsBold(BOOL bBold=TRUE)
Sets the group rows text style: bold or normal.
CXTPGridControl::m_nAutoVScrollTimerResolution
UINT m_nAutoVScrollTimerResolution
Vertical scrolling timer resolution (in milliseconds).
Definition XTPGridControl.h:4165
CXTPGridControl::m_bUnrestrictedDragDrop
BOOL m_bUnrestrictedDragDrop
TRUE to allow a child to be dropped to any pos; default = FALSE.
Definition XTPGridControl.h:4248
CXTPGridControl::IsFocusSubItems
BOOL IsFocusSubItems() const
Determines if each individual record item in a row receives focus when an item in the row is clicked.
Definition XTPGridControl.h:4551
CXTPGridControl::m_nRecordsTreeFilterMode
int m_nRecordsTreeFilterMode
Tree Filter mode.
Definition XTPGridControl.h:4176
CXTPGridControl::m_bSortedDragDrop
BOOL m_bSortedDragDrop
Flag to set Drag Drop mode like Vista Windows Explorer or XP Windows Explorer.
Definition XTPGridControl.h:4244
CXTPGridControl::GetActiveItem
CXTPGridRecordItem * GetActiveItem() const
Gets the active item (i.e.
Definition XTPGridControl.h:4538
CXTPGridControl::EnsureVisible
void EnsureVisible(CXTPGridRow *pRow)
Ensures that a Grid control row is at least partially visible.
CXTPGridControl::m_bAutoCheckItems
BOOL m_bAutoCheckItems
TRUE to enable auto-check mode, FALSE to disable auto-check mode.
Definition XTPGridControl.h:4132
CXTPGridControl::m_pInplaceList
CXTPGridInplaceList * m_pInplaceList
In-place list pointer.
Definition XTPGridControl.h:4162
CXTPGridControl::m_bFilterHiddenColumns
BOOL m_bFilterHiddenColumns
Search filter text in hidden columns too.
Definition XTPGridControl.h:4175
CXTPGridControl::EnsureStopDelayEditTimer
void EnsureStopDelayEditTimer()
Stops the delay edit timer.
CXTPGridControl::SetFastDeselectMode
void SetFastDeselectMode(BOOL bFastDeselect=TRUE)
Enables/disables Fast Deselect mode (like in Windows Explorer).
Definition XTPGridControl.h:4797
CXTPGridControl::OnBeginDrag
virtual void OnBeginDrag(CPoint point, UINT nFlags)
This method is called when the user begins dragging a row.
CXTPGridControl::m_strFilterText
CString m_strFilterText
Filter text.
Definition XTPGridControl.h:4174
CXTPGridControl::GetFreezeColumnsCount
int GetFreezeColumnsCount(int &nLastIndex) const
Gets the number of frozen columns starting from the left hand side.
CXTPGridControl::AdjustIndentation
void AdjustIndentation()
Adjusts control indentation properties depending on the current tree depth.
CXTPGridControl::m_nDefaultRowFreeHeight
int m_nDefaultRowFreeHeight
Row height for initialization.
Definition XTPGridControl.h:4251
CXTPGridControl::SetGridHeader
void SetGridHeader(CXTPGridHeader *pGridHeader)
Sets the associated grid header object.
CXTPGridControl::FreeRowBatchExtraData
static void AFX_CDECL FreeRowBatchExtraData()
This function is used when row batch allocation is enabled to both check all allocated blocks and dea...
CXTPGridControl::SetImageManager
void SetImageManager(CXTPImageManager *pImageManager)
Sets the image manager for the Grid control.
CXTPGridControl::SetVirtualMode
void SetVirtualMode(CXTPGridRecord *pVirtualRecord, int nCount, int nFields=0)
Call this method to enable virtual mode of the control.
CXTPGridControl::SetFilterHiddenColumns
virtual void SetFilterHiddenColumns(BOOL bFilterHidden)
Enables/disables search filter text in hidden columns.
Definition XTPGridControl.h:4717
CXTPGridControl::HasFocus
BOOL HasFocus() const
Determines if the Grid control has focus.
CXTPGridControl::GetDragSensitivityY
int GetDragSensitivityY() const
Gets the vertical sensitivity of Drag'n'Drop operations.
Definition XTPGridControl.h:4792
CXTPGridControl::GetTopRowIndex
int GetTopRowIndex() const
Gets the index of the top row of the Grid control view.
CXTPGridControl::m_bPrevHeaderShow
BOOL m_bPrevHeaderShow
Tells whether the previous header is visible or not.
Definition XTPGridControl.h:4277
CXTPGridControl::EditItem
void EditItem(XTP_GRIDRECORDITEM_ARGS *pItemArgs)
Edits a grid cell by focusing the specified cell and starting in-place editing for the control specif...
CXTPGridControlLocale
Helper class with static member functions used to control active locale for Grid control and perform ...
Definition XTPGridControl.h:4311
CXTPGridControlLocale::VariantChangeTypeEx
static BOOL AFX_CDECL VariantChangeTypeEx(VARIANT &rVarValue, VARTYPE vartype, BOOL bThrowError=TRUE)
Changes the type of a VARIANT value using the active locale ID.
CXTPGridControlLocale::SetUseResourceFileLocale
static void AFX_CDECL SetUseResourceFileLocale(BOOL bUseResourceFileLocale)
Used to set which locale is to be used as an the active locale: current user locale or resource file ...
CXTPGridControlLocale::FormatDateTime
static CString AFX_CDECL FormatDateTime(const COleDateTime &dt, LPCTSTR lpcszFormatString)
Formats a string using strftime() function format specifiers.
CXTPGridControlLocale::IsUseResourceFileLocale
static BOOL AFX_CDECL IsUseResourceFileLocale()
Determines which locale is to be used as an active locale: current user locale or resource file local...
CXTPGridControlLocale::GetActiveLCID
static LCID AFX_CDECL GetActiveLCID()
Retrieves the active locale ID (resource file locale or current user locale).
CXTPGridDataManager
Represents a grid data manager.
Definition XTPGridDataManager.h:153
CXTPGridGroupRow
This class represents a 'group row' of the Grid control view.
Definition XTPGridGroupRow.h:49
CXTPGridHeaderDragWnd
CXTPGridHeaderDragWnd is a CWnd derived class.
Definition XTPGridDragDrop.h:43
CXTPGridHeader
A grid header is a part of the grid window positioned above columns of text or numbers.
Definition XTPGridHeader.h:173
CXTPGridHyperlink
This class represents hyperlinks.
Definition XTPGridHyperlink.h:112
CXTPGridIconNavigator
Utility class, handles Grid control icon navigation.
Definition XTPGridNavigator.h:369
CXTPGridInplaceButtons
This class represents a collection of in-place buttons for a single item of the Grid control.
Definition XTPGridRecordItem.h:429
CXTPGridInplaceEdit
CXTPGridInplaceEdit is a CXTPGridInplaceControl derived class that represents an edit control to allo...
Definition XTPGridInplaceControls.h:88
CXTPGridInplaceList
CXTPGridInplaceList is a CXTPGridInplaceControl derived class that represents a list box with item co...
Definition XTPGridInplaceControls.h:527
CXTPGridNavigator
Utility class, handles Grid control item navigation.
Definition XTPGridNavigator.h:45
CXTPGridPaintManager
Utility class that handles most drawing activities.
Definition XTPGridPaintManager.h:76
CXTPGridRecord
CXTPGridRecord represents a collection of CXTPGridRecordItem objects or objects of classes that are c...
Definition XTPGridRecord.h:59
CXTPGridRecordItemConstraint
CXTPGridRecordItemConstraint is a CXTPCmdTarget derived class.
Definition XTPGridRecordItemConstraint.h:39
CXTPGridRecordItem
Class for working with single list cell.
Definition XTPGridRecordItem.h:600
CXTPGridRecords
This class represents a grid records collection.
Definition XTPGridRecords.h:71
CXTPGridRow
CXTPGridRow class represents a row of the Grid control window.
Definition XTPGridRow.h:71
CXTPGridRows
This class represents a rows collection class.
Definition XTPGridRows.h:108
CXTPGridSection
Represents a grid section.
Definition XTPGridSection.h:61
CXTPGridSections
Collection of sections.
Definition XTPGridSections.h:53
CXTPGridSelectedRows
Encapsulates a collection of CXTPGridRow pointers that represent the selected rows in a Grid control.
Definition XTPGridSelectedRows.h:73
CXTPGridSubListControl
Field chooser list box control.
Definition XTPGridSubListControl.h:60
CXTPGridTip
The CXTPGridTip class encapsulates the functionality of a "tip control", a small pop-up window that d...
Definition XTPGridTip.h:50
CXTPGridView
The CXTPGridView class provides an implementation of the Grid control as a view class.
Definition XTPGridView.h:73
CXTPImageManager
CXTPImageManager is a standalone class.
Definition XTPImageManager.h:1898
CXTPInternalCollectionT
Definition XTPSmartPtrInternalT.h:387
CXTPMarkupContext
CXTPMarkupContext is a standalone class used to provide common settings for Markup objects.
Definition XTPMarkupContext.h:128
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72
CXTPToolTipContext
CXTPToolTipContext is a CXTPCmdTarget derived class.
Definition XTPToolTipContext.h:291
XTP_GRIDRECORDITEM_ARGS
Basic set of parameters transferred to item handlers.
Definition XTPGridRecordItem.h:69
XTP_GRIDRECORDITEM_DRAWARGS
A set of parameters transferred to the Draw item handler.
Definition XTPGridRecordItem.h:125
XTP_GRIDRECORDITEM_METRICS
Record item drawing metrics.
Definition XTPGridRecordItem.h:356
XTP_NM_GRIDDRAGDROP
This structure is sent to the Main window in a WM_NOTIFY message from Grid Control to determine if re...
Definition XTPGridControl.h:137
XTP_NM_GRIDDRAGDROP::dropEffect
DROPEFFECT dropEffect
DropEffect flags.
Definition XTPGridControl.h:143
XTP_NM_GRIDDRAGDROP::pDataObject
COleDataObject * pDataObject
Data Object - required for drag over and drop.
Definition XTPGridControl.h:148
XTP_NM_GRIDDRAGDROP::dwKeyState
DWORD dwKeyState
Key state.
Definition XTPGridControl.h:146
XTP_NM_GRIDDRAGDROP::pTargetRecord
CXTPGridRecord * pTargetRecord
Target record (if any).
Definition XTPGridControl.h:140
XTP_NM_GRIDDRAGDROP::pt
CPoint pt
Current location of the cursor in client coordinates.
Definition XTPGridControl.h:144
XTP_NM_GRIDDRAGDROP::bAbove
BOOL bAbove
Where to insert (relative to the target record).
Definition XTPGridControl.h:142
XTP_NM_GRIDDRAGDROP::bReturnValue
BOOL bReturnValue
TRUE to accept dropEffect, FALSE to not accept dropEffect.
Definition XTPGridControl.h:149
XTP_NM_GRIDDRAGDROP::hdr
NMHDR hdr
Standard structure; contains information about a notification message.
Definition XTPGridControl.h:138
XTP_NM_GRIDDRAGDROP::nState
int nState
Transition state (0 - enter, 1 - leave, 2 - over).
Definition XTPGridControl.h:145
XTP_NM_GRIDDRAGDROP::pDataSource
COleDataSource * pDataSource
Data Source - issue 22675.
Definition XTPGridControl.h:147
XTP_NM_GRIDDRAGDROP::nTargetRow
int nTargetRow
Index of target row.
Definition XTPGridControl.h:141
XTP_NM_GRIDDRAGDROP::pRecords
CXTPGridRecords * pRecords
Records will be dragged/dropped.
Definition XTPGridControl.h:139
XTP_NM_GRIDITEMMETRICS
This structure is sent to the Main window in a WM_NOTIFY message from Item and provides all parameter...
Definition XTPGridControl.h:107
XTP_NM_GRIDITEMMETRICS::hdr
NMHDR hdr
Standard structure; contains information about a notification message.
Definition XTPGridControl.h:108
XTP_NM_GRIDITEMMETRICS::pDrawArgs
XTP_GRIDRECORDITEM_DRAWARGS * pDrawArgs
Pointer to an XTP_GRIDRECORDITEM_DRAWARGS structure.
Definition XTPGridControl.h:109
XTP_NM_GRIDITEMMETRICS::pItemMetrics
XTP_GRIDRECORDITEM_METRICS * pItemMetrics
Pointer to an XTP_GRIDRECORDITEM_METRICS structure to be filled.
Definition XTPGridControl.h:111
XTP_NM_GRIDPREVIEWKEYDOWN
This structure is sent to the Main window in a WM_NOTIFY message before processing the OnKeyDown even...
Definition XTPGridControl.h:161
XTP_NM_GRIDPREVIEWKEYDOWN::nFlags
UINT nFlags
[in] Specifies the scan code, key-transition code, previous key state, and context code.
Definition XTPGridControl.h:166
XTP_NM_GRIDPREVIEWKEYDOWN::nChar
UINT nChar
[in/out] Specifies the virtual key code of the given key.
Definition XTPGridControl.h:164
XTP_NM_GRIDPREVIEWKEYDOWN::bCancel
BOOL bCancel
[out] TRUE to cancel processing key, FALSE to continue.
Definition XTPGridControl.h:169
XTP_NM_GRIDPREVIEWKEYDOWN::hdr
NMHDR hdr
Standard structure; contains information about a notification message.
Definition XTPGridControl.h:162
XTP_NM_GRIDPREVIEWKEYDOWN::nRepCnt
UINT nRepCnt
[in] Repeat count.
Definition XTPGridControl.h:165
XTP_NM_GRIDTOOLTIPINFO
This structure is sent to the Main window in a WM_NOTIFY message from Item and provides all parameter...
Definition XTPGridRecordItem.h:278
XTPGridInputState
Stores the mouse and key states.
Definition XTPGridControl.h:337
XTPGridInputState::nRow
int nRow
Clicked row index.
Definition XTPGridControl.h:351
XTPGridInputState::bKeyControl
BOOL bKeyControl
Control key state.
Definition XTPGridControl.h:349
XTPGridInputState::ptMouse
CPoint ptMouse
Mouse position.
Definition XTPGridControl.h:348
XTPGridInputState::bSelected
BOOL bSelected
Clicked row selection state.
Definition XTPGridControl.h:352
XTPGridInputState::bKeyShift
BOOL bKeyShift
Shift key state.
Definition XTPGridControl.h:350


Toolkit Pro: XTPPropExchangeEnumeratorPtr.h Source File

  • Source
  • Common
  • PropExchange
XTPPropExchangeEnumeratorPtr.h
Go to the documentation of this file.
1
23#if !defined(__XTPPROPEXCHANGEENUMERATORPTR_H__)
24# define __XTPPROPEXCHANGEENUMERATORPTR_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class _XTP_EXT_CLASS CXTPPropExchangeEnumeratorPtr
34{
35public:
42 explicit CXTPPropExchangeEnumeratorPtr(CXTPPropExchangeEnumerator* pPX);
43
49 virtual ~CXTPPropExchangeEnumeratorPtr();
50
51 CXTPPropExchangeEnumerator& operator*() const;
52 CXTPPropExchangeEnumerator* operator->() const;
53 CXTPPropExchangeEnumerator* operator&() const;
54
55private:
56 CXTPPropExchangeEnumerator* m_pPX;
57};
58
59# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
61#endif // !defined(__XTPPROPEXCHANGEENUMERATORPTR_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPPropExchangeEnumerator
CXTPPropExchangeEnumerator is standalone class.
Definition XTPPropExchangeEnumerator.h:56


Toolkit Pro: XTPSkinObjectReBar.h Source File

  • Source
  • SkinFramework
XTPSkinObjectReBar.h
Go to the documentation of this file.
1
23#if !defined(__XTPSKINOBJECTREBAR_H__)
24# define __XTPSKINOBJECTREBAR_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPSkinObjectReBar : public CXTPSkinObjectFrame
39{
41 DECLARE_DYNCREATE(CXTPSkinObjectReBar)
43public:
48 CXTPSkinObjectReBar();
49
54 virtual ~CXTPSkinObjectReBar();
55
56private:
57 void DrawBandBorders(CDC* pDC);
58 void DrawBand(CDC* pDC, CXTPSkinManagerClass* pClassReBar, const CRect& rcBand,
59 const REBARBANDINFO& rbbi);
60
61protected:
64 DECLARE_MESSAGE_MAP()
65
66 //{{AFX_VIRTUAL(CXTPSkinObjectReBar)
67 virtual void OnDraw(CDC* pDC);
68 //}}AFX_VIRTUAL
69
70 //{{AFX_MSG(CXTPSkinObjectReBar)
71 afx_msg int OnCreate(LPCREATESTRUCT lpCreateStruct);
72 afx_msg BOOL OnEraseBkgnd(CDC* pDC);
73 afx_msg void OnPaint();
74 afx_msg LRESULT OnPrintClient(WPARAM wParam, LPARAM lParam);
75 //}}AFX_MSG
77};
78
79# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
81#endif // !defined(__XTPSKINOBJECTREBAR_H__)
XTPDisableNoisyWarnings.h
CXTPSkinManagerClass
CXTPSkinManagerClass is a standalone class that represents a single visual class of the skin manager.
Definition XTPSkinManager.h:110
CXTPSkinObjectFrame
CXTPSkinObjectFrame is a CXTPSkinObject derived class.
Definition XTPSkinObjectFrame.h:75
CXTPSkinObjectReBar
CXTPSkinObjectReBar is a CXTPSkinObjectFrame derived class.
Definition XTPSkinObjectReBar.h:39
CXTPSkinObjectReBar::CXTPSkinObjectReBar
CXTPSkinObjectReBar()
Constructs a CXTPSkinObjectReBar object.
CXTPSkinObjectReBar::~CXTPSkinObjectReBar
virtual ~CXTPSkinObjectReBar()
Destroys a CXTPSkinObjectReBar object, handles cleanup and deallocation.


Toolkit Pro: Member List

CXTPCalendarReminder Member List

This is the complete list of members for CXTPCalendarReminder, including all inherited members.

CXTPCalendarReminder(CXTPCalendarRemindersManager *pOwnerMan=NULL) | CXTPCalendarReminder |
CXTPCmdTarget() | CXTPCmdTarget |
Dismiss() | CXTPCalendarReminder | virtual
EventType enum name | CXTPCalendarReminder | protected
evtNormal enum value | CXTPCalendarReminder | protected
evtRecurrence enum value | CXTPCalendarReminder | protected
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetEvent() const | CXTPCalendarReminder | virtual
GetMinutesBeforeStart() const | CXTPCalendarReminder | virtual
GetNextReminderTime() const | CXTPCalendarReminder | virtual
IsEqualID(const CXTPCalendarReminder *pReminder2) const | CXTPCalendarReminder | virtual
m_dtEventStartTime | CXTPCalendarReminder | protected
m_dtNextReminderTime | CXTPCalendarReminder | protected
m_dwNormalEventID | CXTPCalendarReminder |
m_eEventType | CXTPCalendarReminder | protected
m_nMinutesBeforeStart | CXTPCalendarReminder | protected
m_pEventDataProvider | CXTPCalendarReminder | protected
m_RecurrenceEventInfo | CXTPCalendarReminder |
SetEvent(CXTPCalendarEvent *pEvent) | CXTPCalendarReminder | protectedvirtual
Snooze(int nMinutesAfterNow) | CXTPCalendarReminder | virtual
~CXTPCalendarReminder() | CXTPCalendarReminder | virtual


Toolkit Pro: Member List

  • CXTPTrackControl
  • DRAGBLOCK
CXTPTrackControl::DRAGBLOCK Member List

This is the complete list of members for CXTPTrackControl::DRAGBLOCK, including all inherited members.

nOldLength | CXTPTrackControl::DRAGBLOCK
nOldPos | CXTPTrackControl::DRAGBLOCK
pBlock | CXTPTrackControl::DRAGBLOCK
rcOrigin | CXTPTrackControl::DRAGBLOCK


Toolkit Pro: Member List

CXTPTreeVisualStudio2012Theme Member List

This is the complete list of members for CXTPTreeVisualStudio2012Theme, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPControlTheme() | CXTPControlTheme |
CXTPTreeTheme() | CXTPTreeTheme |
CXTPTreeVisualStudio2012Theme(BOOL bLight=TRUE) | CXTPTreeVisualStudio2012Theme |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetItemBackColor(UINT uState, bool bTreeHasFocus, DWORD dwStyle, COLORREF crTextDef, CTreeCtrl *pTreeBase) const | CXTPTreeTheme | virtual
GetItemTextColor(UINT uState, bool bTreeHasFocus, DWORD dwStyle, COLORREF crBackDef, CTreeCtrl *pTreeBase) const | CXTPTreeTheme | virtual
GetThemeStyle() const | CXTPControlTheme |
GetTreeBackColor() const | CXTPTreeTheme | virtual
GetTreeTextColor() const | CXTPTreeTheme | virtual
IsDrawFocusRect() const | CXTPTreeTheme | inline
IsThemeDark() const | CXTPTreeTheme | inlinevirtual
m_bDarkTheme | CXTPTreeTheme | protected
m_bDrawFocusRect | CXTPTreeTheme | protected
m_crBack | CXTPTreeTheme | protected
m_crBackDisabled | CXTPTreeTheme | protected
m_crBackSelected | CXTPTreeTheme | protected
m_crBackSelectedDisabled | CXTPTreeTheme | protected
m_crBackSelectedInactive | CXTPTreeTheme | protected
m_crText | CXTPTreeTheme | protected
m_crTextDisabled | CXTPTreeTheme | protected
m_crTextSelected | CXTPTreeTheme | protected
m_crTextSelectedDisabled | CXTPTreeTheme | protected
m_crTextSelectedInactive | CXTPTreeTheme | protected
m_nTheme | CXTPControlTheme | protected
RefreshMetrics(CXTPTreeBase *pTreeBase) | CXTPTreeVisualStudio2012Theme | virtual
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static
~CXTPTreeTheme() | CXTPTreeTheme | virtual


Toolkit Pro: XTPCalendarUtils.h Source File

  • Source
  • Calendar
XTPCalendarUtils.h
Go to the documentation of this file.
1
22#if !defined(__XTPCALENDARUTILS_H_)
23# define __XTPCALENDARUTILS_H_
24
25# if _MSC_VER > 1000
26# pragma once
27# endif // _MSC_VER > 1000
28
29# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
30
37# define XTP_HALF_SECOND (1.0 / 172800.0)
38
45static const COleDateTime xtpCalendarDateTime_min(100, 1, 1, 0, 0, 0);
46
53static const COleDateTime xtpCalendarDateTime_max(9999, 12, 31, 0, 0, 0);
54
55class CXTPCalendarEvent;
56
62class ITimeProvider
63{
64public:
65 // Handles object destruction
66 virtual ~ITimeProvider()
67 {
68 }
69
70 virtual COleDateTime GetCurrentTime() = 0;
71};
72
74
85template<class _Type>
86AFX_INLINE int XTPCompare(_Type e1, _Type e2)
87{
88 if (e1 > e2)
89 return 1;
90 if (e2 > e1)
91 return -1;
92 return 0;
93}
94
100class _XTP_EXT_CLASS CXTPCalendarUtils
101{
102private:
111 CXTPCalendarUtils();
112
113public:
125 static int AFX_CDECL GetLocaleLong(LCTYPE LCType);
126
140 static CString AFX_CDECL GetLocaleString(LCTYPE LCType, int nMaxLength = 128);
141
164 static CString AFX_CDECL GetDateFormat(CONST SYSTEMTIME* lpDate, LPCTSTR lpFormat);
165
185 static CString AFX_CDECL GetDateFormat(CONST COleDateTime& dtDate, LPCTSTR lpFormat);
186
208 static CString AFX_CDECL GetTimeFormat(CONST SYSTEMTIME* lpTime, LPCTSTR lpFormat);
209
229 static CString AFX_CDECL GetTimeFormat(CONST COleDateTime& dtTime, LPCTSTR lpFormat);
230
251 static CString AFX_CDECL GetTimeFormat(int nHour, int nMinutes, LPCTSTR lpFormat);
252
262 static int AFX_CDECL GetMaxMonthDay(COleDateTime dtDate);
263
283 static BOOL AFX_CDECL ShiftDate_Month(COleDateTime& refDate, int nMonthCount);
284
308 static BOOL AFX_CDECL ShiftDate_Month(COleDateTime& refDate, int nMonthCount, int nMonthDay);
309
328 static BOOL AFX_CDECL ShiftDate_Year(COleDateTime& refDate, int nYearCount);
329
352 static BOOL AFX_CDECL ShiftDate_Year(COleDateTime& refDate, int nYearCount, int nMonthDay);
353
371 static int AFX_CDECL GetDurationMinutes(const COleDateTime& dtStart, const COleDateTime& dtEnd,
372 BOOL bAllDayEvent);
373
396 static BOOL AFX_CDECL UpdateMonthDay(COleDateTime& refDate, int nMonthDay);
397
413 static const COleDateTime AFX_CDECL UpdateTime(const COleDateTime& dtDate, int nHour,
414 int nMinutes, int nSeconds);
415
429 static const COleDateTime AFX_CDECL UpdateTime(const COleDateTime& dtDate,
430 const COleDateTime& dtTime);
431
443 static const COleDateTime AFX_CDECL SetTime_235959(const COleDateTime& dtDateTime);
444
458 static const COleDateTime AFX_CDECL UpdateDate(const COleDateTime& dtTime,
459 const COleDateTime& dtDate);
460
478 static const COleDateTime AFX_CDECL UpdateDate(const COleDateTime& dtTime, int nYear,
479 int nMonth, int nDay);
480
492 static const COleDateTime AFX_CDECL ResetTime(const COleDateTime& dtDateTime);
493
505 static const COleDateTime AFX_CDECL ResetTime(const DATE dtDateTime);
506
519 static const COleDateTime AFX_CDECL ResetDate(const COleDateTime& dtDateTime);
520
538 static BOOL AFX_CDECL IsEqual(const COleDateTime& dt1, const COleDateTime& dt2,
539 BOOL bOneSecTimeDiff = FALSE);
540
552 static BOOL AFX_CDECL IsZeroTime(const COleDateTime& dtDateTime);
553
568 static int AFX_CDECL GetDiff_Months(const COleDateTime& dt1, const COleDateTime& dt2);
569
584 static COleDateTime AFX_CDECL RetriveEventEndDate(const CXTPCalendarEvent* pEvent);
585
601 static COleDateTime AFX_CDECL RetriveEventEndDate(const COleDateTime& dtStart,
602 const COleDateTime& dtEnd);
603
617 static int AFX_CDECL GetEventPeriodDays(const COleDateTime& dtStart, const COleDateTime& dtEnd);
618
643 static BOOL AFX_CDECL CalcDayOfMonth(COleDateTime& rdtDate, int nWhichDay, int nWhichDayMask);
644
660 static int AFX_CDECL GetDayOfWeekMask(int nWeekDay);
661
677 static int AFX_CDECL GetDayOfWeekIndex(int nDayOfWeekMask);
678
694 static int AFX_CDECL GetDayOfWeekCount(int nDayOfWeekMask);
695
709 static int AFX_CDECL GetDayOfWeekLocaleStringId(int nWeekDay);
710
725 static int AFX_CDECL MakeDaysOfWeekMask_Mo_(int nEndWDay);
726
743 static COleDateTime AFX_CDECL ShiftDateToWeekBegin(COleDateTime dtDate,
744 int nFirstDayOfWeekIndex = 1);
745
759 static int AFX_CDECL GetWeekOfYear(COleDateTime dtDate, int nFirstDayOfWeekIndex = 1);
760
782 static BOOL AFX_CDECL SystemTimeToTzSpecificLocalTime(const TIME_ZONE_INFORMATION* pTZI,
783 const SYSTEMTIME* pUTime,
784 SYSTEMTIME* pTzTime);
785
793 static BOOL AFX_CDECL IsWin9x();
794
804 static COleDateTimeSpan AFX_CDECL Minutes2Span(int nMinutes);
805
806private:
807 static ITimeProvider* g_TimeProviderOverride;
808
809public:
816 static COleDateTime AFX_CDECL GetCurrentTime();
817
830 static void AFX_CDECL OverrideTimeProvider(ITimeProvider* pTimeProvider);
831
837 static void AFX_CDECL ResetTimeProvider();
838
845 static CString AFX_CDECL GetTimeFormatString_HrMin();
846
856 static int AFX_CDECL ParceTimeString_min(LPCTSTR pcszTime_HrMin);
857
869 static CString AFX_CDECL FormatTimeDuration(int nMinutes, BOOL bRoundly);
870
881 static int AFX_CDECL ParceTimeDuration_min(LPCTSTR pcszTimeDuration);
882
891 static CString AFX_CDECL LoadString(UINT nIDResource);
892
906 static BOOL AFX_CDECL LoadString2(CString& rstrString, UINT nIDResource);
907
922 static void AFX_CDECL TextPrepareSingleline(CString& rstrString);
923
933 static LCID AFX_CDECL GetActiveLCID();
934
951 static CFont* AFX_CDECL GetMaxHeightFont(CArray<CFont*, CFont*>& arFonts, CDC* pDC,
952 int* pnMaxHeight = NULL);
953
963 static BOOL AFX_CDECL IsFormatChar(TCHAR t);
964
974 static CString AFX_CDECL RemoveFormatPart(CString strFormat, LPCTSTR lpszRemove);
975
985 static CString AFX_CDECL RemoveFormatPart(CString strFormat, TCHAR cRemove);
986
997 static void AFX_CDECL StripFormat(CString& strFormat, int nIndex, int nRemove);
998
999 // {{AFX_CODEJOCK_PRIVATE
1000 _XTP_DEPRECATED_MSG("Resource file locale is enforced to use by default")
1001 static BOOL AFX_CDECL IsUseResourceFileLocale();
1002 _XTP_DEPRECATED_MSG("Resource file locale is enforced to use by default")
1003 static void AFX_CDECL SetUseResourceFileLocale(BOOL bUseResourceFileLocale);
1004 // }}AFX_CODEJOCK_PRIVATE
1005
1006private:
1007 static BOOL AFX_CDECL IsInDst(const TIME_ZONE_INFORMATION* pTZI, COleDateTime dtTime);
1008
1009 struct CXTPTimesResourceIDs
1010 {
1011 typedef CMap<int, int, UINT, UINT> CMapInt2UINT;
1012
1013 CMapInt2UINT s_mapMinutes;
1014 CMapInt2UINT s_mapHours;
1015 CMapInt2UINT s_mapDays;
1016 CMapInt2UINT s_mapWeeks;
1017
1018 CXTPTimesResourceIDs();
1019 };
1020
1021public:
1031 static double AFX_CDECL _RoundDateTime_dbl(double dblDT);
1032
1041 static double AFX_CDECL _ResetTime_dbl(double dblDT);
1042
1051 static double AFX_CDECL _ResetDate_dbl(double dblDT);
1052
1053public:
1068 static BOOL AFX_CDECL TrackMouseEvent(DWORD dwFlags, HWND hwndTrack,
1069 DWORD dwHoverTime = HOVER_DEFAULT);
1070
1077 static int AFX_CDECL GetFirstWeekOfYearDays();
1078
1079public:
1080 static BOOL AFX_CDECL GetAsSystemTime(const COleDateTime& dtTime, SYSTEMTIME& sysTime);
1081 static LONG AFX_CDECL GetTotalDays(const COleDateTimeSpan& spSpan);
1082 static LONG AFX_CDECL GetTotalHours(const COleDateTimeSpan& spSpan);
1083 static LONG AFX_CDECL GetTotalMinutes(const COleDateTimeSpan& spSpan);
1084 static LONG AFX_CDECL GetTotalSeconds(const COleDateTimeSpan& spSpan);
1085 static LONG AFX_CDECL _DoubleToLONG(double dValue);
1086};
1087
1088AFX_INLINE BOOL AFX_CDECL CXTPCalendarUtils::IsUseResourceFileLocale()
1089{
1090 return TRUE;
1091}
1092
1093AFX_INLINE void AFX_CDECL CXTPCalendarUtils::SetUseResourceFileLocale(BOOL bUseResourceFileLocale)
1094{
1095 UNREFERENCED_PARAMETER(bUseResourceFileLocale);
1096}
1097
1098//===========================================================================
1099
1107template<class _TValue>
1108class CXTPAutoResetValue
1109{
1110 _TValue m_valReset;
1111 _TValue& m_rData;
1112
1113public:
1124 CXTPAutoResetValue(_TValue& rData)
1125 : m_rData(rData)
1126 {
1127 m_valReset = rData;
1128 }
1129
1141 CXTPAutoResetValue(_TValue& rData, const _TValue& valReset)
1142 : m_rData(rData)
1143 {
1144 m_valReset = valReset;
1145 }
1146
1155 virtual ~CXTPAutoResetValue()
1156 {
1157 m_rData = m_valReset;
1158 }
1159
1166 operator _TValue&()
1167 {
1168 return m_rData;
1169 }
1170
1180 const _TValue& operator=(const _TValue& rSrc)
1181 {
1182 return m_rData = rSrc;
1183 }
1184};
1185
1187AFX_INLINE double CXTPCalendarUtils::_RoundDateTime_dbl(double dblDT)
1188{
1189 return (dblDT >= 0 ? dblDT + XTP_HALF_SECOND : dblDT - XTP_HALF_SECOND);
1190}
1191
1192AFX_INLINE double CXTPCalendarUtils::_ResetTime_dbl(double dblDT)
1193{
1194 return (double)((LONGLONG)_RoundDateTime_dbl(dblDT));
1195}
1196
1197AFX_INLINE double CXTPCalendarUtils::_ResetDate_dbl(double dblDT)
1198{
1199 double dblDate = _ResetTime_dbl(dblDT);
1200 double dblResult = dblDT > dblDate ? (dblDT - dblDate) : (dblDate - dblDT);
1201
1202 double dblDate_raw = (double)((LONGLONG)dblDT);
1203
1204 if (dblDate_raw != dblDate)
1205 {
1206 dblResult = _RoundDateTime_dbl(dblResult);
1207 }
1208 return dblResult;
1209}
1210
1211AFX_INLINE const COleDateTime CXTPCalendarUtils::ResetTime(const COleDateTime& dtDateTime)
1212{
1213 return (DATE)_ResetTime_dbl((double)dtDateTime);
1214}
1215
1216AFX_INLINE const COleDateTime CXTPCalendarUtils::ResetTime(const DATE dtDateTime)
1217{
1218 return (DATE)_ResetTime_dbl((double)dtDateTime);
1219}
1220
1221AFX_INLINE const COleDateTime CXTPCalendarUtils::ResetDate(const COleDateTime& dtDateTime)
1222{
1223 return (DATE)_ResetDate_dbl((double)dtDateTime);
1224}
1225
1226AFX_INLINE const COleDateTime CXTPCalendarUtils::SetTime_235959(const COleDateTime& dtDateTime)
1227{
1228 double dDate = _ResetTime_dbl((double)dtDateTime);
1229 return (DATE)(dDate + 1 - XTP_HALF_SECOND * 2);
1230}
1231
1232AFX_INLINE int CXTPCalendarUtils::GetDayOfWeekMask(int nWeekDay)
1233{
1234 _ASSERTE(nWeekDay >= 1 && nWeekDay <= 7);
1235
1236 int nRes = 1 << (nWeekDay - 1);
1237 return nRes;
1238}
1239
1240// return 1 = Sunday, 2 = Monday ...
1241AFX_INLINE int CXTPCalendarUtils::GetDayOfWeekIndex(int nDayOfWeekMask)
1242{
1243 // int nTestMask[7];
1244 // for (int i = 1; i <= 7; i++)
1245 //{
1246 // nTestMask[i - 1] = 1 << (i-1);
1247 //}
1248 // this loop fill array {1,2,4,8,16,32,64}
1249 // by enum XTPCalendarWeekDay
1250 // xtpCalendarDaySunday = 0x001, // Sunday
1251 // xtpCalendarDayMonday = 0x002, // Monday
1252 // xtpCalendarDayTuesday = 0x004, // Tuesday
1253 // xtpCalendarDayWednesday = 0x008, // Wednesday
1254 // xtpCalendarDayThursday = 0x010, // Thursday
1255 // xtpCalendarDayFriday = 0x020, // Friday
1256 // xtpCalendarDaySaturday = 0x040, // Saturday
1257
1258 for (int i = 1; i <= 7; i++)
1259 {
1260 // if (nTestMask[i-1] == nDayOfWeekMask)
1261 int nTestMask = 1 << (i - 1);
1262 if (nTestMask == nDayOfWeekMask)
1263 {
1264 return i;
1265 }
1266 }
1267 _ASSERTE(FALSE);
1268 return 0;
1269}
1270
1271AFX_INLINE int CXTPCalendarUtils::GetMaxMonthDay(COleDateTime dtDate)
1272{
1273 SYSTEMTIME sysDate;
1274 if (!CXTPCalendarUtils::GetAsSystemTime(dtDate, sysDate))
1275 return 0;
1276
1277 // days per month - _ jan feb mar apr may jun jul aug sep oct nov dec
1278 static int arDays[13] = { 0, 31, 28, 31, 30, 31, 30, 31, 31, 30, 31, 30, 31 };
1279 if (sysDate.wMonth == 2 && sysDate.wYear % 4 == 0)
1280 {
1281 if (sysDate.wYear % 100 != 0 || sysDate.wYear % 400 == 0)
1282 return 29;
1283 else
1284 return 28;
1285 }
1286 else
1287 {
1288 return arDays[sysDate.wMonth];
1289 }
1290}
1291
1292AFX_INLINE BOOL CXTPCalendarUtils::UpdateMonthDay(COleDateTime& refDate, int nMonthDay)
1293{
1294 if (nMonthDay > 28)
1295 {
1296 int nMaxDay = GetMaxMonthDay(refDate);
1297 if (!nMaxDay)
1298 {
1299 return FALSE;
1300 }
1301 nMonthDay = min(nMonthDay, nMaxDay);
1302 }
1303
1304 SYSTEMTIME sysDate;
1305 if (!CXTPCalendarUtils::GetAsSystemTime(refDate, sysDate))
1306 return FALSE;
1307
1308 int nRes = refDate.SetDate(sysDate.wYear, sysDate.wMonth, nMonthDay);
1309 return nRes == 0;
1310}
1311/*
1312AFX_INLINE BOOL CXTPCalendarUtils::ShiftDate_Month(COleDateTime &refDate, int nMonthCount)
1313{
1314 int nYearOld = refDate.GetYear();
1315 int nMonthOld = refDate.GetMonth();
1316 int nYearNew = nYearOld + (-12 + nMonthOld + nMonthCount) / 12;
1317 int nMonthCalc = nMonthOld + nMonthCount - 1;
1318 if (nMonthCalc < 0)
1319 nMonthCalc = 12 * (-nMonthCalc) + nMonthCalc;
1320 int nMonthNew = 1 + nMonthCalc % 12;
1321 return COleDateTime::valid == refDate.SetDate(nYearNew, nMonthNew, 1);
1322}
1323*/
1324AFX_INLINE BOOL CXTPCalendarUtils::ShiftDate_Month(COleDateTime& refDate, int nMonthCount)
1325{
1326 SYSTEMTIME sysDate;
1327 if (!CXTPCalendarUtils::GetAsSystemTime(refDate, sysDate))
1328 return FALSE;
1329
1330 int nYearNew = sysDate.wYear + nMonthCount / 12;
1331 int nMonthNew = sysDate.wMonth + nMonthCount % 12;
1332
1333 if (nMonthNew > 12)
1334 {
1335 nMonthNew -= 12 * (nMonthCount / abs(nMonthCount));
1336 nYearNew++;
1337 }
1338 else if (nMonthNew <= 0)
1339 {
1340 nYearNew--;
1341 nMonthNew += 12;
1342
1343 _ASSERTE(nMonthNew >= 1 && nMonthNew <= 12);
1344 }
1345
1346 return COleDateTime::valid == refDate.SetDate(nYearNew, nMonthNew, 1);
1347}
1348
1349AFX_INLINE BOOL CXTPCalendarUtils::ShiftDate_Month(COleDateTime& refDate, int nMonthCount,
1350 int nMonthDay)
1351{
1352 if (ShiftDate_Month(refDate, nMonthCount))
1353 {
1354 BOOL bRes = UpdateMonthDay(refDate, nMonthDay);
1355 return bRes;
1356 }
1357 return FALSE;
1358}
1359
1360AFX_INLINE BOOL CXTPCalendarUtils::ShiftDate_Year(COleDateTime& refDate, int nYearCount)
1361{
1362 SYSTEMTIME sysDate;
1363 if (!CXTPCalendarUtils::GetAsSystemTime(refDate, sysDate))
1364 {
1365 return FALSE;
1366 }
1367 int nYearNew = sysDate.wYear + nYearCount;
1368 return COleDateTime::valid == refDate.SetDate(nYearNew, sysDate.wMonth, 1);
1369}
1370
1371AFX_INLINE BOOL CXTPCalendarUtils::ShiftDate_Year(COleDateTime& refDate, int nYearCount,
1372 int nMonthDay)
1373{
1374 if (ShiftDate_Year(refDate, nYearCount))
1375 {
1376 BOOL bRes = UpdateMonthDay(refDate, nMonthDay);
1377 return bRes;
1378 }
1379 return FALSE;
1380}
1381
1382AFX_INLINE int CXTPCalendarUtils::GetDiff_Months(const COleDateTime& dt1, const COleDateTime& dt2)
1383{
1384 int nYear1 = dt1.GetYear();
1385 int nMonth1 = dt1.GetMonth();
1386
1387 int nYear2 = dt2.GetYear();
1388 int nMonth2 = dt2.GetMonth();
1389
1390 int nYearDiff = nYear1 - nYear2;
1391 int nMonthDiff = nYearDiff * 12;
1392
1393 nMonthDiff += nMonth1 - nMonth2;
1394
1395 return nMonthDiff;
1396}
1397
1398AFX_INLINE int CXTPCalendarUtils::GetDurationMinutes(const COleDateTime& dtStart,
1399 const COleDateTime& dtEnd, BOOL bAllDayEvent)
1400{
1401 COleDateTimeSpan spDuration;
1402 if (bAllDayEvent)
1403 {
1404 spDuration = SetTime_235959(dtEnd) - ResetTime(dtStart);
1405 }
1406 else
1407 {
1408 spDuration = dtEnd - dtStart;
1409 }
1410 return (int)CXTPCalendarUtils::GetTotalMinutes(spDuration);
1411}
1412
1413AFX_INLINE const COleDateTime CXTPCalendarUtils::UpdateTime(const COleDateTime& dtDate, int nHour,
1414 int nMinutes, int nSeconds)
1415{
1416 SYSTEMTIME stResult;
1417 if (!CXTPCalendarUtils::GetAsSystemTime(dtDate, stResult))
1418 {
1419 _ASSERTE(FALSE);
1420 return dtDate;
1421 }
1422
1423 stResult.wHour = (WORD)nHour;
1424 stResult.wMinute = (WORD)nMinutes;
1425 stResult.wSecond = (WORD)nSeconds;
1426
1427 return COleDateTime(stResult);
1428}
1429
1430AFX_INLINE const COleDateTime CXTPCalendarUtils::UpdateTime(const COleDateTime& dtDate,
1431 const COleDateTime& dtTime)
1432{
1433 double dDate = _ResetTime_dbl((double)dtDate);
1434 double dTime = _ResetDate_dbl((double)dtTime);
1435 return (DATE)(dDate + dTime);
1436}
1437
1438AFX_INLINE const COleDateTime CXTPCalendarUtils::UpdateDate(const COleDateTime& dtTime, int nYear,
1439 int nMonth, int nDay)
1440{
1441 SYSTEMTIME stResult;
1442 if (!CXTPCalendarUtils::GetAsSystemTime(dtTime, stResult))
1443 {
1444 _ASSERTE(FALSE);
1445 return dtTime;
1446 }
1447
1448 stResult.wYear = (WORD)nYear;
1449 stResult.wMonth = (WORD)nMonth;
1450 stResult.wDay = (WORD)nDay;
1451
1452 return COleDateTime(stResult);
1453}
1454
1455AFX_INLINE const COleDateTime CXTPCalendarUtils::UpdateDate(const COleDateTime& dtTime,
1456 const COleDateTime& dtDate)
1457{
1458 double dDate = _ResetTime_dbl((double)dtDate);
1459 double dTime = _ResetDate_dbl((double)dtTime);
1460 return (DATE)(dDate + dTime);
1461}
1462
1463AFX_INLINE COleDateTime CXTPCalendarUtils::RetriveEventEndDate(const COleDateTime& dtStart,
1464 const COleDateTime& dtEnd)
1465{
1466 COleDateTime dtEndDay = ResetTime(dtEnd);
1467
1468 if (IsZeroTime(dtEnd))
1469 {
1470 COleDateTime dtStartDay = ResetTime(dtStart);
1471
1472 if (dtStartDay < dtEndDay)
1473 {
1474 const COleDateTimeSpan spDay(1, 0, 0, 0);
1475 dtEndDay -= spDay;
1476 }
1477 }
1478 return dtEndDay;
1479}
1480
1481AFX_INLINE int CXTPCalendarUtils::GetEventPeriodDays(const COleDateTime& dtStart,
1482 const COleDateTime& dtEnd)
1483{
1484 COleDateTime dtStartDay = ResetTime(dtStart);
1485 COleDateTime dtEndDay = RetriveEventEndDate(dtStart, dtEnd);
1486
1487 COleDateTimeSpan spDuration = dtEndDay - dtStartDay;
1488 int nDays = (int)CXTPCalendarUtils::GetTotalDays(spDuration) + 1;
1489
1490 return nDays;
1491}
1492
1493AFX_INLINE COleDateTimeSpan CXTPCalendarUtils::Minutes2Span(int nMunutes)
1494{
1495 double dblSpan = ((double)nMunutes) / (24 * 60);
1496 return COleDateTimeSpan(dblSpan);
1497}
1498
1499AFX_INLINE COleDateTime CXTPCalendarUtils::ShiftDateToWeekBegin(COleDateTime dtDate,
1500 int nFirstDayOfWeekIndex)
1501{
1502 dtDate = CXTPCalendarUtils::ResetTime(dtDate);
1503
1504 int nShift = (dtDate.GetDayOfWeek() - nFirstDayOfWeekIndex + 7) % 7;
1505 if (nShift)
1506 {
1507 COleDateTimeSpan spShift(nShift, 0, 0, 0);
1508 dtDate -= spShift;
1509 }
1510 return dtDate;
1511}
1512
1513AFX_INLINE int CXTPCalendarUtils::GetDayOfWeekCount(int nDayOfWeekMask)
1514{
1515 int nCount = 0;
1516 for (int i = 1; i <= 7; i++)
1517 {
1518 int nTestMask = 1 << (i - 1);
1519 if (nTestMask & nDayOfWeekMask)
1520 {
1521 nCount++;
1522 }
1523 }
1524 return nCount;
1525}
1526
1527AFX_INLINE int CXTPCalendarUtils::MakeDaysOfWeekMask_Mo_(int nEndWDay)
1528{
1529 int nMask = 0;
1530 for (int i = 1; i < nEndWDay; i++)
1531 {
1532 int nWDMask = CXTPCalendarUtils::GetDayOfWeekMask(i);
1533 nMask |= nWDMask;
1534 }
1535 return nMask;
1536}
1537
1538AFX_INLINE BOOL CXTPCalendarUtils::GetAsSystemTime(const COleDateTime& dtTime, SYSTEMTIME& sysTime)
1539{
1540 ::ZeroMemory(&sysTime, sizeof(sysTime));
1541 return dtTime.GetAsSystemTime(sysTime);
1542}
1543
1544AFX_INLINE LONG CXTPCalendarUtils::GetTotalDays(const COleDateTimeSpan& spSpan)
1545{
1546 return (LONG)spSpan.GetTotalDays();
1547}
1548
1549AFX_INLINE LONG CXTPCalendarUtils::GetTotalHours(const COleDateTimeSpan& spSpan)
1550{
1551 return (LONG)spSpan.GetTotalHours();
1552}
1553
1554AFX_INLINE LONG CXTPCalendarUtils::_DoubleToLONG(double dValue)
1555{
1556 return LONG(dValue > 0 ? min(dValue, double(LONG_MAX)) : max(dValue, double(LONG_MIN)));
1557}
1558
1559AFX_INLINE LONG CXTPCalendarUtils::GetTotalMinutes(const COleDateTimeSpan& spSpan)
1560{
1561 double dSpan = _RoundDateTime_dbl(spSpan);
1562 double dMinutes = dSpan * 24 * 60;
1563 LONG nMinutes = _DoubleToLONG(dMinutes);
1564 return nMinutes;
1565}
1566
1567AFX_INLINE LONG CXTPCalendarUtils::GetTotalSeconds(const COleDateTimeSpan& spSpan)
1568{
1569 double dSpan = _RoundDateTime_dbl(spSpan);
1570 double dSeconds = dSpan * 24 * 60 * 60;
1571 LONG nSeconds = _DoubleToLONG(dSeconds);
1572 return nSeconds;
1573}
1574
1576
1577# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
1578#endif // !defined(__XTPCALENDARUTILS_H_)
xtpCalendarDateTime_min
static const COleDateTime xtpCalendarDateTime_min(100, 1, 1, 0, 0, 0)
Defines a lower bound of the time frame for the Calendar control.
XTPCompare
AFX_INLINE int XTPCompare(_Type e1, _Type e2)
This template function is used to compare operands using operator > for the operands type and return ...
Definition XTPCalendarUtils.h:86
XTP_HALF_SECOND
#define XTP_HALF_SECOND
Definition XTPCalendarUtils.h:37
xtpCalendarDateTime_max
static const COleDateTime xtpCalendarDateTime_max(9999, 12, 31, 0, 0, 0)
Defines an upper bound of the time frame for the Calendar control.
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPAutoResetValue
Helper class template provides functionality to temporary set some to variable and reset to initial o...
Definition XTPCalendarUtils.h:1109
CXTPAutoResetValue::CXTPAutoResetValue
CXTPAutoResetValue(_TValue &rData, const _TValue &valReset)
Object constructor.
Definition XTPCalendarUtils.h:1141
CXTPAutoResetValue::operator=
const _TValue & operator=(const _TValue &rSrc)
This member function overloads the assignment operator for the CXTPAutoResetValue class.
Definition XTPCalendarUtils.h:1180
CXTPAutoResetValue::CXTPAutoResetValue
CXTPAutoResetValue(_TValue &rData)
Object constructor.
Definition XTPCalendarUtils.h:1124
CXTPAutoResetValue::~CXTPAutoResetValue
virtual ~CXTPAutoResetValue()
Object destructor.
Definition XTPCalendarUtils.h:1155
CXTPCalendarEvent
This class represents the data of a single Event used in the Calendar control.
Definition XTPCalendarEvent.h:77
CXTPCalendarUtils
Helper class with static member functions to perform common tasks with dates, events and other object...
Definition XTPCalendarUtils.h:101
CXTPCalendarUtils::UpdateMonthDay
static BOOL AFX_CDECL UpdateMonthDay(COleDateTime &refDate, int nMonthDay)
This member function is used to safely update a month day in the specified date.
Definition XTPCalendarUtils.h:1292
CXTPCalendarUtils::CalcDayOfMonth
static BOOL AFX_CDECL CalcDayOfMonth(COleDateTime &rdtDate, int nWhichDay, int nWhichDayMask)
This member function is used to calculate the day of the month from the provided COleDateTime object.
CXTPCalendarUtils::GetTimeFormatString_HrMin
static CString AFX_CDECL GetTimeFormatString_HrMin()
Returns current time format string for hours and minutes.
CXTPCalendarUtils::GetWeekOfYear
static int AFX_CDECL GetWeekOfYear(COleDateTime dtDate, int nFirstDayOfWeekIndex=1)
This member function is used to calculate a week number of year.
CXTPCalendarUtils::IsFormatChar
static BOOL AFX_CDECL IsFormatChar(TCHAR t)
Call this function to check if a character is a format character (Mm Dd Yy).
CXTPCalendarUtils::GetEventPeriodDays
static int AFX_CDECL GetEventPeriodDays(const COleDateTime &dtStart, const COleDateTime &dtEnd)
Call this member function to get an event duration as a number of days.
Definition XTPCalendarUtils.h:1481
CXTPCalendarUtils::GetDiff_Months
static int AFX_CDECL GetDiff_Months(const COleDateTime &dt1, const COleDateTime &dt2)
This member function is used to calculate differences between 2 dates in months.
Definition XTPCalendarUtils.h:1382
CXTPCalendarUtils::GetDurationMinutes
static int AFX_CDECL GetDurationMinutes(const COleDateTime &dtStart, const COleDateTime &dtEnd, BOOL bAllDayEvent)
This member function is used to determine the number of minutes between two DateTime objects.
Definition XTPCalendarUtils.h:1398
CXTPCalendarUtils::GetDateFormat
static CString AFX_CDECL GetDateFormat(CONST SYSTEMTIME *lpDate, LPCTSTR lpFormat)
This member function is used to format a date as a date string for a LOCALE_USER_DEFAULT locale.
CXTPCalendarUtils::ResetTime
static const COleDateTime AFX_CDECL ResetTime(const COleDateTime &dtDateTime)
This member function is used to reset (set to zero) the time part for the specified DateTime value.
Definition XTPCalendarUtils.h:1211
CXTPCalendarUtils::ShiftDate_Year
static BOOL AFX_CDECL ShiftDate_Year(COleDateTime &refDate, int nYearCount)
This member function is used to shift the specified date for the specified number of years.
Definition XTPCalendarUtils.h:1360
CXTPCalendarUtils::GetDayOfWeekMask
static int AFX_CDECL GetDayOfWeekMask(int nWeekDay)
This member function is used to convert a sequential week day number (from 1 to 7) to a value from th...
Definition XTPCalendarUtils.h:1232
CXTPCalendarUtils::IsWin9x
static BOOL AFX_CDECL IsWin9x()
This function is used to determine if the program is running on Windows 9x operation system family.
CXTPCalendarUtils::ResetTimeProvider
static void AFX_CDECL ResetTimeProvider()
Resets time provider to default which will use the current machine date time.
CXTPCalendarUtils::_ResetTime_dbl
static double AFX_CDECL _ResetTime_dbl(double dblDT)
This function is used to reset the time part.
Definition XTPCalendarUtils.h:1192
CXTPCalendarUtils::_ResetDate_dbl
static double AFX_CDECL _ResetDate_dbl(double dblDT)
This function used is to reset the date part.
Definition XTPCalendarUtils.h:1197
CXTPCalendarUtils::SystemTimeToTzSpecificLocalTime
static BOOL AFX_CDECL SystemTimeToTzSpecificLocalTime(const TIME_ZONE_INFORMATION *pTZI, const SYSTEMTIME *pUTime, SYSTEMTIME *pTzTime)
The SystemTimeToTzSpecificLocalTime function converts a time in Coordinated Universal Time (UTC) to a...
CXTPCalendarUtils::GetDayOfWeekLocaleStringId
static int AFX_CDECL GetDayOfWeekLocaleStringId(int nWeekDay)
Obtains locale string ID for a week day specified.
CXTPCalendarUtils::UpdateTime
static const COleDateTime AFX_CDECL UpdateTime(const COleDateTime &dtDate, int nHour, int nMinutes, int nSeconds)
This member function is used to update the time part for the specified DateTime value.
Definition XTPCalendarUtils.h:1413
CXTPCalendarUtils::GetDateFormat
static CString AFX_CDECL GetDateFormat(CONST COleDateTime &dtDate, LPCTSTR lpFormat)
This member function is used to format a date as a date string for a LOCALE_USER_DEFAULT locale.
CXTPCalendarUtils::GetTimeFormat
static CString AFX_CDECL GetTimeFormat(int nHour, int nMinutes, LPCTSTR lpFormat)
This member function is used to format a time as a time string for a LOCALE_USER_DEFAULT locale.
CXTPCalendarUtils::GetCurrentTime
static COleDateTime AFX_CDECL GetCurrentTime()
Returns current local time.
CXTPCalendarUtils::LoadString
static CString AFX_CDECL LoadString(UINT nIDResource)
Loads string using XTPResourceManager.
CXTPCalendarUtils::Minutes2Span
static COleDateTimeSpan AFX_CDECL Minutes2Span(int nMinutes)
Converts a number of minutes into its corresponding COleDateTimeSpan object.
Definition XTPCalendarUtils.h:1493
CXTPCalendarUtils::ShiftDateToWeekBegin
static COleDateTime AFX_CDECL ShiftDateToWeekBegin(COleDateTime dtDate, int nFirstDayOfWeekIndex=1)
This member function is used to shift the specified date to the beginning of the week.
Definition XTPCalendarUtils.h:1499
CXTPCalendarUtils::SetTime_235959
static const COleDateTime AFX_CDECL SetTime_235959(const COleDateTime &dtDateTime)
This member function is used to update the time part to 23:59.
Definition XTPCalendarUtils.h:1226
CXTPCalendarUtils::_RoundDateTime_dbl
static double AFX_CDECL _RoundDateTime_dbl(double dblDT)
This function is used to round date time values by adding (or subtracting) a half-second double value...
Definition XTPCalendarUtils.h:1187
CXTPCalendarUtils::IsZeroTime
static BOOL AFX_CDECL IsZeroTime(const COleDateTime &dtDateTime)
This member function is used to determine if the time part is equal to zero.
CXTPCalendarUtils::RetriveEventEndDate
static COleDateTime AFX_CDECL RetriveEventEndDate(const CXTPCalendarEvent *pEvent)
Get event end date (date part only) value.
CXTPCalendarUtils::OverrideTimeProvider
static void AFX_CDECL OverrideTimeProvider(ITimeProvider *pTimeProvider)
Overrides the local time provider with the custom provider.
CXTPCalendarUtils::MakeDaysOfWeekMask_Mo_
static int AFX_CDECL MakeDaysOfWeekMask_Mo_(int nEndWDay)
This member function is used to make the days mask from Monday until the specified day.
Definition XTPCalendarUtils.h:1527
CXTPCalendarUtils::GetTimeFormat
static CString AFX_CDECL GetTimeFormat(CONST COleDateTime &dtTime, LPCTSTR lpFormat)
This member function is used to format a time as a time string for a LOCALE_USER_DEFAULT locale.
CXTPCalendarUtils::ParceTimeDuration_min
static int AFX_CDECL ParceTimeDuration_min(LPCTSTR pcszTimeDuration)
Parse a time duration string like "5 minutes", "2 hours", "1 day" or "3 weeks" and returns duration a...
CXTPCalendarUtils::ParceTimeString_min
static int AFX_CDECL ParceTimeString_min(LPCTSTR pcszTime_HrMin)
Parse a time string like "18:20" or "7:15 pm" and returns time as total minutes.
CXTPCalendarUtils::GetLocaleString
static CString AFX_CDECL GetLocaleString(LCTYPE LCType, int nMaxLength=128)
This member function is used to retrieve information about a locale.
CXTPCalendarUtils::GetMaxMonthDay
static int AFX_CDECL GetMaxMonthDay(COleDateTime dtDate)
This member function is used to calculate the maximum month day number for a specified Year and Month...
Definition XTPCalendarUtils.h:1271
CXTPCalendarUtils::GetDayOfWeekIndex
static int AFX_CDECL GetDayOfWeekIndex(int nDayOfWeekMask)
This member function is used to convert an XTPCalendarWeekDay enum value to a sequential week day num...
Definition XTPCalendarUtils.h:1241
CXTPCalendarUtils::ResetDate
static const COleDateTime AFX_CDECL ResetDate(const COleDateTime &dtDateTime)
This member function is used to reset (set to zero) the date part for the specified DateTime value.
Definition XTPCalendarUtils.h:1221
CXTPCalendarUtils::GetDayOfWeekCount
static int AFX_CDECL GetDayOfWeekCount(int nDayOfWeekMask)
This member function is used to count the bits in the specified bit mask.
Definition XTPCalendarUtils.h:1513
CXTPCalendarUtils::IsEqual
static BOOL AFX_CDECL IsEqual(const COleDateTime &dt1, const COleDateTime &dt2, BOOL bOneSecTimeDiff=FALSE)
This member function is used to compare two dates (and times).
CXTPCalendarUtils::ShiftDate_Month
static BOOL AFX_CDECL ShiftDate_Month(COleDateTime &refDate, int nMonthCount)
This member function is used to shift the specified date for the specified number of months.
Definition XTPCalendarUtils.h:1324
CXTPCalendarUtils::GetFirstWeekOfYearDays
static int AFX_CDECL GetFirstWeekOfYearDays()
This function return number of days of the new year in the first week of this year.
CXTPCalendarUtils::GetActiveLCID
static LCID AFX_CDECL GetActiveLCID()
Returns active locale ID (current user locale or resource file locale).
CXTPCalendarUtils::StripFormat
static void AFX_CDECL StripFormat(CString &strFormat, int nIndex, int nRemove)
This function removes a fixed number of characters from the format string, starting at a particular i...
CXTPCalendarUtils::TextPrepareSingleline
static void AFX_CDECL TextPrepareSingleline(CString &rstrString)
Prepares a string for single line display.
CXTPCalendarUtils::GetLocaleLong
static int AFX_CDECL GetLocaleLong(LCTYPE LCType)
This member function is used to retrieve information about a locale.
CXTPCalendarUtils::RemoveFormatPart
static CString AFX_CDECL RemoveFormatPart(CString strFormat, LPCTSTR lpszRemove)
Call this function to remove a portion from the time format part (Mm Dd Yy).
CXTPCalendarUtils::RemoveFormatPart
static CString AFX_CDECL RemoveFormatPart(CString strFormat, TCHAR cRemove)
Call this function to remove a character from the time format part (Mm Dd Yy).
CXTPCalendarUtils::GetTimeFormat
static CString AFX_CDECL GetTimeFormat(CONST SYSTEMTIME *lpTime, LPCTSTR lpFormat)
This member function is used to format a time as a time string for a LOCALE_USER_DEFAULT locale.
CXTPCalendarUtils::LoadString2
static BOOL AFX_CDECL LoadString2(CString &rstrString, UINT nIDResource)
Loads string using XTPResourceManager.
CXTPCalendarUtils::TrackMouseEvent
static BOOL AFX_CDECL TrackMouseEvent(DWORD dwFlags, HWND hwndTrack, DWORD dwHoverTime=HOVER_DEFAULT)
The TrackMouseEvent function posts messages when the mouse pointer leaves a window or hovers over a w...
CXTPCalendarUtils::FormatTimeDuration
static CString AFX_CDECL FormatTimeDuration(int nMinutes, BOOL bRoundly)
Format time duration like "3 minutes" or "1 week".
CXTPCalendarUtils::GetMaxHeightFont
static CFont *AFX_CDECL GetMaxHeightFont(CArray< CFont *, CFont * > &arFonts, CDC *pDC, int *pnMaxHeight=NULL)
This function is used to determine a font with maximum symbols height in an array of fonts.
CXTPCalendarUtils::UpdateDate
static const COleDateTime AFX_CDECL UpdateDate(const COleDateTime &dtTime, const COleDateTime &dtDate)
This member function is used to update the date part of the specified DateTime value.
Definition XTPCalendarUtils.h:1455
ITimeProvider
Interface for overriding the GetCurrentTime() function in calendar control.
Definition XTPCalendarUtils.h:63


Toolkit Pro: Member List

CXTPSkinImages Member List

This is the complete list of members for CXTPSkinImages, including all inherited members.

CXTPSkinImages() | CXTPSkinImages |
GetAccessCriticalSection() const | CXTPSynchronized | inline
GetExtent(CXTPSkinManagerResourceFile *pResourceFile, LPCTSTR lpszImageFile) | CXTPSkinImages |
LoadFile(CXTPSkinManagerResourceFile *pResourceFile, LPCTSTR lpszImageFile) | CXTPSkinImages |
m_mapImages | CXTPSkinImages | protected
RemoveAll() | CXTPSkinImages |
~CXTPSkinImages() | CXTPSkinImages |


Toolkit Pro: Member List

CXTPTabColorSetOffice2003 Member List

This is the complete list of members for CXTPTabColorSetOffice2003, including all inherited members.

CXTPTabPaintManagerColorSet() | CXTPTabPaintManagerColorSet |
FillClient(CDC *pDC, CRect rc, CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
FillHeader(CDC *pDC, CRect rc, CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
FillNavigateButton(CDC *pDC, CXTPTabManagerNavigateButton *pButton, CRect &rc) | CXTPTabColorSetOffice2003 | virtual
FillPropertyButton(CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem) | CXTPTabColorSetOffice2003 | virtual
FillStateButton(CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerColorSet | virtual
GetClientColor(CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
GetItemColor(CXTPTabManagerItem *pItem) | CXTPTabPaintManagerColorSet | virtual
GradientFill(CDC *pDC, CRect rc, COLORREF clrLight, COLORREF clrDark, XTPTabPosition position) | CXTPTabPaintManagerColorSet |
IsAppThemed() const | CXTPTabPaintManagerColorSet | virtual
m_bLunaTheme | CXTPTabColorSetOffice2003 | protected
m_clrActiveFilesBack | CXTPTabPaintManagerColorSet |
m_clrActiveFilesBackHighlighted | CXTPTabPaintManagerColorSet |
m_clrActiveFilesBackPressed | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyph | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyphHighlighted | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyphPressed | CXTPTabPaintManagerColorSet |
m_clrAutoHideFace | CXTPTabPaintManagerColorSet |
m_clrBorderHighlight | CXTPTabPaintManagerColorSet |
m_clrButtonBorder | CXTPTabPaintManagerColorSet |
m_clrButtonBorderHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonBorderHot | CXTPTabPaintManagerColorSet |
m_clrButtonBorderKeyTips | CXTPTabPaintManagerColorSet |
m_clrButtonBorderTabContext1 | CXTPTabPaintManagerColorSet |
m_clrButtonBorderTabContext2 | CXTPTabPaintManagerColorSet |
m_clrButtonHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonHighlightedClose | CXTPTabPaintManagerColorSet |
m_clrButtonNormal | CXTPTabPaintManagerColorSet |
m_clrButtonPressed | CXTPTabPaintManagerColorSet |
m_clrButtonSelected | CXTPTabPaintManagerColorSet |
m_clrButtonSelectedHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonSelectedPressed | CXTPTabPaintManagerColorSet |
m_clrControlFace | CXTPTabPaintManagerColorSet |
m_clrFrameBorder | CXTPTabPaintManagerColorSet |
m_clrHeaderFace | CXTPTabPaintManagerColorSet |
m_clrNavigateButtonBorder | CXTPTabColorSetOffice2003 | protected
m_clrPaneFace | CXTPTabPaintManagerColorSet |
m_clrTabClientBack | CXTPTabPaintManagerColorSet |
m_clrTabClientBorder | CXTPTabPaintManagerColorSet |
m_clrTextDisabled | CXTPTabPaintManagerColorSet |
m_clrTextHighlight | CXTPTabPaintManagerColorSet |
m_clrTextHighlightClose | CXTPTabPaintManagerColorSet |
m_clrTextNormal | CXTPTabPaintManagerColorSet |
m_clrTextPressed | CXTPTabPaintManagerColorSet |
m_clrTextSelected | CXTPTabPaintManagerColorSet |
m_clrTextSelectedHighlighted | CXTPTabPaintManagerColorSet |
m_clrTextSelectedPressed | CXTPTabPaintManagerColorSet |
m_csExcelNormal | CXTPTabPaintManagerColorSet |
m_csExcelSelected | CXTPTabPaintManagerColorSet |
m_csPropertyPage | CXTPTabPaintManagerColorSet |
m_csPropertyPage2003 | CXTPTabPaintManagerColorSet |
m_csStateButton | CXTPTabPaintManagerColorSet |
m_pPaintManager | CXTPTabPaintManagerColorSet | protected
Rectangle(CDC *pDC, CRect rc, int nPen, int nBrush) | CXTPTabColorSetOffice2003 |
RefreshMetrics() | CXTPTabColorSetOffice2003 | virtual
SelectClipRgn(CDC *pDC, CRect rcClient, CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
SetTextColor(CDC *pDC, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerColorSet | virtual
~CXTPTabPaintManagerColorSet() | CXTPTabPaintManagerColorSet | virtual


Toolkit Pro: Member List

CXTPCalendarThemeFontValue Member List

This is the complete list of members for CXTPCalendarThemeFontValue, including all inherited members.

CopySettings(const CXTPCalendarThemeFontValue &refSrc) | CXTPCalendarThemeFontValue |
CXTPCalendarViewPartCustomizableValueT< CFont >::CopySettings(const CXTPCalendarViewPartCustomizableValueT< CFont > &refSrc) | CXTPCalendarViewPartCustomizableValueT< CFont > | inline
CXTPCalendarThemeFontValue() | CXTPCalendarThemeFontValue |
CXTPCalendarViewPartCustomizableValueT() | CXTPCalendarViewPartCustomizableValueT< CFont > | inline
GetStandardValue() const | CXTPCalendarViewPartCustomizableValueT< CFont > | inlinevirtual
GetValue() const | CXTPCalendarViewPartCustomizableValueT< CFont > | inlinevirtual
IsCustomValue() const | CXTPCalendarViewPartCustomizableValueT< CFont > | inlinevirtual
IsDefaultValue() const | CXTPCalendarViewPartCustomizableValueT< CFont > | inlinevirtual
IsStandardValue() const | CXTPCalendarViewPartCustomizableValueT< CFont > | inlinevirtual
m_bAutoDelete_Custom | CXTPCalendarViewPartCustomizableValueT< CFont > | protected
m_bAutoDelete_Standard | CXTPCalendarViewPartCustomizableValueT< CFont > | protected
m_pValueCustom | CXTPCalendarViewPartCustomizableValueT< CFont > | protected
m_pValueStandard | CXTPCalendarViewPartCustomizableValueT< CFont > | protected
operator CFont *() const | CXTPCalendarViewPartCustomizableValueT< CFont > | inline
operator->() | CXTPCalendarViewPartCustomizableValueT< CFont > | inline
operator=(LOGFONT &rLogFont) | CXTPCalendarThemeFontValue |
Serialize(CArchive &ar) | CXTPCalendarThemeFontValue | virtual
SetCustomValue(LOGFONT *pLogFont) | CXTPCalendarThemeFontValue | virtual
SetCustomValue(CFont *pFont) | CXTPCalendarThemeFontValue | virtual
CXTPCalendarViewPartCustomizableValueT< CFont >::SetCustomValue(CFont *pValue, BOOL bAutoDelete) | CXTPCalendarViewPartCustomizableValueT< CFont > | inlinevirtual
SetDefaultValue() | CXTPCalendarViewPartCustomizableValueT< CFont > | inlinevirtual
SetStandardValue(LOGFONT *pLogFont) | CXTPCalendarThemeFontValue | virtual
SetStandardValue(CFont *pFont) | CXTPCalendarThemeFontValue | virtual
CXTPCalendarViewPartCustomizableValueT< CFont >::SetStandardValue(CFont *pValue, BOOL bAutoDelete) | CXTPCalendarViewPartCustomizableValueT< CFont > | inlinevirtual
~CXTPCalendarThemeFontValue() | CXTPCalendarThemeFontValue |
~CXTPCalendarViewPartCustomizableValueT() | CXTPCalendarViewPartCustomizableValueT< CFont > | inlinevirtual


Toolkit Pro: XTPGridRecordItemRange.h Source File

  • Source
  • GridControl
XTPGridRecordItemRange.h
Go to the documentation of this file.
1
23#if !defined(__XTPGRIDRECORDITEMRANGE_H__)
24# define __XTPGRIDRECORDITEMRANGE_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPGridRecordItem;
34
35class _XTP_EXT_CLASS CXTPGridRecordItemId
36{
37public:
38 CXTPGridRecordItemId();
39 CXTPGridRecordItemId(int nColumn, int nRecord);
40
41 void Set(int nColumn, int nRecord);
42
43 int GetColumn() const;
44
45 int GetRecord() const;
46
47 bool operator==(const CXTPGridRecordItemId& otherId) const;
48
49public:
50 int m_nColumn;
51 int m_nRecord;
52};
53
54class _XTP_EXT_CLASS CXTPGridRecordMergeItemId : public CXTPGridRecordItemId
55{
56public:
57 CXTPGridRecordMergeItemId();
58 CXTPGridRecordMergeItemId(int nColumnPos, int nColumn, int nRecord);
59
60public:
61 int m_nColumnPos;
62};
63
64class _XTP_EXT_CLASS CXTPGridRecordItemRange
65{
66public:
67 CXTPGridRecordItemRange();
68
69 CXTPGridRecordItemRange(int nColumnFrom, int nColumnTo, int nRecordFrom, int nRecordTo);
70
71 void SetTopLeft(const CXTPGridRecordItemId topLeft);
72 void SetBottomRight(const CXTPGridRecordItemId bottomRight);
73
74 void ExpandTo(int nColumn, int nRecord);
75
76 void ExpandTo(const CXTPGridRecordItemId expand);
77
78 void Invalidate();
79
80 bool IsValid() const;
81
82 bool IsInRange(const int nColumn, const int nRecord) const;
83
84 bool IsNeighbour(const int nColumn, const int nRecord) const;
85
86 bool IsConnected(const int nColumn, const int nRecord) const;
87
88public:
89 int m_nColumnFrom;
90 int m_nColumnTo;
91 int m_nRecordFrom;
92 int m_nRecordTo;
93};
94
95class _XTP_EXT_CLASS CXTPGridRecordMergeItem
96{
97public:
98 CXTPGridRecordMergeItem();
99 CXTPGridRecordMergeItem(const CXTPGridRecordMergeItem& other);
100
101 CXTPGridRecordMergeItem& operator=(const CXTPGridRecordMergeItem& other);
102
103 void AddItem(CXTPGridRecordMergeItemId itemId, CRect rcItem);
104
105 bool FindRange(CXTPGridRecordItemRange& range, CRect& rcItem);
106
107 struct Item
108 {
109 CXTPGridRecordMergeItemId m_itemId;
110 CRect m_rcItem;
111 };
112
113public:
114 void CopyFrom(const CXTPGridRecordMergeItem& other);
115
116 CList<Item, Item> m_items;
117};
118
119class _XTP_EXT_CLASS CXTPGridRecordMergeItems
120 : public CMap<CXTPGridRecordItem*, CXTPGridRecordItem*, CXTPGridRecordMergeItem,
121 CXTPGridRecordMergeItem&>
122{
123};
125# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
126#endif //#if !defined(__XTPGRIDRECORDITEMRANGE_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPGridRecordItem
Class for working with single list cell.
Definition XTPGridRecordItem.h:600


Toolkit Pro: Member List

CXTPControlGalleryItem Member List

This is the complete list of members for CXTPControlGalleryItem, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPControlGalleryItem() | CXTPControlGalleryItem |
Draw(CDC *pDC, CXTPControlGallery *pGallery, CRect rcItem, BOOL bEnabled, BOOL bSelected, BOOL bPressed, BOOL bChecked) | CXTPControlGalleryItem | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCaption() const | CXTPControlGalleryItem |
GetData() const | CXTPControlGalleryItem |
GetDescription() const | CXTPControlGalleryItem |
GetEnabled() const | CXTPControlGalleryItem |
GetID() const | CXTPControlGalleryItem |
GetImage() | CXTPControlGalleryItem |
GetImageIndex() | CXTPControlGalleryItem | virtual
GetImageWidth() const | CXTPControlGalleryItem |
GetIndex() const | CXTPControlGalleryItem |
GetMarkupUIElement() const | CXTPControlGalleryItem |
GetSize() | CXTPControlGalleryItem | virtual
GetToolTip() const | CXTPControlGalleryItem |
IsLabel() const | CXTPControlGalleryItem |
m_bEnabled | CXTPControlGalleryItem | protected
m_bLabel | CXTPControlGalleryItem | protected
m_dwData | CXTPControlGalleryItem | protected
m_nId | CXTPControlGalleryItem | protected
m_nImage | CXTPControlGalleryItem | protected
m_nImageWidth | CXTPControlGalleryItem | protected
m_nIndex | CXTPControlGalleryItem | protected
m_pItems | CXTPControlGalleryItem | protected
m_strCaption | CXTPControlGalleryItem | protected
m_strDescriptionText | CXTPControlGalleryItem | protected
m_strToolTip | CXTPControlGalleryItem | protected
m_szItem | CXTPControlGalleryItem | protected
SetCaption(LPCTSTR lpszCaption) | CXTPControlGalleryItem |
SetData(DWORD_PTR dwData) | CXTPControlGalleryItem |
SetDescription(LPCTSTR lpszDescription) | CXTPControlGalleryItem |
SetEnabled(BOOL bEnabled) | CXTPControlGalleryItem |
SetID(int nId) | CXTPControlGalleryItem |
SetImageIndex(int nImageIndex) | CXTPControlGalleryItem | virtual
SetImageWidth(int nImageWidth) | CXTPControlGalleryItem |
SetSize(CSize szItem) | CXTPControlGalleryItem |
SetToolTip(LPCTSTR lpszToolTip) | CXTPControlGalleryItem |
~CXTPControlGalleryItem() | CXTPControlGalleryItem |


Toolkit Pro: Member List

CXTPAnimationDC Member List

This is the complete list of members for CXTPAnimationDC, including all inherited members.

Animate(int nType=xtpAniDefault, int nSteps=10, int nAnimationTime=1000) | CXTPAnimationDC |
CXTPAnimationDC(HDC hDestDC, const CRect &rcPaint) | CXTPAnimationDC |
CXTPAnimationDC(HDC hDestDC, const CRect &rcPaint, const CXTPPaintManagerColorGradient &clrBack, const BOOL bHorz=FALSE) | CXTPAnimationDC |
DefaultAnimation(CRect rc, CDC *pDestDC, CDC *pSrcDC, int nType, int nSteps, int nAnimationTime) | CXTPAnimationDC | static
LPFNANIMATION typedef | CXTPAnimationDC |
m_bitmap | CXTPAnimationDC | protected
m_hDestDC | CXTPAnimationDC | protected
m_hOldBitmap | CXTPAnimationDC | protected
m_rect | CXTPAnimationDC | protected
SetCustomAnimation(LPFNANIMATION pCustom) | CXTPAnimationDC | static
~CXTPAnimationDC() | CXTPAnimationDC | virtual


Toolkit Pro: Member List

CXTPGridThemeResource Member List

This is the complete list of members for CXTPGridThemeResource, including all inherited members.

CalcColumnHeight(CDC *pDC, CXTPGridColumn *pColumn, int nTotalWidth=0) | CXTPGridPaintManager | protectedvirtual
CalculateRowHeight(CDC *pDC, const CString &strText, int nMaxWidth, BOOL bWordBreak=TRUE) | CXTPGridPaintManager | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPGridPaintManager() | CXTPGridPaintManager |
CXTPGridThemeResource() | CXTPGridThemeResource |
DrawBitmap(CDC *pDC, CXTPGridControl *pControl, CRect rcColumn, int iImage) | CXTPGridPaintManager | virtual
DrawCollapsedBitmap(CDC *pDC, const CXTPGridRow *pRow, CRect &rcBitmap) | CXTPGridThemeResource | virtual
DrawColumn(CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn, BOOL bDrawExternal=FALSE, int nShadowWidth=0) | CXTPGridPaintManager | virtual
DrawColumnBackground(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, BOOL &bColumnPressed, BOOL &bDraggingFromHeader, CXTPGridHeader *pHeader=NULL) | CXTPGridThemeResource | protectedvirtual
DrawColumnFooter(CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn) | CXTPGridPaintManager | virtual
DrawColumnFooterDivider(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn) | CXTPGridThemeResource | virtual
DrawColumnIcon(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, CRect rcIcon, int iIcon) | CXTPGridPaintManager | virtual
DrawColumnText(CDC *pDC, CRect rcText, CString strCaption, int nHeaderAlignment, BOOL bIsHeader, BOOL bColumnPressed) | CXTPGridThemeResource | virtual
DrawConnector(CDC *pDC, CPoint ptFrom, CPoint ptTo) | CXTPGridPaintManager |
DrawFocusedRow(CDC *pDC, CRect rcRow) | CXTPGridPaintManager | virtual
DrawFreezeColsDivider(CDC *pDC, const CRect &rc, CXTPGridControl *pControl, CXTPGridRow *pRow=NULL) | CXTPGridPaintManager | virtual
DrawGlyph(CDC *pDC, CRect rcColumn, int iImage) | CXTPGridPaintManager | virtual
DrawGrid(CDC *pDC, XTPGridOrientation orientation, CRect rcGrid) | CXTPGridPaintManager | virtual
DrawGridPattern(CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush) | CXTPGridPaintManager | protectedvirtual
DrawGridPattern(CDC *pDC, CXTPBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush) | CXTPGridPaintManager | protectedvirtual
DrawGridPattern(CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr) | CXTPGridPaintManager | protectedvirtual
DrawGroupRow(CDC *pDC, CXTPGridGroupRow *pRow, CRect rcRow, XTP_GRIDRECORDITEM_METRICS *pMetrics) | CXTPGridPaintManager | virtual
DrawHorizontalLine(CDC *pDC, int xPos, int yPos, int cx, COLORREF clr) | CXTPGridPaintManager |
DrawInplaceButton(CDC *pDC, CXTPGridInplaceButton *pButton) | CXTPGridPaintManager | virtual
DrawInplaceButtonFrame(CDC *pDC, CXTPGridInplaceButton *pButton) | CXTPGridPaintManager | protectedvirtual
DrawInplaceButtonIcon(CDC *pDC, CXTPGridInplaceButton *pButton) | CXTPGridPaintManager | protectedvirtual
DrawInplaceComboButton(CDC *pDC, CRect *pRc) | CXTPGridPaintManager | virtual
DrawInplaceExpandButton(CDC *pDC, CRect *pRc) | CXTPGridPaintManager | virtual
DrawInplaceSpinButton(CDC *pDC, CRect *pRc) | CXTPGridPaintManager | virtual
DrawItemBitmap(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CRect &rcItem, int nImage) | CXTPGridPaintManager | virtual
DrawItemCaption(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics) | CXTPGridPaintManager | virtual
DrawItemControl(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CXTPGridRecordItemControl *pControl, CRect &rcItem) | CXTPGridPaintManager | virtual
DrawLink(int *pnCurrDrawPos, XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CXTPGridHyperlink *pHyperlink, CString strText, CRect rcLink, int nFlag, BOOL bTrim=FALSE) | CXTPGridPaintManager | protectedvirtual
DrawMultiLineText(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, BOOL bWordBreak=TRUE) | CXTPGridPaintManager | protectedvirtual
DrawNoGroupByText(CDC *pDC, CRect rcItem) | CXTPGridThemeResource | virtual
DrawRowNumber(CDC *pDC, CRect rcNumber, CXTPGridRow *pRow) | CXTPGridPaintManager | virtual
DrawSectionDivider(CDC *pDC, const CRect &rc, XTPGridSectionDividerPosition dividerPosition, XTPGridSectionDividerStyle dividerStyle, CXTPPaintManagerColor dividerColor) | CXTPGridThemeResource |
DrawShellIcon(CDC *pDC, CRect rcColumn, int iImage) | CXTPGridPaintManager | virtual
DrawSingleLineText(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nStartPos, int nEndPos, int nActualWidth) | CXTPGridPaintManager | protectedvirtual
DrawString(int *pnCurrDrawPos, CDC *pDC, const CString &strDraw, CRect rcDraw, UINT nFormat) | CXTPGridPaintManager | protectedvirtual
DrawTextLine(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nFlag, int &nCharCounter, int &nHyperlinkCounter) | CXTPGridPaintManager | protectedvirtual
DrawTreeStructure(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CRect rcItem, CSize sizeGlyph) | CXTPGridPaintManager | virtual
DrawTriangle(CDC *pDC, CRect rcTriangle, BOOL bToDown, int nShadowWidth, BOOL bColumnPressed) | CXTPGridThemeResource | virtual
DrawTriangle(CDC *pDC, CRect rcTriangle, BOOL bToDown, BOOL bDraggingFromHeader, int nShadowWidth, BOOL bColumnPressed) | CXTPGridThemeResource | virtual
DrawVerticalLine(CDC *pDC, int xPos, int yPos, int cy, COLORREF clr) | CXTPGridPaintManager |
DrawVerticalTimeLineMarker(CDC *pDC, int xPos, CXTPGridControl *pControl, COLORREF color=RGB(0, 255, 0)) | CXTPGridPaintManager | virtual
EnablePreviewMode(BOOL bIsPreviewMode) | CXTPGridPaintManager |
FillFooter(CDC *pDC, CRect rcFooter) | CXTPGridThemeResource | virtual
FillGroupByControl(CDC *pDC, CRect &rcGroupBy) | CXTPGridPaintManager | virtual
FillGroupRowMetrics(CXTPGridGroupRow *pRow, XTP_GRIDRECORDITEM_METRICS *pMetrics, BOOL bPrinting) | CXTPGridPaintManager | virtual
FillHeaderControl(CDC *pDC, CRect rcHeader) | CXTPGridPaintManager | virtual
FillIndent(CDC *pDC, CRect rcRow) | CXTPGridPaintManager | virtual
FillItemShade(CDC *pDC, CRect rcItem) | CXTPGridPaintManager | virtual
FillRow(CDC *pDC, CXTPGridRow *pRow, CRect rcRow) | CXTPGridPaintManager | virtual
FindRowAdjacentToMerged(const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, BOOL bUpward) | CXTPGridPaintManager |
FindRowAdjacentToMergedEx(const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, int &nAdjRowIndex, BOOL bUpward) | CXTPGridPaintManager |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetColumnOffice2007CustomThemeBaseColor() const | CXTPGridPaintManager |
GetColumnStyle() const | CXTPGridPaintManager |
GetControlBackColor(CXTPGridControl *pControl) | CXTPGridPaintManager | virtual
GetFooterHeight(CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0) | CXTPGridPaintManager | virtual
GetFreezeColsDividerStyle() const | CXTPGridPaintManager |
GetGlyphs() const | CXTPGridPaintManager |
GetHeaderHeight() | CXTPGridPaintManager | virtual
GetHeaderHeight(CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0) | CXTPGridPaintManager | virtual
GetItemHeight(XTP_GRIDRECORDITEM_DRAWARGS &drawArgs, int nWidth) | CXTPGridPaintManager |
GetMaxPreviewLines() | CXTPGridPaintManager |
GetPreviewItemHeight(CDC *pDC, CXTPGridRow *pRow, int nWidth, int nHeight) | CXTPGridPaintManager | virtual
GetPreviewLinesCount(CDC *pDC, CRect &rcText, const CString &strText) | CXTPGridPaintManager |
GetRowHeight(CDC *pDC, CXTPGridRow *pRow) | CXTPGridPaintManager | virtual
GetRowHeight(CDC *pDC, CXTPGridRow *pRow, int nTotalWidth) | CXTPGridPaintManager | virtual
GetRowHeightEx(CDC *pDC, CXTPGridRow *pRow, int nTotalWidth, const BOOL firstLevel=TRUE) | CXTPGridPaintManager |
GetSectionDividerHeight(XTPGridFixedRowsDividerStyle dividerStyle) | CXTPGridPaintManager |
GetTextFont() | CXTPGridPaintManager |
IsColumHotTrackingEnabled() const | CXTPGridPaintManager | virtual
IsColumnPlusMinusSign() const | CXTPGridPaintManager |
IsColumnWidthWYSIWYG() const | CXTPGridPaintManager |
IsDrawGridForEmptySpace() const | CXTPGridPaintManager |
IsFixedInplaceButtonHeight() const | CXTPGridPaintManager |
IsFixedRowHeight() const | CXTPGridPaintManager |
IsGridVisible(BOOL bVertical) const | CXTPGridPaintManager |
IsGridVisible(XTPGridOrientation orientation) const | CXTPGridPaintManager |
IsLastColumnWidthWYSIWYG() const | CXTPGridPaintManager |
IsPreviewMode() const | CXTPGridPaintManager |
IsPrintGroupRowIcon() const | CXTPGridPaintManager |
IsShowWYSIWYGMarkers() const | CXTPGridPaintManager |
IsUseDropMarker() const | CXTPGridPaintManager |
LoadGlyphs() | CXTPGridPaintManager | virtual
m_arStartCol | CXTPGridPaintManager |
m_bAllowMergeCells | CXTPGridPaintManager |
m_bBaseTreeIndent | CXTPGridPaintManager |
m_bCleanTooltip | CXTPGridPaintManager |
m_bColumnPlusMinusSign | CXTPGridPaintManager | protected
m_bColumnWidthWYSIWYG | CXTPGridPaintManager | protected
m_bCompactText | CXTPGridPaintManager |
m_bDrawGridForEmptySpace | CXTPGridPaintManager | protected
m_bFixedInplaceButtonHeight | CXTPGridPaintManager | protected
m_bFixedRowHeight | CXTPGridPaintManager | protected
m_bForceDynamicMarkupForCell | CXTPGridPaintManager |
m_bForceShowDropMarker | CXTPGridPaintManager |
m_bForceShowTooltip | CXTPGridPaintManager |
m_bGrayIfDisable | CXTPGridPaintManager |
m_bGroupRowTextBold | CXTPGridPaintManager |
m_bHideSelection | CXTPGridPaintManager |
m_bHotTracking | CXTPGridPaintManager |
m_bInvertColumnOnClick | CXTPGridPaintManager |
m_bIsPreviewMode | CXTPGridPaintManager | protected
m_bLastColumnWidthWYSIWYG | CXTPGridPaintManager | protected
m_bMakeUpper | CXTPGridPaintManager |
m_bMoveScrollbarOnFixedColumnsIndent | CXTPGridPaintManager |
m_bPrintGroupRowIcon | CXTPGridPaintManager | protected
m_bPrintPageRectangle | CXTPGridPaintManager |
m_bPrintSortTriangle | CXTPGridPaintManager |
m_bPrintVirtualPageNumber | CXTPGridPaintManager |
m_bPrintWatermark | CXTPGridPaintManager |
m_bRecOrRowNum | CXTPGridPaintManager |
m_bRevertAlignment | CXTPGridPaintManager |
m_bShadeGroupHeadings | CXTPGridPaintManager |
m_bShadeSortColumn | CXTPGridPaintManager |
m_bShowLockIcon | CXTPGridPaintManager |
m_bShowNonActiveInPlaceButton | CXTPGridPaintManager |
m_bShowWYSIWYGMarkers | CXTPGridPaintManager | protected
m_bSortTriangleOffsetFromRight | CXTPGridPaintManager |
m_bThemedInplaceButtons | CXTPGridPaintManager |
m_bUseAlternativeBackground | CXTPGridPaintManager |
m_bUseDropMarker | CXTPGridPaintManager |
m_bUseEditTextAlignment | CXTPGridPaintManager |
m_bUseGroupRowSelectionState | CXTPGridPaintManager |
m_bUseShellIcon | CXTPGridPaintManager |
m_clrAlternativeBackground | CXTPGridPaintManager |
m_clrBoldText | CXTPGridPaintManager |
m_clrBoldTextHighlight | CXTPGridPaintManager |
m_clrBtnFace | CXTPGridPaintManager |
m_clrBtnFacePressed | CXTPGridPaintManager |
m_clrBtnText | CXTPGridPaintManager |
m_clrCaptionText | CXTPGridPaintManager |
m_clrCaptionTextPressed | CXTPGridPaintManager |
m_clrColumnOffice2007CustomTheme | CXTPGridPaintManager |
m_clrConnector | CXTPGridPaintManager |
m_clrControlBack | CXTPGridPaintManager |
m_clrControlDark | CXTPGridPaintManager |
m_clrControlLightLight | CXTPGridPaintManager |
m_clrDisableBitmapDarkest | CXTPGridPaintManager |
m_clrDisableBitmapLightest | CXTPGridPaintManager |
m_clrFormulaSubSum | CXTPGridPaintManager |
m_clrFormulaSum | CXTPGridPaintManager |
m_clrFreezeColsDivider | CXTPGridPaintManager |
m_clrGradientColumnSeparator | CXTPGridPaintManager |
m_clrGradientColumnShadow | CXTPGridPaintManager |
m_clrGroupBoxBack | CXTPGridPaintManager |
m_clrGroupRowText | CXTPGridPaintManager |
m_clrGroupShadeBack | CXTPGridPaintManager |
m_clrGroupShadeBorder | CXTPGridPaintManager |
m_clrGroupShadeText | CXTPGridPaintManager |
m_clrHeaderControl | CXTPGridPaintManager |
m_clrHighlight | CXTPGridPaintManager |
m_clrHighlightText | CXTPGridPaintManager |
m_clrHotDivider | CXTPGridPaintManager |
m_clrIndentControl | CXTPGridPaintManager |
m_clrItemShade | CXTPGridPaintManager |
m_clrPreviewText | CXTPGridPaintManager |
m_clrSelectedRow | CXTPGridPaintManager |
m_clrSelectedRowText | CXTPGridPaintManager |
m_clrWindowText | CXTPGridPaintManager |
m_columnStyle | CXTPGridPaintManager | protected
m_crlNoGroupByText | CXTPGridPaintManager |
m_grcGradientColumn | CXTPGridPaintManager |
m_grcGradientColumnHot | CXTPGridPaintManager |
m_grcGradientColumnPushed | CXTPGridPaintManager |
m_iRecOrRowStart | CXTPGridPaintManager |
m_nBaseParentRecordIndent | CXTPGridPaintManager |
m_nFixedColumnsIndent | CXTPGridPaintManager |
m_nFooterHeight | CXTPGridPaintManager | protected
m_nFreezeColsDividerStyle | CXTPGridPaintManager | protected
m_nGridLineStylePreviousH | CXTPGridPaintManager | protected
m_nGridLineStylePreviousV | CXTPGridPaintManager | protected
m_nGroupGridLineHeight | CXTPGridPaintManager | protected
m_nGroupGridLineStyle | CXTPGridPaintManager | protected
m_nHeaderHeight | CXTPGridPaintManager | protected
m_nMaxPreviewLines | CXTPGridPaintManager | protected
m_nResizingWidth | CXTPGridPaintManager | protected
m_nRowHeight | CXTPGridPaintManager | protected
m_nRowHeightDefault | CXTPGridPaintManager |
m_nTextIndentForGroupRowsWithNoIcon | CXTPGridPaintManager |
m_nTreeColumnLineLength | CXTPGridPaintManager |
m_nTreeIndent | CXTPGridPaintManager |
m_nTreeStructureStyle | CXTPGridPaintManager |
m_nTreeTextIndent | CXTPGridPaintManager |
m_nTreeTextIndentGroupRow | CXTPGridPaintManager |
m_nTreeTextIndentRowChildren | CXTPGridPaintManager |
m_nTreeTextIndentRowParent | CXTPGridPaintManager |
m_pControl | CXTPGridPaintManager | protected
m_pGlyphs | CXTPGridPaintManager | protected
m_pHyperlinkHoverStyle | CXTPGridPaintManager |
m_pHyperlinkStyle | CXTPGridPaintManager |
m_pMarkupUIElement_NoGroupBy | CXTPGridPaintManager | protected
m_PrintPageWidth | CXTPGridPaintManager |
m_rcPreviewIndent | CXTPGridPaintManager |
m_RecordNumberWidth | CXTPGridPaintManager |
m_strCollapse | CXTPGridPaintManager |
m_strDecreasing | CXTPGridPaintManager |
m_strExpand | CXTPGridPaintManager |
m_strIncreasing | CXTPGridPaintManager |
m_strMarkupUIElement_NoGroupBy | CXTPGridPaintManager | protected
m_strNoFieldsAvailable | CXTPGridPaintManager |
m_strNoGroupBy | CXTPGridPaintManager |
m_strNoItems | CXTPGridPaintManager |
m_strSortBy | CXTPGridPaintManager |
m_szGlyph | CXTPGridPaintManager | protected
m_themeButton | CXTPGridPaintManager | protected
m_themeCombo | CXTPGridPaintManager | protected
m_themeHeader | CXTPGridPaintManager | protected
m_themeSpin | CXTPGridPaintManager | protected
m_treeStructureStyle | CXTPGridPaintManager |
m_xtpBrushGroupGridLineStyle | CXTPGridPaintManager | protected
m_xtpBrushHorizontalGrid | CXTPGridPaintManager | protected
m_xtpBrushTreeStructure | CXTPGridPaintManager | protected
m_xtpBrushVeriticalGrid | CXTPGridPaintManager | protected
m_xtpFontBoldText | CXTPGridPaintManager |
m_xtpFontCaption | CXTPGridPaintManager |
m_xtpFontPreview | CXTPGridPaintManager |
m_xtpFontText | CXTPGridPaintManager |
OnDrawAction(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs) | CXTPGridPaintManager | virtual
RecalcTotalHightOfMergedRows(CXTPGridColumns *pColumns, CDC *pDC, CXTPGridRow *pRow, int nRowHeight, int nTotalWidth) | CXTPGridPaintManager |
RefreshMetrics() | CXTPGridThemeResource | virtual
SetCaptionFont(LOGFONT &lf) | CXTPGridPaintManager |
SetColumnOffice2007CustomThemeBaseColor(COLORREF clrBaseColor) | CXTPGridPaintManager |
SetColumnPlusMinusSign(BOOL bDraw) | CXTPGridPaintManager |
SetColumnStyle(XTPGridColumnStyle columnStyle) | CXTPGridPaintManager |
SetColumnWidthWYSIWYG(BOOL bColumnWidthWYSIWYG) | CXTPGridPaintManager |
SetDrawGridForEmptySpace(BOOL bDrawGrid) | CXTPGridPaintManager |
SetFixedRowHeight(BOOL bFixedRowHeight) | CXTPGridPaintManager |
SetFreezeColsDividerStyle(int nStyle) | CXTPGridPaintManager |
SetGridControl(CXTPGridControl *pControl) | CXTPGridPaintManager | virtual
SetHeaderHeight(int nHeight) | CXTPGridPaintManager | virtual
SetInplaceButtonHeight(BOOL bFixedInplaceButtonHeight) | CXTPGridPaintManager |
SetLastColumnWidthWYSIWYG(BOOL bColumnWidthWYSIWYG) | CXTPGridPaintManager |
SetMaxPreviewLines(int nMaxLines) | CXTPGridPaintManager |
SetPreviewIndent(int nLeft, int nTop, int nRight, int nBottom) | CXTPGridPaintManager |
SetPrintGroupRowIcon(BOOL bDraw) | CXTPGridPaintManager |
SetTextFont(LOGFONT &lf) | CXTPGridPaintManager |
ShowWYSIWYGMarkers(BOOL bSet) | CXTPGridPaintManager |
~CXTPGridPaintManager() | CXTPGridPaintManager | virtual


Toolkit Pro: XTPSystemHelpers.h Source File

  • Source
  • Common
XTPSystemHelpers.h
Go to the documentation of this file.
1
23#if !defined(__XTPSYSTEMHELPERS_H__)
24# define __XTPSYSTEMHELPERS_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableAdvancedWarnings.h"
32# include <oleacc.h>
33# include <tlhelp32.h>
34# include "Common/Base/Diagnostic/XTPEnableAdvancedWarnings.h"
35
36# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
37
39class CXTPDummySingletonDependency;
41template<
42 class Singleton1 = CXTPDummySingletonDependency,
43 class Singleton2 = CXTPDummySingletonDependency, class Singleton3 = CXTPDummySingletonDependency,
44 class Singleton4 = CXTPDummySingletonDependency, class Singleton5 = CXTPDummySingletonDependency,
45 class Singleton6 = CXTPDummySingletonDependency, class Singleton7 = CXTPDummySingletonDependency,
46 class Singleton8 = CXTPDummySingletonDependency, class Singleton9 = CXTPDummySingletonDependency,
47 class Singleton10 = CXTPDummySingletonDependency>
48class CXTPSingletonDependencies;
49template<class T, class Dependencies = CXTPSingletonDependencies<> >
50class CXTPSingleton;
51
52class CXTPSystemVersion;
73_XTP_EXT_CLASS CXTPSystemVersion* AFXAPI XTPSystemVersion();
74
79class _XTP_EXT_CLASS CXTPModuleHandle
80{
81public:
86 enum XTPModuleState
87 {
88 xtpModNone,
89 xtpModMapped,
90 xtpModLoaded
91 };
92
93public:
98 CXTPModuleHandle();
99
114 CXTPModuleHandle(LPCTSTR lpszModuleName);
115
120 virtual ~CXTPModuleHandle();
121
137 BOOL Init(LPCTSTR lpszModuleName);
138
156 BOOL LoadLibrary(LPCTSTR lpszModuleName);
157
166 BOOL GetModuleHandle(LPCTSTR lpszModuleName);
167
174 BOOL FreeLibrary();
175
185 BOOL GetProcAddress(FARPROC* ppFnPtr, LPCSTR lpProcName, DWORD dwMinVer = NULL);
186
197 DWORD GetVersion();
198
206 operator HMODULE() const;
207
215 HMODULE GetHandle() const;
216
221 CString GetName() const;
222
227 XTPModuleState GetModuleState() const;
228
229private:
230 BOOL GetVersionInfo();
231 BOOL EnsureModuleState();
232 BOOL IsModule(LPCTSTR lpName, int nLen = -1) const;
233
234 struct XTP_DLLVERSIONINFO
235 {
236 DWORD cbSize;
237 DWORD dwMajorVersion;
238 DWORD dwMinorVersion;
239 DWORD dwBuildNumber;
240 DWORD dwPlatformID;
241 };
242
243 CString m_strModuleName;
244 HMODULE m_hModule;
245 XTPModuleState m_eModuleState;
246 XTP_DLLVERSIONINFO m_dvInfo;
248 typedef HRESULT(WINAPI* PFNDLLVERSIONINFO)(XTP_DLLVERSIONINFO*);
249 PFNDLLVERSIONINFO m_pfnDllGetVersion;
250};
252AFX_INLINE HMODULE CXTPModuleHandle::GetHandle() const
253{
254 return m_hModule;
255}
256AFX_INLINE CXTPModuleHandle::operator HMODULE() const
257{
258 return m_hModule;
259}
260AFX_INLINE CString CXTPModuleHandle::GetName() const
261{
262 return m_strModuleName;
263}
264AFX_INLINE CXTPModuleHandle::XTPModuleState CXTPModuleHandle::GetModuleState() const
265{
266 return m_eModuleState;
267}
269// Obsolete name
270//#define CXTLoadLibrary CXTPModuleHandle
271
278class _XTP_EXT_CLASS CXTPSystemVersion
279{
280 friend class CXTPSingleton<CXTPSystemVersion>;
281
282private:
287 CXTPSystemVersion();
288
289public:
304 bool VerifyWinVer(BYTE dwConditionMask, DWORD dwMajorVersion, DWORD dwMinorVersion,
305 DWORD dwPlatformId) const;
306
322 LRESULT VerifyVersion(BYTE dwConditionMask, DWORD dwMajorVersion, DWORD dwMinorVersion,
323 DWORD dwPlatformId) const;
324
339 LRESULT GetVersion(BYTE dwConditionMask, DWORD dwMajorVersion, DWORD dwMinorVersion,
340 DWORD dwPlatformId) const;
341
348 const OSVERSIONINFOEXW* GetOSVersionInfo() const;
349
357 bool IsWin31() const;
358
366 bool IsWin95() const;
367
375 bool IsWin98() const;
376
384 bool IsWinME() const;
385
393 bool IsWinNT4() const;
394
402 bool IsWin2K() const;
403
411 bool IsWinXP() const;
412
421 bool IsWin31OrGreater() const;
422
432 bool IsWin95OrGreater() const;
433
443 bool IsWin98OrGreater() const;
444
454 bool IsWinMEOrGreater() const;
455
463 bool IsWin9x() const;
464
474 bool IsWinNT4OrGreater() const;
475
485 bool IsWin2KOrGreater() const;
486
496 bool IsWinXPOrGreater() const;
497
507 bool IsWinVistaOrGreater() const;
508
518 bool IsWin7OrGreater() const;
519
529 bool IsWin8OrGreater() const;
530
540 bool IsWin81OrGreater() const;
541
551 bool IsWin10OrGreater() const;
552
562 bool IsWin11OrGreater() const;
563
564public:
574 DWORD GetComCtlVersion() const;
575
576public:
583 BOOL IsLayoutRTLSupported() const;
584
590 BOOL IsClearTypeTextQualitySupported() const;
591
598 int GetMaxCharSize() const;
599
600private:
601 CXTPModuleHandle m_modKernel32;
602 CXTPModuleHandle m_modNtdll;
603
604 BOOL(WINAPI* m_pfnVerifyVersionInfo)(LPOSVERSIONINFOEX, DWORD, DWORDLONG);
605 ULONGLONG(WINAPI* m_pfnVerSetConditionMask)(ULONGLONG, DWORD, BYTE);
606
607 LONG(WINAPI* m_pfnRtlGetVersion)(OSVERSIONINFOEXW*);
608
609 friend _XTP_EXT_CLASS CXTPSystemVersion* AFXAPI XTPSystemVersion();
610};
611
612// deprecated
613# define XTOSVersionInfo XTPSystemVersion
614
619class _XTP_EXT_CLASS CXTPMultiMonitor
620{
621 friend class CXTPSingleton<CXTPMultiMonitor>;
622
623private:
624 DECLARE_HANDLE(XTP_HMONITOR);
625
626private:
627 struct XTP_MONITORINFO
628 {
629 DWORD cbSize;
630 RECT rcMonitor;
631 RECT rcWork;
632 DWORD dwFlags;
633 };
634
635 struct XTP_MONITORINFOEX : XTP_MONITORINFO
636 {
637 TCHAR szDevice[CCHDEVICENAME];
638 };
639
640private:
641 CXTPMultiMonitor();
642
643public:
655 CRect GetWorkArea();
656
669 CRect GetWorkArea(const POINT& point);
670
685 CRect GetWorkArea(LPCRECT rect);
686
699 CRect GetWorkArea(const CWnd* pWnd);
700
713 CRect GetWorkArea(HWND hWnd);
714
727 CRect GetScreenArea(const CWnd* pWnd);
728
741 CRect GetScreenArea(HWND hWnd);
742
755 CRect GetScreenArea(const POINT& point);
756
771 CRect GetScreenArea(LPCRECT rect);
772
785 BOOL GetDisplaySettings(const CWnd* pWnd, DEVMODE* lpDevMode);
786
799 BOOL GetDisplaySettings(HWND hWnd, DEVMODE* lpDevMode);
800
801private:
802 BOOL GetMonitorInfo(XTP_HMONITOR hMonitor, XTP_MONITORINFO* lpMonitorInfo);
803 CRect GetWorkArea(XTP_HMONITOR hMonitor);
804 CRect GetScreenArea(XTP_HMONITOR hMonitor);
805
806 int(WINAPI* m_pfnGetSystemMetrics)(int);
807 XTP_HMONITOR(WINAPI* m_pfnMonitorFromWindow)(HWND, DWORD);
808 XTP_HMONITOR(WINAPI* m_pfnMonitorFromRect)(LPCRECT, DWORD);
809 XTP_HMONITOR(WINAPI* m_pfnMonitorFromPoint)(POINT, DWORD);
810 BOOL(WINAPI* m_pfnGetMonitorInfo)(XTP_HMONITOR, XTP_MONITORINFO*);
811 BOOL(WINAPI* m_pfnEnumDisplaySettingsEx)(LPCTSTR, DWORD, DEVMODE*, DWORD);
812 CXTPModuleHandle m_modUser32;
813
814 friend _XTP_EXT_CLASS CXTPMultiMonitor* AFX_CDECL XTPMultiMonitor();
815};
816
828_XTP_EXT_CLASS CXTPMultiMonitor* AFX_CDECL XTPMultiMonitor();
829
834class _XTP_EXT_CLASS CXTPCriticalSection
835{
836public:
841 CXTPCriticalSection();
842
847 ~CXTPCriticalSection();
848
849public:
855 void EnterCritical();
856
862 void LeaveCritical();
863
868 operator CRITICAL_SECTION&()
869 {
870 return m_csMutex;
871 }
872
873private:
874 CRITICAL_SECTION m_csMutex;
875};
876
881class _XTP_EXT_CLASS CXTPLockGuard
882{
883public:
889 CXTPLockGuard(CRITICAL_SECTION& key);
890
895 ~CXTPLockGuard();
896
897public:
901 void LockThread();
902
906 void UnLockThread();
907
908private:
909 DISABLE_COPY_OPERATOR(CXTPLockGuard);
910
911private:
912 CRITICAL_SECTION& m_key;
913};
914
917# ifndef CHILDID_SELF
918# define CHILDID_SELF 0
919# endif
920
921# ifndef WM_GETOBJECT
922# define WM_GETOBJECT 0x003D
923# endif
924
925# ifndef EVENT_OBJECT_FOCUS
926# define EVENT_OBJECT_FOCUS 0x8005
927# endif
928
929# ifndef OBJID_MENU
930# define OBJID_MENU 0xFFFFFFFD
931# endif
932
933# ifndef OBJID_CLIENT
934# define OBJID_CLIENT 0xFFFFFFFC
935# endif
936
937# ifndef OBJID_WINDOW
938# define OBJID_WINDOW 0x00000000
939# endif
940
941class _XTP_EXT_CLASS CXTPAccessibleProxy;
942class _XTP_EXT_CLASS CXTPAccessible
943{
944 friend class CXTPAccessibleProxy;
945
946public:
947 CXTPAccessible();
948 virtual ~CXTPAccessible();
949
950 LRESULT LresultFromProxyObject(WPARAM wParam);
951 IAccessible* CreateAccProxy();
952
953public:
954 virtual HRESULT GetAccessibleParent(IDispatch** ppdispParent);
955 virtual HRESULT GetAccessibleChildCount(long* pcountChildren);
956 virtual HRESULT GetAccessibleChild(VARIANT varChild, IDispatch** ppdispChild);
957 virtual HRESULT GetAccessibleName(VARIANT varChild, BSTR* pszName);
958 virtual HRESULT GetAccessibleValue(VARIANT varChild, BSTR* pszValue);
959 virtual HRESULT GetAccessibleDescription(VARIANT varChild, BSTR* pszDescription);
960 virtual HRESULT GetAccessibleRole(VARIANT varChild, VARIANT* pvarRole);
961 virtual HRESULT GetAccessibleState(VARIANT varChild, VARIANT* pvarState);
962 virtual HRESULT GetAccessibleHelp(VARIANT varChild, BSTR* pszHelp);
963 virtual HRESULT GetAccessibleHelpTopic(BSTR* pszHelpFile, VARIANT varChild, long* pidTopic);
964 virtual HRESULT GetAccessibleKeyboardShortcut(VARIANT varChild, BSTR* pszKeyboardShortcut);
965 virtual HRESULT GetAccessibleFocus(VARIANT* pvarChild);
966 virtual HRESULT GetAccessibleSelection(VARIANT* pvarChildren);
967 virtual HRESULT GetAccessibleDefaultAction(VARIANT varChild, BSTR* pszDefaultAction);
968 virtual HRESULT AccessibleSelect(long flagsSelect, VARIANT varChild);
969 virtual HRESULT AccessibleLocation(long* pxLeft, long* pyTop, long* pcxWidth, long* pcyHeight,
970 VARIANT varChild);
971 virtual HRESULT AccessibleNavigate(long navDir, VARIANT varStart, VARIANT* pvarEndUpAt);
972 virtual HRESULT AccessibleHitTest(long xLeft, long yTop, VARIANT* pvarChild);
973 virtual HRESULT AccessibleDoDefaultAction(VARIANT varChild);
974 // Obsolete
975 virtual HRESULT PutAccessibleName(VARIANT varChild, BSTR szName);
976 // Obsolete
977 virtual HRESULT PutAccessibleValue(VARIANT varChild, BSTR szValue);
978
979 virtual CCmdTarget* GetAccessible();
980
981 void AccessibleNotifyWinEvent(DWORD event, HWND hwnd, LONG idObject, LONG idChild);
982
983protected:
984 HRESULT AccessibleObjectFromWindow(HWND hwnd, DWORD dwId, REFIID riid, void** ppvObject);
985 LRESULT LresultFromObject(REFIID riid, WPARAM wParam, LPUNKNOWN punk);
986
987 long GetChildIndex(VARIANT* varChild);
988
989public:
990# pragma warning(push)
991// C4616: #pragma warning : warning number '...' out of range, must be between '4001' and '4999'
992// C4619: #pragma warning : there is no warning number 'number'
993// C5204: '...': class has virtual functions, but its trivial destructor is not virtual; instances
994// of objects derived from this class may not be destructed correctly
995# pragma warning(disable : 4616 4619 5204)
996 class _XTP_EXT_CLASS XAccessible;
997 BEGIN_INTERFACE_PART(Accessible, IAccessible)
998 STDMETHOD(GetTypeInfoCount)(UINT FAR* pctinfo);
999 STDMETHOD(GetTypeInfo)(UINT itinfo, LCID lcid, ITypeInfo FAR* FAR* pptinfo);
1000 STDMETHOD(GetIDsOfNames)
1001 (REFIID riid, OLECHAR FAR* FAR* rgszNames, UINT cNames, LCID lcid, DISPID FAR* rgdispid);
1002 STDMETHOD(Invoke)
1003 (DISPID dispidMember, REFIID riid, LCID lcid, WORD wFlags, DISPPARAMS FAR* pdispparams,
1004 VARIANT FAR* pvarResult, EXCEPINFO FAR* pexcepinfo, UINT FAR* puArgErr);
1005
1006 STDMETHOD(get_accParent)(IDispatch* FAR* ppdispParent);
1007 STDMETHOD(get_accChildCount)(long FAR* pChildCount);
1008 STDMETHOD(get_accChild)(VARIANT varChildIndex, IDispatch* FAR* ppdispChild);
1009
1010 STDMETHOD(get_accName)(VARIANT varChild, BSTR* pszName);
1011 STDMETHOD(get_accValue)(VARIANT varChild, BSTR* pszValue);
1012 STDMETHOD(get_accDescription)(VARIANT varChild, BSTR FAR* pszDescription);
1013 STDMETHOD(get_accRole)(VARIANT varChild, VARIANT* pvarRole);
1014 STDMETHOD(get_accState)(VARIANT varChild, VARIANT* pvarState);
1015 STDMETHOD(get_accHelp)(VARIANT varChild, BSTR* pszHelp);
1016 STDMETHOD(get_accHelpTopic)(BSTR* pszHelpFile, VARIANT varChild, long* pidTopic);
1017 STDMETHOD(get_accKeyboardShortcut)(VARIANT varChild, BSTR* pszKeyboardShortcut);
1018 STDMETHOD(get_accFocus)(VARIANT FAR* pvarFocusChild);
1019 STDMETHOD(get_accSelection)(VARIANT FAR* pvarSelectedChildren);
1020 STDMETHOD(get_accDefaultAction)(VARIANT varChild, BSTR* pszDefaultAction);
1021
1022 STDMETHOD(accSelect)(long flagsSelect, VARIANT varChild);
1023 STDMETHOD(accLocation)
1024 (long* pxLeft, long* pyTop, long* pcxWidth, long* pcyHeight, VARIANT varChild);
1025 STDMETHOD(accNavigate)(long navDir, VARIANT varStart, VARIANT* pvarEndUpAt);
1026 STDMETHOD(accHitTest)(long xLeft, long yTop, VARIANT* pvarChildAtPoint);
1027 STDMETHOD(accDoDefaultAction)(VARIANT varChild);
1028
1029 STDMETHOD(put_accName)(VARIANT varChild, BSTR szName);
1030 STDMETHOD(put_accValue)(VARIANT varChild, BSTR pszValue);
1031 END_INTERFACE_PART(ExternalAccessible)
1032# pragma warning(pop)
1033
1034private:
1035 typedef VOID(WINAPI* LPFNNOTIFYWINEVENT)(DWORD event, HWND hwnd, LONG idObject, LONG idChild);
1036
1037 LPFNNOTIFYWINEVENT m_pNotifyWinEvent;
1038 LPFNLRESULTFROMOBJECT m_pLresultFromObject;
1039 LPFNACCESSIBLEOBJECTFROMWINDOW m_pAccessibleObjectFromWindow;
1040
1041 HMODULE m_hUser32;
1042 HMODULE m_hOleAcc;
1043
1044 struct SharedHandle
1045 {
1046 SharedHandle(CXTPAccessible* pAcc);
1047 void AddRef();
1048 void Release();
1049
1050 CXTPAccessible* pAcc;
1051 ULONG cRefs;
1052 };
1053
1054 SharedHandle* m_pHandle;
1055};
1056
1057class _XTP_EXT_CLASS CXTPAccessibleProxy : public IAccessible
1058{
1059public:
1060 explicit CXTPAccessibleProxy(CXTPAccessible::SharedHandle* pAccHandle);
1061 virtual ~CXTPAccessibleProxy();
1062
1063 BOOL IsAlive() const;
1064
1065private:
1066 virtual HRESULT STDMETHODCALLTYPE QueryInterface(
1067 /* [in] */ REFIID riid,
1068 /* [iid_is][out] */ void** ppvObject);
1069
1070 virtual ULONG STDMETHODCALLTYPE AddRef(void);
1071
1072 virtual ULONG STDMETHODCALLTYPE Release(void);
1073
1074 virtual HRESULT STDMETHODCALLTYPE GetTypeInfoCount(
1075 /* [out] */ UINT* pctinfo);
1076
1077 virtual HRESULT STDMETHODCALLTYPE GetTypeInfo(
1078 /* [in] */ UINT iTInfo,
1079 /* [in] */ LCID lcid,
1080 /* [out] */ ITypeInfo** ppTInfo);
1081
1082 virtual HRESULT STDMETHODCALLTYPE GetIDsOfNames(
1083 /* [in] */ REFIID riid,
1084 /* [size_is][in] */ LPOLESTR* rgszNames,
1085 /* [range][in] */ UINT cNames,
1086 /* [in] */ LCID lcid,
1087 /* [size_is][out] */ DISPID* rgDispId);
1088
1089 virtual /* [local] */ HRESULT STDMETHODCALLTYPE Invoke(
1090 /* [annotation][in] */
1091 DISPID dispIdMember,
1092 /* [annotation][in] */
1093 REFIID riid,
1094 /* [annotation][in] */
1095 LCID lcid,
1096 /* [annotation][in] */
1097 WORD wFlags,
1098 /* [annotation][out][in] */
1099 DISPPARAMS* pDispParams,
1100 /* [annotation][out] */
1101 VARIANT* pVarResult,
1102 /* [annotation][out] */
1103 EXCEPINFO* pExcepInfo,
1104 /* [annotation][out] */
1105 UINT* puArgErr);
1106
1107 virtual /* [id][propget][hidden] */ HRESULT STDMETHODCALLTYPE get_accParent(
1108 /* [retval][out] */ IDispatch** ppdispParent);
1109
1110 virtual /* [id][propget][hidden] */ HRESULT STDMETHODCALLTYPE get_accChildCount(
1111 /* [retval][out] */ long* pcountChildren);
1112
1113 virtual /* [id][propget][hidden] */ HRESULT STDMETHODCALLTYPE get_accChild(
1114 /* [in] */ VARIANT varChild,
1115 /* [retval][out] */ IDispatch** ppdispChild);
1116
1117 virtual /* [id][propget][hidden] */ HRESULT STDMETHODCALLTYPE get_accName(
1118 /* [optional][in] */ VARIANT varChild,
1119 /* [retval][out] */ BSTR* pszName);
1120
1121 virtual /* [id][propget][hidden] */ HRESULT STDMETHODCALLTYPE get_accValue(
1122 /* [optional][in] */ VARIANT varChild,
1123 /* [retval][out] */ BSTR* pszValue);
1124
1125 virtual /* [id][propget][hidden] */ HRESULT STDMETHODCALLTYPE get_accDescription(
1126 /* [optional][in] */ VARIANT varChild,
1127 /* [retval][out] */ BSTR* pszDescription);
1128
1129 virtual /* [id][propget][hidden] */ HRESULT STDMETHODCALLTYPE get_accRole(
1130 /* [optional][in] */ VARIANT varChild,
1131 /* [retval][out] */ VARIANT* pvarRole);
1132
1133 virtual /* [id][propget][hidden] */ HRESULT STDMETHODCALLTYPE get_accState(
1134 /* [optional][in] */ VARIANT varChild,
1135 /* [retval][out] */ VARIANT* pvarState);
1136
1137 virtual /* [id][propget][hidden] */ HRESULT STDMETHODCALLTYPE get_accHelp(
1138 /* [optional][in] */ VARIANT varChild,
1139 /* [retval][out] */ BSTR* pszHelp);
1140
1141 virtual /* [id][propget][hidden] */ HRESULT STDMETHODCALLTYPE get_accHelpTopic(
1142 /* [out] */ BSTR* pszHelpFile,
1143 /* [optional][in] */ VARIANT varChild,
1144 /* [retval][out] */ long* pidTopic);
1145
1146 virtual /* [id][propget][hidden] */ HRESULT STDMETHODCALLTYPE get_accKeyboardShortcut(
1147 /* [optional][in] */ VARIANT varChild,
1148 /* [retval][out] */ BSTR* pszKeyboardShortcut);
1149
1150 virtual /* [id][propget][hidden] */ HRESULT STDMETHODCALLTYPE get_accFocus(
1151 /* [retval][out] */ VARIANT* pvarChild);
1152
1153 virtual /* [id][propget][hidden] */ HRESULT STDMETHODCALLTYPE get_accSelection(
1154 /* [retval][out] */ VARIANT* pvarChildren);
1155
1156 virtual /* [id][propget][hidden] */ HRESULT STDMETHODCALLTYPE get_accDefaultAction(
1157 /* [optional][in] */ VARIANT varChild,
1158 /* [retval][out] */ BSTR* pszDefaultAction);
1159
1160 virtual /* [id][hidden] */ HRESULT STDMETHODCALLTYPE accSelect(
1161 /* [in] */ long flagsSelect,
1162 /* [optional][in] */ VARIANT varChild);
1163
1164 virtual /* [id][hidden] */ HRESULT STDMETHODCALLTYPE accLocation(
1165 /* [out] */ long* pxLeft,
1166 /* [out] */ long* pyTop,
1167 /* [out] */ long* pcxWidth,
1168 /* [out] */ long* pcyHeight,
1169 /* [optional][in] */ VARIANT varChild);
1170
1171 virtual /* [id][hidden] */ HRESULT STDMETHODCALLTYPE accNavigate(
1172 /* [in] */ long navDir,
1173 /* [optional][in] */ VARIANT varStart,
1174 /* [retval][out] */ VARIANT* pvarEndUpAt);
1175
1176 virtual /* [id][hidden] */ HRESULT STDMETHODCALLTYPE accHitTest(
1177 /* [in] */ long xLeft,
1178 /* [in] */ long yTop,
1179 /* [retval][out] */ VARIANT* pvarChild);
1180
1181 virtual /* [id][hidden] */ HRESULT STDMETHODCALLTYPE accDoDefaultAction(
1182 /* [optional][in] */ VARIANT varChild);
1183
1184 virtual /* [id][propput][hidden] */ HRESULT STDMETHODCALLTYPE put_accName(
1185 /* [optional][in] */ VARIANT varChild,
1186 /* [in] */ BSTR szName);
1187
1188 virtual /* [id][propput][hidden] */ HRESULT STDMETHODCALLTYPE put_accValue(
1189 /* [optional][in] */ VARIANT varChild,
1190 /* [in] */ BSTR szValue);
1191
1192private:
1193 CXTPAccessible::SharedHandle* m_pAccHandle;
1194 ULONG m_cRefs;
1195};
1196
1208enum XTPSoundManagerState
1209{
1210 xtpSoundNone,
1211 xtpSoundMenuCommand,
1212 xtpSoundMenuPopup,
1213};
1214
1221class _XTP_EXT_CLASS CXTPSoundManager
1222{
1223 friend class CXTPSingleton<CXTPSoundManager>;
1224
1225 friend _XTP_EXT_CLASS CXTPSoundManager* AFX_CDECL XTPSoundManager();
1226
1231 CXTPSoundManager();
1232
1233public:
1238 ~CXTPSoundManager();
1239
1250 void PlaySystemSound(XTPSoundManagerState state);
1251
1259 void EnableSystemSounds(BOOL bEnable);
1260
1265 void StopThread();
1266
1267public:
1269 BOOL IsSoundThreadProc(LPVOID pProc) const;
1270 BOOL IsSoundThreadId(DWORD dwTid) const;
1273private:
1274 void StartThread();
1275 static DWORD WINAPI SoundThreadProc(LPVOID);
1276 XTPSoundManagerState FetchSoundState(BOOL& bQuit);
1277
1278public:
1279 BOOL m_bSoundAvailable;
1281private:
1282 BOOL m_bSystemSounds;
1283 HANDLE m_hThread;
1284 HANDLE m_hThreadStartEvent;
1285 DWORD m_dwThreadId;
1286};
1287
1299_XTP_EXT_CLASS CXTPSoundManager* AFX_CDECL XTPSoundManager();
1300
1305class _XTP_EXT_CLASS CXTPZipMemFile : public CMemFile
1306{
1307 struct ZIPBUFFERHEADER
1308 {
1309 DWORD dwType;
1310 DWORD dwSize;
1311 };
1312
1313 struct ZIPBUFFERINFO
1314 {
1315 ZIPBUFFERHEADER bh;
1316 BYTE bBuffer[1];
1317 };
1318
1319public:
1320 CXTPZipMemFile();
1321 CXTPZipMemFile(BYTE* lpBuffer, UINT nBufferSize);
1322
1323 ~CXTPZipMemFile();
1324
1325public:
1326 void AttachCompressedBuffer(BYTE* lpBuffer, UINT nBufferSize, BOOL bAutoDelete = FALSE);
1327 void DetachCompressedBuffer(BYTE*& lpBuffer, DWORD& dwCount);
1328 BOOL OpenCompressedFile(LPCTSTR lpszFileName);
1329};
1330
1331_XTP_EXT_CLASS CWinThread* AFX_CDECL XTPGetThread();
1332
1337enum XTPUriType
1338{
1339 xtpUriFile,
1340 xtpUriRes
1341};
1342
1347struct XTP_URI
1348{
1349 XTPUriType type;
1350 union {
1351 TCHAR file[MAX_PATH + 1];
1353 struct
1354 {
1355 TCHAR szFilePath[MAX_PATH + 1];
1356 LPCTSTR lpType;
1357 LPCTSTR lpName;
1358 struct
1359 {
1360 TCHAR szType[50];
1361 TCHAR szName[50];
1362 } reserved;
1363 } res;
1364 };
1365};
1366
1371struct XTP_URI_DEFAULTS
1372{
1373 struct
1374 {
1375 LPCTSTR lpType;
1376 } res;
1377};
1378
1419_XTP_EXT_CLASS HRESULT AFX_CDECL XTPParseUri(LPCTSTR lpszUri, XTP_URI* pUri,
1420 const XTP_URI_DEFAULTS* pDefaults = NULL);
1421
1430_XTP_EXT_CLASS HRESULT AFX_CDECL XTPCreateReadOnlyStreamOnUri(const XTP_URI* pUri,
1431 IStream** ppStream);
1432
1442_XTP_EXT_CLASS HRESULT AFX_CDECL XTPCreateReadOnlyStreamOnUri(
1443 LPCTSTR lpszUri, IStream** ppStream, const XTP_URI_DEFAULTS* pDefaults = NULL);
1444
1461_XTP_EXT_CLASS BOOL AFX_CDECL XTPLoadUnicodeText(const void* pRawData, UINT cbRawData,
1462 LPWSTR lpUnicodeText, UINT* pchUnicodeText);
1463
1479_XTP_EXT_CLASS BOOL AFX_CDECL XTPLoadText(const void* pRawData, UINT cbRawData, LPTSTR lpText,
1480 UINT* pchText);
1481
1493_XTP_EXT_CLASS BOOL AFX_CDECL XTPLoadText(const void* pRawData, UINT cbRawData, CString& strText);
1494
1506_XTP_EXT_CLASS BOOL AFX_CDECL XTPLoadFileText(LPCTSTR lpPath, CString& strText);
1507
1519_XTP_EXT_CLASS HRESULT AFX_CDECL XTPCreateReadOnlyMemoryStream(const void* pData, UINT cbData,
1520 BOOL bClone, IStream** ppStream);
1521
1531_XTP_EXT_CLASS HRESULT AFX_CDECL XTPCreateFileStream(LPCTSTR lpPath, DWORD grfMode,
1532 IStream** ppStream);
1533
1542_XTP_EXT_CLASS HRESULT AFX_CDECL XTPCreateReadOnlyFileStream(LPCTSTR lpPath, IStream** ppStream);
1543
1556_XTP_EXT_CLASS HRESULT AFX_CDECL XTPCreateReadOnlyResourceStream(HMODULE hModule,
1557 LPCTSTR lpResource,
1558 LPCTSTR lpResourceType,
1559 BOOL bClone, IStream** ppStream);
1560
1579_XTP_EXT_CLASS HRESULT AFX_CDECL XTPReadStreamData(IStream* pStream, LPVOID& pData, SIZE_T& cbData,
1580 ULONG cbSizeNeeded = ULONG_MAX,
1581 STREAM_SEEK nSeek = STREAM_SEEK_CUR,
1582 LONG nOffset = 0);
1583
1592_XTP_EXT_CLASS void AFX_CDECL XTPReleaseReadStreamData(LPVOID pData);
1593
1597# define XTP_INVALID_TLS_SLOT (~DWORD_PTR(0))
1598
1608_XTP_EXT_CLASS DWORD_PTR AFX_CDECL XTPTlsAllocate(PVOID pValue = NULL);
1609
1620_XTP_EXT_CLASS BOOL AFX_CDECL XTPTlsSetValue(DWORD_PTR dwSlot, PVOID pValue);
1621
1631_XTP_EXT_CLASS PVOID AFX_CDECL XTPTlsGetValue(DWORD_PTR dwSlot);
1632
1642_XTP_EXT_CLASS BOOL AFX_CDECL XTPTlsFree(DWORD_PTR dwSlot);
1643
1646template<class T>
1647struct XTPDefaultInitProcs
1648{
1649 static T* AFX_CDECL Create()
1650 {
1651 return new T();
1652 }
1653
1654 static void AFX_CDECL Destroy(T* p)
1655 {
1656 _ASSERTE(NULL != p);
1657 delete p;
1658 }
1659};
1660
1674template<class T>
1675class CXTPThreadLocal
1676{
1677public:
1681 typedef T*(AFX_CDECL* CreateProc)();
1682
1686 typedef void(AFX_CDECL* DestroyProc)(T*);
1687
1689 typedef XTPDefaultInitProcs<T> DefaultProcs;
1700 CXTPThreadLocal(CreateProc pfnCreate = DefaultProcs::Create,
1701 DestroyProc pfnDestroy = DefaultProcs::Destroy);
1702
1707 ~CXTPThreadLocal();
1708
1715 BOOL IsValid() const;
1716
1724 void Reset(BOOL bCurrentThread = FALSE);
1725
1734 T& operator*();
1735
1744 const T& operator*() const;
1745
1746private:
1747 T* GetData(BOOL bAllocate = TRUE);
1748
1749 DWORD_PTR m_dwSlot;
1750 CreateProc m_pfnCreate;
1751 DestroyProc m_pfnDestroy;
1752 CXTPCriticalSection m_access;
1753 CMap<T*, T*, T*, T*> m_ptrMap;
1754};
1756template<class T>
1757AFX_INLINE CXTPThreadLocal<T>::CXTPThreadLocal(CreateProc pfnCreate /*= DefaultProcs::Create*/,
1758 DestroyProc pfnDestroy /*= DefaultProcs::Destroy*/)
1759 : m_dwSlot(XTPTlsAllocate())
1760 , m_pfnCreate(pfnCreate)
1761 , m_pfnDestroy(pfnDestroy)
1762{
1763 _ASSERTE(NULL != pfnCreate);
1764 _ASSERTE(NULL != pfnDestroy);
1765}
1766
1767template<class T>
1768AFX_INLINE CXTPThreadLocal<T>::~CXTPThreadLocal()
1769{
1770 Reset();
1771
1772 if (IsValid())
1773 XTPTlsFree(m_dwSlot);
1774}
1775
1776template<class T>
1777AFX_INLINE BOOL CXTPThreadLocal<T>::IsValid() const
1778{
1779 return (XTP_INVALID_TLS_SLOT != m_dwSlot);
1780}
1781
1782template<class T>
1783AFX_INLINE void CXTPThreadLocal<T>::Reset(BOOL bCurrentThread /*= FALSE*/)
1784{
1785 if (bCurrentThread)
1786 {
1787 T* pData = reinterpret_cast<T*>(XTPTlsGetValue(m_dwSlot));
1788 if (NULL != pData)
1789 {
1790 CXTPLockGuard lock(m_access);
1791 m_ptrMap.RemoveKey(pData);
1792 m_pfnDestroy(pData);
1793 XTPTlsSetValue(m_dwSlot, NULL);
1794 }
1795 }
1796 else
1797 {
1798 CXTPLockGuard lock(m_access);
1799
1800 POSITION pos = m_ptrMap.GetStartPosition();
1801 while (NULL != pos)
1802 {
1803 T* ptr = NULL;
1804 m_ptrMap.GetNextAssoc(pos, ptr, ptr);
1805 m_pfnDestroy(ptr);
1806 }
1807 }
1808}
1809
1810template<class T>
1811AFX_INLINE T* CXTPThreadLocal<T>::GetData(BOOL bAllocate /*= TRUE*/)
1812{
1813 if (!IsValid())
1814 return NULL;
1815
1816 T* pData = reinterpret_cast<T*>(XTPTlsGetValue(m_dwSlot));
1817
1818 if (NULL == pData && bAllocate)
1819 {
1820 pData = m_pfnCreate();
1821 if (!XTPTlsSetValue(m_dwSlot, pData))
1822 {
1823 m_pfnDestroy(pData);
1824 pData = NULL;
1825 }
1826
1827 CXTPLockGuard lock(m_access);
1828 m_ptrMap[pData] = pData;
1829 }
1830
1831 return pData;
1832}
1833
1834template<class T>
1835AFX_INLINE T& CXTPThreadLocal<T>::operator*()
1836{
1837 _ASSERTE(IsValid());
1838 return *GetData();
1839}
1840
1841template<class T>
1842AFX_INLINE const T& CXTPThreadLocal<T>::operator*() const
1843{
1844 return const_cast< CXTPThreadLocal*>(this)->operator*();
1845}
1853template<class Type>
1854class CXTPExcludedMemberPadding
1855{
1856 BYTE _[sizeof(Type)];
1857};
1858
1865enum XTPWindowClass
1866{
1867 xtpWindowClassRichEdit
1868};
1869
1874enum XTPWindowClassVersionSelectionVerb
1875{
1876 xtpWindowClassVersionExact,
1877 xtpWindowClassVersionAtLeast,
1879 xtpWindowClassVersionHighest
1880};
1881
1886enum XTPRichEditWindowClassVersion
1887{
1888 xtpRichEditWindowClassVersion10,
1889 xtpRichEditWindowClassVersion20,
1890 xtpRichEditWindowClassVersion30,
1891 xtpRichEditWindowClassVersion31,
1892 xtpRichEditWindowClassVersion40,
1893 xtpRichEditWindowClassVersion41,
1894 xtpRichEditWindowClassVersion50,
1895 xtpRichEditWindowClassVersion60,
1896 xtpRichEditWindowClassVersion70,
1898 xtpRichEditWindowClassDefault = xtpRichEditWindowClassVersion20
1900};
1901
1917_XTP_EXT_CLASS BOOL AFX_CDECL XTPLoadWindowClass(XTPWindowClass nClass,
1918 XTPWindowClassVersionSelectionVerb nVerb,
1919 int* pnVersion, LPWNDCLASS pWndClass = NULL);
1920
1933AFX_INLINE BOOL AFX_CDECL XTPLoadWindowClass(XTPWindowClass nClass,
1934 XTPWindowClassVersionSelectionVerb nVerb, int nVersion,
1935 LPWNDCLASS pWndClass = NULL)
1936{
1937 return XTPLoadWindowClass(nClass, nVerb, &nVersion, pWndClass);
1938}
1939
1943enum XTPComInit
1944{
1948 xtpComInitInvalid = -1,
1949
1954 xtpComInitAppDefault,
1955
1960 xtpComInitSTA = 0x1,
1961
1966 xtpComInitMTA = 0x2,
1967
1972 xtpComInitDisableOle1DDE = 0x4,
1973
1979 xtpComInitSpeedOverMemory = 0x8,
1980
1984 xtpComInitOle = 0x10,
1985
1992 xtpComInitAfxOle = 0x20,
1993
2001 xtpComInitModuleAfxOle = 0x40,
2002
2008 xtpComInitUserDefined = 0x10000000,
2009
2011 xtpComInitForce = 0x80000000
2013};
2014
2020class _XTP_EXT_CLASS CXTPComInitializer
2021{
2022public:
2030 CXTPComInitializer(int xtpComInit = xtpComInitAppDefault);
2031
2037 ~CXTPComInitializer();
2038
2045 HRESULT GetInitializationStatus() const;
2046
2055 int GetInitFlags() const;
2056
2057private:
2058 CXTPComInitializer(const CXTPComInitializer&);
2059 CXTPComInitializer& operator=(const CXTPComInitializer&);
2060
2061 int m_xtpComInit;
2062 HRESULT m_hr;
2063};
2065AFX_INLINE HRESULT CXTPComInitializer::GetInitializationStatus() const
2066{
2067 return m_hr;
2068}
2069
2070AFX_INLINE int CXTPComInitializer::GetInitFlags() const
2071{
2072 return m_xtpComInit;
2073}
2075template<class Owner, class Observer>
2076class CXTPObservable;
2077
2088template<class Observable, class Observer>
2089class CXTPSubscriptionList
2090{
2091 friend class CXTPObservable<Observable, Observer>;
2092
2093 struct SubscriptionInfo
2094 {
2095 CXTPObservable<Observable, Observer>* pObservable;
2096 BOOL bMarkedUnsubscribed;
2097 };
2098
2099public:
2105 explicit CXTPSubscriptionList(Observer& observer);
2106
2111 ~CXTPSubscriptionList();
2112
2119 UINT GetSubscriptionCount() const;
2120
2121private:
2122 void OnSubscribed(CXTPObservable<Observable, Observer>* pObservable);
2123 void OnUnsubscribed(CXTPObservable<Observable, Observer>* pObservable);
2124
2125 Observer& m_Observer;
2126 CList<SubscriptionInfo, SubscriptionInfo&> m_Subscriptions;
2127 BOOL m_bBeingDestructed;
2128};
2129
2136template<class Owner, class Observer>
2137class CXTPObservable
2138{
2139 struct ObserverInfo
2140 {
2141 Observer* pObserver;
2142 BOOL bRemove;
2143 CXTPSubscriptionList<Owner, Observer>* pSubcriptionList;
2144 };
2145
2146protected:
2151 CXTPObservable();
2152
2157 ~CXTPObservable();
2158
2159public:
2168 void Subscribe(Observer* pObserver,
2169 CXTPSubscriptionList<Owner, Observer>* pSubcriptionList = NULL);
2170
2182 void Unsubscribe(Observer* pObserver);
2183
2192 void Notify(void (Observer::*method)(Owner*))
2193 {
2194 _ASSERTE(NULL != method);
2195
2196 OnBeforeNotify();
2197
2198 for (INT_PTR i = 0; i < m_Observers.GetSize(); ++i)
2199 {
2200 if (!m_Observers[i].bRemove)
2201 {
2202 (m_Observers[i].pObserver->*method)(static_cast<Owner*>(this));
2203 }
2204 }
2205
2206 OnAfterNotify();
2207 }
2208
2217 void NotifyReversed(void (Observer::*method)(Owner*))
2218 {
2219 _ASSERTE(NULL != method);
2220
2221 OnBeforeNotify();
2222
2223 for (INT_PTR i = m_Observers.GetSize() - 1; 0 <= i; --i)
2224 {
2225 if (!m_Observers[i].bRemove)
2226 {
2227 (m_Observers[i].pObserver->*method)(static_cast<Owner*>(this));
2228 }
2229 }
2230
2231 OnAfterNotify();
2232 }
2233
2242 template<class T, class O>
2243 void NotifyDynamic(void (T::*method)(O*))
2244 {
2245 _ASSERTE(NULL != method);
2246
2247 OnBeforeNotify();
2248
2249 CXTPTypeId specializedTypeId = CXTPTypeIdOf<T>::Id();
2250 for (INT_PTR i = 0; i < m_Observers.GetSize(); ++i)
2251 {
2252 if (!m_Observers[i].bRemove)
2253 {
2254 T* pCastedObserver = reinterpret_cast<T*>(
2255 static_cast<CXTPTypeIdProvider<Observer>*>(m_Observers[i].pObserver)
2256 ->TryCastTo(specializedTypeId));
2257 if (NULL != pCastedObserver)
2258 {
2259 (pCastedObserver->*method)(static_cast<O*>(static_cast<Owner*>(this)));
2260 }
2261 }
2262 }
2263
2264 OnAfterNotify();
2265 }
2266
2275 template<class T, class O>
2276 void NotifyDynamicReversed(void (T::*method)(O*))
2277 {
2278 _ASSERTE(NULL != method);
2279
2280 OnBeforeNotify();
2281
2282 CXTPTypeId specializedTypeId = CXTPTypeIdOf<T>::Id();
2283 for (INT_PTR i = m_Observers.GetSize() - 1; 0 <= i; --i)
2284 {
2285 if (!m_Observers[i].bRemove)
2286 {
2287 T* pCastedObserver = reinterpret_cast<T*>(
2288 static_cast<CXTPTypeIdProvider<Observer>*>(m_Observers[i].pObserver)
2289 ->TryCastTo(specializedTypeId));
2290 if (NULL != pCastedObserver)
2291 {
2292 (pCastedObserver->*method)(static_cast<O*>(static_cast<Owner*>(this)));
2293 }
2294 }
2295 }
2296
2297 OnAfterNotify();
2298 }
2299
2310 template<class A1>
2311 void Notify(void (Observer::*method)(Owner*, A1), A1 arg1)
2312 {
2313 _ASSERTE(NULL != method);
2314
2315 OnBeforeNotify();
2316
2317 for (INT_PTR i = 0; i < m_Observers.GetSize(); ++i)
2318 {
2319 if (!m_Observers[i].bRemove)
2320 {
2321 (m_Observers[i].pObserver->*method)(static_cast<Owner*>(this), arg1);
2322 }
2323 }
2324
2325 OnAfterNotify();
2326 }
2327
2338 template<class A1>
2339 void NotifyReversed(void (Observer::*method)(Owner*, A1), A1 arg1)
2340 {
2341 _ASSERTE(NULL != method);
2342
2343 OnBeforeNotify();
2344
2345 for (INT_PTR i = m_Observers.GetSize() - 1; 0 <= i; --i)
2346 {
2347 if (!m_Observers[i].bRemove)
2348 {
2349 (m_Observers[i].pObserver->*method)(static_cast<Owner*>(this), arg1);
2350 }
2351 }
2352
2353 OnAfterNotify();
2354 }
2355
2366 template<class T, class O, class A1>
2367 void NotifyDynamic(void (T::*method)(O*, A1), A1 arg1)
2368 {
2369 _ASSERTE(NULL != method);
2370
2371 OnBeforeNotify();
2372
2373 CXTPTypeId specializedTypeId = CXTPTypeIdOf<T>::Id();
2374 for (INT_PTR i = 0; i < m_Observers.GetSize(); ++i)
2375 {
2376 if (!m_Observers[i].bRemove)
2377 {
2378 T* pCastedObserver = reinterpret_cast<T*>(
2379 static_cast<CXTPTypeIdProvider<Observer>*>(m_Observers[i].pObserver)
2380 ->TryCastTo(specializedTypeId));
2381 if (NULL != pCastedObserver)
2382 {
2383 (pCastedObserver->*method)(static_cast<O*>(static_cast<Owner*>(this)), arg1);
2384 }
2385 }
2386 }
2387
2388 OnAfterNotify();
2389 }
2390
2401 template<class T, class O, class A1>
2402 void NotifyDynamicReversed(void (T::*method)(O*, A1), A1 arg1)
2403 {
2404 _ASSERTE(NULL != method);
2405
2406 OnBeforeNotify();
2407
2408 CXTPTypeId specializedTypeId = CXTPTypeIdOf<T>::Id();
2409 for (INT_PTR i = m_Observers.GetSize() - 1; 0 <= i; --i)
2410 {
2411 if (!m_Observers[i].bRemove)
2412 {
2413 T* pCastedObserver = reinterpret_cast<T*>(
2414 static_cast<CXTPTypeIdProvider<Observer>*>(m_Observers[i].pObserver)
2415 ->TryCastTo(specializedTypeId));
2416 if (NULL != pCastedObserver)
2417 {
2418 (pCastedObserver->*method)(static_cast<O*>(static_cast<Owner*>(this)), arg1);
2419 }
2420 }
2421 }
2422
2423 OnAfterNotify();
2424 }
2425
2438 template<class A1, class A2>
2439 void Notify(void (Observer::*method)(Owner*, A1, A2), A1 arg1, A2 arg2)
2440 {
2441 _ASSERTE(NULL != method);
2442
2443 OnBeforeNotify();
2444
2445 for (INT_PTR i = 0; i < m_Observers.GetSize(); ++i)
2446 {
2447 if (!m_Observers[i].bRemove)
2448 {
2449 (m_Observers[i].pObserver->*method)(static_cast<Owner*>(this), arg1, arg2);
2450 }
2451 }
2452
2453 OnAfterNotify();
2454 }
2455
2468 template<class A1, class A2>
2469 void NotifyReversed(void (Observer::*method)(Owner*, A1, A2), A1 arg1, A2 arg2)
2470 {
2471 _ASSERTE(NULL != method);
2472
2473 OnBeforeNotify();
2474
2475 for (INT_PTR i = m_Observers.GetSize() - 1; 0 <= i; --i)
2476 {
2477 if (!m_Observers[i].bRemove)
2478 {
2479 (m_Observers[i].pObserver->*method)(static_cast<Owner*>(this), arg1, arg2);
2480 }
2481 }
2482
2483 OnAfterNotify();
2484 }
2485
2498 template<class T, class O, class A1, class A2>
2499 void NotifyDynamic(void (T::*method)(O*, A1, A2), A1 arg1, A2 arg2)
2500 {
2501 _ASSERTE(NULL != method);
2502
2503 OnBeforeNotify();
2504
2505 CXTPTypeId specializedTypeId = CXTPTypeIdOf<T>::Id();
2506 for (INT_PTR i = 0; i < m_Observers.GetSize(); ++i)
2507 {
2508 if (!m_Observers[i].bRemove)
2509 {
2510 T* pCastedObserver = reinterpret_cast<T*>(
2511 static_cast<CXTPTypeIdProvider<Observer>*>(m_Observers[i].pObserver)
2512 ->TryCastTo(specializedTypeId));
2513 if (NULL != pCastedObserver)
2514 {
2515 (pCastedObserver->*method)(static_cast<O*>(static_cast<Owner*>(this)), arg1,
2516 arg2);
2517 }
2518 }
2519 }
2520
2521 OnAfterNotify();
2522 }
2523
2536 template<class T, class O, class A1, class A2>
2537 void NotifyDynamicReversed(void (T::*method)(O*, A1, A2), A1 arg1, A2 arg2)
2538 {
2539 _ASSERTE(NULL != method);
2540
2541 OnBeforeNotify();
2542
2543 CXTPTypeId specializedTypeId = CXTPTypeIdOf<T>::Id();
2544 for (INT_PTR i = m_Observers.GetSize() - 1; 0 <= i; --i)
2545 {
2546 if (!m_Observers[i].bRemove)
2547 {
2548 T* pCastedObserver = reinterpret_cast<T*>(
2549 static_cast<CXTPTypeIdProvider<Observer>*>(m_Observers[i].pObserver)
2550 ->TryCastTo(specializedTypeId));
2551 if (NULL != pCastedObserver)
2552 {
2553 (pCastedObserver->*method)(static_cast<O*>(static_cast<Owner*>(this)), arg1,
2554 arg2);
2555 }
2556 }
2557 }
2558
2559 OnAfterNotify();
2560 }
2561
2576 template<class A1, class A2, class A3>
2577 void Notify(void (Observer::*method)(Owner*, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
2578 {
2579 _ASSERTE(NULL != method);
2580
2581 OnBeforeNotify();
2582
2583 for (INT_PTR i = 0; i < m_Observers.GetSize(); ++i)
2584 {
2585 if (!m_Observers[i].bRemove)
2586 {
2587 (m_Observers[i].pObserver->*method)(static_cast<Owner*>(this), arg1, arg2, arg3);
2588 }
2589 }
2590
2591 OnAfterNotify();
2592 }
2593
2608 template<class A1, class A2, class A3>
2609 void NotifyReversed(void (Observer::*method)(Owner*, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
2610 {
2611 _ASSERTE(NULL != method);
2612
2613 OnBeforeNotify();
2614
2615 for (INT_PTR i = m_Observers.GetSize() - 1; 0 <= i; --i)
2616 {
2617 if (!m_Observers[i].bRemove)
2618 {
2619 (m_Observers[i].pObserver->*method)(static_cast<Owner*>(this), arg1, arg2, arg3);
2620 }
2621 }
2622
2623 OnAfterNotify();
2624 }
2625
2640 template<class T, class O, class A1, class A2, class A3>
2641 void NotifyDynamic(void (T::*method)(O*, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
2642 {
2643 _ASSERTE(NULL != method);
2644
2645 OnBeforeNotify();
2646
2647 CXTPTypeId specializedTypeId = CXTPTypeIdOf<T>::Id();
2648 for (INT_PTR i = 0; i < m_Observers.GetSize(); ++i)
2649 {
2650 if (!m_Observers[i].bRemove)
2651 {
2652 T* pCastedObserver = reinterpret_cast<T*>(
2653 static_cast<CXTPTypeIdProvider<Observer>*>(m_Observers[i].pObserver)
2654 ->TryCastTo(specializedTypeId));
2655 if (NULL != pCastedObserver)
2656 {
2657 (pCastedObserver->*method)(static_cast<O*>(static_cast<Owner*>(this)), arg1,
2658 arg2, arg3);
2659 }
2660 }
2661 }
2662
2663 OnAfterNotify();
2664 }
2665
2680 template<class T, class O, class A1, class A2, class A3>
2681 void NotifyDynamicReversed(void (T::*method)(O*, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
2682 {
2683 _ASSERTE(NULL != method);
2684
2685 OnBeforeNotify();
2686
2687 CXTPTypeId specializedTypeId = CXTPTypeIdOf<T>::Id();
2688 for (INT_PTR i = m_Observers.GetSize() - 1; 0 <= i; --i)
2689 {
2690 if (!m_Observers[i].bRemove)
2691 {
2692 T* pCastedObserver = reinterpret_cast<T*>(
2693 static_cast<CXTPTypeIdProvider<Observer>*>(m_Observers[i].pObserver)
2694 ->TryCastTo(specializedTypeId));
2695 if (NULL != pCastedObserver)
2696 {
2697 (pCastedObserver->*method)(static_cast<O*>(static_cast<Owner*>(this)), arg1,
2698 arg2, arg3);
2699 }
2700 }
2701 }
2702
2703 OnAfterNotify();
2704 }
2705
2706private:
2707 CArray<ObserverInfo, ObserverInfo&> m_Observers;
2708 LONG m_nNotificationDepth;
2709
2710 INT_PTR FindObserver(Observer* pObserver) const;
2711 void OnBeforeNotify();
2712 void OnAfterNotify();
2713 void RemoveObserver(INT_PTR nIndex);
2714};
2715
2716template<class Observable, class Observer>
2717AFX_INLINE CXTPSubscriptionList<Observable, Observer>::CXTPSubscriptionList(Observer& observer)
2718 : m_Observer(observer)
2719 , m_bBeingDestructed(FALSE)
2720{
2721}
2722
2723template<class Observable, class Observer>
2724AFX_INLINE CXTPSubscriptionList<Observable, Observer>::~CXTPSubscriptionList()
2725{
2726 m_bBeingDestructed = TRUE;
2727
2728 POSITION pos = m_Subscriptions.GetHeadPosition();
2729 while (NULL != pos)
2730 {
2731 SubscriptionInfo& subscription = m_Subscriptions.GetNext(pos);
2732 if (!subscription.bMarkedUnsubscribed)
2733 {
2734 subscription.pObservable->Unsubscribe(&m_Observer);
2735 }
2736 }
2737
2738 _ASSERTE("Unable to unsubscribe from all subscriptions. The dangling observer pointer can lead "
2739 "to unspecified behavior."
2740 && 0 == GetSubscriptionCount());
2741}
2742
2743template<class Observable, class Observer>
2744AFX_INLINE UINT CXTPSubscriptionList<Observable, Observer>::GetSubscriptionCount() const
2745{
2746 UINT nCount = 0;
2747 POSITION pos = m_Subscriptions.GetHeadPosition();
2748 while (NULL != pos)
2749 {
2750 const SubscriptionInfo& subscription = m_Subscriptions.GetNext(pos);
2751 if (!subscription.bMarkedUnsubscribed)
2752 {
2753 ++nCount;
2754 }
2755 }
2756
2757 return nCount;
2758}
2759
2760template<class Observable, class Observer>
2761AFX_INLINE void CXTPSubscriptionList<Observable, Observer>::OnSubscribed(
2762 CXTPObservable<Observable, Observer>* pObservable)
2763{
2764 _ASSERTE(NULL != pObservable);
2765
2766 SubscriptionInfo subscriptionInfo = { pObservable, FALSE };
2767 m_Subscriptions.AddTail(subscriptionInfo);
2768}
2769
2770template<class Observable, class Observer>
2771AFX_INLINE void CXTPSubscriptionList<Observable, Observer>::OnUnsubscribed(
2772 CXTPObservable<Observable, Observer>* pObservable)
2773{
2774 POSITION pos = m_Subscriptions.GetHeadPosition();
2775 while (NULL != pos)
2776 {
2777 POSITION oldPos = pos;
2778 SubscriptionInfo& subscription = m_Subscriptions.GetNext(pos);
2779 if (!subscription.bMarkedUnsubscribed && subscription.pObservable == pObservable)
2780 {
2781 if (!m_bBeingDestructed)
2782 {
2783 m_Subscriptions.RemoveAt(oldPos);
2784 }
2785 else
2786 {
2787 subscription.bMarkedUnsubscribed = TRUE;
2788 }
2789 }
2790 }
2791}
2792
2793template<class Owner, class Observer>
2794AFX_INLINE CXTPObservable<Owner, Observer>::CXTPObservable()
2795 : m_nNotificationDepth(0)
2796{
2797}
2798
2799template<class Owner, class Observer>
2800AFX_INLINE CXTPObservable<Owner, Observer>::~CXTPObservable()
2801{
2802 _ASSERTE("All observers must be unsubscribed before destruction" && 0 == m_Observers.GetSize());
2803}
2804
2805template<class Owner, class Observer>
2806AFX_INLINE void CXTPObservable<Owner, Observer>::Subscribe(
2807 Observer* pObserver, CXTPSubscriptionList<Owner, Observer>* pSubcriptionList /*= NULL*/)
2808{
2809 _ASSERTE(NULL != pObserver);
2810
2811 if (FindObserver(pObserver) == -1)
2812 {
2813 ObserverInfo observerInfo = { pObserver, FALSE, pSubcriptionList };
2814 m_Observers.Add(observerInfo);
2815
2816 if (NULL != pSubcriptionList)
2817 {
2818 pSubcriptionList->OnSubscribed(this);
2819 }
2820 }
2821}
2822
2823template<class Owner, class Observer>
2824AFX_INLINE void CXTPObservable<Owner, Observer>::Unsubscribe(Observer* pObserver)
2825{
2826 INT_PTR nIndex = FindObserver(pObserver);
2827 if (0 <= nIndex)
2828 {
2829 if (0 == m_nNotificationDepth)
2830 {
2831 RemoveObserver(nIndex);
2832 }
2833 else
2834 {
2835 _ASSERTE(0 < m_nNotificationDepth);
2836 m_Observers[nIndex].bRemove = TRUE;
2837 }
2838 }
2839}
2840
2841template<class Owner, class Observer>
2842AFX_INLINE INT_PTR CXTPObservable<Owner, Observer>::FindObserver(Observer* pObserver) const
2843{
2844 _ASSERTE(NULL != pObserver);
2845
2846 INT_PTR nIndex = -1;
2847 for (INT_PTR i = 0; i < m_Observers.GetSize(); ++i)
2848 {
2849 if (m_Observers[i].pObserver == pObserver)
2850 {
2851 nIndex = i;
2852 break;
2853 }
2854 }
2855
2856 return nIndex;
2857}
2858
2859template<class Owner, class Observer>
2860AFX_INLINE void CXTPObservable<Owner, Observer>::OnBeforeNotify()
2861{
2862 ++m_nNotificationDepth;
2863}
2864
2865template<class Owner, class Observer>
2866AFX_INLINE void CXTPObservable<Owner, Observer>::OnAfterNotify()
2867{
2868 if (0 == --m_nNotificationDepth)
2869 {
2870 CArray<INT_PTR, INT_PTR> indices;
2871 INT_PTR i;
2872 for (i = 0; i < m_Observers.GetSize(); ++i)
2873 {
2874 if (m_Observers[i].bRemove)
2875 {
2876 indices.Add(i);
2877 }
2878 }
2879
2880 for (i = indices.GetSize(); 0 < i; --i)
2881 {
2882 RemoveObserver(indices[i - 1]);
2883 }
2884 }
2885
2886 _ASSERTE(0 <= m_nNotificationDepth);
2887}
2888
2889template<class Owner, class Observer>
2890AFX_INLINE void CXTPObservable<Owner, Observer>::RemoveObserver(INT_PTR nIndex)
2891{
2892 _ASSERTE(nIndex < m_Observers.GetSize());
2893
2894 ObserverInfo& observerInfo = m_Observers.ElementAt(nIndex);
2895 if (NULL != observerInfo.pSubcriptionList)
2896 {
2897 observerInfo.pSubcriptionList->OnUnsubscribed(this);
2898 }
2899
2900 m_Observers.RemoveAt(nIndex);
2901}
2902
2917_XTP_EXT_CLASS BOOL AFX_CDECL XTPIsDerivedFromRemote(const CRuntimeClass* pBaseClass,
2918 const CRuntimeClass* pClassThis);
2919
2933_XTP_EXT_CLASS BOOL AFX_CDECL XTPIsKindOfRemote(const CRuntimeClass* pClass,
2934 const CObject* pObject);
2935
2951_XTP_EXT_CLASS CObject* AFX_CDECL XTPDynamicDownCastRemote(CRuntimeClass* pClass, CObject* pObject);
2952
2968# define XTP_DYNAMIC_DOWNCAST_REMOTE(className, pObject) \
2969 static_cast<className*>(XTPDynamicDownCastRemote(RUNTIME_CLASS(className), pObject))
2970
2972# ifdef _XTP_ACTIVEX
2973# define XTP_DYNAMIC_DOWNCAST_REMOTE_ XTP_DYNAMIC_DOWNCAST_REMOTE
2974# else
2975# define XTP_DYNAMIC_DOWNCAST_REMOTE_ DYNAMIC_DOWNCAST
2976# endif
2987_XTP_EXT_CLASS BOOL AFX_CDECL XTPVariantEqual(const VARIANT& v1, const VARIANT& v2);
2988
2997_XTP_EXT_CLASS double XTPParseDouble(LPCSTR pStr, int* pEndPos = NULL);
2998
3002_XTP_EXT_CLASS double XTPParseDouble(LPCWSTR pStr, int* pEndPos = NULL);
3003
3026class _XTP_EXT_CLASS CXTPNonClientMetrics : public NONCLIENTMETRICS
3027{
3028public:
3033 CXTPNonClientMetrics();
3034};
3035
3042class _XTP_EXT_CLASS CXTPToolhelpApi
3043{
3044 friend class CXTPSingleton<CXTPToolhelpApi>;
3045
3046public:
3051 static CXTPToolhelpApi& AFX_CDECL Instance();
3052
3060 BOOL IsInitialized() const;
3061
3073 HANDLE CreateSnapshot(DWORD dwFlags, DWORD th32ProcessID);
3074
3088 BOOL GetFirstThread(HANDLE hSnapshot, LPTHREADENTRY32 lpte);
3089
3103 BOOL GetNextThread(HANDLE hSnapshot, LPTHREADENTRY32 lpte);
3104
3117 BOOL GetFirstModule(HANDLE hSnapshot, LPMODULEENTRY32 lpme);
3118
3132 BOOL GetNextModule(HANDLE hSnapshot, LPMODULEENTRY32 lpme);
3133
3134private:
3135 typedef HANDLE(WINAPI* PFNCREATETOOLHELP32SNAPSHOT)(DWORD dwFlags, DWORD th32ProcessID);
3136 typedef BOOL(WINAPI* PFNTHREAD32FIRSTNEXT)(HANDLE hSnapshot, LPTHREADENTRY32 lpte);
3137 typedef BOOL(WINAPI* PFNMODULE32FIRSTNEXT)(HANDLE hSnapshot, LPMODULEENTRY32 lpme);
3138
3139 CXTPToolhelpApi();
3140 ~CXTPToolhelpApi();
3141
3142 BOOL m_bInitialized;
3143 PFNCREATETOOLHELP32SNAPSHOT m_pfnCreateToolhelp32Snapshot;
3144 PFNTHREAD32FIRSTNEXT m_pfnThread32First;
3145 PFNTHREAD32FIRSTNEXT m_pfnThread32Next;
3146 PFNMODULE32FIRSTNEXT m_pfnModule32First;
3147 PFNMODULE32FIRSTNEXT m_pfnModule32Next;
3148};
3149
3150AFX_INLINE BOOL CXTPToolhelpApi::IsInitialized() const
3151{
3152 return m_bInitialized;
3153}
3154
3159class _XTP_EXT_CLASS CXTPGlobalAtom
3160{
3161public:
3169 explicit CXTPGlobalAtom(LPCTSTR lpAtomName);
3170
3176 ~CXTPGlobalAtom();
3177
3184 ATOM GetAtom() const;
3185
3193 LPCTSTR GetAtomString() const;
3194
3201 const CString& GetName() const;
3202
3203private:
3204 ATOM m_atom;
3205 CString m_strName;
3206};
3208AFX_INLINE ATOM CXTPGlobalAtom::GetAtom() const
3209{
3210 return m_atom;
3211}
3212
3213AFX_INLINE LPCTSTR CXTPGlobalAtom::GetAtomString() const
3214{
3215 return MAKEINTATOM(m_atom);
3216}
3217
3218AFX_INLINE const CString& CXTPGlobalAtom::GetName() const
3219{
3220 return m_strName;
3221}
3223# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
3225#endif // !defined(__XTPSYSTEMHELPERS_H__)
XTPDisableAdvancedWarnings.h
XTPDisableNoisyWarnings.h
XTPEnableAdvancedWarnings.h
XTPEnableNoisyWarnings.h
XTPVariantEqual
_XTP_EXT_CLASS BOOL AFX_CDECL XTPVariantEqual(const VARIANT &v1, const VARIANT &v2)
Perform a shallow comparison of two variants.
XTPWindowClass
XTPWindowClass
Defines known global window classes IDs.
Definition XTPSystemHelpers.h:1866
xtpWindowClassRichEdit
@ xtpWindowClassRichEdit
RichEdit window class family.
Definition XTPSystemHelpers.h:1867
XTPCreateReadOnlyResourceStream
_XTP_EXT_CLASS HRESULT AFX_CDECL XTPCreateReadOnlyResourceStream(HMODULE hModule, LPCTSTR lpResource, LPCTSTR lpResourceType, BOOL bClone, IStream **ppStream)
Creates a read-only stream on a resource.
XTPCreateReadOnlyMemoryStream
_XTP_EXT_CLASS HRESULT AFX_CDECL XTPCreateReadOnlyMemoryStream(const void *pData, UINT cbData, BOOL bClone, IStream **ppStream)
Creates a read-only stream on a block of memory.
XTPLoadText
_XTP_EXT_CLASS BOOL AFX_CDECL XTPLoadText(const void *pRawData, UINT cbRawData, LPTSTR lpText, UINT *pchText)
Attempts to load text from a binary buffer.
XTPUriType
XTPUriType
URI type identifier.
Definition XTPSystemHelpers.h:1338
xtpUriFile
@ xtpUriFile
Local file URI.
Definition XTPSystemHelpers.h:1339
xtpUriRes
@ xtpUriRes
Resource in a local file URI.
Definition XTPSystemHelpers.h:1340
XTPIsDerivedFromRemote
_XTP_EXT_CLASS BOOL AFX_CDECL XTPIsDerivedFromRemote(const CRuntimeClass *pBaseClass, const CRuntimeClass *pClassThis)
Call this function to determine if the class specified by pClassThis is derived from the class specif...
XTPCreateReadOnlyStreamOnUri
_XTP_EXT_CLASS HRESULT AFX_CDECL XTPCreateReadOnlyStreamOnUri(const XTP_URI *pUri, IStream **ppStream)
Creates a read-only stream on object identified by the specified URI.
XTPTlsGetValue
_XTP_EXT_CLASS PVOID AFX_CDECL XTPTlsGetValue(DWORD_PTR dwSlot)
Obtains an assigned XTP TLS slot value.
XTPTlsAllocate
_XTP_EXT_CLASS DWORD_PTR AFX_CDECL XTPTlsAllocate(PVOID pValue=NULL)
Allocates a new slot in XTP TLS pool and assigns an initial value if provided.
XTPParseUri
_XTP_EXT_CLASS HRESULT AFX_CDECL XTPParseUri(LPCTSTR lpszUri, XTP_URI *pUri, const XTP_URI_DEFAULTS *pDefaults=NULL)
Parses URI, Sample valid file URIs:
XTPSoundManagerState
XTPSoundManagerState
Enumeration used to play system sound.
Definition XTPSystemHelpers.h:1209
xtpSoundMenuPopup
@ xtpSoundMenuPopup
Menu pop-up system sound
Definition XTPSystemHelpers.h:1212
xtpSoundNone
@ xtpSoundNone
No Sound (default)
Definition XTPSystemHelpers.h:1210
xtpSoundMenuCommand
@ xtpSoundMenuCommand
Menu command system sound.
Definition XTPSystemHelpers.h:1211
XTP_INVALID_TLS_SLOT
#define XTP_INVALID_TLS_SLOT
Defines an invalid TLS slot value specific to XTP TLS pool.
Definition XTPSystemHelpers.h:1597
XTPDynamicDownCastRemote
_XTP_EXT_CLASS CObject *AFX_CDECL XTPDynamicDownCastRemote(CRuntimeClass *pClass, CObject *pObject)
Provides a handy way to cast a pointer to a pointer to a class object while checking to see if the ca...
XTPSoundManager
_XTP_EXT_CLASS CXTPSoundManager *AFX_CDECL XTPSoundManager()
Call this function to access CXTPSoundManager members.
XTPParseDouble
_XTP_EXT_CLASS double XTPParseDouble(LPCSTR pStr, int *pEndPos=NULL)
Attempts to parse a floating point value from the beginning of the provided string.
XTPIsKindOfRemote
_XTP_EXT_CLASS BOOL AFX_CDECL XTPIsKindOfRemote(const CRuntimeClass *pClass, const CObject *pObject)
Tests this object's relationship to a given class.
XTPComInit
XTPComInit
Defines a set of COM/OLE initialization methods.
Definition XTPSystemHelpers.h:1944
xtpComInitModuleAfxOle
@ xtpComInitModuleAfxOle
Causes default AFX OLE initialization to be used during MFC extension DLL initialization.
Definition XTPSystemHelpers.h:2001
xtpComInitSTA
@ xtpComInitSTA
Causes extended COM initialization to be used.
Definition XTPSystemHelpers.h:1960
xtpComInitUserDefined
@ xtpComInitUserDefined
No COM/OLE initialization will be performed.
Definition XTPSystemHelpers.h:2008
xtpComInitAppDefault
@ xtpComInitAppDefault
If passed to CXTPWinApp constructor or to XTPInitialize then uses xtpComInitAfxOle,...
Definition XTPSystemHelpers.h:1954
xtpComInitSpeedOverMemory
@ xtpComInitSpeedOverMemory
Causes extended COM initialization to be used.
Definition XTPSystemHelpers.h:1979
xtpComInitAfxOle
@ xtpComInitAfxOle
Causes default AFX OLE initialization to be used for the main application thread, all other threads w...
Definition XTPSystemHelpers.h:1992
xtpComInitOle
@ xtpComInitOle
Causes OLE initialization to be used.
Definition XTPSystemHelpers.h:1984
xtpComInitMTA
@ xtpComInitMTA
Causes extended COM initialization to be used.
Definition XTPSystemHelpers.h:1966
xtpComInitInvalid
@ xtpComInitInvalid
Used internally.
Definition XTPSystemHelpers.h:1948
xtpComInitDisableOle1DDE
@ xtpComInitDisableOle1DDE
Causes extended COM initialization to be used.
Definition XTPSystemHelpers.h:1972
XTPReadStreamData
_XTP_EXT_CLASS HRESULT AFX_CDECL XTPReadStreamData(IStream *pStream, LPVOID &pData, SIZE_T &cbData, ULONG cbSizeNeeded=ULONG_MAX, STREAM_SEEK nSeek=STREAM_SEEK_CUR, LONG nOffset=0)
Reads data from the specified stream starting at the specified position.
XTPWindowClassVersionSelectionVerb
XTPWindowClassVersionSelectionVerb
Defines rules of how window class version has to be selected.
Definition XTPSystemHelpers.h:1875
xtpWindowClassVersionExact
@ xtpWindowClassVersionExact
The window class version is matched exactly.
Definition XTPSystemHelpers.h:1876
xtpWindowClassVersionHighest
@ xtpWindowClassVersionHighest
The largest available is selected.
Definition XTPSystemHelpers.h:1879
xtpWindowClassVersionAtLeast
@ xtpWindowClassVersionAtLeast
At least the specified window class version should be available.
Definition XTPSystemHelpers.h:1877
XTPReleaseReadStreamData
_XTP_EXT_CLASS void AFX_CDECL XTPReleaseReadStreamData(LPVOID pData)
Releases a memory buffer allocated by XTPReadStreamData.
XTPMultiMonitor
_XTP_EXT_CLASS CXTPMultiMonitor *AFX_CDECL XTPMultiMonitor()
Call this function to access CXTPMultiMonitor members.
XTPTlsSetValue
_XTP_EXT_CLASS BOOL AFX_CDECL XTPTlsSetValue(DWORD_PTR dwSlot, PVOID pValue)
Sets a new value to the previously allocated XTP TLS slot.
XTPTlsFree
_XTP_EXT_CLASS BOOL AFX_CDECL XTPTlsFree(DWORD_PTR dwSlot)
Releases a previously assigned XTP TLS slot.
XTPRichEditWindowClassVersion
XTPRichEditWindowClassVersion
Defines supported RichEdit versions.
Definition XTPSystemHelpers.h:1887
xtpRichEditWindowClassVersion70
@ xtpRichEditWindowClassVersion70
Specifies RichEdit control version 70.
Definition XTPSystemHelpers.h:1896
xtpRichEditWindowClassVersion60
@ xtpRichEditWindowClassVersion60
Specifies RichEdit control version 60.
Definition XTPSystemHelpers.h:1895
xtpRichEditWindowClassVersion20
@ xtpRichEditWindowClassVersion20
Specifies RichEdit control version 20.
Definition XTPSystemHelpers.h:1889
xtpRichEditWindowClassDefault
@ xtpRichEditWindowClassDefault
Specifies RichEdit control version 20.
Definition XTPSystemHelpers.h:1898
xtpRichEditWindowClassVersion40
@ xtpRichEditWindowClassVersion40
Specifies RichEdit control version 40.
Definition XTPSystemHelpers.h:1892
xtpRichEditWindowClassVersion30
@ xtpRichEditWindowClassVersion30
Specifies RichEdit control version 30.
Definition XTPSystemHelpers.h:1890
xtpRichEditWindowClassVersion50
@ xtpRichEditWindowClassVersion50
Specifies RichEdit control version 50.
Definition XTPSystemHelpers.h:1894
xtpRichEditWindowClassVersion41
@ xtpRichEditWindowClassVersion41
Specifies RichEdit control version 41.
Definition XTPSystemHelpers.h:1893
xtpRichEditWindowClassVersion10
@ xtpRichEditWindowClassVersion10
Specifies RichEdit control version 10.
Definition XTPSystemHelpers.h:1888
xtpRichEditWindowClassVersion31
@ xtpRichEditWindowClassVersion31
Specifies RichEdit control version 31.
Definition XTPSystemHelpers.h:1891
XTPCreateReadOnlyFileStream
_XTP_EXT_CLASS HRESULT AFX_CDECL XTPCreateReadOnlyFileStream(LPCTSTR lpPath, IStream **ppStream)
Creates a read-only stream on the file specified.
XTPLoadUnicodeText
_XTP_EXT_CLASS BOOL AFX_CDECL XTPLoadUnicodeText(const void *pRawData, UINT cbRawData, LPWSTR lpUnicodeText, UINT *pchUnicodeText)
Attempts to load a Unicode text from a binary buffer.
XTPLoadFileText
_XTP_EXT_CLASS BOOL AFX_CDECL XTPLoadFileText(LPCTSTR lpPath, CString &strText)
Attempts to load text from a specified file.
XTPLoadWindowClass
_XTP_EXT_CLASS BOOL AFX_CDECL XTPLoadWindowClass(XTPWindowClass nClass, XTPWindowClassVersionSelectionVerb nVerb, int *pnVersion, LPWNDCLASS pWndClass=NULL)
Loads and verifies a window class module of a specified version according to version selection rule.
XTPCreateFileStream
_XTP_EXT_CLASS HRESULT AFX_CDECL XTPCreateFileStream(LPCTSTR lpPath, DWORD grfMode, IStream **ppStream)
Creates a stream on the file specified.
XTPSystemVersion
_XTP_EXT_CLASS CXTPSystemVersion *AFXAPI XTPSystemVersion()
The XTPSystemVersion function is used for access to the CXTPSystemVersion class.
CXTPComInitializer
Initializes COM and increments and holds COM initialization reference counter for the thread where co...
Definition XTPSystemHelpers.h:2021
CXTPComInitializer::CXTPComInitializer
CXTPComInitializer(int xtpComInit=xtpComInitAppDefault)
Initializes COM for the calling thread.
CXTPComInitializer::GetInitFlags
int GetInitFlags() const
Obtains COM initialization flags.
CXTPComInitializer::GetInitializationStatus
HRESULT GetInitializationStatus() const
Obtains COM initialization status code.
CXTPComInitializer::~CXTPComInitializer
~CXTPComInitializer()
Decrements COM reference counter and uninitializes COM for the calling thread if it holds the last CO...
CXTPCriticalSection
Critical Section Wrapper.
Definition XTPSystemHelpers.h:835
CXTPCriticalSection::~CXTPCriticalSection
~CXTPCriticalSection()
Destroys a CXTPCriticalSection object, handles cleanup and deallocation.
CXTPCriticalSection::CXTPCriticalSection
CXTPCriticalSection()
Constructs a CXTPCriticalSection object.
CXTPCriticalSection::EnterCritical
void EnterCritical()
The EnterCriticalSection function waits for ownership of the specified critical section object.
CXTPCriticalSection::LeaveCritical
void LeaveCritical()
The LeaveCriticalSection function releases ownership of the specified critical section object.
CXTPExcludedMemberPadding
The CXTPExcludedMemberPadding type is used for declaring padding members for the members that were ex...
Definition XTPSystemHelpers.h:1855
CXTPGlobalAtom
A helper class for handling a global atom primitive.
Definition XTPSystemHelpers.h:3160
CXTPGlobalAtom::GetAtom
ATOM GetAtom() const
Obtains atom value.
CXTPGlobalAtom::~CXTPGlobalAtom
~CXTPGlobalAtom()
Handles global atom destruction.
CXTPGlobalAtom::GetAtomString
LPCTSTR GetAtomString() const
Obtains atom value as a string pointer.
CXTPGlobalAtom::GetName
const CString & GetName() const
Obtains atom name.
CXTPGlobalAtom::CXTPGlobalAtom
CXTPGlobalAtom(LPCTSTR lpAtomName)
Creates a global atom object using the provided name.
CXTPLockGuard
Critical Sections Lock/Unlock helper.
Definition XTPSystemHelpers.h:882
CXTPLockGuard::UnLockThread
void UnLockThread()
This method call LeaveCritical of key object.
CXTPLockGuard::CXTPLockGuard
CXTPLockGuard(CRITICAL_SECTION &key)
Constructs a CXTPLockGuard object.
CXTPLockGuard::~CXTPLockGuard
~CXTPLockGuard()
Destroys a CXTPCriticalSection object, handles cleanup and deallocation.
CXTPLockGuard::LockThread
void LockThread()
This method call EnterCritical of key object.
CXTPModuleHandle
CXTPModuleHandle class is helper for LoadLibray/GetModuleHandle methods.
Definition XTPSystemHelpers.h:80
CXTPModuleHandle::XTPModuleState
XTPModuleState
Module state enum.
Definition XTPSystemHelpers.h:87
CXTPModuleHandle::xtpModNone
@ xtpModNone
Indicates no module found.
Definition XTPSystemHelpers.h:88
CXTPModuleHandle::xtpModMapped
@ xtpModMapped
Indicates the module handle was set using GetModuleHandle.
Definition XTPSystemHelpers.h:89
CXTPModuleHandle::GetHandle
HMODULE GetHandle() const
This method returns a handle to the module indicating success.
CXTPModuleHandle::FreeLibrary
BOOL FreeLibrary()
The FreeLibrary function decrements the reference count of the loaded dynamic-link library (DLL).
CXTPModuleHandle::CXTPModuleHandle
CXTPModuleHandle(LPCTSTR lpszModuleName)
Constructs a CXTPModuleHandle object.
CXTPModuleHandle::GetVersion
DWORD GetVersion()
Use this member function to return the version number of the module attached to this CLoadLibrary obj...
CXTPModuleHandle::GetModuleState
XTPModuleState GetModuleState() const
CXTPModuleHandle::GetProcAddress
BOOL GetProcAddress(FARPROC *ppFnPtr, LPCSTR lpProcName, DWORD dwMinVer=NULL)
The GetProcAddress function retrieves the address of the specified exported dynamic-link library (DLL...
CXTPModuleHandle::CXTPModuleHandle
CXTPModuleHandle()
Constructs a CXTPModuleHandle object.
CXTPModuleHandle::LoadLibrary
BOOL LoadLibrary(LPCTSTR lpszModuleName)
This member function is called to load the library specified by 'lpszModule'.
CXTPModuleHandle::Init
BOOL Init(LPCTSTR lpszModuleName)
Call this method to LoadLibrary.
CXTPModuleHandle::GetModuleHandle
BOOL GetModuleHandle(LPCTSTR lpszModuleName)
The GetModuleHandle function retrieves a module handle for the specified module if the file has been ...
CXTPModuleHandle::~CXTPModuleHandle
virtual ~CXTPModuleHandle()
Destroys a CXTPModuleHandle object, handles cleanup and deallocation.
CXTPModuleHandle::GetName
CString GetName() const
CXTPMultiMonitor
MultiMonitor API wrapper class.
Definition XTPSystemHelpers.h:620
CXTPMultiMonitor::GetWorkArea
CRect GetWorkArea(const POINT &point)
This function retrieves work area for the display monitor that the mouse cursor is currently position...
CXTPMultiMonitor::GetDisplaySettings
BOOL GetDisplaySettings(HWND hWnd, DEVMODE *lpDevMode)
Obtains display settings for a monitor associated with the window handle provided.
CXTPMultiMonitor::GetScreenArea
CRect GetScreenArea(const POINT &point)
This function retrieves work area for the display monitor that the mouse cursor is currently position...
CXTPMultiMonitor::GetDisplaySettings
BOOL GetDisplaySettings(const CWnd *pWnd, DEVMODE *lpDevMode)
Obtains display settings for a monitor associated with the window handle provided.
CXTPMultiMonitor::GetWorkArea
CRect GetWorkArea(LPCRECT rect)
This function retrieves work area for the display monitor that the mouse cursor is currently position...
CXTPMultiMonitor::GetScreenArea
CRect GetScreenArea(const CWnd *pWnd)
This function retrieves work area for the display monitor that the mouse cursor is currently position...
CXTPMultiMonitor::GetWorkArea
CRect GetWorkArea()
This function retrieves work area for the display monitor that the mouse cursor is currently position...
CXTPMultiMonitor::XTPMultiMonitor
friend _XTP_EXT_CLASS CXTPMultiMonitor *AFX_CDECL XTPMultiMonitor()
Call this function to access CXTPMultiMonitor members.
CXTPMultiMonitor::GetScreenArea
CRect GetScreenArea(LPCRECT rect)
This function retrieves work area for the display monitor that the mouse cursor is currently position...
CXTPMultiMonitor::GetWorkArea
CRect GetWorkArea(HWND hWnd)
This function retrieves work area for the display monitor that the mouse cursor is currently position...
CXTPMultiMonitor::GetScreenArea
CRect GetScreenArea(HWND hWnd)
This function retrieves work area for the display monitor that the mouse cursor is currently position...
CXTPMultiMonitor::GetWorkArea
CRect GetWorkArea(const CWnd *pWnd)
This function retrieves work area for the display monitor that the mouse cursor is currently position...
CXTPNonClientMetrics
CXTPNonClientMetrics is a self-initializing NONCLIENTMETRICS derived class.
Definition XTPSystemHelpers.h:3027
CXTPNonClientMetrics::CXTPNonClientMetrics
CXTPNonClientMetrics()
Constructs a CXTPNonClientMetrics object.
CXTPObservable
Provides a basic implementation of the Observable design pattern.
Definition XTPSystemHelpers.h:2138
CXTPObservable::NotifyReversed
void NotifyReversed(void(Observer::*method)(Owner *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by ...
Definition XTPSystemHelpers.h:2339
CXTPObservable::NotifyDynamic
void NotifyDynamic(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observ...
Definition XTPSystemHelpers.h:2499
CXTPObservable::Subscribe
void Subscribe(Observer *pObserver, CXTPSubscriptionList< Owner, Observer > *pSubcriptionList=NULL)
Subscribes a unique observer for events.
Definition XTPSystemHelpers.h:2806
CXTPObservable::Notify
void Notify(void(Observer::*method)(Owner *))
Notifies all subscribed observers in the order of subscription about an event determined by an observ...
Definition XTPSystemHelpers.h:2192
CXTPObservable::Notify
void Notify(void(Observer::*method)(Owner *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observ...
Definition XTPSystemHelpers.h:2311
CXTPObservable::NotifyReversed
void NotifyReversed(void(Observer::*method)(Owner *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by ...
Definition XTPSystemHelpers.h:2609
CXTPObservable::CXTPObservable
CXTPObservable()
Constructs an observable object.
Definition XTPSystemHelpers.h:2794
CXTPObservable::NotifyDynamic
void NotifyDynamic(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observ...
Definition XTPSystemHelpers.h:2641
CXTPObservable::~CXTPObservable
~CXTPObservable()
Handles observable object destruction.
Definition XTPSystemHelpers.h:2800
CXTPObservable::Notify
void Notify(void(Observer::*method)(Owner *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the order of subscription about an event determined by an observ...
Definition XTPSystemHelpers.h:2439
CXTPObservable::NotifyDynamicReversed
void NotifyDynamicReversed(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the reversed order of subscription about an event determined by ...
Definition XTPSystemHelpers.h:2681
CXTPObservable::NotifyDynamic
void NotifyDynamic(void(T::*method)(O *))
Notifies all subscribed observers in the order of subscription about an event determined by an observ...
Definition XTPSystemHelpers.h:2243
CXTPObservable::Unsubscribe
void Unsubscribe(Observer *pObserver)
Unsubscribes an observer from events.
Definition XTPSystemHelpers.h:2824
CXTPObservable::NotifyDynamicReversed
void NotifyDynamicReversed(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by ...
Definition XTPSystemHelpers.h:2537
CXTPObservable::Notify
void Notify(void(Observer::*method)(Owner *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3)
Notifies all subscribed observers in the order of subscription about an event determined by an observ...
Definition XTPSystemHelpers.h:2577
CXTPObservable::NotifyDynamicReversed
void NotifyDynamicReversed(void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the reversed order of subscription about an event determined by ...
Definition XTPSystemHelpers.h:2402
CXTPObservable::NotifyDynamicReversed
void NotifyDynamicReversed(void(T::*method)(O *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by ...
Definition XTPSystemHelpers.h:2276
CXTPObservable::NotifyDynamic
void NotifyDynamic(void(T::*method)(O *, A1), A1 arg1)
Notifies all subscribed observers in the order of subscription about an event determined by an observ...
Definition XTPSystemHelpers.h:2367
CXTPObservable::NotifyReversed
void NotifyReversed(void(Observer::*method)(Owner *))
Notifies all subscribed observers in the reversed order of subscription about an event determined by ...
Definition XTPSystemHelpers.h:2217
CXTPObservable::NotifyReversed
void NotifyReversed(void(Observer::*method)(Owner *, A1, A2), A1 arg1, A2 arg2)
Notifies all subscribed observers in the reversed order of subscription about an event determined by ...
Definition XTPSystemHelpers.h:2469
CXTPSingletonDependencies
Describes the list of up to 10 optional singleton dependencies.
Definition XTPSingleton.h:179
CXTPSingleton
Implements Singleton design pattern.
Definition XTPSingleton.h:215
CXTPSoundManager
CXTPSoundManager is a standalone class.
Definition XTPSystemHelpers.h:1222
CXTPSoundManager::XTPSoundManager
friend _XTP_EXT_CLASS CXTPSoundManager *AFX_CDECL XTPSoundManager()
Call this function to access CXTPSoundManager members.
CXTPSoundManager::PlaySystemSound
void PlaySystemSound(XTPSoundManagerState state)
Call this method to play system sound.
CXTPSoundManager::m_bSoundAvailable
BOOL m_bSoundAvailable
FALSE to disable sound.
Definition XTPSystemHelpers.h:1279
CXTPSoundManager::StopThread
void StopThread()
This method is called to stop all sounds and terminate sound thread.
CXTPSoundManager::~CXTPSoundManager
~CXTPSoundManager()
Destroys a CXTPSoundManager object, handles cleanup and deallocation.
CXTPSoundManager::EnableSystemSounds
void EnableSystemSounds(BOOL bEnable)
Call this method to disable all system sounds for application.
CXTPSubscriptionList
Holds a list of observable objects to which an oberser is subscribed.
Definition XTPSystemHelpers.h:2090
CXTPSubscriptionList::GetSubscriptionCount
UINT GetSubscriptionCount() const
Obtains the number of registered subscriptions for the observer.
Definition XTPSystemHelpers.h:2744
CXTPSubscriptionList::~CXTPSubscriptionList
~CXTPSubscriptionList()
Handles subscription list destruction.
Definition XTPSystemHelpers.h:2724
CXTPSubscriptionList::CXTPSubscriptionList
CXTPSubscriptionList(Observer &observer)
Constructs a subscription list for the provided observer.
Definition XTPSystemHelpers.h:2717
CXTPSystemVersion
CXTPSystemVersion is used to get the current Windows OS version.
Definition XTPSystemHelpers.h:279
CXTPSystemVersion::IsWin8OrGreater
bool IsWin8OrGreater() const
Call this member function to check whether or not the operating system is of the Windows NT family,...
CXTPSystemVersion::VerifyVersion
LRESULT VerifyVersion(BYTE dwConditionMask, DWORD dwMajorVersion, DWORD dwMinorVersion, DWORD dwPlatformId) const
Compares a set of operating system version requirements to the corresponding values for the currently...
CXTPSystemVersion::IsWin31OrGreater
bool IsWin31OrGreater() const
Call this member function to check whether or not the operating system is greater than or equal to Wi...
CXTPSystemVersion::VerifyWinVer
bool VerifyWinVer(BYTE dwConditionMask, DWORD dwMajorVersion, DWORD dwMinorVersion, DWORD dwPlatformId) const
Compares a set of operating system version requirements to the corresponding values for the currently...
CXTPSystemVersion::IsWin7OrGreater
bool IsWin7OrGreater() const
Call this member function to check whether or not the operating system is of the Windows NT family,...
CXTPSystemVersion::GetComCtlVersion
DWORD GetComCtlVersion() const
Use this member function to return the version number of the comctl32.dll.
CXTPSystemVersion::GetOSVersionInfo
const OSVERSIONINFOEXW * GetOSVersionInfo() const
Retrieves OS version information.
CXTPSystemVersion::IsWin81OrGreater
bool IsWin81OrGreater() const
Call this member function to check whether or not the operating system is of the Windows NT family,...
CXTPSystemVersion::IsWinME
bool IsWinME() const
Call this member function to check whether or not the operating system is Windows ME.
CXTPSystemVersion::IsWin31
bool IsWin31() const
Call this member function to check whether or not the operating system is Windows 3....
CXTPSystemVersion::IsWin11OrGreater
bool IsWin11OrGreater() const
Call this member function to check whether or not the operating system is of the Windows NT family,...
CXTPSystemVersion::IsWin95
bool IsWin95() const
Call this member function to check whether or not the operating system is Windows 95.
CXTPSystemVersion::IsWin98OrGreater
bool IsWin98OrGreater() const
Call this member function to check whether or not the operating system is of the Windows 9x family,...
CXTPSystemVersion::GetMaxCharSize
int GetMaxCharSize() const
Obtains the maximum length, in bytes, of a character in an OEM code page.
CXTPSystemVersion::IsWinVistaOrGreater
bool IsWinVistaOrGreater() const
Call this member function to check whether or not the operating system is of the Windows NT family,...
CXTPSystemVersion::IsWinXP
bool IsWinXP() const
Call this member function to check whether or not the operating system is Windows XP.
CXTPSystemVersion::IsWin2KOrGreater
bool IsWin2KOrGreater() const
Call this member function to check whether or not the operating system is of the Windows NT family,...
CXTPSystemVersion::IsWinNT4OrGreater
bool IsWinNT4OrGreater() const
Call this member function to check whether or not the operating system is of the Windows NT family,...
CXTPSystemVersion::IsWinXPOrGreater
bool IsWinXPOrGreater() const
Call this member function to check whether or not the operating system is of the Windows NT family,...
CXTPSystemVersion::IsWin95OrGreater
bool IsWin95OrGreater() const
Call this member function to check whether or not the operating system is of the Windows 9x family,...
CXTPSystemVersion::IsWin2K
bool IsWin2K() const
Call this member function to check whether or not the operating system is Windows 2000.
CXTPSystemVersion::IsLayoutRTLSupported
BOOL IsLayoutRTLSupported() const
Determines if right-to-left (RTL) formatting is supported by current OS.
CXTPSystemVersion::GetVersion
LRESULT GetVersion(BYTE dwConditionMask, DWORD dwMajorVersion, DWORD dwMinorVersion, DWORD dwPlatformId) const
Compares a set of operating system version requirements to the corresponding values for the currently...
CXTPSystemVersion::IsWin10OrGreater
bool IsWin10OrGreater() const
Call this member function to check whether or not the operating system is of the Windows NT family,...
CXTPSystemVersion::IsWin98
bool IsWin98() const
Call this member function to check whether or not the operating system is Windows 98.
CXTPSystemVersion::IsWin9x
bool IsWin9x() const
Call this member function to check whether or not the operating system is of the Windows 9x family.
CXTPSystemVersion::IsWinNT4
bool IsWinNT4() const
Call this member function to check whether or not the operating system is Windows NT 4.
CXTPSystemVersion::IsWinMEOrGreater
bool IsWinMEOrGreater() const
Call this member function to check whether or not the operating system is of the Windows 9x family,...
CXTPSystemVersion::IsClearTypeTextQualitySupported
BOOL IsClearTypeTextQualitySupported() const
Determines if ClearType text is supported by current OS.
CXTPSystemVersion::XTPSystemVersion
friend _XTP_EXT_CLASS CXTPSystemVersion *AFXAPI XTPSystemVersion()
The XTPSystemVersion function is used for access to the CXTPSystemVersion class.
CXTPThreadLocal
Implements thread local variable adapter.
Definition XTPSystemHelpers.h:1676
CXTPThreadLocal::operator*
const T & operator*() const
Gives access to a variable accessible only to the caller's thread.
CXTPThreadLocal::Reset
void Reset(BOOL bCurrentThread=FALSE)
Resets and destroys allocated object either for the current thread or all threads that use the object...
CXTPThreadLocal::operator*
T & operator*()
Gives access to a variable accessible only to the caller's thread.
CXTPThreadLocal::CreateProc
T *(AFX_CDECL *) CreateProc()
A custom object instance allocation and initialization callback type.
Definition XTPSystemHelpers.h:1681
CXTPThreadLocal::IsValid
BOOL IsValid() const
Checks if an adapter is valid and can create thread local variables.
CXTPThreadLocal::~CXTPThreadLocal
~CXTPThreadLocal()
Deallocates all thread local variables.
CXTPThreadLocal::CXTPThreadLocal
CXTPThreadLocal(CreateProc pfnCreate=DefaultProcs::Create, DestroyProc pfnDestroy=DefaultProcs::Destroy)
Construct adapter only, no thread local variable is constructed.
CXTPThreadLocal::DestroyProc
void(AFX_CDECL *) DestroyProc(T *)
A custom object instance destruction and deallocation callback type.
Definition XTPSystemHelpers.h:1686
CXTPToolhelpApi
A wrapper around the Toolhelp32 API.
Definition XTPSystemHelpers.h:3043
CXTPToolhelpApi::GetNextThread
BOOL GetNextThread(HANDLE hSnapshot, LPTHREADENTRY32 lpte)
Retrieves information about the next thread of any process encountered in the system memory snapshot.
CXTPToolhelpApi::GetFirstModule
BOOL GetFirstModule(HANDLE hSnapshot, LPMODULEENTRY32 lpme)
Retrieves information about the first module associated with a process.
CXTPToolhelpApi::GetFirstThread
BOOL GetFirstThread(HANDLE hSnapshot, LPTHREADENTRY32 lpte)
Retrieves information about the first thread of any process encountered in a system snapshot.
CXTPToolhelpApi::CreateSnapshot
HANDLE CreateSnapshot(DWORD dwFlags, DWORD th32ProcessID)
Takes a snapshot of the specified processes, as well as the heaps, modules, and threads used by these...
CXTPToolhelpApi::IsInitialized
BOOL IsInitialized() const
The method should be used for checking if the Toolhelp32 API is supported and can be used.
Definition XTPSystemHelpers.h:3150
CXTPToolhelpApi::Instance
static CXTPToolhelpApi &AFX_CDECL Instance()
CXTPToolhelpApi::GetNextModule
BOOL GetNextModule(HANDLE hSnapshot, LPMODULEENTRY32 lpme)
Retrieves information about the next module associated with a process or thread.
CXTPZipMemFile
Zipped memory file.
Definition XTPSystemHelpers.h:1306
XTP_URI_DEFAULTS
Default URI values.
Definition XTPSystemHelpers.h:1372
XTP_URI_DEFAULTS::lpType
LPCTSTR lpType
Default resource type.
Definition XTPSystemHelpers.h:1375
XTP_URI
Parse URI information.
Definition XTPSystemHelpers.h:1348
XTP_URI::reserved
struct XTP_URI::@29::@31::@32 reserved
Reserved for internal needs.
XTP_URI::res
struct XTP_URI::@29::@31 res
Valid only for xtpUriRes.
XTP_URI::lpType
LPCTSTR lpType
Resource type.
Definition XTPSystemHelpers.h:1356
XTP_URI::type
XTPUriType type
URI type.
Definition XTPSystemHelpers.h:1349
XTP_URI::file
TCHAR file[MAX_PATH+1]
Valid only for xtpUriFile.
Definition XTPSystemHelpers.h:1351
XTP_URI::lpName
LPCTSTR lpName
Resource name.
Definition XTPSystemHelpers.h:1357
XTP_URI::szFilePath
TCHAR szFilePath[MAX_PATH+1]
Local file full path.
Definition XTPSystemHelpers.h:1355


Toolkit Pro: XTPDockingPanePanelTheme2012.h Source File

  • Source
  • DockingPane
  • TabThemes
XTPDockingPanePanelTheme2012.h
Go to the documentation of this file.
1
23#if !defined(__XTPDOCKINGPANEPANELTHEME2012_H__)
24# define __XTPDOCKINGPANEPANELTHEME2012_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPDockingPanePanelTheme2012 : public CXTPTabThemeFlat
39{
40public:
45 CXTPDockingPanePanelTheme2012();
46
52 virtual void RefreshMetrics();
53
70 virtual void DrawSingleButton(CDC* pDC, CXTPTabManagerItem* pItem);
71
72protected:
73 int m_nGripperWidth;
74};
75
76# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
78#endif // !defined(__XTPDOCKINGPANEPANELTHEME2012_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPDockingPanePanelTheme2012
Helper class used to initialize default colors for a theme from an .INI resource and handle drawing r...
Definition XTPDockingPanePanelTheme2012.h:39
CXTPDockingPanePanelTheme2012::CXTPDockingPanePanelTheme2012
CXTPDockingPanePanelTheme2012()
Default class constructor.
CXTPDockingPanePanelTheme2012::DrawSingleButton
virtual void DrawSingleButton(CDC *pDC, CXTPTabManagerItem *pItem)
This method is called to draw a single tab button in the tab client header area.
CXTPDockingPanePanelTheme2012::RefreshMetrics
virtual void RefreshMetrics()
This member function is used to initialize default colors for a theme from an .INI resource.
CXTPDockingPanePanelTheme2012::m_nGripperWidth
int m_nGripperWidth
Size of the docking pane gripper.
Definition XTPDockingPanePanelTheme2012.h:73
CXTPTabManagerItem
CXTPTabManagerItem is the base class for the tabs that appear in the command bars tab workspace,...
Definition XTPTabManagerItem.h:44
CXTPTabThemeFlat
CXTPTabThemeFlat implements a "Flat" tab appearance.
Definition XTPTabThemeFlat.h:49


Toolkit Pro: Member List

CXTPScrollable< Base > Member List

This is the complete list of members for CXTPScrollable< Base >, including all inherited members.

Create(LPCTSTR lpszClassName, LPCTSTR lpszWindowName, DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID, CCreateContext *pContext=NULL) | CXTPScrollable< Base > | virtual
CreateEx(DWORD dwExStyle, LPCTSTR lpszClassName, LPCTSTR lpszWindowName, DWORD dwStyle, int x, int y, int nWidth, int nHeight, HWND hWndParent, HMENU nIDorHMenu, LPVOID lpParam=NULL) | CXTPScrollable< Base > | virtual
CreateEx(DWORD dwExStyle, LPCTSTR lpszClassName, LPCTSTR lpszWindowName, DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID, LPVOID lpParam=NULL) | CXTPScrollable< Base > | virtual
CXTPScrollable() | CXTPScrollable< Base > |
EnableDefaultBorderDrawing(BOOL bEnable=TRUE) | CXTPScrollable< Base > |
InitScrollBars() | CXTPScrollable< Base > |
SetScrollBarTheme(XTPScrollBarTheme nTheme) | CXTPScrollable< Base > |
~IXTPScrollable() | IXTPScrollable | inlinevirtual


Toolkit Pro: XTPTabColorSetOffice2003.h Source File

  • Source
  • TabManager
  • ColorSets
XTPTabColorSetOffice2003.h
Go to the documentation of this file.
1
23#if !defined(__XTPTABCOLORSETOFFICE2003_H__)
24# define __XTPTABCOLORSETOFFICE2003_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
43class _XTP_EXT_CLASS CXTPTabColorSetOffice2003 : public CXTPTabColorSetDefault
44{
45public:
54 virtual void RefreshMetrics();
55
77 virtual COLORREF FillPropertyButton(CDC* pDC, CRect rcItem, CXTPTabManagerItem* pItem);
78
93 virtual void FillNavigateButton(CDC* pDC, CXTPTabManagerNavigateButton* pButton, CRect& rc);
94
108 void Rectangle(CDC* pDC, CRect rc, int nPen, int nBrush);
109
110protected:
111 CXTPPaintManagerColor m_clrNavigateButtonBorder;
113 BOOL m_bLunaTheme;
115};
116
117# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
119#endif // !defined(__XTPTABCOLORSETOFFICE2003_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPPaintManagerColor
The CXTPPaintManagerColor class is used to manage COLORREF values for determining default and applica...
Definition XTPColorManager.h:117
CXTPTabColorSetDefault
CXTPTabColorSetDefault implements a default tab color set.
Definition XTPTabColorSetDefault.h:44
CXTPTabColorSetOffice2003
CXTPTabColorSetOffice2003 implements an Office 2003 tab color set.
Definition XTPTabColorSetOffice2003.h:44
CXTPTabColorSetOffice2003::m_bLunaTheme
BOOL m_bLunaTheme
TRUE if the current system theme is xtpSystemThemeSilver, xtpSystemThemeOlive or xtpSystemThemeOlive,...
Definition XTPTabColorSetOffice2003.h:113
CXTPTabColorSetOffice2003::m_clrNavigateButtonBorder
CXTPPaintManagerColor m_clrNavigateButtonBorder
Border color of tab navigation buttons on mouse over.
Definition XTPTabColorSetOffice2003.h:111
CXTPTabColorSetOffice2003::Rectangle
void Rectangle(CDC *pDC, CRect rc, int nPen, int nBrush)
Draws a rectangle with a border.
CXTPTabColorSetOffice2003::FillNavigateButton
virtual void FillNavigateButton(CDC *pDC, CXTPTabManagerNavigateButton *pButton, CRect &rc)
Fills a specified tab navigation button.
CXTPTabColorSetOffice2003::RefreshMetrics
virtual void RefreshMetrics()
Refreshes the visual metrics of the tabs.
CXTPTabColorSetOffice2003::FillPropertyButton
virtual COLORREF FillPropertyButton(CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem)
Fills a specified tab button.
CXTPTabManagerItem
CXTPTabManagerItem is the base class for the tabs that appear in the command bars tab workspace,...
Definition XTPTabManagerItem.h:44
CXTPTabManagerNavigateButton
CXTPTabManagerNavigateButton is a class used to represent a tab navigation button.
Definition XTPTabManagerNavigateButton.h:74


Toolkit Pro: XTPCalendarDayViewTimeScale.h Source File

  • Source
  • Calendar
XTPCalendarDayViewTimeScale.h
Go to the documentation of this file.
1
22#if !defined(_XTPCALENDARDAYVIEWTIMESCALE_H__)
23# define _XTPCALENDARDAYVIEWTIMESCALE_H__
24
25# if _MSC_VER > 1000
26# pragma once
27# endif // _MSC_VER > 1000
28
29# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
30
31struct XTP_CALENDAR_HITTESTINFO;
32class CXTPCalendarDayView;
33class CXTPCalendarTimeZones;
34
39struct XTP_LC_TIMEFORMAT
40{
41 XTP_LC_TIMEFORMAT();
42 virtual ~XTP_LC_TIMEFORMAT();
43
44 virtual void RefreshMetrics();
45 void LoadFromLocale();
46
47 void SetCustomFormat(BOOL bAmPm, BOOL bLeadingZero, const CString& separator, const CString& am,
48 const CString& pm);
49 void ResetToDefault();
50
51 BOOL bIsCustom;
52 BOOL bAMPM_timeFormat;
53 BOOL bLeadingZeroTime;
54 CString strSeparator;
55 CString strAM;
56 CString strPM;
57};
58
74class _XTP_EXT_CLASS CXTPCalendarDayViewTimeScale : public CXTPCmdTarget
75{
76 DECLARE_DYNAMIC(CXTPCalendarDayViewTimeScale)
77 friend class CXTPCalendarDayView;
78 friend class CXTPCalendarTheme;
79
80public:
92 CXTPCalendarDayViewTimeScale(CXTPCalendarDayView* pDayView, BOOL bVisible = TRUE,
93 BOOL bDrawNowLine = TRUE);
94
104 virtual ~CXTPCalendarDayViewTimeScale();
105
114 int CalcWidth(CDC* pDC);
115
122 int GetWidth() const;
123
131 void Draw(CDC* pDC);
132
139 virtual void AdjustLayout(CDC* pDC);
140
155 virtual CString Format(COleDateTime dtTime, BOOL bTopCell, CString* pHour = NULL,
156 CString* pMin = NULL);
157
170 virtual BOOL IsDrawNowLine() const;
171
183 COleDateTimeSpan GetScaleInterval() const;
184
198 void SetCaption(LPCTSTR strCaption);
199
212 CString GetCaption() const;
213
228 void SetTimeshift(int nMinutes);
229
243 int GetTimeshift() const;
244
256 void SetVisible(BOOL bVisible);
257
269 BOOL GetVisible() const;
270
287 BOOL HitTestDateTime(XTP_CALENDAR_HITTESTINFO* pHitTest) const;
288
299 CXTPCalendarDayView* GetDayView() const;
300
311 void MoveTo(int nXPos);
312
329 void SetCustomTimeFormat(BOOL bAmPm, BOOL bLeadingZero = TRUE,
330 const CString& separator = _T(":"), const CString& am = _T("am"),
331 const CString& pm = _T("pm"));
332
337 void ResetCustomTimeFormat();
338
339public:
340 void RefreshTimeFormat();
341 const XTP_LC_TIMEFORMAT& GetTimeFormat() const;
342
343private:
344 void DrawLTR(CDC* pDC);
345 void DrawRTL(CDC* pDC);
346
347public:
348 BOOL m_bDrawNowLine;
350protected:
351 XTP_TIMESCALE_LAYOUT& GetLayout();
352
353protected:
354 XTP_TIMESCALE_LAYOUT m_Layout;
355 XTP_LC_TIMEFORMAT m_timeFormat;
356
357 CXTPCalendarDayView* m_pDayView;
359 CString m_strCaption;
360 int m_nTimeshift_min;
361 BOOL m_bVisible;
363private:
364 int m_nWidth;
365 BOOL m_bDrawNowLineDyn;
366};
367
369// CXTPCalendarTimeScalePropertiesDlg dialog
370//
371// This dialog allows for the customization of the Calendar Time Scale part as
372// well as the setting of a proper time zone and its description.
373//
374// This dialog is a simplified version of a similar Outlook dialog.
375//
377class _XTP_EXT_CLASS CXTPCalendarTimeScalePropertiesDlg : public CDialog
378{
379public:
380 enum
381 {
382 IDD = XTP_IDD_CALENDAR_TIMESCALE_PROPERTIES
383 };
384
392 CXTPCalendarTimeScalePropertiesDlg(CWnd* pParent = NULL,
393 UINT nIDTemplate = CXTPCalendarTimeScalePropertiesDlg::IDD);
394
395 ~CXTPCalendarTimeScalePropertiesDlg();
396
397public:
398 CString m_strCaption1;
400 BOOL m_bShowAdditionalScale;
401 CString m_strCaption2;
403 TIME_ZONE_INFORMATION m_tziScale2;
405protected:
406 // Generated message map functions
407
408 virtual void DoDataExchange(CDataExchange* pDX);
409 virtual BOOL OnInitDialog();
410 virtual void OnOK();
411 afx_msg void OnSelchangeZones2();
412 afx_msg void OnBnClickedScale2();
413
415 DECLARE_MESSAGE_MAP()
417protected:
418 CEdit m_edtCaption1;
419 CComboBox m_cmbZones1;
420 CButton m_btnAutoAdjustDayLight1;
423 CEdit m_edtCaption2;
424 CComboBox m_cmbZones2;
425 CButton m_btnAutoAdjustDayLight2;
428 BOOL m_bAutoAdjustDayLight2;
431 CXTPCalendarTimeZones* m_pTimeZones;
432};
433
435AFX_INLINE void CXTPCalendarDayViewTimeScale::SetCaption(LPCTSTR strCaption)
436{
437 m_strCaption = strCaption;
438}
439AFX_INLINE CString CXTPCalendarDayViewTimeScale::GetCaption() const
440{
441 return m_strCaption;
442}
443AFX_INLINE void CXTPCalendarDayViewTimeScale::SetTimeshift(int nMinutes)
444{
445 m_nTimeshift_min = nMinutes;
446}
447AFX_INLINE int CXTPCalendarDayViewTimeScale::GetTimeshift() const
448{
449 return m_nTimeshift_min;
450}
451AFX_INLINE void CXTPCalendarDayViewTimeScale::SetVisible(BOOL bVisible)
452{
453 m_bVisible = bVisible;
454}
455AFX_INLINE BOOL CXTPCalendarDayViewTimeScale::GetVisible() const
456{
457 return m_bVisible;
458}
459AFX_INLINE CXTPCalendarDayView* CXTPCalendarDayViewTimeScale::GetDayView() const
460{
461 return m_pDayView;
462}
463AFX_INLINE XTP_TIMESCALE_LAYOUT& CXTPCalendarDayViewTimeScale::GetLayout()
464{
465 return m_Layout;
466}
467
468AFX_INLINE const XTP_LC_TIMEFORMAT& CXTPCalendarDayViewTimeScale::GetTimeFormat() const
469{
470 return m_timeFormat;
471}
472
473AFX_INLINE BOOL CXTPCalendarDayViewTimeScale::IsDrawNowLine() const
474{
475 return m_bDrawNowLine;
476}
477AFX_INLINE int CXTPCalendarDayViewTimeScale::GetWidth() const
478{
479 return m_Layout.m_rcHeader.Width();
480}
481
482# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
483#endif // !defined(_XTPCALENDARDAYVIEWTIMESCALE_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCalendarDayView
This class implements a specific view portion of the Calendar control - called Day view.
Definition XTPCalendarDayView.h:62
CXTPCalendarDayViewTimeScale
This class implements a specific view portion of the Calendar Day view - called Time scale.
Definition XTPCalendarDayViewTimeScale.h:75
CXTPCalendarDayViewTimeScale::GetWidth
int GetWidth() const
This member function is used to get the time scale width.
Definition XTPCalendarDayViewTimeScale.h:477
CXTPCalendarDayViewTimeScale::SetVisible
void SetVisible(BOOL bVisible)
This member function is used to set the time scale visibility mode (TRUE - visible,...
Definition XTPCalendarDayViewTimeScale.h:451
CXTPCalendarDayViewTimeScale::CXTPCalendarDayViewTimeScale
CXTPCalendarDayViewTimeScale(CXTPCalendarDayView *pDayView, BOOL bVisible=TRUE, BOOL bDrawNowLine=TRUE)
Default object constructor.
CXTPCalendarDayViewTimeScale::m_Layout
XTP_TIMESCALE_LAYOUT m_Layout
Store time scale layout.
Definition XTPCalendarDayViewTimeScale.h:354
CXTPCalendarDayViewTimeScale::HitTestDateTime
BOOL HitTestDateTime(XTP_CALENDAR_HITTESTINFO *pHitTest) const
This member function is used to fill an XTP_CALENDAR_HITTESTINFO structure.
CXTPCalendarDayViewTimeScale::SetCustomTimeFormat
void SetCustomTimeFormat(BOOL bAmPm, BOOL bLeadingZero=TRUE, const CString &separator=_T(":"), const CString &am=_T("am"), const CString &pm=_T("pm"))
Sets the custom time format for the day view timescale.
CXTPCalendarDayViewTimeScale::GetScaleInterval
COleDateTimeSpan GetScaleInterval() const
This member function obtains the time scale cell interval.
CXTPCalendarDayViewTimeScale::Format
virtual CString Format(COleDateTime dtTime, BOOL bTopCell, CString *pHour=NULL, CString *pMin=NULL)
This member function is used to format the time scale text.
CXTPCalendarDayViewTimeScale::CalcWidth
int CalcWidth(CDC *pDC)
This member function is used to obtain the time scale width in pixels.
CXTPCalendarDayViewTimeScale::MoveTo
void MoveTo(int nXPos)
This member function shifts the time scale object.
CXTPCalendarDayViewTimeScale::~CXTPCalendarDayViewTimeScale
virtual ~CXTPCalendarDayViewTimeScale()
Default class destructor.
CXTPCalendarDayViewTimeScale::GetDayView
CXTPCalendarDayView * GetDayView() const
This member function obtains the time scale owner view.
Definition XTPCalendarDayViewTimeScale.h:459
CXTPCalendarDayViewTimeScale::GetCaption
CString GetCaption() const
This member function is used to obtain the text caption for the time scale.
Definition XTPCalendarDayViewTimeScale.h:439
CXTPCalendarDayViewTimeScale::SetTimeshift
void SetTimeshift(int nMinutes)
This member function is used to set the new time shift in hours for the time scale.
Definition XTPCalendarDayViewTimeScale.h:443
CXTPCalendarDayViewTimeScale::GetVisible
BOOL GetVisible() const
This member function is used to obtain the current time scale visibility mode.
Definition XTPCalendarDayViewTimeScale.h:455
CXTPCalendarDayViewTimeScale::ResetCustomTimeFormat
void ResetCustomTimeFormat()
Resets the timescale time format to the current locale format.
CXTPCalendarDayViewTimeScale::m_pDayView
CXTPCalendarDayView * m_pDayView
Pointer to the parent Calendar Day view object.
Definition XTPCalendarDayViewTimeScale.h:357
CXTPCalendarDayViewTimeScale::m_bVisible
BOOL m_bVisible
Show this timescale or not.
Definition XTPCalendarDayViewTimeScale.h:361
CXTPCalendarDayViewTimeScale::Draw
void Draw(CDC *pDC)
This member function is used to perform all drawing logic of the time scale.
CXTPCalendarDayViewTimeScale::m_bDrawNowLine
BOOL m_bDrawNowLine
Specifies whether we should draw the "Now" line on the time scale.
Definition XTPCalendarDayViewTimeScale.h:348
CXTPCalendarDayViewTimeScale::m_nTimeshift_min
int m_nTimeshift_min
Time zone time shift in minutes.
Definition XTPCalendarDayViewTimeScale.h:360
CXTPCalendarDayViewTimeScale::GetTimeshift
int GetTimeshift() const
This member function is used to obtain the time shift in hours for the time scale.
Definition XTPCalendarDayViewTimeScale.h:447
CXTPCalendarDayViewTimeScale::AdjustLayout
virtual void AdjustLayout(CDC *pDC)
This function is used to adjust the time scale layout.
CXTPCalendarDayViewTimeScale::IsDrawNowLine
virtual BOOL IsDrawNowLine() const
This member function is used to determine if the Current Time Mark can be drawn for this time scale.
Definition XTPCalendarDayViewTimeScale.h:473
CXTPCalendarDayViewTimeScale::m_strCaption
CString m_strCaption
Caption under time scale.
Definition XTPCalendarDayViewTimeScale.h:359
CXTPCalendarTimeZones
This class represents a simple array collection of CXTPCalendarTimeZone objects.
Definition XTPCalendarTimeZoneHelper.h:204
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
XTP_CALENDAR_HITTESTINFO
Basic set of parameters transferred from calendar items to mouse handlers.
Definition XTPCalendarDefines.h:856
XTP_LC_TIMEFORMAT
Time format structure.
Definition XTPCalendarDayViewTimeScale.h:40


Toolkit Pro: XTPPropertyGridView.h Source File

  • Source
  • PropertyGrid
XTPPropertyGridView.h
Go to the documentation of this file.
1
23#if !defined(__XTPPROPERTYGRIDVIEW_H__)
24# define __XTPPROPERTYGRIDVIEW_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPPropertyGridView;
34class CXTPPropertyGridPaintManager;
35class CXTPPropertyGrid;
36class CXTPImageManager;
38class CXTPScrollablePropertyGridListBox;
46class _XTP_EXT_CLASS CXTPPropertyGridView
47 : public CListBox
48 , public CXTPAccessible
49{
51 struct WNDRECT;
52 DECLARE_DYNAMIC(CXTPPropertyGridView)
54public:
59 CXTPPropertyGridView();
60
66 virtual ~CXTPPropertyGridView();
67
68public:
75 int GetDividerPos() const;
76
82 void SetDividerPos(int nDivider);
83
88 void LockDivider();
89
98 CXTPPropertyGridItem* ItemFromPoint(CPoint point) const;
99
104 void Refresh();
105
110 void ResetContent();
111
119 CXTPPropertyGridItem* GetItem(int nIndex) const;
120
131 CXTPPropertyGridItem* AddCategory(LPCTSTR strCaption, CXTPPropertyGridItem* pCategory = NULL);
132
144 CXTPPropertyGridItem* InsertCategory(int nIndex, LPCTSTR strCaption,
145 CXTPPropertyGridItem* pCategory = NULL);
146
154 CXTPPropertyGridPaintManager* GetPaintManager() const;
155
163 CXTPImageManager* GetImageManager() const;
164
173 LRESULT SendNotifyMessage(WPARAM wParam = 0, LPARAM lParam = 0);
174
181 CXTPPropertyGrid* GetPropertyGrid() const;
182
188 void FocusInplaceButton(CXTPPropertyGridInplaceButton* pButton);
189
190protected:
196 virtual void ShowToolTip(CPoint pt);
197
198protected:
200 DECLARE_MESSAGE_MAP()
201
202 //{{AFX_VIRTUAL(CXTPPropertyGridView)
203 virtual void DrawItem(LPDRAWITEMSTRUCT);
204 virtual void MeasureItem(LPMEASUREITEMSTRUCT);
205 virtual int CompareItem(LPCOMPAREITEMSTRUCT)
206 {
207 return 0;
208 }
209 virtual BOOL OnWndMsg(UINT message, WPARAM wParam, LPARAM lParam, LRESULT* pResult);
210 virtual INT_PTR OnToolHitTest(CPoint point, TOOLINFO* pTI) const;
211 //}}AFX_VIRTUAL
212
213 //{{AFX_MSG(CXTPPropertyGridView)
214 afx_msg int OnCreate(LPCREATESTRUCT lpCreateStruct);
215 afx_msg BOOL OnEraseBkgnd(CDC* pDC);
216 afx_msg void OnPaint();
217 afx_msg void OnNcPaint();
218 afx_msg void OnNcCalcSize(BOOL bCalcValidRects, NCCALCSIZE_PARAMS* lpncsp);
219 afx_msg void OnLButtonDown(UINT nFlags, CPoint point);
220 afx_msg void OnLButtonDblClk(UINT nFlags, CPoint point);
221 afx_msg void OnRButtonDown(UINT nFlags, CPoint point);
222 afx_msg void OnRButtonUp(UINT nFlags, CPoint point);
223 afx_msg void OnSelectionChanged();
224 afx_msg BOOL OnSetCursor(CWnd* pWnd, UINT nHitTest, UINT message);
225 afx_msg void OnLButtonUp(UINT nFlags, CPoint point);
226 afx_msg void OnCaptureChanged(CWnd* pWnd);
227 afx_msg void OnMouseMove(UINT nFlags, CPoint point);
228 afx_msg void OnSize(UINT nType, int cx, int cy);
229 afx_msg void OnChar(UINT nChar, UINT nRepCntr, UINT nFlags);
230 afx_msg void OnKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags);
231 afx_msg void OnKeyUp(UINT nChar, UINT nRepCnt, UINT nFlags);
232 afx_msg UINT OnGetDlgCode();
233 afx_msg void OnSysKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags);
234 afx_msg void OnSysKeyUp(UINT nChar, UINT nRepCnt, UINT nFlags);
235 afx_msg void OnVScroll(UINT nSBCode, UINT nPos, CScrollBar* pScrollBar);
236 afx_msg BOOL OnMouseWheel(UINT nFlags, short zDelta, CPoint pt);
237 afx_msg void OnSetFocus(CWnd* pOldWnd);
238 afx_msg void OnKillFocus(CWnd* pNewWnd);
239 afx_msg LRESULT OnGetObject(WPARAM wParam, LPARAM lParam);
240 //}}AFX_MSG
243protected:
245 // System accessibility support.
246 virtual HRESULT GetAccessibleParent(IDispatch** ppdispParent);
247 virtual HRESULT GetAccessibleChildCount(long* pcountChildren);
248 virtual HRESULT GetAccessibleChild(VARIANT varChild, IDispatch** ppdispChild);
249 virtual HRESULT GetAccessibleName(VARIANT varChild, BSTR* pszName);
250 virtual HRESULT GetAccessibleRole(VARIANT varChild, VARIANT* pvarRole);
251 virtual HRESULT AccessibleLocation(long* pxLeft, long* pyTop, long* pcxWidth, long* pcyHeight,
252 VARIANT varChild);
253 virtual HRESULT AccessibleHitTest(long xLeft, long yTop, VARIANT* pvarChild);
254 virtual HRESULT GetAccessibleState(VARIANT varChild, VARIANT* pvarState);
255 virtual CCmdTarget* GetAccessible();
256
257 DECLARE_INTERFACE_MAP()
258 XTP_DECLARE_CMDTARGETPROVIDER_INTERFACE()
261private:
262 CXTPPropertyGridItem* GetSelectedItem();
263 void SetPropertySort(XTPPropertyGridSortOrder sort, BOOL bRrefresh = FALSE,
264 BOOL bSetRedraw = TRUE);
265 int InsertItem(CXTPPropertyGridItem* pItem, int nIndex);
266 int _DoExpand(CXTPPropertyGridItem* pItem, int nIndex);
267 void _DoCollapse(CXTPPropertyGridItem* pItem);
268 void _RefreshIndexes();
269 void SwitchExpandState(int nItem);
270 int HitTest(CPoint point) const;
271
272 void _ShowToolTip(CRect rcBound, CRect rcText, CXTPPropertyGridItem* pItem, BOOL bValuePart);
273 CSize _GetTextExtent(const CString& str, CXTPPropertyGridItem* pItem, BOOL bValuePart);
274 void RelayToolTipEvent(UINT message);
275 LRESULT OnScrollControl();
276 CPoint ViewToGrid(CPoint point);
277
278protected:
279 CXTPPropertyGrid* m_pGrid;
280 BOOL m_bTracking;
281 CRect m_rcToolTip;
282 double m_dDivider;
283 BOOL m_bAutoDivider;
284 HCURSOR m_hCursor;
285 CString m_strTipText;
286 XTPPropertyGridSortOrder m_properetySort;
287 CXTPPropertyGridItem* m_pSelected;
288 CXTPPropertyGridItems* m_pCategories;
289 CXTPPropertyGridToolTip m_wndTip;
290 int m_nLockUpdate;
291 UINT m_nItemHeight;
292 BOOL m_bVariableSplitterPos;
295 CXTPPropertyGridInplaceButton* m_pFocusedButton;
296 CXTPPropertyGridInplaceButton* m_pHotButton;
298private:
299 friend class CXTPPropertyGridItem;
300 friend class CXTPPropertyGridItems;
301 friend class CXTPPropertyGrid;
302 friend class CXTPPropertyGridInplaceEdit;
303 friend class CPropertyGridCtrl;
304 friend class CXTPPropertyGridToolTip;
305 friend class CXTPPropertyGridInplaceButton;
306 friend class CXTPPropertyGridInplaceButtons;
307 friend class CXTPScrollablePropertyGridListBox;
308};
309
310AFX_INLINE CXTPPropertyGrid* CXTPPropertyGridView::GetPropertyGrid() const
311{
312 return m_pGrid;
313}
314
316# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
317#endif // #if !defined(__XTPPROPERTYGRIDVIEW_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTP_DECLARE_CMDTARGETPROVIDER_INTERFACE
#define XTP_DECLARE_CMDTARGETPROVIDER_INTERFACE()
When deriving from CXTPCmdTarget is not possible this macro can be used in addition to standard DECLA...
Definition XTPFramework.h:89
XTPPropertyGridSortOrder
XTPPropertyGridSortOrder
XTPPropertyGridSortOrder is an enumeration used by CXTPPropertyGrid to determine the grouping style.
Definition XTPPropertyGridDefines.h:48
CXTPImageManager
CXTPImageManager is a standalone class.
Definition XTPImageManager.h:1898
CXTPPropertyGrid
CXTPPropertyGrid is a CWnd derived class.
Definition XTPPropertyGrid.h:402
CXTPPropertyGridInplaceButton
CXTPPropertyGridInplaceButton is a CXTPCmdTarget derived class.
Definition XTPPropertyGridInplaceButton.h:50
CXTPPropertyGridInplaceButtons
CXTPPropertyGridInplaceButtons is a CXTPCmdTarget derived class.
Definition XTPPropertyGridInplaceButton.h:372
CXTPPropertyGridInplaceEdit
CXTPPropertyGridInplaceEdit is a CEdit derived class.
Definition XTPPropertyGridInplaceEdit.h:44
CXTPPropertyGridItem
CXTPPropertyGridItem is the base class representing an item of the Property Grid control.
Definition XTPPropertyGridItem.h:523
CXTPPropertyGridItems
CXTPPropertyGridItems is a CList derived class.
Definition XTPPropertyGridItem.h:110
CXTPPropertyGridPaintManager
Standalone class used by CXTPPropertyGrid as the paint manager.
Definition XTPPropertyGridPaintManager.h:133
CXTPPropertyGridToolTip
CXTPPropertyGridToolTip is a CWnd derived class.
Definition XTPPropertyGridToolTip.h:39
CXTPPropertyGridView
CXTPPropertyGridView is a CListBox derived class.
Definition XTPPropertyGridView.h:49
CXTPPropertyGridView::GetPaintManager
CXTPPropertyGridPaintManager * GetPaintManager() const
Gets the paint manager associated with the property grid (i.e.
CXTPPropertyGridView::InsertCategory
CXTPPropertyGridItem * InsertCategory(int nIndex, LPCTSTR strCaption, CXTPPropertyGridItem *pCategory=NULL)
Inserts a new category to the property grid control.
CXTPPropertyGridView::ShowToolTip
virtual void ShowToolTip(CPoint pt)
Shows the tooltip of the item located at the mouse position.
CXTPPropertyGridView::GetItem
CXTPPropertyGridItem * GetItem(int nIndex) const
Retrieves the item at a specified index in the list.
CXTPPropertyGridView::SendNotifyMessage
LRESULT SendNotifyMessage(WPARAM wParam=0, LPARAM lParam=0)
Sends a specified message to the owner window.
CXTPPropertyGridView::AddCategory
CXTPPropertyGridItem * AddCategory(LPCTSTR strCaption, CXTPPropertyGridItem *pCategory=NULL)
Adds a new category to the property grid control.
CXTPPropertyGridView::~CXTPPropertyGridView
virtual ~CXTPPropertyGridView()
Destroys a CXTPPropertyGridView object, handles cleanup and deallocation.
CXTPPropertyGridView::LockDivider
void LockDivider()
Disables auto-calculation for the position of the divider.
CXTPPropertyGridView::CXTPPropertyGridView
CXTPPropertyGridView()
Constructs a CXTPPropertyGridView object.
CXTPPropertyGridView::SetDividerPos
void SetDividerPos(int nDivider)
Sets the position for the divider.
CXTPPropertyGridView::FocusInplaceButton
void FocusInplaceButton(CXTPPropertyGridInplaceButton *pButton)
Moves focus to a specified in-place button.
CXTPPropertyGridView::ItemFromPoint
CXTPPropertyGridItem * ItemFromPoint(CPoint point) const
Determines which item, if any, is located at a specified point.
CXTPPropertyGridView::GetImageManager
CXTPImageManager * GetImageManager() const
Gets the image manager associated with the property grid (i.e.
CXTPPropertyGridView::ResetContent
void ResetContent()
Removes all items from the list.
CXTPPropertyGridView::Refresh
void Refresh()
Refreshes the items in the list.
CXTPPropertyGridView::GetDividerPos
int GetDividerPos() const
Gets the position of the divider.


Toolkit Pro: Member List

CXTPChart3dFunnelSeriesPointView Member List

This is the complete list of members for CXTPChart3dFunnelSeriesPointView, including all inherited members.

AddChildView(CXTPChartElementView *pChildView) | CXTPChartElementView |
CalculateLayout(int nIndex, int nCount, double dFrom, double dTo) | CXTPChart3dFunnelSeriesPointView | virtual
CreateDeviceCommand(CXTPChartDeviceContext *pDC) | CXTPChart3dFunnelSeriesPointView | protectedvirtual
CreateLegendDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcBounds) | CXTPChart3dFunnelSeriesPointView | protectedvirtual
CXTPChart3dFunnelSeriesPointView(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView) | CXTPChart3dFunnelSeriesPointView |
CXTPChartElementView(CXTPChartElementView *pParentView) | CXTPChartElementView |
CXTPChartElementView(CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartElementView |
CXTPChartElementView(CXTPChartContainer *pContainer) | CXTPChartElementView |
CXTPChartFunnelSeriesPointViewBase(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView) | CXTPChartFunnelSeriesPointViewBase |
CXTPChartFunnelSeriesPointViewBase(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartFunnelSeriesPointViewBase |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartSeriesPointView(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView) | CXTPChartSeriesPointView |
CXTPChartSeriesPointView(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartSeriesPointView |
GetAt(int nIndex) const | CXTPChartElementView |
GetBorderActualColor() const | CXTPChartFunnelSeriesPointViewBase |
GetBounds() const | CXTPChartElementView |
GetBounds(BOOL bIncludingChildren) const | CXTPChartElementView |
GetCenterShapeConnectorPoint() const | CXTPChart3dFunnelSeriesPointView |
GetChildren() | CXTPChartElementView |
GetColor() const | CXTPChartSeriesPointView |
GetColor2() const | CXTPChartSeriesPointView |
GetCount() const | CXTPChartElementView |
GetInternalValue() const | CXTPChartSeriesPointView |
GetLegendName() const | CXTPChartSeriesPointView | virtual
GetOuterCenterConnectorPoint() const | CXTPChart3dFunnelSeriesPointView |
GetParentView() const | CXTPChartElementView |
GetPoint() const | CXTPChartSeriesPointView |
GetSeriesView() const | CXTPChartSeriesPointView |
Is3D() const | CXTPChartObject |
m_arrChildren | CXTPChartElementView | protected
m_dInternalValue | CXTPChartSeriesPointView |
m_dValue | CXTPChartFunnelSeriesPointViewBase | protected
m_pContainer | CXTPChartElementView | protected
m_pParentView | CXTPChartElementView | protected
m_pPoint | CXTPChartSeriesPointView | protected
m_rcBounds | CXTPChartElementView | protected
OnSetConnectorPoints(CXTPChartDeviceCommand *pCommand, CXTPPoint3d ptShapeCenter, CXTPPoint3d ptOuterCenter) | CXTPChart3dFunnelSeriesPointView | protectedvirtual
OnUpdateBounds(CXTPChartDeviceCommand *pCommand, CRect rcBounds) | CXTPChart3dFunnelSeriesPointView | protectedvirtual
UpdateMinMaxRange(double &nMinValue, double &nMaxValue) const | CXTPChartSeriesPointView | virtual
~CXTPChart3dFunnelSeriesPointView() | CXTPChart3dFunnelSeriesPointView | virtual
~CXTPChartElementView() | CXTPChartElementView | protectedvirtual
~CXTPChartFunnelSeriesPointViewBase() | CXTPChartFunnelSeriesPointViewBase | virtual
~CXTPChartLegendItemView() | CXTPChartLegendItemView | inlinevirtual


Toolkit Pro: XTPCommandBarsOfficeXPTheme.h Source File

  • Source
  • CommandBars
  • Themes
XTPCommandBarsOfficeXPTheme.h
Go to the documentation of this file.
1
23#if !defined(__XTPCOMMANDBARSOFFICEXPTHEME_H__)
24# define __XTPCOMMANDBARSOFFICEXPTHEME_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
40class _XTP_EXT_CLASS CXTPCommandBarsOfficeXPTheme : public CXTPPaintManager
41{
43 DECLARE_DYNAMIC(CXTPCommandBarsOfficeXPTheme)
45public:
50 CXTPCommandBarsOfficeXPTheme();
51
58 virtual void FillCommandBarEntry(CDC* pDC, CXTPCommandBar* pBar);
59
72 virtual COLORREF GetRectangleTextColor(BOOL bSelected, BOOL bPressed, BOOL bEnabled,
73 BOOL bChecked, BOOL bPopuped, XTPBarType barType,
74 XTPBarPosition barPosition);
75
85 virtual CSize DrawCommandBarGripper(CDC* pDC, CXTPCommandBar* pBar, BOOL bDraw = TRUE);
86
97 virtual CSize DrawCommandBarSeparator(CDC* pDC, CXTPCommandBar* pBar, CXTPControl* pControl,
98 BOOL bDraw = TRUE);
99
112 virtual CSize DrawListBoxControl(CDC* pDC, CXTPControl* pButton, CRect rc, BOOL bSelected,
113 BOOL bDraw, CXTPCommandBars* pCommandBars = 0);
114
122 virtual void AdjustExcludeRect(CRect& rc, CXTPControl* pControl, BOOL bVertical);
123
134 virtual CSize DrawTearOffGripper(CDC* pDC, CRect rcGripper, BOOL bSelected, BOOL bDraw);
135
143 virtual void DrawPopupResizeGripper(CDC* pDC, CRect rcGripper, int nFlags);
144
154 virtual CSize DrawDialogBarGripper(CDC* pDC, CXTPDialogBar* pBar, BOOL bDraw);
155
156protected:
169 virtual void DrawPopupBarGripper(CDC* pDC, int xPos, int yPos, int cx, int cy,
170 BOOL bExpanded = FALSE);
171
181 virtual CSize DrawControlPopupParent(CDC* pDC, CXTPControl* pButton, BOOL bDraw);
182
196 virtual void DrawRectangle(CDC* pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled,
197 BOOL bChecked, BOOL bPopuped, XTPBarType barType,
198 XTPBarPosition barPosition);
199
214 virtual void DrawRectangle(CDC* pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled,
215 BOOL bChecked, BOOL bPopuped, XTPBarType barType,
216 XTPBarPosition barPosition, int nID);
217
226 virtual BOOL DrawRectangle(CDC* pDC, CXTPControl* pButton);
227
242 virtual void DrawImage(CDC* pDC, CPoint pt, CSize sz, CXTPImageManagerIcon* pImage,
243 BOOL bSelected, BOOL bPressed, BOOL bEnabled = TRUE,
244 BOOL bChecked = FALSE, BOOL bPopuped = FALSE, BOOL bToolBarImage = TRUE);
245
255 virtual CSize DrawControlComboBox(CDC* pDC, CXTPControlComboBox* pComboBox, BOOL bDraw);
256
266 virtual CSize DrawControlEdit(CDC* pDC, CXTPControlEdit* pEdit, BOOL bDraw);
267
275 void FillIntersectRect(CDC* pDC, CXTPPopupBar* pPopupBar, COLORREF clr);
276
283 virtual XTPPaintTheme BaseTheme()
284 {
285 return xtpThemeOfficeXP;
286 }
287
296 virtual void DrawSplitButtonFrame(CDC* pDC, CXTPControl* pButton, CRect rc);
297
311 virtual CSize DrawControlCheckBoxMark(CDC* pDC, CRect rc, BOOL bDraw, BOOL bSelected,
312 BOOL bPressed, BOOL bChecked, BOOL bEnabled);
313
324 virtual CSize DrawControlCheckBoxMark(CDC* pDC, CXTPControl* pButton, CRect rc, BOOL bDraw);
325
339 virtual CSize DrawControlRadioButtonMark(CDC* pDC, CRect rc, BOOL bDraw, BOOL bSelected,
340 BOOL bPressed, BOOL bChecked, BOOL bEnabled);
341
342 virtual void DrawCheckMark(CDC* pDC, CRect rcCheck, BOOL bIsRadio, BOOL bEnabled,
343 BOOL bSelected);
344
345protected:
347 virtual void DrawSplitButtonPopup(CDC* pDC, CXTPControl* pButton);
348 virtual void DrawControlPopupGlyph(CDC* pDC, CXTPControl* pButton);
349 virtual void FillPopupLabelEntry(CDC* pDC, CRect rc);
351};
352
353# define CXTPOfficeTheme CXTPCommandBarsOfficeXPTheme
354
356# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
357#endif // !defined(__XTPCOMMANDBARSOFFICEXPTHEME_H__)
XTPBarType
XTPBarType
Type of the command bar.
Definition XTPCommandBarsDefines.h:77
XTPBarPosition
XTPBarPosition
Position of the command bar.
Definition XTPCommandBarsDefines.h:52
XTPPaintTheme
XTPPaintTheme
Paint themes used by command bars.
Definition XTPCommandBarsDefines.h:233
xtpThemeOfficeXP
@ xtpThemeOfficeXP
Office XP theme.
Definition XTPCommandBarsDefines.h:236
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCommandBar
CXTPCommandBar is a CWnd derived class.
Definition XTPCommandBar.h:66
CXTPCommandBars
CXTPCommandBars is a standalone class.
Definition XTPCommandBars.h:165
CXTPCommandBarsOfficeXPTheme
The CXTPCommandBarsOfficeXPTheme class is used to enable an Office XP style theme for Command Bars.
Definition XTPCommandBarsOfficeXPTheme.h:41
CXTPCommandBarsOfficeXPTheme::DrawControlRadioButtonMark
virtual CSize DrawControlRadioButtonMark(CDC *pDC, CRect rc, BOOL bDraw, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled)
This method is called to draw a radio button mark area.
CXTPCommandBarsOfficeXPTheme::DrawCommandBarGripper
virtual CSize DrawCommandBarGripper(CDC *pDC, CXTPCommandBar *pBar, BOOL bDraw=TRUE)
This method is called to draw the command bar's gripper.
CXTPCommandBarsOfficeXPTheme::DrawControlComboBox
virtual CSize DrawControlComboBox(CDC *pDC, CXTPControlComboBox *pComboBox, BOOL bDraw)
This method is called to draw the control.
CXTPCommandBarsOfficeXPTheme::DrawSplitButtonFrame
virtual void DrawSplitButtonFrame(CDC *pDC, CXTPControl *pButton, CRect rc)
This method is called to draw the frame for the SplitButton control.
CXTPCommandBarsOfficeXPTheme::DrawListBoxControl
virtual CSize DrawListBoxControl(CDC *pDC, CXTPControl *pButton, CRect rc, BOOL bSelected, BOOL bDraw, CXTPCommandBars *pCommandBars=0)
This method is called to draw the control placed on the ListBox.
CXTPCommandBarsOfficeXPTheme::GetRectangleTextColor
virtual COLORREF GetRectangleTextColor(BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition)
This method retrieves a buttons text color.
CXTPCommandBarsOfficeXPTheme::DrawControlPopupParent
virtual CSize DrawControlPopupParent(CDC *pDC, CXTPControl *pButton, BOOL bDraw)
This method is called to draw the control placed on the pop-up bar.
CXTPCommandBarsOfficeXPTheme::DrawRectangle
virtual BOOL DrawRectangle(CDC *pDC, CXTPControl *pButton)
This method is called to fill the control's face.
CXTPCommandBarsOfficeXPTheme::CXTPCommandBarsOfficeXPTheme
CXTPCommandBarsOfficeXPTheme()
Constructs a CXTPCommandBarsOfficeXPTheme object.
CXTPCommandBarsOfficeXPTheme::FillIntersectRect
void FillIntersectRect(CDC *pDC, CXTPPopupBar *pPopupBar, COLORREF clr)
Draws intersect rectangle of a pop-up bar and its control.
CXTPCommandBarsOfficeXPTheme::AdjustExcludeRect
virtual void AdjustExcludeRect(CRect &rc, CXTPControl *pControl, BOOL bVertical)
This method is called to determine the offset of a pop-up bar.
CXTPCommandBarsOfficeXPTheme::DrawTearOffGripper
virtual CSize DrawTearOffGripper(CDC *pDC, CRect rcGripper, BOOL bSelected, BOOL bDraw)
This method is called to draw a tear-off gripper of a pop-up bar.
CXTPCommandBarsOfficeXPTheme::DrawControlEdit
virtual CSize DrawControlEdit(CDC *pDC, CXTPControlEdit *pEdit, BOOL bDraw)
This method is called to draw the control.
CXTPCommandBarsOfficeXPTheme::DrawPopupBarGripper
virtual void DrawPopupBarGripper(CDC *pDC, int xPos, int yPos, int cx, int cy, BOOL bExpanded=FALSE)
This method is called to draw a pop-up bar's right gripper.
CXTPCommandBarsOfficeXPTheme::FillCommandBarEntry
virtual void FillCommandBarEntry(CDC *pDC, CXTPCommandBar *pBar)
This method is called to fill the command bar's face.
CXTPCommandBarsOfficeXPTheme::DrawPopupResizeGripper
virtual void DrawPopupResizeGripper(CDC *pDC, CRect rcGripper, int nFlags)
This method is called to draw a resize gripper of a pop-up bar.
CXTPCommandBarsOfficeXPTheme::DrawImage
virtual void DrawImage(CDC *pDC, CPoint pt, CSize sz, CXTPImageManagerIcon *pImage, BOOL bSelected, BOOL bPressed, BOOL bEnabled=TRUE, BOOL bChecked=FALSE, BOOL bPopuped=FALSE, BOOL bToolBarImage=TRUE)
This method is called to draw the image of the control.
CXTPCommandBarsOfficeXPTheme::DrawControlCheckBoxMark
virtual CSize DrawControlCheckBoxMark(CDC *pDC, CRect rc, BOOL bDraw, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled)
This method is called to draw a check box mark area.
CXTPCommandBarsOfficeXPTheme::BaseTheme
virtual XTPPaintTheme BaseTheme()
Retrieves the base theme of the manager.
Definition XTPCommandBarsOfficeXPTheme.h:283
CXTPCommandBarsOfficeXPTheme::DrawRectangle
virtual void DrawRectangle(CDC *pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition)
This method is called to fill the control's face.
CXTPCommandBarsOfficeXPTheme::DrawRectangle
virtual void DrawRectangle(CDC *pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition, int nID)
This method is called to fill the control's face.
CXTPCommandBarsOfficeXPTheme::DrawCommandBarSeparator
virtual CSize DrawCommandBarSeparator(CDC *pDC, CXTPCommandBar *pBar, CXTPControl *pControl, BOOL bDraw=TRUE)
This method is called to draw a command bar's separator.
CXTPCommandBarsOfficeXPTheme::DrawControlCheckBoxMark
virtual CSize DrawControlCheckBoxMark(CDC *pDC, CXTPControl *pButton, CRect rc, BOOL bDraw)
This method is called to draw a check box mark area.
CXTPCommandBarsOfficeXPTheme::DrawDialogBarGripper
virtual CSize DrawDialogBarGripper(CDC *pDC, CXTPDialogBar *pBar, BOOL bDraw)
Call this member to draw the gripper of a dialog bar.
CXTPControlComboBox
CXTPControlComboBox is a CXTPControl derived class.
Definition XTPControlComboBox.h:381
CXTPControlEdit
CXTPControlEdit is a CXTPControl derived class.
Definition XTPControlEdit.h:274
CXTPControl
CXTPControl is a CXTPCmdTarget derived class.
Definition XTPControl.h:841
CXTPDialogBar
CXTPDialogBar is a CXTPToolBar derived class.
Definition XTPDialogBar.h:41
CXTPImageManagerIcon
Icons holder class.
Definition XTPImageManager.h:622
CXTPPaintManager
Paint manager of the command bars.
Definition XTPPaintManager.h:199
CXTPPaintManager::DrawCheckMark
void DrawCheckMark(CDC *pDC, CRect rcCheck, COLORREF clr=0)
Call this member function to draw a check mark.
Definition XTPPaintManager.h:949
CXTPPopupBar
CXTPPopupBar is a CXTPCommandBar derived class.
Definition XTPPopupBar.h:42


Toolkit Pro: XTPControlComboBox.h Source File

  • Source
  • CommandBars
XTPControlComboBox.h
Go to the documentation of this file.
1
23#if !defined(__XTPCONTOLCOMBOBOX_H__)
24# define __XTPCONTOLCOMBOBOX_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33# define WM_XTP_SHELLAUTOCOMPLETESTART (WM_XTP_COMMANDBARS_BASE + 30)
34
35class CXTPControlComboBox;
36class CXTPControlComboBoxAutoCompleteWnd;
37
45class _XTP_EXT_CLASS CXTPControlComboBoxAutoCompleteWnd : public CXTPHookManagerHookAble
46{
47public:
48 CXTPControlComboBoxAutoCompleteWnd();
49 ~CXTPControlComboBoxAutoCompleteWnd();
50
51public:
52 HRESULT ShellAutoComplete(HWND hEdit, DWORD dwFlags);
53 void CloseWindow();
54 void SetupMessageHook(BOOL bSetup);
55 BOOL IsDialogCode(UINT nChar, LPARAM lParam);
56
57private:
58 static CXTPControlComboBoxAutoCompleteWnd* m_pWndMonitor;
59 static LRESULT CALLBACK CallWndProc(int code, WPARAM wParam, LPARAM lParam);
60 virtual int OnHookMessage(HWND hWnd, UINT nMessage, WPARAM& wParam, LPARAM& lParam,
61 LRESULT& lResult);
62 void SetAutoCompeteHandle(HWND);
63
64public:
65 HWND m_hWndAutoComplete;
66
67private:
68 static HHOOK m_hHookMessage;
69 HWND m_hWndEdit;
70};
71
79class _XTP_EXT_CLASS CXTPControlComboBoxPopupBar : public CXTPPopupBar
80{
82 DECLARE_XTP_COMMANDBAR(CXTPControlComboBoxPopupBar)
84public:
89 CXTPControlComboBoxPopupBar();
90
91public:
94 // {{AFX_VIRUAL(CXTPControlComboBoxPopupBar)
95
96 virtual int GetCurSel() const
97 {
98 return CB_ERR;
99 }
100 virtual int FindString(int /*nStartAfter*/, LPCTSTR /*lpszItem*/) const
101 {
102 return CB_ERR;
103 }
104 virtual int FindStringExact(int /*nIndexStart*/, LPCTSTR /*lpsz*/) const
105 {
106 return CB_ERR;
107 }
108 virtual int SetTopIndex(int /*nIndex*/)
109 {
110 return CB_ERR;
111 }
112 virtual void SetCurSel(int /*nIndex*/)
113 {
114 }
115 virtual void GetText(int /*nIndex*/, CString& /*rString*/) const
116 {
117 }
118 virtual BOOL ProcessHookKeyDown(CXTPControlComboBox* pComboBox, UINT nChar, LPARAM lParam);
119 BOOL OnHookKeyDown(UINT nChar, LPARAM lParam);
120
121 virtual int GetCount() const
122 {
123 return CB_ERR;
124 }
125
126 // }}AFX_VIRUAL
127
129};
130
136class _XTP_EXT_CLASS CXTPControlComboBoxList : public CXTPControlComboBoxPopupBar
137{
138public:
143 CXTPControlComboBoxList();
144
145public:
150 virtual void CreateListBox();
151
156 CListBox* GetListBoxCtrl() const;
157
158protected:
171 int OnHookMessage(HWND hWnd, UINT nMessage, WPARAM& wParam, LPARAM& lParam, LRESULT& lResult);
172
181 virtual BOOL Popup(CXTPControlPopup* pControlPopup, BOOL bSelectFirst = FALSE);
182
194 virtual BOOL SetTrackingMode(int bMode, BOOL bSelectFirst, BOOL bKeyboard = FALSE);
195
202 virtual void DrawCommandBar(CDC* pDC, CRect rcClipBox);
203
213 virtual BOOL OnHookKeyDown(UINT nChar, LPARAM lParam);
214
221 virtual BOOL IsCustomizable() const
222 {
223 return FALSE;
224 }
225
231 virtual void DoPropExchange(CXTPPropExchange* pPX);
232
239 virtual void Copy(CXTPCommandBar* pCommandBar, BOOL bRecursive = FALSE);
240
241protected:
243 //{{AFX_VIRUAL(CXTPControlComboBoxList)
244
245 virtual int GetCurSel() const
246 {
247 return GetListBoxCtrl()->GetCurSel();
248 }
249 virtual int FindString(int nStartAfter, LPCTSTR lpszItem) const
250 {
251 return GetListBoxCtrl()->FindString(nStartAfter, lpszItem);
252 }
253 virtual int FindStringExact(int nIndexStart, LPCTSTR lpsz) const
254 {
255 return GetListBoxCtrl()->FindStringExact(nIndexStart, lpsz);
256 }
257 virtual int SetTopIndex(int nIndex)
258 {
259 return GetListBoxCtrl()->SetTopIndex(nIndex);
260 }
261 virtual void SetCurSel(int nIndex)
262 {
263 GetListBoxCtrl()->SetCurSel(nIndex);
264 }
265 virtual void GetText(int nIndex, CString& rString) const
266 {
267 GetListBoxCtrl()->GetText(nIndex, rString);
268 }
269 //}}AFX_VIRUAL
272protected:
274 DECLARE_MESSAGE_MAP()
275
276 //{{AFX_MSG(CXTPControlComboBoxList)
277 afx_msg void OnMouseMove(UINT nFlags, CPoint point);
278 afx_msg void OnLButtonUp(UINT nFlags, CPoint point);
279 afx_msg void OnNcPaint();
280 afx_msg BOOL OnEraseBkgnd(CDC* pDC);
281 afx_msg void OnPaint();
282 afx_msg void OnLButtonDown(UINT nFlags, CPoint point);
283
284 //}}AFX_MSG
296 BOOL ProcessHookKeyDown(CXTPControlComboBox* pComboBox, UINT nChar, LPARAM lParam);
297
305 virtual void DrawItem(LPDRAWITEMSTRUCT lpDrawItemStruct);
306
314 virtual void MeasureItem(LPMEASUREITEMSTRUCT lpMeasureItemStruct);
315
316private:
317 DECLARE_XTP_COMMANDBAR(CXTPControlComboBoxList)
318 friend class CXTPControlComboBox;
319
320 int m_nListIconId;
321};
322
324
329class _XTP_EXT_CLASS CXTPControlComboBoxEditCtrl : public CXTPCommandBarEditCtrl
330{
331public:
338 CXTPControlComboBox* GetControlComboBox() const;
339
340protected:
345 void UpdateCharFormat();
346
348 DECLARE_MESSAGE_MAP()
349
350 BOOL OnWndMsg(UINT message, WPARAM wParam, LPARAM lParam, LRESULT* pResult);
351
352 //{{AFX_MSG(CXTPControlComboBoxEditCtrl)
353 afx_msg void OnSetFocus(CWnd* pOldWnd);
354 afx_msg void OnKillFocus(CWnd* pNewWnd);
355 afx_msg void OnMouseMove(UINT nFlags, CPoint point);
356 afx_msg void OnDestroy();
357 afx_msg void OnLButtonDown(UINT nFlags, CPoint point);
358 afx_msg void OnRButtonDown(UINT nFlags, CPoint point);
359 afx_msg void OnContextMenu(CWnd* pWnd, CPoint point);
360 afx_msg void OnEditChanged();
361 afx_msg LRESULT OnEnableDisable(WPARAM, LPARAM);
362 afx_msg LRESULT OnWindowFromPoint(WPARAM, LPARAM);
363 afx_msg void OnShellAutoCompleteStart();
364 afx_msg void OnKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags);
365 //}}AFX_MSG
368protected:
369 CXTPControlComboBox* m_pControl;
371private:
372 friend class CXTPControlComboBox;
373};
374
380class _XTP_EXT_CLASS CXTPControlComboBox : public CXTPControlPopup
381{
382public:
388 CXTPControlComboBox(CXTPCommandBars* pCommandBars = NULL);
389
394 virtual ~CXTPControlComboBox();
395
396public:
405 DWORD GetEditStyle() const;
406
414 void SetEditStyle(DWORD dwStyle);
415
428 void SetDropDownListStyle(BOOL bSet = TRUE);
429
438 BOOL GetDropDownListStyle() const;
439
445 void SetDropDownWidth(int nWidth);
446
452 void SetDropDownItemCount(int nDropDownItemCount);
453
460 int GetDropDownWidth() const;
461
470 int AddString(LPCTSTR lpsz);
471
478 int GetCount() const;
479
486 void GetLBText(int nIndex, CString& str) const;
487
492 void ResetContent();
493
507 int FindStringExact(int nIndexStart, LPCTSTR lpsz) const;
508
520 int InsertString(int nIndex, LPCTSTR lpsz);
521
528 virtual CString GetListBoxText() const;
529
536 CXTPControlComboBoxEditCtrl* GetEditCtrl() const;
537
543 void SetCurSel(int nIndex);
544
552 int GetCurSel() const;
553
561 BOOL GetDroppedState() const;
562
569 CString GetEditText() const;
570
577 void ModifyListBoxStyle(DWORD dwRemove, DWORD dwAdd);
578
586 void SetEditText(const CString& lpszText);
587
599 void SetEditHint(LPCTSTR lpszEditHint);
600
610 CString GetEditHint() const;
611
617 virtual CHARFORMAT2 GetDefaultCharFormat();
618
635 void EnableShellAutoComplete(DWORD dwFlags = SHACF_FILESYSTEM | SHACF_URLALL);
636
642 void EnableAutoComplete(BOOL bAutoComplete = TRUE);
643
664 int FindString(int nStartAfter, LPCTSTR lpszItem) const;
665
674 DWORD_PTR GetItemData(int nIndex) const;
675
685 int SetItemData(int nIndex, DWORD_PTR dwItemData);
686
692 void DeleteItem(long nIndex);
693
698 void OnEnabledChanged();
699
705 void DoPropExchange(CXTPPropExchange* pPX);
706
714 virtual BOOL Compare(CXTPControl* pOther);
715
724 int GetLabelWidth() const;
725
733 void SetLabelWidth(int nLabelWidth);
734
741 virtual BOOL IsCaptionVisible() const;
742
749 BOOL IsImageVisible() const;
750
759 int GetThumbWidth() const;
760
768 void SetThumbWidth(int nThumbWidth);
769
775 BOOL HasFocus() const;
776
783 virtual void DrawEditText(CDC* pDC, CRect rcText);
784
789 CListBox* GetListBoxCtrl() const;
790
795 CXTPControlComboBoxPopupBar* GetComboBoxPopupBar() const;
796
802 void SetEditIconId(int nId);
803
810 int GetEditIconId() const;
816 void SetListIconId(int nId);
817
824 int GetListIconId() const;
825
828 // deprecated
829 virtual CString GetText() const
830 {
831 return GetListBoxText();
832 }
840 virtual void SetFocused(BOOL bFocused);
841
848 virtual BOOL IsFocused() const;
849
854 virtual void OnEditChanged();
855
860 virtual void OnSelChanged();
861
866 virtual void OnExecute();
867
875 virtual void SetHideFlags(DWORD dwFlags);
876
884 virtual void OnActionChanged(int nProperty);
885
893 virtual void OnActionChanging(int nProperty);
894
903 void SetTextLimit(int nTextLimit);
904
914 int GetTextLimit() const;
915
916protected:
924 virtual BOOL IsFocusable() const;
925
931 virtual CXTPControlComboBoxEditCtrl* CreateEditControl();
932
937 void OnMouseHover();
938
944 virtual void OnSetFocus(CWnd* pOldWnd);
945
950 virtual void OnKillFocus();
951
957 virtual void DeflateEditRect(CRect& rcControl);
958
966 BOOL OnSetSelected(int bSelected);
967
973 void SetRect(CRect rcControl);
974
981 void OnClick(BOOL bKeyboard = FALSE, CPoint pt = CPoint(0, 0));
982
987 virtual void OnUnderlineActivate();
988
995 void Copy(CXTPControl* pControl, BOOL bRecursive = FALSE);
996
1005 BOOL OnHookKeyDown(UINT nChar, LPARAM lParam);
1006
1012 void SetParent(CXTPCommandBar* pParent);
1013
1064 virtual void OnCalcDynamicSize(DWORD dwMode);
1065
1073 virtual BOOL OnSetPopup(BOOL bPopup);
1074
1081 virtual BOOL IsCustomizeResizeAllow() const;
1082
1090 virtual int GetCustomizeMinWidth() const;
1091
1097 virtual void OnRemoved();
1098
1104 virtual void OnMouseMove(CPoint point);
1105
1107protected:
1108public:
1109 void UpdatePopupSelection();
1110
1111protected:
1112 BOOL IsValidList() const;
1113 void _SetEditText(const CString& lpszText);
1114 CString _GetEditText() const;
1115 virtual BOOL OnHookMouseWheel(UINT nFlags, short zDelta, CPoint pt);
1116 virtual void OnThemeChanged();
1117 void ShowHideEditControl();
1118
1119 virtual void DrawItem(LPDRAWITEMSTRUCT lpDrawItemStruct);
1120 virtual void MeasureItem(LPMEASUREITEMSTRUCT lpMeasureItemStruct);
1123# ifdef _XTP_COMMANDBARS_ACTIVEX
1126 DECLARE_DISPATCH_MAP()
1127 DECLARE_INTERFACE_MAP()
1128
1129 DECLARE_OLETYPELIB_EX(CXTPControlComboBox);
1130
1131 afx_msg void OleSetDropDownWidth(long nWidth);
1132 afx_msg void OleSetDropDownListStyle(BOOL bSet);
1133 afx_msg void OleAddItem(LPCTSTR strText, const VARIANT* varIndex);
1134 afx_msg BSTR OleList(long nIndex);
1135 afx_msg void OleClear();
1136 afx_msg void OleRemoveItem(long nIndex);
1137
1138 afx_msg BSTR OleGetText();
1139 afx_msg void OleSetText(LPCTSTR str);
1140 afx_msg long OleGetListIndex();
1141 afx_msg void OleSetListIndex(long nIndex);
1142 afx_msg long OleFindItem(LPCTSTR strText);
1143 afx_msg int OleGetCount();
1144 afx_msg HWND OleGetEditHandle();
1145
1146 afx_msg long OleGetItemData(int nIndex);
1147 afx_msg void OleSetItemData(int nIndex, long nNumber);
1148 afx_msg BSTR OleGetEditHint();
1149 afx_msg DWORD OleGetShellAutoComplete();
1150 afx_msg void OleSetShellAutoComplete(DWORD dwShellAutoCompleteFlags);
1151 afx_msg BOOL OleGetThemedItems();
1152 afx_msg void OleSetThemedItems(BOOL bThemedItems);
1153
1154 afx_msg void OleSetEditIconId(int nId);
1155 afx_msg int OleGetEditIconId();
1156 afx_msg void OleSetListIconId(int nId);
1157 afx_msg int OleGetListIconId();
1158
1159 enum
1160 {
1161 dispidStyle = 50L,
1162 dispidAddItem = 51L,
1163 dispidDropDownWidth = 52L,
1164 dispidDropDownListStyle = 53L,
1165 dispidWidth = 54L,
1166 dispidList = 55L,
1167 dispidClear = 56L,
1168 dispidListCount = 57L,
1169 dispidRemoveItem = 58L,
1170 dispidText = 59L,
1171 dispidListIndex = 60L,
1172 dispidFindItem = 61L,
1173 };
1174
1176# endif
1178 DECLARE_XTP_CONTROL(CXTPControlComboBox)
1180protected:
1181 CXTPControlComboBoxEditCtrl* m_pEdit;
1182 BOOL m_bDropDown;
1183 XTPButtonStyle m_comboStyle;
1184 int m_nLastSel;
1185 CString m_strLastText;
1186 BOOL m_bDelayDestroy;
1187 BOOL m_bDelayReposition;
1188 int m_nLabelWidth;
1189 int m_nThumbWidth;
1190 CString m_strEditHint;
1192 BOOL m_bAutoComplete;
1193 BOOL m_bIgnoreAutoComplete;
1194 DWORD m_dwShellAutoCompleteFlags;
1195 BOOL m_bFocused;
1196 int m_nEditIconId;
1197 BOOL m_bSelEndOk;
1198 int m_nDropDownItemCount;
1200 mutable CString m_strEditText;
1201 mutable BOOL m_bEditChanged;
1202 int m_nTextLimit;
1205 CXTPControlComboBoxAutoCompleteWnd* m_pAutoCompleteWnd;
1206 DWORD m_dwEditStyle;
1208private:
1209 int m_nCurSel;
1210 BOOL m_bIgnoreSelection;
1211
1212 friend class CXTPControlComboBoxList;
1213 friend class CXTPControlComboBoxEditCtrl;
1214};
1215
1217
1218AFX_INLINE void CXTPControlComboBox::SetDropDownWidth(int nWidth)
1219{
1220 m_pCommandBar->SetWidth(nWidth);
1221}
1222AFX_INLINE int CXTPControlComboBox::AddString(LPCTSTR lpsz)
1223{
1224 return GetListBoxCtrl()->AddString(lpsz);
1225}
1226AFX_INLINE int CXTPControlComboBox::GetCount() const
1227{
1228 return GetListBoxCtrl()->GetCount();
1229}
1230AFX_INLINE void CXTPControlComboBox::GetLBText(int nIndex, CString& str) const
1231{
1232 GetComboBoxPopupBar()->GetText(nIndex, str);
1233}
1234AFX_INLINE void CXTPControlComboBox::ResetContent()
1235{
1236 GetListBoxCtrl()->ResetContent();
1237}
1238AFX_INLINE int CXTPControlComboBox::FindStringExact(int nIndexStart, LPCTSTR lpsz) const
1239{
1240 return GetComboBoxPopupBar()->FindStringExact(nIndexStart, lpsz);
1241}
1242AFX_INLINE int CXTPControlComboBox::InsertString(int nIndex, LPCTSTR lpsz)
1243{
1244 return GetListBoxCtrl()->InsertString(nIndex, lpsz);
1245}
1246AFX_INLINE CXTPControlComboBoxEditCtrl* CXTPControlComboBox::GetEditCtrl() const
1247{
1248 return m_pEdit;
1249}
1250AFX_INLINE int CXTPControlComboBox::FindString(int nStartAfter, LPCTSTR lpszItem) const
1251{
1252 return GetComboBoxPopupBar()->FindString(nStartAfter, lpszItem);
1253}
1254AFX_INLINE DWORD_PTR CXTPControlComboBox::GetItemData(int nIndex) const
1255{
1256 return (DWORD_PTR)GetListBoxCtrl()->GetItemData(nIndex);
1257}
1258AFX_INLINE int CXTPControlComboBox::SetItemData(int nIndex, DWORD_PTR dwItemData)
1259{
1260 return GetListBoxCtrl()->SetItemData(nIndex, dwItemData);
1261}
1262AFX_INLINE BOOL CXTPControlComboBox::IsCustomizeResizeAllow() const
1263{
1264 return TRUE;
1265}
1266AFX_INLINE CXTPControlComboBox* CXTPControlComboBoxEditCtrl::GetControlComboBox() const
1267{
1268 return m_pControl;
1269}
1270AFX_INLINE int CXTPControlComboBox::GetLabelWidth() const
1271{
1272 return m_nLabelWidth;
1273}
1274AFX_INLINE int CXTPControlComboBox::GetEditIconId() const
1275{
1276 return m_nEditIconId;
1277}
1278AFX_INLINE int CXTPControlComboBox::GetThumbWidth() const
1279{
1280 return m_nThumbWidth;
1281}
1283AFX_INLINE void CXTPControlComboBox::OnThemeChanged()
1284{
1285 m_bDelayReposition = TRUE;
1286}
1288AFX_INLINE void CXTPControlComboBox::SetDropDownItemCount(int nDropDownItemCount)
1289{
1290 m_nDropDownItemCount = nDropDownItemCount;
1291}
1293# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
1294#endif //#if !defined(__XTPCONTOLCOMBOBOX_H__)
XTPButtonStyle
XTPButtonStyle
Button's styles.
Definition XTPCommandBarsDefines.h:197
DECLARE_XTP_CONTROL
#define DECLARE_XTP_CONTROL(class_name)
This macro generates the C++ header code necessary for a CXTPControl-derived class that can be serial...
Definition XTPCommandBarsDefines.h:1169
DECLARE_XTP_COMMANDBAR
#define DECLARE_XTP_COMMANDBAR(class_name)
This macro generates the C++ header code necessary for a CXTPCommandBar-derived class that can be ser...
Definition XTPCommandBarsDefines.h:1234
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCommandBarEditCtrl
CXTPCommandBarEditCtrl is a CEdit derived class.
Definition XTPControlEdit.h:72
CXTPCommandBar
CXTPCommandBar is a CWnd derived class.
Definition XTPCommandBar.h:66
CXTPCommandBars
CXTPCommandBars is a standalone class.
Definition XTPCommandBars.h:165
CXTPControlComboBoxEditCtrl
Inplace Edit control of the combo.
Definition XTPControlComboBox.h:330
CXTPControlComboBoxEditCtrl::UpdateCharFormat
void UpdateCharFormat()
This method is called to refresh the char format of edit control.
CXTPControlComboBoxEditCtrl::GetControlComboBox
CXTPControlComboBox * GetControlComboBox() const
Retrieves parent CXTPControlComboBox object.
Definition XTPControlComboBox.h:1266
CXTPControlComboBox
CXTPControlComboBox is a CXTPControl derived class.
Definition XTPControlComboBox.h:381
CXTPControlComboBox::SetListIconId
void SetListIconId(int nId)
Call this member to set the combo list icon's identifier.
CXTPControlComboBox::OnEditChanged
virtual void OnEditChanged()
This method is called when edit control's text is changed.
CXTPControlComboBox::GetCount
int GetCount() const
Call this member to retrieve the number of items in a list box.
Definition XTPControlComboBox.h:1226
CXTPControlComboBox::GetLabelWidth
int GetLabelWidth() const
Call this method to get the width of a label.
Definition XTPControlComboBox.h:1270
CXTPControlComboBox::Copy
void Copy(CXTPControl *pControl, BOOL bRecursive=FALSE)
This method is called to copy the control.
CXTPControlComboBox::SetItemData
int SetItemData(int nIndex, DWORD_PTR dwItemData)
This method sets the 32-bit value associated with the specified item in a combobox.
Definition XTPControlComboBox.h:1258
CXTPControlComboBox::SetRect
void SetRect(CRect rcControl)
Call this member to set the bounding rectangle of the control.
CXTPControlComboBox::m_nEditIconId
int m_nEditIconId
Edit Icon identifier.
Definition XTPControlComboBox.h:1196
CXTPControlComboBox::SetParent
void SetParent(CXTPCommandBar *pParent)
This method is called to assign a parent command bar object.
CXTPControlComboBox::OnActionChanged
virtual void OnActionChanged(int nProperty)
This method is called when an action property is changed.
CXTPControlComboBox::m_bAutoComplete
BOOL m_bAutoComplete
TRUE if Auto Complete is enabled.
Definition XTPControlComboBox.h:1192
CXTPControlComboBox::DoPropExchange
void DoPropExchange(CXTPPropExchange *pPX)
Either reads this object from or writes this object to an archive.
CXTPControlComboBox::m_bIgnoreAutoComplete
BOOL m_bIgnoreAutoComplete
TRUE to disable auto complete till next key event.
Definition XTPControlComboBox.h:1193
CXTPControlComboBox::OnMouseHover
void OnMouseHover()
Called after the mouse hovers over the control.
CXTPControlComboBox::OnSetFocus
virtual void OnSetFocus(CWnd *pOldWnd)
This method is called when the edit control gets focus.
CXTPControlComboBox::GetDropDownWidth
int GetDropDownWidth() const
Call this member to retrieve the dropdown list width.
CXTPControlComboBox::IsCustomizeResizeAllow
virtual BOOL IsCustomizeResizeAllow() const
This member checks if the user can resize the control.
Definition XTPControlComboBox.h:1262
CXTPControlComboBox::OnEnabledChanged
void OnEnabledChanged()
This method is called when the control's enabled state is changed.
CXTPControlComboBox::SetDropDownItemCount
void SetDropDownItemCount(int nDropDownItemCount)
Call this member to set the count of items in the dropdown list.
Definition XTPControlComboBox.h:1288
CXTPControlComboBox::IsImageVisible
BOOL IsImageVisible() const
Call this member to determine if the icon is visible for a combobox control.
CXTPControlComboBox::m_dwEditStyle
DWORD m_dwEditStyle
Edit style.
Definition XTPControlComboBox.h:1206
CXTPControlComboBox::SetEditStyle
void SetEditStyle(DWORD dwStyle)
Call this member to set the style of edit control.
CXTPControlComboBox::OnRemoved
virtual void OnRemoved()
This method is called when a control is removed from the parent controls collection.
CXTPControlComboBox::m_pAutoCompleteWnd
CXTPControlComboBoxAutoCompleteWnd * m_pAutoCompleteWnd
Auto Complete hook window.
Definition XTPControlComboBox.h:1205
CXTPControlComboBox::GetEditCtrl
CXTPControlComboBoxEditCtrl * GetEditCtrl() const
Call this member to get the edit control of the combobox control.
Definition XTPControlComboBox.h:1246
CXTPControlComboBox::AddString
int AddString(LPCTSTR lpsz)
Call this member function to add a string to a list box.
Definition XTPControlComboBox.h:1222
CXTPControlComboBox::m_bDelayReposition
BOOL m_bDelayReposition
Need to reposition control.
Definition XTPControlComboBox.h:1187
CXTPControlComboBox::GetComboBoxPopupBar
CXTPControlComboBoxPopupBar * GetComboBoxPopupBar() const
CXTPControlComboBox::OnHookKeyDown
BOOL OnHookKeyDown(UINT nChar, LPARAM lParam)
This method is called when a non-system key is pressed.
CXTPControlComboBox::m_pEdit
CXTPControlComboBoxEditCtrl * m_pEdit
Child edit control.
Definition XTPControlComboBox.h:1181
CXTPControlComboBox::m_bFocused
BOOL m_bFocused
TRUE if control is focused.
Definition XTPControlComboBox.h:1195
CXTPControlComboBox::InsertString
int InsertString(int nIndex, LPCTSTR lpsz)
Call this member to insert a string into the list box of a combobox control.
Definition XTPControlComboBox.h:1242
CXTPControlComboBox::GetItemData
DWORD_PTR GetItemData(int nIndex) const
This method retrieves the application-supplied, 32-bit value associated with the specified combobox i...
Definition XTPControlComboBox.h:1254
CXTPControlComboBox::m_nLabelWidth
int m_nLabelWidth
Width of the label.
Definition XTPControlComboBox.h:1188
CXTPControlComboBox::GetLBText
void GetLBText(int nIndex, CString &str) const
Call this member to retrieve a string from the list box of a combobox control.
Definition XTPControlComboBox.h:1230
CXTPControlComboBox::OnExecute
virtual void OnExecute()
This method is called when the control is executed.
CXTPControlComboBox::GetCurSel
int GetCurSel() const
Call this member function to determine which item in the combobox is selected.
CXTPControlComboBox::OnCalcDynamicSize
virtual void OnCalcDynamicSize(DWORD dwMode)
This method is called before recalculating the parent command bar size to calculate the dimensions of...
CXTPControlComboBox::ModifyListBoxStyle
void ModifyListBoxStyle(DWORD dwRemove, DWORD dwAdd)
Call this member to modify the style of a list box.
CXTPControlComboBox::CXTPControlComboBox
CXTPControlComboBox(CXTPCommandBars *pCommandBars=NULL)
Constructs a CXTPControlComboBox object.
CXTPControlComboBox::FindString
int FindString(int nStartAfter, LPCTSTR lpszItem) const
This method finds the first string in a list box that contains the specified prefix,...
Definition XTPControlComboBox.h:1250
CXTPControlComboBox::GetDroppedState
BOOL GetDroppedState() const
Call the GetDroppedState member function to determine whether the list box of a drop-down combobox is...
CXTPControlComboBox::GetEditText
CString GetEditText() const
Call this member to get the edit text.
CXTPControlComboBox::GetEditHint
CString GetEditHint() const
Call this member to get the grayed-out text displayed in the edit control which provides a helpful de...
CXTPControlComboBox::DeflateEditRect
virtual void DeflateEditRect(CRect &rcControl)
This method is called to get the real rect of an edit control of a combobox.
CXTPControlComboBox::SetDropDownListStyle
void SetDropDownListStyle(BOOL bSet=TRUE)
Call this member to insert/delete an edit box in the combobox when the control has focus.
CXTPControlComboBox::GetListBoxCtrl
CListBox * GetListBoxCtrl() const
CXTPControlComboBox::m_nThumbWidth
int m_nThumbWidth
Width of the thumb area.
Definition XTPControlComboBox.h:1189
CXTPControlComboBox::m_bDelayDestroy
BOOL m_bDelayDestroy
TRUE if need to recreate control.
Definition XTPControlComboBox.h:1186
CXTPControlComboBox::OnUnderlineActivate
virtual void OnUnderlineActivate()
This method is called when the user activates a control using its underline.
CXTPControlComboBox::GetDropDownListStyle
BOOL GetDropDownListStyle() const
Call this member to determine if the combobox has an edit control.
CXTPControlComboBox::ResetContent
void ResetContent()
Call this member to remove all items from the list box of a combobox control.
Definition XTPControlComboBox.h:1234
CXTPControlComboBox::OnSelChanged
virtual void OnSelChanged()
This method is called when the selected string is changed.
CXTPControlComboBox::DeleteItem
void DeleteItem(long nIndex)
Call this member function to delete a string.
CXTPControlComboBox::SetCurSel
void SetCurSel(int nIndex)
Call this member to select a string in the list box of a combobox.
CXTPControlComboBox::m_bDropDown
BOOL m_bDropDown
TRUE if the combo is dropdown.
Definition XTPControlComboBox.h:1182
CXTPControlComboBox::GetListIconId
int GetListIconId() const
Call this member to get the combo list icon's identifier.
CXTPControlComboBox::SetThumbWidth
void SetThumbWidth(int nThumbWidth)
This method is called to set the width of a thumb button.
CXTPControlComboBox::OnActionChanging
virtual void OnActionChanging(int nProperty)
This method is called when an action property is about to be changed.
CXTPControlComboBox::SetHideFlags
virtual void SetHideFlags(DWORD dwFlags)
This method is called to hide the control.
CXTPControlComboBox::CreateEditControl
virtual CXTPControlComboBoxEditCtrl * CreateEditControl()
This method creates an edit control.
CXTPControlComboBox::m_bSelEndOk
BOOL m_bSelEndOk
TRUE if user selects a list item.
Definition XTPControlComboBox.h:1197
CXTPControlComboBox::OnSetSelected
BOOL OnSetSelected(int bSelected)
This method is called when the control becomes selected.
CXTPControlComboBox::GetListBoxText
virtual CString GetListBoxText() const
Call this member to get the currently selected item's text.
CXTPControlComboBox::GetDefaultCharFormat
virtual CHARFORMAT2 GetDefaultCharFormat()
This method is called to get the default char format of rich edit text.
CXTPControlComboBox::OnClick
void OnClick(BOOL bKeyboard=FALSE, CPoint pt=CPoint(0, 0))
This method is called when the user clicks the control.
CXTPControlComboBox::GetThumbWidth
int GetThumbWidth() const
Call this method to get the width of a thumb button.
Definition XTPControlComboBox.h:1278
CXTPControlComboBox::SetDropDownWidth
void SetDropDownWidth(int nWidth)
Call this member to set the width of the dropdown list.
Definition XTPControlComboBox.h:1218
CXTPControlComboBox::EnableShellAutoComplete
void EnableShellAutoComplete(DWORD dwFlags=SHACF_FILESYSTEM|SHACF_URLALL)
This member function enables or disables shell auto completion.
CXTPControlComboBox::OnSetPopup
virtual BOOL OnSetPopup(BOOL bPopup)
This method is called to pop-up the control.
CXTPControlComboBox::GetEditStyle
DWORD GetEditStyle() const
Call this member to get the style of edit control.
CXTPControlComboBox::m_nLastSel
int m_nLastSel
Last user selected index (used during display of list box).
Definition XTPControlComboBox.h:1184
CXTPControlComboBox::IsFocusable
virtual BOOL IsFocusable() const
This method is called to check if a control can accept focus.
CXTPControlComboBox::SetEditHint
void SetEditHint(LPCTSTR lpszEditHint)
Call this member to set the grayed-out text displayed in the edit control which provides a helpful de...
CXTPControlComboBox::SetEditIconId
void SetEditIconId(int nId)
Call this member to set the edit icon's identifier.
CXTPControlComboBox::m_strLastText
CString m_strLastText
Last Text before user select focus and change it.
Definition XTPControlComboBox.h:1185
CXTPControlComboBox::OnMouseMove
virtual void OnMouseMove(CPoint point)
This member is called when the mouse cursor moves.
CXTPControlComboBox::m_dwShellAutoCompleteFlags
DWORD m_dwShellAutoCompleteFlags
Shell auto complete flags.
Definition XTPControlComboBox.h:1194
CXTPControlComboBox::m_bEditChanged
BOOL m_bEditChanged
TRUE if Edit Text is changed.
Definition XTPControlComboBox.h:1201
CXTPControlComboBox::~CXTPControlComboBox
virtual ~CXTPControlComboBox()
Destroys a CXTPControlComboBox object, handles cleanup and deallocation.
CXTPControlComboBox::GetEditIconId
int GetEditIconId() const
Call this member to get the edit icon's identifier.
Definition XTPControlComboBox.h:1274
CXTPControlComboBox::m_comboStyle
XTPButtonStyle m_comboStyle
Style of the combobox.
Definition XTPControlComboBox.h:1183
CXTPControlComboBox::GetCustomizeMinWidth
virtual int GetCustomizeMinWidth() const
This member returns the minimum width that the combobox can be sized to by the user while in customiz...
CXTPControlComboBox::DrawEditText
virtual void DrawEditText(CDC *pDC, CRect rcText)
This method draws the text of control if the style is CBS_DROPDOWNLIST.
CXTPControlComboBox::SetTextLimit
void SetTextLimit(int nTextLimit)
This method sets the maximum text length that the user may enter into an edit control.
CXTPControlComboBox::SetFocused
virtual void SetFocused(BOOL bFocused)
Call this member to set focus to the control.
CXTPControlComboBox::Compare
virtual BOOL Compare(CXTPControl *pOther)
Call this member to compare controls.
CXTPControlComboBox::m_nTextLimit
int m_nTextLimit
The maximum number of characters that can be entered into an edit control.
Definition XTPControlComboBox.h:1202
CXTPControlComboBox::SetEditText
void SetEditText(const CString &lpszText)
Call this member to set the edit control text.
CXTPControlComboBox::SetLabelWidth
void SetLabelWidth(int nLabelWidth)
Call this method to set the width of a label.
CXTPControlComboBox::FindStringExact
int FindStringExact(int nIndexStart, LPCTSTR lpsz) const
Call this member to find the first list-box string (in a combobox) that matches the string specified ...
Definition XTPControlComboBox.h:1238
CXTPControlComboBox::IsFocused
virtual BOOL IsFocused() const
Call this member to get the focused state of the control.
CXTPControlComboBox::IsCaptionVisible
virtual BOOL IsCaptionVisible() const
Call this member to determine if the caption of the control is visible.
CXTPControlComboBox::GetTextLimit
int GetTextLimit() const
This method gets the maximum text length that the user may enter into an edit control.
CXTPControlComboBox::m_nDropDownItemCount
int m_nDropDownItemCount
Maximum drop down items.
Definition XTPControlComboBox.h:1198
CXTPControlComboBox::m_strEditText
CString m_strEditText
Edit text.
Definition XTPControlComboBox.h:1200
CXTPControlComboBox::m_strEditHint
CString m_strEditHint
Grayed-out text displayed in the edit control that displayed a helpful description.
Definition XTPControlComboBox.h:1190
CXTPControlComboBox::OnKillFocus
virtual void OnKillFocus()
This method is called when the edit control loses focus.
CXTPControlComboBox::HasFocus
BOOL HasFocus() const
Call this method to determine if control has focus.
CXTPControlComboBox::EnableAutoComplete
void EnableAutoComplete(BOOL bAutoComplete=TRUE)
This member function enables or disables auto completion.
CXTPControlComboBoxList
CXTPControlComboBoxList is a CXTPControlComboBoxPopupBar derived class.
Definition XTPControlComboBox.h:137
CXTPControlComboBoxList::DoPropExchange
virtual void DoPropExchange(CXTPPropExchange *pPX)
Either reads this object from or writes this object to an archive.
CXTPControlComboBoxList::DrawCommandBar
virtual void DrawCommandBar(CDC *pDC, CRect rcClipBox)
This method is called to draw the command bar in the given context.
CXTPControlComboBoxList::SetTrackingMode
virtual BOOL SetTrackingMode(int bMode, BOOL bSelectFirst, BOOL bKeyboard=FALSE)
Call this member to change the tracking state.
CXTPControlComboBoxList::CreateListBox
virtual void CreateListBox()
Creates list box.
CXTPControlComboBoxList::OnHookMessage
int OnHookMessage(HWND hWnd, UINT nMessage, WPARAM &wParam, LPARAM &lParam, LRESULT &lResult)
This member function is called by WindowProc, or is called during message reflection.
CXTPControlComboBoxList::CXTPControlComboBoxList
CXTPControlComboBoxList()
Constructs a CXTPControlButton object.
CXTPControlComboBoxList::GetListBoxCtrl
CListBox * GetListBoxCtrl() const
CXTPControlComboBoxList::OnHookKeyDown
virtual BOOL OnHookKeyDown(UINT nChar, LPARAM lParam)
The framework calls this member function when a non-system key is pressed.
CXTPControlComboBoxList::Popup
virtual BOOL Popup(CXTPControlPopup *pControlPopup, BOOL bSelectFirst=FALSE)
This method is called, then the pop-up bar becomes visible.
CXTPControlComboBoxList::IsCustomizable
virtual BOOL IsCustomizable() const
Call this member to retrieve the customize mode of the command bars.
Definition XTPControlComboBox.h:221
CXTPControlComboBoxList::Copy
virtual void Copy(CXTPCommandBar *pCommandBar, BOOL bRecursive=FALSE)
This method makes a copy of the command bar.
CXTPControlComboBoxPopupBar
CXTPControlComboBoxPopupBar is a CXTPPopupBar derived class.
Definition XTPControlComboBox.h:80
CXTPControlComboBoxPopupBar::CXTPControlComboBoxPopupBar
CXTPControlComboBoxPopupBar()
Constructs a CXTPControlComboBoxPopupBar object.
CXTPControl
CXTPControl is a CXTPCmdTarget derived class.
Definition XTPControl.h:841
CXTPControl::OnThemeChanged
virtual void OnThemeChanged()
This method is called when the paint manager theme is changed.
Definition XTPControl.h:2782
CXTPControlPopup
CXTPControlPopup is a CXTPControl derived class.
Definition XTPControlPopup.h:42
CXTPHookManagerHookAble
HookAble interface.
Definition XTPHookManager.h:42
CXTPHookManagerHookAble::OnHookMessage
virtual int OnHookMessage(HWND hWnd, UINT nMessage, WPARAM &wParam, LPARAM &lParam, LRESULT &lResult)
This member function is called by WindowProc, or is called during message reflection.
CXTPPopupBar
CXTPPopupBar is a CXTPCommandBar derived class.
Definition XTPPopupBar.h:42
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72


Toolkit Pro: XTPMarkupBorder.h Source File

  • Source
  • Markup
  • Controls
XTPMarkupBorder.h
Go to the documentation of this file.
1
23#if !defined(__XTPMARKUPBORDER_H__)
24# define __XTPMARKUPBORDER_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPMarkupBrush;
34class CXTPMarkupBuilder;
35
41class _XTP_EXT_CLASS CXTPMarkupBorder : public CXTPMarkupDecorator
42{
44 DECLARE_MARKUPCLASS(CXTPMarkupBorder);
46protected:
51 CXTPMarkupBorder();
52
57 virtual ~CXTPMarkupBorder();
58
59public:
70 void SetPadding(int nLeft, int nTop, int nRight, int nBottom);
71
79 void SetPadding(int nPadding);
80
93 CXTPMarkupThickness* GetPadding() const;
94
103 void SetBorderThickness(int nLeft, int nTop, int nRight, int nBottom);
104
110 void SetBorderThickness(int nBorderThickness);
111
120 CXTPMarkupThickness* GetBorderThickness() const;
121
127 void SetBackground(CXTPMarkupBrush* pBrush);
128
135 CXTPMarkupBrush* GetBackground() const;
136
142 void SetBorderBrush(CXTPMarkupBrush* pBrush);
143
150 CXTPMarkupBrush* GetBorderBrush() const;
151
158 void SetCornerRadius(int nCornerRadius);
159
169 CXTPMarkupThickness* GetCornerRadius() const;
170
179 CSize GetSize() const;
180
181protected:
183 // Implementation
184 virtual CSize MeasureOverride(CXTPMarkupDrawingContext* pDC, CSize szAvailableSize);
185 virtual CSize ArrangeOverride(CSize szFinalSize);
186 virtual void OnRender(CXTPMarkupDrawingContext* drawingContext);
187 virtual CXTPMarkupInputElement* InputHitTestOverride(CPoint point) const;
188
189public:
190 static CXTPMarkupDependencyProperty* m_pBackgroundProperty;
191 static CXTPMarkupDependencyProperty* m_pBorderThicknessProperty;
192 static CXTPMarkupDependencyProperty* m_pPaddingProperty;
193 static CXTPMarkupDependencyProperty* m_pBorderBrushProperty;
194 static CXTPMarkupDependencyProperty* m_pCornerRadiusProperty;
198public:
199 DECLARE_DISPATCH_MAP()
200# ifdef _XTP_ACTIVEX
201 DECLARE_INTERFACE_MAP()
202 DECLARE_OLETYPELIB_EX(CXTPMarkupBorder);
203# endif
204
205 afx_msg LPDISPATCH OleGetBackground();
206 afx_msg void OleSetBackground(LPDISPATCH lpBackground);
207 afx_msg LPDISPATCH OleGetBorderBrush();
208 afx_msg void OleSetBorderBrush(LPDISPATCH lpBackground);
209 afx_msg LPDISPATCH OleGetBorderThickness();
210 afx_msg void OleSetBorderThickness(LPDISPATCH lpThickness);
211 afx_msg LPDISPATCH OleGetPadding();
212 afx_msg void OleSetPadding(LPDISPATCH lpThickness);
213 afx_msg LPDISPATCH OleGetCornerRadius();
214 afx_msg void OleSetCornerRadius(LPDISPATCH lpThickness);
215 afx_msg LPDISPATCH OleGetChild();
216 afx_msg void OleSetChild(LPDISPATCH lpDisp);
217
219};
220
221# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
223#endif // !defined(__XTPMARKUPBORDER_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPMarkupBorder
CXTPMarkupBorder is a CXTPMarkupDecorator derived class.
Definition XTPMarkupBorder.h:42
CXTPMarkupBorder::GetCornerRadius
CXTPMarkupThickness * GetCornerRadius() const
Gets the corner radius of the border.
CXTPMarkupBorder::SetPadding
void SetPadding(int nLeft, int nTop, int nRight, int nBottom)
Sets a value that indicates the thickness of the padding space between the boundaries of the content ...
CXTPMarkupBorder::GetSize
CSize GetSize() const
Gets the total horizontal and vertical size of the padding, border, and margin.
CXTPMarkupBorder::GetBorderThickness
CXTPMarkupThickness * GetBorderThickness() const
Gets the thickness of the border.
CXTPMarkupBorder::GetBackground
CXTPMarkupBrush * GetBackground() const
Gets the background brush of the border object.
CXTPMarkupBorder::SetBorderBrush
void SetBorderBrush(CXTPMarkupBrush *pBrush)
Sets the border brush for the border object.
CXTPMarkupBorder::GetBorderBrush
CXTPMarkupBrush * GetBorderBrush() const
Gets the border brush of the border object.
CXTPMarkupBorder::GetPadding
CXTPMarkupThickness * GetPadding() const
Retrieves a value that indicates the thickness of the padding space between the boundaries of the con...
CXTPMarkupBorder::SetCornerRadius
void SetCornerRadius(int nCornerRadius)
Sets the corner radius for the border.
CXTPMarkupBorder::~CXTPMarkupBorder
virtual ~CXTPMarkupBorder()
Destroys a CXTPMarkupBorder object, handles cleanup and deallocation.
CXTPMarkupBorder::SetPadding
void SetPadding(int nPadding)
Sets a value that indicates the thickness of the padding space between the boundaries of the content ...
CXTPMarkupBorder::SetBorderThickness
void SetBorderThickness(int nBorderThickness)
Sets the thickness of the border.
CXTPMarkupBorder::CXTPMarkupBorder
CXTPMarkupBorder()
Constructs a CXTPMarkupBorder object.
CXTPMarkupBorder::SetBorderThickness
void SetBorderThickness(int nLeft, int nTop, int nRight, int nBottom)
Sets the thickness of the border.
CXTPMarkupBorder::SetBackground
void SetBackground(CXTPMarkupBrush *pBrush)
Sets the background brush for the border object.
CXTPMarkupDecorator
CXTPMarkupDecorator is a CXTPMarkupFrameworkElement derived class.
Definition XTPMarkupDecorator.h:44
CXTPMarkupThickness
The CXTPMarkupThickness class describes the thickness of the left, top, right, and bottom sides of a ...
Definition XTPMarkupThickness.h:42
CXTPMarkupVisual::InputHitTestOverride
virtual CXTPMarkupInputElement * InputHitTestOverride(CPoint point) const
Override this method in the derived class to provide visual hit testing of a child object.
CXTPMarkupVisual::OnRender
virtual void OnRender(CXTPMarkupDrawingContext *drawingContext)
When overridden in a derived class, participates in rendering operations that are directed by the lay...
Definition XTPMarkupInputElement.h:515


Toolkit Pro: XTPMarkupPathGeometryBuilder.h Source File

  • Source
  • Markup
  • Shapes
XTPMarkupPathGeometryBuilder.h
Go to the documentation of this file.
1
23#if !defined(__XTPMARKUPGEOMETRYBUILDER_H__)
24# define __XTPMARKUPGEOMETRYBUILDER_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
36enum XTPMarkupPathPointType
37{
38 xtpMarkupPathPointTypeStart = 0,
39 xtpMarkupPathPointTypeLine = 1,
40 xtpMarkupPathPointTypeBezier = 3,
41 xtpMarkupPathPointTypeCloseSubpath = 0x80,
42};
43
44struct MARKUP_POINTF
45{
46 float x;
47 float y;
48};
49
50class CXTPMarkupPathData;
51class CXTPMarkupBuilder;
52
53class _XTP_EXT_CLASS CXTPMarkupPathGeometryBuilder
54{
55public:
56 CXTPMarkupPathGeometryBuilder();
57
58public:
59 void Parse(CXTPMarkupBuilder* pBuilder, LPCWSTR lpszValue, int nLength);
60 CXTPMarkupPathData* CreateData() const;
61
62public:
63 void BeginFigure(float x, float y);
64 void BezierTo(float x1, float y1, float x2, float y2, float x3,
65 float y3);
66 void BezierTo(float x1, float y1, float x2, float y2);
67 void LineTo(float x, float y);
68
69 void ArcSegment(double xc, double yc, double th0, double th1, double rx, double ry,
70 double xAxisRotation);
71 void ArcTo(float x, float y, float rotationAngle, double xRadius, double yRadius,
72 BOOL isLargeArcFlag, BOOL sweepDirectionFlag);
73
74 void CloseFigure();
75
76private:
77 BOOL ReadToken();
78 BOOL SkipWhiteSpace(BOOL allowComma);
79 BOOL More() const;
80
81 void ThrowBadToken();
82
83 MARKUP_POINTF ReadSize(BOOL allowcomma);
84
85 MARKUP_POINTF ReadPoint(WCHAR cmd, BOOL allowcomma);
86 float ReadNumber(BOOL allowComma);
87 BOOL IsNumber(BOOL allowComma);
88
89 void EnsureFigure();
90 MARKUP_POINTF Reflect();
91
92private:
93 LPCWSTR m_lpszValue;
94 int m_nLength;
95 int m_nIndex;
96 BOOL m_bFigureStarted;
97 int m_nFillRule;
98
99 CArray<MARKUP_POINTF, MARKUP_POINTF&> m_arrPoints;
100 CArray<BYTE, BYTE> m_arrTypes;
101 WCHAR m_cToken;
102 CXTPMarkupBuilder* m_pBuilder;
103
104 MARKUP_POINTF m_secondLastPoint;
105 MARKUP_POINTF m_lastPoint;
106 MARKUP_POINTF m_lastStart;
107};
108
109# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
111#endif // !defined(__XTPMARKUPGEOMETRYBUILDER_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPMarkupPathPointType
XTPMarkupPathPointType
Defines a markup path point type.
Definition XTPMarkupPathGeometryBuilder.h:37
xtpMarkupPathPointTypeCloseSubpath
@ xtpMarkupPathPointTypeCloseSubpath
closed flag
Definition XTPMarkupPathGeometryBuilder.h:41
xtpMarkupPathPointTypeBezier
@ xtpMarkupPathPointTypeBezier
default Bezier (= cubic Bezier)
Definition XTPMarkupPathGeometryBuilder.h:40
xtpMarkupPathPointTypeLine
@ xtpMarkupPathPointTypeLine
line
Definition XTPMarkupPathGeometryBuilder.h:39
xtpMarkupPathPointTypeStart
@ xtpMarkupPathPointTypeStart
move
Definition XTPMarkupPathGeometryBuilder.h:38


Toolkit Pro: Member List

CXTPCalendarShadowDrawer Member List

This is the complete list of members for CXTPCalendarShadowDrawer, including all inherited members.

AlphaPixel(const COLORREF crPixel, const UINT i) | CXTPCalendarShadowDrawer | static
ApplyShadow2007BL(UINT *pBitmap, const ULONG ulBitmapWidth, const ULONG ulBitmapHeight) | CXTPCalendarShadowDrawer |
ApplyShadow2007Bottom(UINT *pBitmap, const ULONG ulBitmapWidth, const ULONG ulBitmapHeight) | CXTPCalendarShadowDrawer |
ApplyShadow2007BR(UINT *pBitmap, const ULONG ulBitmapWidth, const ULONG ulBitmapHeight) | CXTPCalendarShadowDrawer |
ApplyShadow2007Center(UINT *pBitmap, const ULONG ulBitmapWidth, const ULONG ulBitmapHeight) | CXTPCalendarShadowDrawer |
ApplyShadow2007Right(UINT *pBitmap, const ULONG ulBitmapWidth, const ULONG ulBitmapHeight) | CXTPCalendarShadowDrawer |
ApplyShadow2007TR(UINT *pBitmap, const ULONG ulBitmapWidth, const ULONG ulBitmapHeight) | CXTPCalendarShadowDrawer |
ApplyShadowBL(UINT *pBitmap, const ULONG ulBitmapWidth, const ULONG ulBitmapHeight) | CXTPCalendarShadowDrawer |
ApplyShadowBR(UINT *pBitmap, const ULONG ulBitmapWidth, const ULONG ulBitmapHeight) | CXTPCalendarShadowDrawer |
ApplyShadowLR(UINT *pBitmap, const ULONG ulBitmapWidth, const ULONG ulBitmapHeight) | CXTPCalendarShadowDrawer |
ApplyShadowTB(UINT *pBitmap, const ULONG ulBitmapWidth, const ULONG ulBitmapHeight) | CXTPCalendarShadowDrawer |
ApplyShadowTR(UINT *pBitmap, const ULONG ulBitmapWidth, const ULONG ulBitmapHeight) | CXTPCalendarShadowDrawer |
CheckValue(int iValue) | CXTPCalendarShadowDrawer | static
CXTPCalendarShadowDrawer(CDC *pDC, double dMaxAlpha) | CXTPCalendarShadowDrawer |
DrawShadowRectPart(const CRect &rcShadow, const XTPShadowPart part) | CXTPCalendarShadowDrawer |
m_dMaxAlpha | CXTPCalendarShadowDrawer | protected
m_pDC | CXTPCalendarShadowDrawer | protected
~CXTPCalendarShadowDrawer() | CXTPCalendarShadowDrawer | virtual


Toolkit Pro: Member List

CXTPDatePickerDaysCollection Member List

This is the complete list of members for CXTPDatePickerDaysCollection, including all inherited members.

Add(const COleDateTime &dtDay) | CXTPDatePickerDaysCollection |
Clear() | CXTPDatePickerDaysCollection |
Contains(const COleDateTime &dtDay) const | CXTPDatePickerDaysCollection |
CXTPCmdTarget() | CXTPCmdTarget |
CXTPDatePickerDaysCollection(CXTPDatePickerControl *pControl) | CXTPDatePickerDaysCollection |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetMinMaxRange(COleDateTime &refMinRange, COleDateTime &refMaxRange) const | CXTPDatePickerDaysCollection |
GetSelectedBlock(int nIndex) const | CXTPDatePickerDaysCollection |
GetSelectedBlocksCount() const | CXTPDatePickerDaysCollection |
GetSelectedDaysCount() const | CXTPDatePickerDaysCollection |
m_arrSelectedBlocks | CXTPDatePickerDaysCollection | protected
m_pControl | CXTPDatePickerDaysCollection | protected
Remove(const COleDateTime &dtDay) | CXTPDatePickerDaysCollection |
Select(const COleDateTime &dtDay) | CXTPDatePickerDaysCollection |
SelectRange(const COleDateTime &dtDayBegin, const COleDateTime &dtDayEnd) | CXTPDatePickerDaysCollection |
~CXTPDatePickerDaysCollection() | CXTPDatePickerDaysCollection | virtual


Toolkit Pro: XTPCustomizePageKeyboard.h Source File

  • Source
  • CommandBars
  • Customize
XTPCustomizePageKeyboard.h
Go to the documentation of this file.
1
23#if !defined(__XTPCUSTOMIZEKEYBOARDPAGE_H__) && defined(_XTP_INCLUDE_CONTROLS)
24# define __XTPCUSTOMIZEKEYBOARDPAGE_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPCustomizeSheet;
34class CXTPShortcutManagerAccelTable;
35
41class _XTP_EXT_CLASS CXTPCustomizeKeyboardPage : public CXTPPropertyPage
42{
43public:
51 CXTPCustomizeKeyboardPage(CXTPCustomizeSheet* pSheet);
52
58 ~CXTPCustomizeKeyboardPage();
59
60public:
68 XTP_COMMANDBARS_CATEGORYINFO* FindCategory(LPCTSTR strCategory) const;
69
77 XTP_COMMANDBARS_CATEGORYINFO* GetCategoryInfo(int nIndex) const;
78
89 CXTPControls* InsertCategory(LPCTSTR strCategory, int nIndex = -1);
90
102 BOOL AddCategory(LPCTSTR strCategory, CMenu* pMenu, BOOL bListSubItems = FALSE);
103
113 BOOL AddCategories(CXTPControls* pControls);
114
125 BOOL AddCategories(UINT nIDResource, BOOL bListSubItems = FALSE);
126
132 void ReloadList();
133
139 void EnableControls();
140
145 CXTPShortcutManagerAccelTable* GetFrameAccelerator() const;
146
154 void UpdateAcellTable(LPACCEL lpAccel, int nSize);
155
156protected:
158 DECLARE_MESSAGE_MAP()
159
160 //{{AFX_VIRTUAL(CXTPCustomizeKeyboardPage)
161 virtual BOOL OnSetActive();
162 virtual void DoDataExchange(CDataExchange* pDX);
163 BOOL OnInitDialog();
164 //}}AFX_VIRTUAL
165
166 //{{AFX_MSG(CXTPCustomizeKeyboardPage)
167 afx_msg void OnSelchangeCategory();
168 afx_msg void OnSelchangeCommands();
169 afx_msg void OnSelchangeCurKeys();
170 afx_msg void OnChangeShortcutKey();
171 afx_msg void OnAssign();
172 afx_msg void OnResetAll();
173 afx_msg void OnRemove();
174 afx_msg HBRUSH OnCtlColor(CDC* pDC, CWnd* pWnd, UINT nCtlColor);
175 //}}AFX_MSG
178public:
179 enum
180 {
181 IDD = XTP_IDD_PAGE_KEYBOARD
182 };
183
184# ifdef _XTP_INCLUDE_CONTROLS
185 COLORREF m_clrText;
186 CXTPButton m_btnAssign;
187 CXTPButton m_btnRemove;
188 CXTPButton m_btnResetAll;
189 CXTPListBox m_lboxKeys;
190 CXTPListBox m_lboxCommands;
191 CXTPComboBox m_comboCategory;
192# else
193 CButton m_btnAssign;
194 CButton m_btnRemove;
195 CButton m_btnResetAll;
196 CListBox m_lboxKeys;
197 CListBox m_lboxCommands;
198 CComboBox m_comboCategory;
199# endif
200 CString m_strDesc;
201 int m_iCategory;
202 CXTPShortcutManager::CKeyAssign m_editShortcutKey;
204protected:
205 CXTPCommandBarsCategoryArray m_arrCategories;
206 CXTPCustomizeSheet* m_pSheet;
207};
209# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
210#endif // !defined(__XTPCUSTOMIZEKEYBOARDPAGE_H__)
CXTPCommandBarsCategoryArray
CArray< XTP_COMMANDBARS_CATEGORYINFO *, XTP_COMMANDBARS_CATEGORYINFO * > CXTPCommandBarsCategoryArray
This array is used by the CXTPCustomizeCommandsPage class for maintaining a list of XTP_COMMANDBARS_C...
Definition XTPCustomizePageCommands.h:78
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPButton
Push Button control.
Definition XTPButton.h:109
CXTPComboBox
The CXTPComboBox class provides the functionality of a themed Windows combobox.
Definition XTPComboBox.h:42
CXTPControls
CXTPControls is a CXTPCmdTarget derived class.
Definition XTPControls.h:47
CXTPCustomizeKeyboardPage
CXTPCustomizeKeyboardPage is a CPropertyPage derived class.
Definition XTPCustomizePageKeyboard.h:42
CXTPCustomizeKeyboardPage::EnableControls
void EnableControls()
This member function is called by the page to enable the assignment buttons.
CXTPCustomizeKeyboardPage::GetFrameAccelerator
CXTPShortcutManagerAccelTable * GetFrameAccelerator() const
CXTPCustomizeKeyboardPage::FindCategory
XTP_COMMANDBARS_CATEGORYINFO * FindCategory(LPCTSTR strCategory) const
Finds the category.
CXTPCustomizeKeyboardPage::GetCategoryInfo
XTP_COMMANDBARS_CATEGORYINFO * GetCategoryInfo(int nIndex) const
Gets the category by its index.
CXTPCustomizeKeyboardPage::ReloadList
void ReloadList()
This member function is called by the page to reload the list items.
CXTPCustomizeKeyboardPage::AddCategories
BOOL AddCategories(CXTPControls *pControls)
Adds categories branch from Control or resource ID.
CXTPCustomizeKeyboardPage::m_pSheet
CXTPCustomizeSheet * m_pSheet
Parent Customize dialog.
Definition XTPCustomizePageKeyboard.h:206
CXTPCustomizeKeyboardPage::AddCategories
BOOL AddCategories(UINT nIDResource, BOOL bListSubItems=FALSE)
Adds categories branch from Control or resource ID.
CXTPCustomizeKeyboardPage::m_comboCategory
CComboBox m_comboCategory
Categories combobox.
Definition XTPCustomizePageKeyboard.h:198
CXTPCustomizeKeyboardPage::CXTPCustomizeKeyboardPage
CXTPCustomizeKeyboardPage(CXTPCustomizeSheet *pSheet)
Constructs a CXTPCustomizeKeyboardPage object.
CXTPCustomizeKeyboardPage::~CXTPCustomizeKeyboardPage
~CXTPCustomizeKeyboardPage()
Destroys a CXTPCustomizeKeyboardPage object, handles cleanup and deallocation.
CXTPCustomizeKeyboardPage::m_iCategory
int m_iCategory
Selected category.
Definition XTPCustomizePageKeyboard.h:201
CXTPCustomizeKeyboardPage::m_lboxKeys
CListBox m_lboxKeys
Keys list box.
Definition XTPCustomizePageKeyboard.h:196
CXTPCustomizeKeyboardPage::m_lboxCommands
CListBox m_lboxCommands
Commands list box.
Definition XTPCustomizePageKeyboard.h:197
CXTPCustomizeKeyboardPage::m_editShortcutKey
CXTPShortcutManager::CKeyAssign m_editShortcutKey
Shortcut edit control.
Definition XTPCustomizePageKeyboard.h:202
CXTPCustomizeKeyboardPage::InsertCategory
CXTPControls * InsertCategory(LPCTSTR strCategory, int nIndex=-1)
This method adds a new empty category in the given index.
CXTPCustomizeKeyboardPage::m_arrCategories
CXTPCommandBarsCategoryArray m_arrCategories
Array of categories.
Definition XTPCustomizePageKeyboard.h:205
CXTPCustomizeKeyboardPage::AddCategory
BOOL AddCategory(LPCTSTR strCategory, CMenu *pMenu, BOOL bListSubItems=FALSE)
Adds a new category from a CMenu object.
CXTPCustomizeKeyboardPage::m_strDesc
CString m_strDesc
Description of selected control.
Definition XTPCustomizePageKeyboard.h:200
CXTPCustomizeKeyboardPage::UpdateAcellTable
void UpdateAcellTable(LPACCEL lpAccel, int nSize)
Updates frame accelerators.
CXTPCustomizeSheet
CXTPCustomizeSheet is a CPropertySheet derived class.
Definition XTPCustomizeSheet.h:47
CXTPListBox
CXTPListBox is a CListBox derived class.
Definition XTPListBox.h:127
CXTPPropertyPage
CXTPPropertyPage is a CPropertyPage derived class.
Definition XTPPropertyPage.h:43
CXTPShortcutManagerAccelTable
CXTPShortcutManagerAccelTable represents an accelerator table for the CXTPShortcutManager class.
Definition XTPShortcutManager.h:92
XTP_COMMANDBARS_CATEGORYINFO
This structure stores categories for CXTPCustomizeCommandsPage and CXTPCustomizeKeyboardPage option p...
Definition XTPCustomizePageCommands.h:46


Toolkit Pro: Member List

CXTPResize Member List

This is the complete list of members for CXTPResize, including all inherited members.

AdjustResizeRect(CSize &rcWindow) | CXTPResize | protectedvirtual
AutoLoadPlacement(LPCTSTR pszSection) | CXTPResize |
CResizeItemArray typedef | CXTPResize | protected
CXTPResize(CWnd *pWnd, const UINT nFlags=0) | CXTPResize |
Defer(HDWP &hdwp, CXTPResizeItem *pItem, int dx, int dy) | CXTPResize | protectedvirtual
GetMinMaxInfo(MINMAXINFO *pMMI) | CXTPResize | protected
HasFlag(XTPResize eFlag) | CXTPResize | protected
Init() | CXTPResize | protectedvirtual
LoadPlacement(LPCTSTR pszSection) | CXTPResize |
m_arrItems | CXTPResize | protected
m_nFlagsXX | CXTPResize | protected
m_pWnd | CXTPResize | protected
m_scSizeIcon | CXTPResize | protected
m_strSection | CXTPResize | protected
m_szInitWindow | CXTPResize | protected
m_szMax | CXTPResize | protected
m_szMin | CXTPResize | protected
m_szWindow | CXTPResize | protected
Offset(CPoint ptOffset) | CXTPResize | protected
RemoveAllControls() | CXTPResize | protected
RemoveResize(UINT nID) | CXTPResize | protected
Reset() | CXTPResize | protected
SavePlacement(LPCTSTR pszSection) | CXTPResize |
SetFlag(XTPResize eFlag) | CXTPResize | protected
SetMaxSize(CSize &sz) | CXTPResize |
SetMinSize(CSize &sz) | CXTPResize |
SetResize(UINT nID, XTP_RESIZE left, XTP_RESIZE top, XTP_RESIZE right, XTP_RESIZE bottom) | CXTPResize |
SetResize(UINT nID, const XTP_RESIZERECT &rrcSizing) | CXTPResize |
SetResize(UINT nID, HWND hWnd, const XTP_RESIZERECT &rrcSizing) | CXTPResize |
SetResize(UINT nID, HWND hWnd, const XTP_RESIZEPOINT &rpTopLeft, const XTP_RESIZEPOINT &rpBottomRight) | CXTPResize |
SetResize(UINT nID, const XTP_RESIZEPOINT &rpTopLeft, const XTP_RESIZEPOINT &rpBottomRight) | CXTPResize |
SetResize(CWnd *pWnd, const CXTPResizeRect &rrcSizing, CRect rcWindow) | CXTPResize | protected
Size() | CXTPResize | protectedvirtual
UpdateControlRect(CWnd *pWnd) | CXTPResize | protected
~CXTPResize() | CXTPResize | virtual


Toolkit Pro: Member List

CXTPMarkupMatrixTransform Member List

This is the complete list of members for CXTPMarkupMatrixTransform, including all inherited members.

ApplyTransform(const CXTPMarkupTransformationMatrix *pMatrix) | CXTPMarkupMatrixTransform | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPMarkupTransform() | CXTPMarkupTransform | protected
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static


Toolkit Pro: Member List

CXTPTabCtrl Member List

This is the complete list of members for CXTPTabCtrl, including all inherited members.

CXTPTabCtrl() | CXTPTabCtrl |
EnableToolTips(BOOL bEnable) | CXTPTabCtrl | virtual
~CXTPTabCtrl() | CXTPTabCtrl | virtual


Toolkit Pro: Member List

CXTPCommandBarsNativeXPTheme Member List

This is the complete list of members for CXTPCommandBarsNativeXPTheme, including all inherited members.

AdjustExcludeRect(CRect &rc, CXTPControl *pControl, BOOL bVertical) | CXTPCommandBarsNativeXPTheme | protectedvirtual
Animate(CDC *pDestDC, CDC *pSrcDC, CRect rc, XTPAnimationType animationType) | CXTPPaintManager | virtual
AnimateExpanding(CXTPCommandBar *pCommandBar, CDC *pDestDC, CDC *pSrcDC, BOOL bExpandDown) | CXTPPaintManager | virtual
BaseTheme() | CXTPCommandBarsNativeXPTheme | inlineprotectedvirtual
CreateTheme(XTPPaintTheme paintTheme) | CXTPPaintManager | static
CXTPCmdTarget() | CXTPCmdTarget |
CXTPCommandBarsNativeXPTheme() | CXTPCommandBarsNativeXPTheme |
CXTPCommandBarsOffice2000Theme() | CXTPCommandBarsOffice2000Theme |
CXTPObservable() | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | protected
CXTPPaintManager() | CXTPPaintManager | protected
Draw3dRect(CDC *pDC, LPCRECT rc, int nTopLeft, int nBottomRight) | CXTPPaintManager |
Draw3dRect(CDC *pDC, LPCRECT rc, int frameThickness, COLORREF clrPen, COLORREF clrBrush) | CXTPPaintManager |
DrawCheckMark(CDC *pDC, CRect rcCheck, COLORREF clr=0) | CXTPPaintManager | inline
DrawComboExpandMark(CDC *pDC, CRect rc, COLORREF clr) | CXTPPaintManager | virtual
DrawCommandBarGripper(CDC *pDC, CXTPCommandBar *pBar, BOOL bDraw=TRUE) | CXTPCommandBarsNativeXPTheme | protectedvirtual
DrawCommandBarGroupSeparator(CDC *pDC, CXTPCommandBar *pBar, CXTPControl *pLeftControl, CXTPControl *pRightControl, BOOL bDraw=TRUE) | CXTPPaintManager | virtual
DrawCommandBarSeparator(CDC *pDC, CXTPCommandBar *pBar, CXTPControl *pControl, BOOL bDraw=TRUE) | CXTPCommandBarsNativeXPTheme | protectedvirtual
DrawControl(CDC *pDC, CXTPControl *pButton, BOOL bDraw=TRUE) | CXTPPaintManager |
DrawControlCheckBoxMark(CDC *pDC, CRect rc, BOOL bDraw, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled) | CXTPPaintManager | virtual
DrawControlCheckBoxMark(CDC *pDC, CXTPControl *pButton, CRect rc, BOOL bDraw) | CXTPPaintManager | virtual
DrawControlComboBox(CDC *pDC, CXTPControlComboBox *pComboBox, BOOL bDraw) | CXTPCommandBarsOffice2000Theme | protectedvirtual
DrawControlComboBoxButton(CDC *pDC, CRect rcBtn, BOOL bEnabled, BOOL bSelected, BOOL bDropped) | CXTPCommandBarsNativeXPTheme | protectedvirtual
DrawControlEdit(CDC *pDC, CXTPControlEdit *pEdit, BOOL bDraw) | CXTPCommandBarsOffice2000Theme | protectedvirtual
DrawControlEditFrame(CDC *pDC, CRect rc, BOOL bEnabled, BOOL bSelected) | CXTPCommandBarsNativeXPTheme | protectedvirtual
DrawControlEditSpin(CDC *pDC, CXTPControlEdit *pControlEdit) | CXTPCommandBarsNativeXPTheme | protectedvirtual
DrawControlEntry(CDC *pDC, CXTPControl *pButton) | CXTPCommandBarsNativeXPTheme | protectedvirtual
DrawControlMDIButton(CDC *pDC, CXTPControlButton *pButton) | CXTPCommandBarsNativeXPTheme | protectedvirtual
DrawControlPopupParent(CDC *pDC, CXTPControl *pButton, BOOL bDraw) | CXTPCommandBarsOffice2000Theme | protectedvirtual
DrawControlRadioButtonMark(CDC *pDC, CRect rc, BOOL bDraw, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled) | CXTPPaintManager | virtual
DrawControlText(CDC *pDC, CXTPControl *pControl, CRect rcText, BOOL bDraw, BOOL bVert, BOOL bCentered, BOOL bTriangled) | CXTPPaintManager |
DrawControlToolBarParent(CDC *pDC, CXTPControl *pButton, BOOL bDraw) | CXTPPaintManager | virtual
DrawDialogBarGripper(CDC *pDC, CXTPDialogBar *pBar, BOOL bDraw) | CXTPCommandBarsNativeXPTheme | protectedvirtual
DrawDropDownGlyph(CDC *pDC, CXTPControl *pControl, CPoint pt, BOOL bSelected, BOOL bPopuped, BOOL bEnabled, BOOL bVert) | CXTPPaintManager | virtual
DrawExpandGlyph(CDC *pDC, CXTPControl *pButton, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clr) | CXTPPaintManager | virtual
DrawExpandGlyph(CDC *pDC, CXTPControl *pButton, COLORREF clr, BOOL bVertical) | CXTPPaintManager | virtual
DrawGalleryItemBack(CDC *pDC, CRect rcItem, BOOL bEnabled, BOOL bSelected, BOOL bPressed, BOOL bChecked, XTPBarType barType) | CXTPPaintManager | virtual
DrawHiddenGlyph(CDC *pDC, CXTPControl *pButton, COLORREF clr, BOOL bVertical) | CXTPPaintManager | virtual
DrawImage(CDC *pDC, CPoint pt, CSize sz, CXTPImageManagerIcon *pImage, BOOL bSelected, BOOL bPressed, BOOL bEnabled=TRUE, BOOL bChecked=FALSE, BOOL bPopuped=FALSE, BOOL bToolBarImage=TRUE) | CXTPCommandBarsOffice2000Theme | protectedvirtual
DrawListBoxControl(CDC *pDC, CXTPControl *pButton, CRect rc, BOOL bSelected, BOOL bDraw, CXTPCommandBars *pCommandBars=0) | CXTPCommandBarsOffice2000Theme | virtual
DrawPopupBarCheckMark(CDC *pDC, CRect rcCheck, BOOL bEnabled, COLORREF clr) | CXTPCommandBarsNativeXPTheme | protectedvirtual
DrawPopupBarGripper(CDC *pDC, int xPos, int yPos, int cx, int cy, BOOL bExpanded=FALSE) | CXTPCommandBarsNativeXPTheme | protectedvirtual
DrawPopupBarRadioMark(CDC *pDC, CRect rcCheck, BOOL bEnabled, COLORREF clr) | CXTPCommandBarsNativeXPTheme | protectedvirtual
DrawPopupResizeGripper(CDC *pDC, CRect rcGripper, int nFlags) | CXTPCommandBarsOffice2000Theme | virtual
DrawRectangle(CDC *pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition) | CXTPCommandBarsNativeXPTheme | protectedvirtual
DrawRectangle(CDC *pDC, CXTPControl *pButton) | CXTPCommandBarsNativeXPTheme | protectedvirtual
DrawSpecialControl(CDC *pDC, XTPSpecialControl controlType, CXTPControl *pButton, CXTPCommandBar *pBar, BOOL bDraw, LPVOID lpParam) | CXTPCommandBarsNativeXPTheme | protectedvirtual
DrawSplitButtonFrame(CDC *pDC, CXTPControl *pButton, CRect rcButton) | CXTPCommandBarsNativeXPTheme | protectedvirtual
DrawTearOffGripper(CDC *pDC, CRect rcGripper, BOOL bSelected, BOOL bDraw) | CXTPCommandBarsOffice2000Theme | virtual
FillCommandBarEntry(CDC *pDC, CXTPCommandBar *pBar) | CXTPCommandBarsNativeXPTheme | protectedvirtual
FillDockBar(CDC *pDC, CXTPDockBar *pBar) | CXTPCommandBarsNativeXPTheme | protectedvirtual
FillDockBarRect(CDC *pDC, CWnd *pWnd, CWnd *pFrame) | CXTPCommandBarsNativeXPTheme | protected
FillWorkspace(CDC *pDC, CRect rc, CRect rcExclude) | CXTPPaintManager | virtual
FontExists(LPCTSTR lpszFaceName) | CXTPPaintManager | static
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCommandBarBorders(CXTPCommandBar *pBar) | CXTPCommandBarsOffice2000Theme | virtual
GetCommandBarFont(CXTPCommandBar *pCommandBar) | CXTPPaintManager | virtual
GetControlBackColor(CXTPControl *pButton) | CXTPPaintManager | virtual
GetControlEditBackColor(CXTPControl *pControl) | CXTPPaintManager | virtual
GetControlFont(CXTPControl *pControl) | CXTPPaintManager | virtual
GetControlHeight() const | CXTPPaintManager |
GetControlTextColor(CXTPControl *pButton) | CXTPCommandBarsNativeXPTheme | protectedvirtual
GetControlTextOrientation(CXTPControl *pControl) | CXTPPaintManager | virtual
GetCurrentSystemTheme() | CXTPPaintManager |
GetCurrentTheme() | CXTPPaintManager | inline
GetDefaultCommandBarSize(CXTPCommandBar *pBar) | CXTPPaintManager | virtual
GetFramePaintManager() | CXTPPaintManager | virtual
GetGalleryPaintManager() const | CXTPPaintManager | virtual
GetGlobalPaintManager() | CXTPPaintManager | static
GetIconFont() | CXTPPaintManager |
GetIconsInfo() | CXTPPaintManager |
GetInstanceAddRef() | CXTPPaintManager | static
GetMessageBarPaintManager() | CXTPPaintManager | virtual
GetPopupBarGripperWidth(CXTPCommandBar *pBar) | CXTPCommandBarsNativeXPTheme | protectedvirtual
GetProgressPaintManager() const | CXTPPaintManager | virtual
GetRectangleTextColor(BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition) | CXTPCommandBarsNativeXPTheme | protectedvirtual
GetRegularBoldFont() | CXTPPaintManager |
GetRegularFont() | CXTPPaintManager |
GetRibbonPaintManager() | CXTPPaintManager | virtual
GetScrollBarPaintManager() const | CXTPPaintManager | virtual
GetShadowManager() const | CXTPPaintManager |
GetShadowOptions() const | CXTPPaintManager |
GetSliderPaintManager() const | CXTPPaintManager | virtual
GetSmCaptionFont() | CXTPPaintManager |
GetSplitButtonCommandRect(CXTPControl *pButton) | CXTPPaintManager | virtual
GetStatusBarPaintManager() | CXTPPaintManager | virtual
GetXtremeColor(UINT nIndex) | CXTPPaintManager |
GradientFill(CDC *pDC, LPRECT lpRect, COLORREF crFrom, COLORREF crTo, BOOL bHorz, LPCRECT lpRectClip=NULL) | CXTPPaintManager |
HorizontalLine(CDC *pDC, int x0, int y0, int x1, COLORREF clrPen) | CXTPPaintManager |
IsThemeEnabled() const | CXTPCommandBarsNativeXPTheme | protected
IsUseSystemAccentColorEnabled() const | CXTPPaintManager |
Line(CDC *pDC, CPoint p0, CPoint p1) | CXTPPaintManager |
Line(CDC *pDC, int x0, int y0, int x1, int y1, const int nPen) | CXTPPaintManager |
Line(CDC *pDC, int x0, int y0, int x1, int y1, COLORREF clrPen) | CXTPPaintManager |
m_arrColor | CXTPPaintManager | protected
m_bAutoResizeIcons | CXTPPaintManager |
m_bClearTypeTextQuality | CXTPPaintManager |
m_bEmbossedDisabledText | CXTPPaintManager | protected
m_bEnableAnimation | CXTPPaintManager |
m_bFlatMenuBar | CXTPPaintManager |
m_bFlatMenus | CXTPCommandBarsNativeXPTheme | protected
m_bFlatToolBar | CXTPPaintManager |
m_bOffice2007Padding | CXTPPaintManager |
m_bOffsetPopupLabelText | CXTPPaintManager |
m_bSelectImageInPopupBar | CXTPPaintManager |
m_bShowKeyboardCues | CXTPPaintManager | protected
m_bShowShadow | CXTPPaintManager |
m_bThemedCheckBox | CXTPPaintManager |
m_bThemedStatusBar | CXTPPaintManager |
m_bThickCheckMark | CXTPPaintManager |
m_bUseOfficeFont | CXTPPaintManager |
m_bUseStandardFont | CXTPPaintManager | protected
m_bWrapCaptionBelowText | CXTPPaintManager |
m_clrDisabledIcon | CXTPPaintManager |
m_clrEdgeHighLightColor | CXTPCommandBarsNativeXPTheme | protected
m_clrEdgeShadowColor | CXTPCommandBarsNativeXPTheme | protected
m_clrFloatingGripper | CXTPPaintManager |
m_clrFloatingGripperText | CXTPPaintManager |
m_clrMessageBarText | CXTPPaintManager |
m_clrPressedText | CXTPCommandBarsNativeXPTheme | protected
m_clrSelectedText | CXTPCommandBarsNativeXPTheme | protected
m_fontIcon | CXTPPaintManager |
m_fontIconBold | CXTPPaintManager |
m_fontSmCaption | CXTPPaintManager |
m_fontToolTip | CXTPPaintManager |
m_iconsInfo | CXTPPaintManager | protected
m_nAnimationSteps | CXTPPaintManager | protected
m_nAnimationTime | CXTPPaintManager | protected
m_nEditHeight | CXTPPaintManager | protected
m_nFontHeight | CXTPPaintManager | protected
m_nPopupBarText | CXTPCommandBarsOffice2000Theme | protected
m_nPopupBarTextPadding | CXTPPaintManager |
m_nSplitButtonDropDownHeight | CXTPPaintManager |
m_nSplitButtonDropDownWidth | CXTPPaintManager |
m_nSplitButtonPopupWidth | CXTPPaintManager |
m_nStatusBarMinHeight | CXTPPaintManager |
m_nTextHeight | CXTPPaintManager |
m_pfnSetLayeredWindowAttributes | CXTPPaintManager |
m_pFramePaintManager | CXTPPaintManager |
m_pGalleryPaintManager | CXTPPaintManager |
m_pProgressPaintManager | CXTPPaintManager |
m_pRibbonPaintManager | CXTPPaintManager |
m_pScrollBarPaintManager | CXTPPaintManager |
m_pShadowManager | CXTPPaintManager | protected
m_pSliderPaintManager | CXTPPaintManager |
m_pStatusBarPaintManager | CXTPPaintManager |
m_rcMessageBarMargin | CXTPPaintManager |
m_rcStatusBarBorder | CXTPPaintManager |
m_strOfficeFont | CXTPPaintManager |
m_systemTheme | CXTPPaintManager | protected
m_themeButton | CXTPPaintManager | protected
m_themeCombo | CXTPCommandBarsNativeXPTheme | protected
m_themeCurrent | CXTPPaintManager | protected
m_themeMenu | CXTPCommandBarsNativeXPTheme | protected
m_themeRebar | CXTPCommandBarsNativeXPTheme | protected
m_themeSpin | CXTPCommandBarsNativeXPTheme | protected
m_themeStatusBar | CXTPPaintManager | protected
m_themeToolbar | CXTPCommandBarsNativeXPTheme | protected
m_themeWindow | CXTPCommandBarsNativeXPTheme | protected
m_xtpFontRegular | CXTPPaintManager | protected
m_xtpFontRegularBold | CXTPPaintManager | protected
m_xtpFontVert | CXTPPaintManager | protected
m_xtpFontVertBold | CXTPPaintManager | protected
Notify(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *)) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
Notify(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1), A1 arg1) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
Notify(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
Notify(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamic(void(T::*method)(O *)) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1), A1 arg1) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *)) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1), A1 arg1) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyReversed(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *)) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyReversed(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1), A1 arg1) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyReversed(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyReversed(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
Pixel(CDC *pDC, int xPos, int yPos, int nPen) | CXTPPaintManager |
Rectangle(CDC *pDC, LPCRECT rc, int nPen, const int nBrush) | CXTPPaintManager |
Rectangle(CDC *pDC, LPCRECT rc, COLORREF clrPen, COLORREF clrBrush) | CXTPPaintManager |
RefreshMetrics() | CXTPCommandBarsNativeXPTheme | protectedvirtual
ReleaseInstance() | CXTPPaintManager | static
RequiresResourceImages() | CXTPPaintManager | virtual
RoundRect(CDC *pDC, LPCRECT rc, COLORREF clrPen, COLORREF clrBrush) | CXTPPaintManager |
SetAnimationDelay(int nAnimationSteps, int nAnimationTime) | CXTPPaintManager |
SetColors(int cElements, CONST INT *lpaElements, CONST COLORREF *lpaRgbValues) | CXTPPaintManager |
SetCommandBarRegion(CXTPCommandBar *pCommandBar) | CXTPPaintManager | virtual
SetCommandBarsFontIndirect(LOGFONT *pLogFont, BOOL bUseStandardFont=FALSE) | CXTPPaintManager |
SetCustomTheme(CXTPPaintManager *pTheme) | CXTPPaintManager | static
SetGlobalPaintManager(CXTPPaintManager *pPaintManager) | CXTPPaintManager | static
SetImageHandle(HMODULE hResource, LPCTSTR lpszIniFileName) | CXTPPaintManager | virtual
SetLunaTheme(XTPCurrentSystemTheme systemTheme) | CXTPPaintManager |
SetTheme(XTPPaintTheme paintTheme) | CXTPPaintManager | static
StripMnemonics(CString &strClear) | CXTPPaintManager | static
Subscribe(IXTPPaintManagerEvents *pObserver, CXTPSubscriptionList< CXTPPaintManager, IXTPPaintManagerEvents > *pSubcriptionList=NULL) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > |
Triangle(CDC *pDC, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clr) | CXTPPaintManager | static
Unsubscribe(IXTPPaintManagerEvents *pObserver) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > |
UpdateColors() | CXTPPaintManager | virtual
UpdateFonts() | CXTPPaintManager | virtual
UpdateRTLCaption(CString &strCaption) | CXTPPaintManager | virtual
UseOfficeFont(bool bUseOfficeFont) | CXTPPaintManager |
VerticalLine(CDC *pDC, int x0, int y0, int y1, COLORREF clrPen) | CXTPPaintManager |
~CXTPCommandBarsNativeXPTheme() | CXTPCommandBarsNativeXPTheme |
~CXTPObservable() | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | protected
~CXTPPaintManager() | CXTPPaintManager | protectedvirtual


Toolkit Pro: XTPControlGalleryResourceTheme.h Source File

  • Source
  • CommandBars
  • Gallery
XTPControlGalleryResourceTheme.h
Go to the documentation of this file.
1
23#if !defined(__XTPCONTROLGALLERYRESOURCETHEME_H__)
24# define __XTPCONTROLGALLERYRESOURCETHEME_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
40class _XTP_EXT_CLASS CXTPControlGalleryResourceTheme : public CXTPControlGalleryPaintManager
41{
42public:
48 CXTPControlGalleryResourceTheme(CXTPPaintManager* pPaintManager);
49
50public:
58 virtual void FillControl(CDC* pDC, CXTPControlGallery* pGallery, CRect rc);
59
68 virtual void DrawPopupScrollBar(CDC* pDC, CXTPControlGallery* pGallery);
69
77 virtual void DrawLabel(CDC* pDC, CXTPControlGalleryItem* pLabel, CRect rc);
78
83 virtual void RefreshMetrics();
84
85protected:
86 COLORREF m_clrControlGallerySelected;
87 COLORREF m_clrControlGalleryNormal;
88 COLORREF m_clrControlGalleryBorder;
89};
90
92# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
93#endif // !defined(__XTPCONTROLGALLERYRESOURCETHEME_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPControlGallery
CXTPControlGallery is a CXTPControlPopup derived class.
Definition XTPControlGallery.h:63
CXTPControlGalleryItem
CXTPControlGalleryItem is a CXTPCmdTarget derived class.
Definition XTPControlGalleryItem.h:39
CXTPControlGalleryPaintManager
CXTPControlGalleryPaintManager is a standalone class used to draw a CXTPControlGallery object.
Definition XTPControlGallery.h:682
CXTPControlGalleryResourceTheme
The CXTPControlGalleryResourceTheme class is used to enable a Gallery Resource style theme for Comman...
Definition XTPControlGalleryResourceTheme.h:41
CXTPControlGalleryResourceTheme::m_clrControlGalleryNormal
COLORREF m_clrControlGalleryNormal
Normal item color.
Definition XTPControlGalleryResourceTheme.h:87
CXTPControlGalleryResourceTheme::DrawPopupScrollBar
virtual void DrawPopupScrollBar(CDC *pDC, CXTPControlGallery *pGallery)
This method is called to draw the scrollbar of the inplace gallery.
CXTPControlGalleryResourceTheme::FillControl
virtual void FillControl(CDC *pDC, CXTPControlGallery *pGallery, CRect rc)
This method is called to draw the background of the gallery.
CXTPControlGalleryResourceTheme::m_clrControlGallerySelected
COLORREF m_clrControlGallerySelected
Selected item color.
Definition XTPControlGalleryResourceTheme.h:86
CXTPControlGalleryResourceTheme::m_clrControlGalleryBorder
COLORREF m_clrControlGalleryBorder
Border color.
Definition XTPControlGalleryResourceTheme.h:88
CXTPControlGalleryResourceTheme::CXTPControlGalleryResourceTheme
CXTPControlGalleryResourceTheme(CXTPPaintManager *pPaintManager)
Constructs a CXTPControlGalleryResourceTheme object.
CXTPControlGalleryResourceTheme::RefreshMetrics
virtual void RefreshMetrics()
This method is called to refresh the visual metrics of the manager.
CXTPControlGalleryResourceTheme::DrawLabel
virtual void DrawLabel(CDC *pDC, CXTPControlGalleryItem *pLabel, CRect rc)
This method is called to draw the label control.
CXTPPaintManager
Paint manager of the command bars.
Definition XTPPaintManager.h:199


Toolkit Pro: XTPMarkupPanel.h Source File

  • Source
  • Markup
  • Controls
XTPMarkupPanel.h
Go to the documentation of this file.
1
23#if !defined(__XTPMARKUPPANEL_H__)
24# define __XTPMARKUPPANEL_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPMarkupBrush;
34class CXTPMarkupUIElementCollection;
35class CXTPMarkupVisual;
36class CXTPMarkupBuilder;
37class CXTPMarkupObject;
38class CXTPMarkupDrawingContext;
39class CXTPMarkupInputElement;
40class CXTPMarkupDependencyProperty;
41
47class _XTP_EXT_CLASS CXTPMarkupPanel : public CXTPMarkupFrameworkElement
48{
50 DECLARE_MARKUPCLASS(CXTPMarkupPanel)
52protected:
57 CXTPMarkupPanel();
58
63 virtual ~CXTPMarkupPanel();
64
65public:
72 CXTPMarkupUIElementCollection* GetChildren() const;
73
74public:
80 void SetBackground(CXTPMarkupBrush* pBrush);
81
88 CXTPMarkupBrush* GetBackground() const;
89
90protected:
92 // Implementation
93 virtual int GetVisualChildrenCount() const;
94 virtual CXTPMarkupVisual* GetVisualChild(int nIndex) const;
95
96protected:
97 virtual void SetContentObject(CXTPMarkupBuilder* pBuilder, CXTPMarkupObject* pContent);
98 virtual BOOL HasContentObject() const;
99 virtual void OnRender(CXTPMarkupDrawingContext* drawingContext);
100 virtual CXTPMarkupInputElement* InputHitTestOverride(CPoint point) const;
101
102protected:
103 CXTPMarkupUIElementCollection* m_pChildren;
104
105public:
106 static CXTPMarkupDependencyProperty* m_pBackgroundProperty;
107
111public:
112 DECLARE_DISPATCH_MAP()
113# ifdef _XTP_ACTIVEX
114 DECLARE_INTERFACE_MAP()
115 DECLARE_OLETYPELIB_EX(CXTPMarkupPanel);
116# endif
117
118 afx_msg LPDISPATCH OleGetChildren();
119 afx_msg LPDISPATCH OleGetBackground();
120 afx_msg void OleSetBackground(LPDISPATCH lpBackground);
121
123};
124
125AFX_INLINE CXTPMarkupUIElementCollection* CXTPMarkupPanel::GetChildren() const
126{
127 return m_pChildren;
128}
129
130# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
132#endif // !defined(__XTPMARKUPPANEL_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPMarkupFrameworkElement
This class represents the provided framework-level implementation built on CXTPMarkupUIElement.
Definition XTPMarkupFrameworkElement.h:44
CXTPMarkupPanel
CXTPMarkupPanel is a CXTPMarkupFrameworkElement derived class.
Definition XTPMarkupPanel.h:48
CXTPMarkupPanel::~CXTPMarkupPanel
virtual ~CXTPMarkupPanel()
Destroys a CXTPMarkupPanel object, handles cleanup and deallocation.
CXTPMarkupPanel::GetBackground
CXTPMarkupBrush * GetBackground() const
Gets the background brush of the panel object.
CXTPMarkupPanel::GetChildren
CXTPMarkupUIElementCollection * GetChildren() const
Retrieves the collection of child elements.
Definition XTPMarkupPanel.h:125
CXTPMarkupPanel::CXTPMarkupPanel
CXTPMarkupPanel()
Constructs a CXTPMarkupPanel object.
CXTPMarkupPanel::SetBackground
void SetBackground(CXTPMarkupBrush *pBrush)
Sets the background brush for the panel object.
CXTPMarkupUIElementCollection
CXTPMarkupUIElementCollection is a CXTPMarkupCollection derived class.
Definition XTPMarkupUIElementCollection.h:41
CXTPMarkupVisual
Provides rendering support for XML Markup, which includes hit testing, coordinate transformation,...
Definition XTPMarkupInputElement.h:223
CXTPMarkupVisual::InputHitTestOverride
virtual CXTPMarkupInputElement * InputHitTestOverride(CPoint point) const
Override this method in the derived class to provide visual hit testing of a child object.
CXTPMarkupVisual::GetVisualChild
virtual CXTPMarkupVisual * GetVisualChild(int nIndex) const
Retrieves the child Visual object located at a specified index within the parent VisualCollection.
CXTPMarkupVisual::OnRender
virtual void OnRender(CXTPMarkupDrawingContext *drawingContext)
When overridden in a derived class, participates in rendering operations that are directed by the lay...
Definition XTPMarkupInputElement.h:515
CXTPMarkupVisual::GetVisualChildrenCount
virtual int GetVisualChildrenCount() const
Gets the number of child elements for the Visual.


Toolkit Pro: Member List

CXTPMarkupBorder Member List

This is the complete list of members for CXTPMarkupBorder, including all inherited members.

ApplyRenderTransform(CXTPMarkupDrawingContext *pContext) | CXTPMarkupUIElement | protectedvirtual
Arrange(CRect rcFinalRect) | CXTPMarkupUIElement |
ArrangeCore(CRect rcFinalRect) | CXTPMarkupUIElement | protectedvirtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPMarkupBorder() | CXTPMarkupBorder | protected
CXTPMarkupDecorator() | CXTPMarkupDecorator | protected
CXTPMarkupFrameworkElement() | CXTPMarkupFrameworkElement | protected
CXTPMarkupUIElement() | CXTPMarkupUIElement | protected
CXTPMarkupVisual() | CXTPMarkupVisual |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAbsoluteVisualOffset() const | CXTPMarkupVisual | protected
GetActualSize() const | CXTPMarkupFrameworkElement |
GetBackground() const | CXTPMarkupBorder |
GetBorderBrush() const | CXTPMarkupBorder |
GetBorderThickness() const | CXTPMarkupBorder |
GetBoundRect() const | CXTPMarkupVisual |
GetChild() const | CXTPMarkupDecorator |
GetClipToBounds() const | CXTPMarkupFrameworkElement |
GetCornerRadius() const | CXTPMarkupBorder |
GetDesiredSize() const | CXTPMarkupUIElement |
GetFinalRect() const | CXTPMarkupUIElement |
GetHeight() const | CXTPMarkupFrameworkElement |
GetHorizontalAlignment() const | CXTPMarkupFrameworkElement |
GetLayoutClip(CRect &rc) const | CXTPMarkupUIElement | protectedvirtual
GetLogicalChild(int nIndex) const | CXTPMarkupVisual | virtual
GetLogicalChildrenCount() const | CXTPMarkupVisual | virtual
GetMargin() const | CXTPMarkupFrameworkElement |
GetMaxHeight() const | CXTPMarkupFrameworkElement |
GetMaxWidth() const | CXTPMarkupFrameworkElement |
GetMinHeight() const | CXTPMarkupFrameworkElement |
GetMinWidth() const | CXTPMarkupFrameworkElement |
GetOpacity() const | CXTPMarkupUIElement | protectedvirtual
GetPadding() const | CXTPMarkupBorder |
GetRenderSize() const | CXTPMarkupVisual |
GetRenderTransform() const | CXTPMarkupUIElement | protected
GetSize() const | CXTPMarkupBorder |
GetStyle() const | CXTPMarkupFrameworkElement |
GetTag() const | CXTPMarkupFrameworkElement |
GetUpdateRect() const | CXTPMarkupVisual |
GetVerticalAlignment() const | CXTPMarkupFrameworkElement |
GetVisibility() const | CXTPMarkupUIElement |
GetVisualChild(int nIndex) const | CXTPMarkupVisual | virtual
GetVisualChildrenCount() const | CXTPMarkupVisual | virtual
GetVisualOffset() const | CXTPMarkupVisual |
GetVisualParent() const | CXTPMarkupVisual |
GetWidth() const | CXTPMarkupFrameworkElement |
InputHitTest(CPoint point) const | CXTPMarkupVisual |
InputHitTestOverride(CPoint point) const | CXTPMarkupVisual | protectedvirtual
InvalidateArrange() | CXTPMarkupUIElement | virtual
InvalidateMeasure() | CXTPMarkupUIElement | virtual
InvalidateMeasureOverride(CXTPMarkupDrawingContext *pDC) | CXTPMarkupUIElement | protectedvirtual
InvalidateVisual() | CXTPMarkupUIElement | virtual
IsEnabled() const | CXTPMarkupUIElement |
IsFocusable() const | CXTPMarkupUIElement |
IsVisible() const | CXTPMarkupUIElement | virtual
m_bArrangeDirty | CXTPMarkupUIElement | protected
m_bArrangeInProgress | CXTPMarkupUIElement | protected
m_bMeasureDirty | CXTPMarkupUIElement | protected
m_bMeasureInProgress | CXTPMarkupUIElement | protected
m_bNeverArranged | CXTPMarkupUIElement | protected
m_bNeverMeasured | CXTPMarkupUIElement | protected
m_pClipToBoundsProperty | CXTPMarkupUIElement | static
m_pFocusableProperty | CXTPMarkupUIElement | static
m_pIsEnabledProperty | CXTPMarkupUIElement | static
m_pOpacityProperty | CXTPMarkupUIElement | static
m_pRenderTransformOriginProperty | CXTPMarkupUIElement | static
m_pRenderTransformProperty | CXTPMarkupUIElement | static
m_ptVisualOffset | CXTPMarkupVisual | protected
m_pVisibilityProperty | CXTPMarkupUIElement | static
m_rcBoundRect | CXTPMarkupVisual | protected
m_rcFinalRect | CXTPMarkupUIElement | protected
m_rcPrevUpdateRect | CXTPMarkupVisual | protected
m_rcUpdateRect | CXTPMarkupVisual | protected
m_szDesiredSize | CXTPMarkupUIElement | protected
m_szPreviousAvailableSize | CXTPMarkupUIElement | protected
m_szRenderSize | CXTPMarkupVisual | protected
Measure(CXTPMarkupDrawingContext *pDC, CSize szAvailableSize) | CXTPMarkupUIElement |
MeasureCore(CXTPMarkupDrawingContext *pDC, CSize szAvailableSize) | CXTPMarkupUIElement | protectedvirtual
OnRender(CXTPMarkupDrawingContext *drawingContext) | CXTPMarkupVisual | protectedvirtual
OnRenderFocusVisual(CXTPMarkupDrawingContext *drawingContext) | CXTPMarkupVisual | protectedvirtual
PtInRectTransform(const RECT &rect, const POINT &point) const | CXTPMarkupVisual | protected
Render(CXTPMarkupDrawingContext *drawingContext) | CXTPMarkupVisual |
RenderClipped(CXTPMarkupDrawingContext *drawingContext) | CXTPMarkupVisual | protectedvirtual
RestoreRenderTransform(CXTPMarkupDrawingContext *pContext, TransformationMatrices &matrices) | CXTPMarkupUIElement | protectedvirtual
SetBackground(CXTPMarkupBrush *pBrush) | CXTPMarkupBorder |
SetBorderBrush(CXTPMarkupBrush *pBrush) | CXTPMarkupBorder |
SetBorderThickness(int nLeft, int nTop, int nRight, int nBottom) | CXTPMarkupBorder |
SetBorderThickness(int nBorderThickness) | CXTPMarkupBorder |
SetChild(CXTPMarkupUIElement *pChild) | CXTPMarkupDecorator |
SetClipToBounds(BOOL bClipToBounds) | CXTPMarkupFrameworkElement |
SetCornerRadius(int nCornerRadius) | CXTPMarkupBorder |
SetHeight(int nHeight) | CXTPMarkupFrameworkElement |
SetHorizontalAlignment(XTPMarkupHorizontalAlignment alignment) | CXTPMarkupFrameworkElement |
SetMargin(int nLeft, int nTop, int nRight, int nBottom) | CXTPMarkupFrameworkElement |
SetMargin(int nMargin) | CXTPMarkupFrameworkElement |
SetMaxHeight(int nHeight) | CXTPMarkupFrameworkElement |
SetMaxWidth(int nWidth) | CXTPMarkupFrameworkElement |
SetMinHeight(int nHeight) | CXTPMarkupFrameworkElement |
SetMinWidth(int nWidth) | CXTPMarkupFrameworkElement |
SetPadding(int nLeft, int nTop, int nRight, int nBottom) | CXTPMarkupBorder |
SetPadding(int nPadding) | CXTPMarkupBorder |
SetTag(CXTPMarkupObject *pTag) | CXTPMarkupFrameworkElement |
SetVerticalAlignment(XTPMarkupVerticalAlignment alignment) | CXTPMarkupFrameworkElement |
SetVisibility(XTPMarkupVisibility visibility) | CXTPMarkupUIElement |
SetWidth(int nWidth) | CXTPMarkupFrameworkElement |
~CXTPMarkupBorder() | CXTPMarkupBorder | protectedvirtual
~CXTPMarkupDecorator() | CXTPMarkupDecorator | protectedvirtual
~CXTPMarkupFrameworkElement() | CXTPMarkupFrameworkElement | protectedvirtual
~CXTPMarkupUIElement() | CXTPMarkupUIElement | protectedvirtual
~CXTPMarkupVisual() | CXTPMarkupVisual | virtual


Toolkit Pro: Member List

CXTPScrollableListBoxT< ListBoxBase > Member List

This is the complete list of members for CXTPScrollableListBoxT< ListBoxBase >, including all inherited members.

Create(LPCTSTR lpszClassName, LPCTSTR lpszWindowName, DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID, CCreateContext *pContext=NULL) | CXTPScrollable< ListBoxBase > | virtual
CreateEx(DWORD dwExStyle, LPCTSTR lpszClassName, LPCTSTR lpszWindowName, DWORD dwStyle, int x, int y, int nWidth, int nHeight, HWND hWndParent, HMENU nIDorHMenu, LPVOID lpParam=NULL) | CXTPScrollable< ListBoxBase > | virtual
CreateEx(DWORD dwExStyle, LPCTSTR lpszClassName, LPCTSTR lpszWindowName, DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID, LPVOID lpParam=NULL) | CXTPScrollable< ListBoxBase > | virtual
CXTPScrollable() | CXTPScrollable< ListBoxBase > |
CXTPScrollableListBoxT() | CXTPScrollableListBoxT< ListBoxBase > |
EnableDefaultBorderDrawing(BOOL bEnable=TRUE) | CXTPScrollable< ListBoxBase > |
InitScrollBars() | CXTPScrollable< ListBoxBase > |
SetScrollBarTheme(XTPScrollBarTheme nTheme) | CXTPScrollable< ListBoxBase > |
~IXTPScrollable() | IXTPScrollable | inlinevirtual


Toolkit Pro: Member List

CXTPChartBubbleSeriesPointView Member List

This is the complete list of members for CXTPChartBubbleSeriesPointView, including all inherited members.

AddChildView(CXTPChartElementView *pChildView) | CXTPChartElementView |
CreateDeviceCommand(CXTPChartDeviceContext *pDC) | CXTPChartBubbleSeriesPointView | virtual
CreateLegendDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcBounds) | CXTPChartPointSeriesPointView | virtual
CXTPChartBubbleSeriesPointView(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView) | CXTPChartBubbleSeriesPointView |
CXTPChartElementView(CXTPChartElementView *pParentView) | CXTPChartElementView |
CXTPChartElementView(CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartElementView |
CXTPChartElementView(CXTPChartContainer *pContainer) | CXTPChartElementView |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartPointSeriesPointView(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView) | CXTPChartPointSeriesPointView |
CXTPChartSeriesPointView(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView) | CXTPChartSeriesPointView |
CXTPChartSeriesPointView(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartSeriesPointView |
GetActualColor() const | CXTPChartBubbleSeriesPointView |
GetActualColor2() const | CXTPChartBubbleSeriesPointView |
GetAt(int nIndex) const | CXTPChartElementView |
GetBounds() const | CXTPChartElementView |
GetBounds(BOOL bIncludingChildren) const | CXTPChartElementView |
GetChildren() | CXTPChartElementView |
GetColor() const | CXTPChartSeriesPointView |
GetColor2() const | CXTPChartSeriesPointView |
GetCount() const | CXTPChartElementView |
GetInternalValue() const | CXTPChartSeriesPointView |
GetLegendName() const | CXTPChartSeriesPointView | virtual
GetParentView() const | CXTPChartElementView |
GetPoint() const | CXTPChartSeriesPointView |
GetScreenPoint() const | CXTPChartPointSeriesPointView |
GetSeriesView() const | CXTPChartSeriesPointView |
Is3D() const | CXTPChartObject |
m_arrChildren | CXTPChartElementView | protected
m_dInternalValue | CXTPChartSeriesPointView |
m_pContainer | CXTPChartElementView | protected
m_pParentView | CXTPChartElementView | protected
m_pPoint | CXTPChartSeriesPointView | protected
m_rcBounds | CXTPChartElementView | protected
UpdateMinMaxRange(double &nMinValue, double &nMaxValue) const | CXTPChartSeriesPointView | virtual
~CXTPChartElementView() | CXTPChartElementView | protectedvirtual
~CXTPChartLegendItemView() | CXTPChartLegendItemView | inlinevirtual


Toolkit Pro: XTPComboBox.h Source File

  • Source
  • Controls
  • Combo
XTPComboBox.h
Go to the documentation of this file.
1
23#if !defined(__XTPCOMBOBOX_H__)
24# define __XTPCOMBOBOX_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPComboBoxTheme;
34class CXTPComboBoxEditCtrl;
35class CXTPMarkupContext;
36
41class _XTP_EXT_CLASS CXTPComboBox : public CComboBox
42{
44 DECLARE_DYNAMIC(CXTPComboBox)
46public:
51 CXTPComboBox();
52
57 virtual ~CXTPComboBox();
58
65 virtual void Initialize(bool bAutoFont = true);
66
79 BOOL SetTheme(XTPControlTheme nTheme);
80
87 virtual void SetTheme(CXTPComboBoxTheme* pTheme);
88
96 CXTPComboBoxTheme* GetTheme();
97
105 const CXTPComboBoxTheme* GetTheme() const;
106
112 void RedrawComboBox(BOOL bUpdateWindow = FALSE);
113
123 BOOL GetFlatStyle() const;
124
133 void SetFlatStyle(BOOL bFlatStyle = TRUE);
134
154 BOOL GetUseVisualStyle() const;
155
175 void SetUseVisualStyle(BOOL bUseVisualStyle = TRUE);
176
183 void EnableAutoCompletion(BOOL bEnable = TRUE);
184
194 virtual void SetBackColor(COLORREF crBack);
195
206 COLORREF GetBackColor() const;
207
217 virtual void SetTextColor(COLORREF crText);
218
229 COLORREF GetTextColor() const;
230
236 void RefreshMetrics();
237
245 BOOL IsFocused() const;
246
255 BOOL IsHighlighted() const;
256
266 BOOL IsDroppedDown() const;
267
276 HBRUSH GetClientBrush(CDC* pDC);
277
285 CRect GetComboBoxRect() const;
286
293 void SetHighlighted(BOOL bHot);
294
295protected:
300 void RedrawFocusedFrame();
301
308 BOOL NeedRedraw();
309
312 //{{AFX_VIRTUAL(CXTPComboBox)
313 virtual BOOL PreCreateWindow(CREATESTRUCT& cs);
314 virtual void PreSubclassWindow();
315 virtual BOOL PreTranslateMessage(MSG* pMsg);
316 //}}AFX_VIRTUAL
317
318 virtual void Init();
319
320 //{{AFX_MSG(CXTPComboBox)
321 afx_msg int OnCreate(LPCREATESTRUCT lpCreateStruct);
322 afx_msg void OnPaint();
323 afx_msg void OnMouseMove(UINT nFlags, CPoint point);
324 afx_msg void OnKillFocus(CWnd* pNewWnd);
325 afx_msg void OnSetFocus(CWnd* pOldWnd);
326 afx_msg void OnSysColorChange();
327 afx_msg HBRUSH OnCtlColor(CDC* pDC, CWnd* pWnd, UINT nCtlColor);
328 afx_msg HBRUSH CtlColor(CDC* pDC, UINT nCtlColor); // reflect message
329 afx_msg BOOL OnEditUpdate();
330 afx_msg BOOL OnCloseUp();
331 afx_msg BOOL OnDropDown();
332 afx_msg void OnMouseLeave();
333 //}}AFX_MSG
334 afx_msg LRESULT OnSetTheme(WPARAM wParam, LPARAM lParam);
335
336 DECLARE_MESSAGE_MAP()
337
338
340protected:
341 BOOL m_bPreSubclassInit;
342 BOOL m_bUseVisualStyle;
343 BOOL m_bFlatStyle;
345 BOOL m_bHighlighted;
346 BOOL m_bFocused;
347 BOOL m_bAutoComp;
348 BOOL m_bDisableAC;
350 CXTPComboBoxTheme* m_pTheme;
351 CXTPComboBoxEditCtrl* m_pWndEdit;
353private:
354 friend class CXTPComboBoxEditCtrl;
355
356protected:
357 BOOL m_bEnableMarkup;
358 CXTPMarkupContext* m_pMarkupContext;
360 virtual void DrawItem(LPDRAWITEMSTRUCT lpDrawItemStruct);
361
362public:
369 void EnableMarkup(BOOL bEnableMarkup = TRUE);
370};
371
373
374AFX_INLINE BOOL CXTPComboBox::GetUseVisualStyle() const
375{
376 return m_bUseVisualStyle;
377}
378AFX_INLINE BOOL CXTPComboBox::IsFocused() const
379{
380 return m_bFocused;
381}
382AFX_INLINE BOOL CXTPComboBox::IsHighlighted() const
383{
384 return m_bHighlighted;
385}
386AFX_INLINE BOOL CXTPComboBox::GetFlatStyle() const
387{
388 return m_bFlatStyle;
389}
390AFX_INLINE void CXTPComboBox::SetFlatStyle(BOOL bFlatStyle /* = TRUE*/)
391{
392 m_bFlatStyle = bFlatStyle;
393 if (m_hWnd)
394 Invalidate(FALSE);
395}
396AFX_INLINE void CXTPComboBox::EnableAutoCompletion(BOOL bEnable /*=TRUE*/)
397{
398 m_bAutoComp = bEnable;
399}
401# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
403#endif // #if !defined(__XTPCOMBOBOX_H__)
XTPControlTheme
XTPControlTheme
Enumeration used to determine the active theme style.
Definition XTPControlTheme.h:43
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPComboBoxEditCtrl
Used by the CXTPComboBox object to subclass the edit-box portion of the control.
Definition XTPComboBoxEditCtrl.h:38
CXTPComboBox
The CXTPComboBox class provides the functionality of a themed Windows combobox.
Definition XTPComboBox.h:42
CXTPComboBox::GetTheme
CXTPComboBoxTheme * GetTheme()
Call this member function to retrieve a pointer to the current theme used by the combobox.
CXTPComboBox::RedrawComboBox
void RedrawComboBox(BOOL bUpdateWindow=FALSE)
Redraws the button.
CXTPComboBox::SetTheme
BOOL SetTheme(XTPControlTheme nTheme)
Call this member function to switch the visual theme of the control.
CXTPComboBox::IsHighlighted
BOOL IsHighlighted() const
Call this member function to determine if the combobox state is highilghted, meaning that the mouse c...
CXTPComboBox::~CXTPComboBox
virtual ~CXTPComboBox()
Destroys a CXTPComboBox object, handles cleanup and deallocation.
CXTPComboBox::SetUseVisualStyle
void SetUseVisualStyle(BOOL bUseVisualStyle=TRUE)
Enables Windows XP visual styles for the control.
CXTPComboBox::EnableAutoCompletion
void EnableAutoCompletion(BOOL bEnable=TRUE)
This member function enables/disables auto-completion.
CXTPComboBox::GetFlatStyle
BOOL GetFlatStyle() const
Gets the flat style appearance of the combobox.
CXTPComboBox::SetBackColor
virtual void SetBackColor(COLORREF crBack)
Call this member function to set the background color for the CXTPComboBox control.
CXTPComboBox::GetClientBrush
HBRUSH GetClientBrush(CDC *pDC)
Call this member function to retrieve a handle to the client background brush.
CXTPComboBox::SetTextColor
virtual void SetTextColor(COLORREF crText)
Call this member function to set the text color for the CXTPComboBox control.
CXTPComboBox::SetHighlighted
void SetHighlighted(BOOL bHot)
This member fuction is called to set the highlighted state for the combobox.
CXTPComboBox::IsDroppedDown
BOOL IsDroppedDown() const
Call this member function to determine if the combobox is currently dropped down.
CXTPComboBox::Initialize
virtual void Initialize(bool bAutoFont=true)
Call this member function to initialize the combobox.
CXTPComboBox::GetTextColor
COLORREF GetTextColor() const
Call this member function to retrieve the text color of the CXTPComboBox control.
CXTPComboBox::SetFlatStyle
void SetFlatStyle(BOOL bFlatStyle=TRUE)
Sets the flat style appearance of the button control.
CXTPComboBox::GetBackColor
COLORREF GetBackColor() const
Call this member function to retrieve the background color of the CXTPComboBox control.
CXTPComboBox::GetUseVisualStyle
BOOL GetUseVisualStyle() const
Determines if the control is drawn using visual styles/SkinFramework, if supported.
CXTPComboBox::GetComboBoxRect
CRect GetComboBoxRect() const
Call this member function to retrieve the size of the combobox in client coordinates.
CXTPComboBox::GetTheme
const CXTPComboBoxTheme * GetTheme() const
Call this member function to retrieve a pointer to the current theme used by the combobox.
CXTPComboBox::SetTheme
virtual void SetTheme(CXTPComboBoxTheme *pTheme)
This member function is called to set the theme for the combobox control using the theme specified by...
CXTPComboBox::NeedRedraw
BOOL NeedRedraw()
Called by the framework to determine if the combobox needs to be redrawn.
CXTPComboBox::CXTPComboBox
CXTPComboBox()
Constructs a CXTPComboBox object.
CXTPComboBox::RefreshMetrics
void RefreshMetrics()
This member function is called to update the color, text, and other visual elements of the control.
CXTPComboBox::RedrawFocusedFrame
void RedrawFocusedFrame()
Called by the framework to redraw the focused frame for the combobox.
CXTPComboBox::IsFocused
BOOL IsFocused() const
Call this member function to determine if the combobox has input focus.
CXTPComboBoxTheme
CXTPComboBoxTheme is a class used to perform ComboBox Theme drawing tasks.
Definition XTPComboBoxTheme.h:42
CXTPMarkupContext
CXTPMarkupContext is a standalone class used to provide common settings for Markup objects.
Definition XTPMarkupContext.h:128


Toolkit Pro: XTPSyntaxEditPropertiesPage.h Source File

  • Source
  • SyntaxEdit
XTPSyntaxEditPropertiesPage.h
Go to the documentation of this file.
1
23#if !defined(__XTPSYNTAXEDITPROPERTIESPAGE_H__)
24# define __XTPSYNTAXEDITPROPERTIESPAGE_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPSyntaxEditPropertiesDlg;
34class CXTPSyntaxEditView;
35class CXTPSyntaxEditTextSchemesManager;
36class CXTPSyntaxEditPaintManager;
37struct XTP_EDIT_SCHEMAFILEINFO;
38
39class CXTPSyntaxEditConfigurationManager;
40
42namespace XTPSyntaxEditLexAnalyser
44{
45class CXTPSyntaxEditLexPropInfoArray;
46class CXTPSyntaxEditLexClassInfoArray;
47struct XTP_EDIT_LEXCLASSINFO;
48struct XTP_EDIT_LEXPROPINFO;
49} // namespace XTPSyntaxEditLexAnalyser
50
56class _XTP_EXT_CLASS CXTPSyntaxEditTipWnd : public CWnd
57{
58public:
63 CXTPSyntaxEditTipWnd();
64
69 virtual ~CXTPSyntaxEditTipWnd();
70
80 virtual BOOL Create(CListBox* pListBox);
81
82 using CWnd::Create;
83
93 virtual BOOL IsOwnerDrawn();
94
104 virtual BOOL ShowTip(int iIndex);
105
116 virtual BOOL HideTip();
117
126 virtual COLORREF GetTextColor() const;
127
136 virtual COLORREF GetBackColor() const;
137
138protected:
146 virtual BOOL RegisterWindowClass(HINSTANCE hInstance = NULL);
147
158 virtual BOOL OwnerDrawTip(CDC* pDC, CRect rClient);
159
170 virtual BOOL DrawTip(CDC* pDC, CRect rClient);
171
181 virtual BOOL CalcItemRect(int iItem, CRect& rItem);
182
183//{{AFX_VIRTUAL(CXTPSyntaxEditTipWnd)
184//}}AFX_VIRTUAL
185
187# ifdef _DEBUG
188 virtual void AssertValid() const;
189 virtual void Dump(CDumpContext& dc) const;
190# endif
194 afx_msg void OnPaint();
195 afx_msg void OnTimer(UINT_PTR nIDEvent);
196 afx_msg LRESULT OnNcHitTest(CPoint point);
197 afx_msg void OnNcPaint();
198
199 DECLARE_MESSAGE_MAP()
202protected:
203 int m_iIndex;
204 CRect m_rWindow;
205 CPoint m_ptCursor;
206 CListBox* m_pListBox;
208private:
209 void SetTipTimer();
210 void KillTipTimer();
211 UINT m_uIDEvent1;
212 UINT m_uIDEvent2;
213};
214
219class _XTP_EXT_CLASS CXTPSyntaxEditTipListBox : public CListBox
220{
221public:
226 CXTPSyntaxEditTipListBox();
227
236 int HitTest(LPPOINT pPoint = NULL) const;
237
247 int HitTest(CPoint point, BOOL bIsClient = FALSE) const;
248
258 int ShowTip(CPoint point, BOOL bIsClient = FALSE);
259
266 BOOL SelChanged(); // const;
267
268protected:
270 virtual BOOL PreTranslateMessage(MSG* pMsg);
273protected:
274 DWORD m_dwIdx;
276 CXTPSyntaxEditTipWnd m_wndInfoTip;
277};
278
283class _XTP_EXT_CLASS CXTPSyntaxEditTipComboBox : public CComboBox
284{
285public:
294 CXTPSyntaxEditTipListBox& GetListBox();
295
296protected:
298 afx_msg HBRUSH OnCtlColor(CDC* pDC, CWnd* pWnd, UINT nCtlColor);
299 afx_msg void OnDestroy();
300
301 DECLARE_MESSAGE_MAP()
303private:
304 CXTPSyntaxEditTipListBox m_wndListBox;
305};
306
307AFX_INLINE CXTPSyntaxEditTipListBox& CXTPSyntaxEditTipComboBox::GetListBox()
308{
309 return m_wndListBox;
310}
311
316class _XTP_EXT_CLASS CXTPSyntaxEditPropertiesPageEdit : public CPropertyPage
317{
319 DECLARE_DYNCREATE(CXTPSyntaxEditPropertiesPageEdit)
321public:
327 CXTPSyntaxEditPropertiesPageEdit(CXTPSyntaxEditView* pEditView = NULL);
328
333 virtual ~CXTPSyntaxEditPropertiesPageEdit();
334
336 enum
337 {
338 IDD = XTP_IDD_EDIT_PAGEEDITOR
339 };
340 BOOL m_bAutoReload;
341 BOOL m_bHorzScrollBar;
342 BOOL m_bVertScrollBar;
343 BOOL m_bSyntaxColor;
344 BOOL m_bAutoIndent;
345 BOOL m_bSelMargin;
346 BOOL m_bLineNumbers;
347 BOOL m_bVirtualSpace;
348 BOOL m_bCollapsibleNodes;
349 int m_nCaretStyle;
350 int m_nTabType;
351 int m_nTabSize;
352 CButton m_btnRadioSpaces;
353 CButton m_btnRadioTab;
354 CButton m_btnRadioCaretThin;
355 CButton m_btnRadioCaretThick;
356
357protected:
358 virtual void DoDataExchange(CDataExchange* pDX);
359public:
360 virtual BOOL OnApply();
363protected:
372 BOOL ReadRegistryValues();
373
382 BOOL WriteRegistryValues();
383
391 void SetModified(BOOL bChanged = TRUE);
392
394 virtual BOOL OnInitDialog();
395 afx_msg void OnChkAutoReload();
396 afx_msg void OnChkHorzScrollBar();
397 afx_msg void OnChkVertScrollBar();
398 afx_msg void OnChkSyntaxColor();
399 afx_msg void OnChkAutoIndent();
400 afx_msg void OnChkSelMargin();
401 afx_msg void OnChkLineNumbers();
402 afx_msg void OnChkVirtualSpace();
403 afx_msg void OnChangeTabsSize();
404 afx_msg void OnTabsSpaces();
405 afx_msg void OnTabsTab();
406 afx_msg void OnCaretThin();
407 afx_msg void OnCaretThick();
408
409 DECLARE_MESSAGE_MAP()
412protected:
413 BOOL m_bModified;
414 CXTPSyntaxEditView* m_pEditView;
415};
416
421class _XTP_EXT_CLASS CXTPSyntaxEditPropertiesPageFont : public CPropertyPage
422{
424 DECLARE_DYNCREATE(CXTPSyntaxEditPropertiesPageFont)
426public:
432 CXTPSyntaxEditPropertiesPageFont(CXTPSyntaxEditView* pEditView = NULL);
433
438 virtual ~CXTPSyntaxEditPropertiesPageFont();
439
448 CFont& GetEditFont();
449
459 BOOL GetSafeLogFont(LOGFONT& lf);
460
474 BOOL CreateSafeFontIndirect(CFont& editFont, const LOGFONT& lf);
475
477 enum
478 {
479 IDD = XTP_IDD_EDIT_PAGEFONT
480 };
481 CXTPSyntaxEditColorComboBox m_wndComboHiliteText;
482 CXTPSyntaxEditColorComboBox m_wndComboHiliteBack;
483 CXTPSyntaxEditColorComboBox m_wndComboText;
484 CXTPSyntaxEditColorComboBox m_wndComboBack;
485 CXTPSyntaxEditColorSampleText m_txtSampleSel;
486 CXTPSyntaxEditColorSampleText m_txtSample;
487 CButton m_btnCustomText;
488 CButton m_btnCustomBack;
489 CButton m_btnCustomHiliteText;
490 CButton m_btnCustomHiliteBack;
491 CXTPSyntaxEditTipComboBox m_wndComboScript;
492 CXTPSyntaxEditTipComboBox m_wndComboStyle;
493 CXTPSyntaxEditTipComboBox m_wndComboSize;
494 CXTPSyntaxEditTipComboBox m_wndComboName;
495 BOOL m_bStrikeOut;
496 BOOL m_bUnderline;
497 CString m_csName;
498 CString m_csSize;
499 CString m_csStyle;
500 COLORREF m_crHiliteText;
501 COLORREF m_crHiliteBack;
502 COLORREF m_crText;
503 COLORREF m_crBack;
507protected:
508 virtual void DoDataExchange(CDataExchange* pDX);
509public:
510 virtual BOOL OnApply();
513protected:
518 void InitFontCombo();
519
524 void InitStyleCombo();
525
530 void InitSizeCombo();
531
536 void InitScriptCombo();
537
542 void InitColorComboxes();
543
548 void UpdateSampleFont();
549
554 void UpdateSampleColors();
555
568 int GetLBText(CComboBox& comboBox, CString& csItemText);
569
578 BOOL ReadRegistryValues();
579
588 BOOL WriteRegistryValues();
589
597 void SetModified(BOOL bChanged = TRUE);
598
605 CXTPSyntaxEditPaintManager* GetPaintManager();
606
608 virtual BOOL OnInitDialog();
609 afx_msg void OnSelChangeComboNames();
610 afx_msg void OnSelChangeComboStyles();
611 afx_msg void OnSelChangeComboSizes();
612 afx_msg void OnChkStrikeOut();
613 afx_msg void OnChkUnderline();
614 afx_msg void OnSelEndOkScript();
615 afx_msg void OnBtnCustomText();
616 afx_msg void OnBtnCustomBack();
617 afx_msg void OnBtnCustomHiliteText();
618 afx_msg void OnBtnCustomtHiliteBack();
619 afx_msg void OnSelEndOkHiliteText();
620 afx_msg void OnSelEndOkHiliteBack();
621 afx_msg void OnSelEndOkText();
622 afx_msg void OnSelEndOkBack();
623
624 DECLARE_MESSAGE_MAP()
627protected:
628 const UINT m_uFaceSize;
630 BYTE m_iCharSet;
631 BOOL m_bModified;
632 CXTPSyntaxEditView* m_pEditView;
634 CXTPFont m_xtpFontEdit;
635 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CFont, m_editFont, m_xtpFontEdit, GetEditFontHandle);
636};
637
638AFX_INLINE CFont& CXTPSyntaxEditPropertiesPageFont::GetEditFont()
639{
640 return m_xtpFontEdit;
641}
642
647class _XTP_EXT_CLASS CXTPSyntaxEditPropertiesPageColor : public CPropertyPage
648{
650 DECLARE_DYNCREATE(CXTPSyntaxEditPropertiesPageColor)
652public:
658 CXTPSyntaxEditPropertiesPageColor(CXTPSyntaxEditView* pEditView = NULL);
659
664 virtual ~CXTPSyntaxEditPropertiesPageColor();
665
672 BOOL WriteRegistryValues();
673
681 void SetModified(BOOL bChanged = TRUE);
682
684 enum
685 {
686 IDD = XTP_IDD_EDIT_PAGECOLOR
687 };
688 CXTPSyntaxEditColorSampleText m_txtSampleSel;
689 CXTPSyntaxEditColorSampleText m_txtSample;
690 CXTPSyntaxEditColorComboBox m_wndComboHiliteText;
691 CXTPSyntaxEditColorComboBox m_wndComboHiliteBack;
692 CXTPSyntaxEditColorComboBox m_wndComboText;
693 CXTPSyntaxEditColorComboBox m_wndComboBack;
694 CButton m_btnBold;
695 CButton m_btnItalic;
696 CButton m_btnUnderline;
697 CButton m_btnCustomText;
698 CButton m_btnCustomBack;
699 CButton m_btnCustomHiliteText;
700 CButton m_btnCustomHiliteBack;
701 CXTPSyntaxEditTipListBox m_lboxName;
702 CXTPSyntaxEditTipListBox m_lboxProp;
703 CStatic m_gboxSampleText;
704 BOOL m_bBold;
705 BOOL m_bItalic;
706 BOOL m_bUnderline;
707 COLORREF m_crHiliteText;
708 COLORREF m_crHiliteBack;
709 COLORREF m_crText;
710 COLORREF m_crBack;
711
712public:
713 virtual BOOL OnSetActive();
714
715protected:
716 virtual void DoDataExchange(CDataExchange* pDX);
717public:
718 virtual BOOL OnApply();
721protected:
726 void UpdateSampleColors();
727
732 void UpdateFont();
733
741 BOOL InitSchemaClasses(XTP_EDIT_SCHEMAFILEINFO* pSchemaInfo);
742
748 void InitClassData(const XTPSyntaxEditLexAnalyser::XTP_EDIT_LEXCLASSINFO& infoClass);
749
757 BOOL IsTopLevelClass(const XTPSyntaxEditLexAnalyser::XTP_EDIT_LEXCLASSINFO& infoClass);
758
763 void EnableControls();
764
774 CString GetPropValue(const XTPSyntaxEditLexAnalyser::XTP_EDIT_LEXPROPINFO& infoProp) const;
775
780 void SetDefaults();
781
791 int PropExists(XTPSyntaxEditLexAnalyser::CXTPSyntaxEditLexPropInfoArray& arrProp,
792 LPCTSTR lpszPropName);
793
804 BOOL UpdateFontValue(BOOL& bValue, LPCTSTR lpszPropName);
805
817 BOOL UpdateColorValue(CXTPSyntaxEditColorComboBox& combo, COLORREF& color,
818 LPCTSTR lpszPropName);
819
827 CString GetDisplayName(const XTPSyntaxEditLexAnalyser::XTP_EDIT_LEXCLASSINFO& info) const;
828
830 virtual BOOL OnInitDialog();
831 afx_msg void OnBtnCustomText();
832 afx_msg void OnBtnCustomBack();
833 afx_msg void OnBtnCustomHiliteText();
834 afx_msg void OnBtnCustomtHiliteBack();
835 afx_msg void OnChkBold();
836 afx_msg void OnChkItalic();
837 afx_msg void OnChkUnderline();
838 afx_msg void OnSelEndOkHiliteText();
839 afx_msg void OnSelEndOkHiliteBack();
840 afx_msg void OnSelEndOkText();
841 afx_msg void OnSelEndOkBack();
842 afx_msg void OnSelChangeSchemaNames();
843 afx_msg void OnSelChangeSchemaProp();
844 afx_msg void OnDblClickSchema();
845 afx_msg void OnContextMenu(CWnd* pWnd, CPoint point);
846
847 DECLARE_MESSAGE_MAP()
850protected:
851 BOOL m_bModified;
852 CXTPSyntaxEditView* m_pEditView;
853 CXTPSyntaxEditConfigurationManager* m_ptrConfigMgr;
854 CXTPSyntaxEditTextSchemesManager* m_pTextSchemesMgr;
855 CXTPFont m_xtpFontEdit;
856 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CFont, m_editFont, m_xtpFontEdit, GetEditFontHandle);
857 CMapStringToPtr m_mapLexClassInfo;
859 XTPSyntaxEditLexAnalyser::CXTPSyntaxEditLexClassInfoArray* m_parLexClassInfo;
862};
863
865
866//{{AFX_INSERT_LOCATION}}
867// Microsoft Visual C++ will insert additional declarations immediately before the previous line.
868
869# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
871#endif // !defined(__XTPSYNTAXEDITPROPERTIESPAGE_H__)
pPoint
const CPoint * pPoint
return 0 or xtpCalendarHitTestDayExpandButton
Definition XTPCalendarThemeOffice2007.h:150
XTPDisableNoisyWarnings.h
CXTPFont
Provides a convenient object oriented interface for HFONT GDI object and uses GDI handle caching.
Definition XTPGdiObjects.h:414
CXTPSyntaxEditColorComboBox
This class allows for colors to be edited by using a combobox control.
Definition XTPSyntaxEditColorComboBox.h:39
CXTPSyntaxEditColorSampleText
This class, derived from CStatic, is used to display a sample of colored text.
Definition XTPSyntaxEditColorSampleText.h:38
CXTPSyntaxEditConfigurationManager
This class manages all configuration parameters of the control.
Definition XTPSyntaxEditLexColorFileReader.h:601
CXTPSyntaxEditPaintManager
This class is used by CXTPSyntaxEditCtrl as the paint manager.
Definition XTPSyntaxEditPaintManager.h:47
CXTPSyntaxEditPropertiesDlg
This class provides a default dialog to edit SyntaxEdit control settings.
Definition XTPSyntaxEditPropertiesDlg.h:40
CXTPSyntaxEditPropertiesPageColor
This class implements property page colors options.
Definition XTPSyntaxEditPropertiesPage.h:648
CXTPSyntaxEditPropertiesPageColor::EnableControls
void EnableControls()
Updates controls state (enabled/disabled).
CXTPSyntaxEditPropertiesPageColor::UpdateColorValue
BOOL UpdateColorValue(CXTPSyntaxEditColorComboBox &combo, COLORREF &color, LPCTSTR lpszPropName)
Updates the color parameters for currently selected lex class.
CXTPSyntaxEditPropertiesPageColor::GetDisplayName
CString GetDisplayName(const XTPSyntaxEditLexAnalyser::XTP_EDIT_LEXCLASSINFO &info) const
Gets the display name property value of a lex class.
CXTPSyntaxEditPropertiesPageColor::IsTopLevelClass
BOOL IsTopLevelClass(const XTPSyntaxEditLexAnalyser::XTP_EDIT_LEXCLASSINFO &infoClass)
Determines if a specified class is a top-level schema class.
CXTPSyntaxEditPropertiesPageColor::InitSchemaClasses
BOOL InitSchemaClasses(XTP_EDIT_SCHEMAFILEINFO *pSchemaInfo)
Initializes dialog controls for a specified lex schema.
CXTPSyntaxEditPropertiesPageColor::WriteRegistryValues
BOOL WriteRegistryValues()
Writes controls state (options) to the registry.
CXTPSyntaxEditPropertiesPageColor::InitClassData
void InitClassData(const XTPSyntaxEditLexAnalyser::XTP_EDIT_LEXCLASSINFO &infoClass)
Initializes dialog controls for a specified lex class.
CXTPSyntaxEditPropertiesPageColor::SetDefaults
void SetDefaults()
Sets defaults controls state.
CXTPSyntaxEditPropertiesPageColor::UpdateFont
void UpdateFont()
Updates the font for a sample text control.
CXTPSyntaxEditPropertiesPageColor::~CXTPSyntaxEditPropertiesPageColor
virtual ~CXTPSyntaxEditPropertiesPageColor()
Default object destructor.
CXTPSyntaxEditPropertiesPageColor::CXTPSyntaxEditPropertiesPageColor
CXTPSyntaxEditPropertiesPageColor(CXTPSyntaxEditView *pEditView=NULL)
Default object constructor.
CXTPSyntaxEditPropertiesPageColor::GetPropValue
CString GetPropValue(const XTPSyntaxEditLexAnalyser::XTP_EDIT_LEXPROPINFO &infoProp) const
Gets a specified lex property as a comma-separated string.
CXTPSyntaxEditPropertiesPageColor::UpdateSampleColors
void UpdateSampleColors()
Updates the colors for a sample text control.
CXTPSyntaxEditPropertiesPageColor::SetModified
void SetModified(BOOL bChanged=TRUE)
Sets the value of the modified flag.
CXTPSyntaxEditPropertiesPageColor::PropExists
int PropExists(XTPSyntaxEditLexAnalyser::CXTPSyntaxEditLexPropInfoArray &arrProp, LPCTSTR lpszPropName)
Determines if a specified property data exists within a specified array.
CXTPSyntaxEditPropertiesPageColor::UpdateFontValue
BOOL UpdateFontValue(BOOL &bValue, LPCTSTR lpszPropName)
Updates the font parameters for the currently selected lex class.
CXTPSyntaxEditPropertiesPageEdit
This class implements a property page for common edit options.
Definition XTPSyntaxEditPropertiesPage.h:317
CXTPSyntaxEditPropertiesPageEdit::ReadRegistryValues
BOOL ReadRegistryValues()
Reads controls state (options) from the registry.
CXTPSyntaxEditPropertiesPageEdit::WriteRegistryValues
BOOL WriteRegistryValues()
Writes controls state (options) to the registry.
CXTPSyntaxEditPropertiesPageEdit::~CXTPSyntaxEditPropertiesPageEdit
virtual ~CXTPSyntaxEditPropertiesPageEdit()
Default object destructor.
CXTPSyntaxEditPropertiesPageEdit::SetModified
void SetModified(BOOL bChanged=TRUE)
Sets the value of the modified flag.
CXTPSyntaxEditPropertiesPageEdit::CXTPSyntaxEditPropertiesPageEdit
CXTPSyntaxEditPropertiesPageEdit(CXTPSyntaxEditView *pEditView=NULL)
Default object constructor.
CXTPSyntaxEditPropertiesPageFont
This class implements property page font options.
Definition XTPSyntaxEditPropertiesPage.h:422
CXTPSyntaxEditPropertiesPageFont::InitSizeCombo
void InitSizeCombo()
Initializes the font size combo box.
CXTPSyntaxEditPropertiesPageFont::CXTPSyntaxEditPropertiesPageFont
CXTPSyntaxEditPropertiesPageFont(CXTPSyntaxEditView *pEditView=NULL)
Default object constructor.
CXTPSyntaxEditPropertiesPageFont::ReadRegistryValues
BOOL ReadRegistryValues()
Reads controls state (options) from the registry.
CXTPSyntaxEditPropertiesPageFont::InitScriptCombo
void InitScriptCombo()
Initializes the font script combo box.
CXTPSyntaxEditPropertiesPageFont::GetSafeLogFont
BOOL GetSafeLogFont(LOGFONT &lf)
Gets the LOGFONT data for the editor font object.
CXTPSyntaxEditPropertiesPageFont::CreateSafeFontIndirect
BOOL CreateSafeFontIndirect(CFont &editFont, const LOGFONT &lf)
Sets the font for a specified CFont object.
CXTPSyntaxEditPropertiesPageFont::InitStyleCombo
void InitStyleCombo()
Initializes the font style combo box.
CXTPSyntaxEditPropertiesPageFont::WriteRegistryValues
BOOL WriteRegistryValues()
Writes controls state (options) to the registry.
CXTPSyntaxEditPropertiesPageFont::UpdateSampleFont
void UpdateSampleFont()
Updates the font for a sample text control.
CXTPSyntaxEditPropertiesPageFont::~CXTPSyntaxEditPropertiesPageFont
virtual ~CXTPSyntaxEditPropertiesPageFont()
Default object destructor.
CXTPSyntaxEditPropertiesPageFont::UpdateSampleColors
void UpdateSampleColors()
Updates the colors for a sample text control.
CXTPSyntaxEditPropertiesPageFont::SetModified
void SetModified(BOOL bChanged=TRUE)
Sets the value of the modified flag.
CXTPSyntaxEditPropertiesPageFont::GetLBText
int GetLBText(CComboBox &comboBox, CString &csItemText)
Gets the text of the selected list box item and updates the combo box.
CXTPSyntaxEditPropertiesPageFont::GetPaintManager
CXTPSyntaxEditPaintManager * GetPaintManager()
Gets the edit control paint manager.
CXTPSyntaxEditPropertiesPageFont::InitColorComboxes
void InitColorComboxes()
Initializes the color combo box.
CXTPSyntaxEditPropertiesPageFont::InitFontCombo
void InitFontCombo()
Initializes the font name combo box.
CXTPSyntaxEditTextSchemesManager
This class provides the functionality to store the set of all text schemes that would be written from...
Definition XTPSyntaxEditLexColorFileReader.h:448
CXTPSyntaxEditTipComboBox
This class implements a combo box with a tooltip.
Definition XTPSyntaxEditPropertiesPage.h:284
CXTPSyntaxEditTipComboBox::GetListBox
CXTPSyntaxEditTipListBox & GetListBox()
Gets the attached list box.
Definition XTPSyntaxEditPropertiesPage.h:307
CXTPSyntaxEditTipListBox
This class implements a list box with a tooltip.
Definition XTPSyntaxEditPropertiesPage.h:220
CXTPSyntaxEditTipListBox::m_wndInfoTip
CXTPSyntaxEditTipWnd m_wndInfoTip
Tooltip window.
Definition XTPSyntaxEditPropertiesPage.h:276
CXTPSyntaxEditTipListBox::m_dwIdx
DWORD m_dwIdx
Selection indexes: LOWORD - previous selection index, HIWORD - active selection index.
Definition XTPSyntaxEditPropertiesPage.h:274
CXTPSyntaxEditTipListBox::HitTest
int HitTest(LPPOINT pPoint=NULL) const
Determines which list box item, if any, is at a specified point.
CXTPSyntaxEditTipListBox::CXTPSyntaxEditTipListBox
CXTPSyntaxEditTipListBox()
Default object constructor.
CXTPSyntaxEditTipListBox::ShowTip
int ShowTip(CPoint point, BOOL bIsClient=FALSE)
Shows the tooltip at a specified point, if any.
CXTPSyntaxEditTipListBox::HitTest
int HitTest(CPoint point, BOOL bIsClient=FALSE) const
Determines which list box item, if any, is at a specified point.
CXTPSyntaxEditTipListBox::SelChanged
BOOL SelChanged()
Determines if the selection was changed by the user.
CXTPSyntaxEditTipWnd
CXTPSyntaxEditTipWnd implements a tooltip window for the CXTPSyntaxEditTipListBox class.
Definition XTPSyntaxEditPropertiesPage.h:57
CXTPSyntaxEditTipWnd::OwnerDrawTip
virtual BOOL OwnerDrawTip(CDC *pDC, CRect rClient)
Draws the tooltip for the owner drawn list box.
CXTPSyntaxEditTipWnd::CalcItemRect
virtual BOOL CalcItemRect(int iItem, CRect &rItem)
Gets the rectangle for a specified item.
CXTPSyntaxEditTipWnd::~CXTPSyntaxEditTipWnd
virtual ~CXTPSyntaxEditTipWnd()
Default object destructor.
CXTPSyntaxEditTipWnd::HideTip
virtual BOOL HideTip()
Hides the tooltip.
CXTPSyntaxEditTipWnd::RegisterWindowClass
virtual BOOL RegisterWindowClass(HINSTANCE hInstance=NULL)
Registers the window class if it has not already been registered.
CXTPSyntaxEditTipWnd::CXTPSyntaxEditTipWnd
CXTPSyntaxEditTipWnd()
Default object constructor.
CXTPSyntaxEditTipWnd::DrawTip
virtual BOOL DrawTip(CDC *pDC, CRect rClient)
Draws the tooltip.
CXTPSyntaxEditTipWnd::ShowTip
virtual BOOL ShowTip(int iIndex)
Shows the tooltip for a specified list box item.
CXTPSyntaxEditTipWnd::IsOwnerDrawn
virtual BOOL IsOwnerDrawn()
Determines if the attached list box has owner draw flags (LBS_OWNERDRAWFIXED or LBS_OWNERDRAWVARIABLE...
CXTPSyntaxEditTipWnd::Create
virtual BOOL Create(CListBox *pListBox)
Create a tooltip window.
CXTPSyntaxEditTipWnd::GetBackColor
virtual COLORREF GetBackColor() const
Gets the tooltip background color.
CXTPSyntaxEditTipWnd::GetTextColor
virtual COLORREF GetTextColor() const
Gets the tooltip text color.
CXTPSyntaxEditView
This class represents a View portion of the Edit Control.
Definition XTPSyntaxEditView.h:89


Toolkit Pro: XTPEnableNoisyWarnings.h Source File

  • Source
  • Common
  • Base
  • Diagnostic
XTPEnableNoisyWarnings.h
Go to the documentation of this file.
1
24#define XTP_INTERNAL_WARNING_CONTROL
25#include "Common/Base/Diagnostic/XTPEnableAdvancedWarnings.h"
26
XTPEnableAdvancedWarnings.h


Toolkit Pro: XTPTabToolBar.h Source File

  • Source
  • CommandBars
XTPTabToolBar.h
Go to the documentation of this file.
1
23#if !defined(__XTPTABTOOLBAR_H__) && defined(_XTP_INCLUDE_TABMANAGER)
24# define __XTPTABTOOLBAR_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
37class _XTP_EXT_CLASS CXTPTabToolBar
38 : public CXTPToolBar
39 , public CXTPTabManager
40{
41private:
43 DECLARE_XTP_COMMANDBAR(CXTPTabToolBar)
45public:
50 CXTPTabToolBar();
51
56 virtual ~CXTPTabToolBar();
57
58public:
70 CXTPTabManagerItem* InsertCategory(int nItem, LPCTSTR lpszItem, UINT* pItems, int nCount,
71 BOOL bLoadIcons = TRUE);
72
83 CXTPTabManagerItem* InsertCategory(int nItem, LPCTSTR lpszItem, UINT nIDResource,
84 BOOL bLoadIcons = TRUE);
85
91 void UpdateTabs(CXTPTabManagerItem* pItem = NULL);
92
105 virtual CXTPTabPaintManager* GetPaintManager() const;
106
112 void SetMinimumWidth(int nMinWidth);
113
114protected:
119 void Reposition();
120
136 BOOL DrawIcon(CDC* pDC, CPoint pt, CXTPTabManagerItem* pItem, BOOL bDraw, CSize& szIcon) const;
137
147 void RedrawControl(LPCRECT lpRect, BOOL bAnimate);
148
162 void SetSelectedItem(CXTPTabManagerItem* pItem);
163
171 BOOL OnBeforeItemClick(CXTPTabManagerItem* pItem);
172
179 CRect GetBorders();
180
187 void DrawCommandBar(CDC* pDC, CRect rcClipBox);
188
198 CSize CalcDockingLayout(int nLength, DWORD dwMode, int nWidth);
199
209 CSize CalcDynamicLayout(int nLength, DWORD dwMode);
210
216 void Reset(BOOL bShowWarningMessage);
217
226 void OnCustomizeDrop(CXTPControl* pDataObject, DROPEFFECT& dropEffect, CPoint ptDrop,
227 CPoint ptDrag);
228
229protected:
230 void BeforeCustomizeControlAdd(CXTPControl* pControl);
231
232protected:
233# ifdef _XTP_COMMANDBARS_ACTIVEX
236 LPDISPATCH OleInsertCategory(int nIndex, LPCTSTR lpszTitle);
237 long OleGetItemCount();
238 LPDISPATCH OleGetItem(int nIndex);
239 void OleRemoveCategory(int nIndex);
240 LPDISPATCH OleGetTabPaintManager();
241 void OleUpdateTabs();
242
243 DECLARE_DISPATCH_MAP()
244 DECLARE_OLETYPELIB_EX(CXTPTabToolBar);
245 DECLARE_INTERFACE_MAP()
246 DECLARE_ENUM_VARIANT(CXTPTabToolBar);
247
248 DECLARE_CONNECTION_EX(CXTPTabToolBar)
249
251# endif
252
253protected:
255 DECLARE_MESSAGE_MAP()
256
257 //{{AFX_VIRTUAL(CXTPTabToolBar)
258 //}}AFX_VIRTUAL
259
260 //{{AFX_MSG(CXTPTabToolBar)
261 afx_msg void OnMouseLeave();
262 afx_msg void OnMouseMove(UINT nFlags, CPoint point);
263 afx_msg INT_PTR OnToolHitTest(CPoint point, TOOLINFO* pTI) const;
264 afx_msg void OnSysColorChange();
265 afx_msg void OnLButtonDown(UINT nFlags, CPoint point);
266 //}}AFX_MSG
268protected:
269 CXTPTabPaintManager* m_pTabPaintManager;
270 CRect m_rcTabControl;
271 int m_nMinWidth;
272};
273
274AFX_INLINE CXTPTabPaintManager* CXTPTabToolBar::GetPaintManager() const
275{
276 return m_pTabPaintManager;
277}
278AFX_INLINE void CXTPTabToolBar::SetMinimumWidth(int nMinWidth)
279{
280 m_nMinWidth = nMinWidth;
281}
283# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
284#endif // #if !defined(__XTPTABTOOLBAR_H__)
DECLARE_XTP_COMMANDBAR
#define DECLARE_XTP_COMMANDBAR(class_name)
This macro generates the C++ header code necessary for a CXTPCommandBar-derived class that can be ser...
Definition XTPCommandBarsDefines.h:1234
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCommandBar::GetPaintManager
CXTPPaintManager * GetPaintManager() const
Call this method to retrieve the paint manager.
CXTPControl
CXTPControl is a CXTPCmdTarget derived class.
Definition XTPControl.h:841
CXTPTabManager
CXTPTabManager is the base class for docking pane tabs, tab control tabs, and MDI client tabs.
Definition XTPTabManager.h:87
CXTPTabManagerItem
CXTPTabManagerItem is the base class for the tabs that appear in the command bars tab workspace,...
Definition XTPTabManagerItem.h:44
CXTPTabPaintManager
CXTPTabPaintManager is used to store the color and appearance information of the tabs in the tab mana...
Definition XTPTabPaintManager.h:48
CXTPTabToolBar
CXTPTabToolBar is a CXTPToolBar derived class.
Definition XTPTabToolBar.h:40
CXTPTabToolBar::OnCustomizeDrop
void OnCustomizeDrop(CXTPControl *pDataObject, DROPEFFECT &dropEffect, CPoint ptDrop, CPoint ptDrag)
This method is called when a control is dropped to the command bar.
CXTPTabToolBar::InsertCategory
CXTPTabManagerItem * InsertCategory(int nItem, LPCTSTR lpszItem, UINT *pItems, int nCount, BOOL bLoadIcons=TRUE)
Call this method to add a new tab to CXTPTabToolBar.
CXTPTabToolBar::SetMinimumWidth
void SetMinimumWidth(int nMinWidth)
Call this method to set the minimum available width of the toolbar.
Definition XTPTabToolBar.h:278
CXTPTabToolBar::~CXTPTabToolBar
virtual ~CXTPTabToolBar()
Destroys a CXTPTabToolBar object, handles cleanup and deallocation.
CXTPTabToolBar::RedrawControl
void RedrawControl(LPCRECT lpRect, BOOL bAnimate)
This member is called when the visual properties of the tabs are changed (e.g.
CXTPTabToolBar::UpdateTabs
void UpdateTabs(CXTPTabManagerItem *pItem=NULL)
Call this method to refresh controls on the selected tab.
CXTPTabToolBar::CXTPTabToolBar
CXTPTabToolBar()
Constructs a CXTPTabToolBar object.
CXTPTabToolBar::Reposition
void Reposition()
This method is called to update the position of TabManager.
CXTPTabToolBar::SetSelectedItem
void SetSelectedItem(CXTPTabManagerItem *pItem)
Call this member to select a CXTPTabManagerItem tab.
CXTPTabToolBar::GetBorders
CRect GetBorders()
This method retrieves the borders of the toolbar.
CXTPTabToolBar::OnBeforeItemClick
BOOL OnBeforeItemClick(CXTPTabManagerItem *pItem)
This method is called before an item click.
CXTPTabToolBar::CalcDockingLayout
CSize CalcDockingLayout(int nLength, DWORD dwMode, int nWidth)
This method calculates the dimensions of a toolbar.
CXTPTabToolBar::DrawCommandBar
void DrawCommandBar(CDC *pDC, CRect rcClipBox)
This method is called to draw the command bar in the given context.
CXTPTabToolBar::InsertCategory
CXTPTabManagerItem * InsertCategory(int nItem, LPCTSTR lpszItem, UINT nIDResource, BOOL bLoadIcons=TRUE)
Call this method to add a new tab to CXTPTabToolBar.
CXTPTabToolBar::DrawIcon
BOOL DrawIcon(CDC *pDC, CPoint pt, CXTPTabManagerItem *pItem, BOOL bDraw, CSize &szIcon) const
This member is called when the icon of the tab needs to be drawn.
CXTPTabToolBar::CalcDynamicLayout
CSize CalcDynamicLayout(int nLength, DWORD dwMode)
This method calculates the dimensions of a toolbar.
CXTPTabToolBar::Reset
void Reset(BOOL bShowWarningMessage)
Resets the controls to their original state.
CXTPToolBar
CXTPToolBar is a CXTPCommandBar derived class.
Definition XTPToolBar.h:42


Toolkit Pro: Member List

CXTPCommandBarsVisualStudio2012Theme Member List

This is the complete list of members for CXTPCommandBarsVisualStudio2012Theme, including all inherited members.

AdjustExcludeRect(CRect &rc, CXTPControl *pControl, BOOL bVertical) | CXTPCommandBarsOfficeXPTheme | virtual
Animate(CDC *pDestDC, CDC *pSrcDC, CRect rc, XTPAnimationType animationType) | CXTPPaintManager | virtual
AnimateExpanding(CXTPCommandBar *pCommandBar, CDC *pDestDC, CDC *pSrcDC, BOOL bExpandDown) | CXTPPaintManager | virtual
BaseTheme() | CXTPCommandBarsVisualStudio2012Theme | inlinevirtual
CreateTheme(XTPPaintTheme paintTheme) | CXTPPaintManager | static
CXTPCmdTarget() | CXTPCmdTarget |
CXTPCommandBarsModernUITheme() | CXTPCommandBarsModernUITheme |
CXTPCommandBarsOfficeXPTheme() | CXTPCommandBarsOfficeXPTheme |
CXTPCommandBarsVisualStudio2012Theme(XTPPaintTheme paintTheme=xtpThemeVisualStudio2012Light) | CXTPCommandBarsVisualStudio2012Theme | explicit
CXTPObservable() | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | protected
CXTPPaintManager() | CXTPPaintManager | protected
Draw3dRect(CDC *pDC, LPCRECT rc, int nTopLeft, int nBottomRight) | CXTPPaintManager |
Draw3dRect(CDC *pDC, LPCRECT rc, int frameThickness, COLORREF clrPen, COLORREF clrBrush) | CXTPPaintManager |
CXTPPaintManager::DrawCheckMark(CDC *pDC, CRect rcCheck, COLORREF clr=0) | CXTPPaintManager | inline
DrawComboExpandMark(CDC *pDC, CRect rc, COLORREF clr) | CXTPPaintManager | virtual
DrawCommandBarGripper(CDC *pDC, CXTPCommandBar *pBar, BOOL bDraw=TRUE) | CXTPCommandBarsVisualStudio2012Theme | virtual
DrawCommandBarGroupSeparator(CDC *pDC, CXTPCommandBar *pBar, CXTPControl *pLeftControl, CXTPControl *pRightControl, BOOL bDraw=TRUE) | CXTPPaintManager | virtual
DrawCommandBarSeparator(CDC *pDC, CXTPCommandBar *pBar, CXTPControl *pControl, BOOL bDraw=TRUE) | CXTPCommandBarsVisualStudio2012Theme | virtual
DrawControl(CDC *pDC, CXTPControl *pButton, BOOL bDraw=TRUE) | CXTPPaintManager |
DrawControlCheckBoxMark(CDC *pDC, CRect rc, BOOL bDraw, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled) | CXTPCommandBarsVisualStudio2012Theme | protectedvirtual
CXTPCommandBarsModernUITheme::DrawControlCheckBoxMark(CDC *pDC, CXTPControl *pButton, CRect rc, BOOL bDraw) | CXTPCommandBarsOfficeXPTheme | protectedvirtual
DrawControlComboBox(CDC *pDC, CXTPControlComboBox *pControlCombo, BOOL bDraw) | CXTPCommandBarsVisualStudio2012Theme | virtual
DrawControlEdit(CDC *pDC, CXTPControlEdit *pEdit, BOOL bDraw) | CXTPCommandBarsOfficeXPTheme | protectedvirtual
DrawControlEntry(CDC *pDC, CXTPControl *pButton) | CXTPPaintManager | virtual
DrawControlMDIButton(CDC *pDC, CXTPControlButton *pButton) | CXTPPaintManager | virtual
DrawControlPopupParent(CDC *pDC, CXTPControl *pButton, BOOL bDraw) | CXTPCommandBarsOfficeXPTheme | protectedvirtual
DrawControlRadioButtonMark(CDC *pDC, CRect rc, BOOL bDraw, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled) | CXTPCommandBarsOfficeXPTheme | protectedvirtual
DrawControlText(CDC *pDC, CXTPControl *pControl, CRect rcText, BOOL bDraw, BOOL bVert, BOOL bCentered, BOOL bTriangled) | CXTPPaintManager |
DrawControlToolBarParent(CDC *pDC, CXTPControl *pButton, BOOL bDraw) | CXTPPaintManager | virtual
DrawDialogBarGripper(CDC *pDC, CXTPDialogBar *pBar, BOOL bDraw) | CXTPCommandBarsOfficeXPTheme | virtual
DrawDropDownGlyph(CDC *pDC, CXTPControl *pControl, CPoint pt, BOOL bSelected, BOOL bPopuped, BOOL bEnabled, BOOL bVert) | CXTPCommandBarsVisualStudio2012Theme | virtual
DrawExpandGlyph(CDC *pDC, CXTPControl *pButton, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clr) | CXTPCommandBarsVisualStudio2012Theme | virtual
DrawExpandGlyph(CDC *pDC, CXTPControl *pButton, COLORREF clr, BOOL bVertical) | CXTPCommandBarsVisualStudio2012Theme | virtual
DrawGalleryItemBack(CDC *pDC, CRect rcItem, BOOL bEnabled, BOOL bSelected, BOOL bPressed, BOOL bChecked, XTPBarType barType) | CXTPPaintManager | virtual
DrawHiddenGlyph(CDC *pDC, CXTPControl *pButton, COLORREF clr, BOOL bVertical) | CXTPCommandBarsVisualStudio2012Theme | virtual
DrawImage(CDC *pDC, CPoint pt, CSize sz, CXTPImageManagerIcon *pImage, BOOL bSelected, BOOL bPressed, BOOL bEnabled=TRUE, BOOL bChecked=FALSE, BOOL bPopuped=FALSE, BOOL bToolBarImage=TRUE) | CXTPCommandBarsOfficeXPTheme | protectedvirtual
DrawListBoxControl(CDC *pDC, CXTPControl *pButton, CRect rc, BOOL bSelected, BOOL bDraw, CXTPCommandBars *pCommandBars=0) | CXTPCommandBarsOfficeXPTheme | virtual
DrawPopupBarCheckMark(CDC *pDC, CRect rcCheck, BOOL bEnabled, COLORREF clr) | CXTPPaintManager | virtual
DrawPopupBarGripper(CDC *pDC, int xPos, int yPos, int cx, int cy, BOOL bExpanded) | CXTPCommandBarsVisualStudio2012Theme | virtual
DrawPopupBarRadioMark(CDC *pDC, CRect rcCheck, BOOL bEnabled, COLORREF clr) | CXTPPaintManager | virtual
DrawPopupResizeGripper(CDC *pDC, CRect rcGripper, int nFlags) | CXTPCommandBarsOfficeXPTheme | virtual
DrawRectangle(CDC *pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition) | CXTPCommandBarsVisualStudio2012Theme | virtual
DrawRectangle(CDC *pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition, int nID) | CXTPCommandBarsVisualStudio2012Theme | virtual
DrawRectangle(CDC *pDC, CXTPControl *pButton) | CXTPCommandBarsVisualStudio2012Theme | virtual
DrawSpecialControl(CDC *pDC, XTPSpecialControl controlType, CXTPControl *pButton, CXTPCommandBar *pBar, BOOL bDraw, LPVOID lpParam) | CXTPPaintManager | virtual
DrawSplitButtonFrame(CDC *pDC, CXTPControl *pButton, CRect rc) | CXTPCommandBarsVisualStudio2012Theme | virtual
DrawTearOffGripper(CDC *pDC, CRect rcGripper, BOOL bSelected, BOOL bDraw) | CXTPCommandBarsOfficeXPTheme | virtual
FillCommandBarEntry(CDC *pDC, CXTPCommandBar *pBar) | CXTPCommandBarsVisualStudio2012Theme | virtual
FillDockBar(CDC *pDC, CXTPDockBar *pBar) | CXTPCommandBarsVisualStudio2012Theme | virtual
FillIntersectRect(CDC *pDC, CXTPPopupBar *pPopupBar, COLORREF clr) | CXTPCommandBarsOfficeXPTheme | protected
FillWorkspace(CDC *pDC, CRect rc, CRect rcExclude) | CXTPPaintManager | virtual
FontExists(LPCTSTR lpszFaceName) | CXTPPaintManager | static
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCommandBarBorders(CXTPCommandBar *pBar) | CXTPPaintManager | virtual
GetCommandBarFont(CXTPCommandBar *pCommandBar) | CXTPPaintManager | virtual
GetControlBackColor(CXTPControl *pButton) | CXTPPaintManager | virtual
GetControlEditBackColor(CXTPControl *pControl) | CXTPCommandBarsVisualStudio2012Theme | virtual
GetControlFont(CXTPControl *pControl) | CXTPPaintManager | virtual
GetControlHeight() const | CXTPPaintManager |
GetControlTextColor(CXTPControl *pButton) | CXTPPaintManager | virtual
GetControlTextOrientation(CXTPControl *pControl) | CXTPPaintManager | virtual
GetCurrentSystemTheme() | CXTPPaintManager |
GetCurrentTheme() | CXTPPaintManager | inline
GetDefaultCommandBarSize(CXTPCommandBar *pBar) | CXTPPaintManager | virtual
GetFramePaintManager() | CXTPCommandBarsModernUITheme | virtual
GetGalleryPaintManager() const | CXTPPaintManager | virtual
GetGlobalPaintManager() | CXTPPaintManager | static
GetIconFont() | CXTPPaintManager |
GetIconsInfo() | CXTPPaintManager |
GetInstanceAddRef() | CXTPPaintManager | static
GetMarkupContext() | CXTPCommandBarsModernUITheme | virtual
GetMessageBarPaintManager() | CXTPPaintManager | virtual
GetPopupBarGripperWidth(CXTPCommandBar *pBar) | CXTPPaintManager | virtual
GetProgressPaintManager() const | CXTPPaintManager | virtual
GetRectangleTextColor(BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition) | CXTPCommandBarsOfficeXPTheme | virtual
GetRegularBoldFont() | CXTPPaintManager |
GetRegularFont() | CXTPPaintManager |
GetRibbonPaintManager() | CXTPCommandBarsModernUITheme | virtual
GetScrollBarPaintManager() const | CXTPPaintManager | virtual
GetShadowManager() const | CXTPPaintManager |
GetShadowOptions() const | CXTPPaintManager |
GetSliderPaintManager() const | CXTPPaintManager | virtual
GetSmCaptionFont() | CXTPPaintManager |
GetSplitButtonCommandRect(CXTPControl *pButton) | CXTPPaintManager | virtual
GetStatusBarPaintManager() | CXTPPaintManager | virtual
GetXtremeColor(UINT nIndex) | CXTPPaintManager |
GradientFill(CDC *pDC, LPRECT lpRect, COLORREF crFrom, COLORREF crTo, BOOL bHorz, LPCRECT lpRectClip=NULL) | CXTPPaintManager |
HorizontalLine(CDC *pDC, int x0, int y0, int x1, COLORREF clrPen) | CXTPPaintManager |
IsUseSystemAccentColorEnabled() const | CXTPPaintManager |
Line(CDC *pDC, CPoint p0, CPoint p1) | CXTPPaintManager |
Line(CDC *pDC, int x0, int y0, int x1, int y1, const int nPen) | CXTPPaintManager |
Line(CDC *pDC, int x0, int y0, int x1, int y1, COLORREF clrPen) | CXTPPaintManager |
m_arrColor | CXTPPaintManager | protected
m_bAutoResizeIcons | CXTPPaintManager |
m_bClearTypeTextQuality | CXTPPaintManager |
m_bEmbossedDisabledText | CXTPPaintManager | protected
m_bEnableAnimation | CXTPPaintManager |
m_bFlatMenuBar | CXTPPaintManager |
m_bFlatToolBar | CXTPPaintManager |
m_bOffice2007Padding | CXTPPaintManager |
m_bOffsetPopupLabelText | CXTPPaintManager |
m_bSelectImageInPopupBar | CXTPPaintManager |
m_bShowKeyboardCues | CXTPPaintManager | protected
m_bShowShadow | CXTPPaintManager |
m_bThemedCheckBox | CXTPPaintManager |
m_bThemedStatusBar | CXTPPaintManager |
m_bThickCheckMark | CXTPPaintManager |
m_bUseOfficeFont | CXTPPaintManager |
m_bUseStandardFont | CXTPPaintManager | protected
m_bWrapCaptionBelowText | CXTPPaintManager |
m_clrDisabledIcon | CXTPPaintManager |
m_clrFloatingGripper | CXTPPaintManager |
m_clrFloatingGripperText | CXTPPaintManager |
m_clrMessageBarText | CXTPPaintManager |
m_fontIcon | CXTPPaintManager |
m_fontIconBold | CXTPPaintManager |
m_fontSmCaption | CXTPPaintManager |
m_fontToolTip | CXTPPaintManager |
m_iconsInfo | CXTPPaintManager | protected
m_nAnimationSteps | CXTPPaintManager | protected
m_nAnimationTime | CXTPPaintManager | protected
m_nEditHeight | CXTPPaintManager | protected
m_nFontHeight | CXTPPaintManager | protected
m_nPopupBarTextPadding | CXTPPaintManager |
m_nSplitButtonDropDownHeight | CXTPPaintManager |
m_nSplitButtonDropDownWidth | CXTPPaintManager |
m_nSplitButtonPopupWidth | CXTPPaintManager |
m_nStatusBarMinHeight | CXTPPaintManager |
m_nTextHeight | CXTPPaintManager |
m_pfnSetLayeredWindowAttributes | CXTPPaintManager |
m_pFramePaintManager | CXTPPaintManager |
m_pGalleryPaintManager | CXTPPaintManager |
m_pImages | CXTPCommandBarsModernUITheme | protected
m_pMarkupContext | CXTPCommandBarsModernUITheme | protected
m_pProgressPaintManager | CXTPPaintManager |
m_pRibbonPaintManager | CXTPPaintManager |
m_pScrollBarPaintManager | CXTPPaintManager |
m_pShadowManager | CXTPPaintManager | protected
m_pSliderPaintManager | CXTPPaintManager |
m_pStatusBarPaintManager | CXTPPaintManager |
m_rcMessageBarMargin | CXTPPaintManager |
m_rcStatusBarBorder | CXTPPaintManager |
m_strOfficeFont | CXTPPaintManager |
m_systemTheme | CXTPPaintManager | protected
m_themeButton | CXTPPaintManager | protected
m_themeCurrent | CXTPPaintManager | protected
m_themeStatusBar | CXTPPaintManager | protected
m_xtpFontRegular | CXTPPaintManager | protected
m_xtpFontRegularBold | CXTPPaintManager | protected
m_xtpFontVert | CXTPPaintManager | protected
m_xtpFontVertBold | CXTPPaintManager | protected
Notify(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *)) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
Notify(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1), A1 arg1) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
Notify(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
Notify(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamic(void(T::*method)(O *)) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1), A1 arg1) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *)) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1), A1 arg1) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyReversed(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *)) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyReversed(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1), A1 arg1) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyReversed(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyReversed(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
Pixel(CDC *pDC, int xPos, int yPos, int nPen) | CXTPPaintManager |
Rectangle(CDC *pDC, LPCRECT rc, int nPen, const int nBrush) | CXTPPaintManager |
Rectangle(CDC *pDC, LPCRECT rc, COLORREF clrPen, COLORREF clrBrush) | CXTPPaintManager |
RefreshMetrics() | CXTPCommandBarsVisualStudio2012Theme | virtual
ReleaseInstance() | CXTPPaintManager | static
RequiresResourceImages() | CXTPCommandBarsVisualStudio2012Theme | protectedvirtual
RoundRect(CDC *pDC, LPCRECT rc, COLORREF clrPen, COLORREF clrBrush) | CXTPPaintManager |
SetAnimationDelay(int nAnimationSteps, int nAnimationTime) | CXTPPaintManager |
SetColors(int cElements, CONST INT *lpaElements, CONST COLORREF *lpaRgbValues) | CXTPPaintManager |
SetCommandBarRegion(CXTPCommandBar *pCommandBar) | CXTPPaintManager | virtual
SetCommandBarsFontIndirect(LOGFONT *pLogFont, BOOL bUseStandardFont=FALSE) | CXTPPaintManager |
SetCustomTheme(CXTPPaintManager *pTheme) | CXTPPaintManager | static
SetGlobalPaintManager(CXTPPaintManager *pPaintManager) | CXTPPaintManager | static
SetImageHandle(HMODULE hResource, LPCTSTR lpszIniFileName) | CXTPPaintManager | virtual
SetLunaTheme(XTPCurrentSystemTheme systemTheme) | CXTPPaintManager |
SetTheme(XTPPaintTheme paintTheme) | CXTPPaintManager | static
StripMnemonics(CString &strClear) | CXTPPaintManager | static
Subscribe(IXTPPaintManagerEvents *pObserver, CXTPSubscriptionList< CXTPPaintManager, IXTPPaintManagerEvents > *pSubcriptionList=NULL) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > |
Triangle(CDC *pDC, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clr) | CXTPPaintManager | static
Unsubscribe(IXTPPaintManagerEvents *pObserver) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > |
UpdateColors() | CXTPPaintManager | virtual
UpdateFonts() | CXTPPaintManager | virtual
UpdateRTLCaption(CString &strCaption) | CXTPPaintManager | virtual
UseOfficeFont(bool bUseOfficeFont) | CXTPPaintManager |
VerticalLine(CDC *pDC, int x0, int y0, int y1, COLORREF clrPen) | CXTPPaintManager |
~CXTPCommandBarsModernUITheme() | CXTPCommandBarsModernUITheme | virtual
~CXTPCommandBarsVisualStudio2012Theme() | CXTPCommandBarsVisualStudio2012Theme | virtual
~CXTPObservable() | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | protected
~CXTPPaintManager() | CXTPPaintManager | protectedvirtual


Toolkit Pro: XTPFlowGraphEditItem.h Source File

  • Source
  • FlowGraph
XTPFlowGraphEditItem.h
Go to the documentation of this file.
1
23#if !defined(__XTPFLOWGRAPHEDITITEM_H__)
24# define __XTPFLOWGRAPHEDITITEM_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPFlowGraphEditItem : public CEdit
39{
40public:
45 CXTPFlowGraphEditItem();
46
47public:
56 BOOL Create(CXTPFlowGraphElement* pElement);
57
58# if _MSC_VER > 1200
59 using CEdit::Create;
60 using CWnd::Create;
61# endif
62
64protected:
65 virtual void PostNcDestroy();
66
67protected:
68 afx_msg void OnKillFocus(CWnd* pNewWnd);
69 afx_msg void OnChar(UINT nChar, UINT nRepCnt, UINT nFlags);
70 afx_msg UINT OnGetDlgCode();
88protected:
89 BOOL m_bEscapeKey;
90 CXTPFlowGraphElement* m_pElement;
92 CXTPFont m_xtpFont;
93 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CFont, m_fnt, m_xtpFont, GetFontHandle);
94
95protected:
97 DECLARE_MESSAGE_MAP()
98 DECLARE_DYNAMIC(CXTPFlowGraphEditItem)
100};
102# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
103#endif //#if !defined(__XTPFLOWGRAPHEDITITEM_H__)
XTPDisableNoisyWarnings.h
CXTPFlowGraphEditItem
Represents an edit control used to edit captions for elements in the flow graph.
Definition XTPFlowGraphEditItem.h:39
CXTPFlowGraphEditItem::m_xtpFont
CXTPFont m_xtpFont
Font used in the edit control.
Definition XTPFlowGraphEditItem.h:92
CXTPFlowGraphEditItem::Create
BOOL Create(CXTPFlowGraphElement *pElement)
This member function is called to create the edit control used to edit the caption of a connection.
CXTPFlowGraphEditItem::m_bEscapeKey
BOOL m_bEscapeKey
TRUE if the escape key was pressed, FALSE otherwise.
Definition XTPFlowGraphEditItem.h:89
CXTPFlowGraphEditItem::m_pElement
CXTPFlowGraphElement * m_pElement
Parent element to create the edit control for.
Definition XTPFlowGraphEditItem.h:90
CXTPFlowGraphEditItem::CXTPFlowGraphEditItem
CXTPFlowGraphEditItem()
Constructs a CXTPFlowGraphEditItem object.
CXTPFlowGraphElement
Base class for all elements in the flow graph.
Definition XTPFlowGraphElement.h:46
CXTPFont
Provides a convenient object oriented interface for HFONT GDI object and uses GDI handle caching.
Definition XTPGdiObjects.h:414


Toolkit Pro: Member List

CXTPSplitterWndThemeOfficeXP Member List

This is the complete list of members for CXTPSplitterWndThemeOfficeXP, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPControlTheme() | CXTPControlTheme |
CXTPSplitterWndTheme() | CXTPSplitterWndTheme |
CXTPSplitterWndThemeOfficeXP() | CXTPSplitterWndThemeOfficeXP |
DrawSplitter(CDC *pDC, CXTPSplitterWnd *pSplitter, int nType, const CRect &rectArg) | CXTPSplitterWndTheme | virtual
EnableTabColors(BOOL bEnable=TRUE) | CXTPSplitterWndTheme |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetThemeStyle() const | CXTPControlTheme |
GetTrackBrush() | CXTPSplitterWndThemeOfficeXP | virtual
m_bTabColors | CXTPSplitterWndTheme |
m_crBack | CXTPSplitterWndTheme |
m_crBoxBack | CXTPSplitterWndTheme |
m_crInnerBorder | CXTPSplitterWndTheme |
m_crInnerBoxBorder | CXTPSplitterWndTheme |
m_crOuterBorder | CXTPSplitterWndTheme |
m_crOuterBoxBorder | CXTPSplitterWndTheme |
m_nTheme | CXTPControlTheme | protected
RefreshMetrics() | CXTPSplitterWndThemeOfficeXP | virtual
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static


Toolkit Pro: XTPChart3dPieDiagram.h Source File

  • Source
  • Chart
  • Styles
  • Pie
  • 3D
XTPChart3dPieDiagram.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHART3DPIEDIAGRAM_H__)
24# define __XTPCHART3DPIEDIAGRAM_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartPieBase;
34class CXTPChartDiagramView;
35class CXTPChartDeviceContext;
36class CXTPChartElementView;
37
49class _XTP_EXT_CLASS CXTPChart3dPieDiagram : public CXTPChart3dPieDiagramBase
50{
52 DECLARE_SERIAL(CXTPChart3dPieDiagram)
54public:
59 CXTPChart3dPieDiagram();
60
61public:
72 virtual CXTPChartDiagramView* CreateView(CXTPChartDeviceContext* pDC,
73 CXTPChartElementView* pParent);
74
75# ifdef _XTP_ACTIVEX
76public:
78 DECLARE_DISPATCH_MAP()
79 DECLARE_INTERFACE_MAP()
80 DECLARE_OLETYPELIB_EX(CXTPChart3dPieDiagram);
81 DECLARE_OLECREATE_EX(CXTPChart3dPieDiagram)
83# endif
84};
86# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
87#endif //#if !defined(__XTPCHART3DPIEDIAGRAM_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChart3dPieDiagram
This class abstracts the pie diagram.
Definition XTPChart3dPieDiagram.h:50
CXTPChart3dPieDiagram::CreateView
virtual CXTPChartDiagramView * CreateView(CXTPChartDeviceContext *pDC, CXTPChartElementView *pParent)
Call this function to create the view of the pie diagram.
CXTPChart3dPieDiagram::CXTPChart3dPieDiagram
CXTPChart3dPieDiagram()
Constructs a CXTPChart3dPieDiagram object.
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartDiagramView
This class represents the view of a chart diagram, which is a kind of CXTPChartElementView.
Definition XTPChartDiagramView.h:49
CXTPChartElementView
This class represents the view of a chart element.
Definition XTPChartElementView.h:47
CXTPChartPieBase
This class abstracts a pie chart.
Definition XTPChartPie.h:176
CXTPChartPieDiagramBase
This class abstracts the pie diagram.
Definition XTPChartPieDiagramBase.h:62


Toolkit Pro: XTPColorSelectorCtrl.h Source File

  • Source
  • Controls
  • Popup
XTPColorSelectorCtrl.h
Go to the documentation of this file.
1
23#if !defined(__XTPCOLORSELECTORCTRL_H__)
24# define __XTPCOLORSELECTORCTRL_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPColorDialog;
34class CXTPColorSelectorCtrlTheme;
35
43struct _XTP_EXT_CLASS XTP_PICK_BUTTON
44{
45 COLORREF clrButton;
46 UINT toolTipID;
47 TCHAR szTip[256];
48};
49
55typedef CArray<XTP_PICK_BUTTON, XTP_PICK_BUTTON&> CXTPPickBtnArray;
56
62class _XTP_EXT_CLASS CXTPColorSelectorCtrl : public CWnd
63{
64public:
72 struct _XTP_EXT_CLASS COLOR_CELL
73 {
74 UINT nID;
75 UINT nIndex;
76 bool bChecked;
77 CRect rect;
78 CRect rcBorder;
79 DWORD dwStyle;
80 TCHAR szText[256];
81 COLORREF clr;
82 };
83
84protected:
95 typedef CList<COLOR_CELL*, COLOR_CELL*> CColorCellList;
96
107 typedef CArray<HWND, HWND> CListenerArray;
108
109public:
114 CXTPColorSelectorCtrl();
115
121 virtual ~CXTPColorSelectorCtrl();
122
132 static void AFX_CDECL SetRecentColors(const CUIntArray& arRecentColors,
133 LPCTSTR lpszTitle = NULL);
134
143 static CUIntArray& AFX_CDECL GetRecentColors();
144
153 static void AFX_CDECL AddRecentColor(COLORREF clrRecent);
154
163 static void AFX_CDECL ResetRecentColors();
164
166 _XTP_DEPRECATED_IN_FAVOR(SetRecentColors)
167 static void AFX_CDECL SetUserColors(const CUIntArray& arUserDefColors)
168 {
169 SetRecentColors(arUserDefColors);
170 }
171
172 _XTP_DEPRECATED_IN_FAVOR(GetRecentColors)
173 static CUIntArray& AFX_CDECL GetUserColors()
174 {
175 return GetRecentColors();
176 }
189 CString GetThemeTip(LPCTSTR lpszColor, LPCTSTR lpszDesc, int nShade);
190
253 BOOL SetThemeColors(XTP_PICK_BUTTON* pColors = NULL, int nCount = 10, LPCTSTR lpszTitle = NULL,
254 UINT* pStringIDs = NULL, int ppShadeMatrix[6][10] = NULL);
255
318 BOOL SetThemeColors(XTP_PICK_BUTTON* pColors, int nCount, LPCTSTR lpszTitle,
319 LPCTSTR* ppszStrings, int ppShadeMatrix[6][10]);
320
378 BOOL SetThemeColors(CXTPPickBtnArray& arColors, int nCols = 10, LPCTSTR lpszTitle = NULL);
379
409 BOOL SetStandardColors(XTP_PICK_BUTTON* pColors = NULL, int nCount = 10, int nCols = 10,
410 LPCTSTR lpszTitle = NULL);
411
441 BOOL SetStandardColors(CXTPPickBtnArray& arColors, int nCols = 10, LPCTSTR lpszTitle = NULL);
442
451 void SetColors(XTP_PICK_BUTTON* pColors, int nCount, int nCols = 8, LPCTSTR lpszTitle = NULL);
452
460 CXTPPickBtnArray& GetThemeColors();
461
469 CXTPPickBtnArray& GetStandardColors();
470
479 int GetCurSel(COLOR_CELL* pColorCell);
480
487 void SetCurSel(int nIndex);
488
522 BOOL Create(CRect rect, CWnd* pParentWnd, DWORD dwPopup, COLORREF clrColor,
523 COLORREF clrDefault = CLR_DEFAULT);
524
531 void AddListener(HWND hwndListener);
532
538 void RemoveListener(HWND hwndListener);
539
545 virtual void SelectColorCell(COLOR_CELL* pColorCell);
546
552 void SelectColor(COLORREF clr);
553
562 COLOR_CELL* GetCellFromIndex(int iIndex);
563
573 void SetBorders(int l = 0, int t = 0, int r = 0, int b = 0);
574
582 bool IsColorDlgVisible();
583
593 BOOL IsColorStatic(CDC* pDC) const;
594
609 BOOL SetTheme(XTPControlTheme eTheme);
610
624 BOOL SetTheme(CXTPColorSelectorCtrlTheme* pTheme);
625
634 CXTPColorSelectorCtrlTheme* GetTheme();
635
643 CSize GetButtonSize() const;
644
652 int GetNumCols() const;
653
661 CRect GetBorderRect() const;
662
683 DWORD GetPopupStyle() const;
684
707 BOOL ModifyPopupStyle(DWORD dwRemove, DWORD dwAdd);
708
717 XTP_PICK_BUTTON* GetExtendedColors();
718
726 int GetExtendedCount() const;
727
735 int GetCurSel() const;
736
744 int GetPressed() const;
745
753 COLORREF GetDefColor() const;
754
762 COLORREF GetCurColor() const;
763
771 CToolTipCtrl& GetToolTipCtrl();
772
780 CColorCellList& GetColorCellList();
781
789 CString GetThemeTitle();
790
798 CString GetStandardTitle();
799
807 CString GetCustomTitle();
808
816 BOOL HasCaptions() const;
817
824 void ShowCaptions(BOOL bShow);
825
826protected:
838 BOOL SetColors(CXTPPickBtnArray& arColors, const XTP_PICK_BUTTON* pColors, const int nCount);
839
845 void DrawColorSelector(CDC* pDC);
846
854 virtual void EndSelection(int nCurSel);
855
865 BOOL LookUpColor(const COLORREF crFind);
866
878 virtual void OnEndSelection(int nCurSel, LPARAM callerParam);
879
887 virtual CSize CalcSize();
888
894 virtual void RefreshMetrics();
895
897protected:
898 DECLARE_MESSAGE_MAP()
899
900 //{{AFX_VIRTUAL(CXTPColorSelectorCtrl)
901 virtual BOOL PreTranslateMessage(MSG* pMsg);
902 virtual BOOL OnWndMsg(UINT message, WPARAM wParam, LPARAM lParam, LRESULT* pResult);
903 //}}AFX_VIRTUAL
904
905 //{{AFX_MSG(CXTPColorSelectorCtrl)
906 afx_msg int OnCreate(LPCREATESTRUCT lpCS);
907 afx_msg void OnPaint();
908 afx_msg void OnMouseMove(UINT nFlags, CPoint point);
909 afx_msg int OnMouseActivate(CWnd* /*pDesktopWnd*/, UINT /*nHitTest*/, UINT /*message*/);
910 afx_msg void OnLButtonDown(UINT nFlags, CPoint point);
911 afx_msg void OnLButtonUp(UINT nFlags, CPoint point);
912 afx_msg void OnKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags);
913 afx_msg BOOL OnEraseBkgnd(CDC* pDC);
914 afx_msg void OnMouseLeave();
915 afx_msg LRESULT OnNcHitTest(CPoint point);
916 afx_msg void OnSetFocus(CWnd* pOldWnd);
917 //}}AFX_MSG
918 afx_msg LRESULT OnSetTheme(WPARAM wParam, LPARAM lParam);
919
920private:
921 BOOL Create(LPCTSTR lpszClassName, LPCTSTR lpszWindowName, DWORD dwStyle, const RECT& rect,
922 CWnd* pParentWnd, UINT nID, CCreateContext* pContext = NULL);
923 BOOL SetThemeColors(XTP_PICK_BUTTON* pColors, int nCount, LPCTSTR lpszTitle,
924 CStringArray& arStrings, int ppShadeMatrix[6][10]);
925 friend class CXTPopupColorTearOff;
928public:
929 static CUIntArray m_arRecentColors;
930 static CString m_strTitleRecent;
932protected:
933 int m_nCols;
934 int m_nCurSel;
935 int m_nPressed;
936 BOOL m_bCaptions;
937 CWnd* m_pParentWnd;
938 CRect m_rcWnd;
939 CRect m_rcBorders;
940 DWORD m_dwPopup;
941 CPoint m_point;
942 CString m_strTitleTheme;
943 CString m_strTitleStandard;
944 CString m_strTitleCustom;
945 COLORREF m_clrColor;
946 COLORREF m_clrDefault;
948 CToolTipCtrl m_tooltip;
949 CListenerArray m_listeners;
950 CColorCellList m_arCells;
951 CXTPColorDialog* m_pColorDlg;
952 CXTPColorSelectorCtrlTheme* m_pTheme;
953 XTP_PICK_BUTTON* m_pExtendedColors;
954 int m_nExtendedColors;
955 CXTPPickBtnArray m_arThemeColors;
956 CXTPPickBtnArray m_arStandardColors;
957};
958
964class _XTP_EXT_CLASS CXTPColorSelectorCtrlTheme : public CXTPControlTheme
965{
966public:
971 CXTPColorSelectorCtrlTheme();
972
979 virtual void RefreshMetrics(CXTPColorSelectorCtrl* pOwner);
980
989 virtual void FillBackground(CDC* pDC, CXTPColorSelectorCtrl* pOwner, const CRect& rect);
990
1001 virtual void DrawColorCell(CDC* pDC, CXTPColorSelectorCtrl* pOwner,
1002 CXTPColorSelectorCtrl::COLOR_CELL* pColorCell, BOOL bHighlight,
1003 BOOL bPressed);
1004
1011 virtual void DrawColorSelector(CDC* pDC, CXTPColorSelectorCtrl* pOwner);
1012
1020 virtual CSize CalcSize(CXTPColorSelectorCtrl* pOwner);
1021
1037 virtual BOOL CreateAutoButton(CXTPColorSelectorCtrl* pOwner, int& nIndex, const int x, int& y,
1038 const int cx, bool& bChecked);
1039
1053 virtual BOOL CreateExtendedButtons(CXTPColorSelectorCtrl* pOwner, int& nIndex, const int x,
1054 int& y, const int cx, bool& bChecked);
1055
1069 virtual BOOL CreateThemeButtons(CXTPColorSelectorCtrl* pOwner, int& nIndex, const int x, int& y,
1070 const int cx, bool& bChecked);
1071
1085 virtual BOOL CreateColorButtons(CXTPColorSelectorCtrl* pOwner, int& nIndex, const int x, int& y,
1086 const int cx, bool& bChecked);
1087
1101 virtual BOOL CreateRecentColorButtons(CXTPColorSelectorCtrl* pOwner, int& nIndex, const int x,
1102 int& y, const int cx, bool& bChecked);
1103
1117 virtual BOOL CreateMoreButton(CXTPColorSelectorCtrl* pOwner, int& nIndex, const int x, int& y,
1118 const int cx, bool& bChecked);
1119
1126 virtual CSize GetButtonSize() const;
1127
1128public:
1129 int m_nAutoButton;
1130 int m_nCaption;
1131 int m_nMargin;
1132 CRect m_rcThemeText;
1133 CRect m_rcRecentText;
1134 CRect m_rcStandardText;
1135 CSize m_sizeButton;
1136 BOOL m_bThinBorder;
1137 COLORREF m_crBorder;
1138 COLORREF m_crBorderHilight;
1139 COLORREF m_crBorderPressed;
1140 COLORREF m_crBack;
1141 COLORREF m_crBackPressed;
1142 COLORREF m_crBackHilight;
1143 COLORREF m_crBackChecked;
1144 COLORREF m_crText;
1145 COLORREF m_crTextPressed;
1146 COLORREF m_crPopupBorder;
1147};
1148
1154class _XTP_EXT_CLASS CXTPColorSelectorCtrlThemeOfficeXP : public CXTPColorSelectorCtrlTheme
1155{
1156public:
1161 CXTPColorSelectorCtrlThemeOfficeXP();
1162
1169 virtual void RefreshMetrics(CXTPColorSelectorCtrl* pOwner);
1170};
1171
1178class _XTP_EXT_CLASS CXTPColorSelectorCtrlThemeOffice2003
1179 : public CXTPColorSelectorCtrlThemeOfficeXP
1180{
1181public:
1186 CXTPColorSelectorCtrlThemeOffice2003();
1187
1194 virtual void RefreshMetrics(CXTPColorSelectorCtrl* pOwner);
1195};
1196
1203class _XTP_EXT_CLASS CXTPColorSelectorCtrlThemeResource : public CXTPColorSelectorCtrlThemeOfficeXP
1204{
1205public:
1210 CXTPColorSelectorCtrlThemeResource();
1211
1218 virtual void RefreshMetrics(CXTPColorSelectorCtrl* pOwner);
1219};
1220
1226class _XTP_EXT_CLASS CXTPColorSelectorCtrlThemeOffice2013 : public CXTPColorSelectorCtrlTheme
1227{
1228public:
1233 CXTPColorSelectorCtrlThemeOffice2013();
1234
1241 virtual void RefreshMetrics(CXTPColorSelectorCtrl* pOwner);
1242
1253 virtual void DrawBorder(CDC* pDC, CRect rcItem, CRect rcBorder, COLORREF crBorder);
1254
1266 virtual void DrawColor(CDC* pDC, CXTPColorSelectorCtrl* pOwner,
1267 CXTPColorSelectorCtrl::COLOR_CELL* pColorCell, CRect rcItem,
1268 BOOL bChecked, BOOL bHighlight, BOOL bPressed);
1269
1280 virtual void DrawColorCell(CDC* pDC, CXTPColorSelectorCtrl* pOwner,
1281 CXTPColorSelectorCtrl::COLOR_CELL* pColorCell, BOOL bHighlight,
1282 BOOL bPressed);
1283
1290 virtual void DrawColorSelector(CDC* pDC, CXTPColorSelectorCtrl* pOwner);
1291
1299 virtual CSize CalcSize(CXTPColorSelectorCtrl* pOwner);
1300
1315 virtual BOOL CreateAutoButton(CXTPColorSelectorCtrl* pOwner, int& nIndex, const int x, int& y,
1316 const int cx, bool& bChecked);
1317
1331 virtual BOOL CreateExtendedButtons(CXTPColorSelectorCtrl* pOwner, int& nIndex, const int x,
1332 int& y, const int cx, bool& bChecked);
1333
1347 virtual BOOL CreateThemeButtons(CXTPColorSelectorCtrl* pOwner, int& nIndex, const int x, int& y,
1348 const int cx, bool& bChecked);
1349
1363 virtual BOOL CreateRecentColorButtons(CXTPColorSelectorCtrl* pOwner, int& nIndex, const int x,
1364 int& y, const int cx, bool& bChecked);
1365
1379 virtual BOOL CreateMoreButton(CXTPColorSelectorCtrl* pOwner, int& nIndex, const int x, int& y,
1380 const int cx, bool& bChecked);
1381
1382protected:
1383 COLORREF m_crTitleText;
1384 COLORREF m_crTitleBack;
1385 COLORREF m_crBorderInside;
1386};
1387
1394class _XTP_EXT_CLASS CXTPColorSelectorCtrlThemeVisualStudio2015
1395 : public CXTPColorSelectorCtrlThemeOffice2013
1396{
1397public:
1402 CXTPColorSelectorCtrlThemeVisualStudio2015();
1403
1410 virtual void RefreshMetrics(CXTPColorSelectorCtrl* pOwner);
1411
1422 virtual void DrawColorCell(CDC* pDC, CXTPColorSelectorCtrl* pOwner,
1423 CXTPColorSelectorCtrl::COLOR_CELL* pColorCell, BOOL bHighlight,
1424 BOOL bPressed);
1425};
1426
1433class _XTP_EXT_CLASS CXTPColorSelectorCtrlThemeVisualStudio2017
1434 : public CXTPColorSelectorCtrlThemeVisualStudio2015
1435{
1436public:
1441 CXTPColorSelectorCtrlThemeVisualStudio2017();
1442};
1443
1450class _XTP_EXT_CLASS CXTPColorSelectorCtrlThemeVisualStudio2019
1451 : public CXTPColorSelectorCtrlThemeVisualStudio2015
1452{
1453public:
1458 CXTPColorSelectorCtrlThemeVisualStudio2019();
1459};
1460
1467class _XTP_EXT_CLASS CXTPColorSelectorCtrlThemeVisualStudio2022
1468 : public CXTPColorSelectorCtrlThemeVisualStudio2015
1469{
1470public:
1475 CXTPColorSelectorCtrlThemeVisualStudio2022();
1476};
1477
1484class _XTP_EXT_CLASS CXTPColorSelectorCtrlThemeNativeWindows10
1485 : public CXTPColorSelectorCtrlThemeVisualStudio2015
1486{
1487public:
1492 CXTPColorSelectorCtrlThemeNativeWindows10();
1493};
1494
1501class _XTP_EXT_CLASS CXTPColorSelectorCtrlThemeNativeWindows11
1502 : public CXTPColorSelectorCtrlThemeVisualStudio2015
1503{
1504public:
1509 CXTPColorSelectorCtrlThemeNativeWindows11();
1510};
1511
1513
1514AFX_INLINE void CXTPColorSelectorCtrl::SetBorders(int l, int t, int r, int b)
1515{
1516 m_rcBorders.left = l;
1517 m_rcBorders.top = t;
1518 m_rcBorders.right = r;
1519 m_rcBorders.bottom = b;
1520}
1521AFX_INLINE BOOL CXTPColorSelectorCtrl::Create(LPCTSTR lpszClassName, LPCTSTR lpszWindowName,
1522 DWORD dwStyle, const RECT& rect, CWnd* pParentWnd,
1523 UINT nID, CCreateContext* pContext)
1524{
1525 return CWnd::Create(lpszClassName, lpszWindowName, dwStyle, rect, pParentWnd, nID, pContext);
1526}
1527AFX_INLINE void CXTPColorSelectorCtrl::SetColors(XTP_PICK_BUTTON* pColors, int nCount,
1528 int nCols /*=8*/, LPCTSTR lpszTitle /*=NULL*/)
1529{
1530 m_pExtendedColors = pColors;
1531 m_nExtendedColors = nCount;
1532 m_nCols = nCols;
1533 m_strTitleCustom = lpszTitle;
1534}
1535AFX_INLINE CXTPColorSelectorCtrlTheme* CXTPColorSelectorCtrl::GetTheme()
1536{
1537 return m_pTheme;
1538}
1539AFX_INLINE void CXTPColorSelectorCtrl::AddRecentColor(COLORREF clrRecent)
1540{
1541 m_arRecentColors.Add(clrRecent);
1542}
1543AFX_INLINE void CXTPColorSelectorCtrl::ResetRecentColors()
1544{
1545 m_arRecentColors.RemoveAll();
1546}
1547AFX_INLINE CUIntArray& CXTPColorSelectorCtrl::GetRecentColors()
1548{
1549 return m_arRecentColors;
1550}
1551AFX_INLINE CXTPPickBtnArray& CXTPColorSelectorCtrl::GetThemeColors()
1552{
1553 return m_arThemeColors;
1554}
1555AFX_INLINE CXTPPickBtnArray& CXTPColorSelectorCtrl::GetStandardColors()
1556{
1557 return m_arStandardColors;
1558}
1559AFX_INLINE CSize CXTPColorSelectorCtrl::GetButtonSize() const
1560{
1561 _ASSERTE(m_pTheme != NULL);
1562 return m_pTheme->GetButtonSize();
1563}
1564AFX_INLINE int CXTPColorSelectorCtrl::GetNumCols() const
1565{
1566 return m_nCols;
1567}
1568AFX_INLINE CRect CXTPColorSelectorCtrl::GetBorderRect() const
1569{
1570 return m_rcBorders;
1571}
1572AFX_INLINE DWORD CXTPColorSelectorCtrl::GetPopupStyle() const
1573{
1574 return m_dwPopup;
1575}
1576AFX_INLINE XTP_PICK_BUTTON* CXTPColorSelectorCtrl::GetExtendedColors()
1577{
1578 return m_pExtendedColors;
1579}
1580AFX_INLINE int CXTPColorSelectorCtrl::GetExtendedCount() const
1581{
1582 return m_nExtendedColors;
1583}
1584AFX_INLINE int CXTPColorSelectorCtrl::GetCurSel() const
1585{
1586 return m_nCurSel;
1587}
1588AFX_INLINE int CXTPColorSelectorCtrl::GetPressed() const
1589{
1590 return m_nPressed;
1591}
1592AFX_INLINE COLORREF CXTPColorSelectorCtrl::GetDefColor() const
1593{
1594 return m_clrDefault;
1595}
1596AFX_INLINE COLORREF CXTPColorSelectorCtrl::GetCurColor() const
1597{
1598 return m_clrColor;
1599}
1600AFX_INLINE CToolTipCtrl& CXTPColorSelectorCtrl::GetToolTipCtrl()
1601{
1602 return m_tooltip;
1603}
1604AFX_INLINE CXTPColorSelectorCtrl::CColorCellList& CXTPColorSelectorCtrl::GetColorCellList()
1605{
1606 return m_arCells;
1607}
1608AFX_INLINE CString CXTPColorSelectorCtrl::GetThemeTitle()
1609{
1610 return m_strTitleTheme;
1611}
1612AFX_INLINE CString CXTPColorSelectorCtrl::GetStandardTitle()
1613{
1614 return m_strTitleStandard;
1615}
1616AFX_INLINE CString CXTPColorSelectorCtrl::GetCustomTitle()
1617{
1618 return m_strTitleCustom;
1619}
1620AFX_INLINE BOOL CXTPColorSelectorCtrl::HasCaptions() const
1621{
1622 return m_bCaptions;
1623}
1624AFX_INLINE void CXTPColorSelectorCtrl::ShowCaptions(BOOL bShow)
1625{
1626 m_bCaptions = bShow;
1627}
1630
1631# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
1633#endif //__XTPCOLORSELECTORCTRL_H__
CXTPPickBtnArray
CArray< XTP_PICK_BUTTON, XTP_PICK_BUTTON & > CXTPPickBtnArray
CXTPPickBtnArray is used to manage a collection of XTP_PICK_BUTTON objects.
Definition XTPColorSelectorCtrl.h:55
XTPControlTheme
XTPControlTheme
Enumeration used to determine the active theme style.
Definition XTPControlTheme.h:43
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPColorDialog
CXTPColorDialog is a CPropertySheet derived class.
Definition XTPColorDialog.h:184
CXTPColorSelectorCtrl
CXTPColorSelectorCtrl is a CWnd derived class.
Definition XTPColorSelectorCtrl.h:63
CXTPColorSelectorCtrl::SetColors
BOOL SetColors(CXTPPickBtnArray &arColors, const XTP_PICK_BUTTON *pColors, const int nCount)
Called to initialize the object specified by arColors using the data contained in the array specified...
CXTPColorSelectorCtrl::ModifyPopupStyle
BOOL ModifyPopupStyle(DWORD dwRemove, DWORD dwAdd)
Call this member function to modify the color selector style.
CXTPColorSelectorCtrl::SetBorders
void SetBorders(int l=0, int t=0, int r=0, int b=0)
This member function is called to set the size of the borders for the control.
CXTPColorSelectorCtrl::SelectColorCell
virtual void SelectColorCell(COLOR_CELL *pColorCell)
This member function is called to select a color cell.
CXTPColorSelectorCtrl::SetTheme
BOOL SetTheme(CXTPColorSelectorCtrlTheme *pTheme)
Call this member function to switch the visual theme of the control.
CXTPColorSelectorCtrl::GetCellFromIndex
COLOR_CELL * GetCellFromIndex(int iIndex)
This member function is called to retrieve a COLOR_CELL struct from the color cell array.
CXTPColorSelectorCtrl::LookUpColor
BOOL LookUpColor(const COLORREF crFind)
This member function is called to determine if the specified color is already in the ColorDialog's MR...
CXTPColorSelectorCtrl::~CXTPColorSelectorCtrl
virtual ~CXTPColorSelectorCtrl()
Destroys a CXTPColorSelectorCtrl object, handles cleanup and deallocation.
CXTPColorSelectorCtrl::GetThemeTitle
CString GetThemeTitle()
Call this member function to retrieve the string set for the theme caption.
CXTPColorSelectorCtrl::GetDefColor
COLORREF GetDefColor() const
Call this member function to retrieve the default color defined for the control.
CXTPColorSelectorCtrl::CalcSize
virtual CSize CalcSize()
This method is called to calculate the size of the Selector to fit all buttons.
CXTPColorSelectorCtrl::SetStandardColors
BOOL SetStandardColors(CXTPPickBtnArray &arColors, int nCols=10, LPCTSTR lpszTitle=NULL)
Called to initialize the standard colors for the color selector.
CXTPColorSelectorCtrl::GetCurSel
int GetCurSel() const
Call this member function to retrieve the index of the currently selected color.
CXTPColorSelectorCtrl::SetThemeColors
BOOL SetThemeColors(XTP_PICK_BUTTON *pColors=NULL, int nCount=10, LPCTSTR lpszTitle=NULL, UINT *pStringIDs=NULL, int ppShadeMatrix[6][10]=NULL)
Called to initialize the theme colors for the color selector.
CXTPColorSelectorCtrl::GetStandardTitle
CString GetStandardTitle()
Call this member function to retrieve the string set for the standard caption.
CXTPColorSelectorCtrl::GetRecentColors
static CUIntArray &AFX_CDECL GetRecentColors()
Call this member function to retrieve a reference to the recently used color array.
CXTPColorSelectorCtrl::SetStandardColors
BOOL SetStandardColors(XTP_PICK_BUTTON *pColors=NULL, int nCount=10, int nCols=10, LPCTSTR lpszTitle=NULL)
Called to initialize the standard colors for the color selector.
CXTPColorSelectorCtrl::IsColorStatic
BOOL IsColorStatic(CDC *pDC) const
Call this member function to determine if the ColorSelector control is used in a dialog or used in a ...
CXTPColorSelectorCtrl::GetThemeTip
CString GetThemeTip(LPCTSTR lpszColor, LPCTSTR lpszDesc, int nShade)
Called to create a tooltip for a theme color using the specified string resource ID and shading that ...
CXTPColorSelectorCtrl::GetThemeColors
CXTPPickBtnArray & GetThemeColors()
Called to retrieve a reference to the theme color button array.
CXTPColorSelectorCtrl::GetExtendedColors
XTP_PICK_BUTTON * GetExtendedColors()
Call this member function to retrieve the array of custom colors defined for the color selector contr...
CXTPColorSelectorCtrl::SetColors
void SetColors(XTP_PICK_BUTTON *pColors, int nCount, int nCols=8, LPCTSTR lpszTitle=NULL)
Call this method to set custom colors for the color picker.
CXTPColorSelectorCtrl::HasCaptions
BOOL HasCaptions() const
Call this member function to determine if captions are used for the color selector.
CXTPColorSelectorCtrl::SetTheme
BOOL SetTheme(XTPControlTheme eTheme)
Call this member function to switch the visual theme of the control.
CXTPColorSelectorCtrl::SetCurSel
void SetCurSel(int nIndex)
This member function will select a button based upon its index.
CXTPColorSelectorCtrl::EndSelection
virtual void EndSelection(int nCurSel)
This member function will finish the selection process for the color box or button in the color pop-u...
CXTPColorSelectorCtrl::GetToolTipCtrl
CToolTipCtrl & GetToolTipCtrl()
Call this member function to retrieve a reference to the tooltip for the control.
CXTPColorSelectorCtrl::ShowCaptions
void ShowCaptions(BOOL bShow)
Call this member function to show/hide captions for the color selector.
CXTPColorSelectorCtrl::AddRecentColor
static void AFX_CDECL AddRecentColor(COLORREF clrRecent)
This member function will add a color to the user-defined color list.
CXTPColorSelectorCtrl::DrawColorSelector
void DrawColorSelector(CDC *pDC)
This member function is called to draw the color selector.
CXTPColorSelectorCtrl::SetThemeColors
BOOL SetThemeColors(XTP_PICK_BUTTON *pColors, int nCount, LPCTSTR lpszTitle, LPCTSTR *ppszStrings, int ppShadeMatrix[6][10])
Called to initialize the theme colors for the color selector.
CXTPColorSelectorCtrl::IsColorDlgVisible
bool IsColorDlgVisible()
Call this member function to determine if the color selection dialog is visible.
CXTPColorSelectorCtrl::GetStandardColors
CXTPPickBtnArray & GetStandardColors()
Called to retrieve a reference to the standard color button array.
CXTPColorSelectorCtrl::GetColorCellList
CColorCellList & GetColorCellList()
Call this member function to retrieve a reference to the cell list array for the control.
CXTPColorSelectorCtrl::GetPressed
int GetPressed() const
Call this member function to retrieve the the index of the currently pressed color.
CXTPColorSelectorCtrl::ResetRecentColors
static void AFX_CDECL ResetRecentColors()
Resets the recently used color list.
CXTPColorSelectorCtrl::OnEndSelection
virtual void OnEndSelection(int nCurSel, LPARAM callerParam)
This member function is called to finish the selection process for the color box or button in the col...
CXTPColorSelectorCtrl::GetExtendedCount
int GetExtendedCount() const
Call this member function to retrieve the number of items in the custom color array.
CXTPColorSelectorCtrl::Create
BOOL Create(CRect rect, CWnd *pParentWnd, DWORD dwPopup, COLORREF clrColor, COLORREF clrDefault=CLR_DEFAULT)
This member function handles the creation of the color pop-up window.
CXTPColorSelectorCtrl::GetButtonSize
CSize GetButtonSize() const
Call this member function to retrieve the size of a single color button.
CXTPColorSelectorCtrl::RemoveListener
void RemoveListener(HWND hwndListener)
This member function removes a window from the notification list.
CXTPColorSelectorCtrl::CColorCellList
CList< COLOR_CELL *, COLOR_CELL * > CColorCellList
List for maintaining COLOR_CELL structures.
Definition XTPColorSelectorCtrl.h:95
CXTPColorSelectorCtrl::CListenerArray
CArray< HWND, HWND > CListenerArray
Array of listener windows to send notifications to.
Definition XTPColorSelectorCtrl.h:107
CXTPColorSelectorCtrl::AddListener
void AddListener(HWND hwndListener)
This member function adds a window to send color picker notifications to.
CXTPColorSelectorCtrl::GetCurColor
COLORREF GetCurColor() const
Call this member function to retrieve the currently selected color for the control.
CXTPColorSelectorCtrl::GetTheme
CXTPColorSelectorCtrlTheme * GetTheme()
Call this member function to retrieve a pointer to the currently selected theme.
CXTPColorSelectorCtrl::CXTPColorSelectorCtrl
CXTPColorSelectorCtrl()
Constructs a CXTPColorSelectorCtrl object.
CXTPColorSelectorCtrl::GetCurSel
int GetCurSel(COLOR_CELL *pColorCell)
This member function will return the index of the currently selected color and will initialize 'pColo...
CXTPColorSelectorCtrl::RefreshMetrics
virtual void RefreshMetrics()
Call this member function to refresh theme colors and redraw the control.
CXTPColorSelectorCtrl::SetThemeColors
BOOL SetThemeColors(CXTPPickBtnArray &arColors, int nCols=10, LPCTSTR lpszTitle=NULL)
Called to initialize the theme colors for the color selector.
CXTPColorSelectorCtrl::GetCustomTitle
CString GetCustomTitle()
Call this member function to retrieve the string set for the custom caption.
CXTPColorSelectorCtrl::SelectColor
void SelectColor(COLORREF clr)
This member function is called to select a color cell.
CXTPColorSelectorCtrl::GetPopupStyle
DWORD GetPopupStyle() const
Call this member function to retrieve the pop-up style for the color selector control.
CXTPColorSelectorCtrl::SetRecentColors
static void AFX_CDECL SetRecentColors(const CUIntArray &arRecentColors, LPCTSTR lpszTitle=NULL)
Call this member function to initialize the recently used color list for the color selector.
CXTPColorSelectorCtrl::GetNumCols
int GetNumCols() const
Call this member function to retrieve the number of columns displayed.
CXTPColorSelectorCtrl::GetBorderRect
CRect GetBorderRect() const
Call this member function to retrieve the size of the control border.
CXTPColorSelectorCtrlTheme
CXTPColorSelectorCtrlTheme is derived from CXTPControlThemeManagerStyle to handle theme specific visu...
Definition XTPColorSelectorCtrl.h:965
CXTPColorSelectorCtrlTheme::m_bThinBorder
BOOL m_bThinBorder
TRUE to use thin borders.
Definition XTPColorSelectorCtrl.h:1136
CXTPColorSelectorCtrlTheme::CreateMoreButton
virtual BOOL CreateMoreButton(CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked)
Called to add a 'More Colors' button to the color selector control.
CXTPColorSelectorCtrlTheme::m_nMargin
int m_nMargin
Size for default margin spacing.
Definition XTPColorSelectorCtrl.h:1131
CXTPColorSelectorCtrlTheme::CreateExtendedButtons
virtual BOOL CreateExtendedButtons(CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked)
Called to add default color buttons to the color selector control.
CXTPColorSelectorCtrlTheme::CreateColorButtons
virtual BOOL CreateColorButtons(CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked)
Called to determine if theme or default color buttons should be added.
CXTPColorSelectorCtrlTheme::m_crTextPressed
COLORREF m_crTextPressed
An RGB value for text pressed color.
Definition XTPColorSelectorCtrl.h:1145
CXTPColorSelectorCtrlTheme::GetButtonSize
virtual CSize GetButtonSize() const
Call to retrieve the size of a single color button.
CXTPColorSelectorCtrlTheme::m_sizeButton
CSize m_sizeButton
cx and cy size for a color picker button.
Definition XTPColorSelectorCtrl.h:1135
CXTPColorSelectorCtrlTheme::m_crBack
COLORREF m_crBack
An RGB value for background color.
Definition XTPColorSelectorCtrl.h:1140
CXTPColorSelectorCtrlTheme::m_crBackHilight
COLORREF m_crBackHilight
An RGB value for background highlight color.
Definition XTPColorSelectorCtrl.h:1142
CXTPColorSelectorCtrlTheme::CreateThemeButtons
virtual BOOL CreateThemeButtons(CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked)
Called to add theme and standard buttons to the color selector control.
CXTPColorSelectorCtrlTheme::m_nCaption
int m_nCaption
Height of a caption that is displayed in the control.
Definition XTPColorSelectorCtrl.h:1130
CXTPColorSelectorCtrlTheme::m_crBorderPressed
COLORREF m_crBorderPressed
An RGB value for border pressed color.
Definition XTPColorSelectorCtrl.h:1139
CXTPColorSelectorCtrlTheme::m_crBorderHilight
COLORREF m_crBorderHilight
An RGB value for border highlight color.
Definition XTPColorSelectorCtrl.h:1138
CXTPColorSelectorCtrlTheme::CalcSize
virtual CSize CalcSize(CXTPColorSelectorCtrl *pOwner)
Called to determine the size of the color selector window.
CXTPColorSelectorCtrlTheme::CreateRecentColorButtons
virtual BOOL CreateRecentColorButtons(CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked)
Called to add recent colors to the color selector control.
CXTPColorSelectorCtrlTheme::DrawColorSelector
virtual void DrawColorSelector(CDC *pDC, CXTPColorSelectorCtrl *pOwner)
This member function is called to draw the color selector.
CXTPColorSelectorCtrlTheme::m_crText
COLORREF m_crText
An RGB value for text color.
Definition XTPColorSelectorCtrl.h:1144
CXTPColorSelectorCtrlTheme::m_rcThemeText
CRect m_rcThemeText
Size and location of the 'Theme Colors' caption area text.
Definition XTPColorSelectorCtrl.h:1132
CXTPColorSelectorCtrlTheme::m_crBackPressed
COLORREF m_crBackPressed
An RGB value for pressed background color.
Definition XTPColorSelectorCtrl.h:1141
CXTPColorSelectorCtrlTheme::CXTPColorSelectorCtrlTheme
CXTPColorSelectorCtrlTheme()
Constructs a CXTPColorSelectorCtrlTheme object.
CXTPColorSelectorCtrlTheme::m_rcStandardText
CRect m_rcStandardText
Size and location of the 'Standard Colors' caption area text.
Definition XTPColorSelectorCtrl.h:1134
CXTPColorSelectorCtrlTheme::m_rcRecentText
CRect m_rcRecentText
Size and location of the 'Recent Colors' caption area text.
Definition XTPColorSelectorCtrl.h:1133
CXTPColorSelectorCtrlTheme::m_crPopupBorder
COLORREF m_crPopupBorder
An RGB value for the pop-up border.
Definition XTPColorSelectorCtrl.h:1146
CXTPColorSelectorCtrlTheme::CreateAutoButton
virtual BOOL CreateAutoButton(CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked)
Called to add the 'Automatic Color' button to the color selector control.
CXTPColorSelectorCtrlTheme::m_nAutoButton
int m_nAutoButton
Height of the Automatic/More Colors buttons.
Definition XTPColorSelectorCtrl.h:1129
CXTPColorSelectorCtrlTheme::DrawColorCell
virtual void DrawColorCell(CDC *pDC, CXTPColorSelectorCtrl *pOwner, CXTPColorSelectorCtrl::COLOR_CELL *pColorCell, BOOL bHighlight, BOOL bPressed)
This member function is called to draw the cell specified by 'pColorCell'.
CXTPColorSelectorCtrlTheme::RefreshMetrics
virtual void RefreshMetrics(CXTPColorSelectorCtrl *pOwner)
This member function is called by the theme manager to refresh the visual styles used by each compone...
CXTPColorSelectorCtrlTheme::m_crBorder
COLORREF m_crBorder
An RGB value representing the border color.
Definition XTPColorSelectorCtrl.h:1137
CXTPColorSelectorCtrlTheme::m_crBackChecked
COLORREF m_crBackChecked
An RGB value for checked background color.
Definition XTPColorSelectorCtrl.h:1143
CXTPColorSelectorCtrlTheme::FillBackground
virtual void FillBackground(CDC *pDC, CXTPColorSelectorCtrl *pOwner, const CRect &rect)
Call this member function to draw the background of the ColorSelector control.
CXTPColorSelectorCtrlThemeNativeWindows10
CXTPColorSelectorCtrlThemeNativeWindows10 is derived from CXTPColorSelectorCtrlThemeVisualStudio2015 ...
Definition XTPColorSelectorCtrl.h:1486
CXTPColorSelectorCtrlThemeNativeWindows10::CXTPColorSelectorCtrlThemeNativeWindows10
CXTPColorSelectorCtrlThemeNativeWindows10()
Default constructor.
CXTPColorSelectorCtrlThemeNativeWindows11
CXTPColorSelectorCtrlThemeNativeWindows11 is derived from CXTPColorSelectorCtrlThemeVisualStudio2015 ...
Definition XTPColorSelectorCtrl.h:1503
CXTPColorSelectorCtrlThemeNativeWindows11::CXTPColorSelectorCtrlThemeNativeWindows11
CXTPColorSelectorCtrlThemeNativeWindows11()
Default constructor.
CXTPColorSelectorCtrlThemeOffice2003
CXTPColorSelectorCtrlThemeOffice2003 is derived from CXTPColorSelectorCtrlThemeOfficeXP to handle the...
Definition XTPColorSelectorCtrl.h:1180
CXTPColorSelectorCtrlThemeOffice2003::CXTPColorSelectorCtrlThemeOffice2003
CXTPColorSelectorCtrlThemeOffice2003()
Constructs a CXTPColorSelectorCtrlThemeOffice2003 object.
CXTPColorSelectorCtrlThemeOffice2003::RefreshMetrics
virtual void RefreshMetrics(CXTPColorSelectorCtrl *pOwner)
This member function is called by the theme manager to refresh the visual styles used by each compone...
CXTPColorSelectorCtrlThemeOffice2013
CXTPColorSelectorCtrlThemeOffice2013 is derived from CXTPColorSelectorCtrlTheme to handle theme speci...
Definition XTPColorSelectorCtrl.h:1227
CXTPColorSelectorCtrlThemeOffice2013::CreateMoreButton
virtual BOOL CreateMoreButton(CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked)
Called to add a 'More Colors' button to the color selector control.
CXTPColorSelectorCtrlThemeOffice2013::CreateExtendedButtons
virtual BOOL CreateExtendedButtons(CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked)
Called to add default color buttons to the color selector control.
CXTPColorSelectorCtrlThemeOffice2013::DrawColor
virtual void DrawColor(CDC *pDC, CXTPColorSelectorCtrl *pOwner, CXTPColorSelectorCtrl::COLOR_CELL *pColorCell, CRect rcItem, BOOL bChecked, BOOL bHighlight, BOOL bPressed)
Called to draw a color cell for the color selector control.
CXTPColorSelectorCtrlThemeOffice2013::CreateThemeButtons
virtual BOOL CreateThemeButtons(CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked)
Called to add theme and standard buttons to the color selector control.
CXTPColorSelectorCtrlThemeOffice2013::CXTPColorSelectorCtrlThemeOffice2013
CXTPColorSelectorCtrlThemeOffice2013()
Default constructor.
CXTPColorSelectorCtrlThemeOffice2013::CalcSize
virtual CSize CalcSize(CXTPColorSelectorCtrl *pOwner)
Called to determine the size of the color selector window.
CXTPColorSelectorCtrlThemeOffice2013::CreateRecentColorButtons
virtual BOOL CreateRecentColorButtons(CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked)
Called to add recent colors to the color selector control.
CXTPColorSelectorCtrlThemeOffice2013::DrawColorSelector
virtual void DrawColorSelector(CDC *pDC, CXTPColorSelectorCtrl *pOwner)
This member function is called to draw the color selector.
CXTPColorSelectorCtrlThemeOffice2013::DrawBorder
virtual void DrawBorder(CDC *pDC, CRect rcItem, CRect rcBorder, COLORREF crBorder)
This member function is called to draw the cell specified by 'pColorCell'.
CXTPColorSelectorCtrlThemeOffice2013::CreateAutoButton
virtual BOOL CreateAutoButton(CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked)
Called to add the 'Automatic Color' button to the color selector control.
CXTPColorSelectorCtrlThemeOffice2013::DrawColorCell
virtual void DrawColorCell(CDC *pDC, CXTPColorSelectorCtrl *pOwner, CXTPColorSelectorCtrl::COLOR_CELL *pColorCell, BOOL bHighlight, BOOL bPressed)
This member function is called to draw the cell specified by 'pColorCell'.
CXTPColorSelectorCtrlThemeOffice2013::RefreshMetrics
virtual void RefreshMetrics(CXTPColorSelectorCtrl *pOwner)
This member function is called by the theme manager to refresh the visual styles used by each compone...
CXTPColorSelectorCtrlThemeOffice2013::m_crTitleBack
COLORREF m_crTitleBack
An RGB value representing the title background color.
Definition XTPColorSelectorCtrl.h:1384
CXTPColorSelectorCtrlThemeOffice2013::m_crBorderInside
COLORREF m_crBorderInside
An RGB value representing the inside border highlight color.
Definition XTPColorSelectorCtrl.h:1385
CXTPColorSelectorCtrlThemeOffice2013::m_crTitleText
COLORREF m_crTitleText
An RGB value representing the title text color.
Definition XTPColorSelectorCtrl.h:1383
CXTPColorSelectorCtrlThemeOfficeXP
CXTPColorSelectorCtrlThemeOfficeXP is derived from CXTPColorSelectorCtrlTheme to handle theme specifi...
Definition XTPColorSelectorCtrl.h:1155
CXTPColorSelectorCtrlThemeOfficeXP::CXTPColorSelectorCtrlThemeOfficeXP
CXTPColorSelectorCtrlThemeOfficeXP()
Constructs a CXTPColorSelectorCtrlThemeOfficeXP object.
CXTPColorSelectorCtrlThemeOfficeXP::RefreshMetrics
virtual void RefreshMetrics(CXTPColorSelectorCtrl *pOwner)
This member function is called by the theme manager to refresh the visual styles used by each compone...
CXTPColorSelectorCtrlThemeResource
CXTPColorSelectorCtrlThemeResource is derived from CXTPColorSelectorCtrlThemeOfficeXP to handle theme...
Definition XTPColorSelectorCtrl.h:1204
CXTPColorSelectorCtrlThemeResource::RefreshMetrics
virtual void RefreshMetrics(CXTPColorSelectorCtrl *pOwner)
This member function is called by the theme manager to refresh the visual styles used by each compone...
CXTPColorSelectorCtrlThemeResource::CXTPColorSelectorCtrlThemeResource
CXTPColorSelectorCtrlThemeResource()
Constructs a CXTPColorSelectorCtrlThemeResource object.
CXTPColorSelectorCtrlThemeVisualStudio2015
CXTPColorSelectorCtrlThemeVisualStudio2015 is derived from CXTPColorSelectorCtrlThemeOffice2013 to ha...
Definition XTPColorSelectorCtrl.h:1396
CXTPColorSelectorCtrlThemeVisualStudio2015::CXTPColorSelectorCtrlThemeVisualStudio2015
CXTPColorSelectorCtrlThemeVisualStudio2015()
Default constructor.
CXTPColorSelectorCtrlThemeVisualStudio2015::DrawColorCell
virtual void DrawColorCell(CDC *pDC, CXTPColorSelectorCtrl *pOwner, CXTPColorSelectorCtrl::COLOR_CELL *pColorCell, BOOL bHighlight, BOOL bPressed)
This member function is called to draw the cell specified by 'pColorCell'.
CXTPColorSelectorCtrlThemeVisualStudio2015::RefreshMetrics
virtual void RefreshMetrics(CXTPColorSelectorCtrl *pOwner)
Called by the theme manager to refresh the visual styles used by each component's theme.
CXTPColorSelectorCtrlThemeVisualStudio2017
CXTPColorSelectorCtrlThemeVisualStudio2017 is derived from CXTPColorSelectorCtrlThemeVisualStudio2015...
Definition XTPColorSelectorCtrl.h:1435
CXTPColorSelectorCtrlThemeVisualStudio2017::CXTPColorSelectorCtrlThemeVisualStudio2017
CXTPColorSelectorCtrlThemeVisualStudio2017()
Default constructor.
CXTPColorSelectorCtrlThemeVisualStudio2019
CXTPColorSelectorCtrlThemeVisualStudio2019 is derived from CXTPColorSelectorCtrlThemeVisualStudio2015...
Definition XTPColorSelectorCtrl.h:1452
CXTPColorSelectorCtrlThemeVisualStudio2019::CXTPColorSelectorCtrlThemeVisualStudio2019
CXTPColorSelectorCtrlThemeVisualStudio2019()
Default constructor.
CXTPColorSelectorCtrlThemeVisualStudio2022
CXTPColorSelectorCtrlThemeVisualStudio2022 is derived from CXTPColorSelectorCtrlThemeVisualStudio2015...
Definition XTPColorSelectorCtrl.h:1469
CXTPColorSelectorCtrlThemeVisualStudio2022::CXTPColorSelectorCtrlThemeVisualStudio2022
CXTPColorSelectorCtrlThemeVisualStudio2022()
Default constructor.
CXTPControlTheme
CXTPControlTheme can be used as a base class for user defined themes.
Definition XTPControlTheme.h:95
CXTPColorSelectorCtrl::COLOR_CELL
COLOR_CELL structure is used by the CXTPColorSelectorCtrl class to maintain information about a parti...
Definition XTPColorSelectorCtrl.h:73
CXTPColorSelectorCtrl::COLOR_CELL::dwStyle
DWORD dwStyle
Color picker style for the cell.
Definition XTPColorSelectorCtrl.h:79
CXTPColorSelectorCtrl::COLOR_CELL::nIndex
UINT nIndex
Index of the color cell.
Definition XTPColorSelectorCtrl.h:75
CXTPColorSelectorCtrl::COLOR_CELL::clr
COLORREF clr
An RGB value that represents the color of the cell.
Definition XTPColorSelectorCtrl.h:81
CXTPColorSelectorCtrl::COLOR_CELL::bChecked
bool bChecked
true if the cell is checked.
Definition XTPColorSelectorCtrl.h:76
CXTPColorSelectorCtrl::COLOR_CELL::rect
CRect rect
Size of the color cell.
Definition XTPColorSelectorCtrl.h:77
CXTPColorSelectorCtrl::COLOR_CELL::nID
UINT nID
Command ID of the color cell.
Definition XTPColorSelectorCtrl.h:74
CXTPColorSelectorCtrl::COLOR_CELL::rcBorder
CRect rcBorder
Determines what borders are drawn.
Definition XTPColorSelectorCtrl.h:78
XTP_PICK_BUTTON
XTP_PICK_BUTTON structure is used by the CXTPColorSelectorCtrl class to support a user-defined color ...
Definition XTPColorSelectorCtrl.h:44
XTP_PICK_BUTTON::toolTipID
UINT toolTipID
Resource ID for the tooltip for the color button.
Definition XTPColorSelectorCtrl.h:46
XTP_PICK_BUTTON::clrButton
COLORREF clrButton
An RGB value representing the button color.
Definition XTPColorSelectorCtrl.h:45


Toolkit Pro: Member List

CXTPColorSetStateCheckBox Member List

This is the complete list of members for CXTPColorSetStateCheckBox, including all inherited members.

RefreshColors() | CXTPColorSetStateCheckBox | virtual
~CXTPColorSetStateCheckBox() | CXTPColorSetStateCheckBox | inlinevirtual


Toolkit Pro: XTPChart2dFunnelSeriesView.h Source File

  • Source
  • Chart
  • Styles
  • Funnel
  • 2D
XTPChart2dFunnelSeriesView.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHART2DFUNNELSERIESVIEW_H__)
24# define __XTPCHART2DFUNNELSERIESVIEW_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartSeriesView;
34class CXTPChartBorder;
35class CXTPChartFillStyle;
36
48class _XTP_EXT_CLASS CXTPChartFunnelSeriesView : public CXTPChartFunnelSeriesViewBase
49{
50 DECLARE_DYNAMIC(CXTPChartFunnelSeriesView);
51
52public:
60 CXTPChartFunnelSeriesView(CXTPChartSeries* pSeries, CXTPChartDiagramView* pDiagramView);
61
62public:
70 void CalculatePointLayout(CXTPChartDeviceContext* pDC, CRect rcBounds);
71
85 virtual CXTPChartDeviceCommand* CreateLegendDeviceCommand(CXTPChartDeviceContext* pDC,
86 CRect rcBounds, CXTPChartColor color1,
87 CXTPChartColor color2,
88 CXTPChartColor clrBorder);
89
90protected:
98 virtual CXTPChartRectF GetInnerBounds() const;
99
111 virtual CXTPChartSeriesPointView* CreateSeriesPointView(CXTPChartDeviceContext* pDC,
112 CXTPChartSeriesPoint* pPoint,
113 CXTPChartElementView* pParentView);
114
127 virtual CXTPChartDeviceCommand* CreateDeviceCommand(CXTPChartDeviceContext* pDC);
128
139 virtual CXTPChartDeviceCommand* CreateLegendDeviceCommand(CXTPChartDeviceContext* pDC,
140 CRect rcBounds);
141
142protected:
143 CXTPChartRectF m_rcInnerBounds;
144};
146# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
147#endif //#if !defined(__XTPCHART2DFUNNELSERIESVIEW_H__)
pPoint
const CPoint * pPoint
return 0 or xtpCalendarHitTestDayExpandButton
Definition XTPCalendarThemeOffice2007.h:150
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartBorder
This class abstracts the border of a chart, it is a kind of chart element.
Definition XTPChartBorder.h:42
CXTPChartColor
This class abstracts a color entity.
Definition XTPChartTypes.h:51
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartDiagramView
This class represents the view of a chart diagram, which is a kind of CXTPChartElementView.
Definition XTPChartDiagramView.h:49
CXTPChartElementView
This class represents the view of a chart element.
Definition XTPChartElementView.h:47
CXTPChartFillStyle
This class abstracts a fill style used to fill the background of various chart elements.
Definition XTPChartFillStyle.h:43
CXTPChartFunnelSeriesViewBase
This class abstracts the view of a funnel series.This class is a kind of CXTPChartSeriesView.
Definition XTPChartFunnelSeriesViewBase.h:50
CXTPChartFunnelSeriesView
This class abstracts the view of a funnel series.
Definition XTPChart2dFunnelSeriesView.h:49
CXTPChartFunnelSeriesView::CXTPChartFunnelSeriesView
CXTPChartFunnelSeriesView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Constructs a CXTPChartFunnelSeriesView object.
CXTPChartFunnelSeriesView::GetInnerBounds
virtual CXTPChartRectF GetInnerBounds() const
Call this function to get the inner bounds of the diagram.
CXTPChartFunnelSeriesView::CreateLegendDeviceCommand
virtual CXTPChartDeviceCommand * CreateLegendDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcBounds, CXTPChartColor color1, CXTPChartColor color2, CXTPChartColor clrBorder)
This function creates a label view drawing command object.
CXTPChartFunnelSeriesView::CreateDeviceCommand
virtual CXTPChartDeviceCommand * CreateDeviceCommand(CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
CXTPChartFunnelSeriesView::CreateLegendDeviceCommand
virtual CXTPChartDeviceCommand * CreateLegendDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcBounds)
This function creates a label view drawing command object.
CXTPChartFunnelSeriesView::CreateSeriesPointView
virtual CXTPChartSeriesPointView * CreateSeriesPointView(CXTPChartDeviceContext *pDC, CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Use this function to create the funnel series point view object.
CXTPChartFunnelSeriesView::CalculatePointLayout
void CalculatePointLayout(CXTPChartDeviceContext *pDC, CRect rcBounds)
Call this function to calculate the funnel series point layout.
CXTPChartSeries
This class represents a series in the chart, which is a kind of CXTPChartElement.
Definition XTPChartSeries.h:50
CXTPChartSeriesPoint
CXTPChartSeriesPoint is a kind of CXTPChartElement.
Definition XTPChartSeriesPoint.h:43
CXTPChartSeriesPointView
Represents chart series point view.
Definition XTPChartSeriesPointView.h:48
CXTPRectT< float >


Toolkit Pro: XTPGridThemeOffice2003.h Source File

  • Source
  • GridControl
  • Themes
XTPGridThemeOffice2003.h
Go to the documentation of this file.
1
23#if !defined(__XTPGridThemeOffice2003_H__)
24# define __XTPGridThemeOffice2003_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPGridThemeOffice2003 : public CXTPGridPaintManager
39{
40public:
45 CXTPGridThemeOffice2003();
46
58 virtual void DrawColumnBackground(CDC* pDC, CXTPGridColumn* pColumn, CRect rcColumn,
59 BOOL& bColumnPressed, BOOL& bDraggingFromHeader,
60 CXTPGridHeader* pHeader = NULL);
61
84 virtual void DrawColumn(CDC* pDC, CXTPGridColumn* pColumn, CXTPGridHeader* pHeader,
85 CRect rcColumn, BOOL bDrawExternal = FALSE, int nShadowWidth = 0);
86
99 void DrawSectionDivider(CDC* pDC, const CRect& rc,
100 XTPGridSectionDividerPosition dividerPosition,
101 XTPGridSectionDividerStyle dividerStyle,
102 CXTPPaintManagerColor dividerColor);
103};
105# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
106#endif //#if !defined(__XTPGridThemeOffice2003_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPGridSectionDividerPosition
XTPGridSectionDividerPosition
Section divider position.
Definition XTPGridDefines.h:258
XTPGridSectionDividerStyle
XTPGridSectionDividerStyle
Represent the header/footer rows divider style.
Definition XTPGridDefines.h:227
CXTPGridColumn
Represents a grid column item with its properties and operations.
Definition XTPGridColumn.h:107
CXTPGridHeader
A grid header is a part of the grid window positioned above columns of text or numbers.
Definition XTPGridHeader.h:173
CXTPGridPaintManager
Utility class that handles most drawing activities.
Definition XTPGridPaintManager.h:76
CXTPGridThemeOffice2003
CXTPGridThemeOffice2003 is a CXTPGridPaintManager derived class that represents an Office 2003 style ...
Definition XTPGridThemeOffice2003.h:39
CXTPGridThemeOffice2003::DrawSectionDivider
void DrawSectionDivider(CDC *pDC, const CRect &rc, XTPGridSectionDividerPosition dividerPosition, XTPGridSectionDividerStyle dividerStyle, CXTPPaintManagerColor dividerColor)
Draws the divider between grid sections (e.g.
CXTPGridThemeOffice2003::DrawColumn
virtual void DrawColumn(CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn, BOOL bDrawExternal=FALSE, int nShadowWidth=0)
Draws a column header with all related attributes (sort order, icon, etc.).
CXTPGridThemeOffice2003::DrawColumnBackground
virtual void DrawColumnBackground(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, BOOL &bColumnPressed, BOOL &bDraggingFromHeader, CXTPGridHeader *pHeader=NULL)
This method is called to draw the background of a column using the current column style.
CXTPGridThemeOffice2003::CXTPGridThemeOffice2003
CXTPGridThemeOffice2003()
Default paint manager constructor, handles properties initialization.
CXTPPaintManagerColor
The CXTPPaintManagerColor class is used to manage COLORREF values for determining default and applica...
Definition XTPColorManager.h:117


Toolkit Pro: XTPSyntaxEditView.h Source File

  • Source
  • SyntaxEdit
XTPSyntaxEditView.h
Go to the documentation of this file.
1
23#if !defined(__XTPSYNTAXEDITSYNTAXEDITVIEW_H__)
24# define __XTPSYNTAXEDITSYNTAXEDITVIEW_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPSyntaxEditFindReplaceDlg;
34
36namespace XTPSyntaxEditLexAnalyser
38{
39class CXTPSyntaxEditLexParser;
40}
41
54class _XTP_EXT_CLASS CXTPSyntaxEditViewPrintOptions : public CXTPPrintOptions
55{
57 DECLARE_DYNAMIC(CXTPSyntaxEditViewPrintOptions)
60public:
65 CXTPSyntaxEditViewPrintOptions();
66
67protected:
68# ifdef _XTP_ACTIVEX
70 DECLARE_DISPATCH_MAP()
71 DECLARE_INTERFACE_MAP()
72
73 DECLARE_OLETYPELIB_EX(CXTPSyntaxEditViewPrintOptions);
75# endif
76};
77
88class _XTP_EXT_CLASS CXTPSyntaxEditView : public CView
89{
91 friend class CXTPSyntaxEditDoc;
92 DECLARE_DYNCREATE(CXTPSyntaxEditView)
95protected:
100 CXTPSyntaxEditView();
101
107 virtual ~CXTPSyntaxEditView();
108
109public:
117 void SetFontIndirect(LOGFONT* pLogFont, BOOL bUpdateReg = FALSE);
118
125 void SetLineNumbers(BOOL bEnable);
126
133 BOOL GetHorzScrollBar() const;
134
141 BOOL GetVertScrollBar() const;
142
157 BOOL SetScrollBars(BOOL bHorz, BOOL bVert, BOOL bUpdateReg = FALSE, BOOL bRecalcLayout = TRUE);
158
165 void SetSelMargin(BOOL bEnable);
166
173 void SetAutoIndent(BOOL bEnable);
174
181 void SetSyntaxColor(BOOL bEnable);
182
187 void UpdateAllViews();
188
193 void SetDirty();
194
201 CXTPSyntaxEditCtrl& GetEditCtrl();
202
203 const CXTPSyntaxEditCtrl& GetEditCtrl() const;
204
216 virtual void SetEditCtrl(CXTPSyntaxEditCtrl* pControl);
217
224 CXTPSyntaxEditBufferManager* GetEditBuffer() const;
225
232 CXTPSyntaxEditConfigurationManager* GetLexConfigurationManager() const;
233
238 void Refresh();
239
247 BOOL SetTopRow(int iRow);
248
255 int GetTopRow() const;
256
263 void UpdateScrollPos(CView* pSender, DWORD dwUpdate = XTP_EDIT_UPDATE_ALL);
264
271 CXTPSyntaxEditDoc* GetDocument() const;
272
281 CXTPSyntaxEditBufferManager* GetDataManager() const;
282
289 XTPSyntaxEditLexAnalyser::CXTPSyntaxEditLexParser* GetLexParser() const;
290
297 virtual CXTPSyntaxEditFindReplaceDlg* GetFindReplaceDlg();
298
305 virtual CString GetPageTitle();
306
313 CXTPSyntaxEditViewPrintOptions* GetPrintOptions() const;
314
316public:
317 virtual void OnInitialUpdate();
318 virtual void OnPrepareDC(CDC* pDC, CPrintInfo* pInfo = NULL);
319 virtual DROPEFFECT OnDragEnter(COleDataObject* pDataObject, DWORD dwKeyState, CPoint point);
320 virtual void OnDragLeave();
321 virtual DROPEFFECT OnDragOver(COleDataObject* pDataObject, DWORD dwKeyState, CPoint point);
322 virtual BOOL OnDrop(COleDataObject* pDataObject, DROPEFFECT dropEffect, CPoint point);
323
324protected:
325 afx_msg void OnPaint();
326 virtual void OnDraw(CDC* pDC);
327 virtual BOOL OnNotify(WPARAM wParam, LPARAM lParam, LRESULT* pResult);
328 virtual void OnEndPrinting(CDC* pDC, CPrintInfo* pInfo);
329 virtual BOOL OnPreparePrinting(CPrintInfo* pInfo);
330 virtual void OnBeginPrinting(CDC* pDC, CPrintInfo* pInfo);
331 virtual void OnPrint(CDC* pDC, CPrintInfo* pInfo);
332 virtual BOOL PaginateTo(CDC* pDC, CPrintInfo* pInfo);
333 virtual BOOL PreCreateWindow(CREATESTRUCT& cs);
334 virtual void OnActivateView(BOOL bActivate, CView* pActivateView, CView* pDeactiveView);
335 virtual void OnDropFiles(HDROP hDropInfo);
336 virtual void OnUpdate(CView* pSender, LPARAM lHint = 0L, CObject* pHint = NULL);
339protected:
353 virtual BOOL OnEditChanging(NMHDR* pNMHDR, LRESULT* pResult);
354
367 virtual BOOL OnEditChanged(NMHDR* pNMHDR, LRESULT* pResult);
368
380 virtual BOOL OnSetDocModified(NMHDR* pNMHDR, LRESULT* pResult);
381
395 virtual BOOL OnDrawBookmark(NMHDR* pNMHDR, LRESULT* pResult);
396
408 virtual BOOL OnRowColChanged(NMHDR* pNMHDR, LRESULT* pResult);
409
421 virtual BOOL OnUpdateScrollPos(NMHDR* pNMHDR, LRESULT* pResult);
422
434 virtual BOOL OnEnableScrollBar(NMHDR* pNMHDR, LRESULT* pResult);
435
447 virtual BOOL OnInsertKey(NMHDR* pNMHDR, LRESULT* pResult);
448
460 virtual BOOL OnSelInit(NMHDR* pNMHDR, LRESULT* pResult);
461
473 virtual BOOL OnStartOleDrag(NMHDR* pNMHDR, LRESULT* pResult);
474
488 virtual BOOL OnMarginClicked(NMHDR* pNMHDR, LRESULT* pResult);
489
501 virtual BOOL OnParseEvent(NMHDR* pNMHDR, LRESULT* pResult);
502
503protected:
504# ifdef _DEBUG
505 virtual void AssertValid() const;
506 virtual void Dump(CDumpContext& dc) const;
507# endif
508
515 virtual BOOL CanChangeReadonlyFile();
516
518 afx_msg int OnCreate(LPCREATESTRUCT lpCreateStruct);
519 afx_msg void OnSize(UINT nType, int cx, int cy);
520 afx_msg void OnKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags);
521 afx_msg void OnChar(UINT nChar, UINT nRepCnt, UINT nFlags);
522 afx_msg void OnVScroll(UINT nSBCode, UINT nPos, CScrollBar* pScrollBar);
523 afx_msg void OnHScroll(UINT nSBCode, UINT nPos, CScrollBar* pScrollBar);
524 afx_msg void OnSetFocus(CWnd* pOldWnd);
525 afx_msg void OnEditUndo();
526 afx_msg void OnUpdateEditUndo(CCmdUI* pCmdUI);
527 afx_msg void OnEditRedo();
528 afx_msg void OnUpdateEditRedo(CCmdUI* pCmdUI);
529 afx_msg void OnEditCut();
530 afx_msg void OnUpdateEditCut(CCmdUI* pCmdUI);
531 afx_msg void OnEditCopy();
532 afx_msg void OnUpdateEditCopy(CCmdUI* pCmdUI);
533 afx_msg void OnEditPaste();
534 afx_msg void OnUpdateEditPaste(CCmdUI* pCmdUI);
535 afx_msg void OnEditDelete();
536 afx_msg void OnUpdateEditDelete(CCmdUI* pCmdUI);
537 afx_msg void OnEditSelectAll();
538 afx_msg void OnUpdateEditSelectAll(CCmdUI* pCmdUI);
539 afx_msg void OnEditFind();
540 afx_msg void OnUpdateEditFind(CCmdUI* pCmdUI);
541 afx_msg void OnEditReplace();
542 afx_msg void OnUpdateEditReplace(CCmdUI* pCmdUI);
543 afx_msg void OnEditRepeat();
544 afx_msg void OnUpdateEditRepeat(CCmdUI* pCmdUI);
545 afx_msg BOOL OnEraseBkgnd(CDC* pDC);
546 afx_msg void OnFilePageSetup();
547 afx_msg void OnUpdateKeyIndicator(CCmdUI* pCmdUI);
548
549 virtual void _EditFindReplace(BOOL bReplaceDlg);
550
551 DECLARE_MESSAGE_MAP()
554protected:
561 void UpdateSiblings(XTP_EDIT_NMHDR_EDITCHANGED* pNMHDR_EC = NULL, BOOL bTextChanged = TRUE);
562
572 void UpdateSiblingScrollPos(CXTPSyntaxEditView* pSender, DWORD dwUpdate);
573
584 CXTPSyntaxEditView* GetSplitterView(int nRow, int nCol);
585
590 void StartOleDrag();
591
592 LOGFONT m_lfPrevFont;
593 int m_nPrevTopRow;
595protected:
596 int m_nParserThreadPriority_WhenActive;
597 int m_nParserThreadPriority_WhenInactive;
599 BOOL m_bDraggingOver;
600 BOOL m_bDraggingStartedHere;
602 BOOL m_bScrollBars;
605 static CXTPSyntaxEditView* ms_pTargetView;
607 static BOOL ms_bDroppedHere;
608 static POINT ms_ptDropPos;
609 static DWORD_PTR ms_dwSignature;
611 BOOL m_bOleDragging;
612 BOOL m_bFilesDragging;
613 COleDropTarget m_dropTarget;
615 CSize m_szPage;
616 int m_iTopRow;
618 CWnd* m_pParentWnd;
619 CXTPSyntaxEditCtrl* m_pEditCtrl;
621 static CXTPSyntaxEditFindReplaceDlg* m_pFindReplaceDlg;
624 BOOL m_bOnSizeRunning;
627 CXTPSyntaxEditViewPrintOptions* m_pPrintOptions;
628 CUIntArray m_aPageStart;
630public:
631 BOOL m_bPrintDirect;
632 BOOL m_bResizeControlWithView;
634};
635
637
638AFX_INLINE CXTPSyntaxEditBufferManager* CXTPSyntaxEditView::GetEditBuffer() const
639{
640 return GetEditCtrl().GetEditBuffer();
641}
642AFX_INLINE CXTPSyntaxEditConfigurationManager* CXTPSyntaxEditView::GetLexConfigurationManager() const
643{
644 return GetEditCtrl().GetLexConfigurationManager();
645}
646AFX_INLINE CXTPSyntaxEditViewPrintOptions* CXTPSyntaxEditView::GetPrintOptions() const
647{
648 return m_pPrintOptions;
649}
650
651# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
653#endif // !defined(__XTPSYNTAXEDITSYNTAXEDITVIEW_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPSyntaxEditBufferManager
This class is the main class for buffer management.
Definition XTPSyntaxEditBufferManager.h:59
CXTPSyntaxEditConfigurationManager
This class manages all configuration parameters of the control.
Definition XTPSyntaxEditLexColorFileReader.h:601
CXTPSyntaxEditCtrl
This class is the main CWnd-based editor class.
Definition XTPSyntaxEditCtrl.h:114
CXTPSyntaxEditDoc
This class represents the Document portion of an Edit control.
Definition XTPSyntaxEditDoc.h:45
CXTPSyntaxEditFindReplaceDlg
This class implements the "Find and Replace" and "Find" dialogs for a SyntaxEdit control.
Definition XTPSyntaxEditFindReplaceDlg.h:41
CXTPSyntaxEditLexParser
This class used to 'run' lex schema parsing in a separate thread.
Definition XTPSyntaxEditLexParser.h:861
CXTPSyntaxEditView
This class represents a View portion of the Edit Control.
Definition XTPSyntaxEditView.h:89
CXTPSyntaxEditView::UpdateScrollPos
void UpdateScrollPos(CView *pSender, DWORD dwUpdate=XTP_EDIT_UPDATE_ALL)
Updates sibling views while in split mode.
CXTPSyntaxEditView::OnInsertKey
virtual BOOL OnInsertKey(NMHDR *pNMHDR, LRESULT *pResult)
This function is the default handler for the XTP_EDIT_NM_INSERTKEY message which is sent when the 'In...
CXTPSyntaxEditView::OnDrawBookmark
virtual BOOL OnDrawBookmark(NMHDR *pNMHDR, LRESULT *pResult)
This function is the default handler for the XTP_EDIT_NM_DRAWBOOKMARK message which is sent before th...
CXTPSyntaxEditView::SetSelMargin
void SetSelMargin(BOOL bEnable)
Enables/disables the gutter.
CXTPSyntaxEditView::GetEditCtrl
CXTPSyntaxEditCtrl & GetEditCtrl()
Gets the smart edit control.
CXTPSyntaxEditView::SetLineNumbers
void SetLineNumbers(BOOL bEnable)
Enables/disables line numbering.
CXTPSyntaxEditView::SetTopRow
BOOL SetTopRow(int iRow)
Sets the top row.
CXTPSyntaxEditView::GetHorzScrollBar
BOOL GetHorzScrollBar() const
Determines if the horizontal scrollbar is enabled.
CXTPSyntaxEditView::GetLexConfigurationManager
CXTPSyntaxEditConfigurationManager * GetLexConfigurationManager() const
Gets the associated configuration manager.
Definition XTPSyntaxEditView.h:642
CXTPSyntaxEditView::CXTPSyntaxEditView
CXTPSyntaxEditView()
Protected object constructor.
CXTPSyntaxEditView::OnSelInit
virtual BOOL OnSelInit(NMHDR *pNMHDR, LRESULT *pResult)
This function is the default handler for the XTP_EDIT_NM_SELINIT message which is sent when the selec...
CXTPSyntaxEditView::~CXTPSyntaxEditView
virtual ~CXTPSyntaxEditView()
Destroys a CXTPSyntaxEditView() object, handles cleanup and de-allocation.
CXTPSyntaxEditView::OnRowColChanged
virtual BOOL OnRowColChanged(NMHDR *pNMHDR, LRESULT *pResult)
This function is the default handler for the XTP_EDIT_NM_ROWCOLCHANGED message which is sent before t...
CXTPSyntaxEditView::OnUpdateScrollPos
virtual BOOL OnUpdateScrollPos(NMHDR *pNMHDR, LRESULT *pResult)
This function is the default handler for the XTP_EDIT_NM_UPDATESCROLLPOS message which is sent before...
CXTPSyntaxEditView::OnStartOleDrag
virtual BOOL OnStartOleDrag(NMHDR *pNMHDR, LRESULT *pResult)
This function is the default handler for the XTP_EDIT_NM_STARTOLEDRAG message which is sent when OLE ...
CXTPSyntaxEditView::GetVertScrollBar
BOOL GetVertScrollBar() const
Determines if the vertical scrollbar is enabled.
CXTPSyntaxEditView::GetPrintOptions
CXTPSyntaxEditViewPrintOptions * GetPrintOptions() const
Gets the print options of this view.
Definition XTPSyntaxEditView.h:646
CXTPSyntaxEditView::GetDocument
CXTPSyntaxEditDoc * GetDocument() const
Gets the document.
CXTPSyntaxEditView::GetDataManager
CXTPSyntaxEditBufferManager * GetDataManager() const
Gets the edit buffer manager.
CXTPSyntaxEditView::SetSyntaxColor
void SetSyntaxColor(BOOL bEnable)
Enables/disables syntax colorization.
CXTPSyntaxEditView::GetTopRow
int GetTopRow() const
Gets the top row.
CXTPSyntaxEditView::UpdateAllViews
void UpdateAllViews()
Updates all active sibling views.
CXTPSyntaxEditView::GetPageTitle
virtual CString GetPageTitle()
Gets the document title.
CXTPSyntaxEditView::OnParseEvent
virtual BOOL OnParseEvent(NMHDR *pNMHDR, LRESULT *pResult)
This function is the default handler for the XTP_EDIT_NM_PARSEEVENT message which is sent when a pars...
CXTPSyntaxEditView::GetEditBuffer
CXTPSyntaxEditBufferManager * GetEditBuffer() const
Gets the buffer manager of the smart edit control.
Definition XTPSyntaxEditView.h:638
CXTPSyntaxEditView::OnEditChanged
virtual BOOL OnEditChanged(NMHDR *pNMHDR, LRESULT *pResult)
This function is the default handler for the XTP_EDIT_NM_EDITCHANGED message which is sent when editi...
CXTPSyntaxEditView::OnMarginClicked
virtual BOOL OnMarginClicked(NMHDR *pNMHDR, LRESULT *pResult)
This function is the default handler for the XTP_EDIT_NM_MARGINCLICKED message which is sent when the...
CXTPSyntaxEditView::Refresh
void Refresh()
Refreshes the whole document and recalculates the scrollbar.
CXTPSyntaxEditView::GetLexParser
XTPSyntaxEditLexAnalyser::CXTPSyntaxEditLexParser * GetLexParser() const
Gets the associated lexical parser.
CXTPSyntaxEditView::SetDirty
void SetDirty()
Sets the view ready for redraw.
CXTPSyntaxEditView::OnEnableScrollBar
virtual BOOL OnEnableScrollBar(NMHDR *pNMHDR, LRESULT *pResult)
This function is the default handler for the XTP_EDIT_NM_ENABLESCROLLBAR message which is sent before...
CXTPSyntaxEditView::OnEditChanging
virtual BOOL OnEditChanging(NMHDR *pNMHDR, LRESULT *pResult)
This function is the default handler for the XTP_EDIT_NM_EDITCHANGING message which is sent before ed...
CXTPSyntaxEditView::CanChangeReadonlyFile
virtual BOOL CanChangeReadonlyFile()
Overwrite this method to customize read-only file handling.
CXTPSyntaxEditView::OnSetDocModified
virtual BOOL OnSetDocModified(NMHDR *pNMHDR, LRESULT *pResult)
This function is the default handler for the XTP_EDIT_NM_SETDOCMODIFIED message which is sent when th...
CXTPSyntaxEditView::SetScrollBars
BOOL SetScrollBars(BOOL bHorz, BOOL bVert, BOOL bUpdateReg=FALSE, BOOL bRecalcLayout=TRUE)
Enables/disables the horizontal and vertical scrollbars.
CXTPSyntaxEditView::SetAutoIndent
void SetAutoIndent(BOOL bEnable)
Enables/disables auto-indent.
CXTPSyntaxEditView::SetEditCtrl
virtual void SetEditCtrl(CXTPSyntaxEditCtrl *pControl)
Sets the smart edit control.
CXTPSyntaxEditView::SetFontIndirect
void SetFontIndirect(LOGFONT *pLogFont, BOOL bUpdateReg=FALSE)
Sets the font for the edit control.
CXTPSyntaxEditView::GetFindReplaceDlg
virtual CXTPSyntaxEditFindReplaceDlg * GetFindReplaceDlg()
Gets the attached Find/Replace dialog.
CXTPSyntaxEditViewPrintOptions
Describes printing options for the Calendar control.
Definition XTPSyntaxEditView.h:55
CXTPSyntaxEditViewPrintOptions::CXTPSyntaxEditViewPrintOptions
CXTPSyntaxEditViewPrintOptions()
Default constructor.
XTP_EDIT_NMHDR_EDITCHANGED
Structure to notify "Edit changed" event.
Definition XTPSyntaxEditStruct.h:359


Toolkit Pro: XTPChartAxisCustomLabels.h Source File

  • Source
  • Chart
  • Diagram
  • Axis
XTPChartAxisCustomLabels.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTAXISCUSTOMLABELS_H__)
24# define __XTPCHARTAXISCUSTOMLABELS_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartAxis;
34class CXTPChartLineStyle;
35class CXTPChartLineStyle;
36
42class _XTP_EXT_CLASS CXTPChartAxisCustomLabel : public CXTPChartElement
43{
45 DECLARE_DYNCREATE(CXTPChartAxisCustomLabel)
47public:
52 CXTPChartAxisCustomLabel();
53
58 virtual ~CXTPChartAxisCustomLabel();
59
60public:
67 void SetText(const CXTPChartString& lpszTitle);
68
75 CXTPChartString GetText() const;
76
83 CXTPChartString GetAxisValue() const;
84
91 double GetAxisValueInternal() const;
92
99 void SetAxisValue(LPCTSTR lpszValue);
100
107 void SetAxisValue(double dValue);
108
109public:
121 void DoPropExchange(CXTPPropExchange* pPX);
122
123protected:
124# ifdef _XTP_ACTIVEX
126 DECLARE_DISPATCH_MAP()
127 DECLARE_INTERFACE_MAP()
128 DECLARE_OLETYPELIB_EX(CXTPChartAxisCustomLabel);
129
130 BSTR OleGetText();
131 void OleSetText(LPCTSTR lpszText);
132 VARIANT OleGetAxisValue();
133 void OleSetAxisValue(const VARIANT& var);
134
136# endif
137
138protected:
139 CXTPChartString m_strText;
140 CXTPChartString m_strAxisValue;
141 double m_dAxisValue;
142
143 friend class CXTPChartAxisCustomLabels;
144};
145
150class _XTP_EXT_CLASS CXTPChartAxisCustomLabels : public CXTPChartElementCollection
151{
152public:
159 CXTPChartAxisCustomLabels(CXTPChartAxis* pAxis);
160
165 virtual ~CXTPChartAxisCustomLabels();
166
167public:
175 CXTPChartAxisCustomLabel* Add(CXTPChartAxisCustomLabel* pCustomLabel);
176
186 CXTPChartAxisCustomLabel* GetAt(int nIndex) const;
187
188public:
189 void DoPropExchange(CXTPPropExchange* pPX);
190
191public:
192# ifdef _XTP_ACTIVEX
194 DECLARE_DISPATCH_MAP()
195 DECLARE_INTERFACE_MAP()
196
197 DECLARE_OLETYPELIB_EX(CXTPChartAxisCustomLabels);
198
199 afx_msg long OleGetItemCount();
200 afx_msg LPDISPATCH OleGetItem(long nIndex);
201 DECLARE_ENUM_VARIANT(CXTPChartAxisCustomLabels)
202
203 afx_msg LPDISPATCH OleAdd(LPCTSTR lpszName, const VARIANT& Value);
205# endif
206
207protected:
208};
209
210AFX_INLINE CXTPChartAxisCustomLabel* CXTPChartAxisCustomLabels::GetAt(int nIndex) const
211{
212 return nIndex >= 0 && nIndex < m_arrElements.GetSize()
213 ? (CXTPChartAxisCustomLabel*)m_arrElements.GetAt(nIndex)
214 : NULL;
215}
216
217AFX_INLINE CXTPChartString CXTPChartAxisCustomLabel::GetAxisValue() const
218{
219 return m_strAxisValue;
220}
221AFX_INLINE double CXTPChartAxisCustomLabel::GetAxisValueInternal() const
222{
223 return m_dAxisValue;
224}
225AFX_INLINE void CXTPChartAxisCustomLabel::SetAxisValue(LPCTSTR lpszValue)
226{
227 m_strAxisValue = lpszValue;
228 OnChartChanged();
229}
230AFX_INLINE void CXTPChartAxisCustomLabel::SetAxisValue(double dValue)
231{
232 m_dAxisValue = dValue;
233 m_strAxisValue.Empty();
234 OnChartChanged();
235}
236AFX_INLINE CXTPChartString CXTPChartAxisCustomLabel::GetText() const
237{
238 return m_strText;
239}
241# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
242#endif //#if !defined(__XTPCHARTAXISCUSTOMLABELS_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartAxisCustomLabel
CXTPChartAxisCustomLabel is a CXTPChartElement derived class.
Definition XTPChartAxisCustomLabels.h:43
CXTPChartAxisCustomLabel::~CXTPChartAxisCustomLabel
virtual ~CXTPChartAxisCustomLabel()
Destroys a CXTPChartAxisCustomLabel object, handles cleanup.
CXTPChartAxisCustomLabel::DoPropExchange
void DoPropExchange(CXTPPropExchange *pPX)
Call this member function to Store/Load the label properties using the specified data object.
CXTPChartAxisCustomLabel::m_strText
CXTPChartString m_strText
The text of the item.
Definition XTPChartAxisCustomLabels.h:139
CXTPChartAxisCustomLabel::GetAxisValue
CXTPChartString GetAxisValue() const
Use this function to get the value of the constant line in the axis.
Definition XTPChartAxisCustomLabels.h:217
CXTPChartAxisCustomLabel::GetText
CXTPChartString GetText() const
Call this function to get the text of the custom label.
Definition XTPChartAxisCustomLabels.h:236
CXTPChartAxisCustomLabel::GetAxisValueInternal
double GetAxisValueInternal() const
Use this function to get the value of the constant line in the axis.
Definition XTPChartAxisCustomLabels.h:221
CXTPChartAxisCustomLabel::SetAxisValue
void SetAxisValue(LPCTSTR lpszValue)
Call this function to set the value of the constant line in the axis.
Definition XTPChartAxisCustomLabels.h:225
CXTPChartAxisCustomLabel::CXTPChartAxisCustomLabel
CXTPChartAxisCustomLabel()
Constructs a CXTPChartAxisCustomLabel object.
CXTPChartAxisCustomLabel::m_strAxisValue
CXTPChartString m_strAxisValue
The axis value.
Definition XTPChartAxisCustomLabels.h:140
CXTPChartAxisCustomLabel::SetText
void SetText(const CXTPChartString &lpszTitle)
Use this function to set the text of the custom label.
CXTPChartAxisCustomLabels
This class encapsulates a collection of CXTPChartAxisCustomLabel objects.
Definition XTPChartAxisCustomLabels.h:151
CXTPChartAxisCustomLabels::DoPropExchange
void DoPropExchange(CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
CXTPChartAxisCustomLabels::GetAt
CXTPChartAxisCustomLabel * GetAt(int nIndex) const
Call this function to get the label object at a particular index in the collection.
Definition XTPChartAxisCustomLabels.h:210
CXTPChartAxisCustomLabels::~CXTPChartAxisCustomLabels
virtual ~CXTPChartAxisCustomLabels()
Destroys a CXTPChartAxisCustomLabels object, handles cleanup.
CXTPChartAxisCustomLabels::Add
CXTPChartAxisCustomLabel * Add(CXTPChartAxisCustomLabel *pCustomLabel)
This function adds a new custom label to the collection of labels.
CXTPChartAxisCustomLabels::CXTPChartAxisCustomLabels
CXTPChartAxisCustomLabels(CXTPChartAxis *pAxis)
Constructs a CXTPChartAxisCustomLabels object.
CXTPChartAxis
This abstract base class represents a chart axis as a kind of chart element.
Definition XTPChartAxis.h:86
CXTPChartElementCollection
This class abstracts a chart collection.
Definition XTPChartElement.h:358
CXTPChartElementCollection::m_arrElements
CArray< CXTPChartElement *, CXTPChartElement * > m_arrElements
Array of CXTPChartElement pointer.
Definition XTPChartElement.h:450
CXTPChartElement
This class abstracts a chart element, this class acts as a base class for all chart elements.
Definition XTPChartElement.h:131
CXTPChartElement::OnChartChanged
virtual void OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic propertie...
CXTPChartLineStyle
This class represents a chart line style, which is a kind of CXTPCmdTarget.
Definition XTPChartLineStyle.h:43
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72


Toolkit Pro: Member List

CXTPStickerBase Member List

This is the complete list of members for CXTPStickerBase, including all inherited members.

Create() | CXTPStickerBase |
CXTPStickerBase() | CXTPStickerBase |
m_stickers | CXTPStickerBase | protected
~CXTPStickerBase() | CXTPStickerBase | virtual


Toolkit Pro: XTPWinEventHook.h Source File

  • Source
  • Common
  • Hook
XTPWinEventHook.h
Go to the documentation of this file.
1
23#if !defined(__XTPWINEVENTHOOK_H__)
24# define __XTPWINEVENTHOOK_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class _XTP_EXT_CLASS CXTPWinEventHook
34{
35public:
36 DECLARE_HANDLE(HWINEVENTHOOK);
37 typedef void(CALLBACK* WINEVENTPROC)(HWINEVENTHOOK hWinEventHook, DWORD event, HWND hwnd,
38 LONG idObject, LONG idChild, DWORD idEventThread,
39 DWORD dwmsEventTime);
40
41public:
42 CXTPWinEventHook();
43 virtual ~CXTPWinEventHook();
44
45public:
46 void SetEventHook(UINT eventMin, UINT eventMax, WINEVENTPROC pfnEventProc);
47 void RemoveEventHook();
48
49protected:
50 typedef HWINEVENTHOOK(WINAPI* LPFNSETWINEVENTHOOK)(UINT eventMin, UINT eventMax,
51 HMODULE hmodWinEventProc,
52 WINEVENTPROC lpfnWinEventProc,
53 DWORD idProcess, DWORD idThread,
54 UINT dwflags);
55 typedef BOOL(WINAPI* LPFNUNHOOKWINEVENT)(HWINEVENTHOOK hWinEventHook);
56
57 static void CALLBACK WinEventProc(HWINEVENTHOOK hWinEventHook, DWORD event, HWND hWnd,
58 LONG idObject, LONG idChild, DWORD dwEventThread,
59 DWORD dwmsEventTime);
60
61protected:
62 HWINEVENTHOOK m_hWinEventHook; // HWINEVENTHOOK value that identifies event hook instance
63 LPFNSETWINEVENTHOOK m_pSetWinEventHook;
64 LPFNUNHOOKWINEVENT m_pUnhookWinEvent;
65};
66
67# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
69#endif // !defined(__XTPWINEVENTHOOK_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h


Toolkit Pro: XTPDockingPaneTabTheme2019.h Source File

  • Source
  • DockingPane
  • TabThemes
XTPDockingPaneTabTheme2019.h
Go to the documentation of this file.
1
23#if !defined(__XTPDOCKINGPANETABTHEME2019_H__)
24# define __XTPDOCKINGPANETABTHEME2019_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPDockingPaneTabTheme2019 : public CXTPDockingPaneTabTheme2012
39{
40public:
45 CXTPDockingPaneTabTheme2019();
46
63 virtual void DrawSingleButton(CDC* pDC, CXTPTabManagerItem* pItem);
64};
65
66# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
68#endif // !defined(__XTPDOCKINGPANETABTHEME2019_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPDockingPaneTabTheme2012
Helper class used to initialize default colors for a theme from an .INI resource and handle drawing r...
Definition XTPDockingPaneTabTheme2012.h:39
CXTPDockingPaneTabTheme2019
Helper class used to initialize default colors for a theme from an .INI resource and handle drawing r...
Definition XTPDockingPaneTabTheme2019.h:39
CXTPDockingPaneTabTheme2019::CXTPDockingPaneTabTheme2019
CXTPDockingPaneTabTheme2019()
Default class constructor.
CXTPDockingPaneTabTheme2019::DrawSingleButton
virtual void DrawSingleButton(CDC *pDC, CXTPTabManagerItem *pItem)
This method is called to draw a single tab button in the tab client header area.
CXTPTabManagerItem
CXTPTabManagerItem is the base class for the tabs that appear in the command bars tab workspace,...
Definition XTPTabManagerItem.h:44


Toolkit Pro: XTPSliderThemeResource.h Source File

  • Source
  • CommandBars
  • Slider
XTPSliderThemeResource.h
Go to the documentation of this file.
1
23#if !defined(__XTPSLIDERTHEMERESOURCE_H__)
24# define __XTPSLIDERTHEMERESOURCE_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class _XTP_EXT_CLASS CXTPSliderResourceTheme : public CXTPSliderPaintManager
34{
35public:
36 CXTPSliderResourceTheme(CXTPPaintManager* pPaintManager)
37 : CXTPSliderPaintManager(pPaintManager)
38 {
39 }
40
41public:
42 virtual void DrawScrollBar(CDC* pDC, CXTPScrollBase* pGallery);
43 virtual void RefreshMetrics();
44};
45
47# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
48#endif // !defined(__XTPSLIDERTHEMERESOURCE_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPPaintManager
Paint manager of the command bars.
Definition XTPPaintManager.h:199
CXTPScrollBase
CXTPScrollBase is the base class for all scrollable objects.
Definition XTPScrollBase.h:222
CXTPSliderPaintManager
Paint manager for the slider control.
Definition XTPSliderPaintManager.h:40
CXTPSliderPaintManager::DrawScrollBar
virtual void DrawScrollBar(CDC *pDC, CXTPScrollBase *pScrollBar)
This method is called to draw the scrollbar of the slider.
CXTPSliderPaintManager::RefreshMetrics
virtual void RefreshMetrics()
Recalculates gallery metrics.


Toolkit Pro: XTPChartPyramidSeriesLabelBase.h Source File

  • Source
  • Chart
  • Styles
  • Pyramid
  • Base
XTPChartPyramidSeriesLabelBase.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTPYRAMIDSERIESLABELBASE_H__)
24# define __XTPCHARTPYRAMIDSERIESLABELBASE_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartPyramidSeriesStyleBase;
34class CXTPPropExchange;
35class CXTPChartDeviceContext;
36class CXTPChartSeriesPointView;
37class CXTPChartElementView;
38
43enum XTPChartPyramidLabelPosition
44{
45 xtpChartPyramidLabelLeft,
46 xtpChartPyramidLabelRight,
47 xtpChartPyramidLabelCenter
48};
49
54class _XTP_EXT_CLASS CXTPChartPyramidSeriesLabelBase : public CXTPChartSeriesLabel
55{
56 DECLARE_DYNAMIC(CXTPChartPyramidSeriesLabelBase);
57
58public:
63 CXTPChartPyramidSeriesLabelBase();
64
69 virtual ~CXTPChartPyramidSeriesLabelBase();
70
71public:
79 XTPChartPyramidLabelPosition GetPosition() const;
80
88 void SetPosition(XTPChartPyramidLabelPosition nPosition);
89
97 CXTPChartPyramidSeriesStyleBase* GetStyle() const;
98
110 void DoPropExchange(CXTPPropExchange* pPX);
111
119 BOOL IsInside() const;
120
121protected:
133 virtual CXTPChartElementView* CreateView(CXTPChartDeviceContext* pDC,
134 CXTPChartSeriesPointView* pPointView,
135 CXTPChartElementView* pParentView) = 0;
136
137protected:
138 XTPChartPyramidLabelPosition m_nPosition;
140# ifdef _XTP_ACTIVEX
141public:
143 DECLARE_DISPATCH_MAP()
144 DECLARE_INTERFACE_MAP()
145 DECLARE_OLETYPELIB_EX(CXTPChartPyramidSeriesLabelBase);
147# endif
148};
149
150AFX_INLINE XTPChartPyramidLabelPosition CXTPChartPyramidSeriesLabelBase::GetPosition() const
151{
152 return m_nPosition;
153}
154
155AFX_INLINE void CXTPChartPyramidSeriesLabelBase::SetPosition(XTPChartPyramidLabelPosition nPosition)
156{
157 m_nPosition = nPosition;
158 OnChartChanged();
159}
160
165class CXTPChartPyramidSeriesLabelViewBase : public CXTPChartSeriesLabelView
166{
167 DECLARE_DYNAMIC(CXTPChartPyramidSeriesLabelViewBase);
168
169protected:
178 CXTPChartPyramidSeriesLabelViewBase(CXTPChartSeriesLabel* pLabel,
179 CXTPChartSeriesPointView* pPointView,
180 CXTPChartElementView* pParentView);
181
182public:
190 XTPChartPyramidLabelPosition GetPosition() const;
191
202 virtual CXTPChartDeviceCommand* CreateDeviceCommand(CXTPChartDeviceContext* pDC) = 0;
203};
205# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
206#endif //#if !defined(__XTPCHARTPYRAMIDSERIESLABELBASE_H__)
XTPChartPyramidLabelPosition
XTPChartPyramidLabelPosition
This enumeration tells the various positions available for the pyramid label.
Definition XTPChartPyramidSeriesLabelBase.h:44
xtpChartPyramidLabelCenter
@ xtpChartPyramidLabelCenter
Place label in the center of a pyramid point.
Definition XTPChartPyramidSeriesLabelBase.h:47
xtpChartPyramidLabelLeft
@ xtpChartPyramidLabelLeft
Place label on the left side of a pyramid point.
Definition XTPChartPyramidSeriesLabelBase.h:45
xtpChartPyramidLabelRight
@ xtpChartPyramidLabelRight
Place label on the right side of a pyramid point.
Definition XTPChartPyramidSeriesLabelBase.h:46
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartElement::OnChartChanged
virtual void OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic propertie...
CXTPChartElementView
This class represents the view of a chart element.
Definition XTPChartElementView.h:47
CXTPChartPyramidSeriesLabelBase
This class abstracts the pyramid series label.
Definition XTPChartPyramidSeriesLabelBase.h:55
CXTPChartPyramidSeriesLabelBase::DoPropExchange
void DoPropExchange(CXTPPropExchange *pPX)
Call this member function to Store/Load the properties of content using the specified data object.
CXTPChartPyramidSeriesLabelBase::GetStyle
CXTPChartPyramidSeriesStyleBase * GetStyle() const
Call this function to get the basic style of the pyramid series.
CXTPChartPyramidSeriesLabelBase::SetPosition
void SetPosition(XTPChartPyramidLabelPosition nPosition)
Call this function to set the label position.
Definition XTPChartPyramidSeriesLabelBase.h:155
CXTPChartPyramidSeriesLabelBase::IsInside
BOOL IsInside() const
Call this function to check whether the label is inside the pyramid.
CXTPChartPyramidSeriesLabelBase::~CXTPChartPyramidSeriesLabelBase
virtual ~CXTPChartPyramidSeriesLabelBase()
Destroys a CXTPChartPyramidSeriesLabelBase object, handles cleanup.
CXTPChartPyramidSeriesLabelBase::m_nPosition
XTPChartPyramidLabelPosition m_nPosition
The pyramid label position.
Definition XTPChartPyramidSeriesLabelBase.h:138
CXTPChartPyramidSeriesLabelBase::GetPosition
XTPChartPyramidLabelPosition GetPosition() const
Call this function to get the label position.
Definition XTPChartPyramidSeriesLabelBase.h:150
CXTPChartPyramidSeriesLabelBase::CreateView
virtual CXTPChartElementView * CreateView(CXTPChartDeviceContext *pDC, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView)=0
This function creates the view of the pyramid series.
CXTPChartPyramidSeriesLabelBase::CXTPChartPyramidSeriesLabelBase
CXTPChartPyramidSeriesLabelBase()
Constructs a CXTPChartPyramidSeriesLabelBase object.
CXTPChartPyramidSeriesLabelViewBase
This class abstracts the view of a pyramid series label.
Definition XTPChartPyramidSeriesLabelBase.h:166
CXTPChartPyramidSeriesLabelViewBase::CreateDeviceCommand
virtual CXTPChartDeviceCommand * CreateDeviceCommand(CXTPChartDeviceContext *pDC)=0
Creates view drawing device command for the device context specified.
CXTPChartPyramidSeriesLabelViewBase::CXTPChartPyramidSeriesLabelViewBase
CXTPChartPyramidSeriesLabelViewBase(CXTPChartSeriesLabel *pLabel, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView)
Constructs a CXTPChartPyramidSeriesLabelViewBase object.
CXTPChartPyramidSeriesLabelViewBase::GetPosition
XTPChartPyramidLabelPosition GetPosition() const
Obtains label position.
CXTPChartPyramidSeriesStyleBase
This class abstracts the basic style of a pyramid series.
Definition XTPChartPyramidSeriesStyleBase.h:45
CXTPChartSeriesLabel
This class abstracts the label of a series.
Definition XTPChartSeriesLabel.h:49
CXTPChartSeriesPointView
Represents chart series point view.
Definition XTPChartSeriesPointView.h:48
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72


Toolkit Pro: XTPSliderThemeVisualStudio2015.h Source File

  • Source
  • CommandBars
  • Slider
XTPSliderThemeVisualStudio2015.h
Go to the documentation of this file.
1
23#if !defined(__XTPSLIDERTHEMEVISUALSTUDIO2015_H__)
24# define __XTPSLIDERTHEMEVISUALSTUDIO2015_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class _XTP_EXT_CLASS CXTPSliderThemeVisualStudio2015 : public CXTPSliderThemeOffice2013
34{
35public:
36 CXTPSliderThemeVisualStudio2015(CXTPPaintManager* pPaintManager);
37};
38
40# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
41#endif // !defined(__XTPSLIDERTHEMEVISUALSTUDIO2015_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPPaintManager
Paint manager of the command bars.
Definition XTPPaintManager.h:199


Toolkit Pro: XTPChart2dPyramidSeriesView.h Source File

  • Source
  • Chart
  • Styles
  • Pyramid
  • 2D
XTPChart2dPyramidSeriesView.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHART2DPYRAMIDSERIESVIEW_H__)
24# define __XTPCHART2DPYRAMIDSERIESVIEW_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartDeviceCommand;
34class CXTPChartSeriesPointView;
35class CXTPChartElementView;
36class CXTPChartSeriesPoint;
37class CXTPChartDeviceContext;
38class CXTPChartSeries;
39class CXTPChartDiagramView;
40
52class _XTP_EXT_CLASS CXTPChartPyramidSeriesView : public CXTPChartPyramidSeriesViewBase
53{
54 DECLARE_DYNAMIC(CXTPChartPyramidSeriesView);
55
56public:
64 CXTPChartPyramidSeriesView(CXTPChartSeries* pSeries, CXTPChartDiagramView* pDiagramView);
65
73 virtual void CalculatePointLayout(CXTPChartDeviceContext* pDC, CRect rcBounds);
74
75protected:
83 virtual CXTPChartRectF GetInnerBounds() const;
84
96 virtual CXTPChartSeriesPointView* CreateSeriesPointView(CXTPChartDeviceContext* pDC,
97 CXTPChartSeriesPoint* pPoint,
98 CXTPChartElementView* pParentView);
99
112 virtual CXTPChartDeviceCommand* CreateDeviceCommand(CXTPChartDeviceContext* pDC);
113
124 virtual CXTPChartDeviceCommand* CreateLegendDeviceCommand(CXTPChartDeviceContext* pDC,
125 CRect rcBounds);
126
127public:
141 virtual CXTPChartDeviceCommand* CreateLegendDeviceCommand(CXTPChartDeviceContext* pDC,
142 CRect rcBounds, CXTPChartColor color1,
143 CXTPChartColor color2,
144 CXTPChartColor clrBorder);
145
146private:
147 CXTPChartRectF m_rcInnerBounds;
148};
150# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
151#endif //#if !defined(__XTPCHART2DPYRAMIDSERIESVIEW_H__)
pPoint
const CPoint * pPoint
return 0 or xtpCalendarHitTestDayExpandButton
Definition XTPCalendarThemeOffice2007.h:150
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartColor
This class abstracts a color entity.
Definition XTPChartTypes.h:51
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartDiagramView
This class represents the view of a chart diagram, which is a kind of CXTPChartElementView.
Definition XTPChartDiagramView.h:49
CXTPChartElementView
This class represents the view of a chart element.
Definition XTPChartElementView.h:47
CXTPChartPyramidSeriesViewBase
This class abstracts the view of a pyramid series.
Definition XTPChartPyramidSeriesViewBase.h:47
CXTPChartPyramidSeriesView
This class abstracts the view of a pyramid series.
Definition XTPChart2dPyramidSeriesView.h:53
CXTPChartPyramidSeriesView::GetInnerBounds
virtual CXTPChartRectF GetInnerBounds() const
Call this function to get the inner bounds of the diagram.
CXTPChartPyramidSeriesView::CalculatePointLayout
virtual void CalculatePointLayout(CXTPChartDeviceContext *pDC, CRect rcBounds)
Call this function to calculate the pyramid series point layout.
CXTPChartPyramidSeriesView::CreateLegendDeviceCommand
virtual CXTPChartDeviceCommand * CreateLegendDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcBounds, CXTPChartColor color1, CXTPChartColor color2, CXTPChartColor clrBorder)
This function creates a label view drawing command object.
CXTPChartPyramidSeriesView::CreateDeviceCommand
virtual CXTPChartDeviceCommand * CreateDeviceCommand(CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
CXTPChartPyramidSeriesView::CreateLegendDeviceCommand
virtual CXTPChartDeviceCommand * CreateLegendDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcBounds)
This function creates a label view drawing command object.
CXTPChartPyramidSeriesView::CreateSeriesPointView
virtual CXTPChartSeriesPointView * CreateSeriesPointView(CXTPChartDeviceContext *pDC, CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Use this function to create the pyramid series point view object.
CXTPChartPyramidSeriesView::CXTPChartPyramidSeriesView
CXTPChartPyramidSeriesView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Constructs a CXTPChartPyramidSeriesView object.
CXTPChartSeries
This class represents a series in the chart, which is a kind of CXTPChartElement.
Definition XTPChartSeries.h:50
CXTPChartSeriesPoint
CXTPChartSeriesPoint is a kind of CXTPChartElement.
Definition XTPChartSeriesPoint.h:43
CXTPChartSeriesPointView
Represents chart series point view.
Definition XTPChartSeriesPointView.h:48
CXTPRectT< float >


Toolkit Pro: Member List

CXTPTrackThemeDefault Member List

This is the complete list of members for CXTPTrackThemeDefault, including all inherited members.

CalcColumnHeight(CDC *pDC, CXTPGridColumn *pColumn, int nTotalWidth=0) | CXTPGridPaintManager | protectedvirtual
CalculateRowHeight(CDC *pDC, const CString &strText, int nMaxWidth, BOOL bWordBreak=TRUE) | CXTPGridPaintManager | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPGridPaintManager() | CXTPGridPaintManager |
CXTPTrackPaintManager() | CXTPTrackPaintManager |
CXTPTrackThemeDefault() | CXTPTrackThemeDefault |
DrawBitmap(CDC *pDC, CXTPGridControl *pControl, CRect rcColumn, int iImage) | CXTPGridPaintManager | virtual
DrawCollapsedBitmap(CDC *pDC, const CXTPGridRow *pRow, CRect &rcBitmap) | CXTPGridPaintManager | virtual
DrawColumn(CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn, BOOL bDrawExternal=FALSE, int nShadowWidth=0) | CXTPGridPaintManager | virtual
DrawColumnBackground(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, BOOL &bColumnPressed, BOOL &bDraggingFromHeader, CXTPGridHeader *pHeader=NULL) | CXTPTrackThemeDefault | virtual
DrawColumnFooter(CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn) | CXTPGridPaintManager | virtual
DrawColumnFooterDivider(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn) | CXTPGridPaintManager | virtual
DrawColumnIcon(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, CRect rcIcon, int iIcon) | CXTPGridPaintManager | virtual
DrawColumnText(CDC *pDC, CRect rcText, CString strCaption, int nHeaderAlignment, BOOL bIsHeader, BOOL bColumnPressed) | CXTPGridPaintManager | virtual
DrawConnector(CDC *pDC, CPoint ptFrom, CPoint ptTo) | CXTPGridPaintManager |
DrawFocusedRow(CDC *pDC, CRect rcRow) | CXTPGridPaintManager | virtual
DrawFreezeColsDivider(CDC *pDC, const CRect &rc, CXTPGridControl *pControl, CXTPGridRow *pRow=NULL) | CXTPGridPaintManager | virtual
DrawGlyph(CDC *pDC, CRect rcColumn, int iImage) | CXTPGridPaintManager | virtual
DrawGrid(CDC *pDC, XTPGridOrientation orientation, CRect rcGrid) | CXTPGridPaintManager | virtual
DrawGridPattern(CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush) | CXTPGridPaintManager | protectedvirtual
DrawGridPattern(CDC *pDC, CXTPBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush) | CXTPGridPaintManager | protectedvirtual
DrawGridPattern(CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr) | CXTPGridPaintManager | protectedvirtual
DrawGroupRow(CDC *pDC, CXTPGridGroupRow *pRow, CRect rcRow, XTP_GRIDRECORDITEM_METRICS *pMetrics) | CXTPGridPaintManager | virtual
DrawHorizontalLine(CDC *pDC, int xPos, int yPos, int cx, COLORREF clr) | CXTPGridPaintManager |
DrawInplaceButton(CDC *pDC, CXTPGridInplaceButton *pButton) | CXTPGridPaintManager | virtual
DrawInplaceButtonFrame(CDC *pDC, CXTPGridInplaceButton *pButton) | CXTPGridPaintManager | protectedvirtual
DrawInplaceButtonIcon(CDC *pDC, CXTPGridInplaceButton *pButton) | CXTPGridPaintManager | protectedvirtual
DrawInplaceComboButton(CDC *pDC, CRect *pRc) | CXTPGridPaintManager | virtual
DrawInplaceExpandButton(CDC *pDC, CRect *pRc) | CXTPGridPaintManager | virtual
DrawInplaceSpinButton(CDC *pDC, CRect *pRc) | CXTPGridPaintManager | virtual
DrawItemBitmap(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CRect &rcItem, int nImage) | CXTPGridPaintManager | virtual
DrawItemCaption(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics) | CXTPGridPaintManager | virtual
DrawItemControl(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CXTPGridRecordItemControl *pControl, CRect &rcItem) | CXTPGridPaintManager | virtual
DrawLink(int *pnCurrDrawPos, XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CXTPGridHyperlink *pHyperlink, CString strText, CRect rcLink, int nFlag, BOOL bTrim=FALSE) | CXTPGridPaintManager | protectedvirtual
DrawMarkers(CDC *pDC) | CXTPTrackPaintManager | virtual
DrawMultiLineText(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, BOOL bWordBreak=TRUE) | CXTPGridPaintManager | protectedvirtual
DrawNoGroupByText(CDC *pDC, CRect rcItem) | CXTPGridPaintManager | virtual
DrawRowNumber(CDC *pDC, CRect rcNumber, CXTPGridRow *pRow) | CXTPGridPaintManager | virtual
DrawSectionDivider(CDC *pDC, const CRect &rc, XTPGridSectionDividerPosition dividerPosition, XTPGridSectionDividerStyle dividerStyle, CXTPPaintManagerColor dividerColor) | CXTPGridPaintManager |
DrawShellIcon(CDC *pDC, CRect rcColumn, int iImage) | CXTPGridPaintManager | virtual
DrawSingleLineText(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nStartPos, int nEndPos, int nActualWidth) | CXTPGridPaintManager | protectedvirtual
DrawString(int *pnCurrDrawPos, CDC *pDC, const CString &strDraw, CRect rcDraw, UINT nFormat) | CXTPGridPaintManager | protectedvirtual
DrawTextLine(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nFlag, int &nCharCounter, int &nHyperlinkCounter) | CXTPGridPaintManager | protectedvirtual
DrawTimeLine(CDC *pDC) | CXTPTrackPaintManager | virtual
DrawTrackHeader(CDC *pDC) | CXTPTrackPaintManager | virtual
DrawTreeStructure(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CRect rcItem, CSize sizeGlyph) | CXTPGridPaintManager | virtual
DrawTriangle(CDC *pDC, CRect rcTriangle, BOOL bToDown, BOOL bDraggingFromHeader, int nShadowWidth, BOOL bColumnPressed) | CXTPGridPaintManager | virtual
DrawVerticalLine(CDC *pDC, int xPos, int yPos, int cy, COLORREF clr) | CXTPGridPaintManager |
DrawVerticalTimeLineMarker(CDC *pDC, int xPos, CXTPGridControl *pControl, COLORREF color=RGB(0, 255, 0)) | CXTPGridPaintManager | virtual
EnablePreviewMode(BOOL bIsPreviewMode) | CXTPGridPaintManager |
FillFooter(CDC *pDC, CRect rcFooter) | CXTPGridPaintManager | virtual
FillGroupByControl(CDC *pDC, CRect &rcGroupBy) | CXTPGridPaintManager | virtual
FillGroupRowMetrics(CXTPGridGroupRow *pRow, XTP_GRIDRECORDITEM_METRICS *pMetrics, BOOL bPrinting) | CXTPGridPaintManager | virtual
FillHeaderControl(CDC *pDC, CRect rcHeader) | CXTPGridPaintManager | virtual
FillIndent(CDC *pDC, CRect rcRow) | CXTPGridPaintManager | virtual
FillItemShade(CDC *pDC, CRect rcItem) | CXTPGridPaintManager | virtual
FillRow(CDC *pDC, CXTPGridRow *pRow, CRect rcRow) | CXTPGridPaintManager | virtual
FindRowAdjacentToMerged(const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, BOOL bUpward) | CXTPGridPaintManager |
FindRowAdjacentToMergedEx(const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, int &nAdjRowIndex, BOOL bUpward) | CXTPGridPaintManager |
FormatTime(int nPosition) | CXTPTrackPaintManager | virtual
FormatTimeLineTick(int nPosition, COLORREF &clrTick, int &nTickLength) | CXTPTrackPaintManager | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetColumnOffice2007CustomThemeBaseColor() const | CXTPGridPaintManager |
GetColumnStyle() const | CXTPGridPaintManager |
GetControlBackColor(CXTPGridControl *pControl) | CXTPGridPaintManager | virtual
GetFooterHeight(CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0) | CXTPGridPaintManager | virtual
GetFreezeColsDividerStyle() const | CXTPGridPaintManager |
GetGlyphs() const | CXTPGridPaintManager |
GetHeaderHeight() | CXTPGridPaintManager | virtual
GetHeaderHeight(CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0) | CXTPGridPaintManager | virtual
GetItemHeight(XTP_GRIDRECORDITEM_DRAWARGS &drawArgs, int nWidth) | CXTPGridPaintManager |
GetMaxPreviewLines() | CXTPGridPaintManager |
GetPreviewItemHeight(CDC *pDC, CXTPGridRow *pRow, int nWidth, int nHeight) | CXTPGridPaintManager | virtual
GetPreviewLinesCount(CDC *pDC, CRect &rcText, const CString &strText) | CXTPGridPaintManager |
GetRowHeight(CDC *pDC, CXTPGridRow *pRow) | CXTPGridPaintManager | virtual
GetRowHeight(CDC *pDC, CXTPGridRow *pRow, int nTotalWidth) | CXTPGridPaintManager | virtual
GetRowHeightEx(CDC *pDC, CXTPGridRow *pRow, int nTotalWidth, const BOOL firstLevel=TRUE) | CXTPGridPaintManager |
GetSectionDividerHeight(XTPGridFixedRowsDividerStyle dividerStyle) | CXTPGridPaintManager |
GetTextFont() | CXTPGridPaintManager |
IsColumHotTrackingEnabled() const | CXTPGridPaintManager | virtual
IsColumnPlusMinusSign() const | CXTPGridPaintManager |
IsColumnWidthWYSIWYG() const | CXTPGridPaintManager |
IsDrawGridForEmptySpace() const | CXTPGridPaintManager |
IsFixedInplaceButtonHeight() const | CXTPGridPaintManager |
IsFixedRowHeight() const | CXTPGridPaintManager |
IsGridVisible(BOOL bVertical) const | CXTPGridPaintManager |
IsGridVisible(XTPGridOrientation orientation) const | CXTPGridPaintManager |
IsLastColumnWidthWYSIWYG() const | CXTPGridPaintManager |
IsPreviewMode() const | CXTPGridPaintManager |
IsPrintGroupRowIcon() const | CXTPGridPaintManager |
IsShowWYSIWYGMarkers() const | CXTPGridPaintManager |
IsUseDropMarker() const | CXTPGridPaintManager |
LoadGlyphs() | CXTPGridPaintManager | virtual
m_arStartCol | CXTPGridPaintManager |
m_bAllowMergeCells | CXTPGridPaintManager |
m_bBaseTreeIndent | CXTPGridPaintManager |
m_bCleanTooltip | CXTPGridPaintManager |
m_bColumnPlusMinusSign | CXTPGridPaintManager | protected
m_bColumnWidthWYSIWYG | CXTPGridPaintManager | protected
m_bCompactText | CXTPGridPaintManager |
m_bDrawGridForEmptySpace | CXTPGridPaintManager | protected
m_bFixedInplaceButtonHeight | CXTPGridPaintManager | protected
m_bFixedRowHeight | CXTPGridPaintManager | protected
m_bForceDynamicMarkupForCell | CXTPGridPaintManager |
m_bForceShowDropMarker | CXTPGridPaintManager |
m_bForceShowTooltip | CXTPGridPaintManager |
m_bGrayIfDisable | CXTPGridPaintManager |
m_bGroupRowTextBold | CXTPGridPaintManager |
m_bHideSelection | CXTPGridPaintManager |
m_bHotTracking | CXTPGridPaintManager |
m_bInvertColumnOnClick | CXTPGridPaintManager |
m_bIsPreviewMode | CXTPGridPaintManager | protected
m_bLastColumnWidthWYSIWYG | CXTPGridPaintManager | protected
m_bMakeUpper | CXTPGridPaintManager |
m_bMoveScrollbarOnFixedColumnsIndent | CXTPGridPaintManager |
m_bPrintGroupRowIcon | CXTPGridPaintManager | protected
m_bPrintPageRectangle | CXTPGridPaintManager |
m_bPrintSortTriangle | CXTPGridPaintManager |
m_bPrintVirtualPageNumber | CXTPGridPaintManager |
m_bPrintWatermark | CXTPGridPaintManager |
m_bRecOrRowNum | CXTPGridPaintManager |
m_bRevertAlignment | CXTPGridPaintManager |
m_bShadeGroupHeadings | CXTPGridPaintManager |
m_bShadeSortColumn | CXTPGridPaintManager |
m_bShowLockIcon | CXTPGridPaintManager |
m_bShowNonActiveInPlaceButton | CXTPGridPaintManager |
m_bShowWYSIWYGMarkers | CXTPGridPaintManager | protected
m_bSortTriangleOffsetFromRight | CXTPGridPaintManager |
m_bThemedInplaceButtons | CXTPGridPaintManager |
m_bUseAlternativeBackground | CXTPGridPaintManager |
m_bUseDropMarker | CXTPGridPaintManager |
m_bUseEditTextAlignment | CXTPGridPaintManager |
m_bUseGroupRowSelectionState | CXTPGridPaintManager |
m_bUseShellIcon | CXTPGridPaintManager |
m_clrAlternativeBackground | CXTPGridPaintManager |
m_clrBoldText | CXTPGridPaintManager |
m_clrBoldTextHighlight | CXTPGridPaintManager |
m_clrBtnFace | CXTPGridPaintManager |
m_clrBtnFacePressed | CXTPGridPaintManager |
m_clrBtnText | CXTPGridPaintManager |
m_clrCaptionText | CXTPGridPaintManager |
m_clrCaptionTextPressed | CXTPGridPaintManager |
m_clrColumnOffice2007CustomTheme | CXTPGridPaintManager |
m_clrConnector | CXTPGridPaintManager |
m_clrControlBack | CXTPGridPaintManager |
m_clrControlDark | CXTPGridPaintManager |
m_clrControlLightLight | CXTPGridPaintManager |
m_clrDisableBitmapDarkest | CXTPGridPaintManager |
m_clrDisableBitmapLightest | CXTPGridPaintManager |
m_clrFormulaSubSum | CXTPGridPaintManager |
m_clrFormulaSum | CXTPGridPaintManager |
m_clrFreezeColsDivider | CXTPGridPaintManager |
m_clrGradientColumnSeparator | CXTPGridPaintManager |
m_clrGradientColumnShadow | CXTPGridPaintManager |
m_clrGroupBoxBack | CXTPGridPaintManager |
m_clrGroupRowText | CXTPGridPaintManager |
m_clrGroupShadeBack | CXTPGridPaintManager |
m_clrGroupShadeBorder | CXTPGridPaintManager |
m_clrGroupShadeText | CXTPGridPaintManager |
m_clrHeaderControl | CXTPGridPaintManager |
m_clrHighlight | CXTPGridPaintManager |
m_clrHighlightText | CXTPGridPaintManager |
m_clrHotDivider | CXTPGridPaintManager |
m_clrIndentControl | CXTPGridPaintManager |
m_clrItemShade | CXTPGridPaintManager |
m_clrMarker | CXTPTrackPaintManager |
m_clrMarkerBack | CXTPTrackPaintManager |
m_clrMarkerBorder | CXTPTrackPaintManager |
m_clrPreviewText | CXTPGridPaintManager |
m_clrScrollBarBorderDark | CXTPTrackPaintManager |
m_clrScrollBarBorderLight | CXTPTrackPaintManager |
m_clrScrollBarDark | CXTPTrackPaintManager |
m_clrScrollBarLight | CXTPTrackPaintManager |
m_clrSelectedArea | CXTPTrackPaintManager |
m_clrSelectedRow | CXTPGridPaintManager |
m_clrSelectedRowText | CXTPGridPaintManager |
m_clrTimeHeaderBorder | CXTPTrackPaintManager |
m_clrTimeHeaderDark | CXTPTrackPaintManager |
m_clrTimeHeaderDarkDark | CXTPTrackPaintManager |
m_clrTimeHeaderDivider | CXTPTrackPaintManager |
m_clrTimeLinePosition | CXTPTrackPaintManager |
m_clrTimeLineTick | CXTPTrackPaintManager |
m_clrTimeSliderBackground | CXTPTrackPaintManager |
m_clrTrackHeader | CXTPTrackPaintManager |
m_clrTrackMarkerBorder | CXTPTrackPaintManager |
m_clrTrackMarkerText | CXTPTrackPaintManager |
m_clrTrackMarkerTextBack | CXTPTrackPaintManager |
m_clrTrackMarkerTextBorder | CXTPTrackPaintManager |
m_clrTrackTimeArea | CXTPTrackPaintManager |
m_clrWindowText | CXTPGridPaintManager |
m_clrWorkArea | CXTPTrackPaintManager |
m_clrWorkAreaScrollBarBorder | CXTPTrackPaintManager |
m_clrWorkAreaScrollBarDark | CXTPTrackPaintManager |
m_clrWorkAreaScrollBarLight | CXTPTrackPaintManager |
m_columnStyle | CXTPGridPaintManager | protected
m_crlNoGroupByText | CXTPGridPaintManager |
m_grcGradientColumn | CXTPGridPaintManager |
m_grcGradientColumnHot | CXTPGridPaintManager |
m_grcGradientColumnPushed | CXTPGridPaintManager |
m_iRecOrRowStart | CXTPGridPaintManager |
m_nBaseParentRecordIndent | CXTPGridPaintManager |
m_nFixedColumnsIndent | CXTPGridPaintManager |
m_nFooterHeight | CXTPGridPaintManager | protected
m_nFreezeColsDividerStyle | CXTPGridPaintManager | protected
m_nGridLineStylePreviousH | CXTPGridPaintManager | protected
m_nGridLineStylePreviousV | CXTPGridPaintManager | protected
m_nGroupGridLineHeight | CXTPGridPaintManager | protected
m_nGroupGridLineStyle | CXTPGridPaintManager | protected
m_nHeaderHeight | CXTPGridPaintManager | protected
m_nMaxPreviewLines | CXTPGridPaintManager | protected
m_nResizingWidth | CXTPGridPaintManager | protected
m_nRowHeight | CXTPGridPaintManager | protected
m_nRowHeightDefault | CXTPGridPaintManager |
m_nTextIndentForGroupRowsWithNoIcon | CXTPGridPaintManager |
m_nTreeColumnLineLength | CXTPGridPaintManager |
m_nTreeIndent | CXTPGridPaintManager |
m_nTreeStructureStyle | CXTPGridPaintManager |
m_nTreeTextIndent | CXTPGridPaintManager |
m_nTreeTextIndentGroupRow | CXTPGridPaintManager |
m_nTreeTextIndentRowChildren | CXTPGridPaintManager |
m_nTreeTextIndentRowParent | CXTPGridPaintManager |
m_pControl | CXTPGridPaintManager | protected
m_pGlyphs | CXTPGridPaintManager | protected
m_pHyperlinkHoverStyle | CXTPGridPaintManager |
m_pHyperlinkStyle | CXTPGridPaintManager |
m_pMarkupUIElement_NoGroupBy | CXTPGridPaintManager | protected
m_PrintPageWidth | CXTPGridPaintManager |
m_rcPreviewIndent | CXTPGridPaintManager |
m_RecordNumberWidth | CXTPGridPaintManager |
m_strCollapse | CXTPGridPaintManager |
m_strDecreasing | CXTPGridPaintManager |
m_strExpand | CXTPGridPaintManager |
m_strIncreasing | CXTPGridPaintManager |
m_strMarkupUIElement_NoGroupBy | CXTPGridPaintManager | protected
m_strNoFieldsAvailable | CXTPGridPaintManager |
m_strNoGroupBy | CXTPGridPaintManager |
m_strNoItems | CXTPGridPaintManager |
m_strSortBy | CXTPGridPaintManager |
m_szGlyph | CXTPGridPaintManager | protected
m_themeButton | CXTPGridPaintManager | protected
m_themeCombo | CXTPGridPaintManager | protected
m_themeHeader | CXTPGridPaintManager | protected
m_themeSpin | CXTPGridPaintManager | protected
m_treeStructureStyle | CXTPGridPaintManager |
m_xtpBrushGroupGridLineStyle | CXTPGridPaintManager | protected
m_xtpBrushHorizontalGrid | CXTPGridPaintManager | protected
m_xtpBrushTreeStructure | CXTPGridPaintManager | protected
m_xtpBrushVeriticalGrid | CXTPGridPaintManager | protected
m_xtpFontBoldText | CXTPGridPaintManager |
m_xtpFontCaption | CXTPGridPaintManager |
m_xtpFontPreview | CXTPGridPaintManager |
m_xtpFontText | CXTPGridPaintManager |
OnDrawAction(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs) | CXTPGridPaintManager | virtual
RecalcTotalHightOfMergedRows(CXTPGridColumns *pColumns, CDC *pDC, CXTPGridRow *pRow, int nRowHeight, int nTotalWidth) | CXTPGridPaintManager |
RefreshMetrics() | CXTPTrackPaintManager | virtual
SetCaptionFont(LOGFONT &lf) | CXTPGridPaintManager |
SetColumnOffice2007CustomThemeBaseColor(COLORREF clrBaseColor) | CXTPGridPaintManager |
SetColumnPlusMinusSign(BOOL bDraw) | CXTPGridPaintManager |
SetColumnWidthWYSIWYG(BOOL bColumnWidthWYSIWYG) | CXTPGridPaintManager |
SetDrawGridForEmptySpace(BOOL bDrawGrid) | CXTPGridPaintManager |
SetFixedRowHeight(BOOL bFixedRowHeight) | CXTPGridPaintManager |
SetFreezeColsDividerStyle(int nStyle) | CXTPGridPaintManager |
SetGridControl(CXTPGridControl *pControl) | CXTPGridPaintManager | virtual
SetHeaderHeight(int nHeight) | CXTPGridPaintManager | virtual
SetInplaceButtonHeight(BOOL bFixedInplaceButtonHeight) | CXTPGridPaintManager |
SetLastColumnWidthWYSIWYG(BOOL bColumnWidthWYSIWYG) | CXTPGridPaintManager |
SetMaxPreviewLines(int nMaxLines) | CXTPGridPaintManager |
SetPreviewIndent(int nLeft, int nTop, int nRight, int nBottom) | CXTPGridPaintManager |
SetPrintGroupRowIcon(BOOL bDraw) | CXTPGridPaintManager |
SetTextFont(LOGFONT &lf) | CXTPGridPaintManager |
ShowWYSIWYGMarkers(BOOL bSet) | CXTPGridPaintManager |
~CXTPGridPaintManager() | CXTPGridPaintManager | virtual
~CXTPTrackPaintManager() | CXTPTrackPaintManager |


Toolkit Pro: XTPDrawHelpers.h Source File

  • Source
  • Common
XTPDrawHelpers.h
Go to the documentation of this file.
1
23#if !defined(__XTPDRAWHELPERS_H__)
24# define __XTPDRAWHELPERS_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPPaintManagerColorGradient;
34class CXTPSvgImage;
35
36# ifndef DT_HIDEPREFIX
37# define DT_HIDEPREFIX 0x00100000
38# endif
39
40# ifndef LAYOUT_BITMAPORIENTATIONPRESERVED
41# define LAYOUT_BITMAPORIENTATIONPRESERVED 0x00000008
42# endif
43
44# ifndef LAYOUT_RTL
45# define LAYOUT_RTL 0x00000001
46# endif
47
54class _XTP_EXT_CLASS CXTPTransparentBitmap
55{
56public:
63 CXTPTransparentBitmap(HBITMAP hBitmap);
64
72 COLORREF GetTransparentColor() const;
73
82 HICON ConvertToIcon() const;
83
84protected:
85 HBITMAP m_hBitmap;
86};
87
93class _XTP_EXT_CLASS CXTPClientCursorPos : public CPoint
94{
95public:
103 CXTPClientCursorPos(CWnd* pWnd);
104};
105
111class _XTP_EXT_CLASS CXTPEmptyRect : public CRect
112{
113public:
119 CXTPEmptyRect();
120};
121
127class _XTP_EXT_CLASS CXTPEmptySize : public CSize
128{
129public:
135 CXTPEmptySize();
136
141 void SetSizeEmpty();
142
149 const SIZE& operator=(const SIZE& srcSize);
150};
151
157class _XTP_EXT_CLASS CXTPWindowRect : public CRect
158{
159public:
166 CXTPWindowRect(HWND hWnd);
167
174 CXTPWindowRect(const CWnd* pWnd);
175};
176
182class _XTP_EXT_CLASS CXTPClientRect : public CRect
183{
184public:
191 CXTPClientRect(HWND hWnd);
192
199 CXTPClientRect(const CWnd* pWnd);
200};
201
209class _XTP_EXT_CLASS CXTPBufferDC : public CDC
210{
212 DECLARE_DYNAMIC(CXTPBufferDC)
213public:
222 CXTPBufferDC(HDC hDestDC, const CRect& rcPaint);
223
236 CXTPBufferDC(HDC hDestDC, const CRect& rcPaint, const CXTPPaintManagerColorGradient& clrBack,
237 const BOOL bHorz = FALSE);
238
245 CXTPBufferDC(CPaintDC& paintDC);
246
252 virtual ~CXTPBufferDC();
253
259 void Discard();
260
267 CDC* GetDestDC() const;
268
275 HDC GetDestHDC() const;
276
282 void TakeSnapshot();
283
284protected:
285 HDC m_hDestDC;
286 HBITMAP m_hBitmap;
287 CRect m_rect;
288 HGDIOBJ m_hOldBitmap;
289};
290
298class _XTP_EXT_CLASS CXTPBufferDCEx : public CDC
299{
300 DECLARE_DYNAMIC(CXTPBufferDCEx);
301
302public:
311 CXTPBufferDCEx(HDC hDestDC, const CRect rcPaint);
312
318 virtual ~CXTPBufferDCEx();
319
326 CDC* GetDestDC() const;
327
334 HDC GetDestHDC() const;
335
336protected:
337 HDC m_hDestDC;
338 HBITMAP m_hBitmap;
339 CRect m_rect;
340 HGDIOBJ m_hOldBitmap;
341};
342
350class _XTP_EXT_CLASS CXTPBitmapDC : public CDC
351{
352public:
357 CXTPBitmapDC();
358
367 CXTPBitmapDC(CDC* pDC, CBitmap* pBitmap);
368
376 CXTPBitmapDC(CDC* pDC, HBITMAP hBitmap);
377
383 virtual ~CXTPBitmapDC();
384
392 void SetBitmap(HBITMAP hBitmap);
393
399 void SelectOld();
400
401protected:
402 HBITMAP m_hOldBitmap;
403 HBITMAP m_hCurrentBitmap;
404};
405
413class _XTP_EXT_CLASS CXTPFontDC
414{
415public:
424 CXTPFontDC(CDC* pDC, CFont* pFont = NULL);
425
435 CXTPFontDC(CDC* pDC, CFont* pFont, COLORREF clrTextColor);
436
442 virtual ~CXTPFontDC();
443
451 void SetFont(CFont* pFont);
452
459 void SetColor(COLORREF clrTextColor);
460
469 void SetFontColor(CFont* pFont, COLORREF clrTextColor);
470
478 void ReleaseFont();
479
487 void ReleaseColor();
488
494 void DisableHandleLeakDetection();
495
496protected:
497 CDC* m_pDC;
498 CFont* m_pOldFont;
499 CFont* m_pCurrentFont;
500 COLORREF m_clrOldTextColor;
501};
502
511class _XTP_EXT_CLASS CXTPPenDC
512{
513public:
525 CXTPPenDC(CDC* pDC, CPen* pPen);
526
538 CXTPPenDC(HDC hDC, COLORREF crColor);
539
552 CXTPPenDC(HDC hDC, int nStyle, COLORREF crColor);
553
567 CXTPPenDC(HDC hDC, int nStyle, int nWidth, COLORREF crColor);
568
574 virtual ~CXTPPenDC();
575
589 void Create(HDC hDC, int nStyle, int nWidth, COLORREF crColor);
590
600 COLORREF Color();
601
608 void Color(COLORREF crColor);
609
610private:
611 void ReleasePen();
612
613protected:
614 CPen m_pen;
615 HDC m_hDC;
616 HPEN m_hOldPen;
617 HPEN m_hCurrentPen;
618 int m_nStyle;
619 int m_nWidth;
620 COLORREF m_crColor;
621};
622
631class _XTP_EXT_CLASS CXTPBrushDC
632{
633public:
642 CXTPBrushDC(HDC hDC, COLORREF crColor);
643
649 virtual ~CXTPBrushDC();
650
657 void Color(COLORREF crColor);
658
659private:
660 void ReleaseBrush();
661
662protected:
663 CBrush m_brush;
664 HDC m_hDC;
665 HBRUSH m_hOldBrush;
666};
667
669# ifndef COLORREF_NULL
670# define COLORREF_NULL (COLORREF) - 1
671# endif
682class _XTP_EXT_CLASS CXTPDCSaveState
683{
684public:
691 CXTPDCSaveState(CDC* pDC);
692
698 virtual ~CXTPDCSaveState();
699
700private:
701 CDC* m_pDC;
702 int m_nState;
703};
704
712class _XTP_EXT_CLASS CXTPCompatibleDC : public CDC
713{
714public:
724 CXTPCompatibleDC(CDC* pDC, CBitmap* pBitmap);
725
735 CXTPCompatibleDC(CDC* pDC, HBITMAP hBitmap);
736
742 virtual ~CXTPCompatibleDC();
743
744protected:
745 HBITMAP m_hBitmap;
746 HBITMAP m_hOldBitmap;
747};
748
754class _XTP_EXT_CLASS CXTPSplitterTracker
755{
756public:
763 CXTPSplitterTracker(BOOL bSolid = FALSE, BOOL bDesktopDC = TRUE);
764
765public:
777 BOOL Track(CWnd* pTrackWnd, CRect rcAvail, CRect& rectTracker, CPoint point, BOOL bHoriz);
778
785 void SetBoundRect(CRect rcBoundRect);
786
787private:
795 void OnInvertTracker(CRect rc);
796
797private:
798 CDC* m_pDC;
799 BOOL m_bSolid;
800 CRect m_rcBoundRect;
801 CWnd* m_pWnd;
802 BOOL m_bDesktopDC;
803 CWnd* m_pSplitterWnd;
804 PVOID m_pfnSetLayeredWindowAttributes;
805};
806
813class _XTP_EXT_CLASS CXTPMouseMonitor
814{
815public:
823 static void AFX_CDECL SetupHook(CWnd* pWndMonitor);
824
830 static BOOL AFX_CDECL IsMouseHooked();
831
832protected:
860 static LRESULT CALLBACK MouseProc(int nCode, WPARAM wParam, LPARAM lParam);
861
862private:
863 static HHOOK m_hHookMouse;
864 static CWnd* m_pWndMonitor;
865};
866
943_XTP_EXT_CLASS BOOL AFX_CDECL XTPTrackMouseEvent(HWND hWndTrack, DWORD dwFlags = TME_LEAVE,
944 DWORD dwHoverTime = HOVER_DEFAULT);
945
952class _XTP_EXT_CLASS CXTPDrawHelpers
953{
954 friend class CXTPSingleton<CXTPDrawHelpers>;
955
956public:
958 /* Function pointer used to access the Windows API GradientFill function. */
959 typedef BOOL(__stdcall* PFNGRADIENTFILL)(HDC, PTRIVERTEX, ULONG, PVOID, ULONG, ULONG);
960
961 /* AlphaBlend function declaration */
962 typedef BOOL(__stdcall* PFNALPHABLEND)(HDC, int, int, int, int, HDC, int, int, int, int,
963 BLENDFUNCTION);
964
965 typedef BOOL(WINAPI* PFNTRANSPARENTBLT)(HDC, int, int, int, int, HDC, int, int, int, int, UINT);
968public:
973 CXTPDrawHelpers();
974
979 virtual ~CXTPDrawHelpers();
980
981public:
982 void SolidRectangle(CDC* pDC, CRect rc, COLORREF clrRect, COLORREF clrFill);
983
997 void GradientFill(CDC* pDC, LPCRECT lpRect, COLORREF crFrom, COLORREF crTo, BOOL bHorz);
998
1014 void GradientFill(CDC* pDC, LPCRECT lpRect, COLORREF crFrom, COLORREF crTo, BOOL bHorz,
1015 LPCRECT lpRectClip);
1016
1032 void GradientFill(CDC* pDC, LPCRECT lpRect, const CXTPPaintManagerColorGradient& grc,
1033 BOOL bHorz, LPCRECT lpRectClip = NULL);
1034
1055 BOOL GradientFill(HDC hdc, PTRIVERTEX pVertex, ULONG dwNumVertex, PVOID pMesh, ULONG dwNumMesh,
1056 ULONG dwMode);
1057
1071 static void AFX_CDECL DrawBorder(CDC* pDC, CRect rBorder, COLORREF* pOutsideClr,
1072 COLORREF* pInsideClr = NULL);
1073
1082 void ExcludeCorners(CDC* pDC, CRect rc, BOOL bTopCornersOnly = FALSE);
1083
1091 static void AFX_CDECL StripMnemonics(CString& strClear);
1092
1100 static void AFX_CDECL StripMnemonics(LPTSTR lpszClear);
1101
1110 void BlurPoints(CDC* pDC, LPPOINT pts, int nCount);
1111
1122 static COLORREF AFX_CDECL BlendColors(COLORREF crA, COLORREF crB, double fAmountA);
1123
1124 static BOOL AFX_CDECL GetIconLogFont(LOGFONT* pLogFont);
1125
1146 static BOOL AFX_CDECL GetDefaultLogFont(LOGFONT* pLogFont, BOOL bModernFont = TRUE,
1147 BOOL bVertFont = FALSE);
1148
1159 static void AFX_CDECL ReplaceColor(CDC* pDC, CRect rArea, COLORREF crFind, COLORREF crReplace);
1160
1170 static COLORREF AFX_CDECL DarkenColor(long lScale, COLORREF lColor);
1171
1181 static COLORREF AFX_CDECL LightenColor(long lScale, COLORREF lColor);
1182
1192 static COLORREF AFX_CDECL RGBtoHSL(COLORREF rgb);
1193
1205 static void AFX_CDECL RGBtoHSL(COLORREF clr, double& h, double& s, double& l);
1206
1216 static COLORREF AFX_CDECL HSLtoRGB(COLORREF hsl);
1217
1229 static COLORREF AFX_CDECL HSLtoRGB(double h, double s, double l);
1230
1244 static COLORREF AFX_CDECL DarkenColorLum(COLORREF clr, double dPercent);
1245
1261 static COLORREF AFX_CDECL AdjustBrightness(COLORREF clr, int nPercent);
1262
1272 static COLORREF AFX_CDECL GreyScaleColor(COLORREF clr);
1273
1283 static BOOL AFX_CDECL FontExists(LPCTSTR lpszFaceName);
1284
1291 static CString AFX_CDECL GetDefaultFontName();
1292
1316 static int AFX_CDECL DrawFontText(CDC* pDC, LPCTSTR lpszFontFaceName, int nFontHeight,
1317 LPCTSTR lpchText, int nCount, LPRECT lpRect, UINT uFormat,
1318 COLORREF crForeColor = COLORREF_NULL,
1319 COLORREF crBackColor = COLORREF_NULL);
1320
1343 static int AFX_CDECL DrawFontText(CDC* pDC, CFont* pFont, LPCTSTR lpchText, int nCount,
1344 LPRECT lpRect, UINT uFormat,
1345 COLORREF crForeColor = COLORREF_NULL,
1346 COLORREF crBackColor = COLORREF_NULL);
1347
1356 static CPoint AFX_CDECL Dlu2Pix(int dluX, int dluY);
1357
1365 static CString AFX_CDECL GetVerticalFontName(BOOL bUseOfficeFont);
1366
1380 static void AFX_CDECL Triangle(CDC* pDC, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clrPen,
1381 COLORREF clrBrush = COLORREF_NULL);
1382
1394 static void AFX_CDECL Triangle(CDC* pDC, CPoint pt0, CPoint pt1, CPoint pt2);
1395
1409 static void AFX_CDECL DrawExpandTriangle(CDC* pDC, CPoint pt, BOOL bExpanded, COLORREF clrPen,
1410 COLORREF clrBrush = COLORREF_NULL);
1411
1423 static void AFX_CDECL DrawExpandArrow(CDC* pDC, CRect rc, BOOL bExpanded, COLORREF clrArrow);
1424
1438 static BOOL AFX_CDECL DrawLine(CDC* pDC, int x1, int y1, int x2, int y2, COLORREF crLine);
1439
1450 static BOOL AFX_CDECL IsLowResolution(HDC hDC = 0);
1451
1458 BOOL IsFastFillAvailable() const;
1459
1474 BOOL TakeSnapShot(CWnd* pWndOwner, CBitmap& bmpSnapshot);
1475
1490 BOOL DrawTransparentBack(CDC* pDC, CWnd* pWndOwner, CBitmap& bmpSnapshot);
1491
1499 static BOOL AFX_CDECL IsTopParentActive(HWND hWnd);
1500
1509 static void AFX_CDECL KeyToLayout(CWnd* pWnd, UINT& nChar);
1510
1519 static void AFX_CDECL ScreenToWindow(CWnd* pWnd, LPPOINT lpPoint);
1520
1521 static DWORD AFX_CDECL GetLayout(CDC* pDC);
1522 static DWORD AFX_CDECL GetLayout(HDC hDC);
1523
1524 static DWORD AFX_CDECL SetLayout(CDC* pDC, DWORD dwLayout);
1525 static DWORD AFX_CDECL SetLayout(HDC hDC, DWORD dwLayout);
1526
1533 static BOOL AFX_CDECL IsContextRTL(CDC* pDC);
1534
1541 static BOOL AFX_CDECL IsContextRTL(HDC hDC);
1542
1550 static void AFX_CDECL SetContextRTL(CDC* pDC, DWORD dwLayoutRTL);
1551
1559 static void AFX_CDECL SetContextRTL(HDC hDC, DWORD dwLayoutRTL);
1560
1567 static BOOL AFX_CDECL IsWindowRTL(CWnd* pWnd);
1568
1575 static BOOL AFX_CDECL IsWindowRTL(HWND hWnd);
1576
1583 static BOOL AFX_CDECL IsVScrollOnTheLeft(CWnd* pWnd);
1584
1591 static BOOL AFX_CDECL IsVScrollOnTheLeft(HWND hWnd);
1592
1603 static BOOL AFX_CDECL RegisterWndClass(HINSTANCE hInstance, LPCTSTR lpszClassName, UINT style,
1604 HICON hIcon = 0, HBRUSH hbrBackground = 0);
1605
1615 static void AFX_CDECL GetWindowCaption(HWND hWnd, CString& strWindowText);
1616
1626 static void AFX_CDECL DrawColorRect(CDC* pDC, CRect rColor, COLORREF clrFill,
1627 COLORREF clrBorder);
1628
1641 static void AFX_CDECL DrawColorRect(CDC* pDC, int l, int t, int cx, int cy, COLORREF clrFill,
1642 COLORREF clrBorder);
1643
1653 static void AFX_CDECL DrawHatchRect(CDC* pDC, CRect rColor, COLORREF clrFill,
1654 COLORREF clrBorder);
1655
1666 static void AFX_CDECL CreatePatternBrush(CBitmap& bmp, CBrush& brush, COLORREF clrFill,
1667 const void* pBitsBrush);
1668
1680 static void AFX_CDECL DrawBrushRect(CDC* pDC, CRect rColor, COLORREF clrFill,
1681 COLORREF clrBorder, const void* pBitsBrush);
1682
1699 static int ComputeFittingFontHeight(CDC* pDC, LPCTSTR lpStr, int cch, const CRect& rc,
1700 CFont& fntTest);
1701
1713 static BOOL AFX_CDECL StretchImageListImage(CDC* pDC, CRect rcDest, CImageList* pImageList,
1714 int nImage);
1715
1725 static BOOL AFX_CDECL ProcessPendingPaintMessages(HWND hWnd = NULL);
1726
1728 _XTP_DEPRECATED_IN_FAVOR2(XTPSystemVersion, GetComCtlVersion)
1729 static DWORD AFX_CDECL GetComCtlVersion();
1730
1731 _XTP_DEPRECATED_IN_FAVOR2(XTPMultiMonitor, GetWorkArea)
1732 static CRect AFX_CDECL GetWorkArea();
1733
1734 _XTP_DEPRECATED_IN_FAVOR2(XTPMultiMonitor, GetWorkArea)
1735 static CRect AFX_CDECL GetWorkArea(const POINT& point);
1736
1737 _XTP_DEPRECATED_IN_FAVOR2(XTPMultiMonitor, GetWorkArea)
1738 static CRect AFX_CDECL GetWorkArea(LPCRECT rect);
1739
1740 _XTP_DEPRECATED_IN_FAVOR2(XTPMultiMonitor, GetWorkArea)
1741 static CRect AFX_CDECL GetWorkArea(const CWnd* pWnd);
1742
1743 _XTP_DEPRECATED_IN_FAVOR2(XTPMultiMonitor, GetScreenArea)
1744 static CRect AFX_CDECL GetScreenArea(const CWnd* pWnd);
1747private:
1759 static int AFX_CDECL HueToRGB(int m1, int m2, int h);
1760 static double AFX_CDECL HueToRGB(double temp1, double temp2, double temp3);
1761
1762public:
1763 PFNALPHABLEND m_pfnAlphaBlend;
1764 PFNTRANSPARENTBLT m_pfnTransparentBlt;
1765 PFNGRADIENTFILL m_pfnFastGradientFill;
1766
1767private:
1768 HMODULE m_hMsImgDll;
1770 // private members used for draw routines.
1771 void GradientFillFast(CDC* pDC, LPCRECT lpRect, COLORREF crFrom, COLORREF crTo, BOOL bHorz);
1772 void GradientFillSlow(CDC* pDC, LPCRECT lpRect, COLORREF crFrom, COLORREF crTo, BOOL bHorz);
1773
1774 // singleton
1775 friend _XTP_EXT_CLASS CXTPDrawHelpers* AFX_CDECL XTPDrawHelpers(); // Used to access the
1776 // CXTPDrawHelpers object.
1777};
1778
1794template<class TBase>
1795class CXTPNoFlickerWnd : public TBase
1796{
1797public:
1802 CXTPNoFlickerWnd()
1803 {
1804 m_crBack = ::GetSysColor(COLOR_3DFACE);
1805 }
1806
1807public:
1814 void SetBackColor(COLORREF crBack)
1815 {
1816 m_crBack = crBack;
1817 }
1818
1826 COLORREF GetBackColor()
1827 {
1828 return m_crBack;
1829 }
1830
1846 virtual LRESULT WindowProc(UINT message, WPARAM wParam, LPARAM lParam)
1847 {
1848 switch (message)
1849 {
1850 case WM_PAINT:
1851 {
1852 CPaintDC dc(this);
1853
1854 // Get the client rect and paint to a memory device context.
1855 // This will help reduce screen flicker. Pass the memory
1856 // device context to the default window procedure to do
1857 // default painting.
1858
1859 CRect rc;
1860 TBase::GetClientRect(&rc);
1861
1862 CXTPBufferDC memDC(dc.GetSafeHdc(), rc);
1863 memDC.FillSolidRect(rc, m_crBack);
1864
1865 return TBase::DefWindowProc(WM_PAINT, (WPARAM)memDC.m_hDC, 0);
1866 }
1867
1868 case WM_ERASEBKGND: { return TRUE;
1869 }
1870 }
1871
1872 return TBase::WindowProc(message, wParam, lParam);
1873 }
1874
1875protected:
1876 COLORREF m_crBack;
1877};
1878
1880_XTP_EXT_CLASS COLORREF AFX_CDECL XTPOfficeBorder_GetBorderColor(bool bTopLeft);
1881_XTP_EXT_CLASS void AFX_CDECL XTPOfficeBorder_OnPaint(CWnd* pWnd, COLORREF clr1, COLORREF clr2);
1913template<class TBase, bool bCalcSize = true>
1914class CXTPOfficeBorder : public TBase
1915{
1916protected:
1926 virtual COLORREF GetBorderColor(bool bTopLeft) const
1927 {
1928 return XTPOfficeBorder_GetBorderColor(bTopLeft);
1929 }
1930
1932 virtual LRESULT WindowProc(UINT message, WPARAM wParam, LPARAM lParam)
1933 {
1934 switch (message)
1935 {
1936 case WM_NCPAINT:
1937 {
1938 TBase::WindowProc(message, wParam, lParam);
1939 XTPOfficeBorder_OnPaint(this, GetBorderColor(true), GetBorderColor(false));
1940 return 0; // Handled.
1941 }
1942
1943 case WM_CREATE:
1944 {
1945 if (TBase::WindowProc(message, wParam, lParam) == -1)
1946 return -1;
1947
1948# if (_MSC_VER > 1300)
1949# pragma warning(push)
1950# pragma warning(disable : 4127) // conditional expression is constant
1951# endif
1952 if (bCalcSize)
1953# if (_MSC_VER > 1300)
1954# pragma warning(pop)
1955# endif
1956 {
1957 // remove 3D borders.
1958 long lStyle = ::GetWindowLong(TBase::m_hWnd, GWL_STYLE) & ~WS_BORDER;
1959 ::SetWindowLong(TBase::m_hWnd, GWL_STYLE, lStyle);
1960
1961 long lExStyle = ::GetWindowLong(TBase::m_hWnd, GWL_EXSTYLE) & ~WS_EX_CLIENTEDGE;
1962 ::SetWindowLong(TBase::m_hWnd, GWL_EXSTYLE, lExStyle);
1963
1964 // force non-client area to be recalculated.
1965 ::SetWindowPos(TBase::m_hWnd, NULL, NULL, NULL, NULL, NULL,
1966 SWP_NOMOVE | SWP_NOSIZE | SWP_NOZORDER | SWP_NOACTIVATE
1967 | SWP_FRAMECHANGED);
1968 }
1969
1970 return 0; // Handled.
1971 }
1972 break;
1973
1974 case WM_NCCALCSIZE: { LRESULT lResult = TBase::WindowProc(message, wParam, lParam);
1975
1976# if (_MSC_VER > 1300)
1977# pragma warning(push)
1978# pragma warning(disable : 4127) // conditional expression is constant
1979# endif
1980 if (bCalcSize)
1981# if (_MSC_VER > 1300)
1982# pragma warning(pop)
1983# endif
1984 {
1985 NCCALCSIZE_PARAMS FAR* lpncsp = (NCCALCSIZE_PARAMS FAR*)lParam;
1986
1987 // adjust non-client area for border space
1988 lpncsp->rgrc[0].left += 1;
1989 lpncsp->rgrc[0].top += 1;
1990 lpncsp->rgrc[0].right -= 1;
1991 lpncsp->rgrc[0].bottom -= 1;
1992 }
1993
1994 return lResult;
1995 }
1996 }
1997
1998 return TBase::WindowProc(message, wParam, lParam);
1999 }
2001};
2002
2014_XTP_EXT_CLASS CXTPDrawHelpers* AFX_CDECL XTPDrawHelpers();
2015
2029_XTP_EXT_CLASS BOOL AFX_CDECL XTPGetPrinterDeviceDefaults(HGLOBAL& ref_hDevMode,
2030 HGLOBAL& ref_hDevNames);
2031
2036class _XTP_EXT_CLASS CXTPPrinterInfo : public CXTPCmdTarget
2037{
2039 DECLARE_DYNAMIC(CXTPPrinterInfo)
2041public:
2048 CXTPPrinterInfo();
2049
2056 virtual ~CXTPPrinterInfo();
2057
2064 enum XTPEnumDeviceName
2065 {
2066 xtpDevName_Driver = 0,
2067 xtpDevName_Device = 1,
2068 xtpDevName_Port = 2
2069 };
2070
2082 CString GetName(XTPEnumDeviceName eNameID);
2083
2084protected:
2095 WORD _GetNameOffset(LPDEVNAMES pDevNames, XTPEnumDeviceName eNameID);
2096
2097# ifdef _XTP_ACTIVEX
2099 DECLARE_DISPATCH_MAP()
2100 DECLARE_INTERFACE_MAP()
2101
2102 DECLARE_OLETYPELIB_EX(CXTPPrinterInfo);
2103
2104 afx_msg BSTR OleGetDeviceName();
2105 afx_msg BSTR OleGetDriverName();
2106 afx_msg BSTR OleGetPortName();
2108# endif
2109};
2110
2119class _XTP_EXT_CLASS CXTPPrintPageHeaderFooter : public CXTPCmdTarget
2120{
2122 friend class CXTPPrintOptions;
2123 DECLARE_DYNAMIC(CXTPPrintPageHeaderFooter)
2125public:
2135 CXTPPrintPageHeaderFooter(CXTPPrintOptions* pOwner, BOOL bHeader);
2136
2143 virtual ~CXTPPrintPageHeaderFooter();
2144
2182 virtual void FormatTexts(CPrintInfo* pInfo, LPCTSTR pcszWndTitle, int nVirtualPage = 0);
2183
2197 virtual void Draw(CDC* pDC, CRect& rcRect, BOOL bCalculateOnly = FALSE);
2198
2206 virtual void Set(const CXTPPrintPageHeaderFooter* pSrc);
2207
2214 virtual void Clear();
2215
2222 virtual BOOL IsEmpty();
2223
2224 LOGFONT m_lfFont;
2225 COLORREF m_clrColor;
2226 CString m_strFormatString;
2228 CString m_strLeft;
2229 CString m_strCenter;
2230 CString m_strRight;
2233 static CString AFX_CDECL GetParentFrameTitle(CWnd* pWnd);
2234 static void AFX_CDECL DoInsertHFFormatSpecifierViaMenu(CWnd* pParent, CEdit* pEdit,
2235 CButton* pButton);
2238protected:
2239 BOOL m_bHeader;
2240 CXTPPrintOptions* m_pOwner;
2243 virtual int Calc3ColSizes(CDC* pDC, int nW, const CString& str1, const CString& str2,
2244 const CString& str3, CSize& rsz1, CSize& rsz2, CSize& rsz3);
2245 virtual int _Calc3ColSizesIfSingleCol(CDC* pDC, int nW, const CString& str1,
2246 const CString& str2, const CString& str3, CSize& rsz1,
2247 CSize& rsz2, CSize& rsz3);
2248
2249 virtual void _SplitFormatLCR(CString strFormat);
2250 virtual void _FormatDateTime(CString& strFormat, LCID lcidLocale);
2253# ifdef _XTP_ACTIVEX
2255 afx_msg LPFONTDISP OleGetFont();
2256 afx_msg void OleSetFont(LPFONTDISP pFontDisp);
2257 afx_msg void OleClear();
2258
2259 DECLARE_DISPATCH_MAP()
2260 DECLARE_INTERFACE_MAP()
2261
2262 DECLARE_OLETYPELIB_EX(CXTPPrintPageHeaderFooter);
2264# endif
2265
2266private:
2267 int fnYi(int Xi, int Wi);
2268};
2269
2277AFX_INLINE HDC XTPGetHandle(CDC* pDC)
2278{
2279 _ASSERTE(NULL != pDC);
2280 return pDC->m_hDC;
2281}
2282
2290AFX_INLINE HDC XTPGetHandle(CDC& dc)
2291{
2292 return dc.m_hDC;
2293}
2294
2302AFX_INLINE HDC XTPGetHandle(HDC hDC)
2303{
2304 return hDC;
2305}
2306
2312enum XTPDpiAwareness
2313{
2314 xtpDpiUnaware = 0,
2315 xtpDpiSystemAware = 1,
2316 xtpDpiPerMonitorAware = 2
2317};
2318
2328class _XTP_EXT_CLASS CXTPDpi
2329{
2330 friend class CXTPSingleton<CXTPDpi>;
2331
2332public:
2333 enum
2334 {
2335 DefaultDpi = 96 // Normal DPI.
2336 };
2337
2342 CXTPDpi();
2343
2350 CXTPDpi(HDC hDC);
2351
2358 CXTPDpi(HWND hWnd);
2359
2364 ~CXTPDpi();
2365
2377 BOOL SetDpiAwareness(XTPDpiAwareness dpiAwareness);
2378
2387 XTPDpiAwareness GetDpiAwareness() const;
2388
2401 BOOL OnWndMsg(HWND hWnd, UINT message, WPARAM wParam, LPARAM lParam, LRESULT* pResult);
2402
2410 int GetDPIX() const;
2411
2419 int GetDPIY() const;
2420
2427 BOOL IsDefaultDpiX() const;
2428
2435 BOOL IsDefaultDpiY() const;
2436
2443 BOOL IsDefaultDpi() const;
2444
2453 BOOL IsDpiBitmapScalingEnabled() const;
2454
2462 void EnableDpiBitmapScaling(BOOL bEnable = TRUE);
2463
2473 int ScaleX(int x, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
2474
2484 int ScaleY(int y, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
2485
2495 long ScaleX(long x, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
2496
2506 long ScaleY(long y, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
2507
2517 float ScaleX(float x, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
2518
2528 float ScaleY(float y, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
2529
2539 double ScaleX(double x, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
2540
2550 double ScaleY(double y, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
2551
2561 unsigned int ScaleX(unsigned int x, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
2562
2572 unsigned int ScaleY(unsigned int y, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
2573
2583 int UnscaleX(int x, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
2584
2594 int UnscaleY(int y, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
2595
2605 long UnscaleX(long x, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
2606
2616 long UnscaleY(long y, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
2617
2627 float UnscaleX(float x, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
2628
2638 float UnscaleY(float y, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
2639
2649 double UnscaleX(double x, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
2650
2660 double UnscaleY(double y, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
2661
2671 unsigned int UnscaleX(unsigned int x, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
2672
2682 unsigned int UnscaleY(unsigned int y, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
2683
2694 int ScaleX(HDC hDC, int x, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
2695
2706 int ScaleY(HDC hDC, int y, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
2707
2718 long ScaleX(HDC hDC, long x, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
2719
2730 long ScaleY(HDC hDC, long y, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
2731
2742 float ScaleX(HDC hDC, float x, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
2743
2754 float ScaleY(HDC hDC, float y, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
2755
2766 double ScaleX(HDC hDC, double x, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
2767
2778 double ScaleY(HDC hDC, double y, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
2779
2790 unsigned int ScaleX(HDC hDC, unsigned int x, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
2791
2802 unsigned int ScaleY(HDC hDC, unsigned int y, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
2803
2814 int UnscaleX(HDC hDC, int x, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
2815
2826 int UnscaleY(HDC hDC, int y, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
2827
2838 long UnscaleX(HDC hDC, long x, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
2839
2850 long UnscaleY(HDC hDC, long y, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
2851
2862 float UnscaleX(HDC hDC, float x, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
2863
2874 float UnscaleY(HDC hDC, float y, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
2875
2886 double UnscaleX(HDC hDC, double x, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
2887
2898 double UnscaleY(HDC hDC, double y, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
2899
2910 unsigned int UnscaleX(HDC hDC, unsigned int x, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
2911
2922 unsigned int UnscaleY(HDC hDC, unsigned int y, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
2923
2931 void ScaleRect(RECT* pRect, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
2932
2942 RECT ScaleRect(const RECT& rc, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
2943
2951 void UnscaleRect(RECT* pRect, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
2952
2962 RECT UnscaleRect(const RECT& rc, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
2963
2971 void Scale(RECT* pRect, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
2972
2982 RECT Scale(const RECT& rc, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
2983
2991 void Unscale(RECT* pRect, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
2992
3002 RECT Unscale(const RECT& rc, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
3003
3011 void ScaleRect(CRect* pRect, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
3012
3022 CRect ScaleRect(const CRect& rc, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
3023
3031 void UnscaleRect(CRect* pRect, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
3032
3042 CRect UnscaleRect(const CRect& rc, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
3043
3051 void Scale(CRect* pRect, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
3052
3062 CRect Scale(const CRect& rc, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
3063
3071 void Unscale(CRect* pRect, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
3072
3082 CRect Unscale(const CRect& rc, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
3083
3092 void ScaleRect(HDC hDC, RECT* pRect, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
3093
3104 RECT ScaleRect(HDC hDC, const RECT& rc, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
3105
3114 void UnscaleRect(HDC hDC, RECT* pRect, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
3115
3126 RECT UnscaleRect(HDC hDC, const RECT& rc, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
3127
3136 void Scale(HDC hDC, RECT* pRect, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
3137
3148 RECT Scale(HDC hDC, const RECT& rc, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
3149
3158 void Unscale(HDC hDC, RECT* pRect, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
3159
3170 RECT Unscale(HDC hDC, const RECT& rc, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
3171
3180 void ScaleRect(HDC hDC, CRect* pRect, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
3181
3192 CRect ScaleRect(HDC hDC, const CRect& rc, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
3193
3202 void UnscaleRect(HDC hDC, CRect* pRect, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
3203
3214 CRect UnscaleRect(HDC hDC, const CRect& rc, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
3215
3224 void Scale(HDC hDC, CRect* pRect, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
3225
3236 CRect Scale(HDC hDC, const CRect& rc, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
3237
3246 void Unscale(HDC hDC, CRect* pRect, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
3247
3258 CRect Unscale(HDC hDC, const CRect& rc, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
3259
3267 void ScalePoint(POINT* pPoint, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
3268
3278 POINT ScalePoint(const POINT& pt, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
3279
3287 void UnscalePoint(POINT* pPoint, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
3288
3298 POINT UnscalePoint(const POINT& pt, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
3299
3307 void Scale(POINT* pPoint, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
3308
3318 POINT Scale(const POINT& pt, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
3319
3327 void Unscale(POINT* pPoint, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
3328
3338 POINT Unscale(const POINT& pt, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
3339
3347 void ScalePoint(CPoint* pPoint, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
3348
3358 CPoint ScalePoint(const CPoint& pt, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
3359
3367 void UnscalePoint(CPoint* pPoint, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
3368
3378 CPoint UnscalePoint(const CPoint& pt, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
3379
3387 void Scale(CPoint* pPoint, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
3388
3398 CPoint Scale(const CPoint& pt, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
3399
3407 void Unscale(CPoint* pPoint, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
3408
3418 CPoint Unscale(const CPoint& pt, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
3419
3428 void ScalePoint(HDC hDC, POINT* pPoint, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
3429
3440 POINT ScalePoint(HDC hDC, const POINT& pt, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
3441
3450 void UnscalePoint(HDC hDC, POINT* pPoint, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
3451
3462 POINT UnscalePoint(HDC hDC, const POINT& pt, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
3463
3472 void Scale(HDC hDC, POINT* pPoint, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
3473
3484 POINT Scale(HDC hDC, const POINT& pt, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
3485
3494 void Unscale(HDC hDC, POINT* pPoint, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
3495
3506 POINT Unscale(HDC hDC, const POINT& pt, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
3507
3516 void ScalePoint(HDC hDC, CPoint* pPoint, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
3517
3528 CPoint ScalePoint(HDC hDC, const CPoint& pt, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
3529
3538 void UnscalePoint(HDC hDC, CPoint* pPoint, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
3539
3550 CPoint UnscalePoint(HDC hDC, const CPoint& pt, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
3551
3560 void Scale(HDC hDC, CPoint* pPoint, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
3561
3572 CPoint Scale(HDC hDC, const CPoint& pt, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
3573
3582 void Unscale(HDC hDC, CPoint* pPoint, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
3583
3594 CPoint Unscale(HDC hDC, const CPoint& pt, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
3595
3603 void ScaleSize(SIZE* pSize, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
3604
3614 SIZE ScaleSize(const SIZE& sz, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
3615
3623 void UnscaleSize(SIZE* pSize, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
3624
3634 SIZE UnscaleSize(const SIZE& sz, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
3635
3643 void Scale(SIZE* pSize, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
3644
3654 SIZE Scale(const SIZE& sz, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
3655
3663 void Unscale(SIZE* pSize, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
3664
3674 SIZE Unscale(const SIZE& sz, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
3675
3683 void ScaleSize(CSize* pSize, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
3684
3694 CSize ScaleSize(const CSize& sz, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
3695
3703 void UnscaleSize(CSize* pSize, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
3704
3714 CSize UnscaleSize(const CSize& sz, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
3715
3723 void Scale(CSize* pSize, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
3724
3734 CSize Scale(const CSize& sz, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
3735
3743 void Unscale(CSize* pSize, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
3744
3754 CSize Unscale(const CSize& sz, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
3755
3764 void ScaleSize(HDC hDC, SIZE* pSize, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
3765
3776 SIZE ScaleSize(HDC hDC, const SIZE& sz, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
3777
3786 void UnscaleSize(HDC hDC, SIZE* pSize, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
3787
3798 SIZE UnscaleSize(HDC hDC, const SIZE& sz, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
3799
3808 void Scale(HDC hDC, SIZE* pSize, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
3809
3820 SIZE Scale(HDC hDC, const SIZE& sz, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
3821
3830 void Unscale(HDC hDC, SIZE* pSize, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
3831
3842 SIZE Unscale(HDC hDC, const SIZE& sz, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
3843
3852 void ScaleSize(HDC hDC, CSize* pSize, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
3853
3864 CSize ScaleSize(HDC hDC, const CSize& sz, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
3865
3874 void UnscaleSize(HDC hDC, CSize* pSize, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
3875
3886 CSize UnscaleSize(HDC hDC, const CSize& sz, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
3887
3896 void Scale(HDC hDC, CSize* pSize, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
3897
3908 CSize Scale(HDC hDC, const CSize& sz, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
3909
3918 void Unscale(HDC hDC, CSize* pSize, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
3919
3930 CSize Unscale(HDC hDC, const CSize& sz, int iDpiScaleAbove = CXTPDpi::DefaultDpi) const;
3931
3942 int SelectDpiSpecific(int upToDpi120, int upToDpi144, int upToDpi192, int theLargest) const;
3943
3954 LPCTSTR SelectDpiSpecific(LPCTSTR upToDpi120, LPCTSTR upToDpi144, LPCTSTR upToDpi192,
3955 LPCTSTR theLargest) const;
3956
3966 void* SelectDpiSpecific(void* upToDpi120, void* upToDpi144, void* upToDpi192,
3967 void* theLargest) const;
3968
3975 int ScaledScreenWidth() const;
3976
3983 int ScaledScreenHeight() const;
3984
3993 bool IsResolutionAtLeast(int cxMin, int cyMin) const;
3994
4002 int PointsToPixels(int pt) const;
4003
4008 void Invalidate();
4009
4022 BOOL GetPhysicalWindowScaleFactors(HWND hWnd, double& xScale, double& yScale) const;
4023
4024private:
4025 void Construct(HDC hDC = NULL, HWND hWnd = NULL);
4026 void Init(int dpiX = 0, int dpiY = 0, BOOL bUpdate = FALSE);
4027 void InitDpiAwareness();
4028 int ScaleSystemMetricX(int nIndex) const;
4029 int ScaleSystemMetricY(int nIndex) const;
4030
4031 LRESULT OnWmCreate(HWND hWnd, WPARAM wParam, LPARAM lParam);
4032 LRESULT OnWmDpiChanged(HWND hWnd, WPARAM wParam, LPARAM lParam);
4033
4034private:
4035 enum
4036 {
4037 DpiValueCount = 0x100
4038 };
4039
4040 BOOL m_bInitialized;
4041 BOOL m_bSupportsDpiChange;
4042
4043 HDC m_hDC;
4044 HWND m_hWnd;
4045 BOOL m_bReleaseDC;
4046 BOOL m_bDpiBitmapScaling;
4047
4048 int m_dpiX;
4049 int m_dpiY;
4050
4051 POINT m_nPositiveDpiValues[DpiValueCount + 1];
4052 POINT m_nNegativeDpiValues[DpiValueCount + 1];
4053
4054 static BOOL m_bDpiAwarenessInitialized;
4055 typedef HRESULT(WINAPI* PFNSetProcessDpiAwareness)(XTPDpiAwareness dpiAwareness);
4056 typedef HRESULT(WINAPI* PFNGetProcessDpiAwareness)(HANDLE hProcess,
4057 XTPDpiAwareness* dpiAwareness);
4058 static PFNSetProcessDpiAwareness m_pfnSetProcessDpiAwareness;
4059 static PFNGetProcessDpiAwareness m_pfnGetProcessDpiAwareness;
4060
4061 typedef BOOL(WINAPI* PFNSetProcessDPIAware)();
4062 static PFNSetProcessDPIAware m_pfnSetProcessDPIAware;
4063 static BOOL m_bSetProcessDPIAwareResult;
4064
4065 typedef HANDLE(WINAPI* PFNMonitorFromWindow)(HWND hWnd, DWORD dwFlags);
4066 static PFNMonitorFromWindow m_pfnMonitorFromWindow;
4067
4068 enum MonitorDpiType
4069 {
4070 xtpEffectiveDpiType = 0, // Same as MONITOR_DPI_TYPE::MDT_EFFECTIVE_DPI.
4071 xtpAngularDpiType = 1, // Same as MONITOR_DPI_TYPE::MDT_ANGULAR_DPI.
4072 xtpRawDpiType = 2, // Same as MONITOR_DPI_TYPE::MDT_RAW_DPI.
4073 xtpDefaultDpiType = xtpEffectiveDpiType // Same as MONITOR_DPI_TYPE::MDT_DEFAULT.
4074 };
4075
4076 typedef HRESULT(WINAPI* PFNGetDpiForMonitor)(HANDLE hMonitor, MonitorDpiType dpiType,
4077 UINT* dpiX, UINT* dpiY);
4078 static PFNGetDpiForMonitor m_pfnGetDpiForMonitor;
4079};
4080
4081AFX_INLINE BOOL CXTPDpi::IsDpiBitmapScalingEnabled() const
4082{
4083 return m_bDpiBitmapScaling;
4084}
4085
4086AFX_INLINE void CXTPDpi::EnableDpiBitmapScaling(BOOL bEnable /*= TRUE*/)
4087{
4088 m_bDpiBitmapScaling = bEnable;
4089}
4090
4097_XTP_EXT_CLASS CXTPDpi* AFX_CDECL XTPDpiHelper();
4098
4104# define XTP_DPI_X(n) XTPDpiHelper()->ScaleX(n)
4105# define XTP_DPI_Y(n) XTPDpiHelper()->ScaleY(n)
4106# define XTP_DPI(what) XTPDpiHelper()->Scale(what)
4107# define XTP_DPI_RECT(rc) XTP_DPI(rc)
4108# define XTP_DPI_POINT(pt) XTP_DPI(pt)
4109# define XTP_DPI_SIZE(sz) XTP_DPI(sz)
4110# define XTP_DC_DPI_X(dc, n) \
4111 XTPDpiHelper()->ScaleX(XTPGetHandle(dc), n)
4113# define XTP_DC_DPI_Y(dc, n) \
4114 XTPDpiHelper()->ScaleY(XTPGetHandle(dc), n)
4116# define XTP_DC_DPI(dc, what) \
4117 XTPDpiHelper()->Scale(XTPGetHandle(dc), what)
4118# define XTP_DC_DPI_RECT(dc, rc) XTP_DC_DPI(dc, rc)
4119# define XTP_DC_DPI_POINT(dc, pt) XTP_DC_DPI(dc, pt)
4120# define XTP_DC_DPI_SIZE(dc, sz) XTP_DC_DPI(dc, sz)
4127# define XTP_UNDPI_X(n) XTPDpiHelper()->UnscaleX(n)
4128
4134# define XTP_UNDPI_Y(n) XTPDpiHelper()->UnscaleY(n)
4135
4141# define XTP_UNDPI(what) XTPDpiHelper()->Unscale(what)
4142
4148# define XTP_UNDPI_RECT(rc) XTP_UNDPI(rc)
4149
4155# define XTP_UNDPI_POINT(pt) XTP_UNDPI(pt)
4156
4162# define XTP_UNDPI_SIZE(sz) XTP_UNDPI(sz)
4163
4169# define XTP_DC_UNDPI_X(dc, n) XTPDpiHelper()->UnscaleX(XTPGetHandle(dc), n)
4170
4176# define XTP_DC_UNDPI_Y(dc, n) XTPDpiHelper()->UnscaleY(XTPGetHandle(dc), n)
4177
4183# define XTP_DC_UNDPI(dc, what) XTPDpiHelper()->Unscale(XTPGetHandle(dc), what)
4184
4190# define XTP_DC_UNDPI_RECT(dc, rc) XTP_DC_UNDPI(dc, rc)
4191
4197# define XTP_DC_UNDPI_POINT(dc, pt) XTP_DC_UNDPI(dc, pt)
4198
4204# define XTP_DC_UNDPI_SIZE(dc, sz) XTP_DC_UNDPI(dc, sz)
4205
4210XTP_DECLARE_ENUM(XTPPrimitiveSymbol){
4211 xtpPrimitiveSymbolInvalid = -1, xtpPrimitiveSymbolFirst = 0x41,
4212
4213 // Common glyphs.
4214 xtpPrimitiveSymbolMinimize = xtpPrimitiveSymbolFirst, xtpPrimitiveSymbolMaximize,
4215 xtpPrimitiveSymbolRestore, xtpPrimitiveSymbolQuestionMark, xtpPrimitiveSymbolClose,
4216 xtpPrimitiveSymbolHome, xtpPrimitiveSymbolCheckMark, xtpPrimitiveSymbolCheckMarkRTL,
4217 xtpPrimitiveSymbolRadioMark,
4218
4219 // Normal Play glyph.
4220 xtpPrimitiveSymbolPlayLeft, xtpPrimitiveSymbolPlayRight, xtpPrimitiveSymbolPlayUp,
4221 xtpPrimitiveSymbolPlayDown,
4222
4223 // Small Play glyph.
4224 xtpPrimitiveSymbolPlayLeft2, xtpPrimitiveSymbolPlayRight2, xtpPrimitiveSymbolPlayUp2,
4225 xtpPrimitiveSymbolPlayDown2,
4226
4227 // Rewind glyph.
4228 xtpPrimitiveSymbolRewindLeft, xtpPrimitiveSymbolRewindRight, xtpPrimitiveSymbolRewindUp,
4229 xtpPrimitiveSymbolRewindDown,
4230
4231 // Shift glyph.
4232 xtpPrimitiveSymbolShiftLeft = 0x61, xtpPrimitiveSymbolShiftRight, xtpPrimitiveSymbolShiftDown,
4233 xtpPrimitiveSymbolShiftUp,
4234
4235 // Eject glyph.
4236 xtpPrimitiveSymbolEjectLeft, xtpPrimitiveSymbolEjectRight, xtpPrimitiveSymbolEjectUp,
4237 xtpPrimitiveSymbolEjectDown,
4238
4239 // Inject glyph.
4240 xtpPrimitiveSymbolInjectLeft, xtpPrimitiveSymbolInjectRight, xtpPrimitiveSymbolInjectUp,
4241 xtpPrimitiveSymbolInjectDown,
4242
4243 // Pin glyph.
4244 xtpPrimitiveSymbolPinLeft, xtpPrimitiveSymbolPinRight, xtpPrimitiveSymbolPinDown,
4245
4246 xtpPrimitiveSymbolPlus, xtpPrimitiveSymbolMinus, xtpPrimitiveSymbolEllipsis,
4247
4248 xtpPrimitiveSymbolTabClose, xtpPrimitiveSymbolTabPlayLeft, xtpPrimitiveSymbolTabPlayRight,
4249 xtpPrimitiveSymbolTabPlayLeftDisabled, xtpPrimitiveSymbolTabPlayRightDisabled,
4250 xtpPrimitiveSymbolTabPlayUp, xtpPrimitiveSymbolTabPlayDown, xtpPrimitiveSymbolTabPlayUpDisabled,
4251 xtpPrimitiveSymbolTabPlayDownDisabled,
4252
4253 xtpPrimitiveSymbolLast = xtpPrimitiveSymbolTabPlayDownDisabled
4254};
4255
4260class _XTP_EXT_CLASS CXTPPrimitiveDrawer
4261{
4262 friend class CXTPSingleton<CXTPPrimitiveDrawer>;
4263
4264 CXTPPrimitiveDrawer();
4265 ~CXTPPrimitiveDrawer();
4266
4267public:
4279 void DrawSymbol(CDC* pDC, XTPPrimitiveSymbol nSymbol, const CRect& rc,
4280 COLORREF crForeColor = COLORREF_NULL, COLORREF crBackColor = COLORREF_NULL,
4281 BOOL bOutline = FALSE, HPEN hOutlinePen = NULL);
4282
4283private:
4284 int PrimitiveSymbolToSVG(XTPPrimitiveSymbol nSymbol);
4285 BOOL SVGInit(XTPPrimitiveSymbol nSymbol);
4286 BOOL SVGLoad(CString& svg, UINT nIDResource);
4287 BOOL SVGSetColor(CDC* pDC, XTPPrimitiveSymbol nSymbol, COLORREF crForeColor = COLORREF_NULL);
4288 BOOL SVGDraw(CDC* pDC, const CRect& rc, XTPPrimitiveSymbol nSymbol,
4289 COLORREF crForeColor = COLORREF_NULL);
4290
4291private:
4292 struct SymbolColor
4293 {
4294 CMap<COLORREF, COLORREF, CXTPSvgImage*, CXTPSvgImage*> m_map;
4295 };
4296
4297 struct SymbolData
4298 {
4299 ~SymbolData();
4300
4301 CString svg;
4302 CMap<COLORREF, COLORREF, CXTPSvgImage*, CXTPSvgImage*> m_mapImage;
4303 };
4304
4305 CMap<XTPPrimitiveSymbol, XTPPrimitiveSymbol, SymbolData*, SymbolData*> m_map;
4306 CRITICAL_SECTION m_mapAccess;
4307};
4308
4316_XTP_EXT_CLASS CXTPPrimitiveDrawer* AFX_CDECL XTPPrimitiveDrawer();
4317
4325class _XTP_EXT_CLASS CXTPPrintOptions : public CXTPCmdTarget
4326{
4328 DECLARE_DYNAMIC(CXTPPrintOptions)
4331public:
4336 CXTPPrintOptions();
4337
4342 virtual ~CXTPPrintOptions();
4343
4344 CRect m_rcMargins;
4346 BOOL m_bBlackWhitePrinting;
4347 int m_nBlackWhiteContrast;
4358 CXTPPrintPageHeaderFooter* GetPageHeader();
4359
4368 CXTPPrintPageHeaderFooter* GetPageFooter();
4369
4375 void Set(const CXTPPrintOptions* pSrc);
4376
4386 virtual BOOL IsMarginsMeasureInches();
4387
4396 virtual CRect GetMarginsHimetric();
4397
4407 virtual CRect GetMarginsLP(CDC* pDC);
4408
4416 virtual LCID GetActiveLCID();
4417
4418protected:
4419 CXTPPrintPageHeaderFooter* m_pPageHeader;
4420 CXTPPrintPageHeaderFooter* m_pPageFooter;
4422# ifdef _XTP_ACTIVEX
4424 DECLARE_DISPATCH_MAP()
4425
4426 afx_msg BOOL OleGetMarginsMeasureMetrics();
4427
4428 afx_msg BOOL OleGetLandscape();
4429 afx_msg void OleSetLandscape(BOOL bLandscape);
4430
4431 afx_msg LPDISPATCH OleGetHeader();
4432 afx_msg LPDISPATCH OleGetFooter();
4433
4434 afx_msg LPDISPATCH OleGetPrinterInfo();
4436# endif
4437};
4438
4441
4442_XTP_EXT_CLASS BOOL CALLBACK _XTPAbortProc(HDC, int);
4443
4444// Printing Dialog
4445class _XTP_EXT_CLASS CXTPPrintingDialog : public CDialog
4446{
4447public:
4448 enum
4449 {
4450 IDD = AFX_IDD_PRINTDLG
4451 };
4452
4453 CXTPPrintingDialog(CWnd* pParent);
4454 virtual ~CXTPPrintingDialog()
4455 {
4456 }
4457
4458 virtual BOOL OnInitDialog();
4459 virtual void OnCancel();
4460};
4464
4465AFX_INLINE BOOL CXTPDrawHelpers::IsFastFillAvailable() const
4466{
4467 return m_pfnFastGradientFill != NULL;
4468}
4469AFX_INLINE void CXTPDrawHelpers::Triangle(CDC* pDC, CPoint pt0, CPoint pt1, CPoint pt2)
4470{
4471 CPoint pts[] = { pt0, pt1, pt2 };
4472 pDC->Polygon(pts, 3);
4473}
4474AFX_INLINE void CXTPSplitterTracker::SetBoundRect(CRect rcBoundRect)
4475{
4476 m_rcBoundRect = rcBoundRect;
4477}
4478
4480
4481# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
4483#endif // !defined(__XTPDRAWHELPERS_H__)
pPoint
const CPoint * pPoint
return 0 or xtpCalendarHitTestDayExpandButton
Definition XTPCalendarThemeOffice2007.h:150
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPMultiMonitor
_XTP_EXT_CLASS CXTPMultiMonitor *AFX_CDECL XTPMultiMonitor()
Call this function to access CXTPMultiMonitor members.
XTPSystemVersion
_XTP_EXT_CLASS CXTPSystemVersion *AFXAPI XTPSystemVersion()
The XTPSystemVersion function is used for access to the CXTPSystemVersion class.
CXTPClientCursorPos
CXTPClientCursorPos is a helper class used to retrieve the cursor position in client coordinates.
Definition XTPDrawHelpers.h:94
CXTPClientCursorPos::CXTPClientCursorPos
CXTPClientCursorPos(CWnd *pWnd)
Constructs a CXTPClientCursorPos object used to retrieve the cursor position in client coordinates.
CXTPClientRect
CXTPClientRect is a helper class used to retrieve the client area for a specified window.
Definition XTPDrawHelpers.h:183
CXTPClientRect::CXTPClientRect
CXTPClientRect(const CWnd *pWnd)
Constructs a CXTPClientRect object used to retrieve the client area for the specified window.
CXTPClientRect::CXTPClientRect
CXTPClientRect(HWND hWnd)
Constructs a CXTPClientRect object used to retrieve the client area for the specified window.
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPEmptyRect
CXTPEmptyRect is a helper class used to instantiate an empty CRect object.
Definition XTPDrawHelpers.h:112
CXTPEmptyRect::CXTPEmptyRect
CXTPEmptyRect()
Constructs a CXTPEmptyRect object used to instantiate an empty CRect object.
CXTPEmptySize
CXTPEmptySize is a helper class used to instantiate an empty CSize object.
Definition XTPDrawHelpers.h:128
CXTPEmptySize::operator=
const SIZE & operator=(const SIZE &srcSize)
Assigns srcSize to CSize.
CXTPEmptySize::SetSizeEmpty
void SetSizeEmpty()
Makes CXTPEmptySize a null size by setting all coordinates to zero.
CXTPEmptySize::CXTPEmptySize
CXTPEmptySize()
Constructs a CXTPEmptySize object used to instantiate an empty CSize object.
CXTPPaintManagerColorGradient
The CXTPPaintManagerColorGradient class is used to manage COLORREF values for determining light and d...
Definition XTPColorManager.h:301
CXTPSingleton
Implements Singleton design pattern.
Definition XTPSingleton.h:215
CXTPSvgImage
Implements basic SVG image format support.
Definition XTPSvgImage.h:43
CXTPTransparentBitmap
CXTPTransparentBitmap is a helper class used to extract the transparent color from a transparent BitM...
Definition XTPDrawHelpers.h:55
CXTPTransparentBitmap::GetTransparentColor
COLORREF GetTransparentColor() const
Call this function to get the transparent color of the BitMap.
CXTPTransparentBitmap::m_hBitmap
HBITMAP m_hBitmap
A handle to a BtiMap.
Definition XTPDrawHelpers.h:85
CXTPTransparentBitmap::ConvertToIcon
HICON ConvertToIcon() const
Call this function to create an icon based on the BitMap.
CXTPTransparentBitmap::CXTPTransparentBitmap
CXTPTransparentBitmap(HBITMAP hBitmap)
Constructor.
CXTPWindowRect
CXTPWindowRect is a helper class used to retrieve the screen size for a specified window.
Definition XTPDrawHelpers.h:158
CXTPWindowRect::CXTPWindowRect
CXTPWindowRect(const CWnd *pWnd)
Constructs a CXTPWindowRect object used to retrieve the screen size for the specified window.
CXTPWindowRect::CXTPWindowRect
CXTPWindowRect(HWND hWnd)
Constructs a CXTPWindowRect object used to retrieve the screen size for the specified window.


Toolkit Pro: Member List

CXTPPropertyPageTreeNavigator Member List

This is the complete list of members for CXTPPropertyPageTreeNavigator, including all inherited members.

Create()=0 | CXTPPropertyPageNavigator | pure virtual
CXTPPropertyPageControlNavigator() | CXTPPropertyPageControlNavigator |
CXTPPropertyPageNavigator() | CXTPPropertyPageNavigator |
CXTPPropertyPageTreeNavigator(DWORD dwStyle=TVS_SHOWSELALWAYS) | CXTPPropertyPageTreeNavigator |
GetPageBrush(CDC *pDC, CXTPPropertyPage *pPage)=0 | CXTPPropertyPageNavigator | pure virtual
GetPageColor()=0 | CXTPPropertyPageNavigator | pure virtual
GetSafeHwnd() const =0 | CXTPPropertyPageNavigator | pure virtual
m_pSheet | CXTPPropertyPageNavigator | protected
m_rcButtonMargin | CXTPPropertyPageNavigator |
m_rcNavigatorMargin | CXTPPropertyPageNavigator |
m_rcPageMargin | CXTPPropertyPageNavigator |
OnPageSelected(CXTPPropertyPage *pPage)=0 | CXTPPropertyPageNavigator | pure virtual
PageToSize(AFX_SIZEPARENTPARAMS *pLayout, CSize szPage, CRect &rcPage, CSize &szClient)=0 | CXTPPropertyPageNavigator | pure virtual
SetTheme(XTPControlTheme theme) | CXTPPropertyPageNavigator | virtual
SizeToPage(AFX_SIZEPARENTPARAMS *pLayout, CSize szClient, CRect &rcPage)=0 | CXTPPropertyPageNavigator | pure virtual
~CXTPPropertyPageNavigator() | CXTPPropertyPageNavigator | virtual


Toolkit Pro: XTPComboBoxThemeDefault.h Source File

  • Source
  • Controls
  • Combo
  • Themes
XTPComboBoxThemeDefault.h
Go to the documentation of this file.
1
23#ifndef XTPComboBoxThemeDefault_h__
24# define XTPComboBoxThemeDefault_h__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPComboBoxThemeDefault : public CXTPComboBoxTheme
39{
40public:
45 CXTPComboBoxThemeDefault();
46
51 virtual ~CXTPComboBoxThemeDefault();
52
53 virtual BOOL DrawComboBox(CDC* pDC, CXTPComboBox* pComboBox);
54
61 virtual void RefreshMetrics(CXTPComboBox* pComboBox);
62};
63
64# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
66#endif // XTPComboBoxThemeDefault_h__
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPComboBox
The CXTPComboBox class provides the functionality of a themed Windows combobox.
Definition XTPComboBox.h:42
CXTPComboBoxThemeDefault
Used as the paint manager for a combobox control to render a default appearance.
Definition XTPComboBoxThemeDefault.h:39
CXTPComboBoxThemeDefault::RefreshMetrics
virtual void RefreshMetrics(CXTPComboBox *pComboBox)
This member function is called by the theme manager to refresh the visual styles used by each compone...
CXTPComboBoxThemeDefault::CXTPComboBoxThemeDefault
CXTPComboBoxThemeDefault()
Default constructor.
CXTPComboBoxThemeDefault::~CXTPComboBoxThemeDefault
virtual ~CXTPComboBoxThemeDefault()
Destructor handles cleanup and deallocation.
CXTPComboBoxThemeDefault::DrawComboBox
virtual BOOL DrawComboBox(CDC *pDC, CXTPComboBox *pComboBox)
Called by the framework to draw the combobox control.
CXTPComboBoxTheme
CXTPComboBoxTheme is a class used to perform ComboBox Theme drawing tasks.
Definition XTPComboBoxTheme.h:42


Toolkit Pro: XTPMouseManager.h Source File

  • Source
  • CommandBars
XTPMouseManager.h
Go to the documentation of this file.
1
23#if !defined(__XTPMOUSEMANAGER_H__)
24# define __XTPMOUSEMANAGER_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPCommandBar;
34
40class _XTP_EXT_CLASS CXTPMouseManager : public CNoTrackObject
41{
42 friend class CXTPMouseManager* XTPMouseManager();
43
44public:
49 CXTPMouseManager();
50
51public:
56 class _XTP_EXT_CLASS CTrackArray : public CArray<CXTPCommandBar*, CXTPCommandBar*>
57 {
58 public:
67 int Find(const CXTPCommandBar* pCommandBar) const;
68 };
69
70private:
71 class CTrustedArray : public CArray<HWND, HWND>
72 {
73 public:
74 int Find(const HWND hWnd) const;
75 void Remove(HWND hWnd);
76 };
77
78public:
83 ~CXTPMouseManager();
84
91 void SetTrack(CXTPCommandBar* pTrack, BOOL bCaptureMouse = TRUE);
92
98 void RemoveTrack(CXTPCommandBar* pTrack);
99
104 void SendTrackLost();
105
111 void TrackMouseLeave(HWND hwnd);
112
120 BOOL IsTrackedLock(const CXTPCommandBar* pItem = NULL);
121
127 void SetSelected(CXTPCommandBar* pSelected);
128
134 void RemoveSelected(CXTPCommandBar* pSelected);
135
140 void LockMouseMove();
141
146 void UnlockMouseMove();
147
154 BOOL IsMouseLocked() const;
155
162 BOOL IsForceExpanded() const;
163
169 void SetForceExpanded(BOOL bForceExpanded);
170
176 void AddTrustedWindow(HWND hWnd);
177
183 void RemoveTrustedWindow(HWND hWnd);
184
192 static BOOL AFX_CDECL IsTopParentActive(HWND hWnd);
193
198 void IgnoreLButtonUp();
199
204 static void AFX_CDECL RefreshCursor();
205
214 CXTPCommandBar* HitTest(POINT point) const;
215
217 BOOL PreviewTackLost(CXTPCommandBar* pContextMenu, MSG* msg) const;
218 void LockTrackRecurse(BOOL bLockTrack);
219 void SendTrackLostRecurse();
220 BOOL IsTrackedLockRecurse() const;
221 CTrackArray& GetTrackArray();
222 CXTPCommandBar* GetTopTracked() const;
223 BOOL IsRelated(HWND hWndParent, HWND hWnd) const;
224 void EnableSkipTrackedMouseMoveDuplicates(BOOL bEnable = TRUE);
227private:
228 void DeliverMessage(CXTPCommandBar* pCapture, WPARAM wParam, POINT pt);
229 BOOL PreTranslateMouseEvents(WPARAM wParam, POINT point);
230 void SetupHook(BOOL);
231
232 static void CALLBACK TrackMouseTimerProc(HWND hWnd, UINT /*uMsg*/, UINT_PTR idEvent,
233 DWORD /*dwTime*/);
234 static LRESULT CALLBACK MouseProc(int nCode, WPARAM wParam, LPARAM lParam);
235
236private:
237 int m_nLock;
238 CTrackArray m_arrTracked;
239
240 static CThreadLocal<CXTPMouseManager> _xtpMouseThreadState;
241
242 HHOOK m_hHookMouse;
243 CXTPCommandBar* m_pSelected;
244 HWND m_hwndLeave;
245 BOOL m_bForceExpanded;
246 CTrustedArray m_arrTrusted;
247 BOOL m_bIgnoreLButtonUp;
248 BOOL m_bSkipTrackedMouseMoveDuplicates;
249 CPoint m_ptTrackedPos;
250
251# ifdef _AFXDLL
252 AFX_MODULE_STATE* m_pModuleState;
253# endif
254
255 friend class CXTPCustomizeSheet;
256 friend class CXTPCommandBars;
257};
258
259AFX_INLINE CXTPMouseManager* XTPMouseManager()
260{
261 return CXTPMouseManager::_xtpMouseThreadState.GetData();
262}
264AFX_INLINE CXTPMouseManager::CTrackArray& CXTPMouseManager::GetTrackArray()
265{
266 return m_arrTracked;
267}
269AFX_INLINE void CXTPMouseManager::SetSelected(CXTPCommandBar* pSelected)
270{
271 m_pSelected = pSelected;
272}
273AFX_INLINE void CXTPMouseManager::RemoveSelected(CXTPCommandBar* pSelected)
274{
275 if (m_pSelected == pSelected)
276 m_pSelected = NULL;
277}
278AFX_INLINE void CXTPMouseManager::LockMouseMove()
279{
280 m_nLock++;
281}
282AFX_INLINE void CXTPMouseManager::UnlockMouseMove()
283{
284 m_nLock--;
285}
286AFX_INLINE BOOL CXTPMouseManager::IsMouseLocked() const
287{
288 return m_nLock > 0;
289}
290
291AFX_INLINE BOOL CXTPMouseManager::IsForceExpanded() const
292{
293 return m_bForceExpanded;
294}
295AFX_INLINE void CXTPMouseManager::SetForceExpanded(BOOL bForceExpanded)
296{
297 m_bForceExpanded = bForceExpanded;
298}
299AFX_INLINE void CXTPMouseManager::IgnoreLButtonUp()
300{
301 m_bIgnoreLButtonUp = TRUE;
302}
304AFX_INLINE void CXTPMouseManager::EnableSkipTrackedMouseMoveDuplicates(BOOL bEnable /*= TRUE*/)
305{
306 m_bSkipTrackedMouseMoveDuplicates = bEnable;
307}
308
309# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
310#endif //#if !defined(__XTPMOUSEMANAGER_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCommandBar
CXTPCommandBar is a CWnd derived class.
Definition XTPCommandBar.h:66
CXTPCommandBars
CXTPCommandBars is a standalone class.
Definition XTPCommandBars.h:165
CXTPCustomizeSheet
CXTPCustomizeSheet is a CPropertySheet derived class.
Definition XTPCustomizeSheet.h:47
CXTPMouseManager::CTrackArray
Array of the tracking bars.
Definition XTPMouseManager.h:57
CXTPMouseManager::CTrackArray::Find
int Find(const CXTPCommandBar *pCommandBar) const
Call this method to find the position of a specified command bar.
CXTPMouseManager
CXTPMouseManager is standalone class.
Definition XTPMouseManager.h:41
CXTPMouseManager::RefreshCursor
static void AFX_CDECL RefreshCursor()
CXTPMouseManager::IsTopParentActive
static BOOL AFX_CDECL IsTopParentActive(HWND hWnd)
Call this method to check if the top parent window is active.
CXTPMouseManager::AddTrustedWindow
void AddTrustedWindow(HWND hWnd)
Adds a window to the trusted window list.
CXTPMouseManager::LockMouseMove
void LockMouseMove()
Captures the mouse cursor.
Definition XTPMouseManager.h:278
CXTPMouseManager::RemoveTrack
void RemoveTrack(CXTPCommandBar *pTrack)
Removes the tracking bar.
CXTPMouseManager::IgnoreLButtonUp
void IgnoreLButtonUp()
This method is called to disable one WM_RBUTTONUP message.
Definition XTPMouseManager.h:299
CXTPMouseManager::IsTrackedLock
BOOL IsTrackedLock(const CXTPCommandBar *pItem=NULL)
Checks if the command bar is tracked.
CXTPMouseManager::RemoveSelected
void RemoveSelected(CXTPCommandBar *pSelected)
Removes the selected command bar.
Definition XTPMouseManager.h:273
CXTPMouseManager::SetSelected
void SetSelected(CXTPCommandBar *pSelected)
Sets the selected command bar.
Definition XTPMouseManager.h:269
CXTPMouseManager::IsForceExpanded
BOOL IsForceExpanded() const
Check if the command bar needs to be expanded.
Definition XTPMouseManager.h:291
CXTPMouseManager::~CXTPMouseManager
~CXTPMouseManager()
Destroys a CXTPMouseManager object, handles cleanup and deallocation.
CXTPMouseManager::SendTrackLost
void SendTrackLost()
Removes all tracking bars.
CXTPMouseManager::RemoveTrustedWindow
void RemoveTrustedWindow(HWND hWnd)
Removes a window from the trusted window list.
CXTPMouseManager::HitTest
CXTPCommandBar * HitTest(POINT point) const
This method determines where a point lies in a specified item.
CXTPMouseManager::IsMouseLocked
BOOL IsMouseLocked() const
Checks if the mouse cursor locked.
Definition XTPMouseManager.h:286
CXTPMouseManager::SetForceExpanded
void SetForceExpanded(BOOL bForceExpanded)
Sets expanded state.
Definition XTPMouseManager.h:295
CXTPMouseManager::SetTrack
void SetTrack(CXTPCommandBar *pTrack, BOOL bCaptureMouse=TRUE)
Adds a tracking bar.
CXTPMouseManager::UnlockMouseMove
void UnlockMouseMove()
Unlocks the mouse cursor.
Definition XTPMouseManager.h:282
CXTPMouseManager::CXTPMouseManager
CXTPMouseManager()
Constructs a CXTPMouseManager object.
CXTPMouseManager::TrackMouseLeave
void TrackMouseLeave(HWND hwnd)
Hooks window for the mouse leave event.


Toolkit Pro: Member List

CXTPCalendarTLV_TimeScaleParams_Week Member List

This is the complete list of members for CXTPCalendarTLV_TimeScaleParams_Week, including all inherited members.

CalcScaleIntervalBegin(COleDateTime dtStart) | CXTPCalendarTLV_TimeScaleParams | virtual
CXTPCalendarTLV_TimeScaleParams(int nTimeScaleParamsID, CXTPCalendarTimeLineViewTimeScale *pTimeScale) | CXTPCalendarTLV_TimeScaleParams |
CXTPCalendarTLV_TimeScaleParams_Week(CXTPCalendarTimeLineViewTimeScale *pTimeScale) | CXTPCalendarTLV_TimeScaleParams_Week |
CXTPCmdTarget() | CXTPCmdTarget |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetParentTimeScale() const | CXTPCalendarTLV_TimeScaleParams |
GetPart() const | CXTPCalendarTLV_TimeScaleParams_Week | virtual
GetScaleInterval() const | CXTPCalendarTLV_TimeScaleParams | virtual
GetScaleIntervalWidth_px() const | CXTPCalendarTLV_TimeScaleParams | virtual
GetTimeLineViewScale() const | CXTPCalendarTLV_TimeScaleParams | virtual
GetTimePerPixel() const | CXTPCalendarTLV_TimeScaleParams | virtual
GetTimeScaleParamsID() const | CXTPCalendarTLV_TimeScaleParams | virtual
m_nScaleIntervalWidth_px | CXTPCalendarTLV_TimeScaleParams | protected
m_scaleInterval | CXTPCalendarTLV_TimeScaleParams | protected
SetScaleInterval(int eType, int nValue) | CXTPCalendarTLV_TimeScaleParams | protected
~CXTPCalendarTLV_TimeScaleParams() | CXTPCalendarTLV_TimeScaleParams | virtual
~CXTPCalendarTLV_TimeScaleParams_Week() | CXTPCalendarTLV_TimeScaleParams_Week | virtual


Toolkit Pro: XTPChartDiagram.h Source File

  • Source
  • Chart
XTPChartDiagram.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTDIAGRAM_H__)
24# define __XTPCHARTDIAGRAM_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartSeriesView;
34class CXTPChartElementView;
35class CXTPChartDiagramView;
36class CXTPChartSeries;
37class CXTPArcBall;
38template<class T>
39class CXTPMatrix;
40
41typedef CArray<CXTPChartSeries*, CXTPChartSeries*> CXTPChartSeriesArray;
42
47class _XTP_EXT_CLASS CXTPChartDiagram : public CXTPChartPanel
48{
50 DECLARE_DYNAMIC(CXTPChartDiagram)
52protected:
57 CXTPChartDiagram();
58
59public:
74 virtual CXTPChartDiagramView* CreateView(CXTPChartDeviceContext* pDC,
75 CXTPChartElementView* pParent);
76
88 virtual void CalculateSeriesLayout(CXTPChartDeviceContext* pDC, CXTPChartDiagramView* pView);
89
90public:
98 const CXTPChartSeriesArray& GetSeries() const;
99
100protected:
109 virtual BOOL OnSeriesAdded(CXTPChartSeries* pSeries);
110
118 void OnSeriesRemoved(CXTPChartSeries* pSeries);
119
120protected:
125 void Release();
126
127public:
134 virtual void DoPropExchange(CXTPPropExchange* pPX);
135
136public:
137 friend class CXTPChartContent;
138 friend class CXTPChartSeries;
139
140# ifdef _XTP_ACTIVEX
141public:
143 DECLARE_DISPATCH_MAP()
144 DECLARE_INTERFACE_MAP()
145 DECLARE_OLETYPELIB_EX(CXTPChartDiagram);
146 LPDISPATCH OleGetTitles();
148# endif
149
150protected:
151 CXTPChartSeriesArray m_arrSeries;
152};
153
158class _XTP_EXT_CLASS CXTPChartDiagramDomain
159{
160public:
167 CXTPChartDiagramDomain(const CXTPChartRectF& rcInnerBounds);
168
176 const CXTPChartRectF& GetInnerBounds() const;
177
178private:
179 const CXTPChartRectF m_rcInnerBounds;
180};
181
182AFX_INLINE CXTPChartDiagramDomain::CXTPChartDiagramDomain(const CXTPChartRectF& rcInnerBounds)
183 : m_rcInnerBounds(rcInnerBounds)
184{
185}
186
187AFX_INLINE const CXTPChartRectF& CXTPChartDiagramDomain::GetInnerBounds() const
188{
189 return m_rcInnerBounds;
190}
191
192AFX_INLINE const CXTPChartSeriesArray& CXTPChartDiagram::GetSeries() const
193{
194 return m_arrSeries;
195}
196
201class _XTP_EXT_CLASS CXTPChart2dDiagram : public CXTPChartDiagram
202{
204 DECLARE_DYNAMIC(CXTPChart2dDiagram)
206protected:
211 CXTPChart2dDiagram();
212};
213
218class _XTP_EXT_CLASS CXTPChart3dDiagram : public CXTPChartDiagram
219{
221 DECLARE_DYNAMIC(CXTPChart3dDiagram)
223protected:
228 CXTPChart3dDiagram();
229
234 ~CXTPChart3dDiagram();
235
236public:
238 static const float m_fChartBoxSize;
240 static const int m_nPrimitiveSize;
242 static const float m_fMinModelDistance;
244 static const float m_fMaxModelDistance;
245
254 const CXTPPoint3f& GetCameraPosition() const;
255
264 const CXTPMatrix<double>& GetViewRotationMatrix() const;
265
273 void SetArcBallBounds(double dWidth, double dHeight);
274
285 BOOL SetStartArcBallRotationPoint(POINT point);
286
297 BOOL RotateArcBallToPoint(POINT point);
298
306 void ZoomArcBall(float fDelta);
307
308private:
309 CXTPPoint3f m_ptCameraPosition;
310 CXTPArcBall* m_pArcBall;
311 CXTPMatrix<double>* m_pMatrixBeforeRotation;
312 CXTPMatrix<double>* m_pMatrixAfterRotation;
313};
314
315AFX_INLINE const CXTPPoint3f& CXTPChart3dDiagram::GetCameraPosition() const
316{
317 return m_ptCameraPosition;
318}
319
320AFX_INLINE const CXTPMatrix<double>& CXTPChart3dDiagram::GetViewRotationMatrix() const
321{
322 return *m_pMatrixAfterRotation;
323}
325# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
326#endif //#if !defined(__XTPCHARTDIAGRAM_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPArcBall
Implements natural object rotation computation using quaternions.
Definition XTPArcBall.h:43
CXTPChart2dDiagram
The base class for all 2D diagrams.
Definition XTPChartDiagram.h:202
CXTPChart2dDiagram::CXTPChart2dDiagram
CXTPChart2dDiagram()
Constructs a CXTPChartDiagram2D object.
CXTPChart3dDiagram
The base class for all 3D diagrams.
Definition XTPChartDiagram.h:219
CXTPChart3dDiagram::~CXTPChart3dDiagram
~CXTPChart3dDiagram()
Handles CXTPChart3dDiagram object destruction.
CXTPChart3dDiagram::SetArcBallBounds
void SetArcBallBounds(double dWidth, double dHeight)
Sets boundaries for arc ball used for rotating the view.
CXTPChart3dDiagram::SetStartArcBallRotationPoint
BOOL SetStartArcBallRotationPoint(POINT point)
Sets start arc ball rotation point.
CXTPChart3dDiagram::GetViewRotationMatrix
const CXTPMatrix< double > & GetViewRotationMatrix() const
Obtains view rotation matrix.
Definition XTPChartDiagram.h:320
CXTPChart3dDiagram::GetCameraPosition
const CXTPPoint3f & GetCameraPosition() const
Obtains camera coordinates in 3D space.
Definition XTPChartDiagram.h:315
CXTPChart3dDiagram::m_nPrimitiveSize
static const int m_nPrimitiveSize
The size of a primitive, the smallest part of a chart, e.g.
Definition XTPChartDiagram.h:240
CXTPChart3dDiagram::CXTPChart3dDiagram
CXTPChart3dDiagram()
Constructs a CXTPChart3dDiagram object.
CXTPChart3dDiagram::m_fChartBoxSize
static const float m_fChartBoxSize
The side of the box in 3D space within which a chart is drawn.
Definition XTPChartDiagram.h:238
CXTPChart3dDiagram::ZoomArcBall
void ZoomArcBall(float fDelta)
Zooms arc ball in or out.
CXTPChart3dDiagram::m_fMaxModelDistance
static const float m_fMaxModelDistance
The farthest possible distance to the center of a model.
Definition XTPChartDiagram.h:244
CXTPChart3dDiagram::RotateArcBallToPoint
BOOL RotateArcBallToPoint(POINT point)
Rotates arc ball to the specified point.
CXTPChart3dDiagram::m_fMinModelDistance
static const float m_fMinModelDistance
The closest possible distance to the center of a model.
Definition XTPChartDiagram.h:242
CXTPChartContent
This class represents chart content, which is a kind of CXTPChartElement.
Definition XTPChartContent.h:66
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartDiagramDomain
Represents a virtual diagram rectangular domain area.
Definition XTPChartDiagram.h:159
CXTPChartDiagramDomain::GetInnerBounds
const CXTPChartRectF & GetInnerBounds() const
Determines the domain area boundary rectangle.
Definition XTPChartDiagram.h:187
CXTPChartDiagramDomain::CXTPChartDiagramDomain
CXTPChartDiagramDomain(const CXTPChartRectF &rcInnerBounds)
Constructs a diagram domain.
Definition XTPChartDiagram.h:182
CXTPChartDiagram
This class represents a chart diagram, which is a kind of CXTPChartElement.
Definition XTPChartDiagram.h:48
CXTPChartDiagram::DoPropExchange
virtual void DoPropExchange(CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
CXTPChartDiagram::m_arrSeries
CXTPChartSeriesArray m_arrSeries
The series collection.
Definition XTPChartDiagram.h:151
CXTPChartDiagram::CXTPChartDiagram
CXTPChartDiagram()
Constructs a CXTPChartDiagram object.
CXTPChartDiagram::OnSeriesAdded
virtual BOOL OnSeriesAdded(CXTPChartSeries *pSeries)
This function is called when a series is added to the series collection in the chart content object w...
CXTPChartDiagram::OnSeriesRemoved
void OnSeriesRemoved(CXTPChartSeries *pSeries)
This function is called when a series is removed from the series collection in the chart content obje...
CXTPChartDiagram::CreateView
virtual CXTPChartDiagramView * CreateView(CXTPChartDeviceContext *pDC, CXTPChartElementView *pParent)
Call this function to create a view of the diagram.
CXTPChartDiagram::Release
void Release()
Call this function to decrease the usage count of the object.
CXTPChartDiagram::CalculateSeriesLayout
virtual void CalculateSeriesLayout(CXTPChartDeviceContext *pDC, CXTPChartDiagramView *pView)
Call this function to calculate the series layout of the diagram.
CXTPChartDiagram::GetSeries
const CXTPChartSeriesArray & GetSeries() const
Call this function to get the series collection object.
Definition XTPChartDiagram.h:192
CXTPChartDiagramView
This class represents the view of a chart diagram, which is a kind of CXTPChartElementView.
Definition XTPChartDiagramView.h:49
CXTPChartElementView
This class represents the view of a chart element.
Definition XTPChartElementView.h:47
CXTPChartPanel
This class abstracts a chart panel.
Definition XTPChartPanel.h:48
CXTPChartSeries
This class represents a series in the chart, which is a kind of CXTPChartElement.
Definition XTPChartSeries.h:50
CXTPMatrix
Represents a matrix object built upon a continuos array of elements and provides basic algorithms for...
Definition XTPMatrix.h:40
CXTPPoint3T< float >
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72
CXTPRectT< float >


Toolkit Pro: Member List

CXTPCalendarRemindersManager Member List

This is the complete list of members for CXTPCalendarRemindersManager, including all inherited members.

CXTPCalendarRemindersManager() | CXTPCalendarRemindersManager |
Dismiss(CXTPCalendarReminder *pReminder) | CXTPCalendarRemindersManager | virtual
DismissAll() | CXTPCalendarRemindersManager | virtual
GetActiveReminders(CXTPCalendarReminders &rarActiveReminders) const | CXTPCalendarRemindersManager | virtual
GetActiveRemindersCount() const | CXTPCalendarRemindersManager | virtual
GetConnection() const | CXTPCalendarRemindersManager |
IsMonitoringRunning() const | CXTPCalendarRemindersManager | virtual
m_arActiveReminders | CXTPCalendarRemindersManager | protected
m_arWaitingReminders | CXTPCalendarRemindersManager | protected
m_bMonitoringRunning | CXTPCalendarRemindersManager | protected
m_dtLastUpdateTime | CXTPCalendarRemindersManager | protected
m_pConnection | CXTPCalendarRemindersManager | protected
m_pResourcesNf | CXTPCalendarRemindersManager | protected
m_spPeriod2Cache | CXTPCalendarRemindersManager | protected
NotifyReminders(int eAction, LPARAM lParam=0) | CXTPCalendarRemindersManager | protectedvirtual
PostNotify_RemindersFire() | CXTPCalendarRemindersManager | protectedvirtual
RemoveAll() | CXTPCalendarRemindersManager | protectedvirtual
Snooze(CXTPCalendarReminder *pReminder, int nMinutesAfterNow) | CXTPCalendarRemindersManager | virtual
StartMonitoring(CXTPCalendarResources *pResources, COleDateTimeSpan spPeriod2Cache) | CXTPCalendarRemindersManager | virtual
StopMonitoring() | CXTPCalendarRemindersManager | virtual
~CXTPCalendarRemindersManager() | CXTPCalendarRemindersManager | virtual


Toolkit Pro: XTPCalendarVisualStudio2019Theme.h Source File

  • Source
  • Calendar
  • Themes
XTPCalendarVisualStudio2019Theme.h
Go to the documentation of this file.
1
22#if !defined(__XTPCALENDARVISUALSTUDIO2019THEME_H__)
23# define __XTPCALENDARVISUALSTUDIO2019THEME_H__
24
25# if _MSC_VER > 1000
26# pragma once
27# endif // _MSC_VER > 1000
28
29# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
30
36class _XTP_EXT_CLASS CXTPCalendarVisualStudio2019Theme : public CXTPCalendarOffice2013Theme
37{
38public:
47 CXTPCalendarVisualStudio2019Theme();
48
55 virtual ~CXTPCalendarVisualStudio2019Theme();
56};
57
58# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
59#endif // !defined(__XTPCALENDARVISUALSTUDIO2019THEME_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCalendarOffice2013Theme
CXTPCalendarOffice2013Theme is a CXTPCalendarOffice2000Theme derived class that represents the Office...
Definition XTPCalendarOffice2013Theme.h:37
CXTPCalendarVisualStudio2019Theme
CXTPCalendarVisualStudio2019Theme is a CXTPCalendarOffice2013Theme derived class that represents the ...
Definition XTPCalendarVisualStudio2019Theme.h:37
CXTPCalendarVisualStudio2019Theme::CXTPCalendarVisualStudio2019Theme
CXTPCalendarVisualStudio2019Theme()
Default paint manager constructor.
CXTPCalendarVisualStudio2019Theme::~CXTPCalendarVisualStudio2019Theme
virtual ~CXTPCalendarVisualStudio2019Theme()
Default paint manager destructor.


Toolkit Pro: Member List

CXTPDockingPaneVisualStudio2003Theme Member List

This is the complete list of members for CXTPDockingPaneVisualStudio2003Theme, including all inherited members.

AdjustCaptionRect(const CXTPDockingPaneSidePanel *pPane, CRect &rc) | CXTPDockingPanePaintManager | virtual
AdjustCaptionRect(const CXTPDockingPaneTabbedContainer *pPane, CRect &rc) | CXTPDockingPanePaintManager | virtual
AdjustClientRect(CXTPDockingPaneSidePanel *pPane, CRect &rect) | CXTPDockingPanePaintManager | virtual
AdjustClientRect(CXTPDockingPaneTabbedContainer *pPane, CRect &rect, BOOL bApply) | CXTPDockingPanePaintManager | virtual
ClipAndAddEllipsisIfNeeded(CDC *pDC, CString &strTitle, int nCaptionWidth) const | CXTPDockingPanePaintManager | protected
CXTPCmdTarget() | CXTPCmdTarget |
CXTPDockingPaneDefaultTheme() | CXTPDockingPaneDefaultTheme |
CXTPDockingPaneGripperedTheme() | CXTPDockingPaneGripperedTheme |
CXTPDockingPanePaintManager() | CXTPDockingPanePaintManager | protected
CXTPDockingPaneVisualStudio2003Theme() | CXTPDockingPaneVisualStudio2003Theme |
DrawAutoHidePanel(CDC *pDC, CRect rc, XTPDockingPaneDirection direction) | CXTPDockingPanePaintManager | virtual
DrawCaption(CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc) | CXTPDockingPaneGripperedTheme | virtual
DrawCaptionButton(CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton) | CXTPDockingPanePaintManager | virtual
DrawCaptionButtonEntry(CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton, CSize szOffset) | CXTPDockingPanePaintManager | protectedvirtual
DrawCaptionButtonEntry(CDC *pDC, CXTPDockingPaneCaptionButton *pButton, CPoint pt, COLORREF clrButton) | CXTPDockingPanePaintManager | protectedvirtual
DrawCaptionButtons(CDC *pDC, CXTPDockingPaneCaptionButtons *pButtons, CRect &rcCaption, COLORREF clr, int nButtonSize, int nButtonGap, BOOL bVertical=FALSE) | CXTPDockingPanePaintManager | virtual
DrawCaptionPart(CDC *pDC, CXTPDockingPaneBase *pPane, CRect rcCaption, const CString &strTitle, BOOL bActive, BOOL bVertical) | CXTPDockingPaneVisualStudio2003Theme | protectedvirtual
DrawCaptionText(CDC *pDC, const CString &strTitle, CRect rc, BOOL bVertical, BOOL bCalcWidth=FALSE) | CXTPDockingPanePaintManager |
DrawFloatingFrame(CDC *pDC, CXTPDockingPaneMiniWnd *pPane, CRect rc) | CXTPDockingPaneGripperedTheme | virtual
DrawPane(CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc) | CXTPDockingPanePaintManager | virtual
DrawSidePanel(CDC *pDC, CXTPDockingPaneSidePanel *pPane, CRect rc) | CXTPDockingPaneDefaultTheme | virtual
DrawSplitter(CDC *pDC, CXTPDockingPaneSplitterWnd *pSplitter) | CXTPDockingPanePaintManager | virtual
FillCaptionPart(CDC *pDC, CXTPDockingPaneBase *pPane, CRect rcCaption, BOOL bActive, BOOL bVertical) | CXTPDockingPaneVisualStudio2003Theme | protectedvirtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCaptionButtonStyle() const | CXTPDockingPanePaintManager |
GetCaptionGripperRect(const CXTPDockingPaneTabbedContainer *pPane) | CXTPDockingPanePaintManager | virtual
GetCaptionHeight() const | CXTPDockingPanePaintManager |
GetCaptionRect(const CXTPDockingPaneTabbedContainer *pPane, CRect &rc) | CXTPDockingPanePaintManager | virtual
GetCurrentSystemTheme() const | CXTPDockingPanePaintManager |
GetCustomTitleBrush(BOOL bActive, BOOL bVertical) const | CXTPDockingPanePaintManager |
GetPaneCaptionRect(const CXTPDockingPaneSidePanel *pPane) | CXTPDockingPanePaintManager | virtual
GetPanelPaintManager() const | CXTPDockingPanePaintManager |
GetSplitterStyle() const | CXTPDockingPanePaintManager |
GetTabPaintManager() const | CXTPDockingPanePaintManager |
GetTabsHeight() const | CXTPDockingPanePaintManager |
GetXtremeColor(UINT nIndex) | CXTPDockingPanePaintManager |
Line(CDC *pDC, int x0, int y0, int x1, int y1, int nPen) | CXTPDockingPanePaintManager |
Line(CDC *pDC, int x0, int y0, int x1, int y1) | CXTPDockingPanePaintManager |
m_arrColor | CXTPDockingPanePaintManager | protected
m_bDestroyCustomTitleBrushes | CXTPDockingPanePaintManager | protected
m_bDrawCaptionIcon | CXTPDockingPanePaintManager |
m_bDrawSingleTab | CXTPDockingPanePaintManager |
m_bGradientCaption | CXTPDockingPaneVisualStudio2003Theme | protected
m_bHighlightActiveCaption | CXTPDockingPanePaintManager |
m_bLunaTheme | CXTPDockingPanePaintManager | protected
m_bShowCaption | CXTPDockingPanePaintManager |
m_bUseBoldCaptionFont | CXTPDockingPanePaintManager |
m_bUseOfficeFont | CXTPDockingPanePaintManager | protected
m_bUseStandardFont | CXTPDockingPanePaintManager | protected
m_clrActiveCaption | CXTPDockingPanePaintManager |
m_clrActiveCaptionText | CXTPDockingPanePaintManager |
m_clrBackground | CXTPDockingPanePaintManager |
m_clrDisabledCaptionText | CXTPDockingPanePaintManager |
m_clrNormalCaption | CXTPDockingPanePaintManager |
m_clrNormalCaptionText | CXTPDockingPanePaintManager |
m_clrSplitter | CXTPDockingPanePaintManager |
m_clrSplitterGradient | CXTPDockingPanePaintManager |
m_clrSplitterGripper | CXTPDockingPanePaintManager |
m_dwSplitterStyle | CXTPDockingPanePaintManager | protected
m_hbrActiveTitleHorz | CXTPDockingPanePaintManager | protected
m_hbrActiveTitleVert | CXTPDockingPanePaintManager | protected
m_hbrInactiveTitleHorz | CXTPDockingPanePaintManager | protected
m_hbrInactiveTitleVert | CXTPDockingPanePaintManager | protected
m_nCaptionButtonStyle | CXTPDockingPanePaintManager | protected
m_nCaptionFontGap | CXTPDockingPanePaintManager | protected
m_nSplitterIndent | CXTPDockingPanePaintManager |
m_nSplitterSize | CXTPDockingPanePaintManager |
m_nTabsHeight | CXTPDockingPanePaintManager | protected
m_nTitleHeight | CXTPDockingPanePaintManager | protected
m_pPanelPaintManager | CXTPDockingPanePaintManager | protected
m_pTabPaintManager | CXTPDockingPanePaintManager | protected
m_rcCaptionMargin | CXTPDockingPanePaintManager | protected
m_strOfficeFont | CXTPDockingPanePaintManager | protected
m_systemTheme | CXTPDockingPanePaintManager | protected
m_themeButton | CXTPDockingPanePaintManager | protected
m_themeCurrent | CXTPDockingPanePaintManager | protected
m_themeExplorer | CXTPDockingPanePaintManager | protected
m_themeRebar | CXTPDockingPanePaintManager | protected
m_themeToolbar | CXTPDockingPanePaintManager | protected
m_themeWindow | CXTPDockingPanePaintManager | protected
m_xtpFontTitle | CXTPDockingPanePaintManager | protected
m_xtpFontTitleVertical | CXTPDockingPanePaintManager | protected
Pixel(CDC *pDC, int xPos, int yPos, int nPen) | CXTPDockingPanePaintManager |
Rectangle(CDC *pDC, CRect rc, int nPenEntry, int nPenBorder) | CXTPDockingPanePaintManager |
RefreshMetrics() | CXTPDockingPaneVisualStudio2003Theme | virtual
SetCaptionButtonStyle(XTPDockingPaneCaptionButtonStyle nStyle) | CXTPDockingPanePaintManager |
SetCaptionFontIndirect(LOGFONT *pLogFont, BOOL bUseStandardFont=FALSE) | CXTPDockingPanePaintManager |
SetColors(int cElements, CONST INT *lpaElements, CONST COLORREF *lpaRgbValues) | CXTPDockingPanePaintManager |
SetCustomTitleBrushes(HBRUSH hbrActiveTitleHorz, HBRUSH hbrInactiveTitleHorz=NULL, HBRUSH hbrActiveTitleVert=NULL, HBRUSH hbrInactiveTitleVert=NULL, BOOL bDestroyOnCleanup=FALSE) | CXTPDockingPanePaintManager |
SetLunaTheme(XTPCurrentSystemTheme systemTheme) | CXTPDockingPanePaintManager |
SetPanelPaintManager(CXTPTabPaintManager *pManager) | CXTPDockingPanePaintManager |
SetSplitterStyle(DWORD dwStyle) | CXTPDockingPanePaintManager |
SetTabPaintManager(CXTPTabPaintManager *pManager) | CXTPDockingPanePaintManager |
UseOfficeFont(BOOL bUseOfficeFont) | CXTPDockingPanePaintManager |
~CXTPDockingPanePaintManager() | CXTPDockingPanePaintManager | protectedvirtual


Toolkit Pro: Member List

XTP_TVITEMDATA Member List

This is the complete list of members for XTP_TVITEMDATA, including all inherited members.

lpi | XTP_TVITEMDATA
lpifq | XTP_TVITEMDATA
lpsfParent | XTP_TVITEMDATA


Toolkit Pro: XTPTextPreviewProvider.h Source File

  • Source
  • Controls
  • Preview
  • Providers
  • Text
XTPTextPreviewProvider.h
Go to the documentation of this file.
1
23#if !defined(__XTPTEXTPREVIEWPROVIDER_H__)
24# define __XTPTEXTPREVIEWPROVIDER_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
41class _XTP_EXT_CLASS CXTPTextPreviewProvider : public CXTPPreviewProviderBase
42{
43private:
44 virtual LPCTSTR GetDefaultFileAssociations() const;
45 virtual IXTPPreview* CreatePreview(LPCTSTR pFilePath, HWND hwndParent);
46 virtual IXTPPreview* CreatePreview(IStream& stream, LPCTSTR pImpliedFileName, HWND hwndParent);
47};
48
49# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
51#endif // #if !defined(__XTPTEXTPREVIEWPROVIDER_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPPreviewProviderBase
Base class for a preview provider which implements common behavior to be exposed by a preview provide...
Definition XTPPreviewAbstract.h:251
CXTPTextPreviewProvider
Provides a preview handler for the text file type (TXT).
Definition XTPTextPreviewProvider.h:42
IXTPPreview
The base interface for a preview handler implementation.
Definition XTPPreviewAbstract.h:40
IXTPPreviewProvider::GetDefaultFileAssociations
virtual LPCTSTR GetDefaultFileAssociations() const =0
Obtains the list of file extensions supported by the associated preview implementation.
IXTPPreviewProvider::CreatePreview
virtual IXTPPreview * CreatePreview(LPCTSTR pFilePath, HWND hwndParent)=0
Creates a preview object for the specified file.


Toolkit Pro: XTPChartPie.h Source File

  • Source
  • Chart
  • Types
XTPChartPie.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTPIE_H__)
24# define __XTPCHARTPIE_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartPieBase;
34class CXTPChartDeviceCommand;
35class CXTPChartBounds;
36
41class _XTP_EXT_CLASS CXTPChartEllipse
42{
43public:
48 CXTPChartEllipse();
49
58 CXTPChartEllipse(const CXTPPoint3d& ptCenter, double dMajorSemiaxis, double dMinorSemiaxis);
59
60public:
67 double GetArea() const;
74 CXTPPoint3d GetCenter() const;
75
84 double CalcEllipseSectorFinishAngle(double areaSector, double startAngle) const;
85
86public:
97 CXTPPoint3d Polar2Cartesian(double angle, double radius) const;
98
108 double CalcEllipseRadius(double angle) const;
109
119 CXTPPoint3d CalcEllipsePoint(double angle) const;
120
131 double CalcEllipseSectorArea(double startAngle, double finishAngle) const;
132
141 double CalcEllipseAngleFromCircleAngle(double angle) const;
142
151 CXTPPoint3d ApplyCenterPoint(const CXTPPoint3d& point) const;
152
154 double AtanMulTan(double multiplier, double tanAngle) const;
157public:
158 CXTPPoint3d m_ptCenter;
159 double m_dMajorSemiaxis;
160 double m_dMinorSemiaxis;
161 double m_dArea;
163 friend class CXTPChartPieBase;
164};
165
166AFX_INLINE double CXTPChartEllipse::GetArea() const
167{
168 return m_dArea;
169}
170
175class _XTP_EXT_CLASS CXTPChartPieBase : public CObject
176{
177 DECLARE_DYNAMIC(CXTPChartPieBase);
178
179protected:
190 CXTPChartPieBase(double dStartAngle, double dFinishAngle, const CXTPChartEllipse& ellipse,
191 int nDepthPercent, int nHolePercent);
192
193public:
198 virtual ~CXTPChartPieBase();
199
200public:
209 CXTPPoint3d CalculateCenter(const CXTPChartPointF& basePoint) const;
210
211public:
225 virtual CXTPChartDeviceCommand* CreatePieDeviceCommand(const CXTPChartColor& color,
226 const CXTPChartColor& color2,
227 const CXTPChartPointF& basePoint) = 0;
228
242 virtual CXTPChartDeviceCommand* CreateBoundedPieDeviceCommand(
243 const CXTPChartColor& color, int nThickness, const CXTPChartPointF& basePoint) = 0;
244
251 double GetHalfAngle() const;
252
259 double GetStartAngle() const;
260
267 CXTPChartPointF GetFinishPoint() const;
268
275 CXTPChartPointF GetStartPoint() const;
276
283 CXTPChartPointF GetCenterPoint() const;
284
291 CXTPChartRectF GetBounds() const;
292
299 int GetHolePercent() const;
300
301protected:
307 void UpdateBounds();
308
310 void UpdateBounds(CXTPChartBounds* bounds, CXTPChartEllipse& ellipse);
313protected:
314 CXTPChartEllipse m_ellipse;
315 double m_dStartAngle;
316 double m_dSweepAngle;
317 double m_depth;
318 int m_nHolePercent;
319 CXTPChartRectF m_anchorBounds;
320};
321
322AFX_INLINE CXTPPoint3d CXTPChartEllipse::GetCenter() const
323{
324 return m_ptCenter;
325}
326AFX_INLINE double CXTPChartPieBase::GetStartAngle() const
327{
328 return m_dStartAngle;
329}
330AFX_INLINE int CXTPChartPieBase::GetHolePercent() const
331{
332 return m_nHolePercent;
333}
335# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
336#endif //#if !defined(__XTPCHARTPIE_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartColor
This class abstracts a color entity.
Definition XTPChartTypes.h:51
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPChartEllipse
This class abstracts an ellipse.
Definition XTPChartPie.h:42
CXTPChartEllipse::m_dMinorSemiaxis
double m_dMinorSemiaxis
The minor semi axis of the ellipse.
Definition XTPChartPie.h:160
CXTPChartEllipse::m_ptCenter
CXTPPoint3d m_ptCenter
The center of the ellipse.
Definition XTPChartPie.h:158
CXTPChartEllipse::Polar2Cartesian
CXTPPoint3d Polar2Cartesian(double angle, double radius) const
Call this function to convert polar coordinates to Cartesian co-ordinates.
CXTPChartEllipse::GetCenter
CXTPPoint3d GetCenter() const
Call this function to get the center of the ellipse.
Definition XTPChartPie.h:322
CXTPChartEllipse::ApplyCenterPoint
CXTPPoint3d ApplyCenterPoint(const CXTPPoint3d &point) const
Call this function to apply the center point of the ellipse.
CXTPChartEllipse::CalcEllipseSectorArea
double CalcEllipseSectorArea(double startAngle, double finishAngle) const
Call this function to calculate the sector area from a start angle and finish angle.
CXTPChartEllipse::CalcEllipseSectorFinishAngle
double CalcEllipseSectorFinishAngle(double areaSector, double startAngle) const
Call this function to get the finish angle from a start angle and area of a sector.
CXTPChartEllipse::m_dMajorSemiaxis
double m_dMajorSemiaxis
The major semi axis of the ellipse.
Definition XTPChartPie.h:159
CXTPChartEllipse::CalcEllipsePoint
CXTPPoint3d CalcEllipsePoint(double angle) const
Call this function to calculate the ellipse Cartesian point on a given angle.
CXTPChartEllipse::m_dArea
double m_dArea
The area of the ellipse.
Definition XTPChartPie.h:161
CXTPChartEllipse::CalcEllipseRadius
double CalcEllipseRadius(double angle) const
Call this function to calculate the radius of the ellipse from the given angle.
CXTPChartEllipse::CXTPChartEllipse
CXTPChartEllipse()
Constructs a CXTPChartEllipse object.
CXTPChartEllipse::CalcEllipseAngleFromCircleAngle
double CalcEllipseAngleFromCircleAngle(double angle) const
Call this function to calculate the ellipse angle from the circle angle.
CXTPChartEllipse::GetArea
double GetArea() const
Call this function to get the area of the ellipse.
Definition XTPChartPie.h:166
CXTPChartEllipse::CXTPChartEllipse
CXTPChartEllipse(const CXTPPoint3d &ptCenter, double dMajorSemiaxis, double dMinorSemiaxis)
Overloaded constructor, creates a CXTPChartSplineSeriesView object.
CXTPChartPieBase
This class abstracts a pie chart.
Definition XTPChartPie.h:176
CXTPChartPieBase::GetHalfAngle
double GetHalfAngle() const
Call this function to get the half angle of the pie slice.
CXTPChartPieBase::UpdateBounds
void UpdateBounds()
Call this function to update the bounds of the pie when there is a change in the start angle and/or s...
CXTPChartPieBase::GetHolePercent
int GetHolePercent() const
Call this function to get the hole percentage of the pie chart.
Definition XTPChartPie.h:330
CXTPChartPieBase::m_ellipse
CXTPChartEllipse m_ellipse
The ellipse associated with the pie chart.
Definition XTPChartPie.h:314
CXTPChartPieBase::m_nHolePercent
int m_nHolePercent
The hole percentage.
Definition XTPChartPie.h:318
CXTPChartPieBase::CalculateCenter
CXTPPoint3d CalculateCenter(const CXTPChartPointF &basePoint) const
Call this function to calculate the ceter of the pie.
CXTPChartPieBase::CreatePieDeviceCommand
virtual CXTPChartDeviceCommand * CreatePieDeviceCommand(const CXTPChartColor &color, const CXTPChartColor &color2, const CXTPChartPointF &basePoint)=0
This function creates a CXTPChartDeviceCommand object.
CXTPChartPieBase::~CXTPChartPieBase
virtual ~CXTPChartPieBase()
Destroys a CXTPChartPieBase object, handles cleanup and deallocation.
CXTPChartPieBase::CXTPChartPieBase
CXTPChartPieBase(double dStartAngle, double dFinishAngle, const CXTPChartEllipse &ellipse, int nDepthPercent, int nHolePercent)
Constructs a CXTPChartPieBase object.
CXTPChartPieBase::m_dSweepAngle
double m_dSweepAngle
The sweep angle of the slice.
Definition XTPChartPie.h:316
CXTPChartPieBase::m_depth
double m_depth
The depth of the 3D pie.
Definition XTPChartPie.h:317
CXTPChartPieBase::GetStartPoint
CXTPChartPointF GetStartPoint() const
Call this function to get the finish/start point of the pie slice.
CXTPChartPieBase::m_anchorBounds
CXTPChartRectF m_anchorBounds
The anchor bounds.
Definition XTPChartPie.h:319
CXTPChartPieBase::CreateBoundedPieDeviceCommand
virtual CXTPChartDeviceCommand * CreateBoundedPieDeviceCommand(const CXTPChartColor &color, int nThickness, const CXTPChartPointF &basePoint)=0
This function creates a CXTPChartDeviceCommand object.
CXTPChartPieBase::GetFinishPoint
CXTPChartPointF GetFinishPoint() const
Call this function to get the finish/start point of the pie slice.
CXTPChartPieBase::m_dStartAngle
double m_dStartAngle
The start angle of the slice.
Definition XTPChartPie.h:315
CXTPChartPieBase::GetCenterPoint
CXTPChartPointF GetCenterPoint() const
Call this function to get the center point of the pie slice.
CXTPChartPieBase::GetStartAngle
double GetStartAngle() const
Call this function to get the start angle of the pie slice.
Definition XTPChartPie.h:326
CXTPChartPieBase::GetBounds
CXTPChartRectF GetBounds() const
Call this function to get the bounding rectangle of the pie chart.
CXTPPoint2T< float >
CXTPPoint3T< double >
CXTPRectT< float >


Toolkit Pro: Member List

CXTPChartRadarSplineSeriesStyle Member List

This is the complete list of members for CXTPChartRadarSplineSeriesStyle, including all inherited members.

ApplyTo(CXTPChartDeviceCommand *pCommand) | CXTPChartSeriesStyle | virtual
CorrectAxisSideMargins(CXTPChartAxis *pAxis, double nMinValue, double nMaxValue, double &nCorrection) | CXTPChartSeriesStyle | virtual
CreateDiagram() | CXTPChartRadarDiagramSeriesStyle | virtual
CreateView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView) | CXTPChartRadarSplineSeriesStyle | protectedvirtual
CXTPChartElement() | CXTPChartElement |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartRadarDiagramSeriesStyle() | CXTPChartRadarDiagramSeriesStyle |
CXTPChartRadarLineSeriesStyle() | CXTPChartRadarLineSeriesStyle |
CXTPChartRadarPointSeriesStyle() | CXTPChartRadarPointSeriesStyle |
CXTPChartRadarSplineSeriesStyle() | CXTPChartRadarSplineSeriesStyle |
CXTPChartSeriesStyle() | CXTPChartSeriesStyle |
DoPropExchange(CXTPPropExchange *pPX) | CXTPChartRadarLineSeriesStyle | virtual
Enable3dEdgeSmoothing(BOOL bEnable=TRUE) | CXTPChartSeriesStyle | virtual
Get3dRotation() const | CXTPChartSeriesStyle | virtual
GetAppearance() const | CXTPChartElement |
GetColor() const | CXTPChartSeriesStyle | virtual
GetContent() const | CXTPChartElement |
GetErrorBar() const | CXTPChartSeriesStyle | virtual
GetLabel() const | CXTPChartSeriesStyle | virtual
GetLineStyle() const | CXTPChartRadarLineSeriesStyle |
GetMarker() const | CXTPChartRadarPointSeriesStyle |
GetOwner() const | CXTPChartElement |
GetSeriesPointValueIndex() const | CXTPChartSeriesStyle | virtual
GetStyleAppearance() const | CXTPChartSeriesStyle | virtual
GetTransparency() const | CXTPChartSeriesStyle | virtual
Is3D() const | CXTPChartObject |
Is3dEdgeSmoothingEnabled() const | CXTPChartSeriesStyle | virtual
IsColorEach() const | CXTPChartSeriesStyle | virtual
IsStyleDiagram(CXTPChartDiagram *pDiagram) const | CXTPChartRadarDiagramSeriesStyle | virtual
m_bColorEach | CXTPChartSeriesStyle | protected
m_bSmooth3dEdges | CXTPChartSeriesStyle | protected
m_clrColor | CXTPChartSeriesStyle | protected
m_nTransparency | CXTPChartSeriesStyle | protected
m_pErrorBar | CXTPChartSeriesStyle | protected
m_pLabel | CXTPChartSeriesStyle | protected
m_Rotation3d | CXTPChartSeriesStyle | protected
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartElement | virtual
Release() | CXTPChartElement | virtual
Set3dRotation(const CXTPChart3dRotation &rotation) | CXTPChartSeriesStyle | virtual
Set3dRotation(double dYaw, double dPitch, double dRoll) | CXTPChartSeriesStyle | virtual
SetColor(CXTPChartColor clr) | CXTPChartSeriesStyle | virtual
SetColorEach(BOOL bColorEach) | CXTPChartSeriesStyle | virtual
SetErrorBar(CXTPChartErrorBar *pErrorBar) | CXTPChartSeriesStyle | virtual
SetLabel(CXTPChartSeriesLabel *pLabel) | CXTPChartSeriesStyle | virtual
SetTransparency(int nTransparency) | CXTPChartSeriesStyle | virtual
~CXTPChartElement() | CXTPChartElement | virtual
~CXTPChartRadarDiagramSeriesStyle() | CXTPChartRadarDiagramSeriesStyle | virtual
~CXTPChartRadarLineSeriesStyle() | CXTPChartRadarLineSeriesStyle | virtual
~CXTPChartRadarPointSeriesStyle() | CXTPChartRadarPointSeriesStyle | virtual
~CXTPChartRadarSplineSeriesStyle() | CXTPChartRadarSplineSeriesStyle | virtual
~CXTPChartSeriesStyle() | CXTPChartSeriesStyle | virtual


Toolkit Pro: XTPChart2dPyramidSeriesPointView.h Source File

  • Source
  • Chart
  • Styles
  • Pyramid
  • 2D
XTPChart2dPyramidSeriesPointView.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHART2DPYRAMIDSERIESPOINTVIEW_H__)
24# define __XTPCHART2DPYRAMIDSERIESPOINTVIEW_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartSeriesPoint;
34class CXTPChartElementView;
35class CXTPChartDeviceCommand;
36class CXTPChartDeviceContext;
37
49class _XTP_EXT_CLASS CXTPChartPyramidSeriesPointView : public CXTPChartPyramidSeriesPointViewBase
50{
51 DECLARE_DYNAMIC(CXTPChartPyramidSeriesPointView);
52
53public:
61 CXTPChartPyramidSeriesPointView(CXTPChartSeriesPoint* pPoint,
62 CXTPChartElementView* pParentView);
63
72 CXTPChartPyramidSeriesPointView(CXTPChartSeriesPoint* pPoint, CXTPChartElementView* pParentView,
73 BOOL bAddToParent);
74
75public:
85 void CalculateLayout(int nIndex, int nCount, double dFrom, double dTo);
86
87protected:
100 virtual CXTPChartDeviceCommand* CreateDeviceCommand(CXTPChartDeviceContext* pDC);
101
102public:
103 CXTPChartRectF m_rc;
104
105 double m_dFrom;
106 double m_dTo;
107};
109# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
110#endif //#if !defined(__XTPCHART2DPYRAMIDSERIESPOINTVIEW_H__)
pPoint
const CPoint * pPoint
return 0 or xtpCalendarHitTestDayExpandButton
Definition XTPCalendarThemeOffice2007.h:150
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartElementView
This class represents the view of a chart element.
Definition XTPChartElementView.h:47
CXTPChartPyramidSeriesPointViewBase
This class abstracts the view of a pyramid series point.
Definition XTPChartPyramidSeriesPointViewBase.h:46
CXTPChartPyramidSeriesPointView
This class abstracts the view of a pyramid series point.
Definition XTPChart2dPyramidSeriesPointView.h:50
CXTPChartPyramidSeriesPointView::CXTPChartPyramidSeriesPointView
CXTPChartPyramidSeriesPointView(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Constructs a CXTPChartPyramidSeriesPointView object.
CXTPChartPyramidSeriesPointView::CalculateLayout
void CalculateLayout(int nIndex, int nCount, double dFrom, double dTo)
Use this function to calculate the layout of the pyramid series point.
CXTPChartPyramidSeriesPointView::CreateDeviceCommand
virtual CXTPChartDeviceCommand * CreateDeviceCommand(CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
CXTPChartPyramidSeriesPointView::CXTPChartPyramidSeriesPointView
CXTPChartPyramidSeriesPointView(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView, BOOL bAddToParent)
Constructs a CXTPChartPyramidSeriesPointView object.
CXTPChartSeriesPoint
CXTPChartSeriesPoint is a kind of CXTPChartElement.
Definition XTPChartSeriesPoint.h:43
CXTPRectT< float >


Toolkit Pro: XTPGalleryListBox.h Source File

  • Source
  • CommandBars
  • Gallery
XTPGalleryListBox.h
Go to the documentation of this file.
1
23#if !defined(__XTPGALLERYLISTBOX_H__)
24# define __XTPGALLERYLISTBOX_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPRecentFileListItem;
34
35class _XTP_EXT_CLASS CXTPGalleryListBoxSeparatorItem : public CXTPControlGalleryItem
36{
37 DECLARE_DYNAMIC(CXTPGalleryListBoxSeparatorItem);
38
39public:
40 CXTPGalleryListBoxSeparatorItem();
41
42public:
43 virtual CSize GetSize();
44 virtual void Draw(CDC* pDC, CXTPControlGallery* pGallery, CRect rcItem, BOOL bEnabled,
45 BOOL bSelected, BOOL bPressed, BOOL bChecked);
46
47protected:
48};
49
50class _XTP_EXT_CLASS CXTPRecentFileListBoxItem : public CXTPControlGalleryItem
51{
52 DECLARE_DYNAMIC(CXTPRecentFileListBoxItem);
53
54public:
55 CXTPRecentFileListBoxItem(CXTPRecentFileListItem* pRecentItem);
56
57 BOOL GetUseShellIcon() const;
58 void SetUseShellIcon(BOOL bUseShellIcon);
59
60public:
61 virtual CSize GetSize();
62 virtual void Draw(CDC* pDC, CXTPControlGallery* pGallery, CRect rcItem, BOOL bEnabled,
63 BOOL bSelected, BOOL bPressed, BOOL bChecked);
64
65 CXTPRecentFileListItem* GetRecentItem() const;
66
67 virtual int GetImageIndex();
68 virtual void SetImageIndex(int nImageIndex);
69
70protected:
71 CXTPRecentFileListItem* m_pRecentItem;
72 BOOL m_bUseShellIcon;
75};
76
77AFX_INLINE CXTPRecentFileListItem* CXTPRecentFileListBoxItem::GetRecentItem() const
78{
79 return m_pRecentItem;
80}
81
82AFX_INLINE BOOL CXTPRecentFileListBoxItem::GetUseShellIcon() const
83{
84 return m_bUseShellIcon;
85}
86
87AFX_INLINE void CXTPRecentFileListBoxItem::SetUseShellIcon(BOOL bUseShellIcon)
88{
89 m_bUseShellIcon = bUseShellIcon;
90}
91
92class _XTP_EXT_CLASS CXTPRecentFileListBoxPinItem : public CXTPControlGalleryItem
93{
94 DECLARE_DYNAMIC(CXTPRecentFileListBoxPinItem);
95
96public:
97 CXTPRecentFileListBoxPinItem(CXTPRecentFileListItem* pRecentItem);
98
99public:
100 virtual CSize GetSize();
101 virtual BOOL OnClick();
102 virtual void Draw(CDC* pDC, CXTPControlGallery* pGallery, CRect rcItem, BOOL bEnabled,
103 BOOL bSelected, BOOL bPressed, BOOL bChecked);
104
105protected:
106 CXTPRecentFileListItem* m_pRecentItem;
107};
108
109class _XTP_EXT_CLASS CXTPGalleryListBox : public CXTPCommandBar
110{
111 // Construction
112public:
113 CXTPGalleryListBox();
114 virtual ~CXTPGalleryListBox();
115
116public:
117 void RecalcLayout();
118 BOOL IsVisible() const;
119
120 // Operations
121public:
122 CXTPControlGallery* GetGallery() const;
123 CXTPControlGalleryItems* GetItems() const;
124
125 CXTPToolTipContext* GetToolTipContext() const;
126
127 // Implementation
128public:
129 virtual void OnExecute();
130
131protected:
132 void FillCommandBarEntry(CDC* pDC);
133
134 //{{AFX_VIRTUAL(CXTPGalleryListBox)
135 virtual BOOL OnWndMsg(UINT message, WPARAM wParam, LPARAM lParam, LRESULT* pResult);
136 //}}AFX_VIRTUAL
137
138 //{{AFX_MSG(CXTPGalleryListBox)
139 afx_msg void OnSize(UINT nType, int cx, int cy);
140 afx_msg void OnLButtonDown(UINT nFlags, CPoint point);
141 afx_msg void OnKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags);
142 afx_msg UINT OnGetDlgCode();
143 afx_msg BOOL OnMouseWheel(UINT nFlags, short zDelta, CPoint pt);
144 afx_msg void OnSetFocus(CWnd* pOldWnd);
145 afx_msg void OnKillFocus(CWnd* pNewWnd);
146 afx_msg void OnMouseMove(UINT nFlags, CPoint point);
147 //}}AFX_MSG
149 DECLARE_MESSAGE_MAP()
151protected:
152 CXTPControlGallery* m_pGallery;
153 CXTPControlGalleryItems* m_pItems;
154 CPoint m_ptLastMousePos;
155};
156
157class _XTP_EXT_CLASS CXTPRecentFileListBox : public CXTPGalleryListBox
158{
159public:
160 CXTPRecentFileListBox();
161
162public:
163 void BuildItems();
164 void BuildItems(CXTPRecentFileList* pRecentFileList);
165
166 BOOL GetUseShellIcon() const;
167 void SetUseShellIcon(BOOL bUseShellIcon);
168
169 CRecentFileList* GetRecentFileList() const;
170
171protected:
172 BOOL m_bUseShellIcon;
173};
174
175AFX_INLINE BOOL CXTPRecentFileListBox::GetUseShellIcon() const
176{
177 return m_bUseShellIcon;
178}
179
180AFX_INLINE CXTPControlGalleryItems* CXTPGalleryListBox::GetItems() const
181{
182 return m_pItems;
183}
184
185AFX_INLINE CXTPControlGallery* CXTPGalleryListBox::GetGallery() const
186{
187 return m_pGallery;
188}
189AFX_INLINE BOOL CXTPGalleryListBox::IsVisible() const
190{
191 return m_hWnd && IsWindowVisible();
192}
193AFX_INLINE CXTPToolTipContext* CXTPGalleryListBox::GetToolTipContext() const
194{
195 return m_pToolTipContext;
196}
197
199# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
200#endif // !defined(__XTPGALLERYLISTBOX_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCommandBar
CXTPCommandBar is a CWnd derived class.
Definition XTPCommandBar.h:66
CXTPControlGallery
CXTPControlGallery is a CXTPControlPopup derived class.
Definition XTPControlGallery.h:63
CXTPControlGalleryItem
CXTPControlGalleryItem is a CXTPCmdTarget derived class.
Definition XTPControlGalleryItem.h:39
CXTPControlGalleryItem::SetImageIndex
virtual void SetImageIndex(int nImageIndex)
Sets the preferred image index.
CXTPControlGalleryItem::m_pItems
CXTPControlGalleryItems * m_pItems
Parent items collection.
Definition XTPControlGalleryItem.h:264
CXTPControlGalleryItem::GetSize
virtual CSize GetSize()
This method is called to get the size of the item.
CXTPControlGalleryItem::Draw
virtual void Draw(CDC *pDC, CXTPControlGallery *pGallery, CRect rcItem, BOOL bEnabled, BOOL bSelected, BOOL bPressed, BOOL bChecked)
This method is called to draw the item.
CXTPControlGalleryItem::GetImageIndex
virtual int GetImageIndex()
Gets the index of the used image.
CXTPControlGalleryItems
CXTPControlGalleryItems is a CXTPCmdTarget derived class.
Definition XTPControlGalleryItems.h:39
CXTPRecentFileList
CXTPRecentFileList is a CRecentFileList derived class.
Definition XTPRecentFileList.h:88
CXTPToolTipContext
CXTPToolTipContext is a CXTPCmdTarget derived class.
Definition XTPToolTipContext.h:291


Toolkit Pro: XTPScrollBarThemeVisualStudio2015.h Source File

  • Source
  • Common
  • ScrollBar
  • Themes
XTPScrollBarThemeVisualStudio2015.h
Go to the documentation of this file.
1
23#if !defined(__XTPSCROLLBARTHEMEVISUALSTUDIO2015_H__)
24# define __XTPSCROLLBARTHEMEVISUALSTUDIO2015_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPScrollBarThemeVisualStudio2015 : public CXTPScrollBarThemeVisualStudio2012
39{
40protected:
41 virtual void DrawScrollBar(CDC* pDC, CXTPScrollBase* pScrollBar);
42};
43
44# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
46#endif // !defined(__XTPSCROLLBARTHEMEVISUALSTUDIO2015_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPScrollBarThemeVisualStudio2012
Scrollbar paint manager used to draw Visual Studio 2012 like scrollbars.
Definition XTPScrollBarThemeVisualStudio2012.h:39
CXTPScrollBarThemeVisualStudio2015
Scrollbar paint manager used to draw Visual Studio 2015 like scrollbars.
Definition XTPScrollBarThemeVisualStudio2015.h:39
CXTPScrollBarThemeVisualStudio2015::DrawScrollBar
virtual void DrawScrollBar(CDC *pDC, CXTPScrollBase *pScrollBar)
This method is called to draw all scrollbar parts.
CXTPScrollBase
CXTPScrollBase is the base class for all scrollable objects.
Definition XTPScrollBase.h:222


Toolkit Pro: Member List

CXTPFlowGraphConnections Member List

This is the complete list of members for CXTPFlowGraphConnections, including all inherited members.

AddConnection(CXTPFlowGraphConnection *pConnection) | CXTPFlowGraphConnections |
CXTPCmdTarget() | CXTPCmdTarget |
CXTPFlowGraphConnections(CXTPFlowGraphPage *pPage) | CXTPFlowGraphConnections | protected
DoPropExchange(CXTPPropExchange *pPX) | CXTPFlowGraphConnections |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAt(int nIndex) const | CXTPFlowGraphConnections |
GetCount() const | CXTPFlowGraphConnections |
m_arrConnections | CXTPFlowGraphConnections | protected
m_pPage | CXTPFlowGraphConnections | protected
Remove(CXTPFlowGraphConnection *pConnection) | CXTPFlowGraphConnections |
RemoveAll() | CXTPFlowGraphConnections |
RemoveAt(int nIndex) | CXTPFlowGraphConnections |
~CXTPFlowGraphConnections() | CXTPFlowGraphConnections | protectedvirtual


Toolkit Pro: Member List

CXTPSyntaxEditConfigurationManager Member List

This is the complete list of members for CXTPSyntaxEditConfigurationManager, including all inherited members.

Close() | CXTPSyntaxEditConfigurationManager |
CXTPCmdTarget() | CXTPCmdTarget |
CXTPSyntaxEditConfigurationManager() | CXTPSyntaxEditConfigurationManager |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetConfigFile() const | CXTPSyntaxEditConfigurationManager |
GetConnection() const | CXTPSyntaxEditConfigurationManager |
GetCurrentTheme() const | CXTPSyntaxEditConfigurationManager |
GetTextSchemesManager() | CXTPSyntaxEditConfigurationManager |
GetThemeManager() | CXTPSyntaxEditConfigurationManager |
m_bConfigFileMode | CXTPSyntaxEditConfigurationManager |
m_bUseMonitor | CXTPSyntaxEditConfigurationManager |
m_sIniSet | CXTPSyntaxEditConfigurationManager |
p_sColorScheme | CXTPSyntaxEditConfigurationManager |
p_sSyntaxScheme | CXTPSyntaxEditConfigurationManager |
ReloadConfig(const CString &strConfigFilePath) | CXTPSyntaxEditConfigurationManager |
ReloadConfig() | CXTPSyntaxEditConfigurationManager |
ReloadConfigAsync(int nAsyncThreadPriority=THREAD_PRIORITY_NORMAL) | CXTPSyntaxEditConfigurationManager |
ReloadFile(CString csFileName, DWORD dwOwnerFlags, int nCfgFlags=0) | CXTPSyntaxEditConfigurationManager |
SetSyntaxAndColorScheme(CString *pSyntaxScheme, CString *pColorScheme) | CXTPSyntaxEditConfigurationManager | inline
SetTheme(const CString &strThemeName, CXTPSyntaxEditTextSchema *pActiveSch=NULL) | CXTPSyntaxEditConfigurationManager |
xtpEditCfgObjMainConfig enum value | CXTPSyntaxEditConfigurationManager |
xtpEditCfgObjSchMan enum value | CXTPSyntaxEditConfigurationManager |
xtpEditCfgObjThemeMan enum value | CXTPSyntaxEditConfigurationManager |
XTPSyntaxEditCfgObjects enum name | CXTPSyntaxEditConfigurationManager |
~CXTPSyntaxEditConfigurationManager() | CXTPSyntaxEditConfigurationManager | virtual


Toolkit Pro: XTPRibbonBackstageViewThemeNativeWindows11.h Source File

  • Source
  • Ribbon
  • Backstage
XTPRibbonBackstageViewThemeNativeWindows11.h
Go to the documentation of this file.
1
23#if !defined(__XTPRIBBONBACKSTAGEVIEWTHEMENATIVEWINDOWS11_H__)
24# define __XTPRIBBONBACKSTAGEVIEWTHEMENATIVEWINDOWS11_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class _XTP_EXT_CLASS CXTPRibbonBackstageViewThemeNativeWindows11
34 : public CXTPRibbonBackstageViewThemeOffice2013
35{
36public:
37 CXTPRibbonBackstageViewThemeNativeWindows11();
38 ~CXTPRibbonBackstageViewThemeNativeWindows11();
39
45 void SetButtonBackNormalColor(COLORREF clr);
46
52 void SetButtonBackSelectedColor(COLORREF clr);
53
59 void SetButtonBackHighlightedColor(COLORREF clr);
60
66 void SetButtonTextNormalColor(COLORREF clr);
67
73 void SetButtonTextSelectedColor(COLORREF clr);
74
80 void SetButtonTextHighlightedColor(COLORREF clr);
81};
82
83# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
85#endif // !defined(__XTPRIBBONBACKSTAGEVIEWTHEMENATIVEWINDOWS11_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h


Toolkit Pro: Member List

CXTPPropertyGridNativeWindows10Theme Member List

This is the complete list of members for CXTPPropertyGridNativeWindows10Theme, including all inherited members.

AdjustItemCaptionRect(CXTPPropertyGridItem *pItem, CRect &rcCaption) | CXTPPropertyGridPaintManager | virtual
AdjustItemValueRect(CXTPPropertyGridItem *pItem, CRect &rcValue) | CXTPPropertyGridPaintManager | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPPropertyGridNativeWindows10Theme(CXTPPropertyGrid *pGrid) | CXTPPropertyGridNativeWindows10Theme |
CXTPPropertyGridPaintManager(CXTPPropertyGrid *pGrid) | CXTPPropertyGridPaintManager |
CXTPPropertyGridVisualStudio2010Theme(CXTPPropertyGrid *pGrid) | CXTPPropertyGridVisualStudio2010Theme |
DrawCategoryCaptionBackground(CDC *pDC, CXTPPropertyGridItem *pItem, CRect rc) | CXTPPropertyGridPaintManager | virtual
DrawCheckBox(CDC *pDC, CXTPPropertyGridItemBool *pButton) | CXTPPropertyGridPaintManager | virtual
DrawCheckMark(CDC *pDC, CRect rc, BOOL bEnabled, BOOL bChecked) | CXTPPropertyGridPaintManager | virtual
DrawExpandButton(CDC &dc, CXTPPropertyGridItem *pItem, CRect rcCaption) | CXTPPropertyGridNativeWindows10Theme | virtual
DrawInplaceButtons(CDC *pDC, PDRAWITEMSTRUCT lpDrawItemStruct, CXTPPropertyGridItem *pItem, CRect rcValue) | CXTPPropertyGridPaintManager | virtual
DrawInplaceListItem(CDC *pDC, CXTPPropertyGridItemConstraint *pConstraint, CRect rc, BOOL bSelected) | CXTPPropertyGridPaintManager | virtual
DrawItem(PDRAWITEMSTRUCT lpDrawItemStruct) | CXTPPropertyGridPaintManager | virtual
DrawItemCaption(CDC *pDC, CXTPPropertyGridItem *pItem, CRect rcCaption) | CXTPPropertyGridPaintManager | virtual
DrawItemValue(CDC *pDC, CXTPPropertyGridItem *pItem, CRect rcValue) | CXTPPropertyGridPaintManager | virtual
DrawPropertyGridBorder(CDC *pDC, RECT &rcBorder, XTPPropertyGridWindow nWindow) | CXTPPropertyGridPaintManager | virtual
DrawRadioMark(CDC *pDC, CRect rc, BOOL bEnabled, BOOL bChecked) | CXTPPropertyGridPaintManager | virtual
FillInplaceButton(CDC *pDC, CXTPPropertyGridInplaceButton *pButton) | CXTPPropertyGridPaintManager | virtual
FillPropertyGrid(CDC *pDC) | CXTPPropertyGridPaintManager | virtual
FillPropertyGridView(CDC *pDC) | CXTPPropertyGridPaintManager | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetItemBackColor(CXTPPropertyGridItem *pItem, BOOL bValuePart) | CXTPPropertyGridPaintManager | virtual
GetItemFont(CXTPPropertyGridItem *pItem, BOOL bValuePart) | CXTPPropertyGridPaintManager | virtual
GetItemMetrics() const | CXTPPropertyGridPaintManager |
GetItemsBorderHeight() const | CXTPPropertyGridPaintManager | virtual
GetItemTextColor(CXTPPropertyGridItem *pItem, BOOL bValuePart) | CXTPPropertyGridPaintManager | virtual
GetScrollBarTheme() const | CXTPPropertyGridNativeWindows10Theme | virtual
GetSplitterRect(CRect rc, BOOL bIsHelp) | CXTPPropertyGridPaintManager |
HitTestVerbs(CDC *pDC, CRect rcVerbs, CPoint pt) | CXTPPropertyGridPaintManager |
m_bThinSplitter | CXTPPropertyGridPaintManager | protected
m_bTransparent | CXTPPropertyGridPaintManager |
m_buttonsStyle | CXTPPropertyGridPaintManager |
m_clrCategorySeparator | CXTPPropertyGridPaintManager |
m_clrFace | CXTPPropertyGridPaintManager |
m_clrHighlight | CXTPPropertyGridPaintManager |
m_clrHighlightText | CXTPPropertyGridPaintManager |
m_clrNonHighlightBack | CXTPPropertyGridPaintManager |
m_clrNonHighlightText | CXTPPropertyGridPaintManager |
m_clrShadow | CXTPPropertyGridPaintManager |
m_clrSplitter | CXTPPropertyGridPaintManager |
m_nHelpHeight | CXTPPropertyGridPaintManager | protected
m_nItemsBorderHeight | CXTPPropertyGridPaintManager | protected
m_nSplitterHeight | CXTPPropertyGridPaintManager | protected
m_nVerbsHeight | CXTPPropertyGridPaintManager | protected
m_pGrid | CXTPPropertyGridPaintManager | protected
m_pMetrics | CXTPPropertyGridPaintManager | protected
m_themeButton | CXTPPropertyGridPaintManager |
m_themeCombo | CXTPPropertyGridPaintManager |
m_themeTree | CXTPPropertyGridPaintManager |
MeasureItem(LPMEASUREITEMSTRUCT lpMeasureItemStruct) | CXTPPropertyGridPaintManager | virtual
OnNcCalcSize(RECT &rc) | CXTPPropertyGridPaintManager | virtual
RefreshMetrics() | CXTPPropertyGridNativeWindows10Theme | virtual
SetItemsBorderHeight(int nHeight) | CXTPPropertyGridPaintManager | virtual
SetThinSplitter(BOOL bThinSplitter) | CXTPPropertyGridPaintManager | virtual
~CXTPPropertyGridPaintManager() | CXTPPropertyGridPaintManager | virtual
~CXTPPropertyGridVisualStudio2010Theme() | CXTPPropertyGridVisualStudio2010Theme |


Toolkit Pro: XTPCalendarEventColorNewDlg.h Source File

  • Source
  • Calendar
XTPCalendarEventColorNewDlg.h
Go to the documentation of this file.
1
22#if !defined(__XTPCALENDAREVENTCOLORNEWDLG_H__)
23# define __XTPCALENDAREVENTCOLORNEWDLG_H__
24
25# if _MSC_VER > 1000
26# pragma once
27# endif // _MSC_VER > 1000
28
29# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
30
36class _XTP_EXT_CLASS CXTPCalendarEventColorNewDlg : public CDialog
37{
39 DECLARE_DYNAMIC(CXTPCalendarEventColorNewDlg)
41public:
52 CXTPCalendarEventColorNewDlg(BOOL bCategories, CWnd* pParent = NULL);
53
54protected:
55 BOOL m_bCategories;
62 virtual void EnableOkButton();
63
64 //{{AFX_DATA(CXTPCalendarEventColorNewDlg)
65public:
66 enum
67 {
68 IDD = XTP_IDD_CALENDAR_EVENT_COLORNEW
69 };
70 CButton m_btnOk;
71 CXTPColorPicker m_cpEventColor;
72 COLORREF m_crColor;
73 CString m_strName;
74 //}}AFX_DATA
75
76 //{{AFX_VIRTUAL(CXTPCalendarEventColorNewDlg)
77protected:
78 virtual void DoDataExchange(CDataExchange* pDX); // DDX/DDV support
79 //}}AFX_VIRTUAL
80
81 //{{AFX_MSG(CXTPCalendarEventColorNewDlg)
82 afx_msg void OnChangeEditName();
83 virtual BOOL OnInitDialog();
84 //}}AFX_MSG
85 afx_msg void OnSelEndOkColor();
86
87 DECLARE_MESSAGE_MAP()
88};
89
90//{{AFX_INSERT_LOCATION}}
91// Microsoft Visual C++ will insert additional declarations immediately before the previous line.
92
93# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
94#endif // !defined(__XTPCALENDAREVENTCOLORNEWDLG_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCalendarEventColorNewDlg
This class is used to add new Calendar Event Categories or Labels to the existing data array.
Definition XTPCalendarEventColorNewDlg.h:37
CXTPCalendarEventColorNewDlg::EnableOkButton
virtual void EnableOkButton()
This member function is called to enable / disable the OK button for the dialog.
CXTPCalendarEventColorNewDlg::m_bCategories
BOOL m_bCategories
TRUE when editing event categories.
Definition XTPCalendarEventColorNewDlg.h:55
CXTPCalendarEventColorNewDlg::CXTPCalendarEventColorNewDlg
CXTPCalendarEventColorNewDlg(BOOL bCategories, CWnd *pParent=NULL)
Constructs a CXTPCalendarEventColorNewDlg object used to add new calendar event categories and labels...
CXTPColorPicker
CXTPColorPicker is a CXTPButton derived class.
Definition XTPColorPicker.h:43


Toolkit Pro: Member List

CXTPChart3dPieSeriesLabelView Member List

This is the complete list of members for CXTPChart3dPieSeriesLabelView, including all inherited members.

AddChildView(CXTPChartElementView *pChildView) | CXTPChartElementView |
CreateConnectorDeviceCommand(CXTPChartDeviceContext *pDC) | CXTPChart3dPieSeriesLabelView | virtual
CreateDeviceCommand(CXTPChartDeviceContext *pDC) | CXTPChart3dPieSeriesLabelView | virtual
CreateTranspositionDeviceCommand(CXTPChartDeviceContext *pDC) | CXTPChart3dPieSeriesLabelView | virtual
CXTPChart3dPieSeriesLabelView(CXTPChartSeriesLabel *pLabel, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView) | CXTPChart3dPieSeriesLabelView |
CXTPChartElementView(CXTPChartElementView *pParentView) | CXTPChartElementView |
CXTPChartElementView(CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartElementView |
CXTPChartElementView(CXTPChartContainer *pContainer) | CXTPChartElementView |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartPieSeriesLabelViewBase(CXTPChartSeriesLabel *pLabel, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView) | CXTPChartPieSeriesLabelViewBase | protected
GetAt(int nIndex) const | CXTPChartElementView |
GetBounds() const | CXTPChartElementView |
GetBounds(BOOL bIncludingChildren) const | CXTPChartElementView |
GetChildren() | CXTPChartElementView |
GetConnectorBendPoint() const | CXTPChart3dPieSeriesLabelView |
GetConnectorEndPoint() const | CXTPChart3dPieSeriesLabelView |
GetConnectorStartPoint() const | CXTPChart3dPieSeriesLabelView |
GetCount() const | CXTPChartElementView |
GetLabelAnchorOrigin() const | CXTPChart3dPieSeriesLabelView |
GetLabelAnchorPoint() const | CXTPChart3dPieSeriesLabelView |
GetParentView() const | CXTPChartElementView |
GetPosition() const | CXTPChartPieSeriesLabelViewBase |
Is3D() const | CXTPChartObject |
IsConnectorVisible() const | CXTPChart3dPieSeriesLabelView |
IsLeftDirected() const | CXTPChart3dPieSeriesLabelView |
IsRightDirected() const | CXTPChart3dPieSeriesLabelView |
m_arrChildren | CXTPChartElementView | protected
m_bConnectorVisible | CXTPChart3dPieSeriesLabelView | protected
m_bLeftDirected | CXTPChart3dPieSeriesLabelView | protected
m_p3dPointView | CXTPChart3dPieSeriesLabelView | protected
m_pContainer | CXTPChartElementView | protected
m_pParentView | CXTPChartElementView | protected
m_ptBend | CXTPChart3dPieSeriesLabelView | protected
m_ptEnd | CXTPChart3dPieSeriesLabelView | protected
m_ptLabelAnchor | CXTPChart3dPieSeriesLabelView | protected
m_ptLabelAnchorOrigin | CXTPChart3dPieSeriesLabelView | protected
m_ptStart | CXTPChart3dPieSeriesLabelView | protected
m_rcBounds | CXTPChartElementView | protected
SetConnectorBendPoint(const CXTPPoint3d &point) | CXTPChart3dPieSeriesLabelView |
SetConnectorEndPoint(const CXTPPoint3d &point) | CXTPChart3dPieSeriesLabelView |
SetConnectorStartPoint(const CXTPPoint3d &point) | CXTPChart3dPieSeriesLabelView |
SetConnectorVisible(BOOL bVisible=TRUE) | CXTPChart3dPieSeriesLabelView |
SetLabelAnchorOrigin(CPoint ptAnchorOrigin) | CXTPChart3dPieSeriesLabelView |
SetLabelAnchorPoint(CPoint ptAnchor) | CXTPChart3dPieSeriesLabelView |
SetLeftDirected() | CXTPChart3dPieSeriesLabelView |
SetRightDirected() | CXTPChart3dPieSeriesLabelView |
~CXTPChart3dPieSeriesLabelView() | CXTPChart3dPieSeriesLabelView |
~CXTPChartElementView() | CXTPChartElementView | protectedvirtual


Toolkit Pro: Member List

CXTPMarqueeCtrlThemeOfficeXP Member List

This is the complete list of members for CXTPMarqueeCtrlThemeOfficeXP, including all inherited members.

CXTPMarqueeCtrlPaintManager() | CXTPMarqueeCtrlPaintManager |
CXTPMarqueeCtrlThemeOffice2000() | CXTPMarqueeCtrlThemeOffice2000 |
CXTPMarqueeCtrlThemeOfficeXP() | CXTPMarqueeCtrlThemeOfficeXP |
DeflateRect(CDC *pDC, CRect &rcClient) | CXTPMarqueeCtrlPaintManager | protectedvirtual
DrawBackground(CXTPMarqueeCtrl *pWndCtrl, CDC *pDC, CRect &rcClient) | CXTPMarqueeCtrlPaintManager | virtual
DrawChunk(CXTPMarqueeCtrl *pWndCtrl, CDC *pDC, CXTPCompatibleDC &dcChunk, int i, int &x, int &y, int cx, int cy) | CXTPMarqueeCtrlPaintManager | protectedvirtual
DrawMarquee(CXTPMarqueeCtrl *pWndCtrl, CDC *pDC, CRect &rcClient) | CXTPMarqueeCtrlPaintManager | virtual
GetBackColor() | CXTPMarqueeCtrlPaintManager |
GetBarColor() | CXTPMarqueeCtrlPaintManager |
GetBorderColor() | CXTPMarqueeCtrlPaintManager |
m_bUseWinTheme | CXTPMarqueeCtrlPaintManager | protected
m_clr3DHilite | CXTPMarqueeCtrlPaintManager | protected
m_clr3DShadow | CXTPMarqueeCtrlPaintManager | protected
m_clrBack | CXTPMarqueeCtrlPaintManager | protected
m_clrBar | CXTPMarqueeCtrlPaintManager | protected
m_nTheme | CXTPMarqueeCtrlPaintManager | protected
m_winTheme | CXTPMarqueeCtrlPaintManager | protected
RefreshMetrics() | CXTPMarqueeCtrlThemeOfficeXP | virtual
SetBackColor(COLORREF clrNew) | CXTPMarqueeCtrlPaintManager |
SetBarColor(COLORREF clrNew) | CXTPMarqueeCtrlPaintManager |
SetBorderColor(COLORREF clrNew) | CXTPMarqueeCtrlPaintManager |
UseWinThemes(BOOL bUseWinThemes=TRUE) | CXTPMarqueeCtrlPaintManager |
UsingWinThemes(BOOL bCheckReady=FALSE) | CXTPMarqueeCtrlPaintManager |
~CXTPMarqueeCtrlPaintManager() | CXTPMarqueeCtrlPaintManager | virtual


Toolkit Pro: XTPChartDiagramView.h Source File

  • Source
  • Chart
XTPChartDiagramView.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTDIAGRAMVIEW_H__)
24# define __XTPCHARTDIAGRAMVIEW_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartSeriesView;
34class CXTPChartElementView;
35class CXTPChartDiagramView;
36class CXTPChartSeries;
37class CXTPChartPanel;
38class CXTPChartDiagram;
39class CXTPChartDeviceContext;
40class CXTPChartDeviceCommand;
41class CXTPChart3dDiagram;
42
48class _XTP_EXT_CLASS CXTPChartDiagramView : public CXTPChartElementView
49{
50 DECLARE_DYNAMIC(CXTPChartDiagramView);
51
52public:
60 CXTPChartDiagramView(CXTPChartDiagram* pDiagram, CXTPChartElementView* pParentView);
61
62public:
70 CRect GetBounds() const;
71
81 CXTPChartDiagram* GetDiagram() const;
82
91 CXTPChartElementView* GetLabelsView() const;
92
101 CXTPChartElementView* GetSeriesView() const;
102
114 virtual void CalculateView(CXTPChartDeviceContext* pDC, CRect rcBounds);
115
122 virtual void UpdateRange(CXTPChartDeviceContext* pDC);
123
132 virtual void OnMouseWheel(UINT nFlags, short zDelta, CPoint pt);
133
140 virtual void CreateView(CXTPChartDeviceContext* pDC);
141
142protected:
143 virtual CXTPChartDeviceCommand* CreateDeviceCommand(CXTPChartDeviceContext* pDC);
144
145protected:
146 CXTPChartDiagram* m_pDiagram;
147 CRect m_rcBounds;
148 CXTPChartElementView* m_pLabelsView;
149 CXTPChartElementView* m_pSeriesView;
150 CXTPChartElementView* m_pTitlesView;
152public:
153 HCURSOR m_hcurNormalHand;
154 HCURSOR m_hcurDragHand;
155};
156
157AFX_INLINE CRect CXTPChartDiagramView::GetBounds() const
158{
159 return m_rcBounds;
160}
161AFX_INLINE CXTPChartDiagram* CXTPChartDiagramView::GetDiagram() const
162{
163 return m_pDiagram;
164}
165AFX_INLINE CXTPChartElementView* CXTPChartDiagramView::GetLabelsView() const
166{
167 return m_pLabelsView;
168}
169AFX_INLINE CXTPChartElementView* CXTPChartDiagramView::GetSeriesView() const
170{
171 return m_pSeriesView;
172}
173
179class _XTP_EXT_CLASS CXTPChart3dDiagramView : public CXTPChartDiagramView
180{
181 DECLARE_DYNAMIC(CXTPChart3dDiagramView);
182
183public:
191 CXTPChart3dDiagramView(CXTPChartDiagram* pDiagram, CXTPChartElementView* pParentView);
192
193public:
204 virtual CXTPChartDeviceCommand* CreateDeviceCommand(CXTPChartDeviceContext* pDC);
205
207public:
208 virtual void OnMouseMove(UINT nFlags, CPoint point);
209 virtual void OnLButtonDown(UINT nFlags, CPoint point);
210 virtual void OnLButtonUp(UINT nFlags, CPoint point);
211 virtual void OnMouseWheel(UINT nFlags, short zDelta, CPoint point);
212 virtual BOOL OnSetCursor(CPoint point);
215private:
216 CXTPChart3dDiagram* m_p3dDiagram;
217};
219# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
220#endif //#if !defined(__XTPCHARTDIAGRAMVIEW_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChart3dDiagram
The base class for all 3D diagrams.
Definition XTPChartDiagram.h:219
CXTPChart3dDiagramView
This class represents the view of a chart diagram, which is a kind of CXTPChartElementView.
Definition XTPChartDiagramView.h:180
CXTPChart3dDiagramView::CXTPChart3dDiagramView
CXTPChart3dDiagramView(CXTPChartDiagram *pDiagram, CXTPChartElementView *pParentView)
Constructs a CXTPChart3dDiagramView object.
CXTPChart3dDiagramView::CreateDeviceCommand
virtual CXTPChartDeviceCommand * CreateDeviceCommand(CXTPChartDeviceContext *pDC)
Creates a view device command.
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartDiagram
This class represents a chart diagram, which is a kind of CXTPChartElement.
Definition XTPChartDiagram.h:48
CXTPChartDiagramView
This class represents the view of a chart diagram, which is a kind of CXTPChartElementView.
Definition XTPChartDiagramView.h:49
CXTPChartDiagramView::GetBounds
CRect GetBounds() const
Call this function to get the bounds of the diagram.
Definition XTPChartDiagramView.h:157
CXTPChartDiagramView::GetDiagram
CXTPChartDiagram * GetDiagram() const
Call this function to get the diagram object associated with the view.
Definition XTPChartDiagramView.h:161
CXTPChartDiagramView::m_pDiagram
CXTPChartDiagram * m_pDiagram
Pointer to the associated diagram object.
Definition XTPChartDiagramView.h:146
CXTPChartDiagramView::GetSeriesView
CXTPChartElementView * GetSeriesView() const
Call this function to get the series view object associated with this diagram view.
Definition XTPChartDiagramView.h:169
CXTPChartDiagramView::CreateView
virtual void CreateView(CXTPChartDeviceContext *pDC)
Performs view initialization.
CXTPChartDiagramView::m_pTitlesView
CXTPChartElementView * m_pTitlesView
Titles View.
Definition XTPChartDiagramView.h:150
CXTPChartDiagramView::CreateDeviceCommand
virtual CXTPChartDeviceCommand * CreateDeviceCommand(CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
CXTPChartDiagramView::m_pLabelsView
CXTPChartElementView * m_pLabelsView
The label view.
Definition XTPChartDiagramView.h:148
CXTPChartDiagramView::UpdateRange
virtual void UpdateRange(CXTPChartDeviceContext *pDC)
Updates chart range.
CXTPChartDiagramView::GetLabelsView
CXTPChartElementView * GetLabelsView() const
Call this function to get the label view object associated with this diagram view.
Definition XTPChartDiagramView.h:165
CXTPChartDiagramView::m_pSeriesView
CXTPChartElementView * m_pSeriesView
The series view.
Definition XTPChartDiagramView.h:149
CXTPChartDiagramView::OnMouseWheel
virtual void OnMouseWheel(UINT nFlags, short zDelta, CPoint pt)
Handles mouse wheel event.
CXTPChartDiagramView::m_rcBounds
CRect m_rcBounds
The diagram bounds.
Definition XTPChartDiagramView.h:147
CXTPChartDiagramView::CalculateView
virtual void CalculateView(CXTPChartDeviceContext *pDC, CRect rcBounds)
Call this function to calculate the view of the diagram.
CXTPChartDiagramView::CXTPChartDiagramView
CXTPChartDiagramView(CXTPChartDiagram *pDiagram, CXTPChartElementView *pParentView)
Constructs a CXTPChartDiagram object.
CXTPChartElementView
This class represents the view of a chart element.
Definition XTPChartElementView.h:47
CXTPChartElementView::GetBounds
CRect GetBounds() const
Obtains viewed object's bound rectangle.
Definition XTPChartElementView.h:213
CXTPChartPanel
This class abstracts a chart panel.
Definition XTPChartPanel.h:48
CXTPChartSeries
This class represents a series in the chart, which is a kind of CXTPChartElement.
Definition XTPChartSeries.h:50


Toolkit Pro: Member List

CXTPChartSplineAreaSeriesView Member List

This is the complete list of members for CXTPChartSplineAreaSeriesView, including all inherited members.

AddChildView(CXTPChartElementView *pChildView) | CXTPChartElementView |
CreateDeviceCommand(CXTPChartDeviceContext *pDC) | CXTPChartSplineAreaSeriesView | protectedvirtual
CreateLegendDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcBounds) | CXTPChartAreaSeriesView | protectedvirtual
CreateSeriesPointView(CXTPChartDeviceContext *pDC, CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView) | CXTPChartSplineAreaSeriesView | protected
CXTPChartAreaSeriesView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView) | CXTPChartAreaSeriesView |
CXTPChartElementView(CXTPChartElementView *pParentView) | CXTPChartElementView |
CXTPChartElementView(CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartElementView |
CXTPChartElementView(CXTPChartContainer *pContainer) | CXTPChartElementView |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartSplineAreaSeriesView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView) | CXTPChartSplineAreaSeriesView |
GetActualColor() const | CXTPChartAreaSeriesView | protected
GetActualColor2() const | CXTPChartAreaSeriesView | protected
GetAt(int nIndex) const | CXTPChartElementView |
GetBorderActualColor() const | CXTPChartAreaSeriesView | protected
GetBounds() const | CXTPChartElementView |
GetBounds(BOOL bIncludingChildren) const | CXTPChartElementView |
GetChildren() | CXTPChartElementView |
GetCount() const | CXTPChartElementView |
GetParentView() const | CXTPChartElementView |
Is3D() const | CXTPChartObject |
m_arrChildren | CXTPChartElementView | protected
m_pContainer | CXTPChartElementView | protected
m_pParentView | CXTPChartElementView | protected
m_rcBounds | CXTPChartElementView | protected
~CXTPChartElementView() | CXTPChartElementView | protectedvirtual
~CXTPChartLegendItemView() | CXTPChartLegendItemView | inlinevirtual


Toolkit Pro: XTPCommandBarsThemeRibbon.h Source File

  • Source
  • CommandBars
  • Themes
XTPCommandBarsThemeRibbon.h
Go to the documentation of this file.
1
23#if !defined(__XTPRIBBONTHEME_H__)
24# define __XTPRIBBONTHEME_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
39class _XTP_EXT_CLASS CXTPRibbonTheme : public CXTPResourceTheme
40{
42 DECLARE_DYNAMIC(CXTPRibbonTheme)
44public:
49 CXTPRibbonTheme();
50
55 virtual ~CXTPRibbonTheme();
56
57public:
62 virtual void RefreshMetrics();
63
64protected:
65protected:
72 virtual void DrawControlEntry(CDC* pDC, CXTPControl* pButton);
73
81 virtual void AdjustExcludeRect(CRect& rc, CXTPControl* pControl, BOOL bVertical);
82
91 virtual void DrawSplitButtonFrame(CDC* pDC, CXTPControl* pButton, CRect rc);
92
105 virtual void DrawPopupBarGripper(CDC* pDC, int xPos, int yPos, int cx, int cy,
106 BOOL bExpanded = FALSE);
107
114 virtual void FillCommandBarEntry(CDC* pDC, CXTPCommandBar* pBar);
115
129 virtual void DrawRectangle(CDC* pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled,
130 BOOL bChecked, BOOL bPopuped, XTPBarType barType,
131 XTPBarPosition barPosition);
132
147 virtual void DrawRectangle(CDC* pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled,
148 BOOL bChecked, BOOL bPopuped, XTPBarType barType,
149 XTPBarPosition barPosition, int nID);
150
159 virtual BOOL DrawRectangle(CDC* pDC, CXTPControl* pButton);
160
171 virtual CSize DrawCommandBarSeparator(CDC* pDC, CXTPCommandBar* pBar, CXTPControl* pControl,
172 BOOL bDraw);
173
183 virtual CSize DrawCommandBarGripper(CDC* pDC, CXTPCommandBar* pBar, BOOL bDraw = TRUE);
184
191 virtual void FillStatusBar(CDC* pDC, CXTPStatusBar* pBar);
192
199 virtual void DrawStatusBarGripper(CDC* pDC, CRect rcClient);
200
209 virtual void DrawStatusBarPaneBorder(CDC* pDC, CRect rc, CXTPStatusBarPane* pPane,
210 BOOL bGripperPane);
211
219 virtual void DrawStatusBarPaneSeparator(CDC* pDC, CRect rc, CXTPStatusBarPane* pPane);
220
229 virtual int DrawStatusBarSwitchPane(CDC* pDC, CRect rcItem, CXTPStatusBarSwitchPane* pPane);
230
243 virtual COLORREF GetRectangleTextColor(BOOL bSelected, BOOL bPressed, BOOL bEnabled,
244 BOOL bChecked, BOOL bPopuped, XTPBarType barType,
245 XTPBarPosition barPosition);
246
254 virtual COLORREF GetControlTextColor(CXTPControl* pButton);
255
265 CSize DrawControlEdit(CDC* pDC, CXTPControlEdit* pControlEdit, BOOL bDraw);
266
276 CSize DrawControlComboBox(CDC* pDC, CXTPControlComboBox* pComboBox, BOOL bDraw);
277
285 virtual COLORREF GetControlEditBackColor(CXTPControl* pControl);
286
293 virtual XTPPaintTheme BaseTheme()
294 {
295 return xtpThemeRibbon;
296 }
297
303 virtual void SetCommandBarRegion(CXTPCommandBar* pCommandBar);
304
311 virtual void DrawSplitButtonPopup(CDC* pDC, CXTPControl* pButton);
312
319 virtual void DrawControlPopupGlyph(CDC* pDC, CXTPControl* pButton);
320
327 virtual void FillPopupLabelEntry(CDC* pDC, CRect rc);
328
334 void SetRoundRectRegion(CWnd* pWnd);
335
343 virtual void DrawKeyboardTip(CDC* pDC, CXTPCommandBarKeyboardTip* pWnd, BOOL bSetRegion);
344
358 virtual CSize DrawSpecialControl(CDC* pDC, XTPSpecialControl controlType, CXTPControl* pButton,
359 CXTPCommandBar* pBar, BOOL bDraw, LPVOID lpParam);
360
368 void DrawPopupResizeGripper(CDC* pDC, CRect rcGripper, int nFlags);
369
378 virtual void DrawPopupBarCheckMark(CDC* pDC, CRect rcCheck, BOOL bEnabled, COLORREF clr);
379
388 virtual void DrawPopupBarRadioMark(CDC* pDC, CRect rcCheck, BOOL bEnabled, COLORREF clr);
389
390public:
396 void SetRibbonPaintManager(CXTPRibbonPaintManager* pRibbonPaintManager);
397
398protected:
405 BOOL IsImagesAvailable();
406
408 virtual void DrawDropDownGlyph(CDC* pDC, CXTPControl* pControl, CPoint pt, BOOL bSelected,
409 BOOL bPopuped, BOOL bEnabled, BOOL bVert);
410 virtual CSize DrawControlCheckBoxMark(CDC* pDC, CRect rc, BOOL bDraw, BOOL bSelected,
411 BOOL bPressed, BOOL bChecked, BOOL bEnabled);
412 virtual CSize DrawControlCheckBoxMark(CDC* pDC, CXTPControl* pButton, CRect rc, BOOL bDraw);
413 virtual CSize DrawControlRadioButtonMark(CDC* pDC, CRect rc, BOOL bDraw, BOOL bSelected,
414 BOOL bPressed, BOOL bChecked, BOOL bEnabled);
417protected:
418 friend class CXTPRibbonBar;
419
420protected:
421 COLORREF m_clrControlEditNormal;
422 COLORREF m_clrControlEditSelected;
423 COLORREF m_clrControlEditDisabledBorder;
424 COLORREF m_clrRibbonText;
425 COLORREF m_clrRibbonGrayText;
426 COLORREF m_clrMenuPopupSeparator;
427 COLORREF m_clrMenuPopupGripperShadow;
428 BOOL m_bOffice2010Style;
429};
430
432# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
433#endif // !defined(__XTPRIBBONTHEME_H__)
XTPBarType
XTPBarType
Type of the command bar.
Definition XTPCommandBarsDefines.h:77
XTPBarPosition
XTPBarPosition
Position of the command bar.
Definition XTPCommandBarsDefines.h:52
XTPPaintTheme
XTPPaintTheme
Paint themes used by command bars.
Definition XTPCommandBarsDefines.h:233
xtpThemeRibbon
@ xtpThemeRibbon
Office 2007 style ribbon theme.
Definition XTPCommandBarsDefines.h:241
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPSpecialControl
XTPSpecialControl
Special control with extended drawing.
Definition XTPPaintManager.h:80
CXTPCommandBar
CXTPCommandBar is a CWnd derived class.
Definition XTPCommandBar.h:66
CXTPCommandBarKeyboardTip
CXTPCommandBarKeyboardTip is a CWnd derived class which represents a keyboard tip single window.
Definition XTPCommandBarKeyboardTip.h:41
CXTPCommandBarsOfficeXPTheme::DrawControlRadioButtonMark
virtual CSize DrawControlRadioButtonMark(CDC *pDC, CRect rc, BOOL bDraw, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled)
This method is called to draw a radio button mark area.
CXTPCommandBarsOfficeXPTheme::DrawControlCheckBoxMark
virtual CSize DrawControlCheckBoxMark(CDC *pDC, CRect rc, BOOL bDraw, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled)
This method is called to draw a check box mark area.
CXTPControlComboBox
CXTPControlComboBox is a CXTPControl derived class.
Definition XTPControlComboBox.h:381
CXTPControlEdit
CXTPControlEdit is a CXTPControl derived class.
Definition XTPControlEdit.h:274
CXTPControl
CXTPControl is a CXTPCmdTarget derived class.
Definition XTPControl.h:841
CXTPPaintManager::DrawDropDownGlyph
virtual void DrawDropDownGlyph(CDC *pDC, CXTPControl *pControl, CPoint pt, BOOL bSelected, BOOL bPopuped, BOOL bEnabled, BOOL bVert)
This member function is called to draw a split button expand symbol.
CXTPResourceTheme
The CXTPResourceTheme class is used to enable a resource style theme for Command Bars.
Definition XTPCommandBarsResourceTheme.h:46
CXTPRibbonBar
CXTPRibbonBar is a CXTPMenuBar derived class.
Definition XTPRibbonBar.h:69
CXTPRibbonPaintManager
Standalone class used by CXTPRibbonBar as a paint manager.
Definition XTPRibbonPaintManager.h:51
CXTPRibbonTheme
The CXTPRibbonTheme class is used to enable a Ribbon style theme for Command Bars.
Definition XTPCommandBarsThemeRibbon.h:40
CXTPRibbonTheme::IsImagesAvailable
BOOL IsImagesAvailable()
Determines if images are available.
CXTPRibbonTheme::DrawSpecialControl
virtual CSize DrawSpecialControl(CDC *pDC, XTPSpecialControl controlType, CXTPControl *pButton, CXTPCommandBar *pBar, BOOL bDraw, LPVOID lpParam)
This method is called to draw the specified controls.
CXTPRibbonTheme::DrawPopupBarRadioMark
virtual void DrawPopupBarRadioMark(CDC *pDC, CRect rcCheck, BOOL bEnabled, COLORREF clr)
Call this member function to draw a radio button.
CXTPRibbonTheme::DrawCommandBarSeparator
virtual CSize DrawCommandBarSeparator(CDC *pDC, CXTPCommandBar *pBar, CXTPControl *pControl, BOOL bDraw)
This method is called to draw a command bar's separator.
CXTPRibbonTheme::DrawCommandBarGripper
virtual CSize DrawCommandBarGripper(CDC *pDC, CXTPCommandBar *pBar, BOOL bDraw=TRUE)
This method is called to draw the command bar's gripper.
CXTPRibbonTheme::DrawStatusBarGripper
virtual void DrawStatusBarGripper(CDC *pDC, CRect rcClient)
This method is called to draw the status bar's gripper.
CXTPRibbonTheme::m_clrRibbonGrayText
COLORREF m_clrRibbonGrayText
Gray text of the ribbon.
Definition XTPCommandBarsThemeRibbon.h:425
CXTPRibbonTheme::FillPopupLabelEntry
virtual void FillPopupLabelEntry(CDC *pDC, CRect rc)
This method is called to draw a menu label background.
CXTPRibbonTheme::DrawSplitButtonFrame
virtual void DrawSplitButtonFrame(CDC *pDC, CXTPControl *pButton, CRect rc)
This method is called to draw the frame for the SplitButton control.
CXTPRibbonTheme::SetRibbonPaintManager
void SetRibbonPaintManager(CXTPRibbonPaintManager *pRibbonPaintManager)
Call this member function to set the current ribbon paint manager.
CXTPRibbonTheme::CXTPRibbonTheme
CXTPRibbonTheme()
Constructs a CXTPRibbonTheme object.
CXTPRibbonTheme::m_clrMenuPopupGripperShadow
COLORREF m_clrMenuPopupGripperShadow
Pop-up gripper shadow color.
Definition XTPCommandBarsThemeRibbon.h:427
CXTPRibbonTheme::GetControlEditBackColor
virtual COLORREF GetControlEditBackColor(CXTPControl *pControl)
This method returns the edit control back color to draw.
CXTPRibbonTheme::GetRectangleTextColor
virtual COLORREF GetRectangleTextColor(BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition)
This method retrieves a buttons text color.
CXTPRibbonTheme::DrawControlEdit
CSize DrawControlEdit(CDC *pDC, CXTPControlEdit *pControlEdit, BOOL bDraw)
This method is called to draw the control.
CXTPRibbonTheme::DrawRectangle
virtual BOOL DrawRectangle(CDC *pDC, CXTPControl *pButton)
This method is called to fill the control's face.
CXTPRibbonTheme::SetRoundRectRegion
void SetRoundRectRegion(CWnd *pWnd)
This method is called to set a rounded rectangle region for a window.
CXTPRibbonTheme::DrawControlComboBox
CSize DrawControlComboBox(CDC *pDC, CXTPControlComboBox *pComboBox, BOOL bDraw)
This method is called to draw the control.
CXTPRibbonTheme::m_clrControlEditDisabledBorder
COLORREF m_clrControlEditDisabledBorder
Edit disabled border.
Definition XTPCommandBarsThemeRibbon.h:423
CXTPRibbonTheme::m_clrMenuPopupSeparator
COLORREF m_clrMenuPopupSeparator
Pop-up separator color.
Definition XTPCommandBarsThemeRibbon.h:426
CXTPRibbonTheme::AdjustExcludeRect
virtual void AdjustExcludeRect(CRect &rc, CXTPControl *pControl, BOOL bVertical)
This method is called to determine the offset of a pop-up bar.
CXTPRibbonTheme::m_clrRibbonText
COLORREF m_clrRibbonText
Ribbon text color.
Definition XTPCommandBarsThemeRibbon.h:424
CXTPRibbonTheme::DrawStatusBarPaneSeparator
virtual void DrawStatusBarPaneSeparator(CDC *pDC, CRect rc, CXTPStatusBarPane *pPane)
This method is called to draw the pane separator of status bar panes.
CXTPRibbonTheme::FillStatusBar
virtual void FillStatusBar(CDC *pDC, CXTPStatusBar *pBar)
This method is called to fill a status bar.
CXTPRibbonTheme::DrawControlEntry
virtual void DrawControlEntry(CDC *pDC, CXTPControl *pButton)
This method is called to fill the control's face.
CXTPRibbonTheme::DrawSplitButtonPopup
virtual void DrawSplitButtonPopup(CDC *pDC, CXTPControl *pButton)
This method is called to draw a menu split button dropdown rect.
CXTPRibbonTheme::DrawStatusBarPaneBorder
virtual void DrawStatusBarPaneBorder(CDC *pDC, CRect rc, CXTPStatusBarPane *pPane, BOOL bGripperPane)
This method is called to draw the frame of a single cell of the status bar.
CXTPRibbonTheme::DrawPopupBarGripper
virtual void DrawPopupBarGripper(CDC *pDC, int xPos, int yPos, int cx, int cy, BOOL bExpanded=FALSE)
This method is called to draw a pop-up bar's right gripper.
CXTPRibbonTheme::FillCommandBarEntry
virtual void FillCommandBarEntry(CDC *pDC, CXTPCommandBar *pBar)
This method is called to fill the command bar's face.
CXTPRibbonTheme::GetControlTextColor
virtual COLORREF GetControlTextColor(CXTPControl *pButton)
This method returns a control text color to draw.
CXTPRibbonTheme::DrawControlPopupGlyph
virtual void DrawControlPopupGlyph(CDC *pDC, CXTPControl *pButton)
This method is called to a draw menu pop-up glyph.
CXTPRibbonTheme::SetCommandBarRegion
virtual void SetCommandBarRegion(CXTPCommandBar *pCommandBar)
This method is called to set the bounding region for a pop-up bar.
CXTPRibbonTheme::~CXTPRibbonTheme
virtual ~CXTPRibbonTheme()
Destroys a CXTPRibbonTheme object, handles cleanup and deallocation.
CXTPRibbonTheme::DrawPopupResizeGripper
void DrawPopupResizeGripper(CDC *pDC, CRect rcGripper, int nFlags)
This method is called to draw the resize gripper for the pop-up window.
CXTPRibbonTheme::m_clrControlEditSelected
COLORREF m_clrControlEditSelected
Edit control selected color.
Definition XTPCommandBarsThemeRibbon.h:422
CXTPRibbonTheme::DrawPopupBarCheckMark
virtual void DrawPopupBarCheckMark(CDC *pDC, CRect rcCheck, BOOL bEnabled, COLORREF clr)
Call this member function to draw a check mark.
CXTPRibbonTheme::BaseTheme
virtual XTPPaintTheme BaseTheme()
Retrieves the base theme of the manager.
Definition XTPCommandBarsThemeRibbon.h:293
CXTPRibbonTheme::RefreshMetrics
virtual void RefreshMetrics()
This method is called to refresh the visual metrics of the manager.
CXTPRibbonTheme::DrawRectangle
virtual void DrawRectangle(CDC *pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition)
This method is called to fill the control's face.
CXTPRibbonTheme::DrawRectangle
virtual void DrawRectangle(CDC *pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition, int nID)
This method is called to fill the control's face.
CXTPRibbonTheme::DrawKeyboardTip
virtual void DrawKeyboardTip(CDC *pDC, CXTPCommandBarKeyboardTip *pWnd, BOOL bSetRegion)
This method is called to draw a ribbon keyboard tip.
CXTPRibbonTheme::m_clrControlEditNormal
COLORREF m_clrControlEditNormal
Edit control color.
Definition XTPCommandBarsThemeRibbon.h:421
CXTPRibbonTheme::DrawStatusBarSwitchPane
virtual int DrawStatusBarSwitchPane(CDC *pDC, CRect rcItem, CXTPStatusBarSwitchPane *pPane)
This method is called to draw the status bar switch pane.
CXTPStatusBar
CXTPStatusBar is a CControlBar derived class.
Definition XTPStatusBar.h:52
CXTPStatusBarPane
CXTPStatusBarPane is a CXTPCmdTarget derived class.
Definition XTPStatusBarPane.h:39
CXTPStatusBarSwitchPane
CXTPStatusBarSwitchPane is a CXTPStatusBarPane derived class.
Definition XTPStatusBarPaneSwitch.h:40


Toolkit Pro: Member List

CXTPSyntaxEditColorInfo Member List

This is the complete list of members for CXTPSyntaxEditColorInfo, including all inherited members.

AddParam(const CString &strName, const CString &strValue) | CXTPSyntaxEditColorInfo |
CXTPSyntaxEditColorInfo(CXTPSyntaxEditColorTheme *pTheme) | CXTPSyntaxEditColorInfo |
CXTPSyntaxEditColorInfo(const CString &strClassName, CXTPSyntaxEditColorTheme *pTheme) | CXTPSyntaxEditColorInfo |
GetClassName() const | CXTPSyntaxEditColorInfo |
GetFirstParamNamePosition() | CXTPSyntaxEditColorInfo |
GetHexParam(const CString &strName, BOOL bDynamic=TRUE) | CXTPSyntaxEditColorInfo |
GetNextParamName(POSITION &pos) | CXTPSyntaxEditColorInfo |
GetParam(const CString &strName, BOOL bDynamic=TRUE) | CXTPSyntaxEditColorInfo |
~CXTPSyntaxEditColorInfo() | CXTPSyntaxEditColorInfo | virtual


Toolkit Pro: XTPMessageBarThemeVisualStudio2022.h Source File

  • Source
  • CommandBars
  • MessageBar
XTPMessageBarThemeVisualStudio2022.h
Go to the documentation of this file.
1
23#if !defined(__XTPMESSAGEBARTHEMEVISUALSTUDIO2022_H__)
24# define __XTPMESSAGEBARTHEMEVISUALSTUDIO2022_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPPaintManager;
34class CXTPMessageBar;
35class CXTPMessageBarButton;
36
42class _XTP_EXT_CLASS CXTPMessageBarThemeVisualStudio2022 : public CXTPMessageBarThemeOffice2013
43{
44public:
50 CXTPMessageBarThemeVisualStudio2022(CXTPPaintManager* pPaintManager);
51};
52
54# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
55#endif // !defined(__XTPMESSAGEBARTHEMEVISUALSTUDIO2022_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPMessageBarButton
CXTPMessageBarButton is a standalone class.
Definition XTPMessageBar.h:48
CXTPMessageBar
CXTPMessageBar is a CControlBar derived class.
Definition XTPMessageBar.h:88
CXTPMessageBarThemeOffice2013
The CXTPMessageBarThemeOffice2013 class is used by the message bar to draw an Office 2013 style messa...
Definition XTPMessageBarThemeOffice2013.h:43
CXTPMessageBarThemeVisualStudio2022
The CXTPMessageBarThemeVisualStudio2022 class is used by the message bar to draw a Visual Studio 2022...
Definition XTPMessageBarThemeVisualStudio2022.h:43
CXTPMessageBarThemeVisualStudio2022::CXTPMessageBarThemeVisualStudio2022
CXTPMessageBarThemeVisualStudio2022(CXTPPaintManager *pPaintManager)
Message bar constructor.
CXTPPaintManager
Paint manager of the command bars.
Definition XTPPaintManager.h:199


Toolkit Pro: Member List

CXTPControlPopupColor Member List

This is the complete list of members for CXTPControlPopupColor, including all inherited members.

AdjustExcludeRect(CRect &rc, BOOL bVertical) | CXTPControlPopup | virtual
AssignDocTemplate(UINT nIDResource) | CXTPControl |
ClickToolBarButton(CRect rcActiveRect=CRect(0, 0, 0, 0)) | CXTPControl | protected
Compare(CXTPControl *pOther) | CXTPControlPopup | protectedvirtual
ContainsPopup(CXTPControlPopup *pControlPopup) | CXTPControlPopup | protected
Copy(CXTPControl *pControl, BOOL bRecursive=FALSE) | CXTPControlPopupColor | protectedvirtual
CreateControlPopup(XTPControlType controlType) | CXTPControlPopup | static
CustomizeStartDrag(CPoint point) | CXTPControl | protectedvirtual
CustomizeStartResize(CPoint point) | CXTPControl | protectedvirtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPControl() | CXTPControl | protected
CXTPControlButton() | CXTPControlButton |
CXTPControlPopup() | CXTPControlPopup |
CXTPControlPopupColor() | CXTPControlPopupColor |
DelayLayoutParent() | CXTPControl |
DelayRedrawParent() | CXTPControl |
DoCustomDragOver(CXTPCommandBar *pCommandBar, CPoint point, DROPEFFECT &dropEffect) | CXTPControlPopup | protectedvirtual
DoPropExchange(CXTPPropExchange *pPX) | CXTPControlPopup | virtual
Draw(CDC *pDC) | CXTPControl | virtual
ExcludeDocTemplate(UINT nIDResource) | CXTPControl |
ExpandCommandBar() | CXTPControlPopup | protected
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
FromUI(CCmdUI *pCmdUI) | CXTPControl | static
GenerateCommandBarList(DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam) | CXTPControl | protectedvirtual
GetAction() const | CXTPControl |
GetBeginGroup() const | CXTPControl |
GetButtonSize() const | CXTPControl | virtual
GetCaption() const | CXTPControlPopup | virtual
GetCategory() const | CXTPControl |
GetChecked() const | CXTPControl |
GetCloseSubMenuOnClick() const | CXTPControl |
GetColor() const | CXTPControlPopupColor |
GetCommandBar() const | CXTPControlPopup | virtual
GetControls() const | CXTPControl |
GetCustomizeMinHeight() const | CXTPControl | protectedvirtual
GetCustomizeMinWidth() const | CXTPControl | protectedvirtual
GetCustomShortcutText() const | CXTPControl |
GetDescription() const | CXTPControl | virtual
GetEnabled() const | CXTPControl |
GetExecuteOnPressInterval() const | CXTPControl |
GetExpanded() const | CXTPControl |
GetFlags() const | CXTPControl |
GetHeight() const | CXTPControl |
GetHelpId() const | CXTPControl |
GetHideFlags() const | CXTPControl |
GetIconId() const | CXTPControl |
GetIconSize() const | CXTPControl | virtual
GetID() const | CXTPControl |
GetImage(int nWidth=16) const | CXTPControl | virtual
GetImageManager() const | CXTPControl |
GetIndex() const | CXTPControl |
GetKeyboardTip() const | CXTPControl |
GetPaintManager() const | CXTPControl |
GetParameter() const | CXTPControl |
GetParent() const | CXTPControl |
GetPopuped() const | CXTPControlPopup | virtual
GetPressed() const | CXTPControl | virtual
GetRect() const | CXTPControl |
GetRibbonGroup() const | CXTPControl |
GetRowRect() const | CXTPControl |
GetSelected() const | CXTPControl | virtual
GetShortcutText() const | CXTPControl |
GetSize(CDC *pDC) | CXTPControl | virtual
GetStyle() const | CXTPControl |
GetStyleEx() const | CXTPControlButton |
GetTag() const | CXTPControl |
GetTooltip() const | CXTPControl | virtual
GetType() const | CXTPControl |
GetWidth() const | CXTPControl |
GetWrap() const | CXTPControl |
HasDwmCompositedRect() const | CXTPControl |
IsCaptionVisible() const | CXTPControl | virtual
IsCursorOver() const | CXTPControl |
IsCustomizeMode() const | CXTPControl | protected
IsCustomizeMovable() const | CXTPControl | virtual
IsCustomizeResizeAllow() const | CXTPControl | protectedvirtual
IsFocusable() const | CXTPControl | protectedvirtual
IsFocused() const | CXTPControl | virtual
IsItemDefault() const | CXTPControl |
IsLayoutChanged() | CXTPControl | protected
IsLayoutRTL() const | CXTPControl | protected
IsOnQuickAccess() const | CXTPControl |
IsTemporary() const | CXTPControl |
IsTransparent() const | CXTPControl | inlinevirtual
IsVisible(DWORD dwSkipFlags=0) const | CXTPControl | virtual
m_bBeginGroup | CXTPControl | protected
m_bChecked | CXTPControl | protected
m_bCloseSubMenuOnClick | CXTPControl | protected
m_bDefaultItem | CXTPControl | protected
m_bEnabled | CXTPControl | protected
m_bExpanded | CXTPControl | protected
m_bLayoutRTL | CXTPControl | protected
m_bOnQuickAccess | CXTPControl | protected
m_bPopup | CXTPControlPopup | protected
m_bPressed | CXTPControl | protected
m_bSelected | CXTPControl | protected
m_bShowShadow | CXTPControlPopup | protected
m_bTemporary | CXTPControl | protected
m_buttonCustomStyle | CXTPControl | protected
m_buttonRibbonStyle | CXTPControl | protected
m_buttonStyle | CXTPControl | protected
m_buttonStyleEx | CXTPControlButton | protected
m_bWrap | CXTPControl | protected
m_controlType | CXTPControl | protected
m_dwCommandBarID | CXTPControlPopup | protected
m_dwFlags | CXTPControl | protected
m_dwHideFlags | CXTPControl | protected
m_mapDocTemplatesAssigned | CXTPControl | protected
m_mapDocTemplatesExcluded | CXTPControl | protected
m_nCustomIconId | CXTPControl | protected
m_nExecuteOnPressInterval | CXTPControl | protected
m_nHeight | CXTPControl | protected
m_nHelpId | CXTPControl | protected
m_nIconId | CXTPControl | protected
m_nId | CXTPControl | protected
m_nIndex | CXTPControl | protected
m_nTag | CXTPControl | protected
m_nWidth | CXTPControl | protected
m_pAction | CXTPControl | protected
m_pCommandBar | CXTPControlPopup | protected
m_pControls | CXTPControl | protected
m_pParent | CXTPControl | protected
m_pRibbonGroup | CXTPControl | protected
m_rcControl | CXTPControl | protected
m_rcRow | CXTPControl | protected
m_strCaption | CXTPControl | protected
m_strCategory | CXTPControl | protected
m_strCustomCaption | CXTPControl | protected
m_strDescriptionText | CXTPControl | protected
m_strKeyboardTip | CXTPControl | protected
m_strParameter | CXTPControl | protected
m_strShortcutText | CXTPControl | protected
m_strShortcutTextAuto | CXTPControl | protected
m_strTooltipText | CXTPControl | protected
m_szIcon | CXTPControl | protected
NotifySite(UINT code) | CXTPControl |
NotifySite(UINT code, NMXTPCONTROL *pNM) | CXTPControl |
NotifySite(CWnd *pSite, UINT code, NMXTPCONTROL *pNM) | CXTPControl |
OnActionChanged(int nProperty) | CXTPControl | protectedvirtual
OnActionChanging(int nProperty) | CXTPControl | protectedvirtual
OnCalcDynamicSize(DWORD dwMode) | CXTPControl | virtual
OnCaptionChanged() | CXTPControl | protectedvirtual
OnClick(BOOL bKeyboard=FALSE, CPoint pt=CPoint(0, 0)) | CXTPControlPopup | protectedvirtual
OnCustomizeDragOver(CXTPControl *pDataObject, CPoint point, DROPEFFECT &dropEffect) | CXTPControlPopup | protectedvirtual
OnCustomizeMouseMove(CPoint point) | CXTPControl | protected
OnEnabledChanged() | CXTPControl | virtual
OnExecute() | CXTPControl | virtual
OnHookKeyDown(UINT nChar, LPARAM lParam) | CXTPControl | protectedvirtual
OnHookMouseWheel(UINT nFlags, short zDelta, CPoint point) | CXTPControl | protectedvirtual
OnIdleUpdate() | CXTPControl | protectedvirtual
OnLButtonDblClk(CPoint point) | CXTPControlPopup | protectedvirtual
OnLButtonDown(CPoint point) | CXTPControl | protectedvirtual
OnLButtonUp(CPoint point) | CXTPControlPopup | protectedvirtual
OnMouseHover() | CXTPControlPopup | protectedvirtual
OnMouseMove(CPoint point) | CXTPControlPopup | protectedvirtual
OnRButtonDown(CPoint point) | CXTPControl | protectedvirtual
OnRButtonUp(CPoint point) | CXTPControl | protectedvirtual
OnRemoved() | CXTPControl | protectedvirtual
OnSetPopup(BOOL bPopup) | CXTPControlPopup | protectedvirtual
OnSetSelected(int bSelected) | CXTPControlPopup | protectedvirtual
OnThemeChanged() | CXTPControl | virtual
OnToolHitTest(CPoint point, TOOLINFO *pTI) const | CXTPControl | protectedvirtual
OnUnderlineActivate() | CXTPControlPopup | virtual
RedrawParent(BOOL bAnimate=TRUE) | CXTPControl |
Reset() | CXTPControl |
RestoreCommandBarList(CXTPCommandBarList *pCommandBarList) | CXTPControlPopup | protectedvirtual
ScreenToClient(CPoint *point) | CXTPControl | protected
SetAction(CXTPControlAction *pAction) | CXTPControl | virtual
SetBeginGroup(BOOL bBeginGroup) | CXTPControl | virtual
SetCaption(LPCTSTR lpszCaption) | CXTPControl |
SetCaption(UINT nIDCaption) | CXTPControl |
SetCategory(LPCTSTR lpszCategory) | CXTPControl |
SetChecked(BOOL bChecked) | CXTPControl | virtual
SetCloseSubMenuOnClick(BOOL bCloseOnClick) | CXTPControl |
SetColor(COLORREF clr) | CXTPControlPopupColor |
SetCommandBar(CMenu *pMenu) | CXTPControlPopup |
SetCommandBar(CXTPCommandBar *pBar) | CXTPControlPopup |
SetCustomIcon(HICON hIcon) | CXTPControl |
SetCustomShortcutText(LPCTSTR lpszCustomShortcutText) | CXTPControl |
SetDescription(LPCTSTR lpszDescription) | CXTPControl |
SetEnabled(BOOL bEnabled) | CXTPControl | virtual
SetExecuteOnPressInterval(int nExecuteOnPressInterval) | CXTPControl |
SetExpanded(BOOL bExpanded) | CXTPControl | protected
SetFlags(DWORD dwFlags) | CXTPControl |
SetFocused(BOOL bFocused) | CXTPControl | virtual
SetHeight(int nHeight) | CXTPControl | virtual
SetHelpId(int nId) | CXTPControl |
SetHideFlag(XTPControlHideFlags dwFlag, BOOL bSet) | CXTPControl |
SetHideFlags(DWORD dwFlags) | CXTPControl | virtual
SetHideWrap(BOOL bHide) | CXTPControl |
SetIconId(int nId) | CXTPControl |
SetIconSize(CSize szIcon) | CXTPControl |
SetID(int nId) | CXTPControl |
SetIndex(int nIndex) | CXTPControl | inlineprotected
SetItemDefault(BOOL bDefault) | CXTPControl |
SetKeyboardTip(LPCTSTR lpszKeyboardTip) | CXTPControl |
SetOnQuickAccess(BOOL bOnQuicAccess=FALSE) | CXTPControl |
SetParameter(LPCTSTR lpszParameter) | CXTPControl |
SetParent(CXTPCommandBar *pParent) | CXTPControl | inlineprotectedvirtual
SetPressed(BOOL bPressed) | CXTPControl |
SetPrompt(LPCTSTR lpszPrompt) | CXTPControl |
SetRect(CRect rcControl) | CXTPControl | virtual
SetRowRect(CRect rcRow) | CXTPControl |
SetShortcutText(LPCTSTR lpszShortcutText) | CXTPControl |
SetStyle(XTPButtonStyle buttonStyle) | CXTPControl |
SetStyleEx(XTPButtonStyle buttonStyle) | CXTPControlButton |
SetTag(DWORD_PTR dwTag) | CXTPControl |
SetTooltip(LPCTSTR lpszTooltip) | CXTPControl |
SetVisible(BOOL bVisible) | CXTPControl |
SetWidth(int nWidth) | CXTPControl | virtual
SetWrap(BOOL bWrap) | CXTPControl |
UpdateShadow() | CXTPControlPopup | protectedvirtual
~CXTPControl() | CXTPControl | protectedvirtual
~CXTPControlButton() | CXTPControlButton | virtual
~CXTPControlPopup() | CXTPControlPopup | virtual
~CXTPControlPopupColor() | CXTPControlPopupColor |


Toolkit Pro: Member List

CXTPSyntaxEditColorInfoArray Member List

This is the complete list of members for CXTPSyntaxEditColorInfoArray, including all inherited members.

CXTPSyntaxEditColorInfoArray() | CXTPSyntaxEditColorInfoArray | inline
RemoveAll() | CXTPSyntaxEditColorInfoArray | inline
~CXTPSyntaxEditColorInfoArray() | CXTPSyntaxEditColorInfoArray | inlinevirtual


Toolkit Pro: Member List

CXTPCalendarEvent Member List

This is the complete list of members for CXTPCalendarEvent, including all inherited members.

CalcStartEndDatesFromPattern() | CXTPCalendarEvent | protectedvirtual
Clear() | CXTPCalendarEvent | protectedvirtual
ClearIntermediateData() | CXTPCalendarEvent | protectedvirtual
CloneEvent() | CXTPCalendarEvent | virtual
CloneEventTo(CXTPCalendarEvent *pEventDest) | CXTPCalendarEvent | virtual
CloneForOccurrence(COleDateTime dtStart, COleDateTime dtEnd, DWORD dwNewEventID=XTP_CALENDAR_UNKNOWN_EVENT_ID) | CXTPCalendarEvent | virtual
CXTPCalendarEvent(CXTPCalendarData *pDataProvider) | CXTPCalendarEvent |
CXTPCmdTarget() | CXTPCmdTarget |
DoPropExchange(CXTPPropExchange *pPX) | CXTPCalendarEvent | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetBody() const | CXTPCalendarEvent | virtual
GetBusyStatus() const | CXTPCalendarEvent | virtual
GetCategories() const | CXTPCalendarEvent |
GetCategoriesCount() const | CXTPCalendarEvent |
GetCreationTime() const | CXTPCalendarEvent | virtual
GetCustomIcons() const | CXTPCalendarEvent |
GetCustomProperties() const | CXTPCalendarEvent |
GetDataProvider() const | CXTPCalendarEvent |
GetDuration() const | CXTPCalendarEvent | virtual
GetDurationMinutes() const | CXTPCalendarEvent | virtual
GetEndTime() const | CXTPCalendarEvent | virtual
GetEventID() const | CXTPCalendarEvent | virtual
GetEventPeriodDays() const | CXTPCalendarEvent | virtual
GetImportance() const | CXTPCalendarEvent | virtual
GetLabel() const | CXTPCalendarEvent | virtual
GetLabelID() const | CXTPCalendarEvent | virtual
GetLastModificationTime() const | CXTPCalendarEvent | virtual
GetLocation() const | CXTPCalendarEvent | virtual
GetRecurrencePattern() const | CXTPCalendarEvent | virtual
GetRecurrencePatternID() const | CXTPCalendarEvent | virtual
GetRecurrenceState() const | CXTPCalendarEvent | virtual
GetReminderMinutesBeforeStart() const | CXTPCalendarEvent | virtual
GetReminderSoundFile() const | CXTPCalendarEvent | virtual
GetRException_EndTimeOrig() const | CXTPCalendarEvent | virtual
GetRException_StartTimeOrig() const | CXTPCalendarEvent | virtual
GetRPatternRef() const | CXTPCalendarEvent |
GetScheduleID() const | CXTPCalendarEvent | virtual
GetScheduleSet() const | CXTPCalendarEvent | virtual
GetStartTime() const | CXTPCalendarEvent | virtual
GetSubject() const | CXTPCalendarEvent | virtual
IsAllDayEvent() const | CXTPCalendarEvent | virtual
IsEqualIDs(const CXTPCalendarEvent *pEvent) const | CXTPCalendarEvent |
IsEqualStartEnd(const CXTPCalendarEvent *pEvent) const | CXTPCalendarEvent |
IsEventVisible() const | CXTPCalendarEvent |
IsMeeting() const | CXTPCalendarEvent | virtual
IsPrivate() const | CXTPCalendarEvent | virtual
IsReminder() const | CXTPCalendarEvent | virtual
IsRExceptionDeleted() const | CXTPCalendarEvent | virtual
IsSound() const | CXTPCalendarEvent | virtual
m_bAllDayEvent | CXTPCalendarEvent | protected
m_bEventVisible | CXTPCalendarEvent | protected
m_bMeeting | CXTPCalendarEvent | protected
m_bPrivate | CXTPCalendarEvent | protected
m_bReminder | CXTPCalendarEvent | protected
m_bRExceptionDeleted | CXTPCalendarEvent | protected
m_dtCreationTime | CXTPCalendarEvent | protected
m_dtEndTime | CXTPCalendarEvent | protected
m_dtLastModificationTime | CXTPCalendarEvent | protected
m_dtRException_EndTimeOrig | CXTPCalendarEvent | protected
m_dtRException_StartTimeOrig | CXTPCalendarEvent | protected
m_dtStartTime | CXTPCalendarEvent | protected
m_dwEventID | CXTPCalendarEvent | protected
m_dwRecurrencePatternID | CXTPCalendarEvent | protected
m_dwRecurrencePatternID_ToUse | CXTPCalendarEvent | protected
m_nBusyStatus | CXTPCalendarEvent | protected
m_nImportance | CXTPCalendarEvent | protected
m_nLabelID | CXTPCalendarEvent | protected
m_nRecurrenceState | CXTPCalendarEvent | protected
m_nReminderMinutesBeforeStart | CXTPCalendarEvent | protected
m_pCustomIconsIDs | CXTPCalendarEvent | protected
m_pCustomProperties | CXTPCalendarEvent | protected
m_pDataProvider | CXTPCalendarEvent | protected
m_pEventCategoryIDs | CXTPCalendarEvent | protected
m_ptrRPattern | CXTPCalendarEvent | protected
m_sMultipleSchedules | CXTPCalendarEvent | protected
m_strBody | CXTPCalendarEvent | protected
m_strLocation | CXTPCalendarEvent | protected
m_strReminderSoundFile | CXTPCalendarEvent | protected
m_strSubject | CXTPCalendarEvent | protected
m_uScheduleID | CXTPCalendarEvent | protected
MakeAsRException(DWORD dwPatternID=XTP_CALENDAR_UNKNOWN_RECURRENCE_PATTERN_ID) | CXTPCalendarEvent | virtual
MakeEventAsRecurrence() | CXTPCalendarEvent | virtual
MoveEvent(COleDateTime dtNewStartTime) | CXTPCalendarEvent | virtual
RemoveRecurrence() | CXTPCalendarEvent | virtual
SetAllDayEvent(BOOL bSet=TRUE) | CXTPCalendarEvent | virtual
SetBody(LPCTSTR pcszDesc) | CXTPCalendarEvent | virtual
SetBusyStatus(int Status) | CXTPCalendarEvent | virtual
SetCreationTime(COleDateTime dtTime) | CXTPCalendarEvent | virtual
SetDuration(COleDateTimeSpan spDuration, BOOL bKeepStart=TRUE) | CXTPCalendarEvent | virtual
SetEndTime(COleDateTime dtEnd) | CXTPCalendarEvent | virtual
SetEventID(DWORD dwEventID) | CXTPCalendarEvent | virtual
SetEventVisible(BOOL bSet) | CXTPCalendarEvent |
SetImportance(int nImportance) | CXTPCalendarEvent | virtual
SetLabelID(int nLabelID) | CXTPCalendarEvent | virtual
SetLastModificationTime(COleDateTime dtTime) | CXTPCalendarEvent | virtual
SetLocation(LPCTSTR pcszLocation) | CXTPCalendarEvent | virtual
SetMeeting(BOOL bMeeting=TRUE) | CXTPCalendarEvent | virtual
SetPrivate(BOOL bPrivate=TRUE) | CXTPCalendarEvent | virtual
SetRecurrencePatternID(DWORD dwRecurrencePatternID) | CXTPCalendarEvent | virtual
SetRecurrenceState_ExceptionOccurrence(XTPCalendarEventRecurrenceState nState, DWORD dwNewPatternID=XTP_CALENDAR_UNKNOWN_RECURRENCE_PATTERN_ID) | CXTPCalendarEvent | protectedvirtual
SetRecurrenceState_Master(CXTPCalendarRecurrencePattern *pPattern) | CXTPCalendarEvent | protectedvirtual
SetRecurrenceState_NotRecurring() | CXTPCalendarEvent | protectedvirtual
SetReminder(BOOL bReminder) | CXTPCalendarEvent | virtual
SetReminderMinutesBeforeStart(int nMinutes) | CXTPCalendarEvent | virtual
SetReminderSoundFile(LPCTSTR pcszFile) | CXTPCalendarEvent | virtual
SetRException_EndTimeOrig(COleDateTime dtEndOrig) | CXTPCalendarEvent | virtual
SetRException_StartTimeOrig(COleDateTime dtStartOrig) | CXTPCalendarEvent | virtual
SetRExceptionDeleted(BOOL bDeleted=TRUE) | CXTPCalendarEvent | virtual
SetScheduleID(UINT uScheduleID) | CXTPCalendarEvent | virtual
SetScheduleSet(CString ScheduleSet) | CXTPCalendarEvent | virtual
SetStartTime(COleDateTime dtStart) | CXTPCalendarEvent | virtual
SetSubject(LPCTSTR pcszSubject) | CXTPCalendarEvent | virtual
Update(CXTPCalendarEvent *pNewData) | CXTPCalendarEvent | virtual
UpdateRecurrence(CXTPCalendarRecurrencePattern *pRPattern) | CXTPCalendarEvent | virtual
UpdateStartEndDatesFromPatternExceptions() | CXTPCalendarEvent | protectedvirtual
~CXTPCalendarEvent() | CXTPCalendarEvent | virtual


Toolkit Pro: XTPDockingPaneContext.h Source File

  • Source
  • DockingPane
XTPDockingPaneContext.h
Go to the documentation of this file.
1
23#if !defined(__XTPDOCKINGPANECONTEXT_H__)
24# define __XTPDOCKINGPANECONTEXT_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPDockingPane;
34class CXTPDockingPaneBase;
35class CXTPDockingPaneManager;
36class CXTPDockingPaneContext;
37class CXTPMarkupThemePart;
38class CXTPImageManager;
39class CXTPMarkupContext;
40
46class _XTP_EXT_CLASS CXTPDockingPaneContextAlphaWnd : public CWnd
47{
48 DECLARE_DYNCREATE(CXTPDockingPaneContextAlphaWnd);
49
50public:
55 CXTPDockingPaneContextAlphaWnd();
56
62 virtual ~CXTPDockingPaneContextAlphaWnd();
63
64protected:
66 DECLARE_MESSAGE_MAP()
67 //{{AFX_MSG(CXTPDockingPaneContextAlphaWnd)
68 afx_msg BOOL OnEraseBkgnd(CDC* pDC);
69 afx_msg void OnPaint();
70 //}}AFX_MSG
73 friend class CXTPDockingPaneContext;
74};
75
81class _XTP_EXT_CLASS CXTPDockingPaneContextStickerWnd : public CWnd
82{
83public:
89 CXTPDockingPaneContextStickerWnd(CXTPDockingPaneContext* pContext);
90
96 virtual ~CXTPDockingPaneContextStickerWnd();
97
98public:
104 void OnDraw(CDC* pDC);
105
107public:
108 XTPDockingPaneStickerType HitTest(CPoint pt);
109 struct SPRITEINFO;
110
111protected:
112 void DrawSprite(CDC* pDC, UINT nID, SPRITEINFO* pSpriteInfo, BOOL bClientBitmap = TRUE);
113 void DrawTransparent(CDC* pDC, const CPoint& ptDest, const CSize& sz, CBitmap* pBitmap);
114
115protected:
116 DECLARE_MESSAGE_MAP()
117
118 //{{AFX_MSG(CXTPDockingPaneContextStickerWnd)
119 afx_msg BOOL OnEraseBkgnd(CDC* pDC);
120 afx_msg void OnPaint();
121 //}}AFX_MSG
124public:
125 XTPDockingPaneStickerType m_typeSticker;
126 XTPDockingPaneStickerType m_selectedSticker;
127 CXTPDockingPaneContext* m_pContext;
129 friend class CXTPDockingPaneContext;
130
131 void Init();
132
133protected:
134 const UINT STICKERS_BACK;
135 const UINT STICKERS_CENTER;
136 const UINT STICKERS_LEFT;
137 const UINT STICKERS_TOP;
138 const UINT STICKERS_RIGHT;
139 const UINT STICKERS_BOTTOM;
140
141 void InitSize_VC2005();
142 void InitIcons_VC2005();
143 void InitSize_VC2008();
144 void InitIcons_VC2008();
145 void InitSize();
146 void InitColors();
147 void InitIcons();
148
149 CXTPImageManager* m_pImgManager;
150 CXTPMarkupContext* m_pMarkupContext;
151 CXTPMarkupThemePart* m_partBackNormal;
152 CXTPMarkupThemePart* m_partBackSelected;
153 CXTPMarkupThemePart* m_partSmallBackNormal;
154 CXTPMarkupThemePart* m_partSmallBackSelected;
155 CXTPMarkupThemePart* m_partLeftNormal;
156 CXTPMarkupThemePart* m_partLeftSelected;
157 CXTPMarkupThemePart* m_partTopNormal;
158 CXTPMarkupThemePart* m_partTopSelected;
159 CXTPMarkupThemePart* m_partRightNormal;
160 CXTPMarkupThemePart* m_partRightSelected;
161 CXTPMarkupThemePart* m_partBottomNormal;
162 CXTPMarkupThemePart* m_partBottomSelected;
163 CXTPMarkupThemePart* m_partCenterNormal;
164 CXTPMarkupThemePart* m_partCenterSelected;
165
166 CSize m_szIcon;
167 int m_delimeterX;
168 int m_delimeterY;
169 CRect m_rcSticker;
170 CRect m_rcBack_3x3;
171 CRect m_rcBack_1x1;
172 CRect m_rcLeft;
173 CRect m_rcTop;
174 CRect m_rcRight;
175 CRect m_rcBottom;
176 CRect m_rcCenter;
177};
178
184class _XTP_EXT_CLASS CXTPDockingPaneContext
185{
186public:
191 CXTPDockingPaneContext();
192
197 virtual ~CXTPDockingPaneContext();
198
199public:
206 virtual void Drag(CXTPDockingPaneBase* pPane, CPoint point);
207
215 void Drag(CXTPDockingPaneBase* pPane, CPoint point, CRect rcPane);
216
225 virtual void OnSizingFloatingFrame(CXTPDockingPaneMiniWnd* pWnd, UINT nSide, LPRECT lpRect);
226
227protected:
232 virtual void Track();
233
239 virtual void Move(CPoint pt);
240
245 virtual void InitLoop();
246
251 virtual void CancelLoop();
252
258 virtual void DrawFocusRect(BOOL bRemoveRect = FALSE);
259
260protected:
268 static void AFX_CDECL AdjustRectangle(CRect& rect, CPoint pt);
269
276 static void AFX_CDECL AdjustCursor(CPoint& pt);
277
283 void CreateContextWindow(CXTPDockingPaneContextAlphaWnd* pWnd);
284
289 void UpdateDockingStickers();
290
295 void DestroyDockingStickers();
296
305 CXTPDockingPaneContextStickerWnd* CreateNewSticker(CRect rc,
306 XTPDockingPaneStickerType typeSticker);
307
309public:
310 CSize GetStickerSize(XTPDockingPaneStickerType type) const;
311 XTPDockingContextStickerStyle GetStickerStyle() const;
312 static void AFX_CDECL EnsureVisible(CRect& rectDragFrame);
313
314protected:
315 void _CreateRectangleRgn(CRgn& rgnResult, CRect rc);
316 void _CreateRgn(CRgn& rgnResult, CRect rc, BOOL bTabbedRgn, BOOL bRemove = FALSE);
317 virtual void FindContainer(CPoint pt);
318 BOOL CanDock(CRect rc, CPoint pt, CXTPDockingPaneBase* pPane, BOOL bInside = TRUE);
319 BOOL CanSideDock(CXTPDockingPaneBase* pPane, CRect rcFrame);
320
321 void RegionFromBitmap(CRgn* pRgn, CDC* pDC, CRect rc);
322 BOOL IsAllowDockingTo(CXTPDockingPaneBase* pPane, XTPDockingPaneDirection direction);
323 BOOL IsAllowAttachTo(CXTPDockingPaneBase* pPane);
324 virtual void UpdateStickyFrame(CRect& rectDragFrame);
325 void UpdateStickyFrame(CRect& rectDragFrame, CWnd* pHost);
326 void UpdateSizingStickyFrame(UINT nSide, CRect& rectDragFrame, CWnd* pWnd);
327
328 BOOL IsBehind(CXTPDockingPaneBase* pPane, CXTPDockingPaneBase* pPaneRef);
329
330 void AcquireDesktopDC();
331 void ReleaseDesktopDC();
332
333# ifndef _XTP_ACTIVEX
334# ifdef _XTP_INCLUDE_COMMANDBARS
335 BOOL IsAllowAttachToTabClient(CXTPDockingPaneBase* pPane);
336# endif
337# endif
338
341private:
342 void IncludeRgnPart(CRgn* pRgn, int x1, int y, int x2);
343 void ProcessPendingPaintMessages();
344
345protected:
346 CXTPDockingPaneContextAlphaWnd m_wndContext;
347 CXTPDockingPaneContextAlphaWnd m_wndAttachedTab;
349 PVOID m_pfnSetLayeredWindowAttributes;
351 BOOL m_bUseDockingStickers;
352 BOOL m_bUseAlphaContext;
354 CRect m_rectStickerPane;
355 CXTPDockingPaneBase* m_pStickerPane;
356 CXTPDockingPaneBase* m_pLastStickerPane;
358 CList<CXTPDockingPaneContextStickerWnd*, CXTPDockingPaneContextStickerWnd*>
359 m_lstStickers;
360 CPoint m_ptLast;
361 CPoint m_ptSticky;
362 CRect m_rectDragFrame;
363 CRect m_rectDragFrameScreen;
364 CXTPDockingPaneManager* m_pManager;
365 CXTPDockingPaneBase* m_pPane;
366 BOOL m_bDragKeyboard;
368protected:
370 BOOL m_bResetDC;
371 CXTPDockingPaneBase* m_pContainer;
372 CRect m_rectContainer;
373 BOOL m_bAttachLast;
374 BOOL m_bAttach;
375 BOOL m_bSideDock;
376 BOOL m_bFloatable;
377 BOOL m_bDockable;
378 CRect m_rectLast;
379 CSize m_sizeLast;
380 BOOL m_bDitherLast;
381 CMap<UINT, UINT, CRgn*, CRgn*> m_rgnStickers;
382 XTPDockingPaneDirection m_containDirection;
383 CDC* m_pDC;
386private:
387 friend class CXTPDockingPaneManager;
388 friend class CXTPDockingPaneContextAlphaWnd;
389 friend class CXTPDockingPaneContextStickerWnd;
390};
392# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
393#endif // #if !defined(__XTPDOCKINGPANECONTEXT_H__)
XTPDisableNoisyWarnings.h
XTPDockingPaneDirection
XTPDockingPaneDirection
Docking direction enumeration.
Definition XTPDockingPaneDefines.h:51
XTPDockingContextStickerStyle
XTPDockingContextStickerStyle
Docking Panes sticker style enumeration.
Definition XTPDockingPaneDefines.h:155
XTPDockingPaneStickerType
XTPDockingPaneStickerType
XTPDockingPaneStickerType is an enumeration that is used to indicate which docking stickers are to be...
Definition XTPDockingPaneDefines.h:362
XTPEnableNoisyWarnings.h
CXTPDockingPaneBase
CXTPDockingPaneBase is a standalone class.
Definition XTPDockingPaneBase.h:69
CXTPDockingPaneContextAlphaWnd
CXTPDockingPaneContextAlphaWnd is a CWnd derived class that represents an alpha context helper window...
Definition XTPDockingPaneContext.h:47
CXTPDockingPaneContextAlphaWnd::CXTPDockingPaneContextAlphaWnd
CXTPDockingPaneContextAlphaWnd()
Constructs a CXTPDockingPaneContextAlphaWnd object.
CXTPDockingPaneContextAlphaWnd::~CXTPDockingPaneContextAlphaWnd
virtual ~CXTPDockingPaneContextAlphaWnd()
Destroys a CXTPDockingPaneContextAlphaWnd object, handles cleanup and deallocation.
CXTPDockingPaneContext
CXTPDockingPaneContext is a standalone class.
Definition XTPDockingPaneContext.h:185
CXTPDockingPaneContext::m_bUseDockingStickers
BOOL m_bUseDockingStickers
TRUE to use docking stickers.
Definition XTPDockingPaneContext.h:351
CXTPDockingPaneContext::AdjustRectangle
static void AFX_CDECL AdjustRectangle(CRect &rect, CPoint pt)
Call this member to adjust the rectangle.
CXTPDockingPaneContext::CXTPDockingPaneContext
CXTPDockingPaneContext()
Constructs a CXTPDockingPaneContext object.
CXTPDockingPaneContext::CancelLoop
virtual void CancelLoop()
This member function is called when a loop is canceled.
CXTPDockingPaneContext::DestroyDockingStickers
void DestroyDockingStickers()
Call this member to remove the docking stickers.
CXTPDockingPaneContext::m_wndContext
CXTPDockingPaneContextAlphaWnd m_wndContext
Alpha context control.
Definition XTPDockingPaneContext.h:346
CXTPDockingPaneContext::m_pManager
CXTPDockingPaneManager * m_pManager
Parent pane manager.
Definition XTPDockingPaneContext.h:364
CXTPDockingPaneContext::CreateNewSticker
CXTPDockingPaneContextStickerWnd * CreateNewSticker(CRect rc, XTPDockingPaneStickerType typeSticker)
Creates a new sticker window.
CXTPDockingPaneContext::m_bDragKeyboard
BOOL m_bDragKeyboard
TRUE if the keyboard was used to drag the pane.
Definition XTPDockingPaneContext.h:366
CXTPDockingPaneContext::CreateContextWindow
void CreateContextWindow(CXTPDockingPaneContextAlphaWnd *pWnd)
Call this member function to create a context menu.
CXTPDockingPaneContext::m_ptSticky
CPoint m_ptSticky
Position of the sticky control.
Definition XTPDockingPaneContext.h:361
CXTPDockingPaneContext::Drag
virtual void Drag(CXTPDockingPaneBase *pPane, CPoint point)
Call this member to drag a pane.
CXTPDockingPaneContext::m_pStickerPane
CXTPDockingPaneBase * m_pStickerPane
Sticker Pane.
Definition XTPDockingPaneContext.h:355
CXTPDockingPaneContext::Drag
void Drag(CXTPDockingPaneBase *pPane, CPoint point, CRect rcPane)
Call this member to drag a pane.
CXTPDockingPaneContext::AdjustCursor
static void AFX_CDECL AdjustCursor(CPoint &pt)
Moves the cursor to the available work area.
CXTPDockingPaneContext::m_rectStickerPane
CRect m_rectStickerPane
Area occupied by the sticker pane.
Definition XTPDockingPaneContext.h:354
CXTPDockingPaneContext::DrawFocusRect
virtual void DrawFocusRect(BOOL bRemoveRect=FALSE)
This member function is called to draw the focus rectangle.
CXTPDockingPaneContext::InitLoop
virtual void InitLoop()
Call this member function to initialize a loop.
CXTPDockingPaneContext::Move
virtual void Move(CPoint pt)
This method is called when the user moves the mouse cursor in track mode.
CXTPDockingPaneContext::m_rectDragFrameScreen
CRect m_rectDragFrameScreen
Screen drag frame.
Definition XTPDockingPaneContext.h:363
CXTPDockingPaneContext::m_pPane
CXTPDockingPaneBase * m_pPane
Pointer to the associated pane.
Definition XTPDockingPaneContext.h:365
CXTPDockingPaneContext::m_pfnSetLayeredWindowAttributes
PVOID m_pfnSetLayeredWindowAttributes
Pointer to SetLayeredWindowAttributes method.
Definition XTPDockingPaneContext.h:349
CXTPDockingPaneContext::m_bUseAlphaContext
BOOL m_bUseAlphaContext
TRUE to use alpha context.
Definition XTPDockingPaneContext.h:352
CXTPDockingPaneContext::OnSizingFloatingFrame
virtual void OnSizingFloatingFrame(CXTPDockingPaneMiniWnd *pWnd, UINT nSide, LPRECT lpRect)
This method is called inside the WM_SIZING handler of a mini-frame to update the sticky position of t...
CXTPDockingPaneContext::m_wndAttachedTab
CXTPDockingPaneContextAlphaWnd m_wndAttachedTab
Attached tab control.
Definition XTPDockingPaneContext.h:347
CXTPDockingPaneContext::Track
virtual void Track()
This method is called to track the size of the pane.
CXTPDockingPaneContext::m_lstStickers
CList< CXTPDockingPaneContextStickerWnd *, CXTPDockingPaneContextStickerWnd * > m_lstStickers
List of the stickers.
Definition XTPDockingPaneContext.h:359
CXTPDockingPaneContext::~CXTPDockingPaneContext
virtual ~CXTPDockingPaneContext()
Destroys a CXTPDockingPaneContext object, handles cleanup and deallocation.
CXTPDockingPaneContext::m_ptLast
CPoint m_ptLast
Holds the last selection point.
Definition XTPDockingPaneContext.h:360
CXTPDockingPaneContext::UpdateDockingStickers
void UpdateDockingStickers()
Call this member function to refresh the docking stickers.
CXTPDockingPaneContext::m_rectDragFrame
CRect m_rectDragFrame
Area occupied by the drag frame.
Definition XTPDockingPaneContext.h:362
CXTPDockingPaneContext::m_pLastStickerPane
CXTPDockingPaneBase * m_pLastStickerPane
Last Sticker Pane.
Definition XTPDockingPaneContext.h:356
CXTPDockingPaneContextStickerWnd
CXTPDockingPaneContextStickerWnd is a CWnd derived class that represents a sticker window.
Definition XTPDockingPaneContext.h:82
CXTPDockingPaneContextStickerWnd::OnDraw
void OnDraw(CDC *pDC)
This method is called to draw the sticker.
CXTPDockingPaneContextStickerWnd::CXTPDockingPaneContextStickerWnd
CXTPDockingPaneContextStickerWnd(CXTPDockingPaneContext *pContext)
Constructs a CXTPDockingPaneContextStickerWnd object.
CXTPDockingPaneContextStickerWnd::~CXTPDockingPaneContextStickerWnd
virtual ~CXTPDockingPaneContextStickerWnd()
Destroys a CXTPDockingPaneContextStickerWnd object, handles cleanup and deallocation.
CXTPDockingPane
CXTPDockingPane is a CXTPDockingPaneBase derived class.
Definition XTPDockingPane.h:44
CXTPDockingPaneManager
CXTPDockingPaneManager is a CWnd derived class.
Definition XTPDockingPaneManager.h:58
CXTPDockingPaneMiniWnd
CXTPDockingPaneMiniWnd is a multiple inheritance class derived from CMiniFrameWnd and CXTPDockingPane...
Definition XTPDockingPaneMiniWnd.h:42
CXTPImageManager
CXTPImageManager is a standalone class.
Definition XTPImageManager.h:1898
CXTPMarkupContext
CXTPMarkupContext is a standalone class used to provide common settings for Markup objects.
Definition XTPMarkupContext.h:128
CXTPMarkupThemePart
The CXTPMarkupThemePart class is used to create a theme part object used for rendering.
Definition XTPMarkupTheme.h:42


Toolkit Pro: XTPStatusBarThemeVisualStudio2012.h Source File

  • Source
  • CommandBars
  • StatusBar
XTPStatusBarThemeVisualStudio2012.h
Go to the documentation of this file.
1
23#if !defined(__XTPSTATUSBARTHEMEVISUALSTUDIO2012_H__)
24# define __XTPSTATUSBARTHEMEVISUALSTUDIO2012_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class _XTP_EXT_CLASS CXTPStatusBarThemeVisualStudio2012 : public CXTPStatusBarPaintManager
34{
35public:
36 CXTPStatusBarThemeVisualStudio2012(CXTPPaintManager* pPaintManager);
37
44 virtual void FillStatusBar(CDC* pDC, CXTPStatusBar* pBar);
45
54 virtual void DrawStatusBarPaneBorder(CDC* pDC, CRect rc, CXTPStatusBarPane* pPane,
55 BOOL bGripperPane);
56
63 virtual void DrawStatusBarGripper(CDC* pDC, CRect rcClient);
64
69 virtual void RefreshMetrics();
70};
71
73# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
74#endif // !defined(__XTPSTATUSBARTHEMEVISUALSTUDIO2012_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPPaintManager
Paint manager of the command bars.
Definition XTPPaintManager.h:199
CXTPStatusBar
CXTPStatusBar is a CControlBar derived class.
Definition XTPStatusBar.h:52
CXTPStatusBarPane
CXTPStatusBarPane is a CXTPCmdTarget derived class.
Definition XTPStatusBarPane.h:39


Toolkit Pro: Member List

CXTPTreeCtrl Member List

This is the complete list of members for CXTPTreeCtrl, including all inherited members.

CXTPTreeCtrl() | CXTPTreeCtrl |
~CXTPTreeCtrl() | CXTPTreeCtrl | virtual


Toolkit Pro: Member List

CXTPPropertyGridView Member List

This is the complete list of members for CXTPPropertyGridView, including all inherited members.

AddCategory(LPCTSTR strCaption, CXTPPropertyGridItem *pCategory=NULL) | CXTPPropertyGridView |
CXTPPropertyGridView() | CXTPPropertyGridView |
FocusInplaceButton(CXTPPropertyGridInplaceButton *pButton) | CXTPPropertyGridView |
GetDividerPos() const | CXTPPropertyGridView |
GetImageManager() const | CXTPPropertyGridView |
GetItem(int nIndex) const | CXTPPropertyGridView |
GetPaintManager() const | CXTPPropertyGridView |
GetPropertyGrid() const | CXTPPropertyGridView |
InsertCategory(int nIndex, LPCTSTR strCaption, CXTPPropertyGridItem *pCategory=NULL) | CXTPPropertyGridView |
ItemFromPoint(CPoint point) const | CXTPPropertyGridView |
LockDivider() | CXTPPropertyGridView |
m_bAutoDivider | CXTPPropertyGridView | protected
m_bTracking | CXTPPropertyGridView | protected
m_bVariableSplitterPos | CXTPPropertyGridView | protected
m_dDivider | CXTPPropertyGridView | protected
m_hCursor | CXTPPropertyGridView | protected
m_nItemHeight | CXTPPropertyGridView | protected
m_nLockUpdate | CXTPPropertyGridView | protected
m_pCategories | CXTPPropertyGridView | protected
m_pFocusedButton | CXTPPropertyGridView | protected
m_pGrid | CXTPPropertyGridView | protected
m_pHotButton | CXTPPropertyGridView | protected
m_properetySort | CXTPPropertyGridView | protected
m_pSelected | CXTPPropertyGridView | protected
m_rcToolTip | CXTPPropertyGridView | protected
m_strTipText | CXTPPropertyGridView | protected
m_wndTip | CXTPPropertyGridView | protected
Refresh() | CXTPPropertyGridView |
ResetContent() | CXTPPropertyGridView |
SendNotifyMessage(WPARAM wParam=0, LPARAM lParam=0) | CXTPPropertyGridView |
SetDividerPos(int nDivider) | CXTPPropertyGridView |
ShowToolTip(CPoint pt) | CXTPPropertyGridView | protectedvirtual
~CXTPPropertyGridView() | CXTPPropertyGridView | virtual


Toolkit Pro: Member List

CXTPDatePickerThemeNativeWindows10 Member List

This is the complete list of members for CXTPDatePickerThemeNativeWindows10, including all inherited members.

CalcDayOfWeekRect(CDC *pDC) | CXTPDatePickerPaintManager | virtual
CalcDayRect(CDC *pDC) | CXTPDatePickerPaintManager | virtual
CalcMonthHeaderRect(CDC *pDC) | CXTPDatePickerPaintManager | virtual
CalcMonthRect(CDC *pDC) | CXTPDatePickerPaintManager | virtual
CalcWeekNumbersRect(CDC *pDC) | CXTPDatePickerPaintManager | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPDatePickerPaintManager() | CXTPDatePickerPaintManager |
CXTPDatePickerThemeNativeWindows10() | CXTPDatePickerThemeNativeWindows10 |
CXTPDatePickerThemeOffice2013() | CXTPDatePickerThemeOffice2013 |
DrawBackground(CDC *pDC, CRect rcClient) | CXTPDatePickerThemeOffice2013 | virtual
DrawBorder(CDC *pDC, const CXTPDatePickerControl *pControl, CRect &rcClient, BOOL bDraw) | CXTPDatePickerThemeOffice2013 | virtual
DrawButton(CDC *pDC, const CRect &rcButton, const CString &strButton, BOOL bIsDown, BOOL bIsHighLight) | CXTPDatePickerThemeOffice2013 | virtual
DrawDay(CDC *pDC, CXTPDatePickerItemDay *pDay) | CXTPDatePickerThemeOffice2013 | virtual
DrawDaysOfWeek(CDC *pDC, CXTPDatePickerItemMonth *pMonth) | CXTPDatePickerThemeOffice2013 | virtual
DrawMonthHeader(CDC *pDC, CXTPDatePickerItemMonth *pMonth) | CXTPDatePickerPaintManager | virtual
DrawScrollTriangle(CDC *pDC, CRect rcSpot, BOOL bLeftDirection, COLORREF clrColor=0, BOOL bYears=FALSE) | CXTPDatePickerPaintManager | virtual
DrawWeekNumbers(CDC *pDC, CXTPDatePickerItemMonth *pMonth) | CXTPDatePickerThemeOffice2013 | virtual
EnableTheme(BOOL bEnableTheme) | CXTPDatePickerPaintManager | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetButtonFont() | CXTPDatePickerPaintManager |
GetControlBackColor() | CXTPDatePickerPaintManager | virtual
GetCursorBack() | CXTPDatePickerPaintManager | virtual
GetDayBackColor() | CXTPDatePickerPaintManager | virtual
GetDaysOfWeekBackColor() | CXTPDatePickerPaintManager | virtual
GetDaysOfWeekTextColor() | CXTPDatePickerPaintManager | virtual
GetDaysOfWeekTextFont() | CXTPDatePickerPaintManager |
GetDayTextColor() | CXTPDatePickerPaintManager | virtual
GetDayTextFont() | CXTPDatePickerPaintManager | virtual
GetDayTextFontBold() | CXTPDatePickerPaintManager | virtual
GetHeaderTextFont() | CXTPDatePickerPaintManager |
GetHighlightTodayBackColor() | CXTPDatePickerThemeOffice2013 | virtual
GetHighlightTodayBorderColor() | CXTPDatePickerThemeOffice2013 | virtual
GetHighlightTodayColor() | CXTPDatePickerPaintManager | virtual
GetHighlightTodayTextColor() | CXTPDatePickerThemeOffice2013 | virtual
GetListControlBackColor() | CXTPDatePickerPaintManager | virtual
GetListControlTextColor() | CXTPDatePickerPaintManager | virtual
GetListControlTextFont() | CXTPDatePickerPaintManager |
GetMonthHeaderBackColor() | CXTPDatePickerPaintManager | virtual
GetMonthHeaderTextColor() | CXTPDatePickerPaintManager | virtual
GetNonMonthDayBackColor() | CXTPDatePickerPaintManager | virtual
GetNonMonthDayTextColor() | CXTPDatePickerPaintManager | virtual
GetNonMonthDayTextFont() | CXTPDatePickerPaintManager |
GetPaintTheme() const | CXTPDatePickerPaintManager | protected
GetSelectedDayBackColor() | CXTPDatePickerPaintManager | virtual
GetSelectedDayTextColor() | CXTPDatePickerPaintManager | virtual
GetWeekNumbersBackColor() | CXTPDatePickerPaintManager | virtual
GetWeekNumbersTextColor() | CXTPDatePickerPaintManager | virtual
GetWeekNumbersTextFont() | CXTPDatePickerPaintManager |
m_bEnableTheme | CXTPDatePickerPaintManager | protected
m_clr3DFace | CXTPDatePickerPaintManager | protected
m_clr3DLight | CXTPDatePickerPaintManager | protected
m_clr3DShadow | CXTPDatePickerPaintManager | protected
m_clr3DText | CXTPDatePickerPaintManager | protected
m_clrBackground | CXTPDatePickerThemeOffice2013 | protected
m_clrButtonFace | CXTPDatePickerPaintManager |
m_clrButtonText | CXTPDatePickerPaintManager |
m_clrControlBack | CXTPDatePickerPaintManager |
m_clrDayBack | CXTPDatePickerPaintManager |
m_clrDaysOfWeekBack | CXTPDatePickerPaintManager |
m_clrDaysOfWeekText | CXTPDatePickerPaintManager |
m_clrDayText | CXTPDatePickerPaintManager |
m_clrHighlightToday | CXTPDatePickerPaintManager |
m_clrListControlBack | CXTPDatePickerPaintManager |
m_clrListControlText | CXTPDatePickerPaintManager |
m_clrMonthBorder | CXTPDatePickerPaintManager |
m_clrMonthHeaderBack | CXTPDatePickerPaintManager |
m_clrMonthHeaderButton | CXTPDatePickerPaintManager |
m_clrMonthHeaderText | CXTPDatePickerPaintManager |
m_clrNonMonthDayBack | CXTPDatePickerPaintManager |
m_clrNonMonthDayText | CXTPDatePickerPaintManager |
m_clrSelectedDayBack | CXTPDatePickerPaintManager |
m_clrSelectedDayText | CXTPDatePickerPaintManager |
m_clrStaticBorder | CXTPDatePickerPaintManager | protected
m_clrWeekNumbersBack | CXTPDatePickerPaintManager |
m_clrWeekNumbersText | CXTPDatePickerPaintManager |
m_hCursorBack | CXTPDatePickerPaintManager | protected
m_nPaintTheme | CXTPDatePickerPaintManager | protected
m_szDayMargin | CXTPDatePickerPaintManager |
m_themeButton | CXTPDatePickerPaintManager | protected
m_xtpFontButton | CXTPDatePickerPaintManager | protected
m_xtpFontDay | CXTPDatePickerPaintManager | protected
m_xtpFontDayBold | CXTPDatePickerPaintManager | protected
m_xtpFontDaysOfWeek | CXTPDatePickerPaintManager | protected
m_xtpFontHeader | CXTPDatePickerPaintManager | protected
m_xtpFontListControl | CXTPDatePickerPaintManager | protected
m_xtpFontNonMonthDay | CXTPDatePickerPaintManager | protected
m_xtpFontWeekNumbers | CXTPDatePickerPaintManager | protected
RefreshMetrics() | CXTPDatePickerThemeOffice2013 | virtual
SetButtonFont(CFont *fontButton) | CXTPDatePickerPaintManager |
SetButtonFontIndirect(LOGFONT *lFont) | CXTPDatePickerPaintManager |
SetFontIndirect(LOGFONT *lFont) | CXTPDatePickerPaintManager |
Triangle(CDC *pDC, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clrColor=0) | CXTPDatePickerPaintManager | protectedvirtual
~CXTPDatePickerPaintManager() | CXTPDatePickerPaintManager | virtual
~CXTPDatePickerThemeNativeWindows10() | CXTPDatePickerThemeNativeWindows10 | virtual
~CXTPDatePickerThemeOffice2013() | CXTPDatePickerThemeOffice2013 | virtual


Toolkit Pro: Member List

CXTPTabPaintManager Member List

This is the complete list of members for CXTPTabPaintManager, including all inherited members.

_GetButtonLength(int nValue, int nMin, int nMax) | CXTPTabPaintManager | protected
AddObserver(CXTPTabManagerAtom *pObserver) | CXTPTabPaintManager |
AdjustClientRect(CXTPTabManager *pTabManager, CRect &rcClient) | CXTPTabPaintManager | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPTabPaintManager(BOOL bPanelManager=FALSE) | CXTPTabPaintManager |
DisableLunaColors(BOOL bDisableLunaColors) | CXTPTabPaintManager |
DrawNavigateButton(CDC *pDC, CXTPTabManagerNavigateButton *pButton, CRect &rc) | CXTPTabPaintManager | virtual
DrawSingleButtonIconAndText(CDC *pDC, CXTPTabManagerItem *pItem, CRect rcItem, BOOL bDraw) | CXTPTabPaintManager | virtual
DrawTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl) | CXTPTabPaintManager | virtual
DrawTabControlEx(CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl) | CXTPTabPaintManager | protected
DrawTextPathEllipsis(CDC *pDC, CXTPTabManager *pManager, const CString &strItem, CRect rcItem, UINT uFormat) | CXTPTabPaintManager | protected
EnableToolTips(XTPTabToolTipBehaviour behaviour=xtpTabToolTipAlways) | CXTPTabPaintManager |
EnsureVisible(CXTPTabManager *pTabManager, CXTPTabManagerItem *pItem) | CXTPTabPaintManager |
FillNavigateButton(CDC *pDC, CXTPTabManagerNavigateButton *pButton, CRect &rc) | CXTPTabPaintManager |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAppearance() const | CXTPTabPaintManager |
GetAppearanceSet() const | CXTPTabPaintManager |
GetBoldFont(BOOL bVertical=FALSE) | CXTPTabPaintManager |
GetColor() const | CXTPTabPaintManager |
GetColorSet() const | CXTPTabPaintManager |
GetFont(BOOL bVertical=FALSE) | CXTPTabPaintManager |
GetLayout() const | CXTPTabPaintManager |
GetOneNoteColor(XTPTabOneNoteColor tabColor) | CXTPTabPaintManager | static
GetPosition() const | CXTPTabPaintManager |
IsLunaColorsDisabled() const | CXTPTabPaintManager |
m_arrObservers | CXTPTabPaintManager | protected
m_bBoldNormal | CXTPTabPaintManager |
m_bBoldSelected | CXTPTabPaintManager |
m_bClearTypeTextQuality | CXTPTabPaintManager |
m_bClipHeader | CXTPTabPaintManager |
m_bDrawFocusRect | CXTPTabPaintManager |
m_bDrawTextEndEllipsis | CXTPTabPaintManager |
m_bDrawTextHidePrefix | CXTPTabPaintManager |
m_bDrawTextNoPrefix | CXTPTabPaintManager |
m_bDrawTextPathEllipsis | CXTPTabPaintManager |
m_bFillBackground | CXTPTabPaintManager |
m_bHotTracking | CXTPTabPaintManager |
m_bInvertGradient | CXTPTabPaintManager |
m_bMultiRowFixedSelection | CXTPTabPaintManager |
m_bMultiRowJustified | CXTPTabPaintManager |
m_bMultiRowTabsOptimization | CXTPTabPaintManager |
m_bOneNoteColors | CXTPTabPaintManager |
m_bPanelManager | CXTPTabPaintManager |
m_bRotateImageOnVerticalDraw | CXTPTabPaintManager |
m_bSelectOnButtonDown | CXTPTabPaintManager |
m_bSelectOnDragOver | CXTPTabPaintManager |
m_bShowIcons | CXTPTabPaintManager |
m_bShowTabs | CXTPTabPaintManager |
m_bStaticFrame | CXTPTabPaintManager |
m_bUseStandardFont | CXTPTabPaintManager | protected
m_bVerticalTextTopToBottom | CXTPTabPaintManager |
m_clientFrame | CXTPTabPaintManager |
m_nButtonExtraLength | CXTPTabPaintManager |
m_nDrawTextFormat | CXTPTabPaintManager |
m_nFixedTabWidth | CXTPTabPaintManager |
m_nMaxTabWidth | CXTPTabPaintManager |
m_nMinTabWidth | CXTPTabPaintManager |
m_nSelectOnDragOverDelay | CXTPTabPaintManager | static
m_pAppearanceSet | CXTPTabPaintManager | protected
m_pColorSet | CXTPTabPaintManager | protected
m_rcButtonMargin | CXTPTabPaintManager |
m_rcButtonTextPadding | CXTPTabPaintManager |
m_rcClientMargin | CXTPTabPaintManager |
m_rcControlMargin | CXTPTabPaintManager |
m_szIcon | CXTPTabPaintManager |
m_szNavigateButton | CXTPTabPaintManager |
m_szTabCloseButton | CXTPTabPaintManager |
m_tabAppearance | CXTPTabPaintManager | protected
m_tabColor | CXTPTabPaintManager | protected
m_tabLayout | CXTPTabPaintManager | protected
m_tabPosition | CXTPTabPaintManager | protected
m_toolBehaviour | CXTPTabPaintManager |
m_xtpFontBold | CXTPTabPaintManager | protected
m_xtpFontNormal | CXTPTabPaintManager | protected
m_xtpFontVerticalBold | CXTPTabPaintManager | protected
m_xtpFontVerticalNormal | CXTPTabPaintManager | protected
OnPropertyChanged() | CXTPTabPaintManager | protectedvirtual
RefreshMetrics() | CXTPTabPaintManager | virtual
RepositionNavigateButtons(CXTPTabManager *pTabManager, CRect rcClient) | CXTPTabPaintManager |
RepositionTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl) | CXTPTabPaintManager | virtual
RepositionTabControlEx(CXTPTabManager *pTabManager, CDC *pDC, CRect rcClient) | CXTPTabPaintManager | protected
RepositionTabControlMultiRow(CXTPTabManager *pTabManager, CDC *pDC, CRect rcClient) | CXTPTabPaintManager | protected
SetAppearance(XTPTabAppearanceStyle tabAppearance) | CXTPTabPaintManager | virtual
SetAppearanceSet(CXTPTabPaintManagerTheme *pAppearanceSet) | CXTPTabPaintManager | virtual
SetColor(XTPTabColorStyle tabColor) | CXTPTabPaintManager | virtual
SetColorSet(CXTPTabPaintManagerColorSet *pColorSet) | CXTPTabPaintManager | virtual
SetFontIndirect(LOGFONT *pLogFont, BOOL bUseStandardFont=FALSE) | CXTPTabPaintManager |
SetLayout(XTPTabLayoutStyle tabLayout) | CXTPTabPaintManager |
SetOneNoteColors(BOOL bOneNoteColors) | CXTPTabPaintManager |
SetPosition(XTPTabPosition tabPosition) | CXTPTabPaintManager |
SizeToFit(CXTPTabManager *pTabManager, int nWidth) | CXTPTabPaintManager | protected
~CXTPTabPaintManager() | CXTPTabPaintManager | virtual


Toolkit Pro: XTPTrackHeader.h Source File

  • Source
  • GridControl
  • TrackControl
XTPTrackHeader.h
Go to the documentation of this file.
1
23#if !defined(__XTPTRACKEADER_H__)
24# define __XTPTRACKEADER_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
37class _XTP_EXT_CLASS CXTPTrackHeader : public CXTPGridHeader
38{
39public:
46 CXTPTrackHeader(CXTPGridControl* pControl, CXTPGridColumns* pColumns);
47
52 ~CXTPTrackHeader();
53
54public:
62 void Draw(CDC* pDC, CRect rcHeader, int nLeftOffset);
63
69 void OnLButtonDown(CPoint ptClick);
70
77 void OnMouseMove(UINT nFlags, CPoint point);
78
85 void StartDragScrollBar(BOOL bResize);
86
93 void StartDragSlider(BOOL bResize);
94
101 void StartDragMarker(int nMarkerIndex);
102
103protected:
111 void OnMoveSlider(CPoint pt, BOOL bResize);
112
119 void OnMoveMarker(CPoint pt, int nMarkerIndex);
120
128 void OnMoveScrollBar(CPoint pt, BOOL bResize);
129
130protected:
131 CPoint m_ptStartDrag;
132 int m_nOldWorkAreaMin;
133 int m_nOldWorkAreaMax;
134 int m_nOldViewPortMin;
135 int m_nOldViewPortMax;
137 int m_nOldMarkerPos;
138};
140# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
141#endif //#if !defined(__XTPTRACKEADER_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPGridColumns
This class is a collection of grid column objects.
Definition XTPGridColumns.h:54
CXTPGridControl
The CXTPGridControl class provides an implementation of the Grid control.
Definition XTPGridControl.h:479
CXTPGridHeader
A grid header is a part of the grid window positioned above columns of text or numbers.
Definition XTPGridHeader.h:173
CXTPTrackHeader
This class represents a track control header.
Definition XTPTrackHeader.h:38
CXTPTrackHeader::OnMoveSlider
void OnMoveSlider(CPoint pt, BOOL bResize)
Call this function to resize/move the slider.
CXTPTrackHeader::StartDragScrollBar
void StartDragScrollBar(BOOL bResize)
This function is called when the scrollbar is about to be resized/dragged.
CXTPTrackHeader::m_nOldWorkAreaMax
int m_nOldWorkAreaMax
The old work area maximum value.
Definition XTPTrackHeader.h:133
CXTPTrackHeader::OnMouseMove
void OnMouseMove(UINT nFlags, CPoint point)
This function is called when the mouse is moved over the header.
CXTPTrackHeader::CXTPTrackHeader
CXTPTrackHeader(CXTPGridControl *pControl, CXTPGridColumns *pColumns)
Creates a CXTPTrackHeader object.
CXTPTrackHeader::m_nOldMarkerPos
int m_nOldMarkerPos
The old marker position.
Definition XTPTrackHeader.h:137
CXTPTrackHeader::m_ptStartDrag
CPoint m_ptStartDrag
The drag start point.
Definition XTPTrackHeader.h:131
CXTPTrackHeader::StartDragSlider
void StartDragSlider(BOOL bResize)
This function is called when the slider is about to be resized/dragged.
CXTPTrackHeader::OnLButtonDown
void OnLButtonDown(CPoint ptClick)
This function is called when the left mouse button is clicked on the header.
CXTPTrackHeader::~CXTPTrackHeader
~CXTPTrackHeader()
CXTPTrackHeader default destructor.
CXTPTrackHeader::m_nOldViewPortMin
int m_nOldViewPortMin
The old view port minimum value.
Definition XTPTrackHeader.h:134
CXTPTrackHeader::m_nOldWorkAreaMin
int m_nOldWorkAreaMin
The old work area minimum value.
Definition XTPTrackHeader.h:132
CXTPTrackHeader::Draw
void Draw(CDC *pDC, CRect rcHeader, int nLeftOffset)
Call this function to draw the block.
CXTPTrackHeader::OnMoveMarker
void OnMoveMarker(CPoint pt, int nMarkerIndex)
Call this function to move the marker.
CXTPTrackHeader::m_nOldViewPortMax
int m_nOldViewPortMax
The old view port maximum value.
Definition XTPTrackHeader.h:135
CXTPTrackHeader::OnMoveScrollBar
void OnMoveScrollBar(CPoint pt, BOOL bResize)
Call this function to resize/move the scrollbar.
CXTPTrackHeader::StartDragMarker
void StartDragMarker(int nMarkerIndex)
This function is called when the marker is about to be dragged.


Toolkit Pro: Member List

CXTPSpinButtonCtrl Member List

This is the complete list of members for CXTPSpinButtonCtrl, including all inherited members.

CXTPSpinButtonCtrl() | CXTPSpinButtonCtrl |
DrawArrowGlyph(CDC *pDC, CRect rcArrow, BOOL bHorz, BOOL bUpArrow, COLORREF clrArrow) | CXTPSpinButtonCtrl | protected
DrawFlat(CDC *pDC) | CXTPSpinButtonCtrl | protected
DrawFlatButton(CDC *pDC, UINT nButton) | CXTPSpinButtonCtrl | protected
DrawOffice2007(CDC *pDC) | CXTPSpinButtonCtrl | protected
DrawStandard(CDC *pDC) | CXTPSpinButtonCtrl | protected
DrawVisualStyle(CDC *pDC) | CXTPSpinButtonCtrl | protected
GetButtonRect(int nButton) | CXTPSpinButtonCtrl | protected
GetEditBuddy() const | CXTPSpinButtonCtrl | protected
GetUseVisualStyle() const | CXTPSpinButtonCtrl |
HasSharedBorder() const | CXTPSpinButtonCtrl | protected
HitTest(CPoint pt) | CXTPSpinButtonCtrl | protected
Init() | CXTPSpinButtonCtrl | protected
IsVertical() const | CXTPSpinButtonCtrl | protected
m_bPreSubclassInit | CXTPSpinButtonCtrl | protected
m_bUseVisualStyle | CXTPSpinButtonCtrl | protected
m_crArrowDisabled | CXTPSpinButtonCtrl | protected
m_crArrowEnabled | CXTPSpinButtonCtrl | protected
m_crArrowHilite | CXTPSpinButtonCtrl | protected
m_crArrowPushed | CXTPSpinButtonCtrl | protected
m_crBack | CXTPSpinButtonCtrl | protected
m_crBackDisabled | CXTPSpinButtonCtrl | protected
m_crBackHilite | CXTPSpinButtonCtrl | protected
m_crBackPushed | CXTPSpinButtonCtrl | protected
m_crBorder | CXTPSpinButtonCtrl | protected
m_crBorderDisabled | CXTPSpinButtonCtrl | protected
m_crBorderHilite | CXTPSpinButtonCtrl | protected
m_crBorderPushed | CXTPSpinButtonCtrl | protected
m_nHotButton | CXTPSpinButtonCtrl | protected
m_nPressedButton | CXTPSpinButtonCtrl | protected
m_nTheme | CXTPSpinButtonCtrl | protected
m_themeSpin | CXTPSpinButtonCtrl | protected
OnDraw(CDC *pDC) | CXTPSpinButtonCtrl | protected
RefreshMetrics() | CXTPSpinButtonCtrl | protected
SetTheme(XTPControlTheme nTheme) | CXTPSpinButtonCtrl |
SetUseVisualStyle(BOOL bUseVisualStyle=TRUE) | CXTPSpinButtonCtrl |
~CXTPSpinButtonCtrl() | CXTPSpinButtonCtrl |


Toolkit Pro: Member List

CXTPControlCheckBox Member List

This is the complete list of members for CXTPControlCheckBox, including all inherited members.

AssignDocTemplate(UINT nIDResource) | CXTPControl |
ClickToolBarButton(CRect rcActiveRect=CRect(0, 0, 0, 0)) | CXTPControl | protected
Compare(CXTPControl *pOther) | CXTPControl | virtual
Copy(CXTPControl *pControl, BOOL bRecursive=FALSE) | CXTPControlButton | protectedvirtual
CustomizeStartDrag(CPoint point) | CXTPControl | protectedvirtual
CustomizeStartResize(CPoint point) | CXTPControl | protectedvirtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPControl() | CXTPControl | protected
CXTPControlButton() | CXTPControlButton |
CXTPControlCheckBox() | CXTPControlCheckBox |
DelayLayoutParent() | CXTPControl |
DelayRedrawParent() | CXTPControl |
DoCustomDragOver(CXTPCommandBar *pCommandBar, CPoint point, DROPEFFECT &dropEffect) | CXTPControl | protectedvirtual
DoPropExchange(CXTPPropExchange *pPX) | CXTPControlButton | virtual
Draw(CDC *pDC) | CXTPControl | virtual
ExcludeDocTemplate(UINT nIDResource) | CXTPControl |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
FromUI(CCmdUI *pCmdUI) | CXTPControl | static
GenerateCommandBarList(DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam) | CXTPControl | protectedvirtual
GetAction() const | CXTPControl |
GetBeginGroup() const | CXTPControl |
GetButtonSize() const | CXTPControl | virtual
GetCaption() const | CXTPControl | virtual
GetCategory() const | CXTPControl |
GetChecked() const | CXTPControl |
GetCloseSubMenuOnClick() const | CXTPControl |
GetCommandBar() const | CXTPControl | virtual
GetControls() const | CXTPControl |
GetCustomizeMinHeight() const | CXTPControl | protectedvirtual
GetCustomizeMinWidth() const | CXTPControl | protectedvirtual
GetCustomShortcutText() const | CXTPControl |
GetDescription() const | CXTPControl | virtual
GetEnabled() const | CXTPControl |
GetExecuteOnPressInterval() const | CXTPControl |
GetExpanded() const | CXTPControl |
GetFlags() const | CXTPControl |
GetHeight() const | CXTPControl |
GetHelpId() const | CXTPControl |
GetHideFlags() const | CXTPControl |
GetIconId() const | CXTPControl |
GetIconSize() const | CXTPControl | virtual
GetID() const | CXTPControl |
GetImage(int nWidth=16) const | CXTPControl | virtual
GetImageManager() const | CXTPControl |
GetIndex() const | CXTPControl |
GetKeyboardTip() const | CXTPControl |
GetPaintManager() const | CXTPControl |
GetParameter() const | CXTPControl |
GetParent() const | CXTPControl |
GetPopuped() const | CXTPControl | virtual
GetPressed() const | CXTPControl | virtual
GetRect() const | CXTPControl |
GetRibbonGroup() const | CXTPControl |
GetRowRect() const | CXTPControl |
GetSelected() const | CXTPControl | virtual
GetShortcutText() const | CXTPControl |
GetSize(CDC *pDC) | CXTPControl | virtual
GetStyle() const | CXTPControl |
GetStyleEx() const | CXTPControlButton |
GetTag() const | CXTPControl |
GetTooltip() const | CXTPControl | virtual
GetType() const | CXTPControl |
GetWidth() const | CXTPControl |
GetWrap() const | CXTPControl |
HasDwmCompositedRect() const | CXTPControl |
IsCaptionVisible() const | CXTPControl | virtual
IsCursorOver() const | CXTPControl |
IsCustomizeMode() const | CXTPControl | protected
IsCustomizeMovable() const | CXTPControl | virtual
IsCustomizeResizeAllow() const | CXTPControl | protectedvirtual
IsFocusable() const | CXTPControl | protectedvirtual
IsFocused() const | CXTPControlCheckBox | protectedvirtual
IsItemDefault() const | CXTPControl |
IsLayoutChanged() | CXTPControl | protected
IsLayoutRTL() const | CXTPControl | protected
IsOnQuickAccess() const | CXTPControl |
IsTemporary() const | CXTPControl |
IsTransparent() const | CXTPControl | inlinevirtual
IsVisible(DWORD dwSkipFlags=0) const | CXTPControl | virtual
m_bBeginGroup | CXTPControl | protected
m_bChecked | CXTPControl | protected
m_bCloseSubMenuOnClick | CXTPControl | protected
m_bDefaultItem | CXTPControl | protected
m_bEnabled | CXTPControl | protected
m_bExpanded | CXTPControl | protected
m_bLayoutRTL | CXTPControl | protected
m_bOnQuickAccess | CXTPControl | protected
m_bPressed | CXTPControl | protected
m_bSelected | CXTPControl | protected
m_bTemporary | CXTPControl | protected
m_buttonCustomStyle | CXTPControl | protected
m_buttonRibbonStyle | CXTPControl | protected
m_buttonStyle | CXTPControl | protected
m_buttonStyleEx | CXTPControlButton | protected
m_bWrap | CXTPControl | protected
m_controlType | CXTPControl | protected
m_dwFlags | CXTPControl | protected
m_dwHideFlags | CXTPControl | protected
m_mapDocTemplatesAssigned | CXTPControl | protected
m_mapDocTemplatesExcluded | CXTPControl | protected
m_nCustomIconId | CXTPControl | protected
m_nExecuteOnPressInterval | CXTPControl | protected
m_nHeight | CXTPControl | protected
m_nHelpId | CXTPControl | protected
m_nIconId | CXTPControl | protected
m_nId | CXTPControl | protected
m_nIndex | CXTPControl | protected
m_nTag | CXTPControl | protected
m_nWidth | CXTPControl | protected
m_pAction | CXTPControl | protected
m_pControls | CXTPControl | protected
m_pParent | CXTPControl | protected
m_pRibbonGroup | CXTPControl | protected
m_rcControl | CXTPControl | protected
m_rcRow | CXTPControl | protected
m_strCaption | CXTPControl | protected
m_strCategory | CXTPControl | protected
m_strCustomCaption | CXTPControl | protected
m_strDescriptionText | CXTPControl | protected
m_strKeyboardTip | CXTPControl | protected
m_strParameter | CXTPControl | protected
m_strShortcutText | CXTPControl | protected
m_strShortcutTextAuto | CXTPControl | protected
m_strTooltipText | CXTPControl | protected
m_szIcon | CXTPControl | protected
NotifySite(UINT code) | CXTPControl |
NotifySite(UINT code, NMXTPCONTROL *pNM) | CXTPControl |
NotifySite(CWnd *pSite, UINT code, NMXTPCONTROL *pNM) | CXTPControl |
OnActionChanged(int nProperty) | CXTPControl | protectedvirtual
OnActionChanging(int nProperty) | CXTPControl | protectedvirtual
OnCalcDynamicSize(DWORD dwMode) | CXTPControl | virtual
OnCaptionChanged() | CXTPControl | protectedvirtual
OnClick(BOOL bKeyboard=FALSE, CPoint pt=CPoint(0, 0)) | CXTPControlButton | protectedvirtual
OnCustomizeDragOver(CXTPControl *pDataObject, CPoint point, DROPEFFECT &dropEffect) | CXTPControl | protectedvirtual
OnCustomizeMouseMove(CPoint point) | CXTPControl | protected
OnEnabledChanged() | CXTPControl | virtual
OnExecute() | CXTPControl | virtual
OnHookKeyDown(UINT nChar, LPARAM lParam) | CXTPControlCheckBox | protectedvirtual
OnHookMouseWheel(UINT nFlags, short zDelta, CPoint point) | CXTPControl | protectedvirtual
OnIdleUpdate() | CXTPControl | protectedvirtual
OnLButtonDblClk(CPoint point) | CXTPControl | protectedvirtual
OnLButtonDown(CPoint point) | CXTPControl | protectedvirtual
OnLButtonUp(CPoint point) | CXTPControlButton | protectedvirtual
OnMouseHover() | CXTPControl | protectedvirtual
OnMouseMove(CPoint point) | CXTPControl | protectedvirtual
OnRButtonDown(CPoint point) | CXTPControl | protectedvirtual
OnRButtonUp(CPoint point) | CXTPControl | protectedvirtual
OnRemoved() | CXTPControl | protectedvirtual
OnSetPopup(BOOL bPopup) | CXTPControl | protectedvirtual
OnSetSelected(int bSelected) | CXTPControl | protectedvirtual
OnThemeChanged() | CXTPControl | virtual
OnToolHitTest(CPoint point, TOOLINFO *pTI) const | CXTPControl | protectedvirtual
OnUnderlineActivate() | CXTPControl | virtual
RedrawParent(BOOL bAnimate=TRUE) | CXTPControl |
Reset() | CXTPControl |
RestoreCommandBarList(CXTPCommandBarList *pCommandBarList) | CXTPControl | protectedvirtual
ScreenToClient(CPoint *point) | CXTPControl | protected
SetAction(CXTPControlAction *pAction) | CXTPControl | virtual
SetBeginGroup(BOOL bBeginGroup) | CXTPControl | virtual
SetCaption(LPCTSTR lpszCaption) | CXTPControl |
SetCaption(UINT nIDCaption) | CXTPControl |
SetCategory(LPCTSTR lpszCategory) | CXTPControl |
SetChecked(BOOL bChecked) | CXTPControl | virtual
SetCloseSubMenuOnClick(BOOL bCloseOnClick) | CXTPControl |
SetCustomIcon(HICON hIcon) | CXTPControl |
SetCustomShortcutText(LPCTSTR lpszCustomShortcutText) | CXTPControl |
SetDescription(LPCTSTR lpszDescription) | CXTPControl |
SetEnabled(BOOL bEnabled) | CXTPControl | virtual
SetExecuteOnPressInterval(int nExecuteOnPressInterval) | CXTPControl |
SetExpanded(BOOL bExpanded) | CXTPControl | protected
SetFlags(DWORD dwFlags) | CXTPControl |
SetFocused(BOOL bFocused) | CXTPControl | virtual
SetHeight(int nHeight) | CXTPControl | virtual
SetHelpId(int nId) | CXTPControl |
SetHideFlag(XTPControlHideFlags dwFlag, BOOL bSet) | CXTPControl |
SetHideFlags(DWORD dwFlags) | CXTPControl | virtual
SetHideWrap(BOOL bHide) | CXTPControl |
SetIconId(int nId) | CXTPControl |
SetIconSize(CSize szIcon) | CXTPControl |
SetID(int nId) | CXTPControl |
SetIndex(int nIndex) | CXTPControl | inlineprotected
SetItemDefault(BOOL bDefault) | CXTPControl |
SetKeyboardTip(LPCTSTR lpszKeyboardTip) | CXTPControl |
SetOnQuickAccess(BOOL bOnQuicAccess=FALSE) | CXTPControl |
SetParameter(LPCTSTR lpszParameter) | CXTPControl |
SetParent(CXTPCommandBar *pParent) | CXTPControl | inlineprotectedvirtual
SetPressed(BOOL bPressed) | CXTPControl |
SetPrompt(LPCTSTR lpszPrompt) | CXTPControl |
SetRect(CRect rcControl) | CXTPControl | virtual
SetRowRect(CRect rcRow) | CXTPControl |
SetShortcutText(LPCTSTR lpszShortcutText) | CXTPControl |
SetStyle(XTPButtonStyle buttonStyle) | CXTPControl |
SetStyleEx(XTPButtonStyle buttonStyle) | CXTPControlButton |
SetTag(DWORD_PTR dwTag) | CXTPControl |
SetTooltip(LPCTSTR lpszTooltip) | CXTPControl |
SetVisible(BOOL bVisible) | CXTPControl |
SetWidth(int nWidth) | CXTPControl | virtual
SetWrap(BOOL bWrap) | CXTPControl |
~CXTPControl() | CXTPControl | protectedvirtual
~CXTPControlButton() | CXTPControlButton | virtual


Toolkit Pro: Member List

XTP_COMMANDBARS_CREATECONTROL Member List

This is the complete list of members for XTP_COMMANDBARS_CREATECONTROL, including all inherited members.

bToolBar | XTP_COMMANDBARS_CREATECONTROL
buttonStyle | XTP_COMMANDBARS_CREATECONTROL
controlType | XTP_COMMANDBARS_CREATECONTROL
nID | XTP_COMMANDBARS_CREATECONTROL
nIndex | XTP_COMMANDBARS_CREATECONTROL
pCommandBar | XTP_COMMANDBARS_CREATECONTROL
pControl | XTP_COMMANDBARS_CREATECONTROL
pMenu | XTP_COMMANDBARS_CREATECONTROL
strCaption | XTP_COMMANDBARS_CREATECONTROL


Toolkit Pro: Member List

CXTPChartAppearance Member List

This is the complete list of members for CXTPChartAppearance, including all inherited members.

ApplyToDeviceContext(CXTPChartDeviceContext *pDC) | CXTPChartElementAppearance | virtual
CXTPChartAppearance(CXTPChartElement *pOwner) | CXTPChartAppearance |
CXTPChartElement() | CXTPChartElement |
CXTPChartElementAppearance(CXTPChartElement *pOwner) | CXTPChartElementAppearance |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
DoPropExchange(CXTPPropExchange *pPX) | CXTPChartAppearance | virtual
GetAppearance(const CXTPChartElement *pElement) | CXTPChartAppearance | static
CXTPChartElementAppearance::GetAppearance() const | CXTPChartElement |
GetContent() const | CXTPChartElement |
GetContentAppearance() const | CXTPChartAppearance |
GetDiagram2DAppearance() const | CXTPChartAppearance |
GetDiagram3DAppearance() const | CXTPChartAppearance |
GetFinanceStyleAppearance() const | CXTPChartAppearance |
GetOwner() const | CXTPChartElement |
GetPalette() const | CXTPChartAppearance |
GetPieStyleAppearance() const | CXTPChartAppearance |
GetSeriesStyleAppearance() const | CXTPChartAppearance |
Is3D() const | CXTPChartObject |
LoadAppearance(LPCTSTR lpszAppearance) | CXTPChartAppearance |
LoadPalette(LPCTSTR lpszPallete) | CXTPChartAppearance |
m_pContentAppearance | CXTPChartAppearance | protected
m_pDiagram2DAppearance | CXTPChartAppearance | protected
m_pDiagram3DAppearance | CXTPChartAppearance | protected
m_pFinanceStyleAppearance | CXTPChartAppearance | protected
m_pPalette | CXTPChartAppearance | protected
m_pPieStyleAppearance | CXTPChartAppearance | protected
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartElement | virtual
Release() | CXTPChartElement | virtual
~CXTPChartAppearance() | CXTPChartAppearance | virtual
~CXTPChartElement() | CXTPChartElement | virtual
~CXTPChartElementAppearance() | CXTPChartElementAppearance | virtual


Toolkit Pro: XTPDockingPaneThemeOffice2003.h Source File

  • Source
  • DockingPane
  • Themes
XTPDockingPaneThemeOffice2003.h
Go to the documentation of this file.
1
23#if !defined(__XTPDOCKINGPANETHEMEOFFICE2003_H__)
24# define __XTPDOCKINGPANETHEMEOFFICE2003_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
40class _XTP_EXT_CLASS CXTPDockingPaneOffice2003Theme : public CXTPDockingPaneVisualStudio2003Theme
41{
42public:
47 CXTPDockingPaneOffice2003Theme();
48
54 virtual ~CXTPDockingPaneOffice2003Theme();
55
60 virtual void RefreshMetrics();
61
69 virtual void DrawCaption(CDC* pDC, CXTPDockingPaneTabbedContainer* pPane, CRect rc);
70
78 virtual void DrawFloatingFrame(CDC* pDC, CXTPDockingPaneMiniWnd* pPane, CRect rc);
79
87 virtual void DrawSidePanel(CDC* pDC, CXTPDockingPaneSidePanel* pPane, CRect rc);
88
96 virtual CRect GetPaneCaptionRect(const CXTPDockingPaneSidePanel* pPane);
97
105 virtual CRect GetCaptionGripperRect(const CXTPDockingPaneTabbedContainer* pPane);
106
107protected:
118 virtual void DrawCaptionPart(CDC* pDC, CXTPDockingPaneBase* pPane, CRect rcCaption,
119 const CString& strTitle, BOOL bActive, BOOL bVertical);
120
121public:
122 BOOL m_bDrawGripper;
123protected:
124 BOOL m_bRoundedCaption;
125};
126
127# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
129#endif // !defined(__XTPDOCKINGPANETHEMEOFFICE2003_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPDockingPaneBase
CXTPDockingPaneBase is a standalone class.
Definition XTPDockingPaneBase.h:69
CXTPDockingPaneMiniWnd
CXTPDockingPaneMiniWnd is a multiple inheritance class derived from CMiniFrameWnd and CXTPDockingPane...
Definition XTPDockingPaneMiniWnd.h:42
CXTPDockingPaneOffice2003Theme
CXTPDockingPaneOffice2003Theme is a CXTPDockingPaneVisualStudio2003Theme derived class that represent...
Definition XTPDockingPaneThemeOffice2003.h:41
CXTPDockingPaneOffice2003Theme::CXTPDockingPaneOffice2003Theme
CXTPDockingPaneOffice2003Theme()
Constructs a CXTPDockingPaneOffice2003Theme object.
CXTPDockingPaneOffice2003Theme::m_bRoundedCaption
BOOL m_bRoundedCaption
TRUE to draw rounded caption.
Definition XTPDockingPaneThemeOffice2003.h:124
CXTPDockingPaneOffice2003Theme::DrawFloatingFrame
virtual void DrawFloatingFrame(CDC *pDC, CXTPDockingPaneMiniWnd *pPane, CRect rc)
Call this method to draw the frame of a floating window.
CXTPDockingPaneOffice2003Theme::GetPaneCaptionRect
virtual CRect GetPaneCaptionRect(const CXTPDockingPaneSidePanel *pPane)
Call this method to get the pane's caption rectangle.
CXTPDockingPaneOffice2003Theme::~CXTPDockingPaneOffice2003Theme
virtual ~CXTPDockingPaneOffice2003Theme()
Destroys a CXTPDockingPaneOffice2003Theme object, handles cleanup and deallocation.
CXTPDockingPaneOffice2003Theme::DrawCaption
virtual void DrawCaption(CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc)
Override this member function to draw a caption.
CXTPDockingPaneOffice2003Theme::GetCaptionGripperRect
virtual CRect GetCaptionGripperRect(const CXTPDockingPaneTabbedContainer *pPane)
Call this method to get the caption gripper for a tabbed container.
CXTPDockingPaneOffice2003Theme::DrawSidePanel
virtual void DrawSidePanel(CDC *pDC, CXTPDockingPaneSidePanel *pPane, CRect rc)
Override this member function to draw the side panel.
CXTPDockingPaneOffice2003Theme::m_bDrawGripper
BOOL m_bDrawGripper
TRUE to draw gripper.
Definition XTPDockingPaneThemeOffice2003.h:122
CXTPDockingPaneOffice2003Theme::RefreshMetrics
virtual void RefreshMetrics()
This method is called to refresh the visual metrics of the pane.
CXTPDockingPaneOffice2003Theme::DrawCaptionPart
virtual void DrawCaptionPart(CDC *pDC, CXTPDockingPaneBase *pPane, CRect rcCaption, const CString &strTitle, BOOL bActive, BOOL bVertical)
Draws the common part of a tabbed and floating caption.
CXTPDockingPaneSidePanel
CXTPDockingPaneSidePanel is a multiple inheritance class derived from CWnd and CXTPDockingPaneBase.
Definition XTPDockingPaneSidePanel.h:45
CXTPDockingPaneTabbedContainer
CXTPDockingPaneTabbedContainer is a multiple inheritance class derived from CWnd and CXTPDockingPaneB...
Definition XTPDockingPaneTabbedContainer.h:47
CXTPDockingPaneVisualStudio2003Theme
CXTPDockingPaneVisualStudio2003Theme is a CXTPDockingPaneGripperedTheme derived class that represents...
Definition XTPDockingPaneThemeVisualStudio2003.h:42


Toolkit Pro: Member List

CXTPChartFastLineSeriesView Member List

This is the complete list of members for CXTPChartFastLineSeriesView, including all inherited members.

AddChildView(CXTPChartElementView *pChildView) | CXTPChartElementView |
CreateDeviceCommand(CXTPChartDeviceContext *pDC) | CXTPChartFastLineSeriesView | protectedvirtual
CreateLegendDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcBounds) | CXTPChartFastLineSeriesView | protectedvirtual
CreatePointsView(CXTPChartDeviceContext *pDC) | CXTPChartFastLineSeriesView | protected
CreateSeriesPointView(CXTPChartDeviceContext *pDC, CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView) | CXTPChartFastLineSeriesView | protected
CXTPChartElementView(CXTPChartElementView *pParentView) | CXTPChartElementView |
CXTPChartElementView(CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartElementView |
CXTPChartElementView(CXTPChartContainer *pContainer) | CXTPChartElementView |
CXTPChartFastLineSeriesView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView) | CXTPChartFastLineSeriesView |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
GetAt(int nIndex) const | CXTPChartElementView |
GetBounds() const | CXTPChartElementView |
GetBounds(BOOL bIncludingChildren) const | CXTPChartElementView |
GetChildren() | CXTPChartElementView |
GetCount() const | CXTPChartElementView |
GetParentView() const | CXTPChartElementView |
Is3D() const | CXTPChartObject |
m_arrChildren | CXTPChartElementView | protected
m_pContainer | CXTPChartElementView | protected
m_pParentView | CXTPChartElementView | protected
m_rcBounds | CXTPChartElementView | protected
~CXTPChartElementView() | CXTPChartElementView | protectedvirtual
~CXTPChartLegendItemView() | CXTPChartLegendItemView | inlinevirtual


Toolkit Pro: XTPMarkupPolygon.h Source File

  • Source
  • Markup
  • Shapes
XTPMarkupPolygon.h
Go to the documentation of this file.
1
23#if !defined(__XTPMARKUPPOLYGON_H__)
24# define __XTPMARKUPPOLYGON_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPMarkupPointCollection;
34class CXTPMarkupDrawingContext;
35class CXTPMarkupDependencyProperty;
36
37class _XTP_EXT_CLASS CXTPMarkupPolygon : public CXTPMarkupShape
38{
40 DECLARE_MARKUPCLASS(CXTPMarkupPolygon)
42protected:
43 CXTPMarkupPolygon();
44 virtual ~CXTPMarkupPolygon();
45
46public:
47 void SetPoints(CXTPMarkupPointCollection* pPoints);
48 CXTPMarkupPointCollection* GetPoints() const;
49
50protected:
51 CSize MeasureOverride(CXTPMarkupDrawingContext* pDC, CSize szAvailableSize);
52 void OnRender(CXTPMarkupDrawingContext* pDC);
53
55public:
56 DECLARE_DISPATCH_MAP()
57# ifdef _XTP_ACTIVEX
58 DECLARE_INTERFACE_MAP()
59 DECLARE_OLETYPELIB_EX(CXTPMarkupPolygon);
60# endif
61
62protected:
63 afx_msg BSTR OleGetPoints();
64 afx_msg void OleSetPoints(LPCTSTR lpPoints);
65
68public:
69 static CXTPMarkupDependencyProperty* m_pPointsProperty;
70};
71
72# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
74#endif // !defined(__XTPMARKUPPOLYGON_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPMarkupVisual::OnRender
virtual void OnRender(CXTPMarkupDrawingContext *drawingContext)
When overridden in a derived class, participates in rendering operations that are directed by the lay...
Definition XTPMarkupInputElement.h:515


Toolkit Pro: Member List

CXTPDockingPaneTabColorSetNativeWindows10 Member List

This is the complete list of members for CXTPDockingPaneTabColorSetNativeWindows10, including all inherited members.

CXTPDockingPaneTabColorSet2012() | CXTPDockingPaneTabColorSet2012 |
CXTPDockingPaneTabColorSetNativeWindows10() | CXTPDockingPaneTabColorSetNativeWindows10 |
CXTPTabPaintManagerColorSet() | CXTPTabPaintManagerColorSet |
FillClient(CDC *pDC, CRect rc, CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
FillHeader(CDC *pDC, CRect rc, CXTPTabManager *pTabManager) | CXTPDockingPaneTabColorSetNativeWindows10 | virtual
FillNavigateButton(CDC *pDC, CXTPTabManagerNavigateButton *pButton, CRect &rc) | CXTPDockingPaneTabColorSet2012 | virtual
FillPropertyButton(CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerColorSet | virtual
FillStateButton(CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerColorSet | virtual
GetClientColor(CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
GetItemColor(CXTPTabManagerItem *pItem) | CXTPDockingPaneTabColorSet2012 | virtual
GradientFill(CDC *pDC, CRect rc, COLORREF clrLight, COLORREF clrDark, XTPTabPosition position) | CXTPTabPaintManagerColorSet |
IsAppThemed() const | CXTPTabPaintManagerColorSet | virtual
m_clrActiveFilesBack | CXTPTabPaintManagerColorSet |
m_clrActiveFilesBackHighlighted | CXTPTabPaintManagerColorSet |
m_clrActiveFilesBackPressed | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyph | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyphHighlighted | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyphPressed | CXTPTabPaintManagerColorSet |
m_clrAutoHideFace | CXTPTabPaintManagerColorSet |
m_clrBorderHighlight | CXTPTabPaintManagerColorSet |
m_clrButtonBorder | CXTPTabPaintManagerColorSet |
m_clrButtonBorderHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonBorderHot | CXTPTabPaintManagerColorSet |
m_clrButtonBorderKeyTips | CXTPTabPaintManagerColorSet |
m_clrButtonBorderTabContext1 | CXTPTabPaintManagerColorSet |
m_clrButtonBorderTabContext2 | CXTPTabPaintManagerColorSet |
m_clrButtonHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonHighlightedClose | CXTPTabPaintManagerColorSet |
m_clrButtonNormal | CXTPTabPaintManagerColorSet |
m_clrButtonPressed | CXTPTabPaintManagerColorSet |
m_clrButtonSelected | CXTPTabPaintManagerColorSet |
m_clrButtonSelectedHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonSelectedPressed | CXTPTabPaintManagerColorSet |
m_clrControlFace | CXTPTabPaintManagerColorSet |
m_clrFrameBorder | CXTPTabPaintManagerColorSet |
m_clrHeaderFace | CXTPTabPaintManagerColorSet |
m_clrPaneFace | CXTPTabPaintManagerColorSet |
m_clrTabClientBack | CXTPTabPaintManagerColorSet |
m_clrTabClientBorder | CXTPTabPaintManagerColorSet |
m_clrTextDisabled | CXTPTabPaintManagerColorSet |
m_clrTextHighlight | CXTPTabPaintManagerColorSet |
m_clrTextHighlightClose | CXTPTabPaintManagerColorSet |
m_clrTextNormal | CXTPTabPaintManagerColorSet |
m_clrTextPressed | CXTPTabPaintManagerColorSet |
m_clrTextSelected | CXTPTabPaintManagerColorSet |
m_clrTextSelectedHighlighted | CXTPTabPaintManagerColorSet |
m_clrTextSelectedPressed | CXTPTabPaintManagerColorSet |
m_csExcelNormal | CXTPTabPaintManagerColorSet |
m_csExcelSelected | CXTPTabPaintManagerColorSet |
m_csPropertyPage | CXTPTabPaintManagerColorSet |
m_csPropertyPage2003 | CXTPTabPaintManagerColorSet |
m_csStateButton | CXTPTabPaintManagerColorSet |
m_pPaintManager | CXTPTabPaintManagerColorSet | protected
RefreshMetrics() | CXTPDockingPaneTabColorSet2012 | virtual
SelectClipRgn(CDC *pDC, CRect rcClient, CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
SetTextColor(CDC *pDC, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerColorSet | virtual
~CXTPTabPaintManagerColorSet() | CXTPTabPaintManagerColorSet | virtual


Toolkit Pro: XTPWebViewProvider.h Source File

  • Source
  • Controls
  • WebBrowser
  • Providers
XTPWebViewProvider.h
Go to the documentation of this file.
1
22#if !defined(__XTPWEBVIEWPROVIDER_H__)
24# define __XTPWEBVIEWPROVIDER_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33struct IXTPWebBrowserHost;
34struct ICoreWebView2Controller;
35struct ICoreWebView2;
36
37// Use this macro for linking WebView2LoaderStatic.lib instead of linking WebView2Loader.dll
38// dynamically.
39// #define XTP_USE_WEBVIEW2_STATIC_LIB
40
42class CXTPWebViewProviderSpy;
50class _XTP_EXT_CLASS CXTPWebViewProvider : public CXTPWebBrowserProvider
51{
53 DECLARE_DYNAMIC(CXTPWebViewProvider)
55 friend class CXTPWebViewProviderSpy;
56
57public:
63 CXTPWebViewProvider(IXTPWebBrowserHost& host);
64
69 ~CXTPWebViewProvider();
70
78 static BOOL IsAvailable();
79
89 virtual HRESULT ExecuteScript(LPCWSTR pText, CComVariant* pvtResult = NULL);
90
91protected:
93 // CXTPWebBrowserProvider overrides
94 virtual HRESULT Initialize();
95 virtual HRESULT Navigate(LPCTSTR pUrl);
96 virtual HRESULT LoadHtml(LPCTSTR pHtml);
97 virtual HRESULT WaitUntilReady();
98 virtual void ReleaseBrowser();
99 virtual BOOL OnHostWndMsg(UINT message, WPARAM wParam, LPARAM lParam, LRESULT* pResult);
100 virtual void OnCreateBrowser(IUnknown* pObject);
101 virtual void UpdateExternal();
104private:
105 BOOL OnSize(UINT nType, int cx, int cy);
106 BOOL OnDestroy();
107
108protected:
110 void ApplyUserAgent();
111 void HookEvents();
112 void UnhookEvents();
113 void Layout();
114 void SetPendingExternalReady();
115 void OnExternalReady();
116
117 void OnBeforeNavigationStarting(ICoreWebView2NavigationStartingEventArgs* args);
118 void OnBeforeContentLoading(ICoreWebView2ContentLoadingEventArgs* args);
119 void OnBeforeSourceChanged(ICoreWebView2SourceChangedEventArgs* args);
120 void OnBeforeHistoryChanged(IUnknown* args);
121 void OnBeforeNavigationCompleted(ICoreWebView2NavigationCompletedEventArgs* args);
122 void OnBeforeFrameNavigationStarting(ICoreWebView2NavigationStartingEventArgs* args);
123 void OnBeforeFrameNavigationCompleted(ICoreWebView2NavigationCompletedEventArgs* args);
124 void OnBeforeScriptDialogOpening(ICoreWebView2ScriptDialogOpeningEventArgs* args);
125 void OnBeforePermissionRequested(ICoreWebView2PermissionRequestedEventArgs* args);
126 void OnBeforeProcessFailed(ICoreWebView2ProcessFailedEventArgs* args);
127 void OnBeforeNewWindowRequested(ICoreWebView2NewWindowRequestedEventArgs* args);
128 void OnBeforeDocumentTitleChanged(IUnknown* args);
129 void OnBeforeContainsFullScreenElementChanged(IUnknown* args);
130 void OnBeforeWebResourceRequested(ICoreWebView2WebResourceRequestedEventArgs* args);
131 void OnBeforeWindowCloseRequested(IUnknown* args);
132
133 void OnAfterNavigationStarting(ICoreWebView2NavigationStartingEventArgs* args);
134 void OnAfterContentLoading(ICoreWebView2ContentLoadingEventArgs* args);
135 void OnAfterSourceChanged(ICoreWebView2SourceChangedEventArgs* args);
136 void OnAfterHistoryChanged(IUnknown* args);
137 void OnAfterNavigationCompleted(ICoreWebView2NavigationCompletedEventArgs* args);
138 void OnAfterFrameNavigationStarting(ICoreWebView2NavigationStartingEventArgs* args);
139 void OnAfterFrameNavigationCompleted(ICoreWebView2NavigationCompletedEventArgs* args);
140 void OnAfterScriptDialogOpening(ICoreWebView2ScriptDialogOpeningEventArgs* args);
141 void OnAfterPermissionRequested(ICoreWebView2PermissionRequestedEventArgs* args);
142 void OnAfterProcessFailed(ICoreWebView2ProcessFailedEventArgs* args);
143 void OnAfterNewWindowRequested(ICoreWebView2NewWindowRequestedEventArgs* args);
144 void OnAfterDocumentTitleChanged(IUnknown* args);
145 void OnAfterContainsFullScreenElementChanged(IUnknown* args);
146 void OnAfterWebResourceRequested(ICoreWebView2WebResourceRequestedEventArgs* args);
147 void OnAfterWindowCloseRequested(IUnknown* args);
150private:
151 CXTPWebViewProvider(const CXTPWebViewProvider&);
152 CXTPWebViewProvider& operator=(const CXTPWebViewProvider&);
153
154 static void StaticInit();
155
156private:
157# ifndef XTP_USE_WEBVIEW2_STATIC_LIB
158 static HMODULE m_hWebView2Loader;
159# endif
160
161 typedef HRESULT(STDAPICALLTYPE* PFNGetAvailableCoreWebView2BrowserVersionString)(
162 PCWSTR browserExecutableFolder, LPWSTR* versionInfo);
163 static PFNGetAvailableCoreWebView2BrowserVersionString
164 m_pfnGetAvailableCoreWebView2BrowserVersionString;
165
166 typedef HRESULT(STDAPICALLTYPE* PFNCreateCoreWebView2EnvironmentWithOptions)(
167 PCWSTR browserExecutableFolder, PCWSTR userDataFolder,
168 ICoreWebView2EnvironmentOptions* environmentOptions,
169 ICoreWebView2CreateCoreWebView2EnvironmentCompletedHandler* environmentCreatedHandler);
170 static PFNCreateCoreWebView2EnvironmentWithOptions m_pfnCreateCoreWebView2EnvironmentWithOptions;
171
172 ICoreWebView2* m_pWebView;
173 ICoreWebView2Controller* m_pWebViewController;
174 CComVariant* m_pvtScriptResult;
175 BOOL m_bNavigationInitiated;
176 BOOL m_bNavigationCompleted;
177 BOOL m_bPendingExternalReady;
178 CComVariant* m_pvtDummyResult;
179 BOOL m_bControllerCreationHandled;
180 DWORD m_dwUnusedPadding;
181
182 struct
183 {
184 EventRegistrationToken NavigationStarting;
185 EventRegistrationToken ContentLoading;
186 EventRegistrationToken SourceChanged;
187 EventRegistrationToken HistoryChanged;
188 EventRegistrationToken NavigationCompleted;
189 EventRegistrationToken FrameNavigationStarting;
190 EventRegistrationToken FrameNavigationCompleted;
191 EventRegistrationToken ScriptDialogOpening;
192 EventRegistrationToken PermissionRequested;
193 EventRegistrationToken ProcessFailed;
194 EventRegistrationToken NewWindowRequested;
195 EventRegistrationToken DocumentTitleChanged;
196 EventRegistrationToken ContainsFullScreenElementChanged;
197 EventRegistrationToken WebResourceRequested;
198 EventRegistrationToken WindowCloseRequested;
199 } m_eventTokens;
200};
201
202# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
204#endif
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPWebBrowserProvider
Implements the base class for a WebBrowser provider.
Definition XTPWebBrowserProvider.h:56
CXTPWebViewProvider
Implements WebView2 WebBrowser provider and gives access to WebView2 specific functionality.
Definition XTPWebViewProvider.h:51
CXTPWebViewProvider::ExecuteScript
virtual HRESULT ExecuteScript(LPCWSTR pText, CComVariant *pvtResult=NULL)
Executes a JavaScript code.
CXTPWebViewProvider::IsAvailable
static BOOL IsAvailable()
Determines if WebView2 implementation is available and can be used.
CXTPWebViewProvider::~CXTPWebViewProvider
~CXTPWebViewProvider()
Handles provider destruction.
CXTPWebViewProvider::CXTPWebViewProvider
CXTPWebViewProvider(IXTPWebBrowserHost &host)
Constructs provider object.


Toolkit Pro: Member List

CXTPMarkupDeviceDependentImage Member List

This is the complete list of members for CXTPMarkupDeviceDependentImage, including all inherited members.

CXTPMarkupDeviceDependentImage(IXTPMarkupDeviceDependentImageSite *pSite) | CXTPMarkupDeviceDependentImage | explicitprotected
GetSite() const | CXTPMarkupDeviceDependentImage |
GetSize() const | CXTPMarkupDeviceDependentImage |
IsIcon() const | CXTPMarkupDeviceDependentImage |
IsLoaded() const | CXTPMarkupDeviceDependentImage |
Load(LPCWSTR lpszSource, int nWidth, int nHeight=0)=0 | CXTPMarkupDeviceDependentImage | pure virtual
~CXTPMarkupDeviceDependentImage() | CXTPMarkupDeviceDependentImage | virtual


Toolkit Pro: Member List

XTP_CALENDAR_HITTESTINFO Member List

This is the complete list of members for XTP_CALENDAR_HITTESTINFO, including all inherited members.

bTimePartValid | XTP_CALENDAR_HITTESTINFO |
dayPOS | XTP_CALENDAR_HITTESTINFO |
dt | XTP_CALENDAR_HITTESTINFO |
nDay | XTP_CALENDAR_HITTESTINFO |
nEvent | XTP_CALENDAR_HITTESTINFO |
nGroup | XTP_CALENDAR_HITTESTINFO |
operator!=(const XTP_CALENDAR_HITTESTINFO &hitInfo2) | XTP_CALENDAR_HITTESTINFO | inline
operator==(const XTP_CALENDAR_HITTESTINFO &hitInfo2) | XTP_CALENDAR_HITTESTINFO |
pt | XTP_CALENDAR_HITTESTINFO |
pViewDay | XTP_CALENDAR_HITTESTINFO |
pViewEvent | XTP_CALENDAR_HITTESTINFO |
pViewGroup | XTP_CALENDAR_HITTESTINFO |
uHitCode | XTP_CALENDAR_HITTESTINFO |
XTP_CALENDAR_HITTESTINFO() | XTP_CALENDAR_HITTESTINFO | inline
~XTP_CALENDAR_HITTESTINFO() | XTP_CALENDAR_HITTESTINFO | inlinevirtual


Toolkit Pro: Member List

CXTPEditThemeVisualStudio2012 Member List

This is the complete list of members for CXTPEditThemeVisualStudio2012, including all inherited members.

AdjustBuddyRect(CWnd *pBuddy, CRect &rcUpDown, int nAlignment) | CXTPEditThemeOfficeXP | virtual
CtlColor(CDC *pDC, UINT nCtlColor, CXTPEdit *pEdit) | CXTPEditThemeDefault | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPControlTheme() | CXTPControlTheme |
CXTPEditTheme() | CXTPEditTheme |
CXTPEditThemeDefault() | CXTPEditThemeDefault |
CXTPEditThemeOffice2000() | CXTPEditThemeOffice2000 |
CXTPEditThemeOfficeXP() | CXTPEditThemeOfficeXP |
CXTPEditThemeVisualStudio2012(XTPControlTheme nTheme) | CXTPEditThemeVisualStudio2012 |
DrawBuddyBorders(CWnd *pBuddy, CDC *pDC, CRect rc, int nAlignment, CXTPEdit *pEdit) | CXTPEditThemeOfficeXP | virtual
CXTPEditThemeOffice2000::DrawBuddyBorders(CDC *pDC, CRect rc, int nAlignment, CXTPEdit *pEdit) | CXTPEditThemeOffice2000 | virtual
DrawFrame(CDC *pDC, CRect rc, int nSize, CBrush *pBrush) | CXTPEditTheme | virtual
DrawNcBorders(CDC *pDC, CRect rcWnd, CXTPEdit *pEdit) | CXTPEditThemeOfficeXP | virtual
DrawNcBordersDefault(CDC *pDC, CRect rcWnd, CXTPEdit *pEdit) | CXTPEditThemeDefault | protectedvirtual
DrawNcScrollBack(CDC *pDC, CRect rcWnd, CXTPEdit *pEdit) | CXTPEditThemeDefault | virtual
FillRect(CDC *pDC, int x, int y, int cx, int cy, CBrush *pBrush) | CXTPEditTheme | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetClientBrush(CDC *pDC, CXTPEdit *pEdit) | CXTPEditTheme | virtual
GetThemeID() const | CXTPEditTheme |
GetThemeStyle() const | CXTPControlTheme |
IsFlatStyle() const | CXTPEditTheme |
m_bFlatStyle | CXTPEditTheme | protected
m_bUseWinTheme | CXTPEditTheme | protected
m_clrBack | CXTPEditTheme |
m_clrBackNonClient | CXTPEditTheme |
m_clrBorder | CXTPEditTheme |
m_clrBorderDisabled | CXTPEditThemeOfficeXP | protected
m_clrBorderHilite | CXTPEditThemeOfficeXP | protected
m_clrText | CXTPEditTheme |
m_clrTextReadOnly | CXTPEditTheme |
m_nTheme | CXTPEditTheme | protected
m_winTheme | CXTPEditTheme | protected
m_xtpBrushBack | CXTPEditTheme |
RedrawFocusedFrame() const | CXTPEditThemeOfficeXP | virtual
RefreshMetrics(CXTPEdit *pEdit) | CXTPEditThemeVisualStudio2012 | virtual
SetFlatStyle(BOOL bFlatStyle) | CXTPEditTheme |
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static
UseWinTheme(BOOL bUseWinTheme) | CXTPEditTheme |
~CXTPEditTheme() | CXTPEditTheme | virtual
~CXTPEditThemeDefault() | CXTPEditThemeDefault | virtual
~CXTPEditThemeOffice2000() | CXTPEditThemeOffice2000 | virtual
~CXTPEditThemeOfficeXP() | CXTPEditThemeOfficeXP | virtual
~CXTPEditThemeVisualStudio2012() | CXTPEditThemeVisualStudio2012 | virtual


Toolkit Pro: XTPTrackThemeNativeWindows11.h Source File

  • Source
  • GridControl
  • TrackControl
  • Themes
XTPTrackThemeNativeWindows11.h
Go to the documentation of this file.
1
23#if !defined(__XTPTRACKTHEMENATIVEWINDOWS11_H__)
24# define __XTPTRACKTHEMENATIVEWINDOWS11_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPTrackThemeNativeWindows11 : public CXTPTrackThemeOffice2013
39{
40public:
45 CXTPTrackThemeNativeWindows11();
46
52 virtual void RefreshMetrics();
53};
55# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
56#endif //#if !defined(__XTPTRACKTHEMENATIVEWINDOWS11_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPTrackThemeNativeWindows11
CXTPTrackThemeNativeWindows11 is a CXTPTrackThemeOffice2013 derived class that represents a Native Wi...
Definition XTPTrackThemeNativeWindows11.h:39
CXTPTrackThemeNativeWindows11::CXTPTrackThemeNativeWindows11
CXTPTrackThemeNativeWindows11()
Default paint manager constructor, handles properties initialization.
CXTPTrackThemeNativeWindows11::RefreshMetrics
virtual void RefreshMetrics()
This method is called to refresh the visual metrics of the track control.
CXTPTrackThemeOffice2013
CXTPTrackThemeOffice2013 is a CXTPTrackPaintManager derived class that represents an Office 2013 styl...
Definition XTPTrackThemeOffice2013.h:39


Toolkit Pro: Member List

CXTPFlowGraphConnectionPoints Member List

This is the complete list of members for CXTPFlowGraphConnectionPoints, including all inherited members.

AddConnectionPoint(CXTPFlowGraphConnectionPoint *pConnectionPoint, int nIndex=-1) | CXTPFlowGraphConnectionPoints |
CXTPCmdTarget() | CXTPCmdTarget |
CXTPFlowGraphConnectionPoints(CXTPFlowGraphNode *pNode) | CXTPFlowGraphConnectionPoints | protected
DoPropExchange(CXTPPropExchange *pPX) | CXTPFlowGraphConnectionPoints |
FindConnectionPoint(LPCTSTR lpszName, XTPFlowGraphConnectionPointType type=xtpFlowGraphPointNone) const | CXTPFlowGraphConnectionPoints |
FindConnectionPoint(int nId) const | CXTPFlowGraphConnectionPoints |
FindConnectionPointByCaption(LPCTSTR lpszCaption, XTPFlowGraphConnectionPointType type=xtpFlowGraphPointNone) const | CXTPFlowGraphConnectionPoints |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAt(int nIndex) const | CXTPFlowGraphConnectionPoints |
GetCount() const | CXTPFlowGraphConnectionPoints |
m_arrConnectionPoints | CXTPFlowGraphConnectionPoints | protected
m_pNode | CXTPFlowGraphConnectionPoints | protected
Remove(CXTPFlowGraphConnectionPoint *pConnectionPoint, BOOL bRemovePairs=TRUE) | CXTPFlowGraphConnectionPoints |
RemoveAll() | CXTPFlowGraphConnectionPoints |
RemoveAt(int nIndex, BOOL bRemovePairs=TRUE, BOOL bSkipUndoTask=FALSE) | CXTPFlowGraphConnectionPoints |
~CXTPFlowGraphConnectionPoints() | CXTPFlowGraphConnectionPoints | protectedvirtual


Toolkit Pro: XTPChartOpenGLLineDeviceCommand.h Source File

  • Source
  • Chart
  • Drawing
  • OpenGL
XTPChartOpenGLLineDeviceCommand.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTOPENGLLINEDEVICECOMMAND_H__)
24# define __XTPCHARTOPENGLLINEDEVICECOMMAND_H__
25
26# if _MSC_VER >= 1000
27# pragma once
28# endif // _MSC_VER >= 1000
29
30# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
31
38class _XTP_EXT_CLASS CXTPChartOpenGLSolidLineDeviceCommand : public CXTPChart3dLineDeviceCommand
39{
40public:
50 CXTPChartOpenGLSolidLineDeviceCommand(const CXTPPoint3d& p1, const CXTPPoint3d& p2,
51 const CXTPChartColor& color, int thickness);
52
53protected:
62 void ExecuteOverride(CXTPChartDeviceContext* pDC);
63};
64
65# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
66#endif //#if !defined(__XTPCHARTOPENGLLINEDEVICECOMMAND_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChart3dLineDeviceCommand
Provides an interface for 3D line drawing device command.
Definition XTPChartLineDeviceCommand.h:121
CXTPChartColor
This class abstracts a color entity.
Definition XTPChartTypes.h:51
CXTPChartDeviceCommand::ExecuteOverride
virtual void ExecuteOverride(CXTPChartDeviceContext *pDC)
Override this function to write the drawing code for specific objects.
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPPoint3T< double >


Toolkit Pro: XTPRibbonBackstagePageRecent.h Source File

  • Source
  • Ribbon
  • Backstage
  • Pages
XTPRibbonBackstagePageRecent.h
Go to the documentation of this file.
1
23#if !defined(__XTPRIBBONBACKSTAGEPAGERECENT_H__)
24# define __XTPRIBBONBACKSTAGEPAGERECENT_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPRecentFileListBoxItem;
34
36// CXTPRibbonBackstagePageRecent dialog
37
38# define XTP_IDC_RIBBONBACKSTAGEPAGE_RECENT XTP_IDD_RIBBONBACKSTAGEPAGE_RECENT
39
40const UINT XTP_RRN_CONTEXTMENU = 0x1000;
41
42typedef struct tagNMXTPRRNCONTEXTMENU
43{
44 NMHDR hdr;
45 POINT pt;
46 CXTPRecentFileListBoxItem* pItem;
47} NMXTPRRNCONTEXTMENU, *LPNMXTPRRNCONTEXTMENU;
48
49class _XTP_EXT_CLASS CXTPRibbonBackstagePageRecent : public CXTPRibbonBackstagePage
50{
52 DECLARE_DYNCREATE(CXTPRibbonBackstagePageRecent)
55 // Construction
56public:
57 CXTPRibbonBackstagePageRecent();
58 virtual ~CXTPRibbonBackstagePageRecent();
59
60 void RemoveItem(CXTPRecentFileListBoxItem* pItem);
61 void PinItem(CXTPRecentFileListBoxItem* pItem);
62 void UnpinItem(CXTPRecentFileListBoxItem* pItem);
63
64 BOOL GetUseShellIcon() const;
65 void SetUseShellIcon(BOOL bUseShellIcon);
66
67 //{{AFX_DATA(CXTPRibbonBackstagePageRecent)
68 enum
69 {
70 IDD = XTP_IDD_RIBBONBACKSTAGEPAGE_RECENT
71 };
72 //}}AFX_DATA
73
74 virtual void SetTheme(const XTPControlTheme nTheme);
75
76 //{{AFX_VIRTUAL(CXTPRibbonBackstagePageRecent)
77protected:
78 virtual void DoDataExchange(CDataExchange* pDX);
79 //}}AFX_VIRTUAL
80
81 BOOL OnSetActive();
82
83 CXTPRibbonBackstageSeparator m_lblSeparator1;
84 CXTPRibbonBackstageLabel m_lblRecent;
85
86 CXTPRecentFileListBox m_wndList;
87
88protected:
89 //{{AFX_MSG(CXTPRibbonBackstagePageRecent)
90 virtual BOOL OnInitDialog();
91 virtual BOOL PreTranslateMessage(MSG* pMsg);
92 //}}AFX_MSG
93 afx_msg void OnRecentFileListClick();
95 DECLARE_MESSAGE_MAP()
97private:
98 CWnd* m_pCreatedOnParent;
99};
100
101//{{AFX_INSERT_LOCATION}}
102
103# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
105#endif // !defined(__XTPRIBBONBACKSTAGEPAGERECENT_H__)
XTPControlTheme
XTPControlTheme
Enumeration used to determine the active theme style.
Definition XTPControlTheme.h:43
XTPDisableNoisyWarnings.h


Toolkit Pro: XTPDockingPaneTabColorSetVisualStudio2003.h Source File

  • Source
  • DockingPane
  • TabColorSets
XTPDockingPaneTabColorSetVisualStudio2003.h
Go to the documentation of this file.
1
23#if !defined(__XTPDOCKINGPANETABCOLORSETVISUALSTUDIO2003_H__)
24# define __XTPDOCKINGPANETABCOLORSETVISUALSTUDIO2003_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPDockingPaneTabColorSetVisualStudio2003 : public CXTPTabColorSetOffice2003
39{
40public:
46 CXTPDockingPaneTabColorSetVisualStudio2003(BOOL bHighlightSelected);
47
53 void RefreshMetrics();
54
55public:
65 void FillFramePartRect(CDC* pDC, CRect rc, CWnd* pWnd, CWnd* pSite);
66
75 void FillHeader(CDC* pDC, CRect rc, CXTPTabManager* pTabManager);
76
97 virtual COLORREF FillPropertyButton(CDC* pDC, CRect rcItem, CXTPTabManagerItem* pItem);
98
99protected:
100 BOOL m_bGradientButton;
101 BOOL m_bTransparentButton;
102 BOOL m_bHighlightSelected;
103};
104
105# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
107#endif // !defined(__XTPDOCKINGPANETABCOLORSETVISUALSTUDIO2003_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPDockingPaneTabColorSetVisualStudio2003
Helper class used to initialize default colors for a theme from an .INI resource and handle drawing r...
Definition XTPDockingPaneTabColorSetVisualStudio2003.h:39
CXTPDockingPaneTabColorSetVisualStudio2003::FillHeader
void FillHeader(CDC *pDC, CRect rc, CXTPTabManager *pTabManager)
This member is used to paint the specified header portion for a docking pane tab.
CXTPDockingPaneTabColorSetVisualStudio2003::CXTPDockingPaneTabColorSetVisualStudio2003
CXTPDockingPaneTabColorSetVisualStudio2003(BOOL bHighlightSelected)
Default class constructor.
CXTPDockingPaneTabColorSetVisualStudio2003::FillFramePartRect
void FillFramePartRect(CDC *pDC, CRect rc, CWnd *pWnd, CWnd *pSite)
This member is used to paint the specified frame portion for a docking pane tab.
CXTPDockingPaneTabColorSetVisualStudio2003::RefreshMetrics
void RefreshMetrics()
This member function is used to initialize default colors for a theme from an .INI resource.
CXTPDockingPaneTabColorSetVisualStudio2003::FillPropertyButton
virtual COLORREF FillPropertyButton(CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem)
This member is called to fill a tab button.
CXTPTabColorSetOffice2003
CXTPTabColorSetOffice2003 implements an Office 2003 tab color set.
Definition XTPTabColorSetOffice2003.h:44
CXTPTabManager
CXTPTabManager is the base class for docking pane tabs, tab control tabs, and MDI client tabs.
Definition XTPTabManager.h:87
CXTPTabManagerItem
CXTPTabManagerItem is the base class for the tabs that appear in the command bars tab workspace,...
Definition XTPTabManagerItem.h:44


Toolkit Pro: XTPRibbonBackstageViewThemeVisualStudio2015.h Source File

  • Source
  • Ribbon
  • Backstage
XTPRibbonBackstageViewThemeVisualStudio2015.h
Go to the documentation of this file.
1
23#if !defined(__XTPRIBBONBACKSTAGEVIEWTHEMEVISUALSTUDIO2015_H__)
24# define __XTPRIBBONBACKSTAGEVIEWTHEMEVISUALSTUDIO2015_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class _XTP_EXT_CLASS CXTPRibbonBackstageViewThemeVisualStudio2015
34 : public CXTPRibbonBackstageViewThemeOffice2013
35{
36public:
37 CXTPRibbonBackstageViewThemeVisualStudio2015();
38 ~CXTPRibbonBackstageViewThemeVisualStudio2015();
39};
40
41# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
43#endif // !defined(__XTPRIBBONBACKSTAGEVIEWTHEMEVISUALSTUDIO2015_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h


Toolkit Pro: XTPButtonThemeVisualStudio2022.h Source File

  • Source
  • Controls
  • Button
  • Themes
XTPButtonThemeVisualStudio2022.h
Go to the documentation of this file.
1
23#if !defined(__XTPBUTTONTHEMEVISUALSTUDIO2022_H__)
24# define __XTPBUTTONTHEMEVISUALSTUDIO2022_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPButtonThemeVisualStudio2022 : public CXTPButtonThemeOffice2013
39{
40public:
45 CXTPButtonThemeVisualStudio2022();
46
53 virtual void RefreshMetrics(CXTPButton* pButton);
54};
55
56# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
58#endif //#if !defined(__XTPBUTTONTHEMEVISUALSTUDIO2022_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPButton
Push Button control.
Definition XTPButton.h:109
CXTPButtonThemeOffice2013
CXTPButtonThemeOffice2013 is a class used to perform Office 2013 theme drawing tasks.
Definition XTPButtonThemeOffice2013.h:39
CXTPButtonThemeVisualStudio2022
CXTPButtonThemeVisualStudio2022 is a class used to perform Visual Studio 2022 theme drawing tasks.
Definition XTPButtonThemeVisualStudio2022.h:39
CXTPButtonThemeVisualStudio2022::CXTPButtonThemeVisualStudio2022
CXTPButtonThemeVisualStudio2022()
Constructs a CXTPButtonThemeVisualStudio2022 object.
CXTPButtonThemeVisualStudio2022::RefreshMetrics
virtual void RefreshMetrics(CXTPButton *pButton)
This member function is called by the theme manager to refresh the visual styles used by each compone...


Toolkit Pro: XTPStatusBarPaneScrollBar.h Source File

  • Source
  • CommandBars
  • StatusBar
  • Panes
XTPStatusBarPaneScrollBar.h
Go to the documentation of this file.
1
23#if !defined(__XTPSTATUSBARPANESCROLLBAR_H__)
24# define __XTPSTATUSBARPANESCROLLBAR_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
39class _XTP_EXT_CLASS CXTPStatusBarScrollBarPane
40 : public CXTPStatusBarPane
41 , public CXTPScrollBase
42{
44 DECLARE_DYNAMIC(CXTPStatusBarScrollBarPane)
46public:
51 CXTPStatusBarScrollBarPane();
52
58 virtual ~CXTPStatusBarScrollBarPane();
59
60public:
66 void SetPos(int nValue);
67
74 void SetRange(int nMin, int nMax);
75
83 int GetPos() const;
84
85public:
94 void SetTooltipPart(int nPart, LPCTSTR lpszTooltip);
95
96protected:
98 virtual CRect GetScrollBarRect();
99 virtual void GetScrollInfo(SCROLLINFO* psi);
100 virtual void DoScroll(int cmd, int pos);
101 virtual void RedrawScrollBar();
102 virtual CXTPScrollBarPaintManager* GetScrollBarPaintManager() const;
103 virtual BOOL IsScrollBarEnabled() const;
104 virtual CWnd* GetParentWindow() const;
105 virtual INT_PTR OnToolHitTest(CPoint point, TOOLINFO* pTI) const;
106
107 virtual void OnDraw(CDC* pDC, CRect rcItem);
108 virtual void OnMouseMove(CPoint point);
109 virtual void OnLButtonDown(CPoint point);
112protected:
113 int m_nMin;
114 int m_nMax;
115 int m_nValue;
116 int m_nPage;
117 CString m_strToolTipPart[5];
118};
119
121# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
122#endif // !defined(__XTPSTATUSBARPANESCROLLBAR_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPScrollBarPaintManager
CXTPScrollBarPaintManager is standalone class used to draw CXTPCommandBarScrollBarCtrl object.
Definition XTPScrollBarPaintManager.h:40
CXTPScrollBase
CXTPScrollBase is the base class for all scrollable objects.
Definition XTPScrollBase.h:222
CXTPScrollBase::GetScrollBarPaintManager
virtual CXTPScrollBarPaintManager * GetScrollBarPaintManager() const =0
Obtains a pointer to the associated scrollbar paint manager.
CXTPScrollBase::GetParentWindow
virtual CWnd * GetParentWindow() const =0
Retrieves parent window of scrollbar.
CXTPScrollBase::GetScrollInfo
virtual void GetScrollInfo(SCROLLINFO *psi)=0
The GetScrollInfo function retrieves the parameters of a scroll bar, including the minimum and maximu...
CXTPScrollBase::GetScrollBarRect
virtual CRect GetScrollBarRect()=0
Obtains the rectangle occupied by the scrollbar in client coordinates.
CXTPScrollBase::IsScrollBarEnabled
virtual BOOL IsScrollBarEnabled() const =0
Determines if the scrollbar is enabled.
CXTPScrollBase::RedrawScrollBar
virtual void RedrawScrollBar()=0
Forces the scrollbar to redraw itself.
CXTPStatusBarPane
CXTPStatusBarPane is a CXTPCmdTarget derived class.
Definition XTPStatusBarPane.h:39
CXTPStatusBarPane::OnToolHitTest
virtual INT_PTR OnToolHitTest(CPoint point, TOOLINFO *pTI) const
The framework calls this member function to determine whether a point is in the bounding rectangle of...
CXTPStatusBarPane::OnDraw
virtual void OnDraw(CDC *pDC, CRect rcItem)
This method is called to draw a pane item.
CXTPStatusBarPane::OnMouseMove
virtual void OnMouseMove(CPoint point)
This member is called when the mouse cursor moves.
CXTPStatusBarPane::OnLButtonDown
virtual void OnLButtonDown(CPoint point)
This member function is used to process left mouse button events.
CXTPStatusBarScrollBarPane
CXTPStatusBarScrollBarPane is a CXTPStatusBarPane derived class.
Definition XTPStatusBarPaneScrollBar.h:42
CXTPStatusBarScrollBarPane::CXTPStatusBarScrollBarPane
CXTPStatusBarScrollBarPane()
Constructs a CXTPStatusBarScrollBarPane object.
CXTPStatusBarScrollBarPane::m_nValue
int m_nValue
Scrollbar position.
Definition XTPStatusBarPaneScrollBar.h:115
CXTPStatusBarScrollBarPane::SetTooltipPart
void SetTooltipPart(int nPart, LPCTSTR lpszTooltip)
Call this method to set a tooltip for the scroll part of scrollbar.
CXTPStatusBarScrollBarPane::m_nMin
int m_nMin
Lower limit of the scrollbar control's range.
Definition XTPStatusBarPaneScrollBar.h:113
CXTPStatusBarScrollBarPane::m_nPage
int m_nPage
Scrollbar Page.
Definition XTPStatusBarPaneScrollBar.h:116
CXTPStatusBarScrollBarPane::~CXTPStatusBarScrollBarPane
virtual ~CXTPStatusBarScrollBarPane()
Destroys a CXTPStatusBarScrollBarPane object, handles cleanup and deallocation.
CXTPStatusBarScrollBarPane::m_nMax
int m_nMax
Upper limit of the scrollbar control's range.
Definition XTPStatusBarPaneScrollBar.h:114
CXTPStatusBarScrollBarPane::GetPos
int GetPos() const
Gets the current position of the scroll bar, whose return value is always between the values for the ...
CXTPStatusBarScrollBarPane::SetRange
void SetRange(int nMin, int nMax)
Sets the rangle of the scroll bar.
CXTPStatusBarScrollBarPane::SetPos
void SetPos(int nValue)
Call this method to set the position of the scrollbar.


Toolkit Pro: Member List

  • XTP_CALENDAR_RECURRENCE_OPTIONS
  • PATTERN_DAILY
XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_DAILY Member List

This is the complete list of members for XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_DAILY, including all inherited members.

bEveryWeekDayOnly | XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_DAILY
nIntervalDays | XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_DAILY


Toolkit Pro: XTPRibbonPaintManager.h Source File

  • Source
  • Ribbon
XTPRibbonPaintManager.h
Go to the documentation of this file.
1
23#if !defined(__XTPRIBBONPAINTMANAGER_H__)
24# define __XTPRIBBONPAINTMANAGER_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPRibbonGroup;
34class CXTPRibbonBar;
35class CXTPRibbonTab;
36class CXTPResourceImage;
37class CXTPResourceImages;
38class CXTPTabPaintManager;
39class CXTPRibbonTabContextHeaders;
40class CXTPPopupToolBar;
41class CXTPPaintManager;
42class CXTPRibbonControlSystemButton;
43
44_XTP_EXT_CLASS BOOL AFX_CDECL IsCompositeRect(CXTPCommandBar* pRibbonBar, const CRect& rc);
45
50class _XTP_EXT_CLASS CXTPRibbonPaintManager : public CXTPCmdTarget
51{
53 DECLARE_DYNAMIC(CXTPRibbonPaintManager)
55public:
61 CXTPRibbonPaintManager(CXTPPaintManager* pPaintManager);
62
67 virtual ~CXTPRibbonPaintManager();
68
78 virtual void RefreshMetrics();
79
80public:
92 virtual void DrawGroup(CDC* pDC, CXTPRibbonGroup* pGroup) = 0;
93
101 virtual void DrawQuickAccessControl(CDC* pDC, CXTPRibbonBar* pRibbon, CXTPControl* pControl);
102
116 virtual void FillGroupRect(CDC* pDC, CXTPRibbonTab* pActiveTab, CRect rcGroups) = 0;
117
137 virtual CSize DrawControlGroupPopup(CDC* pDC, CXTPControlPopup* pControlGroupPopup,
138 BOOL bDraw) = 0;
139
146 virtual void FillRibbonBar(CDC* pDC, CXTPRibbonBar* pRibbonBar) = 0;
147
164 virtual CSize DrawControlGroupOption(CDC* pDC, CXTPControl* pControlGroupOption,
165 BOOL bDraw) = 0;
166
174 virtual void DrawRibbonFrameContextHeaders(CDC* pDC, CXTPRibbonBar* pRibbonBar,
175 CXTPRibbonTabContextHeaders* pContextHeaders) = 0;
176
183 virtual void DrawRibbonTab(CDC* pDC, CXTPRibbonTab* pItem) = 0;
184
193 virtual void FillRibbonTabControl(CDC* pDC, CXTPRibbonBar* pRibbonBar, CRect rcControl) = 0;
194
202 virtual void FillGroupPopupToolBar(CDC* pDC, CXTPRibbonGroup* pGroup,
203 CXTPCommandBar* pCommandBar) = 0;
204
213 virtual void DrawRibbonFrameCaptionBar(CDC* pDC, CXTPRibbonBar* pRibbonBar, BOOL bActive) = 0;
214
222 virtual void DrawRibbonFrameCaption(CDC* pDC, CXTPRibbonBar* pRibbonBar, BOOL bActive) = 0;
223
232 virtual void DrawRibbonQuickAccessButton(CDC* pDC, CXTPControlPopup* pControl) = 0;
233
242 virtual void DrawRibbonQuickAccessMoreButton(CDC* pDC, CXTPControlPopup* pControl) = 0;
243
251 virtual void DrawRibbonFrameSystemButton(CDC* pDC, CXTPRibbonControlSystemButton* pControl,
252 CRect rc) = 0;
253
261 virtual void DrawRibbonScrollButton(CDC* pDC, CXTPControl* pControl, BOOL bScrollLeft) = 0;
262
269 virtual void FillTabPopupToolBar(CDC* pDC, CXTPPopupToolBar* pPopupToolBar);
270
278 virtual void DrawRibbonFramePart(CDC* pDC, CXTPRibbonBar* pRibbonBar);
279
286 virtual void FillMorePopupToolBarEntry(CDC* pDC, CXTPCommandBar* pBar) = 0;
287
294 virtual void FillSystemPopupBarEntry(CDC* pDC, CXTPPopupBar* pBar) = 0;
295
302 virtual void DrawSystemPopupBarButton(CDC* pDC, CXTPControl* pButton) = 0;
303
313 virtual BOOL DrawRibbonGroupControlEntry(CDC* pDC, CXTPControl* pButton) = 0;
314
321 virtual void DrawRibbonGroupPopupToolBar(CDC* pDC, CXTPRibbonGroup* pRibbonGroup);
322
323public:
330 int GetEditHeight() const;
331
339 void SetFontHeight(int nFontHeight);
340
349 int GetFontHeight() const;
350
358 virtual int GetRibbonCaptionHeight(const CXTPRibbonBar* pRibbonBar) const = 0;
359
366 virtual CSize GetControlGroupOptionSize() const = 0;
367
376 int GetGroupCaptionHeight() const;
377
396 CXTPResourceImage* LoadImage(LPCTSTR lpszFileName);
397
404 CXTPResourceImages* GetImages() const;
405
406public:
418 CXTPTabPaintManager* GetTabPaintManager() const;
419
426 CXTPFramePaintManager* GetFramePaintManager() const;
427
428protected:
436 virtual CXTPTabPaintManager* CreateTabPaintManager();
437
446 void DrawRibbonApplicationIcon(CDC* pDC, CXTPRibbonBar* pRibbonBar, CRect rc, HICON hIcon);
447
457 void DrawDwmCaptionText(CDC* pDC, CRect rcCaptionText, CString strText, CWnd* pSite,
458 BOOL bActive);
459
460# ifdef _XTP_COMMANDBARS_ACTIVEX
463 LPFONTDISP OleGetCaptionFont();
464 void OleSetCaptionFont(LPFONTDISP pFontDisp);
465 LPFONTDISP OleGetTitleFont();
466 void OleSetTitleFont(LPFONTDISP pFontDisp);
467
468 DECLARE_DISPATCH_MAP()
469 DECLARE_OLETYPELIB_EX(CXTPRibbonTheme);
470 DECLARE_INTERFACE_MAP()
471
473# endif
474
475public:
476 BOOL m_bHotTrackingGroups;
477 BOOL m_bFlatFrame;
479 CXTPPaintManagerFont m_fontGroupCaption;
481 COLORREF m_clrRecentFileListEdgeShadow;
482 COLORREF m_clrRecentFileListEdgeHighLight;
484 int m_nTabsHeight;
485 int m_nGroupSpacing;
486 int m_nGroupCaptionHeight;
488protected:
489 COLORREF m_clrRibbonFace;
490 COLORREF m_clrRibbonBorder;
491 COLORREF m_clrRibbonGroupCaptionText;
492 COLORREF m_clrRibbonInactiveFace;
494 COLORREF m_clrFileButtonText;
498 COLORREF m_clrMinimizedFrameEdgeHighLight;
499 COLORREF m_clrMinimizedFrameEdgeShadow;
501 CXTPPaintManager* m_pPaintManager;
502 CXTPTabPaintManager* m_pTabPaintManager;
504 CRect m_rcFileButtonMargin;
507public:
508private:
509 HICON m_hApplicationIcon;
510 BOOL m_bAlphaApplicationIcon;
511
512protected:
513 friend class CXTPRibbonBar;
514};
515
516AFX_INLINE int CXTPRibbonPaintManager::GetGroupCaptionHeight() const
517{
518 return m_nGroupCaptionHeight;
519}
520
521AFX_INLINE CXTPTabPaintManager* CXTPRibbonPaintManager::GetTabPaintManager() const
522{
523 return m_pTabPaintManager;
524}
525
526AFX_INLINE CXTPFramePaintManager* CXTPRibbonPaintManager::GetFramePaintManager() const
527{
528 CXTPFramePaintManager* pFramePaintManager = NULL;
529
530 if (NULL != m_pPaintManager)
531 {
532 pFramePaintManager = m_pPaintManager->GetFramePaintManager();
533 }
534
535 return pFramePaintManager;
536}
537
538# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
540#endif // !defined(__XTPRIBBONPAINTMANAGER_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPCommandBar
CXTPCommandBar is a CWnd derived class.
Definition XTPCommandBar.h:66
CXTPControl
CXTPControl is a CXTPCmdTarget derived class.
Definition XTPControl.h:841
CXTPControlPopup
CXTPControlPopup is a CXTPControl derived class.
Definition XTPControlPopup.h:42
CXTPFramePaintManager
Paint manager for the Office 2007 style window frame.
Definition XTPFramePaintManager.h:41
CXTPPaintManagerFont
PaintManagers used CFont wrapper.
Definition XTPPaintManager.h:113
CXTPPaintManager
Paint manager of the command bars.
Definition XTPPaintManager.h:199
CXTPPaintManager::GetFramePaintManager
virtual CXTPFramePaintManager * GetFramePaintManager()
Retrieves paint manager used to draw frames.
CXTPPopupBar
CXTPPopupBar is a CXTPCommandBar derived class.
Definition XTPPopupBar.h:42
CXTPPopupToolBar
CXTPPopupToolBar is a CXTPPopupBar derived class.
Definition XTPPopupBar.h:492
CXTPResourceImage
Represent a resource image and provides basic images functions.
Definition XTPResourceImage.h:48
CXTPResourceImages
Implements resource image collection and its operations.
Definition XTPResourceImage.h:257
CXTPRibbonBar
CXTPRibbonBar is a CXTPMenuBar derived class.
Definition XTPRibbonBar.h:69
CXTPRibbonControlSystemButton
CXTPRibbonControlSystemButton is a CXTPControlPopup derived class used as a system button for a Ribbo...
Definition XTPRibbonSystemButton.h:39
CXTPRibbonGroup
Represents a single group that is added to a CXTPRibbonTab.
Definition XTPRibbonGroup.h:70
CXTPRibbonPaintManager
Standalone class used by CXTPRibbonBar as a paint manager.
Definition XTPRibbonPaintManager.h:51
CXTPRibbonPaintManager::FillGroupRect
virtual void FillGroupRect(CDC *pDC, CXTPRibbonTab *pActiveTab, CRect rcGroups)=0
This method is called to fill the background of a CXTPRibbonGroup.
CXTPRibbonPaintManager::DrawQuickAccessControl
virtual void DrawQuickAccessControl(CDC *pDC, CXTPRibbonBar *pRibbon, CXTPControl *pControl)
Draws the specified control which is a part of the Quick Access panel.
CXTPRibbonPaintManager::CXTPRibbonPaintManager
CXTPRibbonPaintManager(CXTPPaintManager *pPaintManager)
Constructs a CXTPRibbonPaintManager object.
CXTPRibbonPaintManager::GetRibbonCaptionHeight
virtual int GetRibbonCaptionHeight(const CXTPRibbonBar *pRibbonBar) const =0
Calculates the ribbon caption height.
CXTPRibbonPaintManager::GetControlGroupOptionSize
virtual CSize GetControlGroupOptionSize() const =0
Calculates the ribbon group option size.
CXTPRibbonPaintManager::m_nGroupCaptionHeight
int m_nGroupCaptionHeight
Group caption bar height.
Definition XTPRibbonPaintManager.h:486
CXTPRibbonPaintManager::DrawRibbonTab
virtual void DrawRibbonTab(CDC *pDC, CXTPRibbonTab *pItem)=0
This method is called to draw a single tab of the ribbon bar.
CXTPRibbonPaintManager::m_clrRibbonGroupCaptionText
COLORREF m_clrRibbonGroupCaptionText
Ribbon group captions color.
Definition XTPRibbonPaintManager.h:491
CXTPRibbonPaintManager::DrawRibbonFrameContextHeaders
virtual void DrawRibbonFrameContextHeaders(CDC *pDC, CXTPRibbonBar *pRibbonBar, CXTPRibbonTabContextHeaders *pContextHeaders)=0
This method is called to draw ribbon context headers.
CXTPRibbonPaintManager::FillRibbonTabControl
virtual void FillRibbonTabControl(CDC *pDC, CXTPRibbonBar *pRibbonBar, CRect rcControl)=0
This member fills in the tab header and tab client area.
CXTPRibbonPaintManager::m_clrMinimizedFrameEdgeHighLight
COLORREF m_clrMinimizedFrameEdgeHighLight
Minimized bottom edge.
Definition XTPRibbonPaintManager.h:498
CXTPRibbonPaintManager::m_nGroupSpacing
int m_nGroupSpacing
Group spacing.
Definition XTPRibbonPaintManager.h:485
CXTPRibbonPaintManager::DrawRibbonFramePart
virtual void DrawRibbonFramePart(CDC *pDC, CXTPRibbonBar *pRibbonBar)
This method is called to draw the ribbon frame if EnableFrameTheme was not called.
CXTPRibbonPaintManager::m_clrRibbonInactiveFace
COLORREF m_clrRibbonInactiveFace
Color of the ribbon when it is inactive.
Definition XTPRibbonPaintManager.h:492
CXTPRibbonPaintManager::m_rcFileButtonMargin
CRect m_rcFileButtonMargin
Margins of the system button when it is displayed as a tab button (Windows 7 style).
Definition XTPRibbonPaintManager.h:504
CXTPRibbonPaintManager::m_clrRibbonBorder
COLORREF m_clrRibbonBorder
Ribbon border color.
Definition XTPRibbonPaintManager.h:490
CXTPRibbonPaintManager::FillMorePopupToolBarEntry
virtual void FillMorePopupToolBarEntry(CDC *pDC, CXTPCommandBar *pBar)=0
This method is called to draw the pop-up bar of the more button.
CXTPRibbonPaintManager::m_pPaintManager
CXTPPaintManager * m_pPaintManager
Paint manager used for the ribbon.
Definition XTPRibbonPaintManager.h:501
CXTPRibbonPaintManager::DrawRibbonFrameSystemButton
virtual void DrawRibbonFrameSystemButton(CDC *pDC, CXTPRibbonControlSystemButton *pControl, CRect rc)=0
Draws the top-left system button.
CXTPRibbonPaintManager::DrawRibbonQuickAccessMoreButton
virtual void DrawRibbonQuickAccessMoreButton(CDC *pDC, CXTPControlPopup *pControl)=0
This method is called to draw the Quick Access more button.
CXTPRibbonPaintManager::DrawRibbonGroupPopupToolBar
virtual void DrawRibbonGroupPopupToolBar(CDC *pDC, CXTPRibbonGroup *pRibbonGroup)
This method is called to draw the ribbon group pop-up toolbar.
CXTPRibbonPaintManager::SetFontHeight
void SetFontHeight(int nFontHeight)
Sets the font height used for Ribbon.
CXTPRibbonPaintManager::DrawRibbonFrameCaption
virtual void DrawRibbonFrameCaption(CDC *pDC, CXTPRibbonBar *pRibbonBar, BOOL bActive)=0
This method is called to draw the Ribbon caption.
CXTPRibbonPaintManager::m_clrRecentFileListEdgeHighLight
COLORREF m_clrRecentFileListEdgeHighLight
Color of the File List edge highlight.
Definition XTPRibbonPaintManager.h:482
CXTPRibbonPaintManager::DrawDwmCaptionText
void DrawDwmCaptionText(CDC *pDC, CRect rcCaptionText, CString strText, CWnd *pSite, BOOL bActive)
This method is called to draw caption text for an aero-transparent caption.
CXTPRibbonPaintManager::m_clrMinimizedFrameEdgeShadow
COLORREF m_clrMinimizedFrameEdgeShadow
Minimized bottom edge shadow.
Definition XTPRibbonPaintManager.h:499
CXTPRibbonPaintManager::m_clrFileButtonText
COLORREF m_clrFileButtonText
Text caption to display when the system button is displayed as a tab button (Windows 7 style).
Definition XTPRibbonPaintManager.h:494
CXTPRibbonPaintManager::FillTabPopupToolBar
virtual void FillTabPopupToolBar(CDC *pDC, CXTPPopupToolBar *pPopupToolBar)
This method is called to draw the background of a minimized pop-up bar.
CXTPRibbonPaintManager::GetTabPaintManager
CXTPTabPaintManager * GetTabPaintManager() const
Call this member to get a pointer to the tab paint manager.
Definition XTPRibbonPaintManager.h:521
CXTPRibbonPaintManager::m_pTabPaintManager
CXTPTabPaintManager * m_pTabPaintManager
Tab paint manager.
Definition XTPRibbonPaintManager.h:502
CXTPRibbonPaintManager::DrawRibbonGroupControlEntry
virtual BOOL DrawRibbonGroupControlEntry(CDC *pDC, CXTPControl *pButton)=0
This method is called to draw the ribbon group when the group is minimized and only a button is displ...
CXTPRibbonPaintManager::DrawGroup
virtual void DrawGroup(CDC *pDC, CXTPRibbonGroup *pGroup)=0
Draws the specified CXTPRibbonGroup.
CXTPRibbonPaintManager::DrawRibbonFrameCaptionBar
virtual void DrawRibbonFrameCaptionBar(CDC *pDC, CXTPRibbonBar *pRibbonBar, BOOL bActive)=0
This method is called to draw the ribbon caption if EnableFrameTheme was not called.
CXTPRibbonPaintManager::DrawControlGroupOption
virtual CSize DrawControlGroupOption(CDC *pDC, CXTPControl *pControlGroupOption, BOOL bDraw)=0
Draws the group option button.
CXTPRibbonPaintManager::DrawRibbonQuickAccessButton
virtual void DrawRibbonQuickAccessButton(CDC *pDC, CXTPControlPopup *pControl)=0
This method is called to draw the Quick Access customize button.
CXTPRibbonPaintManager::LoadImage
CXTPResourceImage * LoadImage(LPCTSTR lpszFileName)
Loads a bitmap image from the specified path.
CXTPRibbonPaintManager::GetFontHeight
int GetFontHeight() const
Gets the font height used for Ribbon.
CXTPRibbonPaintManager::m_nTabsHeight
int m_nTabsHeight
Tabs heights.
Definition XTPRibbonPaintManager.h:484
CXTPRibbonPaintManager::DrawSystemPopupBarButton
virtual void DrawSystemPopupBarButton(CDC *pDC, CXTPControl *pButton)=0
This method is called to draw a pop-up bar button.
CXTPRibbonPaintManager::~CXTPRibbonPaintManager
virtual ~CXTPRibbonPaintManager()
Destroys a CXTPRibbonPaintManager object, handles cleanup and deallocation.
CXTPRibbonPaintManager::CreateTabPaintManager
virtual CXTPTabPaintManager * CreateTabPaintManager()
Creates a CXTPTabPaintManager object used to store the color and appearance information of the tabs i...
CXTPRibbonPaintManager::GetImages
CXTPResourceImages * GetImages() const
This method is called to get a pointer to the CXTPResourceImages object.
CXTPRibbonPaintManager::m_fontGroupCaption
CXTPPaintManagerFont m_fontGroupCaption
Font used to draw text in the group caption.
Definition XTPRibbonPaintManager.h:479
CXTPRibbonPaintManager::DrawRibbonApplicationIcon
void DrawRibbonApplicationIcon(CDC *pDC, CXTPRibbonBar *pRibbonBar, CRect rc, HICON hIcon)
This method is called to draw a ribbon bar application icon.
CXTPRibbonPaintManager::DrawRibbonScrollButton
virtual void DrawRibbonScrollButton(CDC *pDC, CXTPControl *pControl, BOOL bScrollLeft)=0
This method is called to draw scroll group buttons.
CXTPRibbonPaintManager::FillRibbonBar
virtual void FillRibbonBar(CDC *pDC, CXTPRibbonBar *pRibbonBar)=0
This method is called to fill the background of a ribbon bar control.
CXTPRibbonPaintManager::m_clrRecentFileListEdgeShadow
COLORREF m_clrRecentFileListEdgeShadow
Color of the File List edge shadow.
Definition XTPRibbonPaintManager.h:481
CXTPRibbonPaintManager::RefreshMetrics
virtual void RefreshMetrics()
This method is called to refresh the visual metrics of the manager.
CXTPRibbonPaintManager::FillSystemPopupBarEntry
virtual void FillSystemPopupBarEntry(CDC *pDC, CXTPPopupBar *pBar)=0
This method is called to draw the pop-up bar of the system button.
CXTPRibbonPaintManager::GetFramePaintManager
CXTPFramePaintManager * GetFramePaintManager() const
Call this member to get a pointer to the frame paint manager.
Definition XTPRibbonPaintManager.h:526
CXTPRibbonPaintManager::m_bFlatFrame
BOOL m_bFlatFrame
TRUE to draw a flat frame.
Definition XTPRibbonPaintManager.h:477
CXTPRibbonPaintManager::FillGroupPopupToolBar
virtual void FillGroupPopupToolBar(CDC *pDC, CXTPRibbonGroup *pGroup, CXTPCommandBar *pCommandBar)=0
This method is called to draw the pop-up toolbar of a reduced group.
CXTPRibbonPaintManager::DrawControlGroupPopup
virtual CSize DrawControlGroupPopup(CDC *pDC, CXTPControlPopup *pControlGroupPopup, BOOL bDraw)=0
Draws the group pop-up button.
CXTPRibbonPaintManager::m_clrRibbonFace
COLORREF m_clrRibbonFace
Ribbon face color.
Definition XTPRibbonPaintManager.h:489
CXTPRibbonPaintManager::GetEditHeight
int GetEditHeight() const
Gets the edit control height.
CXTPRibbonPaintManager::GetGroupCaptionHeight
int GetGroupCaptionHeight() const
Gets the height of the group caption bar.
Definition XTPRibbonPaintManager.h:516
CXTPRibbonPaintManager::m_bHotTrackingGroups
BOOL m_bHotTrackingGroups
TRUE to highlight the group under the cursor.
Definition XTPRibbonPaintManager.h:476
CXTPRibbonTab
Represents a tab in the Ribbon Bar.
Definition XTPRibbonTab.h:116
CXTPRibbonTheme
The CXTPRibbonTheme class is used to enable a Ribbon style theme for Command Bars.
Definition XTPCommandBarsThemeRibbon.h:40
CXTPTabPaintManager
CXTPTabPaintManager is used to store the color and appearance information of the tabs in the tab mana...
Definition XTPTabPaintManager.h:48


Toolkit Pro: XTPTreeCtrlView.h Source File

  • Source
  • Controls
  • Tree
XTPTreeCtrlView.h
Go to the documentation of this file.
1
23#if !defined(__XTPTREEVIEW_H__)
24# define __XTPTREEVIEW_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33DECLARE_TREE_BASE(CXTPTreeViewBase, CTreeView, CXTPTreeBase)
34DECLARE_TREE_BASE(CXTPTreeCtrlBase, CTreeCtrl, CXTPTreeBase)
35
36
42class _XTP_EXT_CLASS CXTPTreeView : public CXTPTreeViewBase
43{
45 DECLARE_DYNCREATE(CXTPTreeView)
47protected:
53 CXTPTreeView();
54
59 virtual ~CXTPTreeView();
60
61 DECLARE_MESSAGE_MAP()
62};
63
70class _XTP_EXT_CLASS CXTPTreeCtrl : public CXTPTreeCtrlBase
71{
73 DECLARE_DYNAMIC(CXTPTreeCtrl)
75public:
80 CXTPTreeCtrl();
81
86 virtual ~CXTPTreeCtrl();
87
88protected:
89 DECLARE_MESSAGE_MAP()
90};
91
100template<class TreeBase>
101class CXTPScrollableTreeCtrlT : public CXTPScrollable<TreeBase>
102{
103public:
108 CXTPScrollableTreeCtrlT();
109
110 using CXTPScrollable<TreeBase>::GetRuntimeClass;
111 using CXTPScrollable<TreeBase>::ModifyStyle;
112 using CXTPScrollable<TreeBase>::ModifyStyleEx;
113
114protected:
116 virtual BOOL HasVScroll(DWORD dwStyle, DWORD dwExStyle) const;
117 virtual BOOL HasHScroll(DWORD dwStyle, DWORD dwExStyle) const;
118 virtual void DisableScrollbars();
119 virtual void DisableScrollbars(CWnd& wnd);
121};
122
127typedef CXTPScrollableTreeCtrlT<CXTPTreeCtrl> CXTPScrollableTreeCtrl;
129template<class TreeBase>
130AFX_INLINE CXTPScrollableTreeCtrlT<TreeBase>::CXTPScrollableTreeCtrlT()
131{
132 _ASSERTE(GetRuntimeClass()->IsDerivedFrom(RUNTIME_CLASS(CTreeCtrl)));
133}
134
135template<class TreeBase>
136AFX_INLINE BOOL CXTPScrollableTreeCtrlT<TreeBase>::HasVScroll(DWORD dwStyle, DWORD dwExStyle) const
137{
138 UNREFERENCED_PARAMETER(dwExStyle);
139 return 0 == (dwStyle & TVS_NOSCROLL);
140}
141
142template<class TreeBase>
143AFX_INLINE BOOL CXTPScrollableTreeCtrlT<TreeBase>::HasHScroll(DWORD dwStyle, DWORD dwExStyle) const
144{
145 UNREFERENCED_PARAMETER(dwExStyle);
146
147 const DWORD nTVS_NOHSCROLL = 0x8000;
148 return 0 == (dwStyle & (TVS_NOSCROLL | nTVS_NOHSCROLL));
149}
150
151template<class TreeBase>
152AFX_INLINE void CXTPScrollableTreeCtrlT<TreeBase>::DisableScrollbars()
153{
154 ModifyStyle(WS_VSCROLL | WS_HSCROLL, 0);
155 ModifyStyleEx(WS_EX_LEFTSCROLLBAR, 0);
156}
157
158template<class TreeBase>
159AFX_INLINE void CXTPScrollableTreeCtrlT<TreeBase>::DisableScrollbars(CWnd& wnd)
160{
161 UNREFERENCED_PARAMETER(wnd);
162 // Do nothing as SysTreeView32 behaves improperly if scroll bars gets disabled repeatedly.
163}
165# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
167#endif // !defined(__XTPTREEVIEW_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPScrollableTreeCtrl
CXTPScrollableTreeCtrlT< CXTPTreeCtrl > CXTPScrollableTreeCtrl
Type alias for a CXTPTreeCtrl derived scrollable control.
Definition XTPTreeCtrlView.h:127
CXTPScrollable
The adaptor class for a scrollable control for which standard scroll bars have to be overriden.
Definition XTPScrollable.h:249
CXTPScrollableTreeCtrlT
An adaptor for any CTreeCtrl derived control that overrides standard scrollbars with custom scrollbar...
Definition XTPTreeCtrlView.h:102
CXTPScrollableTreeCtrlT::CXTPScrollableTreeCtrlT
CXTPScrollableTreeCtrlT()
Initializes a scrollable control instance.
CXTPTreeBase
CXTPTreeBase is a CTreeView derived class.
Definition XTPTreeBase.h:43
CXTPTreeCtrl
CXTPTreeCtrl is a CTreeCtrl derived class.
Definition XTPTreeCtrlView.h:71
CXTPTreeCtrl::~CXTPTreeCtrl
virtual ~CXTPTreeCtrl()
Destroys a CXTPTreeCtrl object, handles cleanup and deallocation.
CXTPTreeCtrl::CXTPTreeCtrl
CXTPTreeCtrl()
Constructs a CXTPTreeCtrl object.
CXTPTreeView
CXTPTreeView is a CTreeView derived class.
Definition XTPTreeCtrlView.h:43
CXTPTreeView::CXTPTreeView
CXTPTreeView()
Protected constructor used by dynamic creation.
CXTPTreeView::~CXTPTreeView
virtual ~CXTPTreeView()
Destroys a CXTPTreeView object, handles cleanup and deallocation.
IXTPScrollable::DisableScrollbars
virtual void DisableScrollbars()=0
Disables/removes standard scroll bars so that custom scroll bars created via this interface could be ...
IXTPScrollable::HasHScroll
virtual BOOL HasHScroll(DWORD dwStyle, DWORD dwExStyle) const =0
Returns TRUE if the control has horizontal scroll bar for the combination of styles specified.
IXTPScrollable::HasVScroll
virtual BOOL HasVScroll(DWORD dwStyle, DWORD dwExStyle) const =0
Returns TRUE if the control has vertical scroll bar for the combination of styles specified.


Toolkit Pro: Member List

XTP_CALENDAR_WPARAM2 Member List

This is the complete list of members for XTP_CALENDAR_WPARAM2, including all inherited members.

wParam1 | XTP_CALENDAR_WPARAM2
wParam2 | XTP_CALENDAR_WPARAM2


Toolkit Pro: XTPFramework.h Source File

  • Source
  • Common
XTPFramework.h
Go to the documentation of this file.
1
23#if !defined(__XTPFRAMEWORK_H__)
24# define __XTPFRAMEWORK_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
34// IXTPCmdTargetProvider interface identifier.
35EXTERN_C const IID IID_IXTPCmdTargetProvider;
36
37# pragma warning(push)
38// C4616: #pragma warning : warning number '...' out of range, must be between '4001' and '4999'
39// C4619: #pragma warning : there is no warning number 'number'
40// C5204: '...': class has virtual functions, but its trivial destructor is not virtual; instances
41// of objects derived from this class may not be destructed correctly
42# pragma warning(disable : 4616 4619 5204)
43
50struct __declspec(uuid("1965CF4C-7BE1-4E09-94B4-DCEF78B16D04")) IXTPCmdTargetProvider
51 : public IUnknown
52{
60 virtual CCmdTarget* GetCmdTarget() = 0;
61};
62
63# pragma warning(pop)
64
65// clang-format off
66# if defined(_MSC_VER) && (1900 <= _MSC_VER)
67# define XTP_DECLARE_CMDTARGETPROVIDER_INTERFACE_() \
68 __pragma(warning(push)) \
69 __pragma(warning(disable : 4616 4619 5204)) \
70 BEGIN_INTERFACE_PART(CmdTargetProvider, IXTPCmdTargetProvider) \
71 virtual CCmdTarget* GetCmdTarget(); \
72 END_INTERFACE_PART(CmdTargetProvider); \
73 __pragma(warning(pop))
74# else
75# define XTP_DECLARE_CMDTARGETPROVIDER_INTERFACE_() \
76 BEGIN_INTERFACE_PART(CmdTargetProvider, IXTPCmdTargetProvider) \
77 virtual CCmdTarget* GetCmdTarget(); \
78 END_INTERFACE_PART(CmdTargetProvider);
79# endif
80// clang-format on
89# define XTP_DECLARE_CMDTARGETPROVIDER_INTERFACE() XTP_DECLARE_CMDTARGETPROVIDER_INTERFACE_()
90
98# define XTP_DECLARE_CMDTARGETPROVIDER_INTERFACE_PART(className) \
99 INTERFACE_PART(className, IID_IXTPCmdTargetProvider, CmdTargetProvider)
100
108# define XTP_IMPLEMENT_CMDTARGETPROVIDER_INTERFACE(className) \
109 XTP_IMPLEMENT_IUNKNOWN(className, CmdTargetProvider) \
110 CCmdTarget* className::XCmdTargetProvider::GetCmdTarget() \
111 { \
112 METHOD_PROLOGUE(className, CmdTargetProvider); \
113 return pThis; \
114 }
115
121class _XTP_EXT_CLASS CXTPCmdTarget : public CCmdTarget
122{
123 DECLARE_DYNAMIC(CXTPCmdTarget);
124
125public:
130 CXTPCmdTarget();
131
147 static CCmdTarget* AFX_CDECL FromIDispatchSafe(IDispatch* pDisp);
148
150protected:
151 DECLARE_INTERFACE_MAP()
152 XTP_DECLARE_CMDTARGETPROVIDER_INTERFACE()
154};
155
156# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
158#endif // !defined(__XTPFRAMEWORK_H__)
XTPDisableNoisyWarnings.h
XTP_DECLARE_CMDTARGETPROVIDER_INTERFACE
#define XTP_DECLARE_CMDTARGETPROVIDER_INTERFACE()
When deriving from CXTPCmdTarget is not possible this macro can be used in addition to standard DECLA...
Definition XTPFramework.h:89
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPCmdTarget::FromIDispatchSafe
static CCmdTarget *AFX_CDECL FromIDispatchSafe(IDispatch *pDisp)
Tries to cast IDispatch pointer to its CCmdTarget object pointer if it is provided by CCmdTarget.
CXTPCmdTarget::CXTPCmdTarget
CXTPCmdTarget()
Constructs command target instance.


Toolkit Pro: XTPMemFile.h Source File

  • Source
  • Controls
  • Util
XTPMemFile.h
Go to the documentation of this file.
1
23#if !defined(__XTMEMFILE_H__)
24# define __XTMEMFILE_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
72class _XTP_EXT_CLASS CXTPMemFile : public CMemFile
73{
74public:
82 CXTPMemFile(UINT nGrowBytes = 1024);
83
93 CXTPMemFile(BYTE* lpBuffer, UINT nBufferSize, UINT nGrowBytes = 0);
94
109 CXTPMemFile(LPCTSTR lpszFileName, UINT uiOpenFlags);
110
115 virtual ~CXTPMemFile();
116
117public:
125 virtual void Flush();
126
127# if _MSC_VER > 1200 // MFC 7.0
128 using CMemFile::Open;
129# endif
130
147 virtual BOOL Open(LPCTSTR lpszFileName, UINT nOpenFlags, CFileException* pError = NULL);
148
154 virtual void Close();
155
164 virtual BOOL ReadString(CString& rString);
165
174 virtual void WriteString(LPCTSTR lpsz);
175
176# if _MSC_VER > 1200 // MFC 7.0
177 using CMemFile::Duplicate;
178# endif // MFC 7.0
179
188 virtual bool Duplicate(CFile* fDuplicate);
189
198 virtual bool Duplicate(LPCTSTR strDup);
199
207 virtual bool Discard();
208
220 virtual DWORD Insert(CFile* fSrc, DWORD dwSourcePos, DWORD dwDestPos, DWORD dwBytes);
221
234 virtual DWORD Insert(LPCTSTR strSrc, DWORD dwSourcePos, DWORD dwDestPos, DWORD dwBytes);
235
246 virtual DWORD Extract(CFile* fDest, DWORD dwStartPos, DWORD dwBytes);
247
259 virtual DWORD Extract(LPCTSTR strDest, DWORD dwStartPos, DWORD dwBytes);
260
270 LONG FindData(void* pData, DWORD dwDataLen, LONG lStartPos);
271
278 void operator=(CFile* fDup);
279
287 void operator=(CString strDup);
288
294 void operator=(DWORD dwFilePos);
295
302 void operator+=(CFile* fApp);
303
311 void operator+=(CString strApp);
312
321 BYTE operator[](DWORD dwFilePos);
322
323protected:
330 virtual bool Load();
331
338 virtual bool Save();
339
348 virtual bool Import(CFile* fImp);
349
358 virtual bool Append(CFile* fApp);
359
360private:
361 // Unsupported APIs
362 virtual CFile* Duplicate() const;
363
364private:
365 UINT m_uiOpenFlags;
366 bool m_bOpen;
367 CFile m_File;
368};
369
370# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
372#endif // #if !defined(__XTMEMFILE_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPMemFile
CXTPMemFile is a CMemFile derived class.
Definition XTPMemFile.h:73
CXTPMemFile::~CXTPMemFile
virtual ~CXTPMemFile()
Destroys a CXTPMemFile object, handles cleanup and deallocation.
CXTPMemFile::operator+=
void operator+=(CFile *fApp)
This member operator will append the CXTPMemFile object with the object specified by 'fApp'.
CXTPMemFile::Append
virtual bool Append(CFile *fApp)
This member function appends a CFile derived object to the file (operator+=).
CXTPMemFile::Save
virtual bool Save()
This member function saves the file to disk.
CXTPMemFile::Extract
virtual DWORD Extract(LPCTSTR strDest, DWORD dwStartPos, DWORD dwBytes)
This member function extracts bytes to a file and retrieves the length of the actual copied bytes.
CXTPMemFile::operator=
void operator=(CFile *fDup)
This member operator will initialize the CXTPMemFile object with the object specified by 'fDup'.
CXTPMemFile::FindData
LONG FindData(void *pData, DWORD dwDataLen, LONG lStartPos)
This member function finds data in the file.
CXTPMemFile::operator=
void operator=(CString strDup)
This member operator will initialize the CXTPMemFile object with the object specified by 'strDup'.
CXTPMemFile::CXTPMemFile
CXTPMemFile(BYTE *lpBuffer, UINT nBufferSize, UINT nGrowBytes=0)
Constructs a CXTPMemFile object.
CXTPMemFile::Open
virtual BOOL Open(LPCTSTR lpszFileName, UINT nOpenFlags, CFileException *pError=NULL)
This member function opens and loads a physical file into memory.
CXTPMemFile::operator[]
BYTE operator[](DWORD dwFilePos)
This member operator will perform indexing operations for the CXTPMemFile object.
CXTPMemFile::ReadString
virtual BOOL ReadString(CString &rString)
This member function reads a string.
CXTPMemFile::CXTPMemFile
CXTPMemFile(UINT nGrowBytes=1024)
Constructs a CXTPMemFile object.
CXTPMemFile::Duplicate
virtual bool Duplicate(LPCTSTR strDup)
This member function will initialize the CXTPMemFile object with the information specified in the 'fD...
CXTPMemFile::Flush
virtual void Flush()
This member function forces any data remaining in the file buffer to be written to the file.
CXTPMemFile::Insert
virtual DWORD Insert(LPCTSTR strSrc, DWORD dwSourcePos, DWORD dwDestPos, DWORD dwBytes)
This member function inserts any file and retrieves the length of the actual copied bytes.
CXTPMemFile::Load
virtual bool Load()
This member function loads the file into memory.
CXTPMemFile::WriteString
virtual void WriteString(LPCTSTR lpsz)
This method writes data from a buffer to the file associated with the CArchive object.
CXTPMemFile::Import
virtual bool Import(CFile *fImp)
This member function imports the data of a CFile derived object (operator=).
CXTPMemFile::operator=
void operator=(DWORD dwFilePos)
This member operator will adjust the file position.
CXTPMemFile::Discard
virtual bool Discard()
This member function discards all changes to the file since Open() or last Flush().
CXTPMemFile::Close
virtual void Close()
This member function saves the contents of the memory to the disk and closes it.
CXTPMemFile::operator+=
void operator+=(CString strApp)
This member operator will append the CXTPMemFile object with the object specified by 'strApp'.
CXTPMemFile::Duplicate
virtual bool Duplicate(CFile *fDuplicate)
This member function will initialize the CXTPMemFile object with the information specified in the 'fD...
CXTPMemFile::Extract
virtual DWORD Extract(CFile *fDest, DWORD dwStartPos, DWORD dwBytes)
This member function extracts bytes to a file and retrieves the length of the actual copied bytes.
CXTPMemFile::Insert
virtual DWORD Insert(CFile *fSrc, DWORD dwSourcePos, DWORD dwDestPos, DWORD dwBytes)
This member function inserts any file and retrieves the length of the actual copied bytes.
CXTPMemFile::CXTPMemFile
CXTPMemFile(LPCTSTR lpszFileName, UINT uiOpenFlags)
Constructs a CXTPMemFile object.


Toolkit Pro: Member List

  • XTP_CALENDAR_USERACTION_PARAMS
  • EXPANDDAYBUTTONACTION_PARAMS
XTP_CALENDAR_USERACTION_PARAMS::EXPANDDAYBUTTONACTION_PARAMS Member List

This is the complete list of members for XTP_CALENDAR_USERACTION_PARAMS::EXPANDDAYBUTTONACTION_PARAMS, including all inherited members.

nButton | XTP_CALENDAR_USERACTION_PARAMS::EXPANDDAYBUTTONACTION_PARAMS
pViewDay | XTP_CALENDAR_USERACTION_PARAMS::EXPANDDAYBUTTONACTION_PARAMS


Toolkit Pro: Member List

CXTPFlowGraphPages Member List

This is the complete list of members for CXTPFlowGraphPages, including all inherited members.

AddPage(CXTPFlowGraphPage *pPage) | CXTPFlowGraphPages |
CXTPCmdTarget() | CXTPCmdTarget |
CXTPFlowGraphPages(CXTPFlowGraphControl *pControl) | CXTPFlowGraphPages | protected
DoPropExchange(CXTPPropExchange *pPX) | CXTPFlowGraphPages |
FindPage(int nId) const | CXTPFlowGraphPages |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAt(int nIndex) const | CXTPFlowGraphPages |
GetCount() const | CXTPFlowGraphPages |
m_arrPages | CXTPFlowGraphPages | protected
m_pControl | CXTPFlowGraphPages | protected
Remove(CXTPFlowGraphPage *pPage) | CXTPFlowGraphPages |
RemoveAll() | CXTPFlowGraphPages |
RemoveAt(int nIndex) | CXTPFlowGraphPages |
~CXTPFlowGraphPages() | CXTPFlowGraphPages | protectedvirtual


Toolkit Pro: XTPShortcutListBoxTheme.h Source File

  • Source
  • Controls
  • ListBox
XTPShortcutListBoxTheme.h
Go to the documentation of this file.
1
23#if !defined(__XTPSHORTCUTLISTBOXTHEME_H__)
24# define __XTPSHORTCUTLISTBOXTHEME_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPShortcutListBox;
34class CXTPImageManagerIcon;
35
43class _XTP_EXT_CLASS CXTPShortcutListBoxTheme : public CXTPControlTheme
44{
45public:
50 CXTPShortcutListBoxTheme();
51
56 virtual ~CXTPShortcutListBoxTheme();
57
58public:
69 virtual void RefreshMetrics(CXTPShortcutListBox* pList);
70
78 virtual void DrawItem(CXTPShortcutListBox* pMenuListBox, LPDRAWITEMSTRUCT lpDIS);
79
86 COLORREF GetBackColor();
87
94 COLORREF GetTextColor();
95
96public:
97 CXTPPaintManagerColor m_crItemText;
98 CXTPPaintManagerColor m_crItemTextDisabled;
99 CXTPPaintManagerColorGradient m_crgBack;
100 CXTPPaintManagerColorGradient m_crgItemBorder;
101 CXTPPaintManagerColorGradient m_crgItemBackHot;
102 CXTPPaintManagerColorGradient m_crgItemBackPressed;
104public:
105 int m_cyEdge;
106 int m_cxIcon;
107 int m_cyIcon;
109protected:
120 virtual void DrawImage(CDC* pDC, CRect& rcIcon, CXTPImageManagerIcon* pImage, BOOL bEnabled,
121 BOOL bSelected, BOOL bPressed);
122
130 virtual void DrawText(CDC* pDC, CRect& rcText, CXTPShortcutListBox::CONTENT_ITEM* pCI);
131};
132
138class _XTP_EXT_CLASS CXTPShortcutListBoxThemeOfficeXP : public CXTPShortcutListBoxTheme
139{
140public:
145 CXTPShortcutListBoxThemeOfficeXP();
146
157 void RefreshMetrics(CXTPShortcutListBox* pList);
158
159protected:
170 virtual void DrawImage(CDC* pDC, CRect& rcIcon, CXTPImageManagerIcon* pImage, BOOL bEnabled,
171 BOOL bSelected, BOOL bPressed);
172
180 virtual void DrawText(CDC* pDC, CRect& rcText, CXTPShortcutListBox::CONTENT_ITEM* pCI);
181};
182
188class _XTP_EXT_CLASS CXTPShortcutListBoxThemeOffice2003 : public CXTPShortcutListBoxThemeOfficeXP
189{
190public:
195 CXTPShortcutListBoxThemeOffice2003();
196
207 void RefreshMetrics(CXTPShortcutListBox* pList);
208
209protected:
220 virtual void DrawImage(CDC* pDC, CRect& rcIcon, CXTPImageManagerIcon* pImage, BOOL bEnabled,
221 BOOL bSelected, BOOL bPressed);
222};
223
225
226# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
228#endif // !defined(__XTPSHORTCUTLISTBOXTHEME_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPControlTheme
CXTPControlTheme can be used as a base class for user defined themes.
Definition XTPControlTheme.h:95
CXTPImageManagerIcon
Icons holder class.
Definition XTPImageManager.h:622
CXTPPaintManagerColorGradient
The CXTPPaintManagerColorGradient class is used to manage COLORREF values for determining light and d...
Definition XTPColorManager.h:301
CXTPPaintManagerColor
The CXTPPaintManagerColor class is used to manage COLORREF values for determining default and applica...
Definition XTPColorManager.h:117
CXTPShortcutListBox
CCXTPShortcutListBox is a CListBox derived class.
Definition XTPShortcutListBox.h:44
CXTPShortcutListBoxTheme
CXTPShortcutListBoxTheme is used to draw the CXTPShortcutListBox object.
Definition XTPShortcutListBoxTheme.h:44
CXTPShortcutListBoxTheme::DrawText
virtual void DrawText(CDC *pDC, CRect &rcText, CXTPShortcutListBox::CONTENT_ITEM *pCI)
This method is called to draw the text of the item.
CXTPShortcutListBoxTheme::DrawImage
virtual void DrawImage(CDC *pDC, CRect &rcIcon, CXTPImageManagerIcon *pImage, BOOL bEnabled, BOOL bSelected, BOOL bPressed)
This method is called to draw an image of the item.
CXTPShortcutListBoxTheme::m_crgItemBackPressed
CXTPPaintManagerColorGradient m_crgItemBackPressed
Pressed Item color.
Definition XTPShortcutListBoxTheme.h:102
CXTPShortcutListBoxTheme::CXTPShortcutListBoxTheme
CXTPShortcutListBoxTheme()
Constructs a CXTPShortcutListBoxTheme object.
CXTPShortcutListBoxTheme::m_cxIcon
int m_cxIcon
Width of the menu icon.
Definition XTPShortcutListBoxTheme.h:106
CXTPShortcutListBoxTheme::m_crgItemBackHot
CXTPPaintManagerColorGradient m_crgItemBackHot
Selected Item color.
Definition XTPShortcutListBoxTheme.h:101
CXTPShortcutListBoxTheme::RefreshMetrics
virtual void RefreshMetrics(CXTPShortcutListBox *pList)
Call this function to refresh the colors for the list box control.
CXTPShortcutListBoxTheme::~CXTPShortcutListBoxTheme
virtual ~CXTPShortcutListBoxTheme()
Destroys a CXTPShortcutListBoxTheme object, handles cleanup and deallocation.
CXTPShortcutListBoxTheme::m_cyEdge
int m_cyEdge
Height in pixels of the space between the icon and text.
Definition XTPShortcutListBoxTheme.h:105
CXTPShortcutListBoxTheme::m_crgItemBorder
CXTPPaintManagerColorGradient m_crgItemBorder
Item border color.
Definition XTPShortcutListBoxTheme.h:100
CXTPShortcutListBoxTheme::DrawItem
virtual void DrawItem(CXTPShortcutListBox *pMenuListBox, LPDRAWITEMSTRUCT lpDIS)
Call this function to draw an item in the menu list box.
CXTPShortcutListBoxTheme::m_cyIcon
int m_cyIcon
Height of the menu icon.
Definition XTPShortcutListBoxTheme.h:107
CXTPShortcutListBoxTheme::m_crItemText
CXTPPaintManagerColor m_crItemText
Item text color.
Definition XTPShortcutListBoxTheme.h:97
CXTPShortcutListBoxTheme::m_crItemTextDisabled
CXTPPaintManagerColor m_crItemTextDisabled
Disabled item text color.
Definition XTPShortcutListBoxTheme.h:98
CXTPShortcutListBoxTheme::m_crgBack
CXTPPaintManagerColorGradient m_crgBack
Background color.
Definition XTPShortcutListBoxTheme.h:99
CXTPShortcutListBoxTheme::GetBackColor
COLORREF GetBackColor()
Call this function to get the background color of the menu list box.
CXTPShortcutListBoxTheme::GetTextColor
COLORREF GetTextColor()
Call this function to get the color of the text used in the menu list box.
CXTPShortcutListBoxThemeOffice2003
Class CXTPShortcutListBoxThemeOffice2003 is derived from CXTPShortcutListBoxThemeXP.
Definition XTPShortcutListBoxTheme.h:189
CXTPShortcutListBoxThemeOffice2003::CXTPShortcutListBoxThemeOffice2003
CXTPShortcutListBoxThemeOffice2003()
Constructs a CXTPShortcutListBoxThemeOffice2003 object.
CXTPShortcutListBoxThemeOffice2003::DrawImage
virtual void DrawImage(CDC *pDC, CRect &rcIcon, CXTPImageManagerIcon *pImage, BOOL bEnabled, BOOL bSelected, BOOL bPressed)
This method is called to draw an image of the item.
CXTPShortcutListBoxThemeOffice2003::RefreshMetrics
void RefreshMetrics(CXTPShortcutListBox *pList)
Call this function to refresh the colors for the list box control.
CXTPShortcutListBoxThemeOfficeXP
Class CXTPShortcutListBoxThemeOfficeXP is derived from CXTPShortcutListBoxTheme.
Definition XTPShortcutListBoxTheme.h:139
CXTPShortcutListBoxThemeOfficeXP::DrawText
virtual void DrawText(CDC *pDC, CRect &rcText, CXTPShortcutListBox::CONTENT_ITEM *pCI)
This method is called to draw the text of the item.
CXTPShortcutListBoxThemeOfficeXP::DrawImage
virtual void DrawImage(CDC *pDC, CRect &rcIcon, CXTPImageManagerIcon *pImage, BOOL bEnabled, BOOL bSelected, BOOL bPressed)
This method is called to draw an image of the item.
CXTPShortcutListBoxThemeOfficeXP::CXTPShortcutListBoxThemeOfficeXP
CXTPShortcutListBoxThemeOfficeXP()
Constructs a CXTPShortcutListBoxThemeOfficeXP object.
CXTPShortcutListBoxThemeOfficeXP::RefreshMetrics
void RefreshMetrics(CXTPShortcutListBox *pList)
Call this function to refresh the colors for the list box control.
CXTPShortcutListBox::CONTENT_ITEM
CONTENT_ITEM structure is used by the CXTPShortcutListBox class to maintain information about a parti...
Definition XTPShortcutListBox.h:57


Toolkit Pro: XTPDatePickerNativeWindows10Theme.h Source File

  • Source
  • Calendar
  • DatePicker
  • Themes
XTPDatePickerNativeWindows10Theme.h
Go to the documentation of this file.
1
22#if !defined(_XTPDATEPICKERNATIVEWINDOWS10THEME_H__)
23# define _XTPDATEPICKERNATIVEWINDOWS10THEME_H__
24
25# if _MSC_VER > 1000
26# pragma once
27# endif // _MSC_VER > 1000
28
29# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
30
51class _XTP_EXT_CLASS CXTPDatePickerThemeNativeWindows10 : public CXTPDatePickerThemeOffice2013
52{
53public:
62 CXTPDatePickerThemeNativeWindows10();
63
70 virtual ~CXTPDatePickerThemeNativeWindows10();
71};
72
73# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
74#endif // !defined(_XTPDATEPICKERNATIVEWINDOWS10THEME_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPDatePickerThemeNativeWindows10
Class CXTPDatePickerThemeNativeWindows10 is derived from CXTPDatePickerThemeOffice2013 for rendering ...
Definition XTPDatePickerNativeWindows10Theme.h:52
CXTPDatePickerThemeNativeWindows10::~CXTPDatePickerThemeNativeWindows10
virtual ~CXTPDatePickerThemeNativeWindows10()
Default paint manager destructor.
CXTPDatePickerThemeNativeWindows10::CXTPDatePickerThemeNativeWindows10
CXTPDatePickerThemeNativeWindows10()
Default paint manager constructor.
CXTPDatePickerThemeOffice2013
Class CXTPDatePickerThemeOffice2013 is derived from CXTPDatePickerPaintManager for rendering an Offic...
Definition XTPDatePickerOffice2013Theme.h:52


Toolkit Pro: XTPGridRecordItemVariant.h Source File

  • Source
  • GridControl
  • ItemTypes
XTPGridRecordItemVariant.h
Go to the documentation of this file.
1
23#if !defined(__XTPGRIDRECORDITEMVARIANT_H__)
24# define __XTPGRIDRECORDITEMVARIANT_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
43class _XTP_EXT_CLASS CXTPGridRecordItemVariant : public CXTPGridRecordItem
44{
46 DECLARE_SERIAL(CXTPGridRecordItemVariant)
48public:
54 CXTPGridRecordItemVariant(const VARIANT& lpValue = COleVariant((long)0));
55
65 CString GetCaption(CXTPGridColumn* pColumn);
66
67 using CXTPGridRecordItem::GetCaption;
68
74 void SetValue(const COleVariant& var);
75
81 void SetValue(const VARIANT& var);
82
88 void SetValue(const VARIANT* var);
89
96 COleVariant GetValue();
97
110 int Compare(CXTPGridColumn* pCol, CXTPGridRecordItem* pItem);
111
119 virtual COleVariant GetGroupCaptionValue(CXTPGridColumn* pColumn);
120
136 virtual int CompareGroupCaption(CXTPGridColumn* pColumn, CXTPGridGroupRow* pGroupRow);
137
138 using CXTPGridRecordItem::CompareGroupCaption;
139
147 virtual void OnEditChanged(XTP_GRIDRECORDITEM_ARGS* pItemArgs, LPCTSTR szText);
148
157 void OnConstraintChanged(XTP_GRIDRECORDITEM_ARGS* pItemArgs,
158 CXTPGridRecordItemConstraint* pConstraint);
159
168 DWORD GetSelectedConstraintData(XTP_GRIDRECORDITEM_ARGS* pItemArgs);
169
176 virtual void DoPropExchange(CXTPPropExchange* pPX);
177
178protected:
188 virtual BOOL OnValueChanging(XTP_GRIDRECORDITEM_ARGS* pItemArgs, LPVARIANT lpNewValue);
189
200 virtual BOOL OnEditChanging(XTP_GRIDRECORDITEM_ARGS* pItemArgs, CString& rstrNewText);
201
202protected:
203# ifdef _XTP_ACTIVEX
204 DECLARE_DISPATCH_MAP()
205# endif
206
207private:
208 static int CompareValues(const COleVariant& vt1, const COleVariant& vt2, BOOL bCaseSensitive);
209
210public:
211 COleVariant m_oleValue;
212 static int m_nSortLocale;
213};
214
215# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
217#endif // !defined(__XTPGRIDRECORDITEMVARIANT_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPGridColumn
Represents a grid column item with its properties and operations.
Definition XTPGridColumn.h:107
CXTPGridGroupRow
This class represents a 'group row' of the Grid control view.
Definition XTPGridGroupRow.h:49
CXTPGridRecordItemConstraint
CXTPGridRecordItemConstraint is a CXTPCmdTarget derived class.
Definition XTPGridRecordItemConstraint.h:39
CXTPGridRecordItem
Class for working with single list cell.
Definition XTPGridRecordItem.h:600
CXTPGridRecordItem::GetCaption
virtual CString GetCaption()
Gets the text caption of the item.
CXTPGridRecordItem::CompareGroupCaption
virtual int CompareGroupCaption(CXTPGridColumn *pColumn, CXTPGridRecordItem *pItem)
Compares the group caption of the current record item with the group caption of a provided record ite...
CXTPGridRecordItemVariant
Represents a variant item and inherits basic functionality from the CXTPGridRecordItem class.
Definition XTPGridRecordItemVariant.h:44
CXTPGridRecordItemVariant::Compare
int Compare(CXTPGridColumn *pCol, CXTPGridRecordItem *pItem)
Compares the current item with a provided item.
CXTPGridRecordItemVariant::DoPropExchange
virtual void DoPropExchange(CXTPPropExchange *pPX)
Call this member function to store/load a grid record item using the specified data object.
CXTPGridRecordItemVariant::OnEditChanging
virtual BOOL OnEditChanging(XTP_GRIDRECORDITEM_ARGS *pItemArgs, CString &rstrNewText)
This method is called before the value of the in-place editor is changed by the user.
CXTPGridRecordItemVariant::SetValue
void SetValue(const VARIANT *var)
Sets the value for the item.
CXTPGridRecordItemVariant::OnEditChanged
virtual void OnEditChanged(XTP_GRIDRECORDITEM_ARGS *pItemArgs, LPCTSTR szText)
This method is called when the value of the in-place edit control is changed.
CXTPGridRecordItemVariant::CXTPGridRecordItemVariant
CXTPGridRecordItemVariant(const VARIANT &lpValue=COleVariant((long) 0))
Creates a record variant item.
CXTPGridRecordItemVariant::SetValue
void SetValue(const VARIANT &var)
Sets the value for the item.
CXTPGridRecordItemVariant::m_nSortLocale
static int m_nSortLocale
Sort locale.
Definition XTPGridRecordItemVariant.h:212
CXTPGridRecordItemVariant::m_oleValue
COleVariant m_oleValue
Item value.
Definition XTPGridRecordItemVariant.h:211
CXTPGridRecordItemVariant::OnValueChanging
virtual BOOL OnValueChanging(XTP_GRIDRECORDITEM_ARGS *pItemArgs, LPVARIANT lpNewValue)
This method is called before the value of the item is changed by the user.
CXTPGridRecordItemVariant::GetCaption
CString GetCaption(CXTPGridColumn *pColumn)
Retrieves the text caption of the current item.
CXTPGridRecordItemVariant::GetValue
COleVariant GetValue()
Gets the value of the item.
CXTPGridRecordItemVariant::OnConstraintChanged
void OnConstraintChanged(XTP_GRIDRECORDITEM_ARGS *pItemArgs, CXTPGridRecordItemConstraint *pConstraint)
This method is called when the value of the selected contraint of the in-place list is changed by the...
CXTPGridRecordItemVariant::SetValue
void SetValue(const COleVariant &var)
Sets the value for the item.
CXTPGridRecordItemVariant::GetSelectedConstraintData
DWORD GetSelectedConstraintData(XTP_GRIDRECORDITEM_ARGS *pItemArgs)
Retrieves the value associated with the selected constraint.
CXTPGridRecordItemVariant::CompareGroupCaption
virtual int CompareGroupCaption(CXTPGridColumn *pColumn, CXTPGridGroupRow *pGroupRow)
Compares the group caption of the current record item with the group caption of a provided group row.
CXTPGridRecordItemVariant::GetGroupCaptionValue
virtual COleVariant GetGroupCaptionValue(CXTPGridColumn *pColumn)
Retrieves the group caption native value.
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72
XTP_GRIDRECORDITEM_ARGS
Basic set of parameters transferred to item handlers.
Definition XTPGridRecordItem.h:69


Toolkit Pro: XTPChartOpenGLFunnelDeviceCommand.h Source File

  • Source
  • Chart
  • Styles
  • Funnel
  • 3D
  • Commands
  • OpenGL
XTPChartOpenGLFunnelDeviceCommand.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTOPENGLFUNNELDEVICECOMMAND_H__)
24# define __XTPCHARTOPENGLFUNNELDEVICECOMMAND_H__
25
26# if _MSC_VER >= 1000
27# pragma once
28# endif // _MSC_VER >= 1000
29
30# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
31
32class CXTPChart3dFunnelSeriesStyle;
33class CXTPChartDeviceContext;
34class CXTPChartSeriesStyle;
35class CXTPChartOpenGLDeviceContext;
36
43class _XTP_EXT_CLASS CXTPChartOpenGLFunnelDeviceCommand : public CXTPChart3dDeviceCommand
44{
45public:
60 CXTPChartOpenGLFunnelDeviceCommand(const CXTPPoint3d& center, const CXTPChartRectF& rc,
61 double dWidth, double dHeight, double dFrom, double dTo,
62 const CXTPChartColor& color, BOOL bSmoothEdges);
63
68 ~CXTPChartOpenGLFunnelDeviceCommand();
69
70protected:
82 virtual CXTPChartElement* HitTest(CPoint point, CXTPChartElement* pParent) const;
83
90 virtual void ExecuteOverride(CXTPChartDeviceContext* pDC);
91
98 virtual void ApplySeriesStyle(CXTPChartSeriesStyle* pStyle);
99
110 virtual void PrepareOverride(CXTPChartDeviceContext* pDC);
111
112private:
113 void DrawTriangle(const CXTPPoint3d& a, const CXTPPoint3d& va, const CXTPPoint3d& b,
114 const CXTPPoint3d& vb, const CXTPPoint3d& c, const CXTPPoint3d& vc);
115 void DrawFunnelSlice();
116
117 void ComputeConnectorPoints(CXTPChartOpenGLDeviceContext* pGLDC);
118
119private:
120 BOOL m_bPrepared;
121 CXTPChart3dBox m_3dBox;
122 CXTPPoint3d m_ptCenterConnectorPoint;
123 CXTPPoint3d m_ptOuterConnectorPoint;
124 CXTPChartColor m_color;
125 CXTPChart3dFunnelSeriesStyle* m_pStyle;
126 GLuint m_listId;
127 CXTPChartRectF m_rc;
128 double m_dWidth;
129 double m_dHeight;
130 double m_dFrom;
131 double m_dTo;
132 CXTPPoint3d m_ptCenter;
133 BOOL m_bSmoothEdges;
134 CArray<CXTPPoint3d, const CXTPPoint3d&> m_arMidFacePoints;
135};
136
137# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
138#endif //#if !defined(__XTPCHARTOPENGLFUNNELDEVICECOMMAND_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChart3dBox
Represents a 3D box build around included points and provides useful and fast operations.
Definition XTPChartTypes.h:728
CXTPChart3dDeviceCommand
Defines a common implementation interface for chart 3D drawing commands.
Definition XTPChartDeviceCommand.h:368
CXTPChart3dFunnelSeriesStyle
This class abstracts the basic style of a funnel series.
Definition XTPChart3dFunnelSeriesStyle.h:49
CXTPChartColor
This class abstracts a color entity.
Definition XTPChartTypes.h:51
CXTPChartDeviceCommand::ApplySeriesStyle
virtual void ApplySeriesStyle(CXTPChartSeriesStyle *pStyle)
Applies series style to the current element.
CXTPChartDeviceCommand::PrepareOverride
virtual void PrepareOverride(CXTPChartDeviceContext *pDC)
Derived implementation must override this method for implementing implementation specific preparation...
CXTPChartDeviceCommand::HitTest
virtual CXTPChartElement * HitTest(CPoint point, CXTPChartElement *pParent) const
Performs recursive hit testing of the element at the specified point.
CXTPChartDeviceCommand::ExecuteOverride
virtual void ExecuteOverride(CXTPChartDeviceContext *pDC)
Override this function to write the drawing code for specific objects.
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartElement
This class abstracts a chart element, this class acts as a base class for all chart elements.
Definition XTPChartElement.h:131
CXTPChartSeriesStyle
CXTPChartSeriesStyle is a CXTPChartElement derived class.
Definition XTPChartSeriesStyle.h:49
CXTPPoint3T< double >
CXTPRectT< float >


Toolkit Pro: Member List

CXTPRibbonOffice2013Theme Member List

This is the complete list of members for CXTPRibbonOffice2013Theme, including all inherited members.

CreateTabPaintManager() | CXTPRibbonPaintManager | protectedvirtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPRibbonMarkupTheme(CXTPPaintManager *pPaintManager) | CXTPRibbonMarkupTheme |
CXTPRibbonOffice2013Theme(CXTPPaintManager *pPaintManager) | CXTPRibbonOffice2013Theme |
CXTPRibbonPaintManager(CXTPPaintManager *pPaintManager) | CXTPRibbonPaintManager |
DrawBackImage(CDC *pDC, CXTPRibbonBar *pRibbonBar) | CXTPRibbonOffice2013Theme | protectedvirtual
DrawControlGroupOption(CDC *pDC, CXTPControl *pControlGroupOption, BOOL bDraw) | CXTPRibbonMarkupTheme | virtual
DrawControlGroupPopup(CDC *pDC, CXTPControlPopup *pControlGroupPopup, BOOL bDraw) | CXTPRibbonMarkupTheme | virtual
DrawDwmCaptionText(CDC *pDC, CRect rcCaptionText, CString strText, CWnd *pSite, BOOL bActive) | CXTPRibbonPaintManager | protected
DrawGroup(CDC *pDC, CXTPRibbonGroup *pGroup) | CXTPRibbonMarkupTheme | virtual
DrawQuickAccessControl(CDC *pDC, CXTPRibbonBar *pRibbon, CXTPControl *pControl) | CXTPRibbonOffice2013Theme | virtual
DrawRibbonApplicationIcon(CDC *pDC, CXTPRibbonBar *pRibbonBar, CRect rc, HICON hIcon) | CXTPRibbonPaintManager | protected
DrawRibbonFrameCaption(CDC *pDC, CXTPRibbonBar *pRibbonBar, BOOL bActive) | CXTPRibbonOffice2013Theme | virtual
DrawRibbonFrameCaptionBar(CDC *pDC, CXTPRibbonBar *pRibbonBar, BOOL bActive) | CXTPRibbonOffice2013Theme | virtual
DrawRibbonFrameContextHeaders(CDC *pDC, CXTPRibbonBar *pRibbonBar, CXTPRibbonTabContextHeaders *pContextHeaders) | CXTPRibbonOffice2013Theme | virtual
DrawRibbonFramePart(CDC *pDC, CXTPRibbonBar *pRibbonBar) | CXTPRibbonPaintManager | virtual
DrawRibbonFrameSystemButton(CDC *pDC, CXTPRibbonControlSystemButton *pControl, CRect rc) | CXTPRibbonOffice2013Theme | virtual
DrawRibbonGroupControlEntry(CDC *pDC, CXTPControl *pButton) | CXTPRibbonMarkupTheme | virtual
DrawRibbonGroupPopupToolBar(CDC *pDC, CXTPRibbonGroup *pRibbonGroup) | CXTPRibbonMarkupTheme | virtual
DrawRibbonQuickAccessButton(CDC *pDC, CXTPControlPopup *pControl) | CXTPRibbonMarkupTheme | virtual
DrawRibbonQuickAccessControls(CDC *pDC, CXTPRibbonBar *pRibbonBar) | CXTPRibbonMarkupTheme | virtual
DrawRibbonQuickAccessMoreButton(CDC *pDC, CXTPControlPopup *pControl) | CXTPRibbonMarkupTheme | virtual
DrawRibbonScrollButton(CDC *pDC, CXTPControl *pControl, BOOL bScrollLeft) | CXTPRibbonMarkupTheme | virtual
DrawRibbonTab(CDC *pDC, CXTPRibbonTab *pItem) | CXTPRibbonOffice2013Theme | virtual
DrawSystemPopupBarButton(CDC *pDC, CXTPControl *pButton) | CXTPRibbonMarkupTheme | virtual
FillGroupPopupToolBar(CDC *pDC, CXTPRibbonGroup *pGroup, CXTPCommandBar *pCommandBar) | CXTPRibbonMarkupTheme | virtual
FillGroupRect(CDC *pDC, CXTPRibbonTab *pActiveTab, CRect rcGroups) | CXTPRibbonMarkupTheme | virtual
FillMorePopupToolBarEntry(CDC *pDC, CXTPCommandBar *pBar) | CXTPRibbonMarkupTheme | virtual
FillRibbonBar(CDC *pDC, CXTPRibbonBar *pRibbonBar) | CXTPRibbonOffice2013Theme | virtual
FillRibbonTabControl(CDC *pDC, CXTPRibbonBar *pRibbonBar, CRect rcControl) | CXTPRibbonMarkupTheme | virtual
FillSystemPopupBarEntry(CDC *pDC, CXTPPopupBar *pBar) | CXTPRibbonMarkupTheme | virtual
FillTabPopupToolBar(CDC *pDC, CXTPPopupToolBar *pPopupToolBar) | CXTPRibbonPaintManager | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetBackImageName() | CXTPRibbonOffice2013Theme | protectedvirtual
GetControlGroupOptionSize() const | CXTPRibbonMarkupTheme | virtual
GetEditHeight() const | CXTPRibbonPaintManager |
GetFontHeight() const | CXTPRibbonPaintManager |
GetFramePaintManager() const | CXTPRibbonPaintManager |
GetGroupCaptionHeight() const | CXTPRibbonPaintManager |
GetImages() const | CXTPRibbonPaintManager |
GetRibbonCaptionHeight(const CXTPRibbonBar *pRibbonBar) const | CXTPRibbonOffice2013Theme | virtual
GetTabPaintManager() const | CXTPRibbonPaintManager |
LoadImage(LPCTSTR lpszFileName) | CXTPRibbonPaintManager |
LoadParts(BOOL bReload=FALSE) | CXTPRibbonOffice2013Theme | protectedvirtual
CXTPRibbonMarkupTheme::LoadParts(HZIP hZip, CXTPMarkupContext *pMarkupContext=NULL) | CXTPRibbonMarkupTheme |
m_bFlatFrame | CXTPRibbonPaintManager |
m_bHotTrackingGroups | CXTPRibbonPaintManager |
m_clrBackstageSysButtonBack2013Highlighted | CXTPRibbonMarkupTheme | protected
m_clrBackstageSysButtonBack2013Normal | CXTPRibbonMarkupTheme | protected
m_clrFileButtonText | CXTPRibbonPaintManager | protected
m_clrHeader | CXTPRibbonOffice2013Theme | protected
m_clrMinimizedFrameEdgeHighLight | CXTPRibbonPaintManager | protected
m_clrMinimizedFrameEdgeShadow | CXTPRibbonPaintManager | protected
m_clrRecentFileListEdgeHighLight | CXTPRibbonPaintManager |
m_clrRecentFileListEdgeShadow | CXTPRibbonPaintManager |
m_clrRibbonBorder | CXTPRibbonPaintManager | protected
m_clrRibbonFace | CXTPRibbonPaintManager | protected
m_clrRibbonGroupCaptionText | CXTPRibbonPaintManager | protected
m_clrRibbonInactiveFace | CXTPRibbonPaintManager | protected
m_clrRibbonInactiveFaceState | CXTPRibbonOffice2013Theme | protected
m_clrRibbonTabDelimeter | CXTPRibbonOffice2013Theme | protected
m_clrTabBackackstageLeft | CXTPRibbonOffice2013Theme | protected
m_clrTabBackackstageRight | CXTPRibbonOffice2013Theme | protected
m_clrTabBackInactiveState | CXTPRibbonOffice2013Theme | protected
m_fontGroupCaption | CXTPRibbonPaintManager |
m_nGroupCaptionHeight | CXTPRibbonPaintManager |
m_nGroupSpacing | CXTPRibbonPaintManager |
m_nTabsHeight | CXTPRibbonPaintManager |
m_pMarkupContext | CXTPRibbonMarkupTheme | protected
m_pPaintManager | CXTPRibbonPaintManager | protected
m_pTabPaintManager | CXTPRibbonPaintManager | protected
m_rcFileButtonMargin | CXTPRibbonPaintManager | protected
m_strHighlightedPrefix | CXTPRibbonMarkupTheme | protected
m_strNormalPrefix | CXTPRibbonMarkupTheme | protected
RefreshMetrics() | CXTPRibbonOffice2013Theme | virtual
RenderMarkup(CDC *pDC, CRect rc, LPCTSTR lpszText) | CXTPRibbonMarkupTheme |
RenderMarkup(CDC *pDC, CRect rc, XTPRibbonThemePart part) | CXTPRibbonMarkupTheme |
SetBackImage(int nImage) | CXTPRibbonOffice2013Theme | virtual
SetFontHeight(int nFontHeight) | CXTPRibbonPaintManager |
~CXTPRibbonMarkupTheme() | CXTPRibbonMarkupTheme | virtual
~CXTPRibbonOffice2013Theme() | CXTPRibbonOffice2013Theme | virtual
~CXTPRibbonPaintManager() | CXTPRibbonPaintManager | virtual


Toolkit Pro: Member List

CXTPCalendarControl Member List

This is the complete list of members for CXTPCalendarControl, including all inherited members.

_SetDataProvider(CXTPCalendarData *pDataProvider, BOOL bCloseDataProviderWhenDestroy=TRUE) | CXTPCalendarControl | protectedvirtual
AddCustomTimeIntervalForReminder(int nMin, LPCTSTR szCustomMeaning=NULL, BOOL bIgnoreDefaultValues=FALSE) | CXTPCalendarControl |
AdjustLayout() | CXTPCalendarControl | virtual
AdjustLayout(CDC *pDC, const CRect &rcView) | CXTPCalendarControl | virtual
AdjustScrollBar(int nSBType=-1) | CXTPCalendarControl | virtual
AdjustScrollBarEx(int nSBType) | CXTPCalendarControl | protectedvirtual
Create(DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID) | CXTPCalendarControl | virtual
CreateDataProvider(LPCTSTR lpszConnectionString) | CXTPCalendarControl | static
CreateDataProvider(XTPCalendarDataProvider eDataProvider) | CXTPCalendarControl | static
CXTPCalendarControl() | CXTPCalendarControl |
DataProviderTypeFromConStr(LPCTSTR lpszConnectionString, XTPCalendarDataProvider eDPDefault=xtpCalendarDataProviderUnknown) | CXTPCalendarControl | static
DataSourceFromConStr(LPCTSTR lpszConnectionString) | CXTPCalendarControl | static
DayView_IsAutoResetBusyFlag() const | CXTPCalendarControl |
DayView_SetAutoResetBusyFlag(BOOL bAutoResetBusyFlag=TRUE) | CXTPCalendarControl |
DoDeleteEvent(CXTPCalendarViewEvent *pViewEvent) | CXTPCalendarControl | virtual
DoDeleteSelectedEvents(CXTPCalendarViewEvent *pViewEvent) | CXTPCalendarControl | virtual
EnableMarkup(BOOL bEnableMarkup=TRUE) | CXTPCalendarControl |
EnableReminders(BOOL bEnable=TRUE) | CXTPCalendarControl |
EnableSendNotifications(BOOL bEnable=TRUE) | CXTPCalendarControl | virtual
EnableToolTips(BOOL bEnable=TRUE) | CXTPCalendarControl |
GetActiveView() const | CXTPCalendarControl | virtual
GetAskItemTextFlags() const | CXTPCalendarControl | virtual
GetCalendarOptions() const | CXTPCalendarControl |
GetConnection() const | CXTPCalendarControl |
GetDataProvider() const | CXTPCalendarControl |
GetDayView() const | CXTPCalendarControl |
GetFirstDayOfWeek() const | CXTPCalendarControl |
GetFirstWeekOfYearDays() const | CXTPCalendarControl |
GetMarkupContext() const | CXTPCalendarControl |
GetMonthView() const | CXTPCalendarControl |
GetPaintManager() const | CXTPCalendarControl |
GetPaintTheme() const | CXTPCalendarControl | virtual
GetRemindersManager() const | CXTPCalendarControl | virtual
GetResources() const | CXTPCalendarControl |
GetTheme() const | CXTPCalendarControl |
GetThemeVersion() const | CXTPCalendarControl |
GetTimeLineScale() const | CXTPCalendarControl |
GetTimeLineView() const | CXTPCalendarControl |
GetTodayDate() const | CXTPCalendarControl |
GetTodayDateOverride() const | CXTPCalendarControl |
GetWeekView() const | CXTPCalendarControl |
GetWorkDayEndTime(COleDateTime &dtTime) const | CXTPCalendarControl |
GetWorkDayEndTime(int &nHour, int &nMin, int &nSec) const | CXTPCalendarControl |
GetWorkDayStartTime(COleDateTime &dtTime) const | CXTPCalendarControl |
GetWorkDayStartTime(int &nHour, int &nMin, int &nSec) const | CXTPCalendarControl |
GetWorkWeekMask() const | CXTPCalendarControl |
HideToolTip() | CXTPCalendarControl | virtual
IsLayoutRTL() const | CXTPCalendarControl |
IsMarkupEnabled() const | CXTPCalendarControl |
IsReadonlyMode() const | CXTPCalendarControl |
IsRemindersEnabled() const | CXTPCalendarControl |
IsToday(const COleDateTime &dtDate) const | CXTPCalendarControl | virtual
IsToolTipsEnabled() const | CXTPCalendarControl |
IsToolTipVisible() const | CXTPCalendarControl | virtual
m_bDeleteOcurrenceEventIfNoPrompt | CXTPCalendarControl |
m_bDeleteOnFinalRelease | CXTPCalendarControl |
m_bDisableRedraw | CXTPCalendarControl |
m_bForcePagination | CXTPCalendarControl |
m_bFullDateMode | CXTPCalendarControl |
m_bHideCaptionBar | CXTPCalendarControl |
m_bHideLinkContainer | CXTPCalendarControl |
m_bMultiColorScheduleMode | CXTPCalendarControl |
m_bMultiColumnWeekMode | CXTPCalendarControl |
m_bMultipleSchedulesMode | CXTPCalendarControl |
m_bMultipleSchedulesNoSelfLinks | CXTPCalendarControl |
m_Borders | CXTPCalendarControl | protected
m_bPreventAutoAllDayMode | CXTPCalendarControl |
m_bPromptToDeleteRecurrentEvent | CXTPCalendarControl |
m_bReadOnlyMode | CXTPCalendarControl |
m_bShowLinks | CXTPCalendarControl |
m_bShowTooltipForAllDayEvents | CXTPCalendarControl |
m_bShowTooltipForNotFocused | CXTPCalendarControl |
m_bSwitchToDayViewIfPickedSingleDay | CXTPCalendarControl |
m_bTimelineMode | CXTPCalendarControl |
m_bTooltipUnderMouse | CXTPCalendarControl |
m_bUpdateWhenEventChangedNotify | CXTPCalendarControl | protected
m_cntViewChanged | CXTPCalendarControl | protected
m_eViewType | CXTPCalendarControl |
m_mapCustomReminderValues | CXTPCalendarControl |
m_mouseMode | CXTPCalendarControl |
m_nCaptionHeight | CXTPCalendarControl |
m_nRowsPerWheel | CXTPCalendarControl | protected
m_nTimelineScale | CXTPCalendarControl |
m_OwnerUser | CXTPCalendarControl |
m_pMarkupContext | CXTPCalendarControl | protected
m_pRemindersManager | CXTPCalendarControl | protected
m_sCustomFormat4Tooltip | CXTPCalendarControl |
m_sCustomTitle | CXTPCalendarControl |
m_strRedoUIText | CXTPCalendarControl | protected
m_strUndoUIText | CXTPCalendarControl | protected
MonthView_IsCompressWeekendDays() const | CXTPCalendarControl |
MonthView_IsShowEndDate() const | CXTPCalendarControl |
MonthView_IsShowTimeAsClocks() const | CXTPCalendarControl |
MonthView_SetCompressWeekendDays(BOOL bCompress=TRUE) | CXTPCalendarControl |
MonthView_SetShowEndDate(BOOL bShowEnd=TRUE) | CXTPCalendarControl |
MonthView_SetShowTimeAsClocks(BOOL bShowClocks=TRUE) | CXTPCalendarControl |
OnBeforeDestroy() | CXTPCalendarControl | protectedvirtual
OnCalendarTimeline() | CXTPCalendarControl |
OnCopy() | CXTPCalendarControl | virtual
OnCut() | CXTPCalendarControl | virtual
OnDraw(CDC *pDC) | CXTPCalendarControl | protectedvirtual
OnEditCommand(UINT uCommandID) | CXTPCalendarControl | virtual
OnOptionsChanged(int nOptionRelation) | CXTPCalendarControl | protectedvirtual
OnPaste() | CXTPCalendarControl | virtual
OnUndo() | CXTPCalendarControl | virtual
OnUpdateCmdUI(CCmdUI *pCmdUI) | CXTPCalendarControl | virtual
OnUpdateCopy(CCmdUI *pCmdUI) | CXTPCalendarControl | virtual
OnUpdateCut(CCmdUI *pCmdUI) | CXTPCalendarControl | virtual
OnUpdatePaste(CCmdUI *pCmdUI) | CXTPCalendarControl | virtual
OnUpdateUndo(CCmdUI *pCmdUI) | CXTPCalendarControl | virtual
OnWndMsg(UINT message, WPARAM wParam, LPARAM lParam, LRESULT *pResult) | CXTPCalendarControl | virtual
OnWndMsg_Children(UINT message, WPARAM wParam, LPARAM lParam, LRESULT *pResult) | CXTPCalendarControl | virtual
Populate() | CXTPCalendarControl | virtual
QueueDayViewSwitch(DATE dtDate) | CXTPCalendarControl | virtual
RedrawControl(BOOL bForce=FALSE) | CXTPCalendarControl | virtual
RefreshCaptionBar() | CXTPCalendarControl |
RegisterWindowClass(HINSTANCE hInstance=NULL) | CXTPCalendarControl | virtual
ResetTodayDateOverride() | CXTPCalendarControl |
SelectEventById(DWORD dEventID, BOOL bSelect=TRUE) | CXTPCalendarControl |
SelectViewEventByIdAndGroup(int nScheduleID, DWORD dEventID, BOOL bSelect=TRUE) | CXTPCalendarControl |
SendNotification(XTP_NOTIFY_CODE EventCode, WPARAM wParam, LPARAM lParam) | CXTPCalendarControl | virtual
SendNotificationAlways(XTP_NOTIFY_CODE EventCode, WPARAM wParam, LPARAM lParam) | CXTPCalendarControl | virtual
SetActiveView(CXTPCalendarView *pView) | CXTPCalendarControl | protectedvirtual
SetBorders(int nLeft, int nTop, int nRight, int nBottom) | CXTPCalendarControl | virtual
SetDataProvider(LPCTSTR lpszConnectionString) | CXTPCalendarControl |
SetDataProvider(CXTPCalendarData *pDataProvider, BOOL bCloseDataProviderWhenDestroy=TRUE) | CXTPCalendarControl |
SetDataProvider(XTPCalendarDataProvider eDataProvider, LPCTSTR lpszConnectionString=NULL) | CXTPCalendarControl |
SetFirstDayOfWeek(const int nFirstDayOfWeek) | CXTPCalendarControl |
SetFirstWeekOfYearDays(const int nFirstWeekOfYearDays) | CXTPCalendarControl |
SetLayoutRTL(BOOL bRightToLeft) | CXTPCalendarControl |
SetLongDayHeaderFormat(LPCTSTR pcszCustomFormat) | CXTPCalendarControl |
SetPaintManager(CXTPCalendarPaintManager *pPaintManager) | CXTPCalendarControl |
SetPaintTheme(XTPCalendarTheme ePaintTheme) | CXTPCalendarControl | virtual
SetPaintTheme(CXTPCalendarPaintManager *pPaintManager, CXTPCalendarTheme *pTheme) | CXTPCalendarControl | virtual
SetResources(CXTPCalendarResources *pResources, CXTPCalendarData *pOptionsDataProvider=NULL) | CXTPCalendarControl |
SetSmallDayHeaderFormat(LPCTSTR pcszCustomFormat) | CXTPCalendarControl |
SetTheme(CXTPCalendarTheme *pTheme) | CXTPCalendarControl |
SetTimer(UINT uTimeOut_ms) | CXTPCalendarControl | protectedvirtual
SetTodayDateOverride(const COleDateTime &dtTodayOverride) | CXTPCalendarControl |
SetWorkDayEndTime(const COleDateTime &dtTime) | CXTPCalendarControl |
SetWorkDayEndTime(int nHour, int nMin, int nSec) | CXTPCalendarControl |
SetWorkDayStartTime(const COleDateTime &dtTime) | CXTPCalendarControl |
SetWorkDayStartTime(int nHour, int nMin, int nSec) | CXTPCalendarControl |
SetWorkWeekMask(const int nMask) | CXTPCalendarControl |
ShowToolTip(const CString &strText, const CRect rcToolTip, CFont *pFont, BOOL bAdvanced=FALSE) | CXTPCalendarControl | virtual
SwitchActiveView(XTPCalendarViewType eView) | CXTPCalendarControl | virtual
UpdateBorders() | CXTPCalendarControl | virtual
UpdateMouseCursor() | CXTPCalendarControl | virtual
WeekView_IsShowEndDate() const | CXTPCalendarControl |
WeekView_IsShowTimeAsClocks() const | CXTPCalendarControl |
WeekView_SetShowEndDate(BOOL bShowEnd) | CXTPCalendarControl |
WeekView_SetShowTimeAsClocks(BOOL bShowClocks) | CXTPCalendarControl |
~CXTPCalendarControl() | CXTPCalendarControl | virtual


Toolkit Pro: Member List

CXTPTabColorSetVisualStudio2022 Member List

This is the complete list of members for CXTPTabColorSetVisualStudio2022, including all inherited members.

CXTPTabPaintManagerColorSet() | CXTPTabPaintManagerColorSet |
FillClient(CDC *pDC, CRect rc, CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
FillHeader(CDC *pDC, CRect rc, CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
FillNavigateButton(CDC *pDC, CXTPTabManagerNavigateButton *pButton, CRect &rc) | CXTPTabColorSetVisualStudio2015 | virtual
FillPropertyButton(CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem) | CXTPTabColorSetVisualStudio2015 | virtual
FillStateButton(CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerColorSet | virtual
GetClientColor(CXTPTabManager *pTabManager) | CXTPTabColorSetVisualStudio2015 | virtual
GetItemColor(CXTPTabManagerItem *pItem) | CXTPTabColorSetVisualStudio2015 | virtual
GradientFill(CDC *pDC, CRect rc, COLORREF clrLight, COLORREF clrDark, XTPTabPosition position) | CXTPTabPaintManagerColorSet |
IsAppThemed() const | CXTPTabPaintManagerColorSet | virtual
m_clrActiveFilesBack | CXTPTabPaintManagerColorSet |
m_clrActiveFilesBackHighlighted | CXTPTabPaintManagerColorSet |
m_clrActiveFilesBackPressed | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyph | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyphHighlighted | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyphPressed | CXTPTabPaintManagerColorSet |
m_clrAutoHideFace | CXTPTabPaintManagerColorSet |
m_clrBorderHighlight | CXTPTabPaintManagerColorSet |
m_clrButtonBorder | CXTPTabPaintManagerColorSet |
m_clrButtonBorderHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonBorderHot | CXTPTabPaintManagerColorSet |
m_clrButtonBorderKeyTips | CXTPTabPaintManagerColorSet |
m_clrButtonBorderTabContext1 | CXTPTabPaintManagerColorSet |
m_clrButtonBorderTabContext2 | CXTPTabPaintManagerColorSet |
m_clrButtonHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonHighlightedClose | CXTPTabPaintManagerColorSet |
m_clrButtonNormal | CXTPTabPaintManagerColorSet |
m_clrButtonPressed | CXTPTabPaintManagerColorSet |
m_clrButtonSelected | CXTPTabPaintManagerColorSet |
m_clrButtonSelectedHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonSelectedPressed | CXTPTabPaintManagerColorSet |
m_clrControlFace | CXTPTabPaintManagerColorSet |
m_clrFrameBorder | CXTPTabPaintManagerColorSet |
m_clrHeaderFace | CXTPTabPaintManagerColorSet |
m_clrPaneFace | CXTPTabPaintManagerColorSet |
m_clrTabClientBack | CXTPTabPaintManagerColorSet |
m_clrTabClientBorder | CXTPTabPaintManagerColorSet |
m_clrTextDisabled | CXTPTabPaintManagerColorSet |
m_clrTextHighlight | CXTPTabPaintManagerColorSet |
m_clrTextHighlightClose | CXTPTabPaintManagerColorSet |
m_clrTextNormal | CXTPTabPaintManagerColorSet |
m_clrTextPressed | CXTPTabPaintManagerColorSet |
m_clrTextSelected | CXTPTabPaintManagerColorSet |
m_clrTextSelectedHighlighted | CXTPTabPaintManagerColorSet |
m_clrTextSelectedPressed | CXTPTabPaintManagerColorSet |
m_csExcelNormal | CXTPTabPaintManagerColorSet |
m_csExcelSelected | CXTPTabPaintManagerColorSet |
m_csPropertyPage | CXTPTabPaintManagerColorSet |
m_csPropertyPage2003 | CXTPTabPaintManagerColorSet |
m_csStateButton | CXTPTabPaintManagerColorSet |
m_pPaintManager | CXTPTabPaintManagerColorSet | protected
RefreshMetrics() | CXTPTabColorSetVisualStudio2022 | virtual
SelectClipRgn(CDC *pDC, CRect rcClient, CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
SetTextColor(CDC *pDC, CXTPTabManagerItem *pItem) | CXTPTabColorSetVisualStudio2015 | virtual
~CXTPTabPaintManagerColorSet() | CXTPTabPaintManagerColorSet | virtual


Toolkit Pro: Member List

CXTPTaskDialogClient Member List

This is the complete list of members for CXTPTaskDialogClient, including all inherited members.

m_arrCommandButtons | CXTPTaskDialogClient | protected
m_arrLinkButtons | CXTPTaskDialogClient | protected
m_arrRadioButtons | CXTPTaskDialogClient | protected
m_bEnableMarkup | CXTPTaskDialogClient | protected
m_bExpanded | CXTPTaskDialogClient | protected
m_bMessageBoxStyle | CXTPTaskDialogClient | protected
m_bShowInputBox | CXTPTaskDialogClient | protected
m_bThemeReady | CXTPTaskDialogClient | protected
m_bUseSysIcons | CXTPTaskDialogClient | protected
m_bVerification | CXTPTaskDialogClient | protected
m_cr3DHighLight | CXTPTaskDialogClient | protected
m_cr3DLight | CXTPTaskDialogClient | protected
m_cr3DShadow | CXTPTaskDialogClient | protected
m_crContent | CXTPTaskDialogClient | protected
m_crContentText | CXTPTaskDialogClient | protected
m_crFooter | CXTPTaskDialogClient | protected
m_crFooterText | CXTPTaskDialogClient | protected
m_crMainText | CXTPTaskDialogClient | protected
m_hIconFooter | CXTPTaskDialogClient | protected
m_hIconMain | CXTPTaskDialogClient | protected
m_mapWndSize | CXTPTaskDialogClient | protected
m_nMaxClientWidth | CXTPTaskDialogClient | protected
m_nMinClientWidth | CXTPTaskDialogClient | protected
m_nPadding | CXTPTaskDialogClient | protected
m_nSelRadioButtonID | CXTPTaskDialogClient | protected
m_pBtnExpando | CXTPTaskDialogClient | protected
m_pBtnVerify | CXTPTaskDialogClient | protected
m_pConfig | CXTPTaskDialogClient | protected
m_pMarkupContext | CXTPTaskDialogClient | protected
m_ptBorder | CXTPTaskDialogClient | protected
m_ptBtnSpacing | CXTPTaskDialogClient | protected
m_ptMargin | CXTPTaskDialogClient | protected
m_ptPadding | CXTPTaskDialogClient | protected
m_rcCommandButtons | CXTPTaskDialogClient | protected
m_rcContent | CXTPTaskDialogClient | protected
m_rcExpandedInformation | CXTPTaskDialogClient | protected
m_rcFooter | CXTPTaskDialogClient | protected
m_rcLinkButtons | CXTPTaskDialogClient | protected
m_rcMainInstruction | CXTPTaskDialogClient | protected
m_rcRadioButtons | CXTPTaskDialogClient | protected
m_sizeCommandButton | CXTPTaskDialogClient | protected
m_sizeIconFooter | CXTPTaskDialogClient | protected
m_sizeIconMain | CXTPTaskDialogClient | protected
m_strCollapsedControlText | CXTPTaskDialogClient | protected
m_strContent | CXTPTaskDialogClient | protected
m_strExpandedControlText | CXTPTaskDialogClient | protected
m_strExpandedInformation | CXTPTaskDialogClient | protected
m_strFooter | CXTPTaskDialogClient | protected
m_strInputBoxText | CXTPTaskDialogClient | protected
m_strMainInstruction | CXTPTaskDialogClient | protected
m_strVerificationText | CXTPTaskDialogClient | protected
m_wndContent | CXTPTaskDialogClient | protected
m_wndExpandedInformation | CXTPTaskDialogClient | protected
m_wndFooter | CXTPTaskDialogClient | protected
m_wndInputBox | CXTPTaskDialogClient | protected
m_wndProgressBar | CXTPTaskDialogClient | protected
m_xtpFont | CXTPTaskDialogClient | protected
m_xtpFontLarge | CXTPTaskDialogClient | protected
MoveButton(CButton *pButton, int xPos, int yPos, int cx, int cy, BOOL bRedraw=FALSE) | CXTPTaskDialogClient | protected
MoveButton(CButton *pButton, const CRect &rect, BOOL bRedraw=FALSE) | CXTPTaskDialogClient | protected


Toolkit Pro: Member List

CXTPCalendarIconIDs Member List

This is the complete list of members for CXTPCalendarIconIDs, including all inherited members.

Add(UINT newElement) | CXTPArrayT< UINT, UINT > | virtual
AddIfNeed(UINT newElement) | CXTPArrayT< UINT, UINT > | virtual
Append(const CXTPArrayT &src) | CXTPArrayT< UINT, UINT > | virtual
Copy(const CXTPArrayT &src) | CXTPArrayT< UINT, UINT > | virtual
CXTPArrayT() | CXTPArrayT< UINT, UINT > |
CXTPCalendarIconIDs() | CXTPCalendarIconIDs |
CXTPCmdTarget() | CXTPCmdTarget |
DoPropExchange(CXTPPropExchange *pPX) | CXTPCalendarIconIDs | virtual
DoPropExchange(CXTPPropExchange *pPX, LPCTSTR pcszSection, LPCTSTR pcszElement) | CXTPCalendarIconIDs | virtual
ElementAt(int nIndex) | CXTPArrayT< UINT, UINT > | virtual
Find(UINT uID) const | CXTPCalendarUIntArray |
FindElement(UINT nElement) const | CXTPArrayT< UINT, UINT > | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAt(int nIndex) const | CXTPArrayT< UINT, UINT > | virtual
GetData() const | CXTPArrayT< UINT, UINT > | virtual
GetData() | CXTPArrayT< UINT, UINT > | virtual
GetSize() const | CXTPArrayT< UINT, UINT > | virtual
InsertAt(int nIndex, UINT newElement, int nCount=1) | CXTPArrayT< UINT, UINT > | virtual
InsertAt(int nStartIndex, CXTPArrayT *pNewArray) | CXTPArrayT< UINT, UINT > | virtual
LoadFromString(LPCTSTR pcszData) | CXTPCalendarUIntArray | virtual
m_arElements | CXTPArrayT< UINT, UINT > | protected
operator[](int nIndex) const | CXTPArrayT< UINT, UINT > |
operator[](int nIndex) | CXTPArrayT< UINT, UINT > |
RemoveAll() | CXTPArrayT< UINT, UINT > | virtual
RemoveAt(int nIndex, int nCount=1) | CXTPArrayT< UINT, UINT > | virtual
RemoveElement(UINT nElement) | CXTPArrayT< UINT, UINT > | virtual
RemoveID(UINT uID) | CXTPCalendarUIntArray | virtual
SaveToString() const | CXTPCalendarUIntArray | virtual
SetAt(int nIndex, UINT newElement) | CXTPArrayT< UINT, UINT > | virtual
SetAtGrow(int nIndex, UINT newElement) | CXTPArrayT< UINT, UINT > | virtual
SetSize(int nNewSize, int nGrowBy=-1) | CXTPArrayT< UINT, UINT > | virtual
~CXTPArrayT() | CXTPArrayT< UINT, UINT > | virtual
~CXTPCalendarIconIDs() | CXTPCalendarIconIDs | virtual


Toolkit Pro: XTPMacros.h Source File

  • Source
  • Common
XTPMacros.h
Go to the documentation of this file.
1
23#if !defined(__XTPMACROS_H__)
24# define __XTPMACROS_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38# define XTP_WIDE(str) XTP_WIDE_(str)
40# define XTP_WIDE_(str) L##str
62# ifndef SAFE_DELETE
63# define SAFE_DELETE(ptr)
64# endif
66# undef SAFE_DELETE
67# define SAFE_DELETE(ptr) \
68 if (ptr) \
69 { \
70 delete ptr; \
71 ptr = NULL; \
72 }
94# ifndef SAFE_DELETE_AR
95# define SAFE_DELETE_AR(ptr)
96# endif
98# undef SAFE_DELETE_AR
99# define SAFE_DELETE_AR(ptr) \
100 if (ptr) \
101 { \
102 delete[] ptr; \
103 ptr = NULL; \
104 }
118# ifndef SAFE_RELEASE
119# define SAFE_RELEASE(comPointer)
120# endif
122# undef SAFE_RELEASE
123# define SAFE_RELEASE(comPointer) \
124 if (comPointer) \
125 { \
126 (comPointer)->Release(); \
127 (comPointer) = NULL; \
128 }
146# define SAFE_CALLPTR(classPointer, functionName)
148# undef SAFE_CALLPTR
149# define SAFE_CALLPTR(classPointer, functionName) \
150 if (classPointer) \
151 classPointer->functionName
173# define SAFE_DELETE_HICON(hIcon)
175# undef SAFE_DELETE_HICON
176# define SAFE_DELETE_HICON(hIcon) \
177 if (hIcon) \
178 { \
179 ::DestroyIcon(hIcon); \
180 hIcon = NULL; \
181 }
201# define SAFE_DELETE_OBJ(obj)
203# undef SAFE_DELETE_OBJ
204# define SAFE_DELETE_OBJ(obj) \
205 if (obj.GetSafeHandle()) \
206 { \
207 obj.DeleteObject(); \
208 }
212# define XTP_SAFE_GET1(_ptr1, _member, _defVal) (!!(_ptr1) ? (_ptr1->_member) : (_defVal))
213
214# define XTP_SAFE_GET2(_ptr1, _ptr2, _member, _defVal) \
215 ((!!(_ptr1) && !!(_ptr1->_ptr2)) ? (_ptr1->_ptr2->_member) : (_defVal))
216
217# define XTP_SAFE_GET3(_ptr1, _ptr2, _ptr3, _member, _defVal) \
218 ((!!(_ptr1) && !!(_ptr1->_ptr2) && !!(_ptr1->_ptr2->_ptr3)) \
219 ? (_ptr1->_ptr2->_ptr3->_member) \
220 : (_defVal))
221
222# define XTP_SAFE_GET4(_ptr1, _ptr2, _ptr3, _ptr4, _member, _defVal) \
223 ((!!(_ptr1) && !!(_ptr1->_ptr2) && !!(_ptr1->_ptr2->_ptr3) \
224 && !!(_ptr1->_ptr2->_ptr3->_ptr4)) \
225 ? (_ptr1->_ptr2->_ptr3->_ptr4->_member) \
226 : (_defVal))
227
228# define XTP_SAFE_GET5(_ptr1, _ptr2, _ptr3, _ptr4, _ptr5, _member, _defVal) \
229 ((!!(_ptr1) && !!(_ptr1->_ptr2) && !!(_ptr1->_ptr2->_ptr3) \
230 && !!(_ptr1->_ptr2->_ptr3->_ptr4) && !!(_ptr1->_ptr2->_ptr3->_ptr4->_ptr5)) \
231 ? (_ptr1->_ptr2->_ptr3->_ptr4->_ptr5->_member) \
232 : (_defVal))
233
234# define XTP_SAFE_SET1(_ptr1, _member, _Val) \
235 if (!!(_ptr1)) \
236 (_ptr1->_member) = (_Val);
237
238# define XTP_SAFE_SET2(_ptr1, _ptr2, _member, _Val) \
239 if (!!(_ptr1) && !!(_ptr1->_ptr2)) \
240 (_ptr1->_ptr2->_member) = (_Val);
241
242# define XTP_SAFE_SET3(_ptr1, _ptr2, _ptr3, _member, _Val) \
243 if (!!(_ptr1) && !!(_ptr1->_ptr2) && !!(_ptr1->_ptr2->_ptr3)) \
244 (_ptr1->_ptr2->_ptr3->_member) = (_Val);
245
246# define XTP_SAFE_CALL1(_ptr1, _member) \
247 if (!!(_ptr1)) \
248 (_ptr1->_member);
249
250# define XTP_SAFE_CALL2(_ptr1, _ptr2, _member) \
251 if (!!(_ptr1) && !!(_ptr1->_ptr2)) \
252 (_ptr1->_ptr2->_member);
253
254# define XTP_SAFE_CALL3(_ptr1, _ptr2, _ptr3, _member) \
255 if (!!(_ptr1) && !!(_ptr1->_ptr2) && !!(_ptr1->_ptr2->_ptr3)) \
256 (_ptr1->_ptr2->_ptr3->_member);
257
258# define XTP_SAFE_CALL4(_ptr1, _ptr2, _ptr3, _ptr4, _member) \
259 if (!!(_ptr1) && !!(_ptr1->_ptr2) && !!(_ptr1->_ptr2->_ptr3) \
260 && !!(_ptr1->_ptr2->_ptr3->_ptr4)) \
261 (_ptr1->_ptr2->_ptr3->_ptr4->_member);
262
263# define XTP_SAFE_CALL5(_ptr1, _ptr2, _ptr3, _ptr4, _ptr5, _member) \
264 if (!!(_ptr1) && !!(_ptr1->_ptr2) && !!(_ptr1->_ptr2->_ptr3) \
265 && !!(_ptr1->_ptr2->_ptr3->_ptr4) && !!(_ptr1->_ptr2->_ptr3->_ptr4->_ptr5)) \
266 (_ptr1->_ptr2->_ptr3->_ptr4->_ptr5->_member);
267
305# define XT_ASSERT_MSG(exp, msg)
307# undef XT_ASSERT_MSG
308# ifdef _DEBUG
309# ifndef _AFX_NO_DEBUG_CRT
310# define XT_ASSERT_MSG(exp, msg) \
311 { \
312 if (!(exp) \
313 && (_CrtDbgReport(_CRT_ASSERT, __FILE__, __LINE__, NULL, \
314 "\n-----------------------\n" msg \
315 "\n-----------------------"))) \
316 AfxDebugBreak(); \
317 }
318
319# else
320# define XT_ASSERT_MSG(exp, msg) \
321 (void)((exp) \
322 || (_assert("\n-----------------------\n" msg "\n-----------------------", \
323 __FILE__, __LINE__), \
324 0))
325# endif //_AFX_NO_DEBUG_CRT
326
327# else
328# define XT_ASSERT_MSG(exp, msg) ((void)0)
329# endif //_DEBUG
337AFX_INLINE void AFX_CDECL XTPDebugBreak()
338{
339 ::DebugBreak();
340}
341
351# ifdef _DEBUG
352# define XTP_ASSERT_CHECK(expr) \
353 ((expr) || !::AfxAssertFailedLine(THIS_FILE, __LINE__) || (XTPDebugBreak(), 0))
354# else
355# define XTP_ASSERT_CHECK(expr) (expr)
356# endif
357
359template<class T>
360AFX_INLINE T XTPAssertNotNull(T value)
361{
362 XTP_ASSERT_CHECK(NULL != value);
363 return value;
364}
375# ifdef _DEBUG
376# define XTP_ASSERT_CHECK_NOT_NULL(expr) XTPAssertNotNull(expr)
377# else
378# define XTP_ASSERT_CHECK_NOT_NULL(expr) (expr)
379# endif
380
382# ifdef _DEBUG
383# ifndef _AFX_NO_DEBUG_CRT
384# define XTP_ERROR_MSG(msg) \
385 { \
386 if ((_CrtDbgReport(_CRT_ASSERT, __FILE__, __LINE__, NULL, \
387 "\n-----------------------\n" msg \
388 "\n-----------------------"))) \
389 AfxDebugBreak(); \
390 }
391
392# else
393# define XTP_ERROR_MSG(msg) \
394 (void)((_assert("\n-----------------------\n" msg "\n-----------------------", \
395 __FILE__, __LINE__), \
396 0))
397# endif //_AFX_NO_DEBUG_CRT
398
399# else
400# define XTP_ERROR_MSG(msg) ((void)0)
401# endif //_DEBUG
402
403# ifndef XTP_STRINGIZE
404# define XTP_STRINGIZE_(what) # what
405# define XTP_STRINGIZE(what) XTP_STRINGIZE_(what)
406# endif
407
408# ifndef XTP_MESSAGE
409# define XTP_MESSAGE(msg) message(__FILE__ "(" XTP_STRINGIZE(__LINE__) "): " msg)
410# endif /*XTP_MESSAGE*/
411
412# define XTP_WARNING(msg) XTP_MESSAGE("warning : " msg)
413# ifdef _XTP_DEVMODE
414# define XTP_REVIEW(msg) XTP_WARNING("REVIEW - " msg)
415# define XTP_TODO(msg) XTP_WARNING("TODO - " msg)
416# define XTP_TEMP(msg) XTP_WARNING("TEMP - " msg)
417# define XTP_HACK(msg) XTP_WARNING("HACK - " msg)
418# define XTP_BUG(msg) XTP_WARNING("BUG - " msg)
419# else /*_XTP_DEVMODE*/
420# define XTP_REVIEW(msg)
421# define XTP_TODO(msg)
422# define XTP_TEMP(msg)
423# define XTP_HACK(msg)
424# define XTP_BUG(msg)
425# endif
427# if _MSC_VER >= 1400
428# define _XTP_DEPRECATE(_Message) __declspec(deprecated(_Message))
429# elif _MSC_VER >= 1300
430# define _XTP_DEPRECATE(_Message) __declspec(deprecated)
431# else
432# define _XTP_DEPRECATE(_Message)
433# endif
434
435# define _XTP_DEPRECATED_MSG(msg) \
436 _XTP_DEPRECATE( \
437 "Deprecated in v" XTP_STRINGIZE(_XTPLIB_VERSION_MAJOR) "." XTP_STRINGIZE(_XTPLIB_VERSION_MINOR) "." XTP_STRINGIZE( \
438 _XTPLIB_VERSION_REVISION) "." XTP_STRINGIZE(_XTPLIB_VERSION_BUILD) ": " msg)
439
440# define _XTP_DEPRECATED \
441 _XTP_DEPRECATE("Deprecated in v" XTP_STRINGIZE(_XTPLIB_VERSION_MAJOR) "." XTP_STRINGIZE( \
442 _XTPLIB_VERSION_MINOR) "." XTP_STRINGIZE(_XTPLIB_VERSION_REVISION) "." XTP_STRINGIZE(_XTPLIB_VERSION_BUILD))
443
444# define _XTP_DEPRECATED_IN_FAVOR_(what) \
445 _XTP_DEPRECATE( \
446 "Deprecated in v" XTP_STRINGIZE(_XTPLIB_VERSION_MAJOR) "." XTP_STRINGIZE(_XTPLIB_VERSION_MINOR) "." XTP_STRINGIZE( \
447 _XTPLIB_VERSION_REVISION) "." XTP_STRINGIZE(_XTPLIB_VERSION_BUILD) " and is " \
448 "subject to " \
449 "be removed " \
450 "in the " \
451 "future " \
452 "updates. " \
453 "Use " #what \
454 " instead.")
455
456# define _XTP_DEPRECATED_IN_FAVOR(newName) _XTP_DEPRECATED_IN_FAVOR_(# newName)
457
458# define _XTP_DEPRECATED_IN_FAVOR2(newName1, newName2) \
459 _XTP_DEPRECATED_IN_FAVOR_("'" #newName1 "' and/or '" #newName2 "'")
460
461# define _XTP_DEPRECATED_IN_FAVOR3(newName1, newName2, newName3) \
462 _XTP_DEPRECATED_IN_FAVOR_("'" #newName1 "' and/or '" #newName2 "' and/or '" #newName3 "'")
463
464# define _XTP_DEPRECATED_IN_FAVOR4(newName1, newName2, newName3, newName4) \
465 _XTP_DEPRECATED_IN_FAVOR_("'" #newName1 "' and/or '" #newName2 "' and/or '" #newName3 \
466 "' and/or '" #newName4 "'")
467
468# ifdef _UNICODE
469# ifndef UNICODE
470# define UNICODE
471# endif
472# endif
473
474# define __STR2__(x) # x
475# define __STR1__(x) __STR2__(x)
476# define __LOC__ __FILE__ "(" __STR1__(__LINE__) "): "
477
478// usage: #pragma message(__LOC__"Need to do 3D collision testing")
479
480# ifdef _AFXDLL
481# define SAFE_MANAGE_STATE(s) AFX_MANAGE_STATE(s)
482# else
483# define SAFE_MANAGE_STATE(s)
484# endif
485
486# ifndef AFX_INLINE
487# define AFX_INLINE inline
488# endif
489
490# ifndef CBRS_GRIPPER
491# define CBRS_GRIPPER 0x00400000L
492# endif
493
494# ifndef WS_EX_LAYOUTRTL
495# define WS_EX_LAYOUTRTL 0x00400000L
496# endif
497
498# ifndef WS_EX_NOACTIVATE
499# define WS_EX_NOACTIVATE 0x08000000L
500# endif
501
502# ifndef DT_WORD_ELLIPSIS
503# define DT_WORD_ELLIPSIS 0x00040000L
504# endif
505
506# ifndef WM_POPUPSYSTEMMENU
507# define WM_POPUPSYSTEMMENU 0x0313
508# endif
509
510# ifndef _countof
511// clang-format off
512// This definition should match VC6 definition exactly in order to avoid duplicated macro warning.
513#define _countof(array) (sizeof(array)/sizeof(array[0]))
514// clang-format on
515# endif
516
517# define XTP_POINT_FROM_LPARAM(lParam) CPoint((short)LOWORD(lParam), (short)HIWORD(lParam))
518
519# if (_MSC_VER <= 1200) && !defined(_WIN64)
520
521// IA64 Macros:
522# ifndef DWORD_PTR
523# define DWORD_PTR DWORD
524# endif
525
526# ifndef UINT_PTR
527# define UINT_PTR UINT
528# endif
529
530# ifndef INT_PTR
531# define INT_PTR int
532# endif
533
534# ifndef ULONG_PTR
535# define ULONG_PTR ULONG
536# endif
537
538# ifndef LONG_PTR
539# define LONG_PTR long
540# endif
541
542# ifndef SetWindowLongPtr
543# define SetWindowLongPtr SetWindowLong
544# endif
545
546# ifndef GetWindowLongPtr
547# define GetWindowLongPtr GetWindowLong
548# endif
549
550# ifndef GetClassLongPtr
551# define GetClassLongPtr GetClassLong
552# endif
553
554# ifndef SetClassLongPtr
555# define SetClassLongPtr SetClassLong
556# endif
557
558# ifndef GCLP_MENUNAME
559# define GCLP_MENUNAME (-8)
560# endif
561
562# ifndef GCLP_HBRBACKGROUND
563# define GCLP_HBRBACKGROUND (-10)
564# endif
565
566# ifndef GCLP_HCURSOR
567# define GCLP_HCURSOR (-12)
568# endif
569
570# ifndef GCLP_HICON
571# define GCLP_HICON (-14)
572# endif
573
574# ifndef GCLP_HMODULE
575# define GCLP_HMODULE (-16)
576# endif
577
578# ifndef GCLP_WNDPROC
579# define GCLP_WNDPROC (-24)
580# endif
581
582# ifndef GCLP_HICONSM
583# define GCLP_HICONSM (-34)
584# endif
585
586# ifndef GWLP_WNDPROC
587# define GWLP_WNDPROC (-4)
588# endif
589
590# ifndef GWLP_HINSTANCE
591# define GWLP_HINSTANCE (-6)
592# endif
593
594# ifndef GWLP_HWNDPARENT
595# define GWLP_HWNDPARENT (-8)
596# endif
597
598# ifndef GWLP_USERDATA
599# define GWLP_USERDATA (-21)
600# endif
601
602# ifndef GWLP_ID
603# define GWLP_ID (-12)
604# endif
605
606# endif
607
608// Atom name limitation per MSDN
609# define XTP_MAX_CLASSNAME 256
610
611# define ON_WM_NCHITTEST_EX() \
612 { WM_NCHITTEST, \
613 0, \
614 0, \
615 0, \
616 AfxSig_wp, \
617 (AFX_PMSG)(AFX_PMSGW)( \
618 static_cast<LRESULT (AFX_MSG_CALL CWnd::*)(CPoint)>(OnNcHitTest)) },
619
620# define CMDTARGET_RELEASE(x) \
621 if (x) \
622 { \
623 x->InternalRelease(); \
624 x = 0; \
625 }
626# define CMDTARGET_ADDREF(x) \
627 if (x) \
628 { \
629 x->InternalAddRef(); \
630 }
631# define SAFE_INVALIDATE(pWnd) \
632 if (pWnd && pWnd->GetSafeHwnd()) \
633 pWnd->Invalidate(FALSE);
634
635# define DISABLE_COPY_OPERATOR(theClass) \
636 private: \
637 theClass& operator=(const theClass&) \
638 { \
639 _ASSERTE(FALSE); \
640 return *this; \
641 }
642
643# define DISABLE_WNDCREATE() \
644 private: \
645 BOOL Create(LPCTSTR lpszClassName, LPCTSTR lpszWindowName, DWORD dwStyle, \
646 const RECT& rect, CWnd* pParentWnd, UINT nID, CCreateContext* pContext) \
647 { \
648 return CWnd::Create(lpszClassName, lpszWindowName, dwStyle, rect, pParentWnd, nID, \
649 pContext); \
650 }
651
652# define DISABLE_WNDCREATEEX() \
653 private: \
654 BOOL CreateEx(DWORD dwExStyle, LPCTSTR lpszClassName, LPCTSTR lpszWindowName, \
655 DWORD dwStyle, int x, int y, int nWidth, int nHeight, HWND hWndParent, \
656 HMENU nIDorHMenu, LPVOID lpParam = NULL) \
657 { \
658 return CWnd::CreateEx(dwExStyle, lpszClassName, lpszWindowName, dwStyle, x, y, nWidth, \
659 nHeight, hWndParent, nIDorHMenu, lpParam); \
660 } \
661 BOOL CreateEx(DWORD dwExStyle, LPCTSTR lpszClassName, LPCTSTR lpszWindowName, \
662 DWORD dwStyle, const RECT& rect, CWnd* pParentWnd, UINT nID, \
663 LPVOID lpParam = NULL) \
664 { \
665 return CWnd::CreateEx(dwExStyle, lpszClassName, lpszWindowName, dwStyle, rect, \
666 pParentWnd, nID, lpParam); \
667 }
668
669# define XTP_DEFAULT_DISPLAY_DPI 96
670
671# ifndef CLEARTYPE_QUALITY
672# define CLEARTYPE_QUALITY 5
673# endif
674
675# ifndef CLEARTYPE_NATURAL_QUALITY
676# define CLEARTYPE_NATURAL_QUALITY 6
677# endif
678
679# ifndef ANTIALIASED_QUALITY
680# define ANTIALIASED_QUALITY 4
681# endif
682
683# ifndef CLIP_DFA_DISABLE
684# define CLIP_DFA_DISABLE (4 << 4)
685# endif
686
687# ifndef MONO_FONT
688# define MONO_FONT 8
689# endif
690
691# ifndef CB_GETCOMBOBOXINFO
692# define CB_GETCOMBOBOXINFO 0x0164
693# endif
694
698# ifdef __XTPDLLEXPORTS_H__
699
700# if (_MSC_VER > 1200) && !defined(_WIN64)
701
702# ifdef SetWindowLongPtrA
703# undef SetWindowLongPtrA
704inline LONG_PTR SetWindowLongPtrA(HWND hWnd, int nIndex, LONG_PTR dwNewLong)
705{
706 return (::SetWindowLongA(hWnd, nIndex, LONG(dwNewLong)));
707}
708# endif
709
710# ifdef SetWindowLongPtrW
711# undef SetWindowLongPtrW
712inline LONG_PTR SetWindowLongPtrW(HWND hWnd, int nIndex, LONG_PTR dwNewLong)
713{
714 return (::SetWindowLongW(hWnd, nIndex, LONG(dwNewLong)));
715}
716# endif
717
718# ifdef GetWindowLongPtrA
719# undef GetWindowLongPtrA
720inline LONG_PTR GetWindowLongPtrA(HWND hWnd, int nIndex)
721{
722 return (::GetWindowLongA(hWnd, nIndex));
723}
724# endif
725
726# ifdef GetWindowLongPtrW
727# undef GetWindowLongPtrW
728inline LONG_PTR GetWindowLongPtrW(HWND hWnd, int nIndex)
729{
730 return (::GetWindowLongW(hWnd, nIndex));
731}
732# endif
733
734# ifdef SetClassLongPtrA
735# undef SetClassLongPtrA
736inline LONG_PTR SetClassLongPtrA(HWND hWnd, int nIndex, LONG_PTR dwNewLong)
737{
738 return static_cast<LONG_PTR>(::SetClassLongA(hWnd, nIndex, LONG(dwNewLong)));
739}
740# endif
741
742# ifdef SetClassLongPtrW
743# undef SetClassLongPtrW
744inline LONG_PTR SetClassLongPtrW(HWND hWnd, int nIndex, LONG_PTR dwNewLong)
745{
746 return static_cast<LONG_PTR>(::SetClassLongW(hWnd, nIndex, LONG(dwNewLong)));
747}
748# endif
749
750# ifdef GetClassLongPtrA
751# undef GetClassLongPtrA
752inline LONG_PTR GetClassLongPtrA(HWND hWnd, int nIndex)
753{
754 return static_cast<LONG_PTR>(::GetClassLongA(hWnd, nIndex));
755}
756# endif
757
758# ifdef GetClassLongPtrW
759# undef GetClassLongPtrW
760inline LONG_PTR GetClassLongPtrW(HWND hWnd, int nIndex)
761{
762 return static_cast<LONG_PTR>(::GetClassLongW(hWnd, nIndex));
763}
764# endif
765
766# endif
767
768// Note: afxData.cxBorder and afxData.cyBorder aren't used anymore
769# define CX_BORDER 1
770# define CY_BORDER 1
771
772# define _AfxGetDlgCtrlID(hWnd) ((UINT)(WORD)::GetDlgCtrlID(hWnd))
773
774# define AFX_WNDCOMMCTLS_REG 0x00010 // means all original Win95
775# define AFX_WNDCOMMCTL_BAR_REG 0x01000
776# define AFX_WNDCOMMCTL_USEREX_REG 0x10000
777# define AFX_WNDCOMMCTL_DATE_REG 0x20000
778
779# define AfxDeferRegisterClass(fClass) AfxEndDeferRegisterClass(fClass)
780
781# if (_MSC_VER <= 1100)
782extern BOOL AFXAPI AfxEndDeferRegisterClass(short fClass);
783# else
784BOOL AFXAPI AfxEndDeferRegisterClass(LONG fToRegister);
785# endif
786
787HWND AFXAPI AfxGetParentOwner(HWND hWnd);
788
789# endif // __XTPDLLEXPORTS_H__
793# if (WINVER >= 0x40A)
794DECLARE_HANDLE(XTP_HIMC);
795# else
796typedef DWORD XTP_HIMC;
797# endif
801# define XTP_BLOCKSTATEMENT(Type, Lhs, Rhs) \
802 if (Type Lhs = Rhs) \
803 { \
804 while (true) \
805 { \
806 ; \
807 } \
808 } \
809 else
810
811class CXTPBlockStatementBase
812{
813public:
814 operator int()
815 {
816 return 0;
817 }
818 operator int() const
819 {
820 return 0;
821 }
822};
823
824# ifdef GET_X_LPARAM
825# define XTP_GET_X_LPARAM(lParam) GET_X_LPARAM(lParam)
826# else
827# define XTP_GET_X_LPARAM(lParam) ((int)(short)LOWORD(lParam))
828# endif
829
830# ifdef GET_Y_LPARAM
831# define XTP_GET_Y_LPARAM(lParam) GET_Y_LPARAM(lParam)
832# else
833# define XTP_GET_Y_LPARAM(lParam) ((int)(short)HIWORD(lParam))
834# endif
835
836# ifdef COM_DECLSPEC_NOTHROW
837# define XTP_COM_DECLSPEC COM_DECLSPEC_NOTHROW
838# else
839# define XTP_COM_DECLSPEC
840# endif
841
844# define XTP_STDMETHODIMP_(ULONG) XTP_COM_DECLSPEC STDMETHODIMP_(ULONG)
845# define XTP_STDMETHODIMP XTP_COM_DECLSPEC STDMETHODIMP
846
853# define XTP_IMPLEMENT_IUNKNOWN(theClass, localClass) \
854 XTP_STDMETHODIMP_(ULONG) theClass::X##localClass::AddRef() \
855 { \
856 METHOD_PROLOGUE(theClass, localClass) \
857 return pThis->ExternalAddRef(); \
858 } \
859 XTP_STDMETHODIMP_(ULONG) theClass::X##localClass::Release() \
860 { \
861 METHOD_PROLOGUE(theClass, localClass) \
862 return pThis->ExternalRelease(); \
863 } \
864 XTP_STDMETHODIMP theClass::X##localClass::QueryInterface(REFIID riid, LPVOID* ppvObj) \
865 { \
866 METHOD_PROLOGUE(theClass, localClass) \
867 HRESULT hr = (HRESULT)pThis->ExternalQueryInterface(&riid, ppvObj); \
868 return hr; \
869 }
870
875# define XTP_DECLARE_IDISPATCH() \
876 virtual HRESULT STDMETHODCALLTYPE GetTypeInfoCount(UINT* pctinfo); \
877 virtual HRESULT STDMETHODCALLTYPE GetTypeInfo(UINT iTInfo, LCID lcid, \
878 ITypeInfo** ppTInfo); \
879 virtual HRESULT STDMETHODCALLTYPE GetIDsOfNames(REFIID riid, LPOLESTR* rgszNames, \
880 UINT cNames, LCID lcid, DISPID* rgDispId); \
881 virtual HRESULT STDMETHODCALLTYPE Invoke(DISPID dispIdMember, REFIID riid, LCID lcid, \
882 WORD wFlags, DISPPARAMS* pDispParams, \
883 VARIANT* pVarResult, EXCEPINFO* pExcepInfo, \
884 UINT* puArgErr);
885
892# define XTP_IMPLEMENT_IDISPATCH(theClass, localClass) \
893 XTP_STDMETHODIMP theClass::X##localClass::GetTypeInfoCount(UINT* pctinfo) \
894 { \
895 METHOD_PROLOGUE(theClass, localClass); \
896 return pThis->GetIDispatch(FALSE)->GetTypeInfoCount(pctinfo); \
897 } \
898 XTP_STDMETHODIMP theClass::X##localClass::GetTypeInfo(UINT iTInfo, LCID lcid, \
899 ITypeInfo** ppTInfo) \
900 { \
901 METHOD_PROLOGUE(theClass, localClass); \
902 return pThis->GetIDispatch(FALSE)->GetTypeInfo(iTInfo, lcid, ppTInfo); \
903 } \
904 XTP_STDMETHODIMP theClass::X##localClass::GetIDsOfNames(REFIID riid, LPOLESTR* rgszNames, \
905 UINT cNames, LCID lcid, \
906 DISPID* rgDispId) \
907 { \
908 METHOD_PROLOGUE(theClass, localClass); \
909 return pThis->GetIDispatch(FALSE)->GetIDsOfNames(riid, rgszNames, cNames, lcid, \
910 rgDispId); \
911 } \
912 XTP_STDMETHODIMP theClass::X##localClass::Invoke(DISPID dispIdMember, REFIID riid, \
913 LCID lcid, WORD wFlags, \
914 DISPPARAMS* pDispParams, \
915 VARIANT* pVarResult, \
916 EXCEPINFO* pExcepInfo, UINT* puArgErr) \
917 { \
918 METHOD_PROLOGUE(theClass, localClass); \
919 return pThis->GetIDispatch(FALSE)->Invoke(dispIdMember, riid, lcid, wFlags, \
920 pDispParams, pVarResult, pExcepInfo, \
921 puArgErr); \
922 }
923
925# if (1700 <= _MSC_VER)
926# define XTP_DECLARE_ENUM(enumName) enum enumName : int
927# else
928# define XTP_DECLARE_ENUM(enumName) enum enumName
929# endif
930# define XTP_FORWARD_ENUM(enumName) XTP_DECLARE_ENUM(enumName)
934# define XTP_CHARTOLOWERA(ch) static_cast<CHAR>(LOWORD(::CharLowerA((LPSTR)(INT_PTR)(ch))))
935# define XTP_CHARTOLOWERW(ch) static_cast<WCHAR>(LOWORD(::CharLowerW((LPWSTR)(INT_PTR)(ch))))
936# define XTP_CHARTOUPPERA(ch) static_cast<CHAR>(LOWORD(::CharUpperA((LPSTR)(INT_PTR)(ch))))
937# define XTP_CHARTOUPPERW(ch) static_cast<WCHAR>(LOWORD(::CharUpperW((LPWSTR)(INT_PTR)(ch))))
938
939# ifdef _UNICODE
940# define XTP_CHARTOCRT(ch) wint_t(ch)
941# else
942# define XTP_CHARTOCRT(ch) UINT(ch)
943# endif
944
951# define XTP_UNUSED(name) ((void)(&(name)))
952
957# define XTP_UNUSED_PARAMETER(name) ((void)(&(name)))
958
960# define XTP_VARIANT_TRUE VARIANT_BOOL(-1)
961# define XTP_VARIANT_FALSE VARIANT_BOOL(0)
962# ifndef IS_INTRESOURCE
963# define XTP_IS_INTRESOURCE(x) (((size_t)(x) >> 16) == 0)
964# else
965# define XTP_IS_INTRESOURCE(x) IS_INTRESOURCE(x)
966# endif
969# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
970
972# include "Common/Base/Diagnostic/XTPDisableAdvancedWarnings.h"
973
974# if defined(_M_CEE)
975# undef XTP_PARALLEL_DISABLE
976# define XTP_PARALLEL_DISABLE
977# if defined(XTP_USE_PPL) || defined(XTP_USE_OMP_)
978# undef XTP_USE_PPL
979# undef XTP_USE_OMP_
980# pragma XTP_WARNING( \
981 "Parallel computations are not compatible with C++/CLI and were disabled.")
982# endif
983# endif
984
985# ifndef XTP_PARALLEL_DISABLE
986
987# if !defined(XTP_USE_PPL) && !defined(XTP_USE_OMP)
988# if (1600 <= _MSC_VER)
989# define XTP_USE_PPL
990# elif (1400 <= _MSC_VER)
991# define XTP_USE_OMP
992# endif
993# endif
994
995# if defined(XTP_USE_PPL) && !(1600 <= _MSC_VER)
996# pragma XTP_WARNING( \
997 "At least Visual Studio 2010 is required in order to use Parallel Patterns Library (PPL). The XTP_USE_PPL options has been disabled.")
998# undef XTP_USE_PPL
999# endif
1000
1001# if defined(XTP_USE_OMP) && !(1400 <= _MSC_VER)
1002# pragma XTP_WARNING( \
1003 "At least Visual Studio 2005 is required in order to use OpenMP. The XTP_USE_OMP options has been disabled.")
1004# undef XTP_USE_OMP
1005# endif
1006
1007# ifdef XTP_USE_PPL
1008# include <ppl.h>
1009# define XTP_BEGIN_PARALLEL_FOR(type, var, from, to, step) \
1010 Concurrency::critical_section __xtpCriticalSection##__LINE__; \
1011 Concurrency::parallel_for(type(from), type(to), type(step), [&](type var) \
1012 {
1013# define XTP_END_PARALLEL_FOR \
1014 });
1015
1016# define XTP_PARALLEL_BEGIN_CRITICAL \
1017 { \
1018 Concurrency::critical_section::scoped_lock __xtpCriticalSectioLockn##__LINE__( \
1019 __xtpCriticalSection##__LINE__);
1020# define XTP_PARALLEL_END_CRITICAL }
1021# define XTP_PARALLEL_CONTINUE return
1022
1023# define XTP_BEGIN_PARALLEL_SECTIONS Concurrency::parallel_invoke([](){
1024# define XTP_PARALLEL_SECTION \
1025 } \
1026 , [&]() {
1027# define XTP_END_PARALLEL_SECTIONS \
1028 });
1029# elif defined(XTP_USE_OMP)
1030# define XTP_BEGIN_PARALLEL_FOR(type, var, from, to, step) __pragma(omp parallel for) \
1031 for (type var = (from); var < (to); var += (step)) \
1032 {
1033# define XTP_END_PARALLEL_FOR }
1034# define XTP_PARALLEL_BEGIN_CRITICAL \
1035 __pragma(omp critical) \
1036 {
1037# define XTP_PARALLEL_END_CRITICAL }
1038# define XTP_PARALLEL_CONTINUE continue
1039# define XTP_BEGIN_PARALLEL_SECTIONS \
1040 __pragma(omp parallel sections) \
1041 {
1042# define XTP_PARALLEL_SECTION __pragma(omp section)
1043# define XTP_END_PARALLEL_SECTIONS }
1044# else
1045# define XTP_PARALLEL_DISABLE
1046# endif
1047# endif
1048
1049# ifdef XTP_PARALLEL_DISABLE
1050# define XTP_BEGIN_PARALLEL_FOR(type, var, from, to, step) \
1051 for (type var = (from); var < (to); var += (step)) \
1052 {
1053# define XTP_END_PARALLEL_FOR }
1054# define XTP_PARALLEL_BEGIN_CRITICAL
1055# define XTP_PARALLEL_END_CRITICAL
1056# define XTP_PARALLEL_CONTINUE continue
1057# define XTP_BEGIN_PARALLEL_SECTIONS {
1058# define XTP_PARALLEL_SECTION
1059# define XTP_END_PARALLEL_SECTIONS }
1060# endif
1062# include "Common/Base/Diagnostic/XTPEnableAdvancedWarnings.h"
1063
1065#endif // #if !defined(__XTPMACROS_H__)
XTPDisableAdvancedWarnings.h
XTPDisableNoisyWarnings.h
XTPEnableAdvancedWarnings.h
XTPEnableNoisyWarnings.h
XTP_ASSERT_CHECK
#define XTP_ASSERT_CHECK(expr)
XTP_ASSERT_CHECK acts the same way as _ASSERTE but it also returns a boolean result from the evaluate...
Definition XTPMacros.h:355


Toolkit Pro: Member List

CXTPMarkupVisual Member List

This is the complete list of members for CXTPMarkupVisual, including all inherited members.

ApplyRenderTransform(CXTPMarkupDrawingContext *pContext) | CXTPMarkupVisual | protectedvirtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPMarkupVisual() | CXTPMarkupVisual |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAbsoluteVisualOffset() const | CXTPMarkupVisual | protected
GetBoundRect() const | CXTPMarkupVisual |
GetLayoutClip(CRect &rc) const | CXTPMarkupVisual | virtual
GetLogicalChild(int nIndex) const | CXTPMarkupVisual | virtual
GetLogicalChildrenCount() const | CXTPMarkupVisual | virtual
GetOpacity() const | CXTPMarkupVisual | protectedvirtual
GetRenderSize() const | CXTPMarkupVisual |
GetUpdateRect() const | CXTPMarkupVisual |
GetVisualChild(int nIndex) const | CXTPMarkupVisual | virtual
GetVisualChildrenCount() const | CXTPMarkupVisual | virtual
GetVisualOffset() const | CXTPMarkupVisual |
GetVisualParent() const | CXTPMarkupVisual |
InputHitTest(CPoint point) const | CXTPMarkupVisual |
InputHitTestOverride(CPoint point) const | CXTPMarkupVisual | protectedvirtual
IsVisible() const | CXTPMarkupVisual | protectedvirtual
m_ptVisualOffset | CXTPMarkupVisual | protected
m_rcBoundRect | CXTPMarkupVisual | protected
m_rcPrevUpdateRect | CXTPMarkupVisual | protected
m_rcUpdateRect | CXTPMarkupVisual | protected
m_szRenderSize | CXTPMarkupVisual | protected
OnRender(CXTPMarkupDrawingContext *drawingContext) | CXTPMarkupVisual | protectedvirtual
OnRenderFocusVisual(CXTPMarkupDrawingContext *drawingContext) | CXTPMarkupVisual | protectedvirtual
PtInRectTransform(const RECT &rect, const POINT &point) const | CXTPMarkupVisual | protected
Render(CXTPMarkupDrawingContext *drawingContext) | CXTPMarkupVisual |
RenderClipped(CXTPMarkupDrawingContext *drawingContext) | CXTPMarkupVisual | protectedvirtual
RestoreRenderTransform(CXTPMarkupDrawingContext *pContext, TransformationMatrices &matrices) | CXTPMarkupVisual | protectedvirtual
~CXTPMarkupVisual() | CXTPMarkupVisual | virtual


Toolkit Pro: Member List

CXTPReBar Member List

This is the complete list of members for CXTPReBar, including all inherited members.

AddToolBar(CXTPToolBar *pToolBar, DWORD dwStyle=RBBS_GRIPPERALWAYS) | CXTPReBar |
CXTPReBar() | CXTPReBar |
DeleteToolBar(CXTPToolBar *pToolBar) | CXTPReBar |
FindBand(CXTPToolBar *pToolBar) | CXTPReBar |
GetToolBar(int nBand) | CXTPReBar |
LoadState(LPCTSTR lpszProfileName) | CXTPReBar |
SaveState(LPCTSTR lpszProfileName) | CXTPReBar |
SetBandInfo(UINT uBand, REBARBANDINFO *prbbi) | CXTPReBar |
~CXTPReBar() | CXTPReBar | virtual


Toolkit Pro: Member List

CXTPChartPieDeviceCommand Member List

This is the complete list of members for CXTPChartPieDeviceCommand, including all inherited members.

AddChildCommand(CXTPChartDeviceCommand *pCommand) | CXTPChartDeviceCommand |
AfterExecute(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
ApplySeriesStyle(CXTPChartSeriesStyle *pStyle) | CXTPChartDeviceCommand | virtual
BeforeExecute(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
BindView(CXTPChartElementView *pView) | CXTPChartDeviceCommand |
Commit() | CXTPChartDeviceCommand |
CXTPChartDeviceCommand() | CXTPChartDeviceCommand |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartPieDeviceCommand(const CXTPPoint3d &ptCenter, double dMajorSemiAxis, double dMinorSemiAxis, double dStartAngle, double dSweepAngle, double dDepth, double nHolePercent) | CXTPChartPieDeviceCommand | protected
CXTPObservable() | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | protected
Execute(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
ExecuteOverride(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
GetBoundView() const | CXTPChartDeviceCommand |
GetChildCommand(int nIndex) const | CXTPChartDeviceCommand |
GetChildCommandCount() const | CXTPChartDeviceCommand |
GetCurrentDC() const | CXTPChartDeviceCommand |
GetPassNumber() const | CXTPChartDeviceCommand |
HitTest(CPoint point, CXTPChartElement *pParent) const | CXTPChartDeviceCommand | virtual
Is3D() const | CXTPChartObject |
IsCommitted() const | CXTPChartDeviceCommand |
IsEnabled() const | CXTPChartDeviceCommand | virtual
m_arrChildren | CXTPChartDeviceCommand | protected
m_bDoughnut | CXTPChartPieDeviceCommandImpl | protected
m_dCorrectedDepth | CXTPChartPieDeviceCommandImpl | protected
m_dDepth | CXTPChartPieDeviceCommandImpl | protected
m_dFacetSize | CXTPChartPieDeviceCommandImpl | protected
m_dHolePercent | CXTPChartPieDeviceCommandImpl | protected
m_dInnerMajorSemiAxis | CXTPChartPieDeviceCommandImpl | protected
m_dInnerMinorSemiAxis | CXTPChartPieDeviceCommandImpl | protected
m_dInnerRadius | CXTPChartPieDeviceCommandImpl | protected
m_dMajorSemiAxis | CXTPChartPieDeviceCommandImpl | protected
m_dMinorSemiAxis | CXTPChartPieDeviceCommandImpl | protected
m_dRadius | CXTPChartPieDeviceCommandImpl | protected
m_dStartAngle | CXTPChartPieDeviceCommandImpl | protected
m_dSweepAngle | CXTPChartPieDeviceCommandImpl | protected
m_ptCenter | CXTPChartPieDeviceCommandImpl | protected
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Prepare(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
PrepareOverride(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
SetEnabled(BOOL bEnabled=TRUE) | CXTPChartDeviceCommand |
Subscribe(CXTPChartDeviceCommandEvents *pObserver, CXTPSubscriptionList< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > *pSubcriptionList=NULL) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > |
Unsubscribe(CXTPChartDeviceCommandEvents *pObserver) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > |
~CXTPChartDeviceCommand() | CXTPChartDeviceCommand | virtual
~CXTPChartPieDeviceCommandImpl() | CXTPChartPieDeviceCommandImpl | protectedvirtual
~CXTPObservable() | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | protected


Toolkit Pro: XTPPreviewView.h Source File

  • Source
  • CommandBars
XTPPreviewView.h
Go to the documentation of this file.
1
23#if !defined(__XTPPREVIEWVIEW_H__)
24# define __XTPPREVIEWVIEW_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
34// CXTPPreviewView view
35
36# define XTP_ZOOM_WHOLEPAGE 0
37# define XTP_ZOOM_PAGEWIDTH 1
44class _XTP_EXT_CLASS CXTPPreviewView : public CPreviewView
45{
47 DECLARE_DYNCREATE(CXTPPreviewView)
49protected:
57 CXTPPreviewView(int nPageCount = 9);
58
63 virtual ~CXTPPreviewView();
64
65public:
75 void SetZoomState(UINT nNewState, UINT nPage, CPoint point);
76
83 int GetZoomState() const;
84
91 CXTPToolBar* GetCommandBar();
92
94private:
95 CXTPControl* FindToolbarButton(UINT nCommandID);
96 virtual void PositionPage(UINT nPage);
97 void SetScaledSize(UINT nPage);
98 void DoZoom(UINT nPage, CPoint point);
99 CSize CalcPageDisplaySize();
100 void SetupScrollbar();
101 void ZoomIn(UINT nPage, CPoint point);
102
103 virtual void OnActivateView(BOOL bActivate, CView* pActivateView, CView* pDeactiveView);
104
111 void SetNumPreviewPages(int nAcross, int nDown);
112
113protected:
114# ifdef _DEBUG
115 virtual void AssertValid() const;
116 virtual void Dump(CDumpContext& dc) const;
117# endif
118
121protected:
124 //{{AFX_VIRTUAL(CXTPPreviewView)
125public:
126 void RecalLayout();
127 virtual BOOL PreCreateWindow(CREATESTRUCT& cs);
128 //}}AFX_VIRTUAL
129
130 //{{AFX_MSG(CXTPPreviewView)
131 afx_msg int OnCreate(LPCREATESTRUCT lpCreateStruct);
132 afx_msg void OnWindowPosChanged(WINDOWPOS FAR* lpwndpos);
133 afx_msg void OnPaint();
134 afx_msg BOOL OnEraseBkgnd(CDC*);
135 afx_msg void OnNumPageChange();
136 afx_msg void OnZoomIn();
137 afx_msg void OnZoomOut();
138 afx_msg void OnUpdateNumPageChange(CCmdUI* pCmdUI);
139 afx_msg void OnUpdateZoomIn(CCmdUI* pCmdUI);
140 afx_msg void OnUpdateZoomOut(CCmdUI* pCmdUI);
141 afx_msg void OnLButtonDown(UINT nFlags, CPoint point);
142 afx_msg BOOL OnSetCursor(CWnd* pWnd, UINT nHitTest, UINT message);
143 afx_msg void OnPreviewPages();
144 afx_msg void OnVScroll(UINT nSBCode, UINT nPos, CScrollBar* pScrollBar);
145 afx_msg void OnSize(UINT nType, int cx, int cy);
146 afx_msg void OnGotoPageSetFocus(NMHDR* pNMHDR, LRESULT* pRes);
147 afx_msg void OnGotoPageKillFocus(NMHDR* pNMHDR, LRESULT* pRes);
148 afx_msg void OnUpdateGotoPage(CCmdUI* pCmdUI);
149 afx_msg void OnZoomCombo(NMHDR* pNMHDR, LRESULT* pRes);
150 afx_msg void OnOnePage();
151 afx_msg void OnTwoPage(NMHDR* pNMHDR, LRESULT* pRes);
152 //}}AFX_MSG
153
154 DECLARE_MESSAGE_MAP()
155
156
158protected:
159 PAGE_INFO* m_pPageInfo2;
162 CXTPToolBar* m_pCommandBar;
163 int m_cxPixelsPerInch;
164 int m_cyPixelsPerInch;
166 // these variables are used in the page layout algorithm
167
168 int m_Across;
169 int m_Down;
170 CPoint m_PageOffset;
172 COLORREF m_clrBackColor;
173};
174
175AFX_INLINE CXTPToolBar* CXTPPreviewView::GetCommandBar()
176{
177 return m_pCommandBar;
178}
179
181# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
182#endif // !defined(__XTPPREVIEWVIEW_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPControl
CXTPControl is a CXTPCmdTarget derived class.
Definition XTPControl.h:841
CXTPPreviewView
CXTPPreviewView is a CPreviewView derived class that represents a print preview window with a themed ...
Definition XTPPreviewView.h:45
CXTPPreviewView::~CXTPPreviewView
virtual ~CXTPPreviewView()
Destroys a CXTPPreviewView object, handles cleanup and deallocation.
CXTPPreviewView::GetZoomState
int GetZoomState() const
Returns the current zoom state of the preview window.
CXTPPreviewView::CXTPPreviewView
CXTPPreviewView(int nPageCount=9)
Constructs a CXTPPreviewView object.
CXTPPreviewView::SetZoomState
void SetZoomState(UINT nNewState, UINT nPage, CPoint point)
Sets the zoom state of the preview window.
CXTPToolBar
CXTPToolBar is a CXTPCommandBar derived class.
Definition XTPToolBar.h:42


Toolkit Pro: Member List

CXTPExcludedMemberPadding< Type > Member List

This is the complete list of members for CXTPExcludedMemberPadding< Type >, including all inherited members.


Toolkit Pro: XTPMarkupDeviceContext.h Source File

  • Source
  • Markup
  • DeviceContext
XTPMarkupDeviceContext.h
Go to the documentation of this file.
1
23#if !defined(__XTPMARKUPDEVICECONTEXT_H__)
24# define __XTPMARKUPDEVICECONTEXT_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33namespace Gdiplus
34{
35class GpGraphics;
36class GpBrush;
37class GpFont;
38class GpPen;
39class GpStringFormat;
40class GpBitmap;
41} // namespace Gdiplus
42
43class CXTPMarkupStrokeStyle;
44class CXTPMarkupBrush;
45class CXTPMarkupPathData;
46class CXTPMarkupFont;
47class CXTPMarkupTransformationMatrix;
48class CXTPMarkupDrawingContext;
49class CXTPMarkupDeviceContext;
50class CXTPImageManagerIcon;
51class CXTPMarkupDeviceDependentImage;
52struct IXTPMarkupDeviceDependentImageSite;
53
54class _XTP_EXT_CLASS CXTPMarkupDedicatedDC
55{
56public:
57 CXTPMarkupDedicatedDC(CXTPMarkupDeviceContext* pDC, const RECT& rect);
58 virtual ~CXTPMarkupDedicatedDC();
59
60 virtual HDC GetDC() const;
61 virtual void Commit();
62
63 const CRect& GetRect() const;
64 const CSize& GetCorrectionOffset() const;
65
66protected:
67 void ReleaseDC();
68
69 CXTPMarkupDeviceContext* m_pDC;
70 mutable HDC m_hDC;
71 CRect m_rect;
72 CSize m_szCorrectionOffset;
73};
74
75AFX_INLINE const CRect& CXTPMarkupDedicatedDC::GetRect() const
76{
77 return m_rect;
78}
79
80AFX_INLINE const CSize& CXTPMarkupDedicatedDC::GetCorrectionOffset() const
81{
82 return m_szCorrectionOffset;
83}
84
85struct XTPMarkupFontMetrics
86{
87 int nAscent;
88 int nDescent;
89};
90
91class _XTP_EXT_CLASS CXTPMarkupDeviceContext : public CObject
92{
93 DECLARE_DYNAMIC(CXTPMarkupDeviceContext);
94
95public:
96 CXTPMarkupDeviceContext(HDC hDC, HDC hAttribDC);
97 virtual ~CXTPMarkupDeviceContext();
98
99public:
100 virtual CXTPMarkupTransformationMatrix* GetTransformationMatrix() const;
101 virtual void SetTransformationMatrix(CXTPMarkupTransformationMatrix* pMatrix);
102
103 virtual void OffsetViewport(const POINT& ptViewortOrg);
104 virtual XTPMarkupSmoothingMode SetSmoothingMode(XTPMarkupSmoothingMode smoothingMode,
105 BOOL bUseTextSmoothing);
106
107 POINT TranslatePoint(const POINT& ptVisualOffset) const;
108
109 virtual CXTPMarkupDedicatedDC* GetDedicatedDC(const RECT& rect);
110 HDC GetSafeHdc() const;
111
112 virtual CXTPMarkupDeviceDependentImage*
113 CreateDeviceDependentImage(IXTPMarkupDeviceDependentImageSite* pSite) const;
114
115 double GetOpacity() const;
116 void SetOpacity(double dOpacity);
117
118 virtual void Ellipse(CRect rc, CXTPMarkupStrokeStyle* pStrokeStyle,
119 CXTPMarkupBrush* pFillBrush);
120 virtual void DrawRectangle(CRect rc, CXTPMarkupBrush* pBrush, CXTPMarkupThickness* pThickness);
121 virtual void FillRectangle(CRect rc, CXTPMarkupBrush* pBrush);
122 virtual void DrawLine(int x1, int y1, int x2, int y2, CXTPMarkupStrokeStyle* pStrokeStyle);
123 virtual void Polyline(const POINT* points, int nCount, CXTPMarkupStrokeStyle* pStrokeStyle);
124 virtual void Polyline(const void* points, int nCount, CXTPMarkupStrokeStyle* pStrokeStyle);
125 virtual void Polygon(const POINT* points, int nCount, CXTPMarkupStrokeStyle* pStrokeStyle,
126 CXTPMarkupBrush* pFillBrush);
127 virtual void Polygon(const void* points, int nCount, CXTPMarkupStrokeStyle* pStrokeStyle,
128 CXTPMarkupBrush* pFillBrush);
129 virtual void DrawPath(CXTPMarkupPathData* pData, CXTPMarkupStrokeStyle* pStrokeStyle,
130 CXTPMarkupBrush* pFillBrush);
131
132 virtual void DrawImage(CXTPImageManagerIcon* pIcon, CRect rc);
133 virtual void DrawImage(CXTPMarkupDeviceDependentImage* pImage, CRect rc);
134
135 virtual void FillRoundRectangle(CRect rc, CXTPMarkupBrush* pBrush, double* pCornerRadius);
136 virtual void DrawRoundRectangle(CRect rc, CXTPMarkupBrush* pBrush,
137 CXTPMarkupThickness* pThickness, double* pCornerRadius);
138
139 virtual void DrawString(LPCWSTR lpszText, UINT nCount, LPCRECT lpRect);
140 virtual SIZE MeasureString(LPCWSTR lpszText, int nCount) const;
141 virtual void MeasureString(LPCWSTR lpszText, int nCount, CXTPSizeF& size) const;
142
143 virtual void SetTextColor(CXTPMarkupBrush* pBrush);
144 virtual void SetTextFont(CXTPMarkupFont* pFont);
145 virtual BOOL GetFontMetrics(CXTPMarkupFont* pFont, XTPMarkupFontMetrics* pMetrics);
146
147 virtual void IntersectClipRect(const RECT& rcLayoutClip);
148 virtual void GetClipBox(LPRECT lpRect);
149
150 virtual HRGN SaveClipRegion();
151 virtual void RestoreClipRegion(HRGN hRgn);
152
153 virtual HDC GetDC();
154 virtual void ReleaseDC(HDC hDC);
155 virtual void Flush();
156
157protected:
158 BOOL IsSolidBrush(CXTPMarkupBrush* pBrush) const;
159 BOOL IsLinearGradientBrush(CXTPMarkupBrush* pBrush) const;
160 DWORD SetARGBOpacity(DWORD color) const;
161 COLORREF SetCOLORREFOpacity(COLORREF color) const;
162
163private:
164 CSize ComputeDeltas(int& x, LPCWSTR lpszString, UINT& nCount, BOOL bTabbed, UINT nTabStops,
165 LPINT lpnTabStops, int nTabOrigin, LPWSTR lpszOutputString, int* pnDxWidths,
166 int& nRightFixup) const;
167
168 int ComputeNextTab(int x, UINT nTabStops, LPINT lpnTabStops, int nTabOrigin,
169 int nTabWidth) const;
170
171 HFONT SelectFontObject(HFONT hFont);
172 void CreatePen(CPen& pen, CXTPMarkupStrokeStyle* pStrokeStyle);
173
174protected:
175 struct GRADIENTSTOP
176 {
177 RGBQUAD clr;
178 double dOffset;
179 double dDiff;
180 int nIndex;
181 };
182 static int AFX_CDECL _GradientStopCompare(const void* arg1, const void* arg2);
183
184protected:
185 HDC m_hDC;
186 HDC m_hAttribDC;
187 SIZE m_sizeWinExt;
188 SIZE m_sizeVpExt;
189 double m_dOpacity;
190
191 HFONT m_hOldFont;
192 XTPMarkupSmoothingMode m_smoothingMode;
193};
194
195AFX_INLINE HDC CXTPMarkupDeviceContext::GetSafeHdc() const
196{
197 return m_hDC;
198}
199
200AFX_INLINE double CXTPMarkupDeviceContext::GetOpacity() const
201{
202 return m_dOpacity;
203}
204
205AFX_INLINE void CXTPMarkupDeviceContext::SetOpacity(double dOpacity)
206{
207 _ASSERTE(0. <= dOpacity && dOpacity <= 1.);
208 m_dOpacity = dOpacity;
209}
210
211# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
213#endif // !defined(__XTPMARKUPDEVICECONTEXT_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPMarkupSmoothingMode
XTPMarkupSmoothingMode
Defines markup smoothing mode.
Definition XTPMarkupContext.h:69
CXTPImageManagerIcon
Icons holder class.
Definition XTPImageManager.h:622
CXTPMarkupDeviceDependentImage
Implements an abstract device dependent image.
Definition XTPMarkupDeviceDependentImage.h:73
CXTPMarkupThickness
The CXTPMarkupThickness class describes the thickness of the left, top, right, and bottom sides of a ...
Definition XTPMarkupThickness.h:42
CXTPMarkupTransformationMatrix
An abstract class for device context transformation matrix.
Definition XTPMarkupTransformationMatrix.h:40
CXTPSizeT
This class incapsulates size data.
Definition XTPSize.h:40
IXTPMarkupDeviceDependentImageSite
Describes an image site interface.
Definition XTPMarkupDeviceDependentImage.h:40


Toolkit Pro: XTPChartAxisConstantLines.h Source File

  • Source
  • Chart
  • Diagram
  • Axis
XTPChartAxisConstantLines.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTAXISCONSTANTLINES_H__)
24# define __XTPCHARTAXISCONSTANTLINES_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartAxis;
34class CXTPChartLineStyle;
35class CXTPChartLineStyle;
36
43class _XTP_EXT_CLASS CXTPChartAxisConstantLine
44 : public CXTPChartTextElement
45 , public CXTPChartLegendItemView
46{
48 DECLARE_DYNCREATE(CXTPChartAxisConstantLine)
50public:
55 CXTPChartAxisConstantLine();
56
61 virtual ~CXTPChartAxisConstantLine();
62
63public:
71 void SetVisible(BOOL bVisible);
72
79 BOOL IsVisible() const;
80
88 void SetLegendVisible(BOOL bVisible);
89
96 BOOL IsLegendVisible() const;
97
104 void SetText(const CXTPChartString& lpszTitle);
105
112 CXTPChartString GetText() const;
113
120 void SetTextColor(const CXTPChartColor& clrTextColor);
127 CXTPChartColor GetTextColor() const;
128
135 CXTPChartColor GetActualTextColor() const;
136
143 CXTPChartFont* GetFont() const;
144
151 void SetFont(CXTPChartFont* pFont);
152
160 void SetAlignment(XTPChartStringAlignment nAlignment);
161
168 XTPChartStringAlignment GetAlignment() const;
169
178 void SetAntialiasing(BOOL bAntialiasing);
179
187 BOOL GetAntialiasing() const;
188
195 CXTPChartString GetLegendName() const;
196
203 void SetLegendName(const CXTPChartString& strName);
204
211 CXTPChartLineStyle* GetLineStyle() const;
212
219 CXTPChartString GetAxisValue() const;
220
227 double GetAxisValueInternal() const;
228
235 void SetAxisValue(LPCTSTR lpszValue);
236
243 void SetAxisValue(double dValue);
244
251 CXTPChartColor GetActualColor() const;
252
253 BOOL IsShowBehind() const;
254 void SetShowBehind(BOOL bShowBehind);
255
256 void ShowTextBelow(BOOL bShowTextBelow);
257 BOOL IsTextBelow() const;
258
259 CXTPChartColor GetColor() const;
260 void SetColor(const CXTPChartColor& color);
261
262public:
263 void DoPropExchange(CXTPPropExchange* pPX);
264
265protected:
278 virtual CXTPChartDeviceCommand* CreateLegendDeviceCommand(CXTPChartDeviceContext* pDC,
279 CRect rcBounds);
280
281# ifdef _XTP_ACTIVEX
283 DECLARE_DISPATCH_MAP()
284 DECLARE_INTERFACE_MAP()
285 DECLARE_OLETYPELIB_EX(CXTPChartAxisConstantLine);
286
287 BSTR OleGetText();
288 void OleSetText(LPCTSTR lpszText);
289 VARIANT OleGetAxisValue();
290 void OleSetAxisValue(const VARIANT& var);
291
292 BOOL OleGetLegendVisible();
293 void OleSetLegendVisible(BOOL bValue);
294 BOOL OleGetVisible();
295 void OleSetVisible(BOOL bValue);
296 BOOL OleGetShowTextBelow();
297 void OleSetShowTextBelow(BOOL bValue);
298 BOOL OleGetAlignment();
299 void OleSetAlignment(int nValue);
300 LPDISPATCH OleGetLineStyle();
301 LPDISPATCH OleGetFont();
302
303 OLE_COLOR OleGetColor();
304 OLE_COLOR OleGetTextColor();
305 void OleSetColor(OLE_COLOR clr);
306 void OleSetTextColor(OLE_COLOR clr);
307
309# endif
310
311protected:
312 BOOL m_bLegendVisible;
313 BOOL m_bVisible;
315 CXTPChartString m_strText;
316 CXTPChartString m_strLegendName;
317 CXTPChartString m_strAxisValue;
318 double m_dAxisValue;
319
320 CXTPChartColor m_clrTextColor;
321 CXTPChartColor m_clrColor;
323 XTPChartStringAlignment m_nAlignment;
325 BOOL m_bAntialiasing;
326 CXTPChartFont* m_pFont;
327 BOOL m_bShowTextBelow;
328 BOOL m_bShowBehind;
330 CXTPChartLineStyle* m_pLineStyle;
332 friend class CXTPChartAxisConstantLines;
333};
334
339class _XTP_EXT_CLASS CXTPChartAxisConstantLines : public CXTPChartElementCollection
340{
341public:
347 CXTPChartAxisConstantLines(CXTPChartAxis* pAxis);
348
353 virtual ~CXTPChartAxisConstantLines();
354
355public:
362 CXTPChartAxisConstantLine* Add(CXTPChartAxisConstantLine* pConstantLine);
363
372 CXTPChartAxisConstantLine* GetAt(int nIndex) const;
373
374public:
375 void DoPropExchange(CXTPPropExchange* pPX);
376
377public:
378# ifdef _XTP_ACTIVEX
380 DECLARE_DISPATCH_MAP()
381 DECLARE_INTERFACE_MAP()
382
383 DECLARE_OLETYPELIB_EX(CXTPChartAxisConstantLines);
384
385 afx_msg long OleGetItemCount();
386 afx_msg LPDISPATCH OleGetItem(long nIndex);
387 DECLARE_ENUM_VARIANT(CXTPChartAxisConstantLines)
388
389 afx_msg LPDISPATCH OleAdd(LPCWSTR lpszTitle);
391# endif
392
393protected:
394};
395
396AFX_INLINE CXTPChartAxisConstantLine* CXTPChartAxisConstantLines::GetAt(int nIndex) const
397{
398 return nIndex >= 0 && nIndex < m_arrElements.GetSize()
399 ? (CXTPChartAxisConstantLine*)m_arrElements.GetAt(nIndex)
400 : NULL;
401}
402
403AFX_INLINE CXTPChartString CXTPChartAxisConstantLine::GetText() const
404{
405 return m_strText;
406}
407AFX_INLINE CXTPChartFont* CXTPChartAxisConstantLine::GetFont() const
408{
409 return m_pFont;
410}
411AFX_INLINE XTPChartStringAlignment CXTPChartAxisConstantLine::GetAlignment() const
412{
413 return m_nAlignment;
414}
415
416AFX_INLINE void CXTPChartAxisConstantLine::SetAntialiasing(BOOL bAntialiasing)
417{
418 m_bAntialiasing = bAntialiasing;
419 OnChartChanged();
420}
421AFX_INLINE BOOL CXTPChartAxisConstantLine::GetAntialiasing() const
422{
423 return m_bAntialiasing;
424}
425AFX_INLINE void CXTPChartAxisConstantLine::SetVisible(BOOL bVisible)
426{
427 m_bVisible = bVisible;
428 OnChartChanged();
429}
430AFX_INLINE BOOL CXTPChartAxisConstantLine::IsVisible() const
431{
432 return m_bVisible;
433}
434AFX_INLINE CXTPChartLineStyle* CXTPChartAxisConstantLine::GetLineStyle() const
435{
436 return m_pLineStyle;
437}
438AFX_INLINE CXTPChartString CXTPChartAxisConstantLine::GetAxisValue() const
439{
440 return m_strAxisValue;
441}
442AFX_INLINE double CXTPChartAxisConstantLine::GetAxisValueInternal() const
443{
444 return m_dAxisValue;
445}
446AFX_INLINE void CXTPChartAxisConstantLine::SetAxisValue(LPCTSTR lpszValue)
447{
448 m_strAxisValue = lpszValue;
449 OnChartChanged();
450}
451AFX_INLINE void CXTPChartAxisConstantLine::SetAxisValue(double dValue)
452{
453 m_dAxisValue = dValue;
454 m_strAxisValue.Empty();
455 OnChartChanged();
456}
457AFX_INLINE BOOL CXTPChartAxisConstantLine::IsLegendVisible() const
458{
459 return m_bLegendVisible;
460}
461AFX_INLINE void CXTPChartAxisConstantLine::SetLegendVisible(BOOL bLegendVisible)
462{
463 m_bLegendVisible = bLegendVisible;
464 OnChartChanged();
465}
466AFX_INLINE void CXTPChartAxisConstantLine::ShowTextBelow(BOOL bShowTextBelow)
467{
468 m_bShowTextBelow = bShowTextBelow;
469 OnChartChanged();
470}
471AFX_INLINE BOOL CXTPChartAxisConstantLine::IsTextBelow() const
472{
473 return m_bShowTextBelow;
474}
475AFX_INLINE CXTPChartColor CXTPChartAxisConstantLine::GetColor() const
476{
477 return m_clrColor;
478}
479AFX_INLINE void CXTPChartAxisConstantLine::SetColor(const CXTPChartColor& color)
480{
481 m_clrColor = color;
482 OnChartChanged();
483}
484AFX_INLINE void CXTPChartAxisConstantLine::SetLegendName(const CXTPChartString& strName)
485{
486 m_strLegendName = strName;
487 OnChartChanged();
488}
489AFX_INLINE BOOL CXTPChartAxisConstantLine::IsShowBehind() const
490{
491 return m_bShowBehind;
492}
493AFX_INLINE void CXTPChartAxisConstantLine::SetShowBehind(BOOL bShowBehind)
494{
495 m_bShowBehind = bShowBehind;
496 OnChartChanged();
497}
499# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
500#endif //#if !defined(__XTPCHARTAXISCONSTANTLINES_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartAxisConstantLine
CXTPChartAxisConstantLine is a hybrid object derived from CXTPChartTextElement and CXTPChartLegendIte...
Definition XTPChartAxisConstantLines.h:46
CXTPChartAxisConstantLine::SetAlignment
void SetAlignment(XTPChartStringAlignment nAlignment)
Use this function to set the text alignment of the constant line legend item text.
CXTPChartAxisConstantLine::m_pFont
CXTPChartFont * m_pFont
The font used for the text of the constant line legend item.
Definition XTPChartAxisConstantLines.h:326
CXTPChartAxisConstantLine::DoPropExchange
void DoPropExchange(CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
CXTPChartAxisConstantLine::GetActualTextColor
CXTPChartColor GetActualTextColor() const
Use this function to get the actual text color of the constant line legend item.
CXTPChartAxisConstantLine::m_bShowTextBelow
BOOL m_bShowTextBelow
TRUE if the text is below, FALSE if not.
Definition XTPChartAxisConstantLines.h:327
CXTPChartAxisConstantLine::GetTextColor
CXTPChartColor GetTextColor() const
Use this function to get the text color of the constant line legend item.
CXTPChartAxisConstantLine::SetVisible
void SetVisible(BOOL bVisible)
Call this function to set the visibility of the axis constant line.
Definition XTPChartAxisConstantLines.h:425
CXTPChartAxisConstantLine::m_strText
CXTPChartString m_strText
The text of the constant line legend item.
Definition XTPChartAxisConstantLines.h:315
CXTPChartAxisConstantLine::GetAlignment
XTPChartStringAlignment GetAlignment() const
Call this function to get the alignment of the constant line legend item text.
Definition XTPChartAxisConstantLines.h:411
CXTPChartAxisConstantLine::GetActualColor
CXTPChartColor GetActualColor() const
Use this function to get the value of the actual color of the constant line.
CXTPChartAxisConstantLine::m_strLegendName
CXTPChartString m_strLegendName
The legend name.
Definition XTPChartAxisConstantLines.h:316
CXTPChartAxisConstantLine::m_clrColor
CXTPChartColor m_clrColor
The color of the constant line.
Definition XTPChartAxisConstantLines.h:321
CXTPChartAxisConstantLine::GetFont
CXTPChartFont * GetFont() const
Use this function to get the font of the constant line legend item text.
Definition XTPChartAxisConstantLines.h:407
CXTPChartAxisConstantLine::GetAxisValue
CXTPChartString GetAxisValue() const
Use this function to get the value of the constant line in the axis.
Definition XTPChartAxisConstantLines.h:438
CXTPChartAxisConstantLine::SetTextColor
void SetTextColor(const CXTPChartColor &clrTextColor)
Use this function to set the text color of the constant line legend item.
CXTPChartAxisConstantLine::SetLegendVisible
void SetLegendVisible(BOOL bVisible)
Call this function to set the visibility of the constant line legend item.
Definition XTPChartAxisConstantLines.h:461
CXTPChartAxisConstantLine::m_pLineStyle
CXTPChartLineStyle * m_pLineStyle
The chart line style object.
Definition XTPChartAxisConstantLines.h:330
CXTPChartAxisConstantLine::GetLegendName
CXTPChartString GetLegendName() const
Call this function to get the legend name.
CXTPChartAxisConstantLine::SetFont
void SetFont(CXTPChartFont *pFont)
Use this function to set the font of the constant line legend item text.
CXTPChartAxisConstantLine::CXTPChartAxisConstantLine
CXTPChartAxisConstantLine()
Constructs a CXTPChartAxisConstantLine object.
CXTPChartAxisConstantLine::m_nAlignment
XTPChartStringAlignment m_nAlignment
The text alignment of the constant line legend item.
Definition XTPChartAxisConstantLines.h:323
CXTPChartAxisConstantLine::IsVisible
BOOL IsVisible() const
Call this function to check the visibility of the axis constant line.
Definition XTPChartAxisConstantLines.h:430
CXTPChartAxisConstantLine::GetText
CXTPChartString GetText() const
Call this function to get the text of the constant line legend item.
Definition XTPChartAxisConstantLines.h:403
CXTPChartAxisConstantLine::GetAxisValueInternal
double GetAxisValueInternal() const
Use this function to get the value of the constant line in the axis.
Definition XTPChartAxisConstantLines.h:442
CXTPChartAxisConstantLine::m_bLegendVisible
BOOL m_bLegendVisible
TRUE if the legend is visible, FALSE if invisible.
Definition XTPChartAxisConstantLines.h:312
CXTPChartAxisConstantLine::SetLegendName
void SetLegendName(const CXTPChartString &strName)
Call this function to set the legend name.
Definition XTPChartAxisConstantLines.h:484
CXTPChartAxisConstantLine::SetAxisValue
void SetAxisValue(LPCTSTR lpszValue)
Call this function to set the value of the constant line in the axis.
Definition XTPChartAxisConstantLines.h:446
CXTPChartAxisConstantLine::SetAntialiasing
void SetAntialiasing(BOOL bAntialiasing)
Call this function to set anti-aliasing ON or OFF.
Definition XTPChartAxisConstantLines.h:416
CXTPChartAxisConstantLine::CreateLegendDeviceCommand
virtual CXTPChartDeviceCommand * CreateLegendDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcBounds)
This function creates a CXTPChartDeviceCommand object.
CXTPChartAxisConstantLine::m_bVisible
BOOL m_bVisible
TRUE if the constant line is visible, FALSE if invisible.
Definition XTPChartAxisConstantLines.h:313
CXTPChartAxisConstantLine::IsLegendVisible
BOOL IsLegendVisible() const
Call this function to check the visibility of the constant line legend item.
Definition XTPChartAxisConstantLines.h:457
CXTPChartAxisConstantLine::m_clrTextColor
CXTPChartColor m_clrTextColor
The text color of the constant line legend item.
Definition XTPChartAxisConstantLines.h:320
CXTPChartAxisConstantLine::m_strAxisValue
CXTPChartString m_strAxisValue
The string value of constant line parallel to an axis.
Definition XTPChartAxisConstantLines.h:317
CXTPChartAxisConstantLine::SetText
void SetText(const CXTPChartString &lpszTitle)
Use this function to set the text of the constant line legend item.
CXTPChartAxisConstantLine::m_bShowBehind
BOOL m_bShowBehind
TRUE if the text is behind, FALSE if not.
Definition XTPChartAxisConstantLines.h:328
CXTPChartAxisConstantLine::m_bAntialiasing
BOOL m_bAntialiasing
TRUE if anti-aliasing is used, FALSE if not using antialiasing.
Definition XTPChartAxisConstantLines.h:325
CXTPChartAxisConstantLine::~CXTPChartAxisConstantLine
virtual ~CXTPChartAxisConstantLine()
Destroys a CXTPChartAxisConstantLine object, handles cleanup.
CXTPChartAxisConstantLine::GetLineStyle
CXTPChartLineStyle * GetLineStyle() const
Call this function to get the constant line style.
Definition XTPChartAxisConstantLines.h:434
CXTPChartAxisConstantLine::GetAntialiasing
BOOL GetAntialiasing() const
Call this function to check if anti-aliasing is ON or OFF.
Definition XTPChartAxisConstantLines.h:421
CXTPChartAxisConstantLines
This class encapsulates a collection of CXTPChartAxisConstantLine objects.
Definition XTPChartAxisConstantLines.h:340
CXTPChartAxisConstantLines::GetAt
CXTPChartAxisConstantLine * GetAt(int nIndex) const
Call this function to get the constant line object at a particular index in the collection.
Definition XTPChartAxisConstantLines.h:396
CXTPChartAxisConstantLines::DoPropExchange
void DoPropExchange(CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
CXTPChartAxisConstantLines::Add
CXTPChartAxisConstantLine * Add(CXTPChartAxisConstantLine *pConstantLine)
This function adds a new constant line to the collection of lines.
CXTPChartAxisConstantLines::~CXTPChartAxisConstantLines
virtual ~CXTPChartAxisConstantLines()
Destroys a CXTPChartAxisConstantLines object, handles cleanup.
CXTPChartAxisConstantLines::CXTPChartAxisConstantLines
CXTPChartAxisConstantLines(CXTPChartAxis *pAxis)
Constructs a CXTPChartAxisConstantLines object.
CXTPChartAxis
This abstract base class represents a chart axis as a kind of chart element.
Definition XTPChartAxis.h:86
CXTPChartColor
This class abstracts a color entity.
Definition XTPChartTypes.h:51
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartElementCollection
This class abstracts a chart collection.
Definition XTPChartElement.h:358
CXTPChartElementCollection::m_arrElements
CArray< CXTPChartElement *, CXTPChartElement * > m_arrElements
Array of CXTPChartElement pointer.
Definition XTPChartElement.h:450
CXTPChartElement::OnChartChanged
virtual void OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic propertie...
CXTPChartFont
This class abstracts a font entity.
Definition XTPChartTypes.h:540
CXTPChartLegendItemView
CXTPChartLegendItemView is an abstract base class which represents a chart legend item.
Definition XTPChartLegendItem.h:39
CXTPChartLineStyle
This class represents a chart line style, which is a kind of CXTPCmdTarget.
Definition XTPChartLineStyle.h:43
CXTPChartTextElement
This class abstracts a chart text element.
Definition XTPChartElement.h:323
CXTPChartTextElement::GetFont
virtual CXTPChartFont * GetFont() const =0
Call this function to get the font of the text element.
CXTPChartTextElement::GetAntialiasing
virtual BOOL GetAntialiasing() const =0
Call this function to check if anti-aliasing is ON or OFF.
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72


Toolkit Pro: Member List

CXTPCaptionThemeOffice2003 Member List

This is the complete list of members for CXTPCaptionThemeOffice2003, including all inherited members.

CXTPCaptionTheme() | CXTPCaptionTheme |
CXTPCaptionThemeOffice2003() | CXTPCaptionThemeOffice2003 |
CXTPCmdTarget() | CXTPCmdTarget |
CXTPControlTheme() | CXTPControlTheme |
DrawCaptionBack(CDC *pDC, CXTPCaption *pCaption, CRect &rcItem) | CXTPCaptionThemeOffice2003 | protectedvirtual
DrawCaptionIcon(CDC *pDC, CXTPCaption *pCaption, CRect &rcItem) | CXTPCaptionTheme | virtual
DrawCaptionText(CDC *pDC, CXTPCaption *pCaption) | CXTPCaptionTheme | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetThemeStyle() const | CXTPControlTheme |
m_clrEdgeLight | CXTPCaptionTheme |
m_clrEdgeShadow | CXTPCaptionTheme |
m_nTheme | CXTPControlTheme | protected
RefreshMetrics(CXTPCaption *pCaption) | CXTPCaptionTheme | virtual
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static


Toolkit Pro: XTPGridThemeVisualStudio2017.h Source File

  • Source
  • GridControl
  • Themes
XTPGridThemeVisualStudio2017.h
Go to the documentation of this file.
1
23#if !defined(__XTPGRIDTHEMEVISUALSTUDIO2017_H__)
24# define __XTPGRIDTHEMEVISUALSTUDIO2017_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPGridThemeVisualStudio2017 : public CXTPGridThemeOffice2013
39{
40public:
45 CXTPGridThemeVisualStudio2017();
46
52 virtual void RefreshMetrics();
53};
55# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
56#endif //#if !defined(__XTPGRIDTHEMEVISUALSTUDIO2017_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPGridThemeOffice2013
CXTPGridThemeOffice2013 is a CXTPGridPaintManager derived class that represents an Office 2013 style ...
Definition XTPGridThemeOffice2013.h:39
CXTPGridThemeVisualStudio2017
CXTPGridThemeVisualStudio2017 is a CXTPGridThemeOffice2013 derived class that represents a Visual Stu...
Definition XTPGridThemeVisualStudio2017.h:39
CXTPGridThemeVisualStudio2017::CXTPGridThemeVisualStudio2017
CXTPGridThemeVisualStudio2017()
Default paint manager constructor, handles properties initialization.
CXTPGridThemeVisualStudio2017::RefreshMetrics
virtual void RefreshMetrics()
This method is called to refresh the visual metrics of the Grid control.


Toolkit Pro: XTPChartPieSeriesLabel.h Source File

  • Source
  • Chart
  • Styles
  • Pie
XTPChartPieSeriesLabel.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTPIESERIESLABEL_H__)
24# define __XTPCHARTPIESERIESLABEL_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Chart/Styles/Pie/Base/XTPChartPieSeriesLabelBase.h"
32# include "Chart/Styles/Pie/2D/XTPChart2dPieSeriesLabel.h"
33
34// CXTPChart2dPieSeriesLabel alias is necessary for naming consistency.
35typedef CXTPChartPieSeriesLabel CXTPChart2dPieSeriesLabel;
36
37// CXTPChart2dPieSeriesLabelView alias is necessary for naming consistency.
38typedef CXTPChartPieSeriesLabelView CXTPChart2dPieSeriesLabelView;
39
40// CXTPChart2dPieSeriesLabelsView alias is necessary for naming consistency.
41typedef CXTPChartPieSeriesLabelsView CXTPChart2dPieSeriesLabelsView;
43#endif //#if !defined(__XTPCHARTPIESERIESLABEL_H__)
XTPChart2dPieSeriesLabel.h
XTPChartPieSeriesLabelBase.h
CXTPChartPieSeriesLabel
CXTPChartPieSeriesLabelBase is a kind of CXTPChartPieSeriesLabel.
Definition XTPChart2dPieSeriesLabel.h:43
CXTPChartPieSeriesLabelView
Defines 2D series label view.
Definition XTPChart2dPieSeriesLabel.h:91
CXTPChartPieSeriesLabelsView
Defines 2D series label collection view.
Definition XTPChart2dPieSeriesLabel.h:150


Toolkit Pro: Member List

CXTPScrollBar Member List

This is the complete list of members for CXTPScrollBar, including all inherited members.

CXTPScrollBar() | CXTPScrollBar |
CXTPScrollBarCtrl() | CXTPScrollBarCtrl |
CXTPScrollBase() | CXTPScrollBase |
GetCltColor(CDC *pDC) const | CXTPScrollBase |
GetParentWindow() const =0 | CXTPScrollBase | pure virtual
GetScrollBarPaintManager() const | CXTPScrollBarCtrl | virtual
GetScrollBarPartRect(int nPart) const | CXTPScrollBase |
GetScrollBarPosInfo() | CXTPScrollBarCtrl | protected
GetScrollBarRect()=0 | CXTPScrollBase | pure virtual
GetScrollBarStyle() const | CXTPScrollBase |
GetScrollBarTrackInfo() | CXTPScrollBarCtrl | protected
CXTPScrollBase::GetScrollBarTrackInfo() const | CXTPScrollBase |
GetScrollInfo(SCROLLINFO *psi) | CXTPScrollBarCtrl | virtual
GetTicks() const | CXTPScrollBase |
GetUseVisualStyle() const | CXTPScrollBar |
HitTestScrollBar(POINT pt) const | CXTPScrollBase |
Init() | CXTPScrollBarCtrl | protected
IsScrollBarEnabled() const =0 | CXTPScrollBase | pure virtual
IsSlider() const | CXTPScrollBase |
m_bAnimation | CXTPScrollBase | protected
m_bPreSubclassInit | CXTPScrollBarCtrl | protected
m_bUseVisualStyle | CXTPScrollBar | protected
m_nTheme | CXTPScrollBar | protected
m_nTimerElapse | CXTPScrollBase | protected
m_pSBTrack | CXTPScrollBase | protected
m_pTicks | CXTPScrollBase | protected
m_scrollBarStyle | CXTPScrollBase | protected
m_spi | CXTPScrollBase | protected
PerformTrackInit(HWND hWnd, CPoint point, XTP_SCROLLBAR_POSINFO *pSBInfo, BOOL bDirect) | CXTPScrollBase |
RedrawScrollBar()=0 | CXTPScrollBase | pure virtual
RefreshMetrics() | CXTPScrollBarCtrl | virtual
SetScrollBarStyle(XTPScrollBarStyle scrollStyle) | CXTPScrollBase |
SetTheme(XTPControlTheme nTheme) | CXTPScrollBar |
CXTPScrollBarCtrl::SetTheme(XTPScrollBarTheme theme) | CXTPScrollBarCtrl |
SetTicks(double *pTicks, int nCount) | CXTPScrollBase |
SetUseVisualStyle(BOOL bUseVisualStyle=TRUE) | CXTPScrollBar |
~CXTPScrollBar() | CXTPScrollBar | virtual
~CXTPScrollBarCtrl() | CXTPScrollBarCtrl | virtual
~CXTPScrollBase() | CXTPScrollBase | virtual


Toolkit Pro: XTPSliderThemeNativeWindows11.h Source File

  • Source
  • CommandBars
  • Slider
XTPSliderThemeNativeWindows11.h
Go to the documentation of this file.
1
23#if !defined(__XTPSLIDERTHEMENATIVEWINDOWS11_H__)
24# define __XTPSLIDERTHEMENATIVEWINDOWS11_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class _XTP_EXT_CLASS CXTPSliderThemeNativeWindows11 : public CXTPSliderThemeOffice2013
34{
35public:
36 CXTPSliderThemeNativeWindows11(CXTPPaintManager* pPaintManager);
37};
38
40# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
41#endif // !defined(__XTPSLIDERTHEMENATIVEWINDOWS11_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPPaintManager
Paint manager of the command bars.
Definition XTPPaintManager.h:199


Toolkit Pro: Member List

CXTPExcelTabCtrlThemeOfficeXP Member List

This is the complete list of members for CXTPExcelTabCtrlThemeOfficeXP, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPControlTheme() | CXTPControlTheme |
CXTPExcelTabCtrlTheme() | CXTPExcelTabCtrlTheme |
CXTPExcelTabCtrlThemeOfficeXP() | CXTPExcelTabCtrlThemeOfficeXP |
DrawButton(CDC *pDC, CXTPExcelTabCtrl *pTabCtrl, const CXTPExcelTabCtrlButtonState &state) | CXTPExcelTabCtrlTheme | virtual
DrawButtonBack(CDC *pDC, CRect &rect, const CXTPExcelTabCtrlButtonState &state) | CXTPExcelTabCtrlThemeOfficeXP | virtual
DrawGripper(CDC *pDC, CRect rect) | CXTPExcelTabCtrlTheme | virtual
DrawTab(CDC *pDC, CXTPExcelTabCtrl *pTabCtrl, const CPoint &pt, bool bSelected, CXTPTcbItem *pTcbItem) | CXTPExcelTabCtrlTheme | virtual
FillBackground(CDC *pDC, CRect &rect, BOOL bBottom) | CXTPExcelTabCtrlTheme | virtual
FillTabsBackground(CDC *pDC, int cx, int cy) | CXTPExcelTabCtrlTheme | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetSelTabBackColor(CXTPTcbItem *pTcbItem) const | CXTPExcelTabCtrlTheme | virtual
GetSelTabTextColor(CXTPTcbItem *pTcbItem) const | CXTPExcelTabCtrlTheme | virtual
GetTabBackColor(CXTPTcbItem *pTcbItem) const | CXTPExcelTabCtrlTheme | virtual
GetTabTextColor(CXTPTcbItem *pTcbItem) const | CXTPExcelTabCtrlTheme | virtual
GetThemeStyle() const | CXTPControlTheme |
m_clr3DFace | CXTPExcelTabCtrlTheme |
m_clr3DFaceHilite | CXTPExcelTabCtrlTheme |
m_clr3DFacePushed | CXTPExcelTabCtrlTheme |
m_clr3DHilight | CXTPExcelTabCtrlTheme |
m_clr3DShadow | CXTPExcelTabCtrlTheme |
m_clrBorder3DHilite | CXTPExcelTabCtrlTheme |
m_clrBorder3DShadow | CXTPExcelTabCtrlTheme |
m_clrBtnText | CXTPExcelTabCtrlTheme |
m_clrBtnTextGray | CXTPExcelTabCtrlTheme |
m_clrBtnTextHilite | CXTPExcelTabCtrlTheme |
m_clrBtnTextPushed | CXTPExcelTabCtrlTheme |
m_clrWindow | CXTPExcelTabCtrlTheme |
m_clrWindowText | CXTPExcelTabCtrlTheme |
m_nTheme | CXTPControlTheme | protected
RefreshMetrics(CXTPExcelTabCtrl *pTab) | CXTPExcelTabCtrlThemeOfficeXP | virtual
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static
~CXTPExcelTabCtrlTheme() | CXTPExcelTabCtrlTheme |


Toolkit Pro: XTPResizeRect.h Source File

  • Source
  • Controls
  • Resize
XTPResizeRect.h
Go to the documentation of this file.
1
23#if !defined(__XTPRESIZERECT_H__)
24# define __XTPRESIZERECT_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
41typedef float XTP_RESIZE;
42
63struct XTP_RESIZERECT
64{
65 XTP_RESIZE left;
66 XTP_RESIZE top;
67 XTP_RESIZE right;
68 XTP_RESIZE bottom;
69};
70
80class _XTP_EXT_CLASS CXTPResizeRect : public XTP_RESIZERECT
81{
82public:
87 CXTPResizeRect();
88
94 CXTPResizeRect(const RECT& rc);
95
102 CXTPResizeRect(const XTP_RESIZERECT& rrc);
103
112 CXTPResizeRect(XTP_RESIZE l, XTP_RESIZE t, XTP_RESIZE r, XTP_RESIZE b);
113
121 CXTPResizeRect& operator=(const RECT& rc);
122
130 CXTPResizeRect& operator=(const XTP_RESIZERECT& rrc);
131
141 CXTPResizeRect& operator+=(const XTP_RESIZERECT& rrc);
142
151 CXTPResizeRect operator+(const XTP_RESIZERECT& rrc);
152
162 CXTPResizeRect operator&(const XTP_RESIZERECT& rrc);
163
172 bool operator==(const XTP_RESIZERECT& rrc);
173
182 bool operator!=(const XTP_RESIZERECT& rrc);
183
191 operator CRect();
192
199 bool IsNormalized();
200
208 XTP_RESIZE Width();
209
217 XTP_RESIZE Height();
218};
219
221
222AFX_INLINE CXTPResizeRect::CXTPResizeRect(const RECT& rc)
223{
224 (operator=)(rc);
225}
226AFX_INLINE CXTPResizeRect::CXTPResizeRect(const XTP_RESIZERECT& rrc)
227{
228 (operator=)(rrc);
229}
230AFX_INLINE CXTPResizeRect CXTPResizeRect::operator+(const XTP_RESIZERECT& rrc)
231{
232 return CXTPResizeRect(left + rrc.left, top + rrc.top, right + rrc.right, bottom + rrc.bottom);
233}
234AFX_INLINE bool CXTPResizeRect::IsNormalized()
235{
236 return ((left <= right) && (top <= bottom));
237}
238AFX_INLINE bool CXTPResizeRect::operator==(const XTP_RESIZERECT& rrc)
239{
240 return left == rrc.left && top == rrc.top && right == rrc.right && bottom == rrc.bottom;
241}
242AFX_INLINE bool CXTPResizeRect::operator!=(const XTP_RESIZERECT& rrc)
243{
244 return !operator==(rrc);
245}
246AFX_INLINE CXTPResizeRect::operator CRect()
247{
248 return CRect((int)left, (int)top, (int)right, (int)bottom);
249}
250AFX_INLINE XTP_RESIZE CXTPResizeRect::Width()
251{
252 return right - left;
253}
254AFX_INLINE XTP_RESIZE CXTPResizeRect::Height()
255{
256 return bottom - top;
257}
282# define XTP_ATTR_RESIZE(x) CXTPResizeRect(0, 0, x, x)
306# define XTP_ATTR_REPOS(x) CXTPResizeRect(x, x, x, x)
330# define XTP_ATTR_HORRESIZE(x) CXTPResizeRect(0, 0, x, 0)
354# define XTP_ATTR_HORREPOS(x) CXTPResizeRect(x, 0, x, 0)
378# define XTP_ATTR_VERRESIZE(x) CXTPResizeRect(0, 0, 0, x)
402# define XTP_ATTR_VERREPOS(x) CXTPResizeRect(0, x, 0, x)
403
404# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
406#endif // !defined(__XTPRESIZERECT_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTP_RESIZE
float XTP_RESIZE
The XTP_RESIZE data type is defined as a float and is used for storing single-precision floating poin...
Definition XTPResizeRect.h:41
CXTPResizeRect
CXTPResizeRect is an XTP_RESIZERECT structure derived class.
Definition XTPResizeRect.h:81
CXTPResizeRect::operator!=
bool operator!=(const XTP_RESIZERECT &rrc)
This operator determines whether CXTPResizeRect is not equal to a rectangle.
CXTPResizeRect::operator+=
CXTPResizeRect & operator+=(const XTP_RESIZERECT &rrc)
This operator adds the specified offsets to CXTPResizeRect or inflates CXTPResizeRect.
CXTPResizeRect::Width
XTP_RESIZE Width()
This member function calculates the width of a CXTPResizeRect by subtracting the left value from the ...
CXTPResizeRect::operator=
CXTPResizeRect & operator=(const XTP_RESIZERECT &rrc)
This operator copies the dimensions of a rectangle to CXTPResizeRect.
CXTPResizeRect::CXTPResizeRect
CXTPResizeRect(const XTP_RESIZERECT &rrc)
Constructs a CXTPResizeRect object.
CXTPResizeRect::operator=
CXTPResizeRect & operator=(const RECT &rc)
This operator copies the dimensions of a rectangle to CXTPResizeRect.
CXTPResizeRect::CXTPResizeRect
CXTPResizeRect(const RECT &rc)
Constructs a CXTPResizeRect object.
CXTPResizeRect::IsNormalized
bool IsNormalized()
This member function determines if CXTPResizeRect is normalized.
CXTPResizeRect::CXTPResizeRect
CXTPResizeRect(XTP_RESIZE l, XTP_RESIZE t, XTP_RESIZE r, XTP_RESIZE b)
Constructs a CXTPResizeRect object.
CXTPResizeRect::operator+
CXTPResizeRect operator+(const XTP_RESIZERECT &rrc)
This operator adds the given offsets to CRect or inflates CRect.
CXTPResizeRect::operator==
bool operator==(const XTP_RESIZERECT &rrc)
This operator determines whether CXTPResizeRect is equal to a rectangle.
CXTPResizeRect::operator&
CXTPResizeRect operator&(const XTP_RESIZERECT &rrc)
This operator creates the intersection of CXTPResizeRect and a rectangle, and returns the resulting C...
CXTPResizeRect::CXTPResizeRect
CXTPResizeRect()
Constructs a CXTPResizeRect object.
CXTPResizeRect::Height
XTP_RESIZE Height()
This member function calculates the height of a CXTPResizeRect by subtracting the top value from the ...
XTP_RESIZERECT
XTP_RESIZERECT structure is used by the CXTPResizeRect class for defining single-precision floating p...
Definition XTPResizeRect.h:64
XTP_RESIZERECT::left
XTP_RESIZE left
Specifies the x-coordinate of the upper-left corner of a rectangle.
Definition XTPResizeRect.h:65
XTP_RESIZERECT::bottom
XTP_RESIZE bottom
Specifies the y-coordinate of the lower-right corner of a rectangle.
Definition XTPResizeRect.h:68
XTP_RESIZERECT::right
XTP_RESIZE right
Specifies the x-coordinate of the lower-right corner of a rectangle.
Definition XTPResizeRect.h:67
XTP_RESIZERECT::top
XTP_RESIZE top
Specifies the y-coordinate of the upper-left corner of a rectangle.
Definition XTPResizeRect.h:66


Toolkit Pro: Member List

CXTPTaskPanelItems Member List

This is the complete list of members for CXTPTaskPanelItems, including all inherited members.

Add(CXTPTaskPanelItem *pItem, UINT nID) | CXTPTaskPanelItems |
Add(CXTPTaskPanelItem *pItem, UINT nID, LPCTSTR lpCaption, LPCTSTR lpTooltip=NULL) | CXTPTaskPanelItems |
Clear(BOOL bReposition=TRUE) | CXTPTaskPanelItems |
CXTPCmdTarget() | CXTPCmdTarget |
CXTPTaskPanelItems(CXTPTaskPanel *pPanel=NULL) | CXTPTaskPanelItems |
DoPropExchange(CXTPPropExchange *pPX) | CXTPTaskPanelItems |
Find(UINT nID) const | CXTPTaskPanelItems |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAt(int nIndex) const | CXTPTaskPanelItems |
GetCount() const | CXTPTaskPanelItems |
GetDefaultItemClass() const | CXTPTaskPanelItems | virtual
GetFirstVisibleItem() const | CXTPTaskPanelItems |
GetIndex(const CXTPTaskPanelItem *pItem) const | CXTPTaskPanelItems |
GetLastVisibleItem() const | CXTPTaskPanelItems |
GetNextVisibleIndex(int nIndex, int nDirection) const | CXTPTaskPanelItems |
GetOwner() const | CXTPTaskPanelItems |
InsertAt(int nIndex, CXTPTaskPanelItem *pItem) | CXTPTaskPanelItems |
m_arrItems | CXTPTaskPanelItems | protected
m_pOwner | CXTPTaskPanelItems | protected
m_pPanel | CXTPTaskPanelItems | protected
Move(CXTPTaskPanelItem *pItem, int nIndex) | CXTPTaskPanelItems |
Remove(CXTPTaskPanelItem *pItem) | CXTPTaskPanelItems |
RemoveAt(int nIndex) | CXTPTaskPanelItems |
~CXTPTaskPanelItems() | CXTPTaskPanelItems | virtual


Toolkit Pro: Member List

CXTPMarkupColumnDefinitionCollection Member List

This is the complete list of members for CXTPMarkupColumnDefinitionCollection, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPMarkupColumnDefinitionCollection() | CXTPMarkupColumnDefinitionCollection |
CXTPMarkupDefinitionCollection() | CXTPMarkupDefinitionCollection |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetItem(int nIndex) const | CXTPMarkupDefinitionCollection |


Toolkit Pro: Member List

CXTPColorSetStateComboBox Member List

This is the complete list of members for CXTPColorSetStateComboBox, including all inherited members.

clrBack | CXTPColorSetStateComboBox |
clrBackDisabled | CXTPColorSetStateComboBox |
clrBackDropped | CXTPColorSetStateComboBox |
clrBackHighlight | CXTPColorSetStateComboBox |
clrBorder | CXTPColorSetStateComboBox |
clrBorderDisabled | CXTPColorSetStateComboBox |
clrBorderDropped | CXTPColorSetStateComboBox |
clrBorderHighlight | CXTPColorSetStateComboBox |
clrDropDownBack | CXTPColorSetStateComboBox |
clrDropDownBackDisabled | CXTPColorSetStateComboBox |
clrDropDownBackDropped | CXTPColorSetStateComboBox |
clrDropDownBackHighlight | CXTPColorSetStateComboBox |
clrDropDownBorder | CXTPColorSetStateComboBox |
clrDropDownBorderDisabled | CXTPColorSetStateComboBox |
clrDropDownBorderDropped | CXTPColorSetStateComboBox |
clrDropDownBorderHighlight | CXTPColorSetStateComboBox |
clrDropDownMarker | CXTPColorSetStateComboBox |
clrDropDownMarkerDisabled | CXTPColorSetStateComboBox |
clrDropDownMarkerDropped | CXTPColorSetStateComboBox |
clrDropDownMarkerHighlight | CXTPColorSetStateComboBox |
RefreshColors() | CXTPColorSetStateComboBox | virtual
~CXTPColorSetStateComboBox() | CXTPColorSetStateComboBox | inlinevirtual


Toolkit Pro: Member List

CXTPExcelTabCtrlThemeNativeWindows11 Member List

This is the complete list of members for CXTPExcelTabCtrlThemeNativeWindows11, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPControlTheme() | CXTPControlTheme |
CXTPExcelTabCtrlTheme() | CXTPExcelTabCtrlTheme |
CXTPExcelTabCtrlThemeNativeWindows11() | CXTPExcelTabCtrlThemeNativeWindows11 |
CXTPExcelTabCtrlThemeOffice2013() | CXTPExcelTabCtrlThemeOffice2013 |
DrawButton(CDC *pDC, CXTPExcelTabCtrl *pTabCtrl, const CXTPExcelTabCtrlButtonState &state) | CXTPExcelTabCtrlThemeOffice2013 | virtual
DrawButtonBack(CDC *pDC, CRect &rect, const CXTPExcelTabCtrlButtonState &state) | CXTPExcelTabCtrlThemeOffice2013 | virtual
DrawGripper(CDC *pDC, CRect rect) | CXTPExcelTabCtrlThemeOffice2013 | virtual
DrawTab(CDC *pDC, CXTPExcelTabCtrl *pTabCtrl, const CPoint &pt, bool bSelected, CXTPTcbItem *pTcbItem) | CXTPExcelTabCtrlThemeOffice2013 | virtual
FillBackground(CDC *pDC, CRect &rect, BOOL bBottom) | CXTPExcelTabCtrlThemeOffice2013 | virtual
FillTabsBackground(CDC *pDC, int cx, int cy) | CXTPExcelTabCtrlThemeOffice2013 | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetSelTabBackColor(CXTPTcbItem *pTcbItem) const | CXTPExcelTabCtrlTheme | virtual
GetSelTabTextColor(CXTPTcbItem *pTcbItem) const | CXTPExcelTabCtrlTheme | virtual
GetTabBackColor(CXTPTcbItem *pTcbItem) const | CXTPExcelTabCtrlTheme | virtual
GetTabTextColor(CXTPTcbItem *pTcbItem) const | CXTPExcelTabCtrlTheme | virtual
GetThemeStyle() const | CXTPControlTheme |
m_clr3DFace | CXTPExcelTabCtrlTheme |
m_clr3DFaceHilite | CXTPExcelTabCtrlTheme |
m_clr3DFacePushed | CXTPExcelTabCtrlTheme |
m_clr3DHilight | CXTPExcelTabCtrlTheme |
m_clr3DShadow | CXTPExcelTabCtrlTheme |
m_clrBorder3DHilite | CXTPExcelTabCtrlTheme |
m_clrBorder3DShadow | CXTPExcelTabCtrlTheme |
m_clrBtnText | CXTPExcelTabCtrlTheme |
m_clrBtnTextGray | CXTPExcelTabCtrlTheme |
m_clrBtnTextHilite | CXTPExcelTabCtrlTheme |
m_clrBtnTextPushed | CXTPExcelTabCtrlTheme |
m_clrWindow | CXTPExcelTabCtrlTheme |
m_clrWindowText | CXTPExcelTabCtrlTheme |
m_nTheme | CXTPControlTheme | protected
RefreshMetrics(CXTPExcelTabCtrl *pTab) | CXTPExcelTabCtrlThemeOffice2013 | virtual
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static
~CXTPExcelTabCtrlTheme() | CXTPExcelTabCtrlTheme |


Toolkit Pro: XTPChartLegendView.h Source File

  • Source
  • Chart
XTPChartLegendView.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTLEGENDVIEW_H__)
24# define __XTPCHARTLEGENDVIEW_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartFont;
34class CXTPChartElementView;
35class CXTPChartDeviceContext;
36class CXTPChartLegend;
37class CXTPChartDeviceContext;
38class CXTPChartDeviceCommand;
39class CXTPChartBorder;
40class CXTPChartFillStyle;
41class CXTPPropExchange;
42
48class _XTP_EXT_CLASS CXTPChartLegendView : public CXTPChartElementView
49{
50public:
58 CXTPChartLegendView(CXTPChartLegend* pLegend, CXTPChartElementView* pParentView);
59
64 virtual ~CXTPChartLegendView();
65
66public:
79 virtual CXTPChartDeviceCommand* CreateDeviceCommand(CXTPChartDeviceContext* pDC);
80
89 void CalculateView(CXTPChartDeviceContext* pDC, CRect& rcChart);
90
102 CSize CalcSize(CXTPChartDeviceContext* pDC);
103
112 void AddItem(CXTPChartLegendItemView* pItem, double minimum = 0, double maximum = 0);
113
114protected:
115 CXTPChartLegend* m_pLegend;
116 CRect m_rcBounds;
118 struct CHARTLEGEND_ITEM
119 {
120 CXTPChartLegendItemView* pView;
121 double min;
122 double max;
123 CXTPChartString str;
124 };
125
126 CArray<CHARTLEGEND_ITEM, CHARTLEGEND_ITEM> m_arrItems;
128 static int CompareFuncAsc(const CHARTLEGEND_ITEM* pItem1, const CHARTLEGEND_ITEM* pItem2);
129 static int CompareFuncDesc(const CHARTLEGEND_ITEM* pItem1, const CHARTLEGEND_ITEM* pItem2);
130 static int CompareFuncMinToMax(const CHARTLEGEND_ITEM* pItem1, const CHARTLEGEND_ITEM* pItem2);
131 static int CompareFuncMaxToMin(const CHARTLEGEND_ITEM* pItem1, const CHARTLEGEND_ITEM* pItem2);
132};
134# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
135#endif //#if !defined(__XTPCHARTLEGENDVIEW_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartBorder
This class abstracts the border of a chart, it is a kind of chart element.
Definition XTPChartBorder.h:42
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartElementView
This class represents the view of a chart element.
Definition XTPChartElementView.h:47
CXTPChartFillStyle
This class abstracts a fill style used to fill the background of various chart elements.
Definition XTPChartFillStyle.h:43
CXTPChartFont
This class abstracts a font entity.
Definition XTPChartTypes.h:540
CXTPChartLegend
This class represents a chart legend as a kind of chart element.
Definition XTPChartLegend.h:88
CXTPChartLegendItemView
CXTPChartLegendItemView is an abstract base class which represents a chart legend item.
Definition XTPChartLegendItem.h:39
CXTPChartLegendView
This class abstracts the view of a legend and its child items in a bounding rectangle context.
Definition XTPChartLegendView.h:49
CXTPChartLegendView::AddItem
void AddItem(CXTPChartLegendItemView *pItem, double minimum=0, double maximum=0)
Call this function to add a new legend item.
CXTPChartLegendView::CreateDeviceCommand
virtual CXTPChartDeviceCommand * CreateDeviceCommand(CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
CXTPChartLegendView::CalculateView
void CalculateView(CXTPChartDeviceContext *pDC, CRect &rcChart)
This function calculates the legend location in the chart based on the state of the CXTPChartLegend o...
CXTPChartLegendView::m_pLegend
CXTPChartLegend * m_pLegend
Pointer to the legend object.
Definition XTPChartLegendView.h:115
CXTPChartLegendView::m_arrItems
CArray< CHARTLEGEND_ITEM, CHARTLEGEND_ITEM > m_arrItems
The list of legend items.
Definition XTPChartLegendView.h:126
CXTPChartLegendView::CalcSize
CSize CalcSize(CXTPChartDeviceContext *pDC)
This member function calculates the legend's width and height based on the number of legend items pre...
CXTPChartLegendView::m_rcBounds
CRect m_rcBounds
The bounding rectangle of the legend.
Definition XTPChartLegendView.h:116
CXTPChartLegendView::CXTPChartLegendView
CXTPChartLegendView(CXTPChartLegend *pLegend, CXTPChartElementView *pParentView)
Constructs a CXTPChartLegendView object.
CXTPChartLegendView::~CXTPChartLegendView
virtual ~CXTPChartLegendView()
Destroys a CXTPChartLegendView object, handles cleanup.
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72


Toolkit Pro: XTPChartRadarDiagramSeriesView.h Source File

  • Source
  • Chart
  • Diagram
  • RadarDiagram
XTPChartRadarDiagramSeriesView.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTRADARDIAGRAMSERIESVIEW_H__)
24# define __XTPCHARTRADARDIAGRAMSERIESVIEW_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartAxis;
34class CXTPChartDiagramView;
35class CXTPChartAxisView;
36
37class _XTP_EXT_CLASS CXTPChartRadarDiagramSeriesView : public CXTPChartSeriesView
38{
39protected:
40 CXTPChartRadarDiagramSeriesView(CXTPChartSeries* pSeries, CXTPChartDiagramView* pDiagramView);
41
42public:
43 CXTPChartRadarAxisView* GetAxisViewX() const;
44 CXTPChartRadarAxisView* GetAxisViewY() const;
45
46 CXTPChartPointF GetScreenPoint(double x, double y) const;
47
48 virtual void AfterUpdateRange(CXTPChartDeviceContext* pDC);
49 virtual void BeforeUpdateRange(CXTPChartDeviceContext* pDC);
50
51protected:
52 CXTPChartRadarAxisView* m_pAxisViewX;
53 CXTPChartRadarAxisView* m_pAxisViewY;
54
55 friend class CXTPChartRadarDiagramView;
56};
57
58AFX_INLINE CXTPChartRadarAxisView* CXTPChartRadarDiagramSeriesView::GetAxisViewX() const
59{
60 return m_pAxisViewX;
61}
62
63AFX_INLINE CXTPChartRadarAxisView* CXTPChartRadarDiagramSeriesView::GetAxisViewY() const
64{
65 return m_pAxisViewY;
66}
68# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
69#endif //#if !defined(__XTPCHARTRADARDIAGRAMSERIESVIEW_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartAxis
This abstract base class represents a chart axis as a kind of chart element.
Definition XTPChartAxis.h:86
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartDiagramView
This class represents the view of a chart diagram, which is a kind of CXTPChartElementView.
Definition XTPChartDiagramView.h:49
CXTPChartRadarAxisView
This class abstracts the view of a chart axis and its child items in a bounding rectangle context.
Definition XTPChartRadarAxisView.h:41
CXTPChartRadarDiagramView
This class represents the view of a chart 2D diagram, which is a kind of CXTPChartDiagramView.
Definition XTPChartRadarDiagramView.h:48
CXTPChartSeries
This class represents a series in the chart, which is a kind of CXTPChartElement.
Definition XTPChartSeries.h:50
CXTPPoint2T< float >


Toolkit Pro: XTPTabCtrl.h Source File

  • Source
  • Controls
  • Tab
XTPTabCtrl.h
Go to the documentation of this file.
1
23#if !defined(__XTPTABCTRL_H__)
24# define __XTPTABCTRL_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPTabCtrlButtons;
34
36DECLARE_TABCTRLEX_BASE(CXTPTabCtrlBase, CTabCtrl, CXTPTabExBase)
45class _XTP_EXT_CLASS CXTPTabCtrl : public CXTPTabCtrlBase
46{
48 DECLARE_DYNAMIC(CXTPTabCtrl)
50 friend class CXTPTabExBase;
51
52public:
57 CXTPTabCtrl();
58
63 virtual ~CXTPTabCtrl();
64
65public:
73 virtual BOOL EnableToolTips(BOOL bEnable);
74
75protected:
77 //{{AFX_VIRTUAL(CXTPTabCtrl)
78 //}}AFX_VIRTUAL
79
80 //{{AFX_MSG(CXTPTabCtrl)
81 //}}AFX_MSG
82 DECLARE_MESSAGE_MAP()
84};
85
87
88# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
90#endif // #if !defined(__XTPTABCTRL_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPTabCtrlButtons
CXTPTabCtrlButtons is a CWnd derived class.
Definition XTPTabCtrlButtons.h:90
CXTPTabCtrl
CXTPTabCtrl is a multiple inheritance class derived from CTabCtrl and CXTPTabCtrlBase.
Definition XTPTabCtrl.h:46
CXTPTabCtrl::EnableToolTips
virtual BOOL EnableToolTips(BOOL bEnable)
Call this member function to enable/disable tooltip usage.
CXTPTabCtrl::~CXTPTabCtrl
virtual ~CXTPTabCtrl()
Destroys a CXTPTabCtrl object, handles cleanup and deallocation.
CXTPTabCtrl::CXTPTabCtrl
CXTPTabCtrl()
Constructs a CXTPTabCtrl object.
CXTPTabExBase
CXTPTabExBase is a standalone base class.
Definition XTPTabBase.h:279


Toolkit Pro: XTPTrackPaintManager.h Source File

  • Source
  • GridControl
  • TrackControl
XTPTrackPaintManager.h
Go to the documentation of this file.
1
23#if !defined(__XTPTRACKPAINTMANAGER_H__)
24# define __XTPTRACKPAINTMANAGER_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPTrackBlock;
34
40class _XTP_EXT_CLASS CXTPTrackPaintManager : public CXTPGridPaintManager
41{
42public:
47 CXTPTrackPaintManager();
48
53 ~CXTPTrackPaintManager();
54
55public:
61 void RefreshMetrics();
62
63public:
72 virtual void DrawTrackHeader(CDC* pDC);
73
82 virtual void DrawMarkers(CDC* pDC);
83
92 virtual void DrawTimeLine(CDC* pDC);
93
107 virtual CString FormatTimeLineTick(int nPosition, COLORREF& clrTick, int& nTickLength);
108
120 virtual CString FormatTime(int nPosition);
121
122 virtual int DrawTrackBlock(CDC* pDC, CRect rc, BOOL bSelected, CXTPTrackBlock* pTrackBlock);
123
124 void SetColumnStyle(XTPGridColumnStyle columnStyle);
125
126protected:
127 template<class T>
128 const T& SelectDpiSpecific(const T& upToDpi120, const T& upToDpi144, const T& upToDpi192,
129 const T& theLargest) const;
130
131public:
132 COLORREF m_clrWorkArea;
133 COLORREF m_clrTrackHeader;
134 COLORREF m_clrTrackTimeArea;
135 COLORREF m_clrTimeHeaderDarkDark;
136 COLORREF m_clrTimeHeaderDark;
137 COLORREF m_clrTimeSliderBackground;
138 COLORREF m_clrTimeHeaderDivider;
139 COLORREF m_clrScrollBarLight;
140 COLORREF m_clrScrollBarDark;
141 COLORREF m_clrSelectedArea;
142 COLORREF m_clrMarker;
144 COLORREF m_clrTimeLineTick;
145 COLORREF m_clrMarkerBorder;
146 COLORREF m_clrMarkerBack;
147 COLORREF m_clrTrackMarkerBorder;
148 COLORREF m_clrTrackMarkerText;
149 COLORREF m_clrTrackMarkerTextBack;
150 COLORREF m_clrTrackMarkerTextBorder;
151 COLORREF m_clrTimeLinePosition;
152 COLORREF m_clrTimeHeaderBorder;
153 COLORREF m_clrScrollBarBorderDark;
154 COLORREF m_clrScrollBarBorderLight;
155 COLORREF m_clrWorkAreaScrollBarLight;
156 COLORREF m_clrWorkAreaScrollBarDark;
157 COLORREF m_clrWorkAreaScrollBarBorder;
159 int m_nTimeLineStep;
160 BOOL m_bTimeLineStepAuto;
161
162# ifdef _XTP_ACTIVEX
165 DECLARE_DISPATCH_MAP()
166 DECLARE_INTERFACE_MAP()
167
168 DECLARE_OLETYPELIB_EX(CXTPTrackPaintManager);
169
170# define DECLARE_PROPERTY_UN(theProperty, theType) \
171 afx_msg theType OleGet##theProperty(); \
172 afx_msg void OleSet##theProperty(theType);
173
174 DECLARE_PROPERTY_UN(WorkArea, COLORREF);
175 DECLARE_PROPERTY_UN(TrackHeader, COLORREF);
176 DECLARE_PROPERTY_UN(TrackTimeArea, COLORREF);
177 DECLARE_PROPERTY_UN(TimeHeaderDarkDark, COLORREF);
178 DECLARE_PROPERTY_UN(TimeHeaderDark, COLORREF);
179 DECLARE_PROPERTY_UN(TimeSliderBackground, COLORREF);
180 DECLARE_PROPERTY_UN(TimeHeaderDivider, COLORREF);
181 DECLARE_PROPERTY_UN(ScrollBarLight, COLORREF);
182 DECLARE_PROPERTY_UN(ScrollBarDark, COLORREF);
183 DECLARE_PROPERTY_UN(Marker, COLORREF);
184 DECLARE_PROPERTY_UN(SelectedArea, COLORREF);
185
186 void OleSetTimeLineStep(int nStep);
187 int OleGetTimeLineStep();
188 BOOL m_bCustomTimeLineLabel;
189 void OleSetColumnStyle();
190
192# endif
193};
194
195template<class T>
196const T& CXTPTrackPaintManager::SelectDpiSpecific(const T& upToDpi120, const T& upToDpi144,
197 const T& upToDpi192, const T& theLargest) const
198{
199 int dpi = XTPDpiHelper()->GetDPIX();
200
201 if (96 <= dpi && dpi < 120)
202 return upToDpi120;
203 else if (120 <= dpi && dpi < 144)
204 return upToDpi144;
205 else if (144 <= dpi && dpi < 192)
206 return upToDpi192;
207
208 return theLargest;
209}
211# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
212#endif //#if !defined(__XTPTRACKPAINTMANAGER_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPGridColumnStyle
XTPGridColumnStyle
Represents predefined column styles.
Definition XTPGridDefines.h:183
CXTPGridPaintManager
Utility class that handles most drawing activities.
Definition XTPGridPaintManager.h:76
CXTPGridPaintManager::SetColumnStyle
void SetColumnStyle(XTPGridColumnStyle columnStyle)
Sets the header style.
CXTPTrackBlock
This class represents a track control block.
Definition XTPTrackBlock.h:42
CXTPTrackPaintManager
This class represents a track control paint manager.
Definition XTPTrackPaintManager.h:41
CXTPTrackPaintManager::m_clrScrollBarDark
COLORREF m_clrScrollBarDark
The scrollbar dark color.
Definition XTPTrackPaintManager.h:140
CXTPTrackPaintManager::m_clrTimeHeaderBorder
COLORREF m_clrTimeHeaderBorder
The color of a time line header's border.
Definition XTPTrackPaintManager.h:152
CXTPTrackPaintManager::m_clrWorkAreaScrollBarLight
COLORREF m_clrWorkAreaScrollBarLight
The workarea scrollbar light color.
Definition XTPTrackPaintManager.h:155
CXTPTrackPaintManager::m_clrTrackMarkerText
COLORREF m_clrTrackMarkerText
The color of a track marker's text.
Definition XTPTrackPaintManager.h:148
CXTPTrackPaintManager::m_clrScrollBarBorderLight
COLORREF m_clrScrollBarBorderLight
The scrollbar border light color.
Definition XTPTrackPaintManager.h:154
CXTPTrackPaintManager::m_clrSelectedArea
COLORREF m_clrSelectedArea
The color of the selected area.
Definition XTPTrackPaintManager.h:141
CXTPTrackPaintManager::m_clrTimeSliderBackground
COLORREF m_clrTimeSliderBackground
The slider background color.
Definition XTPTrackPaintManager.h:137
CXTPTrackPaintManager::m_clrScrollBarBorderDark
COLORREF m_clrScrollBarBorderDark
The scrollbar border dark color.
Definition XTPTrackPaintManager.h:153
CXTPTrackPaintManager::~CXTPTrackPaintManager
~CXTPTrackPaintManager()
CXTPTrackPaintManager destructor, handles cleanup and deallocation.
CXTPTrackPaintManager::m_clrTimeHeaderDark
COLORREF m_clrTimeHeaderDark
The header dark color.
Definition XTPTrackPaintManager.h:136
CXTPTrackPaintManager::m_clrTrackMarkerBorder
COLORREF m_clrTrackMarkerBorder
The color of a track marker's border.
Definition XTPTrackPaintManager.h:147
CXTPTrackPaintManager::FormatTimeLineTick
virtual CString FormatTimeLineTick(int nPosition, COLORREF &clrTick, int &nTickLength)
Call this function to format the time and tick marker relative to a time line position.
CXTPTrackPaintManager::CXTPTrackPaintManager
CXTPTrackPaintManager()
Creates a CXTPTrackPaintManager object.
CXTPTrackPaintManager::FormatTime
virtual CString FormatTime(int nPosition)
Call this function to format the time and tick marker relative to a time line position.
CXTPTrackPaintManager::m_clrMarkerBorder
COLORREF m_clrMarkerBorder
The color of a time line marker's border.
Definition XTPTrackPaintManager.h:145
CXTPTrackPaintManager::DrawMarkers
virtual void DrawMarkers(CDC *pDC)
Call this function to draw the markers.
CXTPTrackPaintManager::m_clrWorkArea
COLORREF m_clrWorkArea
The color of the work area.
Definition XTPTrackPaintManager.h:132
CXTPTrackPaintManager::m_clrWorkAreaScrollBarBorder
COLORREF m_clrWorkAreaScrollBarBorder
The workarea scrollbar border color.
Definition XTPTrackPaintManager.h:157
CXTPTrackPaintManager::m_clrMarker
COLORREF m_clrMarker
The color of the marker.
Definition XTPTrackPaintManager.h:142
CXTPTrackPaintManager::m_clrWorkAreaScrollBarDark
COLORREF m_clrWorkAreaScrollBarDark
The workarea scrollbar dark color.
Definition XTPTrackPaintManager.h:156
CXTPTrackPaintManager::m_clrTimeHeaderDivider
COLORREF m_clrTimeHeaderDivider
The header divider color.
Definition XTPTrackPaintManager.h:138
CXTPTrackPaintManager::m_clrTrackTimeArea
COLORREF m_clrTrackTimeArea
The track time area color.
Definition XTPTrackPaintManager.h:134
CXTPTrackPaintManager::m_clrTimeLineTick
COLORREF m_clrTimeLineTick
The color of a time line tick.
Definition XTPTrackPaintManager.h:144
CXTPTrackPaintManager::m_clrTimeHeaderDarkDark
COLORREF m_clrTimeHeaderDarkDark
The header deep dark color.
Definition XTPTrackPaintManager.h:135
CXTPTrackPaintManager::m_clrTrackHeader
COLORREF m_clrTrackHeader
The track header color.
Definition XTPTrackPaintManager.h:133
CXTPTrackPaintManager::m_clrScrollBarLight
COLORREF m_clrScrollBarLight
The scrollbar light color.
Definition XTPTrackPaintManager.h:139
CXTPTrackPaintManager::m_clrMarkerBack
COLORREF m_clrMarkerBack
The color of a time line marker's back.
Definition XTPTrackPaintManager.h:146
CXTPTrackPaintManager::DrawTimeLine
virtual void DrawTimeLine(CDC *pDC)
Call this function to draw the time line.
CXTPTrackPaintManager::DrawTrackHeader
virtual void DrawTrackHeader(CDC *pDC)
Call this function to draw the track header.
CXTPTrackPaintManager::RefreshMetrics
void RefreshMetrics()
Initializes all drawings defaults (fonts, colors, etc.).
CXTPTrackPaintManager::m_clrTrackMarkerTextBack
COLORREF m_clrTrackMarkerTextBack
The color of a track marker's text back.
Definition XTPTrackPaintManager.h:149
CXTPTrackPaintManager::m_clrTimeLinePosition
COLORREF m_clrTimeLinePosition
The color of a marked position on a time line.
Definition XTPTrackPaintManager.h:151
CXTPTrackPaintManager::m_clrTrackMarkerTextBorder
COLORREF m_clrTrackMarkerTextBorder
The color of a track marker's text border.
Definition XTPTrackPaintManager.h:150


Toolkit Pro: XTPMarkupGdiPlusScaleTransform.h Source File

  • Source
  • Markup
  • Transform
XTPMarkupGdiPlusScaleTransform.h
Go to the documentation of this file.
1
23#if !defined(__XTPMARKUPGDIPLUSSCALETRANSFORM_H__)
24# define __XTPMARKUPGDIPLUSSCALETRANSFORM_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPGdiPlus;
34
39class _XTP_EXT_CLASS CXTPMarkupGdiPlusScaleTransform
40 : public CXTPMarkupGdiPlusTransformObject<CXTPMarkupScaleTransform>
41{
43 DECLARE_MARKUPCLASS(CXTPMarkupGdiPlusScaleTransform);
45public:
50 CXTPMarkupGdiPlusScaleTransform();
51
60 virtual BOOL TransformMatrix(const CXTPGdiPlus* pReserved, GpMatrix* pMatrix);
61};
62
63# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
65#endif // !defined(__XTPMARKUPGDIPLUSSCALETRANSFORM_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPMarkupGdiPlusScaleTransform
GDI+ ScaleTransform implementation.
Definition XTPMarkupGdiPlusScaleTransform.h:41
CXTPMarkupGdiPlusScaleTransform::CXTPMarkupGdiPlusScaleTransform
CXTPMarkupGdiPlusScaleTransform()
Constructs a CXTPMarkupGdiPlusScaleTransform object.
CXTPMarkupGdiPlusScaleTransform::TransformMatrix
virtual BOOL TransformMatrix(const CXTPGdiPlus *pReserved, GpMatrix *pMatrix)
Performs GDI+ matrix scaling.
CXTPMarkupGdiPlusTransformObject
Base class for all GDI+ markup transformation objects.
Definition XTPMarkupGdiPlusTransformObject.h:91


Toolkit Pro: Member List

CXTPPropertyGridOfficeXPTheme Member List

This is the complete list of members for CXTPPropertyGridOfficeXPTheme, including all inherited members.

AdjustItemCaptionRect(CXTPPropertyGridItem *pItem, CRect &rcCaption) | CXTPPropertyGridPaintManager | virtual
AdjustItemValueRect(CXTPPropertyGridItem *pItem, CRect &rcValue) | CXTPPropertyGridPaintManager | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPPropertyGridOfficeXPTheme(CXTPPropertyGrid *pGrid) | CXTPPropertyGridOfficeXPTheme |
CXTPPropertyGridPaintManager(CXTPPropertyGrid *pGrid) | CXTPPropertyGridPaintManager |
DrawCategoryCaptionBackground(CDC *pDC, CXTPPropertyGridItem *pItem, CRect rc) | CXTPPropertyGridPaintManager | virtual
DrawCheckBox(CDC *pDC, CXTPPropertyGridItemBool *pButton) | CXTPPropertyGridPaintManager | virtual
DrawCheckMark(CDC *pDC, CRect rc, BOOL bEnabled, BOOL bChecked) | CXTPPropertyGridPaintManager | virtual
DrawExpandButton(CDC &dc, CXTPPropertyGridItem *pItem, CRect rcCaption) | CXTPPropertyGridPaintManager | virtual
DrawInplaceButtons(CDC *pDC, PDRAWITEMSTRUCT lpDrawItemStruct, CXTPPropertyGridItem *pItem, CRect rcValue) | CXTPPropertyGridPaintManager | virtual
DrawInplaceListItem(CDC *pDC, CXTPPropertyGridItemConstraint *pConstraint, CRect rc, BOOL bSelected) | CXTPPropertyGridPaintManager | virtual
DrawItem(PDRAWITEMSTRUCT lpDrawItemStruct) | CXTPPropertyGridPaintManager | virtual
DrawItemCaption(CDC *pDC, CXTPPropertyGridItem *pItem, CRect rcCaption) | CXTPPropertyGridPaintManager | virtual
DrawItemValue(CDC *pDC, CXTPPropertyGridItem *pItem, CRect rcValue) | CXTPPropertyGridPaintManager | virtual
DrawPropertyGridBorder(CDC *pDC, RECT &rcBorder, XTPPropertyGridWindow nWindow) | CXTPPropertyGridPaintManager | virtual
DrawRadioMark(CDC *pDC, CRect rc, BOOL bEnabled, BOOL bChecked) | CXTPPropertyGridPaintManager | virtual
FillInplaceButton(CDC *pDC, CXTPPropertyGridInplaceButton *pButton) | CXTPPropertyGridPaintManager | virtual
FillPropertyGrid(CDC *pDC) | CXTPPropertyGridPaintManager | virtual
FillPropertyGridView(CDC *pDC) | CXTPPropertyGridPaintManager | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetItemBackColor(CXTPPropertyGridItem *pItem, BOOL bValuePart) | CXTPPropertyGridPaintManager | virtual
GetItemFont(CXTPPropertyGridItem *pItem, BOOL bValuePart) | CXTPPropertyGridPaintManager | virtual
GetItemMetrics() const | CXTPPropertyGridPaintManager |
GetItemsBorderHeight() const | CXTPPropertyGridPaintManager | virtual
GetItemTextColor(CXTPPropertyGridItem *pItem, BOOL bValuePart) | CXTPPropertyGridPaintManager | virtual
GetScrollBarTheme() const | CXTPPropertyGridOfficeXPTheme | virtual
GetSplitterRect(CRect rc, BOOL bIsHelp) | CXTPPropertyGridPaintManager |
HitTestVerbs(CDC *pDC, CRect rcVerbs, CPoint pt) | CXTPPropertyGridPaintManager |
m_bThinSplitter | CXTPPropertyGridPaintManager | protected
m_bTransparent | CXTPPropertyGridPaintManager |
m_buttonsStyle | CXTPPropertyGridPaintManager |
m_clrCategorySeparator | CXTPPropertyGridPaintManager |
m_clrFace | CXTPPropertyGridPaintManager |
m_clrHighlight | CXTPPropertyGridPaintManager |
m_clrHighlightText | CXTPPropertyGridPaintManager |
m_clrNonHighlightBack | CXTPPropertyGridPaintManager |
m_clrNonHighlightText | CXTPPropertyGridPaintManager |
m_clrShadow | CXTPPropertyGridPaintManager |
m_clrSplitter | CXTPPropertyGridPaintManager |
m_nHelpHeight | CXTPPropertyGridPaintManager | protected
m_nItemsBorderHeight | CXTPPropertyGridPaintManager | protected
m_nSplitterHeight | CXTPPropertyGridPaintManager | protected
m_nVerbsHeight | CXTPPropertyGridPaintManager | protected
m_pGrid | CXTPPropertyGridPaintManager | protected
m_pMetrics | CXTPPropertyGridPaintManager | protected
m_themeButton | CXTPPropertyGridPaintManager |
m_themeCombo | CXTPPropertyGridPaintManager |
m_themeTree | CXTPPropertyGridPaintManager |
MeasureItem(LPMEASUREITEMSTRUCT lpMeasureItemStruct) | CXTPPropertyGridPaintManager | virtual
OnNcCalcSize(RECT &rc) | CXTPPropertyGridPaintManager | virtual
RefreshMetrics() | CXTPPropertyGridOfficeXPTheme | virtual
SetItemsBorderHeight(int nHeight) | CXTPPropertyGridPaintManager | virtual
SetThinSplitter(BOOL bThinSplitter) | CXTPPropertyGridPaintManager | virtual
~CXTPPropertyGridPaintManager() | CXTPPropertyGridPaintManager | virtual


Toolkit Pro: XTPChart3dPyramidDiagram.h Source File

  • Source
  • Chart
  • Styles
  • Pyramid
  • 3D
XTPChart3dPyramidDiagram.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHART3DPYRAMIDDIAGRAM_H__)
24# define __XTPCHART3DPYRAMIDDIAGRAM_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartDeviceContext;
34class CXTPChartElementView;
35class CXTPChartDiagramView;
36
42class _XTP_EXT_CLASS CXTPChart3dPyramidDiagram : public CXTPChart3dPyramidDiagramBase
43{
44 DECLARE_SERIAL(CXTPChart3dPyramidDiagram);
45
46public:
51 CXTPChart3dPyramidDiagram();
52
53public:
64 virtual CXTPChartDiagramView* CreateView(CXTPChartDeviceContext* pDC,
65 CXTPChartElementView* pParent);
66
67# ifdef _XTP_ACTIVEX
68public:
70 DECLARE_DISPATCH_MAP()
71 DECLARE_INTERFACE_MAP()
72 DECLARE_OLETYPELIB_EX(CXTPChart3dPyramidDiagram);
73 DECLARE_OLECREATE_EX(CXTPChart3dPyramidDiagram)
75# endif
76};
78# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
79#endif //#if !defined(__XTPCHART3DPYRAMIDDIAGRAM_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChart3dPyramidDiagram
This class abstracts the pyramid diagram.
Definition XTPChart3dPyramidDiagram.h:43
CXTPChart3dPyramidDiagram::CXTPChart3dPyramidDiagram
CXTPChart3dPyramidDiagram()
Constructs a CXTPChart3dPyramidDiagram object.
CXTPChart3dPyramidDiagram::CreateView
virtual CXTPChartDiagramView * CreateView(CXTPChartDeviceContext *pDC, CXTPChartElementView *pParent)
Call this function to create the view of the pyramid diagram.
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartDiagramView
This class represents the view of a chart diagram, which is a kind of CXTPChartElementView.
Definition XTPChartDiagramView.h:49
CXTPChartElementView
This class represents the view of a chart element.
Definition XTPChartElementView.h:47
CXTPChartPyramidDiagramBase
This class abstracts the pyramid diagram.
Definition XTPChartPyramidDiagramBase.h:55


Toolkit Pro: Member List

CXTPChartAreaSeriesView Member List

This is the complete list of members for CXTPChartAreaSeriesView, including all inherited members.

AddChildView(CXTPChartElementView *pChildView) | CXTPChartElementView |
CreateDeviceCommand(CXTPChartDeviceContext *pDC) | CXTPChartAreaSeriesView | protectedvirtual
CreateLegendDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcBounds) | CXTPChartAreaSeriesView | protectedvirtual
CreateSeriesPointView(CXTPChartDeviceContext *pDC, CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView) | CXTPChartAreaSeriesView | protected
CXTPChartAreaSeriesView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView) | CXTPChartAreaSeriesView |
CXTPChartElementView(CXTPChartElementView *pParentView) | CXTPChartElementView |
CXTPChartElementView(CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartElementView |
CXTPChartElementView(CXTPChartContainer *pContainer) | CXTPChartElementView |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
GetActualColor() const | CXTPChartAreaSeriesView | protected
GetActualColor2() const | CXTPChartAreaSeriesView | protected
GetAt(int nIndex) const | CXTPChartElementView |
GetBorderActualColor() const | CXTPChartAreaSeriesView | protected
GetBounds() const | CXTPChartElementView |
GetBounds(BOOL bIncludingChildren) const | CXTPChartElementView |
GetChildren() | CXTPChartElementView |
GetCount() const | CXTPChartElementView |
GetParentView() const | CXTPChartElementView |
Is3D() const | CXTPChartObject |
m_arrChildren | CXTPChartElementView | protected
m_pContainer | CXTPChartElementView | protected
m_pParentView | CXTPChartElementView | protected
m_rcBounds | CXTPChartElementView | protected
~CXTPChartElementView() | CXTPChartElementView | protectedvirtual
~CXTPChartLegendItemView() | CXTPChartLegendItemView | inlinevirtual


Toolkit Pro: Member List

CXTPDockingPaneOffice2007VisioTheme Member List

This is the complete list of members for CXTPDockingPaneOffice2007VisioTheme, including all inherited members.

AdjustCaptionRect(const CXTPDockingPaneTabbedContainer *pPane, CRect &rc) | CXTPDockingPaneOffice2002VisioTheme | virtual
CXTPDockingPaneVisualStudio2003Theme::AdjustCaptionRect(const CXTPDockingPaneSidePanel *pPane, CRect &rc) | CXTPDockingPanePaintManager | virtual
AdjustClientRect(CXTPDockingPaneSidePanel *pPane, CRect &rect) | CXTPDockingPanePaintManager | virtual
AdjustClientRect(CXTPDockingPaneTabbedContainer *pPane, CRect &rect, BOOL bApply) | CXTPDockingPanePaintManager | virtual
ClipAndAddEllipsisIfNeeded(CDC *pDC, CString &strTitle, int nCaptionWidth) const | CXTPDockingPanePaintManager | protected
CXTPCmdTarget() | CXTPCmdTarget |
CXTPDockingPaneDefaultTheme() | CXTPDockingPaneDefaultTheme |
CXTPDockingPaneGripperedTheme() | CXTPDockingPaneGripperedTheme |
CXTPDockingPaneOffice2002VisioTheme() | CXTPDockingPaneOffice2002VisioTheme |
CXTPDockingPaneOffice2003VisioTheme() | CXTPDockingPaneOffice2003VisioTheme |
CXTPDockingPaneOffice2007VisioTheme() | CXTPDockingPaneOffice2007VisioTheme |
CXTPDockingPanePaintManager() | CXTPDockingPanePaintManager | protected
CXTPDockingPaneVisualStudio2003Theme() | CXTPDockingPaneVisualStudio2003Theme |
DrawAutoHidePanel(CDC *pDC, CRect rc, XTPDockingPaneDirection direction) | CXTPDockingPanePaintManager | virtual
DrawCaption(CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc) | CXTPDockingPaneOffice2002VisioTheme | virtual
DrawCaptionButton(CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton) | CXTPDockingPanePaintManager | virtual
DrawCaptionButtonEntry(CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton, CSize szOffset) | CXTPDockingPanePaintManager | protectedvirtual
DrawCaptionButtonEntry(CDC *pDC, CXTPDockingPaneCaptionButton *pButton, CPoint pt, COLORREF clrButton) | CXTPDockingPanePaintManager | protectedvirtual
DrawCaptionButtons(CDC *pDC, CXTPDockingPaneCaptionButtons *pButtons, CRect &rcCaption, COLORREF clr, int nButtonSize, int nButtonGap, BOOL bVertical=FALSE) | CXTPDockingPanePaintManager | virtual
DrawCaptionPart(CDC *pDC, CXTPDockingPaneBase *pPane, CRect rcCaption, const CString &strTitle, BOOL bActive, BOOL bVertical) | CXTPDockingPaneVisualStudio2003Theme | protectedvirtual
DrawCaptionText(CDC *pDC, const CString &strTitle, CRect rc, BOOL bVertical, BOOL bCalcWidth=FALSE) | CXTPDockingPanePaintManager |
DrawFloatingFrame(CDC *pDC, CXTPDockingPaneMiniWnd *pPane, CRect rc) | CXTPDockingPaneOffice2002VisioTheme | virtual
DrawPane(CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc) | CXTPDockingPaneOffice2002VisioTheme | virtual
DrawSidePanel(CDC *pDC, CXTPDockingPaneSidePanel *pPane, CRect rc) | CXTPDockingPaneDefaultTheme | virtual
DrawSplitter(CDC *pDC, CXTPDockingPaneSplitterWnd *pSplitter) | CXTPDockingPanePaintManager | virtual
FillCaptionPart(CDC *pDC, CXTPDockingPaneBase *pPane, CRect rcCaption, BOOL bActive, BOOL bVertical) | CXTPDockingPaneVisualStudio2003Theme | protectedvirtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCaptionButtonStyle() const | CXTPDockingPanePaintManager |
GetCaptionGripperRect(const CXTPDockingPaneTabbedContainer *pPane) | CXTPDockingPanePaintManager | virtual
GetCaptionHeight() const | CXTPDockingPanePaintManager |
GetCaptionRect(const CXTPDockingPaneTabbedContainer *pPane, CRect &rc) | CXTPDockingPanePaintManager | virtual
GetCurrentSystemTheme() const | CXTPDockingPanePaintManager |
GetCustomTitleBrush(BOOL bActive, BOOL bVertical) const | CXTPDockingPanePaintManager |
GetPaneCaptionRect(const CXTPDockingPaneSidePanel *pPane) | CXTPDockingPanePaintManager | virtual
GetPanelPaintManager() const | CXTPDockingPanePaintManager |
GetSplitterStyle() const | CXTPDockingPanePaintManager |
GetTabPaintManager() const | CXTPDockingPanePaintManager |
GetTabsHeight() const | CXTPDockingPanePaintManager |
GetXtremeColor(UINT nIndex) | CXTPDockingPanePaintManager |
Line(CDC *pDC, int x0, int y0, int x1, int y1, int nPen) | CXTPDockingPanePaintManager |
Line(CDC *pDC, int x0, int y0, int x1, int y1) | CXTPDockingPanePaintManager |
m_arrColor | CXTPDockingPanePaintManager | protected
m_bDestroyCustomTitleBrushes | CXTPDockingPanePaintManager | protected
m_bDrawCaptionIcon | CXTPDockingPanePaintManager |
m_bDrawSingleTab | CXTPDockingPanePaintManager |
m_bGradientCaption | CXTPDockingPaneVisualStudio2003Theme | protected
m_bHighlightActiveCaption | CXTPDockingPanePaintManager |
m_bLunaTheme | CXTPDockingPanePaintManager | protected
m_bShowCaption | CXTPDockingPanePaintManager |
m_bUseBoldCaptionFont | CXTPDockingPanePaintManager |
m_bUseOfficeFont | CXTPDockingPanePaintManager | protected
m_bUseStandardFont | CXTPDockingPanePaintManager | protected
m_clrActiveCaption | CXTPDockingPanePaintManager |
m_clrActiveCaptionText | CXTPDockingPanePaintManager |
m_clrBackground | CXTPDockingPanePaintManager |
m_clrDisabledCaptionText | CXTPDockingPanePaintManager |
m_clrNormalCaption | CXTPDockingPanePaintManager |
m_clrNormalCaptionText | CXTPDockingPanePaintManager |
m_clrSplitter | CXTPDockingPanePaintManager |
m_clrSplitterGradient | CXTPDockingPanePaintManager |
m_clrSplitterGripper | CXTPDockingPanePaintManager |
m_dwSplitterStyle | CXTPDockingPanePaintManager | protected
m_hbrActiveTitleHorz | CXTPDockingPanePaintManager | protected
m_hbrActiveTitleVert | CXTPDockingPanePaintManager | protected
m_hbrInactiveTitleHorz | CXTPDockingPanePaintManager | protected
m_hbrInactiveTitleVert | CXTPDockingPanePaintManager | protected
m_nCaptionButtonStyle | CXTPDockingPanePaintManager | protected
m_nCaptionFontGap | CXTPDockingPanePaintManager | protected
m_nSplitterIndent | CXTPDockingPanePaintManager |
m_nSplitterSize | CXTPDockingPanePaintManager |
m_nTabsHeight | CXTPDockingPanePaintManager | protected
m_nTitleHeight | CXTPDockingPanePaintManager | protected
m_pPanelPaintManager | CXTPDockingPanePaintManager | protected
m_pTabPaintManager | CXTPDockingPanePaintManager | protected
m_rcCaptionMargin | CXTPDockingPanePaintManager | protected
m_strOfficeFont | CXTPDockingPanePaintManager | protected
m_systemTheme | CXTPDockingPanePaintManager | protected
m_themeButton | CXTPDockingPanePaintManager | protected
m_themeCurrent | CXTPDockingPanePaintManager | protected
m_themeExplorer | CXTPDockingPanePaintManager | protected
m_themeRebar | CXTPDockingPanePaintManager | protected
m_themeToolbar | CXTPDockingPanePaintManager | protected
m_themeWindow | CXTPDockingPanePaintManager | protected
m_xtpFontTitle | CXTPDockingPanePaintManager | protected
m_xtpFontTitleVertical | CXTPDockingPanePaintManager | protected
Pixel(CDC *pDC, int xPos, int yPos, int nPen) | CXTPDockingPanePaintManager |
Rectangle(CDC *pDC, CRect rc, int nPenEntry, int nPenBorder) | CXTPDockingPanePaintManager |
RefreshMetrics() | CXTPDockingPaneOffice2002VisioTheme | virtual
SetCaptionButtonStyle(XTPDockingPaneCaptionButtonStyle nStyle) | CXTPDockingPanePaintManager |
SetCaptionFontIndirect(LOGFONT *pLogFont, BOOL bUseStandardFont=FALSE) | CXTPDockingPanePaintManager |
SetColors(int cElements, CONST INT *lpaElements, CONST COLORREF *lpaRgbValues) | CXTPDockingPanePaintManager |
SetCustomTitleBrushes(HBRUSH hbrActiveTitleHorz, HBRUSH hbrInactiveTitleHorz=NULL, HBRUSH hbrActiveTitleVert=NULL, HBRUSH hbrInactiveTitleVert=NULL, BOOL bDestroyOnCleanup=FALSE) | CXTPDockingPanePaintManager |
SetLunaTheme(XTPCurrentSystemTheme systemTheme) | CXTPDockingPanePaintManager |
SetPanelPaintManager(CXTPTabPaintManager *pManager) | CXTPDockingPanePaintManager |
SetSplitterStyle(DWORD dwStyle) | CXTPDockingPanePaintManager |
SetTabPaintManager(CXTPTabPaintManager *pManager) | CXTPDockingPanePaintManager |
UseOfficeFont(BOOL bUseOfficeFont) | CXTPDockingPanePaintManager |
~CXTPDockingPanePaintManager() | CXTPDockingPanePaintManager | protectedvirtual


Toolkit Pro: Member List

CXTPChartTitle Member List

This is the complete list of members for CXTPChartTitle, including all inherited members.

CXTPChartElement() | CXTPChartElement |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartTitle() | CXTPChartTitle |
DoPropExchange(CXTPPropExchange *pPX) | CXTPChartTitle | virtual
GetActualTextColor() const | CXTPChartTitle |
GetAlignment() const | CXTPChartTitle |
GetAntialiasing() const | CXTPChartTitle | virtual
GetAppearance() const | CXTPChartElement |
GetContent() const | CXTPChartElement |
GetDocking() const | CXTPChartTitle |
GetFont() const | CXTPChartTitle | virtual
GetIndent() const | CXTPChartTitle |
GetOwner() const | CXTPChartElement |
GetText() const | CXTPChartTitle |
GetTextAngle() const | CXTPChartTitle |
GetTextColor() const | CXTPChartTitle |
Is3D() const | CXTPChartObject |
IsVisible() const | CXTPChartTitle |
m_bAntialiasing | CXTPChartTitle | protected
m_bVisible | CXTPChartTitle | protected
m_clrTextColor | CXTPChartTitle | protected
m_nAlignment | CXTPChartTitle | protected
m_nDocking | CXTPChartTitle | protected
m_nIndent | CXTPChartTitle | protected
m_nInnerIndent | CXTPChartTitle | protected
m_pFont | CXTPChartTitle | protected
m_strText | CXTPChartTitle | protected
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartElement | virtual
Release() | CXTPChartElement | virtual
SetAlignment(XTPChartStringAlignment nAlignment) | CXTPChartTitle |
SetAntialiasing(BOOL bAntialiasing) | CXTPChartTitle |
SetDocking(XTPChartDocking nDocking) | CXTPChartTitle |
SetFont(CXTPChartFont *pFont) | CXTPChartTitle |
SetIndent(int nIndent) | CXTPChartTitle |
SetText(LPCTSTR lpszTitle) | CXTPChartTitle |
SetTextColor(const CXTPChartColor &clrTextColor) | CXTPChartTitle |
SetVisible(BOOL bVisible) | CXTPChartTitle |
~CXTPChartElement() | CXTPChartElement | virtual
~CXTPChartTitle() | CXTPChartTitle | virtual


Toolkit Pro: XTPChart3dPieSeriesLabel.h Source File

  • Source
  • Chart
  • Styles
  • Pie
  • 3D
XTPChart3dPieSeriesLabel.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHART3DPIESERIESLABEL_H__)
24# define __XTPCHART3DPIESERIESLABEL_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartSeriesView;
34class CXTPChartPieSeriesPointViewBase;
35class CXTPChartPieSeriesStyleBase;
36class CXTPChart3dPieSeriesPointView;
37class CXTPChart3dPieSeriesStyle;
38
44class _XTP_EXT_CLASS CXTPChart3dPieSeriesLabel : public CXTPChartPieSeriesLabelBase
45{
46 DECLARE_SERIAL(CXTPChart3dPieSeriesLabel);
47
48public:
53 CXTPChart3dPieSeriesLabel();
54
55protected:
67 virtual CXTPChartElementView* CreateView(CXTPChartDeviceContext* pDC,
68 CXTPChartSeriesPointView* pPointView,
69 CXTPChartElementView* pParentView);
70};
71
76class _XTP_EXT_CLASS CXTPChart3dPieSeriesLabelView : public CXTPChartPieSeriesLabelViewBase
77{
78public:
87 CXTPChart3dPieSeriesLabelView(CXTPChartSeriesLabel* pLabel,
88 CXTPChartSeriesPointView* pPointView,
89 CXTPChartElementView* pParentView);
90
95 ~CXTPChart3dPieSeriesLabelView();
96
106 virtual CXTPChartDeviceCommand* CreateTranspositionDeviceCommand(CXTPChartDeviceContext* pDC);
107
117 virtual CXTPChartDeviceCommand* CreateDeviceCommand(CXTPChartDeviceContext* pDC);
118
128 virtual CXTPChartDeviceCommand* CreateConnectorDeviceCommand(CXTPChartDeviceContext* pDC);
129
140 const CXTPPoint3d* GetConnectorStartPoint() const;
141
151 void SetConnectorStartPoint(const CXTPPoint3d& point);
152
163 const CXTPPoint3d* GetConnectorBendPoint() const;
164
174 void SetConnectorBendPoint(const CXTPPoint3d& point);
175
186 const CXTPPoint3d* GetConnectorEndPoint() const;
187
197 void SetConnectorEndPoint(const CXTPPoint3d& point);
198
209 const CPoint* GetLabelAnchorPoint() const;
210
220 void SetLabelAnchorPoint(CPoint ptAnchor);
221
232 const CPoint* GetLabelAnchorOrigin() const;
233
243 void SetLabelAnchorOrigin(CPoint ptAnchorOrigin);
244
252 void SetLeftDirected();
253
264 BOOL IsLeftDirected() const;
265
273 void SetRightDirected();
274
285 BOOL IsRightDirected() const;
286
297 BOOL IsConnectorVisible() const;
298
309 void SetConnectorVisible(BOOL bVisible = TRUE);
310
311protected:
312 CXTPPoint3d* m_ptStart;
313 CXTPPoint3d* m_ptBend;
314 CXTPPoint3d* m_ptEnd;
315 CPoint m_ptLabelAnchor;
316 CPoint m_ptLabelAnchorOrigin;
317 CXTPChart3dPieSeriesPointView* m_p3dPointView;
318 BOOL m_bLeftDirected;
319 BOOL m_bConnectorVisible;
321 friend class CXTPChart3dPieSeriesLabelsView;
322};
323
324AFX_INLINE const CXTPPoint3d* CXTPChart3dPieSeriesLabelView::GetConnectorStartPoint() const
325{
326 return m_ptStart;
327}
328AFX_INLINE const CXTPPoint3d* CXTPChart3dPieSeriesLabelView::GetConnectorBendPoint() const
329{
330 return m_ptBend;
331}
332AFX_INLINE const CXTPPoint3d* CXTPChart3dPieSeriesLabelView::GetConnectorEndPoint() const
333{
334 return m_ptEnd;
335}
336AFX_INLINE void CXTPChart3dPieSeriesLabelView::SetLabelAnchorPoint(CPoint ptAnchor)
337{
338 m_ptLabelAnchor = ptAnchor;
339}
340AFX_INLINE void CXTPChart3dPieSeriesLabelView::SetLabelAnchorOrigin(CPoint ptAnchorOrigin)
341{
342 m_ptLabelAnchorOrigin = ptAnchorOrigin;
343}
344AFX_INLINE void CXTPChart3dPieSeriesLabelView::SetLeftDirected()
345{
346 m_bLeftDirected = TRUE;
347}
348AFX_INLINE BOOL CXTPChart3dPieSeriesLabelView::IsLeftDirected() const
349{
350 return m_bLeftDirected;
351}
352AFX_INLINE void CXTPChart3dPieSeriesLabelView::SetRightDirected()
353{
354 m_bLeftDirected = FALSE;
355}
356AFX_INLINE BOOL CXTPChart3dPieSeriesLabelView::IsRightDirected() const
357{
358 return !m_bLeftDirected;
359}
360AFX_INLINE BOOL CXTPChart3dPieSeriesLabelView::IsConnectorVisible() const
361{
362 return m_bConnectorVisible;
363}
364AFX_INLINE void CXTPChart3dPieSeriesLabelView::SetConnectorVisible(BOOL bVisible /*= TRUE*/)
365{
366 m_bConnectorVisible = bVisible;
367}
368
373class _XTP_EXT_CLASS CXTPChart3dPieSeriesLabelsView : public CXTPChartPieSeriesLabelsViewBase
374{
375public:
382 CXTPChart3dPieSeriesLabelsView(CXTPChartElementView* pParentView);
383
384public:
395 virtual CXTPChartDeviceCommand* CreateDeviceCommand(CXTPChartDeviceContext* pDC);
396
401 virtual void ResolveOverlapping();
402
403private:
404 CXTPChart3dPieSeriesStyle* GetStyle() const;
405};
407# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
408#endif //#if !defined(__XTPCHART3DPIESERIESLABEL_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChart3dPieSeriesLabel
CXTPChartPieSeriesLabelBase is a kind of CXTPChart3dPieSeriesLabel.
Definition XTPChart3dPieSeriesLabel.h:45
CXTPChart3dPieSeriesLabel::CXTPChart3dPieSeriesLabel
CXTPChart3dPieSeriesLabel()
Constructs a CXTPChart3dPieSeriesLabel object.
CXTPChart3dPieSeriesLabel::CreateView
virtual CXTPChartElementView * CreateView(CXTPChartDeviceContext *pDC, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView)
This function creates the view of the pie series.
CXTPChart3dPieSeriesLabelView
Represents a series label view object.
Definition XTPChart3dPieSeriesLabel.h:77
CXTPChart3dPieSeriesLabelView::m_p3dPointView
CXTPChart3dPieSeriesPointView * m_p3dPointView
Point view.
Definition XTPChart3dPieSeriesLabel.h:317
CXTPChart3dPieSeriesLabelView::~CXTPChart3dPieSeriesLabelView
~CXTPChart3dPieSeriesLabelView()
Handles view object destruction.
CXTPChart3dPieSeriesLabelView::SetLeftDirected
void SetLeftDirected()
Makes the label left directed.
Definition XTPChart3dPieSeriesLabel.h:344
CXTPChart3dPieSeriesLabelView::IsConnectorVisible
BOOL IsConnectorVisible() const
Determines if the connector is visible.
Definition XTPChart3dPieSeriesLabel.h:360
CXTPChart3dPieSeriesLabelView::SetConnectorBendPoint
void SetConnectorBendPoint(const CXTPPoint3d &point)
Sets the connector bend point.
CXTPChart3dPieSeriesLabelView::IsRightDirected
BOOL IsRightDirected() const
Determies if the label is right directed.
Definition XTPChart3dPieSeriesLabel.h:356
CXTPChart3dPieSeriesLabelView::m_ptLabelAnchor
CPoint m_ptLabelAnchor
Label anchor point.
Definition XTPChart3dPieSeriesLabel.h:315
CXTPChart3dPieSeriesLabelView::m_ptEnd
CXTPPoint3d * m_ptEnd
Connector end point or NULL if not set.
Definition XTPChart3dPieSeriesLabel.h:314
CXTPChart3dPieSeriesLabelView::SetLabelAnchorOrigin
void SetLabelAnchorOrigin(CPoint ptAnchorOrigin)
Sets the label anchor origin point.
Definition XTPChart3dPieSeriesLabel.h:340
CXTPChart3dPieSeriesLabelView::SetLabelAnchorPoint
void SetLabelAnchorPoint(CPoint ptAnchor)
Sets the label anchor point.
Definition XTPChart3dPieSeriesLabel.h:336
CXTPChart3dPieSeriesLabelView::m_ptStart
CXTPPoint3d * m_ptStart
Connector start point or NULL if not set.
Definition XTPChart3dPieSeriesLabel.h:312
CXTPChart3dPieSeriesLabelView::SetConnectorStartPoint
void SetConnectorStartPoint(const CXTPPoint3d &point)
Sets the connector start point.
CXTPChart3dPieSeriesLabelView::CreateConnectorDeviceCommand
virtual CXTPChartDeviceCommand * CreateConnectorDeviceCommand(CXTPChartDeviceContext *pDC)
Creates a label connector drawing device command object.
CXTPChart3dPieSeriesLabelView::CreateTranspositionDeviceCommand
virtual CXTPChartDeviceCommand * CreateTranspositionDeviceCommand(CXTPChartDeviceContext *pDC)
Creates a label transposition device command object.
CXTPChart3dPieSeriesLabelView::IsLeftDirected
BOOL IsLeftDirected() const
Determies if the label is left directed.
Definition XTPChart3dPieSeriesLabel.h:348
CXTPChart3dPieSeriesLabelView::GetLabelAnchorOrigin
const CPoint * GetLabelAnchorOrigin() const
Obtains a previously set label anchor origin point.
CXTPChart3dPieSeriesLabelView::CreateDeviceCommand
virtual CXTPChartDeviceCommand * CreateDeviceCommand(CXTPChartDeviceContext *pDC)
Creates a label drawing device command object.
CXTPChart3dPieSeriesLabelView::SetConnectorEndPoint
void SetConnectorEndPoint(const CXTPPoint3d &point)
Sets the connector end point.
CXTPChart3dPieSeriesLabelView::GetLabelAnchorPoint
const CPoint * GetLabelAnchorPoint() const
Obtains a previously set label anchor point.
CXTPChart3dPieSeriesLabelView::SetConnectorVisible
void SetConnectorVisible(BOOL bVisible=TRUE)
Sets the connector visibility.
Definition XTPChart3dPieSeriesLabel.h:364
CXTPChart3dPieSeriesLabelView::m_bConnectorVisible
BOOL m_bConnectorVisible
TRUE if connector is visible.
Definition XTPChart3dPieSeriesLabel.h:319
CXTPChart3dPieSeriesLabelView::GetConnectorEndPoint
const CXTPPoint3d * GetConnectorEndPoint() const
Obtains a previously set connector end point.
Definition XTPChart3dPieSeriesLabel.h:332
CXTPChart3dPieSeriesLabelView::CXTPChart3dPieSeriesLabelView
CXTPChart3dPieSeriesLabelView(CXTPChartSeriesLabel *pLabel, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView)
Constructs a view object.
CXTPChart3dPieSeriesLabelView::SetRightDirected
void SetRightDirected()
Makes the label right directed.
Definition XTPChart3dPieSeriesLabel.h:352
CXTPChart3dPieSeriesLabelView::m_ptBend
CXTPPoint3d * m_ptBend
Connector bend point or NULL if not set.
Definition XTPChart3dPieSeriesLabel.h:313
CXTPChart3dPieSeriesLabelView::GetConnectorStartPoint
const CXTPPoint3d * GetConnectorStartPoint() const
Obtains a previously set connector start point.
Definition XTPChart3dPieSeriesLabel.h:324
CXTPChart3dPieSeriesLabelView::m_bLeftDirected
BOOL m_bLeftDirected
TRUE if label is to be left directed.
Definition XTPChart3dPieSeriesLabel.h:318
CXTPChart3dPieSeriesLabelView::m_ptLabelAnchorOrigin
CPoint m_ptLabelAnchorOrigin
Label anchor point origin.
Definition XTPChart3dPieSeriesLabel.h:316
CXTPChart3dPieSeriesLabelView::GetConnectorBendPoint
const CXTPPoint3d * GetConnectorBendPoint() const
Obtains a previously set connector bend point.
Definition XTPChart3dPieSeriesLabel.h:328
CXTPChart3dPieSeriesLabelsView
Represents a view object for all pie series labels.
Definition XTPChart3dPieSeriesLabel.h:374
CXTPChart3dPieSeriesLabelsView::ResolveOverlapping
virtual void ResolveOverlapping()
Resolves label overlapping in an implementation specific way.
CXTPChart3dPieSeriesLabelsView::CXTPChart3dPieSeriesLabelsView
CXTPChart3dPieSeriesLabelsView(CXTPChartElementView *pParentView)
Constructs a view object.
CXTPChart3dPieSeriesLabelsView::CreateDeviceCommand
virtual CXTPChartDeviceCommand * CreateDeviceCommand(CXTPChartDeviceContext *pDC)
Creates view drawing device command for the device context specified.
CXTPChart3dPieSeriesPointView
This class abstracts the view of a pie series point.
Definition XTPChart3dPieSeriesPointView.h:49
CXTPChart3dPieSeriesStyle
This class abstracts the pie series style.
Definition XTPChart3dPieSeriesStyle.h:48
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartElementView
This class represents the view of a chart element.
Definition XTPChartElementView.h:47
CXTPChartPieSeriesLabelBase
CXTPChartPieSeriesLabelBase is a kind of CXTPChartSeriesLabel.
Definition XTPChartPieSeriesLabelBase.h:56
CXTPChartPieSeriesLabelBase::GetStyle
CXTPChartPieSeriesStyleBase * GetStyle() const
Call this function to get the basic style of the pie series.
CXTPChartPieSeriesLabelViewBase
Defines a base class interface for series label view.
Definition XTPChartPieSeriesLabelBase.h:157
CXTPChartPieSeriesLabelsViewBase
Defines a base class interface for series label collection view.
Definition XTPChartPieSeriesLabelBase.h:213
CXTPChartPieSeriesPointViewBase
This class abstracts the view of a pie series point.
Definition XTPChartPieSeriesPointViewBase.h:50
CXTPChartPieSeriesStyleBase
This class abstracts the basic style of a pie serie.This class is a kind of CXTPChartSeriesStyle.
Definition XTPChartPieSeriesStyleBase.h:48
CXTPChartSeriesLabel
This class abstracts the label of a series.
Definition XTPChartSeriesLabel.h:49
CXTPChartSeriesPointView
Represents chart series point view.
Definition XTPChartSeriesPointView.h:48
CXTPPoint3T< double >


Toolkit Pro: Member List

CXTPTrackThemeResource Member List

This is the complete list of members for CXTPTrackThemeResource, including all inherited members.

CalcColumnHeight(CDC *pDC, CXTPGridColumn *pColumn, int nTotalWidth=0) | CXTPGridPaintManager | protectedvirtual
CalculateRowHeight(CDC *pDC, const CString &strText, int nMaxWidth, BOOL bWordBreak=TRUE) | CXTPGridPaintManager | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPGridPaintManager() | CXTPGridPaintManager |
CXTPTrackPaintManager() | CXTPTrackPaintManager |
CXTPTrackThemeResource() | CXTPTrackThemeResource |
DrawBitmap(CDC *pDC, CXTPGridControl *pControl, CRect rcColumn, int iImage) | CXTPGridPaintManager | virtual
DrawCollapsedBitmap(CDC *pDC, const CXTPGridRow *pRow, CRect &rcBitmap) | CXTPTrackThemeResource | virtual
DrawColumn(CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn, BOOL bDrawExternal=FALSE, int nShadowWidth=0) | CXTPGridPaintManager | virtual
DrawColumnBackground(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, BOOL &bColumnPressed, BOOL &bDraggingFromHeader, CXTPGridHeader *pHeader=NULL) | CXTPTrackThemeResource | protectedvirtual
DrawColumnFooter(CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn) | CXTPGridPaintManager | virtual
DrawColumnFooterDivider(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn) | CXTPTrackThemeResource | virtual
DrawColumnIcon(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, CRect rcIcon, int iIcon) | CXTPGridPaintManager | virtual
DrawColumnText(CDC *pDC, CRect rcText, CString strCaption, int nHeaderAlignment, BOOL bIsHeader, BOOL bColumnPressed) | CXTPTrackThemeResource | virtual
DrawConnector(CDC *pDC, CPoint ptFrom, CPoint ptTo) | CXTPGridPaintManager |
DrawFocusedRow(CDC *pDC, CRect rcRow) | CXTPGridPaintManager | virtual
DrawFreezeColsDivider(CDC *pDC, const CRect &rc, CXTPGridControl *pControl, CXTPGridRow *pRow=NULL) | CXTPGridPaintManager | virtual
DrawGlyph(CDC *pDC, CRect rcColumn, int iImage) | CXTPGridPaintManager | virtual
DrawGrid(CDC *pDC, XTPGridOrientation orientation, CRect rcGrid) | CXTPGridPaintManager | virtual
DrawGridPattern(CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush) | CXTPGridPaintManager | protectedvirtual
DrawGridPattern(CDC *pDC, CXTPBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush) | CXTPGridPaintManager | protectedvirtual
DrawGridPattern(CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr) | CXTPGridPaintManager | protectedvirtual
DrawGroupRow(CDC *pDC, CXTPGridGroupRow *pRow, CRect rcRow, XTP_GRIDRECORDITEM_METRICS *pMetrics) | CXTPGridPaintManager | virtual
DrawHorizontalLine(CDC *pDC, int xPos, int yPos, int cx, COLORREF clr) | CXTPGridPaintManager |
DrawInplaceButton(CDC *pDC, CXTPGridInplaceButton *pButton) | CXTPGridPaintManager | virtual
DrawInplaceButtonFrame(CDC *pDC, CXTPGridInplaceButton *pButton) | CXTPGridPaintManager | protectedvirtual
DrawInplaceButtonIcon(CDC *pDC, CXTPGridInplaceButton *pButton) | CXTPGridPaintManager | protectedvirtual
DrawInplaceComboButton(CDC *pDC, CRect *pRc) | CXTPGridPaintManager | virtual
DrawInplaceExpandButton(CDC *pDC, CRect *pRc) | CXTPGridPaintManager | virtual
DrawInplaceSpinButton(CDC *pDC, CRect *pRc) | CXTPGridPaintManager | virtual
DrawItemBitmap(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CRect &rcItem, int nImage) | CXTPGridPaintManager | virtual
DrawItemCaption(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics) | CXTPGridPaintManager | virtual
DrawItemControl(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CXTPGridRecordItemControl *pControl, CRect &rcItem) | CXTPGridPaintManager | virtual
DrawLink(int *pnCurrDrawPos, XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CXTPGridHyperlink *pHyperlink, CString strText, CRect rcLink, int nFlag, BOOL bTrim=FALSE) | CXTPGridPaintManager | protectedvirtual
DrawMarkers(CDC *pDC) | CXTPTrackPaintManager | virtual
DrawMultiLineText(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, BOOL bWordBreak=TRUE) | CXTPGridPaintManager | protectedvirtual
DrawNoGroupByText(CDC *pDC, CRect rcItem) | CXTPTrackThemeResource | virtual
DrawRowNumber(CDC *pDC, CRect rcNumber, CXTPGridRow *pRow) | CXTPGridPaintManager | virtual
DrawSectionDivider(CDC *pDC, const CRect &rc, XTPGridSectionDividerPosition dividerPosition, XTPGridSectionDividerStyle dividerStyle, CXTPPaintManagerColor dividerColor) | CXTPTrackThemeResource |
DrawShellIcon(CDC *pDC, CRect rcColumn, int iImage) | CXTPGridPaintManager | virtual
DrawSingleLineText(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nStartPos, int nEndPos, int nActualWidth) | CXTPGridPaintManager | protectedvirtual
DrawString(int *pnCurrDrawPos, CDC *pDC, const CString &strDraw, CRect rcDraw, UINT nFormat) | CXTPGridPaintManager | protectedvirtual
DrawTextLine(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nFlag, int &nCharCounter, int &nHyperlinkCounter) | CXTPGridPaintManager | protectedvirtual
DrawTimeLine(CDC *pDC) | CXTPTrackPaintManager | virtual
DrawTrackHeader(CDC *pDC) | CXTPTrackPaintManager | virtual
DrawTreeStructure(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CRect rcItem, CSize sizeGlyph) | CXTPGridPaintManager | virtual
DrawTriangle(CDC *pDC, CRect rcTriangle, BOOL bToDown, int nShadowWidth, BOOL bColumnPressed) | CXTPTrackThemeResource | virtual
CXTPTrackPaintManager::DrawTriangle(CDC *pDC, CRect rcTriangle, BOOL bToDown, BOOL bDraggingFromHeader, int nShadowWidth, BOOL bColumnPressed) | CXTPGridPaintManager | virtual
DrawVerticalLine(CDC *pDC, int xPos, int yPos, int cy, COLORREF clr) | CXTPGridPaintManager |
DrawVerticalTimeLineMarker(CDC *pDC, int xPos, CXTPGridControl *pControl, COLORREF color=RGB(0, 255, 0)) | CXTPGridPaintManager | virtual
EnablePreviewMode(BOOL bIsPreviewMode) | CXTPGridPaintManager |
FillFooter(CDC *pDC, CRect rcFooter) | CXTPTrackThemeResource | virtual
FillGroupByControl(CDC *pDC, CRect &rcGroupBy) | CXTPGridPaintManager | virtual
FillGroupRowMetrics(CXTPGridGroupRow *pRow, XTP_GRIDRECORDITEM_METRICS *pMetrics, BOOL bPrinting) | CXTPGridPaintManager | virtual
FillHeaderControl(CDC *pDC, CRect rcHeader) | CXTPGridPaintManager | virtual
FillIndent(CDC *pDC, CRect rcRow) | CXTPGridPaintManager | virtual
FillItemShade(CDC *pDC, CRect rcItem) | CXTPGridPaintManager | virtual
FillRow(CDC *pDC, CXTPGridRow *pRow, CRect rcRow) | CXTPGridPaintManager | virtual
FindRowAdjacentToMerged(const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, BOOL bUpward) | CXTPGridPaintManager |
FindRowAdjacentToMergedEx(const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, int &nAdjRowIndex, BOOL bUpward) | CXTPGridPaintManager |
FormatTime(int nPosition) | CXTPTrackPaintManager | virtual
FormatTimeLineTick(int nPosition, COLORREF &clrTick, int &nTickLength) | CXTPTrackPaintManager | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetColumnOffice2007CustomThemeBaseColor() const | CXTPGridPaintManager |
GetColumnStyle() const | CXTPGridPaintManager |
GetControlBackColor(CXTPGridControl *pControl) | CXTPGridPaintManager | virtual
GetFooterHeight(CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0) | CXTPGridPaintManager | virtual
GetFreezeColsDividerStyle() const | CXTPGridPaintManager |
GetGlyphs() const | CXTPGridPaintManager |
GetHeaderHeight() | CXTPGridPaintManager | virtual
GetHeaderHeight(CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0) | CXTPGridPaintManager | virtual
GetItemHeight(XTP_GRIDRECORDITEM_DRAWARGS &drawArgs, int nWidth) | CXTPGridPaintManager |
GetMaxPreviewLines() | CXTPGridPaintManager |
GetPreviewItemHeight(CDC *pDC, CXTPGridRow *pRow, int nWidth, int nHeight) | CXTPGridPaintManager | virtual
GetPreviewLinesCount(CDC *pDC, CRect &rcText, const CString &strText) | CXTPGridPaintManager |
GetRowHeight(CDC *pDC, CXTPGridRow *pRow) | CXTPGridPaintManager | virtual
GetRowHeight(CDC *pDC, CXTPGridRow *pRow, int nTotalWidth) | CXTPGridPaintManager | virtual
GetRowHeightEx(CDC *pDC, CXTPGridRow *pRow, int nTotalWidth, const BOOL firstLevel=TRUE) | CXTPGridPaintManager |
GetSectionDividerHeight(XTPGridFixedRowsDividerStyle dividerStyle) | CXTPGridPaintManager |
GetTextFont() | CXTPGridPaintManager |
IsColumHotTrackingEnabled() const | CXTPGridPaintManager | virtual
IsColumnPlusMinusSign() const | CXTPGridPaintManager |
IsColumnWidthWYSIWYG() const | CXTPGridPaintManager |
IsDrawGridForEmptySpace() const | CXTPGridPaintManager |
IsFixedInplaceButtonHeight() const | CXTPGridPaintManager |
IsFixedRowHeight() const | CXTPGridPaintManager |
IsGridVisible(BOOL bVertical) const | CXTPGridPaintManager |
IsGridVisible(XTPGridOrientation orientation) const | CXTPGridPaintManager |
IsLastColumnWidthWYSIWYG() const | CXTPGridPaintManager |
IsPreviewMode() const | CXTPGridPaintManager |
IsPrintGroupRowIcon() const | CXTPGridPaintManager |
IsShowWYSIWYGMarkers() const | CXTPGridPaintManager |
IsUseDropMarker() const | CXTPGridPaintManager |
LoadGlyphs() | CXTPGridPaintManager | virtual
m_arStartCol | CXTPGridPaintManager |
m_bAllowMergeCells | CXTPGridPaintManager |
m_bBaseTreeIndent | CXTPGridPaintManager |
m_bCleanTooltip | CXTPGridPaintManager |
m_bColumnPlusMinusSign | CXTPGridPaintManager | protected
m_bColumnWidthWYSIWYG | CXTPGridPaintManager | protected
m_bCompactText | CXTPGridPaintManager |
m_bDrawGridForEmptySpace | CXTPGridPaintManager | protected
m_bFixedInplaceButtonHeight | CXTPGridPaintManager | protected
m_bFixedRowHeight | CXTPGridPaintManager | protected
m_bForceDynamicMarkupForCell | CXTPGridPaintManager |
m_bForceShowDropMarker | CXTPGridPaintManager |
m_bForceShowTooltip | CXTPGridPaintManager |
m_bGrayIfDisable | CXTPGridPaintManager |
m_bGroupRowTextBold | CXTPGridPaintManager |
m_bHideSelection | CXTPGridPaintManager |
m_bHotTracking | CXTPGridPaintManager |
m_bInvertColumnOnClick | CXTPGridPaintManager |
m_bIsPreviewMode | CXTPGridPaintManager | protected
m_bLastColumnWidthWYSIWYG | CXTPGridPaintManager | protected
m_bMakeUpper | CXTPGridPaintManager |
m_bMoveScrollbarOnFixedColumnsIndent | CXTPGridPaintManager |
m_bPrintGroupRowIcon | CXTPGridPaintManager | protected
m_bPrintPageRectangle | CXTPGridPaintManager |
m_bPrintSortTriangle | CXTPGridPaintManager |
m_bPrintVirtualPageNumber | CXTPGridPaintManager |
m_bPrintWatermark | CXTPGridPaintManager |
m_bRecOrRowNum | CXTPGridPaintManager |
m_bRevertAlignment | CXTPGridPaintManager |
m_bShadeGroupHeadings | CXTPGridPaintManager |
m_bShadeSortColumn | CXTPGridPaintManager |
m_bShowLockIcon | CXTPGridPaintManager |
m_bShowNonActiveInPlaceButton | CXTPGridPaintManager |
m_bShowWYSIWYGMarkers | CXTPGridPaintManager | protected
m_bSortTriangleOffsetFromRight | CXTPGridPaintManager |
m_bThemedInplaceButtons | CXTPGridPaintManager |
m_bUseAlternativeBackground | CXTPGridPaintManager |
m_bUseDropMarker | CXTPGridPaintManager |
m_bUseEditTextAlignment | CXTPGridPaintManager |
m_bUseGroupRowSelectionState | CXTPGridPaintManager |
m_bUseShellIcon | CXTPGridPaintManager |
m_clrAlternativeBackground | CXTPGridPaintManager |
m_clrBoldText | CXTPGridPaintManager |
m_clrBoldTextHighlight | CXTPGridPaintManager |
m_clrBtnFace | CXTPGridPaintManager |
m_clrBtnFacePressed | CXTPGridPaintManager |
m_clrBtnText | CXTPGridPaintManager |
m_clrCaptionText | CXTPGridPaintManager |
m_clrCaptionTextPressed | CXTPGridPaintManager |
m_clrColumnOffice2007CustomTheme | CXTPGridPaintManager |
m_clrConnector | CXTPGridPaintManager |
m_clrControlBack | CXTPGridPaintManager |
m_clrControlDark | CXTPGridPaintManager |
m_clrControlLightLight | CXTPGridPaintManager |
m_clrDisableBitmapDarkest | CXTPGridPaintManager |
m_clrDisableBitmapLightest | CXTPGridPaintManager |
m_clrFormulaSubSum | CXTPGridPaintManager |
m_clrFormulaSum | CXTPGridPaintManager |
m_clrFreezeColsDivider | CXTPGridPaintManager |
m_clrGradientColumnSeparator | CXTPGridPaintManager |
m_clrGradientColumnShadow | CXTPGridPaintManager |
m_clrGroupBoxBack | CXTPGridPaintManager |
m_clrGroupRowText | CXTPGridPaintManager |
m_clrGroupShadeBack | CXTPGridPaintManager |
m_clrGroupShadeBorder | CXTPGridPaintManager |
m_clrGroupShadeText | CXTPGridPaintManager |
m_clrHeaderControl | CXTPGridPaintManager |
m_clrHighlight | CXTPGridPaintManager |
m_clrHighlightText | CXTPGridPaintManager |
m_clrHotDivider | CXTPGridPaintManager |
m_clrIndentControl | CXTPGridPaintManager |
m_clrItemShade | CXTPGridPaintManager |
m_clrMarker | CXTPTrackPaintManager |
m_clrMarkerBack | CXTPTrackPaintManager |
m_clrMarkerBorder | CXTPTrackPaintManager |
m_clrPreviewText | CXTPGridPaintManager |
m_clrScrollBarBorderDark | CXTPTrackPaintManager |
m_clrScrollBarBorderLight | CXTPTrackPaintManager |
m_clrScrollBarDark | CXTPTrackPaintManager |
m_clrScrollBarLight | CXTPTrackPaintManager |
m_clrSelectedArea | CXTPTrackPaintManager |
m_clrSelectedRow | CXTPGridPaintManager |
m_clrSelectedRowText | CXTPGridPaintManager |
m_clrTimeHeaderBorder | CXTPTrackPaintManager |
m_clrTimeHeaderDark | CXTPTrackPaintManager |
m_clrTimeHeaderDarkDark | CXTPTrackPaintManager |
m_clrTimeHeaderDivider | CXTPTrackPaintManager |
m_clrTimeLinePosition | CXTPTrackPaintManager |
m_clrTimeLineTick | CXTPTrackPaintManager |
m_clrTimeSliderBackground | CXTPTrackPaintManager |
m_clrTrackHeader | CXTPTrackPaintManager |
m_clrTrackMarkerBorder | CXTPTrackPaintManager |
m_clrTrackMarkerText | CXTPTrackPaintManager |
m_clrTrackMarkerTextBack | CXTPTrackPaintManager |
m_clrTrackMarkerTextBorder | CXTPTrackPaintManager |
m_clrTrackTimeArea | CXTPTrackPaintManager |
m_clrWindowText | CXTPGridPaintManager |
m_clrWorkArea | CXTPTrackPaintManager |
m_clrWorkAreaScrollBarBorder | CXTPTrackPaintManager |
m_clrWorkAreaScrollBarDark | CXTPTrackPaintManager |
m_clrWorkAreaScrollBarLight | CXTPTrackPaintManager |
m_columnStyle | CXTPGridPaintManager | protected
m_crlNoGroupByText | CXTPGridPaintManager |
m_grcGradientColumn | CXTPGridPaintManager |
m_grcGradientColumnHot | CXTPGridPaintManager |
m_grcGradientColumnPushed | CXTPGridPaintManager |
m_iRecOrRowStart | CXTPGridPaintManager |
m_nBaseParentRecordIndent | CXTPGridPaintManager |
m_nFixedColumnsIndent | CXTPGridPaintManager |
m_nFooterHeight | CXTPGridPaintManager | protected
m_nFreezeColsDividerStyle | CXTPGridPaintManager | protected
m_nGridLineStylePreviousH | CXTPGridPaintManager | protected
m_nGridLineStylePreviousV | CXTPGridPaintManager | protected
m_nGroupGridLineHeight | CXTPGridPaintManager | protected
m_nGroupGridLineStyle | CXTPGridPaintManager | protected
m_nHeaderHeight | CXTPGridPaintManager | protected
m_nMaxPreviewLines | CXTPGridPaintManager | protected
m_nResizingWidth | CXTPGridPaintManager | protected
m_nRowHeight | CXTPGridPaintManager | protected
m_nRowHeightDefault | CXTPGridPaintManager |
m_nTextIndentForGroupRowsWithNoIcon | CXTPGridPaintManager |
m_nTreeColumnLineLength | CXTPGridPaintManager |
m_nTreeIndent | CXTPGridPaintManager |
m_nTreeStructureStyle | CXTPGridPaintManager |
m_nTreeTextIndent | CXTPGridPaintManager |
m_nTreeTextIndentGroupRow | CXTPGridPaintManager |
m_nTreeTextIndentRowChildren | CXTPGridPaintManager |
m_nTreeTextIndentRowParent | CXTPGridPaintManager |
m_pControl | CXTPGridPaintManager | protected
m_pGlyphs | CXTPGridPaintManager | protected
m_pHyperlinkHoverStyle | CXTPGridPaintManager |
m_pHyperlinkStyle | CXTPGridPaintManager |
m_pMarkupUIElement_NoGroupBy | CXTPGridPaintManager | protected
m_PrintPageWidth | CXTPGridPaintManager |
m_rcPreviewIndent | CXTPGridPaintManager |
m_RecordNumberWidth | CXTPGridPaintManager |
m_strCollapse | CXTPGridPaintManager |
m_strDecreasing | CXTPGridPaintManager |
m_strExpand | CXTPGridPaintManager |
m_strIncreasing | CXTPGridPaintManager |
m_strMarkupUIElement_NoGroupBy | CXTPGridPaintManager | protected
m_strNoFieldsAvailable | CXTPGridPaintManager |
m_strNoGroupBy | CXTPGridPaintManager |
m_strNoItems | CXTPGridPaintManager |
m_strSortBy | CXTPGridPaintManager |
m_szGlyph | CXTPGridPaintManager | protected
m_themeButton | CXTPGridPaintManager | protected
m_themeCombo | CXTPGridPaintManager | protected
m_themeHeader | CXTPGridPaintManager | protected
m_themeSpin | CXTPGridPaintManager | protected
m_treeStructureStyle | CXTPGridPaintManager |
m_xtpBrushGroupGridLineStyle | CXTPGridPaintManager | protected
m_xtpBrushHorizontalGrid | CXTPGridPaintManager | protected
m_xtpBrushTreeStructure | CXTPGridPaintManager | protected
m_xtpBrushVeriticalGrid | CXTPGridPaintManager | protected
m_xtpFontBoldText | CXTPGridPaintManager |
m_xtpFontCaption | CXTPGridPaintManager |
m_xtpFontPreview | CXTPGridPaintManager |
m_xtpFontText | CXTPGridPaintManager |
OnDrawAction(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs) | CXTPGridPaintManager | virtual
RecalcTotalHightOfMergedRows(CXTPGridColumns *pColumns, CDC *pDC, CXTPGridRow *pRow, int nRowHeight, int nTotalWidth) | CXTPGridPaintManager |
RefreshMetrics() | CXTPTrackThemeResource | virtual
SetCaptionFont(LOGFONT &lf) | CXTPGridPaintManager |
SetColumnOffice2007CustomThemeBaseColor(COLORREF clrBaseColor) | CXTPGridPaintManager |
SetColumnPlusMinusSign(BOOL bDraw) | CXTPGridPaintManager |
SetColumnWidthWYSIWYG(BOOL bColumnWidthWYSIWYG) | CXTPGridPaintManager |
SetDrawGridForEmptySpace(BOOL bDrawGrid) | CXTPGridPaintManager |
SetFixedRowHeight(BOOL bFixedRowHeight) | CXTPGridPaintManager |
SetFreezeColsDividerStyle(int nStyle) | CXTPGridPaintManager |
SetGridControl(CXTPGridControl *pControl) | CXTPGridPaintManager | virtual
SetHeaderHeight(int nHeight) | CXTPGridPaintManager | virtual
SetInplaceButtonHeight(BOOL bFixedInplaceButtonHeight) | CXTPGridPaintManager |
SetLastColumnWidthWYSIWYG(BOOL bColumnWidthWYSIWYG) | CXTPGridPaintManager |
SetMaxPreviewLines(int nMaxLines) | CXTPGridPaintManager |
SetPreviewIndent(int nLeft, int nTop, int nRight, int nBottom) | CXTPGridPaintManager |
SetPrintGroupRowIcon(BOOL bDraw) | CXTPGridPaintManager |
SetTextFont(LOGFONT &lf) | CXTPGridPaintManager |
ShowWYSIWYGMarkers(BOOL bSet) | CXTPGridPaintManager |
~CXTPGridPaintManager() | CXTPGridPaintManager | virtual
~CXTPTrackPaintManager() | CXTPTrackPaintManager |


Toolkit Pro: Member List

CAppearanceSetVisualStudio2005 Member List

This is the complete list of members for CAppearanceSetVisualStudio2005, including all inherited members.

AdjustClientRect(CXTPTabManager *pTabManager, CRect &rcClient) | CXTPTabPaintManagerTheme | virtual
CAppearanceSetPropertyPage2003() | CAppearanceSetPropertyPage2003 | inline
CAppearanceSetVisualStudio2005() | CAppearanceSetVisualStudio2005 | inline
CXTPTabPaintManagerTheme() | CXTPTabPaintManagerTheme |
DrawSingleButton(CDC *pDC, CXTPTabManagerItem *pItem) | CAppearanceSetVisualStudio2005 | virtual
DrawTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl) | CXTPTabPaintManagerTheme | virtual
DrawText(CDC *pDC, CXTPTabManager *pManager, const CString &str, LPRECT lpRect, UINT nFormat) | CXTPTabPaintManagerTheme | virtual
DrawWorkspacePart(CDC *pDC, LPRECT lpRect, XTPTabWorkspacePart workspacePart) | CXTPTabPaintManagerTheme | virtual
FillButton(CDC *pDC, CXTPTabManagerItem *pItem, LPPOINT pts, int nCount, XTPTabPosition tabPosition, BOOL bAbsolute=FALSE) | CXTPTabPaintManagerTheme |
FillTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl) | CAppearanceSetPropertyPage2003 | virtual
GetButtonDrawRect(const CXTPTabManagerItem *pItem) | CAppearanceSetVisualStudio2005 | virtual
GetButtonHeight(const CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetButtonLength(CDC *pDC, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerTheme | virtual
GetClientMargin() | CXTPTabPaintManagerTheme | virtual
GetClientRect(CRect rcControl, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetColorSet() const | CXTPTabPaintManagerTheme |
GetDefaultColorSet() | CAppearanceSetPropertyPage2003 | inlinevirtual
GetHeaderClipBox(CDC *pDC, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetHeaderHeight(CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme |
GetHeaderMargin() | CAppearanceSetVisualStudio2005 | inlinevirtual
GetHeaderRect(CRect rcControl, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetSupportedColorSets() | CXTPTabPaintManagerTheme | inlinevirtual
m_bButtonsReverseZOrder | CXTPTabPaintManagerTheme | protected
m_bDoubleHighlightedBorder | CAppearanceSetPropertyPage2003 |
m_nButtonHeight | CXTPTabPaintManagerTheme | protected
m_nRowMargin | CXTPTabPaintManagerTheme |
m_pPaintManager | CXTPTabPaintManagerTheme | protected
m_rcHeaderMargin | CXTPTabPaintManagerTheme |
RefreshMetrics() | CAppearanceSetPropertyPage2003 | virtual
RepositionTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcClient) | CXTPTabPaintManagerTheme | virtual
~CXTPTabPaintManagerTheme() | CXTPTabPaintManagerTheme | virtual


Toolkit Pro: XTPDropSource.h Source File

  • Source
  • Controls
  • Shell
XTPDropSource.h
Go to the documentation of this file.
1
23#if !defined(__XTPDROPSOURCE_H__)
24# define __XTPDROPSOURCE_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
62class _XTP_EXT_CLASS CXTPDropSource : public IDropSource
63{
64public:
69 CXTPDropSource();
70
75 virtual ~CXTPDropSource();
76
77public:
79 // IUnknown Interface Members
81
104 STDMETHODIMP QueryInterface(REFIID riid, LPVOID* ppReturn);
105
121 STDMETHODIMP_(ULONG) AddRef();
122
134 STDMETHODIMP_(ULONG) Release();
138 // IDropSource Interface Members
140
176 STDMETHODIMP QueryContinueDrag(BOOL bEsc, DWORD dwKeyState);
177
199 STDMETHODIMP GiveFeedback(DWORD dwEffect);
200
201protected:
202 UINT m_uiRefCount;
203};
204
205# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
207#endif // __XTPDROPSOURCE_H__
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPDropSource
The CXTPDropSource class is derived from IDropSource.
Definition XTPDropSource.h:63
CXTPDropSource::GiveFeedback
STDMETHODIMP GiveFeedback(DWORD dwEffect)
Provides visual feedback during drag-and-drop operations.
CXTPDropSource::QueryInterface
STDMETHODIMP QueryInterface(REFIID riid, LPVOID *ppReturn)
Provides client access to other interfaces.
CXTPDropSource::~CXTPDropSource
virtual ~CXTPDropSource()
Destroys a CXTPDropSource object, handles cleanup and deallocation.
CXTPDropSource::QueryContinueDrag
STDMETHODIMP QueryContinueDrag(BOOL bEsc, DWORD dwKeyState)
Determines if drag-and-drop should continue, stop or signal complete.
CXTPDropSource::m_uiRefCount
UINT m_uiRefCount
Indicates the current reference count.
Definition XTPDropSource.h:202
CXTPDropSource::CXTPDropSource
CXTPDropSource()
Constructs a CXTPDropSource object.


Toolkit Pro: XTPGridDeprecated.h Source File

  • Source
  • GridControl
XTPGridDeprecated.h
Go to the documentation of this file.
1
23#if !defined(__XTPGRIDDEPRECATED_H__)
24# define __XTPGRIDDEPRECATED_H__
25
26# if _MSC_VER > 1000
27# pragma once
28# endif // _MSC_VER > 1000
29
30# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
31
32_XTP_DEPRECATED_IN_FAVOR(CXTPGridBehavior)
33typedef CXTPGridBehavior CXTReportBehavior;
34_XTP_DEPRECATED_IN_FAVOR(CXTPGridBehaviorRow) typedef CXTPGridBehaviorRow CXTReportBehaviorRow;
35_XTP_DEPRECATED_IN_FAVOR(CXTPGridBehaviorRowKeyDown)
36typedef CXTPGridBehaviorRowKeyDown CXTReportBehaviorRowKeyDown;
37_XTP_DEPRECATED_IN_FAVOR(CXTPGridBehaviorRowKeyUp)
38typedef CXTPGridBehaviorRowKeyUp CXTReportBehaviorRowKeyUp;
39_XTP_DEPRECATED_IN_FAVOR(CXTPGridBehaviorRowModifier)
40typedef CXTPGridBehaviorRowModifier CXTReportBehaviorRowModifier;
41_XTP_DEPRECATED_IN_FAVOR(CXTPGridBehaviorRowMouse)
42typedef CXTPGridBehaviorRowMouse CXTReportBehaviorRowMouse;
43_XTP_DEPRECATED_IN_FAVOR(CXTPGridBehaviorRowMouseButton)
44typedef CXTPGridBehaviorRowMouseButton CXTReportBehaviorRowMouseButton;
45_XTP_DEPRECATED_IN_FAVOR(CXTPGridBorder) typedef CXTPGridBorder CXTReportBorder;
46_XTP_DEPRECATED_IN_FAVOR(CXTPGridBorderEdge) typedef CXTPGridBorderEdge CXTReportBorderEdge;
47_XTP_DEPRECATED_IN_FAVOR(CXTPGridColumn) typedef CXTPGridColumn CXTReportColumn;
48_XTP_DEPRECATED_IN_FAVOR(CXTPGridColumnDisplayOptions)
49typedef CXTPGridColumnDisplayOptions CXTReportColumnDisplayOptions;
50_XTP_DEPRECATED_IN_FAVOR(CXTPGridColumnDisplaySettings)
51typedef CXTPGridColumnDisplaySettings CXTReportColumnDisplaySettings;
52_XTP_DEPRECATED_IN_FAVOR(CXTPGridColumnOrder) typedef CXTPGridColumnOrder CXTReportColumnOrder;
53_XTP_DEPRECATED_IN_FAVOR(CXTPGridColumns) typedef CXTPGridColumns CXTReportColumns;
54_XTP_DEPRECATED_IN_FAVOR(CXTPGridControl) typedef CXTPGridControl CXTReportControl;
55_XTP_DEPRECATED_IN_FAVOR(CXTPGridControlLocale)
56typedef CXTPGridControlLocale CXTReportControlLocale;
57_XTP_DEPRECATED_IN_FAVOR(CXTPGridDataManager) typedef CXTPGridDataManager CXTReportDataManager;
58_XTP_DEPRECATED_IN_FAVOR(CXTPGridDataManager) typedef CXTPGridDataManager CXTReportDataManager;
59_XTP_DEPRECATED_IN_FAVOR(CXTPGridFilterEditControl)
60typedef CXTPGridFilterEditControl CXTReportFilterEditControl;
61_XTP_DEPRECATED_IN_FAVOR(CXTPGridGroupRow) typedef CXTPGridGroupRow CXTReportGroupRow;
62_XTP_DEPRECATED_IN_FAVOR(CXTPGridHeader) typedef CXTPGridHeader CXTReportHeader;
63_XTP_DEPRECATED_IN_FAVOR(CXTPGridHeaderDragWnd)
64typedef CXTPGridHeaderDragWnd CXTReportHeaderDragWnd;
65_XTP_DEPRECATED_IN_FAVOR(CXTPGridHeaderDropWnd)
66typedef CXTPGridHeaderDropWnd CXTReportHeaderDropWnd;
67_XTP_DEPRECATED_IN_FAVOR(CXTPGridHitTestInfo) typedef CXTPGridHitTestInfo CXTReportHitTestInfo;
68_XTP_DEPRECATED_IN_FAVOR(CXTPGridHyperlink) typedef CXTPGridHyperlink CXTReportHyperlink;
69_XTP_DEPRECATED_IN_FAVOR(CXTPGridHyperlinks) typedef CXTPGridHyperlinks CXTReportHyperlinks;
70_XTP_DEPRECATED_IN_FAVOR(CXTPGridHyperlinkStyle)
71typedef CXTPGridHyperlinkStyle CXTReportHyperlinkStyle;
72_XTP_DEPRECATED_IN_FAVOR(CXTPGridIconNavigator)
73typedef CXTPGridIconNavigator CXTReportIconNavigator;
74_XTP_DEPRECATED_IN_FAVOR(CXTPGridInplaceButton)
75typedef CXTPGridInplaceButton CXTReportInplaceButton;
76_XTP_DEPRECATED_IN_FAVOR(CXTPGridInplaceButtons)
77typedef CXTPGridInplaceButtons CXTReportInplaceButtons;
78_XTP_DEPRECATED_IN_FAVOR(CXTPGridInplaceControl)
79typedef CXTPGridInplaceControl CXTReportInplaceControl;
80_XTP_DEPRECATED_IN_FAVOR(CXTPGridInplaceEdit) typedef CXTPGridInplaceEdit CXTReportInplaceEdit;
81_XTP_DEPRECATED_IN_FAVOR(CXTPGridInplaceList) typedef CXTPGridInplaceList CXTReportInplaceList;
82_XTP_DEPRECATED_IN_FAVOR(CXTPGridNavigator) typedef CXTPGridNavigator CXTReportNavigator;
83_XTP_DEPRECATED_IN_FAVOR(CXTPGridNotifications)
84typedef CXTPGridNotifications CXTReportNotifications;
85_XTP_DEPRECATED_IN_FAVOR(CXTPGridNotificationsPopulate)
86typedef CXTPGridNotificationsPopulate CXTReportNotificationsPopulate;
87_XTP_DEPRECATED_IN_FAVOR(CXTPGridNotificationsRow)
88typedef CXTPGridNotificationsRow CXTReportNotificationsRow;
89_XTP_DEPRECATED_IN_FAVOR(CXTPGridNotificationsSelectedRows)
90typedef CXTPGridNotificationsSelectedRows CXTReportNotificationsSelectedRows;
91_XTP_DEPRECATED_IN_FAVOR(CXTPGridPageSetupDialog)
92typedef CXTPGridPageSetupDialog CXTReportPageSetupDialog;
93_XTP_DEPRECATED_IN_FAVOR(CXTPGridPaintManager) typedef CXTPGridPaintManager CXTReportPaintManager;
94_XTP_DEPRECATED_IN_FAVOR(CXTPGridRecord) typedef CXTPGridRecord CXTReportRecord;
95_XTP_DEPRECATED_IN_FAVOR(CXTPGridRecordItem) typedef CXTPGridRecordItem CXTReportRecordItem;
96_XTP_DEPRECATED_IN_FAVOR(CXTPGridRecordItemButton)
97typedef CXTPGridRecordItemButton CXTReportRecordItemButton;
98_XTP_DEPRECATED_IN_FAVOR(CXTPGridRecordItemConstraint)
99typedef CXTPGridRecordItemConstraint CXTReportRecordItemConstraint;
100_XTP_DEPRECATED_IN_FAVOR(CXTPGridRecordItemConstraints)
101typedef CXTPGridRecordItemConstraints CXTReportRecordItemConstraints;
102_XTP_DEPRECATED_IN_FAVOR(CXTPGridRecordItemControl)
103typedef CXTPGridRecordItemControl CXTReportRecordItemControl;
104_XTP_DEPRECATED_IN_FAVOR(CXTPGridRecordItemControlHookWnd)
105typedef CXTPGridRecordItemControlHookWnd CXTReportRecordItemControlHookWnd;
106_XTP_DEPRECATED_IN_FAVOR(CXTPGridRecordItemControls)
107typedef CXTPGridRecordItemControls CXTReportRecordItemControls;
108_XTP_DEPRECATED_IN_FAVOR(CXTPGridRecordItemControls)
109typedef CXTPGridRecordItemControls CXTReportRecordItemControls;
110_XTP_DEPRECATED_IN_FAVOR(CXTPGridRecordItemDateTime)
111typedef CXTPGridRecordItemDateTime CXTReportRecordItemDateTime;
112_XTP_DEPRECATED_IN_FAVOR(CXTPGridRecordItemEditOptions)
113typedef CXTPGridRecordItemEditOptions CXTReportRecordItemEditOptions;
114_XTP_DEPRECATED_IN_FAVOR(CXTPGridRecordItemIcon)
115typedef CXTPGridRecordItemIcon CXTReportRecordItemIcon;
116_XTP_DEPRECATED_IN_FAVOR(CXTPGridRecordItemId) typedef CXTPGridRecordItemId CXTReportRecordItemId;
117_XTP_DEPRECATED_IN_FAVOR(CXTPGridRecordItemNumber)
118typedef CXTPGridRecordItemNumber CXTReportRecordItemNumber;
119_XTP_DEPRECATED_IN_FAVOR(CXTPGridRecordItemPercentNumber)
120typedef CXTPGridRecordItemPercentNumber CXTReportRecordItemPercentNumber;
121_XTP_DEPRECATED_IN_FAVOR(CXTPGridRecordItemPreview)
122typedef CXTPGridRecordItemPreview CXTReportRecordItemPreview;
123_XTP_DEPRECATED_IN_FAVOR(CXTPGridRecordItemRange)
124typedef CXTPGridRecordItemRange CXTReportRecordItemRange;
125_XTP_DEPRECATED_IN_FAVOR(CXTPGridRecordItemText)
126typedef CXTPGridRecordItemText CXTReportRecordItemText;
127_XTP_DEPRECATED_IN_FAVOR(CXTPGridRecordItemVariant)
128typedef CXTPGridRecordItemVariant CXTReportRecordItemVariant;
129_XTP_DEPRECATED_IN_FAVOR(CXTPGridRecordMergeItem)
130typedef CXTPGridRecordMergeItem CXTReportRecordMergeItem;
131_XTP_DEPRECATED_IN_FAVOR(CXTPGridRecordMergeItemId)
132typedef CXTPGridRecordMergeItemId CXTReportRecordMergeItemId;
133_XTP_DEPRECATED_IN_FAVOR(CXTPGridRecordMergeItems)
134typedef CXTPGridRecordMergeItems CXTReportRecordMergeItems;
135_XTP_DEPRECATED_IN_FAVOR(CXTPGridRecords) typedef CXTPGridRecords CXTReportRecords;
136_XTP_DEPRECATED_IN_FAVOR(CXTPGridRow) typedef CXTPGridRow CXTReportRow;
137_XTP_DEPRECATED_IN_FAVOR(CXTPGridRowBase) typedef CXTPGridRowBase CXTReportRowBase;
138_XTP_DEPRECATED_IN_FAVOR(CXTPGridRows) typedef CXTPGridRows CXTReportRows;
139_XTP_DEPRECATED_IN_FAVOR(CXTPGridRowsArray) typedef CXTPGridRowsArray CXTReportRowsArray;
140_XTP_DEPRECATED_IN_FAVOR(CXTPGridScreenRows) typedef CXTPGridScreenRows CXTReportScreenRows;
141_XTP_DEPRECATED_IN_FAVOR(CXTPGridSection) typedef CXTPGridSection CXTReportSection;
142_XTP_DEPRECATED_IN_FAVOR(CXTPGridSections) typedef CXTPGridSections CXTReportSections;
143_XTP_DEPRECATED_IN_FAVOR(CXTPGridSelectedRows) typedef CXTPGridSelectedRows CXTReportSelectedRows;
144_XTP_DEPRECATED_IN_FAVOR(CXTPGridSubListControl)
145typedef CXTPGridSubListControl CXTReportSubListControl;
146_XTP_DEPRECATED_IN_FAVOR(CXTPGridThemeDefault) typedef CXTPGridThemeDefault CXTReportThemeDefault;
147_XTP_DEPRECATED_IN_FAVOR(CXTPGridThemeExplorer)
148typedef CXTPGridThemeExplorer CXTReportThemeExplorer;
149_XTP_DEPRECATED_IN_FAVOR(CXTPGridThemeNativeWindows10)
150typedef CXTPGridThemeNativeWindows10 CXTReportThemeNativeWindows10;
151_XTP_DEPRECATED_IN_FAVOR(CXTPGridThemeNativeWindows11)
152typedef CXTPGridThemeNativeWindows11 CXTReportThemeNativeWindows11;
153_XTP_DEPRECATED_IN_FAVOR(CXTPGridThemeOffice2003)
154typedef CXTPGridThemeOffice2003 CXTReportThemeOffice2003;
155_XTP_DEPRECATED_IN_FAVOR(CXTPGridThemeOffice2003Luna)
156typedef CXTPGridThemeOffice2003Luna CXTReportThemeOffice2003Luna;
157_XTP_DEPRECATED_IN_FAVOR(CXTPGridThemeOffice2013)
158typedef CXTPGridThemeOffice2013 CXTReportThemeOffice2013;
159_XTP_DEPRECATED_IN_FAVOR(CXTPGridThemeOfficeXP)
160typedef CXTPGridThemeOfficeXP CXTReportThemeOfficeXP;
161_XTP_DEPRECATED_IN_FAVOR(CXTPGridThemeResource)
162typedef CXTPGridThemeResource CXTReportThemeResource;
163_XTP_DEPRECATED_IN_FAVOR(CXTPGridThemeVisualStudio2012Blue)
164typedef CXTPGridThemeVisualStudio2012Blue CXTReportThemeVisualStudio2012Blue;
165_XTP_DEPRECATED_IN_FAVOR(CXTPGridThemeVisualStudio2012Dark)
166typedef CXTPGridThemeVisualStudio2012Dark CXTReportThemeVisualStudio2012Dark;
167_XTP_DEPRECATED_IN_FAVOR(CXTPGridThemeVisualStudio2012Light)
168typedef CXTPGridThemeVisualStudio2012Light CXTReportThemeVisualStudio2012Light;
169_XTP_DEPRECATED_IN_FAVOR(CXTPGridThemeVisualStudio2015)
170typedef CXTPGridThemeVisualStudio2015 CXTReportThemeVisualStudio2015;
171_XTP_DEPRECATED_IN_FAVOR(CXTPGridThemeVisualStudio2017)
172typedef CXTPGridThemeVisualStudio2017 CXTReportThemeVisualStudio2017;
173_XTP_DEPRECATED_IN_FAVOR(CXTPGridThemeVisualStudio2019)
174typedef CXTPGridThemeVisualStudio2019 CXTReportThemeVisualStudio2019;
175_XTP_DEPRECATED_IN_FAVOR(CXTPGridThemeVisualStudio2022)
176typedef CXTPGridThemeVisualStudio2022 CXTReportThemeVisualStudio2022;
177_XTP_DEPRECATED_IN_FAVOR(CXTPGridThickness) typedef CXTPGridThickness CXTReportThickness;
178_XTP_DEPRECATED_IN_FAVOR(CXTPGridTip) typedef CXTPGridTip CXTReportTip;
179_XTP_DEPRECATED_IN_FAVOR(CXTPGridView) typedef CXTPGridView CXTReportView;
180_XTP_DEPRECATED_IN_FAVOR(CXTPGridViewPrintOptions)
181typedef CXTPGridViewPrintOptions CXTReportViewPrintOptions;
182
183_XTP_DEPRECATED_IN_FAVOR(XTPGridMouseButton) typedef XTPGridMouseButton XTPReportMouseButton;
184_XTP_DEPRECATED_IN_FAVOR(XTPGridMouseEvent) typedef XTPGridMouseEvent XTPReportMouseEvent;
185_XTP_DEPRECATED_IN_FAVOR(XTPGridBehavior) typedef XTPGridBehavior XTPReportBehavior;
186_XTP_DEPRECATED_IN_FAVOR(XTPGridBorderEdge) typedef XTPGridBorderEdge XTPReportBorderEdge;
187_XTP_DEPRECATED_IN_FAVOR(XTPGridColumnBestFitMode)
188typedef XTPGridColumnBestFitMode XTPReportColumnBestFitMode;
189_XTP_DEPRECATED_IN_FAVOR(XTPGridMouseMode) typedef XTPGridMouseMode XTPReportMouseMode;
190_XTP_DEPRECATED_IN_FAVOR(XTPGridDragDrop) typedef XTPGridDragDrop XTPReportDragDrop;
191_XTP_DEPRECATED_IN_FAVOR(XTPGridDropMarker) typedef XTPGridDropMarker XTPReportDropMarker;
192_XTP_DEPRECATED_IN_FAVOR(XTPGridWatermarkAlignment)
193typedef XTPGridWatermarkAlignment XTPReportWatermarkAlignment;
194_XTP_DEPRECATED_IN_FAVOR(XTPGridElementRect) typedef XTPGridElementRect XTPReportElementRect;
195_XTP_DEPRECATED_IN_FAVOR(XTPGridFilterMode) typedef XTPGridFilterMode XTPReportFilterMode;
196_XTP_DEPRECATED_IN_FAVOR(XTPGridScrollUpdateMode)
197typedef XTPGridScrollUpdateMode XTPReportScrollUpdateMode;
198_XTP_DEPRECATED_IN_FAVOR(XTPGridScrollMode) typedef XTPGridScrollMode XTPReportScrollMode;
199_XTP_DEPRECATED_IN_FAVOR(XTPGridShellIcon) typedef XTPGridShellIcon XTPReportShellIcon;
200_XTP_DEPRECATED_IN_FAVOR(XTPGridGlyph) typedef XTPGridGlyph XTPReportGlyph;
201_XTP_DEPRECATED_IN_FAVOR(XTPGridCheckState) typedef XTPGridCheckState XTPReportCheckState;
202_XTP_DEPRECATED_IN_FAVOR(XTPGridRowType) typedef XTPGridRowType XTPReportRowType;
203_XTP_DEPRECATED_IN_FAVOR(XTPGridOrientation) typedef XTPGridOrientation XTPReportOrientation;
204_XTP_DEPRECATED_IN_FAVOR(XTPGridLineStyle) typedef XTPGridLineStyle XTPReportLineStyle;
205_XTP_DEPRECATED_IN_FAVOR(XTPGridFreezeColsDividerStyle)
206typedef XTPGridFreezeColsDividerStyle XTPReportFreezeColsDividerStyle;
207_XTP_DEPRECATED_IN_FAVOR(XTPGridColumnStyle) typedef XTPGridColumnStyle XTPReportColumnStyle;
208_XTP_DEPRECATED_IN_FAVOR(XTPGridTreeStructureStyle)
209typedef XTPGridTreeStructureStyle XTPReportTreeStructureStyle;
210_XTP_DEPRECATED_IN_FAVOR(XTPGridSectionDividerStyle)
211typedef XTPGridSectionDividerStyle XTPReportSectionDividerStyle;
212_XTP_DEPRECATED_IN_FAVOR(XTPGridSectionDividerPosition)
213typedef XTPGridSectionDividerPosition XTPReportSectionDividerPosition;
214_XTP_DEPRECATED_IN_FAVOR(XTPGridDrawSortTriangleStyle)
215typedef XTPGridDrawSortTriangleStyle XTPReportDrawSortTriangleStyle;
216_XTP_DEPRECATED_IN_FAVOR(XTPGridTextDecoration)
217typedef XTPGridTextDecoration XTPReportTextDecoration;
218_XTP_DEPRECATED_IN_FAVOR(XTPGridPaintTheme) typedef XTPGridPaintTheme XTPReportPaintTheme;
219_XTP_DEPRECATED_IN_FAVOR(XTPGridColumnOrderChangedReason)
220typedef XTPGridColumnOrderChangedReason XTPReportColumnOrderChangedReason;
221_XTP_DEPRECATED_IN_FAVOR(XTPGridColumnDirection)
222typedef XTPGridColumnDirection XTPReportColumnDirection;
223_XTP_DEPRECATED_IN_FAVOR(XTPGridHitTestInfoCode)
224typedef XTPGridHitTestInfoCode XTPReportHitTestInfoCode;
225_XTP_DEPRECATED_IN_FAVOR(XTPGridColumnIconAlignment)
226typedef XTPGridColumnIconAlignment XTPReportColumnIconAlignment;
227_XTP_DEPRECATED_IN_FAVOR(XTPGridGroupRowIconAlignment)
228typedef XTPGridGroupRowIconAlignment XTPReportGroupRowIconAlignment;
229_XTP_DEPRECATED_IN_FAVOR(XTPGridVirtualRowFlags)
230typedef XTPGridVirtualRowFlags XTPReportVirtualRowFlags;
231_XTP_DEPRECATED_IN_FAVOR(XTPGridItemControlType)
232typedef XTPGridItemControlType XTPReportItemControlType;
233_XTP_DEPRECATED_IN_FAVOR(XTPGridItemControlAlignment)
234typedef XTPGridItemControlAlignment XTPReportItemControlAlignment;
235_XTP_DEPRECATED_IN_FAVOR(XTPGridTextSearchParms)
236typedef XTPGridTextSearchParms XTPReportTextSearchParms;
237_XTP_DEPRECATED_IN_FAVOR(XTPGridSelectionChangeType)
238typedef XTPGridSelectionChangeType XTPReportSelectionChangeType;
239_XTP_DEPRECATED_IN_FAVOR(XTPGridSectionHeightMode)
240typedef XTPGridSectionHeightMode XTPReportSectionHeightMode;
241_XTP_DEPRECATED_IN_FAVOR(XTPGridSection) typedef XTPGridSection XTPReportSection;
242
243_XTP_DEPRECATED_IN_FAVOR(xtpGridMouseButtonNone)
244const XTPGridMouseButton xtpReportMouseButtonNone = xtpGridMouseButtonNone;
245_XTP_DEPRECATED_IN_FAVOR(xtpGridMouseButtonLeft)
246const XTPGridMouseButton xtpReportMouseButtonLeft = xtpGridMouseButtonLeft;
247_XTP_DEPRECATED_IN_FAVOR(xtpGridMouseButtonMiddle)
248const XTPGridMouseButton xtpReportMouseButtonMiddle = xtpGridMouseButtonMiddle;
249_XTP_DEPRECATED_IN_FAVOR(xtpGridMouseButtonRight)
250const XTPGridMouseButton xtpReportMouseButtonRight = xtpGridMouseButtonRight;
251
252_XTP_DEPRECATED_IN_FAVOR(xtpGridMouseEventButtonDown)
253const XTPGridMouseEvent xtpReportMouseEventButtonDown = xtpGridMouseEventButtonDown;
254_XTP_DEPRECATED_IN_FAVOR(xtpGridMouseEventButtonUp)
255const XTPGridMouseEvent xtpReportMouseEventButtonUp = xtpGridMouseEventButtonUp;
256
257_XTP_DEPRECATED_IN_FAVOR(xtpGridBehaviorOutlook2003)
258const XTPGridBehavior xtpReportBehaviorOutlook2003 = xtpGridBehaviorOutlook2003;
259_XTP_DEPRECATED_IN_FAVOR(xtpGridBehaviorOutlook2007)
260const XTPGridBehavior xtpReportBehaviorOutlook2007 = xtpGridBehaviorOutlook2007;
261_XTP_DEPRECATED_IN_FAVOR(xtpGridBehaviorOutlook2010)
262const XTPGridBehavior xtpReportBehaviorOutlook2010 = xtpGridBehaviorOutlook2010;
263_XTP_DEPRECATED_IN_FAVOR(xtpGridBehaviorExcel2003)
264const XTPGridBehavior xtpReportBehaviorExcel2003 = xtpGridBehaviorExcel2003;
265_XTP_DEPRECATED_IN_FAVOR(xtpGridBehaviorExcel2007)
266const XTPGridBehavior xtpReportBehaviorExcel2007 = xtpGridBehaviorExcel2007;
267_XTP_DEPRECATED_IN_FAVOR(xtpGridBehaviorExcel2010)
268const XTPGridBehavior xtpReportBehaviorExcel2010 = xtpGridBehaviorExcel2010;
269_XTP_DEPRECATED_IN_FAVOR(xtpGridBehaviorCodejock1340)
270const XTPGridBehavior xtpReportBehaviorCodejock1340 = xtpGridBehaviorCodejock1340;
271_XTP_DEPRECATED_IN_FAVOR(xtpGridBehaviorCodejock1341)
272const XTPGridBehavior xtpReportBehaviorCodejock1341 = xtpGridBehaviorCodejock1341;
273_XTP_DEPRECATED_IN_FAVOR(xtpGridBehaviorCodejock1342)
274const XTPGridBehavior xtpReportBehaviorCodejock1342 = xtpGridBehaviorCodejock1342;
275_XTP_DEPRECATED_IN_FAVOR(xtpGridBehaviorCodejock1501)
276const XTPGridBehavior xtpReportBehaviorCodejock1501 = xtpGridBehaviorCodejock1501;
277_XTP_DEPRECATED_IN_FAVOR(xtpGridBehaviorCodejock1502)
278const XTPGridBehavior xtpReportBehaviorCodejock1502 = xtpGridBehaviorCodejock1502;
279_XTP_DEPRECATED_IN_FAVOR(xtpGridBehaviorCodejockDefault)
280const XTPGridBehavior xtpReportBehaviorCodejockDefault = xtpGridBehaviorCodejockDefault;
281
282_XTP_DEPRECATED_IN_FAVOR(xtpGridBorderEdgeLeft)
283const XTPGridBorderEdge xtpReportBorderEdgeLeft = xtpGridBorderEdgeLeft;
284_XTP_DEPRECATED_IN_FAVOR(xtpGridBorderEdgeTop)
285const XTPGridBorderEdge xtpReportBorderEdgeTop = xtpGridBorderEdgeTop;
286_XTP_DEPRECATED_IN_FAVOR(xtpGridBorderEdgeRight)
287const XTPGridBorderEdge xtpReportBorderEdgeRight = xtpGridBorderEdgeRight;
288_XTP_DEPRECATED_IN_FAVOR(xtpGridBorderEdgeBottom)
289const XTPGridBorderEdge xtpReportBorderEdgeBottom = xtpGridBorderEdgeBottom;
290_XTP_DEPRECATED_IN_FAVOR(xtpGridBorderEdgeCount)
291const XTPGridBorderEdge xtpReportBorderEdgeCount = xtpGridBorderEdgeCount;
292
293_XTP_DEPRECATED_IN_FAVOR(xtpGridMouseNothing)
294const XTPGridMouseMode xtpReportMouseNothing = xtpGridMouseNothing;
295_XTP_DEPRECATED_IN_FAVOR(xtpGridMouseOverColumnDivide)
296const XTPGridMouseMode xtpReportMouseOverColumnDivide = xtpGridMouseOverColumnDivide;
297_XTP_DEPRECATED_IN_FAVOR(xtpGridMousePrepareDragColumn)
298const XTPGridMouseMode xtpReportMousePrepareDragColumn = xtpGridMousePrepareDragColumn;
299_XTP_DEPRECATED_IN_FAVOR(xtpGridMouseDraggingColumn)
300const XTPGridMouseMode xtpReportMouseDraggingColumn = xtpGridMouseDraggingColumn;
301_XTP_DEPRECATED_IN_FAVOR(xtpGridMouseOverRowDivide)
302const XTPGridMouseMode xtpReportMouseOverRowDivide = xtpGridMouseOverRowDivide;
303
304_XTP_DEPRECATED_IN_FAVOR(xtpGridAllowDrop)
305const XTPGridDragDrop xtpReportAllowDrop = xtpGridAllowDrop;
306_XTP_DEPRECATED_IN_FAVOR(xtpGridAllowDragCopy)
307const XTPGridDragDrop xtpReportAllowDragCopy = xtpGridAllowDragCopy;
308_XTP_DEPRECATED_IN_FAVOR(xtpGridAllowDragMove)
309const XTPGridDragDrop xtpReportAllowDragMove = xtpGridAllowDragMove;
310_XTP_DEPRECATED_IN_FAVOR(xtpGridAllowDrag)
311const XTPGridDragDrop xtpReportAllowDrag = xtpGridAllowDrag;
312_XTP_DEPRECATED_IN_FAVOR(xtpGridDontDropAsText)
313const XTPGridDragDrop xtpReportDontDropAsText = xtpGridDontDropAsText;
314
315_XTP_DEPRECATED_IN_FAVOR(xtpGridDropBetween)
316const XTPGridDropMarker xtpReportDropBetween = xtpGridDropBetween;
317_XTP_DEPRECATED_IN_FAVOR(xtpGridDropSelect)
318const XTPGridDropMarker xtpReportDropSelect = xtpGridDropSelect;
319
320_XTP_DEPRECATED_IN_FAVOR(xtpGridWatermarkUnknown)
321const XTPGridWatermarkAlignment xtpReportWatermarkUnknown = xtpGridWatermarkUnknown;
322_XTP_DEPRECATED_IN_FAVOR(xtpGridWatermarkLeft)
323const XTPGridWatermarkAlignment xtpReportWatermarkLeft = xtpGridWatermarkLeft;
324_XTP_DEPRECATED_IN_FAVOR(xtpGridWatermarkCenter)
325const XTPGridWatermarkAlignment xtpReportWatermarkCenter = xtpGridWatermarkCenter;
326_XTP_DEPRECATED_IN_FAVOR(xtpGridWatermarkRight)
327const XTPGridWatermarkAlignment xtpReportWatermarkRight = xtpGridWatermarkRight;
328_XTP_DEPRECATED_IN_FAVOR(xtpGridWatermarkHmask)
329const XTPGridWatermarkAlignment xtpReportWatermarkHmask = xtpGridWatermarkHmask;
330_XTP_DEPRECATED_IN_FAVOR(xtpGridWatermarkTop)
331const XTPGridWatermarkAlignment xtpReportWatermarkTop = xtpGridWatermarkTop;
332_XTP_DEPRECATED_IN_FAVOR(xtpGridWatermarkVCenter)
333const XTPGridWatermarkAlignment xtpReportWatermarkVCenter = xtpGridWatermarkVCenter;
334_XTP_DEPRECATED_IN_FAVOR(xtpGridWatermarkBottom)
335const XTPGridWatermarkAlignment xtpReportWatermarkBottom = xtpGridWatermarkBottom;
336_XTP_DEPRECATED_IN_FAVOR(xtpGridWatermarkVmask)
337const XTPGridWatermarkAlignment xtpReportWatermarkVmask = xtpGridWatermarkVmask;
338_XTP_DEPRECATED_IN_FAVOR(xtpGridWatermarkStretch)
339const XTPGridWatermarkAlignment xtpReportWatermarkStretch = xtpGridWatermarkStretch;
340_XTP_DEPRECATED_IN_FAVOR(xtpGridWatermarkEnlargeOnly)
341const XTPGridWatermarkAlignment xtpReportWatermarkEnlargeOnly = xtpGridWatermarkEnlargeOnly;
342_XTP_DEPRECATED_IN_FAVOR(xtpGridWatermarkShrinkOnly)
343const XTPGridWatermarkAlignment xtpReportWatermarkShrinkOnly = xtpGridWatermarkShrinkOnly;
344_XTP_DEPRECATED_IN_FAVOR(xtpGridWatermarkPreserveRatio)
345const XTPGridWatermarkAlignment xtpReportWatermarkPreserveRatio = xtpGridWatermarkPreserveRatio;
346
347_XTP_DEPRECATED_IN_FAVOR(xtpGridElementRectGridArea)
348const XTPGridElementRect xtpReportElementRectGridArea = xtpGridElementRectGridArea;
349_XTP_DEPRECATED_IN_FAVOR(xtpGridElementRectGroupByArea)
350const XTPGridElementRect xtpReportElementRectGroupByArea = xtpGridElementRectGroupByArea;
351_XTP_DEPRECATED_IN_FAVOR(xtpGridElementRectHeaderArea)
352const XTPGridElementRect xtpReportElementRectHeaderArea = xtpGridElementRectHeaderArea;
353_XTP_DEPRECATED_IN_FAVOR(xtpGridElementRectFooterArea)
354const XTPGridElementRect xtpReportElementRectFooterArea = xtpGridElementRectFooterArea;
355_XTP_DEPRECATED_IN_FAVOR(xtpGridElementRectHeaderRecordsArea)
356const XTPGridElementRect xtpReportElementRectHeaderRecordsArea = xtpGridElementRectHeaderRecordsArea;
357_XTP_DEPRECATED_IN_FAVOR(xtpGridElementRectFooterRecordsArea)
358const XTPGridElementRect xtpReportElementRectFooterRecordsArea = xtpGridElementRectFooterRecordsArea;
359_XTP_DEPRECATED_IN_FAVOR(xtpGridElementRectHeaderRecordsDividerArea)
360const XTPGridElementRect xtpReportElementRectHeaderRecordsDividerArea =
361 xtpGridElementRectHeaderRecordsDividerArea;
362_XTP_DEPRECATED_IN_FAVOR(xtpGridElementRectFooterRecordsDividerArea)
363const XTPGridElementRect xtpReportElementRectFooterRecordsDividerArea =
364 xtpGridElementRectFooterRecordsDividerArea;
365
366_XTP_DEPRECATED_IN_FAVOR(xtpGridFilterTreeSimple)
367const XTPGridFilterMode xtpReportFilterTreeSimple = xtpGridFilterTreeSimple;
368_XTP_DEPRECATED_IN_FAVOR(xtpGridFilterTreeByParentAndChildren)
369const XTPGridFilterMode xtpReportFilterTreeByParentAndChildren =
370 xtpGridFilterTreeByParentAndChildren;
371_XTP_DEPRECATED_IN_FAVOR(xtpGridFilterTreeByEndChildrenOnly)
372const XTPGridFilterMode xtpReportFilterTreeByEndChildrenOnly = xtpGridFilterTreeByEndChildrenOnly;
373
374_XTP_DEPRECATED_IN_FAVOR(xtpGridScrollUpdateModeImmediate)
375const XTPGridScrollUpdateMode xtpReportScrollUpdateModeImmediate = xtpGridScrollUpdateModeImmediate;
376_XTP_DEPRECATED_IN_FAVOR(xtpGridScrollUpdateModeDeferred)
377const XTPGridScrollUpdateMode xtpReportScrollUpdateModeDeferred = xtpGridScrollUpdateModeDeferred;
378
379_XTP_DEPRECATED_IN_FAVOR(xtpGridScrollModeNone)
380const XTPGridScrollMode xtpReportScrollModeNone = xtpGridScrollModeNone;
381_XTP_DEPRECATED_IN_FAVOR(xtpGridScrollModeBlockCount)
382const XTPGridScrollMode xtpReportScrollModeBlockCount = xtpGridScrollModeBlockCount;
383_XTP_DEPRECATED_IN_FAVOR(xtpGridScrollModeBlockSize)
384const XTPGridScrollMode xtpReportScrollModeBlockSize = xtpGridScrollModeBlockSize;
385_XTP_DEPRECATED_IN_FAVOR(xtpGridScrollModeSmooth)
386const XTPGridScrollMode xtpReportScrollModeSmooth = xtpGridScrollModeSmooth;
387_XTP_DEPRECATED_IN_FAVOR(xtpGridScrollModeBlock)
388const XTPGridScrollMode xtpReportScrollModeBlock = xtpGridScrollModeBlock;
389
390_XTP_DEPRECATED_IN_FAVOR(xtpGridShellIconLock)
391const XTPGridShellIcon xtpReportShellIconLock = xtpGridShellIconLock;
392
393_XTP_DEPRECATED_IN_FAVOR(xtpGridGlyphInvalid)
394const XTPGridGlyph xtpReportGlyphInvalid = xtpGridGlyphInvalid;
395_XTP_DEPRECATED_IN_FAVOR(xtpGridGlyphRowCollapse)
396const XTPGridGlyph xtpReportGlyphRowCollapse = xtpGridGlyphRowCollapse;
397_XTP_DEPRECATED_IN_FAVOR(xtpGridGlyphRowExpand)
398const XTPGridGlyph xtpReportGlyphRowExpand = xtpGridGlyphRowExpand;
399_XTP_DEPRECATED_IN_FAVOR(xtpGridGlyphEnabledUnchecked)
400const XTPGridGlyph xtpReportGlyphEnabledUnchecked = xtpGridGlyphEnabledUnchecked;
401_XTP_DEPRECATED_IN_FAVOR(xtpGridGlyphEnabledChecked)
402const XTPGridGlyph xtpReportGlyphEnabledChecked = xtpGridGlyphEnabledChecked;
403_XTP_DEPRECATED_IN_FAVOR(xtpGridGlyphDisabledUnchecked)
404const XTPGridGlyph xtpReportGlyphDisabledUnchecked = xtpGridGlyphDisabledUnchecked;
405_XTP_DEPRECATED_IN_FAVOR(xtpGridGlyphDisabledChecked)
406const XTPGridGlyph xtpReportGlyphDisabledChecked = xtpGridGlyphDisabledChecked;
407_XTP_DEPRECATED_IN_FAVOR(xtpGridGlyphColumnExpand)
408const XTPGridGlyph xtpReportGlyphColumnExpand = xtpGridGlyphColumnExpand;
409_XTP_DEPRECATED_IN_FAVOR(xtpGridGlyphColumnRestore)
410const XTPGridGlyph xtpReportGlyphColumnRestore = xtpGridGlyphColumnRestore;
411_XTP_DEPRECATED_IN_FAVOR(xtpGridGlyphEnabledTristate)
412const XTPGridGlyph xtpReportGlyphEnabledTristate = xtpGridGlyphEnabledTristate;
413_XTP_DEPRECATED_IN_FAVOR(xtpGridGlyphItemLocked)
414const XTPGridGlyph xtpReportGlyphItemLocked = xtpGridGlyphItemLocked;
415_XTP_DEPRECATED_IN_FAVOR(xtpGridGlyphItemUnlocked)
416const XTPGridGlyph xtpReportGlyphItemUnlocked = xtpGridGlyphItemUnlocked;
417_XTP_DEPRECATED_IN_FAVOR(xtpGridGlyphCount)
418const XTPGridGlyph xtpReportGlyphCount = xtpGridGlyphCount;
419
420_XTP_DEPRECATED_IN_FAVOR(xtpGridCheckStateInvalid)
421const XTPGridCheckState xtpReportCheckStateInvalid = xtpGridCheckStateInvalid;
422_XTP_DEPRECATED_IN_FAVOR(xtpGridCheckStateUnchecked)
423const XTPGridCheckState xtpReportCheckStateUnchecked = xtpGridCheckStateUnchecked;
424_XTP_DEPRECATED_IN_FAVOR(xtpGridCheckStateChecked)
425const XTPGridCheckState xtpReportCheckStateChecked = xtpGridCheckStateChecked;
426_XTP_DEPRECATED_IN_FAVOR(xtpGridCheckStateIndeterminate)
427const XTPGridCheckState xtpReportCheckStateIndeterminate = xtpGridCheckStateIndeterminate;
428_XTP_DEPRECATED_IN_FAVOR(xtpGridCheckStateCount)
429const XTPGridCheckState xtpReportCheckStateCount = xtpGridCheckStateCount;
430
431_XTP_DEPRECATED_IN_FAVOR(xtpGridOrientationHorizontal)
432const XTPGridOrientation xtpReportOrientationHorizontal = xtpGridOrientationHorizontal;
433_XTP_DEPRECATED_IN_FAVOR(xtpGridOrientationVertical)
434const XTPGridOrientation xtpReportOrientationVertical = xtpGridOrientationVertical;
435_XTP_DEPRECATED_IN_FAVOR(xtpGridOrientationAll)
436const XTPGridOrientation xtpReportOrientationAll = xtpGridOrientationAll;
437
438_XTP_DEPRECATED_IN_FAVOR(xtpGridLineStyleNone)
439const XTPGridLineStyle xtpReportLineStyleNone = xtpGridLineStyleNone;
440_XTP_DEPRECATED_IN_FAVOR(xtpGridLineStyleDotSmall)
441const XTPGridLineStyle xtpReportLineStyleDotSmall = xtpGridLineStyleDotSmall;
442_XTP_DEPRECATED_IN_FAVOR(xtpGridLineStyleDotLarge)
443const XTPGridLineStyle xtpReportLineStyleDotLarge = xtpGridLineStyleDotLarge;
444_XTP_DEPRECATED_IN_FAVOR(xtpGridLineStyleDash)
445const XTPGridLineStyle xtpReportLineStyleDash = xtpGridLineStyleDash;
446_XTP_DEPRECATED_IN_FAVOR(xtpGridLineStyleSolid)
447const XTPGridLineStyle xtpReportLineStyleSolid = xtpGridLineStyleSolid;
448_XTP_DEPRECATED_IN_FAVOR(xtpGridLineStyleCount)
449const XTPGridLineStyle xtpReportLineStyleCount = xtpGridLineStyleCount;
450_XTP_DEPRECATED_IN_FAVOR(xtpGridGridNoLines)
451const XTPGridLineStyle xtpReportGridNoLines = xtpGridGridNoLines;
452_XTP_DEPRECATED_IN_FAVOR(xtpGridGridSmallDots)
453const XTPGridLineStyle xtpReportGridSmallDots = xtpGridGridSmallDots;
454_XTP_DEPRECATED_IN_FAVOR(xtpGridGridLargeDots)
455const XTPGridLineStyle xtpReportGridLargeDots = xtpGridGridLargeDots;
456_XTP_DEPRECATED_IN_FAVOR(xtpGridGridDashes)
457const XTPGridLineStyle xtpReportGridDashes = xtpGridGridDashes;
458_XTP_DEPRECATED_IN_FAVOR(xtpGridGridSolid)
459const XTPGridLineStyle xtpReportGridSolid = xtpGridGridSolid;
460
461_XTP_DEPRECATED_IN_FAVOR(xtpGridFreezeColsDividerThin)
462const XTPGridFreezeColsDividerStyle xtpReportFreezeColsDividerThin = xtpGridFreezeColsDividerThin;
463_XTP_DEPRECATED_IN_FAVOR(xtpGridFreezeColsDividerBold)
464const XTPGridFreezeColsDividerStyle xtpReportFreezeColsDividerBold = xtpGridFreezeColsDividerBold;
465_XTP_DEPRECATED_IN_FAVOR(xtpGridFreezeColsDividerHeader)
466const XTPGridFreezeColsDividerStyle xtpReportFreezeColsDividerHeader =
467 xtpGridFreezeColsDividerHeader;
468_XTP_DEPRECATED_IN_FAVOR(xtpGridFreezeColsDividerShade)
469const XTPGridFreezeColsDividerStyle xtpReportFreezeColsDividerShade = xtpGridFreezeColsDividerShade;
470_XTP_DEPRECATED_IN_FAVOR(xtpGridFreezeColsDividerShowAlways)
471const XTPGridFreezeColsDividerStyle xtpReportFreezeColsDividerShowAlways =
472 xtpGridFreezeColsDividerShowAlways;
473
474_XTP_DEPRECATED_IN_FAVOR(xtpGridColumnShaded)
475const XTPGridColumnStyle xtpReportColumnShaded = xtpGridColumnShaded;
476_XTP_DEPRECATED_IN_FAVOR(xtpGridColumnFlat)
477const XTPGridColumnStyle xtpReportColumnFlat = xtpGridColumnFlat;
478_XTP_DEPRECATED_IN_FAVOR(xtpGridColumnExplorer)
479const XTPGridColumnStyle xtpReportColumnExplorer = xtpGridColumnExplorer;
480_XTP_DEPRECATED_IN_FAVOR(xtpGridColumnOffice2003)
481const XTPGridColumnStyle xtpReportColumnOffice2003 = xtpGridColumnOffice2003;
482_XTP_DEPRECATED_IN_FAVOR(xtpGridColumnResource)
483const XTPGridColumnStyle xtpReportColumnResource = xtpGridColumnResource;
484
485_XTP_DEPRECATED_IN_FAVOR(xtpGridTreeStructureNone)
486const XTPGridTreeStructureStyle xtpReportTreeStructureNone = xtpGridTreeStructureNone;
487_XTP_DEPRECATED_IN_FAVOR(xtpGridTreeStructureSolid)
488const XTPGridTreeStructureStyle xtpReportTreeStructureSolid = xtpGridTreeStructureSolid;
489_XTP_DEPRECATED_IN_FAVOR(xtpGridTreeStructureDots)
490const XTPGridTreeStructureStyle xtpReportTreeStructureDots = xtpGridTreeStructureDots;
491
492_XTP_DEPRECATED_IN_FAVOR(xtpGridSectionDividerStyleNone)
493const XTPGridSectionDividerStyle xtpReportSectionDividerStyleNone = xtpGridSectionDividerStyleNone;
494_XTP_DEPRECATED_IN_FAVOR(xtpGridSectionDividerStyleThin)
495const XTPGridSectionDividerStyle xtpReportSectionDividerStyleThin = xtpGridSectionDividerStyleThin;
496_XTP_DEPRECATED_IN_FAVOR(xtpGridSectionDividerStyleBold)
497const XTPGridSectionDividerStyle xtpReportSectionDividerStyleBold = xtpGridSectionDividerStyleBold;
498_XTP_DEPRECATED_IN_FAVOR(xtpGridSectionDividerStyleShade)
499const XTPGridSectionDividerStyle xtpReportSectionDividerStyleShade = xtpGridSectionDividerStyleShade;
500_XTP_DEPRECATED_IN_FAVOR(xtpGridSectionDividerStyleOutlook)
501const XTPGridSectionDividerStyle xtpReportSectionDividerStyleOutlook =
502 xtpGridSectionDividerStyleOutlook;
503_XTP_DEPRECATED_IN_FAVOR(xtpGridFixedRowsDividerNone)
504const XTPGridSectionDividerStyle xtpReportFixedRowsDividerNone = xtpGridFixedRowsDividerNone;
505_XTP_DEPRECATED_IN_FAVOR(xtpGridFixedRowsDividerThin)
506const XTPGridSectionDividerStyle xtpReportFixedRowsDividerThin = xtpGridFixedRowsDividerThin;
507_XTP_DEPRECATED_IN_FAVOR(xtpGridFixedRowsDividerBold)
508const XTPGridSectionDividerStyle xtpReportFixedRowsDividerBold = xtpGridFixedRowsDividerBold;
509_XTP_DEPRECATED_IN_FAVOR(xtpGridFixedRowsDividerShade)
510const XTPGridSectionDividerStyle xtpReportFixedRowsDividerShade = xtpGridFixedRowsDividerShade;
511_XTP_DEPRECATED_IN_FAVOR(xtpGridFixedRowsDividerOutlook)
512const XTPGridSectionDividerStyle xtpReportFixedRowsDividerOutlook = xtpGridFixedRowsDividerOutlook;
513
514_XTP_DEPRECATED_IN_FAVOR(xtpGridSectionDividerPositionTop)
515const XTPGridSectionDividerPosition xtpReportSectionDividerPositionTop =
516 xtpGridSectionDividerPositionTop;
517_XTP_DEPRECATED_IN_FAVOR(xtpGridSectionDividerPositionBottom)
518const XTPGridSectionDividerPosition xtpReportSectionDividerPositionBottom =
519 xtpGridSectionDividerPositionBottom;
520
521_XTP_DEPRECATED_IN_FAVOR(xtpGridDrawSortTriangleDefault)
522const XTPGridDrawSortTriangleStyle xtpReportDrawSortTriangleDefault = xtpGridDrawSortTriangleDefault;
523_XTP_DEPRECATED_IN_FAVOR(xtpGridDrawSortTriangleAlways)
524const XTPGridDrawSortTriangleStyle xtpReportDrawSortTriangleAlways = xtpGridDrawSortTriangleAlways;
525_XTP_DEPRECATED_IN_FAVOR(xtpGridDrawSortTriangleNever)
526const XTPGridDrawSortTriangleStyle xtpReportDrawSortTriangleNever = xtpGridDrawSortTriangleNever;
527
528_XTP_DEPRECATED_IN_FAVOR(xtpGridTextDecorationNone)
529const XTPGridTextDecoration xtpReportTextDecorationNone = xtpGridTextDecorationNone;
530_XTP_DEPRECATED_IN_FAVOR(xtpGridTextDecorationUnderline)
531const XTPGridTextDecoration xtpReportTextDecorationUnderline = xtpGridTextDecorationUnderline;
532
533_XTP_DEPRECATED_IN_FAVOR(xtpGridThemeDefault)
534const XTPGridPaintTheme xtpReportThemeDefault = xtpGridThemeDefault;
535_XTP_DEPRECATED_IN_FAVOR(xtpGridThemeOfficeXP)
536const XTPGridPaintTheme xtpReportThemeOfficeXP = xtpGridThemeOfficeXP;
537_XTP_DEPRECATED_IN_FAVOR(xtpGridThemeOffice2003)
538const XTPGridPaintTheme xtpReportThemeOffice2003 = xtpGridThemeOffice2003;
539_XTP_DEPRECATED_IN_FAVOR(xtpGridThemeOffice2003Luna)
540const XTPGridPaintTheme xtpReportThemeOffice2003Luna = xtpGridThemeOffice2003Luna;
541_XTP_DEPRECATED_IN_FAVOR(xtpGridThemeOffice2013)
542const XTPGridPaintTheme xtpReportThemeOffice2013 = xtpGridThemeOffice2013;
543_XTP_DEPRECATED_IN_FAVOR(xtpGridThemeOffice2016)
544const XTPGridPaintTheme xtpReportThemeOffice2016 = xtpGridThemeOffice2016;
545_XTP_DEPRECATED_IN_FAVOR(xtpGridThemeVisualStudio2012Light)
546const XTPGridPaintTheme xtpReportThemeVisualStudio2012Light = xtpGridThemeVisualStudio2012Light;
547_XTP_DEPRECATED_IN_FAVOR(xtpGridThemeVisualStudio2012Dark)
548const XTPGridPaintTheme xtpReportThemeVisualStudio2012Dark = xtpGridThemeVisualStudio2012Dark;
549_XTP_DEPRECATED_IN_FAVOR(xtpGridThemeVisualStudio2012Blue)
550const XTPGridPaintTheme xtpReportThemeVisualStudio2012Blue = xtpGridThemeVisualStudio2012Blue;
551_XTP_DEPRECATED_IN_FAVOR(xtpGridThemeVisualStudio2015)
552const XTPGridPaintTheme xtpReportThemeVisualStudio2015 = xtpGridThemeVisualStudio2015;
553_XTP_DEPRECATED_IN_FAVOR(xtpGridThemeExplorer)
554const XTPGridPaintTheme xtpReportThemeExplorer = xtpGridThemeExplorer;
555_XTP_DEPRECATED_IN_FAVOR(xtpGridThemeResource)
556const XTPGridPaintTheme xtpReportThemeResource = xtpGridThemeResource;
557_XTP_DEPRECATED_IN_FAVOR(xtpGridThemeNativeWindows10)
558const XTPGridPaintTheme xtpReportThemeNativeWindows10 = xtpGridThemeNativeWindows10;
559_XTP_DEPRECATED_IN_FAVOR(xtpGridThemeNativeWindows11)
560const XTPGridPaintTheme xtpReportThemeNativeWindows11 = xtpGridThemeNativeWindows11;
561_XTP_DEPRECATED_IN_FAVOR(xtpGridThemeVisualStudio2017)
562const XTPGridPaintTheme xtpReportThemeVisualStudio2017 = xtpGridThemeVisualStudio2017;
563_XTP_DEPRECATED_IN_FAVOR(xtpGridThemeVisualStudio2019)
564const XTPGridPaintTheme xtpReportThemeVisualStudio2019 = xtpGridThemeVisualStudio2019;
565_XTP_DEPRECATED_IN_FAVOR(xtpGridThemeVisualStudio2022)
566const XTPGridPaintTheme xtpReportThemeVisualStudio2022 = xtpGridThemeVisualStudio2022;
567
568_XTP_DEPRECATED_IN_FAVOR(xtpGridColumnChangeOther)
569const XTPGridColumnOrderChangedReason xtpReportColumnChangeOther = xtpGridColumnChangeOther;
570_XTP_DEPRECATED_IN_FAVOR(xtpGridColumnOrderChanged)
571const XTPGridColumnOrderChangedReason xtpReportColumnOrderChanged = xtpGridColumnOrderChanged;
572_XTP_DEPRECATED_IN_FAVOR(xtpGridColumnGroupOrderChanged)
573const XTPGridColumnOrderChangedReason xtpReportColumnGroupOrderChanged =
574 xtpGridColumnGroupOrderChanged;
575_XTP_DEPRECATED_IN_FAVOR(xtpGridColumnOrderChangedMask)
576const XTPGridColumnOrderChangedReason xtpReportColumnOrderChangedMask =
577 xtpGridColumnOrderChangedMask;
578_XTP_DEPRECATED_IN_FAVOR(xtpGridColumnAdded)
579const XTPGridColumnOrderChangedReason xtpReportColumnAdded = xtpGridColumnAdded;
580_XTP_DEPRECATED_IN_FAVOR(xtpGridColumnRemoved)
581const XTPGridColumnOrderChangedReason xtpReportColumnRemoved = xtpGridColumnRemoved;
582_XTP_DEPRECATED_IN_FAVOR(xtpGridColumnPropExchange)
583const XTPGridColumnOrderChangedReason xtpReportColumnPropExchange = xtpGridColumnPropExchange;
584_XTP_DEPRECATED_IN_FAVOR(xtpGridColumnCaptionChanged)
585const XTPGridColumnOrderChangedReason xtpReportColumnCaptionChanged = xtpGridColumnCaptionChanged;
586_XTP_DEPRECATED_IN_FAVOR(xtpGridColumnWidthChanged)
587const XTPGridColumnOrderChangedReason xtpReportColumnWidthChanged = xtpGridColumnWidthChanged;
588_XTP_DEPRECATED_IN_FAVOR(xtpGridColumnShown)
589const XTPGridColumnOrderChangedReason xtpReportColumnShown = xtpGridColumnShown;
590_XTP_DEPRECATED_IN_FAVOR(xtpGridColumnHidden)
591const XTPGridColumnOrderChangedReason xtpReportColumnHidden = xtpGridColumnHidden;
592_XTP_DEPRECATED_IN_FAVOR(xtpGridColumnMoved)
593const XTPGridColumnOrderChangedReason xtpReportColumnMoved = xtpGridColumnMoved;
594_XTP_DEPRECATED_IN_FAVOR(xtpGridColumnAddedToGroupby)
595const XTPGridColumnOrderChangedReason xtpReportColumnAddedToGroupby = xtpGridColumnAddedToGroupby;
596_XTP_DEPRECATED_IN_FAVOR(xtpGridColumnRemovedFromGroupby)
597const XTPGridColumnOrderChangedReason xtpReportColumnRemovedFromGroupby =
598 xtpGridColumnRemovedFromGroupby;
599_XTP_DEPRECATED_IN_FAVOR(xtpGridColumnAddedToFieldChooser)
600const XTPGridColumnOrderChangedReason xtpReportColumnAddedToFieldChooser =
601 xtpGridColumnAddedToFieldChooser;
602_XTP_DEPRECATED_IN_FAVOR(xtpGridColumnRemovedFromFieldChooser)
603const XTPGridColumnOrderChangedReason xtpReportColumnRemovedFromFieldChooser =
604 xtpGridColumnRemovedFromFieldChooser;
605_XTP_DEPRECATED_IN_FAVOR(xtpGridColumnChangeMask)
606const XTPGridColumnOrderChangedReason xtpReportColumnChangeMask = xtpGridColumnChangeMask;
607
608_XTP_DEPRECATED_IN_FAVOR(xtpGridColumnDirectionLeft)
609const XTPGridColumnDirection xtpReportColumnDirectionLeft = xtpGridColumnDirectionLeft;
610_XTP_DEPRECATED_IN_FAVOR(xtpGridColumnDirectionRight)
611const XTPGridColumnDirection xtpReportColumnDirectionRight = xtpGridColumnDirectionRight;
612
613_XTP_DEPRECATED_IN_FAVOR(xtpGridHitTestUnknown)
614const XTPGridHitTestInfoCode xtpReportHitTestUnknown = xtpGridHitTestUnknown;
615_XTP_DEPRECATED_IN_FAVOR(xtpGridHitTestHeader)
616const XTPGridHitTestInfoCode xtpReportHitTestHeader = xtpGridHitTestHeader;
617_XTP_DEPRECATED_IN_FAVOR(xtpGridHitTestGroupBox)
618const XTPGridHitTestInfoCode xtpReportHitTestGroupBox = xtpGridHitTestGroupBox;
619_XTP_DEPRECATED_IN_FAVOR(xtpGridHitTestBodyRows)
620const XTPGridHitTestInfoCode xtpReportHitTestBodyRows = xtpGridHitTestBodyRows;
621_XTP_DEPRECATED_IN_FAVOR(xtpGridHitTestBlock)
622const XTPGridHitTestInfoCode xtpReportHitTestBlock = xtpGridHitTestBlock;
623_XTP_DEPRECATED_IN_FAVOR(xtpGridHitTestHeaderRows)
624const XTPGridHitTestInfoCode xtpReportHitTestHeaderRows = xtpGridHitTestHeaderRows;
625_XTP_DEPRECATED_IN_FAVOR(xtpGridHitTestFooterRows)
626const XTPGridHitTestInfoCode xtpReportHitTestFooterRows = xtpGridHitTestFooterRows;
627
628_XTP_DEPRECATED_IN_FAVOR(xtpGridTextSearchExactPhrase)
629const XTPGridTextSearchParms xtpReportTextSearchExactPhrase = xtpGridTextSearchExactPhrase;
630_XTP_DEPRECATED_IN_FAVOR(xtpGridTextSearchMatchCase)
631const XTPGridTextSearchParms xtpReportTextSearchMatchCase = xtpGridTextSearchMatchCase;
632_XTP_DEPRECATED_IN_FAVOR(xtpGridTextSearchBackward)
633const XTPGridTextSearchParms xtpReportTextSearchBackward = xtpGridTextSearchBackward;
634_XTP_DEPRECATED_IN_FAVOR(xtpGridTextSearchExactStart)
635const XTPGridTextSearchParms xtpReportTextSearchExactStart = xtpGridTextSearchExactStart;
636
637_XTP_DEPRECATED_IN_FAVOR(xtpGridSelectionAdd)
638const XTPGridSelectionChangeType xtpReportSelectionAdd = xtpGridSelectionAdd;
639_XTP_DEPRECATED_IN_FAVOR(xtpGridSelectionRemove)
640const XTPGridSelectionChangeType xtpReportSelectionRemove = xtpGridSelectionRemove;
641_XTP_DEPRECATED_IN_FAVOR(xtpGridSelectionClear)
642const XTPGridSelectionChangeType xtpReportSelectionClear = xtpGridSelectionClear;
643
644_XTP_DEPRECATED_IN_FAVOR(xtpGridSectionHeightModeFixed)
645const XTPGridSectionHeightMode xtpReportSectionHeightModeFixed = xtpGridSectionHeightModeFixed;
646_XTP_DEPRECATED_IN_FAVOR(xtpGridSectionHeightModeRelative)
647const XTPGridSectionHeightMode xtpReportSectionHeightModeRelative = xtpGridSectionHeightModeRelative;
648_XTP_DEPRECATED_IN_FAVOR(xtpGridSectionHeightModeAuto)
649const XTPGridSectionHeightMode xtpReportSectionHeightModeAuto = xtpGridSectionHeightModeAuto;
650_XTP_DEPRECATED_IN_FAVOR(xtpGridSectionHeightModeExpand)
651const XTPGridSectionHeightMode xtpReportSectionHeightModeExpand = xtpGridSectionHeightModeExpand;
652_XTP_DEPRECATED_IN_FAVOR(xtpGridSectionHeightModeAutoExpand)
653const XTPGridSectionHeightMode xtpReportSectionHeightModeAutoExpand =
654 xtpGridSectionHeightModeAutoExpand;
655_XTP_DEPRECATED_IN_FAVOR(xtpGridSectionHeightModeAutoShrink)
656const XTPGridSectionHeightMode xtpReportSectionHeightModeAutoShrink =
657 xtpGridSectionHeightModeAutoShrink;
658
659_XTP_DEPRECATED_IN_FAVOR(xtpGridSectionHeader)
660const XTPGridSection xtpReportSectionHeader = xtpGridSectionHeader;
661_XTP_DEPRECATED_IN_FAVOR(xtpGridSectionBody)
662const XTPGridSection xtpReportSectionBody = xtpGridSectionBody;
663_XTP_DEPRECATED_IN_FAVOR(xtpGridSectionFooter)
664const XTPGridSection xtpReportSectionFooter = xtpGridSectionFooter;
665_XTP_DEPRECATED_IN_FAVOR(xtpGridSectionCount)
666const XTPGridSection xtpReportSectionCount = xtpGridSectionCount;
667
668_XTP_DEPRECATED_IN_FAVOR(XTP_GRIDRECORDITEM_DRAWARGS)
669typedef XTP_GRIDRECORDITEM_DRAWARGS XTP_REPORTRECORDITEM_DRAWARGS;
670_XTP_DEPRECATED_IN_FAVOR(XTP_GRIDRECORDITEM_METRICS)
671typedef XTP_GRIDRECORDITEM_METRICS XTP_REPORTRECORDITEM_METRICS;
672_XTP_DEPRECATED_IN_FAVOR(XTP_GRIDRECORDITEM_ARGS)
673typedef XTP_GRIDRECORDITEM_ARGS XTP_REPORTRECORDITEM_ARGS;
674_XTP_DEPRECATED_IN_FAVOR(XTP_NM_GRIDTOOLTIPINFO)
675typedef XTP_NM_GRIDTOOLTIPINFO XTP_NM_REPORTTOOLTIPINFO;
676_XTP_DEPRECATED_IN_FAVOR(XTP_NM_GRIDITEMMETRICS)
677typedef XTP_NM_GRIDITEMMETRICS XTP_NM_REPORTITEMMETRICS;
678_XTP_DEPRECATED_IN_FAVOR(XTP_NM_GRIDDRAGDROP)
679typedef XTP_NM_GRIDDRAGDROP XTP_NM_REPORTDRAGDROP;
680_XTP_DEPRECATED_IN_FAVOR(XTP_NM_GRIDPREVIEWKEYDOWN)
681typedef XTP_NM_GRIDPREVIEWKEYDOWN XTP_NM_REPORTPREVIEWKEYDOWN;
682_XTP_DEPRECATED_IN_FAVOR(XTPGridInputState)
683typedef XTPGridInputState XTPReportInputState;
684_XTP_DEPRECATED_IN_FAVOR(XTP_GRIDDATAMANAGER_COM_ERROR)
685typedef XTP_GRIDDATAMANAGER_COM_ERROR XTP_REPORTDATAMANAGER_COM_ERROR;
686_XTP_DEPRECATED_IN_FAVOR(XTP_NM_GRIDSCROLL)
687typedef XTP_NM_GRIDSCROLL XTP_NM_REPORTSCROLL;
688_XTP_DEPRECATED_IN_FAVOR(XTP_NM_GRIDGIVEFEEDBACK)
689typedef XTP_NM_GRIDGIVEFEEDBACK XTP_NM_REPORTGIVEFEEDBACK;
690_XTP_DEPRECATED_IN_FAVOR(XTP_NM_GRIDCOLUMNRESIZE)
691typedef XTP_NM_GRIDCOLUMNRESIZE XTP_NM_REPORTCOLUMNRESIZE;
692_XTP_DEPRECATED_IN_FAVOR(XTP_NM_GRIDROWRESIZE)
693typedef XTP_NM_GRIDROWRESIZE XTP_NM_REPORTROWRESIZE;
694_XTP_DEPRECATED_IN_FAVOR(XTP_NM_GRIDCOLUMNORDERCHANGED)
695typedef XTP_NM_GRIDCOLUMNORDERCHANGED XTP_NM_REPORTCOLUMNORDERCHANGED;
696_XTP_DEPRECATED_IN_FAVOR(XTP_GRIDRECORDITEM_CLICKARGS)
697typedef XTP_GRIDRECORDITEM_CLICKARGS XTP_REPORTRECORDITEM_CLICKARGS;
698_XTP_DEPRECATED_IN_FAVOR(XTP_NM_GRIDRECORDITEM)
699typedef XTP_NM_GRIDRECORDITEM XTP_NM_REPORTRECORDITEM;
700_XTP_DEPRECATED_IN_FAVOR(XTP_NM_GRIDREQUESTEDIT)
701typedef XTP_NM_GRIDREQUESTEDIT XTP_NM_REPORTREQUESTEDIT;
702_XTP_DEPRECATED_IN_FAVOR(XTP_NM_GRIDINPLACEBUTTON)
703typedef XTP_NM_GRIDINPLACEBUTTON XTP_NM_REPORTINPLACEBUTTON;
704_XTP_DEPRECATED_IN_FAVOR(XTP_NM_GRID_BEFORE_COPYPASTE)
705typedef XTP_NM_GRID_BEFORE_COPYPASTE XTP_NM_REPORT_BEFORE_COPYPASTE;
706_XTP_DEPRECATED_IN_FAVOR(XTP_NM_GRIDCONSTRAINTSELECTING)
707typedef XTP_NM_GRIDCONSTRAINTSELECTING XTP_NM_REPORTCONSTRAINTSELECTING;
708_XTP_DEPRECATED_IN_FAVOR(XTP_NM_GRIDTOOLTIPINFO)
709typedef XTP_NM_GRIDTOOLTIPINFO XTP_NM_REPORTTOOLTIPINFO;
710_XTP_DEPRECATED_IN_FAVOR(XTP_GRIDRECORDITEM_METRICS)
711typedef XTP_GRIDRECORDITEM_METRICS XTP_REPORTRECORDITEM_METRICS;
712_XTP_DEPRECATED_IN_FAVOR(XTP_NM_GRIDITEMCONTROL)
713typedef XTP_NM_GRIDITEMCONTROL XTP_NM_REPORTITEMCONTROL;
714_XTP_DEPRECATED_IN_FAVOR(XTP_NM_GRIDSTATECHANGED)
715typedef XTP_NM_GRIDSTATECHANGED XTP_NM_REPORTSTATECHANGED;
716
717# ifdef _XTP_ACTIVEX
718_XTP_DEPRECATED_IN_FAVOR(XTP_NM_GRIDVALUECHANGING)
719typedef XTP_NM_GRIDVALUECHANGING XTP_NM_REPORTVALUECHANGING;
720# endif
721
722namespace XTPREPORTADODB = XTPGRIDADODB;
723
724# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
725#endif //#if !defined(__XTPGRIDDEPRECATED_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPGridBehavior
XTPGridBehavior
Defines grid behavior.
Definition XTPGridBehavior.h:57
xtpGridBehaviorCodejockDefault
@ xtpGridBehaviorCodejockDefault
The latest default behavior.
Definition XTPGridBehavior.h:85
xtpGridBehaviorOutlook2010
@ xtpGridBehaviorOutlook2010
Specifies behavior similar to Outlook 2010 that was the default behavior of the control's version 14....
Definition XTPGridBehavior.h:64
xtpGridBehaviorExcel2003
@ xtpGridBehaviorExcel2003
Specifies behavior similar to Excel 2003 that was the default behavior of the control's version 11....
Definition XTPGridBehavior.h:68
xtpGridBehaviorOutlook2007
@ xtpGridBehaviorOutlook2007
Specifies behavior similar to Outlook 2007 that was the default behavior of the control's version 12....
Definition XTPGridBehavior.h:61
xtpGridBehaviorCodejock1340
@ xtpGridBehaviorCodejock1340
The default behavior of the control's version 13.4.0.
Definition XTPGridBehavior.h:75
xtpGridBehaviorExcel2010
@ xtpGridBehaviorExcel2010
Specifies behavior similar to Excel 2010 that was the default behavior of the control's version 14....
Definition XTPGridBehavior.h:72
xtpGridBehaviorCodejock1502
@ xtpGridBehaviorCodejock1502
The default behavior of the control's version 15.0.2.
Definition XTPGridBehavior.h:83
xtpGridBehaviorOutlook2003
@ xtpGridBehaviorOutlook2003
Specifies behavior similar to Outlook 2003 that was the default behavior of the control's version 11....
Definition XTPGridBehavior.h:58
xtpGridBehaviorCodejock1341
@ xtpGridBehaviorCodejock1341
The default behavior of the control's version 13.4.1.
Definition XTPGridBehavior.h:77
xtpGridBehaviorCodejock1342
@ xtpGridBehaviorCodejock1342
The default behavior of the control's version 13.4.2.
Definition XTPGridBehavior.h:79
xtpGridBehaviorCodejock1501
@ xtpGridBehaviorCodejock1501
The default behavior of the control's version 15.0.1.
Definition XTPGridBehavior.h:81
xtpGridBehaviorExcel2007
@ xtpGridBehaviorExcel2007
Specifies behavior similar to Excel 2007 that was the default behavior of the control's version 12....
Definition XTPGridBehavior.h:70
XTPGridMouseEvent
XTPGridMouseEvent
Defines a mouse event.
Definition XTPGridBehavior.h:48
xtpGridMouseEventButtonDown
@ xtpGridMouseEventButtonDown
Specifies a mouse button down mouse event.
Definition XTPGridBehavior.h:49
xtpGridMouseEventButtonUp
@ xtpGridMouseEventButtonUp
Specifies a mouse button up event.
Definition XTPGridBehavior.h:50
XTPGridMouseButton
XTPGridMouseButton
Defines a mouse button.
Definition XTPGridBehavior.h:37
xtpGridMouseButtonMiddle
@ xtpGridMouseButtonMiddle
Specifies a middle mouse button.
Definition XTPGridBehavior.h:40
xtpGridMouseButtonLeft
@ xtpGridMouseButtonLeft
Specifies a left mouse button.
Definition XTPGridBehavior.h:39
xtpGridMouseButtonRight
@ xtpGridMouseButtonRight
Specifies a right mouse button.
Definition XTPGridBehavior.h:41
xtpGridMouseButtonNone
@ xtpGridMouseButtonNone
No mouse button.
Definition XTPGridBehavior.h:38
XTPGridBorderEdge
XTPGridBorderEdge
Defines a grid border edge.
Definition XTPGridBorder.h:39
xtpGridBorderEdgeLeft
@ xtpGridBorderEdgeLeft
Specifies a left grid border edge.
Definition XTPGridBorder.h:40
xtpGridBorderEdgeBottom
@ xtpGridBorderEdgeBottom
Specifies a bottom grid border edge.
Definition XTPGridBorder.h:43
xtpGridBorderEdgeCount
@ xtpGridBorderEdgeCount
Specifies the number of grid border edges.
Definition XTPGridBorder.h:44
xtpGridBorderEdgeRight
@ xtpGridBorderEdgeRight
Specifies a right grid border edge.
Definition XTPGridBorder.h:42
xtpGridBorderEdgeTop
@ xtpGridBorderEdgeTop
Specifies a top grid border edge.
Definition XTPGridBorder.h:41
XTPGridColumnBestFitMode
XTPGridColumnBestFitMode
This enum defines the best fit mode.
Definition XTPGridColumn.h:44
XTPGridScrollUpdateMode
XTPGridScrollUpdateMode
Enumeration of scroll update modes.
Definition XTPGridControl.h:310
xtpGridScrollUpdateModeDeferred
@ xtpGridScrollUpdateModeDeferred
Updates the scroll position deferred.
Definition XTPGridControl.h:312
xtpGridScrollUpdateModeImmediate
@ xtpGridScrollUpdateModeImmediate
Immediately updates the scroll position.
Definition XTPGridControl.h:311
XTPGridDragDrop
XTPGridDragDrop
Enumeration of drag and drop flags.
Definition XTPGridControl.h:207
xtpGridAllowDragCopy
@ xtpGridAllowDragCopy
Allow copy records from grid.
Definition XTPGridControl.h:209
xtpGridAllowDrag
@ xtpGridAllowDrag
Allow copy and move records from grid.
Definition XTPGridControl.h:211
xtpGridAllowDragMove
@ xtpGridAllowDragMove
Allow move records from grid.
Definition XTPGridControl.h:210
xtpGridDontDropAsText
@ xtpGridDontDropAsText
Do not drag record as plain text.
Definition XTPGridControl.h:212
xtpGridAllowDrop
@ xtpGridAllowDrop
Allow drop records to grid.
Definition XTPGridControl.h:208
XTPGridMouseMode
XTPGridMouseMode
Enumeration of operational mouse modes.
Definition XTPGridControl.h:186
xtpGridMouseNothing
@ xtpGridMouseNothing
User is just watching to the list.
Definition XTPGridControl.h:187
xtpGridMouseOverRowDivide
@ xtpGridMouseOverRowDivide
User watching, but mouse is under row divider.
Definition XTPGridControl.h:191
xtpGridMouseDraggingColumn
@ xtpGridMouseDraggingColumn
User is dragging column header.
Definition XTPGridControl.h:190
xtpGridMousePrepareDragColumn
@ xtpGridMousePrepareDragColumn
User holds mouse button pressed on the column header.
Definition XTPGridControl.h:189
xtpGridMouseOverColumnDivide
@ xtpGridMouseOverColumnDivide
User watching, but mouse is under column divider.
Definition XTPGridControl.h:188
XTPGridWatermarkAlignment
XTPGridWatermarkAlignment
Enumeration of watermark alignment flags.
Definition XTPGridControl.h:237
xtpGridWatermarkHmask
@ xtpGridWatermarkHmask
A mask for horizontal alignment flags.
Definition XTPGridControl.h:246
xtpGridWatermarkStretch
@ xtpGridWatermarkStretch
Stretch watermark to entire Grid control client rect.
Definition XTPGridControl.h:252
xtpGridWatermarkShrinkOnly
@ xtpGridWatermarkShrinkOnly
Watermark can be shrinked only, enlarging is disabled.
Definition XTPGridControl.h:255
xtpGridWatermarkBottom
@ xtpGridWatermarkBottom
Vertical alignment: bottom side of Grid control client rect.
Definition XTPGridControl.h:249
xtpGridWatermarkCenter
@ xtpGridWatermarkCenter
Horizontal alignment: center of Grid control client rect.
Definition XTPGridControl.h:242
xtpGridWatermarkVmask
@ xtpGridWatermarkVmask
A mask for vertical alignment flags.
Definition XTPGridControl.h:251
xtpGridWatermarkLeft
@ xtpGridWatermarkLeft
Horizontal alignment: left side of Grid control client rect.
Definition XTPGridControl.h:240
xtpGridWatermarkTop
@ xtpGridWatermarkTop
Vertical alignment: top side of Grid control client rect.
Definition XTPGridControl.h:247
xtpGridWatermarkVCenter
@ xtpGridWatermarkVCenter
Vertical alignment: center of Grid control client rect.
Definition XTPGridControl.h:248
xtpGridWatermarkEnlargeOnly
@ xtpGridWatermarkEnlargeOnly
Watermark can be enlarged only, shrinking is disabled.
Definition XTPGridControl.h:253
xtpGridWatermarkRight
@ xtpGridWatermarkRight
Horizontal alignment: right side of Grid control client rect.
Definition XTPGridControl.h:244
xtpGridWatermarkPreserveRatio
@ xtpGridWatermarkPreserveRatio
Watermark aspect ratio is preserved.
Definition XTPGridControl.h:257
xtpGridWatermarkUnknown
@ xtpGridWatermarkUnknown
Unknown (empty) value.
Definition XTPGridControl.h:238
XTPGridScrollMode
XTPGridScrollMode
Enumeration of scroll modes.
Definition XTPGridControl.h:320
xtpGridScrollModeBlock
@ xtpGridScrollModeBlock
Deprecated, same as xtpGridScrollModeBlockCount.
Definition XTPGridControl.h:328
xtpGridScrollModeNone
@ xtpGridScrollModeNone
No scrolling.
Definition XTPGridControl.h:321
xtpGridScrollModeBlockCount
@ xtpGridScrollModeBlockCount
Scrolls an entire row or column.
Definition XTPGridControl.h:322
xtpGridScrollModeBlockSize
@ xtpGridScrollModeBlockSize
Scrolls an entire row or column.
Definition XTPGridControl.h:323
xtpGridScrollModeSmooth
@ xtpGridScrollModeSmooth
Smooth scrolling.
Definition XTPGridControl.h:324
XTPGridDropMarker
XTPGridDropMarker
Enumeration describes the drop marker.
Definition XTPGridControl.h:220
xtpGridDropSelect
@ xtpGridDropSelect
Drop the selected rows.
Definition XTPGridControl.h:222
xtpGridDropBetween
@ xtpGridDropBetween
Drop the row between two rows.
Definition XTPGridControl.h:221
XTPGridFilterMode
XTPGridFilterMode
Enumeration of options for the SetRecordsTreeFilterMode method.
Definition XTPGridControl.h:297
xtpGridFilterTreeByParentAndChildren
@ xtpGridFilterTreeByParentAndChildren
Specifies a parent-children tree grid filter mode.
Definition XTPGridControl.h:299
xtpGridFilterTreeSimple
@ xtpGridFilterTreeSimple
Specifies a simple tree grid filter mode.
Definition XTPGridControl.h:298
xtpGridFilterTreeByEndChildrenOnly
@ xtpGridFilterTreeByEndChildrenOnly
Specifies a end children only tree grid filter mode.
Definition XTPGridControl.h:301
XTPGridElementRect
XTPGridElementRect
Enumeration of GetElementRect flags.
Definition XTPGridControl.h:272
xtpGridElementRectHeaderRecordsArea
@ xtpGridElementRectHeaderRecordsArea
The area occupied by the header records.
Definition XTPGridControl.h:277
xtpGridElementRectGridArea
@ xtpGridElementRectGridArea
The area occupied by the records.
Definition XTPGridControl.h:273
xtpGridElementRectHeaderArea
@ xtpGridElementRectHeaderArea
The area occupied by the header.
Definition XTPGridControl.h:275
xtpGridElementRectFooterRecordsDividerArea
@ xtpGridElementRectFooterRecordsDividerArea
The area occupied by the footer records divider.
Definition XTPGridControl.h:281
xtpGridElementRectFooterRecordsArea
@ xtpGridElementRectFooterRecordsArea
The area occupied by the footer records.
Definition XTPGridControl.h:278
xtpGridElementRectFooterArea
@ xtpGridElementRectFooterArea
The area occupied by the footer.
Definition XTPGridControl.h:276
xtpGridElementRectHeaderRecordsDividerArea
@ xtpGridElementRectHeaderRecordsDividerArea
The area occupied by the header records divider.
Definition XTPGridControl.h:279
xtpGridElementRectGroupByArea
@ xtpGridElementRectGroupByArea
The area occupied by Group By item.
Definition XTPGridControl.h:274
XTPGridShellIcon
XTPGridShellIcon
This enum defines the shell icons.
Definition XTPGridDefines.h:49
xtpGridShellIconLock
@ xtpGridShellIconLock
Specifies a Lock icon.
Definition XTPGridDefines.h:50
XTPGridTextDecoration
XTPGridTextDecoration
Enumeration of hyperlink text decorations.
Definition XTPGridDefines.h:284
xtpGridTextDecorationUnderline
@ xtpGridTextDecorationUnderline
Text is underlined.
Definition XTPGridDefines.h:286
xtpGridTextDecorationNone
@ xtpGridTextDecorationNone
Text has no decoration.
Definition XTPGridDefines.h:285
XTPGridTreeStructureStyle
XTPGridTreeStructureStyle
Represent the style of lines used to draw a hierarchical tree structure.
Definition XTPGridDefines.h:213
xtpGridTreeStructureDots
@ xtpGridTreeStructureDots
Dots will be drawn from the parent node to each child node at the next level.
Definition XTPGridDefines.h:218
xtpGridTreeStructureSolid
@ xtpGridTreeStructureSolid
Lines will be drawn from the parent node to each child node at the next level.
Definition XTPGridDefines.h:216
xtpGridTreeStructureNone
@ xtpGridTreeStructureNone
No lines will be drawn from the parent node to each child node.
Definition XTPGridDefines.h:214
XTPGridLineStyle
XTPGridLineStyle
Represents predefined grid line styles.
Definition XTPGridDefines.h:126
xtpGridLineStyleDotLarge
@ xtpGridLineStyleDotLarge
Line is drawn with large dots.
Definition XTPGridDefines.h:129
xtpGridLineStyleDash
@ xtpGridLineStyleDash
Line is drawn with dashes.
Definition XTPGridDefines.h:130
xtpGridGridLargeDots
@ xtpGridGridLargeDots
Deprecated.
Definition XTPGridDefines.h:139
xtpGridLineStyleCount
@ xtpGridLineStyleCount
Number of line styles.
Definition XTPGridDefines.h:132
xtpGridLineStyleDotSmall
@ xtpGridLineStyleDotSmall
Line is drawn with small dots.
Definition XTPGridDefines.h:128
xtpGridLineStyleNone
@ xtpGridLineStyleNone
No line.
Definition XTPGridDefines.h:127
xtpGridGridSolid
@ xtpGridGridSolid
Deprecated.
Definition XTPGridDefines.h:142
xtpGridGridSmallDots
@ xtpGridGridSmallDots
Deprecated.
Definition XTPGridDefines.h:137
xtpGridLineStyleSolid
@ xtpGridLineStyleSolid
Solid line.
Definition XTPGridDefines.h:131
xtpGridGridDashes
@ xtpGridGridDashes
Deprecated.
Definition XTPGridDefines.h:141
xtpGridGridNoLines
@ xtpGridGridNoLines
Deprecated.
Definition XTPGridDefines.h:136
XTPGridDrawSortTriangleStyle
XTPGridDrawSortTriangleStyle
Represent the Grid Draw Sort Triangle logic.
Definition XTPGridDefines.h:268
xtpGridDrawSortTriangleDefault
@ xtpGridDrawSortTriangleDefault
The triangle will be removed when the column size is too small to display the full caption and triang...
Definition XTPGridDefines.h:269
xtpGridDrawSortTriangleNever
@ xtpGridDrawSortTriangleNever
Never draw the triangle.
Definition XTPGridDefines.h:274
xtpGridDrawSortTriangleAlways
@ xtpGridDrawSortTriangleAlways
The sort triangle displayed in column header when a column is sorted and the caption will be cut with...
Definition XTPGridDefines.h:271
XTPGridColumnStyle
XTPGridColumnStyle
Represents predefined column styles.
Definition XTPGridDefines.h:183
xtpGridColumnShaded
@ xtpGridColumnShaded
Columns are gray shaded.
Definition XTPGridDefines.h:184
xtpGridColumnOffice2003
@ xtpGridColumnOffice2003
Gradient column style.
Definition XTPGridDefines.h:187
xtpGridColumnExplorer
@ xtpGridColumnExplorer
Explorer column style.
Definition XTPGridDefines.h:186
xtpGridColumnResource
@ xtpGridColumnResource
Office 2007/2010 column style.
Definition XTPGridDefines.h:188
xtpGridColumnFlat
@ xtpGridColumnFlat
Flat style for drawing columns.
Definition XTPGridDefines.h:185
XTPGridOrientation
XTPGridOrientation
Enumeration of orientations.
Definition XTPGridDefines.h:108
xtpGridOrientationHorizontal
@ xtpGridOrientationHorizontal
Specifies horizontal grid orientation.
Definition XTPGridDefines.h:109
xtpGridOrientationAll
@ xtpGridOrientationAll
Specifies both horizontal and vertical grid orientations.
Definition XTPGridDefines.h:111
xtpGridOrientationVertical
@ xtpGridOrientationVertical
Specifies vertical grid orientation.
Definition XTPGridDefines.h:110
XTPGridRowType
XTPGridRowType
This enum defines body, header, and footer rows.
Definition XTPGridDefines.h:94
XTPGridSectionDividerPosition
XTPGridSectionDividerPosition
Section divider position.
Definition XTPGridDefines.h:258
xtpGridSectionDividerPositionTop
@ xtpGridSectionDividerPositionTop
Divider above the section.
Definition XTPGridDefines.h:259
xtpGridSectionDividerPositionBottom
@ xtpGridSectionDividerPositionBottom
Divider below the section.
Definition XTPGridDefines.h:260
XTPGridPaintTheme
XTPGridPaintTheme
Visual theme enumeration.
Definition XTPGridDefines.h:299
xtpGridThemeVisualStudio2017
@ xtpGridThemeVisualStudio2017
Visual Studio 2017 style theme.
Definition XTPGridDefines.h:313
xtpGridThemeOffice2013
@ xtpGridThemeOffice2013
Office 2013 style theme.
Definition XTPGridDefines.h:304
xtpGridThemeVisualStudio2012Blue
@ xtpGridThemeVisualStudio2012Blue
Visual Studio 2012 Blue style theme.
Definition XTPGridDefines.h:308
xtpGridThemeExplorer
@ xtpGridThemeExplorer
Windows Explorer theme.
Definition XTPGridDefines.h:310
xtpGridThemeResource
@ xtpGridThemeResource
Resource .DLL style theme.
Definition XTPGridDefines.h:311
xtpGridThemeOfficeXP
@ xtpGridThemeOfficeXP
Office XP style theme.
Definition XTPGridDefines.h:301
xtpGridThemeVisualStudio2022
@ xtpGridThemeVisualStudio2022
Visual Studio 2022 style theme.
Definition XTPGridDefines.h:315
xtpGridThemeOffice2016
@ xtpGridThemeOffice2016
Office 2016 style theme.
Definition XTPGridDefines.h:305
xtpGridThemeNativeWindows10
@ xtpGridThemeNativeWindows10
Windows 10 style theme.
Definition XTPGridDefines.h:312
xtpGridThemeVisualStudio2019
@ xtpGridThemeVisualStudio2019
Visual Studio 2019 style theme.
Definition XTPGridDefines.h:314
xtpGridThemeVisualStudio2015
@ xtpGridThemeVisualStudio2015
Visual Studio 2015 style theme.
Definition XTPGridDefines.h:309
xtpGridThemeOffice2003
@ xtpGridThemeOffice2003
Office 2003 style theme.
Definition XTPGridDefines.h:302
xtpGridThemeVisualStudio2012Light
@ xtpGridThemeVisualStudio2012Light
Visual Studio 2012 Light style theme.
Definition XTPGridDefines.h:306
xtpGridThemeNativeWindows11
@ xtpGridThemeNativeWindows11
Windows 11 style theme.
Definition XTPGridDefines.h:316
xtpGridThemeOffice2003Luna
@ xtpGridThemeOffice2003Luna
Office 2003 style theme with luna colors.
Definition XTPGridDefines.h:303
xtpGridThemeVisualStudio2012Dark
@ xtpGridThemeVisualStudio2012Dark
Visual Studio 2012 Dark style theme.
Definition XTPGridDefines.h:307
xtpGridThemeDefault
@ xtpGridThemeDefault
Default theme.
Definition XTPGridDefines.h:300
XTPGridCheckState
XTPGridCheckState
This enum defines the possible checkbox states.
Definition XTPGridDefines.h:79
xtpGridCheckStateIndeterminate
@ xtpGridCheckStateIndeterminate
The checkbox is in an indeterminate state.
Definition XTPGridDefines.h:83
xtpGridCheckStateCount
@ xtpGridCheckStateCount
Number of checkbox states.
Definition XTPGridDefines.h:84
xtpGridCheckStateUnchecked
@ xtpGridCheckStateUnchecked
The checkbox is in an unchecked state.
Definition XTPGridDefines.h:81
xtpGridCheckStateInvalid
@ xtpGridCheckStateInvalid
The checkbox state is invalid.
Definition XTPGridDefines.h:80
xtpGridCheckStateChecked
@ xtpGridCheckStateChecked
The checkbox is in a checked state.
Definition XTPGridDefines.h:82
XTPGridGlyph
XTPGridGlyph
This enum defines the index of the glyphs.
Definition XTPGridDefines.h:58
xtpGridGlyphItemUnlocked
@ xtpGridGlyphItemUnlocked
Specifies an unlocked item glyph.
Definition XTPGridDefines.h:70
xtpGridGlyphCount
@ xtpGridGlyphCount
The number of the glyphs.
Definition XTPGridDefines.h:71
xtpGridGlyphRowCollapse
@ xtpGridGlyphRowCollapse
Specifies a row collapse glyph.
Definition XTPGridDefines.h:60
xtpGridGlyphEnabledChecked
@ xtpGridGlyphEnabledChecked
Specifies an enabled checked glyph.
Definition XTPGridDefines.h:63
xtpGridGlyphColumnRestore
@ xtpGridGlyphColumnRestore
Specifies a column restore glyph.
Definition XTPGridDefines.h:67
xtpGridGlyphDisabledChecked
@ xtpGridGlyphDisabledChecked
Specifies a disabled checked glyph.
Definition XTPGridDefines.h:65
xtpGridGlyphItemLocked
@ xtpGridGlyphItemLocked
Specifies a locked item glyph.
Definition XTPGridDefines.h:69
xtpGridGlyphRowExpand
@ xtpGridGlyphRowExpand
Specifies a row expand glyph.
Definition XTPGridDefines.h:61
xtpGridGlyphColumnExpand
@ xtpGridGlyphColumnExpand
Specifies a column expand glyph.
Definition XTPGridDefines.h:66
xtpGridGlyphInvalid
@ xtpGridGlyphInvalid
Specifies an invalid glyph.
Definition XTPGridDefines.h:59
xtpGridGlyphDisabledUnchecked
@ xtpGridGlyphDisabledUnchecked
Specifies a disabled unchecked glyph.
Definition XTPGridDefines.h:64
xtpGridGlyphEnabledUnchecked
@ xtpGridGlyphEnabledUnchecked
Specifies an enabled unchecked glyph.
Definition XTPGridDefines.h:62
xtpGridGlyphEnabledTristate
@ xtpGridGlyphEnabledTristate
Specifies an enabled tristate glyph.
Definition XTPGridDefines.h:68
XTPGridFreezeColsDividerStyle
XTPGridFreezeColsDividerStyle
Represents predefined freeze column line styles.
Definition XTPGridDefines.h:152
xtpGridFreezeColsDividerShowAlways
@ xtpGridFreezeColsDividerShowAlways
Show event if AutoColumnSizing is On.
Definition XTPGridDefines.h:157
xtpGridFreezeColsDividerBold
@ xtpGridFreezeColsDividerBold
Bold line style.
Definition XTPGridDefines.h:154
xtpGridFreezeColsDividerHeader
@ xtpGridFreezeColsDividerHeader
Header line style.
Definition XTPGridDefines.h:155
xtpGridFreezeColsDividerShade
@ xtpGridFreezeColsDividerShade
Shade line style.
Definition XTPGridDefines.h:156
xtpGridFreezeColsDividerThin
@ xtpGridFreezeColsDividerThin
Thin line style.
Definition XTPGridDefines.h:153
XTPGridSectionDividerStyle
XTPGridSectionDividerStyle
Represent the header/footer rows divider style.
Definition XTPGridDefines.h:227
xtpGridSectionDividerStyleNone
@ xtpGridSectionDividerStyleNone
No line.
Definition XTPGridDefines.h:228
xtpGridSectionDividerStyleThin
@ xtpGridSectionDividerStyleThin
Thin style.
Definition XTPGridDefines.h:229
xtpGridSectionDividerStyleOutlook
@ xtpGridSectionDividerStyleOutlook
Outlook line style.
Definition XTPGridDefines.h:232
xtpGridSectionDividerStyleBold
@ xtpGridSectionDividerStyleBold
Bold style.
Definition XTPGridDefines.h:230
xtpGridSectionDividerStyleShade
@ xtpGridSectionDividerStyleShade
Shaded line style.
Definition XTPGridDefines.h:231
XTPGridColumnDirection
XTPGridColumnDirection
Defines a grid column direction.
Definition XTPGridHeader.h:143
xtpGridColumnDirectionLeft
@ xtpGridColumnDirectionLeft
Specifies a left grid column direction.
Definition XTPGridHeader.h:144
xtpGridColumnDirectionRight
@ xtpGridColumnDirectionRight
Specifies a right grid column direction.
Definition XTPGridHeader.h:145
XTPGridColumnOrderChangedReason
XTPGridColumnOrderChangedReason
Enumeration of OnColumnsChanged event reasons.
Definition XTPGridHeader.h:117
xtpGridColumnHidden
@ xtpGridColumnHidden
A column visibility property is changed to "hidden".
Definition XTPGridHeader.h:129
xtpGridColumnChangeMask
@ xtpGridColumnChangeMask
A mask for column change flags.
Definition XTPGridHeader.h:136
xtpGridColumnWidthChanged
@ xtpGridColumnWidthChanged
The column width is changed.
Definition XTPGridHeader.h:127
xtpGridColumnChangeOther
@ xtpGridColumnChangeOther
Neither column order nor group order is changed.
Definition XTPGridHeader.h:118
xtpGridColumnAdded
@ xtpGridColumnAdded
A column is added to the column list.
Definition XTPGridHeader.h:122
xtpGridColumnRemovedFromFieldChooser
@ xtpGridColumnRemovedFromFieldChooser
A column is removed from the field chooser.
Definition XTPGridHeader.h:134
xtpGridColumnMoved
@ xtpGridColumnMoved
A column is moved.
Definition XTPGridHeader.h:130
xtpGridColumnAddedToFieldChooser
@ xtpGridColumnAddedToFieldChooser
A column is added to the field chooser.
Definition XTPGridHeader.h:133
xtpGridColumnShown
@ xtpGridColumnShown
A column visibility property is changed to "visible".
Definition XTPGridHeader.h:128
xtpGridColumnOrderChangedMask
@ xtpGridColumnOrderChangedMask
A mask for order change flags.
Definition XTPGridHeader.h:121
xtpGridColumnRemoved
@ xtpGridColumnRemoved
A column is removed from the column list.
Definition XTPGridHeader.h:123
xtpGridColumnCaptionChanged
@ xtpGridColumnCaptionChanged
The column caption is changed.
Definition XTPGridHeader.h:126
xtpGridColumnRemovedFromGroupby
@ xtpGridColumnRemovedFromGroupby
A column is removed from the Group By box.
Definition XTPGridHeader.h:132
xtpGridColumnAddedToGroupby
@ xtpGridColumnAddedToGroupby
A column is added to the Group By box.
Definition XTPGridHeader.h:131
xtpGridColumnOrderChanged
@ xtpGridColumnOrderChanged
Column order changed.
Definition XTPGridHeader.h:119
xtpGridColumnPropExchange
@ xtpGridColumnPropExchange
The column properties changed during properties exchange procedure.
Definition XTPGridHeader.h:124
xtpGridColumnGroupOrderChanged
@ xtpGridColumnGroupOrderChanged
Group order changed.
Definition XTPGridHeader.h:120
XTPGridGroupRowIconAlignment
XTPGridGroupRowIconAlignment
This enum defines alignment style for the group row custom icon.
Definition XTPGridRecordItem.h:317
XTPGridVirtualRowFlags
XTPGridVirtualRowFlags
This enum defines flags for virtual row metrics.
Definition XTPGridRecordItem.h:343
XTPGridColumnIconAlignment
XTPGridColumnIconAlignment
This enum defines the alignment style for the column icon and text.
Definition XTPGridRecordItem.h:287
XTPGridItemControlAlignment
XTPGridItemControlAlignment
This enum defines alignment styles for the item control.
Definition XTPGridRecordItemControls.h:53
XTPGridItemControlType
XTPGridItemControlType
This enum defines types for the item control.
Definition XTPGridRecordItemControls.h:42
XTPGridTextSearchParms
XTPGridTextSearchParms
Enumeration of text search parameters.
Definition XTPGridRecords.h:52
xtpGridTextSearchExactPhrase
@ xtpGridTextSearchExactPhrase
Search exact phrase.
Definition XTPGridRecords.h:53
xtpGridTextSearchMatchCase
@ xtpGridTextSearchMatchCase
Match case during search.
Definition XTPGridRecords.h:54
xtpGridTextSearchBackward
@ xtpGridTextSearchBackward
Search backward.
Definition XTPGridRecords.h:55
xtpGridTextSearchExactStart
@ xtpGridTextSearchExactStart
Search phrase starting in the beginning of the item caption.
Definition XTPGridRecords.h:56
XTPGridSelectionChangeType
XTPGridSelectionChangeType
This enumeration defines the selection change action.
Definition XTPGridRows.h:46
xtpGridSelectionAdd
@ xtpGridSelectionAdd
Row will be added to the selected rows collection.
Definition XTPGridRows.h:47
xtpGridSelectionClear
@ xtpGridSelectionClear
The selected rows collection will be cleared.
Definition XTPGridRows.h:49
xtpGridSelectionRemove
@ xtpGridSelectionRemove
Row will be removed from the selected rows collection.
Definition XTPGridRows.h:48
XTPGridSectionHeightMode
XTPGridSectionHeightMode
Section height algorithm.
Definition XTPGridSection.h:46
xtpGridSectionHeightModeAutoExpand
@ xtpGridSectionHeightModeAutoExpand
Minimum auto size.
Definition XTPGridSection.h:52
xtpGridSectionHeightModeAuto
@ xtpGridSectionHeightModeAuto
Equal to 'auto' in HTML.
Definition XTPGridSection.h:49
xtpGridSectionHeightModeRelative
@ xtpGridSectionHeightModeRelative
Equal to '' in HTML.
Definition XTPGridSection.h:48
xtpGridSectionHeightModeExpand
@ xtpGridSectionHeightModeExpand
Equal to '*' in HTML.
Definition XTPGridSection.h:50
xtpGridSectionHeightModeFixed
@ xtpGridSectionHeightModeFixed
Equal to 'px' in HTML.
Definition XTPGridSection.h:47
xtpGridSectionHeightModeAutoShrink
@ xtpGridSectionHeightModeAutoShrink
Maximum auto size.
Definition XTPGridSection.h:53
XTPGridSection
XTPGridSection
Defines a grid section.
Definition XTPGridSections.h:41
xtpGridSectionCount
@ xtpGridSectionCount
Number of default sections.
Definition XTPGridSections.h:45
xtpGridSectionFooter
@ xtpGridSectionFooter
Index of footer section.
Definition XTPGridSections.h:44
xtpGridSectionHeader
@ xtpGridSectionHeader
Index of header section.
Definition XTPGridSections.h:42
xtpGridSectionBody
@ xtpGridSectionBody
Index of body section.
Definition XTPGridSections.h:43
CXTPGridColumn
Represents a grid column item with its properties and operations.
Definition XTPGridColumn.h:107
CXTPGridColumnOrder
Represents the column order, used for sorting and grouping.
Definition XTPGridColumns.h:384
CXTPGridColumns
This class is a collection of grid column objects.
Definition XTPGridColumns.h:54
CXTPGridControl
The CXTPGridControl class provides an implementation of the Grid control.
Definition XTPGridControl.h:479
CXTPGridControlLocale
Helper class with static member functions used to control active locale for Grid control and perform ...
Definition XTPGridControl.h:4311
CXTPGridDataManager
Represents a grid data manager.
Definition XTPGridDataManager.h:153
CXTPGridFilterEditControl
The CXTPGridFilterEditControl class provides the functionality of the filter string edit control asso...
Definition XTPGridFilterEditControl.h:57
CXTPGridGroupRow
This class represents a 'group row' of the Grid control view.
Definition XTPGridGroupRow.h:49
CXTPGridHeaderDragWnd
CXTPGridHeaderDragWnd is a CWnd derived class.
Definition XTPGridDragDrop.h:43
CXTPGridHeaderDropWnd
CXTPGridHeaderDropWnd is a CWnd derived class.
Definition XTPGridDragDrop.h:112
CXTPGridHeader
A grid header is a part of the grid window positioned above columns of text or numbers.
Definition XTPGridHeader.h:173
CXTPGridHyperlink
This class represents hyperlinks.
Definition XTPGridHyperlink.h:112
CXTPGridHyperlinkStyle
This class stores the anchor styles.
Definition XTPGridHyperlink.h:40
CXTPGridHyperlinks
This class represents an array of pointers to CXTPGridHyperlink objects.
Definition XTPGridHyperlink.h:172
CXTPGridIconNavigator
Utility class, handles Grid control icon navigation.
Definition XTPGridNavigator.h:369
CXTPGridInplaceButton
CXTPGridInplaceButton is a CXTPGridInplaceControl derived class that represents a combo button and ex...
Definition XTPGridInplaceControls.h:220
CXTPGridInplaceButtons
This class represents a collection of in-place buttons for a single item of the Grid control.
Definition XTPGridRecordItem.h:429
CXTPGridInplaceControl
CXTPGridInplaceControl is the base class for all in-place controls of the Grid control item.
Definition XTPGridInplaceControls.h:54
CXTPGridInplaceEdit
CXTPGridInplaceEdit is a CXTPGridInplaceControl derived class that represents an edit control to allo...
Definition XTPGridInplaceControls.h:88
CXTPGridInplaceList
CXTPGridInplaceList is a CXTPGridInplaceControl derived class that represents a list box with item co...
Definition XTPGridInplaceControls.h:527
CXTPGridNavigator
Utility class, handles Grid control item navigation.
Definition XTPGridNavigator.h:45
CXTPGridPageSetupDialog
Customized Grid control page setup dialog.
Definition XTPGridPageSetupDialog.h:101
CXTPGridPaintManager
Utility class that handles most drawing activities.
Definition XTPGridPaintManager.h:76
CXTPGridRecord
CXTPGridRecord represents a collection of CXTPGridRecordItem objects or objects of classes that are c...
Definition XTPGridRecord.h:59
CXTPGridRecordItemButton
This class represents an item button and inherits basic functionality from the CXTPGridRecordItemCont...
Definition XTPGridRecordItemControls.h:524
CXTPGridRecordItemConstraint
CXTPGridRecordItemConstraint is a CXTPCmdTarget derived class.
Definition XTPGridRecordItemConstraint.h:39
CXTPGridRecordItemConstraints
CXTPGridRecordItemConstraints is a CXTPCmdTarget derived class.
Definition XTPGridRecordItemConstraint.h:85
CXTPGridRecordItemControlHookWnd
This class represents an item control hook window.
Definition XTPGridRecordItemControls.h:763
CXTPGridRecordItemControl
This class represents a generic item control and handles control's behaviour, common for all derived ...
Definition XTPGridRecordItemControls.h:85
CXTPGridRecordItemControls
This class represents the inplace controls of a single item.
Definition XTPGridRecordItemControls.h:634
CXTPGridRecordItemDateTime
Represents a time cell and inherits basic functionality from the CXTPGridRecordItem class.
Definition XTPGridRecordItemDateTime.h:44
CXTPGridRecordItemEditOptions
This class represents edit options for a single item or column.
Definition XTPGridRecordItem.h:443
CXTPGridRecordItem
Class for working with single list cell.
Definition XTPGridRecordItem.h:600
CXTPGridRecordItemNumber
This class represents a numeric cell and inherits basic functionality from the CXTPGridRecordItem cla...
Definition XTPGridRecordItemNumber.h:47
CXTPGridRecordItemPercentNumber
This class represents a numeric percent cell and inherits basic functionality from the CXTPGridRecord...
Definition XTPGridRecordItemNumber.h:175
CXTPGridRecordItemPreview
This represents a preview cell and inherits basic functionality from the CXTPGridRecordItem class.
Definition XTPGridRecordItemPreview.h:44
CXTPGridRecordItemText
This class represents a text-only cell and inherits basic functionality from the CXTPGridRecordItem c...
Definition XTPGridRecordItemText.h:44
CXTPGridRecordItemVariant
Represents a variant item and inherits basic functionality from the CXTPGridRecordItem class.
Definition XTPGridRecordItemVariant.h:44
CXTPGridRecords
This class represents a grid records collection.
Definition XTPGridRecords.h:71
CXTPGridRow
CXTPGridRow class represents a row of the Grid control window.
Definition XTPGridRow.h:71
CXTPGridRows
This class represents a rows collection class.
Definition XTPGridRows.h:108
CXTPGridSection
Represents a grid section.
Definition XTPGridSection.h:61
CXTPGridSections
Collection of sections.
Definition XTPGridSections.h:53
CXTPGridSelectedRows
Encapsulates a collection of CXTPGridRow pointers that represent the selected rows in a Grid control.
Definition XTPGridSelectedRows.h:73
CXTPGridSubListControl
Field chooser list box control.
Definition XTPGridSubListControl.h:60
CXTPGridThemeDefault
CXTPGridThemeDefault is a CXTPGridPaintManager derived class that represents an Office 97 style theme...
Definition XTPGridThemeDefault.h:39
CXTPGridThemeExplorer
CXTPGridThemeExplorer is a CXTPGridPaintManager derived class that represents an Explorer style theme...
Definition XTPGridThemeExplorer.h:39
CXTPGridThemeNativeWindows10
CXTPGridThemeNativeWindows10 is a CXTPGridThemeOffice2013 derived class that represents a Native Wind...
Definition XTPGridThemeNativeWindows10.h:39
CXTPGridThemeNativeWindows11
CXTPGridThemeNativeWindows11 is a CXTPGridThemeOffice2013 derived class that represents a Native Wind...
Definition XTPGridThemeNativeWindows11.h:39
CXTPGridThemeOffice2003
CXTPGridThemeOffice2003 is a CXTPGridPaintManager derived class that represents an Office 2003 style ...
Definition XTPGridThemeOffice2003.h:39
CXTPGridThemeOffice2003Luna
CXTPGridThemeOffice2003Luna is a CXTPGridPaintManager derived class that represents an Office 2003 Lu...
Definition XTPGridThemeOffice2003Luna.h:39
CXTPGridThemeOffice2013
CXTPGridThemeOffice2013 is a CXTPGridPaintManager derived class that represents an Office 2013 style ...
Definition XTPGridThemeOffice2013.h:39
CXTPGridThemeOfficeXP
CXTPGridThemeOfficeXP is a CXTPGridPaintManager derived class that represents an Office XP style them...
Definition XTPGridThemeOfficeXP.h:39
CXTPGridThemeResource
CXTPGridThemeResource is a CXTPGridPaintManager derived class that represents a Resource style theme.
Definition XTPGridThemeResource.h:39
CXTPGridThemeVisualStudio2012Blue
CXTPGridThemeVisualStudio2012Blue is a CXTPGridThemeOffice2013 derived class that represents a Visual...
Definition XTPGridThemeVisualStudio2012.h:95
CXTPGridThemeVisualStudio2012Dark
CXTPGridThemeVisualStudio2012Dark is a CXTPGridThemeOffice2013 derived class that represents a Visual...
Definition XTPGridThemeVisualStudio2012.h:67
CXTPGridThemeVisualStudio2012Light
CXTPGridThemeVisualStudio2012Light is a CXTPGridThemeOffice2013 derived class that represents a Visua...
Definition XTPGridThemeVisualStudio2012.h:39
CXTPGridThemeVisualStudio2015
CXTPGridThemeVisualStudio2015 is a CXTPGridThemeOffice2013 derived class that represents a Visual Stu...
Definition XTPGridThemeVisualStudio2015.h:39
CXTPGridThemeVisualStudio2017
CXTPGridThemeVisualStudio2017 is a CXTPGridThemeOffice2013 derived class that represents a Visual Stu...
Definition XTPGridThemeVisualStudio2017.h:39
CXTPGridThemeVisualStudio2019
CXTPGridThemeVisualStudio2019 is a CXTPGridThemeOffice2013 derived class that represents a Visual Stu...
Definition XTPGridThemeVisualStudio2019.h:39
CXTPGridThemeVisualStudio2022
CXTPGridThemeVisualStudio2022 is a CXTPGridThemeOffice2013 derived class that represents a Visual Stu...
Definition XTPGridThemeVisualStudio2022.h:39
CXTPGridThickness
The CXTPGridThickness class describes the thickness of the left, top, right, and bottom sides of a re...
Definition XTPGridThickness.h:39
CXTPGridTip
The CXTPGridTip class encapsulates the functionality of a "tip control", a small pop-up window that d...
Definition XTPGridTip.h:50
CXTPGridView
The CXTPGridView class provides an implementation of the Grid control as a view class.
Definition XTPGridView.h:73
CXTPGridViewPrintOptions
This class is used to store printing options.
Definition XTPGridPageSetupDialog.h:40
XTP_GRIDDATAMANAGER_COM_ERROR
Basic set of parameters transferred to item handlers.
Definition XTPGridDataManager.h:58
XTP_GRIDRECORDITEM_ARGS
Basic set of parameters transferred to item handlers.
Definition XTPGridRecordItem.h:69
XTP_GRIDRECORDITEM_CLICKARGS
A set of parameters transferred to mouse click item handlers.
Definition XTPGridRecordItem.h:149
XTP_GRIDRECORDITEM_DRAWARGS
A set of parameters transferred to the Draw item handler.
Definition XTPGridRecordItem.h:125
XTP_GRIDRECORDITEM_METRICS
Record item drawing metrics.
Definition XTPGridRecordItem.h:356
XTP_NM_GRID_BEFORE_COPYPASTE
This structure is sent to the Main window in a WM_NOTIFY message from Item and provides all parameter...
Definition XTPGridRecordItem.h:241
XTP_NM_GRIDCOLUMNORDERCHANGED
This structure is sent to the main window in a WM_NOTIFY message after columns order or group order i...
Definition XTPGridHeader.h:104
XTP_NM_GRIDCOLUMNRESIZE
This structure is sent to the main window in a WM_NOTIFY message after a column is resized.
Definition XTPGridHeader.h:73
XTP_NM_GRIDCONSTRAINTSELECTING
This structure is sent to the Main window in a WM_NOTIFY message from Item and provides all parameter...
Definition XTPGridRecordItem.h:260
XTP_NM_GRIDDRAGDROP
This structure is sent to the Main window in a WM_NOTIFY message from Grid Control to determine if re...
Definition XTPGridControl.h:137
XTP_NM_GRIDGIVEFEEDBACK
NM_GRIDGIVEFEEDBACK notification data.
Definition XTPGridHeader.h:59
XTP_NM_GRIDINPLACEBUTTON
This structure is sent to the Main window in a WM_NOTIFY message from Item and provides all parameter...
Definition XTPGridRecordItem.h:223
XTP_NM_GRIDITEMCONTROL
This structure is sent to the Main window in a WM_NOTIFY message from the item control and provides a...
Definition XTPGridRecordItemControls.h:70
XTP_NM_GRIDITEMMETRICS
This structure is sent to the Main window in a WM_NOTIFY message from Item and provides all parameter...
Definition XTPGridControl.h:107
XTP_NM_GRIDPREVIEWKEYDOWN
This structure is sent to the Main window in a WM_NOTIFY message before processing the OnKeyDown even...
Definition XTPGridControl.h:161
XTP_NM_GRIDRECORDITEM
This structure is sent to the Main window in a WM_NOTIFY message from Item and provides all parameter...
Definition XTPGridRecordItem.h:179
XTP_NM_GRIDREQUESTEDIT
A set of parameters transferred with an XTP_NM_GRID_REQUESTEDIT message.
Definition XTPGridRecordItem.h:197
XTP_NM_GRIDROWRESIZE
This structure is sent to the main window in a WM_NOTIFY message after a row is resized.
Definition XTPGridHeader.h:88
XTP_NM_GRIDSCROLL
NM_GRIDSCROLL notification data.
Definition XTPGridHeader.h:49
XTP_NM_GRIDSTATECHANGED
This structure contains information for use in processing an XTP_NM_GRID_STATECHANGED message.
Definition XTPGridRows.h:72
XTP_NM_GRIDTOOLTIPINFO
This structure is sent to the Main window in a WM_NOTIFY message from Item and provides all parameter...
Definition XTPGridRecordItem.h:278
XTPGridInputState
Stores the mouse and key states.
Definition XTPGridControl.h:337


Toolkit Pro: Member List

CXTPChartRangeBarSeriesLabelView Member List

This is the complete list of members for CXTPChartRangeBarSeriesLabelView, including all inherited members.

AddChildView(CXTPChartElementView *pChildView) | CXTPChartElementView |
CreateDeviceCommand(CXTPChartDeviceContext *pDC) | CXTPChartRangeBarSeriesLabelView | protectedvirtual
CreateDeviceCommand(CXTPChartDeviceContext *pDC, CXTPChartPointF ptCenterPoint) | CXTPChartRangeBarSeriesLabelView | protectedvirtual
CreateDeviceCommand(CXTPChartDeviceContext *pDC, CXTPChartPointF ptCenterPoint, const CXTPChartString &text) | CXTPChartRangeBarSeriesLabelView | protectedvirtual
CreateDeviceCommand(CXTPChartDeviceContext *pDC, const CXTPChartPointF &ptAnchorPoint, double dAnchorAngle, const CXTPChartString &text) | CXTPChartRangeBarSeriesLabelView | protectedvirtual
CXTPChartDiagram2DSeriesLabelView(CXTPChartSeriesLabel *pLabel, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView) | CXTPChartDiagram2DSeriesLabelView |
CXTPChartElementView(CXTPChartElementView *pParentView) | CXTPChartElementView |
CXTPChartElementView(CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartElementView |
CXTPChartElementView(CXTPChartContainer *pContainer) | CXTPChartElementView |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartRangeBarSeriesLabelView(CXTPChartSeriesLabel *pLabel, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView) | CXTPChartRangeBarSeriesLabelView |
GetAnchorPoint() const | CXTPChartRangeBarSeriesLabelView | virtual
GetAt(int nIndex) const | CXTPChartElementView |
GetBounds() const | CXTPChartElementView |
GetBounds(BOOL bIncludingChildren) const | CXTPChartElementView |
GetChildren() | CXTPChartElementView |
GetCount() const | CXTPChartElementView |
GetParentView() const | CXTPChartElementView |
Is3D() const | CXTPChartObject |
m_arrChildren | CXTPChartElementView | protected
m_pContainer | CXTPChartElementView | protected
m_pParentView | CXTPChartElementView | protected
m_rcBounds | CXTPChartElementView | protected
~CXTPChartElementView() | CXTPChartElementView | protectedvirtual


Toolkit Pro: Member List

CXTPControlGalleryOffice2013Theme Member List

This is the complete list of members for CXTPControlGalleryOffice2013Theme, including all inherited members.

CXTPControlGalleryOffice2013Theme(CXTPPaintManager *pPaintManager) | CXTPControlGalleryOffice2013Theme |
CXTPControlGalleryPaintManager(CXTPPaintManager *pPaintManager) | CXTPControlGalleryPaintManager |
DrawLabel(CDC *pDC, CXTPControlGalleryItem *pLabel, CRect rc) | CXTPControlGalleryPaintManager | virtual
DrawPopupScrollBar(CDC *pDC, CXTPControlGallery *pGallery) | CXTPControlGalleryOffice2013Theme | virtual
FillControl(CDC *pDC, CXTPControlGallery *pGallery, CRect rc) | CXTPControlGalleryOffice2013Theme | protectedvirtual
m_cxPopup | CXTPControlGalleryPaintManager |
m_cyPopupDown | CXTPControlGalleryPaintManager |
m_cyPopupUp | CXTPControlGalleryPaintManager |
RefreshMetrics() | CXTPControlGalleryOffice2013Theme | virtual


Toolkit Pro: XTPChartRangeBarSeriesStyle.h Source File

  • Source
  • Chart
  • Styles
  • Range
XTPChartRangeBarSeriesStyle.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTRANGEBARSERIESSTYLE_H__)
24# define __XTPCHARTRANGEBARSERIESSTYLE_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartSeriesView;
34
46class _XTP_EXT_CLASS CXTPChartRangeBarSeriesStyle : public CXTPChartBarSeriesStyle
47{
49 DECLARE_SERIAL(CXTPChartRangeBarSeriesStyle)
51public:
56 CXTPChartRangeBarSeriesStyle();
57
62 virtual ~CXTPChartRangeBarSeriesStyle();
63
64public:
65 CXTPChartMarker* GetMinValueMarker() const;
66 CXTPChartMarker* GetMaxValueMarker() const;
67
68protected:
81 virtual CXTPChartSeriesView* CreateView(CXTPChartSeries* pSeries,
82 CXTPChartDiagramView* pDiagramView);
83
84public:
85 void DoPropExchange(CXTPPropExchange* pPX);
86
87protected:
88 CXTPChartMarker* m_pMinValueMarker;
89 CXTPChartMarker* m_pMaxValueMarker;
90
91protected:
92# ifdef _XTP_ACTIVEX
93public:
95 DECLARE_DISPATCH_MAP()
96 DECLARE_INTERFACE_MAP()
97 DECLARE_OLETYPELIB_EX(CXTPChartRangeBarSeriesStyle);
98 DECLARE_OLECREATE_EX(CXTPChartRangeBarSeriesStyle);
99
100 afx_msg LPDISPATCH OleGetMinValueMarker();
101 afx_msg LPDISPATCH OleGetMaxValueMarker();
102
104# endif
105};
106
107AFX_INLINE CXTPChartMarker* CXTPChartRangeBarSeriesStyle::GetMinValueMarker() const
108{
109 return m_pMinValueMarker;
110}
111AFX_INLINE CXTPChartMarker* CXTPChartRangeBarSeriesStyle::GetMaxValueMarker() const
112{
113 return m_pMaxValueMarker;
114}
116# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
117#endif //#if !defined(__XTPCHARTRANGEBARSERIESSTYLE_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartBarSeriesStyle
This class represents a bar series style for the chart, which is a kind of CXTPChartSeriesStyle.
Definition XTPChartBarSeriesStyle.h:47
CXTPChartDiagramView
This class represents the view of a chart diagram, which is a kind of CXTPChartElementView.
Definition XTPChartDiagramView.h:49
CXTPChartMarker
This class abstracts a marker used in marking the points in a point series style chart.
Definition XTPChartMarker.h:64
CXTPChartRangeBarSeriesStyle
This class represents a RangeBar series style for the chart, which is a kind of CXTPChartBarSeriesSty...
Definition XTPChartRangeBarSeriesStyle.h:47
CXTPChartRangeBarSeriesStyle::~CXTPChartRangeBarSeriesStyle
virtual ~CXTPChartRangeBarSeriesStyle()
Destroys a CXTPChartRangeBarSeriesStyle object, handles cleanup.
CXTPChartRangeBarSeriesStyle::DoPropExchange
void DoPropExchange(CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
CXTPChartRangeBarSeriesStyle::CreateView
virtual CXTPChartSeriesView * CreateView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Call this function to create the view of the RangeBar series.
CXTPChartRangeBarSeriesStyle::CXTPChartRangeBarSeriesStyle
CXTPChartRangeBarSeriesStyle()
Constructs a CXTPChartRangeBarSeriesStyle object.
CXTPChartSeries
This class represents a series in the chart, which is a kind of CXTPChartElement.
Definition XTPChartSeries.h:50
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72


Toolkit Pro: XTPChartSplineSeriesStyle.h Source File

  • Source
  • Chart
  • Styles
  • Line
XTPChartSplineSeriesStyle.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTSPLINESERIESSTYLE_H__)
24# define __XTPCHARTSPLINESERIESSTYLE_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartSeriesView;
34class CXTPChartLineStyle;
35
41class _XTP_EXT_CLASS CXTPChartSplineSeriesStyle : public CXTPChartLineSeriesStyle
42{
44 DECLARE_SERIAL(CXTPChartSplineSeriesStyle)
46public:
51 CXTPChartSplineSeriesStyle();
52
57 virtual ~CXTPChartSplineSeriesStyle();
58
59public:
60protected:
71 virtual CXTPChartSeriesView* CreateView(CXTPChartSeries* pSeries,
72 CXTPChartDiagramView* pDiagramView);
73
74protected:
75# ifdef _XTP_ACTIVEX
76public:
78 DECLARE_DISPATCH_MAP()
79 DECLARE_INTERFACE_MAP()
80 DECLARE_OLETYPELIB_EX(CXTPChartSplineSeriesStyle);
81 DECLARE_OLECREATE_EX(CXTPChartSplineSeriesStyle)
82 LPDISPATCH OleGetLineStyle();
84# endif
85
86protected:
87};
88
94class _XTP_EXT_CLASS CXTPChartSplineSeriesView : public CXTPChartLineSeriesView
95{
96public:
104 CXTPChartSplineSeriesView(CXTPChartSeries* pSeries, CXTPChartDiagramView* pDiagramView);
105
106protected:
118 CXTPChartSeriesPointView* CreateSeriesPointView(CXTPChartDeviceContext* pDC,
119 CXTPChartSeriesPoint* pPoint,
120 CXTPChartElementView* pParentView);
121
134 virtual CXTPChartDeviceCommand* CreateDeviceCommand(CXTPChartDeviceContext* pDC);
135};
137# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
138#endif //#if !defined(__XTPCHARTSPLINESERIESSTYLE_H__)
pPoint
const CPoint * pPoint
return 0 or xtpCalendarHitTestDayExpandButton
Definition XTPCalendarThemeOffice2007.h:150
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartDiagramView
This class represents the view of a chart diagram, which is a kind of CXTPChartElementView.
Definition XTPChartDiagramView.h:49
CXTPChartElementView
This class represents the view of a chart element.
Definition XTPChartElementView.h:47
CXTPChartLineSeriesStyle
This class represents a line series style, which is a kind of CXTPChartPointSeriesStyle.
Definition XTPChartLineSeriesStyle.h:47
CXTPChartLineSeriesView
This class represents the view of a line series, which is a kind of CXTPChartSeriesView.
Definition XTPChartLineSeriesStyle.h:110
CXTPChartLineStyle
This class represents a chart line style, which is a kind of CXTPCmdTarget.
Definition XTPChartLineStyle.h:43
CXTPChartSeries
This class represents a series in the chart, which is a kind of CXTPChartElement.
Definition XTPChartSeries.h:50
CXTPChartSeriesPoint
CXTPChartSeriesPoint is a kind of CXTPChartElement.
Definition XTPChartSeriesPoint.h:43
CXTPChartSeriesPointView
Represents chart series point view.
Definition XTPChartSeriesPointView.h:48
CXTPChartSplineSeriesStyle
This class represents the spline series style in the chart.
Definition XTPChartSplineSeriesStyle.h:42
CXTPChartSplineSeriesStyle::CXTPChartSplineSeriesStyle
CXTPChartSplineSeriesStyle()
Constructs a CXTPChartSplineSeriesStyle object.
CXTPChartSplineSeriesStyle::CreateView
virtual CXTPChartSeriesView * CreateView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Call this function to create a view of the spline series.
CXTPChartSplineSeriesStyle::~CXTPChartSplineSeriesStyle
virtual ~CXTPChartSplineSeriesStyle()
Destroys a CXTPChartSplineSeriesStyle object, handles cleanup.
CXTPChartSplineSeriesView
This class represents the view of a spline series, which is a kind of CXTPChartSeriesView.
Definition XTPChartSplineSeriesStyle.h:95
CXTPChartSplineSeriesView::CXTPChartSplineSeriesView
CXTPChartSplineSeriesView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Constructs a CXTPChartSplineSeriesView object.
CXTPChartSplineSeriesView::CreateDeviceCommand
virtual CXTPChartDeviceCommand * CreateDeviceCommand(CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
CXTPChartSplineSeriesView::CreateSeriesPointView
CXTPChartSeriesPointView * CreateSeriesPointView(CXTPChartDeviceContext *pDC, CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Call this function to create a view of the spline series point.


Toolkit Pro: XTPMarkupScaleTransform.h Source File

  • Source
  • Markup
  • Transform
XTPMarkupScaleTransform.h
Go to the documentation of this file.
1
23#if !defined(__XTPMARKUPSCALETRANSFORM_H__)
24# define __XTPMARKUPSCALETRANSFORM_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPMarkupTransformationMatrix;
34class CXTPMarkupDependencyProperty;
35
40class _XTP_EXT_CLASS CXTPMarkupScaleTransform : public CXTPMarkupTransform
41{
43 DECLARE_MARKUPCLASS(CXTPMarkupScaleTransform);
45public:
52 double GetScaleX() const;
53
59 void SetScaleX(double scaleX);
60
67 double GetScaleY() const;
68
74 void SetScaleY(double scaleY);
75
82 double GetCenterX() const;
83
90 void SetCenterX(double centerX);
91
98 double GetCenterY() const;
99
105 void SetCenterY(double centerY);
106
114 virtual CXTPMarkupTransformationMatrix*
115 ApplyTransform(const CXTPMarkupTransformationMatrix* pMatrix);
116
117private:
118 DECLARE_DISPATCH_MAP();
119 afx_msg double OleGetScaleX();
120 afx_msg void OleSetScaleX(double scaleX);
121 afx_msg double OleGetScaleY();
122 afx_msg void OleSetScaleY(double scaleY);
123 afx_msg double OleGetCenterX();
124 afx_msg void OleSetCenterX(double centerX);
125 afx_msg double OleGetCenterY();
126 afx_msg void OleSetCenterY(double centerY);
127
128public:
129 static CXTPMarkupDependencyProperty* m_pPropertyScaleX;
130 static CXTPMarkupDependencyProperty* m_pPropertyScaleY;
131 static CXTPMarkupDependencyProperty* m_pPropertyCenterX;
132 static CXTPMarkupDependencyProperty* m_pPropertyCenterY;
133};
134
135# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
137#endif // !defined(__XTPMARKUPSCALETRANSFORM_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPMarkupScaleTransform
Default ScaleTransform implementation.
Definition XTPMarkupScaleTransform.h:41
CXTPMarkupScaleTransform::m_pPropertyScaleX
static CXTPMarkupDependencyProperty * m_pPropertyScaleX
ScaleX property.
Definition XTPMarkupScaleTransform.h:129
CXTPMarkupScaleTransform::GetScaleX
double GetScaleX() const
Gets the scale X value.
CXTPMarkupScaleTransform::GetScaleY
double GetScaleY() const
Gets the scale Y value.
CXTPMarkupScaleTransform::m_pPropertyScaleY
static CXTPMarkupDependencyProperty * m_pPropertyScaleY
ScaleY property.
Definition XTPMarkupScaleTransform.h:130
CXTPMarkupScaleTransform::SetCenterX
void SetCenterX(double centerX)
Sets the center X value.
CXTPMarkupScaleTransform::m_pPropertyCenterY
static CXTPMarkupDependencyProperty * m_pPropertyCenterY
CenterY property.
Definition XTPMarkupScaleTransform.h:132
CXTPMarkupScaleTransform::SetScaleX
void SetScaleX(double scaleX)
Sets the scale X value.
CXTPMarkupScaleTransform::m_pPropertyCenterX
static CXTPMarkupDependencyProperty * m_pPropertyCenterX
CenterX property.
Definition XTPMarkupScaleTransform.h:131
CXTPMarkupScaleTransform::GetCenterX
double GetCenterX() const
Gets the center X value.
CXTPMarkupScaleTransform::ApplyTransform
virtual CXTPMarkupTransformationMatrix * ApplyTransform(const CXTPMarkupTransformationMatrix *pMatrix)
Does nothing in default implementation.
CXTPMarkupScaleTransform::SetScaleY
void SetScaleY(double scaleY)
Sets the scale Y value.
CXTPMarkupScaleTransform::GetCenterY
double GetCenterY() const
Gets the center Y value.
CXTPMarkupScaleTransform::SetCenterY
void SetCenterY(double centerY)
Sets the center Y value.
CXTPMarkupTransform
Base class for all markup transformation objects.
Definition XTPMarkupTransform.h:43
CXTPMarkupTransformationMatrix
An abstract class for device context transformation matrix.
Definition XTPMarkupTransformationMatrix.h:40


Toolkit Pro: XTPCalendarViewDay.h Source File

  • Source
  • Calendar
XTPCalendarViewDay.h
Go to the documentation of this file.
1
22#if !defined(_XTPCALENDARVIEWDAY_H__)
23# define _XTPCALENDARVIEWDAY_H__
24
25# if _MSC_VER > 1000
26# pragma once
27# endif // _MSC_VER > 1000
28
29# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
30
31# pragma warning(disable : 4786)
32
33class CXTPCalendarView;
34class CXTPCalendarViewDay;
35class CXTPCalendarViewGroup;
36class CXTPCalendarViewEvent;
37
38class CXTPCalendarEvent;
39
40struct XTP_CALENDAR_HITTESTINFO;
41
53class _XTP_EXT_CLASS CXTPCalendarViewGroup : public CXTPCalendarWMHandler
54{
55 friend class CXTPCalendarView;
56 friend class CXTPCalendarViewDay;
57 friend class CXTPCalendarViewEvent;
58 friend class CXTPCalendarTheme;
59
60 DECLARE_DYNAMIC(CXTPCalendarViewGroup)
61
62 typedef CXTPCalendarWMHandler TBase;
63public:
70 CXTPCalendarViewGroup(CXTPCalendarViewDay* pViewDay);
71
79 virtual ~CXTPCalendarViewGroup();
80
95 virtual CXTPCalendarResources* GetResources() const;
96
106 virtual CXTPCalendarData* GetDataProvider() const;
107
121 virtual void AddResource(CXTPCalendarResource* pResource, BOOL bWithAddRef);
122
133 virtual void SetResources(CXTPCalendarResources* pResources);
134
142 virtual UINT GetScheduleID() const;
143
155 virtual void Populate(COleDateTime dtDayDate);
156
172 virtual void AdjustLayout(CDC* pDC, const CRect& rcGroup);
173
189 virtual void AdjustLayout2(CDC* pDC, const CRect& rcGroup);
190
203 virtual void Draw(CDC* pDC);
204
224 virtual BOOL HitTest(CPoint pt, XTP_CALENDAR_HITTESTINFO* pHitTest) const;
225
242 virtual BOOL HitTestEx(CPoint pt, XTP_CALENDAR_HITTESTINFO* pHitTest) const;
243
255 virtual void FillHitTestEx(XTP_CALENDAR_HITTESTINFO* pHitTest) const = 0;
256
266 virtual CRect GetRect() const
267 {
268 return m_Layout.m_rcGroup;
269 }
270
282 virtual CRect GetHeaderRect() const
283 {
284 return m_Layout.m_rcGroupHeader;
285 }
286
303 virtual CRect GetTooltipRect(const CPoint& ptHit,
304 const XTP_CALENDAR_HITTESTINFO& hitInfo) const;
305
317 int GetViewEventsCount() const;
318
336 CXTPCalendarViewEvent* GetViewEvent_(int nIndex) const;
337
345 CXTPCalendarViewDay* GetViewDay_() const;
346
355 virtual int GetGroupIndex() const;
356
363 virtual CString GetCaption() const;
364
380 virtual int GetChildHandlersCount() const;
381
398 virtual CXTPCalendarWMHandler* GetChildHandlerAt(int nIndex) const;
399
412 virtual CXTPCalendarViewEvent* GetViewEventByEvent_(CXTPCalendarEvent* pEvent) const;
413
426 virtual CXTPCalendarViewEvent* GetViewEventByPlace_(int nEventPlace) const;
427
435 virtual CXTPCalendarControl* GetCalendarControl() const;
436
454 virtual void ExchangeEventPlace(CXTPCalendarViewEvent* pViewEvent, int nNewPlace);
455
456protected:
466 virtual UINT SetTimer(UINT uTimeOut_ms);
467
474 virtual void KillTimer(UINT uTimerID);
475
488 virtual void OnPrePopulate(CXTPCalendarEvents* pEvents);
489
490public:
491 virtual void AddViewEvent(CXTPCalendarEvent* pEvent);
492
493protected:
494 virtual CXTPCalendarViewEvent* CreateViewEvent(CXTPCalendarEvent* pEvent) = 0;
495
496protected:
497 XTP_VIEW_GROUP_LAYOUT& GetLayout_();
498
499protected:
500 XTP_VIEW_GROUP_LAYOUT m_Layout;
502 CXTPCalendarPtrCollectionT<CXTPCalendarViewEvent> m_arEvents;
504 CXTPCalendarResources* m_pResources;
506 CXTPCalendarViewDay* m_pViewDay;
508# ifdef _XTP_ACTIVEX
509
510 DECLARE_DISPATCH_MAP()
511 DECLARE_INTERFACE_MAP()
512
513 DECLARE_OLETYPELIB_EX(CXTPCalendarViewGroup);
514
515 LPDISPATCH OleGetViewDay();
516 LPDISPATCH OleGetViewEvents();
517 LPDISPATCH OleGetMultipleResources();
518
519# endif
520};
521
554class _XTP_EXT_CLASS CXTPCalendarViewDay : public CXTPCalendarWMHandler
555{
556 friend class CXTPCalendarView;
557 friend class CXTPCalendarViewEvent;
558 friend class CXTPCalendarTheme;
559
560 DECLARE_DYNAMIC(CXTPCalendarViewDay)
561
562 typedef CXTPCalendarWMHandler TBase;
563
564public:
573 CXTPCalendarViewDay(const CXTPCalendarView* pView);
574
582 virtual ~CXTPCalendarViewDay();
583
595 virtual void Populate(COleDateTime dtDayDate);
596
610 virtual void AdjustLayout(CDC* pDC, const CRect& rcDay);
611
624 virtual void Draw(CDC* pDC)
625 {
626 UNREFERENCED_PARAMETER(pDC);
627 }
628
641 virtual int GetChildHandlersCount() const
642 {
643 return GetViewGroupsCount();
644 }
645
660 virtual CXTPCalendarWMHandler* GetChildHandlerAt(int nIndex) const
661 {
662 ASSERT_KINDOF(CXTPCalendarWMHandler, GetViewGroup_(nIndex));
663 return GetViewGroup_(nIndex);
664 }
665
685 virtual BOOL HitTest(CPoint pt, XTP_CALENDAR_HITTESTINFO* pHitTest) const;
686
703 virtual BOOL HitTestEx(CPoint pt, XTP_CALENDAR_HITTESTINFO* pHitTest) const;
704
716 virtual void FillHitTestEx(XTP_CALENDAR_HITTESTINFO* pHitTest) const = 0;
717
729 virtual CXTPCalendarView* GetView_() const;
730
738 virtual CXTPCalendarControl* GetCalendarControl() const;
739
751 virtual CXTPCalendarResources* GetResources() const;
752
763 virtual void SetResources(CXTPCalendarResources* pResources);
764
776 virtual int GetViewEventsCount() const;
777
795 virtual CXTPCalendarViewEvent* GetViewEvent_(int nIndex) const;
796
808 int GetViewGroupsCount() const;
809
827 CXTPCalendarViewGroup* GetViewGroup_(int nIndex) const;
828
837 virtual COleDateTime GetDayDate() const;
838
850 virtual COleDateTime SetDayDate(COleDateTime dtDayDate);
851
863 virtual BOOL ContainsInvisibleEvents() const;
864
866 _XTP_DEPRECATED_IN_FAVOR(ContainsInvisibleEvents)
867 virtual BOOL _NoAllEventsAreVisible() const
868 {
869 return ContainsInvisibleEvents();
870 }
882 virtual BOOL ContainsInvisibleEventsUpdate();
883
885 _XTP_DEPRECATED_IN_FAVOR(ContainsInvisibleEventsUpdate)
886 virtual BOOL NoAllEventsAreVisible()
887 {
888 return ContainsInvisibleEventsUpdate();
889 }
900 virtual BOOL IsSelected() const;
901
908 virtual void SetSelected();
909
918 virtual CRect GetDayRect() const;
919
928 virtual void SetDayRect(CRect rcDay);
929
938 virtual BOOL IsExpanded() const;
939
946 virtual CRect GetExpandSignRect() const;
947
957 virtual UINT SetTimer(UINT uTimeOut_ms);
958
965 virtual void KillTimer(UINT uTimerID);
966
975 virtual int GetDayIndex() const;
976
992 virtual BOOL UserAction_OnExpandDay(XTPCalendarExpandDayButton eButton);
993
994protected:
1005 virtual void OnPrePopulateDay();
1006
1012 virtual CXTPCalendarViewGroup* CreateGroup() = 0;
1013
1014public:
1015 const XTP_VIEW_DAY_LAYOUT& GetLayout_() const;
1016
1017protected:
1018 XTP_VIEW_DAY_LAYOUT& GetLayout_();
1019
1020protected:
1021 XTP_VIEW_DAY_LAYOUT m_Layout;
1023 COleDateTime m_dtDate;
1025 CXTPCalendarResources* m_pResources;
1027 CXTPCalendarPtrCollectionT<CXTPCalendarViewGroup> m_arViewGroups;
1030 CXTPCalendarView* m_pView;
1032protected:
1033# ifdef _XTP_ACTIVEX
1034
1035 DECLARE_DISPATCH_MAP()
1036 DECLARE_INTERFACE_MAP()
1037
1038 DECLARE_OLETYPELIB_EX(CXTPCalendarViewDay);
1039
1040 DATE OleGetDate();
1041 LPDISPATCH OleGetView();
1042 LPDISPATCH OleGetViewGroups();
1043
1044 LPDISPATCH OleGetItem(long nIndex);
1045 int OleGetItemCount();
1046
1047 LPDISPATCH OleGetMultipleResources();
1048 void OleSetMultipleResources(LPDISPATCH pDispResources);
1049
1050 DECLARE_ENUM_VARIANT(CXTPCalendarViewDay);
1051
1052# endif
1053};
1054
1075template<class _TView, class _TViewGroup, class XTP_CALENDAR_HITTESTINFO, class _TPThis>
1076class CXTPCalendarViewDayT : public CXTPCalendarViewDay
1077{
1078public:
1083 typedef _TView TView;
1084
1085public:
1094 CXTPCalendarViewDayT(const _TView* pView)
1095 : CXTPCalendarViewDay((CXTPCalendarView*)pView)
1096 {
1097 }
1098
1106 virtual ~CXTPCalendarViewDayT(){};
1107
1119 virtual void FillHitTestEx(XTP_CALENDAR_HITTESTINFO* pHitTest) const = 0;
1120
1129 _TView* GetView() const
1130 {
1131 return (TView*)GetView_();
1132 }
1133
1150 virtual _TViewGroup* GetViewGroup(int nIndex) const
1151 {
1152 return (_TViewGroup*)GetViewGroup_(nIndex);
1153 }
1154
1160 virtual CXTPCalendarViewGroup* CreateGroup()
1161 {
1162 return new _TViewGroup(GetPThis());
1163 }
1164
1178 virtual void AdjustLayout(CDC* pDC, const CRect& rcDay)
1179 {
1180 CXTPCalendarViewDay::AdjustLayout(pDC, rcDay);
1181
1182 int nCount = GetViewGroupsCount();
1183 for (int i = 0; i < nCount; i++)
1184 {
1185 CXTPCalendarViewGroup* pViewGroup = GetViewGroup_(i);
1186 _ASSERTE(pViewGroup);
1187 if (pViewGroup)
1188 {
1189 pViewGroup->AdjustLayout(pDC, rcDay);
1190 }
1191 }
1192 }
1193
1194protected:
1207 virtual _TPThis* GetPThis() = 0;
1208
1209private:
1210};
1211
1213
1214AFX_INLINE COleDateTime CXTPCalendarViewDay::GetDayDate() const
1215{
1216 return m_dtDate;
1217}
1218AFX_INLINE CRect CXTPCalendarViewDay::GetDayRect() const
1219{
1220 return m_Layout.m_rcDay;
1221}
1222AFX_INLINE void CXTPCalendarViewDay::SetDayRect(CRect rcDay)
1223{
1224 m_Layout.m_rcDay.CopyRect(rcDay);
1225}
1226AFX_INLINE BOOL CXTPCalendarViewDay::IsExpanded() const
1227{
1228 return m_Layout.m_rcExpandSign.Width() > 0 ? TRUE : FALSE;
1229}
1230AFX_INLINE CRect CXTPCalendarViewDay::GetExpandSignRect() const
1231{
1232 return m_Layout.m_rcExpandSign;
1233}
1234
1255template<class _TViewDay, class _TViewEvent, class _TPThis>
1256class CXTPCalendarViewGroupT : public CXTPCalendarViewGroup
1257{
1258public:
1263 typedef _TViewDay TViewDay;
1264
1265public:
1274 CXTPCalendarViewGroupT(_TViewDay* pViewDay)
1275 : CXTPCalendarViewGroup(pViewDay)
1276 {
1277 }
1278
1286 virtual ~CXTPCalendarViewGroupT(){};
1287
1299 virtual void FillHitTestEx(XTP_CALENDAR_HITTESTINFO* pHitTest) const = 0;
1300
1309 _TViewDay* GetViewDay() const
1310 {
1311 return (_TViewDay*)GetViewDay_();
1312 }
1313
1330 virtual _TViewEvent* GetViewEvent(int nIndex) const
1331 {
1332 return (_TViewEvent*)GetViewEvent_(nIndex);
1333 }
1334
1335 CXTPCalendarViewEvent* CreateViewEvent(CXTPCalendarEvent* pEvent)
1336 {
1337 return new _TViewEvent(pEvent, GetPThis());
1338 }
1339
1340protected:
1353 virtual _TPThis* GetPThis() = 0;
1354
1355private:
1356};
1357
1359AFX_INLINE XTP_VIEW_DAY_LAYOUT& CXTPCalendarViewDay::GetLayout_()
1360{
1361 return m_Layout;
1362}
1363AFX_INLINE const XTP_VIEW_DAY_LAYOUT& CXTPCalendarViewDay::GetLayout_() const
1364{
1365 return m_Layout;
1366}
1367AFX_INLINE CXTPCalendarResources* CXTPCalendarViewGroup::GetResources() const
1368{
1369 return m_pResources;
1370}
1371AFX_INLINE int CXTPCalendarViewGroup::GetChildHandlersCount() const
1372{
1373 return GetViewEventsCount();
1374}
1375AFX_INLINE XTP_VIEW_GROUP_LAYOUT& CXTPCalendarViewGroup::GetLayout_()
1376{
1377 return m_Layout;
1378}
1379AFX_INLINE CXTPCalendarControl* CXTPCalendarViewGroup::GetCalendarControl() const
1380{
1381 if (GetViewDay_())
1382 return GetViewDay_()->GetCalendarControl();
1383 return NULL;
1384}
1385
1386AFX_INLINE int CXTPCalendarViewGroup::GetViewEventsCount() const
1387{
1388 return m_arEvents.GetCount();
1389}
1390
1391AFX_INLINE CXTPCalendarViewEvent* CXTPCalendarViewGroup::GetViewEvent_(int nIndex) const
1392{
1393 _ASSERTE(this);
1394 if (!this)
1395 {
1396 return NULL;
1397 }
1398
1399 int nCount = m_arEvents.GetCount();
1400 _ASSERTE(nIndex >= 0 && nIndex < nCount);
1401
1402 return (nIndex >= 0 && nIndex < nCount) ? m_arEvents.GetAt(nIndex) : NULL;
1403}
1404
1405AFX_INLINE int CXTPCalendarViewDay::GetViewGroupsCount() const
1406{
1407 return m_arViewGroups.GetCount();
1408}
1409AFX_INLINE CXTPCalendarViewGroup* CXTPCalendarViewDay::GetViewGroup_(int nIndex) const
1410{
1411 _ASSERTE(this);
1412 if (!this)
1413 {
1414 return NULL;
1415 }
1416 int nCount = m_arViewGroups.GetCount();
1417 _ASSERTE(nIndex >= 0 && nIndex < nCount);
1418 return (nIndex >= 0 && nIndex < nCount) ? m_arViewGroups.GetAt(nIndex) : NULL;
1419}
1420
1421AFX_INLINE CXTPCalendarViewDay* CXTPCalendarViewGroup::GetViewDay_() const
1422{
1423 _ASSERTE(this);
1424 return this ? m_pViewDay : NULL;
1425}
1426
1427AFX_INLINE CXTPCalendarView* CXTPCalendarViewDay::GetView_() const
1428{
1429 _ASSERTE(this);
1430 return this ? m_pView : NULL;
1431}
1432
1434
1435# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
1436#endif // !defined(_XTPCALENDARVIEWDAY_H__)
XTPCalendarExpandDayButton
XTPCalendarExpandDayButton
This enum defines parameters for xtpCalendarUserAction_OnExpandDay user action.
Definition XTPCalendarDefines.h:1315
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCalendarControl
Class CXTPCalendarControl implements the calendar's view interface.
Definition XTPCalendarControl.h:126
CXTPCalendarData
This class defines an abstract representation of the Calendar control data with all necessary methods...
Definition XTPCalendarData.h:97
CXTPCalendarEvent
This class represents the data of a single Event used in the Calendar control.
Definition XTPCalendarEvent.h:77
CXTPCalendarEvents
This class represents a simple array collection of CXTPCalendarEvent objects.
Definition XTPCalendarEvents.h:55
CXTPCalendarPtrCollectionT
This class represents a simple array collection of objects.
Definition XTPCalendarPtrCollectionT.h:48
CXTPCalendarPtrCollectionT::GetCount
virtual int GetCount() const
This member function is used to obtain the number of elements in the collection.
Definition XTPCalendarPtrCollectionT.h:659
CXTPCalendarPtrCollectionT::GetAt
virtual _TObject * GetAt(int nIndex) const
This member function returns an element at the specified numeric index.
Definition XTPCalendarPtrCollectionT.h:665
CXTPCalendarResource
Class CXTPCalendarResource represents a calendar for some subject like a person, a shared resource,...
Definition XTPCalendarResource.h:339
CXTPCalendarResources
This class represents a simple array collection of CXTPCalendarResource objects.
Definition XTPCalendarResource.h:555
CXTPCalendarViewDay
This class represents the day view portion of the CalendarView.
Definition XTPCalendarViewDay.h:555
CXTPCalendarViewDay::OnPrePopulateDay
virtual void OnPrePopulateDay()
This member function is used to allow some customization before show events.
CXTPCalendarViewDay::GetCalendarControl
virtual CXTPCalendarControl * GetCalendarControl() const
Call this member function to obtain a pointer to a CXTPCalendarControl object.
CXTPCalendarViewDay::GetViewEvent_
virtual CXTPCalendarViewEvent * GetViewEvent_(int nIndex) const
Call this member function to obtain a pointer to a CXTPCalendarViewEvent object associated with the e...
CXTPCalendarViewDay::m_pResources
CXTPCalendarResources * m_pResources
Resources array.
Definition XTPCalendarViewDay.h:1025
CXTPCalendarViewDay::m_pView
CXTPCalendarView * m_pView
Storage for a owner view.
Definition XTPCalendarViewDay.h:1030
CXTPCalendarViewDay::m_arViewGroups
CXTPCalendarPtrCollectionT< CXTPCalendarViewGroup > m_arViewGroups
Storage for views of groups.
Definition XTPCalendarViewDay.h:1027
CXTPCalendarViewDay::GetViewEventsCount
virtual int GetViewEventsCount() const
Call this member function to obtain the number of event views in the day view collection.
CXTPCalendarViewDay::GetDayRect
virtual CRect GetDayRect() const
Call this member function to obtain the day view rectangle coordinates.
Definition XTPCalendarViewDay.h:1218
CXTPCalendarViewDay::GetViewGroup_
CXTPCalendarViewGroup * GetViewGroup_(int nIndex) const
Call this member function to obtain a pointer to a CXTPCalendarViewGroup object associated with the g...
Definition XTPCalendarViewDay.h:1409
CXTPCalendarViewDay::HitTest
virtual BOOL HitTest(CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const
This member function is used to determine which view item, if any, is at the specified position index...
CXTPCalendarViewDay::GetDayIndex
virtual int GetDayIndex() const
This member function is used to obtain the index of the "this" pointer day in the Calendar Day View.
CXTPCalendarViewDay::GetExpandSignRect
virtual CRect GetExpandSignRect() const
Call this member function to obtain the expand sign rectangle.
Definition XTPCalendarViewDay.h:1230
CXTPCalendarViewDay::IsSelected
virtual BOOL IsSelected() const
Call this member function to determine if the day view is selected.
CXTPCalendarViewDay::GetResources
virtual CXTPCalendarResources * GetResources() const
Call this member function to obtain a pointer to the associated Calendar Resources collection object.
CXTPCalendarViewDay::IsExpanded
virtual BOOL IsExpanded() const
Call this member function to determine if there are invisible event views because the boundaries of t...
Definition XTPCalendarViewDay.h:1226
CXTPCalendarViewDay::KillTimer
virtual void KillTimer(UINT uTimerID)
This member function is used to destroy a timer event.
CXTPCalendarViewDay::CXTPCalendarViewDay
CXTPCalendarViewDay(const CXTPCalendarView *pView)
Default object constructor.
CXTPCalendarViewDay::Draw
virtual void Draw(CDC *pDC)
This member function is used to draw the view contents using the specified device context.
Definition XTPCalendarViewDay.h:624
CXTPCalendarViewDay::GetViewGroupsCount
int GetViewGroupsCount() const
Call this member function to obtain the number of resource group views in the view day collection.
Definition XTPCalendarViewDay.h:1405
CXTPCalendarViewDay::GetChildHandlersCount
virtual int GetChildHandlersCount() const
This member function is used to obtain the number of resource group views elements in the collection.
Definition XTPCalendarViewDay.h:641
CXTPCalendarViewDay::CreateGroup
virtual CXTPCalendarViewGroup * CreateGroup()=0
This member function is used to create a new instance of a group.
CXTPCalendarViewDay::ContainsInvisibleEvents
virtual BOOL ContainsInvisibleEvents() const
Call this member function to determine if there are any invisible event views.
CXTPCalendarViewDay::SetSelected
virtual void SetSelected()
This member function is used to set the day view as selected.
CXTPCalendarViewDay::Populate
virtual void Populate(COleDateTime dtDayDate)
This member function is used to populate the view with data for all items contained in the view.
CXTPCalendarViewDay::GetView_
virtual CXTPCalendarView * GetView_() const
Call this member function to obtain a pointer to a CXTPCalendarView object.
Definition XTPCalendarViewDay.h:1427
CXTPCalendarViewDay::~CXTPCalendarViewDay
virtual ~CXTPCalendarViewDay()
Default class destructor.
CXTPCalendarViewDay::m_Layout
XTP_VIEW_DAY_LAYOUT m_Layout
Layout data.
Definition XTPCalendarViewDay.h:1021
CXTPCalendarViewDay::ContainsInvisibleEventsUpdate
virtual BOOL ContainsInvisibleEventsUpdate()
Call this member function to determine if there are any invisible event views and to calculate the re...
CXTPCalendarViewDay::SetTimer
virtual UINT SetTimer(UINT uTimeOut_ms)
This member function is used to create a timer event.
CXTPCalendarViewDay::GetChildHandlerAt
virtual CXTPCalendarWMHandler * GetChildHandlerAt(int nIndex) const
Call this method to get a resource group view object at the specified numeric index.
Definition XTPCalendarViewDay.h:660
CXTPCalendarViewDay::SetResources
virtual void SetResources(CXTPCalendarResources *pResources)
This member function sets the new Resources collection for the view day.
CXTPCalendarViewDay::FillHitTestEx
virtual void FillHitTestEx(XTP_CALENDAR_HITTESTINFO *pHitTest) const =0
This member function is used to fill the pHitTest structure members with the default values for the c...
CXTPCalendarViewDay::GetDayDate
virtual COleDateTime GetDayDate() const
Call this member function to obtain a day date value.
Definition XTPCalendarViewDay.h:1214
CXTPCalendarViewDay::AdjustLayout
virtual void AdjustLayout(CDC *pDC, const CRect &rcDay)
This member function is used to adjust the view's layout depending on the provided rectangle and then...
CXTPCalendarViewDay::m_dtDate
COleDateTime m_dtDate
Day date.
Definition XTPCalendarViewDay.h:1023
CXTPCalendarViewDay::UserAction_OnExpandDay
virtual BOOL UserAction_OnExpandDay(XTPCalendarExpandDayButton eButton)
This member function is used to process the user action xtpCalendarUserAction_OnExpandDay.
CXTPCalendarViewDay::SetDayDate
virtual COleDateTime SetDayDate(COleDateTime dtDayDate)
Call this member function to obtain the day date value.
CXTPCalendarViewDay::HitTestEx
virtual BOOL HitTestEx(CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const
This member function is used to determine which view item, if any, is at the specified position index...
CXTPCalendarViewDay::SetDayRect
virtual void SetDayRect(CRect rcDay)
This member function is used to set the day view rectangle coordinates.
Definition XTPCalendarViewDay.h:1222
CXTPCalendarViewDayT
This class template customizes, overrides and implements some functionality for the CXTPCalendarViewD...
Definition XTPCalendarViewDay.h:1077
CXTPCalendarViewDayT::~CXTPCalendarViewDayT
virtual ~CXTPCalendarViewDayT()
Default class destructor.
Definition XTPCalendarViewDay.h:1106
CXTPCalendarViewDayT::CreateGroup
virtual CXTPCalendarViewGroup * CreateGroup()
This member function is used to create a new instance of a group.
Definition XTPCalendarViewDay.h:1160
CXTPCalendarViewDayT::GetPThis
virtual _TPThis * GetPThis()=0
Call this member function to obtain the typed pointer to the last derived class in the class hierarch...
CXTPCalendarViewDayT::CXTPCalendarViewDayT
CXTPCalendarViewDayT(const _TView *pView)
Default object constructor.
Definition XTPCalendarViewDay.h:1094
CXTPCalendarViewDayT::TView
_TView TView
Definition XTPCalendarViewDay.h:1083
CXTPCalendarViewDayT::GetViewGroup
virtual _TViewGroup * GetViewGroup(int nIndex) const
Call this member function to obtain a pointer to the _TViewGroup object that corresponds to the resou...
Definition XTPCalendarViewDay.h:1150
CXTPCalendarViewDayT::FillHitTestEx
virtual void FillHitTestEx(XTP_CALENDAR_HITTESTINFO *pHitTest) const =0
This member function is used to fill the pHitTest structure members with the default values for the c...
CXTPCalendarViewDayT::AdjustLayout
virtual void AdjustLayout(CDC *pDC, const CRect &rcDay)
This member function is used to adjust the view's layout depending on the provided rectangle and then...
Definition XTPCalendarViewDay.h:1178
CXTPCalendarViewDayT::GetView
_TView * GetView() const
This member function is used to obtain the owner view object.
Definition XTPCalendarViewDay.h:1129
CXTPCalendarViewEvent
This class represents an event view portion of the CalendarViewGroup.
Definition XTPCalendarViewEvent.h:106
CXTPCalendarViewGroup
Regular schema:
Definition XTPCalendarViewDay.h:54
CXTPCalendarViewGroup::GetTooltipRect
virtual CRect GetTooltipRect(const CPoint &ptHit, const XTP_CALENDAR_HITTESTINFO &hitInfo) const
Call this member function to obtain the bounding rectangle of the tooltip space (currently this is on...
CXTPCalendarViewGroup::CXTPCalendarViewGroup
CXTPCalendarViewGroup(CXTPCalendarViewDay *pViewDay)
Default object constructor.
CXTPCalendarViewGroup::m_arEvents
CXTPCalendarPtrCollectionT< CXTPCalendarViewEvent > m_arEvents
Storage for events views.
Definition XTPCalendarViewDay.h:502
CXTPCalendarViewGroup::m_pViewDay
CXTPCalendarViewDay * m_pViewDay
Parent day view.
Definition XTPCalendarViewDay.h:506
CXTPCalendarViewGroup::m_pResources
CXTPCalendarResources * m_pResources
An associated resource object.
Definition XTPCalendarViewDay.h:504
CXTPCalendarViewGroup::GetGroupIndex
virtual int GetGroupIndex() const
This member function is used to obtain the index of the "this" pointer Group View in the Calendar Day...
CXTPCalendarViewGroup::GetDataProvider
virtual CXTPCalendarData * GetDataProvider() const
Returns data provider for this view group.
CXTPCalendarViewGroup::AdjustLayout2
virtual void AdjustLayout2(CDC *pDC, const CRect &rcGroup)
This member function is used to adjust the view's layout depending on the provided rectangle and then...
CXTPCalendarViewGroup::GetViewEvent_
CXTPCalendarViewEvent * GetViewEvent_(int nIndex) const
Call this member function to obtain a pointer to a CXTPCalendarViewEvent object associated with the e...
Definition XTPCalendarViewDay.h:1391
CXTPCalendarViewGroup::HitTest
virtual BOOL HitTest(CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const
This member function is used to determine which view item, if any, is at the specified position index...
CXTPCalendarViewGroup::KillTimer
virtual void KillTimer(UINT uTimerID)
This member function is used to destroy a timer event.
CXTPCalendarViewGroup::AdjustLayout
virtual void AdjustLayout(CDC *pDC, const CRect &rcGroup)
This member function is used to adjust the view's layout depending on the provided rectangle and then...
CXTPCalendarViewGroup::GetViewDay_
CXTPCalendarViewDay * GetViewDay_() const
Call this member function to obtain a pointer to the containing CXTPCalendarViewDay object.
Definition XTPCalendarViewDay.h:1421
CXTPCalendarViewGroup::GetCaption
virtual CString GetCaption() const
This member function is used to obtain a group's view caption.
CXTPCalendarViewGroup::Draw
virtual void Draw(CDC *pDC)
This member function is used to draw the view contents using the specified device context.
CXTPCalendarViewGroup::GetScheduleID
virtual UINT GetScheduleID() const
Returns default Schedule ID - the first existing one.
CXTPCalendarViewGroup::Populate
virtual void Populate(COleDateTime dtDayDate)
This member function is used to populate the view with data for all items contained in the view.
CXTPCalendarViewGroup::AddResource
virtual void AddResource(CXTPCalendarResource *pResource, BOOL bWithAddRef)
Adds a new Resource object into the collection of resources for this Group View.
CXTPCalendarViewGroup::GetViewEventByEvent_
virtual CXTPCalendarViewEvent * GetViewEventByEvent_(CXTPCalendarEvent *pEvent) const
Call this member function to obtain a pointer to a CXTPCalendarViewEvent object that is identified by...
CXTPCalendarViewGroup::~CXTPCalendarViewGroup
virtual ~CXTPCalendarViewGroup()
Default class destructor.
CXTPCalendarViewGroup::OnPrePopulate
virtual void OnPrePopulate(CXTPCalendarEvents *pEvents)
This member function is used to allow some customization before show events.
CXTPCalendarViewGroup::GetResources
virtual CXTPCalendarResources * GetResources() const
Obtain a pointer to a collection of Calendar Resources.
Definition XTPCalendarViewDay.h:1367
CXTPCalendarViewGroup::GetRect
virtual CRect GetRect() const
Call this member function to obtain the group's rectangle area.
Definition XTPCalendarViewDay.h:266
CXTPCalendarViewGroup::m_Layout
XTP_VIEW_GROUP_LAYOUT m_Layout
This group view client coordinates.
Definition XTPCalendarViewDay.h:500
CXTPCalendarViewGroup::SetTimer
virtual UINT SetTimer(UINT uTimeOut_ms)
This member function is used to create a timer event.
CXTPCalendarViewGroup::GetChildHandlerAt
virtual CXTPCalendarWMHandler * GetChildHandlerAt(int nIndex) const
Call this method to get an event view object at the specified numeric index.
CXTPCalendarViewGroup::GetCalendarControl
virtual CXTPCalendarControl * GetCalendarControl() const
Call this member function to obtain a pointer to the calendar control object.
Definition XTPCalendarViewDay.h:1379
CXTPCalendarViewGroup::SetResources
virtual void SetResources(CXTPCalendarResources *pResources)
Assigns a new Resources collection to this Group View.
CXTPCalendarViewGroup::FillHitTestEx
virtual void FillHitTestEx(XTP_CALENDAR_HITTESTINFO *pHitTest) const =0
This member function is used to fill the pHitTest structure members with the default values for the c...
CXTPCalendarViewGroup::ExchangeEventPlace
virtual void ExchangeEventPlace(CXTPCalendarViewEvent *pViewEvent, int nNewPlace)
This member function is used to exchange event view positions.
CXTPCalendarViewGroup::GetViewEventsCount
int GetViewEventsCount() const
Call this member function to obtain the number of event views in the day view collection.
Definition XTPCalendarViewDay.h:1386
CXTPCalendarViewGroup::GetHeaderRect
virtual CRect GetHeaderRect() const
Call this member function to obtain the group's header rectangle area.
Definition XTPCalendarViewDay.h:282
CXTPCalendarViewGroup::GetChildHandlersCount
virtual int GetChildHandlersCount() const
This member function is used to obtain the number of event views elements in this Group View.
Definition XTPCalendarViewDay.h:1371
CXTPCalendarViewGroup::HitTestEx
virtual BOOL HitTestEx(CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const
This member function is used to determine which view item, if any, is at the specified position index...
CXTPCalendarViewGroup::GetViewEventByPlace_
virtual CXTPCalendarViewEvent * GetViewEventByPlace_(int nEventPlace) const
Call this member function to obtain an event view object identified by its event place number.
CXTPCalendarViewGroupT
This class template customizes, overrides and implements some functionality for the CXTPCalendarViewG...
Definition XTPCalendarViewDay.h:1257
CXTPCalendarViewGroupT::GetViewEvent
virtual _TViewEvent * GetViewEvent(int nIndex) const
Call this member function to obtain a pointer to the _TViewEvent object that corresponds to the event...
Definition XTPCalendarViewDay.h:1330
CXTPCalendarViewGroupT::CXTPCalendarViewGroupT
CXTPCalendarViewGroupT(_TViewDay *pViewDay)
Default object constructor.
Definition XTPCalendarViewDay.h:1274
CXTPCalendarViewGroupT::GetPThis
virtual _TPThis * GetPThis()=0
Call this member function to obtain the typed pointer to the last derived class in the class hierarch...
CXTPCalendarViewGroupT::~CXTPCalendarViewGroupT
virtual ~CXTPCalendarViewGroupT()
Default class destructor.
Definition XTPCalendarViewDay.h:1286
CXTPCalendarViewGroupT::FillHitTestEx
virtual void FillHitTestEx(XTP_CALENDAR_HITTESTINFO *pHitTest) const =0
This member function is used to fill the pHitTest structure members with the default values for the c...
CXTPCalendarViewGroupT::TViewDay
_TViewDay TViewDay
Definition XTPCalendarViewDay.h:1263
CXTPCalendarViewGroupT::GetViewDay
_TViewDay * GetViewDay() const
This member function is used to obtain the owner view object.
Definition XTPCalendarViewDay.h:1309
CXTPCalendarView
This class represents the view portion of the Calendar control.
Definition XTPCalendarView.h:360
CXTPCalendarWMHandler
This class helps to handle Windows messages (WM_*) processing portion of the Calendar control views.
Definition XTPCalendarView.h:100
CXTPCalendarWMHandler::GetChildHandlersCount
virtual int GetChildHandlersCount() const
This member function is used to obtain the number of CXTPCalendarWMHandler elements in the descendant...
XTP_CALENDAR_HITTESTINFO
Basic set of parameters transferred from calendar items to mouse handlers.
Definition XTPCalendarDefines.h:856


Toolkit Pro: XTPResourceImage.h Source File

  • Source
  • Common
XTPResourceImage.h
Go to the documentation of this file.
1
23#if !defined(__XTPRESOURCEIMAGE_H__)
24# define __XTPRESOURCEIMAGE_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33// Composite image flag for CXTPResourceImage::DrawImage
34# define XTP_DI_COMPOSITE 1
35
36class CXTPResourceImages;
37class CXTPResourceImageList;
38class CXTPNotifyConnection;
39class CXTPBitmapDC;
40
47class _XTP_EXT_CLASS CXTPResourceImage : public CXTPCmdTarget
48{
49public:
55 CXTPResourceImage(CXTPResourceImages* pImages);
56
61 virtual ~CXTPResourceImage();
62
63public:
75 BOOL LoadFile(HMODULE hModule, LPCTSTR lpszBitmapFileName);
76
86 void SetBitmap(HBITMAP hBitmap, BOOL bAlpha = FALSE);
87
95 void DrawImage(CDC* pDC, const CRect& rcDest, CRect rcSrc);
96
105 void DrawImage(CDC* pDC, const CRect& rcDest, CRect rcSrc, CRect rcSizingMargins);
106
116 void DrawImage(CDC* pDC, const CRect& rcDest, CRect rcSrc, const CRect& rcSizingMargins,
117 COLORREF clrTransparent);
118
129 void DrawImage(CDC* pDC, const CRect& rcDest, CRect rcSrc, const CRect& rcSizingMargins,
130 COLORREF clrTransparent, DWORD dwFlags);
131
138 int GetHeight() const;
139
146 int GetWidth() const;
147
154 CSize GetExtent() const;
155
162 BOOL IsAlphaImage() const;
163
170 void PreserveOrientation();
171
180 CRect GetSource(int nState = 0, int nCount = 1) const;
181
190 BOOL GetBitmapPixel(CPoint pt, COLORREF& clrPixel);
191
196 void Premultiply();
197
203 void DrawImageFlipped(BOOL bFlip);
204
205protected:
216 BOOL DrawImagePart(CDC* pDCDest, CRect rcDest, CDC* pDCSrc, CRect rcSrc) const;
217
224 BOOL InvertBitmap();
225
233 BOOL ConvertToBits(HBITMAP hBitmap);
234
235protected:
236 LPVOID m_pBits;
237 BOOL m_bAlpha;
238 BOOL m_bMultiply;
239 BOOL m_bImageOrientaionPreserved;
241 BOOL m_bInvert;
242 CSize m_szExtent;
243 BOOL m_bFlipped;
244 CXTPResourceImages* m_pImages;
246 friend class CXTPResourceImages;
247 friend class CXTPResourceImageList;
248};
249
256class _XTP_EXT_CLASS CXTPResourceImages : public CXTPCmdTarget
257{
258 friend class CXTPSingleton<CXTPResourceImages>;
259
260public:
265 CXTPResourceImages();
266
271 virtual ~CXTPResourceImages();
272
273public:
280 void Reset();
281
288 void RemoveAll();
289
300 CXTPResourceImage* LoadFile(LPCTSTR lpszImageFile);
301
312 CXTPResourceImage* LoadImage(LPCTSTR lpszImageFile);
313
322 HMODULE GetHandle() const;
323
336 BOOL SetHandle(LPCTSTR lpszDllFileName, LPCTSTR lpszIniFileName = NULL);
337
352 BOOL SetHandle(HMODULE hResource, LPCTSTR lpszIniFileName = NULL, BOOL bFreeOnRelease = FALSE);
368 BOOL SetHandle(HMODULE hResource, LPCTSTR lpszThemeFileName, LPCTSTR lpszAppFileName,
369 BOOL bFreeOnRelease = FALSE);
370
378 void SetIniData(LPCSTR lpIniData);
379
391 BOOL InitResourceHandle(LPCTSTR lpszTestImageFile, LPCTSTR lpResType = RT_BITMAP);
392
404 COLORREF GetImageColor(LPCTSTR lpszSectionName, LPCTSTR lpszKeyName,
405 COLORREF clrDefault = (COLORREF)-1) const;
406
418 int GetImageInt(LPCTSTR lpszSectionName, LPCTSTR lpszKeyName, int nDefault = -1) const;
419
431 CRect GetImageRect(LPCTSTR lpszSectionName, LPCTSTR lpszKeyName,
432 CRect rcDefault = CRect(0, 0, 0, 0)) const;
433
445 CSize GetImageSize(LPCTSTR lpszSectionName, LPCTSTR lpszKeyName,
446 CSize szDefault = CSize(0, 0)) const;
447
459 CString GetImageString(LPCTSTR lpszSectionName, LPCTSTR lpszKeyName,
460 LPCTSTR lpszDef = NULL) const;
461
472 CString GetImageValue(LPCTSTR lpszSectionName, LPCTSTR lpszKeyName) const;
473
483 BOOL IsValid() const;
484
486 // Retained for backward compatibility
487 void AssertValid() const;
499 BOOL LoadBitmap(CBitmap* pBitmap, LPCTSTR lpszResourceName);
500
508 CXTPNotifyConnection* GetConnection();
509
510 CString m_strDllFileName;
511 CString m_strIniFileName;
513public:
515 BOOL m_bLoadedNothing;
518protected:
527 CString _ImageNameToResourceName(LPCTSTR strImageFile);
528
533 void ClearProperties();
534
542 void LoadProperties(LPSTR lpTextFile, LPSTR lpTextFileEnd, BOOL bAllowOverwrite);
543
544private:
545 BOOL ReadString(CString& str, LPSTR& lpTextFile, LPSTR lpTextFileEnd);
546
547 BOOL LoadResources(LPCTSTR lpszIniFileName);
548 BOOL LoadResources(HRSRC hRsrc, BOOL bAllowOverwrite);
549
550 static BOOL CALLBACK EnumResNameProc(HMODULE hModule, LPCTSTR lpszType, LPTSTR lpszName,
551 LONG_PTR lParam);
552 HRSRC FindResourceIniFile(HMODULE hResource);
553
554 UINT GetKeyHash(LPCTSTR lpszSection, LPCTSTR lpszKeyName) const;
555 HBITMAP AllocateLayerBitmap(UINT cx, UINT cy, LPDWORD* lpBits = NULL, SIZE* pSize = NULL);
556
557protected:
558 HMODULE m_hResource;
559 BOOL m_bFreeOnRelease;
561 CRITICAL_SECTION m_cs;
562 BOOL m_bPremultiplyImages;
563 CXTPBitmapDC* m_pdc;
565 HBITMAP m_hbmLayer;
566 LPDWORD m_pLayerBits;
567 CXTPNotifyConnection* m_pConnection;
568 CMap<UINT, UINT, CString, CString> m_mapPropeties;
569 CMapStringToPtr m_mapImages;
571# ifdef _XTP_ACTIVEX
574 DECLARE_DISPATCH_MAP()
575 DECLARE_INTERFACE_MAP()
576
577 DECLARE_OLETYPELIB_EX(CXTPResourceImages);
578
579 BOOL OleLoadFromFile(LPCTSTR lpszPath, LPCTSTR lpszIniFileName);
580 virtual void OnFinalRelease();
581 BSTR OleGetIniFileName();
582 BSTR OleGetDllFileName();
583 OLE_COLOR OleGetGetColor(LPCTSTR lpszSection, LPCTSTR lpszEntry);
584
586# endif
587
588 friend class CXTPResourceImage;
589};
590
598_XTP_EXT_CLASS CXTPResourceImages* AFX_CDECL XTPResourceImages();
599
608_XTP_EXT_CLASS CXTPResourceImage* AFX_CDECL XTPLoadImage(LPCTSTR lpszImageFile);
609
620_XTP_EXT_CLASS COLORREF AFX_CDECL XTPIniColor(LPCTSTR lpszSection, LPCTSTR lpszKey,
621 COLORREF clrDef);
622
633_XTP_EXT_CLASS int AFX_CDECL XTPIniInt(LPCTSTR lpszSection, LPCTSTR lpszKey, int nDef);
634
645_XTP_EXT_CLASS CRect AFX_CDECL XTPIniRect(LPCTSTR lpszSection, LPCTSTR lpszKey, CRect rcDef);
646
657_XTP_EXT_CLASS CSize AFX_CDECL XTPIniSize(LPCTSTR lpszSection, LPCTSTR lpszKey, CSize szDef);
658
669_XTP_EXT_CLASS CString AFX_CDECL XTPIniString(LPCTSTR lpszSection, LPCTSTR lpszKey,
670 LPCTSTR lpszDef);
671
672// Office2007.dll
673# define xtpIniOffice2007Aqua \
674 _T("OFFICE2007AQUA_INI")
676# define xtpIniOffice2007Blue \
677 _T("OFFICE2007BLUE_INI")
679# define xtpIniOffice2007Black \
680 _T("OFFICE2007BLACK_INI")
682# define xtpIniOffice2007Silver \
683 _T("OFFICE2007SILVER_INI")
686// Office2010.dll
687# define xtpIniOffice2010Blue \
688 _T("OFFICE2010BLUE_INI")
690# define xtpIniOffice2010Black \
691 _T("OFFICE2010BLACK_INI")
693# define xtpIniOffice2010Silver \
694 _T("OFFICE2010SILVER_INI")
697// Office2013.dll
698# define xtpIniOffice2013Access \
699 _T("OFFICE2013ACCESS_INI")
701# define xtpIniOffice2013AccessGrayDark \
702 _T("OFFICE2013ACCESSGRAYDARK_INI")
705# define xtpIniOffice2013AccessGrayLight \
706 _T("OFFICE2013ACCESSGRAYLIGHT_INI")
709# define xtpIniOffice2013Excel \
710 _T("OFFICE2013EXCEL_INI")
712# define xtpIniOffice2013ExcelGrayDark \
713 _T("OFFICE2013EXCELGRAYDARK_INI")
715# define xtpIniOffice2013ExcelGrayLight \
716 _T("OFFICE2013EXCELGRAYLIGHT_INI")
719# define xtpIniOffice2013OneNote \
720 _T("OFFICE2013ONENOTE_INI")
722# define xtpIniOffice2013OneNoteGrayDark \
723 _T("OFFICE2013ONENOTEGRAYDARK_INI")
726# define xtpIniOffice2013OneNoteGrayLight \
727 _T("OFFICE2013ONENOTEGRAYLIGHT_INI")
730# define xtpIniOffice2013Outlook \
731 _T("OFFICE2013OUTLOOK_INI")
733# define xtpIniOffice2013OutlookGrayDark \
734 _T("OFFICE2013OUTLOOKGRAYDARK_INI")
737# define xtpIniOffice2013OutlookGrayLight \
738 _T("OFFICE2013OUTLOOKGRAYLIGHT_INI")
741# define xtpIniOffice2013Publisher \
742 _T("OFFICE2013PUBLISHER_INI")
744# define xtpIniOffice2013PublisherGrayDark \
745 _T("OFFICE2013PUBLISHERGRAYDARK_INI")
748# define xtpIniOffice2013PublisherGrayLight \
749 _T("OFFICE2013PUBLISHERGRAYLIGHT_INI")
753# define xtpIniOffice2013PowerPoint \
754 _T("OFFICE2013POWERPOINT_INI")
756# define xtpIniOffice2013PowerPointGrayDark \
757 _T("OFFICE2013POWERPOINTGRAYDARK_INI")
761# define xtpIniOffice2013PowerPointGrayLight \
762 _T("OFFICE2013POWERPOINTGRAYLIGHT_INI")
766# define xtpIniOffice2013Word \
767 _T("OFFICE2013WORD_INI")
769# define xtpIniOffice2013WordGrayDark \
770 _T("OFFICE2013WORDGRAYDARK_INI")
772# define xtpIniOffice2013WordGrayLight \
773 _T("OFFICE2013WORDGRAYLIGHT_INI")
776// Office2016.dll
777# define xtpIniOffice2016AccessBlack \
778 _T("OFFICE2016ACCESSBLACK_INI")
780# define xtpIniOffice2016AccessColorful \
781 _T("OFFICE2016ACCESSCOLORFUL_INI")
787# define xtpIniOffice2016AccessDarkGray \
788 _T("OFFICE2016ACCESSDARKGRAY_INI")
791# define xtpIniOffice2016AccessWhite \
792 _T("OFFICE2016ACCESSWHITE_INI")
794# define xtpIniOffice2016ExcelBlack \
795 _T("OFFICE2016EXCELBLACK_INI")
797# define xtpIniOffice2016ExcelColorful \
798 _T("OFFICE2016EXCELCOLORFUL_INI")
800# define xtpIniOffice2016ExcelDarkGray \
801 _T("OFFICE2016EXCELDARKGRAY_INI")
803# define xtpIniOffice2016ExcelWhite \
804 _T("OFFICE2016EXCELWHITE_INI")
806# define xtpIniOffice2016OneNoteBlack \
807 _T("OFFICE2016ONENOTEBLACK_INI")
809# define xtpIniOffice2016OneNoteColorful \
810 _T("OFFICE2016ONENOTECOLORFUL_INI")
813# define xtpIniOffice2016OneNoteDarkGray \
814 _T("OFFICE2016ONENOTEDARKGRAY_INI")
817# define xtpIniOffice2016OneNoteWhite \
818 _T("OFFICE2016ONENOTEWHITE_INI")
820# define xtpIniOffice2016OutlookBlack \
821 _T("OFFICE2016OUTLOOKBLACK_INI")
823# define xtpIniOffice2016OutlookColorful \
824 _T("OFFICE2016OUTLOOKCOLORFUL_INI")
827# define xtpIniOffice2016OutlookDarkGray \
828 _T("OFFICE2016OUTLOOKDARKGRAY_INI")
831# define xtpIniOffice2016OutlookWhite \
832 _T("OFFICE2016OUTLOOKWHITE_INI")
834# define xtpIniOffice2016PublisherBlack \
835 _T("OFFICE2016PUBLISHERBLACK_INI")
841# define xtpIniOffice2016PublisherColorful \
842 _T("OFFICE2016PUBLISHERCOLORFUL_INI")
845# define xtpIniOffice2016PublisherDarkGray \
846 _T("OFFICE2016PUBLISHERDARKGRAY_INI")
849# define xtpIniOffice2016PublisherWhite \
850 _T("OFFICE2016PUBLISHERWHITE_INI")
856# define xtpIniOffice2016PowerPointBlack \
857 _T("OFFICE2016POWERPOINTBLACK_INI")
860# define xtpIniOffice2016PowerPointColorful \
861 _T("OFFICE2016POWERPOINTCOLORFUL_INI")
865# define xtpIniOffice2016PowerPointDarkGray \
866 _T("OFFICE2016POWERPOINTDARKGRAY_INI")
870# define xtpIniOffice2016PowerPointWhite \
871 _T("OFFICE2016POWERPOINTWHITE_INI")
874# define xtpIniOffice2016WordBlack \
875 _T("OFFICE2016WORDBLACK_INI")
877# define xtpIniOffice2016WordColorful \
878 _T("OFFICE2016WORDCOLORFUL_INI")
880# define xtpIniOffice2016WordDarkGray \
881 _T("OFFICE2016WORDDARKGRAY_INI")
883# define xtpIniOffice2016WordWhite \
884 _T("OFFICE2016WORDWHITE_INI")
887// VisualStudio2012.dll
888# define xtpIniVisualStudio2012Dark \
889 _T("VISUALSTUDIO2012DARK_INI")
891# define xtpIniVisualStudio2012Light \
892 _T("VISUALSTUDIO2012LIGHT_INI")
895// VisualStudio2015.dll
896# define xtpIniVisualStudio2015Blue \
897 _T("VISUALSTUDIO2015BLUE_INI")
899# define xtpIniVisualStudio2015Dark \
900 _T("VISUALSTUDIO2015DARK_INI")
902# define xtpIniVisualStudio2015Light \
903 _T("VISUALSTUDIO2015LIGHT_INI")
906// VisualStudio2017.dll
907# define xtpIniVisualStudio2017Blue \
908 _T("VISUALSTUDIO2017BLUE_INI")
910# define xtpIniVisualStudio2017BlueExtra \
911 _T("VISUALSTUDIO2017BLUEEXTRA_INI")
914# define xtpIniVisualStudio2017Dark \
915 _T("VISUALSTUDIO2017DARK_INI")
917# define xtpIniVisualStudio2017Light \
918 _T("VISUALSTUDIO2017LIGHT_INI")
921// VisualStudio2019.dll
922# define xtpIniVisualStudio2019Blue \
923 _T("VISUALSTUDIO2019BLUE_INI")
925# define xtpIniVisualStudio2019BlueExtra \
926 _T("VISUALSTUDIO2019BLUEEXTRA_INI")
929# define xtpIniVisualStudio2019Dark \
930 _T("VISUALSTUDIO2019DARK_INI")
932# define xtpIniVisualStudio2019Light \
933 _T("VISUALSTUDIO2019LIGHT_INI")
936// VisualStudio2022.dll
937# define xtpIniVisualStudio2022Blue \
938 _T("VISUALSTUDIO2022BLUE_INI")
940# define xtpIniVisualStudio2022BlueExtra \
941 _T("VISUALSTUDIO2022BLUEEXTRA_INI")
944# define xtpIniVisualStudio2022Dark \
945 _T("VISUALSTUDIO2022DARK_INI")
947# define xtpIniVisualStudio2022Light \
948 _T("VISUALSTUDIO2022LIGHT_INI")
951// Windows7.dll
952# define xtpIniWindows7Blue \
953 _T("WINDOWS7BLUE_INI")
956// Windows10.dll
957# define xtpIniWindows10Light \
958 _T("WINDOWS10LIGHT_INI")
960# define xtpIniWindows10Dark \
961 _T("WINDOWS10DARK_INI")
964// Windows11.dll
965# define xtpIniWindows11Light \
966 _T("WINDOWS11LIGHT_INI")
968# define xtpIniWindows11Dark \
969 _T("WINDOWS11DARK_INI")
972# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
974#endif // !defined(__XTPRESOURCEIMAGE_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPIniSize
_XTP_EXT_CLASS CSize AFX_CDECL XTPIniSize(LPCTSTR lpszSection, LPCTSTR lpszKey, CSize szDef)
Call to get the CSize value specified by lpszKey from the current theme.
XTPIniColor
_XTP_EXT_CLASS COLORREF AFX_CDECL XTPIniColor(LPCTSTR lpszSection, LPCTSTR lpszKey, COLORREF clrDef)
Call to get the color value specified by lpszKey from the current theme.
XTPIniRect
_XTP_EXT_CLASS CRect AFX_CDECL XTPIniRect(LPCTSTR lpszSection, LPCTSTR lpszKey, CRect rcDef)
Call to get the CRect value specified by lpszKey from the current theme.
XTPIniString
_XTP_EXT_CLASS CString AFX_CDECL XTPIniString(LPCTSTR lpszSection, LPCTSTR lpszKey, LPCTSTR lpszDef)
Call to get the CString value specified by lpszKey from the current theme.
XTPIniInt
_XTP_EXT_CLASS int AFX_CDECL XTPIniInt(LPCTSTR lpszSection, LPCTSTR lpszKey, int nDef)
Call to get the int value specified by lpszKey from the current theme.
XTPResourceImages
_XTP_EXT_CLASS CXTPResourceImages *AFX_CDECL XTPResourceImages()
Call to access members of the CXTPResourceImages class.
XTPLoadImage
_XTP_EXT_CLASS CXTPResourceImage *AFX_CDECL XTPLoadImage(LPCTSTR lpszImageFile)
Call to access members of the CXTPResourceImage class.
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPNotifyConnection
This class is used as implementation of Connection interface in a XTPNotification mechanism.
Definition XTPNotifyConnection.h:88
CXTPResourceImage
Represent a resource image and provides basic images functions.
Definition XTPResourceImage.h:48
CXTPResourceImage::DrawImage
void DrawImage(CDC *pDC, const CRect &rcDest, CRect rcSrc)
Draws an image to the device context provided.
CXTPResourceImage::InvertBitmap
BOOL InvertBitmap()
Inverts image bits.
CXTPResourceImage::LoadFile
BOOL LoadFile(HMODULE hModule, LPCTSTR lpszBitmapFileName)
Loads image from the resource specified.
CXTPResourceImage::GetWidth
int GetWidth() const
Determine image dimensions.
CXTPResourceImage::GetHeight
int GetHeight() const
Determine image dimensions.
CXTPResourceImage::m_pImages
CXTPResourceImages * m_pImages
Parent image list pointer.
Definition XTPResourceImage.h:244
CXTPResourceImage::GetBitmapPixel
BOOL GetBitmapPixel(CPoint pt, COLORREF &clrPixel)
Obtains pixel color value at the point specified.
CXTPResourceImage::m_pBits
LPVOID m_pBits
Image bits.
Definition XTPResourceImage.h:236
CXTPResourceImage::CXTPResourceImage
CXTPResourceImage(CXTPResourceImages *pImages)
Constructs resource image which is a part of image collection.
CXTPResourceImage::Premultiply
void Premultiply()
Pre-multiplies alpha image bits.
CXTPResourceImage::PreserveOrientation
void PreserveOrientation()
Enables preserved image orientation for RTL contexts and inverted drawing.
CXTPResourceImage::DrawImage
void DrawImage(CDC *pDC, const CRect &rcDest, CRect rcSrc, const CRect &rcSizingMargins, COLORREF clrTransparent)
Draws an image to the device context provided.
CXTPResourceImage::m_szExtent
CSize m_szExtent
Image size.
Definition XTPResourceImage.h:242
CXTPResourceImage::DrawImagePart
BOOL DrawImagePart(CDC *pDCDest, CRect rcDest, CDC *pDCSrc, CRect rcSrc) const
Draws image part.
CXTPResourceImage::ConvertToBits
BOOL ConvertToBits(HBITMAP hBitmap)
Obtains bitmap bits and uses them as image bits for the current image.
CXTPResourceImage::DrawImage
void DrawImage(CDC *pDC, const CRect &rcDest, CRect rcSrc, const CRect &rcSizingMargins, COLORREF clrTransparent, DWORD dwFlags)
Draws an image to the device context provided.
CXTPResourceImage::m_bMultiply
BOOL m_bMultiply
TRUE if an alpha image bits were multiplied.
Definition XTPResourceImage.h:238
CXTPResourceImage::GetExtent
CSize GetExtent() const
Determine image dimensions.
CXTPResourceImage::m_bInvert
BOOL m_bInvert
TRUE indicates the images bits are currently inverted.
Definition XTPResourceImage.h:241
CXTPResourceImage::m_bAlpha
BOOL m_bAlpha
TRUE for 32-bit alpha images.
Definition XTPResourceImage.h:237
CXTPResourceImage::~CXTPResourceImage
virtual ~CXTPResourceImage()
Handles resource image deallocation.
CXTPResourceImage::GetSource
CRect GetSource(int nState=0, int nCount=1) const
Obtains a source rectable for an image in image list.
CXTPResourceImage::m_bImageOrientaionPreserved
BOOL m_bImageOrientaionPreserved
TRUE if image orientation is to be preserved for RTL or flipped drawing.
Definition XTPResourceImage.h:239
CXTPResourceImage::SetBitmap
void SetBitmap(HBITMAP hBitmap, BOOL bAlpha=FALSE)
Loads image bits from the bitmap provided.
CXTPResourceImage::DrawImage
void DrawImage(CDC *pDC, const CRect &rcDest, CRect rcSrc, CRect rcSizingMargins)
Draws an image to the device context provided.
CXTPResourceImage::DrawImageFlipped
void DrawImageFlipped(BOOL bFlip)
Enables/disables image flipping.
CXTPResourceImage::IsAlphaImage
BOOL IsAlphaImage() const
Determines whether the image is a 32-bit image with alpha channel.
CXTPResourceImage::m_bFlipped
BOOL m_bFlipped
TRUE m_bFlipped the image bits are currently flipped.
Definition XTPResourceImage.h:243
CXTPResourceImages
Implements resource image collection and its operations.
Definition XTPResourceImage.h:257
CXTPResourceImages::m_bFreeOnRelease
BOOL m_bFreeOnRelease
If TRUE, the module determined by m_hResource will be unloaded upon release.
Definition XTPResourceImage.h:559
CXTPResourceImages::GetImageString
CString GetImageString(LPCTSTR lpszSectionName, LPCTSTR lpszKeyName, LPCTSTR lpszDef=NULL) const
Obtains string value from the specific key of the currently loaded INI file.
CXTPResourceImages::GetHandle
HMODULE GetHandle() const
Obtains resource handle value.
CXTPResourceImages::LoadBitmap
BOOL LoadBitmap(CBitmap *pBitmap, LPCTSTR lpszResourceName)
Loads a bitmap from the currently assigned resource module.
CXTPResourceImages::Reset
void Reset()
Removes all loaded images and clears all loaded properties.
CXTPResourceImages::LoadImage
CXTPResourceImage * LoadImage(LPCTSTR lpszImageFile)
Loads image from resource.
CXTPResourceImages::InitResourceHandle
BOOL InitResourceHandle(LPCTSTR lpszTestImageFile, LPCTSTR lpResType=RT_BITMAP)
Searches for a module that contains the resource specified and uses it as a resource module.
CXTPResourceImages::GetImageColor
COLORREF GetImageColor(LPCTSTR lpszSectionName, LPCTSTR lpszKeyName, COLORREF clrDefault=(COLORREF) -1) const
Obtains color value from the specific key of the currently loaded INI file.
CXTPResourceImages::m_pConnection
CXTPNotifyConnection * m_pConnection
Connection sink object pointer.
Definition XTPResourceImage.h:567
CXTPResourceImages::SetHandle
BOOL SetHandle(HMODULE hResource, LPCTSTR lpszThemeFileName, LPCTSTR lpszAppFileName, BOOL bFreeOnRelease=FALSE)
Sets image collection resource handle.
CXTPResourceImages::m_pLayerBits
LPDWORD m_pLayerBits
Bitmap layer bits pointer.
Definition XTPResourceImage.h:566
CXTPResourceImages::GetImageValue
CString GetImageValue(LPCTSTR lpszSectionName, LPCTSTR lpszKeyName) const
Obtains string value from the specific key of any type of the currently loaded INI file.
CXTPResourceImages::GetImageSize
CSize GetImageSize(LPCTSTR lpszSectionName, LPCTSTR lpszKeyName, CSize szDefault=CSize(0, 0)) const
Obtains size value from the specific key of the currently loaded INI file.
CXTPResourceImages::m_cs
CRITICAL_SECTION m_cs
Shared access critical section.
Definition XTPResourceImage.h:561
CXTPResourceImages::m_hbmLayer
HBITMAP m_hbmLayer
Bitmap layer handle.
Definition XTPResourceImage.h:565
CXTPResourceImages::RemoveAll
void RemoveAll()
Removes all loaded images only.
CXTPResourceImages::m_pdc
CXTPBitmapDC * m_pdc
An off-screen device context pointer used for internal image processing.
Definition XTPResourceImage.h:563
CXTPResourceImages::LoadFile
CXTPResourceImage * LoadFile(LPCTSTR lpszImageFile)
Loads image from resources and adds it to the collection.
CXTPResourceImages::IsValid
BOOL IsValid() const
Determines if image collection state is valid, i.e.
CXTPResourceImages::CXTPResourceImages
CXTPResourceImages()
Construct an empty resource image collection.
CXTPResourceImages::GetImageInt
int GetImageInt(LPCTSTR lpszSectionName, LPCTSTR lpszKeyName, int nDefault=-1) const
Obtains integer value from the specific key of the currently loaded INI file.
CXTPResourceImages::~CXTPResourceImages
virtual ~CXTPResourceImages()
Handles resource image list deallocation.
CXTPResourceImages::m_strDllFileName
CString m_strDllFileName
Loaded DLL file name.
Definition XTPResourceImage.h:510
CXTPResourceImages::m_strIniFileName
CString m_strIniFileName
Loaded INI file name.
Definition XTPResourceImage.h:511
CXTPResourceImages::ClearProperties
void ClearProperties()
Clears all loaded INI properties.
CXTPResourceImages::m_mapImages
CMapStringToPtr m_mapImages
Loaded image collection.
Definition XTPResourceImage.h:569
CXTPResourceImages::m_hResource
HMODULE m_hResource
Associated resource module handle.
Definition XTPResourceImage.h:558
CXTPResourceImages::m_mapPropeties
CMap< UINT, UINT, CString, CString > m_mapPropeties
Loaded INI properties.
Definition XTPResourceImage.h:568
CXTPResourceImages::_ImageNameToResourceName
CString _ImageNameToResourceName(LPCTSTR strImageFile)
Converts file name to resource file name, Symbols '.
CXTPResourceImages::SetIniData
void SetIniData(LPCSTR lpIniData)
Loads INI file properties from the provided input.
CXTPResourceImages::LoadProperties
void LoadProperties(LPSTR lpTextFile, LPSTR lpTextFileEnd, BOOL bAllowOverwrite)
Loads INI properties from the INI text range.
CXTPResourceImages::SetHandle
BOOL SetHandle(HMODULE hResource, LPCTSTR lpszIniFileName=NULL, BOOL bFreeOnRelease=FALSE)
Sets image collection resource handle.
CXTPResourceImages::m_bPremultiplyImages
BOOL m_bPremultiplyImages
If TRUE, the bits of alpha images are to be pre-multiplied.
Definition XTPResourceImage.h:562
CXTPResourceImages::GetConnection
CXTPNotifyConnection * GetConnection()
Return connection object pointer that can be used for subscribing to collection events.
CXTPResourceImages::GetImageRect
CRect GetImageRect(LPCTSTR lpszSectionName, LPCTSTR lpszKeyName, CRect rcDefault=CRect(0, 0, 0, 0)) const
Obtains rectangle value from the specific key of the currently loaded INI file.
CXTPResourceImages::SetHandle
BOOL SetHandle(LPCTSTR lpszDllFileName, LPCTSTR lpszIniFileName=NULL)
Sets image collection resource handle.
CXTPSingleton
Implements Singleton design pattern.
Definition XTPSingleton.h:215


Toolkit Pro: Member List

CXTPCalendarRemindersDialog Member List

This is the complete list of members for CXTPCalendarRemindersDialog, including all inherited members.

Create(CWnd *pParent=NULL) | CXTPCalendarRemindersDialog | virtual
CXTPCalendarRemindersDialog(CWnd *pParent=NULL, UINT nIDTemplate=CXTPCalendarRemindersDialog::IDD) | CXTPCalendarRemindersDialog |
Detach() | CXTPCalendarRemindersDialog | virtual
IsAutoPopup() const | CXTPCalendarRemindersDialog |
IsShowInTaskBar() | CXTPCalendarRemindersDialog | virtual
m_arActiveReminders | CXTPCalendarRemindersDialog | protected
m_bAutoPopup | CXTPCalendarRemindersDialog | protected
m_bShowInTaskBar | CXTPCalendarRemindersDialog | protected
m_ctrlDescription | CXTPCalendarRemindersDialog | protected
m_ctrlDismissAllBtn | CXTPCalendarRemindersDialog | protected
m_ctrlDismissBtn | CXTPCalendarRemindersDialog | protected
m_ctrlOpenItemBtn | CXTPCalendarRemindersDialog | protected
m_ctrlRemindersList | CXTPCalendarRemindersDialog | protected
m_ctrlSnoozeBtn | CXTPCalendarRemindersDialog | protected
m_ctrlSnoozeTimeCB | CXTPCalendarRemindersDialog | protected
m_nNextRefreshIndex | CXTPCalendarRemindersDialog | protected
m_pCalendar | CXTPCalendarRemindersDialog | protected
m_pRemindersMan | CXTPCalendarRemindersDialog | protected
SetAutoPopup(BOOL bAutoPopup=TRUE) | CXTPCalendarRemindersDialog |
SetRemindersManager(CXTPCalendarControl *pCalendar) | CXTPCalendarRemindersDialog | virtual
SetShowInTaskBar(BOOL bShow=TRUE) | CXTPCalendarRemindersDialog | virtual
UpdateFromManager() | CXTPCalendarRemindersDialog | virtual
~CXTPCalendarRemindersDialog() | CXTPCalendarRemindersDialog | virtual


Toolkit Pro: Member List

CXTPChartSeriesLabel Member List

This is the complete list of members for CXTPChartSeriesLabel, including all inherited members.

CXTPChartElement() | CXTPChartElement |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartSeriesLabel() | CXTPChartSeriesLabel |
DoPropExchange(CXTPPropExchange *pPX) | CXTPChartSeriesLabel | virtual
GetAntialiasing() const | CXTPChartSeriesLabel | virtual
GetAppearance() const | CXTPChartElement |
GetBackColor() const | CXTPChartSeriesLabel |
GetContent() const | CXTPChartElement |
GetFont() const | CXTPChartSeriesLabel | virtual
GetFormat() const | CXTPChartSeriesLabel |
GetLineColor() const | CXTPChartSeriesLabel |
GetLineLength() const | CXTPChartSeriesLabel |
GetOwner() const | CXTPChartElement |
GetShowLines() const | CXTPChartSeriesLabel |
GetTextColor() const | CXTPChartSeriesLabel |
GetTransparency() const | CXTPChartSeriesLabel |
Is3D() const | CXTPChartObject |
IsVisible() const | CXTPChartSeriesLabel |
m_bAntialiasing | CXTPChartSeriesLabel | protected
m_bShowLines | CXTPChartSeriesLabel | protected
m_bVisible | CXTPChartSeriesLabel | protected
m_clrBackColor | CXTPChartSeriesLabel | protected
m_clrLineColor | CXTPChartSeriesLabel | protected
m_clrTextColor | CXTPChartSeriesLabel | protected
m_nLineLength | CXTPChartSeriesLabel | protected
m_nTransparency | CXTPChartSeriesLabel | protected
m_pBorder | CXTPChartSeriesLabel | protected
m_pFont | CXTPChartSeriesLabel | protected
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartElement | virtual
Release() | CXTPChartElement | virtual
SetAntialiasing(BOOL bAntialiasing) | CXTPChartSeriesLabel |
SetBackColor(const CXTPChartColor &clrBackColor) | CXTPChartSeriesLabel |
SetFont(CXTPChartFont *pFont) | CXTPChartSeriesLabel |
SetFormat(LPCTSTR lpszFormat) | CXTPChartSeriesLabel |
SetLineColor(const CXTPChartColor &clrBackColor) | CXTPChartSeriesLabel |
SetLineLength(int nLineLength) | CXTPChartSeriesLabel |
SetShowLines(BOOL bShowLines) | CXTPChartSeriesLabel |
SetTextColor(const CXTPChartColor &clrTextColor) | CXTPChartSeriesLabel |
SetTransparency(int nTransparency) | CXTPChartSeriesLabel |
SetVisible(BOOL bVisible) | CXTPChartSeriesLabel |
~CXTPChartElement() | CXTPChartElement | virtual
~CXTPChartSeriesLabel() | CXTPChartSeriesLabel | virtual


Toolkit Pro: Member List

CXTPMarkupStaticExtension Member List

This is the complete list of members for CXTPMarkupStaticExtension, including all inherited members.

CXTPMarkupStaticExtension(LPCWSTR lpzName, BOOL bProperty) | CXTPMarkupStaticExtension | protected
CXTPMarkupStaticExtension(LPCWSTR lpzName) | CXTPMarkupStaticExtension |
Extend(CXTPMarkupStaticExtension *pExtension, BOOL bReplace=FALSE) | CXTPMarkupStaticExtension |
FindExtension(LPCWSTR lpzName) const | CXTPMarkupStaticExtension |
GetName() const | CXTPMarkupStaticExtension |
IsProperty() const | CXTPMarkupStaticExtension |
OnPrepareValue() | CXTPMarkupStaticExtension | inlineprotectedvirtual
Parse(LPCWSTR lpzValue, LPCWSTR &lpzSubValue) | CXTPMarkupStaticExtension | static
ProvideValue(LPCWSTR lpzValue) | CXTPMarkupStaticExtension | virtual
ProvideValue() | CXTPMarkupStaticExtension | virtual
~CXTPMarkupStaticExtension() | CXTPMarkupStaticExtension | virtual


Toolkit Pro: XTPCommandBarsThemeMsMoney.h Source File

  • Source
  • CommandBars
  • Themes
XTPCommandBarsThemeMsMoney.h
Go to the documentation of this file.
1
23#if !defined(__XTPCOMMANDBARSTHEMEMSMONEY_H__)
24# define __XTPCOMMANDBARSTHEMEMSMONEY_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class _XTP_EXT_CLASS CXTPCommandBarsThemeMsMoney : public CXTPDefaultTheme
34{
35public:
36 CXTPCommandBarsThemeMsMoney(COLORREF clrGradientLight, COLORREF clrGradientDark,
37 COLORREF clrLineLight, COLORREF clrLineDark);
38 virtual ~CXTPCommandBarsThemeMsMoney();
39
40 virtual void FillCommandBarEntry(CDC* pDC, CXTPCommandBar* pBar);
41 virtual CSize DrawControlPopupParent(CDC* pDC, CXTPControl* pButton, BOOL bDraw);
42 virtual CSize DrawCommandBarSeparator(CDC* pDC, CXTPCommandBar* pBar, CXTPControl* pControl,
43 BOOL bDraw);
44 virtual void AdjustExcludeRect(CRect& rc, CXTPControl* pControl, BOOL bVertical);
45 virtual CSize DrawControlToolBarParent(CDC* pDC, CXTPControl* pButton, BOOL bDraw);
46 virtual CRect GetCommandBarBorders(CXTPCommandBar* pBar);
47 virtual CSize DrawCommandBarGripper(CDC* pDC, CXTPCommandBar* pBar, BOOL bDraw);
48 virtual void DrawImage(CDC* pDC, CPoint pt, CSize sz, CXTPImageManagerIcon* pImage,
49 BOOL bSelected, BOOL bPressed, BOOL bEnabled = TRUE,
50 BOOL bChecked = FALSE, BOOL bPopuped = FALSE, BOOL bToolBarImage = TRUE);
51 virtual CSize DrawSpecialControl(CDC* pDC, XTPSpecialControl controlType, CXTPControl* pButton,
52 CXTPCommandBar* pBar, BOOL bDraw, LPVOID lpParam);
53
54private:
55 COLORREF m_clrGradientLight;
56 COLORREF m_clrGradientDark;
57 COLORREF m_clrLineLight;
58 COLORREF m_clrLineDark;
59};
60
63# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
64#endif // !defined(__XTPCOMMANDBARSTHEMEMSMONEY_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPSpecialControl
XTPSpecialControl
Special control with extended drawing.
Definition XTPPaintManager.h:80
CXTPCommandBar
CXTPCommandBar is a CWnd derived class.
Definition XTPCommandBar.h:66
CXTPControl
CXTPControl is a CXTPCmdTarget derived class.
Definition XTPControl.h:841
CXTPImageManagerIcon
Icons holder class.
Definition XTPImageManager.h:622


Toolkit Pro: Member List

  • CXTPSyntaxEditBufferManager
  • CXTPSyntaxEditStringsManager
CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager Member List

This is the complete list of members for CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager, including all inherited members.

CXTPSyntaxEditStringsManager() | CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager |
DeleteText(int nRow, int nPos, int nCount) | CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager |
GetCount() const | CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager |
GetStr(int nRow) const | CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager |
GetStrData(int nRow, BOOL bGrowArrayIfNeed=TRUE) | CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager |
GetStrDataC(int nRow) const | CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager |
GetStrLen(int nRow) const | CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager |
GetStrLenC(int nRow) const | CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager |
InsertStr(int nRow, const CString &strText) | CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager |
InsertText(int nRow, int nPos, LPCTSTR pcszText, BOOL bGrowArrayIfNeed=FALSE, TCHAR chLeftSpaceFiller=_T(' ')) | CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager |
m_arStrings | CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager |
RemoveAllStrs() | CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager |
RemoveStr(int nRow) | CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager |
SetAtGrowStr(int nRow, const CString &strText) | CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager |
SetAtGrowStr(int nRow, LPCTSTR pcszText) | CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager |
~CXTPSyntaxEditStringsManager() | CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager | virtual


Toolkit Pro: XTPCalendarMsgNotifier.h Source File

  • Source
  • Calendar
XTPCalendarMsgNotifier.h
Go to the documentation of this file.
1
22#if !defined(_XTP_CALENDARMSGNOTIFIER_H__)
23# define _XTP_CALENDARMSGNOTIFIER_H__
24
25# if _MSC_VER > 1000
26# pragma once
27# endif // _MSC_VER > 1000
28
29# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
30
32// CXTPCalendarMsgNotifier window
33
39extern UINT XTP_WM_TIME_ZONE_CHANGED;
40
41class CXTPCalendarMsgNotifier;
42
55_XTP_EXT_CLASS CXTPCalendarMsgNotifier* AFX_CDECL XTPCalendarMsgNotifier();
56
68class _XTP_EXT_CLASS CXTPCalendarMsgNotifier : public CWnd
69{
70public:
75 CXTPCalendarMsgNotifier();
76
81 virtual ~CXTPCalendarMsgNotifier();
82
87 enum EnumParams
88 {
89 msgAll = 0
90 };
91
105 void Advise(CWnd* pWnd, UINT uWndMsg = msgAll);
106
120 void Unadvise(CWnd* pWnd, UINT uWndMsg = msgAll);
121
122protected:
123 friend _XTP_EXT_CLASS CXTPCalendarMsgNotifier* AFX_CDECL XTPCalendarMsgNotifier();
124
134 BOOL CreateWnd();
135
136 DECLARE_MESSAGE_MAP()
137
138 afx_msg void OnTimeChange();
139 afx_msg void OnSysColorChange();
140 afx_msg void OnTimer(UINT_PTR uTimerID);
141
142private:
143 struct CLIENT_INFO
144 {
145 CWnd* m_pWnd;
146 UINT m_uWndMsg;
147 };
148
149 class CClientsArray : public CArray<CLIENT_INFO, CLIENT_INFO&>
150 {
151 public:
152 CClientsArray();
153 virtual ~CClientsArray();
154
155 int FindExact(CWnd* pWnd, UINT uWndMsg = CXTPCalendarMsgNotifier::msgAll) const;
156 int FindClient(CWnd* pWnd, UINT uWndMsg = CXTPCalendarMsgNotifier::msgAll) const;
157 void Remove(CWnd* pWnd, UINT uWndMsg = CXTPCalendarMsgNotifier::msgAll);
158 };
159
160 CClientsArray m_arClients;
161
162 SYSTEMTIME m_timeLastDate;
163 TIME_ZONE_INFORMATION m_tziLast;
164
165 void SendToClients(UINT uWndMsg, WPARAM wParam, LPARAM lParam);
166
167 void _ProcessTimeZone();
168
169 BOOL IsTimeZoneEqual(const TIME_ZONE_INFORMATION& rTzi1,
170 const TIME_ZONE_INFORMATION& rTzi2) const;
171};
172
174
175# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
176#endif // !defined(_XTP_CALENDARMSGNOTIFIER_H__)
XTPCalendarMsgNotifier
_XTP_EXT_CLASS CXTPCalendarMsgNotifier *AFX_CDECL XTPCalendarMsgNotifier()
This global function is used to get a library static common top-level window object to catch windows ...
XTP_WM_TIME_ZONE_CHANGED
UINT XTP_WM_TIME_ZONE_CHANGED
Define windows message sent by CXTPCalendarMsgNotifier when the current timezone is changed.
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCalendarMsgNotifier
This class is used to catch windows messages, which the system sends to top-level windows,...
Definition XTPCalendarMsgNotifier.h:69
CXTPCalendarMsgNotifier::EnumParams
EnumParams
This enum contains additional parameter value(s).
Definition XTPCalendarMsgNotifier.h:88
CXTPCalendarMsgNotifier::msgAll
@ msgAll
This value means all messages or any message.
Definition XTPCalendarMsgNotifier.h:89
CXTPCalendarMsgNotifier::XTPCalendarMsgNotifier
friend _XTP_EXT_CLASS CXTPCalendarMsgNotifier *AFX_CDECL XTPCalendarMsgNotifier()
This global function is used to get a library static common top-level window object to catch windows ...
CXTPCalendarMsgNotifier::CXTPCalendarMsgNotifier
CXTPCalendarMsgNotifier()
Default object constructor.
CXTPCalendarMsgNotifier::CreateWnd
BOOL CreateWnd()
This method is used to Create a CWnd object.
CXTPCalendarMsgNotifier::Unadvise
void Unadvise(CWnd *pWnd, UINT uWndMsg=msgAll)
Unadvise CWnd object from receive specified top-level windows message(s).
CXTPCalendarMsgNotifier::Advise
void Advise(CWnd *pWnd, UINT uWndMsg=msgAll)
Advise CWnd object to receive specified top-level windows message(s).
CXTPCalendarMsgNotifier::~CXTPCalendarMsgNotifier
virtual ~CXTPCalendarMsgNotifier()
Default object destructor.


Toolkit Pro: XTPSearchOptionsCtrl.h Source File

  • Source
  • Controls
  • Static
XTPSearchOptionsCtrl.h
Go to the documentation of this file.
1
23#if !defined(__XTPSEARCHOPTIONSCTRL_H__)
24# define __XTPSEARCHOPTIONSCTRL_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
70class _XTP_EXT_CLASS CXTPSearchOptionsCtrl : public CStatic
71{
73 DECLARE_DYNAMIC(CXTPSearchOptionsCtrl)
75public:
80 CXTPSearchOptionsCtrl();
81
86 virtual ~CXTPSearchOptionsCtrl();
87
88public:
96 bool IsExpanded() const;
97
104 void AddControl(CWnd* pWndCtrl);
105
112 void MoveControl(CWnd* pWndCtrl);
113
123 void SetLabelText(LPCTSTR lpszExpand, LPCTSTR lpszContract);
124
131 void Expand();
132
139 void Contract();
140
149 int GetMinSize();
150
159 int GetMaxSize();
160
171 int GetOffsetSize();
172
173protected:
181 virtual bool Init();
182
184 DECLARE_MESSAGE_MAP()
185
186 //{{AFX_VIRTUAL(CXTPSearchOptionsCtrl)
187 virtual void PreSubclassWindow();
188 virtual BOOL PreCreateWindow(CREATESTRUCT& cs);
189 //}}AFX_VIRTUAL
190
191 //{{AFX_MSG(CXTPSearchOptionsCtrl)
192 afx_msg BOOL OnEraseBkgnd(CDC* pDC);
193 afx_msg void OnPaint();
194 afx_msg void OnLButtonDown(UINT nFlags, CPoint point);
195 afx_msg BOOL OnSetCursor(CWnd* pWnd, UINT nHitTest, UINT message);
196 afx_msg int OnCreate(LPCREATESTRUCT lpCreateStruct);
197 afx_msg void OnWindowPosChanged(WINDOWPOS FAR* lpwndpos);
198 afx_msg void OnEnable(BOOL bEnable);
199 //}}AFX_MSG
202protected:
203 int m_iMinSize;
204 int m_iMaxSize;
205 bool m_bExpanded;
206 bool m_bPreSubclassInit;
207 CRect m_rcLabel;
208 CString m_strExpandLabel;
209 CString m_strContractLabel;
210 CPtrArray m_arHideCtrls;
211 CPtrArray m_arMoveCtrls;
212};
213
215
216AFX_INLINE int CXTPSearchOptionsCtrl::GetMinSize()
217{
218 return m_iMinSize;
219}
220AFX_INLINE int CXTPSearchOptionsCtrl::GetMaxSize()
221{
222 return m_iMaxSize;
223}
224AFX_INLINE int CXTPSearchOptionsCtrl::GetOffsetSize()
225{
226 return GetMaxSize() - GetMinSize();
227}
228AFX_INLINE bool CXTPSearchOptionsCtrl::IsExpanded() const
229{
230 return m_bExpanded;
231}
233// forwards
234class CXTPSearchOptionsCtrl;
235
243class _XTP_EXT_CLASS CXTPSearchOptionsView : public CFormView
244{
246 DECLARE_DYNAMIC(CXTPSearchOptionsView)
248private:
249 // CResizeWnd - private helper class
250 class CResizeWnd
251 {
252 public:
253 CResizeWnd(CWnd* pWndParent, HWND hWndChild, const XTP_RESIZEPOINT& ptTopLeft,
254 const XTP_RESIZEPOINT& ptTopRight);
255 virtual ~CResizeWnd();
256 bool Resize(HDWP& hDWP, float iOffset);
257 bool IsGroupBox();
258
259 HWND m_hWndChild;
260 CWnd* m_pWndParent;
261 CRect m_rcWindow;
262 CRect m_rcParent;
263 CXTPResizeRect m_rcSizing;
264 };
265
266private:
267 // CResizeWndArray - private helper class
268 typedef CList<CResizeWnd*, CResizeWnd*> CResizeWndArray;
269
270protected:
284 CXTPSearchOptionsView(UINT nIDTemplate);
285
300 CXTPSearchOptionsView(LPCTSTR lpszTemplateName);
301
306 virtual ~CXTPSearchOptionsView();
307
308protected:
324 void SetResize(int nID, const XTP_RESIZEPOINT& ptTopLeft, const XTP_RESIZEPOINT& ptTopRight);
325
333 void AdjustScrollSizes(CXTPSearchOptionsCtrl* pSOCtrl, bool bAdd);
334
335public:
336 virtual COLORREF GetBackColor() const;
337
338protected:
340 DECLARE_MESSAGE_MAP()
341
342 //{{AFX_VIRTUAL(CXTPSearchOptionsView)
343protected:
344 virtual LRESULT WindowProc(UINT message, WPARAM wParam, LPARAM lParam);
345 virtual BOOL OnInitDialog();
346 //}}AFX_VIRTUAL
347
348 //{{AFX_MSG(CXTPSearchOptionsView)
349 afx_msg HBRUSH OnCtlColor(CDC* pDC, CWnd* pWnd, UINT nCtlColor);
350 afx_msg void OnSize(UINT nType, int cx, int cy);
351 //}}AFX_MSG
354protected:
355 CXTPBrush m_xtpBrush;
356 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED_(HBRUSH, HBRUSH, HBRUSH, m_hBrush, m_xtpBrush,
357 GetBrushHandle);
358
359 COLORREF m_clrBrush;
360 CRect m_rcWindow;
361 CResizeWndArray m_arResizeWnd;
362};
363
364# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
366#endif // !defined(__XTPSEARCHOPTIONSCTRL_H__)
XTPDisableNoisyWarnings.h
CXTPBrush
Provides a convenient object oriented interface for HBRUSH GDI object and uses GDI handle caching.
Definition XTPGdiObjects.h:653
CXTPResizeRect
CXTPResizeRect is an XTP_RESIZERECT structure derived class.
Definition XTPResizeRect.h:81
CXTPSearchOptionsCtrl
CXTPSearchOptionsCtrl is a CStatic derived class.
Definition XTPSearchOptionsCtrl.h:71
CXTPSearchOptionsCtrl::GetMaxSize
int GetMaxSize()
Call this member function to return the maximum height of the hide item control.
CXTPSearchOptionsCtrl::IsExpanded
bool IsExpanded() const
Call this member function to determine if the search options control has been expanded.
CXTPSearchOptionsCtrl::~CXTPSearchOptionsCtrl
virtual ~CXTPSearchOptionsCtrl()
Destroys a CXTPSearchOptionsCtrl object, handles cleanup and deallocation.
CXTPSearchOptionsCtrl::AddControl
void AddControl(CWnd *pWndCtrl)
Call this member function to add a control to the list of controls that are displayed when the hide i...
CXTPSearchOptionsCtrl::MoveControl
void MoveControl(CWnd *pWndCtrl)
Call this member function to add a control to the list of controls that are moved when the hide item ...
CXTPSearchOptionsCtrl::SetLabelText
void SetLabelText(LPCTSTR lpszExpand, LPCTSTR lpszContract)
Call this member function to set the text that is displayed when the hide item control is either expa...
CXTPSearchOptionsCtrl::Expand
void Expand()
Call this member function to expand the hide item control and display CWnd objects contained in the h...
CXTPSearchOptionsCtrl::Contract
void Contract()
Call this member function to contract the hide item control and hide CWnd objects contained in the hi...
CXTPSearchOptionsCtrl::CXTPSearchOptionsCtrl
CXTPSearchOptionsCtrl()
Constructs a CXTPSearchOptionsCtrl object.
CXTPSearchOptionsCtrl::Init
virtual bool Init()
This member function is called by the CXTPSearchOptionsCtrl class to perform initialization when the ...
CXTPSearchOptionsCtrl::GetMinSize
int GetMinSize()
Call this member function to return the minimum height of the hide item control.
CXTPSearchOptionsCtrl::GetOffsetSize
int GetOffsetSize()
Call this member function to return the offset size for the CXTPSearchOptionsCtrl object.
CXTPSearchOptionsView
CXTPSearchOptionsView is a CFormView derived class.
Definition XTPSearchOptionsCtrl.h:244
CXTPSearchOptionsView::CXTPSearchOptionsView
CXTPSearchOptionsView(UINT nIDTemplate)
When you create an object of a type derived from CXTPSearchOptionsView, invoke one of the constructor...
CXTPSearchOptionsView::SetResize
void SetResize(int nID, const XTP_RESIZEPOINT &ptTopLeft, const XTP_RESIZEPOINT &ptTopRight)
The SetResize function specifies how much each side of a control will move when the dialog is resized...
CXTPSearchOptionsView::CXTPSearchOptionsView
CXTPSearchOptionsView(LPCTSTR lpszTemplateName)
When you create an object of a type derived from CXTPSearchOptionsView, invoke one of the constructor...
CXTPSearchOptionsView::AdjustScrollSizes
void AdjustScrollSizes(CXTPSearchOptionsCtrl *pSOCtrl, bool bAdd)
Call this member function to adjust the scroll sizes for the form view.
CXTPSearchOptionsView::~CXTPSearchOptionsView
virtual ~CXTPSearchOptionsView()
Destroys a CXTPSearchOptionsView object, handles cleanup and deallocation.
XTP_RESIZEPOINT
The XTP_RESIZEPOINT structure is used by the CXTPResizePoint class for defining single-precision floa...
Definition XTPResizePoint.h:42


Toolkit Pro: Member List

CXTPCalendarThemeIntValue Member List

This is the complete list of members for CXTPCalendarThemeIntValue, including all inherited members.

CopySettings(const CXTPCalendarThemeCustomizableXValueT< int, int > &refSrc) | CXTPCalendarThemeCustomizableXValueT< int, int > | inline
CXTPCalendarThemeCustomizableXValueT() | CXTPCalendarThemeCustomizableXValueT< int, int > | inline
CXTPCalendarThemeIntValue() | CXTPCalendarThemeIntValue |
DoDestroy(int &refValue) | CXTPCalendarThemeCustomizableXValueT< int, int > | inlinevirtual
DoPropExchange(CXTPPropExchange *pPX, LPCTSTR pcszPropName) | CXTPCalendarThemeIntValue | virtual
DoPX_Value(CXTPPropExchange *pPX, LPCTSTR pcszPropName, int &rXValue, BOOL bStandard) | CXTPCalendarThemeIntValue | protected
GetStandardValue() const | CXTPCalendarThemeCustomizableXValueT< int, int > | inlinevirtual
GetValue() const | CXTPCalendarThemeCustomizableXValueT< int, int > | inlinevirtual
GetValueX() const | CXTPCalendarThemeCustomizableXValueT< int, int > | inlinevirtual
IsCustomValue() const | CXTPCalendarThemeCustomizableXValueT< int, int > | inlinevirtual
IsDefaultValue() const | CXTPCalendarThemeCustomizableXValueT< int, int > | inlinevirtual
IsStandardValue() const | CXTPCalendarThemeCustomizableXValueT< int, int > | inlinevirtual
m_bAutoDestroy_Custom | CXTPCalendarThemeCustomizableXValueT< int, int > | protected
m_bAutoDestroy_Standard | CXTPCalendarThemeCustomizableXValueT< int, int > | protected
m_bIsCustomSet | CXTPCalendarThemeCustomizableXValueT< int, int > | protected
m_bIsStandardSet | CXTPCalendarThemeCustomizableXValueT< int, int > | protected
m_ValueCustom | CXTPCalendarThemeCustomizableXValueT< int, int > | protected
m_ValueStandard | CXTPCalendarThemeCustomizableXValueT< int, int > | protected
operator int() const | CXTPCalendarThemeCustomizableXValueT< int, int > | inline
operator=(int nValue) | CXTPCalendarThemeIntValue |
Serialize(CArchive &ar) | CXTPCalendarThemeCustomizableXValueT< int, int > | inlinevirtual
SetCustomValue(int refValue, BOOL bAutoDestroy) | CXTPCalendarThemeCustomizableXValueT< int, int > | inlinevirtual
SetCustomValue(int refValue) | CXTPCalendarThemeCustomizableXValueT< int, int > | inlinevirtual
SetDefaultValue() | CXTPCalendarThemeCustomizableXValueT< int, int > | inlinevirtual
SetStandardValue(int refValue, BOOL bAutoDestroy) | CXTPCalendarThemeCustomizableXValueT< int, int > | inlinevirtual
SetStandardValue(int refValue) | CXTPCalendarThemeCustomizableXValueT< int, int > | inlinevirtual
~CXTPCalendarThemeCustomizableXValueT() | CXTPCalendarThemeCustomizableXValueT< int, int > | inlinevirtual


Toolkit Pro: Member List

CXTPCalendarUIntArray Member List

This is the complete list of members for CXTPCalendarUIntArray, including all inherited members.

Add(UINT newElement) | CXTPArrayT< UINT, UINT > | virtual
AddIfNeed(UINT newElement) | CXTPArrayT< UINT, UINT > | virtual
Append(const CXTPArrayT &src) | CXTPArrayT< UINT, UINT > | virtual
Copy(const CXTPArrayT &src) | CXTPArrayT< UINT, UINT > | virtual
CXTPArrayT() | CXTPArrayT< UINT, UINT > |
CXTPCmdTarget() | CXTPCmdTarget |
DoPropExchange(CXTPPropExchange *pPX, LPCTSTR pcszSection, LPCTSTR pcszElement) | CXTPCalendarUIntArray | virtual
ElementAt(int nIndex) | CXTPArrayT< UINT, UINT > | virtual
Find(UINT uID) const | CXTPCalendarUIntArray |
FindElement(UINT nElement) const | CXTPArrayT< UINT, UINT > | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAt(int nIndex) const | CXTPArrayT< UINT, UINT > | virtual
GetData() const | CXTPArrayT< UINT, UINT > | virtual
GetData() | CXTPArrayT< UINT, UINT > | virtual
GetSize() const | CXTPArrayT< UINT, UINT > | virtual
InsertAt(int nIndex, UINT newElement, int nCount=1) | CXTPArrayT< UINT, UINT > | virtual
InsertAt(int nStartIndex, CXTPArrayT *pNewArray) | CXTPArrayT< UINT, UINT > | virtual
LoadFromString(LPCTSTR pcszData) | CXTPCalendarUIntArray | virtual
m_arElements | CXTPArrayT< UINT, UINT > | protected
operator[](int nIndex) const | CXTPArrayT< UINT, UINT > |
operator[](int nIndex) | CXTPArrayT< UINT, UINT > |
RemoveAll() | CXTPArrayT< UINT, UINT > | virtual
RemoveAt(int nIndex, int nCount=1) | CXTPArrayT< UINT, UINT > | virtual
RemoveElement(UINT nElement) | CXTPArrayT< UINT, UINT > | virtual
RemoveID(UINT uID) | CXTPCalendarUIntArray | virtual
SaveToString() const | CXTPCalendarUIntArray | virtual
SetAt(int nIndex, UINT newElement) | CXTPArrayT< UINT, UINT > | virtual
SetAtGrow(int nIndex, UINT newElement) | CXTPArrayT< UINT, UINT > | virtual
SetSize(int nNewSize, int nGrowBy=-1) | CXTPArrayT< UINT, UINT > | virtual
~CXTPArrayT() | CXTPArrayT< UINT, UINT > | virtual


Toolkit Pro: Member List

CXTPDockingPaneCaptionButton Member List

This is the complete list of members for CXTPDockingPaneCaptionButton, including all inherited members.

CheckForMouseOver(CPoint pt) | CXTPDockingPaneCaptionButton |
Click(CWnd *pWnd, CPoint pt, BOOL bClient=TRUE) | CXTPDockingPaneCaptionButton |
CXTPDockingPaneCaptionButton(int nID, CXTPDockingPaneBase *pPane) | CXTPDockingPaneCaptionButton |
DrawCloseButton(CDC *pDC, CRect rc, COLORREF clr=COLORREF_NULL) | CXTPDockingPaneCaptionButton | static
DrawMaximizeRestoreButton(CDC *pDC, CPoint pt, BOOL bMaximize, COLORREF clr=COLORREF_NULL) | CXTPDockingPaneCaptionButton | static
DrawMaximizeRestoreButton(CDC *pDC, CRect rc, BOOL bMaximize, COLORREF clr=COLORREF_NULL) | CXTPDockingPaneCaptionButton | static
DrawMenuButton(CDC *pDC, CRect rc, COLORREF clr=COLORREF_NULL) | CXTPDockingPaneCaptionButton | static
DrawPinButton(CDC *pDC, CPoint pt, BOOL bPinned, COLORREF clr=COLORREF_NULL) | CXTPDockingPaneCaptionButton | static
DrawPinButton(CDC *pDC, CRect rc, BOOL bPinned, COLORREF clr=COLORREF_NULL) | CXTPDockingPaneCaptionButton | static
GetID() const | CXTPDockingPaneCaptionButton |
GetPane() const | CXTPDockingPaneCaptionButton |
GetRect() const | CXTPDockingPaneCaptionButton |
GetState() const | CXTPDockingPaneCaptionButton |
InvalidateRect() | CXTPDockingPaneCaptionButton |
IsEnabled() const | CXTPDockingPaneCaptionButton |
IsPressed() const | CXTPDockingPaneCaptionButton |
IsSelected() const | CXTPDockingPaneCaptionButton |
IsVisible() const | CXTPDockingPaneCaptionButton |
m_bPressed | CXTPDockingPaneCaptionButton | protected
m_bSelected | CXTPDockingPaneCaptionButton | protected
m_dwState | CXTPDockingPaneCaptionButton | protected
m_nID | CXTPDockingPaneCaptionButton | protected
m_pPane | CXTPDockingPaneCaptionButton | protected
m_rcButton | CXTPDockingPaneCaptionButton | protected
PtInRect(POINT pt) const | CXTPDockingPaneCaptionButton |
SetRect(CRect rc) | CXTPDockingPaneCaptionButton |
SetState(DWORD dwState) | CXTPDockingPaneCaptionButton |


Toolkit Pro: XTPEditThemeNativeWindows10.h Source File

  • Source
  • Controls
  • Edit
  • Themes
XTPEditThemeNativeWindows10.h
Go to the documentation of this file.
1
23#if !defined(__XTPEDITTHEMENATIVEWINDOWS10_H__)
24# define __XTPEDITTHEMENATIVEWINDOWS10_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
37class _XTP_EXT_CLASS CXTPEditThemeNativeWindows10 : public CXTPEditThemeOffice2013
38{
39public:
44 CXTPEditThemeNativeWindows10();
45
50 virtual ~CXTPEditThemeNativeWindows10();
51};
52
53# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
55#endif // __XTPEDITTHEMENATIVEWINDOWS10_H__
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPEditThemeNativeWindows10
CXTPEditThemeNativeWindows10 is a class used to perform theme drawing tasks.
Definition XTPEditThemeNativeWindows10.h:38
CXTPEditThemeNativeWindows10::CXTPEditThemeNativeWindows10
CXTPEditThemeNativeWindows10()
Constructs a CXTPEditThemeNativeWindows10 object.
CXTPEditThemeNativeWindows10::~CXTPEditThemeNativeWindows10
virtual ~CXTPEditThemeNativeWindows10()
Destructor, handles cleanup and deallocation.
CXTPEditThemeOffice2013
CXTPEditThemeOffice2013 is a class used to perform theme drawing tasks.
Definition XTPEditThemeOffice2013.h:38


Toolkit Pro: Member List

CXTPSimpleCriticalSection Member List

This is the complete list of members for CXTPSimpleCriticalSection, including all inherited members.

CXTPSimpleCriticalSection() | CXTPSimpleCriticalSection | inline
Enter() | CXTPSimpleCriticalSection |
Leave() | CXTPSimpleCriticalSection |
~CXTPSimpleCriticalSection() | CXTPSimpleCriticalSection |


Toolkit Pro: Member List

CXTPCommandBarsOffice2000Theme Member List

This is the complete list of members for CXTPCommandBarsOffice2000Theme, including all inherited members.

AdjustExcludeRect(CRect &rc, CXTPControl *pControl, BOOL bVertical) | CXTPCommandBarsOffice2000Theme | virtual
Animate(CDC *pDestDC, CDC *pSrcDC, CRect rc, XTPAnimationType animationType) | CXTPPaintManager | virtual
AnimateExpanding(CXTPCommandBar *pCommandBar, CDC *pDestDC, CDC *pSrcDC, BOOL bExpandDown) | CXTPPaintManager | virtual
BaseTheme() | CXTPCommandBarsOffice2000Theme | inlineprotectedvirtual
CreateTheme(XTPPaintTheme paintTheme) | CXTPPaintManager | static
CXTPCmdTarget() | CXTPCmdTarget |
CXTPCommandBarsOffice2000Theme() | CXTPCommandBarsOffice2000Theme |
CXTPObservable() | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | protected
CXTPPaintManager() | CXTPPaintManager | protected
Draw3dRect(CDC *pDC, LPCRECT rc, int nTopLeft, int nBottomRight) | CXTPPaintManager |
Draw3dRect(CDC *pDC, LPCRECT rc, int frameThickness, COLORREF clrPen, COLORREF clrBrush) | CXTPPaintManager |
DrawCheckMark(CDC *pDC, CRect rcCheck, COLORREF clr=0) | CXTPPaintManager | inline
DrawComboExpandMark(CDC *pDC, CRect rc, COLORREF clr) | CXTPPaintManager | virtual
DrawCommandBarGripper(CDC *pDC, CXTPCommandBar *pBar, BOOL bDraw=TRUE) | CXTPCommandBarsOffice2000Theme | virtual
DrawCommandBarGroupSeparator(CDC *pDC, CXTPCommandBar *pBar, CXTPControl *pLeftControl, CXTPControl *pRightControl, BOOL bDraw=TRUE) | CXTPPaintManager | virtual
DrawCommandBarSeparator(CDC *pDC, CXTPCommandBar *pBar, CXTPControl *pControl, BOOL bDraw=TRUE) | CXTPCommandBarsOffice2000Theme | virtual
DrawControl(CDC *pDC, CXTPControl *pButton, BOOL bDraw=TRUE) | CXTPPaintManager |
DrawControlCheckBoxMark(CDC *pDC, CRect rc, BOOL bDraw, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled) | CXTPPaintManager | virtual
DrawControlCheckBoxMark(CDC *pDC, CXTPControl *pButton, CRect rc, BOOL bDraw) | CXTPPaintManager | virtual
DrawControlComboBox(CDC *pDC, CXTPControlComboBox *pComboBox, BOOL bDraw) | CXTPCommandBarsOffice2000Theme | protectedvirtual
DrawControlComboBoxButton(CDC *pDC, CRect rcBtn, BOOL bEnabled, BOOL bSelected, BOOL bDropped) | CXTPCommandBarsOffice2000Theme | protectedvirtual
DrawControlEdit(CDC *pDC, CXTPControlEdit *pEdit, BOOL bDraw) | CXTPCommandBarsOffice2000Theme | protectedvirtual
DrawControlEditFrame(CDC *pDC, CRect rc, BOOL bEnabled, BOOL bSelected) | CXTPCommandBarsOffice2000Theme | protectedvirtual
DrawControlEditSpin(CDC *pDC, CXTPControlEdit *pControlEdit) | CXTPCommandBarsOffice2000Theme | protectedvirtual
DrawControlEntry(CDC *pDC, CXTPControl *pButton) | CXTPPaintManager | virtual
DrawControlMDIButton(CDC *pDC, CXTPControlButton *pButton) | CXTPPaintManager | virtual
DrawControlPopupParent(CDC *pDC, CXTPControl *pButton, BOOL bDraw) | CXTPCommandBarsOffice2000Theme | protectedvirtual
DrawControlRadioButtonMark(CDC *pDC, CRect rc, BOOL bDraw, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled) | CXTPPaintManager | virtual
DrawControlText(CDC *pDC, CXTPControl *pControl, CRect rcText, BOOL bDraw, BOOL bVert, BOOL bCentered, BOOL bTriangled) | CXTPPaintManager |
DrawControlToolBarParent(CDC *pDC, CXTPControl *pButton, BOOL bDraw) | CXTPPaintManager | virtual
DrawDialogBarGripper(CDC *pDC, CXTPDialogBar *pBar, BOOL bDraw) | CXTPCommandBarsOffice2000Theme | protectedvirtual
DrawDropDownGlyph(CDC *pDC, CXTPControl *pControl, CPoint pt, BOOL bSelected, BOOL bPopuped, BOOL bEnabled, BOOL bVert) | CXTPPaintManager | virtual
DrawExpandGlyph(CDC *pDC, CXTPControl *pButton, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clr) | CXTPPaintManager | virtual
DrawExpandGlyph(CDC *pDC, CXTPControl *pButton, COLORREF clr, BOOL bVertical) | CXTPPaintManager | virtual
DrawGalleryItemBack(CDC *pDC, CRect rcItem, BOOL bEnabled, BOOL bSelected, BOOL bPressed, BOOL bChecked, XTPBarType barType) | CXTPPaintManager | virtual
DrawHiddenGlyph(CDC *pDC, CXTPControl *pButton, COLORREF clr, BOOL bVertical) | CXTPPaintManager | virtual
DrawImage(CDC *pDC, CPoint pt, CSize sz, CXTPImageManagerIcon *pImage, BOOL bSelected, BOOL bPressed, BOOL bEnabled=TRUE, BOOL bChecked=FALSE, BOOL bPopuped=FALSE, BOOL bToolBarImage=TRUE) | CXTPCommandBarsOffice2000Theme | protectedvirtual
DrawListBoxControl(CDC *pDC, CXTPControl *pButton, CRect rc, BOOL bSelected, BOOL bDraw, CXTPCommandBars *pCommandBars=0) | CXTPCommandBarsOffice2000Theme | virtual
DrawPopupBarCheckMark(CDC *pDC, CRect rcCheck, BOOL bEnabled, COLORREF clr) | CXTPPaintManager | virtual
DrawPopupBarGripper(CDC *pDC, int xPos, int yPos, int cx, int cy, BOOL bExpanded=FALSE) | CXTPPaintManager | virtual
DrawPopupBarRadioMark(CDC *pDC, CRect rcCheck, BOOL bEnabled, COLORREF clr) | CXTPPaintManager | virtual
DrawPopupResizeGripper(CDC *pDC, CRect rcGripper, int nFlags) | CXTPCommandBarsOffice2000Theme | virtual
DrawRectangle(CDC *pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition) | CXTPCommandBarsOffice2000Theme | protectedvirtual
DrawRectangle(CDC *pDC, CXTPControl *pButton) | CXTPCommandBarsOffice2000Theme | protectedvirtual
DrawSpecialControl(CDC *pDC, XTPSpecialControl controlType, CXTPControl *pButton, CXTPCommandBar *pBar, BOOL bDraw, LPVOID lpParam) | CXTPCommandBarsOffice2000Theme | virtual
DrawSplitButtonFrame(CDC *pDC, CXTPControl *pButton, CRect rcButton) | CXTPCommandBarsOffice2000Theme | protectedvirtual
DrawTearOffGripper(CDC *pDC, CRect rcGripper, BOOL bSelected, BOOL bDraw) | CXTPCommandBarsOffice2000Theme | virtual
FillCommandBarEntry(CDC *pDC, CXTPCommandBar *pBar) | CXTPCommandBarsOffice2000Theme | virtual
FillDockBar(CDC *pDC, CXTPDockBar *pBar) | CXTPPaintManager | virtual
FillWorkspace(CDC *pDC, CRect rc, CRect rcExclude) | CXTPPaintManager | virtual
FontExists(LPCTSTR lpszFaceName) | CXTPPaintManager | static
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCommandBarBorders(CXTPCommandBar *pBar) | CXTPCommandBarsOffice2000Theme | virtual
GetCommandBarFont(CXTPCommandBar *pCommandBar) | CXTPPaintManager | virtual
GetControlBackColor(CXTPControl *pButton) | CXTPPaintManager | virtual
GetControlEditBackColor(CXTPControl *pControl) | CXTPPaintManager | virtual
GetControlFont(CXTPControl *pControl) | CXTPPaintManager | virtual
GetControlHeight() const | CXTPPaintManager |
GetControlTextColor(CXTPControl *pButton) | CXTPPaintManager | virtual
GetControlTextOrientation(CXTPControl *pControl) | CXTPPaintManager | virtual
GetCurrentSystemTheme() | CXTPPaintManager |
GetCurrentTheme() | CXTPPaintManager | inline
GetDefaultCommandBarSize(CXTPCommandBar *pBar) | CXTPPaintManager | virtual
GetFramePaintManager() | CXTPPaintManager | virtual
GetGalleryPaintManager() const | CXTPPaintManager | virtual
GetGlobalPaintManager() | CXTPPaintManager | static
GetIconFont() | CXTPPaintManager |
GetIconsInfo() | CXTPPaintManager |
GetInstanceAddRef() | CXTPPaintManager | static
GetMessageBarPaintManager() | CXTPPaintManager | virtual
GetPopupBarGripperWidth(CXTPCommandBar *pBar) | CXTPPaintManager | virtual
GetProgressPaintManager() const | CXTPPaintManager | virtual
GetRectangleTextColor(BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition) | CXTPCommandBarsOffice2000Theme | virtual
GetRegularBoldFont() | CXTPPaintManager |
GetRegularFont() | CXTPPaintManager |
GetRibbonPaintManager() | CXTPPaintManager | virtual
GetScrollBarPaintManager() const | CXTPPaintManager | virtual
GetShadowManager() const | CXTPPaintManager |
GetShadowOptions() const | CXTPPaintManager |
GetSliderPaintManager() const | CXTPPaintManager | virtual
GetSmCaptionFont() | CXTPPaintManager |
GetSplitButtonCommandRect(CXTPControl *pButton) | CXTPPaintManager | virtual
GetStatusBarPaintManager() | CXTPPaintManager | virtual
GetXtremeColor(UINT nIndex) | CXTPPaintManager |
GradientFill(CDC *pDC, LPRECT lpRect, COLORREF crFrom, COLORREF crTo, BOOL bHorz, LPCRECT lpRectClip=NULL) | CXTPPaintManager |
HorizontalLine(CDC *pDC, int x0, int y0, int x1, COLORREF clrPen) | CXTPPaintManager |
IsUseSystemAccentColorEnabled() const | CXTPPaintManager |
Line(CDC *pDC, CPoint p0, CPoint p1) | CXTPPaintManager |
Line(CDC *pDC, int x0, int y0, int x1, int y1, const int nPen) | CXTPPaintManager |
Line(CDC *pDC, int x0, int y0, int x1, int y1, COLORREF clrPen) | CXTPPaintManager |
m_arrColor | CXTPPaintManager | protected
m_bAutoResizeIcons | CXTPPaintManager |
m_bClearTypeTextQuality | CXTPPaintManager |
m_bEmbossedDisabledText | CXTPPaintManager | protected
m_bEnableAnimation | CXTPPaintManager |
m_bFlatMenuBar | CXTPPaintManager |
m_bFlatToolBar | CXTPPaintManager |
m_bOffice2007Padding | CXTPPaintManager |
m_bOffsetPopupLabelText | CXTPPaintManager |
m_bSelectImageInPopupBar | CXTPPaintManager |
m_bShowKeyboardCues | CXTPPaintManager | protected
m_bShowShadow | CXTPPaintManager |
m_bThemedCheckBox | CXTPPaintManager |
m_bThemedStatusBar | CXTPPaintManager |
m_bThickCheckMark | CXTPPaintManager |
m_bUseOfficeFont | CXTPPaintManager |
m_bUseStandardFont | CXTPPaintManager | protected
m_bWrapCaptionBelowText | CXTPPaintManager |
m_clrDisabledIcon | CXTPPaintManager |
m_clrFloatingGripper | CXTPPaintManager |
m_clrFloatingGripperText | CXTPPaintManager |
m_clrMessageBarText | CXTPPaintManager |
m_fontIcon | CXTPPaintManager |
m_fontIconBold | CXTPPaintManager |
m_fontSmCaption | CXTPPaintManager |
m_fontToolTip | CXTPPaintManager |
m_iconsInfo | CXTPPaintManager | protected
m_nAnimationSteps | CXTPPaintManager | protected
m_nAnimationTime | CXTPPaintManager | protected
m_nEditHeight | CXTPPaintManager | protected
m_nFontHeight | CXTPPaintManager | protected
m_nPopupBarText | CXTPCommandBarsOffice2000Theme | protected
m_nPopupBarTextPadding | CXTPPaintManager |
m_nSplitButtonDropDownHeight | CXTPPaintManager |
m_nSplitButtonDropDownWidth | CXTPPaintManager |
m_nSplitButtonPopupWidth | CXTPPaintManager |
m_nStatusBarMinHeight | CXTPPaintManager |
m_nTextHeight | CXTPPaintManager |
m_pfnSetLayeredWindowAttributes | CXTPPaintManager |
m_pFramePaintManager | CXTPPaintManager |
m_pGalleryPaintManager | CXTPPaintManager |
m_pProgressPaintManager | CXTPPaintManager |
m_pRibbonPaintManager | CXTPPaintManager |
m_pScrollBarPaintManager | CXTPPaintManager |
m_pShadowManager | CXTPPaintManager | protected
m_pSliderPaintManager | CXTPPaintManager |
m_pStatusBarPaintManager | CXTPPaintManager |
m_rcMessageBarMargin | CXTPPaintManager |
m_rcStatusBarBorder | CXTPPaintManager |
m_strOfficeFont | CXTPPaintManager |
m_systemTheme | CXTPPaintManager | protected
m_themeButton | CXTPPaintManager | protected
m_themeCurrent | CXTPPaintManager | protected
m_themeStatusBar | CXTPPaintManager | protected
m_xtpFontRegular | CXTPPaintManager | protected
m_xtpFontRegularBold | CXTPPaintManager | protected
m_xtpFontVert | CXTPPaintManager | protected
m_xtpFontVertBold | CXTPPaintManager | protected
Notify(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *)) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
Notify(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1), A1 arg1) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
Notify(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
Notify(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamic(void(T::*method)(O *)) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1), A1 arg1) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *)) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1), A1 arg1) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyReversed(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *)) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyReversed(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1), A1 arg1) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyReversed(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyReversed(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
Pixel(CDC *pDC, int xPos, int yPos, int nPen) | CXTPPaintManager |
Rectangle(CDC *pDC, LPCRECT rc, int nPen, const int nBrush) | CXTPPaintManager |
Rectangle(CDC *pDC, LPCRECT rc, COLORREF clrPen, COLORREF clrBrush) | CXTPPaintManager |
RefreshMetrics() | CXTPCommandBarsOffice2000Theme | virtual
ReleaseInstance() | CXTPPaintManager | static
RequiresResourceImages() | CXTPPaintManager | virtual
RoundRect(CDC *pDC, LPCRECT rc, COLORREF clrPen, COLORREF clrBrush) | CXTPPaintManager |
SetAnimationDelay(int nAnimationSteps, int nAnimationTime) | CXTPPaintManager |
SetColors(int cElements, CONST INT *lpaElements, CONST COLORREF *lpaRgbValues) | CXTPPaintManager |
SetCommandBarRegion(CXTPCommandBar *pCommandBar) | CXTPPaintManager | virtual
SetCommandBarsFontIndirect(LOGFONT *pLogFont, BOOL bUseStandardFont=FALSE) | CXTPPaintManager |
SetCustomTheme(CXTPPaintManager *pTheme) | CXTPPaintManager | static
SetGlobalPaintManager(CXTPPaintManager *pPaintManager) | CXTPPaintManager | static
SetImageHandle(HMODULE hResource, LPCTSTR lpszIniFileName) | CXTPPaintManager | virtual
SetLunaTheme(XTPCurrentSystemTheme systemTheme) | CXTPPaintManager |
SetTheme(XTPPaintTheme paintTheme) | CXTPPaintManager | static
StripMnemonics(CString &strClear) | CXTPPaintManager | static
Subscribe(IXTPPaintManagerEvents *pObserver, CXTPSubscriptionList< CXTPPaintManager, IXTPPaintManagerEvents > *pSubcriptionList=NULL) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > |
Triangle(CDC *pDC, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clr) | CXTPPaintManager | static
Unsubscribe(IXTPPaintManagerEvents *pObserver) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > |
UpdateColors() | CXTPPaintManager | virtual
UpdateFonts() | CXTPPaintManager | virtual
UpdateRTLCaption(CString &strCaption) | CXTPPaintManager | virtual
UseOfficeFont(bool bUseOfficeFont) | CXTPPaintManager |
VerticalLine(CDC *pDC, int x0, int y0, int y1, COLORREF clrPen) | CXTPPaintManager |
~CXTPObservable() | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | protected
~CXTPPaintManager() | CXTPPaintManager | protectedvirtual


Toolkit Pro: Member List

CXTPMarkupStaticExtensionColorProperty Member List

This is the complete list of members for CXTPMarkupStaticExtensionColorProperty, including all inherited members.

CXTPMarkupStaticExtension(LPCWSTR lpzName, BOOL bProperty) | CXTPMarkupStaticExtension | protected
CXTPMarkupStaticExtension(LPCWSTR lpzName) | CXTPMarkupStaticExtension |
CXTPMarkupStaticExtensionColorProperty(LPCWSTR lpzName, COLORREF crValue=RGB(0, 0, 0)) | CXTPMarkupStaticExtensionColorProperty |
CXTPMarkupStaticExtensionColorProperty(LPCWSTR lpzName, COLORREF crValue, BYTE bAlpha) | CXTPMarkupStaticExtensionColorProperty |
CXTPMarkupStaticExtensionProperty(LPCWSTR lpzName, CXTPMarkupObject *pObject=NULL) | CXTPMarkupStaticExtensionProperty |
Extend(CXTPMarkupStaticExtension *pExtension, BOOL bReplace=FALSE) | CXTPMarkupStaticExtension |
FindExtension(LPCWSTR lpzName) const | CXTPMarkupStaticExtension |
GetName() const | CXTPMarkupStaticExtension |
GetRawValue() const | CXTPMarkupStaticExtensionColorProperty |
GetValue() | CXTPMarkupStaticExtensionProperty |
IsProperty() const | CXTPMarkupStaticExtension |
OnPrepareValue() | CXTPMarkupStaticExtension | inlineprotectedvirtual
Parse(LPCWSTR lpzValue, LPCWSTR &lpzSubValue) | CXTPMarkupStaticExtension | static
ProvideValue() | CXTPMarkupStaticExtensionProperty | virtual
ProvideValue(LPCWSTR lpzValue) | CXTPMarkupStaticExtensionProperty | virtual
SetValue(COLORREF crValue) | CXTPMarkupStaticExtensionColorProperty |
SetValue(COLORREF crValue, BYTE bAlpha) | CXTPMarkupStaticExtensionColorProperty |
CXTPMarkupStaticExtensionProperty::SetValue(CXTPMarkupObject *pObject) | CXTPMarkupStaticExtensionProperty |
~CXTPMarkupStaticExtension() | CXTPMarkupStaticExtension | virtual
~CXTPMarkupStaticExtensionProperty() | CXTPMarkupStaticExtensionProperty |


Toolkit Pro: XTPSortClass.h Source File

  • Source
  • Controls
  • List
XTPSortClass.h
Go to the documentation of this file.
1
23#if !defined(__XTPSORTCLASS_H__)
24# define __XTPSORTCLASS_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
44enum XTPSortType
45{
46 xtpSortInt = 1,
47 xtpSortString,
48 xtpSortDateTime,
49 xtpSortDecimal
50};
51
74class _XTP_EXT_CLASS CXTPSortClass
75{
76public:
85 CXTPSortClass(CListCtrl* pListCtrl, const int nCol, PFNLVCOMPARE pfnCompare = NULL);
86
91 virtual ~CXTPSortClass();
92
107 virtual void Sort(bool bAsc, int iType);
108
124 static int CALLBACK Compare(LPARAM lParam1, LPARAM lParam2, LPARAM lParamSort);
125
135 static int AFX_CDECL RemoveNonNumeric(CString& strSource);
136
154 static int AFX_CDECL SortInt(LPCTSTR lpszItem1, LPCTSTR lpszItem2, const short sOrder);
155
173 static int AFX_CDECL SortString(LPCTSTR lpszItem1, LPCTSTR lpszItem2, const short sOrder);
174
192 static int AFX_CDECL SortDateTime(LPCTSTR lpszItem1, LPCTSTR lpszItem2, const short sOrder);
193
211 static int AFX_CDECL SortDecimal(LPCTSTR lpszItem1, LPCTSTR lpszItem2, const short sOrder);
212
219 struct ITEMDATA
220 {
221 CString strItem;
222 DWORD_PTR dwData;
223 };
224
225protected:
226 CListCtrl* m_pListCtrl;
227 PFNLVCOMPARE m_pfnCompare;
231};
232
233# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
235#endif // #if !defined(__XTPSORTCLASS_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPSortType
XTPSortType
Enumeration used to determine sort type.
Definition XTPSortClass.h:45
xtpSortString
@ xtpSortString
Sort type string.
Definition XTPSortClass.h:47
xtpSortDateTime
@ xtpSortDateTime
Sort type date/time.
Definition XTPSortClass.h:48
xtpSortInt
@ xtpSortInt
Sort type integer.
Definition XTPSortClass.h:46
xtpSortDecimal
@ xtpSortDecimal
Sort type decimal.
Definition XTPSortClass.h:49
CXTPSortClass
CXTPSortClass is a standalone class.
Definition XTPSortClass.h:75
CXTPSortClass::m_pListCtrl
CListCtrl * m_pListCtrl
Pointer to the CListCtrl object to perform the sort on.
Definition XTPSortClass.h:226
CXTPSortClass::m_pfnCompare
PFNLVCOMPARE m_pfnCompare
Address of the application-defined comparison function.
Definition XTPSortClass.h:227
CXTPSortClass::SortDateTime
static int AFX_CDECL SortDateTime(LPCTSTR lpszItem1, LPCTSTR lpszItem2, const short sOrder)
This member function is called by the application defined comparison function to perform date/time so...
CXTPSortClass::SortInt
static int AFX_CDECL SortInt(LPCTSTR lpszItem1, LPCTSTR lpszItem2, const short sOrder)
This member function is called by the application defined comparison function to perform integer sort...
CXTPSortClass::Sort
virtual void Sort(bool bAsc, int iType)
This member function is called to perform the actual sort procedure.
CXTPSortClass::Compare
static int CALLBACK Compare(LPARAM lParam1, LPARAM lParam2, LPARAM lParamSort)
This callback member function is called to compare two data items during sorting operations.
CXTPSortClass::RemoveNonNumeric
static int AFX_CDECL RemoveNonNumeric(CString &strSource)
This member function is called by the sort class to remove non-numeric characters from the specified ...
CXTPSortClass::SortDecimal
static int AFX_CDECL SortDecimal(LPCTSTR lpszItem1, LPCTSTR lpszItem2, const short sOrder)
This member function is called by the application defined comparison function to perform decimal sort...
CXTPSortClass::CXTPSortClass
CXTPSortClass(CListCtrl *pListCtrl, const int nCol, PFNLVCOMPARE pfnCompare=NULL)
Constructs a CXTPSortClass object.
CXTPSortClass::~CXTPSortClass
virtual ~CXTPSortClass()
Destroys a CXTPSortClass object, handles cleanup and deallocation.
CXTPSortClass::SortString
static int AFX_CDECL SortString(LPCTSTR lpszItem1, LPCTSTR lpszItem2, const short sOrder)
This member function is called by the application defined comparison function to perform string sorti...
CXTPSortClass::ITEMDATA
This structure is used by the CXTPSortClass for storing a temporary item data pointer that contains e...
Definition XTPSortClass.h:220
CXTPSortClass::ITEMDATA::strItem
CString strItem
NULL-terminated string that represents the list item's text.
Definition XTPSortClass.h:221
CXTPSortClass::ITEMDATA::dwData
DWORD_PTR dwData
List item's application defined value (if any).
Definition XTPSortClass.h:222


Toolkit Pro: Member List

CXTPCalendarEventCategoryComboBox Member List

This is the complete list of members for CXTPCalendarEventCategoryComboBox, including all inherited members.

CalcColorRect(CRect rItem) | CXTPCalendarComboBoxBase | protectedvirtual
CXTPCalendarComboBoxBase() | CXTPCalendarComboBoxBase |
CXTPCalendarEventCategoryComboBox() | CXTPCalendarEventCategoryComboBox |
DrawCollapsed(CDC *pDC, CRect rcItem, BOOL bFocused, BOOL bDisabled) | CXTPCalendarEventCategoryComboBox | protectedvirtual
DrawExpanded(CDC *pDC, CRect rcItem, BOOL bSelected, UINT uItemID) | CXTPCalendarEventCategoryComboBox | protectedvirtual
DrawItem(LPDRAWITEMSTRUCT lpDIS) | CXTPCalendarEventCategoryComboBox | protectedvirtual
GetCategoryArray() | CXTPCalendarEventCategoryComboBox |
GetChecked(CXTPCalendarEventCategoryIDs *pChecked, BOOL *pbChanged) | CXTPCalendarEventCategoryComboBox | virtual
GetLBCurSel() const | CXTPCalendarEventCategoryComboBox | protectedvirtual
Init(CXTPCalendarEvent *pEvent, XTPCalendarTheme nTheme) | CXTPCalendarEventCategoryComboBox | virtual
m_arChecked | CXTPCalendarEventCategoryComboBox | protected
m_pCategories | CXTPCalendarEventCategoryComboBox | protected
MeasureItem(LPMEASUREITEMSTRUCT lpMIS) | CXTPCalendarComboBoxBase | protectedvirtual
RedrawLB(BOOL bUpdateNow=FALSE) | CXTPCalendarEventCategoryComboBox | protectedvirtual
~CXTPCalendarComboBoxBase() | CXTPCalendarComboBoxBase | virtual
~CXTPCalendarEventCategoryComboBox() | CXTPCalendarEventCategoryComboBox | virtual


Toolkit Pro: Member List

CXTPChartDrawingObjectFactory Member List

This is the complete list of members for CXTPChartDrawingObjectFactory, including all inherited members.


Toolkit Pro: Member List

CXTPProgressCtrlThemeNativeWindows Member List

This is the complete list of members for CXTPProgressCtrlThemeNativeWindows, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPProgressCtrlPaintManager() | CXTPProgressCtrlPaintManager |
CXTPProgressCtrlThemeNativeWindows() | CXTPProgressCtrlThemeNativeWindows |
DeflateRect(XTPPROGRESSDRAWSTRUCT &ds) | CXTPProgressCtrlThemeNativeWindows | protectedvirtual
Draw(XTPPROGRESSDRAWSTRUCT &ds) | CXTPProgressCtrlPaintManager | virtual
DrawNcBorders(CDC *pDC, CRect rc) | CXTPProgressCtrlPaintManager | virtual
DrawText(XTPPROGRESSDRAWSTRUCT &ds) | CXTPProgressCtrlPaintManager | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetBackColor() | CXTPProgressCtrlPaintManager |
GetBarColor() | CXTPProgressCtrlPaintManager |
GetBorderColor() | CXTPProgressCtrlPaintManager |
GetTextColor() | CXTPProgressCtrlPaintManager |
m_bUseWinTheme | CXTPProgressCtrlPaintManager | protected
m_clrBack | CXTPProgressCtrlPaintManager | protected
m_clrBar | CXTPProgressCtrlPaintManager | protected
m_clrBarText | CXTPProgressCtrlPaintManager | protected
m_clrBorder | CXTPProgressCtrlPaintManager | protected
m_clrText | CXTPProgressCtrlPaintManager | protected
m_nTheme | CXTPProgressCtrlPaintManager | protected
m_winTheme | CXTPProgressCtrlPaintManager | protected
RefreshMetrics() | CXTPProgressCtrlPaintManager | virtual
SetBackColor(COLORREF clrNew) | CXTPProgressCtrlPaintManager |
SetBarColor(COLORREF clrNew) | CXTPProgressCtrlPaintManager |
SetBorderColor(COLORREF clrNew) | CXTPProgressCtrlPaintManager |
SetTextColor(COLORREF clrNew) | CXTPProgressCtrlPaintManager |
UseWinThemes(BOOL bUseWinThemes=TRUE) | CXTPProgressCtrlPaintManager |
UsingWinThemes(BOOL bCheckReady=FALSE) | CXTPProgressCtrlPaintManager |
~CXTPProgressCtrlPaintManager() | CXTPProgressCtrlPaintManager | virtual


Toolkit Pro: XTPCalendarCaptionBarControl.h Source File

  • Source
  • Calendar
  • CaptionBar
XTPCalendarCaptionBarControl.h
Go to the documentation of this file.
1
22#if !defined(__XTPCalendarCaptionBarControl_H__)
23# define __XTPCalendarCaptionBarControl_H__
24
25# if _MSC_VER >= 1000
26# pragma once
27# endif // _MSC_VER >= 1000
28
29# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
30
31class CXTPNotifySink;
32class CXTPWinThemeWrapper;
33class CXTPCalendarCaptionBarTheme;
34
36// Office2007
37//
38// Switch View Bar:
39// SwitchViewButtonPart
40// RadioButtonPart
41// * LabelPart
42//
43// Scroll Date Bar:
44// ScrollDateButtonPart
45// DateLabelPart
46//
47// ==========================================
48// ButtonViewDay : SwitchViewButtonPart
49// ButtonViewWeek : SwitchViewButtonPart
50// ButtonViewMonth : SwitchViewButtonPart
51//
52// ShowWorkWeek : RadioButtonPart
53// ShowFullWeek : RadioButtonPart
54// ---------------------------------
55// ScrollPrevDate : ScrollDateButtonPart
56// ScrollNextDate : ScrollDateButtonPart
57// DateLabel : DateLabelPart
58//
59// ---------------------------------
60// SwitchViewBarBkColor
61// ScrollDateBarBkColor
62
67enum XTPEnumCalendarCaptionBarThemeObject
68{
69 xtpCalendarCaptionBar_Unknown = 0,
70 xtpCalendarCaptionBar_ButtonViewDay = 0x00000001,
71 xtpCalendarCaptionBar_ButtonViewWeek = 0x00000002,
73 xtpCalendarCaptionBar_ButtonViewMonth = 0x00000004,
75 xtpCalendarCaptionBar_ShowWorkWeek = 0x00000010,
77 xtpCalendarCaptionBar_ShowFullWeek = 0x00000020,
79 xtpCalendarCaptionBar_ShowTimeline = 0x00000040,
81 xtpCalendarCaptionBar_MultiColumnsWeek = 0x00000080,
84 xtpCalendarCaptionBar_ScrollPrevDate = 0x00000100,
86 xtpCalendarCaptionBar_ScrollNextDate = 0x00000200,
88 xtpCalendarCaptionBar_DateLabel = 0x00000400,
89 xtpCalendarCaptionBar_ButtonExpand = 0x00000800
90};
91
105class _XTP_EXT_CLASS CXTPCalendarCaptionBarControl : public CWnd
106{
107 using CWnd::Create;
108
110 DECLARE_DYNAMIC(CXTPCalendarCaptionBarControl)
112public:
120 CXTPCalendarCaptionBarControl();
121
128 virtual ~CXTPCalendarCaptionBarControl();
129
142 virtual CRect CalcMinRect(BOOL bExactSize = FALSE);
143
155 virtual BOOL Create(DWORD dwStyle, const RECT& rect, CWnd* pParentWnd, UINT nID);
156
166 virtual void AdjustLayout(CDC* pDC = NULL, const CRect* prcWnd = NULL);
167
175 CXTPCalendarCaptionBarTheme* GetTheme() const;
176
183 void SetTheme(CXTPCalendarCaptionBarTheme* pTheme);
184
193 BOOL RegisterWindowClass(HINSTANCE hInstance = NULL);
194
202 CRect GetBorders() const;
203
214 virtual void SetBorders(int nLeft, int nTop, int nRight, int nBottom);
215
221 virtual void UpdateBorders();
222
231 void EnableTimeline(BOOL bEnable);
232
239 BOOL IsTimelineEnable();
240
249 void EnableMulticolumns(BOOL bEnable);
250
257 BOOL IsMulticolumnsEnable();
258
265 void UseOneLine(BOOL bSet);
266
274 BOOL IsUseOneLine(); // get state of m_bIsOneLine
275
299 void SetButtonText(int iButtonNumber, CString sButtonText);
300
301protected:
302 CXTPCalendarCaptionBarTheme* m_pTheme;
304 CRect m_Borders;
306 afx_msg void OnPaint();
307 afx_msg void OnNcPaint();
308 afx_msg void OnNcCalcSize(BOOL bCalcValidRects, NCCALCSIZE_PARAMS* lpncsp);
309
310 afx_msg BOOL OnEraseBkgnd(CDC* pDC);
311 afx_msg void OnSize(UINT nType, int cx, int cy);
312 afx_msg void OnLButtonDown(UINT nFlags, CPoint point);
313 afx_msg void OnLButtonUp(UINT nFlags, CPoint point);
314 afx_msg void OnMouseMove(UINT nFlags, CPoint point);
315 afx_msg void OnKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags);
316 afx_msg void OnKeyUp(UINT nChar, UINT nRepCnt, UINT nFlags);
317 afx_msg void OnTimer(UINT_PTR uTimerID);
318 afx_msg void OnDestroy();
319 // afx_msg void OnEnable(BOOL bEnable);
320 // afx_msg UINT OnGetDlgCode();
321 // afx_msg void OnSetFocus(CWnd* pOldWnd);
322 afx_msg void OnKillFocus(CWnd* pNewWnd);
323
324 DECLARE_MESSAGE_MAP()
325};
326
328
329AFX_INLINE CRect CXTPCalendarCaptionBarControl::GetBorders() const
330{
331 return m_Borders;
332}
333
334# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
335#endif // !defined(__XTPCalendarCaptionBarControl_H__)
XTPEnumCalendarCaptionBarThemeObject
XTPEnumCalendarCaptionBarThemeObject
Enumerates Calendar Caption Bar graphical objects .
Definition XTPCalendarCaptionBarControl.h:68
xtpCalendarCaptionBar_ShowWorkWeek
@ xtpCalendarCaptionBar_ShowWorkWeek
Defines SwitchViewBar ShowWorkWeek radio.
Definition XTPCalendarCaptionBarControl.h:75
xtpCalendarCaptionBar_ShowFullWeek
@ xtpCalendarCaptionBar_ShowFullWeek
Defines SwitchViewBar ShowFullWeek radio.
Definition XTPCalendarCaptionBarControl.h:77
xtpCalendarCaptionBar_ShowTimeline
@ xtpCalendarCaptionBar_ShowTimeline
Defines SwitchViewBar ShowTimeline radio.
Definition XTPCalendarCaptionBarControl.h:79
xtpCalendarCaptionBar_ButtonViewDay
@ xtpCalendarCaptionBar_ButtonViewDay
Defines SwitchViewBar DayViewButton.
Definition XTPCalendarCaptionBarControl.h:70
xtpCalendarCaptionBar_ButtonViewMonth
@ xtpCalendarCaptionBar_ButtonViewMonth
Defines SwitchViewBar MonthViewButton.
Definition XTPCalendarCaptionBarControl.h:73
xtpCalendarCaptionBar_DateLabel
@ xtpCalendarCaptionBar_DateLabel
Defines ScrollDateBar DateLabel.
Definition XTPCalendarCaptionBarControl.h:88
xtpCalendarCaptionBar_Unknown
@ xtpCalendarCaptionBar_Unknown
Defines Unknown (NULL) value.
Definition XTPCalendarCaptionBarControl.h:69
xtpCalendarCaptionBar_ScrollPrevDate
@ xtpCalendarCaptionBar_ScrollPrevDate
Defines ScrollDateBar PrevDateButton.
Definition XTPCalendarCaptionBarControl.h:84
xtpCalendarCaptionBar_ScrollNextDate
@ xtpCalendarCaptionBar_ScrollNextDate
Defines ScrollDateBar NextDateButton.
Definition XTPCalendarCaptionBarControl.h:86
xtpCalendarCaptionBar_ButtonExpand
@ xtpCalendarCaptionBar_ButtonExpand
Defines ScrollDateBar Expand Buton.
Definition XTPCalendarCaptionBarControl.h:89
xtpCalendarCaptionBar_MultiColumnsWeek
@ xtpCalendarCaptionBar_MultiColumnsWeek
Defines SwitchViewBar MultiColumnsWeek.
Definition XTPCalendarCaptionBarControl.h:81
xtpCalendarCaptionBar_ButtonViewWeek
@ xtpCalendarCaptionBar_ButtonViewWeek
Defines SwitchViewBar WeekViewButton.
Definition XTPCalendarCaptionBarControl.h:71
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCalendarCaptionBarControl
CXTPCalendarCaptionBarControl represents CalendarCaptionBar control and used as a part of CXTPCalenda...
Definition XTPCalendarCaptionBarControl.h:106
CXTPCalendarCaptionBarControl::EnableTimeline
void EnableTimeline(BOOL bEnable)
This member function is used to show or hide Timeline button.
CXTPCalendarCaptionBarControl::IsUseOneLine
BOOL IsUseOneLine()
This member function is used to get state of GetTheme()->m_bIsOneLine - flag to toggle CaptionMode 2-...
CXTPCalendarCaptionBarControl::SetBorders
virtual void SetBorders(int nLeft, int nTop, int nRight, int nBottom)
This member function is used to adjust the object's layout depending on the provided bounding rectang...
CXTPCalendarCaptionBarControl::RegisterWindowClass
BOOL RegisterWindowClass(HINSTANCE hInstance=NULL)
Register the window class if it has not already been registered.
CXTPCalendarCaptionBarControl::AdjustLayout
virtual void AdjustLayout(CDC *pDC=NULL, const CRect *prcWnd=NULL)
This member function is used to adjust the object's layout depending on the provided bounding rectang...
CXTPCalendarCaptionBarControl::CXTPCalendarCaptionBarControl
CXTPCalendarCaptionBarControl()
Default object constructor.
CXTPCalendarCaptionBarControl::UpdateBorders
virtual void UpdateBorders()
This member function is used to adjust the object's layout depending on the provided bounding rectang...
CXTPCalendarCaptionBarControl::GetBorders
CRect GetBorders() const
This member function is used to adjust the object's layout depending on the provided bounding rectang...
Definition XTPCalendarCaptionBarControl.h:329
CXTPCalendarCaptionBarControl::~CXTPCalendarCaptionBarControl
virtual ~CXTPCalendarCaptionBarControl()
Default object destructor.
CXTPCalendarCaptionBarControl::Create
virtual BOOL Create(DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID)
This member function is used to create the CaptionBar control window.
CXTPCalendarCaptionBarControl::SetButtonText
void SetButtonText(int iButtonNumber, CString sButtonText)
This member function is used to Set Button Text if text not empty and hide button and adjust Caption ...
CXTPCalendarCaptionBarControl::IsTimelineEnable
BOOL IsTimelineEnable()
This member function is used to get state of m_bTimelineEnable.
CXTPCalendarCaptionBarControl::IsMulticolumnsEnable
BOOL IsMulticolumnsEnable()
This member function is used to get state of m_bMulticolumnsEnable.
CXTPCalendarCaptionBarControl::SetTheme
void SetTheme(CXTPCalendarCaptionBarTheme *pTheme)
This member function is used to set theme object.
CXTPCalendarCaptionBarControl::m_pTheme
CXTPCalendarCaptionBarTheme * m_pTheme
Store pointer to CXTPCalendarCaptionBarTheme object.
Definition XTPCalendarCaptionBarControl.h:302
CXTPCalendarCaptionBarControl::CalcMinRect
virtual CRect CalcMinRect(BOOL bExactSize=FALSE)
This member function retrieves the minimum size required to show a CaptionBar control.
CXTPCalendarCaptionBarControl::m_Borders
CRect m_Borders
Store options to draw border lines;
Definition XTPCalendarCaptionBarControl.h:304
CXTPCalendarCaptionBarControl::GetTheme
CXTPCalendarCaptionBarTheme * GetTheme() const
This member function is used to obtain pointer to CXTPCalendarCaptionBarTheme object.
CXTPCalendarCaptionBarControl::EnableMulticolumns
void EnableMulticolumns(BOOL bEnable)
This member function is used to show or hide Multi-Columns mode button.
CXTPCalendarCaptionBarControl::UseOneLine
void UseOneLine(BOOL bSet)
This member function is used to get state of GetTheme()->m_bIsOneLine -.
CXTPCalendarCaptionBarTheme
This class CalendarCaptionBar control drawing, user interaction logic and interaction logic with atta...
Definition XTPCalendarCaptionBarTheme.h:48
CXTPWinThemeWrapper
The CXTPWinThemeWrapper class wraps the UxTheme.dll visual theme API.
Definition XTPWinThemeWrapper.h:188


Toolkit Pro: XTPRibbonThemeVisualStudio2015.h Source File

  • Source
  • Ribbon
  • Themes
XTPRibbonThemeVisualStudio2015.h
Go to the documentation of this file.
1
23#if !defined(__XTPRIBBONVISUALSTUDIO2015THEME_H__)
24# define __XTPRIBBONVISUALSTUDIO2015THEME_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPRibbonThemeVisualStudio2015 : public CXTPRibbonOffice2013Theme
39{
40public:
46 CXTPRibbonThemeVisualStudio2015(CXTPPaintManager* pPaintManager);
47
52 virtual ~CXTPRibbonThemeVisualStudio2015();
53};
54
55# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
57#endif // !defined(__XTPRIBBONVISUALSTUDIO2015THEME_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPPaintManager
Paint manager of the command bars.
Definition XTPPaintManager.h:199
CXTPRibbonOffice2013Theme
CXTPRibbonOffice2013Theme is a CXTPRibbonMarkupTheme derived class used to represent an Office 2013 r...
Definition XTPRibbonThemeOffice2013.h:50
CXTPRibbonThemeVisualStudio2015
CXTPRibbonThemeVisualStudio2015 is a CXTPRibbonOffice2013Theme derived class used to represent a Visu...
Definition XTPRibbonThemeVisualStudio2015.h:39
CXTPRibbonThemeVisualStudio2015::~CXTPRibbonThemeVisualStudio2015
virtual ~CXTPRibbonThemeVisualStudio2015()
Destroys a CXTPRibbonThemeVisualStudio2015 object, handles cleanup and deallocation.
CXTPRibbonThemeVisualStudio2015::CXTPRibbonThemeVisualStudio2015
CXTPRibbonThemeVisualStudio2015(CXTPPaintManager *pPaintManager)
Constructs a CXTPRibbonThemeVisualStudio2015 object.


Toolkit Pro: XTPCommandBarsContextMenus.h Source File

  • Source
  • CommandBars
XTPCommandBarsContextMenus.h
Go to the documentation of this file.
1
23#if !defined(__XTPCOMMANDBARSCONTEXTMENUS_H__)
24# define __XTPCOMMANDBARSCONTEXTMENUS_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPCommandBarsContextMenus : public CXTPCommandBarList
39{
40public:
46 CXTPCommandBarsContextMenus(CXTPCommandBars* pCommandBars);
47
48public:
56 CXTPCommandBar* Add(UINT nIDBar);
57
67 CXTPCommandBar* Add(UINT nIDBar, UINT nIDMenuResource, int nSubMenu);
68
76 CXTPCommandBar* Add(CXTPCommandBar* pCommandBar);
77
87 CXTPCommandBar* Add(UINT nIDBar, LPCTSTR lpszTitle, CMenu* pSubMenu);
89# ifdef _XTP_COMMANDBARS_ACTIVEX
90
91 DECLARE_DISPATCH_MAP()
92 DECLARE_OLETYPELIB_EX(CXTPCommandBarsContextMenus);
93
94 afx_msg LPDISPATCH OleGetItem(long nIndex);
95 afx_msg LPDISPATCH OleItem(long nIndex);
96 afx_msg long OleGetItemCount();
97 afx_msg LPDISPATCH OleFind(int nId);
98 afx_msg LPDISPATCH OleAdd(int nId, LPCTSTR strCaption);
99 afx_msg void OleAddPopup(LPDISPATCH lpDispatch);
100
101 DECLARE_ENUM_VARIANT(CXTPCommandBarsContextMenus);
102
103# endif
105};
106
108# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
109#endif // !defined(__XTPCOMMANDBARSCONTEXTMENUS_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCommandBar
CXTPCommandBar is a CWnd derived class.
Definition XTPCommandBar.h:66
CXTPCommandBarList
CXTPCommandBarList is a CList derived class.
Definition XTPCommandBarList.h:42
CXTPCommandBarsContextMenus
CXTPCommandBarsContextMenus is CXTPCommandBarList derived class which represents a collection of cont...
Definition XTPCommandBarsContextMenus.h:39
CXTPCommandBarsContextMenus::Add
CXTPCommandBar * Add(UINT nIDBar, UINT nIDMenuResource, int nSubMenu)
Call this method to add a new context menu to the collection.
CXTPCommandBarsContextMenus::CXTPCommandBarsContextMenus
CXTPCommandBarsContextMenus(CXTPCommandBars *pCommandBars)
Constructs a CXTPCommandBarsContextMenus object.
CXTPCommandBarsContextMenus::Add
CXTPCommandBar * Add(CXTPCommandBar *pCommandBar)
Call this method to add a new context menu to the collection.
CXTPCommandBarsContextMenus::Add
CXTPCommandBar * Add(UINT nIDBar)
Call this method to add a new context menu to the collection.
CXTPCommandBarsContextMenus::Add
CXTPCommandBar * Add(UINT nIDBar, LPCTSTR lpszTitle, CMenu *pSubMenu)
Call this method to add a new context menu to the collection.
CXTPCommandBars
CXTPCommandBars is a standalone class.
Definition XTPCommandBars.h:165


Toolkit Pro: XTPChartRadarPointSeriesLabel.h Source File

  • Source
  • Chart
  • Styles
  • Radar
XTPChartRadarPointSeriesLabel.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTRADARPOINTSERIESLABEL_H__)
24# define __XTPCHARTRADARPOINTSERIESLABEL_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartSeriesView;
34
40class _XTP_EXT_CLASS CXTPChartRadarPointSeriesLabel : public CXTPChartSeriesLabel
41{
42 DECLARE_SERIAL(CXTPChartRadarPointSeriesLabel);
43
44public:
49 CXTPChartRadarPointSeriesLabel();
50
55 virtual ~CXTPChartRadarPointSeriesLabel();
56
57public:
58 void DoPropExchange(CXTPPropExchange* pPX);
59
60public:
67 void SetAngle(int nAngle);
68
76 int GetAngle() const;
77
78protected:
79 CXTPChartElementView* CreateView(CXTPChartDeviceContext* pDC,
80 CXTPChartSeriesPointView* pPointView,
81 CXTPChartElementView* pParentView);
82
83protected:
84 int m_nAngle;
86# ifdef _XTP_ACTIVEX
87public:
89 DECLARE_DISPATCH_MAP()
90 DECLARE_INTERFACE_MAP()
91 DECLARE_OLETYPELIB_EX(CXTPChartRadarPointSeriesLabel);
93# endif
94};
95
101class _XTP_EXT_CLASS CXTPChartRadarPointSeriesLabelView : public CXTPChartSeriesLabelView
102{
103public:
112 CXTPChartRadarPointSeriesLabelView(CXTPChartSeriesLabel* pLabel,
113 CXTPChartSeriesPointView* pPointView,
114 CXTPChartElementView* pParentView);
115
128 virtual CXTPChartDeviceCommand* CreateDeviceCommand(CXTPChartDeviceContext* pDC);
129
145 virtual CXTPChartDeviceCommand* CreateDeviceCommand(CXTPChartDeviceContext* pDC,
146 const CXTPChartPointF& ptAnchorPoint,
147 double dAnchorAngle,
148 const CXTPChartString& text);
149
157 virtual CXTPChartPointF GetAnchorPoint() const;
158 virtual double GetAnchorAngle() const;
159
160 virtual void CalculateLayout(CXTPChartDeviceContext* pDC);
161 void CalculateLayout(CXTPChartDeviceContext* pDC, const CXTPChartPointF& ptAnchorPoint,
162 double dAnchorAngle, const CXTPChartString& text);
163
164protected:
165 CRect GetPaneRect() const;
166};
167
168AFX_INLINE void CXTPChartRadarPointSeriesLabel::SetAngle(int nAngle)
169{
170 m_nAngle = nAngle;
171 OnChartChanged();
172}
173AFX_INLINE int CXTPChartRadarPointSeriesLabel::GetAngle() const
174{
175 return m_nAngle;
176}
178# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
179#endif //#if !defined(__XTPCHARTRADARPOINTSERIESLABEL_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartElement::OnChartChanged
virtual void OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic propertie...
CXTPChartElementView
This class represents the view of a chart element.
Definition XTPChartElementView.h:47
CXTPChartRadarPointSeriesLabel
This class abstracts the label of a point series.
Definition XTPChartRadarPointSeriesLabel.h:41
CXTPChartRadarPointSeriesLabel::SetAngle
void SetAngle(int nAngle)
Call this function to set the angle of the label stem.
Definition XTPChartRadarPointSeriesLabel.h:168
CXTPChartRadarPointSeriesLabel::~CXTPChartRadarPointSeriesLabel
virtual ~CXTPChartRadarPointSeriesLabel()
Destroys a CXTPChartRadarPointSeriesLabel object, handles cleanup.
CXTPChartRadarPointSeriesLabel::DoPropExchange
void DoPropExchange(CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
CXTPChartRadarPointSeriesLabel::GetAngle
int GetAngle() const
Call this function to get the angle of the label stem.
Definition XTPChartRadarPointSeriesLabel.h:173
CXTPChartRadarPointSeriesLabel::CXTPChartRadarPointSeriesLabel
CXTPChartRadarPointSeriesLabel()
Constructs a CXTPChartRadarPointSeriesLabel object.
CXTPChartRadarPointSeriesLabel::m_nAngle
int m_nAngle
The stem angle.
Definition XTPChartRadarPointSeriesLabel.h:84
CXTPChartRadarPointSeriesLabelView
This class abstracts the view of the label of a point series, it is a kind of chart series label view...
Definition XTPChartRadarPointSeriesLabel.h:102
CXTPChartRadarPointSeriesLabelView::CXTPChartRadarPointSeriesLabelView
CXTPChartRadarPointSeriesLabelView(CXTPChartSeriesLabel *pLabel, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView)
Constructs a CXTPChartRadarPointSeriesLabelView object.
CXTPChartRadarPointSeriesLabelView::CreateDeviceCommand
virtual CXTPChartDeviceCommand * CreateDeviceCommand(CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
CXTPChartRadarPointSeriesLabelView::GetAnchorPoint
virtual CXTPChartPointF GetAnchorPoint() const
This function calculates the anchor point of the label stem.
CXTPChartRadarPointSeriesLabelView::CreateDeviceCommand
virtual CXTPChartDeviceCommand * CreateDeviceCommand(CXTPChartDeviceContext *pDC, const CXTPChartPointF &ptAnchorPoint, double dAnchorAngle, const CXTPChartString &text)
This function creates a CXTPChartDeviceCommand object.
CXTPChartSeriesLabel
This class abstracts the label of a series.
Definition XTPChartSeriesLabel.h:49
CXTPChartSeriesPointView
Represents chart series point view.
Definition XTPChartSeriesPointView.h:48
CXTPPoint2T< float >
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72


Toolkit Pro: XTPTabColorSetDefault.h Source File

  • Source
  • TabManager
  • ColorSets
XTPTabColorSetDefault.h
Go to the documentation of this file.
1
23#if !defined(__XTPTABCOLORSETDEFAULT_H__)
24# define __XTPTABCOLORSETDEFAULT_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
43class _XTP_EXT_CLASS CXTPTabColorSetDefault : public CXTPTabPaintManagerColorSet
44{
45public:
53 virtual void RefreshMetrics();
54
69 void FillNavigateButton(CDC* pDC, CXTPTabManagerNavigateButton* pButton, CRect& rc);
70};
71
72class _XTP_EXT_CLASS CXTPTabPaintManager::CColorSetDefault : public CXTPTabColorSetDefault
73{
74};
75
76# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
78#endif // !defined(__XTPTABCOLORSETDEFAULT_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPTabColorSetDefault
CXTPTabColorSetDefault implements a default tab color set.
Definition XTPTabColorSetDefault.h:44
CXTPTabColorSetDefault::FillNavigateButton
void FillNavigateButton(CDC *pDC, CXTPTabManagerNavigateButton *pButton, CRect &rc)
Fills a specified tab navigation button.
CXTPTabColorSetDefault::RefreshMetrics
virtual void RefreshMetrics()
Refreshes the visual metrics of the tabs.
CXTPTabManagerNavigateButton
CXTPTabManagerNavigateButton is a class used to represent a tab navigation button.
Definition XTPTabManagerNavigateButton.h:74
CXTPTabPaintManagerColorSet
CXTPTabPaintManagerColorSet represents the colors for all of the components of the tab manager (e....
Definition XTPTabPaintManagerColorSet.h:50
CXTPTabPaintManager
CXTPTabPaintManager is used to store the color and appearance information of the tabs in the tab mana...
Definition XTPTabPaintManager.h:48


Toolkit Pro: Member List

CXTPShortcutBarOffice2000Theme Member List

This is the complete list of members for CXTPShortcutBarOffice2000Theme, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPShortcutBarPaintManager() | CXTPShortcutBarPaintManager |
DrawExpandButton(CDC *pDC, CRect rc) | CXTPShortcutBarPaintManager | virtual
DrawGripper(CDC *pDC, CXTPShortcutBar *pShortcutBar, BOOL bDraw) | CXTPShortcutBarOffice2000Theme | virtual
DrawImage(CDC *pDC, CPoint pt, CSize sz, CXTPImageManagerIcon *pImage, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled) | CXTPShortcutBarOffice2000Theme | virtual
DrawNavigationItem(CDC *pDC, CXTPShortcutBarItem *pItem) | CXTPShortcutBarPaintManager | virtual
DrawPaneCaption(CDC *pDC, CXTPShortcutBarPane *pPane, BOOL bDraw) | CXTPShortcutBarPaintManager | virtual
DrawPaneItemCaption(CDC *pDC, CXTPShortcutBarPaneItem *pItem, BOOL bDraw) | CXTPShortcutBarPaintManager | virtual
DrawShortcutBarFrame(CDC *pDC, CXTPShortcutBar *pShortcutBar) | CXTPShortcutBarOffice2000Theme | virtual
DrawShortcutItem(CDC *pDC, CXTPShortcutBarItem *pItem) | CXTPShortcutBarPaintManager | virtual
FillNavigationItemEntry(CDC *pDC, CXTPShortcutBarItem *pItem) | CXTPShortcutBarPaintManager | virtual
FillShortcutBar(CDC *pDC, CXTPShortcutBar *pShortcutBar) | CXTPShortcutBarOffice2000Theme | virtual
FillShortcutItemEntry(CDC *pDC, CXTPShortcutBarItem *pItem) | CXTPShortcutBarOffice2000Theme | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
IsShortcutItemTruncated(CDC *pDC, CXTPShortcutBarItem *pItem) | CXTPShortcutBarPaintManager |
Line(CDC *pDC, int x0, int y0, int x1, int y1, int nPen) | CXTPShortcutBarOffice2000Theme |
m_bBoldItemCaptionFont | CXTPShortcutBarPaintManager |
m_bClearTypeTextQuality | CXTPShortcutBarPaintManager |
m_bNavigationButton | CXTPShortcutBarPaintManager |
m_bUseStandardFont | CXTPShortcutBarPaintManager |
m_clrDisabledText | CXTPShortcutBarPaintManager |
m_clrHotText | CXTPShortcutBarPaintManager |
m_clrNormalText | CXTPShortcutBarPaintManager |
m_clrPushedText | CXTPShortcutBarPaintManager |
m_clrSelectedText | CXTPShortcutBarPaintManager |
m_clrShortcutItemShadow | CXTPShortcutBarPaintManager |
m_grcHot | CXTPShortcutBarPaintManager |
m_grcPushed | CXTPShortcutBarPaintManager |
m_grcSelected | CXTPShortcutBarPaintManager |
m_grcShortcutBarGripper | CXTPShortcutBarPaintManager |
m_grcShortcutItem | CXTPShortcutBarPaintManager |
m_nExpandedIconWidth | CXTPShortcutBarPaintManager |
m_nNormalIconWidth | CXTPShortcutBarPaintManager |
m_nPaneItemHeight | CXTPShortcutBarPaintManager |
m_pExpandIcon | CXTPShortcutBarPaintManager |
m_rcCaptionPadding | CXTPShortcutBarPaintManager |
m_rcItemCaptionPadding | CXTPShortcutBarPaintManager |
m_strOfficeFont | CXTPShortcutBarPaintManager |
m_xtpFontPaneCaption | CXTPShortcutBarPaintManager |
m_xtpFontPaneItemCaption | CXTPShortcutBarPaintManager |
m_xtpFontText | CXTPShortcutBarPaintManager |
m_xtpFontVerticalText | CXTPShortcutBarPaintManager |
Rectangle(CDC *pDC, CRect rc, int nPen, int nBrush) | CXTPShortcutBarOffice2000Theme |
RefreshMetrics() | CXTPShortcutBarPaintManager | virtual
~CXTPShortcutBarPaintManager() | CXTPShortcutBarPaintManager | virtual


Toolkit Pro: XTPChartRangeBarSeriesView.h Source File

  • Source
  • Chart
  • Styles
  • Range
XTPChartRangeBarSeriesView.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTRANGEBARSERIESVIEW_H__)
24# define __XTPCHARTRANGEBARSERIESVIEW_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartSeriesView;
34
40class _XTP_EXT_CLASS CXTPChartRangeBarSeriesView : public CXTPChartBarSeriesView
41{
42public:
50 CXTPChartRangeBarSeriesView(CXTPChartSeries* pSeries, CXTPChartDiagramView* pDiagramView);
51
52protected:
64 CXTPChartSeriesPointView* CreateSeriesPointView(CXTPChartDeviceContext* pDC,
65 CXTPChartSeriesPoint* pPoint,
66 CXTPChartElementView* pParentView);
67
68protected:
69 friend class CXTPChartRangeBarSeriesPointView;
70};
71
77class _XTP_EXT_CLASS CXTPChartRangeBarSeriesPointView : public CXTPChartBarSeriesPointView
78{
79public:
87 CXTPChartRangeBarSeriesPointView(CXTPChartSeriesPoint* pPoint,
88 CXTPChartElementView* pParentView);
89
90public:
91 virtual CXTPChartRectF GetScreenRect() const;
92
93 virtual CXTPChartDeviceCommand* CreateDeviceCommand(CXTPChartDeviceContext* pDC);
94
95public:
96 virtual void UpdateMinMaxRange(double& nMinValue, double& nMaxValue) const;
97
98 CXTPChartPointF GetScreenPoint(BOOL bMinValue) const;
99
100public:
101};
103# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
104#endif //#if !defined(__XTPCHARTRANGEBARSERIESVIEW_H__)
pPoint
const CPoint * pPoint
return 0 or xtpCalendarHitTestDayExpandButton
Definition XTPCalendarThemeOffice2007.h:150
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartBarSeriesPointView
This class represents the view of a bar series point, which is a kind of CXTPChartPointSeriesPointVie...
Definition XTPChartBarSeriesView.h:105
CXTPChartBarSeriesView
This class represents the view of a bar series, which is a kind of CXTPChartSeriesView.
Definition XTPChartBarSeriesView.h:41
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartDiagramView
This class represents the view of a chart diagram, which is a kind of CXTPChartElementView.
Definition XTPChartDiagramView.h:49
CXTPChartElementView
This class represents the view of a chart element.
Definition XTPChartElementView.h:47
CXTPChartRangeBarSeriesPointView
This class represents the view of a RangeBar series point, which is a kind of CXTPChartPointSeriesPoi...
Definition XTPChartRangeBarSeriesView.h:78
CXTPChartRangeBarSeriesPointView::UpdateMinMaxRange
virtual void UpdateMinMaxRange(double &nMinValue, double &nMaxValue) const
Provides a default empty implementation for min/max range update request.
CXTPChartRangeBarSeriesPointView::CXTPChartRangeBarSeriesPointView
CXTPChartRangeBarSeriesPointView(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Constructs a CXTPChartRangeBarSeriesPointView object.
CXTPChartRangeBarSeriesPointView::CreateDeviceCommand
virtual CXTPChartDeviceCommand * CreateDeviceCommand(CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
CXTPChartRangeBarSeriesView
This class represents the view of a RangeBar series, which is a kind of CXTPChartSeriesView.
Definition XTPChartRangeBarSeriesView.h:41
CXTPChartRangeBarSeriesView::CXTPChartRangeBarSeriesView
CXTPChartRangeBarSeriesView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Constructs a CXTPChartRangeBarSeriesView object.
CXTPChartRangeBarSeriesView::CreateSeriesPointView
CXTPChartSeriesPointView * CreateSeriesPointView(CXTPChartDeviceContext *pDC, CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Call this function to create a view of the RangeBar series point.
CXTPChartSeries
This class represents a series in the chart, which is a kind of CXTPChartElement.
Definition XTPChartSeries.h:50
CXTPChartSeriesPoint
CXTPChartSeriesPoint is a kind of CXTPChartElement.
Definition XTPChartSeriesPoint.h:43
CXTPChartSeriesPointView
Represents chart series point view.
Definition XTPChartSeriesPointView.h:48
CXTPPoint2T< float >
CXTPRectT< float >


Toolkit Pro: Member List

CXTPCalendarNativeWindows10Theme Member List

This is the complete list of members for CXTPCalendarNativeWindows10Theme, including all inherited members.

_GetAtGrow_BusyStatusBrushValue(int eBusyStatus, BOOL bGrow) | CXTPCalendarPaintManager | protected
_Init() | CXTPCalendarPaintManager | virtual
AddViewPart(CXTPCalendarViewPart *pPart) | CXTPCalendarPaintManager | protected
AdjustTimeFont(CDC *pDC, CRect rcCell) | CXTPCalendarPaintManager |
BEGIN_VIEW_PART(ControlPart, XTPCalendarViewPart) virtual void RefreshMetrics() | CXTPCalendarPaintManager |
CalcEventSize(CDC *c, CXTPCalendarTimeLineViewEvent *pViewEvent) | CXTPCalendarPaintManager | virtual
CalcWidth(CDC *pDC, const CString &strHour, const CString &strMin, int nHourHeight, int &nWidth) | CXTPCalendarPaintManager |
CXTPCalendarNativeWindows10Theme() | CXTPCalendarNativeWindows10Theme |
CXTPCalendarOffice2000Theme() | CXTPCalendarOffice2000Theme |
CXTPCalendarOffice2013Theme() | CXTPCalendarOffice2013Theme |
CXTPCalendarPaintManager() | CXTPCalendarPaintManager |
CXTPCmdTarget() | CXTPCmdTarget |
DrawBigHourCell(CDC *pDC, CRect rc, CString strHour, CString strMin, int nRowPerHour, BOOL bFillBackground=TRUE, BOOL bCurrentTime=FALSE) | CXTPCalendarPaintManager | virtual
DrawBitmap(CImageList *pImageList, CDC *pDC, CRect rcView, int iIcon, UINT uFlags=0) | CXTPCalendarPaintManager | virtual
DrawBitmap(UINT nIDResource, CDC *pDC, CRect rcBitmap) | CXTPCalendarPaintManager | virtual
DrawBorder(CDC *pDC, CRect rcView, CXTPCalendarWeekViewEvent *pWeekViewEvent) | CXTPCalendarPaintManager | virtual
DrawBusyStatus(CDC *pDC, CRect &rcRect, int eBusyStatus) | CXTPCalendarPaintManager | virtual
DrawBusyStatus(CDC *pDC, CRgn &rgnBusy, int eBusyStatus) | CXTPCalendarPaintManager | virtual
DrawClock(CDC *pDC, COleDateTime dtClockTime, CRect rcView, COLORREF clrBackground, XTPCalendarClockAlignFlags cafAlign) | CXTPCalendarPaintManager | virtual
DrawDayHeader(CDC *pDC, CRect rcDay, int nHeaderHeight, CString strHeader, BOOL bIsCurrent=FALSE, BOOL bIsSelected=FALSE) | CXTPCalendarPaintManager | virtual
DrawEvent(CDC *pDC, const CRect &rcEvents, CXTPCalendarTimeLineViewEvent *pViewEvent) | CXTPCalendarPaintManager | virtual
DrawExpandSigns(CDC *pDC, CXTPCalendarDayView *pView, const CRect &rcTSHours) | CXTPCalendarPaintManager | virtual
DrawGroup(CDC *pDC, const CRect &rcRect, CXTPCalendarTimeLineViewGroup *pGroup) | CXTPCalendarPaintManager | virtual
DrawHeader(CDC *pDC, CRect &rcHeader, BOOL bIsSelected, BOOL bIsCurrent, const CXTPPaintManagerColorGradient &grclr, COLORREF clrUnderLineHdr) | CXTPCalendarOffice2013Theme | virtual
CXTPCalendarOffice2000Theme::DrawHeader(CDC *pDC, CRect &rcHeader, BOOL bIsSelected, BOOL bIsCurrent) | CXTPCalendarPaintManager | virtual
DrawHorizontalLine(CDC *pDC, int xPos, int yPos, int cx) | CXTPCalendarPaintManager | virtual
DrawHourCell(CDC *pDC, CRect rc, CString strText, BOOL bFillBackground=TRUE, BOOL bCurrentTime=FALSE) | CXTPCalendarPaintManager | virtual
DrawIconChar(CDC *pDC, CRect rc, TCHAR ch) | CXTPCalendarPaintManager | virtual
DrawIcons(CDC *pDC, CXTPCalendarViewEvent *pViewEvent) | CXTPCalendarPaintManager | virtual
DrawLine(CDC *pDC, int xPos, int yPos, int cx, int cy) | CXTPCalendarPaintManager | virtual
DrawNowLine(CDC *pDC, CXTPCalendarDayView *pView, CRect rc, int y, BOOL bDrawBk=FALSE) | CXTPCalendarPaintManager | virtual
DrawNowLine(CDC *pDC, CXTPCalendarDayView *pView, CXTPCalendarDayViewTimeScale *pScale, CRect rc, int y, BOOL bDrawBk=FALSE) | CXTPCalendarPaintManager | virtual
DrawShadow(CDC *pDC, const CRect &rcRect) | CXTPCalendarPaintManager | virtual
DrawSubj(CDC *pDC, CXTPCalendarWeekViewEvent *pWeekViewEvent) | CXTPCalendarPaintManager | virtual
DrawTimes(CDC *pDC, CXTPCalendarWeekViewEvent *pWeekViewEvent) | CXTPCalendarPaintManager | virtual
DrawVerticalLine(CDC *pDC, int xPos, int yPos, int cy) | CXTPCalendarPaintManager | virtual
EnableTheme(BOOL bEnableTheme) | CXTPCalendarPaintManager |
END_VIEW_PART(ControlPart) BEGIN_VIEW_PART(DayViewTimeScaleHeaderPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewTimeScaleHeaderPart) BEGIN_VIEW_PART(DayViewTimeScaleCellPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewTimeScaleCellPart) BEGIN_VIEW_PART(DayViewCellPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewCellPart) BEGIN_VIEW_PART(DayViewWorkCellPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewWorkCellPart) BEGIN_VIEW_PART(DayViewNonworkCellPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewNonworkCellPart) BEGIN_VIEW_PART(DayMonthViewHeaderPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayMonthViewHeaderPart) BEGIN_VIEW_PART(DayViewHeaderPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewHeaderPart) BEGIN_VIEW_PART(DayViewGroupHeaderPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewGroupHeaderPart) BEGIN_VIEW_PART(DayViewAllDayEventsPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewAllDayEventsPart) BEGIN_VIEW_PART(DayViewAllDayEventScrollIconsPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewAllDayEventScrollIconsPart) BEGIN_VIEW_PART(DayViewEventPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewEventPart) BEGIN_VIEW_PART(MonthViewGridPart | CXTPCalendarPaintManager |
END_VIEW_PART(MonthViewGridPart) BEGIN_VIEW_PART(MonthViewHeaderPart | CXTPCalendarPaintManager |
END_VIEW_PART(MonthViewHeaderPart) BEGIN_VIEW_PART(MonthViewEventPart | CXTPCalendarPaintManager |
END_VIEW_PART(MonthViewEventPart) BEGIN_VIEW_PART(WeekViewPart | CXTPCalendarPaintManager |
END_VIEW_PART(WeekViewPart) BEGIN_VIEW_PART(WeekViewEventPart | CXTPCalendarPaintManager |
END_VIEW_PART(WeekViewEventPart) BEGIN_VIEW_PART(TimeLineViewTimeScalePart_Day | CXTPCalendarPaintManager |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAskItemTextFlags() const | CXTPCalendarPaintManager |
GetBusyStatusBrush(int nBusyStatus) | CXTPCalendarPaintManager |
GetClockSize() | CXTPCalendarPaintManager | virtual
GetCurrentSystemTheme() | CXTPCalendarPaintManager |
GetEventBackColor(CXTPCalendarEvent *pEvent) | CXTPCalendarOffice2013Theme | virtual
CXTPCalendarOffice2000Theme::GetEventBackColor(CXTPCalendarEvent *pEvent, COLORREF crDefault) | CXTPCalendarPaintManager | virtual
GetEventEdgeColor(CXTPCalendarEvent *pEvent) | CXTPCalendarOffice2013Theme | virtual
GetExpandSignSize() | CXTPCalendarPaintManager | virtual
GetPaintTheme() const | CXTPCalendarPaintManager | virtual
GetParams(CXTPCalendarDayViewGroup *pViewGroup, XTP_CALENDAR_DAYVIEWCELL_PARAMS *rCellParams) | CXTPCalendarPaintManager | virtual
idxExpandSignDown enum value | CXTPCalendarPaintManager | protected
idxExpandSignUp enum value | CXTPCalendarPaintManager | protected
idxMeeting enum value | CXTPCalendarPaintManager | protected
idxPrivate enum value | CXTPCalendarPaintManager | protected
idxRecurrenceException enum value | CXTPCalendarPaintManager | protected
idxRecurrenceOccurrence enum value | CXTPCalendarPaintManager | protected
idxReminder enum value | CXTPCalendarPaintManager | protected
InitBusyStatusDefaultColors() | CXTPCalendarPaintManager | protectedvirtual
IsThemeEnabled() | CXTPCalendarPaintManager |
m_arBusyStatusBrushes | CXTPCalendarPaintManager | protected
m_arStartCol | CXTPCalendarPaintManager |
m_arStartRow | CXTPCalendarPaintManager |
m_bEnableTheme | CXTPCalendarPaintManager | protected
m_bmpElsewherePattern | CXTPCalendarPaintManager | protected
m_bmpTentativePattern | CXTPCalendarPaintManager | protected
m_bShowMinutes | CXTPCalendarPaintManager |
m_clr3DShadow | CXTPCalendarPaintManager |
m_clrBackground | CXTPCalendarPaintManager |
m_clrBackground2 | CXTPCalendarPaintManager |
m_clrBackgroundSlave | CXTPCalendarPaintManager |
m_clrBorders | CXTPCalendarPaintManager |
m_clrButtonFace | CXTPCalendarPaintManager |
m_clrButtonFaceText | CXTPCalendarPaintManager |
m_clrClassicUnderline | CXTPCalendarPaintManager |
m_clrEventBar | CXTPCalendarPaintManager |
m_clrEventBarLine | CXTPCalendarPaintManager |
m_clrEventBorderLine | CXTPCalendarPaintManager |
m_clrHeaderBottomLine | CXTPCalendarPaintManager |
m_clrHighlight | CXTPCalendarPaintManager |
m_clrHour | CXTPCalendarPaintManager |
m_clrSelectedBackground | CXTPCalendarPaintManager |
m_clrSelectedText | CXTPCalendarPaintManager |
m_clrShadow | CXTPCalendarPaintManager |
m_clrText | CXTPCalendarPaintManager |
m_clrTextHighLightColor | CXTPCalendarPaintManager |
m_clrTextNormalColor | CXTPCalendarPaintManager |
m_clrTimeScaleBackground | CXTPCalendarPaintManager |
m_clrTimeScaleHightlite | CXTPCalendarPaintManager |
m_clrTimeScaleText | CXTPCalendarPaintManager |
m_clrUnderLineHdr | CXTPCalendarPaintManager | protected
m_clrWeekendBackground | CXTPCalendarPaintManager |
m_clrWindow | CXTPCalendarPaintManager |
m_clrWindowText | CXTPCalendarPaintManager |
m_CurrSystemTheme | CXTPCalendarPaintManager | protected
m_dwAskItemTextFlags | CXTPCalendarPaintManager | protected
m_fntTimeText | CXTPCalendarPaintManager |
m_grclrClassicSelDay | CXTPCalendarPaintManager |
m_grclrToday | CXTPCalendarPaintManager |
m_lstViewParts | CXTPCalendarPaintManager | protected
m_nHourWidth | CXTPCalendarPaintManager |
m_nMinWidth | CXTPCalendarPaintManager |
m_nPaintTheme | CXTPCalendarPaintManager | protected
m_pControl | CXTPCalendarPaintManager | protected
m_pExpandSigns | CXTPCalendarPaintManager | protected
m_pGlyphs | CXTPCalendarPaintManager | protected
m_pGlyphsFont | CXTPCalendarPaintManager | protected
m_PrintPageWidth | CXTPCalendarPaintManager |
m_szClockRect | CXTPCalendarPaintManager | protected
m_xtpBrushElsewhere | CXTPCalendarPaintManager | protected
m_xtpBrushTentative | CXTPCalendarPaintManager | protected
OnDraw(CDC *pDC, CXTPCalendarDayView *pView, CRect rc, CString strText) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarDayViewGroup *pViewGroup, CRect rc, const XTP_CALENDAR_DAYVIEWCELL_PARAMS &cellParams) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarDayViewDay *pViewDay, CRect rc, CString strText) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarDayViewGroup *pViewGroup, CRect rc, CString strText) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarDayViewGroup *pViewGroup, CRect rc, BOOL bSelected) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarDayViewGroup *pViewGroup, BOOL bDrawUp, BOOL bDrawDown, const CRect &rcIconUp, const CRect &rcIconDown, BOOL bHighlightUp, BOOL bHighlightDown) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarDayViewEvent *pViewEvent) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarMonthView *pMonthView, CRect rc, int nCollIndex, CString strText) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarWeekView *pWeekView) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarWeekViewEvent *pWeekViewEvent) | CXTPCalendarPaintManager | virtual
OnDrawDayDate(CDC *pDC, CRect rc, BOOL bToday, BOOL bSelected, BOOL bFirstMonthDay, CString strText) | CXTPCalendarPaintManager | virtual
OnDrawEvent(CDC *pDC, CXTPCalendarMonthViewEvent *pViewEvent) | CXTPCalendarPaintManager | virtual
OnDrawGrid(CDC *pDC, CXTPCalendarMonthView *pMonthView) | CXTPCalendarPaintManager | virtual
RefreshMetrics() | CXTPCalendarOffice2013Theme | virtual
SetAskItemTextFlags(DWORD dwFlags) | CXTPCalendarPaintManager |
SetBusyStatusBrush(int nBusyStatus, CBrush *pBrush, BOOL bAutodeleteBrush) | CXTPCalendarPaintManager |
SetControl(CXTPCalendarControl *pControl) | CXTPCalendarPaintManager | virtual
SetPaintTheme(XTPCalendarTheme ePaintTheme) | CXTPCalendarPaintManager | virtual
UpdateEventCategoriesDefaultColors() | CXTPCalendarOffice2013Theme | virtual
UpdateEventLabelsDefaultColors() | CXTPCalendarOffice2013Theme | virtual
UpdateGlyphs() | CXTPCalendarOffice2013Theme | virtual
XTPEnumEventGlyphs enum name | CXTPCalendarPaintManager | protected
XTPEnumExpandSigns enum name | CXTPCalendarPaintManager | protected
~CTimeLineViewPart() | CXTPCalendarPaintManager | virtual
~CXTPCalendarNativeWindows10Theme() | CXTPCalendarNativeWindows10Theme | virtual
~CXTPCalendarOffice2000Theme() | CXTPCalendarOffice2000Theme | virtual
~CXTPCalendarOffice2013Theme() | CXTPCalendarOffice2013Theme | virtual
~CXTPCalendarPaintManager() | CXTPCalendarPaintManager | virtual


Toolkit Pro: Member List

CXTPCalendarTimeZone Member List

This is the complete list of members for CXTPCalendarTimeZone, including all inherited members.

CXTPCalendarTimeZone(const TIME_ZONE_INFORMATION *pTZInfo=NULL) | CXTPCalendarTimeZone |
CXTPCalendarTimeZone(const CXTPCalendarTimeZone *pTZInfoEx) | CXTPCalendarTimeZone |
CXTPCmdTarget() | CXTPCmdTarget |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetDisplayString() const | CXTPCalendarTimeZone |
GetIndex() const | CXTPCalendarTimeZone |
GetTimeZoneInfo(const TIME_ZONE_INFORMATION *pTZIdata) | CXTPCalendarTimeZone | static
IsEqual(const TIME_ZONE_INFORMATION *pTZI2) const | CXTPCalendarTimeZone |
m_dwIndex | CXTPCalendarTimeZone | protected
m_strDisplayString | CXTPCalendarTimeZone | protected
operator=(const CXTPCalendarTimeZone &rTZInfo) | CXTPCalendarTimeZone |
~CXTPCalendarTimeZone() | CXTPCalendarTimeZone | virtual


Toolkit Pro: Member List

CXTPSyntaxEditLexParserSchemaOptions Member List

This is the complete list of members for CXTPSyntaxEditLexParserSchemaOptions, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPSyntaxEditLexParserSchemaOptions() | CXTPSyntaxEditLexParserSchemaOptions |
CXTPSyntaxEditLexParserSchemaOptions(const CXTPSyntaxEditLexParserSchemaOptions &rSrc) | CXTPSyntaxEditLexParserSchemaOptions |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
m_bConfigChangedReparceInSeparateThread | CXTPSyntaxEditLexParserSchemaOptions |
m_bEditReparceInSeparateThread | CXTPSyntaxEditLexParserSchemaOptions |
m_bFirstParseInSeparateThread | CXTPSyntaxEditLexParserSchemaOptions |
m_dwEditReparceTimeout_ms | CXTPSyntaxEditLexParserSchemaOptions |
m_dwMaxBackParseOffset | CXTPSyntaxEditLexParserSchemaOptions |
m_dwOnScreenSchCacheLifeTime_sec | CXTPSyntaxEditLexParserSchemaOptions |
m_dwParserThreadIdleLifeTime_ms | CXTPSyntaxEditLexParserSchemaOptions |
operator=(const CXTPSyntaxEditLexParserSchemaOptions &rSrc) | CXTPSyntaxEditLexParserSchemaOptions |


Toolkit Pro: Member List

CXTPPropertyGridInplaceMultilineEdit Member List

This is the complete list of members for CXTPPropertyGridInplaceMultilineEdit, including all inherited members.

Apply() | CXTPPropertyGridInplaceMultilineEdit | protectedvirtual
Cancel() | CXTPPropertyGridInplaceMultilineEdit | protectedvirtual
Create(CXTPPropertyGridItem *pItem, CRect rect) | CXTPPropertyGridInplaceMultilineEdit | virtual
CXTPPropertyGridInplaceMultilineEdit() | CXTPPropertyGridInplaceMultilineEdit |
~CXTPPropertyGridInplaceMultilineEdit() | CXTPPropertyGridInplaceMultilineEdit | virtual


Toolkit Pro: XTPMarkupScrollBar.h Source File

  • Source
  • Markup
  • Controls
XTPMarkupScrollBar.h
Go to the documentation of this file.
1
23#if !defined(__XTPMARKUPSCROLLBAR_H__)
24# define __XTPMARKUPSCROLLBAR_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
34struct XTP_SCROLLBAR_POSINFO;
35struct XTP_SCROLLBAR_TRACKINFO;
38class CXTPMarkupMouseEventArgs;
39class CXTPMarkupDrawingContext;
40class CXTPMarkupMouseButtonEventArgs;
41
42class _XTP_EXT_CLASS CXTPMarkupScrollBar : public CXTPMarkupControl
43{
45 DECLARE_MARKUPCLASS(CXTPMarkupScrollBar);
47protected:
48 CXTPMarkupScrollBar();
49
50public:
51 void SetOrientation(XTPMarkupOrientation orientation);
52 void SetScrollInfo(SCROLLINFO* pScrollInfo);
53 void GetScrollInfo(SCROLLINFO* pScrollInfo);
54
55protected:
56 CSize MeasureOverride(CXTPMarkupDrawingContext* pDC, CSize szAvailableSize);
57 CSize ArrangeOverride(CSize szFinalSize);
58 void OnRender(CXTPMarkupDrawingContext* pDC);
59
60 void CalcScrollBarInfo(LPRECT lprc, XTP_SCROLLBAR_POSINFO* pSBInfo, SCROLLINFO* pSI);
61
62 void OnMouseLeave(CXTPMarkupMouseEventArgs* e);
63 void OnMouseEnter(CXTPMarkupMouseEventArgs* e);
64 void OnMouseMove(CXTPMarkupMouseEventArgs* e);
65
66 void OnMouseLeftButtonUp(CXTPMarkupMouseButtonEventArgs* e);
67 void OnMouseLeftButtonDown(CXTPMarkupMouseButtonEventArgs* e);
68
69 BOOL IsEnabled() const;
70
71private:
72 void PerformTrackInit(HWND hWnd, CPoint point, XTP_SCROLLBAR_POSINFO* pSBInfo, BOOL bDirect);
73 void CalcTrackDragRect(XTP_SCROLLBAR_TRACKINFO* pSBTrack) const;
74
75 void DoScroll(int cmd, int pos);
76 int HitTestScrollBar(POINT pt) const;
77 void EndScroll(BOOL fCancel);
78 void RedrawScrollBar();
79 void MoveThumb(int px);
80 void TrackThumb(UINT message, CPoint pt);
81 void TrackBox(UINT message, CPoint point);
82 void ContScroll();
83 void ScreenToClient(HWND hWnd, LPPOINT lpPoint);
84
85protected:
86 XTPMarkupOrientation m_orientation;
87
88 XTP_SCROLLBAR_POSINFO m_spi;
89 XTP_SCROLLBAR_TRACKINFO* m_pSBTrack;
90 SCROLLINFO m_si;
91};
92
93AFX_INLINE void CXTPMarkupScrollBar::SetOrientation(XTPMarkupOrientation orientation)
94{
95 m_orientation = orientation;
96}
97
98# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
100#endif // !defined(__XTPMARKUPSCROLLBAR_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPMarkupControl
CXTPMarkupControl is a CXTPMarkupFrameworkElement derived class.
Definition XTPMarkupControl.h:44
CXTPMarkupUIElement::IsEnabled
BOOL IsEnabled() const
Gets or sets a value indicating whether this element is enabled in the user interface (UI).
CXTPMarkupVisual::OnRender
virtual void OnRender(CXTPMarkupDrawingContext *drawingContext)
When overridden in a derived class, participates in rendering operations that are directed by the lay...
Definition XTPMarkupInputElement.h:515
XTP_SCROLLBAR_POSINFO
The XTP_SCROLLBAR_POSINFO structure contains scroll bar information.
Definition XTPScrollBase.h:143
XTP_SCROLLBAR_TRACKINFO
The XTP_SCROLLBAR_TRACKINFO structure contains tracking information.
Definition XTPScrollBase.h:174


Toolkit Pro: Member List

CXTPDockingPaneSidePanel Member List

This is the complete list of members for CXTPDockingPaneSidePanel, including all inherited members.

_InsertPane(CXTPDockingPaneBase *pPane) | CXTPDockingPaneSidePanel | protected
Clone(CXTPDockingPaneLayout *pLayout, CXTPPaneToPaneMap *pMap, DWORD dwIgnoredOptions=0) | CXTPDockingPaneBase | protectedvirtual
Collapse(BOOL bDelay=FALSE) | CXTPDockingPaneSidePanel |
ContainPane(CXTPDockingPaneBase *pPane) const | CXTPDockingPaneBaseContainer | virtual
Copy(CXTPDockingPaneBase *pClone, CXTPPaneToPaneMap *pMap, DWORD dwIgnoredOptions) | CXTPDockingPaneSidePanel | protectedvirtual
Create(CRect rc) | CXTPDockingPaneSidePanel | protected
CreateContainer() | CXTPDockingPaneBase | protectedvirtual
CXTPDockingPaneBase(XTPDockingPaneType type, CXTPDockingPaneLayout *pLayout) | CXTPDockingPaneBase | protected
CXTPDockingPaneBaseContainer(XTPDockingPaneType type, CXTPDockingPaneLayout *pLayout) | CXTPDockingPaneBaseContainer | protected
CXTPDockingPaneSidePanel(CXTPDockingPaneLayout *pLayout) | CXTPDockingPaneSidePanel | protected
DeletePane()=0 | CXTPDockingPaneBase | protectedpure virtual
DoPropExchange(CXTPPropExchange *pPX) | CXTPDockingPaneSidePanel | protectedvirtual
DoSlideStep(BOOL bActivate=FALSE) | CXTPDockingPaneSidePanel | protected
Expand() | CXTPDockingPaneSidePanel |
FindCaptionButton(int nID) const | CXTPDockingPaneBase |
FindPane(XTPDockingPaneType type, CXTPDockingPaneBaseList *pList) const | CXTPDockingPaneBaseContainer | virtual
GetCaptionButtons() const | CXTPDockingPaneBase |
GetContainer() const | CXTPDockingPaneBase |
GetDirection() const | CXTPDockingPaneSidePanel |
GetDockingPaneManager() const | CXTPDockingPaneBase |
GetDockingSite() const | CXTPDockingPaneBase | virtual
GetFirstPane() const | CXTPDockingPaneBaseContainer |
GetHeadPosition() const | CXTPDockingPaneBaseContainer |
GetLastPane() const | CXTPDockingPaneBaseContainer |
GetMinMaxInfo(LPMINMAXINFO pMinMaxInfo) const | CXTPDockingPaneSidePanel | protectedvirtual
GetNext(POSITION &pos) const | CXTPDockingPaneBaseContainer |
GetPaintManager() const | CXTPDockingPaneBase |
GetPaneHwnd() const | CXTPDockingPaneSidePanel | protectedvirtual
GetPanes() | CXTPDockingPaneBaseContainer |
GetPaneWindowRect() const | CXTPDockingPaneBase |
GetSelectedPane() const | CXTPDockingPaneSidePanel |
GetTitle() const | CXTPDockingPaneSidePanel | virtual
GetTopContainer() const | CXTPDockingPaneSidePanel |
GetType() const | CXTPDockingPaneBase |
Init(CXTPDockingPaneBase *pPane, XTPDockingPaneDirection direction, CRect rc) | CXTPDockingPaneSidePanel | protected
InvalidatePane(BOOL bSelectionChanged) | CXTPDockingPaneSidePanel | protectedvirtual
IsActive() const | CXTPDockingPaneSidePanel | virtual
IsCaptionVertical() const | CXTPDockingPaneSidePanel | virtual
IsCollapsed() const | CXTPDockingPaneSidePanel |
IsEmpty() const | CXTPDockingPaneBaseContainer | protectedvirtual
IsHidden() const | CXTPDockingPaneBase | virtual
IsHorizontal() const | CXTPDockingPaneSidePanel | protected
m_bCollapsed | CXTPDockingPaneSidePanel | protected
m_bExpanded | CXTPDockingPaneSidePanel | protected
m_bSlideOut | CXTPDockingPaneSidePanel | protected
m_direction | CXTPDockingPaneSidePanel | protected
m_lstPanes | CXTPDockingPaneBaseContainer | protected
m_nDeactivationCount | CXTPDockingPaneSidePanel | protected
m_nSlideStep | CXTPDockingPaneSidePanel | protected
m_nStepsCount | CXTPDockingPaneSidePanel | protected
m_pCaptionButtons | CXTPDockingPaneBase | protected
m_pDockingSite | CXTPDockingPaneBase | protected
m_pLayout | CXTPDockingPaneBase | protected
m_pParentContainer | CXTPDockingPaneBase | protected
m_rcWindow | CXTPDockingPaneBase | protected
m_szDocking | CXTPDockingPaneBase | protected
m_type | CXTPDockingPaneBase | protected
MovePanel(XTPDockingPaneDirection direction, CRect rect) | CXTPDockingPaneSidePanel |
OnAction(XTPDockingPaneAction action) | CXTPDockingPaneBaseContainer |
OnCaptionButtonRectChanged(CXTPDockingPaneCaptionButton *pButton) | CXTPDockingPaneBase | protectedvirtual
OnChildContainerChanged(CXTPDockingPaneBase *pContainer) | CXTPDockingPaneBase | protectedvirtual
OnFocusChanged() | CXTPDockingPaneBase | protectedvirtual
OnParentContainerChanged(CXTPDockingPaneBase *pContainer) | CXTPDockingPaneBase | protectedvirtual
OnPinButtonClick() | CXTPDockingPaneSidePanel | protected
OnSizeParent(CWnd *pParent, CRect rect, LPVOID lParam) | CXTPDockingPaneBase | protectedvirtual
OnToolHitTest(CPoint point, TOOLINFO *pTI) const | CXTPDockingPaneSidePanel | protected
RedrawPane() | CXTPDockingPaneBase | virtual
RemovePane(CXTPDockingPaneBase *pPane) | CXTPDockingPaneBase | protectedvirtual
SetDockingSite(CWnd *pFrame) | CXTPDockingPaneBase | protectedvirtual
SetParentContainer(CXTPDockingPaneBase *pContainer) | CXTPDockingPaneBase | protectedvirtual
~CXTPDockingPaneBase() | CXTPDockingPaneBase | protectedvirtual
~CXTPDockingPaneBaseContainer() | CXTPDockingPaneBaseContainer | protectedvirtual
~CXTPDockingPaneSidePanel() | CXTPDockingPaneSidePanel | protected


Toolkit Pro: Member List

CXTPTearOffFrame Member List

This is the complete list of members for CXTPTearOffFrame, including all inherited members.

CXTPCommandBarsSiteBase() | CXTPCommandBarsSiteBase< CMDIFrameWnd > | inline
CXTPFrameWndBase() | CXTPFrameWndBase< CMDIFrameWnd > | inline
CXTPTearOffFrame() | CXTPTearOffFrame |
CXTPMDIFrameWnd::DECLARE_DYNCREATE(CXTPMDIFrameWnd) CXTPMDIFrameWnd() | CXTPMDIFrameWnd |
DestroyWindow() | CXTPTearOffFrame | virtual
DockRightOf(CXTPToolBar *pBarToDock, CXTPToolBar *pBarOnLeft) | CXTPCommandBarsSiteBase< CMDIFrameWnd > | inline
GetCommandBars() const | CXTPCommandBarsSiteBase< CMDIFrameWnd > | inline
GetTabClient() const | CXTPTearOffFrame |
Init(CXTPTabClientWnd *pTabClient, CXTPTabManagerItem *pTabItem) | CXTPTearOffFrame |
InitCommandBars(CRuntimeClass *pCommandBarsClass=RUNTIME_CLASS(CXTPCommandBars)) | CXTPCommandBarsSiteBase< CMDIFrameWnd > | inlinevirtual
IsFrameBeingDragged() const | CXTPTearOffFrame |
LoadCommandBars(LPCTSTR lpszProfileName, BOOL bSilent=FALSE) | CXTPCommandBarsSiteBase< CMDIFrameWnd > | inlinevirtual
m_pCommandBars | CXTPCommandBarsFrameHook | private
SaveCommandBars(LPCTSTR lpszProfileName) | CXTPCommandBarsSiteBase< CMDIFrameWnd > | inlinevirtual
Update(CXTPTabClientWnd *pTabClient) | CXTPTearOffFrame |
UpdateMDIChildrenTheme() | CXTPMDIFrameWnd |
~CXTPCommandBarsSiteBase() | CXTPCommandBarsSiteBase< CMDIFrameWnd > | inline
~CXTPFrameWndBase() | CXTPFrameWndBase< CMDIFrameWnd > | inline
~CXTPTearOffFrame() | CXTPTearOffFrame | virtual


Toolkit Pro: XTPCommandBarsColorSetVisualStudio2012.h Source File

  • Source
  • CommandBars
  • ColorSets
XTPCommandBarsColorSetVisualStudio2012.h
Go to the documentation of this file.
1
23#if !defined(__XTPCOMMANDBARSCOLORSETVISUALSTUDIO2012_H__)
24# define __XTPCOMMANDBARSCOLORSETVISUALSTUDIO2012_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
34/*
35 * CXTPCommandBarsColorSetVisualStudio2012
36 */
37
38class _XTP_EXT_CLASS CXTPCommandBarsColorSetVisualStudio2012 : public CXTPCommandBarsColorSet
39{
40public:
41 CXTPCommandBarsColorSetVisualStudio2012();
42
43 virtual void RefreshColors(const CXTPResourceImages* pImages);
44};
45
47// CXTPCommandBarsColorSetVisualStudio2012Light
48
49class _XTP_EXT_CLASS CXTPCommandBarsColorSetVisualStudio2012Light : public CXTPCommandBarsColorSet
50{
51public:
52 CXTPCommandBarsColorSetVisualStudio2012Light();
53
54 virtual void RefreshColors(const CXTPResourceImages* pImages);
55};
56
58// CXTPCommandBarsColorSetVisualStudio2012Dark
59
60class _XTP_EXT_CLASS CXTPCommandBarsColorSetVisualStudio2012Dark : public CXTPCommandBarsColorSet
61{
62public:
63 CXTPCommandBarsColorSetVisualStudio2012Dark();
64
65 virtual void RefreshColors(const CXTPResourceImages* pImages);
66};
68# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
69#endif // !defined(__XTPCOMMANDBARSCOLORSETVISUALSTUDIO2012_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPResourceImages
Implements resource image collection and its operations.
Definition XTPResourceImage.h:257


Toolkit Pro: XTPChart2dPieDiagram.h Source File

  • Source
  • Chart
  • Styles
  • Pie
  • 2D
XTPChart2dPieDiagram.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHART2DPIEDIAGRAM_H__)
24# define __XTPCHART2DPIEDIAGRAM_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartPieBase;
34class CXTPChartDiagramDomain;
35
47class _XTP_EXT_CLASS CXTPChartPieDiagram : public CXTPChart2dPieDiagramBase
48{
50 DECLARE_SERIAL(CXTPChartPieDiagram)
52public:
57 CXTPChartPieDiagram();
58
59public:
70 virtual CXTPChartDiagramView* CreateView(CXTPChartDeviceContext* pDC,
71 CXTPChartElementView* pParent);
72
73# ifdef _XTP_ACTIVEX
74public:
76 DECLARE_DISPATCH_MAP()
77 DECLARE_INTERFACE_MAP()
78 DECLARE_OLETYPELIB_EX(CXTPChartPieDiagram);
79 DECLARE_OLECREATE_EX(CXTPChartPieDiagram)
81# endif
82};
84# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
85#endif //#if !defined(__XTPCHART2DPIEDIAGRAM_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartDiagramDomain
Represents a virtual diagram rectangular domain area.
Definition XTPChartDiagram.h:159
CXTPChartDiagramView
This class represents the view of a chart diagram, which is a kind of CXTPChartElementView.
Definition XTPChartDiagramView.h:49
CXTPChartElementView
This class represents the view of a chart element.
Definition XTPChartElementView.h:47
CXTPChartPieBase
This class abstracts a pie chart.
Definition XTPChartPie.h:176
CXTPChartPieDiagramBase
This class abstracts the pie diagram.
Definition XTPChartPieDiagramBase.h:62
CXTPChartPieDiagram
This class abstracts the pie diagram.
Definition XTPChart2dPieDiagram.h:48
CXTPChartPieDiagram::CXTPChartPieDiagram
CXTPChartPieDiagram()
Constructs a CXTPChartPieDiagram object.
CXTPChartPieDiagram::CreateView
virtual CXTPChartDiagramView * CreateView(CXTPChartDeviceContext *pDC, CXTPChartElementView *pParent)
Call this function to create the view of the pie diagram.


Toolkit Pro: XTPGridThickness.h Source File

  • Source
  • GridControl
XTPGridThickness.h
Go to the documentation of this file.
1
23#if !defined(__XTPGRIDTHICKNESS_H__)
24# define __XTPGRIDTHICKNESS_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPGridThickness : public CXTPCmdTarget
39{
40public:
46 CXTPGridThickness();
47
54 CXTPGridThickness(const CXTPGridThickness& thickness);
55
62 CXTPGridThickness(const int nThickness);
63
73 CXTPGridThickness(const int nLeft, const int nTop, const int nRight, const int nBottom);
74
80 void Set(const CXTPGridThickness& thickness);
81
87 void Set(const int nThickness);
88
97 void Set(const int nLeft, const int nTop, const int nRight, const int nBottom);
98
105 int GetLeft() const;
106
112 void SetLeft(const int nThickness);
113
120 int GetTop() const;
121
127 void SetTop(const int nThickness);
128
135 int GetRight() const;
136
142 void SetRight(const int nThickness);
143
150 int GetBottom() const;
151
157 void SetBottom(const int nThickness);
158
159 CSize GetSize() const;
160
167 CXTPGridThickness& operator=(const CXTPGridThickness& thickness);
168
175 CXTPGridThickness& operator=(const int nThickness);
176
177 static CRect AFX_CDECL DeflateRect(CRect rcDeflate, const CXTPGridThickness* pThickness);
178
179protected:
180 int m_nLeft;
181 int m_nTop;
182 int m_nRight;
183 int m_nBottom;
184};
185
188# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
189#endif // #if !defined(__XTPGRIDTHICKNESS_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPGridThickness
The CXTPGridThickness class describes the thickness of the left, top, right, and bottom sides of a re...
Definition XTPGridThickness.h:39
CXTPGridThickness::operator=
CXTPGridThickness & operator=(const CXTPGridThickness &thickness)
Sets the left, top, right, and bottom thickness.
CXTPGridThickness::Set
void Set(const CXTPGridThickness &thickness)
Sets the left, top, right, and bottom thickness.
CXTPGridThickness::Set
void Set(const int nLeft, const int nTop, const int nRight, const int nBottom)
Sets the left, top, right, and bottom thickness.
CXTPGridThickness::SetRight
void SetRight(const int nThickness)
Sets the right thickness.
CXTPGridThickness::CXTPGridThickness
CXTPGridThickness(const int nThickness)
Constructs a CXTPGridThickness object and sets the left, top, right, and bottom thickness.
CXTPGridThickness::SetBottom
void SetBottom(const int nThickness)
Sets the bottom thickness.
CXTPGridThickness::SetLeft
void SetLeft(const int nThickness)
Sets the left thickness.
CXTPGridThickness::m_nTop
int m_nTop
Top thickness.
Definition XTPGridThickness.h:181
CXTPGridThickness::SetTop
void SetTop(const int nThickness)
Sets the top thickness.
CXTPGridThickness::CXTPGridThickness
CXTPGridThickness(const int nLeft, const int nTop, const int nRight, const int nBottom)
Constructs a CXTPGridThickness object and sets the left, top, right, and bottom thickness.
CXTPGridThickness::operator=
CXTPGridThickness & operator=(const int nThickness)
Sets the left, top, right, and bottom thickness.
CXTPGridThickness::GetLeft
int GetLeft() const
Gets the left thickness.
CXTPGridThickness::m_nLeft
int m_nLeft
Left thickness.
Definition XTPGridThickness.h:180
CXTPGridThickness::CXTPGridThickness
CXTPGridThickness()
Constructs a CXTPGridThickness object and sets the left, top, right, and bottom thickness to 0.
CXTPGridThickness::Set
void Set(const int nThickness)
Sets the left, top, right, and bottom thickness.
CXTPGridThickness::m_nRight
int m_nRight
Right thickness.
Definition XTPGridThickness.h:182
CXTPGridThickness::GetBottom
int GetBottom() const
Gets the bottom thickness.
CXTPGridThickness::GetTop
int GetTop() const
Gets the top thickness.
CXTPGridThickness::GetRight
int GetRight() const
Gets the right thickness.
CXTPGridThickness::m_nBottom
int m_nBottom
Bottom thickness.
Definition XTPGridThickness.h:183
CXTPGridThickness::CXTPGridThickness
CXTPGridThickness(const CXTPGridThickness &thickness)
Constructs a CXTPGridThickness object and sets the left, top, right, and bottom thickness.


Toolkit Pro: Member List

  • CXTPCalendarMonthView
  • CMonthViewGrid
CXTPCalendarMonthView::CMonthViewGrid Member List

This is the complete list of members for CXTPCalendarMonthView::CMonthViewGrid, including all inherited members.

AdjustDays(CDC *pDC) | CXTPCalendarMonthView::CMonthViewGrid |
AdjustEvents(CDC *pDC) | CXTPCalendarMonthView::CMonthViewGrid |
AdjustFirstDayOfWeek() | CXTPCalendarMonthView::CMonthViewGrid |
AdjustGrid(const CRect &rcRect) | CXTPCalendarMonthView::CMonthViewGrid |
AdjustHeader(CDC *pDC) | CXTPCalendarMonthView::CMonthViewGrid | protected
AdjustLayout(CDC *pDC) | CXTPCalendarMonthView::CMonthViewGrid |
CMonthViewGrid(CXTPCalendarMonthView *pView) | CXTPCalendarMonthView::CMonthViewGrid |
Draw(CDC *pDC) | CXTPCalendarMonthView::CMonthViewGrid |
GetBeginDate() const | CXTPCalendarMonthView::CMonthViewGrid |
GetCelRect(int nWeekIndex, int nColIndex, BOOL bIncludeBorders=FALSE) const | CXTPCalendarMonthView::CMonthViewGrid |
GetColHeaderHeight() const | CXTPCalendarMonthView::CMonthViewGrid |
GetColsCount() const | CXTPCalendarMonthView::CMonthViewGrid |
GetDayDate(int nWeekIndex, int nWeekDayIndex) const | CXTPCalendarMonthView::CMonthViewGrid |
GetDayRect(int nWeekIndex, int nWeekDayIndex, BOOL bIncludeBorders=FALSE) const | CXTPCalendarMonthView::CMonthViewGrid |
GetFirstDayOfWeek() const | CXTPCalendarMonthView::CMonthViewGrid |
GetMaxDayPOS() const | CXTPCalendarMonthView::CMonthViewGrid |
GetMiddleScrollBeginDate() const | CXTPCalendarMonthView::CMonthViewGrid | protected
GetScrollPos() const | CXTPCalendarMonthView::CMonthViewGrid |
GetViewDay(int nWeekIndex, int nWeekDayIndex) const | CXTPCalendarMonthView::CMonthViewGrid |
GetWeekDayCol(int nWeekDayIndex) const | CXTPCalendarMonthView::CMonthViewGrid |
GetWeekDayForColIndex(int nColIdx) const | CXTPCalendarMonthView::CMonthViewGrid |
GetWeeksCount() const | CXTPCalendarMonthView::CMonthViewGrid |
m_arColHeaderText | CXTPCalendarMonthView::CMonthViewGrid | protected
m_arColsLeftX | CXTPCalendarMonthView::CMonthViewGrid | protected
m_arRowsTopY | CXTPCalendarMonthView::CMonthViewGrid | protected
m_dtBeginDate | CXTPCalendarMonthView::CMonthViewGrid | protected
m_nColHeaderHeight | CXTPCalendarMonthView::CMonthViewGrid | protected
m_nFirstDayOfWeekIndex | CXTPCalendarMonthView::CMonthViewGrid | protected
m_nWeeksCount | CXTPCalendarMonthView::CMonthViewGrid | protected
m_pView | CXTPCalendarMonthView::CMonthViewGrid | protected
ScrollV(int nPos) | CXTPCalendarMonthView::CMonthViewGrid |
SetBeginDate(COleDateTime dtBeginDate) | CXTPCalendarMonthView::CMonthViewGrid |
SetColHeaderHeight(int nHeight) | CXTPCalendarMonthView::CMonthViewGrid |
SetWeeksCount(int nWeeks) | CXTPCalendarMonthView::CMonthViewGrid |
ShiftDateToCell_00(COleDateTime dtDate) const | CXTPCalendarMonthView::CMonthViewGrid |
~CMonthViewGrid() | CXTPCalendarMonthView::CMonthViewGrid | virtual


Toolkit Pro: Member List

CXTPChartDiagram2DAxisView Member List

This is the complete list of members for CXTPChartDiagram2DAxisView, including all inherited members.

AddChildView(CXTPChartElementView *pChildView) | CXTPChartElementView |
CalcSize(CXTPChartDeviceContext *pDC, CRect rcDiagram) | CXTPChartDiagram2DAxisView |
CreateConstantLinesDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcPane, BOOL bBehind) | CXTPChartDiagram2DAxisView | virtual
CreateDeviceCommand(CXTPChartDeviceContext *pDC) | CXTPChartDiagram2DAxisView | virtual
CreateGridLinesDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcPane) | CXTPChartDiagram2DAxisView | virtual
CreateInterlacedDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcPane) | CXTPChartDiagram2DAxisView | virtual
CreateLabelsDeviceCommand(CXTPChartDeviceContext *pDC) | CXTPChartDiagram2DAxisView | virtual
CreateStripsDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcPane) | CXTPChartDiagram2DAxisView | virtual
CreateTickMarks(CXTPChartDeviceContext *pDC, CRect rcDiagram) | CXTPChartDiagram2DAxisView | protected
CreateTickMarksDeviceCommand(CXTPChartDeviceContext *pDC) | CXTPChartDiagram2DAxisView | virtual
CreateTitleDeviceCommand(CXTPChartDeviceContext *pDC) | CXTPChartDiagram2DAxisView | virtual
CreateView(CXTPChartDeviceContext *pDC) | CXTPChartDiagram2DAxisView |
CXTPChartDiagram2DAxisView(CXTPChartAxis *pAxis, CXTPChartElementView *pParentView) | CXTPChartDiagram2DAxisView |
CXTPChartElementView(CXTPChartElementView *pParentView) | CXTPChartElementView |
CXTPChartElementView(CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartElementView |
CXTPChartElementView(CXTPChartContainer *pContainer) | CXTPChartElementView |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
DistanceToPoint(double nDistance) const | CXTPChartDiagram2DAxisView |
GetAt(int nIndex) const | CXTPChartElementView |
CXTPChartAxisView::GetBounds(BOOL bIncludingChildren) const | CXTPChartElementView |
GetChildren() | CXTPChartElementView |
GetCount() const | CXTPChartElementView |
GetParentView() const | CXTPChartElementView |
GetSize() const | CXTPChartDiagram2DAxisView |
Is3D() const | CXTPChartObject |
IsVertical() const | CXTPChartDiagram2DAxisView |
m_arrChildren | CXTPChartElementView | protected
m_arrTicks | CXTPChartDiagram2DAxisView |
m_nSize | CXTPChartDiagram2DAxisView | protected
m_pContainer | CXTPChartElementView | protected
m_pParentView | CXTPChartElementView | protected
m_rcBounds | CXTPChartDiagram2DAxisView | protected
SetBounds(CXTPChartDeviceContext *pDC, CRect rcBounds) | CXTPChartDiagram2DAxisView |
ValueToPoint(double nValue) const | CXTPChartDiagram2DAxisView |
~CXTPChartDiagram2DAxisView() | CXTPChartDiagram2DAxisView |
~CXTPChartElementView() | CXTPChartElementView | protectedvirtual


Toolkit Pro: XTPDockingPanePanelColorSet2015.h Source File

  • Source
  • DockingPane
  • TabColorSets
XTPDockingPanePanelColorSet2015.h
Go to the documentation of this file.
1
23#if !defined(__XTPDOCKINGPANEPANELCOLORSET2015_H__)
24# define __XTPDOCKINGPANEPANELCOLORSET2015_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPDockingPanePanelColorSet2015 : public CXTPDockingPanePanelColorSet2012
39{
40public:
45 CXTPDockingPanePanelColorSet2015();
46
52 virtual void RefreshMetrics();
53};
54
55# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
57#endif // !defined(__XTPDOCKINGPANEPANELCOLORSET2015_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPDockingPanePanelColorSet2012
Helper class used to initialize default colors for a theme from an .INI resource and handle drawing r...
Definition XTPDockingPanePanelColorSet2012.h:39
CXTPDockingPanePanelColorSet2015
Helper class used to initialize default colors for a theme from an .INI resource and handle drawing r...
Definition XTPDockingPanePanelColorSet2015.h:39
CXTPDockingPanePanelColorSet2015::CXTPDockingPanePanelColorSet2015
CXTPDockingPanePanelColorSet2015()
Default class constructor.
CXTPDockingPanePanelColorSet2015::RefreshMetrics
virtual void RefreshMetrics()
This member function is used to initialize default colors for a theme from an .INI resource.


Toolkit Pro: Member List

CXTPMarqueeCtrlThemeResource Member List

This is the complete list of members for CXTPMarqueeCtrlThemeResource, including all inherited members.

CXTPMarqueeCtrlPaintManager() | CXTPMarqueeCtrlPaintManager |
CXTPMarqueeCtrlThemeOffice2000() | CXTPMarqueeCtrlThemeOffice2000 |
CXTPMarqueeCtrlThemeResource() | CXTPMarqueeCtrlThemeResource |
DeflateRect(CDC *pDC, CRect &rcClient) | CXTPMarqueeCtrlPaintManager | protectedvirtual
DrawBackground(CXTPMarqueeCtrl *pWndCtrl, CDC *pDC, CRect &rcClient) | CXTPMarqueeCtrlThemeResource | virtual
DrawChunk(CXTPMarqueeCtrl *pWndCtrl, CDC *pDC, CXTPCompatibleDC &dcChunk, int i, int &x, int &y, int cx, int cy) | CXTPMarqueeCtrlThemeResource | virtual
DrawMarquee(CXTPMarqueeCtrl *pWndCtrl, CDC *pDC, CRect &rcClient) | CXTPMarqueeCtrlPaintManager | virtual
GetBackColor() | CXTPMarqueeCtrlPaintManager |
GetBarColor() | CXTPMarqueeCtrlPaintManager |
GetBorderColor() | CXTPMarqueeCtrlPaintManager |
m_bUseWinTheme | CXTPMarqueeCtrlPaintManager | protected
m_clr3DHilite | CXTPMarqueeCtrlPaintManager | protected
m_clr3DShadow | CXTPMarqueeCtrlPaintManager | protected
m_clrBack | CXTPMarqueeCtrlPaintManager | protected
m_clrBar | CXTPMarqueeCtrlPaintManager | protected
m_nTheme | CXTPMarqueeCtrlPaintManager | protected
m_winTheme | CXTPMarqueeCtrlPaintManager | protected
RefreshMetrics() | CXTPMarqueeCtrlThemeOffice2000 | virtual
SetBackColor(COLORREF clrNew) | CXTPMarqueeCtrlPaintManager |
SetBarColor(COLORREF clrNew) | CXTPMarqueeCtrlPaintManager |
SetBorderColor(COLORREF clrNew) | CXTPMarqueeCtrlPaintManager |
UseWinThemes(BOOL bUseWinThemes=TRUE) | CXTPMarqueeCtrlPaintManager |
UsingWinThemes(BOOL bCheckReady=FALSE) | CXTPMarqueeCtrlPaintManager |
~CXTPMarqueeCtrlPaintManager() | CXTPMarqueeCtrlPaintManager | virtual


Toolkit Pro: Member List

CXTPPasswordPeek Member List

This is the complete list of members for CXTPPasswordPeek, including all inherited members.

AdjustBuddyRect(CWnd *pBuddy, CRect &rcUpDown, int nAlignment) | CXTPEdit |
CanOverType() const | CXTPMaskEditT< CEdit > | inline
CanPaste() | CXTPEdit | virtual
CanUseMask() const | CXTPMaskEditT< CEdit > | inline
CheckChar(TCHAR &nChar, int nPos) | CXTPMaskEditT< CEdit > | inlinevirtual
ConvertUnicodeAlpha(TCHAR nChar, BOOL bUpperCase) const | CXTPMaskEditT< CEdit > | inline
CopyToClipboard(const CString &strText) | CXTPMaskEditT< CEdit > | inline
CXTPEdit() | CXTPEdit |
CXTPMaskEditT() | CXTPMaskEditT< CEdit > | inline
CXTPPasswordPeek() | CXTPPasswordPeek |
DeleteCharAt(int iPos) | CXTPMaskEditT< CEdit > | inline
DrawBuddyBorders(CWnd *pBuddy, CDC *pDC, CRect rc, int nAlignment) | CXTPEdit |
GetClientBrush(CDC *pDC) | CXTPEdit | protected
GetFlatStyle() const | CXTPEdit |
GetImageManager() | CXTPPasswordPeek |
GetMaskedText(int nStartPos=0, int nEndPos=-1) const | CXTPMaskEditT< CEdit > | inline
GetPromptChar() const | CXTPMaskEditT< CEdit > | inline
GetPromptString(int nLength) const | CXTPMaskEditT< CEdit > | inline
GetTheme() | CXTPEdit |
GetThemeID() | CXTPEdit |
GetUseVisualStyle() const | CXTPEdit |
HasSelection() const | CXTPEdit |
InitIcons() | CXTPPasswordPeek | virtual
InsertCharAt(int iPos, TCHAR nChar) | CXTPMaskEditT< CEdit > | inline
IsFlatStyle() const | CXTPEdit |
IsFocused() const | CXTPEdit |
IsHighlighted() const | CXTPEdit |
IsModified() const | CXTPMaskEditT< CEdit > | inline
IsPatternValid() | CXTPEdit |
IsPeekButtonEnabled() | CXTPPasswordPeek |
m_bFocused | CXTPEdit | protected
m_bHighlighted | CXTPEdit | protected
m_bModified | CXTPMaskEditT< CEdit > | protected
m_bOverType | CXTPMaskEditT< CEdit > | protected
m_bPreSubclassInit | CXTPEdit | protected
m_bRedo | CXTPMaskEditT< CEdit > | protected
m_bShowBorder | CXTPEdit | protected
m_bUpdateUndo | CXTPMaskEditT< CEdit > | protected
m_bUseMask | CXTPMaskEditT< CEdit > | protected
m_chPrompt | CXTPMaskEditT< CEdit > | protected
m_nEndChar | CXTPMaskEditT< CEdit > | protected
m_nStartChar | CXTPMaskEditT< CEdit > | protected
m_pRegExp | CXTPEdit | protected
m_pTheme | CXTPEdit | protected
m_strDefault | CXTPMaskEditT< CEdit > | protected
m_strLiteral | CXTPMaskEditT< CEdit > | protected
m_strMask | CXTPMaskEditT< CEdit > | protected
m_strRedoBuffer | CXTPMaskEditT< CEdit > | protected
m_strUndoBuffer | CXTPMaskEditT< CEdit > | protected
m_strWindowText | CXTPMaskEditT< CEdit > | protected
MaskClear() | CXTPMaskEditT< CEdit > | inline
MaskCopy() | CXTPMaskEditT< CEdit > | inline
MaskCut() | CXTPMaskEditT< CEdit > | inline
MaskDeleteSel() | CXTPMaskEditT< CEdit > | inline
MaskPaste() | CXTPMaskEditT< CEdit > | inline
MaskReplaceSel(LPCTSTR lpszNewText) | CXTPMaskEditT< CEdit > | inline
MaskSelectAll() | CXTPMaskEditT< CEdit > | inline
MaskUndo() | CXTPMaskEditT< CEdit > | inline
OnChangeLayout() | CXTPPasswordPeek | virtual
OnCommand(WPARAM wParam, LPARAM lParam) | CXTPMaskEditT< CEdit > | inlineprotectedvirtual
OnDrawButton(CDC *pDC, CRect rect, BOOL bIsButtonPressed, BOOL bIsButtonHot) | CXTPPasswordPeek | virtual
PeekButtonEnable(BOOL bEnable=TRUE) | CXTPPasswordPeek |
PosInRange(int iPos) const | CXTPMaskEditT< CEdit > | inline
PreTranslateMessage(MSG *pMsg) | CXTPMaskEditT< CEdit > | inlinevirtual
ProcessMask(TCHAR &nChar, int nEndPos) | CXTPMaskEditT< CEdit > | inlinevirtual
RedrawEdit() | CXTPEdit | protected
RedrawFocusedFrame() | CXTPEdit | protected
RefreshMetrics() | CXTPEdit | virtual
SetEditMask(LPCTSTR lpszMask, LPCTSTR lpszLiteral, LPCTSTR lpszDefault=NULL) | CXTPEdit | virtual
SetFlatStyle(BOOL bFlatStyle=TRUE) | CXTPEdit |
SetImageManager(CXTPImageManager *pImageManager) | CXTPPasswordPeek |
SetMaskedText(LPCTSTR lpszMaskedText, int iPos=0, BOOL bUpdateWindow=TRUE) | CXTPMaskEditT< CEdit > | inline
SetOverType(BOOL bOverType) | CXTPMaskEditT< CEdit > | inline
SetPattern(LPCTSTR lpszPattern) | CXTPEdit |
SetPromptChar(TCHAR ch, BOOL bAutoReplace=TRUE) | CXTPMaskEditT< CEdit > | inline
SetTheme(XTPControlTheme nTheme) | CXTPEdit | virtual
SetUseMask(BOOL bUseMask) | CXTPMaskEditT< CEdit > | inline
SetUseVisualStyle(BOOL bUseVisualStyle=TRUE) | CXTPEdit |
ShowBorder() const | CXTPEdit |
ShowThemedBorder(BOOL bShowThemedBorder) | CXTPEdit |
~CXTPEdit() | CXTPEdit | virtual
~CXTPPasswordPeek() | CXTPPasswordPeek | virtual


Toolkit Pro: XTPChartFunnelSeriesLabelBase.h Source File

  • Source
  • Chart
  • Styles
  • Funnel
  • Base
XTPChartFunnelSeriesLabelBase.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTFUNNELSERIESLABELBASE_H__)
24# define __XTPCHARTFUNNELSERIESLABELBASE_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartSeriesView;
34class CXTPChartFunnelSeriesPointView;
35class CXTPChartFunnelSeriesStyleBase;
36
41enum XTPChartFunnelLabelPosition
42{
43 xtpChartFunnelLabelLeft,
44 xtpChartFunnelLabelRight,
45 xtpChartFunnelLabelCenter,
46};
47
53class _XTP_EXT_CLASS CXTPChartFunnelSeriesLabelBase : public CXTPChartSeriesLabel
54{
56 DECLARE_DYNAMIC(CXTPChartFunnelSeriesLabelBase)
58public:
63 CXTPChartFunnelSeriesLabelBase();
64
69 virtual ~CXTPChartFunnelSeriesLabelBase();
70
71public:
79 XTPChartFunnelLabelPosition GetPosition() const;
80
88 void SetPosition(XTPChartFunnelLabelPosition nPosition);
89
97 CXTPChartFunnelSeriesStyleBase* GetStyle() const;
98
105 void DoPropExchange(CXTPPropExchange* pPX);
106
114 BOOL IsInside() const;
115
116protected:
128 virtual CXTPChartElementView* CreateView(CXTPChartDeviceContext* pDC,
129 CXTPChartSeriesPointView* pPointView,
130 CXTPChartElementView* pParentView) = 0;
131
132 XTPChartFunnelLabelPosition m_nPosition;
134# ifdef _XTP_ACTIVEX
135public:
137 DECLARE_DISPATCH_MAP()
138 DECLARE_INTERFACE_MAP()
139 DECLARE_OLETYPELIB_EX(CXTPChartPunnelSeriesLabelBase);
141# endif
142};
143
144AFX_INLINE XTPChartFunnelLabelPosition CXTPChartFunnelSeriesLabelBase::GetPosition() const
145{
146 return m_nPosition;
147}
148AFX_INLINE void CXTPChartFunnelSeriesLabelBase::SetPosition(XTPChartFunnelLabelPosition nPosition)
149{
150 m_nPosition = nPosition;
151 OnChartChanged();
152}
153
158class CXTPChartFunnelSeriesLabelViewBase : public CXTPChartSeriesLabelView
159{
160 DECLARE_DYNAMIC(CXTPChartFunnelSeriesLabelViewBase);
161
162protected:
171 CXTPChartFunnelSeriesLabelViewBase(CXTPChartSeriesLabel* pLabel,
172 CXTPChartSeriesPointView* pPointView,
173 CXTPChartElementView* pParentView);
174
175public:
183 XTPChartFunnelLabelPosition GetPosition() const;
184
195 virtual CXTPChartDeviceCommand* CreateDeviceCommand(CXTPChartDeviceContext* pDC) = 0;
196};
198# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
199#endif //#if !defined(__XTPCHARTFUNNELSERIESLABELBASE_H__)
XTPChartFunnelLabelPosition
XTPChartFunnelLabelPosition
This enumeration tells the various positions available for the funnel label.
Definition XTPChartFunnelSeriesLabelBase.h:42
xtpChartFunnelLabelRight
@ xtpChartFunnelLabelRight
Specifies right chart label direction.
Definition XTPChartFunnelSeriesLabelBase.h:44
xtpChartFunnelLabelCenter
@ xtpChartFunnelLabelCenter
Specifies center chart label direction.
Definition XTPChartFunnelSeriesLabelBase.h:45
xtpChartFunnelLabelLeft
@ xtpChartFunnelLabelLeft
Specifies left chart label direction.
Definition XTPChartFunnelSeriesLabelBase.h:43
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartElement::OnChartChanged
virtual void OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic propertie...
CXTPChartElementView
This class represents the view of a chart element.
Definition XTPChartElementView.h:47
CXTPChartFunnelSeriesLabelBase
CXTPChartFunnelSeriesLabelBase is a kind of CXTPChartSeriesLabel.
Definition XTPChartFunnelSeriesLabelBase.h:54
CXTPChartFunnelSeriesLabelBase::DoPropExchange
void DoPropExchange(CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
CXTPChartFunnelSeriesLabelBase::GetStyle
CXTPChartFunnelSeriesStyleBase * GetStyle() const
Call this function to get the basic style of the funnel series.
CXTPChartFunnelSeriesLabelBase::m_nPosition
XTPChartFunnelLabelPosition m_nPosition
The funnel label position.
Definition XTPChartFunnelSeriesLabelBase.h:132
CXTPChartFunnelSeriesLabelBase::CXTPChartFunnelSeriesLabelBase
CXTPChartFunnelSeriesLabelBase()
Constructs a CXTPChartFunnelSeriesLabelBase object.
CXTPChartFunnelSeriesLabelBase::GetPosition
XTPChartFunnelLabelPosition GetPosition() const
Call this function to get the label position.
Definition XTPChartFunnelSeriesLabelBase.h:144
CXTPChartFunnelSeriesLabelBase::~CXTPChartFunnelSeriesLabelBase
virtual ~CXTPChartFunnelSeriesLabelBase()
Destroys a CXTPChartFunnelSeriesLabelBase object, handles cleanup.
CXTPChartFunnelSeriesLabelBase::SetPosition
void SetPosition(XTPChartFunnelLabelPosition nPosition)
Call this function to set the label position.
Definition XTPChartFunnelSeriesLabelBase.h:148
CXTPChartFunnelSeriesLabelBase::IsInside
BOOL IsInside() const
Call this function to check whether the label is inside the funnel.
CXTPChartFunnelSeriesLabelBase::CreateView
virtual CXTPChartElementView * CreateView(CXTPChartDeviceContext *pDC, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView)=0
This function creates the view of the funnel series.
CXTPChartFunnelSeriesLabelViewBase
This class abstracts the view of a funnel series label.
Definition XTPChartFunnelSeriesLabelBase.h:159
CXTPChartFunnelSeriesLabelViewBase::GetPosition
XTPChartFunnelLabelPosition GetPosition() const
Obtains label position.
CXTPChartFunnelSeriesLabelViewBase::CreateDeviceCommand
virtual CXTPChartDeviceCommand * CreateDeviceCommand(CXTPChartDeviceContext *pDC)=0
Creates view drawing device command for the device context specified.
CXTPChartFunnelSeriesLabelViewBase::CXTPChartFunnelSeriesLabelViewBase
CXTPChartFunnelSeriesLabelViewBase(CXTPChartSeriesLabel *pLabel, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView)
Constructs a CXTPChartFunnelSeriesLabelViewBase object.
CXTPChartFunnelSeriesPointView
This class abstracts the view of a funnel series point.
Definition XTPChart2dFunnelSeriesPointView.h:49
CXTPChartFunnelSeriesStyleBase
This class abstracts the basic style of a funnel serie.This class is a kind of CXTPChartSeriesStyle.
Definition XTPChartFunnelSeriesStyleBase.h:49
CXTPChartSeriesLabel
This class abstracts the label of a series.
Definition XTPChartSeriesLabel.h:49
CXTPChartSeriesPointView
Represents chart series point view.
Definition XTPChartSeriesPointView.h:48
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72


Toolkit Pro: XTPWebView2.h Source File

  • Source
  • Controls
  • WebBrowser
  • Providers
  • WebView2
XTPWebView2.h
Go to the documentation of this file.
1
23#if !defined(__XTPWEBVIEW2_H__)
24# define __XTPWEBVIEW2_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "rpc.h"
32# include "rpcndr.h"
33# include "objidl.h"
34# include "oaidl.h"
35
40# define XTP_BROWSER_WEBVIEW_MIN_VC_VERSION 1900
41
42# if _MSC_VER >= XTP_BROWSER_WEBVIEW_MIN_VC_VERSION
43// Indicates that WebView2 web browser provider is supported by the current compiler.
44# define XTP_BROWSER_WEBVIEW_SUPPORTED
45# endif
46
48# ifdef DEFINE_ENUM_FLAG_OPERATORS
49# define XTP_DEFINE_ENUM_FLAG_OPERATORS_DISABLED
50# pragma push_macro("DEFINE_ENUM_FLAG_OPERATORS")
51# undef DEFINE_ENUM_FLAG_OPERATORS
52# endif
53
54# define DEFINE_ENUM_FLAG_OPERATORS(unused)
55
56# include "Controls/WebBrowser/Providers/WebView2/WebView2.h"
57
58# undef DEFINE_ENUM_FLAG_OPERATORS
59
60# ifdef XTP_DEFINE_ENUM_FLAG_OPERATORS_DISABLED
61# pragma pop_macro("DEFINE_ENUM_FLAG_OPERATORS")
62# undef XTP_DEFINE_ENUM_FLAG_OPERATORS_DISABLED
63# endif
64
65#endif


Toolkit Pro: Member List

CXTPDockingPaneVisualStudio2015Theme Member List

This is the complete list of members for CXTPDockingPaneVisualStudio2015Theme, including all inherited members.

AdjustCaptionRect(const CXTPDockingPaneTabbedContainer *pPane, CRect &rc) | CXTPDockingPaneVisualStudio2012Theme | virtual
CXTPDockingPaneDefaultTheme::AdjustCaptionRect(const CXTPDockingPaneSidePanel *pPane, CRect &rc) | CXTPDockingPanePaintManager | virtual
AdjustClientRect(CXTPDockingPaneTabbedContainer *pPane, CRect &rc, BOOL bApply) | CXTPDockingPaneVisualStudio2012Theme | virtual
CXTPDockingPaneDefaultTheme::AdjustClientRect(CXTPDockingPaneSidePanel *pPane, CRect &rect) | CXTPDockingPanePaintManager | virtual
ClipAndAddEllipsisIfNeeded(CDC *pDC, CString &strTitle, int nCaptionWidth) const | CXTPDockingPanePaintManager | protected
CXTPCmdTarget() | CXTPCmdTarget |
CXTPDockingPaneDefaultTheme() | CXTPDockingPaneDefaultTheme |
CXTPDockingPanePaintManager() | CXTPDockingPanePaintManager | protected
CXTPDockingPaneVisualStudio2012Theme() | CXTPDockingPaneVisualStudio2012Theme |
CXTPDockingPaneVisualStudio2015Theme() | CXTPDockingPaneVisualStudio2015Theme |
DeletePaneColorSets() | CXTPDockingPaneVisualStudio2012Theme | protected
DrawAutoHidePanel(CDC *pDC, CRect rc, XTPDockingPaneDirection direction) | CXTPDockingPaneVisualStudio2015Theme | virtual
DrawCaption(CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc) | CXTPDockingPaneVisualStudio2012Theme | virtual
DrawCaptionButton(CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton) | CXTPDockingPaneVisualStudio2012Theme | virtual
DrawCaptionButtonEntry(CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton, CSize szOffset) | CXTPDockingPanePaintManager | protectedvirtual
DrawCaptionButtonEntry(CDC *pDC, CXTPDockingPaneCaptionButton *pButton, CPoint pt, COLORREF clrButton) | CXTPDockingPanePaintManager | protectedvirtual
DrawCaptionButtons(CDC *pDC, CXTPDockingPaneCaptionButtons *pButtons, CRect &rcCaption, COLORREF clr, int nButtonSize, int nButtonGap, BOOL bVertical=FALSE) | CXTPDockingPanePaintManager | virtual
DrawCaptionPart(CDC *pDC, CXTPDockingPaneBase *pPane, CRect rcCaption, const CString &strTitle, BOOL bActive, BOOL bVertical) | CXTPDockingPaneDefaultTheme | protectedvirtual
DrawCaptionText(CDC *pDC, const CString &strTitle, CRect rc, BOOL bVertical, BOOL bCalcWidth=FALSE) | CXTPDockingPanePaintManager |
DrawDottedLine(CDC *pDC, int x, int y, int nSize, COLORREF clr, BOOL bVertical) | CXTPDockingPaneVisualStudio2012Theme | protected
DrawFloatingFrame(CDC *pDC, CXTPDockingPaneMiniWnd *pPane, CRect rc) | CXTPDockingPaneVisualStudio2012Theme | virtual
DrawGripper(CDC *pDC, CRect rcGripper, COLORREF clr, BOOL bVertical) | CXTPDockingPaneVisualStudio2012Theme | protected
DrawPane(CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc) | CXTPDockingPaneVisualStudio2012Theme | virtual
DrawSidePanel(CDC *pDC, CXTPDockingPaneSidePanel *pPane, CRect rc) | CXTPDockingPaneVisualStudio2012Theme | virtual
DrawSplitter(CDC *pDC, CXTPDockingPaneSplitterWnd *pSplitter) | CXTPDockingPaneVisualStudio2015Theme | virtual
DrawTitleBar(CDC *pDC, CXTPDockingPaneBase *pPane, CRect rc, BOOL bVertical) | CXTPDockingPaneVisualStudio2015Theme | protectedvirtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCaptionButtonStyle() const | CXTPDockingPanePaintManager |
GetCaptionGripperRect(const CXTPDockingPaneTabbedContainer *pPane) | CXTPDockingPanePaintManager | virtual
GetCaptionHeight() const | CXTPDockingPanePaintManager |
GetCaptionRect(const CXTPDockingPaneTabbedContainer *pPane, CRect &rc) | CXTPDockingPanePaintManager | virtual
GetColorSet(BOOL bActive) | CXTPDockingPaneVisualStudio2012Theme | protectedvirtual
GetCurrentSystemTheme() const | CXTPDockingPanePaintManager |
GetCustomTitleBrush(BOOL bActive, BOOL bVertical) const | CXTPDockingPanePaintManager |
GetPaneCaptionRect(const CXTPDockingPaneSidePanel *pPane) | CXTPDockingPaneVisualStudio2012Theme | virtual
GetPanelPaintManager() const | CXTPDockingPanePaintManager |
GetSplitterStyle() const | CXTPDockingPanePaintManager |
GetTabPaintManager() const | CXTPDockingPanePaintManager |
GetTabsHeight() const | CXTPDockingPanePaintManager |
GetXtremeColor(UINT nIndex) | CXTPDockingPanePaintManager |
Line(CDC *pDC, int x0, int y0, int x1, int y1, int nPen) | CXTPDockingPanePaintManager |
Line(CDC *pDC, int x0, int y0, int x1, int y1) | CXTPDockingPanePaintManager |
m_arrColor | CXTPDockingPanePaintManager | protected
m_bDestroyCustomTitleBrushes | CXTPDockingPanePaintManager | protected
m_bDrawCaptionIcon | CXTPDockingPanePaintManager |
m_bDrawSingleTab | CXTPDockingPanePaintManager |
m_bHighlightActiveCaption | CXTPDockingPanePaintManager |
m_bLunaTheme | CXTPDockingPanePaintManager | protected
m_bShowCaption | CXTPDockingPanePaintManager |
m_bUseBoldCaptionFont | CXTPDockingPanePaintManager |
m_bUseOfficeFont | CXTPDockingPanePaintManager | protected
m_bUseStandardFont | CXTPDockingPanePaintManager | protected
m_clrActiveCaption | CXTPDockingPanePaintManager |
m_clrActiveCaptionText | CXTPDockingPanePaintManager |
m_clrBackground | CXTPDockingPanePaintManager |
m_clrCaptionBorder | CXTPDockingPaneVisualStudio2015Theme | protected
m_clrDisabledCaptionText | CXTPDockingPanePaintManager |
m_clrNormalCaption | CXTPDockingPanePaintManager |
m_clrNormalCaptionText | CXTPDockingPanePaintManager |
m_clrSplitter | CXTPDockingPanePaintManager |
m_clrSplitterGradient | CXTPDockingPanePaintManager |
m_clrSplitterGripper | CXTPDockingPanePaintManager |
m_dwSplitterStyle | CXTPDockingPanePaintManager | protected
m_hbrActiveTitleHorz | CXTPDockingPanePaintManager | protected
m_hbrActiveTitleVert | CXTPDockingPanePaintManager | protected
m_hbrInactiveTitleHorz | CXTPDockingPanePaintManager | protected
m_hbrInactiveTitleVert | CXTPDockingPanePaintManager | protected
m_nCaptionButtonStyle | CXTPDockingPanePaintManager | protected
m_nCaptionFontGap | CXTPDockingPanePaintManager | protected
m_nFontSize | CXTPDockingPaneVisualStudio2012Theme | protected
m_nSplitterIndent | CXTPDockingPanePaintManager |
m_nSplitterSize | CXTPDockingPanePaintManager |
m_nTabsHeight | CXTPDockingPanePaintManager | protected
m_nTitleHeight | CXTPDockingPanePaintManager | protected
m_pcsActive | CXTPDockingPaneVisualStudio2012Theme | protected
m_pcsInactive | CXTPDockingPaneVisualStudio2012Theme | protected
m_pPanelPaintManager | CXTPDockingPanePaintManager | protected
m_pTabPaintManager | CXTPDockingPanePaintManager | protected
m_rcCaptionMargin | CXTPDockingPanePaintManager | protected
m_strFontFace | CXTPDockingPaneVisualStudio2012Theme | protected
m_strOfficeFont | CXTPDockingPanePaintManager | protected
m_systemTheme | CXTPDockingPanePaintManager | protected
m_themeButton | CXTPDockingPanePaintManager | protected
m_themeCurrent | CXTPDockingPanePaintManager | protected
m_themeExplorer | CXTPDockingPanePaintManager | protected
m_themeRebar | CXTPDockingPanePaintManager | protected
m_themeToolbar | CXTPDockingPanePaintManager | protected
m_themeWindow | CXTPDockingPanePaintManager | protected
m_xtpFontTitle | CXTPDockingPanePaintManager | protected
m_xtpFontTitleVertical | CXTPDockingPanePaintManager | protected
Pixel(CDC *pDC, int xPos, int yPos, int nPen) | CXTPDockingPanePaintManager |
Rectangle(CDC *pDC, CRect rc, int nPenEntry, int nPenBorder) | CXTPDockingPanePaintManager |
RefreshMetrics() | CXTPDockingPaneVisualStudio2015Theme | virtual
SetCaptionButtonStyle(XTPDockingPaneCaptionButtonStyle nStyle) | CXTPDockingPanePaintManager |
SetCaptionFontIndirect(LOGFONT *pLogFont, BOOL bUseStandardFont=FALSE) | CXTPDockingPanePaintManager |
SetColors(int cElements, CONST INT *lpaElements, CONST COLORREF *lpaRgbValues) | CXTPDockingPanePaintManager |
SetCustomTitleBrushes(HBRUSH hbrActiveTitleHorz, HBRUSH hbrInactiveTitleHorz=NULL, HBRUSH hbrActiveTitleVert=NULL, HBRUSH hbrInactiveTitleVert=NULL, BOOL bDestroyOnCleanup=FALSE) | CXTPDockingPanePaintManager |
SetLunaTheme(XTPCurrentSystemTheme systemTheme) | CXTPDockingPanePaintManager |
SetPaneColorSets(CXTPDockingPaneColorSet *pcsActive, CXTPDockingPaneColorSet *pcsInactive) | CXTPDockingPaneVisualStudio2012Theme | protected
SetPanelPaintManager(CXTPTabPaintManager *pManager) | CXTPDockingPanePaintManager |
SetSplitterStyle(DWORD dwStyle) | CXTPDockingPanePaintManager |
SetTabPaintManager(CXTPTabPaintManager *pManager) | CXTPDockingPanePaintManager |
UseOfficeFont(BOOL bUseOfficeFont) | CXTPDockingPanePaintManager |
~CXTPDockingPanePaintManager() | CXTPDockingPanePaintManager | protectedvirtual
~CXTPDockingPaneVisualStudio2012Theme() | CXTPDockingPaneVisualStudio2012Theme | virtual
~CXTPDockingPaneVisualStudio2015Theme() | CXTPDockingPaneVisualStudio2015Theme | virtual


Toolkit Pro: Member List

CXTPPropertyPageControlNavigator Member List

This is the complete list of members for CXTPPropertyPageControlNavigator, including all inherited members.

Create()=0 | CXTPPropertyPageNavigator | pure virtual
CXTPPropertyPageControlNavigator() | CXTPPropertyPageControlNavigator |
CXTPPropertyPageNavigator() | CXTPPropertyPageNavigator |
GetPageBrush(CDC *pDC, CXTPPropertyPage *pPage)=0 | CXTPPropertyPageNavigator | pure virtual
GetPageColor()=0 | CXTPPropertyPageNavigator | pure virtual
GetSafeHwnd() const =0 | CXTPPropertyPageNavigator | pure virtual
m_pSheet | CXTPPropertyPageNavigator | protected
m_rcButtonMargin | CXTPPropertyPageNavigator |
m_rcNavigatorMargin | CXTPPropertyPageNavigator |
m_rcPageMargin | CXTPPropertyPageNavigator |
OnPageSelected(CXTPPropertyPage *pPage)=0 | CXTPPropertyPageNavigator | pure virtual
PageToSize(AFX_SIZEPARENTPARAMS *pLayout, CSize szPage, CRect &rcPage, CSize &szClient)=0 | CXTPPropertyPageNavigator | pure virtual
SetTheme(XTPControlTheme theme) | CXTPPropertyPageNavigator | virtual
SizeToPage(AFX_SIZEPARENTPARAMS *pLayout, CSize szClient, CRect &rcPage)=0 | CXTPPropertyPageNavigator | pure virtual
~CXTPPropertyPageNavigator() | CXTPPropertyPageNavigator | virtual


Toolkit Pro: XTPPopupThemeMSN.h Source File

  • Source
  • Controls
  • Popup
  • Themes
XTPPopupThemeMSN.h
Go to the documentation of this file.
1
23#if !defined(__XTPPOPUPTHEMEMSN_H__)
24# define __XTPPOPUPTHEMEMSN_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPPopupThemeMSN : public CXTPPopupThemeOffice2000
39{
40public:
45 CXTPPopupThemeMSN();
46
51 virtual ~CXTPPopupThemeMSN();
52
53public:
58 void RefreshMetrics();
59
67 virtual void DrawBackground(CDC* pDC, CXTPPopupControl* pControl, CRect rcClient);
68};
69
70# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
72#endif // __XTPPOPUPTHEMEMSN_H__
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPPopupControl
CXTPPopupControl is a class for control of a pop-up window.
Definition XTPPopupControl.h:225
CXTPPopupThemeMSN
CXTPPopupThemeMSN is a class used to perform MSN Messenger drawing tasks.
Definition XTPPopupThemeMSN.h:39
CXTPPopupThemeMSN::DrawBackground
virtual void DrawBackground(CDC *pDC, CXTPPopupControl *pControl, CRect rcClient)
Call this member function to draw the background of a pop-up window.
CXTPPopupThemeMSN::RefreshMetrics
void RefreshMetrics()
Call this member function to refresh draw metrics.
CXTPPopupThemeMSN::~CXTPPopupThemeMSN
virtual ~CXTPPopupThemeMSN()
Destroys a CXTPPopupThemeMSN object.
CXTPPopupThemeMSN::CXTPPopupThemeMSN
CXTPPopupThemeMSN()
Constructs a CXTPPopupThemeMSN object.
CXTPPopupThemeOffice2000
CXTPPopupThemeOffice2000 is a class used to perform Office 2000 drawing tasks.
Definition XTPPopupThemeOffice2000.h:39


Toolkit Pro: Member List

CXTPActiveScriptObjectContext Member List

This is the complete list of members for CXTPActiveScriptObjectContext, including all inherited members.

AddRef() | CXTPActiveScriptObjectContext
GetContext(LPCWSTR lpszName) | CXTPActiveScriptObjectContext
GetEngine() | CXTPActiveScriptObjectContext
GetEngine() const | CXTPActiveScriptObjectContext
GetValue(LPCWSTR lpszName, CComVariant *pvtResult) | CXTPActiveScriptObjectContext
Invoke(VARIANT *pvtResult=NULL) | CXTPActiveScriptObjectContext
Invoke(A1 arg1, VARIANT *pvtResult=NULL) | CXTPActiveScriptObjectContext
Invoke(A1 arg1, A2 arg2, VARIANT *pvtResult=NULL) | CXTPActiveScriptObjectContext
Invoke(A1 arg1, A2 arg2, A3 arg3, VARIANT *pvtResult=NULL) | CXTPActiveScriptObjectContext
Invoke(A1 arg1, A2 arg2, A3 arg3, A4 arg4, VARIANT *pvtResult=NULL) | CXTPActiveScriptObjectContext
Invoke(A1 arg1, A2 arg2, A3 arg3, A4 arg4, A5 arg5, VARIANT *pvtResult=NULL) | CXTPActiveScriptObjectContext
InvokeWithArgs(VARIANT *lpArguments, UINT nCount, VARIANT *pvtResult=NULL) | CXTPActiveScriptObjectContext
Release() | CXTPActiveScriptObjectContext
SetValue(LPCWSTR lpszName, VARIANT vtValue) | CXTPActiveScriptObjectContext


Toolkit Pro: Member List

CXTPCalendarController Member List

This is the complete list of members for CXTPCalendarController, including all inherited members.

_HasEvents(COleDateTime dtDay) | CXTPCalendarController | protected
AdviseToNotifications() | CXTPCalendarController | protectedvirtual
CXTPCalendarController() | CXTPCalendarController |
CXTPCmdTarget() | CXTPCmdTarget |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetBoldDaysIdleStepTime_ms() const | CXTPCalendarController | virtual
GetBoldDaysPerIdleStep() const | CXTPCalendarController | virtual
GetCalendar() const | CXTPCalendarController | virtual
GetDatePicker() const | CXTPCalendarController | virtual
IsBoldDaysOnIdle() const | CXTPCalendarController | virtual
IsBoldDaysWithEvents() const | CXTPCalendarController | virtual
m_bBoldDaysOnIdle | CXTPCalendarController | protected
m_bBoldDaysWithEvents | CXTPCalendarController | protected
m_bUseActiveViewResoucesForBold | CXTPCalendarController | protected
m_nBoldDaysIdleStepTime_ms | CXTPCalendarController | protected
m_nBoldDaysPerIdleStep | CXTPCalendarController | protected
m_pCalendarCtrl | CXTPCalendarController | protected
m_pDatePickerCtrl | CXTPCalendarController | protected
OnEvent_CalendarOptionsChanged(XTP_NOTIFY_CODE Event, WPARAM wParam, LPARAM lParam) | CXTPCalendarController | protectedvirtual
OnEvent_CalendarResourcesChanged(XTP_NOTIFY_CODE Event, WPARAM wParam, LPARAM lParam) | CXTPCalendarController | protectedvirtual
OnEvent_CalendarThemeChanged(XTP_NOTIFY_CODE Event, WPARAM wParam, LPARAM lParam) | CXTPCalendarController | protectedvirtual
OnEvent_CalendarView(XTP_NOTIFY_CODE Event, WPARAM wParam, LPARAM lParam) | CXTPCalendarController | protectedvirtual
OnEvent_DatePicker(XTP_NOTIFY_CODE Event, WPARAM wParam, LPARAM lParam) | CXTPCalendarController | protectedvirtual
OnEvent_DtPickGetItemMetrics(XTP_NOTIFY_CODE Event, WPARAM wParam, LPARAM lParam) | CXTPCalendarController | protectedvirtual
SetBoldDaysIdleStepTime_ms(long nStepTime_ms) | CXTPCalendarController | virtual
SetBoldDaysOnIdle(BOOL bBoldDaysOnIdle) | CXTPCalendarController | virtual
SetBoldDaysPerIdleStep(long nDaysPerStep) | CXTPCalendarController | virtual
SetBoldDaysWithEvents(BOOL bBold) | CXTPCalendarController | virtual
SetCalendar(CXTPCalendarControl *pCalendarCtrl) | CXTPCalendarController | virtual
SetDatePicker(CXTPDatePickerControl *pDatePickerCtrl) | CXTPCalendarController | virtual
SetFirstDayOfWeekToDatePicker() | CXTPCalendarController | protectedvirtual
~CXTPCalendarController() | CXTPCalendarController | virtual


Toolkit Pro: XTPChartSeries.h Source File

  • Source
  • Chart
XTPChartSeries.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTSERIES_H__)
24# define __XTPCHARTSERIES_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartSeriesView;
34class CXTPChartSeriesPointCollection;
35class CXTPChartSeriesPointView;
36class CXTPChartSeriesPoint;
37class CXTPChartContent;
38class CXTPChartDiagramView;
39class CXTPChartDiagram;
40class CXTPChartSeriesStyle;
41class CXTPChartNumberFormat;
42class CXTPChartLegendItem;
43
49class _XTP_EXT_CLASS CXTPChartSeries : public CXTPChartElement
50{
52 DECLARE_DYNAMIC(CXTPChartSeries)
54public:
59 CXTPChartSeries();
60
65 virtual ~CXTPChartSeries();
66
67public:
68 CXTPChartColor GetColor() const;
69 CXTPChartColor GetColor2() const;
70
71public:
79 CXTPChartLegendItem* GetLegendItem() const;
80
88 CXTPChartSeriesPointCollection* GetPoints() const;
89
96 void SetPoints(CXTPChartSeriesPointCollection* pPoints);
97
107 CXTPChartSeriesStyle* GetStyle() const;
108
118 CXTPChartSeriesStyle* SetStyle(CXTPChartSeriesStyle* pView);
119
128 BOOL SetDiagram(CXTPChartDiagram* pDiagram);
129
138 CXTPChartDiagram* GetDiagram() const;
139
147 void SetArgumentScaleType(XTPChartScaleType scaleType);
148
157 XTPChartScaleType GetArgumentScaleType() const;
158
166 void SetValueScaleType(XTPChartScaleType scaleType);
167
176 XTPChartScaleType GetValueScaleType() const;
177
185 int GetPaletteIndex() const;
186
193 void SetName(LPCTSTR lpszName);
201 CXTPChartString GetName() const;
202
210 void SetLegendText(LPCTSTR lpszLegendText);
211
217 CXTPChartString GetLegendText() const;
218
230 CXTPChartNumberFormat* GetPointLegendFormat() const;
231
241 void SetPointLegendFormat(LPCTSTR lpszFormat);
242
249 void SetVisible(BOOL bVisible);
250
258 BOOL IsVisible() const;
259
267 void SetLegendVisible(BOOL bVisible);
268
276 BOOL IsLegendVisible() const;
277
278public:
279 virtual void DoPropExchange(CXTPPropExchange* pPX);
280
281 void Release();
282# ifdef _XTP_ACTIVEX
283public:
285 DECLARE_DISPATCH_MAP()
286 DECLARE_INTERFACE_MAP()
287
288 DECLARE_OLETYPELIB_EX(CXTPChartSeries);
289
290 afx_msg LPDISPATCH OleGetStyle();
291 afx_msg LPDISPATCH OleGetPoints();
292 afx_msg LPDISPATCH OleGetDiagram();
293 afx_msg void OleSetStyle(LPDISPATCH lpStyle);
294 afx_msg void OleSetDiagram(LPDISPATCH lpDiagram);
295 afx_msg long OleGetArgumentScaleType();
296 afx_msg void OleSetArgumentScaleType(long ArgumentScaleType);
297 afx_msg long OleGetValueScaleType();
298 afx_msg void OleSetValueScaleType(long ValueScaleType);
299 afx_msg void OleChartChanged();
300 afx_msg LPDISPATCH OleGetPointLegendFormat();
301 afx_msg LPDISPATCH OleGetLegendItem();
302 afx_msg BOOL OleGetLegendVisible();
303 afx_msg void OleSetLegendVisible(BOOL bValue);
304 afx_msg void OleEnableVirtualMode(double MinRange, double MaxRange, double Step);
305
307# endif
308
309protected:
310 CXTPChartLegendItem* m_pLegendItem;
311 CXTPChartSeriesStyle* m_pStyle;
312 CXTPChartSeriesPointCollection* m_pPoints;
314 XTPChartScaleType m_nArgumentScaleType;
315 XTPChartScaleType m_nValueScaleType;
317 CXTPChartDiagram* m_pDiagram;
319 CXTPChartString m_strName;
320 CXTPChartString m_strLegendText;
321 CXTPChartNumberFormat* m_pPointLegendFormat;
323 BOOL m_bVisible;
324 BOOL m_bLegendVisible;
326 int m_nPaletteIndex;
328protected:
329 friend class CXTPChartSeriesCollection;
330 friend class CXTPChartContent;
331};
332
338class _XTP_EXT_CLASS CXTPChartSeriesCollection : public CXTPChartElementCollection
339{
340public:
348 CXTPChartSeriesCollection(CXTPChartContent* pOwner);
349
354 virtual ~CXTPChartSeriesCollection();
355
356public:
365 CXTPChartSeries* Add(CXTPChartSeries* pSeries);
366
375 CXTPChartSeries* GetAt(int nIndex) const;
376
377public:
378 virtual void DoPropExchange(CXTPPropExchange* pPX);
379
380protected:
381# ifdef _XTP_ACTIVEX
382public:
384 DECLARE_DISPATCH_MAP()
385 DECLARE_INTERFACE_MAP()
386
387 DECLARE_OLETYPELIB_EX(CXTPChartSeriesCollection);
388
389 afx_msg long OleGetItemCount();
390 afx_msg LPDISPATCH OleGetItem(long nIndex);
391 afx_msg LPDISPATCH OleAdd(LPCTSTR lpszName);
392 afx_msg LPDISPATCH OleAddTrendline(LPCTSTR lpszName);
393 DECLARE_ENUM_VARIANT(CXTPChartSeriesCollection)
394
396# endif
397
398 friend class CXTPChartContent;
399};
400
401AFX_INLINE CXTPChartSeriesPointCollection* CXTPChartSeries::GetPoints() const
402{
403 return m_pPoints;
404}
405AFX_INLINE CXTPChartSeriesStyle* CXTPChartSeries::GetStyle() const
406{
407 return m_pStyle;
408}
409
410AFX_INLINE CXTPChartSeries* CXTPChartSeriesCollection::GetAt(int nIndex) const
411{
412 return nIndex >= 0 && nIndex < m_arrElements.GetSize()
413 ? (CXTPChartSeries*)m_arrElements.GetAt(nIndex)
414 : NULL;
415}
416AFX_INLINE CXTPChartDiagram* CXTPChartSeries::GetDiagram() const
417{
418 return m_pDiagram;
419}
420
421AFX_INLINE void CXTPChartSeries::SetArgumentScaleType(XTPChartScaleType scaleType)
422{
423 m_nArgumentScaleType = scaleType;
424 OnChartChanged();
425}
426AFX_INLINE XTPChartScaleType CXTPChartSeries::GetArgumentScaleType() const
427{
428 return m_nArgumentScaleType;
429}
430AFX_INLINE void CXTPChartSeries::SetValueScaleType(XTPChartScaleType scaleType)
431{
432 m_nValueScaleType = scaleType;
433 OnChartChanged();
434}
435AFX_INLINE XTPChartScaleType CXTPChartSeries::GetValueScaleType() const
436{
437 return m_nValueScaleType;
438}
439AFX_INLINE int CXTPChartSeries::GetPaletteIndex() const
440{
441 return m_nPaletteIndex;
442}
443
444AFX_INLINE void CXTPChartSeries::SetName(LPCTSTR lpszName)
445{
446 m_strName = lpszName;
447 OnChartChanged();
448}
449AFX_INLINE CXTPChartString CXTPChartSeries::GetName() const
450{
451 return m_strName;
452}
453AFX_INLINE void CXTPChartSeries::SetLegendText(LPCTSTR lpszLegendText)
454{
455 m_strLegendText = lpszLegendText;
456 OnChartChanged();
457}
458AFX_INLINE CXTPChartString CXTPChartSeries::GetLegendText() const
459{
460 return m_strLegendText;
461}
462AFX_INLINE void CXTPChartSeries::SetVisible(BOOL bVisible)
463{
464 m_bVisible = bVisible;
465 OnChartChanged();
466}
467AFX_INLINE BOOL CXTPChartSeries::IsVisible() const
468{
469 return m_bVisible;
470}
471AFX_INLINE CXTPChartNumberFormat* CXTPChartSeries::GetPointLegendFormat() const
472{
473 return m_pPointLegendFormat;
474}
475AFX_INLINE BOOL CXTPChartSeries::IsLegendVisible() const
476{
477 return m_bLegendVisible;
478}
479AFX_INLINE void CXTPChartSeries::SetLegendVisible(BOOL bLegendVisible)
480{
481 m_bLegendVisible = bLegendVisible;
482 OnChartChanged();
483}
485# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
486#endif //#if !defined(__XTPCHARTSERIES_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartColor
This class abstracts a color entity.
Definition XTPChartTypes.h:51
CXTPChartContent
This class represents chart content, which is a kind of CXTPChartElement.
Definition XTPChartContent.h:66
CXTPChartDiagram
This class represents a chart diagram, which is a kind of CXTPChartElement.
Definition XTPChartDiagram.h:48
CXTPChartDiagramView
This class represents the view of a chart diagram, which is a kind of CXTPChartElementView.
Definition XTPChartDiagramView.h:49
CXTPChartElementCollection
This class abstracts a chart collection.
Definition XTPChartElement.h:358
CXTPChartElementCollection::m_arrElements
CArray< CXTPChartElement *, CXTPChartElement * > m_arrElements
Array of CXTPChartElement pointer.
Definition XTPChartElement.h:450
CXTPChartElement
This class abstracts a chart element, this class acts as a base class for all chart elements.
Definition XTPChartElement.h:131
CXTPChartElement::OnChartChanged
virtual void OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic propertie...
CXTPChartNumberFormat
This class helper is used to format number to string.
Definition XTPChartNumberFormat.h:72
CXTPChartSeriesCollection
This class represents the collection of series in the chart, which is a kind of CXTPChartElement.
Definition XTPChartSeries.h:339
CXTPChartSeriesCollection::DoPropExchange
virtual void DoPropExchange(CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
CXTPChartSeriesCollection::GetAt
CXTPChartSeries * GetAt(int nIndex) const
Call this function to get a series at a particular index in the series collection.
Definition XTPChartSeries.h:410
CXTPChartSeriesCollection::Add
CXTPChartSeries * Add(CXTPChartSeries *pSeries)
Call this function to add a series to the collection.
CXTPChartSeriesCollection::~CXTPChartSeriesCollection
virtual ~CXTPChartSeriesCollection()
Destroys a CXTPChartSeriesCollection object, handles cleanup.
CXTPChartSeriesCollection::CXTPChartSeriesCollection
CXTPChartSeriesCollection(CXTPChartContent *pOwner)
Constructs a CXTPChartSeriesCollection object.
CXTPChartSeries
This class represents a series in the chart, which is a kind of CXTPChartElement.
Definition XTPChartSeries.h:50
CXTPChartSeries::SetArgumentScaleType
void SetArgumentScaleType(XTPChartScaleType scaleType)
Use this function to set the scale type used for the argument.
Definition XTPChartSeries.h:421
CXTPChartSeries::DoPropExchange
virtual void DoPropExchange(CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
CXTPChartSeries::CXTPChartSeries
CXTPChartSeries()
Constructs a CXTPChartSeries object.
CXTPChartSeries::GetPoints
CXTPChartSeriesPointCollection * GetPoints() const
Call this function to gets the the collection of the series points.
Definition XTPChartSeries.h:401
CXTPChartSeries::GetDiagram
CXTPChartDiagram * GetDiagram() const
Call this function to get the diagram object associated with this object.
Definition XTPChartSeries.h:416
CXTPChartSeries::m_pDiagram
CXTPChartDiagram * m_pDiagram
The diagram object.
Definition XTPChartSeries.h:317
CXTPChartSeries::SetVisible
void SetVisible(BOOL bVisible)
Use this function to set the series visible/invisible.
Definition XTPChartSeries.h:462
CXTPChartSeries::SetPoints
void SetPoints(CXTPChartSeriesPointCollection *pPoints)
Call this function to sets the the collection of the series points.
CXTPChartSeries::GetValueScaleType
XTPChartScaleType GetValueScaleType() const
Call this function to get the scale type used for the value.
Definition XTPChartSeries.h:435
CXTPChartSeries::GetStyle
CXTPChartSeriesStyle * GetStyle() const
Use this function to get the series style of the chart series.
Definition XTPChartSeries.h:405
CXTPChartSeries::GetArgumentScaleType
XTPChartScaleType GetArgumentScaleType() const
Call this function to get the scale type used for the argument.
Definition XTPChartSeries.h:426
CXTPChartSeries::SetPointLegendFormat
void SetPointLegendFormat(LPCTSTR lpszFormat)
Obsolete method.
CXTPChartSeries::SetName
void SetName(LPCTSTR lpszName)
Call this function to set the name of the chart series.
Definition XTPChartSeries.h:444
CXTPChartSeries::SetLegendVisible
void SetLegendVisible(BOOL bVisible)
Use this function to set the legend item visible/invisible.
Definition XTPChartSeries.h:479
CXTPChartSeries::IsVisible
BOOL IsVisible() const
Call this function to check if the series is visible.
Definition XTPChartSeries.h:467
CXTPChartSeries::m_pLegendItem
CXTPChartLegendItem * m_pLegendItem
The legend item.
Definition XTPChartSeries.h:310
CXTPChartSeries::m_bLegendVisible
BOOL m_bLegendVisible
TRUE if the legend item is visible, FALSE if not visible.
Definition XTPChartSeries.h:324
CXTPChartSeries::m_pPointLegendFormat
CXTPChartNumberFormat * m_pPointLegendFormat
The legend text format of the series.
Definition XTPChartSeries.h:321
CXTPChartSeries::SetLegendText
void SetLegendText(LPCTSTR lpszLegendText)
Call this function to set the name of the legend item.
Definition XTPChartSeries.h:453
CXTPChartSeries::m_strName
CXTPChartString m_strName
The name of the series.
Definition XTPChartSeries.h:319
CXTPChartSeries::Release
void Release()
Call this function to decrease the usage count of the object.
CXTPChartSeries::GetLegendItem
CXTPChartLegendItem * GetLegendItem() const
Call this function to get the legend item of the series.
CXTPChartSeries::SetStyle
CXTPChartSeriesStyle * SetStyle(CXTPChartSeriesStyle *pView)
Call this function to set the series style of the chart series.
CXTPChartSeries::m_nArgumentScaleType
XTPChartScaleType m_nArgumentScaleType
The scale type of the argument.
Definition XTPChartSeries.h:314
CXTPChartSeries::m_pPoints
CXTPChartSeriesPointCollection * m_pPoints
The collection of points which form the series.
Definition XTPChartSeries.h:312
CXTPChartSeries::m_nValueScaleType
XTPChartScaleType m_nValueScaleType
The scale type of the value.
Definition XTPChartSeries.h:315
CXTPChartSeries::GetPointLegendFormat
CXTPChartNumberFormat * GetPointLegendFormat() const
Call this function to get a pointer to CXTPChartNumberFormat that specifies how to convert numbers to...
Definition XTPChartSeries.h:471
CXTPChartSeries::m_bVisible
BOOL m_bVisible
TRUE if the series visible and FALSE if it is invisible.
Definition XTPChartSeries.h:323
CXTPChartSeries::GetPaletteIndex
int GetPaletteIndex() const
Use this function to get the palette index.
Definition XTPChartSeries.h:439
CXTPChartSeries::SetDiagram
BOOL SetDiagram(CXTPChartDiagram *pDiagram)
Use this function to set the diagram object associated with this object.
CXTPChartSeries::SetValueScaleType
void SetValueScaleType(XTPChartScaleType scaleType)
Use this function to set the scale type used for the value.
Definition XTPChartSeries.h:430
CXTPChartSeries::m_nPaletteIndex
int m_nPaletteIndex
The palette index.
Definition XTPChartSeries.h:326
CXTPChartSeries::m_pStyle
CXTPChartSeriesStyle * m_pStyle
The series style object.
Definition XTPChartSeries.h:311
CXTPChartSeries::IsLegendVisible
BOOL IsLegendVisible() const
Call this function to check if the legend item is visible.
Definition XTPChartSeries.h:475
CXTPChartSeries::GetLegendText
CXTPChartString GetLegendText() const
Use this function to get the name of the legend item.
Definition XTPChartSeries.h:458
CXTPChartSeries::GetName
CXTPChartString GetName() const
Use this function to get the name of the chart series.
Definition XTPChartSeries.h:449
CXTPChartSeries::~CXTPChartSeries
virtual ~CXTPChartSeries()
Destroys a CXTPChartSeries object, handles cleanup.
CXTPChartSeries::m_strLegendText
CXTPChartString m_strLegendText
The legend text of the series.
Definition XTPChartSeries.h:320
CXTPChartSeriesPointCollection
CXTPChartSeriesPointCollection class represents a collection of chart series points.
Definition XTPChartSeriesPoint.h:376
CXTPChartSeriesPoint
CXTPChartSeriesPoint is a kind of CXTPChartElement.
Definition XTPChartSeriesPoint.h:43
CXTPChartSeriesPointView
Represents chart series point view.
Definition XTPChartSeriesPointView.h:48
CXTPChartSeriesStyle
CXTPChartSeriesStyle is a CXTPChartElement derived class.
Definition XTPChartSeriesStyle.h:49
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72


Toolkit Pro: XTPStatusBarThemeVisualStudio2022.h Source File

  • Source
  • CommandBars
  • StatusBar
XTPStatusBarThemeVisualStudio2022.h
Go to the documentation of this file.
1
23#if !defined(__XTPXTPSTATUSBARTHEMEVISUALSTUDIO2022_H__)
24# define __XTPXTPSTATUSBARTHEMEVISUALSTUDIO2022_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPStatusBarThemeVisualStudio2022
39 : public CXTPStatusBarThemeOffice2013
40 , private IXTPApplicationEvents
41{
42public:
48 CXTPStatusBarThemeVisualStudio2022(CXTPPaintManager* pPaintManager);
49
54 ~CXTPStatusBarThemeVisualStudio2022();
55
62 virtual void DrawStatusBarGripper(CDC* pDC, CRect rcClient);
63
69 virtual void RefreshMetrics();
70
78 virtual void SetStateColor(COLORREF clrState);
79
86 virtual COLORREF GetStateColor() const;
87
88private:
89 virtual void OnAmbientPropertyChanged(CXTPApplication* pApplication,
90 XTPApplicationAmbientProperty nProperty);
91 void UpdateStateColor();
92
93 BOOL m_bAutomaticStateColor;
94};
95
97# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
98#endif // !defined(__XTPXTPSTATUSBARTHEMEVISUALSTUDIO2022_H__)
XTPApplicationAmbientProperty
XTPApplicationAmbientProperty
Global ambient property identifiers.
Definition XTPApplication.h:46
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPApplication
Defines a global XTP application object interface.
Definition XTPApplication.h:151
CXTPPaintManager
Paint manager of the command bars.
Definition XTPPaintManager.h:199
CXTPStatusBarThemeOffice2013
The CXTPStatusBarThemeVisualStudio2015 class is used to enable the Office 2013 style theme for the st...
Definition XTPStatusBarThemeOffice2013.h:39
CXTPStatusBarThemeVisualStudio2022
The CXTPStatusBarThemeVisualStudio2022 class is used to enable the Visual Studio 2022 style theme for...
Definition XTPStatusBarThemeVisualStudio2022.h:41
CXTPStatusBarThemeVisualStudio2022::~CXTPStatusBarThemeVisualStudio2022
~CXTPStatusBarThemeVisualStudio2022()
Handles object destruction.
CXTPStatusBarThemeVisualStudio2022::DrawStatusBarGripper
virtual void DrawStatusBarGripper(CDC *pDC, CRect rcClient)
This method is called to draw the status bar's gripper.
CXTPStatusBarThemeVisualStudio2022::SetStateColor
virtual void SetStateColor(COLORREF clrState)
Call this member function to set the application state color for the status bar.
CXTPStatusBarThemeVisualStudio2022::CXTPStatusBarThemeVisualStudio2022
CXTPStatusBarThemeVisualStudio2022(CXTPPaintManager *pPaintManager)
Constructs a CXTPStatusBarThemeVisualStudio2022 object.
CXTPStatusBarThemeVisualStudio2022::RefreshMetrics
virtual void RefreshMetrics()
This method is called to refresh colors and other theme specific metrics for the paint manager.
CXTPStatusBarThemeVisualStudio2022::GetStateColor
virtual COLORREF GetStateColor() const
Call this member function to get the application state color for the status bar.
IXTPApplicationEvents
Defines a callback interface for XTP application event sink.
Definition XTPApplication.h:82
IXTPApplicationEvents::OnAmbientPropertyChanged
virtual void OnAmbientPropertyChanged(CXTPApplication *pApplication, XTPApplicationAmbientProperty nProperty)
Called by framework when an ambient property is changed.
Definition XTPApplication.h:130


Toolkit Pro: XTPShortcutBarPopup.h Source File

  • Source
  • ShortcutBar
XTPShortcutBarPopup.h
Go to the documentation of this file.
1
23#if !defined(__XTPSHORTCUTBARPOPUP_H__)
24# define __XTPSHORTCUTBARPOPUP_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPShortcutBar;
34
35class _XTP_EXT_CLASS CXTPShortcutBarPopup : public CWnd
36{
37public:
38 CXTPShortcutBarPopup(CXTPShortcutBar* pShortcutBar, HWND hWndChild);
39 ~CXTPShortcutBarPopup();
40
41public:
42 void DoModal();
43 void Close();
44
45protected:
46 DECLARE_MESSAGE_MAP();
47 afx_msg void OnPaint();
48 afx_msg LRESULT OnFloatStatus(WPARAM wParam, LPARAM);
49 afx_msg BOOL OnNcCreate(LPCREATESTRUCT lpCreateStruct);
50 afx_msg BOOL OnNcActivate(BOOL bActive);
51 afx_msg int OnMouseActivate(CWnd* /*pDesktopWnd*/, UINT /*nHitTest*/, UINT /*message*/);
52 afx_msg LRESULT OnNcHitTest(CPoint point);
53 afx_msg void OnSize(UINT nType, int cx, int cy);
54
55protected:
56 BOOL IsTrackingMode() const;
57 void PumpMessage();
58
59protected:
60 HWND m_hWndChild;
61 CXTPShortcutBar* m_pShortcutBar;
62 CSize m_szGap;
63
64public:
65 static int m_nPopupWidth;
66};
67
68# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
70#endif // !defined(__XTPSHORTCUTBARPOPUP_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPShortcutBar
CXTPShortcutBar is a CWnd derived class used to implement an Outlook 2003 shortcut bar control style.
Definition XTPShortcutBar.h:456


Toolkit Pro: Member List

  • CXTPSortClass
  • ITEMDATA
CXTPSortClass::ITEMDATA Member List

This is the complete list of members for CXTPSortClass::ITEMDATA, including all inherited members.

dwData | CXTPSortClass::ITEMDATA
strItem | CXTPSortClass::ITEMDATA


Toolkit Pro: Member List

CXTPChartCandleStickSeriesPointView Member List

This is the complete list of members for CXTPChartCandleStickSeriesPointView, including all inherited members.

AddChildView(CXTPChartElementView *pChildView) | CXTPChartElementView |
CreateDeviceCommand(CXTPChartDeviceContext *pDC) | CXTPChartCandleStickSeriesPointView | virtual
CreateLegendDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcBounds) | CXTPChartSeriesPointView | virtual
CXTPChartCandleStickSeriesPointView(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView) | CXTPChartCandleStickSeriesPointView |
CXTPChartElementView(CXTPChartElementView *pParentView) | CXTPChartElementView |
CXTPChartElementView(CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartElementView |
CXTPChartElementView(CXTPChartContainer *pContainer) | CXTPChartElementView |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartSeriesPointView(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView) | CXTPChartSeriesPointView |
CXTPChartSeriesPointView(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartSeriesPointView |
GetAt(int nIndex) const | CXTPChartElementView |
GetBounds() const | CXTPChartElementView |
GetBounds(BOOL bIncludingChildren) const | CXTPChartElementView |
GetChildren() | CXTPChartElementView |
GetColor() const | CXTPChartSeriesPointView |
GetColor2() const | CXTPChartSeriesPointView |
GetCount() const | CXTPChartElementView |
GetInternalValue() const | CXTPChartSeriesPointView |
GetLegendName() const | CXTPChartSeriesPointView | virtual
GetParentView() const | CXTPChartElementView |
GetPoint() const | CXTPChartSeriesPointView |
GetScreenPoint(int nIndex) | CXTPChartCandleStickSeriesPointView |
GetSeriesView() const | CXTPChartSeriesPointView |
Is3D() const | CXTPChartObject |
m_arrChildren | CXTPChartElementView | protected
m_dInternalValue | CXTPChartSeriesPointView |
m_pContainer | CXTPChartElementView | protected
m_pParentView | CXTPChartElementView | protected
m_pPoint | CXTPChartSeriesPointView | protected
m_rcBounds | CXTPChartElementView | protected
UpdateMinMaxRange(double &nMinValue, double &nMaxValue) const | CXTPChartSeriesPointView | virtual
~CXTPChartElementView() | CXTPChartElementView | protectedvirtual
~CXTPChartLegendItemView() | CXTPChartLegendItemView | inlinevirtual


Toolkit Pro: Member List

CXTPColorSetStateMenu Member List

This is the complete list of members for CXTPColorSetStateMenu, including all inherited members.

clrBack | CXTPColorSetStateButton |
clrBackChecked | CXTPColorSetStateButton |
clrBackCheckedHighlight | CXTPColorSetStateButton |
clrBackDisabled | CXTPColorSetStateButton |
clrBackHighlight | CXTPColorSetStateButton |
clrBackPushed | CXTPColorSetStateButton |
clrBorder | CXTPColorSetStateButton |
clrBorderChecked | CXTPColorSetStateButton |
clrBorderCheckedHighlight | CXTPColorSetStateButton |
clrBorderDisabled | CXTPColorSetStateButton |
clrBorderHighlight | CXTPColorSetStateButton |
clrBorderPushed | CXTPColorSetStateButton |
clrGripper | CXTPColorSetStateMenu |
clrMenuBack | CXTPColorSetStateMenu |
clrMenuBorder | CXTPColorSetStateMenu |
clrSeparator | CXTPColorSetStateMenu |
clrText | CXTPColorSetStateButton |
clrTextChecked | CXTPColorSetStateButton |
clrTextCheckedHighlight | CXTPColorSetStateButton |
clrTextDisabled | CXTPColorSetStateButton |
clrTextHighlight | CXTPColorSetStateButton |
clrTextPushed | CXTPColorSetStateButton |
CXTPCmdTarget() | CXTPCmdTarget |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
RefreshColors() | CXTPColorSetStateMenu | virtual


Toolkit Pro: Member List

CXTPGridRow Member List

This is the complete list of members for CXTPGridRow, including all inherited members.

_SetExpanded(BOOL bExpanded, BOOL bRecursive, BOOL bNotify) | CXTPGridRow | virtual
AddChild(CXTPGridRow *pRow) | CXTPGridRow | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPGridRow() | CXTPGridRow |
Draw(CDC *pDC, CRect rcRow, CRect rcClip, int nLeftOffset, CXTPGridRecordMergeItems &mergeItems, int nColumnFrom, int nColumnTo) | CXTPGridRow | virtual
EnsureVisible() | CXTPGridRow | virtual
FillMetrics(CXTPGridColumn *pColumn, CXTPGridRecordItem *pItem, XTP_GRIDRECORDITEM_METRICS *pMetrics) | CXTPGridRow | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetChilds(BOOL bCreate=TRUE) | CXTPGridRow | virtual
GetControl() const | CXTPGridRow | virtual
GetGroupLevel() const | CXTPGridRow | virtual
GetHeight(CDC *pDC, int nWidth) | CXTPGridRow | virtual
GetIndex() const | CXTPGridRow | virtual
GetItemMetrics(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pItemMetrics) | CXTPGridRow | virtual
GetItemRect(CXTPGridRecordItem *pItem) | CXTPGridRow | virtual
GetItemRect(CXTPGridRecordItem *pItem, BOOL bAsMerged) | CXTPGridRow | protected
GetLastChildRow(CXTPGridRows *pChildren) const | CXTPGridRow | protected
GetMergeHeight() const | CXTPGridRow |
GetNextSiblingRow() const | CXTPGridRow | virtual
GetParentRow() const | CXTPGridRow | virtual
GetParentRows() const | CXTPGridRow | virtual
GetRecord() const | CXTPGridRow | virtual
GetRect() const | CXTPGridRow | virtual
GetSection() const | CXTPGridRow |
GetTreeDepth() const | CXTPGridRow | virtual
GetType() const | CXTPGridRow |
HasChildren() const | CXTPGridRow | virtual
HasMergedItems() const | CXTPGridRow |
HasParent(CXTPGridRow *pRow) | CXTPGridRow | virtual
HitTest(CPoint ptPoint, CRect *pRectItem=NULL, CXTPGridColumn **ppColumn=NULL) const | CXTPGridRow | virtual
InitRow(CXTPGridRow *pRow) | CXTPGridRow | virtual
InitRow(CXTPGridControl *pControl, CXTPGridSection *pSection, CXTPGridRecord *pRecord) | CXTPGridRow | virtual
IsExpanded() const | CXTPGridRow | virtual
IsFocused() const | CXTPGridRow | virtual
IsGroupRow() const | CXTPGridRow | virtual
IsItemsVisible() const | CXTPGridRow | virtual
IsLastTreeRow() const | CXTPGridRow | virtual
IsLockExpand() const | CXTPGridRow | virtual
IsPreviewVisible() const | CXTPGridRow | virtual
IsSelected() const | CXTPGridRow | virtual
IsVisible() const | CXTPGridRow | virtual
LockExpand(BOOL bLockExpand) | CXTPGridRow | virtual
m_bExpanded | CXTPGridRow | protected
m_bHasSelectedChilds | CXTPGridRow | protected
m_bLockExpand | CXTPGridRow | protected
m_bVisible | CXTPGridRow | protected
m_nChildIndex | CXTPGridRow | protected
m_nFreeHeight | CXTPGridRow | protected
m_nGroupLevel | CXTPGridRow | protected
m_nIndex | CXTPGridRow | protected
m_nMergeHeight | CXTPGridRow | protected
m_nPreviewHeight | CXTPGridRow | protected
m_nRowLevel | CXTPGridRow | protected
m_pChilds | CXTPGridRow | protected
m_pControl | CXTPGridRow | protected
m_pParentRow | CXTPGridRow | protected
m_pParentRows | CXTPGridRow | protected
m_pRecord | CXTPGridRow | protected
m_pSection | CXTPGridRow | protected
m_rcCollapse | CXTPGridRow | protected
m_rcRow | CXTPGridRow | protected
OnClick(CPoint ptClicked) | CXTPGridRow | virtual
OnContextMenu(CPoint ptClick) | CXTPGridRow | virtual
OnDblClick(CPoint ptClicked) | CXTPGridRow | virtual
OnLButtonDown(XTP_GRIDRECORDITEM_CLICKARGS *pClickArgs) | CXTPGridRow | virtual
OnLButtonUp(XTP_GRIDRECORDITEM_CLICKARGS *pClickArgs) | CXTPGridRow | virtual
OnMouseMove(UINT nFlags, CPoint point) | CXTPGridRow | virtual
OnToolHitTest(CPoint point, TOOLINFO *pTI) | CXTPGridRow | virtual
operator delete(void *p) | CXTPHeapObjectT< CXTPGridRowBase, CXTPGridRowAllocator > | inline
operator new(size_t nSize) | CXTPHeapObjectT< CXTPGridRowBase, CXTPGridRowAllocator > | inline
SelectChilds() | CXTPGridRow | virtual
SetCollapseRect(CRect rcCollapse) | CXTPGridRow | virtual
SetControl(CXTPGridControl *pControl) | CXTPGridRow | virtual
SetExpanded(BOOL bExpanded, BOOL bRecursive=FALSE) | CXTPGridRow | virtual
SetFullExpanded(BOOL bExpanded) | CXTPGridRow |
SetIndex(int nNewIndex) | CXTPGridRow | protectedvirtual
SetMergeHeight(int nMergeHeight) | CXTPGridRow |
SetSelected(BOOL bSelected) | CXTPGridRow | virtual
SetVisible(BOOL bVisible) | CXTPGridRow | virtual
ShiftTreeIndent(CRect &rcItem, CXTPGridColumn *pColumn) const | CXTPGridRow | virtual
ShowToolTip(CPoint ptTip, CXTPGridTip *pTipWnd) | CXTPGridRow | virtual
~CXTPGridRow() | CXTPGridRow | virtual


Toolkit Pro: Member List

CXTPChartLegendItemView Member List

This is the complete list of members for CXTPChartLegendItemView, including all inherited members.

CreateLegendDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcBounds)=0 | CXTPChartLegendItemView | pure virtual
GetLegendName() const =0 | CXTPChartLegendItemView | pure virtual
~CXTPChartLegendItemView() | CXTPChartLegendItemView | inlinevirtual


Toolkit Pro: Member List

XTP_SCROLLBARDRAWCOLORS Member List

This is the complete list of members for XTP_SCROLLBARDRAWCOLORS, including all inherited members.

clrBack | XTP_SCROLLBARINICOLORS
clrScrollArrow | XTP_SCROLLBARINICOLORS
clrScrollBack | XTP_SCROLLBARINICOLORS
clrScrollBorder | XTP_SCROLLBARINICOLORS
clrScrollDownArrow | XTP_SCROLLBARDRAWCOLORS
clrScrollDownBack | XTP_SCROLLBARDRAWCOLORS
clrScrollDownBorder | XTP_SCROLLBARDRAWCOLORS
clrThumbBack | XTP_SCROLLBARINICOLORS
clrThumbBorder | XTP_SCROLLBARINICOLORS


Toolkit Pro: XTPCommandBarsColorSet.h Source File

  • Source
  • CommandBars
XTPCommandBarsColorSet.h
Go to the documentation of this file.
1
23#if !defined(__XTPCOMMANDBARSCOLORSET_H__)
24# define __XTPCOMMANDBARSCOLORSET_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPResourceImages;
34
35class _XTP_EXT_CLASS CXTPCommandBarsColorSetButton
36{
37public:
38 CXTPPaintManagerColor m_clrButtonBorder;
39 CXTPPaintManagerColor m_clrButtonBackground;
40};
41
42class _XTP_EXT_CLASS CXTPCommandBarsColorSetDropDown
43{
44public:
45 CXTPPaintManagerColor m_clrDropDownBorder;
46 CXTPPaintManagerColor m_clrDropDownBackground;
47 CXTPPaintManagerColor m_clrDropDownMarker;
48};
49
50class _XTP_EXT_CLASS CXTPCommandBarsColorSetComboBox
51{
52public:
53 CXTPPaintManagerColor m_clrComboBoxBorder;
54 CXTPPaintManagerColor m_clrComboBoxBackground;
56 CXTPCommandBarsColorSetDropDown m_dropDown;
57};
58
59class _XTP_EXT_CLASS CXTPCommandBarsColorSet
60{
61public:
62 virtual ~CXTPCommandBarsColorSet()
63 {
64 }
65
66 virtual void RefreshColors(const CXTPResourceImages* pImages);
67
68public:
69 CXTPPaintManagerColor m_clrAppWorkspace;
71 CXTPPaintManagerColor m_clrToolBarBackground;
72 CXTPPaintManagerColor m_clrToolBarGripper;
73 CXTPPaintManagerColor m_clrToolBarText;
74
75 CXTPPaintManagerColor m_clrMenuText;
76 CXTPPaintManagerColor m_clrMenuTextHighlighted;
78 CXTPPaintManagerColor m_clrMenuBorder;
79 CXTPPaintManagerColor m_clrMenuBackground;
80
81 CXTPPaintManagerColor m_clrButtonBorderHighlighted;
82 CXTPPaintManagerColor m_clrButtonBorderPushed;
83 CXTPPaintManagerColor m_clrButtonBorderChecked;
84 CXTPPaintManagerColor m_clrButtonBorderPopped;
85
86 CXTPPaintManagerColor m_clrButtonBackgroundHighlighted;
87 CXTPPaintManagerColor m_clrButtonBackgroundPushed;
88 CXTPPaintManagerColor m_clrButtonBackgroundChecked;
89 CXTPPaintManagerColor m_clrButtonBackgroundPopped;
90
91 CXTPPaintManagerColor m_clrControlText;
92 CXTPPaintManagerColor m_clrControlTextDisabled;
93 CXTPPaintManagerColor m_clrControlTextHighlighted;
94
95 CXTPPaintManagerColor m_clrToolbarFace;
96
97 CXTPPaintManagerColor m_clrEditCtrlBorder;
98
99 // check mark.
100 CXTPPaintManagerColor m_clrCheckMark;
101 CXTPPaintManagerColor m_clrCheckMarkHighlighted;
102 CXTPPaintManagerColor m_clrCheckMarkPushed;
103 CXTPPaintManagerColor m_clrCheckMarkDisabled;
104
105 CXTPPaintManagerColor m_clrCheckMarkBackground;
106 CXTPPaintManagerColor m_clrCheckMarkBackgroundHighlighted;
107 CXTPPaintManagerColor m_clrCheckMarkBackgroundPushed;
108 CXTPPaintManagerColor m_clrCheckMarkBackgroundDisabled;
109
110 // Combobox
111 CXTPCommandBarsColorSetComboBox m_csComboBoxDisabled;
112 CXTPCommandBarsColorSetComboBox m_csComboBoxNormal;
113 CXTPCommandBarsColorSetComboBox m_csComboBoxHighlighted;
114 CXTPCommandBarsColorSetComboBox m_csComboBoxDropped;
115
116 // command bar
117 CXTPPaintManagerColor m_clrSeparator;
118 CXTPPaintManagerColor m_clrSeparatorHighlight;
119 CXTPPaintManagerColor m_clrGlyph;
120 CXTPPaintManagerColor m_clrGlyphPushed;
121 CXTPPaintManagerColor m_clrGlyphHighlighted;
122};
123
124AFX_INLINE void CXTPCommandBarsColorSet::RefreshColors(const CXTPResourceImages* pImages)
125{
126 UNREFERENCED_PARAMETER(pImages);
127}
128
130# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
131#endif // !defined(__XTPCOMMANDBARSCOLORSET_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPPaintManagerColor
The CXTPPaintManagerColor class is used to manage COLORREF values for determining default and applica...
Definition XTPColorManager.h:117
CXTPResourceImages
Implements resource image collection and its operations.
Definition XTPResourceImage.h:257


Toolkit Pro: Member List

CXTPCriticalSection Member List

This is the complete list of members for CXTPCriticalSection, including all inherited members.

CXTPCriticalSection() | CXTPCriticalSection |
EnterCritical() | CXTPCriticalSection |
LeaveCritical() | CXTPCriticalSection |
operator CRITICAL_SECTION &() | CXTPCriticalSection | inline
~CXTPCriticalSection() | CXTPCriticalSection |


Toolkit Pro: Member List

CXTPTaskDialogProgressCtrl Member List

This is the complete list of members for CXTPTaskDialogProgressCtrl, including all inherited members.


Toolkit Pro: XTPPropertySheet.h Source File

  • Source
  • Controls
  • Dialog
XTPPropertySheet.h
Go to the documentation of this file.
1
23#if !defined(__XTPPROPERTYSHEET_H__)
24# define __XTPPROPERTYSHEET_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPDialogEx;
34class CXTPPropertyPageNavigator;
35class CXTPPropertyPage;
36
48enum XTPPropertyPageBorder
49{
50 xtpPageBorderNone,
51 xtpPageBorderBottomLine,
52 xtpPageBorderFrame
53};
54
64class _XTP_EXT_CLASS CXTPPropertySheet : public CXTPDialogEx
65{
67 DECLARE_DYNAMIC(CXTPPropertySheet)
69public:
78 CXTPPropertySheet();
79
93 CXTPPropertySheet(UINT nIDCaption, CWnd* pParentWnd = NULL, UINT iSelectPage = 0);
94
109 CXTPPropertySheet(LPCTSTR pszCaption, CWnd* pParentWnd = NULL, UINT iSelectPage = 0);
110
115 ~CXTPPropertySheet();
116
117public:
133 BOOL Create(CWnd* pParentWnd = NULL, DWORD dwStyle = (DWORD)-1, DWORD dwExStyle = 0);
134
135 using CXTPDialogEx::Create;
136# if (1200 < _MSC_VER)
137 using CWnd::Create;
138# endif
139
154 INT_PTR DoModal();
155
156public:
172 void AddPage(CXTPPropertyPage* pPage);
173
190 void InsertPage(int nIndex, CXTPPropertyPage* pPage);
191
202 void RemovePage(int nPage);
203
213 void RemovePage(CXTPPropertyPage* pPage);
214
224 int GetPageCount() const;
225
237 CXTPPropertyPage* GetPage(int nPage) const;
238
252 int GetPageIndex(CXTPPropertyPage* pPage) const;
253
265 CXTPPropertyPage* GetActivePage() const;
266
278 int GetActiveIndex() const;
279
293 virtual BOOL SetActivePage(int nPage);
294
307 virtual BOOL SetActivePage(CXTPPropertyPage* pPage);
317 void SetTitle(LPCTSTR lpszText);
318
325 CRect GetPageRect() const;
326
327public:
336 CXTPPropertyPageNavigator* GetNavigator() const;
337
358 void SetNavigator(CXTPPropertyPageNavigator* pNavigator);
359
360public:
371 virtual BOOL AddButton(UINT nIDCaption, UINT nID);
372
379 void RemoveButtons();
380
388 void SetPageBorderStyle(XTPPropertyPageBorder nBorder);
389
398 XTPPropertyPageBorder GetPageBorderStyle() const;
399
406 void SetResizable(BOOL bResizable = TRUE);
407
413 void SetPageSize(CSize szPage);
414
420 void SetPageSizeMin(CSize szPage);
421
427 void SetPageSizeMax(CSize szPage);
428
429public:
438 BOOL SavePlacement(LPCTSTR pszSection);
439
448 BOOL LoadPlacement(LPCTSTR pszSection);
449
461 BOOL AutoLoadPlacement(LPCTSTR pszSection);
462
468 void UpdatePages();
469
480 void SetTheme(XTPControlTheme theme);
481
488 XTPControlTheme GetTheme();
489
490protected:
497 virtual BOOL CreateButtons();
498
506 virtual BOOL CreatePage(CXTPPropertyPage* pPage);
507
509public:
510 CFont* GetFont();
511 void EndDialog(int nEndID);
512 virtual void RecalcLayout(LPSIZE pPageSize = NULL, BOOL bMoveWindow = FALSE);
513 BOOL IsWizard() const;
514 HWND GetNavigatorHwnd() const;
515
516protected:
517 void CommonConstruct(CWnd* pParentWnd, UINT iSelectPage);
518
519protected:
520 virtual BOOL CreateClient();
521 void ResizeParentToFit(CSize szClient, BOOL bMoveWindow);
522 BOOL IsPositionRelativeToWindow();
523 virtual void MoveButtons(AFX_SIZEPARENTPARAMS* pLayout, CSize szClient);
524 void CreateFont(CXTPPropertyPage* pActivePage);
525
526 virtual CXTPButton* CreateButton();
527
528private:
529 void PageInfoChanged(CXTPPropertyPage* pPage, BOOL bModified);
530 BOOL OnButtonClick(UINT nButton);
531 LRESULT SendPageNotify(CXTPPropertyPage* pPage, int code, LPARAM lParam = 0);
532 TCHAR ToUpper(TCHAR vkTCHAR);
535protected:
537 DECLARE_MESSAGE_MAP()
538 //{{AFX_VIRTUAL(CXTPPropertySheet)
539public:
540 virtual BOOL PreTranslateMessage(MSG* pMsg);
541
542protected:
543 virtual void DoDataExchange(CDataExchange* pDX);
544 virtual LRESULT WindowProc(UINT message, WPARAM wParam, LPARAM lParam);
545 virtual BOOL OnCommand(WPARAM wParam, LPARAM lParam);
546 //}}AFX_VIRTUAL
547
548 //{{AFX_MSG(CXTPPropertySheet)
549 afx_msg int OnCreate(LPCREATESTRUCT lpCreateStruct);
550 afx_msg void OnDestroy();
551 virtual BOOL OnInitDialog();
552 afx_msg LRESULT OnCommandHelp(WPARAM wParam, LPARAM lParam);
553 afx_msg void OnSysCommand(UINT nID, LPARAM lParam);
554 afx_msg void OnClose();
555 afx_msg void OnPaint();
556 afx_msg LRESULT OnQuerySiblings(WPARAM wParam, LPARAM lParam);
557 afx_msg void OnSize(UINT nType, int cx, int cy);
558 afx_msg LRESULT HandleInitDialog(WPARAM, LPARAM);
559 afx_msg BOOL OnEraseBkgnd(CDC* pDC);
560 afx_msg void OnGetMinMaxInfo(MINMAXINFO* pMMI);
561 //}}AFX_MSG
564protected:
565 CString m_strCaption;
566 LPDLGTEMPLATE m_lpDlgTemplate;
567 CArray<CButton*, CButton*> m_arrButtons;
568 CXTPPropertyPageNavigator* m_pNavigator;
569 CXTPFont m_xtpFontNormal;
570 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CFont, m_fntNormal, m_xtpFontNormal, GetNormalFontHandle);
571 CArray<CXTPPropertyPage*, CXTPPropertyPage*> m_arrPages;
572 CXTPPropertyPage* m_pActivePage;
573 CRect m_rcPage;
574 CRect m_rcMinPage;
575 CRect m_rcMaxPage;
576 BOOL m_bAllowApply;
577 BOOL m_bModeless;
578 BOOL m_bResizable;
579 CSize m_szWindow;
580 CSize m_szButton;
581 CXTPScrollBar m_scSizeIcon;
582 XTPPropertyPageBorder m_nPageBorderStyle;
584 CString m_strSection;
585
586 CXTPBrush m_brBack;
587
588public:
589 PROPSHEETHEADER m_psh;
591};
593AFX_INLINE int CXTPPropertySheet::GetPageCount() const
594{
595 return (int)m_arrPages.GetSize();
596}
597AFX_INLINE CXTPPropertyPageNavigator* CXTPPropertySheet::GetNavigator() const
598{
599 return m_pNavigator;
600}
601AFX_INLINE CFont* CXTPPropertySheet::GetFont()
602{
603 return &m_xtpFontNormal;
604}
605AFX_INLINE CRect CXTPPropertySheet::GetPageRect() const
606{
607 return m_rcPage;
608}
609AFX_INLINE XTPPropertyPageBorder CXTPPropertySheet::GetPageBorderStyle() const
610{
611 return m_nPageBorderStyle;
612}
613AFX_INLINE INT_PTR CXTPPropertySheet::DoModal()
614{
615 return CXTPDialogEx::DoModal();
616}
618# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
620#endif // !defined(__XTPPROPERTYSHEET_H__)
XTPControlTheme
XTPControlTheme
Enumeration used to determine the active theme style.
Definition XTPControlTheme.h:43
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPPropertyPageBorder
XTPPropertyPageBorder
XTPPropertyPageBorder is an enumeration used to set the client frame style drawn around the client of...
Definition XTPPropertySheet.h:49
xtpPageBorderFrame
@ xtpPageBorderFrame
Draw a page boarder.
Definition XTPPropertySheet.h:52
xtpPageBorderNone
@ xtpPageBorderNone
No page boarder.
Definition XTPPropertySheet.h:50
xtpPageBorderBottomLine
@ xtpPageBorderBottomLine
Draw a bottom border.
Definition XTPPropertySheet.h:51
CXTPBrush
Provides a convenient object oriented interface for HBRUSH GDI object and uses GDI handle caching.
Definition XTPGdiObjects.h:653
CXTPButton
Push Button control.
Definition XTPButton.h:109
CXTPDialogEx
CXTPDialogEx is a CXTPDialogBase derived class.
Definition Controls/Dialog/XTPDialogBase.h:358
CXTPFont
Provides a convenient object oriented interface for HFONT GDI object and uses GDI handle caching.
Definition XTPGdiObjects.h:414
CXTPPropertyPage
CXTPPropertyPage is a CPropertyPage derived class.
Definition XTPPropertyPage.h:43
CXTPPropertyPageNavigator
CXTPPropertyPageNavigator is a standalone class.
Definition XTPPropertyPageNavigator.h:44
CXTPPropertySheet
CXTPPropertySheet is a CXTPDialogEx derived class.
Definition XTPPropertySheet.h:65
CXTPPropertySheet::GetPageIndex
int GetPageIndex(CXTPPropertyPage *pPage) const
Call this member function to retrieve the index number of a specified page in the property sheet.
CXTPPropertySheet::SetActivePage
virtual BOOL SetActivePage(int nPage)
Call this member function to set the active page.
CXTPPropertySheet::SetPageSize
void SetPageSize(CSize szPage)
Call this member to set a custom size for property pages.
CXTPPropertySheet::CXTPPropertySheet
CXTPPropertySheet(UINT nIDCaption, CWnd *pParentWnd=NULL, UINT iSelectPage=0)
Constructs a CXTPPropertySheet object.
CXTPPropertySheet::LoadPlacement
BOOL LoadPlacement(LPCTSTR pszSection)
This member function loads saved window placement information from the registry.
CXTPPropertySheet::Create
BOOL Create(CWnd *pParentWnd=NULL, DWORD dwStyle=(DWORD) -1, DWORD dwExStyle=0)
Displays a modeless property sheet.
CXTPPropertySheet::SetPageSizeMin
void SetPageSizeMin(CSize szPage)
Call this member to set a minimun size for property pages.
CXTPPropertySheet::AddPage
void AddPage(CXTPPropertyPage *pPage)
Adds a page to the property sheet.
CXTPPropertySheet::CreatePage
virtual BOOL CreatePage(CXTPPropertyPage *pPage)
This method is called to create a property page window.
CXTPPropertySheet::InsertPage
void InsertPage(int nIndex, CXTPPropertyPage *pPage)
Adds a page to the property sheet.
CXTPPropertySheet::CXTPPropertySheet
CXTPPropertySheet(LPCTSTR pszCaption, CWnd *pParentWnd=NULL, UINT iSelectPage=0)
Constructs a CXTPPropertySheet object.
CXTPPropertySheet::AutoLoadPlacement
BOOL AutoLoadPlacement(LPCTSTR pszSection)
This member function loads saved window placement information from the registry.
CXTPPropertySheet::RemovePage
void RemovePage(int nPage)
This member function removes a page from the property sheet and destroys the associated window.
CXTPPropertySheet::RemovePage
void RemovePage(CXTPPropertyPage *pPage)
This member function removes a page from the property sheet and destroys the associated window.
CXTPPropertySheet::AddButton
virtual BOOL AddButton(UINT nIDCaption, UINT nID)
Adds a new button to the property sheet window.
CXTPPropertySheet::GetPageCount
int GetPageCount() const
Call this member function to determine the number of pages currently in the property sheet.
CXTPPropertySheet::~CXTPPropertySheet
~CXTPPropertySheet()
Destroys a CXTPPropertySheet object, handles cleanup and deallocation.
CXTPPropertySheet::RemoveButtons
void RemoveButtons()
Deletes all buttons from the property sheet.
CXTPPropertySheet::UpdatePages
void UpdatePages()
Forces all pages to update themselves as the data that they rely on is supposed to be changed from ou...
CXTPPropertySheet::CXTPPropertySheet
CXTPPropertySheet()
Constructs a CXTPPropertySheet object.
CXTPPropertySheet::GetActivePage
CXTPPropertyPage * GetActivePage() const
Call this member function to retrieve a pointer to the property sheet window's active page.
CXTPPropertySheet::SetPageBorderStyle
void SetPageBorderStyle(XTPPropertyPageBorder nBorder)
Sets a border style around a client page rectangle.
CXTPPropertySheet::GetPage
CXTPPropertyPage * GetPage(int nPage) const
Call this member function to retrieve a pointer to a specified page in the property sheet.
CXTPPropertySheet::GetPageRect
CRect GetPageRect() const
Retrieves the CRect bounding rectangle for all property pages.
CXTPPropertySheet::SetNavigator
void SetNavigator(CXTPPropertyPageNavigator *pNavigator)
Sets the navigator object that will be used to switch property pages.
CXTPPropertySheet::SetActivePage
virtual BOOL SetActivePage(CXTPPropertyPage *pPage)
Call this member function to set the active page.
CXTPPropertySheet::SavePlacement
BOOL SavePlacement(LPCTSTR pszSection)
This member function saves the window placement to the registry.
CXTPPropertySheet::SetTheme
void SetTheme(XTPControlTheme theme)
Call this member to switch the visual theme of the control.
CXTPPropertySheet::DoModal
INT_PTR DoModal()
Call this member function to display a modal property sheet.
CXTPPropertySheet::GetPageBorderStyle
XTPPropertyPageBorder GetPageBorderStyle() const
Retrieves the border style around a client page rectangle.
CXTPPropertySheet::GetTheme
XTPControlTheme GetTheme()
This method is called to retrieve the current theme ID.
CXTPPropertySheet::CreateButtons
virtual BOOL CreateButtons()
This method is called to create all property sheet buttons.
CXTPPropertySheet::GetActiveIndex
int GetActiveIndex() const
Call this member function to retrieve the index number of the property sheet window's active page.
CXTPPropertySheet::SetTitle
void SetTitle(LPCTSTR lpszText)
Call this member function to set the property sheet's caption (the text displayed in the title bar of...
CXTPPropertySheet::SetResizable
void SetResizable(BOOL bResizable=TRUE)
Call this member to allow the user to resize the property sheet.
CXTPPropertySheet::GetNavigator
CXTPPropertyPageNavigator * GetNavigator() const
Retrieves the currently used navigator object.
CXTPPropertySheet::SetPageSizeMax
void SetPageSizeMax(CSize szPage)
Call this member to set a maximum size for property pages.
CXTPScrollBar
Scrollbar control.
Definition XTPScrollBar.h:44


Toolkit Pro: Member List

CXTPTaskPanelVisualStudio2017Theme Member List

This is the complete list of members for CXTPTaskPanelVisualStudio2017Theme, including all inherited members.

BlendColor(COLORREF clrFrom, COLORREF clrTo, int nAlpha) | CXTPTaskPanelPaintManager | protected
CreateGripperBitmaps() | CXTPTaskPanelPaintManager | protected
CreateGripperIcon(HICON &hIcon, UINT nIDResource, COLORREF clrGripperBack) | CXTPTaskPanelPaintManager | protected
CXTPTaskPanelPaintManager() | CXTPTaskPanelPaintManager |
CXTPTaskPanelPaintManagerPlain() | CXTPTaskPanelPaintManagerPlain |
CXTPTaskPanelToolboxTheme() | CXTPTaskPanelToolboxTheme |
CXTPTaskPanelVisualStudio2005Theme() | CXTPTaskPanelVisualStudio2005Theme |
CXTPTaskPanelVisualStudio2012Theme(BOOL bLight=TRUE) | CXTPTaskPanelVisualStudio2012Theme |
CXTPTaskPanelVisualStudio2017Theme() | CXTPTaskPanelVisualStudio2017Theme |
DrawCaptionGripper(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelPaintManager | protectedvirtual
DrawCaptionGripperBitmap(CDC *pDC, CXTPTaskPanelGroup *pGroup, BOOL bExpanded, BOOL bHot, CRect rc) | CXTPTaskPanelPaintManager | protected
DrawCaptionGripperSigns(CDC *pDC, CPoint pt, COLORREF clr, BOOL bExpanded) | CXTPTaskPanelPaintManager | protected
DrawDragArrow(CDC *pDC, CXTPTaskPanelItem *pItem, CRect rc, BOOL bAfter=FALSE) | CXTPTaskPanelPaintManager | protectedvirtual
DrawFocusRect(CDC *pDC, CRect rc) | CXTPTaskPanelPaintManager | protectedvirtual
DrawGroupCaption(CDC *pDC, CXTPTaskPanelGroup *pGroup, BOOL bDraw) | CXTPTaskPanelToolboxTheme | virtual
DrawGroupCaptionBackground(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelVisualStudio2012Theme | virtual
DrawGroupClient(CDC *pDC, CXTPTaskPanelGroup *pGroup) | CXTPTaskPanelPaintManager | virtual
DrawGroupClientFace(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelVisualStudio2012Theme | virtual
DrawGroupClientItems(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelPaintManager | protectedvirtual
DrawGroupItem(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw) | CXTPTaskPanelPaintManager | virtual
DrawGroupItemFrame(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc) | CXTPTaskPanelVisualStudio2012Theme | virtual
DrawGroupItemImage(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw) | CXTPTaskPanelPaintManager | protected
DrawGroupItemImageWithText(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw) | CXTPTaskPanelPaintManager | protected
DrawGroupItemImageWithTextBelow(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw) | CXTPTaskPanelPaintManager | protected
DrawItemCaption(CDC *pDC, CXTPTaskPanelItem *pItem, CRect rcText, UINT nFormat) | CXTPTaskPanelVisualStudio2012Theme | virtual
DrawItemImage(CDC *pDC, CXTPTaskPanelItem *pItem, CPoint ptIcon, CXTPImageManagerIcon *pImage, CSize szIcon) | CXTPTaskPanelPaintManager | protectedvirtual
DrawScrollButton(CDC *pDC, CXTPTaskPanelScrollButton *pScrollButton) | CXTPTaskPanelPaintManager | virtual
FillGroupClientFace(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelVisualStudio2012Theme | virtual
FillTaskPanel(CDC *pDC, CXTPTaskPanel *pTaskPanel) | CXTPTaskPanelVisualStudio2012Theme | virtual
FreeBitmaps() | CXTPTaskPanelPaintManager | protected
GetCaptionGripperWidth(CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelPaintManager | protectedvirtual
GetControlMargins(const CXTPTaskPanel *pPanel) | CXTPTaskPanelPaintManager | virtual
GetGroupColors(BOOL bSpecial) | CXTPTaskPanelPaintManager |
GetGroupColors(CXTPTaskPanelGroup *pGroup) | CXTPTaskPanelPaintManager | virtual
GetGroupInnerMargins(const CXTPTaskPanelGroup *pGroup) | CXTPTaskPanelPaintManager | virtual
GetGroupOuterMargins(const CXTPTaskPanelGroup *pGroup) | CXTPTaskPanelPaintManager | virtual
GetGroupSpacing(const CXTPTaskPanel *pPanel) | CXTPTaskPanelPaintManager | virtual
GetHighlightOffset(CXTPTaskPanelGroupItem *pItem) | CXTPTaskPanelPaintManager | protectedvirtual
GetItemFont(CXTPTaskPanelItem *pItem) | CXTPTaskPanelPaintManager | virtual
GetItemIconPadding(const CXTPTaskPanelItem *pItem) | CXTPTaskPanelPaintManager | virtual
GetItemInnerMargins(const CXTPTaskPanelGroupItem *pItem) | CXTPTaskPanelPaintManager | virtual
GetItemOuterMargins(const CXTPTaskPanelGroupItem *pItem) | CXTPTaskPanelPaintManager | virtual
m_bBoldCaption | CXTPTaskPanelPaintManager |
m_bCaptionScrollButton | CXTPTaskPanelPaintManager |
m_bEmbossedDisabledText | CXTPTaskPanelPaintManager |
m_bEmulateEplorerTheme | CXTPTaskPanelPaintManager |
m_bInvertDragRect | CXTPTaskPanelPaintManager |
m_bLeftRoundedCorner | CXTPTaskPanelPaintManager | protected
m_bmpGrippers | CXTPTaskPanelPaintManager | protected
m_bOfficeBorder | CXTPTaskPanelPaintManager | protected
m_bOfficeCaption | CXTPTaskPanelPaintManagerPlain | protected
m_bOfficeHighlight | CXTPTaskPanelPaintManager |
m_bRightRoundedCorner | CXTPTaskPanelPaintManager | protected
m_bRoundedFrame | CXTPTaskPanelPaintManagerPlain | protected
m_bUseBitmapGrippers | CXTPTaskPanelPaintManager | protected
m_bUseStandardCaptionFont | CXTPTaskPanelPaintManager | protected
m_bUseStandardItemsFont | CXTPTaskPanelPaintManager | protected
m_clrBackground | CXTPTaskPanelPaintManager | protected
m_clrHighlightBorder | CXTPTaskPanelPaintManager | protected
m_clrHighlightHot | CXTPTaskPanelPaintManager | protected
m_clrHighlightPressed | CXTPTaskPanelPaintManager | protected
m_clrHighlightSelected | CXTPTaskPanelPaintManager | protected
m_clrSelectedText | CXTPTaskPanelVisualStudio2012Theme | protected
m_clrSelectedTextWithoutFocus | CXTPTaskPanelVisualStudio2012Theme | protected
m_clrSelectedWithoutFocus | CXTPTaskPanelVisualStudio2012Theme | protected
m_clrText | CXTPTaskPanelVisualStudio2012Theme | protected
m_eGripper | CXTPTaskPanelPaintManager |
m_groupNormal | CXTPTaskPanelPaintManager | protected
m_groupSpecial | CXTPTaskPanelPaintManager | protected
m_hGripperNormal | CXTPTaskPanelPaintManager | protected
m_hGripperSpecial | CXTPTaskPanelPaintManager | protected
m_nCaptionHeight | CXTPTaskPanelPaintManager | protected
m_nCaptionTextFormat | CXTPTaskPanelPaintManager | protected
m_nGroupSpacing | CXTPTaskPanelPaintManager |
m_nItemTextFormat | CXTPTaskPanelPaintManager | protected
m_rcControlMargins | CXTPTaskPanelPaintManager |
m_rcGroupIconPadding | CXTPTaskPanelPaintManager |
m_rcGroupInnerMargins | CXTPTaskPanelPaintManager |
m_rcGroupOuterMargins | CXTPTaskPanelPaintManager |
m_rcImageLayoutIconPadding | CXTPTaskPanelPaintManager |
m_rcItemIconPadding | CXTPTaskPanelPaintManager |
m_rcItemInnerMargins | CXTPTaskPanelPaintManager |
m_rcItemOuterMargins | CXTPTaskPanelPaintManager |
m_xtpFontCaption | CXTPTaskPanelPaintManager | protected
m_xtpFontIcon | CXTPTaskPanelPaintManager | protected
m_xtpFontIconBold | CXTPTaskPanelPaintManager | protected
m_xtpFontIconHot | CXTPTaskPanelPaintManager | protected
m_xtpFontIconHotBold | CXTPTaskPanelPaintManager | protected
Rectangle(CDC *pDC, CRect rc, COLORREF clrPen, COLORREF clrBrush) | CXTPTaskPanelPaintManager | protected
rectDefault | CXTPTaskPanelPaintManager | static
RefreshMetrics() | CXTPTaskPanelVisualStudio2017Theme | virtual
SetCaptionFontIndirect(LOGFONT *pLogFont, BOOL bUseStandardCaptionFont=FALSE) | CXTPTaskPanelPaintManager |
SetItemsFontIndirect(LOGFONT *pLogFont, BOOL bUseStandardItemsFont=FALSE) | CXTPTaskPanelPaintManager |
SetTextFormat(int nTextFormat, BOOL bCaption=FALSE) | CXTPTaskPanelPaintManager |
~CXTPTaskPanelPaintManager() | CXTPTaskPanelPaintManager | virtual
~CXTPTaskPanelVisualStudio2012Theme() | CXTPTaskPanelVisualStudio2012Theme | virtual
~CXTPTaskPanelVisualStudio2017Theme() | CXTPTaskPanelVisualStudio2017Theme | virtual


Toolkit Pro: XTPCaptionPopupWnd.h Source File

  • Source
  • Controls
  • Static
XTPCaptionPopupWnd.h
Go to the documentation of this file.
1
23#if !defined(__XTPCAPTIONPOPUPWND_H__)
24# define __XTPCAPTIONPOPUPWND_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPCaptionPopupWnd : public CWnd
39{
41 DECLARE_DYNAMIC(CXTPCaptionPopupWnd)
43public:
48 CXTPCaptionPopupWnd();
49
54 virtual ~CXTPCaptionPopupWnd();
55
56public:
68 virtual BOOL Create(const CRect& rect, CWnd* pParentWnd, CWnd* pChildWnd);
69
75 virtual void RecalcLayout();
76
84 virtual BOOL ResetParent();
85
93 virtual BOOL SendCancelMessage();
94
111 void SetTheme(XTPControlTheme nTheme);
112
113protected:
121 BOOL RegisterWindowClass();
122
123protected:
125 DECLARE_MESSAGE_MAP()
126
127 //{{AFX_MSG(CXTPCaptionPopupWnd)
128 afx_msg void OnDestroy();
129 afx_msg void OnCaptButton();
130 afx_msg void OnPaint();
131 afx_msg void OnTimer(UINT_PTR nIDEvent);
132 //}}AFX_MSG
135private:
136 BOOL Create(LPCTSTR lpszClassName, LPCTSTR lpszWindowName, DWORD dwStyle, const RECT& rect,
137 CWnd* pParentWnd, UINT nID, CCreateContext* pContext = NULL);
138
139protected:
140 CWnd* m_pParentWnd;
141 CWnd* m_pChildWnd;
142 CWnd* m_pChildParent;
143 CXTPCaption m_Caption;
144 CXTPCaptionButton m_CaptionButton;
145 CXTPIconHandle m_hIconOn;
146 CXTPIconHandle m_hIconOff;
147};
148
150
151AFX_INLINE BOOL CXTPCaptionPopupWnd::Create(LPCTSTR lpszClassName, LPCTSTR lpszWindowName,
152 DWORD dwStyle, const RECT& rect, CWnd* pParentWnd,
153 UINT nID, CCreateContext* pContext)
154{
155 return CWnd::Create(lpszClassName, lpszWindowName, dwStyle, rect, pParentWnd, nID, pContext);
156}
158# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
160#endif // #if !defined(__XTPCAPTIONPOPUPWND_H__)
XTPControlTheme
XTPControlTheme
Enumeration used to determine the active theme style.
Definition XTPControlTheme.h:43
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCaptionButton
CXTPCaptionButton is a CXTPButton derived class.
Definition XTPCaption.h:45
CXTPCaption
CXTPCaption is a CStatic derived class.
Definition XTPCaption.h:92
CXTPCaptionPopupWnd
CXTPCaptionPopupWnd is a CWnd derived class.
Definition XTPCaptionPopupWnd.h:39
CXTPCaptionPopupWnd::ResetParent
virtual BOOL ResetParent()
Call this member function to reset the parent of the child window back to its default.
CXTPCaptionPopupWnd::SendCancelMessage
virtual BOOL SendCancelMessage()
Call this member function to send a cancel message that will cause the pop-up to close.
CXTPCaptionPopupWnd::RecalcLayout
virtual void RecalcLayout()
Call this member function to recalculate the layout of the caption and child window.
CXTPCaptionPopupWnd::~CXTPCaptionPopupWnd
virtual ~CXTPCaptionPopupWnd()
Destroys a CXTPCaptionPopupWnd object, handles cleanup and deallocation.
CXTPCaptionPopupWnd::Create
virtual BOOL Create(const CRect &rect, CWnd *pParentWnd, CWnd *pChildWnd)
This member function is called to create and display the pop-up window.
CXTPCaptionPopupWnd::RegisterWindowClass
BOOL RegisterWindowClass()
Call this member function to register the window class for the pop-up window.
CXTPCaptionPopupWnd::SetTheme
void SetTheme(XTPControlTheme nTheme)
Call this member to switch the visual theme of the control.
CXTPCaptionPopupWnd::CXTPCaptionPopupWnd
CXTPCaptionPopupWnd()
Constructs a CXTPCaptionPopupWnd object.
CXTPIconHandle
CXTPIconHandle is a standalone helper class.
Definition XTPUtil.h:39


Toolkit Pro: XTPCoreTreeControl.h Source File

  • Source
  • Controls
  • CoreTree
XTPCoreTreeControl.h
Go to the documentation of this file.
1
23#if !defined(__XTPCORETREECONTROL_H__)
24# define __XTPCORETREECONTROL_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33# define XTP_TVN_CHECKCHANGED (TVN_FIRST - 110)
34
35class CXTPCoreTreeItems;
36class CXTPCoreTreePaintManager;
37class CXTPCoreTreeItem;
38class CXTPImageManager;
39class CXTPMarkupContext;
40
41enum XTPCoreTreeDropPosition
42{
43 xtpCoreTreeDropBefore,
44 xtpCoreTreeDropAfter,
45 xtpCoreTreeDropChild,
46};
47
49// CXTPCoreTreeControl window
50class _XTP_EXT_CLASS CXTPCoreTreeControl : public CWnd
51{
52 DECLARE_DYNAMIC(CXTPCoreTreeControl)
53 class CTreeDropTarget;
54
55public:
56 CXTPCoreTreeControl();
57 virtual ~CXTPCoreTreeControl();
58
59public:
60 BOOL RegisterWindowClass(HINSTANCE hInstance = NULL);
61
62public:
63 CXTPCoreTreeItems* GetItems() const;
64 void ResetContent();
65
66 void SetFocusedItem(CXTPCoreTreeItem* pItem);
67 CXTPCoreTreeItem* GetFocusedItem() const;
68
69 CXTPCoreTreeItem* GetDragOverItem() const;
70 XTPCoreTreeDropPosition GetDropPosition() const;
71
72public:
73 void SetPaintManager(CXTPCoreTreePaintManager* pPaintManager);
74 CXTPCoreTreePaintManager* GetPaintManager() const;
75
76 void SetImageManager(CXTPImageManager* pImageManager);
77 CXTPImageManager* GetImageManager() const;
78
79 void EnableTheme(BOOL bEnable);
80
81public:
82 using CWnd::Create;
83
84 BOOL Create(DWORD dwStyle, const RECT& rect, CWnd* pParentWnd, UINT nID);
85
86public:
87 void OnDraw(CDC* pDC, CRect rcClipBox);
88 void RecalcLayout();
89
90 void SetLockRedraw(BOOL bLockRedraw);
91
92 void OnCheckClicked(CXTPCoreTreeItem* pItem);
93
94public:
95 void RedrawControl(LPCRECT lpcRect = NULL);
96 CXTPCoreTreeItem* HitTest(CPoint point) const;
97
98 void EnsureVisible(CXTPCoreTreeItem* pItem);
99
100 int GetScrollOffset() const;
101 void OnScrollChanged(int nScrollOffset);
102
103public:
109 void EnableMarkup(BOOL bEnable = TRUE);
110
117 CXTPMarkupContext* GetMarkupContext() const;
118
129 BOOL IsDpiBitmapScalingEnabled() const;
130
140 void EnableDpiBitmapScaling(BOOL bEnable = TRUE);
141
142public:
143 void SetDragOverItem(CXTPCoreTreeItem* pDragOveritem,
144 XTPCoreTreeDropPosition nDropPosition = xtpCoreTreeDropAfter);
145
146public:
147 static CLIPFORMAT AFX_CDECL GetClipboardFormat();
148
149public:
150 LRESULT SendMessageToParent(int nMessage, NMHDR* pNMHDR = NULL);
151
152protected:
153 virtual void OnItemRemoved(CXTPCoreTreeItem* pItem);
154
155protected:
156 int RecalcTreeItems(CXTPCoreTreeItems* pItems, CDC* pDC, int nLevel, LPCRECT lprcMargin);
157 void DrawTreeItems(CXTPCoreTreeItems* pItems, CDC* pDC, CRect rcClipBox);
158 void ExpandeTreeItems(CXTPCoreTreeItems* pItems);
159
160 CXTPCoreTreeItem* HitTestTreeItems(CXTPCoreTreeItems* pItems, CPoint point) const;
161
162 CXTPCoreTreeItem* GetNextFocusableItem(CXTPCoreTreeItem* pFocusedItem) const;
163 CXTPCoreTreeItem* GetPrevFocusableItem(CXTPCoreTreeItem* pFocusedItem) const;
164
165 void UpdateScrollBar();
166
167protected:
168 BOOL DragItem(CXTPCoreTreeItem* pItem,
169 DROPEFFECT dropEffectMask = DROPEFFECT_COPY | DROPEFFECT_MOVE);
170
171 virtual void StartDragItem(CXTPCoreTreeItem* pItem);
172 virtual BOOL OnDrop(COleDataObject* pDataObject, DROPEFFECT dropEffect, CPoint point);
173 virtual DROPEFFECT OnDragOver(COleDataObject* pDataObject, DWORD dwKeyState, CPoint point);
174 virtual void OnDragHover(COleDataObject* pDataObject, DWORD dwKeyState, CPoint point);
175
176protected:
178 //{{AFX_VIRTUAL(CXTPCoreTreeControl)
179 virtual BOOL PreCreateWindow(CREATESTRUCT& cs);
180 virtual void PreSubclassWindow();
181 //}}AFX_VIRTUAL
182
183 //{{AFX_MSG(CXTPCoreTreeControl)
184 afx_msg void OnPaint();
185 afx_msg BOOL OnEraseBkgnd(CDC* pDC);
186 afx_msg void OnSize(UINT nType, int cx, int cy);
187 afx_msg void OnKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags);
188 afx_msg void OnLButtonDown(UINT nFlags, CPoint point);
189 afx_msg void OnSysColorChange();
190 afx_msg UINT OnGetDlgCode();
191 afx_msg void OnVScroll(UINT nSBCode, UINT nPos, CScrollBar* pScrollBar);
192 afx_msg BOOL OnMouseWheel(UINT nFlags, short zDelta, CPoint pt);
193 afx_msg void OnLButtonDblClk(UINT nFlags, CPoint point);
194 afx_msg void OnChar(UINT nChar, UINT nRepCnt, UINT nFlags);
195 afx_msg void OnMouseMove(UINT nFlags, CPoint point);
196 afx_msg void OnLButtonUp(UINT nFlags, CPoint point);
197 afx_msg void OnCaptureChanged(CWnd* pWnd);
198 afx_msg void OnNcPaint();
199 afx_msg void OnSetFocus(CWnd* pOldWnd);
200 afx_msg void OnKillFocus(CWnd* pNewWnd);
201 //}}AFX_MSG
202 afx_msg LRESULT OnPrintClient(WPARAM wParam, LPARAM /*lParam*/);
203 afx_msg LRESULT OnSetFont(WPARAM wParam, LPARAM lParam);
204 DECLARE_MESSAGE_MAP()
206protected:
207 BOOL m_bEnableTheme;
208 COLORREF m_clrBorder1;
209 COLORREF m_clrBorder2;
210
211 CXTPCoreTreeItems* m_pItems;
212 CXTPCoreTreePaintManager* m_pPaintManager;
213 CXTPImageManager* m_pImageManager;
214 BOOL m_bPreSubclassWindow;
215
216 int m_nClientHeight;
217 CRect m_rcControl;
218
219 BOOL m_bScrollVisible;
220 BOOL m_bInUpdateScrollBar;
221 int m_nLockRedraw;
223 CXTPCoreTreeItem* m_pFocusedItem;
224
225 CXTPCoreTreeItem* m_pPressedItem;
226 CXTPCoreTreeItem* m_pDraggingItem;
227 CXTPCoreTreeItem* m_pDragOverItem;
228 XTPCoreTreeDropPosition m_nDropPosition;
229 CPoint m_ptPressed;
230 CTreeDropTarget* m_pDropTarget;
231 static CLIPFORMAT m_cfItem;
233 CXTPMarkupContext* m_pMarkupContext;
234
235private:
236 BOOL m_bDpiBitmapScaling;
237 BOOL m_bDpiBitmapScalingModified;
238
239 friend class CXTPCoreTreeItems;
240 friend class CTreeDropTarget;
241};
243AFX_INLINE CXTPCoreTreeItems* CXTPCoreTreeControl::GetItems() const
244{
245 return m_pItems;
246}
247
248AFX_INLINE CXTPCoreTreePaintManager* CXTPCoreTreeControl::GetPaintManager() const
249{
250 return m_pPaintManager;
251}
252AFX_INLINE CXTPCoreTreeItem* CXTPCoreTreeControl::GetFocusedItem() const
253{
254 return m_pFocusedItem;
255}
256AFX_INLINE CXTPImageManager* CXTPCoreTreeControl::GetImageManager() const
257{
258 return m_pImageManager;
259}
260AFX_INLINE CXTPCoreTreeItem* CXTPCoreTreeControl::GetDragOverItem() const
261{
262 return m_pDragOverItem;
263}
264AFX_INLINE XTPCoreTreeDropPosition CXTPCoreTreeControl::GetDropPosition() const
265{
266 return m_nDropPosition;
267}
268AFX_INLINE CLIPFORMAT AFX_CDECL CXTPCoreTreeControl::GetClipboardFormat()
269{
270 return m_cfItem;
271}
272AFX_INLINE CXTPMarkupContext* CXTPCoreTreeControl::GetMarkupContext() const
273{
274 return m_pMarkupContext;
275}
277# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
279#endif // !defined(__XTPCORETREECONTROL_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPImageManager
CXTPImageManager is a standalone class.
Definition XTPImageManager.h:1898
CXTPMarkupContext
CXTPMarkupContext is a standalone class used to provide common settings for Markup objects.
Definition XTPMarkupContext.h:128


Toolkit Pro: XTPFramePaintManager.h Source File

  • Source
  • CommandBars
  • Frame
XTPFramePaintManager.h
Go to the documentation of this file.
1
23#if !defined(__XTPFRAMEPAINTMANAGER_H__)
24# define __XTPFRAMEPAINTMANAGER_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPCommandBarsFrameHook;
34class CXTPFrameShadow;
35class CXTPRibbonBar;
36
40class _XTP_EXT_CLASS CXTPFramePaintManager : public CObject
41{
42 DECLARE_DYNAMIC(CXTPFramePaintManager);
43
44public:
51 CXTPFramePaintManager(CXTPPaintManager* pPaintManager);
52
58 virtual ~CXTPFramePaintManager();
59
60public:
67 void SetIcon(HICON hIcon, CSize szIcon);
68
69public:
76 virtual CRect CalcFrameCaption(const CXTPCommandBarsFrameHook* pFrameHook) const;
77
84 virtual CRect CalcFrameBorder(const CXTPCommandBarsFrameHook* pFrameHook) const;
85
86public:
87 virtual void RecalcLayout(CXTPCommandBarsFrameHook* pFrameHook);
88
99 virtual HRGN CalcFrameRegion(CXTPCommandBarsFrameHook* pFrameHook, CSize sz) const = 0;
100
108 virtual void DrawFrame(CDC* pDC, CXTPCommandBarsFrameHook* pFrameHook) = 0;
109
110 virtual void DrawFrameIcon(CDC* pDC, CXTPCommandBarsFrameHook* pFrameHook, CRect& rcCaption);
111
112 virtual void DrawFrameCaptionButtons(CDC* pDC, CXTPCommandBarsFrameHook* pFrameHook,
113 CRect& rcCaptionText);
114
126 virtual void DrawFrameCaptionButton(CDC* pDC, CRect rc, int nId, BOOL bSelected, BOOL bPressed,
127 BOOL bActive) = 0;
128
141 virtual void DrawFrameCaptionButton(CDC* pDC, CRect rc, int nId, BOOL bSelected, BOOL bPressed,
142 BOOL bActive, CXTPRibbonBar* pRibbonBar) = 0;
143
144 virtual CSize GetCaptionButtonSize(UINT nId) const;
145 virtual CSize GetCaptionButtonSize(UINT nId, HWND hwnd) const;
146
147 virtual CRect GetCaptionButtonMargin() const;
148
154 virtual COLORREF GetFrameCaptionAccentTextColor(BOOL bActive) const;
155
161 BOOL IsUseSystemAccentColorEnabled() const;
162
170 virtual int GetFrameCaptionHeight() const;
171
176 virtual void RefreshMetrics();
177
185 CXTPResourceImages* GetImages() const;
186
196 virtual void DrawCaptionText(CDC* pDC, CRect rcCaptionText, CWnd* pSite, BOOL bActive);
197
208 virtual void DrawCaptionText(CDC* pDC, CRect rcCaptionText, CWnd* pSite, BOOL bActive,
209 CXTPRibbonBar* pRibbonBar);
210
220 virtual void DrawCaptionBar(CDC* pDC, CRect rcCaptionBar, CWnd* pSite, BOOL bActive);
221
244 CXTPResourceImage* LoadImage(LPCTSTR lpszFileName);
245
258 HICON GetFrameSmallIcon(CWnd* pFrame);
259
272 HICON GetFrameLargeIcon(CWnd* pFrame);
273
287 virtual CXTPFrameShadow* CreateShadow(CWnd* pFrame);
288
301 virtual void OnShadowedFrameActiveStateChanged(BOOL bActive, CWnd* pFrame,
302 CXTPFrameShadow* pShadow);
303
309 const CXTPPaintManagerColor& GetFrameCaptionActiveColor() const;
310
311public:
312 BOOL m_bFrameStatusBar;
313 BOOL m_bRoundedCornersAlways;
314
315 CXTPPaintManagerFont m_fntFrameCaption;
317public:
318 int m_nFrameCaptionHeight;
320 CXTPPaintManager* m_pPaintManager;
322 BOOL m_bFlatFrame;
323 BOOL m_bCaptionCenterAligned;
325protected:
326 HICON m_hIcon;
327 CSize m_szIcon;
328 CRect m_rcIconMargin;
329 CRect m_rcCaptionButtonMargin;
330 CSize m_szCaptionButtonSize;
331 CSize m_szMDIClildWindowCaptionButtonSize;
332
333 CXTPPaintManagerColor m_clrFrameCaptionActive;
334 CXTPPaintManagerColor m_clrFrameCaptionInactive;
335 CXTPPaintManagerColor m_clrFrameCaptionTextActive;
336 CXTPPaintManagerColor m_clrFrameCaptionTextInactive;
337 CXTPPaintManagerColor m_clrFrameCaptionTextActiveTitle;
338 CXTPPaintManagerColor m_clrFrameCaptionTextActiveBSMode;
339 CXTPPaintManagerColor m_clrFrameCaptionTextInactiveBSMode;
340 CXTPPaintManagerColor m_clrFrameCaptionTextActiveTitleBSMode;
342 friend class CXTPMenuTitleBarCaption;
343};
344
345AFX_INLINE int CXTPFramePaintManager::GetFrameCaptionHeight() const
346{
347 return m_nFrameCaptionHeight;
348}
349
350AFX_INLINE CRect CXTPFramePaintManager::GetCaptionButtonMargin() const
351{
352 return m_rcCaptionButtonMargin;
353}
354
355AFX_INLINE CSize CXTPFramePaintManager::GetCaptionButtonSize(UINT /*nId*/) const
356{
357 return m_szCaptionButtonSize;
358}
359
360AFX_INLINE const CXTPPaintManagerColor& CXTPFramePaintManager::GetFrameCaptionActiveColor() const
361{
362 return m_clrFrameCaptionActive;
363}
364
366# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
367#endif // !defined(__XTPFRAMEPAINTMANAGER_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCommandBarsFrameHook
CXTPCommandBarsFrameHook is a CXTPHookManagerHookAble derived class.
Definition XTPFrameHook.h:56
CXTPFramePaintManager
Paint manager for the Office 2007 style window frame.
Definition XTPFramePaintManager.h:41
CXTPFramePaintManager::m_bFrameStatusBar
BOOL m_bFrameStatusBar
TRUE if status bar used to draw.
Definition XTPFramePaintManager.h:312
CXTPFramePaintManager::SetIcon
void SetIcon(HICON hIcon, CSize szIcon)
Sets the frame icon.
CXTPFramePaintManager::GetFrameSmallIcon
HICON GetFrameSmallIcon(CWnd *pFrame)
Retrieves frame small icon.
CXTPFramePaintManager::DrawFrameCaptionButton
virtual void DrawFrameCaptionButton(CDC *pDC, CRect rc, int nId, BOOL bSelected, BOOL bPressed, BOOL bActive)=0
This method is called to draw the caption button.
CXTPFramePaintManager::CXTPFramePaintManager
CXTPFramePaintManager(CXTPPaintManager *pPaintManager)
Constructs a CXTPFramePaintManager object.
CXTPFramePaintManager::m_clrFrameCaptionTextActive
CXTPPaintManagerColor m_clrFrameCaptionTextActive
Caption text color.
Definition XTPFramePaintManager.h:335
CXTPFramePaintManager::m_clrFrameCaptionInactive
CXTPPaintManagerColor m_clrFrameCaptionInactive
Caption color (inactive)
Definition XTPFramePaintManager.h:334
CXTPFramePaintManager::m_clrFrameCaptionTextActiveTitle
CXTPPaintManagerColor m_clrFrameCaptionTextActiveTitle
Caption text color.
Definition XTPFramePaintManager.h:337
CXTPFramePaintManager::DrawFrameCaptionButton
virtual void DrawFrameCaptionButton(CDC *pDC, CRect rc, int nId, BOOL bSelected, BOOL bPressed, BOOL bActive, CXTPRibbonBar *pRibbonBar)=0
This method is called to draw the caption button.
CXTPFramePaintManager::m_pPaintManager
CXTPPaintManager * m_pPaintManager
Parent Paint Manager.
Definition XTPFramePaintManager.h:320
CXTPFramePaintManager::OnShadowedFrameActiveStateChanged
virtual void OnShadowedFrameActiveStateChanged(BOOL bActive, CWnd *pFrame, CXTPFrameShadow *pShadow)
An implementation can override this method in order to change frame appearance when a window gets act...
CXTPFramePaintManager::CalcFrameRegion
virtual HRGN CalcFrameRegion(CXTPCommandBarsFrameHook *pFrameHook, CSize sz) const =0
This method is called to create the window region.
CXTPFramePaintManager::m_bCaptionCenterAligned
BOOL m_bCaptionCenterAligned
If TRUE, caption title will be center aligned.
Definition XTPFramePaintManager.h:323
CXTPFramePaintManager::GetFrameCaptionActiveColor
const CXTPPaintManagerColor & GetFrameCaptionActiveColor() const
Obtains theme specific active frame caption color value.
Definition XTPFramePaintManager.h:360
CXTPFramePaintManager::DrawCaptionText
virtual void DrawCaptionText(CDC *pDC, CRect rcCaptionText, CWnd *pSite, BOOL bActive, CXTPRibbonBar *pRibbonBar)
This method is called to draw the frame caption text.
CXTPFramePaintManager::m_nFrameCaptionHeight
int m_nFrameCaptionHeight
Frame caption.
Definition XTPFramePaintManager.h:318
CXTPFramePaintManager::m_fntFrameCaption
CXTPPaintManagerFont m_fntFrameCaption
Font used to draw text in the frame caption.
Definition XTPFramePaintManager.h:315
CXTPFramePaintManager::m_clrFrameCaptionTextInactiveBSMode
CXTPPaintManagerColor m_clrFrameCaptionTextInactiveBSMode
Caption text color.
Definition XTPFramePaintManager.h:339
CXTPFramePaintManager::m_clrFrameCaptionTextActiveTitleBSMode
CXTPPaintManagerColor m_clrFrameCaptionTextActiveTitleBSMode
Caption text color.
Definition XTPFramePaintManager.h:340
CXTPFramePaintManager::CalcFrameCaption
virtual CRect CalcFrameCaption(const CXTPCommandBarsFrameHook *pFrameHook) const
Calculates the frame caption rect.
CXTPFramePaintManager::m_szIcon
CSize m_szIcon
Icon size.
Definition XTPFramePaintManager.h:327
CXTPFramePaintManager::LoadImage
CXTPResourceImage * LoadImage(LPCTSTR lpszFileName)
Loads a bitmap image from the specified path.
CXTPFramePaintManager::DrawCaptionText
virtual void DrawCaptionText(CDC *pDC, CRect rcCaptionText, CWnd *pSite, BOOL bActive)
This method is called to draw the frame caption text.
CXTPFramePaintManager::DrawCaptionBar
virtual void DrawCaptionBar(CDC *pDC, CRect rcCaptionBar, CWnd *pSite, BOOL bActive)
This method is called to draw the frame caption bar.
CXTPFramePaintManager::IsUseSystemAccentColorEnabled
BOOL IsUseSystemAccentColorEnabled() const
Determines whether xtpApplicationUseSystemAccentColor application ambient property is set.
CXTPFramePaintManager::m_hIcon
HICON m_hIcon
Icon handle.
Definition XTPFramePaintManager.h:326
CXTPFramePaintManager::GetImages
CXTPResourceImages * GetImages() const
This method is called to get a pointer to the CXTPResourceImages object.
CXTPFramePaintManager::CalcFrameBorder
virtual CRect CalcFrameBorder(const CXTPCommandBarsFrameHook *pFrameHook) const
Calculates the frame border sizes.
CXTPFramePaintManager::m_rcIconMargin
CRect m_rcIconMargin
Icon margin.
Definition XTPFramePaintManager.h:328
CXTPFramePaintManager::~CXTPFramePaintManager
virtual ~CXTPFramePaintManager()
Destroys a CXTPFramePaintManager object, handles cleanup and deallocation.
CXTPFramePaintManager::RefreshMetrics
virtual void RefreshMetrics()
This method is called to refresh the visual metrics of the manager.
CXTPFramePaintManager::DrawFrame
virtual void DrawFrame(CDC *pDC, CXTPCommandBarsFrameHook *pFrameHook)=0
This method is called to draw the frame if Ribbon was found.
CXTPFramePaintManager::m_clrFrameCaptionTextInactive
CXTPPaintManagerColor m_clrFrameCaptionTextInactive
Caption text color.
Definition XTPFramePaintManager.h:336
CXTPFramePaintManager::m_clrFrameCaptionActive
CXTPPaintManagerColor m_clrFrameCaptionActive
Caption color (active)
Definition XTPFramePaintManager.h:333
CXTPFramePaintManager::m_clrFrameCaptionTextActiveBSMode
CXTPPaintManagerColor m_clrFrameCaptionTextActiveBSMode
Caption text color.
Definition XTPFramePaintManager.h:338
CXTPFramePaintManager::GetFrameCaptionAccentTextColor
virtual COLORREF GetFrameCaptionAccentTextColor(BOOL bActive) const
Obtains frame caption accent color.
CXTPFramePaintManager::m_bFlatFrame
BOOL m_bFlatFrame
TRUE to use a flat frame, FALSE otherwise.
Definition XTPFramePaintManager.h:322
CXTPFramePaintManager::GetFrameLargeIcon
HICON GetFrameLargeIcon(CWnd *pFrame)
Retrieves frame large icon.
CXTPFramePaintManager::GetFrameCaptionHeight
virtual int GetFrameCaptionHeight() const
Retrieves the frame caption's height.
Definition XTPFramePaintManager.h:345
CXTPFramePaintManager::CreateShadow
virtual CXTPFrameShadow * CreateShadow(CWnd *pFrame)
Creates frame shadow if supported by theme.
CXTPFrameShadow
The class represents frame shadow object.
Definition XTPFrameShadow.h:47
CXTPPaintManagerColor
The CXTPPaintManagerColor class is used to manage COLORREF values for determining default and applica...
Definition XTPColorManager.h:117
CXTPPaintManagerFont
PaintManagers used CFont wrapper.
Definition XTPPaintManager.h:113
CXTPPaintManager
Paint manager of the command bars.
Definition XTPPaintManager.h:199
CXTPResourceImage
Represent a resource image and provides basic images functions.
Definition XTPResourceImage.h:48
CXTPResourceImages
Implements resource image collection and its operations.
Definition XTPResourceImage.h:257
CXTPRibbonBar
CXTPRibbonBar is a CXTPMenuBar derived class.
Definition XTPRibbonBar.h:69


Toolkit Pro: Member List

CXTPChartSplineDeviceCommand Member List

This is the complete list of members for CXTPChartSplineDeviceCommand, including all inherited members.

AddChildCommand(CXTPChartDeviceCommand *pCommand) | CXTPChartDeviceCommand |
AfterExecute(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
ApplySeriesStyle(CXTPChartSeriesStyle *pStyle) | CXTPChartDeviceCommand | virtual
BeforeExecute(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
BindView(CXTPChartElementView *pView) | CXTPChartDeviceCommand |
Commit() | CXTPChartDeviceCommand |
CXTPChartDeviceCommand() | CXTPChartDeviceCommand |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartSplineDeviceCommand(const CXTPChartPoints &p, int thickness) | CXTPChartSplineDeviceCommand | protected
CXTPObservable() | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | protected
Execute(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
ExecuteOverride(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
GetBoundView() const | CXTPChartDeviceCommand |
GetChildCommand(int nIndex) const | CXTPChartDeviceCommand |
GetChildCommandCount() const | CXTPChartDeviceCommand |
GetCurrentDC() const | CXTPChartDeviceCommand |
GetPassNumber() const | CXTPChartDeviceCommand |
HitTest(CPoint point, CXTPChartElement *pParent) const | CXTPChartDeviceCommand | virtual
Is3D() const | CXTPChartObject |
IsCommitted() const | CXTPChartDeviceCommand |
IsEnabled() const | CXTPChartDeviceCommand | virtual
m_arrChildren | CXTPChartDeviceCommand | protected
m_nThickness | CXTPChartSplineDeviceCommand | protected
m_p | CXTPChartSplineDeviceCommand | protected
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Prepare(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
PrepareOverride(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
SetEnabled(BOOL bEnabled=TRUE) | CXTPChartDeviceCommand |
Subscribe(CXTPChartDeviceCommandEvents *pObserver, CXTPSubscriptionList< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > *pSubcriptionList=NULL) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > |
Unsubscribe(CXTPChartDeviceCommandEvents *pObserver) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > |
~CXTPChartDeviceCommand() | CXTPChartDeviceCommand | virtual
~CXTPObservable() | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | protected


Toolkit Pro: Member List

CXTPPropertyGridItemMetrics Member List

This is the complete list of members for CXTPPropertyGridItemMetrics, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPPropertyGridItemMetrics(CXTPPropertyGridPaintManager *pPaintManager) | CXTPPropertyGridItemMetrics |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
m_clrBack | CXTPPropertyGridItemMetrics |
m_clrCategoryFore | CXTPPropertyGridItemMetrics |
m_clrFore | CXTPPropertyGridItemMetrics |
m_clrHelpBack | CXTPPropertyGridItemMetrics |
m_clrHelpFore | CXTPPropertyGridItemMetrics |
m_clrLine | CXTPPropertyGridItemMetrics |
m_clrReadOnlyFore | CXTPPropertyGridItemMetrics |
m_clrVerbFace | CXTPPropertyGridItemMetrics |
m_nImage | CXTPPropertyGridItemMetrics |
m_nMaxLength | CXTPPropertyGridItemMetrics |
m_pPaintManager | CXTPPropertyGridItemMetrics | protected
m_uDrawTextFormat | CXTPPropertyGridItemMetrics |
m_xtpFontBold | CXTPPropertyGridItemMetrics |
m_xtpFontNormal | CXTPPropertyGridItemMetrics |
m_xtpFontUnderline | CXTPPropertyGridItemMetrics |
SetDefaultValues() | CXTPPropertyGridItemMetrics | virtual


Toolkit Pro: XTPMarkupStatic.h Source File

  • Source
  • Controls
  • Static
XTPMarkupStatic.h
Go to the documentation of this file.
1
23#if !defined(__MARKUPSTATIC_H__)
24# define __MARKUPSTATIC_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33# ifdef _XTP_INCLUDE_MARKUP
34
35class CXTPMarkupUIElement;
36class CXTPMarkupContext;
37
42class _XTP_EXT_CLASS CXTPMarkupStatic : public CStatic
43{
44public:
49 CXTPMarkupStatic();
50
55 virtual ~CXTPMarkupStatic();
56
57public:
63 void SetMarkupText(LPCSTR lpszMarkup);
64
70 void SetMarkupText(LPCWSTR lpszMarkup);
71
80 void SetMarkupTextEx(LPCSTR lpszMarkup, UINT nCodePage = CP_UTF8);
81
90 void SetMarkupTextEx(LPCWSTR lpszMarkup, UINT nCodePage = CP_UTF8);
91
98 CXTPMarkupContext* GetMarkupContext() const;
99
106 CXTPMarkupUIElement* GetUIElement() const;
107
108 void SetIgnoreRTL(BOOL value);
109
110protected:
111 DECLARE_MESSAGE_MAP()
112
113 //{{AFX_VIRTUAL(CXTPMarkupStatic)
114 BOOL OnWndMsg(UINT message, WPARAM wParam, LPARAM lParam, LRESULT* pResult);
115 //}}AFX_VIRTUAL
116
117 //{{AFX_MSG(CXTPMarkupStatic)
118 afx_msg void OnPaint();
119 //}}AFX_MSG
120
121 CXTPMarkupUIElement* m_pUIElement;
122 CXTPMarkupContext* m_pMarkupContext;
123
124 BOOL m_bIgnoreRTL;
125};
126
128
129AFX_INLINE CXTPMarkupContext* CXTPMarkupStatic::GetMarkupContext() const
130{
131 return m_pMarkupContext;
132}
133
134AFX_INLINE CXTPMarkupUIElement* CXTPMarkupStatic::GetUIElement() const
135{
136 return m_pUIElement;
137}
138AFX_INLINE void CXTPMarkupStatic::SetIgnoreRTL(BOOL value)
139{
140 m_bIgnoreRTL = value;
141}
143# endif
144
145//{{AFX_INSERT_LOCATION}}
146// Microsoft Visual C++ will insert additional declarations immediately before the previous line.
147
148# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
150#endif // !defined(__MARKUPSTATIC_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPMarkupContext
CXTPMarkupContext is a standalone class used to provide common settings for Markup objects.
Definition XTPMarkupContext.h:128
CXTPMarkupUIElement
Base class for XML Markup core level implementations.
Definition XTPMarkupUIElement.h:43


Toolkit Pro: XTPTabManagerAtom.h Source File

  • Source
  • TabManager
XTPTabManagerAtom.h
Go to the documentation of this file.
1
23#if !defined(__XTPTABMANAGERATOM_H__)
24# define __XTPTABMANAGERATOM_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
48class _XTP_EXT_CLASS CXTPTabManagerAtom
49{
50public:
57 virtual void OnPropertyChanged()
58 {
59 Reposition();
60 }
61
68 virtual void Reposition() = 0;
69
70protected:
75 virtual ~CXTPTabManagerAtom()
76 {
77 }
78};
79
80# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
82#endif // !defined(__XTPTABMANAGERATOM_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPTabManagerAtom
CXTPTabManagerAtom is a class that has only one purpose; to catch the event when a property of the Pa...
Definition XTPTabManagerAtom.h:49
CXTPTabManagerAtom::~CXTPTabManagerAtom
virtual ~CXTPTabManagerAtom()
Destroys a CXTPTabManagerAtom object, handles cleanup and deallocation.
Definition XTPTabManagerAtom.h:75
CXTPTabManagerAtom::Reposition
virtual void Reposition()=0
Recalculates the layout of the tab manager and then repositions itself.
CXTPTabManagerAtom::OnPropertyChanged
virtual void OnPropertyChanged()
This method is called when a property of the tab paint manager is changed.
Definition XTPTabManagerAtom.h:57


Toolkit Pro: Member List

CXTPPropertyGridItemBool Member List

This is the complete list of members for CXTPPropertyGridItemBool, including all inherited members.

AddChildItem(CXTPPropertyGridItem *pItem) | CXTPPropertyGridItem |
AddComboButton() | CXTPPropertyGridItem |
AddExpandButton() | CXTPPropertyGridItem |
AddSliderControl() | CXTPPropertyGridItem |
AddSpinButton() | CXTPPropertyGridItem |
BindToBool(BOOL *pBindBool) | CXTPPropertyGridItemBool | virtual
BindToString(CString *pBindString) | CXTPPropertyGridItem |
Collapse() | CXTPPropertyGridItem |
CXTPCmdTarget() | CXTPCmdTarget |
CXTPPropertyGridItem(LPCTSTR lpszCaption, LPCTSTR strValue=NULL, CString *pBindString=NULL) | CXTPPropertyGridItem |
CXTPPropertyGridItem(UINT nID, LPCTSTR strValue=NULL, CString *pBindString=NULL) | CXTPPropertyGridItem |
CXTPPropertyGridItemBool(LPCTSTR strCaption, BOOL bValue=FALSE, BOOL *pBindBool=NULL) | CXTPPropertyGridItemBool |
CXTPPropertyGridItemBool(UINT nID, BOOL bValue=FALSE, BOOL *pBindBool=NULL) | CXTPPropertyGridItemBool |
EnsureVisible() | CXTPPropertyGridItem |
Expand() | CXTPPropertyGridItem |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetBool() const | CXTPPropertyGridItemBool | virtual
GetCaption() const | CXTPPropertyGridItem |
GetCaptionMetrics() const | CXTPPropertyGridItem |
GetChilds() const | CXTPPropertyGridItem |
GetConstraintEdit() const | CXTPPropertyGridItem |
GetConstraints() const | CXTPPropertyGridItem |
GetDefaultValue() const | CXTPPropertyGridItem |
GetDescription() const | CXTPPropertyGridItem |
GetDropDownItemCount() const | CXTPPropertyGridItem |
GetEditStyle() const | CXTPPropertyGridItem | virtual
GetFlags() const | CXTPPropertyGridItem |
GetGrid() const | CXTPPropertyGridItem |
GetHeight() const | CXTPPropertyGridItem |
GetID() const | CXTPPropertyGridItem |
GetIndent() const | CXTPPropertyGridItem |
GetIndex() const | CXTPPropertyGridItem |
GetInplaceButtons() const | CXTPPropertyGridItem |
GetInplaceControls() const | CXTPPropertyGridItem |
GetInPlacedEditValue() | CXTPPropertyGridItem | inlineprotectedvirtual
GetInplaceEdit() | CXTPPropertyGridItem | virtual
GetInplaceList() | CXTPPropertyGridItem | protectedvirtual
GetItemData() const | CXTPPropertyGridItem |
GetItemRect() const | CXTPPropertyGridItem |
GetMarkupCaption() const | CXTPPropertyGridItem |
GetMarkupDescription() const | CXTPPropertyGridItem |
GetMarkupTemplate() const | CXTPPropertyGridItem | virtual
GetMarkupValue() const | CXTPPropertyGridItem |
GetMaskedText() const | CXTPPropertyGridItem |
GetMetrics(BOOL bValueMetrics, BOOL bCreate=TRUE) const | CXTPPropertyGridItem |
GetMultiLinesCount() const | CXTPPropertyGridItem |
GetParentItem() const | CXTPPropertyGridItem |
GetReadOnly() const | CXTPPropertyGridItem | virtual
GetTooltip() const | CXTPPropertyGridItem |
GetValue() const | CXTPPropertyGridItem |
GetValueMetrics() const | CXTPPropertyGridItem |
GetValueRect() | CXTPPropertyGridItem | virtual
GetViewValue() | CXTPPropertyGridItemBool | protectedvirtual
HasChilds() const | CXTPPropertyGridItem |
HasParent(CXTPPropertyGridItem *pParent) | CXTPPropertyGridItem |
HasVisibleChilds() const | CXTPPropertyGridItem |
InsertChildItem(int nIndex, CXTPPropertyGridItem *pItem) | CXTPPropertyGridItem |
IsAllowEdit() const | CXTPPropertyGridItem | virtual
IsCategory() const | CXTPPropertyGridItem |
IsCheckBoxStyle() const | CXTPPropertyGridItemBool |
IsExpandable() const | CXTPPropertyGridItem |
IsExpanded() const | CXTPPropertyGridItem |
IsHidden() const | CXTPPropertyGridItem |
IsInplaceButtonVisible(CXTPPropertyGridInplaceButton *pButton) const | CXTPPropertyGridItem | virtual
IsMultiLine() const | CXTPPropertyGridItem |
IsSelected() const | CXTPPropertyGridItem |
IsValueChanged() const | CXTPPropertyGridItem | virtual
IsVisible() const | CXTPPropertyGridItem |
m_bAutoComplete | CXTPPropertyGridItem | protected
m_bCategory | CXTPPropertyGridItem | protected
m_bCheckBoxStyle | CXTPPropertyGridItemBool | protected
m_bConstraintEdit | CXTPPropertyGridItem | protected
m_bExpandable | CXTPPropertyGridItem | protected
m_bExpanded | CXTPPropertyGridItem | protected
m_bHidden | CXTPPropertyGridItem | protected
m_bPassword | CXTPPropertyGridItem | protected
m_bReadOnly | CXTPPropertyGridItem | protected
m_bUseMask | CXTPPropertyGridItem | protected
m_bValue | CXTPPropertyGridItemBool | protected
m_bVisible | CXTPPropertyGridItem | protected
m_chPrompt | CXTPPropertyGridItem | protected
m_dwData | CXTPPropertyGridItem | protected
m_dwEditStyle | CXTPPropertyGridItem | protected
m_nDropDownItemCount | CXTPPropertyGridItem | protected
m_nFlags | CXTPPropertyGridItem | protected
m_nHeight | CXTPPropertyGridItem | protected
m_nID | CXTPPropertyGridItem | protected
m_nIndent | CXTPPropertyGridItem | protected
m_nIndex | CXTPPropertyGridItem | protected
m_nLinesCount | CXTPPropertyGridItem | protected
m_pBindBool | CXTPPropertyGridItemBool | protected
m_pBindString | CXTPPropertyGridItem | protected
m_pCaptionMetrics | CXTPPropertyGridItem | mutableprotected
m_pChilds | CXTPPropertyGridItem | protected
m_pConstraints | CXTPPropertyGridItem | protected
m_pGrid | CXTPPropertyGridItem | protected
m_pInplaceButtons | CXTPPropertyGridItem | protected
m_pInplaceControls | CXTPPropertyGridItem | protected
m_pMarkupCaption | CXTPPropertyGridItem | protected
m_pMarkupDescription | CXTPPropertyGridItem | protected
m_pMarkupValue | CXTPPropertyGridItem | protected
m_pParent | CXTPPropertyGridItem | protected
m_pValueMetrics | CXTPPropertyGridItem | mutableprotected
m_strCaption | CXTPPropertyGridItem | protected
m_strDefaultValue | CXTPPropertyGridItem | protected
m_strDescription | CXTPPropertyGridItem | protected
m_strFalseText | CXTPPropertyGridItemBool | protected
m_strFormat | CXTPPropertyGridItem | protected
m_strLiteral | CXTPPropertyGridItem | protected
m_strMarkupTemplate | CXTPPropertyGridItem | protected
m_strMask | CXTPPropertyGridItem | protected
m_strTooltip | CXTPPropertyGridItem | protected
m_strTrueText | CXTPPropertyGridItemBool | protected
m_strValue | CXTPPropertyGridItem | protected
MeasureItem(LPMEASUREITEMSTRUCT lpMeasureItemStruct) | CXTPPropertyGridItem | virtual
Move(CXTPPropertyGridItem *pParent, int nIndex=-1) | CXTPPropertyGridItem |
NotifyValueChanged() | CXTPPropertyGridItem | protected
OnAddChildItem() | CXTPPropertyGridItem | protectedvirtual
OnAfterEdit(CString &strValue) | CXTPPropertyGridItem | virtual
OnBeforeInsert() | CXTPPropertyGridItemBool | protectedvirtual
OnCancelEdit() | CXTPPropertyGridItem | virtual
OnCaptionChanged() | CXTPPropertyGridItem | protectedvirtual
OnChar(UINT nChar) | CXTPPropertyGridItem | protectedvirtual
OnConstraintsChanged() | CXTPPropertyGridItem | protectedvirtual
OnDeselect() | CXTPPropertyGridItem | protectedvirtual
OnDrawItemConstraint(CDC *pDC, CXTPPropertyGridItemConstraint *pConstraint, CRect rc, BOOL bSelected) | CXTPPropertyGridItem | virtual
OnDrawItemValue(CDC &dc, CRect rcValue) | CXTPPropertyGridItemBool | protectedvirtual
OnIndexChanged() | CXTPPropertyGridItem | protectedvirtual
OnInpaceControlFocus(BOOL bForward) | CXTPPropertyGridItem | protectedvirtual
OnInplaceButtonDown(CXTPPropertyGridInplaceButton *pButton) | CXTPPropertyGridItem | protectedvirtual
OnKeyDown(UINT nChar) | CXTPPropertyGridItemBool | protectedvirtual
OnLButtonDblClk(UINT nFlags, CPoint point) | CXTPPropertyGridItemBool | protectedvirtual
OnLButtonDown(UINT nFlags, CPoint point) | CXTPPropertyGridItemBool | protectedvirtual
OnLButtonUp(UINT nFlags, CPoint point) | CXTPPropertyGridItem | protectedvirtual
OnMarkupChanged() | CXTPPropertyGridItem | virtual
OnMergeItemConstraint(CDC *pDC, CXTPPropertyGridItemConstraint *pConstraint) | CXTPPropertyGridItem | virtual
OnRButtonDown(UINT nFlags, CPoint point) | CXTPPropertyGridItem | protectedvirtual
OnRequestEdit() | CXTPPropertyGridItem | virtual
OnSelect() | CXTPPropertyGridItem | protectedvirtual
OnValidateEdit() | CXTPPropertyGridItem | virtual
OnValueChanged(CString strValue) | CXTPPropertyGridItem | virtual
PtInCheckBoxRect(CPoint point) | CXTPPropertyGridItemBool | protected
PtInValueRect(CPoint point) | CXTPPropertyGridItem | protected
RedrawItem() | CXTPPropertyGridItem |
Remove() | CXTPPropertyGridItem |
ResetValue() | CXTPPropertyGridItem | virtual
Select() | CXTPPropertyGridItem |
SelectNextConstraint() | CXTPPropertyGridItem | protected
SetAutoComplete(BOOL bAutoComplete=TRUE) | CXTPPropertyGridItem |
SetBool(BOOL bValue) | CXTPPropertyGridItemBool | virtual
SetCaption(LPCTSTR lpszCaption) | CXTPPropertyGridItem |
SetCheckBoxStyle(BOOL bCheckBoxStyle=TRUE) | CXTPPropertyGridItemBool |
SetConstraintEdit(BOOL bConstraintEdit=TRUE) | CXTPPropertyGridItem |
SetDefaultValue(LPCTSTR lpszDefaultValue) | CXTPPropertyGridItem |
SetDescription(LPCTSTR lpszDescription) | CXTPPropertyGridItem |
SetDropDownItemCount(int nDropDownItemCount) | CXTPPropertyGridItem |
SetEditStyle(DWORD dwEditStyle) | CXTPPropertyGridItem |
SetEditText(const CString &str) | CXTPPropertyGridItem | protectedvirtual
SetExpandable(BOOL bExpandable) | CXTPPropertyGridItem |
SetFlags(UINT nFlags) | CXTPPropertyGridItem |
SetFocusToInplaceControl() | CXTPPropertyGridItem | virtual
SetHeight(int nHeight) | CXTPPropertyGridItem |
SetHidden(BOOL bHidden) | CXTPPropertyGridItem |
SetID(UINT nID) | CXTPPropertyGridItem |
SetItemData(DWORD_PTR dwData) | CXTPPropertyGridItem |
SetMarkupTemplate(LPCTSTR lpstrMarkupTemplate) | CXTPPropertyGridItem |
SetMask(LPCTSTR strMask, LPCTSTR strLiteral, TCHAR chPrompt=_T('_')) | CXTPPropertyGridItem |
SetMaskedText(LPCTSTR lpszMaskedText) | CXTPPropertyGridItem |
SetMultiLinesCount(int nLinesCount) | CXTPPropertyGridItem |
SetPasswordMask(TCHAR chMask=_T(' *')) | CXTPPropertyGridItem |
SetPrompt(LPCTSTR lpszPrompt) | CXTPPropertyGridItem |
SetReadOnly(BOOL bReadOnly=TRUE) | CXTPPropertyGridItem | virtual
SetTooltip(LPCTSTR lpstrTooltip) | CXTPPropertyGridItem |
SetTrueFalseText(LPCTSTR strTrueText, LPCTSTR strFalseText) | CXTPPropertyGridItemBool |
SetValue(CString strValue) | CXTPPropertyGridItemBool | protectedvirtual
SetValueText(CString &strValueText, LPCTSTR strNewText) | CXTPPropertyGridItemBool | protected
SetVisible(BOOL bVisible) | CXTPPropertyGridItem | protectedvirtual
~CXTPPropertyGridItem() | CXTPPropertyGridItem | virtual
~CXTPPropertyGridItemBool() | CXTPPropertyGridItemBool | virtual


Toolkit Pro: Member List

CXTPCommandBar Member List

This is the complete list of members for CXTPCommandBar, including all inherited members.

CalcDynamicLayout(int nLength, DWORD dwMode) | CXTPCommandBar | protectedvirtual
Copy(CXTPCommandBar *pCommandBar, BOOL bRecursive=FALSE) | CXTPCommandBar | protectedvirtual
CreateKeyboardTips() | CXTPCommandBar | virtual
CXTPCommandBar() | CXTPCommandBar | protected
CXTPHookManagerHookAble() | CXTPHookManagerHookAble |
DelayLayout() | CXTPCommandBar |
DelayRedraw() | CXTPCommandBar | virtual
DoPropExchange(CXTPPropExchange *pPX) | CXTPCommandBar | virtual
DrawCommandBar(CDC *pDC, CRect rcClipBox) | CXTPCommandBar | virtual
EnableAnimation(BOOL bEnable=TRUE) | CXTPCommandBar |
EnableCustomization(BOOL bEnable=TRUE) | CXTPCommandBar |
EnableDoubleBuffer(BOOL bEnable=TRUE) | CXTPCommandBar |
EnsureVisible(CXTPControl *pControl) | CXTPCommandBar | virtual
FillCommandBarEntry(CDC *pDC) | CXTPCommandBar | virtual
FindAccel(TCHAR chAccel) const | CXTPCommandBar |
FindAccelEx(UINT chAccel, BOOL &bSelectOnly) const | CXTPCommandBar |
GenerateCommandBarList(DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam) | CXTPCommandBar | protectedvirtual
GetActiveDocTemplate() const | CXTPCommandBar | protected
GetBarID() const | CXTPCommandBar |
GetBorders() | CXTPCommandBar | virtual
GetButtonSize() const | CXTPCommandBar | virtual
GetCommandBarData() const | CXTPCommandBar |
GetCommandBars() const | CXTPCommandBar |
GetControl(int nIndex) const | CXTPCommandBar |
GetControlCount() const | CXTPCommandBar |
GetControls() const | CXTPCommandBar |
GetDefaultButtonStyle() const | CXTPCommandBar |
GetFlags() const | CXTPCommandBar |
GetFrameSite() const | CXTPCommandBar |
GetIconSize() const | CXTPCommandBar | virtual
GetImageManager() const | CXTPCommandBar |
GetLargeIconSize(BOOL bAutoSize) const | CXTPCommandBar |
GetOwnerSite() const | CXTPCommandBar |
GetPaintManager() const | CXTPCommandBar |
GetParentCommandBar() const | CXTPCommandBar | virtual
GetPosition() const | CXTPCommandBar |
GetRootParent() const | CXTPCommandBar |
GetSelected() const | CXTPCommandBar |
GetShowGripper() const | CXTPCommandBar |
GetSite() const | CXTPCommandBar |
GetTextOrientation() const | CXTPCommandBar |
GetTitle() const | CXTPCommandBar |
GetTrackFocus() const | CXTPCommandBar |
GetType() const | CXTPCommandBar |
GetWidth() const | CXTPCommandBar |
HideKeyboardTips() | CXTPCommandBar |
InvalidateParents() | CXTPCommandBar |
IsAnimationEnabled() const | CXTPCommandBar |
IsCustomizable() const | CXTPCommandBar | virtual
IsCustomizeDialogPresent() const | CXTPCommandBar |
IsCustomizeMode() const | CXTPCommandBar |
IsDialogBar() const | CXTPCommandBar | virtual
IsHelpMode() const | CXTPCommandBar | protected
IsKeyboardCuesVisible() const | CXTPCommandBar | virtual
IsKeyboardTipsVisible() const | CXTPCommandBar |
IsLayoutRTL() const | CXTPCommandBar |
IsMenuTitleBar() const | CXTPCommandBar | virtual
IsPopupBar() const | CXTPCommandBar | virtual
IsResizable() const | CXTPCommandBar | virtual
IsRibbonBar() const | CXTPCommandBar | virtual
IsTextBelowIcons() const | CXTPCommandBar |
IsTrackingMode() const | CXTPCommandBar |
IsVisible() const | CXTPCommandBar | virtual
LoadMenu(CMenu *pMenu, BOOL bRemoveControls=TRUE) | CXTPCommandBar | virtual
LoadToolBar(UINT nIDResource, BOOL bLoadIcons=TRUE) | CXTPCommandBar | virtual
LockMouseMove(CXTPControl *pControl) | CXTPCommandBar |
LockRedraw() | CXTPCommandBar |
m_bAnimatePopup | CXTPCommandBar | protected
m_barPosition | CXTPCommandBar | protected
m_barType | CXTPCommandBar | protected
m_bAutoDestroy | CXTPHookManagerHookAble |
m_bCloseable | CXTPCommandBar | protected
m_bComboBar | CXTPCommandBar |
m_bCustomizable | CXTPCommandBar | protected
m_bCustomizeDialogPresent | CXTPCommandBar | protected
m_bExecOnRButton | CXTPCommandBar | protected
m_bGrabFocus | CXTPCommandBar | protected
m_bIgnoreUpdateHandler | CXTPCommandBar | protected
m_bKeyboardSelect | CXTPCommandBar | protected
m_bMultiLine | CXTPCommandBar | protected
m_bRecursePopup | CXTPCommandBar | protected
m_bTextBelow | CXTPCommandBar | protected
m_bTracking | CXTPCommandBar | protected
m_bTrackOnHover | CXTPCommandBar |
m_buttonStyle | CXTPCommandBar | protected
m_bVerticalMarker | CXTPCommandBar | protected
m_dwData | CXTPCommandBar | protected
m_dwFlags | CXTPCommandBar | protected
m_dwStyle | CXTPCommandBar | protected
m_hwndFocus | CXTPCommandBar | protected
m_nBarID | CXTPCommandBar | protected
m_nIdleFlags | CXTPCommandBar | protected
m_nLockRedraw | CXTPCommandBar | protected
m_nMRUWidth | CXTPCommandBar | protected
m_nPopuped | CXTPCommandBar | protected
m_nSelected | CXTPCommandBar | protected
m_nStateFlags | CXTPCommandBar |
m_nTextOrientation | CXTPCommandBar | protected
m_pAnimation | CXTPCommandBar | protected
m_pCommandBars | CXTPCommandBar | protected
m_pControls | CXTPCommandBar | protected
m_pImageManager | CXTPCommandBar | protected
m_pOwner | CXTPCommandBar | protected
m_pPaintManager | CXTPCommandBar | protected
m_pReturnCmd | CXTPCommandBar | protected
m_pSite | CXTPCommandBar | protected
m_pToolTipContext | CXTPCommandBar | protected
m_rcMarker | CXTPCommandBar | protected
m_strTitle | CXTPCommandBar | protected
m_szButtons | CXTPCommandBar | protected
m_szButtonSpacing | CXTPCommandBar | protected
m_szIcons | CXTPCommandBar | protected
OnControlsChanged() | CXTPCommandBar | protectedvirtual
OnControlSelected(BOOL bSelected, CXTPControl *pControl) | CXTPCommandBar | virtual
OnCustomizeDragEnter(CXTPControl *pDataObject, CPoint point) | CXTPCommandBar | virtual
OnCustomizeDragLeave() | CXTPCommandBar | virtual
OnCustomizeDragOver(CXTPControl *pDataObject, CPoint point) | CXTPCommandBar | virtual
OnCustomizeDrop(CXTPControl *pDataObject, DROPEFFECT &dropEffect, CPoint ptDrop, CPoint ptDrag) | CXTPCommandBar | virtual
OnHookAttached(HWND hWnd) | CXTPHookManagerHookAble | virtual
OnHookDetached() | CXTPHookManagerHookAble | virtual
OnHookKeyDown(UINT nChar, LPARAM lParam) | CXTPCommandBar | protectedvirtual
OnHookMessage(HWND hWnd, UINT nMessage, WPARAM &wParam, LPARAM &lParam, LRESULT &lResult) | CXTPCommandBar | virtual
OnKeyboardTip(CXTPCommandBarKeyboardTip *pTip) | CXTPCommandBar | virtual
OnKeyboardTipChar(UINT chAccel) | CXTPCommandBar |
OnMouseHitTest(CPoint pt) | CXTPCommandBar | protectedvirtual
OnPostHookMessage(HWND hWnd, UINT nMessage, WPARAM &wParam, LPARAM &lParam, LRESULT &lResult) | CXTPHookManagerHookAble | virtual
OnRecalcLayout() | CXTPCommandBar | virtual
OnRemoved() | CXTPCommandBar | protectedvirtual
OnTrackEnter() | CXTPCommandBar | virtual
OnTrackLost() | CXTPCommandBar | virtual
Popup(CXTPControlPopup *pControlPopup, BOOL bSelectFirst=FALSE) | CXTPCommandBar | virtual
ProcessSpecialKey(XTPSpecialKey key) | CXTPCommandBar | protectedvirtual
Redraw(LPCRECT lpRect=0, BOOL bAnimate=TRUE) | CXTPCommandBar | virtual
RestoreCommandBarList(CXTPCommandBarList *pCommandBarList) | CXTPCommandBar | protectedvirtual
s_nExpandDelay | CXTPCommandBar | static
s_nExpandHoverDelay | CXTPCommandBar | static
s_nHoverDelay | CXTPCommandBar | static
SetBarID(UINT nID) | CXTPCommandBar |
SetButtons(UINT *pButtons, int nCount) | CXTPCommandBar |
SetButtonSize(CSize size) | CXTPCommandBar |
SetCommandBarData(DWORD_PTR dwData) | CXTPCommandBar |
SetCommandBars(CXTPCommandBars *pCommandBars) | CXTPCommandBar |
SetControls(CXTPControls *pControls) | CXTPCommandBar |
SetDefaultButtonStyle(XTPButtonStyle buttonStyle) | CXTPCommandBar |
SetFlags(DWORD dwFlagsAdd, DWORD dwFlagsRemove=0) | CXTPCommandBar |
SetGrabFocus(BOOL bGrabFocus) | CXTPCommandBar |
SetIconSize(CSize size) | CXTPCommandBar |
SetImageManager(CXTPImageManager *pImageManager) | CXTPCommandBar |
SetPaintManager(CXTPPaintManager *pPaintManager) | CXTPCommandBar |
SetPopuped(int nPopuped, BOOL bKeyboard=FALSE) | CXTPCommandBar |
SetPosition(XTPBarPosition barPosition) | CXTPCommandBar | virtual
SetSelected(int nSelected, BOOL bKeyboard=FALSE) | CXTPCommandBar | virtual
SetShowGripper(BOOL bShow) | CXTPCommandBar |
SetStatusText(const CString &strDescription) | CXTPCommandBar |
SetTextOrientation(XTPBarTextOrientation nTextOrientation) | CXTPCommandBar |
SetTitle(LPCTSTR lpszTitle) | CXTPCommandBar |
SetTrackFocus(HWND hwnd) | CXTPCommandBar |
SetTrackingMode(int bMode, BOOL bSelectFirst=TRUE, BOOL bKeyboard=FALSE) | CXTPCommandBar | virtual
SetVisible(BOOL bVisible) | CXTPCommandBar | virtual
SetWidth(int nWidth) | CXTPCommandBar |
ShowTextBelowIcons(BOOL bTextBelow=TRUE) | CXTPCommandBar |
UnlockMouseMove() | CXTPCommandBar |
UnlockRedraw() | CXTPCommandBar |
UpdateShortcuts() | CXTPCommandBar | protectedvirtual
~CXTPCommandBar() | CXTPCommandBar | protectedvirtual
~CXTPHookManagerHookAble() | CXTPHookManagerHookAble | virtual


Toolkit Pro: Member List

CXTPProgressThemeVisualStudio2015 Member List

This is the complete list of members for CXTPProgressThemeVisualStudio2015, including all inherited members.

CXTPProgressPaintManager(CXTPPaintManager *pPaintManager) | CXTPProgressPaintManager |
CXTPProgressThemeOffice2013(CXTPPaintManager *pPaintManager) | CXTPProgressThemeOffice2013 |
CXTPProgressThemeVisualStudio2015(CXTPPaintManager *pPaintManager) | CXTPProgressThemeVisualStudio2015 |
DrawProgress(CDC *pDC, CXTPProgressBase *pProgressBar) | CXTPProgressThemeOffice2013 | virtual
GetPaintManager() const | CXTPProgressPaintManager |
m_clrBack | CXTPProgressThemeOffice2013 | protected
m_clrBar | CXTPProgressThemeOffice2013 | protected
m_clrBorder | CXTPProgressThemeOffice2013 | protected
m_cyProgress | CXTPProgressPaintManager |
m_pPaintManager | CXTPProgressPaintManager | protected
RefreshMetrics() | CXTPProgressThemeOffice2013 | virtual
~CXTPProgressPaintManager() | CXTPProgressPaintManager | virtual
~CXTPProgressThemeOffice2013() | CXTPProgressThemeOffice2013 | virtual
~CXTPProgressThemeVisualStudio2015() | CXTPProgressThemeVisualStudio2015 | virtual


Toolkit Pro: XTPRibbonTabColorSet.h Source File

  • Source
  • Ribbon
XTPRibbonTabColorSet.h
Go to the documentation of this file.
1
23#if !defined(__XTPRIBBONTABCOLORSET_H__)
24# define __XTPRIBBONTABCOLORSET_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class _XTP_EXT_CLASS CXTPRibbonTabColorSet : public CXTPTabColorSetOffice2003
34{
35public:
40 CXTPRibbonTabColorSet();
41
42protected:
43 void RefreshMetrics();
44
45 void SetTextColor(CDC* pDC, CXTPTabManagerItem* pItem);
46
47public:
48 // Indicates that text color of inactive (normal) tab is visible on back color of selected tab
49 BOOL m_bIsInactiveSelectedTextVisible;
50};
51
52# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
54#endif // !defined(__XTPRIBBONTABCOLORSET_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPTabColorSetOffice2003
CXTPTabColorSetOffice2003 implements an Office 2003 tab color set.
Definition XTPTabColorSetOffice2003.h:44
CXTPTabColorSetOffice2003::RefreshMetrics
virtual void RefreshMetrics()
Refreshes the visual metrics of the tabs.
CXTPTabManagerItem
CXTPTabManagerItem is the base class for the tabs that appear in the command bars tab workspace,...
Definition XTPTabManagerItem.h:44
CXTPTabPaintManagerColorSet::SetTextColor
virtual void SetTextColor(CDC *pDC, CXTPTabManagerItem *pItem)
Sets the text color for the tab.


Toolkit Pro: Member List

  • CXTPCalendarReminder
  • RecurrenceEventInfo
CXTPCalendarReminder::RecurrenceEventInfo Member List

This is the complete list of members for CXTPCalendarReminder::RecurrenceEventInfo, including all inherited members.

m_dtOccurrenceEndTime | CXTPCalendarReminder::RecurrenceEventInfo
m_dtOccurrenceStartTime | CXTPCalendarReminder::RecurrenceEventInfo
m_dwMasterEventID | CXTPCalendarReminder::RecurrenceEventInfo


Toolkit Pro: XTPArrowDrawer.h Source File

  • Source
  • FlowGraph
XTPArrowDrawer.h
Go to the documentation of this file.
1
23#if !defined(__XTPARROWDRAWER_H__)
24# define __XTPARROWDRAWER_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
34// description
35
36class CXTPFlowGraphDrawContext;
37
38class _XTP_EXT_CLASS CXTPArrowDrawer
39{
40protected:
41 Gdiplus::PointF* GetBezierCurveNodes(float p1X, float p1Y, float p2X, float p2Y, float p1cX,
42 float p1cY, float p2cX, float p2cY, int numberOfNodes);
43
44 float GetDistance(float x1, float y1, float x2, float y2);
45
46public:
47 CXTPArrowDrawer(float width = 10.f, float theta = 0.8f, int nNumberOfBezierNodes = 100);
48
53 void Draw(CXTPFlowGraphDrawContext* pDC, Gdiplus::PointF p1, Gdiplus::PointF p2);
54
59 void Draw(CXTPFlowGraphDrawContext* pDC, float p1X, float p1Y, float p2X, float p2Y, float p1cX,
60 float p1cY, float p2cX, float p2cY);
61
66 void Draw(CXTPFlowGraphDrawContext* pDC, Gdiplus::PointF p1, Gdiplus::PointF p2,
67 Gdiplus::PointF cp1, Gdiplus::PointF cp2);
68
69protected:
70 float m_Width;
71 float m_Theta;
74 int m_nNumberOfBezierNodes;
75};
77# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
78#endif // __XTPARROWDRAWER_H__
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h


Toolkit Pro: Member List

XTP_PICK_BUTTON Member List

This is the complete list of members for XTP_PICK_BUTTON, including all inherited members.

clrButton | XTP_PICK_BUTTON
szTip | XTP_PICK_BUTTON
toolTipID | XTP_PICK_BUTTON


Toolkit Pro: XTPFrameThemeVisualStudio2017.h Source File

  • Source
  • CommandBars
  • Frame
XTPFrameThemeVisualStudio2017.h
Go to the documentation of this file.
1
23#if !defined(__XTPFRAMETHEMEVISUALSTUDIO2017_H__)
24# define __XTPFRAMETHEMEVISUALSTUDIO2017_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPPaintManager;
34class CXTPCommandBarsFrameHook;
35class CXTPRibbonBar;
36
37class _XTP_EXT_CLASS CXTPFrameThemeVisualStudio2017
38 : public CXTPFrameThemeOffice2013
39 , private IXTPApplicationEvents
40{
41public:
42 CXTPFrameThemeVisualStudio2017(CXTPPaintManager* pPaintManager);
43
44 virtual ~CXTPFrameThemeVisualStudio2017();
45
46public:
51 virtual void RefreshMetrics();
52
64 virtual void DrawFrameCaptionButton(CDC* pDC, CRect rc, int nId, BOOL bSelected, BOOL bPressed,
65 BOOL bActive);
66
79 virtual void DrawFrameCaptionButton(CDC* pDC, CRect rc, int nId, BOOL bSelected, BOOL bPressed,
80 BOOL bActive, CXTPRibbonBar* pRibbonBar);
81
90 virtual void SetStateColor(COLORREF clrState);
91
100 virtual COLORREF GetStateColor() const;
101
102 virtual CRect CalcFrameBorder(const CXTPCommandBarsFrameHook* pFrameHook) const;
103
104 virtual CXTPFrameShadow* CreateShadow(CWnd* pFrame);
105
106 virtual void OnShadowedFrameActiveStateChanged(BOOL bActive, CWnd* pFrame,
107 CXTPFrameShadow* pShadow);
108
109private:
110 virtual void OnAmbientPropertyChanged(CXTPApplication* pApplication,
111 XTPApplicationAmbientProperty nProperty);
112 void UpdateStateColor();
113
114 BOOL m_bAutomaticStateColor;
115
116protected:
117 COLORREF m_clrShadowColorActive;
118 COLORREF m_clrShadowColorInactive;
119};
120
122# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
123#endif // !defined(__XTPFRAMETHEMEVISUALSTUDIO2017_H__)
XTPApplicationAmbientProperty
XTPApplicationAmbientProperty
Global ambient property identifiers.
Definition XTPApplication.h:46
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPApplication
Defines a global XTP application object interface.
Definition XTPApplication.h:151
CXTPCommandBarsFrameHook
CXTPCommandBarsFrameHook is a CXTPHookManagerHookAble derived class.
Definition XTPFrameHook.h:56
CXTPFramePaintManager::OnShadowedFrameActiveStateChanged
virtual void OnShadowedFrameActiveStateChanged(BOOL bActive, CWnd *pFrame, CXTPFrameShadow *pShadow)
An implementation can override this method in order to change frame appearance when a window gets act...
CXTPFrameShadow
The class represents frame shadow object.
Definition XTPFrameShadow.h:47
CXTPPaintManager
Paint manager of the command bars.
Definition XTPPaintManager.h:199
CXTPRibbonBar
CXTPRibbonBar is a CXTPMenuBar derived class.
Definition XTPRibbonBar.h:69
IXTPApplicationEvents
Defines a callback interface for XTP application event sink.
Definition XTPApplication.h:82
IXTPApplicationEvents::OnAmbientPropertyChanged
virtual void OnAmbientPropertyChanged(CXTPApplication *pApplication, XTPApplicationAmbientProperty nProperty)
Called by framework when an ambient property is changed.
Definition XTPApplication.h:130


Toolkit Pro: XTPCalendarEventColorListBox.h Source File

  • Source
  • Calendar
XTPCalendarEventColorListBox.h
Go to the documentation of this file.
1
22#if !defined(__XTPCALENDAREVENTCOLORLISTBOX_H__)
23# define __XTPCALENDAREVENTCOLORLISTBOX_H__
24
25# if _MSC_VER > 1000
26# pragma once
27# endif // _MSC_VER > 1000
28
29# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
30
36class _XTP_EXT_CLASS CXTPCalendarEventColorEdit : public CEdit
37{
38public:
46 CXTPCalendarEventColorEdit(int nIndex);
47
54 int GetIndex() const;
55
56protected:
57 int m_nIndex; // Index of listbox item associated with this control.
58
59 //{{AFX_VIRTUAL(CXTPCalendarEventColorEdit)
60public:
61 virtual BOOL PreTranslateMessage(MSG* pMsg);
62 //}}AFX_VIRTUAL
63
64 //{{AFX_MSG(CXTPCalendarEventColorEdit)
65protected:
66 afx_msg void OnKillFocus(CWnd* pNewWnd);
67 //}}AFX_MSG
68
69 DECLARE_MESSAGE_MAP()
70};
71
72AFX_INLINE int CXTPCalendarEventColorEdit::GetIndex() const
73{
74 return m_nIndex;
75}
76
82class _XTP_EXT_CLASS CXTPCalendarEventColorListBox : public CListBox
83{
85 DECLARE_DYNAMIC(CXTPCalendarEventColorListBox)
88public:
94 CXTPCalendarEventColorListBox();
95
100 virtual ~CXTPCalendarEventColorListBox();
101
112 virtual void Init(CXTPCalendarData* pData, CXTPCalendarEvent* pEvent, BOOL bCategories);
113
119 virtual void BeginEdit();
120
128 virtual void EndEdit(BOOL bUpdate = TRUE);
129
136 virtual void DeleteItem(int nItem = LB_ERR);
137
145 virtual int AddItem();
146
155 virtual void SetItemColor(COLORREF crItem, int nItem = LB_ERR);
156
167 CXTPCalendarEventLabel* GetLabel(int nIndex);
168
179 CXTPCalendarEventCategory* GetCategory(int nIndex);
180
190 CXTPCalendarEventColorEdit* GetEdit();
191
199 void UpdateCategories(CXTPCalendarData* pData);
200
208 void UpdateLabels(CXTPCalendarData* pData);
209
217 void ToggleCheck(int nItem);
218
227 void SetModified(BOOL bModified);
228
237 BOOL IsModified();
238
239protected:
240 BOOL m_bModified;
241 BOOL m_bCategories;
242 CSize m_sizeColor;
243 CXTPCalendarData* m_pData;
244 CXTPCalendarEvent* m_pEvent;
245 CXTPCalendarEventColorEdit* m_pWndEdit;
248 CXTPCalendarEventCategoryIDs m_arChecked;
261 CRect CalcColorRect(CRect rItem);
262
263 //{{AFX_VIRTUAL(CXTPCalendarEventColorListBox)
264public:
265 virtual void MeasureItem(LPMEASUREITEMSTRUCT lpMIS);
266 virtual void DrawItem(LPDRAWITEMSTRUCT lpDIS);
267 virtual void DeleteItem(LPDELETEITEMSTRUCT lpDIS);
268 //}}AFX_VIRTUAL
269
270 //{{AFX_MSG(CXTPCalendarEventColorListBox)
271protected:
272 afx_msg void OnLButtonDown(UINT nFlags, CPoint point);
273 afx_msg HBRUSH CtlColor(CDC* pDC, UINT nCtlColor);
274 //}}AFX_MSG
275
276 DECLARE_MESSAGE_MAP()
277};
278
280
281AFX_INLINE CXTPCalendarEventColorEdit* CXTPCalendarEventColorListBox::GetEdit()
282{
283 return m_pWndEdit;
284}
285AFX_INLINE void CXTPCalendarEventColorListBox::SetModified(BOOL bModified)
286{
287 m_bModified = bModified;
288}
289AFX_INLINE BOOL CXTPCalendarEventColorListBox::IsModified()
290{
291 return m_bModified;
292}
293
294//{{AFX_INSERT_LOCATION}}
295// Microsoft Visual C++ will insert additional declarations immediately before the previous line.
296
297# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
298#endif // !defined(__XTPCALENDAREVENTCOLORLISTBOX_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCalendarData
This class defines an abstract representation of the Calendar control data with all necessary methods...
Definition XTPCalendarData.h:97
CXTPCalendarEventCategory
This class defines Calendar Event Category properties.
Definition XTPCalendarEventLabel.h:229
CXTPCalendarEventCategoryIDs
This class represents the collection of event categories IDs.
Definition XTPCalendarEventLabel.h:692
CXTPCalendarEventColorEdit
This class is used by CXTPCalendarEventColorListBox to create an inplace edit box for renaming event ...
Definition XTPCalendarEventColorListBox.h:37
CXTPCalendarEventColorEdit::GetIndex
int GetIndex() const
Returns the index of the listbox item associated with this edit control.
Definition XTPCalendarEventColorListBox.h:72
CXTPCalendarEventColorEdit::CXTPCalendarEventColorEdit
CXTPCalendarEventColorEdit(int nIndex)
Constructs a CXTPCalendarEventColorEdit object used to edit calendar event categories and labels name...
CXTPCalendarEventColorListBox
This class is used to display a list of Calendar Event Categories or Labels that can be edited.
Definition XTPCalendarEventColorListBox.h:83
CXTPCalendarEventColorListBox::m_pEvent
CXTPCalendarEvent * m_pEvent
Points to a valid CXTPCalendarEvent object.
Definition XTPCalendarEventColorListBox.h:244
CXTPCalendarEventColorListBox::SetModified
void SetModified(BOOL bModified)
This member function is called to set the modified state for the listbox control.
Definition XTPCalendarEventColorListBox.h:285
CXTPCalendarEventColorListBox::UpdateLabels
void UpdateLabels(CXTPCalendarData *pData)
This member function is called to update the calendar event labels based on the current listbox state...
CXTPCalendarEventColorListBox::m_bModified
BOOL m_bModified
TRUE if the listbox state has been changed.
Definition XTPCalendarEventColorListBox.h:240
CXTPCalendarEventColorListBox::m_pData
CXTPCalendarData * m_pData
Points to a valid CXTPCalendarData object.
Definition XTPCalendarEventColorListBox.h:243
CXTPCalendarEventColorListBox::m_arChecked
CXTPCalendarEventCategoryIDs m_arChecked
Array which store checked item IDs.
Definition XTPCalendarEventColorListBox.h:248
CXTPCalendarEventColorListBox::CXTPCalendarEventColorListBox
CXTPCalendarEventColorListBox()
Constructs a CXTPCalendarEventColorListBox object used to edit calendar event categories and labels.
CXTPCalendarEventColorListBox::SetItemColor
virtual void SetItemColor(COLORREF crItem, int nItem=LB_ERR)
Call this member function to set the color for a calendar event category or label.
CXTPCalendarEventColorListBox::GetLabel
CXTPCalendarEventLabel * GetLabel(int nIndex)
Call this member function to retrieve the label object for the specified index.
CXTPCalendarEventColorListBox::CalcColorRect
CRect CalcColorRect(CRect rItem)
This member function is called to determine the size and location of a color rectangle for the specif...
CXTPCalendarEventColorListBox::m_pWndEdit
CXTPCalendarEventColorEdit * m_pWndEdit
Points to a valid CXTPCalendarEventColorEdit object, only valid when a list box item is being edited.
Definition XTPCalendarEventColorListBox.h:245
CXTPCalendarEventColorListBox::m_sizeColor
CSize m_sizeColor
Size in pixels of the color selection box.
Definition XTPCalendarEventColorListBox.h:242
CXTPCalendarEventColorListBox::BeginEdit
virtual void BeginEdit()
Called to begin the editing of a listbox event category or label item.
CXTPCalendarEventColorListBox::ToggleCheck
void ToggleCheck(int nItem)
This member function is called to toggle the checked state for the specified calendar event category.
CXTPCalendarEventColorListBox::UpdateCategories
void UpdateCategories(CXTPCalendarData *pData)
This member function is called to update the calendar event categories based on the current listbox s...
CXTPCalendarEventColorListBox::Init
virtual void Init(CXTPCalendarData *pData, CXTPCalendarEvent *pEvent, BOOL bCategories)
This member function is called to initialize the listbox with calendar event category or list data.
CXTPCalendarEventColorListBox::IsModified
BOOL IsModified()
This member function is called to check the modified state of the listbox control.
Definition XTPCalendarEventColorListBox.h:289
CXTPCalendarEventColorListBox::~CXTPCalendarEventColorListBox
virtual ~CXTPCalendarEventColorListBox()
Destructor handles cleanup and deallocation.
CXTPCalendarEventColorListBox::m_bCategories
BOOL m_bCategories
TRUE if the listbox should display calendar event categories.
Definition XTPCalendarEventColorListBox.h:241
CXTPCalendarEventColorListBox::GetEdit
CXTPCalendarEventColorEdit * GetEdit()
This member function is called to get a pointer to the edit control used for renaming calendar event ...
Definition XTPCalendarEventColorListBox.h:281
CXTPCalendarEventColorListBox::DeleteItem
virtual void DeleteItem(int nItem=LB_ERR)
Called to delete a list box category or label item.
CXTPCalendarEventColorListBox::AddItem
virtual int AddItem()
Called to add a new event category or label to the listbox.
CXTPCalendarEventColorListBox::EndEdit
virtual void EndEdit(BOOL bUpdate=TRUE)
Called to end the editing of a listbox event category or label item.
CXTPCalendarEventColorListBox::GetCategory
CXTPCalendarEventCategory * GetCategory(int nIndex)
Call this member function to retrieve the category object for the specified index.
CXTPCalendarEvent
This class represents the data of a single Event used in the Calendar control.
Definition XTPCalendarEvent.h:77
CXTPCalendarEventLabel
This class defines Calendar Event label properties.
Definition XTPCalendarEventLabel.h:43


Toolkit Pro: Member List

CXTPPaintManagerColorGradient Member List

This is the complete list of members for CXTPPaintManagerColorGradient, including all inherited members.

clrDark | CXTPPaintManagerColorGradient |
clrLight | CXTPPaintManagerColorGradient |
CXTPPaintManagerColorGradient() | CXTPPaintManagerColorGradient |
CXTPPaintManagerColorGradient(const COLORREF clr) | CXTPPaintManagerColorGradient |
CXTPPaintManagerColorGradient(const CXTPPaintManagerColor clr) | CXTPPaintManagerColorGradient |
CXTPPaintManagerColorGradient(COLORREF clrLight, COLORREF clrDark) | CXTPPaintManagerColorGradient |
fGradientFactor | CXTPPaintManagerColorGradient |
IsNull() const | CXTPPaintManagerColorGradient |
operator COLORREF() const | CXTPPaintManagerColorGradient |
operator CXTPPaintManagerColor &() | CXTPPaintManagerColorGradient |
operator=(const CXTPPaintManagerColorGradient &refSrc) | CXTPPaintManagerColorGradient |
Serialize(CArchive &ar) | CXTPPaintManagerColorGradient | virtual
SetCustomValue(const COLORREF clr) | CXTPPaintManagerColorGradient |
SetCustomValue(CXTPPaintManagerColorGradient &clrref) | CXTPPaintManagerColorGradient |
SetCustomValue(COLORREF clrLight, COLORREF clrDark) | CXTPPaintManagerColorGradient |
SetStandardValue(const COLORREF clr) | CXTPPaintManagerColorGradient |
SetStandardValue(CXTPPaintManagerColorGradient &clrref) | CXTPPaintManagerColorGradient |
SetStandardValue(COLORREF clrLight, COLORREF clrDark, float fGradientFactor=0.5f) | CXTPPaintManagerColorGradient |
~CXTPPaintManagerColorGradient() | CXTPPaintManagerColorGradient | inlinevirtual


Toolkit Pro: Member List

CXTPControlGalleryVisualStudio2019Theme Member List

This is the complete list of members for CXTPControlGalleryVisualStudio2019Theme, including all inherited members.

CXTPControlGalleryOffice2013Theme(CXTPPaintManager *pPaintManager) | CXTPControlGalleryOffice2013Theme |
CXTPControlGalleryPaintManager(CXTPPaintManager *pPaintManager) | CXTPControlGalleryPaintManager |
CXTPControlGalleryVisualStudio2019Theme(CXTPPaintManager *pPaintManager) | CXTPControlGalleryVisualStudio2019Theme |
DrawLabel(CDC *pDC, CXTPControlGalleryItem *pLabel, CRect rc) | CXTPControlGalleryPaintManager | virtual
DrawPopupScrollBar(CDC *pDC, CXTPControlGallery *pGallery) | CXTPControlGalleryOffice2013Theme | virtual
FillControl(CDC *pDC, CXTPControlGallery *pGallery, CRect rc) | CXTPControlGalleryOffice2013Theme | protectedvirtual
m_cxPopup | CXTPControlGalleryPaintManager |
m_cyPopupDown | CXTPControlGalleryPaintManager |
m_cyPopupUp | CXTPControlGalleryPaintManager |
RefreshMetrics() | CXTPControlGalleryOffice2013Theme | virtual


Toolkit Pro: Member List

CXTPSvgImage Member List

This is the complete list of members for CXTPSvgImage, including all inherited members.

CXTPSvgImage() | CXTPSvgImage
DirectDraw(PVOID pBits, SIZE_T cbSize, CRect rc) | CXTPSvgImage
Draw(HDC hDC, CPoint pt, BOOL bPreserveAlpha=TRUE) | CXTPSvgImage
Draw(CDC *pDC, CPoint pt, BOOL bPreserveAlpha=TRUE) | CXTPSvgImage
Draw(HDC hDC, CRect rc, BOOL bPreserveAlpha=TRUE) | CXTPSvgImage
Draw(CDC *pDC, CRect rc, BOOL bPreserveAlpha=TRUE) | CXTPSvgImage
GetBitmap() const | CXTPSvgImage
GetSize() const | CXTPSvgImage
IsAlpha() const | CXTPSvgImage
IsLoaded() const | CXTPSvgImage
Load(const void *pData, SIZE_T cbSize, Units nUnits=unitPX) | CXTPSvgImage
Load(IStream *pStream, Units nUnits=unitPX) | CXTPSvgImage
Load(CFile *pFile, Units nUnits=unitPX) | CXTPSvgImage
Load(LPCTSTR lpFilePath, Units nUnits=unitPX) | CXTPSvgImage
Load(HMODULE hModule, HRSRC hRes, Units nUnits=unitPX) | CXTPSvgImage
SetSize(CSize size) | CXTPSvgImage
unitCM enum value | CXTPSvgImage
unitEM enum value | CXTPSvgImage
unitEX enum value | CXTPSvgImage
unitIN enum value | CXTPSvgImage
unitMM enum value | CXTPSvgImage
unitPC enum value | CXTPSvgImage
unitPercent enum value | CXTPSvgImage
unitPT enum value | CXTPSvgImage
unitPX enum value | CXTPSvgImage
Units enum name | CXTPSvgImage
~CXTPSvgImage() | CXTPSvgImage


Toolkit Pro: Member List

CXTPGridColumns Member List

This is the complete list of members for CXTPGridColumns, including all inherited members.

Add(CXTPGridColumn *pColumn) | CXTPGridColumns |
ChangeColumnOrder(int nNewIndex, int nOldIndex) | CXTPGridColumns |
Clear() | CXTPGridColumns |
CXTPCmdTarget() | CXTPCmdTarget |
CXTPGridColumns(CXTPGridControl *pControl) | CXTPGridColumns |
DoPropExchange(CXTPPropExchange *pPX) | CXTPGridColumns | virtual
Find(int nItemIndex) const | CXTPGridColumns |
Find(const CString &strInternalName) const | CXTPGridColumns |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAt(int nIndex) const | CXTPGridColumns |
GetAtOffset(int nOffset, BOOL bFrozen) const | CXTPGridColumns |
GetCount() const | CXTPGridColumns |
GetFirstVisibleColumn() const | CXTPGridColumns |
GetGridHeader() const | CXTPGridColumns |
GetGroupsOrder() const | CXTPGridColumns |
GetIndentColumn() const | CXTPGridColumns |
GetLastVisibleColumn() const | CXTPGridColumns |
GetOffset(int nIndex) const | CXTPGridColumns |
GetSortOrder() const | CXTPGridColumns |
GetVisibleAt(int nIndex) const | CXTPGridColumns |
GetVisibleColumns(CXTPGridColumns &arrColumns) const | CXTPGridColumns |
GetVisibleColumnsCount() const | CXTPGridColumns |
IndexOf(const CXTPGridColumn *pColumn) const | CXTPGridColumns |
InsertSortColumn(CXTPGridColumn *pColumn) | CXTPGridColumns |
m_arrColumns | CXTPGridColumns | protected
m_pControl | CXTPGridColumns | protected
m_pGroupsOrder | CXTPGridColumns | protected
m_pSortOrder | CXTPGridColumns | protected
m_pTreeColumn | CXTPGridColumns | protected
Remove(CXTPGridColumn *pColumn) | CXTPGridColumns |
ResetSortOrder() | CXTPGridColumns |
SetSortColumn(CXTPGridColumn *pColumn, BOOL bIncreasing) | CXTPGridColumns |
~CXTPGridColumns() | CXTPGridColumns | virtual


Toolkit Pro: Member List

CXTPRadioButtonPart Member List

This is the complete list of members for CXTPRadioButtonPart, including all inherited members.

AdjustLayout(CDC *pDC, const CRect &rcRect) | CXTPRadioButtonPart | virtual
CXTPCalendarCaptionBarThemePart(CXTPCalendarCaptionBarTheme *pTheme, int nPartID) | CXTPCalendarCaptionBarThemePart |
CXTPCalendarWMHandler() | CXTPCalendarWMHandler |
CXTPCmdTarget() | CXTPCmdTarget |
Draw(CDC *pDC) | CXTPRadioButtonPart | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCheck() const | CXTPCalendarCaptionBarThemePart | virtual
GetChildHandlerAt(int nIndex) const | CXTPCalendarWMHandler | virtual
GetChildHandlersCount() const | CXTPCalendarWMHandler | virtual
GetPaintManager() const | CXTPCalendarCaptionBarThemePart |
GetPaintTheme() const | CXTPCalendarCaptionBarThemePart | virtual
GetPartID() const | CXTPCalendarCaptionBarThemePart | virtual
GetRect() const | CXTPCalendarCaptionBarThemePart | virtual
GetState() const | CXTPCalendarCaptionBarThemePart |
GetText() const | CXTPCalendarCaptionBarThemePart | virtual
GetTextColor() | CXTPCalendarCaptionBarThemePart | virtual
GetTheme() const | CXTPCalendarCaptionBarThemePart | virtual
HitTest(const CPoint &pt) const | CXTPCalendarCaptionBarThemePart | virtual
IsVisible() const | CXTPCalendarCaptionBarThemePart | virtual
m_bVisible | CXTPCalendarCaptionBarThemePart | protected
m_clrTextColor | CXTPCalendarCaptionBarThemePart |
m_nPartID | CXTPCalendarCaptionBarThemePart | protected
m_nState | CXTPCalendarCaptionBarThemePart |
m_pTheme | CXTPCalendarCaptionBarThemePart | protected
m_rcRect | CXTPCalendarCaptionBarThemePart |
m_strText | CXTPCalendarCaptionBarThemePart |
OnBeforeDestroy() | CXTPCalendarWMHandler | virtual
OnChar(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnKeyUp(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnLButtonDblClk(UINT nFlags, CPoint point) | CXTPCalendarWMHandler | virtual
OnLButtonDown(UINT nFlags, CPoint point) | CXTPCalendarCaptionBarThemePart | virtual
OnLButtonUp(UINT nFlags, CPoint point) | CXTPCalendarCaptionBarThemePart | virtual
OnMouseMove(UINT nFlags, CPoint point) | CXTPCalendarCaptionBarThemePart | virtual
OnPostAdjustLayout() | CXTPCalendarWMHandler | virtual
OnSysKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnTimer(UINT_PTR uTimerID) | CXTPCalendarWMHandler | virtual
OnWndMsg(UINT message, WPARAM wParam, LPARAM lParam, LRESULT *pResult) | CXTPCalendarWMHandler | virtual
Redraw(BOOL bUpdateNow=FALSE) | CXTPCalendarCaptionBarThemePart | virtual
RefreshMetrics() | CXTPRadioButtonPart | virtual
SetCheck(int nCheck) | CXTPCalendarCaptionBarThemePart | virtual
SetState(int nState) | CXTPCalendarCaptionBarThemePart | virtual
SetText(LPCTSTR pcszText) | CXTPCalendarCaptionBarThemePart | virtual
SetVisible(BOOL bVisible) | CXTPCalendarCaptionBarThemePart | virtual
~CXTPCalendarCaptionBarThemePart() | CXTPCalendarCaptionBarThemePart | virtual


Toolkit Pro: XTPMarkupColumnDefinition.h Source File

  • Source
  • Markup
  • Controls
XTPMarkupColumnDefinition.h
Go to the documentation of this file.
1
23#if !defined(__XTPMARKUPCOLUMNDEFINITION_H__)
24# define __XTPMARKUPCOLUMNDEFINITION_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPMarkupDependencyProperty;
34class CXTPMarkupGridLength;
35
41class _XTP_EXT_CLASS CXTPMarkupColumnDefinition : public CXTPMarkupDefinitionBase
42{
44 DECLARE_MARKUPCLASS(CXTPMarkupColumnDefinition);
46public:
51 CXTPMarkupColumnDefinition();
52
53public:
59 void SetMinWidth(int nWidth);
60
66 void SetMaxWidth(int nWidth);
67
73 void SetWidth(int nWidth);
74
80 void SetWidth(CXTPMarkupGridLength* pLength);
81
83public:
84 DECLARE_DISPATCH_MAP()
85# ifdef _XTP_ACTIVEX
86 DECLARE_INTERFACE_MAP()
87 DECLARE_OLETYPELIB_EX(CXTPMarkupColumnDefinition);
88# endif&
89
90 afx_msg void OleSetMinWidth(int nWidth);
91 afx_msg void OleSetMaxWidth(int nWidth);
92 afx_msg void OleSetWidth(int nWidth);
93 afx_msg int OleGetMinWidth();
94 afx_msg int OleGetMaxWidth();
95 afx_msg int OleGetWidth();
96 afx_msg int OleGetUnitType();
97 afx_msg void OleSetUnitType(int nType);
100public:
101 static CXTPMarkupDependencyProperty* m_pWidthProperty;
102 static CXTPMarkupDependencyProperty* m_pMinWidthProperty;
103 static CXTPMarkupDependencyProperty* m_pMaxWidthProperty;
104};
105
106# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
108#endif // !defined(__XTPMARKUPCOLUMNDEFINITION_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPMarkupColumnDefinition
CXTPMarkupColumnDefinition is a CXTPMarkupDefinitionBase derived class.
Definition XTPMarkupColumnDefinition.h:42
CXTPMarkupColumnDefinition::SetMinWidth
void SetMinWidth(int nWidth)
Sets the minimum width constraint for the column.
CXTPMarkupColumnDefinition::SetMaxWidth
void SetMaxWidth(int nWidth)
Sets the maximum width constraint for the column.
CXTPMarkupColumnDefinition::SetWidth
void SetWidth(CXTPMarkupGridLength *pLength)
Sets the width for the column.
CXTPMarkupColumnDefinition::SetWidth
void SetWidth(int nWidth)
Sets the width for the column.
CXTPMarkupColumnDefinition::CXTPMarkupColumnDefinition
CXTPMarkupColumnDefinition()
Constructs a CXTPMarkupColumnDefinition object.
CXTPMarkupDefinitionBase
CXTPMarkupDefinitionBase is the base class for CXTPMarkupColumnDefinition and CXTPMarkupRowDefinition...
Definition XTPMarkupDefinitionBase.h:45
CXTPMarkupGridLength
CXTPMarkupGridLength is a class defined length of grid rows and columns.
Definition XTPMarkupGridLength.h:41


Toolkit Pro: XTPSkinObjectFrame.h Source File

  • Source
  • SkinFramework
XTPSkinObjectFrame.h
Go to the documentation of this file.
1
23#if !defined(__XTPSKINOBJECTFRAME_H__)
24# define __XTPSKINOBJECTFRAME_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
34# ifndef WM_NCMOUSELEAVE
35# define WM_NCMOUSELEAVE 0x02A2
36# endif
37
38# ifndef WM_QUERYUISTATE
39# define WM_UPDATEUISTATE 0x0128
40# define WM_QUERYUISTATE 0x0129
41
42# define UISF_HIDEACCEL 0x2
43# define UISF_HIDEFOCUS 0x1
44# endif
45
46# define XTP_TID_MOUSELEAVE 0xACB
47# define XTP_TID_REFRESHFRAME 0xACD
48# define XTP_REFRESHFRAME_AFFECTED_STYLES WS_DLGFRAME
49# define XTP_REFRESHFRAME_DURATION 1000
50
51struct _XTP_EXT_CLASS XTP_SKINSCROLLBAR_POSINFO : public XTP_SCROLLBAR_POSINFO
52{
53 int nBar;
54 BOOL fVisible;
55};
56
57struct _XTP_EXT_CLASS XTP_SKINSCROLLBAR_TRACKINFO : public XTP_SCROLLBAR_TRACKINFO
58{
59 BOOL fTrackVert;
60 HWND hWndSB;
61 HWND hWndSBNotify;
62 int nBar;
63 BOOL fNonClient;
64 XTP_SKINSCROLLBAR_POSINFO* pSBInfo;
65};
66
74class _XTP_EXT_CLASS CXTPSkinObjectFrame : public CXTPSkinObject
75{
77 DECLARE_DYNCREATE(CXTPSkinObjectFrame)
79public:
84 class _XTP_EXT_CLASS CCaptionButton
85 {
86 public:
95 CCaptionButton(int nCommand, CXTPSkinObjectFrame* pFrame, UINT nHTCode, int m_nClassPart);
96
101 virtual ~CCaptionButton();
102
109 void Draw(CDC* pDC, BOOL bFrameActive);
110
117 BOOL IsPressed() const;
118
125 BOOL IsHighlighted() const;
126
127 public:
128 UINT m_nHTCode;
129 CRect m_rcButton;
130 int m_nClassPart;
131 CXTPSkinObjectFrame* m_pFrame;
132 int m_nCommand;
133 BOOL m_bEnabled;
134 };
135
136 typedef CArray<CCaptionButton*, CCaptionButton*> CCaptionButtons;
137
138public:
143 CXTPSkinObjectFrame();
144
149 virtual ~CXTPSkinObjectFrame();
150
151public:
158 void RedrawScrollBar(int nBar);
159
166 CRect GetBorders() const;
167
174 BOOL IsActive() const;
175
182 CCaptionButtons* GetCaptionButtons();
183
191 virtual HBRUSH GetClientBrush(CDC* pDC);
192
193public:
195 BOOL IsFrameScrollBars();
196 HBRUSH GetClientBrush(HDC hDC, HWND hWnd, UINT nCtlColor);
197 XTP_SKINSCROLLBAR_TRACKINFO* GetScrollBarTrackInfo() const;
198
199 BOOL DrawMenuBar();
200 virtual void UpdateMenuBar();
203protected:
210 virtual void OnSkinChanged(BOOL bPrevState, BOOL bNewState);
211
216 virtual void RefreshMetrics();
217
227 virtual void OnHookAttached(LPCREATESTRUCT lpcs, BOOL bAuto);
228
236 void OnHookDetached(BOOL bAuto);
237
239public:
240 void RedrawFrame();
241 BOOL HasCaption() const;
242 BOOL HasWindowBorder() const;
243 virtual int GetClientBrushMessage();
244
245protected:
246 void UpdateFrameRegion(CSize szFrameRegion);
247 void UpdateButtons();
248 void InvalidateButtons();
249 CCaptionButton* HitTestButton(CPoint pt);
250 void UpdateButton(int nID, BOOL bVisible, BOOL bEnabled, UINT htCode, int nClassPart);
251 void RemoveButtons();
252 void RefreshFrameStyle();
253 HBRUSH FillBackground(CDC* pDC, LPCRECT lprc, int nMessage = WM_CTLCOLORSTATIC);
254 HBRUSH GetFillBackgroundBrush(CDC* pDC, int nMessage);
255 void ResizeFrame(BOOL bUpdateRegion = TRUE);
256
257protected:
258 virtual void DrawFrame(CDC* pDC);
259 void ScreenToFrame(LPPOINT lpPoint);
260 void ClientToFrame(LPPOINT lpPoint);
261 void AdjustFrame(CRect& rc);
262 BOOL OnHookMessage(UINT nMessage, WPARAM& wParam, LPARAM& lParam, LRESULT& lResult);
263 BOOL OnHookDefWindowProc(UINT nMessage, WPARAM& wParam, LPARAM& lParam, LRESULT& lResult);
264
265 using CXTPSkinObject::OnCtlColor;
266 BOOL OnCtlColor(UINT nMessage, WPARAM& wParam, LPARAM& lParam, LRESULT& lResult,
267 BOOL bConsiderDlgTexture = FALSE);
268
269protected:
270 void DrawScrollBar(CDC* pDC, XTP_SKINSCROLLBAR_POSINFO* pSBInfo);
271 void TrackInit(CPoint point, XTP_SKINSCROLLBAR_POSINFO* pSBInfo, BOOL bDirect);
272 void ContScroll();
273 void DoScroll(HWND hwnd, HWND hwndNotify, int cmd, int pos, BOOL fVert);
274 void TrackBox(UINT message, CPoint point);
275 void TrackThumb(UINT message, CPoint point);
276 void MoveThumb(int px);
277 int HitTestScrollBar(XTP_SKINSCROLLBAR_POSINFO* pSBInfo, POINT pt);
278 void EndScroll(BOOL fCancel);
279 void CalcScrollBarInfo(LPRECT lprc, XTP_SKINSCROLLBAR_POSINFO* pSBInfo, SCROLLINFO* pSI);
280 void RedrawScrollBar(XTP_SKINSCROLLBAR_POSINFO* pSBInfo);
281 void SetupScrollInfo(XTP_SKINSCROLLBAR_POSINFO* pSBInfo);
282 CRect GetScrollBarRect(int sbCode);
283 void TrackCaptionButton();
284 BOOL IsSizeBox();
285 virtual BOOL IsDefWindowProcAvail(int nMessage) const;
286 BOOL PreHookMessage(UINT nMessage);
287 BOOL IsFlatScrollBarInitialized() const;
288 HWND FindMDIClient();
289 virtual BOOL HandleSysCommand(UINT nID, LPARAM lParam);
292protected:
294 DECLARE_MESSAGE_MAP()
295
296 //{{AFX_VIRTUAL(CXTPSkinObjectFrame)
297 //}}AFX_VIRTUAL
298
299 //{{AFX_MSG(CXTPSkinObjectFrame)
300 afx_msg void OnNcPaint();
301 afx_msg void OnNcCalcSize(BOOL bCalcValidRects, NCCALCSIZE_PARAMS FAR* lpncsp);
302 afx_msg void OnNcMouseMove(UINT nHitTest, CPoint point);
303 afx_msg LRESULT OnNcHitTest(CPoint point);
304 afx_msg void OnNcLButtonDown(UINT nHitTest, CPoint point);
305 afx_msg void OnNcRButtonUp(UINT nHitTest, CPoint point);
306 afx_msg void OnNcLButtonDblClk(UINT nHitTest, CPoint point);
307 afx_msg void HandleTimer(UINT_PTR nIDEvent);
308 afx_msg void OnNcMouseLeave();
309 afx_msg LRESULT OnSetText(WPARAM wParam, LPARAM lParam);
310 afx_msg BOOL OnNcActivate(BOOL bActive);
311 afx_msg int OnCreate(LPCREATESTRUCT lpCreateStruct);
312 afx_msg void OnWindowPosChanging(WINDOWPOS FAR* lpwndpos);
313 afx_msg void OnPaint();
314 afx_msg LRESULT OnPrint(WPARAM, LPARAM);
315 afx_msg void OnVScroll(UINT nSBCode, UINT nPos, CScrollBar* pScrollBar);
316 afx_msg void OnHScroll(UINT nSBCode, UINT nPos, CScrollBar* pScrollBar);
317 afx_msg void OnGetMinMaxInfo(MINMAXINFO* lpMMI);
318 afx_msg void OnStyleChanged(int nStyleType, LPSTYLESTRUCT lpStyleStruct);
319 afx_msg void OnSysCommand(UINT nID, LPARAM lParam);
320 afx_msg void OnSysKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags);
321 afx_msg void OnSysKeyUp(UINT nChar, UINT nRepCnt, UINT nFlags);
322 afx_msg void OnKeyUp(UINT nChar, UINT nRepCnt, UINT nFlags);
323 virtual BOOL HandleMouseMove(CPoint point);
324 virtual LRESULT HandleNcHitTest(CPoint point);
325 afx_msg void OnWindowPosChanged(WINDOWPOS FAR* lpwndpos);
326 afx_msg BOOL OnEraseBkgnd(CDC* pDC);
327 LRESULT CallDefDlgProc(UINT nMessage, WPARAM wParam, LPARAM lParam);
328 static void CALLBACK OnTimerInternal(HWND hWnd, UINT nMsg, UINT_PTR nIDEvent, DWORD dwTime);
329 afx_msg LRESULT OnSetIcon(WPARAM, LPARAM);
330 //}}AFX_MSG
333protected:
334 void CancelMouseLeaveTracking();
335 HWND GetTopLevelWindow() const;
336
337private:
338 void RefreshScrollBarsData();
339
340public:
341 BOOL m_bLockFrameDraw;
342 DWORD m_dwDialogTexture;
343 CXTPSkinObjectFrame* m_pMDIClient;
344
345protected:
346 CCaptionButtons m_arrButtons;
347 CRect m_rcBorders;
348 CCaptionButton* m_pButtonHot;
349 CCaptionButton* m_pButtonPressed;
350 BOOL m_bRegionChanged;
351 XTP_SKINSCROLLBAR_TRACKINFO* m_pSBTrack;
352 XTP_SKINSCROLLBAR_POSINFO m_spi[2];
353 CSize m_szFrameRegion;
354 BOOL m_bMDIClient;
355 BOOL m_bActive;
356 DWORD m_dwStyle;
357 DWORD m_dwExStyle;
359 BOOL m_bInUpdateRegion;
360 BOOL m_bInWindowPosChanged;
361
362 int m_nCtlColorMessage;
363 static CXTPThreadLocal<BOOL> m_bMenuStatus;
364
365private:
366 friend class CXTPSkinManager;
367 friend class CCaptionButton;
368};
369
370AFX_INLINE BOOL CXTPSkinObjectFrame::IsActive() const
371{
372 return m_bActive;
373}
374
375AFX_INLINE CRect CXTPSkinObjectFrame::GetBorders() const
376{
377 return m_rcBorders;
378}
380AFX_INLINE XTP_SKINSCROLLBAR_TRACKINFO* CXTPSkinObjectFrame::GetScrollBarTrackInfo() const
381{
382 return m_pSBTrack;
383}
385AFX_INLINE CXTPSkinObjectFrame::CCaptionButtons* CXTPSkinObjectFrame::GetCaptionButtons()
386{
387 return &m_arrButtons;
388}
390AFX_INLINE void CXTPSkinObjectFrame::UpdateMenuBar()
391{
392}
399class _XTP_EXT_CLASS CXTPSkinObjectUser32Control : public CXTPSkinObjectFrame
400{
401protected:
406 CXTPSkinObjectUser32Control();
407
408protected:
413 virtual void CheckScrollBarsDraw();
414
415protected:
417 DECLARE_MESSAGE_MAP()
418
419 // Overrides
420 //{{AFX_VIRTUAL(CXTPSkinObjectUser32Control)
421 BOOL OnWndMsg(UINT message, WPARAM wParam, LPARAM lParam, LRESULT* pResult);
422 //}}AFX_VIRTUAL
423
424 //{{AFX_MSG(CXTPSkinObjectUser32Control)
425 afx_msg void OnHScroll(UINT nSBCode, UINT nPos, CScrollBar* pScrollBar);
426 afx_msg void OnVScroll(UINT nSBCode, UINT nPos, CScrollBar* pScrollBar);
427 afx_msg BOOL OnEraseBkgnd(CDC* pDC);
428 afx_msg void OnKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags);
429 afx_msg void OnChar(UINT nChar, UINT nRepCnt, UINT nFlags);
430 afx_msg void OnWindowPosChanged(WINDOWPOS FAR* lpwndpos);
431 //}}AFX_MSG
432
433protected:
434 SCROLLINFO m_si[2];
436};
437
443class _XTP_EXT_CLASS CXTPSkinObjectComCtl32Control : public CXTPSkinObjectUser32Control
444{
445protected:
450 CXTPSkinObjectComCtl32Control();
451
452protected:
457 virtual void CheckScrollBarsDraw();
458};
459
466class _XTP_EXT_CLASS CXTPSkinObjectSolidFilled : public CXTPSkinObjectFrame
467{
468public:
474 explicit CXTPSkinObjectSolidFilled(COLORREF crFill);
475
481 explicit CXTPSkinObjectSolidFilled(HBRUSH hbrFill);
482
483protected:
485 DECLARE_MESSAGE_MAP()
486
487 //{{AFX_MSG(CXTPSkinObjectUser32Control)
488 afx_msg void OnPaint();
489 afx_msg BOOL OnEraseBkgnd(CDC* pDC);
490 //}}AFX_MSG
491
493};
494
495# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
497#endif // !defined(__XTPSKINOBJECTFRAME_H__)
XTPDisableNoisyWarnings.h
CXTPSkinManager
CXTPSkinManager is a standalone class that represents a global object that manages skins.
Definition XTPSkinManager.h:541
CXTPSkinObjectComCtl32Control
CXTPSkinObjectComCtl32Control is a CXTPSkinObjectUser32Control derived class.
Definition XTPSkinObjectFrame.h:444
CXTPSkinObjectComCtl32Control::CheckScrollBarsDraw
virtual void CheckScrollBarsDraw()
Determines if the scrollbar position was changed.
CXTPSkinObjectComCtl32Control::CXTPSkinObjectComCtl32Control
CXTPSkinObjectComCtl32Control()
Constructs a CXTPSkinObjectComCtl32Control object.
CXTPSkinObjectFrame::CCaptionButton
Caption button class.
Definition XTPSkinObjectFrame.h:85
CXTPSkinObjectFrame::CCaptionButton::Draw
void Draw(CDC *pDC, BOOL bFrameActive)
This method is called to draw the caption button.
CXTPSkinObjectFrame::CCaptionButton::IsHighlighted
BOOL IsHighlighted() const
Determines the highlighted state of the button.
CXTPSkinObjectFrame::CCaptionButton::CCaptionButton
CCaptionButton(int nCommand, CXTPSkinObjectFrame *pFrame, UINT nHTCode, int m_nClassPart)
Constructs a CCaptionButton object.
CXTPSkinObjectFrame::CCaptionButton::m_nHTCode
UINT m_nHTCode
Hit test code.
Definition XTPSkinObjectFrame.h:128
CXTPSkinObjectFrame::CCaptionButton::m_nClassPart
int m_nClassPart
Class part.
Definition XTPSkinObjectFrame.h:130
CXTPSkinObjectFrame::CCaptionButton::m_pFrame
CXTPSkinObjectFrame * m_pFrame
Parent frame object.
Definition XTPSkinObjectFrame.h:131
CXTPSkinObjectFrame::CCaptionButton::IsPressed
BOOL IsPressed() const
Determines the pressed state of the button.
CXTPSkinObjectFrame::CCaptionButton::m_nCommand
int m_nCommand
Button Command.
Definition XTPSkinObjectFrame.h:132
CXTPSkinObjectFrame::CCaptionButton::m_rcButton
CRect m_rcButton
Button bounding rectangle.
Definition XTPSkinObjectFrame.h:129
CXTPSkinObjectFrame::CCaptionButton::~CCaptionButton
virtual ~CCaptionButton()
Destroys a CCaptionButton object.
CXTPSkinObjectFrame
CXTPSkinObjectFrame is a CXTPSkinObject derived class.
Definition XTPSkinObjectFrame.h:75
CXTPSkinObjectFrame::OnHookDetached
void OnHookDetached(BOOL bAuto)
This method is called when the hook is detached.
CXTPSkinObjectFrame::RedrawScrollBar
void RedrawScrollBar(int nBar)
Redraws the scrollbar of the frame.
CXTPSkinObjectFrame::GetBorders
CRect GetBorders() const
Gets the borders of the window.
Definition XTPSkinObjectFrame.h:375
CXTPSkinObjectFrame::CXTPSkinObjectFrame
CXTPSkinObjectFrame()
Constructs a CXTPSkinObjectFrame object.
CXTPSkinObjectFrame::GetClientBrush
virtual HBRUSH GetClientBrush(CDC *pDC)
Gets the client brush.
CXTPSkinObjectFrame::GetCaptionButtons
CCaptionButtons * GetCaptionButtons()
Gets the collection of caption buttons.
Definition XTPSkinObjectFrame.h:385
CXTPSkinObjectFrame::RefreshMetrics
virtual void RefreshMetrics()
This method is called when visual metrics are changed.
CXTPSkinObjectFrame::OnHookAttached
virtual void OnHookAttached(LPCREATESTRUCT lpcs, BOOL bAuto)
This method is called when the hook is attached.
CXTPSkinObjectFrame::~CXTPSkinObjectFrame
virtual ~CXTPSkinObjectFrame()
Destroys a CXTPSkinObjectFrame object, handles cleanup and deallocation.
CXTPSkinObjectFrame::OnSkinChanged
virtual void OnSkinChanged(BOOL bPrevState, BOOL bNewState)
This method is called when the skin is changed.
CXTPSkinObject
CXTPSkinObject is a CWnd derived class.
Definition XTPSkinObject.h:80
CXTPSkinObjectSolidFilled
CXTPSkinObjectSolidFilled is a CXTPSkinObjectFrame derived class.
Definition XTPSkinObjectFrame.h:467
CXTPSkinObjectSolidFilled::CXTPSkinObjectSolidFilled
CXTPSkinObjectSolidFilled(COLORREF crFill)
Constructs a CXTPSkinObjectSolidFilled object.
CXTPSkinObjectSolidFilled::CXTPSkinObjectSolidFilled
CXTPSkinObjectSolidFilled(HBRUSH hbrFill)
Constructs a CXTPSkinObjectSolidFilled object.
CXTPSkinObjectUser32Control
CXTPSkinObjectUser32Control is a CXTPSkinObjectFrame derived class.
Definition XTPSkinObjectFrame.h:400
CXTPSkinObjectUser32Control::CheckScrollBarsDraw
virtual void CheckScrollBarsDraw()
Determines if the scrollbar position was changed.
CXTPSkinObjectUser32Control::CXTPSkinObjectUser32Control
CXTPSkinObjectUser32Control()
Constructs a CXTPSkinObjectUser32Control object.
CXTPThreadLocal
Implements thread local variable adapter.
Definition XTPSystemHelpers.h:1676
XTP_SCROLLBAR_POSINFO
The XTP_SCROLLBAR_POSINFO structure contains scroll bar information.
Definition XTPScrollBase.h:143
XTP_SCROLLBAR_TRACKINFO
The XTP_SCROLLBAR_TRACKINFO structure contains tracking information.
Definition XTPScrollBase.h:174


Toolkit Pro: Member List

CXTPTransparentBitmap Member List

This is the complete list of members for CXTPTransparentBitmap, including all inherited members.

ConvertToIcon() const | CXTPTransparentBitmap |
CXTPTransparentBitmap(HBITMAP hBitmap) | CXTPTransparentBitmap |
GetTransparentColor() const | CXTPTransparentBitmap |
m_hBitmap | CXTPTransparentBitmap | protected


Toolkit Pro: XTPChartRadarAxisView.h Source File

  • Source
  • Chart
  • Diagram
  • Axis
XTPChartRadarAxisView.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTRADARAXISVIEW_H__)
24# define __XTPCHARTRADARAXISVIEW_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartRadarDiagramView;
34
40class _XTP_EXT_CLASS CXTPChartRadarAxisView : public CXTPChartAxisView
41{
42public:
50 CXTPChartRadarAxisView(CXTPChartAxis* pAxis, CXTPChartElementView* pParentView);
51
56 ~CXTPChartRadarAxisView();
57
58public:
59 virtual CXTPChartDeviceCommand* CreateGridLinesDeviceCommand(CXTPChartDeviceContext* pDC) = 0;
60 virtual CXTPChartDeviceCommand* CreateInterlacedDeviceCommand(CXTPChartDeviceContext* pDC) = 0;
61 virtual CXTPChartDeviceCommand* CreateConstantLinesDeviceCommand(CXTPChartDeviceContext* pDC,
62 BOOL bBehind) = 0;
63 virtual CXTPChartDeviceCommand* CreateStripsDeviceCommand(CXTPChartDeviceContext* pDC) = 0;
64
65public:
66 CXTPChartRadarDiagramView* GetDiagramView() const;
67
68public:
69 BOOL IsPolygonDiagramStyle() const;
70};
71
72AFX_INLINE CXTPChartRadarAxisView::CXTPChartRadarAxisView(CXTPChartAxis* pAxis,
73 CXTPChartElementView* pParentView)
74 : CXTPChartAxisView(pAxis, pParentView)
75{
76}
77AFX_INLINE CXTPChartRadarAxisView::~CXTPChartRadarAxisView()
78{
79}
80
81AFX_INLINE CXTPChartRadarDiagramView* CXTPChartRadarAxisView::GetDiagramView() const
82{
83 return (CXTPChartRadarDiagramView*)GetParentView()->GetParentView();
84}
86# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
87#endif //#if !defined(__XTPCHARTRADARAXISVIEW_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartAxis
This abstract base class represents a chart axis as a kind of chart element.
Definition XTPChartAxis.h:86
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartElementView
This class represents the view of a chart element.
Definition XTPChartElementView.h:47
CXTPChartElementView::GetParentView
CXTPChartElementView * GetParentView() const
Call this function to get the parent view.
Definition XTPChartElementView.h:205
CXTPChartRadarAxisView
This class abstracts the view of a chart axis and its child items in a bounding rectangle context.
Definition XTPChartRadarAxisView.h:41
CXTPChartRadarAxisView::~CXTPChartRadarAxisView
~CXTPChartRadarAxisView()
Destroys a CXTPChartRadarAxisView object, handles cleanup and deallocation.
Definition XTPChartRadarAxisView.h:77
CXTPChartRadarAxisView::CXTPChartRadarAxisView
CXTPChartRadarAxisView(CXTPChartAxis *pAxis, CXTPChartElementView *pParentView)
Constructs a CXTPChartRadarAxisView object.
Definition XTPChartRadarAxisView.h:72
CXTPChartRadarDiagramView
This class represents the view of a chart 2D diagram, which is a kind of CXTPChartDiagramView.
Definition XTPChartRadarDiagramView.h:48


Toolkit Pro: XTPChart3dFunnelSeriesStyle.h Source File

  • Source
  • Chart
  • Styles
  • Funnel
  • 3D
XTPChart3dFunnelSeriesStyle.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHART3DFUNNELSERIESSTYLE_H__)
24# define __XTPCHART3DFUNNELSERIESSTYLE_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartSeriesView;
34class CXTPChartBorder;
35class CXTPChartFillStyle;
36
48class _XTP_EXT_CLASS CXTPChart3dFunnelSeriesStyle : public CXTPChartFunnelSeriesStyleBase
49{
50 DECLARE_SERIAL(CXTPChart3dFunnelSeriesStyle);
51
52public:
57 CXTPChart3dFunnelSeriesStyle();
58
67 virtual CXTPChartDiagram* CreateDiagram();
68
79 virtual CXTPChartSeriesView* CreateView(CXTPChartSeries* pSeries,
80 CXTPChartDiagramView* pDiagramView);
81
92 virtual BOOL IsStyleDiagram(CXTPChartDiagram* pDiagram) const;
93
105 virtual void DoPropExchange(CXTPPropExchange* pPX);
106
116 int GetBaseEdgeCount() const;
117
126 void SetBaseEdgeCount(int nEdgeCount);
127
129# ifdef _XTP_ACTIVEX
130public:
131 DECLARE_DISPATCH_MAP()
132 DECLARE_INTERFACE_MAP()
133 DECLARE_OLETYPELIB_EX(CXTPChart3dFunnelSeriesStyle);
134 DECLARE_OLECREATE_EX(CXTPChart3dFunnelSeriesStyle)
135# endif
138private:
139 int m_nBaseEdgeCount;
140};
141
142AFX_INLINE int CXTPChart3dFunnelSeriesStyle::GetBaseEdgeCount() const
143{
144 return m_nBaseEdgeCount;
145}
147# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
148#endif //#if !defined(__XTPCHART3DFUNNELSERIESSTYLE_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChart3dFunnelSeriesStyle
This class abstracts the basic style of a funnel series.
Definition XTPChart3dFunnelSeriesStyle.h:49
CXTPChart3dFunnelSeriesStyle::DoPropExchange
virtual void DoPropExchange(CXTPPropExchange *pPX)
Call this member function to Store/Load an event using the specified data object.
CXTPChart3dFunnelSeriesStyle::CXTPChart3dFunnelSeriesStyle
CXTPChart3dFunnelSeriesStyle()
Constructs a CXTPChart3dFunnelSeriesStyle object.
CXTPChart3dFunnelSeriesStyle::IsStyleDiagram
virtual BOOL IsStyleDiagram(CXTPChartDiagram *pDiagram) const
Call this function to check whether the chart diagram object passed is a kind of CXTPChart3dFunnelDia...
CXTPChart3dFunnelSeriesStyle::CreateView
virtual CXTPChartSeriesView * CreateView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Call this function to create the view of the funnel series.
CXTPChart3dFunnelSeriesStyle::CreateDiagram
virtual CXTPChartDiagram * CreateDiagram()
Call this function to create the funnel diagram object.
CXTPChart3dFunnelSeriesStyle::SetBaseEdgeCount
void SetBaseEdgeCount(int nEdgeCount)
Sets the number of base edges for the funnel.
CXTPChart3dFunnelSeriesStyle::GetBaseEdgeCount
int GetBaseEdgeCount() const
Gets the number of base edges for the funnel.
Definition XTPChart3dFunnelSeriesStyle.h:142
CXTPChartBorder
This class abstracts the border of a chart, it is a kind of chart element.
Definition XTPChartBorder.h:42
CXTPChartDiagram
This class represents a chart diagram, which is a kind of CXTPChartElement.
Definition XTPChartDiagram.h:48
CXTPChartDiagramView
This class represents the view of a chart diagram, which is a kind of CXTPChartElementView.
Definition XTPChartDiagramView.h:49
CXTPChartFillStyle
This class abstracts a fill style used to fill the background of various chart elements.
Definition XTPChartFillStyle.h:43
CXTPChartFunnelSeriesStyleBase
This class abstracts the basic style of a funnel serie.This class is a kind of CXTPChartSeriesStyle.
Definition XTPChartFunnelSeriesStyleBase.h:49
CXTPChartSeries
This class represents a series in the chart, which is a kind of CXTPChartElement.
Definition XTPChartSeries.h:50
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72


Toolkit Pro: Member List

CXTPChartRadarAreaSeriesStyle Member List

This is the complete list of members for CXTPChartRadarAreaSeriesStyle, including all inherited members.

ApplyTo(CXTPChartDeviceCommand *pCommand) | CXTPChartSeriesStyle | virtual
CorrectAxisSideMargins(CXTPChartAxis *pAxis, double nMinValue, double nMaxValue, double &nCorrection) | CXTPChartSeriesStyle | virtual
CreateDiagram() | CXTPChartRadarDiagramSeriesStyle | virtual
CreateView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView) | CXTPChartRadarAreaSeriesStyle | protectedvirtual
CXTPChartElement() | CXTPChartElement |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartRadarAreaSeriesStyle() | CXTPChartRadarAreaSeriesStyle |
CXTPChartRadarDiagramSeriesStyle() | CXTPChartRadarDiagramSeriesStyle |
CXTPChartRadarPointSeriesStyle() | CXTPChartRadarPointSeriesStyle |
CXTPChartSeriesStyle() | CXTPChartSeriesStyle |
DoPropExchange(CXTPPropExchange *pPX) | CXTPChartRadarAreaSeriesStyle | virtual
Enable3dEdgeSmoothing(BOOL bEnable=TRUE) | CXTPChartSeriesStyle | virtual
Get3dRotation() const | CXTPChartSeriesStyle | virtual
GetAppearance() const | CXTPChartElement |
GetColor() const | CXTPChartSeriesStyle | virtual
GetContent() const | CXTPChartElement |
GetErrorBar() const | CXTPChartSeriesStyle | virtual
GetFillStyle() const | CXTPChartRadarAreaSeriesStyle |
GetLabel() const | CXTPChartSeriesStyle | virtual
GetMarker() const | CXTPChartRadarPointSeriesStyle |
GetOwner() const | CXTPChartElement |
GetSeriesPointValueIndex() const | CXTPChartSeriesStyle | virtual
GetStyleAppearance() const | CXTPChartSeriesStyle | virtual
GetTransparency() const | CXTPChartRadarAreaSeriesStyle | virtual
Is3D() const | CXTPChartObject |
Is3dEdgeSmoothingEnabled() const | CXTPChartSeriesStyle | virtual
IsColorEach() const | CXTPChartSeriesStyle | virtual
IsStyleDiagram(CXTPChartDiagram *pDiagram) const | CXTPChartRadarDiagramSeriesStyle | virtual
m_bColorEach | CXTPChartSeriesStyle | protected
m_bSmooth3dEdges | CXTPChartSeriesStyle | protected
m_clrColor | CXTPChartSeriesStyle | protected
m_nTransparency | CXTPChartRadarAreaSeriesStyle | protected
m_pBorder | CXTPChartRadarAreaSeriesStyle | protected
m_pErrorBar | CXTPChartSeriesStyle | protected
m_pFillStyle | CXTPChartRadarAreaSeriesStyle | protected
m_pLabel | CXTPChartSeriesStyle | protected
m_Rotation3d | CXTPChartSeriesStyle | protected
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartElement | virtual
Release() | CXTPChartElement | virtual
Set3dRotation(const CXTPChart3dRotation &rotation) | CXTPChartSeriesStyle | virtual
Set3dRotation(double dYaw, double dPitch, double dRoll) | CXTPChartSeriesStyle | virtual
SetColor(CXTPChartColor clr) | CXTPChartSeriesStyle | virtual
SetColorEach(BOOL bColorEach) | CXTPChartSeriesStyle | virtual
SetErrorBar(CXTPChartErrorBar *pErrorBar) | CXTPChartSeriesStyle | virtual
SetLabel(CXTPChartSeriesLabel *pLabel) | CXTPChartSeriesStyle | virtual
SetTransparency(int nTransparency) | CXTPChartRadarAreaSeriesStyle | virtual
~CXTPChartElement() | CXTPChartElement | virtual
~CXTPChartRadarAreaSeriesStyle() | CXTPChartRadarAreaSeriesStyle | virtual
~CXTPChartRadarDiagramSeriesStyle() | CXTPChartRadarDiagramSeriesStyle | virtual
~CXTPChartRadarPointSeriesStyle() | CXTPChartRadarPointSeriesStyle | virtual
~CXTPChartSeriesStyle() | CXTPChartSeriesStyle | virtual


Toolkit Pro: Member List

CXTPChartFunnelSeriesLabelViewBase Member List

This is the complete list of members for CXTPChartFunnelSeriesLabelViewBase, including all inherited members.

AddChildView(CXTPChartElementView *pChildView) | CXTPChartElementView |
CreateDeviceCommand(CXTPChartDeviceContext *pDC)=0 | CXTPChartFunnelSeriesLabelViewBase | pure virtual
CXTPChartElementView(CXTPChartElementView *pParentView) | CXTPChartElementView |
CXTPChartElementView(CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartElementView |
CXTPChartElementView(CXTPChartContainer *pContainer) | CXTPChartElementView |
CXTPChartFunnelSeriesLabelViewBase(CXTPChartSeriesLabel *pLabel, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView) | CXTPChartFunnelSeriesLabelViewBase | protected
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
GetAt(int nIndex) const | CXTPChartElementView |
GetBounds() const | CXTPChartElementView |
GetBounds(BOOL bIncludingChildren) const | CXTPChartElementView |
GetChildren() | CXTPChartElementView |
GetCount() const | CXTPChartElementView |
GetParentView() const | CXTPChartElementView |
GetPosition() const | CXTPChartFunnelSeriesLabelViewBase |
Is3D() const | CXTPChartObject |
m_arrChildren | CXTPChartElementView | protected
m_pContainer | CXTPChartElementView | protected
m_pParentView | CXTPChartElementView | protected
m_rcBounds | CXTPChartElementView | protected
~CXTPChartElementView() | CXTPChartElementView | protectedvirtual


Toolkit Pro: XTPMarkupInputElement.h Source File

  • Source
  • Markup
XTPMarkupInputElement.h
Go to the documentation of this file.
1
23#if !defined(__XTPMARKUPINPUTELEMENT_H__)
24# define __XTPMARKUPINPUTELEMENT_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPMarkupString;
34class CXTPMarkupContext;
35class CXTPMarkupTriggerCollection;
36
37class CXTPMarkupEventHandlerMap;
38class CXTPMarkupDelegate;
39class CXTPMarkupDispatchDelegate;
40class CXTPMarkupRoutedEventArgs;
41class CXTPMarkupMouseEventArgs;
42class CXTPMarkupMouseWheelEventArgs;
43class CXTPMarkupQueryCursorEventArgs;
44class CXTPMarkupMouseButtonEventArgs;
45class CXTPMarkupTransformationMatrix;
46
47class _XTP_EXT_CLASS CXTPMarkupInputElement : public CXTPMarkupObject
48{
50 DECLARE_MARKUPCLASS(CXTPMarkupInputElement);
52protected:
53 CXTPMarkupInputElement();
54 virtual ~CXTPMarkupInputElement();
55
56public:
57 virtual void OnMouseLeave(CXTPMarkupMouseEventArgs* e);
58 virtual void OnMouseEnter(CXTPMarkupMouseEventArgs* e);
59 virtual void OnMouseMove(CXTPMarkupMouseEventArgs* e);
60 virtual void OnQueryCursor(CXTPMarkupQueryCursorEventArgs* e);
61
62 virtual void OnMouseLeftButtonUp(CXTPMarkupMouseButtonEventArgs* e);
63 virtual void OnMouseRightButtonUp(CXTPMarkupMouseButtonEventArgs* e);
64 virtual void OnMouseLeftButtonDown(CXTPMarkupMouseButtonEventArgs* e);
65 virtual void OnMouseRightButtonDown(CXTPMarkupMouseButtonEventArgs* e);
66
67 virtual void OnLostMouseCapture(CXTPMarkupMouseEventArgs* e);
68 CXTPMarkupContext* GetMarkupContext() const;
69
70 virtual void OnMouseWheel(CXTPMarkupMouseWheelEventArgs* e);
71
72 void Apply();
73
74public:
75 virtual CXTPMarkupInputElement* InputHitTest(CPoint point) const;
76
77 BOOL IsMouseOver() const;
78 CXTPMarkupObject* GetToolTip() const;
79 void SetToolTip(LPCTSTR lpszTooltip);
80
81 void AddHandler(CXTPMarkupRoutedEvent* pEvent, CXTPMarkupDelegate* pDelegate);
82
83 CXTPMarkupObject* FindResource(const CXTPMarkupObject* pKey) const;
84
85 void Focus();
86 BOOL IsKeyboardFocused() const;
87
88 CXTPMarkupString* GetName() const;
89 void SetName(LPCTSTR lpszName);
90
91protected:
92 void RaiseEvent(CXTPMarkupRoutedEventArgs* pEventArgs);
93
94protected:
95 void CaptureMouse();
96 void ReleaseMouseCapture();
97
98protected:
99 void FireTriggers(CXTPMarkupDependencyProperty* pProperty, CXTPMarkupObject* pNewValue);
100 BOOL AddStyleTriggers(CXTPMarkupStyle* pStyle, CXTPMarkupDependencyProperty* pProperty,
101 CXTPMarkupObject* pNewValue);
102
103protected:
104 void SetPropertyObject(CXTPMarkupBuilder* pBuilder, CXTPMarkupDependencyProperty* pProperty,
105 CXTPMarkupObject* pValue);
106 virtual void OnFinalRelease();
107 virtual void OnApply();
108 void ApplyTree(CXTPMarkupObject* pChild);
109
110 static void AFX_CDECL OnStylePropertyChanged(CXTPMarkupObject* d,
111 CXTPMarkupPropertyChangedEventArgs* /*e*/);
112 static void AFX_CDECL OnCursorPropertyChanged(CXTPMarkupObject* d,
113 CXTPMarkupPropertyChangedEventArgs* e);
114 virtual CXTPMarkupObject* GetValueCore(CXTPMarkupDependencyProperty* pProperty) const;
115
116protected:
118public:
119 DECLARE_DISPATCH_MAP()
120# ifdef _XTP_ACTIVEX
121 DECLARE_INTERFACE_MAP()
122 DECLARE_OLETYPELIB_EX(CXTPMarkupInputElement);
123# endif
124
125 afx_msg long OleGetCursor();
126 afx_msg void OleSetCursor(long nValue);
127 afx_msg VARIANT OleGetToolTip();
128 afx_msg void OleSetToolTip(const VARIANT& va);
129 afx_msg BOOL OleGetIsMouseOver();
130 afx_msg void OleAddHandler(LPDISPATCH lpEventDisp, LPCOLESTR Method);
131 afx_msg LPDISPATCH OleFindName(LPCOLESTR lpszName);
132 void OleSetName(LPCTSTR lpszName);
133 BSTR OleGetName();
134
135 afx_msg LPDISPATCH OleGetMouseLeaveEvent();
136 afx_msg LPDISPATCH OleGetMouseEnterEvent();
137 afx_msg LPDISPATCH OleGetMouseLeftButtonUpEvent();
138 afx_msg LPDISPATCH OleGetMouseLeftButtonDownEvent();
139 afx_msg LPDISPATCH OleGetMouseRightButtonUpEvent();
140 afx_msg LPDISPATCH OleGetMouseRightButtonDownEvent();
141 afx_msg LPDISPATCH OleGetMouseMoveEvent();
142 afx_msg LPDISPATCH OleGetLostMouseCaptureEvent();
143
144 afx_msg VARIANT OleGetMouseLeave();
145 afx_msg void OleSetMouseLeave(VARIANT& v);
146 afx_msg VARIANT OleGetMouseEnter();
147 afx_msg void OleSetMouseEnter(VARIANT& v);
148 afx_msg VARIANT OleGetMouseLeftButtonUp();
149 afx_msg void OleSetMouseLeftButtonUp(VARIANT& v);
150 afx_msg VARIANT OleGetMouseLeftButtonDown();
151 afx_msg void OleSetMouseLeftButtonDown(VARIANT& v);
152 afx_msg VARIANT OleGetMouseRightButtonUp();
153 afx_msg void OleSetMouseRightButtonUp(VARIANT& v);
154 afx_msg VARIANT OleGetMouseRightButtonDown();
155 afx_msg void OleSetMouseRightButtonDown(VARIANT& v);
156 afx_msg VARIANT OleGetMouseMove();
157 afx_msg void OleSetMouseMove(VARIANT& v);
158 afx_msg VARIANT OleGetLostMouseCapture();
159 afx_msg void OleSetLostMouseCapture(VARIANT& v);
160
163protected:
164 CXTPMarkupEventHandlerMap* AccessHandlers();
165
166 IDispatch* GetDispDelegate(CXTPMarkupDispatchDelegate* pDelegate);
167 void SetDispDelegate(CXTPMarkupDispatchDelegate*& pDelegate, CXTPMarkupRoutedEvent* pEvent,
168 IDispatch* pDisp);
169 VARIANT GetDispDelegateVariant(CXTPMarkupDispatchDelegate* pDelegate);
170 void SetDispDelegateVariant(CXTPMarkupDispatchDelegate*& pDelegate,
171 CXTPMarkupRoutedEvent* pEvent, VARIANT v);
172
173protected:
174 CXTPMarkupEventHandlerMap* m_pHandlers;
175 CXTPMarkupContext* m_pMarkupContext;
176 CXTPMarkupTriggerCollection* m_pActiveTriggers;
177 CXTPMarkupProperties* m_pTriggerProperties;
178 CXTPMarkupStyle* m_pStyleCache;
179
180 CXTPMarkupDispatchDelegate* m_pMouseLeave;
181 CXTPMarkupDispatchDelegate* m_pMouseEnter;
182 CXTPMarkupDispatchDelegate* m_pMouseLeftButtonUp;
183 CXTPMarkupDispatchDelegate* m_pMouseLeftButtonDown;
184 CXTPMarkupDispatchDelegate* m_pMouseRightButtonUp;
185 CXTPMarkupDispatchDelegate* m_pMouseRightButtonDown;
186 CXTPMarkupDispatchDelegate* m_pMouseMove;
187 CXTPMarkupDispatchDelegate* m_pLostMouseCapture;
188
189public:
190 static CXTPMarkupDependencyProperty* m_pCursorProperty;
191 static CXTPMarkupDependencyProperty* m_pIsMouseOverProperty;
192 static CXTPMarkupDependencyProperty* m_pStyleProperty;
193 static CXTPMarkupDependencyProperty* m_pResourcesProperty;
194 static CXTPMarkupDependencyProperty* m_pToolTipProperty;
195
196 static CXTPMarkupDependencyProperty* m_pIsKeyboardFocusedProperty;
197 static CXTPMarkupDependencyProperty* m_pIsFocusableProperty;
198
199 static CXTPMarkupRoutedEvent* m_pMouseLeaveEvent;
200 static CXTPMarkupRoutedEvent* m_pMouseEnterEvent;
201 static CXTPMarkupRoutedEvent* m_pMouseLeftButtonUpEvent;
202 static CXTPMarkupRoutedEvent* m_pMouseLeftButtonDownEvent;
203 static CXTPMarkupRoutedEvent* m_pMouseRightButtonUpEvent;
204 static CXTPMarkupRoutedEvent* m_pMouseRightButtonDownEvent;
205 static CXTPMarkupRoutedEvent* m_pMouseMoveEvent;
206 static CXTPMarkupRoutedEvent* m_pLostMouseCaptureEvent;
207
208private:
209 friend class CXTPMarkupContext;
210};
211
212AFX_INLINE CXTPMarkupContext* CXTPMarkupInputElement::GetMarkupContext() const
213{
214 return m_pMarkupContext;
215}
216
222class _XTP_EXT_CLASS CXTPMarkupVisual : public CXTPMarkupInputElement
223{
225 DECLARE_MARKUPCLASS(CXTPMarkupVisual);
227public:
233 CXTPMarkupVisual();
234
239 virtual ~CXTPMarkupVisual();
240
241public:
247 void Render(CXTPMarkupDrawingContext* drawingContext);
248
257 CXTPMarkupInputElement* InputHitTest(CPoint point) const;
258
259public:
269 virtual int GetVisualChildrenCount() const;
270
280 virtual CXTPMarkupVisual* GetVisualChild(int nIndex) const;
281
288 virtual int GetLogicalChildrenCount() const;
289
303 virtual CXTPMarkupObject* GetLogicalChild(int nIndex) const;
304
311 CRect GetBoundRect() const;
312
319 CRect GetUpdateRect() const;
320
327 CSize GetRenderSize() const;
328
335 CPoint GetVisualOffset() const;
336
345 virtual BOOL GetLayoutClip(CRect& rc) const;
346
353 CXTPMarkupVisual* GetVisualParent() const;
354
360 struct TransformationMatrices
361 {
366 TransformationMatrices();
367
374 TransformationMatrices(CXTPMarkupTransformationMatrix* pOldMatrix,
375 CXTPMarkupTransformationMatrix* pNewMatrix);
376
377 CXTPMarkupTransformationMatrix* pOldMatrix;
379 CXTPMarkupTransformationMatrix* pNewMatrix;
380 };
381
382protected:
391 virtual TransformationMatrices ApplyRenderTransform(CXTPMarkupDrawingContext* pContext);
392
400 virtual void RestoreRenderTransform(CXTPMarkupDrawingContext* pContext,
401 TransformationMatrices& matrices);
402
411 BOOL PtInRectTransform(const RECT& rect, const POINT& point) const;
412
419 POINT GetAbsoluteVisualOffset() const;
420
427 virtual void OnRender(CXTPMarkupDrawingContext* drawingContext);
428
435 virtual void OnRenderFocusVisual(CXTPMarkupDrawingContext* drawingContext);
436
446 virtual CXTPMarkupInputElement* InputHitTestOverride(CPoint point) const;
447
453 virtual void RenderClipped(CXTPMarkupDrawingContext* drawingContext);
454
461 virtual double GetOpacity() const;
462
469 virtual BOOL IsVisible() const;
470
472 // Internal methods
473protected:
474 void UpdateBoundRect();
475 CXTPMarkupTransformationMatrix* GetAbsoluteTransformationMatrix() const;
476 void SetCurrentTransformationMatrix(CXTPMarkupTransformationMatrix* pMatrix);
480public:
481 DECLARE_DISPATCH_MAP()
482# ifdef _XTP_ACTIVEX
483 DECLARE_INTERFACE_MAP()
484 DECLARE_OLETYPELIB_EX(CXTPMarkupVisual);
485# endif
486
487 afx_msg LPDISPATCH OleGetVisualParent();
488 afx_msg void OleGetBoundingRect(int* left, int* top, int* right, int* bottom);
489 afx_msg int OleGetActualWidth();
490 afx_msg int OleGetActualHeight();
493protected:
494 CPoint m_ptVisualOffset;
495 CSize m_szRenderSize;
496 CRect m_rcBoundRect;
497 CRect m_rcUpdateRect;
498 CRect m_rcPrevUpdateRect;
499 CXTPMarkupTransformationMatrix* m_pCurrentTransformationMatrix;
500};
501
502AFX_INLINE CXTPMarkupVisual::TransformationMatrices::TransformationMatrices()
503 : pOldMatrix(NULL)
504 , pNewMatrix(NULL)
505{
506}
507
508AFX_INLINE CXTPMarkupVisual::TransformationMatrices::TransformationMatrices(
509 CXTPMarkupTransformationMatrix* pOldMatrix, CXTPMarkupTransformationMatrix* pNewMatrix)
510 : pOldMatrix(pOldMatrix)
511 , pNewMatrix(pNewMatrix)
512{
513}
514
515AFX_INLINE void CXTPMarkupVisual::OnRender(CXTPMarkupDrawingContext* /*drawingContext*/)
516{
517}
518
519AFX_INLINE void CXTPMarkupVisual::OnRenderFocusVisual(CXTPMarkupDrawingContext* /*drawingContext*/)
520{
521}
522
523AFX_INLINE CXTPMarkupVisual::TransformationMatrices
524 CXTPMarkupVisual::ApplyRenderTransform(CXTPMarkupDrawingContext* pContext)
525{
526 UNREFERENCED_PARAMETER(pContext);
527 return TransformationMatrices();
528}
529
530AFX_INLINE void CXTPMarkupVisual::RestoreRenderTransform(CXTPMarkupDrawingContext* pContext,
531 TransformationMatrices& matrices)
532{
533 UNREFERENCED_PARAMETER(pContext);
534 UNREFERENCED_PARAMETER(matrices);
535}
536
537AFX_INLINE CSize CXTPMarkupVisual::GetRenderSize() const
538{
539 return m_szRenderSize;
540}
541
542AFX_INLINE CRect CXTPMarkupVisual::GetBoundRect() const
543{
544 return m_rcBoundRect;
545}
546
547AFX_INLINE CPoint CXTPMarkupVisual::GetVisualOffset() const
548{
549 return m_ptVisualOffset;
550}
551
552# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
554#endif // !defined(__XTPMARKUPINPUTELEMENT_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPMarkupContext
CXTPMarkupContext is a standalone class used to provide common settings for Markup objects.
Definition XTPMarkupContext.h:128
CXTPMarkupTransformationMatrix
An abstract class for device context transformation matrix.
Definition XTPMarkupTransformationMatrix.h:40
CXTPMarkupVisual
Provides rendering support for XML Markup, which includes hit testing, coordinate transformation,...
Definition XTPMarkupInputElement.h:223
CXTPMarkupVisual::IsVisible
virtual BOOL IsVisible() const
Checks if the element is currently visible.
CXTPMarkupVisual::PtInRectTransform
BOOL PtInRectTransform(const RECT &rect, const POINT &point) const
Checks if a point is inside a rectangle with transformation applied.
CXTPMarkupVisual::GetVisualOffset
CPoint GetVisualOffset() const
Gets or sets the offset value of the visual object.
Definition XTPMarkupInputElement.h:547
CXTPMarkupVisual::InputHitTest
CXTPMarkupInputElement * InputHitTest(CPoint point) const
Determines if a point belongs to this object.
CXTPMarkupVisual::GetVisualParent
CXTPMarkupVisual * GetVisualParent() const
Gets the Visual tree parent of the Visual object.
CXTPMarkupVisual::~CXTPMarkupVisual
virtual ~CXTPMarkupVisual()
Destroys a CXTPMarkupVisual object, handles cleanup and deallocation.
CXTPMarkupVisual::m_rcBoundRect
CRect m_rcBoundRect
Bounding rectangle of the element.
Definition XTPMarkupInputElement.h:496
CXTPMarkupVisual::GetLogicalChildrenCount
virtual int GetLogicalChildrenCount() const
Retrieves the number of logical child elements of this object.
CXTPMarkupVisual::GetLayoutClip
virtual BOOL GetLayoutClip(CRect &rc) const
Retrieves an alternative clipping geometry that represents the region that would be clipped if child ...
CXTPMarkupVisual::m_rcPrevUpdateRect
CRect m_rcPrevUpdateRect
Previous update rectangle.
Definition XTPMarkupInputElement.h:498
CXTPMarkupVisual::GetUpdateRect
CRect GetUpdateRect() const
Computes the update rectangle.
CXTPMarkupVisual::InputHitTestOverride
virtual CXTPMarkupInputElement * InputHitTestOverride(CPoint point) const
Override this method in the derived class to provide visual hit testing of a child object.
CXTPMarkupVisual::m_rcUpdateRect
CRect m_rcUpdateRect
Update rectangle.
Definition XTPMarkupInputElement.h:497
CXTPMarkupVisual::GetAbsoluteVisualOffset
POINT GetAbsoluteVisualOffset() const
Gets the absolute element visual offset.
CXTPMarkupVisual::GetRenderSize
CSize GetRenderSize() const
Gets the final render size of this element.
Definition XTPMarkupInputElement.h:537
CXTPMarkupVisual::Render
void Render(CXTPMarkupDrawingContext *drawingContext)
Call this method to draw a Visual object inside a drawing context.
CXTPMarkupVisual::GetLogicalChild
virtual CXTPMarkupObject * GetLogicalChild(int nIndex) const
Retrieves the logical child element located at a specified index within the parent collection.
CXTPMarkupVisual::m_szRenderSize
CSize m_szRenderSize
The rendered size for this element.
Definition XTPMarkupInputElement.h:495
CXTPMarkupVisual::CXTPMarkupVisual
CXTPMarkupVisual()
Provides the base initialization for objects derived from the CXTPMarkupVisual class.
CXTPMarkupVisual::RenderClipped
virtual void RenderClipped(CXTPMarkupDrawingContext *drawingContext)
Called by the framework when an element is clipped and no rendering will occur.
CXTPMarkupVisual::GetBoundRect
CRect GetBoundRect() const
Retrieves the bounding rectangle of the element.
Definition XTPMarkupInputElement.h:542
CXTPMarkupVisual::GetOpacity
virtual double GetOpacity() const
Gets either the default or explicitly set opacity factor value.
CXTPMarkupVisual::GetVisualChild
virtual CXTPMarkupVisual * GetVisualChild(int nIndex) const
Retrieves the child Visual object located at a specified index within the parent VisualCollection.
CXTPMarkupVisual::OnRender
virtual void OnRender(CXTPMarkupDrawingContext *drawingContext)
When overridden in a derived class, participates in rendering operations that are directed by the lay...
Definition XTPMarkupInputElement.h:515
CXTPMarkupVisual::RestoreRenderTransform
virtual void RestoreRenderTransform(CXTPMarkupDrawingContext *pContext, TransformationMatrices &matrices)
Restores a previously applied render transformation.
Definition XTPMarkupInputElement.h:530
CXTPMarkupVisual::OnRenderFocusVisual
virtual void OnRenderFocusVisual(CXTPMarkupDrawingContext *drawingContext)
This method is called to render the focus rectangle of a focused object.
Definition XTPMarkupInputElement.h:519
CXTPMarkupVisual::ApplyRenderTransform
virtual TransformationMatrices ApplyRenderTransform(CXTPMarkupDrawingContext *pContext)
Applies render transformation if necessary.
Definition XTPMarkupInputElement.h:524
CXTPMarkupVisual::m_ptVisualOffset
CPoint m_ptVisualOffset
The offset value of the visual object.
Definition XTPMarkupInputElement.h:494
CXTPMarkupVisual::GetVisualChildrenCount
virtual int GetVisualChildrenCount() const
Gets the number of child elements for the Visual.
CXTPMarkupVisual::TransformationMatrices
A structure that optionally describes the previous and the new transformation matrices.
Definition XTPMarkupInputElement.h:361
CXTPMarkupVisual::TransformationMatrices::TransformationMatrices
TransformationMatrices()
Constructs an empty object.
Definition XTPMarkupInputElement.h:502
CXTPMarkupVisual::TransformationMatrices::pNewMatrix
CXTPMarkupTransformationMatrix * pNewMatrix
A pointer to a new tranformation matrix.
Definition XTPMarkupInputElement.h:379
CXTPMarkupVisual::TransformationMatrices::pOldMatrix
CXTPMarkupTransformationMatrix * pOldMatrix
A pointer to an old tranformation matrix.
Definition XTPMarkupInputElement.h:377


Toolkit Pro: XTPSkinObjectProgress.h Source File

  • Source
  • SkinFramework
XTPSkinObjectProgress.h
Go to the documentation of this file.
1
23#if !defined(__XTPSKINOBJECTPROGRESS_H__)
24# define __XTPSKINOBJECTPROGRESS_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPSkinObjectProgress : public CXTPSkinObjectFrame
39{
41 DECLARE_DYNCREATE(CXTPSkinObjectProgress)
43public:
48 CXTPSkinObjectProgress();
49
54 virtual ~CXTPSkinObjectProgress();
55
56protected:
58 void OnSkinChanged(BOOL bPrevState, BOOL bNewState);
59 void OnDraw(CDC* pDC);
60
61 void DoStep(int nStep);
62
63protected:
64 DECLARE_MESSAGE_MAP()
65
66 //{{AFX_VIRTUAL(CXTPSkinObjectProgress)
67 //}}AFX_VIRTUAL
68
69 //{{AFX_MSG(CXTPSkinObjectProgress)
70 afx_msg BOOL OnEraseBkgnd(CDC* pDC);
71 afx_msg void OnPaint();
72 afx_msg int OnCreate(LPCREATESTRUCT lpCreateStruct);
73 afx_msg LRESULT OnPrintClient(WPARAM wParam, LPARAM lParam);
74 afx_msg LRESULT OnStartMarquee(WPARAM wParam, LPARAM lParam);
75 afx_msg void OnTimer(UINT_PTR nIDEvent);
76 afx_msg LRESULT OnStepIt(WPARAM wParam, LPARAM lParam);
77 afx_msg LRESULT OnSetPos(WPARAM /*wParam*/, LPARAM /*lParam*/);
78 //}}AFX_MSG
79
80protected:
81 int m_nMarqueePos;
82 int m_nMarqueeDelay;
84};
85
86# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
88#endif // !defined(__XTPSKINOBJECTPROGRESS_H__)
XTPDisableNoisyWarnings.h
CXTPSkinObjectFrame
CXTPSkinObjectFrame is a CXTPSkinObject derived class.
Definition XTPSkinObjectFrame.h:75
CXTPSkinObjectFrame::OnSkinChanged
virtual void OnSkinChanged(BOOL bPrevState, BOOL bNewState)
This method is called when the skin is changed.
CXTPSkinObjectProgress
CXTPSkinObjectProgress is a CXTPSkinObjectFrame derived class.
Definition XTPSkinObjectProgress.h:39
CXTPSkinObjectProgress::~CXTPSkinObjectProgress
virtual ~CXTPSkinObjectProgress()
Destroys a CXTPSkinObjectProgress object, handles cleanup and deallocation.
CXTPSkinObjectProgress::CXTPSkinObjectProgress
CXTPSkinObjectProgress()
Constructs a CXTPSkinObjectProgress object.


Toolkit Pro: Member List

  • CXTPTabPaintManagerColorSet
  • COLORSET_TAB_STATEBUTTON
CXTPTabPaintManagerColorSet::COLORSET_TAB_STATEBUTTON Member List

This is the complete list of members for CXTPTabPaintManagerColorSet::COLORSET_TAB_STATEBUTTON, including all inherited members.

clrBorder | CXTPTabPaintManagerColorSet::COLORSET_TAB_STATEBUTTON
clrFace | CXTPTabPaintManagerColorSet::COLORSET_TAB_STATEBUTTON


Toolkit Pro: Member List

CXTPChart3dPieSeriesLabelsView Member List

This is the complete list of members for CXTPChart3dPieSeriesLabelsView, including all inherited members.

AddChildView(CXTPChartElementView *pChildView) | CXTPChartElementView |
CreateDeviceCommand(CXTPChartDeviceContext *pDC) | CXTPChart3dPieSeriesLabelsView | virtual
CXTPChart3dPieSeriesLabelsView(CXTPChartElementView *pParentView) | CXTPChart3dPieSeriesLabelsView |
CXTPChartElementView(CXTPChartElementView *pParentView) | CXTPChartElementView |
CXTPChartElementView(CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartElementView |
CXTPChartElementView(CXTPChartContainer *pContainer) | CXTPChartElementView |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartPieSeriesLabelsViewBase(CXTPChartElementView *pParentView) | CXTPChartPieSeriesLabelsViewBase | protected
GetAt(int nIndex) const | CXTPChartElementView |
GetBounds() const | CXTPChartElementView |
GetBounds(BOOL bIncludingChildren) const | CXTPChartElementView |
GetChildren() | CXTPChartElementView |
GetCount() const | CXTPChartElementView |
GetParentView() const | CXTPChartElementView |
Is3D() const | CXTPChartObject |
m_arrChildren | CXTPChartElementView | protected
m_pContainer | CXTPChartElementView | protected
m_pParentView | CXTPChartElementView | protected
m_rcBounds | CXTPChartElementView | protected
ResolveOverlapping() | CXTPChart3dPieSeriesLabelsView | virtual
~CXTPChartElementView() | CXTPChartElementView | protectedvirtual


Toolkit Pro: Member List

CXTPSvgPreviewProvider Member List

This is the complete list of members for CXTPSvgPreviewProvider, including all inherited members.

BindHost(IXTPPreviewHost &host) | CXTPPreviewProviderBase | protectedvirtual
CXTPPreviewProviderBase() | CXTPPreviewProviderBase | protected
GetHost() const | CXTPPreviewProviderBase | protected
~IXTPPreviewProvider() | IXTPPreviewProvider | inlinevirtual


Toolkit Pro: Member List

CXTPCalendarResource Member List

This is the complete list of members for CXTPCalendarResource, including all inherited members.

CXTPCalendarResource(CXTPCalendarControl *pCalendarCtrl=NULL) | CXTPCalendarResource |
CXTPCmdTarget() | CXTPCmdTarget |
ExistsScheduleID(UINT uScheduleID, BOOL bReturnTrueIfSchedulesSetEmpty=TRUE) | CXTPCalendarResource | virtual
FilterEventsByScheduleID(CXTPCalendarEvents *pEvents) | CXTPCalendarResource |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetColor() const | CXTPCalendarResource | virtual
GetDataProvider() const | CXTPCalendarResource |
GetName() const | CXTPCalendarResource | virtual
GetSchedules() | CXTPCalendarResource | virtual
IsSchedulesSetEmpty() const | CXTPCalendarResource | virtual
m_arScheduleIDs | CXTPCalendarResource | protected
m_bCloseDataProviderWhenDestroy | CXTPCalendarResource | protected
m_Color | CXTPCalendarResource | protected
m_pCalendarCtrl | CXTPCalendarResource | protected
m_pDataProvider | CXTPCalendarResource | protected
m_strResourceName | CXTPCalendarResource | protected
RetrieveDayEvents(COleDateTime dtDay) | CXTPCalendarResource | virtual
SetColor(COLORREF color) | CXTPCalendarResource | virtual
SetDataProvider(CXTPCalendarData *pDataProvider, BOOL bCloseDataProviderWhenDestroy=FALSE) | CXTPCalendarResource |
SetName(LPCTSTR pcszResourceName) | CXTPCalendarResource | virtual
~CXTPCalendarResource() | CXTPCalendarResource | virtual


Toolkit Pro: Member List

CXTPRibbonThemeOffice2007System Member List

This is the complete list of members for CXTPRibbonThemeOffice2007System, including all inherited members.

CreateTabPaintManager() | CXTPRibbonPaintManager | protectedvirtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPRibbonMarkupTheme(CXTPPaintManager *pPaintManager) | CXTPRibbonMarkupTheme |
CXTPRibbonPaintManager(CXTPPaintManager *pPaintManager) | CXTPRibbonPaintManager |
CXTPRibbonThemeOffice2007System(CXTPPaintManager *pPaintManager) | CXTPRibbonThemeOffice2007System |
DrawControlGroupOption(CDC *pDC, CXTPControl *pControlGroupOption, BOOL bDraw) | CXTPRibbonMarkupTheme | virtual
DrawControlGroupPopup(CDC *pDC, CXTPControlPopup *pControlGroupPopup, BOOL bDraw) | CXTPRibbonMarkupTheme | virtual
DrawDwmCaptionText(CDC *pDC, CRect rcCaptionText, CString strText, CWnd *pSite, BOOL bActive) | CXTPRibbonPaintManager | protected
DrawGroup(CDC *pDC, CXTPRibbonGroup *pGroup) | CXTPRibbonMarkupTheme | virtual
DrawQuickAccessControl(CDC *pDC, CXTPRibbonBar *pRibbon, CXTPControl *pControl) | CXTPRibbonPaintManager | virtual
DrawRibbonApplicationIcon(CDC *pDC, CXTPRibbonBar *pRibbonBar, CRect rc, HICON hIcon) | CXTPRibbonPaintManager | protected
DrawRibbonFrameCaption(CDC *pDC, CXTPRibbonBar *pRibbonBar, BOOL bActive) | CXTPRibbonMarkupTheme | virtual
DrawRibbonFrameCaptionBar(CDC *pDC, CXTPRibbonBar *pRibbonBar, BOOL bActive) | CXTPRibbonMarkupTheme | virtual
DrawRibbonFrameContextHeaders(CDC *pDC, CXTPRibbonBar *pRibbonBar, CXTPRibbonTabContextHeaders *pContextHeaders) | CXTPRibbonMarkupTheme | virtual
DrawRibbonFramePart(CDC *pDC, CXTPRibbonBar *pRibbonBar) | CXTPRibbonPaintManager | virtual
DrawRibbonFrameSystemButton(CDC *pDC, CXTPRibbonControlSystemButton *pControl, CRect rc) | CXTPRibbonMarkupTheme | virtual
DrawRibbonGroupControlEntry(CDC *pDC, CXTPControl *pButton) | CXTPRibbonMarkupTheme | virtual
DrawRibbonGroupPopupToolBar(CDC *pDC, CXTPRibbonGroup *pRibbonGroup) | CXTPRibbonMarkupTheme | virtual
DrawRibbonQuickAccessButton(CDC *pDC, CXTPControlPopup *pControl) | CXTPRibbonThemeOffice2007System | virtual
DrawRibbonQuickAccessControls(CDC *pDC, CXTPRibbonBar *pRibbonBar) | CXTPRibbonThemeOffice2007System | virtual
DrawRibbonQuickAccessMoreButton(CDC *pDC, CXTPControlPopup *pControl) | CXTPRibbonMarkupTheme | virtual
DrawRibbonScrollButton(CDC *pDC, CXTPControl *pControl, BOOL bScrollLeft) | CXTPRibbonMarkupTheme | virtual
DrawRibbonTab(CDC *pDC, CXTPRibbonTab *pItem) | CXTPRibbonMarkupTheme | virtual
DrawSystemPopupBarButton(CDC *pDC, CXTPControl *pButton) | CXTPRibbonMarkupTheme | virtual
FillGroupPopupToolBar(CDC *pDC, CXTPRibbonGroup *pGroup, CXTPCommandBar *pCommandBar) | CXTPRibbonMarkupTheme | virtual
FillGroupRect(CDC *pDC, CXTPRibbonTab *pActiveTab, CRect rcGroups) | CXTPRibbonMarkupTheme | virtual
FillMorePopupToolBarEntry(CDC *pDC, CXTPCommandBar *pBar) | CXTPRibbonMarkupTheme | virtual
FillRibbonBar(CDC *pDC, CXTPRibbonBar *pRibbonBar) | CXTPRibbonMarkupTheme | virtual
FillRibbonTabControl(CDC *pDC, CXTPRibbonBar *pRibbonBar, CRect rcControl) | CXTPRibbonMarkupTheme | virtual
FillSystemPopupBarEntry(CDC *pDC, CXTPPopupBar *pBar) | CXTPRibbonMarkupTheme | virtual
FillTabPopupToolBar(CDC *pDC, CXTPPopupToolBar *pPopupToolBar) | CXTPRibbonPaintManager | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetControlGroupOptionSize() const | CXTPRibbonMarkupTheme | virtual
GetEditHeight() const | CXTPRibbonPaintManager |
GetFontHeight() const | CXTPRibbonPaintManager |
GetFramePaintManager() const | CXTPRibbonPaintManager |
GetGroupCaptionHeight() const | CXTPRibbonPaintManager |
GetImages() const | CXTPRibbonPaintManager |
GetRibbonCaptionHeight(const CXTPRibbonBar *pRibbonBar) const | CXTPRibbonThemeOffice2007System | virtual
GetTabPaintManager() const | CXTPRibbonPaintManager |
LoadImage(LPCTSTR lpszFileName) | CXTPRibbonPaintManager |
LoadParts(BOOL bReload=FALSE) | CXTPRibbonThemeOffice2007System | virtual
CXTPRibbonMarkupTheme::LoadParts(HZIP hZip, CXTPMarkupContext *pMarkupContext=NULL) | CXTPRibbonMarkupTheme |
m_bFlatFrame | CXTPRibbonPaintManager |
m_bHotTrackingGroups | CXTPRibbonPaintManager |
m_clrBackstageSysButtonBack2013Highlighted | CXTPRibbonMarkupTheme | protected
m_clrBackstageSysButtonBack2013Normal | CXTPRibbonMarkupTheme | protected
m_clrFileButtonText | CXTPRibbonPaintManager | protected
m_clrMinimizedFrameEdgeHighLight | CXTPRibbonPaintManager | protected
m_clrMinimizedFrameEdgeShadow | CXTPRibbonPaintManager | protected
m_clrRecentFileListEdgeHighLight | CXTPRibbonPaintManager |
m_clrRecentFileListEdgeShadow | CXTPRibbonPaintManager |
m_clrRibbonBorder | CXTPRibbonPaintManager | protected
m_clrRibbonFace | CXTPRibbonPaintManager | protected
m_clrRibbonGroupCaptionText | CXTPRibbonPaintManager | protected
m_clrRibbonInactiveFace | CXTPRibbonPaintManager | protected
m_fontGroupCaption | CXTPRibbonPaintManager |
m_nGroupCaptionHeight | CXTPRibbonPaintManager |
m_nGroupSpacing | CXTPRibbonPaintManager |
m_nTabsHeight | CXTPRibbonPaintManager |
m_pMarkupContext | CXTPRibbonMarkupTheme | protected
m_pPaintManager | CXTPRibbonPaintManager | protected
m_pTabPaintManager | CXTPRibbonPaintManager | protected
m_rcFileButtonMargin | CXTPRibbonPaintManager | protected
m_strHighlightedPrefix | CXTPRibbonMarkupTheme | protected
m_strNormalPrefix | CXTPRibbonMarkupTheme | protected
RefreshMetrics() | CXTPRibbonThemeOffice2007System | virtual
RenderMarkup(CDC *pDC, CRect rc, LPCTSTR lpszText) | CXTPRibbonMarkupTheme |
RenderMarkup(CDC *pDC, CRect rc, XTPRibbonThemePart part) | CXTPRibbonMarkupTheme |
SetFontHeight(int nFontHeight) | CXTPRibbonPaintManager |
~CXTPRibbonMarkupTheme() | CXTPRibbonMarkupTheme | virtual
~CXTPRibbonPaintManager() | CXTPRibbonPaintManager | virtual
~CXTPRibbonThemeOffice2007System() | CXTPRibbonThemeOffice2007System | virtual


Toolkit Pro: XTPMarkupPathGeometryFigures.h Source File

  • Source
  • Markup
  • Shapes
XTPMarkupPathGeometryFigures.h
Go to the documentation of this file.
1
23#if !defined(__XTPMARKUPPATHGEOMETRYFIGURES_H__)
24# define __XTPMARKUPPATHGEOMETRYFIGURES_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPMarkupObject;
34class CXTPMarkupBuilder;
35
36class _XTP_EXT_CLASS CXTPMarkupPathGeometryFigures : public CXTPMarkupObject
37{
39 DECLARE_MARKUPCLASS(CXTPMarkupPathGeometryFigures);
41protected:
42 CXTPMarkupPathGeometryFigures();
43 ~CXTPMarkupPathGeometryFigures();
44
45protected:
46 CXTPMarkupObject* ConvertFrom(CXTPMarkupBuilder* pBuilder, CXTPMarkupObject* pObject) const;
47};
48
49# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
51#endif // !defined(__XTPMARKUPPATHGEOMETRYFIGURES_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h


Toolkit Pro: Member List

IXTPGaugeClientSite Member List

This is the complete list of members for IXTPGaugeClientSite, including all inherited members.

OnGaugeUpdated(CXTPGaugeBaseType &type)=0 IXTPGaugeClientSite pure virtual


Toolkit Pro: XTPChartGanttSeriesStyle.h Source File

  • Source
  • Chart
  • Styles
  • Range
XTPChartGanttSeriesStyle.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTGANTTSERIESSTYLE_H__)
24# define __XTPCHARTGANTTSERIESSTYLE_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartSeriesView;
34
46class _XTP_EXT_CLASS CXTPChartGanttSeriesStyle : public CXTPChartRangeBarSeriesStyle
47{
49 DECLARE_SERIAL(CXTPChartGanttSeriesStyle)
51public:
56 CXTPChartGanttSeriesStyle();
57
62 virtual ~CXTPChartGanttSeriesStyle();
63
64public:
65protected:
78 virtual CXTPChartSeriesView* CreateView(CXTPChartSeries* pSeries,
79 CXTPChartDiagramView* pDiagramView);
80
81public:
82 void DoPropExchange(CXTPPropExchange* pPX);
83
84protected:
85# ifdef _XTP_ACTIVEX
86public:
88 DECLARE_DISPATCH_MAP()
89 DECLARE_INTERFACE_MAP()
90 DECLARE_OLETYPELIB_EX(CXTPChartGanttSeriesStyle);
91 DECLARE_OLECREATE_EX(CXTPChartGanttSeriesStyle)
93# endif
94};
100class _XTP_EXT_CLASS CXTPChartGanttSeriesView : public CXTPChartRangeBarSeriesView
101{
102public:
110 CXTPChartGanttSeriesView(CXTPChartSeries* pSeries, CXTPChartDiagramView* pDiagramView);
111
112protected:
124 CXTPChartSeriesPointView* CreateSeriesPointView(CXTPChartDeviceContext* pDC,
125 CXTPChartSeriesPoint* pPoint,
126 CXTPChartElementView* pParentView);
127
128protected:
129 friend class CXTPChartGanttSeriesPointView;
130};
131
137class _XTP_EXT_CLASS CXTPChartGanttSeriesPointView : public CXTPChartRangeBarSeriesPointView
138{
139public:
147 CXTPChartGanttSeriesPointView(CXTPChartSeriesPoint* pPoint, CXTPChartElementView* pParentView);
148};
150# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
151#endif //#if !defined(__XTPCHARTGANTTSERIESSTYLE_H__)
pPoint
const CPoint * pPoint
return 0 or xtpCalendarHitTestDayExpandButton
Definition XTPCalendarThemeOffice2007.h:150
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartDiagramView
This class represents the view of a chart diagram, which is a kind of CXTPChartElementView.
Definition XTPChartDiagramView.h:49
CXTPChartElementView
This class represents the view of a chart element.
Definition XTPChartElementView.h:47
CXTPChartGanttSeriesPointView
This class represents the view of a Gantt series point, which is a kind of CXTPChartPointSeriesPointV...
Definition XTPChartGanttSeriesStyle.h:138
CXTPChartGanttSeriesPointView::CXTPChartGanttSeriesPointView
CXTPChartGanttSeriesPointView(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Constructs a CXTPChartGanttSeriesPointView object.
CXTPChartGanttSeriesStyle
This class represents a Gantt series style for the chart, which is a kind of CXTPChartBarSeriesStyle.
Definition XTPChartGanttSeriesStyle.h:47
CXTPChartGanttSeriesStyle::DoPropExchange
void DoPropExchange(CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
CXTPChartGanttSeriesStyle::CXTPChartGanttSeriesStyle
CXTPChartGanttSeriesStyle()
Constructs a CXTPChartGanttSeriesStyle object.
CXTPChartGanttSeriesStyle::CreateView
virtual CXTPChartSeriesView * CreateView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Call this function to create the view of the Gantt series.
CXTPChartGanttSeriesStyle::~CXTPChartGanttSeriesStyle
virtual ~CXTPChartGanttSeriesStyle()
Destroys a CXTPChartGanttSeriesStyle object, handles cleanup.
CXTPChartGanttSeriesView
This class represents the view of a Gantt series, which is a kind of CXTPChartSeriesView.
Definition XTPChartGanttSeriesStyle.h:101
CXTPChartGanttSeriesView::CXTPChartGanttSeriesView
CXTPChartGanttSeriesView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Constructs a CXTPChartGanttSeriesView object.
CXTPChartGanttSeriesView::CreateSeriesPointView
CXTPChartSeriesPointView * CreateSeriesPointView(CXTPChartDeviceContext *pDC, CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Call this function to create a view of the Gantt series point.
CXTPChartRangeBarSeriesPointView
This class represents the view of a RangeBar series point, which is a kind of CXTPChartPointSeriesPoi...
Definition XTPChartRangeBarSeriesView.h:78
CXTPChartRangeBarSeriesStyle
This class represents a RangeBar series style for the chart, which is a kind of CXTPChartBarSeriesSty...
Definition XTPChartRangeBarSeriesStyle.h:47
CXTPChartRangeBarSeriesView
This class represents the view of a RangeBar series, which is a kind of CXTPChartSeriesView.
Definition XTPChartRangeBarSeriesView.h:41
CXTPChartSeries
This class represents a series in the chart, which is a kind of CXTPChartElement.
Definition XTPChartSeries.h:50
CXTPChartSeriesPoint
CXTPChartSeriesPoint is a kind of CXTPChartElement.
Definition XTPChartSeriesPoint.h:43
CXTPChartSeriesPointView
Represents chart series point view.
Definition XTPChartSeriesPointView.h:48
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72


Toolkit Pro: XTPWinThread.h Source File

  • Source
  • Common
  • Base
XTPWinThread.h
Go to the documentation of this file.
1
23#if !defined(__XTPWINTHREAD_H__)
24# define __XTPWINTHREAD_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPComInitializer;
34
41class _XTP_EXT_CLASS CXTPWinThread : public CWinThread
42{
43 DECLARE_DYNAMIC(CXTPWinThread);
44
45public:
59 CXTPWinThread(int xtpComInit = xtpComInitAppDefault);
60
65 virtual ~CXTPWinThread();
66
67private:
68 CXTPComInitializer* m_pComInit;
69};
70
72
73//{{AFX_INSERT_LOCATION}}
74// Microsoft Visual C++ will insert additional declarations immediately before the previous line.
75
76# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
78#endif // !defined(__XTPWINTHREAD_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
xtpComInitAppDefault
@ xtpComInitAppDefault
If passed to CXTPWinApp constructor or to XTPInitialize then uses xtpComInitAfxOle,...
Definition XTPSystemHelpers.h:1954
CXTPComInitializer
Initializes COM and increments and holds COM initialization reference counter for the thread where co...
Definition XTPSystemHelpers.h:2021
CXTPWinThread
All XTP threads should derive from CXTPWinThread instead of CWinThread in order to ensure compatibili...
Definition XTPWinThread.h:42
CXTPWinThread::CXTPWinThread
CXTPWinThread(int xtpComInit=xtpComInitAppDefault)
Default constructor.
CXTPWinThread::~CXTPWinThread
virtual ~CXTPWinThread()
Default destructor, handles cleanup / deallocation.


Toolkit Pro: Member List

CXTPChartFastLineSeriesStyle Member List

This is the complete list of members for CXTPChartFastLineSeriesStyle, including all inherited members.

ApplyTo(CXTPChartDeviceCommand *pCommand) | CXTPChartSeriesStyle | virtual
CorrectAxisSideMargins(CXTPChartAxis *pAxis, double nMinValue, double nMaxValue, double &nCorrection) | CXTPChartSeriesStyle | virtual
CreateDiagram() | CXTPChartDiagram2DSeriesStyle | virtual
CreateView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView) | CXTPChartFastLineSeriesStyle | protectedvirtual
CXTPChartDiagram2DSeriesStyle() | CXTPChartDiagram2DSeriesStyle |
CXTPChartElement() | CXTPChartElement |
CXTPChartFastLineSeriesStyle() | CXTPChartFastLineSeriesStyle |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartSeriesStyle() | CXTPChartSeriesStyle |
DoPropExchange(CXTPPropExchange *pPX) | CXTPChartFastLineSeriesStyle | protectedvirtual
Enable3dEdgeSmoothing(BOOL bEnable=TRUE) | CXTPChartSeriesStyle | virtual
Get3dRotation() const | CXTPChartSeriesStyle | virtual
GetAntialiasing() const | CXTPChartFastLineSeriesStyle |
GetAppearance() const | CXTPChartElement |
GetColor() const | CXTPChartSeriesStyle | virtual
GetContent() const | CXTPChartElement |
GetErrorBar() const | CXTPChartSeriesStyle | virtual
GetLabel() const | CXTPChartSeriesStyle | virtual
GetLineStyle() const | CXTPChartFastLineSeriesStyle |
GetOwner() const | CXTPChartElement |
GetSeriesPointValueIndex() const | CXTPChartSeriesStyle | virtual
GetStyleAppearance() const | CXTPChartSeriesStyle | virtual
GetTransparency() const | CXTPChartSeriesStyle | virtual
Is3D() const | CXTPChartObject |
Is3dEdgeSmoothingEnabled() const | CXTPChartSeriesStyle | virtual
IsColorEach() const | CXTPChartSeriesStyle | virtual
IsStyleDiagram(CXTPChartDiagram *pDiagram) const | CXTPChartDiagram2DSeriesStyle | virtual
m_bColorEach | CXTPChartSeriesStyle | protected
m_bSmooth3dEdges | CXTPChartSeriesStyle | protected
m_clrColor | CXTPChartSeriesStyle | protected
m_nAxisIndexX | CXTPChartDiagram2DSeriesStyle | protected
m_nAxisIndexY | CXTPChartDiagram2DSeriesStyle | protected
m_nTransparency | CXTPChartSeriesStyle | protected
m_pErrorBar | CXTPChartSeriesStyle | protected
m_pLabel | CXTPChartSeriesStyle | protected
m_pLineStyle | CXTPChartFastLineSeriesStyle | protected
m_Rotation3d | CXTPChartSeriesStyle | protected
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartElement | virtual
Release() | CXTPChartElement | virtual
Set3dRotation(const CXTPChart3dRotation &rotation) | CXTPChartSeriesStyle | virtual
Set3dRotation(double dYaw, double dPitch, double dRoll) | CXTPChartSeriesStyle | virtual
SetAntialiasing(BOOL bEnable=TRUE) | CXTPChartFastLineSeriesStyle |
SetColor(CXTPChartColor clr) | CXTPChartSeriesStyle | virtual
SetColorEach(BOOL bColorEach) | CXTPChartSeriesStyle | virtual
SetErrorBar(CXTPChartErrorBar *pErrorBar) | CXTPChartSeriesStyle | virtual
SetLabel(CXTPChartSeriesLabel *pLabel) | CXTPChartSeriesStyle | virtual
SetTransparency(int nTransparency) | CXTPChartSeriesStyle | virtual
~CXTPChartDiagram2DSeriesStyle() | CXTPChartDiagram2DSeriesStyle | virtual
~CXTPChartElement() | CXTPChartElement | virtual
~CXTPChartFastLineSeriesStyle() | CXTPChartFastLineSeriesStyle | virtual
~CXTPChartSeriesStyle() | CXTPChartSeriesStyle | virtual


Toolkit Pro: XTPChartCircleDeviceCommand.h Source File

  • Source
  • Chart
  • Drawing
XTPChartCircleDeviceCommand.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTCIRCLEDEVICECOMMAND_H__)
24# define __XTPCHARTCIRCLEDEVICECOMMAND_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
37class _XTP_EXT_CLASS CXTPChartCircleDeviceCommand : public CXTPChartDeviceCommand
38{
39protected:
47 CXTPChartCircleDeviceCommand(const CXTPChartPointF& center, double radius);
48
59 CXTPChartElement* HitTest(CPoint point, CXTPChartElement* pParent) const;
60
61protected:
62 CXTPChartPointF m_center;
63 double m_radius;
64};
65
72class _XTP_EXT_CLASS CXTPChartBoundedCircleDeviceCommand : public CXTPChartDeviceCommand
73{
74protected:
84 CXTPChartBoundedCircleDeviceCommand(const CXTPChartPointF& center, double radius,
85 const CXTPChartColor& color, int thickness);
86
87protected:
88 CXTPChartColor m_color;
89 int m_thickness;
90 CXTPChartPointF m_center;
91 double m_radius;
92};
94# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
95#endif //#if !defined(__XTPCHARTCIRCLEDEVICECOMMAND_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartBoundedCircleDeviceCommand
This class represents a bounded circle device command, which is a kind of CXTPChartDeviceCommand.
Definition XTPChartCircleDeviceCommand.h:73
CXTPChartBoundedCircleDeviceCommand::m_radius
double m_radius
The radius of the circle.
Definition XTPChartCircleDeviceCommand.h:91
CXTPChartBoundedCircleDeviceCommand::CXTPChartBoundedCircleDeviceCommand
CXTPChartBoundedCircleDeviceCommand(const CXTPChartPointF &center, double radius, const CXTPChartColor &color, int thickness)
Constructs a CXTPChartBoundedCircleDeviceCommand object.
CXTPChartBoundedCircleDeviceCommand::m_color
CXTPChartColor m_color
The color of the cirular boundary.
Definition XTPChartCircleDeviceCommand.h:88
CXTPChartBoundedCircleDeviceCommand::m_thickness
int m_thickness
The thickness of the circular boundary.
Definition XTPChartCircleDeviceCommand.h:89
CXTPChartBoundedCircleDeviceCommand::m_center
CXTPChartPointF m_center
The center point of the circle.
Definition XTPChartCircleDeviceCommand.h:90
CXTPChartCircleDeviceCommand
This class is the base class for all circle device commands.
Definition XTPChartCircleDeviceCommand.h:38
CXTPChartCircleDeviceCommand::m_radius
double m_radius
The radius of the circle.
Definition XTPChartCircleDeviceCommand.h:63
CXTPChartCircleDeviceCommand::HitTest
CXTPChartElement * HitTest(CPoint point, CXTPChartElement *pParent) const
Performs recursive hit testing of the element at the specified point.
CXTPChartCircleDeviceCommand::CXTPChartCircleDeviceCommand
CXTPChartCircleDeviceCommand(const CXTPChartPointF &center, double radius)
Constructs a CXTPChartCircleDeviceCommand object.
CXTPChartCircleDeviceCommand::m_center
CXTPChartPointF m_center
The center of the circle.
Definition XTPChartCircleDeviceCommand.h:62
CXTPChartColor
This class abstracts a color entity.
Definition XTPChartTypes.h:51
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPChartElement
This class abstracts a chart element, this class acts as a base class for all chart elements.
Definition XTPChartElement.h:131
CXTPPoint2T< float >


Toolkit Pro: XTPCommandBarsVisualStudio2022Theme.h Source File

  • Source
  • CommandBars
  • Themes
XTPCommandBarsVisualStudio2022Theme.h
Go to the documentation of this file.
1
23#if !defined(__XTPCOMMANDBARSVISUALSTUDIO2022THEME_H__)
24# define __XTPCOMMANDBARSVISUALSTUDIO2022THEME_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
40class _XTP_EXT_CLASS CXTPCommandBarsVisualStudio2022Theme : public CXTPCommandBarsOffice2013Theme
41{
43 DECLARE_DYNAMIC(CXTPCommandBarsVisualStudio2022Theme)
45public:
50 CXTPCommandBarsVisualStudio2022Theme();
51
57 virtual ~CXTPCommandBarsVisualStudio2022Theme();
58
66 virtual void SetStateColor(COLORREF clrState = COLORREF_NULL);
67
75 virtual COLORREF GetStateColor() const;
76
77protected:
86 virtual void DrawSplitButtonFrame(CDC* pDC, CXTPControl* pButton, CRect rc);
87
101 virtual void DrawRectangle(CDC* pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled,
102 BOOL bChecked, BOOL bPopuped, XTPBarType barType,
103 XTPBarPosition barPosition);
104
119 virtual void DrawRectangle(CDC* pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled,
120 BOOL bChecked, BOOL bPopuped, XTPBarType barType,
121 XTPBarPosition barPosition, int nID);
122
131 virtual BOOL DrawRectangle(CDC* pDC, CXTPControl* pButton);
132
139 virtual COLORREF GetControlTextColor(CXTPControl* pButton);
140
152 virtual void DrawGalleryItemBack(CDC* pDC, CRect rcItem, BOOL bEnabled, BOOL bSelected,
153 BOOL bPressed, BOOL bChecked, XTPBarType barType);
154
164 virtual void DrawCheckRect(CDC* pDC, CRect rc, COLORREF clrFore, COLORREF clrBack);
165
175 virtual CSize DrawCommandBarGripper(CDC* pDC, CXTPCommandBar* pBar, BOOL bDraw = TRUE);
176
186 virtual CSize DrawControlComboBox(CDC* pDC, CXTPControlComboBox* pComboBox, BOOL bDraw);
187};
188
206_XTP_EXT_CLASS BOOL AFX_CDECL XTPSetVS2022StateColor(CXTPCommandBars* pCommandBars,
207 COLORREF clrState = COLORREF_NULL);
208
210# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
211#endif // !defined(__XTPCOMMANDBARSVISUALSTUDIO2022THEME_H__)
XTPBarType
XTPBarType
Type of the command bar.
Definition XTPCommandBarsDefines.h:77
XTPBarPosition
XTPBarPosition
Position of the command bar.
Definition XTPCommandBarsDefines.h:52
XTPSetVS2022StateColor
_XTP_EXT_CLASS BOOL AFX_CDECL XTPSetVS2022StateColor(CXTPCommandBars *pCommandBars, COLORREF clrState=COLORREF_NULL)
Call XTPSetVS2022StateColor to set the border and status bar colors for this theme to indicate state ...
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCommandBar
CXTPCommandBar is a CWnd derived class.
Definition XTPCommandBar.h:66
CXTPCommandBars
CXTPCommandBars is a standalone class.
Definition XTPCommandBars.h:165
CXTPCommandBarsOffice2013Theme
The CXTPCommandBarsOffice2013Theme class is used to enable an Office 2013 style theme for Command Bar...
Definition XTPCommandBarsOffice2013Theme.h:63
CXTPCommandBarsVisualStudio2022Theme
The CXTPCommandBarsVisualStudio2022Theme class is used to enable a Visual Studio 2022 style theme for...
Definition XTPCommandBarsVisualStudio2022Theme.h:41
CXTPCommandBarsVisualStudio2022Theme::~CXTPCommandBarsVisualStudio2022Theme
virtual ~CXTPCommandBarsVisualStudio2022Theme()
Destroys a CXTPCommandBarsVisualStudio2022Theme object, handles cleanup and deallocation.
CXTPCommandBarsVisualStudio2022Theme::DrawCheckRect
virtual void DrawCheckRect(CDC *pDC, CRect rc, COLORREF clrFore, COLORREF clrBack)
Helper class called by DrawRectangle to render a checkmark background and border.
CXTPCommandBarsVisualStudio2022Theme::CXTPCommandBarsVisualStudio2022Theme
CXTPCommandBarsVisualStudio2022Theme()
Constructs a CXTPCommandBarsVisualStudio2022Theme object.
CXTPCommandBarsVisualStudio2022Theme::DrawCommandBarGripper
virtual CSize DrawCommandBarGripper(CDC *pDC, CXTPCommandBar *pBar, BOOL bDraw=TRUE)
This method is called to draw the command bar's gripper.
CXTPCommandBarsVisualStudio2022Theme::DrawControlComboBox
virtual CSize DrawControlComboBox(CDC *pDC, CXTPControlComboBox *pComboBox, BOOL bDraw)
This method is called to draw the control.
CXTPCommandBarsVisualStudio2022Theme::DrawSplitButtonFrame
virtual void DrawSplitButtonFrame(CDC *pDC, CXTPControl *pButton, CRect rc)
This method is called to draw the frame for the SplitButton control.
CXTPCommandBarsVisualStudio2022Theme::DrawGalleryItemBack
virtual void DrawGalleryItemBack(CDC *pDC, CRect rcItem, BOOL bEnabled, BOOL bSelected, BOOL bPressed, BOOL bChecked, XTPBarType barType)
This method is called to draw the background for a gallery menu item.
CXTPCommandBarsVisualStudio2022Theme::SetStateColor
virtual void SetStateColor(COLORREF clrState=COLORREF_NULL)
Call this member function to set the application state color for the frame border and status bar.
CXTPCommandBarsVisualStudio2022Theme::DrawRectangle
virtual BOOL DrawRectangle(CDC *pDC, CXTPControl *pButton)
This method is called to fill the control's face.
CXTPCommandBarsVisualStudio2022Theme::GetControlTextColor
virtual COLORREF GetControlTextColor(CXTPControl *pButton)
This method returns the control text color to draw.
CXTPCommandBarsVisualStudio2022Theme::GetStateColor
virtual COLORREF GetStateColor() const
Call this member function to get the application state color for the frame border and status bar.
CXTPCommandBarsVisualStudio2022Theme::DrawRectangle
virtual void DrawRectangle(CDC *pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition)
This method is called to fill the control's face.
CXTPCommandBarsVisualStudio2022Theme::DrawRectangle
virtual void DrawRectangle(CDC *pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition, int nID)
This method is called to fill the control's face.
CXTPControlComboBox
CXTPControlComboBox is a CXTPControl derived class.
Definition XTPControlComboBox.h:381
CXTPControl
CXTPControl is a CXTPCmdTarget derived class.
Definition XTPControl.h:841


Toolkit Pro: XTPMarkupBold.h Source File

  • Source
  • Markup
  • Text
XTPMarkupBold.h
Go to the documentation of this file.
1
23#if !defined(__XTPMARKUPBOLD_H__)
24# define __XTPMARKUPBOLD_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class _XTP_EXT_CLASS CXTPMarkupBold : public CXTPMarkupSpan
34{
36 DECLARE_MARKUPCLASS(CXTPMarkupBold)
38protected:
39 CXTPMarkupBold();
40
42public:
43 DECLARE_DISPATCH_MAP()
44# ifdef _XTP_ACTIVEX
45 DECLARE_INTERFACE_MAP()
46 DECLARE_OLETYPELIB_EX(CXTPMarkupBold);
47# endif
48
50};
51
52# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
54#endif // !defined(__XTPMARKUPBOLD_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h


Toolkit Pro: Member List

CXTPDatePickerPaintManager Member List

This is the complete list of members for CXTPDatePickerPaintManager, including all inherited members.

CalcDayOfWeekRect(CDC *pDC) | CXTPDatePickerPaintManager | virtual
CalcDayRect(CDC *pDC) | CXTPDatePickerPaintManager | virtual
CalcMonthHeaderRect(CDC *pDC) | CXTPDatePickerPaintManager | virtual
CalcMonthRect(CDC *pDC) | CXTPDatePickerPaintManager | virtual
CalcWeekNumbersRect(CDC *pDC) | CXTPDatePickerPaintManager | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPDatePickerPaintManager() | CXTPDatePickerPaintManager |
DrawBackground(CDC *pDC, CRect rcClient) | CXTPDatePickerPaintManager | virtual
DrawBorder(CDC *pDC, const CXTPDatePickerControl *pControl, CRect &rcClient, BOOL bDraw) | CXTPDatePickerPaintManager | virtual
DrawButton(CDC *pDC, const CRect &rcButton, const CString &strButton, BOOL bIsDown, BOOL bIsHighLight) | CXTPDatePickerPaintManager | virtual
DrawDay(CDC *pDC, CXTPDatePickerItemDay *pDay) | CXTPDatePickerPaintManager | virtual
DrawDaysOfWeek(CDC *pDC, CXTPDatePickerItemMonth *pMonth) | CXTPDatePickerPaintManager | virtual
DrawMonthHeader(CDC *pDC, CXTPDatePickerItemMonth *pMonth) | CXTPDatePickerPaintManager | virtual
DrawScrollTriangle(CDC *pDC, CRect rcSpot, BOOL bLeftDirection, COLORREF clrColor=0, BOOL bYears=FALSE) | CXTPDatePickerPaintManager | virtual
DrawWeekNumbers(CDC *pDC, CXTPDatePickerItemMonth *pMonth) | CXTPDatePickerPaintManager | virtual
EnableTheme(BOOL bEnableTheme) | CXTPDatePickerPaintManager | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetButtonFont() | CXTPDatePickerPaintManager |
GetControlBackColor() | CXTPDatePickerPaintManager | virtual
GetCursorBack() | CXTPDatePickerPaintManager | virtual
GetDayBackColor() | CXTPDatePickerPaintManager | virtual
GetDaysOfWeekBackColor() | CXTPDatePickerPaintManager | virtual
GetDaysOfWeekTextColor() | CXTPDatePickerPaintManager | virtual
GetDaysOfWeekTextFont() | CXTPDatePickerPaintManager |
GetDayTextColor() | CXTPDatePickerPaintManager | virtual
GetDayTextFont() | CXTPDatePickerPaintManager | virtual
GetDayTextFontBold() | CXTPDatePickerPaintManager | virtual
GetHeaderTextFont() | CXTPDatePickerPaintManager |
GetHighlightTodayColor() | CXTPDatePickerPaintManager | virtual
GetListControlBackColor() | CXTPDatePickerPaintManager | virtual
GetListControlTextColor() | CXTPDatePickerPaintManager | virtual
GetListControlTextFont() | CXTPDatePickerPaintManager |
GetMonthHeaderBackColor() | CXTPDatePickerPaintManager | virtual
GetMonthHeaderTextColor() | CXTPDatePickerPaintManager | virtual
GetNonMonthDayBackColor() | CXTPDatePickerPaintManager | virtual
GetNonMonthDayTextColor() | CXTPDatePickerPaintManager | virtual
GetNonMonthDayTextFont() | CXTPDatePickerPaintManager |
GetPaintTheme() const | CXTPDatePickerPaintManager | protected
GetSelectedDayBackColor() | CXTPDatePickerPaintManager | virtual
GetSelectedDayTextColor() | CXTPDatePickerPaintManager | virtual
GetWeekNumbersBackColor() | CXTPDatePickerPaintManager | virtual
GetWeekNumbersTextColor() | CXTPDatePickerPaintManager | virtual
GetWeekNumbersTextFont() | CXTPDatePickerPaintManager |
m_bEnableTheme | CXTPDatePickerPaintManager | protected
m_clr3DFace | CXTPDatePickerPaintManager | protected
m_clr3DLight | CXTPDatePickerPaintManager | protected
m_clr3DShadow | CXTPDatePickerPaintManager | protected
m_clr3DText | CXTPDatePickerPaintManager | protected
m_clrButtonFace | CXTPDatePickerPaintManager |
m_clrButtonText | CXTPDatePickerPaintManager |
m_clrControlBack | CXTPDatePickerPaintManager |
m_clrDayBack | CXTPDatePickerPaintManager |
m_clrDaysOfWeekBack | CXTPDatePickerPaintManager |
m_clrDaysOfWeekText | CXTPDatePickerPaintManager |
m_clrDayText | CXTPDatePickerPaintManager |
m_clrHighlightToday | CXTPDatePickerPaintManager |
m_clrListControlBack | CXTPDatePickerPaintManager |
m_clrListControlText | CXTPDatePickerPaintManager |
m_clrMonthBorder | CXTPDatePickerPaintManager |
m_clrMonthHeaderBack | CXTPDatePickerPaintManager |
m_clrMonthHeaderButton | CXTPDatePickerPaintManager |
m_clrMonthHeaderText | CXTPDatePickerPaintManager |
m_clrNonMonthDayBack | CXTPDatePickerPaintManager |
m_clrNonMonthDayText | CXTPDatePickerPaintManager |
m_clrSelectedDayBack | CXTPDatePickerPaintManager |
m_clrSelectedDayText | CXTPDatePickerPaintManager |
m_clrStaticBorder | CXTPDatePickerPaintManager | protected
m_clrWeekNumbersBack | CXTPDatePickerPaintManager |
m_clrWeekNumbersText | CXTPDatePickerPaintManager |
m_hCursorBack | CXTPDatePickerPaintManager | protected
m_nPaintTheme | CXTPDatePickerPaintManager | protected
m_szDayMargin | CXTPDatePickerPaintManager |
m_themeButton | CXTPDatePickerPaintManager | protected
m_xtpFontButton | CXTPDatePickerPaintManager | protected
m_xtpFontDay | CXTPDatePickerPaintManager | protected
m_xtpFontDayBold | CXTPDatePickerPaintManager | protected
m_xtpFontDaysOfWeek | CXTPDatePickerPaintManager | protected
m_xtpFontHeader | CXTPDatePickerPaintManager | protected
m_xtpFontListControl | CXTPDatePickerPaintManager | protected
m_xtpFontNonMonthDay | CXTPDatePickerPaintManager | protected
m_xtpFontWeekNumbers | CXTPDatePickerPaintManager | protected
RefreshMetrics() | CXTPDatePickerPaintManager | virtual
SetButtonFont(CFont *fontButton) | CXTPDatePickerPaintManager |
SetButtonFontIndirect(LOGFONT *lFont) | CXTPDatePickerPaintManager |
SetFontIndirect(LOGFONT *lFont) | CXTPDatePickerPaintManager |
Triangle(CDC *pDC, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clrColor=0) | CXTPDatePickerPaintManager | protectedvirtual
~CXTPDatePickerPaintManager() | CXTPDatePickerPaintManager | virtual


Toolkit Pro: Member List

XTP_CALENDAR_TIMELINE_VIEW_SCALE Member List

This is the complete list of members for XTP_CALENDAR_TIMELINE_VIEW_SCALE, including all inherited members.

m_eType | XTP_CALENDAR_TIMELINE_VIEW_SCALE
m_nValue | XTP_CALENDAR_TIMELINE_VIEW_SCALE


Toolkit Pro: Member List

CXTPMessageBar Member List

This is the complete list of members for CXTPMessageBar, including all inherited members.

AddButton(UINT nID, LPCTSTR lpszCaption, LPCTSTR lpszToolTop=NULL) | CXTPMessageBar |
Click(CXTPMessageBarButton *pButton) | CXTPMessageBar | virtual
Create(CXTPCommandBars *pCommandBars, DWORD dwStyle=WS_CHILD|WS_VISIBLE|CBRS_TOP, UINT nID=XTP_IDW_MESSAGE_BAR) | CXTPMessageBar |
CXTPMessageBar() | CXTPMessageBar |
DrawButton(CDC *pDC, CXTPMessageBarButton *pButton) | CXTPMessageBar | protectedvirtual
DrawButtons(CDC *pDC) | CXTPMessageBar | protected
DrawContent(CDC *pDC) | CXTPMessageBar | protectedvirtual
EnableMarkup(BOOL bEnableMarkup=TRUE) | CXTPMessageBar |
FillMessageBar(CDC *pDC) | CXTPMessageBar | protectedvirtual
FindButton(UINT nID) const | CXTPMessageBar |
GetHeight() const | CXTPMessageBar |
GetMarkupContext() const | CXTPMessageBar |
GetMessageBarPaintManager() const | CXTPMessageBar |
GetMessageRect() | CXTPMessageBar |
GetPaintManager() const | CXTPMessageBar |
HitTestButton(CPoint point) const | CXTPMessageBar |
m_arrButtons | CXTPMessageBar | protected
m_bAutoSize | CXTPMessageBar | protected
m_nCustomHeight | CXTPMessageBar | protected
m_pCommandBars | CXTPMessageBar | protected
m_pHotButton | CXTPMessageBar | protected
m_pMarkupContext | CXTPMessageBar | protected
m_pUIElement | CXTPMessageBar | protected
m_rcContent | CXTPMessageBar | protected
m_strContent | CXTPMessageBar | protected
MeasureButton(CDC *pDC, CXTPMessageBarButton *pButton) | CXTPMessageBar | protectedvirtual
MeasureContent(CDC *pDC) | CXTPMessageBar | protectedvirtual
RecalcLayout(CDC *pDC) | CXTPMessageBar | protectedvirtual
RemoveButtons() | CXTPMessageBar |
SetAutoSize(BOOL bAutoSize) | CXTPMessageBar |
SetHeight(int nHeight) | CXTPMessageBar |
SetMessage(LPCTSTR lpszMessage) | CXTPMessageBar |
~CXTPMessageBar() | CXTPMessageBar | virtual


Toolkit Pro: Member List

XTP_NM_GRIDSCROLL Member List

This is the complete list of members for XTP_NM_GRIDSCROLL, including all inherited members.

nPosition | XTP_NM_GRIDSCROLL
nSection | XTP_NM_GRIDSCROLL


Toolkit Pro: XTPChartStackedAreaSeriesStyle.h Source File

  • Source
  • Chart
  • Styles
  • Area
XTPChartStackedAreaSeriesStyle.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTSTACKEDAREASERIESSTYLE_H__)
24# define __XTPCHARTSTACKEDAREASERIESSTYLE_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartSeriesView;
34class CXTPChartBorder;
35class CXTPChartFillStyle;
36
47class _XTP_EXT_CLASS CXTPChartStackedAreaSeriesStyle : public CXTPChartAreaSeriesStyle
48{
50 DECLARE_SERIAL(CXTPChartStackedAreaSeriesStyle)
52public:
57 CXTPChartStackedAreaSeriesStyle();
58
63 virtual ~CXTPChartStackedAreaSeriesStyle();
64
65public:
66 void SetStackHeight(double dLevel = 100);
67 double GetStackHeight() const;
68
69public:
70protected:
83 virtual CXTPChartSeriesView* CreateView(CXTPChartSeries* pSeries,
84 CXTPChartDiagramView* pDiagramView);
85
86# ifdef _XTP_ACTIVEX
87public:
89 DECLARE_DISPATCH_MAP()
90 DECLARE_INTERFACE_MAP()
91 DECLARE_OLETYPELIB_EX(CXTPChartStackedAreaSeriesStyle);
92 DECLARE_OLECREATE_EX(CXTPChartStackedAreaSeriesStyle)
93
94 double OleGetStackHeight();
95 void OleSetStackHeight(double dStackHeight);
97# endif
98
99protected:
100 double m_dStackHeight;
101};
102
113class _XTP_EXT_CLASS CXTPChartStackedAreaSeriesView : public CXTPChartAreaSeriesView
114{
115public:
123 CXTPChartStackedAreaSeriesView(CXTPChartSeries* pSeries, CXTPChartDiagramView* pDiagramView);
124
125protected:
141 CXTPChartSeriesPointView* CreateSeriesPointView(CXTPChartDeviceContext* pDC,
142 CXTPChartSeriesPoint* pPoint,
143 CXTPChartElementView* pParentView);
144
156 virtual CXTPChartDeviceCommand* CreateDeviceCommand(CXTPChartDeviceContext* pDC);
157
158 void UpdateRange(CXTPChartDeviceContext* pDC);
159};
160
161class _XTP_EXT_CLASS CXTPChartStackedAreaSeriesPointView : public CXTPChartPointSeriesPointView
162{
163public:
170 CXTPChartStackedAreaSeriesPointView(CXTPChartSeriesPoint* pPoint,
171 CXTPChartElementView* pParentView);
172
173public:
174 double m_dValueFrom;
175 double m_dValueTo;
176
177 friend class CXTPChartStackedAreaSeriesView;
178};
179
180AFX_INLINE void CXTPChartStackedAreaSeriesStyle::SetStackHeight(double dStackHeight)
181{
182 m_dStackHeight = dStackHeight;
183 OnChartChanged();
184}
185AFX_INLINE double CXTPChartStackedAreaSeriesStyle::GetStackHeight() const
186{
187 return m_dStackHeight;
188}
190# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
191#endif //#if !defined(__XTPCHARTSTACKEDAREASERIESSTYLE_H__)
pPoint
const CPoint * pPoint
return 0 or xtpCalendarHitTestDayExpandButton
Definition XTPCalendarThemeOffice2007.h:150
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartAreaSeriesStyle
CXTPChartAreaSeriesStyle is a CXTPChartPointSeriesStyle derived class which represents the area serie...
Definition XTPChartAreaSeriesStyle.h:48
CXTPChartAreaSeriesView
CXTPChartAreaSeriesView is a kind of CXTPChartSeriesView.
Definition XTPChartAreaSeriesView.h:48
CXTPChartBorder
This class abstracts the border of a chart, it is a kind of chart element.
Definition XTPChartBorder.h:42
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartDiagramView
This class represents the view of a chart diagram, which is a kind of CXTPChartElementView.
Definition XTPChartDiagramView.h:49
CXTPChartElement::OnChartChanged
virtual void OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic propertie...
CXTPChartElementView
This class represents the view of a chart element.
Definition XTPChartElementView.h:47
CXTPChartFillStyle
This class abstracts a fill style used to fill the background of various chart elements.
Definition XTPChartFillStyle.h:43
CXTPChartPointSeriesPointView
This class represents the view of a point series point, which is a kind of CXTPChartSeriesPointView.
Definition XTPChartPointSeriesView.h:90
CXTPChartSeries
This class represents a series in the chart, which is a kind of CXTPChartElement.
Definition XTPChartSeries.h:50
CXTPChartSeriesPoint
CXTPChartSeriesPoint is a kind of CXTPChartElement.
Definition XTPChartSeriesPoint.h:43
CXTPChartSeriesPointView
Represents chart series point view.
Definition XTPChartSeriesPointView.h:48
CXTPChartStackedAreaSeriesStyle
CXTPChartStackedAreaSeriesStyle is a CXTPChartAreaSeriesStyle derived class which represents the area...
Definition XTPChartStackedAreaSeriesStyle.h:48
CXTPChartStackedAreaSeriesStyle::~CXTPChartStackedAreaSeriesStyle
virtual ~CXTPChartStackedAreaSeriesStyle()
Destroys a CXTPChartStackedAreaSeriesStyle object, handles cleanup.
CXTPChartStackedAreaSeriesStyle::CXTPChartStackedAreaSeriesStyle
CXTPChartStackedAreaSeriesStyle()
Constructs a CXTPChartStackedAreaSeriesStyle object.
CXTPChartStackedAreaSeriesStyle::CreateView
virtual CXTPChartSeriesView * CreateView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Use this function to create a chart series view object.
CXTPChartStackedAreaSeriesView
CXTPChartStackedAreaSeriesView is a kind of CXTPChartSeriesView.
Definition XTPChartStackedAreaSeriesStyle.h:114
CXTPChartStackedAreaSeriesView::CXTPChartStackedAreaSeriesView
CXTPChartStackedAreaSeriesView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Constructs a CXTPChartStackedAreaSeriesView object.
CXTPChartStackedAreaSeriesView::CreateDeviceCommand
virtual CXTPChartDeviceCommand * CreateDeviceCommand(CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
CXTPChartStackedAreaSeriesView::CreateSeriesPointView
CXTPChartSeriesPointView * CreateSeriesPointView(CXTPChartDeviceContext *pDC, CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Call this function to create a chart area series point view object.


Toolkit Pro: Member List

CXTPDockingPanePanelColorSet2015 Member List

This is the complete list of members for CXTPDockingPanePanelColorSet2015, including all inherited members.

CXTPDockingPanePanelColorSet2012() | CXTPDockingPanePanelColorSet2012 |
CXTPDockingPanePanelColorSet2015() | CXTPDockingPanePanelColorSet2015 |
CXTPTabPaintManagerColorSet() | CXTPTabPaintManagerColorSet |
FillClient(CDC *pDC, CRect rc, CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
FillHeader(CDC *pDC, CRect rc, CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
FillNavigateButton(CDC *pDC, CXTPTabManagerNavigateButton *pButton, CRect &rc) | CXTPDockingPanePanelColorSet2012 | virtual
FillPropertyButton(CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerColorSet | virtual
FillStateButton(CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerColorSet | virtual
GetClientColor(CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
GetItemColor(CXTPTabManagerItem *pItem) | CXTPDockingPanePanelColorSet2012 | virtual
GradientFill(CDC *pDC, CRect rc, COLORREF clrLight, COLORREF clrDark, XTPTabPosition position) | CXTPTabPaintManagerColorSet |
IsAppThemed() const | CXTPTabPaintManagerColorSet | virtual
m_clrActiveFilesBack | CXTPTabPaintManagerColorSet |
m_clrActiveFilesBackHighlighted | CXTPTabPaintManagerColorSet |
m_clrActiveFilesBackPressed | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyph | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyphHighlighted | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyphPressed | CXTPTabPaintManagerColorSet |
m_clrAutoHideFace | CXTPTabPaintManagerColorSet |
m_clrBorderHighlight | CXTPTabPaintManagerColorSet |
m_clrButtonBorder | CXTPTabPaintManagerColorSet |
m_clrButtonBorderHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonBorderHot | CXTPTabPaintManagerColorSet |
m_clrButtonBorderKeyTips | CXTPTabPaintManagerColorSet |
m_clrButtonBorderTabContext1 | CXTPTabPaintManagerColorSet |
m_clrButtonBorderTabContext2 | CXTPTabPaintManagerColorSet |
m_clrButtonHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonHighlightedClose | CXTPTabPaintManagerColorSet |
m_clrButtonNormal | CXTPTabPaintManagerColorSet |
m_clrButtonPressed | CXTPTabPaintManagerColorSet |
m_clrButtonSelected | CXTPTabPaintManagerColorSet |
m_clrButtonSelectedHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonSelectedPressed | CXTPTabPaintManagerColorSet |
m_clrControlFace | CXTPTabPaintManagerColorSet |
m_clrFrameBorder | CXTPTabPaintManagerColorSet |
m_clrHeaderFace | CXTPTabPaintManagerColorSet |
m_clrPaneFace | CXTPTabPaintManagerColorSet |
m_clrTabClientBack | CXTPTabPaintManagerColorSet |
m_clrTabClientBorder | CXTPTabPaintManagerColorSet |
m_clrTextDisabled | CXTPTabPaintManagerColorSet |
m_clrTextHighlight | CXTPTabPaintManagerColorSet |
m_clrTextHighlightClose | CXTPTabPaintManagerColorSet |
m_clrTextNormal | CXTPTabPaintManagerColorSet |
m_clrTextPressed | CXTPTabPaintManagerColorSet |
m_clrTextSelected | CXTPTabPaintManagerColorSet |
m_clrTextSelectedHighlighted | CXTPTabPaintManagerColorSet |
m_clrTextSelectedPressed | CXTPTabPaintManagerColorSet |
m_csExcelNormal | CXTPTabPaintManagerColorSet |
m_csExcelSelected | CXTPTabPaintManagerColorSet |
m_csPropertyPage | CXTPTabPaintManagerColorSet |
m_csPropertyPage2003 | CXTPTabPaintManagerColorSet |
m_csStateButton | CXTPTabPaintManagerColorSet |
m_pPaintManager | CXTPTabPaintManagerColorSet | protected
RefreshMetrics() | CXTPDockingPanePanelColorSet2015 | virtual
SelectClipRgn(CDC *pDC, CRect rcClient, CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
SetTextColor(CDC *pDC, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerColorSet | virtual
~CXTPTabPaintManagerColorSet() | CXTPTabPaintManagerColorSet | virtual


Toolkit Pro: Member List

CXTPDockingPaneColorSet2019 Member List

This is the complete list of members for CXTPDockingPaneColorSet2019, including all inherited members.

GetButtonColorSet(CXTPDockingPaneCaptionButton *pButton) | CXTPDockingPaneColorSet | virtual
m_clrBackground | CXTPDockingPaneColorSet |
m_clrBorder | CXTPDockingPaneColorSet |
m_clrCaption | CXTPDockingPaneColorSet |
m_clrGripper | CXTPDockingPaneColorSet |
m_clrSplitter | CXTPDockingPaneColorSet |
m_clrText | CXTPDockingPaneColorSet |
m_csCaptionButtonHot | CXTPDockingPaneColorSet | protected
m_csCaptionButtonNormal | CXTPDockingPaneColorSet | protected
m_csCaptionButtonPressed | CXTPDockingPaneColorSet | protected
RefreshMetrics(CString strSection) | CXTPDockingPaneColorSet2019 | virtual
~CXTPDockingPaneColorSet() | CXTPDockingPaneColorSet | virtual


Toolkit Pro: Member List

CXTPSplitterWndThemeVisualStudio2017 Member List

This is the complete list of members for CXTPSplitterWndThemeVisualStudio2017, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPControlTheme() | CXTPControlTheme |
CXTPSplitterWndTheme() | CXTPSplitterWndTheme |
CXTPSplitterWndThemeOffice2013() | CXTPSplitterWndThemeOffice2013 |
CXTPSplitterWndThemeOfficeXP() | CXTPSplitterWndThemeOfficeXP |
CXTPSplitterWndThemeVisualStudio2017() | CXTPSplitterWndThemeVisualStudio2017 |
DrawSplitter(CDC *pDC, CXTPSplitterWnd *pSplitter, int nType, const CRect &rectArg) | CXTPSplitterWndTheme | virtual
EnableTabColors(BOOL bEnable=TRUE) | CXTPSplitterWndTheme |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetThemeStyle() const | CXTPControlTheme |
GetTrackBrush() | CXTPSplitterWndThemeOfficeXP | virtual
m_bTabColors | CXTPSplitterWndTheme |
m_crBack | CXTPSplitterWndTheme |
m_crBoxBack | CXTPSplitterWndTheme |
m_crInnerBorder | CXTPSplitterWndTheme |
m_crInnerBoxBorder | CXTPSplitterWndTheme |
m_crOuterBorder | CXTPSplitterWndTheme |
m_crOuterBoxBorder | CXTPSplitterWndTheme |
m_nTheme | CXTPControlTheme | protected
RefreshMetrics() | CXTPSplitterWndThemeOffice2013 | virtual
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static


Toolkit Pro: Member List

CXTPTabThemeFlat Member List

This is the complete list of members for CXTPTabThemeFlat, including all inherited members.

AdjustClientRect(CXTPTabManager *pTabManager, CRect &rcClient) | CXTPTabPaintManagerTheme | virtual
CXTPTabPaintManagerTheme() | CXTPTabPaintManagerTheme |
CXTPTabThemeFlat() | CXTPTabThemeFlat | inline
DrawSingleButton(CDC *pDC, CXTPTabManagerItem *pItem) | CXTPTabThemeFlat | virtual
DrawTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl) | CXTPTabPaintManagerTheme | virtual
DrawText(CDC *pDC, CXTPTabManager *pManager, const CString &str, LPRECT lpRect, UINT nFormat) | CXTPTabPaintManagerTheme | virtual
DrawWorkspacePart(CDC *pDC, LPRECT lpRect, XTPTabWorkspacePart workspacePart) | CXTPTabPaintManagerTheme | virtual
FillButton(CDC *pDC, CXTPTabManagerItem *pItem, LPPOINT pts, int nCount, XTPTabPosition tabPosition, BOOL bAbsolute=FALSE) | CXTPTabPaintManagerTheme |
FillTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl) | CXTPTabThemeFlat | virtual
GetButtonDrawRect(const CXTPTabManagerItem *pItem) | CXTPTabPaintManagerTheme | virtual
GetButtonHeight(const CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetButtonLength(CDC *pDC, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerTheme | virtual
GetClientMargin() | CXTPTabPaintManagerTheme | virtual
GetClientRect(CRect rcControl, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetColorSet() const | CXTPTabPaintManagerTheme |
GetDefaultColorSet() | CXTPTabThemeFlat | inlinevirtual
GetHeaderClipBox(CDC *pDC, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetHeaderHeight(CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme |
GetHeaderMargin() | CXTPTabPaintManagerTheme | virtual
GetHeaderRect(CRect rcControl, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetSupportedColorSets() | CXTPTabPaintManagerTheme | inlinevirtual
m_bButtonsReverseZOrder | CXTPTabPaintManagerTheme | protected
m_nButtonHeight | CXTPTabPaintManagerTheme | protected
m_nRowMargin | CXTPTabPaintManagerTheme |
m_pPaintManager | CXTPTabPaintManagerTheme | protected
m_rcHeaderMargin | CXTPTabPaintManagerTheme |
RefreshMetrics() | CXTPTabPaintManagerTheme | virtual
RepositionTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcClient) | CXTPTabPaintManagerTheme | virtual
~CXTPTabPaintManagerTheme() | CXTPTabPaintManagerTheme | virtual


Toolkit Pro: Member List

CXTPCalendarCaptionBarVisualStudio2015Theme Member List

This is the complete list of members for CXTPCalendarCaptionBarVisualStudio2015Theme, including all inherited members.

CXTPCalendarCaptionBarOffice2000Theme(CXTPCalendarCaptionBarTheme *pTheme=NULL) | CXTPCalendarCaptionBarOffice2000Theme |
CXTPCalendarCaptionBarOffice2003Theme(CXTPCalendarCaptionBarTheme *pTheme=NULL) | CXTPCalendarCaptionBarOffice2003Theme |
CXTPCalendarCaptionBarOffice2013Theme(CXTPCalendarCaptionBarTheme *pTheme=NULL) | CXTPCalendarCaptionBarOffice2013Theme |
CXTPCalendarCaptionBarOfficeXPTheme(CXTPCalendarCaptionBarTheme *pTheme=NULL) | CXTPCalendarCaptionBarOfficeXPTheme |
CXTPCalendarCaptionBarPaintManager(CXTPCalendarCaptionBarTheme *pTheme=NULL) | CXTPCalendarCaptionBarPaintManager |
CXTPCalendarCaptionBarVisualStudio2015Theme(CXTPCalendarCaptionBarTheme *pTheme=NULL) | CXTPCalendarCaptionBarVisualStudio2015Theme |
CXTPCmdTarget() | CXTPCmdTarget |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetPaintTheme() const | CXTPCalendarCaptionBarPaintManager | virtual
m_clrBorders | CXTPCalendarCaptionBarPaintManager | protected
m_clrScrollDateBarBk | CXTPCalendarCaptionBarPaintManager | protected
m_clrScrollTriangleColor | CXTPCalendarCaptionBarPaintManager | protected
m_clrSwitchViewBarBk | CXTPCalendarCaptionBarPaintManager | protected
m_clrTextColor | CXTPCalendarCaptionBarPaintManager | protected
m_fntTextFont | CXTPCalendarCaptionBarPaintManager | protected
m_pTheme | CXTPCalendarCaptionBarPaintManager | protected
RefreshMetrics() | CXTPCalendarCaptionBarOffice2013Theme | virtual
~CXTPCalendarCaptionBarOffice2000Theme() | CXTPCalendarCaptionBarOffice2000Theme | virtual
~CXTPCalendarCaptionBarOffice2003Theme() | CXTPCalendarCaptionBarOffice2003Theme | virtual
~CXTPCalendarCaptionBarOffice2013Theme() | CXTPCalendarCaptionBarOffice2013Theme | virtual
~CXTPCalendarCaptionBarOfficeXPTheme() | CXTPCalendarCaptionBarOfficeXPTheme | virtual
~CXTPCalendarCaptionBarPaintManager() | CXTPCalendarCaptionBarPaintManager | virtual
~CXTPCalendarCaptionBarVisualStudio2015Theme() | CXTPCalendarCaptionBarVisualStudio2015Theme | virtual


Toolkit Pro: XTPCalendarData.h Source File

  • Source
  • Calendar
XTPCalendarData.h
Go to the documentation of this file.
1
22#if !defined(_XTPCALENDARDATA_H__)
23# define _XTPCALENDARDATA_H__
24
25# if _MSC_VER > 1000
26# pragma once
27# endif // _MSC_VER > 1000
28
29# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
30
32
33class CXTPCalendarRecurrencePattern;
34class CXTPCalendarEventLabels;
35class CXTPCalendarSchedules;
36class CXTPNotifyConnection;
37class CXTPCalendarOptions;
38class CXTPCalendarEventCategories;
39class CXTPCalendarCustomProperties;
40class CXTPCalendarEvents;
41class CXTPCalendarEvent;
43 XTP_DEFINE_SMART_PTR_INTERNAL(CXTPCalendarEvents)
44 XTP_DEFINE_SMART_PTR_INTERNAL(CXTPCalendarEvent)
45 XTP_DEFINE_SMART_PTR_INTERNAL(CXTPCalendarRecurrencePattern)
55# define XTP_OBJECT_CACHE_HASH_TABLE_SIZE 1021
56
57static const LPCTSTR cszProcess_RecurrenceState =
58 _T("process_RecurrenceState");
59static const LPCTSTR cszProcess_RecurrencePatternID =
60 _T("process_RecurrencePatternID");
96class _XTP_EXT_CLASS CXTPCalendarData : public CXTPCmdTarget
97{
98 friend class CXTPCalendarRecurrencePattern;
99 friend class CXTPCalendarEvent;
100 friend class CXTPCalendarOptions;
101 friend class CXTPCalendarControl;
103 DECLARE_DYNAMIC(CXTPCalendarData)
105public:
117 CXTPCalendarData();
118
126 virtual ~CXTPCalendarData();
127
136 virtual BOOL Open();
137
148 virtual BOOL Create();
149
162 virtual BOOL Save();
163
168 virtual void Close();
169
176 virtual BOOL IsOpen() const;
177
187 virtual XTPCalendarDataProvider GetType() const;
188
205 virtual CXTPCalendarEventsPtr RetrieveDayEvents(COleDateTime dtDay);
206
222 virtual CXTPCalendarEventPtr CreateNewEvent(DWORD dwEventID = XTP_CALENDAR_UNKNOWN_EVENT_ID);
223
239 virtual CXTPCalendarRecurrencePatternPtr
240 CreateNewRecurrencePattern(DWORD dwPatternID = XTP_CALENDAR_UNKNOWN_RECURRENCE_PATTERN_ID);
241
256 virtual CXTPCalendarEventPtr GetEvent(DWORD dwEventID);
257
272 virtual CXTPCalendarRecurrencePatternPtr GetRecurrencePattern(DWORD dwPatternID);
273
290 virtual BOOL AddEvent(CXTPCalendarEvent* pEvent);
291
305 virtual BOOL AddEvents(CXTPCalendarEvents* pEvents);
306
316 virtual void RemoveAllEvents();
317
334 virtual BOOL DeleteEvent(CXTPCalendarEvent* pEvent);
335
352 virtual BOOL ChangeEvent(CXTPCalendarEvent* pNewEvent);
353
362 virtual CXTPNotifyConnection* GetConnection() const;
363
372 virtual CXTPCalendarCustomProperties* GetCustomProperties() const;
373
385 virtual CXTPCalendarEventLabels* GetLabelList() const;
386
397 virtual CXTPCalendarEventCategories* GetEventCategories() const;
398
408 virtual void SetLabelList(CXTPCalendarEventLabels* pLabelList);
409
420 virtual BOOL AddEventLabel(int nID, CString strName, COLORREF crLabel);
421
434 virtual BOOL AddEventCategory(UINT uID, CString strName, COLORREF crBorder, COLORREF crBkBase);
435
443 virtual void UpdateEventLabels(COLORREF* clrEventColors, UINT uCount);
444
450 virtual void ClearEventCategoryList();
451
457 virtual void ClearEventLabelList();
458
464 virtual void RestoreEventCategoryList();
465
471 virtual void RestoreEventLabelList();
472
484 void UpdateEventCategories(COLORREF* pClrBkBase, COLORREF* pClrBorder, int nCount);
485
494 virtual CXTPCalendarSchedules* GetSchedules() const;
495
505 virtual void SetConnectionString(LPCTSTR lpszConnectionString);
506
516 virtual CString GetConnectionString() const;
517
531 virtual CString GetDataSource();
532
540 virtual int GetCacheMode() const;
541
556 virtual void SetCacheMode(int eCacheMode, CXTPCalendarData* pCacheDataProvider = NULL);
557
562 virtual void ClearCache();
563
582 virtual CXTPCalendarEventsPtr GetUpcomingEvents(COleDateTime dtFrom = (DATE)0,
583 COleDateTimeSpan spPeriod = (DATE)0);
584
604 virtual CXTPCalendarEventsPtr GetAllEvents_raw();
605
606 BOOL m_bOwnershipMode;
607 // flag to set protected mode of using Calendar when some schedules can be protected and other -
608 // public
609protected:
626 virtual CXTPCalendarEventsPtr DoRetrieveDayEvents(COleDateTime dtDay);
627
637 virtual void DoRemoveAllEvents();
638
653 virtual CXTPCalendarEventPtr DoRead_Event(DWORD dwEventID);
654
669 virtual CXTPCalendarRecurrencePatternPtr DoRead_RPattern(DWORD dwPatternID);
670
688 virtual BOOL DoCreate_Event(CXTPCalendarEvent* pEvent, DWORD& rdwNewEventID);
689
706 virtual BOOL DoUpdate_Event(CXTPCalendarEvent* pEvent);
707
724 virtual BOOL DoDelete_Event(CXTPCalendarEvent* pEvent);
725
743 virtual BOOL DoCreate_RPattern(CXTPCalendarRecurrencePattern* pPattern, DWORD& rdwNewPatternID);
744
760 virtual BOOL DoUpdate_RPattern(CXTPCalendarRecurrencePattern* pPattern);
761
778 virtual BOOL DoDelete_RPattern(CXTPCalendarRecurrencePattern* pPattern);
779
798 virtual CXTPCalendarEventsPtr DoGetUpcomingEvents(COleDateTime dtFrom,
799 COleDateTimeSpan spPeriod);
800
818 virtual CXTPCalendarEventsPtr DoGetAllEvents_raw();
819
820protected:
831 virtual void SendNotification(XTP_NOTIFY_CODE EventCode, WPARAM wParam, LPARAM lParam);
832
847 virtual BOOL OnTimeZoneChanged()
848 {
849 return FALSE;
850 };
851
852 virtual BOOL _AddRPatternWithExceptions(CXTPCalendarRecurrencePattern* pPattern);
853 virtual BOOL _RemoveRPatternWithExceptions(CXTPCalendarRecurrencePattern* pPattern);
854 virtual BOOL _ChangeRPatternWithExceptions(CXTPCalendarRecurrencePattern* pRecurrencePattern);
855
856 virtual BOOL _ChangeRExceptionOccurrence_nf(CXTPCalendarEvent* pExcOcc,
857 BOOL bSend_EventDeleted);
858
859 virtual void _PostProcessOccurrencesFromMaster(COleDateTime dtDay, CXTPCalendarEvents* pEvents);
860 virtual void _PostProcessOccurrencesFromMaster2(COleDateTime dtDayFrom, COleDateTime dtDayTo,
861 CXTPCalendarEvents* pEvents);
862
863 virtual BOOL _PostProcessRecurrenceIfNeed(CXTPCalendarEvent* pEvent);
864 virtual void _PostProcessRecurrenceIfNeed(CXTPCalendarEvents* pEvents);
865
866 virtual void _FilterDayEventsInstancesByEndTime(COleDateTime dtDay,
867 CXTPCalendarEvents* pEvents);
868
869 virtual CXTPCalendarRecurrencePatternPtr _GetRecurrencePattern_raw(DWORD dwPatternID);
870 virtual CXTPCalendarEventPtr _GetEvent_raw(DWORD dwEventID);
871
872protected:
873 BOOL m_bOpened;
875 CXTPNotifyConnection* m_pConnection;
876 BOOL m_bDisableNotificationsSending;
879 CXTPCalendarEventLabels* m_pLabelList;
880 CXTPCalendarSchedules* m_pSchedules;
881 CXTPCalendarEventCategories* m_pEventCategories;
883 CXTPCalendarCustomProperties* m_pCustomProperties;
884protected:
885 CString m_strConnectionString;
887 XTPCalendarDataProvider m_typeProvider;
893 class _XTP_EXT_CLASS CXTPDPCache
894 {
895 public:
900 CXTPDPCache();
901
906 virtual ~CXTPDPCache();
907
912 void SafeClose();
913
918 void SafeRemoveAll();
919
929 virtual BOOL IsDayInCache(COleDateTime dtDay);
930
938 virtual void SetDayInCache(COleDateTime dtDay, BOOL bSet = TRUE);
939
949 virtual BOOL IsEventInCache(CXTPCalendarEvent* pEvent);
950
958 virtual void AddToCache(CXTPCalendarEvents* pEvents, COleDateTime dtDay);
959
967 virtual void AddToCacheIfNeed(CXTPCalendarEvent* pEvent);
968
976 virtual void _AddToCacheIfNeed(CXTPCalendarRecurrencePattern* pPattern);
977
978 CXTPCalendarData* m_pCacheDP; // Cache Data Provider.
979 int m_eCacheMode; // see XTPCalendarDataProviderCacheMode
980
981 protected:
982 CMap<DWORD, DWORD, BOOL, BOOL> m_mapIsDayInCache; // whether events for this day are already
983 // stored in cache
984 };
985
986protected:
987 CXTPDPCache m_cache; // Common data provider cache.
988
997 template<class _TObject>
998 class EventsMapByID_T
999 {
1000 public:
1010 EventsMapByID_T(UINT uHashTableSize = XTP_OBJECT_CACHE_HASH_TABLE_SIZE)
1011 {
1012 m_mapID2Object.InitHashTable(uHashTableSize, FALSE);
1013 };
1014
1025 virtual ~EventsMapByID_T(){};
1026
1044 void Add(DWORD dwID, _TObject* pObj)
1045 {
1046 if (!pObj)
1047 {
1048 _ASSERTE(FALSE);
1049 return;
1050 }
1051 TObjPtr ptrObj(pObj, TRUE);
1052 m_mapID2Object.SetAt(dwID, ptrObj);
1053 };
1054
1071 _TObject* Get(DWORD dwID)
1072 {
1073 TObjPtr ptrObj;
1074 if (m_mapID2Object.Lookup(dwID, ptrObj) && !!ptrObj)
1075 {
1076 return (_TObject*)(CCmdTarget*)ptrObj;
1077 }
1078 return NULL;
1079 };
1080
1097 BOOL IsExist(DWORD dwID)
1098 {
1099 TObjPtr ptrObj;
1100 return m_mapID2Object.Lookup(dwID, ptrObj) && !!ptrObj;
1101 };
1102
1121 BOOL Remove(DWORD dwID)
1122 {
1123 BOOL bRes = m_mapID2Object.RemoveKey(dwID);
1124 return bRes;
1125 };
1126
1139 void RemoveAll()
1140 {
1141 m_mapID2Object.RemoveAll();
1142 }
1143
1154 POSITION GetStartPosition()
1155 {
1156 return m_mapID2Object.GetStartPosition();
1157 }
1158
1178 _TObject* GetNextElement(POSITION& rPos, DWORD& rID)
1179 {
1180 TObjPtr ptrElement;
1181 m_mapID2Object.GetNextAssoc(rPos, rID, ptrElement);
1182 return (_TObject*)(CCmdTarget*)ptrElement;
1183 }
1184
1193 int GetCount()
1194 {
1195 return (int)m_mapID2Object.GetCount();
1196 }
1197
1198 protected:
1204 typedef CXTPSmartPtrInternalT<CCmdTarget> TObjPtr;
1205 CMap<DWORD, DWORD, TObjPtr, TObjPtr&> m_mapID2Object;
1206 };
1207
1214 static DWORD AFX_CDECL GetNextFreeTempID();
1215
1216 static DWORD ms_dwNextFreeTempID;
1218 CXTPCalendarOptions* m_pCalendarOptions;
1220public:
1234 static CXTPCalendarData* AFX_CDECL CreateDataProvider(LPCTSTR lpszConnectionString);
1235
1250 static CXTPCalendarData* AFX_CDECL CreateDataProvider(XTPCalendarDataProvider eDataProvider);
1251
1270 static XTPCalendarDataProvider AFX_CDECL DataProviderTypeFromConStr(
1271 LPCTSTR lpszConnectionString,
1272 XTPCalendarDataProvider eDPDefault = xtpCalendarDataProviderUnknown);
1273
1290 static CString AFX_CDECL DataSourceFromConStr(LPCTSTR lpszConnectionString);
1291
1292private:
1293 void SetOptionsToUpdate(CXTPCalendarOptions* pOptions);
1294
1295protected:
1296# ifdef _XTP_ACTIVEX
1297
1298 virtual BOOL OpenEx(LPDISPATCH pdispADOConnection);
1299
1300 DECLARE_DISPATCH_MAP()
1301 DECLARE_INTERFACE_MAP()
1302
1303 DECLARE_OLETYPELIB_EX(CXTPCalendarData);
1304
1305 afx_msg LPDISPATCH OleCreateEvent();
1306 afx_msg LPDISPATCH OleCreateEventEx(long EventID);
1307 afx_msg LPDISPATCH OleCreateRecurrencePattern(long PatternID);
1308
1309 afx_msg void OleAddEvent(LPDISPATCH Event);
1310 afx_msg void OleChangeEvent(LPDISPATCH Event);
1311
1312 afx_msg BOOL OleOpen();
1313 afx_msg BOOL OleOpenEx(LPDISPATCH pdispADOConnection);
1314
1315 afx_msg BOOL OleCreate();
1316 afx_msg void OleDeleteEvent(LPDISPATCH Event);
1317 afx_msg BSTR OleGetDataSource();
1318 afx_msg void OleClose();
1319 afx_msg void OleSave();
1320 afx_msg void OleRemoveAllEvents();
1321 afx_msg LPDISPATCH OleRetrieveDayEvents(DATE dt);
1322 afx_msg LPDISPATCH OleGetEvent(long EventID);
1323 afx_msg LPDISPATCH OleGetRecurrencePattern(long PatternID);
1324
1325 afx_msg LPDISPATCH OleGetLabelList();
1326
1327 afx_msg long OleGetCacheMode();
1328 afx_msg void OleSetCacheMode(long eCacheMode);
1329
1330 afx_msg BOOL OleGetOwnershipMode();
1331 afx_msg void OleSetOwnershipMode(BOOL bMode);
1332
1333 afx_msg void OleClearCache();
1334
1335 afx_msg LPDISPATCH OleGetAllEventsRaw();
1336 afx_msg LPDISPATCH OleGetSchedules();
1337 afx_msg LPDISPATCH OleGetEventCategories();
1338
1339# endif
1340};
1341
1343AFX_INLINE BOOL CXTPCalendarData::Open()
1344{
1345 // _ASSERTE(!m_bOpened);
1346 return m_bOpened = TRUE;
1347}
1348AFX_INLINE BOOL CXTPCalendarData::Create()
1349{
1350 // _ASSERTE(!m_bOpened);
1351 return m_bOpened = TRUE;
1352}
1353AFX_INLINE BOOL CXTPCalendarData::IsOpen() const
1354{
1355 return m_bOpened;
1356}
1357AFX_INLINE BOOL CXTPCalendarData::Save()
1358{
1359 // _ASSERTE(m_bOpened);
1360 return TRUE;
1361}
1362AFX_INLINE void CXTPCalendarData::Close()
1363{
1364 // _ASSERTE(m_bOpened);
1365
1366 m_cache.SafeClose();
1367 m_bOpened = FALSE;
1368}
1369AFX_INLINE CXTPNotifyConnection* CXTPCalendarData::GetConnection() const
1370{
1371 return m_pConnection;
1372}
1373AFX_INLINE DWORD AFX_CDECL CXTPCalendarData::GetNextFreeTempID()
1374{
1375 return ms_dwNextFreeTempID--;
1376}
1377AFX_INLINE CXTPCalendarEventLabels* CXTPCalendarData::GetLabelList() const
1378{
1379 return m_pLabelList;
1380}
1381AFX_INLINE CXTPCalendarEventCategories* CXTPCalendarData::GetEventCategories() const
1382{
1383 return m_pEventCategories;
1384}
1385AFX_INLINE CXTPCalendarSchedules* CXTPCalendarData::GetSchedules() const
1386{
1387 return m_pSchedules;
1388}
1389
1390AFX_INLINE void CXTPCalendarData::SetConnectionString(LPCTSTR lpszConnectionString)
1391{
1392 _ASSERTE(lpszConnectionString);
1393 if (lpszConnectionString)
1394 {
1395 m_strConnectionString = lpszConnectionString;
1396 }
1397}
1398AFX_INLINE CString CXTPCalendarData::GetConnectionString() const
1399{
1400 return m_strConnectionString;
1401}
1402AFX_INLINE XTPCalendarDataProvider CXTPCalendarData::GetType() const
1403{
1404 return m_typeProvider;
1405}
1406AFX_INLINE int CXTPCalendarData::GetCacheMode() const
1407{
1408 return m_cache.m_eCacheMode;
1409}
1410AFX_INLINE CXTPCalendarCustomProperties* CXTPCalendarData::GetCustomProperties() const
1411{
1412 return m_pCustomProperties;
1413}
1414
1415# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
1416#endif // !defined(_XTPCALENDARDATA_H__)
cszProcess_RecurrencePatternID
static const LPCTSTR cszProcess_RecurrencePatternID
String name for a corresponding property.
Definition XTPCalendarData.h:59
XTP_OBJECT_CACHE_HASH_TABLE_SIZE
#define XTP_OBJECT_CACHE_HASH_TABLE_SIZE
Cache table size.
Definition XTPCalendarData.h:55
cszProcess_RecurrenceState
static const LPCTSTR cszProcess_RecurrenceState
String name for a corresponding property.
Definition XTPCalendarData.h:57
XTPCalendarDataProvider
XTPCalendarDataProvider
Enumeration used to determine the calendar data provider in use.
Definition XTPCalendarDefines.h:337
xtpCalendarDataProviderUnknown
@ xtpCalendarDataProviderUnknown
Unknown data provider.
Definition XTPCalendarDefines.h:338
XTP_CALENDAR_UNKNOWN_RECURRENCE_PATTERN_ID
#define XTP_CALENDAR_UNKNOWN_RECURRENCE_PATTERN_ID
Define an unknown recurrence pattern ID.
Definition XTPCalendarDefines.h:113
XTP_CALENDAR_UNKNOWN_EVENT_ID
#define XTP_CALENDAR_UNKNOWN_EVENT_ID
Define unknown event ID.
Definition XTPCalendarDefines.h:107
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTP_DEFINE_SMART_PTR_INTERNAL
#define XTP_DEFINE_SMART_PTR_INTERNAL(ClassName)
Define smart pointer for the specified class as ClassNamePtr.
Definition XTPSmartPtrInternalT.h:47
CXTPCalendarControl
Class CXTPCalendarControl implements the calendar's view interface.
Definition XTPCalendarControl.h:126
CXTPCalendarCustomProperties
This class is used to store properties collection.
Definition XTPCalendarCustomProperties.h:44
CXTPCalendarData::CXTPDPCache
Definition XTPCalendarData.h:894
CXTPCalendarData::CXTPDPCache::~CXTPDPCache
virtual ~CXTPDPCache()
Default class destructor.
CXTPCalendarData::CXTPDPCache::SafeRemoveAll
void SafeRemoveAll()
Safely removes all elements from the cache.
CXTPCalendarData::CXTPDPCache::_AddToCacheIfNeed
virtual void _AddToCacheIfNeed(CXTPCalendarRecurrencePattern *pPattern)
Checks whether a specified recurrence pattern is already stored in the cache and adds it there if not...
CXTPCalendarData::CXTPDPCache::SetDayInCache
virtual void SetDayInCache(COleDateTime dtDay, BOOL bSet=TRUE)
Sets a flag that this day is in the cache.
CXTPCalendarData::CXTPDPCache::AddToCache
virtual void AddToCache(CXTPCalendarEvents *pEvents, COleDateTime dtDay)
Adds a collection of events to the cache for a specified day.
CXTPCalendarData::CXTPDPCache::SafeClose
void SafeClose()
Closes a cache.
CXTPCalendarData::CXTPDPCache::IsDayInCache
virtual BOOL IsDayInCache(COleDateTime dtDay)
Checks whether events for this day are already stored in the cache.
CXTPCalendarData::CXTPDPCache::AddToCacheIfNeed
virtual void AddToCacheIfNeed(CXTPCalendarEvent *pEvent)
Checks whether a specified event is already stored in the cache and adds it there if not.
CXTPCalendarData::CXTPDPCache::CXTPDPCache
CXTPDPCache()
Default class constructor.
CXTPCalendarData::CXTPDPCache::IsEventInCache
virtual BOOL IsEventInCache(CXTPCalendarEvent *pEvent)
Checks whether a specified event is already stored in the cache.
CXTPCalendarData::EventsMapByID_T
Definition XTPCalendarData.h:999
CXTPCalendarData::EventsMapByID_T::GetNextElement
_TObject * GetNextElement(POSITION &rPos, DWORD &rID)
This member function is used to get the next object pointer.
Definition XTPCalendarData.h:1178
CXTPCalendarData::EventsMapByID_T::IsExist
BOOL IsExist(DWORD dwID)
This member function is used to determine if an object with the specified ID exists.
Definition XTPCalendarData.h:1097
CXTPCalendarData::EventsMapByID_T::Remove
BOOL Remove(DWORD dwID)
This member function is used to remove an object with the specified ID.
Definition XTPCalendarData.h:1121
CXTPCalendarData::EventsMapByID_T::Get
_TObject * Get(DWORD dwID)
This member function is used to obtain a pointer to an object using the specified ID.
Definition XTPCalendarData.h:1071
CXTPCalendarData::EventsMapByID_T::TObjPtr
CXTPSmartPtrInternalT< CCmdTarget > TObjPtr
typedef CXTPSmartPtrInternalT<_TObject> TObjPtr; Smart pointer object type.
Definition XTPCalendarData.h:1204
CXTPCalendarData::EventsMapByID_T::RemoveAll
void RemoveAll()
This member function is used to remove all stored objects from the map.
Definition XTPCalendarData.h:1139
CXTPCalendarData::EventsMapByID_T::GetCount
int GetCount()
This member function is used to get object count.
Definition XTPCalendarData.h:1193
CXTPCalendarData::EventsMapByID_T::GetStartPosition
POSITION GetStartPosition()
This member function is used to get the start iteration position.
Definition XTPCalendarData.h:1154
CXTPCalendarData::EventsMapByID_T::EventsMapByID_T
EventsMapByID_T(UINT uHashTableSize=XTP_OBJECT_CACHE_HASH_TABLE_SIZE)
Default class constructor.
Definition XTPCalendarData.h:1010
CXTPCalendarData::EventsMapByID_T::~EventsMapByID_T
virtual ~EventsMapByID_T()
Default class destructor.
Definition XTPCalendarData.h:1025
CXTPCalendarData::EventsMapByID_T::Add
void Add(DWORD dwID, _TObject *pObj)
This member function is used to add new or to replace existing pairs of IDs and Objects.
Definition XTPCalendarData.h:1044
CXTPCalendarData::EventsMapByID_T::m_mapID2Object
CMap< DWORD, DWORD, TObjPtr, TObjPtr & > m_mapID2Object
The map of ID to object.
Definition XTPCalendarData.h:1205
CXTPCalendarData
This class defines an abstract representation of the Calendar control data with all necessary methods...
Definition XTPCalendarData.h:97
CXTPCalendarData::DoRead_Event
virtual CXTPCalendarEventPtr DoRead_Event(DWORD dwEventID)
Read event from the data source.
CXTPCalendarData::DoRead_RPattern
virtual CXTPCalendarRecurrencePatternPtr DoRead_RPattern(DWORD dwPatternID)
Read recurrence pattern from the data source.
CXTPCalendarData::UpdateEventLabels
virtual void UpdateEventLabels(COLORREF *clrEventColors, UINT uCount)
Update event labels colors when the theme is changed.
CXTPCalendarData::GetConnectionString
virtual CString GetConnectionString() const
Returns a data provider connection string.
Definition XTPCalendarData.h:1398
CXTPCalendarData::CreateDataProvider
static CXTPCalendarData *AFX_CDECL CreateDataProvider(LPCTSTR lpszConnectionString)
Call this method to create a data provider from a specified Calendar connection string.
CXTPCalendarData::GetRecurrencePattern
virtual CXTPCalendarRecurrencePatternPtr GetRecurrencePattern(DWORD dwPatternID)
Reads a recurrence pattern from the data source.
CXTPCalendarData::CXTPCalendarData
CXTPCalendarData()
Default constructor.
CXTPCalendarData::DataSourceFromConStr
static CString AFX_CDECL DataSourceFromConStr(LPCTSTR lpszConnectionString)
Call this method to retrieve a data source connection string from a regular Calendar connection strin...
CXTPCalendarData::m_pSchedules
CXTPCalendarSchedules * m_pSchedules
Data source Schedules list.
Definition XTPCalendarData.h:880
CXTPCalendarData::m_strConnectionString
CString m_strConnectionString
default connection string;
Definition XTPCalendarData.h:885
CXTPCalendarData::GetSchedules
virtual CXTPCalendarSchedules * GetSchedules() const
Returns a collection of schedules used in this data source.
Definition XTPCalendarData.h:1385
CXTPCalendarData::DoCreate_RPattern
virtual BOOL DoCreate_RPattern(CXTPCalendarRecurrencePattern *pPattern, DWORD &rdwNewPatternID)
Creates a new recurrence pattern in the data source.
CXTPCalendarData::DoDelete_Event
virtual BOOL DoDelete_Event(CXTPCalendarEvent *pEvent)
Deletes an event from the data source.
CXTPCalendarData::SendNotification
virtual void SendNotification(XTP_NOTIFY_CODE EventCode, WPARAM wParam, LPARAM lParam)
Sends a notification to all listeners.
CXTPCalendarData::m_pCalendarOptions
CXTPCalendarOptions * m_pCalendarOptions
This member stores user's calendar view options.
Definition XTPCalendarData.h:1218
CXTPCalendarData::DoUpdate_RPattern
virtual BOOL DoUpdate_RPattern(CXTPCalendarRecurrencePattern *pPattern)
Updates a recurrence pattern in the database.
CXTPCalendarData::DoCreate_Event
virtual BOOL DoCreate_Event(CXTPCalendarEvent *pEvent, DWORD &rdwNewEventID)
Creates a new event in the data source.
CXTPCalendarData::m_bOpened
BOOL m_bOpened
Stores a flag whether a data source connection is open.
Definition XTPCalendarData.h:873
CXTPCalendarData::DataProviderTypeFromConStr
static XTPCalendarDataProvider AFX_CDECL DataProviderTypeFromConStr(LPCTSTR lpszConnectionString, XTPCalendarDataProvider eDPDefault=xtpCalendarDataProviderUnknown)
Call this method to retrieve a type of the data provider from its connection string.
CXTPCalendarData::IsOpen
virtual BOOL IsOpen() const
This method determines whether a data source connection is opened.
Definition XTPCalendarData.h:1353
CXTPCalendarData::CreateDataProvider
static CXTPCalendarData *AFX_CDECL CreateDataProvider(XTPCalendarDataProvider eDataProvider)
Call this method to create a data provider of the specified type.
CXTPCalendarData::m_pConnection
CXTPNotifyConnection * m_pConnection
Connection object to send notifications.
Definition XTPCalendarData.h:875
CXTPCalendarData::AddEvent
virtual BOOL AddEvent(CXTPCalendarEvent *pEvent)
Creates a new event in the data source.
CXTPCalendarData::m_bDisableNotificationsSending
BOOL m_bDisableNotificationsSending
Stores a flag whether notifications sending is disabled.
Definition XTPCalendarData.h:876
CXTPCalendarData::GetCustomProperties
virtual CXTPCalendarCustomProperties * GetCustomProperties() const
Returns a custom properties collection.
Definition XTPCalendarData.h:1410
CXTPCalendarData::DeleteEvent
virtual BOOL DeleteEvent(CXTPCalendarEvent *pEvent)
Deletes an event from the data source.
CXTPCalendarData::ClearEventLabelList
virtual void ClearEventLabelList()
Call this member function to remove all items from the event label list.
CXTPCalendarData::RemoveAllEvents
virtual void RemoveAllEvents()
Removes all events from the data source.
CXTPCalendarData::GetAllEvents_raw
virtual CXTPCalendarEventsPtr GetAllEvents_raw()
This method Gets all events without generating recurrence occurrences.
CXTPCalendarData::AddEventLabel
virtual BOOL AddEventLabel(int nID, CString strName, COLORREF crLabel)
Call this member function to add a new item to the event label list.
CXTPCalendarData::RetrieveDayEvents
virtual CXTPCalendarEventsPtr RetrieveDayEvents(COleDateTime dtDay)
Retrieves day events for a specified day from the data source.
CXTPCalendarData::SetConnectionString
virtual void SetConnectionString(LPCTSTR lpszConnectionString)
Sets a data provider connection string.
Definition XTPCalendarData.h:1390
CXTPCalendarData::ClearEventCategoryList
virtual void ClearEventCategoryList()
Call this member function to remove all items from the event category list.
CXTPCalendarData::~CXTPCalendarData
virtual ~CXTPCalendarData()
Default Destructor.
CXTPCalendarData::DoGetUpcomingEvents
virtual CXTPCalendarEventsPtr DoGetUpcomingEvents(COleDateTime dtFrom, COleDateTimeSpan spPeriod)
Retrieves a collection of events expiring in the period from dtFrom during next spPeriod.
CXTPCalendarData::GetEvent
virtual CXTPCalendarEventPtr GetEvent(DWORD dwEventID)
Reads an event from the data source.
CXTPCalendarData::GetEventCategories
virtual CXTPCalendarEventCategories * GetEventCategories() const
Returns a collection of Event categories.
Definition XTPCalendarData.h:1381
CXTPCalendarData::GetLabelList
virtual CXTPCalendarEventLabels * GetLabelList() const
Returns a collection of Labels used in this Data source.
Definition XTPCalendarData.h:1377
CXTPCalendarData::UpdateEventCategories
void UpdateEventCategories(COLORREF *pClrBkBase, COLORREF *pClrBorder, int nCount)
This member function updates the default colors of the category list when the theme is changed.
CXTPCalendarData::m_pCustomProperties
CXTPCalendarCustomProperties * m_pCustomProperties
Custom properties collection object.
Definition XTPCalendarData.h:883
CXTPCalendarData::Open
virtual BOOL Open()
Call this member function to initialize a newly constructed Data object.
Definition XTPCalendarData.h:1343
CXTPCalendarData::DoDelete_RPattern
virtual BOOL DoDelete_RPattern(CXTPCalendarRecurrencePattern *pPattern)
Deletes a recurrence pattern from the database.
CXTPCalendarData::DoUpdate_Event
virtual BOOL DoUpdate_Event(CXTPCalendarEvent *pEvent)
Updates event properties in the data source.
CXTPCalendarData::GetType
virtual XTPCalendarDataProvider GetType() const
This method determines the type of the current Data Provider implementation.
Definition XTPCalendarData.h:1402
CXTPCalendarData::GetCacheMode
virtual int GetCacheMode() const
Determines current cache mode.
Definition XTPCalendarData.h:1406
CXTPCalendarData::OnTimeZoneChanged
virtual BOOL OnTimeZoneChanged()
This method is called by the calendar control framework when Time Zone is Changed.
Definition XTPCalendarData.h:847
CXTPCalendarData::m_pLabelList
CXTPCalendarEventLabels * m_pLabelList
Event labels list.
Definition XTPCalendarData.h:879
CXTPCalendarData::AddEvents
virtual BOOL AddEvents(CXTPCalendarEvents *pEvents)
Creates a set of events in the data source.
CXTPCalendarData::GetDataSource
virtual CString GetDataSource()
Returns a data provider data source.
CXTPCalendarData::Save
virtual BOOL Save()
This method saves data to the file.
Definition XTPCalendarData.h:1357
CXTPCalendarData::Create
virtual BOOL Create()
Call this member function to create a file for storing custom data provider data.
Definition XTPCalendarData.h:1348
CXTPCalendarData::m_typeProvider
XTPCalendarDataProvider m_typeProvider
Data provider type.
Definition XTPCalendarData.h:887
CXTPCalendarData::SetCacheMode
virtual void SetCacheMode(int eCacheMode, CXTPCalendarData *pCacheDataProvider=NULL)
Sets common data provider cache mode.
CXTPCalendarData::ms_dwNextFreeTempID
static DWORD ms_dwNextFreeTempID
Next unique event ID.
Definition XTPCalendarData.h:1216
CXTPCalendarData::RestoreEventCategoryList
virtual void RestoreEventCategoryList()
Call this member function to restore the event category list to default values.
CXTPCalendarData::DoRemoveAllEvents
virtual void DoRemoveAllEvents()
Removes all events from the data source.
CXTPCalendarData::DoRetrieveDayEvents
virtual CXTPCalendarEventsPtr DoRetrieveDayEvents(COleDateTime dtDay)
Retrieves day events for a specified day from the data source.
CXTPCalendarData::m_pEventCategories
CXTPCalendarEventCategories * m_pEventCategories
Store a collection of Event categories.
Definition XTPCalendarData.h:881
CXTPCalendarData::SetLabelList
virtual void SetLabelList(CXTPCalendarEventLabels *pLabelList)
Set custom collection of Labels to be used in this Data source.
CXTPCalendarData::GetConnection
virtual CXTPNotifyConnection * GetConnection() const
Returns a connection pointer for the data source.
Definition XTPCalendarData.h:1369
CXTPCalendarData::CreateNewRecurrencePattern
virtual CXTPCalendarRecurrencePatternPtr CreateNewRecurrencePattern(DWORD dwPatternID=XTP_CALENDAR_UNKNOWN_RECURRENCE_PATTERN_ID)
Creates a new empty CXTPCalendarRecurrencePattern object.
CXTPCalendarData::ClearCache
virtual void ClearCache()
Clears common data provider cache.
CXTPCalendarData::RestoreEventLabelList
virtual void RestoreEventLabelList()
Call this member function to restore the event label list to default values.
CXTPCalendarData::AddEventCategory
virtual BOOL AddEventCategory(UINT uID, CString strName, COLORREF crBorder, COLORREF crBkBase)
Call this member function to add a new item to the event category list.
CXTPCalendarData::ChangeEvent
virtual BOOL ChangeEvent(CXTPCalendarEvent *pNewEvent)
Updates event properties in the data source.
CXTPCalendarData::GetUpcomingEvents
virtual CXTPCalendarEventsPtr GetUpcomingEvents(COleDateTime dtFrom=(DATE) 0, COleDateTimeSpan spPeriod=(DATE) 0)
Retrieves a collection of events expiring in the period from dtFrom during next spPeriod.
CXTPCalendarData::Close
virtual void Close()
Call this member function to close the connection to a data source.
Definition XTPCalendarData.h:1362
CXTPCalendarData::DoGetAllEvents_raw
virtual CXTPCalendarEventsPtr DoGetAllEvents_raw()
Retrieves all events without generating recurrence occurrences.
CXTPCalendarData::CreateNewEvent
virtual CXTPCalendarEventPtr CreateNewEvent(DWORD dwEventID=XTP_CALENDAR_UNKNOWN_EVENT_ID)
Creates a new empty CXTPCalendarEvent object.
CXTPCalendarData::GetNextFreeTempID
static DWORD AFX_CDECL GetNextFreeTempID()
Call this member function to get a unique temporary event ID.
Definition XTPCalendarData.h:1373
CXTPCalendarEventCategories
This class is used as a collection of CXTPCalendarEventCategory objects.
Definition XTPCalendarEventLabel.h:440
CXTPCalendarEvent
This class represents the data of a single Event used in the Calendar control.
Definition XTPCalendarEvent.h:77
CXTPCalendarEventLabels
This class is used as a collection of CXTPCalendarEventLabel objects.
Definition XTPCalendarEventLabel.h:120
CXTPCalendarEvents
This class represents a simple array collection of CXTPCalendarEvent objects.
Definition XTPCalendarEvents.h:55
CXTPCalendarOptions
Structure contains all calendar options.
Definition XTPCalendarOptions.h:77
CXTPCalendarRecurrencePattern
This class represents a recurrence pattern and stores data to build a schedule for recurrence events.
Definition XTPCalendarRecurrencePattern.h:398
CXTPCalendarSchedules
This class represents a simple array collection of CXTPCalendarSchedule objects.
Definition XTPCalendarResource.h:175
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPNotifyConnection
This class is used as implementation of Connection interface in a XTPNotification mechanism.
Definition XTPNotifyConnection.h:88
CXTPSmartPtrInternalT
Definition XTPSmartPtrInternalT.h:72


Toolkit Pro: Member List

CXTPWindowPos Member List

This is the complete list of members for CXTPWindowPos, including all inherited members.

CXTPWindowPos() | CXTPWindowPos
LoadWindowPos(LPCTSTR lpszWndPos=NULL, LPCTSTR lpszSection=NULL) | CXTPWindowPos
LoadWindowPos(CWnd *pWnd, LPCTSTR lpszWndPos=NULL, LPCTSTR lpszSection=NULL) | CXTPWindowPos
SaveWindowPos(CWnd *pWnd, LPCTSTR lpszWndPos=NULL, LPCTSTR lpszSection=NULL) | CXTPWindowPos


Toolkit Pro: Member List

CXTPComboBoxThemeResource Member List

This is the complete list of members for CXTPComboBoxThemeResource, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPComboBoxTheme() | CXTPComboBoxTheme |
CXTPComboBoxThemeResource() | CXTPComboBoxThemeResource |
CXTPControlTheme() | CXTPControlTheme |
DrawBackground(CDC *pDC, CXTPComboBox *pComboBox) | CXTPComboBoxTheme | virtual
DrawButton(CDC *pDC, CXTPComboBox *pComboBox, CRect rcBtn) | CXTPComboBoxTheme | virtual
DrawButtonTriangle(CDC *pDC, CXTPComboBox *pComboBox, CRect rcBtn) | CXTPComboBoxTheme | virtual
DrawComboBox(CDC *pDC, CXTPComboBox *pComboBox) | CXTPComboBoxThemeResource | virtual
DrawFrame(HDC hdc, LPRECT lprc, int nSize, HBRUSH hBrush) | CXTPComboBoxTheme | virtual
FillSolidRect(HDC hdc, int x, int y, int cx, int cy, HBRUSH hBrush) | CXTPComboBoxTheme | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetBackColor() const | CXTPComboBoxTheme |
GetBackgroundBrush() const | CXTPComboBoxTheme |
GetTextColor() const | CXTPComboBoxTheme |
GetThemeStyle() const | CXTPControlTheme |
m_clrBackDisabled | CXTPComboBoxTheme |
m_clrBackground | CXTPComboBoxTheme |
m_clrBackHighlight | CXTPComboBoxTheme |
m_clrBorderDisabled | CXTPComboBoxTheme |
m_clrBorderHot | CXTPComboBoxTheme |
m_clrBorderNormal | CXTPComboBoxTheme |
m_clrButtonArrowHot | CXTPComboBoxTheme |
m_clrButtonArrowNormal | CXTPComboBoxTheme |
m_clrButtonArrowPressed | CXTPComboBoxTheme |
m_clrButtonHot | CXTPComboBoxTheme |
m_clrButtonNormal | CXTPComboBoxTheme |
m_clrButtonPressed | CXTPComboBoxTheme |
m_clrText | CXTPComboBoxTheme |
m_clrTextDisabled | CXTPComboBoxTheme |
m_clrTextHighlight | CXTPComboBoxTheme |
m_grcButton | CXTPComboBoxTheme |
m_grcButtonHilite | CXTPComboBoxTheme |
m_grcButtonPushed | CXTPComboBoxTheme |
m_nTheme | CXTPControlTheme | protected
m_nThumbWidth | CXTPComboBoxTheme | protected
m_themeComboBox | CXTPComboBoxTheme | protected
m_xtpBrushBackground | CXTPComboBoxTheme | protected
RefreshMetrics(CXTPComboBox *pComboBox) | CXTPComboBoxThemeResource | virtual
ResetBackColor() | CXTPComboBoxTheme |
ResetTextColor() | CXTPComboBoxTheme |
SetBackColor(COLORREF clrBackground) | CXTPComboBoxTheme |
SetTextColor(COLORREF clrText) | CXTPComboBoxTheme |
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static
UpdateBackgroundBrush() | CXTPComboBoxTheme | protected
~CXTPComboBoxTheme() | CXTPComboBoxTheme | virtual
~CXTPComboBoxThemeResource() | CXTPComboBoxThemeResource | virtual


Toolkit Pro: XTPSyntaxEditAutoCompleteWnd.h Source File

  • Source
  • SyntaxEdit
XTPSyntaxEditAutoCompleteWnd.h
Go to the documentation of this file.
1
23#if !defined(__XTPSYNTAXEDITAUTOCOMPLETEWND_H__)
24# define __XTPSYNTAXEDITAUTOCOMPLETEWND_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPSyntaxEditCtrl;
34class CXTPImageManager;
35
41struct XTP_EDIT_ACDATA
42{
43 int m_nIcon;
44 CString m_strText;
52 XTP_EDIT_ACDATA(int nIcon, CString strText)
53 {
54 m_nIcon = nIcon;
55 m_strText = strText;
56 }
57};
58
66typedef CArray<XTP_EDIT_ACDATA*, XTP_EDIT_ACDATA*> CXTPSyntaxEditACDataArray;
67
73typedef CArray<CRect, CRect> CXTPSyntaxEditACGrid;
74
86class _XTP_EXT_CLASS CXTPSyntaxEditAutoCompleteWnd : public CWnd
87{
89 friend class CXTPSyntaxEditCtrl;
91public:
96 CXTPSyntaxEditAutoCompleteWnd();
97
103 virtual ~CXTPSyntaxEditAutoCompleteWnd();
104
115 virtual BOOL Create(CWnd* pParentWnd);
116
117 using CWnd::Create;
118
135 virtual void SetList(CXTPSyntaxEditACDataArray& parrData);
136
152 virtual void SetOpenTags(CString strOpenTags);
153
161 BOOL IsOpenTag(CString strToTest);
162
178 virtual void SetCloseTags(CString strCloseTags);
179
187 BOOL IsCloseTag(CString strToTest);
188
200 virtual void Show(CPoint pt, CString strSearch = _T(""));
201
206 virtual void Hide();
207
214 BOOL IsActive() const;
215
220 virtual void RefreshMetrics();
221
229 virtual BOOL RegisterWindowClass(HINSTANCE hInstance = NULL);
230
237 int GetWndWidth() const;
238
244 void SetWndWidth(int nWidth);
245
252 CXTPImageManager* GetImageManager() const;
253
259 void SetDelimiters(CString strDelims);
260
267 CString GetDelimiters();
268
269protected:
277 int HitTest(CPoint ptTest) const;
278
280 // message handlers
281 void OnLButtonDown(UINT nFlags, CPoint point);
282 void OnRButtonDown(UINT nFlags, CPoint point);
283 void OnLButtonDblClk(UINT nFlags, CPoint point);
284 BOOL OnMouseWheel(UINT nFlags, short zDelta, CPoint pt);
285 void OnKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags);
286 void OnChar(UINT nChar, UINT nRepCnt, UINT nFlags);
287 void OnVScroll(UINT nSBCode, UINT nPos, CScrollBar* pScrollBar);
288 void OnPaint();
289 BOOL OnSetCursor(CWnd* pWnd, UINT nHitTest, UINT message);
290
291 DECLARE_MESSAGE_MAP()
294protected:
295 CString m_strSearch;
297 CString m_strCloseTags;
299 CString m_strTmpCloseTag;
301 CString m_strOpenTags;
303 CString m_strTmpOpenTag;
306 CXTPSyntaxEditCtrl* m_pParentWnd;
308 CXTPFont m_xtpFontBasic;
309 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CFont, m_fontBasic, m_xtpFontBasic, GetBasicFontHandle);
310
311 COLORREF m_clrWindow;
312 COLORREF m_clrHighLight;
313 COLORREF m_clrWindowText;
314 COLORREF m_clrHighLightText;
316 CXTPSyntaxEditACDataArray m_arrACData;
318 CXTPSyntaxEditACDataArray m_arrACDataFiltered;
321 CXTPSyntaxEditACGrid m_arrGrid;
324 int m_nBordersHeight;
325 int m_nLineHeight;
326 int m_nLines;
327 int m_nWndHeight;
328 int m_nWndWidth;
330 int m_nHighLightLine;
331 int m_nFirstDisplayedStr;
333 BOOL m_bFixedBottom;
336 BOOL m_bActive;
338 BOOL m_bFilteredMode;
340 BOOL m_bHighLight;
342 int m_nStartReplacePos;
344 int m_nEndReplacePos;
346 CXTPImageManager* m_pImageManager;
348 CString m_strDelims;
350private:
351 BOOL AdjusLayout(int nHeightMax = 0);
352 void _AdjustWndRect(CRect& rrcWndRect);
353
354 void RemoveAll();
355
356 BOOL ScrollTo(int nNewLine);
357
358 void UpdateFilteredList();
359
360 void ReturnSelected(BOOL bAdjust = FALSE);
361
362 void Sort();
363
364 static int AFX_CDECL CompareACData(const XTP_EDIT_ACDATA** p1, const XTP_EDIT_ACDATA** p2);
365
366 int Search(CString strSearch = _T(""));
367
368 int Filter(CString strSearch = _T(""));
369
370 static int AFX_CDECL CompareACDataToSearch(const XTP_EDIT_ACDATA** ppKey,
371 const XTP_EDIT_ACDATA** ppElem);
372
373protected:
374 CXTPSyntaxEditACDataArray m_InsertItems;
375 CXTPSyntaxEditACDataArray m_RemoveItems;
376
377public:
378 void InsertItem(int iconID, CString str);
379 void RemoveItem(CString str);
380
381protected:
382# ifdef _XTP_ACTIVEX
385 DECLARE_DISPATCH_MAP()
386 DECLARE_INTERFACE_MAP()
387
388 DECLARE_OLETYPELIB_EX(CXTPSyntaxEditAutoCompleteWnd)
389
390 afx_msg LPDISPATCH OleGetIcons();
391 afx_msg void OleSetIcons(LPDISPATCH lpDispatch);
392 afx_msg void OleInsertItem(int nID, const LPCTSTR str);
393 afx_msg void OleRemoveItem(const LPCTSTR str);
394 afx_msg bool OleIsExistItem(const LPCTSTR str);
395 afx_msg void OleSetDelimiters(LPCTSTR pcszConfigFileName);
396 afx_msg BSTR OleGetDelimiters();
397
399# endif
400};
401
403AFX_INLINE int CXTPSyntaxEditAutoCompleteWnd::GetWndWidth() const
404{
405 return m_nWndWidth;
406}
407AFX_INLINE BOOL CXTPSyntaxEditAutoCompleteWnd::IsActive() const
408{
409 return m_bActive;
410}
411AFX_INLINE void CXTPSyntaxEditAutoCompleteWnd::InsertItem(int iconID, CString str)
412{
413 m_InsertItems.Add(new XTP_EDIT_ACDATA(iconID, str));
414}
415AFX_INLINE void CXTPSyntaxEditAutoCompleteWnd::RemoveItem(CString str)
416{
417 m_RemoveItems.Add(new XTP_EDIT_ACDATA(-1, str));
418}
419AFX_INLINE CXTPImageManager* CXTPSyntaxEditAutoCompleteWnd::GetImageManager() const
420{
421 return m_pImageManager;
422}
423AFX_INLINE void CXTPSyntaxEditAutoCompleteWnd::SetDelimiters(CString strDelims)
424{
425 m_strDelims = strDelims;
426}
427AFX_INLINE CString CXTPSyntaxEditAutoCompleteWnd::GetDelimiters()
428{
429 return m_strDelims;
430}
431
432# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
434#endif // !defined(__XTPSYNTAXEDITAUTOCOMPLETEWND_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPSyntaxEditACDataArray
CArray< XTP_EDIT_ACDATA *, XTP_EDIT_ACDATA * > CXTPSyntaxEditACDataArray
The CXTPSyntaxEditACDataArray type defines a custom array to store auto-complete items' displayed dat...
Definition XTPSyntaxEditAutoCompleteWnd.h:66
CXTPSyntaxEditACGrid
CArray< CRect, CRect > CXTPSyntaxEditACGrid
The CXTPSyntaxEditACGrid type defines a custom array to store and manage visible rectangle arrays tha...
Definition XTPSyntaxEditAutoCompleteWnd.h:73
CXTPFont
Provides a convenient object oriented interface for HFONT GDI object and uses GDI handle caching.
Definition XTPGdiObjects.h:414
CXTPImageManager
CXTPImageManager is a standalone class.
Definition XTPImageManager.h:1898
CXTPSyntaxEditAutoCompleteWnd
This class implements the auto-complete window.
Definition XTPSyntaxEditAutoCompleteWnd.h:87
CXTPSyntaxEditAutoCompleteWnd::GetWndWidth
int GetWndWidth() const
Gets the width of the auto-complete window.
Definition XTPSyntaxEditAutoCompleteWnd.h:403
CXTPSyntaxEditAutoCompleteWnd::IsCloseTag
BOOL IsCloseTag(CString strToTest)
Determines if a specified string contains close tags.
CXTPSyntaxEditAutoCompleteWnd::~CXTPSyntaxEditAutoCompleteWnd
virtual ~CXTPSyntaxEditAutoCompleteWnd()
Destroys a CXTPSyntaxEditAutoCompleteWnd object, handles cleanup and de-allocation.
CXTPSyntaxEditAutoCompleteWnd::m_bActive
BOOL m_bActive
Active flag.
Definition XTPSyntaxEditAutoCompleteWnd.h:336
CXTPSyntaxEditAutoCompleteWnd::GetDelimiters
CString GetDelimiters()
Retrieves the char list that are tag delimiters.
Definition XTPSyntaxEditAutoCompleteWnd.h:427
CXTPSyntaxEditAutoCompleteWnd::m_nWndWidth
int m_nWndWidth
Width of the window.
Definition XTPSyntaxEditAutoCompleteWnd.h:328
CXTPSyntaxEditAutoCompleteWnd::SetDelimiters
void SetDelimiters(CString strDelims)
Sets the char list that are tag delimiters.
Definition XTPSyntaxEditAutoCompleteWnd.h:423
CXTPSyntaxEditAutoCompleteWnd::HitTest
int HitTest(CPoint ptTest) const
Gets the integer identfier of the text line at a specified point.
CXTPSyntaxEditAutoCompleteWnd::RegisterWindowClass
virtual BOOL RegisterWindowClass(HINSTANCE hInstance=NULL)
Registers the window class if it has not already been registered.
CXTPSyntaxEditAutoCompleteWnd::SetWndWidth
void SetWndWidth(int nWidth)
Sets the width for the auto-complete window.
CXTPSyntaxEditAutoCompleteWnd::m_pImageManager
CXTPImageManager * m_pImageManager
Images for auto-complete list.
Definition XTPSyntaxEditAutoCompleteWnd.h:346
CXTPSyntaxEditAutoCompleteWnd::IsActive
BOOL IsActive() const
Determines if the auto-complete window is visible and active.
Definition XTPSyntaxEditAutoCompleteWnd.h:407
CXTPSyntaxEditAutoCompleteWnd::CXTPSyntaxEditAutoCompleteWnd
CXTPSyntaxEditAutoCompleteWnd()
Default class constructor.
CXTPSyntaxEditAutoCompleteWnd::SetCloseTags
virtual void SetCloseTags(CString strCloseTags)
Sets the list of close tags for the auto-complete window.
CXTPSyntaxEditAutoCompleteWnd::Show
virtual void Show(CPoint pt, CString strSearch=_T(""))
Shows the auto-complete window.
CXTPSyntaxEditAutoCompleteWnd::SetOpenTags
virtual void SetOpenTags(CString strOpenTags)
Sets the list of open tags for the auto-complete window.
CXTPSyntaxEditAutoCompleteWnd::SetList
virtual void SetList(CXTPSyntaxEditACDataArray &parrData)
Sets the list of data to be displayed in the auto-complete window.
CXTPSyntaxEditAutoCompleteWnd::Hide
virtual void Hide()
Hides the auto-complete window.
CXTPSyntaxEditAutoCompleteWnd::m_strDelims
CString m_strDelims
Stores char list that are tag delimiters.
Definition XTPSyntaxEditAutoCompleteWnd.h:348
CXTPSyntaxEditAutoCompleteWnd::IsOpenTag
BOOL IsOpenTag(CString strToTest)
Determines if a specified string contains open tags.
CXTPSyntaxEditAutoCompleteWnd::GetImageManager
CXTPImageManager * GetImageManager() const
Retrieves the image manager for the items.
Definition XTPSyntaxEditAutoCompleteWnd.h:419
CXTPSyntaxEditAutoCompleteWnd::RefreshMetrics
virtual void RefreshMetrics()
Updates display settings from system settings.
CXTPSyntaxEditAutoCompleteWnd::Create
virtual BOOL Create(CWnd *pParentWnd)
Creates an auto-complete window and sets its predefined properties.
CXTPSyntaxEditCtrl
This class is the main CWnd-based editor class.
Definition XTPSyntaxEditCtrl.h:114
XTP_EDIT_ACDATA
The XTP_EDIT_ACDATA structure defines items' displayed data and provides text and icons for each disp...
Definition XTPSyntaxEditAutoCompleteWnd.h:42
XTP_EDIT_ACDATA::m_strText
CString m_strText
The item text.
Definition XTPSyntaxEditAutoCompleteWnd.h:44
XTP_EDIT_ACDATA::XTP_EDIT_ACDATA
XTP_EDIT_ACDATA(int nIcon, CString strText)
Default class constructor.
Definition XTPSyntaxEditAutoCompleteWnd.h:52
XTP_EDIT_ACDATA::m_nIcon
int m_nIcon
The icon ID.
Definition XTPSyntaxEditAutoCompleteWnd.h:43


Toolkit Pro: Member List

CXTPChartPyramidSeriesStyle Member List

This is the complete list of members for CXTPChartPyramidSeriesStyle, including all inherited members.

ApplyTo(CXTPChartDeviceCommand *pCommand) | CXTPChartSeriesStyle | virtual
CorrectAxisSideMargins(CXTPChartAxis *pAxis, double nMinValue, double nMaxValue, double &nCorrection) | CXTPChartSeriesStyle | virtual
CreateDiagram() | CXTPChartPyramidSeriesStyle | protectedvirtual
CreateView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView) | CXTPChartPyramidSeriesStyle | protectedvirtual
CXTPChartElement() | CXTPChartElement |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartPyramidSeriesStyle() | CXTPChartPyramidSeriesStyle |
CXTPChartPyramidSeriesStyleBase() | CXTPChartPyramidSeriesStyleBase |
CXTPChartSeriesStyle() | CXTPChartSeriesStyle |
DoPropExchange(CXTPPropExchange *pPX) | CXTPChartPyramidSeriesStyleBase | virtual
Enable3dEdgeSmoothing(BOOL bEnable=TRUE) | CXTPChartSeriesStyle | virtual
Get3dRotation() const | CXTPChartSeriesStyle | virtual
GetAppearance() const | CXTPChartElement |
GetBorder() const | CXTPChartPyramidSeriesStyleBase |
GetColor() const | CXTPChartSeriesStyle | virtual
GetContent() const | CXTPChartElement |
GetErrorBar() const | CXTPChartSeriesStyle | virtual
GetFillStyle() const | CXTPChartPyramidSeriesStyleBase |
GetHeightToWidthRatio() const | CXTPChartPyramidSeriesStyleBase |
GetLabel() const | CXTPChartSeriesStyle | virtual
GetOwner() const | CXTPChartElement |
GetPointDistance() const | CXTPChartPyramidSeriesStyleBase |
GetSeriesPointValueIndex() const | CXTPChartSeriesStyle | virtual
GetStyleAppearance() const | CXTPChartSeriesStyle | virtual
GetTransparency() const | CXTPChartSeriesStyle | virtual
Is3D() const | CXTPChartObject |
Is3dEdgeSmoothingEnabled() const | CXTPChartSeriesStyle | virtual
IsColorEach() const | CXTPChartSeriesStyle | virtual
IsStyleDiagram(CXTPChartDiagram *pDiagram) const | CXTPChartPyramidSeriesStyle | protectedvirtual
m_bColorEach | CXTPChartSeriesStyle | protected
m_bSmooth3dEdges | CXTPChartSeriesStyle | protected
m_clrColor | CXTPChartSeriesStyle | protected
m_nTransparency | CXTPChartSeriesStyle | protected
m_pErrorBar | CXTPChartSeriesStyle | protected
m_pLabel | CXTPChartSeriesStyle | protected
m_Rotation3d | CXTPChartSeriesStyle | protected
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartElement | virtual
Release() | CXTPChartElement | virtual
Set3dRotation(const CXTPChart3dRotation &rotation) | CXTPChartSeriesStyle | virtual
Set3dRotation(double dYaw, double dPitch, double dRoll) | CXTPChartSeriesStyle | virtual
SetColor(CXTPChartColor clr) | CXTPChartSeriesStyle | virtual
SetColorEach(BOOL bColorEach) | CXTPChartSeriesStyle | virtual
SetErrorBar(CXTPChartErrorBar *pErrorBar) | CXTPChartSeriesStyle | virtual
SetHeightToWidthRatio(double dRatio) | CXTPChartPyramidSeriesStyleBase |
SetLabel(CXTPChartSeriesLabel *pLabel) | CXTPChartSeriesStyle | virtual
SetPointDistance(int nPointDistance) | CXTPChartPyramidSeriesStyleBase |
SetTransparency(int nTransparency) | CXTPChartSeriesStyle | virtual
~CXTPChartElement() | CXTPChartElement | virtual
~CXTPChartPyramidSeriesStyleBase() | CXTPChartPyramidSeriesStyleBase | virtual
~CXTPChartSeriesStyle() | CXTPChartSeriesStyle | virtual


Toolkit Pro: Member List

CXTPControlAction Member List

This is the complete list of members for CXTPControlAction, including all inherited members.

AddControl(CXTPControl *pControl) | CXTPControlAction | protected
CXTPCmdTarget() | CXTPCmdTarget |
CXTPControlAction(CXTPControlActions *pActions) | CXTPControlAction | protected
DoPropExchange(CXTPPropExchange *pPX) | CXTPControlAction |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCaption() const | CXTPControlAction |
GetCategory() const | CXTPControlAction |
GetChecked() const | CXTPControlAction |
GetCommandBars() const | CXTPControlAction |
GetControl(int nIndex) const | CXTPControlAction |
GetCount() const | CXTPControlAction |
GetCustomShortcutText() const | CXTPControlAction |
GetDescription() const | CXTPControlAction |
GetEditHint() const | CXTPControlAction |
GetEnabled() const | CXTPControlAction |
GetHelpId() const | CXTPControlAction |
GetIconId() const | CXTPControlAction |
GetID() const | CXTPControlAction |
GetKey() const | CXTPControlAction |
GetKeyboardTip() const | CXTPControlAction |
GetShortcutText() const | CXTPControlAction |
GetTag() const | CXTPControlAction |
GetTooltip() const | CXTPControlAction |
IsVisible() const | CXTPControlAction |
m_arrControls | CXTPControlAction | protected
m_bChecked | CXTPControlAction | protected
m_bEnabled | CXTPControlAction | protected
m_bVisible | CXTPControlAction | protected
m_nHelpId | CXTPControlAction | protected
m_nIconId | CXTPControlAction | protected
m_nId | CXTPControlAction | protected
m_nTag | CXTPControlAction | protected
m_pActions | CXTPControlAction | protected
m_pTarget | CXTPControlAction |
m_strCaption | CXTPControlAction | protected
m_strCategory | CXTPControlAction | protected
m_strCustomShortcutText | CXTPControlAction | protected
m_strDescriptionText | CXTPControlAction | protected
m_strEditHint | CXTPControlAction | protected
m_strKey | CXTPControlAction | protected
m_strKeyboardTip | CXTPControlAction | protected
m_strShortcutText | CXTPControlAction | protected
m_strTooltipText | CXTPControlAction | protected
OnChanged(int nProperty) | CXTPControlAction | protected
OnChanging(int nProperty) | CXTPControlAction | protected
OnRemoved() | CXTPControlAction | protected
RedrawControls() | CXTPControlAction |
RemoveControl(CXTPControl *pControl) | CXTPControlAction | protected
RepositionControls() | CXTPControlAction |
SetCaption(LPCTSTR lpszCaption) | CXTPControlAction |
SetCaption(UINT nIDCaption) | CXTPControlAction |
SetCategory(LPCTSTR lpszCategory) | CXTPControlAction |
SetChecked(BOOL bChecked) | CXTPControlAction |
SetCustomShortcutText(LPCTSTR lpszCustomShortcutText) | CXTPControlAction |
SetDescription(LPCTSTR lpszDescription) | CXTPControlAction |
SetEditHint(LPCTSTR lpszEditHint) | CXTPControlAction |
SetEnabled(BOOL bEnabled) | CXTPControlAction |
SetHelpId(int nId) | CXTPControlAction |
SetIconId(int nId) | CXTPControlAction |
SetKey(LPCTSTR lpszKey) | CXTPControlAction |
SetKeyboardTip(LPCTSTR lpszKeyboardTip) | CXTPControlAction |
SetPrompt(LPCTSTR lpszPrompt) | CXTPControlAction |
SetShortcutText(LPCTSTR lpszShortcutText) | CXTPControlAction |
SetTag(DWORD_PTR dwTag) | CXTPControlAction |
SetTooltip(LPCTSTR lpszTooltip) | CXTPControlAction |
SetVisible(BOOL bVisible) | CXTPControlAction |
~CXTPControlAction() | CXTPControlAction | protected


Toolkit Pro: XTPPropertyPageNavigator.h Source File

  • Source
  • Controls
  • Dialog
XTPPropertyPageNavigator.h
Go to the documentation of this file.
1
23#if !defined(__XTPPROPERTYPAGENAVIGATOR_H__)
24# define __XTPPROPERTYPAGENAVIGATOR_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPPropertySheet;
34class CXTPPropertyPage;
35
43class _XTP_EXT_CLASS CXTPPropertyPageNavigator
44{
45public:
50 CXTPPropertyPageNavigator();
51
56 virtual ~CXTPPropertyPageNavigator();
57
58public:
65 virtual BOOL Create() = 0;
66
67 virtual void OnPageChanged();
68
78 virtual void PageToSize(AFX_SIZEPARENTPARAMS* pLayout, CSize szPage, CRect& rcPage,
79 CSize& szClient) = 0;
80
89 virtual void SizeToPage(AFX_SIZEPARENTPARAMS* pLayout, CSize szClient, CRect& rcPage) = 0;
90
96 virtual void OnPageSelected(CXTPPropertyPage* pPage) = 0;
97
104 virtual HWND GetSafeHwnd() const = 0;
105
114 virtual HBRUSH GetPageBrush(CDC* pDC, CXTPPropertyPage* pPage) = 0;
115
122 virtual COLORREF GetPageColor() = 0;
123
134 virtual void SetTheme(XTPControlTheme theme);
135
136 XTPControlTheme GetTheme();
137
138protected:
139 virtual void SetPropertySheet(CXTPPropertySheet* pSheet);
140
141public:
142 CRect m_rcNavigatorMargin;
143 CRect m_rcButtonMargin;
144 CRect m_rcPageMargin;
145protected:
146 CXTPPropertySheet* m_pSheet;
148 XTPControlTheme m_themeCurrent;
149
150 friend class CXTPPropertySheet;
151};
152
153# if defined(_XTP_INCLUDE_TABMANAGER)
154
162class _XTP_EXT_CLASS CXTPPropertyPageTabNavigator
163 : public CXTPTabControl
164 , public CXTPPropertyPageNavigator
165{
166public:
171 CXTPPropertyPageTabNavigator();
172
174public:
175 virtual BOOL Create();
176 virtual void OnPageChanged();
177
178 using CXTPTabControl::Create;
179
180 void PageToSize(AFX_SIZEPARENTPARAMS* pLayout, CSize szPage, CRect& rcPage, CSize& szClient);
181 void SizeToPage(AFX_SIZEPARENTPARAMS* pLayout, CSize szClient, CRect& rcPage);
182
183 virtual void OnPageSelected(CXTPPropertyPage* pPage);
184 virtual HWND GetSafeHwnd() const
185 {
186 return m_hWnd;
187 }
188 virtual HBRUSH GetPageBrush(CDC* pDC, CXTPPropertyPage* pPage);
189 virtual COLORREF GetPageColor()
190 {
191 return m_clrBrush;
192 }
193
194 virtual void SetTheme(XTPControlTheme theme);
195
196protected:
197 void SetSelectedItem(CXTPTabManagerItem* pItem);
198
199protected:
200 DECLARE_MESSAGE_MAP()
201 afx_msg void OnSysColorChange();
202
203private:
204 CXTPBrush m_brushPage;
205 COLORREF m_clrBrush;
207};
208
209# endif // #if defined(_XTP_INCLUDE_TABMANAGER)
210
218class _XTP_EXT_CLASS CXTPPropertyPageControlNavigator : public CXTPPropertyPageNavigator
219{
220public:
225 CXTPPropertyPageControlNavigator();
226
228public:
229 void PageToSize(AFX_SIZEPARENTPARAMS* pLayout, CSize szPage, CRect& rcPage, CSize& szClient);
230 void SizeToPage(AFX_SIZEPARENTPARAMS* pLayout, CSize szClient, CRect& rcPage);
231 virtual HBRUSH GetPageBrush(CDC* pDC, CXTPPropertyPage* pPage);
232 virtual COLORREF GetPageColor()
233 {
234 return m_clrBrush;
235 }
236
237public:
238 CSize m_szControl;
239
240private:
241 CXTPBrush m_brushPage;
242 COLORREF m_clrBrush;
244};
245
253class _XTP_EXT_CLASS CXTPPropertyPageListNavigator
254 : public CXTPListBox
255 , public CXTPPropertyPageControlNavigator
256{
257public:
262 CXTPPropertyPageListNavigator();
263
265public:
266 virtual BOOL Create();
267 virtual void OnPageChanged();
268
269# if _MSC_VER > 1200
270 using CListBox::Create;
271 using CWnd::Create;
272# endif
273
274 virtual void OnPageSelected(CXTPPropertyPage* pPage);
275 virtual HWND GetSafeHwnd() const
276 {
277 return m_hWnd;
278 }
279 virtual void SetPropertySheet(CXTPPropertySheet* pSheet);
280
281 virtual void SetTheme(XTPControlTheme theme);
282 HBRUSH GetPageBrush(CDC* /*pDC*/, CXTPPropertyPage* /*pPage*/);
283 virtual COLORREF GetPageColor()
284 {
285 return m_clrBrush;
286 }
287
288protected:
289 DECLARE_MESSAGE_MAP()
290
291 afx_msg void OnSelChanged();
292
293public:
294 int m_nItemMargin;
295
296private:
297 CXTPBrush m_brushPage;
298 COLORREF m_clrBrush;
300};
301
309class _XTP_EXT_CLASS CXTPPropertyPageTreeNavigator
310 : public CTreeCtrl
311 , public CXTPPropertyPageControlNavigator
312{
313public:
319 CXTPPropertyPageTreeNavigator(DWORD dwStyle = TVS_SHOWSELALWAYS);
320
322public:
323 virtual BOOL Create();
324 virtual void OnPageChanged();
325
326# if _MSC_VER > 1200
327 using CWnd::Create;
328# endif
329
330 virtual void OnPageSelected(CXTPPropertyPage* pPage);
331 virtual HWND GetSafeHwnd() const
332 {
333 return m_hWnd;
334 }
335 virtual void SetPropertySheet(CXTPPropertySheet* pSheet);
336
337protected:
338 virtual BOOL CreateTree();
339
340protected:
341 DECLARE_MESSAGE_MAP()
342
343 afx_msg void OnSelChanging(NMHDR* pNMHeader, LRESULT* pResult);
344
345protected:
346 DWORD m_dwStyle;
348};
350AFX_INLINE void CXTPPropertyPageNavigator::OnPageChanged()
351{
352 _ASSERTE(FALSE);
353}
355# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
357#endif // !defined(__XTPPROPERTYPAGENAVIGATOR_H__)
XTPControlTheme
XTPControlTheme
Enumeration used to determine the active theme style.
Definition XTPControlTheme.h:43
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPBrush
Provides a convenient object oriented interface for HBRUSH GDI object and uses GDI handle caching.
Definition XTPGdiObjects.h:653
CXTPListBox
CXTPListBox is a CListBox derived class.
Definition XTPListBox.h:127
CXTPPropertyPageControlNavigator
CXTPPropertyPageControlNavigator is a CXTPPropertyPageNavigator derived class.
Definition XTPPropertyPageNavigator.h:219
CXTPPropertyPageControlNavigator::CXTPPropertyPageControlNavigator
CXTPPropertyPageControlNavigator()
Constructs a CXTPPropertyPageControlNavigator object.
CXTPPropertyPage
CXTPPropertyPage is a CPropertyPage derived class.
Definition XTPPropertyPage.h:43
CXTPPropertyPageListNavigator
CXTPPropertyPageListNavigator is a CXTPListBox and CXTPPropertyPageControlNavigator derived class.
Definition XTPPropertyPageNavigator.h:256
CXTPPropertyPageListNavigator::CXTPPropertyPageListNavigator
CXTPPropertyPageListNavigator()
Constructs a CXTPPropertyPageListNavigator object.
CXTPPropertyPageNavigator
CXTPPropertyPageNavigator is a standalone class.
Definition XTPPropertyPageNavigator.h:44
CXTPPropertyPageNavigator::GetSafeHwnd
virtual HWND GetSafeHwnd() const =0
This method is called to get the window handler of a navigator window.
CXTPPropertyPageNavigator::m_pSheet
CXTPPropertySheet * m_pSheet
Parent property sheet object.
Definition XTPPropertyPageNavigator.h:146
CXTPPropertyPageNavigator::OnPageSelected
virtual void OnPageSelected(CXTPPropertyPage *pPage)=0
This method is called when a property page becomes selected.
CXTPPropertyPageNavigator::m_rcNavigatorMargin
CRect m_rcNavigatorMargin
Total navigator margin.
Definition XTPPropertyPageNavigator.h:142
CXTPPropertyPageNavigator::SizeToPage
virtual void SizeToPage(AFX_SIZEPARENTPARAMS *pLayout, CSize szClient, CRect &rcPage)=0
This method is called to reposition a property page using the size of a property sheet.
CXTPPropertyPageNavigator::PageToSize
virtual void PageToSize(AFX_SIZEPARENTPARAMS *pLayout, CSize szPage, CRect &rcPage, CSize &szClient)=0
This method is called to reposition a property sheet using the size of a property page.
CXTPPropertyPageNavigator::Create
virtual BOOL Create()=0
This method is called to create a page navigator.
CXTPPropertyPageNavigator::m_rcPageMargin
CRect m_rcPageMargin
Total page margin.
Definition XTPPropertyPageNavigator.h:144
CXTPPropertyPageNavigator::SetTheme
virtual void SetTheme(XTPControlTheme theme)
Call this member to switch the visual theme of the control.
CXTPPropertyPageNavigator::CXTPPropertyPageNavigator
CXTPPropertyPageNavigator()
Constructs a CXTPPropertyPageNavigator object.
CXTPPropertyPageNavigator::GetPageBrush
virtual HBRUSH GetPageBrush(CDC *pDC, CXTPPropertyPage *pPage)=0
Retrieves page brush.
CXTPPropertyPageNavigator::~CXTPPropertyPageNavigator
virtual ~CXTPPropertyPageNavigator()
Destroys a CXTPPropertyPageNavigator object, handles cleanup and deallocation.
CXTPPropertyPageNavigator::GetPageColor
virtual COLORREF GetPageColor()=0
Retrieves page color.
CXTPPropertyPageNavigator::m_rcButtonMargin
CRect m_rcButtonMargin
Total buttons margin.
Definition XTPPropertyPageNavigator.h:143
CXTPPropertyPageTreeNavigator
CXTPPropertyPageTreeNavigator is a CTreeCtrl and CXTPPropertyPageControlNavigator derived class.
Definition XTPPropertyPageNavigator.h:312
CXTPPropertyPageTreeNavigator::CXTPPropertyPageTreeNavigator
CXTPPropertyPageTreeNavigator(DWORD dwStyle=TVS_SHOWSELALWAYS)
Constructs a CXTPPropertyPageTreeNavigator object.
CXTPPropertySheet
CXTPPropertySheet is a CXTPDialogEx derived class.
Definition XTPPropertySheet.h:65
CXTPTabControl
CXTPTabControl is used to draw an enhanced tab control with Office 2003, Visual Studio,...
Definition XTPTabControl.h:47
CXTPTabControl::Create
BOOL Create(DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID)
Creates the tab control.
Definition XTPTabControl.h:350
CXTPTabManagerItem
CXTPTabManagerItem is the base class for the tabs that appear in the command bars tab workspace,...
Definition XTPTabManagerItem.h:44


Toolkit Pro: Member List

CXTPControlSlider Member List

This is the complete list of members for CXTPControlSlider, including all inherited members.

AssignDocTemplate(UINT nIDResource) | CXTPControl |
ClickToolBarButton(CRect rcActiveRect=CRect(0, 0, 0, 0)) | CXTPControl | protected
Compare(CXTPControl *pOther) | CXTPControl | virtual
Copy(CXTPControl *pControl, BOOL bRecursive=FALSE) | CXTPControl | virtual
CustomizeStartDrag(CPoint point) | CXTPControl | protectedvirtual
CustomizeStartResize(CPoint point) | CXTPControl | protectedvirtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPControl() | CXTPControl | protected
CXTPControlSlider() | CXTPControlSlider |
DelayLayoutParent() | CXTPControl |
DelayRedrawParent() | CXTPControl |
DoCustomDragOver(CXTPCommandBar *pCommandBar, CPoint point, DROPEFFECT &dropEffect) | CXTPControl | protectedvirtual
DoPropExchange(CXTPPropExchange *pPX) | CXTPControl | virtual
Draw(CDC *pDC) | CXTPControl | virtual
ExcludeDocTemplate(UINT nIDResource) | CXTPControl |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
FromUI(CCmdUI *pCmdUI) | CXTPControl | static
GenerateCommandBarList(DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam) | CXTPControl | protectedvirtual
GetAction() const | CXTPControl |
GetBeginGroup() const | CXTPControl |
GetButtonSize() const | CXTPControl | virtual
GetCaption() const | CXTPControl | virtual
GetCategory() const | CXTPControl |
GetChecked() const | CXTPControl |
GetCloseSubMenuOnClick() const | CXTPControl |
GetCommandBar() const | CXTPControl | virtual
GetControls() const | CXTPControl |
GetCustomizeMinHeight() const | CXTPControl | protectedvirtual
GetCustomizeMinWidth() const | CXTPControl | protectedvirtual
GetCustomShortcutText() const | CXTPControl |
GetDescription() const | CXTPControl | virtual
GetEnabled() const | CXTPControl |
GetExecuteOnPressInterval() const | CXTPControl |
GetExpanded() const | CXTPControl |
GetFlags() const | CXTPControl |
GetHeight() const | CXTPControl |
GetHelpId() const | CXTPControl |
GetHideFlags() const | CXTPControl |
GetIconId() const | CXTPControl |
GetIconSize() const | CXTPControl | virtual
GetID() const | CXTPControl |
GetImage(int nWidth=16) const | CXTPControl | virtual
GetImageManager() const | CXTPControl |
GetIndex() const | CXTPControl |
GetKeyboardTip() const | CXTPControl |
GetPaintManager() const | CXTPControl |
GetParameter() const | CXTPControl |
GetParent() const | CXTPControl |
GetPopuped() const | CXTPControl | virtual
GetPos() | CXTPControlSlider |
GetPressed() const | CXTPControl | virtual
GetRect() const | CXTPControl |
GetRibbonGroup() const | CXTPControl |
GetRowRect() const | CXTPControl |
GetSelected() const | CXTPControl | virtual
GetShortcutText() const | CXTPControl |
GetSize(CDC *pDC) | CXTPControl | virtual
GetSliderCtrl() const | CXTPControlSlider |
GetSliderStyle() const | CXTPControlSlider |
GetStyle() const | CXTPControl |
GetTag() const | CXTPControl |
GetTooltip() const | CXTPControl | virtual
GetType() const | CXTPControl |
GetWidth() const | CXTPControl |
GetWrap() const | CXTPControl |
HasDwmCompositedRect() const | CXTPControl |
IsCaptionVisible() const | CXTPControl | virtual
IsCursorOver() const | CXTPControl |
IsCustomizeMode() const | CXTPControl | protected
IsCustomizeMovable() const | CXTPControl | virtual
IsCustomizeResizeAllow() const | CXTPControl | protectedvirtual
IsFocusable() const | CXTPControl | protectedvirtual
IsFocused() const | CXTPControl | virtual
IsItemDefault() const | CXTPControl |
IsLayoutChanged() | CXTPControl | protected
IsLayoutRTL() const | CXTPControl | protected
IsOnQuickAccess() const | CXTPControl |
IsTemporary() const | CXTPControl |
IsTransparent() const | CXTPControl | inlinevirtual
IsVisible(DWORD dwSkipFlags=0) const | CXTPControl | virtual
m_bBeginGroup | CXTPControl | protected
m_bChecked | CXTPControl | protected
m_bCloseSubMenuOnClick | CXTPControl | protected
m_bDefaultItem | CXTPControl | protected
m_bEnabled | CXTPControl | protected
m_bExpanded | CXTPControl | protected
m_bLayoutRTL | CXTPControl | protected
m_bOnQuickAccess | CXTPControl | protected
m_bPressed | CXTPControl | protected
m_bSelected | CXTPControl | protected
m_bTemporary | CXTPControl | protected
m_buttonCustomStyle | CXTPControl | protected
m_buttonRibbonStyle | CXTPControl | protected
m_buttonStyle | CXTPControl | protected
m_bWrap | CXTPControl | protected
m_controlType | CXTPControl | protected
m_dwFlags | CXTPControl | protected
m_dwHideFlags | CXTPControl | protected
m_dwSliderStyle | CXTPControlSlider | protected
m_mapDocTemplatesAssigned | CXTPControl | protected
m_mapDocTemplatesExcluded | CXTPControl | protected
m_nCustomIconId | CXTPControl | protected
m_nExecuteOnPressInterval | CXTPControl | protected
m_nHeight | CXTPControl | protected
m_nHelpId | CXTPControl | protected
m_nIconId | CXTPControl | protected
m_nId | CXTPControl | protected
m_nIndex | CXTPControl | protected
m_nMax | CXTPControlSlider | protected
m_nMin | CXTPControlSlider | protected
m_nPos | CXTPControlSlider | protected
m_nTag | CXTPControl | protected
m_nWidth | CXTPControl | protected
m_pAction | CXTPControl | protected
m_pControls | CXTPControl | protected
m_pParent | CXTPControl | protected
m_pRibbonGroup | CXTPControl | protected
m_pSliderCtrl | CXTPControlSlider | protected
m_rcControl | CXTPControl | protected
m_rcPadding | CXTPControlSlider | protected
m_rcRow | CXTPControl | protected
m_strCaption | CXTPControl | protected
m_strCategory | CXTPControl | protected
m_strCustomCaption | CXTPControl | protected
m_strDescriptionText | CXTPControl | protected
m_strKeyboardTip | CXTPControl | protected
m_strParameter | CXTPControl | protected
m_strShortcutText | CXTPControl | protected
m_strShortcutTextAuto | CXTPControl | protected
m_strTooltipText | CXTPControl | protected
m_szIcon | CXTPControl | protected
NotifySite(UINT code) | CXTPControl |
NotifySite(UINT code, NMXTPCONTROL *pNM) | CXTPControl |
NotifySite(CWnd *pSite, UINT code, NMXTPCONTROL *pNM) | CXTPControl |
OnActionChanged(int nProperty) | CXTPControl | protectedvirtual
OnActionChanging(int nProperty) | CXTPControl | protectedvirtual
OnCalcDynamicSize(DWORD dwMode) | CXTPControl | virtual
OnCaptionChanged() | CXTPControl | protectedvirtual
OnClick(BOOL bKeyboard=FALSE, CPoint pt=CPoint(0, 0)) | CXTPControl | virtual
OnCustomizeDragOver(CXTPControl *pDataObject, CPoint point, DROPEFFECT &dropEffect) | CXTPControl | protectedvirtual
OnCustomizeMouseMove(CPoint point) | CXTPControl | protected
OnEnabledChanged() | CXTPControlSlider | virtual
OnExecute() | CXTPControl | virtual
OnHookKeyDown(UINT nChar, LPARAM lParam) | CXTPControl | protectedvirtual
OnHookMouseWheel(UINT nFlags, short zDelta, CPoint point) | CXTPControl | protectedvirtual
OnIdleUpdate() | CXTPControl | protectedvirtual
OnLButtonDblClk(CPoint point) | CXTPControl | protectedvirtual
OnLButtonDown(CPoint point) | CXTPControl | protectedvirtual
OnLButtonUp(CPoint point) | CXTPControl | protectedvirtual
OnMouseHover() | CXTPControl | protectedvirtual
OnMouseMove(CPoint point) | CXTPControl | protectedvirtual
OnRButtonDown(CPoint point) | CXTPControl | protectedvirtual
OnRButtonUp(CPoint point) | CXTPControl | protectedvirtual
OnRemoved() | CXTPControl | protectedvirtual
OnScroll(UINT nSBCode, UINT nPos) | CXTPControlSlider | protectedvirtual
OnSetPopup(BOOL bPopup) | CXTPControl | protectedvirtual
OnSetSelected(int bSelected) | CXTPControl | protectedvirtual
OnThemeChanged() | CXTPControl | virtual
OnToolHitTest(CPoint point, TOOLINFO *pTI) const | CXTPControl | protectedvirtual
OnUnderlineActivate() | CXTPControl | virtual
RedrawParent(BOOL bAnimate=TRUE) | CXTPControl |
Reset() | CXTPControl |
RestoreCommandBarList(CXTPCommandBarList *pCommandBarList) | CXTPControl | protectedvirtual
ScreenToClient(CPoint *point) | CXTPControl | protected
SetAction(CXTPControlAction *pAction) | CXTPControl | virtual
SetBeginGroup(BOOL bBeginGroup) | CXTPControl | virtual
SetCaption(LPCTSTR lpszCaption) | CXTPControl |
SetCaption(UINT nIDCaption) | CXTPControl |
SetCategory(LPCTSTR lpszCategory) | CXTPControl |
SetChecked(BOOL bChecked) | CXTPControl | virtual
SetCloseSubMenuOnClick(BOOL bCloseOnClick) | CXTPControl |
SetCustomIcon(HICON hIcon) | CXTPControl |
SetCustomShortcutText(LPCTSTR lpszCustomShortcutText) | CXTPControl |
SetDescription(LPCTSTR lpszDescription) | CXTPControl |
SetEnabled(BOOL bEnabled) | CXTPControl | virtual
SetExecuteOnPressInterval(int nExecuteOnPressInterval) | CXTPControl |
SetExpanded(BOOL bExpanded) | CXTPControl | protected
SetFlags(DWORD dwFlags) | CXTPControl |
SetFocused(BOOL bFocused) | CXTPControl | virtual
SetHeight(int nHeight) | CXTPControl | virtual
SetHelpId(int nId) | CXTPControl |
SetHideFlag(XTPControlHideFlags dwFlag, BOOL bSet) | CXTPControl |
SetHideFlags(DWORD dwFlags) | CXTPControl | virtual
SetHideWrap(BOOL bHide) | CXTPControl |
SetIconId(int nId) | CXTPControl |
SetIconSize(CSize szIcon) | CXTPControl |
SetID(int nId) | CXTPControl |
SetIndex(int nIndex) | CXTPControl | inlineprotected
SetItemDefault(BOOL bDefault) | CXTPControl |
SetKeyboardTip(LPCTSTR lpszKeyboardTip) | CXTPControl |
SetOnQuickAccess(BOOL bOnQuicAccess=FALSE) | CXTPControl |
SetParameter(LPCTSTR lpszParameter) | CXTPControl |
SetParent(CXTPCommandBar *pParent) | CXTPControl | inlineprotectedvirtual
SetPos(int nPos) | CXTPControlSlider |
SetPressed(BOOL bPressed) | CXTPControl |
SetPrompt(LPCTSTR lpszPrompt) | CXTPControl |
SetRange(int nMin, int nMax) | CXTPControlSlider |
SetRect(CRect rcControl) | CXTPControl | virtual
SetRowRect(CRect rcRow) | CXTPControl |
SetShortcutText(LPCTSTR lpszShortcutText) | CXTPControl |
SetSliderStyle(DWORD dwStyle) | CXTPControlSlider |
SetStyle(XTPButtonStyle buttonStyle) | CXTPControl |
SetTag(DWORD_PTR dwTag) | CXTPControl |
SetTooltip(LPCTSTR lpszTooltip) | CXTPControl |
SetVisible(BOOL bVisible) | CXTPControl |
SetWidth(int nWidth) | CXTPControl | virtual
SetWrap(BOOL bWrap) | CXTPControl |
~CXTPControl() | CXTPControl | protectedvirtual
~CXTPControlSlider() | CXTPControlSlider | virtual


Toolkit Pro: Member List

CXTPPropertyGridInplaceButton Member List

This is the complete list of members for CXTPPropertyGridInplaceButton, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPPropertyGridInplaceButton(UINT nID) | CXTPPropertyGridInplaceButton |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAlignment() const | CXTPPropertyGridInplaceButton |
GetCaption() const | CXTPPropertyGridInplaceButton |
GetEnabled() const | CXTPPropertyGridInplaceButton |
GetGrid() const | CXTPPropertyGridInplaceButton |
GetIconIndex() const | CXTPPropertyGridInplaceButton |
GetID() const | CXTPPropertyGridInplaceButton |
GetImage() const | CXTPPropertyGridInplaceButton | virtual
GetIndex() const | CXTPPropertyGridInplaceButton |
GetItem() const | CXTPPropertyGridInplaceButton |
GetRect() const | CXTPPropertyGridInplaceButton |
GetShowAlways() const | CXTPPropertyGridInplaceButton |
GetTabStop() const | CXTPPropertyGridInplaceButton |
GetTooltip() const | CXTPPropertyGridInplaceButton |
GetWidth() | CXTPPropertyGridInplaceButton |
IsFocused() const | CXTPPropertyGridInplaceButton |
IsHot() const | CXTPPropertyGridInplaceButton |
IsHyperlink() const | CXTPPropertyGridInplaceButton |
IsPressed() const | CXTPPropertyGridInplaceButton |
OnDraw(CDC *pDC, CRect rc) | CXTPPropertyGridInplaceButton | virtual
OnKeyDown(UINT nChar) | CXTPPropertyGridInplaceButton | virtual
OnLButtonDown(UINT nFlags, CPoint point) | CXTPPropertyGridInplaceButton | virtual
SetAlignment(int nAlignment) | CXTPPropertyGridInplaceButton |
SetCaption(LPCTSTR lpszCaption) | CXTPPropertyGridInplaceButton |
SetEnabled(BOOL bEnabled) | CXTPPropertyGridInplaceButton |
SetHyperlink(BOOL bHyperlink=TRUE) | CXTPPropertyGridInplaceButton |
SetIconIndex(int nIconIndex) | CXTPPropertyGridInplaceButton |
SetShowAlways(BOOL bShowAlways) | CXTPPropertyGridInplaceButton |
SetTooltip(LPCTSTR lpstrTooltip) | CXTPPropertyGridInplaceButton |
SetWidth(int nWidth) | CXTPPropertyGridInplaceButton |
~CXTPPropertyGridInplaceButton() | CXTPPropertyGridInplaceButton | virtual


Toolkit Pro: Member List

CXTPRibbonThemeNativeWindows10 Member List

This is the complete list of members for CXTPRibbonThemeNativeWindows10, including all inherited members.

CreateTabPaintManager() | CXTPRibbonPaintManager | protectedvirtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPRibbonMarkupTheme(CXTPPaintManager *pPaintManager) | CXTPRibbonMarkupTheme |
CXTPRibbonOffice2013Theme(CXTPPaintManager *pPaintManager) | CXTPRibbonOffice2013Theme |
CXTPRibbonPaintManager(CXTPPaintManager *pPaintManager) | CXTPRibbonPaintManager |
CXTPRibbonThemeNativeWindows10(CXTPPaintManager *pPaintManager) | CXTPRibbonThemeNativeWindows10 |
DrawBackImage(CDC *pDC, CXTPRibbonBar *pRibbonBar) | CXTPRibbonOffice2013Theme | protectedvirtual
DrawControlGroupOption(CDC *pDC, CXTPControl *pControlGroupOption, BOOL bDraw) | CXTPRibbonMarkupTheme | virtual
DrawControlGroupPopup(CDC *pDC, CXTPControlPopup *pControlGroupPopup, BOOL bDraw) | CXTPRibbonMarkupTheme | virtual
DrawDwmCaptionText(CDC *pDC, CRect rcCaptionText, CString strText, CWnd *pSite, BOOL bActive) | CXTPRibbonPaintManager | protected
DrawGroup(CDC *pDC, CXTPRibbonGroup *pGroup) | CXTPRibbonMarkupTheme | virtual
DrawQuickAccessControl(CDC *pDC, CXTPRibbonBar *pRibbon, CXTPControl *pControl) | CXTPRibbonOffice2013Theme | virtual
DrawRibbonApplicationIcon(CDC *pDC, CXTPRibbonBar *pRibbonBar, CRect rc, HICON hIcon) | CXTPRibbonPaintManager | protected
DrawRibbonFrameCaption(CDC *pDC, CXTPRibbonBar *pRibbonBar, BOOL bActive) | CXTPRibbonOffice2013Theme | virtual
DrawRibbonFrameCaptionBar(CDC *pDC, CXTPRibbonBar *pRibbonBar, BOOL bActive) | CXTPRibbonOffice2013Theme | virtual
DrawRibbonFrameContextHeaders(CDC *pDC, CXTPRibbonBar *pRibbonBar, CXTPRibbonTabContextHeaders *pContextHeaders) | CXTPRibbonThemeNativeWindows10 | virtual
DrawRibbonFramePart(CDC *pDC, CXTPRibbonBar *pRibbonBar) | CXTPRibbonPaintManager | virtual
DrawRibbonFrameSystemButton(CDC *pDC, CXTPRibbonControlSystemButton *pControl, CRect rc) | CXTPRibbonOffice2013Theme | virtual
DrawRibbonGroupControlEntry(CDC *pDC, CXTPControl *pButton) | CXTPRibbonMarkupTheme | virtual
DrawRibbonGroupPopupToolBar(CDC *pDC, CXTPRibbonGroup *pRibbonGroup) | CXTPRibbonMarkupTheme | virtual
DrawRibbonQuickAccessButton(CDC *pDC, CXTPControlPopup *pControl) | CXTPRibbonMarkupTheme | virtual
DrawRibbonQuickAccessControls(CDC *pDC, CXTPRibbonBar *pRibbonBar) | CXTPRibbonMarkupTheme | virtual
DrawRibbonQuickAccessMoreButton(CDC *pDC, CXTPControlPopup *pControl) | CXTPRibbonMarkupTheme | virtual
DrawRibbonScrollButton(CDC *pDC, CXTPControl *pControl, BOOL bScrollLeft) | CXTPRibbonMarkupTheme | virtual
DrawRibbonTab(CDC *pDC, CXTPRibbonTab *pItem) | CXTPRibbonThemeNativeWindows10 | virtual
DrawSystemPopupBarButton(CDC *pDC, CXTPControl *pButton) | CXTPRibbonMarkupTheme | virtual
FillGroupPopupToolBar(CDC *pDC, CXTPRibbonGroup *pGroup, CXTPCommandBar *pCommandBar) | CXTPRibbonMarkupTheme | virtual
FillGroupRect(CDC *pDC, CXTPRibbonTab *pActiveTab, CRect rcGroups) | CXTPRibbonThemeNativeWindows10 | virtual
FillMorePopupToolBarEntry(CDC *pDC, CXTPCommandBar *pBar) | CXTPRibbonMarkupTheme | virtual
FillRibbonBar(CDC *pDC, CXTPRibbonBar *pRibbonBar) | CXTPRibbonOffice2013Theme | virtual
FillRibbonTabControl(CDC *pDC, CXTPRibbonBar *pRibbonBar, CRect rcControl) | CXTPRibbonMarkupTheme | virtual
FillSystemPopupBarEntry(CDC *pDC, CXTPPopupBar *pBar) | CXTPRibbonMarkupTheme | virtual
FillTabPopupToolBar(CDC *pDC, CXTPPopupToolBar *pPopupToolBar) | CXTPRibbonPaintManager | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetBackImageName() | CXTPRibbonOffice2013Theme | protectedvirtual
GetControlGroupOptionSize() const | CXTPRibbonMarkupTheme | virtual
GetEditHeight() const | CXTPRibbonPaintManager |
GetFontHeight() const | CXTPRibbonPaintManager |
GetFramePaintManager() const | CXTPRibbonPaintManager |
GetGroupCaptionHeight() const | CXTPRibbonPaintManager |
GetImages() const | CXTPRibbonPaintManager |
GetRibbonCaptionHeight(const CXTPRibbonBar *pRibbonBar) const | CXTPRibbonOffice2013Theme | virtual
GetTabPaintManager() const | CXTPRibbonPaintManager |
LoadImage(LPCTSTR lpszFileName) | CXTPRibbonPaintManager |
LoadParts(BOOL bReload=FALSE) | CXTPRibbonOffice2013Theme | protectedvirtual
CXTPRibbonMarkupTheme::LoadParts(HZIP hZip, CXTPMarkupContext *pMarkupContext=NULL) | CXTPRibbonMarkupTheme |
m_bFlatFrame | CXTPRibbonPaintManager |
m_bHotTrackingGroups | CXTPRibbonPaintManager |
m_clrBackstageSysButtonBack2013Highlighted | CXTPRibbonMarkupTheme | protected
m_clrBackstageSysButtonBack2013Normal | CXTPRibbonMarkupTheme | protected
m_clrFileButtonText | CXTPRibbonPaintManager | protected
m_clrHeader | CXTPRibbonOffice2013Theme | protected
m_clrMinimizedFrameEdgeHighLight | CXTPRibbonPaintManager | protected
m_clrMinimizedFrameEdgeShadow | CXTPRibbonPaintManager | protected
m_clrRecentFileListEdgeHighLight | CXTPRibbonPaintManager |
m_clrRecentFileListEdgeShadow | CXTPRibbonPaintManager |
m_clrRibbonBorder | CXTPRibbonPaintManager | protected
m_clrRibbonFace | CXTPRibbonPaintManager | protected
m_clrRibbonGroupCaptionText | CXTPRibbonPaintManager | protected
m_clrRibbonInactiveFace | CXTPRibbonPaintManager | protected
m_clrRibbonInactiveFaceState | CXTPRibbonOffice2013Theme | protected
m_clrRibbonTabDelimeter | CXTPRibbonOffice2013Theme | protected
m_clrTabBackackstageLeft | CXTPRibbonOffice2013Theme | protected
m_clrTabBackackstageRight | CXTPRibbonOffice2013Theme | protected
m_clrTabBackInactiveState | CXTPRibbonOffice2013Theme | protected
m_fontGroupCaption | CXTPRibbonPaintManager |
m_nGroupCaptionHeight | CXTPRibbonPaintManager |
m_nGroupSpacing | CXTPRibbonPaintManager |
m_nTabsHeight | CXTPRibbonPaintManager |
m_pMarkupContext | CXTPRibbonMarkupTheme | protected
m_pPaintManager | CXTPRibbonPaintManager | protected
m_pTabPaintManager | CXTPRibbonPaintManager | protected
m_rcFileButtonMargin | CXTPRibbonPaintManager | protected
m_strHighlightedPrefix | CXTPRibbonMarkupTheme | protected
m_strNormalPrefix | CXTPRibbonMarkupTheme | protected
RefreshMetrics() | CXTPRibbonThemeNativeWindows10 | virtual
RenderMarkup(CDC *pDC, CRect rc, LPCTSTR lpszText) | CXTPRibbonMarkupTheme |
RenderMarkup(CDC *pDC, CRect rc, XTPRibbonThemePart part) | CXTPRibbonMarkupTheme |
SetBackImage(int nImage) | CXTPRibbonOffice2013Theme | virtual
SetFontHeight(int nFontHeight) | CXTPRibbonPaintManager |
~CXTPRibbonMarkupTheme() | CXTPRibbonMarkupTheme | virtual
~CXTPRibbonOffice2013Theme() | CXTPRibbonOffice2013Theme | virtual
~CXTPRibbonPaintManager() | CXTPRibbonPaintManager | virtual
~CXTPRibbonThemeNativeWindows10() | CXTPRibbonThemeNativeWindows10 | virtual


Toolkit Pro: Member List

CXTPShellSettings Member List

This is the complete list of members for CXTPShellSettings, including all inherited members.

AllowUpperCase() | CXTPShellSettings
CXTPShellSettings() | CXTPShellSettings
DoubleClickOpen() | CXTPShellSettings
HTMLDesktop() | CXTPShellSettings
m_crCompColor | CXTPShellSettings
m_crEncrColor | CXTPShellSettings
NoConfirmRecycle() | CXTPShellSettings
RefreshSettings() | CXTPShellSettings
ShowAllFiles() | CXTPShellSettings
ShowAttributes() | CXTPShellSettings
ShowCompColor() | CXTPShellSettings
ShowExtensions() | CXTPShellSettings
ShowInfoTips() | CXTPShellSettings
ShowMapNetworkDrive() | CXTPShellSettings
ShowSysFiles() | CXTPShellSettings
Win95Classic() | CXTPShellSettings
~CXTPShellSettings() | CXTPShellSettings


Toolkit Pro: Member List

CXTPCalendarVisualStudio2022Theme Member List

This is the complete list of members for CXTPCalendarVisualStudio2022Theme, including all inherited members.

_GetAtGrow_BusyStatusBrushValue(int eBusyStatus, BOOL bGrow) | CXTPCalendarPaintManager | protected
_Init() | CXTPCalendarPaintManager | virtual
AddViewPart(CXTPCalendarViewPart *pPart) | CXTPCalendarPaintManager | protected
AdjustTimeFont(CDC *pDC, CRect rcCell) | CXTPCalendarPaintManager |
BEGIN_VIEW_PART(ControlPart, XTPCalendarViewPart) virtual void RefreshMetrics() | CXTPCalendarPaintManager |
CalcEventSize(CDC *c, CXTPCalendarTimeLineViewEvent *pViewEvent) | CXTPCalendarPaintManager | virtual
CalcWidth(CDC *pDC, const CString &strHour, const CString &strMin, int nHourHeight, int &nWidth) | CXTPCalendarPaintManager |
CXTPCalendarOffice2000Theme() | CXTPCalendarOffice2000Theme |
CXTPCalendarOffice2013Theme() | CXTPCalendarOffice2013Theme |
CXTPCalendarPaintManager() | CXTPCalendarPaintManager |
CXTPCalendarVisualStudio2022Theme() | CXTPCalendarVisualStudio2022Theme |
CXTPCmdTarget() | CXTPCmdTarget |
DrawBigHourCell(CDC *pDC, CRect rc, CString strHour, CString strMin, int nRowPerHour, BOOL bFillBackground=TRUE, BOOL bCurrentTime=FALSE) | CXTPCalendarPaintManager | virtual
DrawBitmap(CImageList *pImageList, CDC *pDC, CRect rcView, int iIcon, UINT uFlags=0) | CXTPCalendarPaintManager | virtual
DrawBitmap(UINT nIDResource, CDC *pDC, CRect rcBitmap) | CXTPCalendarPaintManager | virtual
DrawBorder(CDC *pDC, CRect rcView, CXTPCalendarWeekViewEvent *pWeekViewEvent) | CXTPCalendarPaintManager | virtual
DrawBusyStatus(CDC *pDC, CRect &rcRect, int eBusyStatus) | CXTPCalendarPaintManager | virtual
DrawBusyStatus(CDC *pDC, CRgn &rgnBusy, int eBusyStatus) | CXTPCalendarPaintManager | virtual
DrawClock(CDC *pDC, COleDateTime dtClockTime, CRect rcView, COLORREF clrBackground, XTPCalendarClockAlignFlags cafAlign) | CXTPCalendarPaintManager | virtual
DrawDayHeader(CDC *pDC, CRect rcDay, int nHeaderHeight, CString strHeader, BOOL bIsCurrent=FALSE, BOOL bIsSelected=FALSE) | CXTPCalendarPaintManager | virtual
DrawEvent(CDC *pDC, const CRect &rcEvents, CXTPCalendarTimeLineViewEvent *pViewEvent) | CXTPCalendarPaintManager | virtual
DrawExpandSigns(CDC *pDC, CXTPCalendarDayView *pView, const CRect &rcTSHours) | CXTPCalendarPaintManager | virtual
DrawGroup(CDC *pDC, const CRect &rcRect, CXTPCalendarTimeLineViewGroup *pGroup) | CXTPCalendarPaintManager | virtual
DrawHeader(CDC *pDC, CRect &rcHeader, BOOL bIsSelected, BOOL bIsCurrent, const CXTPPaintManagerColorGradient &grclr, COLORREF clrUnderLineHdr) | CXTPCalendarOffice2013Theme | virtual
CXTPCalendarOffice2000Theme::DrawHeader(CDC *pDC, CRect &rcHeader, BOOL bIsSelected, BOOL bIsCurrent) | CXTPCalendarPaintManager | virtual
DrawHorizontalLine(CDC *pDC, int xPos, int yPos, int cx) | CXTPCalendarPaintManager | virtual
DrawHourCell(CDC *pDC, CRect rc, CString strText, BOOL bFillBackground=TRUE, BOOL bCurrentTime=FALSE) | CXTPCalendarPaintManager | virtual
DrawIconChar(CDC *pDC, CRect rc, TCHAR ch) | CXTPCalendarPaintManager | virtual
DrawIcons(CDC *pDC, CXTPCalendarViewEvent *pViewEvent) | CXTPCalendarPaintManager | virtual
DrawLine(CDC *pDC, int xPos, int yPos, int cx, int cy) | CXTPCalendarPaintManager | virtual
DrawNowLine(CDC *pDC, CXTPCalendarDayView *pView, CRect rc, int y, BOOL bDrawBk=FALSE) | CXTPCalendarPaintManager | virtual
DrawNowLine(CDC *pDC, CXTPCalendarDayView *pView, CXTPCalendarDayViewTimeScale *pScale, CRect rc, int y, BOOL bDrawBk=FALSE) | CXTPCalendarPaintManager | virtual
DrawShadow(CDC *pDC, const CRect &rcRect) | CXTPCalendarPaintManager | virtual
DrawSubj(CDC *pDC, CXTPCalendarWeekViewEvent *pWeekViewEvent) | CXTPCalendarPaintManager | virtual
DrawTimes(CDC *pDC, CXTPCalendarWeekViewEvent *pWeekViewEvent) | CXTPCalendarPaintManager | virtual
DrawVerticalLine(CDC *pDC, int xPos, int yPos, int cy) | CXTPCalendarPaintManager | virtual
EnableTheme(BOOL bEnableTheme) | CXTPCalendarPaintManager |
END_VIEW_PART(ControlPart) BEGIN_VIEW_PART(DayViewTimeScaleHeaderPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewTimeScaleHeaderPart) BEGIN_VIEW_PART(DayViewTimeScaleCellPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewTimeScaleCellPart) BEGIN_VIEW_PART(DayViewCellPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewCellPart) BEGIN_VIEW_PART(DayViewWorkCellPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewWorkCellPart) BEGIN_VIEW_PART(DayViewNonworkCellPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewNonworkCellPart) BEGIN_VIEW_PART(DayMonthViewHeaderPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayMonthViewHeaderPart) BEGIN_VIEW_PART(DayViewHeaderPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewHeaderPart) BEGIN_VIEW_PART(DayViewGroupHeaderPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewGroupHeaderPart) BEGIN_VIEW_PART(DayViewAllDayEventsPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewAllDayEventsPart) BEGIN_VIEW_PART(DayViewAllDayEventScrollIconsPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewAllDayEventScrollIconsPart) BEGIN_VIEW_PART(DayViewEventPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewEventPart) BEGIN_VIEW_PART(MonthViewGridPart | CXTPCalendarPaintManager |
END_VIEW_PART(MonthViewGridPart) BEGIN_VIEW_PART(MonthViewHeaderPart | CXTPCalendarPaintManager |
END_VIEW_PART(MonthViewHeaderPart) BEGIN_VIEW_PART(MonthViewEventPart | CXTPCalendarPaintManager |
END_VIEW_PART(MonthViewEventPart) BEGIN_VIEW_PART(WeekViewPart | CXTPCalendarPaintManager |
END_VIEW_PART(WeekViewPart) BEGIN_VIEW_PART(WeekViewEventPart | CXTPCalendarPaintManager |
END_VIEW_PART(WeekViewEventPart) BEGIN_VIEW_PART(TimeLineViewTimeScalePart_Day | CXTPCalendarPaintManager |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAskItemTextFlags() const | CXTPCalendarPaintManager |
GetBusyStatusBrush(int nBusyStatus) | CXTPCalendarPaintManager |
GetClockSize() | CXTPCalendarPaintManager | virtual
GetCurrentSystemTheme() | CXTPCalendarPaintManager |
GetEventBackColor(CXTPCalendarEvent *pEvent) | CXTPCalendarOffice2013Theme | virtual
CXTPCalendarOffice2000Theme::GetEventBackColor(CXTPCalendarEvent *pEvent, COLORREF crDefault) | CXTPCalendarPaintManager | virtual
GetEventEdgeColor(CXTPCalendarEvent *pEvent) | CXTPCalendarOffice2013Theme | virtual
GetExpandSignSize() | CXTPCalendarPaintManager | virtual
GetPaintTheme() const | CXTPCalendarPaintManager | virtual
GetParams(CXTPCalendarDayViewGroup *pViewGroup, XTP_CALENDAR_DAYVIEWCELL_PARAMS *rCellParams) | CXTPCalendarPaintManager | virtual
idxExpandSignDown enum value | CXTPCalendarPaintManager | protected
idxExpandSignUp enum value | CXTPCalendarPaintManager | protected
idxMeeting enum value | CXTPCalendarPaintManager | protected
idxPrivate enum value | CXTPCalendarPaintManager | protected
idxRecurrenceException enum value | CXTPCalendarPaintManager | protected
idxRecurrenceOccurrence enum value | CXTPCalendarPaintManager | protected
idxReminder enum value | CXTPCalendarPaintManager | protected
InitBusyStatusDefaultColors() | CXTPCalendarPaintManager | protectedvirtual
IsThemeEnabled() | CXTPCalendarPaintManager |
m_arBusyStatusBrushes | CXTPCalendarPaintManager | protected
m_arStartCol | CXTPCalendarPaintManager |
m_arStartRow | CXTPCalendarPaintManager |
m_bEnableTheme | CXTPCalendarPaintManager | protected
m_bmpElsewherePattern | CXTPCalendarPaintManager | protected
m_bmpTentativePattern | CXTPCalendarPaintManager | protected
m_bShowMinutes | CXTPCalendarPaintManager |
m_clr3DShadow | CXTPCalendarPaintManager |
m_clrBackground | CXTPCalendarPaintManager |
m_clrBackground2 | CXTPCalendarPaintManager |
m_clrBackgroundSlave | CXTPCalendarPaintManager |
m_clrBorders | CXTPCalendarPaintManager |
m_clrButtonFace | CXTPCalendarPaintManager |
m_clrButtonFaceText | CXTPCalendarPaintManager |
m_clrClassicUnderline | CXTPCalendarPaintManager |
m_clrEventBar | CXTPCalendarPaintManager |
m_clrEventBarLine | CXTPCalendarPaintManager |
m_clrEventBorderLine | CXTPCalendarPaintManager |
m_clrHeaderBottomLine | CXTPCalendarPaintManager |
m_clrHighlight | CXTPCalendarPaintManager |
m_clrHour | CXTPCalendarPaintManager |
m_clrSelectedBackground | CXTPCalendarPaintManager |
m_clrSelectedText | CXTPCalendarPaintManager |
m_clrShadow | CXTPCalendarPaintManager |
m_clrText | CXTPCalendarPaintManager |
m_clrTextHighLightColor | CXTPCalendarPaintManager |
m_clrTextNormalColor | CXTPCalendarPaintManager |
m_clrTimeScaleBackground | CXTPCalendarPaintManager |
m_clrTimeScaleHightlite | CXTPCalendarPaintManager |
m_clrTimeScaleText | CXTPCalendarPaintManager |
m_clrUnderLineHdr | CXTPCalendarPaintManager | protected
m_clrWeekendBackground | CXTPCalendarPaintManager |
m_clrWindow | CXTPCalendarPaintManager |
m_clrWindowText | CXTPCalendarPaintManager |
m_CurrSystemTheme | CXTPCalendarPaintManager | protected
m_dwAskItemTextFlags | CXTPCalendarPaintManager | protected
m_fntTimeText | CXTPCalendarPaintManager |
m_grclrClassicSelDay | CXTPCalendarPaintManager |
m_grclrToday | CXTPCalendarPaintManager |
m_lstViewParts | CXTPCalendarPaintManager | protected
m_nHourWidth | CXTPCalendarPaintManager |
m_nMinWidth | CXTPCalendarPaintManager |
m_nPaintTheme | CXTPCalendarPaintManager | protected
m_pControl | CXTPCalendarPaintManager | protected
m_pExpandSigns | CXTPCalendarPaintManager | protected
m_pGlyphs | CXTPCalendarPaintManager | protected
m_pGlyphsFont | CXTPCalendarPaintManager | protected
m_PrintPageWidth | CXTPCalendarPaintManager |
m_szClockRect | CXTPCalendarPaintManager | protected
m_xtpBrushElsewhere | CXTPCalendarPaintManager | protected
m_xtpBrushTentative | CXTPCalendarPaintManager | protected
OnDraw(CDC *pDC, CXTPCalendarDayView *pView, CRect rc, CString strText) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarDayViewGroup *pViewGroup, CRect rc, const XTP_CALENDAR_DAYVIEWCELL_PARAMS &cellParams) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarDayViewDay *pViewDay, CRect rc, CString strText) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarDayViewGroup *pViewGroup, CRect rc, CString strText) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarDayViewGroup *pViewGroup, CRect rc, BOOL bSelected) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarDayViewGroup *pViewGroup, BOOL bDrawUp, BOOL bDrawDown, const CRect &rcIconUp, const CRect &rcIconDown, BOOL bHighlightUp, BOOL bHighlightDown) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarDayViewEvent *pViewEvent) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarMonthView *pMonthView, CRect rc, int nCollIndex, CString strText) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarWeekView *pWeekView) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarWeekViewEvent *pWeekViewEvent) | CXTPCalendarPaintManager | virtual
OnDrawDayDate(CDC *pDC, CRect rc, BOOL bToday, BOOL bSelected, BOOL bFirstMonthDay, CString strText) | CXTPCalendarPaintManager | virtual
OnDrawEvent(CDC *pDC, CXTPCalendarMonthViewEvent *pViewEvent) | CXTPCalendarPaintManager | virtual
OnDrawGrid(CDC *pDC, CXTPCalendarMonthView *pMonthView) | CXTPCalendarPaintManager | virtual
RefreshMetrics() | CXTPCalendarOffice2013Theme | virtual
SetAskItemTextFlags(DWORD dwFlags) | CXTPCalendarPaintManager |
SetBusyStatusBrush(int nBusyStatus, CBrush *pBrush, BOOL bAutodeleteBrush) | CXTPCalendarPaintManager |
SetControl(CXTPCalendarControl *pControl) | CXTPCalendarPaintManager | virtual
SetPaintTheme(XTPCalendarTheme ePaintTheme) | CXTPCalendarPaintManager | virtual
UpdateEventCategoriesDefaultColors() | CXTPCalendarOffice2013Theme | virtual
UpdateEventLabelsDefaultColors() | CXTPCalendarOffice2013Theme | virtual
UpdateGlyphs() | CXTPCalendarOffice2013Theme | virtual
XTPEnumEventGlyphs enum name | CXTPCalendarPaintManager | protected
XTPEnumExpandSigns enum name | CXTPCalendarPaintManager | protected
~CTimeLineViewPart() | CXTPCalendarPaintManager | virtual
~CXTPCalendarOffice2000Theme() | CXTPCalendarOffice2000Theme | virtual
~CXTPCalendarOffice2013Theme() | CXTPCalendarOffice2013Theme | virtual
~CXTPCalendarPaintManager() | CXTPCalendarPaintManager | virtual
~CXTPCalendarVisualStudio2022Theme() | CXTPCalendarVisualStudio2022Theme | virtual


Toolkit Pro: XTPMarkupDecorator.h Source File

  • Source
  • Markup
  • Controls
XTPMarkupDecorator.h
Go to the documentation of this file.
1
23#if !defined(__XTPMARKUPDECORATOR_H__)
24# define __XTPMARKUPDECORATOR_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPMarkupUIElement;
34class CXTPMarkupBuilder;
35class CXTPMarkupObject;
36class CXTPMarkupVisual;
37
43class _XTP_EXT_CLASS CXTPMarkupDecorator : public CXTPMarkupFrameworkElement
44{
45protected:
50 CXTPMarkupDecorator();
51
56 virtual ~CXTPMarkupDecorator();
57
58public:
66 void SetChild(CXTPMarkupUIElement* pChild);
67
76 CXTPMarkupUIElement* GetChild() const;
77
78protected:
81 // Implementation
82 virtual void SetContentObject(CXTPMarkupBuilder* pBuilder, CXTPMarkupObject* pContent);
83 virtual BOOL HasContentObject() const;
84
85public:
86 virtual int GetVisualChildrenCount() const;
87 virtual CXTPMarkupVisual* GetVisualChild(int nIndex) const;
88
89protected:
90 CXTPMarkupUIElement* m_pChild;
92};
94AFX_INLINE int CXTPMarkupDecorator::GetVisualChildrenCount() const
95{
96 return m_pChild != NULL ? 1 : 0;
97}
98AFX_INLINE CXTPMarkupVisual* CXTPMarkupDecorator::GetVisualChild(int nIndex) const
99{
100 return nIndex == 0 ? m_pChild : NULL;
101}
103# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
105#endif // !defined(__XTPMARKUPDECORATOR_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPMarkupDecorator
CXTPMarkupDecorator is a CXTPMarkupFrameworkElement derived class.
Definition XTPMarkupDecorator.h:44
CXTPMarkupDecorator::CXTPMarkupDecorator
CXTPMarkupDecorator()
Constructs a CXTPMarkupDecorator object.
CXTPMarkupDecorator::~CXTPMarkupDecorator
virtual ~CXTPMarkupDecorator()
Destroys a CXTPMarkupDecorator object, handles cleanup and deallocation.
CXTPMarkupDecorator::GetChild
CXTPMarkupUIElement * GetChild() const
Retrieves the child object of the decorator element.
CXTPMarkupDecorator::SetChild
void SetChild(CXTPMarkupUIElement *pChild)
Sets a new child object for the decorator element.
CXTPMarkupFrameworkElement
This class represents the provided framework-level implementation built on CXTPMarkupUIElement.
Definition XTPMarkupFrameworkElement.h:44
CXTPMarkupUIElement
Base class for XML Markup core level implementations.
Definition XTPMarkupUIElement.h:43
CXTPMarkupVisual
Provides rendering support for XML Markup, which includes hit testing, coordinate transformation,...
Definition XTPMarkupInputElement.h:223
CXTPMarkupVisual::GetVisualChild
virtual CXTPMarkupVisual * GetVisualChild(int nIndex) const
Retrieves the child Visual object located at a specified index within the parent VisualCollection.
CXTPMarkupVisual::GetVisualChildrenCount
virtual int GetVisualChildrenCount() const
Gets the number of child elements for the Visual.


Toolkit Pro: Member List

CXTPHeaderCtrl Member List

This is the complete list of members for CXTPHeaderCtrl, including all inherited members.

ApplyFieldWidths(int iNewWidth) | CXTPHeaderCtrl | protectedvirtual
CXTPHeaderCtrl() | CXTPHeaderCtrl |
DetermineRTL() | CXTPHeaderCtrl | protectedvirtual
EnableAutoSize(bool bEnable=true) | CXTPHeaderCtrl |
EnableDpiBitmapScaling(BOOL bEnable=TRUE) | CXTPHeaderCtrl |
EnablePopupMenus(BOOL bEnableMenus) | CXTPHeaderCtrl |
FitFieldWidths(int iNewWidth) | CXTPHeaderCtrl | protectedvirtual
FreezeColumn(int iCol) | CXTPHeaderCtrl |
GetAscending() const | CXTPHeaderCtrl |
GetFrozenColWidth() | CXTPHeaderCtrl | protectedvirtual
GetImageManager() const | CXTPHeaderCtrl |
GetSortedCol(BOOL *pbSortAsc=NULL) | CXTPHeaderCtrl |
GetTheme() | CXTPHeaderCtrl |
HasSortArrow() | CXTPHeaderCtrl |
HitTest(CPoint pt, UINT *pFlags=NULL) const | CXTPHeaderCtrl |
InitializeHeader(BOOL bBoldFont) | CXTPHeaderCtrl | virtual
IsColFrozen(int iCol) | CXTPHeaderCtrl |
IsDpiBitmapScalingEnabled() const | CXTPHeaderCtrl |
IsThemeValid() const | CXTPHeaderCtrl |
ItemPressed(int iItem) | CXTPHeaderCtrl | virtual
m_arFrozenCols | CXTPHeaderCtrl | protected
m_bAscending | CXTPHeaderCtrl | protected
m_bAutoSize | CXTPHeaderCtrl | protected
m_bDpiBitmapScaling | CXTPHeaderCtrl | protected
m_bDpiBitmapScalingModified | CXTPHeaderCtrl | protected
m_bEnableMenus | CXTPHeaderCtrl | protected
m_bLBtnDown | CXTPHeaderCtrl | protected
m_bPainted | CXTPHeaderCtrl | protected
m_bRTL | CXTPHeaderCtrl | protected
m_iMinSize | CXTPHeaderCtrl | protected
m_iOverIndex | CXTPHeaderCtrl | protected
m_nPos | CXTPHeaderCtrl | protected
m_nSortedCol | CXTPHeaderCtrl | protected
m_pImageManager | CXTPHeaderCtrl | protected
m_popupMenuID | CXTPHeaderCtrl | protected
m_pt | CXTPHeaderCtrl | protected
m_pTheme | CXTPHeaderCtrl | protected
OnThemeChanged() | CXTPHeaderCtrl | virtual
RecalcLayout() | CXTPHeaderCtrl |
RefreshMetrics() | CXTPHeaderCtrl | protectedvirtual
ResizeColumnsToFit() | CXTPHeaderCtrl |
SendNotify(int iIndex) | CXTPHeaderCtrl | protected
SetAlingment(int nFlag) | CXTPHeaderCtrl | virtual
SetBitmap(int iCol, UINT uBitmapID, DWORD dwRemove=NULL) | CXTPHeaderCtrl |
SetBitmap(int iCol, UINT uBitmapID, BOOL bRemove, COLORREF crMask) | CXTPHeaderCtrl |
SetFontBold(BOOL bBoldFont=TRUE) | CXTPHeaderCtrl | virtual
SetImageManager(CXTPImageManager *pImageManager) | CXTPHeaderCtrl |
SetMenuID(UINT popupMenuID, int nPos=0) | CXTPHeaderCtrl | virtual
SetMinSize(int iMinSize) | CXTPHeaderCtrl |
SetSortImage(int iSortCol, BOOL bSortAsc) | CXTPHeaderCtrl |
SetTheme(XTPControlTheme eTheme) | CXTPHeaderCtrl |
SetTheme(CXTPHeaderCtrlTheme *pTheme) | CXTPHeaderCtrl |
ShowSortArrow(BOOL bSortArrow) | CXTPHeaderCtrl | virtual
ThawAllColumns() | CXTPHeaderCtrl |
ThawColumn(int iCol) | CXTPHeaderCtrl |
~CXTPHeaderCtrl() | CXTPHeaderCtrl | virtual


Toolkit Pro: Member List

CXTPColorManager Member List

This is the complete list of members for CXTPColorManager, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
DisableLunaColors(BOOL bDisable=TRUE) | CXTPColorManager |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetColor(int nIndex) const | CXTPColorManager |
GetCurrentSystemTheme() const | CXTPColorManager |
GetLunaColor(int nIndex) const | CXTPColorManager |
GetWinThemeWrapperTheme() const | CXTPColorManager |
grcCaption | CXTPColorManager |
grcDockBar | CXTPColorManager |
grcLunaChecked | CXTPColorManager |
grcLunaPushed | CXTPColorManager |
grcLunaSelected | CXTPColorManager |
grcMenu | CXTPColorManager |
grcMenuExpanded | CXTPColorManager |
grcMenuItemPopup | CXTPColorManager |
grcShortcutBarGripper | CXTPColorManager |
grcToolBar | CXTPColorManager |
IsLowResolution(HDC hDC=0) | CXTPColorManager |
IsLunaColorsDisabled() const | CXTPColorManager |
LightColor(COLORREF clrLight, COLORREF clrDark, int nDelta) const | CXTPColorManager |
m_bEnableLunaBlueForAeroTheme | CXTPColorManager |
m_bEnableLunaBlueForRoyaleTheme | CXTPColorManager |
PFNGETSYSCOLOR typedef | CXTPColorManager |
RefreshColors(BOOL bResetCustomColors=TRUE) | CXTPColorManager |
RefreshLunaColors() | CXTPColorManager |
SetColor(int nIndex, COLORREF clrValue) | CXTPColorManager |
SetColors(int cElements, const int *lpaElements, const COLORREF *lpaRgbValues) | CXTPColorManager |
SetGetSysColorPtr(PFNGETSYSCOLOR pfnGetSysColor) | CXTPColorManager |
SetLunaTheme(XTPCurrentSystemTheme systemTheme) | CXTPColorManager |


Toolkit Pro: Member List

NMXTPSCROLL Member List

This is the complete list of members for NMXTPSCROLL, including all inherited members.

hdr | NMXTPSCROLL
nPos | NMXTPSCROLL
nSBCode | NMXTPSCROLL
pSender | NMXTPSCROLL


Toolkit Pro: XTPSkinObject.h Source File

  • Source
  • SkinFramework
XTPSkinObject.h
Go to the documentation of this file.
1
23#if !defined(_XTPSKINOBJECT_H__)
24# define _XTPSKINOBJECT_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPSkinManager;
34class CXTPSkinManagerClass;
35class CXTPSkinManagerMetrics;
36class CXTPSkinManagerSchema;
37
40// Internal enumerator
41
46enum XTPSkinDefaultProc
47{
48 xtpSkinDefaultHookMessage,
49 xtpSkinDefaultCallWindowProc,
50 xtpSkinDefaultDefWindowProc,
51 xtpSkinDefaultDefMDIChildProc,
52 xtpSkinDefaultDefFrameProc,
53 xtpSkinDefaultDefDlgProc
54};
55
56class _XTP_EXT_CLASS CXTPSkinObjectPaintDC : public CDC
57{
58 // Constructors
59public:
60 CXTPSkinObjectPaintDC(CWnd* pWnd);
61 virtual ~CXTPSkinObjectPaintDC();
62
63 // Attributes
64protected:
65 HWND m_hWnd;
66
67public:
68 PAINTSTRUCT m_ps;
69};
77class _XTP_EXT_CLASS CXTPSkinObject
78 : public CWnd
79 , public CXTPSynchronized
80{
81 DECLARE_DYNAMIC(CXTPSkinObject);
82
83protected:
88 CXTPSkinObject();
89
94 ~CXTPSkinObject();
95
96public:
103 CXTPSkinManager* GetSkinManager() const;
104
113 CString GetClassName() const;
114
123 CXTPSkinManagerClass* GetSkinClass() const;
124
131 CXTPSkinManagerMetrics* GetMetrics() const;
132
133 CXTPSkinManagerSchema* GetSchema() const;
134
143 COLORREF GetColor(int nIndex) const;
144
145 BOOL IsSkinEnabled() const;
146
147protected:
154 virtual void OnSkinChanged(BOOL bPrevState, BOOL bNewState);
155
160 virtual void RefreshMetrics();
161
171 virtual void OnHookAttached(LPCREATESTRUCT lpcs, BOOL bAuto);
172
180 virtual void OnHookDetached(BOOL bAuto);
181
182 BOOL IsDrawingEnabled(BOOL bForceUpdateStatus = FALSE) const;
183
185public:
186 UINT GetHeadMessage();
187
188protected:
189 virtual BOOL CheckDrawingEnabled();
190 virtual BOOL OnHookMessage(UINT nMessage, WPARAM& wParam, LPARAM& lParam, LRESULT& lResult);
191 virtual BOOL OnHookDefWindowProc(UINT nMessage, WPARAM& wParam, LPARAM& lParam,
192 LRESULT& lResult);
193 void AttachHook(HWND hWnd, LPCREATESTRUCT lpcs, BOOL bAuto);
194 void UnattachHook(BOOL bAuto);
195 virtual void OnFinalRelease();
196 virtual WNDPROC* GetSuperWndProcAddr();
197 virtual BOOL IsDefWindowProcAvail(int nMessage) const;
198 virtual LRESULT DefWindowProc(UINT nMsg, WPARAM wParam, LPARAM lParam);
199 virtual BOOL PreHookMessage(UINT nMessage);
200# ifdef _DEBUG
201 virtual void AssertValid() const
202 {
203 }
204# endif
205 void SetWindowProc();
206
207 void OnBeginHook(UINT nMessage, XTPSkinDefaultProc defProc, PROC defProcAddr,
208 LPVOID defProcPrevWndFunc);
209 void OnEndHook();
210 LRESULT DoDefWindowProc(UINT nMsg, WPARAM wParam, LPARAM lParam);
211
212 static CString AFX_CDECL GetWndClassTreePath(HWND hWnd, BOOL bPathOnly = FALSE);
215public:
216 static const UINT m_nMsgQuerySkinState;
217 static const UINT m_nMsgUpdateSkinState;
218 static const UINT m_nMsgSkinChanged;
219
220protected:
221 WNDPROC m_pOldWndProc;
222 CXTPSkinManager* m_pManager;
223 CString m_strClassName;
224 BOOL m_bActiveX;
225 BOOL m_bWindowsForms;
226 BOOL m_bCustomDraw;
227 BOOL m_bUnicode;
228 CRITICAL_SECTION m_csDescriptors;
229
230 BOOL m_bSystemWindowModule;
231 BOOL m_bWindowProcAttached;
232 BOOL m_bSetWindowProc;
233
234 CXTPSkinManagerSchema* m_pSchema;
235
236private:
237 struct DEFWINDOW_DESCRIPTIOR
238 {
239 XTPSkinDefaultProc defProc;
240 PROC defProcAddr;
241 LPVOID lpPrev;
242 UINT nMessage;
243 };
244 CList<DEFWINDOW_DESCRIPTIOR, DEFWINDOW_DESCRIPTIOR&> m_arrDescriptors;
245 BOOL m_bDrawingEnabled;
246
247protected:
248 friend class CXTPSkinManager;
249 friend class CXTPSkinManagerApiHookBase;
250 friend class CXTPSkinObjectClassInfoActiveX;
251};
252
254class CXTPSkinObjectClassMap;
255
256class _XTP_EXT_CLASS CXTPSkinObjectClassInfo
257 : public CXTPCmdTarget
258 , public CXTPSynchronized
259{
260public:
261 CXTPSkinObjectClassInfo(CRuntimeClass* pClass);
262
263public:
264 virtual CXTPSkinObject* CreateObject(LPCTSTR lpszClassName, LPCREATESTRUCT lpcs);
265
266public:
267 void AddClass(LPCTSTR lpszClassName);
268 void Remove();
269
270protected:
271 CRuntimeClass* m_pClass;
272 CXTPSkinObjectClassMap* m_pMap;
273
274 friend class CXTPSkinObjectClassMap;
275};
276
277class _XTP_EXT_CLASS CXTPSkinObjectClassInfoActiveX : public CXTPSkinObjectClassInfo
278{
279public:
280 CXTPSkinObjectClassInfoActiveX(CRuntimeClass* pClass, BOOL bSysModule, BOOL bSetWindowProc)
281 : CXTPSkinObjectClassInfo(pClass)
282 {
283 m_bSysModule = bSysModule;
284 m_bSetWindowProc = bSetWindowProc;
285 }
286
287 virtual CXTPSkinObject* CreateObject(LPCTSTR lpszClassName, LPCREATESTRUCT lpcs)
288 {
289 CXTPSkinObject* pObject = CXTPSkinObjectClassInfo::CreateObject(lpszClassName, lpcs);
290 if (pObject)
291 {
292 pObject->m_bActiveX = TRUE;
293 if (m_bSysModule)
294 pObject->m_bSystemWindowModule = TRUE;
295 if (m_bSetWindowProc)
296 pObject->m_bSetWindowProc = TRUE;
297 }
298 return pObject;
299 }
300 BOOL m_bSysModule;
301 BOOL m_bSetWindowProc;
302};
303
319class _XTP_EXT_CLASS CXTPSkinObjectClassMap : public CXTPSynchronized
320{
321public:
326 CXTPSkinObjectClassMap();
327
332 ~CXTPSkinObjectClassMap();
333
334public:
342 void AddStandardClasses();
343
344public:
358 CXTPSkinObjectClassInfo* AddClass(LPCTSTR lpszClassName, CXTPSkinObjectClassInfo* pInfo);
359
371 void AddSynonymClass(LPCTSTR lpszClassNameSynonym, LPCTSTR lpszClassName);
372
380 void RemoveClass(LPCTSTR lpszClassName);
381
389 void RemoveClass(CXTPSkinObjectClassInfo* pInfo);
390
397 void RemoveAll();
398
406 CXTPSkinObjectClassInfo* Lookup(LPCTSTR lpszClassName);
407
408protected:
409 CMapStringToPtr m_mapInfo;
410};
411
412AFX_INLINE CXTPSkinManager* CXTPSkinObject::GetSkinManager() const
413{
414 return m_pManager;
415}
416AFX_INLINE CString CXTPSkinObject::GetClassName() const
417{
418 return m_strClassName;
419}
420
421# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
423#endif // !defined(_XTPSKINOBJECT_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPSkinManagerClass
CXTPSkinManagerClass is a standalone class that represents a single visual class of the skin manager.
Definition XTPSkinManager.h:110
CXTPSkinManager
CXTPSkinManager is a standalone class that represents a global object that manages skins.
Definition XTPSkinManager.h:541
CXTPSkinManagerMetrics
CXTPSkinManagerMetrics is a standalone class that represents a collection of metrics of the current s...
Definition XTPSkinManager.h:403
CXTPSkinManagerSchema
CXTPSkinManagerSchema is a standalone class used to read a visual styles schema file.
Definition XTPSkinManagerSchema.h:164
CXTPSkinObjectClassMap
CXTPSkinObjectClassMap is a standalone class that helps map windows controls to skin framework classe...
Definition XTPSkinObject.h:320
CXTPSkinObjectClassMap::~CXTPSkinObjectClassMap
~CXTPSkinObjectClassMap()
Destroys a CXTPSkinObjectClassMap object, handles cleanup and deallocation.
CXTPSkinObjectClassMap::AddClass
CXTPSkinObjectClassInfo * AddClass(LPCTSTR lpszClassName, CXTPSkinObjectClassInfo *pInfo)
Maps a window class name to a skin framework class.
CXTPSkinObjectClassMap::m_mapInfo
CMapStringToPtr m_mapInfo
General map.
Definition XTPSkinObject.h:409
CXTPSkinObjectClassMap::RemoveClass
void RemoveClass(LPCTSTR lpszClassName)
Removes a window class.
CXTPSkinObjectClassMap::RemoveAll
void RemoveAll()
Removes all classes.
CXTPSkinObjectClassMap::AddStandardClasses
void AddStandardClasses()
This method is called by the framework to add all standard window classes.
CXTPSkinObjectClassMap::RemoveClass
void RemoveClass(CXTPSkinObjectClassInfo *pInfo)
Removes a skin framework class.
CXTPSkinObjectClassMap::CXTPSkinObjectClassMap
CXTPSkinObjectClassMap()
Constructs a CXTPSkinObjectClassMap object.
CXTPSkinObjectClassMap::AddSynonymClass
void AddSynonymClass(LPCTSTR lpszClassNameSynonym, LPCTSTR lpszClassName)
Maps a window class name to another window class name.
CXTPSkinObjectClassMap::Lookup
CXTPSkinObjectClassInfo * Lookup(LPCTSTR lpszClassName)
Searches for a Skin Object Class Information object by a specified name.
CXTPSkinObject
CXTPSkinObject is a CWnd derived class.
Definition XTPSkinObject.h:80
CXTPSkinObject::CXTPSkinObject
CXTPSkinObject()
Constructs a CXTPSkinObject object.
CXTPSkinObject::m_bWindowsForms
BOOL m_bWindowsForms
TRUE if .NET controls.
Definition XTPSkinObject.h:225
CXTPSkinObject::m_strClassName
CString m_strClassName
Own class name.
Definition XTPSkinObject.h:223
CXTPSkinObject::m_bActiveX
BOOL m_bActiveX
TRUE if ActiveX controls.
Definition XTPSkinObject.h:224
CXTPSkinObject::GetSkinManager
CXTPSkinManager * GetSkinManager() const
Gets the parent CXTPSkinManager object.
Definition XTPSkinObject.h:412
CXTPSkinObject::GetMetrics
CXTPSkinManagerMetrics * GetMetrics() const
Gets the skin metrics.
CXTPSkinObject::m_pManager
CXTPSkinManager * m_pManager
Parent CXTPSkinManager object.
Definition XTPSkinObject.h:222
CXTPSkinObject::~CXTPSkinObject
~CXTPSkinObject()
Destroys a CXTPSkinObject object, handles cleanup and deallocation.
CXTPSkinObject::GetColor
COLORREF GetColor(int nIndex) const
Retrieves the specified system color.
CXTPSkinObject::m_pOldWndProc
WNDPROC m_pOldWndProc
Old window window handler.
Definition XTPSkinObject.h:221
CXTPSkinObject::GetSkinClass
CXTPSkinManagerClass * GetSkinClass() const
Gets the CXTPSkinManagerClass object associated with own class name.
CXTPSkinObject::OnHookDetached
virtual void OnHookDetached(BOOL bAuto)
This method is called when the hook is detached.
CXTPSkinObject::RefreshMetrics
virtual void RefreshMetrics()
This method is called when visual metrics are changed.
CXTPSkinObject::OnHookAttached
virtual void OnHookAttached(LPCREATESTRUCT lpcs, BOOL bAuto)
This method is called when the hook is attached.
CXTPSkinObject::GetClassName
CString GetClassName() const
Gets own class name.
Definition XTPSkinObject.h:416
CXTPSkinObject::OnSkinChanged
virtual void OnSkinChanged(BOOL bPrevState, BOOL bNewState)
This method is called when the skin is changed.
CXTPSynchronized
A base class for a synchronized object.
Definition XTPSynchro.h:602


Toolkit Pro: Member List

  • CXTPTreeBase
  • CLRFONT
CXTPTreeBase::CLRFONT Member List

This is the complete list of members for CXTPTreeBase::CLRFONT, including all inherited members.

CLRFONT() | CXTPTreeBase::CLRFONT
color | CXTPTreeBase::CLRFONT
colorBack | CXTPTreeBase::CLRFONT
logfont | CXTPTreeBase::CLRFONT


Toolkit Pro: XTPScrollBarThemeOffice2003.h Source File

  • Source
  • Common
  • ScrollBar
  • Themes
XTPScrollBarThemeOffice2003.h
Go to the documentation of this file.
1
23#if !defined(__XTPSCROLLBARTHEMEOFFICE2003_H__)
24# define __XTPSCROLLBARTHEMEOFFICE2003_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPScrollBarThemeOffice2003 : public CXTPScrollBarThemeWindowsUx
39{
40protected:
45 virtual void RefreshMetrics();
46};
47
48# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
50#endif /*__XTPSCROLLBARTHEMEOFFICE2003_H__*/
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPScrollBarThemeOffice2003
Scrollbar paint manager used to draw Office 2003 like scrollbars.
Definition XTPScrollBarThemeOffice2003.h:39
CXTPScrollBarThemeOffice2003::RefreshMetrics
virtual void RefreshMetrics()
Recalculates scrollbar metrics.
CXTPScrollBarThemeWindowsUx
Scrollbar paint manager used to draw scrollbars that use current Windows theme.
Definition XTPScrollBarThemeWindowsUx.h:39


Toolkit Pro: XTPColorPageStandard.h Source File

  • Source
  • Controls
  • Dialog
XTPColorPageStandard.h
Go to the documentation of this file.
1
23#if !defined(__XTPCOLORSTANDARD_H__)
24# define __XTPCOLORSTANDARD_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPColorHex : public CStatic
39{
41 DECLARE_DYNAMIC(CXTPColorHex)
43protected:
49 class CRgnCell : public CRgn
50 {
51 public:
56 struct CTX_DATA
57 {
62 struct HEXAGON_DATA
63 {
64 float width;
65 float half;
66 float height;
67 float roof;
68 float side;
69 };
70 HEXAGON_DATA lg;
71 HEXAGON_DATA sm;
72 };
73
84 CRgnCell(const CTX_DATA& data, CXTPRectF& rect, COLORREF color, float u, float d);
85
99 CRgnCell(const CTX_DATA& data, CXTPRectF& rect, COLORREF color, float u, float d, float x,
100 float y, BOOL bLarge = FALSE);
101
102 protected:
110 virtual BOOL DrawCell(CDC* pDC);
111
120 virtual BOOL DrawSelection(CDC* pDC);
121
122 int m_iCell[2];
124 COLORREF m_color;
125 CXTPRectF m_rect;
126 CXTPPoint2f m_pts[6];
129 friend class CXTPColorHex;
130
131 private:
132 static void AFX_CDECL ConvertFloatToIntPoints(const CXTPPoint2f (&from)[6],
133 CPoint (&to)[6]);
134
135 static void AFX_CDECL ComputeHexagon(const CTX_DATA::HEXAGON_DATA& data, float left,
136 float top, CXTPPoint2f (&points)[6]);
137 };
138
149 typedef CList<CRgnCell*, CRgnCell*> CRgnCellList;
150
151public:
156 CXTPColorHex();
157
162 virtual ~CXTPColorHex();
163
164public:
174 COLORREF ColorFromPoint(CPoint point);
175
185 CRgnCell* GetColorCell(int iIndex);
186
196 CRgnCell* GetColorCell(COLORREF color);
197
208 BOOL SetSelectedColor(int iIndex, BOOL bNotify = TRUE);
209
220 BOOL SetSelectedColor(COLORREF color, BOOL bNotify = TRUE);
221
228 COLORREF GetSelectedColor() const;
229
230protected:
238 virtual bool Init();
239
249 BOOL UpdateSelection(CPoint point, BOOL bNotify = TRUE);
250
260 BOOL UpdateSelection(CRgnCell* pCell, BOOL bNotify = TRUE);
261
271 virtual bool IsValidColor(COLORREF color) const;
272
278 void CreateCellArray();
279
280protected:
282 DECLARE_MESSAGE_MAP()
283
284 //{{AFX_VIRTUAL(CXTPColorHex)
285 virtual void PreSubclassWindow();
286 virtual BOOL PreTranslateMessage(MSG* pMsg);
287 virtual BOOL PreCreateWindow(CREATESTRUCT& cs);
288 //}}AFX_VIRTUAL
289
290 //{{AFX_MSG(CXTPColorHex)
291 afx_msg void OnPaint();
292 afx_msg void OnLButtonDown(UINT nFlags, CPoint point);
293 afx_msg void OnLButtonUp(UINT nFlags, CPoint point);
294 afx_msg void OnMouseMove(UINT nFlags, CPoint point);
295 afx_msg BOOL OnEraseBkgnd(CDC* pDC);
296 afx_msg void OnLButtonDblClk(UINT nFlags, CPoint point);
297 afx_msg int OnCreate(LPCREATESTRUCT lpCreateStruct);
298 //}}AFX_MSG
301 CBitmap m_bmpPicker;
302 bool m_bPreSubclassInit;
303 COLORREF m_clrColor;
305 CRgnCellList m_rgnList;
307 CRgnCell* m_pCell;
309};
310
312
313AFX_INLINE COLORREF CXTPColorHex::GetSelectedColor() const
314{
315 return m_clrColor;
316}
323class _XTP_EXT_CLASS CXTPColorPageStandard : public CPropertyPage
324{
325public:
331 CXTPColorPageStandard(CXTPColorDialog* pParentSheet = NULL);
332
338 virtual ~CXTPColorPageStandard();
339
346 void SetColor(COLORREF clr);
347
348protected:
350 DECLARE_MESSAGE_MAP()
351
352 //{{AFX_VIRTUAL(CXTPColorPageStandard)
353 virtual void DoDataExchange(CDataExchange* pDX);
354 //}}AFX_VIRTUAL
355
356 //{{AFX_MSG(CXTPColorPageStandard)
357 afx_msg LRESULT OnUpdateColor(WPARAM wParam, LPARAM lParam);
358 afx_msg LRESULT OnColorDblClick(WPARAM wParam, LPARAM lParam);
359 //}}AFX_MSG
360
361 //{{AFX_DATA(CXTPColorPageStandard)
362 enum
363 {
364 IDD = XTP_IDD_COLORSTANDARD
365 };
366 //}}AFX_DATA
369protected:
370 CXTPColorHex m_colorHex;
371 CXTPColorDialog* m_pParentSheet;
373 friend class CXTPColorHex;
374
375public:
376 virtual BOOL OnSetActive();
377};
378
380
381AFX_INLINE void CXTPColorPageStandard::SetColor(COLORREF clr)
382{
383 m_colorHex.SetSelectedColor(clr, FALSE);
384}
386# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
388#endif // !defined(__XTPCOLORSTANDARD_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPColorDialog
CXTPColorDialog is a CPropertySheet derived class.
Definition XTPColorDialog.h:184
CXTPColorHex::CRgnCell
CRgnCell is a CRgn derived class used by the CXTPColorHex to create individual color cells.
Definition XTPColorPageStandard.h:50
CXTPColorHex::CRgnCell::CRgnCell
CRgnCell(const CTX_DATA &data, CXTPRectF &rect, COLORREF color, float u, float d)
Constructs a CRgnCell object.
CXTPColorHex::CRgnCell::DrawSelection
virtual BOOL DrawSelection(CDC *pDC)
Used by the CRgnCell to display a selection around the active color cell.
CXTPColorHex::CRgnCell::m_rect
CXTPRectF m_rect
Represents the size and position of the color cell.
Definition XTPColorPageStandard.h:125
CXTPColorHex::CRgnCell::CRgnCell
CRgnCell(const CTX_DATA &data, CXTPRectF &rect, COLORREF color, float u, float d, float x, float y, BOOL bLarge=FALSE)
Constructs a CRgnCell object.
CXTPColorHex::CRgnCell::DrawCell
virtual BOOL DrawCell(CDC *pDC)
Used by the CRgnCell to render each color cell.
CXTPColorHex::CRgnCell::m_color
COLORREF m_color
An RGB value that represents the color of the cell.
Definition XTPColorPageStandard.h:124
CXTPColorHex
CXTPColorHex is a CStatic derived class.
Definition XTPColorPageStandard.h:39
CXTPColorHex::IsValidColor
virtual bool IsValidColor(COLORREF color) const
This member function is called to determine if a specified color is defined in the color array.
CXTPColorHex::GetColorCell
CRgnCell * GetColorCell(int iIndex)
Call this member function to retrieve a pointer to a CRgnCell object that represents information for ...
CXTPColorHex::GetSelectedColor
COLORREF GetSelectedColor() const
Call this member function to return the currently selected color.
CXTPColorHex::SetSelectedColor
BOOL SetSelectedColor(COLORREF color, BOOL bNotify=TRUE)
Call this member function to set the selected color using either the list 'iIndex' or RGB 'color'.
CXTPColorHex::CXTPColorHex
CXTPColorHex()
Constructs a CXTPColorHex object.
CXTPColorHex::~CXTPColorHex
virtual ~CXTPColorHex()
Destroys a CXTPColorHex object, handles cleanup and deallocation.
CXTPColorHex::UpdateSelection
BOOL UpdateSelection(CPoint point, BOOL bNotify=TRUE)
This member function updates the color selection based on the x- and y- coordinates specified by 'poi...
CXTPColorHex::SetSelectedColor
BOOL SetSelectedColor(int iIndex, BOOL bNotify=TRUE)
Call this member function to set the selected color using either the list 'iIndex' or RGB 'color'.
CXTPColorHex::CRgnCellList
CList< CRgnCell *, CRgnCell * > CRgnCellList
List for maintaining CRgnCell objects.
Definition XTPColorPageStandard.h:149
CXTPColorHex::GetColorCell
CRgnCell * GetColorCell(COLORREF color)
Call this member function to retrieve a pointer to a CRgnCell object that represents information for ...
CXTPColorHex::CreateCellArray
void CreateCellArray()
This member function is called by the CXTPColorHex class to build the array of color cells used to re...
CXTPColorHex::UpdateSelection
BOOL UpdateSelection(CRgnCell *pCell, BOOL bNotify=TRUE)
This member function updates the color selection based on the x- and y- coordinates specified by 'poi...
CXTPColorHex::ColorFromPoint
COLORREF ColorFromPoint(CPoint point)
Call this member function to retrieve RGB information for the color found at a location specified by ...
CXTPColorHex::Init
virtual bool Init()
This member function is called by the CXTPColorHex class to perform initialization when the window is...
CXTPColorPageStandard
CXTPColorPageStandard is derived from CPropertyPage.
Definition XTPColorPageStandard.h:324
CXTPColorPageStandard::~CXTPColorPageStandard
virtual ~CXTPColorPageStandard()
Destroys a CXTPColorPageStandard object, handles cleanup and deallocation.
CXTPColorPageStandard::m_pParentSheet
CXTPColorDialog * m_pParentSheet
Pointer to the parent property sheet.
Definition XTPColorPageStandard.h:371
CXTPColorPageStandard::m_colorHex
CXTPColorHex m_colorHex
ColorHex control.
Definition XTPColorPageStandard.h:370
CXTPColorPageStandard::SetColor
void SetColor(COLORREF clr)
This member function is called to set the selected color for the page.
CXTPColorPageStandard::CXTPColorPageStandard
CXTPColorPageStandard(CXTPColorDialog *pParentSheet=NULL)
Constructs a CXTPColorPageStandard object.
CXTPPoint2T< float >
CXTPRectT< float >
CXTPColorHex::CRgnCell::CTX_DATA::HEXAGON_DATA
Describes pre-computed hexagon data.
Definition XTPColorPageStandard.h:63
CXTPColorHex::CRgnCell::CTX_DATA::HEXAGON_DATA::height
float height
Hexagon height.
Definition XTPColorPageStandard.h:66
CXTPColorHex::CRgnCell::CTX_DATA::HEXAGON_DATA::half
float half
Hexagon half.
Definition XTPColorPageStandard.h:65
CXTPColorHex::CRgnCell::CTX_DATA::HEXAGON_DATA::side
float side
Hexagon side.
Definition XTPColorPageStandard.h:68
CXTPColorHex::CRgnCell::CTX_DATA::HEXAGON_DATA::width
float width
Hexagon width.
Definition XTPColorPageStandard.h:64
CXTPColorHex::CRgnCell::CTX_DATA::HEXAGON_DATA::roof
float roof
Hexagon roof.
Definition XTPColorPageStandard.h:67
CXTPColorHex::CRgnCell::CTX_DATA
Contains pre-computed hexagon data for both small and big hexagons.
Definition XTPColorPageStandard.h:57
CXTPColorHex::CRgnCell::CTX_DATA::sm
HEXAGON_DATA sm
Small hexagon data.
Definition XTPColorPageStandard.h:71
CXTPColorHex::CRgnCell::CTX_DATA::lg
HEXAGON_DATA lg
Large hexagon data.
Definition XTPColorPageStandard.h:70


Toolkit Pro: XTPPreviewNavigatorWindow.h Source File

  • Source
  • Controls
  • Preview
XTPPreviewNavigatorWindow.h
Go to the documentation of this file.
1
23#if !defined(__XTPPREVIEWNAVIGATORWINDOW_H__)
24# define __XTPPREVIEWNAVIGATORWINDOW_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
35class CXTPPreviewCtrl;
36
37class _XTP_EXT_CLASS CXTPPreviewNavigatorWindow : public CWnd
38{
39 DECLARE_DYNAMIC(CXTPPreviewNavigatorWindow)
40
41public:
42 explicit CXTPPreviewNavigatorWindow(CXTPPreviewCtrl* pPreviewCtrl);
43 virtual ~CXTPPreviewNavigatorWindow();
44
45protected:
46 virtual BOOL PreTranslateMessage(MSG* pMsg);
47
48 DECLARE_MESSAGE_MAP()
49 afx_msg int OnCreate(LPCREATESTRUCT lpCreateStruct);
50 afx_msg void OnFirstBtn();
51 afx_msg void OnLastBtn();
52 afx_msg void OnPrevBtn();
53 afx_msg void OnNextBtn();
54 afx_msg void OnWindowPosChanged(WINDOWPOS* lpwndpos);
55 afx_msg void OnWindowPosChanging(WINDOWPOS* lpwndpos);
56 afx_msg BOOL OnEraseBkgnd(CDC*);
57
58private:
59 void PlaceButtons();
60
61private:
62 CButton m_FirstBtn;
63 CButton m_LastBtn;
64 CButton m_PrevBtn;
65 CButton m_NextBtn;
66
67 CBitmap m_FirstBitmap;
68 CBitmap m_PreviousBitmap;
69 CBitmap m_NextBitmap;
70 CBitmap m_LastBitmap;
71
72 CXTPPreviewCtrl* m_pPreviewCtrl;
73};
74
77# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
79#endif // #if !defined(__XTPPREVIEWNAVIGATORWINDOW_H__)
XTPDisableNoisyWarnings.h
CXTPPreviewCtrl
Implements the preview control that can display visual preview data provided by the best matching pre...
Definition XTPPreviewCtrl.h:42


Toolkit Pro: Member List

CXTPChartPyramidSeriesPointViewBase Member List

This is the complete list of members for CXTPChartPyramidSeriesPointViewBase, including all inherited members.

AddChildView(CXTPChartElementView *pChildView) | CXTPChartElementView |
CalculateLayout(int nIndex, int nCount, double dFrom, double dTo)=0 | CXTPChartPyramidSeriesPointViewBase | pure virtual
CreateDeviceCommand(CXTPChartDeviceContext *pDC)=0 | CXTPChartPyramidSeriesPointViewBase | protectedpure virtual
CreateLegendDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcBounds) | CXTPChartPyramidSeriesPointViewBase | protectedvirtual
CXTPChartElementView(CXTPChartElementView *pParentView) | CXTPChartElementView |
CXTPChartElementView(CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartElementView |
CXTPChartElementView(CXTPChartContainer *pContainer) | CXTPChartElementView |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartPyramidSeriesPointViewBase(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView) | CXTPChartPyramidSeriesPointViewBase |
CXTPChartPyramidSeriesPointViewBase(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartPyramidSeriesPointViewBase |
CXTPChartSeriesPointView(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView) | CXTPChartSeriesPointView |
CXTPChartSeriesPointView(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartSeriesPointView |
GetAt(int nIndex) const | CXTPChartElementView |
GetBorderActualColor() const | CXTPChartPyramidSeriesPointViewBase |
GetBounds() const | CXTPChartElementView |
GetBounds(BOOL bIncludingChildren) const | CXTPChartElementView |
GetChildren() | CXTPChartElementView |
GetColor() const | CXTPChartSeriesPointView |
GetColor2() const | CXTPChartSeriesPointView |
GetCount() const | CXTPChartElementView |
GetInternalValue() const | CXTPChartSeriesPointView |
GetLegendName() const | CXTPChartSeriesPointView | virtual
GetParentView() const | CXTPChartElementView |
GetPoint() const | CXTPChartSeriesPointView |
GetSeriesView() const | CXTPChartSeriesPointView |
Is3D() const | CXTPChartObject |
m_arrChildren | CXTPChartElementView | protected
m_dInternalValue | CXTPChartSeriesPointView |
m_dValue | CXTPChartPyramidSeriesPointViewBase | protected
m_pContainer | CXTPChartElementView | protected
m_pParentView | CXTPChartElementView | protected
m_pPoint | CXTPChartSeriesPointView | protected
m_rcBounds | CXTPChartElementView | protected
UpdateMinMaxRange(double &nMinValue, double &nMaxValue) const | CXTPChartSeriesPointView | virtual
~CXTPChartElementView() | CXTPChartElementView | protectedvirtual
~CXTPChartLegendItemView() | CXTPChartLegendItemView | inlinevirtual
~CXTPChartPyramidSeriesPointViewBase() | CXTPChartPyramidSeriesPointViewBase | virtual


Toolkit Pro: Member List

CXTPChartDiagram2DSeriesLabel Member List

This is the complete list of members for CXTPChartDiagram2DSeriesLabel, including all inherited members.

CXTPChartDiagram2DSeriesLabel() | CXTPChartDiagram2DSeriesLabel |
CXTPChartElement() | CXTPChartElement |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartSeriesLabel() | CXTPChartSeriesLabel |
DoPropExchange(CXTPPropExchange *pPX) | CXTPChartDiagram2DSeriesLabel | virtual
GetAntialiasing() const | CXTPChartSeriesLabel | virtual
GetAppearance() const | CXTPChartElement |
GetBackColor() const | CXTPChartSeriesLabel |
GetContent() const | CXTPChartElement |
GetFont() const | CXTPChartSeriesLabel | virtual
GetFormat() const | CXTPChartSeriesLabel |
GetLineColor() const | CXTPChartSeriesLabel |
GetLineLength() const | CXTPChartSeriesLabel |
GetOwner() const | CXTPChartElement |
GetShowLines() const | CXTPChartSeriesLabel |
GetTextColor() const | CXTPChartSeriesLabel |
GetTransparency() const | CXTPChartSeriesLabel |
Is3D() const | CXTPChartObject |
IsVisible() const | CXTPChartSeriesLabel |
m_bAntialiasing | CXTPChartSeriesLabel | protected
m_bShowLines | CXTPChartSeriesLabel | protected
m_bVisible | CXTPChartSeriesLabel | protected
m_clrBackColor | CXTPChartSeriesLabel | protected
m_clrLineColor | CXTPChartSeriesLabel | protected
m_clrTextColor | CXTPChartSeriesLabel | protected
m_nLineLength | CXTPChartSeriesLabel | protected
m_nTransparency | CXTPChartSeriesLabel | protected
m_pBorder | CXTPChartSeriesLabel | protected
m_pFont | CXTPChartSeriesLabel | protected
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartElement | virtual
Release() | CXTPChartElement | virtual
SetAntialiasing(BOOL bAntialiasing) | CXTPChartSeriesLabel |
SetBackColor(const CXTPChartColor &clrBackColor) | CXTPChartSeriesLabel |
SetFont(CXTPChartFont *pFont) | CXTPChartSeriesLabel |
SetFormat(LPCTSTR lpszFormat) | CXTPChartSeriesLabel |
SetLineColor(const CXTPChartColor &clrBackColor) | CXTPChartSeriesLabel |
SetLineLength(int nLineLength) | CXTPChartSeriesLabel |
SetShowLines(BOOL bShowLines) | CXTPChartSeriesLabel |
SetTextColor(const CXTPChartColor &clrTextColor) | CXTPChartSeriesLabel |
SetTransparency(int nTransparency) | CXTPChartSeriesLabel |
SetVisible(BOOL bVisible) | CXTPChartSeriesLabel |
~CXTPChartDiagram2DSeriesLabel() | CXTPChartDiagram2DSeriesLabel | virtual
~CXTPChartElement() | CXTPChartElement | virtual
~CXTPChartSeriesLabel() | CXTPChartSeriesLabel | virtual


Toolkit Pro: Member List

CXTPPropertyGridToolBar Member List

This is the complete list of members for CXTPPropertyGridToolBar, including all inherited members.

CXTPPropertyGridToolBar() | CXTPPropertyGridToolBar
~CXTPPropertyGridToolBar() | CXTPPropertyGridToolBar


Toolkit Pro: Member List

CXTPTabColorSetOffice2007Access Member List

This is the complete list of members for CXTPTabColorSetOffice2007Access, including all inherited members.

CXTPTabPaintManagerColorSet() | CXTPTabPaintManagerColorSet |
FillClient(CDC *pDC, CRect rc, CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
FillHeader(CDC *pDC, CRect rc, CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
FillNavigateButton(CDC *pDC, CXTPTabManagerNavigateButton *pButton, CRect &rc) | CXTPTabColorSetOffice2007 | virtual
FillPropertyButton(CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem) | CXTPTabColorSetOffice2003 | virtual
FillStateButton(CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerColorSet | virtual
GetClientColor(CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
GetItemColor(CXTPTabManagerItem *pItem) | CXTPTabPaintManagerColorSet | virtual
GradientFill(CDC *pDC, CRect rc, COLORREF clrLight, COLORREF clrDark, XTPTabPosition position) | CXTPTabPaintManagerColorSet |
IsAppThemed() const | CXTPTabPaintManagerColorSet | virtual
m_bLunaTheme | CXTPTabColorSetOffice2003 | protected
m_clrActiveFilesBack | CXTPTabPaintManagerColorSet |
m_clrActiveFilesBackHighlighted | CXTPTabPaintManagerColorSet |
m_clrActiveFilesBackPressed | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyph | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyphHighlighted | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyphPressed | CXTPTabPaintManagerColorSet |
m_clrAutoHideFace | CXTPTabPaintManagerColorSet |
m_clrBorderHighlight | CXTPTabPaintManagerColorSet |
m_clrButtonBorder | CXTPTabPaintManagerColorSet |
m_clrButtonBorderHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonBorderHot | CXTPTabPaintManagerColorSet |
m_clrButtonBorderKeyTips | CXTPTabPaintManagerColorSet |
m_clrButtonBorderTabContext1 | CXTPTabPaintManagerColorSet |
m_clrButtonBorderTabContext2 | CXTPTabPaintManagerColorSet |
m_clrButtonHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonHighlightedClose | CXTPTabPaintManagerColorSet |
m_clrButtonNormal | CXTPTabPaintManagerColorSet |
m_clrButtonPressed | CXTPTabPaintManagerColorSet |
m_clrButtonSelected | CXTPTabPaintManagerColorSet |
m_clrButtonSelectedHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonSelectedPressed | CXTPTabPaintManagerColorSet |
m_clrButtonText | CXTPTabColorSetOffice2007 | protected
m_clrControlFace | CXTPTabPaintManagerColorSet |
m_clrFrameBorder | CXTPTabPaintManagerColorSet |
m_clrHeaderFace | CXTPTabPaintManagerColorSet |
m_clrNavigateButtonBorder | CXTPTabColorSetOffice2003 | protected
m_clrPaneFace | CXTPTabPaintManagerColorSet |
m_clrTabClientBack | CXTPTabPaintManagerColorSet |
m_clrTabClientBorder | CXTPTabPaintManagerColorSet |
m_clrTextDisabled | CXTPTabPaintManagerColorSet |
m_clrTextHighlight | CXTPTabPaintManagerColorSet |
m_clrTextHighlightClose | CXTPTabPaintManagerColorSet |
m_clrTextNormal | CXTPTabPaintManagerColorSet |
m_clrTextPressed | CXTPTabPaintManagerColorSet |
m_clrTextSelected | CXTPTabPaintManagerColorSet |
m_clrTextSelectedHighlighted | CXTPTabPaintManagerColorSet |
m_clrTextSelectedPressed | CXTPTabPaintManagerColorSet |
m_csExcelNormal | CXTPTabPaintManagerColorSet |
m_csExcelSelected | CXTPTabPaintManagerColorSet |
m_csPropertyPage | CXTPTabPaintManagerColorSet |
m_csPropertyPage2003 | CXTPTabPaintManagerColorSet |
m_csStateButton | CXTPTabPaintManagerColorSet |
m_pPaintManager | CXTPTabPaintManagerColorSet | protected
Rectangle(CDC *pDC, CRect rc, int nPen, int nBrush) | CXTPTabColorSetOffice2003 |
RefreshMetrics() | CXTPTabColorSetOffice2007Access | virtual
SelectClipRgn(CDC *pDC, CRect rcClient, CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
SetTextColor(CDC *pDC, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerColorSet | virtual
~CXTPTabPaintManagerColorSet() | CXTPTabPaintManagerColorSet | virtual


Toolkit Pro: XTPSpinButtonCtrl.h Source File

  • Source
  • Controls
  • Spin
XTPSpinButtonCtrl.h
Go to the documentation of this file.
1
23#if !defined(__XTPSPINBUTTONCTRL_H__)
24# define __XTPSPINBUTTONCTRL_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPEdit;
34class CXTPWinThemeWrapper;
35
41class _XTP_EXT_CLASS CXTPSpinButtonCtrl : public CSpinButtonCtrl
42{
44 DECLARE_DYNAMIC(CXTPSpinButtonCtrl)
46public:
51 CXTPSpinButtonCtrl();
52
57 ~CXTPSpinButtonCtrl();
58
73 void SetTheme(XTPControlTheme nTheme);
74
94 BOOL GetUseVisualStyle() const;
95
115 void SetUseVisualStyle(BOOL bUseVisualStyle = TRUE);
116
117protected:
126 UINT HitTest(CPoint pt);
127
133 void OnDraw(CDC* pDC);
134
140 void RefreshMetrics();
141
148 BOOL HasSharedBorder() const;
149
157 CXTPEdit* GetEditBuddy() const;
158
165 void DrawVisualStyle(CDC* pDC);
166
172 void DrawOffice2007(CDC* pDC);
173
179 void DrawFlat(CDC* pDC);
180
188 void DrawFlatButton(CDC* pDC, UINT nButton);
189
200 void DrawArrowGlyph(CDC* pDC, CRect rcArrow, BOOL bHorz, BOOL bUpArrow, COLORREF clrArrow);
201
207 void DrawStandard(CDC* pDC);
208
216 BOOL IsVertical() const;
217
227 CRect GetButtonRect(int nButton);
228
234 void Init();
235
237 virtual BOOL PreCreateWindow(CREATESTRUCT& cs);
238 virtual void PreSubclassWindow();
239 virtual int OnCreate(LPCREATESTRUCT lpCreateStruct);
240
241 //{{AFX_MSG(CXTPSpinButtonCtrl)
242 afx_msg BOOL OnEraseBkgnd(CDC* pDC);
243 afx_msg void OnPaint();
244 afx_msg void OnMouseLeave();
245 afx_msg void OnLButtonDown(UINT nFlags, CPoint point);
246 afx_msg void OnLButtonUp(UINT nFlags, CPoint point);
247 afx_msg void OnSize(UINT nType, int cx, int cy);
248 afx_msg void OnMouseMove(UINT nFlags, CPoint point);
249 afx_msg LRESULT OnSetTheme(WPARAM wParam, LPARAM lParam);
250 DECLARE_MESSAGE_MAP()
251
252 //}}AFX_MSG
255 UINT m_nHotButton;
257 UINT m_nPressedButton;
259 BOOL m_bUseVisualStyle;
260 BOOL m_bPreSubclassInit;
261 COLORREF m_crBack;
262 COLORREF m_crBackHilite;
263 COLORREF m_crBackPushed;
264 COLORREF m_crBackDisabled;
265 COLORREF m_crBorder;
266 COLORREF m_crBorderHilite;
267 COLORREF m_crBorderPushed;
268 COLORREF m_crBorderDisabled;
269 COLORREF m_crArrowEnabled;
270 COLORREF m_crArrowHilite;
271 COLORREF m_crArrowPushed;
272 COLORREF m_crArrowDisabled;
273 XTPControlTheme m_nTheme;
274 CXTPWinThemeWrapper* m_themeSpin;
275};
276
278
279AFX_INLINE BOOL CXTPSpinButtonCtrl::GetUseVisualStyle() const
280{
281 return m_bUseVisualStyle;
282}
284# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
286#endif // #if !defined(__XTPSPINBUTTONCTRL_H__)
XTPControlTheme
XTPControlTheme
Enumeration used to determine the active theme style.
Definition XTPControlTheme.h:43
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPEdit
CXTPEdit is a CEdit derived class.
Definition XTPEdit.h:129
CXTPSpinButtonCtrl
The CXTPSpinButtonCtrl class provides the functionality of a themed Windows spin button control.
Definition XTPSpinButtonCtrl.h:42
CXTPSpinButtonCtrl::OnDraw
void OnDraw(CDC *pDC)
Called by the framework to render the spin button control.
CXTPSpinButtonCtrl::DrawOffice2007
void DrawOffice2007(CDC *pDC)
Called by the framework to render resource driven themes.
CXTPSpinButtonCtrl::Init
void Init()
This member function is called from OnInitDialog or OnInitialUpdate to initialize the control.
CXTPSpinButtonCtrl::SetUseVisualStyle
void SetUseVisualStyle(BOOL bUseVisualStyle=TRUE)
Enables Windows XP visual styles for the control.
CXTPSpinButtonCtrl::CXTPSpinButtonCtrl
CXTPSpinButtonCtrl()
Constructs a CXTPSpinButtonCtrl object.
CXTPSpinButtonCtrl::DrawArrowGlyph
void DrawArrowGlyph(CDC *pDC, CRect rcArrow, BOOL bHorz, BOOL bUpArrow, COLORREF clrArrow)
Called by the framework to render the up and down arrows for the spin button control.
CXTPSpinButtonCtrl::GetEditBuddy
CXTPEdit * GetEditBuddy() const
Called to retrieve a pointer to the CXTPEdit buddy window.
CXTPSpinButtonCtrl::DrawFlat
void DrawFlat(CDC *pDC)
Called by the framework to render flat style spin button themes.
CXTPSpinButtonCtrl::DrawFlatButton
void DrawFlatButton(CDC *pDC, UINT nButton)
Called by the framework to render the button portion of the spin button control for flat style themes...
CXTPSpinButtonCtrl::HitTest
UINT HitTest(CPoint pt)
Determines which spin button, if any, is at a specified position.
CXTPSpinButtonCtrl::SetTheme
void SetTheme(XTPControlTheme nTheme)
Call this member to switch the visual theme of the control.
CXTPSpinButtonCtrl::HasSharedBorder
BOOL HasSharedBorder() const
Called to determine if the border is shared with a buddy.
CXTPSpinButtonCtrl::GetUseVisualStyle
BOOL GetUseVisualStyle() const
Determines if the control is drawn using visual styles/SkinFramework, if supported.
CXTPSpinButtonCtrl::DrawStandard
void DrawStandard(CDC *pDC)
Draw spin button using native Windows theme.
CXTPSpinButtonCtrl::RefreshMetrics
void RefreshMetrics()
This member is called to update color, text, and other visual elements of the control.
CXTPSpinButtonCtrl::IsVertical
BOOL IsVertical() const
Called by the framework to determine if the spin button control is vertically orientated.
CXTPSpinButtonCtrl::~CXTPSpinButtonCtrl
~CXTPSpinButtonCtrl()
Destroys a CXTPSpinButtonCtrl object, handles cleanup and deallocation.
CXTPSpinButtonCtrl::DrawVisualStyle
void DrawVisualStyle(CDC *pDC)
Called by the framework to render Windows themes for the spin button control.
CXTPSpinButtonCtrl::GetButtonRect
CRect GetButtonRect(int nButton)
Called by the spin button control to determine the size of the spin button specified by nButton.
CXTPWinThemeWrapper
The CXTPWinThemeWrapper class wraps the UxTheme.dll visual theme API.
Definition XTPWinThemeWrapper.h:188


Toolkit Pro: Member List

CXTPVisualStudio2008Theme Member List

This is the complete list of members for CXTPVisualStudio2008Theme, including all inherited members.

AdjustExcludeRect(CRect &rc, CXTPControl *pControl, BOOL bVertical) | CXTPVisualStudio2008Theme | virtual
AlphaBorder(CDC *pDC, CRect rc, COLORREF clrBorder) | CXTPVisualStudio2008Theme | static
AlphaPixel(CDC *pDC, int xPos, int yPos, COLORREF clr, int nAlpha) | CXTPVisualStudio2008Theme | static
Animate(CDC *pDestDC, CDC *pSrcDC, CRect rc, XTPAnimationType animationType) | CXTPPaintManager | virtual
AnimateExpanding(CXTPCommandBar *pCommandBar, CDC *pDestDC, CDC *pSrcDC, BOOL bExpandDown) | CXTPPaintManager | virtual
BaseTheme() | CXTPVisualStudio2008Theme | inlinevirtual
CreateGradientCircle() | CXTPCommandBarsOffice2003Theme | protected
CreateTheme(XTPPaintTheme paintTheme) | CXTPPaintManager | static
CXTPCmdTarget() | CXTPCmdTarget |
CXTPCommandBarsOffice2003Theme() | CXTPCommandBarsOffice2003Theme |
CXTPCommandBarsOfficeXPTheme() | CXTPCommandBarsOfficeXPTheme |
CXTPObservable() | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | protected
CXTPPaintManager() | CXTPPaintManager | protected
CXTPVisualStudio2005Theme() | CXTPVisualStudio2005Theme |
CXTPVisualStudio2008Theme() | CXTPVisualStudio2008Theme |
Draw3dRect(CDC *pDC, LPCRECT rc, int nTopLeft, int nBottomRight) | CXTPPaintManager |
Draw3dRect(CDC *pDC, LPCRECT rc, int frameThickness, COLORREF clrPen, COLORREF clrBrush) | CXTPPaintManager |
CXTPPaintManager::DrawCheckMark(CDC *pDC, CRect rcCheck, COLORREF clr=0) | CXTPPaintManager | inline
DrawComboExpandMark(CDC *pDC, CRect rc, COLORREF clr) | CXTPPaintManager | virtual
DrawCommandBarGripper(CDC *pDC, CXTPCommandBar *pBar, BOOL bDraw=TRUE) | CXTPCommandBarsOffice2003Theme | protectedvirtual
DrawCommandBarGroupSeparator(CDC *pDC, CXTPCommandBar *pBar, CXTPControl *pLeftControl, CXTPControl *pRightControl, BOOL bDraw=TRUE) | CXTPPaintManager | virtual
DrawCommandBarSeparator(CDC *pDC, CXTPCommandBar *pBar, CXTPControl *pControl, BOOL bDraw) | CXTPVisualStudio2008Theme | virtual
DrawControl(CDC *pDC, CXTPControl *pButton, BOOL bDraw=TRUE) | CXTPPaintManager |
DrawControlCheckBoxMark(CDC *pDC, CRect rc, BOOL bDraw, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled) | CXTPCommandBarsOfficeXPTheme | protectedvirtual
DrawControlCheckBoxMark(CDC *pDC, CXTPControl *pButton, CRect rc, BOOL bDraw) | CXTPCommandBarsOfficeXPTheme | protectedvirtual
DrawControlComboBox(CDC *pDC, CXTPControlComboBox *pComboBox, BOOL bDraw) | CXTPCommandBarsOfficeXPTheme | protectedvirtual
DrawControlEdit(CDC *pDC, CXTPControlEdit *pEdit, BOOL bDraw) | CXTPCommandBarsOfficeXPTheme | protectedvirtual
DrawControlEntry(CDC *pDC, CXTPControl *pButton) | CXTPPaintManager | virtual
DrawControlMDIButton(CDC *pDC, CXTPControlButton *pButton) | CXTPPaintManager | virtual
DrawControlPopupParent(CDC *pDC, CXTPControl *pButton, BOOL bDraw) | CXTPCommandBarsOfficeXPTheme | protectedvirtual
DrawControlRadioButtonMark(CDC *pDC, CRect rc, BOOL bDraw, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled) | CXTPCommandBarsOfficeXPTheme | protectedvirtual
DrawControlText(CDC *pDC, CXTPControl *pControl, CRect rcText, BOOL bDraw, BOOL bVert, BOOL bCentered, BOOL bTriangled) | CXTPPaintManager |
DrawControlToolBarParent(CDC *pDC, CXTPControl *pButton, BOOL bDraw) | CXTPPaintManager | virtual
DrawDialogBarGripper(CDC *pDC, CXTPDialogBar *pBar, BOOL bDraw) | CXTPCommandBarsOffice2003Theme | protectedvirtual
DrawDropDownGlyph(CDC *pDC, CXTPControl *pControl, CPoint pt, BOOL bSelected, BOOL bPopuped, BOOL bEnabled, BOOL bVert) | CXTPPaintManager | virtual
DrawExpandGlyph(CDC *pDC, CXTPControl *pButton, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clr) | CXTPPaintManager | virtual
DrawExpandGlyph(CDC *pDC, CXTPControl *pButton, COLORREF clr, BOOL bVertical) | CXTPPaintManager | virtual
DrawGalleryItemBack(CDC *pDC, CRect rcItem, BOOL bEnabled, BOOL bSelected, BOOL bPressed, BOOL bChecked, XTPBarType barType) | CXTPPaintManager | virtual
DrawHiddenGlyph(CDC *pDC, CXTPControl *pButton, COLORREF clr, BOOL bVertical) | CXTPPaintManager | virtual
DrawImage(CDC *pDC, CPoint pt, CSize sz, CXTPImageManagerIcon *pImage, BOOL bSelected, BOOL bPressed, BOOL bEnabled=TRUE, BOOL bChecked=FALSE, BOOL bPopuped=FALSE, BOOL bToolBarImage=TRUE) | CXTPCommandBarsOfficeXPTheme | protectedvirtual
DrawListBoxControl(CDC *pDC, CXTPControl *pButton, CRect rc, BOOL bSelected, BOOL bDraw, CXTPCommandBars *pCommandBars=0) | CXTPCommandBarsOfficeXPTheme | virtual
DrawPopupBarCheckMark(CDC *pDC, CRect rcCheck, BOOL bEnabled, COLORREF clr) | CXTPPaintManager | virtual
DrawPopupBarGripper(CDC *pDC, int xPos, int yPos, int cx, int cy, BOOL bExpanded) | CXTPVisualStudio2008Theme | virtual
DrawPopupBarRadioMark(CDC *pDC, CRect rcCheck, BOOL bEnabled, COLORREF clr) | CXTPPaintManager | virtual
DrawPopupResizeGripper(CDC *pDC, CRect rcGripper, int nFlags) | CXTPCommandBarsOfficeXPTheme | virtual
DrawRectangle(CDC *pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition) | CXTPVisualStudio2008Theme | virtual
DrawRectangle(CDC *pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition, int nID) | CXTPVisualStudio2008Theme | virtual
DrawRectangle(CDC *pDC, CXTPControl *pButton) | CXTPVisualStudio2008Theme | virtual
DrawSpecialControl(CDC *pDC, XTPSpecialControl controlType, CXTPControl *pButton, CXTPCommandBar *pBar, BOOL bDraw, LPVOID lpParam) | CXTPCommandBarsOffice2003Theme | protectedvirtual
DrawSplitButtonFrame(CDC *pDC, CXTPControl *pButton, CRect rc) | CXTPCommandBarsOfficeXPTheme | protectedvirtual
DrawTearOffGripper(CDC *pDC, CRect rcGripper, BOOL bSelected, BOOL bDraw) | CXTPCommandBarsOffice2003Theme | protectedvirtual
ExcludeCorners(CDC *pDC, CRect rc) | CXTPCommandBarsOffice2003Theme |
FillCommandBarEntry(CDC *pDC, CXTPCommandBar *pBar) | CXTPCommandBarsOffice2003Theme | protectedvirtual
FillDockBar(CDC *pDC, CXTPDockBar *pBar) | CXTPCommandBarsOffice2003Theme | protectedvirtual
FillIntersectRect(CDC *pDC, CXTPPopupBar *pPopupBar, COLORREF clr) | CXTPCommandBarsOfficeXPTheme | protected
FillWorkspace(CDC *pDC, CRect rc, CRect rcExclude) | CXTPPaintManager | virtual
FontExists(LPCTSTR lpszFaceName) | CXTPPaintManager | static
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCommandBarBorders(CXTPCommandBar *pBar) | CXTPVisualStudio2008Theme | virtual
GetCommandBarFont(CXTPCommandBar *pCommandBar) | CXTPPaintManager | virtual
GetControlBackColor(CXTPControl *pButton) | CXTPPaintManager | virtual
GetControlEditBackColor(CXTPControl *pControl) | CXTPPaintManager | virtual
GetControlFont(CXTPControl *pControl) | CXTPPaintManager | virtual
GetControlHeight() const | CXTPPaintManager |
GetControlTextColor(CXTPControl *pButton) | CXTPPaintManager | virtual
GetControlTextOrientation(CXTPControl *pControl) | CXTPPaintManager | virtual
GetCurrentSystemTheme() | CXTPPaintManager |
GetCurrentTheme() | CXTPPaintManager | inline
GetDefaultCommandBarSize(CXTPCommandBar *pBar) | CXTPPaintManager | virtual
GetFramePaintManager() | CXTPPaintManager | virtual
GetGalleryPaintManager() const | CXTPPaintManager | virtual
GetGlobalPaintManager() | CXTPPaintManager | static
GetIconFont() | CXTPPaintManager |
GetIconsInfo() | CXTPPaintManager |
GetInstanceAddRef() | CXTPPaintManager | static
GetMessageBarPaintManager() | CXTPPaintManager | virtual
GetModernBitmap(UINT nIDResource) | CXTPCommandBarsOffice2003Theme | static
GetPopupBarGripperWidth(CXTPCommandBar *pBar) | CXTPPaintManager | virtual
GetProgressPaintManager() const | CXTPPaintManager | virtual
GetRectangleTextColor(BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition) | CXTPVisualStudio2008Theme | virtual
GetRegularBoldFont() | CXTPPaintManager |
GetRegularFont() | CXTPPaintManager |
GetRibbonPaintManager() | CXTPPaintManager | virtual
GetScrollBarPaintManager() const | CXTPPaintManager | virtual
GetShadowManager() const | CXTPPaintManager |
GetShadowOptions() const | CXTPPaintManager |
GetSliderPaintManager() const | CXTPPaintManager | virtual
GetSmCaptionFont() | CXTPPaintManager |
GetSplitButtonCommandRect(CXTPControl *pButton) | CXTPPaintManager | virtual
GetStatusBarPaintManager() | CXTPPaintManager | virtual
GetXtremeColor(UINT nIndex) | CXTPPaintManager |
GradientFill(CDC *pDC, LPRECT lpRect, COLORREF crFrom, COLORREF crTo, BOOL bHorz, LPCRECT lpRectClip=NULL) | CXTPPaintManager |
HasFloatingBarGradientEntry(CXTPCommandBar *pBar) | CXTPCommandBarsOffice2003Theme | protectedvirtual
HorizontalLine(CDC *pDC, int x0, int y0, int x1, COLORREF clrPen) | CXTPPaintManager |
IsUseSystemAccentColorEnabled() const | CXTPPaintManager |
Line(CDC *pDC, CPoint p0, CPoint p1) | CXTPPaintManager |
Line(CDC *pDC, int x0, int y0, int x1, int y1, const int nPen) | CXTPPaintManager |
Line(CDC *pDC, int x0, int y0, int x1, int y1, COLORREF clrPen) | CXTPPaintManager |
LoadModernToolbarIcons(UINT nIDResource) | CXTPCommandBarsOffice2003Theme | static
LoadModernToolbarIcons(UINT nIDResource, UINT *pCommands, int nCount, CSize szIcon=CSize(16, 15)) | CXTPCommandBarsOffice2003Theme | static
m_arrColor | CXTPPaintManager | protected
m_bAutoResizeIcons | CXTPPaintManager |
m_bClearTypeTextQuality | CXTPPaintManager |
m_bEmbossedDisabledText | CXTPPaintManager | protected
m_bEnableAnimation | CXTPPaintManager |
m_bFlatMenuBar | CXTPPaintManager |
m_bFlatToolBar | CXTPPaintManager |
m_bLunaTheme | CXTPCommandBarsOffice2003Theme |
m_bOffice2007Padding | CXTPPaintManager |
m_bOffsetPopupLabelText | CXTPPaintManager |
m_bPlainSeparators | CXTPCommandBarsOffice2003Theme |
m_bSelectImageInPopupBar | CXTPPaintManager |
m_bShowKeyboardCues | CXTPPaintManager | protected
m_bShowShadow | CXTPPaintManager |
m_bThemedCheckBox | CXTPPaintManager |
m_bThemedStatusBar | CXTPPaintManager |
m_bThickCheckMark | CXTPPaintManager |
m_bUseOfficeFont | CXTPPaintManager |
m_bUseStandardFont | CXTPPaintManager | protected
m_bWrapCaptionBelowText | CXTPPaintManager |
m_clrCommandBar | CXTPCommandBarsOffice2003Theme |
m_clrDisabledIcon | CXTPPaintManager |
m_clrDockBar | CXTPCommandBarsOffice2003Theme |
m_clrFloatingGripper | CXTPPaintManager |
m_clrFloatingGripperText | CXTPPaintManager |
m_clrMenuExpand | CXTPCommandBarsOffice2003Theme |
m_clrMenuExpandedGripper | CXTPCommandBarsOffice2003Theme |
m_clrMenuGripper | CXTPCommandBarsOffice2003Theme |
m_clrMenuSelection | CXTPVisualStudio2008Theme |
m_clrMenuSelectionBorder | CXTPVisualStudio2008Theme |
m_clrMenuSelectionText | CXTPVisualStudio2008Theme |
m_clrMessageBarText | CXTPPaintManager |
m_clrPopupControl | CXTPCommandBarsOffice2003Theme |
m_clrTearOffGripper | CXTPCommandBarsOffice2003Theme |
m_clrToolbarExpand | CXTPCommandBarsOffice2003Theme |
m_clrToolbarShadow | CXTPCommandBarsOffice2003Theme |
m_fontIcon | CXTPPaintManager |
m_fontIconBold | CXTPPaintManager |
m_fontSmCaption | CXTPPaintManager |
m_fontToolTip | CXTPPaintManager |
m_grcLunaChecked | CXTPCommandBarsOffice2003Theme |
m_grcLunaPushed | CXTPCommandBarsOffice2003Theme |
m_grcLunaSelected | CXTPCommandBarsOffice2003Theme |
m_iconsInfo | CXTPPaintManager | protected
m_ilGradientCircle | CXTPCommandBarsOffice2003Theme |
m_nAnimationSteps | CXTPPaintManager | protected
m_nAnimationTime | CXTPPaintManager | protected
m_nEditHeight | CXTPPaintManager | protected
m_nFontHeight | CXTPPaintManager | protected
m_nPopupBarTextPadding | CXTPPaintManager |
m_nSplitButtonDropDownHeight | CXTPPaintManager |
m_nSplitButtonDropDownWidth | CXTPPaintManager |
m_nSplitButtonPopupWidth | CXTPPaintManager |
m_nStatusBarMinHeight | CXTPPaintManager |
m_nTextHeight | CXTPPaintManager |
m_pfnSetLayeredWindowAttributes | CXTPPaintManager |
m_pFramePaintManager | CXTPPaintManager |
m_pGalleryPaintManager | CXTPPaintManager |
m_pProgressPaintManager | CXTPPaintManager |
m_pRibbonPaintManager | CXTPPaintManager |
m_pScrollBarPaintManager | CXTPPaintManager |
m_pShadowManager | CXTPPaintManager | protected
m_pSliderPaintManager | CXTPPaintManager |
m_pStatusBarPaintManager | CXTPPaintManager |
m_rcMessageBarMargin | CXTPPaintManager |
m_rcStatusBarBorder | CXTPPaintManager |
m_strOfficeFont | CXTPPaintManager |
m_systemTheme | CXTPPaintManager | protected
m_themeButton | CXTPPaintManager | protected
m_themeCurrent | CXTPPaintManager | protected
m_themeStatusBar | CXTPPaintManager | protected
m_xtpFontRegular | CXTPPaintManager | protected
m_xtpFontRegularBold | CXTPPaintManager | protected
m_xtpFontVert | CXTPPaintManager | protected
m_xtpFontVertBold | CXTPPaintManager | protected
Notify(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *)) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
Notify(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1), A1 arg1) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
Notify(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
Notify(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamic(void(T::*method)(O *)) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1), A1 arg1) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *)) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1), A1 arg1) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyReversed(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *)) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyReversed(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1), A1 arg1) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyReversed(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyReversed(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
Pixel(CDC *pDC, int xPos, int yPos, int nPen) | CXTPPaintManager |
Rectangle(CDC *pDC, LPCRECT rc, int nPen, const int nBrush) | CXTPPaintManager |
Rectangle(CDC *pDC, LPCRECT rc, COLORREF clrPen, COLORREF clrBrush) | CXTPPaintManager |
RefreshMetrics() | CXTPVisualStudio2008Theme | virtual
ReleaseInstance() | CXTPPaintManager | static
RequiresResourceImages() | CXTPPaintManager | virtual
RoundRect(CDC *pDC, LPCRECT rc, COLORREF clrPen, COLORREF clrBrush) | CXTPPaintManager |
SetAnimationDelay(int nAnimationSteps, int nAnimationTime) | CXTPPaintManager |
SetColors(int cElements, CONST INT *lpaElements, CONST COLORREF *lpaRgbValues) | CXTPPaintManager |
SetCommandBarRegion(CXTPCommandBar *pCommandBar) | CXTPPaintManager | virtual
SetCommandBarsFontIndirect(LOGFONT *pLogFont, BOOL bUseStandardFont=FALSE) | CXTPPaintManager |
SetCustomTheme(CXTPPaintManager *pTheme) | CXTPPaintManager | static
SetGlobalPaintManager(CXTPPaintManager *pPaintManager) | CXTPPaintManager | static
SetImageHandle(HMODULE hResource, LPCTSTR lpszIniFileName) | CXTPPaintManager | virtual
SetLunaTheme(XTPCurrentSystemTheme systemTheme) | CXTPPaintManager |
SetTheme(XTPPaintTheme paintTheme) | CXTPPaintManager | static
StripMnemonics(CString &strClear) | CXTPPaintManager | static
Subscribe(IXTPPaintManagerEvents *pObserver, CXTPSubscriptionList< CXTPPaintManager, IXTPPaintManagerEvents > *pSubcriptionList=NULL) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > |
Triangle(CDC *pDC, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clr) | CXTPPaintManager | static
Unsubscribe(IXTPPaintManagerEvents *pObserver) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > |
UpdateColors() | CXTPPaintManager | virtual
UpdateFonts() | CXTPPaintManager | virtual
UpdateRTLCaption(CString &strCaption) | CXTPPaintManager | virtual
UseOfficeFont(bool bUseOfficeFont) | CXTPPaintManager |
VerticalLine(CDC *pDC, int x0, int y0, int y1, COLORREF clrPen) | CXTPPaintManager |
~CXTPCommandBarsOffice2003Theme() | CXTPCommandBarsOffice2003Theme | virtual
~CXTPObservable() | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | protected
~CXTPPaintManager() | CXTPPaintManager | protectedvirtual
~CXTPVisualStudio2005Theme() | CXTPVisualStudio2005Theme | virtual
~CXTPVisualStudio2008Theme() | CXTPVisualStudio2008Theme | virtual


Toolkit Pro: Member List

CXTPCalendarCaptionBarPaintManager Member List

This is the complete list of members for CXTPCalendarCaptionBarPaintManager, including all inherited members.

CXTPCalendarCaptionBarPaintManager(CXTPCalendarCaptionBarTheme *pTheme=NULL) | CXTPCalendarCaptionBarPaintManager |
CXTPCmdTarget() | CXTPCmdTarget |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetPaintTheme() const | CXTPCalendarCaptionBarPaintManager | virtual
m_clrBorders | CXTPCalendarCaptionBarPaintManager | protected
m_clrScrollDateBarBk | CXTPCalendarCaptionBarPaintManager | protected
m_clrScrollTriangleColor | CXTPCalendarCaptionBarPaintManager | protected
m_clrSwitchViewBarBk | CXTPCalendarCaptionBarPaintManager | protected
m_clrTextColor | CXTPCalendarCaptionBarPaintManager | protected
m_fntTextFont | CXTPCalendarCaptionBarPaintManager | protected
m_pTheme | CXTPCalendarCaptionBarPaintManager | protected
RefreshMetrics() | CXTPCalendarCaptionBarPaintManager | virtual
~CXTPCalendarCaptionBarPaintManager() | CXTPCalendarCaptionBarPaintManager | virtual


Toolkit Pro: XTPTabThemePropertyPage2003.h Source File

  • Source
  • TabManager
  • Themes
XTPTabThemePropertyPage2003.h
Go to the documentation of this file.
1
23#if !defined(__XTPTABTHEMEPROPERTYPAGE2003_H__)
24# define __XTPTABTHEMEPROPERTYPAGE2003_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
52class _XTP_EXT_CLASS CAppearanceSetPropertyPage2003 : public CXTPTabPaintManagerTheme
53{
54public:
59 CAppearanceSetPropertyPage2003()
60 {
61 m_rcHeaderMargin.SetRect(2, 3, 6, 0);
62 m_bDoubleHighlightedBorder = FALSE;
63 }
64
79 virtual CRect GetHeaderMargin()
80 {
81 return CRect(m_rcHeaderMargin.left + m_nButtonHeight, m_rcHeaderMargin.top,
82 m_rcHeaderMargin.right, m_rcHeaderMargin.bottom);
83 }
84
93 virtual void RefreshMetrics();
94
113 virtual void DrawSingleButton(CDC* pDC, CXTPTabManagerItem* pItem);
114
134 virtual CRect FillTabControl(CXTPTabManager* pTabManager, CDC* pDC, CRect rcControl);
135
144 virtual XTPTabColorStyle GetDefaultColorSet()
145 {
146 return xtpTabColorOffice2003;
147 }
148
159 virtual CRect GetButtonDrawRect(const CXTPTabManagerItem* pItem);
160
161public:
162 BOOL m_bDoubleHighlightedBorder;
164};
165
166# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
168#endif // !defined(__XTPTABTHEMEPROPERTYPAGE2003_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPTabColorStyle
XTPTabColorStyle
XTPTabColorStyle is an enumeration used to set the color style of tabs.
Definition XTPTabManagerDefines.h:139
xtpTabColorOffice2003
@ xtpTabColorOffice2003
Tabs will use the Office 2003 color style for the currently set Appearance.
Definition XTPTabManagerDefines.h:142
CAppearanceSetPropertyPage2003
CAppearanceSetPropertyPage2003 implements an Office 2003 tab appearance.
Definition XTPTabThemePropertyPage2003.h:53
CAppearanceSetPropertyPage2003::GetDefaultColorSet
virtual XTPTabColorStyle GetDefaultColorSet()
Gets the default value of the color set for this theme.
Definition XTPTabThemePropertyPage2003.h:144
CAppearanceSetPropertyPage2003::GetButtonDrawRect
virtual CRect GetButtonDrawRect(const CXTPTabManagerItem *pItem)
Retrieves the bounding rectangle of a specified drawing item.
CAppearanceSetPropertyPage2003::GetHeaderMargin
virtual CRect GetHeaderMargin()
Gets the top, left, right, and bottom margins of the tab header.
Definition XTPTabThemePropertyPage2003.h:79
CAppearanceSetPropertyPage2003::FillTabControl
virtual CRect FillTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl)
Fills both the tab header and the tab client area and then draws the tab client frame.
CAppearanceSetPropertyPage2003::DrawSingleButton
virtual void DrawSingleButton(CDC *pDC, CXTPTabManagerItem *pItem)
Draws a single tab button in the tab client header area.
CAppearanceSetPropertyPage2003::RefreshMetrics
virtual void RefreshMetrics()
Refreshes the appearance metrics.
CAppearanceSetPropertyPage2003::CAppearanceSetPropertyPage2003
CAppearanceSetPropertyPage2003()
Constructs a CAppearanceSetPropertyPage2003 object.
Definition XTPTabThemePropertyPage2003.h:59
CAppearanceSetPropertyPage2003::m_bDoubleHighlightedBorder
BOOL m_bDoubleHighlightedBorder
TRUE to draw a double border on mouse over when hot tracking is enabled.
Definition XTPTabThemePropertyPage2003.h:162
CXTPTabManager
CXTPTabManager is the base class for docking pane tabs, tab control tabs, and MDI client tabs.
Definition XTPTabManager.h:87
CXTPTabManagerItem
CXTPTabManagerItem is the base class for the tabs that appear in the command bars tab workspace,...
Definition XTPTabManagerItem.h:44
CXTPTabPaintManagerTheme
CXTPTabPaintManagerTheme is a class that represents the appearance of all components of the tab manag...
Definition XTPTabPaintManagerTheme.h:56


Toolkit Pro: Member List

CXTPChartPointSeriesLabel Member List

This is the complete list of members for CXTPChartPointSeriesLabel, including all inherited members.

CreateView(CXTPChartDeviceContext *pDC, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView) | CXTPChartPointSeriesLabel | virtual
CXTPChartDiagram2DSeriesLabel() | CXTPChartDiagram2DSeriesLabel |
CXTPChartElement() | CXTPChartElement |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartPointSeriesLabel() | CXTPChartPointSeriesLabel |
CXTPChartSeriesLabel() | CXTPChartSeriesLabel |
DoPropExchange(CXTPPropExchange *pPX) | CXTPChartPointSeriesLabel | virtual
GetAngle() const | CXTPChartPointSeriesLabel |
GetAntialiasing() const | CXTPChartSeriesLabel | virtual
GetAppearance() const | CXTPChartElement |
GetBackColor() const | CXTPChartSeriesLabel |
GetContent() const | CXTPChartElement |
GetFont() const | CXTPChartSeriesLabel | virtual
GetFormat() const | CXTPChartSeriesLabel |
GetLineColor() const | CXTPChartSeriesLabel |
GetLineLength() const | CXTPChartSeriesLabel |
GetOwner() const | CXTPChartElement |
GetShowLines() const | CXTPChartSeriesLabel |
GetTextColor() const | CXTPChartSeriesLabel |
GetTransparency() const | CXTPChartSeriesLabel |
Is3D() const | CXTPChartObject |
IsVisible() const | CXTPChartSeriesLabel |
m_bAntialiasing | CXTPChartSeriesLabel | protected
m_bShowLines | CXTPChartSeriesLabel | protected
m_bVisible | CXTPChartSeriesLabel | protected
m_clrBackColor | CXTPChartSeriesLabel | protected
m_clrLineColor | CXTPChartSeriesLabel | protected
m_clrTextColor | CXTPChartSeriesLabel | protected
m_nAngle | CXTPChartPointSeriesLabel | protected
m_nLineLength | CXTPChartSeriesLabel | protected
m_nTransparency | CXTPChartSeriesLabel | protected
m_pBorder | CXTPChartSeriesLabel | protected
m_pFont | CXTPChartSeriesLabel | protected
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartElement | virtual
Release() | CXTPChartElement | virtual
SetAngle(int nAngle) | CXTPChartPointSeriesLabel |
SetAntialiasing(BOOL bAntialiasing) | CXTPChartSeriesLabel |
SetBackColor(const CXTPChartColor &clrBackColor) | CXTPChartSeriesLabel |
SetFont(CXTPChartFont *pFont) | CXTPChartSeriesLabel |
SetFormat(LPCTSTR lpszFormat) | CXTPChartSeriesLabel |
SetLineColor(const CXTPChartColor &clrBackColor) | CXTPChartSeriesLabel |
SetLineLength(int nLineLength) | CXTPChartSeriesLabel |
SetShowLines(BOOL bShowLines) | CXTPChartSeriesLabel |
SetTextColor(const CXTPChartColor &clrTextColor) | CXTPChartSeriesLabel |
SetTransparency(int nTransparency) | CXTPChartSeriesLabel |
SetVisible(BOOL bVisible) | CXTPChartSeriesLabel |
~CXTPChartDiagram2DSeriesLabel() | CXTPChartDiagram2DSeriesLabel | virtual
~CXTPChartElement() | CXTPChartElement | virtual
~CXTPChartPointSeriesLabel() | CXTPChartPointSeriesLabel | virtual
~CXTPChartSeriesLabel() | CXTPChartSeriesLabel | virtual


Toolkit Pro: XTPGridRow.h Source File

  • Source
  • GridControl
XTPGridRow.h
Go to the documentation of this file.
1
23#if !defined(__XTPGRIDROW_H__)
24# define __XTPGRIDROW_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPGridRecord;
34class CXTPGridControl;
35class CXTPGridTip;
36class CXTPGridRecordItem;
37class CXTPGridRows;
38class CXTPGridColumn;
39class CXTPGridRecordMergeItems;
40class CXTPGridSection;
41
42struct XTP_GRIDRECORDITEM_DRAWARGS;
43struct XTP_GRIDRECORDITEM_METRICS;
44struct XTP_GRIDRECORDITEM_CLICKARGS;
45
46class _XTP_EXT_CLASS CXTPGridRowBase
47 : public CXTPCmdTarget
48 , public CXTPAccessible
49{
50};
51
70class _XTP_EXT_CLASS CXTPGridRow : public CXTPHeapObjectT<CXTPGridRowBase, CXTPGridRowAllocator>
71{
73 DECLARE_INTERFACE_MAP()
74 DECLARE_DYNAMIC(CXTPGridRow)
76public:
81 CXTPGridRow();
82
87 virtual ~CXTPGridRow();
88
89public:
95 virtual void InitRow(CXTPGridRow* pRow);
103 virtual void InitRow(CXTPGridControl* pControl, CXTPGridSection* pSection,
104 CXTPGridRecord* pRecord);
105
117 virtual CXTPGridRecord* GetRecord() const;
118
137 virtual void Draw(CDC* pDC, CRect rcRow, CRect rcClip, int nLeftOffset,
138 CXTPGridRecordMergeItems& mergeItems, int nColumnFrom, int nColumnTo);
139
140 virtual void DrawItemGrid(CDC* pDC, CXTPGridColumn* pColumn, CRect rcGridItem);
141
155 virtual int GetHeight(CDC* pDC, int nWidth);
156
166 virtual int GetIndex() const;
167
179 virtual BOOL IsFocused() const;
180
192 virtual BOOL IsSelected() const;
193
205 virtual BOOL IsExpanded() const;
206
218 virtual void SetExpanded(BOOL bExpanded, BOOL bRecursive = FALSE);
219
232 virtual void _SetExpanded(BOOL bExpanded, BOOL bRecursive, BOOL bNotify);
233
242 void SetFullExpanded(BOOL bExpanded);
243
255 virtual BOOL IsVisible() const;
256
267 virtual void SetVisible(BOOL bVisible);
268
275 virtual BOOL IsLockExpand() const;
276
283 virtual void LockExpand(BOOL bLockExpand);
284
292 virtual void SetSelected(BOOL bSelected);
293
298 virtual void SelectChilds();
299
309 virtual BOOL IsGroupRow() const;
310
324 virtual CXTPGridRecordItem* HitTest(CPoint ptPoint, CRect* pRectItem = NULL,
325 CXTPGridColumn** ppColumn = NULL) const;
326
341 virtual void OnClick(CPoint ptClicked);
342
354 virtual BOOL OnLButtonDown(XTP_GRIDRECORDITEM_CLICKARGS* pClickArgs);
355
367 virtual BOOL OnLButtonUp(XTP_GRIDRECORDITEM_CLICKARGS* pClickArgs);
368
383 virtual void OnDblClick(CPoint ptClicked);
384
398 virtual void OnMouseMove(UINT nFlags, CPoint point);
399
414 virtual void OnContextMenu(CPoint ptClick);
415
427 virtual void ShowToolTip(CPoint ptTip, CXTPGridTip* pTipWnd);
428
439 virtual void SetControl(CXTPGridControl* pControl);
440
452 virtual CXTPGridControl* GetControl() const;
453
466 virtual CXTPGridRow* GetParentRow() const;
467
480 virtual CXTPGridRows* GetParentRows() const;
481
494 virtual int GetTreeDepth() const;
495
508 virtual BOOL HasParent(CXTPGridRow* pRow);
509
524 virtual CXTPGridRows* GetChilds(BOOL bCreate = TRUE);
525
538 virtual CXTPGridRow* AddChild(CXTPGridRow* pRow);
539
551 virtual BOOL HasChildren() const;
552
565 virtual CXTPGridRow* GetNextSiblingRow() const;
566
578 virtual void SetCollapseRect(CRect rcCollapse);
579
588 virtual BOOL IsPreviewVisible() const;
589
598 virtual BOOL IsItemsVisible() const;
599
611 virtual CRect GetRect() const;
612
622 virtual void GetItemMetrics(XTP_GRIDRECORDITEM_DRAWARGS* pDrawArgs,
623 XTP_GRIDRECORDITEM_METRICS* pItemMetrics);
624
631 virtual int GetGroupLevel() const;
632
640 virtual CRect GetItemRect(CXTPGridRecordItem* pItem);
641
649 virtual BOOL IsLastTreeRow() const;
650
659 virtual void EnsureVisible();
660
661public:
671 virtual void ShiftTreeIndent(CRect& rcItem, CXTPGridColumn* pColumn) const;
672
683 virtual void FillMetrics(CXTPGridColumn* pColumn, CXTPGridRecordItem* pItem,
684 XTP_GRIDRECORDITEM_METRICS* pMetrics);
685
697 virtual INT_PTR OnToolHitTest(CPoint point, TOOLINFO* pTI);
698
706 XTPGridRowType GetType() const;
707
714 CXTPGridSection* GetSection() const;
715
722 BOOL HasMergedItems() const;
723
734 void SetMergeHeight(int nMergeHeight);
735
746 int GetMergeHeight() const;
747
748protected:
757 CRect GetItemRect(CXTPGridRecordItem* pItem, BOOL bAsMerged);
758
764 virtual void SetIndex(int nNewIndex);
765
773 int GetLastChildRow(CXTPGridRows* pChildren) const;
774
776 // System accessibility support.
777 virtual HRESULT GetAccessibleParent(IDispatch** ppdispParent);
778 virtual HRESULT GetAccessibleChildCount(long* pcountChildren);
779 virtual HRESULT GetAccessibleChild(VARIANT varChild, IDispatch** ppdispChild);
780 virtual HRESULT GetAccessibleName(VARIANT varChild, BSTR* pszName);
781 virtual HRESULT GetAccessibleRole(VARIANT varChild, VARIANT* pvarRole);
782 virtual HRESULT AccessibleLocation(long* pxLeft, long* pyTop, long* pcxWidth, long* pcyHeight,
783 VARIANT varChild);
784 virtual HRESULT AccessibleHitTest(long xLeft, long yTop, VARIANT* pvarChild);
785 virtual HRESULT GetAccessibleState(VARIANT varChild, VARIANT* pvarState);
786 virtual CCmdTarget* GetAccessible();
789protected:
790 CXTPGridControl* m_pControl;
791 CXTPGridRecord* m_pRecord;
792 CXTPGridRow* m_pParentRow;
793 CXTPGridRows* m_pParentRows;
794 CXTPGridRows* m_pChilds;
795 CXTPGridSection* m_pSection;
797 CRect m_rcRow;
798 CRect m_rcCollapse;
800 int m_nIndex;
801 int m_nGroupLevel;
802 int m_nRowLevel;
804 BOOL m_bVisible;
805 BOOL m_bExpanded;
806 BOOL m_bLockExpand;
807 BOOL m_bHasSelectedChilds;
809 int m_nPreviewHeight;
810 int m_nFreeHeight;
811 int m_nMergeHeight;
813 int m_nChildIndex;
815private:
816# ifdef _XTP_ACTIVEX
818 DECLARE_DISPATCH_MAP()
819
820 DECLARE_OLETYPELIB_EX(CXTPGridRow);
821
822 afx_msg LPDISPATCH OleGetRecord();
823 afx_msg LPDISPATCH OleGetChilds();
824 afx_msg LPDISPATCH OleGetParentRow();
825 afx_msg LPDISPATCH OleGetSection();
826 afx_msg LPDISPATCH OleGetNextSiblingRow();
827 afx_msg void OleGetRect(long* Left, long* Top, long* Right, long* Bottom);
828 afx_msg void OleGetItemRect(LPDISPATCH lpDispatch, long* Left, long* Top, long* Right,
829 long* Bottom);
830 afx_msg void OleGetItemRectAsMerged(LPDISPATCH lpDispatch, long* Left, long* Top, long* Right,
831 long* Bottom, VARIANT_BOOL fAsMerged);
832
833public:
834 static CXTPGridRow* AFX_CDECL FromDispatch(LPDISPATCH pDisp);
835
837# endif /*_XTP_ACTIVEX*/
838
840 friend class CXTPGridControl;
841 friend class CXTPGridSelectedRows;
842 friend class CXTPGridRows;
843 friend class CXTPGridRecordItem;
844 friend class CXTPGridSection;
845 friend class CXTPGridPaintManager;
847};
848
849AFX_INLINE void CXTPGridRow::SetIndex(int nNewIndex)
850{
851 m_nIndex = nNewIndex;
852}
853
854AFX_INLINE CXTPGridRecord* CXTPGridRow::GetRecord() const
855{
856 return m_pRecord;
857}
858
859AFX_INLINE CXTPGridRow* CXTPGridRow::GetParentRow() const
860{
861 return m_pParentRow;
862}
863
864AFX_INLINE void CXTPGridRow::SetControl(CXTPGridControl* pControl)
865{
866 m_pControl = pControl;
867}
868
869AFX_INLINE CXTPGridControl* CXTPGridRow::GetControl() const
870{
871 return m_pControl;
872}
873
874AFX_INLINE void CXTPGridRow::SetCollapseRect(CRect rcCollapse)
875{
876 m_rcCollapse = rcCollapse;
877}
878
879AFX_INLINE CRect CXTPGridRow::GetRect() const
880{
881 return m_rcRow;
882}
883
884AFX_INLINE int CXTPGridRow::GetGroupLevel() const
885{
886 return m_nGroupLevel;
887}
888
889AFX_INLINE CXTPGridRows* CXTPGridRow::GetParentRows() const
890{
891 return m_pParentRows;
892}
893
894AFX_INLINE CXTPGridSection* CXTPGridRow::GetSection() const
895{
896 return m_pSection;
897}
898
899AFX_INLINE void CXTPGridRow::SetMergeHeight(int nMergeHeight)
900{
901 m_nMergeHeight = nMergeHeight;
902}
903
904AFX_INLINE int CXTPGridRow::GetMergeHeight() const
905{
906 return m_nMergeHeight;
907}
909# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
910#endif //#if !defined(__XTPGRIDROW_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPGridRowType
XTPGridRowType
This enum defines body, header, and footer rows.
Definition XTPGridDefines.h:94
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPGridColumn
Represents a grid column item with its properties and operations.
Definition XTPGridColumn.h:107
CXTPGridControl
The CXTPGridControl class provides an implementation of the Grid control.
Definition XTPGridControl.h:479
CXTPGridPaintManager
Utility class that handles most drawing activities.
Definition XTPGridPaintManager.h:76
CXTPGridRecord
CXTPGridRecord represents a collection of CXTPGridRecordItem objects or objects of classes that are c...
Definition XTPGridRecord.h:59
CXTPGridRecordItem
Class for working with single list cell.
Definition XTPGridRecordItem.h:600
CXTPGridRow
CXTPGridRow class represents a row of the Grid control window.
Definition XTPGridRow.h:71
CXTPGridRow::OnDblClick
virtual void OnDblClick(CPoint ptClicked)
Processes double mouse clicks.
CXTPGridRow::GetParentRows
virtual CXTPGridRows * GetParentRows() const
Gets the parent rows of the current row.
Definition XTPGridRow.h:889
CXTPGridRow::SetIndex
virtual void SetIndex(int nNewIndex)
Sets the index of the current row in the corresponding rows collection.
Definition XTPGridRow.h:849
CXTPGridRow::_SetExpanded
virtual void _SetExpanded(BOOL bExpanded, BOOL bRecursive, BOOL bNotify)
Sets the expanded state for the current row.
CXTPGridRow::GetLastChildRow
int GetLastChildRow(CXTPGridRows *pChildren) const
Gets the index of the last child row in a specified child row collection.
CXTPGridRow::IsVisible
virtual BOOL IsVisible() const
Determines the visible state of the current row.
CXTPGridRow::ShiftTreeIndent
virtual void ShiftTreeIndent(CRect &rcItem, CXTPGridColumn *pColumn) const
Updates the rectangle of an item.
CXTPGridRow::HasMergedItems
BOOL HasMergedItems() const
Determines if the current row has merged items.
CXTPGridRow::GetHeight
virtual int GetHeight(CDC *pDC, int nWidth)
Calculates the height of the current row depending on the specified device context.
CXTPGridRow::m_pParentRows
CXTPGridRows * m_pParentRows
Pointer to the parent rows in the tree.
Definition XTPGridRow.h:793
CXTPGridRow::IsLockExpand
virtual BOOL IsLockExpand() const
Determines if the user's ability to collapse/expand rows is locked.
CXTPGridRow::LockExpand
virtual void LockExpand(BOOL bLockExpand)
Specifies if the user's ability to collapse/expand rows should be locked.
CXTPGridRow::GetIndex
virtual int GetIndex() const
Gets the current row index in the view.
CXTPGridRow::m_bExpanded
BOOL m_bExpanded
TRUE if row is expanded in a tree view, FALSE if row is collapsed.
Definition XTPGridRow.h:805
CXTPGridRow::m_nFreeHeight
int m_nFreeHeight
Height of row in FreeHeight RC mode.
Definition XTPGridRow.h:810
CXTPGridRow::m_pChilds
CXTPGridRows * m_pChilds
Pointer to collection of children.
Definition XTPGridRow.h:794
CXTPGridRow::OnClick
virtual void OnClick(CPoint ptClicked)
Processes single mouse clicks.
CXTPGridRow::SetSelected
virtual void SetSelected(BOOL bSelected)
Sets the selected state for the current row.
CXTPGridRow::GetItemRect
CRect GetItemRect(CXTPGridRecordItem *pItem, BOOL bAsMerged)
Gets the rectangle of a specified item.
CXTPGridRow::m_nChildIndex
int m_nChildIndex
Index of row inside parent rows.
Definition XTPGridRow.h:813
CXTPGridRow::GetType
XTPGridRowType GetType() const
Determine the type of the current row (i.e.
CXTPGridRow::SelectChilds
virtual void SelectChilds()
Selects all child items of the current row.
CXTPGridRow::GetGroupLevel
virtual int GetGroupLevel() const
Gets the row depth level when the current row is a group row.
Definition XTPGridRow.h:884
CXTPGridRow::SetFullExpanded
void SetFullExpanded(BOOL bExpanded)
Sets the expanded state for the current row and its children.
CXTPGridRow::GetItemMetrics
virtual void GetItemMetrics(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pItemMetrics)
Gets the drawing metrics of the current row.
CXTPGridRow::IsSelected
virtual BOOL IsSelected() const
Gets the selected state of the current row.
CXTPGridRow::InitRow
virtual void InitRow(CXTPGridControl *pControl, CXTPGridSection *pSection, CXTPGridRecord *pRecord)
Performs initial initialization for the current row.
CXTPGridRow::m_nGroupLevel
int m_nGroupLevel
Contains row depth level when row is a group row.
Definition XTPGridRow.h:801
CXTPGridRow::SetVisible
virtual void SetVisible(BOOL bVisible)
Sets the visible state for the current row.
CXTPGridRow::m_nIndex
int m_nIndex
Item index.
Definition XTPGridRow.h:800
CXTPGridRow::GetRecord
virtual CXTPGridRecord * GetRecord() const
Gets the record associated with the current row.
Definition XTPGridRow.h:854
CXTPGridRow::GetMergeHeight
int GetMergeHeight() const
Gets the height of the current row calculated during merge cell processing.
Definition XTPGridRow.h:904
CXTPGridRow::AddChild
virtual CXTPGridRow * AddChild(CXTPGridRow *pRow)
Adds a child row to the current row.
CXTPGridRow::GetTreeDepth
virtual int GetTreeDepth() const
Gets the depth of the current row in tree view.
CXTPGridRow::m_pSection
CXTPGridSection * m_pSection
Pointer to section the row belongs to.
Definition XTPGridRow.h:795
CXTPGridRow::Draw
virtual void Draw(CDC *pDC, CRect rcRow, CRect rcClip, int nLeftOffset, CXTPGridRecordMergeItems &mergeItems, int nColumnFrom, int nColumnTo)
Draws the current row on the specified device context.
CXTPGridRow::OnToolHitTest
virtual INT_PTR OnToolHitTest(CPoint point, TOOLINFO *pTI)
The framework calls this member function to determine whether a point is in the bounding rectangle of...
CXTPGridRow::GetParentRow
virtual CXTPGridRow * GetParentRow() const
Gets the parent row of the current row.
Definition XTPGridRow.h:859
CXTPGridRow::m_nRowLevel
int m_nRowLevel
Row depth level in a tree.
Definition XTPGridRow.h:802
CXTPGridRow::SetExpanded
virtual void SetExpanded(BOOL bExpanded, BOOL bRecursive=FALSE)
Sets the expanded state for the current row.
CXTPGridRow::HitTest
virtual CXTPGridRecordItem * HitTest(CPoint ptPoint, CRect *pRectItem=NULL, CXTPGridColumn **ppColumn=NULL) const
Determines which grid item, if any, is at a specified point.
CXTPGridRow::IsLastTreeRow
virtual BOOL IsLastTreeRow() const
Determine if the current row is the last tree row or is not a part of a tree row.
CXTPGridRow::~CXTPGridRow
virtual ~CXTPGridRow()
Destroys a CXTPGridRow object, handles cleanup and deallocation.
CXTPGridRow::m_pControl
CXTPGridControl * m_pControl
Pointer to the parent Grid control.
Definition XTPGridRow.h:790
CXTPGridRow::m_nMergeHeight
int m_nMergeHeight
Height of row which calculated on merge cells processing.
Definition XTPGridRow.h:811
CXTPGridRow::FillMetrics
virtual void FillMetrics(CXTPGridColumn *pColumn, CXTPGridRecordItem *pItem, XTP_GRIDRECORDITEM_METRICS *pMetrics)
Fills an XTP_GRIDRECORDITEM_METRICS structure with drawing metrics.
CXTPGridRow::m_rcRow
CRect m_rcRow
A rectangle where a row is to be drawn.
Definition XTPGridRow.h:797
CXTPGridRow::m_pRecord
CXTPGridRecord * m_pRecord
Pointer to the associated CXTPGridRecord object.
Definition XTPGridRow.h:791
CXTPGridRow::IsItemsVisible
virtual BOOL IsItemsVisible() const
Determines if items are visible.
CXTPGridRow::EnsureVisible
virtual void EnsureVisible()
Ensures that the current row is visible.
CXTPGridRow::m_bLockExpand
BOOL m_bLockExpand
TRUE if row cannot be expanded/collapsed by the user.
Definition XTPGridRow.h:806
CXTPGridRow::GetNextSiblingRow
virtual CXTPGridRow * GetNextSiblingRow() const
Gets the next sibling row of the current row.
CXTPGridRow::InitRow
virtual void InitRow(CXTPGridRow *pRow)
Performs initial initialization for the current row.
CXTPGridRow::m_bVisible
BOOL m_bVisible
TRUE if this row should be visible, FALSE if row is hidden.
Definition XTPGridRow.h:804
CXTPGridRow::OnLButtonUp
virtual BOOL OnLButtonUp(XTP_GRIDRECORDITEM_CLICKARGS *pClickArgs)
Processes mouse left button up clicks.
CXTPGridRow::OnLButtonDown
virtual BOOL OnLButtonDown(XTP_GRIDRECORDITEM_CLICKARGS *pClickArgs)
Processes mouse left button down clicks.
CXTPGridRow::GetSection
CXTPGridSection * GetSection() const
Gets the section that the current row belongs to.
Definition XTPGridRow.h:894
CXTPGridRow::OnMouseMove
virtual void OnMouseMove(UINT nFlags, CPoint point)
Processes the move mouse event.
CXTPGridRow::OnContextMenu
virtual void OnContextMenu(CPoint ptClick)
Processes context menu.
CXTPGridRow::IsExpanded
virtual BOOL IsExpanded() const
Gets the expanded state of the current row.
CXTPGridRow::m_pParentRow
CXTPGridRow * m_pParentRow
Pointer to the parent row in the tree.
Definition XTPGridRow.h:792
CXTPGridRow::CXTPGridRow
CXTPGridRow()
Constructs a CXTPGridRow object.
CXTPGridRow::m_rcCollapse
CRect m_rcCollapse
A rectangle with coordinates of collapse/expand bitmap.
Definition XTPGridRow.h:798
CXTPGridRow::m_nPreviewHeight
int m_nPreviewHeight
Height of the preview item of this row.
Definition XTPGridRow.h:809
CXTPGridRow::IsPreviewVisible
virtual BOOL IsPreviewVisible() const
Determines if the preview item is visible for the current row.
CXTPGridRow::GetRect
virtual CRect GetRect() const
Gets the coordinates of the row rectangle.
Definition XTPGridRow.h:879
CXTPGridRow::IsFocused
virtual BOOL IsFocused() const
Gets the focused state of the current row.
CXTPGridRow::IsGroupRow
virtual BOOL IsGroupRow() const
Determines if the current row is a group row.
CXTPGridRow::SetCollapseRect
virtual void SetCollapseRect(CRect rcCollapse)
Sets the coordinates of the collapse/expand button for the current row.
Definition XTPGridRow.h:874
CXTPGridRow::HasParent
virtual BOOL HasParent(CXTPGridRow *pRow)
Determines if a specified row has a parent row in tree view.
CXTPGridRow::GetChilds
virtual CXTPGridRows * GetChilds(BOOL bCreate=TRUE)
Gets the child collection of the current row.
CXTPGridRow::GetItemRect
virtual CRect GetItemRect(CXTPGridRecordItem *pItem)
Gets the rectangle of a specified item.
CXTPGridRow::GetControl
virtual CXTPGridControl * GetControl() const
Gets the parent Grid control.
Definition XTPGridRow.h:869
CXTPGridRow::SetMergeHeight
void SetMergeHeight(int nMergeHeight)
Sets the height of the current row calculated during merge cell processing.
Definition XTPGridRow.h:899
CXTPGridRow::ShowToolTip
virtual void ShowToolTip(CPoint ptTip, CXTPGridTip *pTipWnd)
Shows a specified tooltip window at a specified position.
CXTPGridRow::SetControl
virtual void SetControl(CXTPGridControl *pControl)
Sets the parent Grid control.
Definition XTPGridRow.h:864
CXTPGridRow::m_bHasSelectedChilds
BOOL m_bHasSelectedChilds
TRUE if the row has selected children (on any deep level).
Definition XTPGridRow.h:807
CXTPGridRow::HasChildren
virtual BOOL HasChildren() const
Determines if the current row has child rows in tree view.
CXTPGridRows
This class represents a rows collection class.
Definition XTPGridRows.h:108
CXTPGridSection
Represents a grid section.
Definition XTPGridSection.h:61
CXTPGridSelectedRows
Encapsulates a collection of CXTPGridRow pointers that represent the selected rows in a Grid control.
Definition XTPGridSelectedRows.h:73
CXTPGridTip
The CXTPGridTip class encapsulates the functionality of a "tip control", a small pop-up window that d...
Definition XTPGridTip.h:50
CXTPHeapObjectT
This template class used as a helper class to override new/delete operators and use custom heap alloc...
Definition XTPCustomHeap.h:335
XTP_GRIDRECORDITEM_CLICKARGS
A set of parameters transferred to mouse click item handlers.
Definition XTPGridRecordItem.h:149
XTP_GRIDRECORDITEM_DRAWARGS
A set of parameters transferred to the Draw item handler.
Definition XTPGridRecordItem.h:125
XTP_GRIDRECORDITEM_METRICS
Record item drawing metrics.
Definition XTPGridRecordItem.h:356


Toolkit Pro: XTPMarkupThickness.h Source File

  • Source
  • Markup
XTPMarkupThickness.h
Go to the documentation of this file.
1
23#if !defined(__XTPMARKUPTHICKNESS_H__)
24# define __XTPMARKUPTHICKNESS_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPMarkupObject;
34class CXTPMarkupBuilder;
35
41class _XTP_EXT_CLASS CXTPMarkupThickness : public CXTPMarkupObject
42{
44 DECLARE_MARKUPCLASS(CXTPMarkupThickness);
46 struct DefaultThicknessTag
47 {
48 };
49
50public:
56 CXTPMarkupThickness();
57
64 CXTPMarkupThickness(const CXTPMarkupThickness& other);
65
72 CXTPMarkupThickness(long nThickness);
73
81 CXTPMarkupThickness(long nXThickness, long nYThickness);
82
92 CXTPMarkupThickness(long nLeft, long nTop, long nRight, long nBottom);
93
94public:
95 static CXTPMarkupThickness* AFX_CDECL CreateValue();
96
97 CSize GetSize() const;
98
99 BOOL IsZero() const;
100
101 static CRect AFX_CDECL HelperDeflateRect(CRect rt, CXTPMarkupThickness* thick);
102
103 CXTPMarkupObject* ConvertFrom(CXTPMarkupBuilder* pBuilder, CXTPMarkupObject* pObject) const;
104
111 long GetLeft() const;
112
118 void SetLeft(long nThickness);
119
126 long GetTop() const;
127
134 long GetRight() const;
135
142 long GetBottom() const;
143
144 virtual BOOL IsEqual(const CXTPMarkupObject* pObject) const;
145
147public:
148 DECLARE_DISPATCH_MAP()
149# ifdef _XTP_ACTIVEX
150 DECLARE_INTERFACE_MAP()
151 DECLARE_OLETYPELIB_EX(CXTPMarkupThickness);
152# endif
153
156protected:
157 long m_left;
158 long m_top;
159 long m_right;
160 long m_bottom;
161};
162
163AFX_INLINE long CXTPMarkupThickness::GetLeft() const
164{
165 return m_left;
166}
167AFX_INLINE long CXTPMarkupThickness::GetTop() const
168{
169 return m_top;
170}
171AFX_INLINE long CXTPMarkupThickness::GetRight() const
172{
173 return m_right;
174}
175AFX_INLINE long CXTPMarkupThickness::GetBottom() const
176{
177 return m_bottom;
178}
179AFX_INLINE CSize CXTPMarkupThickness::GetSize() const
180{
181 return CSize(m_left + m_right, m_top + m_bottom);
182}
183AFX_INLINE BOOL CXTPMarkupThickness::IsZero() const
184{
185 return m_left == 0 && m_right == 0 && m_top == 0 && m_bottom == 0;
186}
188# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
189#endif // #if !defined(__XTPMARKUPTHICKNESS_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPMarkupThickness
The CXTPMarkupThickness class describes the thickness of the left, top, right, and bottom sides of a ...
Definition XTPMarkupThickness.h:42
CXTPMarkupThickness::CXTPMarkupThickness
CXTPMarkupThickness(long nLeft, long nTop, long nRight, long nBottom)
Constructs a CXTPMarkupThickness object and sets the left, top, right, and bottom thickness.
CXTPMarkupThickness::GetBottom
long GetBottom() const
Gets the bottom thickness.
Definition XTPMarkupThickness.h:175
CXTPMarkupThickness::GetTop
long GetTop() const
Gets the top thickness.
Definition XTPMarkupThickness.h:167
CXTPMarkupThickness::CXTPMarkupThickness
CXTPMarkupThickness(long nXThickness, long nYThickness)
Constructs a CXTPMarkupThickness object and sets the left/right and top/bottom thickness.
CXTPMarkupThickness::GetLeft
long GetLeft() const
Gets the left thickness.
Definition XTPMarkupThickness.h:163
CXTPMarkupThickness::GetRight
long GetRight() const
Gets the right thickness.
Definition XTPMarkupThickness.h:171
CXTPMarkupThickness::SetLeft
void SetLeft(long nThickness)
Sets the left thickness.
CXTPMarkupThickness::CXTPMarkupThickness
CXTPMarkupThickness(const CXTPMarkupThickness &other)
Constructs a CXTPMarkupThickness object and sets the left, top, right, and bottom thickness.
CXTPMarkupThickness::CXTPMarkupThickness
CXTPMarkupThickness()
Constructs a CXTPMarkupThickness object and sets the left, top, right, and bottom thickness to 0.
CXTPMarkupThickness::CXTPMarkupThickness
CXTPMarkupThickness(long nThickness)
Constructs a CXTPMarkupThickness object and sets the left, top, right, and bottom thickness.


Toolkit Pro: Member List

CXTPGaugeCtrl Member List

This is the complete list of members for CXTPGaugeCtrl, including all inherited members.

Create(DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID, CCreateContext *pContext=NULL) | CXTPGaugeCtrl | virtual
CreateEx(DWORD dwExStyle, DWORD dwStyle, int x, int y, int nWidth, int nHeight, HWND hWndParent, HMENU nIDorHMenu, LPVOID lpParam=NULL) | CXTPGaugeCtrl | virtual
CreateEx(DWORD dwExStyle, DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID, LPVOID lpParam=NULL) | CXTPGaugeCtrl | virtual
CXTPGaugeCtrl() | CXTPGaugeCtrl |
GetCilentSite() const | CXTPGaugeCtrl |
GetMeterType() | CXTPGaugeCtrl |
GetMeterType() const | CXTPGaugeCtrl |
GetStateType() | CXTPGaugeCtrl |
GetStateType() const | CXTPGaugeCtrl |
GetType() | CXTPGaugeCtrl |
GetType() const | CXTPGaugeCtrl |
IsLoaded() const | CXTPGaugeCtrl |
IsMeterType() const | CXTPGaugeCtrl |
IsStateType() const | CXTPGaugeCtrl |
IsType(CRuntimeClass *pClass) const | CXTPGaugeCtrl |
Load(CRuntimeClass *pClass, IStream &source, const CXTPGaugeTraits &traits) | CXTPGaugeCtrl |
LoadMeterType(IStream &source, const CXTPGaugeTraits &traits) | CXTPGaugeCtrl |
LoadStateType(IStream &source, const CXTPGaugeTraits &traits) | CXTPGaugeCtrl |
RegisterWindowClass(HINSTANCE hInstance=NULL) | CXTPGaugeCtrl |
SetCilentSite(IXTPGaugeClientSite *pSite) | CXTPGaugeCtrl |
Unload() | CXTPGaugeCtrl |
~CXTPGaugeCtrl() | CXTPGaugeCtrl |


Toolkit Pro: XTPChartFunnelSeriesLabel.h Source File

  • Source
  • Chart
  • Styles
  • Funnel
XTPChartFunnelSeriesLabel.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTFUNNELSERIESLABEL_H__)
24# define __XTPCHARTFUNNELSERIESLABEL_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Chart/Styles/Funnel/Base/XTPChartFunnelSeriesLabelBase.h"
32# include "Chart/Styles/Funnel/2D/XTPChart2dFunnelSeriesLabel.h"
33
34// CXTPChart2dFunnelSeriesLabel alias is necessary for naming consistency.
35typedef CXTPChartFunnelSeriesLabel CXTPChart2dFunnelSeriesLabel;
37#endif //#if !defined(__XTPCHARTFUNNELSERIESLABEL_H__)
XTPChart2dFunnelSeriesLabel.h
XTPChartFunnelSeriesLabelBase.h
CXTPChartFunnelSeriesLabel
CXTPChartFunnelSeriesLabel is a kind of CXTPChartSeriesLabel.
Definition XTPChart2dFunnelSeriesLabel.h:43


Toolkit Pro: XTPRibbonBackstageButtonThemeVisualStudio2022.h Source File

  • Source
  • Ribbon
  • Backstage
XTPRibbonBackstageButtonThemeVisualStudio2022.h
Go to the documentation of this file.
1
23#if !defined(__XTPRIBBONBACKSTAGEBUTTONTHEMEVISUALSTUDIO2022T_H__)
24# define __XTPRIBBONBACKSTAGEBUTTONTHEMEVISUALSTUDIO2022T_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class _XTP_EXT_CLASS CXTPRibbonBackstageButtonThemeVisualStudio2022
34 : public CXTPButtonThemeVisualStudio2022
35{
36public:
37 CXTPRibbonBackstageButtonThemeVisualStudio2022();
38
39public:
40 void DrawButtonBackground(CDC* pDC, CXTPButton* pButton);
41
42protected:
43 friend class CBackstageButtonCtrl;
44};
45
46# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
48#endif // !defined(__XTPRIBBONBACKSTAGEBUTTONTHEMEVISUALSTUDIO2022T_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPButton
Push Button control.
Definition XTPButton.h:109
CXTPButtonThemeOffice2013::DrawButtonBackground
virtual void DrawButtonBackground(CDC *pDC, CXTPButton *pButton)
This member function is called to draw the background for the button.
CXTPButtonThemeVisualStudio2022
CXTPButtonThemeVisualStudio2022 is a class used to perform Visual Studio 2022 theme drawing tasks.
Definition XTPButtonThemeVisualStudio2022.h:39


Toolkit Pro: XTPTipWindow.h Source File

  • Source
  • Controls
  • Popup
XTPTipWindow.h
Go to the documentation of this file.
1
23#if !defined(__XTPTIPWINDOW_H__)
24# define __XTPTIPWINDOW_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33const DWORD TWS_XTP_THICKBORDER = 0x0001;
34const DWORD TWS_XTP_DROPSHADOW = 0x0002;
35const DWORD TWS_XTP_ALPHASHADOW = 0x0004;
44class _XTP_EXT_CLASS CXTPTipWindow : public CWnd
45{
46public:
51 CXTPTipWindow();
52
57 virtual ~CXTPTipWindow();
58
59public:
67 virtual BOOL Create(CWnd* pParentWnd);
68
69public:
76 void SetTipOffsetPos(CPoint pointOffset);
77
82 void HideTipWindow();
83
92 void SetTextTabStopPositions(LPINT pnTabStopPositions, int nTabPositions);
93
104 void SetTipText(LPCTSTR lpszTitle, LPCTSTR lpszDescrip, BOOL bRedraw = FALSE);
105
114 void SetTipColors(COLORREF crBackColor, COLORREF crTextColor, BOOL bRedraw = FALSE);
115
143 virtual BOOL ShowTipWindow(const CPoint& point, DWORD dwTipStyle = TWS_XTP_DROPSHADOW,
144 UINT nDelay = 0, UINT nElapse = 5000, BOOL bCenterHorz = FALSE);
145
176 virtual BOOL ShowTipWindow(const CRect& rectCtrl, const CPoint& pointMousePos,
177 DWORD dwTipStyle = TWS_XTP_DROPSHADOW, UINT nDelay = 0,
178 UINT nElapse = 5000, BOOL bCenterHorz = FALSE,
179 BOOL bShowTipAtCursorPos = FALSE);
180
186 void SetMargins(CSize size);
187
193 void SetLineSpace(int nLineSpace);
194
195protected:
204 void DrawShadowRect(CDC* pDC, const CRect& rect);
205
213 virtual void InitializeSize(const CPoint& point, BOOL bCenterHorz = FALSE);
214
234 void ForwardMessage(UINT uiMsg, UINT nFlags, CPoint point);
235
240 void CreateShadow();
241
242protected:
244 DECLARE_MESSAGE_MAP()
245
246 //{{AFX_VIRTUAL(CXTPTipWindow)
247 //}}AFX_VIRTUAL
248
249 //{{AFX_MSG(CXTPTipWindow)
250 afx_msg void OnMouseMove(UINT nFlags, CPoint point);
251 afx_msg void OnKillFocus(CWnd* pNewWnd);
252 afx_msg void OnPaint();
253 afx_msg void OnTimer(UINT_PTR nIDEvent);
254 afx_msg BOOL OnEraseBkgnd(CDC* pDC);
255 afx_msg void OnLButtonDown(UINT nFlags, CPoint point);
256 afx_msg void OnRButtonDown(UINT nFlags, CPoint point);
257 afx_msg void OnMButtonDown(UINT nFlags, CPoint point);
258 //}}AFX_MSG
261private:
262 BOOL Create(LPCTSTR lpszClassName, LPCTSTR lpszWindowName, DWORD dwStyle, const RECT& rect,
263 CWnd* pParentWnd, UINT nID, CCreateContext* pContext = NULL);
264 COLORREF AlphaPixel(COLORREF crPixel, int i);
265 int CheckValue(int iValue);
266
267protected:
268 BOOL m_bSystemShadow;
269 int m_nLineSpace;
270 int m_nTabPositions;
272 UINT m_nElapseTimerEventID;
273 UINT m_nDelayTimerEventID;
274 BOOL m_bDelayTimerRunning;
275 BOOL m_bCenterHorz;
276 LPINT m_pnTabStopPositions;
280 DWORD m_dwTipStyle;
281 COLORREF m_crBackColor;
282 COLORREF m_crTextColor;
283 CRect m_rcWindow;
284 CRect m_rcScreenWindow;
285 CRect m_rcShadow;
286 CRect m_rectTipArea;
287 CPoint m_pointTipOffsetPos;
289 CPoint m_ptMousePos;
291 CWnd* m_pParentWnd;
292 CSize m_sizeMargin;
294 CSize m_sizeTitle;
295 CString m_strTitle;
296 CString m_strDescrip;
297 CStringArray m_arStrings;
298};
299
301
302AFX_INLINE BOOL CXTPTipWindow::Create(LPCTSTR lpszClassName, LPCTSTR lpszWindowName, DWORD dwStyle,
303 const RECT& rect, CWnd* pParentWnd, UINT nID,
304 CCreateContext* pContext)
305{
306 return CWnd::Create(lpszClassName, lpszWindowName, dwStyle, rect, pParentWnd, nID, pContext);
307}
308AFX_INLINE void CXTPTipWindow::SetTipColors(COLORREF crBackColor, COLORREF crTextColor,
309 BOOL bRedraw)
310{
311 m_crBackColor = crBackColor;
312 m_crTextColor = crTextColor;
313 if (bRedraw)
314 {
315 InvalidateRect(NULL);
316 }
317}
318AFX_INLINE void CXTPTipWindow::SetMargins(CSize size)
319{
320 m_sizeMargin.cx = __max(0, size.cx);
321 m_sizeMargin.cy = __max(0, size.cy);
322}
323AFX_INLINE void CXTPTipWindow::SetLineSpace(int nLineSpace)
324{
325 m_nLineSpace = __max(0, nLineSpace);
326}
327AFX_INLINE void CXTPTipWindow::SetTipOffsetPos(CPoint pointOffset)
328{
329 m_pointTipOffsetPos = pointOffset;
330}
332# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
334#endif // #if !defined(__XTPTIPWINDOW_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
TWS_XTP_ALPHASHADOW
const DWORD TWS_XTP_ALPHASHADOW
Definition XTPTipWindow.h:35
TWS_XTP_DROPSHADOW
const DWORD TWS_XTP_DROPSHADOW
Definition XTPTipWindow.h:34
TWS_XTP_THICKBORDER
const DWORD TWS_XTP_THICKBORDER
Definition XTPTipWindow.h:33
CXTPTipWindow
CXTPTipWindow is a CWnd derived class.
Definition XTPTipWindow.h:45
CXTPTipWindow::HideTipWindow
void HideTipWindow()
Call this member function to hide the tip window.
CXTPTipWindow::DrawShadowRect
void DrawShadowRect(CDC *pDC, const CRect &rect)
This member function will draw a shadow rect to the device context specified by 'pDC'.
CXTPTipWindow::InitializeSize
virtual void InitializeSize(const CPoint &point, BOOL bCenterHorz=FALSE)
This member function will set the sizes for the tip window.
CXTPTipWindow::CreateShadow
void CreateShadow()
Updates style to show system shadow.
CXTPTipWindow::SetTipColors
void SetTipColors(COLORREF crBackColor, COLORREF crTextColor, BOOL bRedraw=FALSE)
This member function will set the text and background colors for the tip window display.
CXTPTipWindow::SetMargins
void SetMargins(CSize size)
This member function will set the text margins for the tip window.
CXTPTipWindow::ShowTipWindow
virtual BOOL ShowTipWindow(const CRect &rectCtrl, const CPoint &pointMousePos, DWORD dwTipStyle=TWS_XTP_DROPSHADOW, UINT nDelay=0, UINT nElapse=5000, BOOL bCenterHorz=FALSE, BOOL bShowTipAtCursorPos=FALSE)
This member function will display a tip window to display a title and description text.
CXTPTipWindow::SetLineSpace
void SetLineSpace(int nLineSpace)
This member function will set the text line spacing for the tip window.
CXTPTipWindow::~CXTPTipWindow
virtual ~CXTPTipWindow()
Destroys a CXTPTipWindow object, handles cleanup and deallocation.
CXTPTipWindow::SetTextTabStopPositions
void SetTextTabStopPositions(LPINT pnTabStopPositions, int nTabPositions)
Call this member function to set the text tab stop positions for the tooltip window.
CXTPTipWindow::CXTPTipWindow
CXTPTipWindow()
Constructs a CXTPTipWindow object.
CXTPTipWindow::SetTipText
void SetTipText(LPCTSTR lpszTitle, LPCTSTR lpszDescrip, BOOL bRedraw=FALSE)
This member function will set the text for the title and description values that are displayed in the...
CXTPTipWindow::SetTipOffsetPos
void SetTipOffsetPos(CPoint pointOffset)
Call this member function to offset the tip window by the distance specified by pointOffset.
CXTPTipWindow::ForwardMessage
void ForwardMessage(UINT uiMsg, UINT nFlags, CPoint point)
Forwards a message to the window at a specified cursor position.
CXTPTipWindow::ShowTipWindow
virtual BOOL ShowTipWindow(const CPoint &point, DWORD dwTipStyle=TWS_XTP_DROPSHADOW, UINT nDelay=0, UINT nElapse=5000, BOOL bCenterHorz=FALSE)
This member function will display a tip window to display a title and description text.
CXTPTipWindow::Create
virtual BOOL Create(CWnd *pParentWnd)
Call this member function to create the tooltip window.


Toolkit Pro: XTPGridRecordItemConstraint.h Source File

  • Source
  • GridControl
XTPGridRecordItemConstraint.h
Go to the documentation of this file.
1
23#if !defined(__XTPGRIDRECORDITEMCONSTRAINT_H__)
24# define __XTPGRIDRECORDITEMCONSTRAINT_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPGridRecordItemConstraint : public CXTPCmdTarget
39{
40 DECLARE_DYNAMIC(CXTPGridRecordItemConstraint);
41
42public:
47 CXTPGridRecordItemConstraint();
48
49public:
56 int GetIndex() const;
57
58public:
59 CString m_strConstraint;
61 DWORD_PTR m_dwData;
63protected:
64 int m_nIndex;
66private:
67# ifdef _XTP_ACTIVEX
69 DECLARE_DISPATCH_MAP()
70 DECLARE_INTERFACE_MAP()
71
72 DECLARE_OLETYPELIB_EX(CXTPGridRecordItemConstraint);
74# endif
75 friend class CXTPGridRecordItemConstraints;
76 friend class CXTPGridRecordItemEditOptions;
77};
78
84class _XTP_EXT_CLASS CXTPGridRecordItemConstraints : public CXTPCmdTarget
85{
86public:
91 CXTPGridRecordItemConstraints();
92
98 ~CXTPGridRecordItemConstraints();
99
100public:
108 int GetCount() const;
109
114 void RemoveAll();
115
125 CXTPGridRecordItemConstraint* GetAt(int nIndex) const;
126
127protected:
128 CArray<CXTPGridRecordItemConstraint*, CXTPGridRecordItemConstraint*>
129 m_arrConstraints;
131private:
132# ifdef _XTP_ACTIVEX
134 DECLARE_DISPATCH_MAP()
135 DECLARE_INTERFACE_MAP()
136
137 DECLARE_OLETYPELIB_EX(CXTPGridRecordItemConstraints);
138
139 int OleGetItemCount();
140 afx_msg LPDISPATCH OleGetItem(long nIndex);
141 afx_msg void OleAdd(LPCTSTR lpszCaption, long dwData);
142 DECLARE_ENUM_VARIANT(CXTPGridRecordItemConstraints)
143
144 enum
145 {
146 dispidCount = 1L,
147 dispidAdd = 2L,
148 };
149
151# endif
152
153 friend class CXTPGridRecordItemEditOptions;
154};
156# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
157#endif //#if !defined(__XTPGRIDRECORDITEMCONSTRAINT_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPGridRecordItemConstraint
CXTPGridRecordItemConstraint is a CXTPCmdTarget derived class.
Definition XTPGridRecordItemConstraint.h:39
CXTPGridRecordItemConstraint::m_nIndex
int m_nIndex
Index of the constraint.
Definition XTPGridRecordItemConstraint.h:64
CXTPGridRecordItemConstraint::m_strConstraint
CString m_strConstraint
Caption text of this constraint.
Definition XTPGridRecordItemConstraint.h:59
CXTPGridRecordItemConstraint::m_dwData
DWORD_PTR m_dwData
The 32-bit value associated with the item.
Definition XTPGridRecordItemConstraint.h:61
CXTPGridRecordItemConstraint::GetIndex
int GetIndex() const
Retrieve the index of this constraint within the collection of constraints.
CXTPGridRecordItemConstraint::CXTPGridRecordItemConstraint
CXTPGridRecordItemConstraint()
Constructs a CXTPPropertyGridItemConstraint object.
CXTPGridRecordItemConstraints
CXTPGridRecordItemConstraints is a CXTPCmdTarget derived class.
Definition XTPGridRecordItemConstraint.h:85
CXTPGridRecordItemConstraints::GetCount
int GetCount() const
Determines the total number of constraints in the list.
CXTPGridRecordItemConstraints::CXTPGridRecordItemConstraints
CXTPGridRecordItemConstraints()
Constructs a CXTPGridRecordItemConstraints object.
CXTPGridRecordItemConstraints::GetAt
CXTPGridRecordItemConstraint * GetAt(int nIndex) const
Retrieves the constraint at a specified index from the collection of constraints.
CXTPGridRecordItemConstraints::~CXTPGridRecordItemConstraints
~CXTPGridRecordItemConstraints()
Destroys a CXTPPropertyGridItemConstraints object, handles cleanup and deallocation.
CXTPGridRecordItemConstraints::RemoveAll
void RemoveAll()
Removes all constraints from the list of constraints.
CXTPGridRecordItemConstraints::m_arrConstraints
CArray< CXTPGridRecordItemConstraint *, CXTPGridRecordItemConstraint * > m_arrConstraints
Collection of constraints.
Definition XTPGridRecordItemConstraint.h:129
CXTPGridRecordItemEditOptions
This class represents edit options for a single item or column.
Definition XTPGridRecordItem.h:443


Toolkit Pro: XTPChartOpenGLDeviceContext.h Source File

  • Source
  • Chart
  • Drawing
  • OpenGL
XTPChartOpenGLDeviceContext.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTOPENGLDEVICECONTEXT_H__)
24# define __XTPCHARTOPENGLDEVICECONTEXT_H__
25
26# if _MSC_VER >= 1000
27# pragma once
28# endif // _MSC_VER >= 1000
29
30# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
31
32template<class T>
33class CXTPMatrix;
34class CXTPChartContainer;
35class CXTPChartDeviceCommand;
36
37class _XTP_EXT_CLASS CXTPChartOpenGLDeviceContext : public CXTPChart3dDeviceContext
38{
39 DECLARE_DYNAMIC(CXTPChartOpenGLDeviceContext);
40
41public:
48 CXTPChartOpenGLDeviceContext(CXTPChartContainer* pContainer, HDC hDC, CRect rcBounds);
49
54 ~CXTPChartOpenGLDeviceContext();
55
56public:
63 virtual void Execute(CXTPChartDeviceCommand* pCommand);
64
69 virtual BOOL Initialize();
70
81 virtual CXTPChartSizeF MeasureString(const CXTPChartString* pText, CXTPChartFont* pFont);
82
93 virtual CXTPChartSizeF MeasureMarkupElement(CXTPMarkupUIElement* pMarkupUIElement,
94 CXTPChartFont* pFont);
95
102 virtual void Rotate(const CXTPChart3dRotation& rotation);
103
119 virtual BOOL Project(const CXTPPoint3d& pt3d, CPoint& pt2d, double* pdWinZ = NULL);
120
133 virtual BOOL Project(const CXTPChart3dBox& box, CRect& rc);
134
151 virtual BOOL Unproject(const CPoint& pt2d, CXTPPoint3d& pt3d, double dWinZ = 0.);
152
161 virtual void Transform(CXTPPoint3d& v, const CXTPPoint3d* pTranslation = NULL,
162 const CXTPChart3dRotation* pRotation = NULL);
163
172 virtual void Transform(CXTPChart3dBox& box, const CXTPPoint3d* pTranslation = NULL,
173 const CXTPChart3dRotation* pRotation = NULL);
174
182 virtual void Transform(CXTPPoint3d& v, const CXTPMatrix<double>& matrix);
183
191 virtual void Transform(CXTPChart3dBox& box, const CXTPMatrix<double>& matrix);
192
203 virtual BOOL DepthTest(CPoint point, double& dWinZ);
204
214 static float ClampTransparency(int nTransparency);
215
216private:
217 BOOL InitializePixelFormat();
218 void SetOpenGLParameters();
219 BOOL OnPreRender();
220 void OnPostRender();
221 double ComputeAntialiasingJitterFactor() const;
222 void Execute3dCommandTree(CXTPChartDeviceCommand* pCommand);
223 void Execute2dCommandTree(CXTPChartDeviceCommand* pCommand);
224 CXTPMatrix<double>* BuildTransformationMatrix(const CXTPPoint3d* pTranslation = NULL,
225 const CXTPChart3dRotation* pRotation = NULL);
226 void Render3dCommand(CXTPChartDeviceCommand* pCommand, double& dJitterFactor,
227 BOOL bAntialiased = FALSE);
228 void RenderTriangles(double& dJitterFactor, BOOL bAntialiased = FALSE);
229
230protected:
232 HGLRC m_hGLContext;
233 int m_nExecuteNesting;
234 CList<CXTPChartDeviceCommand*, CXTPChartDeviceCommand*> m_2dCommands;
235 BOOL m_bHave2dCommands;
236 BOOL m_bIn2dCommandExecutionMode;
237 CXTPChartDeviceContext* m_p2dDC;
238
239 static const CXTPPoint3d m_arJitter[];
240 static const float m_fJitterAccumStep;
242};
243
244AFX_INLINE float CXTPChartOpenGLDeviceContext::ClampTransparency(int nTransparency)
245{
246 _ASSERTE(0 <= nTransparency && nTransparency <= 255);
247 return (1.f - static_cast<float>(nTransparency) / 255);
248}
249# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
250#endif //#if !defined(__XTPCHARTOPENGLDEVICECONTEXT_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChart3dBox
Represents a 3D box build around included points and provides useful and fast operations.
Definition XTPChartTypes.h:728
CXTPChart3dDeviceContext
A base implementation of 3D device context.
Definition XTPChart3dDeviceContext.h:48
CXTPChart3dDeviceContext::Project
virtual BOOL Project(const CXTPPoint3d &pt3d, CPoint &pt2d, double *pdWinZ=NULL)=0
Projects 3D coordinates to 2D space point coordinates.
CXTPChart3dDeviceContext::DepthTest
virtual BOOL DepthTest(CPoint point, double &dWinZ)=0
Performs depth dest for 2D point provided.
CXTPChart3dDeviceContext::Transform
virtual void Transform(CXTPPoint3d &v, const CXTPPoint3d *pTranslation=NULL, const CXTPChart3dRotation *pRotation=NULL)=0
Transforms vector or box coordinates.
CXTPChart3dDeviceContext::Unproject
virtual BOOL Unproject(const CPoint &pt2d, CXTPPoint3d &pt3d, double dWinZ=0)=0
Projects 2D space point coordinates to 3D space point coordinate on the specified plane.
CXTPChart3dDeviceContext::Rotate
virtual void Rotate(const CXTPChart3dRotation &rotation)=0
Rotates current matrix.
CXTPChart3dRotation
Represents a 3D rotation primitive for chart objects using Euler angles Yaw, Pitch and Roll in degree...
Definition XTPChartTypes.h:639
CXTPChartContainer
This class represents the chart container.
Definition XTPChartElement.h:232
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartDeviceContext::MeasureMarkupElement
virtual CXTPChartSizeF MeasureMarkupElement(CXTPMarkupUIElement *pMarkupUIElement, CXTPChartFont *pFont)=0
Measures the markup element size provided with the font set as the default font for the associated ma...
CXTPChartDeviceContext::Execute
virtual void Execute(CXTPChartDeviceCommand *pCommand)
Call this function to trigger the drawing.
CXTPChartDeviceContext::Initialize
virtual BOOL Initialize()
Initializes devices context.
CXTPChartDeviceContext::MeasureString
virtual CXTPChartSizeF MeasureString(const CXTPChartString *pText, CXTPChartFont *pFont)=0
Call this function to get the measurements of texts rendered in a device context using a specific fon...
CXTPChartFont
This class abstracts a font entity.
Definition XTPChartTypes.h:540
CXTPMarkupUIElement
Base class for XML Markup core level implementations.
Definition XTPMarkupUIElement.h:43
CXTPMatrix
Represents a matrix object built upon a continuos array of elements and provides basic algorithms for...
Definition XTPMatrix.h:40
CXTPPoint3T< double >
CXTPSizeT
This class incapsulates size data.
Definition XTPSize.h:40


Toolkit Pro: XTPRibbonBackstageButton.h Source File

  • Source
  • Ribbon
  • Backstage
XTPRibbonBackstageButton.h
Go to the documentation of this file.
1
23#if !defined(__XTPRIBBONBACKSTAGEBUTTON_H__)
24# define __XTPRIBBONBACKSTAGEBUTTON_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class _XTP_EXT_CLASS CXTPRibbonBackstageButton : public CXTPButton
34{
35# ifndef _XTP_ACTIVEX_BUTTON
37 DECLARE_DYNCREATE(CXTPRibbonBackstageButton)
39# else
40 DECLARE_DYNAMIC(CXTPOleRibbonBackstageButton)
41# endif
42
43public:
44 CXTPRibbonBackstageButton();
45
46 virtual ~CXTPRibbonBackstageButton();
47
48 using CXTPButton::SetTheme;
49
50 virtual BOOL SetTheme(XTPControlTheme theme);
51
52public:
53 void SetShowShadow(BOOL bShowShadow);
54
55 BOOL GetShowShadow() const;
56
57 void ShowShadow(BOOL bShowShadow);
58
59 void SetTabStyle(BOOL bTabStyle);
60
61protected:
62 DECLARE_MESSAGE_MAP()
63 //{{AFX_MSG(CXTPRibbonBackstageButton)
64 afx_msg void OnLButtonDown(UINT nFlags, CPoint point);
65 afx_msg LRESULT OnSetKeyboardTip(WPARAM wParam, LPARAM lParam);
66 afx_msg LRESULT OnSetKeyboardTipDrawFlag(WPARAM wParam, LPARAM lParam);
67 //}}AFX_MSG
68
69public:
70 BOOL m_bChecked;
71 BOOL m_bShowShadow;
72 BOOL m_bTabStyle;
73 BOOL m_bDrawKeyboardTip;
74 CString m_strKeyboardTip;
75};
76
77AFX_INLINE void CXTPRibbonBackstageButton::SetShowShadow(BOOL bShowShadow)
78{
79 m_bShowShadow = bShowShadow;
80}
81
82AFX_INLINE BOOL CXTPRibbonBackstageButton::GetShowShadow() const
83{
84 return m_bShowShadow;
85}
86
87AFX_INLINE void CXTPRibbonBackstageButton::ShowShadow(BOOL bShowShadow)
88{
89 SetShowShadow(bShowShadow);
90}
91
92# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
94#endif // !defined(__XTPRIBBONBACKSTAGEBUTTON_H__)
XTPControlTheme
XTPControlTheme
Enumeration used to determine the active theme style.
Definition XTPControlTheme.h:43
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPButton
Push Button control.
Definition XTPButton.h:109
CXTPButton::SetTheme
virtual BOOL SetTheme(XTPControlTheme eTheme)
Call this member to switch the visual theme of the control.


Toolkit Pro: Member List

CXTPDockingPaneManager Member List

This is the complete list of members for CXTPDockingPaneManager, including all inherited members.

ActivateNextPane(CXTPDockingPane *pPane, BOOL bForward) | CXTPDockingPaneManager |
AttachPane(CXTPDockingPaneBase *pPane, CXTPDockingPaneBase *pNeighbour) | CXTPDockingPaneManager | virtual
ClearIconMap() | CXTPDockingPaneManager |
CloseAll() | CXTPDockingPaneManager |
ClosePane(int nID) | CXTPDockingPaneManager | virtual
ClosePane(CXTPDockingPane *pPane) | CXTPDockingPaneManager | virtual
CreateLayout() | CXTPDockingPaneManager | virtual
CreatePane(UINT nID, CRect rc, XTPDockingPaneDirection direction, CXTPDockingPaneBase *pNeighbour=NULL) | CXTPDockingPaneManager | virtual
CXTPDockingPaneManager() | CXTPDockingPaneManager |
DestroyAll() | CXTPDockingPaneManager |
DestroyPane(int nID) | CXTPDockingPaneManager | virtual
DestroyPane(CXTPDockingPane *pPane) | CXTPDockingPaneManager | virtual
DockPane(CXTPDockingPaneBase *pPane, XTPDockingPaneDirection direction, CXTPDockingPaneBase *pNeighbour=NULL) | CXTPDockingPaneManager | virtual
DockSidePane(CXTPDockingPaneBase *pPane, XTPDockingPaneDirection direction, CRect rc) | CXTPDockingPaneManager | virtual
DoPropExchange(CXTPPropExchange *pPX) | CXTPDockingPaneManager |
EnableFloatingFrameTheme(BOOL bThemedFloatingFrames) | CXTPDockingPaneManager |
EnableKeyboardNavigate(DWORD options=xtpPaneKeyboardUseAll) | CXTPDockingPaneManager |
EnableSideDocking(BOOL bEnable=TRUE) | CXTPDockingPaneManager |
EnsureVisible(CXTPDockingPaneBase *pPane) | CXTPDockingPaneManager |
FindPane(int nID) const | CXTPDockingPaneManager |
FloatPane(CXTPDockingPaneBase *pPane, CRect rc) | CXTPDockingPaneManager | virtual
GetActivePane() const | CXTPDockingPaneManager |
GetAnimationDelay(int *pAnimationDuration=NULL, int *pAnimationInterval=NULL) const | CXTPDockingPaneManager |
GetCaptionDirection() const | CXTPDockingPaneManager |
GetClientMargin() const | CXTPDockingPaneManager |
GetClientMargins() const | CXTPDockingPaneManager |
GetClientPane() const | CXTPDockingPaneManager |
GetCurrentTheme() const | CXTPDockingPaneManager |
GetDefaultPaneOptions() const | CXTPDockingPaneManager |
GetDockingContext() const | CXTPDockingPaneManager |
GetDockingContextStickerStyle() const | CXTPDockingPaneManager |
GetFloatingFramesOpacity() const | CXTPDockingPaneManager |
GetIcon(UINT nID, int nWidth=16) const | CXTPDockingPaneManager |
GetImageManager() const | CXTPDockingPaneManager |
GetKeyboardWindowSelectClass() const | CXTPDockingPaneManager |
GetLayout(CXTPDockingPaneLayout *pLayout) const | CXTPDockingPaneManager |
GetPaintManager() const | CXTPDockingPaneManager |
GetPaneDirection(const CXTPDockingPaneBase *pPane) const | CXTPDockingPaneManager |
GetPaneList() const | CXTPDockingPaneManager |
GetPaneStack() const | CXTPDockingPaneManager |
GetRTLDirection(XTPDockingPaneDirection direction) const | CXTPDockingPaneManager |
GetShowContentsWhileDragging() const | CXTPDockingPaneManager |
GetSideDockingMargin() const | CXTPDockingPaneManager |
GetSite() const | CXTPDockingPaneManager |
GetToolTipContext() const | CXTPDockingPaneManager |
GetTopPane() const | CXTPDockingPaneManager |
HideClient(BOOL bHide) | CXTPDockingPaneManager |
HidePane(int nID) | CXTPDockingPaneManager | virtual
HidePane(CXTPDockingPaneBase *pPane) | CXTPDockingPaneManager | virtual
InstallDockingPanes(CWnd *pParent, bool bClipChildren=true) | CXTPDockingPaneManager | virtual
IsAlphaDockingContext() const | CXTPDockingPaneManager |
IsCaptionMaximizeButtonsVisible() const | CXTPDockingPaneManager |
IsClientHidden() const | CXTPDockingPaneManager |
IsFloatingCaptionMaximizeButtonsVisible() const | CXTPDockingPaneManager |
IsFloatingFrameThemeEnabled() const | CXTPDockingPaneManager |
IsKeyboardNavigateEnabled() const | CXTPDockingPaneManager |
IsLayoutRTL() const | CXTPDockingPaneManager |
IsPaneClosed(int nID) const | CXTPDockingPaneManager |
IsPaneClosed(CXTPDockingPane *pPane) const | CXTPDockingPaneManager |
IsPaneHidden(int nID) const | CXTPDockingPaneManager |
IsPaneHidden(CXTPDockingPane *pPane) const | CXTPDockingPaneManager |
IsPaneSelected(int nID) const | CXTPDockingPaneManager |
IsPaneSelected(CXTPDockingPane *pPane) const | CXTPDockingPaneManager |
IsShowDockingContextStickers() const | CXTPDockingPaneManager |
IsSideDockingEnabled() const | CXTPDockingPaneManager |
IsSplittersLocked() const | CXTPDockingPaneManager |
IsSplitterTrackerUsed() const | CXTPDockingPaneManager |
IsStickyFloatingFrames() const | CXTPDockingPaneManager |
LockSplitters(BOOL bLock=TRUE) | CXTPDockingPaneManager |
m_bAlphaDockingContext | CXTPDockingPaneManager | protected
m_bAutoInitialUpdate | CXTPDockingPaneManager |
m_bCloseGroupOnButtonClick | CXTPDockingPaneManager |
m_bHideClient | CXTPDockingPaneManager | protected
m_bHideGroupOnButtonClick | CXTPDockingPaneManager |
m_bKeyboardEnabled | CXTPDockingPaneManager | protected
m_bLockSplitters | CXTPDockingPaneManager | protected
m_bShowCloseTabButton | CXTPDockingPaneManager |
m_bShowContentsWhileDragging | CXTPDockingPaneManager | protected
m_bShowDockingContextStickers | CXTPDockingPaneManager | protected
m_bShowFloatingMaximizeButton | CXTPDockingPaneManager | protected
m_bShowMaximizeButton | CXTPDockingPaneManager | protected
m_bShowPanelScrollButtons | CXTPDockingPaneManager |
m_bShowSizeCursorWhileDragging | CXTPDockingPaneManager |
m_bSideDocking | CXTPDockingPaneManager | protected
m_bStickyFloatingFrames | CXTPDockingPaneManager | protected
m_bSyncActiveFloatingFrames | CXTPDockingPaneManager | protected
m_bThemedFloatingFrames | CXTPDockingPaneManager | protected
m_bUseSplitterTracker | CXTPDockingPaneManager | protected
m_captionDirection | CXTPDockingPaneManager | protected
m_dwDefaultPaneOptions | CXTPDockingPaneManager | protected
m_nDockingContextStickerStyle | CXTPDockingPaneManager | protected
m_nFloatingFramesOpacity | CXTPDockingPaneManager | protected
m_nSplitterGap | CXTPDockingPaneManager |
m_nStickyGap | CXTPDockingPaneManager |
m_pActivePane | CXTPDockingPaneManager | protected
m_pDockingContext | CXTPDockingPaneManager | protected
m_pfnSetLayeredWindowAttributes | CXTPDockingPaneManager | protected
m_pImageManager | CXTPDockingPaneManager | protected
m_pLayout | CXTPDockingPaneManager | protected
m_pPaintManager | CXTPDockingPaneManager | protected
m_pPreviewLayout | CXTPDockingPaneManager | protected
m_pSite | CXTPDockingPaneManager | protected
m_ptMinClientSize | CXTPDockingPaneManager |
m_pToolTipContext | CXTPDockingPaneManager | protected
m_pWindowSelectClass | CXTPDockingPaneManager | protected
m_rcClientMargins | CXTPDockingPaneManager | protected
m_rcSideDockingMargin | CXTPDockingPaneManager | protected
m_strFloatingFrameCaption | CXTPDockingPaneManager | protected
NormalizeSplitters() | CXTPDockingPaneManager |
NotifyAction(XTPDockingPaneAction action, CXTPDockingPane *pPane, CXTPDockingPaneBase *pDockContainer=NULL, XTPDockingPaneDirection dockDirection=xtpPaneDockLeft) | CXTPDockingPaneManager |
NotifyOwner(UINT nCode, LPARAM lParam) | CXTPDockingPaneManager | virtual
OnActivatePane(BOOL bActive, CXTPDockingPane *pPane) | CXTPDockingPaneManager | virtual
OnCreatePane(XTPDockingPaneType type, CXTPDockingPaneLayout *pLayout) | CXTPDockingPaneManager | virtual
OnSetPreviewMode(BOOL bPreview) | CXTPDockingPaneManager |
RecalcFrameLayout(CXTPDockingPaneBase *pPane, BOOL bDelay=FALSE) | CXTPDockingPaneManager |
RecalcFramesLayout() | CXTPDockingPaneManager |
RedrawPanes() | CXTPDockingPaneManager |
SetAlphaDockingContext(BOOL bAlphaDockingContext) | CXTPDockingPaneManager |
SetAnimationDelay(double dAnimationDelay=-1, int nAnimationDuration=128, int nAnimationInterval=16) | CXTPDockingPaneManager |
SetCaptionDirection(XTPDockingPaneCaptionDirection captionDirection) | CXTPDockingPaneManager |
SetClientMargin(int nMargin) | CXTPDockingPaneManager |
SetClientMargins(CRect rcClientMargins) | CXTPDockingPaneManager |
SetCustomTheme(CXTPDockingPanePaintManager *pTheme) | CXTPDockingPaneManager |
SetDefaultPaneOptions(DWORD dwOptions) | CXTPDockingPaneManager |
SetDockingContext(CXTPDockingPaneContext *pDockingContext) | CXTPDockingPaneManager |
SetDockingContextStickerStyle(XTPDockingContextStickerStyle style) | CXTPDockingPaneManager |
SetFloatingFrameCaption(LPCTSTR lpszCaption) | CXTPDockingPaneManager |
SetFloatingFramesOpacity(int nOpacity) | CXTPDockingPaneManager |
SetIcon(UINT nID, const CXTPImageManagerIconHandle &hIcon) | CXTPDockingPaneManager |
SetIcons(UINT nIDResource, const int *nIDs, int nCount, COLORREF clrMask=0xC0C0C0) | CXTPDockingPaneManager |
SetImageManager(CXTPImageManager *pImageManager) | CXTPDockingPaneManager |
SetKeyboardWindowSelectClass(CRuntimeClass *pWindowSelectClass) | CXTPDockingPaneManager |
SetLayout(const CXTPDockingPaneLayout *pLayout) | CXTPDockingPaneManager |
SetShowContentsWhileDragging(BOOL bShow=TRUE) | CXTPDockingPaneManager |
SetShowDockingContextStickers(BOOL bShowDockingContextStickers) | CXTPDockingPaneManager |
SetSideDockingMargin(CRect rcMargin) | CXTPDockingPaneManager |
SetStickyFloatingFrames(BOOL bSticky) | CXTPDockingPaneManager |
SetTheme(XTPDockingPanePaintTheme theme) | CXTPDockingPaneManager |
ShowCaptionMaximizeButton(BOOL bShowMaximizeButton) | CXTPDockingPaneManager |
ShowFloatingCaptionMaximizeButton(BOOL bShowMaximizeButton) | CXTPDockingPaneManager |
ShowPane(int nID, BOOL bSetFocus=TRUE) | CXTPDockingPaneManager | virtual
ShowPane(CXTPDockingPane *pPane, BOOL bSetFocus=TRUE) | CXTPDockingPaneManager | virtual
SyncActiveFloatingFrames(BOOL bSyncActiveFloatingFrames) | CXTPDockingPaneManager |
SyncPanesState() | CXTPDockingPaneManager |
ToggleAutoHide(CXTPDockingPaneBase *pPane) | CXTPDockingPaneManager | virtual
ToggleDocking(CXTPDockingPaneBase *pPane) | CXTPDockingPaneManager | virtual
UpdatePanes() | CXTPDockingPaneManager | virtual
UseSplitterTracker(BOOL bSplitterTracker) | CXTPDockingPaneManager |
~CXTPDockingPaneManager() | CXTPDockingPaneManager |


Toolkit Pro: Member List

CXTPTrackUndoAddMarkerCommand Member List

This is the complete list of members for CXTPTrackUndoAddMarkerCommand, including all inherited members.

CXTPTrackUndoAddMarkerCommand(CXTPTrackMarker *pMarker) | CXTPTrackUndoAddMarkerCommand |
CXTPTrackUndoCommand(int nID) | CXTPTrackUndoCommand | protected
GetID() const | CXTPTrackUndoCommand |
m_nID | CXTPTrackUndoCommand | protected
m_pMarker | CXTPTrackUndoAddMarkerCommand | protected
Undo() | CXTPTrackUndoAddMarkerCommand | protectedvirtual
~CXTPTrackUndoAddMarkerCommand() | CXTPTrackUndoAddMarkerCommand | virtual
~CXTPTrackUndoCommand() | CXTPTrackUndoCommand | protectedvirtual


Toolkit Pro: Member List

CXTPTrackThemeNativeWindows11 Member List

This is the complete list of members for CXTPTrackThemeNativeWindows11, including all inherited members.

CalcColumnHeight(CDC *pDC, CXTPGridColumn *pColumn, int nTotalWidth=0) | CXTPGridPaintManager | protectedvirtual
CalculateRowHeight(CDC *pDC, const CString &strText, int nMaxWidth, BOOL bWordBreak=TRUE) | CXTPGridPaintManager | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPGridPaintManager() | CXTPGridPaintManager |
CXTPTrackPaintManager() | CXTPTrackPaintManager |
CXTPTrackThemeNativeWindows11() | CXTPTrackThemeNativeWindows11 |
CXTPTrackThemeOffice2013() | CXTPTrackThemeOffice2013 |
DrawBitmap(CDC *pDC, CXTPGridControl *pControl, CRect rcColumn, int iImage) | CXTPGridPaintManager | virtual
DrawCollapsedBitmap(CDC *pDC, const CXTPGridRow *pRow, CRect &rcBitmap) | CXTPGridPaintManager | virtual
DrawColumn(CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn, BOOL bDrawExternal=FALSE, int nShadowWidth=0) | CXTPGridPaintManager | virtual
DrawColumnBackground(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, BOOL &bColumnPressed, BOOL &bDraggingFromHeader, CXTPGridHeader *pHeader=NULL) | CXTPTrackThemeOffice2013 | virtual
DrawColumnFooter(CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn) | CXTPGridPaintManager | virtual
DrawColumnFooterDivider(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn) | CXTPGridPaintManager | virtual
DrawColumnIcon(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, CRect rcIcon, int iIcon) | CXTPGridPaintManager | virtual
DrawColumnText(CDC *pDC, CRect rcText, CString strCaption, int nHeaderAlignment, BOOL bIsHeader, BOOL bColumnPressed) | CXTPTrackThemeOffice2013 | virtual
DrawConnector(CDC *pDC, CPoint ptFrom, CPoint ptTo) | CXTPGridPaintManager |
DrawFocusedRow(CDC *pDC, CRect rcRow) | CXTPTrackThemeOffice2013 | virtual
DrawFreezeColsDivider(CDC *pDC, const CRect &rc, CXTPGridControl *pControl, CXTPGridRow *pRow=NULL) | CXTPGridPaintManager | virtual
DrawGlyph(CDC *pDC, CRect rcColumn, int iImage) | CXTPGridPaintManager | virtual
DrawGrid(CDC *pDC, XTPGridOrientation orientation, CRect rcGrid) | CXTPGridPaintManager | virtual
DrawGridPattern(CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush) | CXTPGridPaintManager | protectedvirtual
DrawGridPattern(CDC *pDC, CXTPBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush) | CXTPGridPaintManager | protectedvirtual
DrawGridPattern(CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr) | CXTPGridPaintManager | protectedvirtual
DrawGroupRow(CDC *pDC, CXTPGridGroupRow *pRow, CRect rcRow, XTP_GRIDRECORDITEM_METRICS *pMetrics) | CXTPTrackThemeOffice2013 | virtual
DrawHorizontalLine(CDC *pDC, int xPos, int yPos, int cx, COLORREF clr) | CXTPGridPaintManager |
DrawInplaceButton(CDC *pDC, CXTPGridInplaceButton *pButton) | CXTPGridPaintManager | virtual
DrawInplaceButtonFrame(CDC *pDC, CXTPGridInplaceButton *pButton) | CXTPGridPaintManager | protectedvirtual
DrawInplaceButtonIcon(CDC *pDC, CXTPGridInplaceButton *pButton) | CXTPGridPaintManager | protectedvirtual
DrawInplaceComboButton(CDC *pDC, CRect *pRc) | CXTPGridPaintManager | virtual
DrawInplaceExpandButton(CDC *pDC, CRect *pRc) | CXTPGridPaintManager | virtual
DrawInplaceSpinButton(CDC *pDC, CRect *pRc) | CXTPGridPaintManager | virtual
DrawItemBitmap(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CRect &rcItem, int nImage) | CXTPGridPaintManager | virtual
DrawItemCaption(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics) | CXTPGridPaintManager | virtual
DrawItemControl(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CXTPGridRecordItemControl *pControl, CRect &rcItem) | CXTPGridPaintManager | virtual
DrawLink(int *pnCurrDrawPos, XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CXTPGridHyperlink *pHyperlink, CString strText, CRect rcLink, int nFlag, BOOL bTrim=FALSE) | CXTPGridPaintManager | protectedvirtual
DrawMarkers(CDC *pDC) | CXTPTrackPaintManager | virtual
DrawMultiLineText(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, BOOL bWordBreak=TRUE) | CXTPGridPaintManager | protectedvirtual
DrawNoGroupByText(CDC *pDC, CRect rcItem) | CXTPGridPaintManager | virtual
DrawRowNumber(CDC *pDC, CRect rcNumber, CXTPGridRow *pRow) | CXTPGridPaintManager | virtual
DrawSectionDivider(CDC *pDC, const CRect &rc, XTPGridSectionDividerPosition dividerPosition, XTPGridSectionDividerStyle dividerStyle, CXTPPaintManagerColor dividerColor) | CXTPGridPaintManager |
DrawShellIcon(CDC *pDC, CRect rcColumn, int iImage) | CXTPGridPaintManager | virtual
DrawSingleLineText(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nStartPos, int nEndPos, int nActualWidth) | CXTPGridPaintManager | protectedvirtual
DrawString(int *pnCurrDrawPos, CDC *pDC, const CString &strDraw, CRect rcDraw, UINT nFormat) | CXTPGridPaintManager | protectedvirtual
DrawTextLine(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nFlag, int &nCharCounter, int &nHyperlinkCounter) | CXTPGridPaintManager | protectedvirtual
DrawTimeLine(CDC *pDC) | CXTPTrackPaintManager | virtual
DrawTrackHeader(CDC *pDC) | CXTPTrackPaintManager | virtual
DrawTreeStructure(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CRect rcItem, CSize sizeGlyph) | CXTPGridPaintManager | virtual
DrawTriangle(CDC *pDC, CRect rcTriangle, BOOL bToDown, BOOL bDraggingFromHeader, int nShadowWidth, BOOL bColumnPressed) | CXTPTrackThemeOffice2013 | virtual
DrawVerticalLine(CDC *pDC, int xPos, int yPos, int cy, COLORREF clr) | CXTPGridPaintManager |
DrawVerticalTimeLineMarker(CDC *pDC, int xPos, CXTPGridControl *pControl, COLORREF color=RGB(0, 255, 0)) | CXTPGridPaintManager | virtual
EnablePreviewMode(BOOL bIsPreviewMode) | CXTPGridPaintManager |
FillFooter(CDC *pDC, CRect rcFooter) | CXTPGridPaintManager | virtual
FillGroupByControl(CDC *pDC, CRect &rcGroupBy) | CXTPGridPaintManager | virtual
FillGroupRowMetrics(CXTPGridGroupRow *pRow, XTP_GRIDRECORDITEM_METRICS *pMetrics, BOOL bPrinting) | CXTPTrackThemeOffice2013 | virtual
FillHeaderControl(CDC *pDC, CRect rcHeader) | CXTPGridPaintManager | virtual
FillIndent(CDC *pDC, CRect rcRow) | CXTPGridPaintManager | virtual
FillItemShade(CDC *pDC, CRect rcItem) | CXTPGridPaintManager | virtual
FillRow(CDC *pDC, CXTPGridRow *pRow, CRect rcRow) | CXTPGridPaintManager | virtual
FindRowAdjacentToMerged(const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, BOOL bUpward) | CXTPGridPaintManager |
FindRowAdjacentToMergedEx(const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, int &nAdjRowIndex, BOOL bUpward) | CXTPGridPaintManager |
FormatTime(int nPosition) | CXTPTrackPaintManager | virtual
FormatTimeLineTick(int nPosition, COLORREF &clrTick, int &nTickLength) | CXTPTrackPaintManager | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetColumnOffice2007CustomThemeBaseColor() const | CXTPGridPaintManager |
GetColumnStyle() const | CXTPGridPaintManager |
GetControlBackColor(CXTPGridControl *pControl) | CXTPGridPaintManager | virtual
GetFooterHeight(CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0) | CXTPGridPaintManager | virtual
GetFreezeColsDividerStyle() const | CXTPGridPaintManager |
GetGlyphs() const | CXTPGridPaintManager |
GetHeaderHeight() | CXTPGridPaintManager | virtual
GetHeaderHeight(CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0) | CXTPGridPaintManager | virtual
GetItemHeight(XTP_GRIDRECORDITEM_DRAWARGS &drawArgs, int nWidth) | CXTPGridPaintManager |
GetMaxPreviewLines() | CXTPGridPaintManager |
GetPreviewItemHeight(CDC *pDC, CXTPGridRow *pRow, int nWidth, int nHeight) | CXTPGridPaintManager | virtual
GetPreviewLinesCount(CDC *pDC, CRect &rcText, const CString &strText) | CXTPGridPaintManager |
GetRowHeight(CDC *pDC, CXTPGridRow *pRow) | CXTPTrackThemeOffice2013 | virtual
CXTPTrackPaintManager::GetRowHeight(CDC *pDC, CXTPGridRow *pRow, int nTotalWidth) | CXTPGridPaintManager | virtual
GetRowHeightEx(CDC *pDC, CXTPGridRow *pRow, int nTotalWidth, const BOOL firstLevel=TRUE) | CXTPGridPaintManager |
GetSectionDividerHeight(XTPGridFixedRowsDividerStyle dividerStyle) | CXTPGridPaintManager |
GetTextFont() | CXTPGridPaintManager |
IsColumHotTrackingEnabled() const | CXTPGridPaintManager | virtual
IsColumnPlusMinusSign() const | CXTPGridPaintManager |
IsColumnWidthWYSIWYG() const | CXTPGridPaintManager |
IsDrawGridForEmptySpace() const | CXTPGridPaintManager |
IsFixedInplaceButtonHeight() const | CXTPGridPaintManager |
IsFixedRowHeight() const | CXTPGridPaintManager |
IsGridVisible(BOOL bVertical) const | CXTPGridPaintManager |
IsGridVisible(XTPGridOrientation orientation) const | CXTPGridPaintManager |
IsLastColumnWidthWYSIWYG() const | CXTPGridPaintManager |
IsPreviewMode() const | CXTPGridPaintManager |
IsPrintGroupRowIcon() const | CXTPGridPaintManager |
IsShowWYSIWYGMarkers() const | CXTPGridPaintManager |
IsUseDropMarker() const | CXTPGridPaintManager |
LoadGlyphs() | CXTPTrackThemeOffice2013 | virtual
m_arStartCol | CXTPGridPaintManager |
m_bAllowMergeCells | CXTPGridPaintManager |
m_bBaseTreeIndent | CXTPGridPaintManager |
m_bCleanTooltip | CXTPGridPaintManager |
m_bColumnPlusMinusSign | CXTPGridPaintManager | protected
m_bColumnWidthWYSIWYG | CXTPGridPaintManager | protected
m_bCompactText | CXTPGridPaintManager |
m_bDrawGridForEmptySpace | CXTPGridPaintManager | protected
m_bFixedInplaceButtonHeight | CXTPGridPaintManager | protected
m_bFixedRowHeight | CXTPGridPaintManager | protected
m_bForceDynamicMarkupForCell | CXTPGridPaintManager |
m_bForceShowDropMarker | CXTPGridPaintManager |
m_bForceShowTooltip | CXTPGridPaintManager |
m_bGrayIfDisable | CXTPGridPaintManager |
m_bGroupRowTextBold | CXTPGridPaintManager |
m_bHideSelection | CXTPGridPaintManager |
m_bHotTracking | CXTPGridPaintManager |
m_bInvertColumnOnClick | CXTPGridPaintManager |
m_bIsPreviewMode | CXTPGridPaintManager | protected
m_bLastColumnWidthWYSIWYG | CXTPGridPaintManager | protected
m_bMakeUpper | CXTPGridPaintManager |
m_bMoveScrollbarOnFixedColumnsIndent | CXTPGridPaintManager |
m_bPrintGroupRowIcon | CXTPGridPaintManager | protected
m_bPrintPageRectangle | CXTPGridPaintManager |
m_bPrintSortTriangle | CXTPGridPaintManager |
m_bPrintVirtualPageNumber | CXTPGridPaintManager |
m_bPrintWatermark | CXTPGridPaintManager |
m_bRecOrRowNum | CXTPGridPaintManager |
m_bRevertAlignment | CXTPGridPaintManager |
m_bShadeGroupHeadings | CXTPGridPaintManager |
m_bShadeSortColumn | CXTPGridPaintManager |
m_bShowLockIcon | CXTPGridPaintManager |
m_bShowNonActiveInPlaceButton | CXTPGridPaintManager |
m_bShowWYSIWYGMarkers | CXTPGridPaintManager | protected
m_bSortTriangleOffsetFromRight | CXTPGridPaintManager |
m_bThemedInplaceButtons | CXTPGridPaintManager |
m_bUseAlternativeBackground | CXTPGridPaintManager |
m_bUseDropMarker | CXTPGridPaintManager |
m_bUseEditTextAlignment | CXTPGridPaintManager |
m_bUseGroupRowSelectionState | CXTPGridPaintManager |
m_bUseShellIcon | CXTPGridPaintManager |
m_clrAlternativeBackground | CXTPGridPaintManager |
m_clrBoldText | CXTPGridPaintManager |
m_clrBoldTextHighlight | CXTPGridPaintManager |
m_clrBtnFace | CXTPGridPaintManager |
m_clrBtnFacePressed | CXTPGridPaintManager |
m_clrBtnText | CXTPGridPaintManager |
m_clrCaptionText | CXTPGridPaintManager |
m_clrCaptionTextPressed | CXTPGridPaintManager |
m_clrColumnOffice2007CustomTheme | CXTPGridPaintManager |
m_clrConnector | CXTPGridPaintManager |
m_clrControlBack | CXTPGridPaintManager |
m_clrControlDark | CXTPGridPaintManager |
m_clrControlLightLight | CXTPGridPaintManager |
m_clrDisableBitmapDarkest | CXTPGridPaintManager |
m_clrDisableBitmapLightest | CXTPGridPaintManager |
m_clrFormulaSubSum | CXTPGridPaintManager |
m_clrFormulaSum | CXTPGridPaintManager |
m_clrFreezeColsDivider | CXTPGridPaintManager |
m_clrGlyph | CXTPTrackThemeOffice2013 |
m_clrGlyphHighlight | CXTPTrackThemeOffice2013 |
m_clrGradientColumnSeparator | CXTPGridPaintManager |
m_clrGradientColumnShadow | CXTPGridPaintManager |
m_clrGroupBoxBack | CXTPGridPaintManager |
m_clrGroupRowText | CXTPGridPaintManager |
m_clrGroupShadeBack | CXTPGridPaintManager |
m_clrGroupShadeBorder | CXTPGridPaintManager |
m_clrGroupShadeText | CXTPGridPaintManager |
m_clrHeaderControl | CXTPGridPaintManager |
m_clrHighlight | CXTPGridPaintManager |
m_clrHighlightText | CXTPGridPaintManager |
m_clrHotDivider | CXTPGridPaintManager |
m_clrIndentControl | CXTPGridPaintManager |
m_clrItemShade | CXTPGridPaintManager |
m_clrMarker | CXTPTrackPaintManager |
m_clrMarkerBack | CXTPTrackPaintManager |
m_clrMarkerBorder | CXTPTrackPaintManager |
m_clrPreviewText | CXTPGridPaintManager |
m_clrScrollBarBorderDark | CXTPTrackPaintManager |
m_clrScrollBarBorderLight | CXTPTrackPaintManager |
m_clrScrollBarDark | CXTPTrackPaintManager |
m_clrScrollBarLight | CXTPTrackPaintManager |
m_clrSelectedArea | CXTPTrackPaintManager |
m_clrSelectedBorder | CXTPTrackThemeOffice2013 |
m_clrSelectedRow | CXTPGridPaintManager |
m_clrSelectedRowText | CXTPGridPaintManager |
m_clrTimeHeaderBorder | CXTPTrackPaintManager |
m_clrTimeHeaderDark | CXTPTrackPaintManager |
m_clrTimeHeaderDarkDark | CXTPTrackPaintManager |
m_clrTimeHeaderDivider | CXTPTrackPaintManager |
m_clrTimeLinePosition | CXTPTrackPaintManager |
m_clrTimeLineTick | CXTPTrackPaintManager |
m_clrTimeSliderBackground | CXTPTrackPaintManager |
m_clrTrackHeader | CXTPTrackPaintManager |
m_clrTrackMarkerBorder | CXTPTrackPaintManager |
m_clrTrackMarkerText | CXTPTrackPaintManager |
m_clrTrackMarkerTextBack | CXTPTrackPaintManager |
m_clrTrackMarkerTextBorder | CXTPTrackPaintManager |
m_clrTrackTimeArea | CXTPTrackPaintManager |
m_clrWindowText | CXTPGridPaintManager |
m_clrWorkArea | CXTPTrackPaintManager |
m_clrWorkAreaScrollBarBorder | CXTPTrackPaintManager |
m_clrWorkAreaScrollBarDark | CXTPTrackPaintManager |
m_clrWorkAreaScrollBarLight | CXTPTrackPaintManager |
m_columnStyle | CXTPGridPaintManager | protected
m_crlNoGroupByText | CXTPGridPaintManager |
m_grcGradientColumn | CXTPGridPaintManager |
m_grcGradientColumnHot | CXTPGridPaintManager |
m_grcGradientColumnPushed | CXTPGridPaintManager |
m_iRecOrRowStart | CXTPGridPaintManager |
m_nBaseParentRecordIndent | CXTPGridPaintManager |
m_nFixedColumnsIndent | CXTPGridPaintManager |
m_nFooterHeight | CXTPGridPaintManager | protected
m_nFreezeColsDividerStyle | CXTPGridPaintManager | protected
m_nGridLineStylePreviousH | CXTPGridPaintManager | protected
m_nGridLineStylePreviousV | CXTPGridPaintManager | protected
m_nGroupGridLineHeight | CXTPGridPaintManager | protected
m_nGroupGridLineStyle | CXTPGridPaintManager | protected
m_nHeaderHeight | CXTPGridPaintManager | protected
m_nMaxPreviewLines | CXTPGridPaintManager | protected
m_nResizingWidth | CXTPGridPaintManager | protected
m_nRowHeight | CXTPGridPaintManager | protected
m_nRowHeightDefault | CXTPGridPaintManager |
m_nTextIndentForGroupRowsWithNoIcon | CXTPGridPaintManager |
m_nTreeColumnLineLength | CXTPGridPaintManager |
m_nTreeIndent | CXTPGridPaintManager |
m_nTreeStructureStyle | CXTPGridPaintManager |
m_nTreeTextIndent | CXTPGridPaintManager |
m_nTreeTextIndentGroupRow | CXTPGridPaintManager |
m_nTreeTextIndentRowChildren | CXTPGridPaintManager |
m_nTreeTextIndentRowParent | CXTPGridPaintManager |
m_pControl | CXTPGridPaintManager | protected
m_pGlyphs | CXTPGridPaintManager | protected
m_pHyperlinkHoverStyle | CXTPGridPaintManager |
m_pHyperlinkStyle | CXTPGridPaintManager |
m_pMarkupUIElement_NoGroupBy | CXTPGridPaintManager | protected
m_PrintPageWidth | CXTPGridPaintManager |
m_rcPreviewIndent | CXTPGridPaintManager |
m_RecordNumberWidth | CXTPGridPaintManager |
m_strCollapse | CXTPGridPaintManager |
m_strDecreasing | CXTPGridPaintManager |
m_strExpand | CXTPGridPaintManager |
m_strIncreasing | CXTPGridPaintManager |
m_strMarkupUIElement_NoGroupBy | CXTPGridPaintManager | protected
m_strNoFieldsAvailable | CXTPGridPaintManager |
m_strNoGroupBy | CXTPGridPaintManager |
m_strNoItems | CXTPGridPaintManager |
m_strSortBy | CXTPGridPaintManager |
m_szGlyph | CXTPGridPaintManager | protected
m_themeButton | CXTPGridPaintManager | protected
m_themeCombo | CXTPGridPaintManager | protected
m_themeHeader | CXTPGridPaintManager | protected
m_themeSpin | CXTPGridPaintManager | protected
m_treeStructureStyle | CXTPGridPaintManager |
m_xtpBrushGroupGridLineStyle | CXTPGridPaintManager | protected
m_xtpBrushHorizontalGrid | CXTPGridPaintManager | protected
m_xtpBrushTreeStructure | CXTPGridPaintManager | protected
m_xtpBrushVeriticalGrid | CXTPGridPaintManager | protected
m_xtpFontBoldText | CXTPGridPaintManager |
m_xtpFontCaption | CXTPGridPaintManager |
m_xtpFontPreview | CXTPGridPaintManager |
m_xtpFontText | CXTPGridPaintManager |
OnDrawAction(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs) | CXTPGridPaintManager | virtual
RecalcTotalHightOfMergedRows(CXTPGridColumns *pColumns, CDC *pDC, CXTPGridRow *pRow, int nRowHeight, int nTotalWidth) | CXTPGridPaintManager |
RefreshMetrics() | CXTPTrackThemeNativeWindows11 | virtual
SetCaptionFont(LOGFONT &lf) | CXTPGridPaintManager |
SetColumnOffice2007CustomThemeBaseColor(COLORREF clrBaseColor) | CXTPGridPaintManager |
SetColumnPlusMinusSign(BOOL bDraw) | CXTPGridPaintManager |
SetColumnWidthWYSIWYG(BOOL bColumnWidthWYSIWYG) | CXTPGridPaintManager |
SetDrawGridForEmptySpace(BOOL bDrawGrid) | CXTPGridPaintManager |
SetFixedRowHeight(BOOL bFixedRowHeight) | CXTPGridPaintManager |
SetFreezeColsDividerStyle(int nStyle) | CXTPGridPaintManager |
SetGridControl(CXTPGridControl *pControl) | CXTPGridPaintManager | virtual
SetHeaderHeight(int nHeight) | CXTPGridPaintManager | virtual
SetInplaceButtonHeight(BOOL bFixedInplaceButtonHeight) | CXTPGridPaintManager |
SetLastColumnWidthWYSIWYG(BOOL bColumnWidthWYSIWYG) | CXTPGridPaintManager |
SetMaxPreviewLines(int nMaxLines) | CXTPGridPaintManager |
SetPreviewIndent(int nLeft, int nTop, int nRight, int nBottom) | CXTPGridPaintManager |
SetPrintGroupRowIcon(BOOL bDraw) | CXTPGridPaintManager |
SetTextFont(LOGFONT &lf) | CXTPGridPaintManager |
ShowWYSIWYGMarkers(BOOL bSet) | CXTPGridPaintManager |
~CXTPGridPaintManager() | CXTPGridPaintManager | virtual
~CXTPTrackPaintManager() | CXTPTrackPaintManager |


Toolkit Pro: Member List

CXTPDatePickerButton Member List

This is the complete list of members for CXTPDatePickerButton, including all inherited members.

CXTPDatePickerButton() | CXTPDatePickerButton |
GetCaption() const | CXTPDatePickerButton | virtual
m_bHighlight | CXTPDatePickerButton |
m_bPressed | CXTPDatePickerButton |
m_bVisible | CXTPDatePickerButton |
m_nID | CXTPDatePickerButton |
m_rcButton | CXTPDatePickerButton |
m_strCaption | CXTPDatePickerButton | protected
SetCaption(LPCTSTR pcszCaption) | CXTPDatePickerButton | virtual
~CXTPDatePickerButton() | CXTPDatePickerButton | inlinevirtual


Toolkit Pro: Member List

CXTPPropertyGridInplaceEdit Member List

This is the complete list of members for CXTPPropertyGridInplaceEdit, including all inherited members.

CanOverType() const | CXTPMaskEditT< CEdit > | inline
CanUseMask() const | CXTPMaskEditT< CEdit > | inline
CheckChar(TCHAR &nChar, int nPos) | CXTPMaskEditT< CEdit > | inlinevirtual
ConvertUnicodeAlpha(TCHAR nChar, BOOL bUpperCase) const | CXTPMaskEditT< CEdit > | inline
CopyToClipboard(const CString &strText) | CXTPMaskEditT< CEdit > | inline
Create(CXTPPropertyGridItem *pItem, CRect rect) | CXTPPropertyGridInplaceEdit | virtual
CXTPMaskEditT() | CXTPMaskEditT< CEdit > | inline
CXTPPropertyGridInplaceEdit() | CXTPPropertyGridInplaceEdit |
DeleteCharAt(int iPos) | CXTPMaskEditT< CEdit > | inline
DestroyItem() | CXTPPropertyGridInplaceEdit | virtual
GetItem() | CXTPPropertyGridInplaceEdit |
GetMaskedText(int nStartPos=0, int nEndPos=-1) const | CXTPMaskEditT< CEdit > | inline
GetPromptChar() const | CXTPMaskEditT< CEdit > | inline
GetPromptString(int nLength) const | CXTPMaskEditT< CEdit > | inline
HideWindow() | CXTPPropertyGridInplaceEdit | virtual
InsertCharAt(int iPos, TCHAR nChar) | CXTPMaskEditT< CEdit > | inline
IsModified() const | CXTPMaskEditT< CEdit > | inline
m_bCancel | CXTPPropertyGridInplaceEdit | protected
m_bCheckAutoComplete | CXTPPropertyGridInplaceEdit | protected
m_bCreated | CXTPPropertyGridInplaceEdit | protected
m_bDelayCreate | CXTPPropertyGridInplaceEdit | protected
m_bEditMode | CXTPPropertyGridInplaceEdit | protected
m_bIgnoreEditChanged | CXTPPropertyGridInplaceEdit | protected
m_bModified | CXTPMaskEditT< CEdit > | protected
m_bOverType | CXTPMaskEditT< CEdit > | protected
m_bRedo | CXTPMaskEditT< CEdit > | protected
m_bUpdateUndo | CXTPMaskEditT< CEdit > | protected
m_bUseMask | CXTPMaskEditT< CEdit > | protected
m_chPrompt | CXTPMaskEditT< CEdit > | protected
m_clrBack | CXTPPropertyGridInplaceEdit | protected
m_nEndChar | CXTPMaskEditT< CEdit > | protected
m_nStartChar | CXTPMaskEditT< CEdit > | protected
m_pGrid | CXTPPropertyGridInplaceEdit | protected
m_pItem | CXTPPropertyGridInplaceEdit | protected
m_strDefault | CXTPMaskEditT< CEdit > | protected
m_strLiteral | CXTPMaskEditT< CEdit > | protected
m_strMask | CXTPMaskEditT< CEdit > | protected
m_strRedoBuffer | CXTPMaskEditT< CEdit > | protected
m_strUndoBuffer | CXTPMaskEditT< CEdit > | protected
m_strValue | CXTPPropertyGridInplaceEdit | protected
m_strWindowText | CXTPMaskEditT< CEdit > | protected
m_xtpBrushBack | CXTPPropertyGridInplaceEdit | protected
MaskClear() | CXTPMaskEditT< CEdit > | inline
MaskCopy() | CXTPMaskEditT< CEdit > | inline
MaskCut() | CXTPMaskEditT< CEdit > | inline
MaskDeleteSel() | CXTPMaskEditT< CEdit > | inline
MaskPaste() | CXTPMaskEditT< CEdit > | inline
MaskReplaceSel(LPCTSTR lpszNewText) | CXTPMaskEditT< CEdit > | inline
MaskSelectAll() | CXTPMaskEditT< CEdit > | inline
MaskUndo() | CXTPMaskEditT< CEdit > | inline
OnCommand(WPARAM wParam, LPARAM lParam) | CXTPMaskEditT< CEdit > | inlineprotectedvirtual
PosInRange(int iPos) const | CXTPMaskEditT< CEdit > | inline
PreTranslateMessage(MSG *pMsg) | CXTPMaskEditT< CEdit > | inlinevirtual
ProcessMask(TCHAR &nChar, int nEndPos) | CXTPMaskEditT< CEdit > | inlinevirtual
SelectConstraint(int nDirection, BOOL bCycle) | CXTPPropertyGridInplaceEdit | virtual
SetEditMask(LPCTSTR lpszMask, LPCTSTR lpszLiteral, LPCTSTR lpszDefault=NULL) | CXTPMaskEditT< CEdit > | inlinevirtual
SetMaskedText(LPCTSTR lpszMaskedText, int iPos=0, BOOL bUpdateWindow=TRUE) | CXTPMaskEditT< CEdit > | inline
SetOverType(BOOL bOverType) | CXTPMaskEditT< CEdit > | inline
SetPromptChar(TCHAR ch, BOOL bAutoReplace=TRUE) | CXTPMaskEditT< CEdit > | inline
SetUseMask(BOOL bUseMask) | CXTPMaskEditT< CEdit > | inline
SetValue(LPCTSTR strValue) | CXTPPropertyGridInplaceEdit | virtual
~CXTPPropertyGridInplaceEdit() | CXTPPropertyGridInplaceEdit | virtual


Toolkit Pro: Member List

CXTPMarkupGdiImage Member List

This is the complete list of members for CXTPMarkupGdiImage, including all inherited members.

CXTPMarkupDeviceDependentImage(IXTPMarkupDeviceDependentImageSite *pSite) | CXTPMarkupDeviceDependentImage | explicitprotected
CXTPMarkupGdiImage(IXTPMarkupDeviceDependentImageSite *pSite) | CXTPMarkupGdiImage | explicit
GetNativeImage() | CXTPMarkupGdiImage |
GetSite() const | CXTPMarkupDeviceDependentImage |
GetSize() const | CXTPMarkupDeviceDependentImage |
IsIcon() const | CXTPMarkupDeviceDependentImage |
IsLoaded() const | CXTPMarkupDeviceDependentImage |
Load(LPCWSTR lpszSource, int nWidth, int nHeight=0) | CXTPMarkupGdiImage | virtual
~CXTPMarkupDeviceDependentImage() | CXTPMarkupDeviceDependentImage | virtual
~CXTPMarkupGdiImage() | CXTPMarkupGdiImage | virtual


Toolkit Pro: Member List

CXTPListBoxThemeOffice2013 Member List

This is the complete list of members for CXTPListBoxThemeOffice2013, including all inherited members.

CXTPListBoxThemeOffice2013() | CXTPListBoxThemeOffice2013 |
DrawItem(CDC *pDC, CXTPListBox *pListBox, LPDRAWITEMSTRUCT lpDIS) | CXTPListBoxThemeOffice2013 | virtual
DrawItemText(CDC *pDC, CRect rcText, CXTPListBox *pListBox, LPDRAWITEMSTRUCT lpDIS) | CXTPListBoxTheme | virtual
DrawNcBorders(CDC *pDC, CRect rc) | CXTPListBoxThemeOffice2013 | virtual
GetBackColor() | CXTPListBoxThemeOffice2013 | virtual
m_clrBack | CXTPListBoxThemeOffice2013 |
m_clrBorder | CXTPListBoxThemeOffice2013 |
m_clrItemBack | CXTPListBoxThemeOffice2013 |
m_clrItemBackHighlight | CXTPListBoxThemeOffice2013 |
m_clrItemBackSelected | CXTPListBoxThemeOffice2013 |
m_clrItemBorder | CXTPListBoxThemeOffice2013 |
m_clrItemBorderHighlight | CXTPListBoxThemeOffice2013 |
m_clrItemBorderSelected | CXTPListBoxThemeOffice2013 |
m_clrItemText | CXTPListBoxThemeOffice2013 |
m_clrItemTextHighlight | CXTPListBoxThemeOffice2013 |
m_clrItemTextSelected | CXTPListBoxThemeOffice2013 |
RefreshMetrics() | CXTPListBoxThemeOffice2013 | virtual
~CXTPListBoxTheme() | CXTPListBoxTheme | inlinevirtual


Toolkit Pro: Member List

CXTPListBoxThemeNativeWindows11 Member List

This is the complete list of members for CXTPListBoxThemeNativeWindows11, including all inherited members.

CXTPListBoxThemeNativeWindows11() | CXTPListBoxThemeNativeWindows11 |
CXTPListBoxThemeOffice2013() | CXTPListBoxThemeOffice2013 |
DrawItem(CDC *pDC, CXTPListBox *pListBox, LPDRAWITEMSTRUCT lpDIS) | CXTPListBoxThemeOffice2013 | virtual
DrawItemText(CDC *pDC, CRect rcText, CXTPListBox *pListBox, LPDRAWITEMSTRUCT lpDIS) | CXTPListBoxTheme | virtual
DrawNcBorders(CDC *pDC, CRect rc) | CXTPListBoxThemeOffice2013 | virtual
GetBackColor() | CXTPListBoxThemeOffice2013 | virtual
m_clrBack | CXTPListBoxThemeOffice2013 |
m_clrBorder | CXTPListBoxThemeOffice2013 |
m_clrItemBack | CXTPListBoxThemeOffice2013 |
m_clrItemBackHighlight | CXTPListBoxThemeOffice2013 |
m_clrItemBackSelected | CXTPListBoxThemeOffice2013 |
m_clrItemBorder | CXTPListBoxThemeOffice2013 |
m_clrItemBorderHighlight | CXTPListBoxThemeOffice2013 |
m_clrItemBorderSelected | CXTPListBoxThemeOffice2013 |
m_clrItemText | CXTPListBoxThemeOffice2013 |
m_clrItemTextHighlight | CXTPListBoxThemeOffice2013 |
m_clrItemTextSelected | CXTPListBoxThemeOffice2013 |
RefreshMetrics() | CXTPListBoxThemeOffice2013 | virtual
~CXTPListBoxTheme() | CXTPListBoxTheme | inlinevirtual


Toolkit Pro: Member List

CXTPResourceImages Member List

This is the complete list of members for CXTPResourceImages, including all inherited members.

_ImageNameToResourceName(LPCTSTR strImageFile) | CXTPResourceImages | protected
ClearProperties() | CXTPResourceImages | protected
CXTPCmdTarget() | CXTPCmdTarget |
CXTPResourceImages() | CXTPResourceImages |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetConnection() | CXTPResourceImages |
GetHandle() const | CXTPResourceImages |
GetImageColor(LPCTSTR lpszSectionName, LPCTSTR lpszKeyName, COLORREF clrDefault=(COLORREF) -1) const | CXTPResourceImages |
GetImageInt(LPCTSTR lpszSectionName, LPCTSTR lpszKeyName, int nDefault=-1) const | CXTPResourceImages |
GetImageRect(LPCTSTR lpszSectionName, LPCTSTR lpszKeyName, CRect rcDefault=CRect(0, 0, 0, 0)) const | CXTPResourceImages |
GetImageSize(LPCTSTR lpszSectionName, LPCTSTR lpszKeyName, CSize szDefault=CSize(0, 0)) const | CXTPResourceImages |
GetImageString(LPCTSTR lpszSectionName, LPCTSTR lpszKeyName, LPCTSTR lpszDef=NULL) const | CXTPResourceImages |
GetImageValue(LPCTSTR lpszSectionName, LPCTSTR lpszKeyName) const | CXTPResourceImages |
InitResourceHandle(LPCTSTR lpszTestImageFile, LPCTSTR lpResType=RT_BITMAP) | CXTPResourceImages |
IsValid() const | CXTPResourceImages |
LoadBitmap(CBitmap *pBitmap, LPCTSTR lpszResourceName) | CXTPResourceImages |
LoadFile(LPCTSTR lpszImageFile) | CXTPResourceImages |
LoadImage(LPCTSTR lpszImageFile) | CXTPResourceImages |
LoadProperties(LPSTR lpTextFile, LPSTR lpTextFileEnd, BOOL bAllowOverwrite) | CXTPResourceImages | protected
m_bFreeOnRelease | CXTPResourceImages | protected
m_bPremultiplyImages | CXTPResourceImages | protected
m_cs | CXTPResourceImages | protected
m_hbmLayer | CXTPResourceImages | protected
m_hResource | CXTPResourceImages | protected
m_mapImages | CXTPResourceImages | protected
m_mapPropeties | CXTPResourceImages | protected
m_pConnection | CXTPResourceImages | protected
m_pdc | CXTPResourceImages | protected
m_pLayerBits | CXTPResourceImages | protected
m_strDllFileName | CXTPResourceImages |
m_strIniFileName | CXTPResourceImages |
RemoveAll() | CXTPResourceImages |
Reset() | CXTPResourceImages |
SetHandle(LPCTSTR lpszDllFileName, LPCTSTR lpszIniFileName=NULL) | CXTPResourceImages |
SetHandle(HMODULE hResource, LPCTSTR lpszIniFileName=NULL, BOOL bFreeOnRelease=FALSE) | CXTPResourceImages |
SetHandle(HMODULE hResource, LPCTSTR lpszThemeFileName, LPCTSTR lpszAppFileName, BOOL bFreeOnRelease=FALSE) | CXTPResourceImages |
SetIniData(LPCSTR lpIniData) | CXTPResourceImages |
~CXTPResourceImages() | CXTPResourceImages | virtual


Toolkit Pro: XTPFrameWnd.h Source File

  • Source
  • CommandBars
XTPFrameWnd.h
Go to the documentation of this file.
1
23#if !defined(__XTPFRAMEWND_H__)
24# define __XTPFRAMEWND_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPShortcutManager;
34class CXTPTabClientWnd;
35class CXTPTearOffFrame;
36class CXTPDockingPaneManager;
37
43template<class TBase>
44class CXTPCommandBarsSiteBase : public TBase
45{
46public:
51 CXTPCommandBarsSiteBase()
52 {
53 m_pCommandBars = 0;
54 }
55
60 ~CXTPCommandBarsSiteBase()
61 {
62 CMDTARGET_RELEASE(m_pCommandBars);
63 }
64
73 virtual BOOL InitCommandBars(CRuntimeClass* pCommandBarsClass = RUNTIME_CLASS(CXTPCommandBars))
74 {
75 CMDTARGET_RELEASE(m_pCommandBars);
76
77 _ASSERTE(pCommandBarsClass->IsDerivedFrom(RUNTIME_CLASS(CXTPCommandBars)));
78 m_pCommandBars = (CXTPCommandBars*)pCommandBarsClass->CreateObject();
79 _ASSERTE(m_pCommandBars);
80 if (!m_pCommandBars)
81 return FALSE;
82 m_pCommandBars->SetSite(this);
83 m_pCommandBars->EnableDocking();
84 return TRUE;
85 }
86
94 void DockRightOf(CXTPToolBar* pBarToDock, CXTPToolBar* pBarOnLeft)
95 {
96 CWnd::RepositionBars(AFX_IDW_CONTROLBAR_FIRST, AFX_IDW_CONTROLBAR_LAST, AFX_IDW_PANE_FIRST);
97
98 CXTPWindowRect rcBar(pBarOnLeft);
99
100 if (IsVerticalPosition(pBarOnLeft->GetPosition()))
101 rcBar.OffsetRect(0, rcBar.Height());
102 else
103 rcBar.OffsetRect(rcBar.Width(), 0);
104
105 GetCommandBars()->DockCommandBar(pBarToDock, rcBar, pBarOnLeft->GetDockBar());
106 }
107
117 virtual void SaveCommandBars(LPCTSTR lpszProfileName)
118 {
119 if (m_pCommandBars)
120 {
121 m_pCommandBars->SaveOptions(lpszProfileName);
122 m_pCommandBars->SaveBarState(lpszProfileName);
123 m_pCommandBars->GetShortcutManager()->SaveShortcuts(lpszProfileName);
124 }
125 }
126
138 virtual void LoadCommandBars(LPCTSTR lpszProfileName, BOOL bSilent = FALSE)
139 {
140 if (m_pCommandBars)
141 {
142 m_pCommandBars->LoadOptions(lpszProfileName);
143 m_pCommandBars->LoadBarState(lpszProfileName, bSilent);
144 m_pCommandBars->GetShortcutManager()->LoadShortcuts(lpszProfileName);
145 }
146 }
147
154 CXTPCommandBars* GetCommandBars() const
155 {
156 return m_pCommandBars;
157 }
158
163 CXTPShortcutManager* XTPShortcutManager()
164 {
165 return ((m_pCommandBars == NULL) ? NULL : m_pCommandBars->GetShortcutManager());
166 }
170protected:
171 virtual BOOL PreTranslateMessage(MSG* pMsg)
172 {
173 if ((pMsg->message >= WM_KEYFIRST && pMsg->message <= WM_KEYLAST)
174 && (pMsg->wParam != VK_RETURN && pMsg->wParam != VK_TAB && pMsg->wParam != VK_ESCAPE))
175 {
176 CWnd* pWnd = CWnd::GetFocus();
177 if (pWnd && pWnd->IsKindOf(RUNTIME_CLASS(CXTPCommandBarEditCtrl)))
178 return FALSE;
179 }
180
181 if (TBase::PreTranslateMessage(pMsg))
182 return TRUE;
183
184 if (m_pCommandBars && m_pCommandBars->PreTranslateFrameMessage(pMsg))
185 return TRUE;
186
187 return FALSE;
188 }
189
190 virtual BOOL OnWndMsg(UINT message, WPARAM wParam, LPARAM lParam, LRESULT* pResult)
191 {
192 BOOL bBase = FALSE;
193 BOOL bCommandBars = FALSE;
195 // The WM_SYSCOLORCHANGE message must be handled in the
196 // base class first to update the AUX_DATA brushes.
197 if (WM_SYSCOLORCHANGE == message)
198 {
199 bBase = TBase::OnWndMsg(message, wParam, lParam, pResult);
200 }
201
202 if (NULL != m_pCommandBars)
203 {
204 bCommandBars = m_pCommandBars->OnFrameWndMsg(message, wParam, lParam, pResult);
205 }
206
207 if (!bBase && !bCommandBars)
208 {
209 bBase = TBase::OnWndMsg(message, wParam, lParam, pResult);
210 }
211
212 return (bBase || bCommandBars);
213 }
214
217private:
218 CXTPCommandBars* m_pCommandBars;
219};
220
226template<class TBase>
227class CXTPFrameWndBase : public CXTPCommandBarsSiteBase<TBase>
228{
229 typedef CXTPCommandBarsSiteBase<TBase> Parent;
230
231public:
236 CXTPFrameWndBase()
237 {
238 }
243 ~CXTPFrameWndBase()
244 {
245 }
246
248public:
249 BOOL LoadFrame(UINT nIDResource, DWORD dwDefaultStyle = WS_OVERLAPPEDWINDOW | FWS_ADDTOTITLE,
250 CWnd* pParentWnd = NULL, CCreateContext* pContext = NULL)
251 {
252 BOOL bResult = CXTPCommandBarsSiteBase<TBase>::LoadFrame(nIDResource, dwDefaultStyle,
253 pParentWnd, pContext);
254 if (!bResult)
255 return FALSE;
256
257 if (CXTPCommandBarsSiteBase<TBase>::GetCommandBars()
258 && CXTPCommandBarsSiteBase<TBase>::GetCommandBars()
259 ->GetShortcutManager()
260 ->GetOriginalAccelerator())
261 {
262 CFrameWnd::m_hAccelTable = NULL;
263 }
264
265 return TRUE;
266 }
267
268 void OnSetPreviewMode(BOOL bPreview, CPrintPreviewState* pState)
269 {
270 if (CXTPCommandBarsSiteBase<TBase>::GetCommandBars())
271 {
272 CXTPCommandBarsSiteBase<TBase>::GetCommandBars()->OnSetPreviewMode(bPreview);
273 }
274
275 CXTPCommandBarsSiteBase<TBase>::OnSetPreviewMode(bPreview, pState);
276 }
278};
279
285extern const UINT _XTP_EXTRN XTP_WM_UPDATE_MDI_CHILD_THEME;
286
291class _XTP_EXT_CLASS CXTPMDIFrameWnd : public CXTPFrameWndBase<CMDIFrameWnd>
292{
293public:
294 DECLARE_DYNCREATE(CXTPMDIFrameWnd)
295
296
300 CXTPMDIFrameWnd();
301
306 void UpdateMDIChildrenTheme();
307
309 virtual BOOL OnCmdMsg(UINT nID, int nCode, void* pExtra, AFX_CMDHANDLERINFO* pHandlerInfo);
311};
312
317class _XTP_EXT_CLASS CXTPMDIFrameWndEx : public CXTPMDIFrameWnd
318{
319public:
320 DECLARE_DYNAMIC(CXTPMDIFrameWndEx)
321
322
326 CXTPMDIFrameWndEx();
327
332 virtual ~CXTPMDIFrameWndEx();
333
340 virtual CXTPTabClientWnd* GetTabClientWnd() = 0;
341
342# ifndef _XTP_COMMANDBARS_ACTIVEX
343# ifdef _XTP_INCLUDE_DOCKINGPANE
350 virtual CXTPDockingPaneManager* GetDockingPaneManager() = 0;
351# endif
352# endif
353
355 virtual BOOL OnCommand(WPARAM wParam, LPARAM lParam);
356 virtual BOOL OnCmdMsg(UINT nID, int nCode, void* pExtra, AFX_CMDHANDLERINFO* pHandlerInfo);
357 virtual BOOL PreTranslateMessage(MSG* pMsg);
358
359# ifdef _DEBUG
360 virtual void AssertValid() const;
361 virtual void Dump(CDumpContext& dc) const;
362# endif
363
364protected:
365 //{{AFX_MSG(CXTPMDIFrameWndEx)
366 afx_msg int OnCreate(LPCREATESTRUCT lpCreateStruct);
367 afx_msg void OnDestroy();
368 afx_msg void OnActivate(UINT nState, CWnd* pWndOther, BOOL bMinimized);
369 afx_msg int OnMouseActivate(CWnd* pDesktopWnd, UINT nHitTest, UINT message);
370 afx_msg void OnActivateApp(BOOL bActive, DWORD dwThreadID);
371 afx_msg LRESULT OnTearoffActivate(WPARAM wParam, LPARAM lParam);
372 //}}AFX_MSG
373
374 DECLARE_MESSAGE_MAP()
375
376protected:
377 CXTPTearOffFrame* m_pPrevActiveFrame;
378 CXTPTearOffFrame* m_pLastActiveFrame;
379
380public:
381 UINT m_nIDResource;
382
383protected:
384 LRESULT UpdateMDIMenu(CWnd* pWnd);
385
386 friend class CXTPTearOffFrame;
388};
389
394class _XTP_EXT_CLASS CXTPFrameWnd : public CXTPFrameWndBase<CFrameWnd>
395{
396public:
397 DECLARE_DYNCREATE(CXTPFrameWnd)
398
399
403 CXTPFrameWnd();
404};
406# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
407#endif // #if !defined(__XTPFRAMEWND_H__)
IsVerticalPosition
AFX_INLINE BOOL IsVerticalPosition(XTPBarPosition barPosition)
Call this member to determine if the specified bar position is left, right, or is a pop-up toolbar.
Definition XTPCommandBarsDefines.h:1375
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTP_WM_UPDATE_MDI_CHILD_THEME
const UINT _XTP_EXTRN XTP_WM_UPDATE_MDI_CHILD_THEME
A message that is sent to each MDI child window as a result of a call to CXTPMDIFrameWnd::UpdateMDICh...
CXTPCommandBarEditCtrl
CXTPCommandBarEditCtrl is a CEdit derived class.
Definition XTPControlEdit.h:72
CXTPCommandBar::GetPosition
XTPBarPosition GetPosition() const
Call this member to get the position of the command bar.
Definition XTPCommandBar.h:1327
CXTPCommandBars
CXTPCommandBars is a standalone class.
Definition XTPCommandBars.h:165
CXTPCommandBars::DockCommandBar
BOOL DockCommandBar(CXTPToolBar *pBar, LPRECT lpRect, CXTPDockBar *pDockBar)
Call this member to dock a toolbar to the specified dockbar.
CXTPCommandBars::LoadBarState
void LoadBarState(LPCTSTR lpszProfileName, BOOL bSilent=FALSE)
Call this function to retrieve state information from the registry or .INI file.
CXTPCommandBars::LoadOptions
void LoadOptions(LPCTSTR lpszProfileName)
Call this function to restore the options of the command bars.
CXTPCommandBars::OnFrameWndMsg
BOOL OnFrameWndMsg(UINT message, WPARAM wParam, LPARAM lParam, LRESULT *pResult)
Call this method to process frame messages.
CXTPCommandBars::GetShortcutManager
CXTPShortcutManager * GetShortcutManager() const
Call this function to get the ShortcutManager class pointer.
CXTPCommandBars::PreTranslateFrameMessage
BOOL PreTranslateFrameMessage(MSG *pMsg)
Call this method to process frame messages.
CXTPCommandBars::SaveOptions
void SaveOptions(LPCTSTR lpszProfileName)
Call this function to save the command bars options.
CXTPCommandBars::EnableDocking
void EnableDocking()
This member is called to create dock bars.
CXTPCommandBars::OnSetPreviewMode
void OnSetPreviewMode(BOOL bPreview)
Call this member function to set the application's command bars into and out of print-preview mode.
CXTPCommandBars::SetSite
void SetSite(CWnd *pFrame)
This method is called to set the site window.
CXTPCommandBars::SaveBarState
void SaveBarState(LPCTSTR lpszProfileName, BOOL bOnlyCustomized=TRUE)
Call this function to save the state information to the registry or .INI file.
CXTPCommandBarsSiteBase
CXTPCommandBarsSiteBase is a standalone class.
Definition XTPFrameWnd.h:45
CXTPCommandBarsSiteBase::DockRightOf
void DockRightOf(CXTPToolBar *pBarToDock, CXTPToolBar *pBarOnLeft)
This member function will re-dock a toolbar specified by 'pBarToDock' to the right of a newly docked ...
Definition XTPFrameWnd.h:94
CXTPCommandBarsSiteBase::SaveCommandBars
virtual void SaveCommandBars(LPCTSTR lpszProfileName)
Call this function to save the state information to the registry or .INI file.
Definition XTPFrameWnd.h:117
CXTPCommandBarsSiteBase::~CXTPCommandBarsSiteBase
~CXTPCommandBarsSiteBase()
Destroys a CXTPCommandBarsSiteBase object, handles cleanup and deallocation.
Definition XTPFrameWnd.h:60
CXTPCommandBarsSiteBase::CXTPCommandBarsSiteBase
CXTPCommandBarsSiteBase()
Constructs a CXTPCommandBarsSiteBase object.
Definition XTPFrameWnd.h:51
CXTPCommandBarsSiteBase::InitCommandBars
virtual BOOL InitCommandBars(CRuntimeClass *pCommandBarsClass=RUNTIME_CLASS(CXTPCommandBars))
Creates command bars.
Definition XTPFrameWnd.h:73
CXTPCommandBarsSiteBase::LoadCommandBars
virtual void LoadCommandBars(LPCTSTR lpszProfileName, BOOL bSilent=FALSE)
Call this function to retrieve state information from the registry or .INI file.
Definition XTPFrameWnd.h:138
CXTPCommandBarsSiteBase::GetCommandBars
CXTPCommandBars * GetCommandBars() const
Call this member to retrieve a pointer to the CommandBars object.
Definition XTPFrameWnd.h:154
CXTPDockingPaneManager
CXTPDockingPaneManager is a CWnd derived class.
Definition XTPDockingPaneManager.h:58
CXTPFrameWndBase
CXTPFrameWndBase is a standalone class.
Definition XTPFrameWnd.h:228
CXTPFrameWndBase::CXTPFrameWndBase
CXTPFrameWndBase()
Constructs a CXTPFrameWndBase object.
Definition XTPFrameWnd.h:236
CXTPFrameWndBase::~CXTPFrameWndBase
~CXTPFrameWndBase()
Destroys a CXTPFrameWndBase object, handles cleanup and deallocation.
Definition XTPFrameWnd.h:243
CXTPFrameWnd
CXTPFrameWnd is a CXTPFrameWndBase derived class.
Definition XTPFrameWnd.h:395
CXTPFrameWnd::DECLARE_DYNCREATE
DECLARE_DYNCREATE(CXTPFrameWnd) CXTPFrameWnd()
Constructs a CXTPFrameWnd object.
CXTPMDIFrameWndEx
CXTPMDIFrameWndEx is a CXTPMDIFrameWnd derived class.
Definition XTPFrameWnd.h:318
CXTPMDIFrameWndEx::GetTabClientWnd
virtual CXTPTabClientWnd * GetTabClientWnd()=0
Obtains the associated tab client pointer.
CXTPMDIFrameWndEx::~CXTPMDIFrameWndEx
virtual ~CXTPMDIFrameWndEx()
Handles CXTPMDIFrameWndEx object destruction.
CXTPMDIFrameWndEx::DECLARE_DYNAMIC
DECLARE_DYNAMIC(CXTPMDIFrameWndEx) CXTPMDIFrameWndEx()
Constructs a CXTPMDIFrameWndEx object.
CXTPMDIFrameWnd
CXTPMDIFrameWnd is a CXTPFrameWndBase derived class.
Definition XTPFrameWnd.h:292
CXTPMDIFrameWnd::DECLARE_DYNCREATE
DECLARE_DYNCREATE(CXTPMDIFrameWnd) CXTPMDIFrameWnd()
Constructs a CXTPMDIFrameWnd object.
CXTPMDIFrameWnd::UpdateMDIChildrenTheme
void UpdateMDIChildrenTheme()
Sends a theme update notification to all MDI children.
CXTPShortcutManager
CXTPShortcutManager is a standalone class used to manipulate accelerators of a frame.
Definition XTPShortcutManager.h:189
CXTPShortcutManager::SaveShortcuts
void SaveShortcuts(LPCTSTR lpszProfileName)
Call this function to save the accelerators to the registry or .INI file.
CXTPShortcutManager::LoadShortcuts
void LoadShortcuts(LPCTSTR lpszProfileName)
Call this function to retrieve accelerators from the registry or .INI file.
CXTPTabClientWnd
CXTPTabClientWnd is a CWnd derived class.
Definition XTPTabClientWnd.h:383
CXTPTearOffFrame
The class represents a floating torn off frame.
Definition XTPTearOffFrame.h:86
CXTPToolBar
CXTPToolBar is a CXTPCommandBar derived class.
Definition XTPToolBar.h:42
CXTPToolBar::GetDockBar
CXTPDockBar * GetDockBar() const
Retrieves the parent dock bar.
Definition XTPToolBar.h:501
CXTPWindowRect
CXTPWindowRect is a helper class used to retrieve the screen size for a specified window.
Definition XTPDrawHelpers.h:158


Toolkit Pro: Member List

CXTPMDIFrameWndEx Member List

This is the complete list of members for CXTPMDIFrameWndEx, including all inherited members.

CXTPCommandBarsSiteBase() | CXTPCommandBarsSiteBase< CMDIFrameWnd > | inline
CXTPFrameWndBase() | CXTPFrameWndBase< CMDIFrameWnd > | inline
DECLARE_DYNAMIC(CXTPMDIFrameWndEx) CXTPMDIFrameWndEx() | CXTPMDIFrameWndEx |
DECLARE_DYNCREATE(CXTPMDIFrameWnd) CXTPMDIFrameWnd() | CXTPMDIFrameWnd |
DockRightOf(CXTPToolBar *pBarToDock, CXTPToolBar *pBarOnLeft) | CXTPCommandBarsSiteBase< CMDIFrameWnd > | inline
GetCommandBars() const | CXTPCommandBarsSiteBase< CMDIFrameWnd > | inline
GetTabClientWnd()=0 | CXTPMDIFrameWndEx | pure virtual
InitCommandBars(CRuntimeClass *pCommandBarsClass=RUNTIME_CLASS(CXTPCommandBars)) | CXTPCommandBarsSiteBase< CMDIFrameWnd > | inlinevirtual
LoadCommandBars(LPCTSTR lpszProfileName, BOOL bSilent=FALSE) | CXTPCommandBarsSiteBase< CMDIFrameWnd > | inlinevirtual
SaveCommandBars(LPCTSTR lpszProfileName) | CXTPCommandBarsSiteBase< CMDIFrameWnd > | inlinevirtual
UpdateMDIChildrenTheme() | CXTPMDIFrameWnd |
~CXTPCommandBarsSiteBase() | CXTPCommandBarsSiteBase< CMDIFrameWnd > | inline
~CXTPFrameWndBase() | CXTPFrameWndBase< CMDIFrameWnd > | inline
~CXTPMDIFrameWndEx() | CXTPMDIFrameWndEx | virtual


Toolkit Pro: XTPGaugeBaseType.h Source File

  • Source
  • Gauge
XTPGaugeBaseType.h
Go to the documentation of this file.
1
22#if !defined(__XTPGAUGEBASE_H__)
23# define __XTPGAUGEBASE_H__
24
25# if _MSC_VER > 1000
26# pragma once
27# endif // _MSC_VER > 1000
28
29# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
30
31class CXTPGaugeCtrl;
32class CXTPGaugeTraits;
33
41class _XTP_EXT_CLASS CXTPGaugeBaseType
42 : public CXTPCmdTarget
43 , private IXTPMarkupClientSite
44{
45 DECLARE_DYNAMIC(CXTPGaugeBaseType);
46
47 friend class CXTPGaugeCtrl;
48
49protected:
54 CXTPGaugeBaseType();
55
56public:
61 ~CXTPGaugeBaseType();
62
63public:
70 virtual LPCWSTR GetTypeName() const = 0;
71
82 BOOL IsAutomaticUpdateEnabled() const;
83
95 void EnableAutomaticUpdate(BOOL bEnable = TRUE);
96
116 HRESULT GetTrait(LPCTSTR pJPath, COleVariant& vtValue) const;
117
137 HRESULT SetTrait(LPCTSTR pJPath, const COleVariant& vtValue);
138
146 HRESULT Update();
147
155 BOOL DumpTraits(CString& strTraits) const;
156
167 HRESULT InvokeAction(LPCTSTR lpName, const COleVariant& vtArg = COleVariant(),
168 COleVariant* pvtResult = NULL);
169
170protected:
172 virtual void OnLoad();
173 virtual void OnInit();
174 virtual void OnUpdate();
175 virtual void OnCleanup();
176
177 void SetDirty();
178 HRESULT GetDispValue(LPDISPATCH pDisp, LPCWSTR pJPath, COleVariant& vtValue) const;
179 HRESULT SetDispValue(LPDISPATCH pDisp, LPCWSTR pJPath, const COleVariant& vtValue);
180 void GetNamedObject(LPDISPATCH pDisp, LPCWSTR pJPath, VARTYPE vt, BOOL bRequired,
181 COleVariant& vtValue) const;
184private:
185 BOOL Load(CXTPMarkupContext* pContext, IStream& stream, const CXTPGaugeTraits& traits);
186 void Unload();
187 void Draw(CDC& dc, CRect rc);
188 void TraceTraits() const;
189
190 CXTPMarkupContext* GetMarkupContext();
191 CXTPMarkupUIElement* GetMarkupRoot();
192
193 void Bind(CXTPGaugeCtrl* pCtrl);
194 BOOL OnWndMsg(UINT message, WPARAM wParam, LPARAM lParam, LRESULT& lResult);
195
196 CString GetJSLib(UINT nResourceID) const;
197
198private:
203 virtual LPWSTR PrepareCodeChunk(LPCWSTR pCode, const CList<LPCWSTR, LPCWSTR>& requirements);
204
205protected:
207 DECLARE_DISPATCH_MAP();
208 afx_msg void OleInit(LPDISPATCH pData);
209 afx_msg LPDISPATCH OleGetTraits();
210 afx_msg BSTR OleGetUserTraits();
211 afx_msg BSTR OleGetUserTraitsArg();
212 afx_msg BOOL OleIsDebug();
213 afx_msg void OleGetTraitsModifiers(LPDISPATCH pCallback);
214 afx_msg BSTR OleGetLibrary(LPCOLESTR pName);
215 afx_msg void OleUpdate();
216 afx_msg void OleRedraw();
217 afx_msg void OleSetTransparentBackgroundColor(LPDISPATCH pBrushDisp);
218 afx_msg void OleSetBackgroundColor(LPDISPATCH pBrushDisp);
219 afx_msg double OleDpiX(double dX);
220 afx_msg double OleDpiY(double dY);
221 afx_msg double OleUnDpiX(double dX);
222 afx_msg double OleUnDpiY(double dY);
225private:
226 CXTPGaugeCtrl* m_pCtrl;
227 BOOL m_bAutomaticUpdate;
228 const CXTPGaugeTraits* m_pUserTraits;
229 CXTPMarkupContext* m_pMarkupContext;
230 CXTPMarkupUIElement* m_pMarkupRoot;
231 LPDISPATCH m_pInitObj;
232 LPDISPATCH m_pDispTraits;
233 LPDISPATCH m_pDispUpdate;
234 LPDISPATCH m_pDispShutdown;
235 LPDISPATCH m_pDispInput;
236 LPDISPATCH m_pDispDumpTraits;
237 BOOL m_bDirty;
238
239 struct JSLib
240 {
241 LPCWSTR pName;
242 UINT nResID;
243 };
244
245 static const JSLib m_JSLibs[];
246};
247
248AFX_INLINE BOOL CXTPGaugeBaseType::IsAutomaticUpdateEnabled() const
249{
250 return m_bAutomaticUpdate;
251}
252
253AFX_INLINE void CXTPGaugeBaseType::EnableAutomaticUpdate(BOOL bEnable /*= TRUE*/)
254{
255 m_bAutomaticUpdate = bEnable;
256}
257
258AFX_INLINE CXTPMarkupContext* CXTPGaugeBaseType::GetMarkupContext()
259{
260 return m_pMarkupContext;
261}
262
263AFX_INLINE CXTPMarkupUIElement* CXTPGaugeBaseType::GetMarkupRoot()
264{
265 return m_pMarkupRoot;
266}
267
268# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
269
270#endif // !defined(__XTPGAUGEBASE_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPGaugeBaseType
A base class for all gauge types.
Definition XTPGaugeBaseType.h:44
CXTPGaugeBaseType::GetTypeName
virtual LPCWSTR GetTypeName() const =0
Obtains implementation specified type name.
CXTPGaugeBaseType::SetTrait
HRESULT SetTrait(LPCTSTR pJPath, const COleVariant &vtValue)
Sets a trait value using the specified JPath expression.
CXTPGaugeBaseType::EnableAutomaticUpdate
void EnableAutomaticUpdate(BOOL bEnable=TRUE)
Sets automatic update flag value.
Definition XTPGaugeBaseType.h:253
CXTPGaugeBaseType::GetTrait
HRESULT GetTrait(LPCTSTR pJPath, COleVariant &vtValue) const
Gets a trait value using the specified JPath expression.
CXTPGaugeBaseType::InvokeAction
HRESULT InvokeAction(LPCTSTR lpName, const COleVariant &vtArg=COleVariant(), COleVariant *pvtResult=NULL)
Invokes named gauge action.
CXTPGaugeBaseType::DumpTraits
BOOL DumpTraits(CString &strTraits) const
Obtains the current evaluated traits object in JSON format.
CXTPGaugeBaseType::CXTPGaugeBaseType
CXTPGaugeBaseType()
Handles gauge type object construction.
CXTPGaugeBaseType::IsAutomaticUpdateEnabled
BOOL IsAutomaticUpdateEnabled() const
Gets automatic update flag value.
Definition XTPGaugeBaseType.h:248
CXTPGaugeBaseType::Update
HRESULT Update()
Causes onUpdate JavaScript callback to be invoked to apply state and traits changes.
CXTPGaugeBaseType::~CXTPGaugeBaseType
~CXTPGaugeBaseType()
Handles gauge type object destruction.
CXTPGaugeCtrl
Gauge control hosts a JavaScript and Markup based gauge implementation of a certain type and provides...
Definition XTPGaugeCtrl.h:102
CXTPGaugeTraits
Defines a set of loaded gauge traits.
Definition XTPGaugeTraits.h:38
CXTPMarkupContext
CXTPMarkupContext is a standalone class used to provide common settings for Markup objects.
Definition XTPMarkupContext.h:128
CXTPMarkupUIElement
Base class for XML Markup core level implementations.
Definition XTPMarkupUIElement.h:43
IXTPMarkupClientSite
Defines default implementation of the markup client site interface.
Definition XTPMarkupContext.h:85
IXTPMarkupClientSite::PrepareCodeChunk
virtual LPWSTR PrepareCodeChunk(LPCWSTR pCode, const CList< LPCWSTR, LPCWSTR > &requirements)
Gets called by the markup context before executing script code chunk.
Definition XTPMarkupContext.h:105


Toolkit Pro: Member List

CXTPChartRadarAxisYView Member List

This is the complete list of members for CXTPChartRadarAxisYView, including all inherited members.

AddChildView(CXTPChartElementView *pChildView) | CXTPChartElementView |
CalcSize(CXTPChartDeviceContext *pDC, CRect rcDiagram) | CXTPChartRadarAxisYView |
CreateConstantLinesDeviceCommand(CXTPChartDeviceContext *pDC, BOOL bBehind) | CXTPChartRadarAxisYView | virtual
CreateDeviceCommand(CXTPChartDeviceContext *pDC) | CXTPChartRadarAxisYView | virtual
CreateGridLinesDeviceCommand(CXTPChartDeviceContext *pDC) | CXTPChartRadarAxisYView | virtual
CreateInterlacedDeviceCommand(CXTPChartDeviceContext *pDC) | CXTPChartRadarAxisYView | virtual
CreateLabelsDeviceCommand(CXTPChartDeviceContext *pDC) | CXTPChartRadarAxisYView | virtual
CreateStripsDeviceCommand(CXTPChartDeviceContext *pDC) | CXTPChartRadarAxisYView | virtual
CreateTickMarks(CXTPChartDeviceContext *pDC, CRect rcDiagram) | CXTPChartRadarAxisYView | protected
CreateTickMarksDeviceCommand(CXTPChartDeviceContext *pDC) | CXTPChartRadarAxisYView | virtual
CreateTitleDeviceCommand(CXTPChartDeviceContext *pDC) | CXTPChartRadarAxisYView | virtual
CreateView(CXTPChartDeviceContext *pDC) | CXTPChartRadarAxisYView |
CXTPChartElementView(CXTPChartElementView *pParentView) | CXTPChartElementView |
CXTPChartElementView(CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartElementView |
CXTPChartElementView(CXTPChartContainer *pContainer) | CXTPChartElementView |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartRadarAxisView(CXTPChartAxis *pAxis, CXTPChartElementView *pParentView) | CXTPChartRadarAxisView |
CXTPChartRadarAxisYView(CXTPChartAxis *pAxis, CXTPChartElementView *pParentView) | CXTPChartRadarAxisYView |
GetAt(int nIndex) const | CXTPChartElementView |
GetBounds() const | CXTPChartElementView |
GetBounds(BOOL bIncludingChildren) const | CXTPChartElementView |
GetChildren() | CXTPChartElementView |
GetCount() const | CXTPChartElementView |
GetParentView() const | CXTPChartElementView |
GetSize() const | CXTPChartRadarAxisYView |
Is3D() const | CXTPChartObject |
m_arrChildren | CXTPChartElementView | protected
m_arrTicks | CXTPChartRadarAxisYView |
m_nSize | CXTPChartRadarAxisYView | protected
m_pContainer | CXTPChartElementView | protected
m_pParentView | CXTPChartElementView | protected
m_rcBounds | CXTPChartRadarAxisYView | protected
m_rcPaneBounds | CXTPChartRadarAxisYView | protected
SetBounds(CXTPChartDeviceContext *pDC, CRect rcBounds) | CXTPChartRadarAxisYView |
~CXTPChartElementView() | CXTPChartElementView | protectedvirtual
~CXTPChartRadarAxisView() | CXTPChartRadarAxisView |
~CXTPChartRadarAxisYView() | CXTPChartRadarAxisYView |


Toolkit Pro: Member List

CXTPGridRecordItemNumber Member List

This is the complete list of members for CXTPGridRecordItemNumber, including all inherited members.

AddHyperlink(CXTPGridHyperlink *pHyperlink) | CXTPGridRecordItem | virtual
Compare(CXTPGridColumn *pColumn, CXTPGridRecordItem *pItem) | CXTPGridRecordItemNumber | virtual
CompareGroupCaption(CXTPGridColumn *pColumn, CXTPGridGroupRow *pGroupRow) | CXTPGridRecordItemNumber | virtual
CompareGroupCaption(CXTPGridColumn *pColumn, CXTPGridRecordItem *pItem) | CXTPGridRecordItemNumber | virtual
CreateBorder() | CXTPGridRecordItem |
CXTPCmdTarget() | CXTPCmdTarget |
CXTPGridRecordItem() | CXTPGridRecordItem |
CXTPGridRecordItemNumber(double dValue=0) | CXTPGridRecordItemNumber |
CXTPGridRecordItemNumber(double dValue, LPCTSTR strFormat) | CXTPGridRecordItemNumber |
DestroyBorder() | CXTPGridRecordItem |
DoPropExchange(CXTPPropExchange *pPX) | CXTPGridRecordItemNumber | virtual
Draw(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs) | CXTPGridRecordItem | virtual
DrawCheckBox(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CRect &rcItem) | CXTPGridRecordItem | protectedvirtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAlignment() const | CXTPGridRecordItem |
GetBackgroundColor() | CXTPGridRecordItem | virtual
GetBorder() const | CXTPGridRecordItem |
GetCanEditCheckboxItem() const | CXTPGridRecordItem |
GetCaption(CXTPGridColumn *pColumn) | CXTPGridRecordItemNumber | virtual
GetCaption() | CXTPGridRecordItemNumber | virtual
GetCaptionRect(XTP_GRIDRECORDITEM_ARGS *pDrawArgs, CRect &rcItem) | CXTPGridRecordItem | virtual
GetCheckedState() const | CXTPGridRecordItem |
GetColumnCaptionPrefix(CXTPGridColumn *pColumn) const | CXTPGridRecordItem |
GetEditOptions(CXTPGridColumn *pColumn) | CXTPGridRecordItem |
GetFont() | CXTPGridRecordItem | virtual
GetFormatString() const | CXTPGridRecordItem | virtual
GetFormula() const | CXTPGridRecordItem | virtual
GetGroupCaption(CXTPGridColumn *pColumn) | CXTPGridRecordItem | virtual
GetGroupCaptionID(CXTPGridColumn *pColumn) | CXTPGridRecordItem | virtual
GetGroupCaptionValue(CXTPGridColumn *pColumn) | CXTPGridRecordItemNumber | virtual
GetGroupPriority() const | CXTPGridRecordItem | virtual
GetHasCheckbox() const | CXTPGridRecordItem | virtual
GetHyperlinkAt(int nHyperlink) const | CXTPGridRecordItem | virtual
GetHyperlinks() | CXTPGridRecordItem | protected
GetHyperlinksCount() const | CXTPGridRecordItem | virtual
GetIconIndex() const | CXTPGridRecordItem | virtual
GetIndex() const | CXTPGridRecordItem |
GetItemControls() | CXTPGridRecordItem |
GetItemData() const | CXTPGridRecordItem | virtual
GetItemMetrics(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pItemMetrics) | CXTPGridRecordItem | virtual
GetMarkupUIElement() const | CXTPGridRecordItem |
GetRecord() const | CXTPGridRecordItem |
GetSelectedConstraintData(XTP_GRIDRECORDITEM_ARGS *pItemArgs) | CXTPGridRecordItem | virtual
GetSortPriority() const | CXTPGridRecordItem | virtual
GetTextColor() | CXTPGridRecordItem | virtual
GetTooltip() const | CXTPGridRecordItem | virtual
GetValue() | CXTPGridRecordItemNumber |
HasCheckbox(BOOL bHasCheckbox, BOOL bTristate=FALSE) | CXTPGridRecordItem | virtual
HitTest(CPoint ptPoint) | CXTPGridRecordItem |
HitTestHyperlink(CPoint ptClick) | CXTPGridRecordItem | virtual
IsBold() const | CXTPGridRecordItem | virtual
IsChecked() const | CXTPGridRecordItem | virtual
IsChildOfMerge() const | CXTPGridRecordItem |
IsEditable() const | CXTPGridRecordItem | virtual
IsFocusable() const | CXTPGridRecordItem | virtual
IsPreviewItem() const | CXTPGridRecordItem | virtual
m_Alignment | CXTPGridRecordItem | protected
m_bBoldText | CXTPGridRecordItem | protected
m_bCanEditCheckboxItem | CXTPGridRecordItem | protected
m_bEditable | CXTPGridRecordItem | protected
m_bFocusable | CXTPGridRecordItem | protected
m_bHasCheckbox | CXTPGridRecordItem | protected
m_bItemControlUnderMouse | CXTPGridRecordItem | protected
m_bTristateCheckbox | CXTPGridRecordItem | protected
m_checkState | CXTPGridRecordItem | protected
m_clrBackground | CXTPGridRecordItem | protected
m_clrText | CXTPGridRecordItem | protected
m_dValue | CXTPGridRecordItemNumber | protected
m_dwData | CXTPGridRecordItem | protected
m_nGroupPriority | CXTPGridRecordItem | protected
m_nIconIndex | CXTPGridRecordItem | protected
m_nSortPriority | CXTPGridRecordItem | protected
m_pBorder | CXTPGridRecordItem | protected
m_pControl | CXTPGridRecordItem | protected
m_pEditOptions | CXTPGridRecordItem | protected
m_pFocusedItemControl | CXTPGridRecordItem | protected
m_pFontCaption | CXTPGridRecordItem | protected
m_pHyperlinks | CXTPGridRecordItem | protected
m_pItemControlHookWnd | CXTPGridRecordItem | protected
m_pItemControls | CXTPGridRecordItem | protected
m_pMarkupUIElement | CXTPGridRecordItem | protected
m_pRecord | CXTPGridRecordItem | protected
m_rcGlyph | CXTPGridRecordItem | protected
m_strCaption | CXTPGridRecordItem | protected
m_strFormatString | CXTPGridRecordItem | protected
m_strFormula | CXTPGridRecordItem | protected
m_strGroupCaption | CXTPGridRecordItem | protected
m_strTooltip | CXTPGridRecordItem | protected
OnBeginEdit(XTP_GRIDRECORDITEM_ARGS *pItemArgs) | CXTPGridRecordItem | protectedvirtual
OnCancelEdit(CXTPGridControl *pControl, BOOL bApply) | CXTPGridRecordItem | virtual
OnChar(XTP_GRIDRECORDITEM_ARGS *pItemArgs, UINT nChar) | CXTPGridRecordItem | protectedvirtual
OnClick(XTP_GRIDRECORDITEM_CLICKARGS *pClickArgs) | CXTPGridRecordItem | virtual
OnConstraintChanged(XTP_GRIDRECORDITEM_ARGS *pItemArgs, CXTPGridRecordItemConstraint *pConstraint) | CXTPGridRecordItem | virtual
OnDblClick(XTP_GRIDRECORDITEM_CLICKARGS *pClickArgs) | CXTPGridRecordItem | virtual
OnDrawCaption(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics) | CXTPGridRecordItem | virtual
OnDrawControls(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CRect &rcItem) | CXTPGridRecordItem | virtual
OnEditCanceled(XTP_GRIDRECORDITEM_ARGS *pItemArgs) | CXTPGridRecordItem | virtual
OnEditChanged(XTP_GRIDRECORDITEM_ARGS *pItemArgs, LPCTSTR szText) | CXTPGridRecordItemNumber | virtual
OnEditChanging(XTP_GRIDRECORDITEM_ARGS *pItemArgs, CString &rstrNewText) | CXTPGridRecordItem | virtual
OnInplaceButtonDown(CXTPGridInplaceButton *pButton) | CXTPGridRecordItem | virtual
OnLButtonDown(XTP_GRIDRECORDITEM_CLICKARGS *pClickArgs) | CXTPGridRecordItem | virtual
OnLButtonUp(XTP_GRIDRECORDITEM_CLICKARGS *pClickArgs) | CXTPGridRecordItem | virtual
OnMouseMove(UINT nFlags, CPoint point, CXTPGridControl *pControl=NULL) | CXTPGridRecordItem | virtual
OnRequestEdit(XTP_GRIDRECORDITEM_ARGS *pItemArgs) | CXTPGridRecordItem | protectedvirtual
OnToolHitTest(CPoint point, TOOLINFO *pTI) | CXTPGridRecordItem | virtual
OnValidateEdit(XTP_GRIDRECORDITEM_ARGS *pItemArgs) | CXTPGridRecordItem | virtual
operator delete(void *p) | CXTPHeapObjectT< CXTPCmdTarget, CXTPGridDataAllocator > | inline
operator new(size_t nSize) | CXTPHeapObjectT< CXTPCmdTarget, CXTPGridDataAllocator > | inline
RemoveHyperlinkAt(int nHyperlink) | CXTPGridRecordItem | virtual
ResetMarkupUIElement() | CXTPGridRecordItem | virtual
SetAlignment(int nAlignment) | CXTPGridRecordItem |
SetBackgroundColor(COLORREF clrBackground) | CXTPGridRecordItem | virtual
SetBold(BOOL bBold=TRUE) | CXTPGridRecordItem | virtual
SetCanEditCheckboxItem(BOOL bSet) | CXTPGridRecordItem |
SetCaption(LPCTSTR strCaption) | CXTPGridRecordItem | virtual
SetChecked(BOOL bChecked) | CXTPGridRecordItem | virtual
SetCheckedState(int iState) | CXTPGridRecordItem |
SetEditable(BOOL bEditable=TRUE) | CXTPGridRecordItem | virtual
SetFocusable(BOOL bFocusable) | CXTPGridRecordItem | virtual
SetFont(CFont *pFont) | CXTPGridRecordItem | virtual
SetFormatString(LPCTSTR strFormat) | CXTPGridRecordItem | virtual
SetFormula(LPCTSTR sFormula) | CXTPGridRecordItem | virtual
SetGridControl(CXTPGridControl *pControl) | CXTPGridRecordItem |
SetGroupCaption(LPCTSTR strCaption) | CXTPGridRecordItem | virtual
SetGroupPriority(int nGroupPriority) | CXTPGridRecordItem | virtual
SetIconIndex(int nIconIndex) | CXTPGridRecordItem | virtual
SetItemData(DWORD_PTR dwData) | CXTPGridRecordItem | virtual
SetRecord(CXTPGridRecord *pGridRecord) | CXTPGridRecordItem |
SetSortPriority(int nSortPriority) | CXTPGridRecordItem | virtual
SetTextColor(COLORREF clrText) | CXTPGridRecordItem | virtual
SetTooltip(LPCTSTR lpszTooltip) | CXTPGridRecordItem | virtual
SetValue(double dValue) | CXTPGridRecordItemNumber |
UpdateValue() | CXTPGridRecordItem |
~CXTPGridRecordItem() | CXTPGridRecordItem | virtual


Toolkit Pro: Member List

CXTPChartGanttSeriesPointView Member List

This is the complete list of members for CXTPChartGanttSeriesPointView, including all inherited members.

AddChildView(CXTPChartElementView *pChildView) | CXTPChartElementView |
CreateDeviceCommand(CXTPChartDeviceContext *pDC) | CXTPChartRangeBarSeriesPointView | virtual
CreateLegendDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcBounds) | CXTPChartBarSeriesPointView | virtual
CXTPChartBarSeriesPointView(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView) | CXTPChartBarSeriesPointView |
CXTPChartElementView(CXTPChartElementView *pParentView) | CXTPChartElementView |
CXTPChartElementView(CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartElementView |
CXTPChartElementView(CXTPChartContainer *pContainer) | CXTPChartElementView |
CXTPChartGanttSeriesPointView(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView) | CXTPChartGanttSeriesPointView |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartRangeBarSeriesPointView(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView) | CXTPChartRangeBarSeriesPointView |
CXTPChartSeriesPointView(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView) | CXTPChartSeriesPointView |
CXTPChartSeriesPointView(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartSeriesPointView |
GetAt(int nIndex) const | CXTPChartElementView |
GetBounds() const | CXTPChartElementView |
GetBounds(BOOL bIncludingChildren) const | CXTPChartElementView |
GetChildren() | CXTPChartElementView |
GetColor() const | CXTPChartSeriesPointView |
GetColor2() const | CXTPChartSeriesPointView |
GetCount() const | CXTPChartElementView |
GetInternalValue() const | CXTPChartSeriesPointView |
GetLegendName() const | CXTPChartSeriesPointView | virtual
GetParentView() const | CXTPChartElementView |
GetPoint() const | CXTPChartSeriesPointView |
GetSeriesView() const | CXTPChartSeriesPointView |
Is3D() const | CXTPChartObject |
m_arrChildren | CXTPChartElementView | protected
m_dInternalValue | CXTPChartSeriesPointView |
m_pContainer | CXTPChartElementView | protected
m_pParentView | CXTPChartElementView | protected
m_pPoint | CXTPChartSeriesPointView | protected
m_rcBounds | CXTPChartElementView | protected
UpdateMinMaxRange(double &nMinValue, double &nMaxValue) const | CXTPChartRangeBarSeriesPointView | virtual
~CXTPChartElementView() | CXTPChartElementView | protectedvirtual
~CXTPChartLegendItemView() | CXTPChartLegendItemView | inlinevirtual


Toolkit Pro: Member List

CXTPMarkupPage Member List

This is the complete list of members for CXTPMarkupPage, including all inherited members.

ApplyRenderTransform(CXTPMarkupDrawingContext *pContext) | CXTPMarkupUIElement | protectedvirtual
Arrange(CRect rcFinalRect) | CXTPMarkupUIElement |
ArrangeCore(CRect rcFinalRect) | CXTPMarkupUIElement | protectedvirtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPMarkupFrameworkElement() | CXTPMarkupFrameworkElement | protected
CXTPMarkupPage() | CXTPMarkupPage | protected
CXTPMarkupUIElement() | CXTPMarkupUIElement | protected
CXTPMarkupVisual() | CXTPMarkupVisual |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAbsoluteVisualOffset() const | CXTPMarkupVisual | protected
GetActualSize() const | CXTPMarkupFrameworkElement |
GetBoundRect() const | CXTPMarkupVisual |
GetClipToBounds() const | CXTPMarkupFrameworkElement |
GetContent() const | CXTPMarkupPage |
GetDesiredSize() const | CXTPMarkupUIElement |
GetFinalRect() const | CXTPMarkupUIElement |
GetHeight() const | CXTPMarkupFrameworkElement |
GetHorizontalAlignment() const | CXTPMarkupFrameworkElement |
GetLayoutClip(CRect &rc) const | CXTPMarkupUIElement | protectedvirtual
GetLogicalChild(int nIndex) const | CXTPMarkupVisual | virtual
GetLogicalChildrenCount() const | CXTPMarkupVisual | virtual
GetMargin() const | CXTPMarkupFrameworkElement |
GetMaxHeight() const | CXTPMarkupFrameworkElement |
GetMaxWidth() const | CXTPMarkupFrameworkElement |
GetMinHeight() const | CXTPMarkupFrameworkElement |
GetMinWidth() const | CXTPMarkupFrameworkElement |
GetOpacity() const | CXTPMarkupUIElement | protectedvirtual
GetRenderSize() const | CXTPMarkupVisual |
GetRenderTransform() const | CXTPMarkupUIElement | protected
GetStyle() const | CXTPMarkupFrameworkElement |
GetTag() const | CXTPMarkupFrameworkElement |
GetUpdateRect() const | CXTPMarkupVisual |
GetVerticalAlignment() const | CXTPMarkupFrameworkElement |
GetVisibility() const | CXTPMarkupUIElement |
GetVisualChild(int nIndex) const | CXTPMarkupVisual | virtual
GetVisualChildrenCount() const | CXTPMarkupVisual | virtual
GetVisualOffset() const | CXTPMarkupVisual |
GetVisualParent() const | CXTPMarkupVisual |
GetWidth() const | CXTPMarkupFrameworkElement |
InputHitTest(CPoint point) const | CXTPMarkupVisual |
InputHitTestOverride(CPoint point) const | CXTPMarkupVisual | protectedvirtual
InvalidateArrange() | CXTPMarkupUIElement | virtual
InvalidateMeasure() | CXTPMarkupUIElement | virtual
InvalidateMeasureOverride(CXTPMarkupDrawingContext *pDC) | CXTPMarkupUIElement | protectedvirtual
InvalidateVisual() | CXTPMarkupUIElement | virtual
IsEnabled() const | CXTPMarkupUIElement |
IsFocusable() const | CXTPMarkupUIElement |
IsVisible() const | CXTPMarkupUIElement | virtual
m_bArrangeDirty | CXTPMarkupUIElement | protected
m_bArrangeInProgress | CXTPMarkupUIElement | protected
m_bMeasureDirty | CXTPMarkupUIElement | protected
m_bMeasureInProgress | CXTPMarkupUIElement | protected
m_bNeverArranged | CXTPMarkupUIElement | protected
m_bNeverMeasured | CXTPMarkupUIElement | protected
m_pClipToBoundsProperty | CXTPMarkupUIElement | static
m_pFocusableProperty | CXTPMarkupUIElement | static
m_pIsEnabledProperty | CXTPMarkupUIElement | static
m_pOpacityProperty | CXTPMarkupUIElement | static
m_pRenderTransformOriginProperty | CXTPMarkupUIElement | static
m_pRenderTransformProperty | CXTPMarkupUIElement | static
m_ptVisualOffset | CXTPMarkupVisual | protected
m_pVisibilityProperty | CXTPMarkupUIElement | static
m_rcBoundRect | CXTPMarkupVisual | protected
m_rcFinalRect | CXTPMarkupUIElement | protected
m_rcPrevUpdateRect | CXTPMarkupVisual | protected
m_rcUpdateRect | CXTPMarkupVisual | protected
m_szDesiredSize | CXTPMarkupUIElement | protected
m_szPreviousAvailableSize | CXTPMarkupUIElement | protected
m_szRenderSize | CXTPMarkupVisual | protected
Measure(CXTPMarkupDrawingContext *pDC, CSize szAvailableSize) | CXTPMarkupUIElement |
MeasureCore(CXTPMarkupDrawingContext *pDC, CSize szAvailableSize) | CXTPMarkupUIElement | protectedvirtual
OnRender(CXTPMarkupDrawingContext *drawingContext) | CXTPMarkupVisual | protectedvirtual
OnRenderFocusVisual(CXTPMarkupDrawingContext *drawingContext) | CXTPMarkupVisual | protectedvirtual
PtInRectTransform(const RECT &rect, const POINT &point) const | CXTPMarkupVisual | protected
Render(CXTPMarkupDrawingContext *drawingContext) | CXTPMarkupVisual |
RenderClipped(CXTPMarkupDrawingContext *drawingContext) | CXTPMarkupVisual | protectedvirtual
RestoreRenderTransform(CXTPMarkupDrawingContext *pContext, TransformationMatrices &matrices) | CXTPMarkupUIElement | protectedvirtual
SetClipToBounds(BOOL bClipToBounds) | CXTPMarkupFrameworkElement |
SetContent(CXTPMarkupUIElement *pContent) | CXTPMarkupPage |
SetHeight(int nHeight) | CXTPMarkupFrameworkElement |
SetHorizontalAlignment(XTPMarkupHorizontalAlignment alignment) | CXTPMarkupFrameworkElement |
SetMargin(int nLeft, int nTop, int nRight, int nBottom) | CXTPMarkupFrameworkElement |
SetMargin(int nMargin) | CXTPMarkupFrameworkElement |
SetMaxHeight(int nHeight) | CXTPMarkupFrameworkElement |
SetMaxWidth(int nWidth) | CXTPMarkupFrameworkElement |
SetMinHeight(int nHeight) | CXTPMarkupFrameworkElement |
SetMinWidth(int nWidth) | CXTPMarkupFrameworkElement |
SetTag(CXTPMarkupObject *pTag) | CXTPMarkupFrameworkElement |
SetVerticalAlignment(XTPMarkupVerticalAlignment alignment) | CXTPMarkupFrameworkElement |
SetVisibility(XTPMarkupVisibility visibility) | CXTPMarkupUIElement |
SetWidth(int nWidth) | CXTPMarkupFrameworkElement |
~CXTPMarkupFrameworkElement() | CXTPMarkupFrameworkElement | protectedvirtual
~CXTPMarkupPage() | CXTPMarkupPage | protectedvirtual
~CXTPMarkupUIElement() | CXTPMarkupUIElement | protectedvirtual
~CXTPMarkupVisual() | CXTPMarkupVisual | virtual


Toolkit Pro: Member List

CXTPTaskPanelVisualStudio2022Theme Member List

This is the complete list of members for CXTPTaskPanelVisualStudio2022Theme, including all inherited members.

BlendColor(COLORREF clrFrom, COLORREF clrTo, int nAlpha) | CXTPTaskPanelPaintManager | protected
CreateGripperBitmaps() | CXTPTaskPanelPaintManager | protected
CreateGripperIcon(HICON &hIcon, UINT nIDResource, COLORREF clrGripperBack) | CXTPTaskPanelPaintManager | protected
CXTPTaskPanelPaintManager() | CXTPTaskPanelPaintManager |
CXTPTaskPanelPaintManagerPlain() | CXTPTaskPanelPaintManagerPlain |
CXTPTaskPanelToolboxTheme() | CXTPTaskPanelToolboxTheme |
CXTPTaskPanelVisualStudio2005Theme() | CXTPTaskPanelVisualStudio2005Theme |
CXTPTaskPanelVisualStudio2012Theme(BOOL bLight=TRUE) | CXTPTaskPanelVisualStudio2012Theme |
CXTPTaskPanelVisualStudio2022Theme() | CXTPTaskPanelVisualStudio2022Theme |
DrawCaptionGripper(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelPaintManager | protectedvirtual
DrawCaptionGripperBitmap(CDC *pDC, CXTPTaskPanelGroup *pGroup, BOOL bExpanded, BOOL bHot, CRect rc) | CXTPTaskPanelPaintManager | protected
DrawCaptionGripperSigns(CDC *pDC, CPoint pt, COLORREF clr, BOOL bExpanded) | CXTPTaskPanelPaintManager | protected
DrawDragArrow(CDC *pDC, CXTPTaskPanelItem *pItem, CRect rc, BOOL bAfter=FALSE) | CXTPTaskPanelPaintManager | protectedvirtual
DrawFocusRect(CDC *pDC, CRect rc) | CXTPTaskPanelPaintManager | protectedvirtual
DrawGroupCaption(CDC *pDC, CXTPTaskPanelGroup *pGroup, BOOL bDraw) | CXTPTaskPanelToolboxTheme | virtual
DrawGroupCaptionBackground(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelVisualStudio2012Theme | virtual
DrawGroupClient(CDC *pDC, CXTPTaskPanelGroup *pGroup) | CXTPTaskPanelPaintManager | virtual
DrawGroupClientFace(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelVisualStudio2012Theme | virtual
DrawGroupClientItems(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelPaintManager | protectedvirtual
DrawGroupItem(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw) | CXTPTaskPanelPaintManager | virtual
DrawGroupItemFrame(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc) | CXTPTaskPanelVisualStudio2012Theme | virtual
DrawGroupItemImage(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw) | CXTPTaskPanelPaintManager | protected
DrawGroupItemImageWithText(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw) | CXTPTaskPanelPaintManager | protected
DrawGroupItemImageWithTextBelow(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw) | CXTPTaskPanelPaintManager | protected
DrawItemCaption(CDC *pDC, CXTPTaskPanelItem *pItem, CRect rcText, UINT nFormat) | CXTPTaskPanelVisualStudio2012Theme | virtual
DrawItemImage(CDC *pDC, CXTPTaskPanelItem *pItem, CPoint ptIcon, CXTPImageManagerIcon *pImage, CSize szIcon) | CXTPTaskPanelPaintManager | protectedvirtual
DrawScrollButton(CDC *pDC, CXTPTaskPanelScrollButton *pScrollButton) | CXTPTaskPanelPaintManager | virtual
FillGroupClientFace(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelVisualStudio2012Theme | virtual
FillTaskPanel(CDC *pDC, CXTPTaskPanel *pTaskPanel) | CXTPTaskPanelVisualStudio2012Theme | virtual
FreeBitmaps() | CXTPTaskPanelPaintManager | protected
GetCaptionGripperWidth(CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelPaintManager | protectedvirtual
GetControlMargins(const CXTPTaskPanel *pPanel) | CXTPTaskPanelPaintManager | virtual
GetGroupColors(BOOL bSpecial) | CXTPTaskPanelPaintManager |
GetGroupColors(CXTPTaskPanelGroup *pGroup) | CXTPTaskPanelPaintManager | virtual
GetGroupInnerMargins(const CXTPTaskPanelGroup *pGroup) | CXTPTaskPanelPaintManager | virtual
GetGroupOuterMargins(const CXTPTaskPanelGroup *pGroup) | CXTPTaskPanelPaintManager | virtual
GetGroupSpacing(const CXTPTaskPanel *pPanel) | CXTPTaskPanelPaintManager | virtual
GetHighlightOffset(CXTPTaskPanelGroupItem *pItem) | CXTPTaskPanelPaintManager | protectedvirtual
GetItemFont(CXTPTaskPanelItem *pItem) | CXTPTaskPanelPaintManager | virtual
GetItemIconPadding(const CXTPTaskPanelItem *pItem) | CXTPTaskPanelPaintManager | virtual
GetItemInnerMargins(const CXTPTaskPanelGroupItem *pItem) | CXTPTaskPanelPaintManager | virtual
GetItemOuterMargins(const CXTPTaskPanelGroupItem *pItem) | CXTPTaskPanelPaintManager | virtual
m_bBoldCaption | CXTPTaskPanelPaintManager |
m_bCaptionScrollButton | CXTPTaskPanelPaintManager |
m_bEmbossedDisabledText | CXTPTaskPanelPaintManager |
m_bEmulateEplorerTheme | CXTPTaskPanelPaintManager |
m_bInvertDragRect | CXTPTaskPanelPaintManager |
m_bLeftRoundedCorner | CXTPTaskPanelPaintManager | protected
m_bmpGrippers | CXTPTaskPanelPaintManager | protected
m_bOfficeBorder | CXTPTaskPanelPaintManager | protected
m_bOfficeCaption | CXTPTaskPanelPaintManagerPlain | protected
m_bOfficeHighlight | CXTPTaskPanelPaintManager |
m_bRightRoundedCorner | CXTPTaskPanelPaintManager | protected
m_bRoundedFrame | CXTPTaskPanelPaintManagerPlain | protected
m_bUseBitmapGrippers | CXTPTaskPanelPaintManager | protected
m_bUseStandardCaptionFont | CXTPTaskPanelPaintManager | protected
m_bUseStandardItemsFont | CXTPTaskPanelPaintManager | protected
m_clrBackground | CXTPTaskPanelPaintManager | protected
m_clrHighlightBorder | CXTPTaskPanelPaintManager | protected
m_clrHighlightHot | CXTPTaskPanelPaintManager | protected
m_clrHighlightPressed | CXTPTaskPanelPaintManager | protected
m_clrHighlightSelected | CXTPTaskPanelPaintManager | protected
m_clrSelectedText | CXTPTaskPanelVisualStudio2012Theme | protected
m_clrSelectedTextWithoutFocus | CXTPTaskPanelVisualStudio2012Theme | protected
m_clrSelectedWithoutFocus | CXTPTaskPanelVisualStudio2012Theme | protected
m_clrText | CXTPTaskPanelVisualStudio2012Theme | protected
m_eGripper | CXTPTaskPanelPaintManager |
m_groupNormal | CXTPTaskPanelPaintManager | protected
m_groupSpecial | CXTPTaskPanelPaintManager | protected
m_hGripperNormal | CXTPTaskPanelPaintManager | protected
m_hGripperSpecial | CXTPTaskPanelPaintManager | protected
m_nCaptionHeight | CXTPTaskPanelPaintManager | protected
m_nCaptionTextFormat | CXTPTaskPanelPaintManager | protected
m_nGroupSpacing | CXTPTaskPanelPaintManager |
m_nItemTextFormat | CXTPTaskPanelPaintManager | protected
m_rcControlMargins | CXTPTaskPanelPaintManager |
m_rcGroupIconPadding | CXTPTaskPanelPaintManager |
m_rcGroupInnerMargins | CXTPTaskPanelPaintManager |
m_rcGroupOuterMargins | CXTPTaskPanelPaintManager |
m_rcImageLayoutIconPadding | CXTPTaskPanelPaintManager |
m_rcItemIconPadding | CXTPTaskPanelPaintManager |
m_rcItemInnerMargins | CXTPTaskPanelPaintManager |
m_rcItemOuterMargins | CXTPTaskPanelPaintManager |
m_xtpFontCaption | CXTPTaskPanelPaintManager | protected
m_xtpFontIcon | CXTPTaskPanelPaintManager | protected
m_xtpFontIconBold | CXTPTaskPanelPaintManager | protected
m_xtpFontIconHot | CXTPTaskPanelPaintManager | protected
m_xtpFontIconHotBold | CXTPTaskPanelPaintManager | protected
Rectangle(CDC *pDC, CRect rc, COLORREF clrPen, COLORREF clrBrush) | CXTPTaskPanelPaintManager | protected
rectDefault | CXTPTaskPanelPaintManager | static
RefreshMetrics() | CXTPTaskPanelVisualStudio2022Theme | virtual
SetCaptionFontIndirect(LOGFONT *pLogFont, BOOL bUseStandardCaptionFont=FALSE) | CXTPTaskPanelPaintManager |
SetItemsFontIndirect(LOGFONT *pLogFont, BOOL bUseStandardItemsFont=FALSE) | CXTPTaskPanelPaintManager |
SetTextFormat(int nTextFormat, BOOL bCaption=FALSE) | CXTPTaskPanelPaintManager |
~CXTPTaskPanelPaintManager() | CXTPTaskPanelPaintManager | virtual
~CXTPTaskPanelVisualStudio2012Theme() | CXTPTaskPanelVisualStudio2012Theme | virtual
~CXTPTaskPanelVisualStudio2022Theme() | CXTPTaskPanelVisualStudio2022Theme | virtual


Toolkit Pro: Member List

  • CXTPCommandBars
  • KEYBOARDTIPS
CXTPCommandBars::KEYBOARDTIPS Member List

This is the complete list of members for CXTPCommandBars::KEYBOARDTIPS, including all inherited members.

arr | CXTPCommandBars::KEYBOARDTIPS
nKey | CXTPCommandBars::KEYBOARDTIPS
nLevel | CXTPCommandBars::KEYBOARDTIPS


Toolkit Pro: Member List

CXTPChartDeviceContext Member List

This is the complete list of members for CXTPChartDeviceContext, including all inherited members.

CXTPChartDeviceContext(CXTPChartContainer *pContainer, HDC hDC, BOOL bIs3D, CXTPChartDrawingObjectFactory *pDrawingObjectFactory) | CXTPChartDeviceContext | protected
CXTPCmdTarget() | CXTPCmdTarget |
Execute(CXTPChartDeviceCommand *pCommand) | CXTPChartDeviceContext | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetContainer() const | CXTPChartDeviceContext |
GetDrawingObjectFactory() const | CXTPChartDeviceContext |
GetHDC() const | CXTPChartDeviceContext |
Initialize() | CXTPChartDeviceContext | virtual
Is3D() const | CXTPChartDeviceContext |
m_bIs3D | CXTPChartDeviceContext | protected
m_hDC | CXTPChartDeviceContext | protected
m_pContainer | CXTPChartDeviceContext | protected
m_pDrawingObjectFactory | CXTPChartDeviceContext | protected
MeasureMarkupElement(CXTPMarkupUIElement *pMarkupUIElement, CXTPChartFont *pFont)=0 | CXTPChartDeviceContext | pure virtual
MeasureString(const CXTPChartString *pText, CXTPChartFont *pFont)=0 | CXTPChartDeviceContext | pure virtual
~CXTPChartDeviceContext()=0 | CXTPChartDeviceContext | pure virtual


Toolkit Pro: XTPDockingPaneTabThemeNativeWindows11.h Source File

  • Source
  • DockingPane
  • TabThemes
XTPDockingPaneTabThemeNativeWindows11.h
Go to the documentation of this file.
1
23#if !defined(__XTPDOCKINGPANETABTHEMENATIVEWINDOWS11_H__)
24# define __XTPDOCKINGPANETABTHEMENATIVEWINDOWS11_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPDockingPaneTabThemeNativeWindows11 : public CXTPDockingPaneTabTheme2012
39{
40public:
45 CXTPDockingPaneTabThemeNativeWindows11();
46
63 virtual void DrawSingleButton(CDC* pDC, CXTPTabManagerItem* pItem);
64};
65
66# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
68#endif // !defined(__XTPDOCKINGPANETABTHEMENATIVEWINDOWS11_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPDockingPaneTabTheme2012
Helper class used to initialize default colors for a theme from an .INI resource and handle drawing r...
Definition XTPDockingPaneTabTheme2012.h:39
CXTPDockingPaneTabThemeNativeWindows11
Helper class used to initialize default colors for a theme from an .INI resource and handle drawing r...
Definition XTPDockingPaneTabThemeNativeWindows11.h:39
CXTPDockingPaneTabThemeNativeWindows11::CXTPDockingPaneTabThemeNativeWindows11
CXTPDockingPaneTabThemeNativeWindows11()
Default class constructor.
CXTPDockingPaneTabThemeNativeWindows11::DrawSingleButton
virtual void DrawSingleButton(CDC *pDC, CXTPTabManagerItem *pItem)
This method is called to draw a single tab button in the tab client header area.
CXTPTabManagerItem
CXTPTabManagerItem is the base class for the tabs that appear in the command bars tab workspace,...
Definition XTPTabManagerItem.h:44


Toolkit Pro: Member List

CAppearanceSetPropertyPage2007 Member List

This is the complete list of members for CAppearanceSetPropertyPage2007, including all inherited members.

AdjustClientRect(CXTPTabManager *pTabManager, CRect &rcClient) | CXTPTabPaintManagerTheme | virtual
CAppearanceSetPropertyPage2007() | CAppearanceSetPropertyPage2007 | inline
CXTPTabPaintManagerTheme() | CXTPTabPaintManagerTheme |
DrawSingleButton(CDC *pDC, CXTPTabManagerItem *pItem) | CAppearanceSetPropertyPage2007 | protectedvirtual
DrawTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl) | CXTPTabPaintManagerTheme | virtual
DrawText(CDC *pDC, CXTPTabManager *pManager, const CString &str, LPRECT lpRect, UINT nFormat) | CXTPTabPaintManagerTheme | virtual
DrawWorkspacePart(CDC *pDC, LPRECT lpRect, XTPTabWorkspacePart workspacePart) | CXTPTabPaintManagerTheme | virtual
FillButton(CDC *pDC, CXTPTabManagerItem *pItem, LPPOINT pts, int nCount, XTPTabPosition tabPosition, BOOL bAbsolute=FALSE) | CXTPTabPaintManagerTheme |
FillTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl) | CAppearanceSetPropertyPage2007 | protectedvirtual
GetButtonDrawRect(const CXTPTabManagerItem *pItem) | CXTPTabPaintManagerTheme | virtual
GetButtonHeight(const CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetButtonLength(CDC *pDC, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerTheme | virtual
GetClientMargin() | CXTPTabPaintManagerTheme | virtual
GetClientRect(CRect rcControl, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetColorSet() const | CXTPTabPaintManagerTheme |
GetDefaultColorSet() | CAppearanceSetPropertyPage2007 | inlineprotectedvirtual
GetHeaderClipBox(CDC *pDC, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetHeaderHeight(CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme |
GetHeaderMargin() | CXTPTabPaintManagerTheme | virtual
GetHeaderRect(CRect rcControl, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetSupportedColorSets() | CXTPTabPaintManagerTheme | inlinevirtual
m_bButtonsReverseZOrder | CXTPTabPaintManagerTheme | protected
m_nButtonHeight | CXTPTabPaintManagerTheme | protected
m_nRowMargin | CXTPTabPaintManagerTheme |
m_pPaintManager | CXTPTabPaintManagerTheme | protected
m_rcHeaderMargin | CXTPTabPaintManagerTheme |
RefreshMetrics() | CAppearanceSetPropertyPage2007 | protectedvirtual
RepositionTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcClient) | CXTPTabPaintManagerTheme | virtual
~CXTPTabPaintManagerTheme() | CXTPTabPaintManagerTheme | virtual


Toolkit Pro: Member List

CXTPChartFunnelSeriesPointViewBase Member List

This is the complete list of members for CXTPChartFunnelSeriesPointViewBase, including all inherited members.

AddChildView(CXTPChartElementView *pChildView) | CXTPChartElementView |
CalculateLayout(int nIndex, int nCount, double dFrom, double dTo) | CXTPChartFunnelSeriesPointViewBase | virtual
CreateDeviceCommand(CXTPChartDeviceContext *pDC)=0 | CXTPChartFunnelSeriesPointViewBase | protectedpure virtual
CreateLegendDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcBounds) | CXTPChartFunnelSeriesPointViewBase | protectedvirtual
CXTPChartElementView(CXTPChartElementView *pParentView) | CXTPChartElementView |
CXTPChartElementView(CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartElementView |
CXTPChartElementView(CXTPChartContainer *pContainer) | CXTPChartElementView |
CXTPChartFunnelSeriesPointViewBase(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView) | CXTPChartFunnelSeriesPointViewBase |
CXTPChartFunnelSeriesPointViewBase(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartFunnelSeriesPointViewBase |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartSeriesPointView(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView) | CXTPChartSeriesPointView |
CXTPChartSeriesPointView(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartSeriesPointView |
GetAt(int nIndex) const | CXTPChartElementView |
GetBorderActualColor() const | CXTPChartFunnelSeriesPointViewBase |
GetBounds() const | CXTPChartElementView |
GetBounds(BOOL bIncludingChildren) const | CXTPChartElementView |
GetChildren() | CXTPChartElementView |
GetColor() const | CXTPChartSeriesPointView |
GetColor2() const | CXTPChartSeriesPointView |
GetCount() const | CXTPChartElementView |
GetInternalValue() const | CXTPChartSeriesPointView |
GetLegendName() const | CXTPChartSeriesPointView | virtual
GetParentView() const | CXTPChartElementView |
GetPoint() const | CXTPChartSeriesPointView |
GetSeriesView() const | CXTPChartSeriesPointView |
Is3D() const | CXTPChartObject |
m_arrChildren | CXTPChartElementView | protected
m_dInternalValue | CXTPChartSeriesPointView |
m_dValue | CXTPChartFunnelSeriesPointViewBase | protected
m_pContainer | CXTPChartElementView | protected
m_pParentView | CXTPChartElementView | protected
m_pPoint | CXTPChartSeriesPointView | protected
m_rcBounds | CXTPChartElementView | protected
UpdateMinMaxRange(double &nMinValue, double &nMaxValue) const | CXTPChartSeriesPointView | virtual
~CXTPChartElementView() | CXTPChartElementView | protectedvirtual
~CXTPChartFunnelSeriesPointViewBase() | CXTPChartFunnelSeriesPointViewBase | virtual
~CXTPChartLegendItemView() | CXTPChartLegendItemView | inlinevirtual


Toolkit Pro: Member List

CXTPMarkupGdiPlusScaleTransform Member List

This is the complete list of members for CXTPMarkupGdiPlusScaleTransform, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPMarkupGdiPlusScaleTransform() | CXTPMarkupGdiPlusScaleTransform |
CXTPMarkupGdiPlusTransformObject() | CXTPMarkupGdiPlusTransformObject< CXTPMarkupScaleTransform > | protected
CXTPMarkupGdiPlusTransformObjectImpl() | CXTPMarkupGdiPlusTransformObjectImpl | protected
CXTPMarkupTransform() | CXTPMarkupTransform | protected
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCenterX() const | CXTPMarkupScaleTransform |
GetCenterY() const | CXTPMarkupScaleTransform |
GetScaleX() const | CXTPMarkupScaleTransform |
GetScaleY() const | CXTPMarkupScaleTransform |
m_pPropertyCenterX | CXTPMarkupScaleTransform | static
m_pPropertyCenterY | CXTPMarkupScaleTransform | static
m_pPropertyScaleX | CXTPMarkupScaleTransform | static
m_pPropertyScaleY | CXTPMarkupScaleTransform | static
SetCenterX(double centerX) | CXTPMarkupScaleTransform |
SetCenterY(double centerY) | CXTPMarkupScaleTransform |
SetScaleX(double scaleX) | CXTPMarkupScaleTransform |
SetScaleY(double scaleY) | CXTPMarkupScaleTransform |
TransformMatrix(const CXTPGdiPlus *pReserved, GpMatrix *pMatrix) | CXTPMarkupGdiPlusScaleTransform | virtual
~CXTPMarkupGdiPlusTransformObjectImpl() | CXTPMarkupGdiPlusTransformObjectImpl | inlineprotectedvirtual


Toolkit Pro: XTPGridThemeExplorer.h Source File

  • Source
  • GridControl
  • Themes
XTPGridThemeExplorer.h
Go to the documentation of this file.
1
23#if !defined(__XTPGridThemeExplorer_H__)
24# define __XTPGridThemeExplorer_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPGridThemeExplorer : public CXTPGridPaintManager
39{
40public:
45 CXTPGridThemeExplorer();
46
78 virtual void DrawTriangle(CDC* pDC, CRect rcTriangle, BOOL bToDown, int nShadowWidth = 0);
79
80 using CXTPGridPaintManager::DrawTriangle;
81
91 virtual CSize DrawGlyph(CDC* pDC, CRect rcColumn, int iImage);
92
104 virtual BOOL IsColumHotTrackingEnabled() const;
105
117 virtual void DrawColumnBackground(CDC* pDC, CXTPGridColumn* pColumn, CRect rcColumn,
118 BOOL& bColumnPressed, BOOL& bDraggingFromHeader,
119 CXTPGridHeader* pHeader = NULL);
120
133 void DrawSectionDivider(CDC* pDC, const CRect& rc,
134 XTPGridSectionDividerPosition dividerPosition,
135 XTPGridSectionDividerStyle dividerStyle,
136 CXTPPaintManagerColor dividerColor);
137};
139# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
140#endif //#if !defined(__XTPGridThemeExplorer_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPGridSectionDividerPosition
XTPGridSectionDividerPosition
Section divider position.
Definition XTPGridDefines.h:258
XTPGridSectionDividerStyle
XTPGridSectionDividerStyle
Represent the header/footer rows divider style.
Definition XTPGridDefines.h:227
CXTPGridColumn
Represents a grid column item with its properties and operations.
Definition XTPGridColumn.h:107
CXTPGridHeader
A grid header is a part of the grid window positioned above columns of text or numbers.
Definition XTPGridHeader.h:173
CXTPGridPaintManager
Utility class that handles most drawing activities.
Definition XTPGridPaintManager.h:76
CXTPGridPaintManager::DrawTriangle
virtual void DrawTriangle(CDC *pDC, CRect rcTriangle, BOOL bToDown, BOOL bDraggingFromHeader, int nShadowWidth, BOOL bColumnPressed)
Draws a triangle that shows the sort order of the column.
CXTPGridThemeExplorer
CXTPGridThemeExplorer is a CXTPGridPaintManager derived class that represents an Explorer style theme...
Definition XTPGridThemeExplorer.h:39
CXTPGridThemeExplorer::DrawTriangle
virtual void DrawTriangle(CDC *pDC, CRect rcTriangle, BOOL bToDown, int nShadowWidth=0)
Draws a triangle that shows the sort order of the column.
CXTPGridThemeExplorer::DrawSectionDivider
void DrawSectionDivider(CDC *pDC, const CRect &rc, XTPGridSectionDividerPosition dividerPosition, XTPGridSectionDividerStyle dividerStyle, CXTPPaintManagerColor dividerColor)
Draws the divider between grid sections (e.g.
CXTPGridThemeExplorer::DrawColumnBackground
virtual void DrawColumnBackground(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, BOOL &bColumnPressed, BOOL &bDraggingFromHeader, CXTPGridHeader *pHeader=NULL)
This method is called to draw the background of a column using the current column style.
CXTPGridThemeExplorer::IsColumHotTrackingEnabled
virtual BOOL IsColumHotTrackingEnabled() const
Determines if hot tracking is enabled for the current column style.
CXTPGridThemeExplorer::CXTPGridThemeExplorer
CXTPGridThemeExplorer()
Default paint manager constructor, handles properties initialization.
CXTPGridThemeExplorer::DrawGlyph
virtual CSize DrawGlyph(CDC *pDC, CRect rcColumn, int iImage)
Draws the standard glyphs of the Grid control.
CXTPPaintManagerColor
The CXTPPaintManagerColor class is used to manage COLORREF values for determining default and applica...
Definition XTPColorManager.h:117


Toolkit Pro: Member List

CXTPChart3dPyramidDeviceCommandEvents Member List

This is the complete list of members for CXTPChart3dPyramidDeviceCommandEvents, including all inherited members.

CXTPChart3dPyramidDeviceCommandEvents() | CXTPChart3dPyramidDeviceCommandEvents | protected
CXTPChartDeviceCommandEvents() | CXTPChartDeviceCommandEvents | protected
OnAfterExecute(CXTPChartDeviceCommand *pCommand, CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommandEvents | virtual
OnBeforeExecute(CXTPChartDeviceCommand *pCommand, CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommandEvents | virtual
OnSetConnectorPoints(CXTPChartDeviceCommand *pCommand, CXTPPoint3d ptShapeCenter, CXTPPoint3d ptOuterCenter) | CXTPChart3dPyramidDeviceCommandEvents | virtual
OnUnsubscribe(CXTPChartDeviceCommand *pCommand) | CXTPChartDeviceCommandEvents |
OnUpdateBounds(CXTPChartDeviceCommand *pCommand, CRect rcBounds) | CXTPChartDeviceCommandEvents | virtual


Toolkit Pro: Member List

CXTPApplication Member List

This is the complete list of members for CXTPApplication, including all inherited members.

CXTPObservable() | CXTPObservable< CXTPApplication, IXTPApplicationEvents > | protected
GetAccessCriticalSection() const | CXTPSynchronized | inline
GetAmbientProperty(XTPApplicationAmbientProperty nProperty) const | CXTPApplication |
GetAppThreadId() const | CXTPApplication |
GetComInitFlags() const | CXTPApplication |
GetModuleState() | CXTPApplication |
IsReady() const | CXTPApplication |
Notify(void(IXTPApplicationEvents::*method)(CXTPApplication *)) | CXTPObservable< CXTPApplication, IXTPApplicationEvents > | inline
Notify(void(IXTPApplicationEvents::*method)(CXTPApplication *, A1), A1 arg1) | CXTPObservable< CXTPApplication, IXTPApplicationEvents > | inline
Notify(void(IXTPApplicationEvents::*method)(CXTPApplication *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPApplication, IXTPApplicationEvents > | inline
Notify(void(IXTPApplicationEvents::*method)(CXTPApplication *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPApplication, IXTPApplicationEvents > | inline
NotifyDynamic(void(T::*method)(O *)) | CXTPObservable< CXTPApplication, IXTPApplicationEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1), A1 arg1) | CXTPObservable< CXTPApplication, IXTPApplicationEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPApplication, IXTPApplicationEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPApplication, IXTPApplicationEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *)) | CXTPObservable< CXTPApplication, IXTPApplicationEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1), A1 arg1) | CXTPObservable< CXTPApplication, IXTPApplicationEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPApplication, IXTPApplicationEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPApplication, IXTPApplicationEvents > | inline
NotifyReversed(void(IXTPApplicationEvents::*method)(CXTPApplication *)) | CXTPObservable< CXTPApplication, IXTPApplicationEvents > | inline
NotifyReversed(void(IXTPApplicationEvents::*method)(CXTPApplication *, A1), A1 arg1) | CXTPObservable< CXTPApplication, IXTPApplicationEvents > | inline
NotifyReversed(void(IXTPApplicationEvents::*method)(CXTPApplication *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPApplication, IXTPApplicationEvents > | inline
NotifyReversed(void(IXTPApplicationEvents::*method)(CXTPApplication *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPApplication, IXTPApplicationEvents > | inline
SetAmbientProperty(XTPApplicationAmbientProperty nProperty, COleVariant vtValue) | CXTPApplication |
Subscribe(IXTPApplicationEvents *pObserver, CXTPSubscriptionList< CXTPApplication, IXTPApplicationEvents > *pSubcriptionList=NULL) | CXTPObservable< CXTPApplication, IXTPApplicationEvents > |
TriggerAmbientPropertyUpdate(XTPApplicationAmbientProperty nProperty) | CXTPApplication |
Unsubscribe(IXTPApplicationEvents *pObserver) | CXTPObservable< CXTPApplication, IXTPApplicationEvents > |
XTPGetApplication() | CXTPApplication | friend
XTPInitialize(int xtpComInit=xtpComInitAppDefault) | CXTPApplication | friend
XTPShutdown() | CXTPApplication | friend
~CXTPObservable() | CXTPObservable< CXTPApplication, IXTPApplicationEvents > | protected


Toolkit Pro: Member List

CXTPPropertyGridInplaceButtons Member List

This is the complete list of members for CXTPPropertyGridInplaceButtons, including all inherited members.

AddButton(CXTPPropertyGridInplaceButton *pButton) | CXTPPropertyGridInplaceButtons |
AddComboButton() | CXTPPropertyGridInplaceButtons |
AddExpandButton() | CXTPPropertyGridInplaceButtons |
CXTPCmdTarget() | CXTPCmdTarget |
CXTPPropertyGridInplaceButtons(CXTPPropertyGridItem *pItem) | CXTPPropertyGridInplaceButtons |
Find(UINT nID) const | CXTPPropertyGridInplaceButtons |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAt(int nIndex) const | CXTPPropertyGridInplaceButtons |
GetCount() const | CXTPPropertyGridInplaceButtons |
HitTest(CPoint point) const | CXTPPropertyGridInplaceButtons |
OnButtonRemoved(CXTPPropertyGridInplaceButton *pButton) | CXTPPropertyGridInplaceButtons | protectedvirtual
Remove(CXTPPropertyGridInplaceButton *pButton) | CXTPPropertyGridInplaceButtons |
Remove(UINT nID) | CXTPPropertyGridInplaceButtons |
RemoveAll() | CXTPPropertyGridInplaceButtons |
RemoveAt(long nIndex) | CXTPPropertyGridInplaceButtons |
~CXTPPropertyGridInplaceButtons() | CXTPPropertyGridInplaceButtons |


Toolkit Pro: Member List

CXTPTipWindow Member List

This is the complete list of members for CXTPTipWindow, including all inherited members.

Create(CWnd *pParentWnd) | CXTPTipWindow | virtual
CreateShadow() | CXTPTipWindow | protected
CXTPTipWindow() | CXTPTipWindow |
DrawShadowRect(CDC *pDC, const CRect &rect) | CXTPTipWindow | protected
ForwardMessage(UINT uiMsg, UINT nFlags, CPoint point) | CXTPTipWindow | protected
HideTipWindow() | CXTPTipWindow |
InitializeSize(const CPoint &point, BOOL bCenterHorz=FALSE) | CXTPTipWindow | protectedvirtual
m_arStrings | CXTPTipWindow | protected
m_bCenterHorz | CXTPTipWindow | protected
m_bDelayTimerRunning | CXTPTipWindow | protected
m_crBackColor | CXTPTipWindow | protected
m_crTextColor | CXTPTipWindow | protected
m_dwTipStyle | CXTPTipWindow | protected
m_nDelayTimerEventID | CXTPTipWindow | protected
m_nElapseTimerEventID | CXTPTipWindow | protected
m_nLineSpace | CXTPTipWindow | protected
m_nTabPositions | CXTPTipWindow | protected
m_pnTabStopPositions | CXTPTipWindow | protected
m_pointTipOffsetPos | CXTPTipWindow | protected
m_pParentWnd | CXTPTipWindow | protected
m_ptMousePos | CXTPTipWindow | protected
m_rcScreenWindow | CXTPTipWindow | protected
m_rcShadow | CXTPTipWindow | protected
m_rcWindow | CXTPTipWindow | protected
m_rectTipArea | CXTPTipWindow | protected
m_sizeMargin | CXTPTipWindow | protected
m_sizeTitle | CXTPTipWindow | protected
m_strDescrip | CXTPTipWindow | protected
m_strTitle | CXTPTipWindow | protected
SetLineSpace(int nLineSpace) | CXTPTipWindow |
SetMargins(CSize size) | CXTPTipWindow |
SetTextTabStopPositions(LPINT pnTabStopPositions, int nTabPositions) | CXTPTipWindow |
SetTipColors(COLORREF crBackColor, COLORREF crTextColor, BOOL bRedraw=FALSE) | CXTPTipWindow |
SetTipOffsetPos(CPoint pointOffset) | CXTPTipWindow |
SetTipText(LPCTSTR lpszTitle, LPCTSTR lpszDescrip, BOOL bRedraw=FALSE) | CXTPTipWindow |
ShowTipWindow(const CPoint &point, DWORD dwTipStyle=TWS_XTP_DROPSHADOW, UINT nDelay=0, UINT nElapse=5000, BOOL bCenterHorz=FALSE) | CXTPTipWindow | virtual
ShowTipWindow(const CRect &rectCtrl, const CPoint &pointMousePos, DWORD dwTipStyle=TWS_XTP_DROPSHADOW, UINT nDelay=0, UINT nElapse=5000, BOOL bCenterHorz=FALSE, BOOL bShowTipAtCursorPos=FALSE) | CXTPTipWindow | virtual
~CXTPTipWindow() | CXTPTipWindow | virtual


Toolkit Pro: Member List

CXTPChartBarSeriesErrorBarView Member List

This is the complete list of members for CXTPChartBarSeriesErrorBarView, including all inherited members.

AddChildView(CXTPChartElementView *pChildView) | CXTPChartElementView |
CXTPChartBarSeriesErrorBarView(CXTPChartErrorBar *pErrorBar, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView) | CXTPChartBarSeriesErrorBarView |
CXTPChartElementView(CXTPChartElementView *pParentView) | CXTPChartElementView |
CXTPChartElementView(CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartElementView |
CXTPChartElementView(CXTPChartContainer *pContainer) | CXTPChartElementView |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
GetAt(int nIndex) const | CXTPChartElementView |
GetBounds() const | CXTPChartElementView |
GetBounds(BOOL bIncludingChildren) const | CXTPChartElementView |
GetChildren() | CXTPChartElementView |
GetCount() const | CXTPChartElementView |
GetParentView() const | CXTPChartElementView |
Is3D() const | CXTPChartObject |
m_arrChildren | CXTPChartElementView | protected
m_pContainer | CXTPChartElementView | protected
m_pParentView | CXTPChartElementView | protected
m_rcBounds | CXTPChartElementView | protected
~CXTPChartElementView() | CXTPChartElementView | protectedvirtual


Toolkit Pro: XTPMarkupToggleButton.h Source File

  • Source
  • Markup
  • Controls
XTPMarkupToggleButton.h
Go to the documentation of this file.
1
23#if !defined(__XTPMARKUPTOGGLEBUTTON_H__)
24# define __XTPMARKUPTOGGLEBUTTON_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPMarkupDependencyProperty;
34class CXTPMarkupRoutedEvent;
35class CXTPMarkupObject;
36class CXTPMarkupBuilder;
37class CXTPMarkupRoutedEventArgs;
38
44class _XTP_EXT_CLASS CXTPMarkupToggleButton : public CXTPMarkupButtonBase
45{
47 DECLARE_MARKUPCLASS(CXTPMarkupToggleButton);
49public:
55 void SetChecked(BOOL bChecked);
56
63 BOOL GetChecked() const;
64
71 void SetThreeState(BOOL bThreeState);
72
80 BOOL IsThreeState() const;
81
82protected:
87 virtual void OnClick();
88
93 virtual void OnToggle();
94
100 virtual void OnChecked(CXTPMarkupRoutedEventArgs* e);
101
107 virtual void OnUnchecked(CXTPMarkupRoutedEventArgs* e);
108
114 virtual void OnIndeterminate(CXTPMarkupRoutedEventArgs* e);
115
117 // Implementation
118protected:
119 static void AFX_CDECL OnIsCheckedChanged(CXTPMarkupObject* d,
120 CXTPMarkupPropertyChangedEventArgs* e);
121 static CXTPMarkupObject* AFX_CDECL
122 ConvertIsChecked(CXTPMarkupBuilder* pBuilder, CXTPMarkupObject* pObject,
123 CXTPMarkupDependencyProperty* pAssociatedProperty = NULL);
124
125public:
126 static CXTPMarkupDependencyProperty* m_pIsThreeStateProperty;
127 static CXTPMarkupDependencyProperty* m_pIsCheckedProperty;
128 static CXTPMarkupRoutedEvent* m_pCheckedEvent;
129 static CXTPMarkupRoutedEvent* m_pUncheckedEvent;
130 static CXTPMarkupRoutedEvent* m_pIndeterminateEvent;
134public:
135 DECLARE_DISPATCH_MAP()
136# ifdef _XTP_ACTIVEX
137 DECLARE_INTERFACE_MAP()
138 DECLARE_OLETYPELIB_EX(CXTPMarkupToggleButton);
139# endif
140
141 afx_msg long OleGetIsChecked();
142 afx_msg void OleSetIsChecked(long bValue);
143
144 afx_msg BOOL OleGetIsThreeState();
145 afx_msg void OleSetIsThreeState(BOOL bValue);
146
147 afx_msg LPDISPATCH OleGetCheckedEvent();
148 afx_msg LPDISPATCH OleGetIndeterminateEvent();
149 afx_msg LPDISPATCH OleGetUncheckedEvent();
150
152};
153
154# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
156#endif // !defined(__XTPMARKUPTOGGLEBUTTON_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPMarkupButtonBase
CXTPMarkupButtonBase is a CXTPMarkupContentControl derived class.
Definition XTPMarkupButtonBase.h:46
CXTPMarkupToggleButton
CXTPMarkupToggleButton is a CXTPMarkupButtonBase derived class.
Definition XTPMarkupToggleButton.h:45
CXTPMarkupToggleButton::GetChecked
BOOL GetChecked() const
Determines the checked state of a button.
CXTPMarkupToggleButton::OnIndeterminate
virtual void OnIndeterminate(CXTPMarkupRoutedEventArgs *e)
Virtual method called when the user sets the state to indeterminate.
CXTPMarkupToggleButton::OnUnchecked
virtual void OnUnchecked(CXTPMarkupRoutedEventArgs *e)
Virtual method called when the user sets the state to unchecked.
CXTPMarkupToggleButton::SetThreeState
void SetThreeState(BOOL bThreeState)
Specifies if the button supports two or three states.
CXTPMarkupToggleButton::OnClick
virtual void OnClick()
Virtual method called when the user clicks the button.
CXTPMarkupToggleButton::SetChecked
void SetChecked(BOOL bChecked)
Call this method to set the checked state for a button.
CXTPMarkupToggleButton::OnChecked
virtual void OnChecked(CXTPMarkupRoutedEventArgs *e)
Virtual method called when the user sets the state to checked.
CXTPMarkupToggleButton::IsThreeState
BOOL IsThreeState() const
Determines if the button supports two or three states.
CXTPMarkupToggleButton::OnToggle
virtual void OnToggle()
Virtual method called when the state is toggled by the user.


Toolkit Pro: XTPSingleton.h Source File

  • Source
  • Common
XTPSingleton.h
Go to the documentation of this file.
1
23#if !defined(__XTPSINGLETON_H__)
24# define __XTPSINGLETON_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33# ifndef __XTPSYSTEMHELPERS_H__
34class CXTPDummySingletonDependency;
35
36template<
37 class Singleton1 = CXTPDummySingletonDependency,
38 class Singleton2 = CXTPDummySingletonDependency, class Singleton3 = CXTPDummySingletonDependency,
39 class Singleton4 = CXTPDummySingletonDependency, class Singleton5 = CXTPDummySingletonDependency,
40 class Singleton6 = CXTPDummySingletonDependency, class Singleton7 = CXTPDummySingletonDependency,
41 class Singleton8 = CXTPDummySingletonDependency, class Singleton9 = CXTPDummySingletonDependency,
42 class Singleton10 = CXTPDummySingletonDependency>
43class CXTPSingletonDependencies;
44
45template<class T, class Dependencies = CXTPSingletonDependencies<> >
46class CXTPSingleton;
47# endif /*__XTPSYSTEMHELPERS_H__*/
48
55class _XTP_EXT_CLASS CXTPSingletonPointer : IXTPApplicationEvents
56{
57public:
61 typedef BOOL(AFX_CDECL* Creator)(void*);
62
66 typedef void(AFX_CDECL* Destroyer)(void*);
67
71 typedef void(AFX_CDECL* Initializer)();
72
81 CXTPSingletonPointer(SIZE_T cbObjectSize, Creator pfnCreator, Destroyer pfnDestroyer,
82 Initializer pfnInitializer = NULL);
83
88 virtual ~CXTPSingletonPointer();
89
99 void* GetInstance();
100
106 void Destroy();
107
114 ::CRITICAL_SECTION& GetAccess() const
115 {
116 return m_access;
117 }
118
119private:
120 virtual void OnApplicationShutdown(CXTPApplication* pApplication);
121
122private:
123 void* m_pInstance;
124 mutable ::CRITICAL_SECTION m_access;
125 const SIZE_T m_cbObjectSize;
126 const Creator m_pfnCreator;
127 const Destroyer m_pfnDestroyer;
128 BOOL m_bDestroyed;
129};
130
133class CXTPDummySingletonDependency
134{
135};
136
137template<class Singleton>
138AFX_INLINE void XTPInitSingletonInstance(Singleton*)
139{
140 Singleton::Instance();
141}
142
143AFX_INLINE void XTPInitSingletonInstance(CXTPDummySingletonDependency*)
144{
145 // Do nothing.
146}
147
168template<class Singleton1 /*= CXTPDummySingletonDependency*/,
169 class Singleton2 /*= CXTPDummySingletonDependency*/,
170 class Singleton3 /*= CXTPDummySingletonDependency*/,
171 class Singleton4 /*= CXTPDummySingletonDependency*/,
172 class Singleton5 /*= CXTPDummySingletonDependency*/,
173 class Singleton6 /*= CXTPDummySingletonDependency*/,
174 class Singleton7 /*= CXTPDummySingletonDependency*/,
175 class Singleton8 /*= CXTPDummySingletonDependency*/,
176 class Singleton9 /*= CXTPDummySingletonDependency*/,
177 class Singleton10 /*= CXTPDummySingletonDependency*/>
178class CXTPSingletonDependencies
179{
180public:
182 static void AFX_CDECL InitDependencies()
183 {
184 // Template overloading approach doesn't work in VC6,
185 // that's why function overloading with dummy pointers is used.
186 XTPInitSingletonInstance(reinterpret_cast<Singleton1*>(NULL));
187 XTPInitSingletonInstance(reinterpret_cast<Singleton2*>(NULL));
188 XTPInitSingletonInstance(reinterpret_cast<Singleton3*>(NULL));
189 XTPInitSingletonInstance(reinterpret_cast<Singleton4*>(NULL));
190 XTPInitSingletonInstance(reinterpret_cast<Singleton5*>(NULL));
191 XTPInitSingletonInstance(reinterpret_cast<Singleton6*>(NULL));
192 XTPInitSingletonInstance(reinterpret_cast<Singleton7*>(NULL));
193 XTPInitSingletonInstance(reinterpret_cast<Singleton8*>(NULL));
194 XTPInitSingletonInstance(reinterpret_cast<Singleton9*>(NULL));
195 XTPInitSingletonInstance(reinterpret_cast<Singleton10*>(NULL));
196 }
198};
199
213template<class T, class Dependencies /*= CXTPSingletonDependencies<>*/>
214class CXTPSingleton
215{
216public:
224 static T& AFX_CDECL Instance()
225 {
226 void* pInstance = InstancePointer().GetInstance();
227 return *reinterpret_cast<T*>(pInstance);
228 }
229
230private:
231 static BOOL AFX_CDECL Create(void* ptr)
232 {
233 new (ptr) T();
234 return TRUE;
235 }
236
237 static void AFX_CDECL Destroy(void* ptr)
238 {
239 reinterpret_cast<T*>(ptr)->T::~T();
240 }
241
242protected:
245 CXTPSingleton()
246 {
247 }
248
249 static ::CRITICAL_SECTION& AFX_CDECL GetInstanceAccess()
250 {
251 return InstancePointer().GetAccess();
252 }
253
254 static CXTPSingletonPointer& AFX_CDECL InstancePointer()
255 {
256 static CXTPSingletonPointer instanceHolder(sizeof(T), Create, Destroy,
257 Dependencies::InitDependencies);
258 return instanceHolder;
259 }
260
262};
263
265template<class Parent>
266class CXTPDerive : public Parent
267{
268};
269template<>
270class CXTPDerive<void>
271{
272};
283template<class Derived, class Parent>
284class CXTPSingletonBase
285 : public CXTPDerive<Parent>
286 , public CXTPSingleton<Derived>
287{
288protected:
293 CXTPSingletonBase()
294 {
295 }
296};
297
298template<class ValueType, class Tag>
299struct XTPSingletonValueAdaptor
300{
301 ValueType Value;
302};
303
304# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
306#endif /*__XTPSINGLETON_H__*/
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPApplication
Defines a global XTP application object interface.
Definition XTPApplication.h:151
CXTPSingletonBase
Implements Singleton design pattern for a derived class with possibility of providing a parent class.
Definition XTPSingleton.h:287
CXTPSingletonBase::CXTPSingletonBase
CXTPSingletonBase()
Handles object construction.
Definition XTPSingleton.h:293
CXTPSingletonDependencies
Describes the list of up to 10 optional singleton dependencies.
Definition XTPSingleton.h:179
CXTPSingleton
Implements Singleton design pattern.
Definition XTPSingleton.h:215
CXTPSingleton::Instance
static T &AFX_CDECL Instance()
Obtains encapsulated singleton instance reference.
Definition XTPSingleton.h:224
CXTPSingletonPointer
Implements Singleton design pattern for a pointer of unspecified type that is to be allocated,...
Definition XTPSingleton.h:56
CXTPSingletonPointer::Destroy
void Destroy()
Destroys a previously created and allocated instance and invalidate the instance pointer.
CXTPSingletonPointer::GetAccess
::CRITICAL_SECTION & GetAccess() const
Obtains reference to singleton access critical secton.
Definition XTPSingleton.h:114
CXTPSingletonPointer::~CXTPSingletonPointer
virtual ~CXTPSingletonPointer()
Handles object destruction.
CXTPSingletonPointer::GetInstance
void * GetInstance()
Obtains encapsulated singleton instance pointer.
CXTPSingletonPointer::CXTPSingletonPointer
CXTPSingletonPointer(SIZE_T cbObjectSize, Creator pfnCreator, Destroyer pfnDestroyer, Initializer pfnInitializer=NULL)
Handles object construction.
IXTPApplicationEvents
Defines a callback interface for XTP application event sink.
Definition XTPApplication.h:82
IXTPApplicationEvents::OnApplicationShutdown
virtual void OnApplicationShutdown(CXTPApplication *pApplication)
Is called by framework when application is being shutdown before the actual shutting down.
Definition XTPApplication.h:107


Toolkit Pro: Member List

CXTPChartRadarAxisView Member List

This is the complete list of members for CXTPChartRadarAxisView, including all inherited members.

AddChildView(CXTPChartElementView *pChildView) | CXTPChartElementView |
CreateDeviceCommand(CXTPChartDeviceContext *pDC) | CXTPChartElementView | virtual
CXTPChartElementView(CXTPChartElementView *pParentView) | CXTPChartElementView |
CXTPChartElementView(CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartElementView |
CXTPChartElementView(CXTPChartContainer *pContainer) | CXTPChartElementView |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartRadarAxisView(CXTPChartAxis *pAxis, CXTPChartElementView *pParentView) | CXTPChartRadarAxisView |
GetAt(int nIndex) const | CXTPChartElementView |
GetBounds() const | CXTPChartElementView |
GetBounds(BOOL bIncludingChildren) const | CXTPChartElementView |
GetChildren() | CXTPChartElementView |
GetCount() const | CXTPChartElementView |
GetParentView() const | CXTPChartElementView |
Is3D() const | CXTPChartObject |
m_arrChildren | CXTPChartElementView | protected
m_pContainer | CXTPChartElementView | protected
m_pParentView | CXTPChartElementView | protected
m_rcBounds | CXTPChartElementView | protected
~CXTPChartElementView() | CXTPChartElementView | protectedvirtual
~CXTPChartRadarAxisView() | CXTPChartRadarAxisView |


Toolkit Pro: Member List

CXTPDockingPaneTabbedContainer Member List

This is the complete list of members for CXTPDockingPaneTabbedContainer, including all inherited members.

AddItem(int nItem, CXTPTabManagerItem *pItem=NULL) | CXTPTabManager | protected
CanAttach(CRect &rcClient, CPoint pt) const | CXTPDockingPaneTabbedContainer | virtual
Clone(CXTPDockingPaneLayout *pLayout, CXTPPaneToPaneMap *pMap, DWORD dwIgnoredOptions=0) | CXTPDockingPaneBase | protectedvirtual
ContainPane(CXTPDockingPaneBase *pPane) const | CXTPDockingPaneBaseContainer | virtual
Copy(CXTPDockingPaneBase *pClone, CXTPPaneToPaneMap *pMap, DWORD dwIgnoredOptions) | CXTPDockingPaneTabbedContainer | protectedvirtual
CreateContainer() | CXTPDockingPaneTabbedContainer | protectedvirtual
CXTPDockingPaneBase(XTPDockingPaneType type, CXTPDockingPaneLayout *pLayout) | CXTPDockingPaneBase | protected
CXTPDockingPaneBaseContainer(XTPDockingPaneType type, CXTPDockingPaneLayout *pLayout) | CXTPDockingPaneBaseContainer | protected
CXTPDockingPaneTabbedContainer(CXTPDockingPaneLayout *pLayout) | CXTPDockingPaneTabbedContainer | protected
CXTPTabManager() | CXTPTabManager |
DeleteAllItems() | CXTPTabManager |
DeleteItem(int nItem) | CXTPTabManager |
DeletePane()=0 | CXTPDockingPaneBase | protectedpure virtual
DoPropExchange(CXTPPropExchange *pPX) | CXTPDockingPaneTabbedContainer | protectedvirtual
DrawIcon(CDC *pDC, CPoint pt, CXTPTabManagerItem *pItem, BOOL bDraw, CSize &szIcon) const | CXTPDockingPaneTabbedContainer | protectedvirtual
DrawParentBackground(CDC *pDC, CRect rc) | CXTPTabManager | virtual
EnableMarkup(BOOL bEnable=TRUE) | CXTPTabManager |
EnableTabThemeTexture(HWND hWnd, BOOL bEnable=TRUE) | CXTPTabManager |
EnsureVisible(CXTPTabManagerItem *pItem) | CXTPTabManager |
FindCaptionButton(int nID) const | CXTPDockingPaneBase |
FindNavigateButton(UINT nID) const | CXTPTabManager |
FindNextFocusable(int nIndex, int nDirection) const | CXTPTabManager |
FindPane(XTPDockingPaneType type, CXTPDockingPaneBaseList *pList) const | CXTPDockingPaneBaseContainer | virtual
GetAppearance() const | CXTPTabManager |
GetAppearanceSet() const | CXTPTabManager |
GetCaptionButtons() const | CXTPDockingPaneBase |
GetClientRect() const | CXTPTabManager |
GetCloseButton() const | CXTPDockingPaneTabbedContainer |
GetColor() const | CXTPTabManager |
GetColorSet() const | CXTPTabManager |
GetContainer() const | CXTPDockingPaneBase |
GetControlRect() const | CXTPTabManager |
GetCurSel() const | CXTPTabManager |
GetDockingPaneManager() const | CXTPDockingPaneBase |
GetDockingSite() const | CXTPDockingPaneBase | virtual
GetFirstPane() const | CXTPDockingPaneBaseContainer |
GetHeaderOffset() const | CXTPTabManager |
GetHeaderRect() const | CXTPTabManager |
GetHeadPosition() const | CXTPDockingPaneBaseContainer |
GetItem(int nIndex) const | CXTPTabManager |
GetItemCaption(const CXTPTabManagerItem *pItem) const | CXTPTabManager | virtual
GetItemColor(const CXTPTabManagerItem *pItem) const | CXTPTabManager | virtual
GetItemCount() const | CXTPTabManager |
GetItemIcon(const CXTPTabManagerItem *pItem) const | CXTPTabManager | virtual
GetItemMetrics(CSize *szNormal, CSize *szMin=NULL, CSize *szMax=NULL) const | CXTPTabManager | virtual
GetItemPane(int nIndex) const | CXTPDockingPaneTabbedContainer |
GetItemsLength() const | CXTPTabManager | virtual
GetItemTooltip(const CXTPTabManagerItem *pItem) const | CXTPTabManager | virtual
GetLastPane() const | CXTPDockingPaneBaseContainer |
GetLayout() const | CXTPTabManager |
GetMarkupContext() const | CXTPTabManager | virtual
GetMinMaxInfo(LPMINMAXINFO pMinMaxInfo) const | CXTPDockingPaneTabbedContainer | virtual
GetNavigateButton(int nIndex) const | CXTPTabManager |
GetNavigateButtonCount() const | CXTPTabManager |
GetNavigateButtons() | CXTPTabManager |
GetNext(POSITION &pos) const | CXTPDockingPaneBaseContainer |
GetPaintManager() const | CXTPDockingPaneTabbedContainer | protectedvirtual
GetPaneHwnd() const | CXTPDockingPaneTabbedContainer | virtual
GetPanes() | CXTPDockingPaneBaseContainer |
GetPaneTab(CXTPDockingPane *pPane) const | CXTPDockingPaneTabbedContainer |
GetPaneWindowRect() const | CXTPDockingPaneBase |
GetPinButton() const | CXTPDockingPaneTabbedContainer |
GetPosition() const | CXTPTabManager | virtual
GetRectLength(CRect rc) const | CXTPTabManager |
GetRowCount() const | CXTPTabManager |
GetSelected() const | CXTPDockingPaneTabbedContainer |
GetSelectedItem() const | CXTPTabManager |
GetTitle() const | CXTPDockingPaneTabbedContainer | virtual
GetType() const | CXTPDockingPaneBase |
HeaderHasFocus() const | CXTPTabManager | protectedvirtual
HitTest(CPoint point) const | CXTPTabManager |
HitTestNavigateButton(CPoint point, BOOL bHeaderOnly, int *pnIndex=NULL) const | CXTPTabManager |
Init(CXTPDockingPane *pPane, CWnd *pFrame) | CXTPDockingPaneTabbedContainer | protected
InvalidatePane(BOOL bSelectionChanged) | CXTPDockingPaneBase | virtual
IsActive() const | CXTPDockingPaneTabbedContainer | virtual
IsAllowReorder() const | CXTPTabManager | virtual
IsCaptionButtonVisible(CXTPDockingPaneCaptionButton *pButton) | CXTPDockingPaneTabbedContainer | protectedvirtual
IsCaptionVertical() const | CXTPDockingPaneTabbedContainer | virtual
IsDrawStaticFrame() const | CXTPTabManager | virtual
IsEmpty() const | CXTPDockingPaneBaseContainer | protectedvirtual
IsHidden() const | CXTPDockingPaneTabbedContainer | virtual
IsHorizontalPosition() const | CXTPTabManager |
IsMouseLocked() const | CXTPTabManager | protectedvirtual
IsNavigateButtonAutomaticVisible(CXTPTabManagerNavigateButton *pButton) | CXTPTabManager | protectedvirtual
IsNavigateButtonVisible(CXTPTabManagerNavigateButton *pButton) | CXTPTabManager | protectedvirtual
IsTabsVisible() const | CXTPDockingPaneTabbedContainer | virtual
IsTitleVisible() const | CXTPDockingPaneTabbedContainer |
m_arrItems | CXTPTabManager | protected
m_arrNavigateButtons | CXTPTabManager | protected
m_bActive | CXTPDockingPaneTabbedContainer | protected
m_bAllowReorder | CXTPTabManager | protected
m_bCloseItemButton | CXTPTabManager | protected
m_bDelayRedraw | CXTPDockingPaneTabbedContainer | protected
m_bEnsureSelectedTab | CXTPDockingPaneTabbedContainer | protected
m_bMaximized | CXTPDockingPaneTabbedContainer | protected
m_bTitleVisible | CXTPDockingPaneTabbedContainer | protected
m_lstPanes | CXTPDockingPaneBaseContainer | protected
m_lstRects | CXTPDockingPaneTabbedContainer | protected
m_nHeaderOffset | CXTPTabManager | protected
m_nLockReposition | CXTPDockingPaneTabbedContainer | protected
m_nScrollDelta | CXTPTabManager | protected
m_pCaptionButtons | CXTPDockingPaneBase | protected
m_pDockingSite | CXTPDockingPaneBase | protected
m_pDropTarget | CXTPDockingPaneTabbedContainer | protected
m_pHighlighted | CXTPTabManager | protected
m_pHighlightedNavigateButton | CXTPTabManager | protected
m_pLayout | CXTPDockingPaneBase | protected
m_pMarkupContext | CXTPTabManager | protected
m_pParentContainer | CXTPDockingPaneBase | protected
m_pPressed | CXTPTabManager | protected
m_pRowIndexer | CXTPTabManager | protected
m_pSelected | CXTPTabManager | protected
m_pSelectedPane | CXTPDockingPaneTabbedContainer | protected
m_pTrackingPane | CXTPDockingPaneTabbedContainer | protected
m_rcControl | CXTPTabManager | protected
m_rcHeaderRect | CXTPTabManager | protected
m_rcWindow | CXTPDockingPaneBase | protected
m_szDocking | CXTPDockingPaneBase | protected
m_type | CXTPDockingPaneBase | protected
MoveItem(CXTPTabManagerItem *pItem, int nIndex) | CXTPTabManager |
OnAction(XTPDockingPaneAction action) | CXTPDockingPaneBaseContainer |
OnBeforeItemClick(CXTPTabManagerItem *pItem) | CXTPTabManager | protectedvirtual
OnCaptionButtonClick(CXTPDockingPaneCaptionButton *pButton) | CXTPDockingPaneTabbedContainer | protectedvirtual
OnCaptionButtonRectChanged(CXTPDockingPaneCaptionButton *pButton) | CXTPDockingPaneBase | protectedvirtual
OnCaptionLButtonDown(CPoint point) | CXTPDockingPaneTabbedContainer | virtual
OnChildContainerChanged(CXTPDockingPaneBase *pContainer) | CXTPDockingPaneBase | protectedvirtual
OnFocusChanged() | CXTPDockingPaneBase | protectedvirtual
OnItemClick(CXTPTabManagerItem *pItem) | CXTPTabManager | protectedvirtual
OnItemHandleChanged(CXTPTabManagerItem *pItem, HWND hwndOld, HWND hwndNew) | CXTPTabManager | protectedvirtual
OnItemOrderChanged(CXTPTabManagerItem *pItem, int nOldIndex, int nNewIndex) | CXTPTabManager | protectedvirtual
OnItemsChanged() | CXTPTabManager | virtual
OnNavigateButtonClick(CXTPTabManagerNavigateButton *pButton) | CXTPDockingPaneTabbedContainer | protectedvirtual
OnParentContainerChanged(CXTPDockingPaneBase *pContainer) | CXTPDockingPaneBase | protectedvirtual
OnPropertyChanged() | CXTPTabManagerAtom | inlinevirtual
OnScrollHeader(BOOL bRight) | CXTPTabManager | virtual
OnSizeParent(CWnd *pParent, CRect rect, LPVOID lParam) | CXTPDockingPaneBase | protectedvirtual
OnSwitchItem(CXTPTabManagerItem *pItem1, CXTPTabManagerItem *pItem2) | CXTPTabManager | protectedvirtual
OnTabsChanged() | CXTPDockingPaneTabbedContainer | protectedvirtual
PerformClick(HWND hWnd, CPoint pt, BOOL bNoItemClick=FALSE) | CXTPTabManager |
PerformKeyDown(HWND hWnd, UINT nChar) | CXTPTabManager | virtual
PerformMouseMove(HWND hWnd, CPoint pt) | CXTPTabManager |
PerformToolHitTest(HWND hWnd, CPoint point, TOOLINFO *pTI) const | CXTPTabManager | virtual
RedrawControl(LPCRECT lpRect, BOOL bAnimate) | CXTPDockingPaneTabbedContainer | protectedvirtual
RedrawPane() | CXTPDockingPaneBase | virtual
RemovePane(CXTPDockingPaneBase *pPane) | CXTPDockingPaneBase | protectedvirtual
ReOrder(HWND hWnd, CPoint pt, CXTPTabManagerItem *pItem) | CXTPTabManager | protectedvirtual
Reposition() | CXTPDockingPaneTabbedContainer | protectedvirtual
SelectPane(CXTPDockingPane *pPane, BOOL bSetFocus=TRUE, BOOL bDelayRedraw=TRUE) | CXTPDockingPaneTabbedContainer | virtual
SetActive(BOOL bActive) | CXTPTabManager |
SetAllowReorder(BOOL bAllowReorder) | CXTPTabManager | virtual
SetAppearance(XTPTabAppearanceStyle tabAppearance) | CXTPTabManager |
SetAppearanceSet(CXTPTabPaintManagerTheme *pAppearanceSet) | CXTPTabManager |
SetColor(XTPTabColorStyle tabColor) | CXTPTabManager |
SetColorSet(CXTPTabPaintManagerColorSet *pColorSet) | CXTPTabManager |
SetCurSel(int nIndex) | CXTPTabManager |
SetDockingSite(CWnd *pFrame) | CXTPDockingPaneBase | protectedvirtual
SetFocusedItem(CXTPTabManagerItem *pItem) | CXTPTabManager | virtual
SetHeaderOffset(int nOffset) | CXTPTabManager |
SetItemMetrics(CSize szNormal, CSize szMin=CSize(0, 0), CSize szMax=CSize(0, 0)) | CXTPTabManager |
SetLayoutStyle(XTPTabLayoutStyle tabLayout) | CXTPTabManager |
SetPaintManager(CXTPTabPaintManager *pPaintManager) | CXTPDockingPaneTabbedContainer | protectedvirtual
SetParentContainer(CXTPDockingPaneBase *pContainer) | CXTPDockingPaneBase | protectedvirtual
SetPosition(XTPTabPosition tabPosition) | CXTPTabManager |
SetSelectedItem(CXTPTabManagerItem *pItem) | CXTPTabManager | virtual
ShowCloseItemButton(XTPTabNavigateButtonFlags bCloseItemButton=xtpTabNavigateButtonAlways) | CXTPTabManager |
ShowIcons(BOOL bShowIcons) | CXTPTabManager |
TrackClick(HWND hWnd, CPoint pt, CXTPTabManagerItem *pItem) | CXTPTabManager | protected
~CXTPDockingPaneBase() | CXTPDockingPaneBase | protectedvirtual
~CXTPDockingPaneBaseContainer() | CXTPDockingPaneBaseContainer | protectedvirtual
~CXTPDockingPaneTabbedContainer() | CXTPDockingPaneTabbedContainer | protectedvirtual
~CXTPTabManager() | CXTPTabManager | virtual
~CXTPTabManagerAtom() | CXTPTabManagerAtom | inlineprotectedvirtual


Toolkit Pro: XTPPopupItem.h Source File

  • Source
  • Controls
  • Popup
XTPPopupItem.h
Go to the documentation of this file.
1
23#if !defined(_XTPPOPUPITEM_H__)
24# define _XTPPOPUPITEM_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPPopupControl;
34class CXTPImageManagerIcon;
35class CXTPRichRender;
36class CXTPMarkupUIElement;
37
52enum XTPPopupItemIcon
53{
54 xtpPopupItemIconNormal = 1,
55 xtpPopupItemIconSelected = 2,
56 xtpPopupItemIconPressed = 4
57};
58
63# define XTP_ID_POPUP_CLOSE -1
64
69class _XTP_EXT_CLASS CXTPPopupItem : public CXTPCmdTarget
70{
72 DECLARE_DYNCREATE(CXTPPopupItem)
74public:
83 CXTPPopupItem(LPRECT rcItem = NULL, LPCTSTR lpszCaption = NULL, COLORREF clrBack = (COLORREF)-1,
84 COLORREF clrBorder = (COLORREF)-1);
85
90 ~CXTPPopupItem();
91
92public:
98 virtual void Draw(CDC* pDC);
99
106 CRect GetRect() const;
107
114 BOOL IsButton() const;
115
121 void SetButton(BOOL bButton);
122
129 BOOL IsSelected() const;
130
137 BOOL IsPressed() const;
138
144 void SetID(int nID);
145
152 int GetID() const;
153
159 void SetCaption(LPCTSTR str);
160
167 CString GetCaption() const;
168
174 void SetRTFText(LPCTSTR str);
175
181 void SetRTFText(UINT nIDResource);
182
188 void SetMarkupText(LPCTSTR str);
189
194 void FitToContent();
195
203 void SetTextColor(COLORREF clrText, COLORREF clrHotText = (COLORREF)-1);
204
211 COLORREF GetTextColor() const;
212
219 COLORREF GetBackgroundColor() const;
220
227 COLORREF GetBorderColor() const;
228
234 void SetTextAlignment(int nAlign);
235
242 int GetTextAlignment() const;
243
249 void SetTextFont(CFont* pFntText);
250
256 void SetTextFont(PLOGFONT pLogfText);
257
264 virtual CFont* GetTextFont();
265
273 BOOL IsHyperLink() const;
274
282 BOOL IsHandCursor() const;
283
289 void SetHyperLink(BOOL bHyperLink);
290
297 void SetHandCursor(BOOL bHandCursor);
298
305 BOOL IsBold() const;
306
316 BOOL IsUnderline() const;
317
323 void SetBold(BOOL bBold);
324
333 void SetUnderline(BOOL bUnderline);
334
339 void CalculateHeight();
340
345 void CalculateWidth();
346
356 BOOL SetIcon(HICON hIcon, XTPPopupItemIcon itemIcon = xtpPopupItemIconNormal);
357
367 BOOL SetIcon(UINT nIDIcon, XTPPopupItemIcon itemIcon = xtpPopupItemIconNormal);
368
379 BOOL SetIcons(UINT nIDBitmap, COLORREF clrTransparent, int itemIcon);
380
392 BOOL SetIcons(HBITMAP hBitmap, COLORREF clrTransparent, int itemIcon,
393 BOOL bAlphaBitmap = FALSE);
394
401 CXTPImageManagerIcon* GetImage() const;
402
409 CXTPPopupControl* GetPopupControl() const;
410
415 void CenterIcon();
416
423 CPoint GetIconOffset() const;
424
433 int GetIconIndex() const;
434
442 void SetIconIndex(int nIconIndex);
443
450 CXTPMarkupUIElement* GetMarkupUIElement() const;
451
458 CXTPRichRender* GetRichRender() const;
459
460protected:
465 void RedrawControl();
466
471 virtual void OnItemInserted();
472
473protected:
474 int m_nID;
475 int m_nIndex;
476 int m_nIconIndex;
478 BOOL m_bButton;
479 BOOL m_bHyperLink;
480 BOOL m_bBold;
481 BOOL m_bUnderline;
483 UINT m_nAlign;
486 CXTPFont m_xtpFontText;
487 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CFont, m_fntText, m_xtpFontText, GetTextFontHandle);
488
489 CRect m_rcItem;
490 CPoint m_ptOffset;
492 CString m_strCaption;
493 COLORREF m_clrText;
494 COLORREF m_clrHotText;
495 COLORREF m_clrBack;
496 COLORREF m_clrBorder;
497 CXTPPopupControl* m_pControl;
499 CXTPRichRender* m_pRichRender;
500 CXTPMarkupUIElement* m_pUIElement;
502protected:
503# ifdef _XTP_ACTIVEX
505 DECLARE_DISPATCH_MAP()
506 DECLARE_INTERFACE_MAP()
507
508 DECLARE_OLETYPELIB_EX(CXTPPopupItem)
509
510 void OleSetIcons(int hBitmap, COLORREF clrTransparent, int itemIcon);
511 void OleSetIcon(int hIcon, int itemIcon);
512 LPFONTDISP OleGetFont();
513 void OleSetFont(LPFONTDISP pFontDisp);
514
515 afx_msg long OleGetLeft();
516 afx_msg void OleSetLeft(long nLeft);
517 afx_msg long OleGetTop();
518 afx_msg void OleSetTop(long nTop);
519 afx_msg long OleGetWidth();
520 afx_msg void OleSetWidth(long nWidth);
521 afx_msg long OleGetHeight();
522 afx_msg void OleSetHeight(long nHeight);
523 afx_msg BSTR OleGetCaption();
524
525 enum
526 {
527 dispidCaption = 1L,
528 };
530# endif
531 friend class CXTPPopupControl;
532 friend class CXTPPopupPaintManager;
533};
535AFX_INLINE CRect CXTPPopupItem::GetRect() const
536{
537 return m_rcItem;
538}
539AFX_INLINE BOOL CXTPPopupItem::IsButton() const
540{
541 return m_bButton;
542}
543AFX_INLINE void CXTPPopupItem::SetButton(BOOL bButton)
544{
545 m_bButton = bButton;
546}
547AFX_INLINE void CXTPPopupItem::SetID(int nID)
548{
549 m_nID = nID;
550}
551AFX_INLINE int CXTPPopupItem::GetID() const
552{
553 return m_nID;
554}
555AFX_INLINE COLORREF CXTPPopupItem::GetTextColor() const
556{
557 return IsSelected() ? ((m_clrHotText != (COLORREF)-1) ? m_clrHotText : m_clrText) : m_clrText;
558}
559AFX_INLINE int CXTPPopupItem::GetTextAlignment() const
560{
561 return XTPToInt(m_nAlign);
562}
563AFX_INLINE void CXTPPopupItem::SetTextAlignment(int nAlign)
564{
565 m_nAlign = XTPToUInt(nAlign);
566 RedrawControl();
567}
568AFX_INLINE CString CXTPPopupItem::GetCaption() const
569{
570 return m_strCaption;
571}
572AFX_INLINE void CXTPPopupItem::SetTextColor(COLORREF clrText, COLORREF clrHotText)
573{
574 m_clrText = clrText;
575 m_clrHotText = clrHotText;
576 RedrawControl();
577}
578AFX_INLINE BOOL CXTPPopupItem::IsHyperLink() const
579{
580 return m_bHyperLink;
581}
582AFX_INLINE BOOL CXTPPopupItem::IsBold() const
583{
584 return m_bBold;
585}
586AFX_INLINE BOOL CXTPPopupItem::IsUnderline() const
587{
588 return m_bUnderline;
589}
590AFX_INLINE void CXTPPopupItem::SetBold(BOOL bBold)
591{
592 m_bBold = bBold;
593 RedrawControl();
594}
595AFX_INLINE void CXTPPopupItem::SetUnderline(BOOL bUnderline)
596{
597 m_bUnderline = bUnderline;
598 RedrawControl();
599}
600AFX_INLINE void CXTPPopupItem::SetHyperLink(BOOL bHyperLink)
601{
602 m_bHyperLink = bHyperLink;
603}
604AFX_INLINE COLORREF CXTPPopupItem::GetBackgroundColor() const
605{
606 return m_clrBack;
607}
608AFX_INLINE COLORREF CXTPPopupItem::GetBorderColor() const
609{
610 return m_clrBorder;
611}
612AFX_INLINE CPoint CXTPPopupItem::GetIconOffset() const
613{
614 return m_ptOffset;
615}
616AFX_INLINE void CXTPPopupItem::SetIconIndex(int nIconIndex)
617{
618 m_nIconIndex = nIconIndex;
619 RedrawControl();
620}
621AFX_INLINE int CXTPPopupItem::GetIconIndex() const
622{
623 return m_nIconIndex == -1 ? m_nIndex : m_nIconIndex;
624}
625AFX_INLINE CXTPPopupControl* CXTPPopupItem::GetPopupControl() const
626{
627 return m_pControl;
628}
629AFX_INLINE CXTPMarkupUIElement* CXTPPopupItem::GetMarkupUIElement() const
630{
631 return m_pUIElement;
632}
633AFX_INLINE CXTPRichRender* CXTPPopupItem::GetRichRender() const
634{
635 return m_pRichRender;
636}
638# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
640#endif // !defined(_XTPPOPUPITEM_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPPopupItemIcon
XTPPopupItemIcon
Enumeration used to determine the icon type of CXTPPopupItem.
Definition XTPPopupItem.h:53
xtpPopupItemIconPressed
@ xtpPopupItemIconPressed
Pressed icon handler.
Definition XTPPopupItem.h:56
xtpPopupItemIconSelected
@ xtpPopupItemIconSelected
Selected icon handler.
Definition XTPPopupItem.h:55
xtpPopupItemIconNormal
@ xtpPopupItemIconNormal
Normal icon handler.
Definition XTPPopupItem.h:54
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPFont
Provides a convenient object oriented interface for HFONT GDI object and uses GDI handle caching.
Definition XTPGdiObjects.h:414
CXTPImageManagerIcon
Icons holder class.
Definition XTPImageManager.h:622
CXTPMarkupUIElement
Base class for XML Markup core level implementations.
Definition XTPMarkupUIElement.h:43
CXTPPopupControl
CXTPPopupControl is a class for control of a pop-up window.
Definition XTPPopupControl.h:225
CXTPPopupItem
CXTPPopupItem is a class used to manage a pop-up item object.
Definition XTPPopupItem.h:70
CXTPPopupItem::SetIcons
BOOL SetIcons(UINT nIDBitmap, COLORREF clrTransparent, int itemIcon)
Call this member function to set the normal, selected, or pressed icon from a resource bitmap picture...
CXTPPopupItem::IsBold
BOOL IsBold() const
Call this member function to get the bold state of a text item.
CXTPPopupItem::SetCaption
void SetCaption(LPCTSTR str)
Call this member function to set the text for an item.
CXTPPopupItem::m_clrBorder
COLORREF m_clrBorder
An RGB color value representing the item's border color.
Definition XTPPopupItem.h:496
CXTPPopupItem::m_ptOffset
CPoint m_ptOffset
x- and y- coordinates representing the offset for the pop-up item's icon.
Definition XTPPopupItem.h:490
CXTPPopupItem::SetIcon
BOOL SetIcon(HICON hIcon, XTPPopupItemIcon itemIcon=xtpPopupItemIconNormal)
Call this member function to set the normal, selected, or pressed icon from an icon item.
CXTPPopupItem::m_bUnderline
BOOL m_bUnderline
TRUE if the pop-up item's text is underlined on mouse over, otherwise FALSE.
Definition XTPPopupItem.h:481
CXTPPopupItem::SetBold
void SetBold(BOOL bBold)
Call this member function to set the bold state for a text item.
CXTPPopupItem::IsSelected
BOOL IsSelected() const
Call this member function to get the selected state of an item.
CXTPPopupItem::GetMarkupUIElement
CXTPMarkupUIElement * GetMarkupUIElement() const
Call this method to get the Markup element that renders the item.
CXTPPopupItem::SetUnderline
void SetUnderline(BOOL bUnderline)
Call this member function to set the underlined state of a text item.
CXTPPopupItem::m_nAlign
UINT m_nAlign
Specifies the method of formatting the text.
Definition XTPPopupItem.h:483
CXTPPopupItem::SetIconIndex
void SetIconIndex(int nIconIndex)
Call this method to set the icon index of the item.
CXTPPopupItem::SetID
void SetID(int nID)
Call this member function to set the ID number for an item.
CXTPPopupItem::GetTextAlignment
int GetTextAlignment() const
Call this member function to get the alignment style of an item's text.
CXTPPopupItem::CenterIcon
void CenterIcon()
Calculates the offset to center an icon.
CXTPPopupItem::m_bBold
BOOL m_bBold
TRUE if the pop-up item's text is bold, otherwise FALSE.
Definition XTPPopupItem.h:480
CXTPPopupItem::GetCaption
CString GetCaption() const
Call this member function to get the text of an item.
CXTPPopupItem::FitToContent
void FitToContent()
Call this method to set item size using the size of its content.
CXTPPopupItem::SetButton
void SetButton(BOOL bButton)
Call this member function to set the button state for an item.
CXTPPopupItem::RedrawControl
void RedrawControl()
Call this method to redraw the parent control.
CXTPPopupItem::SetTextAlignment
void SetTextAlignment(int nAlign)
Call this member function to set the alignment style for an item's text.
CXTPPopupItem::GetBorderColor
COLORREF GetBorderColor() const
Call this member to get the border color of an item.
CXTPPopupItem::GetTextFont
virtual CFont * GetTextFont()
Call this member function to get the font of an item's text.
CXTPPopupItem::m_nIndex
int m_nIndex
Zero-based index of the item in the parent pop-up control's item list.
Definition XTPPopupItem.h:475
CXTPPopupItem::SetRTFText
void SetRTFText(LPCTSTR str)
Call this member function to set the RichText for an item.
CXTPPopupItem::GetTextColor
COLORREF GetTextColor() const
Call this member function to get the color of an item's text.
CXTPPopupItem::GetRect
CRect GetRect() const
Call this member function to get the bounding rectangle of an item.
CXTPPopupItem::~CXTPPopupItem
~CXTPPopupItem()
Destroys a CXTPPopupItem object.
CXTPPopupItem::GetIconIndex
int GetIconIndex() const
Call this method to retrieve the icon index of the item.
CXTPPopupItem::OnItemInserted
virtual void OnItemInserted()
This method is called when an item is inserted in the control.
CXTPPopupItem::Draw
virtual void Draw(CDC *pDC)
This method is called to draw the item.
CXTPPopupItem::SetIcon
BOOL SetIcon(UINT nIDIcon, XTPPopupItemIcon itemIcon=xtpPopupItemIconNormal)
Call this member function to set the normal, selected, or pressed icon from an icon item.
CXTPPopupItem::IsPressed
BOOL IsPressed() const
Call this member function to get the pressed state of an item.
CXTPPopupItem::SetHyperLink
void SetHyperLink(BOOL bHyperLink)
Call this member function to enable hyperlink support for a text item.
CXTPPopupItem::m_pRichRender
CXTPRichRender * m_pRichRender
Richtext Render.
Definition XTPPopupItem.h:499
CXTPPopupItem::CalculateWidth
void CalculateWidth()
Call this member function to update the rectangular width of a text.
CXTPPopupItem::CXTPPopupItem
CXTPPopupItem(LPRECT rcItem=NULL, LPCTSTR lpszCaption=NULL, COLORREF clrBack=(COLORREF) -1, COLORREF clrBorder=(COLORREF) -1)
Constructs a CXTPPopupItem object.
CXTPPopupItem::SetMarkupText
void SetMarkupText(LPCTSTR str)
Call this method to set the Markup text for the item.
CXTPPopupItem::m_rcItem
CRect m_rcItem
Size and location of the pop-up item.
Definition XTPPopupItem.h:489
CXTPPopupItem::IsHandCursor
BOOL IsHandCursor() const
Call this member function to determine if the sytem hand cursor should be displayed when the mouse mo...
CXTPPopupItem::SetTextFont
void SetTextFont(CFont *pFntText)
Call this member function to set the font for an item's text.
CXTPPopupItem::SetHandCursor
void SetHandCursor(BOOL bHandCursor)
Call this member function to enable the system hand cursor displayed when the mouse moves over this i...
CXTPPopupItem::GetID
int GetID() const
Call this member function to get the ID number of an item.
CXTPPopupItem::IsButton
BOOL IsButton() const
Call this member function to get the button state of an item.
CXTPPopupItem::GetIconOffset
CPoint GetIconOffset() const
Call this method to retrieve the icon offset.
CXTPPopupItem::m_pUIElement
CXTPMarkupUIElement * m_pUIElement
Markup Element that renders the item.
Definition XTPPopupItem.h:500
CXTPPopupItem::IsHyperLink
BOOL IsHyperLink() const
Call this member function to determine if hyperlink support is enabled for a text item.
CXTPPopupItem::IsUnderline
BOOL IsUnderline() const
Call this member function to get the underlined state of a text item.
CXTPPopupItem::m_clrBack
COLORREF m_clrBack
An RGB color value representing the item's background color.
Definition XTPPopupItem.h:495
CXTPPopupItem::m_pControl
CXTPPopupControl * m_pControl
Pointer to the CXTPPopupControl object containing this item/.
Definition XTPPopupItem.h:497
CXTPPopupItem::m_nIconIndex
int m_nIconIndex
Zero-based index of the item's icon in the parent control's image list.
Definition XTPPopupItem.h:476
CXTPPopupItem::SetTextFont
void SetTextFont(PLOGFONT pLogfText)
Call this member function to set the font for an item's text.
CXTPPopupItem::GetImage
CXTPImageManagerIcon * GetImage() const
Retrieves the icon image associated with the item.
CXTPPopupItem::GetBackgroundColor
COLORREF GetBackgroundColor() const
Call this member to get the background color of an item.
CXTPPopupItem::m_clrHotText
COLORREF m_clrHotText
An RGB color value representing the item's mouse over text color.
Definition XTPPopupItem.h:494
CXTPPopupItem::m_bButton
BOOL m_bButton
TRUE if the pop-up item is a button, otherwise FALSE.
Definition XTPPopupItem.h:478
CXTPPopupItem::m_clrText
COLORREF m_clrText
An RGB color value representing the item's normal text color.
Definition XTPPopupItem.h:493
CXTPPopupItem::SetTextColor
void SetTextColor(COLORREF clrText, COLORREF clrHotText=(COLORREF) -1)
Call this member function to set the color for an item's text.
CXTPPopupItem::m_bHyperLink
BOOL m_bHyperLink
TRUE if the pop-up item is a hyperlink, otherwise FALSE.
Definition XTPPopupItem.h:479
CXTPPopupItem::CalculateHeight
void CalculateHeight()
Call this member function to update the rectangular height of a text.
CXTPPopupItem::SetRTFText
void SetRTFText(UINT nIDResource)
Call this member function to set the RichText for an item.
CXTPPopupItem::GetRichRender
CXTPRichRender * GetRichRender() const
Call this method to get the Rich Render element that renders the item.
CXTPPopupItem::SetIcons
BOOL SetIcons(HBITMAP hBitmap, COLORREF clrTransparent, int itemIcon, BOOL bAlphaBitmap=FALSE)
Call this member function to set the normal, selected, or pressed icon from a resource bitmap picture...
CXTPPopupItem::GetPopupControl
CXTPPopupControl * GetPopupControl() const
Retrieves the parent CXTPPopupControl object.
CXTPPopupItem::m_nID
int m_nID
ID of the pop-up item.
Definition XTPPopupItem.h:474
CXTPPopupItem::m_xtpFontText
CXTPFont m_xtpFontText
Pop-up item's fntText.
Definition XTPPopupItem.h:486
CXTPPopupItem::m_strCaption
CString m_strCaption
Pop-up item's display text.
Definition XTPPopupItem.h:492
CXTPPopupPaintManager
CXTPPopupPaintManager is a class used to perform specialized drawing tasks.
Definition XTPPopupPaintManager.h:44


Toolkit Pro: XTPButtonThemeOffice2013.h Source File

  • Source
  • Controls
  • Button
  • Themes
XTPButtonThemeOffice2013.h
Go to the documentation of this file.
1
23#if !defined(__XTPBUTTONTHEMEOFFICE2013_H__)
24# define __XTPBUTTONTHEMEOFFICE2013_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPButtonThemeOffice2013 : public CXTPButtonThemeUltraFlat
39{
40public:
41 CXTPButtonThemeOffice2013();
42
49 virtual void DrawButtonBackground(CDC* pDC, CXTPButton* pButton);
50
57 virtual void DrawGroupBox(CDC* pDC, CXTPButton* pButton);
58
66 virtual void DrawCheckBoxMark(CDC* pDC, CXTPButton* pButton);
67
75 virtual void DrawRadioButtonMark(CDC* pDC, CXTPButton* pButton);
76
83 virtual void RefreshMetrics(CXTPButton* pButton);
84
92 virtual COLORREF GetTextColor(CXTPButton* pButton);
93
100 virtual void DrawPushButtonText(CDC* pDC, CXTPButton* pButton);
101
108 virtual void DrawPushButtonIcon(CDC* pDC, CXTPButton* pButton);
109
116 virtual void DrawPushButtonDropDown(CDC* pDC, CXTPButton* pButton);
117
118protected:
119 CXTPPaintManagerColor m_crBorder;
120 CXTPPaintManagerColor m_crBorderDefault;
121 CXTPPaintManagerColor m_crBorderDisabled;
123 CXTPPaintManagerColor m_crBackDisabled;
125 CXTPPaintManagerColor m_crMark;
126 CXTPPaintManagerColor m_crMarkHilite;
127 CXTPPaintManagerColor m_crMarkPushed;
128 CXTPPaintManagerColor m_crMarkDisabled;
130};
131
132# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
134#endif //#if !defined(__XTPBUTTONTHEMEOFFICE2013_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPButton
Push Button control.
Definition XTPButton.h:109
CXTPButtonThemeOffice2013
CXTPButtonThemeOffice2013 is a class used to perform Office 2013 theme drawing tasks.
Definition XTPButtonThemeOffice2013.h:39
CXTPButtonThemeOffice2013::GetTextColor
virtual COLORREF GetTextColor(CXTPButton *pButton)
Call this member function to retrieve the color used to draw the button text.
CXTPButtonThemeOffice2013::DrawGroupBox
virtual void DrawGroupBox(CDC *pDC, CXTPButton *pButton)
This member function is called to draw the group box for the button.
CXTPButtonThemeOffice2013::DrawCheckBoxMark
virtual void DrawCheckBoxMark(CDC *pDC, CXTPButton *pButton)
This member function is called to draw the check box mark for the button control.
CXTPButtonThemeOffice2013::m_crMark
CXTPPaintManagerColor m_crMark
An RGB value representing checkmark color.
Definition XTPButtonThemeOffice2013.h:125
CXTPButtonThemeOffice2013::DrawPushButtonIcon
virtual void DrawPushButtonIcon(CDC *pDC, CXTPButton *pButton)
This member function draws the icon for the button, if one has been defined.
CXTPButtonThemeOffice2013::DrawButtonBackground
virtual void DrawButtonBackground(CDC *pDC, CXTPButton *pButton)
This member function is called to draw the background for the button.
CXTPButtonThemeOffice2013::DrawPushButtonDropDown
virtual void DrawPushButtonDropDown(CDC *pDC, CXTPButton *pButton)
This member function draws the dropdown for the button, if one has been defined.
CXTPButtonThemeOffice2013::m_crBackDisabled
CXTPPaintManagerColor m_crBackDisabled
An RGB value representing disabled background color.
Definition XTPButtonThemeOffice2013.h:123
CXTPButtonThemeOffice2013::m_crBorderDefault
CXTPPaintManagerColor m_crBorderDefault
An RGB value representing default border color.
Definition XTPButtonThemeOffice2013.h:120
CXTPButtonThemeOffice2013::m_crMarkHilite
CXTPPaintManagerColor m_crMarkHilite
An RGB value representing checkmark hilite color.
Definition XTPButtonThemeOffice2013.h:126
CXTPButtonThemeOffice2013::m_crBorder
CXTPPaintManagerColor m_crBorder
An RGB value representing border color.
Definition XTPButtonThemeOffice2013.h:119
CXTPButtonThemeOffice2013::DrawPushButtonText
virtual void DrawPushButtonText(CDC *pDC, CXTPButton *pButton)
This member function is called to draw the text for the button.
CXTPButtonThemeOffice2013::m_crMarkDisabled
CXTPPaintManagerColor m_crMarkDisabled
An RGB value representing checkmark disabled color.
Definition XTPButtonThemeOffice2013.h:128
CXTPButtonThemeOffice2013::m_crMarkPushed
CXTPPaintManagerColor m_crMarkPushed
An RGB value representing checkmark pushed color.
Definition XTPButtonThemeOffice2013.h:127
CXTPButtonThemeOffice2013::m_crBorderDisabled
CXTPPaintManagerColor m_crBorderDisabled
An RGB value representing disabled border color.
Definition XTPButtonThemeOffice2013.h:121
CXTPButtonThemeOffice2013::DrawRadioButtonMark
virtual void DrawRadioButtonMark(CDC *pDC, CXTPButton *pButton)
This member function is called to draw the radio mark for the button control.
CXTPButtonThemeOffice2013::RefreshMetrics
virtual void RefreshMetrics(CXTPButton *pButton)
This member function is called by the theme manager to refresh the visual styles used by each compone...
CXTPButtonThemeUltraFlat
CXTPButtonThemeUltraFlat is a class used to perform Ultra Flat Theme drawing tasks.
Definition XTPButtonThemeUltraFlat.h:39
CXTPPaintManagerColor
The CXTPPaintManagerColor class is used to manage COLORREF values for determining default and applica...
Definition XTPColorManager.h:117


Toolkit Pro: Member List

  • CXTPCalendarTimeZones
  • REGISTRY_TIMEZONE_INFORMATION
CXTPCalendarTimeZones::REGISTRY_TIMEZONE_INFORMATION Member List

This is the complete list of members for CXTPCalendarTimeZones::REGISTRY_TIMEZONE_INFORMATION, including all inherited members.

Bias | CXTPCalendarTimeZones::REGISTRY_TIMEZONE_INFORMATION
DaylightBias | CXTPCalendarTimeZones::REGISTRY_TIMEZONE_INFORMATION
DaylightDate | CXTPCalendarTimeZones::REGISTRY_TIMEZONE_INFORMATION
StandardBias | CXTPCalendarTimeZones::REGISTRY_TIMEZONE_INFORMATION
StandardDate | CXTPCalendarTimeZones::REGISTRY_TIMEZONE_INFORMATION


Toolkit Pro: XTPCalendarDayViewEvent.h Source File

  • Source
  • Calendar
XTPCalendarDayViewEvent.h
Go to the documentation of this file.
1
22#if !defined(_XTPCALENDARVIEWEVENT_H__)
23# define _XTPCALENDARVIEWEVENT_H__
24
25# if _MSC_VER > 1000
26# pragma once
27# endif // _MSC_VER > 1000
28
29# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
30
31class CXTPCalendarEvent;
32class CXTPCalendarControl;
33class CXTPCalendarDayViewDay;
34class CXTPCalendarDayViewGroup;
35
54class _XTP_EXT_CLASS CXTPCalendarDayViewEvent
55 : public CXTPCalendarViewEventT<CXTPCalendarDayViewGroup>
56{
58 DECLARE_DYNAMIC(CXTPCalendarDayViewEvent)
60public:
65 typedef CXTPCalendarViewEventT<CXTPCalendarDayViewGroup> TBase;
66
76 CXTPCalendarDayViewEvent(CXTPCalendarEvent* pEvent, CXTPCalendarDayViewGroup* pViewGroup);
77
82 virtual ~CXTPCalendarDayViewEvent();
83
100 virtual void AdjustLayout(CDC* pDC, const CRect& rcEventMax, int nEventPlaceNumber);
101
118 virtual void AdjustLayout2(CDC* pDC, const CRect& rcEventMax, int nEventPlaceNumber);
119
129 virtual void OnPostAdjustLayout();
130
143 virtual void Draw(CDC* pDC);
144
161 virtual BOOL HitTestEx(CPoint point, XTP_CALENDAR_HITTESTINFO* pInfo) const;
162
169 virtual BOOL IsMultidayEvent() const;
170
181 virtual BOOL IsVisible() const;
182
197 virtual BOOL IsVisibleEx(BOOL bCheckTop, BOOL bCheckBottom, BOOL bTopAndBottom) const;
198
211 virtual CXTPCalendarViewEvent* StartEditSubject();
212
222 CRect GetEventsRect() const;
223
233 int GetEventPlacePos() const;
234
245 int GetEventPlaceCount() const;
246
256 void SetEventPlacePos(int nPlace);
257
267 void SetEventPlaceCount(int nPlaceCount);
268
277 BOOL IsHideEventTime() const;
278
288 CRect GetTimeframeRect() const;
289
290protected:
297 virtual CFont* GetSubjectEditorFont() const;
298
306 virtual DWORD GetSubjectEditorStyles() const;
307
314 virtual void ChangeEventPlace(int nNewPlace);
315
316public:
326 virtual void AdjustSubjectEditor();
327
340 virtual void AdjustSubjectEditorEx(BOOL bUpdateView);
341
349 int GetSlotNumber() const;
350
358 void SetSlotNumber(int nSlotNumber);
359
360public:
361 CRect m_rcTimeframe;
363 BOOL m_bHideEventTime;
364 BOOL m_bShowArrow;
366private:
367 int m_nSlotNumber;
368};
369
371
372AFX_INLINE void CXTPCalendarDayViewEvent::SetSlotNumber(int nSlotNumber)
373{
374 m_nSlotNumber = nSlotNumber;
375}
376AFX_INLINE int CXTPCalendarDayViewEvent::GetSlotNumber() const
377{
378 return m_nSlotNumber;
379}
380AFX_INLINE int CXTPCalendarDayViewEvent::GetEventPlacePos() const
381{
382 return (int)LOWORD((DWORD)m_nEventPlaceNumber);
383}
384AFX_INLINE int CXTPCalendarDayViewEvent::GetEventPlaceCount() const
385{
386 return (int)HIWORD((DWORD)m_nEventPlaceNumber);
387}
388AFX_INLINE void CXTPCalendarDayViewEvent::SetEventPlacePos(int nPlace)
389{
390 m_nEventPlaceNumber = (int)MAKELONG((WORD)nPlace, HIWORD((DWORD)m_nEventPlaceNumber));
391}
392AFX_INLINE void CXTPCalendarDayViewEvent::SetEventPlaceCount(int nPlaceCount)
393{
394 m_nEventPlaceNumber = (int)MAKELONG(LOWORD((DWORD)m_nEventPlaceNumber), (WORD)nPlaceCount);
395}
396AFX_INLINE DWORD CXTPCalendarDayViewEvent::GetSubjectEditorStyles() const
397{
398 if (IsMultidayEvent())
399 {
400 return TBase::GetSubjectEditorStyles();
401 }
402 return (ES_NOHIDESEL | ES_MULTILINE | ES_AUTOVSCROLL);
403}
404
405AFX_INLINE BOOL CXTPCalendarDayViewEvent::IsHideEventTime() const
406{
407 return m_bHideEventTime;
408}
409AFX_INLINE CRect CXTPCalendarDayViewEvent::GetTimeframeRect() const
410{
411 return m_rcTimeframe;
412}
413
414# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
415#endif // !defined(_XTPCALENDARVIEWEVENT_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCalendarControl
Class CXTPCalendarControl implements the calendar's view interface.
Definition XTPCalendarControl.h:126
CXTPCalendarDayViewDay
This class represents a day view portion of the Calendar Day View.
Definition XTPCalendarDayViewDay.h:726
CXTPCalendarDayViewEvent
This class represents an event view portion of the CalendarDayViewDay.
Definition XTPCalendarDayViewEvent.h:56
CXTPCalendarDayViewEvent::m_rcTimeframe
CRect m_rcTimeframe
Rectangle area to display times.
Definition XTPCalendarDayViewEvent.h:361
CXTPCalendarDayViewEvent::m_bShowArrow
BOOL m_bShowArrow
TRUE if event in AllDay area should have arrow to indicate more events follows.
Definition XTPCalendarDayViewEvent.h:364
CXTPCalendarDayViewEvent::IsVisible
virtual BOOL IsVisible() const
This member function is used to determine if the event is visible.
CXTPCalendarDayViewEvent::AdjustSubjectEditorEx
virtual void AdjustSubjectEditorEx(BOOL bUpdateView)
This member function is used to perform adjustments of the subject editor area.
CXTPCalendarDayViewEvent::GetEventPlacePos
int GetEventPlacePos() const
This member function is used to obtain the event's view position identifier.
Definition XTPCalendarDayViewEvent.h:380
CXTPCalendarDayViewEvent::GetSubjectEditorFont
virtual CFont * GetSubjectEditorFont() const
This member function is used to obtain the editor window font.
CXTPCalendarDayViewEvent::IsVisibleEx
virtual BOOL IsVisibleEx(BOOL bCheckTop, BOOL bCheckBottom, BOOL bTopAndBottom) const
This member function is used to obtain the value of the visibility flag.
CXTPCalendarDayViewEvent::AdjustLayout2
virtual void AdjustLayout2(CDC *pDC, const CRect &rcEventMax, int nEventPlaceNumber)
This member function is used to adjust the view's layout depending on the provided rectangle and then...
CXTPCalendarDayViewEvent::OnPostAdjustLayout
virtual void OnPostAdjustLayout()
This member function is used to perform additional adjustments in some kinds of views.
CXTPCalendarDayViewEvent::AdjustSubjectEditor
virtual void AdjustSubjectEditor()
This member function is used to perform adjustments of the subject editor area.
CXTPCalendarDayViewEvent::StartEditSubject
virtual CXTPCalendarViewEvent * StartEditSubject()
This member function is used to create and show the subject editor.
CXTPCalendarDayViewEvent::Draw
virtual void Draw(CDC *pDC)
This member function is used to draw the view content using the specified device context.
CXTPCalendarDayViewEvent::CXTPCalendarDayViewEvent
CXTPCalendarDayViewEvent(CXTPCalendarEvent *pEvent, CXTPCalendarDayViewGroup *pViewGroup)
Default object constructor.
CXTPCalendarDayViewEvent::AdjustLayout
virtual void AdjustLayout(CDC *pDC, const CRect &rcEventMax, int nEventPlaceNumber)
This member function is used to adjust the view's layout depending on the provided rectangle and then...
CXTPCalendarDayViewEvent::TBase
CXTPCalendarViewEventT< CXTPCalendarDayViewGroup > TBase
Definition XTPCalendarDayViewEvent.h:65
CXTPCalendarDayViewEvent::GetTimeframeRect
CRect GetTimeframeRect() const
This member function is used to obtain timeframe's bounding rectangle.
Definition XTPCalendarDayViewEvent.h:409
CXTPCalendarDayViewEvent::SetSlotNumber
void SetSlotNumber(int nSlotNumber)
This member function set the slot number of event in all day/ multiday events.
Definition XTPCalendarDayViewEvent.h:372
CXTPCalendarDayViewEvent::~CXTPCalendarDayViewEvent
virtual ~CXTPCalendarDayViewEvent()
Default class destructor.
CXTPCalendarDayViewEvent::SetEventPlacePos
void SetEventPlacePos(int nPlace)
This member function is used to set the event view place identifier.
Definition XTPCalendarDayViewEvent.h:388
CXTPCalendarDayViewEvent::SetEventPlaceCount
void SetEventPlaceCount(int nPlaceCount)
This member function is used to set the event view places count.
Definition XTPCalendarDayViewEvent.h:392
CXTPCalendarDayViewEvent::HitTestEx
virtual BOOL HitTestEx(CPoint point, XTP_CALENDAR_HITTESTINFO *pInfo) const
This member function is used to fill an XTP_CALENDAR_HITTESTINFO structure.
CXTPCalendarDayViewEvent::GetEventPlaceCount
int GetEventPlaceCount() const
This member function is used to obtain the count of the event view positions.
Definition XTPCalendarDayViewEvent.h:384
CXTPCalendarDayViewEvent::GetSubjectEditorStyles
virtual DWORD GetSubjectEditorStyles() const
This member function is used to obtain the styles of the editor window.
Definition XTPCalendarDayViewEvent.h:396
CXTPCalendarDayViewEvent::m_bHideEventTime
BOOL m_bHideEventTime
Flag determines if event time should not be displayed.
Definition XTPCalendarDayViewEvent.h:363
CXTPCalendarDayViewEvent::GetSlotNumber
int GetSlotNumber() const
This member function returns the slot number of event in all day/ multiday events.
Definition XTPCalendarDayViewEvent.h:376
CXTPCalendarDayViewEvent::IsHideEventTime
BOOL IsHideEventTime() const
This member function is used to determine if the event time should not be displayed.
Definition XTPCalendarDayViewEvent.h:405
CXTPCalendarDayViewEvent::ChangeEventPlace
virtual void ChangeEventPlace(int nNewPlace)
This function is used to change the event place number.
CXTPCalendarDayViewEvent::GetEventsRect
CRect GetEventsRect() const
This member function is used to obtain the event's bounding rectangle.
CXTPCalendarDayViewEvent::IsMultidayEvent
virtual BOOL IsMultidayEvent() const
Call this member function to determine if an event is "Multi Day".
CXTPCalendarDayViewGroup
This class represents a single resource view portion of the Calendar Day View.
Definition XTPCalendarDayViewDay.h:53
CXTPCalendarEvent
This class represents the data of a single Event used in the Calendar control.
Definition XTPCalendarEvent.h:77
CXTPCalendarViewEvent
This class represents an event view portion of the CalendarViewGroup.
Definition XTPCalendarViewEvent.h:106
CXTPCalendarViewEvent::GetSubjectEditorStyles
virtual DWORD GetSubjectEditorStyles() const
This member function is used to obtain the styles of the editor window.
Definition XTPCalendarViewEvent.h:1273
CXTPCalendarViewEvent::m_nEventPlaceNumber
int m_nEventPlaceNumber
Event view place number (sequential identifier).
Definition XTPCalendarViewEvent.h:967
CXTPCalendarViewEventT
This class is used to build the ViewEvent layer of the DayView and ViewEvent hierarchies.
Definition XTPCalendarViewEvent.h:1077
XTP_CALENDAR_HITTESTINFO
Basic set of parameters transferred from calendar items to mouse handlers.
Definition XTPCalendarDefines.h:856


Toolkit Pro: XTPChartPyramidSeriesPointView.h Source File

  • Source
  • Chart
  • Styles
  • Pyramid
XTPChartPyramidSeriesPointView.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTPYRAMIDSERIESPOINTVIEW_H__)
24# define __XTPCHARTPYRAMIDSERIESPOINTVIEW_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Chart/Styles/Pyramid/Base/XTPChartPyramidSeriesPointViewBase.h"
32# include "Chart/Styles/Pyramid/2D/XTPChart2dPyramidSeriesPointView.h"
33
35typedef CXTPChartPyramidSeriesPointView CXTPChart2dPyramidSeriesPointView;
37#endif //#if !defined(__XTPCHARTPYRAMIDSERIESPOINTVIEW_H__)
XTPChart2dPyramidSeriesPointView.h
CXTPChart2dPyramidSeriesPointView
CXTPChartPyramidSeriesPointView CXTPChart2dPyramidSeriesPointView
CXTPChart2dPyramidSeriesPointView alias is necessary for naming consistency.
Definition XTPChartPyramidSeriesPointView.h:35
XTPChartPyramidSeriesPointViewBase.h
CXTPChartPyramidSeriesPointView
This class abstracts the view of a pyramid series point.
Definition XTPChart2dPyramidSeriesPointView.h:50


Toolkit Pro: Member List

CXTPPropertyGridItemFont Member List

This is the complete list of members for CXTPPropertyGridItemFont, including all inherited members.

AddChildItem(CXTPPropertyGridItem *pItem) | CXTPPropertyGridItem |
AddComboButton() | CXTPPropertyGridItem |
AddExpandButton() | CXTPPropertyGridItem |
AddSliderControl() | CXTPPropertyGridItem |
AddSpinButton() | CXTPPropertyGridItem |
BindToString(CString *pBindString) | CXTPPropertyGridItem |
Collapse() | CXTPPropertyGridItem |
CXTPCmdTarget() | CXTPCmdTarget |
CXTPPropertyGridItem(LPCTSTR lpszCaption, LPCTSTR strValue=NULL, CString *pBindString=NULL) | CXTPPropertyGridItem |
CXTPPropertyGridItem(UINT nID, LPCTSTR strValue=NULL, CString *pBindString=NULL) | CXTPPropertyGridItem |
CXTPPropertyGridItemFont(LPCTSTR strCaption, LOGFONT &font) | CXTPPropertyGridItemFont |
CXTPPropertyGridItemFont(UINT nID, LOGFONT &font) | CXTPPropertyGridItemFont |
EnsureVisible() | CXTPPropertyGridItem |
Expand() | CXTPPropertyGridItem |
FontToString(const LOGFONT &lfValue) | CXTPPropertyGridItemFont | protectedvirtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCaption() const | CXTPPropertyGridItem |
GetCaptionMetrics() const | CXTPPropertyGridItem |
GetChilds() const | CXTPPropertyGridItem |
GetColor() | CXTPPropertyGridItemFont | virtual
GetConstraintEdit() const | CXTPPropertyGridItem |
GetConstraints() const | CXTPPropertyGridItem |
GetDefaultValue() const | CXTPPropertyGridItem |
GetDescription() const | CXTPPropertyGridItem |
GetDropDownItemCount() const | CXTPPropertyGridItem |
GetEditStyle() const | CXTPPropertyGridItem | virtual
GetFlags() const | CXTPPropertyGridItem |
GetFont(LOGFONT *lf) | CXTPPropertyGridItemFont | virtual
GetGrid() const | CXTPPropertyGridItem |
GetHeight() const | CXTPPropertyGridItem |
GetID() const | CXTPPropertyGridItem |
GetIndent() const | CXTPPropertyGridItem |
GetIndex() const | CXTPPropertyGridItem |
GetInplaceButtons() const | CXTPPropertyGridItem |
GetInplaceControls() const | CXTPPropertyGridItem |
GetInPlacedEditValue() | CXTPPropertyGridItem | inlineprotectedvirtual
GetInplaceEdit() | CXTPPropertyGridItem | virtual
GetInplaceList() | CXTPPropertyGridItem | protectedvirtual
GetItemData() const | CXTPPropertyGridItem |
GetItemRect() const | CXTPPropertyGridItem |
GetMarkupCaption() const | CXTPPropertyGridItem |
GetMarkupDescription() const | CXTPPropertyGridItem |
GetMarkupTemplate() const | CXTPPropertyGridItem | virtual
GetMarkupValue() const | CXTPPropertyGridItem |
GetMaskedText() const | CXTPPropertyGridItem |
GetMetrics(BOOL bValueMetrics, BOOL bCreate=TRUE) const | CXTPPropertyGridItem |
GetMultiLinesCount() const | CXTPPropertyGridItem |
GetParentItem() const | CXTPPropertyGridItem |
GetReadOnly() const | CXTPPropertyGridItem | virtual
GetTooltip() const | CXTPPropertyGridItem |
GetValue() const | CXTPPropertyGridItem |
GetValueMetrics() const | CXTPPropertyGridItem |
GetValueRect() | CXTPPropertyGridItemFont | protectedvirtual
GetViewValue() | CXTPPropertyGridItem | virtual
HasChilds() const | CXTPPropertyGridItem |
HasParent(CXTPPropertyGridItem *pParent) | CXTPPropertyGridItem |
HasVisibleChilds() const | CXTPPropertyGridItem |
InsertChildItem(int nIndex, CXTPPropertyGridItem *pItem) | CXTPPropertyGridItem |
IsAllowEdit() const | CXTPPropertyGridItem | virtual
IsCategory() const | CXTPPropertyGridItem |
IsExpandable() const | CXTPPropertyGridItem |
IsExpanded() const | CXTPPropertyGridItem |
IsHidden() const | CXTPPropertyGridItem |
IsInplaceButtonVisible(CXTPPropertyGridInplaceButton *pButton) const | CXTPPropertyGridItem | virtual
IsMultiLine() const | CXTPPropertyGridItem |
IsSelected() const | CXTPPropertyGridItem |
IsValueChanged() const | CXTPPropertyGridItem | virtual
IsVisible() const | CXTPPropertyGridItem |
m_bAutoComplete | CXTPPropertyGridItem | protected
m_bCategory | CXTPPropertyGridItem | protected
m_bConstraintEdit | CXTPPropertyGridItem | protected
m_bExpandable | CXTPPropertyGridItem | protected
m_bExpanded | CXTPPropertyGridItem | protected
m_bHidden | CXTPPropertyGridItem | protected
m_bPassword | CXTPPropertyGridItem | protected
m_bReadOnly | CXTPPropertyGridItem | protected
m_bUseMask | CXTPPropertyGridItem | protected
m_bVisible | CXTPPropertyGridItem | protected
m_chPrompt | CXTPPropertyGridItem | protected
m_clrValue | CXTPPropertyGridItemFont | protected
m_dwData | CXTPPropertyGridItem | protected
m_dwEditStyle | CXTPPropertyGridItem | protected
m_lfValue | CXTPPropertyGridItemFont | protected
m_nDropDownItemCount | CXTPPropertyGridItem | protected
m_nFlags | CXTPPropertyGridItem | protected
m_nHeight | CXTPPropertyGridItem | protected
m_nID | CXTPPropertyGridItem | protected
m_nIndent | CXTPPropertyGridItem | protected
m_nIndex | CXTPPropertyGridItem | protected
m_nLinesCount | CXTPPropertyGridItem | protected
m_pBindString | CXTPPropertyGridItem | protected
m_pCaptionMetrics | CXTPPropertyGridItem | mutableprotected
m_pChilds | CXTPPropertyGridItem | protected
m_pConstraints | CXTPPropertyGridItem | protected
m_pGrid | CXTPPropertyGridItem | protected
m_pInplaceButtons | CXTPPropertyGridItem | protected
m_pInplaceControls | CXTPPropertyGridItem | protected
m_pMarkupCaption | CXTPPropertyGridItem | protected
m_pMarkupDescription | CXTPPropertyGridItem | protected
m_pMarkupValue | CXTPPropertyGridItem | protected
m_pParent | CXTPPropertyGridItem | protected
m_pValueMetrics | CXTPPropertyGridItem | mutableprotected
m_strCaption | CXTPPropertyGridItem | protected
m_strDefaultValue | CXTPPropertyGridItem | protected
m_strDescription | CXTPPropertyGridItem | protected
m_strFormat | CXTPPropertyGridItem | protected
m_strLiteral | CXTPPropertyGridItem | protected
m_strMarkupTemplate | CXTPPropertyGridItem | protected
m_strMask | CXTPPropertyGridItem | protected
m_strTooltip | CXTPPropertyGridItem | protected
m_strValue | CXTPPropertyGridItem | protected
MeasureItem(LPMEASUREITEMSTRUCT lpMeasureItemStruct) | CXTPPropertyGridItem | virtual
Move(CXTPPropertyGridItem *pParent, int nIndex=-1) | CXTPPropertyGridItem |
NotifyValueChanged() | CXTPPropertyGridItem | protected
OnAddChildItem() | CXTPPropertyGridItem | protectedvirtual
OnAfterEdit(CString &strValue) | CXTPPropertyGridItem | virtual
OnBeforeInsert() | CXTPPropertyGridItem | protectedvirtual
OnCancelEdit() | CXTPPropertyGridItem | virtual
OnCaptionChanged() | CXTPPropertyGridItem | protectedvirtual
OnChar(UINT nChar) | CXTPPropertyGridItem | protectedvirtual
OnConstraintsChanged() | CXTPPropertyGridItem | protectedvirtual
OnDeselect() | CXTPPropertyGridItem | protectedvirtual
OnDrawItemConstraint(CDC *pDC, CXTPPropertyGridItemConstraint *pConstraint, CRect rc, BOOL bSelected) | CXTPPropertyGridItem | virtual
OnDrawItemValue(CDC &dc, CRect rcValue) | CXTPPropertyGridItemFont | protectedvirtual
OnIndexChanged() | CXTPPropertyGridItem | protectedvirtual
OnInpaceControlFocus(BOOL bForward) | CXTPPropertyGridItem | protectedvirtual
OnInplaceButtonDown(CXTPPropertyGridInplaceButton *pButton) | CXTPPropertyGridItemFont | protectedvirtual
OnKeyDown(UINT nChar) | CXTPPropertyGridItem | protectedvirtual
OnLButtonDblClk(UINT nFlags, CPoint point) | CXTPPropertyGridItem | protectedvirtual
OnLButtonDown(UINT nFlags, CPoint point) | CXTPPropertyGridItem | protectedvirtual
OnLButtonUp(UINT nFlags, CPoint point) | CXTPPropertyGridItem | protectedvirtual
OnMarkupChanged() | CXTPPropertyGridItem | virtual
OnMergeItemConstraint(CDC *pDC, CXTPPropertyGridItemConstraint *pConstraint) | CXTPPropertyGridItem | virtual
OnRButtonDown(UINT nFlags, CPoint point) | CXTPPropertyGridItem | protectedvirtual
OnRequestEdit() | CXTPPropertyGridItem | virtual
OnSelect() | CXTPPropertyGridItem | protectedvirtual
OnValidateEdit() | CXTPPropertyGridItem | virtual
OnValueChanged(CString strValue) | CXTPPropertyGridItem | virtual
PtInValueRect(CPoint point) | CXTPPropertyGridItem | protected
RedrawItem() | CXTPPropertyGridItem |
Remove() | CXTPPropertyGridItem |
ResetValue() | CXTPPropertyGridItem | virtual
Select() | CXTPPropertyGridItem |
SelectNextConstraint() | CXTPPropertyGridItem | protected
SetAutoComplete(BOOL bAutoComplete=TRUE) | CXTPPropertyGridItem |
SetCaption(LPCTSTR lpszCaption) | CXTPPropertyGridItem |
SetColor(COLORREF clr) | CXTPPropertyGridItemFont | virtual
SetConstraintEdit(BOOL bConstraintEdit=TRUE) | CXTPPropertyGridItem |
SetDefaultValue(LPCTSTR lpszDefaultValue) | CXTPPropertyGridItem |
SetDescription(LPCTSTR lpszDescription) | CXTPPropertyGridItem |
SetDropDownItemCount(int nDropDownItemCount) | CXTPPropertyGridItem |
SetEditStyle(DWORD dwEditStyle) | CXTPPropertyGridItem |
SetEditText(const CString &str) | CXTPPropertyGridItem | protectedvirtual
SetExpandable(BOOL bExpandable) | CXTPPropertyGridItem |
SetFlags(UINT nFlags) | CXTPPropertyGridItem |
SetFocusToInplaceControl() | CXTPPropertyGridItem | virtual
SetFont(LOGFONT &font) | CXTPPropertyGridItemFont | virtual
SetHeight(int nHeight) | CXTPPropertyGridItem |
SetHidden(BOOL bHidden) | CXTPPropertyGridItem |
SetID(UINT nID) | CXTPPropertyGridItem |
SetItemData(DWORD_PTR dwData) | CXTPPropertyGridItem |
SetMarkupTemplate(LPCTSTR lpstrMarkupTemplate) | CXTPPropertyGridItem |
SetMask(LPCTSTR strMask, LPCTSTR strLiteral, TCHAR chPrompt=_T('_')) | CXTPPropertyGridItem |
SetMaskedText(LPCTSTR lpszMaskedText) | CXTPPropertyGridItem |
SetMultiLinesCount(int nLinesCount) | CXTPPropertyGridItem |
SetPasswordMask(TCHAR chMask=_T(' *')) | CXTPPropertyGridItem |
SetPrompt(LPCTSTR lpszPrompt) | CXTPPropertyGridItem |
SetReadOnly(BOOL bReadOnly=TRUE) | CXTPPropertyGridItem | virtual
SetTooltip(LPCTSTR lpstrTooltip) | CXTPPropertyGridItem |
SetValue(CString strValue) | CXTPPropertyGridItem | virtual
SetVisible(BOOL bVisible) | CXTPPropertyGridItem | protectedvirtual
~CXTPPropertyGridItem() | CXTPPropertyGridItem | virtual
~CXTPPropertyGridItemFont() | CXTPPropertyGridItemFont | virtual


Toolkit Pro: XTPTabThemeFlat.h Source File

  • Source
  • TabManager
  • Themes
XTPTabThemeFlat.h
Go to the documentation of this file.
1
23#if !defined(__XTPTABTHEMEFLAT_H__)
24# define __XTPTABTHEMEFLAT_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
48class _XTP_EXT_CLASS CXTPTabThemeFlat : public CXTPTabPaintManagerTheme
49{
50public:
55 CXTPTabThemeFlat()
56 {
57 m_rcHeaderMargin.SetRect(2, 2, 4, 0);
58 }
59
75 virtual void DrawSingleButton(CDC* pDC, CXTPTabManagerItem* pItem);
76
96 virtual CRect FillTabControl(CXTPTabManager* pTabManager, CDC* pDC, CRect rcControl);
97
106 virtual XTPTabColorStyle GetDefaultColorSet()
107 {
108 return xtpTabColorVisualStudio2003;
109 }
110};
111
112class _XTP_EXT_CLASS CXTPTabPaintManager::CAppearanceSetFlat : public CXTPTabThemeFlat
113{
114};
115
116# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
118#endif // !defined(__XTPTABTHEMEFLAT_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPTabColorStyle
XTPTabColorStyle
XTPTabColorStyle is an enumeration used to set the color style of tabs.
Definition XTPTabManagerDefines.h:139
xtpTabColorVisualStudio2003
@ xtpTabColorVisualStudio2003
Tabs will use the Visual Studio 2003 color style for the currently set Appearance.
Definition XTPTabManagerDefines.h:150
CXTPTabManager
CXTPTabManager is the base class for docking pane tabs, tab control tabs, and MDI client tabs.
Definition XTPTabManager.h:87
CXTPTabManagerItem
CXTPTabManagerItem is the base class for the tabs that appear in the command bars tab workspace,...
Definition XTPTabManagerItem.h:44
CXTPTabPaintManager
CXTPTabPaintManager is used to store the color and appearance information of the tabs in the tab mana...
Definition XTPTabPaintManager.h:48
CXTPTabPaintManagerTheme
CXTPTabPaintManagerTheme is a class that represents the appearance of all components of the tab manag...
Definition XTPTabPaintManagerTheme.h:56
CXTPTabThemeFlat
CXTPTabThemeFlat implements a "Flat" tab appearance.
Definition XTPTabThemeFlat.h:49
CXTPTabThemeFlat::GetDefaultColorSet
virtual XTPTabColorStyle GetDefaultColorSet()
Gets the default value of the color set for this theme.
Definition XTPTabThemeFlat.h:106
CXTPTabThemeFlat::CXTPTabThemeFlat
CXTPTabThemeFlat()
Constructs a CXTPTabThemeFlat object.
Definition XTPTabThemeFlat.h:55
CXTPTabThemeFlat::FillTabControl
virtual CRect FillTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl)
Fills both the tab header and the tab client area and then draws the tab client frame.
CXTPTabThemeFlat::DrawSingleButton
virtual void DrawSingleButton(CDC *pDC, CXTPTabManagerItem *pItem)
Draws a single tab button in the tab client header area.


Toolkit Pro: Member List

CXTPProgressCtrlThemeNativeWinXP Member List

This is the complete list of members for CXTPProgressCtrlThemeNativeWinXP, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPProgressCtrlPaintManager() | CXTPProgressCtrlPaintManager |
CXTPProgressCtrlThemeNativeWinXP() | CXTPProgressCtrlThemeNativeWinXP |
DeflateRect(XTPPROGRESSDRAWSTRUCT &ds) | CXTPProgressCtrlThemeNativeWinXP | protectedvirtual
Draw(XTPPROGRESSDRAWSTRUCT &ds) | CXTPProgressCtrlPaintManager | virtual
DrawNcBorders(CDC *pDC, CRect rc) | CXTPProgressCtrlPaintManager | virtual
DrawText(XTPPROGRESSDRAWSTRUCT &ds) | CXTPProgressCtrlPaintManager | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetBackColor() | CXTPProgressCtrlPaintManager |
GetBarColor() | CXTPProgressCtrlPaintManager |
GetBorderColor() | CXTPProgressCtrlPaintManager |
GetTextColor() | CXTPProgressCtrlPaintManager |
m_bUseWinTheme | CXTPProgressCtrlPaintManager | protected
m_clrBack | CXTPProgressCtrlPaintManager | protected
m_clrBar | CXTPProgressCtrlPaintManager | protected
m_clrBarText | CXTPProgressCtrlPaintManager | protected
m_clrBorder | CXTPProgressCtrlPaintManager | protected
m_clrText | CXTPProgressCtrlPaintManager | protected
m_nTheme | CXTPProgressCtrlPaintManager | protected
m_winTheme | CXTPProgressCtrlPaintManager | protected
RefreshMetrics() | CXTPProgressCtrlPaintManager | virtual
SetBackColor(COLORREF clrNew) | CXTPProgressCtrlPaintManager |
SetBarColor(COLORREF clrNew) | CXTPProgressCtrlPaintManager |
SetBorderColor(COLORREF clrNew) | CXTPProgressCtrlPaintManager |
SetTextColor(COLORREF clrNew) | CXTPProgressCtrlPaintManager |
UseWinThemes(BOOL bUseWinThemes=TRUE) | CXTPProgressCtrlPaintManager |
UsingWinThemes(BOOL bCheckReady=FALSE) | CXTPProgressCtrlPaintManager |
~CXTPProgressCtrlPaintManager() | CXTPProgressCtrlPaintManager | virtual


Toolkit Pro: Member List

CXTPStatusBarThemeOffice2013 Member List

This is the complete list of members for CXTPStatusBarThemeOffice2013, including all inherited members.

CXTPStatusBarThemeOffice2013(CXTPPaintManager *pPaintManager) | CXTPStatusBarThemeOffice2013 |
DrawStatusBarButtonFace(CDC *pDC, CRect rcItem, CXTPStatusBarPane *pPane) | CXTPStatusBarThemeOffice2013 | virtual
DrawStatusBarGripper(CDC *pDC, CRect rcClient) | CXTPStatusBarThemeOffice2013 | virtual
DrawStatusBarPaneBorder(CDC *pDC, CRect rc, CXTPStatusBarPane *pPane, BOOL bGripperPane) | CXTPStatusBarThemeOffice2013 | virtual
DrawStatusBarPaneEntry(CDC *pDC, CRect rcItem, CXTPStatusBarPane *pPane) | CXTPStatusBarThemeOffice2013 | virtual
DrawStatusBarPaneSeparator(CDC *pDC, CRect rc, CXTPStatusBarPane *pPane) | CXTPStatusBarThemeOffice2013 | virtual
DrawStatusBarSwitchPane(CDC *pDC, CRect rcItem, CXTPStatusBarSwitchPane *pPane) | CXTPStatusBarThemeOffice2013 | virtual
FillStatusBar(CDC *pDC, CXTPStatusBar *pBar) | CXTPStatusBarThemeOffice2013 | virtual
GetTextColor(CXTPStatusBarPane *pPane) | CXTPStatusBarThemeOffice2013 | virtual
m_clrButtonBack | CXTPStatusBarThemeOffice2013 | protected
m_clrButtonBackChecked | CXTPStatusBarThemeOffice2013 | protected
m_clrButtonBackHighlight | CXTPStatusBarThemeOffice2013 | protected
m_clrButtonBackPushed | CXTPStatusBarThemeOffice2013 | protected
m_clrButtonTextChecked | CXTPStatusBarThemeOffice2013 | protected
m_clrButtonTextHighlight | CXTPStatusBarThemeOffice2013 | protected
m_clrButtonTextPushed | CXTPStatusBarThemeOffice2013 | protected
RefreshMetrics() | CXTPStatusBarThemeOffice2013 | virtual


Toolkit Pro: XTPTabManagerNavigateButtons.h Source File

  • Source
  • TabManager
XTPTabManagerNavigateButtons.h
Go to the documentation of this file.
1
23#if !defined(__XTPTABMANAGERNAVIGATEBUTTONS_H__)
24# define __XTPTABMANAGERNAVIGATEBUTTONS_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPTabManagerNavigateButtons
39{
40public:
45 CXTPTabManagerNavigateButtons();
46
51 virtual ~CXTPTabManagerNavigateButtons();
52
53public:
62 CXTPTabManagerNavigateButton* GetAt(int nIndex) const;
63
72 CXTPTabManagerNavigateButton* operator[](int nIndex) const;
73
81 int Add(CXTPTabManagerNavigateButton* pButton);
82
89 void InsertAt(int nIndex, CXTPTabManagerNavigateButton* pButton);
90
96 void RemoveAt(int nIndex);
97
102 void RemoveAll();
103
110 int GetSize() const;
111
112protected:
113 CArray<CXTPTabManagerNavigateButton*, CXTPTabManagerNavigateButton*>
114 m_arrButtons;
115};
116
117AFX_INLINE CXTPTabManagerNavigateButton* CXTPTabManagerNavigateButtons::GetAt(int nIndex) const
118{
119 return m_arrButtons.GetAt(nIndex);
120}
121
122AFX_INLINE int CXTPTabManagerNavigateButtons::Add(CXTPTabManagerNavigateButton* pButton)
123{
124 return (int)m_arrButtons.Add(pButton);
125}
126
127AFX_INLINE int CXTPTabManagerNavigateButtons::GetSize() const
128{
129 return (int)m_arrButtons.GetSize();
130}
131
132AFX_INLINE void CXTPTabManagerNavigateButtons::InsertAt(int nIndex,
133 CXTPTabManagerNavigateButton* pButton)
134{
135 m_arrButtons.InsertAt(nIndex, pButton);
136}
137
138AFX_INLINE CXTPTabManagerNavigateButton* CXTPTabManagerNavigateButtons::operator[](int nIndex) const
139{
140 return m_arrButtons.GetAt(nIndex);
141}
142
143# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
145#endif // !defined(__XTPTABMANAGERNAVIGATEBUTTONS_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPTabManagerNavigateButton
CXTPTabManagerNavigateButton is a class used to represent a tab navigation button.
Definition XTPTabManagerNavigateButton.h:74
CXTPTabManagerNavigateButton::GetSize
virtual CSize GetSize() const
Gets the size of the navigation button.
CXTPTabManagerNavigateButtons
CXTPTabManagerNavigateButtons is a class used to represent a collection of tab navigation buttons.
Definition XTPTabManagerNavigateButtons.h:39
CXTPTabManagerNavigateButtons::GetAt
CXTPTabManagerNavigateButton * GetAt(int nIndex) const
Retrieves the tab navigation button at a specified index in the collection.
Definition XTPTabManagerNavigateButtons.h:117
CXTPTabManagerNavigateButtons::InsertAt
void InsertAt(int nIndex, CXTPTabManagerNavigateButton *pButton)
Inserts a specified tab navigation button to the collection.
Definition XTPTabManagerNavigateButtons.h:132
CXTPTabManagerNavigateButtons::GetSize
int GetSize() const
Gets the number of tab navigation buttons in the collection.
Definition XTPTabManagerNavigateButtons.h:127
CXTPTabManagerNavigateButtons::RemoveAll
void RemoveAll()
Removes all tab navigation buttons from the collection.
CXTPTabManagerNavigateButtons::operator[]
CXTPTabManagerNavigateButton * operator[](int nIndex) const
Retrieves the tab navigation button at a specified index in the collection.
Definition XTPTabManagerNavigateButtons.h:138
CXTPTabManagerNavigateButtons::~CXTPTabManagerNavigateButtons
virtual ~CXTPTabManagerNavigateButtons()
Destroys a CXTPTabManagerNavigateButtons object, handles cleanup and deallocation.
CXTPTabManagerNavigateButtons::Add
int Add(CXTPTabManagerNavigateButton *pButton)
Adds a specified tab navigation button to the collection.
Definition XTPTabManagerNavigateButtons.h:122
CXTPTabManagerNavigateButtons::RemoveAt
void RemoveAt(int nIndex)
Removes the tab navigation button at a specified index from the collection.
CXTPTabManagerNavigateButtons::m_arrButtons
CArray< CXTPTabManagerNavigateButton *, CXTPTabManagerNavigateButton * > m_arrButtons
Collection of tab navigation buttons.
Definition XTPTabManagerNavigateButtons.h:114
CXTPTabManagerNavigateButtons::CXTPTabManagerNavigateButtons
CXTPTabManagerNavigateButtons()
Constructs a CXTPTabManagerNavigateButtons object.


Toolkit Pro: Member List

CXTPPropertyGrid Member List

This is the complete list of members for CXTPPropertyGrid, including all inherited members.

AddCategory(LPCTSTR lpszCaption, CXTPPropertyGridItem *pCategory=NULL) | CXTPPropertyGrid |
AddCategory(int nID, CXTPPropertyGridItem *pCategory=NULL) | CXTPPropertyGrid |
AllowEdit(BOOL bAllowEdit) | CXTPPropertyGrid |
BeginUpdate(CXTPPropertyGridUpdateContext &context, BOOL bResetContent=TRUE) | CXTPPropertyGrid |
Create(const RECT &rect, CWnd *pParentWnd, UINT nID, DWORD dwListStyle=0) | CXTPPropertyGrid | virtual
CreateGridView(DWORD dwListStyle) | CXTPPropertyGrid | protected
CreateToolbar() | CXTPPropertyGrid | protectedvirtual
CreateView() const | CXTPPropertyGrid | virtual
CXTPPropertyGrid() | CXTPPropertyGrid |
EnableMarkup(BOOL bEnable=TRUE) | CXTPPropertyGrid |
EnableMultiSelect(BOOL bMultiSelect=TRUE) | CXTPPropertyGrid |
EnableToolTips(BOOL bEnable=TRUE) | CXTPPropertyGrid |
EndUpdate(CXTPPropertyGridUpdateContext &context) | CXTPPropertyGrid |
FindItem(LPCTSTR strCaption) const | CXTPPropertyGrid |
FindItem(UINT nID) const | CXTPPropertyGrid |
GetBorderStyle() const | CXTPPropertyGrid |
GetCategories() const | CXTPPropertyGrid |
GetCount() const | CXTPPropertyGrid |
GetCurrentTheme() const | CXTPPropertyGrid |
GetGridView() const | CXTPPropertyGrid |
GetHelpBackColor() const | CXTPPropertyGrid |
GetHelpForeColor() const | CXTPPropertyGrid |
GetHelpHeight() const | CXTPPropertyGrid |
GetImageManager() const | CXTPPropertyGrid |
GetItem(int nIndex) const | CXTPPropertyGrid |
GetMarkupContext() const | CXTPPropertyGrid |
GetPaintManager() const | CXTPPropertyGrid |
GetPropertySort() const | CXTPPropertyGrid |
GetSelectedItem() const | CXTPPropertyGrid |
GetSelectedItems(CArray< int, int > *pItems) const | CXTPPropertyGrid |
GetShowInplaceButtonsAlways() const | CXTPPropertyGrid |
GetToolBar() | CXTPPropertyGrid |
GetToolTipContext() const | CXTPPropertyGrid |
GetTopIndex() const | CXTPPropertyGrid |
GetVariableHelpHeight() const | CXTPPropertyGrid |
GetVariableSplitterPos() const | CXTPPropertyGrid |
GetVerbs() const | CXTPPropertyGrid |
GetVerbsHeight() const | CXTPPropertyGrid |
GetViewDivider() const | CXTPPropertyGrid |
HighlightChangedButtonItems(BOOL bHighlightChanged) | CXTPPropertyGrid |
HighlightChangedItems(BOOL bHighlightChanged) | CXTPPropertyGrid |
HitTest(CPoint pt) | CXTPPropertyGrid | protectedvirtual
InsertCategory(int nIndex, LPCTSTR lpszCaption, CXTPPropertyGridItem *pCategory=NULL) | CXTPPropertyGrid |
InsertCategory(int nIndex, int nID, CXTPPropertyGridItem *pCategory=NULL) | CXTPPropertyGrid |
IsBarVisible() const | CXTPPropertyGrid |
IsHelpVisible() const | CXTPPropertyGrid |
IsHighlightChangedButtonItems() const | CXTPPropertyGrid |
IsHighlightChangedItems() const | CXTPPropertyGrid |
IsLayoutRTL() const | CXTPPropertyGrid |
IsVerbsVisible() const | CXTPPropertyGrid |
m_bAllowEdit | CXTPPropertyGrid | protected
m_bEnableTooltips | CXTPPropertyGrid | protected
m_bHelpVisible | CXTPPropertyGrid | protected
m_bHideSelection | CXTPPropertyGrid |
m_bHighlightChanged | CXTPPropertyGrid | protected
m_bHighlightChangedButton | CXTPPropertyGrid | protected
m_bMultiSelect | CXTPPropertyGrid | protected
m_bPreSubclassWindow | CXTPPropertyGrid | protected
m_bShowInplaceButtonsAlways | CXTPPropertyGrid | protected
m_bTabCaptions | CXTPPropertyGrid | protected
m_bTabItems | CXTPPropertyGrid | protected
m_bToolBarVisible | CXTPPropertyGrid | protected
m_bVariableHelpHeight | CXTPPropertyGrid | protected
m_bVariableItemsHeight | CXTPPropertyGrid | protected
m_bVerbsVisible | CXTPPropertyGrid | protected
m_bViewVisible | CXTPPropertyGrid | protected
m_hCursorHand | CXTPPropertyGrid | protected
m_hCursorSplit | CXTPPropertyGrid | protected
m_nFocusedVerb | CXTPPropertyGrid | protected
m_pImageManager | CXTPPropertyGrid | protected
m_pInplaceEdit | CXTPPropertyGrid | protected
m_pInplaceListBox | CXTPPropertyGrid | protected
m_pMarkupContext | CXTPPropertyGrid | protected
m_pPaintManager | CXTPPropertyGrid | protected
m_pToolTipContext | CXTPPropertyGrid | protected
m_pVerbs | CXTPPropertyGrid | protected
m_pView | CXTPPropertyGrid | mutableprotected
m_themeCurrent | CXTPPropertyGrid | protected
m_wndToolbar | CXTPPropertyGrid | protected
NavigateItems(BOOL bTabItems, BOOL bTabCaptions=TRUE) | CXTPPropertyGrid |
OnInvertTracker(CRect rc) | CXTPPropertyGrid | protected
OnNavigate(XTPPropertyGridUI nUIElement, BOOL bForward, CXTPPropertyGridItem *pItem) | CXTPPropertyGrid | virtual
OnSelectionChanged(CXTPPropertyGridItem *pItem) | CXTPPropertyGrid | protectedvirtual
OnSortChanged() | CXTPPropertyGrid | protectedvirtual
OnVerbClick(int nIndex, CPoint pt) | CXTPPropertyGrid | virtual
OnVerbsChanged() | CXTPPropertyGrid | protected
RedrawControl() | CXTPPropertyGrid |
RefeshBindings(CXTPPropertyGridItem *pItem=NULL) | CXTPPropertyGrid | protected
Refresh() | CXTPPropertyGrid |
RefreshToolBarButtons() | CXTPPropertyGrid | protected
RegisterWindowClass(HINSTANCE hInstance=NULL) | CXTPPropertyGrid |
Reposition() | CXTPPropertyGrid |
Reposition(int cx, int cy) | CXTPPropertyGrid | protectedvirtual
ResetContent() | CXTPPropertyGrid |
SendNotifyMessage(WPARAM wParam=0, LPARAM lParam=0) | CXTPPropertyGrid | virtual
SetBorderStyle(XTPPropertyGridBorderStyle borderStyle) | CXTPPropertyGrid |
SetCustomColors(COLORREF clrHelpBack, COLORREF clrHelpFore, COLORREF clrViewLine, COLORREF clrViewBack, COLORREF clrViewFore, COLORREF clrCategoryFore=::GetSysColor(COLOR_GRAYTEXT)) | CXTPPropertyGrid |
SetCustomTheme(CXTPPropertyGridPaintManager *pPaintManager) | CXTPPropertyGrid |
SetFont(CFont *pFont) | CXTPPropertyGrid |
SetHelpHeight(int nHeight) | CXTPPropertyGrid |
SetImageManager(CXTPImageManager *pImageManager) | CXTPPropertyGrid |
SetInplaceEdit(CXTPPropertyGridInplaceEdit *pInplaceEdit) | CXTPPropertyGrid |
SetInplaceList(CXTPPropertyGridInplaceList *pInplaceList) | CXTPPropertyGrid |
SetLayoutRTL(BOOL bRightToLeft) | CXTPPropertyGrid |
SetPropertySort(XTPPropertyGridSortOrder sort) | CXTPPropertyGrid |
SetShowInplaceButtonsAlways(BOOL bShow) | CXTPPropertyGrid |
SetStandardColors() | CXTPPropertyGrid |
SetTheme(XTPPropertyGridPaintTheme paintTheme) | CXTPPropertyGrid |
SetTopIndex(int nIndex) | CXTPPropertyGrid |
SetVariableHelpHeight(BOOL bVariable) | CXTPPropertyGrid |
SetVariableItemsHeight(BOOL bVariable=TRUE) | CXTPPropertyGrid |
SetVariableSplitterPos(BOOL bVariable) | CXTPPropertyGrid |
SetVerbsHeight(int nHeight) | CXTPPropertyGrid |
SetViewDivider(double dDivider) | CXTPPropertyGrid |
SetViewDividerPos(int nDivider, BOOL bLockDivider=FALSE) | CXTPPropertyGrid |
ShowHelp(BOOL bShow=TRUE) | CXTPPropertyGrid |
ShowToolBar(BOOL bShow=TRUE) | CXTPPropertyGrid |
ShowView(BOOL bShow=TRUE) | CXTPPropertyGrid |
~CXTPPropertyGrid() | CXTPPropertyGrid | virtual


Toolkit Pro: XTPChartTransformationDeviceCommand.h Source File

  • Source
  • Chart
  • Drawing
XTPChartTransformationDeviceCommand.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTTRANSFORMATIONDEVICECOMMAND_H__)
24# define __XTPCHARTTRANSFORMATIONDEVICECOMMAND_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
37class _XTP_EXT_CLASS CXTPChartClipDeviceCommand : public CXTPChartDeviceCommand
38{
39protected:
45 CXTPChartClipDeviceCommand(CRect rcClip);
46
47protected:
48 CRect m_rcClip;
49};
50
55class _XTP_EXT_CLASS CXTPChartRotateDeviceCommand : public CXTPChartDeviceCommand
56{
57protected:
64 CXTPChartRotateDeviceCommand(float fAngle);
72 CXTPChartRotateDeviceCommand(float fAngle, const CXTPPoint3d& rotateVector);
73
84 CXTPChartElement* HitTest(CPoint point, CXTPChartElement* pParent) const;
85
86protected:
87 float m_fAngle;
88 CXTPPoint3d m_ptRotateVector;
89};
90
95class _XTP_EXT_CLASS CXTPChart3dRotateDeviceCommand : public CXTPChart3dDeviceCommand
96{
97public:
104 CXTPChart3dRotateDeviceCommand(const CXTPChart3dRotation& rotation);
105
116 CXTPChartElement* HitTest(CPoint point, CXTPChartElement* pParent) const;
117
118protected:
119 CXTPChart3dRotation m_rotation;
120};
121
126class _XTP_EXT_CLASS CXTPChartTranslateDeviceCommand : public CXTPChartDeviceCommand
127{
128public:
136 CXTPChartTranslateDeviceCommand(double dx, double dy);
137
138protected:
139 double m_dx;
140 double m_dy;
141};
142
147class _XTP_EXT_CLASS CXTPChart3dTranslateDeviceCommand : public CXTPChart3dDeviceCommand
148{
149public:
158 CXTPChart3dTranslateDeviceCommand(double dx, double dy, double dz);
159
160protected:
161 double m_dx;
162 double m_dy;
163 double m_dz;
164};
166# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
167#endif //#if !defined(__XTPCHARTTRANSFORMATIONDEVICECOMMAND_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChart3dDeviceCommand
Defines a common implementation interface for chart 3D drawing commands.
Definition XTPChartDeviceCommand.h:368
CXTPChart3dRotateDeviceCommand
Base class implementation for 3D chart rotation device command.
Definition XTPChartTransformationDeviceCommand.h:96
CXTPChart3dRotateDeviceCommand::CXTPChart3dRotateDeviceCommand
CXTPChart3dRotateDeviceCommand(const CXTPChart3dRotation &rotation)
Constructs a CXTPChart3dRotateDeviceCommand object.
CXTPChart3dRotateDeviceCommand::HitTest
CXTPChartElement * HitTest(CPoint point, CXTPChartElement *pParent) const
Performs recursive hit testing of the element at the specified point.
CXTPChart3dRotateDeviceCommand::m_rotation
CXTPChart3dRotation m_rotation
Rotation parameters.
Definition XTPChartTransformationDeviceCommand.h:119
CXTPChart3dRotation
Represents a 3D rotation primitive for chart objects using Euler angles Yaw, Pitch and Roll in degree...
Definition XTPChartTypes.h:639
CXTPChart3dTranslateDeviceCommand
Base class implementation for 3D chart translation device command.
Definition XTPChartTransformationDeviceCommand.h:148
CXTPChart3dTranslateDeviceCommand::CXTPChart3dTranslateDeviceCommand
CXTPChart3dTranslateDeviceCommand(double dx, double dy, double dz)
Constructs a CXTPChartTranslateDeviceCommand object.
CXTPChart3dTranslateDeviceCommand::m_dz
double m_dz
The change in Z direction.
Definition XTPChartTransformationDeviceCommand.h:163
CXTPChart3dTranslateDeviceCommand::m_dx
double m_dx
The change in X direction.
Definition XTPChartTransformationDeviceCommand.h:161
CXTPChart3dTranslateDeviceCommand::m_dy
double m_dy
The change in Y direction.
Definition XTPChartTransformationDeviceCommand.h:162
CXTPChartClipDeviceCommand
Base class implementation for 2D chart clipping device command.
Definition XTPChartTransformationDeviceCommand.h:38
CXTPChartClipDeviceCommand::m_rcClip
CRect m_rcClip
The clipping rectangle.
Definition XTPChartTransformationDeviceCommand.h:48
CXTPChartClipDeviceCommand::CXTPChartClipDeviceCommand
CXTPChartClipDeviceCommand(CRect rcClip)
Constructs a CXTPChartClipDeviceCommand object.
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPChartElement
This class abstracts a chart element, this class acts as a base class for all chart elements.
Definition XTPChartElement.h:131
CXTPChartRotateDeviceCommand
Base class implementation for 2D chart rotation device command.
Definition XTPChartTransformationDeviceCommand.h:56
CXTPChartRotateDeviceCommand::CXTPChartRotateDeviceCommand
CXTPChartRotateDeviceCommand(float fAngle)
Constructs a CXTPChartRotateDeviceCommand object.
CXTPChartRotateDeviceCommand::HitTest
CXTPChartElement * HitTest(CPoint point, CXTPChartElement *pParent) const
Performs recursive hit testing of the element at the specified point.
CXTPChartRotateDeviceCommand::m_fAngle
float m_fAngle
The angle of rotation.
Definition XTPChartTransformationDeviceCommand.h:87
CXTPChartRotateDeviceCommand::m_ptRotateVector
CXTPPoint3d m_ptRotateVector
The rotation vector.
Definition XTPChartTransformationDeviceCommand.h:88
CXTPChartRotateDeviceCommand::CXTPChartRotateDeviceCommand
CXTPChartRotateDeviceCommand(float fAngle, const CXTPPoint3d &rotateVector)
Constructs a CXTPChartRotateDeviceCommand object.
CXTPChartTranslateDeviceCommand
Base class implementation for 2D chart translation device command.
Definition XTPChartTransformationDeviceCommand.h:127
CXTPChartTranslateDeviceCommand::CXTPChartTranslateDeviceCommand
CXTPChartTranslateDeviceCommand(double dx, double dy)
Constructs a CXTPChartTranslateDeviceCommand object.
CXTPChartTranslateDeviceCommand::m_dx
double m_dx
The change in X direction.
Definition XTPChartTransformationDeviceCommand.h:139
CXTPChartTranslateDeviceCommand::m_dy
double m_dy
The change in Y direction.
Definition XTPChartTransformationDeviceCommand.h:140
CXTPPoint3T< double >


Toolkit Pro: Member List

CXTPChartRectangleDeviceCommand Member List

This is the complete list of members for CXTPChartRectangleDeviceCommand, including all inherited members.

AddChildCommand(CXTPChartDeviceCommand *pCommand) | CXTPChartDeviceCommand |
AfterExecute(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
ApplySeriesStyle(CXTPChartSeriesStyle *pStyle) | CXTPChartDeviceCommand | virtual
BeforeExecute(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
BindView(CXTPChartElementView *pView) | CXTPChartDeviceCommand |
Commit() | CXTPChartDeviceCommand |
CXTPChartDeviceCommand() | CXTPChartDeviceCommand |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartRectangleDeviceCommand(const CXTPChartRectF &rect) | CXTPChartRectangleDeviceCommand | protected
CXTPObservable() | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | protected
Execute(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
ExecuteOverride(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
GetBoundView() const | CXTPChartDeviceCommand |
GetChildCommand(int nIndex) const | CXTPChartDeviceCommand |
GetChildCommandCount() const | CXTPChartDeviceCommand |
GetCurrentDC() const | CXTPChartDeviceCommand |
GetPassNumber() const | CXTPChartDeviceCommand |
HitTest(CPoint point, CXTPChartElement *pParent) const | CXTPChartRectangleDeviceCommand | protectedvirtual
Is3D() const | CXTPChartObject |
IsCommitted() const | CXTPChartDeviceCommand |
IsEnabled() const | CXTPChartDeviceCommand | virtual
m_arrChildren | CXTPChartDeviceCommand | protected
m_rect | CXTPChartRectangleDeviceCommand | protected
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Prepare(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
PrepareOverride(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
SetEnabled(BOOL bEnabled=TRUE) | CXTPChartDeviceCommand |
Subscribe(CXTPChartDeviceCommandEvents *pObserver, CXTPSubscriptionList< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > *pSubcriptionList=NULL) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > |
Unsubscribe(CXTPChartDeviceCommandEvents *pObserver) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > |
~CXTPChartDeviceCommand() | CXTPChartDeviceCommand | virtual
~CXTPObservable() | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | protected


Toolkit Pro: XTPCalendarMAPIWrapper.h Source File

  • Source
  • Calendar
XTPCalendarMAPIWrapper.h
Go to the documentation of this file.
1
22#ifndef _XTP_INCLUDE_CALENDAR_MAPI
23# error Use _XTP_INCLUDE_CALENDAR_MAPI to enable Calendar MAPI support.
24#else
25
26# if !defined(__XTPCALENDARMAPIWRAPPER_H__)
27# define __XTPCALENDARMAPIWRAPPER_H__
28
29# if _MSC_VER > 1000
30# pragma once
31# endif // _MSC_VER > 1000
32
33# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
34
35# define TYPEDEF_WRAPPER_POINTER(val, type, proc) \
36 const int xtpWrapper##proc = val; \
37 const LPCSTR xtpWrapperProc##proc = #proc; \
38 typedef type(__stdcall* PFN##proc)
39
40# define TYPEDEF_WRAPPER_PTR_NUM(val, type, proc, num) \
41 const int xtpWrapper##proc = val; \
42 const LPCSTR xtpWrapperProc##proc = #proc "@" #num; \
43 typedef type(__stdcall* PFN##proc)
44
45TYPEDEF_WRAPPER_POINTER(0, HRESULT, MAPIInitialize)(LPVOID);
46TYPEDEF_WRAPPER_POINTER(1, void, MAPIUninitialize)();
47TYPEDEF_WRAPPER_POINTER(2, HRESULT, MAPILogonEx)(ULONG, LPTSTR, LPTSTR, FLAGS, LPMAPISESSION FAR*);
48TYPEDEF_WRAPPER_POINTER(3, ULONG, MAPIFreeBuffer)(LPVOID);
49TYPEDEF_WRAPPER_PTR_NUM(4, ULONG, UlRelease, 4)(LPVOID);
50TYPEDEF_WRAPPER_PTR_NUM(5, void, FreeProws, 4)(LPSRowSet);
51TYPEDEF_WRAPPER_PTR_NUM(6, HRESULT, HrQueryAllRows, 24)
52(LPMAPITABLE, LPSPropTagArray, LPSRestriction, LPSSortOrderSet, LONG, LPSRowSet FAR*);
53TYPEDEF_WRAPPER_PTR_NUM(7, HRESULT, HrGetOneProp, 12)(LPMAPIPROP, ULONG, LPSPropValue FAR*);
54TYPEDEF_WRAPPER_PTR_NUM(8, HRESULT, HrSetOneProp, 8)(LPMAPIPROP, LPSPropValue);
55TYPEDEF_WRAPPER_POINTER(9, SCODE, MAPIAllocateBuffer)(ULONG, LPVOID FAR*);
56TYPEDEF_WRAPPER_PTR_NUM(10, HRESULT, HrThisThreadAdviseSink, 8)
57(LPMAPIADVISESINK, LPMAPIADVISESINK FAR*);
58TYPEDEF_WRAPPER_PTR_NUM(11, HRESULT, HrAllocAdviseSink, 12)
59(LPNOTIFCALLBACK, LPVOID, LPMAPIADVISESINK FAR*);
60
65class _XTP_EXT_CLASS CXTPCalendarMAPIWrapper
66{
67public:
72 CXTPCalendarMAPIWrapper();
73
79 virtual ~CXTPCalendarMAPIWrapper();
80
82 // Wrapped methods
83
95 HRESULT MAPIInitialize(LPVOID lpMapiInit);
96
102 void MAPIUninitialize();
103
131 HRESULT MAPILogonEx(ULONG ulUIParam, LPTSTR lpszProfileName, LPTSTR lpszPassword, FLAGS flFlags,
132 LPMAPISESSION FAR* lppSession);
133
146 ULONG MAPIFreeBuffer(LPVOID lpBuffer);
147
159 ULONG UlRelease(LPVOID punk);
160
168 void FreeProws(LPSRowSet prows);
169
200 HRESULT HrQueryAllRows(LPMAPITABLE ptable, LPSPropTagArray ptaga, LPSRestriction pres,
201 LPSSortOrderSet psos, LONG crowsMax, LPSRowSet FAR* pprows);
202
217 HRESULT HrGetOneProp(LPMAPIPROP pmp, ULONG ulPropTag, LPSPropValue FAR* ppprop);
218
232 HRESULT HrSetOneProp(LPMAPIPROP pmp, LPSPropValue pprop);
233
244 SCODE MAPIAllocateBuffer(ULONG cbSize, LPVOID FAR* lppBuffer);
245
259 HRESULT HrThisThreadAdviseSink(LPMAPIADVISESINK lpAdviseSink,
260 LPMAPIADVISESINK FAR* lppAdviseSink);
261
283 HRESULT HrAllocAdviseSink(LPNOTIFCALLBACK lpfnCallback, LPVOID lpvContext,
284 LPMAPIADVISESINK FAR* lppAdviseSink);
285
286private:
287 LPVOID m_ptrWrappers[12];
288 HMODULE m_hMapiDll;
289};
290
292
293# endif // !defined(__XTPCALENDARMAPIWRAPPER_H__)
294
295# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
296#endif
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h


Toolkit Pro: XTPFrameShadow.h Source File

  • Source
  • Common
  • FrameShadow
XTPFrameShadow.h
Go to the documentation of this file.
1
23#if !defined(__XTPFRAMESHADOW_H__)
24# define __XTPFRAMESHADOW_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPFrameShadowManager;
34
44class _XTP_EXT_CLASS CXTPFrameShadow
45 : public CWnd
46 , IXTPFrameShadowManagerEvents
47{
48 DECLARE_DYNAMIC(CXTPFrameShadow)
49 friend class CXTPFrameShadowManager;
50
51 using CWnd::Create;
52
53public:
59 explicit CXTPFrameShadow(HWND hOwner);
60
65 virtual ~CXTPFrameShadow();
66
73 static BOOL AFX_CDECL IsShadowSupported();
74
91 BOOL Create(COLORREF crColor, UINT nOuterSize, UINT nInnerSize = 0,
92 CPoint ptOffset = CPoint(0, 0), BYTE bTransparency = 0x80);
93
101 void FreezeUpdates(BOOL bFreeze = TRUE);
102
111 BOOL IsCreated() const;
112
119 HWND GetOwner() const;
120
129 UINT GetOuterSize() const;
130
138 void SetOuterSize(UINT nSize);
139
148 UINT GetInnerSize() const;
149
157 void SetInnerSize(UINT nSize);
158
167 CPoint GetOffset() const;
168
176 void SetOffset(CPoint ptOffset);
177
186 COLORREF GetColor() const;
187
195 void SetColor(COLORREF crColor);
196
205 BYTE GetTransparency() const;
206
214 void SetTransparency(BYTE bTransparency);
215
235 UINT GetBlendingOptions(OUT OPTIONAL float* pFactors, OUT OPTIONAL float* pPositions) const;
236
255 void SetBlendingOptions(UINT nCount, const float* pFactors, const float* pPositions);
256
268 BOOL GetClipOwner() const;
269
280 void SetClipOwner(BOOL bClipOwner);
281
292 void Show();
293
304 void Hide();
305
310 void UpdatePosition();
311
313 BOOL IsIconic() const;
314 void OnRestore();
315 void OnOwnersStyleChanged(DWORD oldStyle, DWORD newStyle);
318protected:
319 DECLARE_MESSAGE_MAP();
320 afx_msg void OnPaint();
321 afx_msg void OnDestroy();
322 afx_msg void OnTimer(UINT_PTR nIDEvent);
323 afx_msg BOOL OnSetCursor(CWnd* pWnd, UINT nHitTest, UINT message);
324 afx_msg void OnLButtonDown(UINT nFlags, CPoint point);
325 afx_msg int OnMouseActivate(CWnd* pDesktopWnd, UINT nHitTest, UINT message);
326
327 virtual void OnFinalRelease();
328
329 virtual void OnFlagsChanged(CXTPFrameShadowManager* pManager, int nOldEffectiveFlags,
330 int nNewEffectiveFlags);
331
332 enum HitTestResult
333 {
334 NoHit,
335 HitTop,
336 HitTopRight,
337 HitRight,
338 HitBottomRight,
339 HitBottom,
340 HitBottomLeft,
341 HitLeft,
342 HitTopLeft
343 };
344
345 void LoadDefaults();
346 void ComputeData();
347 void SetDefaultBackgroundBlendingOptions();
348 void Update(BOOL bReposition, BOOL bRedraw = TRUE);
349 BOOL IsSizingAllowed() const;
350 CSize GetOwnerMinTrackSize() const;
351 CPoint GetDraggingInitialOffset(HitTestResult nHitTest, CPoint ptStart) const;
352 HitTestResult HitTest(CPoint point) const;
353 void Drag(HitTestResult nHitTest, CPoint ptOffset, CSize szMinSize);
354 CRect GetClipRect() const;
355
356 typedef BOOL(WINAPI* PFNUpdateLayeredWindow)(HWND hWnd, HDC hdcDst, POINT* pptDst, SIZE* psize,
357 HDC hdcSrc, POINT* pptSrc, COLORREF crKey,
358 BLENDFUNCTION* pBlend, DWORD dwFlags);
359
360 static PFNUpdateLayeredWindow m_pfnUpdateLayeredWindow;
361 static BOOL m_bSupportTested;
362
363 HWND m_hOwner;
364 BOOL m_bCreated;
365 BOOL m_bVisible;
366 UINT m_nOuterSize;
367 UINT m_nInnerSize;
368 CPoint m_ptOffset;
369 COLORREF m_crColor;
370 BYTE m_bTransparency;
371 BOOL m_bPendingUpdate;
372 BOOL m_bIsIconic;
373 int m_bFreezeUpdatesCounter;
374 BOOL m_bSizingAllowed;
375 BOOL m_bClipOwner;
376 BOOL m_bBeingUpdated;
377
378 struct BlendingOptions
379 {
380 CArray<float, const float&> Factors;
381 CArray<float, const float&> Positions;
382 CArray<float, const float&> CornerFactors;
383 CArray<float, const float&> CornerPositions;
384 CArray<float, const float&> BackgroundFactors;
385 CArray<float, const float&> BackgroundPositions;
386 } m_BlendingOptions;
387
388 struct PreComputedData;
389 PreComputedData* m_pPCD;
390
391private:
392# ifdef _XTP_ACTIVEX
395 DECLARE_DISPATCH_MAP()
396 DECLARE_INTERFACE_MAP()
397 XTP_DECLARE_CMDTARGETPROVIDER_INTERFACE()
398
399 DECLARE_OLETYPELIB_EX(CXTPFrameShadow);
400
401 afx_msg OLE_HANDLE OleGetOwner();
402 afx_msg void OleSetOuterSize(long size);
403 afx_msg long OleGetOuterSize();
404 afx_msg void OleSetInnerSize(long size);
405 afx_msg long OleGetInnerSize();
406 afx_msg OLE_XSIZE_PIXELS OleGetOffsetX();
407 afx_msg void OleSetOffsetX(OLE_XSIZE_PIXELS offset);
408 afx_msg OLE_YSIZE_PIXELS OleGetOffsetY();
409 afx_msg void OleSetOffsetY(OLE_YSIZE_PIXELS offset);
410 afx_msg OLE_COLOR OleGetColor();
411 afx_msg void OleSetColor(OLE_COLOR color);
412 afx_msg short OleGetTransparency();
413 afx_msg void OleSetTransparency(short val);
414 afx_msg BOOL OleGetClipOwner();
415 afx_msg void OleSetClipOwner(BOOL bClip);
416 afx_msg VARIANT OleGetBlendingFactors();
417 afx_msg VARIANT OleGetBlendingPositions();
418 afx_msg void OleFreezeUpdates(VARIANT_BOOL bFreeze);
419 afx_msg void OleShow();
420 afx_msg void OleHide();
421 afx_msg void OleUpdatePosition();
422 afx_msg void OleSetBlendingOptions(VARIANT factors, VARIANT positions);
424# endif
425};
427AFX_INLINE BOOL CXTPFrameShadow::IsCreated() const
428{
429 return m_bCreated;
430}
431
432AFX_INLINE HWND CXTPFrameShadow::GetOwner() const
433{
434 return m_hOwner;
435}
436
437AFX_INLINE UINT CXTPFrameShadow::GetInnerSize() const
438{
439 return m_nInnerSize;
440}
441
442AFX_INLINE UINT CXTPFrameShadow::GetOuterSize() const
443{
444 return m_nOuterSize;
445}
446
447AFX_INLINE CPoint CXTPFrameShadow::GetOffset() const
448{
449 return m_ptOffset;
450}
451
452AFX_INLINE COLORREF CXTPFrameShadow::GetColor() const
453{
454 return m_crColor;
455}
456
457AFX_INLINE BYTE CXTPFrameShadow::GetTransparency() const
458{
459 return m_bTransparency;
460}
461
462AFX_INLINE BOOL CXTPFrameShadow::IsIconic() const
463{
464 return m_bIsIconic;
465}
466
467AFX_INLINE BOOL CXTPFrameShadow::GetClipOwner() const
468{
469 return m_bClipOwner;
470}
472# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
474#endif // !defined(__XTPFRAMESHADOW_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTP_DECLARE_CMDTARGETPROVIDER_INTERFACE
#define XTP_DECLARE_CMDTARGETPROVIDER_INTERFACE()
When deriving from CXTPCmdTarget is not possible this macro can be used in addition to standard DECLA...
Definition XTPFramework.h:89
CXTPFrameShadow
The class represents frame shadow object.
Definition XTPFrameShadow.h:47
CXTPFrameShadow::GetBlendingOptions
UINT GetBlendingOptions(OUT OPTIONAL float *pFactors, OUT OPTIONAL float *pPositions) const
Obtains shadow blending options.
CXTPFrameShadow::Hide
void Hide()
Hides frame shadow if not visible.
CXTPFrameShadow::~CXTPFrameShadow
virtual ~CXTPFrameShadow()
Handles frame shadow deallocation.
CXTPFrameShadow::SetInnerSize
void SetInnerSize(UINT nSize)
Sets the value of the inner size.
CXTPFrameShadow::UpdatePosition
void UpdatePosition()
Updates shadow position and redraws it if necessary.
CXTPFrameShadow::GetColor
COLORREF GetColor() const
Obtains color value.
CXTPFrameShadow::IsCreated
BOOL IsCreated() const
Determines if the shadows has been created.
CXTPFrameShadow::SetOuterSize
void SetOuterSize(UINT nSize)
Sets the value of the outer size.
CXTPFrameShadow::SetColor
void SetColor(COLORREF crColor)
Sets color value.
CXTPFrameShadow::CXTPFrameShadow
CXTPFrameShadow(HWND hOwner)
Constructs frame shadow object.
CXTPFrameShadow::GetInnerSize
UINT GetInnerSize() const
Obtains the value of the inner size.
CXTPFrameShadow::GetOuterSize
UINT GetOuterSize() const
Obtains the value of the outer size.
CXTPFrameShadow::SetTransparency
void SetTransparency(BYTE bTransparency)
Sets transparency value.
CXTPFrameShadow::SetBlendingOptions
void SetBlendingOptions(UINT nCount, const float *pFactors, const float *pPositions)
Sets shadow blending options.
CXTPFrameShadow::FreezeUpdates
void FreezeUpdates(BOOL bFreeze=TRUE)
Freezes/unfreezes updates on changing shadow settings, as a result shadow blinking is reduced.
CXTPFrameShadow::GetOffset
CPoint GetOffset() const
Obtains offset value.
CXTPFrameShadow::SetOffset
void SetOffset(CPoint ptOffset)
Sets offset value.
CXTPFrameShadow::SetClipOwner
void SetClipOwner(BOOL bClipOwner)
Sets owner clipping for the current shadow only.
CXTPFrameShadow::GetOwner
HWND GetOwner() const
Obtains an owning window pointer.
CXTPFrameShadow::GetClipOwner
BOOL GetClipOwner() const
Obtains owner clipping for the current shadow only.
CXTPFrameShadow::GetTransparency
BYTE GetTransparency() const
Obtains transparency value.
CXTPFrameShadow::OnFlagsChanged
virtual void OnFlagsChanged(CXTPFrameShadowManager *pManager, int nOldEffectiveFlags, int nNewEffectiveFlags)
Invoked when flags are changed.
CXTPFrameShadow::Show
void Show()
Shows frame shadow if not visible.
CXTPFrameShadow::Create
BOOL Create(COLORREF crColor, UINT nOuterSize, UINT nInnerSize=0, CPoint ptOffset=CPoint(0, 0), BYTE bTransparency=0x80)
Creates frame shadow and initializes it with initial parameters.
CXTPFrameShadow::IsShadowSupported
static BOOL AFX_CDECL IsShadowSupported()
Determines if frame shadows are supported by the platform.
CXTPFrameShadowManager
Provides frame shadow management functionality.
Definition XTPFrameShadowManager.h:147
IXTPFrameShadowManagerEvents
An interface for Frame Shadow Manager event listener.
Definition XTPFrameShadowManager.h:80


Toolkit Pro: Member List

CXTPGridHeaderDragWnd Member List

This is the complete list of members for CXTPGridHeaderDragWnd, including all inherited members.

Create(CRect rect, CXTPGridHeader *pHeader, CXTPGridPaintManager *pPaintManager, CXTPGridColumn *pColumn) | CXTPGridHeaderDragWnd | virtual
CXTPGridHeaderDragWnd() | CXTPGridHeaderDragWnd |
m_pColumn | CXTPGridHeaderDragWnd | protected
m_pHeader | CXTPGridHeaderDragWnd | protected
m_pPaintManager | CXTPGridHeaderDragWnd | protected
OnDraw(CDC *pDC, CRect rcClient) | CXTPGridHeaderDragWnd | protectedvirtual
~CXTPGridHeaderDragWnd() | CXTPGridHeaderDragWnd | virtual


Toolkit Pro: XTPBeginAfxMap.h Source File

  • Source
  • Common
  • Base
  • Diagnostic
XTPBeginAfxMap.h
Go to the documentation of this file.
1
24#ifndef XTP_AFX_MAP_INCLUSION_CONTROL
25# define XTP_AFX_MAP_INCLUSION_CONTROL
26
27// C4619: #pragma warning: there is no warning number '...'
28// C4616: #pragma warning : warning number '...' out of range, must be between '4001' and '4999'
29// C4191: 'type cast' : unsafe conversion from '...' to 'AFX_PMSGW'
30// C5246: '...': the initialization of a subobject should be wrapped in braces
31// C5204: '...': class has virtual functions, but its trivial destructor is not virtual; instances
32// of objects derived from this class may not be destructed correctly
33# pragma warning(push)
34# pragma warning(disable : 4619 4616 4191 5246 5204)
35#else
36# error "Common/Base/Diagnostic/XTPEndAfxMap.h" inclusion is missing
37#endif
38


Toolkit Pro: Member List

CXTPFrameShadowManager Member List

This is the complete list of members for CXTPFrameShadowManager, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPObservable() | CXTPObservable< CXTPFrameShadowManager, IXTPFrameShadowManagerEvents > | protected
DisableShadow(HWND hWnd) | CXTPFrameShadowManager |
DisableShadow(CWnd *pWnd) | CXTPFrameShadowManager |
EnableShadow(CWnd *pWnd, COLORREF crColor=(COLORREF) -1, UINT nOuterSize=0, UINT nInnerSize=0, CPoint ptOffset=CPoint(0, 0), BYTE bTransparency=0) | CXTPFrameShadowManager |
EnableShadow(HWND hWnd, COLORREF crColor=(COLORREF) -1, UINT nOuterSize=0, UINT nInnerSize=0, CPoint ptOffset=CPoint(0, 0), BYTE bTransparency=0) | CXTPFrameShadowManager |
FreezeUpdates(BOOL bFreeze=TRUE) | CXTPFrameShadowManager |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetDefaultBlendingOptions(OUT OPTIONAL float *pFactors, OUT OPTIONAL float *pPositions) const | CXTPFrameShadowManager |
GetDefaultClipOwner() const | CXTPFrameShadowManager |
GetDefaultColor() const | CXTPFrameShadowManager |
GetDefaultInnerSize() const | CXTPFrameShadowManager |
GetDefaultOffset() const | CXTPFrameShadowManager |
GetDefaultOuterSize() const | CXTPFrameShadowManager |
GetDefaultTransparency() const | CXTPFrameShadowManager |
GetFirstShadowPosition() const | CXTPFrameShadowManager |
GetFlags() const | CXTPFrameShadowManager |
GetNextShadow(POSITION &pos) const | CXTPFrameShadowManager |
GetShadow(HWND hWnd) const | CXTPFrameShadowManager |
GetShadow(CWnd *pWnd) const | CXTPFrameShadowManager |
IsShadowEnabled(CWnd *pWnd) const | CXTPFrameShadowManager |
IsShadowSupported() const | CXTPFrameShadowManager |
Notify(void(IXTPFrameShadowManagerEvents::*method)(CXTPFrameShadowManager *)) | CXTPObservable< CXTPFrameShadowManager, IXTPFrameShadowManagerEvents > | inline
Notify(void(IXTPFrameShadowManagerEvents::*method)(CXTPFrameShadowManager *, A1), A1 arg1) | CXTPObservable< CXTPFrameShadowManager, IXTPFrameShadowManagerEvents > | inline
Notify(void(IXTPFrameShadowManagerEvents::*method)(CXTPFrameShadowManager *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPFrameShadowManager, IXTPFrameShadowManagerEvents > | inline
Notify(void(IXTPFrameShadowManagerEvents::*method)(CXTPFrameShadowManager *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPFrameShadowManager, IXTPFrameShadowManagerEvents > | inline
NotifyDynamic(void(T::*method)(O *)) | CXTPObservable< CXTPFrameShadowManager, IXTPFrameShadowManagerEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1), A1 arg1) | CXTPObservable< CXTPFrameShadowManager, IXTPFrameShadowManagerEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPFrameShadowManager, IXTPFrameShadowManagerEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPFrameShadowManager, IXTPFrameShadowManagerEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *)) | CXTPObservable< CXTPFrameShadowManager, IXTPFrameShadowManagerEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1), A1 arg1) | CXTPObservable< CXTPFrameShadowManager, IXTPFrameShadowManagerEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPFrameShadowManager, IXTPFrameShadowManagerEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPFrameShadowManager, IXTPFrameShadowManagerEvents > | inline
NotifyReversed(void(IXTPFrameShadowManagerEvents::*method)(CXTPFrameShadowManager *)) | CXTPObservable< CXTPFrameShadowManager, IXTPFrameShadowManagerEvents > | inline
NotifyReversed(void(IXTPFrameShadowManagerEvents::*method)(CXTPFrameShadowManager *, A1), A1 arg1) | CXTPObservable< CXTPFrameShadowManager, IXTPFrameShadowManagerEvents > | inline
NotifyReversed(void(IXTPFrameShadowManagerEvents::*method)(CXTPFrameShadowManager *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPFrameShadowManager, IXTPFrameShadowManagerEvents > | inline
NotifyReversed(void(IXTPFrameShadowManagerEvents::*method)(CXTPFrameShadowManager *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPFrameShadowManager, IXTPFrameShadowManagerEvents > | inline
SetDefaultBlendingOptions(UINT nCount, const float *pFactors, const float *pPositions) | CXTPFrameShadowManager |
SetDefaultClipOwner(BOOL bClipOwner) | CXTPFrameShadowManager |
SetDefaultColor(COLORREF crColor) | CXTPFrameShadowManager |
SetDefaultInnerSize(UINT nSize) | CXTPFrameShadowManager |
SetDefaultOffset(CPoint ptOffset) | CXTPFrameShadowManager |
SetDefaultOuterSize(UINT nSize) | CXTPFrameShadowManager |
SetDefaultTransparency(BYTE bTransparency) | CXTPFrameShadowManager |
SetFlags(int nFlags) | CXTPFrameShadowManager |
SetGlobalBlendingOptions(UINT nCount, const float *pFactors, const float *pPositions) | CXTPFrameShadowManager |
SetGlobalClipOwner(BOOL bClipOwner) | CXTPFrameShadowManager |
SetGlobalColor(COLORREF crColor) | CXTPFrameShadowManager |
SetGlobalInnerSize(UINT nSize) | CXTPFrameShadowManager |
SetGlobalOffset(CPoint ptOffset) | CXTPFrameShadowManager |
SetGlobalOuterSize(UINT nSize) | CXTPFrameShadowManager |
SetGlobalTransparency(BYTE bTransparency) | CXTPFrameShadowManager |
Subscribe(IXTPFrameShadowManagerEvents *pObserver, CXTPSubscriptionList< CXTPFrameShadowManager, IXTPFrameShadowManagerEvents > *pSubcriptionList=NULL) | CXTPObservable< CXTPFrameShadowManager, IXTPFrameShadowManagerEvents > |
Unsubscribe(IXTPFrameShadowManagerEvents *pObserver) | CXTPObservable< CXTPFrameShadowManager, IXTPFrameShadowManagerEvents > |
~CXTPObservable() | CXTPObservable< CXTPFrameShadowManager, IXTPFrameShadowManagerEvents > | protected


Toolkit Pro: Member List

CXTPCustomizeToolbarsPage Member List

This is the complete list of members for CXTPCustomizeToolbarsPage, including all inherited members.

AdjustResizeRect(CSize &rcWindow) | CXTPResize | protectedvirtual
AllowNewToolbars(BOOL bEnable) | CXTPCustomizeToolbarsPage |
AutoLoadPlacement(LPCTSTR pszSection) | CXTPResize |
CResizeItemArray typedef | CXTPResize | protected
CXTPCustomizeToolbarsPage(CXTPCustomizeSheet *pSheet=NULL) | CXTPCustomizeToolbarsPage |
CXTPPropertyPage() | CXTPPropertyPage |
CXTPPropertyPage(UINT nIDTemplate, UINT nIDCaption=0) | CXTPPropertyPage |
CXTPPropertyPage(LPCTSTR lpszTemplateName, UINT nIDCaption=0) | CXTPPropertyPage |
CXTPResize(CWnd *pWnd, const UINT nFlags=0) | CXTPResize |
Defer(HDWP &hdwp, CXTPResizeItem *pItem, int dx, int dy) | CXTPResize | protectedvirtual
GetCaption() const | CXTPPropertyPage |
GetMinMaxInfo(MINMAXINFO *pMMI) | CXTPResize | protected
HasFlag(XTPResize eFlag) | CXTPResize | protected
IDD enum value | CXTPCustomizeToolbarsPage |
Init() | CXTPResize | protectedvirtual
LoadPlacement(LPCTSTR pszSection) | CXTPResize |
m_arrItems | CXTPResize | protected
m_bAllowNewToolbars | CXTPCustomizeToolbarsPage | protected
m_bModified | CXTPPropertyPage | protected
m_btnDelete | CXTPCustomizeToolbarsPage |
m_btnNew | CXTPCustomizeToolbarsPage |
m_btnRename | CXTPCustomizeToolbarsPage |
m_btnReset | CXTPCustomizeToolbarsPage |
m_checkList | CXTPCustomizeToolbarsPage |
m_dwData | CXTPPropertyPage |
m_nFlagsXX | CXTPResize | protected
m_pSheet | CXTPCustomizeToolbarsPage |
m_pWnd | CXTPResize | protected
m_scSizeIcon | CXTPResize | protected
m_strSection | CXTPResize | protected
m_szInitWindow | CXTPResize | protected
m_szMax | CXTPResize | protected
m_szMin | CXTPResize | protected
m_szWindow | CXTPResize | protected
Offset(CPoint ptOffset) | CXTPResize | protected
RemoveAllControls() | CXTPResize | protected
RemoveResize(UINT nID) | CXTPResize | protected
Reset() | CXTPResize | protected
SavePlacement(LPCTSTR pszSection) | CXTPResize |
SetCaption(LPCTSTR lpszCaption) | CXTPPropertyPage |
SetFlag(XTPResize eFlag) | CXTPResize | protected
SetMaxSize(CSize &sz) | CXTPResize |
SetMinSize(CSize &sz) | CXTPResize |
SetResize(UINT nID, XTP_RESIZE left, XTP_RESIZE top, XTP_RESIZE right, XTP_RESIZE bottom) | CXTPResize |
SetResize(UINT nID, const XTP_RESIZERECT &rrcSizing) | CXTPResize |
SetResize(UINT nID, HWND hWnd, const XTP_RESIZERECT &rrcSizing) | CXTPResize |
SetResize(UINT nID, HWND hWnd, const XTP_RESIZEPOINT &rpTopLeft, const XTP_RESIZEPOINT &rpBottomRight) | CXTPResize |
SetResize(UINT nID, const XTP_RESIZEPOINT &rpTopLeft, const XTP_RESIZEPOINT &rpBottomRight) | CXTPResize |
SetResize(CWnd *pWnd, const CXTPResizeRect &rrcSizing, CRect rcWindow) | CXTPResize | protected
Size() | CXTPResize | protectedvirtual
UpdateControlRect(CWnd *pWnd) | CXTPResize | protected
UpdatePage(void) | CXTPPropertyPage | virtual
~CXTPCustomizeToolbarsPage() | CXTPCustomizeToolbarsPage |
~CXTPPropertyPage() | CXTPPropertyPage |
~CXTPResize() | CXTPResize | virtual


Toolkit Pro: Member List

CXTPListBox Member List

This is the complete list of members for CXTPListBox, including all inherited members.

CXTPListBox() | CXTPListBox |
GetBackColor() | CXTPListBox | virtual
GetListStyle() const | CXTPListBox |
HasFocus() const | CXTPListBox |
Initialize(bool bAutoFont=true) | CXTPListBox | virtual
m_nHotItem | CXTPListBox |
m_nItemHeight | CXTPListBox |
m_nTextPadding | CXTPListBox |
m_pTheme | CXTPListBox |
m_theme | CXTPListBox |
RefreshMetrics() | CXTPListBox | virtual
SetListStyle(XTPListBoxStyle style) | CXTPListBox |
SetTheme(XTPControlTheme nTheme) | CXTPListBox |
TryItemFromPoint(CPoint pt, BOOL &bOutside, int &nIndex) const | CXTPListBox | protected
~CXTPListBox() | CXTPListBox | virtual


Toolkit Pro: XTPButtonThemeVisualStudio2015.h Source File

  • Source
  • Controls
  • Button
  • Themes
XTPButtonThemeVisualStudio2015.h
Go to the documentation of this file.
1
23#if !defined(__XTPBUTTONTHEMEVISUALSTUDIO2015_H__)
24# define __XTPBUTTONTHEMEVISUALSTUDIO2015_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPButtonThemeVisualStudio2015 : public CXTPButtonThemeOffice2013
39{
40public:
45 CXTPButtonThemeVisualStudio2015();
46
53 virtual void RefreshMetrics(CXTPButton* pButton);
54};
55
56# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
58#endif //#if !defined(__XTPBUTTONTHEMEVISUALSTUDIO2015_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPButton
Push Button control.
Definition XTPButton.h:109
CXTPButtonThemeOffice2013
CXTPButtonThemeOffice2013 is a class used to perform Office 2013 theme drawing tasks.
Definition XTPButtonThemeOffice2013.h:39
CXTPButtonThemeVisualStudio2015
CXTPButtonThemeVisualStudio2015 is a class used to perform Visual Studio 2015 theme drawing tasks.
Definition XTPButtonThemeVisualStudio2015.h:39
CXTPButtonThemeVisualStudio2015::CXTPButtonThemeVisualStudio2015
CXTPButtonThemeVisualStudio2015()
Constructs a CXTPButtonThemeVisualStudio2015 object.
CXTPButtonThemeVisualStudio2015::RefreshMetrics
virtual void RefreshMetrics(CXTPButton *pButton)
This member function is called by the theme manager to refresh the visual styles used by each compone...


Toolkit Pro: XTPChartRangeBarSeriesLabel.h Source File

  • Source
  • Chart
  • Styles
  • Range
XTPChartRangeBarSeriesLabel.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTRANGEBARSERIESLABEL_H__)
24# define __XTPCHARTRANGEBARSERIESLABEL_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartSeriesView;
38enum XTPChartRangeBarLabelPosition
39{
40 xtpChartRangeBarLabelOutside,
41 xtpChartRangeBarLabelInside,
42};
47enum XTPChartRangeBarLabelType
48{
49 xtpChartRangeBarOneLabel,
50 xtpChartRangeBarTwoLabels,
51 xtpChartRangeBarMinValueLabel,
52 xtpChartRangeBarMaxValueLabel
53};
54
60class _XTP_EXT_CLASS CXTPChartRangeBarSeriesLabel : public CXTPChartDiagram2DSeriesLabel
61{
62 DECLARE_SERIAL(CXTPChartRangeBarSeriesLabel);
63
64public:
69 CXTPChartRangeBarSeriesLabel();
70
75 virtual ~CXTPChartRangeBarSeriesLabel();
76
77public:
78 void SetPosition(XTPChartRangeBarLabelPosition nPosition);
79 XTPChartRangeBarLabelPosition GetPosition() const;
80
81 void SetType(XTPChartRangeBarLabelType nType);
82 XTPChartRangeBarLabelType GetType() const;
83
84public:
96 virtual CXTPChartElementView* CreateView(CXTPChartDeviceContext* pDC,
97 CXTPChartSeriesPointView* pPointView,
98 CXTPChartElementView* pParentView);
99
100 void DoPropExchange(CXTPPropExchange* pPX);
101
102protected:
103 XTPChartRangeBarLabelPosition m_nPosition;
104 XTPChartRangeBarLabelType m_nType;
105 int m_nIndent;
106
107# ifdef _XTP_ACTIVEX
108public:
110 DECLARE_DISPATCH_MAP()
111 DECLARE_INTERFACE_MAP()
112 DECLARE_OLETYPELIB_EX(CXTPChartRangeBarSeriesLabel);
114# endif
115};
116
122class _XTP_EXT_CLASS CXTPChartRangeBarSeriesLabelView : public CXTPChartDiagram2DSeriesLabelView
123{
124public:
133 CXTPChartRangeBarSeriesLabelView(CXTPChartSeriesLabel* pLabel,
134 CXTPChartSeriesPointView* pPointView,
135 CXTPChartElementView* pParentView);
136
144 using CXTPChartDiagram2DSeriesLabelView::GetAnchorPoint;
145
146 virtual CXTPChartPointF GetAnchorPoint(BOOL bMinValue) const;
147
148 using CXTPChartDiagram2DSeriesLabelView::GetAnchorAngle;
149
150 virtual double GetAnchorAngle(BOOL bMinValue) const;
151
152protected:
153 using CXTPChartDiagram2DSeriesLabelView::CreateDeviceCommand;
154
155 virtual CXTPChartDeviceCommand* CreateDeviceCommand(CXTPChartDeviceContext* pDC);
156 void CalculateLayout(CXTPChartDeviceContext* pDC);
157};
158
159AFX_INLINE void CXTPChartRangeBarSeriesLabel::SetPosition(XTPChartRangeBarLabelPosition nPosition)
160{
161 m_nPosition = nPosition;
162 OnChartChanged();
163}
164AFX_INLINE XTPChartRangeBarLabelPosition CXTPChartRangeBarSeriesLabel::GetPosition() const
165{
166 return m_nPosition;
167}
168
169AFX_INLINE void CXTPChartRangeBarSeriesLabel::SetType(XTPChartRangeBarLabelType nType)
170{
171 m_nType = nType;
172 OnChartChanged();
173}
174AFX_INLINE XTPChartRangeBarLabelType CXTPChartRangeBarSeriesLabel::GetType() const
175{
176 return m_nType;
177}
179# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
180#endif //#if !defined(__XTPCHARTRANGEBARSERIESLABEL_H__)
XTPChartRangeBarLabelPosition
XTPChartRangeBarLabelPosition
Specifies range bar chart label position.
Definition XTPChartRangeBarSeriesLabel.h:39
xtpChartRangeBarLabelOutside
@ xtpChartRangeBarLabelOutside
A label is located outside a range bar.
Definition XTPChartRangeBarSeriesLabel.h:40
xtpChartRangeBarLabelInside
@ xtpChartRangeBarLabelInside
A label is located inside a range bar.
Definition XTPChartRangeBarSeriesLabel.h:41
XTPChartRangeBarLabelType
XTPChartRangeBarLabelType
Specifies range bar chart label type.
Definition XTPChartRangeBarSeriesLabel.h:48
xtpChartRangeBarMinValueLabel
@ xtpChartRangeBarMinValueLabel
Defines a label with a minimum range value.
Definition XTPChartRangeBarSeriesLabel.h:51
xtpChartRangeBarMaxValueLabel
@ xtpChartRangeBarMaxValueLabel
Defines a label with a maximum range value.
Definition XTPChartRangeBarSeriesLabel.h:52
xtpChartRangeBarOneLabel
@ xtpChartRangeBarOneLabel
Defines a label that contains both range values.
Definition XTPChartRangeBarSeriesLabel.h:49
xtpChartRangeBarTwoLabels
@ xtpChartRangeBarTwoLabels
Defines a two labels for each range value.
Definition XTPChartRangeBarSeriesLabel.h:50
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartDiagram2DSeriesLabel
This class abstracts the label of a point series.
Definition XTPChartDiagram2DSeriesLabel.h:41
CXTPChartDiagram2DSeriesLabelView
This class abstracts the view of the label of a point series.
Definition XTPChartDiagram2DSeriesLabel.h:69
CXTPChartDiagram2DSeriesLabelView::CreateDeviceCommand
virtual CXTPChartDeviceCommand * CreateDeviceCommand(CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
CXTPChartDiagram2DSeriesLabelView::GetAnchorPoint
virtual CXTPChartPointF GetAnchorPoint() const
This function calculates the anchor point of the label stem.
CXTPChartElement::OnChartChanged
virtual void OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic propertie...
CXTPChartElementView
This class represents the view of a chart element.
Definition XTPChartElementView.h:47
CXTPChartRangeBarSeriesLabel
This class abstracts the label of a bar series.
Definition XTPChartRangeBarSeriesLabel.h:61
CXTPChartRangeBarSeriesLabel::DoPropExchange
void DoPropExchange(CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
CXTPChartRangeBarSeriesLabel::~CXTPChartRangeBarSeriesLabel
virtual ~CXTPChartRangeBarSeriesLabel()
Destroys a CXTPChartRangeBarSeriesLabel object, handles cleanup.
CXTPChartRangeBarSeriesLabel::CXTPChartRangeBarSeriesLabel
CXTPChartRangeBarSeriesLabel()
Constructs a CXTPChartRangeBarSeriesLabel object.
CXTPChartRangeBarSeriesLabel::CreateView
virtual CXTPChartElementView * CreateView(CXTPChartDeviceContext *pDC, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView)
This function create the view of the bar series label.
CXTPChartRangeBarSeriesLabelView
This class abstracts the view of the label of a bar series.
Definition XTPChartRangeBarSeriesLabel.h:123
CXTPChartRangeBarSeriesLabelView::CXTPChartRangeBarSeriesLabelView
CXTPChartRangeBarSeriesLabelView(CXTPChartSeriesLabel *pLabel, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView)
Constructs a CXTPChartRangeBarSeriesLabel object.
CXTPChartRangeBarSeriesLabelView::CreateDeviceCommand
virtual CXTPChartDeviceCommand * CreateDeviceCommand(CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
CXTPChartSeriesLabel
This class abstracts the label of a series.
Definition XTPChartSeriesLabel.h:49
CXTPChartSeriesPointView
Represents chart series point view.
Definition XTPChartSeriesPointView.h:48
CXTPPoint2T< float >
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72


Toolkit Pro: XTPResource.h Source File

  • Source
  • Common
Common/XTPResource.h
Go to the documentation of this file.
1
23#if !defined(__XTPRESOURCE_H__)
24# define __XTPRESOURCE_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class _XTP_EXT_CLASS CXTPResource
34{
35 // Construction / Destruction
36public:
37 CXTPResource();
38
39 virtual ~CXTPResource();
40
41 // Methods
42public:
43 BOOL LoadResource(HMODULE hInstance, LPCTSTR pszName, LPCTSTR pszType);
44
45 // Members
46public:
48 HRSRC m_hResource;
49
51 HGLOBAL m_hResourceData;
52
54 LPVOID m_pvResourceData;
55
57 DWORD m_dwSize;
58};
59
60# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
62#endif // !defined(__XTPRESOURCE_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h


Toolkit Pro: Member List

CXTPEmptySize Member List

This is the complete list of members for CXTPEmptySize, including all inherited members.

CXTPEmptySize() | CXTPEmptySize
operator=(const SIZE &srcSize) | CXTPEmptySize
SetSizeEmpty() | CXTPEmptySize


Toolkit Pro: XTPChartFunnelSeriesPointViewBase.h Source File

  • Source
  • Chart
  • Styles
  • Funnel
  • Base
XTPChartFunnelSeriesPointViewBase.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTFUNNELSERIESPOINTVIEWBASE_H__)
24# define __XTPCHARTFUNNELSERIESPOINTVIEWBASE_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartSeriesPoint;
34class CXTPChartElementView;
35class CXTPChartDeviceContext;
36class CXTPChartFunnelSeriesView;
37
49class _XTP_EXT_CLASS CXTPChartFunnelSeriesPointViewBase : public CXTPChartSeriesPointView
50{
51 DECLARE_DYNAMIC(CXTPChartFunnelSeriesPointViewBase);
52
53public:
61 CXTPChartFunnelSeriesPointViewBase(CXTPChartSeriesPoint* pPoint,
62 CXTPChartElementView* pParentView);
63
72 CXTPChartFunnelSeriesPointViewBase(CXTPChartSeriesPoint* pPoint,
73 CXTPChartElementView* pParentView, BOOL bAddToParent);
74
79 virtual ~CXTPChartFunnelSeriesPointViewBase();
80
81public:
91 virtual void CalculateLayout(int nIndex, int nCount, double dFrom, double dTo);
92
100 CXTPChartColor GetBorderActualColor() const;
101
102protected:
115 virtual CXTPChartDeviceCommand* CreateDeviceCommand(CXTPChartDeviceContext* pDC) = 0;
116
127 virtual CXTPChartDeviceCommand* CreateLegendDeviceCommand(CXTPChartDeviceContext* pDC,
128 CRect rcBounds);
129
130protected:
131 double m_dValue;
133public:
134 CXTPChartRectF m_rc;
135
136 double m_dFrom;
137 double m_dTo;
138
139protected:
140 double m_dWidth;
141 double m_dHeight;
142
143 friend class CXTPChartFunnelSeriesViewBase;
144 friend class CXTPChartFunnelSeriesView;
145 friend class CXTPChart3dFunnelSeriesView;
146 friend class CXTPChart3dFunnelSeriesPointView;
147};
149# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
150#endif //#if !defined(__XTPCHARTFUNNELSERIESPOINTVIEWBASE_H__)
pPoint
const CPoint * pPoint
return 0 or xtpCalendarHitTestDayExpandButton
Definition XTPCalendarThemeOffice2007.h:150
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChart3dFunnelSeriesPointView
This class abstracts the view of a funnel series point.
Definition XTPChart3dFunnelSeriesPointView.h:47
CXTPChart3dFunnelSeriesView
This class abstracts the view of a funnel series.
Definition XTPChart3dFunnelSeriesView.h:45
CXTPChartColor
This class abstracts a color entity.
Definition XTPChartTypes.h:51
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartElementView
This class represents the view of a chart element.
Definition XTPChartElementView.h:47
CXTPChartFunnelSeriesPointViewBase
This class abstracts the view of a funnel series point.
Definition XTPChartFunnelSeriesPointViewBase.h:50
CXTPChartFunnelSeriesPointViewBase::CXTPChartFunnelSeriesPointViewBase
CXTPChartFunnelSeriesPointViewBase(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView, BOOL bAddToParent)
Constructs a CXTPChartFunnelSeriesPointView object.
CXTPChartFunnelSeriesPointViewBase::GetBorderActualColor
CXTPChartColor GetBorderActualColor() const
Obtains border color value.
CXTPChartFunnelSeriesPointViewBase::~CXTPChartFunnelSeriesPointViewBase
virtual ~CXTPChartFunnelSeriesPointViewBase()
Destroys a CXTPChartFunnelSeriesPointView object, handle cleanup.
CXTPChartFunnelSeriesPointViewBase::CreateDeviceCommand
virtual CXTPChartDeviceCommand * CreateDeviceCommand(CXTPChartDeviceContext *pDC)=0
This function creates a CXTPChartDeviceCommand object.
CXTPChartFunnelSeriesPointViewBase::CXTPChartFunnelSeriesPointViewBase
CXTPChartFunnelSeriesPointViewBase(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Constructs a CXTPChartFunnelSeriesPointView object.
CXTPChartFunnelSeriesPointViewBase::CreateLegendDeviceCommand
virtual CXTPChartDeviceCommand * CreateLegendDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcBounds)
This function creates a label view drawing command object.
CXTPChartFunnelSeriesPointViewBase::CalculateLayout
virtual void CalculateLayout(int nIndex, int nCount, double dFrom, double dTo)
Use this function to calculate the layout of the funnel series point.
CXTPChartFunnelSeriesPointViewBase::m_dValue
double m_dValue
The value of the point.
Definition XTPChartFunnelSeriesPointViewBase.h:131
CXTPChartFunnelSeriesViewBase
This class abstracts the view of a funnel series.This class is a kind of CXTPChartSeriesView.
Definition XTPChartFunnelSeriesViewBase.h:50
CXTPChartFunnelSeriesView
This class abstracts the view of a funnel series.
Definition XTPChart2dFunnelSeriesView.h:49
CXTPChartSeriesPoint
CXTPChartSeriesPoint is a kind of CXTPChartElement.
Definition XTPChartSeriesPoint.h:43
CXTPChartSeriesPointView
Represents chart series point view.
Definition XTPChartSeriesPointView.h:48
CXTPRectT< float >


Toolkit Pro: XTPProgressThemeVisualStudio2017.h Source File

  • Source
  • CommandBars
  • Progress
XTPProgressThemeVisualStudio2017.h
Go to the documentation of this file.
1
23#if !defined(__XTPPROGRESSTHEMEVISUALSTUDIO2017_H__)
24# define __XTPPROGRESSTHEMEVISUALSTUDIO2017_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPProgressBase;
34class CXTPPaintManager;
35
40class _XTP_EXT_CLASS CXTPProgressThemeVisualStudio2017 : public CXTPProgressThemeOffice2013
41{
42public:
48 CXTPProgressThemeVisualStudio2017(CXTPPaintManager* pPaintManager);
49
55 virtual ~CXTPProgressThemeVisualStudio2017();
56};
57
59# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
60#endif // !defined(__XTPPROGRESSTHEMEVISUALSTUDIO2017_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPPaintManager
Paint manager of the command bars.
Definition XTPPaintManager.h:199
CXTPProgressBase
CXTPControlProgressBase is base class for all progress objects.
Definition XTPProgressBase.h:40
CXTPProgressThemeOffice2013
CXTPProgressThemeOffice2013 object.
Definition XTPProgressThemeOffice2013.h:41
CXTPProgressThemeVisualStudio2017
CXTPProgressThemeVisualStudio2017 object.
Definition XTPProgressThemeVisualStudio2017.h:41
CXTPProgressThemeVisualStudio2017::CXTPProgressThemeVisualStudio2017
CXTPProgressThemeVisualStudio2017(CXTPPaintManager *pPaintManager)
Constructs a CXTPProgressThemeVisualStudio2017 object.
CXTPProgressThemeVisualStudio2017::~CXTPProgressThemeVisualStudio2017
virtual ~CXTPProgressThemeVisualStudio2017()
Destroys a CXTPProgressThemeVisualStudio2017 object, handles cleanup and deallocation.


Toolkit Pro: Member List

CXTPGridControlLocale Member List

This is the complete list of members for CXTPGridControlLocale, including all inherited members.

FormatDateTime(const COleDateTime &dt, LPCTSTR lpcszFormatString) | CXTPGridControlLocale | static
GetActiveLCID() | CXTPGridControlLocale | static
IsUseResourceFileLocale() | CXTPGridControlLocale | static
SetUseResourceFileLocale(BOOL bUseResourceFileLocale) | CXTPGridControlLocale | static
VariantChangeTypeEx(VARIANT &rVarValue, VARTYPE vartype, BOOL bThrowError=TRUE) | CXTPGridControlLocale | static


Toolkit Pro: Member List

CXTPTabThemeVisualStudio2010 Member List

This is the complete list of members for CXTPTabThemeVisualStudio2010, including all inherited members.

AdjustClientRect(CXTPTabManager *pTabManager, CRect &rcClient) | CXTPTabPaintManagerTheme | virtual
CAppearanceSetPropertyPageFlat() | CAppearanceSetPropertyPageFlat | inline
CXTPTabPaintManagerTheme() | CXTPTabPaintManagerTheme |
CXTPTabThemeFlat() | CXTPTabThemeFlat | inline
CXTPTabThemeVisualStudio2010() | CXTPTabThemeVisualStudio2010 | inline
DrawSingleButton(CDC *pDC, CXTPTabManagerItem *pItem) | CXTPTabThemeVisualStudio2010 | virtual
DrawTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl) | CXTPTabPaintManagerTheme | virtual
DrawText(CDC *pDC, CXTPTabManager *pManager, const CString &str, LPRECT lpRect, UINT nFormat) | CXTPTabPaintManagerTheme | virtual
DrawWorkspacePart(CDC *pDC, LPRECT lpRect, XTPTabWorkspacePart workspacePart) | CXTPTabPaintManagerTheme | virtual
FillButton(CDC *pDC, CXTPTabManagerItem *pItem, LPPOINT pts, int nCount, XTPTabPosition tabPosition, BOOL bAbsolute=FALSE) | CXTPTabPaintManagerTheme |
FillTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl) | CXTPTabThemeFlat | virtual
GetButtonDrawRect(const CXTPTabManagerItem *pItem) | CXTPTabPaintManagerTheme | virtual
GetButtonHeight(const CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetButtonLength(CDC *pDC, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerTheme | virtual
GetClientMargin() | CXTPTabPaintManagerTheme | virtual
GetClientRect(CRect rcControl, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetColorSet() const | CXTPTabPaintManagerTheme |
GetDefaultColorSet() | CXTPTabThemeVisualStudio2010 | inlinevirtual
GetHeaderClipBox(CDC *pDC, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetHeaderHeight(CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme |
GetHeaderMargin() | CXTPTabPaintManagerTheme | virtual
GetHeaderRect(CRect rcControl, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetSupportedColorSets() | CXTPTabPaintManagerTheme | inlinevirtual
m_bBlurPoints | CAppearanceSetPropertyPageFlat |
m_bButtonsReverseZOrder | CXTPTabPaintManagerTheme | protected
m_bVisualStudio2005Style | CAppearanceSetPropertyPageFlat |
m_nButtonHeight | CXTPTabPaintManagerTheme | protected
m_nRowMargin | CXTPTabPaintManagerTheme |
m_pPaintManager | CXTPTabPaintManagerTheme | protected
m_rcHeaderMargin | CXTPTabPaintManagerTheme |
RefreshMetrics() | CXTPTabPaintManagerTheme | virtual
RepositionTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcClient) | CXTPTabPaintManagerTheme | virtual
~CXTPTabPaintManagerTheme() | CXTPTabPaintManagerTheme | virtual


Toolkit Pro: XTPCalendarNativeWindows10Theme.h Source File

  • Source
  • Calendar
  • Themes
XTPCalendarNativeWindows10Theme.h
Go to the documentation of this file.
1
22#if !defined(__XTPCALENDARNATIVEWINDOWS10THEME_H__)
23# define __XTPCALENDARNATIVEWINDOWS10THEME_H__
24
25# if _MSC_VER > 1000
26# pragma once
27# endif // _MSC_VER > 1000
28
29# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
30
36class _XTP_EXT_CLASS CXTPCalendarNativeWindows10Theme : public CXTPCalendarOffice2013Theme
37{
38public:
47 CXTPCalendarNativeWindows10Theme();
48
55 virtual ~CXTPCalendarNativeWindows10Theme();
56};
57
58# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
59#endif // !defined(__XTPCALENDARNATIVEWINDOWS10THEME_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCalendarNativeWindows10Theme
CXTPCalendarNativeWindows10Theme is a CXTPCalendarOffice2013Theme derived class that represents the N...
Definition XTPCalendarNativeWindows10Theme.h:37
CXTPCalendarNativeWindows10Theme::~CXTPCalendarNativeWindows10Theme
virtual ~CXTPCalendarNativeWindows10Theme()
Default paint manager destructor.
CXTPCalendarNativeWindows10Theme::CXTPCalendarNativeWindows10Theme
CXTPCalendarNativeWindows10Theme()
Default paint manager constructor.
CXTPCalendarOffice2013Theme
CXTPCalendarOffice2013Theme is a CXTPCalendarOffice2000Theme derived class that represents the Office...
Definition XTPCalendarOffice2013Theme.h:37


Toolkit Pro: XTPDockingPaneThemeGrippered.h Source File

  • Source
  • DockingPane
  • Themes
XTPDockingPaneThemeGrippered.h
Go to the documentation of this file.
1
23#if !defined(__XTPDOCKINGPANETHEMEGRIPPERED_H__)
24# define __XTPDOCKINGPANETHEMEGRIPPERED_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
40class _XTP_EXT_CLASS CXTPDockingPaneGripperedTheme : public CXTPDockingPaneDefaultTheme
41{
42public:
47 CXTPDockingPaneGripperedTheme();
48
49public:
57 void DrawFloatingFrame(CDC* pDC, CXTPDockingPaneMiniWnd* pPane, CRect rc);
58
66 virtual void DrawCaption(CDC* pDC, CXTPDockingPaneTabbedContainer* pPane, CRect rc);
67
72 virtual void RefreshMetrics();
73
74protected:
85 virtual void DrawCaptionPart(CDC* pDC, CXTPDockingPaneBase* pPane, CRect rcCaption,
86 const CString& strTitle, BOOL bActive, BOOL bVertical);
87};
88
89# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
91#endif // !defined(__XTPDOCKINGPANETHEMEGRIPPERED_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPDockingPaneBase
CXTPDockingPaneBase is a standalone class.
Definition XTPDockingPaneBase.h:69
CXTPDockingPaneDefaultTheme
CXTPDockingPaneDefaultTheme is a CXTPDockingPanePaintManager derived class that represents a classic ...
Definition XTPDockingPaneThemeDefault.h:41
CXTPDockingPaneGripperedTheme
CXTPDockingPaneGripperedTheme is a CXTPDockingPaneDefaultTheme derived class that represents a grippe...
Definition XTPDockingPaneThemeGrippered.h:41
CXTPDockingPaneGripperedTheme::DrawFloatingFrame
void DrawFloatingFrame(CDC *pDC, CXTPDockingPaneMiniWnd *pPane, CRect rc)
Call this method to draw the frame of a floating window.
CXTPDockingPaneGripperedTheme::CXTPDockingPaneGripperedTheme
CXTPDockingPaneGripperedTheme()
Constructs a CXTPDockingPaneGripperedTheme object.
CXTPDockingPaneGripperedTheme::DrawCaption
virtual void DrawCaption(CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc)
Override this member function to draw a caption.
CXTPDockingPaneGripperedTheme::RefreshMetrics
virtual void RefreshMetrics()
This method is called to refresh the visual metrics of the pane.
CXTPDockingPaneGripperedTheme::DrawCaptionPart
virtual void DrawCaptionPart(CDC *pDC, CXTPDockingPaneBase *pPane, CRect rcCaption, const CString &strTitle, BOOL bActive, BOOL bVertical)
Draws the common part of a tabbed and floating caption.
CXTPDockingPaneMiniWnd
CXTPDockingPaneMiniWnd is a multiple inheritance class derived from CMiniFrameWnd and CXTPDockingPane...
Definition XTPDockingPaneMiniWnd.h:42
CXTPDockingPaneTabbedContainer
CXTPDockingPaneTabbedContainer is a multiple inheritance class derived from CWnd and CXTPDockingPaneB...
Definition XTPDockingPaneTabbedContainer.h:47


Toolkit Pro: Member List

CXTPDockingPaneContext Member List

This is the complete list of members for CXTPDockingPaneContext, including all inherited members.

AdjustCursor(CPoint &pt) | CXTPDockingPaneContext | protectedstatic
AdjustRectangle(CRect &rect, CPoint pt) | CXTPDockingPaneContext | protectedstatic
CancelLoop() | CXTPDockingPaneContext | protectedvirtual
CreateContextWindow(CXTPDockingPaneContextAlphaWnd *pWnd) | CXTPDockingPaneContext | protected
CreateNewSticker(CRect rc, XTPDockingPaneStickerType typeSticker) | CXTPDockingPaneContext | protected
CXTPDockingPaneContext() | CXTPDockingPaneContext |
DestroyDockingStickers() | CXTPDockingPaneContext | protected
Drag(CXTPDockingPaneBase *pPane, CPoint point) | CXTPDockingPaneContext | virtual
Drag(CXTPDockingPaneBase *pPane, CPoint point, CRect rcPane) | CXTPDockingPaneContext |
DrawFocusRect(BOOL bRemoveRect=FALSE) | CXTPDockingPaneContext | protectedvirtual
InitLoop() | CXTPDockingPaneContext | protectedvirtual
m_bDragKeyboard | CXTPDockingPaneContext | protected
m_bUseAlphaContext | CXTPDockingPaneContext | protected
m_bUseDockingStickers | CXTPDockingPaneContext | protected
m_lstStickers | CXTPDockingPaneContext | protected
m_pfnSetLayeredWindowAttributes | CXTPDockingPaneContext | protected
m_pLastStickerPane | CXTPDockingPaneContext | protected
m_pManager | CXTPDockingPaneContext | protected
m_pPane | CXTPDockingPaneContext | protected
m_pStickerPane | CXTPDockingPaneContext | protected
m_ptLast | CXTPDockingPaneContext | protected
m_ptSticky | CXTPDockingPaneContext | protected
m_rectDragFrame | CXTPDockingPaneContext | protected
m_rectDragFrameScreen | CXTPDockingPaneContext | protected
m_rectStickerPane | CXTPDockingPaneContext | protected
m_wndAttachedTab | CXTPDockingPaneContext | protected
m_wndContext | CXTPDockingPaneContext | protected
Move(CPoint pt) | CXTPDockingPaneContext | protectedvirtual
OnSizingFloatingFrame(CXTPDockingPaneMiniWnd *pWnd, UINT nSide, LPRECT lpRect) | CXTPDockingPaneContext | virtual
Track() | CXTPDockingPaneContext | protectedvirtual
UpdateDockingStickers() | CXTPDockingPaneContext | protected
~CXTPDockingPaneContext() | CXTPDockingPaneContext | virtual


Toolkit Pro: XTPDockBar.h Source File

  • Source
  • CommandBars
XTPDockBar.h
Go to the documentation of this file.
1
23#if !defined(__XTPDOCKBAR_H__)
24# define __XTPDOCKBAR_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPToolBar;
34class CXTPCommandBars;
35
41class _XTP_EXT_CLASS CXTPDockBar : public CWnd
42{
43private:
45 DECLARE_DYNCREATE(CXTPDockBar)
47public:
52 typedef CArray<CXTPToolBar*, CXTPToolBar*> CToolBarArray;
53
54private:
55 class CDockInfoArray;
56 struct DOCK_INFO;
57
58public:
63 CXTPDockBar();
64
69 virtual ~CXTPDockBar();
70
71public:
78 XTPBarPosition GetPosition() const;
79
86 BOOL IsVerticalPosition() const;
87
88 CXTPCommandBars* GetCommandBars() const;
89
90protected:
92 // Implementation
93
94 BOOL RemoveCommandBar(CXTPToolBar* pBar, int nPosExclude = -1);
95 BOOL Create(CWnd* pParentWnd, DWORD dwStyle, UINT nID);
96 BOOL PreCreateWindow(CREATESTRUCT& cs);
97 BOOL DockCommandBar(CXTPToolBar* bBar);
98 void DockCommandBar(CXTPToolBar* pBar, LPCRECT lpRect);
99
100 CXTPToolBar* GetDockedCommandBar(int nPos) const;
101 int GetDockedCount() const;
102 int GetDockedVisibleCount() const;
103 int FindBar(CXTPToolBar* pBar, int nPosExclude = -1);
104 int Insert(CXTPToolBar* pBarIns, CRect rect, CPoint ptMid);
105
106 void GetVisibleToolbars(int nPos, CToolBarArray& arrBars);
107 void AdjustStretchBars();
108
109 int AdjustRow(CToolBarArray&, CPoint pt, int nLength, BOOL bHorz,
110 AFX_SIZEPARENTPARAMS* lpLayout);
111 int _AdjustRow(CToolBarArray&, CPoint pt, int nLength, BOOL bHorz,
112 AFX_SIZEPARENTPARAMS* lpLayout, int& nRemove);
113 int _GetMode(BOOL bHorz, CXTPToolBar* pBar);
114
115 CSize CalcFixedLayout(BOOL bStretch, BOOL bHorz, AFX_SIZEPARENTPARAMS* lpLayout);
116 CSize CalcDynamicLayout(int, DWORD nMode, AFX_SIZEPARENTPARAMS* lpLayout);
119protected:
121 //{{AFX_MSG(CXTPDockBar)
122 DECLARE_MESSAGE_MAP()
123
124 afx_msg void OnPaint();
125 afx_msg LRESULT OnPrintClient(WPARAM wParam, LPARAM);
126 afx_msg BOOL OnEraseBkgnd(CDC* pDC);
127 afx_msg void OnRButtonDown(UINT nFlags, CPoint point);
128 afx_msg LRESULT OnSizeParent(WPARAM, LPARAM lParam);
129 afx_msg LRESULT OnNcHitTest(CPoint /*point*/);
130 afx_msg void OnSize(UINT nType, int cx, int cy);
131 //}}AFX_MSG
134private:
135 BOOL Create(LPCTSTR lpszClassName, LPCTSTR lpszWindowName, DWORD dwStyle, const RECT& rect,
136 CWnd* pParentWnd, UINT nID, CCreateContext* pContext = NULL);
137
138protected:
139 DWORD m_dwStyle;
140 CToolBarArray m_arrBars;
141 CXTPCommandBars* m_pCommandBars;
143 friend class CXTPToolBar;
144 friend class CXTPCommandBars;
145 friend class CXTPReBar;
146};
147
148AFX_INLINE BOOL CXTPDockBar::Create(LPCTSTR lpszClassName, LPCTSTR lpszWindowName, DWORD dwStyle,
149 const RECT& rect, CWnd* pParentWnd, UINT nID,
150 CCreateContext* pContext)
151{
152 return CWnd::Create(lpszClassName, lpszWindowName, dwStyle, rect, pParentWnd, nID, pContext);
153}
154AFX_INLINE CXTPCommandBars* CXTPDockBar::GetCommandBars() const
155{
156 return m_pCommandBars;
157}
159# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
160#endif // #if !defined(__XTPDOCKBAR_H__)
XTPBarPosition
XTPBarPosition
Position of the command bar.
Definition XTPCommandBarsDefines.h:52
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCommandBars
CXTPCommandBars is a standalone class.
Definition XTPCommandBars.h:165
CXTPDockBar
CXTPDockBar is a CWnd derived class.
Definition XTPDockBar.h:42
CXTPDockBar::CXTPDockBar
CXTPDockBar()
Constructs a CXTPDockBar object.
CXTPDockBar::~CXTPDockBar
virtual ~CXTPDockBar()
Destroys a CXTPDockBar object, handles cleanup and deallocation.
CXTPDockBar::CToolBarArray
CArray< CXTPToolBar *, CXTPToolBar * > CToolBarArray
Array of CXTPToolBar objects.
Definition XTPDockBar.h:52
CXTPDockBar::IsVerticalPosition
BOOL IsVerticalPosition() const
Checks if dockbar is vertical.
CXTPDockBar::GetPosition
XTPBarPosition GetPosition() const
Retrieves the dockbar position.
CXTPReBar
The CXTPReBar object extends the standard MFC CReBar class to provide extended functionality such as ...
Definition XTPReBar.h:100
CXTPToolBar
CXTPToolBar is a CXTPCommandBar derived class.
Definition XTPToolBar.h:42


Toolkit Pro: XTPChart3dPyramidSeriesLabelsViewDeviceCommand.h Source File

  • Source
  • Chart
  • Styles
  • Pyramid
  • 3D
  • Commands
XTPChart3dPyramidSeriesLabelsViewDeviceCommand.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHART3DPYRAMIDSERIESLABELSVIEWDEVICECOMMAND_H__)
24# define __XTPCHART3DPYRAMIDSERIESLABELSVIEWDEVICECOMMAND_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChart3dPyramidSeriesLabelsView;
34class CXTPChart3dPyramidSeriesLabelView;
35class CXTPChart3dPyramidSeriesPointView;
36class CXTPChart3dPyramidSeriesLabelDeviceCommand;
37class CXTPChart3dDeviceContext;
38class CXTPChart3dPyramidSeriesLabel;
39
44class _XTP_EXT_CLASS CXTPChart3dPyramidSeriesLabelDeviceCommand : public CXTPChart3dDeviceCommand
45{
46 DECLARE_DYNAMIC(CXTPChart3dPyramidSeriesLabelDeviceCommand);
47
48public:
55 CXTPChart3dPyramidSeriesLabelDeviceCommand(CXTPChart3dPyramidSeriesLabelView* pSeriesLabelView);
56
57public:
64 virtual void ExecuteOverride(CXTPChartDeviceContext* pDC);
65
73 CXTPChart3dPyramidSeriesLabelView* GetSeriesLabelView() const;
74
85 BOOL IsFailed() const;
86
91 void SetFailed();
92
103 CRect GetLabelRect() const;
104
114 void SetLabelRect(CRect rcLabel);
115
125 BOOL ComputeConnectorVector(CXTPChart3dDeviceContext* pDC);
126
133 void ComputeLabel(CXTPChart3dDeviceContext* pDC);
134
145 double GetConnectorLength() const;
146
156 void SetConnectorLength(double dLength);
157
168 double GetConnectorEndpointVerticalOffset() const;
169
179 void SetConnectorEndpointVerticalOffset(double yOffset);
180
181private:
182 BOOL ComputeConnectorStartPoint(CXTPChart3dDeviceContext* pDC, CXTPPoint3d& ptStart,
183 CPoint& ptProjected) const;
184 CXTPPoint3d ComputeConnectorEndPoint() const;
185 CXTPPoint3d ComputeConnectorVectorEndPoint(const CXTPPoint3d& point) const;
186 void ComputeLabel_Outside(const CSize& szLabel, const CPoint& ptAnchorOrigin,
187 const CPoint& ptAnchor);
188 void ComputeLabel_Center(const CSize& szLabel, const CPoint& ptAnchor);
189
190private:
191 CXTPChart3dPyramidSeriesLabelView* m_pSeriesLabelView;
192 CXTPChart3dPyramidSeriesPointView* m_pPointView;
193 CRect m_rcLabel;
194 BOOL m_bFailed;
195 double m_dConnectorLength;
196 double m_dConnectorEndpointVerticalOffset;
197};
198
199AFX_INLINE BOOL CXTPChart3dPyramidSeriesLabelDeviceCommand::IsFailed() const
200{
201 return m_bFailed;
202}
203
204AFX_INLINE void CXTPChart3dPyramidSeriesLabelDeviceCommand::SetFailed()
205{
206 m_bFailed = TRUE;
207}
208
209AFX_INLINE CXTPChart3dPyramidSeriesLabelView*
210 CXTPChart3dPyramidSeriesLabelDeviceCommand::GetSeriesLabelView() const
211{
212 return m_pSeriesLabelView;
213}
214
215AFX_INLINE CRect CXTPChart3dPyramidSeriesLabelDeviceCommand::GetLabelRect() const
216{
217 return m_rcLabel;
218}
219
220AFX_INLINE void CXTPChart3dPyramidSeriesLabelDeviceCommand::SetLabelRect(CRect rcLabel)
221{
222 m_rcLabel = rcLabel;
223}
224
225AFX_INLINE double CXTPChart3dPyramidSeriesLabelDeviceCommand::GetConnectorLength() const
226{
227 return m_dConnectorLength;
228}
229
230AFX_INLINE void CXTPChart3dPyramidSeriesLabelDeviceCommand::SetConnectorLength(double dLength)
231{
232 m_dConnectorLength = dLength;
233}
234
235AFX_INLINE double
236 CXTPChart3dPyramidSeriesLabelDeviceCommand::GetConnectorEndpointVerticalOffset() const
237{
238 return m_dConnectorEndpointVerticalOffset;
239}
240
241AFX_INLINE void
242 CXTPChart3dPyramidSeriesLabelDeviceCommand::SetConnectorEndpointVerticalOffset(double yOffset)
243{
244 m_dConnectorEndpointVerticalOffset = yOffset;
245}
246
251class _XTP_EXT_CLASS CXTPChart3dPyramidSeriesLabelsViewDeviceCommand
252 : public CXTPChart3dDeviceCommand
253 , private CXTPChartDeviceCommandEvents
254{
255public:
262 CXTPChart3dPyramidSeriesLabelsViewDeviceCommand(
263 CXTPChart3dPyramidSeriesLabelsView* pSeriesLabelsView);
264
265public:
272 virtual void ExecuteOverride(CXTPChartDeviceContext* pDC);
273
274private:
275 CXTPChart3dPyramidSeriesLabel* GetLabel() const;
276 void ComputeLabelConnectorVectors(CXTPChart3dDeviceContext* pDC);
277 void ComputeLabels(CXTPChart3dDeviceContext* pDC);
278 BOOL ResolveLabelOverlaps(CXTPChart3dDeviceContext* pDC);
279 BOOL ResolveLabelOverlaps_ChangeConnectorLength(CXTPChart3dDeviceContext* pDC);
280
281 CXTPChart3dPyramidSeriesLabelDeviceCommand*
282 FindLabelDeviceCommand(CXTPChartDeviceCommand* pCommand) const;
283
284private:
285 virtual void OnAfterExecute(CXTPChartDeviceCommand* pCommand, CXTPChartDeviceContext* pDC);
286
287 struct CommandCallbackData
288 {
289 enum State
290 {
291 None,
292 ComputeVector
293 };
294
295 CommandCallbackData(State state = None);
296 void SwitchTo(State state);
297 State GetState() const;
298
299 BOOL bSuccess;
300 CXTPChart3dDeviceContext* pDC;
301 CXTPChart3dPyramidSeriesLabelDeviceCommand* pLabelCommand;
302
303 private:
304 State state;
305 };
306
307 CommandCallbackData m_CommandCallbackData;
308
309protected:
310 CXTPChart3dPyramidSeriesLabelsView* m_pSeriesLabelsView; // View pointer
311};
312
313AFX_INLINE void
314 CXTPChart3dPyramidSeriesLabelsViewDeviceCommand::CommandCallbackData::SwitchTo(State newState)
315{
316 *this = CommandCallbackData(newState);
317}
318
319AFX_INLINE CXTPChart3dPyramidSeriesLabelsViewDeviceCommand::CommandCallbackData::State
320 CXTPChart3dPyramidSeriesLabelsViewDeviceCommand::CommandCallbackData::GetState() const
321{
322 return state;
323}
324
325AFX_INLINE CXTPChart3dPyramidSeriesLabelsViewDeviceCommand::CommandCallbackData::CommandCallbackData(
326 State state)
327 : bSuccess(FALSE)
328 , pDC(NULL)
329 , pLabelCommand(NULL)
330 , state(state)
331{
332}
334# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
335#endif //#if !defined(__XTPCHART3DPYRAMIDSERIESLABELSVIEWDEVICECOMMAND_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChart3dDeviceCommand
Defines a common implementation interface for chart 3D drawing commands.
Definition XTPChartDeviceCommand.h:368
CXTPChart3dDeviceContext
A base implementation of 3D device context.
Definition XTPChart3dDeviceContext.h:48
CXTPChart3dPyramidSeriesLabelDeviceCommand
Implements 3D chart pyramid series label device command.
Definition XTPChart3dPyramidSeriesLabelsViewDeviceCommand.h:45
CXTPChart3dPyramidSeriesLabelDeviceCommand::SetConnectorLength
void SetConnectorLength(double dLength)
Sets the connector length value.
Definition XTPChart3dPyramidSeriesLabelsViewDeviceCommand.h:230
CXTPChart3dPyramidSeriesLabelDeviceCommand::GetConnectorEndpointVerticalOffset
double GetConnectorEndpointVerticalOffset() const
Determines the connector endpoint vertical offset value.
Definition XTPChart3dPyramidSeriesLabelsViewDeviceCommand.h:236
CXTPChart3dPyramidSeriesLabelDeviceCommand::ComputeLabel
void ComputeLabel(CXTPChart3dDeviceContext *pDC)
Computes label.
CXTPChart3dPyramidSeriesLabelDeviceCommand::GetSeriesLabelView
CXTPChart3dPyramidSeriesLabelView * GetSeriesLabelView() const
Obtains the label view object pointer.
Definition XTPChart3dPyramidSeriesLabelsViewDeviceCommand.h:210
CXTPChart3dPyramidSeriesLabelDeviceCommand::CXTPChart3dPyramidSeriesLabelDeviceCommand
CXTPChart3dPyramidSeriesLabelDeviceCommand(CXTPChart3dPyramidSeriesLabelView *pSeriesLabelView)
Constructs a CXTPChart3dPyramidSeriesLabelDeviceCommand object.
CXTPChart3dPyramidSeriesLabelDeviceCommand::SetFailed
void SetFailed()
Sets the command object to a failed state.
Definition XTPChart3dPyramidSeriesLabelsViewDeviceCommand.h:204
CXTPChart3dPyramidSeriesLabelDeviceCommand::SetConnectorEndpointVerticalOffset
void SetConnectorEndpointVerticalOffset(double yOffset)
Sets the connector endpoint vertical offset value.
Definition XTPChart3dPyramidSeriesLabelsViewDeviceCommand.h:242
CXTPChart3dPyramidSeriesLabelDeviceCommand::ComputeConnectorVector
BOOL ComputeConnectorVector(CXTPChart3dDeviceContext *pDC)
Computes the connector vector.
CXTPChart3dPyramidSeriesLabelDeviceCommand::ExecuteOverride
virtual void ExecuteOverride(CXTPChartDeviceContext *pDC)
Override this function to write the drawing code for specific objects.
CXTPChart3dPyramidSeriesLabelDeviceCommand::GetLabelRect
CRect GetLabelRect() const
Obtains the label rectangle.
Definition XTPChart3dPyramidSeriesLabelsViewDeviceCommand.h:215
CXTPChart3dPyramidSeriesLabelDeviceCommand::GetConnectorLength
double GetConnectorLength() const
Determines the connector length value.
Definition XTPChart3dPyramidSeriesLabelsViewDeviceCommand.h:225
CXTPChart3dPyramidSeriesLabelDeviceCommand::IsFailed
BOOL IsFailed() const
Checks whether the command object is in a failed state.
Definition XTPChart3dPyramidSeriesLabelsViewDeviceCommand.h:199
CXTPChart3dPyramidSeriesLabelDeviceCommand::SetLabelRect
void SetLabelRect(CRect rcLabel)
Sets the label rectangle.
Definition XTPChart3dPyramidSeriesLabelsViewDeviceCommand.h:220
CXTPChart3dPyramidSeriesLabel
CXTPChartPyramidSeriesLabelBase is a kind of CXTPChart3dPyramidSeriesLabel.
Definition XTPChart3dPyramidSeriesLabel.h:45
CXTPChart3dPyramidSeriesLabelView
Represents series label view object.
Definition XTPChart3dPyramidSeriesLabel.h:77
CXTPChart3dPyramidSeriesLabelsViewDeviceCommand
Represents device command for all pyramid series labels view.
Definition XTPChart3dPyramidSeriesLabelsViewDeviceCommand.h:254
CXTPChart3dPyramidSeriesLabelsViewDeviceCommand::CXTPChart3dPyramidSeriesLabelsViewDeviceCommand
CXTPChart3dPyramidSeriesLabelsViewDeviceCommand(CXTPChart3dPyramidSeriesLabelsView *pSeriesLabelsView)
Constructs a command object instance.
CXTPChart3dPyramidSeriesLabelsViewDeviceCommand::ExecuteOverride
virtual void ExecuteOverride(CXTPChartDeviceContext *pDC)
Override this function to write the drawing code for specific objects.
CXTPChart3dPyramidSeriesLabelsView
Represents a view object for all pyramid series labels.
Definition XTPChart3dPyramidSeriesLabel.h:385
CXTPChart3dPyramidSeriesPointView
This class abstracts the view of a pyramid series point.
Definition XTPChart3dPyramidSeriesPointView.h:47
CXTPChartDeviceCommandEvents
Defines a callback interface for a chart device command event sink.
Definition XTPChartDeviceCommand.h:48
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPPoint3T< double >


Toolkit Pro: XTPChartGdiTransformationDeviceCommand.h Source File

  • Source
  • Chart
  • Drawing
  • Gdi
XTPChartGdiTransformationDeviceCommand.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTGDITRANSFORMATIONDEVICECOMMAND_H__)
24# define __XTPCHARTGDITRANSFORMATIONDEVICECOMMAND_H__
25
26# if _MSC_VER >= 1000
27# pragma once
28# endif // _MSC_VER >= 1000
29
30# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
31
32namespace Gdiplus
33{
34class GpRegion;
35}
36
42class _XTP_EXT_CLASS CXTPChartGdiSaveStateDeviceCommand : public CXTPChartDeviceCommand
43{
44public:
49 CXTPChartGdiSaveStateDeviceCommand();
50
51protected:
59 virtual void BeforeExecute(CXTPChartDeviceContext* pDC);
60
68 virtual void AfterExecute(CXTPChartDeviceContext* pDC);
69
70protected:
71 UINT m_nState;
72};
73
74class _XTP_EXT_CLASS CXTPChartGdiClipDeviceCommand : public CXTPChartClipDeviceCommand
75{
76public:
81 CXTPChartGdiClipDeviceCommand(CRect rcClip);
82
90 virtual void BeforeExecute(CXTPChartDeviceContext* pDC);
91
99 virtual void AfterExecute(CXTPChartDeviceContext* pDC);
100
101protected:
102 CRect m_rcState;
103};
104
105class _XTP_EXT_CLASS CXTPChartGdiClipRegionDeviceCommand : public CXTPChartDeviceCommand
106{
107public:
112 CXTPChartGdiClipRegionDeviceCommand(const CXTPChartPoints& points);
113
118 ~CXTPChartGdiClipRegionDeviceCommand();
119
120protected:
128 virtual void BeforeExecute(CXTPChartDeviceContext* pDC);
129
137 virtual void AfterExecute(CXTPChartDeviceContext* pDC);
138
139protected:
140 Gdiplus::GpRegion* m_pGpState;
141 Gdiplus::GpRegion* m_pGpClip;
142};
143
149class _XTP_EXT_CLASS CXTPChartGdiRotateDeviceCommand : public CXTPChartRotateDeviceCommand
150{
151public:
158 CXTPChartGdiRotateDeviceCommand(float fAngle);
159
167 CXTPChartGdiRotateDeviceCommand(float fAngle, const CXTPPoint3d& rotateVector);
168
169protected:
178 virtual void ExecuteOverride(CXTPChartDeviceContext* pDC);
179};
180
186class _XTP_EXT_CLASS CXTPChartGdiTranslateDeviceCommand : public CXTPChartTranslateDeviceCommand
187{
188public:
196 CXTPChartGdiTranslateDeviceCommand(double dx, double dy);
197
198public:
207 virtual void ExecuteOverride(CXTPChartDeviceContext* pDC);
208
209 CXTPChartElement* HitTest(CPoint point, CXTPChartElement* pParent) const;
210};
211
212# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
213#endif //#if !defined(__XTPCHARTGDITRANSFORMATIONDEVICECOMMAND_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartClipDeviceCommand
Base class implementation for 2D chart clipping device command.
Definition XTPChartTransformationDeviceCommand.h:38
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPChartDeviceCommand::AfterExecute
virtual void AfterExecute(CXTPChartDeviceContext *pDC)
This method gets called after a command is executed which allows for the customization of command beh...
CXTPChartDeviceCommand::BeforeExecute
virtual void BeforeExecute(CXTPChartDeviceContext *pDC)
This method gets called before a command is executed which allows for the customization of command be...
CXTPChartDeviceCommand::HitTest
virtual CXTPChartElement * HitTest(CPoint point, CXTPChartElement *pParent) const
Performs recursive hit testing of the element at the specified point.
CXTPChartDeviceCommand::ExecuteOverride
virtual void ExecuteOverride(CXTPChartDeviceContext *pDC)
Override this function to write the drawing code for specific objects.
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartElement
This class abstracts a chart element, this class acts as a base class for all chart elements.
Definition XTPChartElement.h:131
CXTPChartRotateDeviceCommand
Base class implementation for 2D chart rotation device command.
Definition XTPChartTransformationDeviceCommand.h:56
CXTPChartTranslateDeviceCommand
Base class implementation for 2D chart translation device command.
Definition XTPChartTransformationDeviceCommand.h:127
CXTPPoint3T< double >


Toolkit Pro: XTPHelpers.h Source File

  • Source
  • Controls
  • Util
XTPHelpers.h
Go to the documentation of this file.
1
23#if !defined(__XTHELPERS_H__)
24# define __XTHELPERS_H__
25
26# if _MSC_VER > 1000
27# pragma once
28# endif // _MSC_VER > 1000
29
30# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
31
32// Safely selects object into device context
33template<class T>
34class CXTPContextObjectHandler
35{
36 T* m_pObject;
37 CDC* m_pDC;
38
39public:
40 CXTPContextObjectHandler(CDC* pDC, T* object)
41 : m_pDC(pDC)
42 , m_pObject(pDC->SelectObject(object))
43 {
44 }
45
46 ~CXTPContextObjectHandler()
47 {
48 if (m_pObject)
49 {
50 m_pDC->SelectObject(m_pObject);
51 }
52 }
53};
54
55// Background mode context handler
56class CXTPContextBkModeHandler
57{
58 int m_nMode;
59 CDC* m_pDC;
60
61public:
62 CXTPContextBkModeHandler(CDC* pDC, int nNewMode)
63 : m_nMode(pDC->SetBkMode(nNewMode))
64 , m_pDC(pDC)
65 {
66 }
67
68 ~CXTPContextBkModeHandler()
69 {
70 m_pDC->SetBkMode(m_nMode);
71 }
72};
73
74// Text color context handler
75class CXTPContextTextColorHandler
76{
77 COLORREF m_clrFore;
78 CDC* m_pDC;
79
80public:
81 CXTPContextTextColorHandler(CDC* pDC, int clrFore)
82 : m_clrFore(pDC->SetTextColor(static_cast<COLORREF>(clrFore)))
83 , m_pDC(pDC)
84 {
85 }
86
87 ~CXTPContextTextColorHandler()
88 {
89 m_pDC->SetTextColor(m_clrFore);
90 }
91};
92
93// Background color context handler
94class CXTPContextBkColorHandler
95{
96 COLORREF m_clrBack;
97 CDC* m_pDC;
98
99public:
100 CXTPContextBkColorHandler(CDC* pDC, int clrBack)
101 : m_clrBack(pDC->SetBkColor(static_cast<COLORREF>(clrBack)))
102 , m_pDC(pDC)
103 {
104 }
105
106 ~CXTPContextBkColorHandler()
107 {
108 m_pDC->SetBkColor(m_clrBack);
109 }
110};
111
112// Handles viewport origin
113class CXTPContextViewPortOrgHandler
114{
115 CPoint m_pointOrigin;
116 CDC* m_pDC;
117
118public:
119 CXTPContextViewPortOrgHandler(CDC* pDC, const CPoint& pointOrigin)
120 : m_pointOrigin(pDC->SetViewportOrg(pointOrigin))
121 , m_pDC(pDC)
122 {
123 }
124
125 ~CXTPContextViewPortOrgHandler()
126 {
127 m_pDC->SetViewportOrg(m_pointOrigin);
128 }
129};
130
131# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
132#endif // #if !defined(__XTHELPERS_H__)
133
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h


Toolkit Pro: XTPComboBoxThemeResource.h Source File

  • Source
  • Controls
  • Combo
  • Themes
XTPComboBoxThemeResource.h
Go to the documentation of this file.
1
23#ifndef XTPComboBoxThemeResource_h__
24# define XTPComboBoxThemeResource_h__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPComboBoxThemeResource : public CXTPComboBoxTheme
39{
40public:
45 CXTPComboBoxThemeResource();
46
51 virtual ~CXTPComboBoxThemeResource();
52
53 virtual BOOL DrawComboBox(CDC* pDC, CXTPComboBox* pComboBox);
54
61 virtual void RefreshMetrics(CXTPComboBox* pComboBox);
62};
63
64# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
66#endif // XTPComboBoxThemeResource_h__
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPComboBox
The CXTPComboBox class provides the functionality of a themed Windows combobox.
Definition XTPComboBox.h:42
CXTPComboBoxTheme
CXTPComboBoxTheme is a class used to perform ComboBox Theme drawing tasks.
Definition XTPComboBoxTheme.h:42
CXTPComboBoxThemeResource
Used as the paint manager for a combobox control to render a resource appearance.
Definition XTPComboBoxThemeResource.h:39
CXTPComboBoxThemeResource::RefreshMetrics
virtual void RefreshMetrics(CXTPComboBox *pComboBox)
This member function is called by the theme manager to refresh the visual styles used by each compone...
CXTPComboBoxThemeResource::CXTPComboBoxThemeResource
CXTPComboBoxThemeResource()
Default constructor.
CXTPComboBoxThemeResource::~CXTPComboBoxThemeResource
virtual ~CXTPComboBoxThemeResource()
Destructor handles cleanup and deallocation.
CXTPComboBoxThemeResource::DrawComboBox
virtual BOOL DrawComboBox(CDC *pDC, CXTPComboBox *pComboBox)
Called by the framework to draw the combobox control.


Toolkit Pro: Member List

CXTPCalendarViewPartCustomizableValueT< _TValue > Member List

This is the complete list of members for CXTPCalendarViewPartCustomizableValueT< _TValue >, including all inherited members.

CopySettings(const CXTPCalendarViewPartCustomizableValueT< _TValue > &refSrc) | CXTPCalendarViewPartCustomizableValueT< _TValue > | inline
CXTPCalendarViewPartCustomizableValueT() | CXTPCalendarViewPartCustomizableValueT< _TValue > | inline
DeleteCustomValue() | CXTPCalendarViewPartCustomizableValueT< _TValue > | inlineprotectedvirtual
DeleteStandardValue() | CXTPCalendarViewPartCustomizableValueT< _TValue > | inlineprotectedvirtual
GetStandardValue() const | CXTPCalendarViewPartCustomizableValueT< _TValue > | inlinevirtual
GetValue() const | CXTPCalendarViewPartCustomizableValueT< _TValue > | inlinevirtual
IsCustomValue() const | CXTPCalendarViewPartCustomizableValueT< _TValue > | inlinevirtual
IsDefaultValue() const | CXTPCalendarViewPartCustomizableValueT< _TValue > | inlinevirtual
IsStandardValue() const | CXTPCalendarViewPartCustomizableValueT< _TValue > | inlinevirtual
m_bAutoDelete_Custom | CXTPCalendarViewPartCustomizableValueT< _TValue > | protected
m_bAutoDelete_Standard | CXTPCalendarViewPartCustomizableValueT< _TValue > | protected
m_pValueCustom | CXTPCalendarViewPartCustomizableValueT< _TValue > | protected
m_pValueStandard | CXTPCalendarViewPartCustomizableValueT< _TValue > | protected
operator _TValue *() const | CXTPCalendarViewPartCustomizableValueT< _TValue > | inline
operator->() | CXTPCalendarViewPartCustomizableValueT< _TValue > | inline
SetCustomValue(_TValue *pValue, BOOL bAutoDelete) | CXTPCalendarViewPartCustomizableValueT< _TValue > | inlinevirtual
SetDefaultValue() | CXTPCalendarViewPartCustomizableValueT< _TValue > | inlinevirtual
SetStandardValue(_TValue *pValue, BOOL bAutoDelete) | CXTPCalendarViewPartCustomizableValueT< _TValue > | inlinevirtual
~CXTPCalendarViewPartCustomizableValueT() | CXTPCalendarViewPartCustomizableValueT< _TValue > | inlinevirtual


Toolkit Pro: Member List

  • CXTPSyntaxEditBufferManager
  • CXTPSyntaxEditStringsManager
  • CStringPtrArray
CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager::CStringPtrArray Member List

This is the complete list of members for CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager::CStringPtrArray, including all inherited members.

CStringPtrArray() | CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager::CStringPtrArray |
RemoveAll() | CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager::CStringPtrArray |
~CStringPtrArray() | CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager::CStringPtrArray | virtual


Toolkit Pro: Member List

CXTPChartStepAreaSeriesStyle Member List

This is the complete list of members for CXTPChartStepAreaSeriesStyle, including all inherited members.

ApplyTo(CXTPChartDeviceCommand *pCommand) | CXTPChartSeriesStyle | virtual
CorrectAxisSideMargins(CXTPChartAxis *pAxis, double nMinValue, double nMaxValue, double &nCorrection) | CXTPChartSeriesStyle | virtual
CreateDiagram() | CXTPChartDiagram2DSeriesStyle | virtual
CreateView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView) | CXTPChartStepAreaSeriesStyle | protectedvirtual
CXTPChartAreaSeriesStyle() | CXTPChartAreaSeriesStyle |
CXTPChartDiagram2DSeriesStyle() | CXTPChartDiagram2DSeriesStyle |
CXTPChartElement() | CXTPChartElement |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartPointSeriesStyle() | CXTPChartPointSeriesStyle |
CXTPChartSeriesStyle() | CXTPChartSeriesStyle |
CXTPChartStepAreaSeriesStyle() | CXTPChartStepAreaSeriesStyle |
DoPropExchange(CXTPPropExchange *pPX) | CXTPChartStepAreaSeriesStyle | protectedvirtual
Enable3dEdgeSmoothing(BOOL bEnable=TRUE) | CXTPChartSeriesStyle | virtual
Get3dRotation() const | CXTPChartSeriesStyle | virtual
GetAppearance() const | CXTPChartElement |
GetColor() const | CXTPChartSeriesStyle | virtual
GetContent() const | CXTPChartElement |
GetErrorBar() const | CXTPChartSeriesStyle | virtual
GetFillAcrossXAxis() const | CXTPChartAreaSeriesStyle |
GetFillStyle() const | CXTPChartAreaSeriesStyle |
GetLabel() const | CXTPChartSeriesStyle | virtual
GetMarker() const | CXTPChartPointSeriesStyle |
GetOwner() const | CXTPChartElement |
GetSeriesPointValueIndex() const | CXTPChartSeriesStyle | virtual
GetStyleAppearance() const | CXTPChartSeriesStyle | virtual
GetTransparency() const | CXTPChartAreaSeriesStyle | virtual
Is3D() const | CXTPChartObject |
Is3dEdgeSmoothingEnabled() const | CXTPChartSeriesStyle | virtual
IsColorEach() const | CXTPChartSeriesStyle | virtual
IsStyleDiagram(CXTPChartDiagram *pDiagram) const | CXTPChartDiagram2DSeriesStyle | virtual
m_bColorEach | CXTPChartSeriesStyle | protected
m_bSmooth3dEdges | CXTPChartSeriesStyle | protected
m_clrColor | CXTPChartSeriesStyle | protected
m_nAxisIndexX | CXTPChartDiagram2DSeriesStyle | protected
m_nAxisIndexY | CXTPChartDiagram2DSeriesStyle | protected
m_nFillAcrossXAxis | CXTPChartAreaSeriesStyle | protected
m_nTransparency | CXTPChartAreaSeriesStyle | protected
m_pBorder | CXTPChartAreaSeriesStyle | protected
m_pErrorBar | CXTPChartSeriesStyle | protected
m_pFillStyle | CXTPChartAreaSeriesStyle | protected
m_pLabel | CXTPChartSeriesStyle | protected
m_Rotation3d | CXTPChartSeriesStyle | protected
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartElement | virtual
Release() | CXTPChartElement | virtual
Set3dRotation(const CXTPChart3dRotation &rotation) | CXTPChartSeriesStyle | virtual
Set3dRotation(double dYaw, double dPitch, double dRoll) | CXTPChartSeriesStyle | virtual
SetColor(CXTPChartColor clr) | CXTPChartSeriesStyle | virtual
SetColorEach(BOOL bColorEach) | CXTPChartSeriesStyle | virtual
SetErrorBar(CXTPChartErrorBar *pErrorBar) | CXTPChartSeriesStyle | virtual
SetFillAcrossXAxis(BOOL nFillAcrossXAxis) | CXTPChartAreaSeriesStyle |
SetLabel(CXTPChartSeriesLabel *pLabel) | CXTPChartSeriesStyle | virtual
SetTransparency(int nTransparency) | CXTPChartAreaSeriesStyle | virtual
~CXTPChartAreaSeriesStyle() | CXTPChartAreaSeriesStyle | virtual
~CXTPChartDiagram2DSeriesStyle() | CXTPChartDiagram2DSeriesStyle | virtual
~CXTPChartElement() | CXTPChartElement | virtual
~CXTPChartPointSeriesStyle() | CXTPChartPointSeriesStyle | virtual
~CXTPChartSeriesStyle() | CXTPChartSeriesStyle | virtual
~CXTPChartStepAreaSeriesStyle() | CXTPChartStepAreaSeriesStyle | virtual


Toolkit Pro: XTPSkinObjectScrollBar.h Source File

  • Source
  • SkinFramework
XTPSkinObjectScrollBar.h
Go to the documentation of this file.
1
23#if !defined(__XTPSKINOBJECTSCROLLBAR_H__)
24# define __XTPSKINOBJECTSCROLLBAR_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPSkinObjectScrollBar : public CXTPSkinObjectFrame
39{
41 DECLARE_DYNCREATE(CXTPSkinObjectScrollBar)
43public:
48 CXTPSkinObjectScrollBar();
49
54 virtual ~CXTPSkinObjectScrollBar();
55
56protected:
58 DECLARE_MESSAGE_MAP()
59
60 void OnDraw(CDC* pDC);
61
62 //{{AFX_VIRTUAL(CXTPSkinObjectScrollBar)
63 //}}AFX_VIRTUAL
64
65 //{{AFX_MSG(CXTPSkinObjectScrollBar)
66 afx_msg int OnCreate(LPCREATESTRUCT lpCreateStruct);
67 afx_msg void OnPaint();
68 afx_msg void OnEnable(BOOL bEnable);
69 afx_msg void OnMouseLeave();
70 afx_msg void OnMouseMove(UINT nFlags, CPoint point);
71 afx_msg void OnLButtonDown(UINT nFlags, CPoint point);
72 afx_msg void OnLButtonDblClk(UINT nFlags, CPoint point);
73 afx_msg LRESULT OnSetScrollInfo(WPARAM wParam, LPARAM lParam);
74 afx_msg LRESULT OnGetScrollInfo(WPARAM wParam, LPARAM lParam);
75 afx_msg LRESULT OnSetScrollPos(WPARAM wParam, LPARAM lParam);
76 afx_msg void OnSetFocus(CWnd* pOldWnd);
77 afx_msg LRESULT OnPrintClient(WPARAM wParam, LPARAM lParam);
78 //}}AFX_MSG
79
80protected:
81 XTP_SKINSCROLLBAR_POSINFO m_spiCtl;
83};
84
85# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
87#endif // !defined(__XTPSKINOBJECTSCROLLBAR_H__)
XTPDisableNoisyWarnings.h
CXTPSkinObjectFrame
CXTPSkinObjectFrame is a CXTPSkinObject derived class.
Definition XTPSkinObjectFrame.h:75
CXTPSkinObjectScrollBar
CXTPSkinObjectScrollBar is a CXTPSkinObjectFrame derived class.
Definition XTPSkinObjectScrollBar.h:39
CXTPSkinObjectScrollBar::~CXTPSkinObjectScrollBar
virtual ~CXTPSkinObjectScrollBar()
Destroys a CXTPSkinObjectScrollBar object, handles cleanup and deallocation.
CXTPSkinObjectScrollBar::CXTPSkinObjectScrollBar
CXTPSkinObjectScrollBar()
Constructs a CXTPSkinObjectScrollBar object.


Toolkit Pro: Member List

CXTPChartElementCollection Member List

This is the complete list of members for CXTPChartElementCollection, including all inherited members.

CXTPChartElement() | CXTPChartElement |
CXTPChartElementCollection() | CXTPChartElementCollection |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
DoPropExchange(CXTPPropExchange *pPX) | CXTPChartElement | virtual
GetAppearance() const | CXTPChartElement |
GetAt(int nIndex) const | CXTPChartElementCollection |
GetContent() const | CXTPChartElement |
GetCount() const | CXTPChartElementCollection | virtual
GetOwner() const | CXTPChartElement |
IndexOf(CXTPChartElement *pElement) const | CXTPChartElementCollection |
InsertAt(int nIndex, CXTPChartElement *pElement) | CXTPChartElementCollection |
Is3D() const | CXTPChartObject |
m_arrElements | CXTPChartElementCollection | protected
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartElement | virtual
Release() | CXTPChartElementCollection | virtual
Remove(CXTPChartElement *pElement) | CXTPChartElementCollection | virtual
RemoveAll() | CXTPChartElementCollection | virtual
RemoveAt(int nIndex) | CXTPChartElementCollection | virtual
~CXTPChartElement() | CXTPChartElement | virtual
~CXTPChartElementCollection() | CXTPChartElementCollection |


Toolkit Pro: XTPMarkupScrollViewer.h Source File

  • Source
  • Markup
  • Controls
XTPMarkupScrollViewer.h
Go to the documentation of this file.
1
23#if !defined(__XTPMARKUPSCROLLVIEWER_H__)
24# define __XTPMARKUPSCROLLVIEWER_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPMarkupScrollBarGripper;
34class CXTPMarkupScrollBar;
35class CXTPMarkupVisual;
36class CXTPMarkupDrawingContext;
37class CXTPMarkupMouseWheelEventArgs;
38class CXTPMarkupDependencyProperty;
39
40enum XTPMarkupScrollBarVisibility
41{
42 xtpMarkupScrollBarDisabled,
43 xtpMarkupScrollBarAuto,
44 xtpMarkupScrollBarVisible
45};
46
47class _XTP_EXT_CLASS CXTPMarkupScrollBarGripper : public CXTPMarkupUIElement
48{
50 DECLARE_MARKUPCLASS(CXTPMarkupScrollBarGripper)
52public:
53 void OnRender(CXTPMarkupDrawingContext* pDC);
54};
55
56class _XTP_EXT_CLASS CXTPMarkupScrollViewer : public CXTPMarkupContentControl
57{
58 DECLARE_MARKUPCLASS(CXTPMarkupScrollViewer);
59
60protected:
61 CXTPMarkupScrollViewer();
62 ~CXTPMarkupScrollViewer();
63
64public:
65 int GetVisualChildrenCount() const;
66 CXTPMarkupVisual* GetVisualChild(int nIndex) const;
67
68 void Scroll(int nBar, int cmd, int pos);
69 void SetScrollPos(int nBar, int pos);
70 int GetScrollPos(int nBar);
71 int GetScrollLimit(int nBar);
72
73 XTPMarkupScrollBarVisibility GetVerticalScrollBarVisibility() const;
74 XTPMarkupScrollBarVisibility GetHorizontalScrollBarVisibility() const;
75
76protected:
77 CSize ArrangeOverride(CSize szFinalSize);
78 CSize MeasureOverride(CXTPMarkupDrawingContext* pDC, CSize szAvailableSize);
79
80 void OnMouseWheel(CXTPMarkupMouseWheelEventArgs* e);
81
82protected:
83 void CreateScrollBar(int nBar);
84
86public:
87 DECLARE_DISPATCH_MAP()
88# ifdef _XTP_ACTIVEX
89 DECLARE_INTERFACE_MAP()
90 DECLARE_OLETYPELIB_EX(CXTPMarkupScrollViewer);
91# endif
92
93 afx_msg long OleGetVerticalOffset();
94 afx_msg long OleGetHorizontalOffset();
95 afx_msg void OleSetVerticalOffset(int nOffset);
96 afx_msg void OleSetHorizontalOffset(int nOffset);
97
100protected:
101 CXTPMarkupScrollBar* m_pVerticalScrollBar;
102 CXTPMarkupScrollBar* m_pHorizontalScrollBar;
103 CXTPMarkupScrollBarGripper* m_pScrollBarGripper;
104
105 int m_xOffset;
106 int m_yOffset;
107
108public:
109 static CXTPMarkupDependencyProperty* m_pVerticalScrollBarVisibilityProperty;
110 static CXTPMarkupDependencyProperty* m_pHorizontalScrollBarVisibilityProperty;
111};
112
113# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
115#endif // !defined(__XTPMARKUPSCROLLVIEWER_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPMarkupContentControl
CXTPMarkupContentControl is a CXTPMarkupControl derived class.
Definition XTPMarkupContentControl.h:45
CXTPMarkupUIElement
Base class for XML Markup core level implementations.
Definition XTPMarkupUIElement.h:43
CXTPMarkupVisual
Provides rendering support for XML Markup, which includes hit testing, coordinate transformation,...
Definition XTPMarkupInputElement.h:223
CXTPMarkupVisual::GetVisualChild
virtual CXTPMarkupVisual * GetVisualChild(int nIndex) const
Retrieves the child Visual object located at a specified index within the parent VisualCollection.
CXTPMarkupVisual::OnRender
virtual void OnRender(CXTPMarkupDrawingContext *drawingContext)
When overridden in a derived class, participates in rendering operations that are directed by the lay...
Definition XTPMarkupInputElement.h:515
CXTPMarkupVisual::GetVisualChildrenCount
virtual int GetVisualChildrenCount() const
Gets the number of child elements for the Visual.


Toolkit Pro: Member List

  • CXTPMarkupVisual
  • TransformationMatrices
CXTPMarkupVisual::TransformationMatrices Member List

This is the complete list of members for CXTPMarkupVisual::TransformationMatrices, including all inherited members.

pNewMatrix | CXTPMarkupVisual::TransformationMatrices
pOldMatrix | CXTPMarkupVisual::TransformationMatrices
TransformationMatrices() | CXTPMarkupVisual::TransformationMatrices
TransformationMatrices(CXTPMarkupTransformationMatrix *pOldMatrix, CXTPMarkupTransformationMatrix *pNewMatrix) | CXTPMarkupVisual::TransformationMatrices


Toolkit Pro: Member List

CXTPImageList Member List

This is the complete list of members for CXTPImageList, including all inherited members.

Add(CBitmap *pbmImage, CBitmap *pbmMask) | CXTPImageList |
Add(CBitmap *pbmImage, COLORREF crMask) | CXTPImageList |
Add(HICON hIcon) | CXTPImageList |
Attach(HIMAGELIST hImageList) | CXTPImageList |
BeginDrag(int nImage, CPoint ptHotSpot) | CXTPImageList |
Copy(int iDst, int iSrc, UINT uFlags=ILCF_MOVE) | CXTPImageList |
Copy(int iDst, CXTPImageList *pSrc, int iSrc, UINT uFlags=ILCF_MOVE) | CXTPImageList |
Create(int cx, int cy, UINT nFlags, int nInitial, int nGrow) | CXTPImageList |
Create(UINT nBitmapID, int cx, int nGrow, COLORREF crMask) | CXTPImageList |
Create(LPCTSTR lpszBitmapID, int cx, int nGrow, COLORREF crMask) | CXTPImageList |
Create(CXTPImageList &imagelist1, int nImage1, CXTPImageList &imagelist2, int nImage2, int dx, int dy) | CXTPImageList |
Create(CXTPImageList *pImageList) | CXTPImageList |
CXTPImageList() | CXTPImageList |
DeleteImageList() | CXTPImageList |
Detach() | CXTPImageList |
Draw(CDC *pDC, int nImage, POINT pt, UINT nStyle) | CXTPImageList |
DrawIndirect(IMAGELISTDRAWPARAMS *pimldp) | CXTPImageList |
ExtractIcon(int nImage) | CXTPImageList |
GetBkColor() const | CXTPImageList |
GetImageCount() const | CXTPImageList |
GetImageInfo(int nImage, IMAGEINFO *pImageInfo) const | CXTPImageList |
GetNativeGdiObject() | CXTPImageList |
GetNativeGdiObject() const | CXTPImageList |
GetSafeHandle() const | CXTPImageList |
operator CImageList &() | CXTPImageList |
operator const CImageList &() const | CXTPImageList |
operator HIMAGELIST() const | CXTPImageList |
Read(CArchive *pArchive) | CXTPImageList |
Remove(int nImage) | CXTPImageList |
Replace(int nImage, CBitmap *pbmImage, CBitmap *pbmMask) | CXTPImageList |
Replace(int nImage, HICON hIcon) | CXTPImageList |
SetBkColor(COLORREF cr) | CXTPImageList |
SetDragCursorImage(int nDrag, CPoint ptHotSpot) | CXTPImageList |
SetImageCount(UINT uNewCount) | CXTPImageList |
SetOverlayImage(int nImage, int nOverlay) | CXTPImageList |
Write(CArchive *pArchive) | CXTPImageList |
~CXTPImageList() | CXTPImageList | virtual


Toolkit Pro: Member List

CXTPShortcutBarResourceTheme Member List

This is the complete list of members for CXTPShortcutBarResourceTheme, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPShortcutBarOffice2003Theme() | CXTPShortcutBarOffice2003Theme |
CXTPShortcutBarPaintManager() | CXTPShortcutBarPaintManager |
CXTPShortcutBarResourceTheme() | CXTPShortcutBarResourceTheme |
DrawExpandButton(CDC *pDC, CRect rc) | CXTPShortcutBarResourceTheme | virtual
DrawGripper(CDC *pDC, CXTPShortcutBar *pShortcutBar, BOOL bDraw) | CXTPShortcutBarResourceTheme | virtual
DrawImage(CDC *pDC, CPoint pt, CSize sz, CXTPImageManagerIcon *pImage, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled) | CXTPShortcutBarOffice2003Theme | virtual
DrawNavigationItem(CDC *pDC, CXTPShortcutBarItem *pItem) | CXTPShortcutBarPaintManager | virtual
DrawPaneCaption(CDC *pDC, CXTPShortcutBarPane *pPane, BOOL bDraw) | CXTPShortcutBarResourceTheme | virtual
DrawPaneItemCaption(CDC *pDC, CXTPShortcutBarPaneItem *pItem, BOOL bDraw) | CXTPShortcutBarResourceTheme | virtual
DrawShortcutBarFrame(CDC *pDC, CXTPShortcutBar *pShortcutBar) | CXTPShortcutBarOffice2003Theme | virtual
DrawShortcutItem(CDC *pDC, CXTPShortcutBarItem *pItem) | CXTPShortcutBarPaintManager | virtual
FillNavigationItemEntry(CDC *pDC, CXTPShortcutBarItem *pItem) | CXTPShortcutBarResourceTheme | virtual
FillShortcutBar(CDC *pDC, CXTPShortcutBar *pShortcutBar) | CXTPShortcutBarResourceTheme | virtual
FillShortcutItemEntry(CDC *pDC, CXTPShortcutBarItem *pItem) | CXTPShortcutBarResourceTheme | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
IsShortcutItemTruncated(CDC *pDC, CXTPShortcutBarItem *pItem) | CXTPShortcutBarPaintManager |
Line(CDC *pDC, int x0, int y0, int x1, int y1, int nPen) | CXTPShortcutBarPaintManager |
m_bBoldItemCaptionFont | CXTPShortcutBarPaintManager |
m_bClearTypeTextQuality | CXTPShortcutBarPaintManager |
m_bNavigationButton | CXTPShortcutBarPaintManager |
m_bShowTopLeftCaptionShadow | CXTPShortcutBarOffice2003Theme |
m_bUseStandardFont | CXTPShortcutBarPaintManager |
m_clrCaptionText | CXTPShortcutBarOffice2003Theme |
m_clrDisabledText | CXTPShortcutBarPaintManager |
m_clrHotText | CXTPShortcutBarPaintManager |
m_clrItemCaptionShadow | CXTPShortcutBarOffice2003Theme |
m_clrItemCaptionText | CXTPShortcutBarOffice2003Theme |
m_clrItemCaptionTop | CXTPShortcutBarOffice2003Theme |
m_clrNormalText | CXTPShortcutBarPaintManager |
m_clrPushedText | CXTPShortcutBarPaintManager |
m_clrSelectedText | CXTPShortcutBarPaintManager |
m_clrShortcutItemShadow | CXTPShortcutBarPaintManager |
m_grcCaption | CXTPShortcutBarOffice2003Theme |
m_grcHot | CXTPShortcutBarPaintManager |
m_grcItemCaption | CXTPShortcutBarOffice2003Theme |
m_grcItemHotCaption | CXTPShortcutBarOffice2003Theme |
m_grcPushed | CXTPShortcutBarPaintManager |
m_grcSelected | CXTPShortcutBarPaintManager |
m_grcShortcutBarGripper | CXTPShortcutBarPaintManager |
m_grcShortcutItem | CXTPShortcutBarPaintManager |
m_nExpandedIconWidth | CXTPShortcutBarPaintManager |
m_nNormalIconWidth | CXTPShortcutBarPaintManager |
m_nPaneItemHeight | CXTPShortcutBarPaintManager |
m_pExpandIcon | CXTPShortcutBarPaintManager |
m_rcCaptionPadding | CXTPShortcutBarPaintManager |
m_rcItemCaptionPadding | CXTPShortcutBarPaintManager |
m_strOfficeFont | CXTPShortcutBarPaintManager |
m_xtpFontPaneCaption | CXTPShortcutBarPaintManager |
m_xtpFontPaneItemCaption | CXTPShortcutBarPaintManager |
m_xtpFontText | CXTPShortcutBarPaintManager |
m_xtpFontVerticalText | CXTPShortcutBarPaintManager |
Rectangle(CDC *pDC, CRect rc, int nPen, int nBrush) | CXTPShortcutBarPaintManager |
RefreshMetrics() | CXTPShortcutBarResourceTheme | virtual
~CXTPShortcutBarPaintManager() | CXTPShortcutBarPaintManager | virtual


Toolkit Pro: XTPTabColorSetVisualStudio2008.h Source File

  • Source
  • TabManager
  • ColorSets
XTPTabColorSetVisualStudio2008.h
Go to the documentation of this file.
1
23#if !defined(__XTPTABCOLORSETVISUALSTUDIO2008_H__)
24# define __XTPTABCOLORSETVISUALSTUDIO2008_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
47class _XTP_EXT_CLASS CXTPTabColorSetVisualStudio2008 : public CXTPTabColorSetOffice2003
48{
49public:
54 CXTPTabColorSetVisualStudio2008();
55
56public:
64 void RefreshMetrics();
65
81 COLORREF FillPropertyButton(CDC* pDC, CRect rcItem, CXTPTabManagerItem* pItem);
82
83protected:
84 BOOL m_bGradientButton;
87};
88
89# define CColorSetVisualStudio2008 CXTPTabColorSetVisualStudio2008
90
91# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
93#endif // !defined(__XTPTABCOLORSETVISUALSTUDIO2008_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPTabColorSetOffice2003
CXTPTabColorSetOffice2003 implements an Office 2003 tab color set.
Definition XTPTabColorSetOffice2003.h:44
CXTPTabColorSetVisualStudio2008
CXTPTabColorSetVisualStudio2008 implements a Visual Studio 2008 tab color set.
Definition XTPTabColorSetVisualStudio2008.h:48
CXTPTabColorSetVisualStudio2008::m_bGradientButton
BOOL m_bGradientButton
TRUE if luna colors are enabled.
Definition XTPTabColorSetVisualStudio2008.h:84
CXTPTabColorSetVisualStudio2008::FillPropertyButton
COLORREF FillPropertyButton(CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem)
Fills a specified tab button.
CXTPTabColorSetVisualStudio2008::CXTPTabColorSetVisualStudio2008
CXTPTabColorSetVisualStudio2008()
Constructs a CXTPTabColorSetVisualStudio2008 object.
CXTPTabColorSetVisualStudio2008::RefreshMetrics
void RefreshMetrics()
Refreshes the visual metrics of the tabs.
CXTPTabManagerItem
CXTPTabManagerItem is the base class for the tabs that appear in the command bars tab workspace,...
Definition XTPTabManagerItem.h:44


Toolkit Pro: XTPTrackThemeVisualStudio2012.h Source File

  • Source
  • GridControl
  • TrackControl
  • Themes
XTPTrackThemeVisualStudio2012.h
Go to the documentation of this file.
1
23#if !defined(__XTPTRACKTHEMEVISUALSTUDIO2012_H__)
24# define __XTPTRACKTHEMEVISUALSTUDIO2012_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPTrackThemeVisualStudio2012Light : public CXTPTrackThemeOffice2013
39{
40public:
45 CXTPTrackThemeVisualStudio2012Light();
46
51 virtual void LoadGlyphs();
52
58 virtual void RefreshMetrics();
59};
60
66class _XTP_EXT_CLASS CXTPTrackThemeVisualStudio2012Dark : public CXTPTrackThemeOffice2013
67{
68public:
73 CXTPTrackThemeVisualStudio2012Dark();
74
79 virtual void LoadGlyphs();
80
86 virtual void RefreshMetrics();
87};
88
94class _XTP_EXT_CLASS CXTPTrackThemeVisualStudio2012Blue : public CXTPTrackThemeOffice2013
95{
96public:
101 CXTPTrackThemeVisualStudio2012Blue();
102
107 virtual void LoadGlyphs();
108
114 virtual void RefreshMetrics();
115};
117# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
118#endif //#if !defined(__XTPTRACKTHEMEVISUALSTUDIO2012_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPTrackThemeOffice2013
CXTPTrackThemeOffice2013 is a CXTPTrackPaintManager derived class that represents an Office 2013 styl...
Definition XTPTrackThemeOffice2013.h:39
CXTPTrackThemeVisualStudio2012Blue
CXTPTrackThemeVisualStudio2012Blue is a CXTPTrackThemeOffice2013 derived class that represents a Visu...
Definition XTPTrackThemeVisualStudio2012.h:95
CXTPTrackThemeVisualStudio2012Blue::LoadGlyphs
virtual void LoadGlyphs()
Loads the default images used by the track control.
CXTPTrackThemeVisualStudio2012Blue::CXTPTrackThemeVisualStudio2012Blue
CXTPTrackThemeVisualStudio2012Blue()
Default paint manager constructor, handles properties initialization.
CXTPTrackThemeVisualStudio2012Blue::RefreshMetrics
virtual void RefreshMetrics()
This method is called to refresh the visual metrics of the track control.
CXTPTrackThemeVisualStudio2012Dark
CXTPTrackThemeVisualStudio2012Dark is a CXTPTrackThemeOffice2013 derived class that represents a Visu...
Definition XTPTrackThemeVisualStudio2012.h:67
CXTPTrackThemeVisualStudio2012Dark::CXTPTrackThemeVisualStudio2012Dark
CXTPTrackThemeVisualStudio2012Dark()
Default paint manager constructor, handles properties initialization.
CXTPTrackThemeVisualStudio2012Dark::LoadGlyphs
virtual void LoadGlyphs()
Loads the default images used by the track control.
CXTPTrackThemeVisualStudio2012Dark::RefreshMetrics
virtual void RefreshMetrics()
This method is called to refresh the visual metrics of the track control.
CXTPTrackThemeVisualStudio2012Light
CXTPTrackThemeVisualStudio2012Light is a CXTPTrackThemeOffice2013 derived class that represents a Vis...
Definition XTPTrackThemeVisualStudio2012.h:39
CXTPTrackThemeVisualStudio2012Light::CXTPTrackThemeVisualStudio2012Light
CXTPTrackThemeVisualStudio2012Light()
Default paint manager constructor, handles properties initialization.
CXTPTrackThemeVisualStudio2012Light::LoadGlyphs
virtual void LoadGlyphs()
Loads the default images used by the track control.
CXTPTrackThemeVisualStudio2012Light::RefreshMetrics
virtual void RefreshMetrics()
This method is called to refresh the visual metrics of the track control.


Toolkit Pro: Member List

CXTPWinThemeWrapper Member List

This is the complete list of members for CXTPWinThemeWrapper, including all inherited members.

BeginBufferedPaint(HDC hdcTarget, const RECT *prcTarget, XTP_UX_BUFFERFORMAT dwFormat, XTP_UX_PAINTPARAMS *pPaintParams, HDC *phdc) | CXTPWinThemeWrapper |
BufferedPaintSetAlpha(HPAINTBUFFER hBufferedPaint, const RECT *prc, BYTE alpha) | CXTPWinThemeWrapper |
CloseThemeData() | CXTPWinThemeWrapper |
CXTPWinThemeWrapper(BOOL bUseSkinFramework=TRUE) | CXTPWinThemeWrapper |
DrawThemeBackground(HDC hDC, int iPartID, int iStateID, const RECT *pRect, const RECT *pClipRect) | CXTPWinThemeWrapper |
DrawThemeBackgroundEx(HDC hDC, int iPartID, int iStateID, const RECT *pRect, const PDTBGOPTS pOptions) | CXTPWinThemeWrapper |
DrawThemeEdge(HDC hDC, int iPartID, int iStateID, const RECT *pDestRect, UINT uEdge, UINT uFlags, RECT *pContentRect) | CXTPWinThemeWrapper |
DrawThemeIcon(HDC hDC, int iPartID, int iStateID, const RECT *pRect, HIMAGELIST himl, int iImageIndex) | CXTPWinThemeWrapper |
DrawThemeParentBackground(HWND hWnd, HDC hDC, RECT *pRect) | CXTPWinThemeWrapper |
DrawThemeText(HDC hDC, int iPartID, int iStateID, LPCWSTR pszText, int iCharCount, DWORD dwTextFlags, DWORD dwTextFlags2, const RECT *pRect) | CXTPWinThemeWrapper |
DrawThemeTextEx(HDC hdc, int iPartId, int iStateId, LPCWSTR pszText, int cchText, DWORD dwTextFlags, LPRECT pRect, const XTP_UX_DTTOPTS *pOptions) | CXTPWinThemeWrapper |
EnableThemeDialogTexture(HWND hWnd, DWORD dwFlags) | CXTPWinThemeWrapper |
EnableTheming(BOOL bEnable) | CXTPWinThemeWrapper |
EndBufferedPaint(HPAINTBUFFER hBufferedPaint, BOOL fUpdateTarget) | CXTPWinThemeWrapper |
GetCurrentThemeName(LPWSTR pszThemeFileName, int dwMaxNameChars, LPWSTR pszColorBuff, int cchMaxColorChars, LPWSTR pszSizeBuff, int cchMaxSizeChars) | CXTPWinThemeWrapper |
GetThemeAppProperties() | CXTPWinThemeWrapper |
GetThemeBackgroundContentRect(HDC hDC, int iPartID, int iStateID, const RECT *pBoundingRect, RECT *pContentRect) | CXTPWinThemeWrapper |
GetThemeBackgroundExtent(HDC hDC, int iPartID, int iStateID, const RECT *pContentRect, RECT *pExtentRect) | CXTPWinThemeWrapper |
GetThemeBackgroundRegion(HDC hDC, int iPartID, int iStateID, const RECT *pRect, HRGN *pRegion) | CXTPWinThemeWrapper |
GetThemeBool(int iPartID, int iStateID, int iPropID, BOOL *pfVal) | CXTPWinThemeWrapper |
GetThemeColor(int iPartID, int iStateID, int iPropID, COLORREF *pColor) | CXTPWinThemeWrapper |
GetThemeDocumentationProperty(LPCWSTR pszThemeName, LPCWSTR pszPropertyName, LPWSTR pszValueBuff, int cchMaxValChars) | CXTPWinThemeWrapper |
GetThemeEnumValue(int iPartID, int iStateID, int iPropID, int *piVal) | CXTPWinThemeWrapper |
GetThemeFilename(int iPartID, int iStateID, int iPropID, LPWSTR pszThemeFilename, int cchMaxBuffChars) | CXTPWinThemeWrapper |
GetThemeFont(HDC hDC, int iPartID, int iStateID, int iPropID, LOGFONTW *pFont) | CXTPWinThemeWrapper |
GetThemeInt(int iPartID, int iStateID, int iPropID, int *piVal) | CXTPWinThemeWrapper |
GetThemeIntList(int iPartID, int iStateID, int iPropID, INTLIST *pIntList) | CXTPWinThemeWrapper |
GetThemeMargins(HDC hDC, int iPartID, int iStateID, int iPropID, RECT *pRect, MARGINS *pMargins) | CXTPWinThemeWrapper |
GetThemeMetric(HDC hDC, int iPartID, int iStateID, int iPropID, int *piVal) | CXTPWinThemeWrapper |
GetThemePartSize(HDC hDC, int iPartID, int iStateID, RECT *pRect, THEMESIZE eSize, SIZE *pSize) | CXTPWinThemeWrapper |
GetThemePosition(int iPartID, int iStateID, int iPropID, POINT *pPoint) | CXTPWinThemeWrapper |
GetThemePropertyOrigin(int iPartID, int iStateID, int iPropID, PROPERTYORIGIN *pOrigin) | CXTPWinThemeWrapper |
GetThemeRect(int iPartID, int iStateID, int iPropID, RECT *pRect) | CXTPWinThemeWrapper |
GetThemeString(int iPartID, int iStateID, int iPropID, LPWSTR pszBuff, int cchMaxBuffChars) | CXTPWinThemeWrapper |
GetThemeSysBool(int iBoolID) | CXTPWinThemeWrapper |
GetThemeSysColor(int iColorID) | CXTPWinThemeWrapper |
GetThemeSysColorBrush(int iColorID) | CXTPWinThemeWrapper |
GetThemeSysFont(int iFontID, LOGFONT *pLF) | CXTPWinThemeWrapper |
GetThemeSysInt(int iIntID, int *piValue) | CXTPWinThemeWrapper |
GetThemeSysSize(int iSizeID) | CXTPWinThemeWrapper |
GetThemeSysString(int iStringID, LPWSTR pszStringBuff, int cchMaxStringChars) | CXTPWinThemeWrapper |
GetThemeTextExtent(HDC hDC, int iPartID, int iStateID, LPCWSTR pszText, int iCharCount, DWORD dwTextFlags, const RECT *pBoundingRect, RECT *pExtentRect) | CXTPWinThemeWrapper |
GetThemeTextMetrics(HDC hDC, int iPartID, int iStateID, TEXTMETRIC *ptm) | CXTPWinThemeWrapper |
GetWindowTheme(HWND hWnd) | CXTPWinThemeWrapper |
HitTestThemeBackground(HDC hDC, int iPartID, int iStateID, DWORD dwOptions, const RECT *pRect, HRGN hRgn, POINT ptTest, WORD *pwHitTestCode) | CXTPWinThemeWrapper |
IsAppThemeActive() const | CXTPWinThemeWrapper |
IsAppThemed() const | CXTPWinThemeWrapper |
IsAppThemeReady() const | CXTPWinThemeWrapper |
IsThemeActive() const | CXTPWinThemeWrapper |
IsThemeBackgroundPartiallyTransparent(int iPartID, int iStateID) | CXTPWinThemeWrapper |
IsThemeDialogTextureEnabled(HWND hWnd) | CXTPWinThemeWrapper |
IsThemePartDefined(int iPartID, int iStateID) | CXTPWinThemeWrapper |
OpenThemeData(HWND hWnd, LPCWSTR pszClassList) | CXTPWinThemeWrapper |
SetThemeAppProperties(DWORD dwFlags) | CXTPWinThemeWrapper |
SetThemeWrapperPtr(int nThemeWrapper, LPVOID lpWrapperPtr) | CXTPWinThemeWrapper |
SetWindowTheme(HWND hWnd, LPCWSTR pszSubAppName, LPCWSTR pszSubIdList) | CXTPWinThemeWrapper |
ThemeAppProperties() | CXTPWinThemeWrapper |
ThemeDataOpen() const | CXTPWinThemeWrapper |
~CXTPWinThemeWrapper() | CXTPWinThemeWrapper | virtual


Toolkit Pro: Member List

CXTPMarkupFrameworkElement Member List

This is the complete list of members for CXTPMarkupFrameworkElement, including all inherited members.

ApplyRenderTransform(CXTPMarkupDrawingContext *pContext) | CXTPMarkupUIElement | protectedvirtual
Arrange(CRect rcFinalRect) | CXTPMarkupUIElement |
ArrangeCore(CRect rcFinalRect) | CXTPMarkupUIElement | protectedvirtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPMarkupFrameworkElement() | CXTPMarkupFrameworkElement | protected
CXTPMarkupUIElement() | CXTPMarkupUIElement | protected
CXTPMarkupVisual() | CXTPMarkupVisual |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAbsoluteVisualOffset() const | CXTPMarkupVisual | protected
GetActualSize() const | CXTPMarkupFrameworkElement |
GetBoundRect() const | CXTPMarkupVisual |
GetClipToBounds() const | CXTPMarkupFrameworkElement |
GetDesiredSize() const | CXTPMarkupUIElement |
GetFinalRect() const | CXTPMarkupUIElement |
GetHeight() const | CXTPMarkupFrameworkElement |
GetHorizontalAlignment() const | CXTPMarkupFrameworkElement |
GetLayoutClip(CRect &rc) const | CXTPMarkupUIElement | protectedvirtual
GetLogicalChild(int nIndex) const | CXTPMarkupVisual | virtual
GetLogicalChildrenCount() const | CXTPMarkupVisual | virtual
GetMargin() const | CXTPMarkupFrameworkElement |
GetMaxHeight() const | CXTPMarkupFrameworkElement |
GetMaxWidth() const | CXTPMarkupFrameworkElement |
GetMinHeight() const | CXTPMarkupFrameworkElement |
GetMinWidth() const | CXTPMarkupFrameworkElement |
GetOpacity() const | CXTPMarkupUIElement | protectedvirtual
GetRenderSize() const | CXTPMarkupVisual |
GetRenderTransform() const | CXTPMarkupUIElement | protected
GetStyle() const | CXTPMarkupFrameworkElement |
GetTag() const | CXTPMarkupFrameworkElement |
GetUpdateRect() const | CXTPMarkupVisual |
GetVerticalAlignment() const | CXTPMarkupFrameworkElement |
GetVisibility() const | CXTPMarkupUIElement |
GetVisualChild(int nIndex) const | CXTPMarkupVisual | virtual
GetVisualChildrenCount() const | CXTPMarkupVisual | virtual
GetVisualOffset() const | CXTPMarkupVisual |
GetVisualParent() const | CXTPMarkupVisual |
GetWidth() const | CXTPMarkupFrameworkElement |
InputHitTest(CPoint point) const | CXTPMarkupVisual |
InputHitTestOverride(CPoint point) const | CXTPMarkupVisual | protectedvirtual
InvalidateArrange() | CXTPMarkupUIElement | virtual
InvalidateMeasure() | CXTPMarkupUIElement | virtual
InvalidateMeasureOverride(CXTPMarkupDrawingContext *pDC) | CXTPMarkupUIElement | protectedvirtual
InvalidateVisual() | CXTPMarkupUIElement | virtual
IsEnabled() const | CXTPMarkupUIElement |
IsFocusable() const | CXTPMarkupUIElement |
IsVisible() const | CXTPMarkupUIElement | virtual
m_bArrangeDirty | CXTPMarkupUIElement | protected
m_bArrangeInProgress | CXTPMarkupUIElement | protected
m_bMeasureDirty | CXTPMarkupUIElement | protected
m_bMeasureInProgress | CXTPMarkupUIElement | protected
m_bNeverArranged | CXTPMarkupUIElement | protected
m_bNeverMeasured | CXTPMarkupUIElement | protected
m_pClipToBoundsProperty | CXTPMarkupUIElement | static
m_pFocusableProperty | CXTPMarkupUIElement | static
m_pIsEnabledProperty | CXTPMarkupUIElement | static
m_pOpacityProperty | CXTPMarkupUIElement | static
m_pRenderTransformOriginProperty | CXTPMarkupUIElement | static
m_pRenderTransformProperty | CXTPMarkupUIElement | static
m_ptVisualOffset | CXTPMarkupVisual | protected
m_pVisibilityProperty | CXTPMarkupUIElement | static
m_rcBoundRect | CXTPMarkupVisual | protected
m_rcFinalRect | CXTPMarkupUIElement | protected
m_rcPrevUpdateRect | CXTPMarkupVisual | protected
m_rcUpdateRect | CXTPMarkupVisual | protected
m_szDesiredSize | CXTPMarkupUIElement | protected
m_szPreviousAvailableSize | CXTPMarkupUIElement | protected
m_szRenderSize | CXTPMarkupVisual | protected
Measure(CXTPMarkupDrawingContext *pDC, CSize szAvailableSize) | CXTPMarkupUIElement |
MeasureCore(CXTPMarkupDrawingContext *pDC, CSize szAvailableSize) | CXTPMarkupUIElement | protectedvirtual
OnRender(CXTPMarkupDrawingContext *drawingContext) | CXTPMarkupVisual | protectedvirtual
OnRenderFocusVisual(CXTPMarkupDrawingContext *drawingContext) | CXTPMarkupVisual | protectedvirtual
PtInRectTransform(const RECT &rect, const POINT &point) const | CXTPMarkupVisual | protected
Render(CXTPMarkupDrawingContext *drawingContext) | CXTPMarkupVisual |
RenderClipped(CXTPMarkupDrawingContext *drawingContext) | CXTPMarkupVisual | protectedvirtual
RestoreRenderTransform(CXTPMarkupDrawingContext *pContext, TransformationMatrices &matrices) | CXTPMarkupUIElement | protectedvirtual
SetClipToBounds(BOOL bClipToBounds) | CXTPMarkupFrameworkElement |
SetHeight(int nHeight) | CXTPMarkupFrameworkElement |
SetHorizontalAlignment(XTPMarkupHorizontalAlignment alignment) | CXTPMarkupFrameworkElement |
SetMargin(int nLeft, int nTop, int nRight, int nBottom) | CXTPMarkupFrameworkElement |
SetMargin(int nMargin) | CXTPMarkupFrameworkElement |
SetMaxHeight(int nHeight) | CXTPMarkupFrameworkElement |
SetMaxWidth(int nWidth) | CXTPMarkupFrameworkElement |
SetMinHeight(int nHeight) | CXTPMarkupFrameworkElement |
SetMinWidth(int nWidth) | CXTPMarkupFrameworkElement |
SetTag(CXTPMarkupObject *pTag) | CXTPMarkupFrameworkElement |
SetVerticalAlignment(XTPMarkupVerticalAlignment alignment) | CXTPMarkupFrameworkElement |
SetVisibility(XTPMarkupVisibility visibility) | CXTPMarkupUIElement |
SetWidth(int nWidth) | CXTPMarkupFrameworkElement |
~CXTPMarkupFrameworkElement() | CXTPMarkupFrameworkElement | protectedvirtual
~CXTPMarkupUIElement() | CXTPMarkupUIElement | protectedvirtual
~CXTPMarkupVisual() | CXTPMarkupVisual | virtual


Toolkit Pro: XTPFrameThemeOffice2013.h Source File

  • Source
  • CommandBars
  • Frame
XTPFrameThemeOffice2013.h
Go to the documentation of this file.
1
23#if !defined(__XTPFRAMETHEMEOFFICE2013_H__)
24# define __XTPFRAMETHEMEOFFICE2013_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPPaintManager;
34class CXTPCommandBarsFrameHook;
35class CXTPRibbonBar;
36
37class _XTP_EXT_CLASS CXTPFrameThemeOffice2013 : public CXTPFrameThemeModernUI
38{
39public:
40 CXTPFrameThemeOffice2013(CXTPPaintManager* pPaintManager);
41
42 virtual ~CXTPFrameThemeOffice2013();
43
44protected:
54 virtual void DrawCaptionBar(CDC* pDC, CRect rcCaptionBar, CWnd* pSite, BOOL bActive);
55
67 virtual void DrawFrameCaptionButton(CDC* pDC, CRect rc, int nId, BOOL bSelected, BOOL bPressed,
68 BOOL bActive);
69
82 virtual void DrawFrameCaptionButton(CDC* pDC, CRect rc, int nId, BOOL bSelected, BOOL bPressed,
83 BOOL bActive, CXTPRibbonBar* pRibbonBar);
84
89 virtual void RefreshMetrics();
90
97 virtual void LoadParts(BOOL bReload = FALSE);
98
99 virtual LPCTSTR GetStyleResourceName() const;
100
101 virtual CRect CalcFrameBorder(const CXTPCommandBarsFrameHook* pFrameHook) const;
102
103 virtual CXTPFrameShadow* CreateShadow(CWnd* pFrame);
104
105 CXTPPaintManagerColor m_clrFrameCaptionBorder;
106
107 CXTPColorSetCaptionButton m_csFrameCloseButtonActive;
109 CXTPColorSetCaptionButton m_csFrameCloseButtonInactive;
111 CXTPColorSetCaptionButton m_csFrameCloseButtonHot;
112 CXTPColorSetCaptionButton m_csFrameCloseButtonPressed;
115 CXTPColorSetCaptionButton m_csFrameCloseButtonActiveBSMode;
117 CXTPColorSetCaptionButton m_csFrameCloseButtonInactiveBSMode;
119 CXTPColorSetCaptionButton m_csFrameCaptionButtonInactiveBSMode;
120 CXTPColorSetCaptionButton m_csFrameCaptionButtonActiveBSMode;
121 CXTPColorSetCaptionButton m_csFrameCaptionButtonHotBSMode;
122 CXTPColorSetCaptionButton m_csFrameCaptionButtonPressedBSMode;
123
124 using CXTPFrameThemeModernUI::m_bMarkupPartsLoaded;
125};
127# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
128#endif // !defined(__XTPFRAMETHEMEOFFICE2013_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPColorSetCaptionButton
Default theme caption button color set.
Definition XTPTheme.h:40
CXTPCommandBarsFrameHook
CXTPCommandBarsFrameHook is a CXTPHookManagerHookAble derived class.
Definition XTPFrameHook.h:56
CXTPFramePaintManager::DrawCaptionBar
virtual void DrawCaptionBar(CDC *pDC, CRect rcCaptionBar, CWnd *pSite, BOOL bActive)
This method is called to draw the frame caption bar.
CXTPFramePaintManager::CreateShadow
virtual CXTPFrameShadow * CreateShadow(CWnd *pFrame)
Creates frame shadow if supported by theme.
CXTPFrameShadow
The class represents frame shadow object.
Definition XTPFrameShadow.h:47
CXTPPaintManagerColor
The CXTPPaintManagerColor class is used to manage COLORREF values for determining default and applica...
Definition XTPColorManager.h:117
CXTPPaintManager
Paint manager of the command bars.
Definition XTPPaintManager.h:199
CXTPRibbonBar
CXTPRibbonBar is a CXTPMenuBar derived class.
Definition XTPRibbonBar.h:69


Toolkit Pro: XTPSkinManagerLegacyApiHook.h Source File

  • Source
  • SkinFramework
  • ApiHook
XTPSkinManagerLegacyApiHook.h
Go to the documentation of this file.
1
23#if !defined(__XTPSKINMANAGERLEGACYAPIHOOK_H__) && defined(XTP_SKINFRAMEWORK_USE_LEGACY_API_HOOK)
24# define __XTPSKINMANAGERLEGACYAPIHOOK_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPWinThemeWrapper;
34
37enum XTPSkinFrameworkLegacyApiFunctionIndex
38{
39 xtpSkinLegacyApiLoadLibraryA_KERNEL32,
40 xtpSkinLegacyApiLoadLibraryA_API_MS_WIN_CORE_LIBRARYLOADER_L1_1_0,
41 xtpSkinLegacyApiLoadLibraryA_API_MS_WIN_CORE_LIBRARYLOADER_L1_1_1,
42 xtpSkinLegacyApiLoadLibraryA_API_MS_WIN_CORE_LIBRARYLOADER_L1_2_0,
43 xtpSkinLegacyApiLoadLibraryA_API_MS_WIN_CORE_LIBRARYLOADER_PRIVATE_L1_1_0,
44 xtpSkinLegacyApiLoadLibraryA_API_MS_WIN_CORE_LIBRARYLOADER_L1_2_1,
45 xtpSkinLegacyApiLoadLibraryA_API_MS_WIN_CORE_LIBRARYLOADER_L1_2_2,
46 xtpSkinLegacyApiLoadLibraryA_API_MS_WIN_CORE_LIBRARYLOADER_L2_1_0,
47 xtpSkinLegacyApiLoadLibraryW_KERNEL32,
48 xtpSkinLegacyApiLoadLibraryW_API_MS_WIN_CORE_LIBRARYLOADER_L1_1_0,
49 xtpSkinLegacyApiLoadLibraryW_API_MS_WIN_CORE_LIBRARYLOADER_L1_1_1,
50 xtpSkinLegacyApiLoadLibraryW_API_MS_WIN_CORE_LIBRARYLOADER_L1_2_0,
51 xtpSkinLegacyApiLoadLibraryW_API_MS_WIN_CORE_LIBRARYLOADER_PRIVATE_L1_1_0,
52 xtpSkinLegacyApiLoadLibraryW_API_MS_WIN_CORE_LIBRARYLOADER_L1_2_1,
53 xtpSkinLegacyApiLoadLibraryW_API_MS_WIN_CORE_LIBRARYLOADER_L1_2_2,
54 xtpSkinLegacyApiLoadLibraryW_API_MS_WIN_CORE_LIBRARYLOADER_L2_1_0,
55 xtpSkinLegacyApiLoadLibraryExA_KERNEL32,
56 xtpSkinLegacyApiLoadLibraryExA_API_MS_WIN_CORE_LIBRARYLOADER_L1_1_0,
57 xtpSkinLegacyApiLoadLibraryExA_API_MS_WIN_CORE_LIBRARYLOADER_L1_1_1,
58 xtpSkinLegacyApiLoadLibraryExA_API_MS_WIN_CORE_LIBRARYLOADER_L1_2_0,
59 xtpSkinLegacyApiLoadLibraryExA_API_MS_WIN_CORE_LIBRARYLOADER_PRIVATE_L1_1_0,
60 xtpSkinLegacyApiLoadLibraryExA_API_MS_WIN_CORE_LIBRARYLOADER_L1_2_1,
61 xtpSkinLegacyApiLoadLibraryExA_API_MS_WIN_CORE_LIBRARYLOADER_L1_2_2,
62 xtpSkinLegacyApiLoadLibraryExA_API_MS_WIN_CORE_LIBRARYLOADER_L2_1_0,
63 xtpSkinLegacyApiLoadLibraryExW_KERNEL32,
64 xtpSkinLegacyApiLoadLibraryExW_API_MS_WIN_CORE_LIBRARYLOADER_L1_1_0,
65 xtpSkinLegacyApiLoadLibraryExW_API_MS_WIN_CORE_LIBRARYLOADER_L1_1_1,
66 xtpSkinLegacyApiLoadLibraryExW_API_MS_WIN_CORE_LIBRARYLOADER_L1_2_0,
67 xtpSkinLegacyApiLoadLibraryExW_API_MS_WIN_CORE_LIBRARYLOADER_PRIVATE_L1_1_0,
68 xtpSkinLegacyApiLoadLibraryExW_API_MS_WIN_CORE_LIBRARYLOADER_L1_2_1,
69 xtpSkinLegacyApiLoadLibraryExW_API_MS_WIN_CORE_LIBRARYLOADER_L1_2_2,
70 xtpSkinLegacyApiLoadLibraryExW_API_MS_WIN_CORE_LIBRARYLOADER_L2_1_0,
71 xtpSkinLegacyApiFreeLibrary_KERNEL32,
72 xtpSkinLegacyApiFreeLibrary_API_MS_WIN_CORE_LIBRARYLOADER_L1_1_0,
73 xtpSkinLegacyApiFreeLibrary_API_MS_WIN_CORE_LIBRARYLOADER_L1_1_1,
74 xtpSkinLegacyApiFreeLibrary_API_MS_WIN_CORE_LIBRARYLOADER_L1_2_0,
75 xtpSkinLegacyApiFreeLibrary_API_MS_WIN_CORE_LIBRARYLOADER_PRIVATE_L1_1_0,
76 xtpSkinLegacyApiFreeLibrary_API_MS_WIN_CORE_LIBRARYLOADER_L1_2_1,
77 xtpSkinLegacyApiFreeLibrary_API_MS_WIN_CORE_LIBRARYLOADER_L1_2_2,
78 xtpSkinLegacyApiFreeLibrary_API_MS_WIN_CORE_LIBRARYLOADER_L2_1_0,
79 xtpSkinLegacyApiFreeLibraryAndExitThread_KERNEL32,
80 xtpSkinLegacyApiFreeLibraryAndExitThread_API_MS_WIN_CORE_LIBRARYLOADER_L1_1_0,
81 xtpSkinLegacyApiFreeLibraryAndExitThread_API_MS_WIN_CORE_LIBRARYLOADER_L1_1_1,
82 xtpSkinLegacyApiFreeLibraryAndExitThread_API_MS_WIN_CORE_LIBRARYLOADER_L1_2_0,
83 xtpSkinLegacyApiFreeLibraryAndExitThread_API_MS_WIN_CORE_LIBRARYLOADER_PRIVATE_L1_1_0,
84 xtpSkinLegacyApiFreeLibraryAndExitThread_API_MS_WIN_CORE_LIBRARYLOADER_L1_2_1,
85 xtpSkinLegacyApiFreeLibraryAndExitThread_API_MS_WIN_CORE_LIBRARYLOADER_L1_2_2,
86 xtpSkinLegacyApiFreeLibraryAndExitThread_API_MS_WIN_CORE_LIBRARYLOADER_L2_1_0,
87 xtpSkinLegacyApiGetProcAddress_KERNEL32,
88 xtpSkinLegacyApiGetProcAddress_API_MS_WIN_CORE_LIBRARYLOADER_L1_1_0,
89 xtpSkinLegacyApiGetProcAddress_API_MS_WIN_CORE_LIBRARYLOADER_L1_1_1,
90 xtpSkinLegacyApiGetProcAddress_API_MS_WIN_CORE_LIBRARYLOADER_L1_2_0,
91 xtpSkinLegacyApiGetProcAddress_API_MS_WIN_CORE_LIBRARYLOADER_PRIVATE_L1_1_0,
92 xtpSkinLegacyApiGetProcAddress_API_MS_WIN_CORE_LIBRARYLOADER_L1_2_1,
93 xtpSkinLegacyApiGetProcAddress_API_MS_WIN_CORE_LIBRARYLOADER_L1_2_2,
94 xtpSkinLegacyApiGetProcAddress_API_MS_WIN_CORE_LIBRARYLOADER_L2_1_0,
95 xtpSkinLegacyApiGetModuleHandleA_KERNEL32,
96 xtpSkinLegacyApiGetModuleHandleA_API_MS_WIN_CORE_LIBRARYLOADER_L1_1_0,
97 xtpSkinLegacyApiGetModuleHandleA_API_MS_WIN_CORE_LIBRARYLOADER_L1_1_1,
98 xtpSkinLegacyApiGetModuleHandleA_API_MS_WIN_CORE_LIBRARYLOADER_L1_2_0,
99 xtpSkinLegacyApiGetModuleHandleA_API_MS_WIN_CORE_LIBRARYLOADER_PRIVATE_L1_1_0,
100 xtpSkinLegacyApiGetModuleHandleA_API_MS_WIN_CORE_LIBRARYLOADER_L1_2_1,
101 xtpSkinLegacyApiGetModuleHandleA_API_MS_WIN_CORE_LIBRARYLOADER_L1_2_2,
102 xtpSkinLegacyApiGetModuleHandleA_API_MS_WIN_CORE_LIBRARYLOADER_L2_1_0,
103 xtpSkinLegacyApiGetModuleHandleW_KERNEL32,
104 xtpSkinLegacyApiGetModuleHandleW_API_MS_WIN_CORE_LIBRARYLOADER_L1_1_0,
105 xtpSkinLegacyApiGetModuleHandleW_API_MS_WIN_CORE_LIBRARYLOADER_L1_1_1,
106 xtpSkinLegacyApiGetModuleHandleW_API_MS_WIN_CORE_LIBRARYLOADER_L1_2_0,
107 xtpSkinLegacyApiGetModuleHandleW_API_MS_WIN_CORE_LIBRARYLOADER_PRIVATE_L1_1_0,
108 xtpSkinLegacyApiGetModuleHandleW_API_MS_WIN_CORE_LIBRARYLOADER_L1_2_1,
109 xtpSkinLegacyApiGetModuleHandleW_API_MS_WIN_CORE_LIBRARYLOADER_L1_2_2,
110 xtpSkinLegacyApiGetModuleHandleW_API_MS_WIN_CORE_LIBRARYLOADER_L2_1_0,
111 xtpSkinLegacyApiGetModuleHandleExA_KERNEL32,
112 xtpSkinLegacyApiGetModuleHandleExA_API_MS_WIN_CORE_LIBRARYLOADER_L1_1_0,
113 xtpSkinLegacyApiGetModuleHandleExA_API_MS_WIN_CORE_LIBRARYLOADER_L1_1_1,
114 xtpSkinLegacyApiGetModuleHandleExA_API_MS_WIN_CORE_LIBRARYLOADER_L1_2_0,
115 xtpSkinLegacyApiGetModuleHandleExA_API_MS_WIN_CORE_LIBRARYLOADER_PRIVATE_L1_1_0,
116 xtpSkinLegacyApiGetModuleHandleExA_API_MS_WIN_CORE_LIBRARYLOADER_L1_2_1,
117 xtpSkinLegacyApiGetModuleHandleExA_API_MS_WIN_CORE_LIBRARYLOADER_L1_2_2,
118 xtpSkinLegacyApiGetModuleHandleExA_API_MS_WIN_CORE_LIBRARYLOADER_L2_1_0,
119 xtpSkinLegacyApiGetModuleHandleExW_KERNEL32,
120 xtpSkinLegacyApiGetModuleHandleExW_API_MS_WIN_CORE_LIBRARYLOADER_L1_1_0,
121 xtpSkinLegacyApiGetModuleHandleExW_API_MS_WIN_CORE_LIBRARYLOADER_L1_1_1,
122 xtpSkinLegacyApiGetModuleHandleExW_API_MS_WIN_CORE_LIBRARYLOADER_L1_2_0,
123 xtpSkinLegacyApiGetModuleHandleExW_API_MS_WIN_CORE_LIBRARYLOADER_PRIVATE_L1_1_0,
124 xtpSkinLegacyApiGetModuleHandleExW_API_MS_WIN_CORE_LIBRARYLOADER_L1_2_1,
125 xtpSkinLegacyApiGetModuleHandleExW_API_MS_WIN_CORE_LIBRARYLOADER_L1_2_2,
126 xtpSkinLegacyApiGetModuleHandleExW_API_MS_WIN_CORE_LIBRARYLOADER_L2_1_0,
127 xtpSkinLegacyApiCreateThread_KERNEL32,
128 xtpSkinLegacyApiCreateThread_API_MS_WIN_CORE_PROCESSTHREADS_L1_1_1,
129 xtpSkinLegacyApiCreateThread_API_MS_WIN_CORE_PROCESSTHREADS_L1_1_2,
130 xtpSkinLegacyApiRegisterClassA,
131 xtpSkinLegacyApiRegisterClassW,
132 xtpSkinLegacyApiGetSysColor,
133 xtpSkinLegacyApiGetSysColorBrush,
134 xtpSkinLegacyApiDrawEdge,
135 xtpSkinLegacyApiDrawFrameControl,
136 xtpSkinLegacyApiSetScrollInfo,
137 xtpSkinLegacyApiSetScrollPos,
138 xtpSkinLegacyApiGetScrollInfo,
139 xtpSkinLegacyApiEnableScrollBar,
140 xtpSkinLegacyApiOpenThemeData,
141 xtpSkinLegacyApiOpenThemeDataForDpi,
142 xtpSkinLegacyApiOpenThemeDataEx,
143 xtpSkinLegacyApiDrawThemeBackground,
144 xtpSkinLegacyApiCloseThemeData,
145 xtpSkinLegacyApiGetThemeColor,
146 xtpSkinLegacyApiGetThemeInt,
147 xtpSkinLegacyApiIsAppThemed,
148 xtpSkinLegacyApiIsThemeActive,
149 xtpSkinLegacyApiGetCurrentThemeName,
150 xtpSkinLegacyApiGetThemeSysBool,
151 xtpSkinLegacyApiGetThemeSysColor,
152 xtpSkinLegacyApiGetThemePartSize,
153 xtpSkinLegacyApiSystemParametersInfoA,
154 xtpSkinLegacyApiSystemParametersInfoW,
155 xtpSkinLegacyApiDefWindowProcA,
156 xtpSkinLegacyApiDefWindowProcW,
157 xtpSkinLegacyApiDefMDIChildProcA,
158 xtpSkinLegacyApiDefMDIChildProcW,
159 xtpSkinLegacyApiDefFrameProcA,
160 xtpSkinLegacyApiDefFrameProcW,
161 xtpSkinLegacyApiDefDlgProcA,
162 xtpSkinLegacyApiDefDlgProcW,
163 xtpSkinLegacyApiCallWindowProcA,
164 xtpSkinLegacyApiCallWindowProcW,
165 xtpSkinLegacyApiFillRect,
166 xtpSkinLegacyApiDeleteObject,
167 xtpSkinLegacyApiAdjustWindowRectEx,
168 xtpSkinLegacyApiAdjustWindowRect,
169 xtpSkinLegacyApiGetSystemMetrics,
170 xtpSkinLegacyApiTrackPopupMenu,
171 xtpSkinLegacyApiTrackPopupMenuEx_USER32,
172 xtpSkinLegacyApiNtUserTrackPopupMenuEx_WIN32U,
173 xtpSkinLegacyApiDrawMenuBar,
174 xtpSkinLegacyApiGetMenuItemRect,
175 xtpSkinLegacyApiDwmExtendFrameIntoClientArea,
176 XTP_SKIN_LEGACY_API_HOOK_COUNT
177};
178
179class CXTPSkinManagerLegacyApiHook;
180class CXTPSkinManagerModuleList;
181
182class _XTP_EXT_CLASS CXTPSkinManagerLegacyApiFunction : public CXTPSynchronized
183{
184public:
185 CXTPSkinManagerLegacyApiFunction(CXTPSkinManagerLegacyApiHook* pApiHook,
186 LPCSTR pszCalleeModName, LPCSTR pszFuncName, PROC pfnOrig,
187 PROC pfnHook, PROC pfnAltOrig = NULL);
188
189 virtual ~CXTPSkinManagerLegacyApiFunction();
190
191public:
192 BOOL HookImport(CXTPSkinManagerModuleList* pModuleList);
193 BOOL UnhookImport(CXTPSkinManagerModuleList* pModuleList);
194 BOOL UnhookImport(HMODULE hmod);
195 BOOL IsHooked() const;
196 PROC GetOriginal() const;
197
198 static PVOID GetAfxWndProc();
199
200private:
201 BOOL ReplaceInOneModule(LPCSTR pszCalleeModName, PROC pfnCurrent, PROC pfnNew,
202 HMODULE hmodCaller, PROC pfnAltCurrent = NULL);
203 BOOL ReplaceInAllModules(LPCSTR pszCalleeModName, PROC pfnCurrent, PROC pfnNew,
204 CXTPSkinManagerModuleList* pModuleList, PROC pfnAltCurrent = NULL);
205
206private:
207 CXTPSkinManagerLegacyApiHook* m_pApiHook;
208 BOOL m_bHooked;
209 char m_szCalleeModName[50];
210 PROC m_pfnOrig;
211 PROC m_pfnAltOrig;
212 PROC m_pfnHook;
213 char m_szFuncName[30];
214
215 static PVOID sm_pvMaxAppAddr;
216
217 friend class CXTPSkinManagerLegacyApiHook;
218 friend class CXTPSkinObject;
219};
220
221AFX_INLINE BOOL CXTPSkinManagerLegacyApiFunction::IsHooked() const
222{
223 return m_bHooked;
224}
225
226AFX_INLINE PROC CXTPSkinManagerLegacyApiFunction::GetOriginal() const
227{
228 return m_pfnOrig;
229}
230
231class _XTP_EXT_CLASS CXTPSkinManagerLegacyApiHook : public CXTPSkinManagerApiHookBase
232{
233 DECLARE_DYNAMIC(CXTPSkinManagerLegacyApiHook);
234
235 struct EXCLUDEDMODULE
236 {
237 HMODULE hModule;
238 CString strModule;
239 BOOL bWin9x;
240 };
241
242 struct APIHOOKINFO
243 {
244 XTPSkinFrameworkLegacyApiFunctionIndex nIndex;
245 LPCSTR lpModuleName;
246 LPCSTR lpRoutineName;
247 PROC pfnHook;
248 int nApplyOptions;
249 bool (CXTPSystemVersion::*pfnVersionCheck)() const;
250 };
251
252public:
253 CXTPSkinManagerLegacyApiHook();
254 virtual ~CXTPSkinManagerLegacyApiHook();
255
256 virtual void InitializeHookManagement();
257 virtual void FinalizeHookManagement();
258 virtual void ExcludeModule(LPCTSTR lpszModule, BOOL bWin9x);
259 virtual LPVOID GetOriginalFunctionAddress(int nFunction) const;
260 virtual BOOL AdjustWindowRectExOrig(LPRECT lpRect, DWORD dwStyle, BOOL bMenu, DWORD dwExStyle);
261 virtual LRESULT CallWindowProcOrig(WNDPROC lpPrevWndFunc, HWND hWnd, UINT Msg, WPARAM wParam,
262 LPARAM lParam);
263 virtual LPVOID GetOpenThemeDataOriginalPtr() const;
264 virtual LPVOID GetCloseThemeDataOriginalPtr() const;
265 virtual void ConnectWrapper(CXTPWinThemeWrapper* pThemeWrapper);
266
267public:
268 static CXTPSkinManagerLegacyApiHook* AFX_CDECL GetInstance();
269
270 BOOL IsModuleExcluded(HMODULE hModule) const;
271
272 CXTPSkinManagerLegacyApiFunction* GetHookedFunction(LPCSTR pszCalleeModName,
273 LPCSTR pszFuncName);
274 CXTPSkinManagerLegacyApiFunction*
275 GetHookedFunction(XTPSkinFrameworkLegacyApiFunctionIndex nIndex);
276
277 static FARPROC WINAPI GetProcAddressWindows(HMODULE hmod, LPCSTR pszProcName);
278 static FARPROC WINAPI GetProcAddressManual(HMODULE hmod, LPCSTR pszProcName);
279 static HMODULE WINAPI GetModuleHandleAWindows(LPCSTR pszModuleName);
280
281protected:
282 void UnhookAllFunctions(BOOL bFinal);
283 void UnhookAllFunctions(HMODULE hModule);
284 CXTPSkinManagerLegacyApiFunction* HookImport(XTPSkinFrameworkLegacyApiFunctionIndex nIndex,
285 LPCSTR pszCalleeModName, LPCSTR pszFuncName,
286 PROC pfnHook,
287 CXTPSkinManagerModuleList* pModuleList);
288
289private:
290 void ProcessExcludedModules();
291 void IncrementAllModulesReferenceCounters(CXTPSkinManagerModuleList* pModuleList,
292 BOOL bIncrement = TRUE);
293
294 CXTPSkinManagerLegacyApiFunction* AddHook(XTPSkinFrameworkLegacyApiFunctionIndex nIndex,
295 LPCSTR pszCalleeModName, LPCSTR pszFuncName,
296 PROC pfnOrig, PROC pfnHook,
297 CXTPSkinManagerModuleList* pModuleList);
298
299 BOOL RemoveHook(LPCSTR pszCalleeModName, LPCSTR pszFuncName);
300
301 void HackModuleOnLoad(HMODULE hmod, DWORD dwFlags);
302
303 static CXTPSkinManagerLegacyApiFunction* AFX_CDECL EnterHookedCall(LPCSTR pszCalleeModName,
304 LPCSTR pszFuncName);
305 static CXTPSkinManagerLegacyApiFunction* AFX_CDECL
306 EnterHookedCall(XTPSkinFrameworkLegacyApiFunctionIndex nIndex);
307
308 static HMODULE WINAPI OnHookLoadLibraryA_KERNEL32(LPCSTR pszModuleName);
309 static HMODULE WINAPI
310 OnHookLoadLibraryA_API_MS_WIN_CORE_LIBRARYLOADER_L1_1_0(LPCSTR pszModuleName);
311 static HMODULE WINAPI
312 OnHookLoadLibraryA_API_MS_WIN_CORE_LIBRARYLOADER_L1_1_1(LPCSTR pszModuleName);
313 static HMODULE WINAPI
314 OnHookLoadLibraryA_API_MS_WIN_CORE_LIBRARYLOADER_L1_2_0(LPCSTR pszModuleName);
315 static HMODULE WINAPI
316 OnHookLoadLibraryA_API_MS_WIN_CORE_LIBRARYLOADER_PRIVATE_L1_1_0(LPCSTR pszModuleName);
317 static HMODULE WINAPI
318 OnHookLoadLibraryA_API_MS_WIN_CORE_LIBRARYLOADER_L1_2_1(LPCSTR pszModuleName);
319 static HMODULE WINAPI
320 OnHookLoadLibraryA_API_MS_WIN_CORE_LIBRARYLOADER_L1_2_2(LPCSTR pszModuleName);
321 static HMODULE WINAPI
322 OnHookLoadLibraryA_API_MS_WIN_CORE_LIBRARYLOADER_L2_1_0(LPCSTR pszModuleName);
323 static HMODULE WINAPI OnHookLoadLibraryW_KERNEL32(PCWSTR pszModuleName);
324 static HMODULE WINAPI
325 OnHookLoadLibraryW_API_MS_WIN_CORE_LIBRARYLOADER_L1_1_0(PCWSTR pszModuleName);
326 static HMODULE WINAPI
327 OnHookLoadLibraryW_API_MS_WIN_CORE_LIBRARYLOADER_L1_1_1(PCWSTR pszModuleName);
328 static HMODULE WINAPI
329 OnHookLoadLibraryW_API_MS_WIN_CORE_LIBRARYLOADER_L1_2_0(PCWSTR pszModuleName);
330 static HMODULE WINAPI
331 OnHookLoadLibraryW_API_MS_WIN_CORE_LIBRARYLOADER_PRIVATE_L1_1_0(PCWSTR pszModuleName);
332 static HMODULE WINAPI
333 OnHookLoadLibraryW_API_MS_WIN_CORE_LIBRARYLOADER_L1_2_1(PCWSTR pszModuleName);
334 static HMODULE WINAPI
335 OnHookLoadLibraryW_API_MS_WIN_CORE_LIBRARYLOADER_L1_2_2(PCWSTR pszModuleName);
336 static HMODULE WINAPI
337 OnHookLoadLibraryW_API_MS_WIN_CORE_LIBRARYLOADER_L2_1_0(PCWSTR pszModuleName);
338 static HMODULE WINAPI OnHookLoadLibraryExA_KERNEL32(LPCSTR pszModuleName, HANDLE hFile,
339 DWORD dwFlags);
340 static HMODULE WINAPI OnHookLoadLibraryExA_API_MS_WIN_CORE_LIBRARYLOADER_L1_1_0(
341 LPCSTR pszModuleName, HANDLE hFile, DWORD dwFlags);
342 static HMODULE WINAPI OnHookLoadLibraryExA_API_MS_WIN_CORE_LIBRARYLOADER_L1_1_1(
343 LPCSTR pszModuleName, HANDLE hFile, DWORD dwFlags);
344 static HMODULE WINAPI OnHookLoadLibraryExA_API_MS_WIN_CORE_LIBRARYLOADER_L1_2_0(
345 LPCSTR pszModuleName, HANDLE hFile, DWORD dwFlags);
346 static HMODULE WINAPI OnHookLoadLibraryExA_API_MS_WIN_CORE_LIBRARYLOADER_PRIVATE_L1_1_0(
347 LPCSTR pszModuleName, HANDLE hFile, DWORD dwFlags);
348 static HMODULE WINAPI OnHookLoadLibraryExA_API_MS_WIN_CORE_LIBRARYLOADER_L1_2_1(
349 LPCSTR pszModuleName, HANDLE hFile, DWORD dwFlags);
350 static HMODULE WINAPI OnHookLoadLibraryExA_API_MS_WIN_CORE_LIBRARYLOADER_L1_2_2(
351 LPCSTR pszModuleName, HANDLE hFile, DWORD dwFlags);
352 static HMODULE WINAPI OnHookLoadLibraryExA_API_MS_WIN_CORE_LIBRARYLOADER_L2_1_0(
353 LPCSTR pszModuleName, HANDLE hFile, DWORD dwFlags);
354 static HMODULE WINAPI OnHookLoadLibraryExW_KERNEL32(PCWSTR pszModuleName, HANDLE hFile,
355 DWORD dwFlags);
356 static HMODULE WINAPI OnHookLoadLibraryExW_API_MS_WIN_CORE_LIBRARYLOADER_L1_1_0(
357 PCWSTR pszModuleName, HANDLE hFile, DWORD dwFlags);
358 static HMODULE WINAPI OnHookLoadLibraryExW_API_MS_WIN_CORE_LIBRARYLOADER_L1_1_1(
359 PCWSTR pszModuleName, HANDLE hFile, DWORD dwFlags);
360 static HMODULE WINAPI OnHookLoadLibraryExW_API_MS_WIN_CORE_LIBRARYLOADER_L1_2_0(
361 PCWSTR pszModuleName, HANDLE hFile, DWORD dwFlags);
362 static HMODULE WINAPI OnHookLoadLibraryExW_API_MS_WIN_CORE_LIBRARYLOADER_PRIVATE_L1_1_0(
363 PCWSTR pszModuleName, HANDLE hFile, DWORD dwFlags);
364 static HMODULE WINAPI OnHookLoadLibraryExW_API_MS_WIN_CORE_LIBRARYLOADER_L1_2_1(
365 PCWSTR pszModuleName, HANDLE hFile, DWORD dwFlags);
366 static HMODULE WINAPI OnHookLoadLibraryExW_API_MS_WIN_CORE_LIBRARYLOADER_L1_2_2(
367 PCWSTR pszModuleName, HANDLE hFile, DWORD dwFlags);
368 static HMODULE WINAPI OnHookLoadLibraryExW_API_MS_WIN_CORE_LIBRARYLOADER_L2_1_0(
369 PCWSTR pszModuleName, HANDLE hFile, DWORD dwFlags);
370 static BOOL WINAPI OnHookFreeLibrary_KERNEL32(HMODULE hmod);
371 static BOOL WINAPI OnHookFreeLibrary_API_MS_WIN_CORE_LIBRARYLOADER_L1_1_0(HMODULE hmod);
372 static BOOL WINAPI OnHookFreeLibrary_API_MS_WIN_CORE_LIBRARYLOADER_L1_1_1(HMODULE hmod);
373 static BOOL WINAPI OnHookFreeLibrary_API_MS_WIN_CORE_LIBRARYLOADER_L1_2_0(HMODULE hmod);
374 static BOOL WINAPI OnHookFreeLibrary_API_MS_WIN_CORE_LIBRARYLOADER_PRIVATE_L1_1_0(HMODULE hmod);
375 static BOOL WINAPI OnHookFreeLibrary_API_MS_WIN_CORE_LIBRARYLOADER_L1_2_1(HMODULE hmod);
376 static BOOL WINAPI OnHookFreeLibrary_API_MS_WIN_CORE_LIBRARYLOADER_L1_2_2(HMODULE hmod);
377 static BOOL WINAPI OnHookFreeLibrary_API_MS_WIN_CORE_LIBRARYLOADER_L2_1_0(HMODULE hmod);
378 static BOOL WINAPI OnHookFreeLibraryAndExitThread_KERNEL32(HMODULE hmod, DWORD dwExitCode);
379 static BOOL WINAPI OnHookFreeLibraryAndExitThread_API_MS_WIN_CORE_LIBRARYLOADER_L1_1_0(
380 HMODULE hmod, DWORD dwExitCode);
381 static BOOL WINAPI OnHookFreeLibraryAndExitThread_API_MS_WIN_CORE_LIBRARYLOADER_L1_1_1(
382 HMODULE hmod, DWORD dwExitCode);
383 static BOOL WINAPI OnHookFreeLibraryAndExitThread_API_MS_WIN_CORE_LIBRARYLOADER_L1_2_0(
384 HMODULE hmod, DWORD dwExitCode);
385 static BOOL WINAPI OnHookFreeLibraryAndExitThread_API_MS_WIN_CORE_LIBRARYLOADER_PRIVATE_L1_1_0(
386 HMODULE hmod, DWORD dwExitCode);
387 static BOOL WINAPI OnHookFreeLibraryAndExitThread_API_MS_WIN_CORE_LIBRARYLOADER_L1_2_1(
388 HMODULE hmod, DWORD dwExitCode);
389 static BOOL WINAPI OnHookFreeLibraryAndExitThread_API_MS_WIN_CORE_LIBRARYLOADER_L1_2_2(
390 HMODULE hmod, DWORD dwExitCode);
391 static BOOL WINAPI OnHookFreeLibraryAndExitThread_API_MS_WIN_CORE_LIBRARYLOADER_L2_1_0(
392 HMODULE hmod, DWORD dwExitCode);
393 static FARPROC WINAPI OnHookGetProcAddress_KERNEL32(HMODULE hmod, PCSTR pszProcName);
394 static FARPROC WINAPI
395 OnHookGetProcAddress_API_MS_WIN_CORE_LIBRARYLOADER_L1_1_0(HMODULE hmod, PCSTR pszProcName);
396 static FARPROC WINAPI
397 OnHookGetProcAddress_API_MS_WIN_CORE_LIBRARYLOADER_L1_1_1(HMODULE hmod, PCSTR pszProcName);
398 static FARPROC WINAPI
399 OnHookGetProcAddress_API_MS_WIN_CORE_LIBRARYLOADER_L1_2_0(HMODULE hmod, PCSTR pszProcName);
400 static FARPROC WINAPI OnHookGetProcAddress_API_MS_WIN_CORE_LIBRARYLOADER_PRIVATE_L1_1_0(
401 HMODULE hmod, PCSTR pszProcName);
402 static FARPROC WINAPI
403 OnHookGetProcAddress_API_MS_WIN_CORE_LIBRARYLOADER_L1_2_1(HMODULE hmod, PCSTR pszProcName);
404 static FARPROC WINAPI
405 OnHookGetProcAddress_API_MS_WIN_CORE_LIBRARYLOADER_L1_2_2(HMODULE hmod, PCSTR pszProcName);
406 static FARPROC WINAPI
407 OnHookGetProcAddress_API_MS_WIN_CORE_LIBRARYLOADER_L2_1_0(HMODULE hmod, PCSTR pszProcName);
408 static HMODULE WINAPI OnHookGetModuleHandleA_KERNEL32(LPCSTR lpModuleName);
409 static HMODULE WINAPI
410 OnHookGetModuleHandleA_API_MS_WIN_CORE_LIBRARYLOADER_L1_1_0(LPCSTR lpModuleName);
411 static HMODULE WINAPI
412 OnHookGetModuleHandleA_API_MS_WIN_CORE_LIBRARYLOADER_L1_1_1(LPCSTR lpModuleName);
413 static HMODULE WINAPI
414 OnHookGetModuleHandleA_API_MS_WIN_CORE_LIBRARYLOADER_L1_2_0(LPCSTR lpModuleName);
415 static HMODULE WINAPI
416 OnHookGetModuleHandleA_API_MS_WIN_CORE_LIBRARYLOADER_PRIVATE_L1_1_0(LPCSTR lpModuleName);
417 static HMODULE WINAPI
418 OnHookGetModuleHandleA_API_MS_WIN_CORE_LIBRARYLOADER_L1_2_1(LPCSTR lpModuleName);
419 static HMODULE WINAPI
420 OnHookGetModuleHandleA_API_MS_WIN_CORE_LIBRARYLOADER_L1_2_2(LPCSTR lpModuleName);
421 static HMODULE WINAPI
422 OnHookGetModuleHandleA_API_MS_WIN_CORE_LIBRARYLOADER_L2_1_0(LPCSTR lpModuleName);
423 static HMODULE WINAPI OnHookGetModuleHandleW_KERNEL32(LPCWSTR lpModuleName);
424 static HMODULE WINAPI
425 OnHookGetModuleHandleW_API_MS_WIN_CORE_LIBRARYLOADER_L1_1_0(LPCWSTR lpModuleName);
426 static HMODULE WINAPI
427 OnHookGetModuleHandleW_API_MS_WIN_CORE_LIBRARYLOADER_L1_1_1(LPCWSTR lpModuleName);
428 static HMODULE WINAPI
429 OnHookGetModuleHandleW_API_MS_WIN_CORE_LIBRARYLOADER_L1_2_0(LPCWSTR lpModuleName);
430 static HMODULE WINAPI
431 OnHookGetModuleHandleW_API_MS_WIN_CORE_LIBRARYLOADER_PRIVATE_L1_1_0(LPCWSTR lpModuleName);
432 static HMODULE WINAPI
433 OnHookGetModuleHandleW_API_MS_WIN_CORE_LIBRARYLOADER_L1_2_1(LPCWSTR lpModuleName);
434 static HMODULE WINAPI
435 OnHookGetModuleHandleW_API_MS_WIN_CORE_LIBRARYLOADER_L1_2_2(LPCWSTR lpModuleName);
436 static HMODULE WINAPI
437 OnHookGetModuleHandleW_API_MS_WIN_CORE_LIBRARYLOADER_L2_1_0(LPCWSTR lpModuleName);
438 static HMODULE WINAPI OnHookGetModuleHandleExA_KERNEL32(DWORD dwFlags, LPCSTR lpModuleName,
439 HMODULE* phModule);
440 static HMODULE WINAPI OnHookGetModuleHandleExA_API_MS_WIN_CORE_LIBRARYLOADER_L1_1_0(
441 DWORD dwFlags, LPCSTR lpModuleName, HMODULE* phModule);
442 static HMODULE WINAPI OnHookGetModuleHandleExA_API_MS_WIN_CORE_LIBRARYLOADER_L1_1_1(
443 DWORD dwFlags, LPCSTR lpModuleName, HMODULE* phModule);
444 static HMODULE WINAPI OnHookGetModuleHandleExA_API_MS_WIN_CORE_LIBRARYLOADER_L1_2_0(
445 DWORD dwFlags, LPCSTR lpModuleName, HMODULE* phModule);
446 static HMODULE WINAPI OnHookGetModuleHandleExA_API_MS_WIN_CORE_LIBRARYLOADER_PRIVATE_L1_1_0(
447 DWORD dwFlags, LPCSTR lpModuleName, HMODULE* phModule);
448 static HMODULE WINAPI OnHookGetModuleHandleExA_API_MS_WIN_CORE_LIBRARYLOADER_L1_2_1(
449 DWORD dwFlags, LPCSTR lpModuleName, HMODULE* phModule);
450 static HMODULE WINAPI OnHookGetModuleHandleExA_API_MS_WIN_CORE_LIBRARYLOADER_L1_2_2(
451 DWORD dwFlags, LPCSTR lpModuleName, HMODULE* phModule);
452 static HMODULE WINAPI OnHookGetModuleHandleExA_API_MS_WIN_CORE_LIBRARYLOADER_L2_1_0(
453 DWORD dwFlags, LPCSTR lpModuleName, HMODULE* phModule);
454 static HMODULE WINAPI OnHookGetModuleHandleExW_KERNEL32(DWORD dwFlags, LPCWSTR lpModuleName,
455 HMODULE* phModule);
456 static HMODULE WINAPI OnHookGetModuleHandleExW_API_MS_WIN_CORE_LIBRARYLOADER_L1_1_0(
457 DWORD dwFlags, LPCWSTR lpModuleName, HMODULE* phModule);
458 static HMODULE WINAPI OnHookGetModuleHandleExW_API_MS_WIN_CORE_LIBRARYLOADER_L1_1_1(
459 DWORD dwFlags, LPCWSTR lpModuleName, HMODULE* phModule);
460 static HMODULE WINAPI OnHookGetModuleHandleExW_API_MS_WIN_CORE_LIBRARYLOADER_L1_2_0(
461 DWORD dwFlags, LPCWSTR lpModuleName, HMODULE* phModule);
462 static HMODULE WINAPI OnHookGetModuleHandleExW_API_MS_WIN_CORE_LIBRARYLOADER_PRIVATE_L1_1_0(
463 DWORD dwFlags, LPCWSTR lpModuleName, HMODULE* phModule);
464 static HMODULE WINAPI OnHookGetModuleHandleExW_API_MS_WIN_CORE_LIBRARYLOADER_L1_2_1(
465 DWORD dwFlags, LPCWSTR lpModuleName, HMODULE* phModule);
466 static HMODULE WINAPI OnHookGetModuleHandleExW_API_MS_WIN_CORE_LIBRARYLOADER_L1_2_2(
467 DWORD dwFlags, LPCWSTR lpModuleName, HMODULE* phModule);
468 static HMODULE WINAPI OnHookGetModuleHandleExW_API_MS_WIN_CORE_LIBRARYLOADER_L2_1_0(
469 DWORD dwFlags, LPCWSTR lpModuleName, HMODULE* phModule);
470 static HANDLE WINAPI OnHookCreateThread_KERNEL32(LPSECURITY_ATTRIBUTES lpThreadAttributes,
471 UINT_PTR dwStackSize,
472 LPTHREAD_START_ROUTINE lpStartAddress,
473 LPVOID lpParameter, DWORD dwCreationFlags,
474 LPDWORD lpThreadId);
475 static HANDLE WINAPI OnHookCreateThread_API_MS_WIN_CORE_PROCESSTHREADS_L1_1_1(
476 LPSECURITY_ATTRIBUTES lpThreadAttributes, UINT_PTR dwStackSize,
477 LPTHREAD_START_ROUTINE lpStartAddress, LPVOID lpParameter, DWORD dwCreationFlags,
478 LPDWORD lpThreadId);
479 static HANDLE WINAPI OnHookCreateThread_API_MS_WIN_CORE_PROCESSTHREADS_L1_1_2(
480 LPSECURITY_ATTRIBUTES lpThreadAttributes, UINT_PTR dwStackSize,
481 LPTHREAD_START_ROUTINE lpStartAddress, LPVOID lpParameter, DWORD dwCreationFlags,
482 LPDWORD lpThreadId);
483
484 static HMODULE WINAPI OnHookLoadLibraryA(XTPSkinFrameworkLegacyApiFunctionIndex nFunctionIndex,
485 LPCSTR pszModuleName);
486 static HMODULE WINAPI OnHookLoadLibraryW(XTPSkinFrameworkLegacyApiFunctionIndex nFunctionIndex,
487 PCWSTR pszModuleName);
488 static HMODULE WINAPI OnHookLoadLibraryExA(XTPSkinFrameworkLegacyApiFunctionIndex nFunctionIndex,
489 LPCSTR pszModuleName, HANDLE hFile, DWORD dwFlags);
490 static HMODULE WINAPI OnHookLoadLibraryExW(XTPSkinFrameworkLegacyApiFunctionIndex nFunctionIndex,
491 PCWSTR pszModuleName, HANDLE hFile, DWORD dwFlags);
492 static FARPROC WINAPI OnHookGetProcAddress(
493 XTPSkinFrameworkLegacyApiFunctionIndex nFunctionIndex, HMODULE hmod, PCSTR pszProcName);
494 static BOOL WINAPI OnHookFreeLibrary(XTPSkinFrameworkLegacyApiFunctionIndex nFunctionIndex,
495 HMODULE hmod);
496 static BOOL WINAPI OnHookFreeLibraryAndExitThread(
497 XTPSkinFrameworkLegacyApiFunctionIndex nFunctionIndex, HMODULE hmod, DWORD dwExitCode);
498 static HMODULE WINAPI OnHookGetModuleHandleA(
499 XTPSkinFrameworkLegacyApiFunctionIndex nFunctionIndex, LPCSTR lpModuleName);
500 static HMODULE WINAPI OnHookGetModuleHandleW(
501 XTPSkinFrameworkLegacyApiFunctionIndex nFunctionIndex, LPCWSTR lpModuleName);
502 static HMODULE WINAPI
503 OnHookGetModuleHandleExA(XTPSkinFrameworkLegacyApiFunctionIndex nFunctionIndex,
504 DWORD dwFlags, LPCSTR lpModuleName, HMODULE* phModule);
505 static HMODULE WINAPI
506 OnHookGetModuleHandleExW(XTPSkinFrameworkLegacyApiFunctionIndex nFunctionIndex,
507 DWORD dwFlags, LPCWSTR lpModuleName, HMODULE* phModule);
508 static HANDLE STDAPICALLTYPE
509 OnHookCreateThread(XTPSkinFrameworkLegacyApiFunctionIndex nFunctionIndex,
510 LPSECURITY_ATTRIBUTES lpThreadAttributes, UINT_PTR dwStackSize,
511 LPTHREAD_START_ROUTINE lpStartAddress, LPVOID lpParameter,
512 DWORD dwCreationFlags, LPDWORD lpThreadId);
513
514 static ATOM WINAPI OnHookRegisterClassA(const WNDCLASSA* lpWndClass);
515 static ATOM WINAPI OnHookRegisterClassW(const WNDCLASSW* lpWndClass);
516 static int WINAPI OnHookSetScrollInfo(HWND hwnd, int fnBar, LPCSCROLLINFO lpsi, BOOL fRedraw);
517 static int WINAPI OnHookSetScrollPos(HWND hwnd, int nBar, int nPos, BOOL redraw);
518 static BOOL WINAPI OnHookAdjustWindowRectEx(LPRECT lpRect, DWORD dwStyle, BOOL bMenu,
519 DWORD dwExStyle);
520 static BOOL WINAPI OnHookAdjustWindowRect(LPRECT lpRect, DWORD dwStyle, BOOL bMenu);
521 static int WINAPI OnHookGetSystemMetrics(int nIndex);
522 static BOOL WINAPI OnHookEnableScrollBar(HWND hWnd, UINT wSBflags, UINT wArrows);
523 static BOOL WINAPI OnHookGetScrollInfo(HWND hwnd, int nBar, LPSCROLLINFO lpsi);
524 static DWORD WINAPI OnHookGetSysColor(int nIndex);
525 static BOOL WINAPI OnHookDeleteObject(HGDIOBJ hObject);
526 static BOOL WINAPI OnHookDrawEdge(HDC hdc, LPRECT qrc, UINT edge, UINT grfFlags);
527 static BOOL WINAPI OnHookDrawFrameControl(HDC hDC, LPRECT rect, UINT, UINT);
528 static HBRUSH WINAPI OnHookGetSysColorBrush(int nIndex);
529 static BOOL WINAPI OnHookSystemParametersInfoA(UINT uiAction, UINT uiParam, PVOID pvParam,
530 UINT fWinIni);
531 static BOOL WINAPI OnHookSystemParametersInfoW(UINT uiAction, UINT uiParam, PVOID pvParam,
532 UINT fWinIni);
533 static LRESULT WINAPI OnHookDefWindowProcA(HWND hWnd, UINT Msg, WPARAM wParam, LPARAM lParam);
534 static LRESULT WINAPI OnHookDefWindowProcW(HWND hWnd, UINT Msg, WPARAM wParam, LPARAM lParam);
535 static LRESULT WINAPI OnHookDefFrameProcA(HWND hWnd, HWND hWndMDIClient, UINT Msg,
536 WPARAM wParam, LPARAM lParam);
537 static LRESULT WINAPI OnHookDefFrameProcW(HWND hWnd, HWND hWndMDIClient, UINT Msg,
538 WPARAM wParam, LPARAM lParam);
539 static LRESULT WINAPI OnHookDefDlgProcA(HWND hWnd, UINT Msg, WPARAM wParam, LPARAM lParam);
540 static LRESULT WINAPI OnHookDefDlgProcW(HWND hWnd, UINT Msg, WPARAM wParam, LPARAM lParam);
541 static LRESULT WINAPI OnHookDefMDIChildProcA(HWND hWnd, UINT Msg, WPARAM wParam, LPARAM lParam);
542 static LRESULT WINAPI OnHookDefMDIChildProcW(HWND hWnd, UINT Msg, WPARAM wParam, LPARAM lParam);
543 static LRESULT WINAPI OnHookCallWindowProcA(WNDPROC lpPrevWndFunc, HWND hWnd, UINT Msg,
544 WPARAM wParam, LPARAM lParam);
545 static LRESULT WINAPI OnHookCallWindowProcW(WNDPROC lpPrevWndFunc, HWND hWnd, UINT Msg,
546 WPARAM wParam, LPARAM lParam);
547 static int WINAPI OnHookFillRect(HDC hDC, CONST RECT* lprc, HBRUSH hbr);
548 static BOOL WINAPI OnHookTrackPopupMenu(HMENU hMenu, UINT uFlags, int x, int y, int nReserved,
549 HWND hWnd, CONST RECT* prcRect);
550 static BOOL WINAPI OnHookTrackPopupMenuEx(XTPSkinFrameworkLegacyApiFunctionIndex nFunctionIndex,
551 HMENU hMenu, UINT uFlags, int x, int y, HWND hWnd,
552 LPTPMPARAMS lptpParams);
553 static BOOL WINAPI OnHookTrackPopupMenuEx_USER32(HMENU hMenu, UINT uFlags, int x, int y,
554 HWND hWnd, LPTPMPARAMS lptpParams);
555 static BOOL WINAPI OnHookNtUserTrackPopupMenuEx_WIN32U(HMENU hMenu, UINT uFlags, int x, int y,
556 HWND hWnd, LPTPMPARAMS lptpParams);
557 static BOOL WINAPI OnHookDrawMenuBar(HWND hWnd);
558 static BOOL WINAPI OnHookGetMenuItemRect(HWND hWnd, HMENU hMenu, UINT uItem, LPRECT lprcItem);
559 static HRESULT STDAPICALLTYPE OnHookGetCurrentThemeName(LPWSTR pszThemeFileName,
560 int dwMaxNameChars, LPWSTR pszColorBuff,
561 int cchMaxColorChars,
562 LPWSTR /*pszSizeBuff*/,
563 int /*cchMaxSizeChars*/);
564 static BOOL STDAPICALLTYPE OnHookGetThemeSysBool(HTHEME /*hTheme*/, int iBoolId);
565 static COLORREF STDAPICALLTYPE OnHookGetThemeSysColor(HTHEME /*hTheme*/, int iColorId);
566 static HRESULT STDAPICALLTYPE OnHookGetThemePartSize(HTHEME hTheme, HDC, int iPartId,
567 int iStateId, RECT* pRect, THEMESIZE eSize,
568 SIZE* pSize);
569 static BOOL STDAPICALLTYPE OnHookIsAppThemed();
570 static BOOL STDAPICALLTYPE OnHookIsThemeActive();
571 static HRESULT STDAPICALLTYPE OnHookGetThemeColor(HTHEME hTheme, int iPartId, int iStateId,
572 int iPropID, COLORREF* pColor);
573 static HRESULT STDAPICALLTYPE OnHookGetThemeInt(HTHEME hTheme, int iPartId, int iStateId,
574 int iPropID, int* piVal);
575 static HRESULT STDAPICALLTYPE OnHookCloseThemeData(HTHEME);
576 static HRESULT STDAPICALLTYPE OnHookDrawThemeBackground(HTHEME hTheme, HDC hDC, int iPartId,
577 int iStateId, const RECT* pRect,
578 const RECT*);
579 static HTHEME STDAPICALLTYPE OnHookOpenThemeData(HWND /*hWnd*/, LPCWSTR pszClassList);
580 static HTHEME STDAPICALLTYPE OnHookOpenThemeDataForDpi(HWND hwnd, LPCWSTR pszClassList,
581 UINT dpi);
582 static HTHEME STDAPICALLTYPE OnHookOpenThemeDataEx(HWND hwnd, LPCWSTR pszClassList,
583 DWORD dwFlags);
584 static DWORD WINAPI ThreadProcHook(LPVOID lpParameter);
585 static HRESULT WINAPI OnHookDwmExtendFrameIntoClientArea(HWND hWnd, LPCVOID pMarInset);
586
587 LONG IncrementModuleReferenceCounter(HMODULE hModule);
588 LONG DecrementModuleReferenceCounter(HMODULE hModule);
589
590protected:
591 CXTPSkinManagerLegacyApiFunction* m_arrFunctions[XTP_SKIN_LEGACY_API_HOOK_COUNT];
592 static BOOL m_bInitialized;
593 static BOOL m_bInitializationInProgress;
594 CArray<EXCLUDEDMODULE, EXCLUDEDMODULE&> m_arrExcludedModules;
595 BOOL m_bInAppCompatMode;
596 long m_nLockCondition;
597 CMap<HMODULE, HMODULE, LONG, LONG> m_mapModuleRefCount;
598 CXTPThreadLocal<int> m_HackModuleOnLoadCounter;
599 static const APIHOOKINFO m_apiHookInfos[];
600
601 friend class CXTPSkinManagerLegacyApiFunction;
602 friend class CXTPSkinManager;
603};
604
607# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
609#endif // !defined(__XTPSKINMANAGERLEGACYAPIHOOK_H__) &&
610 // defined(XTP_SKINFRAMEWORK_USE_LEGACY_API_HOOK)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPSkinManager
CXTPSkinManager is a standalone class that represents a global object that manages skins.
Definition XTPSkinManager.h:541
CXTPSkinObject
CXTPSkinObject is a CWnd derived class.
Definition XTPSkinObject.h:80
CXTPSynchronized
A base class for a synchronized object.
Definition XTPSynchro.h:602
CXTPSystemVersion
CXTPSystemVersion is used to get the current Windows OS version.
Definition XTPSystemHelpers.h:279
CXTPThreadLocal
Implements thread local variable adapter.
Definition XTPSystemHelpers.h:1676
CXTPWinThemeWrapper
The CXTPWinThemeWrapper class wraps the UxTheme.dll visual theme API.
Definition XTPWinThemeWrapper.h:188


Toolkit Pro: XTPRibbonMarkupFrameTheme.h Source File

  • Source
  • Ribbon
XTPRibbonMarkupFrameTheme.h
Go to the documentation of this file.
1
23#if !defined(__XTPRIBBONMARKUPFRAMETHEME_H__)
24# define __XTPRIBBONMARKUPFRAMETHEME_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPMarkupThemePart;
34
42class _XTP_EXT_CLASS CXTPRibbonMarkupFrameTheme : public CXTPFramePaintManager
43{
44 DECLARE_DYNAMIC(CXTPRibbonMarkupFrameTheme);
45
46protected:
51 enum XTPBorderPart
52 {
53 xtpBorderPartTop,
54 xtpBorderPartLeft,
55 xtpBorderPartLeftCaption,
56 xtpBorderPartRight,
57 xtpBorderPartRightCaption,
58 xtpBorderPartBottom,
59 xtpBorderPartCount
60 };
61
62public:
68 CXTPRibbonMarkupFrameTheme(CXTPPaintManager* pPaintManager);
69
75 virtual ~CXTPRibbonMarkupFrameTheme();
76
77public:
84 virtual void DrawFrame(CDC* pDC, CXTPCommandBarsFrameHook* pFrameHook);
85
92 virtual void DrawFrameBorder(CDC* pDC, CXTPCommandBarsFrameHook* pFrameHook);
93
100 void ReloadMarkupParts(HZIP hZip, CXTPMarkupContext* pMarkupContext);
101
102protected:
111 virtual CXTPMarkupThemePart* GetFrameBorder(int nId, BOOL bActive) = 0;
112
119 virtual void LoadParts(HZIP hZip, CXTPMarkupContext* pMarkupContext) = 0;
120
126 virtual void LoadParts(BOOL bReload = FALSE) = 0;
127
128protected:
129 BOOL m_bMarkupPartsLoaded;
130};
131
132# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
134#endif // !defined(__XTPRIBBONMARKUPFRAMETHEME_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCommandBarsFrameHook
CXTPCommandBarsFrameHook is a CXTPHookManagerHookAble derived class.
Definition XTPFrameHook.h:56
CXTPFramePaintManager
Paint manager for the Office 2007 style window frame.
Definition XTPFramePaintManager.h:41
CXTPMarkupContext
CXTPMarkupContext is a standalone class used to provide common settings for Markup objects.
Definition XTPMarkupContext.h:128
CXTPMarkupThemePart
The CXTPMarkupThemePart class is used to create a theme part object used for rendering.
Definition XTPMarkupTheme.h:42
CXTPPaintManager
Paint manager of the command bars.
Definition XTPPaintManager.h:199
CXTPRibbonMarkupFrameTheme
The CXTPRibbonMarkupFrameTheme class is used to enable a system style theme for Command Bars.
Definition XTPRibbonMarkupFrameTheme.h:43
CXTPRibbonMarkupFrameTheme::XTPBorderPart
XTPBorderPart
Defines border parts.
Definition XTPRibbonMarkupFrameTheme.h:52
CXTPRibbonMarkupFrameTheme::xtpBorderPartLeftCaption
@ xtpBorderPartLeftCaption
Specifies a left caption border part.
Definition XTPRibbonMarkupFrameTheme.h:55
CXTPRibbonMarkupFrameTheme::xtpBorderPartTop
@ xtpBorderPartTop
Specifies a top border part.
Definition XTPRibbonMarkupFrameTheme.h:53
CXTPRibbonMarkupFrameTheme::xtpBorderPartRight
@ xtpBorderPartRight
Specifies a right border part.
Definition XTPRibbonMarkupFrameTheme.h:56
CXTPRibbonMarkupFrameTheme::xtpBorderPartRightCaption
@ xtpBorderPartRightCaption
Specifies a right caption border part.
Definition XTPRibbonMarkupFrameTheme.h:57
CXTPRibbonMarkupFrameTheme::xtpBorderPartBottom
@ xtpBorderPartBottom
Specifies a bottom border part.
Definition XTPRibbonMarkupFrameTheme.h:58
CXTPRibbonMarkupFrameTheme::xtpBorderPartLeft
@ xtpBorderPartLeft
Specifies a left border part.
Definition XTPRibbonMarkupFrameTheme.h:54
CXTPRibbonMarkupFrameTheme::ReloadMarkupParts
void ReloadMarkupParts(HZIP hZip, CXTPMarkupContext *pMarkupContext)
Re-loads markup parts from the specified ZIP source.
CXTPRibbonMarkupFrameTheme::DrawFrame
virtual void DrawFrame(CDC *pDC, CXTPCommandBarsFrameHook *pFrameHook)
This method is called to draw the frame if the Ribbon was found.
CXTPRibbonMarkupFrameTheme::GetFrameBorder
virtual CXTPMarkupThemePart * GetFrameBorder(int nId, BOOL bActive)=0
This method is called to get the frame border part.
CXTPRibbonMarkupFrameTheme::LoadParts
virtual void LoadParts(BOOL bReload=FALSE)=0
Loads markup parts.
CXTPRibbonMarkupFrameTheme::LoadParts
virtual void LoadParts(HZIP hZip, CXTPMarkupContext *pMarkupContext)=0
Loads markup parts from the specified ZIP source.
CXTPRibbonMarkupFrameTheme::~CXTPRibbonMarkupFrameTheme
virtual ~CXTPRibbonMarkupFrameTheme()
Destroys a CXTPRibbonMarkupFrameTheme object, handles cleanup and deallocation.
CXTPRibbonMarkupFrameTheme::CXTPRibbonMarkupFrameTheme
CXTPRibbonMarkupFrameTheme(CXTPPaintManager *pPaintManager)
Constructs a CXTPRibbonMarkupFrameTheme object.
CXTPRibbonMarkupFrameTheme::m_bMarkupPartsLoaded
BOOL m_bMarkupPartsLoaded
TRUE if markup parts have been loaded.
Definition XTPRibbonMarkupFrameTheme.h:129
CXTPRibbonMarkupFrameTheme::DrawFrameBorder
virtual void DrawFrameBorder(CDC *pDC, CXTPCommandBarsFrameHook *pFrameHook)
This method is called to draw the frame border.


Toolkit Pro: XTPDatePickerPaintManager.h Source File

  • Source
  • Calendar
  • DatePicker
XTPDatePickerPaintManager.h
Go to the documentation of this file.
1
22#if !defined(_XTPDATEPICKERPAINTMANAGER_H__)
23# define _XTPDATEPICKERPAINTMANAGER_H__
24
25# if _MSC_VER > 1000
26# pragma once
27# endif // _MSC_VER > 1000
28
29# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
30
31class CXTPDatePickerControl;
32class CXTPDatePickerItemMonth;
33class CXTPDatePickerItemDay;
34class CXTPWinThemeWrapper;
35
54class _XTP_EXT_CLASS CXTPDatePickerPaintManager : public CXTPCmdTarget
55{
56 friend class CXTPDatePickerControl;
57
58public:
67 CXTPDatePickerPaintManager();
68
75 virtual ~CXTPDatePickerPaintManager();
76
85 virtual void RefreshMetrics();
86
95 virtual void DrawBackground(CDC* pDC, CRect rcClient);
96
107 virtual void DrawBorder(CDC* pDC, const CXTPDatePickerControl* pControl, CRect& rcClient,
108 BOOL bDraw);
109
123 virtual void DrawScrollTriangle(CDC* pDC, CRect rcSpot, BOOL bLeftDirection,
124 COLORREF clrColor = 0, BOOL bYears = FALSE);
125
132 virtual COLORREF GetControlBackColor();
133
142 virtual COLORREF GetDayBackColor();
143
152 virtual COLORREF GetDayTextColor();
153
173 virtual CFont* GetDayTextFont();
174
182 virtual CFont* GetDayTextFontBold();
183
192 virtual COLORREF GetNonMonthDayBackColor();
193
202 virtual COLORREF GetNonMonthDayTextColor();
203
223 CFont* GetNonMonthDayTextFont();
224
233 virtual COLORREF GetSelectedDayBackColor();
234
242 virtual COLORREF GetSelectedDayTextColor();
243
252 virtual COLORREF GetMonthHeaderBackColor();
253
262 virtual COLORREF GetMonthHeaderTextColor();
263
272 CFont* GetHeaderTextFont();
273
282 virtual COLORREF GetDaysOfWeekBackColor();
283
291 virtual COLORREF GetDaysOfWeekTextColor();
292
301 CFont* GetDaysOfWeekTextFont();
302
311 virtual COLORREF GetWeekNumbersBackColor();
312
321 virtual COLORREF GetWeekNumbersTextColor();
322
330 CFont* GetWeekNumbersTextFont();
331
340 virtual COLORREF GetListControlBackColor();
341
350 virtual COLORREF GetListControlTextColor();
351
360 CFont* GetListControlTextFont();
361
370 virtual COLORREF GetHighlightTodayColor();
371
384 void SetButtonFont(CFont* fontButton);
385
399 void SetButtonFontIndirect(LOGFONT* lFont);
400
410 CFont* GetButtonFont();
411
422 void SetFontIndirect(LOGFONT* lFont);
423
452 virtual void DrawButton(CDC* pDC, const CRect& rcButton, const CString& strButton, BOOL bIsDown,
453 BOOL bIsHighLight);
454
468 virtual BOOL DrawDay(CDC* pDC, CXTPDatePickerItemDay* pDay);
469
481 virtual void DrawMonthHeader(CDC* pDC, CXTPDatePickerItemMonth* pMonth);
482
494 virtual void DrawWeekNumbers(CDC* pDC, CXTPDatePickerItemMonth* pMonth);
495
507 virtual void DrawDaysOfWeek(CDC* pDC, CXTPDatePickerItemMonth* pMonth);
508
522 virtual CSize CalcDayRect(CDC* pDC);
523
538 virtual CSize CalcMonthHeaderRect(CDC* pDC);
539
553 virtual CSize CalcDayOfWeekRect(CDC* pDC);
554
568 virtual CSize CalcWeekNumbersRect(CDC* pDC);
569
583 virtual CSize CalcMonthRect(CDC* pDC);
584
592 virtual void EnableTheme(BOOL bEnableTheme);
593
601 virtual HCURSOR GetCursorBack();
602
603protected:
614 virtual void Triangle(CDC* pDC, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clrColor = 0);
615
622 XTPCalendarTheme GetPaintTheme() const;
623
624protected:
631 // void SetPaintTheme(XTPCalendarTheme ePaintTheme);
632
633public:
634 CSize m_szDayMargin;
635 CSize m_szHdrMargin;
636 CSize m_szDoWMargin;
637
638 CXTPPaintManagerColor m_clrControlBack;
643 CXTPPaintManagerColor m_clrHighlightToday;
649 CXTPPaintManagerColor m_clrSelectedDayBack;
655 CXTPPaintManagerColor m_clrMonthHeaderBack;
661 CXTPPaintManagerColor m_clrMonthHeaderText;
667 CXTPPaintManagerColor m_clrSelectedDayText;
672 CXTPPaintManagerColor m_clrMonthBorder;
678 CXTPPaintManagerColor m_clrMonthHeaderButton;
684 CXTPPaintManagerColor m_clrDayBack;
689 CXTPPaintManagerColor m_clrDayText;
694 CXTPPaintManagerColor m_clrNonMonthDayBack;
700 CXTPPaintManagerColor m_clrNonMonthDayText;
705 CXTPPaintManagerColor m_clrDaysOfWeekBack;
711 CXTPPaintManagerColor m_clrDaysOfWeekText;
716 CXTPPaintManagerColor m_clrWeekNumbersBack;
722 CXTPPaintManagerColor m_clrWeekNumbersText;
728 CXTPPaintManagerColor m_clrButtonText;
733 CXTPPaintManagerColor m_clrButtonFace;
738 CXTPPaintManagerColor m_clrListControlBack;
744 CXTPPaintManagerColor m_clrListControlText;
750protected:
751 COLORREF m_clrStaticBorder;
752 COLORREF m_clr3DShadow;
756 COLORREF m_clr3DLight;
760 COLORREF m_clr3DFace;
764 COLORREF m_clr3DText;
769 CXTPFont m_xtpFontDay;
773 CXTPFont m_xtpFontDayBold;
777 CXTPFont m_xtpFontNonMonthDay;
781 CXTPFont m_xtpFontHeader;
785 CXTPFont m_xtpFontDaysOfWeek;
789 CXTPFont m_xtpFontWeekNumbers;
793 CXTPFont m_xtpFontListControl;
797 CXTPFont m_xtpFontButton;
802 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CFont, m_fontDay, m_xtpFontDay, GetDayFontHandle);
803 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CFont, m_fontDayBold, m_xtpFontDayBold,
804 GetDayBoldFontHandle);
805 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CFont, m_fontNonMonthDay, m_xtpFontNonMonthDay,
806 GetNonMonthDayFontHandle);
807 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CFont, m_fontHeader, m_xtpFontHeader,
808 GetHeaderFontHandle);
809 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CFont, m_fontDaysOfWeek, m_xtpFontDaysOfWeek,
810 GetDaysOfWeekFontHandle);
811 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CFont, m_fontWeekNumbers, m_xtpFontWeekNumbers,
812 GetWeekNumbersFontHandle);
813 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CFont, m_fontListControl, m_xtpFontListControl,
814 GetListControlFontHandle);
815 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CFont, m_fontButton, m_xtpFontButton,
816 GetButtonFontHandle);
817
818 BOOL m_bEnableTheme;
824 CXTPWinThemeWrapper* m_themeButton;
829 HCURSOR m_hCursorBack;
831 XTPCalendarTheme m_nPaintTheme;
833protected:
834 friend class CXTPDatePickerControl;
835# ifdef _XTP_ACTIVEX
836
837 DECLARE_DISPATCH_MAP()
838 DECLARE_INTERFACE_MAP()
839
840 DECLARE_OLETYPELIB_EX(CXTPDatePickerPaintManager)
841
842# define DECLARE_PROPERTY_UN(theProperty, theType) \
843 afx_msg theType OleGet##theProperty(); \
844 afx_msg void OleSet##theProperty(theType);
845
846 DECLARE_PROPERTY_UN(ControlBackColor, COLORREF);
847
848 DECLARE_PROPERTY_UN(HighlightTodayColor, COLORREF);
849 DECLARE_PROPERTY_UN(SelectedDayBackColor, COLORREF);
850 DECLARE_PROPERTY_UN(MonthHeaderBackColor, COLORREF);
851 DECLARE_PROPERTY_UN(MonthHeaderTextColor, COLORREF);
852 DECLARE_PROPERTY_UN(SelectedDayTextColor, COLORREF);
853 DECLARE_PROPERTY_UN(MonthBorderColor, COLORREF);
854 DECLARE_PROPERTY_UN(MonthHeaderButtonColor, COLORREF);
855 DECLARE_PROPERTY_UN(DayBackColor, COLORREF);
856 DECLARE_PROPERTY_UN(DayTextColor, COLORREF);
857
858 DECLARE_PROPERTY_UN(NonMonthDayBackColor, COLORREF);
859 DECLARE_PROPERTY_UN(NonMonthDayTextColor, COLORREF);
860 DECLARE_PROPERTY_UN(DaysOfWeekBackColor, COLORREF);
861 DECLARE_PROPERTY_UN(DaysOfWeekTextColor, COLORREF);
862 DECLARE_PROPERTY_UN(WeekNumbersBackColor, COLORREF);
863 DECLARE_PROPERTY_UN(WeekNumbersTextColor, COLORREF);
864
865 DECLARE_PROPERTY_UN(ButtonTextColor, COLORREF);
866 DECLARE_PROPERTY_UN(ButtonFaceColor, COLORREF);
867
868 DECLARE_PROPERTY_UN(ListControlBackColor, COLORREF);
869 DECLARE_PROPERTY_UN(ListControlTextColor, COLORREF);
870
871# endif
872};
873
874AFX_INLINE COLORREF CXTPDatePickerPaintManager::GetControlBackColor()
875{
876 return m_clrControlBack;
877}
878
879AFX_INLINE COLORREF CXTPDatePickerPaintManager::GetDayBackColor()
880{
881 return m_clrDayBack;
882}
883
884AFX_INLINE COLORREF CXTPDatePickerPaintManager::GetDayTextColor()
885{
886 return m_clrDayText;
887}
888
889AFX_INLINE CFont* CXTPDatePickerPaintManager::GetDayTextFont()
890{
891 return &m_xtpFontDay;
892}
893
894AFX_INLINE CFont* CXTPDatePickerPaintManager::GetDayTextFontBold()
895{
896 return &m_xtpFontDayBold;
897}
898
899AFX_INLINE COLORREF CXTPDatePickerPaintManager::GetNonMonthDayBackColor()
900{
901 return m_clrNonMonthDayBack;
902}
903
904AFX_INLINE COLORREF CXTPDatePickerPaintManager::GetNonMonthDayTextColor()
905{
906 return m_clrNonMonthDayText;
907}
908
909AFX_INLINE CFont* CXTPDatePickerPaintManager::GetNonMonthDayTextFont()
910{
911 return &m_xtpFontNonMonthDay;
912}
913
914AFX_INLINE COLORREF CXTPDatePickerPaintManager::GetSelectedDayBackColor()
915{
916 return m_clrSelectedDayBack;
917}
918
919AFX_INLINE COLORREF CXTPDatePickerPaintManager::GetSelectedDayTextColor()
920{
921 return m_clrSelectedDayText;
922}
923
924AFX_INLINE COLORREF CXTPDatePickerPaintManager::GetMonthHeaderBackColor()
925{
926 return m_clrMonthHeaderBack;
927}
928
929AFX_INLINE COLORREF CXTPDatePickerPaintManager::GetMonthHeaderTextColor()
930{
931 return m_clrMonthHeaderText;
932}
933
934AFX_INLINE CFont* CXTPDatePickerPaintManager::GetHeaderTextFont()
935{
936 return &m_xtpFontHeader;
937}
938
939AFX_INLINE COLORREF CXTPDatePickerPaintManager::GetDaysOfWeekBackColor()
940{
941 return m_clrDaysOfWeekBack;
942}
943
944AFX_INLINE COLORREF CXTPDatePickerPaintManager::GetDaysOfWeekTextColor()
945{
946 return m_clrDaysOfWeekText;
947}
948
949AFX_INLINE CFont* CXTPDatePickerPaintManager::GetDaysOfWeekTextFont()
950{
951 return &m_xtpFontDaysOfWeek;
952}
953
954AFX_INLINE COLORREF CXTPDatePickerPaintManager::GetWeekNumbersBackColor()
955{
956 return m_clrWeekNumbersBack;
957}
958
959AFX_INLINE COLORREF CXTPDatePickerPaintManager::GetWeekNumbersTextColor()
960{
961 return m_clrWeekNumbersText;
962}
963
964AFX_INLINE CFont* CXTPDatePickerPaintManager::GetWeekNumbersTextFont()
965{
966 return &m_xtpFontWeekNumbers;
967}
968
969AFX_INLINE COLORREF CXTPDatePickerPaintManager::GetListControlBackColor()
970{
971 return m_clrListControlBack;
972}
973
974AFX_INLINE COLORREF CXTPDatePickerPaintManager::GetListControlTextColor()
975{
976 return m_clrListControlText;
977}
978
979AFX_INLINE CFont* CXTPDatePickerPaintManager::GetListControlTextFont()
980{
981 return &m_xtpFontListControl;
982}
983
984AFX_INLINE COLORREF CXTPDatePickerPaintManager::GetHighlightTodayColor()
985{
986 return m_clrHighlightToday;
987}
988
989AFX_INLINE CFont* CXTPDatePickerPaintManager::GetButtonFont()
990{
991 return &m_xtpFontButton;
992}
993
994AFX_INLINE void CXTPDatePickerPaintManager::EnableTheme(BOOL bEnableTheme)
995{
996 m_bEnableTheme = bEnableTheme;
997 RefreshMetrics();
998}
999
1000AFX_INLINE HCURSOR CXTPDatePickerPaintManager::GetCursorBack()
1001{
1002 return m_hCursorBack;
1003}
1004
1005AFX_INLINE XTPCalendarTheme CXTPDatePickerPaintManager::GetPaintTheme() const
1006{
1007 return m_nPaintTheme;
1008}
1009
1010# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
1011#endif // !defined(_XTPDATEPICKERPAINTMANAGER_H__)
XTPCalendarTheme
XTPCalendarTheme
Paint themes used by calendar.
Definition XTPCalendarDefines.h:62
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPDatePickerControl
Class CXTPDatePickerControl encapsulates the functionality of a date and time picker control.
Definition XTPDatePickerControl.h:331
CXTPDatePickerItemDay
Class CXTPDatePickerItemDay represents one displayed day item in the calendar.
Definition XTPDatePickerItemDay.h:47
CXTPDatePickerItemMonth
Class CXTPDatePickerItemMonth represents one month inside the date picker month grid.
Definition XTPDatePickerItemMonth.h:54
CXTPDatePickerPaintManager
Class CXTPDatePickerPaintManager handles most of the drawing activities for the DatePicker control.
Definition XTPDatePickerPaintManager.h:55
CXTPDatePickerPaintManager::DrawWeekNumbers
virtual void DrawWeekNumbers(CDC *pDC, CXTPDatePickerItemMonth *pMonth)
Call this member function to draw the week numbers in the month area.
CXTPDatePickerPaintManager::m_hCursorBack
HCURSOR m_hCursorBack
Back cursor for week selection.
Definition XTPDatePickerPaintManager.h:829
CXTPDatePickerPaintManager::m_xtpFontDay
CXTPFont m_xtpFontDay
This member variable is a CXTPFont object that is used for the font -of the usual day item.
Definition XTPDatePickerPaintManager.h:769
CXTPDatePickerPaintManager::GetMonthHeaderBackColor
virtual COLORREF GetMonthHeaderBackColor()
This member function obtains the background color of the month header area.
Definition XTPDatePickerPaintManager.h:924
CXTPDatePickerPaintManager::GetListControlBackColor
virtual COLORREF GetListControlBackColor()
This member function obtains the background color of the pop-up month list control.
Definition XTPDatePickerPaintManager.h:969
CXTPDatePickerPaintManager::m_clrListControlBack
CXTPPaintManagerColor m_clrListControlBack
This member variable is a COLORREF object that is used as the background color of the pop-up month li...
Definition XTPDatePickerPaintManager.h:738
CXTPDatePickerPaintManager::DrawDaysOfWeek
virtual void DrawDaysOfWeek(CDC *pDC, CXTPDatePickerItemMonth *pMonth)
Call this member function to draw the days of the week in the month header.
CXTPDatePickerPaintManager::m_szDayMargin
CSize m_szDayMargin
This member function is used to set current paint theme.
Definition XTPDatePickerPaintManager.h:634
CXTPDatePickerPaintManager::SetButtonFont
void SetButtonFont(CFont *fontButton)
This member function sets the button's font.
CXTPDatePickerPaintManager::CalcMonthRect
virtual CSize CalcMonthRect(CDC *pDC)
This member function calculates the month's bounding rectangle coordinates.
CXTPDatePickerPaintManager::m_xtpFontButton
CXTPFont m_xtpFontButton
This member variable is a CXTPFont object that is used as the font for the button text.
Definition XTPDatePickerPaintManager.h:797
CXTPDatePickerPaintManager::DrawBorder
virtual void DrawBorder(CDC *pDC, const CXTPDatePickerControl *pControl, CRect &rcClient, BOOL bDraw)
This member function draws a border around the control.
CXTPDatePickerPaintManager::m_xtpFontDaysOfWeek
CXTPFont m_xtpFontDaysOfWeek
This member variable is a CXTPFont object that is used as the font for the days of weeks text.
Definition XTPDatePickerPaintManager.h:785
CXTPDatePickerPaintManager::CXTPDatePickerPaintManager
CXTPDatePickerPaintManager()
Default paint manager constructor.
CXTPDatePickerPaintManager::CalcDayOfWeekRect
virtual CSize CalcDayOfWeekRect(CDC *pDC)
This member function calculates the "day of week names" bounding rectangle coordinates.
CXTPDatePickerPaintManager::m_xtpFontWeekNumbers
CXTPFont m_xtpFontWeekNumbers
This member variable is a CXTPFont object that is used as the font for the week number items text.
Definition XTPDatePickerPaintManager.h:789
CXTPDatePickerPaintManager::m_clrDaysOfWeekBack
CXTPPaintManagerColor m_clrDaysOfWeekBack
This member variable is a COLORREF object that is used for the background color of the days of weeks ...
Definition XTPDatePickerPaintManager.h:705
CXTPDatePickerPaintManager::Triangle
virtual void Triangle(CDC *pDC, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clrColor=0)
This member function is used to draw a black triangle.
CXTPDatePickerPaintManager::GetListControlTextColor
virtual COLORREF GetListControlTextColor()
This member function obtains the text color of the pop-up month list control.
Definition XTPDatePickerPaintManager.h:974
CXTPDatePickerPaintManager::m_clrDayText
CXTPPaintManagerColor m_clrDayText
This member variable is a COLORREF object that is used as the color of the usual day item.
Definition XTPDatePickerPaintManager.h:689
CXTPDatePickerPaintManager::m_clr3DFace
COLORREF m_clr3DFace
This member variable is a COL ORREF object that is used as the color for the button text.
Definition XTPDatePickerPaintManager.h:760
CXTPDatePickerPaintManager::GetHighlightTodayColor
virtual COLORREF GetHighlightTodayColor()
This member function obtains the highlighting color of the "Today" item.
Definition XTPDatePickerPaintManager.h:984
CXTPDatePickerPaintManager::m_clrListControlText
CXTPPaintManagerColor m_clrListControlText
This member variable is a COLORREF object that is used as the text color of the pop-up month list con...
Definition XTPDatePickerPaintManager.h:744
CXTPDatePickerPaintManager::DrawMonthHeader
virtual void DrawMonthHeader(CDC *pDC, CXTPDatePickerItemMonth *pMonth)
Call this member function to draw the month header in the month area.
CXTPDatePickerPaintManager::m_clrStaticBorder
COLORREF m_clrStaticBorder
Static border color.
Definition XTPDatePickerPaintManager.h:751
CXTPDatePickerPaintManager::GetWeekNumbersTextColor
virtual COLORREF GetWeekNumbersTextColor()
This member function obtains the text color of the week numbers items.
Definition XTPDatePickerPaintManager.h:959
CXTPDatePickerPaintManager::GetDaysOfWeekTextFont
CFont * GetDaysOfWeekTextFont()
This member function obtains the font of the days of weeks area text.
Definition XTPDatePickerPaintManager.h:949
CXTPDatePickerPaintManager::m_bEnableTheme
BOOL m_bEnableTheme
This member variable is a BOOL that is used to indicate if Luna colors are enabled.
Definition XTPDatePickerPaintManager.h:818
CXTPDatePickerPaintManager::m_clr3DText
COLORREF m_clr3DText
This member variable is a COLORREF object that is used as the basic color for buttons.
Definition XTPDatePickerPaintManager.h:764
CXTPDatePickerPaintManager::DrawBackground
virtual void DrawBackground(CDC *pDC, CRect rcClient)
This member function is called to fill the control's background.
CXTPDatePickerPaintManager::m_clr3DLight
COLORREF m_clr3DLight
This member variable is a COLORREF object that is used to specify the color for light areas.
Definition XTPDatePickerPaintManager.h:756
CXTPDatePickerPaintManager::GetHeaderTextFont
CFont * GetHeaderTextFont()
This member function obtains the font of the month header area text.
Definition XTPDatePickerPaintManager.h:934
CXTPDatePickerPaintManager::m_clrSelectedDayBack
CXTPPaintManagerColor m_clrSelectedDayBack
This member variable is a COLORREF object that is used as the background color of the selected day it...
Definition XTPDatePickerPaintManager.h:649
CXTPDatePickerPaintManager::m_nPaintTheme
XTPCalendarTheme m_nPaintTheme
Store the Paint Theme;.
Definition XTPDatePickerPaintManager.h:831
CXTPDatePickerPaintManager::m_clrSelectedDayText
CXTPPaintManagerColor m_clrSelectedDayText
This member variable is a COLORREF object that is used as the color of the selected day item.
Definition XTPDatePickerPaintManager.h:667
CXTPDatePickerPaintManager::GetButtonFont
CFont * GetButtonFont()
This member function is used to obtain the button's font object.
Definition XTPDatePickerPaintManager.h:989
CXTPDatePickerPaintManager::m_xtpFontDayBold
CXTPFont m_xtpFontDayBold
This member variable is a CXTPFont object that is used for the font -of the bold day item.
Definition XTPDatePickerPaintManager.h:773
CXTPDatePickerPaintManager::m_clrMonthHeaderButton
CXTPPaintManagerColor m_clrMonthHeaderButton
This member variable is a COLORREF object that is used as the color for the scroll's triangle button.
Definition XTPDatePickerPaintManager.h:678
CXTPDatePickerPaintManager::GetDayTextFont
virtual CFont * GetDayTextFont()
This member function is used to obtain a pointer to the font for the standard day item.
Definition XTPDatePickerPaintManager.h:889
CXTPDatePickerPaintManager::m_clrDayBack
CXTPPaintManagerColor m_clrDayBack
This member variable is a COLORREF object that is used as the background color of the normal day item...
Definition XTPDatePickerPaintManager.h:684
CXTPDatePickerPaintManager::m_clrNonMonthDayBack
CXTPPaintManagerColor m_clrNonMonthDayBack
This member variable is a COLORREF object that is used as the background color of the non-month day i...
Definition XTPDatePickerPaintManager.h:694
CXTPDatePickerPaintManager::GetSelectedDayTextColor
virtual COLORREF GetSelectedDayTextColor()
This member function obtains the color of the selected day item.
Definition XTPDatePickerPaintManager.h:919
CXTPDatePickerPaintManager::GetDaysOfWeekTextColor
virtual COLORREF GetDaysOfWeekTextColor()
This member function obtains the text color of the days of weeks area.
Definition XTPDatePickerPaintManager.h:944
CXTPDatePickerPaintManager::m_clrButtonFace
CXTPPaintManagerColor m_clrButtonFace
This member variable is a COLORREF object that is used as the basic color for buttons.
Definition XTPDatePickerPaintManager.h:733
CXTPDatePickerPaintManager::m_xtpFontListControl
CXTPFont m_xtpFontListControl
This member variable is a CXTPFont object that is used as the font for the pop-up month list control.
Definition XTPDatePickerPaintManager.h:793
CXTPDatePickerPaintManager::m_clr3DShadow
COLORREF m_clr3DShadow
This member variable is a COLORREF object that is used to specify the color for shadow areas.
Definition XTPDatePickerPaintManager.h:752
CXTPDatePickerPaintManager::GetCursorBack
virtual HCURSOR GetCursorBack()
This member function is used to obtain the back cursor used for weeks selection.
Definition XTPDatePickerPaintManager.h:1000
CXTPDatePickerPaintManager::GetMonthHeaderTextColor
virtual COLORREF GetMonthHeaderTextColor()
This member function obtains the text color of the month header area.
Definition XTPDatePickerPaintManager.h:929
CXTPDatePickerPaintManager::m_clrDaysOfWeekText
CXTPPaintManagerColor m_clrDaysOfWeekText
This member variable is a COLORFEF object that is used as the text color of the days of weeks area.
Definition XTPDatePickerPaintManager.h:711
CXTPDatePickerPaintManager::SetFontIndirect
void SetFontIndirect(LOGFONT *lFont)
This member function is used to set the control's default font using a LOGFONT structure.
CXTPDatePickerPaintManager::GetNonMonthDayBackColor
virtual COLORREF GetNonMonthDayBackColor()
This member function is used to obtain the background color of the non-month day item.
Definition XTPDatePickerPaintManager.h:899
CXTPDatePickerPaintManager::GetListControlTextFont
CFont * GetListControlTextFont()
This member function obtains the font of the pop-up month list control.
Definition XTPDatePickerPaintManager.h:979
CXTPDatePickerPaintManager::GetPaintTheme
XTPCalendarTheme GetPaintTheme() const
This member function is used to obtain current paint theme.
Definition XTPDatePickerPaintManager.h:1005
CXTPDatePickerPaintManager::CalcWeekNumbersRect
virtual CSize CalcWeekNumbersRect(CDC *pDC)
This member function calculates the "week numbers" bounding rectangle coordinates.
CXTPDatePickerPaintManager::GetDayTextFontBold
virtual CFont * GetDayTextFontBold()
This member function is used to obtain a pointer to the font for the bolded day item.
Definition XTPDatePickerPaintManager.h:894
CXTPDatePickerPaintManager::SetButtonFontIndirect
void SetButtonFontIndirect(LOGFONT *lFont)
This member function sets the button's font using a LOGFONT structure.
CXTPDatePickerPaintManager::DrawDay
virtual BOOL DrawDay(CDC *pDC, CXTPDatePickerItemDay *pDay)
Call this member function to draw a single month day in the month area.
CXTPDatePickerPaintManager::m_xtpFontNonMonthDay
CXTPFont m_xtpFontNonMonthDay
This member variable is a CXTPFont object that is used as the font for the non-month day item.
Definition XTPDatePickerPaintManager.h:777
CXTPDatePickerPaintManager::m_themeButton
CXTPWinThemeWrapper * m_themeButton
This member variable is a CXTPWinThemeWrapper object that is used as the theme wrapper for the Paint ...
Definition XTPDatePickerPaintManager.h:824
CXTPDatePickerPaintManager::GetDaysOfWeekBackColor
virtual COLORREF GetDaysOfWeekBackColor()
This member function returns the background color of the days of weeks area.
Definition XTPDatePickerPaintManager.h:939
CXTPDatePickerPaintManager::m_clrHighlightToday
CXTPPaintManagerColor m_clrHighlightToday
This member variable is a COLORREF object that is used as the color for highlighting the "Today" item...
Definition XTPDatePickerPaintManager.h:643
CXTPDatePickerPaintManager::~CXTPDatePickerPaintManager
virtual ~CXTPDatePickerPaintManager()
Default paint manager destructor.
CXTPDatePickerPaintManager::m_clrMonthHeaderText
CXTPPaintManagerColor m_clrMonthHeaderText
This member variable is a COLORREF object that is used as the text color of the month header area.
Definition XTPDatePickerPaintManager.h:661
CXTPDatePickerPaintManager::DrawScrollTriangle
virtual void DrawScrollTriangle(CDC *pDC, CRect rcSpot, BOOL bLeftDirection, COLORREF clrColor=0, BOOL bYears=FALSE)
This member function draws scrolling triangles on the highest bounded month headers.
CXTPDatePickerPaintManager::EnableTheme
virtual void EnableTheme(BOOL bEnableTheme)
This member function is used to switch "Themes".
Definition XTPDatePickerPaintManager.h:994
CXTPDatePickerPaintManager::CalcDayRect
virtual CSize CalcDayRect(CDC *pDC)
This member function is used to calculate the day's bounding rectangle coordinates.
CXTPDatePickerPaintManager::GetSelectedDayBackColor
virtual COLORREF GetSelectedDayBackColor()
This member function is used to obtain the background color of the selected day item.
Definition XTPDatePickerPaintManager.h:914
CXTPDatePickerPaintManager::CalcMonthHeaderRect
virtual CSize CalcMonthHeaderRect(CDC *pDC)
This member function calculates the month's header bounding rectangle coordinates.
CXTPDatePickerPaintManager::m_clrWeekNumbersText
CXTPPaintManagerColor m_clrWeekNumbersText
This member variable is a COLORREF object that is used as the text color of the week numbers items.
Definition XTPDatePickerPaintManager.h:722
CXTPDatePickerPaintManager::m_xtpFontHeader
CXTPFont m_xtpFontHeader
This member variable is a CXTPFont object that is used as the font for the header text.
Definition XTPDatePickerPaintManager.h:781
CXTPDatePickerPaintManager::GetDayBackColor
virtual COLORREF GetDayBackColor()
This member function is used to obtain the background color of the standard day item.
Definition XTPDatePickerPaintManager.h:879
CXTPDatePickerPaintManager::m_clrMonthHeaderBack
CXTPPaintManagerColor m_clrMonthHeaderBack
This member variable is a COLORREF object that is used as the background color of the month header ar...
Definition XTPDatePickerPaintManager.h:655
CXTPDatePickerPaintManager::GetControlBackColor
virtual COLORREF GetControlBackColor()
This member function is used to obtain the control's background color.
Definition XTPDatePickerPaintManager.h:874
CXTPDatePickerPaintManager::m_clrWeekNumbersBack
CXTPPaintManagerColor m_clrWeekNumbersBack
This member variable is a COLORREF object that is used as the background color of the week numbers ar...
Definition XTPDatePickerPaintManager.h:716
CXTPDatePickerPaintManager::m_clrButtonText
CXTPPaintManagerColor m_clrButtonText
This member variable is a COLORREF object that is used as the color for the button text.
Definition XTPDatePickerPaintManager.h:728
CXTPDatePickerPaintManager::RefreshMetrics
virtual void RefreshMetrics()
This member function performs initialization for the Paint Manager.
CXTPDatePickerPaintManager::m_clrNonMonthDayText
CXTPPaintManagerColor m_clrNonMonthDayText
This member variable is a COLORREF object that is used as the color of the non-month day item.
Definition XTPDatePickerPaintManager.h:700
CXTPDatePickerPaintManager::GetWeekNumbersTextFont
CFont * GetWeekNumbersTextFont()
This member function obtains the font of the week numbers items.
Definition XTPDatePickerPaintManager.h:964
CXTPDatePickerPaintManager::GetDayTextColor
virtual COLORREF GetDayTextColor()
This member function is used to obtain the color of the standard day item.
Definition XTPDatePickerPaintManager.h:884
CXTPDatePickerPaintManager::m_clrMonthBorder
CXTPPaintManagerColor m_clrMonthBorder
This member variable is a COLORREF object that is used as the color of the border between day of mont...
Definition XTPDatePickerPaintManager.h:672
CXTPDatePickerPaintManager::GetNonMonthDayTextFont
CFont * GetNonMonthDayTextFont()
This member function is used to obtain the font of the non-month day item.
Definition XTPDatePickerPaintManager.h:909
CXTPDatePickerPaintManager::m_clrControlBack
CXTPPaintManagerColor m_clrControlBack
This member variable is a COLORREF object that is used as the background color of the control.
Definition XTPDatePickerPaintManager.h:638
CXTPDatePickerPaintManager::DrawButton
virtual void DrawButton(CDC *pDC, const CRect &rcButton, const CString &strButton, BOOL bIsDown, BOOL bIsHighLight)
This member function is used to draw the control's buttons.
CXTPDatePickerPaintManager::GetNonMonthDayTextColor
virtual COLORREF GetNonMonthDayTextColor()
This member function is used to obtain the color of the non-month day item.
Definition XTPDatePickerPaintManager.h:904
CXTPDatePickerPaintManager::GetWeekNumbersBackColor
virtual COLORREF GetWeekNumbersBackColor()
This member function obtains the background color of the week numbers area.
Definition XTPDatePickerPaintManager.h:954
CXTPFont
Provides a convenient object oriented interface for HFONT GDI object and uses GDI handle caching.
Definition XTPGdiObjects.h:414
CXTPPaintManagerColor
The CXTPPaintManagerColor class is used to manage COLORREF values for determining default and applica...
Definition XTPColorManager.h:117
CXTPWinThemeWrapper
The CXTPWinThemeWrapper class wraps the UxTheme.dll visual theme API.
Definition XTPWinThemeWrapper.h:188


Toolkit Pro: XTPProgressThemeVisualStudio2019.h Source File

  • Source
  • CommandBars
  • Progress
XTPProgressThemeVisualStudio2019.h
Go to the documentation of this file.
1
23#if !defined(__XTPPROGRESSTHEMEVISUALSTUDIO2019_H__)
24# define __XTPPROGRESSTHEMEVISUALSTUDIO2019_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPProgressBase;
34class CXTPPaintManager;
35
40class _XTP_EXT_CLASS CXTPProgressThemeVisualStudio2019 : public CXTPProgressThemeOffice2013
41{
42public:
48 CXTPProgressThemeVisualStudio2019(CXTPPaintManager* pPaintManager);
49
55 virtual ~CXTPProgressThemeVisualStudio2019();
56};
57
59# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
60#endif // !defined(__XTPPROGRESSTHEMEVISUALSTUDIO2019_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPPaintManager
Paint manager of the command bars.
Definition XTPPaintManager.h:199
CXTPProgressBase
CXTPControlProgressBase is base class for all progress objects.
Definition XTPProgressBase.h:40
CXTPProgressThemeOffice2013
CXTPProgressThemeOffice2013 object.
Definition XTPProgressThemeOffice2013.h:41
CXTPProgressThemeVisualStudio2019
CXTPProgressThemeVisualStudio2019 object.
Definition XTPProgressThemeVisualStudio2019.h:41
CXTPProgressThemeVisualStudio2019::~CXTPProgressThemeVisualStudio2019
virtual ~CXTPProgressThemeVisualStudio2019()
Destroys a CXTPProgressThemeVisualStudio2019 object, handles cleanup and deallocation.
CXTPProgressThemeVisualStudio2019::CXTPProgressThemeVisualStudio2019
CXTPProgressThemeVisualStudio2019(CXTPPaintManager *pPaintManager)
Constructs a CXTPProgressThemeVisualStudio2019 object.


Toolkit Pro: Member List

CXTPChartStackedBarSeriesPointView Member List

This is the complete list of members for CXTPChartStackedBarSeriesPointView, including all inherited members.

AddChildView(CXTPChartElementView *pChildView) | CXTPChartElementView |
CreateDeviceCommand(CXTPChartDeviceContext *pDC) | CXTPChartStackedBarSeriesPointView | virtual
CreateLegendDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcBounds) | CXTPChartBarSeriesPointView | virtual
CXTPChartBarSeriesPointView(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView) | CXTPChartBarSeriesPointView |
CXTPChartElementView(CXTPChartElementView *pParentView) | CXTPChartElementView |
CXTPChartElementView(CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartElementView |
CXTPChartElementView(CXTPChartContainer *pContainer) | CXTPChartElementView |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartSeriesPointView(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView) | CXTPChartSeriesPointView |
CXTPChartSeriesPointView(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartSeriesPointView |
CXTPChartStackedBarSeriesPointView(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView) | CXTPChartStackedBarSeriesPointView |
GetAt(int nIndex) const | CXTPChartElementView |
GetBounds() const | CXTPChartElementView |
GetBounds(BOOL bIncludingChildren) const | CXTPChartElementView |
GetChildren() | CXTPChartElementView |
GetColor() const | CXTPChartSeriesPointView |
GetColor2() const | CXTPChartSeriesPointView |
GetCount() const | CXTPChartElementView |
GetInternalValue() const | CXTPChartSeriesPointView |
GetLegendName() const | CXTPChartSeriesPointView | virtual
GetParentView() const | CXTPChartElementView |
GetPoint() const | CXTPChartSeriesPointView |
GetSeriesView() const | CXTPChartSeriesPointView |
Is3D() const | CXTPChartObject |
m_arrChildren | CXTPChartElementView | protected
m_dInternalValue | CXTPChartSeriesPointView |
m_pContainer | CXTPChartElementView | protected
m_pParentView | CXTPChartElementView | protected
m_pPoint | CXTPChartSeriesPointView | protected
m_rcBounds | CXTPChartElementView | protected
UpdateMinMaxRange(double &nMinValue, double &nMaxValue) const | CXTPChartSeriesPointView | virtual
~CXTPChartElementView() | CXTPChartElementView | protectedvirtual
~CXTPChartLegendItemView() | CXTPChartLegendItemView | inlinevirtual


Toolkit Pro: XTPGridGroupRow.h Source File

  • Source
  • GridControl
XTPGridGroupRow.h
Go to the documentation of this file.
1
23#if !defined(__XTPGRIDGROUPROW_H__)
24# define __XTPGRIDGROUPROW_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPMarkupContext;
34class CXTPMarkupUIElement;
35
48class _XTP_EXT_CLASS CXTPGridGroupRow : public CXTPGridRow
49{
50 DECLARE_DYNAMIC(CXTPGridGroupRow);
51
52public:
57 CXTPGridGroupRow();
58
63 virtual ~CXTPGridGroupRow();
64
73 virtual CString GetCaption() const;
74
83 virtual COleVariant GetCaptionValue() const;
84
91 virtual CString GetTooltip() const;
92
108 void SetCaption(LPCTSTR lpszCaption);
109
126 void SetCaption(LPCTSTR lpszCaption, COleVariant vtValue);
127
132 void UpdateValue();
133
140 virtual CString GetFormula() const;
141
147 virtual void SetFormula(LPCTSTR sFormula);
148
155 virtual CString GetFormatString() const;
156
162 virtual void SetFormatString(LPCTSTR strFormat);
163
177 virtual void Draw(CDC* pDC, CRect rcRow, CRect rcClip, int nLeftOffset,
178 CXTPGridRecordMergeItems& mergeItems, int nColumnFrom, int nColumnTo);
179
187 void OnClick(CPoint ptClicked);
188
199 void OnDblClick(CPoint ptClicked);
200
209 BOOL IsGroupRow() const;
210
212 BOOL CalculateByChilds(CXTPGridRow* pPassedRow, int col_start, int col_end,
213 double& dPassedValue);
215 CXTPMarkupUIElement* m_pMarkupUIElement;
223 virtual void ResetMarkupUIElement();
224
232 virtual void SetControl(CXTPGridControl* pControl);
233
240 void SetCurrencyFormat(LPCURRENCYFMT fmt);
241
242protected:
255 virtual INT_PTR OnToolHitTest(CPoint point, TOOLINFO* pTI);
256
264 CString GetCurrencyString(double value);
265
266protected:
267 CString m_strGroupText;
268 CString m_strGroupLabel;
269 CString m_strFormula;
270 CString m_strFormat;
271 COleVariant m_vtCaptionValue;
272 LPCURRENCYFMT m_lpCurrencyFmt;
278 friend class CXTPGridPaintManager;
279
280# ifdef _XTP_ACTIVEX
282 DECLARE_DISPATCH_MAP()
283 DECLARE_INTERFACE_MAP()
284
285 DECLARE_OLETYPELIB_EX(CXTPGridGroupRow);
286 BSTR OleGetCaption();
287 void OleSetCaption(LPCTSTR pcszCaption);
288
289 BSTR OleGetFormat();
290 void OleSetFormat(LPCTSTR pcszFormat);
291
292 BSTR OleGetFormula();
293 void OleSetFormula(LPCTSTR pcszFormula);
294
296# endif
297};
298
299AFX_INLINE BOOL CXTPGridGroupRow::IsGroupRow() const
300{
301 return TRUE;
302}
303
304AFX_INLINE CString CXTPGridGroupRow::GetTooltip() const
305{
306 return GetCaption();
307}
308
309AFX_INLINE CString CXTPGridGroupRow::GetFormula() const
310{
311 return m_strFormula;
312}
313
314AFX_INLINE void CXTPGridGroupRow::SetFormula(LPCTSTR sFormula)
315{
316 m_strFormula = sFormula;
317}
318
319AFX_INLINE CString CXTPGridGroupRow::GetFormatString() const
320{
321 return m_strFormat;
322}
323
324AFX_INLINE void CXTPGridGroupRow::SetFormatString(LPCTSTR strFormat)
325{
326 m_strFormat = strFormat;
327}
328
329AFX_INLINE void CXTPGridGroupRow::SetControl(CXTPGridControl* pControl)
330{
331 CXTPGridRow::SetControl(pControl);
332 ResetMarkupUIElement();
333}
334
335AFX_INLINE void CXTPGridGroupRow::SetCurrencyFormat(LPCURRENCYFMT fmt)
336{
337 m_lpCurrencyFmt = fmt;
338}
340# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
341#endif //#if !defined(__XTPGRIDGROUPROW_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPGridControl
The CXTPGridControl class provides an implementation of the Grid control.
Definition XTPGridControl.h:479
CXTPGridGroupRow
This class represents a 'group row' of the Grid control view.
Definition XTPGridGroupRow.h:49
CXTPGridGroupRow::ResetMarkupUIElement
virtual void ResetMarkupUIElement()
Resets the Markup element.
CXTPGridGroupRow::GetFormatString
virtual CString GetFormatString() const
Gets the group row caption format string.
Definition XTPGridGroupRow.h:319
CXTPGridGroupRow::m_strFormat
CString m_strFormat
The format string.
Definition XTPGridGroupRow.h:270
CXTPGridGroupRow::OnClick
void OnClick(CPoint ptClicked)
Processes single mouse clicks.
CXTPGridGroupRow::GetCurrencyString
CString GetCurrencyString(double value)
Converts a value into a formatted currency string using m_lpCurrencyFmt.
CXTPGridGroupRow::CXTPGridGroupRow
CXTPGridGroupRow()
Constructs a CXTPGridGroupRow object.
CXTPGridGroupRow::SetCaption
void SetCaption(LPCTSTR lpszCaption, COleVariant vtValue)
Sets the text caption and, optionally, the group caption value.
CXTPGridGroupRow::GetFormula
virtual CString GetFormula() const
Gets the group row formula.
Definition XTPGridGroupRow.h:309
CXTPGridGroupRow::m_strFormula
CString m_strFormula
The formula.
Definition XTPGridGroupRow.h:269
CXTPGridGroupRow::SetCurrencyFormat
void SetCurrencyFormat(LPCURRENCYFMT fmt)
Sets a pointer to the LPCURRENCYFMT (i.e.
Definition XTPGridGroupRow.h:335
CXTPGridGroupRow::SetFormula
virtual void SetFormula(LPCTSTR sFormula)
Sets the group row formula.
Definition XTPGridGroupRow.h:314
CXTPGridGroupRow::~CXTPGridGroupRow
virtual ~CXTPGridGroupRow()
Destroys a CXTPGridGroupRow object, handles cleanup and deallocation.
CXTPGridGroupRow::SetFormatString
virtual void SetFormatString(LPCTSTR strFormat)
Sets the group row caption format string.
Definition XTPGridGroupRow.h:324
CXTPGridGroupRow::Draw
virtual void Draw(CDC *pDC, CRect rcRow, CRect rcClip, int nLeftOffset, CXTPGridRecordMergeItems &mergeItems, int nColumnFrom, int nColumnTo)
Draws the group row on the specified device context.
CXTPGridGroupRow::m_vtCaptionValue
COleVariant m_vtCaptionValue
Native caption value.
Definition XTPGridGroupRow.h:271
CXTPGridGroupRow::OnToolHitTest
virtual INT_PTR OnToolHitTest(CPoint point, TOOLINFO *pTI)
The framework calls this member function to determine whether a point is in the bounding rectangle of...
CXTPGridGroupRow::m_strGroupLabel
CString m_strGroupLabel
Group text label - used as formula prefix.
Definition XTPGridGroupRow.h:268
CXTPGridGroupRow::GetCaption
virtual CString GetCaption() const
Gets the text caption.
CXTPGridGroupRow::UpdateValue
void UpdateValue()
Causes formula computed value to be updated.
CXTPGridGroupRow::SetCaption
void SetCaption(LPCTSTR lpszCaption)
Sets the text caption and, optionally, the group caption value.
CXTPGridGroupRow::m_pMarkupUIElement
CXTPMarkupUIElement * m_pMarkupUIElement
Store markup object.
Definition XTPGridGroupRow.h:215
CXTPGridGroupRow::GetCaptionValue
virtual COleVariant GetCaptionValue() const
Gets the optional native group caption value.
CXTPGridGroupRow::IsGroupRow
BOOL IsGroupRow() const
Determines if this row is a group row.
Definition XTPGridGroupRow.h:299
CXTPGridGroupRow::m_strGroupText
CString m_strGroupText
Group text label.
Definition XTPGridGroupRow.h:267
CXTPGridGroupRow::GetTooltip
virtual CString GetTooltip() const
Gets the tooltip text.
Definition XTPGridGroupRow.h:304
CXTPGridGroupRow::m_lpCurrencyFmt
LPCURRENCYFMT m_lpCurrencyFmt
Contains information that defines the format of a currency.
Definition XTPGridGroupRow.h:272
CXTPGridGroupRow::OnDblClick
void OnDblClick(CPoint ptClicked)
Processes double mouse clicks.
CXTPGridGroupRow::SetControl
virtual void SetControl(CXTPGridControl *pControl)
Sets a pointer to the parent Grid control.
Definition XTPGridGroupRow.h:329
CXTPGridPaintManager
Utility class that handles most drawing activities.
Definition XTPGridPaintManager.h:76
CXTPGridRow
CXTPGridRow class represents a row of the Grid control window.
Definition XTPGridRow.h:71
CXTPGridRow::IsGroupRow
virtual BOOL IsGroupRow() const
Determines if the current row is a group row.
CXTPGridRow::SetControl
virtual void SetControl(CXTPGridControl *pControl)
Sets the parent Grid control.
Definition XTPGridRow.h:864
CXTPMarkupContext
CXTPMarkupContext is a standalone class used to provide common settings for Markup objects.
Definition XTPMarkupContext.h:128
CXTPMarkupUIElement
Base class for XML Markup core level implementations.
Definition XTPMarkupUIElement.h:43


Toolkit Pro: XTPProgressThemeResource.h Source File

  • Source
  • CommandBars
  • Progress
XTPProgressThemeResource.h
Go to the documentation of this file.
1
23#if !defined(__XTPPROGRESSTHEMERESOURCE_H__)
24# define __XTPPROGRESSTHEMERESOURCE_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class _XTP_EXT_CLASS CXTPProgressResourceTheme : public CXTPProgressPaintManager
34{
35public:
36 CXTPProgressResourceTheme(CXTPPaintManager* pPaintManager);
37
38public:
39 virtual void DrawProgress(CDC* pDC, CXTPProgressBase* pGallery);
40};
41
43# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
44#endif // !defined(__XTPPROGRESSTHEMERESOURCE_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPPaintManager
Paint manager of the command bars.
Definition XTPPaintManager.h:199
CXTPProgressBase
CXTPControlProgressBase is base class for all progress objects.
Definition XTPProgressBase.h:40
CXTPProgressPaintManager
CXTPProgressPaintManager object.
Definition XTPProgressPaintManager.h:41
CXTPProgressPaintManager::DrawProgress
virtual void DrawProgress(CDC *pDC, CXTPProgressBase *pProgressBar)
This method is called to draw progress.


Toolkit Pro: XTPTabPaintManager.h Source File

  • Source
  • TabManager
XTPTabPaintManager.h
Go to the documentation of this file.
1
23#if !defined(__XTPTABPAINTMANAGER_H__)
24# define __XTPTABPAINTMANAGER_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPTabManager;
34class CXTPTabManagerAtom;
35class CXTPTabManagerItem;
36class CXTPTabManagerNavigateButton;
37class CXTPWinThemeWrapper;
38class CXTPTabPaintManager;
39class CXTPTabPaintManagerColorSet;
40class CXTPTabPaintManagerTheme;
41
47class _XTP_EXT_CLASS CXTPTabPaintManager : public CXTPCmdTarget
48{
49public:
50 class CAppearanceSetPropertyPage;
51 class CAppearanceSetFlat;
52 class CColorSetDefault;
53
54public:
60 CXTPTabPaintManager(BOOL bPanelManager = FALSE);
61
66 virtual ~CXTPTabPaintManager();
67
68public:
86 virtual CXTPTabPaintManagerColorSet* SetColor(XTPTabColorStyle tabColor);
87
104 virtual CXTPTabPaintManagerColorSet* SetColorSet(CXTPTabPaintManagerColorSet* pColorSet);
105
124 virtual CXTPTabPaintManagerTheme* SetAppearance(XTPTabAppearanceStyle tabAppearance);
125
148 virtual CXTPTabPaintManagerTheme* SetAppearanceSet(CXTPTabPaintManagerTheme* pAppearanceSet);
149
167 CXTPTabPaintManagerTheme* GetAppearanceSet() const;
168
180 CXTPTabPaintManagerColorSet* GetColorSet() const;
181
195 XTPTabAppearanceStyle GetAppearance() const;
196
208 XTPTabColorStyle GetColor() const;
209
223 BOOL IsLunaColorsDisabled() const;
224
238 void DisableLunaColors(BOOL bDisableLunaColors);
239
273 static COLORREF AFX_CDECL GetOneNoteColor(XTPTabOneNoteColor tabColor);
274
284 void SetOneNoteColors(BOOL bOneNoteColors);
285
298 void SetPosition(XTPTabPosition tabPosition);
299
312 void SetLayout(XTPTabLayoutStyle tabLayout);
313
327 XTPTabPosition GetPosition() const;
328
342 XTPTabLayoutStyle GetLayout() const;
343
356 void SetFontIndirect(LOGFONT* pLogFont, BOOL bUseStandardFont = FALSE);
357
358public:
372 virtual void DrawTabControl(CXTPTabManager* pTabManager, CDC* pDC, CRect rcControl);
373
394 virtual void AdjustClientRect(CXTPTabManager* pTabManager, CRect& rcClient);
395
410 virtual void RepositionTabControl(CXTPTabManager* pTabManager, CDC* pDC, CRect rcControl);
411
423 CRect RepositionNavigateButtons(CXTPTabManager* pTabManager, CRect rcClient);
424
441 void FillNavigateButton(CDC* pDC, CXTPTabManagerNavigateButton* pButton, CRect& rc);
442
453 virtual void DrawNavigateButton(CDC* pDC, CXTPTabManagerNavigateButton* pButton, CRect& rc);
454
477 virtual int DrawSingleButtonIconAndText(CDC* pDC, CXTPTabManagerItem* pItem, CRect rcItem,
478 BOOL bDraw);
479
488 void EnsureVisible(CXTPTabManager* pTabManager, CXTPTabManagerItem* pItem);
489
501 virtual void RefreshMetrics();
502
512 void AddObserver(CXTPTabManagerAtom* pObserver);
513
526 void EnableToolTips(XTPTabToolTipBehaviour behaviour = xtpTabToolTipAlways);
527
528public:
539 CFont* GetFont(BOOL bVertical = FALSE);
540
557 CFont* GetBoldFont(BOOL bVertical = FALSE);
558
559protected:
573 void SizeToFit(CXTPTabManager* pTabManager, int nWidth);
574
587 void DrawTabControlEx(CXTPTabManager* pTabManager, CDC* pDC, CRect rcControl);
588
605 void RepositionTabControlEx(CXTPTabManager* pTabManager, CDC* pDC, CRect rcClient);
606
614 void RepositionTabControlMultiRow(CXTPTabManager* pTabManager, CDC* pDC, CRect rcClient);
615
620 virtual void OnPropertyChanged();
621
622protected:
636 int _GetButtonLength(int nValue, int nMin, int nMax);
637
648 void DrawTextPathEllipsis(CDC* pDC, CXTPTabManager* pManager, const CString& strItem,
649 CRect rcItem, UINT uFormat);
650
651protected:
653 int GetPrefixTextExtent(CDC* pDC, CXTPTabManager* pManager, const CString& str, CRect rcItem,
654 UINT uFormat);
655 void StripMnemonics(CString& strClear);
656 void DrawRowItems(CXTPTabManager* pTabManager, CDC* pDC, const CRect& rcClient, int nItemRow);
657 void CreateMultiRowIndexer(CXTPTabManager* pTabManager, CDC* pDC, int nWidth);
658 virtual void DrawFocusRect(CDC* pDC, CXTPTabManagerItem* pItem, CRect rcItem);
659 BOOL _CreateMultiRowIndexerBestFit(CXTPTabManager* pTabManager, int nWidth, int nRow,
660 int nTotalLength);
661 BOOL _CreateMultiRowIndexerPlain(CXTPTabManager* pTabManager, int nWidth, int nRow,
662 int nTotalLength);
663
664 int _ReduceNumberOfRowsForPlainIndexer(CXTPTabManager* pTabManager, int nRowCount, int nWidth,
665 int nTotalLength);
669 static int AFX_CDECL _SizeToFitCompare(const void* arg1, const void* arg2);
670
673public:
674 BOOL m_bHotTracking;
675 BOOL m_bShowIcons;
676 BOOL m_bBoldSelected;
678 BOOL m_bBoldNormal;
680 BOOL m_bDisableLunaColors;
682 BOOL m_bOneNoteColors;
683 XTPTabClientFrame m_clientFrame;
684 BOOL m_bStaticFrame;
686 CRect m_rcClientMargin;
687 CRect m_rcControlMargin;
689 CRect m_rcButtonMargin;
690 CRect m_rcButtonTextPadding;
691 BOOL m_bInvertGradient;
694 BOOL m_bFillBackground;
698 CSize m_szIcon;
699 BOOL m_bDrawTextPathEllipsis;
703 BOOL m_bDrawTextEndEllipsis;
707 BOOL m_bDrawTextNoPrefix;
710 UINT m_nDrawTextFormat;
711 BOOL m_bDrawTextHidePrefix;
714 BOOL m_bMultiRowFixedSelection;
716 BOOL m_bMultiRowJustified;
718 BOOL m_bDrawFocusRect;
719 int m_bSelectOnDragOver;
721 int m_nButtonExtraLength;
722 BOOL m_bSelectOnButtonDown;
723 BOOL m_bClearTypeTextQuality;
724 BOOL m_bRotateImageOnVerticalDraw;
725 BOOL m_bClipHeader;
726 CSize m_szNavigateButton;
727 CSize m_szTabCloseButton;
728 BOOL m_bShowTabs;
729 BOOL m_bMultiRowTabsOptimization;
731 int m_nMinTabWidth;
732 int m_nMaxTabWidth;
733 int m_nFixedTabWidth;
734 XTPTabToolTipBehaviour m_toolBehaviour;
735 BOOL m_bVerticalTextTopToBottom;
736 BOOL m_bPanelManager;
738 static DWORD m_nSelectOnDragOverDelay;
741protected:
742 CXTPTabPaintManagerTheme* m_pAppearanceSet;
743 CXTPTabPaintManagerColorSet* m_pColorSet;
744 CArray<CXTPTabManagerAtom*, CXTPTabManagerAtom*> m_arrObservers;
748 XTPTabAppearanceStyle m_tabAppearance;
749 XTPTabColorStyle m_tabColor;
750 XTPTabPosition m_tabPosition;
754 XTPTabLayoutStyle m_tabLayout;
756 CXTPFont m_xtpFontNormal;
757 CXTPFont m_xtpFontBold;
759 CXTPFont m_xtpFontVerticalNormal;
761 CXTPFont m_xtpFontVerticalBold;
765 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CFont, m_fntNormal, m_xtpFontNormal, GetNormalFontHandle);
766 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CFont, m_fntBold, m_xtpFontBold, GetBoldFontHandle);
767 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CFont, m_fntVerticalNormal, m_xtpFontVerticalNormal,
768 GetVerticalNormalFontHandle);
769 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CFont, m_fntVerticalBold, m_xtpFontVerticalBold,
770 GetVerticalBoldFontHandle);
771
772 BOOL m_bUseStandardFont;
774private:
775 int m_nItemColor;
776
777 friend class CXTPTabPaintManagerTheme;
778 friend class CXTPTabPaintManagerColorSet;
779 friend class CXTPTabManager;
780
781# ifdef _XTP_ACTIVEX
783public:
784 afx_msg BOOL OleIsColorSupported(long nColor);
785 afx_msg LPDISPATCH OleGetClientMargin();
786 afx_msg LPDISPATCH OleGetControlMargin();
787 afx_msg LPDISPATCH OleGetHeaderMargin();
788 afx_msg LPDISPATCH OleGetButtonMargin();
789 afx_msg void OleSetFont(LPFONTDISP pFontDisp);
790 afx_msg LPFONTDISP OleGetFont();
791 afx_msg LPDISPATCH OleGetColorSet();
792 afx_msg void OleSetIconSize(long cx, long cy);
793 afx_msg void OleRefreshMetrics();
794 afx_msg void OnClearTypeTextQualityChanged();
795 DECLARE_DISPATCH_MAP()
796 DECLARE_INTERFACE_MAP()
797
798 DECLARE_OLETYPELIB_EX(CXTPTabPaintManager);
799
800 friend class CXTPTabPaintManagerMargin;
802# endif
803};
804
806
807AFX_INLINE CFont* CXTPTabPaintManager::GetFont(BOOL bVertical)
808{
809 return bVertical ? &m_xtpFontVerticalNormal : &m_xtpFontNormal;
810}
811
812AFX_INLINE CFont* CXTPTabPaintManager::GetBoldFont(BOOL bVertical)
813{
814 return bVertical ? &m_xtpFontVerticalBold : &m_xtpFontBold;
815}
816
817AFX_INLINE CXTPTabPaintManagerTheme* CXTPTabPaintManager::GetAppearanceSet() const
818{
819 return m_pAppearanceSet;
820}
821
822AFX_INLINE CXTPTabPaintManagerColorSet* CXTPTabPaintManager::GetColorSet() const
823{
824 return m_pColorSet;
825}
826
827AFX_INLINE void CXTPTabPaintManager::EnableToolTips(XTPTabToolTipBehaviour behaviour)
828{
829 m_toolBehaviour = behaviour;
830}
831
832# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
834#endif // !defined(__XTPTABPAINTMANAGER_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPTabAppearanceStyle
XTPTabAppearanceStyle
XTPTabAppearanceStyle is an enumeration used to set the appearance of tabs.
Definition XTPTabManagerDefines.h:84
XTPTabPosition
XTPTabPosition
XTPTabPosition is an enumeration used to set the position of tabs.
Definition XTPTabManagerDefines.h:200
XTPTabLayoutStyle
XTPTabLayoutStyle
XTPTabLayoutStyle is an enumeration used to set the layout of tabs.
Definition XTPTabManagerDefines.h:217
XTPTabColorStyle
XTPTabColorStyle
XTPTabColorStyle is an enumeration used to set the color style of tabs.
Definition XTPTabManagerDefines.h:139
XTPTabClientFrame
XTPTabClientFrame
XTPTabClientFrame is an enumeration used to set the client frame style drawn around the client of tab...
Definition XTPTabManagerDefines.h:309
XTPTabOneNoteColor
XTPTabOneNoteColor
XTPTabOneNoteColor is an enumeration used to indicate which OneNote RGB color value to retrieve.
Definition XTPTabManagerDefines.h:262
XTPTabToolTipBehaviour
XTPTabToolTipBehaviour
XTPTabToolTipBehaviour is an enumeration used to set the tooltip behaviour for tabs.
Definition XTPTabManagerDefines.h:240
xtpTabToolTipAlways
@ xtpTabToolTipAlways
Always show tooltips for tabs.
Definition XTPTabManagerDefines.h:242
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPFont
Provides a convenient object oriented interface for HFONT GDI object and uses GDI handle caching.
Definition XTPGdiObjects.h:414
CXTPTabManagerAtom
CXTPTabManagerAtom is a class that has only one purpose; to catch the event when a property of the Pa...
Definition XTPTabManagerAtom.h:49
CXTPTabManager
CXTPTabManager is the base class for docking pane tabs, tab control tabs, and MDI client tabs.
Definition XTPTabManager.h:87
CXTPTabManagerItem
CXTPTabManagerItem is the base class for the tabs that appear in the command bars tab workspace,...
Definition XTPTabManagerItem.h:44
CXTPTabManagerNavigateButton
CXTPTabManagerNavigateButton is a class used to represent a tab navigation button.
Definition XTPTabManagerNavigateButton.h:74
CXTPTabPaintManagerColorSet
CXTPTabPaintManagerColorSet represents the colors for all of the components of the tab manager (e....
Definition XTPTabPaintManagerColorSet.h:50
CXTPTabPaintManager
CXTPTabPaintManager is used to store the color and appearance information of the tabs in the tab mana...
Definition XTPTabPaintManager.h:48
CXTPTabPaintManager::m_rcButtonTextPadding
CRect m_rcButtonTextPadding
Margin around the text in tab button.
Definition XTPTabPaintManager.h:690
CXTPTabPaintManager::_GetButtonLength
int _GetButtonLength(int nValue, int nMin, int nMax)
Gets the total button length of a tab button including the left and right button margins.
CXTPTabPaintManager::m_nMinTabWidth
int m_nMinTabWidth
Minimum tabs width.
Definition XTPTabPaintManager.h:731
CXTPTabPaintManager::m_rcClientMargin
CRect m_rcClientMargin
Margin around the tab client area.
Definition XTPTabPaintManager.h:686
CXTPTabPaintManager::SetFontIndirect
void SetFontIndirect(LOGFONT *pLogFont, BOOL bUseStandardFont=FALSE)
Sets the font for the tabs.
CXTPTabPaintManager::GetFont
CFont * GetFont(BOOL bVertical=FALSE)
Gets the font used to display caption text in the tab buttons.
Definition XTPTabPaintManager.h:807
CXTPTabPaintManager::GetLayout
XTPTabLayoutStyle GetLayout() const
Gets the tab layout style.
CXTPTabPaintManager::m_bShowIcons
BOOL m_bShowIcons
If TRUE, then tab icons will be drawn if icons were added.
Definition XTPTabPaintManager.h:675
CXTPTabPaintManager::m_bDrawTextEndEllipsis
BOOL m_bDrawTextEndEllipsis
If TRUE, when the size of a tab button is too small to display the caption, the end of the caption wi...
Definition XTPTabPaintManager.h:703
CXTPTabPaintManager::m_xtpFontVerticalBold
CXTPFont m_xtpFontVerticalBold
Font used to display bold text in the tab buttons when the tab position is vertical (i....
Definition XTPTabPaintManager.h:761
CXTPTabPaintManager::m_bDrawFocusRect
BOOL m_bDrawFocusRect
TRUE to draw focus rect for focused item.
Definition XTPTabPaintManager.h:718
CXTPTabPaintManager::m_bDrawTextHidePrefix
BOOL m_bDrawTextHidePrefix
If FALSE, then an ampersand '&' in the tab button caption will be ignored and a double ampersand '&&'...
Definition XTPTabPaintManager.h:711
CXTPTabPaintManager::DrawSingleButtonIconAndText
virtual int DrawSingleButtonIconAndText(CDC *pDC, CXTPTabManagerItem *pItem, CRect rcItem, BOOL bDraw)
Draws the text and icon of a specified tab button.
CXTPTabPaintManager::AddObserver
void AddObserver(CXTPTabManagerAtom *pObserver)
Adds a control to the list of controls that receives a notification when a property of the paint mana...
CXTPTabPaintManager::m_tabPosition
XTPTabPosition m_tabPosition
Currently set tab button position.
Definition XTPTabPaintManager.h:750
CXTPTabPaintManager::m_bShowTabs
BOOL m_bShowTabs
TRUE to show tabs.
Definition XTPTabPaintManager.h:728
CXTPTabPaintManager::m_bOneNoteColors
BOOL m_bOneNoteColors
If FALSE, then tabs will not use luna colors * the current theme uses luna colors.
Definition XTPTabPaintManager.h:682
CXTPTabPaintManager::FillNavigateButton
void FillNavigateButton(CDC *pDC, CXTPTabManagerNavigateButton *pButton, CRect &rc)
Fills a specified tab navigation button.
CXTPTabPaintManager::GetAppearance
XTPTabAppearanceStyle GetAppearance() const
Gets the currently applied "built-in appearance set.
CXTPTabPaintManager::GetBoldFont
CFont * GetBoldFont(BOOL bVertical=FALSE)
Gets the font used to display bold caption text in the tab buttons.
Definition XTPTabPaintManager.h:812
CXTPTabPaintManager::m_szNavigateButton
CSize m_szNavigateButton
Navigate buttons size.
Definition XTPTabPaintManager.h:726
CXTPTabPaintManager::m_bSelectOnButtonDown
BOOL m_bSelectOnButtonDown
If TRUE, then tab selected on mouse button down.
Definition XTPTabPaintManager.h:722
CXTPTabPaintManager::m_bStaticFrame
BOOL m_bStaticFrame
If TRUE, then a static frame will be drawn around the entire tab area.
Definition XTPTabPaintManager.h:684
CXTPTabPaintManager::DrawNavigateButton
virtual void DrawNavigateButton(CDC *pDC, CXTPTabManagerNavigateButton *pButton, CRect &rc)
Draws a specified tab navigation button.
CXTPTabPaintManager::m_bInvertGradient
BOOL m_bInvertGradient
If TRUE, then the colors passed into CXTPTabPaintManagerColorSet::GradientFill will be swapped before...
Definition XTPTabPaintManager.h:691
CXTPTabPaintManager::m_bHotTracking
BOOL m_bHotTracking
If TRUE, then tab hot tracking will be enabled.
Definition XTPTabPaintManager.h:674
CXTPTabPaintManager::m_bFillBackground
BOOL m_bFillBackground
If TRUE, then the tab client space is filled using CXTPTabPaintManager.CXTPTabPaintManagerColorSet....
Definition XTPTabPaintManager.h:694
CXTPTabPaintManager::m_xtpFontVerticalNormal
CXTPFont m_xtpFontVerticalNormal
Font used to display tab button caption when the tab position is vertical.
Definition XTPTabPaintManager.h:759
CXTPTabPaintManager::GetOneNoteColor
static COLORREF AFX_CDECL GetOneNoteColor(XTPTabOneNoteColor tabColor)
Retrieves the RGB value of a specified OneNote color.
CXTPTabPaintManager::m_szTabCloseButton
CSize m_szTabCloseButton
Tab close button size.
Definition XTPTabPaintManager.h:727
CXTPTabPaintManager::DrawTabControl
virtual void DrawTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl)
Draws the tab control.
CXTPTabPaintManager::m_xtpFontNormal
CXTPFont m_xtpFontNormal
Font used to display text in tab buttons.
Definition XTPTabPaintManager.h:756
CXTPTabPaintManager::SetLayout
void SetLayout(XTPTabLayoutStyle tabLayout)
Sets the tab layout style.
CXTPTabPaintManager::m_bClipHeader
BOOL m_bClipHeader
TRUE to select clip rectangle before draw tabs.
Definition XTPTabPaintManager.h:725
CXTPTabPaintManager::m_nButtonExtraLength
int m_nButtonExtraLength
Additional padding of tabs.
Definition XTPTabPaintManager.h:721
CXTPTabPaintManager::SetOneNoteColors
void SetOneNoteColors(BOOL bOneNoteColors)
Enables/disables OneNote colorization for the tabs.
CXTPTabPaintManager::GetColorSet
CXTPTabPaintManagerColorSet * GetColorSet() const
Gets the currently applied custom color set.
Definition XTPTabPaintManager.h:822
CXTPTabPaintManager::EnableToolTips
void EnableToolTips(XTPTabToolTipBehaviour behaviour=xtpTabToolTipAlways)
Sets the behaviour for tooltips.
Definition XTPTabPaintManager.h:827
CXTPTabPaintManager::m_xtpFontBold
CXTPFont m_xtpFontBold
Font used to display bold text in the tab buttons (i.e.
Definition XTPTabPaintManager.h:757
CXTPTabPaintManager::m_bPanelManager
BOOL m_bPanelManager
TRUE indicates that this is a panel manager, FALSE for tab manager.
Definition XTPTabPaintManager.h:736
CXTPTabPaintManager::OnPropertyChanged
virtual void OnPropertyChanged()
This method is called when a property of the tab paint manager is changed.
CXTPTabPaintManager::m_pAppearanceSet
CXTPTabPaintManagerTheme * m_pAppearanceSet
Currently set CXTPTabPaintManagerTheme.
Definition XTPTabPaintManager.h:742
CXTPTabPaintManager::DrawTextPathEllipsis
void DrawTextPathEllipsis(CDC *pDC, CXTPTabManager *pManager, const CString &strItem, CRect rcItem, UINT uFormat)
Draws an ellipse "..." in the middle of a specified string.
CXTPTabPaintManager::RepositionNavigateButtons
CRect RepositionNavigateButtons(CXTPTabManager *pTabManager, CRect rcClient)
Repositions the tab navigation buttons.
CXTPTabPaintManager::m_tabColor
XTPTabColorStyle m_tabColor
Currently used color style.
Definition XTPTabPaintManager.h:749
CXTPTabPaintManager::m_szIcon
CSize m_szIcon
Size of the icon displayed in the tab button.
Definition XTPTabPaintManager.h:698
CXTPTabPaintManager::DisableLunaColors
void DisableLunaColors(BOOL bDisableLunaColors)
Disables/enables luna colors.
CXTPTabPaintManager::m_bClearTypeTextQuality
BOOL m_bClearTypeTextQuality
TRUE to enable ClearType text for the font.
Definition XTPTabPaintManager.h:723
CXTPTabPaintManager::m_bMultiRowTabsOptimization
BOOL m_bMultiRowTabsOptimization
TRUE if the tab manager will arrange tabs according to their widths.
Definition XTPTabPaintManager.h:729
CXTPTabPaintManager::m_bDrawTextNoPrefix
BOOL m_bDrawTextNoPrefix
If FALSE, then an ampersand '&' in the tab button caption will be ignored and a double ampersand '&&'...
Definition XTPTabPaintManager.h:707
CXTPTabPaintManager::GetColor
XTPTabColorStyle GetColor() const
Gets the currently applied "built-in" color set.
CXTPTabPaintManager::GetAppearanceSet
CXTPTabPaintManagerTheme * GetAppearanceSet() const
Gets the currently applied custom appearance set.
Definition XTPTabPaintManager.h:817
CXTPTabPaintManager::m_bBoldNormal
BOOL m_bBoldNormal
If TRUE, then bold font will be used for all tabs regardless of whether they are selected or non-sele...
Definition XTPTabPaintManager.h:678
CXTPTabPaintManager::m_bMultiRowFixedSelection
BOOL m_bMultiRowFixedSelection
FALSE to move row with selected item close to client pane.
Definition XTPTabPaintManager.h:714
CXTPTabPaintManager::m_bUseStandardFont
BOOL m_bUseStandardFont
TRUE to use standard system "icon" font (i.e.
Definition XTPTabPaintManager.h:772
CXTPTabPaintManager::m_bVerticalTextTopToBottom
BOOL m_bVerticalTextTopToBottom
Draw vertical text Top-to-Bottom or Bottom-to-Top.
Definition XTPTabPaintManager.h:735
CXTPTabPaintManager::m_arrObservers
CArray< CXTPTabManagerAtom *, CXTPTabManagerAtom * > m_arrObservers
List of controls that receive a notification when a property of the paint manager has changed.
Definition XTPTabPaintManager.h:744
CXTPTabPaintManager::RepositionTabControl
virtual void RepositionTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl)
Moves the tab buttons of the tab control to their correct positions.
CXTPTabPaintManager::m_rcControlMargin
CRect m_rcControlMargin
Margin around the entire tab control (i.e.
Definition XTPTabPaintManager.h:687
CXTPTabPaintManager::m_tabAppearance
XTPTabAppearanceStyle m_tabAppearance
Currently set appearance style.
Definition XTPTabPaintManager.h:748
CXTPTabPaintManager::m_bMultiRowJustified
BOOL m_bMultiRowJustified
TRUE to stretch each row of tabs to fill the entire width of the control.
Definition XTPTabPaintManager.h:716
CXTPTabPaintManager::IsLunaColorsDisabled
BOOL IsLunaColorsDisabled() const
Determines if luna colors are disabled/enabled.
CXTPTabPaintManager::~CXTPTabPaintManager
virtual ~CXTPTabPaintManager()
Destroys a CXTPTabPaintManager object, handles cleanup and deallocation.
CXTPTabPaintManager::DrawTabControlEx
void DrawTabControlEx(CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl)
Draws the tab control.
CXTPTabPaintManager::SetAppearance
virtual CXTPTabPaintManagerTheme * SetAppearance(XTPTabAppearanceStyle tabAppearance)
Applies one of the "built-in" appearance sets for the tabs.
CXTPTabPaintManager::SetColor
virtual CXTPTabPaintManagerColorSet * SetColor(XTPTabColorStyle tabColor)
Applies one of the "built-in" color sets for the tabs.
CXTPTabPaintManager::SetColorSet
virtual CXTPTabPaintManagerColorSet * SetColorSet(CXTPTabPaintManagerColorSet *pColorSet)
Applies a custom color set for the tabs.
CXTPTabPaintManager::m_toolBehaviour
XTPTabToolTipBehaviour m_toolBehaviour
Tootips behaviour.
Definition XTPTabPaintManager.h:734
CXTPTabPaintManager::CXTPTabPaintManager
CXTPTabPaintManager(BOOL bPanelManager=FALSE)
Constructs a CXTPTabPaintManager object.
CXTPTabPaintManager::GetPosition
XTPTabPosition GetPosition() const
Gets the tab position.
CXTPTabPaintManager::SizeToFit
void SizeToFit(CXTPTabManager *pTabManager, int nWidth)
Changes the tab button size when XTPTabLayoutStyle is set to xtpTabLayoutSizeToFit.
CXTPTabPaintManager::m_bRotateImageOnVerticalDraw
BOOL m_bRotateImageOnVerticalDraw
TRUE to rotate image when tab located left or right.
Definition XTPTabPaintManager.h:724
CXTPTabPaintManager::m_bSelectOnDragOver
int m_bSelectOnDragOver
1 - to activate tab when user drag files/text under it.
Definition XTPTabPaintManager.h:719
CXTPTabPaintManager::m_pColorSet
CXTPTabPaintManagerColorSet * m_pColorSet
Currently used CXTPTabPaintManagerColorSet.
Definition XTPTabPaintManager.h:743
CXTPTabPaintManager::RefreshMetrics
virtual void RefreshMetrics()
Refreshes the visual metrics of the main tab manager.
CXTPTabPaintManager::SetAppearanceSet
virtual CXTPTabPaintManagerTheme * SetAppearanceSet(CXTPTabPaintManagerTheme *pAppearanceSet)
Applies a custom appearance set for the tabs.
CXTPTabPaintManager::RepositionTabControlEx
void RepositionTabControlEx(CXTPTabManager *pTabManager, CDC *pDC, CRect rcClient)
Moves the tab buttons of the tab control to their correct positions.
CXTPTabPaintManager::m_tabLayout
XTPTabLayoutStyle m_tabLayout
Currently set tab button layout.
Definition XTPTabPaintManager.h:754
CXTPTabPaintManager::m_bDrawTextPathEllipsis
BOOL m_bDrawTextPathEllipsis
If TRUE, when the size of a tab button is too small to display the caption, the middle of the caption...
Definition XTPTabPaintManager.h:699
CXTPTabPaintManager::AdjustClientRect
virtual void AdjustClientRect(CXTPTabManager *pTabManager, CRect &rcClient)
Adjusts the tab client rectangle.
CXTPTabPaintManager::EnsureVisible
void EnsureVisible(CXTPTabManager *pTabManager, CXTPTabManagerItem *pItem)
Ensures that a specified tab is visible.
CXTPTabPaintManager::m_clientFrame
XTPTabClientFrame m_clientFrame
If TRUE, then tabs will use OneNote colorization.
Definition XTPTabPaintManager.h:683
CXTPTabPaintManager::m_bBoldSelected
BOOL m_bBoldSelected
If TRUE, then the text of selected tabs will be displayed in bold font.
Definition XTPTabPaintManager.h:676
CXTPTabPaintManager::m_nSelectOnDragOverDelay
static DWORD m_nSelectOnDragOverDelay
Delay before Select-on-Drag-Over (300 by default).
Definition XTPTabPaintManager.h:738
CXTPTabPaintManager::SetPosition
void SetPosition(XTPTabPosition tabPosition)
Sets the tab position.
CXTPTabPaintManager::RepositionTabControlMultiRow
void RepositionTabControlMultiRow(CXTPTabManager *pTabManager, CDC *pDC, CRect rcClient)
Moves the tab buttons of the multi-row tab control to their correct positions.
CXTPTabPaintManager::m_nDrawTextFormat
UINT m_nDrawTextFormat
Text format for tabs (default - DT_LEFT | DT_VCENTER).
Definition XTPTabPaintManager.h:710
CXTPTabPaintManager::m_nMaxTabWidth
int m_nMaxTabWidth
Maximum tabs width.
Definition XTPTabPaintManager.h:732
CXTPTabPaintManager::m_rcButtonMargin
CRect m_rcButtonMargin
Margin around the text in tab button.
Definition XTPTabPaintManager.h:689
CXTPTabPaintManager::m_nFixedTabWidth
int m_nFixedTabWidth
Tabs width for fixed layout.
Definition XTPTabPaintManager.h:733
CXTPTabPaintManagerTheme
CXTPTabPaintManagerTheme is a class that represents the appearance of all components of the tab manag...
Definition XTPTabPaintManagerTheme.h:56
CXTPWinThemeWrapper
The CXTPWinThemeWrapper class wraps the UxTheme.dll visual theme API.
Definition XTPWinThemeWrapper.h:188


Toolkit Pro: Member List

CXTPDialogEx Member List

This is the complete list of members for CXTPDialogEx, including all inherited members.

CXTPDialogBase() | CXTPDialogBase< CDialog > | inline
CXTPDialogBase(UINT nIDTemplate, CWnd *pParentWnd=NULL) | CXTPDialogBase< CDialog > | inline
CXTPDialogBase(LPCTSTR lpszTemplateName, CWnd *pParentWnd=NULL) | CXTPDialogBase< CDialog > | inline
CXTPDialogEx() | CXTPDialogEx | inline
CXTPDialogEx(UINT nIDTemplate, CWnd *pParentWnd=NULL) | CXTPDialogEx | inline
CXTPDialogEx(LPCTSTR lpszTemplateName, CWnd *pParentWnd=NULL) | CXTPDialogEx | inline


Toolkit Pro: XTPFlowGraphConnections.h Source File

  • Source
  • FlowGraph
XTPFlowGraphConnections.h
Go to the documentation of this file.
1
23#if !defined(__XTPFLOWGRAPHCONNECTIONS_H__)
24# define __XTPFLOWGRAPHCONNECTIONS_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPFlowGraphPage;
34class CXTPFlowGraphConnection;
35
40class _XTP_EXT_CLASS CXTPFlowGraphConnections : public CXTPCmdTarget
41{
42protected:
48 CXTPFlowGraphConnections(CXTPFlowGraphPage* pPage);
54 virtual ~CXTPFlowGraphConnections();
55
56public:
61 void RemoveAll();
62
70 CXTPFlowGraphConnection* AddConnection(CXTPFlowGraphConnection* pConnection);
71
77 void Remove(CXTPFlowGraphConnection* pConnection);
84 void RemoveAt(int nIndex);
85
92 int GetCount() const;
100 CXTPFlowGraphConnection* GetAt(int nIndex) const;
101
102public:
112 void DoPropExchange(CXTPPropExchange* pPX);
113
114protected:
115 CXTPFlowGraphPage* m_pPage;
116 CArray<CXTPFlowGraphConnection*, CXTPFlowGraphConnection*> m_arrConnections;
119 friend class CXTPFlowGraphPage;
120
121# ifdef _XTP_ACTIVEX
124 DECLARE_DISPATCH_MAP()
125 DECLARE_INTERFACE_MAP()
126
127 DECLARE_OLETYPELIB_EX(CXTPFlowGraphConnections)
128 DECLARE_ENUM_VARIANT(CXTPFlowGraphConnections)
129
130 afx_msg int OleGetItemCount();
131 afx_msg LPDISPATCH OleGetItem(int nIndex);
132 afx_msg LPDISPATCH OleAddConnection();
133
135# endif
136};
137
138AFX_INLINE int CXTPFlowGraphConnections::GetCount() const
139{
140 return (int)m_arrConnections.GetSize();
141}
142AFX_INLINE CXTPFlowGraphConnection* CXTPFlowGraphConnections::GetAt(int nIndex) const
143{
144 return nIndex >= 0 && nIndex < m_arrConnections.GetSize() ? m_arrConnections[nIndex] : NULL;
145}
147# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
148#endif //#if !defined(__XTPFLOWGRAPHCONNECTIONS_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPFlowGraphConnection
Represents a connection.
Definition XTPFlowGraphConnection.h:49
CXTPFlowGraphConnections
Represents a collection of connections for a Node.
Definition XTPFlowGraphConnections.h:41
CXTPFlowGraphConnections::GetCount
int GetCount() const
Gets the total number of connections for the Node.
Definition XTPFlowGraphConnections.h:138
CXTPFlowGraphConnections::DoPropExchange
void DoPropExchange(CXTPPropExchange *pPX)
Call this member function to store/load a collection of connections using the specified data object.
CXTPFlowGraphConnections::Remove
void Remove(CXTPFlowGraphConnection *pConnection)
Removes the specified connection.
CXTPFlowGraphConnections::AddConnection
CXTPFlowGraphConnection * AddConnection(CXTPFlowGraphConnection *pConnection)
Adds a connection to the Node.
CXTPFlowGraphConnections::m_pPage
CXTPFlowGraphPage * m_pPage
Pointer to the page that displays these connections.
Definition XTPFlowGraphConnections.h:115
CXTPFlowGraphConnections::RemoveAll
void RemoveAll()
Removes all connections from the Node.
CXTPFlowGraphConnections::~CXTPFlowGraphConnections
virtual ~CXTPFlowGraphConnections()
Destroys a CXTPFlowGraphConnections object, handles cleanup and deallocation.
CXTPFlowGraphConnections::RemoveAt
void RemoveAt(int nIndex)
Removes the specified connection from the Node's collection of connections.
CXTPFlowGraphConnections::m_arrConnections
CArray< CXTPFlowGraphConnection *, CXTPFlowGraphConnection * > m_arrConnections
Collection of connections.
Definition XTPFlowGraphConnections.h:116
CXTPFlowGraphConnections::CXTPFlowGraphConnections
CXTPFlowGraphConnections(CXTPFlowGraphPage *pPage)
Constructs a CXTPFlowGraphConnections object.
CXTPFlowGraphConnections::GetAt
CXTPFlowGraphConnection * GetAt(int nIndex) const
Retrieves the connection at the specified index.
Definition XTPFlowGraphConnections.h:142
CXTPFlowGraphPage
Represents a page in the flow graph.
Definition XTPFlowGraphPage.h:54
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72


Toolkit Pro: Member List

CAppearanceSetStateButtons Member List

This is the complete list of members for CAppearanceSetStateButtons, including all inherited members.

AdjustClientRect(CXTPTabManager *pTabManager, CRect &rcClient) | CXTPTabPaintManagerTheme | virtual
CAppearanceSetStateButtons() | CAppearanceSetStateButtons | inline
CXTPTabPaintManagerTheme() | CXTPTabPaintManagerTheme |
DrawSingleButton(CDC *pDC, CXTPTabManagerItem *pItem) | CAppearanceSetStateButtons | virtual
DrawTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl) | CXTPTabPaintManagerTheme | virtual
DrawText(CDC *pDC, CXTPTabManager *pManager, const CString &str, LPRECT lpRect, UINT nFormat) | CXTPTabPaintManagerTheme | virtual
DrawWorkspacePart(CDC *pDC, LPRECT lpRect, XTPTabWorkspacePart workspacePart) | CXTPTabPaintManagerTheme | virtual
FillButton(CDC *pDC, CXTPTabManagerItem *pItem, LPPOINT pts, int nCount, XTPTabPosition tabPosition, BOOL bAbsolute=FALSE) | CXTPTabPaintManagerTheme |
FillTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl) | CAppearanceSetStateButtons | virtual
GetButtonDrawRect(const CXTPTabManagerItem *pItem) | CXTPTabPaintManagerTheme | virtual
GetButtonHeight(const CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetButtonLength(CDC *pDC, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerTheme | virtual
GetClientMargin() | CXTPTabPaintManagerTheme | virtual
GetClientRect(CRect rcControl, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetColorSet() const | CXTPTabPaintManagerTheme |
GetDefaultColorSet() | CAppearanceSetStateButtons | inlinevirtual
GetHeaderClipBox(CDC *pDC, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetHeaderHeight(CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme |
GetHeaderMargin() | CXTPTabPaintManagerTheme | virtual
GetHeaderRect(CRect rcControl, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetSupportedColorSets() | CXTPTabPaintManagerTheme | inlinevirtual
m_bButtonsReverseZOrder | CXTPTabPaintManagerTheme | protected
m_nButtonHeight | CXTPTabPaintManagerTheme | protected
m_nRowMargin | CXTPTabPaintManagerTheme |
m_pPaintManager | CXTPTabPaintManagerTheme | protected
m_rcHeaderMargin | CXTPTabPaintManagerTheme |
RefreshMetrics() | CXTPTabPaintManagerTheme | virtual
RepositionTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcClient) | CXTPTabPaintManagerTheme | virtual
~CXTPTabPaintManagerTheme() | CXTPTabPaintManagerTheme | virtual


Toolkit Pro: XTPRibbonBackstageCommand.h Source File

  • Source
  • Ribbon
  • Backstage
XTPRibbonBackstageCommand.h
Go to the documentation of this file.
1
23#if !defined(__XTPRIBBONBACKSTAGECOMMAND_H__)
24# define __XTPRIBBONBACKSTAGECOMMAND_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class _XTP_EXT_CLASS CXTPRibbonBackstageCommand : public CXTPControl
34{
36 DECLARE_XTP_CONTROL(CXTPRibbonBackstageCommand)
38protected:
39 CXTPRibbonBackstageCommand();
40
41protected:
42# ifdef _XTP_COMMANDBARS_ACTIVEX
45 DECLARE_DISPATCH_MAP()
46 DECLARE_INTERFACE_MAP()
47 DECLARE_OLETYPELIB_EX(CXTPRibbonBackstageCommand);
48
50# endif
51 friend class CXTPRibbonBackstageView;
52};
53
54# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
56#endif // !defined(__XTPRIBBONBACKSTAGECOMMAND_H__)
DECLARE_XTP_CONTROL
#define DECLARE_XTP_CONTROL(class_name)
This macro generates the C++ header code necessary for a CXTPControl-derived class that can be serial...
Definition XTPCommandBarsDefines.h:1169
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPControl
CXTPControl is a CXTPCmdTarget derived class.
Definition XTPControl.h:841
CXTPRibbonBackstageView
CXTPRibbonBackstageView is a CDialog derived class used for a Backstage parent frame.
Definition XTPRibbonBackstageView.h:87


Toolkit Pro: XTPThemeDLL.h Source File

  • Source
  • Common
XTPThemeDLL.h
Go to the documentation of this file.
1
22#if !defined(__XTPTHEMEDLL_H__)
24# define __XTPTHEMEDLL_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
41class _XTP_EXT_CLASS CXTPThemeDLL
42{
43 friend class CXTPSingleton<CXTPThemeDLL>;
44
49 CXTPThemeDLL();
50
51public:
56 virtual ~CXTPThemeDLL();
57
70 BOOL Init(HINSTANCE hAppInstance = NULL, LPCTSTR lpszDllPath = NULL);
71
83 BOOL SetHandle(CString strINI);
84
89 void Reset();
90
91private:
102 BOOL LoadThemeDll(CXTPModuleHandle& hModule, LPCTSTR lpszDLLPath, LPCTSTR lpszDllName);
103
104 CXTPModuleHandle m_hOffice2007;
105 CXTPModuleHandle m_hOffice2010;
106 CXTPModuleHandle m_hOffice2013;
107 CXTPModuleHandle m_hOffice2016;
108 CXTPModuleHandle m_hVisualStudio2012;
109 CXTPModuleHandle m_hVisualStudio2015;
110 CXTPModuleHandle m_hVisualStudio2017;
111 CXTPModuleHandle m_hVisualStudio2019;
112 CXTPModuleHandle m_hVisualStudio2022;
113 CXTPModuleHandle m_hWindows7;
114 CXTPModuleHandle m_hWindows10;
115 CXTPModuleHandle m_hWindows11;
117 friend _XTP_EXT_CLASS CXTPThemeDLL* AFX_CDECL XTPThemeDLL();
118};
119
128_XTP_EXT_CLASS CXTPThemeDLL* AFX_CDECL XTPThemeDLL();
129
130# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
132#endif // !defined(__XTPTHEMEDLL_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPThemeDLL
_XTP_EXT_CLASS CXTPThemeDLL *AFX_CDECL XTPThemeDLL()
XTPThemeDLL returns pointer to common CXTPThemeDLL class.
CXTPModuleHandle
CXTPModuleHandle class is helper for LoadLibray/GetModuleHandle methods.
Definition XTPSystemHelpers.h:80
CXTPSingleton
Implements Singleton design pattern.
Definition XTPSingleton.h:215
CXTPThemeDLL
CXTPThemeDLL is a helper class used to load Codejock theme resource DLLs.
Definition XTPThemeDLL.h:42
CXTPThemeDLL::XTPThemeDLL
friend _XTP_EXT_CLASS CXTPThemeDLL *AFX_CDECL XTPThemeDLL()
XTPThemeDLL returns pointer to common CXTPThemeDLL class.
CXTPThemeDLL::~CXTPThemeDLL
virtual ~CXTPThemeDLL()
Destructor, handles cleanup and deallocation.
CXTPThemeDLL::SetHandle
BOOL SetHandle(CString strINI)
Sets the handle to the resource DLL used for Codejock themes.
CXTPThemeDLL::Reset
void Reset()
Resets all properties of ResourceImages.
CXTPThemeDLL::Init
BOOL Init(HINSTANCE hAppInstance=NULL, LPCTSTR lpszDllPath=NULL)
This member function is called to load the style DLL's from the specified path.


Toolkit Pro: Member List

CXTPProgressCtrlThemeOffice2000 Member List

This is the complete list of members for CXTPProgressCtrlThemeOffice2000, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPProgressCtrlPaintManager() | CXTPProgressCtrlPaintManager |
CXTPProgressCtrlThemeOffice2000() | CXTPProgressCtrlThemeOffice2000 |
DeflateRect(XTPPROGRESSDRAWSTRUCT &ds) | CXTPProgressCtrlPaintManager | protectedvirtual
Draw(XTPPROGRESSDRAWSTRUCT &ds) | CXTPProgressCtrlPaintManager | virtual
DrawNcBorders(CDC *pDC, CRect rc) | CXTPProgressCtrlThemeOffice2000 | virtual
DrawText(XTPPROGRESSDRAWSTRUCT &ds) | CXTPProgressCtrlPaintManager | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetBackColor() | CXTPProgressCtrlPaintManager |
GetBarColor() | CXTPProgressCtrlPaintManager |
GetBorderColor() | CXTPProgressCtrlPaintManager |
GetTextColor() | CXTPProgressCtrlPaintManager |
m_bUseWinTheme | CXTPProgressCtrlPaintManager | protected
m_clrBack | CXTPProgressCtrlPaintManager | protected
m_clrBar | CXTPProgressCtrlPaintManager | protected
m_clrBarText | CXTPProgressCtrlPaintManager | protected
m_clrBorder | CXTPProgressCtrlPaintManager | protected
m_clrText | CXTPProgressCtrlPaintManager | protected
m_nTheme | CXTPProgressCtrlPaintManager | protected
m_winTheme | CXTPProgressCtrlPaintManager | protected
RefreshMetrics() | CXTPProgressCtrlPaintManager | virtual
SetBackColor(COLORREF clrNew) | CXTPProgressCtrlPaintManager |
SetBarColor(COLORREF clrNew) | CXTPProgressCtrlPaintManager |
SetBorderColor(COLORREF clrNew) | CXTPProgressCtrlPaintManager |
SetTextColor(COLORREF clrNew) | CXTPProgressCtrlPaintManager |
UseWinThemes(BOOL bUseWinThemes=TRUE) | CXTPProgressCtrlPaintManager |
UsingWinThemes(BOOL bCheckReady=FALSE) | CXTPProgressCtrlPaintManager |
~CXTPProgressCtrlPaintManager() | CXTPProgressCtrlPaintManager | virtual


Toolkit Pro: XTPCalendarController.h Source File

  • Source
  • Calendar
XTPCalendarController.h
Go to the documentation of this file.
1
22#if !defined(_XTPCALENDARCONTROLLER_H__)
23# define _XTPCALENDARCONTROLLER_H__
24
25# if _MSC_VER > 1000
26# pragma once
27# endif // _MSC_VER > 1000
28
29# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
30
31class CXTPDatePickerControl;
32class CXTPCalendarControl;
33class CXTPCalendarResourcesNf;
34class CXTPNotifySink;
35
36struct XTP_DAYITEM_METRICS;
37
53class _XTP_EXT_CLASS CXTPCalendarController : public CXTPCmdTarget
54{
56 DECLARE_DYNCREATE(CXTPCalendarController)
58public:
86 CXTPCalendarController();
87
93 virtual ~CXTPCalendarController();
94
95 // Attributes
96public:
111 virtual void SetCalendar(CXTPCalendarControl* pCalendarCtrl);
112
127 virtual void SetDatePicker(CXTPDatePickerControl* pDatePickerCtrl);
128
143 virtual CXTPCalendarControl* GetCalendar() const;
144
159 virtual CXTPDatePickerControl* GetDatePicker() const;
160
161public:
171 virtual BOOL IsBoldDaysWithEvents() const;
172
187 virtual void SetBoldDaysWithEvents(BOOL bBold);
188
202 virtual BOOL IsBoldDaysOnIdle() const;
203
218 virtual void SetBoldDaysOnIdle(BOOL bBoldDaysOnIdle);
219
234 virtual long GetBoldDaysPerIdleStep() const;
235
249 virtual long GetBoldDaysIdleStepTime_ms() const;
250
264 virtual void SetBoldDaysPerIdleStep(long nDaysPerStep);
265
279 virtual void SetBoldDaysIdleStepTime_ms(long nStepTime_ms);
280
281 // Implementation
282protected:
283 CXTPNotifySink* m_pSink;
284
295 virtual void AdviseToNotifications();
296
305 virtual void SetFirstDayOfWeekToDatePicker();
306
322 // virtual BOOL IsFirstDayOfWeekShifted_FromSun2Mon();
323
339 virtual void OnEvent_CalendarView(XTP_NOTIFY_CODE Event, WPARAM wParam, LPARAM lParam);
340
356 virtual void OnEvent_CalendarOptionsChanged(XTP_NOTIFY_CODE Event, WPARAM wParam,
357 LPARAM lParam);
358
370 virtual void OnEvent_CalendarResourcesChanged(XTP_NOTIFY_CODE Event, WPARAM wParam,
371 LPARAM lParam);
372
383 virtual void OnEvent_CalendarThemeChanged(XTP_NOTIFY_CODE Event, WPARAM wParam, LPARAM lParam);
384
400 virtual void OnEvent_DatePicker(XTP_NOTIFY_CODE Event, WPARAM wParam, LPARAM lParam);
401
417 virtual void OnEvent_DtPickGetItemMetrics(XTP_NOTIFY_CODE Event, WPARAM wParam, LPARAM lParam);
418
419protected:
420 CXTPCalendarControl* m_pCalendarCtrl;
421 CXTPDatePickerControl* m_pDatePickerCtrl;
423 BOOL m_bBoldDaysWithEvents;
425 BOOL m_bUseActiveViewResoucesForBold;
428 BOOL m_bBoldDaysOnIdle;
430 long m_nBoldDaysPerIdleStep;
432 long m_nBoldDaysIdleStepTime_ms;
443 BOOL _HasEvents(COleDateTime dtDay);
444
445private:
446 void _AdviseToDataChanged();
447 void _UnadviseFromDataChanged();
448
449 virtual void OnEvent_CalendarDataChanged(XTP_NOTIFY_CODE Event, WPARAM wParam, LPARAM lParam);
450
451 BOOL m_bAdjustingView;
452
453 CXTPCalendarResourcesNf* m_pResourcesNf;
454 int m_eLastActiveView;
455
456 XTP_CONNECTION_ID m_cnidEventAdded;
457 XTP_CONNECTION_ID m_cnidEventChanged;
458 XTP_CONNECTION_ID m_cnidEventDeleted;
459
460 //
461 class CXTPDayInfoCache
462 {
463 struct XTPDayInfo
464 {
465 BOOL bHasEvents;
466 DATE dtLastAccessTime;
467 };
468 CMap<long, long, XTPDayInfo, XTPDayInfo&> m_mapDaysInfo;
469 CMap<long, long, UINT, UINT> m_mapDaysToRefresh;
470
471 CXTPCalendarController* m_pOwner;
472 UINT_PTR m_uTimerID;
473 DWORD m_dwLastRedrawTime;
474 DWORD m_dwLastSelfClearTime;
475 DWORD m_dwWaitingDataTime;
476
477 UINT m_uActivePriority;
478
479 public:
480 CXTPDayInfoCache();
481 virtual ~CXTPDayInfoCache();
482
483 BOOL HasEvents(DATE dtDay);
484
485 void Init(CXTPCalendarController* pOwner);
486 void Clear();
487
488 void ClearDays(COleDateTime dtDayFrom, COleDateTime dtDayTo);
489 void RequestToRefreshDays(COleDateTime dtDayFrom, COleDateTime dtDayTo);
490
491 UINT UpActivePriority();
492
493 protected:
494 void UpdateDayInfo(DATE dtDay, BOOL bHasEvents);
495 void KillTimer();
496
497 void _RequestToRefreshDays(COleDateTime dtDayFrom, COleDateTime dtDayTo,
498 UINT uPriority = 0);
499
500 void OnRefreshDays(int nDaysCountToRefresh = 1);
501 void OnSelfClearOld();
502
503 static VOID CALLBACK OnTimerCallback(HWND hwnd, UINT uMsg, UINT_PTR idEvent, DWORD dwTime);
504
505 typedef CMap<UINT_PTR, UINT_PTR, CXTPDayInfoCache*, CXTPDayInfoCache*> CXTPMapTimers;
506 static CXTPMapTimers m_mapTimers;
507 };
508 friend class CXTPDayInfoCache;
509
510 CXTPDayInfoCache m_DayInfoCache;
511};
512
514AFX_INLINE BOOL CXTPCalendarController::IsBoldDaysWithEvents() const
515{
516 return m_bBoldDaysWithEvents;
517}
518AFX_INLINE BOOL CXTPCalendarController::IsBoldDaysOnIdle() const
519{
520 return m_bBoldDaysOnIdle;
521}
522AFX_INLINE void CXTPCalendarController::SetBoldDaysOnIdle(BOOL bBoldDaysOnIdle)
523{
524 m_bBoldDaysOnIdle = bBoldDaysOnIdle;
525 m_DayInfoCache.Clear();
526}
527AFX_INLINE long CXTPCalendarController::GetBoldDaysPerIdleStep() const
528{
529 return m_nBoldDaysPerIdleStep;
530}
531AFX_INLINE void CXTPCalendarController::SetBoldDaysPerIdleStep(long nDaysPerStep)
532{
533 m_nBoldDaysPerIdleStep = nDaysPerStep;
534}
535AFX_INLINE long CXTPCalendarController::GetBoldDaysIdleStepTime_ms() const
536{
537 return m_nBoldDaysIdleStepTime_ms;
538}
539AFX_INLINE void CXTPCalendarController::SetBoldDaysIdleStepTime_ms(long nStepTime_ms)
540{
541 m_nBoldDaysIdleStepTime_ms = nStepTime_ms;
542}
543
544# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
545#endif // !defined(_XTPCALENDARCONTROLLER_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCalendarControl
Class CXTPCalendarControl implements the calendar's view interface.
Definition XTPCalendarControl.h:126
CXTPCalendarController
Class CXTPCalendarController provides a connection between a CXTPCalendarControl object and a CXTPDat...
Definition XTPCalendarController.h:54
CXTPCalendarController::m_bUseActiveViewResoucesForBold
BOOL m_bUseActiveViewResoucesForBold
If true - active view resources are used, if FALSE - calendar control Resources are used.
Definition XTPCalendarController.h:425
CXTPCalendarController::m_pDatePickerCtrl
CXTPDatePickerControl * m_pDatePickerCtrl
Pointer to the associated DatePicker control.
Definition XTPCalendarController.h:421
CXTPCalendarController::SetDatePicker
virtual void SetDatePicker(CXTPDatePickerControl *pDatePickerCtrl)
This member function associates a custom date picker control with the controller.
CXTPCalendarController::OnEvent_DtPickGetItemMetrics
virtual void OnEvent_DtPickGetItemMetrics(XTP_NOTIFY_CODE Event, WPARAM wParam, LPARAM lParam)
This member function catches all the events from the associated date picker control.
CXTPCalendarController::OnEvent_CalendarView
virtual void OnEvent_CalendarView(XTP_NOTIFY_CODE Event, WPARAM wParam, LPARAM lParam)
This member function is used to determine if Compressed Weekend Day - Sunday, is used as the first da...
CXTPCalendarController::SetFirstDayOfWeekToDatePicker
virtual void SetFirstDayOfWeekToDatePicker()
This member function gets the first day of week from the calendar control and set the same value to t...
CXTPCalendarController::GetCalendar
virtual CXTPCalendarControl * GetCalendar() const
Gets a calendar control object associated with the controller.
CXTPCalendarController::GetBoldDaysPerIdleStep
virtual long GetBoldDaysPerIdleStep() const
Returns Amount of days for the associated DatePicker to update state in one idle step.
Definition XTPCalendarController.h:527
CXTPCalendarController::SetBoldDaysPerIdleStep
virtual void SetBoldDaysPerIdleStep(long nDaysPerStep)
Set amount of days for the associated DatePicker to update state in one idle step.
Definition XTPCalendarController.h:531
CXTPCalendarController::AdviseToNotifications
virtual void AdviseToNotifications()
This member function subscribes itself for all necessary notifications.
CXTPCalendarController::_HasEvents
BOOL _HasEvents(COleDateTime dtDay)
This member function is used to determine if the specified day has events or not.
CXTPCalendarController::OnEvent_CalendarResourcesChanged
virtual void OnEvent_CalendarResourcesChanged(XTP_NOTIFY_CODE Event, WPARAM wParam, LPARAM lParam)
This member function catches all the events when resource configuration is changed in the CalendarCon...
CXTPCalendarController::m_nBoldDaysIdleStepTime_ms
long m_nBoldDaysIdleStepTime_ms
Time between idle steps to update days state (bold or regular) for the associated DatePicker.
Definition XTPCalendarController.h:432
CXTPCalendarController::OnEvent_CalendarThemeChanged
virtual void OnEvent_CalendarThemeChanged(XTP_NOTIFY_CODE Event, WPARAM wParam, LPARAM lParam)
This member function catches the XTP_NC_CALENDAR_THEME_CHANGED event.
CXTPCalendarController::m_pCalendarCtrl
CXTPCalendarControl * m_pCalendarCtrl
Pointer to the associated Calendar control.
Definition XTPCalendarController.h:420
CXTPCalendarController::IsBoldDaysOnIdle
virtual BOOL IsBoldDaysOnIdle() const
Is BoldDaysOnIdle option enabled or disabled.
Definition XTPCalendarController.h:518
CXTPCalendarController::OnEvent_CalendarOptionsChanged
virtual void OnEvent_CalendarOptionsChanged(XTP_NOTIFY_CODE Event, WPARAM wParam, LPARAM lParam)
This member function catches all the events when calendar control options were changed.
CXTPCalendarController::m_nBoldDaysPerIdleStep
long m_nBoldDaysPerIdleStep
Amount of days for the associated DatePicker to update state in one idle step.
Definition XTPCalendarController.h:430
CXTPCalendarController::SetBoldDaysOnIdle
virtual void SetBoldDaysOnIdle(BOOL bBoldDaysOnIdle)
Enable or Disable retrieve days state (bold or regular) on idle (by timer) for the associated DatePic...
Definition XTPCalendarController.h:522
CXTPCalendarController::SetBoldDaysIdleStepTime_ms
virtual void SetBoldDaysIdleStepTime_ms(long nStepTime_ms)
Set time (in milliseconds) between idle steps to update days state (bold or regular) for the associat...
Definition XTPCalendarController.h:539
CXTPCalendarController::IsBoldDaysWithEvents
virtual BOOL IsBoldDaysWithEvents() const
This member function is used to determine whether Bold font is used for days in DatePicker which have...
Definition XTPCalendarController.h:514
CXTPCalendarController::CXTPCalendarController
CXTPCalendarController()
Constructs a CXTPCalendarController object.
CXTPCalendarController::GetDatePicker
virtual CXTPDatePickerControl * GetDatePicker() const
Gets a date picker control object associated with the controller.
CXTPCalendarController::SetCalendar
virtual void SetCalendar(CXTPCalendarControl *pCalendarCtrl)
This member function associates a custom calendar control with the controller.
CXTPCalendarController::m_bBoldDaysWithEvents
BOOL m_bBoldDaysWithEvents
TRUE to use Bold for days with events in the associated DatePicker.
Definition XTPCalendarController.h:423
CXTPCalendarController::m_bBoldDaysOnIdle
BOOL m_bBoldDaysOnIdle
TRUE to retrieve days state (bold or regular) on idle (by timer) for the associated DatePicker.
Definition XTPCalendarController.h:428
CXTPCalendarController::OnEvent_DatePicker
virtual void OnEvent_DatePicker(XTP_NOTIFY_CODE Event, WPARAM wParam, LPARAM lParam)
This member function catches all the events from the associated date picker control.
CXTPCalendarController::~CXTPCalendarController
virtual ~CXTPCalendarController()
Destroys a CXTPCalendarController object, handles cleanup and deallocation.
CXTPCalendarController::SetBoldDaysWithEvents
virtual void SetBoldDaysWithEvents(BOOL bBold)
This member function enables or disables Bold font usage for displaying days in DatePicker which have...
CXTPCalendarController::GetBoldDaysIdleStepTime_ms
virtual long GetBoldDaysIdleStepTime_ms() const
Returns time between idle steps to update days state (bold or regular) for the associated DatePicker.
Definition XTPCalendarController.h:535
CXTPCalendarResourcesNf
This class implements CXTPCalendarResource functionality with the addition of a notifications mechani...
Definition XTPCalendarResource.h:635
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPDatePickerControl
Class CXTPDatePickerControl encapsulates the functionality of a date and time picker control.
Definition XTPDatePickerControl.h:331
XTP_DAYITEM_METRICS
This structure represents a set of parameters which are used to display day items.
Definition XTPDatePickerControl.h:53


Toolkit Pro: XTPMessageBarThemeVisualStudio2015.h Source File

  • Source
  • CommandBars
  • MessageBar
XTPMessageBarThemeVisualStudio2015.h
Go to the documentation of this file.
1
23#if !defined(__XTPMESSAGEBARTHEMEVISUALSTUDIO2015_H__)
24# define __XTPMESSAGEBARTHEMEVISUALSTUDIO2015_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPPaintManager;
34class CXTPMessageBar;
35class CXTPMessageBarButton;
36
42class _XTP_EXT_CLASS CXTPMessageBarThemeVisualStudio2015 : public CXTPMessageBarThemeOffice2013
43{
44public:
50 CXTPMessageBarThemeVisualStudio2015(CXTPPaintManager* pPaintManager);
51};
52
54# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
55#endif // !defined(__XTPMESSAGEBARTHEMEVISUALSTUDIO2015_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPMessageBarButton
CXTPMessageBarButton is a standalone class.
Definition XTPMessageBar.h:48
CXTPMessageBar
CXTPMessageBar is a CControlBar derived class.
Definition XTPMessageBar.h:88
CXTPMessageBarThemeOffice2013
The CXTPMessageBarThemeOffice2013 class is used by the message bar to draw an Office 2013 style messa...
Definition XTPMessageBarThemeOffice2013.h:43
CXTPMessageBarThemeVisualStudio2015
The CXTPMessageBarThemeVisualStudio2015 class is used by the message bar to draw a Visual Studio 2015...
Definition XTPMessageBarThemeVisualStudio2015.h:43
CXTPMessageBarThemeVisualStudio2015::CXTPMessageBarThemeVisualStudio2015
CXTPMessageBarThemeVisualStudio2015(CXTPPaintManager *pPaintManager)
Message bar constructor.
CXTPPaintManager
Paint manager of the command bars.
Definition XTPPaintManager.h:199


Toolkit Pro: XTPChartDeviceCommand.h Source File

  • Source
  • Chart
  • Drawing
XTPChartDeviceCommand.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTDEVICECOMMAND_H__)
24# define __XTPCHARTDEVICECOMMAND_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartDeviceContext;
34class CXTPChartFont;
35class CXTPChartElement;
36class CXTPChartSeriesStyle;
37class CXTPChartElementView;
38
46class _XTP_EXT_CLASS CXTPChartDeviceCommandEvents
47 : public CXTPTypeIdProvider<CXTPChartDeviceCommandEvents>
48{
49protected:
54 CXTPChartDeviceCommandEvents();
55
56public:
64 virtual void OnBeforeExecute(CXTPChartDeviceCommand* pCommand, CXTPChartDeviceContext* pDC);
65
73 virtual void OnAfterExecute(CXTPChartDeviceCommand* pCommand, CXTPChartDeviceContext* pDC);
74
82 virtual void OnUpdateBounds(CXTPChartDeviceCommand* pCommand, CRect rcBounds);
83
90 void OnUnsubscribe(CXTPChartDeviceCommand* pCommand);
91};
92
97class _XTP_EXT_CLASS CXTPChartDeviceCommand
98 : public CXTPChartObject
99 , public CXTPObservable<CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents>
100{
101 DECLARE_DYNAMIC(CXTPChartDeviceCommand);
102
103public:
108 CXTPChartDeviceCommand();
109
114 virtual ~CXTPChartDeviceCommand();
115
116public:
126 BOOL IsCommitted() const;
127
136 void Commit();
137
147 int GetChildCommandCount() const;
148
162 CXTPChartDeviceCommand* GetChildCommand(int nIndex) const;
163
176 CXTPChartDeviceCommand* AddChildCommand(CXTPChartDeviceCommand* pCommand);
177
188 virtual void Execute(CXTPChartDeviceContext* pDC);
189
197 virtual void BeforeExecute(CXTPChartDeviceContext* pDC);
198
206 virtual void AfterExecute(CXTPChartDeviceContext* pDC);
207
214 virtual void ExecuteOverride(CXTPChartDeviceContext* pDC);
215
222 UINT GetPassNumber() const;
223
234 virtual CXTPChartElement* HitTest(CPoint point, CXTPChartElement* pParent) const;
235
242 virtual void ApplySeriesStyle(CXTPChartSeriesStyle* pStyle);
243
253 virtual void Prepare(CXTPChartDeviceContext* pDC);
254
265 virtual void PrepareOverride(CXTPChartDeviceContext* pDC);
266
276 virtual BOOL IsEnabled() const;
277
284 void SetEnabled(BOOL bEnabled = TRUE);
285
295 CXTPChartDeviceContext* GetCurrentDC() const;
296
305 void BindView(CXTPChartElementView* pView);
306
313 CXTPChartElementView* GetBoundView() const;
314
315protected:
316 CArray<CXTPChartDeviceCommand*, CXTPChartDeviceCommand*> m_arrChildren;
317
318private:
319 BOOL m_bCommitted;
320 UINT m_nPassNumber;
321 BOOL m_bEnabled;
322 CXTPChartDeviceContext* m_pCurrentDC;
323 CXTPChartElementView* m_pBoundView;
324};
325
326AFX_INLINE BOOL CXTPChartDeviceCommand::IsCommitted() const
327{
328 return m_bCommitted;
329}
330AFX_INLINE void CXTPChartDeviceCommand::Commit()
331{
332 _ASSERTE("Must not be committed twice" && !m_bCommitted);
333 m_bCommitted = TRUE;
334}
335
336AFX_INLINE UINT CXTPChartDeviceCommand::GetPassNumber() const
337{
338 return m_nPassNumber;
339}
340
341AFX_INLINE void CXTPChartDeviceCommand::SetEnabled(BOOL bEnabled /*= TRUE*/)
342{
343 m_bEnabled = bEnabled;
344}
345
346AFX_INLINE CXTPChartDeviceContext* CXTPChartDeviceCommand::GetCurrentDC() const
347{
348 return m_pCurrentDC;
349}
350
351AFX_INLINE CXTPChartElementView* CXTPChartDeviceCommand::GetBoundView() const
352{
353 return m_pBoundView;
354}
355
356enum XTPChart3dAntialiasingPolicy
357{
358 xtpChart3dAntialiasingPolicyDefault,
359 xtpChart3dAntialiasingPolicyEnabled,
360 xtpChart3dAntialiasingPolicyDisabled,
361};
362
367class _XTP_EXT_CLASS CXTPChart3dDeviceCommand : public CXTPChartDeviceCommand
368{
369 DECLARE_DYNAMIC(CXTPChart3dDeviceCommand);
370
371protected:
378 CXTPChart3dDeviceCommand(XTPChart3dAntialiasingPolicy nAntialiasingPolicy);
379
380public:
402 virtual BOOL IsEnabled() const;
403
404private:
405 XTPChart3dAntialiasingPolicy m_nAntialiasingPolicy;
406};
407
412class _XTP_EXT_CLASS CXTPChartHitTestElementCommand : public CXTPChartDeviceCommand
413{
414public:
422 CXTPChartHitTestElementCommand(CXTPChartElement* pElement);
423
432 CXTPChartHitTestElementCommand(CXTPChartElement* pElement, const CRect& rcBounds);
433
442 CXTPChartHitTestElementCommand(CXTPChartElement* pElement, const CXTPChartRectF& rcBounds);
443
455 virtual CXTPChartElement* HitTest(CPoint point, CXTPChartElement* pParent) const;
456
457protected:
458 CXTPChartElement* m_pElement;
460 CRect m_rcBounds;
461};
463# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
464#endif //#if !defined(__XTPCHARTDEVICECOMMAND_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChart3dDeviceCommand
Defines a common implementation interface for chart 3D drawing commands.
Definition XTPChartDeviceCommand.h:368
CXTPChart3dDeviceCommand::IsEnabled
virtual BOOL IsEnabled() const
Determines if the command is currently enabled.
CXTPChart3dDeviceCommand::CXTPChart3dDeviceCommand
CXTPChart3dDeviceCommand(XTPChart3dAntialiasingPolicy nAntialiasingPolicy)
Constructs a CXTPChart3dDeviceCommand object.
CXTPChartDeviceCommandEvents
Defines a callback interface for a chart device command event sink.
Definition XTPChartDeviceCommand.h:48
CXTPChartDeviceCommandEvents::OnUnsubscribe
void OnUnsubscribe(CXTPChartDeviceCommand *pCommand)
Invoked when an event sink is to be unsubscribed from command events.
CXTPChartDeviceCommandEvents::CXTPChartDeviceCommandEvents
CXTPChartDeviceCommandEvents()
Constructs an event sink.
CXTPChartDeviceCommandEvents::OnBeforeExecute
virtual void OnBeforeExecute(CXTPChartDeviceCommand *pCommand, CXTPChartDeviceContext *pDC)
Notifies that a command has entered the BeforeExecute step.
CXTPChartDeviceCommandEvents::OnUpdateBounds
virtual void OnUpdateBounds(CXTPChartDeviceCommand *pCommand, CRect rcBounds)
Notifies about updated boundaries for the command result.
CXTPChartDeviceCommandEvents::OnAfterExecute
virtual void OnAfterExecute(CXTPChartDeviceCommand *pCommand, CXTPChartDeviceContext *pDC)
Notifies that a command has entered the AfterExecute step.
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPChartDeviceCommand::GetChildCommand
CXTPChartDeviceCommand * GetChildCommand(int nIndex) const
Obtains immediate child command point by index.
CXTPChartDeviceCommand::IsCommitted
BOOL IsCommitted() const
Determines if the execution of the command has been committed.
Definition XTPChartDeviceCommand.h:326
CXTPChartDeviceCommand::IsEnabled
virtual BOOL IsEnabled() const
Determines if the command is currently enabled.
CXTPChartDeviceCommand::~CXTPChartDeviceCommand
virtual ~CXTPChartDeviceCommand()
Destroys a CXTPChartDeviceCommand object, handles cleanup.
CXTPChartDeviceCommand::GetCurrentDC
CXTPChartDeviceContext * GetCurrentDC() const
Obtains device context pointer for which the command is currenly being prepared or executed.
Definition XTPChartDeviceCommand.h:346
CXTPChartDeviceCommand::GetChildCommandCount
int GetChildCommandCount() const
Obtains the number of immediate children commands.
CXTPChartDeviceCommand::AfterExecute
virtual void AfterExecute(CXTPChartDeviceContext *pDC)
This method gets called after a command is executed which allows for the customization of command beh...
CXTPChartDeviceCommand::ApplySeriesStyle
virtual void ApplySeriesStyle(CXTPChartSeriesStyle *pStyle)
Applies series style to the current element.
CXTPChartDeviceCommand::BindView
void BindView(CXTPChartElementView *pView)
Binds a view to the command object.
CXTPChartDeviceCommand::Prepare
virtual void Prepare(CXTPChartDeviceContext *pDC)
Performs inital preparation steps necessary for successful command execution.
CXTPChartDeviceCommand::m_arrChildren
CArray< CXTPChartDeviceCommand *, CXTPChartDeviceCommand * > m_arrChildren
< The array of child device commands.
Definition XTPChartDeviceCommand.h:316
CXTPChartDeviceCommand::Commit
void Commit()
Commits the execution of the command.
Definition XTPChartDeviceCommand.h:330
CXTPChartDeviceCommand::BeforeExecute
virtual void BeforeExecute(CXTPChartDeviceContext *pDC)
This method gets called before a command is executed which allows for the customization of command be...
CXTPChartDeviceCommand::PrepareOverride
virtual void PrepareOverride(CXTPChartDeviceContext *pDC)
Derived implementation must override this method for implementing implementation specific preparation...
CXTPChartDeviceCommand::SetEnabled
void SetEnabled(BOOL bEnabled=TRUE)
Enables/disable the command.
Definition XTPChartDeviceCommand.h:341
CXTPChartDeviceCommand::GetBoundView
CXTPChartElementView * GetBoundView() const
Obtains a bound view pointer or NULL if no view is bound.
Definition XTPChartDeviceCommand.h:351
CXTPChartDeviceCommand::HitTest
virtual CXTPChartElement * HitTest(CPoint point, CXTPChartElement *pParent) const
Performs recursive hit testing of the element at the specified point.
CXTPChartDeviceCommand::Execute
virtual void Execute(CXTPChartDeviceContext *pDC)
Call this function to execute the drawing.
CXTPChartDeviceCommand::ExecuteOverride
virtual void ExecuteOverride(CXTPChartDeviceContext *pDC)
Override this function to write the drawing code for specific objects.
CXTPChartDeviceCommand::CXTPChartDeviceCommand
CXTPChartDeviceCommand()
Constructs a CXTPChartDeviceCommand object.
CXTPChartDeviceCommand::AddChildCommand
CXTPChartDeviceCommand * AddChildCommand(CXTPChartDeviceCommand *pCommand)
Call this function to add a child device command.
CXTPChartDeviceCommand::GetPassNumber
UINT GetPassNumber() const
Get the number of executions made by the command.
Definition XTPChartDeviceCommand.h:336
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartElement
This class abstracts a chart element, this class acts as a base class for all chart elements.
Definition XTPChartElement.h:131
CXTPChartElementView
This class represents the view of a chart element.
Definition XTPChartElementView.h:47
CXTPChartFont
This class abstracts a font entity.
Definition XTPChartTypes.h:540
CXTPChartHitTestElementCommand
Defines a base class interface for a 2D hit test command.
Definition XTPChartDeviceCommand.h:413
CXTPChartHitTestElementCommand::CXTPChartHitTestElementCommand
CXTPChartHitTestElementCommand(CXTPChartElement *pElement)
Constructs a CXTPChartHitTestElementCommand object instance.
CXTPChartHitTestElementCommand::CXTPChartHitTestElementCommand
CXTPChartHitTestElementCommand(CXTPChartElement *pElement, const CXTPChartRectF &rcBounds)
Constructs a CXTPChartHitTestElementCommand object instance.
CXTPChartHitTestElementCommand::HitTest
virtual CXTPChartElement * HitTest(CPoint point, CXTPChartElement *pParent) const
Performs recursive hit testing of the element at the specified point.
CXTPChartHitTestElementCommand::m_rcBounds
CRect m_rcBounds
Hit test boundary rectangle.
Definition XTPChartDeviceCommand.h:460
CXTPChartHitTestElementCommand::m_pElement
CXTPChartElement * m_pElement
Chart element pointer for which hit testing is to be performed.
Definition XTPChartDeviceCommand.h:458
CXTPChartHitTestElementCommand::CXTPChartHitTestElementCommand
CXTPChartHitTestElementCommand(CXTPChartElement *pElement, const CRect &rcBounds)
Constructs a CXTPChartHitTestElementCommand object instance.
CXTPChartObject
A base class for all chart objects.
Definition XTPChartElement.h:61
CXTPChartSeriesStyle
CXTPChartSeriesStyle is a CXTPChartElement derived class.
Definition XTPChartSeriesStyle.h:49
CXTPObservable
Provides a basic implementation of the Observable design pattern.
Definition XTPSystemHelpers.h:2138
CXTPRectT< float >


Toolkit Pro: XTPProgressThemeNativeWindows11.h Source File

  • Source
  • CommandBars
  • Progress
XTPProgressThemeNativeWindows11.h
Go to the documentation of this file.
1
23#if !defined(__XTPPROGRESSTHEMENATIVEWINDOWS11_H__)
24# define __XTPPROGRESSTHEMENATIVEWINDOWS11_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPProgressBase;
34class CXTPPaintManager;
35
40class _XTP_EXT_CLASS CXTPProgressThemeNativeWindows11 : public CXTPProgressThemeOffice2013
41{
42public:
48 CXTPProgressThemeNativeWindows11(CXTPPaintManager* pPaintManager);
49
55 virtual ~CXTPProgressThemeNativeWindows11();
56};
57
59# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
60#endif // !defined(__XTPPROGRESSTHEMENATIVEWINDOWS11_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPPaintManager
Paint manager of the command bars.
Definition XTPPaintManager.h:199
CXTPProgressBase
CXTPControlProgressBase is base class for all progress objects.
Definition XTPProgressBase.h:40
CXTPProgressThemeNativeWindows11
CXTPProgressThemeNativeWindows11 object.
Definition XTPProgressThemeNativeWindows11.h:41
CXTPProgressThemeNativeWindows11::CXTPProgressThemeNativeWindows11
CXTPProgressThemeNativeWindows11(CXTPPaintManager *pPaintManager)
Constructs a CXTPProgressThemeNativeWindows11 object.
CXTPProgressThemeNativeWindows11::~CXTPProgressThemeNativeWindows11
virtual ~CXTPProgressThemeNativeWindows11()
Destroys a CXTPProgressThemeNativeWindows11 object, handles cleanup and deallocation.
CXTPProgressThemeOffice2013
CXTPProgressThemeOffice2013 object.
Definition XTPProgressThemeOffice2013.h:41


Toolkit Pro: XTPDockingPaneTabTheme2013.h Source File

  • Source
  • DockingPane
  • TabThemes
XTPDockingPaneTabTheme2013.h
Go to the documentation of this file.
1
23#if !defined(__XTPDOCKINGPANETABTHEME2013_H__)
24# define __XTPDOCKINGPANETABTHEME2013_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPDockingPaneTabTheme2013 : public CXTPTabThemeFlat
39{
40public:
45 CXTPDockingPaneTabTheme2013();
46
52 virtual void RefreshMetrics();
53
70 virtual void DrawSingleButton(CDC* pDC, CXTPTabManagerItem* pItem);
71};
72
73# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
75#endif // !defined(__XTPDOCKINGPANETABTHEME2013_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPDockingPaneTabTheme2013
Helper class used to initialize default colors for a theme from an .INI resource and handle drawing r...
Definition XTPDockingPaneTabTheme2013.h:39
CXTPDockingPaneTabTheme2013::DrawSingleButton
virtual void DrawSingleButton(CDC *pDC, CXTPTabManagerItem *pItem)
This method is called to draw a single tab button in the tab client header area.
CXTPDockingPaneTabTheme2013::RefreshMetrics
virtual void RefreshMetrics()
This member function is used to initialize default colors for a theme from an .INI resource.
CXTPDockingPaneTabTheme2013::CXTPDockingPaneTabTheme2013
CXTPDockingPaneTabTheme2013()
Default class constructor.
CXTPTabManagerItem
CXTPTabManagerItem is the base class for the tabs that appear in the command bars tab workspace,...
Definition XTPTabManagerItem.h:44
CXTPTabThemeFlat
CXTPTabThemeFlat implements a "Flat" tab appearance.
Definition XTPTabThemeFlat.h:49


Toolkit Pro: Member List

CXTPShortcutBarPane Member List

This is the complete list of members for CXTPShortcutBarPane, including all inherited members.

AddItem(LPCTSTR lpszCaption, CWnd *pWnd, int nHeight) | CXTPShortcutBarPane |
Create(LPCTSTR lpszCaption, CXTPShortcutBar *pParent) | CXTPShortcutBarPane |
CXTPShortcutBarPane() | CXTPShortcutBarPane |
GetCaption() const | CXTPShortcutBarPane |
GetItem(int nIndex) const | CXTPShortcutBarPane |
GetMinimumClientHeight() const | CXTPShortcutBarPane | virtual
HitTest(CPoint point) const | CXTPShortcutBarPane |
m_arrItems | CXTPShortcutBarPane | protected
m_bShowCaption | CXTPShortcutBarPane | protected
m_hHandCursor | CXTPShortcutBarPane | protected
m_nMinClientHeight | CXTPShortcutBarPane | protected
m_pHighlighted | CXTPShortcutBarPane | protected
m_pShortcutBar | CXTPShortcutBarPane | protected
m_rcIndent | CXTPShortcutBarPane | protected
m_strCaption | CXTPShortcutBarPane | protected
RecalcLayout() | CXTPShortcutBarPane |
SetCaption(LPCTSTR lpszCaption) | CXTPShortcutBarPane |
SetIndent(int left, int top, int right, int bottom) | CXTPShortcutBarPane |
SetMinimumClientHeight(int nMinHeight) | CXTPShortcutBarPane |
ShowCaption(BOOL bShowCaption) | CXTPShortcutBarPane |
~CXTPShortcutBarPane() | CXTPShortcutBarPane | virtual


Toolkit Pro: Member List

  • CXTPShortcutListBox
  • CONTENT_ITEM
CXTPShortcutListBox::CONTENT_ITEM Member List

This is the complete list of members for CXTPShortcutListBox::CONTENT_ITEM, including all inherited members.

m_bEnabled | CXTPShortcutListBox::CONTENT_ITEM
m_nIndex | CXTPShortcutListBox::CONTENT_ITEM
m_pIcon | CXTPShortcutListBox::CONTENT_ITEM
m_strText | CXTPShortcutListBox::CONTENT_ITEM


Toolkit Pro: XTPDatePickerOffice2003Theme.h Source File

  • Source
  • Calendar
  • DatePicker
  • Themes
XTPDatePickerOffice2003Theme.h
Go to the documentation of this file.
1
22#if !defined(_XTPDATEPICKEROFFICE2003THEME_H__)
23# define _XTPDATEPICKEROFFICE2003THEME_H__
24
25# if _MSC_VER > 1000
26# pragma once
27# endif // _MSC_VER > 1000
28
29# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
30
51class _XTP_EXT_CLASS CXTPDatePickerThemeOffice2003 : public CXTPDatePickerPaintManager
52{
53public:
62 CXTPDatePickerThemeOffice2003();
63
70 virtual ~CXTPDatePickerThemeOffice2003();
71
72public:
81 virtual void RefreshMetrics();
82
109 virtual void DrawButton(CDC* pDC, const CRect& rcButton, const CString& strButton, BOOL bIsDown,
110 BOOL bIsHighLight);
111};
112
113# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
114#endif // !defined(_XTPDATEPICKEROFFICE2003THEME_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPDatePickerPaintManager
Class CXTPDatePickerPaintManager handles most of the drawing activities for the DatePicker control.
Definition XTPDatePickerPaintManager.h:55
CXTPDatePickerThemeOffice2003
Class CXTPDatePickerThemeOffice2003 is derived from CXTPDatePickerPaintManager for rendering an Offic...
Definition XTPDatePickerOffice2003Theme.h:52
CXTPDatePickerThemeOffice2003::CXTPDatePickerThemeOffice2003
CXTPDatePickerThemeOffice2003()
Default paint manager constructor.
CXTPDatePickerThemeOffice2003::~CXTPDatePickerThemeOffice2003
virtual ~CXTPDatePickerThemeOffice2003()
Default paint manager destructor.
CXTPDatePickerThemeOffice2003::RefreshMetrics
virtual void RefreshMetrics()
This member function performs initialization for the Paint Manager.
CXTPDatePickerThemeOffice2003::DrawButton
virtual void DrawButton(CDC *pDC, const CRect &rcButton, const CString &strButton, BOOL bIsDown, BOOL bIsHighLight)
This member function is used to draw the control's buttons.


Toolkit Pro: XTPMarkupStyle.h Source File

  • Source
  • Markup
XTPMarkupStyle.h
Go to the documentation of this file.
1
23#if !defined(__XTPMARKUPSTYLE_H__)
24# define __XTPMARKUPSTYLE_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPMarkupObject;
34class CXTPMarkupBuilder;
35class CXTPMarkupTrigger;
36class CXTPMarkupTriggerCollection;
37class CXTPMarkupSetterCollection;
38class CXTPMarkupDependencyProperty;
39
40class _XTP_EXT_CLASS CXTPMarkupStyle : public CXTPMarkupObject
41{
43 DECLARE_MARKUPCLASS(CXTPMarkupStyle);
45public:
46 CXTPMarkupStyle();
47 virtual ~CXTPMarkupStyle();
48
49public:
50 void Seal();
51
52 CXTPMarkupSetterCollection* GetSetters() const;
53 CXTPMarkupTriggerCollection* GetTriggers() const;
54 void SetTriggers(CXTPMarkupTriggerCollection* pTriggers);
55
56 CXTPMarkupStyle* GetBasedStyle() const;
57 void SetBasedStyle(CXTPMarkupStyle* pStyle);
58
59 CXTPMarkupObject* GetStyleValue(CXTPMarkupDependencyProperty* pProperty) const;
60
61 CXTPMarkupObject* FindResource(const CXTPMarkupObject* pKey) const;
62
63protected:
64 void SetContentObject(CXTPMarkupBuilder* pBuilder, CXTPMarkupObject* pContent);
65 void ResolveSetterProperty(CXTPMarkupBuilder* pBuilder, CXTPMarkupObject* pSetter);
66 void ResolveTriggerProperty(CXTPMarkupBuilder* pBuilder, CXTPMarkupTrigger* pTrigger);
67 void SetPropertyObject(CXTPMarkupBuilder* pBuilder, CXTPMarkupDependencyProperty* pProperty,
68 CXTPMarkupObject* pValue);
69
70protected:
71 CXTPMarkupSetterCollection* m_pSetters;
72 BOOL m_bSealed;
73 CXTPMarkupProperties* m_pProperties;
74
75public:
76 static CXTPMarkupDependencyProperty* m_pTargetTypeProperty;
77 static CXTPMarkupDependencyProperty* m_pBasedOnProperty;
78 static CXTPMarkupDependencyProperty* m_pResourcesProperty;
79 static CXTPMarkupDependencyProperty* m_pTriggersProperty;
80};
81
82# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
84#endif // !defined(__XTPMARKUPSTYLE_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h


Toolkit Pro: XTPRibbonThemeVisualStudio2017.h Source File

  • Source
  • Ribbon
  • Themes
XTPRibbonThemeVisualStudio2017.h
Go to the documentation of this file.
1
23#if !defined(__XTPRIBBONVISUALSTUDIO2017THEME_H__)
24# define __XTPRIBBONVISUALSTUDIO2017THEME_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPRibbonThemeVisualStudio2017 : public CXTPRibbonOffice2013Theme
39{
40public:
46 CXTPRibbonThemeVisualStudio2017(CXTPPaintManager* pPaintManager);
47
52 virtual ~CXTPRibbonThemeVisualStudio2017();
53};
54
55# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
57#endif // !defined(__XTPRIBBONVISUALSTUDIO2017THEME_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPPaintManager
Paint manager of the command bars.
Definition XTPPaintManager.h:199
CXTPRibbonOffice2013Theme
CXTPRibbonOffice2013Theme is a CXTPRibbonMarkupTheme derived class used to represent an Office 2013 r...
Definition XTPRibbonThemeOffice2013.h:50
CXTPRibbonThemeVisualStudio2017
CXTPRibbonThemeVisualStudio2017 is a CXTPRibbonOffice2013Theme derived class used to represent a Visu...
Definition XTPRibbonThemeVisualStudio2017.h:39
CXTPRibbonThemeVisualStudio2017::~CXTPRibbonThemeVisualStudio2017
virtual ~CXTPRibbonThemeVisualStudio2017()
Destroys a CXTPRibbonThemeVisualStudio2017 object, handles cleanup and deallocation.
CXTPRibbonThemeVisualStudio2017::CXTPRibbonThemeVisualStudio2017
CXTPRibbonThemeVisualStudio2017(CXTPPaintManager *pPaintManager)
Constructs a CXTPRibbonThemeVisualStudio2017 object.


Toolkit Pro: Member List

CXTPSplitterWndEx Member List

This is the complete list of members for CXTPSplitterWndEx, including all inherited members.

CreateScrollBarCtrl(DWORD dwStyle, UINT nID) | CXTPScrollBarContainer< CSplitterWnd > | inline
CXTPScrollBarContainer() | CXTPScrollBarContainer< CSplitterWnd > | inlineprotected
CXTPSplitterWnd() | CXTPSplitterWnd |
CXTPSplitterWndEx() | CXTPSplitterWndEx |
EnableBorder(BOOL bBorder) | CXTPSplitterWnd |
EnableDotTracker(BOOL bEnable) | CXTPSplitterWnd |
EnableFullDrag(int nFullDrag) | CXTPSplitterWnd |
EnableNoSize(BOOL bEnable) | CXTPSplitterWnd |
EnableScrollBar(int nSBFlags, UINT nArrowFlags=ESB_ENABLE_BOTH) | CXTPScrollBarContainer< CSplitterWnd > | inline
FullDragWindows() const | CXTPSplitterWnd |
GetHiddenColIndex() const | CXTPSplitterWnd |
GetHiddenRowIndex() const | CXTPSplitterWnd |
GetInsideRect(CRect &rect) const | CXTPSplitterWndEx | protectedvirtual
GetScrollBarCtrl(int nBar) const | CXTPScrollBarContainer< CSplitterWnd > | inlinevirtual
GetTheme() const | CXTPSplitterWnd |
HideColumn(int nColHide) | CXTPSplitterWnd | virtual
HideRow(int nRowHide) | CXTPSplitterWnd | virtual
IsBorderVisible() const | CXTPSplitterWnd |
m_bClipStyles | CXTPSplitterWnd | protected
m_bDotTracker | CXTPSplitterWnd | protected
m_bFullDrag | CXTPSplitterWnd | protected
m_bNoSize | CXTPSplitterWnd | protected
m_bShowBorder | CXTPSplitterWnd | protected
m_bShowTopBorder | CXTPSplitterWndEx | protected
m_bSubclassed | CXTPSplitterWnd | protected
m_cyTopBorderGap | CXTPSplitterWndEx | protected
m_nFullDrag | CXTPSplitterWnd | protected
m_nHiddenCol | CXTPSplitterWnd | protected
m_nHiddenRow | CXTPSplitterWnd | protected
m_point | CXTPSplitterWnd | protected
m_pTheme | CXTPSplitterWnd | protected
OnDrawSplitter(CDC *pDC, ESplitType nType, const CRect &rectArg) | CXTPSplitterWndEx | virtual
OptimizeChildrenClipping() | CXTPScrollBarContainer< CSplitterWnd > | inline
PrintClient(CDC *pDC) | CXTPSplitterWnd | protected
RecalcLayout() | CXTPSplitterWndEx | virtual
RefreshMetrics() | CXTPSplitterWnd | protectedvirtual
RefreshScrollBarMetrics() | CXTPScrollBarContainer< CSplitterWnd > | inline
ReplaceView(int nRow, int nCol, CView *pNewView) | CXTPSplitterWnd | virtual
ReplaceView(int nRow, int nCol, CRuntimeClass *pViewClass) | CXTPSplitterWnd | virtual
SetActivePane(int row, int col, CWnd *pWnd=NULL) | CXTPSplitterWnd | virtual
SetScrollBarClass(CRuntimeClass *pClass=NULL) | CXTPScrollBarContainer< CSplitterWnd > | inline
SetScrollBarTheme(XTPScrollBarTheme theme) | CXTPScrollBarContainer< CSplitterWnd > | inline
SetTheme(XTPControlTheme eTheme) | CXTPSplitterWnd |
SetTheme(CXTPSplitterWndTheme *pTheme) | CXTPSplitterWnd |
ShowColumn() | CXTPSplitterWnd | virtual
ShowRow() | CXTPSplitterWnd | virtual
ShowScrollBar(UINT nBar, BOOL bShow=TRUE) | CXTPScrollBarContainer< CSplitterWnd > | inline
ShowTopBorder(bool bShowTopBorder=true, int cyTopBorderGap=7) | CXTPSplitterWndEx | virtual
SwitchView(int nRow, int nCol, CView *pNewView) | CXTPSplitterWnd | virtual
~CXTPSplitterWnd() | CXTPSplitterWnd | virtual
~CXTPSplitterWndEx() | CXTPSplitterWndEx | virtual


Toolkit Pro: XTPHeaderCtrl.h Source File

  • Source
  • Controls
  • Header
XTPHeaderCtrl.h
Go to the documentation of this file.
1
23#if !defined(__XTHEADERCTRL_H__)
24# define __XTHEADERCTRL_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPImageManager;
34class CXTPHeaderCtrlTheme;
35
55class _XTP_EXT_CLASS CXTPHeaderCtrl : public CHeaderCtrl
56{
58 DECLARE_DYNAMIC(CXTPHeaderCtrl)
60public:
65 CXTPHeaderCtrl();
66
71 virtual ~CXTPHeaderCtrl();
72
73public:
81 void EnableAutoSize(bool bEnable = true);
82
89 void FreezeColumn(int iCol);
90
98 void ThawColumn(int iCol);
99
106 void ThawAllColumns();
107
116 bool IsColFrozen(int iCol);
117
125 void SetMinSize(int iMinSize);
126
135 int SetSortImage(int iSortCol, BOOL bSortAsc);
136
145 int GetSortedCol(BOOL* pbSortAsc = NULL);
146
163 void SetBitmap(int iCol, UINT uBitmapID, DWORD dwRemove = NULL);
164
184 void SetBitmap(int iCol, UINT uBitmapID, BOOL bRemove, COLORREF crMask);
185
194 virtual BOOL ItemPressed(int iItem);
195
203 virtual void OnThemeChanged();
204
212 BOOL IsThemeValid() const;
213
250 int HitTest(CPoint pt, UINT* pFlags = NULL) const;
251
259 BOOL RecalcLayout();
260
267 virtual void InitializeHeader(BOOL bBoldFont);
268
276 virtual void SetMenuID(UINT popupMenuID, int nPos = 0);
277
283 virtual void SetFontBold(BOOL bBoldFont = TRUE);
284
290 virtual void ShowSortArrow(BOOL bSortArrow);
291
300 virtual BOOL SetAlingment(int nFlag);
301
309 BOOL GetAscending() const;
310
317 void EnablePopupMenus(BOOL bEnableMenus);
318
326 BOOL HasSortArrow();
327
333 void ResizeColumnsToFit();
334
342 CXTPImageManager* GetImageManager() const;
343
350 void SetImageManager(CXTPImageManager* pImageManager);
351
365 BOOL SetTheme(XTPControlTheme eTheme);
366
373 BOOL SetTheme(CXTPHeaderCtrlTheme* pTheme);
381 CXTPHeaderCtrlTheme* GetTheme();
382
393 BOOL IsDpiBitmapScalingEnabled() const;
394
404 void EnableDpiBitmapScaling(BOOL bEnable = TRUE);
405
406protected:
415 virtual bool DetermineRTL();
416
423 virtual void ApplyFieldWidths(int iNewWidth);
424
433 virtual void FitFieldWidths(int iNewWidth);
434
442 virtual int GetFrozenColWidth();
443
450 void SendNotify(int iIndex);
451
456 virtual void RefreshMetrics();
457
459 //{{AFX_VIRTUAL(CXTPHeaderCtrl)
460 virtual BOOL OnWndMsg(UINT message, WPARAM wParam, LPARAM lParam, LRESULT* pResult);
461 //}}AFX_VIRTUAL
464protected:
466 DECLARE_MESSAGE_MAP()
467
468 //{{AFX_MSG(CXTPHeaderCtrl)
469 afx_msg void OnWindowPosChanging(WINDOWPOS FAR* lpwndpos);
470 afx_msg BOOL OnSetCursor(CWnd* pWnd, UINT nHitTest, UINT message);
471 afx_msg void OnPaint();
472 afx_msg LRESULT OnPrintClient(WPARAM wParam, LPARAM /*lParam*/);
473 afx_msg BOOL OnEraseBkgnd(CDC* pDC);
474 afx_msg void OnLButtonDown(UINT nFlags, CPoint point);
475 afx_msg void OnLButtonUp(UINT nFlags, CPoint point);
476 afx_msg void OnMouseMove(UINT nFlags, CPoint point);
477 afx_msg void OnTimer(UINT_PTR nIDEvent);
478 afx_msg LRESULT OnLayout(WPARAM wparam, LPARAM lparam);
479 afx_msg void OnDestroy();
480 afx_msg BOOL OnItemchanging(NMHDR* pNMHDR, LRESULT* pResult);
481 afx_msg void OnRButtonDown(UINT nFlags, CPoint point);
482 afx_msg void OnSortAsc();
483 afx_msg void OnSortDsc();
484 afx_msg void OnAlignLeft();
485 afx_msg void OnAlignCenter();
486 afx_msg void OnAlignRight();
487 //}}AFX_MSG
488 afx_msg LRESULT OnSetTheme(WPARAM wParam, LPARAM lParam);
491protected:
492 int m_iMinSize;
493 int m_nPos;
494 int m_iOverIndex;
495 int m_nSortedCol;
496 bool m_bRTL;
498 bool m_bAutoSize;
499 BOOL m_bEnableMenus;
500 BOOL m_bAscending;
501 BOOL m_bLBtnDown;
502 BOOL m_bPainted;
503 UINT m_popupMenuID;
504 CPoint m_pt;
505 CList<int, int&> m_arFrozenCols;
506 CXTPHeaderCtrlTheme* m_pTheme;
507 CXTPImageManager* m_pImageManager;
509 BOOL m_bDpiBitmapScaling;
510 BOOL m_bDpiBitmapScalingModified;
512 friend class CXTPHeaderCtrlTheme;
513};
514
516
517AFX_INLINE BOOL CXTPHeaderCtrl::GetAscending() const
518{
519 _ASSERTE(::IsWindow(m_hWnd));
520 return m_bAscending;
521}
522AFX_INLINE void CXTPHeaderCtrl::EnablePopupMenus(BOOL bEnableMenus)
523{
524 m_bEnableMenus = bEnableMenus;
525}
526AFX_INLINE CXTPImageManager* CXTPHeaderCtrl::GetImageManager() const
527{
528 return m_pImageManager;
529}
530AFX_INLINE CXTPHeaderCtrlTheme* CXTPHeaderCtrl::GetTheme()
531{
532 return m_pTheme;
533}
535# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
537#endif // #if !defined(__XTHEADERCTRL_H__)
XTPControlTheme
XTPControlTheme
Enumeration used to determine the active theme style.
Definition XTPControlTheme.h:43
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPHeaderCtrl
CXTPHeaderCtrl is a CHeaderCtrl derived class.
Definition XTPHeaderCtrl.h:56
CXTPHeaderCtrl::EnablePopupMenus
void EnablePopupMenus(BOOL bEnableMenus)
Call this member function to enable/disable the pop-up menu display whenever a user right clicks on t...
CXTPHeaderCtrl::FitFieldWidths
virtual void FitFieldWidths(int iNewWidth)
This member function is used by the header control to determine the new width for auto-sized columns ...
CXTPHeaderCtrl::OnThemeChanged
virtual void OnThemeChanged()
This member function is called whenever the theme has changed.
CXTPHeaderCtrl::SetMinSize
void SetMinSize(int iMinSize)
Call this member to set the minimum size for auto-sizing columns.
CXTPHeaderCtrl::GetAscending
BOOL GetAscending() const
Call this member function to determine if the current sorting order is ascending.
CXTPHeaderCtrl::SetAlingment
virtual BOOL SetAlingment(int nFlag)
Call this member function to set the text justification for the header control.
CXTPHeaderCtrl::IsColFrozen
bool IsColFrozen(int iCol)
Call this member function to determine if a specified column is frozen.
CXTPHeaderCtrl::ApplyFieldWidths
virtual void ApplyFieldWidths(int iNewWidth)
This member function is used by the header control to auto-size the columns for the list control.
CXTPHeaderCtrl::SetSortImage
int SetSortImage(int iSortCol, BOOL bSortAsc)
This member function will set the sort image for the specified column.
CXTPHeaderCtrl::DetermineRTL
virtual bool DetermineRTL()
This member function is used by the header control to determine the text alignment for the system loc...
CXTPHeaderCtrl::IsDpiBitmapScalingEnabled
BOOL IsDpiBitmapScalingEnabled() const
Gets DPI bitmap scaling flag.
CXTPHeaderCtrl::CXTPHeaderCtrl
CXTPHeaderCtrl()
Constructs a CXTPHeaderCtrl object.
CXTPHeaderCtrl::HasSortArrow
BOOL HasSortArrow()
Call this member function to determine if the header control displays a sort arrow.
CXTPHeaderCtrl::FreezeColumn
void FreezeColumn(int iCol)
Call this member function to freeze a column in the header control.
CXTPHeaderCtrl::SetTheme
BOOL SetTheme(XTPControlTheme eTheme)
Call this member to change the visual theme of the control.
CXTPHeaderCtrl::EnableDpiBitmapScaling
void EnableDpiBitmapScaling(BOOL bEnable=TRUE)
Sets DPI bitmap scaling flag.
CXTPHeaderCtrl::ItemPressed
virtual BOOL ItemPressed(int iItem)
Call this member function to determine if the specified header item is pressed (selected).
CXTPHeaderCtrl::ThawColumn
void ThawColumn(int iCol)
Call this member function to thaw a column in the header control.
CXTPHeaderCtrl::ShowSortArrow
virtual void ShowSortArrow(BOOL bSortArrow)
Call this member function to enable/disable the column sort arrow.
CXTPHeaderCtrl::SetFontBold
virtual void SetFontBold(BOOL bBoldFont=TRUE)
This member function can be used to toggle the font from bold to normal.
CXTPHeaderCtrl::ResizeColumnsToFit
void ResizeColumnsToFit()
Call this member function to resize all header columns equally to fit the available client area.
CXTPHeaderCtrl::IsThemeValid
BOOL IsThemeValid() const
This member function is called to check if the header control is using a theme.
CXTPHeaderCtrl::GetTheme
CXTPHeaderCtrlTheme * GetTheme()
Call this member function to get a pointer to the currently selected theme.
CXTPHeaderCtrl::SetBitmap
void SetBitmap(int iCol, UINT uBitmapID, DWORD dwRemove=NULL)
Call this member function to set the bitmap image for the specified header item.
CXTPHeaderCtrl::EnableAutoSize
void EnableAutoSize(bool bEnable=true)
Call this member function to enable auto-sizing for the header control.
CXTPHeaderCtrl::HitTest
int HitTest(CPoint pt, UINT *pFlags=NULL) const
Tests a point to determine which header item, if any, is at the specified point.
CXTPHeaderCtrl::GetImageManager
CXTPImageManager * GetImageManager() const
Retrieves the image manager associated with the header.
CXTPHeaderCtrl::~CXTPHeaderCtrl
virtual ~CXTPHeaderCtrl()
Destroys a CXTPHeaderCtrl object, handles cleanup and deallocation.
CXTPHeaderCtrl::SetMenuID
virtual void SetMenuID(UINT popupMenuID, int nPos=0)
This member function is called to associate a menu and toolbar resource with the context menu.
CXTPHeaderCtrl::RecalcLayout
BOOL RecalcLayout()
Called by the header control to recalculate the size and layout for the header control and header ite...
CXTPHeaderCtrl::SendNotify
void SendNotify(int iIndex)
Called to send WM_NOTIFY to tell the parent's owner that a column needs to be sorted.
CXTPHeaderCtrl::GetFrozenColWidth
virtual int GetFrozenColWidth()
This member function is used by the header control to determine the total width of all frozen columns...
CXTPHeaderCtrl::GetSortedCol
int GetSortedCol(BOOL *pbSortAsc=NULL)
Call this member function to return the index to the currently sorted column.
CXTPHeaderCtrl::SetBitmap
void SetBitmap(int iCol, UINT uBitmapID, BOOL bRemove, COLORREF crMask)
Call this member function to set the bitmap image for the specified header item.
CXTPHeaderCtrl::RefreshMetrics
virtual void RefreshMetrics()
Call this member function to refresh theme colors and redraw the control.
CXTPHeaderCtrl::ThawAllColumns
void ThawAllColumns()
Call this member function to thaw all columns in the header control.
CXTPHeaderCtrl::InitializeHeader
virtual void InitializeHeader(BOOL bBoldFont)
This member function must be called after creation to initialize the font that the header will use.
CXTPHeaderCtrl::SetTheme
BOOL SetTheme(CXTPHeaderCtrlTheme *pTheme)
Call this member to change the visual theme of the control.
CXTPHeaderCtrl::SetImageManager
void SetImageManager(CXTPImageManager *pImageManager)
Call this method to assign a new image manager.
CXTPHeaderCtrlTheme
CXTPHeaderCtrlTheme is a theme class used to draw a Windows classic style theme for the header contro...
Definition XTPHeaderCtrlTheme.h:51
CXTPImageManager
CXTPImageManager is a standalone class.
Definition XTPImageManager.h:1898


Toolkit Pro: XTPChartElement.h Source File

  • Source
  • Chart
XTPChartElement.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTELEMENT_H__)
24# define __XTPCHARTELEMENT_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartFont;
34class CXTPChartContent;
35class CXTPChartElementView;
36class CXTPPropExchange;
37class CXTPChartDeviceContext;
38class CXTPChartDeviceCommand;
39class CXTPChartAppearance;
44enum XTPChartUpdateOptions
45{
46 xtpChartUpdateView = 1,
47 xtpChartUpdateLayout = 2,
48 xtpChartUpdateRedraw = 4,
49};
50
55class _XTP_EXT_CLASS CXTPChartObject
56# ifdef _XTP_ACTIVEX
57 : public CXTPCmdTarget
58# else
59 : public CObject
60# endif
61{
62 DECLARE_DYNAMIC(CXTPChartObject);
63
64protected:
69 CXTPChartObject();
70
81 CXTPChartObject(BOOL bIs3D);
82
83public:
91 BOOL Is3D() const;
92
94protected:
95 void Set3D();
98private:
99 BOOL m_bIs3D;
100};
101
102AFX_INLINE CXTPChartObject::CXTPChartObject()
103 : m_bIs3D(FALSE)
104{
105}
106AFX_INLINE CXTPChartObject::CXTPChartObject(BOOL bIs3D)
107 : m_bIs3D(bIs3D)
108{
109}
111AFX_INLINE void CXTPChartObject::Set3D()
112{
113 m_bIs3D = TRUE;
114}
116AFX_INLINE BOOL CXTPChartObject::Is3D() const
117{
118 return m_bIs3D;
119}
120
130class _XTP_EXT_CLASS CXTPChartElement : public CXTPChartObject
131{
132 DECLARE_DYNAMIC(CXTPChartElement);
133
134public:
139 CXTPChartElement();
140
145 virtual ~CXTPChartElement();
146
147public:
152 virtual void Release();
153
161 CXTPChartElement* GetOwner() const;
162
163public:
170 virtual void OnChartChanged(XTPChartUpdateOptions updateOptions = xtpChartUpdateView);
171
183 CXTPChartContent* GetContent() const;
184
192 CXTPChartAppearance* GetAppearance() const;
193
194public:
201 virtual void DoPropExchange(CXTPPropExchange* pPX);
202
203public:
204# ifdef _XTP_ACTIVEX
205
206public:
208 DECLARE_DISPATCH_MAP()
209 DECLARE_INTERFACE_MAP()
210
211 DECLARE_OLETYPELIB_EX(CXTPChartElement);
213# else
214 DWORD InternalAddRef();
215 DWORD InternalRelease();
216
217 long m_dwRef;
218# endif
219
220protected:
221 CXTPChartElement* m_pOwner; // Owner of the element.
222
223 friend class CXTPChartElementCollection;
224};
225
231class _XTP_EXT_CLASS CXTPChartContainer
232{
233public:
238 CXTPChartContainer();
239
244 virtual ~CXTPChartContainer();
245
246public:
247
253 virtual CWnd* GetControl() = 0;
254
261 virtual void OnChartChanged(XTPChartUpdateOptions updateOptions = xtpChartUpdateView);
262
269 virtual void SetCapture(CXTPChartElementView* pView);
270
279 void BeginFrequentUpdates();
280
291 BOOL IsBeingFrequentlyUpdated() const;
292
302 void EndFrequentUpdates(XTPChartUpdateOptions updateOptions = xtpChartUpdateRedraw);
303
304private:
305 BOOL m_bBeingFrequentlyUpdated;
306};
307
308AFX_INLINE BOOL CXTPChartContainer::IsBeingFrequentlyUpdated() const
309{
310 return m_bBeingFrequentlyUpdated;
311}
312
322class _XTP_EXT_CLASS CXTPChartTextElement : public CXTPChartElement
323{
324 DECLARE_DYNAMIC(CXTPChartTextElement);
325
326public:
335 virtual CXTPChartFont* GetFont() const = 0;
336
345 virtual BOOL GetAntialiasing() const = 0;
346};
347
357class _XTP_EXT_CLASS CXTPChartElementCollection : public CXTPChartElement
358{
360 DECLARE_DYNAMIC(CXTPChartElementCollection)
362public:
367 CXTPChartElementCollection();
368
373 ~CXTPChartElementCollection();
374
375public:
384 virtual void RemoveAll();
385
394 virtual int GetCount() const;
395
402 virtual void RemoveAt(int nIndex);
403
410 virtual void Remove(CXTPChartElement* pElement);
411
421 CXTPChartElement* GetAt(int nIndex) const;
422
432 int IndexOf(CXTPChartElement* pElement) const;
433
441 void InsertAt(int nIndex, CXTPChartElement* pElement);
442
447 virtual void Release();
448
449protected:
450 CArray<CXTPChartElement*, CXTPChartElement*> m_arrElements;
452};
453
454AFX_INLINE CXTPChartElement* CXTPChartElement::GetOwner() const
455{
456 return m_pOwner;
457}
458
459AFX_INLINE CXTPChartElement* CXTPChartElementCollection::GetAt(int nIndex) const
460{
461 return nIndex >= 0 && nIndex < m_arrElements.GetSize() ? m_arrElements.GetAt(nIndex) : NULL;
462}
463AFX_INLINE int CXTPChartElementCollection::GetCount() const
464{
465 return (int)m_arrElements.GetSize();
466}
468# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
469#endif //#if !defined(__XTPCHARTELEMENT_H__)
XTPChartUpdateOptions
XTPChartUpdateOptions
Specifies chart update options.
Definition XTPChartElement.h:45
xtpChartUpdateView
@ xtpChartUpdateView
Recreate View.
Definition XTPChartElement.h:46
xtpChartUpdateLayout
@ xtpChartUpdateLayout
Don't recreate View but call Calculate.
Definition XTPChartElement.h:47
xtpChartUpdateRedraw
@ xtpChartUpdateRedraw
Rebuild Command Tree.
Definition XTPChartElement.h:48
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartAppearance
This class represents the appearance of the chart.
Definition XTPChartAppearance.h:629
CXTPChartContainer
This class represents the chart container.
Definition XTPChartElement.h:232
CXTPChartContainer::EndFrequentUpdates
void EndFrequentUpdates(XTPChartUpdateOptions updateOptions=xtpChartUpdateRedraw)
Leave the frequent update mode and performs the final update.
CXTPChartContainer::BeginFrequentUpdates
void BeginFrequentUpdates()
Enters a mode in which a container is expected to be frequently updated.
CXTPChartContainer::GetControl
virtual CWnd * GetControl()=0
Obtains Chart control's window object.
CXTPChartContainer::IsBeingFrequentlyUpdated
BOOL IsBeingFrequentlyUpdated() const
Determines if the container is currently being frequently updated.
Definition XTPChartElement.h:308
CXTPChartContainer::OnChartChanged
virtual void OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this function to trigger a re-painting when there is a change in the intrinsic properties of the...
CXTPChartContainer::SetCapture
virtual void SetCapture(CXTPChartElementView *pView)
This method is called to set capture to view.
CXTPChartContainer::CXTPChartContainer
CXTPChartContainer()
Constructs a CXTPChartContainer object.
CXTPChartContainer::~CXTPChartContainer
virtual ~CXTPChartContainer()
Destroys a CXTPChartContainer object, handles cleanup.
CXTPChartContent
This class represents chart content, which is a kind of CXTPChartElement.
Definition XTPChartContent.h:66
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartElementCollection
This class abstracts a chart collection.
Definition XTPChartElement.h:358
CXTPChartElementCollection::GetCount
virtual int GetCount() const
Call this function to get the number of objects in the internal array of this object.
Definition XTPChartElement.h:463
CXTPChartElementCollection::Remove
virtual void Remove(CXTPChartElement *pElement)
Use this function to remove an object from the collection.
CXTPChartElementCollection::m_arrElements
CArray< CXTPChartElement *, CXTPChartElement * > m_arrElements
Array of CXTPChartElement pointer.
Definition XTPChartElement.h:450
CXTPChartElementCollection::InsertAt
void InsertAt(int nIndex, CXTPChartElement *pElement)
Call this method to add a new element to the collection.
CXTPChartElementCollection::Release
virtual void Release()
Call this function to decrease the usage count of the object.
CXTPChartElementCollection::CXTPChartElementCollection
CXTPChartElementCollection()
Constructs a CXTPChartElementCollection object.
CXTPChartElementCollection::~CXTPChartElementCollection
~CXTPChartElementCollection()
Destroys a CXTPChartElementCollection object, handles cleanup.
CXTPChartElementCollection::IndexOf
int IndexOf(CXTPChartElement *pElement) const
Call this function to get the index of a specified element.
CXTPChartElementCollection::RemoveAll
virtual void RemoveAll()
This function removes all the individual objects from this collection object.
CXTPChartElementCollection::GetAt
CXTPChartElement * GetAt(int nIndex) const
Call this function to get an element by its index.
Definition XTPChartElement.h:459
CXTPChartElementCollection::RemoveAt
virtual void RemoveAt(int nIndex)
Use this function to remove an object from the collection.
CXTPChartElement
This class abstracts a chart element, this class acts as a base class for all chart elements.
Definition XTPChartElement.h:131
CXTPChartElement::DoPropExchange
virtual void DoPropExchange(CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
CXTPChartElement::GetAppearance
CXTPChartAppearance * GetAppearance() const
Call this function to get the the appearance of the chart.
CXTPChartElement::CXTPChartElement
CXTPChartElement()
Constructs a CXTPChartElement object.
CXTPChartElement::GetOwner
CXTPChartElement * GetOwner() const
Call this function to get the owner element.
Definition XTPChartElement.h:454
CXTPChartElement::Release
virtual void Release()
Call this function to decrease the usage count of the object.
CXTPChartElement::GetContent
CXTPChartContent * GetContent() const
Call this virtual function to get the chart content object.
CXTPChartElement::~CXTPChartElement
virtual ~CXTPChartElement()
Destroys a CXTPChartElement object, handles cleanup.
CXTPChartElement::OnChartChanged
virtual void OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic propertie...
CXTPChartElementView
This class represents the view of a chart element.
Definition XTPChartElementView.h:47
CXTPChartFont
This class abstracts a font entity.
Definition XTPChartTypes.h:540
CXTPChartObject
A base class for all chart objects.
Definition XTPChartElement.h:61
CXTPChartObject::CXTPChartObject
CXTPChartObject()
Constructs an empty chart object.
Definition XTPChartElement.h:102
CXTPChartObject::Is3D
BOOL Is3D() const
Determines if a derived object is used in 3D mode.
Definition XTPChartElement.h:116
CXTPChartTextElement
This class abstracts a chart text element.
Definition XTPChartElement.h:323
CXTPChartTextElement::GetFont
virtual CXTPChartFont * GetFont() const =0
Call this function to get the font of the text element.
CXTPChartTextElement::GetAntialiasing
virtual BOOL GetAntialiasing() const =0
Call this function to check if anti-aliasing is ON or OFF.
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72


Toolkit Pro: XTPTabThemeOffice2013.h Source File

  • Source
  • TabManager
  • Themes
XTPTabThemeOffice2013.h
Go to the documentation of this file.
1
23#if !defined(__XTPTABTHEMEOFFICE2013_H__)
24# define __XTPTABTHEMEOFFICE2013_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
37class _XTP_EXT_CLASS CXTPTabThemeOffice2013 : public CXTPTabThemeVisualStudio2012
38{
39public:
44 CXTPTabThemeOffice2013();
45
54 virtual void RefreshMetrics();
55
64 virtual XTPTabColorStyle GetDefaultColorSet()
65 {
66 return xtpTabColorOffice2013;
67 }
68};
69
70# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
72#endif // __XTPTABTHEMEOFFICE2013_H__
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPTabColorStyle
XTPTabColorStyle
XTPTabColorStyle is an enumeration used to set the color style of tabs.
Definition XTPTabManagerDefines.h:139
xtpTabColorOffice2013
@ xtpTabColorOffice2013
Tabs will use the Office 2013 style for the currently set Appearance.
Definition XTPTabManagerDefines.h:162
CXTPTabThemeOffice2013
CXTPTabThemeOffice2013 implements an Office 2013 tab appearance.
Definition XTPTabThemeOffice2013.h:38
CXTPTabThemeOffice2013::GetDefaultColorSet
virtual XTPTabColorStyle GetDefaultColorSet()
Gets the default value of the color set for this theme.
Definition XTPTabThemeOffice2013.h:64
CXTPTabThemeOffice2013::CXTPTabThemeOffice2013
CXTPTabThemeOffice2013()
Constructs a CXTPTabThemeOffice2013 object.
CXTPTabThemeOffice2013::RefreshMetrics
virtual void RefreshMetrics()
Refreshes the appearance metrics.
CXTPTabThemeVisualStudio2012
CXTPTabThemeVisualStudio2012 implements a Visual Studio 2012 tab appearance.
Definition XTPTabThemeVisualStudio2012.h:38


Toolkit Pro: XTPChartMarker.h Source File

  • Source
  • Chart
  • Styles
  • Point
XTPChartMarker.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTMARKER_H__)
24# define __XTPCHARTMARKER_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartSeriesStyle;
34class CXTPChartDeviceCommand;
35class CXTPChartDeviceContext;
36class CXTPChartFillStyle;
37
43enum XTPChartMarkerType
44{
45 xtpChartMarkerCircle,
46 xtpChartMarkerSquare,
47 xtpChartMarkerDiamond,
48 xtpChartMarkerTriangle,
49 xtpChartMarkerPentagon,
50 xtpChartMarkerHexagon,
51 xtpChartMarkerStar
52};
53
63class _XTP_EXT_CLASS CXTPChartMarker : public CXTPChartElement
64{
66 DECLARE_DYNAMIC(CXTPChartMarker)
68public:
75 CXTPChartMarker(CXTPChartSeriesStyle* pOwner);
76
81 virtual ~CXTPChartMarker();
82
83public:
84 int GetSize() const;
85 void SetSize(int nSize);
86
87 void SetBorderVisible(BOOL bBorderVisible);
88 BOOL GetBorderVisible() const;
89
90 XTPChartMarkerType GetType() const;
91 void SetType(XTPChartMarkerType nType);
92
93 CXTPChartFillStyle* GetFillStyle() const;
94
95 BOOL GetVisible() const;
96 void SetVisible(BOOL bVisible);
97
98public:
99 virtual void DoPropExchange(CXTPPropExchange* pPX);
100
101public:
118 virtual CXTPChartDeviceCommand* CreateDeviceCommand(CXTPChartDeviceContext* pDC,
119 const CXTPChartPointF& point,
120 CXTPChartColor color, CXTPChartColor color2,
121 CXTPChartColor colorBorder);
122
140 virtual CXTPChartDeviceCommand* CreateDeviceCommand(CXTPChartDeviceContext* pDC,
141 const CXTPChartPointF& point, int nWidth,
142 CXTPChartColor color, CXTPChartColor color2,
143 CXTPChartColor colorBorder);
144
145protected:
146# ifdef _XTP_ACTIVEX
147public:
149 DECLARE_DISPATCH_MAP()
150 DECLARE_INTERFACE_MAP()
151 DECLARE_OLETYPELIB_EX(CXTPChartMarker);
152
153 afx_msg LPDISPATCH OleGetFillStyle();
155# endif
156protected:
157 BOOL m_bBorderVisible;
158 CXTPChartColor m_clrBorderColor;
159 CXTPChartColor m_clrColor;
160 XTPChartMarkerType m_nType;
161 int m_nSize;
162 BOOL m_bVisible;
163 CXTPChartFillStyle* m_pFillStyle;
164};
165
166AFX_INLINE int CXTPChartMarker::GetSize() const
167{
168 return m_nSize;
169}
170AFX_INLINE void CXTPChartMarker::SetSize(int nSize)
171{
172 m_nSize = nSize;
173 OnChartChanged();
174}
175AFX_INLINE void CXTPChartMarker::SetBorderVisible(BOOL bBorderVisible)
176{
177 m_bBorderVisible = bBorderVisible;
178 OnChartChanged();
179}
180AFX_INLINE BOOL CXTPChartMarker::GetBorderVisible() const
181{
182 return m_bBorderVisible;
183}
184AFX_INLINE XTPChartMarkerType CXTPChartMarker::GetType() const
185{
186 return m_nType;
187}
188AFX_INLINE void CXTPChartMarker::SetType(XTPChartMarkerType nType)
189{
190 m_nType = nType;
191 OnChartChanged();
192}
193AFX_INLINE CXTPChartFillStyle* CXTPChartMarker::GetFillStyle() const
194{
195 return m_pFillStyle;
196}
197AFX_INLINE BOOL CXTPChartMarker::GetVisible() const
198{
199 return m_bVisible;
200}
201AFX_INLINE void CXTPChartMarker::SetVisible(BOOL bVisible)
202{
203 m_bVisible = bVisible;
204 OnChartChanged();
205}
207# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
208#endif //#if !defined(__XTPCHARTMARKER_H__)
XTPChartMarkerType
XTPChartMarkerType
This enumeration is used for naming the various styles for the point series point marking.
Definition XTPChartMarker.h:44
xtpChartMarkerPentagon
@ xtpChartMarkerPentagon
Specifies pentagon marker shape.
Definition XTPChartMarker.h:49
xtpChartMarkerSquare
@ xtpChartMarkerSquare
Specifies square marker shape.
Definition XTPChartMarker.h:46
xtpChartMarkerStar
@ xtpChartMarkerStar
Specifies star marker shape.
Definition XTPChartMarker.h:51
xtpChartMarkerDiamond
@ xtpChartMarkerDiamond
Specifies diamond marker shape.
Definition XTPChartMarker.h:47
xtpChartMarkerHexagon
@ xtpChartMarkerHexagon
Specifies hexagon marker shape.
Definition XTPChartMarker.h:50
xtpChartMarkerTriangle
@ xtpChartMarkerTriangle
Specifies triangle marker shape.
Definition XTPChartMarker.h:48
xtpChartMarkerCircle
@ xtpChartMarkerCircle
The circular style.
Definition XTPChartMarker.h:45
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartColor
This class abstracts a color entity.
Definition XTPChartTypes.h:51
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartElement
This class abstracts a chart element, this class acts as a base class for all chart elements.
Definition XTPChartElement.h:131
CXTPChartElement::OnChartChanged
virtual void OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic propertie...
CXTPChartFillStyle
This class abstracts a fill style used to fill the background of various chart elements.
Definition XTPChartFillStyle.h:43
CXTPChartMarker
This class abstracts a marker used in marking the points in a point series style chart.
Definition XTPChartMarker.h:64
CXTPChartMarker::DoPropExchange
virtual void DoPropExchange(CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
CXTPChartMarker::m_bBorderVisible
BOOL m_bBorderVisible
TRUE if the border is visible, FALSE if the border is invisible.
Definition XTPChartMarker.h:157
CXTPChartMarker::m_clrColor
CXTPChartColor m_clrColor
The first color of the marker gradient.
Definition XTPChartMarker.h:159
CXTPChartMarker::m_nSize
int m_nSize
The size of the marker.
Definition XTPChartMarker.h:161
CXTPChartMarker::CreateDeviceCommand
virtual CXTPChartDeviceCommand * CreateDeviceCommand(CXTPChartDeviceContext *pDC, const CXTPChartPointF &point, int nWidth, CXTPChartColor color, CXTPChartColor color2, CXTPChartColor colorBorder)
This function creates a CXTPChartDeviceCommand object.
CXTPChartMarker::~CXTPChartMarker
virtual ~CXTPChartMarker()
Destroys a CXTPChartMarker object, handles cleanup.
CXTPChartMarker::m_clrBorderColor
CXTPChartColor m_clrBorderColor
The color of the marker border.
Definition XTPChartMarker.h:158
CXTPChartMarker::m_nType
XTPChartMarkerType m_nType
The Marker Type.
Definition XTPChartMarker.h:160
CXTPChartMarker::m_bVisible
BOOL m_bVisible
TRUE if the marker is visible and FALSE if the marker is invisible.
Definition XTPChartMarker.h:162
CXTPChartMarker::CreateDeviceCommand
virtual CXTPChartDeviceCommand * CreateDeviceCommand(CXTPChartDeviceContext *pDC, const CXTPChartPointF &point, CXTPChartColor color, CXTPChartColor color2, CXTPChartColor colorBorder)
This function creates a CXTPChartDeviceCommand object.
CXTPChartMarker::CXTPChartMarker
CXTPChartMarker(CXTPChartSeriesStyle *pOwner)
Constructs a CXTPChartMarker object.
CXTPChartSeriesStyle
CXTPChartSeriesStyle is a CXTPChartElement derived class.
Definition XTPChartSeriesStyle.h:49
CXTPPoint2T< float >
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72


Toolkit Pro: XTPSyntaxEditDefines.h Source File

  • Source
  • SyntaxEdit
XTPSyntaxEditDefines.h
Go to the documentation of this file.
1
23#if !defined(__XTPSYNTAXEDITDEFINES_H__)
24# define __XTPSYNTAXEDITDEFINES_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33# pragma warning(disable : 4097)
34
35// Edit action flags
36# define XTP_EDIT_EDITACTION_INSERTROW 0x01
37# define XTP_EDIT_EDITACTION_INSERTROW_NEW 0x10
38# define XTP_EDIT_EDITACTION_DELETEROW 0x02
39# define XTP_EDIT_EDITACTION_DELETEROW_FULL 0x20 //
40# define XTP_EDIT_EDITACTION_MODIFYROW 0x04
41// #define XTP_EDIT_EDITACTION_SELECTIONCHANGED 0x08 // Selection changed
42# define XTP_EDIT_EDITACTION_INSERTTEXT 0x100
43# define XTP_EDIT_EDITACTION_DELETETEXT 0x200
50# define XTP_EDIT_DISABLED_COLOR_LIGHT RGB(250, 250, 250)
51
57# define XTP_EDIT_DISABLED_COLOR_DARK RGB(128, 128, 128)
59// Notification codes
61
62// First and last entries
63# define XTP_EDIT_NM_FIRST (0U - 951U)
64# define XTP_EDIT_NM_LAST (0U - 979U)
66// Following are the codes for various notifications
67# define XTP_EDIT_NM_EDITCHANGING \
68 (XTP_EDIT_NM_FIRST + 0)
69# define XTP_EDIT_NM_EDITCHANGED \
70 (XTP_EDIT_NM_FIRST + 1)
71# define XTP_EDIT_NM_SETDOCMODIFIED \
72 (XTP_EDIT_NM_FIRST + 2)
73# define XTP_EDIT_NM_DRAWBOOKMARK \
74 (XTP_EDIT_NM_FIRST + 3)
75# define XTP_EDIT_NM_ROWCOLCHANGED \
76 (XTP_EDIT_NM_FIRST + 4)
77# define XTP_EDIT_NM_INSERTKEY (XTP_EDIT_NM_FIRST + 8)
78# define XTP_EDIT_NM_SELINIT \
79 (XTP_EDIT_NM_FIRST + 9)
80# define XTP_EDIT_NM_STARTOLEDRAG (XTP_EDIT_NM_FIRST + 10)
81# define XTP_EDIT_NM_MARGINCLICKED \
82 (XTP_EDIT_NM_FIRST + 11)
83# define XTP_EDIT_NM_UPDATESCROLLPOS \
84 (XTP_EDIT_NM_FIRST + 12)
85# define XTP_EDIT_NM_PARSEEVENT \
86 (XTP_EDIT_NM_FIRST + 13)
88# define XTP_EDIT_NM_LBUTTONDOWN \
89 (XTP_EDIT_NM_FIRST + 14)
91# define XTP_EDIT_NM_LBUTTONDBLCLICK \
92 (XTP_EDIT_NM_FIRST + 15)
94# define XTP_EDIT_NM_LBUTTONUP \
95 (XTP_EDIT_NM_FIRST + 16)
97# define XTP_EDIT_NM_RBUTTONDOWN \
98 (XTP_EDIT_NM_FIRST + 17)
100# define XTP_EDIT_NM_RBUTTONUP \
101 (XTP_EDIT_NM_FIRST + 18)
103# define XTP_EDIT_NM_MOUSEMOVE \
104 (XTP_EDIT_NM_FIRST \
105 + 19)
107# define XTP_EDIT_NM_ENABLESCROLLBAR \
108 (XTP_EDIT_NM_FIRST + 20)
110# define XTP_EDIT_FINDWORD_PREV 0x01
111# define XTP_EDIT_FINDWORD_NEXT 0x02
114// send with XTP_EDIT_NM_UPDATESCROLLPOS but unused on higher layer.
115# define XTP_EDIT_UPDATE_HORZ 0x01
116# define XTP_EDIT_UPDATE_VERT 0x02
117# define XTP_EDIT_UPDATE_DIAG 0x04
118# define XTP_EDIT_UPDATE_ALL (XTP_EDIT_UPDATE_HORZ | XTP_EDIT_UPDATE_VERT | XTP_EDIT_UPDATE_DIAG)
121# define XTP_EDIT_AVELINELEN \
122 30
126// default values for some parcer parameters
127# define XTP_EDIT_LEXPARSER_MAXBACKOFFSETDEFAULT 100
128# define XTP_EDIT_LEXPARSER_REPARSETIMEOUTMS 500
129# define XTP_EDIT_LEXPARSER_ONSCREENSCHCACHELIFETIMESEC 180
130# define XTP_EDIT_LEXPARSER_THREADIDLELIFETIMESEC 60
134// Registry constants.
135const TCHAR XTP_EDIT_REG_SETTINGS[] = _T("Settings");
136const TCHAR XTP_EDIT_REG_AUTORELOAD[] = _T("AutoReload");
137const TCHAR XTP_EDIT_REG_LINENUMBACKCOLOR[] = _T("ColorLineNumberBack");
138const TCHAR XTP_EDIT_REG_LINENUMTEXTCOLOR[] = _T("ColorLineNumberText");
139const TCHAR XTP_EDIT_REG_INSELBACKCOLOR[] = _T("ColorInactiveHiliteColorBack");
140const TCHAR XTP_EDIT_REG_INSELTEXTCOLOR[] = _T("ColorInactiveHiliteColorText");
141const TCHAR XTP_EDIT_REG_SELBACKCOLOR[] = _T("ColorHiliteBack");
142const TCHAR XTP_EDIT_REG_SELTEXTCOLOR[] = _T("ColorHiliteText");
143const TCHAR XTP_EDIT_REG_BACKCOLOR[] = _T("ColorBack");
144const TCHAR XTP_EDIT_REG_READONLYBACKCOLOR[] = _T("ColorReadOnlyBack");
145const TCHAR XTP_EDIT_REG_TEXTCOLOR[] = _T("ColorText");
146const TCHAR XTP_EDIT_REG_LOGFONT[] = _T("LogFont");
147const TCHAR XTP_EDIT_REG_VSCROLLBAR[] = _T("VScrollBar");
148const TCHAR XTP_EDIT_REG_HSCROLLBAR[] = _T("HScrollBar");
149const TCHAR XTP_EDIT_REG_SYNTAXCOLOR[] = _T("SyntaxColor");
150const TCHAR XTP_EDIT_REG_AUTOINDENT[] = _T("AutoIndent");
151const TCHAR XTP_EDIT_REG_SELMARGIN[] = _T("SelMargin");
152const TCHAR XTP_EDIT_REG_LINENUMBERS[] = _T("LineNumbers");
153const TCHAR XTP_EDIT_REG_WIDECARET[] = _T("WideCaret");
154const TCHAR XTP_EDIT_REG_TABWITHSPACE[] = _T("TabWithSpace");
155const TCHAR XTP_EDIT_REG_TABSIZE[] = _T("TabSize");
156const TCHAR XTP_EDIT_REG_VIRTUALSPACE[] = _T("VirtualSpace");
157const TCHAR XTP_EDIT_REG_COLLAPSIBLENODES[] = _T("CollapsibleNodes");
158const TCHAR XTP_EDIT_REG_BREAKPOINTTEXTCOLOR[] = _T("ColorBreakpointText");
159const TCHAR XTP_EDIT_REG_BREAKPOINTBACKCOLOR[] = _T("ColorBreakpointBack");
163// Lexer classes' defines
164const TCHAR XTP_EDIT_LEXCLASS_STARTTOKEN[] = _T("lexClass:");
165const TCHAR XTP_EDIT_LEXCLASS_ENDTOKEN[] = _T("//:lexClass");
166const TCHAR XTP_EDIT_LEXCLASS_PROPNAME[] = _T("name");
167const TCHAR XTP_EDIT_LEXCLASS_EOL[] = _T("\r\n");
168const TCHAR XTP_EDIT_LEXCLASS_EMPTYSTR[] = _T("");
169
170const TCHAR XTP_EDIT_LEXPARSER_DEFTHEME[] = _T("Default");
171const TCHAR XTP_EDIT_LEXPARSER_CFG_FILENAME[] = _T("SyntaxEdit.ini");
172const TCHAR XTP_EDIT_LEXPARSER_PARENT_SCHEMA[] = _T("parentschema");
173const TCHAR XTP_EDIT_LEXPARSER_SECTION_MAIN[] = _T("main");
174const TCHAR XTP_EDIT_LEXPARSER_SECTION_THEMES[] = _T("themes");
175const TCHAR XTP_EDIT_LEXPARSER_SECTION_SCHEMES[] = _T("schemes");
176const TCHAR XTP_EDIT_LEXPARSER_PARAM_COLORBK[] = _T("colorBK");
177const TCHAR XTP_EDIT_LEXPARSER_PARAM_COLORFG[] = _T("colorFG");
178const TCHAR XTP_EDIT_LEXPARSER_PARAM_COLORSELBK[] = _T("colorSelBK");
179const TCHAR XTP_EDIT_LEXPARSER_PARAM_COLORSELFG[] = _T("colorSelFG");
180const TCHAR XTP_EDIT_LEXPARSER_PARAM_FONTBOLD[] = _T("Bold");
181const TCHAR XTP_EDIT_LEXPARSER_PARAM_FONTITALIC[] = _T("Italic");
182const TCHAR XTP_EDIT_LEXPARSER_PARAM_FONTUNDERLINE[] = _T("Underline");
183
184const TCHAR XTP_EDIT_CFMSDEVCOLSEL[] = _T("MSDEVColumnSelect");
185const TCHAR XTP_EDIT_CLASSNAME_EDITCTRL[] = _T("CodejockSyntaxEditor");
186const TCHAR XTP_EDIT_CLASSNAME_AUTOCOMPLETEWND[] = _T("CodejockSEAutoCompleteWnd");
187const TCHAR XTP_EDIT_CLASSNAME_TOOLTIP[] = _T("CodejockSEToolTip");
188const TCHAR XTP_EDIT_CLASSNAME_LBOXTIP[] = _T("CodejockSEListBoxTipWnd");
191# define XTP_EDIT_RGB_GETRED(rgb) \
192 (((rgb) >> 16) & 0xff)
193# define XTP_EDIT_RGB_GETGREEN(rgb) \
194 (((rgb) >> 8) & 0xff)
195# define XTP_EDIT_RGB_GETBLUE(rgb) \
196 ((rgb)&0xff)
197# define XTP_EDIT_RGB_INT2CLR(rgb) \
198 RGB(XTP_EDIT_RGB_GETRED(rgb), XTP_EDIT_RGB_GETGREEN(rgb), \
199 XTP_EDIT_RGB_GETBLUE( \
200 rgb))
206enum XTPSyntaxEditCRLFStyle
207{
208 xtpEditCRLFStyleUnknown = -1,
209 xtpEditCRLFStyleDos = 0,
210 xtpEditCRLFStyleUnix = 1,
211 xtpEditCRLFStyleMac = 2
212};
213
218enum XTPSyntaxEditDeletePos
219{
220 xtpEditDelPosAfter,
221 xtpEditDelPosBefore
222};
223
228enum XTPSyntaxEditOnParseEvent
229{
230 xtpEditOnParserStarted = 1,
231 xtpEditOnTextBlockParsed = 2,
232 xtpEditOnParserEnded = 3
234};
235
240enum XTPSyntaxEditOnCfgChangedEvent
241{
242 xtpEditClassSchWasChanged = 10,
245 xtpEditThemeWasChanged = 11,
248 xtpEditAllConfigWasChanged = 12
249};
250
255enum XTPSyntaxEditUpdateViewHint
256{
257 xtpEditHintUnknown,
258 xtpEditHintRefreshView,
259 xtpEditHintInitView,
260 xtpEditHintSetFont,
261 xtpEditHintSetLineNum,
262 xtpEditHintSetSelMargin,
263 xtpEditHintSetAutoIndent,
264 xtpEditHintSetSyntaxColor,
265 xtpEditHintUpdateScrollPos,
266 xtpEditHintLast,
267 xtpEditHintInvalidate,
268};
269
274enum XTPSyntaxEditEditAction
275{
276 xtpEditActInsert = 1,
277 xtpEditActDelete = 2,
278};
279
280typedef DWORD XTP_NOTIFY_CODE;
281
283
284//{{AFX_INSERT_LOCATION}}
285// Microsoft Visual C++ will insert additional declarations immediately before the previous line.
286
287# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
289#endif // !defined(__XTPSYNTAXEDITDEFINES_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPSyntaxEditUpdateViewHint
XTPSyntaxEditUpdateViewHint
View update actions.
Definition XTPSyntaxEditDefines.h:256
xtpEditHintSetSelMargin
@ xtpEditHintSetSelMargin
The view should update the selection margin display.
Definition XTPSyntaxEditDefines.h:262
xtpEditHintSetLineNum
@ xtpEditHintSetLineNum
The view should update line number display.
Definition XTPSyntaxEditDefines.h:261
xtpEditHintSetAutoIndent
@ xtpEditHintSetAutoIndent
The view should update the auto-indent setting.
Definition XTPSyntaxEditDefines.h:263
xtpEditHintInitView
@ xtpEditHintInitView
The view should be initialized.
Definition XTPSyntaxEditDefines.h:259
xtpEditHintSetSyntaxColor
@ xtpEditHintSetSyntaxColor
The view should update the syntax color setting.
Definition XTPSyntaxEditDefines.h:264
xtpEditHintRefreshView
@ xtpEditHintRefreshView
The view should be refreshed.
Definition XTPSyntaxEditDefines.h:258
xtpEditHintSetFont
@ xtpEditHintSetFont
The view should update the display font.
Definition XTPSyntaxEditDefines.h:260
xtpEditHintUpdateScrollPos
@ xtpEditHintUpdateScrollPos
The view should update scrollbars positions.
Definition XTPSyntaxEditDefines.h:265
xtpEditHintInvalidate
@ xtpEditHintInvalidate
Invalidates the view.
Definition XTPSyntaxEditDefines.h:267
xtpEditHintLast
@ xtpEditHintLast
The last update code.
Definition XTPSyntaxEditDefines.h:266
xtpEditHintUnknown
@ xtpEditHintUnknown
Updating action is unknown.
Definition XTPSyntaxEditDefines.h:257
XTPSyntaxEditEditAction
XTPSyntaxEditEditAction
Edit actions.
Definition XTPSyntaxEditDefines.h:275
xtpEditActInsert
@ xtpEditActInsert
Edit action insert text.
Definition XTPSyntaxEditDefines.h:276
xtpEditActDelete
@ xtpEditActDelete
Edit action delete text.
Definition XTPSyntaxEditDefines.h:277
XTPSyntaxEditOnCfgChangedEvent
XTPSyntaxEditOnCfgChangedEvent
These events are sent from different threads.
Definition XTPSyntaxEditDefines.h:241
xtpEditThemeWasChanged
@ xtpEditThemeWasChanged
dwParam1 = LPCTSTR - Theme name; dwParam2 = CXTPSyntaxEditColorTheme* New theme pointer,...
Definition XTPSyntaxEditDefines.h:245
xtpEditAllConfigWasChanged
@ xtpEditAllConfigWasChanged
dwParam1 - unused, dwParam2 - unused
Definition XTPSyntaxEditDefines.h:248
xtpEditClassSchWasChanged
@ xtpEditClassSchWasChanged
dwParam1 = LPCTSTR - Schema name; dwParam2 = CXTPSyntaxEditLexTextSchema* New text schema pointer,...
Definition XTPSyntaxEditDefines.h:242
XTPSyntaxEditDeletePos
XTPSyntaxEditDeletePos
Edit delete position.
Definition XTPSyntaxEditDefines.h:219
xtpEditDelPosBefore
@ xtpEditDelPosBefore
Delete char(s) before specified position.
Definition XTPSyntaxEditDefines.h:221
xtpEditDelPosAfter
@ xtpEditDelPosAfter
Delete char(s) after specified position.
Definition XTPSyntaxEditDefines.h:220
XTPSyntaxEditCRLFStyle
XTPSyntaxEditCRLFStyle
Line ending types.
Definition XTPSyntaxEditDefines.h:207
xtpEditCRLFStyleUnix
@ xtpEditCRLFStyleUnix
UNIX style CRLF (0x0a0d).
Definition XTPSyntaxEditDefines.h:210
xtpEditCRLFStyleDos
@ xtpEditCRLFStyleDos
DOS style CRLF (0x0d0a).
Definition XTPSyntaxEditDefines.h:209
xtpEditCRLFStyleUnknown
@ xtpEditCRLFStyleUnknown
Used to indicate unknown or error value.
Definition XTPSyntaxEditDefines.h:208
xtpEditCRLFStyleMac
@ xtpEditCRLFStyleMac
MAC style CRLF (0x0a).
Definition XTPSyntaxEditDefines.h:211
XTPSyntaxEditOnParseEvent
XTPSyntaxEditOnParseEvent
These events are sent from different threads.
Definition XTPSyntaxEditDefines.h:229
xtpEditOnParserEnded
@ xtpEditOnParserEnded
dwParam1 = status flags : xtpEditLPR_RunFinished, xtpEditLPR_RunBreaked, xtpEditLPR_Error;
Definition XTPSyntaxEditDefines.h:232
xtpEditOnTextBlockParsed
@ xtpEditOnTextBlockParsed
dwParam1 = Text Block ID
Definition XTPSyntaxEditDefines.h:231
xtpEditOnParserStarted
@ xtpEditOnParserStarted
dwParam1 - unused
Definition XTPSyntaxEditDefines.h:230


Toolkit Pro: Member List

XTP_TASKPANEL_GROUPCOLORS Member List

This is the complete list of members for XTP_TASKPANEL_GROUPCOLORS, including all inherited members.

clrClient | XTP_TASKPANEL_GROUPCOLORS
clrClientBorder | XTP_TASKPANEL_GROUPCOLORS
clrClientLink | XTP_TASKPANEL_GROUPCOLORS
clrClientLinkHot | XTP_TASKPANEL_GROUPCOLORS
clrClientLinkSelected | XTP_TASKPANEL_GROUPCOLORS
clrClientText | XTP_TASKPANEL_GROUPCOLORS
clrHead | XTP_TASKPANEL_GROUPCOLORS
clrHeadTextHot | XTP_TASKPANEL_GROUPCOLORS
clrHeadTextNormal | XTP_TASKPANEL_GROUPCOLORS
dHeadGradientFactor | XTP_TASKPANEL_GROUPCOLORS


Toolkit Pro: XTPDockingPaneThemeVisualStudio2005Beta1.h Source File

  • Source
  • DockingPane
  • Themes
XTPDockingPaneThemeVisualStudio2005Beta1.h
Go to the documentation of this file.
1
23#if !defined(__XTPDOCKINGPANETHEMEVISUALSTUDIO2005BETA1_H__)
24# define __XTPDOCKINGPANETHEMEVISUALSTUDIO2005BETA1_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
41class _XTP_EXT_CLASS CXTPDockingPaneVisualStudio2005Beta1Theme
42 : public CXTPDockingPaneVisualStudio2003Theme
43{
44public:
49 CXTPDockingPaneVisualStudio2005Beta1Theme();
50
51public:
56 void RefreshMetrics();
57};
58
59# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
61#endif // !defined(__XTPDOCKINGPANETHEMEVISUALSTUDIO2005BETA1_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPDockingPaneVisualStudio2003Theme
CXTPDockingPaneVisualStudio2003Theme is a CXTPDockingPaneGripperedTheme derived class that represents...
Definition XTPDockingPaneThemeVisualStudio2003.h:42
CXTPDockingPaneVisualStudio2005Beta1Theme
CXTPDockingPaneVisualStudio2005Beta1Theme is CXTPDockingPaneVisualStudio2003Theme derived class that ...
Definition XTPDockingPaneThemeVisualStudio2005Beta1.h:43
CXTPDockingPaneVisualStudio2005Beta1Theme::CXTPDockingPaneVisualStudio2005Beta1Theme
CXTPDockingPaneVisualStudio2005Beta1Theme()
Constructs a CXTPDockingPaneVisualStudio2005Beta1Theme object.
CXTPDockingPaneVisualStudio2005Beta1Theme::RefreshMetrics
void RefreshMetrics()
This method is called to refresh the visual metrics of the pane.


Toolkit Pro: Member List

NMXTPCHARHDR Member List

This is the complete list of members for NMXTPCHARHDR, including all inherited members.

cf | NMXTPCHARHDR
hdr | NMXTPCONTROL
pControl | NMXTPCONTROL


Toolkit Pro: Member List

CXTPActiveScriptEngine Member List

This is the complete list of members for CXTPActiveScriptEngine, including all inherited members.

AddNamedItem(LPCWSTR lpszName, LPVOID lpItemData=NULL, DWORD dwFlags=SCRIPTITEM_ISVISIBLE) | CXTPActiveScriptEngine |
CreateContext(LPDISPATCH pDispObject) const | CXTPActiveScriptEngine |
CXTPActiveScriptEngine() | CXTPActiveScriptEngine |
CXTPCmdTarget() | CXTPCmdTarget |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetExceptionData() const | CXTPActiveScriptEngine |
GetExceptionInfo() const | CXTPActiveScriptEngine |
GetGlobalContext() const | CXTPActiveScriptEngine |
GetNamedItemData(LPCWSTR lpszName) const | CXTPActiveScriptEngine |
Initialize(LPCWSTR lpszEngineProgId, IActiveScriptSite *pSite=NULL) | CXTPActiveScriptEngine |
LoadCode(LPCWSTR lpszCode) | CXTPActiveScriptEngine |
Run() | CXTPActiveScriptEngine |
Uninitialize() | CXTPActiveScriptEngine |
~CXTPActiveScriptEngine() | CXTPActiveScriptEngine | virtual


Toolkit Pro: Member List

CXTPProgressCtrlPaintManager Member List

This is the complete list of members for CXTPProgressCtrlPaintManager, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPProgressCtrlPaintManager() | CXTPProgressCtrlPaintManager |
DeflateRect(XTPPROGRESSDRAWSTRUCT &ds) | CXTPProgressCtrlPaintManager | protectedvirtual
Draw(XTPPROGRESSDRAWSTRUCT &ds) | CXTPProgressCtrlPaintManager | virtual
DrawNcBorders(CDC *pDC, CRect rc) | CXTPProgressCtrlPaintManager | virtual
DrawText(XTPPROGRESSDRAWSTRUCT &ds) | CXTPProgressCtrlPaintManager | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetBackColor() | CXTPProgressCtrlPaintManager |
GetBarColor() | CXTPProgressCtrlPaintManager |
GetBorderColor() | CXTPProgressCtrlPaintManager |
GetTextColor() | CXTPProgressCtrlPaintManager |
m_bUseWinTheme | CXTPProgressCtrlPaintManager | protected
m_clrBack | CXTPProgressCtrlPaintManager | protected
m_clrBar | CXTPProgressCtrlPaintManager | protected
m_clrBarText | CXTPProgressCtrlPaintManager | protected
m_clrBorder | CXTPProgressCtrlPaintManager | protected
m_clrText | CXTPProgressCtrlPaintManager | protected
m_nTheme | CXTPProgressCtrlPaintManager | protected
m_winTheme | CXTPProgressCtrlPaintManager | protected
RefreshMetrics() | CXTPProgressCtrlPaintManager | virtual
SetBackColor(COLORREF clrNew) | CXTPProgressCtrlPaintManager |
SetBarColor(COLORREF clrNew) | CXTPProgressCtrlPaintManager |
SetBorderColor(COLORREF clrNew) | CXTPProgressCtrlPaintManager |
SetTextColor(COLORREF clrNew) | CXTPProgressCtrlPaintManager |
UseWinThemes(BOOL bUseWinThemes=TRUE) | CXTPProgressCtrlPaintManager |
UsingWinThemes(BOOL bCheckReady=FALSE) | CXTPProgressCtrlPaintManager |
~CXTPProgressCtrlPaintManager() | CXTPProgressCtrlPaintManager | virtual


Toolkit Pro: Member List

CXTPDockingPaneOffice2003Theme Member List

This is the complete list of members for CXTPDockingPaneOffice2003Theme, including all inherited members.

AdjustCaptionRect(const CXTPDockingPaneSidePanel *pPane, CRect &rc) | CXTPDockingPanePaintManager | virtual
AdjustCaptionRect(const CXTPDockingPaneTabbedContainer *pPane, CRect &rc) | CXTPDockingPanePaintManager | virtual
AdjustClientRect(CXTPDockingPaneSidePanel *pPane, CRect &rect) | CXTPDockingPanePaintManager | virtual
AdjustClientRect(CXTPDockingPaneTabbedContainer *pPane, CRect &rect, BOOL bApply) | CXTPDockingPanePaintManager | virtual
ClipAndAddEllipsisIfNeeded(CDC *pDC, CString &strTitle, int nCaptionWidth) const | CXTPDockingPanePaintManager | protected
CXTPCmdTarget() | CXTPCmdTarget |
CXTPDockingPaneDefaultTheme() | CXTPDockingPaneDefaultTheme |
CXTPDockingPaneGripperedTheme() | CXTPDockingPaneGripperedTheme |
CXTPDockingPaneOffice2003Theme() | CXTPDockingPaneOffice2003Theme |
CXTPDockingPanePaintManager() | CXTPDockingPanePaintManager | protected
CXTPDockingPaneVisualStudio2003Theme() | CXTPDockingPaneVisualStudio2003Theme |
DrawAutoHidePanel(CDC *pDC, CRect rc, XTPDockingPaneDirection direction) | CXTPDockingPanePaintManager | virtual
DrawCaption(CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc) | CXTPDockingPaneOffice2003Theme | virtual
DrawCaptionButton(CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton) | CXTPDockingPanePaintManager | virtual
DrawCaptionButtonEntry(CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton, CSize szOffset) | CXTPDockingPanePaintManager | protectedvirtual
DrawCaptionButtonEntry(CDC *pDC, CXTPDockingPaneCaptionButton *pButton, CPoint pt, COLORREF clrButton) | CXTPDockingPanePaintManager | protectedvirtual
DrawCaptionButtons(CDC *pDC, CXTPDockingPaneCaptionButtons *pButtons, CRect &rcCaption, COLORREF clr, int nButtonSize, int nButtonGap, BOOL bVertical=FALSE) | CXTPDockingPanePaintManager | virtual
DrawCaptionPart(CDC *pDC, CXTPDockingPaneBase *pPane, CRect rcCaption, const CString &strTitle, BOOL bActive, BOOL bVertical) | CXTPDockingPaneOffice2003Theme | protectedvirtual
DrawCaptionText(CDC *pDC, const CString &strTitle, CRect rc, BOOL bVertical, BOOL bCalcWidth=FALSE) | CXTPDockingPanePaintManager |
DrawFloatingFrame(CDC *pDC, CXTPDockingPaneMiniWnd *pPane, CRect rc) | CXTPDockingPaneOffice2003Theme | virtual
DrawPane(CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc) | CXTPDockingPanePaintManager | virtual
DrawSidePanel(CDC *pDC, CXTPDockingPaneSidePanel *pPane, CRect rc) | CXTPDockingPaneOffice2003Theme | virtual
DrawSplitter(CDC *pDC, CXTPDockingPaneSplitterWnd *pSplitter) | CXTPDockingPanePaintManager | virtual
FillCaptionPart(CDC *pDC, CXTPDockingPaneBase *pPane, CRect rcCaption, BOOL bActive, BOOL bVertical) | CXTPDockingPaneVisualStudio2003Theme | protectedvirtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCaptionButtonStyle() const | CXTPDockingPanePaintManager |
GetCaptionGripperRect(const CXTPDockingPaneTabbedContainer *pPane) | CXTPDockingPaneOffice2003Theme | virtual
GetCaptionHeight() const | CXTPDockingPanePaintManager |
GetCaptionRect(const CXTPDockingPaneTabbedContainer *pPane, CRect &rc) | CXTPDockingPanePaintManager | virtual
GetCurrentSystemTheme() const | CXTPDockingPanePaintManager |
GetCustomTitleBrush(BOOL bActive, BOOL bVertical) const | CXTPDockingPanePaintManager |
GetPaneCaptionRect(const CXTPDockingPaneSidePanel *pPane) | CXTPDockingPaneOffice2003Theme | virtual
GetPanelPaintManager() const | CXTPDockingPanePaintManager |
GetSplitterStyle() const | CXTPDockingPanePaintManager |
GetTabPaintManager() const | CXTPDockingPanePaintManager |
GetTabsHeight() const | CXTPDockingPanePaintManager |
GetXtremeColor(UINT nIndex) | CXTPDockingPanePaintManager |
Line(CDC *pDC, int x0, int y0, int x1, int y1, int nPen) | CXTPDockingPanePaintManager |
Line(CDC *pDC, int x0, int y0, int x1, int y1) | CXTPDockingPanePaintManager |
m_arrColor | CXTPDockingPanePaintManager | protected
m_bDestroyCustomTitleBrushes | CXTPDockingPanePaintManager | protected
m_bDrawCaptionIcon | CXTPDockingPanePaintManager |
m_bDrawGripper | CXTPDockingPaneOffice2003Theme |
m_bDrawSingleTab | CXTPDockingPanePaintManager |
m_bGradientCaption | CXTPDockingPaneVisualStudio2003Theme | protected
m_bHighlightActiveCaption | CXTPDockingPanePaintManager |
m_bLunaTheme | CXTPDockingPanePaintManager | protected
m_bRoundedCaption | CXTPDockingPaneOffice2003Theme | protected
m_bShowCaption | CXTPDockingPanePaintManager |
m_bUseBoldCaptionFont | CXTPDockingPanePaintManager |
m_bUseOfficeFont | CXTPDockingPanePaintManager | protected
m_bUseStandardFont | CXTPDockingPanePaintManager | protected
m_clrActiveCaption | CXTPDockingPanePaintManager |
m_clrActiveCaptionText | CXTPDockingPanePaintManager |
m_clrBackground | CXTPDockingPanePaintManager |
m_clrDisabledCaptionText | CXTPDockingPanePaintManager |
m_clrNormalCaption | CXTPDockingPanePaintManager |
m_clrNormalCaptionText | CXTPDockingPanePaintManager |
m_clrSplitter | CXTPDockingPanePaintManager |
m_clrSplitterGradient | CXTPDockingPanePaintManager |
m_clrSplitterGripper | CXTPDockingPanePaintManager |
m_dwSplitterStyle | CXTPDockingPanePaintManager | protected
m_hbrActiveTitleHorz | CXTPDockingPanePaintManager | protected
m_hbrActiveTitleVert | CXTPDockingPanePaintManager | protected
m_hbrInactiveTitleHorz | CXTPDockingPanePaintManager | protected
m_hbrInactiveTitleVert | CXTPDockingPanePaintManager | protected
m_nCaptionButtonStyle | CXTPDockingPanePaintManager | protected
m_nCaptionFontGap | CXTPDockingPanePaintManager | protected
m_nSplitterIndent | CXTPDockingPanePaintManager |
m_nSplitterSize | CXTPDockingPanePaintManager |
m_nTabsHeight | CXTPDockingPanePaintManager | protected
m_nTitleHeight | CXTPDockingPanePaintManager | protected
m_pPanelPaintManager | CXTPDockingPanePaintManager | protected
m_pTabPaintManager | CXTPDockingPanePaintManager | protected
m_rcCaptionMargin | CXTPDockingPanePaintManager | protected
m_strOfficeFont | CXTPDockingPanePaintManager | protected
m_systemTheme | CXTPDockingPanePaintManager | protected
m_themeButton | CXTPDockingPanePaintManager | protected
m_themeCurrent | CXTPDockingPanePaintManager | protected
m_themeExplorer | CXTPDockingPanePaintManager | protected
m_themeRebar | CXTPDockingPanePaintManager | protected
m_themeToolbar | CXTPDockingPanePaintManager | protected
m_themeWindow | CXTPDockingPanePaintManager | protected
m_xtpFontTitle | CXTPDockingPanePaintManager | protected
m_xtpFontTitleVertical | CXTPDockingPanePaintManager | protected
Pixel(CDC *pDC, int xPos, int yPos, int nPen) | CXTPDockingPanePaintManager |
Rectangle(CDC *pDC, CRect rc, int nPenEntry, int nPenBorder) | CXTPDockingPanePaintManager |
RefreshMetrics() | CXTPDockingPaneOffice2003Theme | virtual
SetCaptionButtonStyle(XTPDockingPaneCaptionButtonStyle nStyle) | CXTPDockingPanePaintManager |
SetCaptionFontIndirect(LOGFONT *pLogFont, BOOL bUseStandardFont=FALSE) | CXTPDockingPanePaintManager |
SetColors(int cElements, CONST INT *lpaElements, CONST COLORREF *lpaRgbValues) | CXTPDockingPanePaintManager |
SetCustomTitleBrushes(HBRUSH hbrActiveTitleHorz, HBRUSH hbrInactiveTitleHorz=NULL, HBRUSH hbrActiveTitleVert=NULL, HBRUSH hbrInactiveTitleVert=NULL, BOOL bDestroyOnCleanup=FALSE) | CXTPDockingPanePaintManager |
SetLunaTheme(XTPCurrentSystemTheme systemTheme) | CXTPDockingPanePaintManager |
SetPanelPaintManager(CXTPTabPaintManager *pManager) | CXTPDockingPanePaintManager |
SetSplitterStyle(DWORD dwStyle) | CXTPDockingPanePaintManager |
SetTabPaintManager(CXTPTabPaintManager *pManager) | CXTPDockingPanePaintManager |
UseOfficeFont(BOOL bUseOfficeFont) | CXTPDockingPanePaintManager |
~CXTPDockingPaneOffice2003Theme() | CXTPDockingPaneOffice2003Theme | virtual
~CXTPDockingPanePaintManager() | CXTPDockingPanePaintManager | protectedvirtual


Toolkit Pro: Member List

CXTPProgressCtrlThemeVisualStudio2015 Member List

This is the complete list of members for CXTPProgressCtrlThemeVisualStudio2015, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPProgressCtrlPaintManager() | CXTPProgressCtrlPaintManager |
CXTPProgressCtrlThemeOffice2000() | CXTPProgressCtrlThemeOffice2000 |
CXTPProgressCtrlThemeOffice2013() | CXTPProgressCtrlThemeOffice2013 |
CXTPProgressCtrlThemeVisualStudio2015() | CXTPProgressCtrlThemeVisualStudio2015 |
DeflateRect(XTPPROGRESSDRAWSTRUCT &ds) | CXTPProgressCtrlPaintManager | protectedvirtual
Draw(XTPPROGRESSDRAWSTRUCT &ds) | CXTPProgressCtrlThemeOffice2013 | virtual
DrawNcBorders(CDC *pDC, CRect rc) | CXTPProgressCtrlThemeOffice2013 | virtual
DrawText(XTPPROGRESSDRAWSTRUCT &ds) | CXTPProgressCtrlPaintManager | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetBackColor() | CXTPProgressCtrlPaintManager |
GetBarColor() | CXTPProgressCtrlPaintManager |
GetBorderColor() | CXTPProgressCtrlPaintManager |
GetTextColor() | CXTPProgressCtrlPaintManager |
m_bUseWinTheme | CXTPProgressCtrlPaintManager | protected
m_clrBack | CXTPProgressCtrlPaintManager | protected
m_clrBar | CXTPProgressCtrlPaintManager | protected
m_clrBarText | CXTPProgressCtrlPaintManager | protected
m_clrBorder | CXTPProgressCtrlPaintManager | protected
m_clrText | CXTPProgressCtrlPaintManager | protected
m_nTheme | CXTPProgressCtrlPaintManager | protected
m_winTheme | CXTPProgressCtrlPaintManager | protected
RefreshMetrics() | CXTPProgressCtrlThemeVisualStudio2015 | virtual
SetBackColor(COLORREF clrNew) | CXTPProgressCtrlPaintManager |
SetBarColor(COLORREF clrNew) | CXTPProgressCtrlPaintManager |
SetBorderColor(COLORREF clrNew) | CXTPProgressCtrlPaintManager |
SetTextColor(COLORREF clrNew) | CXTPProgressCtrlPaintManager |
UseWinThemes(BOOL bUseWinThemes=TRUE) | CXTPProgressCtrlPaintManager |
UsingWinThemes(BOOL bCheckReady=FALSE) | CXTPProgressCtrlPaintManager |
~CXTPProgressCtrlPaintManager() | CXTPProgressCtrlPaintManager | virtual


Toolkit Pro: XTPCalendarTimeLineViewTimeScale.h Source File

  • Source
  • Calendar
XTPCalendarTimeLineViewTimeScale.h
Go to the documentation of this file.
1
22#ifndef _XTPCALENDARTIMELINEVIEWTIMESCALE_H__
23#define _XTPCALENDARTIMELINEVIEWTIMESCALE_H__
24
25#if _MSC_VER > 1000
26# pragma once
27#endif // _MSC_VER > 1000
28
29#include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
30
31struct XTPCALENDARHITTESTINFO_TIMELINE_VIEW;
32class CXTPCalendarTimeLineView;
33class CXTPCalendarTLV_TimeScaleParams;
34class CXTPCalendarTimeLineViewTimeScalePart;
35
40enum XTPEnumCalendarDateItem
41{
42 xtpDTScale_Unknown = 0,
44 xtpDTScale_Sec = 0x0001,
45 xtpDTScale_Min = 0x0002,
46 xtpDTScale_Hour = 0x0004,
47 xtpDTScale_Day = 0x0010,
48 xtpDTScale_WorkWeek = 0x0015,
49 xtpDTScale_Week = 0x0020,
50 xtpDTScale_Month = 0x0040,
51 xtpDTScale_Year = 0x0080,
52};
53
58struct XTP_CALENDAR_TIMELINE_VIEW_SCALE
59{
60 int m_eType;
61 int m_nValue;
62};
63
69class _XTP_EXT_CLASS CXTPCalendarTimeLineViewTimeScale : public CXTPCmdTarget
70{
71public:
78 CXTPCalendarTimeLineViewTimeScale(CXTPCalendarTimeLineView* pView);
79
87 virtual ~CXTPCalendarTimeLineViewTimeScale();
88
95 CXTPCalendarTimeLineView* GetView() const;
96
103 virtual CXTPCalendarTLV_TimeScaleParams* GetTimeScaleParams() const;
104
113 virtual void SetTimeScaleParams(int eTimeScaleParamsID);
114
122 virtual void SetTimeScaleParams2(CXTPCalendarTLV_TimeScaleParams* pSParams);
123
130 virtual COleDateTime GetStartViewDate() const;
131
138 virtual void SetStartViewDate(COleDateTime dt);
139
147 virtual void AdjustLayout(CRect rcParentRect);
148
158 virtual CRect GetClientRect(int nYstart = 0);
159
166 virtual CRect GetRect() const;
167
175 virtual void Draw(CDC* pDC);
176
192 virtual BOOL HitTestEx(CPoint pt, XTP_CALENDAR_HITTESTINFO* pHitTest) const;
193
194 CRect m_rcScale;
196protected:
197 CXTPCalendarTimeLineView* m_pParentView;
198 COleDateTime m_dtStartViewDate;
199 CRect m_rcRect;
200 CXTPCalendarTLV_TimeScaleParams* m_pTimeScaleParams;
202};
203
208class _XTP_EXT_CLASS CXTPCalendarTLV_TimeScaleParams : public CXTPCmdTarget
209{
210 friend class CXTPCalendarTimeLineViewTimeScale;
211
212public:
220 CXTPCalendarTLV_TimeScaleParams(int nTimeScaleParamsID,
221 CXTPCalendarTimeLineViewTimeScale* pTimeScale);
222
230 virtual ~CXTPCalendarTLV_TimeScaleParams();
231
238 CXTPCalendarTimeLineViewTimeScale* GetParentTimeScale() const;
239
246 virtual int GetTimeScaleParamsID() const;
247
254 virtual XTP_CALENDAR_TIMELINE_VIEW_SCALE GetTimeLineViewScale() const;
255
262 virtual COleDateTimeSpan GetScaleInterval() const;
263
270 virtual int GetScaleIntervalWidth_px() const;
271
278 virtual COleDateTimeSpan GetTimePerPixel() const;
279
288 virtual COleDateTime CalcScaleIntervalBegin(COleDateTime dtStart);
289
301 virtual CXTPCalendarTimeLineViewTimeScalePart* GetPart() const = 0;
302
303protected:
311 void SetScaleInterval(int eType, int nValue);
312
313 XTP_CALENDAR_TIMELINE_VIEW_SCALE m_scaleInterval;
316 int m_nScaleIntervalWidth_px;
318private:
319 CXTPCalendarTimeLineViewTimeScale* m_pTimeScale;
320 int m_nTimeScaleParamsID;
321};
322
327class _XTP_EXT_CLASS CXTPCalendarTLV_TimeScaleParams_Day : public CXTPCalendarTLV_TimeScaleParams
328{
329public:
336 CXTPCalendarTLV_TimeScaleParams_Day(CXTPCalendarTimeLineViewTimeScale* pTimeScale);
337
345 virtual ~CXTPCalendarTLV_TimeScaleParams_Day();
346
358 virtual CXTPCalendarTimeLineViewTimeScalePart* GetPart() const;
359};
360
365class _XTP_EXT_CLASS CXTPCalendarTLV_TimeScaleParams_Week : public CXTPCalendarTLV_TimeScaleParams
366{
367public:
374 CXTPCalendarTLV_TimeScaleParams_Week(CXTPCalendarTimeLineViewTimeScale* pTimeScale);
375
383 virtual ~CXTPCalendarTLV_TimeScaleParams_Week();
384
396 virtual CXTPCalendarTimeLineViewTimeScalePart* GetPart() const;
397};
398
403class _XTP_EXT_CLASS CXTPCalendarTLV_TimeScaleParams_WorkWeek
404 : public CXTPCalendarTLV_TimeScaleParams
405{
406public:
413 CXTPCalendarTLV_TimeScaleParams_WorkWeek(CXTPCalendarTimeLineViewTimeScale* pTimeScale);
414
422 virtual ~CXTPCalendarTLV_TimeScaleParams_WorkWeek();
423
435 virtual CXTPCalendarTimeLineViewTimeScalePart* GetPart() const;
436};
437
442class _XTP_EXT_CLASS CXTPCalendarTLV_TimeScaleParams_Month : public CXTPCalendarTLV_TimeScaleParams
443{
444public:
451 CXTPCalendarTLV_TimeScaleParams_Month(CXTPCalendarTimeLineViewTimeScale* pTimeScale);
452
460 virtual ~CXTPCalendarTLV_TimeScaleParams_Month();
461
471 virtual CXTPCalendarTimeLineViewTimeScalePart* GetPart() const;
472
473 // virtual CString FormatLowerScaleLabel(COleDateTime dtDateTime);
474 // virtual void DrawLowerScale(CDC* pDC, DATE dtStart, const CRect& rcRect);
475};
476
477class _XTP_EXT_CLASS CXTPCalendarTimeLineViewTimeScaleGrid
478{
479public:
480 CXTPCalendarTimeLineViewTimeScaleGrid(CXTPCalendarTimeLineView* pView);
481 virtual ~CXTPCalendarTimeLineViewTimeScaleGrid();
482
483 void AdjustLayout(CRect rcParentRect);
484 CRect GetRect() const;
485 void Draw(CDC* pDC);
486
487protected:
488 CXTPCalendarTimeLineView* m_pParentView;
489 CRect m_rcRect;
490};
491
492AFX_INLINE CXTPCalendarTimeLineView* CXTPCalendarTimeLineViewTimeScale::GetView() const
493{
494 return m_pParentView;
495}
496AFX_INLINE CXTPCalendarTLV_TimeScaleParams*
497 CXTPCalendarTimeLineViewTimeScale::GetTimeScaleParams() const
498{
499 return m_pTimeScaleParams;
500}
501AFX_INLINE COleDateTime CXTPCalendarTimeLineViewTimeScale::GetStartViewDate() const
502{
503 return m_dtStartViewDate;
504}
505AFX_INLINE void CXTPCalendarTimeLineViewTimeScale::SetStartViewDate(COleDateTime dt)
506{
507 m_dtStartViewDate = dt;
508}
509AFX_INLINE CRect CXTPCalendarTimeLineViewTimeScale::GetRect() const
510{
511 return m_rcRect;
512}
513AFX_INLINE CXTPCalendarTimeLineViewTimeScale*
514 CXTPCalendarTLV_TimeScaleParams::GetParentTimeScale() const
515{
516 return m_pTimeScale;
517}
518AFX_INLINE XTP_CALENDAR_TIMELINE_VIEW_SCALE
519 CXTPCalendarTLV_TimeScaleParams::GetTimeLineViewScale() const
520{
521 return m_scaleInterval;
522}
523AFX_INLINE int CXTPCalendarTLV_TimeScaleParams::GetScaleIntervalWidth_px() const
524{
525 return m_nScaleIntervalWidth_px;
526}
527AFX_INLINE int CXTPCalendarTLV_TimeScaleParams::GetTimeScaleParamsID() const
528{
529 return m_nTimeScaleParamsID;
530}
531
532//============================================================================
533
534#include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
535#endif // (_XTPCALENDARTIMELINEVIEWTIMESCALE_H__)
XTPEnumCalendarDateItem
XTPEnumCalendarDateItem
Predefined set of different scales based on time intervals.
Definition XTPCalendarTimeLineViewTimeScale.h:41
xtpDTScale_Min
@ xtpDTScale_Min
Min scale.
Definition XTPCalendarTimeLineViewTimeScale.h:45
xtpDTScale_Week
@ xtpDTScale_Week
Week scale.
Definition XTPCalendarTimeLineViewTimeScale.h:49
xtpDTScale_WorkWeek
@ xtpDTScale_WorkWeek
WorkWeek scale.
Definition XTPCalendarTimeLineViewTimeScale.h:48
xtpDTScale_Sec
@ xtpDTScale_Sec
Sec scale.
Definition XTPCalendarTimeLineViewTimeScale.h:44
xtpDTScale_Year
@ xtpDTScale_Year
Year scale.
Definition XTPCalendarTimeLineViewTimeScale.h:51
xtpDTScale_Hour
@ xtpDTScale_Hour
Hour scale.
Definition XTPCalendarTimeLineViewTimeScale.h:46
xtpDTScale_Month
@ xtpDTScale_Month
Month scale.
Definition XTPCalendarTimeLineViewTimeScale.h:50
xtpDTScale_Day
@ xtpDTScale_Day
Day scale.
Definition XTPCalendarTimeLineViewTimeScale.h:47
xtpDTScale_Unknown
@ xtpDTScale_Unknown
Typed unknown value.
Definition XTPCalendarTimeLineViewTimeScale.h:42
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCalendarTLV_TimeScaleParams_Day
This class implements Timeline scale params for Day case.
Definition XTPCalendarTimeLineViewTimeScale.h:328
CXTPCalendarTLV_TimeScaleParams_Day::~CXTPCalendarTLV_TimeScaleParams_Day
virtual ~CXTPCalendarTLV_TimeScaleParams_Day()
Default class destructor.
CXTPCalendarTLV_TimeScaleParams_Day::CXTPCalendarTLV_TimeScaleParams_Day
CXTPCalendarTLV_TimeScaleParams_Day(CXTPCalendarTimeLineViewTimeScale *pTimeScale)
Default object constructor.
CXTPCalendarTLV_TimeScaleParams_Day::GetPart
virtual CXTPCalendarTimeLineViewTimeScalePart * GetPart() const
abstract function - real ones are: CXTPCalendarTimeLineViewTimeScalePart* CXTPCalendarTLV_TimeScalePa...
CXTPCalendarTLV_TimeScaleParams_Month
This class implements Timeline scale params for Month case.
Definition XTPCalendarTimeLineViewTimeScale.h:443
CXTPCalendarTLV_TimeScaleParams_Month::GetPart
virtual CXTPCalendarTimeLineViewTimeScalePart * GetPart() const
abstract function - real ones are: CXTPCalendarTimeLineViewTimeScalePart* CXTPCalendarTLV_TimeScalePa...
CXTPCalendarTLV_TimeScaleParams_Month::~CXTPCalendarTLV_TimeScaleParams_Month
virtual ~CXTPCalendarTLV_TimeScaleParams_Month()
Default class destructor.
CXTPCalendarTLV_TimeScaleParams_Month::CXTPCalendarTLV_TimeScaleParams_Month
CXTPCalendarTLV_TimeScaleParams_Month(CXTPCalendarTimeLineViewTimeScale *pTimeScale)
Default object constructor.
CXTPCalendarTLV_TimeScaleParams_Week
This class implements Timeline scale params for Week case.
Definition XTPCalendarTimeLineViewTimeScale.h:366
CXTPCalendarTLV_TimeScaleParams_Week::~CXTPCalendarTLV_TimeScaleParams_Week
virtual ~CXTPCalendarTLV_TimeScaleParams_Week()
Default class destructor.
CXTPCalendarTLV_TimeScaleParams_Week::CXTPCalendarTLV_TimeScaleParams_Week
CXTPCalendarTLV_TimeScaleParams_Week(CXTPCalendarTimeLineViewTimeScale *pTimeScale)
Default object constructor.
CXTPCalendarTLV_TimeScaleParams_Week::GetPart
virtual CXTPCalendarTimeLineViewTimeScalePart * GetPart() const
abstract function - real ones are: CXTPCalendarTimeLineViewTimeScalePart* CXTPCalendarTLV_TimeScalePa...
CXTPCalendarTLV_TimeScaleParams_WorkWeek
This class implements Timeline scale params for WorkWeek case.
Definition XTPCalendarTimeLineViewTimeScale.h:405
CXTPCalendarTLV_TimeScaleParams_WorkWeek::CXTPCalendarTLV_TimeScaleParams_WorkWeek
CXTPCalendarTLV_TimeScaleParams_WorkWeek(CXTPCalendarTimeLineViewTimeScale *pTimeScale)
Default object constructor.
CXTPCalendarTLV_TimeScaleParams_WorkWeek::~CXTPCalendarTLV_TimeScaleParams_WorkWeek
virtual ~CXTPCalendarTLV_TimeScaleParams_WorkWeek()
Default class destructor.
CXTPCalendarTLV_TimeScaleParams_WorkWeek::GetPart
virtual CXTPCalendarTimeLineViewTimeScalePart * GetPart() const
abstract function - real ones are: CXTPCalendarTimeLineViewTimeScalePart* CXTPCalendarTLV_TimeScalePa...
CXTPCalendarTLV_TimeScaleParams
This class implements Timeline scale params.
Definition XTPCalendarTimeLineViewTimeScale.h:209
CXTPCalendarTLV_TimeScaleParams::CalcScaleIntervalBegin
virtual COleDateTime CalcScaleIntervalBegin(COleDateTime dtStart)
Used to calculate scale interval initial position.
CXTPCalendarTLV_TimeScaleParams::GetScaleIntervalWidth_px
virtual int GetScaleIntervalWidth_px() const
Access function to get the current time scale inteval width.
Definition XTPCalendarTimeLineViewTimeScale.h:523
CXTPCalendarTLV_TimeScaleParams::GetTimeScaleParamsID
virtual int GetTimeScaleParamsID() const
Access function to get the current time scale params ID.
Definition XTPCalendarTimeLineViewTimeScale.h:527
CXTPCalendarTLV_TimeScaleParams::~CXTPCalendarTLV_TimeScaleParams
virtual ~CXTPCalendarTLV_TimeScaleParams()
Default class destructor.
CXTPCalendarTLV_TimeScaleParams::GetPart
virtual CXTPCalendarTimeLineViewTimeScalePart * GetPart() const =0
abstract function - real ones are: CXTPCalendarTimeLineViewTimeScalePart* CXTPCalendarTLV_TimeScalePa...
CXTPCalendarTLV_TimeScaleParams::m_scaleInterval
XTP_CALENDAR_TIMELINE_VIEW_SCALE m_scaleInterval
Internal instance with m_eType and m_nValue.
Definition XTPCalendarTimeLineViewTimeScale.h:313
CXTPCalendarTLV_TimeScaleParams::GetTimePerPixel
virtual COleDateTimeSpan GetTimePerPixel() const
Access function to get current time per pixel value.
CXTPCalendarTLV_TimeScaleParams::GetParentTimeScale
CXTPCalendarTimeLineViewTimeScale * GetParentTimeScale() const
Access function to get the current parent time scale object.
Definition XTPCalendarTimeLineViewTimeScale.h:514
CXTPCalendarTLV_TimeScaleParams::GetScaleInterval
virtual COleDateTimeSpan GetScaleInterval() const
Access function to get the current time scale interval.
CXTPCalendarTLV_TimeScaleParams::GetTimeLineViewScale
virtual XTP_CALENDAR_TIMELINE_VIEW_SCALE GetTimeLineViewScale() const
Access function to get the current time scale interval.
Definition XTPCalendarTimeLineViewTimeScale.h:519
CXTPCalendarTLV_TimeScaleParams::SetScaleInterval
void SetScaleInterval(int eType, int nValue)
This member function is used to set the time scale interval m_scaleInterval.
CXTPCalendarTLV_TimeScaleParams::CXTPCalendarTLV_TimeScaleParams
CXTPCalendarTLV_TimeScaleParams(int nTimeScaleParamsID, CXTPCalendarTimeLineViewTimeScale *pTimeScale)
Default object constructor.
CXTPCalendarTLV_TimeScaleParams::m_nScaleIntervalWidth_px
int m_nScaleIntervalWidth_px
Internal value for scale interval (by x).
Definition XTPCalendarTimeLineViewTimeScale.h:316
CXTPCalendarTimeLineView
This class implements a specific view portion of the Calendar control - called Timeline view.
Definition XTPCalendarTimeLineView.h:76
CXTPCalendarTimeLineViewTimeScale
This class implements a specific view portion of the Calendar control called Timeline view scale.
Definition XTPCalendarTimeLineViewTimeScale.h:70
CXTPCalendarTimeLineViewTimeScale::m_rcScale
CRect m_rcScale
internal member to keep time scale rectangle
Definition XTPCalendarTimeLineViewTimeScale.h:194
CXTPCalendarTimeLineViewTimeScale::m_rcRect
CRect m_rcRect
Internal member used for layout adjustment.
Definition XTPCalendarTimeLineViewTimeScale.h:199
CXTPCalendarTimeLineViewTimeScale::GetStartViewDate
virtual COleDateTime GetStartViewDate() const
Access function to get start view date value.
Definition XTPCalendarTimeLineViewTimeScale.h:501
CXTPCalendarTimeLineViewTimeScale::GetTimeScaleParams
virtual CXTPCalendarTLV_TimeScaleParams * GetTimeScaleParams() const
Access function to get time scale params.
Definition XTPCalendarTimeLineViewTimeScale.h:497
CXTPCalendarTimeLineViewTimeScale::AdjustLayout
virtual void AdjustLayout(CRect rcParentRect)
This member function is used to adjust time scale layout depending on the provided parent rectangle.
CXTPCalendarTimeLineViewTimeScale::SetTimeScaleParams2
virtual void SetTimeScaleParams2(CXTPCalendarTLV_TimeScaleParams *pSParams)
Access function to set time scale params from another CXTPCalendarTLV_TimeScaleParams object.
CXTPCalendarTimeLineViewTimeScale::m_dtStartViewDate
COleDateTime m_dtStartViewDate
Internal datetime object to keep start view date.
Definition XTPCalendarTimeLineViewTimeScale.h:198
CXTPCalendarTimeLineViewTimeScale::SetTimeScaleParams
virtual void SetTimeScaleParams(int eTimeScaleParamsID)
Access function to set time scale params from the predefined set XTPEnumCalendarTimeScaleParamsID.
CXTPCalendarTimeLineViewTimeScale::SetStartViewDate
virtual void SetStartViewDate(COleDateTime dt)
Access function to set start view date value.
Definition XTPCalendarTimeLineViewTimeScale.h:505
CXTPCalendarTimeLineViewTimeScale::Draw
virtual void Draw(CDC *pDC)
This member function is used to draw the time scale for the specified device context.
CXTPCalendarTimeLineViewTimeScale::m_pTimeScaleParams
CXTPCalendarTLV_TimeScaleParams * m_pTimeScaleParams
Internal pointer to CXTPCalendarTLV_TimeScaleParams.
Definition XTPCalendarTimeLineViewTimeScale.h:200
CXTPCalendarTimeLineViewTimeScale::m_pParentView
CXTPCalendarTimeLineView * m_pParentView
Internal pointer to parent view.
Definition XTPCalendarTimeLineViewTimeScale.h:197
CXTPCalendarTimeLineViewTimeScale::~CXTPCalendarTimeLineViewTimeScale
virtual ~CXTPCalendarTimeLineViewTimeScale()
Default class destructor.
CXTPCalendarTimeLineViewTimeScale::CXTPCalendarTimeLineViewTimeScale
CXTPCalendarTimeLineViewTimeScale(CXTPCalendarTimeLineView *pView)
Default object constructor.
CXTPCalendarTimeLineViewTimeScale::GetView
CXTPCalendarTimeLineView * GetView() const
This member function is used to obtain the owner view object.
Definition XTPCalendarTimeLineViewTimeScale.h:492
CXTPCalendarTimeLineViewTimeScale::GetRect
virtual CRect GetRect() const
Access function to get time scale rectangle.
Definition XTPCalendarTimeLineViewTimeScale.h:509
CXTPCalendarTimeLineViewTimeScale::GetClientRect
virtual CRect GetClientRect(int nYstart=0)
Access function to get client rectangle according to passed vertical start position.
CXTPCalendarTimeLineViewTimeScale::HitTestEx
virtual BOOL HitTestEx(CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const
This member function is used to determine which view item, if any, is at a specified position index,...
CXTPCalendarTimeLineViewTimeScalePart
Helper base class to implement parts for calendar paint manager.
Definition XTPCalendarViewPart.h:1394
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
XTP_CALENDAR_HITTESTINFO
Basic set of parameters transferred from calendar items to mouse handlers.
Definition XTPCalendarDefines.h:856
XTP_CALENDAR_TIMELINE_VIEW_SCALE
Timeline's view scale.
Definition XTPCalendarTimeLineViewTimeScale.h:59
XTP_CALENDAR_TIMELINE_VIEW_SCALE::m_nValue
int m_nValue
Number of days to show (e.g.
Definition XTPCalendarTimeLineViewTimeScale.h:61
XTP_CALENDAR_TIMELINE_VIEW_SCALE::m_eType
int m_eType
One of the values from enum XTPEnumCalendarDateItem.
Definition XTPCalendarTimeLineViewTimeScale.h:60


Toolkit Pro: Member List

CXTPControlListBox Member List

This is the complete list of members for CXTPControlListBox, including all inherited members.

AssignDocTemplate(UINT nIDResource) | CXTPControl |
ClickToolBarButton(CRect rcActiveRect=CRect(0, 0, 0, 0)) | CXTPControl | protected
Compare(CXTPControl *pOther) | CXTPControl | virtual
Copy(CXTPControl *pControl, BOOL bRecursive=FALSE) | CXTPControlListBox | protectedvirtual
CustomizeStartDrag(CPoint point) | CXTPControl | protectedvirtual
CustomizeStartResize(CPoint point) | CXTPControl | protectedvirtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPControl() | CXTPControl | protected
CXTPControlListBox() | CXTPControlListBox |
DelayLayoutParent() | CXTPControl |
DelayRedrawParent() | CXTPControl |
DoCustomDragOver(CXTPCommandBar *pCommandBar, CPoint point, DROPEFFECT &dropEffect) | CXTPControl | protectedvirtual
DoPropExchange(CXTPPropExchange *pPX) | CXTPControlListBox | protectedvirtual
Draw(CDC *pDC) | CXTPControlListBox | protectedvirtual
ExcludeDocTemplate(UINT nIDResource) | CXTPControl |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
FromUI(CCmdUI *pCmdUI) | CXTPControl | static
GenerateCommandBarList(DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam) | CXTPControl | protectedvirtual
GetAction() const | CXTPControl |
GetBeginGroup() const | CXTPControl |
GetButtonSize() const | CXTPControl | virtual
GetCaption() const | CXTPControl | virtual
GetCategory() const | CXTPControl |
GetChecked() const | CXTPControl |
GetCloseSubMenuOnClick() const | CXTPControl |
GetCommandBar() const | CXTPControl | virtual
GetControls() const | CXTPControl |
GetCustomizeMinHeight() const | CXTPControl | protectedvirtual
GetCustomizeMinWidth() const | CXTPControl | protectedvirtual
GetCustomShortcutText() const | CXTPControl |
GetDescription() const | CXTPControl | virtual
GetEnabled() const | CXTPControl |
GetExecuteOnPressInterval() const | CXTPControl |
GetExpanded() const | CXTPControl |
GetFlags() const | CXTPControl |
GetHeight() const | CXTPControl |
GetHelpId() const | CXTPControl |
GetHideFlags() const | CXTPControl |
GetIconId() const | CXTPControl |
GetIconSize() const | CXTPControl | virtual
GetID() const | CXTPControl |
GetImage(int nWidth=16) const | CXTPControl | virtual
GetImageManager() const | CXTPControl |
GetIndex() const | CXTPControl |
GetKeyboardTip() const | CXTPControl |
GetListCtrl() const | CXTPControlListBox |
GetPaintManager() const | CXTPControl |
GetParameter() const | CXTPControl |
GetParent() const | CXTPControl |
GetPopuped() const | CXTPControl | virtual
GetPressed() const | CXTPControl | virtual
GetRect() const | CXTPControl |
GetRibbonGroup() const | CXTPControl |
GetRowRect() const | CXTPControl |
GetSelected() const | CXTPControl | virtual
GetShortcutText() const | CXTPControl |
GetSize(CDC *pDC) | CXTPControlListBox | protectedvirtual
GetStyle() const | CXTPControl |
GetTag() const | CXTPControl |
GetTooltip() const | CXTPControl | virtual
GetType() const | CXTPControl |
GetWidth() const | CXTPControl |
GetWrap() const | CXTPControl |
HasDwmCompositedRect() const | CXTPControl |
IsCaptionVisible() const | CXTPControl | virtual
IsCursorOver() const | CXTPControl |
IsCustomizeMode() const | CXTPControl | protected
IsCustomizeMovable() const | CXTPControl | virtual
IsCustomizeResizeAllow() const | CXTPControl | protectedvirtual
IsFocusable() const | CXTPControl | protectedvirtual
IsFocused() const | CXTPControlListBox | protectedvirtual
IsItemDefault() const | CXTPControl |
IsLayoutChanged() | CXTPControl | protected
IsLayoutRTL() const | CXTPControl | protected
IsOnQuickAccess() const | CXTPControl |
IsTemporary() const | CXTPControl |
IsTransparent() const | CXTPControl | inlinevirtual
IsVisible(DWORD dwSkipFlags=0) const | CXTPControl | virtual
m_bBeginGroup | CXTPControl | protected
m_bChecked | CXTPControl | protected
m_bCloseSubMenuOnClick | CXTPControl | protected
m_bDefaultItem | CXTPControl | protected
m_bEnabled | CXTPControl | protected
m_bExpanded | CXTPControl | protected
m_bLayoutRTL | CXTPControl | protected
m_bMouseLocked | CXTPControlListBox | protected
m_bMultiplSel | CXTPControlListBox | protected
m_bOnQuickAccess | CXTPControl | protected
m_bPressed | CXTPControl | protected
m_bSelected | CXTPControl | protected
m_bTemporary | CXTPControl | protected
m_buttonCustomStyle | CXTPControl | protected
m_buttonRibbonStyle | CXTPControl | protected
m_buttonStyle | CXTPControl | protected
m_bWrap | CXTPControl | protected
m_controlType | CXTPControl | protected
m_dwFlags | CXTPControl | protected
m_dwHideFlags | CXTPControl | protected
m_mapDocTemplatesAssigned | CXTPControl | protected
m_mapDocTemplatesExcluded | CXTPControl | protected
m_nCustomIconId | CXTPControl | protected
m_nExecuteOnPressInterval | CXTPControl | protected
m_nHeight | CXTPControl | protected
m_nHelpId | CXTPControl | protected
m_nIconId | CXTPControl | protected
m_nId | CXTPControl | protected
m_nIndex | CXTPControl | protected
m_nListBoxLinesMax | CXTPControlListBox | protected
m_nListBoxLinesMin | CXTPControlListBox | protected
m_nTag | CXTPControl | protected
m_nWidth | CXTPControl | protected
m_pAction | CXTPControl | protected
m_pControls | CXTPControl | protected
m_pListBox | CXTPControlListBox | protected
m_pParent | CXTPControl | protected
m_pRibbonGroup | CXTPControl | protected
m_rcControl | CXTPControl | protected
m_rcRow | CXTPControl | protected
m_strCaption | CXTPControl | protected
m_strCategory | CXTPControl | protected
m_strCustomCaption | CXTPControl | protected
m_strDescriptionText | CXTPControl | protected
m_strKeyboardTip | CXTPControl | protected
m_strParameter | CXTPControl | protected
m_strShortcutText | CXTPControl | protected
m_strShortcutTextAuto | CXTPControl | protected
m_strTooltipText | CXTPControl | protected
m_szIcon | CXTPControl | protected
NotifySite(UINT code) | CXTPControl |
NotifySite(UINT code, NMXTPCONTROL *pNM) | CXTPControl |
NotifySite(CWnd *pSite, UINT code, NMXTPCONTROL *pNM) | CXTPControl |
OnActionChanged(int nProperty) | CXTPControl | protectedvirtual
OnActionChanging(int nProperty) | CXTPControl | protectedvirtual
OnCalcDynamicSize(DWORD dwMode) | CXTPControlListBox | protectedvirtual
OnCaptionChanged() | CXTPControl | protectedvirtual
OnClick(BOOL bKeyboard=FALSE, CPoint pt=CPoint(0, 0)) | CXTPControlListBox | protectedvirtual
OnCustomizeDragOver(CXTPControl *pDataObject, CPoint point, DROPEFFECT &dropEffect) | CXTPControl | protectedvirtual
OnCustomizeMouseMove(CPoint point) | CXTPControl | protected
OnEnabledChanged() | CXTPControlListBox | virtual
OnExecute() | CXTPControl | virtual
OnHookKeyDown(UINT nChar, LPARAM lParam) | CXTPControlListBox | protectedvirtual
OnHookMouseWheel(UINT nFlags, short zDelta, CPoint point) | CXTPControl | protectedvirtual
OnIdleUpdate() | CXTPControl | protectedvirtual
OnLButtonDblClk(CPoint point) | CXTPControl | protectedvirtual
OnLButtonDown(CPoint point) | CXTPControl | protectedvirtual
OnLButtonUp(CPoint point) | CXTPControl | protectedvirtual
OnMouseHover() | CXTPControl | protectedvirtual
OnMouseMove(CPoint point) | CXTPControl | protectedvirtual
OnRButtonDown(CPoint point) | CXTPControl | protectedvirtual
OnRButtonUp(CPoint point) | CXTPControl | protectedvirtual
OnRemoved() | CXTPControl | protectedvirtual
OnSetPopup(BOOL bPopup) | CXTPControl | protectedvirtual
OnSetSelected(int bSelected) | CXTPControlListBox | protectedvirtual
OnThemeChanged() | CXTPControl | virtual
OnToolHitTest(CPoint point, TOOLINFO *pTI) const | CXTPControl | protectedvirtual
OnUnderlineActivate() | CXTPControl | virtual
RedrawParent(BOOL bAnimate=TRUE) | CXTPControl |
Reset() | CXTPControl |
RestoreCommandBarList(CXTPCommandBarList *pCommandBarList) | CXTPControl | protectedvirtual
ScreenToClient(CPoint *point) | CXTPControl | protected
SetAction(CXTPControlAction *pAction) | CXTPControl | virtual
SetBeginGroup(BOOL bBeginGroup) | CXTPControl | virtual
SetCaption(LPCTSTR lpszCaption) | CXTPControl |
SetCaption(UINT nIDCaption) | CXTPControl |
SetCategory(LPCTSTR lpszCategory) | CXTPControl |
SetChecked(BOOL bChecked) | CXTPControl | virtual
SetCloseSubMenuOnClick(BOOL bCloseOnClick) | CXTPControl |
SetCustomIcon(HICON hIcon) | CXTPControl |
SetCustomShortcutText(LPCTSTR lpszCustomShortcutText) | CXTPControl |
SetDescription(LPCTSTR lpszDescription) | CXTPControl |
SetEnabled(BOOL bEnabled) | CXTPControl | virtual
SetExecuteOnPressInterval(int nExecuteOnPressInterval) | CXTPControl |
SetExpanded(BOOL bExpanded) | CXTPControl | protected
SetFlags(DWORD dwFlags) | CXTPControl |
SetFocused(BOOL bFocused) | CXTPControl | virtual
SetHeight(int nHeight) | CXTPControl | virtual
SetHelpId(int nId) | CXTPControl |
SetHideFlag(XTPControlHideFlags dwFlag, BOOL bSet) | CXTPControl |
SetHideFlags(DWORD dwFlags) | CXTPControl | virtual
SetHideWrap(BOOL bHide) | CXTPControl |
SetIconId(int nId) | CXTPControl |
SetIconSize(CSize szIcon) | CXTPControl |
SetID(int nId) | CXTPControl |
SetIndex(int nIndex) | CXTPControl | inlineprotected
SetItemDefault(BOOL bDefault) | CXTPControl |
SetKeyboardTip(LPCTSTR lpszKeyboardTip) | CXTPControl |
SetLinesMinMax(int nMin, int nMax) | CXTPControlListBox |
SetMultiplSel(BOOL bMultiplSel) | CXTPControlListBox |
SetOnQuickAccess(BOOL bOnQuicAccess=FALSE) | CXTPControl |
SetParameter(LPCTSTR lpszParameter) | CXTPControl |
SetParent(CXTPCommandBar *pParent) | CXTPControlListBox | protectedvirtual
SetPressed(BOOL bPressed) | CXTPControl |
SetPrompt(LPCTSTR lpszPrompt) | CXTPControl |
SetRect(CRect rcControl) | CXTPControlListBox | protectedvirtual
SetRowRect(CRect rcRow) | CXTPControl |
SetShortcutText(LPCTSTR lpszShortcutText) | CXTPControl |
SetStyle(XTPButtonStyle buttonStyle) | CXTPControl |
SetTag(DWORD_PTR dwTag) | CXTPControl |
SetTooltip(LPCTSTR lpszTooltip) | CXTPControl |
SetVisible(BOOL bVisible) | CXTPControl |
SetWidth(int nWidth) | CXTPControlListBox | virtual
SetWrap(BOOL bWrap) | CXTPControl |
~CXTPControl() | CXTPControl | protectedvirtual
~CXTPControlListBox() | CXTPControlListBox | virtual


Toolkit Pro: Member List

CXTPGridRecordItemPreview Member List

This is the complete list of members for CXTPGridRecordItemPreview, including all inherited members.

AddHyperlink(CXTPGridHyperlink *pHyperlink) | CXTPGridRecordItem | virtual
Compare(CXTPGridColumn *pColumn, CXTPGridRecordItem *pItem) | CXTPGridRecordItem | virtual
CompareGroupCaption(CXTPGridColumn *pColumn, CXTPGridRecordItem *pItem) | CXTPGridRecordItem | virtual
CompareGroupCaption(CXTPGridColumn *pColumn, CXTPGridGroupRow *pGroupRow) | CXTPGridRecordItem | virtual
CreateBorder() | CXTPGridRecordItem |
CXTPCmdTarget() | CXTPCmdTarget |
CXTPGridRecordItem() | CXTPGridRecordItem |
CXTPGridRecordItemPreview(LPCTSTR szPreviewText=_T("")) | CXTPGridRecordItemPreview |
DestroyBorder() | CXTPGridRecordItem |
DoPropExchange(CXTPPropExchange *pPX) | CXTPGridRecordItemPreview | virtual
Draw(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs) | CXTPGridRecordItem | virtual
DrawCheckBox(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CRect &rcItem) | CXTPGridRecordItem | protectedvirtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAlignment() const | CXTPGridRecordItem |
GetBackgroundColor() | CXTPGridRecordItem | virtual
GetBorder() const | CXTPGridRecordItem |
GetCanEditCheckboxItem() const | CXTPGridRecordItem |
GetCaption(CXTPGridColumn *pColumn) | CXTPGridRecordItemPreview | virtual
GetCaption() | CXTPGridRecordItemPreview | virtual
GetCaptionRect(XTP_GRIDRECORDITEM_ARGS *pDrawArgs, CRect &rcItem) | CXTPGridRecordItemPreview | virtual
GetCheckedState() const | CXTPGridRecordItem |
GetColumnCaptionPrefix(CXTPGridColumn *pColumn) const | CXTPGridRecordItem |
GetEditOptions(CXTPGridColumn *pColumn) | CXTPGridRecordItem |
GetFont() | CXTPGridRecordItem | virtual
GetFormatString() const | CXTPGridRecordItem | virtual
GetFormula() const | CXTPGridRecordItem | virtual
GetGroupCaption(CXTPGridColumn *pColumn) | CXTPGridRecordItem | virtual
GetGroupCaptionID(CXTPGridColumn *pColumn) | CXTPGridRecordItem | virtual
GetGroupCaptionValue(CXTPGridColumn *pColumn) | CXTPGridRecordItem | virtual
GetGroupPriority() const | CXTPGridRecordItem | virtual
GetHasCheckbox() const | CXTPGridRecordItem | virtual
GetHyperlinkAt(int nHyperlink) const | CXTPGridRecordItem | virtual
GetHyperlinks() | CXTPGridRecordItem | protected
GetHyperlinksCount() const | CXTPGridRecordItem | virtual
GetIconIndex() const | CXTPGridRecordItem | virtual
GetIndex() const | CXTPGridRecordItem |
GetItemControls() | CXTPGridRecordItem |
GetItemData() const | CXTPGridRecordItem | virtual
GetItemMetrics(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pItemMetrics) | CXTPGridRecordItemPreview | virtual
GetMarkupUIElement() const | CXTPGridRecordItem |
GetPreviewHeight(CDC *pDC, CXTPGridRow *pRow, int nWidth) | CXTPGridRecordItemPreview | virtual
GetPreviewText() | CXTPGridRecordItemPreview | virtual
GetRecord() const | CXTPGridRecordItem |
GetSelectedConstraintData(XTP_GRIDRECORDITEM_ARGS *pItemArgs) | CXTPGridRecordItem | virtual
GetSortPriority() const | CXTPGridRecordItem | virtual
GetTextColor() | CXTPGridRecordItem | virtual
GetTooltip() const | CXTPGridRecordItem | virtual
HasCheckbox(BOOL bHasCheckbox, BOOL bTristate=FALSE) | CXTPGridRecordItem | virtual
HitTest(CPoint ptPoint) | CXTPGridRecordItem |
HitTestHyperlink(CPoint ptClick) | CXTPGridRecordItem | virtual
IsBold() const | CXTPGridRecordItem | virtual
IsChecked() const | CXTPGridRecordItem | virtual
IsChildOfMerge() const | CXTPGridRecordItem |
IsEditable() const | CXTPGridRecordItem | virtual
IsFocusable() const | CXTPGridRecordItem | virtual
IsPreviewItem() const | CXTPGridRecordItemPreview | virtual
m_Alignment | CXTPGridRecordItem | protected
m_bBoldText | CXTPGridRecordItem | protected
m_bCanEditCheckboxItem | CXTPGridRecordItem | protected
m_bEditable | CXTPGridRecordItem | protected
m_bFocusable | CXTPGridRecordItem | protected
m_bHasCheckbox | CXTPGridRecordItem | protected
m_bItemControlUnderMouse | CXTPGridRecordItem | protected
m_bTristateCheckbox | CXTPGridRecordItem | protected
m_checkState | CXTPGridRecordItem | protected
m_clrBackground | CXTPGridRecordItem | protected
m_clrText | CXTPGridRecordItem | protected
m_dwData | CXTPGridRecordItem | protected
m_nGroupPriority | CXTPGridRecordItem | protected
m_nIconIndex | CXTPGridRecordItem | protected
m_nSortPriority | CXTPGridRecordItem | protected
m_pBorder | CXTPGridRecordItem | protected
m_pControl | CXTPGridRecordItem | protected
m_pEditOptions | CXTPGridRecordItem | protected
m_pFocusedItemControl | CXTPGridRecordItem | protected
m_pFontCaption | CXTPGridRecordItem | protected
m_pHyperlinks | CXTPGridRecordItem | protected
m_pItemControlHookWnd | CXTPGridRecordItem | protected
m_pItemControls | CXTPGridRecordItem | protected
m_pMarkupUIElement | CXTPGridRecordItem | protected
m_pRecord | CXTPGridRecordItem | protected
m_rcGlyph | CXTPGridRecordItem | protected
m_strCaption | CXTPGridRecordItem | protected
m_strFormatString | CXTPGridRecordItem | protected
m_strFormula | CXTPGridRecordItem | protected
m_strGroupCaption | CXTPGridRecordItem | protected
m_strPreviewText | CXTPGridRecordItemPreview | protected
m_strTooltip | CXTPGridRecordItem | protected
OnBeginEdit(XTP_GRIDRECORDITEM_ARGS *pItemArgs) | CXTPGridRecordItemPreview | protectedvirtual
OnCancelEdit(CXTPGridControl *pControl, BOOL bApply) | CXTPGridRecordItem | virtual
OnChar(XTP_GRIDRECORDITEM_ARGS *pItemArgs, UINT nChar) | CXTPGridRecordItem | protectedvirtual
OnClick(XTP_GRIDRECORDITEM_CLICKARGS *pClickArgs) | CXTPGridRecordItem | virtual
OnConstraintChanged(XTP_GRIDRECORDITEM_ARGS *pItemArgs, CXTPGridRecordItemConstraint *pConstraint) | CXTPGridRecordItem | virtual
OnDblClick(XTP_GRIDRECORDITEM_CLICKARGS *pClickArgs) | CXTPGridRecordItem | virtual
OnDrawCaption(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics) | CXTPGridRecordItemPreview | virtual
OnDrawControls(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CRect &rcItem) | CXTPGridRecordItem | virtual
OnEditCanceled(XTP_GRIDRECORDITEM_ARGS *pItemArgs) | CXTPGridRecordItem | virtual
OnEditChanged(XTP_GRIDRECORDITEM_ARGS *pItemArgs, LPCTSTR szText) | CXTPGridRecordItemPreview | virtual
OnEditChanging(XTP_GRIDRECORDITEM_ARGS *pItemArgs, CString &rstrNewText) | CXTPGridRecordItem | virtual
OnInplaceButtonDown(CXTPGridInplaceButton *pButton) | CXTPGridRecordItem | virtual
OnLButtonDown(XTP_GRIDRECORDITEM_CLICKARGS *pClickArgs) | CXTPGridRecordItem | virtual
OnLButtonUp(XTP_GRIDRECORDITEM_CLICKARGS *pClickArgs) | CXTPGridRecordItem | virtual
OnMouseMove(UINT nFlags, CPoint point, CXTPGridControl *pControl=NULL) | CXTPGridRecordItem | virtual
OnRequestEdit(XTP_GRIDRECORDITEM_ARGS *pItemArgs) | CXTPGridRecordItem | protectedvirtual
OnToolHitTest(CPoint point, TOOLINFO *pTI) | CXTPGridRecordItem | virtual
OnValidateEdit(XTP_GRIDRECORDITEM_ARGS *pItemArgs) | CXTPGridRecordItem | virtual
operator delete(void *p) | CXTPHeapObjectT< CXTPCmdTarget, CXTPGridDataAllocator > | inline
operator new(size_t nSize) | CXTPHeapObjectT< CXTPCmdTarget, CXTPGridDataAllocator > | inline
RemoveHyperlinkAt(int nHyperlink) | CXTPGridRecordItem | virtual
ResetMarkupUIElement() | CXTPGridRecordItem | virtual
SetAlignment(int nAlignment) | CXTPGridRecordItem |
SetBackgroundColor(COLORREF clrBackground) | CXTPGridRecordItem | virtual
SetBold(BOOL bBold=TRUE) | CXTPGridRecordItem | virtual
SetCanEditCheckboxItem(BOOL bSet) | CXTPGridRecordItem |
SetCaption(LPCTSTR strCaption) | CXTPGridRecordItemPreview | virtual
SetChecked(BOOL bChecked) | CXTPGridRecordItem | virtual
SetCheckedState(int iState) | CXTPGridRecordItem |
SetEditable(BOOL bEditable=TRUE) | CXTPGridRecordItem | virtual
SetFocusable(BOOL bFocusable) | CXTPGridRecordItem | virtual
SetFont(CFont *pFont) | CXTPGridRecordItem | virtual
SetFormatString(LPCTSTR strFormat) | CXTPGridRecordItem | virtual
SetFormula(LPCTSTR sFormula) | CXTPGridRecordItem | virtual
SetGridControl(CXTPGridControl *pControl) | CXTPGridRecordItem |
SetGroupCaption(LPCTSTR strCaption) | CXTPGridRecordItem | virtual
SetGroupPriority(int nGroupPriority) | CXTPGridRecordItem | virtual
SetIconIndex(int nIconIndex) | CXTPGridRecordItem | virtual
SetItemData(DWORD_PTR dwData) | CXTPGridRecordItem | virtual
SetPreviewText(LPCTSTR strPreviewText) | CXTPGridRecordItemPreview |
SetRecord(CXTPGridRecord *pGridRecord) | CXTPGridRecordItem |
SetSortPriority(int nSortPriority) | CXTPGridRecordItem | virtual
SetTextColor(COLORREF clrText) | CXTPGridRecordItem | virtual
SetTooltip(LPCTSTR lpszTooltip) | CXTPGridRecordItem | virtual
UpdateValue() | CXTPGridRecordItem |
~CXTPGridRecordItem() | CXTPGridRecordItem | virtual


Toolkit Pro: Member List

CXTPScrollBarCtrl Member List

This is the complete list of members for CXTPScrollBarCtrl, including all inherited members.

CXTPScrollBarCtrl() | CXTPScrollBarCtrl |
CXTPScrollBase() | CXTPScrollBase |
GetCltColor(CDC *pDC) const | CXTPScrollBase |
GetParentWindow() const =0 | CXTPScrollBase | pure virtual
GetScrollBarPaintManager() const | CXTPScrollBarCtrl | virtual
GetScrollBarPartRect(int nPart) const | CXTPScrollBase |
GetScrollBarPosInfo() | CXTPScrollBarCtrl | protected
GetScrollBarRect()=0 | CXTPScrollBase | pure virtual
GetScrollBarStyle() const | CXTPScrollBase |
GetScrollBarTrackInfo() | CXTPScrollBarCtrl | protected
CXTPScrollBase::GetScrollBarTrackInfo() const | CXTPScrollBase |
GetScrollInfo(SCROLLINFO *psi) | CXTPScrollBarCtrl | virtual
GetTicks() const | CXTPScrollBase |
HitTestScrollBar(POINT pt) const | CXTPScrollBase |
Init() | CXTPScrollBarCtrl | protected
IsScrollBarEnabled() const =0 | CXTPScrollBase | pure virtual
IsSlider() const | CXTPScrollBase |
m_bAnimation | CXTPScrollBase | protected
m_bPreSubclassInit | CXTPScrollBarCtrl | protected
m_nTimerElapse | CXTPScrollBase | protected
m_pSBTrack | CXTPScrollBase | protected
m_pTicks | CXTPScrollBase | protected
m_scrollBarStyle | CXTPScrollBase | protected
m_spi | CXTPScrollBase | protected
PerformTrackInit(HWND hWnd, CPoint point, XTP_SCROLLBAR_POSINFO *pSBInfo, BOOL bDirect) | CXTPScrollBase |
RedrawScrollBar()=0 | CXTPScrollBase | pure virtual
RefreshMetrics() | CXTPScrollBarCtrl | virtual
SetScrollBarStyle(XTPScrollBarStyle scrollStyle) | CXTPScrollBase |
SetTheme(XTPScrollBarTheme theme) | CXTPScrollBarCtrl |
SetTicks(double *pTicks, int nCount) | CXTPScrollBase |
~CXTPScrollBarCtrl() | CXTPScrollBarCtrl | virtual
~CXTPScrollBase() | CXTPScrollBase | virtual


Toolkit Pro: XTPImageManagerResource.h Source File

  • Source
  • Common
XTPImageManagerResource.h
Go to the documentation of this file.
1
23#if !defined(__XTPIMAGEMANAGERRESOURCE_H__)
24# define __XTPIMAGEMANAGERRESOURCE_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
37class _XTP_EXT_CLASS CXTPImageManagerResource
38{
39protected:
40public:
48 CXTPImageManagerResource(CXTPImageManager* pImageManager, CSize szIcon);
49
55 ~CXTPImageManagerResource();
56
64 XTP_IMAGERESOURCE_INFO* Add(const CXTPImageManagerIconHandle& hHandle);
65
71 void Clear(XTP_IMAGERESOURCE_INFO* pRInfo);
72
82 void Draw(CDC* pDC, XTP_IMAGERESOURCE_INFO* pRInfo, CPoint pt, CSize szIcon,
83 BOOL bDrawComposited);
84
91 void CreateIcon(CXTPImageManagerIconHandle& hHandle, XTP_IMAGERESOURCE_INFO* pRInfo);
98 CSize GetExtent() const;
99
100private:
101 XTP_IMAGERESOURCE_INFO* AllocBitmap();
102 void RemoveAll();
103 void DrawIconComposited(CDC* pDC, XTP_IMAGERESOURCE_INFO* pRInfo, CPoint pt, CSize szIcon);
104
105protected:
106 HBITMAP m_hbmpImage;
107 HBITMAP m_hbmpMask;
108 CXTPBitmapDC m_dc;
110 BYTE* m_pBits;
111 CXTPImageManager* m_pImageManager;
112 CSize m_szIcon;
113 int m_nAllocWidth;
114 CArray<XTP_IMAGERESOURCE_INFO*, XTP_IMAGERESOURCE_INFO*> m_arrIcons;
115 CArray<XTP_IMAGERESOURCE_INFO*, XTP_IMAGERESOURCE_INFO*> m_arrAlloc;
116 CRITICAL_SECTION m_cs;
118private:
119 friend class CXTPImageManager;
120 friend class CXTPImageManagerIconHandle;
121 friend class CXTPImageManagerIcon;
122};
123
124# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
126#endif // !defined(__XTPIMAGEMANAGERRESOURCE_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPImageManager
CXTPImageManager is a standalone class.
Definition XTPImageManager.h:1898
CXTPImageManagerIconHandle
CXTPImageManagerIconHandle is a HICON wrapper class.
Definition XTPImageManager.h:384
CXTPImageManagerIcon
Icons holder class.
Definition XTPImageManager.h:622
CXTPImageManagerResource
Definition XTPImageManagerResource.h:38
CXTPImageManagerResource::m_arrIcons
CArray< XTP_IMAGERESOURCE_INFO *, XTP_IMAGERESOURCE_INFO * > m_arrIcons
List of used icons.
Definition XTPImageManagerResource.h:114
CXTPImageManagerResource::m_dc
CXTPBitmapDC m_dc
Helper device context class for quick image select.
Definition XTPImageManagerResource.h:108
CXTPImageManagerResource::m_hbmpMask
HBITMAP m_hbmpMask
Handle of bitmap contained mask for images of the resources.
Definition XTPImageManagerResource.h:107
CXTPImageManagerResource::CreateIcon
void CreateIcon(CXTPImageManagerIconHandle &hHandle, XTP_IMAGERESOURCE_INFO *pRInfo)
Creates new icon from bitmap specified by pRInfo parameter.
CXTPImageManagerResource::Add
XTP_IMAGERESOURCE_INFO * Add(const CXTPImageManagerIconHandle &hHandle)
This method is called to add new icon to common bitmap fo resource manger.
CXTPImageManagerResource::m_hbmpImage
HBITMAP m_hbmpImage
Handle of bitmap contained all images of the resources.
Definition XTPImageManagerResource.h:106
CXTPImageManagerResource::Clear
void Clear(XTP_IMAGERESOURCE_INFO *pRInfo)
Clears image in specified position.
CXTPImageManagerResource::m_pImageManager
CXTPImageManager * m_pImageManager
Parent CXTPImageManager object.
Definition XTPImageManagerResource.h:111
CXTPImageManagerResource::m_cs
CRITICAL_SECTION m_cs
Critical section for multithreading support.
Definition XTPImageManagerResource.h:116
CXTPImageManagerResource::m_pBits
BYTE * m_pBits
Bits of m_hbmpImage.
Definition XTPImageManagerResource.h:110
CXTPImageManagerResource::m_nAllocWidth
int m_nAllocWidth
Total allocated with of the resources.
Definition XTPImageManagerResource.h:113
CXTPImageManagerResource::m_szIcon
CSize m_szIcon
Size of images of the resources.
Definition XTPImageManagerResource.h:112
CXTPImageManagerResource::CXTPImageManagerResource
CXTPImageManagerResource(CXTPImageManager *pImageManager, CSize szIcon)
Constructs a CXTPImageManagerResource object used to create common bitmap for all icons of image mana...
CXTPImageManagerResource::~CXTPImageManagerResource
~CXTPImageManagerResource()
Destroys a CXTPImageManagerResource object, handles cleanup and de- allocation.
CXTPImageManagerResource::Draw
void Draw(CDC *pDC, XTP_IMAGERESOURCE_INFO *pRInfo, CPoint pt, CSize szIcon, BOOL bDrawComposited)
This method is called to draw image.
CXTPImageManagerResource::GetExtent
CSize GetExtent() const
Returns size of iconsmanaged by this Resource.
CXTPImageManagerResource::m_arrAlloc
CArray< XTP_IMAGERESOURCE_INFO *, XTP_IMAGERESOURCE_INFO * > m_arrAlloc
List of free icons.
Definition XTPImageManagerResource.h:115
XTP_IMAGERESOURCE_INFO
This structure is used to define the position and style of the icon in resources.
Definition XTPImageManager.h:372


Toolkit Pro: Member List

CXTPExcelTabCtrl Member List

This is the complete list of members for CXTPExcelTabCtrl, including all inherited members.

_DeleteItem(int nItem) | CXTPExcelTabCtrl | protectedvirtual
ButtonHitTest(CPoint &pt) | CXTPExcelTabCtrl | protectedvirtual
ClearAllItems() | CXTPExcelTabCtrl | protected
Create(DWORD dwStyle, const CRect &rect, CWnd *pParentWnd, UINT nID) | CXTPExcelTabCtrl | virtual
CreateButtonIcons() | CXTPExcelTabCtrl | protected
CXTPExcelTabCtrl() | CXTPExcelTabCtrl |
DeleteAllItems() | CXTPExcelTabCtrl | virtual
DeleteItem(int nItem) | CXTPExcelTabCtrl | virtual
DrawGripper(CDC *pDC, CRect rect) const | CXTPExcelTabCtrl | protected
EnableButtons() | CXTPExcelTabCtrl | protected
FreeButtonIcons() | CXTPExcelTabCtrl | protected
GetCurSel() const | CXTPExcelTabCtrl | virtual
GetGripperPosition() const | CXTPExcelTabCtrl |
GetItemCount() const | CXTPExcelTabCtrl | virtual
GetItemRect(int nItem, LPRECT lpRect) | CXTPExcelTabCtrl | virtual
GetItemText(int nIndex) const | CXTPExcelTabCtrl |
GetItemWindow(int nIndex) const | CXTPExcelTabCtrl |
GetOverlap() const | CXTPExcelTabCtrl | protectedvirtual
GetScrollBarCtrl(int nBar) const | CXTPExcelTabCtrl | virtual
GetSelTabBackColor() const | CXTPExcelTabCtrl |
GetSelTabBackColor(int nIndex) const | CXTPExcelTabCtrl |
GetSelTabTextColor() const | CXTPExcelTabCtrl |
GetSelTabTextColor(int nIndex) const | CXTPExcelTabCtrl |
GetTabBackColor() const | CXTPExcelTabCtrl |
GetTabBackColor(int nIndex) const | CXTPExcelTabCtrl |
GetTabFont(BOOL bBold) | CXTPExcelTabCtrl |
GetTabHeight() const | CXTPExcelTabCtrl |
GetTabHighlightColor() const | CXTPExcelTabCtrl |
GetTabItemArray() | CXTPExcelTabCtrl | inline
GetTabShadowColor() const | CXTPExcelTabCtrl |
GetTabsRect() | CXTPExcelTabCtrl |
GetTabStyle() | CXTPExcelTabCtrl |
GetTabTextColor() const | CXTPExcelTabCtrl |
GetTabTextColor(int nIndex) const | CXTPExcelTabCtrl |
GetTabWidth(int nItem) const | CXTPExcelTabCtrl | protected
GetTheme() | CXTPExcelTabCtrl |
GetTipText(int nItem) | CXTPExcelTabCtrl | virtual
GetTotalArrowWidth() const | CXTPExcelTabCtrl | protected
GetTotalButtonRect() const | CXTPExcelTabCtrl | protected
GetTotalTabAreaWidth() const | CXTPExcelTabCtrl | protected
GetTotalTabWidth() const | CXTPExcelTabCtrl | protected
HitTest(TCHITTESTINFO *pHitTestInfo) const | CXTPExcelTabCtrl | virtual
Home() | CXTPExcelTabCtrl | virtual
Init() | CXTPExcelTabCtrl | protectedvirtual
InsertItem(int nItem, UINT nTextID, CWnd *pWndControl=NULL) | CXTPExcelTabCtrl | virtual
InsertItem(int nItem, LPCTSTR lpszItem, CWnd *pWndControl=NULL) | CXTPExcelTabCtrl | virtual
InvalidateTabs() | CXTPExcelTabCtrl | protected
m_bManagingViews | CXTPExcelTabCtrl | protected
m_bPainted | CXTPExcelTabCtrl | protected
m_bSubclassed | CXTPExcelTabCtrl | protected
m_bTracking | CXTPExcelTabCtrl | protected
m_bUserColors | CXTPExcelTabCtrl | protected
m_buttons | CXTPExcelTabCtrl | protected
m_cx | CXTPExcelTabCtrl | protected
m_cy | CXTPExcelTabCtrl | protected
m_dwStyle | CXTPExcelTabCtrl | protected
m_iBtnEnd | CXTPExcelTabCtrl | protected
m_iBtnHilight | CXTPExcelTabCtrl | protected
m_iBtnHome | CXTPExcelTabCtrl | protected
m_iBtnLeft | CXTPExcelTabCtrl | protected
m_iBtnRight | CXTPExcelTabCtrl | protected
m_iGripperPosPerCent | CXTPExcelTabCtrl | protected
m_iTabHeight | CXTPExcelTabCtrl | protected
m_nClientHeight | CXTPExcelTabCtrl | protected
m_nClientWidth | CXTPExcelTabCtrl | protected
m_nCurSel | CXTPExcelTabCtrl | protected
m_nOffset | CXTPExcelTabCtrl | protected
m_pBoldFont | CXTPExcelTabCtrl | protected
m_pNormFont | CXTPExcelTabCtrl | protected
m_pTheme | CXTPExcelTabCtrl | protected
m_pWndLastFocus | CXTPExcelTabCtrl | protected
m_rectGripper | CXTPExcelTabCtrl | protected
m_rectSB_H | CXTPExcelTabCtrl | protected
m_rectTabs | CXTPExcelTabCtrl | protected
m_rectViews | CXTPExcelTabCtrl | protected
m_tcbItems | CXTPExcelTabCtrl | protected
m_ToolTip | CXTPExcelTabCtrl | protected
m_wndHScrollBar | CXTPExcelTabCtrl | protected
m_xGripperPos | CXTPExcelTabCtrl | protected
m_xTrackingDelta | CXTPExcelTabCtrl | protected
RecalcLayout() | CXTPExcelTabCtrl | protectedvirtual
RefreshMetrics() | CXTPExcelTabCtrl | protectedvirtual
ResetMouseOver() | CXTPExcelTabCtrl | protected
SetCurSel(int nItem) | CXTPExcelTabCtrl | virtual
SetGripperPosition(int nPos, bool bPercent) | CXTPExcelTabCtrl |
SetItemText(int nIndex, LPCTSTR pszText) | CXTPExcelTabCtrl |
SetSelTabBackColor(COLORREF crBack) | CXTPExcelTabCtrl |
SetSelTabBackColor(int nIndex, COLORREF crBack) | CXTPExcelTabCtrl |
SetSelTabTextColor(COLORREF crText) | CXTPExcelTabCtrl |
SetSelTabTextColor(int nIndex, COLORREF crText) | CXTPExcelTabCtrl |
SetTabBackColor(COLORREF crBack) | CXTPExcelTabCtrl |
SetTabBackColor(int nIndex, COLORREF crBack) | CXTPExcelTabCtrl |
SetTabFonts(CFont *pNormFont, CFont *pBoldFont) | CXTPExcelTabCtrl | virtual
SetTabHeight(int iTabHeight) | CXTPExcelTabCtrl |
SetTabHighlightColor(COLORREF crHighlight) | CXTPExcelTabCtrl |
SetTabShadowColor(COLORREF crShadow) | CXTPExcelTabCtrl |
SetTabStyle(DWORD dwStyle) | CXTPExcelTabCtrl |
SetTabTextColor(COLORREF crText) | CXTPExcelTabCtrl |
SetTabTextColor(int nIndex, COLORREF crText) | CXTPExcelTabCtrl |
SetTheme(XTPControlTheme eTheme) | CXTPExcelTabCtrl |
SetTipText(int nItem, LPCTSTR lpszTabTip) | CXTPExcelTabCtrl | virtual
SetTracking(bool bTracking) | CXTPExcelTabCtrl | protected
SyncScrollBar() | CXTPExcelTabCtrl |
UpdateDefaultColors() | CXTPExcelTabCtrl |
~CXTPExcelTabCtrl() | CXTPExcelTabCtrl | virtual


Toolkit Pro: Member List

CXTPGridThemeVisualStudio2012Light Member List

This is the complete list of members for CXTPGridThemeVisualStudio2012Light, including all inherited members.

CalcColumnHeight(CDC *pDC, CXTPGridColumn *pColumn, int nTotalWidth=0) | CXTPGridPaintManager | protectedvirtual
CalculateRowHeight(CDC *pDC, const CString &strText, int nMaxWidth, BOOL bWordBreak=TRUE) | CXTPGridPaintManager | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPGridPaintManager() | CXTPGridPaintManager |
CXTPGridThemeOffice2013() | CXTPGridThemeOffice2013 |
CXTPGridThemeVisualStudio2012Light() | CXTPGridThemeVisualStudio2012Light |
DrawBitmap(CDC *pDC, CXTPGridControl *pControl, CRect rcColumn, int iImage) | CXTPGridPaintManager | virtual
DrawCollapsedBitmap(CDC *pDC, const CXTPGridRow *pRow, CRect &rcBitmap) | CXTPGridThemeOffice2013 | virtual
DrawColumn(CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn, BOOL bDrawExternal=FALSE, int nShadowWidth=0) | CXTPGridPaintManager | virtual
DrawColumnBackground(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, BOOL &bColumnPressed, BOOL &bDraggingFromHeader, CXTPGridHeader *pHeader=NULL) | CXTPGridThemeOffice2013 | virtual
DrawColumnFooter(CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn) | CXTPGridPaintManager | virtual
DrawColumnFooterDivider(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn) | CXTPGridPaintManager | virtual
DrawColumnIcon(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, CRect rcIcon, int iIcon) | CXTPGridPaintManager | virtual
DrawColumnText(CDC *pDC, CRect rcText, CString strCaption, int nHeaderAlignment, BOOL bIsHeader, BOOL bColumnPressed) | CXTPGridThemeOffice2013 | virtual
DrawConnector(CDC *pDC, CPoint ptFrom, CPoint ptTo) | CXTPGridPaintManager |
DrawFocusedRow(CDC *pDC, CRect rcRow) | CXTPGridThemeOffice2013 | virtual
DrawFreezeColsDivider(CDC *pDC, const CRect &rc, CXTPGridControl *pControl, CXTPGridRow *pRow=NULL) | CXTPGridPaintManager | virtual
DrawGlyph(CDC *pDC, CRect rcColumn, int iImage) | CXTPGridPaintManager | virtual
DrawGrid(CDC *pDC, XTPGridOrientation orientation, CRect rcGrid) | CXTPGridPaintManager | virtual
DrawGridPattern(CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush) | CXTPGridPaintManager | protectedvirtual
DrawGridPattern(CDC *pDC, CXTPBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush) | CXTPGridPaintManager | protectedvirtual
DrawGridPattern(CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr) | CXTPGridPaintManager | protectedvirtual
DrawGroupRow(CDC *pDC, CXTPGridGroupRow *pRow, CRect rcRow, XTP_GRIDRECORDITEM_METRICS *pMetrics) | CXTPGridThemeOffice2013 | virtual
DrawHorizontalLine(CDC *pDC, int xPos, int yPos, int cx, COLORREF clr) | CXTPGridPaintManager |
DrawInplaceButton(CDC *pDC, CXTPGridInplaceButton *pButton) | CXTPGridPaintManager | virtual
DrawInplaceButtonFrame(CDC *pDC, CXTPGridInplaceButton *pButton) | CXTPGridPaintManager | protectedvirtual
DrawInplaceButtonIcon(CDC *pDC, CXTPGridInplaceButton *pButton) | CXTPGridPaintManager | protectedvirtual
DrawInplaceComboButton(CDC *pDC, CRect *pRc) | CXTPGridPaintManager | virtual
DrawInplaceExpandButton(CDC *pDC, CRect *pRc) | CXTPGridPaintManager | virtual
DrawInplaceSpinButton(CDC *pDC, CRect *pRc) | CXTPGridPaintManager | virtual
DrawItemBitmap(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CRect &rcItem, int nImage) | CXTPGridPaintManager | virtual
DrawItemCaption(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics) | CXTPGridPaintManager | virtual
DrawItemControl(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CXTPGridRecordItemControl *pControl, CRect &rcItem) | CXTPGridPaintManager | virtual
DrawLink(int *pnCurrDrawPos, XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CXTPGridHyperlink *pHyperlink, CString strText, CRect rcLink, int nFlag, BOOL bTrim=FALSE) | CXTPGridPaintManager | protectedvirtual
DrawMultiLineText(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, BOOL bWordBreak=TRUE) | CXTPGridPaintManager | protectedvirtual
DrawNoGroupByText(CDC *pDC, CRect rcItem) | CXTPGridPaintManager | virtual
DrawRowNumber(CDC *pDC, CRect rcNumber, CXTPGridRow *pRow) | CXTPGridPaintManager | virtual
DrawSectionDivider(CDC *pDC, const CRect &rc, XTPGridSectionDividerPosition dividerPosition, XTPGridSectionDividerStyle dividerStyle, CXTPPaintManagerColor dividerColor) | CXTPGridPaintManager |
DrawShellIcon(CDC *pDC, CRect rcColumn, int iImage) | CXTPGridPaintManager | virtual
DrawSingleLineText(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nStartPos, int nEndPos, int nActualWidth) | CXTPGridPaintManager | protectedvirtual
DrawString(int *pnCurrDrawPos, CDC *pDC, const CString &strDraw, CRect rcDraw, UINT nFormat) | CXTPGridPaintManager | protectedvirtual
DrawTextLine(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nFlag, int &nCharCounter, int &nHyperlinkCounter) | CXTPGridPaintManager | protectedvirtual
DrawTreeStructure(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CRect rcItem, CSize sizeGlyph) | CXTPGridPaintManager | virtual
DrawTriangle(CDC *pDC, CRect rcTriangle, BOOL bToDown, BOOL bDraggingFromHeader, int nShadowWidth, BOOL bColumnPressed) | CXTPGridThemeOffice2013 | virtual
DrawVerticalLine(CDC *pDC, int xPos, int yPos, int cy, COLORREF clr) | CXTPGridPaintManager |
DrawVerticalTimeLineMarker(CDC *pDC, int xPos, CXTPGridControl *pControl, COLORREF color=RGB(0, 255, 0)) | CXTPGridPaintManager | virtual
EnablePreviewMode(BOOL bIsPreviewMode) | CXTPGridPaintManager |
FillFooter(CDC *pDC, CRect rcFooter) | CXTPGridPaintManager | virtual
FillGroupByControl(CDC *pDC, CRect &rcGroupBy) | CXTPGridPaintManager | virtual
FillGroupRowMetrics(CXTPGridGroupRow *pRow, XTP_GRIDRECORDITEM_METRICS *pMetrics, BOOL bPrinting) | CXTPGridThemeOffice2013 | virtual
FillHeaderControl(CDC *pDC, CRect rcHeader) | CXTPGridPaintManager | virtual
FillIndent(CDC *pDC, CRect rcRow) | CXTPGridPaintManager | virtual
FillItemShade(CDC *pDC, CRect rcItem) | CXTPGridPaintManager | virtual
FillRow(CDC *pDC, CXTPGridRow *pRow, CRect rcRow) | CXTPGridPaintManager | virtual
FindRowAdjacentToMerged(const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, BOOL bUpward) | CXTPGridPaintManager |
FindRowAdjacentToMergedEx(const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, int &nAdjRowIndex, BOOL bUpward) | CXTPGridPaintManager |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetColumnOffice2007CustomThemeBaseColor() const | CXTPGridPaintManager |
GetColumnStyle() const | CXTPGridPaintManager |
GetControlBackColor(CXTPGridControl *pControl) | CXTPGridPaintManager | virtual
GetFooterHeight(CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0) | CXTPGridPaintManager | virtual
GetFreezeColsDividerStyle() const | CXTPGridPaintManager |
GetGlyphs() const | CXTPGridPaintManager |
GetHeaderHeight() | CXTPGridPaintManager | virtual
GetHeaderHeight(CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0) | CXTPGridPaintManager | virtual
GetItemHeight(XTP_GRIDRECORDITEM_DRAWARGS &drawArgs, int nWidth) | CXTPGridPaintManager |
GetMaxPreviewLines() | CXTPGridPaintManager |
GetPreviewItemHeight(CDC *pDC, CXTPGridRow *pRow, int nWidth, int nHeight) | CXTPGridPaintManager | virtual
GetPreviewLinesCount(CDC *pDC, CRect &rcText, const CString &strText) | CXTPGridPaintManager |
GetRowHeight(CDC *pDC, CXTPGridRow *pRow) | CXTPGridThemeOffice2013 | virtual
GetRowHeight(CDC *pDC, CXTPGridRow *pRow, int nTotalWidth) | CXTPGridThemeOffice2013 | virtual
GetRowHeightEx(CDC *pDC, CXTPGridRow *pRow, int nTotalWidth, const BOOL firstLevel=TRUE) | CXTPGridPaintManager |
GetSectionDividerHeight(XTPGridFixedRowsDividerStyle dividerStyle) | CXTPGridPaintManager |
GetTextFont() | CXTPGridPaintManager |
IsColumHotTrackingEnabled() const | CXTPGridPaintManager | virtual
IsColumnPlusMinusSign() const | CXTPGridPaintManager |
IsColumnWidthWYSIWYG() const | CXTPGridPaintManager |
IsDrawGridForEmptySpace() const | CXTPGridPaintManager |
IsFixedInplaceButtonHeight() const | CXTPGridPaintManager |
IsFixedRowHeight() const | CXTPGridPaintManager |
IsGridVisible(BOOL bVertical) const | CXTPGridPaintManager |
IsGridVisible(XTPGridOrientation orientation) const | CXTPGridPaintManager |
IsLastColumnWidthWYSIWYG() const | CXTPGridPaintManager |
IsPreviewMode() const | CXTPGridPaintManager |
IsPrintGroupRowIcon() const | CXTPGridPaintManager |
IsShowWYSIWYGMarkers() const | CXTPGridPaintManager |
IsUseDropMarker() const | CXTPGridPaintManager |
LoadGlyphs() | CXTPGridThemeVisualStudio2012Light | virtual
m_arStartCol | CXTPGridPaintManager |
m_bAllowMergeCells | CXTPGridPaintManager |
m_bBaseTreeIndent | CXTPGridPaintManager |
m_bCleanTooltip | CXTPGridPaintManager |
m_bColumnPlusMinusSign | CXTPGridPaintManager | protected
m_bColumnWidthWYSIWYG | CXTPGridPaintManager | protected
m_bCompactText | CXTPGridPaintManager |
m_bDrawGridForEmptySpace | CXTPGridPaintManager | protected
m_bFixedInplaceButtonHeight | CXTPGridPaintManager | protected
m_bFixedRowHeight | CXTPGridPaintManager | protected
m_bForceDynamicMarkupForCell | CXTPGridPaintManager |
m_bForceShowDropMarker | CXTPGridPaintManager |
m_bForceShowTooltip | CXTPGridPaintManager |
m_bGrayIfDisable | CXTPGridPaintManager |
m_bGroupRowTextBold | CXTPGridPaintManager |
m_bHideSelection | CXTPGridPaintManager |
m_bHotTracking | CXTPGridPaintManager |
m_bInvertColumnOnClick | CXTPGridPaintManager |
m_bIsPreviewMode | CXTPGridPaintManager | protected
m_bLastColumnWidthWYSIWYG | CXTPGridPaintManager | protected
m_bMakeUpper | CXTPGridPaintManager |
m_bMoveScrollbarOnFixedColumnsIndent | CXTPGridPaintManager |
m_bPrintGroupRowIcon | CXTPGridPaintManager | protected
m_bPrintPageRectangle | CXTPGridPaintManager |
m_bPrintSortTriangle | CXTPGridPaintManager |
m_bPrintVirtualPageNumber | CXTPGridPaintManager |
m_bPrintWatermark | CXTPGridPaintManager |
m_bRecOrRowNum | CXTPGridPaintManager |
m_bRevertAlignment | CXTPGridPaintManager |
m_bShadeGroupHeadings | CXTPGridPaintManager |
m_bShadeSortColumn | CXTPGridPaintManager |
m_bShowLockIcon | CXTPGridPaintManager |
m_bShowNonActiveInPlaceButton | CXTPGridPaintManager |
m_bShowWYSIWYGMarkers | CXTPGridPaintManager | protected
m_bSortTriangleOffsetFromRight | CXTPGridPaintManager |
m_bThemedInplaceButtons | CXTPGridPaintManager |
m_bUseAlternativeBackground | CXTPGridPaintManager |
m_bUseDropMarker | CXTPGridPaintManager |
m_bUseEditTextAlignment | CXTPGridPaintManager |
m_bUseGroupRowSelectionState | CXTPGridPaintManager |
m_bUseShellIcon | CXTPGridPaintManager |
m_clrAlternativeBackground | CXTPGridPaintManager |
m_clrBoldText | CXTPGridPaintManager |
m_clrBoldTextHighlight | CXTPGridPaintManager |
m_clrBtnFace | CXTPGridPaintManager |
m_clrBtnFacePressed | CXTPGridPaintManager |
m_clrBtnText | CXTPGridPaintManager |
m_clrCaptionText | CXTPGridPaintManager |
m_clrCaptionTextPressed | CXTPGridPaintManager |
m_clrColumnOffice2007CustomTheme | CXTPGridPaintManager |
m_clrConnector | CXTPGridPaintManager |
m_clrControlBack | CXTPGridPaintManager |
m_clrControlDark | CXTPGridPaintManager |
m_clrControlLightLight | CXTPGridPaintManager |
m_clrDisableBitmapDarkest | CXTPGridPaintManager |
m_clrDisableBitmapLightest | CXTPGridPaintManager |
m_clrFormulaSubSum | CXTPGridPaintManager |
m_clrFormulaSum | CXTPGridPaintManager |
m_clrFreezeColsDivider | CXTPGridPaintManager |
m_clrGlyph | CXTPGridThemeOffice2013 |
m_clrGlyphBorder | CXTPGridThemeOffice2013 |
m_clrGlyphContract | CXTPGridThemeOffice2013 |
m_clrGlyphExpand | CXTPGridThemeOffice2013 |
m_clrGlyphHighlight | CXTPGridThemeOffice2013 |
m_clrGradientColumnSeparator | CXTPGridPaintManager |
m_clrGradientColumnShadow | CXTPGridPaintManager |
m_clrGroupBoxBack | CXTPGridPaintManager |
m_clrGroupRowText | CXTPGridPaintManager |
m_clrGroupShadeBack | CXTPGridPaintManager |
m_clrGroupShadeBorder | CXTPGridPaintManager |
m_clrGroupShadeText | CXTPGridPaintManager |
m_clrHeaderControl | CXTPGridPaintManager |
m_clrHighlight | CXTPGridPaintManager |
m_clrHighlightText | CXTPGridPaintManager |
m_clrHotDivider | CXTPGridPaintManager |
m_clrIndentControl | CXTPGridPaintManager |
m_clrItemShade | CXTPGridPaintManager |
m_clrPreviewText | CXTPGridPaintManager |
m_clrSelectedRow | CXTPGridPaintManager |
m_clrSelectedRowText | CXTPGridPaintManager |
m_clrWindowText | CXTPGridPaintManager |
m_columnStyle | CXTPGridPaintManager | protected
m_crlNoGroupByText | CXTPGridPaintManager |
m_grcGradientColumn | CXTPGridPaintManager |
m_grcGradientColumnHot | CXTPGridPaintManager |
m_grcGradientColumnPushed | CXTPGridPaintManager |
m_iRecOrRowStart | CXTPGridPaintManager |
m_nBaseParentRecordIndent | CXTPGridPaintManager |
m_nFixedColumnsIndent | CXTPGridPaintManager |
m_nFooterHeight | CXTPGridPaintManager | protected
m_nFreezeColsDividerStyle | CXTPGridPaintManager | protected
m_nGridLineStylePreviousH | CXTPGridPaintManager | protected
m_nGridLineStylePreviousV | CXTPGridPaintManager | protected
m_nGroupGridLineHeight | CXTPGridPaintManager | protected
m_nGroupGridLineStyle | CXTPGridPaintManager | protected
m_nHeaderHeight | CXTPGridPaintManager | protected
m_nMaxPreviewLines | CXTPGridPaintManager | protected
m_nResizingWidth | CXTPGridPaintManager | protected
m_nRowHeight | CXTPGridPaintManager | protected
m_nRowHeightDefault | CXTPGridPaintManager |
m_nTextIndentForGroupRowsWithNoIcon | CXTPGridPaintManager |
m_nTreeColumnLineLength | CXTPGridPaintManager |
m_nTreeIndent | CXTPGridPaintManager |
m_nTreeStructureStyle | CXTPGridPaintManager |
m_nTreeTextIndent | CXTPGridPaintManager |
m_nTreeTextIndentGroupRow | CXTPGridPaintManager |
m_nTreeTextIndentRowChildren | CXTPGridPaintManager |
m_nTreeTextIndentRowParent | CXTPGridPaintManager |
m_pControl | CXTPGridPaintManager | protected
m_pGlyphs | CXTPGridPaintManager | protected
m_pHyperlinkHoverStyle | CXTPGridPaintManager |
m_pHyperlinkStyle | CXTPGridPaintManager |
m_pMarkupUIElement_NoGroupBy | CXTPGridPaintManager | protected
m_PrintPageWidth | CXTPGridPaintManager |
m_rcPreviewIndent | CXTPGridPaintManager |
m_RecordNumberWidth | CXTPGridPaintManager |
m_strCollapse | CXTPGridPaintManager |
m_strDecreasing | CXTPGridPaintManager |
m_strExpand | CXTPGridPaintManager |
m_strIncreasing | CXTPGridPaintManager |
m_strMarkupUIElement_NoGroupBy | CXTPGridPaintManager | protected
m_strNoFieldsAvailable | CXTPGridPaintManager |
m_strNoGroupBy | CXTPGridPaintManager |
m_strNoItems | CXTPGridPaintManager |
m_strSortBy | CXTPGridPaintManager |
m_szGlyph | CXTPGridPaintManager | protected
m_themeButton | CXTPGridPaintManager | protected
m_themeCombo | CXTPGridPaintManager | protected
m_themeHeader | CXTPGridPaintManager | protected
m_themeSpin | CXTPGridPaintManager | protected
m_treeStructureStyle | CXTPGridPaintManager |
m_xtpBrushGroupGridLineStyle | CXTPGridPaintManager | protected
m_xtpBrushHorizontalGrid | CXTPGridPaintManager | protected
m_xtpBrushTreeStructure | CXTPGridPaintManager | protected
m_xtpBrushVeriticalGrid | CXTPGridPaintManager | protected
m_xtpFontBoldText | CXTPGridPaintManager |
m_xtpFontCaption | CXTPGridPaintManager |
m_xtpFontPreview | CXTPGridPaintManager |
m_xtpFontText | CXTPGridPaintManager |
OnDrawAction(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs) | CXTPGridPaintManager | virtual
RecalcTotalHightOfMergedRows(CXTPGridColumns *pColumns, CDC *pDC, CXTPGridRow *pRow, int nRowHeight, int nTotalWidth) | CXTPGridPaintManager |
RefreshMetrics() | CXTPGridThemeVisualStudio2012Light | virtual
SetCaptionFont(LOGFONT &lf) | CXTPGridPaintManager |
SetColumnOffice2007CustomThemeBaseColor(COLORREF clrBaseColor) | CXTPGridPaintManager |
SetColumnPlusMinusSign(BOOL bDraw) | CXTPGridPaintManager |
SetColumnStyle(XTPGridColumnStyle columnStyle) | CXTPGridPaintManager |
SetColumnWidthWYSIWYG(BOOL bColumnWidthWYSIWYG) | CXTPGridPaintManager |
SetDrawGridForEmptySpace(BOOL bDrawGrid) | CXTPGridPaintManager |
SetFixedRowHeight(BOOL bFixedRowHeight) | CXTPGridPaintManager |
SetFreezeColsDividerStyle(int nStyle) | CXTPGridPaintManager |
SetGridControl(CXTPGridControl *pControl) | CXTPGridPaintManager | virtual
SetHeaderHeight(int nHeight) | CXTPGridPaintManager | virtual
SetInplaceButtonHeight(BOOL bFixedInplaceButtonHeight) | CXTPGridPaintManager |
SetLastColumnWidthWYSIWYG(BOOL bColumnWidthWYSIWYG) | CXTPGridPaintManager |
SetMaxPreviewLines(int nMaxLines) | CXTPGridPaintManager |
SetPreviewIndent(int nLeft, int nTop, int nRight, int nBottom) | CXTPGridPaintManager |
SetPrintGroupRowIcon(BOOL bDraw) | CXTPGridPaintManager |
SetTextFont(LOGFONT &lf) | CXTPGridPaintManager |
ShowWYSIWYGMarkers(BOOL bSet) | CXTPGridPaintManager |
~CXTPGridPaintManager() | CXTPGridPaintManager | virtual


Toolkit Pro: Member List

  • CXTPResourceManager
  • CManageState
CXTPResourceManager::CManageState Member List

This is the complete list of members for CXTPResourceManager::CManageState, including all inherited members.

CManageState() | CXTPResourceManager::CManageState |
m_bSet | CXTPResourceManager::CManageState | protected
m_hModOldResource | CXTPResourceManager::CManageState | protected
Redo() | CXTPResourceManager::CManageState |
Undo() | CXTPResourceManager::CManageState |
~CManageState() | CXTPResourceManager::CManageState |


Toolkit Pro: Member List

  • CXTPRWCriticalSection
  • CExclusiveLock
CXTPRWCriticalSection::CExclusiveLock Member List

This is the complete list of members for CXTPRWCriticalSection::CExclusiveLock, including all inherited members.

CExclusiveLock(CXTPRWCriticalSection &cs) | CXTPRWCriticalSection::CExclusiveLock | inlineexplicit
~CExclusiveLock() | CXTPRWCriticalSection::CExclusiveLock | inline


Toolkit Pro: Member List

CXTPScrollBarThemeOfficeXP Member List

This is the complete list of members for CXTPScrollBarThemeOfficeXP, including all inherited members.

CalcHScroll(CXTPScrollBase *pScroll, XTPScrollMetricsH *pHScroll) | CXTPScrollBarPaintManager | protectedstatic
CalcVScroll(CXTPScrollBase *pScroll, XTPScrollMetricsV *pVScroll) | CXTPScrollBarPaintManager | protectedstatic
CXTPScrollBarPaintManager() | CXTPScrollBarPaintManager |
CXTPScrollBarThemeWindowsUx() | CXTPScrollBarThemeWindowsUx |
DrawArrowGlyph(CDC *pDC, CRect rcArrow, XTPArrowGlyph glyph, BOOL bEnabled, COLORREF clrText=COLORREF_NULL) | CXTPScrollBarPaintManager | protected
DrawArrows(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics) | CXTPScrollBarPaintManager | protectedvirtual
DrawArrows(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics) | CXTPScrollBarPaintManager | protectedvirtual
DrawBackground(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics) | CXTPScrollBarPaintManager | protectedvirtual
DrawBackground(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics) | CXTPScrollBarPaintManager | protectedvirtual
DrawButtons(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics) | CXTPScrollBarThemeWindowsUx | protectedvirtual
DrawButtons(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics) | CXTPScrollBarThemeWindowsUx | protectedvirtual
DrawGripper(CDC *pDC, CXTPScrollBase *pScroll) | CXTPScrollBarThemeWindowsUx | protectedvirtual
DrawScrollBar(CDC *pDC, CXTPScrollBase *pScrollBar) | CXTPScrollBarPaintManager | virtual
DrawThumbButton(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics) | CXTPScrollBarThemeWindowsUx | protectedvirtual
DrawThumbButton(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics) | CXTPScrollBarThemeWindowsUx | protectedvirtual
DrawTracker(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics) | CXTPScrollBarThemeWindowsUx | protectedvirtual
DrawTracker(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics) | CXTPScrollBarThemeWindowsUx | protectedvirtual
m_crBack | CXTPScrollBarPaintManager |
m_crBackHilite | CXTPScrollBarPaintManager |
m_crBackPushed | CXTPScrollBarPaintManager |
m_crBorder | CXTPScrollBarPaintManager |
m_crBorderHilite | CXTPScrollBarPaintManager |
m_cThumb | CXTPScrollBarPaintManager |
m_cxHScroll | CXTPScrollBarPaintManager |
m_cxVScroll | CXTPScrollBarPaintManager |
m_cyHScroll | CXTPScrollBarPaintManager |
m_cyVScroll | CXTPScrollBarPaintManager |
RefreshMetrics() | CXTPScrollBarThemeOfficeXP | protectedvirtual
~CXTPScrollBarThemeWindowsUx() | CXTPScrollBarThemeWindowsUx | virtual


Toolkit Pro: Member List

CXTPTabBaseThemeOffice2003 Member List

This is the complete list of members for CXTPTabBaseThemeOffice2003, including all inherited members.

AdjustBorders(CXTPTabBase *pTabCtrl, CXTPTcbItem *pMember) | CXTPTabBaseThemeOfficeXP | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPControlTheme() | CXTPControlTheme |
CXTPTabBaseTheme() | CXTPTabBaseTheme |
CXTPTabBaseThemeOffice2003() | CXTPTabBaseThemeOffice2003 |
CXTPTabBaseThemeOfficeXP() | CXTPTabBaseThemeOfficeXP |
DrawBorder(CDC *pDC, const CRect &r) | CXTPTabBaseThemeOffice2003 | protectedvirtual
DrawBorders(CDC *pDC, const CRect &rcClient) | CXTPTabBaseThemeOfficeXP | protectedvirtual
DrawButton(CDC *pDC, CXTPTabCtrlButton *pButton, COLORREF clrButton) | CXTPTabBaseThemeOfficeXP | virtual
DrawTab(CDC *pDC, CXTPTabBase *pTabCtrlBase, int iItem) | CXTPTabBaseTheme | protectedvirtual
DrawTabCtrl(CDC *pDC, CXTPTabBase *pTabCtrl) | CXTPTabBaseTheme | virtual
DrawTabIcon(CDC *pDC, CTabCtrl *pTabCtrl, CRect &rcItem, int iItem) | CXTPTabBaseThemeOfficeXP | protectedvirtual
DrawTabText(CDC *pDC, CTabCtrl *pTabCtrl, CRect &rcItem, int iItem, BOOL bSelected, BOOL bBoldFont) | CXTPTabBaseTheme | protectedvirtual
FillButtons(CDC *pDC, CXTPTabCtrlButtons *pButtons) | CXTPTabBaseThemeOffice2003 | protectedvirtual
FillHeader(CDC *pDC, CXTPTabBase *pTabCtrlBase, CRect rcHeader) | CXTPTabBaseThemeOffice2003 | protectedvirtual
FillTabFace(CDC *pDC, CTabCtrl *pTabCtrl, CRect rcItem, BOOL bSelected) | CXTPTabBaseThemeOffice2003 | protectedvirtual
FillTabFaceNativeWinXP(CDC *pDC, CTabCtrl *pTabCtrl, CRect rcItem, BOOL bSelected) | CXTPTabBaseTheme | protectedvirtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetBackColor() const | CXTPTabBaseThemeOffice2003 | virtual
GetHeaderRect(CXTPTabBase *pTabCtrlBase) | CXTPTabBaseTheme | protectedvirtual
GetTabStyle(CTabCtrl *pTabCtrl) const | CXTPTabBaseTheme | inlineprotected
GetThemeStyle() const | CXTPControlTheme |
GradientFillTabFace(CDC *pDC, CTabCtrl *pTabCtrl, CRect rcItem, BOOL bSelected) | CXTPTabBaseThemeOffice2003 | protectedvirtual
HorizontalLine(CDC *pDC, int xPos, int yPos, int nLength, COLORREF clr) | CXTPTabBaseTheme | protected
IsBottom(DWORD dwStyle) const | CXTPTabBaseTheme | inlineprotected
IsHorz(DWORD dwStyle) const | CXTPTabBaseTheme | inlineprotected
IsLeft(DWORD dwStyle) const | CXTPTabBaseTheme | inlineprotected
IsRight(DWORD dwStyle) const | CXTPTabBaseTheme | inlineprotected
IsTop(DWORD dwStyle) const | CXTPTabBaseTheme | inlineprotected
IsVert(DWORD dwStyle) const | CXTPTabBaseTheme | inlineprotected
m_bSystemDrawing | CXTPTabBaseTheme |
m_bUseWinThemes | CXTPTabBaseTheme |
m_clrButtonNormal | CXTPTabBaseThemeOffice2003 | protected
m_clrButtonSelected | CXTPTabBaseThemeOffice2003 | protected
m_clrDarkShadow | CXTPTabBaseThemeOffice2003 | protected
m_clrHeaderFace | CXTPTabBaseThemeOffice2003 | protected
m_clrHighlight | CXTPTabBaseThemeOffice2003 | protected
m_clrNormalText | CXTPTabBaseTheme | protected
m_clrShadow | CXTPTabBaseThemeOffice2003 | protected
m_iEdge | CXTPTabBaseTheme | protected
m_nTheme | CXTPControlTheme | protected
m_themeTab | CXTPTabBaseTheme | protected
Pixel(CDC *pDC, int xPos, int yPos, COLORREF clr) | CXTPTabBaseTheme | protected
RefreshMetrics(CTabCtrl *pTab) | CXTPTabBaseThemeOffice2003 | virtual
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static
ShowButtons(CXTPTabBase *pTabCtrlBase) | CXTPTabBaseTheme | protectedvirtual
SwapColors(COLORREF &clrLight, COLORREF &clrDark) | CXTPTabBaseTheme | protected
VerticalLine(CDC *pDC, int xPos, int yPos, int nLength, COLORREF clr) | CXTPTabBaseTheme | protected
~CXTPTabBaseTheme() | CXTPTabBaseTheme | virtual


Toolkit Pro: XTPGridColumn.h Source File

  • Source
  • GridControl
XTPGridColumn.h
Go to the documentation of this file.
1
23#if !defined(__XTPGRIDCOLUMN_H__)
24# define __XTPGRIDCOLUMN_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPGridGroups;
34class CXTPGridRecordItemEditOptions;
35class CXTPPropExchange;
36class CXTPMarkupContext;
37class CXTPMarkupUIElement;
38
43enum XTPGridColumnBestFitMode
44{
45 xtpColumnBestFitModeVisibleData = 0,
46 xtpColumnBestFitModeAllData = 1,
47};
48
49class _XTP_EXT_CLASS CXTPGridColumnDisplaySettings : public CXTPCmdTarget
50{
51public:
52 CXTPGridColumnDisplaySettings();
53
54 BOOL IsShowIcon() const;
55 void SetShowIcon(BOOL bShowIcon);
56
57 BOOL IsShowText() const;
58 void SetShowText(BOOL bShowText);
59
60protected:
61 BOOL m_bShowIcon;
62 BOOL m_bShowText;
63};
64
65class _XTP_EXT_CLASS CXTPGridColumnDisplayOptions : public CXTPCmdTarget
66{
67public:
68 CXTPGridColumnDisplayOptions();
69 virtual ~CXTPGridColumnDisplayOptions();
70
71public:
72 CXTPGridColumnDisplaySettings* Column() const;
73 CXTPGridColumnDisplaySettings* FieldChooser() const;
74 CXTPGridColumnDisplaySettings* GroupBy() const;
75
76protected:
77 CXTPGridColumnDisplaySettings* m_pColumn;
78 CXTPGridColumnDisplaySettings* m_pFieldChooser;
79 CXTPGridColumnDisplaySettings* m_pGroupBy;
80};
81
106class _XTP_EXT_CLASS CXTPGridColumn : public CXTPCmdTarget
107{
108 DECLARE_DYNAMIC(CXTPGridColumn);
109
111 friend class CXTPGridControl;
112 friend class CXTPGridColumns;
113 friend class CXTPGridHeader;
114 friend class CXTPGridRows;
115 friend class CXTPGridRow;
116 friend class CXTPGridColumnOrder;
119public:
151 CXTPGridColumn(int nItemIndex, LPCTSTR strName, int nWidth, BOOL bAutoSize = TRUE,
152 int nIconID = XTP_GRID_NOICON, BOOL bSortable = TRUE, BOOL bVisible = TRUE);
186 CXTPGridColumn(int nItemIndex, LPCTSTR strDisplayName, LPCTSTR strInternalName, int nWidth,
187 BOOL bAutoSize = TRUE, int nIconID = XTP_GRID_NOICON, BOOL bSortable = TRUE,
188 BOOL bVisible = TRUE);
189
194 virtual ~CXTPGridColumn();
195
209 BOOL IsDragging() const;
210
221 CRect GetRect() const;
222
233 int GetWidth() const;
234
245 int GetCaptionWidth(CDC* pDC);
246
258 int SetWidth(int nNewWidth);
259
266 int GetIndent() const;
267
274 int GetItemIndex() const;
275
281 void SetItemIndex(int nItemIndex);
282
289 int GetIndex() const;
290
297 int GetVisibleIndex() const;
298
305 int GetOldVisibleIndex() const;
306
317 int GetIconID() const;
318
324 void SetIconID(int nIconId);
325
334 CString GetCaption() const;
335
341 void SetCaption(LPCTSTR strCaption);
342
352 void SetFooterText(LPCTSTR strFooter);
353
362 CString GetFooterText() const;
363
374 void SetFooterFont(CFont* pFont);
375
387 CFont* GetFooterFont();
388
399 void SetDrawFooterDivider(BOOL bSet);
400
411 BOOL GetDrawFooterDivider() const;
412
423 void SetDrawHeaderDivider(BOOL bSet);
424
435 BOOL GetDrawHeaderDivider() const;
436
443 CString GetTooltip() const;
444
450 void SetTooltip(LPCTSTR lpszTooltip);
451
460 BOOL IsVisible() const;
461
473 void SetVisible(BOOL bVisible = TRUE);
474
481 BOOL IsHotTracking() const;
482
493 BOOL SetFilterable(BOOL bFilterable = TRUE);
494
503 BOOL IsFilterable() const;
504
513 BOOL IsResizable() const;
514
522 void EnableResize(BOOL bIsResizable);
523
536 int SetMinWidth(int nMinWidth);
537
546 int GetMinWidth() const;
547
560 int SetMaxWidth(int nMaxWidth);
561
570 int GetMaxWidth() const;
571
580 BOOL IsSortable() const;
581
591 BOOL IsGroupable() const;
592
602 BOOL IsPlusMinus() const;
603
612 BOOL IsExpanded() const;
613
622 int GetNextVisualBlock() const;
623
630 BOOL IsAutoSortWhenGrouped() const;
631
640 BOOL IsAllowDragging() const;
641
650 BOOL IsSortedIncreasing() const;
651
660 BOOL IsSortedDecreasing() const;
661
670 void SetSortIncreasing(BOOL bSortIncreasing);
671
680 BOOL IsSorted() const;
681
690 void SetTreeColumn(BOOL bIsTreeColumn);
691
700 BOOL IsTreeColumn() const;
701
707 virtual void DoPropExchange(CXTPPropExchange* pPX);
708
718 int SetAlignment(int nAlignment);
719
728 int GetAlignment() const;
729
737 void SetHeaderAlignment(int nAlignment);
738
747 int GetHeaderAlignment() const;
748
756 void SetFooterAlignment(int nAlignment);
757
766 int GetFooterAlignment() const;
767
775 BOOL HasSortTriangle() const;
776
783 BOOL IsAutoSize() const;
784
792 void SetAutoSize(BOOL bSet);
793
812 void SetSortable(BOOL bSortable);
813
825 void SetAutoSortWhenGrouped(BOOL bAutoSortWhenGrouped);
826
839 void SetGroupable(BOOL bGroupable);
840
848 void SetPlusMinus(BOOL bPlusMinus);
849
857 void SetExpanded(BOOL bExpanded);
858
866 void SetNextVisualBlock(int nNextVisualBlock);
867
876 void SetAllowDrag(BOOL bAllowDrag);
877
884 CXTPGridColumns* GetColumns() const;
885
894 CXTPGridControl* GetControl() const;
895
913 BOOL IsShowInFieldChooser() const;
914
931 void SetShowInFieldChooser(BOOL bShow);
932
939 CXTPGridRecordItemEditOptions* GetEditOptions() const;
940
947 CXTPGridColumnDisplayOptions* GetDisplayOptions() const;
948
962 BOOL IsEditable() const;
963
977 void SetEditable(BOOL bEditable = TRUE);
978
990 void AllowRemove(BOOL bAllow);
991
1000 BOOL IsAllowRemove() const;
1001
1011 int GetPrintWidth(int nTotalWidth) const;
1012
1020 CString GetInternalName() const;
1021
1028 void SetInternalName(LPCTSTR pcszName);
1029
1038 BOOL GetDrawHeaderRowsVGrid() const;
1039
1048 BOOL GetDrawFooterRowsVGrid() const;
1049
1057 void SetDrawHeaderRowsVGrid(BOOL bDrawVGrid = TRUE);
1058
1066 void SetDrawFooterRowsVGrid(BOOL bDrawVGrid = TRUE);
1067
1073 virtual void EnsureVisible();
1074
1084 int GetBestFitMode() const;
1085
1094 void SetBestFitMode(int nMode);
1095
1096 // private:
1097
1099 int GetNormAlignment(int nAlignment) const;
1100 int GetBestFitWidth();
1109 CXTPMarkupUIElement* GetMarkupUIElement() const;
1110
1117 virtual void ResetMarkupUIElement();
1118
1124 void SetFixed(BOOL bFixed);
1125
1132 BOOL IsFixed() const;
1133
1140 BOOL IsFrozen() const;
1141
1147 void SetFrozen(BOOL bFrozen);
1148
1149 BOOL IsAutoNumbering() const;
1150
1151 void SetAutoNumbering(BOOL bAutoNumbering);
1152
1153 int GetAutoNumberingBase() const;
1154
1155 void SetAutoNumberingBase(int nAutoNumberingBase);
1156
1207 void SetMask(LPCTSTR strMask, LPCTSTR strLiteral, TCHAR chPrompt = _T('_'));
1208
1217 CString GetMask() const;
1218
1227 CString GetLiteral() const;
1228
1237 TCHAR GetPrompt() const;
1238
1247 BOOL IsUseMask() const;
1248
1249private:
1250 void _initData(int nItemIndex, LPCTSTR strDisplayName, LPCTSTR strInternalName, int nWidth,
1251 BOOL bAutoSize, int nIconID, BOOL bSortable, BOOL bVisible);
1252
1253protected:
1254 CString m_strInternalName;
1255 CString m_strName;
1256 CString m_strTooltip;
1257 int m_nItemIndex;
1259 CString m_strFooterText;
1261 CXTPFont m_xtpFontFooter;
1263 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CFont, m_fontFooter, m_xtpFontFooter,
1264 GetFooterFontHandle);
1265
1266 BOOL m_bDrawFooterDivider;
1267 BOOL m_bDrawHeaderDivider;
1269 BOOL m_bAutoNumbering;
1270 int m_nAutoNumberingBase;
1272 BOOL m_bSortIncreasing;
1273 BOOL m_bSortable;
1274 BOOL m_bGroupable;
1275 BOOL m_bAutoSortWhenGrouped;
1278 BOOL m_bFixed;
1279 BOOL m_bFrozen;
1280 BOOL m_bFilterable;
1282 BOOL m_bPlusMinus;
1285 BOOL m_bExpanded;
1287 int m_nNextVisualBlock;
1290 BOOL m_bAllowDrag;
1291 BOOL m_bAllowRemove;
1293 CXTPGridColumns* m_pColumns;
1295 int m_nIconID;
1296 BOOL m_bVisible;
1297 int m_nOldVisibleIndex;
1299 BOOL m_bIsResizable;
1300 CRect m_rcColumn;
1301 CRect m_rcGroupBy;
1302 int m_nMinWidth;
1303 int m_nMaxWidth;
1305 int m_nMaxItemWidth;
1307 int m_nAlignment;
1309 int m_nHeaderAlignment;
1311 int m_nFooterAlignment;
1314 int m_nColumnAutoWidth;
1315 int m_nColumnStaticWidth;
1316 BOOL m_bAutoSize;
1318 BOOL m_bShowInFieldChooser;
1320 BOOL m_bEditable;
1322 BOOL m_bDrawHeaderRowsVGrid;
1323 BOOL m_bDrawFooterRowsVGrid;
1324 int m_nBestFitMode;
1326 CXTPGridRecordItemEditOptions* m_pEditOptions;
1327 CXTPGridColumnDisplayOptions* m_pDisplayOptions;
1328 CXTPMarkupUIElement* m_pMarkupUIElement;
1330 CString m_strMask;
1331 CString m_strLiteral;
1333 TCHAR m_chPrompt;
1335 BOOL m_bUseMask;
1337# ifdef _XTP_ACTIVEX
1339 DECLARE_DISPATCH_MAP()
1340 DECLARE_INTERFACE_MAP()
1341
1342 DECLARE_OLETYPELIB_EX(CXTPGridColumn);
1343
1344 void OleMove(long nIndex);
1345 BSTR OleGetFooterText();
1346 BSTR OleGetCaption();
1347
1348 void OleBestFit();
1349
1350 LPFONTDISP OleGetFooterFont();
1351 void OleSetFooterFont(LPFONTDISP pFontDisp);
1352
1353 afx_msg void OleSetMask(LPCTSTR strMask, LPCTSTR strLiteral, LPCTSTR chPrompt);
1354
1355public:
1356 static CXTPGridColumn* AFX_CDECL FromDispatch(LPDISPATCH pDisp);
1357
1358 LPDISPATCH OleGetEditOptions();
1359 COleVariant m_oleTag;
1360
1362# endif /*_XTP_ACTIVEX*/
1363};
1364
1365AFX_INLINE CString CXTPGridColumn::GetCaption() const
1366{
1367 return m_strName;
1368}
1369
1370AFX_INLINE int CXTPGridColumn::GetIconID() const
1371{
1372 return m_nIconID;
1373}
1374
1375AFX_INLINE void CXTPGridColumn::SetIconID(int nIconId)
1376{
1377 m_nIconID = nIconId;
1378}
1379
1380AFX_INLINE BOOL CXTPGridColumn::IsFilterable() const
1381{
1382 return m_bFilterable;
1383}
1384
1385AFX_INLINE BOOL CXTPGridColumn::IsResizable() const
1386{
1387 return m_bIsResizable;
1388}
1389
1390AFX_INLINE void CXTPGridColumn::EnableResize(BOOL bIsResizable)
1391{
1392 m_bIsResizable = bIsResizable;
1393}
1394
1395AFX_INLINE BOOL CXTPGridColumn::IsPlusMinus() const
1396{
1397 return m_bPlusMinus;
1398}
1399
1400AFX_INLINE BOOL CXTPGridColumn::IsExpanded() const
1401{
1402 return m_bExpanded;
1403}
1404
1405AFX_INLINE int CXTPGridColumn::GetNextVisualBlock() const
1406{
1407 return m_nNextVisualBlock;
1408}
1409
1410AFX_INLINE BOOL CXTPGridColumn::IsAutoSortWhenGrouped() const
1411{
1412 return m_bAutoSortWhenGrouped;
1413}
1414
1415AFX_INLINE BOOL CXTPGridColumn::IsAllowDragging() const
1416{
1417 return m_bAllowDrag;
1418}
1419
1420AFX_INLINE void CXTPGridColumn::SetAutoSortWhenGrouped(BOOL bAutoSortWhenGrouped)
1421{
1422 m_bAutoSortWhenGrouped = bAutoSortWhenGrouped;
1423}
1424
1425AFX_INLINE void CXTPGridColumn::SetSortIncreasing(BOOL bSortIncreasing)
1426{
1427 m_bSortIncreasing = bSortIncreasing;
1428}
1429
1430AFX_INLINE CXTPGridRecordItemEditOptions* CXTPGridColumn::GetEditOptions() const
1431{
1432 return m_pEditOptions;
1433}
1434
1435AFX_INLINE CXTPGridColumnDisplayOptions* CXTPGridColumn::GetDisplayOptions() const
1436{
1437 return m_pDisplayOptions;
1438}
1439
1441
1442AFX_INLINE void CXTPGridColumn::SetAutoSize(BOOL bSet)
1443{
1444 m_bAutoSize = bSet;
1445}
1446
1447AFX_INLINE BOOL CXTPGridColumn::IsAutoSize() const
1448{
1449 return m_bAutoSize;
1450}
1451
1453
1454AFX_INLINE void CXTPGridColumn::SetFixed(BOOL bFixed)
1455{
1456 m_bFixed = bFixed;
1457}
1458
1459AFX_INLINE BOOL CXTPGridColumn::IsFixed() const
1460{
1461 return m_bFixed;
1462}
1463
1465
1466AFX_INLINE BOOL CXTPGridColumn::IsFrozen() const
1467{
1468 return m_bFrozen;
1469}
1470
1471AFX_INLINE void CXTPGridColumn::SetFrozen(BOOL bFrozen)
1472{
1473 m_bFrozen = bFrozen;
1474}
1475
1477
1478AFX_INLINE BOOL CXTPGridColumn::IsAutoNumbering() const
1479{
1480 return m_bAutoNumbering;
1481}
1482
1483AFX_INLINE void CXTPGridColumn::SetAutoNumbering(BOOL bAutoNumbering)
1484{
1485 m_bAutoNumbering = bAutoNumbering;
1486}
1487
1489
1490AFX_INLINE int CXTPGridColumn::GetAutoNumberingBase() const
1491{
1492 return m_nAutoNumberingBase;
1493}
1494
1495AFX_INLINE void CXTPGridColumn::SetAutoNumberingBase(int nAutoNumberingBase)
1496{
1497 m_nAutoNumberingBase = nAutoNumberingBase;
1498}
1499
1501
1502AFX_INLINE void CXTPGridColumn::SetGroupable(BOOL bGroupable)
1503{
1504 m_bGroupable = bGroupable;
1505}
1506
1507AFX_INLINE BOOL CXTPGridColumn::IsGroupable() const
1508{
1509 return m_bGroupable;
1510}
1511
1513
1514AFX_INLINE void CXTPGridColumn::SetSortable(BOOL bSortable)
1515{
1516 m_bSortable = bSortable;
1517}
1518
1519AFX_INLINE BOOL CXTPGridColumn::IsSortable() const
1520{
1521 return m_bSortable;
1522}
1523
1525
1526AFX_INLINE BOOL CXTPGridColumn::IsEditable() const
1527{
1528 return m_bEditable;
1529}
1530
1531AFX_INLINE void CXTPGridColumn::SetEditable(BOOL bEditable)
1532{
1533 m_bEditable = bEditable;
1534}
1535
1537
1538AFX_INLINE void CXTPGridColumn::AllowRemove(BOOL bAllow)
1539{
1540 m_bAllowRemove = bAllow;
1541}
1542
1543AFX_INLINE BOOL CXTPGridColumn::IsAllowRemove() const
1544{
1545 return m_bAllowRemove;
1546}
1547
1549
1550AFX_INLINE CString CXTPGridColumn::GetTooltip() const
1551{
1552 return m_strTooltip;
1553}
1554
1555AFX_INLINE void CXTPGridColumn::SetTooltip(LPCTSTR lpszTooltip)
1556{
1557 m_strTooltip = lpszTooltip;
1558}
1559
1560AFX_INLINE CString CXTPGridColumn::GetFooterText() const
1561{
1562 return m_strFooterText;
1563}
1564
1565AFX_INLINE void CXTPGridColumn::SetHeaderAlignment(int nAlignment)
1566{
1567 m_nHeaderAlignment = nAlignment;
1568}
1569
1570AFX_INLINE BOOL CXTPGridColumn::GetDrawFooterDivider() const
1571{
1572 return m_bDrawFooterDivider;
1573}
1574
1575AFX_INLINE BOOL CXTPGridColumn::GetDrawHeaderDivider() const
1576{
1577 return m_bDrawHeaderDivider;
1578}
1579
1580AFX_INLINE CString CXTPGridColumn::GetInternalName() const
1581{
1582 return m_strInternalName;
1583}
1584
1585AFX_INLINE void CXTPGridColumn::SetInternalName(LPCTSTR pcszName)
1586{
1587 m_strInternalName = pcszName;
1588}
1589
1590AFX_INLINE BOOL CXTPGridColumn::GetDrawHeaderRowsVGrid() const
1591{
1592 return m_bDrawHeaderRowsVGrid;
1593}
1594
1595AFX_INLINE void CXTPGridColumn::SetDrawHeaderRowsVGrid(BOOL bDrawVGrid)
1596{
1597 m_bDrawHeaderRowsVGrid = bDrawVGrid;
1598}
1599
1600AFX_INLINE BOOL CXTPGridColumn::GetDrawFooterRowsVGrid() const
1601{
1602 return m_bDrawFooterRowsVGrid;
1603}
1604
1605AFX_INLINE void CXTPGridColumn::SetDrawFooterRowsVGrid(BOOL bDrawVGrid)
1606{
1607 m_bDrawFooterRowsVGrid = bDrawVGrid;
1608}
1609
1610AFX_INLINE int CXTPGridColumn::GetBestFitMode() const
1611{
1612 return m_nBestFitMode;
1613}
1614
1615AFX_INLINE void CXTPGridColumn::SetBestFitMode(int nMode)
1616{
1617 m_nBestFitMode = nMode;
1618}
1619
1620AFX_INLINE CXTPMarkupUIElement* CXTPGridColumn::GetMarkupUIElement() const
1621{
1622 return m_pMarkupUIElement;
1623}
1624
1625AFX_INLINE CString CXTPGridColumn::GetMask() const
1626{
1627 return m_strMask;
1628}
1629
1630AFX_INLINE CString CXTPGridColumn::GetLiteral() const
1631{
1632 return m_strLiteral;
1633}
1634
1635AFX_INLINE TCHAR CXTPGridColumn::GetPrompt() const
1636{
1637 return m_chPrompt;
1638}
1639
1640AFX_INLINE BOOL CXTPGridColumn::IsUseMask() const
1641{
1642 return m_bUseMask;
1643}
1645# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
1646#endif //#if !defined(__XTPGRIDCOLUMN_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPGridColumnBestFitMode
XTPGridColumnBestFitMode
This enum defines the best fit mode.
Definition XTPGridColumn.h:44
xtpColumnBestFitModeAllData
@ xtpColumnBestFitModeAllData
Fit by all column data.
Definition XTPGridColumn.h:46
xtpColumnBestFitModeVisibleData
@ xtpColumnBestFitModeVisibleData
Fit by visible column data.
Definition XTPGridColumn.h:45
XTP_GRID_NOICON
const int XTP_GRID_NOICON
This constant indicates that an icon ID is not defined.
Definition XTPGridDefines.h:409
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPFont
Provides a convenient object oriented interface for HFONT GDI object and uses GDI handle caching.
Definition XTPGdiObjects.h:414
CXTPGridColumn
Represents a grid column item with its properties and operations.
Definition XTPGridColumn.h:107
CXTPGridColumn::GetDisplayOptions
CXTPGridColumnDisplayOptions * GetDisplayOptions() const
Gets the display options of the column.
Definition XTPGridColumn.h:1435
CXTPGridColumn::IsUseMask
BOOL IsUseMask() const
Determines the specified mask to a data field.
Definition XTPGridColumn.h:1640
CXTPGridColumn::GetDrawHeaderDivider
BOOL GetDrawHeaderDivider() const
Returns is right column header divider visible.
Definition XTPGridColumn.h:1575
CXTPGridColumn::DoPropExchange
virtual void DoPropExchange(CXTPPropExchange *pPX)
Reads/writes column data to/from the provided archive stream.
CXTPGridColumn::IsVisible
BOOL IsVisible() const
Determines the visible state of the column header.
CXTPGridColumn::ResetMarkupUIElement
virtual void ResetMarkupUIElement()
Resets the Markup UI element object.
CXTPGridColumn::m_strInternalName
CString m_strInternalName
Internal column name (to serialize column options).
Definition XTPGridColumn.h:1254
CXTPGridColumn::IsSortedIncreasing
BOOL IsSortedIncreasing() const
Determines if the column is sorted in increasing order.
CXTPGridColumn::m_strName
CString m_strName
Column name.
Definition XTPGridColumn.h:1255
CXTPGridColumn::m_strFooterText
CString m_strFooterText
Column Footer Text.
Definition XTPGridColumn.h:1259
CXTPGridColumn::GetIndent
int GetIndent() const
Gets the column indentation.
CXTPGridColumn::m_strTooltip
CString m_strTooltip
Column tooltip.
Definition XTPGridColumn.h:1256
CXTPGridColumn::IsAutoSortWhenGrouped
BOOL IsAutoSortWhenGrouped() const
Determines if the column is sortable when grouped.
Definition XTPGridColumn.h:1410
CXTPGridColumn::SetVisible
void SetVisible(BOOL bVisible=TRUE)
Sets the visible state for the column header.
CXTPGridColumn::m_xtpFontFooter
CXTPFont m_xtpFontFooter
Column Footer font.
Definition XTPGridColumn.h:1261
CXTPGridColumn::m_bIsResizable
BOOL m_bIsResizable
Indicates if the column allows for width resizing.
Definition XTPGridColumn.h:1299
CXTPGridColumn::m_nMinWidth
int m_nMinWidth
Minimal column width.
Definition XTPGridColumn.h:1302
CXTPGridColumn::GetAlignment
int GetAlignment() const
Gets the alignment value of the column.
CXTPGridColumn::GetFooterAlignment
int GetFooterAlignment() const
Gets the alignment value of the column footer.
CXTPGridColumn::SetNextVisualBlock
void SetNextVisualBlock(int nNextVisualBlock)
Sets the index of the next visual column.
CXTPGridColumn::m_nIconID
int m_nIconID
Associated icon ID.
Definition XTPGridColumn.h:1295
CXTPGridColumn::SetTooltip
void SetTooltip(LPCTSTR lpszTooltip)
Sets the tooltop text for the column header.
Definition XTPGridColumn.h:1555
CXTPGridColumn::GetMask
CString GetMask() const
Gets string to use as edit mask.
Definition XTPGridColumn.h:1625
CXTPGridColumn::SetDrawHeaderRowsVGrid
void SetDrawHeaderRowsVGrid(BOOL bDrawVGrid=TRUE)
Specifies if the vertical grid will be shown for header rows.
Definition XTPGridColumn.h:1595
CXTPGridColumn::m_bUseMask
BOOL m_bUseMask
TRUE to use an edit mask to display item data.
Definition XTPGridColumn.h:1335
CXTPGridColumn::SetItemIndex
void SetItemIndex(int nItemIndex)
Sets the index of the associated record item.
CXTPGridColumn::m_bShowInFieldChooser
BOOL m_bShowInFieldChooser
Indicates if the column is shown in the field chooser when the column is hidden or in the GroupBy Box...
Definition XTPGridColumn.h:1318
CXTPGridColumn::SetCaption
void SetCaption(LPCTSTR strCaption)
Sets the text caption for the column header.
CXTPGridColumn::GetWidth
int GetWidth() const
Gets the column width.
CXTPGridColumn::SetFooterAlignment
void SetFooterAlignment(int nAlignment)
Sets the alignment value for the column footer.
CXTPGridColumn::SetAlignment
int SetAlignment(int nAlignment)
Sets the alignment value for the column.
CXTPGridColumn::SetFilterable
BOOL SetFilterable(BOOL bFilterable=TRUE)
Sets the filterable state for the column header.
CXTPGridColumn::m_pColumns
CXTPGridColumns * m_pColumns
Pointer to the parent columns collection.
Definition XTPGridColumn.h:1293
CXTPGridColumn::IsAllowDragging
BOOL IsAllowDragging() const
Determines if the column can be dragged.
Definition XTPGridColumn.h:1415
CXTPGridColumn::m_bDrawFooterRowsVGrid
BOOL m_bDrawFooterRowsVGrid
Indicates whether to draw vertical grid for footers rows.
Definition XTPGridColumn.h:1323
CXTPGridColumn::IsSorted
BOOL IsSorted() const
Determines if the column is sorted.
CXTPGridColumn::m_strLiteral
CString m_strLiteral
String to use as literal.
Definition XTPGridColumn.h:1331
CXTPGridColumn::SetDrawFooterDivider
void SetDrawFooterDivider(BOOL bSet)
Call this member to set/change is the right column footer divider visible.
CXTPGridColumn::m_bExpanded
BOOL m_bExpanded
State of PlusMinus column.
Definition XTPGridColumn.h:1285
CXTPGridColumn::SetFooterFont
void SetFooterFont(CFont *pFont)
Sets the font for the column footer.
CXTPGridColumn::SetFrozen
void SetFrozen(BOOL bFrozen)
Sets the frozen state for the column.
Definition XTPGridColumn.h:1471
CXTPGridColumn::GetItemIndex
int GetItemIndex() const
Gets the index of the associated record item.
CXTPGridColumn::HasSortTriangle
BOOL HasSortTriangle() const
Checks if the column header should have the sort triangle drawn.
CXTPGridColumn::SetBestFitMode
void SetBestFitMode(int nMode)
Sets the column best fit mode.
Definition XTPGridColumn.h:1615
CXTPGridColumn::GetHeaderAlignment
int GetHeaderAlignment() const
Gets the alignment value of the column header.
CXTPGridColumn::IsPlusMinus
BOOL IsPlusMinus() const
Determines if the column's expand collapse right icon (+/-) is enabled/disabled.
Definition XTPGridColumn.h:1395
CXTPGridColumn::SetFixed
void SetFixed(BOOL bFixed)
Sets the fixed state for the column.
Definition XTPGridColumn.h:1454
CXTPGridColumn::m_nMaxWidth
int m_nMaxWidth
Maximal column width (if set as positive).
Definition XTPGridColumn.h:1303
CXTPGridColumn::SetHeaderAlignment
void SetHeaderAlignment(int nAlignment)
Sets the alignment value for the column header.
Definition XTPGridColumn.h:1565
CXTPGridColumn::IsFilterable
BOOL IsFilterable() const
Determines the filterable state of the column header.
Definition XTPGridColumn.h:1380
CXTPGridColumn::SetInternalName
void SetInternalName(LPCTSTR pcszName)
Sets the internal column name used in serialization to uniquely identify a column rather than a colum...
Definition XTPGridColumn.h:1585
CXTPGridColumn::m_bSortable
BOOL m_bSortable
TRUE if the column could be sortable by.
Definition XTPGridColumn.h:1273
CXTPGridColumn::IsResizable
BOOL IsResizable() const
Determines the resizable state of the column.
Definition XTPGridColumn.h:1385
CXTPGridColumn::IsTreeColumn
BOOL IsTreeColumn() const
Determines if the column contains a tree.
CXTPGridColumn::IsExpanded
BOOL IsExpanded() const
Determines the expanded state of the column.
Definition XTPGridColumn.h:1400
CXTPGridColumn::GetControl
CXTPGridControl * GetControl() const
Gets the parent Grid control.
CXTPGridColumn::GetDrawFooterRowsVGrid
BOOL GetDrawFooterRowsVGrid() const
Determines if the vertical grid will be shown for footer rows.
Definition XTPGridColumn.h:1600
CXTPGridColumn::GetDrawFooterDivider
BOOL GetDrawFooterDivider() const
Returns is right column footer divider visible.
Definition XTPGridColumn.h:1570
CXTPGridColumn::SetSortable
void SetSortable(BOOL bSortable)
Specifies if the column should be sorted when the user clicks on the column's header.
Definition XTPGridColumn.h:1514
CXTPGridColumn::IsDragging
BOOL IsDragging() const
Determines if the column header is in dragging mode.
CXTPGridColumn::SetPlusMinus
void SetPlusMinus(BOOL bPlusMinus)
Enables/disables the column's expand collapse right icon (+/-).
CXTPGridColumn::IsFixed
BOOL IsFixed() const
Determines the fixed state of the column.
Definition XTPGridColumn.h:1459
CXTPGridColumn::m_nMaxItemWidth
int m_nMaxItemWidth
Contains maximal width of the corresponding item drawn in the column.
Definition XTPGridColumn.h:1305
CXTPGridColumn::m_strMask
CString m_strMask
String to use as edit mask.
Definition XTPGridColumn.h:1330
CXTPGridColumn::m_nAlignment
int m_nAlignment
Alignment mode for column: DT_LEFT || DT_RIGHT || DT_CENTER.
Definition XTPGridColumn.h:1307
CXTPGridColumn::m_bEditable
BOOL m_bEditable
Indicates whether an edit box should be added to the items in the column.
Definition XTPGridColumn.h:1320
CXTPGridColumn::m_pEditOptions
CXTPGridRecordItemEditOptions * m_pEditOptions
Edit options of the column.
Definition XTPGridColumn.h:1326
CXTPGridColumn::m_pDisplayOptions
CXTPGridColumnDisplayOptions * m_pDisplayOptions
Display options of the column.
Definition XTPGridColumn.h:1327
CXTPGridColumn::GetRect
CRect GetRect() const
Gets the client rectangle where the column was drawn last time.
CXTPGridColumn::GetVisibleIndex
int GetVisibleIndex() const
Gets the visible index of the column.
CXTPGridColumn::m_nHeaderAlignment
int m_nHeaderAlignment
Alignment mode for column text: DT_LEFT || DT_RIGHT || DT_CENTER.
Definition XTPGridColumn.h:1309
CXTPGridColumn::SetEditable
void SetEditable(BOOL bEditable=TRUE)
Specifies the editable state of items in the column.
Definition XTPGridColumn.h:1531
CXTPGridColumn::m_nAutoNumberingBase
int m_nAutoNumberingBase
Base index for auto-numbering.
Definition XTPGridColumn.h:1270
CXTPGridColumn::IsAllowRemove
BOOL IsAllowRemove() const
Determines if column removing is allowed.
Definition XTPGridColumn.h:1543
CXTPGridColumn::SetShowInFieldChooser
void SetShowInFieldChooser(BOOL bShow)
Specifies if the column header will appear in the field chooser when the column is hidden or in the "...
CXTPGridColumn::m_rcGroupBy
CRect m_rcGroupBy
Saves rectangle where column was drawn in group box.
Definition XTPGridColumn.h:1301
CXTPGridColumn::SetFooterText
void SetFooterText(LPCTSTR strFooter)
Sets the text caption for the column footer.
CXTPGridColumn::m_pMarkupUIElement
CXTPMarkupUIElement * m_pMarkupUIElement
Markup Object.
Definition XTPGridColumn.h:1328
CXTPGridColumn::m_bFilterable
BOOL m_bFilterable
TRUE if filtering by this column is allowed.
Definition XTPGridColumn.h:1280
CXTPGridColumn::GetMaxWidth
int GetMaxWidth() const
Gets the maximal width of the column.
CXTPGridColumn::m_bAutoSize
BOOL m_bAutoSize
TRUE if column auto-sized.
Definition XTPGridColumn.h:1316
CXTPGridColumn::m_bAutoNumbering
BOOL m_bAutoNumbering
Enables auto-numbering.
Definition XTPGridColumn.h:1269
CXTPGridColumn::m_bPlusMinus
BOOL m_bPlusMinus
Determines if the column have Expand / Collapse right icon (+/-).
Definition XTPGridColumn.h:1282
CXTPGridColumn::SetAutoSortWhenGrouped
void SetAutoSortWhenGrouped(BOOL bAutoSortWhenGrouped)
Specifies if the column should be sortable when grouped.
Definition XTPGridColumn.h:1420
CXTPGridColumn::IsAutoSize
BOOL IsAutoSize() const
Gets if the column is automatically sized.
Definition XTPGridColumn.h:1447
CXTPGridColumn::EnableResize
void EnableResize(BOOL bIsResizable)
Sets the resizable state of the column.
Definition XTPGridColumn.h:1390
CXTPGridColumn::SetGroupable
void SetGroupable(BOOL bGroupable)
Sets the groupable state of the column.
Definition XTPGridColumn.h:1502
CXTPGridColumn::IsFrozen
BOOL IsFrozen() const
Determines the frozen state of the column.
Definition XTPGridColumn.h:1466
CXTPGridColumn::SetDrawFooterRowsVGrid
void SetDrawFooterRowsVGrid(BOOL bDrawVGrid=TRUE)
Specifies if the vertical grid will be shown for footer rows.
Definition XTPGridColumn.h:1605
CXTPGridColumn::IsShowInFieldChooser
BOOL IsShowInFieldChooser() const
Determines if the column header will appear in the field chooser when the column is hidden or in the ...
CXTPGridColumn::SetTreeColumn
void SetTreeColumn(BOOL bIsTreeColumn)
Specifies if the column should contain a tree.
CXTPGridColumn::AllowRemove
void AllowRemove(BOOL bAllow)
Specifies if column removing is allowed.
Definition XTPGridColumn.h:1538
CXTPGridColumn::GetCaption
CString GetCaption() const
Gets the text caption of the column header.
Definition XTPGridColumn.h:1365
CXTPGridColumn::~CXTPGridColumn
virtual ~CXTPGridColumn()
Destroys a CXTPGridColumn object, handles cleanup and deallocation.
CXTPGridColumn::IsSortedDecreasing
BOOL IsSortedDecreasing() const
Determines if the column is sorted in decreasing order.
CXTPGridColumn::GetEditOptions
CXTPGridRecordItemEditOptions * GetEditOptions() const
Gets the edit options of the column.
Definition XTPGridColumn.h:1430
CXTPGridColumn::m_chPrompt
TCHAR m_chPrompt
Character used as a space holder for a character.
Definition XTPGridColumn.h:1333
CXTPGridColumn::m_nColumnAutoWidth
int m_nColumnAutoWidth
The column automatic width.
Definition XTPGridColumn.h:1314
CXTPGridColumn::EnsureVisible
virtual void EnsureVisible()
Ensures that this column is visible.
CXTPGridColumn::GetOldVisibleIndex
int GetOldVisibleIndex() const
Gets the old visible index of the column.
CXTPGridColumn::GetPrintWidth
int GetPrintWidth(int nTotalWidth) const
Gets the column print width.
CXTPGridColumn::GetBestFitMode
int GetBestFitMode() const
Gets the column best fit mode.
Definition XTPGridColumn.h:1610
CXTPGridColumn::SetAutoSize
void SetAutoSize(BOOL bSet)
Sets if the column is automatically sized.
Definition XTPGridColumn.h:1442
CXTPGridColumn::GetPrompt
TCHAR GetPrompt() const
Gets character used as a space holder for a character.
Definition XTPGridColumn.h:1635
CXTPGridColumn::GetIconID
int GetIconID() const
Gets the ID of the associated column header icon.
Definition XTPGridColumn.h:1370
CXTPGridColumn::m_bVisible
BOOL m_bVisible
Visible state.
Definition XTPGridColumn.h:1296
CXTPGridColumn::GetMinWidth
int GetMinWidth() const
Gets the minimal width of the column.
CXTPGridColumn::m_bAllowRemove
BOOL m_bAllowRemove
TRUE to allow column remove.
Definition XTPGridColumn.h:1291
CXTPGridColumn::GetColumns
CXTPGridColumns * GetColumns() const
Gets the array of column objects.
CXTPGridColumn::m_nColumnStaticWidth
int m_nColumnStaticWidth
The user defined width.
Definition XTPGridColumn.h:1315
CXTPGridColumn::m_bAutoSortWhenGrouped
BOOL m_bAutoSortWhenGrouped
Column will be sortable when grouped by, otherwise it will grouped without sorting by it (sort by oth...
Definition XTPGridColumn.h:1275
CXTPGridColumn::m_bAllowDrag
BOOL m_bAllowDrag
Allow/disallow dragging of the column.
Definition XTPGridColumn.h:1290
CXTPGridColumn::m_bDrawHeaderDivider
BOOL m_bDrawHeaderDivider
If TRUE, then draw header column right divider.
Definition XTPGridColumn.h:1267
CXTPGridColumn::IsEditable
BOOL IsEditable() const
Determines the editable state of items in the column.
Definition XTPGridColumn.h:1526
CXTPGridColumn::m_nOldVisibleIndex
int m_nOldVisibleIndex
Visible index before Hide state.
Definition XTPGridColumn.h:1297
CXTPGridColumn::m_nBestFitMode
int m_nBestFitMode
Best fit mode.
Definition XTPGridColumn.h:1324
CXTPGridColumn::GetFooterFont
CFont * GetFooterFont()
Gets the font of the column footer.
CXTPGridColumn::m_nFooterAlignment
int m_nFooterAlignment
Alignment mode for column footer text: DT_LEFT || DT_RIGHT || DT_CENTER.
Definition XTPGridColumn.h:1311
CXTPGridColumn::SetSortIncreasing
void SetSortIncreasing(BOOL bSortIncreasing)
Specifies if the column should be sorted in increasing/decreasing order.
Definition XTPGridColumn.h:1425
CXTPGridColumn::SetMask
void SetMask(LPCTSTR strMask, LPCTSTR strLiteral, TCHAR chPrompt=_T('_'))
Applies a specified mask to a CXTPGridColumn data field to create a restrictive field for text entry.
CXTPGridColumn::SetWidth
int SetWidth(int nNewWidth)
Sets the column width.
CXTPGridColumn::CXTPGridColumn
CXTPGridColumn(int nItemIndex, LPCTSTR strName, int nWidth, BOOL bAutoSize=TRUE, int nIconID=XTP_GRID_NOICON, BOOL bSortable=TRUE, BOOL bVisible=TRUE)
Constructs a CXTPGridColumn object.
CXTPGridColumn::GetTooltip
CString GetTooltip() const
Gets the tooltip text of the column header.
Definition XTPGridColumn.h:1550
CXTPGridColumn::m_bDrawFooterDivider
BOOL m_bDrawFooterDivider
If TRUE, then draw footer column right divider.
Definition XTPGridColumn.h:1266
CXTPGridColumn::m_bSortIncreasing
BOOL m_bSortIncreasing
Stores column sort direction (used when m_bSortable is TRUE).
Definition XTPGridColumn.h:1272
CXTPGridColumn::SetDrawHeaderDivider
void SetDrawHeaderDivider(BOOL bSet)
Call this member to set/change is the right column header divider visible.
CXTPGridColumn::SetExpanded
void SetExpanded(BOOL bExpanded)
Sets the expanded state of the column.
CXTPGridColumn::IsHotTracking
BOOL IsHotTracking() const
Determines the highlighted state of the group.
CXTPGridColumn::SetMinWidth
int SetMinWidth(int nMinWidth)
Sets the minimal width for the column.
CXTPGridColumn::SetIconID
void SetIconID(int nIconId)
Sets the ID for the associated column header icon.
Definition XTPGridColumn.h:1375
CXTPGridColumn::GetNextVisualBlock
int GetNextVisualBlock() const
Gets the index of the next visual column.
Definition XTPGridColumn.h:1405
CXTPGridColumn::CXTPGridColumn
CXTPGridColumn(int nItemIndex, LPCTSTR strDisplayName, LPCTSTR strInternalName, int nWidth, BOOL bAutoSize=TRUE, int nIconID=XTP_GRID_NOICON, BOOL bSortable=TRUE, BOOL bVisible=TRUE)
Constructs a CXTPGridColumn object.
CXTPGridColumn::m_bDrawHeaderRowsVGrid
BOOL m_bDrawHeaderRowsVGrid
Indicates whether to draw vertical grid for headers rows.
Definition XTPGridColumn.h:1322
CXTPGridColumn::GetDrawHeaderRowsVGrid
BOOL GetDrawHeaderRowsVGrid() const
Determines if the vertical grid will be shown for header rows.
Definition XTPGridColumn.h:1590
CXTPGridColumn::GetCaptionWidth
int GetCaptionWidth(CDC *pDC)
Calculates the caption width (i.e.
CXTPGridColumn::GetFooterText
CString GetFooterText() const
Gets the text caption of the column footer.
Definition XTPGridColumn.h:1560
CXTPGridColumn::SetAllowDrag
void SetAllowDrag(BOOL bAllowDrag)
Specifies if columns can be dragged with the mouse.
CXTPGridColumn::m_nNextVisualBlock
int m_nNextVisualBlock
Number of next visual columns to show or hide see SetNextVisualBlock(...) and GetNextVisualBlock().
Definition XTPGridColumn.h:1287
CXTPGridColumn::GetIndex
int GetIndex() const
Gets the index of the column.
CXTPGridColumn::m_rcColumn
CRect m_rcColumn
Saves rectangle where column was drawn last time.
Definition XTPGridColumn.h:1300
CXTPGridColumn::GetLiteral
CString GetLiteral() const
Gets string to use as literal.
Definition XTPGridColumn.h:1630
CXTPGridColumn::GetInternalName
CString GetInternalName() const
Gets the internal column name used in serialization to uniquely identify a column rather than a colum...
Definition XTPGridColumn.h:1580
CXTPGridColumn::m_bFixed
BOOL m_bFixed
TRUE if the column is fixed.
Definition XTPGridColumn.h:1278
CXTPGridColumn::IsSortable
BOOL IsSortable() const
Gets the sortable state of the column.
Definition XTPGridColumn.h:1519
CXTPGridColumn::IsGroupable
BOOL IsGroupable() const
Gets the groupable state of the column.
Definition XTPGridColumn.h:1507
CXTPGridColumn::m_nItemIndex
int m_nItemIndex
Index of the associated record item.
Definition XTPGridColumn.h:1257
CXTPGridColumn::SetMaxWidth
int SetMaxWidth(int nMaxWidth)
Sets the maximal width for the column.
CXTPGridColumn::m_bGroupable
BOOL m_bGroupable
TRUE if the column could be grouped by.
Definition XTPGridColumn.h:1274
CXTPGridColumn::GetMarkupUIElement
CXTPMarkupUIElement * GetMarkupUIElement() const
Gets the Markup UI element object.
Definition XTPGridColumn.h:1620
CXTPGridColumn::m_bFrozen
BOOL m_bFrozen
TRUE if the column is frozen (i.e.
Definition XTPGridColumn.h:1279
CXTPGridColumnOrder
Represents the column order, used for sorting and grouping.
Definition XTPGridColumns.h:384
CXTPGridColumns
This class is a collection of grid column objects.
Definition XTPGridColumns.h:54
CXTPGridControl
The CXTPGridControl class provides an implementation of the Grid control.
Definition XTPGridControl.h:479
CXTPGridHeader
A grid header is a part of the grid window positioned above columns of text or numbers.
Definition XTPGridHeader.h:173
CXTPGridRecordItemEditOptions
This class represents edit options for a single item or column.
Definition XTPGridRecordItem.h:443
CXTPGridRow
CXTPGridRow class represents a row of the Grid control window.
Definition XTPGridRow.h:71
CXTPGridRows
This class represents a rows collection class.
Definition XTPGridRows.h:108
CXTPMarkupContext
CXTPMarkupContext is a standalone class used to provide common settings for Markup objects.
Definition XTPMarkupContext.h:128
CXTPMarkupUIElement
Base class for XML Markup core level implementations.
Definition XTPMarkupUIElement.h:43
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72


Toolkit Pro: XTPReBar.h Source File

  • Source
  • CommandBars
XTPReBar.h
Go to the documentation of this file.
1
23#if !defined(__XTPREBAR_H__)
24# define __XTPREBAR_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPToolBar;
34
36# if _MSC_VER < 1200 // MFC 6.0
37
38# ifndef AFX_IDW_REBAR
39# define AFX_IDW_REBAR 0xE804
40# endif
41
42class _XTP_EXT_CLASS CXTPReBarBase : public CControlBar
43{
44 DECLARE_DYNAMIC(CXTPReBarBase)
45
46 // Construction
47public:
48 CXTPReBarBase();
49 BOOL Create(CWnd* pParentWnd, DWORD dwCtrlStyle = RBS_BANDBORDERS,
50 DWORD dwStyle = WS_CHILD | WS_VISIBLE | WS_CLIPSIBLINGS | WS_CLIPCHILDREN
51 | CBRS_TOP,
52 UINT nID = AFX_IDW_REBAR);
53
54 // Attributes
55public:
56 int m_iComCtlVersion;
57
58 // Operations
59public:
60 BOOL AddBar(CWnd* pBar, LPCTSTR pszText = NULL, CBitmap* pbmp = NULL,
61 DWORD dwStyle = RBBS_GRIPPERALWAYS | RBBS_FIXEDBMP);
62 BOOL AddBar(CWnd* pBar, COLORREF clrFore, COLORREF clrBack, LPCTSTR pszText = NULL,
63 DWORD dwStyle = RBBS_GRIPPERALWAYS);
64
65 // Implementation
66 virtual void OnUpdateCmdUI(CFrameWnd* pTarget, BOOL bDisableIfNoHndler);
67 virtual INT_PTR OnToolHitTest(CPoint point, TOOLINFO* pTI) const;
68 virtual CSize CalcFixedLayout(BOOL bStretch, BOOL bHorz);
69 virtual CSize CalcDynamicLayout(int nLength, DWORD nMode);
70# ifdef _DEBUG
71 void EnableDocking(DWORD dwDockStyle);
72# endif
73
74protected:
75 virtual LRESULT WindowProc(UINT message, WPARAM wParam, LPARAM lParam);
76 BOOL _AddBar(CWnd* pBar, REBARBANDINFO* pRBBI);
77
78 //{{AFX_MSG(CReBar)
79 afx_msg BOOL OnNcCreate(LPCREATESTRUCT);
80 afx_msg void OnHeightChange(NMHDR* pNMHDR, LRESULT* pResult);
81 afx_msg void OnNcPaint();
82 afx_msg void OnNcCalcSize(BOOL, NCCALCSIZE_PARAMS*);
83 afx_msg LRESULT OnShowBand(WPARAM wParam, LPARAM lParam);
84 afx_msg void OnRecalcParent();
85 //}}AFX_MSG
86 DECLARE_MESSAGE_MAP()
87};
88
89# else
90# define CXTPReBarBase CReBar
91# endif
99class _XTP_EXT_CLASS CXTPReBar : public CXTPReBarBase
100{
102 DECLARE_DYNAMIC(CXTPReBar)
104public:
109 CXTPReBar();
110
115 virtual ~CXTPReBar();
116
117public:
132 BOOL AddToolBar(CXTPToolBar* pToolBar, DWORD dwStyle = RBBS_GRIPPERALWAYS);
133
140 void DeleteToolBar(CXTPToolBar* pToolBar);
141
150 int FindBand(CXTPToolBar* pToolBar);
151
160 CXTPToolBar* GetToolBar(int nBand);
161
169 void LoadState(LPCTSTR lpszProfileName);
170
178 void SaveState(LPCTSTR lpszProfileName);
179
216 BOOL SetBandInfo(UINT uBand, REBARBANDINFO* prbbi);
217
218protected:
220 DECLARE_MESSAGE_MAP()
221
222 //{{AFX_MSG(CXTPReBar)
223 void OnChildSize(NMHDR* pNotifyStruct, LRESULT* result);
224 void OnPaint();
225 BOOL OnEraseBkgnd(CDC* pDC);
226 virtual CSize CalcFixedLayout(BOOL bStretch, BOOL bHorz);
227 //}}AFX_MSG
228
231private:
232 static const LPCTSTR m_lpszStateInfoEntry;
233 static const LPCTSTR m_lpszStateInfoFormat;
234};
235
236AFX_INLINE BOOL CXTPReBar::SetBandInfo(UINT uBand, REBARBANDINFO* prbbi)
237{
238 return (BOOL)DefWindowProc(RB_SETBANDINFO, uBand, (LPARAM)prbbi);
239}
241
243# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
244#endif // !defined(__XTPREBAR_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPReBar
The CXTPReBar object extends the standard MFC CReBar class to provide extended functionality such as ...
Definition XTPReBar.h:100
CXTPReBar::LoadState
void LoadState(LPCTSTR lpszProfileName)
Retrieves state information from the registry.
CXTPReBar::SaveState
void SaveState(LPCTSTR lpszProfileName)
Saves state information to the registry.
CXTPReBar::CXTPReBar
CXTPReBar()
Constructs a CXTPReBar object.
CXTPReBar::~CXTPReBar
virtual ~CXTPReBar()
Destroys a CXTPReBar object, handles cleanup and deallocation.
CXTPReBar::DeleteToolBar
void DeleteToolBar(CXTPToolBar *pToolBar)
Call this member to remove a toolbar within the rebar.
CXTPReBar::GetToolBar
CXTPToolBar * GetToolBar(int nBand)
Call this member to retrieve a pointer to the toolbar contained in the band with the specified ID.
CXTPReBar::FindBand
int FindBand(CXTPToolBar *pToolBar)
Call this member to locate the band that contains a toolbar.
CXTPReBar::AddToolBar
BOOL AddToolBar(CXTPToolBar *pToolBar, DWORD dwStyle=RBBS_GRIPPERALWAYS)
Call this member to add a band to the rebar.
CXTPToolBar
CXTPToolBar is a CXTPCommandBar derived class.
Definition XTPToolBar.h:42


Toolkit Pro: Member List

CXTPDockingPanePanelThemeNativeWindows10 Member List

This is the complete list of members for CXTPDockingPanePanelThemeNativeWindows10, including all inherited members.

AdjustClientRect(CXTPTabManager *pTabManager, CRect &rcClient) | CXTPTabPaintManagerTheme | virtual
CXTPDockingPanePanelTheme2012() | CXTPDockingPanePanelTheme2012 |
CXTPDockingPanePanelThemeNativeWindows10() | CXTPDockingPanePanelThemeNativeWindows10 |
CXTPTabPaintManagerTheme() | CXTPTabPaintManagerTheme |
CXTPTabThemeFlat() | CXTPTabThemeFlat | inline
DrawSingleButton(CDC *pDC, CXTPTabManagerItem *pItem) | CXTPDockingPanePanelTheme2012 | virtual
DrawTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl) | CXTPTabPaintManagerTheme | virtual
DrawText(CDC *pDC, CXTPTabManager *pManager, const CString &str, LPRECT lpRect, UINT nFormat) | CXTPTabPaintManagerTheme | virtual
DrawWorkspacePart(CDC *pDC, LPRECT lpRect, XTPTabWorkspacePart workspacePart) | CXTPTabPaintManagerTheme | virtual
FillButton(CDC *pDC, CXTPTabManagerItem *pItem, LPPOINT pts, int nCount, XTPTabPosition tabPosition, BOOL bAbsolute=FALSE) | CXTPTabPaintManagerTheme |
FillTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl) | CXTPTabThemeFlat | virtual
GetButtonDrawRect(const CXTPTabManagerItem *pItem) | CXTPTabPaintManagerTheme | virtual
GetButtonHeight(const CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetButtonLength(CDC *pDC, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerTheme | virtual
GetClientMargin() | CXTPTabPaintManagerTheme | virtual
GetClientRect(CRect rcControl, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetColorSet() const | CXTPTabPaintManagerTheme |
GetDefaultColorSet() | CXTPTabThemeFlat | inlinevirtual
GetHeaderClipBox(CDC *pDC, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetHeaderHeight(CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme |
GetHeaderMargin() | CXTPTabPaintManagerTheme | virtual
GetHeaderRect(CRect rcControl, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetSupportedColorSets() | CXTPTabPaintManagerTheme | inlinevirtual
m_bButtonsReverseZOrder | CXTPTabPaintManagerTheme | protected
m_nButtonHeight | CXTPTabPaintManagerTheme | protected
m_nGripperWidth | CXTPDockingPanePanelTheme2012 | protected
m_nRowMargin | CXTPTabPaintManagerTheme |
m_pPaintManager | CXTPTabPaintManagerTheme | protected
m_rcHeaderMargin | CXTPTabPaintManagerTheme |
RefreshMetrics() | CXTPDockingPanePanelTheme2012 | virtual
RepositionTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcClient) | CXTPTabPaintManagerTheme | virtual
~CXTPTabPaintManagerTheme() | CXTPTabPaintManagerTheme | virtual